ルーティングとスイッチングの検証方法

IxNetwork
+ IxNetwork

ルーティング、収束、およびフォワーディングテスト

エンジニアは、被試験デバイスの周囲に再現可能なプロトコル・トポロジーを構築し、定義された条件下でコントロールプレーンとデータプレーンの両方を動作させることで、ルーティングおよびスイッチングの動作を検証できます。まず、Intermediate System to Intermediate System (IS-IS)、Open Shortest Path First (OSPF)、Enhanced Interior Gateway Routing Protocol (EIGRP)、Routing Information Protocol (RIP)、Border Gateway Protocol (BGP)などのプロトコルを使用して、ルーティングネイバーのエミュレート、プロトコルセッションの確立、および制御されたルートセットの広告を行います。次に、学習されたパス全体でフォワーディングトラフィックを生成し、ルートスケール、トラフィックミックス、およびプロトコルアクティビティを変化させてターゲットネットワーク環境を再現します。また、エンジニアは、双方向フォワーディング検出 (BFD)、ルートフラップ、セッション変更、および再起動イベントを導入して、再現可能な収束シナリオを作成することもできます。

各実行中、エンジニアは、エミュレートされたネットワークをアクティブに保ったまま、プロトコル状態、ルート数、収束動作、スループット、レイテンシ、ジッター、およびパケット結果を追跡できます。IPv4とIPv6のトラフィックを組み合わせたり、複数のプロトコルを同時に実行したり、ルートやトラフィックのスケールを拡大したりして、ネットワークの複雑さが増すにつれてデバイスがどのように応答するかを評価できます。また、再現可能なフォワーディングまたはマルチキャスト性能測定が必要なワークフローでは、RFC 2544、RFC 2889、RFC 3918テストなどの標準化されたベンチマーク手法を適用することもできます。実行間でトポロジー、ルートスケール、トラフィックロード、障害イベント、および合格基準を一致させることで、チームは同じルーティングおよびスイッチング条件下でソフトウェアの改訂、構成、およびハードウェアの変更を比較できます。

ルーティングおよびスイッチング検証ソリューション

被試験デバイスの周囲にプロトコルエミュレーションを構成し、ルーティングセッションの確立、制御されたルートの広告、およびフォワーディングトラフィックの生成を行いながら、コントロールプレーンおよびデータプレーンの測定値を収集します。キースサイトのIxNetworkは、IS-IS、OSPF、EIGRP、RIP、Internal Border Gateway Protocol (IBGP)、External Border Gateway Protocol (EBGP)などのルーティングおよびスイッチングプロトコルを大規模にエミュレートし、選択されたアンカーアセットに記載されている大規模なルート広告や実際のインターネットルーティングテーブルのインポートをサポートします。エンジニアは、双方向フォワーディング検出 (BFD)、ルートまたはセッションフラッピング、および再起動シーケンスを追加して障害検出と収束動作を検証し、IPv4およびIPv6のプロトコルバリアントと回線レートトラフィックを同時に動作させることができます。また、IxNetworkは、RFC 2544、RFC 2889、RFC 3918 QuickTestsなどの標準化されたベンチマークワークフローもサポートしています。エンジニアは、得られたプロトコル状態、ルートスケール、収束時間、スループット、レイテンシ、ジッター、およびパケット測定値を使用して、再現可能なテスト条件間でルーティングおよびスイッチング性能を比較できます。

ルーティングおよびスイッチング検証ソリューションのデモ動画を見る

ルーティングおよびスイッチング検証ソリューションの製品を探索する

関連するユースケース

お問い合わせ ロゴ

当社のエキスパートにお問い合わせください。

所望のソリューションを見つけるのにお困りですか?