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SAS-2 Electrical Compliance Test Application—At a Glance

The N5412B automated test application for SAS- 2 (Serial Attached SCSI) 
provides a framework for using Agilent 90000 Series Infiniium 
oscilloscopes to perform compliance testing. The automated test 
application guides you through the process of identifying the test 
environment, selecting and configuring tests, making oscilloscope 
connections, running tests, and evaluating the test results.

To use the automated test application, see:

• Chapter 1, “Installing the SAS- 2 Electrical Compliance Test 
Application,” starting on page 7

• Chapter 2, “Preparing to Take Measurements,” starting on page 11

• Chapter 3, “Using the Electrical Compliance Test Application,” starting 
on page 15

For advanced features, see:

• Chapter 4, “User Defined Add- Ins,” starting on page 57

• Chapter 5, “Controlling the Application via a Remote PC,” starting on 
page 63

See Also For more information on performing SAS- 2 compliance tests, see:

• "SAS- 2 6Gbps Physical Layer Test Suite".

• "INCITS Technical Committee T10 web site".

For a printable version of this help file, see: "Agilent N5412B SAS- 2 
Electrical Compliance Test Application Online Help".

http://www.iol.unh.edu/services/testing/sas/testsuites/
http://www.t10.org/
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Installing the SAS-2 Electrical 
Compliance Test Application

Installing the Software 8

Installing the License Key 9

If you purchased the N5412B SAS- 2 Electrical Compliance Test application 
separately from your oscilloscope, you need to install the software and 
license key.
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1 Installing the SAS-2 Electrical Compliance Test Application
 

Installing the Software

1 Make sure you have the required version of Infiniium oscilloscope 
software:

a See the compliance test application release notes for the required 
minimum version of software.

b To check the software version on the oscilloscope, choose Help>About 
Infiniium... from the main menu

2 Download the N5412B SAS- 2 Electrical Compliance Test application 
from the Agilent website:

a Go to "http://www.agilent.com/find/scope- apps- sw", and navigate to 
the N5412B SAS- 2 Electrical Compliance Test application software 
download.

b Then, follow the instructions to download and install the application 
software.

http://www.agilent.com/find/scope-apps-sw
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Installing the License Key

1 Request a license code from Agilent by following the instructions on the 
Entitlement Certificate.

You will need the oscillocope's "Option ID Number", which you can find 
in the Help>About Infiniium... dialog.

2 After you receive your license code from Agilent, choose Utilities>Install 
Option License....

3 In the Install Option License dialog, enter your license code and click 
Install License.

4 Click OK in the dialog that tells you to restart the Infiniium oscilloscope 
application software to complete the license installation.

5 Click Close to close the Install Option License dialog.

6 Choose File>Exit.

7 Restart the Infiniium oscilloscope application software to complete the 
license installation.
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1 Installing the SAS-2 Electrical Compliance Test Application
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Preparing to Take Measurements

Required Equipment and Software 12

Calibrating the Oscilloscope 13

Running the Automated Test Application on a Second Monitor 75

Before running the automated tests, you need to acquire the required 
equipment and software, and you should calibrate the oscilloscope. After 
the oscilloscope has been calibrated, you are ready to start the SAS- 2 
Electrical Compliance Test application and perform measurements.
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2 Preparing to Take Measurements
 

Required Equipment and Software

In order to run the SAS- 2 Electrical Compliance Test application, you 
need the following equipment and software:

• The minimum version of Infiniium oscilloscope software described in 
the compliance test application's release notes.

• The equipment and software listed in the data sheet's "Ordering 
Information" section (see "N5412B Serial Attached SCSI (SAS- 2) 
Electrical Performance Validation and Compliance Software Data 
Sheet").

Licenses are also required for these software options:

• N5400A EZJIT Plus Jitter Analysis Software Option.

• E2688A Serial Data Analysis/Mask Testing with Clock Recovery 
Software Option.

• Agilent also recommends using a second monitor (see page 75) to view 
the automated test application.

• Before performing tests, calibrate the oscilloscope (see page 13).

http://cp.literature.agilent.com/litweb/pdf/5989-4208EN.pdf
http://cp.literature.agilent.com/litweb/pdf/5989-4208EN.pdf
http://cp.literature.agilent.com/litweb/pdf/5989-4208EN.pdf
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Calibrating the Oscilloscope

If you have not already calibrated the oscilloscope, see Appendix A, 
“Calibrating the Oscilloscope,” starting on page 69.

NOTE If the ambient temperature changes more than 5 degrees Celsius from the calibration 
temperature, internal calibration should be performed again. The delta between the 
calibration temperature and the present operating temperature is shown in the 
Utilities>Calibration menu.

NOTE If you switch cables between channels or other oscilloscopes, it is necessary to perform 
cable and probe calibration again. Agilent recommends that, once calibration is performed, 
you label the cables with the channel for which they were calibrated.
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2 Preparing to Take Measurements
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Using the Electrical Compliance Test 
Application

Starting the SAS-2 Electrical Compliance Test Application 16

Creating or Opening a Test Project 19

Setting Up the Test Environment 20

Selecting Tests 25

Configuring Tests 27

Connecting the Oscilloscope to the DUT 29

Running Tests 30

Viewing Results 39

Viewing/Exporting/Printing the Report 50

Saving Test Projects 54

This chapter shows how to use the SAS- 2 Electrical Compliance Test 
application.
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3 Using the Electrical Compliance Test Application
 

Starting the SAS-2 Electrical Compliance Test Application

1 From the Infiniium oscilloscope's main menu, choose Analyze>Automated 
Test Apps>SAS-2 Test.

The SAS- 2 Electrical Compliance Test application window appears.

The task flow pane and the tabs in the main pane, show the steps you 
take when running the automated tests:

NOTE If SAS-2 Test does not appear in the Automated Test Apps menu, the SAS-2 Electrical 
Compliance Test application has not been installed (see Chapter 1, “Installing the SAS-2 
Electrical Compliance Test Application,” starting on page 7).
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See Also • "To view/minimize the task flow pane" on page 17

• "To view/hide the toolbar" on page 18

Next • "Creating or Opening a Test Project" on page 19

To view/minimize the task flow pane

• To toggle between a minimized and restored task flow pane, choose 
View>Task Flow from the menu.

• To minimize the task flow pane, click the minimize button in the pane.

• To restore a minimized task flow pane, click the Task Flow button in the 
pane.

Set Up Lets you identify the test environment.

Select Tests Lets you select the tests you want to run. The tests are organized 
hierarchically so you can select all tests in a group. After tests are run, 
status indicators show which tests have passed, failed, or not been run, 
and there are indicators for the test groups.

Configure Lets you configure the test parameters (for example, stimulus 
frequency).

Connect Shows you how to connect the oscilloscope to the device under test for 
the tests that are to be run.

Run Tests Starts the automated tests. If the connections to the device under test 
need to be changed while multiple tests are running, the tests pause, 
show you how to change the connection, and wait for you to confirm 
that the connections have been changed before continuing.

Results Contains more detailed information about the tests that have been run. 
You can change the thresholds at which marginal or critical warnings 
appear.

Html Report Shows a compliance test report that can be printed.
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3 Using the Electrical Compliance Test Application
 

To view/hide the toolbar

• To toggle between a hidden and visible toolbar, choose View>Toolbar 
from the menu.
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Creating or Opening a Test Project

To create a new test project:

1 Choose File>New Project... from the menu.

A new, empty project, with all the default settings is created.

To open an existing test project:

1 Choose File>Open Project... from the menu.

2 In the Open dialog, browse to a test project directory and select the 
desired ".proj" file.

3 Click Open.

See Also • "To set load preferences" on page 19

Next • "Setting Up the Test Environment" on page 20

To set load preferences

1 From the SAS- 2 Electrical Compliance Test application's menu, choose 
View>Preferences....

2 In the Preferences dialog, select the Save/Load tab.

3 In the Save/Load tab, you can choose to restore saved test selections 
when loading a project.

4 Click Apply to save the changes and click OK to close the Preferences 
dialog.



20 Agilent N5412B SAS-2 Electrical Compliance Test Application Online Help

3 Using the Electrical Compliance Test Application
 

Setting Up the Test Environment

1 Click the Set Up tab, or click the Set Up box in the Task Flow pane.

2 Select the appropriate Device Test Point:

• IT— Intra- Enclosure (in other words, internal). The signal is from a 
transmitter device as measured at probe points in a test load 
attached with an internal connector.

• CT— Inter- Enclosure (in other words, cabinet). The signal is from a 
transmitter device, as measured at probe points in a test load 
attached with an external connector.

3 Select the appropriate Bit Rate (Gbps)which identifies a 1.5, 3.0, or 
6.0 Gbps rate.

4 Select the appropriate Device Typewhich identifies a drive or host device.

5 Select the appropriateSSCSpread:

• None — for a device that does not support SSC (NRZ test only).

• SAS-SASDown — for SAS PHY that can turn on SASSASDown in 
addition to turning off SSC (SSC on and other NRZ test).

• SAS-SASCenter — for SAS PHY that can turn on SASSASCenter in 
addition to turning off SSC (SSC on and other NRZ test).

• SAS-SATADown — for expander PHY that can turn on SASSATADown 
in addition to turning off SSC (SSC on and other NRZ test).



Using the Electrical Compliance Test Application 3

Agilent N5412B SAS-2 Electrical Compliance Test Application Online Help 21

 

6 Select or type the appropriateDevice Identifier andUser Description, and 
enter any desiredComments.

7 If an 81134A pulse pattern generator is required (for example, when 
the DUT is not able to transmit an OOB signal upon power up and a 
pulse generator is required to perform OOB signal simulation):

a Select Yes under "Using Stimulus".

b To enter the pulse pattern generator's network address, click 
Configure Devices....

c In the Configure Devices dialog, enter the pulse pattern generator's 
IP Address or SICL Address.

d Click Get IDN... to verify the pulse pattern generator's network 
address.

e Click OK to close the verification message dialog.

f Click Close to close the Configure Devices dialog.

The automated test application will set up and control the pulse pattern 
generator over the network.

8 Select the appropriate Test Pattern Source:

NOTE These steps assume the oscilloscope and pulse pattern generator are already networked so 
that the oscilloscope can remotely control the pulse pattern generator (over LAN, GPIB, 
etc.). For more information, see the instruments' documentation.
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3 Using the Electrical Compliance Test Application
 

• BIST_T — is a test mode that is partially automated for acquiring the 
test patterns for the TX Spread Spectrum Clocking and TX NRZ Data Signaling 
Requirements group, where during setup, all the test patterns of the 
selected waveforms are acquired before the actual tests are run. 
During the waveform acquisition setup:

• First, put the device under test (DUT) into BIST- T (Transmit) 
mode.

• The application will pop up a message box every time to ask you 
to command the DUT to output a required test pattern.

• Before the application proceeds, it will set up a simple 
oscilloscope screen preview for you to confirm whether the DUT is 
in BIST- T mode .

• BIST_L — is a test mode that is fully automated for acquiring the test 
patterns for the TX Spread Spectrum Clocking and TX NRZ Data Signaling 
Requirements group, where during setup, all the test patterns of the 
selected waveforms are acquired before the actual tests are run. 
During the waveform acquisition setup:

• First, put the device under test into (DUT) into BIST- L 
(Loopback) mode.

• The application will set up a simple oscilloscope screen preview 
for you to confirm whether the DUT is in BIST- L mode.

• The application will send the respective stimulus pattern for the 
DUT to echo back the correct pattern (without you having to send 
commands to the DUT).

• Please note that there is no specification documentation on how 
the BIST- L test pattern source should be implemented, and it is 
experimental for the application at this stage. Some other setup 
tweaking like adjusting the stimulus data rate in the Config tab 
may be needed.

• SavedWFM — lets you run from saved waveform (WFM format) files 
for non- OOB tests, that is, tests in the All Tests in TX Spread Spectrum 
Clocking and NRZ Data Signaling Requirements group.

When SavedWFM is selected, enter the saved waveform location in the 
Use Saved Waveform(WFM) or click LoadWFM to browse to the saved 
waveform location.

When SavedWFM is selected, the Using Stimulus selection is ignored.

See "Running Non- OOB Tests From a Saved Waveform" on page 23.

9 To specify the InfiniiSim settings, click InfiniiSim. Use the Configure 
InfiniiSim dialog to specify the desired settings.

For more information on InfiniiSim options and settings, see the Agilent 
Infiniium Oscilloscope application's main online help.
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Next • "Selecting Tests" on page 25

Running Non-OOB Tests From a Saved Waveform

This feature allows the user to run from saved waveform (WFM format) 
files for non- OOB tests. See:

• "Peparing WFM Files" on page 23

• "Loading a WFM File and Running Tests" on page 23

Peparing WFM Files

How to prepare the WFM files:

1 Select the desired tests to be run.

2 For example:

• In the Set Up tab, select Bit Rate = 6.0 Gbps and SSCSpread = None,

• In the Select Tests tab, select the All Tests in TX Spread Spectrum Clocking 
and NRZ Data Signaling Requirements test group.

3 Using the above selected tests matrix example, after all the tests run 
successfully, the WFM files generated would be:

• CM_CJTPAT_6.0_SSCOff_4E6_40E9.wfm

• DIFF_D30.3_6.0_SSCOff_4E6_40E9.wfm

• DIFF_HFTP_6.0_SSCOff_4E6_40E9.wfm

• DIFF_MFTP_6.0_SSCOff_4E6_40E9.wfm

4 These files are temporarily available at:

C:\Documents and Settings\All Users\Application Data\Agilent\
Infiniium\Apps\SAS- 2Test\Project\app\SaveWFMDir

until the current project becomes inactive.

5 Because .wfm files are saved with a project, save the project to a 
desired location. Later, you can find the saved waveforms at:

[PROJECT DIRECTORY]\app\SaveWFMDir

Loading a WFM File and Running Tests

How to load back the WFM files:

1 In the Set Up tab, under Test Pattern Source, select the Saved WFM 
option.

This can be done either with Using Stimulus = Yes or No — they achieve 
the same purpose.

2 When Saved WFM is selected, the Load WFM button is enabled.
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3 Select the folder that stores the WFM files of the desired test to be run 
with the valid file name and data.

4 Using the above example, locate the WFM directory where all four files 
are located.

5 Then:

• In the Set Up tab, select Bit Rate = 6.0 Gbps and SSCSpread = None,

• In the Select Tests tab, select the All Tests in TX Spread Spectrum Clocking 
and NRZ Data Signaling Requirements test group.

Now, you can run the non- OOB tests using the saved waveforms.
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Selecting Tests

1 Click the Select Tests tab, or click the Select Tests box in the Task Flow 
pane.

2 Check the tests you want to run.

Some things to note:

• Checking a parent node/group will check all available 
sub- groups/tests.

• Unchecking a parent node/group will uncheck all sub- groups/tests.

• A parent node is checked if all subgroups are checked.

• A parent node is unchecked if ANY subgroup is unchecked.

Using the
Right-Click

Pop-Up Menu

When you right- click in the test pane, it produces a pop- up menu 
containing some shortcuts for selecting and deselecting tests.

NOTE If a test has a non-range limit of 0, that is, value < 0, then the test application will provide a 
nominal value. This nominal value produces a non-infinite margin and is used to declare the 
100% margin point. The assigned nominal value can be viewed at the description pane.
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When Tests Have
Already Been Run

If tests have already been run, you see their status in the Select Tests tab.

The marks have the following meanings:

Next • "Configuring Tests" on page 27

The test passed.

The test failed.

The test has not been run, or no tests in the group have been run.

The test is currently running.

Some tests in the group have run and passed.

Some tests in the group have run and failed.

Some tests in the group have passed and some have failed; not all of the tests have 
been run.

Some tests in the group have passed and some have failed; all of the tests have run.

All tests in the group have run and passed.

All tests in the group have run and failed.
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Configuring Tests

1 Click the Configure tab, or click the Configure box in the Task Flow pane.

2 Select either Compliance Mode or Debug Mode.

• Compliance Mode — chooses the configuration options necessary to 
meet compliance.

• Debug Mode — lets you modify configuration options. This can be 
useful, for example, when investigating a test failure.

3 Select the bulleted item for the settings you want to configure; then, 
select or enter your settings.

A description of the selected configuration item appears in the lower, 
right part of the application window.

Note that you can also enter values in some of the drop- down selection 
fields. Entered values are checked for validity.

TIP A quick way to see the Debug Mode configuration option values that are used in the 
Compliance Mode is to switch from Compliance Mode to Debug Mode.

TIP A quick way to reset all configuration options is to switch from Debug Mode to Compliance 
Mode.
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Next • "Connecting the Oscilloscope to the DUT" on page 29

TIP A quick way to reset all configuration options and delete all test results is to create a new 
project (see page 19). The new project will have default configuration options.
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Connecting the Oscilloscope to the DUT

1 Click the Connect tab, or click the Connect box in the Task Flow pane.

2 Follow the displayed instructions for connecting the oscilloscope to the 
device under test.

3 When connections to the device under test have been made, check the I 
have completed these instructions box.

Next • "Running Tests" on page 30
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Running Tests

The Run Tests tab's settings let you run the selected tests once or multiple 
times. When you run tests multiple times, there are options for selecting 
which trials are stored and how long tests are run.

To run the selected tests once:

1 Start the test run.

There are several ways to run selected tests:

• Click Run Tests in the Task Flow pane.

• Click  in the toolbar.

• Select a branch in the Select Tests tab; then, click  in the toolbar.

• Select the Run Tests tab, make sure the Once "run until" option is 
selected, and click the big Run button.

NOTE You should allow the oscilloscope to warm-up at least 30 minutes before running any 
measurement tests.

TIP It is a good idea to calibrate the oscilloscope at least once a year or when the Calibration 
Temp is greater than ±5 C. The Calibration Temp is found in the Help>About Infiniium... 
menu on the Infiniium oscilloscope.
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For more information on additional run options, see:

• "To select the "store mode"" on page 32

• "To run multiple times" on page 33

• "To send email on pauses or stops" on page 34

• "To pause or stop on events" on page 34

• "To specify the event" on page 35

2 If there are existing test results, you are asked if you would like to keep 
them or re- test (delete) them.

If you would like to keep the existing test results to compare against 
new results, select Append New "Trial" Results.

Select Replace the Existing Results if you would like to delete the existing 
test results.

3 While the tests are running, status dialogs appear to inform you about 
the test progress.
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4 When the tests are complete, click OK.

See Also • "To set the display preferences" on page 36

• "To set the run preferences" on page 37

Next • "Viewing Results" on page 39

To select the "store mode"

When running tests multiple times, you can select which trials are stored.

1 Select the Run Tests tab.

2 In the Store Mode area, select:

• Best — stores the results of the best N trials.

• Event — stores the results of N trials in which the event is detected. 
The event is determined in the Event area. See "To specify the event" 
on page 35.
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• Last — stores the results of the last N trials.

• Worst — stores the results of the worst N trials.

Up to 25 trials can be stored.

If you change the Store Mode when test results exist, the existing results 
will be deleted.

The Store Mode selection affects the trial display options in the Report tab 
of the Preference dialog. See "To set trial display preferences" on page 48.

To run multiple times

The "run until" option lets you specify whether tests are run once or 
multiple times.

1 Select the Run Tests tab.

2 In the Run Until area, select:

• Forever — runs the tests repeatedly until you click the Cancel button.

• N Times — runs the tests N times. When this option is selected, you 
can specify the number of runs and whether pauses occur between 
each run.

• Once — runs the tests only once. This is the default setting.

When multiple runs are selected, you can use the trial display options in 
the Report tab of the Preference dialog to specify how many trials are 
displayed in the test report. See "To set trial display preferences" on 
page 48.
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To send email on pauses or stops

You can configure the test application to send email whenever a run 
pauses or ends.

1 Select the Run Tests tab.

2 In the Run Until area, check Send email.

3 Click Configure.

4 In the Configure Email dialog, enter your To and From email addresses 
and the hostname of the SMTP Server.

5 Click OK.

Pauses can occur between runs when running a specific number of times 
(see "To run multiple times" on page 33) or when pausing on an event (see 
"To pause or stop on events" on page 34).

To pause or stop on events

You can set up test runs to pause or stop on events which are checked at 
the end of each test.

1 Select the Run Tests tab.

2 In the Run Until area, check On event.

3 In the drop- down selection field that appears, select either:
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• Pause — causes the run to pause when the event is detected.

• Stop — cause the run to stop when the event is detected.

4 In the Event area, specify the type of event. See "To specify the event" 
on page 35.

Pauses or stops can be set up to automatically send email (see "To send 
email on pauses or stops" on page 34).

To specify the event

In the Store Mode area when you have selected Event (see "To select the 
"store mode"" on page 32) or in the Run Until area when you have selected 
to pause or stop on an event (see "To pause or stop on events" on 
page 34), the Event area appears so that you can specify the event.

1 In the Event area, select the type of event:

• Fail — causes the event to fire when a prerequisite test or selected 
test fails.

• Margin < N — causes the event to fire when a test generates a 
margin < specified. When this option is selected, enter the minimum 
required margin percentage.

• Pass — causes the event to fire when a test passes (excluding 
prerequisite tests).
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A tilde "~" character in the event selection drop- down shows that the 
event is unavailable. If you select an event type that is not available, a 
dialog tells you why. For example, the Pass condition is only available 
when the Store Mode is set to Best, Event, or Last. As such, the 
condition appears as ~Pass when the Store Mode is set to Worst.

To set the display preferences

Information, warning, and error conditions can occur while running tests. 
The display preferences let you choose whether message dialogs are 
shown. And, there are other display preferences that affect what happens 
as tests are run.

1 From the SAS- 2 Electrical Compliance Test application's menu, choose 
View>Preferences....

2 In the Preferences dialog, select the Display tab.

3 In the Display tab, you can choose to show the following types of 
message dialogs:

• Information dialogs.

• Warning dialogs.

• Error dialogs.

4 Also, you can choose to:

NOTE Messages that require you to make a choice, such as "OK/Cancel" and "Yes/No" are 
always enabled.
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• Invert scope display — (white background) when the application 
captures the screen shots. Note that no inversion takes place is the 
oscilloscope's ColorGrade is enabled.

• Keep application on top — Always keep the application's main dialog on 
the top of the Infiniium application. Note that the mid- run dialogs 
are always displayed on the top.

• Log events — Use this option only when directed to by Agilent Support 
(Note that this option degrades the runtime performance).

• Show tooltips — By enabling this option, the tooltips appear as you 
move the pointer over various controls in the application.

5 Click Apply to save the changes and click OK to close the Preferences 
dialog.

To set the run preferences

Information, warning, and error conditions can occur while running tests. 
The display preferences let you choose whether message dialogs are 
shown. And, there are other display preferences that affect what happens 
as tests are run.

1 From the SAS- 2 Electrical Compliance Test application's menu, choose 
View>Preferences....

2 In the Preferences dialog, select the Run tab.

3 In the Run tab, specify Prompts settings:

• Beep when user prompted —  causes the oscilloscope to beep when there 
is prompt for user input.

• Beep only during run — specifies that beeps only occur during runs.
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4 Specify Test Abort Action settings:

• Continue the run —  causes tests to continue running after a test 
aborts. When this option is selected, you can view problem 
descriptions after the run ends.

• Stop the run — causes the run to stop after a test aborts, and the 
problem is reported immediately.

Note that these settings do not affect the Stop button.

5 Click Apply to save the changes and click OK to close the Preferences 
dialog.



Using the Electrical Compliance Test Application 3

Agilent N5412B SAS-2 Electrical Compliance Test Application Online Help 39

 

Viewing Results

1 Click  in the toolbar, or click the Results tab.

The Results tab contains three resizable panes for test results 
information. If you select one of the tests in the top pane, details and 
reference images (if any) are shown in the lower panes.

The summary of the test trial is displayed in the bottom left pane. It 
also shows the Worst Trial (depending on your settings in the Store 
Mode of the Run Tests tab).

The bottom right pane may have several tabs, depending on the selected 
Report Preferences. If more than one trial is selected, then the first tab 
will be the Summary tab. It shows the summary of all the test trials. A 
maximum of 25 trials can be displayed at any one time.

If the worst first is selected as the trial display option, the Worst Trial 
will be the next tab after the Summary tab, followed by other trials in 
the order of trial performance.

The reference images will appear in the bottom right pane for the 
selected trials. See "To show reference images and flash mask hits" on 
page 45 for more details on reference images.
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See Also • "To delete trials from the results" on page 40

• "To show reference images and flash mask hits" on page 45

• "To change margin thresholds" on page 46

• "To change the test display order" on page 47

• "To set trial display preferences" on page 48

Next • "Viewing/Exporting/Printing the Report" on page 50

To delete trials from the results

1 In the Results tab, choose one of these ways to delete a trial:

• While a test result entry (at upper pane) or trial tab (at lower pane) 
has input focus, either click on the toolbar 'delete' button or press 
the delete key on the keyboard OR:

TIP A quick way to reset all configuration options and delete all test results is to create a new 
project (see page 19). The new project will have default configuration options.

NOTE If a test has a non-range limit of 0, that is, value < 0, then the test application will provide a 
nominal value. This nominal value produces a non-infinite margin and is used to declare the 
100% margin point. The assigned nominal value can be viewed at the description pane.
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• Another option is to right- click at a test result (at upper pane) and 
select a trial or test to delete OR:

• Right- click inside the display area of trial summary tab (at the lower 
pane):
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2 Select the trial to delete:

3 If other tests have results that were generated during the same trial run 
as the trial you are deleting, you will be asked if you wish to delete 
these tests at the same time.
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4 Once you have selected the trials to delete and clicked OK, you get a 
confirmation dialog:

5 The remaining trials are renumbered downwards to fill in the hole left 
by the deleted trial:

6 If you delete the last remaining trial of a test, the entire test results are 
removed:

NOTE The trial numbers of the affected results may not match. The application presents you with 
those results that were generated during the same run. You can decide to delete those 
other trials as well.
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NOTE: There are two situations in which you are not allowed to delete a trial:
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• Case 1: The trial you attempt to delete is the last remaining extreme 
trial but not the last remaining trial. In the SAS- 2 Electrical Compliance 
Test application, the maximum number of trials displayed is 25. For 
example:

a Let's assume N is 25 (the maximum number of trials displayed).

b You have run more than N trials of a test.

c Now, you can delete up to N- 1, where all these tests are displayed in 
the individual result tabs. You will not be able to delete the last 
remaining test displayed in the individual result tab or other 
non- displayed tests; however, you can delete the entire test.

• Case 2: The trial you attempt to delete is associated with a trial defined 
in Case 1.

To show reference images and flash mask hits

1 In the Results tab, click on an image in the Reference Images pane.

This opens the reference image dialog.
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In the reference image dialog, you can:

• Click the  flash red pixels button to highlight the points of failure.

• Click the  zoom in or  zoom out buttons to resize the dialog.

2 Click the  close button to close the # Mask Failures dialog.

To change margin thresholds

1 From the SAS- 2 Electrical Compliance Test application's menu, choose 
View>Preferences....

Or, when viewing the Results tab, click  in the toolbar.

2 In the Preferences dialog, select the Report tab.
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3 In the Margin Reporting area, you can:

• Enable or disable margin highlighting.

• Change the percent of margin at which to give warnings or critical 
failures.

4 Click OK to save your changes and close the Preferences dialog.

To change the test display order

1 From the SAS- 2 Electrical Compliance Test application's menu, choose 
View>Preferences....

Or, when viewing the Results tab, click  in the toolbar.

2 In the Preferences dialog, select the Report tab.
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3 In the Test Display area, you can:

• Order tests chronologically or use the same ordering as in the Select 
Tests tab.

4 Click OK to save your changes and close the Preferences dialog.

To set trial display preferences

1 From the SAS- 2 Electrical Compliance Test application's menu, choose 
View>Preferences....

Or, when viewing the Results tab, click  in the toolbar.

2 In the Preferences dialog, select the Report tab.
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3 In the Trial Display area, you can:

• Select the maximum number of trials, up to 25, whose details are 
displayed at one time.

• Order trial details chronologically or by "best", "worst", or "last" trial 
first.

• Specify whether screens captured during the run are displayed in the 
Results tab.

Note that the "worst", "best", or "last" trials depends on the "store mode" 
setting in the Run Tests tab. See "To select the "store mode"" on 
page 32.

4 Click Apply to save the changes and click OK to close the Preferences 
dialog.

NOTE These settings only affect the viewing of results and not their capture. Therefore, a change 
can be made to either before or after running the tests.
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Viewing/Exporting/Printing the Report

• To view the HTML test report, click the Html Report tab.

See Also • "To export the report" on page 50

• "To print the report" on page 53

Next • "Saving Test Projects" on page 54

To export the report

1 From the SAS- 2 Electrical Compliance Test application's menu, choose 
File>Export Results> from the menu.

There are two options for exporting the HTML test report: CSV or 
HTML.

To export results
in CSV

(comma-separate
d values) format

Select the CSV option to export the results as a comma- separated list of 
values.
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The data format is shown in the first line of the exported *.csv file.
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To export the
report in HTML

format

There are two options for exporting HTML format test reports:

• Single-File — To save a single- file report, use the "save as" type "Web 
Archive, single file (.mht)".

• Multi-File — If your report is large and you would like to use links 
within the report, select the HTML>Multi-File option. Selecting the 
multi- file option exports the results as a set of separate image and 
HTML files. It creates a folder with the specified name that may be 
copied to any computer.

NOTE Single-file reports will not contain hyperlinks in the summary table (due to a .mht format 
limitation). If you want these hyperlinks, use the multi-file format.
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To view the exported report, open the HTML file stored in the folder.

To print the report

• To preview the HTML test report printout, click  or choose File>Print 
Preview... from the menu.

• To print the HTML test report, click  or choose File>Print... from the 
menu.
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Saving Test Projects

To save test settings and results to the current project directory:

1 Choose File>Save Project from the menu.

To save test settings and results to a new project directory:

1 Choose File>Save Project As... from the menu.

2 In the Save Project As... dialog, enter the device name and location.

Project files will be saved in a directory whose name is the device 
name.

3 Click OK.

See Also • "To set AutoRecovery preferences" on page 54

To set AutoRecovery preferences

1 From the SAS- 2 Electrical Compliance Test application's menu, choose 
View>Preferences....

2 In the Preferences dialog, select the Save/Load tab.
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3 In the AutoRecovery area, you can choose:

• To auto- save results after each trial or permutation even if the entire 
multi- trial is not completed. This option enables full recovery.

• To auto- save results only upon the completion of the entire 
multi- trial.

4 Click Apply to save the changes and click OK to close the Preferences 
dialog.
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User Defined Add-Ins

To install an add-in 58

To remove an add-in 61

If there are measurements you would like the compliance test application 
to make that are not currently included in its test list, you can use 
Agilent's N5467A User Defined Application (UDA) tool to design and 
deploy an "add- in", or package of tests that can be imported into existing 
compliance applications. Please see the UDA documentation for how to 
create an add- in.
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To install an add-in

To install an add- in:

1 Use the File menu:

You will be prompted for the location of the add- in's installer (created 
by the N5467A UDA tool):

and then reminded that the application will need to restart to complete 
the installation:



User Defined Add-Ins 4

Agilent N5412B SAS-2 Electrical Compliance Test Application Online Help 59

 

Restart the application, and you will receive a notice that there is an 
active add- in:

Add- in tests are only visible in Debug Mode, so when there is an active 
add- in installed, the compliance application will start up in this mode.

Add- in tests are displayed in their own test group on the Select Tests tab:

CAUTION If your project has unsaved test results, choose Cancel and save the project before 
retrying.
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To remove an add-in

To remove an add- in:

1 Use the File menu:

You will be reminded that the application will need to restart to 
complete the installation:

CAUTION If your project has unsaved test results, choose Cancel and save the project before 
retrying.
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Controlling the Application via a 
Remote PC

To check for the App Remote license 64

To identify the remote interface version 65

To enable the remote interface 66

To enable remote interface hints 67

If the oscilloscope has the App Remote license option installed (for the 
N5452A remote interface), the SAS- 2 Electrical Compliance Test 
application's Preference dialog will have a Remote tab for enabling the 
remote interface and setting remote options.

The N5452A remote interface lets you control Infiniium compliance 
applications from a remote PC. It comes with ready to run executables, 
but it also lets you create custom programs using a .NET 2.0 programming 
language or the National Instruments' LabVIEW 8.5 graphical programming 
environment.

With the remote interface, you can:

• Launch and close applications.

• Configure options.

• Run tests.

• Obtain results.

• Control when and where dialogs are displayed.

• Save and load projects.

For more information on the remote interface, see the "N5452A Remote 
Interface for Infiniium Compliance Applications" on the Agilent web site.

http://www.home.agilent.com/agilent/redirector.jspx?action=ref&cname=PRODUCT&ckey=1439856&cc=US&lc=eng
http://www.home.agilent.com/agilent/redirector.jspx?action=ref&cname=PRODUCT&ckey=1439856&cc=US&lc=eng
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To check for the App Remote license

1 From the Infiniium oscilloscope's main menu, choose Help>About 
Infiniium.

2 In the license list, check for the App Remote license as shown below.
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To identify the remote interface version

1 From the SAS- 2 Electrical Compliance Test application's menu, choose 
Help>About....

2 In the About dialog, the remote interface version is listed above other 
version information.
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To enable the remote interface

1 From the SAS- 2 Electrical Compliance Test application's menu, choose 
View>Preferences....

2 In the Preferences dialog, select the Remote tab.

3 Check the Enable remote interface option if you need to access the 
application remotely.

If you are performing the tests with the application's user interface and 
want to ensure no remote users accidentally interfere with you, disable 
the remote interface by un- checking this option.

4 Click Apply to save the changes and click OK to close the Preferences 
dialog.
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To enable remote interface hints

1 From the SAS- 2 Electrical Compliance Test application's menu, choose 
View>Preferences....

2 In the Preferences dialog, select the Remote tab.

3 In the remote options area, check Show remote interface hints.

When this option is checked:

• You can select the remote programming language described in the 
tips.

• Tooltips related to the remote interface commands appear when you 
click the toolbar.

• Various controls in the tabs will have a context menu item added as 
"Remote interface hint…".

• The Select Tests and Configure tabs will display a remote hint in their 
description panes at the bottom of the screen, when an item is 
selected.

4 Click Apply to save the changes and click OK to close the Preferences 
dialog.
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Channel-to-Channel De-skew 70

This section describes oscilloscope calibration procedures.



70 Agilent N5412B SAS-2 Electrical Compliance Test Application Online Help

A Calibrating the Oscilloscope
 

Channel-to-Channel De-skew

This procedure ensures that the timing skew errors between channel 1 and 
channel 3 are minimized. In addition to the required equipment, you need:

• SMA T- adapter.

• Additional BNC to SMA male adapter (two precision 3.5 mm BNC to 
SMA male adapters are provided with the oscilloscope).

To perform the channel- to- channel de- skew:

1 Connect the Channel 1 and Channel 3 SMA cables to the oscilloscope's 
Aux Out:

a Leave the RG- 316 cables and SMA adapters on Channel 1 and 
Channel 3.

b Install a BNC to SMA male adapter on the oscilloscope Aux Out.

c Connect the middle branch of the SMA T- adapter to the SMA 
adapter on the Aux Out BNC.

d Connect the far end of the cable from the Channel 1 SMA adapter, to 
one branch of the SMA T- adapter on the Aux Out.

e Connect the far end of the cable from the Channel 3 SMA adapter, to 
the other branch of the SMA T- adapter on the Aux Out.

2 Set up the oscilloscope:

a From the oscilloscope's main menu, choose File>Load>Setup....

b In the Load Setup dialog, select the "INF_SMA_Deskew.set" setup file, 
and click Load.
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If the setup file is not available, it can be created by following the 
instructions in "INF_SMA_Deskew.set Setup File Details" on page 73.

3 Observe the channel- to- channel skew.

The oscilloscope display should look similar to the picture below. A 
falling edge of the square wave is shown in a 200 ps/div horizontal 
scale. The upper portion of the screen shows channel 1 (yellow trace) 
and channel 3 (purple trace) superimposed on one another. The lower 
portion of the screen is the differential signal (green trace) of channel 1 
minus channel 3. The top two traces provide for visual inspection of 
relative time skew between the two channels. The bottom trace provides 
for visual presentation of unwanted differential mode signal resulted 
from relative channel skew (and to a much lesser extent from other 
inevitable channel mismatch parameters like gain and non- linearity). 
The picture below is an example of exaggerated skew between channel 1 
and channel 3, measured to be about 50 ps with the cursor.
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The following picture shows the desired effect of no skew between the 
cables. Note that the channel 1 (yellow trace), channel 3 (purple trace) 
traces overlap, and the differential signal (green trace) is flat. If this is 
not the case, then perform the following steps to reduce the skew 
between channels 1 and 3.
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4 De- skew the channels:

a Choose Setup>Channel 1....

b Move the Channel Setup dialog to the left so you can see the traces.

c Adjust the Skew (by clicking on the < or > arrows) to achieve the 
flattest response on the differential signal (green trace).

d Click Close to close the Channel Setup dialog.

5 Disconnect the cables from the T- adapter on the Aux Out BNC. Leave 
the cables connected to the Channel 1 and Channel 3 inputs.

INF_SMA_Deskew.set Setup File Details

If the INF_SMA_Deskew.set file is not available, you can create it by 
following these instructions.

1 Start from a default setup by pressing the Default Setup key on the 
front panel. Then, configure the following settings:

NOTE Each cable is now calibrated for the oscilloscope channel it is connected to. Do not switch 
cables between channels or other oscilloscopes, or it will be necessary to calibrate them 
again. It is recommended that the cables be labeled with the channel they were calibrated 
for.

Acquisition: Averaging on, number of averages 16, Interpolation on.

Channel 1: Scale 100.0 mV/, Offset &#8722;350 mV, Coupling DC, Impedance 50 Ohms.
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2 From the oscilloscope's main menu, choose File>Save>Setup..., enter the 
file name "INF_SMA_Deskew.set", and click Save.

Channel 3: Turn Channel On; Scale 100.0 mV/, Offset &#8722;350 mV, Coupling DC, 
Impedance 50 Ohms.

Time base: Scale 200 ps/div.

Trigger: Trigger level &#8722;173 mV, Slope falling.

Function 2: Turn on and configure for channel 1 subtract channel 3, Vertical scale 50 mV/, 
Offset 100.000 mV.
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A second monitor can be used to display the automated test application, 
allowing you to view the oscilloscope while using the application. You need 
to connect a second monitor to the video port labeled Second Monitor on 
the rear panel of the oscilloscope and not to the port labeled VGA. (The 
VGA output is only used to display the screen of the oscilloscope on the 
external monitor.)

Before starting the automated test application, you should be sure that the 
second monitor is properly configured:

1 Exit the oscilloscope application, and click on the Windows Start menu 
button.

2 Select the Control Panel menu item.

3 Select Appearance and Themes.

4 Select Display.
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5 Select the Settings tab.

6 Select monitor two and set the Screen resolution and Color quality for 
your monitor.

7 Enable the Extend my Windows desktop onto this monitor control.

8 Click OK to apply these changes and close the Display Properties dialog 
box.

Once the second monitor is configured, moving the mouse off the 
oscilloscope screen will cause the mouse to be displayed on the second 
monitor. If you want to stop using the second monitor, you should disable 
the Extend my Windows desktop onto this monitor control.
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Numerics

81134A pulse pattern generator, 21

A

abort (test) actions, 38
ambient temperature change, 13
App Remote license, 64
AutoRecovery preferences, 54

B

beep only during run, 37
beep when user prompted, 37
best trials, store mode, 32
BIST_L test pattern source, 22
BIST_T test pattern source, 22
bit rate (Gbps), 20

C

cable change, 13
calibrating the oscilloscope, 13, 69
channel-to-channel de-skew, 70
clock speed, 20
comma-separated value (CSV) format, export 

results, 50
comments, 21
configuring tests, 27
connecting oscilloscope to DUT, 29
continue run when test aborts, 38
creating test project, 19
critical at percent of margin, 46, 47
CSV (comma-separated value) format, export 

results, 50
CT device test point, 20
CTC commands, 20

D

deleting trials, 40
de-skew, channel-to-channel, 70
device identifier, 21
device test point, 20
device type, 20
display preferences, 36
dual monitor configuration, 75
DUT, connecting to oscilloscope, 29

E

email on pause or stop, 34
enable margin reporting, 46, 47
enable remote interface, 66
Entitlement Certificate, 9
equipment required, 12
error dialogs, 36
event log, 37
event specification, 35
event trials, store mode, 32
events, pause or stop on, 34
exporting the report, 50

F

fail event, 35
flash red pixels in reference images, 45
forever, run until setting, 33

H

hints, remote interface, 67
HTML format, export results, 52
HTML test report, 

viewing/exporting/printing, 50

I

INF_SMA_Deskew.set file details, 73
information dialogs, 36
installation, 7
invert scope display, 37
IT device test point, 20

K

keep application on top, 37

L

last trials, store mode, 33
license key, 9
license, App Remote, 64
load preferences, 19
log events, 37

M

margin < N event, 35
margin thresholds, changing, 46, 47

mask hits, flash red pixels in reference 
images, 45

monitor, second for automated test 
application, 75

multi-file HTML, export results, 52
multiple runs, 33

N

N times, run until setting, 33
N5412B SAS-2 (Serial Attached SCSI) electrical 

compliance test application, 3
N5452A remote interface, 63
None, SSCSpread, 20
notices, 2

O

once, run until setting, 33
opening test project, 19
oscilloscope, connecting to DUT, 29

P

pass event, 35
pause on event, 34
pause, email on, 34
preferences, display, 36
preferences, remote, 66
preferences, report, 46, 47, 48
preferences, run, 37
preferences, save/load, 19, 54
preview print, 53
printing HTML test report, 53
project, creating or opening, 19
project, saving, 54

R

reference images, showing, 45
remote control, 63
remote interface hints, 67
remote interface version, 65
remote interface, enable, 66
remote preferences, 66
report (HTML), viewing/exporting/printing, 50
report preferences, 46, 48
report, exporting, 50
report, printing, 53
required equipment and software, 12
results, viewing test, 39
run multiple times, 33
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run preferences, 37
run until, 33
running tests, 30

S

SAS-2 (Serial Attached SCSI) automated 
testing, 3

SAS-SASCenter, SSCSpread, 20
SAS-SASDown, SSCSpread, 20
SAS-SATADown, SSCSpread, 20
save/load preferences, 19, 54
SavedWFM test pattern source, 22
saving test project, 54
second monitor for automated test 

application, 75
selecting tests, 25
set up, 20
show tooltips, 37
showing reference images, 45
single-file HTML, export results, 52
software installation, 8
software required, 12
SSCSpread, 20
starting SAS-2 (Serial Attached SCSI) Electrical 

Compliance Test application, 16
stop on event, 34
stop run when test aborts, 38
stop, email on, 34
store mode, 32

T

task flow pane, viewing/minimizing, 17
test abort actions, 38
test display order, 47
test order, 48
test project, creating or opening, 19
test project, saving, 54
test report (HTML), 

viewing/exporting/printing, 50
tests, configuring, 27
tests, running, 30
tests, selecting, 25
tests, viewing results, 39
toolbar, viewing/hiding, 18
tooltips, show, 37
trademarks, 2
trial display preferences, 48
trials, best/worst/last, 32, 48
trials, deleting, 40

U

unavailable tests, 25
user description, 21

V

version, remote interface, 65
viewing HTML test report, 50

viewing test results, 39

W

warn at percent of margin, 46, 47
warning dialogs, 36
worst trials, store mode, 33

Z

zoom in/out in reference images, 45
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