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Overview of RCal
Overview of RCal
The U9361x RCal Receiver Calibrator provides accurate signal analysis at a remote measurement 
plane when using an X-Series Signal Analyzer. This integrated solution allows you to correct for 
signal path and analyzer magnitude and phase errors to provide a more accurate measurement of 
your transmitter under test. This measurement guide provides the following resources for best 
success when using RCal:

— Initial RCal setup, including connector care and an overview of RCal’s I/O.

— Overview of the RCal Calibration graphical user interface (GUI).

— Demonstrations of both magnitude and complex corrections that highlight the most important 
RCal measurement practices.

— MATLAB scripts for RCal configuration and application.

Requirements

— X-Series Signal Analyzer Software Rev A.27.05 or higher (A.29.01 or higher recommended)

— U9361Y_RCL license installed on X-Series Signal Analyzer (two licenses come with each RCal 
unit, and additional upgrade options are available as U9361YU_RCL)

— X-Series Signal Analyzer (N9020B, N9021B, N9030B, N9032B, N9040B, N9041B, N9042B) To 
use the N9020B with RCal, you will need option DP2, MPB, or B40.

— Various signal generators. You can perform all demonstrations using either an N5173B, N5183B, 
or any model of the N519xA UXG. Additional models can be used for demos 1, 3, 4, 5, and 6. 
Refer to each Demo for specific requirements.

— Option CPX adds magnitude/phase for IF flatness calibration.

Available RCal Models and Options

Model Frequency Range Connector Type

U9361C 10 MHz – 26.5 GHz 3.5 mm male (option MMM) or 
3.5 mm female (option MMF)

U9361F 10 MHz – 50 GHz 2.4 mm male (option MMM) or 
2.4 mm female (option MMF)

U9361G 10 MHz - 67 GHz 1.85 mm male (option MMM) or 
1.85 mm female (option MMF)

U9361M 10 MHz – 110 GHz 1.0 mm male (option MMM)
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RCal I/O 
RCal I/O

The typical RCal use case requires three connections: USB Power & Control, Ext Ref In, and RF Out.

USB Power & Control

RCal has a USB Type-C connector, which must be connected to the signal analyzer for both power 
and control. Since RCal needs ample current to operate correctly, be sure to use one of the 
following ports:

— The signal analyzer front-panel USB 2.0 port, marked with a lightning bolt symbol (bottom front 
panel USB connector closest to RF input connector) or marked in blue (for the N9042B).

— A signal analyzer rear-panel USB 3.0 port, identified with “SS” or having a blue connector.

When plugged in, the RCal module will boot up, accompanied by an LED boot sequence. When 
boot-up is complete, the LEDs will settle to Status = Green. For more information about RCal’s LED 
codes, see “LED Indicators on RCal Module” on page 7.

External 10 MHz Reference

RCal’s signals are synthesized from an internal 100 MHz clock. For the best possible measurement 
accuracy, it is recommended that RCal be connected to the external 10 MHz Ref Out from the 
signal analyzer, or another reference that both RCal and the analyzer are locked to. The default 
setting of the RCal is Ref = External.
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RCal I/O
RF Output

The RF Output connector on the RCal module is the physical point where the calibration data 
applies.

An adapter may be needed between the RCal output and test port where calibration is desired. Use 
the shortest and highest quality connectors possible. Mismatch errors can be reduced with small 
fixed attenuators, such as a 6 dB attenuator.

Higher frequencies require smaller connector geometries, such as 1 mm. To avoid damaging these 
fragile connectors, please follow the recommendations in “Appendix: Connector Care” on page 61.
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LED Indicators on RCal Module 
LED Indicators on RCal Module
At startup, all LEDs on the RCal will blink with the firmware revision code and sequence through 
three colors. If problems occur on startup, the LED pattern may indicate self-test codes for use by 
support experts. Contact Keysight customer support, via email, at csg.servicedesk@keysight.com 
if you encounter any issues.

After startup, the LEDs indicate the following status messages:

Status LED RF Out LED 10 MHz Ref LED

Off = No USB Connection Off = No RF Output Off: Internal Reference Used

Green = On, Ready, Stable 
Green Blink = Busy

Green = RF Out On Green = External Ref locked successfully

Amber Blink = Temperature 
Unstable (during warm-up period)

- - 

Red = USB Power Failure 
Red Blink = Processor Error

Red Blink = USB Power Failure Red Blink = External Ref unlocked

Blue Blink = Self Identification - - 
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RCal Software – Configuration
RCal Software – Configuration
The RCal controls can be accessed in the X-Series application by selecting Input/Output, 
Calibration, Configuration. If this tab is missing, then the instrument is most likely using an older 
software revision, missing a license, or is unsupported. (See “Available RCal Models and Options” 
on page 4). 

This section provides an overview of how to perform the RCal configuration, calibration, and 
application.

RCal calibrations are created and applied within the calibration configuration window.
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RCal Software – Configuration 
Left-Panel Controls

Cal Group: Stores and groups combinations of user-created calibration states. This is useful for 
test setups involving multiple external paths that multiplex into a single output; each path may 
need its own individual calibration. The desired Cal Group can be specified here.

Cal Input: Specifies the desired input for instruments that have more than one input. Each Cal 
Group can only support one Cal Input at the same time. If multiple inputs are desired, create a 
Cal Group for each input.

Calibrate Checked Rows: Starts the RCal calibrations for each selected row according to all 
user-specified parameters. (See “Configuration Table Overview” on page 10 for information on 
how to set calibration parameters).

Copy From Cal Group: Allows you to import Cal Group settings into the current Cal Group. This 
is useful for calibrating text fixtures that use the same parameters across multiple signal paths.

Apply Cal Group: Applies all active calibration states for the selected Cal Group.

Select Calibrator: Selects the RCal module for use. A single signal analyzer can have multiple 
RCal modules connected to different ports, but only one module can be used and controlled at a 
time. The RCal Model and Serial numbers will appear below this tab.

RCal Reference: Selects whether RCal is using its internal 100 MHz clock or is locked to an 
external 10 MHz reference. The default (and strongly recommended) setting is to use an external 
reference in order to synchronize the RCal module with the signal analyzer for complex 
calibrations.

Identify RCal Module: Identifies the active RCal module. If multiple RCal modules are 
connected to the signal analyzer, touching this key will cause LEDs on the active unit to flash.
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RCal Software – Configuration
RCal Status: Opens the RCal status and error message dialogue. See “Errors, Warnings, and 
Status” on page 17 for more details.

Configuration Table Overview

The RCal configuration table is where you define the measurement parameters for your RCal 
correction. The table is initially empty. Click on Insert Row below, or Use Current Meas1 (located at 
the top of the configuration window), to start populating the table.

The simplest and fastest configuration option is to define one, single state (row). If you anticipate 
the need to make measurements that involve changing the analyzer’s state, you can provide ranges 
within a row or define additional rows within the same Cal Group. Calibrating for multiple states will 
require a longer calibration time, but allows for the RCal to match a wider range of states.

Rows

A row contains a collection of settings or ranges for RCal operation. A row is linked to the analyzer’s 
settings or “state” which can be viewed as an internal path through the analyzer. The row with a 
blue border is active for editing. To change the active editing row, use the Go to Row button or 
touch/click within the desired row. The Insert, Duplicate, and Delete buttons operate on the active 
row.

Columns

The columns contain the state settings or ranges that RCal needs for calibration. Some column 
groups allow you to define a range of settings; e.g. Frequency and Attenuation have 
Start/Stop/Step parameters. Other columns contain On/Off settings or provide a drop-down table 
of options, such as for IF Path or μW Path Ctrl. If you want to calibrate more than one of these 
choices, add another row and select each alternative in separate rows.

1. Use Current Meas automatically populates the Cal Row using parameters from the current X-Series Signal 
Analyzer application. This feature is supported by the Signal Analyzer mode and many others, but it is not 
supported by every X-Series Signal Analyzer application.

Not all columns fit on the display screen. Use a finger or mouse to grab 
the scroll bar (just below the bottom of the active row) and scroll to the 
left, or right to see all columns.
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RCal Software – Configuration 
Shown below are all parameters (columns) for an RCal calibration state (row):

RCal Configuration Table – Parameters

The following table details the parameters for each column in every calibration row.

Column Title Description Additional Information

Calibrate 
(checkbox)

Rows that are selected will be included when 
Calibrate Checked Rows is used to start a 
calibration.

Apply 
(checkbox)

Rows that are successfully calibrated will be 
applied to measurements when selected.

Name User defined row name.

Last Calibrated (Read only) Date and time that last calibration 
was successfully executed.

Applied (Read only) 
“Yes” if successfully applied, “---“ if not yet 
calibrated, and “No” if not applied.

Ext Mixer (Read only)

Applies only if Input = Ext Mixer

Type Magnitude: Select for correcting magnitude 
only (no phase corrections). Use for swept 
measurements.

Complex: Select for correcting magnitude and 
phase. Use for correcting IF responses for IQ 
demodulation measurements.

Complex is only available if RCal Option 
CPX is installed.
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RCal Software – Configuration
Frequency:

Start Freq

Stop Freq

Freq Step

Freq Points

Defines frequency range for calibration. Step 
and Points are coupled parameters; use either 
one to modify the “density” of the points over the 
selected frequency range.

For Complex calibrations, refers to the 
center of the IQ analysis span.

Mechanical 
Attenuation:

Mech Atten

Mech Atten Start

Mech Atten Stop

Mech Atten Step

Defines the range of main mechanical attenuator 
to calibrate. 
 
Mech Atten Step uses start, stop, and step 
range.

Calibrating over large attenuation ranges 
can take a long time, and calibration may 
not be possible at the highest attenuation 
levels. 
 
Step size is typically 2 dB.

Electronic 
Attenuation:

Elec Atten

Elec Atten Start

Elec Atten Stop

Elec Atten Step

Defines the range of the electronic attenuator to 
calibrate. 
 
All calibrates the entire range of electronic 
attenuation 
 
Elec Atten Step uses the start, stop, and step 
range. 
 
Bypass disables electronic attenuation.

Operates only at frequencies < 3.6 GHz.

IF Gain Auto (default) 
High Gain 
Low Gain 
All

Recommended to use Auto and set Match 
State = False. High Gain sets the IF gain 
to 10 dB for better noise levels, while Low 
Gain sets the IF gain to 0 dB for large 
signals. Auto will set the IF gain to 10 dB if 
the input attenuator is set to 0 dB. All will 
calibrate for both High Gain and Low Gain.

IF Path Selects the IF and digitizer path to be calibrated. 

Swept is only used for Magnitude calibrations.

Other paths for IQ demodulation include:

— 40 MHz

— 160 MHz

— 255 MHz

— 520 MHz

— 1 GHz

Only IF Paths that are available in an 
instrument’s HW configuration will appear.

Calibration is valid for the maximum 
bandwidth of the IF path.

Column Title Description Additional Information
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RCal Software – Configuration 
Preamp Off 
 
Low Band: Use for frequencies less than  
3.6 GHz 
 
Full Range: Use for frequencies up to 50 GHz

 
 
Low Band path is not compatible with 
Options LNP (Low Noise) or FBP (Full 
Bypass).

Coupling AC or DC Not all instruments support both AC and 
DC.

Phase Noise 
 
Opt = PNO

Selects PNO mode used by LO synthesizer 
system. Options include:

— Best Close-In

— Balance Noise and Spurs

— Best Spurs

— Best Wide-Offset

— Fast Tuning

— All

Best Close-In: better phase noise 
performance at the cost of higher spurs for 
offset < 600 kHz*

Balance Noise and Spurs: balanced spur 
and phase noise for offset < 600 kHz*

Best Spurs: spurs held to -90 dB at the cost 
of phase noise for offset < 600 kHz*

Best Wide-Offset: optimized phase noise for 
offset > 800 kHz*

Fast Tuning: provides faster tuning speed

All: calibrates for all PNO modes

*Phase Noise Optimization offset 
frequencies vary based on the Synthesizer 
option (EP0, EP1, EP2)

μW Path Options:

— Low Noise (LNP)

— μW Presel Bypass (MPB)

— Full Bypass (FBP)

μW path reverts to STD if any points are < 
3.6 GHz. In STD mode, the μW Preselector 
is in the circuit and the Low Noise Path is 
disabled.

LNP: bypasses low-band switch to lower 
noise floor (only for signals > 3.6 GHz)

MPB: bypasses preselector to lower noise 
floor (only for signals > 3.6 GHz)

FBP: bypasses both the low-band switch 
and preselector for the best dynamic range 
(only for signals > 3.6 GHz)

Mixing Mode Refers to ‘high-side’ or ‘low-side’ mixing (LO>RF 
or LO<RF).

Normal is default for a given band (can be either 
LO > RF or LO < RF).

Alternate if using alternate-side mixing for 
digital demodulation to flip the side of image 
products, then you would want to calibrate the 
alternate mixing side.

All does both.

Normal is sufficient for most use cases.

Column Title Description Additional Information
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RCal Software – Configuration
Match State False (default) allows instrument to interpolate 
and approximate when correction data is “close”; 
reduces frequency of Apply errors.

True requires strict match between correction 
data and instrument settings.

See “How to Utilize Match State” 
on page 18 for more details.

Column Title Description Additional Information
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RCal Software – Calibration and Application 
RCal Software – Calibration and Application

Running a Calibration

Once the desired measurement state(s) have been configured, select the states to calibrate by 
clicking/tapping on each state’s Calibrate check box to select.

After selecting the states for calibration, select the Calibrate Checked Rows button on the left 
panel. You should see the following message:

After ensuring that the RCal module is connected to the signal path, select OK to start the 
calibration.

The following is a brief summary of what occurs during the calibration process:

— The RCal configuration software automatically prepares the signal analyzer to control the RCal 
module for the calibration process.

— The signal analyzer reads relevant factory calibration data from the RCal module to prepare for 
corrections.

— The signal analyzer makes measurements and calculates the difference between expected and 
actual measurements.

— The differences are stored as corrections to be applied to a later measurement.

Calibrations involving multiple states take longer to execute.
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RCal Software – Calibration and Application
The following message will be displayed during the calibration process:

When calibration is complete, you should see the following message which will disappear 
automatically:

To cancel a calibration in progress, press the Cancel button or use the Esc key.

After calibration, you should see a time stamp for all calibrated rows under the Last Calibrated 
column.

Applying a Calibration

To apply the correction, select the Apply column in the row. The instrument will compare its current 
state to all corrections in the active RCal correction pool and apply correction factors according to 
the Match State rules. The Applied column should now show Yes, indicating that the selected 
calibration is being applied.

When calibrations are active, the Corr CCorr (Complex Correction) option on the measurement 
panel should show "RCal" in orange as shown below.

The Apply indicator is dynamic; as you change analyzer settings, RCal will re-evaluate to check if 
any RCal corrections in the active correction pool are applicable.
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RCal Software – Calibration and Application 
Typically, only 1 single correction should be actively applied at a time. Multiple states can be 
selected to apply, but these states should be configured in such a way that only 1 is active per given 
instrument state. If 0, or more than 1 state matches, the system will display a warning.

To remove a row from the active calibration pool, clear the Apply box. This state can always be 
added back to the pool by selecting Apply again.

Errors, Warnings, and Status

The RCal system displays status and error conditions in three ways:

— Meas Bar: The Corr CCorr option displays “RCal” in white if it is connected but inactive, and 
displays “RCal” in orange if calibrations are active.

— Status Bar: Located at the bottom of screen; is used to report high-level errors or warnings from 
any cause (not just from RCal). Only the most recent status changes are displayed. Select the 
‘balloon’ with “…” to see the error queue history with details.

— RCal Status dialog: This table is fully devoted to RCal and provides the greatest detail. To open, 
select Input/Output menu > Calibration > Configuration > RCal Status.

In this table, errors and warnings appear listed by both group and row number. Errors (red circle, 
white X) indicate failure, meaning RCal calibration is not successful. Warnings (yellow triangle, with 
“!”) indicates caution about a possible issue, but RCal can still calibrate successfully.

Correcting State Mismatches

Apply-time errors usually occur because an instrument state was changed and no longer matches 
any correction. To fix this:

— Modify the current state to stay within ranges or paths that are already calibrated.

— Change settings from “Auto” to “Man” (manual), to prevent automatic or coupled changes to 
parameters.

— Expand the range of RCal, and/or add RCal rows, to include the state or path that caused the 
mismatch, and recalibrate.

In most applications, the state parameters of a given measurement can be found and set via:

— The “Meas Bar” summary (at top of screen)

— The Meas Setup menu

Best RCal Configuration Practices

The following recommendations should be considered when creating RCal calibration states:
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RCal Software – Calibration and Application
— Plan for how the signal analyzer will be used after calibration, so that the corrections are valid 
for later changes in measurement parameters.

— Start with a a simple configuration and gradually configure for higher complexity. For example, 
start with a single row, a small number of frequency steps, and a small range of attenuation 
steps before further increasing these values as needed.

— In general, leave Match State set to False. See “How to Utilize Match State” on page 18 for 
more information.

— If you use the “Duplicate Row” feature, verify that the original row works correctly, and doesn’t 
take an excessively long time, before copying to another row.

Multiple SA Input Ports and RCal Modules

Most signal analyzer systems employ a single input port. However, some analyzers (such as the 
N9041B) have more than one input. If you need to calibrate both inputs, create a Cal Group for 
each RF input port, since each Cal group may choose which module is associated with that group.

How to Utilize Match State

Acquisitions rarely match the exact hardware state at which the original RCal correction was 
performed. The stored correction must be converted to the correction required for the exact 
hardware acquisition state. This conversion is controlled by the Match State parameter within the 
RCal configuration window.

If you want to only apply corrections to test setups that exactly match the state of their RCal 
calibration(s), you should set the Match State to True. If you want to apply RCal corrections to 
similar hardware states that may not exactly match the original hardware calibration state, you 
should set the Match State to False. When the Match State is set to False, the following rules are 
followed:

— Situations that are “close enough” will use the closest available correction.

— Situations that are too different will never be selected even when the Match State is set to 
False.

— Situations that are in between will utilize interpolation to get the desired correction.

Multiple Rows, Overlap, and Dual Corrections

If you create multiple rows, calibrate them, and select Apply in more than one row, the RCal system 
may raise apply-time warnings. As long as one row matches the current state, the calibration will 
be applied successfully for that row despite the warning.

If two or more rows both match state, they are considered overlapping and yield a 
double-correction. This overlap may be over a portion of the spectrum trace. This usually is 
undesired, and should be avoided or fixed by:

— Selecting Apply in a single row, or fewer rows, until the warning goes away, or configuring RCal 
to avoid overlap.
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RCal Software – Calibration and Application 
The following warning indicates that more than two rows match state:

When performing a calibration, no corrections will be made outside of the calibration bandwidth. 
However, if performing a calibration on a signal with a wider bandwidth than the calibration 
bandwidth, corrections will still be applied within the calibrated bandwidth.

Key Steps for Every RCal Calibration

The following procedure should be followed before every RCal calibration to guarantee the best 
possible accuracy:

1. RCal calibrations are independent of measurement time and temperature, which are 
parameters that are handled through routine spectrum analyzer alignments. For the best 
possible accuracy, alignments should be run before every RCal calibration and after a 30 
minute warm-up time. The RCal module does not replace spectrum analyzer calibrations and 
alignments.

2. Make sure that the Ext 10 MHz reference is connected and that the selected USB connection 
supplies ample current.

3. If source control is desired for the calibration, connect the necessary input and output triggers 
between the analyzer and source.
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Demonstrations
Demonstrations

Demo Setup

The following diagram shows the configuration for all front-panel demonstrations.

These demonstrations show how to correct for absolute power accuracy under the Swept SA 
application.

— Some demos involve the use of fixed attenuators, which should be inserted into the RF path 
such that the attenuator is present in both the signal generator to signal analyzer path as well as 
the RCal to signal analyzer path.

— The switch in the diagram represents changing the physical connection to the signal analyzer to 
use either the signal generator or RCal as the RF input.

— The Trig connections between the signal generator and signal analyzer are recommended for 
demos involving source control. The software trigger can also be used without a physical 
connection.

— The USB-C connection is located above the Ext Ref In and Trig Out ports, as shown below.
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Demonstrations 
Setting Up a Signal Analyzer to Control a Signal Generator

You will need to set up the signal generators address on the signal analyzer in order for the signal 
analyzer to control the signal generator.

1. Connect your signal generator to the LAN or to the SA through GPIB.

2. Navigate to Meas Setup > Select Source.

3. Add the source address using GPIB or LAN, highlight it, then choose Select Highlighted 
Source to add the source. 
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Demonstrations
Demo #1 – Simple Magnitude Calibration

Compatible Signal Generators:

— N5166B (CXG)

— N517xB (all EXG)

— N518xB (all MXG)

— N519xA (all UXG)

— M9x84B/C (all VXG)

This demonstration corrects for loss introduced by a 13 dB attenuator in the signal path. Before 
beginning this demo, please follow the guidelines detailed in the “Key Steps for Every RCal 
Calibration” on page 19. 

1. Connect the RF output of the signal generator to the RF input of the signal analyzer with the 
attenuator in between.

On the Spectrum Analyzer:

2. Select Mode Preset to set the analyzer to a known state. 
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Demonstrations 
3. Select Freq and set the Start Freq to 3 GHz and Stop Freq to 4 GHz.

4. Select Sweep > Sweep Config and set the Points to 101.
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Demonstrations
On the signal generator: Configure the following settings to sweep across the defined 
measurement span.

1. Select Preset to set the signal generator to a known state.

2. Set Amptd > -10 dBm.

3. Select Sweep > Sweep > Freq > On to enable frequency sweeping.

4. Select Return> Configure Step Sweep > Freq Start > 3 GHz and Freq Stop > 4 GHz.

5. Set # Points > 101.

6. Select More > Step Dwell > 2.00 msec.

7. Set RF Out > On. The RF output state is indicated by the LED next to the toggle button.

On the signal analyzer:

1. Select Trace. In the Select Trace drop-down, select Trace 1.

2. Set Trace Type to Max Hold, and then in the View/Blank area, select Active.
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Demonstrations 
The trace will begin to flatten as the maximum points are saved.

3. Once the trace has stabilized, save it for comparison by selecting View in the View/Blank area.

4.  Disconnect the RF cable from the signal generator and connect it to the RCal module.
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Demonstrations
5.  Select Input/Output > Calibration > Configuration to access the RCal Calibration 
Configuration window.

6.  Select Use Current Meas, then select the Calibrate check box > Calibrate Checked Rows to 
populate a row using the current measurement settings, and run the calibration.

7.  When calibration is complete, select Apply, then Close the window.

8.  Disconnect the cable from the RCal RF Out port and connect it to the signal generator RF Out 
port.
26 U9361C/F/G/M RCal Receiver Calibrator Measurement Guide



Demonstrations 
9.  Select Trace. In the Select Trace drop-down, select Trace 2 to verify the calibration by adding 
another trace.

10. Set Trace Type to Max Hold, and then in the View/Blank area, select View Active.

The trace will begin to flatten as the maximum points are saved. Notice the improvement in the 
measurement.
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Demonstrations
Demo #2 – Magnitude Cal with Source Control, Multiple States

Compatible Signal Generators:

— N5173B EXG

— N5183B MXG

— N519xA (all UXG)

This demonstration shows how changing measurement parameters after a calibration may require 
adding additional Cal states. A signal generator and a signal analyzer connected through USB is 
required for source control. This demo calibrates for a 3 dB attenuator. For signal generator control, 
refer to “Setting Up a Signal Analyzer to Control a Signal Generator” on page 21.

On the Signal Analyzer:

1. Select Mode > Spectrum Analyzer > Mode Preset to set the signal analyzer to a known state.

2. Select FREQ > Start Freq > 24 GHz 

3.  Stop Freq > 25 GHz
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4. Select Sweep > Sweep Config > Points > 101 to set the number of sweep point to 101.

5. Select Meas Setup> Source> Source Mode> Tracking to set up the source control to sweep 
across the frequency range

6. Select RF Output > Off

SW or External Trigger can be selected under the Source Setup table menu.
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7. Connect the RF output of the signal generator to the RF Input of the signal analyzer.

8. Select Meas Setup > Source > RF Output > On to enable the RF output of the signal generator.

9. Select Trace > Select Trace > Trace 1, set Trace Type > Max Hold, and set View > Active.

10.Once the trace has stabilized, save it for comparison by setting View > View.

11.Disable the RF output on the signal generator from Meas Setup > Source > RF Output > Off.

12.Disconnect the cable from the signal generator and connect it to the RCal module.
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13.Select Input Output > Calibration > Configuration to navigate to the RCal Calibration 
Configuration window.

14.Select Use Current Meas > Calibrate > Calibrate Checked Rows to populate a row using the 
current measurement settings and run the calibration.

15. When the calibration is complete, select the Apply box.

16. Disconnect the cable from the RCal module and connect it to the RF output of the signal 
generator.

17. Select Source > RF Output > On to enable the signal generator output.
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18. Verify the calibration by adding another trace.

Navigate to Trace > Select Trace > Trace 2

Set Trace Type > Max Hold and set View > Active

Wait for the trace to stabilize, then select View > View to store the trace.

19.Change the μW path to Bypass: Presel Bypass by selecting μW Path > Bypass
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This should generate a warning that the current instrument state does not match the applied 
calibration.

To handle both paths, an additional path must be added to the Calibration Configuration table.

20.Disable the RF output on the signal generator through Meas Setup > Source > RF Output > Off

21.Disconnect the cable from the signal generator and connect it to RCal module.

22.Navigate to the RCal Calibration Configuration window.

Input Output > Calibration > Configuration

23.Duplicate the existing state and change the new state’s RF path. (You will need to scroll to 
access some of these settings)

Select Row 1 > Duplicate Row > uW Path Ctrl > uW Presel Bypass

24. Clear the Calibrate check box on row 1 and select Calibrate on the new row.
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Calibrate > Calibrate Checked Rows

25.When calibration is complete, click the Apply box.

26.Disconnect the cable from the RCal module and connect it to the signal generator. Enable the 
RF output on the signal generator through Meas Setup > Source >RF Output > On.

Now the trace should be properly corrected and without errors.

27.View the new trace by adding a 3rd trace.

Trace > Select Trace > Trace 3

Trace Type > Max Hold

View > Active
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Observe the differences between the uncorrected trace (Trace 1), the corrected trace (Trace 
2), and the corrected trace with Preselector Bypass enabled (Trace 3).
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Demo #3 – Complex Cal: Improving EVM in a 128 QAM Signal

Compatible Signal Generators:

— N5166B (CXG)

— N517xB (all EXG)

— N518xB (all MXG)

— N519xA (all UXG)

— M9x84B/C (all VXG)

This demonstration shows how to perform a complex calibration on a QAM signal, correcting for 
both absolute power accuracy and Error Vector Magnitude (EVM). This will also demonstrate how 
to add an additional calibration state to improve measurement flexibility, specifically for handling 
multiple RF paths. Normally you would not make digital demodulation measurements through the 
YTF preselected path; however, using the built-in YTF allows for an easy way to demonstrate using 
RCal to correct for a bandpass filter’s roll-off.

1. Preset the analyzer.

Mode > Spectrum Analyzer > Mode Preset

2. Connect the signal analyzer to the signal generator without an attenuator in between.

3. Configure the signal generator using the following settings:

FREQ > 5GHz

AMPTD > -10dBm

Mode > Arb Custom Modulation > Single Carrier Setup > Modulation Type > Select > QAM 
> 128 QAM
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Return > Symbol Rate > 10 Msps

Return > Digital Modulation ON

RF > ON

4. Open the Digital Demod application in Vector Modulation Analyzer mode.

Mode > Vector Modulation Analyzer > Digital Demod

5. Configure the signal analyzer to demodulate the waveform.

Ctr (Center Frequency) > 5GHz

Format > 128-QAM

Sym Rate > 10MHz

Info BW > 20MHz

You should now see the constellation, signal, and metrics.

6. On the signal generator, enable trace averaging to smooth the signal.
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Meas Setup > Averaging > On

7. Disable the RF output on the signal generator.

RF Output > Off

8. Disconnect the cable from the signal generator and connect it to the RCal module.

9. Navigate to the RCal Calibration Configuration window.

Input/Output > Calibration > Configuration

The Calibration Configuration table should be unpopulated.
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10.Populate a row with the following parameters: (which should also be set in the signal analyzer 
meas bar)

Type: Complex

Start/Stop Freq: 5 GHz

Freq Points: 1

Mech Atten: Step

Mech Atten Start: 10 dB

Mech Atten Stop: 10 dB

Elec Atten: Bypass

IF Gain: Auto

IF Path: 25 MHz

Preamp: Off

Coupling: AC

Phase Noise Opt: Best Wide Offset

uW Path Ctrl: uW Presel Bypass

11.Run the calibration after selecting the calibrate check box.
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Calibrate > Calibrate Checked Rows

12.When calibration is complete, click the Apply box.

13.Disconnect the cable from the RCal module and connect it to the signal generator. Enable the 
RF output on the signal generator.

RF Output > On

The EVM should now be improved, as shown in the comparison below.

14.Change the RF path to use the Yig Tuned Filter (Standard Path).

µW Path > Standard

This will generate a warning, since the current corrections only apply to the µW Bypass Path.
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Another state must be added in order to properly apply corrections to both RF paths.

15.Disable the RF output on the signal generator.

RF Output > Off

16.Disconnect the cable from the signal generator and connect it to the RCal module.

17.Navigate to the RCal Calibration Configuration window.

Input Output > Calibration > Configuration

18.Duplicate the existing state and change the new state’s RF path.

Select Row 1> Duplicate Row> µW Path Ctrl > Standard
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19.Calibrate and apply the new state as previously demonstrated for the uW path.

20.Disconnect the cable from the RCal module and connect it to the signal generator. Enable the 
RF output on the signal generator.

RF Output > On

The EVM is now reduced to 0.12% with the Standard path. By leaving both paths applied, the 
instrument will automatically select the proper calibration state.
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Demo #4 - Using RCal with the 89600 VSA Software

Compatible Signal Generators:

— N5166B (CXG)

— N517xB (all EXG)

— N518xB (all MXG)

— N519xA (all UXG)

— M9x84B/C (all VXG)

RCal calibrations are supported by 89600 VSA software but must be set up outside of the VSA 
application. Before beginning the following demo, complete “Demo #3 – Complex Cal: Improving 
EVM in a 128 QAM Signal” on page 36 Demo #3 for RCal calibration setup for the uW path.

1. Start the VSA application.

Mode/Measure > Launch VSA

2. Configure the Trace Layout to be a 2x2 grid.

Window > Trace Layout > Grid 2x2

3. Set the Measurement Type to Digital Demod.
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Meas Setup > Measurement Type > General Purpose > Digital Demod

4. Open the Digital Demod Properties tab.

Meas Setup > Digital Demod Properties

5. Configure the following measurement parameters under the Format tab.

Format: 128-QAM

Symbol Rate: 10 MHz

Points/Symbol: 10

Result Length: 501 Symbols
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6. Under the Filter tab, set the following matched filter parameters.

Measurement Filter > Root Raised Cosine

Reference Filter > Raised Cosine

Alpha/BT: (rolloff) > 0.5

7. Set the IF Path to 25 MHz.

Input > Extensions > IF Path> 25 MHz
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8. Under the same Extensions window, scroll down and enable RCal Corrections.

RCal Correction > Correction

9. Perform an Auto-range by selecting the button shown below.

10.Exit the input window. EVM should now be improved. For this example, EVM went from 1.02% 
to 0.188%.
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Demo #5 - RCal vs. Power Sensor Accuracy

Compatible Signal Generators:

— N517xB (all EXG)

— N518xB (all MXG)

— N519xA (all UXG)

— M9x84B/C (all VXG)

This demonstration compares the absolute amplitude accuracy after an RCal calibration compared 
to a calibration done using a power sensor. In this case, we used the U5532C sensor module, but 
this demonstration can be done with other types of sensor modules and power meters.

1. Preset the analyzer.

Mode > Spectrum Analyzer > Mode Preset

2. Connect the signal analyzer to the signal generator.

3. Set start frequency to 1 GHz and stop frequency to 20 GHz.

FREQ > Start Freq > 1 GHz

Stop Freq > 20 GHz
U9361C/F/G/M RCal Receiver Calibrator Measurement Guide  47



Demonstrations
4. Set the number of sweep points to 101.

Sweep > Sweep Config > Points > 101

5. Set up source control to automatically sweep across the frequency range.

Meas Setup > Source

Source Mode > Tracking

RF Output > On
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SW or External Trigger can be selected under the Source Setup Table menu.

6. Enable the RF output on the signal generator.

RF > On

7. Prepare to store the uncorrected trace.

Trace > Select Trace > Trace 1

Trace Type > Max Hold

View > Active

8. Once the trace has stabilized, save it for comparison.

View > View
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9. Disable the RF output on the signal generator.

RF Output > Off

10.Disconnect the cable from the signal generator and connect it to the RCal module.

11.Navigate to the RCal Calibration Configuration Window.

Input Output > Calibration > Configuration

The Calibration Configuration Table should be unpopulated.
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12.Populate a row using the current measurement settings. Duplicate this row if comparisons for 
both the Standard Path and µW Preselector Bypass are desired.

Use Current Meas > Duplicate Row > µW Path Control > µW Presel Bypass

13.Run the calibration after selecting the calibrate parameter.

Calibrate > Calibrate > Checked Rows

14.When calibration is complete, select Apply.

15.Disconnect the cable from the RCal module and connect it to the signal generator. Enable the 
RF output on the signal generator.

RF Output > On
U9361C/F/G/M RCal Receiver Calibrator Measurement Guide  51



Demonstrations
16.Place Markers at 2 GHz, 5 GHz, 8 GHz, 11 GHz, 14 GHz, 17 GHz, and 20 GHz for comparisons 
with power meter accuracy.

Marker > Marker Table > On

Select Marker 1 - 7 > Marker Frequency > 2.5 GHz, 5 GHz, 8 GHz, 11 GHz, 14 GHz, 17 GHz, 
and 20 GHz

Marker Mode > Normal

17.If you are using a USB power sensor, connect the Power sensor to the RF Output of the signal 
generator and connect the USB to a USB port on the signal generator.

18. On the signal generator, select Aux Fctn > Power Meter Measurements > Channel A Setup > 
Connection Settings > Connection Type > USB, then select your Power Meter from the USB 
Device menu and select Test Connection to confirm the device is connected properly.

19. Return to view the power meter measurements, and set FREQ > 2.5 GHz, 5 GHz, 8 GHz, 11 
GHz, 14 GHz, 17 GHz, and 20 GHz, recording the measured power at each frequency point.

The results have been tabulated below. TX power is -10 dBm.

Frequency (GHz) Power Sensor (dBm) RCal Corrected Difference (Abs)

2.5 -10.07 -10.01 0.06

5 -10.06 -9.996 0.064

8 -10.35 -9.881 0.469

11 -9.97 -10.08 0.11

14 -9.91 -10.16 0.25
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The average difference in results between the Power Sensor and the measurement using an RCal 
calibration for this test case was 0.192 dBm across the selected measurement span.

17 -10.12 -10.08 0.04

20 -10.36 -10.01 0.35

Frequency (GHz) Power Sensor (dBm) RCal Corrected Difference (Abs)
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Demo #6 - Using RCal as a CW Source and Comb Generator

RCal now supports the Calibrator Control feature, which allows you to use RCal to generate both 
CW and comb signals with adjustable frequencies and comb spacings. The power of the output 
signal cannot be adjusted within the X-Series software. External attenuators can be used to adjust 
the power as needed. CW output power is normally greater than -10 dBm below 40 GHz and 
normally greater than -30 dBm above 40 GHz. RCal calibrator control can be accessed within the 
X-Series front panel through Input/Output > Calibrator Control.

Calibrator Control Options:

— Cal Source: Selects the desired RCal module to control

— Output: Toggles the RCal RF output state

— Frequency: Sets the RCal signal frequency

— Frequency Reference: Selects the frequency reference used by the RCal module. Using the 
External 10MHz reference is highly recommended.

— Signal: Selects between a CW tone or a comb signal for the RCal output signal type

— Comb Spacing: Select the spacing of the frequency comb when using a comb signal

The table below gives minimum and maximum frequency and comb spacing options when using 
Calibrator Control:

Minimum Maximum

Frequency 10 MHz 110 GHz

Comb Spacing 100 kHz 1.344 GHz
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Example Calibrator Control Outputs:

CW signal at 10 GHz. The amplitude of the signal can be adjusted using external attenuation.

Comb signal centered at 10 GHz with 100 kHz spacing.
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Comb signal centered at 10 GHz with 100 MHz spacing.
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SCPI commands can be used to help simplify and speed up the RCal configuration and calibration 
process. The software for RCal calibrations is stored and executed on the analyzer itself, so 
commands must be made through a USB, VISA, or GPIB connection to the signal analyzer directly. 
Additionally, some of the following programming examples require a connection to the signal 
generator in the test setup.

Magnitude Calibration and Comparison with Use Current Meas

This script allows you to perform a magnitude calibration that utilizes the Use Current Meas 
command for an efficient demonstration of RCal’s RX power correction capabilities.

clear all; 
close all; 
instrreset; 
clc;

% Define Parameters Here: 
SA_address = 'USB0::0x2A8D::0x0D0B::MY49431812::0::INSTR' 
SG_address = 'USB0::0x0957::0x1F01::MY53050777::0::INSTR' 
center_freq = 5; 
freq_span = 2; 
amp = -50; 
cal_group = 1; 
cal_row = 1;

% Create VISA objects for your X-Series Signal Analyzer and Power Source 
my_SA = visa('keysight', SA_address); 
my_SG = visa('keysight', SG_address);

% Connect to the instruments 
fopen(my_SA); 
fopen(my_SG);

% get instrument identification to make sure we are speaking with the 
% devices 
query(my_SA,'*idn?') 
query(my_SG,'*idn?')

% Set up SG to sweep from 5 to 6 GHz, 101 points, -20dBm 
fprintf(my_SG, ':FREQuency:MODE LIST'); 
fprintf(my_SG, ':SWE:GEN STEP'); 
fprintf(my_SG, ':FREQ:CENT %dGHz', center_freq); 
fprintf(my_SG, ':FREQ:SPAN %dGHz', freq_span); 
fprintf(my_SG, ':POW %ddBm', amp);

% Set X-Series Signal Analyzer to basic mode, set trace to <> hold order to see avg. 
power 
% level before calibration 
fprintf(my_SA, ':INST:SEL SA'); 
fprintf(my_SA, ':SYST:PRES:TYPE MODE'); 
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fprintf(my_SA, ':FREQ:CENT %dGHz', center_freq); 
fprintf(my_SA, ':FREQ:SPAN %dGHz', freq_span); 
fprintf(my_SA, ':TRAC1:TYPE MAXH');

% Once the trace has stabilized, press enter to save the trace and continue 
input('Press ''Enter'' when trace stabilized...','s'); 
fprintf(my_SA, ':TRAC1:MODE VIEW'); 
input('Switch cable from SG to RCal Unit, then press ''enter''...','s');

% Set desired cal group and row to use current measurement parameters 
fprintf(my_SA, 'SYST:CAL:CGR %d', cal_group); 
fprintf(my_SA, ':SYST:CAL:ROW%d:UCM', cal_row);

% Now Run Calibrations (the UCM command automatically selects the newly inserted 
Row)

fprintf(my_SA, ':SYST:CAL:INIT:SEL'); 
input('Switch cable from RCal to SG after Calibration complete, apply 
calibrations manually, then press ''enter''...', 's'); 
fprintf(my_SA, ':SYST:CAL:ROW1:STAT ON'); 
fprintf(my_SA, ':TRAC2:TYPE MAXH'); 
input('Press ''Enter'' when trace 2 stabilized...','s'); 
fprintf(my_SA, ':TRAC2:MODE VIEW'); 
disp("Magnitude Cal Demo Complete");

Calibration Table Setup for VMA

As shown in the previous demonstrations, the Use Current Meas feature is not available when using 
the Vector Modulation Analysis (VMA) application. The following script populates the desired 
Calibration Row with your selected settings in VMA.

%% Demo #2 | {Use Current Meas} for VMA

clear all; 
close all; 
instrreset; 
clc;

% Define Desired Cal Group 
cal_group = 1;

% Define Mechanical Attenuation Range (must be divisable by 2) 
mech_atten_range = 6; 
elec_atten_raange = 6;

% Input ID (VISA, IP, etc.) 
SA_address = 'USB0::0x2A8D::0x0D0B::MY49431812::0::INSTR' 
SG_address = 'USB0::0x0957::0x1F01::MY53050777::0::INSTR'

% Create VISA objects for your X-Series Signal Analyzer and Power Source 
my_SA = visa('keysight', SA_address); 
my_SG = visa('keysight', SG_address);
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% Connect to the instruments 
fopen(my_SA); 
fopen(my_SG);

% get instrument identification to make sure we are speaking with the  
% devices 
query(my_SA,'*idn?'); 
query(my_SG,'*idn?');

% Assumes X-Series Signal Analyzer has desired measurement parameters set in VMA, IF 
Gain Auto 
center_frequency = query(my_SA, ':FREQ:CENT?') 
mech_atten = query(my_SA, ':POW:ATT?') 
preamp = query(my_SA, ':POW:GAIN:BAND?') 
preamp_enable = query(my_SA, ':POW:GAIN?') 
elec_atten = query(my_SA, ':POW:EATT?') 
coupling = query(my_SA, ':INP:COUP?') 
uW_path = query(my_SA, ':POW:MW:PATH?') 
fprintf(my_SA, ':DDEM:IF:GAIN:AUTO ON') 
IF_gain = query(my_SA, ':DDEM:IF:GAIN:AUTO?') 
pno = query(my_SA, 'DDEM:FREQ:SYNT?') %Phase Noise Offset

% IF path, Start and Stop Frequency, is determined by the IF BW 
% Determine IF path given IF BW

Info_BW = query(my_SA, 'DDEM:BAND?') 
Info_BW_num = str2num(Info_BW)

if Info_BW_num <= 10E6 
    IF_path = 'B10M' 
elseif Info_BW_num > 10E6 && Info_BW_num <= 25E6 
    IF_path = 'B25M' 
elseif Info_BW_num > 25E6 && Info_BW_num <= 40E6 
    IF_path = 'B40M' 
elseif Info_BW_num > 40E6 && Info_BW_num <= 160E6 
    IF_path = 'B160M' 
elseif Info_BW_num > 160E6 && Info_BW_num <= 255E6 
    IF_path = 'B255M' 
elseif Info_BW_num > 255E6 && Info_BW_num <= 510E6 
    IF_path = 'B510M' 
elseif Info_BW_num > 510E6 && Info_BW_num <= 1000E6 
    IF_path = 'B100M' 
end

% Assume Single-Carrier (Add additional frequency range for OFDM) 
center_frequency_num = str2num(center_frequency) 
freq_start = num2str(center_frequency_num) 
freq_stop = num2str(center_frequency_num)

% Now populate an RCal State with the instrument parameters 
fprintf(my_SA, ':SYST:CAL:CGR %d', cal_group)
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fprintf(my_SA, ':SYST:CAL:ROW1:FREQ:STAR %s', freq_start); 
fprintf(my_SA, ':SYST:CAL:ROW1:FREQ:STOP %s', freq_stop);

% Given Mechanical Attenuation State, go +/- x dB in 2 dB steps 
mech_atten_num = str2num(mech_atten) 
mech_atten_start = num2str(mech_atten_num - (mech_atten_range/2)) 
mech_atten_stop = num2str(mech_atten_num + (mech_atten_range/2)) 
mech_atten_step = '2' 
fprintf(my_SA, ':SYST:CAL:ROW1:ATT:TYPE STEP'); 
fprintf(my_SA, ':SYST:CAL:ROW1:ATT:STAR %s', mech_atten_start); 
fprintf(my_SA, ':SYST:CAL:ROW1:ATT:STOP %s', mech_atten_stop); 
fprintf(my_SA, ':SYST:CAL:ROW1:ATT:STEP %s', mech_atten_step);

% Bypass electronic attenuation if it is disabled or 0dB 
% QUERY automatically returns ['x' char newline] 
if elec_atten == ['0' char newline] 
    fprintf(my_SA, ':SYST:CAL:ROW1:EATT:TYPE BYP'); 
else 
    elec_atten_num = str2num(elec_atten) 
    elec_atten_start = num2str(elec_atten_num - (elec_atten_range/2)) 
    elec_atten_stop = num2str(elec_atten_num + (elec_atten_range/2)) 
    elec_atten_step = '2' 
    fprintf(my_SA, ':SYST:CAL:ROW1:EATT:TYPE STEP'); 
    fprintf(my_SA, ':SYST:CAL:ROW1:EATT:STAR %s', elec_atten_start); 
    fprintf(my_SA, ':SYST:CAL:ROW1:EATT:STOP %s', elec_atten_stop); 
    fprintf(my_SA, ':SYST:CAL:ROW1:EATT:STEP %s', elec_atten_step); 
end

fprintf(my_SA, ':SYST:CAL:ROW1:IF:PATH %s', IF_path);

if preamp_enable == ['0' char newline] 
    fprintf(my_SA, ':SYST:CAL:ROW1:POW:GAIN:BAND OFF'); 
else 
    fprintf(my_SA, ':SYST:CAL:ROW1:POW:GAIN:BAND %s', preamp); 
end

fprintf(my_SA, ':SYST:CAL:ROW1:COUP %s', coupling) 
fprintf(my_SA, ':SYST:CAL:ROW1:FREQ:SYNT %s', pno) 
fprintf(my_SA, ':SYST:CAL:ROW1:POW:MW:PATH %s', uW_path)

% Mixing Mode and Match State are default on new row addition 
% Uncomment below to automatically calibrate for single added row 
% input('Switch cable from SG to RCal Unit, then press ''enter''...', 's'); 
% fprintf(my_SA, ':SYST:CAL:INIT:SEL')
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Appendix: Connector Care

Making Connections

Good connections require a skilled operator. Instrument sensitivity and coaxial connector 
mechanical tolerances are such that slight errors in operator technique can have a significant effect 
on measurements and measurement uncertainties.

The most common cause of measurement error is with poor connections.

Connection Procedure

1. Ground yourself and all devices (wear a grounded wrist strap and work on an antistatic mat).

2. Visually inspect the connectors (refer to Visual Inspection).

3. If necessary, clean the connectors (refer to Cleaning Connectors).

4. Carefully align the connectors. The male connector center pin must slip concentrically into the 
contact fingers of the female connector.

5. Push the connectors straight together. Do not twist or screw them together. As the center 
conductors mate, there is usually a slight resistance.

6. Initial tightening can be done by hand or with an open-end wrench. Tighten until "snug" or 
where the connectors are first making contact. The preliminary connection is tight enough 
when the mating plane surfaces make uniform, light contact. Do not over tighten this 
connection. At this point, all you want is for the outer conductors to make gentle contact on 
both mating surfaces. Use very light finger pressure (no more than 2 inch-pounds of torque).

7. Relieve any side pressure on the connection from long or heavy devices or cables. This assures 
consistent torque.

8. Torque the cable or device to the final value using a torque wrench.

Cleaning Connectors

1. Inspect the connectors for dust, dirt, metal fragment, oils or film, and debris.

2. Blow off any dust with a filtered, clean supply of compressed air.

3. Add a few drops of high-purity isopropyl alcohol to a small cleaning swab (do not apply 

Do not twist one connector into the other (like inserting a light bulb). This happens when you 
turn the device body, rather than the connector nut. Major damage to the center conductor and 
the outer conductor can occur if the device body is twisted.
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alcohol directly to the parts).

4. Gently wipe connecting surfaces with the end of the cleaning swab.

5. Blow dry with compressed air.

6. Inspect and repeat cleaning procedure if necessary.

Visual Inspection

Visual inspection and, if necessary, cleaning should be done every time a connection is made. 
Metal particles from connector threads may fall into the connector when it is disconnected. One 
connection made with a dirty or damaged connector can damage both connectors beyond repair.

Magnification is helpful when inspecting connectors, but it is not required and may be misleading. 
Defects and damage that cannot be seen without magnification generally have no effect on 
electrical or mechanical performance. Magnification is of great use in analyzing the nature and 
cause of damage and in cleaning connectors, but it is not required for inspection.

Obvious defects or damage

Examine the connectors first for obvious defects or damage:

1. Plating

— Bare metal showing

2. Burrs or blisters

3. Deformed threads

4. Center conductors

— Bent

— Broken

— Misaligned

— Concentricity

5. Connector nuts should move smoothly and be free of:

— Burrs

— Loose metal particles

When using isopropyl alcohol to clean connectors do not allow the liquid 
to flow down Keysight U9361 RCal Receiver Calibrator – Startup and 
Demonstration Guide page 6 | 28 inside the connector. This may cause 
measurement errors due to residue inside the connector. If possible, keep 
the connector downward facing.
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Resources 
Resources

U9361x Product Pages:

U9361C RCal Receiver Calibrator, 10 MHz to 26.5 GHz

U9361F RCal Receiver Calibrator, 10 MHz to 50 GHz

U9361G RCal Receiver Calibrator, 10 MHz to 67 GHz

U9361M RCal Receiver Calibrator, 10 MHz to 110 GHz

U9361x Receiver Calibrator Quick Start Guide

U9361x RCal Receiver Calibrator Technical Overview

The Essential Guide to Receiver Calibration - RCal Application Note

RCal Magnitude Calibration Demo

RCal Complex Calibration Demo
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https://www.keysight.com/us/en/product/U9361M/u9361m-rcal-receiver-calibrator.html
https://www.keysight.com/us/en/assets/9018-70258/quick-start-guides/9018-70258.pdf
https://www.keysight.com/us/en/product/U9361C/rcal-receiver-calibrator.html
https://www.keysight.com/us/en/product/U9361F/u9361f-rcal-receiver-calibrator.html
https://www.keysight.com/us/en/product/U9361G/rcal-receiver-calibrator.html
https://www.keysight.com/us/en/assets/3120-1426/technical-overviews/U9361-RCal-Receiver-Calibrator.pdf
https://www.keysight.com/us/en/assets/7120-1290/application-notes/The-Essential-Guide-to-Receiver-Calibration.pdf
https://www.keysight.com/us/en/library/demos/video/rcal-magnitude-calibration-demo.html
https://www.keysight.com/us/en/library/demos/video/rcal-complex-calibration-demo.html
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