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Introduction

This demonstration guide follows the list from page 2, which shows 

the demonstrations included in this document. Each demonstration 

is given a brief description of its function and the corresponding  

measurement steps on the signal generator and/or signal analyzer. 
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Digital Cable TV Measurement Application 

Measurement Details

All of the RF transmitter measurements as defined by the Digital Cable TV 

standards, as well as a wide range of additional measurements and analysis 

tools, are available with a press of a button. These measurements are fully 

remote controllable via the IEC/IEEE bus or LAN, using SCPI commands. Analog 

baseband measurements are available on the MXA signal analyzer equipped 

with BBIQ hardware. Supported baseband measurements include all of the 

modulation quality plus I/Q waveform and CCDF measurements.

Technology Digital Cable TV standards

(DVB-C (J.83/A), J.83/B, J.83/C)

Measurement application N6152A, W6152A

X-Series signal analyzer PXA, MXA, EXA, CXA

Measurements Channel power

ACP (Adjacent channel power)

Power stat CCDF

Spectrum emission mask

Modulation accuracy

  Constellation graph

  RMS EVM (%)

  Peak EVM (%)

  Position of peak EVM 

  RMS MER (SNR) (dB)

  Peak MER (SNR) (dB)

  Position of peak MER (SNR) 

  RMS mag error (%)

  Peak mag error (%)

  Position of peak mag error

  RMS phase error (deg)

  Peak phase error (deg)

  Position of peak phase error

  Frequency error (Hz)

  IQ Offset (dB)

  Quadrature error (deg)

  Gain imbalance (dB)

  Tx power (dBm)

  MER/EVM vs. symbol

  Mag error vs. symbol (%)

  Phase error vs. symbol (deg)

  Amplitude vs. frequency (dB)

  Phase vs. frequency (deg)

  Group delay vs. frequency (ns)

  Channel impulse response (dB)

  BER before RS 

  BER after RS

  Packet error ratio

Monitor spectrum 

IQ waveform
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Demonstration Preparation

All demonstrations use an X-Series signal analyzer with the Digital Cable 

TV measurement application and the N5182A MXG vector signal generator. 

Keystrokes surrounded by [ ] indicate front-panel keys; keystrokes surrounded 

by { } indicate softkeys located on the display.

Product type/instrument Model number Required options

MXG (or ESG) vector  

signal generator

N5182A (or E4438C) firmware revision  

of MXG A.01.44 or later

 – 503 – frequency range at 3 GHz

 – 651, 652, or 654 – internal baseband 

generator

 – 019 – Upgrade baseband generator memory 

to 64 Msa (recommended)

Signal Studio for Digital 

Video, Digital Cable  

TV options

N7623B Signal Studio for Digital Video

Please check the N7623B Signal Studio 

webpage for the latest version

www.keysight.com/find/N7623B

 – 3FP – N5182A connectivity

 – QFP – Advanced DVB-T/H/C/J.83 Annex 

A/C

 – XFP – Advanced J.83 Annex B

X-Series signal analyzer N9030A PXA, N9020A MXA, 

N9010A EXA, or N9000A CXA

Firmware revision A.07.xx or later

 – 503, 507 (for EXA and CXA), 508, 513 or 526 

(513 and 526 not available for CXA)
Recommended:

 – EA3 – electronic attenuator, 3.6 GHz 

 – P0x – preamplifier

 – B25 , B40 or B1X – analysis bandwidth up 

to 25 MHz, 40 MHz or 140 MHz 

 – BBA – analog baseband IQ inputs  

(only for MXA)

Digital cable TV  

measurement application

N6152A (PXA, MXA, EXA)

W6152A (CXA)

 – 2FP: DVB-C (J.83 Annex A/C) measure-

ment application, fixed perpetual license

 – 3FP: J.83 Annex B measurement  

application, fixed perpetual license
Or

 – 2TP: DVB-C (J.83 Annex A/C) measurement  

application, transportable license (only for 

PXA/MXA/EXA) 

 – 3TP: J.83 Annex B measurement  

application, transportable license  

(only for PXA/MXA/EXA)

Controller PC for Signal 

Studio

 – Install N7623B to generate and download 

the signal waveform into the Keysight MXG 

via GPIB or LAN (TCP/IP)—please refer to 

the online documentation for installation 

and setup

Minimum equipment coniguration requirements

Helpful tips!

Update your instrument 

firmware and software to the 

latest version, at

www.keysight.com/find/

xseries_software

www.keysight.com/find/ 

signalstudio

http://www.keysight.com/find/N7623B
http://www.keysight.com/find/xseries_software
http://www.keysight.com/find/xseries_software
http://www.keysight.com/find/signalstudio
http://www.keysight.com/find/signalstudio
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Connect the PC, X-Series Signal Analyzer and MXG 

Connect a PC (loaded with N7623B Signal Studio for Digital Video software and 

Keysight I/O libraries) to the N5182A MXG via GPIB or LAN. Follow the Signal 

Studio instructions to complete the connection, then perform the following 

steps to interconnect the X-Series signal analyzer and MXG (see Figure 1 for  

a graphical overview):

a. Connect the MXG RF output port to the X-Series signal analyzer RF input port

b. Connect the MXG 10 MHz out to the X-Series signal analyzer Ext Ref in port  

 (rear panel)

Demonstration Setup: 

Figure 1. Demonstration setup

N7623B digital 

video signal studio

LAN/GPIB

MXG 

RF Out

X-Series 

signal 

analyzer 

RF In

10 MHz Ref
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Demonstrations

Demonstration 1: 

Set up Signal Studio for  
digital video on the MXG 

The N7623B Signal Studio for Digital 

Video is a Windows-based utility that 

simplifies the creation of standards-

based or customized digital cable TV 

signals, including DVB-C (J.83/A), 

J.83/B, and J.83/C, and then the 

parameters are downloaded into the 

MXG vector signal generator, which 

creates the desired waveform. In this 

demonstration guide, DVB-C (J.83/A) 

signals are used as an example.

Instructions Keystrokes

On the MXG

    Preset the MXG; check the IP address [Preset]
[Utility] {I/O Config} {GPIB/LAN Setup}

On the Signal Studio software

    Run the Signal Studio for Digital Video Double-click on the Digital Video shortcut on the desktop or access 
the program via the Windows start menu. 

    Verify the software is communicating with the 
    instrument via the GPIB or LAN (TCP/IP) link

To establish a new connection, click on the {System} pull-down 
menu at the top of the Signal Studio program window. Next, select 
{Run System Configuration Wizard}.

    Select the DVB-C, J.83 Annex A/C format Click on the {Format} pull down menu at the top of the signal studio 
program window, Next, select {DVB-C, J.83 Annex A/C}.

    Set the basic parameters of the signal at  
    center frequency 474 MHz, amplitude  
    –20 dBm, and RF output turned ON

Click Signal Generator at the hardware on the explorer menu on the 
left. Instrument Model Number: N5162A/N5182A
Press [Preset] green button on the top. Frequency = 474 MHz, 
amplitude = –20 dBm, RF Output = On , ALC = On

    Confirm the waveform setup from upper level Click Waveform Setup to see the fundamental waveform signal 
setups, set DVB-C common parameters as follows: Oversampling 
Ratio = 2, Mirror Spectrum = Off, Quadrature Angle Adjustment = 0 
deg, I/Q Gain Balance = 0 dB

    Set a test signal for demonstrations.  
    The settings of the signal are as follows:
    Standard: DVB-C (J.83/A)
    Symbol rate: 6.9 MHz
    Modulation type: 64QAM
    Filter type: Root Nyquist
    Roll-off factor: 0.15

Click Carrier0 (Basic) under Waveform Setup on the explorer menu 
on the left. Set the parameters of the signal to be transmitted on the 
right side of the menu accordingly. Figure 2 is a graphic showing the 
signals setting once the setup done.   

    Download the signal to the MXG
Click    Generate and Download button on the top tool bar. If you 
encounter any errors, please refer to the online help of Signal Studio 
software.

    Save the signal file for future use File > Save Setting File > DVB_C.scp (name it as you like.)

    Export the waveform file for future use File > Export Waveform Data > DVB_C.wfm (name it as you like).

Figure 2.

Digital Cable TV 

signals setup in the 

Signal Studio for 

Digital Video software
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Figure 3.

Channel power 

measurement 

Demonstration 2:

Channel power 

The channel power measurement measures and reports the integrated power 

in the digital cable TV defined bandwidth and power spectral density (PSD) 

displayed in dBm/Hz or dBm/MHz.

Instructions Keystrokes

On the X-Series in Digital Cable TV mode:

    Select Digital Cable TV mode [Mode Preset] [Mode] {Digital Cable TV}

    Set the center frequency at 474 MHz [FREQ Channel] {Center Freq} {474} {MHz}

    Select the DVB-C (J.83/A) standard [Mode Setup] {Radio Std} {DVB-C (J.83/A)}

    Set the modulation format and symbols rate [Mode Setup] {Modulation Format} {64QAM}

[Mode Setup] {Symbol Rate Auto}

    Activate the channel power measurement [Meas] {Channel Power}
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Figure 4.

ACP measurement with 

noise correction on

Instructions Keystrokes

On the X-Series Digital Cable TV mode:

    Active adjacent channel power measurement [Meas] {ACP} 

    Compare the measurement results with noise  

    correction turned on. Better ACP results are  

    achieved with noise correction on (Figure 4).

[Meas Setup] {More 1 of 2} {Noise Correction On}

Demonstration 3:

Adjacent channel power (ACP) 

Adjacent channel power can measure and report the power in one or more 

transmit channels. The text window shows the total power within the defined 

carrier bandwidth and at given frequency offsets on both sides of the carrier 

frequency. The ACP measurement results should look similar to Figure 4.
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Figure 5.

Power stat CCDF 

measurement

Figure 6.

Power stat CCDF 

measurement with 

reference trace

Instructions Keystrokes

On the X-Series Digital Cable TV mode:

    Active the power stat CCDF measurement [Meas] {Power Stat CCDF} 

    Store a reference trace [Trace/Detector] {Store Ref Trace}

    Turn on reference trace [Trace/Detector] {Ref Trace On}

Demonstration 4:

Power stat CCDF 

The power stat complementary cumulative distribution function (CCDF) is a sta-

tistical method used to interpret the peak-to-average ratio of digitally modulated 

noise-like signals. It is a key tool for power amplifier design for digital cable 

TV transmitters, which is particularly challenging because the amplifier must 

be capable of handling the high peak-to-average ratio while maintaining good 

adjacent channel leakage performance.
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Instructions Keystrokes

On the X-Series Digital Cable TV mode:

    Active the spectrum emission mask measurement [Meas] {Spectrum Emission Mask} 

    Set the limit mask as needed [Meas Setup] {Ref Channel}

[Meas Setup] {Offset Limit}

Demonstration 5:

Spectrum emission mask 

The spectrum emission mask (SEM) measurement compares the total power 

level within the defined carrier bandwidth and the given offset channel on both 

sides of the carrier frequency to levels allowed by the standard or manually set 

by the user. This measurement refers to the design of the power amplifier in 

the transmitter, and it is a key measurement linking amplifier linearity and other 

performance characteristics to the stringent system specifications.

Figure 7.

Spectrum emission 

mask measurement
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Demonstration 6:

Modulation accuracy 

Measurement of modulation accuracy and quality are necessary to meet test 

requirements defined in ETSI TR 101 290 and ensure proper operations of the 

transmitters. Error vector magnitude (EVM) and modulation error ratio (MER) 

present the total signal degradation including noise, interferences, or distortions 

at the input of a commercial receiver’s decision circuits to give an indication of 

the ability of that receiver to correctly decode the signal. 

The modulation accuracy measurement provides many methods for measuring 

the errors in a digital cable TV transmitter. In the measurements, you can  

measure the EVM, MER, magnitude error, phase error and more.

Instructions Keystrokes

On the X-Series Digital Cable TV 
mode:

    Active the modulation  

    accuracy measurement

[Meas] {Mod Accuracy} 

    View the IQ measured polar     

    graph results (Figure 8)

[View/Display] {I/Q Measured Polar Graph}

    View the IQ error results 

    (Figure 9) 

[View/Display] {IQ Error}
To view the MER vs. symbol results in the top 

left window, press [AMPTD Y Scale], {More 

1 of 2} and toggle the {Scale Type} to MER.

    Turn the equalizer on to view  

    the channel frequency  

    response and channel impulse  

    response results 

[Meas Setup] {Adaptive Equalizer} {Filter On}

    View the channel frequency  

    response results (Figure 10)

[View/Display] {Channel Frequency 

Response}

    View the channel impulse  

    response results (Figure 11)

[View/Display] {Channel Impulse 

Response}

    View the BER results 

    (Figure 12)

[View/Display] {BER}
If the signal under test are Null TS packet, 

press [Meas Setup], {Decode} and toggle the 

{Payload} to NullPacket. 

    View the result metrics     

    (Figure 13)

[View/Display] {Result Metrics}

Available views and traces in  

modulation accuracy:

 – I/Q measured polar graph view 

(Figure 8): 

 – Results metrics (left)

 – I/Q measured polar graph (right)

 – I/Q error view (Figure 9): A view 

of computed error vector between 

corresponding symbol points in the 

I/Q measured and I/Q reference 

signals

 – EVM/MER vs. symbol (top left)

 – Mag error vs. symbol (top right)

 – Phase error vs. symbol (bottom 

left)

 – Results metrics (bottom right) 

 – Channel frequency response view 

(Figure 10):

 – Amplitude vs. sub-carrier (top)

 – Phase vs. sub-carrier (middle)

 – Group delay vs. sub-carrier  

(bottom)

 – Channel impulse response view 

(Figure 11): a view of the state of 

the channel

 – BER view (Figure 12): summary of 

non real-time BER results

 – Result metrics view (Figure 13): 

summary of all the result metrics
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Figure 8. 

IQ measured polar 

graph view

Figure 9.

IQ error view

Figure 10.

Channel frequency 

response view
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Figure 11.

Channel impulse 

response view

Figure 12.

BER view

Figure 13.

Result metrics view
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Instructions Keystrokes

On the X-Series Digital Cable TV mode:

    Active the monitor spectrum measurement [Meas] {Monitor Spectrum}

Demonstration 7:

Monitor spectrum 

The monitor spectrum measurement is used as a quick, convenient means of 

looking at the entire spectrum. While the look and feel is similar to the spectrum 

analyzer mode, the functionality is greatly reduced for easy operation. The main 

purpose of the measurement is to show the spectrum.

Figure 14. 

Monitor spectrum 

measurement
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Figure 15.

RF envelope view

Figure 16.

I/Q waveform view

Instructions Keystrokes

On the X-Series Digital Cable TV mode:

    Active the IQ waveform measurement

    (RF envelope view default) (Figure 15)

[Meas] {IQ Waveform} 

    View the IQ waveform (Figure 16) [View/Display] {I/Q Waveform}

Demonstration 8:

IQ waveform 

Waveform measurement is a generic measurement for viewing the input signal  

waveforms in the time domain. Under this measurement there is also an I/Q 

waveform window that shows I and Q signal waveforms in parameters of voltage  

versus time to disclose the voltages, which comprise the complex modulated 

waveform of a digital signal. The waveform measurement can also be used to 

perform general-purpose power measurements with a high degree of accuracy.
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