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Warranty
The material contained in this document is 
provided "as is," and is subject to being 
changed, without notice, in future editions. 
Further, to the maximum extent permitted 
by applicable law, Keysight disclaims all 
warranties, either express or implied, with 
regard to this manual and any information 
contained herein, including but not limited 
to the implied warranties of merchantability 
and fitness for a particular purpose. 
Keysight shall not be liable for errors or for 
incidental or consequential damages in 
connection with the furnishing, use, or 
performance of this document or of any 
information contained herein. Should 
Keysight and the user have a separate 
written agreement with warranty terms 
covering the material in this document that 
conflict with these terms, the warranty 

terms in the separate agreement shall 
control.

Technology License
The hardware and/or software described in 
this document are furnished under a license 
and may be used or copied only in 
accordance with the terms of such license.

U.S. Government Rights
The Software is "commercial computer 
software," as defined by Federal Acquisition 
Regulation ("FAR") 2.101. Pursuant to FAR 
12.212 and 27.405-3 and Department of 
Defense FAR Supplement ("DFARS") 
227.7202, the U.S. government acquires 
commercial computer software under the 
same terms by which the software is 
customarily provided to the public. 
Accordingly, Keysight provides the Software 
to U.S. government customers under its 
standard commercial license, which is 
embodied in its End User License Agreement 
(EULA), a copy of which can be found at 
www.keysight.com/find/sweula. The 
license set forth in the EULA represents the 
exclusive authority by which the U.S. 
government may use, modify, distribute, or 
disclose the Software. The EULA and the 
license set forth therein, does not require or 
permit, among other things, that Keysight: (1) 
Furnish technical information related to 
commercial computer software or 
commercial computer software 
documentation that is not customarily 
provided to the public; or (2) Relinquish to, or 
otherwise provide, the government rights in 
excess of these rights customarily provided 
to the public to use, modify, reproduce, 
release, perform, display, or disclose 
commercial computer software or 
commercial computer software 
documentation. No additional government 
requirements beyond those set forth in the 
EULA shall apply, except to the extent that 
those terms, rights, or licenses are explicitly 
required from all providers of commercial 
computer software pursuant to the FAR and 

the DFARS and are set forth specifically in 
writing elsewhere in the EULA. Keysight shall 
be under no obligation to update, revise or 
otherwise modify the Software. With respect 
to any technical data as defined by FAR 
2.101, pursuant to FAR 12.211 and 27.404.2 
and DFARS 227.7102, the U.S. government 
acquires no greater than Limited Rights as 
defined in FAR 27.401 or DFAR 227.7103-5 
(c), as applicable in any technical data.

Safety Notices

CAUTION

A CAUTION notice denotes a hazard. 
It calls attention to an operating 
procedure, practice, or the like that, 
if not correctly performed or 
adhered to, could result in damage 
to the product or loss of important 
data. Do not proceed beyond a 
CAUTION notice until the indicated 
conditions are fully understood and 
met.

WARNING

A WARNING notice denotes a 
hazard. It calls attention to an 
operating procedure, practice, or 
the like that, if not correctly 
performed or adhered to, could 
result in personal injury or death. 
Do not proceed beyond a WARNING 
notice until the indicated 
conditions are fully understood and 
met.

http://www.keysight.com/find/sweula
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InfiniiVision DSOX1204A/G Oscilloscopes—At a Glance

Table 1 DSOX1204A/G Model Numbers, Bandwidths 

Model: DSOX1204A DSOX1204G

Channels: 4

Bandwidth: 70 MHz

Bandwidth upgrades: 70 MHz to 100 MHz with D1200BW1A upgrade

70 MHz to 200 MHz with D1200BW2A upgrade

100 MHz to 200 MHz with D1200BW3A upgrade

Sampling rate: 2 GSa/s (interleaved), 1 GSa/s (non-interleaved)

Memory: 1 Mpts

Segmented memory: Yes

Waveform generator: No Yes (20 MHz)

Mask/limit test: Yes
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The Keysight InfiniiVision DSOX1204A/G oscilloscopes deliver these features:

• 7 inch WVGA display.

• 50,000 waveforms/second update rate.

• All knobs are pushable for making quick selections.

• Trigger types: edge, pulse width, video, pattern, rise/fall time, and setup and 
hold.

• Serial decode/trigger options for: I2C, UART/RS232, CAN, LIN, and SPI.

• Math waveforms: add, subtract, multiply, divide, FFT (magnitude and phase), 
and low-pass filter.

• Reference waveforms (2) for comparing with other channel or math waveforms.

• Many built-in measurements.

• G-suffix models have built-in waveform generator with: sine, square, ramp, 
pulse, DC, noise.

• USB/LAN ports makes printing, saving, and sharing data easy.

• A Quick Help system is built into the oscilloscope. Press and hold any key to 
display Quick Help. Complete instructions for using the quick help system are 
given in "Access the Built-In Quick Help" on page 29.

For more information about InfiniiVision oscilloscopes, see: 
www.keysight.com/find/scope

http://www.keysight.com/find/scope
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In This Guide
This guide shows how to use the InfiniiVision DSOX1204A/G oscilloscopes.

When unpacking and using the 
oscilloscope for the first time, see:

• Chapter 1, “Getting Started,” starting on page 11

When displaying waveforms and 
acquired data, see:

• "Running, Stopping, and Making Single 
Acquisitions (Run Control)" on page 32

• "Horizontal Controls" on page 33

• "Vertical Controls" on page 36

• "Analog Bus Display" on page 39

• "FFT Spectral Analysis" on page 40

• "Math Waveforms" on page 44

• "Reference Waveforms" on page 46

• "Display Settings" on page 47

When setting up triggers or changing 
how data is acquired, see:

• "Triggers" on page 50

• "Acquisition Control" on page 54

Making measurements and analyzing 
data:

• "Cursors" on page 61

• "Measurements" on page 63

• "Mask Testing" on page 65

• "Digital Voltmeter" on page 72

• "Frequency Response Analysis" on page 73

When using the built-in waveform 
generator, see:

• "Waveform Generator" on page 75

When using licensed serial bus 
decode and triggering features, see:

• "Serial Bus Decode/Trigger" on page 76

When saving, recalling, or printing, 
see:

• "Save/Recall (Setups, Screens, Data)" on page 82

• "Print (Screens)" on page 85
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When using the oscilloscope's utility 
functions, see:

• "Utility Settings" on page 87

• "Web Interface" on page 93

For reference information, see: • "Specifications and Characteristics" on page 95

• "Environmental Conditions" on page 96

• "Probes and Accessories" on page 97

• "Software and Firmware Updates" on page 98

• "Acknowledgements" on page 99

• "Product Markings and Regulatory 
Information" on page 100

NOTE Abbreviated instructions for pressing a series of keys and softkeys

Instructions for pressing a series of keys are written in an abbreviated manner. Instructions for 
pressing [Key1], then pressing Softkey2, then pressing Softkey3 are abbreviated as follows:

Press [Key1]> Softkey2 > Softkey3.

The keys may be a front panel [Key] or a Softkey. Softkeys are the six keys located directly 
below the oscilloscope display.
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This chapter describes the steps you take when using the oscilloscope for the first 
time.
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Inspect the Package Contents

• Inspect the shipping container for damage.

If your shipping container appears to be damaged, keep the shipping container 
or cushioning material until you have inspected the contents of the shipment 
for completeness and have checked the oscilloscope mechanically and 
electrically.

• Verify that you received the following items and any optional accessories you 
may have ordered:

• InfiniiVision DSOX1204A/G oscilloscope.

• Power cord (country of origin determines specific type).

• Oscilloscope probes (one for each analog input channel).
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Power-On the Oscilloscope

Power
Requirements

Line voltage, frequency, and power:

• ~Line 100-120 Vac, 50/60/400 Hz

• 100-240 Vac, 50/60 Hz

• 50 W max

Ventilation
Requirements

The air intake and exhaust areas must be free from obstructions. Unrestricted air 
flow is required for proper cooling. Always ensure that the air intake and exhaust 
areas are free from obstructions.

The fan draws air in from the left side and bottom of the oscilloscope and pushes it 
out behind the oscilloscope.

When using the oscilloscope in a bench-top setting, provide at least 2" clearance 
at the sides and 4" (100 mm) clearance above and behind the oscilloscope for 
proper cooling.

To power-on the
oscilloscope

1 Connect the power cord to the rear of the oscilloscope, then to a suitable AC 
voltage source. Route the power cord so the oscilloscope's feet and legs do not 
pinch the cord.

2 The oscilloscope automatically adjusts for input line voltages in the range 100 
to 240 VAC. The line cord provided is matched to the country of origin.

3 Press the power switch.

The power switch is located on the lower left corner of the front panel. The 
oscilloscope will perform a self-test and will be operational in a few seconds.

WARNING Always use a grounded power cord. Do not defeat the power cord ground.
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Connect Probes to the Oscilloscope

1 Connect the oscilloscope probe to an oscilloscope channel BNC connector.

2 Connect the probe's retractable hook tip to the point of interest on the circuit or 
device under test. Be sure to connect the probe ground lead to a ground point 
on the circuit.

CAUTION  Maximum input voltage at analog inputs

150 Vrms, 200 Vpk

CAUTION  Do not float the oscilloscope chassis

Defeating the ground connection and "floating" the oscilloscope chassis will probably 
result in inaccurate measurements and may also cause equipment damage. The probe 
ground lead is connected to the oscilloscope chassis and the ground wire in the power 
cord. If you need to measure between two live points, use a differential probe with 
sufficient dynamic range.

WARNING Do not negate the protective action of the ground connection to the oscilloscope. The 
oscilloscope must remain grounded through its power cord. Defeating the ground 
creates an electric shock hazard.
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Input a Waveform

The Probe Comp signal is used for compensating probes.

1 Connect an oscilloscope probe from channel 1 to the Demo, Probe Comp terminal 
on the front panel.

2 Connect the probe's ground lead to the ground terminal (next to the Demo 
terminal).

WARNING A voltage source should never be connected to the ground terminal of this instrument. 
If, for any reason, the Protective Conductor Terminal is disconnected or not functioning 
properly and a voltage source is connected to the equipment's ground terminals, the 
entire chassis will be at the voltage potential of the voltage source, and the operator or 
bystanders could receive an electric shock.
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Recall the Default Oscilloscope Setup

To recall the default oscilloscope setup:

1 Press [Default Setup].

The default setup restores the oscilloscope's default settings. This places the 
oscilloscope in a known operating condition.

In the Save/Recall menu, there are also options for restoring the complete factory 
settings or performing a secure erase (see "Save/Recall (Setups, Screens, 
Data)" on page 82).
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Use Autoscale

Use [Auto Scale] to automatically configure the oscilloscope to best display the 
input signals.

1 Press [Auto Scale].

You should see a waveform on the oscilloscope's display similar to this:

2 If you want to return to the oscilloscope settings that existed before, press Undo 
Autoscale.

3 If you want to enable "fast debug" autoscaling, change the channels 
autoscaled, or preserve the acquisition mode during autoscale, press Fast 
Debug, Channels, or Acq Mode.

These are the same softkeys that appear in the Autoscale Preferences menu. 
See "Utility Settings" on page 87.

If you see the waveform, but the square wave is not shaped correctly as shown 
above, perform the procedure "Compensate Passive Probes" on page 18.

If you do not see the waveform, make sure the probe is connected securely to the 
front panel channel input BNC and to the Demo/Probe Comp terminal.
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Compensate Passive Probes

Each oscilloscope passive probe must be compensated to match the input 
characteristics of the oscilloscope channel to which it is connected. A poorly 
compensated probe can introduce significant measurement errors.

1 Input the Probe Comp signal (see "Input a Waveform" on page 15).

2 Press [Default Setup] to recall the default oscilloscope setup (see "Recall the 
Default Oscilloscope Setup" on page 16).

3 Press [Auto Scale] to automatically configure the oscilloscope for the Probe 
Comp signal (see "Use Autoscale" on page 17).

4 Press the channel key to which the probe is connected ([1], [2], etc.).

5 In the Channel Menu, press Probe.

6 In the Channel Probe Menu, press Probe Check; then, follow the instructions 
on-screen.

If necessary, use a nonmetallic tool (supplied with the probe) to adjust the 
trimmer capacitor on the probe for the flattest pulse possible.

On some probes (like the N2140/42A probes), the trimmer capacitor is located 
on the probe BNC connector. On other probes (like the N2862/63/90 probes), 
the trimmer capacitor is a yellow adjustment on the probe tip.

7 Connect probes to all other oscilloscope channels.

NOTE If your probe has a configurable attenuation setting (like the N2140/42A probes do), the 10:1 
setting must be used for probe compensation.

Perfectly compensated 

Over compensated 

Under compensated
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8 Repeat the procedure for each channel.



20 Keysight InfiniiVision DSOX1204A/G Oscilloscopes User's Guide

1 Getting Started
 

Learn the Front Panel Controls and Connectors

On the front panel, key refers to any key (button) you can press.

Softkey specifically refers to the six keys next to the display. Menus and softkey 
labels appear on the display when other front panel keys are pressed. Softkey 
functions change as you navigate through the oscilloscope's menus.

For the following figure, refer to the numbered descriptions in the table that 
follows.

6. [Auto Scale] key5. [Default Setup] key

10. Tools keys

1. Power
   switch

2. Softkeys

3. [Intensity]
   key

4. Entry knob

11. Trigger controls

12. Vertical controls

19. Demo/Probe Comp
and Ground

terminals

15. [Help] key20. USB
Host
port

13. [Wave Gen] key

8. Run Control keys

9. Measure controls

7. Horizontal and Acquisition controls

16. Math
function
controls

18. Waveform
generator

output

17. Analog
channel
inputs

14. [FFT] key

1. Power switch Press once to switch power on; press again to switch power off. See "Power-On the 
Oscilloscope" on page 13.

2. Softkeys The functions of these keys change based upon the menus shown on the display next to the keys.

The Back key moves back in the softkey menu hierarchy. At the top of the hierarchy, the 

Back key turns the menus off, and oscilloscope information is shown instead.

3. [Intensity] key Press the key to illuminate it. When illuminated, turn the Entry knob to adjust waveform intensity.

You can vary the intensity control to bring out signal detail, much like an analog oscilloscope.

Back

Back
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4. Entry knob The Entry knob is used to select items from menus and to change values. The function of the Entry 
knob changes based upon the current menu and softkey selections.

Note that when the Entry knob symbol appears on a softkey, you can use the Entry knob, to 
select values.

Often, rotating the Entry knob is enough to make a selection. Sometimes, you can push the Entry 
knob to enable or disable a selection. Also, pushing the Entry knob can also make popup menus 
disappear.

5. [Default Setup] 
key

Press this key to restore the oscilloscope's default settings (details on "Recall the Default 
Oscilloscope Setup" on page 16).

6. [Auto Scale] 
key

When you press the [AutoScale] key, the oscilloscope will quickly determine which channels have 
activity, and it will turn these channels on and scale them to display the input signals. See "Use 
Autoscale" on page 17.

7. Horizontal and 
Acquisition 
controls

The Horizontal and Acquisition controls consist of:

• Horizontal scale knob — Turn the knob in the Horizontal section that is marked  to 
adjust the time/div setting. The symbols under the knob indicate that this control has the effect 
of spreading out or zooming in on the waveform using the horizontal scale.

Push the horizontal scale knob to toggle between fine and coarse adjustment.

• Horizontal position knob — Turn the knob marked  to pan through the waveform data 
horizontally. You can see the captured waveform before the trigger (turn the knob clockwise) or 
after the trigger (turn the knob counterclockwise). If you pan through the waveform when the 
oscilloscope is stopped (not in Run mode) then you are looking at the waveform data from the last 
acquisition taken.

• [Acquire] key — Press this key to open the Acquire menu where you can select the Normal, XY, and 
Roll time modes, enable or disable Zoom, and select the trigger time reference point.

Also you can select the Normal, Peak Detect, Averaging, or High Resolution acquisition modes 
and use segmented memory (see "Selecting the Acquisition Mode" on page 54).

• Zoom  key — Press the  zoom key to split the oscilloscope display into Normal and Zoom 
sections without opening the Acquire menu.

For more information see "Horizontal Controls" on page 33.
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8. Run Control 
keys

When the [Run/Stop] key is green, the oscilloscope is running, that is, acquiring data when trigger 
conditions are met. To stop acquiring data, press [Run/Stop].

When the [Run/Stop] key is red, data acquisition is stopped. To start acquiring data, press 
[Run/Stop].

To capture and display a single acquisition (whether the oscilloscope is running or stopped), press 
[Single]. The [Single] key is yellow until the oscilloscope triggers.

For more information, see "Running, Stopping, and Making Single Acquisitions (Run 
Control)" on page 32.

9. Measure 
controls

The measure controls consist of:

• [Analyze] key — Press this key to access analysis features like:

• Trigger level setting.

• Measurement threshold setting.

• Video trigger automatic set up and display.

• Display a bus made up of the analog channel inputs where channel 1 is the least significant bit 
and channel 4 is the most significant bit. See also "Analog Bus Display" on page 39.

• Enable serial bus decodes. See also "Serial Bus Decode/Trigger" on page 76.

• Reference waveforms (see "Reference Waveforms" on page 46).

• Mask testing (see "Mask Testing" on page 65).

• Digital voltmeter (see "Digital Voltmeter" on page 72).

• Frequency response analysis on models with a built-in waveform generator (see "Frequency 
Response Analysis" on page 73).

• [Meas] key — Press this key to access a set of predefined measurements. See 
"Measurements" on page 63.

• [Cursors] key — Press this key to open a menu that lets you select the cursors mode and source.

• Cursors knob — Push this knob select cursors from a popup menu. Then, after the popup menu 
closes (either by timeout or by pushing the knob again), rotate the knob to adjust the selected 
cursor position.
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10. Tools keys The Tools keys consist of:

• [Save/Recall] key — Press this key to save oscilloscope setups, screen images, waveform data, or 
mask files or to recall setups, mask files or reference waveforms. See "Save/Recall (Setups, 
Screens, Data)" on page 82.

• [Utility] key — Press this key to access the Utility menu, which lets you configure the 
oscilloscope's I/O settings, use the file explorer, set preferences, access the service menu, and 
choose other options. See "Utility Settings" on page 87.

• [Display] key — Press this key to access the menu where you can enable persistence, adjust the 
display grid (graticule) intensity, label waveforms, add an annotation, and clear the display (see 
"Display Settings" on page 47).

• [Quick Action] key — Press this key to perform the selected quick action: measure all snapshot, 
print, save, recall, freeze display. and more. See "Configuring the [Quick Action] Key" on 
page 92.

• [Save to USB] key — Press this key to perform a quick save to a USB storage device.

11. Trigger controls The Trigger controls determine how the oscilloscope triggers to capture data. These controls consist 
of:

• Level knob — Turn the Level knob to adjust the trigger level for a selected analog channel.

Push the knob to set the level to the waveform's 50% value. If AC coupling is used, pushing the 
Level knob sets the trigger level to about 0 V.

The position of the trigger level for the analog channel is indicated by the trigger level icon  (if 
the analog channel is on) at the far left side of the display. The value of the analog channel trigger 
level is displayed in the upper-right corner of the display.

• [Trigger] key — Press this key to select the trigger type (edge, pulse width, video, etc.). See 
"Trigger Types" on page 50. You can also set options that affect all trigger types. See "Trigger 
Mode, Coupling, Reject, Holdoff" on page 51.

• [Force] key — Causes a trigger (on anything) and displays the acquisition.

This key is useful in the Normal trigger mode where acquisitions are made only when the trigger 
condition is met. In this mode, if no triggers are occurring (that is, the "Trig'd?" indicator is 
displayed), you can press [Force] to force a trigger and see what the input signals look like.

T
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12. Vertical 
controls

The Vertical controls consist of:

• Analog channel on/off keys — Use these keys to switch a channel on or off, or to access a 
channel's menu in the softkeys. There is one channel on/off key for each analog channel.

• Vertical scale knob — Use the knob marked  to change the vertical sensitivity (gain) for 
the selected analog input channel.

Push the vertical scale knob to toggle between fine and coarse adjustment.

The default mode for expanding the signal is about the ground level of the channel; however, you 
can change this to expand about the center of the display.

• Vertical position knob — Use this knob to change the selected analog input channel waveform 
vertical position on the display.

The voltage value momentarily displayed in the upper right portion of the display represents the 

voltage difference between the vertical center of the display and the ground level ( ) icon. It 
also represents the voltage at the vertical center of the display if vertical expansion is set to 
expand about ground.

For more information, see "Vertical Controls" on page 36.

13. [Wave Gen] key On G-suffix models that have a built-in waveform generator, press this key to access waveform 
generator functions. See "Waveform Generator" on page 75.

14. [FFT] key Provides access to FFT spectrum analysis function. See "FFT Spectral Analysis" on page 40.

15. [Help] key Opens the Help menu where you can display overview help topics and select the Language. See also 
"Access the Built-In Quick Help" on page 29.

16. Math function 
controls

The Math function controls consist of:

• [Math] key — provides access to math (add, subtract, etc.) waveform functions. See "Math 
Waveforms" on page 44.

• Vertical scale knob — Use the knob marked  to change the vertical sensitivity (as with 
the analog channel vertical controls).

• Vertical position knob — Use the knob to change a math function waveform's vertical position on 
the display (as with the analog channel vertical controls).

17. Analog channel 
inputs

Attach oscilloscope probes or BNC cables to these BNC connectors.

In the InfiniiVision 1000 X-Series oscilloscopes, the analog channel inputs have 1 MΩ impedance.

Also, there is no automatic probe detection, so you must properly set the probe attenuation for 
accurate measurement results. See "Setting Analog Channel Probe Options" on page 38.



Getting Started 1

Keysight InfiniiVision DSOX1204A/G Oscilloscopes User's Guide 25

 

Front Panel Overlays for Different Languages

Front panel overlays, which have translations for the English front panel keys and 
label text, are available in many languages. The appropriate overlay is included 
when the localization option is chosen at time of purchase.

To install a front panel overlay:

1 Gently pull on the front panel knobs to remove them.

2 Insert the overlay's side tabs into the slots on the front panel.

3 Reinstall the front panel knobs.

18. Waveform 
generator 
output

On G-suffix models, the built-in waveform generator can output sine, square, ramp, pulse, DC, or 
noise on the Gen Out BNC. Press the [Wave Gen] key to set up the waveform generator. See 
"Waveform Generator" on page 75.

You can also send the trigger output signal or the mask test failure signal to the Gen Out BNC 
connector. See "Utility Settings" on page 87.

19. Demo/Probe 
Comp, Ground 
terminals

• Demo terminal — This terminal outputs the Probe Comp signal which helps you match a probe's 
input capacitance to the oscilloscope channel to which it is connected. See "Compensate 
Passive Probes" on page 18. The oscilloscope can also output demo or training signals on this 
terminal.

• Ground terminal — Use the ground terminal for oscilloscope probes connected to the Demo/Probe 
Comp terminal. See the warning in "Input a Waveform" on page 15.

20. USB Host port This port is for connecting USB mass storage devices or printers to the oscilloscope.

Connect a USB compliant mass storage device (flash drive, disk drive, etc.) to save or recall 
oscilloscope setup files and reference waveforms or to save data and screen images. See 
"Save/Recall (Setups, Screens, Data)" on page 82.

To print, connect a USB compliant printer. For more information about printing see "Print 
(Screens)" on page 85.

You can also use the USB port to update the oscilloscope's system software when updates are 
available.

NOTE: You must Eject a USB mass storage device before unplugging it; otherwise, the device will be 
marked as needing repair when connecting to a computer with the Windows operating system (even 
though there are no harmful effects to the device).

CAUTION:Do not connect a host computer to the oscilloscope's USB host port. A host computer 
sees the oscilloscope as a device, so connect the host computer to the oscilloscope's device port (on 
the rear panel). See "Learn the Rear Panel Connectors" on page 26.
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Learn the Rear Panel Connectors

For the following figure, refer to the numbered descriptions in the table that 
follows.

3. USB Device port

1. Power cord connector

2. Kensington lock hole

5. Ext Trig input

4. LAN port

1. Power cord 
connector

Attach the power cord here.

2. Kensington lock 
hole

This is where you can attach a Kensington lock for securing the instrument.

3. USB Device 
port

This port is for connecting the oscilloscope to a host PC. You can issue remote commands from a 
host PC to the oscilloscope via the USB device port. See "Utility Settings" on page 87.

4. LAN port Lets you print to network printers (see "Print (Screens)" on page 85), access the oscilloscope's 
built-in web server, and issue remote commands. See "Web Interface" on page 93, "Accessing 
the Web Interface" on page 93, and "Utility Settings" on page 87.

15. Ext Trig input External trigger input BNC connector. See "External Trigger Input" on page 53 for an explanation 
of this feature.
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Learn the Oscilloscope Display

The oscilloscope display contains acquired waveforms, setup information, 
measurement results, and the softkey definitions.

Figure 1 Interpreting the oscilloscope display

Analog channel
sensitivity

Status line

Analog
channels
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levels

Trigger level

Trigger point,
time reference

Delay
time

Time/
div

Run/Stop
status

Trigger
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Trigger
source

Measurements

Trigger level
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Other
waveforms

Status line The top line of the display contains vertical, horizontal, and trigger setup information.

Display area The display area contains the waveform acquisitions, channel identifiers, and analog trigger, and 
ground level indicators. Each analog channel's information appears in a different color.

Signal detail is displayed using 256 levels of intensity.

For more information about display modes see "Display Settings" on page 47.
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Softkey labels and 
information area

When most front panel keys are pressed, short menu names and softkey labels appear in this area. 
The labels describe the softkey functions. Typically, softkeys let you set up additional parameters for 
the selected mode or menu.

Pressing the Back key returns through the menu hierarchy until softkey labels are off and the 
information area is displayed. The information area contains acquisition, analog channel, math 
function, and reference waveform information.

You can also specify that softkey menus turn off automatically after a specified timeout period 
([Utility] > Options > Menu Timeout). 

Pressing the Back key when the information area is displayed returns to the most recent menu 
displayed.

Measurements area When measurements or cursors are turned on, this area contains automatic measurement and cursor 
results.

When measurements are turned off, this area displays additional status information describing 
channel offset and other configuration parameters.

Back

Back
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Access the Built-In Quick Help

To view Quick Help 1 Press and hold the key, softkey, or knob for which you would like to view help.

Quick Help remains on the screen until another key is pressed or a knob is turned.

To select the user
interface and

Quick Help
language

To select the user interface and Quick Help language:

1 Press [Help], then press the Language softkey.

2 Turn the Entry knob until the desired language is selected.
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Running, Stopping, and Making Single Acquisitions (Run Control)

To display the results of multiple acquisitions, use persistence. See "Display 
Settings" on page 47.

Single vs. Running
and Record Length

The maximum data record length is greater for a single acquisition than when the 
oscilloscope is running (or when the oscilloscope is stopped after running):

• Single — Single acquisitions always use the maximum memory available — at 
least twice as much memory as acquisitions captured when running — and the 
oscilloscope stores at least twice as many samples. At slower time/div settings, 
because there is more memory available for a single acquisition, the acquisition 
has a higher effective sample rate.

• Running — When running (versus taking a single acquisition), the memory is 
divided in half. This lets the acquisition system acquire one record while 
processing the previous acquisition, dramatically improving the number of 
waveforms per second processed by the oscilloscope. When running, a high 
waveform update rate provides the best representation of your input signal.

To acquire data with the longest possible record length, press the [Single] key.

For more information on settings that affect record length, see "Length 
Control" on page 83.

Table 2 Run Control Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Run acquisitions [Run/Stop] (the key is green when running)

Stop acquisitions [Run/Stop] (the key is red when stopped)

Single acquisition [Single] (the key is yellow until the oscilloscope triggers)

If the oscilloscope does not trigger, you can press [Force Trigger] to trigger on anything and make a 
single acquisition.
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Horizontal Controls

Horizontal Knobs and Keys

Horizontal Softkey Controls

The following figure shows the Acquire menu which appears after pressing the 
[Acquire] key.
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The time reference is indicated at the top of the display grid by a small hollow 
triangle (∇). Turning the Horizontal scale knob expands or contracts the waveform 
about the time reference point (∇).

The trigger point, which is always time = 0, is indicated at the top of the display 
grid by a small solid triangle (▼).

The delay time is the time of the reference point with respect to the trigger. 
Turning the Horizontal position ( ) knob moves the trigger point (▼) to the left 
or right of the time reference (∇) and displays the delay time.

The Acquire menu lets you select the time mode (Normal, XY, or Roll), enable 
Zoom, set the time base fine control (vernier), and specify the time reference.

See Also "Acquisition Control" on page 54

Zoom

The Zoom window is a magnified portion of the normal time/div window. To turn 

on (or off) Zoom, press the  zoom key (or press the [Acquire] key and then the 
Zoom softkey).

Table 3 Horizontal Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Time mode [Acquire] > Time Mode (Normal, XY, or Roll)

XY time mode [Acquire] > Time Mode, XY

Channel 1 is the X-axis input, channel 2 is the Y-axis input. The Z-axis input (Ext Trig) turns the trace 
on and off (blanking). When Z is low (<1.4 V), Y versus X is displayed; when Z is high (>1.4 V), the 
trace is turned off.

Measuring the phase difference between two signals of the same frequency with the Lissajous 
method is a common use of the XY display mode (see the "XY Display Mode Example" description at 
www.keysight.com/find/xy-display-mode).

Roll time mode [Acquire] > Time Mode, Roll

Zoom
[Acquire] > Zoom (or press the  zoom key)

Time reference [Acquire] > Time Ref (Left, Center, Right)

http://www.keysight.com/find/xy-display-mode
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Vertical Controls

Vertical Knobs and Keys

Vertical Softkey Controls

The following figure shows the Channel 1 menu that appears after pressing the [1] 
channel key.

NOTE Keysight recommends always scaling the signal so that the entire waveform is contained 
between the top and bottom of the display.

For proper operation of the 1000 X-Series oscilloscope, the channel inputs must not be 
overdriven more than ±8 divisions. Exceeding this limit may result in signals that appear 
incorrect and may increase crosstalk between the input channels.

NOTE To minimize crosstalk between input channels, make sure the channel is not overdriven. Also, 
connecting a probe or cable to a channel will reduce crosstalk.
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The ground level of the signal for each displayed analog channel is identified by 

the position of the  icon at the far-left side of the display.

Channel,
Volts/div

Channel 1
ground
level

Trigger
source

Trigger level
or threshold 

Channel 2
ground
level

Table 4 Vertical Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Channel coupling [1/2/3/4] > Coupling (DC or AC)

Note that Channel Coupling is independent of Trigger Coupling. To change trigger coupling see 
"Trigger Mode, Coupling, Reject, Holdoff" on page 51.

Channel bandwidth 
limit

[1/2/3/4] > BW Limit

Vertical scale fine 
adjustment

[1/2/3/4] > Fine

Channel Invert [1/2/3/4] > Invert
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Setting Analog Channel Probe Options

In the Channel menu, the Probe softkey opens the Channel Probe menu.

This menu lets you select additional probe parameters such as attenuation factor 
and units of measurement for the connected probe.

CAUTION For correct measurements, you must match the oscilloscope's probe attenuation factor 
settings with the attenuation factors of the probes being used.

Table 5 Probe Features

Channel Probe Menu Feature Front Panel Key/Softkey Location (see built-in help for more information)

Channel units [1/2/3/4] > Probe > Units (Volts, Amps)

Probe attenuation
[1/2/3/4] > Probe > Probe, Ratio/Decibels, Entry knob

Changes the vertical scale so that measurement results reflect the actual 
voltage levels at the probe tip.

Channel skew
[1/2/3/4] > Probe > Skew, Entry knob 

Probe check [1/2/3/4] > Probe > Probe Check

Guides you through the process of compensating passive probes (such as 
the N2140A, N2142A, N2862A/B, N2863A/B, N2889A, N2890A, 10073C, 
10074C, or 1165A probes).
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Analog Bus Display

You can display a bus made up of the analog channel inputs. Any of the input 
channels can be assigned to the bus. The bus values display appears at the 
bottom of the graticule. Channel 1 is the least significant bit and channel 4 is the 
most significant bit.

Table 6 Analog Bus Display Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Analog bus, display
[Analyze] > Features, Entry knob to select Analog Bus Analysis, push Entry knob to enable or 
disable

Analog bus, channel 
assignment [Analyze] > Channel, Entry knob, push Entry knob to make or clear assignment

Analog bus, value 
number base [Analyze] > Base, Entry knob (Hex, Binary)

Analog bus, threshold 
source [Analyze] > Source, Entry knob (1, 2, 3, 4), push Entry knob to toggle between source and 

threshold

Analog bus, threshold 
level for selected 
source

[Analyze] > Threshold, Entry knob, push Entry knob to toggle between source and threshold
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FFT Spectral Analysis

FFT is used to compute the fast Fourier transform using analog input channels. 
FFT takes the digitized time record of the specified source and transforms it to the 
frequency domain.

When the FFT function is selected, the FFT spectrum is plotted on the oscilloscope 
display as magnitude in dBV versus frequency. The readout for the horizontal axis 
changes from time to frequency (Hertz) and the vertical readout changes from 
volts to dB.

Use the FFT function to find crosstalk problems, to find distortion problems in 
analog waveforms caused by amplifier non-linearity, or for adjusting analog filters.

FFT Measurement Hints

The number of points acquired for the FFT record can be up to 65,536, and when 
frequency span is at maximum, all points are displayed. Once the FFT spectrum is 
displayed, the frequency span and center frequency controls are used much like 
the controls of a spectrum analyzer to examine the frequency of interest in greater 
detail. Place the desired part of the waveform at the center of the screen and 
decrease frequency span to increase the display resolution. As frequency span is 
decreased, the number of points shown is reduced, and the display is magnified.

While the FFT spectrum is displayed, use the [FFT] and [Cursors] keys to switch 
between measurement functions and frequency domain controls in FFT Menu.

Table 7 FFT Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

FFT span/center [FFT] > Span

[FFT] > Center

FFT window [FFT] > Settings > Window (Hanning, Flat Top, Rectangular, Blackman Harris, see also "FFT 
Spectral Leakage" on page 43)

FFT vertical units [FFT] > Settings > Vertical Units (Decibels, VRMS)

FFT auto setup [FFT] > Settings > Auto Setup

FFT waveform, scale [FFT], turn the Math vertical scale knob 

FFT waveform, offset [FFT], turn the Math vertical position knob 
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Decreasing the effective sampling rate by selecting a greater time/div setting will 
increase the low frequency resolution of the FFT display and also increase the 
chance that an alias will be displayed. The resolution of the FFT is the effective 
sample rate divided by the number of points in the FFT. The actual resolution of 
the display will not be this fine as the shape of the window will be the actual 
limiting factor in the FFTs ability to resolve two closely space frequencies. A good 
way to test the ability of the FFT to resolve two closely spaced frequencies is to 
examine the sidebands of an amplitude modulated sine wave.

For the best vertical accuracy on peak measurements:

• Make sure the probe attenuation is set correctly. The probe attenuation is set 
from the Channel Menu if the operand is a channel.

• Set the source sensitivity so that the input signal is near full screen, but not 
clipped.

• Use the Flat Top window.

• Set the FFT sensitivity to a sensitive range, such as 2 dB/division.

For best frequency accuracy on peaks:

• Use the Hanning window.

• Use Cursors to place an X cursor on the frequency of interest.

• Adjust frequency span for better cursor placement.

• Return to the Cursors Menu to fine tune the X cursor.

For more information on the use of FFTs please refer to Keysight Application Note 
243, The Fundamentals of Signal Analysis at 
http://literature.cdn.keysight.com/litweb/pdf/5952-8898E.pdf. Additional 
information can be obtained from Chapter 4 of the book Spectrum and Network 
Measurements by Robert A. Witte.

NOTE FFT Resolution

The FFT resolution is the quotient of the sampling rate and the number of FFT points (fS/N). 
With a fixed number of FFT points (up to 65,536), the lower the sampling rate, the better the 
resolution.

http://literature.cdn.keysight.com/litweb/pdf/5952-8898E.pdf


42 Keysight InfiniiVision DSOX1204A/G Oscilloscopes User's Guide

2 Quick Reference
 

FFT DC Value

The FFT computation produces a DC value that is incorrect. It does not take the 
offset at center screen into account. The DC value is not corrected in order to 
accurately represent frequency components near DC.

FFT Aliasing

When using FFTs, it is important to be aware of frequency aliasing. This requires 
that the operator have some knowledge as to what the frequency domain should 
contain, and also consider the sampling rate, frequency span, and oscilloscope 
vertical bandwidth when making FFT measurements. The FFT resolution (the 
quotient of the sampling rate and the number of FFT points) is displayed directly 
above the softkeys when the FFT Menu is displayed.

Aliasing happens when there are frequency components in the signal higher than 
half the sample rate. Because the FFT spectrum is limited by this frequency, any 
higher components are displayed at a lower (aliased) frequency.

The following figure illustrates aliasing. This is the spectrum of a 990 Hz square 
wave, which has many harmonics. The horizontal time/div setting for the square 
wave sets the sample rate and results in a FFT resolution of 1.91 Hz. The displayed 
FFT spectrum waveform shows the components of the input signal above the 
Nyquist frequency to be mirrored (aliased) on the display and reflected off the right 
edge.

NOTE Nyquist Frequency and Aliasing in the Frequency Domain

The Nyquist frequency is the highest frequency that any real-time digitizing oscilloscope can 
acquire without aliasing. This frequency is half of the sample rate. Frequencies above the 
Nyquist frequency will be under sampled, which causes aliasing. The Nyquist frequency is also 
called the folding frequency because aliased frequency components fold back from that 
frequency when viewing the frequency domain.
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Because the frequency span goes from ≈ 0 to the Nyquist frequency, the best way 
to prevent aliasing is to make sure that the frequency span is greater than the 
frequencies of significant energy present in the input signal.

FFT Spectral Leakage

The FFT operation assumes that the time record repeats. Unless there is an 
integral number of cycles of the sampled waveform in the record, a discontinuity is 
created at the end of the record. This is referred to as leakage. In order to minimize 
spectral leakage, windows that approach zero smoothly at the beginning and end 
of the signal are employed as filters to the FFT. The FFT Menu provides four 
windows: Hanning, Flat Top, Rectangular, and Blackman-Harris. For more 
information on leakage, see Keysight Application Note 243, The Fundamentals of 
Signal Analysis at 
http://literature.cdn.keysight.com/litweb/pdf/5952-8898E.pdf.

Figure 2 Aliasing

http://literature.cdn.keysight.com/litweb/pdf/5952-8898E.pdf
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Math Waveforms

Math functions can be performed on analog channels and lower math functions. 
The resulting math waveform is displayed in light purple.

Table 8 Math Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Math operator [Math] > Operator (Add, Subtract, Multiply, Divide, FFT Magnitude, FFT Phase, Low Pass Filter)

Cascaded math 
functions

[Math] > Source

Math function 
waveforms, scale

[Math], turn the Math vertical scale knob

Math function 
waveforms, offset

[Math], turn the Math vertical position knob

TIP Math Operating Hints

If the analog channel or math function is clipped (not fully displayed on screen) the resulting 
displayed math function will also be clipped.

Once the function is displayed, the analog channel(s) may be turned off for better viewing of 
the math waveform.

The math function waveform can be measured using [Cursors] and/or [Meas].

Table 9 FFT (Magnitude), FFT (Phase) Operator Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Auto setup [Math] > Auto Setup

Span/center [Math] > More > Span

[Math] > More > Center

Window function [Math] > More > Window (Hanning, Flat Top, Rectangular, Blackman Harris, see also "FFT Spectral 
Leakage" on page 43)
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Units for Math Waveforms

Units for each input channel can be set to Volts or Amps using the Units softkey in 
the channel's Probe Menu. Units for math function waveforms are:

A scale unit of U (undefined) will be displayed for math functions when two source 
channels are used and they are set to dissimilar units and the combination of units 
cannot be resolved.

Vertical units [Math] > More > Vertical Units (For FFT (Magnitude): Decibels or V RMS. For FFT (Phase): Radians or 
Degrees.)

FFT (Phase) zero 
phase reference point

[Math] > More > Zero Phase Ref (Trigger, Entire Display)

Table 9 FFT (Magnitude), FFT (Phase) Operator Features (continued)

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Table 10 Low Pass Filter Operator Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Math low-pass filter 
cutoff frequency

[Math] > Bandwidth

Math function Units

add or subtract V or A

multiply V2, A2, or W (Volt-Amp)

FFT Magnitude dB (decibels) or V RMS.

FFT Phase degrees or radians
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Reference Waveforms

Analog channel or math waveforms can be saved to one of two reference 
waveform locations in the oscilloscope. Then, a reference waveform can be 
displayed and compared against other waveforms. One reference waveform can 
be displayed at a time.

Table 11 Reference Waveform Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Reference waveforms, 
display [Analyze] > Features, Entry knob to select R1 or R2, push Entry knob to enable or disable

Reference waveforms, 
save

[Analyze] > Save/Clear > Source, [Analyze] > Save/Clear > Save to

Reference waveforms, 
skew [Analyze] > Skew, Entry knob 

Reference waveforms, 
scale [Analyze] > Scale, Entry knob 

Reference waveforms, 
offset [Analyze] > Offset, Entry knob 

Reference waveforms, 
clear

[Analyze] > Save/Clear > Clear

[Save/Recall] > Default/Erase > Secure Erase

Reference waveforms, 
info

[Analyze] > Save/Clear > Display Info

Reference waveforms, 
info, transparent 
background

[Analyze] > Save/Clear > Transparent

Reference waveforms, 
save/recall from USB 
storage device

[Save/Recall] > Save > Format, Reference Waveform data (*.h5)

[Save/Recall] > Recall > Recall:, Reference Waveform data (*.h5)
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Display Settings

You can adjust the intensity of displayed analog input channel waveforms to 
account for various signal characteristics, such as fast time/div settings and low 
trigger rates.

You can turn on waveform persistence, where the oscilloscope updates the display 
with new acquisitions, but does not immediately erase the results of previous 
acquisitions. All previous acquisitions are displayed with reduced intensity. New 
acquisitions are shown in their normal color with normal intensity.

Table 12 Display Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Waveform intensity 
(for analog input 
channels)

[Intensity] (small round key just below Entry knob)

Increasing the intensity lets you see the maximum amount of noise and infrequently occurring 
events. Reducing the intensity can expose more detail in complex signals.

Persistence, 
single-shot infinite

[Display] > Persistence > Persistence, Off, [Display] > Capture Waveforms

Persistence, infinite [Display] > Persistence > Persistence, ∞ Persistence

Persistence, variable [Display] > Persistence > Persistence, Variable Persistence, [Display] > Persistence > Time, 

Entry knob 

Clear persistence [Display] > Persistence > Clear Persistence

Clear display [Display] > Clear Display

You can also configure the [Quick Action] key to clear the display. See "Configuring the [Quick 
Action] Key" on page 92.

Grid intensity
[Display] > Grid > Intensity, Entry knob

Grid type [Display] > Grid > Grid (Full, mV, IRE)

Waveform labels [Display] > Labels >

See also "To load a list of labels from a text file you create" on page 48.

Label library reset [Utility] > Options > Preferences > Default Library

Annotations [Display] > Annotation >
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To load a list of labels from a text file you create

It may be convenient to create a list of labels using a text editor, then load the 
label list into the oscilloscope. This lets you type on a keyboard rather than edit 
the label list using the oscilloscope's controls.

You can create a list of up to 75 labels and load it into the oscilloscope. Labels are 
added to the beginning of the list. If more than 75 labels are loaded, only the first 
75 are stored.

To load labels from a text file into the oscilloscope:

1 Use a text editor to create each label. Each label can be up to ten characters in 
length. Separate each label with a line feed.

2 Name the file labellist.txt and save it on a USB mass storage device such as a 
thumb drive.

3 Load the list into the oscilloscope using the File Explorer (press [Utility] > File 
Explorer).

Freeze display You must configure the [Quick Action] key to freeze the display. See "Configuring the [Quick 
Action] Key" on page 92.

Many activities, such as adjusting the trigger level, adjusting vertical or horizontal settings, or saving 
data will un-freeze the display.

Table 12 Display Features (continued)

Feature Front Panel Key/Softkey Location (see built-in help for more information)
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NOTE Label List Management

When you press the Library softkey, you will see a list of the last 75 labels used. The list does 
not save duplicate labels. Labels can end in any number of trailing digits. As long as the base 
string is the same as an existing label in the library, the new label will not be put in the library. 
For example, if label A0 is in the library and you make a new label called A12345, the new 
label is not added to the library.

When you save a new user-defined label, the new label will replace the oldest label in the list. 
Oldest is defined as the longest time since the label was last assigned to a channel. Any time 
you assign any label to a channel, that label will move to the newest in the list. Thus, after you 
use the label list for a while, your labels will predominate, making it easier to customize the 
instrument display for your needs.

When you reset the label library list, all of your custom labels will be deleted, and the label 
list will be returned to its factory configuration.
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Triggers

A trigger setup tells the oscilloscope when to acquire and display data. For 
example, you can set up to trigger on the rising edge of the analog channel 1 input 
signal.

You can use any input channel or the Ext Trig input BNC as the source for most 
trigger types (see "External Trigger Input" on page 53).

Changes to the trigger setup are applied immediately. If the oscilloscope is 
stopped when you change a trigger setup, the oscilloscope uses the new 
specification when you press [Run/Stop] or [Single]. If the oscilloscope is running 
when you change a trigger setup, it uses the new trigger definition when it starts 
the next acquisition.

You can save trigger setups along with the oscilloscope setup (see "Save/Recall 
(Setups, Screens, Data)" on page 82).

Trigger Knobs and Keys

Trigger Types

In addition to the edge trigger type, you can set up triggers on pulse widths, 
patterns, rising and falling edge transition times, setup and hold violations, and 
video signals.
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Trigger Mode, Coupling, Reject, Holdoff

Noisy Signals If the signal you are probing is noisy, you can set up the oscilloscope to reduce the 
noise in the trigger path and on the displayed waveform. First, stabilize the 
displayed waveform by removing the noise from the trigger path. Second, reduce 
the noise on the displayed waveform.

1 Connect a signal to the oscilloscope and obtain a stable display.

2 Remove the noise from the trigger path by turning on high-frequency rejection, 
low-frequency rejection, or noise reject.

3 Use "Selecting the Acquisition Mode" on page 54 to reduce noise on the 
displayed waveform.

Table 13 Trigger Type Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Trigger level Turn the trigger Level knob.

Also: [Analyze] > Features, Trigger Levels.

The edge trigger level for the Line source is not adjustable. This trigger is synchronized with the 
power line supplied to the oscilloscope.

Trigger type [Trigger] > Trigger Type (Edge, Pulse Width, Pattern, Rise/Fall Time, Setup and Hold, Video, Serial 1)

Edge trigger [Auto Scale] (sets up an Edge trigger)

[Trigger] > Trigger Type, Edge

Pulse width trigger [Trigger] > Trigger Type, Pulse Width

Video trigger [Trigger] > Trigger Type, Video

NOTE: Many video signals are produced from 75 Ω sources. To provide correct matching to these 
sources, a 75 Ω terminator (such as a Keysight 11094B) should be connected to the oscilloscope 
input.

Pattern trigger [Trigger] > Trigger Type, Pattern

Rise/fall edge 
transition time trigger

[Trigger] > Trigger Type, Rise/Fall Time

Setup and hold 
violation trigger

[Trigger] > Trigger Type, Setup and Hold

Serial bus trigger [Trigger] > Trigger Type, Serial 1

See "Serial Bus Decode/Trigger" on page 76.
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Table 14 Trigger Mode, Coupling, Reject, Holdoff Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Trigger mode [Trigger] > Mode

You can also configure the [Quick Action] key to toggle between the Auto and Normal trigger modes. 
See "Configuring the [Quick Action] Key" on page 92.

Auto trigger mode [Trigger] > Mode, Auto

If the specified trigger conditions are not found, triggers are forced and acquisitions are made so that 
signal activity is displayed on the oscilloscope. The Auto trigger mode is appropriate when:

• Checking DC signals or signals with unknown levels or activity.

• When trigger conditions occur often enough that forced triggers are unnecessary.

Normal trigger mode [Trigger] > Mode, Normal

Triggers and acquisitions only occur when the specified trigger conditions are found. The Normal 
trigger mode is appropriate when:

• You only want to acquire specific events specified by the trigger settings.

• Making single-shot acquisitions with the [Single] key.

Often with single-shot acquisitions, you must initiate some action in the device under test, and 
you do not want the oscilloscope to auto-trigger before that happens. Before initiating the action 
in the circuit, wait for the trigger condition indicator Trig'd? to flash (this tells you the pre-trigger 
buffer is filled).

Force trigger [Force]

When in the Normal trigger mode and no triggers are occurring, you can force a trigger to acquire 
and display waveforms (which may show why triggers are not occurring). 

Trigger coupling [Trigger] > Coupling (DC, AC, LF Reject, TV/Video)

NOTE: Trigger coupling is independent of channel coupling (see "Vertical Controls" on page 36).

Trigger noise reject
[Trigger] > Reject, Entry knob to select Noise Reject, push Entry knob to enable or disable

Trigger high frequency 
reject [Trigger] > Reject, Entry knob to select HF Reject, push Entry knob to enable or disable

Trigger holdoff [Trigger] > Holdoff

The correct holdoff setting is typically slightly less than one repetition of the waveform.
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External Trigger Input

The external trigger input can be used as a source in several of the trigger types. 
The external trigger BNC input is labeled Ext Trig.

The external trigger input impedance is 1M Ohm. This lets you use passive probes 
for general-purpose measurements. The higher impedance minimizes the loading 
effect of the oscilloscope on the device under test.

CAUTION Maximum voltage at oscilloscope external trigger input

30 Vrms

Table 15 External Trigger Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

External trigger units [Trigger] > External > Units (Volts, Amps)

External trigger 
attenuation [Trigger] > External > Probe, Ratio/Decibels, Entry knob 

External trigger 
threshold [Trigger] > External > Threshold, Entry knob

External trigger range
[Trigger] > External > Range, Entry knob



54 Keysight InfiniiVision DSOX1204A/G Oscilloscopes User's Guide

2 Quick Reference
 

Acquisition Control

This section shows how to use the oscilloscope's acquisition controls.

Selecting the Acquisition Mode

When selecting the oscilloscope acquisition mode, keep in mind that samples are 
normally decimated (thrown away) at slower time/div settings.

At slower time/div settings, the effective sample rate drops (and the effective 
sample period increases) because the acquisition time increases and the 
oscilloscope's digitizer is sampling faster than is required to fill memory.

For example, suppose an oscilloscope's digitizer has a sample period of 1 ns 
(maximum sample rate of 1 GSa/s) and a 1 M memory depth. At that rate, memory 
is filled in 1 ms. If the acquisition time is 100 ms (10 ms/div), only 1 of every 100 
samples is needed to fill memory.

Table 16 Acquisition Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Acquisition mode [Acquire] > Acq Mode

Normal acquisition 
mode

[Acquire] > Acq Mode, Normal

At slower time/div settings, normal decimation occurs, and there is no averaging. Use this mode for 
most waveforms.

Peak detect 
acquisition mode

[Acquire] > Acq Mode, Peak Detect

At slower time/div settings when decimation would normally occur, the maximum and minimum 
samples in the effective sample period are stored. Use this mode for displaying narrow pulses that 
occur infrequently.

Averaging acquisition 
mode

[Acquire] > Acq Mode, Averaging, [Acquire] > # Avgs

At all time/div settings, the specified number of triggers are averaged together. Use this mode for 
reducing noise and increasing resolution of periodic signals without bandwidth or rise time 
degradation.

High resolution 
acquisition mode

[Acquire] > Acq Mode, High Resolution

At slower time/div settings, all samples in the effective sample period are averaged and the average 
value is stored. Use this mode for reducing random noise.
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Overview of Sampling

To understand the oscilloscope's sampling and acquisition modes, it is helpful to 
understand sampling theory, aliasing, oscilloscope bandwidth and sample rate, 
oscilloscope rise time, oscilloscope bandwidth required, and how memory depth 
affects sample rate.

Sampling Theory

The Nyquist sampling theorem states that for a limited bandwidth (band-limited) 
signal with maximum frequency fMAX, the equally spaced sampling frequency fS 
must be greater than twice the maximum frequency fMAX, in order to have the 
signal be uniquely reconstructed without aliasing.

fMAX = fS/2 = Nyquist frequency (fN) = folding frequency

Aliasing

Aliasing occurs when signals are under-sampled (fS < 2fMAX). Aliasing is the signal 
distortion caused by low frequencies falsely reconstructed from an insufficient 
number of sample points.

Table 17 Segmented Memory Acquisition Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Segmented memory 
acquisitions

[Acquire] > Segmented > Segmented, # of Segs, [Run] or [Single]

After each segment fills, the oscilloscope re-arms and is ready to trigger in about 19 µs. Remember 
though, for example, if the horizontal time per division control is set to 5 µs/div, and the Time 
Reference is set to Center, it will take at least 50 µs to fill all ten divisions and re-arm. (That is 25 µs 
to capture pre-trigger data and 25 µs to capture post-trigger data.)

Segmented memory 
navigation

[Acquire] > Segmented > Current Seg

Segmented memory 
and persistence

[Display] > Persistence, Infinite ∞ Persistence or Variable Persistence

[Acquire] > Segmented > Analyze Segments

Segmented memory, 
save to USB storage 
device

[Save/Recall] > Save > Format (CSV, ASCII XY, or BIN) > Settings > Save Seg (Current, All)
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Oscilloscope Bandwidth and Sample Rate

An oscilloscope's bandwidth is typically described as the lowest frequency at 
which input signal sine waves are attenuated by 3 dB (-30% amplitude error).

At the oscilloscope bandwidth, sampling theory says the required sample rate is fS 
= 2fBW. However, the theory assumes there are no frequency components above 
fMAX (fBW in this case) and it requires a system with an ideal brick-wall frequency 
response.

Figure 3 Aliasing
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However, digital signals have frequency components above the fundamental 
frequency (square waves are made up of sine waves at the fundamental frequency 
and an infinite number of odd harmonics), and typically, for 500 MHz bandwidths 
and below, oscilloscopes have a Gaussian frequency response.

Figure 4 Theoretical Brick-Wall Frequency Response
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 So, in practice, an oscilloscope's sample rate should be four or more times its 

bandwidth: fS = 4fBW. This way, there is less aliasing, and aliased frequency 
components have a greater amount of attenuation.

See Also Evaluating Oscilloscope Sample Rates vs. Sampling Fidelity: How to Make the 
Most Accurate Digital Measurements, Keysight Application Note 1587 
(http://literature.cdn.keysight.com/litweb/pdf/5989-5732EN.pdf)

Oscilloscope Rise Time

Closely related to an oscilloscope's bandwidth specification is its rise time 
specification. Oscilloscopes with a Gaussian-type frequency response have an 
approximate rise time of 0.35/fBW based on a 10% to 90% criterion.

An oscilloscope's rise time is not the fastest edge speed that the oscilloscope can 
accurately measure. It is the fastest edge speed the oscilloscope can possibly 
produce.

Figure 5 Sample Rate and Oscilloscope Bandwidth

Limiting oscilloscope bandwidth (fBW) to 1/4 the sample rate (fS/4)
reduces frequency components above the Nyquist frequency (fN).

http://literature.cdn.keysight.com/litweb/pdf/5989-5732EN.pdf
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Oscilloscope Bandwidth Required

The oscilloscope bandwidth required to accurately measure a signal is primarily 
determined by the signal's rise time, not the signal's frequency. You can use these 
steps to calculate the oscilloscope bandwidth required:

1 Determine the fastest edge speeds.

You can usually obtain rise time information from published specifications for 
devices used in your designs.

2 Compute the maximum "practical" frequency component.

From Dr. Howard W. Johnson's book, High-Speed Digital Design – A 
Handbook of Black Magic, all fast edges have an infinite spectrum of frequency 
components. However, there is an inflection (or "knee") in the frequency 
spectrum of fast edges where frequency components higher than fknee are 
insignificant in determining the shape of the signal.

fknee = 0.5 / signal rise time (based on 10% - 90% thresholds)

fknee = 0.4 / signal rise time (based on 20% - 80% thresholds)

3 Use a multiplication factor for the required accuracy to determine the 
oscilloscope bandwidth required.

See Also Choosing an Oscilloscope with the Right Bandwidth for your Application, Keysight 
Application Note 1588 
(http://literature.cdn.keysight.com/litweb/pdf/5989-5733EN.pdf)

Memory Depth and Sample Rate

The number of points of oscilloscope memory is fixed, and there is a maximum 
sample rate associated with oscilloscope's analog-to-digital converter; however, 
the actual sample rate is determined by the time of the acquisition (which is set 
according to the oscilloscope's horizontal time/div scale).

Required accuracy Oscilloscope bandwidth required

20% fBW = 1.0 x fknee

10% fBW = 1.3 x fknee

3% fBW = 1.9 x fknee

http://literature.cdn.keysight.com/litweb/pdf/5989-5733EN.pdf
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sample rate = number of samples / time of acquisition

For example, when storing 50 µs of data in 50,000 points of memory, the actual 
sample rate is 1 GSa/s.

Likewise, when storing 50 ms of data in 50,000 points of memory, the actual 
sample rate is 1 MSa/s.

The actual sample rate is displayed in the right-side information area.

The oscilloscope achieves the actual sample rate by throwing away (decimating) 
unneeded samples.
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Cursors

Cursors are horizontal and vertical markers that indicate X-axis values and Y-axis 
values on a selected waveform source. You can use cursors to make custom 
voltage, time, phase, or ratio measurements on oscilloscope signals.

Cursor information is displayed at the bottom of the screen.

X Cursors X cursors are vertical dashed lines that adjust horizontally and can be used to 
measure time (s), frequency (1/s), phase (°), and ratio (%).

When used with the FFT math function as a source, the X cursors indicate 
frequency.

In XY horizontal mode, the X cursors display channel 1 values (Volts or Amps).

Y Cursors Y cursors are horizontal dashed lines that adjust vertically and can be used to 
measure Volts or Amps, dependent on the channel Probe Units setting, or they can 
measure ratios (%). When math functions are used as a source, the measurement 
units correspond to that math function.

The Y cursors adjust vertically and typically indicate values relative to the 
waveform's ground point, except math FFT where the values are relative to 0 dB.

In XY horizontal mode, the Y cursors display channel 2 values (Volts or Amps).

Cursor Knobs and Keys

Cursor Softkey Controls
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Table 18 Cursor Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Cursors mode [Cursors] > Mode

Manual cursors mode [Cursors] > Mode, Manual (and use Cursors knob to select and adjust)

Track Waveform 
cursors mode

[Cursors] > Mode, Track Waveform

Measure cursors 
mode

[Meas] (cursors show locations used for most recently added measurement)

Binary cursors mode [Cursors] > Mode, Binary

Hex cursors mode [Cursors] > Mode, Hex

Cursors X units [Cursors] > Units > X Units (Seconds, Hz, Phase, Ratio)

Cursors Y units [Cursors] > Units > Y Units (Base, Ratio)
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Measurements

The [Meas] key lets you make automatic measurements on waveforms. Some 
measurements can be made only on analog input channels.

The results of the most recent measurements are displayed in the Measurements 
information area at the bottom of the screen.

Cursors are turned on to show the portion of the waveform being measured for the 
most recently selected measurement (right-most in the bottom measurement 
area).

The units of math waveforms are described in "Units for Math Waveforms" on 
page 45.

All measurements are available for analog channel waveforms. All measurements 
except Counter are available for math waveforms other than FFT. A limited set of 
measurements is available for math FFT waveforms. Use the cursors to make other 
measurements on FFT.

NOTE If a portion of the waveform required for a measurement is not displayed or does not display 
enough resolution to make the measurement (approximately 4% of full scale), the result will 
be displayed as greater than a value, less than a value, not enough edges, not enough 
amplitude (low signal), or waveform is clipped.

NOTE Post Acquisition Processing

In addition to changing display parameters after the acquisition, you can perform all of the 
measurements and math functions after the acquisition. Measurements and math functions 
will be recalculated as you pan and zoom and turn channels on and off. As you zoom in and out 
on a signal using the horizontal scale knob and vertical volts/division knob, you affect the 
resolution of the display. Because measurements and math functions are performed on 
displayed data, you affect the resolution of functions and measurements.
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Table 19 Measurement Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Measurement source [Meas] > Source

Displayed channels or math functions are available for measurements. The External source is 
available only for the Counter measurement when the trigger type is Edge.

Measurement type [Meas] > Type:

Snapshot all 
measurements

[Meas] > Type: Snapshot All, Add Measurement

You can also configure the [Quick Action] key to display the Snapshot All popup. See "Configuring 
the [Quick Action] Key" on page 92.

Voltage 
measurements

[Meas] > Type: (Peak-Peak, Maximum, Minimum, Amplitude, Top, Base, Overshoot, Preshoot, 
Average, DC RMS, AC RMS), Add Measurement

Time measurements [Meas] > Type: (Period, Frequency, Counter, + Width, – Width, Bit Rate, + Duty Cycle, - Duty Cycle, 
Rise Time, Fall Time, Delay, Phase, X at Min Y, X at Max Y), Add Measurement

The Counter measurement is available when the edge or pulse width trigger mode is selected and 
the measurement source is the same as the trigger source.

Count measurements [Meas] > Type: (Positive Pulse Count, Negative Pulse Count, Rising Edge Count, Falling Edge Count), 
Add Measurement

Measurement 
thresholds

[Meas] > Settings > Thresholds >

Also: [Analyze] > Features, Measurement Thresholds.

Measurement window [Meas] > Settings > Meas Window (Auto Select, Main, Zoom)

Clear measurements [Meas] > Clear Meas >
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Mask Testing

One way to verify a waveform's compliance to a particular set of parameters is to 
use mask testing. A mask defines a region of the oscilloscope's display in which 
the waveform must remain in order to comply with chosen parameters. 
Compliance to the mask is verified point-by-point across the display. Mask test 
operates on displayed analog channels; it does not operate on channels that are 
not displayed.

Creating/Editing Mask Files

A mask file contains the following sections:

• Mask File Identifier.

• Mask Title.

• Mask Violation Regions.

• Oscilloscope Setup Information.

Mask File Identifier The Mask File Identifier is MASK_FILE_548XX.

Table 20 Mask Testing Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Mask testing 
enable/disable [Analyze] > Features, Entry knob to select Mask Test, push Entry knob to enable or disable

Mask statistics [Analyze] > Statistics >

Mask test run until [Analyze] > Setup > Run Until (Forever, Minimum # of Tests, Minimum Time, Minimum Sigma)

Mask test error action [Analyze] > Setup > On Error (Stop, Save, Print, Measure)

Mask test source lock [Analyze] > Setup > Source Lock

Auto mask creation [Analyze] > Automask >

Clear mask [Analyze] > Clear Mask

Mask files, save/recall 
from USB storage 
device

[Save/Recall] > Save > Format, Mask (*.msk)

[Save/Recall] > Recall > Recall:, Mask (*.msk)
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Mask Title The Mask Title is a string of ASCII characters. Example: autoMask CH1 OCT 03 
09:40:26 2008

When a mask file contains the keyword "autoMask" in the title, the edge of the 
mask is passing by definition. Otherwise, the edge of the mask is defined as a 
failure.

Mask Violation
Regions

Up to 8 regions can be defined for a mask. They can be numbered 1-8. They can 
appear in any order in the .msk file. The numbering of the regions must go from 
top to bottom, left to right.

An Automask file contains two special regions: the region "glued" to the top of the 
display, and the region that is "glued" to the bottom. The top region is indicated by 
y-values of "MAX" for the first and last points. The bottom region is indicated by 
y-values of "MIN" for the first and last points.

The top region must be the lowest numbered region in the file. The bottom region 
must be the highest numbered region in the file.

Region number 1 is the top mask region. The vertices in Region 1 describe points 
along a line; that line is the bottom edge of the top portion of the mask.

Similarly, the vertices in Region 2 describe the line that forms the top of the 
bottom part of the mask.

Region 1

Region 2



Quick Reference 2

Keysight InfiniiVision DSOX1204A/G Oscilloscopes User's Guide 67

 

The vertices in a mask file are normalized. There are four parameters that define 
how values are normalized:

• X1

• ΔX

• Y1

• Y2

These four parameters are defined in the Oscilloscope Setup portion of the mask 
file.

The Y-values (normally voltage) are normalized in the file using the following 
equation:

Ynorm = (Y - Y1)/ΔY

where ΔY = Y2 - Y1

To convert the normalized Y-values in the mask file to voltage:

Y = (Ynorm * ΔY) + Y1

where ΔY = Y2 - Y1

The X-values (normally time) are normalized in the file using the following 
equation:

Xnorm = (X - X1)/ΔX

To convert the normalized X-values to time:

X = (Xnorm * ΔX) + X1

Oscilloscope
Setup Information

The keywords "setup" and "end_setup" (appearing alone on a line) define the 
beginning and end of the oscilloscope setup region of the mask file. The 
oscilloscope setup information contains remote programming language 
commands that the oscilloscope executes when the mask file is loaded.

Any legal remote programming command can be entered in this section.

The mask scaling controls how the normalized vectors are interpreted. This in turn 
controls how the mask is drawn on the display. The remote programming 
commands that control mask scaling are:
:MTES:SCAL:BIND 0
:MTES:SCAL:X1 -400.000E-06
:MTES:SCAL:XDEL +800.000E-06
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:MTES:SCAL:Y1 +359.000E-03
:MTES:SCAL:Y2 +2.35900E+00

Building a Mask File

The following display shows a mask that uses all eight regions.

This mask is created by recalling the following mask file:
MASK_FILE_548XX

"All Regions"

/* Region Number */ 1
/* Number of vertices */ 4
-12.50, MAX
-10.00, 1.750
10.00, 1.750
12.50, MAX

/* Region Number */ 2
/* Number of vertices */ 5
-10.00, 1.000
-12.50, 0.500
-15.00, 0.500
-15.00, 1.500
-12.50, 1.500

/* Region Number */ 3
/* Number of vertices */ 6
-05.00, 1.000
-02.50, 0.500
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02.50, 0.500
05.00, 1.000
02.50, 1.500
-02.50, 1.500

/* Region Number */ 4
/* Number of vertices */ 5
10.00, 1.000
12.50, 0.500
15.00, 0.500
15.00, 1.500
12.50, 1.500

/* Region Number */ 5
/* Number of vertices */ 5
-10.00, -1.000
-12.50, -0.500
-15.00, -0.500
-15.00, -1.500
-12.50, -1.500

/* Region Number */ 6
/* Number of vertices */ 6
-05.00, -1.000
-02.50, -0.500
02.50, -0.500
05.00, -1.000
02.50, -1.500
-02.50, -1.500

/* Region Number */ 7
/* Number of vertices */ 5
10.00, -1.000
12.50, -0.500
15.00, -0.500
15.00, -1.500
12.50, -1.500

/* Region Number */ 8
/* Number of vertices */ 4
-12.50, MIN
-10.00, -1.750
10.00, -1.750
12.50, MIN

setup
:CHANnel1:RANGe +8.00E+00
:CHANnel1:OFFSet +2.0E+00
:CHANnel1:DISPlay 1
:TIMebase:MODE MAIN
:TIMebase:REFerence CENTer
:TIMebase:RANGe +50.00E-09
:TIMebase:POSition +10.0E-09
:MTESt:SOURce CHANnel1
:MTESt:ENABle 1
:MTESt:LOCK 1
:MTESt:SCALe:X1 +10.0E-09
:MTESt:SCALe:XDELta +1.0000E-09
:MTESt:SCALe:Y1 +2.0E+00
:MTESt:SCALe:Y2 +4.00000E+00
end_setup
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In a mask file, all region definitions need to be separated by a blank line.

Mask regions are defined by a number of (x,y) coordinate vertices (as on an 
ordinary x,y graph). A "y" value of "MAX" specifies the top of the graticule, and a 
"y" value of "MIN" specifies the bottom of the graticule.

The mask x,y graph is related to the oscilloscope graticule using the 
:MTESt:SCALe setup commands.

The oscilloscope's graticule has a time reference location (at the left, center, or 
right of the screen) and a trigger (t=0) position/delay value relative to the 
reference. The graticule also has a vertical ground 0 V reference (offset relative to 
the center of the screen) location.

The X1 and Y1 setup commands relate the mask region's x,y graph origin to the 
oscilloscope graticule's t=0 and V=0 reference locations, and the XDELta and Y2 
setup commands specify the size of the graph's x and y units.

• The X1 setup command specifies the time location of the x,y graph's x origin.

• The Y1 setup command specifies the vertical location of the x,y graph's y origin.

• The XDELta setup command specifies the amount of time associated with each 
x unit.

• The Y2 setup command is the vertical location of the x,y graph's y=1 value (so 
in effect, Y2 – Y1 is the YDELta value).

For example:

• With a graticule whose trigger position is 10 ns (before a center screen 
reference) and whose ground reference (offset) is 2 V below the center of the 
screen, to place the mask region's x,y graph's origin at center screen, you would 
set X1 = 10 ns and Y1 = 2 V.

• If the XDELta parameter is set to 5 ns and Y2 is set to 4 V, a mask region whose 
vertices are (-1, 1), (1, 1), (1, -1), and (-1, -1) goes from 5 ns to 15 ns and from 
0 V to 4 V.

• If you move the mask region's x,y graph origin to the t=0 and V=0 location by 
setting X1 = 0 and Y1 = 0, the same vertices define a region that goes from 
-5 ns to 5 ns and from -2 V to 2 V.

NOTE If there are more than 1000 vertices in a mask region, only the first 1000 vertices will be 
processed.
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How is mask testing done? InfiniiVision oscilloscopes start mask testing by 
creating a database that is 200 x 640 for the waveform viewing area. Each location 
in the array is designated as either a violation or a pass area. Each time a data 
point from a waveform occurs in a violation area a failure is logged. If Test All was 
selected, every active analog channel is tested against the mask database for 
each acquisition. Over 2 billion failures can be logged per-channel. The number of 
acquisitions tested is also logged and displayed as "# of Tests".

The mask file allows greater resolution than the 200 X 640 database. Some 
quantization of data occurs to reduce the mask file data for display on-screen.

NOTE Although a mask can have up to 8 regions, in any given vertical column, it is only possible to 
define 4 regions. When there are 4 regions in a vertical column, one region must be tied to the 
top (using the MAX y value) and one must be tied to the bottom (using the MIN y value).
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Digital Voltmeter

The Digital Voltmeter (DVM) analysis feature provides 3-digit voltage and 5-digit 
frequency measurements using any analog channel. DVM measurements are 
asynchronous from the oscilloscope's acquisition system and are always 
acquiring.

Table 21 Digital Voltmeter Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Digital voltmeter 
enable/disable [Analyze] > Features, Entry knob to select Digital Voltmeter, push Entry knob to enable or 

disable

Digital voltmeter 
mode

[Analyze] > Mode (DC, DC RMS, AC RMS, Frequency)

The Frequency mode requires the Edge or Pulse Width trigger type, and the DVM source and the 
trigger source must be the same analog channel.

Digital voltmeter 
display, transparent 
background

[Analyze] > Transparent

Auto range 
enable/disable

[Analyze] > Auto Range

Auto range can be used when the DVM input channel is not used in oscilloscope triggering.
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Frequency Response Analysis

On G-suffix oscilloscope models (that have a a built-in waveform generator), the 
Frequency Response Analysis (FRA) feature controls the built-in waveform 
generator to sweep a sine wave across a range of frequencies while measuring the 
input to and output from a device under test (DUT). At each frequency, gain (A) 
and phase are measured and plotted on a frequency response Bode chart.

When the frequency response analysis completes, you can move a marker across 
the chart to see the measured gain and phase values at each frequency point. You 
can also adjust the chart's scale and offset settings for the gain and phase plots.

Table 22 Frequency Response Analysis Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Frequency Response 
Analysis (FRA) 
enable/disable

[Analyze] > Features, Entry knob to select Frequency Response Analysis, push Entry knob to 
enable or disable

Channels probing DUT 
input V and output V

[Analyze] > Setup > Sources > Input V

[Analyze] > Setup > Sources > Output V

Frequency sweep min 
and max values [Analyze] > Setup > Min/Max Freq, Entry knob

Waveform generator 
amplitude and 
expected output load

[Analyze] > Setup > Amplitude, Entry knob

[Analyze] > Setup > Output Load (50 Ω, High-Z)

Points [Analyze] > Setup > Points

Run the analysis [Analyze] > Run Analysis

Frequency Response Analysis automatically changes the acquisition mode during the sweep to 
provide a good balance between a clean signal and high throughput at each frequency. For most 
frequencies, averaging is enabled with a varying number of averages.
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Adjust scale, offset, 
and frequency range 
of gain or phase Bode 
plots

[Analyze] > Chart > Select, Entry knob (Gain, Phase, Frequency)

[Analyze] > Chart > Gain Scale/Gain Offset, Entry knob (after Gain selection)

[Analyze] > Chart > Phase Scale/Phase Offset, Entry knob (after Phase selection)

[Analyze] > Chart > Min Freq/Max Freq, Entry knob (after Frequency selection)

Gain, Phase, or both 
plots in chart

[Analyze] > Chart > Trace (Gain, Phase, both)

Autoscale gain and 
phase plots

[Analyze] > Chart > Autoscale

View measured gain 
and phase values [Analyze] > Move Marker, Entry knob

Frequency response 
analysis display, 
transparent 
background

[Analyze] > Transparent

Save data to USB 
storage device

[Save/Recall] > Save > Format, Frequency Response Analysis data (*.csv)

Table 22 Frequency Response Analysis Features (continued)

Feature Front Panel Key/Softkey Location (see built-in help for more information)
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Waveform Generator

On G-suffix oscilloscope models, a waveform generator is built into the 
oscilloscope. The waveform generator gives you an easy way to provide input 
signals when testing circuitry with the oscilloscope.

Waveform generator settings can be saved and recalled with oscilloscope setups. 
See "Save/Recall (Setups, Screens, Data)" on page 82.

Table 23 Waveform Generator Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Waveform generator 
waveform type

[Wave Gen] > Waveform (Sine, Square, Ramp, Pulse, DC, Noise)

Waveform generator 
expected output load

[Wave Gen] > Settings > Output Load (50 Ω, High-Z)

Waveform generator 
logic presets

[Wave Gen] > Settings > Logic Presets > (TTL, CMOS 5.0V, CMOS 3.3V, CMOS 2.5V, ECL)

Invert shape of 
waveform

[Wave Gen] > Settings > Invert Output

Add noise to output [Wave Gen] > Settings > Add Noise

Modulation, 
enable/disable

[Wave Gen] > Settings > Modulation > Modulation

AM modulated output [Wave Gen] > Settings > Modulation > Type, Amplitude Modulation (AM)

FM modulated output [Wave Gen] > Settings > Modulation > Type, Frequency Modulation (FM)

FSK modulated output [Wave Gen] > Settings > Modulation > Type, Frequency-Shift Keying Modulation (FSK)

Restore waveform 
generator defaults

[Wave Gen] > Settings > Default Wave Gen
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Serial Bus Decode/Trigger

Depending on the oscilloscope model, the following hardware-accelerated serial 
decode and trigger options are available:

To determine whether these licenses are installed on your oscilloscope, press 
[Help] > About Oscilloscope.

To order serial decode licenses, go to www.keysight.com and search for the 
product number (for example, D1200AUTA or D1200EMBA) or contact your local 
Keysight Technologies representative (see www.keysight.com/find/contactus).

Triggering on
Serial Data

When triggering on a slow serial signal (for example, I2C, SPI, CAN, LIN, etc.) it 
may be necessary to switch from the Auto trigger mode to the Normal trigger 
mode to prevent the oscilloscope from Auto-triggering and stabilize the display. 
You can select the trigger mode by pressing the [Trigger] key, then the Mode 
softkey.

Also, the threshold voltage level must be set appropriately for each source 
channel. The threshold level for each serial signal can be set in the Signals menu 
(press [Analyze] > Features, select Serial Bus, then press the Signals softkey).

Serial decode and trigger type: With license:

CAN (Controller Area Network) AUTO

I2C (Inter-IC) EMBD

LIN (Local Interconnect Network) AUTO

SPI (Serial Peripheral Interface) EMBD

UART (Universal Asynchronous Receiver/Transmitter) protocols including 
RS232 (Recommended Standard 232)

EMBD

http://www.keysight.com/
http://www.keysight.com/find/contactus
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CAN Decode/Trigger

The CAN serial decode and triggering option can be enabled with the AUTO 
license.

When interpreting the decode waveforms, see the Mode softkey built-in help.

Table 24 Serial Bus Decode/Trigger Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Serial bus select, 
enable/disable [Analyze] > Features, Entry knob to select Serial Bus, push Features softkey or Entry knob to 

enable or disable

Serial bus mode
[Analyze] > Mode, Entry knob (CAN, I2C, LIN, SPI, UART/RS232)

The built-in help for the Mode softkey describes the decode waveforms.

Serial bus trigger [Trigger] > Trigger Type, Serial 1

Table 25 CAN Decode/Trigger Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

CAN signal setup After selecting the Serial Bus and the CAN serial bus mode, press [Analyze] > Signals > to open the 
CAN Signals menu. In this menu, you can select the oscilloscope source channel probing the signal 
and the appropriate threshold voltage to use when decoding/triggering the signal, as well as other 
signal options.

CAN baud rate
[Analyze] > Signals > Baud, Entry knob

CAN sample point
[Analyze] > Signals > Sample Point, Entry knob

CAN signal 
type/polarity [Analyze] > Signals > Signal, Entry knob (Rx, Tx, CAN_H, CAN_L, Differential (L-H), Differential 

(H-L))

CAN counters [Analyze] > Reset CAN Counters

Counters run even when the oscilloscope is stopped (not acquiring data).

When an overflow condition occurs, the counter displays OVERFLOW.
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I2C Decode/Trigger

On all 1000 X-Series oscilloscopes, the I2C serial decode and triggering option 
can be enabled with the EMBD license.

When interpreting the decode waveforms, see the Mode softkey built-in help.

LIN Decode/Trigger

The LIN serial decode and triggering option can be enabled with the AUTO license.

When interpreting the decode waveforms, see the Mode softkey built-in help.

CAN trigger [Trigger] > Trigger Type, Serial 1 (CAN)

[Trigger] > Trigger on: (SOF - Start of Frame, Remote Frame ID (RTR), Data Frame ID (~RTR), Remote 
or Data Frame ID, Data Frame ID and Data, Error Frame, All Errors, Acknowledge Error, Overload 
Frame)

For triggers where you can specify frame ID or data values, press [Trigger] > Bits > to open the CAN 
Bits menu where you can enter the values.

Table 25 CAN Decode/Trigger Features (continued)

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Table 26 I2C Decode/Trigger Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

I2C signal setup After selecting the Serial Bus and the I2C serial bus mode, press [Analyze] > Signals > to open the 
I2C Signals menu. In this menu, you can select the oscilloscope source channels probing the serial 
clock and serial data signals. You can also specify the appropriate threshold voltages to use when 
decoding and triggering on the signals.

I2C address size [Analyze] > Addr Size (7 Bit, 8 Bit)

I2C trigger [Trigger] > Trigger Type, Serial 1 (I2C)

[Trigger] > Trigger on: (Start Condition, Stop Condition, Missing Acknowledge, Address with no Ack, 
Restart, EEPROM Data Read, Frame (Start: Addr7: Read: Ack: Data), Frame (Start: Addr7: Write: Ack: 
Data), Frame (Start: Addr7: Read: Ack: Data: Ack: Data2), Frame (Start: Addr7: Write: Ack: Data: Ack: 
Data2), 10-bit Write)

For triggers where you can specify address or data values, there are additional softkeys you can use 
to enter the values.
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SPI Decode/Trigger

The SPI serial decode and triggering option can be enabled with the EMBD 
license.

When interpreting the decode waveforms, see the Mode softkey built-in help.

Table 27 LIN Decode/Trigger Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

LIN signal setup After selecting the Serial Bus and the LIN serial bus mode, press [Analyze] > Signals > to open the 
LIN Signals menu. In this menu, you can select the oscilloscope source channel probing the signal 
and the appropriate threshold voltage to use when decoding/triggering the signal, as well as other 
signal options.

LIN baud rate
[Analyze] > Signals > Baud > Baud, Entry knob

LIN sample point
[Analyze] > Signals > Sample Point, Entry knob

LIN standard
[Analyze] > Signals > Standard, Entry knob (LIN 1.3, LIN 2.X) 

LIN sync break
[Analyze] > Signals > Sync Break, Entry knob (>= 11, >= 12, >= 13)

LIN show parity [Analyze] > Show Parity

LIN trigger [Trigger] > Trigger Type, Serial 1 (LIN)

[Trigger] > Trigger on: (Sync - Sync Break, ID - Frame ID, ID & Data - Frame ID and Data, Parity Error, 
Checksum Error)

For triggers where you can specify frame ID or data values, there are additional softkeys you can use 
to enter the values.

Table 28 SPI Decode/Trigger Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

SPI signal setup After selecting the Serial Bus and the SPI serial bus mode, press [Analyze] > Signals > to open the 
SPI Signals menu. In this menu, there are separate softkeys and submenus for specifying the Clock, 
MOSI/MISO, and CS (chip select) signal oscilloscope source channels, threshold voltages, and edge 
for the Clock source.

The Display Info softkey lets you display or hide signal setup and timing diagram information.
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UART/RS232 Decode/Trigger

On all 1000 X-Series oscilloscopes, the UART/RS232 serial decode and triggering 
option can be enabled with the EMBD license.

When interpreting the decode waveforms, see the Mode softkey built-in help.

SPI framing
[Analyze] > Signals > CS > Frame by, Entry knob (~CS - Not Chip Select, CS - Chip Select, 
Clock Timeout)

SPI word size [Analyze] > Word Size

SPI bit order [Analyze] > Bit Order (MSB, LSB)

SPI trigger [Trigger] > Trigger Type, Serial 1 (SPI)

[Trigger] > Trigger Setup > Trigger Type (Master-Out, Slave-In (MOSI) Data)

The additional softkeys let you specify the number of data bits and the value of each bit.

Table 28 SPI Decode/Trigger Features (continued)

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Table 29 UART/RS232 Decode/Trigger Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

UART/RS232 signal 
setup

After selecting the Serial Bus and the UART/RS232 serial bus mode, press [Analyze] > Signals > to 
open the UART Signals menu. In this menu, you can select the oscilloscope source channels probing 
the Rx and Tx signals and the appropriate threshold voltage for each.

UART/RS232 bus 
configuration

After selecting the Serial Bus and the UART/RS232 serial bus mode, press [Analyze] > Bus Config > 
to open the UART Bus Config menu. In this menu, you can select the oscilloscope source channels 
probing the Rx and Tx signals and the appropriate threshold voltage for each.

UART/RS232 number 
of bits [Analyze] > Bus Config > # Bits, Entry knob (5, 6, 7, 8, 9)

UART/RS232 parity
[Analyze] > Bus Config > Parity, Entry knob (Even, Odd, None)

UART/RS232 baud 
rate [Analyze] > Bus Config > Baud Rate > Baud, Entry knob

UART/RS232 bus 
polarity [Analyze] > Bus Config > Polarity, Entry knob (Idle low, Idle high)
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UART/RS232 bit order
[Analyze] > Bus Config > Bit Order, Entry knob (LSB, MSB)

UART/RS232 display 
base [Analyze] > Settings > Base, Entry knob (Hex, Binary, ASCII)

UART/RS232 framing
[Analyze] > Settings > Framing, Entry knob (Off, 8-bit hex value)

UART/RS232 counters [Analyze] > Settings > Reset UART Counters

Counters run even when the oscilloscope is stopped (not acquiring data).

When an overflow condition occurs, the counter displays OVERFLOW.

UART/RS232 trigger [Trigger] > Trigger Type, Serial 1 (UART/RS232)

[Trigger] > Trigger Setup > Trigger (Rx Start Bit, Rx Stop Bit, Rx Data, Rx 1:Data, Rx 0:Data, Rx 
X:Data, Tx Start Bit, Tx Stop Bit, Tx Data, Tx 1:Data, Tx 0:Data, Tx X:Data, Rx or Tx Parity Error)

For triggers where you can specify data values, there are additional softkeys for specifying the data 
comparison operator, the data value, the data value base (Hex or ASCII), and the Nth frame burst 
count.

Table 29 UART/RS232 Decode/Trigger Features (continued)

Feature Front Panel Key/Softkey Location (see built-in help for more information)
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Save/Recall (Setups, Screens, Data)

Oscilloscope setups, reference waveforms, and mask files can be saved to internal 
oscilloscope memory or to a USB storage device and recalled later. You can also 
recall default or factory default setups.

Oscilloscope screen images can be saved to a USB storage device in BMP or PNG 
formats.

Acquired waveform data can be saved to a USB storage device in 
comma-separated value (CSV), ASCII XY, and binary (BIN) formats.

There is also a command to securely erase all the oscilloscope's non-volatile 
internal memory.

Table 30 Save/Recall Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Save setup files, 
screen images, 
waveform data, mask 
files

[Save/Recall] > Save >

You can also configure the [Quick Action] key to save setups, screen images, or data. See 
"Configuring the [Quick Action] Key" on page 92.

Save setup files [Save/Recall] > Save > Format, Setup (*.scp)

Press to Save

Save screen images [Save/Recall] > Save > Format, 

• 8-bit Bitmap image (*.bmp)

• 24-bit Bitmap image (*.bmp)

• 24-bit image (*.png)

Settings >

• Setup Info

• Invert Grat

• Palette (Color, Grayscale)
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Length Control

The Length control is available when saving data to CSV, ASCII XY, or BIN format 
files. It sets the number of data points that will be output to the file. Only displayed 
data points are saved.

The maximum number of data points depends on these things:

• Whether acquisitions are running. When stopped, data comes from the raw 
acquisition record. When running, data comes from the smaller measurement 
record.

• Whether the oscilloscope was stopped using [Stop] or [Single]. Running 
acquisitions split memory to provide fast waveform update rates. Single 
acquisitions use full memory.

• Whether only one channel of a pair is turned on. (Channels 1 and 2 are one pair, 
channels 3 and 4 are the other.) Acquisition memory is divided among the 
channels in a pair.

Save waveform data [Save/Recall] > Save > Format,

• CSV data (*.csv)

• ASCII XY data (*.csv)

• Multi Channel Waveform data (*.h5)

• Binary data (*.bin)

Settings > Length (to select number of data points to be saved, see "Length Control" on page 83)

When saving waveform data, the save times depend on the chosen format: BIN=fastest, 
ASCII XY=medium, CSV=slowest.

Quick save to USB 
storage device

[Save to USB] (once "save to USB" settings have been configured under [Save/Recall] > Save)

Recall setups, mask 
files, or reference 
waveforms

[Save/Recall] > Recall > Recall:

Recall setup files [Save/Recall] > Recall > Recall:, Setup (*.scp)

Factory default setup [Save/Recall] > Default/Erase > Factory Default

Secure erase [Save/Recall] > Default/Erase > Secure Erase

Table 30 Save/Recall Features (continued)

Feature Front Panel Key/Softkey Location (see built-in help for more information)
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• Whether reference waveforms are on. Displayed reference waveforms consume 
acquisition memory.

• Whether segmented memory is on. Acquisition memory is divided by the 
number of segments.

• The horizontal time/div (sweep speed) setting. At faster settings, fewer data 
points appear on the display.

• When saving to a CSV format file, the maximum number of data points is 
50,000.

When necessary, the Length control performs a "1 of n" decimation of the data . 
For example: if the Length is set to 1000, and you are displaying a record that is 
5000 data points in length, four of each five data points will be decimated, 
creating an output file 1000 data points in length.
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Print (Screens)

You can print the complete display, including the status line and softkey labels, to 
a USB printer or a network printer.

To set up a printer:

1 Connect a printer. You can:

• Connect a USB printer to the rectangular USB host port on the front panel.

For the most up-to-date information on printers that are compatible with the 
InfiniiVision oscilloscopes, please visit 
www.keysight.com/find/InfiniiVision-printers.

• Set up a network printer connection. See "To set up network printer 
connections" on page 86.

2 To open the Print Config menu:

• Press [Save/Recall] > Print.

• Select the Quick Print quick action ([Utility] > Quick Action > Action, Quick Print); 
then, press Settings.

Some softkeys in the Print Config menu are ghosted (not available) until a 
printer is connected.

Table 31 Print Config Menu Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Printer selection Print to, (printer)

Print options Options,

• Setup Information

• Invert Graticule Colors

• Form Feed

• Landscape

Color or grayscale 
printing

Palette, (Color, Grayscale)

Print the current 
screen

Press to Print

http://www.keysight.com/find/InfiniiVision-printers
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To print the current screen once the printer is configured (and Quick Print is 
selected as the quick action), simply press the [Quick Action] key.

To set up network printer connections

You can set up network printer connections. A network printer is a printer 
attached to the network or a print server on the network.

1 Press [Save/Recall] > Print.

2 In the Print Config menu, press the Print to softkey; then, turn the Entry knob to 
select the network printer you want to configure (either #0 or #1).

3 Press the Network Setup softkey.

4 In the Network Printer Setup Menu, press the Modify softkey; then, turn the 
Entry knob to select the network parameter you want to enter.

The setting that must be entered is:

• Printer Address — this is the printer or print server's address in one of the 
following formats:

• IP address of a network-enabled printer (for example: 192.168.1.100 or 
192.168.1.100:650). Optionally, a non-standard port number can be 
specified following a colon.

• IP address of a print server followed by the path to the printer (for 
example: 192.168.1.100/printers/printer-name or 
192.168.1.100:650/printers/printer-name).

5 Use the Spell, Enter, and Delete Character softkeys to enter the network printer 
settings:

• Spell — press this softkey and turn the entry knob to select the character at 
the current position.

• Enter — press this softkey to enter characters and move the cursor to the next 
character position.

• Delete Character — press the Enter softkey until the desired character is 
highlighted; then, press this softkey to delete the character.

6 Press the Apply softkey to make the printer connection.

A message appears to tell you whether the connection was successful.
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Utility Settings

This section explains oscilloscope utility functions.

Table 32 Utility Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

I/O setup [Utility] > I/O >

The oscilloscope can be accessed and/or controlled remotely using these interfaces:

• USB device port on the rear panel (square shaped USB port).

Connect the USB device port to a computer only when the oscilloscope is turned off or when the 
oscilloscope is fully booted up and running. If you make this connection while the oscilloscope is 
booting up, you will likely get a "USB device not recognized" error.

• LAN interface on the rear panel.

The oscilloscope can be controlled using both I/O interfaces at the same time.

For more information, see the Programmer's Guide.

File explorer [Utility] > File Explorer >

From the internal file system, under "/User Files", you can load oscilloscope setup files (from 10 
locations) or mask files (from four locations).

From a connected USB storage device, you can load setup files, mask files, license files, firmware 
update (*.ksx) files, label files, etc. Also, you can delete files on a connected USB storage device. See 
also "USB Storage Devices" on page 91.

The rectangular USB port on the front panel is a USB Series A receptacle to which you can connect 
USB mass storage devices and printers.

NOTE: To properly unmount a USB storage device before removal, press the Eject softkey. If you 
remove the device without pressing the Eject softkey first, the device will be marked as needing 
repair when connecting to a computer with the Windows operating system (even though there are no 
harmful effects to the device).

V/div expansion 
options

[Utility] > Options > Preferences > Expand, 

• Ground

• Center

Transparent 
backgrounds

[Utility] > Options > Preferences > Transparent

Screen saver [Utility] > Options > Preferences > Screen Saver >

Autoscale preferences [Utility] > Options > Preferences > Autoscale >
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Undo Autoscale [Utility] > Options > Preferences > Autoscale > Undo Autoscale

Fast debug Autoscale [Utility] > Options > Preferences > Autoscale > Fast Debug

Channels to be 
autoscaled

[Utility] > Options > Preferences > Autoscale > Channels (All Channels, Only Displayed Channels)

Acquisition mode 
during autoscale

[Utility] > Options > Preferences > Autoscale > Acq Mode (Use normal acquisition mode, Preserve 
acquisition mode)

Oscilloscope clock [Utility] > Options > Clock >

Softkey menu timeout [Utility] > Options > Menu Timeout

Gen Out signal [Utility] > Options > Auxiliary > Gen Out,

• Triggers

• Mask

• WaveGen

User calibration 
protect

[Utility] > Options > Auxiliary > Cal Protect

Remote command 
logging

[Utility] > Options > Remote Log >

Service task support [Utility] > Service >

See also the Keysight InfiniiVision DSOX1204A/G Oscilloscopes Service Guide. The service guide 
also tells you how to:

• Clean the oscilloscope

• Check warranty and extended services status

• Contact Keysight (www.keysight.com/find/contactus)

• Return the instrument

User calibration [Utility] > Service > Start User Calibration

User calibration status [Utility] > Service > User Calibration Status

Hardware self test [Utility] > Service > Diagnostics > Hardware Self Test

Front panel self test [Utility] > Service > Diagnostics > Front Panel Self Test

Crash log export [Utility] > Service > Diagnostics > Export Logs >

Crash log files are used by Keysight Technical Support when debugging oscilloscope problems.

Table 32 Utility Features (continued)

Feature Front Panel Key/Softkey Location (see built-in help for more information)

http://www.keysight.com/find/contactus
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Setting up the Oscilloscope's LAN Connection

You can place the oscilloscope on the network and set up its LAN connection. 
Once that is done, you can use the oscilloscope's web interface or remotely 
control the oscilloscope via the LAN interface.

The oscilloscope supports methods for automated LAN configuration or manual 
LAN configuration (see "To establish a LAN connection" on page 89). It is also 
possible to set up a point-to-point LAN connection between a PC and the 
oscilloscope (see "Stand-alone (Point-to-Point) Connection to a PC" on page 91).

Once the oscilloscope is set up on the network, you can use the oscilloscope's 
web page to view or change its network configuration and access additional 
settings (like the network password). See "Web Interface" on page 93.

To establish a LAN connection

Automatic
Configuration

1 Press [Utility] > I/O.

2 Press the LAN Settings softkey.

3 Press the Config softkey; then, turn the Entry knob to select Automatic, and press 
the softkey again to enable it.

Host ID export [Utility] > Service > Export Host ID >

The oscilloscope's Host ID is needed when redeeming licenses for oscilloscope upgrades or other 
licensed features.

About oscilloscope [Help] > About Oscilloscope

Displays: model number, serial number, bandwidth, software version, and installed licenses

User interface 
language

[Help] > Language

Table 32 Utility Features (continued)

Feature Front Panel Key/Softkey Location (see built-in help for more information)

NOTE Any time you modify the oscilloscope's hostname, it breaks the connection between the 
oscilloscope and the LAN. You need to re-establish communication to the oscilloscope using 
the new hostname.
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If your network supports DHCP or AutoIP, enabling Automatic lets the 
oscilloscope use those services to get its LAN configuration settings

4 If your network provides Dynamic DNS, you can enable the Dynamic DNS option 
to let the oscilloscope register its hostname and use the DNS server for name 
resolution.

5 You can enable the Multicast DNS option to let the oscilloscope use Multicast 
DNS for name resolution on small networks without a conventional DNS server.

6 Connect the oscilloscope to the local area network (LAN) by inserting the LAN 
cable into the "LAN" port on the rear panel of the oscilloscope.

In a few moments the oscilloscope will connect to the network automatically.

If the oscilloscope does not automatically connect to the network, press [Utility] 
> I/O > LAN Reset. In a few moments the oscilloscope will connect to the 
network.

Manual
Configuration

1 Get the oscilloscope's network parameters (host name, IP address, subnet 
mask, gateway IP, DNS IP, etc.) from your network administrator.

2 Press [Utility] > I/O.

3 Press the LAN Settings softkey.

4 Press the Config softkey; then, turn the Entry knob to select Automatic, and press 
the softkey again to disable it.

If Automatic is not enabled, the oscilloscope's LAN configuration must be set 
up manually using the Addresses and Host name softkeys

5 Configure the oscilloscope's LAN interface:

a Press the Addresses softkey.

b Use the Modify softkey (and the other softkeys and the Entry knob) to enter 
the IP Address, Subnet Mask, Gateway IP, and DNS IP values. When you are 
done, go back up in the menu hierarchy.

c Press the Host name softkey. Use the softkeys and the Entry knob to enter the 
Host name. When you are done, go back up in the menu hierarchy.

d Press the Apply softkey.

6 Connect the oscilloscope to the local area network (LAN) by inserting the LAN 
cable into the "LAN" port on the rear panel of the oscilloscope.
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Stand-alone (Point-to-Point) Connection to a PC

The following procedure describes how to establish a point-to-point (stand alone) 
connection to the oscilloscope. This is useful if you want to control the 
oscilloscope using a laptop computer or a stand-alone computer.

1 Press [Utility] > I/O.

2 Press the LAN Settings softkey.

3 Press the Config softkey; then, turn the Entry knob to select Automatic, and press 
the softkey again to enable it.

If your network supports DHCP or AutoIP, enabling Automatic lets the 
oscilloscope use those services to get its LAN configuration settings

4 Connect your PC to the oscilloscope using a cross-over LAN cable such as 
Keysight part number 5061-0701, available on the web at 
www.keysight.com/find/parts.

5 Cycle power on the oscilloscope. Wait until the LAN connection is configured:

• Press [Utility] > I/O and wait until the LAN status shows "configured".

This may take a few minutes.

Now, the instrument is connected, and the instrument's web interface or remote 
control via LAN may be used.

USB Storage Devices

Use your PC to create directories on a USB storage device.

Most USB mass storage devices are compatible with the oscilloscope. However, 
certain devices may be incompatible, and may not be able to be read or written to. 
USB storage devices must be formatted with the FAT/FAT16, FAT32, NTFS, EXT2, 
EXT3, or EXT4 file system format. The exFAT format is not supported. Any given 
storage device may not support all of these formats.

When the USB mass storage device is connected to the oscilloscope's USB host 
port, a small four-color circle icon may be displayed briefly as the USB storage 
device is read.

You must "eject" a USB mass storage device before unplugging it; otherwise, the 
device will be marked as needing repair when connecting to a computer with the 
Windows operating system (even though there are no harmful effects to the 
device).

http://www.keysight.com/find/parts
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Do not connect USB storage devices that identify themselves as hardware type 
"CD" because these devices are not compatible with the InfiniiVision X-Series 
oscilloscopes.

Configuring the [Quick Action] Key

The [Quick Action] key lets you perform common, repetitive actions by pressing a 
single key.

Table 33 Quick Action Features

Feature Front Panel Key/Softkey Location (see built-in help for more information)

Quick action setup [Utility] > Quick Action > Action,

• Off

• Quick Measure All

• Quick Mask Statistics Reset — see "Mask Testing" on page 65.

• Quick Print — see "Print (Screens)" on page 85.

• Quick Save — see "Save/Recall (Setups, Screens, Data)" on page 82.

• Quick Recall

• Quick Freeze Display

• Quick Trigger Mode — see "Trigger Mode, Coupling, Reject, Holdoff" on page 51.

• Quick Clear Display

Quick action perform [Quick Action]
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Web Interface

When Keysight InfiniiVision 1000 X-Series oscilloscopes are set up on the LAN, 
you can access the oscilloscope's built-in web server using a web browser. The 
oscilloscope's web interface lets you:

• View information about the oscilloscope like its model number, serial number, 
host name, IP address, and VISA (address) connect string.

• Control the oscilloscope using the Remote Front Panel.

• Get screen images and save or print them from the browser.

• Activate the Identification function to identify a particular instrument by 
causing a message to be displayed or a front panel light to blink.

• View installed options, view firmware versions, and view calibration status (via 
the Instrument Utilities page).

• View and modify the oscilloscope's network configuration.

The web interface for InfiniiVision X-Series oscilloscopes also provides help for 
each of its pages.

Before you can use the web interface, you must place the oscilloscope on the 
network and set up its LAN connection.

Accessing the Web Interface

To access the oscilloscope's web interface:

1 Connect the oscilloscope to your LAN (see "To establish a LAN connection" on 
page 89) or establish a point-to-point connection (see "Stand-alone 
(Point-to-Point) Connection to a PC" on page 91).

It is possible to use a point-to-point connection, but using a normal LAN 
connection is the preferred method.

2 Type the oscilloscope's hostname or IP address in the web browser.

The oscilloscope's web interface Welcome Page is displayed.
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Specifications and Characteristics

For up-to-date specifications and characteristics on the 1000 X-Series 
oscilloscopes, see the data sheet at: www.keysight.com/find/1200X-Series

http://www.keysight.com/find/1200X-Series
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Environmental Conditions

Declaration of Conformity

For Declarations of Conformity for Keysight products, go to: 
www.keysight.com/go/conformity

Environment Indoor use only.

Ambient 
temperature

Operating: 0 °C to +50 °C

Non-operating: -10 °C to +70 °C

Humidity Operating: Up to 95% RH, non-condensing to temperatures up to +40 °C 
decreasing linearly to 50% RH at +50 °C

Non-operating: Up to 90% RH up to +65 °C (non condensing)

Altitude Operating: to 3,000 m

Non-operating to 15,300 m

Overvoltage 
Category

This product is intended to be powered by MAINS that comply to Overvoltage 
Category II, which is typical of cord-and-plug connected equipment.

Pollution Degree The InfiniiVision 1000 X-Series oscilloscopes may be operated in environments 
of Pollution Degree 2 (or Pollution Degree 1).

Pollution Degree 
Definitions

Pollution Degree 1: No pollution or only dry, non-conductive pollution occurs. 
The pollution has no influence. Example: A clean room or climate controlled 
office environment.

Pollution Degree 2. Normally only dry non-conductive pollution occurs. 
Occasionally a temporary conductivity caused by condensation may occur. 
Example: General indoor environment.

Pollution Degree 3: Conductive pollution occurs, or dry, non-conductive 
pollution occurs which becomes conductive due to condensation which is 
expected. Example: Sheltered outdoor environment.

http://www.keysight.com/go/conformity
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Probes and Accessories

For a list of the probes and accessories that are compatible with the 1000 X-Series 
oscilloscopes, see the data sheet at: www.keysight.com/find/1200X-Series

Because the 1000 X-Series oscilloscopes do not have a ring around the BNC 
connector for identifying probes, you must set the probe attenuation factor 
manually. See "Setting Analog Channel Probe Options" on page 38.

See Also For more information on probes and accessories, see www.keysight.com for:

• Probes and Accessories Selection Guide (5989-6162EN)

• InfiniiVision Oscilloscope Probes and Accessories Selection Guide Data Sheet 
(5968-8153EN)

• For compatibility information, manuals, application notes, data sheets, 
selection guides, SPICE models, and more for oscilloscope probes, see the 
Probe Resource Center at: www.keysight.com/find/PRC

http://www.keysight.com/find/1200X-Series
http://www.keysight.com
http://literature.cdn.keysight.com/litweb/pdf/5989-6162EN.pdf
http://literature.cdn.keysight.com/litweb/pdf/5968-8153EN.pdf
http://www.keysight.com/find/PRC
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Software and Firmware Updates

From time to time Keysight Technologies releases software and firmware updates 
for its products. To search for firmware updates for your oscilloscope, direct your 
web browser to www.keysight.com/find/1200X-Series-sw.

To view the currently installed software and firmware press [Help] > About 
Oscilloscope.

Once you have downloaded a firmware update file, you can place it on a USB 
storage device and load the file using File Explorer (see "Utility Settings" on 
page 87).

http://www.keysight.com/find/1200X-Series-sw
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Acknowledgements

Third party software acknowledgements and licenses for the InfiniiVision 
DSOX1204A/G oscilloscopes with the embedded Linux operating system are 
located at www.keysight.com/find/1200X-Series-third-party-software.

You can also find a link to this list on the Keysight InfiniiVision oscilloscopes 
manuals website at www.keysight.com/find/1200X-Series-manual.

http://www.keysight.com/find/1200X-Series-third-party-software
http://www.keysight.com/find/1200X-Series-manual
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Product Markings and Regulatory Information

These symbols are used on the 1000 X-Series oscilloscopes.

Symbol Description

Caution, risk of electric shock

Caution, refer to accompanying documentation

This symbol indicates separate collection for electrical and electronic 
equipment mandated under EU law as of August 13, 2005. All electric and 
electronic equipment are required to be separated from normal waste for 
disposal (Reference WEEE Directive 2002/96/EC).

Indicates the time period during which no hazardous or toxic substance 
elements are expected to leak or deteriorate during normal use. Forty 
years is the expected useful life of the product.

The RCM mark is a registered trademark of the Australian 
Communications and Media Authority.

The CE mark is a registered trademark of the European Community.

ICES / NMB-001 Cet appareil ISM est conforme a la norme NMB du 
Canada. This is a marking to indicate product compliance with the 
Industry Canadian Interference-Causing Equipment Standard (ICES-001).

This is also a symbol of an Industrial Scientific and Medical Group 1 Class 
A product (CISPR 11, Clause 4).

The CSA mark is a registered trademark of the CSA International.

South Korean Certification (KC) mark; includes the marking's identifier 
code which follows this format:

MSIP-REM-YYY-ZZZZZZZZZZZZZZ.

ccr.keysight@keysight.com

267459

MSIP-REM-Kst-
     1A15150
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Symbols
(-) Width measurement, 64
(+) Width measurement, 64

Numerics
10-bit write trigger, I2C, 78

A
About Oscilloscope, 89
AC channel coupling, 37
AC RMS measurement, 64
accessories, 12, 97
acquire, 54
Acquire key, 21, 33, 34
Acquisition controls, 21
acquisition memory, saving, 83
acquisition mode, 54
acquisition mode during autoscale, 88
acquisition mode, preserve during 

AutoScale, 88
acquisition modes, 54
actual sample rate, 59
addition math function, 44
address size, I2C, 78
address with no ack condition, I2C 

trigger, 78
Addresses softkey, 90
aliasing, 55
aliasing, FFT, 42
altitude (environmental conditions), 96
AM (amplitude modulation), waveform 

generator output, 75
Amp units, 38, 53
Amplitude measurement, 64
amplitude modulation (AM), waveform 

generator output, 75
analog bus display, 39
analog channel, probe attenuation, 38
analog channel, setup, 36

analog filters, adjusting, 40
Analyze key, 22
Analyze Segments, 55
annotation, adding, 47
ASCII file format, 83
attenuation, probe, 38
attenuation, probe, external trigger, 53
auto mask creation, 65
auto range, digital voltmeter, 72
Auto Scale key, 21
Auto Setup, FFT, 40
Auto Setup, FFT (Magnitude), FFT 

(Phase), 44
Auto trigger mode, 52
AutoIP, 90, 91
automatic measurements, 63
Autoscale, 17
Autoscale preferences, 87
Autoscale, undo, 17, 88
Average measurement, 64
averaging acquisition mode, 54

B
Back key, 20
bandwidth, 89
bandwidth limit, 37
bandwidth required, oscilloscope, 59
bandwidth, oscilloscope, 56
Base measurement, 64
base, UART/RS232, 81
baud rate, CAN, 77
baud rate, LIN, 79
baud rate, UART/RS232, 80
BIN file format, 83
bit order, SPI, 80
bit order, UART/RS232, 81
Bit Rate measurement, 64
Blackman Harris FFT window, 40, 44
blanking, 34
BMP file format, 82

Bode plot, frequency response 
analysis, 74

brick-wall frequency response, 56
brightness of waveforms, 20
built-in help, 29
bus configuration, UART/RS232, 80
Bus key, 39, 76
buttons (keys), front panel, 20

C
calibration, 88
calibration protect button, 26
CAN baud rate, 77
CAN bus trigger, 78
CAN counters, 77
CAN polarity, 77
CAN sample point, 77
CAN serial bus decode/trigger, 77
CAN signal setup, 77
cascaded math functions, 44
Center, FFT, 40
Center, FFT (Magnitude), FFT 

(Phase), 44
channel labels, 47
channel, analog, 36
channel, bandwidth limit, 37
channel, coupling, 37
channel, invert, 37
channel, on/off keys, 24
channel, probe units, 38
channel, skew, 38
channel, vernier, 24
channels to be autoscaled, 88
characteristics, 95
choosing values, 21
clear display, 47
clear display, Quick Clear Display, 92
Clear measurements, 64
clear persistence, 47
clear, mask test, 65
clock, oscilloscope, 88
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color printing, 85
color screen image, 82
compensate passive probes, 18, 25
Config softkey, 89, 90, 91
Conformity, Declaration of, 96
connection, to a PC, 91
connectors, rear panel, 26
control, remote, 87
controls, front panel, 20
copyright, 2
count measurements, 64
Counter measurement, 64
counters, CAN, 77
counters, UART/RS232, 81
coupling, channel, 37
coupling, trigger, 52
crash log export, 88
crosstalk between input channels, 

minimizing, 36
crosstalk problems, 40
CSV file format, 83
cursor measurements, 61
cursor units, 62
Cursors key, 22
Cursors knob, 22
cursors, binary, 62
cursors, hex, 62
cursors, manual, 62
cursors, track waveform, 62
cutoff frequency, low-pass filter, 45

D
damage, shipping, 12
data sheet, 95
date, 88
DC channel coupling, 37
DC RMS measurement, 64
DC signals, checking, 52
DC waveform generator output, 75
decibels, FFT (Magnitude) vertical 

units, 45
decibels, FFT vertical units, 40
decimating samples, 60
Declaration of Conformity, 96
decode, CAN serial bus, 77
decode, I2C serial bus, 78
decode, LIN serial bus, 78
decode, SPI serial bus, 79

decode, UART/RS232 serial bus, 80
default configuration, 16
default label library, 47
default setup, 16
Default Setup key, 21
defaults, waveform generator, 75
degrees, FFT (Phase) vertical units, 45
Delay measurement, 64
delay time, 34
delete file, 87
Demo terminal, 25
DHCP, 90, 91
digital voltmeter (DVM), 72
digital voltmeter mode, 72
Display key, 23
display multiple acquisitions, 32
display, area, 27
display, interpreting, 27
display, persistence, 47
display, single-shot infinite 

persistence, 47
display, softkey labels, 28
display, status line, 27
displayed channels AutoScale, 88
distortion problems, 40
Divide math function, 44
DNS IP, 90
Duty cycle - measurement, 64
Duty cycle + measurement, 64
DVM (digital voltmeter), 72
Dynamic DNS, 90

E
edge speeds, 59
edge triggering, 51
EEPROM data read, I2C trigger, 78
eject USB mass storage device, 87
eject USB storage device, 87, 91
entire display, FFT (Phase) zero phase 

reference, 45
Entry knob, 21
Entry knob, push to select, 21
environmental conditions, 96
erase, secure, 83
error action, mask test, 65
exFAT file system format not 

supported, 91
expand about, 24, 87

expand about center, 87
expand about ground, 87
exporting waveform, 82
Ext Trig as Z-axis input, 34
Ext Trig input connector, 26
EXT2 file system format, 91
EXT3 file system format, 91
EXT4 file system format, 91
external memory device, 25
external trigger, 53
external trigger, input impedance, 53
external trigger, probe attenuation, 53
external trigger, probe units, 53
external trigger, range, 53
external trigger, threshold, 53

F
factory default settings, 83
Fall time measurement, 64
Falling Edge Count measurement, 64
fast debug AutoScale, 88
FAT file system format, 91
FAT16 file system format, 91
FAT32 file system format, 91
FFT (Magnitude), FFT (Phase) vertical 

units, 45
FFT aliasing, 42
FFT DC value, 42
FFT key, 24
FFT magnitude math function, 44
FFT measurement hints, 40
FFT phase math function, 44
FFT resolution, 41
FFT spectral analysis, 40
FFT spectral leakage, 43
FFT vertical units, 40
FFT window, 40
file explorer, 87
file format, ASCII, 83
file format, BIN, 83
file format, BMP, 82
file format, CSV, 83
file format, PNG, 82
file, save, recall, load, 87
filter, low pass, 44
fine adjustment, vertical scale, 37
firmware updates, 98
firmware version information, 93
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flash drive, 25
Flat top FFT window, 40, 44
FM (frequency modulation), waveform 

generator output, 75
folding frequency, 55
Force key, 23
forcing a trigger, 52
FRA (frequency response analysis), 73
frame trigger, I2C, 78
framing, SPI, 80
framing, UART/RS232, 81
freeze display, 48, 92
freeze display, Quick Freeze 

Display, 92
Frequency measurement, 64
frequency modulation (FM), waveform 

generator output, 75
frequency requirements, power 

source, 13
frequency response analysis (FRA), 73
frequency response analysis data, 

save, 74
frequency, Nyquist, 55
frequency-shift keying modulation 

(FSK), waveform generator 
output, 75

front panel controls and connectors, 20
front panel self test, 88
front panel, language overlay, 25
FSK (frequency-shift keying 

modulation), waveform generator 
output, 75

G
Gain plot in FRA chart, 74
gateway IP, 90
Gaussian frequency response, 57
Gen Out connector, 88
Gen Out, mask test, 88
glitch trigger, 51
golden waveform test, 65
graphical user interface language, 29
graticule intensity, 47
graticule type, 47
grayscale printing, 85
grayscale screen image, 82
grid intensity, 47
grid type, 47

ground level, 37
Ground terminal, 25

H
Hanning FFT window, 40, 44
hardware self test, 88
Help key, 24
help, built-in, 29
HF Reject, 52
high-frequency noise rejection, 52
high-resolution acquisition mode, 54
holdoff, 52
Horizontal controls, 21, 33
Horizontal knobs and keys, 33
horizontal position control, 21
Horizontal softkey controls, 33
horizontal time/div control, 21
horizontal Zoom key, 21
Host ID export, 89
host name, 90, 93
Host name softkey, 90
humidity (environmental 

conditions), 96

I
I/O interface settings, 87
I2C address size, 78
I2C bus trigger, 78
I2C serial bus decode/trigger, 78
I2C signal setup, 78
infinite persistence, 32, 47
information area, 28
installed licenses, 89
intensity control, 47
Intensity key, 20
invert shape of waveform generator 

output, 75
invert waveform, 37
inverted screen image, 82
IP address, 90, 93
IRE grid type, 47

K
keys, front panel, 20
knobs, front panel, 20

L
label list, 49
label list, loading from text file, 48
labels, 47
labels, default library, 47
LAN connection, 89
LAN interface, remote control, 87
LAN port, 26
LAN Settings softkey, 89, 90, 91
landscape printing, 85
language, user interface and Quick 

Help, 29
length control, 83
Level knob, 23
level, trigger, 51
LF Reject, 52
LIN baud rate, 79
LIN bus trigger, 79
LIN sample point, 79
LIN serial bus decode/trigger, 78
LIN show parity, 79
LIN signal setup, 79
LIN standard, 79
LIN sync break, 79
Line trigger, 51
line voltage, 13
load file, 87
localized front panel overlay, 25
logging, remote command, 88
logic presets, waveform generator, 75
low pass filter, 44
low signal, 63
low-frequency noise rejection, 52

M
markings, product, 100
mask files, recall, 65
mask statistics reset, Quick Action, 92
mask test output, 88
mask testing, 65
mask, Gen Out signal, 88
Math function controls, 24
Math key, 24
math operators, 44
math, addition, 44
math, divide, 44
math, FFT magnitude, 44
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math, FFT phase, 44
math, functions, 44
math, multiply, 44
math, subtract, 44
math, units, 45
math, using waveform math, 44
Maximum measurement, 64
maximum sample rate, 59
Meas key, 22, 63
Measure controls, 22
measure, Quick Measure All, 92
measurement definitions, 63
measurement record, 83
measurement source, 64
measurement thresholds, 64
measurement type, 64
measurement window with zoom 

display, 64
measurements area, 28
measurements, automatic, 63
measurements, count, 64
measurements, time, 64
measurements, voltage, 64
memory depth and sample rate, 59
menu name, 28
Minimum measurement, 64
missing acknowledge condition, I2C 

trigger, 78
Mode/Coupling key, trigger, 51
model number, 89, 93
Modify softkey, 90
modulation, waveform generator 

output, 75
Multicast DNS, 90
Multiply math function, 44
mV grid type, 47

N
navigate files, 87
Negative Pulse Count 

measurement, 64
network configuration parameters, 93
network printer connection, 86
network, connecting to, 89
noise rejection, 52
noise waveform generator output, 75
noise, adding to waveform generator 

output, 75

noise, high-frequency, 52
noise, low-frequency, 52
noisy signals, 51
non-volatile memory, secure erase, 83
normal acquisition mode, 54
Normal trigger mode, 52
notices, 2
NTFS file system format, 91
number of bits, UART/RS232, 80
Nyquist frequency, 42
Nyquist sampling theory, 55

O
operators, math, 44
options, print, 85
oscilloscope bandwidth, 56
oscilloscope bandwidth required, 59
oscilloscope clock, 88
oscilloscope rise time, 58
oscilloscope sample rate, 58
output load expected, waveform 

generator, 75
output, Gen Out, 88
overdrive on input channels, 

avoiding, 36
overlay, localized, 25
Overshoot measurement, 64
overvoltage category, 96

P
parity, UART/RS232, 80
passive probes, compensating, 18
pattern trigger, 51
PC connection, 91
peak detect acquisition mode, 54
Peak-peak measurement, 64
Period measurement, 64
persistence, 47
persistence, clearing, 47
persistence, infinite, 32
persistence, single-shot infinite, 47
Phase measurement, 64
Phase plot in FRA chart, 74
phase X cursor units, 62
PNG file format, 82
points, FRA, 73
point-to-point connection, 91

polarity, CAN, 77
polarity, UART/RS232, 80
pollution degree, 96
pollution degree, definitions, 96
Positive Pusle Count measurement, 64
post-processing, 63
power consumption, 13
power cord connector, 26
power requirements, 13
power supply, 26
power switch, 13, 20
power-on, 13
Preshoot measurement, 64
print, 92
print options, 85
print, landscape, 85
print, Quick Print, 92
printer selection, 85
printer, USB, 25, 85
printing the display, 85
probe attenuation, 38
probe attenuation, external trigger, 53
probe check, 38
probe compensation, 25
probe compensation, 10:1 setting 

required, 18
probe options, 38
probe units, 38
probes, 97
probes, connecting to oscilloscope, 14
probes, passive, compensating, 18
protect, user calibration, 88
pulse waveform generator output, 75
pulse width trigger, 51

Q
Quick Action key, 23, 92
Quick Clear Display, 92
Quick Freeze Display, 92
Quick Help, 29
Quick Help language, 29
Quick Mask Statistics Reset, 92
Quick Measure All, 92
Quick Print, 92
Quick Print quick action, 85
Quick Recall, 92
Quick Save, 92
quick save to USB storage device, 83
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Quick Trigger Mode, 92

R
radians, FFT (Phase) vertical units, 45
ramp waveform generator output, 75
random noise, 51
range, external trigger, 53
ratio X cursor units, 62
ratio Y cursor units, 62
raw acquisition record, 83
rear panel connectors, 26
re-arm time, segmented memory, 55
recall, 92
recall mask files, 65
recall setups, 83
recall, Quick Recall, 92
Rectangular FFT window, 40, 44
Ref key, 46
reference waveforms, 46
reference, vertical expansion, 87
regulatory information, 100
remote command logging, 88
remote control, 87
required oscilloscope bandwidth, 59
restart condition, I2C trigger, 78
Rise time measurement, 64
rise time, oscilloscope, 58
rise time, signal, 59
rise/fall edge transition time trigger, 51
Rising Edge Count measurement, 64
roll time mode, 34
RS232/UART serial bus 

decode/trigger, 80
run acquisitions, 32
Run Control keys, 22
run until, mask test, 65

S
safety warning, 14
sample point, CAN, 77
sample point, LIN, 79
sample rate, 3
sample rate and memory depth, 59
sample rate, oscilloscope, 56, 58
sampling theory, 55
sampling, overview, 55
save, 92

save file, 87
save segment, 55
save setup files, 82
save times, data, 83
Save to USB key, 23, 83
save, Quick Save, 92
Save/Recall key, 23
saver, screen, 87
saving data, 82
screen image, saving, 82
screen saver, 87
secure erase, 83
segmented memory acquisitions, 55
segmented memory and 

persistence, 55
segmented memory navigation, 55
segmented memory, re-arm time, 55
segmented memory, saving 

segments, 55
selecting, values, 21
self test, front panel, 88
self test, hardware, 88
serial bus decode/trigger, 76
serial bus trigger, 51, 77
serial decode controls, 22
serial decode, CAN, 77
serial decode, I2C, 78
serial decode, LIN, 78
serial decode, SPI, 79
serial decode, UART/RS232, 80
serial number, 89, 93
service functions, 88
setup and hold violation trigger, 51
setup files, saving, 82
setup, default, 16
setups, recall, 83
shipping damage, 12
show parity, LIN, 79
Sigma, minimum, 65
signal setup, CAN, 77
signal setup, I2C, 78
signal setup, LIN, 79
signal setup, SPI, 79
signal setup, UART/RS232, 80
sine waveform generator output, 75
single acquisition, 22
Single key, 32
single-shot acquisitions, 52
single-shot infinite persistence, 47

skew, analog channel, 38
slope trigger, 51
Snapshot All measurements, 64
snapshot all, quick action, 92
softkey labels, 28
softkeys, 6, 20
software updates, 98
software version, 89
source lock, mask test, 65
Span, FFT, 40
Span, FFT (Magnitude), FFT (Phase), 44
specifications, 95
spectral analysis, FFT, 40
spectral leakage, FFT, 43
SPI bit order, 80
SPI bus trigger, 80
SPI framing, 80
SPI serial bus decode/trigger, 79
SPI signal setup, 79
SPI word size, 80
square waveform generator output, 75
square waves, 57
stand-alone connection, 91
standard, LIN, 79
start acquisition, 22
start condition, I2C, 78
statistics, mask test, 65
status line, 27
status, User Cal, 88
stop acquisition, 22
stop acquisitions, 32
stop condition, I2C, 78
subnet mask, 90
subtract math function, 44
sweep frequencies, frequency response 

analysis, 73
sync break, LIN, 79

T
temperature (environmental 

conditions), 96
template, front panel, 25
test, mask, 65
theory, sampling, 55
threshold, analog channel 

measurements, 64
threshold, external trigger, 53
thumb drive, 25
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time, 88
time measurements, 64
time mode, 34
time reference, 34
time reference indicator, 34
time, segmented memory re-arm, 55
timeout, softkey menu, 28, 88
times for saving data, 83
Tools keys, 23
Top measurement, 64
tracking cursors, 62
transparent backgrounds, 87
Trigger controls, 23
trigger coupling, 52
Trigger key, 23
Trigger knobs and keys, 50
trigger level, 51
trigger mode, auto or normal, 52
trigger mode, Quick Trigger Mode, 92
trigger position indicator, 34
trigger type, 51
trigger type, edge, 51
trigger type, glitch, 51
trigger type, pattern, 51
trigger type, pulse width, 51
trigger type, rise/fall edge transition 

time, 51
trigger type, serial bus, 51, 77
trigger type, setup and hold 

violation, 51
trigger type, slope, 51
trigger type, video, 51
trigger types, 23, 50
trigger, CAN serial bus, 77, 78
trigger, external, 53
trigger, FFT (Phase) zero phase 

reference, 45
trigger, holdoff, 52
trigger, I2C serial bus, 78
trigger, LIN serial bus, 78, 79
trigger, mode/coupling, 51
trigger, SPI serial bus, 79, 80
trigger, UART/RS232 serial bus, 80, 81
triggers, Gen Out signal, 88
turn channel on, 24

U
UART/RS232 base, 81

UART/RS232 baud rate, 80
UART/RS232 bit order, 81
UART/RS232 bus configuration, 80
UART/RS232 counters, 81
UART/RS232 framing, 81
UART/RS232 number of bits, 80
UART/RS232 parity, 80
UART/RS232 polarity, 80
UART/RS232 serial bus 

decode/trigger, 80
UART/RS232 signal setup, 80
UART/RS232 trigger, 81
under-sampled signals, 55
units, cursor, 62
units, external trigger probe, 53
units, math, 45
units, probe, 38
updating software and firmware, 98
USB device not recognized, 87
USB device port, remote control, 26, 

87
USB host port, 25, 85
USB printer, 85
USB printers, supported, 85
USB storage device, 25
USB, CD device, 92
USB, eject device, 25
user cal, 88
user calibration, 88
user calibration protect, 88
user interface language, 29, 89
Utility key, 23
utility settings, 87

V
V RMS, FFT (Magnitude) vertical 

units, 45
V RMS, FFT vertical units, 40
values, choosing, 21
variable persistence, 47
ventilation requirements, 13
vernier, channel, 24
Vertical controls, 24, 36
vertical expansion, 24
vertical expansion reference, 87
Vertical knobs and keys, 36
vertical position knob, 24
vertical scale fine adjustment, 37

vertical scale knob, 24
vertical sensitivity, 24
Vertical softkey controls, 36
Vertical Units, FFT, 40
Vertical Units, FFT (Magnitude), FFT 

(Phase), 45
video trigger, 51
VISA connect string, 93
Volt units, 38, 53
voltage measurements, 64

W
warranted specifications, 95
warranty, 2
Wave Gen key, 24, 25
waveform data, saving, 83
waveform generator, 75
waveform generator amplitude, 

frequency response analysis, 73
waveform generator defaults, 

restoring, 75
waveform generator expected output 

load, 75
waveform generator logic presets, 75
waveform generator output, Gen Out 

signal, 88
waveform generator, waveform 

type, 75
waveform type, waveform 

generator, 75
waveform, cursor tracking, 62
waveform, intensity, 47
waveform, saving/exporting, 82
web interface, 93
web interface, accessing, 93
white noise, adding to waveform 

generator output, 75
Width - measurement, 64
Width + measurement, 64
Window, FFT, 40
window, FFT (Magnitude), FFT 

(Phase), 44
word size, SPI, 80

X
X at Max Y measurement, 64
X at Min Y measurement, 64
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XY time mode, 34

Z
Z-axis blanking, 34
zero phase reference, FFT (Phase), 45
zoom display, measurement window 

with, 64
Zoom key, 21
zoomed time base, 34
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