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Chapter 6 

Microwave Discrete and  
Microstrip Filter Design 
PathWave Advanced Design System (ADS) 

 

Background 

Microwave filters play an important role in any RF front end for the suppression of out of 

band signals. In the lumped and distributed form, they are extensively used for both 

commercial and military applications. A filter is a reactive network that passes a desired 

band of frequencies while almost stopping all other bands of frequencies. The frequency 

that separates the transmission band from the attenuation band is called the cutoff 

frequency and denoted as fc. The attenuation of the filter is denoted in decibels or 

nepers. A filter in general can have any number of pass bands separated by stop bands. 

They are mainly classified into four common types – namely low-pass, high-pass, 

bandpass, and band stop filters. 

An ideal filter should have zero insertion loss in the pass band, infinite attenuation in the 

stop band, and a linear phase response in the pass band. An ideal filter cannot be 

realizable as the response of an ideal lowpass or band pass filter is a rectangular pulse 

in the frequency domain. The art of filter design necessitates compromises with respect 

to cutoff and roll off. There are basically three methods for filter synthesis. They are the 

image parameter method, insertion loss method, and numerical synthesis. The image 

parameter method is an old and crude method, whereas the numerical method of 

synthesis is newer but cumbersome. The insertion loss method of filter design on the 

other hand is the optimum and more popular method for higher frequency applications. 

The filter design flow for insertion loss method is shown in Figure 1. 
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Since the characteristics of an ideal filter cannot be obtained, the goal of filter design is to approximate 

the ideal requirements within an acceptable tolerance. There are four types of approximations – namely 

Butterworth or maximally flat, Chebyshev, Bessel, and Elliptic approximations. For the prototype filters, 

maximally flat or Butterworth provides the flattest pass band response for a given filter order. In the 

Chebyshev method, sharper cutoff is achieved and the pass band response will have ripples of 

amplitude 1+k2. Bessel approximations are based on the Bessel function, which provides sharper 

cutoff, and Elliptic approximations results in pass band and stop band ripples. Depending on the 

application and the cost, the approximations can be chosen. The optimum filter is the Chebyshev filter 

with respect to response and the bill of materials. Filters can be designed both in the lumped and 

distributed form using the above approximations. 

 

 

 

 

 

Figure 1. Filter design flow for insertion loss method 
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Design of Microwave Filters 

The first step in the design of microwave filters is to select a suitable approximation of the prototype 

model based on the specifications. 

Calculate the order of the filter from the necessary roll off as per the given specifications. The order can 

be calculated as follows: 

 

Butterworth Approximation: 

 LA(ω' ) = 10log
10

{1+ε (
𝜔′

𝜔𝑐
)

2N

}  

  Where ε = {Antilog
10

LA/10}-1 and LA = 3 dB for Butterworth 

 

Chebyshev Approximation: 

 LA(ω') = 10log
10

{1+εcos2 [ncos-1 (
ω'

ω1
'
)]}    when ω' ≤ ω1' and 

 LA(ω') = 10log
10

{1+εcosh
2 [ncosh

-1 (
ω'

ω1
'
)]}    when ω' ≥ ω1' 

  Where ωc is the angular cutoff frequency 

  ω' is the angular attenuation frequency 

  LA(ω') is the attenuation at ω' 

  N is the order of the filter 

  Where ε = {Antilog
10

LAr / 10} - 1 and LAr is ripple in passband 

 

The next step in the filter design is to calculate the prototype values of the filter depending on the type of 

approximation. The prototype values for the Chebyshev and Butterworth approximations can be 

calculated using the following equations: 

 

Butterworth Approximation: 

 g
0
 = 1 

 g
k
 = 2 sin {(2k - 1)π / 2n} where k = 1, 2, …, n and 

 g
N+1

 = 1 

  Where n is the order of the filter 
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Chebyshev Approximation: 

 β = ln (coth
LAr

17.37
)  where LAr is ripple in the passband 

 γ = sinh (
β

2n
)  

 ak = sin [
(2k - 1) π

2n
]  , k = 1, 2, 3, …, n 

 bk = γ2+sin
2 (

kπ

n
)  , k = 1, 2, 3, …, n 

 g
1
 = 

2a1

γ
  

 g
k
 = 

4ak-1ak

bk-1gk-1

  , k = 2, 3, …, n 

 g
n+1

 = 1 for n odd 

  = coth
2 (

β

4
) for n even 

 

After computing the prototype values, the prototype filter must be transformed with respect to frequency 

and impedance to meet the specifications. The transformations can be done using the given equations 

below. 

 

For Lowpass Filter: 

After impedance and frequency scaling: 

 Ck
'
 = 

Ck

R0ωc
 

 Lk
'  = 

R0Lk

ωc
 where R0=50 Ω 

For the distributed design, the electrical length is given by: 

 Length of capacitance section (βlc)  : CkZl / R0 

 Length of inductance section (βll) : LkR0 / Zh 

  Where Zl is the low impedance value and Zh is the high impedance value 

 

For bandpass filter: 

After impedance and frequency scaling: 

 L1
'  = 

L1Z0

ω0Δ
 

 C1
'
 = 

Δ

L1Z0ω0
 

 L2
'  = 

Δ Z0

ω0C2
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 C2
'
 = 

C2

Z0Δ ω0
 

 L3
'  = 

L3Z0

ω0Δ
 

 C3
'
 = 

Δ

L3Z0ω0
 

  Where Δ is the fractional bandwidth Δ = (ω2 - ω1) / ω0 

Calculating the electrical length of the distributed design of the bandpass filter will be discussed later in 

this chapter. 

 

Simulation of a Lumped and Distributed Lowpass Filter Using ADS 

Typical Design 

Cutoff Frequency (fc)  : 2 GHz 

Attenuation at f = 4 GHz : 30 dB (LA(ω)) 

Type of approximation  : Butterworth 

Order of the filter  : LA(ω' ) = 10log
10

{1+ε (
𝜔

𝜔𝑐
)

2N

} 

     Where ε = {Antilog
10

LA/10} – 1 

 

Substituting the values of LA(ω), ω, and ωc, the value of N is calculated to be 4. 

 

Protype Values of the Lowpass Filter 

The prototype values of the filter are calculated using the formulas given earlier: 

 g
0
 = 1 

 g
k
 = 2 sin {(2k - 1)π / 2n} for k = 1, 2, …, n, and 

 g
N+1

 = 1 

 

The prototype values for the given specifications of the filter are: 

 g
1
 = 0.7654 = C1 

 g
2
 = 1.8478 = L2 

 g
3
 = 1.8478 = C3 

 g
4
 = 0.7654 = L4 
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Lumped Model of the Filter 

The lumped values of the lowpass filter after frequency and impedance scaling are given by the 

formulas given earlier: 

 Ck
'
 = 

Ck

R0ωc
 

 Lk
'  = 

R0Lk

ωc
 where R0=50 Ω 

 

The resulting lumped values are: 

 C1
'
 = 1.218 pF 

 L2
'
 = 7.35 nH 

 C3
'
 = 2.94 pF 

 L4
'
 = 3.046 nH 

 

Distributed Model of the Filter 

For the distributed design, the electrical length is given by: 

 Length of capacitance section (βlc)  : CkZl / R0 

 Length of inductance section (βll) : LkR0 / Zh 

 

Where 

 Zl is the low impedance value 

 Zh is the high impedance value 

 R0 is the source and load impedance 

 ωc is the desired cutoff frequency 

 

If we consider Zl = 10 Ω and Zh = 100 Ω, then  

 βlc1 = 0.1530 

 βli2 = 0.9239 

 βlc3 = 0.3695 

 βli4 = 0.3827 
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Since β = 2π / λ, the physical lengths are given by 

 lc1 = 1.680 mm 

 li2 = 10.145 mm 

 lc3 = 4.057 mm 

 li4 = 4.202 mm 

 

Schematic Simulation Steps for Lumped Lowpass Filter 

1. Open the Schematic window of ADS. 

2. From the Lumped-Components library, select the appropriate components necessary for the lumped 

element lowpass filter. As you place components on the schematic, enter the component values that 

were calculated earlier. 

 

Figure 2. Parts library for lumped elements 

 

3. Connect the components with wire and terminate both ports of the lowpass filter using 

terminations from the Simulation_S-Param library. 

4. Place the S-Parameter simulation controller from the Simulation S-Param library and set its 

parameters as: 

Start = 0.1 GHz 

Stop = 5 GHz 

Number of Points = 101 (or Step Size = 49 MHz) 

The design of the lumped element low pass filter is shown in Figure 3. 
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5. Simulate the circuit by clicking F7 or the simulation gear icon. 

6. After the simulation is complete, ADS automatically opens the Data Display window, which shows the 

results. If the Data Display window does not open, click Window > New Data Display. In the Data 

Display window, select a rectangular plot. In the popup window, plot S(1,1) and S(2,1) as dB. 

7. Click and insert a marker on S(2,1) trace around 2GHz to see the data display graph as shown in 

Figure 4. The point at which S(2,1) is at -3 dB is the cutoff frequency. According to our design, this 

should be around 2 GHz. 

 

Figure 3. Schematic of the completed low pass filter 

 

Figure 4. Graph showing the S(1,1) and S(2,1) of the lowpass filter  
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Results and Observations 

The simulation of the lumped element model shows that the lowpass filter has a cutoff frequency of 

about 2 GHz and has a gentle roll off, which is expected for a Butterworth filter. 

 

Layout Simulation Steps for Distributed Low Pass Filter 

Calculate the physical parameters of the distributed lowpass filter using the design procedure given 

above. Since the length has already been calculated, the only parameter left to calculate is the width of 

the Zl and Zh transmission lines for the stepped impedance low pass filter. As a reminder, Zl = 10 Ω and 

Zh = 100 Ω, which means the low impedance line width is 24.7 mm and the high impedance line width is 

0.66 mm. Both calculations were done with a dielectric constant of 4.6 and a thickness of 1.6 mm. For 

simplicity, the low impedance and high impedance line widths are shown below: 

 wl = wc1 =  wc3 = 24.7 mm 

 wh = wi2 = wi4 = 0.66 mm 

Calculate the length and width of the 50 Ω line using Line Calc (Tools > Line Calc > Start Line Calc) in 

the schematic window. Change the values for Substrate Parameters, Component Parameters, and 

Electrical Characteristics (Z0 and E_Eff) to match Figure 5. Click Synthesize to generate the Physical 

Characteristics. 

The 50 Ω input and output transmission line characteristics should be: 

 Width = 2.93 mm 

 Length = 4.53 mm 

 

Figure 5. Using Line Calc to calculate the parameters for 50 Ω line 
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Now that the parameters have all been determined, create a model of the stepped impedance lowpass 

filter in the layout window. There are two ways to do this: using library components or by drawing 

rectangles. 

To create the model using library components, select the TLines-Microstrip library, and use the MLIN 

components. The TLines-Microstrip library is shown in Figure 6. To create the model by drawing 

rectangles, go to Insert > Rectangle. 

 

Figure 6. TLines-Microstrip library 

 

Ensure that each of the different sections are connected. Connect Pin 1 to the input and Pin 2 to the 

output. The completed model of the stepped impedance (distributed) lowpass filter is shown in Figure 7. 

 

Figure 7. Layout of the stepped impedance lowpass filter 
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Setup the EM simulation as described earlier in the EM simulation chapter. The following properties will 

be used to define the substrate: 

 Material   : FR_4 

 Er   : 4.6 

 Height   : 1.6 mm 

 Loss Tangent  : 0.0023  

 Metal Thickness : 0.035 mm 

 Metal Conductivity : Cu (5.8E7 S/m) 

 

The EM Setup window, showing the substrate definition, is shown in Figure 8. Make sure to enable 

Edge Mesh (Options > Mesh > Edge Mesh) and select ‘Auto-determine edge width’. 

 

Figure 8. EM Setup window showing the substrate definition 

 

After setting up the simulation, press Simulate. As with earlier, create a rectangular plot showing S(1,1) 

and S(2,1). This plot is shown in Figure 9. 
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Notice that the 3 dB cutoff has shifted from 2 GHz to 1.68 GHz, as the theoretical calculations don’t 

allow for accurate analysis of open-end effects and a sudden change in the impedance of the 

transmission lines. In order to get closer to the 2 GHz cutoff frequency specification, the lines need to be 

optimized. This optimization can be carried out using the Momentum simulator or by performing a 

parametric sweep on the lengths of the capacitive and inductive lines. 

 

Parametric EM Simulations in ADS 

To begin parametric simulation on the layout, we need to define the variable parameters that will be 

associated with the layout components. Click EM > Component > Parameters, as shown in Figure 10. 

 

 

 

 

 

 

Figure 9. Graph showing the S(1,1) and S(2,1) of the distributed lowpass filter  
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Figure 10. How to open parameter variable definitions 

 

In the Design Parameters window, define variables for the length of capacitive and inductive lines. For 

the default value, enter the lengths that were calculated earlier, and make sure to select the appropriate 

unit. Set Type to Subnetwork, as these parameters will be associated with the microstrip library 

components, which have parameterized artwork. If you were trying to parameterize the 

polygon/rectangle-based components, you would select the Nominal/Perturbed method, which 

requires additional information. 

 

Figure 11. Design parameter definitions 

 

After defining the parameters, double-click the respective components in the layout window and change 

the length values to the corresponding variable names. Note that no units need to be defined here, as 

the units are specified in the parameter definition. An example is in Figure 12. 
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Figure 12. Redefining the length parameters 

 

After defining the parameter values for each transmission line, the next step is to create an EM model 

and symbol that can then be used for parametric EM cosimulation. To create a parametric model and 

symbol for the layout, go to EM > Component > Create EM Model and Symbol. Select both options in 

the window that pops up. 

 

Figure 13. Creating an EM model and symbol 
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After the EM model and symbol have been created, they will appear below the layout cell, as shown in 

Figure 14. 

 

Figure 14. EM model and symbol shown in the layout 

 

Open a new schematic cell and drag and drop the emModel component to place it as a subcircuit. The 

parameters defined in the layout view (from Figure 11) are the default values for the emModel component. 

These values will be swept using the Parameter Sweep component in the ADS schematic, but the 

Parameter Sweep is done on variables contained in a VAR block. Therefore, you will need to redefine the 

default values in the VAR block and change the parameters for the emModel to use the variables in the 

VAR block (i.e. set LC1=L1, which is defined the VAR block). In this case, the variables L1-L4 are defined 

in the VAR block and assigned to the emModel component. This is shown in Figure 15. 

For our initial sweep, add a Parameter Sweep component (from the Simulation-S_Param library). Open 

the Parameter Sweep component and define Parameter to Sweep as L2 (first inductive line). Set the 

sweep to go from 6.145 to 12.145 in steps of 1. Under the Simulations tab, define Simulation 1 as SP1. 
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Click the Simulate button and plot S(1,1) and S(2,1) in the Data Display window. This shows how the 

filter response changes with the length of the first inductive line. Add a line marker at 2 GHz to see the 

S-parameters at this point. This is shown in Figure 16. 

 

Figure 16. Plot showing the effect of the first inductive line length on the S -Parameters 

 

Figure 15. Schematic for the Parameter Sweep 
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From the plot, we can see that S(2,1) provides a 3 dB cutoff at 2 GHz for the first sweep value. 

Therefore, 6.145 mm seems to be the best value for L2. 

In the schematic, disable the Parameter Sweep, and set L2 = 6.145. Perform the simulation again to 

see the filter response. The result is shown in Figure 17. 

 

Results and Observations 

Using theoretical values, the cutoff frequency for the distributed (stepped impedance) lowpass filter was 

about 1.68 GHz, far below the specification of 2 GHz. Further optimization was needed to meet the 

specification. By performing a parametric sweep, the first inductive line length was optimized. This 

optimization showed significant impact to the 3 dB cutoff frequency by reducing the length of the first 

inductive line. This raised the cutoff frequency to about 2 GHz. As this met the specification, no further 

optimization was needed. 

 

Simulation of a Lumped and Distributed Bandpass Filter Using ADS 

Typical Design 

Upper Cutoff Frequency (fc1)  : 1.9 GHz 

Lower Cutoff Frequency (fc2)  : 2.1 GHz 

Ripple in Passband   : 0.5 dB 

Order of the Filter   : 3 

Type of Approximation   : Chebyshev 

 

Figure 17. Plot showing the S-Parameters with the first inductive line length redefined 
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Prototype Values of the Filter 

The prototype values of the filter for a Chebyshev approximation are calculated using the formulas: 

 β = ln (coth
LAr

17.37
)  where LAr is ripple in the passband 

 γ = sinh (
β

2n
)  

 ak = sin [
(2k - 1) π

2n
]  , k = 1, 2, 3, …, n 

 bk = γ2+sin
2 (

kπ

n
)  , k = 1, 2, 3, …, n 

 g
1
 = 

2a1

γ
  

 g
k
 = 

4ak-1ak

bk-1gk-1

  , k = 2, 3, …, n 

 g
n+1

 = 1 for n odd 

  = coth
2 (

β

4
) for n even 

 

The prototype values for the given specifications of the filter are: 

 g
1
 = 1.5963 = C1 

 g
2
 = 1.0967 = L2 

 g
3
 = 1.5963 = C3 

 g
4
 = 1.0000  

 

Lumped Model of the Filter 

The lumped values of the bandpass filter after frequency and impedance scaling are given by: 

 L1
'  = 

L1Z0

ω0Δ
 

 C1
'
 = 

Δ

L1Z0ω0
 

 L2
'  = 

Δ Z0

ω0C2
 

 C2
'
 = 

C2

Z0Δ ω0
 

 L3
'  = 

L3Z0

ω0Δ
 

 C3
'
 = 

Δ

L3Z0ω0
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 Where 

  Δ is the fractional bandwidth Δ = (ω2 - ω1) / ω0 

  Z0 = 50 Ω 

 

The resulting lumped element values are calculated to be: 

 L1
'  = 63 nH 

 C1
'
 = 0.1004 pF 

 L2
'  = 0.365 nH 

 C2
'
 = 17.34 pF 

 L3
'  = 63 nH 

 C3
'
 = 0.1004 pF 

 

The geometry of the lumped element bandpass filter is shown in Figure 18. 

 

Distributed Model of the Filter 

Calculate the value of J from the prototype values: 

 Z0J1 = √
πΔ

2g1

  

 Z0Jn = 
πΔ

2√gn-1gn

  for n = 2, 3, …, N 

 Z0JN+1 = √
πΔ

2gNgN+1

   

 

Figure 18. Geometry of lumped element bandpass filter 
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 Where  

  Δ is the fractional bandwidth Δ = (ω2 - ω1) / ω0 

  Z0 = 50 Ω 

 

The values of odd and even mode impedances can be calculated as follows 

 Z0e = Z0[1 + JZ0 + (JZ0)2]  

 Z0o = Z0[1 – JZ0 + (JZ0)2] 

 

Schematic Simulation Steps for the Lumped Bandpass Filter 

Open a new schematic window and construct the lumped element bandpass filter, as shown in Figure 

19. These values were calculated earlier and is the same geometry as the circuit in Figure 18. Setup the 

S-Paramater simulation from 1.0 GHz to 3.0 GHz with steps of 5 MHz. 

 

 

Figure 19. Lumped element bandpass filter schematic 
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Click the Simulate button and plot S(1,1) and S(2,1) in the data display window. Add markers for the 

lower and upper cutoff frequencies. The results are shown in Figure 20. 

 

Results and Observations 

The results are satisfactory for the lumped element design. The simulation shows that the design is in 

agreement with the specified lower and upper cutoff frequencies. The filter also has an appropriate roll 

off for a Chebyshev filter. However, to get more accurate results, the circuit should be simulated and 

optimized with the vendor component libraries. It may also be helpful to perform a yield analysis to 

determine how the results are impacted by the tolerance of the lumped components. 

 

Layout Simulation Steps for the Distributed Bandpass Filter 

Calculate the even mode and odd mode impedance values (Z0e and Z0o) of the bandpass filter using the 

design procedure given above. Synthesize the physical parameters (length, width, and spacing) for the 

coupled lines for a substrate thickness of 1.6 mm and dielectric constant of 4.6. This can be done using 

LineCalc. Make sure to change Component Type to MCLIN. This is shown in Figure 21. 

 

 

 

Figure 20. Lumped element bandpass filter S-Parameters 
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The physical parameters of the coupled lines for the given values of Z0o and Z0e are shown below: 

Substrate Parameters 

 Thickness: 1.6 mm 

 Dielectric constant: 4.6 

 Frequency: 2 GHz 

 Electrical length: 90 degrees 

 

Section 1: Z0e = 70.61 Ω, Z0o = 39.24 Ω 

 Width = 2.290 mm 

 Spacing = 0.491 mm 

 Length = 20.723 mm 

 

Section 2: Z0e = 56.64 Ω, Z0o = 44.77 Ω 

 Width = 2.803 mm 

 Spacing = 1.804 mm 

 Length = 20.255 mm 

 

Section 3: Z0e = 56.64 Ω, Z0o = 44.77 Ω 

 Width = 2.803 mm 

 Spacing = 1.804 mm 

 Length = 20.255 mm 

 

Section 4: Z0e = 70.61 Ω, Z0o = 39.24 Ω 

 Width = 2.290 mm 

 Spacing = 0.491 mm 

 Length = 20.723 mm 
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Figure 21. Using LineCalc to determine parameters 

 

Calculate the width of the 50 Ω line using LineCalc. Make sure to reset Component Type to MLIN. The 

length of the line is chosen to be 5 mm for simplicity. The parameters for the 50 Ω line should be: 

 Width = 2.918 mm 

 Length = 5 mm 

 

Now that the parameters have been determined, create a model of the distributed bandpass filter in a 

new layout window. The easiest way to do this is to use the library components. Select the TLines-

Microstrip library. Use the MCFIL components for the coupled line sections and the MLIN components 

for the 50 Ω lines. Connect Pin 1 to the input and Pin 2 to the output. The finished layout is shown in 

Figure 22. 

 

Figure 22. Layout of the distributed bandpass filter 
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Setup the EM simulation using the procedure defined earlier for 1.6 mm FR4 dielectric. Define the 

frequency plan as 1 GHz to 3 GHz with 101 number of points. Don’t forget to turn on Edge Mesh under 

the Options > Mesh tab of the EM Setup window. 

Once the simulation finishes, plot S(1,1) and S(2,1). Add markers to the -3dB bandwidth points to 

determine the lower and upper cutoff frequencies. The plot is shown in Figure 23. Note that the markers 

are not at -3 dB. That is because the passband ripple varies between approximately -1.0 dB and  

-1.5 dB, which will slightly impact the definition of the lower and upper cutoff frequencies. 

 

Results and Observations 

For the distributed design, the filter does not meet the specifications and the coupled lines need to be 

optimized (length, width, spacing). The odd and even impedance values were calculated from standard 

formulas using ideal assumptions and do not consider any electromagnetic or parasitic effects. The 

optimization can be done using a variety of tools inside ADS. 

 

 

 

Figure 23. Plot of S-Parameters for distributed bandpass filter 
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Conclusion 

Congratulations! You have completed Microwave Discrete and Microstrip Filter Design. Check out more 

examples at www.keysight.com/find/eesof-ads-rfmw-examples. 

http://www.keysight.com/find/eesof-ads-rfmw-examples

