Intelligent Test Framework
Software Solutions
Setup Guide

- Agilent Repair Tool
- Agilent Quality Tool
- ITF components

Version 3.1
ITFSS 03.10 p 1204
April 2005

Agilent Technologies
© Agilent Technologies, Inc. 2001-2005. All rights reserved.

No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Agilent Technologies, Inc. as governed by United States and international copyright laws.

Additional Notices
The material contained in this document is subject to change without notice.

Agilent Technologies makes no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Agilent Technologies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Adobe®, Acrobat® are U.S. registered trademarks of Adobe Systems Incorporated.

Notepad®, WordPad®, Excel®, Windows®, and Microsoft® are U.S. registered trademarks of Microsoft Corporation.

Other trademarks and copyrights are owned by the respective companies mentioned in this document.
ITF Software Solutions Setup Guide

1 Introduction

In this chapter........................................................................................................................................ 1-1
Overview............................................................................................................................................. 1-2
Setup Steps.......................................................................................................................................... 1-4
System Requirements .......................................................................................................................... 1-5
Pre-Installation Verification Procedures............................................................................................. 1-7
   Verifying if the correct operating system is installed............................................................... 1-7
   Verifying if Microsoft SQL Server 2000 Service Pack 3a is installed.................................. 1-7
   Verifying if Microsoft SQL Server 2000 is configured correctly .......................................... 1-8
   Disabling the IIS Admin Service .............................................................................................. 1-9
   Configuring the SQL Server .................................................................................................... 1-10
How this Manual is Organized ........................................................................................................... 1-12
Setup Quick Reference ....................................................................................................................... 1-13

2 Installing the ITF Server

Overview.............................................................................................................................................. 2-1
Installing the ITF Server Components and Administration System ............................................. 2-2
Performing ITF Integrity Check ........................................................................................................ 2-8
   Rectifying Login to ITF Administration System .................................................................... 2-9
Optimizing the ITF Server for a Multi-Tester Environment ............................................................. 2-10

3 Networking the ITF Server

In this chapter....................................................................................................................................... 3-1
Overview.............................................................................................................................................. 3-2
Table of Contents

Connecting the ITF Server to the Network ................................................................. 3-3
Setting TCP/IP Connections ...................................................................................... 3-4

4 Setting Up Software Licenses
In this chapter .............................................................................................................. 4-1
Overview ....................................................................................................................... 4-2
Required Tools and Materials .................................................................................... 4-3
Setting Up Licenses .................................................................................................... 4-4
Viewing Licenses ......................................................................................................... 4-8
Additional Licenses ..................................................................................................... 4-9
Troubleshooting .......................................................................................................... 4-10

5 Setting Up Permissions and Logins
In this chapter .............................................................................................................. 5-1
Overview ....................................................................................................................... 5-2
Setting Permissions and Logins .................................................................................. 5-3

6 Installing, Configuring and Running the Agilent Repair Tool
In this chapter .............................................................................................................. 6-1
Overview ....................................................................................................................... 6-2
Installing ART ............................................................................................................... 6-5
Configuring ART .......................................................................................................... 6-11
Running ART ................................................................................................................ 6-13

7 Installing, Configuring and Running the Agilent Quality Tool
In this chapter .............................................................................................................. 7-1
Overview...................................................................................................................................... 7-2
Installing AQT .................................................................................................................................. 7-5
Configuring AQT............................................................................................................................... 7-10
Running AQT .................................................................................................................................... 7-12

8 Installing and Configuring the Agilent AXI
In this chapter.................................................................................................................................... 8-1
Overview.......................................................................................................................................... 8-2
Pre-Installation Checklist................................................................................................................... 8-3
Installing the ITF Tester Components on the Agilent AXI................................................................. 8-4
Configuring the Agilent AXI.......................................................................................................... 8-11
  Modifying the trcmdpro.cmd file................................................................................................. 8-11
  Modifying the plrimg.cfg file ...................................................................................................... 8-13

9 Installing and Configuring the Agilent AOI
In this chapter.................................................................................................................................... 9-1
Overview.......................................................................................................................................... 9-2
Pre-Installation Checklist................................................................................................................... 9-3
Installing the ITF Tester Components on the Agilent AOI................................................................. 9-4
Configuring the Agilent AOI.......................................................................................................... 9-12
  Configuring the Agilent AOI to transfer Rep files ..................................................................... 9-12

10 Installing and Configuring the Agilent ICT WN
In this chapter.................................................................................................................................... 10-1
Overview.......................................................................................................................................... 10-2
Pre-Installation Checklist.................................................................................................................... 10-3
Table of Contents

Installing the ITF Tester Components on the Agilent ICT WN ................................................. 10-4
Configuring the Agilent ICT WN ............................................................................................. 10-11
    Creating the GENCAMSTORE Environment Variable ...................................................... 10-11
    Modifying the Existing Directory Structure ...................................................................... 10-14
    Running the Perl Script to Modify the tld.prplus File ....................................................... 10-15
    Running the aitfprp2art Script to Modify Testplans and Generate GenCAM Files ........... 10-15
    Verifying the Names of the GenCAM Files ...................................................................... 10-17

11 Installing and Configuring the Agilent ICT UNIX

In this chapter ............................................................................................................................. 11-1
Overview .................................................................................................................................... 11-2
Installing the Tester Components on the ITF Server ................................................................. 11-3
Networking the Agilent ICT UNIX ........................................................................................... 11-9
    Pre-Conditions for Networking the Agilent ICT UNIX .................................................... 11-9
    Mapping the Agilent ICT UNIX to the ITF Server ........................................................... 11-10
    Determining whether Automounter is in use ................................................................. 11-12
    Mounting the Remote File Systems Using SAM (if using Automounter) ....................... 11-13
    Mounting the Remote File Systems Manually (if not using Automounter) ...................... 11-16
Pre-Installation Checklist for ITF UNIX Components .............................................................. 11-28
Installing the ITF Components on the Agilent ICT UNIX ........................................................ 11-29
Configuring the Agilent ICT UNIX ......................................................................................... 11-32
    Setting the ITF Server Path in the hp3070 and profile Files ........................................... 11-32
    Running the Perl Script to Modify the tld.prplus File ....................................................... 11-37
    Running the aitfprp2art Script to Modify Testplans and Generate GenCAM Files ........... 11-38
    Verifying the Names of the GenCAM Files ...................................................................... 11-40

12 Verifying Data Transmission

In this chapter ............................................................................................................................. 12-1
Overview .................................................................................................................................... 12-2
Verifying Data is Sent to the ITF Server .......................................................................................... 12-3

13 Troubleshooting

In this chapter ................................................................................................................................. 13-1
Restarting the ITF Server Software ............................................................................................ 13-2
Changing the Locale ...................................................................................................................... 13-3
   For Windows XP ....................................................................................................................... 13-3
   For Windows 2000 ................................................................................................................... 13-5
Changing the Local Security Policy for Microsoft Windows Server 2003 ......................... 13-7
Sharing the ITF Server with Agilent ICT UNIX ................................................................. 13-9
Problem Scenarios ....................................................................................................................... 13-11

14 Getting Help

Overview........................................................................................................................................ 14-1
Technical Support ......................................................................................................................... 14-2
Phone Support ............................................................................................................................... 14-3
Sales and Product Information ..................................................................................................... 14-4

A Optional Configurations for Agilent ICT and Agilent AXI

In this appendix ............................................................................................................................ A-1
Manually Modifying Testplans for Agilent ICT .......................................................................... A-2
Manually Generating Agilent ICT GenCAM Files for Each Board Type .................................. A-4
   Using CAMCAD Professional ............................................................................................... A-5
   Running the gc3070 Tool ...................................................................................................... A-5
Modifications to the ART Setup for Use with TestWise SPC on the Agilent AXI .................. A-7
   I. Modifying the autorpt.cfg File on the Agilent AXI ........................................................ A-7
   II. Configuring ART .............................................................................................................. A-7
Table of Contents

B  Other Optional Settings

In this appendix..............................................................................................................................................B-1

Setting up a Network PC or Server to receive XML Export files .....................................................B-2

Setting up ART for in-line use with the Agilent AOI.................................................................................B-5
  Setting Up Board Buffering ....................................................................................................................B-6
  Resetting the Buffer ..............................................................................................................................B-7

Using an RS232 Barcode Reader with the Agilent Repair Tool .....................................................B-8
  Configuring Settings .............................................................................................................................B-8
  Exiting the Program ..............................................................................................................................B-9

Glossary

Index
Introduction

- Overview, 1-2
- Setup Steps, 1-4
- System Requirements, 1-5
- Pre-Installation Verification Procedures, 1-7
- How this Manual is Organized, 1-12
- Setup Quick Reference, 1-13

CAUTION

⚠️ It is essential that you follow the instructions exactly, in the order given. If you do not follow the Setup Guide exactly, the system will not function properly.
Overview

This setup guide provides information for networking, installing and configuring the following test systems and applications for use with the Intelligent Test Framework (ITF):

■ Agilent AXI
■ Agilent AOI
■ Agilent ICT UNIX or WN
■ Agilent Repair Tool
■ Agilent Quality Tool

The Intelligent Test Framework allows for data sharing and communication among test systems and applications. It consists of software and an ITF Server.

Entry and Standard ITF Servers can connect to several test systems and Client PCs (see Figure 1-1). The Agilent Repair Tool and Agilent Quality Tool are installed on Client PCs.
Single-Tester ITF Servers can connect to only one test system. The Single-Tester ITF Server comes with the Agilent Repair Tool preinstalled. The Agilent Quality Tool can be installed on the Single-Tester ITF Server or a Client PC (see Figure 1-2).

Figure 1-2  Intelligent Test Framework with a Single-Tester ITF Server

Single-Tester ITF Server with ART and AQT applications
(Agilent Quality Tool – optional)
Setup Steps

Networking, installation, and configuration steps associated with the Intelligent Test Framework are highlighted in Figure 1-3.

**Figure 1-3** Setup Overview

1. **STEP 1**
   - ITF Server
   - Install and Network

2. **STEP 2**
   - Set up software licenses
   - Set permissions and logins

3. **STEP 3**
   - Client PC
   - Install, Configure and Run ART
   - Install, Configure and Run AQI

4. **STEP 4**
   - Agilent AXI
   - Agilent AOI
   - Agilent ICT WN or UX
   - Install and Configure

5. **STEP 5**
   - Verify data transmission
System Requirements

In order to network the Intelligent Test Framework and its associated applications, you need the following items:

- An Intelligent Test Framework (ITF) Server:
  - Entry ITF Server, or
  - Standard ITF Server, or
  - Single-Tester ITF Server

The following are the software requirements for the ITF Server:

- Microsoft® Windows® Server 2003 operating system (English/Chinese)
  OR Microsoft® Windows® 2000 Server operating system with Service Pack 4 (English/Chinese)
- Microsoft® SQL Server 2000 Standard Edition with Service Pack 3a
- Microsoft® Windows® Services for UNIX 3.5 (if you are using Agilent ICT UX test systems)

NOTE

If you wish to view ART in Chinese, you need to install the Chinese version of both the Windows Server operating system and SQL Server 2000.

NOTE

It is recommended that you install the latest version of an anti-virus software such as Symantec® Norton AntiVirus® on your ITF Server. However, do not install any additional software on the ITF Server as it may affect the system’s performance.

For additional information on Agilent test systems, see the Printed Circuit Board Test and Inspection web site:

http://www.agilent.com/see/pcb

NOTE

Prior to networking the ITF Server, please make sure the following assumptions are met:

- The date/time and time zone settings on the ITF Server match the date/time and time zone settings on your test systems and Client PCs. All machines attached to the Intelligent Test Framework must have the same date/time and time zone settings. Be sure to restart the ITF Server or Client PC after changing the time settings.

- Network requirements:
  - Category 5 (CAT 5) LAN network cables (for performance at 100 Mbps)
  - 10/100 Base-T network switch recommended (or hub)
Chapter 1: Introduction: System Requirements

- Test systems with the following software versions:
  - Agilent ICT UNIX with software version 04.00p or later
  - Agilent ICT WN with software version 3070 04.00p WN or later
  - Agilent AXI with software version 7.3 or later
  - Agilent AOI SJ Series with software version 4.07 or later
  - Agilent AOI SP Series with software version 2.0.0.7 or later

- Client PCs with the following minimum requirements:
  - Intel® Pentium III 800 MHz or higher processor or equivalent
  - 512 MB RAM
  - Minimum 500 MB of free disk space
  - 10/100 Base-T network interface card
  - 17” monitor minimum, 19" or 21" monitor recommended with SVGA or higher resolution (1024 x 768, 256 colors)
  - Windows 2000 Professional (Service Pack 4) or Windows XP Professional (Service Pack 2)

**NOTE**

It is recommended that you install the latest version of an anti-virus software such as Symantec® Norton AntiVirus® on each Client PC.
Before you proceed to install the ITF server, you need to do the following:

- **Verifying if the correct operating system is installed**, 1-7
- **Verifying if Microsoft SQL Server 2000 Service Pack 3a is installed**, 1-7
- **Verifying if Microsoft SQL Server 2000 is configured correctly**, 1-8
- **Disabling the IIS Admin Service**, 1-9
- **Configuring the SQL Server**, 1-10

**Verifying if the correct operating system is installed**

To verify that Microsoft® Windows® 2000/2003 Server operating system is installed:

1. Right-click the My Computer desktop icon.
2. Click Properties.

   A dialog box appears, stating the system and service pack. For Windows 2000 Server, note that it may list the system as Microsoft Windows 2000.

**Verifying if Microsoft SQL Server 2000 Service Pack 3a is installed**

To verify if Microsoft® SQL Server® 2000 Service Pack 3a (SP3a) is installed:

1. Click Start > Control Panel.
2. Double-click Add or Remove Programs.
3. Click Microsoft SQL Server 2000 followed by Support Information.

   If the version number shown is 8.00.761, it is running on SP3a.

4. Close the Support Information window by clicking the button at the top right-hand of the window.
5 If SP3a is not installed, do the following to install it:
   a  Browse to Microsoft’s SQL Server 2000 Service Pack 3a Download web site, and download the files \texttt{SQL2KSP3.exe} and \texttt{SQL2KASP3.exe}.
   b  Back up your SQL Server databases (\texttt{itf\_Data.MDF} and \texttt{itf\_Log.LDF} for ITF 3.1).
   c  Back up your Analysis Service databases, if any.
   d  Make sure that the system databases have enough free space (approximately 400 MB).
   e  Install Database Components SP3a (\texttt{SQL2KSP3.exe})
   f  Install Analysis Service Components SP3a (\texttt{SQL2KASP3.exe})
   g  Restart the server.

Verifying if Microsoft SQL Server 2000 is configured correctly

To verify if Microsoft® SQL Server® 2000 is configured correctly:

1  Click Start > Programs > Microsoft SQL Server > Enterprise Manager.
2  In the console tree, select Console Root > Microsoft SQL Servers > SQL Server Group > (local) (Windows NT).
3  Right-click (local) (Windows NT), and then select Properties.
   The SQL Server Properties (Configure) dialog box appears.
4  Click the Security tab.
5  Under Authentication, ensure that the SQL Server and Windows option is selected.
   If it is already selected, click Cancel and close the Enterprise Manager.
   If it is not, select it and click OK to save the setting.
   You will be prompted to restart the SQL Server.

Please remember to register your ITF Server with the respective hardware supplier, for example, Hewlett-Packard or Dell, to ensure warranty coverage.
Disabling the IIS Admin Service

If the IIS Admin Service is active, do the following to disable it.

1. To open Services, click Start > Control Panel.

A Services console similar to Figure 1-4 appears.

![Services console image](image-url)
3 Locate the **IIS Admin Service** entry and double click it.

A dialog box similar to the one shown in Figure 1-5 appears.

**Figure 1-5**  Stopping the IIS Admin Service

4 Click **Stop**.

The **IIS Admin Service** is stopped.

5 Click **Startup type**, select **Disabled** and then click **OK**.

This ensures the **IIS Admin Service** is permanently disabled.

**Configuring the SQL Server**

To optimize the performance of the SQL Server, you need to change the size of the temporary database.

To change the size of the temporary database:

1 Click **Start > All Programs > Microsoft SQL Server > Enterprise Manager**.

2 In the console tree, select **Console Root > Microsoft SQL Servers > SQL Server Group > (local) (Windows NT)**.

3 Click **Databases** to expand it.
Chapter 1: Introduction: Pre-Installation Verification Procedures

4 Right-click the database tempdb, and select Properties.

The tempdb Properties dialog box appears.

5 Click the Data Files tab.

Figure 1-7 Tempdb properties - Data Files

6 Click the column under Space allocated (MB), and change the default value to 100.

7 Click OK to save.

8 Right-click the database tempdb, and select Properties.

The tempdb Properties dialog box appears.

9 Click the Transaction Log tab.

10 Click the column under Space allocated (MB), and change the default value to 10.

11 Close the Enterprise Manager.
Chapter 1: Introduction: How this Manual is Organized

How this Manual is Organized

The chapters in this manual cover the following topics:

- Chapter 2, Installing the ITF Server - Steps for installing the ITF Server.
- Chapter 3, Networking the ITF Server - Steps for networking the ITF Server.
- Chapter 4, Setting Up Software Licenses - Information on how to activate and validate your software licenses.
- Chapter 5, Setting Up Permissions and Logins - Information on how to set permissions and logins for the ITF software applications, such as the Agilent Repair Tool and Agilent Quality Tool.
- Chapter 6, Installing, Configuring and Running the Agilent Repair Tool - Steps for installing, configuring, and running the Agilent Repair Tool.
- Chapter 7, Installing, Configuring and Running the Agilent Quality Tool - Steps for installing, configuring, and running the Agilent Quality Tool.
- Chapter 8, Installing and Configuring the Agilent AXI - Steps for installing and configuring the Agilent AXI inspection system.
- Chapter 9, Installing and Configuring the Agilent AOI - Steps for installing and configuring the Agilent AOI inspection system.
- Chapter 10, Installing and Configuring the Agilent ICT WN - Steps for installing and configuring the Agilent ICT WN inspection system.
- Chapter 11, Installing and Configuring the Agilent ICT UNIX - Steps for installing and configuring the Agilent ICT UNIX inspection system.
- Chapter 12, Verifying Data Transmission - Information on verifying data transmission.
- Chapter 13, Troubleshooting - Basic troubleshooting tips.
- Chapter 14, Getting Help - Information on technical support.
- Appendix A, Optional Configurations for Agilent ICT and Agilent AXI - Information on manually modifying testplans, generating GenCAM files, and making changes for TestWise SPC.
- Appendix B, Other Optional Settings - Instructions for setting up and using an RS232 barcode reader with the Agilent Repair Tool.
- Glossary - A list of common terms and definitions associated with the Intelligent Test Framework.
Installing the ITF Server

This chapter provides instructions on installing the ITF Server Components and the ITF Administration System.

- Installing the ITF Server Components and Administration System, 2-2

After installing the ITF Server, do the following to ensure smooth running of the ITF Server.

- Performing ITF Integrity Check, 2-8
- Optimizing the ITF Server for a Multi-Tester Environment, 2-10

**CAUTION**

⚠️ It is essential that you follow the instructions exactly, in the order given. If you do not follow the Setup Guide exactly, the system will not function properly.

**CAUTION**

⚠️ Whenever you change the time settings on the ITF Server, you must restart the system.
**Installing the ITF Server Components and Administration System**

To install ITF Server Components and ITF Administration System:

1. Insert the ITF Server Installation CD into the ITF Server. The setup will start automatically. If it does not, double-click the file, `setup.exe`, in the CD.

The setup program starts extracting files.

**Figure 2-1 Extracting files**

After the files are extracted, the **Welcome** dialog box appears.

**Figure 2-2 Welcome dialog box**
Chapter 2: Installing the ITF Server: Installing the ITF Server Components and Administration System

2  Click Next.

The License Agreement dialog box appears.

3  Read the Agilent License Agreement, and then click Yes to accept it.

The Release Notes dialog box appears.

4  Read the Release Notes, and then click Next.

The Enter Text dialog box for entering the ITFSS3.1 serial number appears.
5 Enter the serial number located at the back of the ITFSS3.1 envelope and then click Next.

The Choose Destination Location dialog box for ITF appears. The default directory is C:\Agilent\ITFSS3.1\ITF\.

Figure 2-5 Enter destination folder for ITF

6 To accept the default destination, click Next. Otherwise, enter the desired destination and click Next.

The Choose Destination Location dialog box for the data store appears. The default directory is E:\Agilent\ITFSS\DataStore. If the E:\ drive is not available, the default directory will be C:\Agilent\ITFSS\DataStore.

Figure 2-6 Enter destination location for data folder

7 To accept the default directory, click Next. Otherwise, enter the desired directory and click Next. The Edit Data dialog box appears.
Chapter 2: Installing the ITF Server: Installing the ITF Server Components and Administration System

8 To accept the default locations, click **Next**. Otherwise, enter the desired locations and click **Next**. The **Edit Data** dialog box for entering the port number appears.

9 To accept the default server port number of 7331, click **Next**. Otherwise, enter the server port number and click **Next**. The **Edit Data** dialog box for entering the port number for the web application appears.
Chapter 2: Installing the ITF Server: Installing the ITF Server Components and Administration System

Figure 2-9 Enter port number for web application

10 Enter the port number for the web application, ITF Administration System, and then click Next.

ADVICE

It is recommended that the port 8080 be used for the ITF Administration System.

The Start Copying Files dialog box appears for you to review the installation settings.

Figure 2-10 Review installation settings

11 Review the installation settings and then click Next. The Setup Status dialog box appears, displaying the progress of the installation.
If a read-only file is detected during the installation, select the **Don't display this message again** check box and then click **Yes**.

**Figure 2-11** Setup Status dialog box

**Figure 2-12** Read-only file detected

When the installation is completed, the **Setup Complete** dialog box appears.

**Figure 2-13** Setup Complete

12 Click **Finish**.
Performing ITF Integrity Check

To verify that the ITF software is correctly installed:

1. Double-click the **ITF Administration System** desktop icon on the ITF Server.
   This opens the browser-based ITF Administration System application login page.

2. Log in to the ITF Administration System as:
   - **User** = Administrator
   - **Password** = password

3. Click **Login** to gain access to the system.
   If you are able to gain access into the ITF Administration System, this means the ITF installation has been completed correctly.

**NOTE**
If you are unable to log in, follow the instructions given in **Rectifying Login to ITF Administration System** to solve the problem.
Chapter 2: Installing the ITF Server: Performing ITF Integrity Check

Rectifying Login to ITF Administration System

To rectify the login problem, you need to create a new ITF database. Before doing that, make sure the ITF services are stopped and the SQL services are started.

Stopping the ITF services

1. Browse to the installed ITF folder on the ITF server. The default ITF directory is located at C:\Agilent\ITFSS3.1\ITF.
2. Go to the bin subfolder.
3. Double-click the file, StopServices.bat.

Starting the SQL services

1. Double-click the SQL Server Service Manager icon on the Windows system tray.
2. Click Start and wait for the SQL server to restart.

Creating a new ITF database

1. Detach the ITF database files from the SQL server.
   a. Click Start > Programs > Microsoft SQL Server > Enterprise Manager.
   b. In the console tree, select Console Root > Microsoft SQL Servers > SQL Server Group > (local) (Windows NT).
   c. Right-click ITF and select All Tasks > Detach Database on the menu that appears.
   d. Click OK.

2. Remove the incomplete database files.
   a. Browse to the E:\Program Files\Microsoft SQL Server\MSSQL\Data folder.
   b. Delete itf_Data.MDF and itf_Log.LDF.

3. Run the batch file for creating the new ITF database.
   a. Browse to the C:\Agilent\ITFSS3.1\ITF\db folder.
   b. Double-click the MakeDB.bat file.
      A new ITF database is created.

Starting the ITF services

1. Browse to the installed ITF folder on the ITF server. The default ITF directory is located at C:\Agilent\ITFSS3.1\ITF.
2. Go to the bin subfolder.
3. Double-click the file, StartServices.bat.

Now, try again to log in to the ITF Administration System. If you can log in successfully, this means that the database has been restored correctly.
Optimizing the ITF Server for a Multi-Tester Environment

The `minPoolSize` and `maxPoolSize` parameters in the `Config.properties` file on the ITF Server specify the minimum and maximum number of concurrent background processing threads in the ITF Server. These two parameters are set by default at 1 and 3 respectively to optimize the ITF server for running in a single-tester environment.

If the ITF server has more than one tester connected to it, you may change the parameter settings to optimize the ITF Server.

To change the parameter settings:

1. Stop all ITF Services. For details, see Stopping the ITF services.
2. Browse to the installed ITF folder on the ITF server. The default ITF directory is located at `C:\Agilent\ITFSS3.1\ITF`.
3. Go to the `storage\AgentContainerRoot\agent\AgentNetServer` subfolder.
4. Use a text editor, such as Notepad and edit the `minPoolSize` and `maxPoolSize` parameters in the `Config.properties` file to the following values:

   ```
   type=com.agilent.mtis.agilent.impl.AgentNetServer
   maxPoolSize=80
   minPoolSize=40
   port=7331
   responseDir=${AgentHome}->response
   registry=AgentNameRegistry
   ```

5. Save the `Config.properties` file.
6. Restart the services. For details, see Starting the SQL services.

The new settings will apply.
Networking the ITF Server

- Overview, 3-2
- Connecting the ITF Server to the Network, 3-3
- Setting TCP/IP Connections, 3-4

**CAUTION**

⚠️ It is essential that you follow the instructions exactly, in the order given. If you do not follow the Setup Guide exactly, the system will not function properly.

**CAUTION**

⚠️ Whenever you change the time settings on the ITF Server, you must restart the system.
Networking the Intelligent Test Framework (ITF) Server includes the following steps:

- Verifying the Hardware, Software and Networking Components
- Connecting the ITF Server to the Network
- Setting the TCP/IP Connections
- Setting Permissions for the User Account “ITFUser”

For ITF applications to work correctly, Ethernet links must exist among the ITF Server, the Client PCs, and the selected test systems (either Agilent AXI, Agilent AOI, and/or Agilent ICT).
Connecting the ITF Server to the Network

The ITF Server receives test and repair information for use with the Agilent Repair Tool and Agilent Quality Tool. In order for the ITF Server to function correctly, it must be networked to the other systems and share result folders with the Agilent AXI, Agilent AOI, and/or Agilent ICT test and inspection systems.

Follow your company’s networking procedures when adding the ITF Server to your local area network. In addition, make sure the following conditions are met:

- Appropriate Network Interface Cards (NIC) are installed on all machines and they can successfully "ping" (send and receive a test communication handshake) to each other.

To verify this:

1) Open a Command Prompt window on the ITF Server.

2) Type `ping <name of computer>` at the command prompt where `<name of computer>` represents the name of a test system on your ITF network.

3) Press Enter.
   If the NIC cards can successfully “ping” to each other, a message will appear, stating the “ping” statistics.

4) Repeat this test for each test system connected to the Intelligent Test Framework.

- All network cabling is correctly installed, network switches (recommended) or hubs are properly configured, and network nodes are configured and physically connected.
Setting TCP/IP Connections

After the ITF Server is physically connected to the network, you must set up its TCP/IP connections.

**NOTE**

It is recommended that the ITF Server be assigned a static IP address (rather than using DHCP). You may need to contact your IT department to obtain a static IP address.

To set the TCP/IP connections,

1. At the Windows® Login dialog box on the ITF Server, log in with *Administrator privileges*. Check with your IT department if you do not have Administrator access.

2. Click **Start > Settings > Network and Dial-up Connections**.

3. Double-click **Local Area Connection**.

4. Click the **Properties** button.

5. In the Local Area Connection Properties dialog box, select **Internet Protocol (TCP/IP)**, and then click the **Properties** button.

6. In the Internet Protocol (TCP/IP) Properties dialog box, select the **Use the following IP address** and **Use the following DNS server address** options. Fill in the appropriate information for each category. If you have WINS, click the **Advanced** button; otherwise, click **OK**.
Chapter 3: Networking the ITF Server: Setting TCP/IP Connections

**Figure 3-3** Internet Protocol (TCP/IP) Properties dialog box

For WINS, select the **WINS** tab in the **Advanced TCP/IP Settings** dialog box, and then click **Add**.

**Figure 3-4** WINS tab

Enter the IP Address of the WINS Server in the **TCP/IP WINS Server** dialog box, and then click **Add**.

**Figure 3-5** TCP/IP WINS Server dialog box
Chapter 3: Networking the ITF Server: Setting TCP/IP Connections

7 Click OK at each dialog box until all dialog boxes are closed.

Networking of the ITF Server is completed.

Please proceed to Chapter 4, Setting Up Software Licenses.
Setting Up Software Licenses

- **Overview**, 4-2
- **Required Tools and Materials**, 4-3
- **Setting Up Licenses**, 4-4
- **Viewing Licenses**, 4-8
- **Additional Licenses**, 4-9
- **Troubleshooting**, 4-10

**CAUTION**

⚠️ It is essential that you follow the instructions exactly, in the order given. If you do not follow the Setup Guide exactly, the system will not function properly.
Overview

Before continuing with the networking, installation and configuration process for the Intelligent Test Framework, you should first set up your software licenses. This process includes:

- Downloading the software license file from the Agilent Software Licensing web site
- Activating the license file using the ITF Administration System

NOTE

The ITF Administration System is a browser-based application located on the ITF Server. It is used to configure system properties within ITF applications. System properties include user access, repair configurations, and framework services.
Chapter 4: Setting Up Software Licenses: Required Tools and Materials

Required Tools and Materials

Before activating your software license, you will need the following items:

- ITF Software Solutions 3.1 or later
- An Entitlement Certificate which contains an Order Number and Certificate Number
- ITF Server MAC address
- Product serial number (found on the back of the CD envelope.)
- An internet connection (You do not need an internet connection from the ITF Server itself.)
- A valid email address
- Ability to transfer a 1 kb file from the computer that has the license file to the ITF Server by using a diskette, CD or network connection

NOTE

The Entitlement Certificate evidences Agilent Technologies' grant of the right to use the software products listed on the certificate. Each license redeemed from this certificate authorizes the use of the software product on a Client PC or ITF Server.

Figure 4-1  Example Entitlement Certificate

CAUTION

The Entitlement Certificate is an important document. Keep it for your records. You will need the Entitlement Certificate to reactivate or recover your software licenses.
Setting Up Licenses

To set up the software licenses for the ART and AQT clients:

1. Start the ITF Administration System on the ITF Server by double-clicking the ITF Administration System desktop icon.

2. Log on to the ITF Administration System as:
   - User = Administrator
   - Password = password

   **NOTE**
   The ITF Administration System login is case-sensitive.

3. Click Framework > Licenses on the main menu.

4. Click Set Up.

5. Click ART/AQT.

   The ITF Administration System provides you with the following information about your ITF Server:
   - Hostname
   - MAC Address

6. Print or write down the MAC address. You will need it when accessing the Agilent Software Licensing web site.

7. From any computer with Internet access, browse to the Agilent Software Licensing web site at http://www.agilent.com/find/softwarelicense.

   **NOTE**
   It is assumed that the ITF Server does not have Internet access. If it does, simply browse to the Agilent Software Licensing web site from the ITF Server and follow the instructions below.

   If you do not have Internet access or cannot contact Agilent through this web site, contact the Agilent Customer Support Center at 1-800-447-TEST (U.S. only) for assistance. If you are located outside the U.S., please contact your local Agilent representative.

8. Once at the Agilent Software Licensing web site, click Click here to start software license redemption.

9. Enter the Order Number and Certificate Number from your Entitlement Certificate, and then click Search.

10. The next window provides you with three options. Click Option I: Request license(s) for one or more software products on one instrument or host computer.

   **NOTE**
   You may redeem licenses for only one ITF Server at a time.
11 Select the product for which you want to redeem a license (i.e., Agilent Repair Tool or Agilent Quality Tool).

The products are listed in the drop-down menu. The “available” and “desired” quantities are filled in automatically. If necessary, change the desired quantity for licensing. This is the number of products that you wish to license at this time.

12 Click **Add**.

The product is listed in the **Selected Product List** box. If you have more than one product for which you would like to redeem a software license, repeat steps 10 and 11.

13 At the bottom of the page, enter the MAC Address of the ITF Server and the Product Serial Number.

14 Click **Next**.

15 Review the transaction and click **Next**.

16 Enter an email address where you can retrieve the license file.

17 Click **Submit**.

An email will be sent to you with your license file.

18 Review and print the confirmation page.

19 Click **Close** to exit the Agilent Software Licensing web site.

20 Open your email and look for a new message from license_support@agilent.com. If you have network access to the ITF Server, copy the attached license file over the network to the ITF Server. Otherwise, copy the file to a diskette, then go over to the ITF Server.

![CAUTION]

Check that the license file ends with a .lic file name extension. If the file does not have a .lic extension, change the file extension to .lic manually.

21 Return to the ITF Administration System on the ITF Server.

22 Click **Framework > Licenses > Set Up** to continue with the licensing process.

23 If you have copied the license file to a diskette, insert the diskette into the appropriate drive on the ITF Server.

24 Click **ART/AQT**.
Chapter 4: Setting Up Software Licenses: Setting Up Licenses

25 Enter the location of the license file in the Enter the license file path text box. You can also browse to the path using the Browse button.

**Figure 4-2** Set Up ART and AQT Client Licenses

<table>
<thead>
<tr>
<th>Set Up Licenses</th>
</tr>
</thead>
<tbody>
<tr>
<td>For more detailed information, see the Set Up Licenses section of the online help.</td>
</tr>
<tr>
<td>1. <strong>Print or write down the ITF Server Information</strong></td>
</tr>
<tr>
<td><strong>Hostname</strong></td>
</tr>
<tr>
<td><strong>MAC Address</strong></td>
</tr>
<tr>
<td>2. <strong>Complete the steps below to retrieve the software license file</strong></td>
</tr>
<tr>
<td>a. From a machine with Internet access, Go to the Agilent Licensing website at <a href="http://www.agilent.com/invokicslsoftwarelicense">http://www.agilent.com/invokicslsoftwarelicense</a></td>
</tr>
<tr>
<td>b. Enter the MAC address and product serial number of the ITF Software, when prompted.</td>
</tr>
<tr>
<td>c. Retrieve the email with the license file.</td>
</tr>
<tr>
<td>d. Save the file to a temporary location.</td>
</tr>
<tr>
<td>e. Note the file name and directory</td>
</tr>
<tr>
<td>3. Enter the license file path</td>
</tr>
</tbody>
</table>

*The production serial number of the ITF Software is found at the back of the installation CD envelope.*

26 Click Next >.

The system activates the file and the ITF License Information table is automatically populated to reflect your new license.

27 Compare the new licenses listed in the ITF License Information table with those listed on your Entitlement Certificate. They should match. If they are not identical, an error may have occurred during the licensing process. Please contact your local Agilent representative or the Agilent Customer Support Center at 1-800-447-8378 (U.S. only).
Chapter 4: Setting Up Software Licenses: Setting Up Licenses

NOTE

In order to activate additional licenses in the future, you will need to download a new software license file. See Additional Licenses on page 4-9 for more information.

Single-Tester ITF Servers are limited to only one license for the Agilent Repair Tool and one license for the Agilent Quality Tool.

28 Log out of the ITF Administration System.

29 It is recommended that you save a copy of your license file in case you need to recover your ITF Server in the future. Store your license file with your Entitlement Certificate into the diskette.

30 Remove the diskette with the license file from the ITF Server drive.
Viewing Licenses

The ITF License Information table in the ITF Administration System lists your current licenses for all your ITF software applications and their expiration dates.

To view your current software licenses:

1. Login to the ITF Server with Administrator privileges.
2. Start the ITF Administration System by double-clicking the ITF Administration System desktop icon.
3. Login to the ITF Administration System on the ITF Server as Administrator.
4. Click Framework > Licenses > List on the main menu.

The ITF License Information table appears, listing your current licenses and their expiration dates.

**NOTE**

The ITF License Information table for Single-Tester ITF Servers will list only one license for the Agilent Repair Tool and one license for the Agilent Quality Tool.

The ITF License Information table is updated automatically whenever a new software license file is activated. See Setting Up Licenses on page 4-4 for more information.
Additional Licenses

If you have an Entry or Standard ITF Server, you can purchase additional software licenses for the various ITF software applications at any time. Single-Tester ITF Servers are limited to only one license per application.

If you would like to purchase additional licenses, contact your local Agilent field representative for assistance. They will process your order and issue you a new Entitlement Certificate.

Once you receive your Entitlement Certificate, follow the steps listed under Setting Up Licenses on page 4-4.
Chapter 4: Setting Up Software Licenses: Troubleshooting

Troubleshooting

If for some reason, you can no longer use the software license file after activation, use the following recovery process.

The following procedure will only work for the same MAC address for which the original license was processed. If no license history is found or you cannot locate your Entitlement Certificate, contact your local Agilent representative or call the Agilent Customer Support Center at 1-800-447-8378 (U.S. only) for assistance.

To recover your license file:

1. Locate your original Entitlement Certificate.

   **NOTE**

   If you do not have the Entitlement Certificate, you will not be able to retrieve your software license file through the Agilent Software Licensing web site. You will need to contact your local Agilent representative or call the Agilent Customer Support Center at 1-800-447-8378 (U.S. only) for assistance.


3. Once at the Agilent Software Licensing web site, click **Click here to start software license redemption**.

4. Enter the **Order Number** and **Certificate Number** from your Entitlement Certificate, and click **Search**.

   The next window provides you with three options.

5. Click **Option III: Get previously-issued licenses for this order number**.

6. Right-click the license file you need and choose **Save Target As** to retrieve the software license file.

7. Save the software license file to a directory from which you can retrieve it later.

8. If you have network access to the ITF Server, copy the license file over the network to the ITF Server. Otherwise, copy the file to a diskette, then go over to the ITF Server.

   **CAUTION**

   Check that the license file ends with a `.lic` file name extension. If the file does not have a `.lic` extension, change the file extension to `.lic` manually.

9. Return to the ITF Administration System on the ITF Server.

10. Login to the ITF Administration System on the ITF Server as **Administrator**.

11. Click **Framework > Licenses > Set Up**. Skip steps 1 and 2 in the **Set Up Licenses** dialog box.
12 If you have copied the license file to a diskette, insert the diskette into the appropriate drive on the ITF Server.

13 Enter the location of the license file in the **Enter the license file path** text box. You can also browse to the path using the **Browse** button.

14 Click **Next >**.

The system activates the file and the ITF License Information table is automatically populated to reflect your new license.

15 Compare the new licenses listed in the ITF License Information table with those listed on your Entitlement Certificate. They should match. If they are not the same, an error may have occurred during the licensing process. Please contact your local Agilent representative or the Agilent Customer Support Center at 1-800-447-8378 (U.S. only).

**NOTE**

This process will only work for the same MAC address to which the original license was submitted. If no license history is found or you cannot locate your Entitlement Certificate, contact your local Agilent representative or call the Agilent Customer Support Center at 1-800-447-8378 (U.S. only) for assistance.

16 Store your license file together with your Entitlement Certificate.

17 Remove the diskette from the ITF Server floppy drive.
Setting Up Permissions and Logins

- Overview, 5-2
- Setting Permissions and Logins, 5-3

**CAUTION**

⚠️ It is essential that you follow the instructions exactly, in the order given. If you do not follow the Setup Guide exactly, the system will not function properly.
Chapter 5: Setting Up Permissions and Logins: Overview

Overview

Prior to using an ITF software application, such as the Agilent Repair Tool or Agilent Quality Tool, you need to establish permissions and logins using the ITF Administration System.

The ITF Administration System is a browser-based application located on the ITF Server. It is used to configure system properties within the Agilent ITF and other applications. System properties include user access, repair configurations, and framework services.

The purpose of the ITF Administration System is to provide user security and control functionality for the following categories of information:

- Users
- Agilent Repair Tool - AXI, AOI, and ICT
- Agilent Quality Tool - AXI and AOI
- Intelligent Test Framework
Chapter 5: Setting Up Permissions and Logins: Setting Permissions and Logins

Setting Permissions and Logins

Each user must be assigned a login ID, password, and role to access ITF software applications. Once a user has been added to the system, that user’s information is automatically added to the data store and the user can immediately access any resource for which they have permission.

**NOTE**

You can access the ITF Administration System in one of two ways:

1. Directly from the ITF Server
2. From a web browser on a system connected to the network:
   
   \[ \text{http://<Name of ITF Server>:nnnn/adminclient} \]

   where nnnn is the port number

To assign user permissions and login IDs:

1. Open the ITF Administration System by either:
   - Double-clicking the ITF Administration System desktop icon on the ITF Server or
   - Browsing to the following location from a web browser on any system connected to the network:

   \[ \text{http://<Name of ITF Server>:nnnn/adminclient} \]

   where nnnn is the port number

   **NOTE**

   This System Administrator account is set up automatically during installation. It is a permanent account that has the unique ability to assign other users an administrative role.

   At this time, you may want to change the default password for the ITF Administration System. Click **Users > Set Up**, Click **Edit** in the Administrator row. Click the **Change Password** button and enter your new password. Be sure to follow your company’s guidelines for assigning passwords.

2. At the login dialog box, type **Administrator** for the **User Name** and **password** for the **Password**, and then press **Enter**.

3. Click **Users > Set Up** on the main menu.

   This opens a data table with the **Add User** button located above it.

4. Click **Add User**.

   The **Add User** dialog box appears.
5 Complete the user profile information, including the login ID, first name, last name, and password.

**NOTE**

The login ID and password fields are case-sensitive and must contain a character string between 3 and 15 characters to be valid. Both numbers and letters are acceptable in the password. Be sure to follow your company’s guidelines for assigning passwords.

**Figure 5-2** Add User dialog box

![Add User dialog box](image)

6 Choose one or more roles to assign the user by selecting them in the **Roles Available** box.
Chapter 5: Setting Up Permissions and Logins: Setting Permissions and Logins

NOTE
At least one role must be assigned to each new user or the user cannot be added to the data store.

For more information on the various types of roles, please see the ITF Administration System online help.

7 Click Add > to assign the role(s) to the selected user.

The role is automatically moved to the Assigned Roles column.

NOTE
To assign all available roles to a user, click Add All >>.

8 Click Apply to save the user information.

Changes are applied immediately.

9 When you have completed your changes, click Logout to exit the ITF Administration System.

You are now ready to install the ART and AQT applications on the client PCs. Proceed to Chapter 6, Installing, Configuring and Running the Agilent Repair Tool.
Installing, Configuring and Running the Agilent Repair Tool

- **Overview**, 6-2
- **Installing ART**, 6-5
- **Configuring ART**, 6-11
- **Running ART**, 6-13

**CAUTION**

⚠️ It is essential that you follow the instructions exactly, in the order given. If you do not follow the Setup Guide exactly, the system will not function properly.
Overview

The Agilent Repair Tool (ART) is a printed circuit board repair tool that supports a common graphical user interface for all three types of Agilent Technologies automated inspection systems: Agilent AXI, Agilent AOI, and Agilent ICT UNIX and WN systems. With this tool, operators can leverage skills, knowledge and training across X-ray (AXI), optical (AOI) and in-circuit test (ICT) repair loops. This increases the efficiency of repair and provides a more consistent method for reporting repair efforts.

See Figure 6-2 for information on files and data shared among test systems, ART, and an Entry or Standard ITF Server.

See Figure 6-3 for information on files and data shared among a test system, ART, and a Single-Tester ITF Server.

Figure 6-1 ART Welcome Screen

ART is an application that uses the Intelligent Test Framework. The Intelligent Test Framework allows for data sharing and communication among test systems and applications, such as ART.

When ART is used with an Entry or Standard ITF Server, it is installed on a Client PC. When ART is used with a Single-Tester ITF Server, it is installed on the server.
Figure 6-2  ART Data Flow for Entry and Standard ITF Servers

Agilent AXI

Agilent AOI

Agilent ICT

.res
.ex
.log
<Folder> .jpg
.ph

.rep
.plx
.pls
.dat
<Folder> .jpg

GenCAM files
Log records

Quality Client

Repair Client

Standard or Entry ITF Server

Quality Client

Repair Client
Figure 6-3  ART Data Flow for the Single-Tester ITF Server

Note: The ART may be installed on a Client PC instead of the Single-Tester ITF Server.
Chapter 6: Installing, Configuring and Running the Agilent Repair Tool: Installing ART

Installing ART

In order to use ART, you need to install it on the Client PC or the ITF Server.

The following information provides guidance for the successful installation of the ART.

Prior to installing ART, verify the following:

- The Date/Time and time zone settings on the ITF Server match the Date/Time and time zone settings on your test systems and Client PCs. All machines attached to the Intelligent Test Framework must have the same Date/Time and time zone settings. Be sure to restart the ITF Server or Client PC after changing the time setting.

- The assumptions have been met under System Requirements.

To install ART:

1. If you are installing ART on a Client PC, log on with Administrator privileges.
   If you are installing AQT on a Single-Tester ITF Server, log on with Administrator privileges and then skip to Step 6.

2. Open Windows® Explorer.

3. On the Tools menu, click Map Network Drive.

4. Map to the ITF Server from the Client PC.
   a. Select any available drive in the Drive text box.
   b. Enter the folder (Windows 2000/Windows XP):
      ```\<System Name of ITF Server>\install```
   c. If you do not want this drive to reconnect at logon, clear the Reconnect at Logon check box.
   d. Click Finish for Windows® 2000/Windows XP.

   **NOTE**
   It may be necessary to provide the ITF Server’s Administrator login name and password to complete the mapping to a network drive.
5 If you are installing the ART on the Single-Tester ITF Server, you must change the licensing mode for the SQL Server. To change the licensing mode,
   a  Click Start > Settings > Control Panel.
   b  Double-click SQL Server 2000 Licensing Setup.
   c  In the Choose Licensing Mode dialog box, change the number of devices in the Licensing Mode box to 2.
   d  Click Continue.
6 Locate the applications directory on the ITF Server.
7 Double-click the agilent_repair_tool_3_1.exe file. This is a self-extracting file that opens automatically to the temp directory and begins the installation of ART on the Client PC.
   The setup program starts extracting files.
Chapter 6: Installing, Configuring and Running the Agilent Repair Tool: Installing ART

After the files are extracted, the **Welcome** dialog box appears.

**Figure 6-5** Welcome dialog box

8 Click **Next**.

The **License Agreement** dialog box appears.

**Figure 6-6** License Agreement dialog box
9 Read the Agilent License Agreement, and then click Yes to accept it.

The Release Notes dialog box appears.

10 Read the Release Notes, and then click Next.

The Choose Destination Location dialog box appears.

Figure 6-7 Enter destination location for ART

11 To accept the default destination, click Next.

Otherwise, enter the desired destination and click Next.

The Serial Port Barcode Reader dialog box appears.

12 If you will be using an RS232 (serial port) barcode reader with ART, click Yes. Otherwise, click No.

CAUTION

! If you are planning on using an RS232 barcode reader, answer Yes when asked during the software installation. If you are planning on using an RS232 barcode reader later, answer No. In this case, you will have to re-install the ART software when you want to use the RS232 barcode reader.

The Start Copying Files dialog box appears for you to review the installation settings.
Chapter 6: Installing, Configuring and Running the Agilent Repair Tool: Installing ART

13 **Click Next.**

The **Setup Status** dialog box appears, displaying the progress of the installation.

When the installation is completed, the **Setup Complete** dialog box appears.
**Figure 6-11** Setup Complete

14 Click **Finish**.

The installation of the Agilent Repair Tool software on the Client PC is completed.
Chapter 6: Installing, Configuring and Running the Agilent Repair Tool: Configuring ART

Configuring ART

You need to specify the data source before you can use ART.

NOTE
If you wish to view ART in Chinese, you need to change your client PC’s locale to Chinese (PRC) by using the Regional and Language Options in the Windows Control Panel. Detailed steps can be found in Changing the Locale.

To specify the data source:

1. Open ART by double-clicking the Agilent Repair Tool desktop icon.

Figure 6-12   Agilent Repair Tool icon

2. Click Cancel when the Login User dialog box appears.

3. On the Tools menu, click Data Source.

   The Data Source dialog box appears.

Figure 6-13   Data Source dialog box

4. Enter the name or IP address of the ITF Server and then click OK.

   NOTE
   If you change the IP address of your ITF Server in future, you need to redefine the data source using steps 3 through 4 above.

5. To verify that the Client PC has successfully connected to the ITF Server,

   a. Click Login.

   b. The list of user names that have been set up on the ITF Server should be displayed. If so, then the Client PC is connected to the ITF Server.

   c. If the list of user names is not displayed, check the configuration steps again and/or consult your System Administrator.
NOTE

See Setting Permissions and Logins on page 5-3, for information on setting up user names, passwords, and permissions.

For 3DRender Users

If you are using 3DRender, please note that it runs at a lower speed on ART Client PCs than it does on an SJ/SP PC platform. For a smoother operation, it is recommended that you change the default value of the parameter, Recon_hires, from 1000 to 150. This parameter is stored in the settings.txt file located in the C:\Program Files\Agilent Technologies\3DRender folder.

Repeat the installation and configuration procedures for each ART Client PC you wish to connect to the Intelligent Test Framework.
To run the Agilent Repair Tool:

1. Double-click the Agilent Repair Tool desktop icon on your Client PC or Single-Tester ITF Server.

2. Log in to the Agilent Repair Tool. If you have not already set permissions and logins, please see Chapter 5, Setting Up Permissions and Logins.

3. For information on how to use the functions in ART, refer to the Agilent Repair Tool online Help. To display the online Help, click Contents on the Help menu of the Agilent Repair Tool window.

NOTE

If you would like to use ART in-line with the Agilent SJ Series, refer to the section, Setting up ART for in-line use with the Agilent AOI in Appendix B.

If you are using an RS232 barcode reader, refer to the section, Using an RS232 Barcode Reader with the Agilent Repair Tool in Appendix B.

NOTE

The first time ART opens a board, the response time may be longer due to the number of defects and complexity of the board types.
Installing, Configuring and Running the Agilent Quality Tool

- Overview, 7-2
- Installing AQT, 7-5
- Configuring AQT, 7-10
- Running AQT, 7-12

CAUTION

⚠️ It is essential that you follow the instructions exactly, in the order given. If you do not follow the Setup Guide exactly, the system will not function properly.
Chapter 7: Installing, Configuring and Running the Agilent Quality Tool: Overview

Overview

The following information provides guidance for the successful installation of the Agilent Quality Tool on a Client PC or the Single-Tester ITF Server.

The Agilent Quality Tool is a common SPC/SQC tool for the Agilent AXI and Agilent AOI test systems. It provides quick and easy access to actionable information on quality, line throughput, and false calls.

Figure 7-1  Agilent Quality Tool Welcome Screen

The Agilent Quality Tool is an application that uses the Intelligent Test Framework (ITF). The Intelligent Test Framework allows for data sharing and communication among test systems and applications, such as the Agilent Quality Tool.

See Figure 7-3 for information on files and data shared among test systems, the Agilent Quality Tool, and the Single-Tester ITF Server.

See Figure 7-2 for information on files and data shared among test systems, the Agilent Quality Tool, and Standard or Entry ITF Servers.
Figure 7-2  Agilent Quality Tool Data Flow with an Entry or Standard ITF Server
Chapter 7: Installing, Configuring and Running the Agilent Quality Tool: Overview

Figure 7-3  Agilent Quality Tool Data Flow with a Single-Tester ITF Server

Note: The Agilent Quality Tool may be installed on a Client PC instead of the Single-Tester ITF Server.
Installing AQT

Before you install the Agilent Quality Tool software on the Client PC or Single-Tester ITF Server, please verify that the assumptions have been met under System Requirements.

NOTE

The following installation procedure must be completed for each Client PC you wish to connect to the Intelligent Test Framework.

It is recommended that you accept all default installation options rather than perform a custom installation.

Prior to installing the Agilent Quality Tool, check to see that the Date/Time and time zone settings on the ITF Server match the Date/Time and time zone settings on your test systems and Client PCs. All machines attached to the Intelligent Test Framework must have the same Date/Time and time zone settings. Be sure to restart the ITF Server or Client PC after changing the time setting.

To install the Agilent Quality Tool:

1. If you are installing AQT on a Client PC, log on with Administrator privileges.
   If you are installing AQT on a Single-Tester ITF Server, log on with Administrator privileges and then skip to Step 6.

2. Open Windows® Explorer.

3. On the Tools menu, click Map Network Drive.

4. Map to the ITF Server from the Client PC.
   a. Select any available drive in the Drive text box.
   b. Enter the folder (Windows 2000/Windows XP):
      \<System Name of ITF Server>\install
   c. If you do not want this drive to reconnect at logon, clear the Reconnect at Logon check box.
   d. Click Finish for Windows® 2000/Windows XP.

NOTE

It may be necessary to provide the ITF Server’s Administrator login name and password to complete the mapping to a network drive.
5 If you are installing the Agilent Quality Tool on the Single-Tester ITF Server, you must change the licensing mode for the SQL Server. To change the licensing mode,
   a Click Start > Settings > Control Panel.
   b Double-click SQL Server 2000 Licensing Setup.
   c In the Choose Licensing Mode dialog box, change the number of devices in the Licensing Mode box to 2.
   d Click Continue.

Figure 7-4 Choose Licensing Mode dialog box

7 Double-click the agilent_quality_tool_1_1.exe file. This is a self-extracting file that automatically opens to the temp directory and begins the installation of the Agilent Quality Tool on the Client PC or Single-Tester ITF Server.

The setup program starts extracting files.

Figure 7-5 Extracting Files dialog box

6 Locate the applications directory on the ITF Server.
Chapter 7: Installing, Configuring and Running the Agilent Quality Tool: Installing AQT

After the files are extracted, the **Welcome** dialog box appears.

**Figure 7-6** Welcome dialog box

8 Click **Next**.

The **License Agreement** dialog box appears.

**Figure 7-7** License Agreement dialog box
9 Read the Agilent License Agreement, and then click **Yes** to accept it.

The **Release Notes** dialog box appears.

10 Read the Release Notes, and then click **Next**.

The **Choose Destination Location** dialog box appears.

![Figure 7-8](image)

Enter destination location for AQT

11 To accept the default destination, click **Next**.

Otherwise, enter the desired destination and click **Next**.

The **Start Copying Files** dialog box appears for you to review the installation settings.

![Figure 7-9](image)

Start Copying Files dialog box

12 Click **Next**.

The **Setup Status** dialog box appears, displaying the progress of the installation.
When the installation is completed, the **Setup Complete** dialog box appears.

13 Click **Finish**.

The installation of the Agilent Quality Tool software on the Client PC or Single-Tester ITF Server is completed.
You need to specify the location of the data source before you can use AQT.

To specify the location of the data source:

1. Open the Agilent Quality Tool software by double-clicking the Agilent Quality Tool desktop icon.

\[\text{Figure 7-12} \quad \text{Agilent Quality Tool icon}\]

2. Click **Cancel** when the **Login User** dialog box appears.

3. On the **Tools** menu, click **Data Source**.

   The **Data Source** dialog box appears.

\[\text{Figure 7-13} \quad \text{Data Source dialog box}\]

4. Enter the name or IP address of the ITF Server and then click **OK**.

\[\text{NOTE}\]

If you change the IP address of your ITF Server in future, you need to redefine the data source using steps 3 through 4 above.

5. To verify that the Client PC has successfully connected to the ITF Server,
   a. Click **Login**.
   b. You should see the list of user names that have been set up on the ITF Server. If you can see the list of current user names, the Client PC is connected to the ITF Server.
   c. If you cannot see the list of user names, recheck the configuration steps and/or check with your System Administrator.

\[\text{NOTE}\]

See Chapter 5, *Setting Permissions and Logins*, for information on setting up user names, passwords, and permissions.
Chapter 7: Installing, Configuring and Running the Agilent Quality Tool: Configuring AQT

Repeat the installation and configuration procedures for each AQT Client PC you wish to connect to the Intelligent Test Framework.

Remember that the Single-Tester ITF Server can only connect to one Agilent Quality Tool.
Running AQT

To run the Agilent Quality Tool:

1. Double-click the Agilent Quality Tool desktop icon on your Client PC or Single-Tester ITF Server.

2. Log in to the Agilent Quality Tool. If you have not already set permissions and logins, please see Chapter 5, Setting Up Permissions and Logins.

3. For information on creating Views and generating charts, refer to the Agilent Quality Tool online Help. To display the online Help, click Contents on the Help menu of the Agilent Quality Tool window.

**NOTE**

Trend charts in the Agilent Quality Tool are updated on the hour and every half-hour. Therefore, when creating a new View, please note that data may not appear in the View’s charts for up to 30 minutes.

For instance, if you start testing boards at 3:05pm and create a new View at 3:15pm. The data for the tested boards will not appear in your new View until 3:30pm.

You are now ready to connect test systems to the Intelligent Test Framework. Please continue with one of the following:

- If you would like to connect an Agilent AXI system to the Intelligent Test Framework, please see Chapter 8, Installing and Configuring the Agilent AXI.

- If you would like to connect an Agilent AOI system to the Intelligent Test Framework, please see Chapter 9, Installing and Configuring the Agilent AOI.

- If you would like to connect an Agilent ICT WN system to the Intelligent Test Framework, please see Chapter 10, Installing and Configuring the Agilent ICT WN.

- If you would like to connect an Agilent ICT UNIX system to the Intelligent Test Framework, please see Chapter 11, Installing and Configuring the Agilent ICT UNIX.
Installing and Configuring the Agilent AXI

- Overview, 8-2
- Pre-Installation Checklist, 8-3
- Installing the ITF Tester Components on the Agilent AXI, 8-4
- Configuring the Agilent AXI, 8-11

CAUTION

⚠️ It is essential that you follow the instructions exactly, in the order given. If you do not follow the Setup Guide exactly, the system will not function properly.
Overview

The following information provides guidance for the successful networking, installation, and configuration of the Intelligent Test Framework software on the Agilent AXI.

The process involves the following steps:

- Installing the Intelligent Test Framework software components on the Agilent AXI
- Configuring the Agilent AXI for use with the ITF software applications
Before you install the ITF components on the Agilent AXI, please review the pre-installation checklist below.

Table 8-1  Pre-Installation Checklist

<table>
<thead>
<tr>
<th>PRE-INSTALLATION CHECKLIST</th>
</tr>
</thead>
<tbody>
<tr>
<td>Complete all the networking steps listed in the Networking the ITF Server chapter of the documentation.</td>
</tr>
<tr>
<td>Check that your Agilent AXI meets the minimum system and software requirements for use with the Intelligent Test Framework. See System Requirements on page 1-5.</td>
</tr>
<tr>
<td>Check that TCP/IP is installed and working on your Agilent AXI.</td>
</tr>
<tr>
<td>Note down the system name of your ITF Server.</td>
</tr>
<tr>
<td>Verify that you can log on to the ITF Server and Agilent AXI controller with Administrator privileges.</td>
</tr>
<tr>
<td>Check that the Date/Time and time zone settings on the ITF Server match the Date/Time and time zone settings on the Agilent AXI. All machines attached to the Intelligent Test Framework must have the same Date/Time and time zone settings.</td>
</tr>
</tbody>
</table>
Chapter 8: Installing and Configuring the Agilent AXI: Installing the ITF Tester Components on the Agilent AXI

Installing the ITF Tester Components on the Agilent AXI

In order for an ITF software application, such as the Agilent Repair Tool, to receive and display Agilent AXI inspection data, there are several Intelligent Test Framework tester components that must be added to the Agilent AXI.

These components include the following files:

- ijl15.dll
- mkjpg.exe

These files will be placed in the `bin` directory.

**NOTE**

The following installation procedure must be completed for each Agilent AXI inspection system you wish to connect to the Intelligent Test Framework.

If you have a Single-Tester ITF Server, only one test system can be connected to the Intelligent Test Framework.

To add the Intelligent Test Framework tester components to the Agilent AXI:

1. Log on to the Agilent AXI controller with *Administrator privileges*.
2. Check that TCP/IP is installed on the Agilent AXI controller.
3. If a board test is in progress, wait for the test to be completed, then close/stop the Auto Reporter on the Agilent AXI.
4. Open Windows® Explorer.
5. On the **Tools** menu, click **Map Network Drive**.
   
   The **Map Network Drive** dialog box appears.
6. Map to the ITF Server from the Agilent AXI controller.
   
   a. In the Path text box, enter:
   
   ```
   \<System Name of ITF Server>\install
   ```
   
   b. Make sure you clear the the **Reconnect at Logon** check box.
   
   c. Click **OK**.

   **NOTE**
   
   It may be necessary to provide the Agilent ITF Administrator login name and password to complete the mapping to a network drive.

7. Locate the `components` directory on the newly-mapped drive.

   This is a self-extracting file that automatically opens to the `temp` directory and begins the installation process on the Agilent AXI controller.

   The setup program starts extracting files.
After the files are extracted, the **Welcome** dialog box appears.

**Figure 8-2**  Welcome dialog box
9  Click **Next**.

The **License Agreement** dialog box appears.

**Figure 8-3**  **License Agreement** dialog box

10 Read the Agilent License Agreement, and then click **Yes** to accept it.

The **Release Notes** dialog box appears.

11 Read the Release Notes, and then click **Next**.

The **Choose Destination Location** dialog box for ITF Agent appears. The default directory is `C:\Agilent\ITFSS3.1\Agent`.

**Figure 8-4**  **Enter destination folder for ITF Agent**

12 To accept the default directory, click **Next**. Otherwise, enter the desired directory and click **Next**.

The **Edit Data** dialog box appears.
13 Enter the name and port number of the ITF Server, and then click **Next**.

The **Setup type** dialog box for selecting the tester type appears.

14 Click **AXI** and then click **Next**.

You will receive the following warning message, if you attempt to install the components on a system other than an Agilent AXI controller.

The **Edit Data** dialog box appears for you to enter the local port number.
15 Enter the local port number and then click Next.
The Start Copying Files dialog box appears for you to review the installation settings.

16 Review the installation settings and then click Next.
The Setup Status dialog box appears, displaying the progress of the installation.
During the installation process, the **Modifications for trcmdpro.cmd** dialog box appears. It lists the changes that you need to make to the `trcmdpro.cmd` file on the Agilent AXI. The text will be saved automatically into a file called `trcmdpro.txt` in the Agilent AXI `bin` directory.

Use this file as a reference when you modify the `trcmdpro.cmd` file later.

For more information regarding these modifications, please see **Modifying the trcmdpro.cmd file** on page 8-11.
When the installation is completed, the **Setup Complete** dialog box appears.

**Figure 8-12  Setup Complete**

17 Click **Finish**.

18 Remove the drive mapping to the ITF Server (from **step 6**). In Windows Explorer, right-click the drive you just mapped and select **Disconnect**. Be sure not to display the contents of the mapped drive before disconnecting it.

19 Verify that ITFAgent Service is started.
   a  Click **Start > Control Panel**.
   b  Double-click **Administrative Tools** followed by **Services**.
      The **Services** console appears.

   c  Verify if the status of ITFAgent Service is indicated as **Started**. If it is not started, double-click it and click the **Start** button on the **ITFAgent Service Properties** dialog box.

   d  Verify if the **Startup type** is set to **Automatic**. If it is not, select and set it to **Automatic**.

   e  Press the **F5** key to refresh the service console to ensure the service has been started.

The installation of the Intelligent Test Framework tester components to the Agilent AXI is completed.

Please proceed to the next section, **Configuring the Agilent AXI**.
The process of configuring the Agilent AXI involves:

- **Modifying the trcmdpro.cmd file** on page 8-11
- **Modifying the plrimg.cfg file** on page 8-13

To configure the Agilent AXI for use with the Intelligent Test Framework, the `trcmdpro.cmd` file on the Agilent AXI controller must be modified to send the result files, CAD data, X-ray images, log files and `.plr` files to the ITF Server.

The `plrimg.cfg` file must also be modified to generate tif images for Agilent AXI software versions 7.3 and higher.

**NOTE**

These configuration steps must be repeated for each Agilent AXI inspection system you wish to connect to the Intelligent Test Framework.

If you have a Single-Tester ITF Server, only one test system can be connected to the Intelligent Test Framework.

---

**Modifying the trcmdpro.cmd file**

If you are using Agilent AXI software version 7.3 or higher, the `trcmdpro.cmd` file on your system includes most of the code needed for the ITF Server. However, you still need to manually insert and uncomment a few lines of code. If you are using a software version below 7.3, please contact your Agilent Field Engineer to upgrade to software version 7.3 or higher.

To configure the Agilent AXI:

1. Stop the Automatic Defect Reporter on the Agilent AXI controller by opening the Automatic Defect Reporter window, clicking in the window with the mouse and then pressing the ESC key.

2. Make a backup copy of the original `trcmdpro.cmd` file before editing.

3. Using a text editor, open the `trcmdpro.cmd` file on the Agilent AXI controller. Be sure to open and modify this file in a text editor.

   For assistance in locating the `TRCMDPRO.CMD` file, please refer to your Agilent AXI user manual.

4. Locate the log files section of the file.

5. Insert the code to send log files to the ITF Server and then delete them from the Agilent AXI. To do this, open the `trcmdpro.txt` file from the `bin` directory. Copy the appropriate Begin-End section and paste it into the `trcmdpro.cmd` file. See Figure 8-13 on page 8-12 for coding details.
Figure 8-13  Code for Sending Log Files to the ITF Server and Deleting Log Files on the Agilent AXI

;------------------------------------------------------------------------
; To delete the panel results log files, use the commands in
; the following example:

;BEGIN
;    trcp -plr &TRFILE P:\5DX\RES
;    cmd /cdel /Q $(RESROOT)\&TRNAME.LOG
;;
;    cmd /cdel /Q $(RESROOT)*.LOG
;    cmd /cdel /Q $(RESROOT)\&TRNAME\*.*
;    rd $(RESROOT)\&TRNAME
;END

BEGIN
    mkdir <INPUTDIR>\&TRNAME
    mkjpg <INPUTDIR>\&TRNAME $(RESROOT)\&TRNAME\*.tif
    copy $(RESROOT)\&TRNAME\*.plr <INPUTDIR>\&TRNAME
    trcp &TRFILE <INPUTDIR>
    cmd /cmove $(RESROOT)\&TRNAME.LOG <INPUTDIR>\&TRNAME.LOG
    cmd /cdel /Q $(RESROOT)\&TRNAME\*.*
    rd $(RESROOT)\&TRNAME
END

**NOTE**

<INPUTDIR> represents the actual path of the installed folder for the ITF tester agent, for example, C:\Agilent\ITFSS3.1\Agent\storage\Input.

Filters can be added to the trcmdpro.cmd file to prevent certain data from being transferred.

---

6 Check to make sure your code includes the correct drive letter for the ITF Server. If you did not map the Agilent AXI to the ITF Server using the data directory, change the code to reflect the appropriate drive.

7 Save the file.
Chapter 8: Installing and Configuring the Agilent AXI: Configuring the Agilent AXI

8 Restart the Automatic Defect Reporter on the Agilent AXI controller by double-clicking the **Automatic Reporter** desktop icon.

9 Modifying the `trcmdpro.cmd` file is complete.

**Modifying the `plrimg.cfg` file**

For Agilent AXI software versions 7.3 and higher, the `plrimg.cfg` file must be modified so that the Agilent AXI generates tif images. These tif images are used with the ITF software applications.

To modify the `plrimg.cfg` file:

1 Make a backup copy of the `plrimg.cfg` file before editing.

2 Open the `plrimg.cfg` file on the Agilent AXI controller. Be sure to open and modify this file in a text editor.

Refer to your Agilent AXI user manual for assistance in locating the `plrimg.cfg` file.

**NOTE**

For software version 7.3, the `PLRIMG.CFG` file should be located at:

```
C:\5DX\R73\CALIB\plrimg.cfg
```

3 Locate the variable `numDefJointsCapture`.

4 Set `numDefJointsCapture=1`.

5 Save the file.

Repeat the setup and configuration procedures for all Agilent AXI inspection systems you wish to connect to the Intelligent Test Framework.

If you have a Single-Tester ITF Server, only one test system can be connected to the Intelligent Test Framework.

Proceed to Chapter 12, **Verifying Data Transmission** to verify data transmission to the ITF Server.
Installing and Configuring the Agilent AOI

- Overview, 9-2
- Pre-Installation Checklist, 9-3
- Installing the ITF Tester Components on the Agilent AOI, 9-4
- Configuring the Agilent AOI, 9-12

**CAUTION**

⚠️ It is essential that you follow the instructions exactly, in the order given. If you do not follow the Setup Guide exactly, the system will not function properly.
Overview

The following information provides guidance for the successful networking, installation, and configuration of the Intelligent Test Framework software on the Agilent AOI inspection system.

The process involves the following steps:

- Installing the Intelligent Test Framework software components on the Agilent AOI.
- Configuring the Agilent AOI for use with the ITF software applications.
Pre-Installation Checklist

Before you install the ITF components on the Agilent AOI, please review the pre-installation checklist below.

Table 9-1  Pre-Installation Checklist

<table>
<thead>
<tr>
<th>PRE-INSTALLATION CHECKLIST</th>
</tr>
</thead>
<tbody>
<tr>
<td>Complete all the networking steps listed in the <em>Networking the ITF Server</em> chapter of the documentation.</td>
</tr>
<tr>
<td>Check that your Agilent AOI inspection system meets the minimum system and software requirements for use with the Intelligent Test Framework. See <em>System Requirements</em> on page 1-5.</td>
</tr>
<tr>
<td>Check that TCP/IP is installed and working on your Agilent AOI inspection system.</td>
</tr>
<tr>
<td>Note down the system name of your ITF Server.</td>
</tr>
<tr>
<td>Verify that you can log on to the ITF Server and Agilent AOI controller with <em>Administrator privileges</em>.</td>
</tr>
<tr>
<td>Check that the Date/Time and time zone settings on the ITF Server match the Date/Time and time zone settings on the Agilent AOI. All machines attached to the Intelligent Test Framework must have the same Date/Time and time zone settings.</td>
</tr>
</tbody>
</table>
Chapter 9: Installing and Configuring the Agilent AOI: Installing the ITF Tester Components on the Agilent AOI

Installing the ITF Tester Components on the Agilent AOI

In order for an ITF software application, such as the Agilent Repair Tool, to receive and display Agilent AOI inspection data, there are several Intelligent Test Framework tester components that must be added to the Agilent AOI controller.

NOTE

The following installation procedure must be completed for each Agilent AOI system you wish to connect to the Intelligent Test Framework.

If you have a Single-Tester ITF Server, only one test system can be connected to the Intelligent Test Framework.

To add the Intelligent Test Framework tester components:

1. Log on to the Agilent AOI controller with Administrator privileges.

2. Check that TCP/IP is installed on the Agilent AOI controller.

3. Open Windows® Explorer.

4. On the Tools menu, click Map Network Drive.

   The Map Network Drive dialog box appears.

5. Map to the ITF Server from the Agilent AOI controller.
   a. In the Folder text box, enter: `\\<Name of ITF Server>\install`
   b. Make sure that you clear the Reconnect at Logon check box.
   c. Click Finish.

   NOTE

   It may be necessary to provide Agilent ITF Administrator login name and password to complete the mapping to a network drive.

6. Locate and open the components directory on the newly-mapped drive.

7. Double-click the testers_components.exe file.
   This is a self-extracting file that automatically opens to the temp directory and begins the installation process on the Agilent AOI controller.

   The setup program starts extracting files.
Chapter 9: Installing and Configuring the Agilent AOI: Installing the ITF Tester Components on the Agilent AOI

Figure 9-1  Extracting files

After the files are extracted, the **Welcome** dialog box appears.

Figure 9-2  **Welcome** dialog box
Chapter 9: Installing and Configuring the Agilent AOI: Installing the ITF Tester Components on the Agilent AOI

8 Click Next.

The License Agreement dialog box appears.

Figure 9-3 License Agreement dialog box

9 Read the Agilent License Agreement, and then click Yes to accept it.

The Release Notes dialog box appears.

10 Read the Release Notes, and then click Next.

The Choose Destination Location dialog box for ITF Agent appears. The default directory is C:\Agilent\ITFSS3.1\Agent\.

Figure 9-4 Enter destination folder for ITF Agent

11 To accept the default directory, click Next.

Otherwise, enter the desired directory and click Next.

The Edit Data dialog box appears.
Chapter 9: Installing and Configuring the Agilent AOI: Installing the ITF Tester Components on the Agilent AOI

12 Enter the name and port number of the ITF Server, and then click **Next**.

The **Setup type** dialog box for selecting the tester type appears.

13 Click **AOI_SJ** or **AOI_SP** depending on the model of your tester.

14 Click **Next**.

You will receive the following warning message, if you attempt to install the components on a system other than an Agilent AOI controller.
Chapter 9: Installing and Configuring the Agilent AOI: Installing the ITF Tester Components on the Agilent AOI

The **Edit Data** dialog box appears for you to enter the local port number.

**Figure 9-8** Enter local port number

![Edit Data dialog box](image)

15 Enter the local port number and then click **Next**.

The **Start Copying Files** dialog box appears for you to review the installation settings.

**Figure 9-9** Review installation settings

![Start Copying Files dialog box](image)

16 Review the installation settings and then click **Next**.

The **Setup Status** dialog box appears, displaying the progress of the installation.
Figure 9-10  Setup Status dialog box

During the installation process, the ITF mods to config.txt dialog box appears. It lists the changes that you need to make to the config.txt file on the Agilent AOI.

Figure 9-11  ITF mods to config.txt

17 Review the changes and then click Next.

When the installation is completed, the Setup Complete dialog box appears.
Chapter 9: Installing and Configuring the Agilent AOI: Installing the ITF Tester Components on the Agilent AOI

Figure 9-12  Setup Complete

In order to maintain active network connections, the installation software will increase the network autodisconnect timer to two days (2880 minutes).

NOTE

18 Click Finish.

19 Remove the drive mapping to the ITF Server (from step 5). In Windows® Explorer, right-click the drive you just mapped and select Disconnect. Be sure not to display the contents of the mapped drive before disconnecting it.

20 Verify the contents of the image_save line in the C:\cpi\data\config.txt file.

For SJ software versions 4.08 or later, this line should read as follows:

```
Image_save 52 1000 1000000 -1 1
```

For SJ software versions prior to 4.08, this line should read as follows:

```
Image_save 20 1000 1000000 -1 1
```

For SP software versions, this line should read as follows:

```
Image_save 4 100 5000000 1 0
```

If the contents of the line need to be modified,

a Make a backup copy of the current config.txt file.

b Change the contents of the Image_save line according to the code above.

c Save the new config.txt file.

21 Verify that ITFAgent Service is started.

a Click Start > Control Panel.

b Double-click Administrative Tools followed by Services.

The Services console appears.

c Verify if the status of ITFAgent Service is indicated as Started. If it is not started, double-click it and click the Start button on the ITFAgent Service Properties dialog box.
d Verify if the Startup type is set to Automatic. If it is not, select and set it to Automatic.

e Press the F5 key to refresh the service console to ensure the service has been started.

The installation of Intelligent Test Framework tester components to the Agilent AOI is completed.

Please proceed to the next section, Configuring the Agilent AOI.
Configuring the Agilent AOI

The process of configuring the Agilent AOI involves:

- **Configuring the Agilent AOI to transfer Rep files** on page 9-12

**NOTE**

The following installation procedure must be completed for each Agilent AOI inspection system you wish to connect to the Intelligent Test Framework.

If you have a Single-Tester ITF Server, only one test system can be connected to the Intelligent Test Framework.

**Configuring the Agilent AOI to transfer Rep files**

1. At the Agilent AOI controller, open Windows® Explorer. Browse to the \C:\Agilent\ITF folder.
2. Double-click the SJBoardSend.exe file. You will see a dialog box similar to Figure 9-13.
3. Change the default storage location to point to \<Agent>\storage\Input where \<Agent> represents the install folder of the ITF Agent.
4. Accept the remaining default configuration settings:
   - **Transfer SSM images to ITF** — No

**NOTE**

Solid Shape Modeling (SSM) images are only available with SJ50 Series 2 inspection systems.

5. Click **OK** to save the settings and close the dialog box.
6 Repeat steps 1 through 5 for all Agilent AOI inspection systems you wish to connect to the Intelligent Test Framework.

**NOTE**

If you would like to use ART in-line with the Agilent AOI, please refer to the section, *Setting up ART for in-line use with the Agilent AOI* in Appendix B.

The configuration of the Agilent AOI inspection system is completed.

Repeat the setup and configuration procedures for all Agilent AOI inspection systems you wish to connect to the Intelligent Test Framework.

If you have a Single-Tester ITF Server, only one test system can be connected to the Intelligent Test Framework.

Proceed to Chapter 12, *Verifying Data Transmission* to verify data transmission to the ITF Server.
Installing and Configuring the Agilent ICT WN

- Overview, 10-2
- Pre-Installation Checklist, 10-3
- Installing the ITF Tester Components on the Agilent ICT WN, 10-4
- Configuring the Agilent ICT WN, 10-11

CAUTION

⚠️ It is essential that you follow the instructions exactly, in the order given. If you do not follow the Setup Guide exactly, the system will not function properly.
Overview

The following information provides guidance for the successful networking, installation, and configuration of the Intelligent Test Framework software on the Agilent ICT WN.

The process involves the following steps:

- Installing the Intelligent Test Framework software components on the Agilent ICT WN
- Configuring the Agilent ICT WN for Use with the Agilent Repair Tool (ART)
Before you install the ITF components on the Agilent ICT WN, please review the pre-installation checklist below.

### Table 10-1 Pre-Installation Checklist

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Complete all the networking steps listed in the Networking the ITF Server chapter of the documentation.</td>
<td></td>
</tr>
<tr>
<td>Check that your Agilent ICT WN meets the minimum system and software requirements for use with the Intelligent Test Framework. See System Requirements on page 1-5.</td>
<td></td>
</tr>
<tr>
<td>Note down the system name of your ITF Server.</td>
<td></td>
</tr>
<tr>
<td>Verify that you can log on to the ITF Server and Agilent ICT WN controller with Administrator privileges.</td>
<td></td>
</tr>
<tr>
<td>Check that the Date/Time and time zone settings on the ITF Server match the Date/Time and time zone settings on the Agilent ICT. All machines attached to the Intelligent Test Framework must have the same Date/Time and time zone settings.</td>
<td></td>
</tr>
</tbody>
</table>
Chapter 10: Installing and Configuring the Agilent ICT WN: Installing the ITF Tester Components on the Agilent ICT WN

Installing the ITF Tester Components on the Agilent ICT WN

In order for the Agilent Repair Tool to receive and display Agilent ICT WN test data, there are two new tester components from the Intelligent Test Framework that must be added to the Agilent ICT WN.

These are the three new components:

- **In the `C:\Agilent3070\bin` directory:**
  - aitfprp2art.ksh
  - aitfmodtld.pl
  - qtrans.ksh

Other related files:

- **In the `C:\Agilent3070\contrib\bin` directory:**
  - gc3070.exe

- **In the `C:\Agilent3070\standard` directory:**
  - abhtestmain
  - abhtestmain_panel
  - testmain
  - testmain_JOT
  - testmain_JOT_dual_well
  - testmain_JOT_panel
  - testmain_panel
  - testmain_QPT
  - testmain_QPT_dual_well
  - testmain_QPT_panel

**NOTE**

The following installation procedure must be completed for each Agilent ICT WN inspection system you wish to connect to the Intelligent Test Framework.

If you have a Single-Tester ITF Server, only one test system can be connected to the Intelligent Test Framework.

To add the Intelligent Test Framework tester components:

1. Log on to the Agilent ICT WN controller with **Administrator privileges**.
2. Open Windows® Explorer.
3. On the **Tools** menu, click **Map Network Drive**.
4. Map the ITF Server from the Agilent ICT WN controller.
   a. Select any available drive in the **Drive** text box.
   b. Enter the folder: `\<System Name of ITF Server>\install`
   c. Make sure you **clear** the **Reconnect at Logon** check box.
   d. Click **Finish**.
It may be necessary to provide the Agilent ITF Administrator login name and password to complete the mapping to a network drive.

5 Locate the components directory on the ITF Server.

6 Double-click the testers_components.exe file located in the components folder. This is a self-extracting file that automatically opens to the temp directory and begins the installation of the ICT components on the Agilent ICT WN controller.

The setup program starts extracting files.

After the files are extracted, the Welcome dialog box appears.

Figure 10-1 Extracting files

Figure 10-2 Welcome dialog box
Chapter 10: Installing and Configuring the Agilent ICT WN: Installing the ITF Tester Components on the Agilent ICT WN

7 Click **Next**.
   The **License Agreement** dialog box appears.
   
   **Figure 10-3** License Agreement dialog box

8 Read the Agilent License Agreement, and then click **Yes** to accept it.
   The **Release Notes** dialog box appears.

9 Read the Release Notes, and then click **Next**.
   The **Choose Destination Location** dialog box for ITF Agent appears. The default directory is C:\Agilent\ITFSS.1\Agent. 
   
   **Figure 10-4** Enter destination folder for ITF Agent

10 To accept the default directory, click **Next**.
   Otherwise, enter the desired directory and click **Next**.
   The **Edit Data** dialog box appears.
11 Enter the name and port number of the ITF Server, and then click Next.

The Setup Type dialog box for selecting the tester type appears.

12 Click ICT and then click Next.

You will receive the following warning message, if you attempt to install the components on a system other than an Agilent ICT WN controller.

The Edit Data dialog box appears for you to enter the local port number.
Chapter 10: Installing and Configuring the Agilent ICT WN: Installing the ITF Tester Components on the Agilent ICT WN

**Figure 10-8** Enter local port number

![Enter local port number](image)

Enter the local port number and then click **Next**.

The **Start Copying Files** dialog box appears for you to review the installation settings.

**Figure 10-9** Review installation settings

![Review installation settings](image)

Review the installation settings and then click **Next**.

The **Setup Status** dialog box appears, displaying the progress of the installation.
When the installation is completed, the **Setup Complete** dialog box appears.

15 Click **Finish**.

16 Verify that ITFAgent Service is started.
   a Click **Start > Control Panel**.
   b Double-click **Administrative Tools** followed by **Services**.
      The **Services** console appears.
   c Verify if the status of ITFAgent Service is indicated as **Started**. If it is not started, double-click it and click the **Start** button on the **ITFAgent Service Properties** dialog box.
   d Verify if the **Startup type** is set to **Automatic**. If it is not, select and set it to **Automatic**.
e Press the **F5** key to refresh the service console to ensure the service has been started.

The installation of Intelligent Test Framework tester components on the Agilent ICT WN is completed.
Configuring the Agilent ICT WN

The process for configuring the Agilent ICT WN involves:

- **Creating the GENCAMSTORE Environment Variable** on page 10-11
- **Modifying the Existing Directory Structure** on page 10-14
- **Running the Perl Script to Modify the tld.prplus File** on page 10-15
- **Running the aitfprp2art Script to Modify Testplans and Generate GenCAM Files** on page 10-15
- **Verifying the Names of the GenCAM Files** on page 10-17

**NOTE**

The following configuration procedures must be completed for each Agilent ICT WN inspection system you wish to connect to the Intelligent Test Framework.

If you have a Single-Tester ITF Server, only one test system can be connected to the Intelligent Test Framework.

Creating the GENCAMSTORE Environment Variable

In order to specify the location of the GenCAM files, you need to create the GENCAMSTORE environment variable.

To do so:

1. On the computer desktop, right-click the **My Computer** icon.
2. Click **Properties** on the menu that appears.
   
   The **System Properties** dialog box appears.
3. In the **System Properties** dialog box, click the **Advanced** tab followed by the **Environment Variables** button.
Figure 10-12  System Properties dialog box
Chapter 10: Installing and Configuring the Agilent ICT WN: Configuring the Agilent ICT WN

The **Environment Variables** dialog box appears.

![Environment Variables dialog box](image)

**Figure 10-13** Environment Variables dialog box

4. Under **System Variables**, click the **New** button.
5. Add a new GENCAMSTORE environment variable as shown in **Figure 10-14**.
   a. In the **Variable Name** text box, type: GENCAMSTORE
   b. In the **Variable Value** text box, type:
      ```
      \<Install folder of ITF Agent>\storage\Input
      ```
      The default location is
      ```
      C:\Agilent\ITFSS3.1\Agent\storage\Input
      ```
   c. Click **OK**.

![GENCAMSTORE System Variable](image)

**Figure 10-14** GENCAMSTORE System Variable

The **Environment Variables** dialog box (**Figure 10-13**) appears again.

6. Click **OK** until all dialog boxes are closed.

Repeat this setup procedure for each Agilent ICT WN system you wish to connect to the Intelligent Test Framework.

**NOTE**

If you have a Single-Tester ITF Server, only one test system can be connected to the Intelligent Test Framework.
Modifying the Existing Directory Structure

In order for the ITF Server to send and receive tester data to the Repair Client PCs, it must share results folders with the Agilent ICT WN.

To modify the existing directory structure on the Agilent ICT WN controller:

1. Log on to the Agilent ICT WN controller with Administrator privileges.
2. Use Windows® Explorer to expand the directory structure C:\Agilent3070\qm.

   NOTE
   The drive letter may be different.

3. Verify whether there is a logdata folder inside the qm folder. There should also be a subq folder under the logdata folder, and a customq folder under the subq folder. Figure 10-15 shows the folders you need.

4. If you need to create these folders,
   a. In the left hand pane of Windows® Explorer, highlight the qm folder (C:\Agilent3070\qm), and then click File > New > Folder on the main menu. Name the new folder, logdata.
   b. In the left hand pane of Windows® Explorer, highlight the new logdata folder, and then click File > New > Folder on the main menu. Name the new folder, subq.
   c. In the left hand pane of Windows® Explorer, highlight the new subq folder, and then click File > New > Folder on the main menu to create another folder under it. Name this new folder, customq.
Chapter 10: Installing and Configuring the Agilent ICT WN: Configuring the Agilent ICT WN

Running the Perl Script to Modify the tld.prplus File

As part of the Agilent ITF software installation process, a Perl script file called `aitfmodtld.pl` was added to your Agilent ICT WN controller. You must run this file in order to modify your system’s `tld.prplus` file for use with the Intelligent Test Framework.

To run the Perl script:

1. Log on to the Agilent ICT WN controller with Administrator privileges.
2. Open a Korn shell dialog box. To open a Korn shell dialog box, click **Start > Programs > Agilent3070 > Korn Shell**.
3. At the command prompt, type:
   
   ```bash
   perl $AGILENT3070_ROOT/bin/aitfmodtld.pl
   ```
   then press ENTER.

   **NOTE**
   
   If you have modified the `tld.prplus` file (i.e., for a custom log-data consumer), the Perl script may not work correctly. You may need to re-design your custom log-data consumer in order to use it simultaneously with Agilent Repair Tool.

4. Restart the Agilent ICT WN controller.

Running the aitfprp2art Script to Modify Testplans and Generate GenCAM Files

One of the last steps in configuring the Agilent ICT WN for use with the Agilent Repair Tool is to run the `aitfprp2art` script. This script automatically modifies your testplans and generates GenCAM files for use with the Intelligent Test Framework.

In particular, the `aitfprp2art` script does the following:

- Modifies each board testplan.
- Generates GenCAM files and places them in the GenCAMData folder on the ITF Server.

If you have a large number of board directories that you would like to modify for use with the Intelligent Test Framework and Agilent Repair Tool, you may wish to use this script.

**NOTE**

Instructions are also given for making these changes manually. For more information see, [Manually Modifying Testplans for Agilent ICT](#) on page A-2 and [Manually Generating Agilent ICT GenCAM Files for Each Board Type](#) on page A-4.
CAUTION

If CAD data is not available for a board type and a GenCAM file cannot be successfully created using the gc3070 tool, you must first create an empty text file on the Agilent ICT WN controller (touch <board-type>.gcm) in a Korn shell dialog box.

Before you manually move GenCAM files from the Agilent ICT WN to the ITF Server, be sure to run the following command to make the files readable and writable:

```
chmod 666 <board-type>.gcm
```

Now move the empty GenCAM file to the C:\Agilent\ITFSS3.1\Agent\storage\Input folder.

To run the aitfprp2art script:

1. Log on to the Agilent ICT WN controller with User privileges.
2. Open a Korn shell dialog box on the Agilent ICT WN. To open a Korn shell dialog box, click Start > Programs > Agilent3070 > Korn Shell.
3. Change to the parent directory of your boards.
4. At the command prompt, type: aitfprp2art then press ENTER.

The script moves from the parent directory down through your file system looking for all board directories. Board directories are identified by the presence of a file called “testplan.”

The aitfprp2art script does the following:

- Makes a backup copy of the original testplan and names it testplan.prp
- Changes all occurrences of the words Using_PRPlus to Using_ART in the testplan file
- Sets Using_ART = True
- Changes the log level in the testplan from failures without nhls, pins to indictments without nhls
- Executes the gc3070 utility in the board directory. This produces GenCAM files and sends then to the ITF Server.
- Saves the modified testplan and names it testplan.
Verifying the Names of the GenCAM Files

The Intelligent Test Framework software requires the name of your GenCAM file to match the board type in the log file which was generated by a standard testmain. If the names are different, CAD data for the given board type is not displayed in the Agilent Repair Tool.

There are two ways to verify the name of your GenCAM file. You can cross-check the GenCAM file name listed in the GenCAMData folder on the ITF Server with either the:

- Board$ variable in the Agilent ICT WN testplan, or
- @BATCH log record in the Agilent ICT WN log file.

To locate the Board$ variable in a standard ICT testplan:

1. Open the testplan in a BT-Basic window.
2. Locate the sub Initialize.Board CONSTANTS section of the testplan.
3. The first variable listed under the section should be Board$ = "<board type>". For example, in Figure 10-16, the board type is “gecko.” You would want to make sure your GenCAM file is also named “gecko” (i.e., gecko.gcm).

**NOTE**

If you are not using the standard Agilent ICT testplan format, you may have to check to see if the log board variable designator is something other than “Board$.”

To locate the @BATCH log record in the Agilent ICT WN log file:

1. Open a copy of the log file in a BT-BASIC window.
2. The @BATCH log record should be the first line in the log file.
3. The board type will be the first parameter listed in the @BATCH log record.
The configuration of the Agilent ICT WN is completed.
Repeat the setup and configuration procedures for all Agilent ICT WN inspection systems you wish to connect to the Intelligent Test Framework.
If you have a Single-Tester ITF Server, only one test system can be connected to the Intelligent Test Framework.
Proceed to Chapter 12, **Verifying Data Transmission** to verify data transmission to the ITF Server.
Installing and Configuring the Agilent ICT UNIX

In this chapter...

■ Overview, 11-2
■ Installing the Tester Components on the ITF Server, 11-3
■ Networking the Agilent ICT UNIX, 11-9
■ Pre-Installation Checklist for ITF UNIX Components, 11-28
■ Installing the ITF Components on the Agilent ICT UNIX, 11-29
■ Configuring the Agilent ICT UNIX, 11-32

CAUTION

⚠️ It is essential that you follow the instructions exactly, in the order given. If you do not follow the Setup Guide exactly, the system will not function properly.
Chapter 11: Installing and Configuring the Agilent ICT UNIX: Overview

Overview

The following information provides guidance for the successful networking, installation, and configuration of the Intelligent Test Framework software on the Agilent ICT UNIX.

The process involves the following steps:

- **Installing the Tester Components on the ITF Server** on page 11-3
- **Networking the Agilent ICT UNIX** on page 11-9
- **Installing the ITF Components on the Agilent ICT UNIX** on page 11-29
- **Configuring the Agilent ICT UNIX** on page 11-32
Before you network the Agilent ICT UNIX, you need to install the tester components for Agilent ICT UNIX on the ITF Server.

To do so:

1. Log on to the ITF Server with Administrator privileges.
2. Open Windows® Explorer.
3. Browse to the folder:
   
   `<Installed folder of ITF Server>\install\components`

   The default location is
   
   `C:\Agilent\ITFSS3.1\ITF\install\components`

   **NOTE**

   It may be necessary to provide the Agilent ITF Administrator login name and password to complete the mapping to a network drive.

4. Double-click the `testers_components.exe` file located in the `components` folder. This is a self-extracting file that automatically opens to the `temp` directory and begins the installation of the tester components on the ITF Server.

   The setup program starts extracting files.
Chapter 11: Installing and Configuring the Agilent ICT UNIX: Installing the Tester Components on the ITF Server

After the files are extracted, the **Welcome** dialog box appears.

**Figure 11-2 Welcome** dialog box

5 Click **Next**.

The **License Agreement** dialog box appears.

**Figure 11-3 License Agreement** dialog box
6. Read the Agilent License Agreement, and then click **Yes** to accept it.

   The **Release Notes** dialog box appears.

7. Read the Release Notes, and then click **Next**.

   The **Choose Destination Location** dialog box for ITF Agent appears. The default directory is `C:\Agilent\ITFSS3.1\Agent\`.

**Figure 11-4**  Enter destination folder for ITF Agent

8. To accept the default directory, click **Next**. Otherwise, enter the desired directory and click **Next**.

   The **Edit Data** dialog box appears.

**Figure 11-5**  Enter name and port number of ITF Server

   ![Edit Data Dialog Box](image-url)
Chapter 11: Installing and Configuring the Agilent ICT UNIX: Installing the Tester Components on the ITF Server

9  Enter the name and port number of the ITF Server, and then click Next.

   The **Setup type** dialog box for selecting the tester type appears.

**Figure 11-6**  Select tester type

10 Click ICT (UNIX) and then click **Next**.

   The **Start Copying Files** dialog box appears for you to review the installation settings.

**Figure 11-7**  Review installation settings

11 Review the installation settings and then click **Next**.

   The **Setup Status** dialog box appears, displaying the progress of the installation.
When the installation is completed, the **Setup Complete** dialog box appears.

12 Click **Finish**.

13 Verify that ITFAgent Service is started.
   a Click **Start > Control Panel**.
   b Double-click **Administrative Tools** followed by **Services**.
      The **Services** console appears.
   c Verify if the status of ITFAgent Service is indicated as **Started**. If it is not started, double-click it and click the **Start** button on the **ITFAgent Service Properties** dialog box.
   d Verify if the **Startup type** is set to **Automatic**. If it is not, select and set it to **Automatic**.
Press the F5 key to refresh the service console to ensure the service has been started.

The installation of Intelligent Test Framework tester components on the ITF Server is completed.

Proceed to the next section to network the Agilent ICT UNIX.
Networking the Agilent ICT UNIX

The Agilent Repair Tool can receive and display information from the Agilent ICT UNIX test system. In order for this to occur, the Agilent ICT UNIX test system must be networked to the ITF Server.

The Agilent ICT UNIX must have software version 04.00p or higher.

Pre-Conditions for Networking the Agilent ICT UNIX

Before you begin networking the Agilent ICT UNIX, be sure that you have met all of the assumptions under System Requirements.

In addition, if Microsoft® Windows® Services for UNIX (SFU) 3.5 is not installed on the ITF Server, you need to install it in order to enable NFS sharing of the install and storage folders.

For instructions on how to enable NFS sharing, see Sharing the ITF Server with Agilent ICT UNIX in Chapter 13, Troubleshooting.

About Microsoft Windows SFU 3.5

Microsoft Windows SFU 3.5 contains Network File-Server (NFS) utilities that allow the sharing of network resources between systems running under Windows® NT, Windows® 2000, Windows® XP, and UNIX operating systems. This allows the Agilent ICT UNIX test system to transfer data to the ITF Server.

The networking process is:

- Mapping the Agilent ICT UNIX to the ITF Server on page 11-10
- Determining whether Automounter is in use on page 11-12
- Mounting the Remote File Systems Using SAM (if using Automounter) on page 11-13
  OR
- Mounting the Remote File Systems Manually (if not using Automounter) on page 11-16

NOTE

The following steps must be repeated for each Agilent ICT UNIX inspection system you wish to connect to the Intelligent Test Framework.

If you have a Single-Tester ITF Server, only one test system can be connected to the Intelligent Test Framework.
Chapter 11: Installing and Configuring the Agilent ICT UNIX: Networking the Agilent ICT UNIX

Mapping the Agilent ICT UNIX to the ITF Server

1  At the command prompt
   a  Type: `sam`
   b  Press ENTER.
       This runs the System Administrator Manager.

2  In the SAM Areas dialog box, double-click the Networking and Communications icon.

Figure 11-10  Internet Addresses icon

3  Verify that the IP address and hostname of the ITF Server is registered with the Agilent ICT UNIX system. To do this, double-click the Internet Addresses icon in the SAM Areas:Networking and Communications dialog box.

If the IP address and hostname appear in the list, close the Internet Addresses dialog box.

If the IP address and hostname do not appear, on the Actions menu, click Add.

The Add Internet Address dialog box appears as in Figure 11-11.
Figure 11-11  Add Internet Address dialog box

NOTE
If the Confirmation dialog box appears before the Add Internet Address dialog box, click Yes to continue.

4 In the Add Internet Address dialog box, enter the IP address of the ITF Server in the Internet Address text box. In addition, enter the System Name (hostname) of the ITF Server in the Remote System Name text box. Click OK when finished.

5 In the Internet Addresses dialog box, click Exit on the File menu to return to the SAM Areas: Networking and Communications dialog box.

6 Proceed to the following section.
Determining whether Automounter is in use

To determine whether Automounter is in use,

1. Open a shell dialog box.
2. At the command prompt, type:
   
   ```
   ps -ef | grep automount
   ```
3. Press ENTER.

   Automounter is running if you see a line similar to the following text:
   
   ```
   root xxx x x hh:mm:ss ? 0:00 /usr/sbin/automountd
   ```

   You may close the shell dialog box and proceed to step 1 on page 11-13 to mount the remote file systems using SAM.

4. If Automounter is not running, you may choose to start Automounter using SAM. Proceed to the section, Mounting the Remote File Systems Using SAM (if using Automounter) on page 11-13 for instructions.

   Otherwise, proceed to Mounting the Remote File Systems Manually (if not using Automounter) on page 11-16.
Mounting the Remote File Systems Using SAM (if using Automounter)

1. In the **SAM Areas: Networking and Communications** dialog box, double-click the **Networked File Systems** icon, and then double-click the **Mounted Remote File Systems** icon in **Figure 11-12**.

![Figure 11-12 Mounted Remote File Systems icon](image)

2. On the **Mounted Remote File Systems** menu in **Figure 11-13**, click **Actions** > **Add Remote File System** > **Using NFS**.

![Figure 11-13 Mounted Remote File System: Using NFS](image)
3. In the **Add Remote File System** dialog box in **Figure 11-14**,

   a. Enter the following in the appropriate text boxes:
      - **Local Directory Name:** 
        `/var/hp3070/qm/transGenCAM`
      - **Remote Server Name:** 
        `<System Name of the ITF Server>`
      - **Remote Directory Name:** `/storage/Input`

   b. Change **Allow SetUID** to **No**.
      Do not change the remaining default settings.

   c. Click **Advanced Options**.

---

**NOTE**

Whenever you see commands surrounded by `<>`, please replace these symbols and the text with the stated information.

If you see an error message, “A SAM internal error has occurred” after performing this step, ignore the message and click **OK**.
In the Advanced Options dialog box,

a. Select **Mount Type: soft** from the drop-down menu. Do not change any of the other options.

b. Click **OK**.

c. Click **OK** again.

**Figure 11-15** Advanced Options dialog box
Chapter 11: Installing and Configuring the Agilent ICT UNIX: Networking the Agilent ICT UNIX

NOTE
If you are not able to use Automounter, please skip to Mounting the Remote File Systems Manually (if not using Automounter) in the next section. Otherwise, please continue with the following steps.

5 On the File menu, click Exit to return to SAM.

6 On the File menu of the SAM window, click Exit SAM to close SAM.

Networking for the Agilent ICT UNIX controller is complete. Please continue with the Pre-Installation Checklist for ITF UNIX Components on page 11-28.

Mounting the Remote File Systems Manually (if not using Automounter)

NOTE
You must be logged in as Super User to mount remote file systems manually.

1 Open a UNIX shell dialog box. At the command prompt, type the following lines. Press ENTER after each line.

   umount -a
   cd /net
   mkdir <System Name of ITF Server>
   chmod 777 <System Name of ITF Server>
   cd /net/<System Name of ITF Server>/mkdir storage
   chmod 777 storage
   mkdir install
   chmod 777 install

2 If you have had problems using SAM or prefer to change the /etc/fstab file manually, follow the steps below. Otherwise, skip to step 5 to use SAM.
   a At the prompt, type: vi /etc/fstab
   b Add the lines in Figure 11-16 at the end of fstab.

3 Save the fstab file.
4 At the command prompt, type the following:

```
mount -a
cd /net/<System Name of ITF Server>/storage
ll
```

You should see the following directories:

- Input
- NoGenCAMFiles
- Broken

Skip to step 16.

**Figure 11-16 Lines to Add to the /etc/fstab File**

```
<System Name of ITF Server>:/storage/Input /var/hp3070/qm/transGenCAM nfs rw,soft 0 0
<System Name of ITF Server>:/storage /net/<System Name of ITF Server>/storage nfs rw,soft 0 0
<System Name of ITF Server>:/install /net/<System Name of ITF Server>/install nfs rw,soft 0 0
```

5 Open the System Administrator Manager (SAM). At the command prompt,

- Type: `sam`
- Press ENTER.

This runs the System Administrator Manager.

6 In the **SAM Areas:Networking and Communications** dialog box, double-click the **Networked File Systems** icon, and then double-click the **Mounted Remote File Systems** icon in **Figure 11-17**.

**Figure 11-17 Mounted Remote File Systems icon**

7 From the **Mounted Remote File Systems** menu in **Figure 11-18**, select **Actions > Add Remote File System > Using NFS**.
8 In the Add Remote File System dialog box in Figure 11-19,

a Enter the following in the appropriate text boxes:

**Local Directory Name:**
/var/hp3070/qm/transGenCAM

**Remote Server Name:** `<System Name of the ITF Server>`

**Remote Directory Name:** `/storage/Input`

b Change **Allow SetUID** to **No**.

Do not change the remaining default settings.

c Click **Advanced Options**.

---

**NOTE**

Whenever you see commands surrounded by `<`, please replace these symbols and the text with the stated information.
Chapter 11: Installing and Configuring the Agilent ICT UNIX: Networking the Agilent ICT UNIX

Figure 11-19  Add Remote File System dialog box
9 In the **Advanced Options** dialog box,

a Select **Mount Type: soft** from the drop-down menu.

Do not change any of the other options.

**Figure 11-20** Advanced Options dialog box
10 From the Mounted Remote File Systems menu, select **Actions > Add Remote File System > Using NFS.**

**Figure 11-21 Add Remote File System: Using NFS**

![Add Remote File System: Using NFS](image)

11 In the **Add Remote File System** dialog box in **Figure 11-22**.

- **a** Enter the following in the appropriate text boxes:
  
  **Local Directory Name:** `/net/<System Name of the ITF Server>/storage`  
  **Remote Server Name:** `<System Name of the ITF Server>`  
  **Remote Directory Name:** `/storage`

- **b** Change **Allow SetUID** to **No.**  
  Do not change the remaining default settings.

- **c** Click **Advanced Options**.

**NOTE**

Whenever you see commands surrounded by `<>`, please replace these symbols and the text with the stated information.
Figure 11-22  Add Remote File System dialog box
12 Select **Mount Type: soft** from the drop-down menu. Do not change any of the other options.

- Click **OK**.
- Click **OK** again.

**Figure 11-23** Advanced Options dialog box

Figure 11-24  Add Remote File System: Using NFS

14 In the Add Remote File System dialog box in Figure 11-25,

a Enter the following in the appropriate text boxes:

Local Directory Name: /net/<System Name of the ITF Server>/install

Remote Server Name: <System Name of the ITF Server>

Remote Directory Name: /install

b Change Allow SetUID to No.

Do not change the remaining default settings.

c Click Advanced Options.

NOTE

Whenever you see commands surrounded by <>, please replace these symbols and the text with the stated information.
Figure 11-25  Add Remote File System dialog box
15 Select **Mount Type: soft** from the drop-down menu. Do not change any of the other options.

a) Click **OK**.

b) Click **OK** again.

**Figure 11-26** Advanced Options dialog box

16 On the **File** menu, click **Exit** to return to SAM.
17 On the **File** menu of the SAM window, click **Exit SAM** to close SAM.

Networking for the Agilent ICT UNIX controller is complete. Please continue with the next section, **Pre-Installation Checklist for ITF UNIX Components.**
Before you install the ITF UNIX components on the Agilent ICT UNIX, please review the pre-installation checklist below.

### Table 11-1 Pre-Installation Checklist

<table>
<thead>
<tr>
<th>PRE-INSTALLATION CHECKLIST</th>
</tr>
</thead>
<tbody>
<tr>
<td>Verify that Microsoft Services for UNIX 3.5 is installed on the ITF Server.</td>
</tr>
<tr>
<td>Complete all the networking steps listed in the Networking the Agilent ICT UNIX chapter of the documentation.</td>
</tr>
<tr>
<td>Check that your Agilent ICT UNIX meets the minimum system and software requirements for use with the Intelligent Test Framework. See System Requirements on page 1-5.</td>
</tr>
<tr>
<td>Note down the system name of your ITF Server.</td>
</tr>
<tr>
<td>Verify that you can log on to the ITF Server and Agilent ICT UNIX controller with Administrator privileges.</td>
</tr>
<tr>
<td>Check that the Date/Time and time zone settings on the ITF Server match the Date/Time and time zone settings on the Agilent ICT. All machines attached to the Intelligent Test Framework must have the same Date/Time and time zone settings.</td>
</tr>
</tbody>
</table>
Chapter 11: Installing and Configuring the Agilent ICT UNIX: Installing the ITF Components on the Agilent ICT UNIX

Installing the ITF Components on the Agilent ICT UNIX

In order for the Agilent Repair Tool to receive and display Agilent ICT UNIX test data, there are several Intelligent Test Framework software components that must be added to the Agilent ICT UNIX, and other files that must be modified.

The affected components include the following files:

- In the /opt/hp3070/bin directory:
  - qtrans
  - aitfprp2art
  - aitmodtld.pl
  - aitftldmodwrite

- In the /hp3070/standard directory:
  - abhtestmain
  - abhtestmain_panel
  - testmain
  - testmain_JOT
  - testmain_JOT_dual_well
  - testmain_JOT_panel
  - testmain_panel
  - testmain_QPT
  - testmain_QPT_dual_well
  - testmain_QPT_panel

**NOTE**

Prior to installing the Intelligent Test Framework software components on the Agilent ICT UNIX, check that the Date/Time and time zone settings on the Agilent ICT match those on the ITF Server. Data/Time settings can be changed using SAM. The time zone setting can be changed using the calendar icon.

To add the Intelligent Test Framework software components:

1. Log on to the Agilent ICT UNIX controller as Root or Super User.
2. Open a shell dialog box.
3. At the command prompt, map to the ITF Server by typing:
   ```bash
   cd /net/<System name of ITF Server>/install/components/ICT_UX
   ```
   and then press **ENTER**.

   **NOTE**
   Whenever you see commands surrounded by `<`, please replace these symbols and the text with the stated information.

4. At the command prompt, type the command line which corresponds to your version of Agilent ICT UNIX software.

   - For software version **04.00pa**, type:
     ```bash
     tar -xvf ITF3070_400.tar
     ```

If you have a Single-Tester ITF Server, only one test system can be connected to the Intelligent Test Framework.

The following installation procedure must be completed for each Agilent ICT UNIX you wish to connect to the Intelligent Test Framework.
Chapter 11: Installing and Configuring the Agilent ICT UNIX: Installing the ITF Components on the Agilent ICT UNIX

For software version **05.00pa or higher**, type:

```
tar -xvf ITF3070_500.tar
```

After you type the command, press **ENTER.**

5 At the command prompt, type:

```
cd /opt/hp3070/contrib/bin and then press ENTER.
```

6 At the command prompt, type the following to see a listing of the files in the directory.

```
ll gc3070*
```

7 Verify whether the directory includes the `gc3070` file. If the directory includes the gc3070 file, the installation process is complete. Skip to **step 8 on page 11-30**.

   If the directory does not include the `gc3070` file, look to see if it includes the `gc3070.Z` file; `gc3070.Z` is a compressed version of the `gc3070` file. To uncompress the `gc3070.Z` file, you can run the Convert utility on that directory or uncompress it manually. The Convert utility will unpack all *.Z files and make them runnable. If you prefer to uncompress the `gc3070.Z` file manually, see the instructions at the end of this step.

   To uncompress the file using the Convert utility,

   a Make sure you are logged in as Super User.
   b At the command prompt, type:

   ```
   cd /opt/hp3070/contrib/bin and then press ENTER.
   ```

   c At the command prompt, type: `./Convert` and then press **ENTER.**

   The Convert utility will unpack all of the files located under the `/contrib/bin` directory.

   d Type **Yes** when asked if you want to continue.

   e When Convert is finished, check to make sure the `gc3070` file is listed in the `/contrib/bin` directory.

   **NOTE**

   To uncompress the files manually, type:

   ```
   uncompress gc3070.Z
   chmod 555 gc3070
   chown hp3070:hp3070 gc3070
   ```

   The installation of Intelligent Test Framework components is completed.

8 Verify that ITFAgent Service is started.

   a Click **Start > Control Panel.**
   b Double-click **Administrative Tools** followed by **Services.**

   The **Services** console appears.

   c Verify if the status of ITFAgent Service is indicated as **Started.** If it is not started, double-click it and click the **Start** button on the **ITFAgent Service Properties** dialog box.
d Verify if the **Startup type** is set to **Automatic**. If it is not, select and set it to **Automatic**.

e Press the **F5** key to refresh the service console to ensure the service has been started.

Proceed to the next section, *Configuring the Agilent ICT UNIX.*
Configuring the Agilent ICT UNIX

The process of configuring the Agilent ICT UNIX involves:

- **Setting the ITF Server Path in the hp3070 and profile Files** on page 11-32
- **Running the Perl Script to Modify the tld.prplus File** on page 11-37
- **Running the aitfprp2art Script to Modify Testplans and Generate GenCAM Files** on page 11-38
- **Verifying the Names of the GenCAM Files** on page 11-40

**NOTE**

The following configuration procedures must be completed for each Agilent ICT UNIX inspection system you wish to connect to the Intelligent Test Framework.

If you have a Single-Tester ITF Server, only one test system can be connected to the Intelligent Test Framework.

**Setting the ITF Server Path in the hp3070 and profile Files**

**NOTE**

The following steps apply only to Agilent ICT UNIX.

1. Log on to the Agilent ICT UNIX controller as Root or Super User.
2. Open a shell dialog box.
3. At the command prompt, type: `cd /sbin/init.d` and then press **ENTER**.
4. Make a backup copy of the `hp3070` file. For example, typing `cp -p hp3070 hp3070_old` at the command prompt will create a backup copy named `hp3070_old` of the `hp3070` file.
5. Type: `vi hp3070` and then press **ENTER**.

This opens the `hp3070` file and allows you to edit its contents.

6. Locate the environment variable `declaration/export` section of the file and uncomment the following lines of code.
CAUTION

Double-check to make sure the correct directory path is listed for GENCAMSTORE in your hp3070 file. If it is not, replace the directory path with the path indicated in the following figure.

Figure 11-27  Environment Variable Code

```
export FRAMEWORKHOST=<System Name of ITF Server>
export GENCAMSTORE=/net/$FRAMEWORKHOST/storage/Input
```

7 Replace `<System Name of ITF Server>` with the system name (hostname) of your ITF Server.

NOTE

Whenever you see commands surrounded by `<`, please replace these symbols and the text with the stated information.

NOTE

If the code is not currently listed in the file, manually enter it. The code should be placed immediately after the `LIB=/opt/hp3070/lib` command. Be sure to replace the text and brackets in the first line of code with the actual system name of your ITF Server.
To save your changes, press the **ESC** key. Type: `:wq!` and then press **ENTER**.

At the command prompt, type:

```
cd /opt/hp3070/lib and then press **ENTER**.
```

Make a backup copy of the `profile` file. For example, typing `cp -p profile profile_old` at the command prompt will make a backup copy named `profile_old` of the `profile` file.

At the command prompt, type: `vi profile` then press **ENTER**. This opens the `profile` file and allows you to edit its contents.

Locate the `Set variables` section of the file and uncomment the following lines of code:
CAUTION

Double-check to make sure the correct directory path is listed for GENCAMSTORE in your profile file. If it is not, replace it with the one listed below.

Figure 11-29  Set Variable Code

```
export FRAMEWORKHOST=<System Name of ITF Server>
export GENCAMSTORE=/net/$FRAMEWORKHOST/storage/Input
```

13 Replace `<System Name of ITF Server>` with the actual system name (hostname) of your ITF Server.

NOTE

Whenever you see commands surrounded by `<`, please replace these symbols and the text with the stated information.

NOTE

If the code is not currently listed in the file, manually enter it. The code should be placed immediately after the `export HP3070_HELP_DIR` command. Be sure to replace the text and brackets in the first line of code with the actual system name of your ITF Server.
### Figure 11-30  Modified profile file

```bash
addtopath CLASSPATH ${AGILENT3070_MAIN}/lib/FrameChainview.jar
addtopath CLASSPATH ${AGILENT3070_MAIN}/lib/magicgui.jar
addtopath CLASSPATH ${AGILENT3070_MAIN}/lib/java
# addtopath CLASSPATH ${AGILENT3070_MAIN}/lib/jcbwt350.jar
addtopath CLASSPATH ${AGILENT3070_MAIN}/lib/swing.jar
export CLASSPATH

addtopath HP3070_HELP_DIR ${AGILENT3070_MAIN}/help
export HP3070_HELP_DIR

# The following variables are set for the Agilent Intelligent Test Framework.
# The first defines the hostname of the ITF Server.
# The second points to the directory where the GenCAM CAD data is to be sent.

export FRAMEWORKHOST=<System name of ITF Server>
export GENCAMSTORE=/net/$FRAMEWORKHOST/storage/Input

# Set this environment variable for GUI programs that still use built in
# Motif help widgets and old VUE help files. And set it here for remote
# login case, since this script will get called in $HOME/.profile
addtopath XVHHELPSYSTEMSEARCHPATH ${AGILENT3070_MAIN}/help/C/PBQ/PBQ hv
export XVHHELPSYSTEMSEARCHPATH

# The following looks for login from a separate system being used as an
# X-Terminal, and provides a symbolic link to the home directory there.
# if possible. This code will also execute when logging in from a true
# X-Terminal, in which case nothing useful can be done, but we try anyway.
if [ "$LOCAL_XSERVER" = false ] &&
  [ "$XKBDSERVER" = "itf_hp" ]
  # we only do this for non-PC keyboards
  # as a simple way to estimate which
```

**14** To save your changes,

a. Press the **ESC** key.

b. Type: `:wq!` and press **ENTER**.
Running the Perl Script to Modify the tld.prplus File

As part of the Agilent ITF software installation process, a Perl script file called aitfmodtld.pl was added to your Agilent ICT UNIX controller. You must run this file in order to modify your system's tld.prplus file for use with the Intelligent Test Framework.

To run the Perl script:

1. Log out of the Agilent ICT UNIX controller, if you are currently logged in as Super User.
2. Log on to the Agilent ICT UNIX controller as an ICT user.
3. Open a shell dialog box.
4. At the command prompt, type:
   perl /opt/hp3070/bin/aitfmodtld.pl
   and then press ENTER.
5. Log out of the system. At the Welcome login dialog box, select Options > Command Line Login, and then press ENTER.
6. Login as Super User, and then restart the Agilent ICT UNIX controller. (Type: /etc/shutdown -r)

**NOTE**

Whenever you run the PR+ administrative program (prsetup), you must re-run the above Perl script. Prsetup overwrites the /var/hp3070/qm/logdata/tld.prplus file, thus removing the modifications performed by this perl script. Prsetup is typically run whenever you add a new board type to your Agilent 3070 UNIX test system for PR+.

Running prsetup on one tester has the ability to overwrite the tld.prplus file on all testers that are known to prsetup. Therefore, if you run prsetup, you must re-run the Perl script for every tester in the prsetup list.

If you have modified the tld.prplus file (i.e., for a custom log-data consumer), the Perl script may not work correctly. You may need to re-design your custom log-data consumer in order to use it simultaneously with Agilent Repair Tool.

Running the aitfprp2art Script to Modify Testplans and Generate GenCAM Files

One of the last steps in configuring the Agilent ICT UNIX for use with the Agilent Repair Tool is to run the aitfprp2art script. This script automatically modifies your testplans and generates GenCAM files for use with the Intelligent Test Framework.

In particular, the aitfprp2art script does the following:

- Modifies each board testplan
- Generates GenCAM files and places them in the GenCAMData folder on the ITF Server

If you have a large number of board directories that you would like to modify for use with the Intelligent Test Framework and Agilent Repair Tool, you may wish to use this script.

NOTE

Instructions are also given for making these changes manually. For more information see, Manually Modifying Testplans for Agilent ICT on page A-2 and Manually Generating Agilent ICT GenCAM Files for Each Board Type on page A-4.

CAUTION

If CAD data is not available for a board type and a GenCAM file cannot be successfully created using the gc3070 tool, you must first create an empty text file on the Agilent ICT UNIX controller (touch <board-type>.gcm).

Before you manually move GenCAM files from the Agilent ICT UNIX to the ITF Server, be sure to run the following command to make the files readable and writable:

```bash
chmod 666 <board-type>.gcm
```

Now copy (using cp -p) the empty GenCAM file from the Agilent ICT UNIX controller to the ITF Server in the following directory:

```bash
<Install folder of ITF Agent>\storage\Input
```

The default location is

```bash
C:\Agilent\ITFSS3.1\Agent\storage\Input.
```

To run the aitfprp2art script:

1. Log on to the Agilent ICT UNIX controller as Super User.
2. Open a shell dialog box.
3. Change to the parent directory of your boards.
4 At the command prompt, type:

```
/opt/hp3070/bin/aitfprp2art
```

and then press ENTER.

The script moves from the parent directory down through your file system looking for all board directories. Board directories are identified by the presence of a file called “testplan.”

The aitfprp2art script does the following:

- Makes a backup copy of the original testplan and names it `testplan.prp`.
- Changes all occurrences of the words `Using_PRPlus` to `Using_ART` in the testplan file.
- Sets `Using_ART = True`.
- Changes the log level in the testplan from `failures without nhls, pins` to `indictments without nhls`.
- Executes the gc3070 utility in the board directory. This produces GenCAM files and sends them to the ITF Server.
- Saves the modified testplan and names it `testplan`.

**NOTE**

Make sure the GenCAM files have the correct permissions. If not, at the prompt type:

```
# chmod 666 /net/\<System Name of ITF Server>/3070/GenCAMData/\<board-type>.gcm
```
Verifying the Names of the GenCAM Files

The Intelligent Test Framework software requires the name of your GenCAM file to match the board type in the log file which was generated by a standard testmain. If the names are different, CAD data for the given board type is not displayed in the Agilent Repair Tool.

There are two ways to verify the name of your GenCAM file. You can cross-check the GenCAM file name listed in the GenCAMData folder on the ITF Server with either the:

- Board$ variable in the Agilent ICT UNIX testplan, or
- @BATCH log record in the Agilent ICT UNIX log file.

To locate the Board$ variable in a standard Agilent ICT UNIX testplan:

1. Open the testplan in a BT-Basic window.
2. Locate the sub Initialize.Board CONSTANTS section of the testplan.
3. The first variable listed under the section should be Board$ = "<board type>". For example, in Figure 11-31, the board type is “gecko.” You would want to make sure your GenCAM file is also named “gecko” (i.e., gecko.gcm).

Figure 11-31 Example of Board$ Variable in Testplan

NOTE

If you are not using the standard Agilent ICT testplan format, you may have to check to see if the log board variable designator is something other than “Board$.”
To locate the `@BATCH` log record in the ICT log file:

1. Open a copy of a log file in a BT-BASIC window.

2. The `@BATCH` log record should be the first line in the log file.

3. The board type will be the first parameter listed in the `@BATCH` log record.

Figure 11-32  Example `@BATCH` Log Record in a ICT Log File

```
(@BATCH|gecko|311||btest|010402152402||rpmtabug|gecko|RevA||

Board Type
```

The setup of the Agilent ICT UNIX is completed.

Repeat the setup and configuration procedures for all Agilent ICT UNIX inspection systems you wish to connect to the Intelligent Test Framework.

If you have a Single-Tester ITF Server, only one test system can be connected to the Intelligent Test Framework.

Proceed to Chapter 12, Verifying Data Transmission to verify data transmission to the ITF Server.
Verifying Data Transmission

- Overview, 12-2
- Verifying Data is Sent to the ITF Server, 12-3
Prior to using the Intelligent Test Framework and its associated software applications, you should check your installation and configuration setup to verify that data is being sent to the ITF Server.
Chapter 12: Verifying Data Transmission: Verifying Data is Sent to the ITF Server

Verifying Data is Sent to the ITF Server

After the test systems have been configured for use with the Intelligent Test Framework, verify that tester data is being sent to the ITF Server correctly.

For each test system, do the following:

1. Test one board on the test system that is connected to the ITF Server. Use a dummy serial number such as “test123” for this board.

2. Log on to the ITF Administration System in the ITF Server.

3. Click **Framework** > **Data Management** > **Data Viewer**.

4. Select the type of tester, and click **Browse**.

   The board type name of the board just tested should appear in a new browser window.

5. Click the board type name.

   You should see the available serial numbers for this board.

**NOTE**

Steps 3 through 5 help to verify that board test result is populated from the tester to the ITF Server.

6. Run the ART Client.

7. Log into the ART Client.

8. Use the ART Client to display the board test results for viewing.
Troubleshooting

- Restarting the ITF Server Software, 13-2
- Changing the Locale, 13-3
- Changing the Local Security Policy for Microsoft Windows Server 2003, 13-7
- Sharing the ITF Server with Agilent ICT UNIX, 13-9
- Problem Scenarios, 13-11
Chapter 13: Troubleshooting: Restarting the ITF Server Software

Restarting the ITF Server Software

You may want to restart the ITF Server software if one of the following occurs:

- You can no longer log in or open boards in the Agilent Repair Tool.
- No CAD data or images are displayed in the Agilent Repair Tool.
- You can no longer log in or view charts in the Agilent Quality Tool.
- Test systems are not sending data to the ITF Server.
- You changed the time setting on the ITF Server.

Before restarting the ITF Server software, check to make sure the Client PC configurations for the Agilent Repair Tool and Agilent Quality Tool are correct.

To restart the ITF Server software,

1. Log out of the ITF Administration System.
2. Stop all services.
3. Restart the ITF Server.

Once the ITF software has been restarted, the services are started automatically. The ITF Server is now ready to continue with its normal functions.
Changing the Locale

If you wish to use ART in Chinese, you need to change your ART client PC’s locale to Chinese (PRC).

To change the locale to Chinese (PRC), do the following.

For Windows XP

1. Click Start > Control Panel.
2. Double-click Regional and Language Options.
3. Under Regional Options, select Chinese (PRC) from the drop-down list.

Figure 13-1  Selecting Chinese (PRC) as the locale
4 Click the **Advanced** tab.

5 Select **Chinese (PRC)** from the drop-down list under **Language for non-Unicode programs**.

**Figure 13-2** Selecting language for non-Unicode programs

6 Click the **Languages** tab.

7 Ensure the **Install files for East-Asian languages** check box is selected under **Supplemental language support**.

**Figure 13-3** Specifying supplemental language support

8 Click **Apply** followed by **OK**.
Chapter 13: Troubleshooting: Changing the Locale

For Windows 2000

1. Click Start > Settings > Control Panel.
2. Double-click **Regional and Language Options**.
3. On the **General** tab, select **Chinese (PRC)** from the drop-down list under **Settings for the current user**.

**Figure 13-4** Selecting settings for the current user

4. Under **Language settings for the system**, select the **Simplified Chinese** check box.

**Figure 13-5** Selecting language settings for the system

If the system prompts you for the Windows 2000 CD, insert it and follow the instructions on the screen. After the required files are installed, you will be prompted to restart the computer. Click **OK** and wait for the computer to restart. After it is restarted, you will return to the screen in **Figure 13-5**.
Chapter 13: Troubleshooting: Changing the Locale

5  Click the Set default button.

6  In the Select System Locale dialog box, select Chinese (PRC) from the drop-down list and click OK.

Figure 13-6   Selecting system locale

7  Restart your computer when prompted.
If you are mounting a UNIX system to Microsoft Windows Server 2003, you need to do the following:

1. Log on to the ITF Server with administrative privileges.
2. Click Start > Programs > Administrative Tools > Local Security Policy.
3. Change the setting for Network access: Let Everyone permission apply to anonymous users to Enabled. See Figure 13-7.
4. Restart the ITF Server.
Figure 13-7 Local Security Settings dialog box
Sharing the ITF Server with Agilent ICT UNIX

If you have installed Microsoft Windows SFU 3.5 after installing the ITF Server, you need to enable NFS sharing manually.

1. On the ITF Server, right-click the storage folder in the installed folder of the tester components.
2. Select Sharing from the menu that appears.
3. In the storage Properties dialog box, click the NFS Sharing tab.
4. Click the Share this folder option.
   The word storage should appear in the Share Name text box.

5. Click the Permissions button.
   The NFS Permissions dialog box appears. Make sure ALL MACHINES and Read-Write access options are selected.
Figure 13-9  NFS Share Permissions

6 Click **OK** to exit the **NFS Sharing** dialog box.

7 Click **Apply** followed by **OK** to save the settings and close the **storage Properties** dialog box.

Repeat this procedure for the **install** folder on the ITF Server. At step 5, select **Read-Only** instead of **Read-Write** for the **install** folder.

Sharing the ITF Server with the Agilent ICT system is complete.
Problem Scenarios

Below are problem scenarios you may experience while installing or using the Agilent ITF applications. Possible reasons for their occurrence and suggested solutions are listed for each.

Table 13-1  Problem Scenarios

<table>
<thead>
<tr>
<th>Scenario</th>
<th>Reason(s)</th>
<th>Solution(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Agilent Repair Tool or Agilent Quality Tool cannot find the ITF Server</td>
<td>• ART or Agilent Quality Tool is not mapped to the ITF Server.</td>
<td>• Check the Tools &gt; Data Source settings to make sure the ITF Server Name or IP Address is correct.</td>
</tr>
<tr>
<td>The ITF Administration System or connections to the network are slow.</td>
<td>• ITF Server could be trying to access a web proxy server and is timing out.</td>
<td>• Right-click the Windows Explorer desktop icon. Select Properties from the drop-down menu. Select the Connections tab and click LAN Settings. Clear the Automatically detect settings check box. Click OK to exit dialog boxes.</td>
</tr>
<tr>
<td>No data appears in the Agilent Repair Tool defect table for AXI stage.</td>
<td>• Automatic Reporter on the Agilent AXI is not started. • ITF Server disk is full.</td>
<td>• See the Agilent AXI User Guide for more information on how to start the Automatic Defect Reporter. • Check the allocated disk space on the ITF Server. • Check the Installing and Configuring the Agilent AXI chapter for information on mapping drives. • Check the Broken folder on the tester controller to see if there are any files there. Files will be placed in this directory if the ITF Agent cannot parse them. Examine any broken files for errors, correct them.</td>
</tr>
</tbody>
</table>
**Chapter 13: Troubleshooting: Problem Scenarios**

### Table 13-1  Problem Scenarios

<table>
<thead>
<tr>
<th>Scenario</th>
<th>Reason(s)</th>
<th>Solution(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>No images appear in the Agilent Repair Tool image view for AXI stage</td>
<td>• Image collection on the Agilent AXI is not turned on.</td>
<td>• Set the Agilent AXI to collect images.</td>
</tr>
<tr>
<td></td>
<td>• Automatic Reporter on the Agilent AXI is not started.</td>
<td>• See the Agilent AXI User Guide for more information on how to start the Automatic Defect Reporter.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Check lines in <code>trcmdpro.cmd</code> that convert and copy images.</td>
</tr>
<tr>
<td>Cannot open AOI boards in the Agilent Repair Tool. OR No data is available for AOI stage in the Agilent Quality Tool.</td>
<td>• Data files are not being transferred from the AOI test system to the ITF Server.</td>
<td>• The CommConfig utility is not configured properly. Re-configure the CONFIGFILE registry key on the AOI test system using the following steps:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>a  Click <strong>Start &gt; Run</strong> from the Start &gt; Programs menu on the AOI controller.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>b  In the <strong>Run</strong> dialog box, type <code>regedit</code> then click <strong>OK</strong>.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>c  Browse to the following folder: <code>HKEY_LOCAL_MACHINE\SOFTWARE\MV Technology\GS-1\Comm</code></td>
</tr>
<tr>
<td></td>
<td></td>
<td>d  Double-click the <strong>CONFIGFILE</strong> registry key.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>e  In the <strong>Edit String</strong> dialog box, type <code>C:\Agilent\Itf\ITFConfig.xml</code> in the <strong>Data Value</strong> box, and then click <strong>OK</strong>.</td>
</tr>
</tbody>
</table>

![Edit String dialog box](image)
### Table 13-1  Problem Scenarios

<table>
<thead>
<tr>
<th>Scenario</th>
<th>Reason(s)</th>
<th>Solution(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>No data appears in the Agilent Repair Tool</td>
<td>• ITF Server disk is full.</td>
<td>• Check the allocated disk space on the ITF Server.</td>
</tr>
<tr>
<td>defect table for ICT view.</td>
<td>• Drives may not be mapped correctly.</td>
<td>• Check either Installing and Configuring the Agilent ICT UNIX or Installing and Configuring the Agilent ICT WN for information on mapping drives.</td>
</tr>
<tr>
<td></td>
<td>• The Agilent ICT testplan was modified incorrectly.</td>
<td>• Verify that the testplan has been modified properly on the Agilent ICT and that the data is being logged.</td>
</tr>
<tr>
<td></td>
<td>• Translogd is not running.</td>
<td>• Verify that translogd is running on the Agilent ICT.</td>
</tr>
<tr>
<td></td>
<td>• ITF Agent could not parse files.</td>
<td>From a UNIX shell dialog box, type: ps -ef</td>
</tr>
<tr>
<td></td>
<td>• ITF Agent could not locate the appropriate GenCAM file for the board.</td>
<td>• Check the Broken folder on the tester controller to see if there are any files there. Files will be placed in this directory if the ITF Agent cannot parse them. Examine any broken files for errors, correct them.</td>
</tr>
<tr>
<td></td>
<td>• ITF Agent service has stopped running.</td>
<td>• Check the NoGenCAMFiles directory on the ITF Server to see if it contains any files. Files will be placed in this directory if the adapter cannot locate the correct GenCAM file for the board. Locate or generate the appropriate GenCAM file and put it in the GenCAMData directory. Then move the unparsed logfiles from the NoGenCAMFiles directory to the Logfiles directory.</td>
</tr>
<tr>
<td>No images appear in Agilent Repair Tool image view for AOI and AXI stages.</td>
<td>• Agilent Repair Tool is not in the same time zone as the ITF server.</td>
<td>• Check to see that the Date/Time and time zone settings on the ITF Server match the Date/Time and time zone settings on your test systems and Client PCs. All machines attached to the Intelligent Test Framework must have the same Date/Time and time zone settings. Be sure to restart the ITF Server or Client PC after changing the time setting.</td>
</tr>
</tbody>
</table>
### Table 13-1  Problem Scenarios

<table>
<thead>
<tr>
<th>Scenario</th>
<th>Reason(s)</th>
<th>Solution(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>The 3DRender is running at a low speed on Agilent Repair Tool Client PCs.</td>
<td>• A parameter setting needs to be changed.</td>
<td>• Change the parameter Recon_hires from 1000 to 150 in the settings.txt found in the C:\Program Files\Agilent Technologies\3DRender folder.</td>
</tr>
<tr>
<td>Charts are displaying incorrect board data in the Agilent Quality Tool.</td>
<td>• Time settings for test systems, ITF Server, and Client PCs are different.</td>
<td>• Check to see that the Date/Time and time zone settings on the ITF Server match the Date/Time and time zone settings on your test systems and Client PCs. All machines attached to the Intelligent Test Framework must have the same Date/Time and time zone settings. Be sure to restart the ITF Server or Client PC after changing the time setting.</td>
</tr>
<tr>
<td>Trend charts stop updating automatically in the Agilent Quality Tool.</td>
<td>• Time settings for test systems, ITF Server, and Client PCs are different.</td>
<td>• Check to see that the Date/Time and time zone settings on the ITF Server match the Date/Time and time zone settings on your test systems and Client PCs. All machines attached to the Intelligent Test Framework must have the same Date/Time and time zone settings. Be sure to restart the ITF Server or Client PC after changing the time setting.</td>
</tr>
<tr>
<td>No charts appear in the Agilent Quality Tool.</td>
<td>• For new Views, you may have to wait up to 30 minutes for data to appear in your trend charts. Trend charts are updated on the hour and every half-hour. • Drives may not be mapped correctly. • Time settings for test systems, ITF Server, and Client PCs are different. • Data has been deleted.</td>
<td>• If you have just created a new View, wait 30 minutes for the data to be updated and trend charts to appear. • Check to see if the View properties are correct. • Make sure the Date/Time and time zone settings on all the test systems, ITF Server, and Client PCs are the same. Be sure to restart the ITF Server or Client PC after changing the time setting. • Check the Lifetime Rules setting in the ITF Administration System. The data may have been deleted because of the current settings in the Lifetime Rules utility.</td>
</tr>
</tbody>
</table>
## Chapter 13: Troubleshooting: Problem Scenarios

### Table 13-1  Problem Scenarios

<table>
<thead>
<tr>
<th>Scenario</th>
<th>Reason(s)</th>
<th>Solution(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>ITF Agent stops processing files.</td>
<td>• Time settings for test systems, ITF Server, and Client PCs are different.</td>
<td>• Check to see that the Date/Time and time zone settings on the ITF Server match the Date/Time and time zone settings on your test systems and Client PCs. All machines attached to the Intelligent Test Framework must have the same Date/Time and time zone settings. Be sure to restart the ITF Server or Client PC after changing the time setting.</td>
</tr>
<tr>
<td></td>
<td>• Time settings were changed on the ITF Server, but Server was not restarted.</td>
<td>• Stop and restart all services on the ITF Server.</td>
</tr>
<tr>
<td></td>
<td>• ITF Agent service has stopped running.</td>
<td>• Restart the ITF Server.</td>
</tr>
<tr>
<td></td>
<td>• Connection between the ITF Server and the ITF Agent has been lost.</td>
<td>• Make sure that the connection between the ITF Server and the ITF Agent is working properly.</td>
</tr>
<tr>
<td>Logfiles are missing or not showing up at the ITF Server.</td>
<td>• Error occurred with translogd.</td>
<td>• Go to /var/hp3070/qm/logdata on the Agilent ICT and open the tld.log file. This file contains a list of possible errors.</td>
</tr>
<tr>
<td>Perl script file fails and does not modify the tld.prplus file.</td>
<td>• You may not be logged in as an ICT user.</td>
<td>• Please contact Agilent Technologies Technical Support at 1-800-447-8378. Outside the U.S., please contact your local support.</td>
</tr>
<tr>
<td></td>
<td>• Permissions are set incorrectly. Permissions assigned to the aitfmodtldwrite file must match prsetup.</td>
<td>• Manually modify the testplan. See Manually Modifying Testplans for Agilent ICT for more information.</td>
</tr>
<tr>
<td>aitfprp2art script fails and does not modify the testplans or generate GenCAM files.</td>
<td>• Permissions are set incorrectly. No read-write access to board directory or no search permissions.</td>
<td>• Manually run the gc3070 tool. See Manually Generating Agilent ICT GenCAM Files for Each Board Type for more information.</td>
</tr>
</tbody>
</table>
### Table 13-1  Problem Scenarios

<table>
<thead>
<tr>
<th>Scenario</th>
<th>Reason(s)</th>
<th>Solution(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>GenCAM files are loading slowly.</td>
<td>• Files are too large.</td>
<td>• Regenerate the files using CAMCAD Professional. Be sure to turn off internal layers prior to regenerating the files.</td>
</tr>
<tr>
<td>In the ART Zoom view, components look like they are stacked on top of each other and are only on one side of the board.</td>
<td>• board.o and board_xy.o files do not designate board sides (top/bottom) correctly.</td>
<td>• Check the Agilent Technologies Technical Support web site (<a href="http://www.agilent.com/key/boardtest">www.agilent.com/key/boardtest</a>) for more information or call Agilent Support at 1-800-447-8378. Outside the U.S., please contact your local support.</td>
</tr>
</tbody>
</table>
### Table 13-1 Problem Scenarios

<table>
<thead>
<tr>
<th>Scenario</th>
<th>Reason(s)</th>
<th>Solution(s)</th>
</tr>
</thead>
</table>
| Cannot view contents of the Install directory on the ITF Server from the ICT UNIX system. | • Security options may be set incorrectly.  
• System may have old paths cached in memory. | • On the ITF Server, use Windows® Explorer to locate the Install directory. Right-click the highlighted Install directory. Select **Sharing** from the menu. In the Install Properties dialog box, select the Security tab. Check that **Everyone** is listed with **Full Control** permissions.  
• Restart the Agilent ICT UNIX controller |
Getting Help

Assistance is available in the following ways:

- Technical Support, 14-2
- Phone Support, 14-3
- Sales and Product Information, 14-4
Technical Support

The Agilent Technologies Printed Circuit Board Test and Inspection web site is for the benefit of owners and users of the Agilent Quality Tool, the Agilent Repair Tool, and Agilent Technologies' board test and inspection systems.

Visit the web site at: http://www.agilent.com/see/pcb

**NOTE**

A login is required for access to service documentation and downloads.

Topics available from the web site include the following:

- Application Notes and Technical Papers
- Data Sheets, Brochures, Demonstrations and Catalogs
- Frequently-Asked Questions (FAQs)
- Manuals, Guides and Notifications
- Newsletters, Presentations, and Articles
- Software, Firmware and Drivers
Phone Support

Phone-based support is included for the first year of purchase and is highly recommended for subsequent years.

Customers can call a 24-hour toll free support phone number.

- In the United States, the phone number is 1-800-447-8378.
- Customers in the rest of the world can call their local support.

For more information about support services, go to the Agilent Technologies web site at http://www.agilent.com/see/pcb or contact your local Agilent Technologies field representative.
Sales and Product Information

- For more information about Agilent Technologies products and services in electronics manufacturing, visit our web site: http://www.agilent.com/see/pcb

- To learn about other Agilent Technologies test and measurement products, applications and services, or for a current sales office listing, visit our web site: http://www.agilent.com/find/tmdir
This appendix provides information on optional configurations you can set for Agilent ICT and Agilent AXI.

- Manually Modifying Testplans for Agilent ICT, A-2
- Manually Generating Agilent ICT GenCAM Files for Each Board Type, A-4
- Modifications to the ART Setup for Use with TestWise SPC on the Agilent AXI, A-7
Appendix A: Optional Configurations for Agilent ICT and Agilent AXI: Manually Modifying Testplans for Agilent ICT

Manually Modifying Testplans for Agilent ICT

When preparing the Agilent ICT for use with the Agilent Repair Tool, some minor modifications must be made to the testplan. These modifications must be done for each board directory on the Agilent ICT UNIX and WN.

Modifications to the testplan include the following:

- Turning on data-logging
- Setting the log level and report levels

**NOTE**

These modifications can be done automatically by running the aitfprp2art script on the Agilent ICT. This script also generates GenCAM files for each board type located on the Agilent ICT. For more information about automatically making these changes, see Running the aitfprp2art Script to Modify Testplans and Generate GenCAM Files on page 11-38.

To manually modify the testplan:

1. Open an existing testplan in a BT-Basic window.
2. Make a copy of the existing testplan:
   
   Using BT-Basic, copy testplan to testplan.prp.
3. Edit the testplan file.
4. Find the subroutine called Set_Custom_Options.
5. Under that subroutine is the line:
   
   Using_PRPlus = False

   This command is used to turn data-logging on and off to the Repair Client software.
6. If your board tests are ready for production, set the command to:

   Using_ART = TRUE

   This tells the Agilent ICT to send test results to the Intelligent Test Framework and Agilent Repair Tool.
7. Change all other occurrences of the words Using_PRPlus to Using_ART within the testplan code.
8. The log level commands must also be modified. Locate the occurrences of the following line:

   log level is failures without nhls, pins

   Change the lines to the following:

   log level is indictments without nhls
Appendix A: Optional Configurations for Agilent ICT and Agilent AXI: Manually Modifying Testplans for Agilent ICT

9 Locate the subroutine called Initializations. Under this subroutine is the setting for the report level.

if Using_ART then
report level is all

The report level determines where the test report information is sent. If the report level is set to all, then the information is sent to both the logging destination and the strip printer or other reporting device at the tester.

If you do not wish to view or print the report ticket at the Agilent ICT, turn off the local reporting function by changing the level to log. The test report information will only be sent to the Agilent Repair Tool. For example,

if Using_ART then
report level is log

10 Repeat the above steps for each testplan you wish to use with the Intelligent Test Framework.
Manually Generating Agilent ICT GenCAM Files for Each Board Type

The Agilent Repair Tool produces board graphics using CAD information about the board’s net-list, Bill of Materials, and component locations. Because the Intelligent Test Framework is structured to work with IPC compliant protocols and standards, it is necessary that you generate IPC-2511 (GenCAM) CAD files for each board type you wish to test and repair using the Intelligent Test Framework.

CAUTION

⚠️ If CAD data is not available for a board type and a GenCAM file cannot be successfully created using the gc3070 tool, you must first create an empty text file on the Agilent ICT controller (touch <board-type>.gcm).

Before you manually move GenCAM files from an Agilent ICT UNIX or Agilent ICT WN to the ITF Server, be sure to run the following command to make the files readable and writable:

```bash
chmod 666 <board-type>.gcm
```

Now copy the empty GenCAM file from the Agilent 3070 controller to the ITF Server in the following directory:

```bash
<installed ITF tester agent>\storage\Input
```

where the default value of `<installed ITF tester agent>` is C:\Agilent\ITFSS3.1\Agent.

Note that this directory for UNIX will be on the ITF Server.

GenCAM is an ANSI standard data file format used to describe printed board and printed board assembly products with details sufficient for tooling, manufacturing, assembly, inspection and testing requirements.

NOTE

You can automatically generate GenCAM files for each board type by running the aitfprp2art script on the Agilent ICT. This script also modifies the testplan by turning on data-logging and setting the log level and report levels. For more information about automatically making these changes, see Running the aitfprp2art Script to Modify Testplans and Generate GenCAM Files on page 11-38.

You can manually generate GenCAM files for each board type by either:

- Using CAMCAD Professional to output CAD files in the GenCAM 1.5 format, or
- Running the gc3070 tool on the Agilent ICT in all board directories to generate a GenCAM 1.5 format file from your existing board.o and board_xy.o files.

After generating your GenCAM files, check to make sure the name matches the board type listed in the corresponding testplan. For more information, please
see [Verifying the Names of the GenCAM Files](#) on page 11-40.

### Using CAMCAD Professional

**NOTE**

If you do not currently have the GenCAM V1.5 Write export module in CAMCAD Professional, you can purchase it through Agilent Technologies.

1. Simply import your original CAD files into CAMCAD Professional and output the files using the GenCAM V1.5 Write export module.

2. The name given to your `.gcm` files must match the board type in the corresponding testplan.

3. Copy the `.gcm` files to the `storage\Input` folder in the installed folder for the ITF tester agent on the ITF Server (for ICT UNIX) or the tester controller (for ICT WN). The default path is `C:\Agilent\ITFSS3.1\Agent\storage\Input`.

4. Repeat these steps for each board type you wish to test and repair using the Intelligent Test Framework.

### Running the gc3070 Tool

The gc3070 tool requires that you have both a `board.o` and `board_xy.o` file in order to generate a GenCAM file.

1. Log on to the Agilent ICT UNIX or WN controller as Super User or with Administrator privileges.

2. In a shell or Korn shell dialog box, open the directory that includes your `board.o` and `board_xy.o` files of interest.

3. At the command prompt, type: `gc3070` and then press ENTER. If you have set up your networking and configuration correctly, a `.gcm` file is created and automatically placed under the GenCAMData folder on the ITF Server. The name of the `.gcm` file is based upon the name of the original board directory that contained the `board.o` and `board_xy.o` files.

4. Repeat these steps for each board type you wish to test and repair using the Intelligent Test Framework.
Appendix A: Optional Configurations for Agilent ICT and Agilent AXI: Manually Generating Agilent ICT GenCAM Files for Each Board Type

NOTE

If you are generating a GenCAM file using the command `gc3070` or a local GenCAM file using the command `gc3070 -l`, please make sure you run the `chmod 666` command to make the file readable and writable before you manually move it (using `cp -p`) from the Agilent ICT UNIX or WN system to the ITF Server.

For the Agilent ICT UNIX type:

```
# /opt/hp3070/bin/gc3070
```

For the Agilent ICT WN type:

```
$ C:\Agilent3070\bin\gc3070
```
I. Modifying the autorpt.cfg File on the Agilent AXI

TestWise SPC requires that Agilent AXI serial numbers are included in the .RLE files it receives from the Agilent Repair Tool. To make sure this occurs, check the test report header identifier in the autorpt.cfg file on the Agilent AXI. The command should read:

```
MachineSerialNumber=Yes
```

II. Configuring ART

In order for ART to send the appropriate information to TestWise SPC:

1. Open the ITF Administration System by either:
   a. Double-clicking the ITF Administration System desktop icon on the ITF Server or
   b. Browsing to the following location from a web browser on any system connected to the network:

   `http://<Name of ITF Server>:8080/adminclient`

2. Log on to the ITF Administration System with Administrator privileges.

3. Create a new user with REPAIR_ADMIN permission.

4. Save the new REPAIR_ADMIN user.

5. Log out of the ITF Administration System.

6. At the Client PC or Single-Tester ITF Server, log on to ART as the new REPAIR_ADMIN user or as Administrator.

7. If the Open Board dialog box appears, click Cancel.

8. On the Tools menu, click Administration.

9. Click the General tab.

10. Select the option to export RLE files when closing a board in the Agilent Repair Tool:
   a. Place a check in the following box:

   `[X] Export RLE File when Closing Board`
   b. Browse to the RLE export directory to select the location for your files.

11. Click Apply, and then click OK when done.

12. Click the Logout button at the top of the screen.

**NOTE**

The ITF Administration System will not generate RLE files for a board if it has not been repaired or if it contains no defects.
Other Optional Settings

This appendix contains information on other optional settings you may want to configure.

- Setting up a Network PC or Server to receive XML Export files, B-2
- Setting up ART for in-line use with the Agilent AOI, B-5
- Using an RS232 Barcode Reader with the Agilent Repair Tool, B-8
Setting up a Network PC or Server to receive XML Export files

Before running XML Export on the ITF Server, you must first designate and configure a network PC or server to receive the XML files exported by the ITF Server.

To set up a network PC or server to receive XML Export files:

1. Select a machine on your network, other than the ITF Server, to receive and store the XML files. This machine must be on the same domain as your ITF Server. It is recommended that you select the same machine that will be used to parse your XML files.

   **NOTE**

   Do not select the ITF Server as the XML file destination. Storing XML files on the ITF Server would decrease system performance.

2. Create a user account on the network PC or server designated to receive XML files.

   **NOTE**

   The following instructions are for Windows 2000 operating systems.

   To create the user account,

   - Log on to the designated network PC or server with *Administrator privileges*.
   - Click **Start > Programs > Administrative Tools > Computer Management**.
   - In the left pane window, double-click **Local Users and Groups**.
   - Click **Users**.
   - From the toolbar at the top of the dialog box, click **Action > New User**.
   - Fill in the following text boxes:
     - **User Name**: ITFUser
     - **Full Name**: (leave blank)
     - **Description**: Drive mapping for XML Export
     - **Password**: (leave blank)
     - **Confirm Password**: (leave blank)
   - Clear the **User must change password at next logon** check box.
   - Select the **Password never expires** check box.
   - Click **Create**.
   - Click **Close**.
Appendix B: Other Optional Settings: Setting up a Network PC or Server to receive XML Export files

k  Verify that the new user, ITFUser, appears in the list of users.
l  Close the Computer Management window.
m  Click Start > Programs > Administrative Tools > Local Security Policy.
n  In the left pane window, double-click Local Policies.
o  Click User Rights Assignment.
p  Click Deny Logon Locally.
q  Right-click and select Security.
r  Click Add.
s  Select the new user account, ITF User.
t  Click Add.
u  Click OK to exit all dialog boxes.
v  Close the Local Security Setting window.
w  Setting up the ITF User account is complete.

3  Create a folder named ITF on the network PC or server that will receive the XML files. Create the folder at the highest level i.e., C:\ITF.
a  In Windows Explorer, right-click the C: drive.
b  Select New Folder.
c  Name the new folder ITF.

4  Assign “Sharing” privileges to the ITF folder.
a  In Windows Explorer, right-click the ITF folder.
b  Select Sharing from the menu.
c  Select the Sharing tab.
d  Select the Share this folder option.
e  Check to make sure the Maximum allowed option is selected for the User Limit.
f  Click the Permissions button. Make sure that Full control permissions is selected, and then click OK.
g  Click Apply followed by OK.

5  Log in to the ITF Server with Administrator privileges.

6  Log in to the ITF Administration System by double-clicking the ITF Administration System desktop icon. Log in with Administrator privileges.

7  Click Framework > Data Management from the main menu.

8  Click XML Export.

   The XML Export dialog box appears.

9  In the Destination box, enter the hostname and shared folder of the network PC or server that will receive the XML files from the ITF Server.

   For example, if your machine's hostname is XML1 and the shared folder is ITF, you would enter the following in the Destination box:
   \XML1\ITF\XMLExport.
Appendix B: Other Optional Settings: Setting up a Network PC or Server to receive XML Export files

Figure B-1  Destination box

XML Export

Enable XML Export to transfer files:
- F After a board is tested
- F After a board is repaired

Include board data for:
- IT AOI (Automated Optical Inspection)
- IT AIX (Automated X-ray Inspection)
- IT ICT (In-circuit Test)

Include defect data:
- F Include defect information in XML files (optional)

Destination (<hostname>\ITF\XMLExport):

Note: Do not select the ITF Server as the XML file destination. Storing XML files on the ITF Server would decrease system performance.

10 Click Apply.

11 Follow the instructions listed in the Run XML Export section of the ITF Administration System online Help to begin using XML Export.

NOTE

The ITF Administration System will not generate XML files for a board if it has not been repaired or if it contains no defects.
Setting up ART for in-line use with the Agilent AOI

The Agilent Repair Tool (ART) Board Buffering option allows you to configure ART for in-line use with the Agilent AOI. The Board Buffering option is useful when boards are non-serialized (no barcode labels) and you want to open boards in ART to repair them in the order they were tested. This option is available if you have selected to open boards in sequence, rather than using serial numbers.

**NOTE**

A user must have Repair Administrator privileges to access the Administration dialog boxes.

For example:

Three boards are inspected on an Agilent AOI inspection system. Board A1 was tested at 8 a.m., Board A2 at 9 a.m., and Board A3 at 10 a.m.

If you select **Use Board Buffering**, test results for all of the boards will go to the board buffer. Test results for the board with the oldest test time (A1) are displayed first in ART. Test results for A2 are displayed next, then A3.

If you do not select to use board buffering, test results are only available in ART for the most recently tested board. In this example, only results from Board A3 would be available in ART.
Setting Up Board Buffering

To set up the **Board Buffering** option, you will need to know the following:

- Will the boards be coded with serial numbers (barcodes)?
- Will the repair station receive boards inspected by several test machines, or just one particular test machine?
- The machine ID (serial number) for the test or inspection system if just one particular test machine is used.

There are three options on the **AOI Board Source** tab for opening boards for AOI repair. They are:

- Open boards by serial number; Boards are inspected by any machine.
- Open boards by serial number; Boards are inspected by a specific machine.
- Open boards in sequence; Boards are inspected by a specific machine.

To set the **AOI Board Source** options:

1. On the **Tools** menu, click **Administration**.
2. In the **Administration** dialog box, click the **AOI Board Source** tab.

3. Click the option you want for opening boards.
4. Enter the machine ID, if necessary.
5. If you select **Open boards in sequence**, you may also choose:
   - Whether to use board buffering, and
   - Whether to prompt the user to manually enter a serial number when they close a board.
If you need to check or change any information on another tab, click that tab heading now. Otherwise, click OK to save your changes and close the Administration dialog box.

**NOTE**

For more information, see the Agilent Repair Tool online Help.

**Resetting the Buffer**

If you are using the Board Buffering option, you can delete the current buffer by clicking Reset Buffer on the AOI Board Source tab. This deletes the test results for boards not yet opened in ART.

You may want to reset the buffer when:

- Boards waiting for repair are out of sequence and you want to reset the buffer, start over, and retest the boards.
- You tested boards only to configure your test station, and do not need the actual test results.
- You are not interested in test results for the boards queued up as repair work in progress (WIP).
Appendix B: Other Optional Settings: Using an RS232 Barcode Reader with the Agilent Repair Tool

Using an RS232 Barcode Reader with the Agilent Repair Tool

The RS232 to PS2 program allows you to use an RS232 serial port barcode reader with the Agilent Repair Tool. The option to install the RS232 to PS2 software occurs during the Agilent Repair Tool software installation on the Client PC. Once installed, the program for RS232 barcode readers will launch and run automatically each time your system is restarted.

**NOTE**

If you have a Single-Tester ITF Server, the RS232 to PS2 software is already installed.

Re-establishing a Connection

If your connection has failed:

1. Click the **RS232 to PS2** button on the toolbar at the bottom of the Client PC or Single-Tester ITF Server display.

**Figure B-4**  RS232 to PS2 button

2. On the **Action** menu, click **Connect**.

**Figure B-5**  Reconnect RS232 to PS2

This will re-establish the connection to the barcode reader.

Configuring Settings

To configure the connection settings:

1. From the main menu, click **Settings**. The **TTY Settings** dialog box appears.
Exit the Program

Exiting the RS232 to PS2 program will stop the RS232 to PS2 conversion. Once you have exited the program, you will no longer be able to use an RS232 barcode reader with the Agilent Repair Tool unless you start the RS232 to PS2 program again.

To exit the RS232 to PS2 program:

1. On the Action menu, click Exit.
2. Click OK to exit the program.

2. Select the COM, Terminal, or Control options that are appropriate for your RS232 barcode reader.

Font display can also be selected from this dialog box.

3. Click OK to save the selected options and close the TTY Settings dialog box.

NOTE

TTY Settings can also be changed while the barcode reader is connected.
Glossary

A
Administration System - see ITF Administration System.

Agilent AOI - Agilent Technologies' optical inspection system. Automated Optical Inspection (AOI) uses cameras to inspect components on printed circuit boards. AOI can be used to check for presence-absence, skew, character markings, and polarity.

Agilent AXI - Agilent Technologies' X-ray inspection system. Automated X-ray Inspection (AXI) uses 3-D x-ray testing to locate manufacturing defects. In addition, it does not require in-circuit test probing or visual access and does not require a fixture. AXI pinpoints the exact location of the defects; thus, repairs are both fast and inexpensive.

Agilent ICT - Agilent Technologies' in-circuit board test system family.

Agilent Quality Tool - An SPC/SQC tool for the Agilent AXI and Agilent AOI test systems. The Agilent Quality Tool allows users to apply SPC and SQC methods to improve assembly and test process efficiencies while helping them meet targeted quality levels. Common abbreviation is AQT.

Agilent Repair Tool - The common repair tool for the Agilent ICT, Agilent AXI, and Agilent AOI test systems. Common abbreviation is ART.

AQT - Abbreviation for Agilent Quality Tool. See Agilent Quality Tool.

ART - Abbreviation for Agilent Repair Tool. See Agilent Repair Tool.

C
Client PC - The computer on which the Agilent Repair Tool or Agilent Quality Tool software runs.

D
DNS - Domain Name Server

G
gc3070 - GenCAM translator on Agilent ICT (board.o and board_xy.o to GenCAM)

H
Hostname - Name of your system on the network.

I
ICT UNIX - Agilent ICT HP-UX platform.

ICT WN - Agilent ICT Windows platform.

Intelligent Test Framework - A collective term that refers to the Intelligent Test Framework software and server. Abbreviation is ITF.

Intelligent Test Framework Server - The server hardware on which the Intelligent Test Framework software runs. Abbreviation is ITF Server.

ITF Administration System - A browser-based application used to configure system properties, such as user access, repair configurations, and framework services for ITF software.
applications. It is a software program located on the Intelligent Test Framework Server.

**ITF Software Solutions** - A suite of software applications that run on the Intelligent Test Framework.

**N**

**NFS** - Networked File System

**Q**

**Quality Client** - The Client PC on which the Agilent Quality Tool software runs.

**RAID** - Abbreviation for Redundant Array of Independent Disks

**Repair Client** - The Client PC on which the Agilent Repair Tool software runs.

**RLE** - Abbreviation for Run-Length Encoding.

**T**

**trcmdpro.cmd file** - Autoreporter script on the Agilent AXI.

**X**

**XML** - Abbreviation for Extensible Markup Language. XML is a specification developed by the World Wide Web Consortium. It allows designers to create their own customized tags, enabling the definition, transmission, validation, and interpretation of data between applications and between organizations.
Index

Symbols
@BATCH log record, 10-17, 11-41

A
Administration System, see ITF Administration System
Agilent 3070 UNIX
  automounter, 11-12, 11-13
  configuring, 11-32
  installation checklist, 11-28
  installing Agilent ITF components, 11-29
  networking, 11-9
Agilent 3070 WN
  configuring, 10-11
  installation checklist, 10-3
  installing Agilent ITF components, 10-4
  modifying the directory structure, 10-14
Agilent 5DX
  configuring, 8-11
  installation checklist, 8-3
  instailling ITF components, 8-4
Agilent ITF Server
  minimum system requirements, 1-5
  networking, 3-3
  restarting, 13-2
  security options, 13-17
  setting TCP/IP connections, 3-4
  sharing directories, 13-9
  troubleshooting, 13-11

Agilent Quality Tool
  installing, 7-5
  overview, 7-2
  setting logins, 5-3
  setting permissions, 5-3
  starting, 7-12

Agilent Repair Tool
  in-line use with Agilent SJ Series, B-5
  installing, 6-5
  networking, 6-5
  overview, 6-2
  setting logins, 5-3
  setting permissions, 5-3
  starting, 6-13

Agilent SJ Series
  ART in-line, B-5
  configuring, 9-12
  installation checklist, 9-3
  installing Agilent ITF components, 9-4

Agilent Technologies
  web sites, 14-4
  aitfrp2art script, 10-15, 11-38
  anti-virus software, 1-5, 1-6
Index

Automounter. 11-12, 11-13
AXI view
data missing. 13-11

B
board buffering. B-5
board$ variable. 10-17, 11-40

C
CAMCAD Professional. A-5
Client PC
    installing Agilent Quality Tool. 7-5
    installing Agilent Repair Tool. 6-5
    minimum system requirements. 1-6
    networking for the Agilent Repair Tool, 6-5
CommConfig utility. 13-12

D
Date/Time settings. 1-5

E
Entitlement Certificate. 4-3
environment variables
    setting on the Agilent 3070 WN, 10-11

G
gc3070 tool. A-5
GenCAM files
    CAMCAD Professional. A-5
gc3070 tool. A-5
generating. 10-15, 11-38, A-4

H
help. 14-2
hp3070 file. 11-32

I
ICT view
data missing. 13-13
ITF Administration System. 4-2, 5-2
    web access, 5-3

L
licenses
    adding new. 4-9
    troubleshooting. 4-10
    viewing. 4-8
logins. 5-3
Index

M
manual
  quick reference, 1-13
Microsoft SQL Server, 1-7, 1-8
Microsoft Windows® 2000 Server Operating System, 1-7
minimum system requirements
  Agilent ITF Server, 1-5
  Client PC, 1-6
  software, 1-5

N
Network File System
  configuring, 11-13
Network Interface Cards, 3-3
networking
  overview, 3-2

P
perl script, 10-15, 11-37
  troubleshooting, 13-15
permissions, 5-3
phone support, 14-3
plimg.cfg file
  modifying, 8-13
PR+, 11-37
profile file, 11-34
Prsetup, 11-37

R
RS232 Barcode Reader, 6-13, B-8
RS232 to PS2 program, B-8

S
sales, 14-4
SAM, see System Administrator Manager, 11-10, 11-17
Symantec AntiVirus software
  for Client PCs, 1-5, 1-6
System Administrator Manager, 11-10, 11-17

T
TCP/IP, 3-4
technical support, 14-2
testplans
  modifying, 10-15, 11-38, A-2
TestWise SPC, A-7
timestamps, 1-5
tld.prplus file, 10-15, 11-37
transGenCAM directory, 11-12
trcmdpro.cmd file
  modifying, 8-11
TTY Settings dialog box, B-9