Universal Serial Bus Specification Revision 2.0

Keysight Method of Implementation (MOI) for USB 2.0

Connectors and Cables Assemblies Compliance Tests

Using Keysight E5071C ENA Option TDR
Table of Contents

1. Revision History ......................................................................................... 3
2. Purpose ........................................................................................................ 3
3. References .................................................................................................... 3
4. Required Equipment .................................................................................... 3
5. Test Procedure .............................................................................................. 4
  5.1. Outline of Test Procedure ........................................................................ 4
  5.2. Setup ......................................................................................................... 6
    5.2.1. Recalling a State File .......................................................................... 6
    5.2.2. Saving a State File .............................................................................. 7
  5.3. Calibration ............................................................................................... 8
    5.3.1. Time Domain Calibration .................................................................... 8
    5.3.2. Frequency Domain Calibration ........................................................... 13
    5.3.3. Adjustment of Effective Rise Time ....................................................... 15
  5.4. Measurement ........................................................................................... 18
    5.4.1. Cable Impedance (High/Full-Speed) ................................................... 18
    5.4.2. Propagation Delay .............................................................................. 18
    5.4.3. Propagation Delay Skew .................................................................... 19
    5.4.4. Signal Pair Attenuation (High/Full-Speed) ......................................... 20
  6.1. Channel & Trace Setup ............................................................................ 21
  6.2. Cable Impedance (High/Full-Speed) ....................................................... 22
  6.3. Propagation Delay .................................................................................. 24
  6.4. Propagation Delay Skew ......................................................................... 25
    6.4.1. Parameter Setup .................................................................................. 25
    6.4.2. Crosstalk Compensation .................................................................... 26
  6.5. Common Parameters Setup for Frequency-domain Measurements .......... 27
  6.6. Signal Pair Attenuation (High/Full-Speed) .............................................. 28
  6.7. Defining Limit Line Tables ..................................................................... 28
7. [Appendix] Defining SOLT Calibration Kit .................................................. 29
1. Revision History

<table>
<thead>
<tr>
<th>Revision</th>
<th>Comments</th>
<th>Issue Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.00</td>
<td>Initial Revision.</td>
<td>Sep. 24, 2014</td>
</tr>
</tbody>
</table>

2. Purpose

This test procedure was written to explain how to use the Keysight ENA Option TDR to make the connectors and cable assemblies measurements required per USB Specification Revision 2.0 and Cables and Connectors Class Document Revision 2.0.

3. References

- Universal Serial Bus Specification Revision 2.0 (April 27, 2000)
- Universal Serial Bus Cables and Connectors Class Document Revision 2.0 (August 2007)

4. Required Equipment

<table>
<thead>
<tr>
<th>Description</th>
<th>Test Equipment</th>
<th>QTY</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network Analyzer</td>
<td>Keysight E5071C ENA Series Network Analyzer</td>
<td>1 ea.</td>
</tr>
<tr>
<td></td>
<td>➢ Option 440/445/460/465/480/485/4DK/4K5 (one of port/freq. options)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>➢ Option TDR (Enhanced time domain analysis)</td>
<td></td>
</tr>
<tr>
<td>4-port ECAL or Mechanical Cal Kit</td>
<td>Keysight N4431B or 85033E (E5071C-44x/46x/48x)</td>
<td>1 ea.</td>
</tr>
<tr>
<td></td>
<td>Keysight N4433A or 85052D (E5071C-4D5/4K5)</td>
<td></td>
</tr>
<tr>
<td>Test Fixture</td>
<td>USB 3.0 official test fixture</td>
<td>1 ea.</td>
</tr>
<tr>
<td>Adapter</td>
<td>1250-1744 3.5 mm(f)-Type N(m) adapter (E5071C-44x/46x/48x) or 83059B coaxial adapter (E5071C-4DK/4K5) for E5071C ports</td>
<td>4 ea.</td>
</tr>
<tr>
<td>RF cable</td>
<td>3.5 mm or SMA cables of 4 GHz bandwidth or more</td>
<td>4 ea.</td>
</tr>
</tbody>
</table>

Note: Signal pair attenuation test requires the test frequency from 64 kHz. When using E5071C-4x5, the lower frequency is limited to either 100 kHz or 300 kHz depending on the frequency option.
5. Test Procedure

5.1. Outline of Test Procedure

1. Setup
   - Instrument, RF cables and test fixture setup
   - Automatic setup by recalling a state file or manual setup

2. Calibration
   - ECaCal Calibration & Fixture Compensation or Deskew & Loss Compensation
   - SOLT Calibration
   - Adjustment of Effective Rise Time

3. Measurements
   4-1. Time-domain Measurements
       - Cable Impedance (High/Full-Speed)
       - Propagation Delay
       - Propagation Delay Skew
   4-2. Frequency-domain Measurements
       - Signal Pair Attenuation (High/Full-Speed)
Note: Hard keys (Keys on the E5071C’s front panel) are displayed in Blue color and **Bold**.
(Example: **Avg. Analysis**)

Note: Soft keys (Keys on the E5071C’s screen) are displayed in **Bold**.
(Example: **S11, Real, Transform**)

Note: Buttons of the TDR software are displayed in **Green color and Bold**.
(Example: **Trace, Rise Time**)

Note: Tabs of the TDR software are displayed in **Brown color and Bold**.
(Example: **Setup, Trace Control**)

*Keysight MOI for USB 2.0 Connectors & Cable Assemblies Compliance Tests*
5.2. Setup

5.2.1. Recalling a State File
This section describes how to recall a state file of the E5071C that includes all the measurement settings for USB2.0 connectors and cable assemblies compliance tests. The state file can be downloaded at: [http://www.keysight.com/find/ena-tdr_compliance](http://www.keysight.com/find/ena-tdr_compliance)

Copy the state file into the E5071C’s directory via USB mass storage device and recall the state file using the TDR software. Necessary parameters for testing are automatically set up in the E5071C. Refer to Appendix for the details about manual setup.

If TDR setup wizard is shown, click Close button in the TDR setup wizard main window.

1. Open Setup tab.
2. Click Advanced Mode to show the dialog box.
3. A dialog box appears requesting for confirmation. Then click Yes. (Uncheck “Use Advanced Calibration Methods”)
4. Click File and select Recall State.
5. Specify a folder and a file name, and click Open.

The E5071C’s channel 1 is used for time-domain measurements by using the TDR software displayed at the bottom of the E5071C’s screen. The channel 2 is used for frequency-domain measurements by using the hard keys on the front panel and the soft keys on the right side of the screen.
5.2.2. Saving a State File
All the measurement settings including calibration information can be saved in a state file (*.tdr). After performing calibration, all necessary calibration coefficients are saved in a state file and can be recalled for the next measurements.

1. Press Save/Recall > Save Type and select State & Cal as a state file type.
2. Click File of the TDR software and select Save State.
3. Enter file name and save the state file with calibration information.
5.3. Calibration
The purpose of this step is to calibrate the RF effects such as delay, loss or mismatch of RF cables and test fixture traces before measurements. In order to remove the fixture trace effect, two calibration methods (ECal calibration & fixture compensation or deskew & loss compensation) are available for time domain and SOLT calibration is available for frequency domain with the E5071C firmware for the USB 2.0 connectors and cable assemblies compliance tests.

5.3.1. Time Domain Calibration

5.3.1.1. ECal Calibration & Fixture Compensation
Full calibration is performed by using the ECal Module (i.e. N4431B/N4433A) at the end of RF cables connected to the E5071C’s test ports. The effect of the fixture is removed by fixture compensation.

ECal calibration & fixture compensation for time-domain measurements are performed by the TDR software.

1. ECal Calibration & Fixture Compensation
   a) Press Channel Next to select Channel 1.
   b) Click Setup tab.
   c) Click ECal to launch the TDR Setup Wizard.
   d) Connect the E5071C ports (port 1 to 4) to the ECal module with RF cables.
   e) Click Calibrate to perform ECal Calibration.
   f) Click Next >.
g) Click **Options**.

h) Select Standard Type to “Short”.

i) Connect Short standard of USB 3.0 official test fixture to the E5071C port 1 with the RF cable.

j) Click **Port 1**.

k) Connect Short standard of USB 3.0 official test fixture to the E5071C port 2 with the RF cable.

l) Click **Port 2**.

m) Connect Short standard of USB 3.0 official test fixture to the E5071C port 3 with the RF cable.

n) Click **Port 3**.

o) Connect Short standard of USB 3.0 official test fixture to the E5071C port 4 with the RF cable.

p) Click **Port 4**.
5.3.1.2. Deskew & Loss Compensation
Deskew and loss compensation for time-domain measurements are performed by the TDR software.

1. Deskew and Loss Compensation
a) Press **Channel Next** to select Channel 1.
b) Click **Setup** tab.
c) Click **Deskew & Loss** to launch the TDR Setup Wizard.
d) Leave RF cables open and click **Deskew**.
e) Click **Next >**.
f) Connect 3.5 mm(f) to 3.5mm(f) adapter of 85033E or 85052D Mechanical Calibration Kit between port 1 and port 3 with RF cables.

g) Click Measure.

h) Click Next >.

i) Connect 3.5 mm(f) to 3.5mm(f) adapter of 85033E or 85052D Mechanical Calibration Kit between port 2 and port 4 with RF cables.

j) Click Measure.

k) Click Next >.
l) Connect Load standard of 85033E or 85052D Mechanical Calibration Kit to the E5071C port 1 with the RF cable.
m) Click Port 1.

n) Connect Load standard of 85033E or 85052D Mechanical Calibration Kit to the E5071C port 2 with the RF cable.
o) Click Port 2.
p) Connect Load standard of 85033E or 85052D Mechanical Calibration Kit to the E5071C port 3 with the RF cable.
q) Click Port 3.
r) Connect Load standard of 85033E or 85052D Mechanical Calibration Kit to the E5071C port 4 with the RF cable.
s) Click Port 4.
t) Click Apply.
u) Click Finish.
v) Press **Cal** > **Port Extensions** > **Auto Port Extension** > **Select Ports** to confirm that check-marks are on all the ports (if not, activate it by clicking the port).

w) Connect Short standard of USB 3.0 official test fixture to the E5071C port 1 with the RF cable.

x) Press **Cal** > **Port Extensions** > **Auto Port Extension** > **Measure SHORT** > **Port 1**

y) Connect Short standard of USB 3.0 official test fixture to the E5071C port 2 with the RF cable.

z) Press **Cal** > **Port Extensions** > **Auto Port Extension** > **Measure SHORT** > **Port 2**

aa) Connect Short standard of USB 3.0 official test fixture to the E5071C port 3 with the RF cable.

bb) Press **Cal** > **Port Extensions** > **Auto Port Extension** > **Measure SHORT** > **Port 3**

c) Connect Short standard of USB 3.0 official test fixture to the E5071C port 4 with the RF cable.

d) Press **Cal** > **Port Extensions** > **Auto Port Extension** > **Measure SHORT** > **Port 4**

5.3.2. Frequency Domain Calibration

SOLT calibration is performed to remove the RF effects (i.e. mismatch, loss or delay) of RF cables and test fixtures. The definition file of the calibration standards is imported to the E5071C, and SOLT calibration is performed with the E5071C firmware by measuring the calibration standards. The calibration is applied for frequency-domain measurements.

5.3.2.1. Selecting Cal Kit
1. Press **Channel Next** to select Channel 2
2. Press **Cal** > **Cal Kit** and select **User**.
3. Press **Cal** > **Modify Cal Kit** > **Import Cal Kit** and select the cal kit definition file (*.ckx) and click **Open**.
4. Confirm that the imported cal kit is set for the selected channel by pressing **Cal** > **Cal Kit**.

5.3.2.2. Performing SOLT Calibration
1. Reflection measurement
   a) Connect Open standard of USB 3.0 official test fixture to the E5071C port 1 with the RF cable.
   b) Press **Cal** > **Calibrate** > **4-port Cal** > **Reflection** > **Port1 Open**.
c) Connect Short standard of USB 3.0 official test fixture to the E5071C port 1 with the RF cable.
d) Press Cal > Calibrate > 4-port Cal > Reflection > Port1 Short.
e) Connect Load standard of USB 3.0 official test fixture to the E5071C port 1 with the RF cable.
f) Press Cal > Calibrate > 4-port Cal > Reflection > Port1 Load.
g) Connect Open standard of USB 3.0 official test fixture to the E5071C port 2 with the RF cable.
h) Press Cal > Calibrate > 4-port Cal > Reflection > Port2 Open.
i) Connect Short standard of USB 3.0 official test fixture to the E5071C port 2 with the RF cable.
j) Press Cal > Calibrate > 4-port Cal > Reflection > Port2 Short.
k) Connect Load standard of USB 3.0 official test fixture to the E5071C port 2 with the RF cable.
l) Press Cal > Calibrate > 4-port Cal > Reflection > Port2 Load.
m) Connect Open standard of USB 3.0 official test fixture to the E5071C port 3 with the RF cable.
n) Press Cal > Calibrate > 4-port Cal > Reflection > Port3 Open.
o) Connect Short standard of USB 3.0 official test fixture to the E5071C port 3 with the RF cable.
p) Press Cal > Calibrate > 4-port Cal > Reflection > Port3 Short.
q) Connect Load standard of USB 3.0 official test fixture to the E5071C port 3 with the RF cable.
r) Press Cal > Calibrate > 4-port Cal > Reflection > Port3 Load.
s) Connect Open standard of USB 3.0 official test fixture to the E5071C port 4 with the RF cable.
t) Press Cal > Calibrate > 4-port Cal > Reflection > Port4 Open.
u) Connect Short standard of USB 3.0 official test fixture to the E5071C port 4 with the RF cable.
v) Press Cal > Calibrate > 4-port Cal > Reflection > Port4 Short.
w) Connect Load standard of USB 3.0 official test fixture to the E5071C port 4 with the RF cable.
x) Press Cal > Calibrate > 4-port Cal > Reflection > Port4 Load.

2. Transmission measurement
   a) Connect Thru standard of USB 3.0 official test fixture to the E5071C port 1 and port 2 with the RF cable.
   b) Press Cal > Calibrate > 4-port Cal > Transmission > Port 1-2 Thru.
   c) Connect Thru standard of USB 3.0 official test fixture to the E5071C port 1 and port 3 with the RF cable.
d) Press Cal > Calibrate > 4-port Cal > Transmission > Port 1-3 Thru.
e) Connect Thru standard of USB 3.0 official test fixture to the E5071C port 3 and port 4 with the RF cable.
f) Press Cal > Calibrate > 4-port Cal > Transmission > Port 3-4 Thru.

3. Press Cal > Calibrate > 4-port Cal > Done to complete calibration. The calibration coefficients are calculated and the error correction is automatically turned on.

5.3.3. Adjustment of Effective Rise Time
After performing the calibration, the effective rise time entering the USB 3.0 connector pins is adjusted for the specification in time-domain measurements (Table 5-1). 1/2 Thru standard is connected to the E5071C port with RF cables. DUT is disconnected during the adjustment procedure.

<table>
<thead>
<tr>
<th>Trace</th>
<th>Test Items</th>
<th>Rise Time %</th>
<th>Target Rise Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tr 1 &amp; 5 &amp; 2 &amp; 6</td>
<td>Cable Impedance</td>
<td>10 – 90 %</td>
<td>200 ps</td>
</tr>
<tr>
<td>Tr 3</td>
<td>Propagation Delay</td>
<td>10 – 90 %</td>
<td>200 ps</td>
</tr>
<tr>
<td>Tr 4 &amp; 8</td>
<td>Propagation Delay Skew</td>
<td>10 – 90 %</td>
<td>200 ps</td>
</tr>
</tbody>
</table>

1. Press Channel Next to select Channel 1.
2. Press Trace Max to maximize the selected trace in the screen.
3. Open TDR/TDT tab.
4. Adjust effective rise time for each trace with the following procedure.

- Trace 4 (Trace 8) (Adjust effective rise time for Trace 4 then Trace 8)
  a) Connect 1/2 Thru standard to the E5071C port 1 (port 2) with the RF cable.
  b) Click Trace 4 (Trace 8).
  c) Click Parameter tab.
  d) Select Measure to “Time Domain” and “Single Ended”.
  e) Select Format to “Volt”.
  f) Click Marker Search and select “Rise Time” (10 – 90 %).
  g) Click T11 (T22).
  h) Press Display > Equation to turn off the equation editor.
  i) Click Run to measure the rise time on the screen.
  j) Click Auto Scale and select “X&Y”.
  k) Enter rise time until the measured rise time is close to the specified value (200 ps).
  l) Click Marker Search and select “Rise Time” (10 – 90 %) to turn off the
m) Click T31 (T42).

n) Press Display > Equation to turn on the equation editor.

- Trace 1 (Trace 5) (Adjust effective rise time for Trace 1 then Trace 5)
  a) Connect 1/2 Thru standard to the E5071C port 1 (port 3) with the RF cable.
  b) Click Trace 1 (Trace 5).
  c) Click Parameter tab.
  d) Select Measure to “Time Domain” and “Single Ended”.
  e) Select Format to “Volt”.
  f) Click Marker Search and select “Rise Time” (10 – 90 %).
  g) Click T11 (T33).
  h) Click Run to measure the rise time on the screen.
  i) Click Auto Scale and select “X&Y”.
  j) Enter rise time until the measured rise time is close to the specified value (200 ps).
  k) Click Marker Search and select “Rise Time” (10 – 90 %) to turn off the marker.
  l) Select Measure to “Time Domain” and “Differential”.
  m) Select Format to “Impedance”.
n) Click Tdd11 (Tdd22).

- Trace 2 (Trace 6) (Adjust effective rise time for Trace 2 then Trace 6)
  o) Connect 1/2 Thru standard to the E5071C port 1 (port 3) with the RF cable.
  p) Click Trace 2 (Trace 6).
  q) Click Parameter tab.
  r) Select Measure to “Time Domain” and “Single Ended”.
  s) Select Format to “Volt”.
  t) Click Marker Search and select “Rise Time” (10 – 90 %).
  u) Click T11 (T33).
  v) Click Run to measure the rise time on the screen.
  w) Click Auto Scale and select “X&Y”.
  x) Enter rise time until the measured rise time is close to the specified value (200 ps).
  y) Click Marker Search and select “Rise Time” (10 – 90 %) to turn off the marker.
  z) Select Measure to “Time Domain” and “Differential”.
  aa) Select Format to “Impedance”.
  bb) Click Tcc11 (Tcc22).

- Trace 3
  a) Connect 1/2 Thru standard to the E5071C port 1 with the RF cable.
  b) Click Trace 3.
  c) Click Parameter tab.
  d) Select Measure to “Time Domain” and “Single Ended”.
  e) Select Format to “Volt”.
  f) Click Marker Search and select “Rise Time” (10 – 90 %).
  g) Click T11.
  h) Click Run to measure the rise time on the screen.
  i) Click Auto Scale and select “X&Y”.
  j) Enter rise time until the measured rise time is close to the specified value (200 ps).
  k) Click Marker Search and select “Rise Time” (10 – 90 %) to turn off the marker.
  l) Select Measure to “Time Domain” and “Differential”.
  m) Click Tdd21.
5.4. Measurement

5.4.1. Cable Impedance (High/Full-Speed)
The cable impedance measurement insures the signal conductors have the proper impedance.
1. Connect the E5071C ports (port 1 to 4) to the test fixture ports with RF cables.

<table>
<thead>
<tr>
<th>E5071C</th>
<th>Port 1</th>
<th>Port 2</th>
<th>Port 3</th>
<th>Port 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Test Fixtures</td>
<td>TF1 D+</td>
<td>TF1 D-</td>
<td>TF2 D+</td>
<td>TF2 D-</td>
</tr>
</tbody>
</table>

Note: Unused fixture pots should be terminated with 50 ohm terminators.

2. Press Channel Next to select Channel 1.
3. Press Channel Max to maximize Channel 1 on the screen.
4. Press Trace Max to maximize the selected trace on the screen.
5. Select Trace 1 (Tdd11).
6. Click Stop Single.
7. Confirm the measured impedance is within the limit shown below.

<table>
<thead>
<tr>
<th>Impedance</th>
<th>Min</th>
<th>Max</th>
<th>Unit</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Differential impedance (Z₀)</td>
<td>76.5</td>
<td>103.5</td>
<td>Ohm</td>
<td>90 ohm +- 15%</td>
</tr>
<tr>
<td>Common-mode impedance (Z_CM)</td>
<td>21</td>
<td>39</td>
<td>Ohm</td>
<td>30 ohm +- 30%</td>
</tr>
</tbody>
</table>

8. Select Trace 5 and repeat step 6 to step 7 for the impedance measurement at the device-end of DUT (Tdd22).
9. Select Trace 2 and repeat step 6 to step 7 for the impedance measurement at the device-end of DUT (Tcc11).
10. Select Trace 6 and repeat step 6 to step 7 for the impedance measurement at the device-end of DUT (Tcc22).

5.4.2. Propagation Delay
The propagation delay measurement is to verify the end-to-end propagation of the cable.
1. Connect the E5071C ports (port 1 to 4) to the test fixture ports with RF cables.

<table>
<thead>
<tr>
<th>E5071C</th>
<th>Port 1</th>
<th>Port 2</th>
<th>Port 3</th>
<th>Port 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Test Fixtures</td>
<td>TF1 D+</td>
<td>TF1 D-</td>
<td>TF2 D+</td>
<td>TF2 D-</td>
</tr>
</tbody>
</table>

2. Press Channel Next to select Channel 1.
3. Press Channel Max to maximize Channel 1 on the screen.
4. Press Trace Max to maximize the selected trace on the screen.
5. Select Trace 3 (Tdd21).
6. Click Stop Single.
7. Read marker value of Trace 3 on the screen.
8. Confirm the measured propagation delay is within the limit shown below.

<table>
<thead>
<tr>
<th>Speed Mode</th>
<th>Limit</th>
</tr>
</thead>
</table>
Full/High-Speed | If the time at the rising edge ($T_{FSCLB}$) < 26 nsec then PASS. Otherwise Fail
---|---
Low-Speed | If the time at the rising edge ($T_{LSCLB}$) < 18 nsec then PASS. Otherwise Fail.

9. Confirm the cable delay is < 5.2 ns/m.

5.4.3. Propagation Delay Skew
The propagation delay skew measurement insures the signal on both D+ and D- lines arrive at the receiver at the same time.

1. Connect the E5071C ports (port 1 to 4) to the test fixture ports with RF cables.

| E5071C | Port 1 | Port 2 | Port 3 | Port 4 |
| Test Fixtures | TF1 D+ | TF1 D- | TF2 D+ | TF2 D- |

2. Press **Channel Next** to select Channel 1.
3. Press **Channel Max** to maximize Channel 1 on the screen.
4. Press **Trace Max** to maximize the selected trace on the screen.
5. Select Trace 4 (T31).
6. Click **Stop Single**.

7. Read Delta Time (Tr8) on the E5071C screen.
8. Confirm the measured propagation delay skew. If the skew ($T_{SKEW}$) is lower than 100 psec, then PASS. Otherwise, FAIL.
5.4.4. Signal Pair Attenuation (High/Full-Speed)
1. Connect the E5071C ports (port 1 to 4) to the test fixture ports with RF cables.

<table>
<thead>
<tr>
<th>E5071C</th>
<th>Port 1</th>
<th>Port 2</th>
<th>Port 3</th>
<th>Port 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Test Fixtures</td>
<td>TF1 D+</td>
<td>TF1 D-</td>
<td>TF2 D+</td>
<td>TF2 D-</td>
</tr>
</tbody>
</table>

2. Press Channel Next to select Channel 2 and Trace 1 (Sdd21).
3. Press Channel Max to maximize Channel 1 on the screen.
5. Confirm the measured signal pair attenuation is within the limit shown below.

<table>
<thead>
<tr>
<th>Start Frequency</th>
<th>Stop Frequency</th>
<th>Start Limit</th>
<th>Stop Limit</th>
</tr>
</thead>
<tbody>
<tr>
<td>64 kHz</td>
<td>256 kHz</td>
<td>-80 dB</td>
<td>-110 dB</td>
</tr>
<tr>
<td>256 kHz</td>
<td>512 kHz</td>
<td>-110 dB</td>
<td>-130 dB</td>
</tr>
<tr>
<td>512 kHz</td>
<td>772 kHz</td>
<td>-130 dB</td>
<td>-150 dB</td>
</tr>
<tr>
<td>772 kHz</td>
<td>1 MHz</td>
<td>-150 dB</td>
<td>-200 dB</td>
</tr>
<tr>
<td>1 MHz</td>
<td>4 MHz</td>
<td>-200 dB</td>
<td>-390 dB</td>
</tr>
<tr>
<td>4 MHz</td>
<td>8 MHz</td>
<td>-390 dB</td>
<td>-570 dB</td>
</tr>
<tr>
<td>8 MHz</td>
<td>12 MHz</td>
<td>-570 dB</td>
<td>-670 dB</td>
</tr>
<tr>
<td>12 MHz</td>
<td>24 MHz</td>
<td>-670 dB</td>
<td>-950 dB</td>
</tr>
<tr>
<td>24 MHz</td>
<td>48 MHz</td>
<td>-950 dB</td>
<td>-1.35 dB</td>
</tr>
<tr>
<td>48 MHz</td>
<td>96 MHz</td>
<td>-1.35 dB</td>
<td>-1.9 dB</td>
</tr>
<tr>
<td>96 MHz</td>
<td>200 MHz</td>
<td>-1.9 dB</td>
<td>-3.2 dB</td>
</tr>
<tr>
<td>200 MHz</td>
<td>400 MHz</td>
<td>-3.2 dB</td>
<td>-5.8 dB</td>
</tr>
</tbody>
</table>

The procedures of manual setup for time-domain and frequency-domain measurements are introduced in the section. All the following parameters are saved in the E5071C’s state file, which is available at: [www.keysight.com/find/ena-tdr_USB2-cabcon](http://www.keysight.com/find/ena-tdr_USB2-cabcon)

### 6.1. Channel & Trace Setup

If TDR setup wizard is shown when launching the TDR software, click **Close** button in the TDR setup wizard main window.

1. Open **Setup** tab in the TDR software.
2. Click **Preset** to preset the instrument. Click **OK** in a dialog box to continue.
3. Set **DUT Topology** to “Differential 2-Port”. Click **OK** in a dialog box.
4. Click **Advanced Mode>>**.

5. A dialog box appears requesting for confirmation. Then click **Yes**. (Clear the check box for “Use Advanced Calibration Methods”)

### 6.2. Stop Single

6. Click **Stop Single**.
7. Set DUT Length to “16 ns”.
8. Open **TDR/TDT** tab.
9. Click **Trace Control** tab.
10. Clear **Time** and **Marker** check box under Coupling.

11. Press **Display** > **Allocate Channels** > 📌.
12. Press **Channel Max** to maximize the screen of channel 1.

6.2. Cable Impedance (High/Full-Speed)
1. Select **Trace 1**.
2. Open **Parameters** tab.
4. Select Format to “Impedance”
5. Select **Rise Time** to 10-90% and input value (200 ps).
6. Click **Tdd11**.
7. Input vertical scale (10 Ohm/div) and vertical position (50 Ohm).

8. Open **Trace Control** tab.
9. Click **Trace Settings Copy** to launch trace copy dialog box.

10. Select the Trace 1 in the From list.
11. Select the Trace 5 in the To list.
12. Click **Copy**.
13. Click **Close**.

14. Select **Trace 5**.
15. Open **Parameter** tab.
16. Click **Tdd22**.
17. Select **Trace 2**.
18. Open **Parameters** tab.
20. Select Format to “Impedance”
21. Select **Rise Time** to 10-90% and input value (200 ps).
22. Click **Tec11**.
23. Input vertical scale (5 Ohm/div) and vertical position (0 Ohm).

24. Open **Trace Control** tab.
25. Click **Trace Settings Copy** to launch trace copy dialog box.

26. Select the Trace 2 in the From list.
27. Select the Trace 6 in the To list.
28. Click **Copy**.
29. Click **Close**.
30. Select Trace 6.
31. Open Parameter tab.
32. Click Tec22.

6.3. Propagation Delay
1. Select Trace 3.
2. Open Parameters tab.
4. Select Formant to “Volt”.
5. Select Rise Time to 10-90% and input value (200 ps).
6. Click Tdd21.
7. Input vertical scale (100 mV/div) and vertical position (200 mV).
8. Press Marker Search > Target > Target Value and enter 200 mU.
9. Press Marker Search and turn on Tracking.
6.4. Propagation Delay Skew

6.4.1. Parameter Setup
1. Select **Trace 4**.
2. Open **Parameters** tab.
4. Select Formant to “Volt”.
5. Select **Rise Time** to 10-90% and input value (200 ps).
6. Click **T31**.
7. Input vertical scale (50 mV/div) and vertical position (100 mV).
8. Open **Trace Control** tab.
9. Click **Trace Settings Copy** to launch trace copy dialog box.
10. Select Trace 4 in the From list.
11. Select Trace 8 in the To list.
12. Click **Copy**.
13. Click **Close**.
14. Select **Trace 8**.
15. Open **Parameters** tab.
16. Click **T42**.
17. Select Trace 4 (T31).
18. Click Marker Search and select Δ Time.
19. Check Δ Time.
20. Select Target (Stop) to Trace 8 and click OK.

6.4.2. Crosstalk Compensation
1. Select Trace 4.
2. Press Display > Equation Editor… > Enter an equation “ S31-S32”.
3. Check Enabled to enable the equation on trace.
4. Click Apply.
5. Click Close.
7. Press Display > Equation Editor… > Enter an equation “S42-S41”.
8. Check Enabled to enable the equation on trace.
9. Click Apply.
10. Click Close.

6.5. Common Parameters Setup for Frequency-domain Measurements
1. Press Channel Next to select Channel 2.
2. Press Sweep Setup > Points and set to “1,601”.
3. Press Sweep Setup > Sweep Type > Log Freq.
4. Press Start > Set start value to “64 kHz”.
5. Press Stop > Set stop value to “400 MHz”.
6. Press Avg > Set IF Bandwidth to “1 kHz”.
7. Press Analysis > Fixture Simulator and turn it ON.
8. Press Analysis > Fixture Simulator > Topology > Device > Bal-Bal
9. Press Analysis > Fixture Simulator > Topology > Port1 (bal) > 1-2
10. Press Analysis > BalUn ON All Traces to enable mixed-mode S-parameters (i.e. Sdd21) measurements on all traces.
11. Press Analysis > Port ZConversion > Port1 Z0 Real and set the port impedance to “45 ohm”.
12. Press Analysis > Port ZConversion > Port2 Z0 Real and set the port impedance to “45 ohm”.
13. Press Analysis > Port ZConversion > Port3 Z0 Real and set the port impedance to “45 ohm”.
14. Press Analysis > Port ZConversion > Port ZConversion and turn ON.
Note: Signal pair attenuation test requires the test frequency from 64 kHz at step 4. When using E5071C-4x5, the lower frequency is limited to either 100 kHz or 300 kHz depending on the frequency option.

6.6. Signal Pair Attenuation (High/Full-Speed)
1. Press **Meas > Sdd21**.
2. Press **Scale > Scale/Div** to 1 dB/div.
3. Press **Scale > Reference Value** to -4 dB.

6.7. Defining Limit Line Tables
1. Press **Trace Next** to select trace to set the limit line table.
2. Press **Analysis > Limit Test > Limit Line** and turn it ON to display limit lines.
3. Press **Analysis > Limit Test > Edit Limit Line** to edit the limit line table.

```
<table>
<thead>
<tr>
<th>Type</th>
<th>Begin Stimulus</th>
<th>End Stimulus</th>
<th>Begin Response</th>
<th>End Response</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0 s</td>
<td>600 ps</td>
<td>105 u</td>
<td>105 u</td>
</tr>
<tr>
<td>2</td>
<td>0 s</td>
<td>600 ps</td>
<td>75 u</td>
<td>75 u</td>
</tr>
</tbody>
</table>
```

4. Press **Analysis > Limit Test > Limit Test** and turn it ON.
5. Press **Analysis > Limit Test > Fail Sign** to switch the fail sign ON/OFF. When turned on, the Fail sign is displayed on the E5071C’s screen, if one or more failed traces are within the channel.
6. Press **System > Misc Setup > Beeper > Beep Warning** to turn ON/OFF the warning beeper.
7. [Appendix] Defining SOLT Calibration Kit

The SOLT calibration kit file is defined with the E5071C before performing the calibration. Refer to the values defined by the fixture.

1. Create a new cal kit file.
   A) Press Cal > Cal Kit and select User to setup a cal kit definition file.
   B) Press Cal > Modify Cal Kit > Label Kit (User) and enter name of new cal kit file. (i.e. USB-HS).

2. Define short standard.
   A) Press Cal > Modify Cal Kit > Define STDs > 1.No Name > Label and enter “Short”.
   B) Press Cal > Modify Cal Kit > Define STDs > 1.Short > STD Type and select Short.
   C) Press Cal > Modify Cal Kit > Define STDs > 1.Short > Offset Delay and enter the value of short standard. (i.e. 0.0000 s)
   D) Press Cal > Modify Cal Kit > Define STDs > 1.Short > Offset Z0 and enter the value of the short standard. (i.e. 50.000 ohm)
   E) Press Cal > Modify Cal Kit > Define STDs > 1.Short > Offset Loss and enter the value of the short standard. (i.e. 0.0000 ohm/s)
   F) Press Cal > Modify Cal Kit > Define STDs > 1.Short > Min. Frequency and enter the value of the short standard. (i.e. 0.0000 Hz)
   G) Press Cal > Modify Cal Kit > Define STDs > 1.Short > Max. Frequency and enter the value of the short standard. (i.e. 10.000 GHz)
   H) Press Cal > Modify Cal Kit > Define STDs > 1.Short > Media and select Coaxial.

3. Define open standard.
   A) Press Cal > Modify Cal Kit > Define STDs > 2.No Name > Label and enter “Open”.
   B) Press Cal > Modify Cal Kit > Define STDs > 2.Open > STD Type and select Open.
   C) Press Cal > Modify Cal Kit > Define STDs > 2.Open > Offset Delay and enter the value of open standard. (i.e. 0.0000 s)
   D) Press Cal > Modify Cal Kit > Define STDs > 2.Open > Offset Z0 and enter the value of the open standard. (i.e. 50.000 ohm)
   E) Press Cal > Modify Cal Kit > Define STDs > 2.Open > Offset Loss and enter the value of the open standard. (i.e. 0.0000 ohm/s)
   F) Press Cal > Modify Cal Kit > Define STDs > 2.Open > Min. Frequency and enter the value of the open standard. (i.e. 0.0000 Hz)
   G) Press Cal > Modify Cal Kit > Define STDs > 2.Open > Max. Frequency and
enter the value of the open standard. (i.e. 10.000 GHz)

H) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **2. Open** > **Media** and select **Coaxial**.

4. Define load standard.

A) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **3. No Name** > **Label** and enter “Load”.

B) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **3. Load** > **STD Type** and select **Load**.

C) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **3. Load** > **Offset Delay** and enter the value of load standard. (i.e. 0.0000 s)

D) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **3. Load** > **Offset Z0** and enter the value of the load standard. (i.e. 50.000 ohm)

E) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **3. Load** > **Offset Loss** and enter the value of the load standard. (i.e. 0.0000 ohm/s)

F) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **3. Load** > **Min. Frequency** and enter the value of the load standard. (i.e. 0.0000 Hz)

G) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **3. Load** > **Max. Frequency** and enter the value of the load standard. (i.e. 500.00 MHz)

H) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **3. Load** > **Media** and select **Coaxial**.

I) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **3. Load** > **Length Type** and select **Fixed**.

5. Define thru standard.

A) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **4. No Name** > **Label** and enter “Thru”.

B) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **4. Thru** > **STD Type** and select **Delay/Thru**.

C) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **4. Thru** > **Offset Delay** and enter the value of thru standard. (i.e. 0.0000 s)

D) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **4. Thru** > **Offset Z0** and enter the value of the thru standard. (i.e. 50.000 ohm)

E) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **4. Thru** > **Offset Loss** and enter the value of the thru standard. (i.e. 0.0000 ohm/s)

F) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **4. Thru** > **Min. Frequency** and enter the value of the thru standard. (i.e. 0.0000 Hz)

G) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **4. Thru** > **Max. Frequency** and enter the value of the thru standard. (i.e. 10.000 GHz)

H) Press **Cal** > **Modify Cal Kit** > **Define STDs** > **4. Thru** > **Media** and select **Coaxial**.

A) Press **Cal > Modify Cal Kit > Specify CLSs > Sub Class > Sub Class 1.**
B) Press **Cal > Modify Cal Kit > Specify CLSs > Open > Set All > 2.Open.**
C) Press **Cal > Modify Cal Kit > Specify CLSs > Short > Set All > 1.Short.**
D) Press **Cal > Modify Cal Kit > Specify CLSs > Load > Set All > 3.Load.**
E) Press **Cal > Modify Cal Kit > Specify CLSs > Thru > Set All > 4.Thru.**

F) Note: Line 1/2/3 are not used for USB 2.0 connectors and cable assemblies compliance tests because the SOLT calibration can be performed to 400 MHz using USB 3.0 official test fixture, which is the upper frequency for the frequency domain measurement.

7. Press **Cal > Modify Cal Kit** and select **Export Cal Kit...** to Save Cal Kit File (*.ckx).