E1963A/E6703C W-CDMA Online User's Guide

Revision 2004-12-22

What's New in the User's Guide?

  • This guide supports the E1963A W-CDMA Mobile Test Application and the E6703C W-CDMA Lab Application

Take Advantage of your W-CDMA Mobile Test and Lab Applications

Use the Contents and Search tabs to find specific information about your test and lab applications.

If you are unfamiliar with these products, or don't know where to find the information you need, click here: Getting Started with the W-CDMA Mobile Test and Lab Applications

The User's Guide is updated frequently. Check the web monthly to verify that you have the latest version of this guide:

http://www.agilent.com/find/e1963a

(choose "Manuals & Guides" under "In the Library," then download the "Help File")

© Agilent Technologies, Inc. 2004


Legal Information

Acknowledgements

Microsoft ® is a U.S. registered trademark of Microsoft Corporation

Windows ® and MS Windows ® are U.S. registered trademarks of Microsoft Corporation.

Adobe ® Acrobat ® are trademarks of Adobe Systems Incorporated.

Notice

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as "Commercial computer software" as defined in DFAR 252.227-7014 (June 1995), or as a "commercial item" as defined in FAR 2.101(a) or as "Restricted computer software" as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

© Agilent Technologies, Inc. 2001


Protocol Logging

Protocol Logging

Last updated: December 21, 2004

This section is only applicable to the lab application.

Getting Started with Protocol Logging

You can use the test set to capture the exchange of control and data information between the test set and a UE (user equipment). Captured information is forwarded to a software application that runs on a personal computer under the Windows operating system.

The software application is referred to as the WPA, or "Wireless Protocol Advisor." It is tailored for the capture, display, and analysis of message exchange protocols between the test set (emulating a base station), and a UE.

IMPORTANT
Most of the information necessary to establish a connection and to display, filter, store, print, and analyze the message exchange between the test set and a UE is accessible through the Help feature available on-line when the WPA application is running.

This on-line help is also available for download at:

http://www.agilent.com/find/e6584a/

Additional information, including PC operating system requirements and additional protocol logging reference information is listed below.

PC Operating System Requirements

Logging protocol messages requires an external PC with the following system requirements:

  • Protocol Logging Requirements

Starting and Stopping Protocol Logging

There are several ways to control the logging of signaling messages.

The primary method for starting and stopping is through features found in the WPA software.

The following information describes features available through the test set's remote and manual user interface for performing these functions:

  • Activating Protocol Logging From the Test Set


Data Channel

Data Channel

This section is only applicable to the lab application.

Getting Started with the Data Channel

The data channel feature allows you to use the test set as an IP router, exchanging data between a wireless device and remote servers.

There are several applications of the Data Channel. See Data Channel Applications .

There are two data channel services supported by the WCDMA Lab Applications:

  • GPRS Packet Data Service
    • GPRS Packet Data Service Example Procedure
    • GPRS Packet Data Service Ladder Diagrams
    • Activate PDP Context Reject
  • CS (Circuit Switched) Data Service

Ping is provided as a Data Channel troubleshooting tool.

Data Channel Requirements

IP Address Requirements


Measurements

Measurements

Getting Started with Measurements

  • What 3GPP W-CDMA Conformance Tests Are Supported?

Measurement Descriptions

  • Adjacent Channel Leakage Ratio Measurement Description
  • Audio Analyzer Measurement Description
    • Audio Analyzer Block Diagram
    • Audio Frequency Measurement Description
    • Audio Level Measurement Description
    • Distortion Measurement Description
    • SINAD Measurement Description
  • Block Error Ratio Measurement Description
  • Change of TFC (Transport Format Combination) Measurement Description (Lab Application only)
  • Channel Power Measurement Description
  • Code Domain Measurement Description
  • Data Throughput Monitor Description (Lab Application only)
  • Dynamic Power Analysis Measurement Description
  • Frequency Stability Measurement Description
  • Inner Loop Power Measurement Description
  • IQ Tuning Measurement Description
  • Loopback Bit Error Ratio Measurement Description
  • Occupied Bandwidth Measurement Description
  • Out-of-Synch Handling of Output Power Measurement Description (Lab Application only)
  • Phase Discontinuity Measurement Description
  • PRACH Preamble Analysis Measurement Description (Lab Application only)
  • PRACH Transmit On/Off Power Measurement Description
  • Spectrum Emission Mask Measurement Description
  • Spectrum Monitor Description
  • Swept Audio Measurement Description
  • Thermal Power Measurement Description
  • Waveform Quality Measurement Description

Measurement Calibration

  • Calibrating the Test Set

Amplitude Offset

  • Amplitude Offset


Call Processing

Call Processing

Last updated: December 20, 2004

Getting Started with Call Processing

W-CDMA Concepts

  • W-CDMA Concepts
  • Downlink and Uplink Channels Overview
  • Base Station Originated Call Setup Flowchart

Operating Modes

  • Active Cell Operating Mode
  • FDD Test Operating Mode
  • CW Operating Mode
  • Cell Off Operating Mode

Base Station Emulator Configuration

Cell Configuration

  • Cell Parameters (BCCH Update Page, PS Domain Information, MCC, MNC, LAC, RAC, Cell Identity, ATT (IMSI Attach) Flag State, etc.)
  • Uplink Parameters (PRACH Power Ramp Step, PRACH Signatures, PRACH Scrambling Codeword, PRACH Bc/Bd Control, etc.)
  • Security Setup
  • SIB11 Cell Info List (SIB 11 Intra-freq, Inter-freq and GSM Cell Info Lists)

Channel Configuration

  • Cell Power and AWGN Power
  • Uplink Channel (UARFCN)
  • Downlink Channel (UARFCN)
  • Downlink Channel Codes and Levels
  • Radio Bearer Test Mode Setup (RB Test Mode RRC State Setting, Uplink DTCH RMC CRC Presence, Uplink Dummy DCCH Data, MS Loopback Type)

Call Configuration

  • Channel Type and Paging Service
  • Paging IMSI
  • Other Downlink Parameters (DL DTCH Data, DL PICH Data, RLC Reestablish, Call Limit State, and Call Drop Timer)
  • Signalling Radio Bearer (SRB) Configuration
  • Uplink Closed Loop Power Control Parameters and UE Target Power
  • Calling Party Number Parameters (Lab Application only)

Call Processing Status and Operations

  • Call Processing Status
  • Performing a Location Update (Registration)
  • Broadcast Channel (BCCH) Update Procedure
  • Establishing a Connection with the UE
    • Call Processing Ladder Diagrams (RRC Connection Setup, Location Update, Paging, Radio Bearer Setup, BS Release from RB Test Mode)
  • Handoffs
    • Handoffs (Handover) (Physical Channel Reconfig, Transport Channel Reconfig, System Handoff)
      • Handoff Ladder Diagrams
    • Soft Handoff (Lab Application only)
  • Compressed Mode (Lab Application only)
    • Compressed Mode Ladder Diagrams
  • Video Call (Lab Application only)
    • Video Call Ladder Diagrams
  • Short Message Service (SMS) (Lab Application only)

UE Information

  • UE Information
  • UE Expected Open Loop Transmit Power
  • UE Reported Measurements

Other

  • Trigger Output Setup
  • Digital Bus Information (Lab Application with rear panel digital bus only)


Programming

Programming

Getting Started with Programming

  • Programming: Getting Started Guide for W-CDMA Mobile Test
  • Control Program Example

Programming Examples for Individual Measurements

  • Programming an Audio Frequency Measurement
  • Programming an Audio Level Measurement
  • Programming a Distortion Measurement
  • Programming a SINAD Measurement
  • Programming an Adjacent Channel Leakage Ratio Measurement
  • Programming a Block Error Ratio Measurement
  • Programming a Change of TFC (Transport Format Combination) Measurement (Lab Application only)
  • Programming a Channel Power Measurement
  • Programming a Code Domain Measurement
  • Programming the Dynamic Power Analysis Measurement
  • Programming a Frequency Stability Measurement
  • Programming an Inner Loop Power Measurement
  • Programming an IQ Tuning Measurement
  • Programming a Loopback Bit Error Ratio Measurement
  • Programming an Occupied Bandwidth Measurement
  • Programming the Phase Discontinuity Measurement
  • Programming the PRACH Preamble Analysis Measurement (Lab Application only)
  • Programming a PRACH Transmit On/Off Power Measurement
  • Programming a Spectrum Emission Mask Measurement
  • Programming the Spectrum Monitor
  • Programming a Swept Audio Measurement
  • Programming a Thermal Power Measurement
  • Programming a Waveform Quality Measurement

General Programming

  • Preset Descriptions
  • Receiver Control
  • Status Subsystem Overview
  • Obtaining Measurement Results
  • Test System Synchronization
  • UI Log


GPIB Commands

GPIB Commands

GPIB Diagram Conventions

  • Diagram Conventions to understand how GPIB commands are represented in the diagrams.

Call Processing

  • CALL Subsystem to control the mobile and set up and control the cell.

Measurement Control

  • ABORt Subsystem to stop a measurement.
  • CALCulate Subsystem to perform data processing on measurement results.
  • FETCh? Subsystem or READ? Subsystem to get measurement results.
  • INITiate Subsystem or READ? Subsystem to start a measurement.
  • SETup Subsystem to configure a measurement.
  • STATus Subsystem Description to communicate test set status.

IEEE 488.2 Common Commands

  • IEEE 488.2 Common Commands

Test Set Configuration

  • AFGenerator Subsystem
  • RFANalyzer Subsystem (not controlled as an instrument)
  • RFGenerator Subsystem (not controlled as an instrument)
  • CALibration Subsystem
  • DISPlay Subsystem
  • SYSTem Subsystem
  • Help Mode


Manual Operation

Manual Operation

Getting Started with Manual Operation

Call Processing Configuration

  • How Do I Change Cell Parameters?
  • How Do I Change Call Parameters?
  • How Do I Configure the Radio Bearer Test Mode?
  • How Do I Configure the AMR Voice Radio Access Bearer? (Lab Application only)
  • How Do I Change Generator Information?
  • How Do I Change Uplink Parameters?
  • How Do I Change UE TX Power Levels
  • How do I Change Security Setup Parameters
  • How Do I Change the SIB11 Cell Info List?
  • How Do I Perform Calling Party Number Verification? (Lab Application only)

Call Processing Operations

  • How Do I Set Up a Call and Make a Connection?
  • End a Connection
  • How Do I Order and Retrieve UE Reported Measurement Results?
  • How Do I Perform a Handoff (Handover)?
  • Soft Handoff (Lab Application only):
    • How Do I Configure Cell 2? (Lab Application only)
    • How Do I Perform a Soft Handoff? (Lab Application only)
    • How Do I Configure and Enable (Start) Event Reporting? (Lab Application only)
  • How Do I Enable Compressed Mode and Obtain UE Measurement Results? (Lab Application only)
  • How Do I Make a Video Call? (Lab Application only)
  • Short Message Service (Lab Application only):
    • How to use the Short Message Service Features
    • Enabling the HTTP Interface

Making Measurements

  • How Do I Make Measurements on a UE?
  • How Do I Change the Measurement Setup?
  • How Do I Turn Off a Measurement?
  • Performing Individual Measurements Manually (Adjacent Channel Leakage Ratio, Channel Power, Code Domain, Occupied Bandwidth, Spectrum Emission Mask, Thermal Power, Waveform Quality)
    • How Do I Make a Change of TFC (Transport Format Combination) Measurement? (Lab Application only)
    • How Do I Make a Dynamic Power Analysis Measurement?
    • How Do I Make an Inner Loop Power Measurement?
    • How Do I Make an IQ Tuning Measurement?
    • How Do I Perform a Loopback BER Measurement?
    • How Do I Perform a Block Error Ratio (BLER) Measurement?
    • How Do I Make an Out-of-Synch Handling of Output Power Measurement? (Lab Application only)
    • How Do I Make a Phase Discontinuity Measurement?
    • How Do I Make a PRACH Preamble Analysis Measurement? (Lab Application only)
    • How Do I Make a PRACH Transmit On/Off Power Measurement?
  • How Do I Use the Spectrum Monitor?
  • How Do I Use the Data Throughput Monitor? (Lab Application only)

Data Channel (Lab Application only)

  • How Do I Configure the Data Channel? (Lab Application only)
  • GPRS Packet Data Service Example Procedure (Lab Application only)
  • How Do I Ping a Device From the Test Set? (Lab Application only)

Test Set Configuration

  • How Do I Configure the Test Set for My Test System? (GPIB address, amplitude offsets, etc.)
  • How Do I Configure the AUDIO OUT Port?
  • How Do I Configure Test Signals in CW Operating Mode?
  • How Do I Make an External Device Connection? (Lab Application only)

General Manual Operation

  • How Do I Change Receiver Control Parameters?
  • Help Mode
  • Front Panel Connectors
  • Rear Panel Connectors
  • Remote/Local Mode
  • Printing Screens
  • Save and Recall Registers
  • Instrument Status Area
  • Preset Descriptions


Troubleshooting

Troubleshooting

Some features may be inaccessible or may not perform to specifications without a hardware upgrade to your test set or a proper license. For more details, please see:

http://www.agilent.com/find/8960upgrades

Contact Information

  • Contact Us

Measurement Troubleshooting

  • AFANalyzer Troubleshooting
  • Adjacent Channel Leakage Ratio Troubleshooting
  • Change of TFC (Transport Format Combination) Troubleshooting (Lab Application only)
  • Channel Power Troubleshooting
  • Code Domain Troubleshooting
  • Dynamic Power Analysis Troubleshooting
  • Frequency Stability Troubleshooting
  • Inner Loop Power Troubleshooting
  • IQ Tuning Measurement Troubleshooting
  • Loopback Bit Error Ratio Troubleshooting
  • Block Error Ratio Troubleshooting
  • Occupied Bandwidth Troubleshooting
  • Out-of-Synch Handling of Output Power Troubleshooting (Lab Application only)
  • Phase Discontinuity Troubleshooting
  • PRACH Preamble Analysis Troubleshooting (Lab Application only)
  • PRACH Transmit On/Off Power Troubleshooting
  • Spectrum Emission Mask Troubleshooting
  • Spectrum Monitor Troubleshooting
  • Swept Audio Measurement Troubleshooting
  • Thermal Power Troubleshooting
  • Waveform Quality Troubleshooting

Call Processing Troubleshooting

  • Troubleshooting UE Reported Measurements
  • Troubleshooting Call Processing Operations
  • Troubleshooting Handoffs (Handovers)
  • Troubleshooting Soft Handoff (Lab Application only)
  • Troubleshooting Compressed Mode Operation (Lab Application only)
  • Troubleshooting Video Call (Lab Application only)

Data Channel Troubleshooting (Lap Application only)

  • Data Channel Troubleshooting (Lab Application only)

Troubleshooting Other Operations

  • Troubleshooting External Device Connection (Lab Application only)
  • Test Set Lockup Due to Hardware Incompatibility

Error Messages

  • Error Messages
  • Error Message Log

GPIB Command Debug and Troubleshooting

  • SYSTem:COMMunicate:GPIB:DEBug[:STATe]
  • UI Log

Test Set Block Diagram

  • Block Diagram

Known Issues

  • 8960 Known Issues


Configuration

Configuration

Last updated: December 20, 2004

Configuration Information

  • Obtaining Identification Information (*IDN)
  • Hardware Configuration Report

Configuring the Test Set

  • Amplitude Offset
  • Configuring the Test Set's AUDIO OUT port
  • External Device Connection (Lab Application only)
  • Timebase Description/Configuration

Instrument Setup

  • Configuring the Test Set's GPIB
  • Configuring the Test Set's LAN
  • Display Mode (Track/Fast)
  • Adjusting the Brightness of the Test Set's Display
  • Test Set Beeper
  • Configuring System Time and Date

Selecting an Application

  • Application Switching


Release Notes

Release Notes

Features and Functionality

  • E1963A W-CDMA Test Application Revision Information
  • E6703C W-CDMA Lab Application Revision Information

GPIB Commands

  • E1963A and E6703B W-CDMA Applications: GPIB Command Revision Information


Getting Started with Call Processing

Getting Started with Call Processing

Last updated: December 20, 2004

While in operating modes other than CW (see Operating Modes ), the test set includes a base station emulator which allows you to establish a connection between the test set and your wireless device. The base station emulator can be configured by changing various parameters. You can then perform many call processing operations and measurements.

To learn more about the parameters available for configuring the base station emulator, see Base Station Emulator Configuration .

To learn more about the call processing operations you can perform using the test set, see Call Processing Status and Operations .

For general technology information to help you become more familiar with the W-CDMA system, see W-CDMA Concepts .

TO RETURN TO THE MAIN CALL PROCESSING PAGE, click here: Call Processing .


Configuring the Test Set's AUDIO OUT port

Configuring the Test Set's AUDIO OUT port

Last updated: December 20, 2004

Description

The AUDIO OUT connector on the test set's front panel can be configured to carry one of two signals:

  • Audio Generator
  • FM Demod

By default, the AUDIO OUT connector is configured to carry the output from the built in audio generator. This signal is typically used to stimulate a system to measure its audio performance. When the audio generator's signal is selected for output at the front panel AUDIO OUT connector, use the AFGenerator commands to control the signal.

When testing AMPS systems, it may be useful to configure the AUDIO OUT connector to carry the analog FM Demod signal. This provides the demodulated FM signal for external analysis and baseband processing. Fixed bandwidth bandpass, expandor, and de-emphasis filters can be selected to control the FM Demod signal. When the FM Demod signal is selected for output at the front panel AUDIO OUT connector, use the SYSTem:AUDio:OUTPut commands to control the signal.

For front panel operation, to select the signal source for output to the AUDIO OUT connector, press System Config hardkey, then select Audio Out Port ( F1 ) on the System Config Screen (2 of 2).

Programmatically, to select the signal source for output to the AUDIO OUT connector, use the SYSTem:AUDio:OUTPut:SOURce commands.

Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:SOURce AFGenerator" !Selects Audio Generator signal for output
                                                    !at the front panel AUDIO OUT port.

NOTE
Refer to the Technical Specifications in the Application Datasheet for specifications of the AUDIO OUT connector. There will be no guaranteed performance for the signal present at the AUDIO OUT connector when FM Demod signal is selected for output.

Related Topics

How Do I Configure the AUDIO OUT Port?


Test Set Beeper

Test Set Beeper

Last updated: December 20, 2004

Description

This parameter allows you to change the beeper state to on or off. A beep will indicate error conditions caused during manual or remote operation of the test set.

A 100 ms, 1.24 kHz audible tone (beep) is generated when an error message is logged and the beeper state is set to on. If two errors are generated in quick succession, two beeps are generated to indicate that more than one error has been logged.

The beeper state can be manually set in the Instrument Setup window found in the SYSTEM CONFIG screen.

Example

OUTPUT 714;"SYSTEM:BEEPER:STATE OFF"

Related Topics

SYSTem:BEEPer


Adjusting the Brightness of the Test Set's Display

Adjusting the Brightness of the Test Set's Display

Last updated: December 20, 2004

Description

This parameter allows you to adjust the brightness of the test set's display. The test set's display screen has two brightness settings:

  • medium brightness
  • high brightness

Example

OUTPUT 714;"DISPLAY:BRIGHTNESS MEDIUM" ! sets screen brightness to medium.

Related Topics

DISPlay


Display Mode (Track/Fast)

Display Mode (Track/Fast)

Last updated: December 20, 2004

Description

There are two display modes to select from when operating the test set remotely.

  • Display mode fast
  • Display mode track

Fast Mode

When operating remotely, there is often no need for the display to be updated as measurements are made. Using the fast display mode will increase the speed of the test set when it is operated remotely.

Fast mode is designed for remote use only. The test set returns to track mode if you change to manual operation.

  • No screen or menu items are visible (except error messages).
  • Error messages will be displayed in their normal location.
  • "This instrument is being operated remotely" will be displayed at the bottom of the screen.

Example

OUTPUT 714;"DISPLAY:MODE FAST" !Selects fast mode

Track Mode

The track display mode is used to allow users to see what the test set is doing while it is being controlled remotely. Track mode is the default mode of the test set.

  • Any changes made remotely will be updated on the screen if that screen is displayed.
  • The error message window will be displayed as required when an error occurs.

Example

OUTPUT 714;"DISPLAY:MODE TRACK"!Selects track mode

Writing Messages to the Display

The capability to write up to four 30-character lines of text to the front panel display for operator messages is available when the display is in Fast Mode . This feature can be used to control the flow of software running on an external controller by pressing softkeys on the test set's front panel.

For example, by displaying a message that prompts the operator to press a front panel softkey and then monitoring that softkey through status register bits, the programmer can design code that starts measurements, stops measurements, or branches to a selected routine or function without the need for access to the external computer's keyboard.

The GPIB commands for writing messages to the display are found in the DISPlay:OPERator:MESSage table.

The status bit register GPIB commands and bit definitions for monitoring the test set's softkeys are found in the STATus:OPERation:KEYPressed Register Bit Assignments table.

Related Topics

DISPlay


External Device Connection

External Device Connection

This section is only applicable to the lab application and to a test application with the required feature license.

Description

You can connect your 8960 to an external device (such as another 8960) over an IP network. Once you've established this connection, you can test supported end-to-end services between two wireless devices (such as W-CDMA end-to-end video calls when you've connected two 8960s).

You can establish an External Device Connection while your 8960 is in any operating mode. However, most end-to-end services utilizing the External Device Connection feature require active cell mode operation.

When connecting two 8960s, it is recommended that you connect them via a hub, rather than through a gateway or WAN link, or connect them directly using a LAN crossover cable. This helps minimize the risk of lost data due to delayed packets.

External Device Connection Setup for Two 8960s

External 8960 Connection Setup

  • External 8960 IP Address

    Before establishing a connection with another 8960, you must first specify its IP address.

    Ext 8960 IP Addr can not be set to the same value as LAN IP Address or DUT IP Address . If LAN IP Address is set to the value of Ext 8960 IP Addr , Ext 8960 IP Addr is reset to a blank field.

    GPIB command: SYSTem:COMMunicate:LAN:EXTernal:ADDRess

  • Connect to External 8960

    This action establishes a TCP/IP connection with the 8960 at the address specified by External 8960 IP Address .

    If the External Device Connection Status is Connected , then this action is ignored by the test set.

    GPIB command: SYSTem:COMMunicate:LAN:EXTernal:CONNect

  • Disconnect from External 8960

    This action disconnects the TCP/IP connection with the connected external 8960.

    If the External Device Connection Status is Disconnected , then this action is ignored by the test set.

    GPIB command: SYSTem:COMMunicate:LAN:EXTernal:DCONnect

  • External Device Connection Status

    The External Device Connection Status is displayed in the LAN Connection Information window of both 8960 tests sets, regardless of which 8960 initiated the connection. The possible states of the external device connection are: Not Connected , Connecting , Connected and Disconnecting .

    GPIB command: SYSTem:STATus:COMMunicate:LAN:EXTernal[:STATe]

  • Connected Device IP Address

    Once a connection has been established between the two 8960s, the IP address of each 8960 is displayed in the other 8960's LAN Connection Information window.

    GPIB command: SYSTem:STATus:COMMunicate:LAN:EXTernal:CONNected:ADDRess

  • LAN (Self) IP Address

    For your convenience, the IP address of the 8960 is shown in its LAN Connection Information window. This is a duplicate display of its LAN IP Address setting, which you set from the Instrument Setup ( F1 ) menu on its System Config screen, or using the SYSTem:COMMunicate:LAN[:SELF]:ADDRess command.

Other Considerations

The external device connection is not affected by a partial preset. However, the external device connection is disconnected as a result of a full preset.

Before initiating an external device connection between two 8960s, you can verify that the two test sets are able to communicate by pinging one test set from the other. To do so, on 8960 #1:

  • Press the Call Setup key, then the left More key until the Ping menu is available.
  • Select Ping , then Ping Setup ( F1 ).
  • Set Device to Ping to Alternate ( CALL:DATA:PING:SETup:DEVice ).
  • Set the Alternate Ping Address to the IP address of 8960 #2 ( CALL:DATA:PING:SETup:ALTernate:IP:ADDRess ).
  • Select Start Ping ( F3 ) ( CALL:DATA:PING:STARt ).

Related Topics

Manual Operation: How Do I Make an External Device Connection?

SYSTem:COMMunicate

SYSTem:STATus

Troubleshooting External Device Connection

Video Call

Configuring the Test Set's LAN


Configuring the Test Set's GPIB

Configuring the Test Set's GPIB

Last updated: December 20, 2004

Description

The GPIB address is an integer between 0 and 30. The test set comes with a default address of 14 and may be set/queried using the SYSTem subsystem or manually through the system configuration screen by selecting the parameter and changing the number with the knob or the keypad.

The GPIB address is a non-volatile parameter. The GPIB address is not affected by any reset operation and can only be changed by direct access to the parameter itself.

Related Topics

SYSTem:COMMunicate


Hardware Configuration Report

Hardware Configuration Report

Last updated: December 20, 2004

Description

You can generate a list of the test set's hardware configuration over the LAN or GPIB.

The LAN query is the easiest and most direct way to query the test set's hardware configuration. This method uses your web browser to display a formatted report.

The GPIB query returns an unformatted character string that must be buffered and saved to an HTML file to provide formatted text.

LAN Query

  1. Refer to the SYSTEM CONFIG screen to determine the LAN address.
  2. Open a web browser and enter <LAN address>/iconfig. For example, if your LAN address is 130.2.2.147, you would enter:

    130.2.2.147/iconfig

  3. The web browser will then display formatted text. A partial list of the hardware configuration information is shown below:

GPIB Query

Use the following Basic example as a model to store the test set's configuration as an HTML file.

GPIB Example:

10    DIM Buf1$[20000],Buf2$[20000] ! This is the minimum space for the arrays
20    OUTPUT 714;"SYSTEM:CONFIGURE:INFORMATION:HARDWARE:VERBOSE?"
30    ENTER 714;Buf1$,Buf2$
40    CREATE "HW.htm",1              ! Create an HTML file
50    ASSIGN @File TO "HW.htm"
60    OUTPUT @File;Buf1$,Buf2$
70    END

In the future, the hardware configuration report may increase in length. More space would then need to be allocated for the arrays.

Display the HTML file using a web browser or HTML text editor.

Related Topics

SYSTem:CONFigure


Obtaining Identification Information (*IDN)

Obtaining Identification Information (*IDN)

Last updated: December 20, 2004

Description

Test set information is returned from a *IDN? query. The *IDN? query provides information about the Manufacturer, Model Number, Serial Number, and Firmware Revision. *IDN? is defined in IEEE Std. 488.2-1992, 10.14.

Test Set Information

*IDN? query returns identification information as a comma separated string.

DIM A$[100]
OUTPUT 714;"*IDN?" !returns manufacturer,model number, serial number and "0"
                   !separated by commas
ENTER 714;A$
PRINT A$           !prints, for example "Agilent Technologies, 8960 Series 10 E5515B,
                   !US38020105,0
  • Agilent Technologies is the manufacturer.
  • Printable ASCII characters excluding comma and semicolon up to a 25-character string.
    Model number example: 8960 Series 10 E5515B
  • Printable ASCII characters excluding comma and semicolon up to a 10-character string.
    Serial number example: US00000123
  • Printable ASCII characters excluding comma and semicolon up to a 20-character string.
    Firmware revision example: 0

NOTE
The *IDN? query will always indicate that the firmware revision is zero. SYSTem:APPLication[:CURRent]:REVision? is the recommended way to query the firmware revision.

Related Topics

Hardware Configuration Report


Configuring the Test Set's LAN

Configuring the Test Set's LAN

Last updated: December 20, 2004

Description

LAN IP Address

CAUTION
Always verify that the test set is responding to a new LAN IP Address by pinging the test set. If the test set does not respond to the ping, cycle power. This will ensure that the test set will respond to the new LAN IP Address.

The LAN address is a character string with a maximum of 15 characters and a format of A.B.C. D where A is between 0 and 223 (excluding 127, which is assigned for use as the Internet host loopback address), and B, C, and D are between 0 and 255. No embedded spaces are allowed. The address may be manually set/viewed in the system configuration screen. The LAN address can be set/queried using the SYSTem subsystem.

The LAN address is a non-volatile parameter. The LAN address is not affected by any reset operation and can only be changed by direct access to the parameter itself.

NOTE
If the LAN address is set to a different network class, the subnet mask will change to the default net mask for the new network class.

For convenience the DATA port on the front panel may be configured as a LAN port. When an RJ45 jumper cable, (part number E5515-61160) is connected from the LAN PORT on the rear panel, to the ETHERNET TO FRONT PANEL port also on the rear panel, the user has LAN access from the front panel of the test set. Without the RJ45 jumper cable, the test set connection to a LAN is the rear-panel, LAN PORT connector.

LAN Default Gateway

The LAN router, (default gateway), is a character string with a maximum of 15 characters and a format of A, B, C, D, where A is between 0 and 223 , and B, C, and D are between 0 and 255, no embedded spaces are allowed. If the default gateway is set to a format not allowed with the LAN address or the subnet mask that have been selected, the default gateway will be set to a null string, indicated by a blank field on the test set display. The address may be manually set/viewed in the system configuration screen. The LAN default gateway can be set/queried using the SYSTem subsystem.

The LAN default gateway is the address of a router that routes messages between networks and or subnets. If this value is not specified, LAN communications will be limited to the network and subnet specified by the LAN IP address and the subnet mask. Your network administrator will know if a default gateway is needed and if so, the address of the router. If the default gateway address is not needed by your network, it may be disabled by entering any of the following values: "0" (zero), "" (null string), "0.0.0.0"

The LAN default gateway is a non-volatile parameter. The LAN default gateway is not affected by any reset operation and can only be changed by direct access to the parameter itself.

LAN Subnet Mask

The LAN subnet mask address is a character string with a maximum of 15 characters and a format of A, B, C, D, where A , B, C, and D are between 0 and 255. No embedded spaces are allowed. The address may be manually set/viewed in the system configuration screen. The LAN subnet mask address can be set/queried using the SYSTem subsystem.

The subnet mask number combined with the IP address identifies which network and subnet your computer is on. Contact your system administrator for the correct subnet mask for your network.

The subnet mask determines the boundaries between the subnet ID and the host ID.

The LAN subnet mask is a non-volatile parameter. The LAN subnet mask is not affected by any reset operation and can only be changed by direct access to the parameter itself or by changes to the LAN IP Address.

NOTE
If the LAN address is set to a different network class, the subnet mask will change to the default net mask for the new network class.

The subnet mask number is obtained from your network administrator.

Related Topics

SYSTem:COMMunicate


Amplitude Offset

Amplitude Offset

Last updated: December 20, 2004

Description

Amplitude offsets compensate for loss or gain between the test set's RF IN/OUT front panel connector and the mobile station's RF connector.

To access the amplitude offset feature, press the SYSTEM CONFIG key, followed by the RF IN/OUT Amptd Offset ( F5 ) key.

Amplitude offset settings are preserved during power cycles or instrument preset.

Setting Up Amplitude Offsets and Frequency Points

Up to 20 frequency points can be assigned an amplitude offset. Negative amplitude offset values should be entered when there is a loss through the RF cabling and test fixtures and positive values should be entered when there is a gain.

The RF IN/OUT Amplitude Offset table displays the current (on/off) state of the amplitude offset feature. There are also 20 rows for entering frequencies and 20 rows for entering corresponding offset values. To enter values in the table use the RF IN/OUT Amplitude Offset Setup menu.

To set up amplitude offsets remotely, one comma-separated string is sent to set up frequency points and another comma-separated string assigns the corresponding amplitudes.

GPIB Commands

OUTPUT 714;"SYSTEM:CORRECTION:SFREQUENCY 1710.2 MHZ,1805.2 MHZ,1784.8 MHZ,1879.8 MHZ"
!sets the first 4 frequencies in the amplitude offset table.

OUTPUT 714;"SYSTEM:CORRECTION:SGAIN -2.55,-3.12,-3.68,-4.23"
!sets the first 4 amplitude offsets in the amplitude offset table.

Turning amplitude offsets on/off

When the RF IN/OUT Amplitude Offset State is on, all offsets that are not individually turned off are applied and the word "Offset" appears in the Instrument Status Area of the test set's display.

If the RF IN/OUT Amplitude Offset State is off, none of the amplitude offsets are applied.

GPIB Command

OUTPUT 714;"SYSTEM:CORRECTION:STATE ON"
!Sets the RF IN/OUT Amplitude Offset State to On

NOTE
If the RF IN/OUT Amplitude Offset State is turned off , none of the amplitude offsets are on, even if values are entered for the individual offsets.

Examples of Amplitude Offset Behavior

When the amplitude offset table entries accurately represent the loss in all components (cabling, connectors, and test fixturing) in the signal path between the test set and the mobile station, the test set will make the necessary adjustments in both receiver and transmitter measurements.

Mobile Station Receiver Example

When you set a transmit power level, the test set uses the amplitude offset value to adjust the power so that the test set's transmit power level refers to the power level received at the mobile station.

As shown in Amplitude Offset Mobile Station Receiver Example , with the test set's transmit power set to -85 dBm and a -3 dB amplitude offset the actual power level transmitted from the test set will be automatically offset to -82 dBm. With a 3 dB loss in the signal path the mobile station will receive -85 dBm, the actual setting.

Amplitude Offset Mobile Station Receiver Example

Mobile Station Transmitter Example

When you measure power from the mobile station, the displayed and queried values are offset to show the level at the mobile station.

As shown in Amplitude Offset Mobile Station Transmitter Example , with the mobile station transmitting 12 dBm and a -3 dB amplitude offset is entered, the measured power at the test set would be 9 dBm. The displayed power level is automatically adjusted to 12 dBm to show the level at the mobile station.

If the expected power, which can be set manually or automatically is 12 dBm, the test set's internal hardware adjusts itself to receive 9 dBm which is the actual power from the mobile station after 3 dB loss in the network.

Amplitude Offset Mobile Station Transmitter Example

Amplitude Offsets Between Frequency Settings

If mobile station testing is performed at frequencies that do not have amplitude offsets assigned to them, the test set will estimate an amplitude offset based on the nearest settings. For example, the following screen shows five amplitude offsets for frequencies ranging from 890.2 MHz to 1710.2 MHz.

RF IN/OUT Amplitude Offset Setup

For test frequencies between the lowest (890.2 MHz) and highest (1710.2 MHz) frequency points that are not entered in the table, the test set will calculate offsets using piece-wise linear interpolation.

The graph shown in Amplitude Offset Interpolation is a conceptual representation of the test set's amplitude offset configuration using the settings from the RF IN/OUT Amplitude Offset table in RF IN/OUT Amplitude Offset Setup . Each of the five points are shown on a non-scaled frequency versus amplitude offset graph. At a test frequency of 890.4 MHz, which is midway between point number one (-1 dB) and point number two (-2 dB) the test set applies an offset of -1.5 dB. Be aware that since amplitude offsets are in units of dB, this piece-wise linear interpolation does not produce a linear transition from point to point.

Amplitude Offset Interpolation

If testing is done outside the range of frequencies bounded by the lowest and highest frequency entries, the test set simply uses the amplitude offset that is paired with the nearest frequency point.

IMPORTANT
It is highly recommended that amplitude offsets are set up for each test frequency. This eliminates inaccuracies due to the mismatch between the test set's linear interpolation and the actual frequency response of the RF path between the test set and mobile station.

Related Topics

SYSTem:CORRection


Application Name

Application Name

Last updated: December 20, 2004

Description

The following queries give you details about the application name. To query or switch applications you must use the application's name as it appears in the catalog (without regard to case).

  • To query the name of the all applications installed in the test set use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME?"

  • To query the name of the selected application (running or not) use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME?"
  • To query the name of the currently running application use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:CURRENT:NAME?"

  • To query the number of applications installed in the test set use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME:COUNT?"

The application names can also be displayed in the Application Setup menu on the test set's display.

Related Topics

SYSTem:APPLication


Application Revisions and Licenses

Application Revisions and Licenses

Last updated: December 20, 2004

Description

Different revisions of the applications in your test set provide different capabilities. The selected application revision is loaded after the next application switch or power cycle of the test set. Once you select a revision the revision does not change unless you select another revision.

You can query the selected revision, all available revisions, and the total count of available revisions for a selected application. These queries are helpful when selecting revisions but are not usually necessary when switching applications.

NOTE
The Agilent E1960A GSM Mobile Test Application revisions prior to A.04.00 do not support application switching. If you select a revision prior to A.04.00 you will not have a path to switch back to later revisions.

If you accidentally switch to a non-supported revision, use the firmware upgrade process to load firmware with the correct revision.

Application Revision Queries and Commands

These are commands to query revision information or select a revision.

  • To query a selected application revision (running or not) use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION? `AMPS/136 MOBILE TEST'"
  • To query the revision of the application currently running use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:CURRENT:REVISION?"
  • To query all of the revisions available for a application use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION? `AMPS/136 MOBILE TEST'"
  • To select a revision of an application use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION `GSM mobile test','A.04.01'"

    After switching to a different revision of your application, you may need to calibrate the test set. See the on-line reference guide for your application for more information.

  • To query the number of revisions for a specified application:

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION:COUNT? `GSM MOBILE TEST'"

Application License Status Query

The application license status can be queried for a particular application and revision using the following GPIB query:

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:LICENSE? `GSM mobile test','A.04.01'"

This query returns one of the following:

  • "LIC" - This revision of application appears to have a LICense. The application may have been developed before licensing and therefore needs no license.
  • "NLIC" - This application does not appear to have a license. Selecting a Not LICensed revision will result in an error +130.
  • "PART" - Some PART of the application does not appear to have a license.
  • "UNKN" - This application has UNKNown license status.

You can also query a list of all licensed applications, formats and features using the following GPIB query:

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:ALL?"

NOTE
If you switch to a not licensed revision the test set will reboot to the SYSTEM CONFIG screen. You will be unable to select any other screen or make any measurements. Query or view the Application Setup menu to determine the licensed versions of applications available.

Revision and license information can be viewed and selected from the SYSTEM CONFIG screen, by selecting the Application Setup menu. Revisions are shown with their license status. After the revision number is a letter. That letter indicates the revision license status; Licensed "L", Not Licensed "N", or Unknown "U".

  • "L"- This revision of application appears to have a License. The application may have been developed before licensing and therefore needs no license.
  • "N" - This application does not appear to have a license. Selecting a Not licensed revision will result in an error +130.
  • "P" - Some Part of the application does not appear to have a license.
  • "U" - This application has Unknown license status.

Related Topics

Application Switching


Configuring System Time and Date

Configuring System Time and Date

Last updated: December 20, 2004

Description

The test set provides the following time and date settings:

  • Time

    This field provides entry of the local time in hours and minutes.

    The Universal Coordinated Time field will track changes made to the Time field.

  • Date

    This field provides entry of the local date.

  • Universal Coordinated Time (UTC)

    Also known as Zulu, Greenwich Mean Time, or UCT, this field provides entry of universal time in hours and minutes.

    The Time field will track changes made to the Universal Coordinated Time (UTC) field.

  • Universal Coordinated Time (UTC) Date
  • Time Zone

    The Time Zone field provides entry of a time offset to the universal coordinated time (UTC). Based on each new time zone setting and the current UTC, a new local time value is calculated and automatically entered into the Time field.

These features are accessed by pressing the SYSTEM CONFIG hardkey followed by the Instrument Setup ( F1 ) softkey.

Related Topics

SYSTem:DATE


Application Switching

Application Switching

Last updated: December 20, 2004

Description

Different radio formats (such as GSM, AMPS, CDMA 2000 or TIA/EIA 136) can be tested when additional applications are purchased from Agilent Technologies. The test set allows you to switch between different applications. A reboot is necessary to make a newly selected application functional. The reboot happens automatically when the you tell the test set to switch applications. Switching to another application takes about one minute.

Some radio formats are combined as fast switching applications. Switching formats in a fast switching application takes less than 2 seconds.

Application Switching GPIB Command

In order to switch to another application use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME `GSM MOBILE TEST'"

Sending this command causes the test set to reboot.

Application Revision and Licensing

Each application must have a valid license and revision to function. Licensed revisions of applications are available from Agilent Technologies.

It may take several seconds before revision, model, and name information is returned.

Application Switching Programming Example

This program example shows you how to switch to the GSM Mobile Test Application.

  1. Query the list of application names to get exact spelling of the GSM Mobile Test Application. This is not necessary if you already know the exact name.
  2. Query the test set to get a list of all revisions for "GSM Mobile Test." This is not necessary if you are not changing revisions.
  3. Select a revision of "GSM Mobile Test." This is required if you are changing revisions.
  4. Select the GSM test application. This will switch applications and cause the test set to reboot.

10    OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME?"
20    !Queries all of the application names
30    ENTER 714;N$
40    PRINT "The CATALOG names that are loaded are ";N$
50    OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION? `GSM MOBILE TEST'"
60    !Queries all revisions of GSM MOBILE TEST
70    ENTER 714;Cat_rev$
80    PRINT "The revisions for the GSM Mobile Test Application are ";Cat_rev$
90    OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION `GSM MOBILE TEST','A.04.01'"
100   !Selects a revision
110   OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME `GSM MOBILE TEST'"
120   !Switches the application to GSM MOBILE TEST
130   END

Related Topics

Application Revisions and Licenses


Timebase Description/Configuration

Timebase Description/Configuration

Last updated: December 20, 2004

Description

The time base source is selected by the test set, either an internal time base or an external source (if a suitable signal is detected) is used as the reference oscillator. If a 10 MHz +/- 100 ppm signal, that has an input level from 0 to +13 dBm is connected to the 10 MHz REF IN connector on the rear panel, the test set will automatically select the external timebase.

You can read the status window at the bottom of the test set display for the EXT REF indicator, or query the test set to verify if it is using an external time base or an internal time base. You may also query the test set to verify if the time base is locked. The reference oscillator functionality is controlled through the SYSTEM subsystem.

Example:

OUTPUT 714;"SYSTEM:ROSCILLATOR[:TIMEBASE]?" !returns INT or EXT
                                            !(internal or external) timebase.
OUTPUT 714;"SYSTEM:ROSCILLATOR:LOCKED?" !returns 1 or 0 (locked or unlocked)
                                        !condition for timebase

Related Topics

SYSTem:ROSCillator


IP Address Requirements

IP Address Requirements

Last updated: December 20, 2004

This section is only applicable to the lab application.

Description

The test set provides a field for entering the IP Address for a wireless device being tested using the packet and CS (circuit switched) data channels.

There are two requirements for the DUT IP Address field:

  1. The network portion (see IP Address Formatting ) of the wireless device's DUT IP address must be the same as the network and subnet portion of the test set's LAN IP Address.

  2. The host portion of the wireless device's DUT IP address must be unique. (It should not be the same as any other host on the network or subnet that the test set is connected to.)

How Network Addresses Are Assigned

Network IDs are assigned by the NIC (Network Information Center). The network portion (first two bytes) of the class B address in the example above would be acquired from the NIC by a network administrator to avoid conflicts with other networks. The network administrator is then free to allocate subnets as needed since subnetting is not visible outside the network.

If you do not know the IP address the test set and/or DUT should be set to, or which unique host IDs are available, you should contact your network administrator.

How to Interpret IP Addresses

The network portion of the LAN IP Address depends on the address classification as shown below:

LAN IP Address Classification

Class A = 1.0.0.0 to 127.255.255.255
Class B = 128.0.0.0 to 191.255.255.255
Class C = 192.0.0.0 to 223.255.255.255
Class D = 224.0.0.0 to 247.255.255.255

An IP Address consists of a 4-byte (32 bit) number. Each byte is in a decimal form separated from other bytes by a dot. This is referred to as a "dotted decimal" format.

NOTE
The test set does not allow LAN IP Addresses in the range of 127.0.0.0 to 127.255.255.255 because these addresses are assigned for use as the Internet host loopback address.

The IP address class defines which bytes contain the network portion of the address. For Class A addresses, the first byte from the left identifies the network. For class B it is the first two bytes from the left, and for class C it is the first three bytes. Class D addresses are multicast, which are used when a datagram is directed to multiple hosts. See IP Address Formatting .

IP Address Formatting
Class | Byte 1 | Byte 2 | Byte 3 | Byte 4
A | Network | Host
B | Network |  | Host
C | Network |  |  | Host
D | Multicast

Determining the Test Set's Network Address

If the test set's LAN IP Address is set to 130.29.183.121, as shown below, the first two bytes represent the network portion since this is a Class B address.

If the test set is on a subnet, the Subnet Mask must be applied to determine the subnet address. This is done by performing bit-wise AND logic between the binary values of the LAN IP Address and Subnet Mask. See Applying the Subnet Address .

Applying the Subnet Address
LAN IP Address | 130 |  |  |  |  |  |  |  | 29 |  |  |  |  |  |  |  | 183 |  |  |  |  |  |  |  | 121
Subnet Mask | 255 |  |  |  |  |  |  |  | 255 |  |  |  |  |  |  |  | 255 |  |  |  |  |  |  |  | 0
Subnet Mask (Binary) | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
LAN IP Address (Binary) | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 1 | 0 | 1 | 1 | 1 | 1 | 0 | 0 | 1
Subnet Address (Binary) | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
Subnet Address | Network130 |  |  |  |  |  |  |  | Network 29 |  |  |  |  |  |  |  | Subnet 183 |  |  |  |  |  |  |  | Host 0

As shown in the table above, the Subnet Mask splits the 16 bit host portion of the class B address into an 8-bit subnet ID and an 8-bit host ID.

In this example the DUT IP Address would need to be set to 130.29.183.XXX to match the test set's subnet ID. The host portion of the LAN IP Address is identified by the bits corresponding to the 0 bits in the Subnet Mask. Therefore, the last byte in the DUT IP Address must not be 121 or any address that corresponds with any other host on the subnet at 130.29.183.XXX


Block Diagram

Block Diagram

Last updated: December 20, 2004

Description

RF Interface Module

Input and output signals are routed through the RF Interface module. The RF Interface module consists of:

  • A directional bridge for sampling incoming power.
  • Hybrid power splitters which create 4 bidirectional ports (two receiver ports and two source ports). The directional bridge couples power to the Power Detector.
  • RF amplifiers.
  • Video gain circuits.
  • Fast and thermal power detectors.

The RF Interface module provides two identical RF Source path connections to the In/Out port of the instrument. There is about 25 dB of isolation between the two source paths. There is about 35 dB of isolation between the source paths and either receiver path. The RFIO module has nominally 23 dB of insertion loss in the source path. A temperature sensing circuit facilitates compensation for path loss variation with temperature.

The source signals can be looped back through the input signal path to cross-calibrate the Measurement Downconverter and the Power Detector.

The sampled input power from the directional bridge can be amplified by as many as two 18 dB range amplifiers and then can be directed to the fast detector or the thermal detector. The input power to the fast detector is detected by a diode detector that is part of a feedback loop. The input to the thermal detector is measured in a bridge using a pair of RMS thermal detectors in a feedback loop.

Signal Downconversion

The test set's downconversion receiver section has two downconversion modules; a Measurement Downconversion Module for making measurements, and a Demodulation Downconversion Module for maintaining the radio link.

Demodulation Downconverter Module

The Demodulation Downconverter module is used as part of the demodulation receiver that maintains the radio link.

Measurement Downconverter Module

The Measurement Downconverter module provides high quality (wide dynamic range, spurious free) signals to the Analog To Digital Converter module's measurement sampler input.

The Measurement Downconverter module is designed for very high performance operation to ensure accurate and repeatable measurement results. The Measurement Downconverter module contains two downconversion stages, two local oscillators, and a logarithmic IF envelope detector . Both first and second LO synthesizers are tunable. The first LO is used when tuning to the RF input frequency, and the second LO is used when setting second IF frequency, which is fed to the measurement sampler on the Analog To Digital Converter module.

Link Subsystem

The Link Subsystem maintains the radio link for all CDMA formats. The Link Subsystem has two parts:

  • Protocol Processor
  • Optional Link Subsystem hardware

The Protocol Processor module is responsible for maintaining the radio link between the test set and the mobile station under test. The primary tasks of the Protocol Processor module are:

  • Generating the protocol messaging necessary for the forward channel and sending that protocol stream to the test set's RF source for transmission to the mobile station.
  • Decoding the protocol messaging received from the mobile station under test on the reverse channel.
  • Computing measurement results which are associated with data bits contained within the mobile stations messaging, such as bit error ratio and frame error rate.

The optional Link Subsystem hardware provides additional signaling link control for CDMA signaling formats. These include:

  • Layer 1 digital signal processing.
  • Providing I/Q baseband signals which are sent to the I/Q modulator in the RF Source

Analog To Digital Converter Module

Following the Measurement Downconverter and Demodulation Downconverter IF 1 is the Analog to Digital Converter module. The purpose of the Analog to Digital Converter module is to convert the downconverted analog signals into digital data streams which can be processed by the Digital Signal Processing module.

In order to maintain the radio link of non-CDMA formats, the downconversion path through the Demodulation Downconverter module has a dedicated A/D conversion path.

To optimize measurement throughput, the fast RF power detector also has a single dedicated A/D path. This allows power measurements, in many cases, to be made concurrently with other measurements. The two outputs from the Measurement Downconverter module and the Audio In signal share a single multiplexed A/D path.

The outputs of the various analog to digital converters on the Analog to Digital Converter module share a common data bus with the Digital Signal Processing module.

Digital Signal Processing Module

The Digital Signal Processing (DSP) module is responsible for a variety of tasks within the overall test set architecture. These tasks are:

  • Demodulate data from the radio under test (data received from the Demodulation Downconverter module) and sending the demodulated data bits to the Protocol Processor module.
  • For some systems, perform audio measurements using audio information sent to the DSP module from the Protocol Processor module.
  • Execute a variety of signal processing algorithms to perform measurements on the radio system of the currently loaded TA (data received from the power detector ADC, the measurement ADC and, in some cases, data received from the Demodulation Downconverter ADC).

The DSP processor communicates with the Host Processor and the Protocol Processor, as well as controlling the configuration and synchronization of the Analog To Digital Converter module.

Host Processor Module

The Host Processor module is responsible for a variety of tasks within the overall test set architecture. These tasks include:

  • Control of the manual user interface (MUI).
  • Executing commands and processing data received from the LAN interface.
  • Executing commands and processing data received from the GPIB interface.
  • Controlling hard disk access.
  • Control of all RF and audio hardware modules.
  • Routing measurement results received form the Digital Signal Processing and Protocol Processor modules to the appropriate output device (display, GPIB, LAN, serial, etc.).

Voltmeter/Counter

Voltmeter

The voltmeter is used to measure internal voltages for instrument self-diagnostics.

Frequency Counter

The Frequency Counter is used to measure external frequencies from the front panel Audio IN, High or Low BNC connectors, and to measure internal signals for diagnostics. The external input can receive a signal between 20 Hz and 50 MHz, with a level from 25 mV to 8 V rms.

Audio Section

Audio Analysis Path

Externally applied audio signals can be analyzed through the test set's DSP module for such characteristics as AC level, SINAD, or distortion.

The audio signal to be analyzed is input to the test set using the front panel Audio IN High/Low connectors. The signal is then routed to the Analog To Digital Converter module's measurement sampler for analysis by the DSP module.

The Audio In connector accepts signals from 20 Hz to 15 KHz, at input levels from 10 mV to 20 V peak.

Audio 1 Path

The Audio 1 path provides analog baseband signals used for frequency modulation of the test set's RF sources. Up to four separate audio sources may be summed together in any combination to provide the composite Audio 1 output. These include the external FM input, internal direct digital synthesis (DDS,) regenerated SAT, and audio echo input.

The external FM input accepts an externally supplied audio signal with a peak voltage between 0.25 and 2 V peak.

The internal DDS generates low distortion audio signals from DC to 20 KHz with 0.1 Hz resolution. One to four signals may be generated and internally summed, with independent level control of each waveform.

The SAT regeneration circuit outputs a signal which is phase-locked to a received SAT signal. This is useful for testing situations where the test set needs to emulate a mobile station.

The audio echo input is used for retransmitting the received audio after a selectable time delay, to check both radio transmit and receive paths simultaneously.

For most applications, only one or two of these Audio 1 path sources are enabled at any given time.

Audio 2 Path

The Audio 2 path provides a secondary means for sending analog baseband signals to the FM modulator. Audio 2 contains only one source, a DDS similar to that used for Audio 1.

Typically, the Audio 2 path DDS is used for cases where multiple signals must be summed together with the lowest possible distortion. Another potential use of Audio 2 would be to obtain higher output levels than Audio 1 is capable of (up to twice as much), assuming the two outputs are set to the same frequency and phase, and then summed together at the Baseband Generator module.

Audio 2 is rarely used in practice because the DDS used for Audio 2 is the same DDS that is used for the front panel audio output.

Audio Out Path

Any one of four inputs may be coupled to the front panel audio output connector. These include a 4 channel DDS (shared with Audio 2), receiver discriminator audio from the Demodulation Downconverter module, audio echo from the Analog To Digital Converter module, and audio vocoder.

The front panel output is capable of providing signal levels up to 9 V peak into > 600 ohm loads, and up to 0.8 V peak into an 8 ohm load (e.g. speaker). The output level is calibrated for all modes except discriminator audio,
The discriminator audio has an uncalibrated volume control provided due to the high tolerances involved.

Typically the DDS mode is used to feed the MIC input of a radio, or it may simply be used as a general purpose low distortion function generator.

Audio echo can be selected to route the received audio to the front panel audio output connector.

RF Sources

The test set has up to two identical RF sources. The RF sources are used to provide analog or digitally modulated RF carriers for use in parametric testing of mobile stations encompassing a variety of cellular radio formats. In general, the sources have a frequency range of 292 MHz to 2.7 GHz and an amplitude range of -10 dBm to -127 dBm.

The RF sources consist of a Synthesized Signal Generator module followed by a Vector Output module and an RF Attenuator module. Baseband modulation information is supplied to the RF sources from a Baseband Generator module preceded by an Audio Section module.

Baseband Generators

The purpose of the Baseband Generator module is to provide, for the modulation type currently in effect, properly formatted baseband signals to the modulation circuits on the RF Source modules.

The Baseband Generator performs several functions related to the generation and processing of these base-band modulation signals. These are:

  • Transform data and clock signals from the Protocol Processor module into base-band analog I/Q modulation signals for the I/Q modulator in the Vector Output module
  • Transform data from the Protocol Processor module into baseband FSK modulation for the FM modulator in the Signal Generator module
  • Provide baseband FM path source selection, gain adjustment and summing node for analog FM signals from the Audio module and internally generated baseband FSK signals which are output to the FM modulator in the Signal Generator module
  • Transform burst and adjacent timeslot signals from the Protocol Processor module into baseband burst modulation signals for the burst modulator in the Vector Output module


Active Cell Operating Mode

Active Cell Operating Mode

Last updated: December 20, 2004

The Active Cell Operating Mode allows you to make a signalling connection between the test set (emulating a base station (BS) in a network) and a UE (mobile station). The types of connections available are described in Channel Type and Paging Service . When connected (and during the connection process for some measurements), the UE's performance can be measured using the suite of measurements shown when the Measurement selection key is pressed.

The following example selects Active Cell Operating Mode via GPIB:

OUTPUT 714;"CALL:OPERating:MODE CALL"

Active Cell Features

While operating in Active Cell mode the test set is capable of performing the following call processing operations:

  • Test set and UE-originated connection and disconnection. See Establishing a Connection with the UE and Channel Type and Paging Service .
  • Intra-cell hard handoff between different W-CDMA UARFCNs ( Physical Channel Reconfiguration ), handoff between RMCs ( Transport Channel Reconfiguration ), inter-system hard handoff from W-CDMA to the GSM system and soft handoff (in the lab application). See Handoffs (Handover) .
  • UE registration. See Performing a Location Update (Registration) .
  • Security operation control. See Security Setup .
  • UE (mobile station) reported measurement results. See UE Reported Measurements .
  • User selectable Signalling Radio Bear configuration. See Signalling Radio Bearer (SRB) Configuration .
  • Open loop power control. See UE Expected Open Loop Transmit Power .
  • Closed loop power control. See UE Expected Open Loop Transmit Power .
  • Automatic or manual frequency control and power ranging of the test set's receiver. See Receiver Control .

Operating Considerations

Many of the settings used in active cell mode cannot be changed during active cell mode operation. A message is displayed to alert you to this situation if you try to change them. These are settings that must be set before attempting to get the UE connected on a call, or settings that are not normally changed during base station operation in a network. Use the Cell Off operating mode to change these settings. See CALL:OPERating to select operating modes.

Related Topics

How Do I Set Up a Call and Make a Connection?

Call Processing Status

Cell Off Operating Mode

FDD Test Operating Mode

W-CDMA Concepts


Broadcast Channel (BCCH) Update Procedure

Broadcast Channel (BCCH) Update Procedure

Last updated: December 20, 2004

While in active cell operating mode, the test set broadcasts the System Information Message on the BCCH. The System Information Message consists of a Master Information Block (MIB) and several System Information Blocks (SIBs 1, 2, 3, 5, 7 and 11). The information in these SIBs helps the UE (mobile station) successfully communicate with the network.

The user-settable parameters contained in the MIB and SIBs are listed in the table below. When you change any of these parameters, the test set changes the information it sends on the BCCH accordingly. Some of these parameters can only be changed while in cell off operating modes. Changing any of the other parameters causes the test set to perform a BCCH update procedure if the test set is not on a connection with the UE. (If the test set is on a connection with a UE, the test set will post an error if you try to change any of these parameters.) During a BCCH update procedure, the test set sends a Paging Type I message to the UE indicating that it needs to re-read the BCCH. (See BCCH Update Page to find out how to prevent the test set from sending a Paging Type I message to the UE).

BCCH Settable Parameters
 | Change Prompts BCCH Update?
MIB Settable Parameters:
Mobile Country Code (MCC) | Yes
Mobile Network Code (MNC) | Yes
SIB 1 Settable Parameters:
ATT (IMSI Attach) Flag State | Yes
DRX Cycle Length (CN Domain) | Yes
Local Area Code (LAC) | Yes
N313 UE Out-Of-Sync Counter | Yes
N315 UE In-Sync Counter | Yes
PS Domain Information | Yes
Routing Area Code (RAC) | Yes
T313 UE Link Reestablishment Timer | Yes
SIB 3 Settable Parameters:
Cell Identity | Yes
Maximum Uplink Transmit Power Level | Yes
SIB 5 Settable Parameters:
Acquisition Indicator Channel (AICH) Channelization Code | No (this setting can only be changed in cell off operating mode)
Acquisition Indicator Channel (AICH) Level | No (this setting can only be changed in cell off operating mode)
Available Subchannels (Bit Mask) | Yes
Constant Value | Yes
Manual PRACH Bc | Yes
Manual PRACH Bd | Yes
Page Indicator Channel (PICH) Channelization Code | No (this setting can only be changed in cell off operating mode)
Page Indicator Channel (PICH) Level | No (this setting can only be changed in cell off operating mode)
PRACH Bc/Bd Control | Yes
PRACH Power Ramp Step | Yes
PRACH Preambles | Yes
PRACH Ramping Cycles (MMAX) | Yes
PRACH Scrambling Codeword | Yes
PRACH Signature | Yes
Primary CPICH TX Power | Yes
Secondary Common Control Physical Channel (S-CCPCH) Channelization Code | No (this setting can only be changed in cell off operating mode)
SIB 7 Settable Parameters:
Uplink Interference | Yes
SIB 11 Settable Parameters:
Cell Info List | Yes
GSM Cell 1-8 BCC (see GSM Cells ) | Yes
GSM Cell 1-8 BCH ARFCN (see GSM Cells ) | Yes
GSM Cell 1-8 NCC (see GSM Cells ) | Yes
GSM Cell 1-8 Shared ARFCN Indicator (see GSM Cells ) | Yes
GSM Cell 1-8 State (see GSM Cells ) | Yes
Intra Freq Cell 1-8 Scrambling Code (see Intra-frequency Cells ) | Yes
Intra Freq Cell 1-8 State (see Intra-frequency Cells ) | Yes
Inter Freq Cell 1-8 DL Channel (see Inter-frequency Cells ) | Yes
Inter Freq Cell 1-8 Scrambling Code (see Inter-frequency Cells ) | Yes
Inter Freq Cell 1-8 State (see Inter-frequency Cells ) | Yes

Related Topics

How Do I Change Cell Parameters?


Cell Parameters

Cell Parameters

Last updated: December 22, 2004

The test set broadcasts cell-specific information on the BCCH. This information is needed by the UE to successfully communicate with the network.

Changing some of the following settings while in Active Cell Operating Mode will result in the execution of the BCCH Update procedure (see Broadcast Channel (BCCH) Update Procedure ).

Some settings cannot be changed during Active Cell operation. Attempting to change these settings while in Active Cell Operating Mode results in an error, and the test set rejects the change. Switch to Cell Off Operating Mode to change these settings.

  • BCCH Update Page

    If BCCH Update Page is set to Auto , when you change a parameter that causes a BCCH Update, the test set updates its BCCH information and sends a Paging Type I message to the UE telling it to re-read the BCCH. If BCCH Update Page is set to Inhibit , when you change a parameter that causes a BCCH Update, the test set updates its BCCH information but does NOT send a Paging Type I message to the UE.

    If your UE does not support the BCCH Update procedure, set this field to Inhibit .

    You may also use this field to reduce the amount of signalling between the test set and UE as follows: if you need to change many BCCH parameters, set this field to Inhibit , change all of the parameters except one, set this field to Auto , then change the final parameter. That way, only one Paging Type I message is sent to the UE. See Broadcast Channel (BCCH) Update Procedure

    GPIB command: CALL[:CELL[1]]:BCCHannel:UPDAtepage .

    This parameter can be set at any time.

  • PS Domain Information

    This setting indicates to the UE what type of services are supported by the test set. When PS Domain Information is set to Absent , the CN Domain System Information List sent by the test set in SIB 1 (see 3GPP TS 25.331 10.2.48.8.4) includes CN Domain System Information for the CN Domain Identity of CS Domain only (see 3GPP TS 25.331 10.3.1.2). When PS Domain is set to Present , the CN Domain System Information List also includes CN Domain System Information for the CN Domain Identity of PS Domain.

    Setting PS Domain Information to Present allows UEs that require both of these CN Domain Identities to camp to the test set. PS Domain Information must be set to Present before a UE will initiate PS services with the test set.

    The test application supports the PS Domain Information setting even though it does not support PS services. The test application will allow a UE to attach to the test set, but if the UE attempts an Activate PDP Context Request, it will be rejected with a cause of "Feature Not Supported" (see Activate PDP Context Reject ).

    GPIB command: CALL[:CELL]:PSDomain .

    This parameter can only be set when call status is Idle .

  • Mobile Country Code (MCC)

    GPIB command: CALL:MCCode .

    This parameter can only be set when call status is Idle .

  • Mobile Network Code (MNC)

    GPIB command: CALL:MNCode .

    This parameter can only be set when call status is Idle .

  • Local Area Code (LAC)

    GPIB command: CALL:LACode .

    This parameter can only be set when call status is Idle .

  • Routing Area Code (RAC)

    The RAC is a fixed length code (of 1 octet) identifying a routing area within a location area (see 3GPP TS 23.003 4.2). The CN Domain identifier for Packet Switching (PS) consists of the PLMN-Id, Local Area Code (LAC) and the RAC (see 3GPP TS 23.003 12.2).

    GPIB command: CALL:RACode .

    This parameter can only be set when PS Domain Information is set to Present and call status is Idle .

  • Cell Identity

    3GPP TS 25.331 10.3.2.2 defines cell identity as a 28 bit number which unambiguously identifies a cell within a PLMN (Public Land Mobile Network). The Cell Identity parameter in the test set allows you to input a decimal value between 0 and 268435455, which is then transmitted to the UE as a 28 bit number, identifying the test set.

    GPIB command: CALL[:CELL]:IDENtity .

    This parameter can only be set when call status is Idle .

  • ATT (IMSI Attach) Flag State

    When ATT (IMSI Attach) Flag State is Set , the test set signals the UE to perform an IMSI Attach when it camps to the test set signal. This results in the UE performing a Location Update. The test set does not actually perform the IMSI Attach procedure. See also Performing a Location Update (Registration) .

    GPIB command: CALL:ATTFlag .

    This parameter can only be set when call status is Idle .

  • DRX Cycle Length (CN Domain)

    DRX (Discontinuous Reception) Cycle is defined in 3GPP TS 25.304 3.1 as "Individual time interval between monitoring Paging Occasion for a specific UE." 3GPP TS 25.331 8.6.3.1a states "The UE shall determine its idle mode paging occasions and PICH monitoring occasions for that CN domain..., based on the stored CN domain specific DRX cycle length, when using DRX in idle mode." This setting determines the length of the DRX cycle that the UE uses while in idle mode.

    This parameter is useful for idle mode battery drain testing.

    See Page Indicator Channel (PICH) and Repeat Paging for related information.

    Note, this setting does not configure the UTRAN DRX Cycle length coefficient described in 3GPP TS 25.331 8.6.3.2.

    GPIB command: CALL[:CELL]:DRX:CLENgth .

    This parameter can only be set when call status is Idle .

  • Repeat Paging

    When Repeat Paging is set to Off, the test set issues a single PICH page indication and Paging Type I message when you select Originate Call ( CALL:ORIGinate ).

    When Repeat Paging is set to On, when you select Originate Call ( CALL:ORIGinate ), the test set sends PICH page indications and Paging Type I messages every DRX Cycle Length (CN Domain) until the UE responds with PRACH preambles and a valid RRC Connection request (see RRC Connection Setup Procedure ) or until End Call ( CALL:END ) is selected.

    GPIB command: CALL:PAGing:REPeat[:STATe][:SELected]

    This parameter can only be set when operating mode is Cell Off .

  • Open loop power control settings - these settings are used by the UE to determine the initial transmit power of the first PRACH preamble. See also Initial PRACH Tx Power .
    • Primary CPICH TX Power

      GPIB command: CALL:PCTPower .

      Primary CPICH Tx Power is a parameter transmitted to the UE on the BCCH by the test set. It is not the actual transmit power level of the test set's CPICH.

      This parameter can only be set when call status is Idle .

    • Uplink Interference

      GPIB command: CALL:UINTerferenc .

      This parameter can only be set when call status is Idle .

    • Constant Value

      GPIB command: CALL:CVALue .

      This parameter can only be set when call status is Idle .

  • UE Timers

    3GPP TS 25.331 8.5.6 states that after receiving N313 consecutive "out of sync" indications from layer 1, the UE shall start the T313 timer. Upon receiving N315 successive "in sync" indications from layer 1, the UE shall stop and reset the T313 timer. If T313 expires, a "Radio Link failure" has occurred, and the UE shall drop the call. See 3GPP TS 25.214 4.3.1.2 for more details regarding "in sync" and "out of sync" indications.

    • N313 UE Out-Of-Sync CounterN313 can be set to one of the following

      integer values: 1, 2, 4, 10, 20, 50, 100, 200.

      GPIB command: CALL[:CELL[1]]:BCCHannel:N313

      This parameter can only be set when call status is Idle .

    • T313 UE Link Reestablishment Timer

      T313 can be set to an integer value between 0 and 15 seconds.

      GPIB command: CALL[:CELL[1]]:BCCHannel:T313

      This parameter can only be set when call status is Idle .

    • N315 UE In-Sync Counter

      N315 can be set to one of the following integer values: 1, 2, 4, 10, 20, 50, 100, 200, 400, 600, 800, 1000.

      GPIB command: CALL[:CELL[1]]:BCCHannel:N315

      This parameter can only be set when call status is Idle .

Related Topics

Manual Operation: How Do I Change Cell Parameters?


Cell Off Operating Mode

Cell Off Operating Mode

Last updated: December 20, 2004

Cell Off operating mode and Active Cell operating mode share the same settings. However, Cell Off mode allows you to change the parameters that cannot be changed during Active Cell operation but used for call processing, such as downlink and uplink channel number (UARFCN), reference measurement channel configuration (Channel Type), signalling radio bearer configuration, etc.

Use Cell Off operating mode to set up those downlink and uplink parameters before establishing a connection to the UE (mobile station). After making the settings, switch to Active Cell operating mode to begin generating the downlink signal. Use CALL:OPERating to select operating modes.

NOTE
No signal is generated by the test set during Cell Off operation, regardless of the Cell Power setting. All settings are deferred until the Active Cell operating mode or FDD Test operating mode is used.

Related Topics

Active Cell Operating Mode

FDD Test Operating Mode

Downlink Channel (UARFCN)

Uplink Channel (UARFCN)

Channel Type and Paging Service

Signalling Radio Bearer (SRB) Configuration

Cell Parameters

Downlink Channel Codes and Levels

Uplink Parameters


Downlink and Uplink Channels Overview

Downlink and Uplink Channels Overview

Last updated: December 22, 2004

The "Downlink" refers to a radio link for the transmission of signals from the test set to a UE (mobile station) while the "Uplink" refers to a radio link for the transmission of signals from a UE (mobile station) to the test set. Table below summarizes the downlink and uplink channels supported by the test set in Active Cell operating mode and the FDD Test operating mode, and the following figures show the channel structures respectively.

Physical Channels in Active Cell and FDD Test Operating Modes
Active Cell Operating Mode |  | FDD Test Operating Mode
Downlink Channels | Uplink Channels | Downlink Channels | Uplink Channels
CPICH | PRACH | CPICH |
P-CCPCH/SCH | DPCH | P-CCPCH/SCH | DPCH
S-CCPCH |  |  |
PICH |  | PICH |
AICH |  |  |
DPCH |  | DPCH |
Comp. OCNS |  | Comp. OCNS |

Active Cell Mode Downlink Channel Structure

FDD Test Mode Downlink Channel Structure

Active Cell Mode W-CDMA Uplink Channel Structure

FDD Test Mode W-CDMA Uplink Channel Structure

Downlink Channels

The downlink channels transmitted by the test set in Active Cell operating mode (see Active Cell Mode Downlink Channel Structure ) are different from the downlink channels in FDD Test operating mode (see FDD Test Mode Downlink Channel Structure ). To configure the downlink channel codes and levels, see

  • Common pilot channel (CPICH): Used by the UE (mobile station) to find the primary scrambling code and to help determine its transmit power during open loop power control.
  • Primary common control physical channel (P-CCPCH): Contains the broadcast channel (BCH) that normally provides system information to the UE. In FDD Test operating mode, this channel consists of pseudo-random bit sequence (PRBS) data and a valid system frame number (SFN).
  • Secondary common control physical channel (S-CCPCH)

    Carries the signalling information used to set up the connection with the UE. This channel is not used in FDD Test Mode.

  • Synchronization channel (SCH): Includes the primary and secondary synchronization channels (PSC and SSC) that contain timing information to allow the UE to synchronize to the test set (or base station).
  • Page Indicator Channel (PICH)

    Used to alert the UE that it is possibly being paged. The UE must then read the Secondary common control physical channel (S-CCPCH) to determine if it is being paged.

    In Active Cell mode, the PICH contents are initially set to "no page" in all paging indicators. Once call origination is initiated, all of the page indicators in each valid access frame are set to indicate a page. The valid access frames occur at times specified by the DRX Cycle Length (CN Domain) setting. Once the UE has responded to the page, the paging indicators are returned to "no page."

    In FDD Test mode, the PICH contents are determined by the DL PICH Data setting.

  • Acquisition Indicator Channel (AICH): Used in response to a UE's PRACH Preambles to indicate to the UE that it may continue with call setup. This channel is not used in FDD Test Mode.
  • Dedicated physical channel (DPCH): Contains the dedicated physical control channel (DPCCH) which includes the transmit power control (TPC) and transmit format combination indicator (TFCI), and the dedicated physical data channel (DPDCH) which contains the user data.

Interference Sources on the Downlink

  • Additive White Gaussian Noise (AWGN) - can be summed into the downlink signal to simulate interference from other cells when enabled. See Cell Power and AWGN Power .
  • Orthogonal Channel Noise Simulator (OCNS) - used to simulate additional users on the downlink. OCNS is automatically enabled when the sum of the levels of all the enabled downlink physical channels is less than the cell power setting. See Orthogonal Channel Noise Simulator (OCNS) .

Uplink Channels

The test set recognizes two types of uplink physical channels, the Physical Random Access Channel (PRACH) and the Dedicated Physical Channel (DPCH). However, the Active Cell Mode W-CDMA Uplink Channel Structure is different from the FDD Test Mode W-CDMA Uplink Channel Structure .

  • Physical Random Access Channel (PRACH) - used by the UE to request registration on the network. The test set only responds to the PRACH in Active Cell Mode.
  • Dedicated Physical Channel (DPCH) - is the combination of the Dedicated Physical Data Channel (DPDCH) which carries the user data/signalling, and the Dedicated Physical Control Channel (DPCCH) which contains physical channel control information. In Active Cell Mode the test set will configure the Uplink DPCH by sending signalling information to the UE during Call Setup (see Channels Used for Call Setup ). In FDD Test Mode the Test Set assumes that the UE's uplink has been properly configured to match the expected configuration. The expected configuration is determined by the FDD Channel Type setting (see Channel Type and Paging Service ).

Related Topics

W-CDMA Concepts


Channel Type and Paging Service

Channel Type and Paging Service

Last updated: December 22, 2004

Service Types

While in Active Cell Operating Mode , the test set supports the following services:

  • Radio Bearer Test Mode

    The W-CDMA specifications define a suite of uplink (UL) and downlink (DL) reference measurement channels (RMCs) to use for UE transmitter and receiver conformance test. See Radio Bearer Test Mode, TC, and Reference Measurement Channels . The test set supports the following RMCs:

    • Symmetrical RMCs

      The symmetrical RMCs always use Transparent Mode (TM) RLC entities on the DTCH. The UE must send the Close UE Test Loop Complete message to the test set before it will start transmitting data on the downlink DTCH.

      • 12.2 kbps (3GPP TS 25.101 A.2.1 and A.3.1)
      • 64k kbps (3GPP TS 25.101 A.2.2 and A.3.2)
      • 144 kbps (3GPP TS 25.101 A.2.3 and A.3.3)
      • 384 kbps (3GPP TS 25.101 A.2.4 and A.3.4)
      • 33k No Coding RMC

        This Agilent proprietary RMC does not use convolutional coding on the downlink data, to allow for raw BER testing (see Loopback Bit Error Ratio Measurement Description ).

    • Asymmetrical RMCs

      The asymmetrical RMCs allow high data rate receiver testing in UEs that don't support rates above 64 kbps in the uplink. The asymmetrical RMCs use Acknowledged Mode (AM) RLC entities on the DTCH. When an asymmetrical RMC is established, no Close UE Test Loop message is sent to the UE. Asymmetrical RMCs are not available in FDD test operating mode.

      • 12.2 kbps UL/64 kbps DL (3GPP TS 34.121 C.6.7 and 3GPP TS 34.121 C.3.2 (table C.3.2.3))
      • 12.2 kbps UL/144 kbps DL (3GPP TS 34.121 C.6.7 and 3GPP TS 34.121 C.3.3 (table C.3.3.3))
      • 12.2 kbps UL/384 kbps DL (3GPP TS 34.121 C.6.7 and 3GPP TS 34.121 C.3.4 (table C.3.4.3))
      • 64 kbps UL/384 kbps DL (3GPP TS 34.121 C.2.2 (table C.2.2.3) and 3GPP TS 34.121 C.3.4 (table C.3.4.3))

    You can configure the radio bearer test mode as explained in Radio Bearer Test Mode Setup .

  • AMR Voice

    While in AMR Voice service, the test set loops the transport blocks arriving from the UE on the uplink back down to the UE (unaltered) on the downlink. There is a fixed voice echo delay of 1 second.

    At this time, the AMR RAB is fixed to a maximum rate of 12.2 kbps. See How Do I Configure the AMR Voice Radio Access Bearer? and CALL:SERVice:AMR:RAB ).

  • UMTS/GPRS Packet Data (lab application only): see GPRS Packet Data Service .
  • CS Data - Async (lab application only): see CS (Circuit Switched) Data Service .
  • CS Data - UE to UE Video Call (lab application or feature-licensed test application only): see Video Call .

Current Service Type is displayed under Call Processing Status on the Call Setup Screen , and can be queried using the CALL:STATus:SERVice:TYPe? command.

Paging Service

The Paging Service setting is used to set which type of service is initiated when the test set pages the UE. The Paging Service setting does not apply to UE-originated connections (see Establishing a Connection with the UE ). Paging Service can be set to Radio Bearer Test Mode or AMR Voice .

For the lab application only, Paging Service can also be set to UMTS/GPRS Packet Data (the test set only supports UE-origination of CS Data services, so CS Data is not an option for Paging Service ).

Channel Type

The Channel Type setting allows you to specify which RMC to use while operating in Radio Bearer Test Mode . Channel Type can be set to:

  • Symmetrical RMCs
    • 12.2k RMC
    • 64k RMC
    • 144k RMC
    • 384k RMC
    • 33k No Coding RMC
  • Asymmetrical RMCs

    The asymmetrical RMCs are not available in FDD Test Operating Mode . If Channel Type is set to an asymmetrical RMC and you move to FDD Test Operating Mode , Channel Type is changed to 12.2k RMC .

    • 12.2k UL/64k DL AM RMC
    • 12.2k UL/144k DL AM RMC
    • 12.2k UL/384k DL AM RMC
    • 64k UL/384k DL AM RMC

This setting can not be changed while on a call. You can hand off between Symmetrical RMCs while on an RB Test Mode call by performing a Transport Channel Reconfiguration .

Related Topics

Channel Type and Paging Service via Front Panel: How Do I Change Call Parameters?

Channel Type GPIB Command: CALL:SERVice:RBTest:RAB

Paging Service GPIB Command: CALL:PAGing:SERVice[:TYPE]


Compressed Mode

Compressed Mode

Last updated: December 20, 2004

This section is only applicable to the lab application.

  • Compressed Mode Overview
  • Compressed Mode Operation in the Test Set
  • UE Measurements During Compressed Mode Operation
  • Additional Considerations While in Compressed Mode Operation
  • Compressed Mode Operation While in FDD Test Operating Mode

Compressed Mode Overview

Compressed mode operation allows a UE, while on a call, to interrupt its reception and transmission for short periods of time (transmission gaps) so that it can perform measurements on neighboring cells of a different frequency than its current serving cell. The UE can perform measurements on neighboring GSM or WCDMA cells.

The network specifies the transmission gap pattern sequences (TGPSs), which control when the transmission gaps occur, and their duration. During radio frames that contain transmission gaps, the UE and network use a lower spreading factor to ensure no data is lost.

Compressed Mode Operation in the Test Set

Compressed mode is only available when on a 12.2k RMC call (see Channel Type and Paging Service ). Once on a call, you may enable (or disable) compressed mode operation by selecting Enable Compressed Mode (or Disable Compressed Mode ) or using the CALL:COMPressed:ENABle command. Upon successful activation of compressed mode, Compressed Mode State changes to " On " (as displayed on the Call Setup Screen under Call Processing Status and on the compressed mode measurement results screens, and queriable using the CALL:STATus:COMPressed:STATe? command). The message that activates compressed mode specifies a starting time that gives the UE sufficient time to respond with the proper messaging before compressed mode is enabled. If the proper messaging is received, Compressed Mode State changes to On .

The compressed mode functionality in the test set consists of one transmission gap pattern sequence that has a single transmission gap pattern, which uses spreading factor reduction for both the uplink and downlink. Note, the test set does not transmit compressed frames at an increased power level. Compressed frames are transmitted at the same power level as non-compressed frames (the power level determined by the Cell Power setting).

You may specify the following parameters to configure the compressed mode transmission gap pattern:

Transmission Gap Parameters

The default values for these parameters match the values in 3GPP TS 34.121 Table C.5.1 Set 1.

  • Transmission Gap Starting Slot Number (TGSN)

    The TGSN setting determines on which timeslot the transmission gap in TGPS 1 will start. Note that the range of this setting (slot 0 to slot 14) matches the definition of TGSN in 3GPP TS 25.331.

    GPIB syntax: CALL:COMPressed:TGPSequence:TGSNumber .

  • Transmission Gap Length (TGL)

    The TGL setting determines how long the transmission gap is (in slots) for TGPS 1.

    GPIB syntax: CALL:COMPressed:TGPSequence:TGLength .

  • Transmission Gap Pattern Length (TGPL)

    The TGPL setting determines how long the pattern length is (in frames) for TGPS 1.

    GPIB syntax: CALL:COMPressed:TGPSequence:TGPLength .

The transmission gap pattern repetition count is fixed at infinity. All other applicable parameters are fixed according to 3GPP TS 34.121 Table C.5.1 Set 1.

Activation of compressed mode in the UE involves two steps:

  1. TGPS definition: the network supplies the TGPS definition(s).
  2. TGPS activation: the network orders the UE to activate a particular TGPS.
These actions may be combined within a single message (Physical Channel Reconfiguration message while on a call) or in separate messages (TGPS definitions supplied in an RB Setup message during call setup and TGPS activation ordered in a Measurement Control or Physical Channel Reconfiguration message once on a call (see Summary of Options for Enabling Compressed Mode and UE Measurements ).

You may specify whether to define the TGPS during call setup or while on a call using the following parameter:

  • TGPS Definition During Call Setup

    If this parameter is set to RB Setup , then the test set will supply the TGPS definitions to the UE in the RB Setup message during call setup. If this parameter is set to Off , then the test set will supply the TGPS definitions to the UE after the call is established (see Summary of Options for Enabling Compressed Mode and UE Measurements ).

    If TGPS Definition During Call Setup is set to RB Setup , then you can only configure the Transmission Gap Parameters when the call status is idle (so that the transmission gap definition can then be provided to the UE when the call is established). If TGPS Definition During Call Setup is set to Off , then the Transmission Gap Parameters can only be configured if Compressed Mode State is Off (so that the transmission gap definition can then be provided to the UE when compressed mode is activated).

    GPIB syntax: CALL:COMPressed:TGPSequence:DEFinition .

UE Measurements During Compressed Mode Operation

To order the UE to perform measurements on neighboring cells, you must configure the test set to send a Measurement Control message to the UE when compressed mode is enabled.

  • UE Measurements in Compressed Mode

    If this parameter is set to On , when compressed mode is enabled, the UE will be instructed to perform periodic measurements on the neighbor cells specified by the Compressed Mode Measurement Purpose parameter (in this case, the test set activates compressed mode using a Measurement Control message). If this parameter is set to Off , when compressed mode is enabled, the UE will not perform any measurements on neighboring cells (in this case, the test set activates compressed mode using a Physical Channel Reconfiguration message, no Measurement Control message is sent to the UE). See Summary of Options for Enabling Compressed Mode and UE Measurements .

    GPIB syntax: CALL:COMPressed:MEASurement:STATe .

NOTE
If UE Measurements in Compressed Mode is set to Off when compressed mode is enabled, no UE measurement results will be available. To enable UE measurements, you must disable compressed mode, set UE Measurements in Compressed Mode to On , and then enable compressed mode.

Once compressed mode is enabled with UE measurements, UE measurement results are posted to the front panel and available via GPIB (see Compressed Mode UE Reported Measurements ).

The following table summarizes the options for enabling compressed mode and UE measurements:

Summary of Options for Enabling Compressed Mode and UE Measurements
TGPS Definition During Call Setup | UE Measurements in Compressed Mode | TGPS Definition occurs in which message? | TGPS Activation occurs in which message? | Result
RB Setup | Off | RB Setup message | Physical Channel Reconfiguration message | TGPS definition occurs during call setup, compressed mode is activated without UE measurements.
Off | Off | Physical Channel Reconfiguration message | Physical Channel Reconfiguration message | TGPS definition occurs after the call is established, compressed mode is activated without UE measurements.
RB Setup | On | RB Setup message | Measurement Control message | TGPS definition occurs during call setup, compressed mode is activated with UE measurements.
Off | On | Physical Channel Reconfiguration message | Measurement Control message | TGPS definition occurs after the call is established, compressed mode is activated with UE measurements.
See Compressed Mode Ladder Diagrams for more information about the messages exchanged during these operations.

UE Measurement Configuration

The UE may perform measurements on either GSM or WCDMA neighbor cells when you enable compressed mode, but not both. You must specify which to measure using the following parameter:

  • Compressed Mode Measurement Purpose

    This setting determines whether the UE will perform measurements on neighboring (WCDMA) Inter-frequency Cells (when FDD Meas is selected) or GSM Cells (when GSM RSSI is selected).

    If TGPS Definition During Call Setup is set to RB Setup , then you can only configure this parameter when the call status is idle. If TGPS Definition During Call Setup is set to Off , then this parameter can only be configured if Compressed Mode State is Off . Therefore, to change which type of cells are measured when compressed mode is enabled, you must disable compressed mode, change this setting, then enable compressed mode.

    GPIB syntax: CALL:COMPressed:MEASurement:TYPe .

The UE performs periodic measurements on the neighbor cells that you specify. You may configure how many measurements are reported, and how often, using the following parameters (these parameters can only be changed when Compressed Mode State is Off ):

  • GSM RSSI Measurement Reporting Quantity

    This setting determines how many measurement reports the UE will return after the GSM RSSI measurement has been activated. After the UE has returned the number of reports specified by this parameter, it will stop reporting measurement results.

    GPIB syntax: CALL:COMPressed:MEASurement:GSMSystem:RSSI:RQUantity .

  • GSM RSSI Measurement Reporting Interval

    This setting determines the period (in seconds) between measurement reports when the GSM RSSI measurement is active in the UE.

    GPIB syntax: CALL:COMPressed:MEASurement:GSMSystem:RSSI:RINTerval .

  • Interfreq Measurement Reporting Quantity

    This setting determines how many measurement reports the UE will return after the FDD measurement has been activated. After the UE has returned the number of reports specified by this parameter, it will stop reporting measurement results.

    GPIB syntax: CALL:COMPressed:MEASurement:ITRFrequency:RQUantity .

  • Interfreq Measurement Reporting Interval

    This setting determines the period (in seconds) between measurement reports when the FDD measurement is active in the UE.

    GPIB syntax: CALL:COMPressed:MEASurement:ITRFrequency:RINTerval .

Additional Considerations While in Compressed Mode Operation

A consequence of using spreading factor reduction is that during compressed frames, the DPCH occupies twice as much code channel space as non-compressed frames. You must thus carefully choose the DPCH code channel to avoid collisions with other channels during compressed mode operation. Compressed mode can only be activated when the DPCH channelization code is 20, 29, 37, 45, 60, 70, 76, 87 or 93. Any other channelization codes will cause compressed frames to collide with other downlink channels (see Setting Downlink Channel Codes ). The default DPCH 30 ksps Channelization Code setting is 9 . Thus, before beginning compressed mode testing, you must place the test set in Cell Off Operating Mode , and change the DPCH channelization code to an acceptable value.

All call processing features that are normally available while on a call (such as soft handoff or handovers to a new frequency or RMC) are available during compressed mode operation. However, compressed mode is automatically disabled after a handover to another frequency or RMC type (see Handoffs (Handover) ).

While in compressed mode operation, the uplink closed loop power control algorithms function normally. Note however that the test set does not send power control bits during transmission gaps. If you request the test set to send a power control sequence such as continuous 10 Up/Down bits during compressed mode operation, when a transmission gap occurs, the test set will stop sending power control bits during the transmission gap, and then continue sending the power control bits in the sequence after the transmission gap is over (it does not restart the 10 up/down pattern, it continues where it left off before the transmission gap occurred). This means the 10 up/down pattern will no longer be aligned to a 20 ms TTI boundary. When you deactivate compressed mode, the 10 up/down pattern will remain unaligned to the 20 ms TTI boundary. To reestablish alignment, you must select another pattern, such as Alternating bits , then reselect 10 Up/Down bits .

While in compressed mode operation, all transmitter measurements performed while on a call will work intermittently, as the measurement may sample the uplink while the UE is not transmitting. Receiver measurements (Loopback BER and Loopback BLER) function completely during compressed mode operation. As compressed mode can only be enabled while on a call, measurements performed while not on a call (such as PRACH transmit on/off power and PRACH preamble analysis) are not affected by compressed mode operation.

Compressed Mode Operation While in FDD Test Operating Mode

You can enable compressed mode operation while in FDD Test Operating Mode , but the UE can not perform neighbor cell measurements. However, you can still make receiver measurements on the UE.

Before enabling compressed mode operation, the UE must synchronize to the 12.2k RMC signal from the test set. You define the transmission gap as explained in Transmission Gap Parameters . You can then configure the starting CFN and compressed mode deactivation using the following parameters (and enable compressed mode operation as explained in Compressed Mode Operation in the Test Set ):

  • Starting CFN

    This setting determines the frame upon which the compressed mode pattern will be started. The starting CFN must be aligned to a 40 ms boundary.

    GPIB syntax: CALL:FDDTest:COMPressed:SCFNumber .

  • Deactivation Type

    This setting controls whether compressed mode will be deactivated immediately after you select Disable Compressed Mode , or upon a specific CFN (as specified by Ending CFN ).

    GPIB syntax: CALL:FDDTest:COMPressed:DACTivation:TYPe .

  • Ending CFN

    When Deactivation Type is set to Specified CFN , the Ending CFN parameter specifies the specific CFN upon which compressed mode will be deactivated after you select Disable Compressed Mode .

    GPIB syntax: CALL:FDDTest:COMPressed:ECFNumber .

Related Topics

Manual Operation: How Do I Enable Compressed Mode and Obtain UE Measurement Results?

CALL:COMPressed

CALL:STATus

CALL:FDDTest

Compressed Mode Ladder Diagrams

Troubleshooting Compressed Mode Operation

SIB11 Cell Info List

UE Reported Measurements


W-CDMA Concepts

W-CDMA Concepts

Last Updated: December 20, 2004

W-CDMA Protocol Structure

The W-CDMA protocol has a layered structure designed to give the system a great deal of flexibility. The two major parts are the Core Network (CN) and Radio Access Network (RAN). The structure of the RAN and the relationship of several key terms to it are illustrated in W-CDMA Protocol Structure It is important to recognize that this figure is only an illustration. The exact structure, including the number and type of channels, number and type of user services, and the configuration of blocks in the structure will vary over time to meet the current needs of the system. The structures of the uplink and downlink are very similar; however, some types of channels exist in only one direction; while others exist in both.

W-CDMA Protocol Structure

The WCDMA structure is divided vertically into an "Access Stratum (AS)" and a "Non Access Stratum (NAS)", and horizontally into a "Control Plane" and a "User Plane". Protocol Layers 1 and 2 are in the Access Stratum. Protocol Layer three is divided between the Access and Non-Access strata. In layers 2 and 3 control plane and user plane information is carried on separate channels. Within layer 1 some channels carry only control plane information, while others carry both user and control plane data.

Radio Bearer Test Mode, TC, and Reference Measurement Channels

Radio Bearer Test Mode is a special mode of operation defined by the W-CDMA specifications. Its purpose is to provide for efficient manufacturing testing of a W-CDMA UE by offering a simplified mode of operation wherein the Test Set has complete control of the necessary UE functions. In Radio Bearer Test Mode connection to the UE is done via a special Test Control (TC) protocol entity and any User Plane radio bearers are terminated in a layer 3 loopback entity, rather than being connected through to a real service. In radio Bearer Test Mode the protocol structure appears as shown in W-CDMA Protocol Structure in Radio Bearer Test Mode

W-CDMA Protocol Structure in Radio Bearer Test Mode

While it is still possible to configure layers 1 and 2 in any valid configuration in Radio Bearer Test Mode, the typical use of this mode is to set up the special test configurations known as "Reference Measurement Channels". The reference measurement channels are a defined set of configurations of layers 1 and 2 that provide stable, predictable behavior for radio testing. All aspects of these layers are explicitly defined by the definition of the Reference Measurement Channels given in the W-CDMA system specifications. The protocol structure of the Reference Measurement Channels is shown in W-CDMA Reference Measurement Channel Protocol Structure

W-CDMA Reference Measurement Channel Protocol Structure

W-CDMA Channels

"Channel" has several meanings in the W-CDMA system.

W-CDMA System Channels
Channel Name | Channel Type | Exists in Uplink | Exists in Downlink
CPICH | Physical Channel |  | *
P-CCPCH/SCH | Physical Channel |  | *
S-CCPCH | Physical Channel |  | *
PICH | Physical Channel |  | *
AICH | Physical Channel |  | *
DPCH | Physical Channel | * | *
PRACH | Physical Channel | * |
DCH | Transport Channel | * | *
RACH | Transport Channel | * |
PCH | Transport Channel |  | *
BCH | Transport Channel |  | *
FACH | Transport Channel |  | *
DTCH | Logical Channel | * | *
DCCH | Logical Channel | * | *
CCCH | Logical Channel | * | *
PCCH | Logical Channel |  | *
BCCH | Logical Channel |  | *

Downlink Overhead Channels

The overhead channels are transmitted continuously in each cell. They are used by the UE to synchronize to the cell, to identify the cell and the network, and to obtain information about how to access the cell.

W-CDMA Downlink Overhead Channels

  • Common Pilot Channel (CPICH) - used to transmit timing and frequency reference information to UEs (mobile stations) which are used by the UE (mobile station) to find the primary scrambling code and to help determine its transmit power during open loop power control.
  • Synchronization channel (SCH): includes the primary and secondary synchronization channels (PSC and SSC) that contain timing information to allow the UE to synchronize to the test set (or base station). It is time multiplexed with P-CCPCH.
  • Primary Common Control Physical Channel (P-CCPCH) - used to transmit Broadcast transport channel (BCH) which provides system information to the UE. It is time multiplexed with Synchronization Channel (SCH) which is used to aid the UE synchronization to the network. In FDD Test operating mode, this channel consists of pseudo-random bit sequence (PRBS) data and a valid system frame number (SFN).

Channels Used for Call Setup

After the UE has identified a cell that it wants to access and has read the access information from the Broadcast Channel, it must register. Registration informs the network of the presence of the UE and is performed using the Location Update Procedure.

In order for there to be any communication between the mobile and the network a control connection must be established between the RRC entities in the network and the UE. This step is the same whether the purpose is registration, mobile initiated call setup, or network originated call setup. These channels are shown in W-CDMA Connection Setup Channels

W-CDMA Connection Setup Channels

  • Acquisition Indication Channel (AICH) - used to acknowledge UE access request.
  • Paging Indication Channel (PICH) - used to alert the UE of a forthcoming page message. In FDD test mode, the test set only provides a user specified bit pattern to allow the operator to verify that the UE is correctly decoding this channel.
  • Secondary Common Control Physical Channel (S-CCPCH) - used to transmit pages and signalling to idling UEs.
  • Physical Random Access Channel - used by the UE to make its initial transmissions to the network.


Calling Party Number Parameters

Calling Party Number Parameters

Last updated: December 20, 2004

This section is only applicable to the lab application.

The test set allows you to specify the calling party number (CPN) parameters sent to the called mobile station so that you can evaluate the mobile station's behavior in response to the CPN (for example, to see whether the mobile station displays the calling party's number as expected).

When you originate a call from the test set, the calling party number parameter is sent to the called mobile station via the SETUP message. See How Do I Perform Calling Party Number Verification? for the detailed procedure.

When you send SMS messages, the test set also allows you to enter the originating address. The address setting for messages is different from that for calling party number. See Originating Address for more information.

Operating Considerations

The Calling Party Number feature is only applicable to UE-terminated CS services ( AMR Voice and the called UE when establishing a Video Call ).

Parameter Descriptions

The following gives the parameter and value descriptions defined in 3GPP TS 24.008 Section 10.5.4.9.

  • Calling Party Number Inclusion ("CALL:CPNumber:INCLusion" on page 8): specifies whether or not the calling party number parameters ( CALL:CPNumber<[:SELected]> , CALL:CPNumber:PLAN , CALL:CPNumber:PRESentation[:INDicator] , CALL:CPNumber:SCReening[:INDicator] and CALL:CPNumber:TYPE ) are sent to the called mobile station. If Exclude is selected, the parameters are not included in the message.
    Calling Party Number is Excluded

    If Include is selected, the parameters are filled in the message that is sent out to the mobile station.

    Calling Party Number is Included
  • Calling Party Number ( CALL:CPNumber<[:SELected]> ): indicates the ASCII representation of each character in the calling party number.
  • Number Type ( CALL:CPNumber:TYPE ): specifies the type of number used for the calling party number.
    Number Type

    Test Set's front panel

    Description

    NUMBER_TYPE Field Value

    Unknown

    Unknown number type

    000

    International

    International number

    001

    National

    National number

    010

    Network

    Network specific number

    011

    Dedicated

    Dedicated PAD access, short code

    100
  • Number Plan ( CALL:CPNumber:PLAN ): specifies the numbering plan used for the calling party number.
    Number Plan
    Test Set's front panel Description

    NUMBER_PLAN Field Value

    Unknown

    Unknown numbering plan

    0000

    ISDN/Telephony

    ISDN/Telephony numbering plan

    0001

    Data

    Data numbering plan

    0011

    Telex

    Telex Numbering plan

    0100

    Private

    Private numbering plan

    1001

    National

    National numbering plan

             1000
  • Presentation Indicator ( CALL:CPNumber:PRESentation[:INDicator] ): specifies whether or not to allow the calling party number to be displayed on the called mobile station's screen.
    Presentation Indicator
    Test Set's front panel

    Description

    PI Field Value

    Allowed

    Presentation allowed

    00

    Restricted

    Presentation restricted

    01

    Number Not Avail

    Address not available

    10
  • Screening Indicator ( CALL:CPNumber:SCReening[:INDicator] ): specifies how the calling number is screened.
    Screening Indicator
    Test Set's front panel

    Description

    SI Field Value

    User No Screen

    User provided, not screened

    00

    User Verify Pass

    User provided, verified passed

    01
    User Verify Fail

    User provided, verified and failed

             10

    Network

    Network provided

    11

Related Topics

How Do I Perform Calling Party Number Verification?


CW Operating Mode

CW Operating Mode

December 20, 2004

Description

When in CW operating mode, the test set operates like a signal generator. The basic features provided by CW operating mode are:

  • No over the air signaling is used. Therefore there is no synchronization between the mobile station and test set.
  • No demodulation or channel decoding is available.
  • No automatic receiver control is provided. Expected CW power, measurement receiver frequency, and uplink receiver frequency are available as manual settings only.

    NOTE
    Manual receiver control settings made while using the CW operating mode can affect manual receiver settings made in other operating modes. When changing operating modes and using manual receiver settings, always verify that the manual receiver settings are correct for the new operating mode.

  • Any one of three test signals can be generated while analyzing another signal (at the same frequency or at a different frequency). No interaction exists between these controls.
  • All test set measurements are available while in CW operating mode. However, measurements requiring protocol triggering cannot be made. Immediate triggering should be used for most measurements because no overhead signaling is occurring. Protocol triggering will timeout or report an integrity indicator other than zero.

Test Signals Description

The test set in CW operating mode provides any one of three test signals: CW (no modulation), AM (fixed 56% amplitude modulation), and DSB-SC (dual side-band suppressed carrier). An example usage of the test signals is for calibrating mobile stations that use Qualcomm's radioOne™ Zero Intermediate Frequency (Zero IF) architecture.

You can select any one of three signals with adjustable power level and frequency for output to the currently selected front panel RF connector.

  • With CW test signal selected (the default setting), the test set provides an unmodulated carrier. With either AM or DSB-SC test signal selected, the test set will modulate the signal as shown in the following figure.
  • For any of the test signals selected, the output power level is controlled by the Cell Power ( F7 ). The Cell Power refers to the power found in the entire signal including sidebands if applicable.
  • For any of the test signals selected, the frequency is adjusted by changing the RF Gen Freq ( F8 ).
    • With the CW or AM signal selected, the RF Gen Freq setting represents the center frequency of the signal (fc).
    • With the DSB-SC signal selected, the RF Gen Freq setting represents the frequency of the lower sideband signal (fL). The upper sideband (fh) is 20 kHz above the RF Gen Freq setting, that is fh = fL+20 kHz.

NOTE
When in CW operating mode, switching the test signals requires a few seconds. This delay is also encountered when changing operating modes if the current test signal is not CW.

Programming Usage

Use the following commands to control each function for CW operating mode:

  • Select CW operating mode: CALL[:CELL]:OPERating:MODE
  • Set the cell power output level to be transmitted by the test set: CALL:POWer
  • Set the RF generator frequency: CALL[:CELL]:RFGenerator:FREQuency
  • Set the expected CW power level to be received by the test set: RFANalyzer:CW:EXPected:POWer
  • Set the measurement receiver frequency: RFANalyzer:MANual:MEASurement[:MFRequency]

Related Topics

Effects on Receiver Control When Changing Operating Mode


Downlink Channel (UARFCN)

Downlink Channel (UARFCN)

Last updated: December 22, 2004

DL Channel

The DL Channel setting specifies the downlink UTRA Absolute RF Channel Number (UARFCN). This determines at what frequency the test set's RF generator will transmit the downlink signal.

The relationship between UARFCN and downlink frequency is described in 3GPP TS 25.101 section 5.

Downlink Frequency and UARFCN, and DL Channel Range
Band TS 25.101
DL to UL Frequency Separation (MHz) 		TS 25.101
Center Frequency Range (MHz) 		TS 25.101
UARFCN Equation 		TS 25.101
UARFCN Range 		Test Set's "DL Channel" Range
(increment = 1 for all)
I
(IMT-2000) 		190 2112.4 - 2167.6,
increment = 0.2 		5 * (center freq in MHz)

10562 - 10838,
increment = 1

10525 - 10875
II
(U.S. PCS) 		80 1932.4 - 1987.6,
increment = 0.2 		5 * (center freq in MHz) 9662 - 9938,
increment = 1 		9625 - 9975
1932.5 - 1987.5,
increment = 5 		5 * ((center freq in MHz) - 1850.1 MHz)

412 - 687,
increment = 25

 412 - 687
III
(DCS/PCS) 		95 1807.4 - 1877.6,
increment = 0.2 		5 * (center freq in MHz) 9037 - 9388,
increment = 1 		9000 - 9425
IV 400 2112.4 - 2152.6,
increment = 0.2 		5 * (center freq in MHz) 10562 - 10763,
increment = 1 		Not supported *
2112.5 - 2152.5,
increment = 5 		5 * ((center freq in MHz) - 1820.1 MHz) 1462 - 1662,
increment = 25 		Not supported
V
(US Cellular) 		45 871.4 - 891.6,
increment = 0.2 		5 * (center freq in MHz) 4357 - 4458,
increment = 1 		Not supported **
871.5, 872.5, 876.5, 877.5, 882.5, 887.5 | 5* ((center freq in MHz) - 670.1 MHz) | 1007, 1012, 1032, 1037, 1062, 1087 | Not supported **
VI
(Japan 800) 		45 877.4 - 882.6,
increment = 0.2 		5 * (center freq in MHz) 4387 - 4413,
increment = 1 		4320 - 4495
877.5, 882.5 | 5 * ((center freq in MHz) - 670.1 MHz) | 1037, 1062 | 1037 - 1062
The test set also supports a DL Channel range of 4600 - 4825, which corresponds to a center frequency range of 920 - 965 MHz (UARFCN = 5 * (center freq in MHz)).

* You can set DL Channel to 10525 - 10875 and the test set's source will be set to the correct frequency, however no Frequency Band Indicator Information Element will be included in SIB 5 as required for this band by 3GPP TS 25.331 10.3.6.35b.

** You can set DL Channel to 1037, 1062, and 4320 - 4495 and the test set's source will be set to the correct frequency, however the Frequency Band Indicator Information Element of SIB 5 will be set to Band VI (see 3GPP TS 25.331 10.3.6.35b). The Frequency Band Indicator Information Element is only included in SIB 5 when DL Channel is set to a Band VI UARFCN.

When in FDD Test operating mode, the downlink frequency can also be set by setting RF Gen Freq Ctrl to Manual and then manually entering the RF Gen Freq (see RF Generator Frequency ).

To set the downlink channel number from the front panel, see Setting DL Channel, Uplink Channel and Uplink Separation .

To set the downlink channel number via GPIB command, see CALL:CHANnel .

Operating Considerations

  • This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in an error and the test set rejects the change. Use the Cell Off operating mode when changing this setting. See CALL:OPERating to select operating modes.
  • To hand over to a new downlink channel while on a connection, you must perform a Physical Channel Reconfiguration . After successful completion of a handover to a new DL UARFCN, the DL Channel setting is overwritten with the value of Handoff Downlink UARFCN .
  • If Uplink Channel is set to Auto , and you attempt to set DL Channel to a value that would result in an Uplink Channel that is not within the supported range (based on the current Uplink Separation setting), an error is posted and the change is rejected. With Uplink Channel not set to Auto , set DL Channel and Uplink Separation to a valid combination, then set Uplink Channel to Auto .
  • If the DL Channel setting results in an UL/DL offset of less than 30 MHz when compared with the Uplink Channel setting, the warning message "Performance not specified for UL/DL frequency offset <30 MHz" is issued.

Related Topics

Manual Operation: Setting DL Channel, Uplink Channel and Uplink Separation

CALL:CHANnel

Troubleshooting Call Processing Operations

Uplink Channel (UARFCN)

Handoffs (Handovers)


Downlink Channel Codes and Levels

Downlink Channel Codes and Levels

Last updated: December 22, 2004

While in Active Cell Operating Mode , downlink scrambling and channelization codes are used by the UE (mobile station) to synchronize to the base station emulator's frame clock and to specify message formats for call processing operations.

The relative level of all downlink channels can be individually set or turned off except that the P-CCPCH and the SCH are controlled together. The level of each active channel is a fraction of the Cell Power setting, expressed in dB. If the summed level of all channels is less than one, the orthogonal coded noise source (OCNS) is turned on to account for the difference (see Orthogonal Channel Noise Simulator (OCNS) ).

Setting Downlink Channel Codes

Downlink Channel Codes can only be changed during Cell Off operation.

To set the Primary Scrambling Code, or the channelization code for the S-CCPCH, PICH or AICH from the front panel, see How Do I Change Generator Information? , or use the following GPIB commands:

  • Primary Scrambling Code

    CALL:SCODe .

  • Secondary Common Control Physical Channel (S-CCPCH) Channelization Code

    CALL:CCPChannel:SECondary:CCODe .

  • Page Indicator Channel (PICH) Channelization Code

    CALL:PICHannel:CCODe .

  • Acquisition Indicator Channel (AICH) Channelization Code

    CALL:AICHannel:CCODe .

The method for setting downlink DPCH channel codes differs between the test application and lab application. The following table illustrates the valid channelization codes for each type of DPCH channel, and indicates the GPIB commands and front panel fields (see How Do I Change Generator Information? to help you find these fields) used to set the channelization codes, for both the test application and lab application.

Downlink DPCH Channel Types vs. Channelization Code Selection
Downlink Channel Type | Valid Channelization Codes | Test Application Front Panel Setting and GPIB Command | Lab Application Front Panel Setting and GPIB Command
Signalling Radio Bearers: (see Signalling Radio Bearer (SRB) Configuration )
2.2k DCCH | 12/13/20/21/40/43/ 58/126/127/142/ 153/174/235/255 | 3.4k SRB Channelization Code, CALL:SRBearer | DPCH 15 ksps (OVSF 256) Channelization Code, CALL:DPCHannel:KSPS15[:CCODe]
3.4k DCCH | 12/13/20/21/40/43/ 58/126/127/142 /153/174/235/255 | 3.4k SRB Channelization Code, CALL:SRBearer | DPCH 15 ksps (OVSF 256) Channelization Code, CALL:DPCHannel:KSPS15[:CCODe]
13.6k DCCH | 6/9/10/20/29/37/ 45/54/60/63/70/76/ 87/93/112/118 | DPCH 12.2k RMC & 33k NC RMC Channelization Code, CALL:DPCHannel:RMC12:CCODe | DPCH 30 ksps (OVSF 128) Channelization Code, CALL:DPCHannel:KSPS30[:CCODe]
Radio Bearer Test Mode Reference Measurement Channels: (see Radio Bearer Test Mode )
12.2k RMC | 6/9/10/20/29/37/ 45/54/60/63/70/76/ 87/93/112/118 | DPCH 12.2k RMC & 33k NC RMC Channelization Code, CALL:DPCHannel:RMC12:CCODe | DPCH 30 ksps (OVSF 128) Channelization Code, CALL:DPCHannel:KSPS30[:CCODe]
64k RMC | 6/10/12/14/16/18/ 20/22/24/25/26/27 | DPCH 64k RMC Channelization Code, CALL:DPCHannel:RMC64:CCODe | DPCH 120 ksps (OVSF 32) Channelization Code, CALL:DPCHannel:KSPS120[:CCODe]
144k RMC | 12/13 | DPCH 144k RMC Channelization Code, CALL:DPCHannel:RMC144:CCODe | DPCH 240 ksps (OVSF 16) Channelization Code, CALL:DPCHannel:KSPS240[:CCODe]
384k RMC | 6 | DPCH 384k RMC Channelization Code, CALL:DPCHannel:RMC384:CCODe | DPCH 480 ksps (OVSF 8) Channelization Code, CALL:DPCHannel:KSPS480[:CCODe]
33k No Coding RMC | 6/9/10/20/29/37/ 45/54/60/63/70/76/ 87/93/112/118 | DPCH 12.2k RMC & 33k NC RMC Channelization Code, CALL:DPCHannel:RMC12:CCODe | DPCH 30 ksps (OVSF 128) Channelization Code, CALL:DPCHannel:KSPS30[:CCODe]
12.2k UL/64k DL AM RMC | 6/10/12/14/16/18/ 20/22/24/25/26/27 | DPCH 64k RMC Channelization Code, CALL:DPCHannel:RMC64:CCODe | DPCH 120 ksps (OVSF 32) Channelization Code, CALL:DPCHannel:KSPS120[:CCODe]
12.2k UL/144k DL AM RMC | 12/13 | DPCH 144k RMC Channelization Code, CALL:DPCHannel:RMC144:CCODe | DPCH 240 ksps (OVSF 16) Channelization Code, CALL:DPCHannel:KSPS240[:CCODe]
12.2k UL/384k DL AM RMC | 6 | DPCH 384k RMC Channelization Code, CALL:DPCHannel:RMC384:CCODe | DPCH 480 ksps (OVSF 8) Channelization Code, CALL:DPCHannel:KSPS480[:CCODe]
64k UL/384k DL AM RMC | 6 | DPCH 384k RMC Channelization Code, CALL:DPCHannel:RMC384:CCODe | DPCH 480 ksps (OVSF 8) Channelization Code, CALL:DPCHannel:KSPS480[:CCODe]
AMR Voice Radio Access Bearer: (see AMR Voice )
12.2k AMR Voice | 6/9/10/20/29/37/ 45/54/60/63/70/76/ 87/93/112/118 | DPCH 12.2k RMC & 33k NC RMC Channelization Code, CALL:DPCHannel:RMC12:CCODe | DPCH 30 ksps (OVSF 128) Channelization Code, CALL:DPCHannel:KSPS30[:CCODe]
Circuit Switched Data Radio Access Bearers: (see CS (Circuit Switched) Data Service )
14.4k UL/14.4k DL CS Data RAB | 6/9/10/20/29/37/ 45/54/60/63/70/76/ 87/93/112/118 | Not applicable to the test application. | DPCH 30 ksps (OVSF 128) Channelization Code, CALL:DPCHannel:KSPS30[:CCODe]
57.6k UL/57.6k DL CS Data RAB | 6/10/12/14/16/18/ 20/22/24/25/26/27 | Not applicable to the test application. | DPCH 120 ksps (OVSF 32) Channelization Code, CALL:DPCHannel:KSPS120[:CCODe]
64k UL/64k DL CS Data RAB | 6/10/12/14/16/18/ 20/22/24/25/26/27 | DPCH 64k RMC Channelization Code, CALL:DPCHannel:RMC64:CCODe (feature license required) | DPCH 120 ksps (OVSF 32) Channelization Code, CALL:DPCHannel:KSPS120[:CCODe]
GPRS Radio Access Bearers: (see GPRS Packet Data Service )
64k UL/64k DL PS Data RAB | 6/10/12/14/16/18/ 20/22/24/25/26/27 | Not applicable to the test application. | DPCH 120 ksps (OVSF 32) Channelization Code, CALL:DPCHannel:KSPS120[:CCODe]
64k UL/384k DL RMC | 6 | Not applicable to the test application. | DPCH 480 ksps (OVSF 8) Channelization Code, CALL:DPCHannel:KSPS480[:CCODe]
64k UL/384k DL PS Data RAB | 6 | Not applicable to the test application. | DPCH 480 ksps (OVSF 8) Channelization Code, CALL:DPCHannel:KSPS480[:CCODe]

Setting Downlink Channel Levels

Active Cell operating mode emulates a base station in operation, and is used for call processing operations. During call processing, the downlink channel levels for idle mode may be different than the levels used during a call. This is why there are two different level settings for the downlink codes: Downlink Channel Levels and Connected DL Channel Levels .

  • Downlink Channel Levels

    The Downlink Channel Levels set of power levels is used when RRC State is Idle or CELL_FACH .

    NOTE
    No DPCH is generated before the call is established. Setting Downlink Channel Levels : DPCH Level to a non-zero value simply adds that power to the OCNS.

    These levels can only be changed in the Cell Off operating mode. You can query these settings via GPIB and view them on the front panel during Active Cell mode operation, but attempting to change the levels during Active Cell mode operation results in an error message.

  • Connected DL Channel Levels

    The Connected DL Channel Levels are used when RRC State is CELL_DCH . These levels are applied after the RRC Connection Setup message is sent by the test set during the RRC Connection Setup Procedure , directing the UE to go into CELL_DCH (i.e. once a DPCH has been established). When the DPCH channel is released, the test set transitions back to the Downlink Channel Levels set.

    NOTE
    PO1, PO2 and PO3, which define the offset of the TFCI, TPC and pilot fields of the DPCCH relative to the DPDCH's power (see 3GPP TS 25.214 5.2.1.1) are always set to 0 in the test set (as specified by 3GPP TS 25.101 A.3 and 34.121 C.3).

    These levels can be changed while using either the Active Cell or Cell Off operating modes. This allows you to vary the relative channel levels while a call is connected in order to test the UE's response.

To change these settings from the front panel, see How Do I Change Generator Information? . After then, all your changes will be displayed in the Downlink Code Channel Information table as shown in The Downlink Code Channel Information on the Generator Information Screen .

The Downlink Code Channel Information on the Generator Information Screen

Orthogonal Channel Noise Simulator (OCNS)

OCNS is used to simulate additional users on the downlink. OCNS is automatically enabled when the sum of the levels of all the enabled downlink physical channels is less than the cell power setting. OCNS is made up of the following 16 separate code channels: 2, 11, 17, 23, 31, 38, 47, 55, 62, 69, 78, 85, 94, 113, 119, and 125. All channels use a spreading factor of 128. The current setting is displayed in the Downlink Code Channel Information window on the test set.

As individual downlink channel levels are adjusted, the composite OCNS level is automatically set to a value equal to the difference between the summed downlink channel levels and the cell power setting. The fraction of the composite OCNS power that is allocated to each of the code channels making up the composite OCNS varies for each channel, and cannot be changed. See CALL:OCNSource .

GPIB Commands for Setting Downlink Channel Levels in Cell Off Mode

  • Common Pilot Channel (CPICH) Level

    GPIB command: CALL:CPIChannel

  • The Primary Common Control Physical Channel (P-CCPCH) and the Synchronization Channel (SCH) are time multiplexed, and use the same level for both channels.

    GPIB command: CALL:CCPChannel:PRIMary[:SLEVel]

  • Secondary Common Control Physical Channel (S-CCPCH) Level

    GPIB command: CALL:CCPChannel:SECondary[:SLEVel]

  • Page Indicator Channel (PICH) Level

    GPIB command: CALL:PICHannel[:SLEVel]

  • Acquisition Indicator Channel (AICH) Level

    GPIB command: CALL:AICHannel

  • Dedicated Physical Channel (DPCH) Level

    GPIB command: CALL:DPCHannel[:SLEVel]

GPIB Commands for Changing Connected Downlink Channel Levels

  • Connected Common Pilot Channel (CPICH) Level - CALL:CONNected:CPIChannel[:SLEVel]
  • The Connected Primary Common Control Physical Channel (P-CCPCH) and the Synchronization Channel (SCH) are time multiplexed, and use the same level for both channels - CALL:CONNected:CCPChannel:PRIMary[:SLEVel]
  • Connected Secondary Common Control Physical Channel (S-CCPCH) Level - CALL:CONNected:CCPChannel:SECondary[:SLEVel]
  • Connected Page Indicator Channel (PICH) Level - CALL:CONNected:PICHannel[:SLEVel]
  • Dedicated Physical Channel (DPCH) Level - CALL:CONNected:DPCHannel[:SLEVel]

Considerations When Setting Code Channel States and levels

  • All code channels have the range of 0 to -20 dB, except the relative power level of the DPCH channel ranges from 0 to -30 dB.
  • Any code channel powers that are ON must not be greater than 30 dB below the Total RF Power.

Related Topics

How Do I Change Generator Information?

Cell Power and AWGN Power

Signalling Radio Bearer (SRB) Configuration

Active Cell Operating Mode

Cell Off Operating Mode


Other Downlink Parameters

Other Downlink Parameters

Last updated: December 22, 2004

The following parameters are provided to define the contents of the downlink signal to the UE (mobile station) while the call is connected, and to control the call connection behavior. To access these parameters from the front panel, see How Do I Change Call Parameters? .

DL DTCH Data

The data pattern of the DTCH Data (user data) sent on the DPCH can be set to:

  • CCITT PRBS15 - a 15-bit pseudo-random bit sequence.
  • CCITT PRBS9 - a 9-bit pseudo-random bit sequence.
  • All Zeroes - a continuous series of 0's. This setting can be used to help quickly find CRC errors when viewing the UL DTCH data using the Protocol Logging functionality of the lab application.
  • All Ones - a continuous series of 1's.
  • Incrementing - a 16 bit data pattern that starts at 0000000000000000 and increments by 1 each TTI (i.e. 0000000000000001, 0000000000000010 etc.). This setting can be used to identify a missing block or shifted bit pattern.
You can use the test set's loopback bit error ratio measurement (see Loopback Bit Error Ratio Measurement Description ) or use your UE's built-in bit error reporting (if available) to determine if the UE has correctly decoded the data stream.

Paging Indicator Channel (PICH) Data

The paging indicator channel can be set to transmit either all zeroes or all ones. While in Active Cell operating mode, the PICH contents will initially be set to all zeroes in all paging indicators ("no page"). Once call origination is initiated, all of the page indicators in each valid access frame will be set to all ones indicating a page. The valid access frames occur at times specified by the DRX cycle length. Once the UE has responded to the page the paging indicators will return to "no page".

RLC Reestablish

The RLC re-establishment procedure automatically occurs during the radio bearer setup portion of call establishment as the DPCH is reconfigured from the signalling radio bearer (3.4K or 13.6K DCCH) to the actual service configuration. For the early UEs (mobile stations) that do not support the RLC reestablishment, the test set allows you to turn off the RLC re-establishment procedure and select an Agilent proprietary SRB configuration (2.2k DCCH). See also Signalling Radio Bearer (SRB) Configuration .

Call Limit State

When the call limit state is on, the test set does not respond to any PRACH preambles from the UE. Call Limit must be OFF for any random access procedure, such as Location Update or BS Origination to be successful (see Establishing a Connection with the UE ).

Once the random access procedure has been initiated with Call Limit set to "ON", the Test Set will appear to be "hung" indefinitely. You must end the call to terminate the procedure and return the Call Status to "IDLE". (See End a Connection or CALL:END .)

Call Drop Timer

The call drop timer can be turned off or on. When turned on, anytime the uplink signal is not detected, the test set only waits the length of the timer before assuming the call has been dropped by the UE. This timer is optimized for the manufacturing test environment. The timers defined in the 3GPP standards for determining that a call has been dropped are much longer. Turning on the call drop timer allows you to quickly identify UEs that can not maintain a call and remove them from your test area.

GPIB Commands for Setting DTCH Parameters

  • Downlink DTCH Data - CALL:DTCHannel:DATA
  • Downlink Paging Indicator Channel Data - CALL:PICHannel
  • RLC Reestablish - CALL[:CELL[1]]:RLC:REEStablish
  • Call Limit State - CALL:CONNected:LIMit[:STATe][:SELected]
  • Call Drop Timer - CALL:CONNected:DROP:TIMer[:STATe][:SELected]

Related Topics

How Do I Change Call Parameters?


Cell Power and AWGN Power

Cell Power and AWGN Power

Last updated: December 20, 2004

The test set's base station emulator provides control over the following RF power levels:

  • Cell Power

    Îor is defined in 3GPP TS 25.101 as the received power spectral density of the downlink as measured at the UE (mobile station) antenna connector. The downlink contains one or more downlink physical channels. The Cell Power setting sets the absolute level (in dBm) of the physical channels. The individual physical channel levels account for fractions of this setting, and are set in dB relative to the cell power (see Downlink Channel Codes and Levels ). If you have accounted for path loss (see Amplitude Offset ) between the test set output port and the UE antenna connector, then cell power is equivalent to Îor.

  • AWGN Power

    Ioc is defined in 3GPP TS 25.101 as the power spectral density of a band-limited white noise source (simulating interference from other cells) as measured at the UE antenna connector. If you have accounted for path loss, then AWGN (Additive White Gaussian Noise) power is equivalent to Ioc.

  • Total RF Power

    Io is defined in 3GPP TS 25.101 as the total received power spectral density, including signal and interference, as measured at the UE antenna connector. The total RF power is the sum of cell power and AWGN power. If you have accounted for path loss, then total RF power is equivalent to Io.

NOTE
No signal is generated by the test set during Cell Off operation, regardless of the Cell Power setting. All settings are deferred until the Active Cell operating mode or FDD Test operating mode is used.

To access the cell power parameter using the test set's front panel, see How Do I Change Call Parameters? .

To access the AWGN power parameter using the test set's the front panel, How Do I Change Generator Information?

These power parameters are displayed in the Generated Power Level Information table.

Generated Power Level Information (Test Application)

Generated Power Level Information (Lab Application)

For the lab application only, the test set has the ability to simulate two individual cells (see Soft Handoff ). In the lab application, the total RF power consists of Cell 1 power, Cell 2 power and the AWGN power if their states are on.

For the lab application, an external AWGN value is displayed when the test set is configured to generate faded forward channel signals with AWGN enabled. This setup requires a rear panel digital bus connection to an external PC running Baseband Studio software. For details, see Digital Bus Information .

Cell Power, AWGN Power and Total RF Power Ranges

The range of values that you can set these power levels to differs from the actual hardware range of the source. This is due to compensation for path loss between the test set RF output port and the UE antenna connector (see Amplitude Offset ).

For example, if you enter a value of -30 dBm for desired CW cell power, this indicates that you want -30 dBm of power at the UE antenna connector. So, if you have indicated an amplitude offset of -3.5 dB exists between the test set's RF In/Out port and the UE antenna connector, the source will actually have to output -26.5 dB in order to deliver -30 dB to the UE's antenna connector. Thus, with an amplitude offset of -3.5 dB, the settable range of CW cell power is -130.5 dB to -13.5 dB. The actual power range at a given time is defined by adding the value of the associated amplitude offset to the actual hardware range. If you select an invalid combination of power levels and amplitude offsets, an error message will appear at the bottom of the screen to alert you to this condition.

Range of Power Levels
Parameter | Actual Hardware Range with Amplitude Offset = 0 (RF In/Out Port) | Setting (or Query) Range
Cell Power (CW) | -127 dBm to -10 dBm | -177 dBm to +40 dBm
Cell Power (FDD) | -115 dBm/3.84 MHz to -13 dBm/3.84 MHz | -165 dBm/3.84 MHz to +37 dBm/3.84 MHz
AWGN Power (FDD) | -115 dBm/3.84 MHz to -15 dBm/3.84 MHz | -165 dBm/3.84 MHz to +35 dBm/3.84 MHz
Total RF Power | -115 dBm/3.84 MHz to -10.88 dBm/3.84 MHz | -165 dBm/3.84 MHz to +42 dBm/3.84 MHz

GPIB Commands for Setting the RF Power Levels

The test set includes commands to set the desired cell power and AWGN power levels. You may also query what you've set these desired power levels to, as well as query what the total RF power will be based on your desired cell power and AWGN power levels. See RF Power Levels .

The test set also includes commands to query the current level of cell power, AWGN power, and total RF power. See RF Power Levels . These CALL:STATus commands are query only. They return values that indicate the test set's actual hardware settings and hardware status. Actual hardware settings can differ from the desired level you've set. When no error conditions exist, the commands used to set the desired level will return the same results as the commands used to query current level. For example, "CALL:AWGNoise:POWer?" will return the same value as "CALL:STATus:AWGNoise:POWer?" when no error conditions exist.

RF Power Levels
Parameter | Current Level | Desired Level
Cell Power | CALL:STATus:CELL:POWer[:AMPLitude]? | CALL:POWer
AWGN Power | CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude]? | CALL:AWGNoise
Total RF Power | CALL:STATus:TOTal:POWer[:AMPLitude]? | CALL:TOTal:POWer[:AMPLitude]? (query only)

Considerations When Setting Power Levels

  • The difference between cell power and AWGN power must not be more than 10 dB when both power states are set to ON.
  • The total RF power and amplitude offset must not set the source outside its valid hardware range.

Related Topics

How Do I Change Generator Information?

How Do I Change Call Parameters?

Active Cell Operating Mode

FDD Test Operating Mode

Downlink Channel Codes and Levels


Signalling Radio Bearer (SRB) Configuration

Signalling Radio Bearer (SRB) Configuration

Last updated: December 22, 2004

The test set supports 3.4k DCCH or 13.6 DCCH configuration of the signalling radio bearer (SRB) as specified in the W-CDMA specifications. They are used during RRC connection (see Channels Used for Call Setup ). Once the RRC connection has been established, the downlink DPCH is reconfigured to the reference measurement channel (RMC) selected in the Channel Type field (see Channel Type and Paging Service ) during the Radio Bearer Setup portion of the BS origination procedure.

The test set also provides an Agilent proprietary SRB configuration, 2.2k DCCH, for UEs which do not support RLC reestablish during Radio Bearer Setup. To turn off the RLC reestablish function from the test set, see RLC Reestablish .

To choose which DCCH configuration to use for the signalling radio bearer from the front panel, see How Do I Change Call Parameters? ( SRB Config ( F12 )) or use the CALL[:CELL]:SRBearer:CCHannel:DEDicated:DRATe GPIB command.

To set the channelization code for the signalling radio bearer, see Setting Downlink Channel Codes .

Operating Considerations

  • These settings cannot be changed during Active Cell operation. Instead, use the Cell Off operating mode when changing these settings. Attempting to change these settings while in Active Cell operating mode results in an error issued and the test set will reject the change. See CALL:OPERating to select operating modes.

Related Topics

How Do I Change Call Parameters?


FDD Test Operating Mode

FDD Test Operating Mode

Last updated: December 20, 2004

In FDD Test (frequency division duplex) Operating Mode , the test set does not send any signalling information on the downlink. Any changes to the UE (mobile station) configuration, such as channel, uplink power level, or dedicated physical channel (DPCH) scrambling code, must be accomplished by directly sending commands to the UE from a system controller (usually a personal computer) through a proprietary digital interface.

Upon entry into test mode, the test set begins continuously transmitting a downlink signal which consists of a dedicated physical channel (DPCH) configured as the specified symmetric reference measurement channel (RMC) (see Symmetrical RMCs ) and several overhead channels required to allow the UE to synchronize to the test set and decode transmitted data (see Downlink and Uplink Channels Overview ). The UE must then synchronize to the transmitted downlink channels and start transmitting a corresponding uplink signal. The UE's performance can then be measured using the suite of measurements shown when the Measurement selection key is pressed. To emulate the interference from other cells or uses, two noise sources (OCNS and AWGN) can be added as desired.

NOTE
As there is no signalling information sent on the downlink by the test set while in FDD Test mode, there is no S-CCPCH and AICH downlink physical channels or PRACH uplink channel.

The following example selects FDD Test operating mode via GPIB:

OUTPUT 714;"CALL:OPERating:MODE FDDT"

Synchronizing the UE to the Test Set's Downlink to Make Measurements

The following test set controls must match your UE configuration to allow it to synchronize to the test set's downlink signal and transmit an uplink signal that the test set can receive and measure:

  • Channel Type - The UE must support Symmetrical RMCs .
  • Downlink Channel - The UE must be set to receive the downlink signal on this channel.
  • Uplink Channel - The UE must be set to transmit an uplink signal on this channel.
  • Downlink Channel Codes - The UE must be set to expect the following code settings from the test set on the downlink:
    • Primary Scrambling Code
    • PICH Channelization Code (if the UE responds to this channel in test mode)
    • DPCH Channelization Code
  • Transport Format Combination Indicator Pattern (TFCI) - The UE must be able to decode the TFCI and correctly configure itself to accept the downlink data (in this case, the format for the selected RMC).
  • Cell Power - The power level out of the test set must be high enough for the UE to receive the downlink signal and decode the data.
  • Uplink Scrambling Code - The scrambling code the UE is transmitting on the uplink signal.
  • MS Target Power - The power level at which the UE is expected to transmit.

Downlink Channel Codes and Power Level Settings

In test mode, the test set can be configured to transmit a downlink signal which consists of a number of physical channels, and also OCNS and AWGN are available if desired. See W-CDMA Channels .

The relative level, desired level, spreading factor, and channel code for each of these channels is displayed in the Downlink Code Channel Information window on the Call Setup Screen.

Channel Codes

The following downlink channel codes can be specified:

  • Primary scrambling code ( CALL:SCODe ). This value must match the UE expected downlink scrambling code in order for the UE to decode the downlink channels and synchronize to the test set. The current setting is displayed in the Downlink Code Channel Information window on the test set. This value is used to configure the secondary synchronization channel (S-SCH).
  • PICH channelization code ( CALL:PICHannel ).
  • DPCH RMC channelization codes ( CALL:DPCHannel )

Channel Levels

The relative level of all FDD test channels can be individually set or turned off (although the P-CCPCH and the SCH are controlled together). The level of each active channel is a fraction of the total cell power, expressed in dB. If the summed level of all channels is less than one, OCNS is turned on to account for the difference. See CALL:FDDTest .

Noise Sources on the Downlink

  • Additive White Gaussian Noise (AWGN) - used to simulate interference from other cells and mobiles when enabled. See Cell Power and AWGN Power .
  • Orthogonal Channel Noise Simulator (OCNS) - used to simulate additional users on the downlink. OCNS is automatically enabled when the sum of the levels of all the enabled downlink physical channels is less than the cell power setting. See Downlink Channel Codes and Levels .

Other Downlink Signal Settings

Cell Power

This setting specifies the combined power level of all code channels on the downlink from the test set, expressed in dBm/3.84 MHz (including OCNS, if used). This does not include AWGN power.

The Call Setup Screen displays a window entitled Generated Power Level Information . The Total RF Power listed in that window is the sum of the Cell Power and AWGN Power levels. The power level at the RF IN/OUT or RF OUT ONLY connector is the Current Level of the Total RF Power plus any amplitude offsets that have been entered. See Amplitude Offset for more information on entering amplitude offsets.

MS Target Power

This setting specifies the expected power level from the UE (mobile station). When using automatic receiver control (the default setting), the test set uses the MS Target Power setting to set the input range for its measurement and uplink receivers. If the transmitted level from the UE is above or below the range expected by the receivers, an Under Range or Over Range message and integrity indicator are produced. This setting is not used during manual receiver control.

This setting does not anticipate a change in UE power output when sending closed loop power control changes or transmit power control (TPC) commands during FDD Test mode operation. It is only used to indicate the expected power level from the UE as determined by the user. See Receiver Control for information on setting the expected power level into the test set.

Transport Format Combination Indicator Pattern

The TFCI pattern tells the UE which transport formats to use for communications between the downlink physical channels protocol layer (L1) and the medium access control (MAC) layer. In FDD Test mode, this value does not correspond to any specific transport channel format; it is provided to allow the user to determine if their UE is correctly decoding this value.

If the UE is configured to respond to the TFCI, this value must match the UE transport format configuration in order for the UE to decode the downlink channels and synchronize to the test set. See CALL:FDDTest .

Power Control Settings

Power control commands can be sent by specifying the uplink closed loop power control data or by sending transmit power control (TPC) step up/step down bit patterns. However, the user must verify that the UE correctly decoded the power control data, either by verifying that the power level from the UE did change or by looking at the UE decoded downlink data. If the UE power output does change in response to the change order, the user must change the test set's expected power level (MS Target Power) when making measurements that do not use autoranging. See MS Target Power . See also CALL:CLPControl and CALL:FDDTest:CLPControl:UPLink:MODE for a description of the GPIB commands for power control.

DL PICH Data

Downlink paging indicator channel data can be set to all ones or all zeroes. However, the user must verify that the UE has correctly decoded the page indicator data. See CALL:FDDTest:PICHannel:DATA .

Traffic Channel (DTCH) Data

Downlink dedicated traffic channel (DTCH) data of various types can be sent. To determine if the UE has correctly decoded the data stream, you can use the test set's loopback bit error ratio measurement or use your UE built in bit error reporting (if available). See CALL:DTCHannel:DATA .

Downlink Channel

When the RF generator frequency control (RF Gen Freq Ctrl) is set to auto, the downlink channel setting automatically adjusts the center frequency for the test set's RF generator based on the specified channel number. See CALL:CHANnel .

RF Generator Frequency

To set a downlink frequency that does not correspond to a defined channel number, you can set the RF generator frequency control to manual. When manual RF generator control is used, the downlink channel (DL Channel) control is replaced by the RF generator frequency (RF Gen Freq Ctrl) control to allow manual entry of the RF generator frequency. See CALL[:CELL]:CONTrol:DOWNlink:FREQuency:AUTO and CALL[:CELL]:RFGenerator:FREQuency .

Uplink Settings

Closed Loop Power Control Data

Closed loop power control data can be set using four formats while in FDD Test operating mode: alternating (up/down) bits, all up bits, all down bits, 10 up bits & 10 down bits. See CALL:FDDTest:CLPControl:UPLink:MODE .

Uplink Channel

When the test set is using automatic receiver control (the default), the uplink channel setting sets the test set's receivers to the expected UE uplink channel frequency. If manual receiver control is selected, the Measurement Frequency and Uplink Frequency settings are used to manually enter the receiver frequencies. See CALL:UPLink:CHANnel[:MCHannel] . See also Receiver Control for information about automatic and manual receiver settings.

Uplink Scrambling Code

This setting tells the test set which scrambling code to use to decode the uplink signal from the UE (mobile station). This setting must match the UE uplink scrambling code to make waveform quality and loopback bit error ratio measurements. See CALL:UPLink:DPCHannel:SCODe .

Receiver Control Settings

The expected power into the test set, and the frequency of the signal being measured, can be set either automatically or manually. Automatic receiver control is the default mode, and provides the simplest form of operation. Manual control is typically used to enter values that are different from those normally set during automatic control. See Receiver Control for more information on how manual and automatic receiver control are used.

Operating Considerations

The test set can perform thermal power, channel power, waveform quality, and adjacent channel leakage ratio (ACLR) measurements on the uplink signal. Loopback bit error ratio (BER) can be tested if the UE provides a loopback mode that conforms to 3GPP TS 34.109, section 5.3.2.6.2, Loopback of RLC SDUs . For either the loopback BER or modulation quality measurements to function, the uplink dedicated physical data channel (DPDCH) spreading factor must be the minimum allowed for the channel type; which is 64 for the 12.2 kbps reference measurement channel. Additionally, for the loopback BER measurement, the uplink DPDCH transport format must be set so both the dedicated traffic channel (DTCH) and dedicated control channel (DCCH) are present (however, the test set will ignore the contents of the DCCH so the actual content of this channel is not relevant).

When the test set and the UE are synchronized, the UE uplink frame starts 1024 chips after the receiving the corresponding downlink frame. Measurements that require synchronization will not trigger correctly (or at all) if this timing relationship does not exist.

In FDD Test operating mode, the test set does not negotiate with the UE to set up a call, or provide any other form of interactive control of the UE. User-selected patterns of power control (TPC) or transport format indication (TFCI) commands can be sent to the UE on the downlink, but the test set does not assume or verify that the UE responded. The test set ignores transport format combination indicator (TFCI) and transmit power control (TPC) bits sent on the uplink.

Related Topics

Cell Power and AWGN Power


Paging IMSI

Paging IMSI

Last updated: December 20, 2004

If you know the UE's International Mobile Subscriber Identity (IMSI), you can enter it under Paging IMSI (see CALL:PAGing:IMSI[:SELected] ) and proceed directly to originating a call even if the UE has not registered. Otherwise, you must wait for the UE to report its IMSI value upon registering with the test set. See Performing a Location Update (Registration) .

Related Topics

Establishing a Connection with the UE


Radio Bearer Test Mode Setup

Radio Bearer Test Mode Setup

Last updated: December 20, 2004

You can configure the following characteristics of the RMC channels when operating in RB Test Mode (see Channel Type and Paging Service ). These parameters can only be changed when the call status is idle.

  • RB Test Mode RRC State Setting

    In the lab application only, this setting controls whether the RB Test Mode service will set the UE up into a CELL_FACH or CELL_DCH state.

    GPIB command: CALL:SERVice:RBTest:RRC:STATe .

    To query the current RRC State, see RRC State .

  • Uplink DTCH RMC CRC Presence

    This setting controls whether the uplink transport channel carrying the DTCH has a Cyclic Redundancy Check (CRC) field or whether the bits that would normally be used for this CRC field are used to carry data instead. If this parameter is set to Present , then the test set assumes that the bits in the CRC field are actual CRC bits for the uplink transport block. If the parameter is set to Used for Data , then the test set assumes that the bits in the CRC field are just data bits. In other words, the UE is NOT sending uplink CRC bits, but instead is sending more data bits in their place (such as looped back downlink CRC bits).

    Uplink DTCH RMC CRC Presence must be set to Present when performing the loopback BER measurement (see Loopback Bit Error Ratio Measurement Description ) so that the measurement can detect and report any uplink CRC errors that occur while the measurement is running (any uplink errors that occur during receiver testing invalidate the results, and must be considered).

    Uplink DTCH RMC CRC Presence must be set to Used for Data when performing the loopback block error ratio measurement for Symmetrical RMCs (see Block Error Ratio Measurement Description ). This disables the uplink CRC, to allow room for the UE to loop back the downlink CRC for each block (there are an equal number of bits in the uplink and downlink transport blocks, if the UE were to transmit an uplink CRC, it would not be able to loop back the downlink CRC).

    GPIB command: CALL:SERVice:RBTest:DTCHannel:CRC:PRESence .

  • Uplink Dummy DCCH Data

    3GPP TS 34.109 section 5.3.2.8 specifies that when UE test loop mode 1 or 2 is active, if DCCH dummy mode is enabled and there is no DCCH data to be sent, then the UE shall set all bits in the uplink DCH transport block associated with a DCCH to 1. Thus, if the Uplink Dummy DCCH Data parameter in the test set is set to On, the test set discards any received DCH transport blocks associated with a DCCH having its bits set to 1.

    GPIB command: CALL:UPLink:DCCHannel:DDATa .

  • UE Loopback Type

    This setting controls which loopback mode the Test control (TC) protocol layer instructs the UE to go into. This is signaled to the UE in the Close UE Test Loop message. In Type 1 loopback mode, the loopback point is just above the traffic plane RLC entities (see 3GPP TS 34.109, 5.3.2.6). In Type 2 loopback mode, the loopback point is just above the layer 1 transport channels (see 3GPP TS 34.109, 5.3.2.7).

    Typically, you should set MS Loopback Type to Type 1 when performing the loopback bit error ratio measurement (see Loopback Bit Error Ratio Measurement Description ).

    You must set MS Loopback Type to Type 2 when performing the loopback block error ratio measurement for Symmetrical RMCs (see Block Error Ratio Measurement Description ).

    GPIB command: CALL:MS:LOOPback:TYPE .

Related Topics

Manual Operation: How Do I Configure the Radio Bearer Test Mode?

CALL:SERVice

Call Processing Status

Channel Type and Paging Service

Loopback Bit Error Ratio Measurement Description

Block Error Ratio Measurement Description


Receiver Control

Receiver Control

The test set's receiver includes two frequency downconverters:

  • Measurement downconverter
  • Demodulation downconverter

The Demodulation downconverter is used to establish and maintain the call (RF link) between the mobile station and test set, while the Measurement downconverter is optimized for measurements.

Refer to the Block Diagram for a description of the Signal Downconversion paths.

Automatic Receiver Control

Automatic receiver control is the default for all operating modes except CW (see CW Operating Mode ). With automatic receiver control, the test set automatically tunes to the correct frequencies for making measurements and maintaining a call. Also, the test set adjusts attenuation settings according to the power level that should be present at the RF IN/OUT port given the current settings. This power level is referred to as the expected power, and the current value for expected power is displayed on many of the transmitter power measurement screens.

When operating in active cell operating mode with automatic receiver control, expected power is derived essentially from the Cell Power setting according to closed loop power control behavior, but expected power is also offset by other settings (see Expected Power ). Tune frequencies are derived from Uplink Channel field settings (see Uplink Channel (UARFCN) ).

Manual Receiver Control

In some instances, you may want to control the test set's receiver settings manually rather than allowing the test set to automatically control them. This ability is referred to as manual receiver control. Manual receiver settings can be used to override some or all of the automatic receiver settings. You can manually set the receiver's expected power, the measurement downconverter's tune frequency (Measurement Frequency), and the demodualtion downconverter's tune frequency (Uplink Frequency).

In CW operating mode, you must always specify what frequencies and power the receiver should tune to, there is no automatic receiver control.

For front panel operation, see How Do I Change Receiver Control Parameters? .

GPIB Equivalent Commands for Receiver Control

The following settings control the test set's receivers:

Power Control (Except for CW Mode)

The expected power from the mobile station (UE) is set manually by enabling manual power control using the RFANalyzer:CONTrol:POWer:AUTO command, and by using the RFANalyzer:MANual:POWer[:SELected] command to set the level.

CW Receiver Power

When using the CW operating mode, the expected power from the mobile station is set manually using the RFANalyzer:CW:EXPected:POWer command.

Measurement Receiver Frequency

Measurement receiver frequency commands are used to manually tune the test set's measurement downconverter input signal path (see Block Diagram ). This path is used by the channel power, waveform quality, and adjacent channel leakage ratio measurements.

The commands are:

  • RFANalyzer:MANual:MEASurement[:MFRequency] (to specify a frequency and turn manual mode on)

  • RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO (to turn manual mode on/off)

  • RFANalyzer:MANual:MEASurement:FREQuency (to specify a frequency)

Demodulation (Uplink) Receiver Frequency

Demodulation receiver frequency commands are used to manually tune the test set's demodulation downconverter input signal path (see Block Diagram ). The demodulation downconverter signal path is part of the function that demodulates information from the mobile station's (UE) uplink channel transmission. This path is used by the loopback bit error ratio measurement.

The commands are:

  • RFANalyzer:MANual:UPLink[:MFRequency] (to specify a frequency and turn manual mode on)

  • RFANalyzer:CONTrol:UPLink:FREQuency:AUTO (to turn manual mode on/off)

  • RFANalyzer:MANual:UPLink:FREQuency (to specify a frequency)

Expected Power

To make accurate measurements, the test set needs to know how much power to expect at its RF IN/OUT port; this is referred to as the Expected Power. If a measurement uses autoranging (such as the thermal power, ACLR measurement, etc.), the expected power level is calibrated by the test set before making the measurement and does not need to be set by the user. For measurements that do not use autoranging, the test set determines the expected power level from the UE Target Power setting while in Automatic Receiver Control , or from the Manual Power value while in Manual Receiver Control .

The test set uses the expected power level to establish a range of acceptable input levels into its receivers. If the received signal is above or below the acceptable range, an Over Range or an Under Range message is displayed and the integrity value for the measurement is set to 5 or 6 (respectively). Refer to Integrity Indicator for details about the integrity values.

You can set the expected power level beyond the actual capability of the test set's hardware. This is because expected power is intended to reflect the potential range of RF power at the UE (mobile station). This range of RF power is meant to accommodate the use of a gain or loss network between the mobile station and the test set. See Amplitude Offset for details about amplitude offsets.

The upper and lower limits of expected power provide boundaries for the combination of amplitude offset and expected power. If you set expected power to +52 dBm and the amplitude offset to -3 dB, the calculated receiver power will be 49 dBm, but the test set shall be set to +43 dBm, the upper limit of the hardware. If the calculated value of receiver power goes below -25 dBm, the lower limit of the hardware, the test set shall be set to -25 dBm.

Effects on Receiver Control When Changing Operating Mode

After selecting the operating mode and setting one or more receiver controls to manual, the receiver control settings remain as you set them until you change operating mode. Changing operating mode causes some or all receiver parameters to return to automatic control.

Related Topics

How Do I Change Receiver Control Parameters?

RFANalyzer

Uplink Closed Loop Power Control Parameters and UE Target Power

Active Cell Operating Mode

CW Operating Mode

FDD Test Operating Mode


Security Setup

Security Setup

Last updated: December 20, 2004

You can specify whether or not to perform the security procedure during UE (mobile station) registration (see Performing a Location Update (Registration) ). The security settings are available by pressing Security Setup ( F6 ) under Call Control (1 of 3). See How do I Change Security Setup Parameters . When Security Operations field is set to a value other than None, the authentication procedure will be performed during the UE registration. You can also specify to perform the Integrity Check for all downlink RRC (radio resource control) messages by selecting Auth. & Int. in the Security Operations field.

The Authentication Sequence Number (SQN) is set to zero each time the test set is powered on. It then increments each time an authentication procedure is performed. The SQN can be reset to zero by using Reset Authen. SQN key or with CALL:SECurity:AUTHenticate:SQN:RESet[:IMMediate] .

When the test set receives an Authentication Response message from the UE, the following authentication results are displayed in the Security Results window (see How do I Change Security Setup Parameters ).

  • MM Authentication Result is for non-GPRS service, either successful or a reject cause due to authentication failure. It can also be obtained with CALL:SECurity:AUTHenticate:RESult[:MM]? .
  • GMM Authentication Result is for GPRS service, either successful or a reject cause due to authentication failure. It can also be obtained with CALL:SECurity:AUTHenticate:RESult:GMM? .
  • MS Reported Failure Cause is the value of reject cause included in the Authentication Failure message. It can also be obtained with CALL:MS:REPorted:AUTHenticate:FAILcause? .
MS Reported Failure Cause

MS Reported Failure Cause

Description

2

IMSI unknown in HLR

3

Illegal MS

4

IMSI unknown in VLR

5

IMEI not accepted

6

Illegal ME
7

GPRS service not allowed

8

GPRS services and non-GPRS services not allowed

9

MS identity cannot be derived by the network

10

Implicitly detached

11

PLMN not allowed

12

Location Area not allowed

13

Roaming not allowed in this location area

14

GPRS services not allowed in this PLMN

15

No Suitable Cells In Location Area

16

MSC temporarily not reachable

17

Network failure

20

MAC failure

21

Synch failure

22

Congestion

23

GSM authentication unacceptable

32

Service option not supported

33

Requested service option not subscribed

34

Service option temporarily out of order

38

Call cannot be identified

40

No PDP context activated

48 to 63

Retry upon entry into a new cell

95

Semantically incorrect message

96

Invalid mandatory information

97

Message type non-existent or not implemented

98

Message type not compatible with the protocol state

99

Information element non-existent or not implemented

100

Conditional IE error

101

Message not compatible with the protocol state

111

Protocol error, unspecified

Note:

  • Any other value received by the UE (mobile station) shall be treated as the value of 32, 'Service option temporarily out of order'.
  • Any other value received by the network shall be treated as the value of 111, 'Protocol error, unspecified'.

GPIB Commands for These Settings

  • Security Operations - CALL:SECurity:OPERation
  • Authentication Algorithm - CALL:SECurity:AUTHenticate:ALGorithm
  • Authentication Key, Upper (Hex) - CALL:SECurity:AUTHenticate[:KEY]
  • Authentication Key, Upper Middle (Hex) - CALL:SECurity:AUTHenticate[:KEY]
  • Authentication Key, Lower Middle (Hex) - CALL:SECurity:AUTHenticate[:KEY]
  • Authentication Key, Lower (Hex) - CALL:SECurity:AUTHenticate[:KEY]
  • Operator Variant Parm Type - CALL:SECurity:AUTHenticate:OPVariant:PTYPe
  • Operator Variant Auth. Alg., Upper (Hex) - CALL:SECurity:AUTHenticate:OPVariant:PVALue
  • Operator Variant Auth. Alg., Upper Middle (Hex) - CALL:SECurity:AUTHenticate:OPVariant:PVALue
  • Operator Variant Auth. Alg., Lower Middle (Hex) - CALL:SECurity:AUTHenticate:OPVariant:PVALue
  • Operator Variant Auth. Alg., Lower (Hex) - CALL:SECurity:AUTHenticate:OPVariant:PVALue
  • Random (RAND) Value, Upper (Hex) - CALL:SECurity:AUTHenticate:RANDom
  • Random (RAND) Value, Upper Middle (Hex) - CALL:SECurity:AUTHenticate:RANDom
  • Random (RAND) Value, Lower Middle (Hex) - CALL:SECurity:AUTHenticate:RANDom
  • Random (RAND) Value, Lower (Hex) - CALL:SECurity:AUTHenticate:RANDom
  • AMF Value - CALL:SECurity:AUTHenticate:AMF

Related Topics

How do I Change Security Setup Parameters


SIB11 Cell Info List

SIB11 Cell Info List

Last updated: December 20, 2004

You can specify neighbor cell information for the test set to broadcast on the BCCH (see Broadcast Channel (BCCH) Update Procedure ). There are three cell info lists that the test set can send in SIB11:

  • Intra-frequency Cells

    These are WCDMA neighbor cells on the same frequency as the serving cell (cell 1) but with a different primary scrambling code (you may include the serving cell in this list as well by including its primary scrambling code).

    You may specify that up to 8 intra-frequency neighbor cells are present ( State = On ) or not present in the list, and also specify their primary scrambling codes (see CALL[:CELL[1]]:BCCHannel:ITAFrequency:STATe and CALL[:CELL[1]]:BCCHannel:ITAFrequency:SCODe ). These settings can not be changed while in active cell operating mode unless the call processing state is idle.

  • Inter-frequency Cells

    These are W-CDMA neighbor cells on a different frequency than the serving cell (cell 1) and possibly with a different primary scrambling code.

    You may specify that up to 8 inter-frequency neighbor cells are present ( State = On ) or not present in the list, and also specify their primary scrambling codes and downlink channels (see CALL[:CELL[1]]:BCCHannel:ITRFrequency:STATe , CALL[:CELL[1]]:BCCHannel:ITRFrequency:SCODe , and CALL[:CELL[1]]:BCCHannel:ITRFrequency:DOWNlink:CHANnel ). These settings can not be changed while in active cell operating mode unless the call processing state is idle.

  • GSM Cells

    These are GSM neighbor cells.

    You may specify that up to 8 GSM neighbor cells are present ( State = On ) or not present in the list, and also specify their BCCs, NCCs, shared ARFCN indicators and BCH ARFCNs (see CALL[:CELL[1]]:BCCHannel:GSMSystem:STATe , CALL[:CELL[1]]:BCCHannel:GSMSystem:BCC , CALL[:CELL[1]]:BCCHannel:GSMSystem:NCC , CALL[:CELL[1]]:BCCHannel:GSMSystem:BAND , CALL[:CELL[1]]:BCCHannel:GSMSystem:BCHannel ). These settings can not be changed while in active cell operating mode unless the call processing state is idle.

Note, the information specified by Intra-freq 1st Cell State and Intra-freq 1st Cell Scrambling Code is transmitted in SIB11 as the information pertaining to "intra-frequency cell id" = 0, as the "intra-frequency cell id" Information Element begins its numbering at 0 see 3GPP TS 25.331 10.3.7.33). Likewise, the information specified by Intra-freq 2nd Cell State and Intra-freq 2nd Cell Scrambling Code is transmitted in SIB11 as the information pertaining to "intra-frequency cell id" = 1, etc. If you set the state of a cell to Off , then no information is sent for the "intra-frequency cell id" corresponding to that cell. This numbering convention is also true for the "inter-frequency cell id" for inter-frequency cells (see 3GPP TS 25.331 10.3.7.13) and "inter-RAT cell id" for GSM cells (see 3GPP TS 25.331 10.3.7.23).

Note that the test set does not actually generate any of these neighbor cells, it simply broadcasts a list of neighbor cells to the UE. However if you set Intra-freq 1st Cell Scrambling Code to the same value as the Primary Scrambling Code for cell 1 (see Downlink Channel Codes and Levels ), then the Intra-freq 1st neighbor cell is mapped to the actual cell 1 signal from the test set. Also, for the lab application only, if you set Intra-freq 2nd Cell Scrambling Code to the same value as Cell2 Primary Scrambling Code then the Intra-freq 2nd neighbor cell is mapped to the actual cell 2 signal from the test set. Mapping the intra-frequency neighbor cells to cell 1 and cell 2 in this way allows you to most closely emulate a real network situation. Also, for some devices, mapping cell 2 in this way may be required to allow successful soft handoff (see Some UEs require Cell 2 Primary Scrambling Code = Intra Freq 2nd Cell Scrambling Code )

You specify whether or not the test set should broadcast the neighbor cell lists in SIB11 using the following setting:

  • Cell Info List

    You may set this setting to Present (all three neighbor cell lists are included in SIB11) or Absent (no neighbor cell lists are included in SIB11).

    This setting can not be changed while in active cell operating mode unless the call processing state is idle.

    GPIB syntax: CALL[:CELL[1]]:BCCHannel:CELLlist

Changing any of the cell info list settings in SIB11 while in active cell operating mode will result in the execution of the BCCH Update procedure (see Broadcast Channel (BCCH) Update Procedure ). These settings can only be changed when the call status is idle.

Related Topics

Manual Operation: How Do I Change the SIB11 Cell Info List?

GPIB Syntax: CALL:BCCHannel

Broadcast Channel (BCCH) Update Procedure

Compressed Mode (Lab Application only)


Short Message Service (SMS)

Short Message Service (SMS)

Last updated: December 20, 2004

This section is only applicable to the lab applications.

The Short Message Service (SMS) testing capability available in the test set allows you to test both the cell broadcast and point-to-point (mobile terminated and mobile originated messages) SMS capability of your mobile station. The point-to-point testing capability is extensive, including support for concatenated and binary SMS applications like WAP Push, MMS notifications, ringtones, picture messaging, as well as character based languages such as Chinese, Japanese, and Hebrew. In addition to the standard GPIB and front panel interface, an HTTP interface is available providing easy connectivity with commercially available SMS Gateways. Support is also available for capturing logs of the protocol messages exchanged between the test set and the mobile station during SMS verification.

  • Cell Broadcast Service (CBS)
  • Point-to-Point SMS - Includes information on how to send and receive point-to-point SMS messages in either the CS (Circuit Switched) or PS (Packet Switched) domain.
    • Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station - Includes specific information on sending messages to the mobile station.
    • Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station - Includes specific information on receiving messages from the mobile station.
    • HTTP Interface for SMS - Introduction - Includes information on the HTTP interface available in the test set for sending and receiving SMS messages.
  • Multimedia Service (MMS) Messages
  • Logging SMS Messages

Related Topics

How to use the Short Message Service Features


Cell Broadcast Service (CBS)

Cell Broadcast Service (CBS)

Last updated: December 20, 2004

This section is only applicable to the lab applications.

You can test a mobile station's ability to receive Cell Broadcast messages using the Cell Broadcast Service capability in the test set. The Cell Broadcast messages are transmitted by the Broadcast and Multicast Control (BMC) protocol layer over the CTCH (Common Traffic Channel) logical channel. The messages are sent using DRX (Discontinuous Reception) on the CTCH, and the CBS Schedule message states which fragments of CBS messages will be sent in specific frames. The MAC layer multiplexes the CTCH onto the FACH transport channel with the CCCH (Common Control Channel) logical channel. The FACH is then multiplexed onto the S-CCPCH (Secondary Common Control Physical Channel) with the PCH (Paging Channel) transport channel, which also uses DRX to transmit in particular frames. The test set gives priority to the PCH over the FACH. Thus, it is possible that CBS data might not be transmitted in the intended slot because the slot contains PCH data instead. If this occurs, the CBS data is sent in the subsequent slot, and the CBS data for the subsequent slot is discarded by the test set.

Starting the Cell Broadcast Service (CBS)

The Cell Broadcast Service in the test set allows you to send short messages to the mobile station that are repeated at intervals over a period of time, which allows the mobile station to receive the message even if entering the cell after the first transmission. These messages are not acknowledged by the mobile station.

The test set can transmit up to three different messages at a time using the Cell Broadcast Service. If you configure the Cell Broadcast Service to transmit multiple messages, the messages are sent serially in numerical order at a rate of one page every multiframe. The messages are retransmitted every 30 seconds. This allows time to react to an incoming message.

Message Setup

All three of the messages available for use in the test set's Cell Broadcast Service can be configured independently. Each message can include either one of two predefined text messages or one you define yourself. In addition, each message is classified by topic and allocated a message identifier, message code, update number, and language. You can configure the following parameters for each of the three possible Cell Broadcast messages:

  • Message State allows you to configure which messages are sent using CBS. The message state should be ON for each message you want to send. The Message State for Message 1 is set to ON by default.
  • Message Text associates the message with the actual SMS data to be sent by the test set. The test set only provides support for ASCII messages. See Cell Broadcast Service (CBS) Messages for more specific information.
  • Message Code identifies a particular message, so that a mobile station receiving a message with the same code as a previously received message will recognize that it is a repeat, and may not display it to the user.
  • Message Identifier is a header number identifying the message topic (such as 'Weather Report' or 'Traffic Information').
  • Update Number is used to identify a particular version of a message. This is useful for reporting a dynamic situation, where a message may be reporting one event (such as road works or road construction ahead), but the details change periodically (the length of the tail-back or traffic jam caused, for example). A mobile station which remains in one cell for a length of time receives messages with the same message code but increments the update numbers as updated versions of the same message are received. A mobile station that has just entered a cell receives only the most recent version of the message, followed by any subsequent versions.
  • Language indicates in what language the message is. Changing this parameter does not translate the text of a message.

Cell Broadcast Service (CBS) Messages

Several Cell Broadcast Service (CBS) message options are available which allow you to choose or create messages to be sent. You can set the Message Text parameter to Text1 , Text2 , or Custom . See the sections below for more information about these settings.

Predefined Cell Broadcast Text Messages

There are two predefined cell broadcast text messages. The ASCII text strings of these messages are as follows:

  • Predefined text message 1 ( Text1 )-

    The quick brown fox jumps over the lazy dog

  • Predefined text message 2 ( Text2 )-

    This instrument provides functional testing of broadcast SMS by sending up to three broadcast messages to the device under test. Two fixed messages and a user defined message are available for selection. The second fixed message spans multiple pages.

User Defined Text Message (Custom)

You can also customize the text sent in the cell broadcast message using the Custom parameter. You can define the text for the custom message using the following GPIB command:

CALL:SMService:CBRoadcast:TEXT:CUSTom .

A custom text message can be defined only via the remote user interface. The maximum length for the cell broadcast user defined messages is 93 characters.

The default custom text message is:

Enter your text here

NOTE
Text messages sent from the test set to the mobile station are encoded using the ETSI Default Alphabet character set. The ETSI Default Alphabet encoding shares the majority of its character codes with those used by the ASCII character set. Between the two character sets, all alphanumeric characters and most punctuation characters have identical codes.

For the custom user defined text message, the test set accepts a 7-bit ASCII string. This string is then encoded using the ETSI Default Alphabet before it is transmitted. The ASCII code for each character in this string is mapped to the ETSI Default Alphabet character with the same code. Characters present in the user defined text message whose ASCII and ETSI Default Alphabet codes are not identical will be received and displayed by the mobile station as the ETSI Default Alphabet character with the original ASCII character's code. This behavior is only noticeable with certain user defined text messages as all of the predefined text messages use only alphanumeric and basic punctuation characters.

Related Topics

Short Message Service (SMS)


HTTP Interface for SMS - Introduction

HTTP Interface for SMS - Introduction

Last updated: December 20, 2004

The HTTP interface in the test set provides an industry standard interface for interfacing the base station simulation capability of the test set with necessary external components for verifying SMS capability in a mobile station. The HTTP implementation in the test set also provides SMS routing capability, simulating a simple Short Message Service Center (SMSC).

Introduction to HTTP

HTTP is the client/server based protocol used to deliver virtually all files and data on the World Wide Web. If you'd like a more detailed description of HTTP protocol, refer to Internet RFCs `HTTP/1.0 - RFC 1945' and `HTTP/1.1 - RFC 2616', which can be downloaded from http://www.rfc-editor.org/rfc.html.

When you use HTTP in a web browser, you enter the "address" for the web page you wish to view. These addresses can be generalized into the following format:

In this example, the web browser is the HTTP client and it uses the information in this address to open a connection to an HTTP server and send a request.

  • "http://" is the protocol specifier, telling the browser what protocol to use for the request.
  • <ip_address> is the IP address of the server.
  • <port> is the port number on which to communicate with the server. The default port for HTTP is 80.
  • <request_URL> provides information to the server on the location of the resource that's being requested and can also be used to provide information to the resource.

HTTP Interface for SMS verification

The test set acts as both a server and a client, depending on which operation it is performing.

The test set as the server:

If you have a PC and your test set connected to a network or directly connected together, you can open a web browser (client) and send a request to the test set using the test set's IP address and a correctly configured request URL. For example, you might send the following from the web browser if your test set's IP address was 111.111.111.112.

NOTE
It is not necessary to specify a port number because the test set uses 80, which is the default port for HTTP.

Sending the URL causes an SMS message to arrive at the mobile station attached to the test set's RF port. This message contains the text "hello".

The test set acts as the server for mobile terminated SMS messages. While this is a simple example, this same information is necessary to configure an SMS Gateway or proprietary software for interfacing with the test set via HTTP.

For configuration information see:

  • HTTP Interface Configuration for Mobile Terminated SMS .

The test set as the client:

SMS messages originating from the mobile station attached to the test set are sent out the test set's LAN port as HTTP requests to the IP address for the intended receiving entity.

For configuration information see:

  • HTTP Interface Configuration for Mobile Originated SMS

Related Topics

HTTP Interface Configuration for Mobile Terminated SMS


HTTP Interface Configuration for Mobile Originated SMS

HTTP Interface Configuration for Mobile Originated SMS

Last updated: December 20, 2004

Information must be provided to the test set in order for mobile originated SMS messages to be correctly routed by the HTTP SMS Router to the receiving entity. The test set's HTTP interface must be enabled before it can be used to send messages and the HTTP Interface must be configured with information about where to route the messages.

See the following sections for more information about configuring the HTTP interface for mobile originated messages.

  • Enable the Test Set's HTTP Interface
  • HTTP Interface Settings - General
  • HTTP Interface Settings for Using an SMS Gateway
  • Configuring Message URL
  • Example Text Message URL
  • Example Binary Message URL

Enable the Test Set's HTTP Interface

You must enable the HTTP interface output in the test set. This can be done via a GPIB command (see CALL:SMService:HTTProtocol:OUTPut ) or from the test set's front panel (see Enabling the HTTP Interface for Mobile Originated SMS ).

If the interface is not enabled, messages received from a mobile station are not output over HTTP.

HTTP Interface Settings - General

See HTTP SMS Router Web-based Configuration Interface for information on how to change the settings described in this section. Two of the settings are general and apply to every testing scenario:

  • DUT Sender address
  • Other 8960 IP Address or Alternative Device Destination (SMS Gateway) IP Address

DUT Sender address

The DUT Sender address setting allows you to associate a phone number with the mobile station originating the messages. This setting may not be required by the receiving entity, but is useful to allow mobile originated messages to be `replied' to correctly in a test system configuration making use of a gateway and more than two mobile stations and test sets.

Setting Type | String
Factory Setting | "1000"
Range | 0 - 20 character ASCII formatted string of BCD digits from 0-9, *, #, A-C

Other 8960 IP Address or Alternative Device Destination (SMS Gateway) IP Address

The IP Address where the HTTP SMS Router is to send the mobile originated message. You can only specify one destination IP address, therefore, if you want to use more than two test sets in a test system, you must use an intermediate SMS gateway or other software to route the messages.

If you have a test system with two test sets and are not using an SMS Gateway, you would specify the Other 8960 IP Address to be the other test set's IP Address. If you are sending the messages to another entity for routing, like an SMS Gateway, specify the IP Address of the PC on which that entity is running.

Setting Type | String
Factory Setting | ""
Range | Any valid IP address

HTTP Interface Settings for Using an SMS Gateway

See HTTP SMS Router Web-based Configuration Interface for information on how to change the settings described in this section. The following settings are only used when Alternative Device Destination (SMS Gateway) as been selected for the Output Destination. When Other 8960 is selected, these parameters are automatically configured internal to the test set.

  • Destination Port
  • Text Message URL
  • Binary Message URL
  • Request Method

Destination Port

The TCP/IP port on which the receiving entity listens for web/HTTP requests.

Setting Type | Numeric
Factory Setting | 80
Range | 0-65534

Text Message URL

Defines the URL format for SMS text messages accepted by the receiving entity, which might be an SMS gateway or proprietary software. The test set automatically selects this URL if the type of message received from the mobile station is a text message. See Example Text Message URL for more information on specifying this URL.

Setting Type | String
Factory Setting | ""
Range | 0 - 256 character ASCII formatted string

Binary Message URL

Defines the URL format for SMS binary messages accepted by the receiving entity, which might be an SMS gateway or proprietary software. The test set automatically selects this URL if the type of message received from the mobile station is any type of binary or Unicode message. See Example Binary Message URL for more information on specifying this URL.

Setting Type | String
Factory Setting | ""
Range | 0 - 256 character ASCII formatted string

Request Method

Allows you to select which HTTP request method the test set's HTTP interface is to use when sending SMS messages over HTTP. The method to use is dependent on the format accepted by the receiving entity.

Setting Type | Enum
Factory Setting | GET
Range | GET|POST

Configuring Message URL

Just as the test set requires a specific format for request URLs received at it's HTTP interface, so do SMS Gateways or customer programs receiving request URLs from the test set. This is very similar to the URL requests configuration discussed for mobile terminated SMS messages (see Configure the Request URL ).

In order to configure the text and binary URLs for the test set's HTTP interface, you must know the receiving entity's requirements for request URLs. If the message is being sent directly to another test set, it is not necessary to configure the message URLs.

Use the tags defined in the following table, Message URL Tags , when configuring the text and message URLs. When a mobile originated message arrives at the test set, the tags in the message URL are replaced with the respective message content before the request URL is sent to the receiving entity.

Message URL Tags

Tag | Replaced with
@@TEXT@@ | The ASCII text of a received text message (reformatted to meet URL escaping requirements). Should only be used for 7-bit text messages and will return the same as the @@DATA@@ tag if used for binary messages.
@@DATA@@ | The message content as a string of hex characters, not including any user data header present in the content. Should only be used for binary messages and will return the same as the @@TEXT@@ tag if used for 7-bit text messages
@@NUMBER@@ | The destination phone number of the message.
@@SENDER@@ | The assigned originating phone number of the message as defined by the Sender Address setting detailed in section 4.2.3.2
@@UDH@@ | The User Data Header of the message as a string of hex characters. Should only be used for binary messages, will return an empty string if used otherwise.
@@UHDI@@ | The User Data Header indicator of the received message, either 0 (UDH not present) or 1 (UDH present).
@@PID@@ | The Protocol Identifier of the received message as a decimal number.
@@PIDHEX@@ | The Protocol Identifier of the received message as a string of hex characters.
@@DCS@@ | The Data Coding Scheme of the received message as a decimal number.
@@DCSHEX@@ | The Data Coding Scheme of the received message as a string of hex characters.
@@SRR@@ | The Status Report Request flag of the received message, either 0 or 1.
@@MREF@@ | The Message Reference number of the message as a decimal number
@@MREFHEX@@ | The Message Reference number of the message as a string of hex characters.
@@TRANSPORT@@ | The transport that was used by the DUT when originally sending the message, this parameter is replaced with a text string of "CS Domain" or "PS Domain" if included in the format string.

Example Text Message URL

You might configure your text message URL to look like the following:

If a text message is sent from the mobile station attached to the test set with the following information:

  • Destination number: 12345
  • Message Text: "This is a text message"

And the DUT Sender Address is configured to be `1000', the following URL request is sent by the test set to the receiving entity at the currently configured IP Address and Port Number:

/?PhoneNumber=12345&Text=This%20is%20a%20text%20message&Sender=1000

Example Binary Message URL

You might configure your binary message URL to look like the following:

Note the `Binary=1', `User=user535', and `Password=pass' parameters at the end of the format string. These do not contain any test set defined tags (see Message URL Tags ), but it can be useful to specify such extra parameters if the receiving entity, like an SMS gateway for example, requires username and password information included in URL requests or a specific flag to inform it the message is binary.

If a binary message is sent from the mobile station attached to the test set with the following information:

  • Destination number: 54321
  • Message Content: 140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C65000701 03424243206D6F62696C652073697465000101
  • User Data Header: 0605040B8423F0
  • Protocol ID: 0
  • Data Coding Scheme: 245

The following URL request is sent by the test set to the receiving entity at the currently configured IP Address and Port Number:

/?PhoneNumber=54321&Data=140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C6500070103424243206D6F62696C652073697465000101&UDH=0605040B8423F0&PID=00&DCS=245&Binary=1&User=user535&Password=pass

Related Topics

HTTP SMS Router Web-based Configuration Interface


HTTP SMS Router Web-based Configuration Interface

HTTP SMS Router Web-based Configuration Interface

Last updated: December 20, 2004

This section explains how to use the web-based interface provided for configuring the HTTP SMS Router for mobile originated SMS messages. To configure the HTTP Interface for Mobile Originated SMS, you must have an active LAN connection to the test set in order to access its http server. You can access the HTML pages for configuration via any standard internet browser.

  • Accessing the web-based HTTP SMS Router Interface
  • Current Configuration
  • Change Configuration
  • Configuration Error

Accessing the web-based HTTP SMS Router Interface

  1. Access the instrument home page for your test by directing an internet browser to http://x.x.x.x, where `x.x.x.x' is the IP address of the test set to which the mobile station is attached that is sending the mobile originated message. The test set's home page is displayed in the browser window, as shown below.

  2. Click on SMS (circled in red in the previous figure). This opens the HTTP SMS Router Current Configuration page.

Current Configuration

The current HTTP Interface Settings are summarized on the Current Configuration page. See Change Configuration for information on changing these settings.

NOTE
Although the enabled or disabled state of both the HTTP Input interface and the HTTP Output interface is displayed on the Current Configuration page, these settings cannot be changed using the web-based interface. For instructions on changing these settings, see Enable the Test Set's HTTP Interface .

Change Configuration

The following parameters are configured using the HTTP SMS Router Web-based Configuration Interface. For more detailed explanation of each of these parameters, see HTTP Interface Settings - General .

  • DUT Sender address
  • Other 8960 IP Address
  • Alternative Device Destination IP Address
  • Destination Port
  • Text Message URL
  • Binary Message URL
  • Request Method

Click on the Change button from the HTTP SMS Router Current Configuration page to access the HTTP SMS Router Change Configuration page.

The HTTP SMS Router Change Configuration page, shown in the figure below, allows changes to be made to the HTTP Interface Settings.

The HTTP SMS Router Change Configuration page is divided into two sections: General and Output Destination.

General

This section controls the number that is associated with the mobile station for messages output over the HTTP interface.

Output Destination

This section allows you to specify the destination for mobile originated SMS messages. If this is another test set, only the IP address of the destination test set is required for this section. For other destinations, such as an SMS Gateway running on a PC, more specific details are required.

Click the Apply Changes button to save any configuration changes you have made. The browser returns to the HTTP SMS Router Current Configuration page.

Alternatively, use the Cancel button to discard any changes you have made that you do not want saved.

Configuration Error

If any of the settings specified on the HTTP SMS Router Change Configuration page contain illegal values when the Apply Changes button is clicked, the HTTP SMS Router Configuration Error page is displayed. This page provides a description of the first error found when verifying the updated settings. Press the Back button to return to the HTTP SMS Router Change Configuration page to correct any errors.

Example Configuration Error page

Related Topics

HTTP Interface Configuration for Mobile Originated SMS


HTTP Interface Configuration for Mobile Terminated SMS

HTTP Interface Configuration for Mobile Terminated SMS

Last updated: December 20, 2004

If you wish to use the HTTP interface in the test set to route SMS messages to the mobile station attached to the test set's RF port you must do the following:

  1. Enable the Test Set's HTTP Interface
  2. Specify the SMSC IP Address and Port
  3. Configure the Request URL

Enable the Test Set's HTTP Interface

You must enable the HTTP interface in the test set. This can be done via a GPIB command (see CALL:SMService:HTTProtocol:INPut ) or from the test set's front panel (see Enabling the HTTP Interface ).

If the interface is not enabled, HTTP SMS requests sent to the test set are rejected and the HTTP error code 503 (Service Unavailable) is returned to the client issuing the request.

Specify the SMSC IP Address and Port

Several different types of clients could be used to send SMS messages to the test set. Some examples are:

  • SMS Gateway
  • another test set
  • a custom http client

When setting up any of these clients, it is necessary to specify the IP Address and port number on which the test set is listening for incoming messages. These parameters are always to be configured as follows:

  • IP Address/Host Name: The IP address of the test set receiving the messages
  • Port number: 80

NOTE
When configuring an SMS Gateway, these parameters apply to the SMSC configuration. In a test system with more than one test set, each test set may be thought of as a separate SMSC and configured as such in the gateway.

Configure the Request URL

When using the HTTP interface in the test set for sending SMS messages, you must configure a request URL.

Requests to send SMS messages to the mobile station attached to the test set using the HTTP interface must be configured using the following rules:

  1. The request URL format accepted by the test set is:

    /sms/send/?parameter1=value1&parameter2=value2&parameter3=value3......

    NOTE
    "/sms/send/?" must be specified at the beginning of the request URL in order for the test set to recognize the HTTP request as a request to send an SMS message to the mobile station.

    The parameters and values variables provides the content of the SMS message as well as additional information for header configuration and test set configuration. All configurable parameters and values are detailed in Request URL Parameters .

  2. Mandatory parameters must be included in the request URL. The mandatory parameters depend on the content of the SMS message you are sending.
    SMS Message Content Type | Mandatory Parameters
    7-bit text | TEXT
    8 or 16 bit data | DATA and/or UDH
  3. An HTTP error code of 400 (Bad Request) is returned to the client initiating an HTTP request and the message is not forwarded on to the mobile station if one or both of the following is true:
    • any parameter values in the request URL do not adhere to the constraints detailed in Request URL Parameters , or
    • any mandatory parameters are not present.
  4. Optional parameters may be set equal to an empty value in the request URL. For example, if parameter2 is an optional parameter, then /sms/send/?parameter1=value1&parameter2=&parameter3=value3 is a valid request URL. The test set uses the default value for optional parameters when they have been set to empty values.
    Optional Parameters
    UDHI
    PIDHEX or PID
    DCSHEX or DCS
    SENDER
    MMTS
    SRI
    RPATH
    TRANSPORT
  5. Parameters in the request URL can be in any order.
  6. When a text message is being submitted via the `TEXT' parameter, HTTP URL escaping restrictions apply. Therefore, all space characters must be replaced with the `%20' character sequence. Other characters that require escape characters when used in URLs are detailed in the following table.

    Character to URL Escape Sequence Mapping

    NOTE
    It is only necessary for you to use the escape characters when building a request URL manually. If you are sending messages to the mobile station through either an SMS gateway or from another 8960, the escaping is performed automatically.

Request URL Parameters

Parameter | Use and expected value | Inclusion
TEXT | 0-160 character string of 7-bit text characters. The underlying character codes specified here are used directly when sending the message OTA and will be interpreted by a receiving mobile station as per the ETSI default Alphabet specification. | This parameter must be included in all HTTP requests to send 7-bit text based SMS messages. It must not be included in the same request as either of the DATA or UDH parameters outlined below.
DATA | 0-280 ASCII formatted hex characters (the length of the combined UDH and DATA values must not exceed 280 characters) | One or both of these parameters must be included in all HTTP requests to send binary SMS messages. The UDH and data for a message may be encoded as a single hex string and specified via either of these parameters, or may instead be specified separately and sent via both parameters. Neither of these parameters may be present in the same request as the TEXT parameter outlined above.
UDH | 0-280 ASCII formatted hex characters representing the User Data Header to be included in the message content (the length of the combined UDH and DATA parameters must not exceed 280 characters)
UDHI | The User Data Header Indicator (TP-UDHI) of the message. Should be either 0 or 1 to indicate the presence of a User Data Header in the message content. If a UDH parameter (see above) containing a non-empty value is present in the request URL, the UDHI used when sending the message OTA is always 1 regardless of the presence/value of the this parameter. | Optional (Default = 0)
PIDHEX | The Protocol Identifier (TP-PID) of the message as a string of hex characters | Both of these parameters are optional but at most one may be included in any request. (Default = 0)
PID | The Protocol Identifier (TP-PID) of the message as a decimal number
DCSHEX | The Data Coding Scheme (TP-DCS) of the message as a string of hex characters | Both of these parameters are optional but at most one may be included in any request. (Default = 0)
DCS | The Data Coding Scheme (TP-DCS) of the message as a decimal number
SENDER | The phone number of the sending client as a 0 - 20 character ASCII formatted string of BCD digits from 0-9, *, #, a, b, c | Optional (Default = 1000)
MMTS | The More Messages to Send value for the SMS PDU header. Should be either 0 or 1. | Optional (Default = 1)
SRI | The Status Report Indication value for the SMS PDU header. Should be either 0 or 1. | Optional (Default = 0)
RPATH | The reply path value for the SMS PDU header. Should be either 0 or 1. | Optional (Default = 0)
TRANSPORT | The transport mechanism to use when sending the message, valid value is either `CS Domain' or `PS Domain'. | Optional (Default = Whatever SMS transport is currently set for use in the instrument receiving the request)

Example request URL strings

Text message:

To send a text based SMS message with the following message details:

  • Originating number: 1001
  • Message Text: "This is a simple text message"

you would format the HTTP request URL as follows:

/sms/send/?TEXT=This%20is%20a%20simple%20text%20message&SENDER=1001

Binary message:

To send a binary message with the following message details:

  • Originating number: 987654321
  • Message Content: 140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C6500070103424243206D6F62696C652073697465000101
  • User Data Header: 0605040B8423F0
  • Protocol ID: 0
  • Data Coding Scheme: 245

you would format the HTTP request URL as follows:

/sms/send/?DATA=140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C6500070103424243206D6F62696C652073697465000101&PID=0&DCS=245&SENDER=987654321&UDH=0605040B8423F0

or, the test set also allows you to include the User Data Header as part of the `DATA' parameter as explained in the table Request URL Parameters . Therefore, the HTTP request URL could instead be configured as follows:

/sms/send/?DATA=0605040B8423F0140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C6500070103424243206D6F62696C652073697465000101&UDHI=1&PID=0&DCS=245&SENDER=987654321

Accepted HTTP request methods

Both POST and GET HTTP requests are accepted by the test set for sending SMS messages.

If POST is used as the request method, the URL request parameters detailed in Request URL Parameters are not included in the request URL, but are included in the request body instead. Therefore, the request URL in POST requests contains only `sms/send'.

Related Topics

HTTP Interface for SMS - Introduction


Logging SMS Messages

Logging SMS Messages

Last updated: December 20, 2004

This section is only applicable to the lab applications.

You can use the Wireless Protocol Advisor (WPA) to log SMS messages.

  • SMS Logging Control
  • Setting Up the Wireless Protocol Advisor (WPA)

SMS Logging Control

The test set gives you access to the protocol layers necessary to allow you to observe the SMS cell broadcast and point-to-point messages. You can capture all the messages exchanged between either the GMM or MM and these protocol layers:

  • CM - Connection Management
  • SMRL - Short Message Relay Layer
  • SMTL - Short Message Transport Layer

SMS Message Support

The messages in the following tables are examples of messages related to SMS. The table indicates whether each is supported in the test set. There may be more messages supported by the test set or by the Wireless Protocol Advisor. In addition, certain parameters in these messages may not be supported.

SMS Point-to-Point Messages
Messages | Supported
SMS_CP_DATA | Yes
SMS_CP_ERROR | Yes
SMS_CP_ACK | Yes
SMS_RL_MS2N_DATA | Yes
SMS_RL_N2MS_DATA | Yes
SMS_RL_MS2N_ERROR | Yes
SMS_RL_N2MS_ERROR | Yes
SMS_RL_MS2N_ACK | Yes
SMS_RL_N2MS_ACK | Yes
SMS_RL_MS2N_SMMA | Yes
SMS_TP_DELIVER | Yes
SMS_TP_SUBMIT_RPT | Yes
SMS_TP_STATUS_RPT | Yes
SMS_TP_DELIVER_RPT | Yes
SMS_TP_SUBMIT | Yes
SMS_TP_COMMAND | No
User Configurable SMS Message Parameters
Mobile-Terminated SMS Parameters on Test Set | Parameters in 3GPP TS 23.040 | Message Types
Content | TP-User Data (TP-UD) - 9.2.3.24 | Deliver, Submit Report, Status Report
Message Type | TP-Message Type Indicator (TP-MTI) - 9.2.3.1 | Deliver, Submit Report, Status Report
Data Coding Scheme | TP-Data Coding Scheme (TP-DCS) - 9.2.3.10 (Defined in 3GPP TS 23.038) | Deliver, Submit Report, Status Report
Failure Cause | TP-Failure Cause (TP-FCS) - 9.2.3.22 | Submit Report if RP type is set to RP-ERR
Message Reference | TP-Message Reference (TP-MR) - 9.2.3.6 | Status Report
More Messages to Send | TP-More Messages to Send (TP-MMS) - 9.2.3.2 | Deliver, Status Report
Parameter Indicator | TP-Parameter Indicator (TP-PI) - 9.2.3.27 | Submit Report, Status Report
Protocol Identifier | TP-Protocol Identifier (TP-PID) - 9.2.3.9 | Deliver, Submit Report
Reply Path | TP-Reply Path (TP-RP) - 9.2.3.17 | Deliver
Status | TP-Status (TP-ST) - 9.2.3.15 | Status Report
Status Report Indication | TP-Status Report Indication (TP-SRI) - 9.2.3.4 | Deliver
User Data Header Indicator | TP-User Data Header Indication (TP-UDHI) - 9.2.3.23 | Deliver, Submit Report, Status Report
Originating Address | TP-Originating Address (TP-OA) - 9.2.3.7 | Deliver
Recipient Address | TP-Recipient Address (TP-RA) - 9.2.3.14 | Status Report
Mobile Originated Parameters
Mobile-Originated SMS Parameters available for query from the test set | Parameters in 3GPP TS 23.040
Coding Scheme | TP-Data Coding Scheme (TP-DCS) - 9.2.3.10 (Defined in 3GPP TS 23.038)
User Data Length | TP-User Data Length (TP-UDL) - 9.2.3.24
Destination | TP- Destination Address (TP-DA) - 9.2.3.8
Content | TP-User Data (TP-UD) - 9.2.3.24
Reference No. | TP-Message Reference (TP-MR) - 9.2.3.6
UDHI | TP-User Data Header Indication (TP-UDHI) - 9.2.3.23
Protocol Identifier | TP-Protocol Identifier (TP-PID) - 9.2.3.9
Status | TP-Status Report Request (TP-SRR) - 9.2.3.5

Setting Up the Wireless Protocol Advisor (WPA)

You can use the Wireless Protocol Advisor (WPA) to log the messages exchanged between the test set and the mobile station during SMS procedures. This tool provides a means to evaluate the mobile station's performance and to troubleshoot problems.

You can set up the WPA to capture and display as much or little information as you want. For this example, the logging filter is defined to capture only SMS protocol messages. The view filter is configured to only display the CP-Data messages. This allows you to view only the messages that contain the SMS message contents being exchanged between the mobile station and the test set.

Test Set Message Filter Setup

The test set filter is useful for limiting the amount of data sent over the LAN connecting the test set and the WPA. In the example below, all messages are sent from the test set to the WPA.

All filters are accessed from the Measurement Setup view. This can be accessed from the menu bar by clicking:

WPA Logging Filter Setup

The logging filter is useful for limiting what messages get captured in your log. Using this filter, you can choose to only log certain types of messages from certain protocol layers. In this example, we are using the logging filter to limit the captured log to SMS protocol messages.

WPA View Filter Setup

The view filter has no effect on what messages are captured. It simply limits the messages that are visible on the WPA's traffic overview. The view filter can easily be enabled and disabled by right clicking your mouse in the traffic overview and selecting View Filter Enabled from the menu that appears.

In the following view filter example, the messages in the traffic overview are limited to the CP-Data messages.

SMS Message Log

For the step-by-step procedure for setting up the test set to capture this log, refer to Mobile Originated Point-to-Point Message Transfer .

The captured log allows you to determine exactly what is being exchanged between the test set and the mobile station. In this example, an SMS message was sent from the test set to the mobile station. You can look in the decode of the captured message to verify all the parameters associated with that message. The following data is only a portion of the decode belonging to the captured message. In this data, you can see the text message that was sent to the mobile station.

Related Topics

Protocol Logging


Short Message Service (SMS) Messages

Short Message Service (SMS) Messages

Last updated: December 20, 2004

This section is only applicable to the lab applications.

Several Short Message Service (SMS) message options are available which allow you to choose or create the message content to be sent to the mobile station.

The Content parameter for SMS includes the following selections:

  • Text1 - see Predefined Point-to-Point Text Messages
  • Text2 - - see Predefined Point-to-Point Text Messages
  • Custom Text - see User Defined Text Message (Custom Text Message)
  • Custom Data - Defining the User Data (TP-UD) content for Binary SMS Applications

You can use the following GPIB command to select the content type to be used in mobile terminated SMS messages:

CALL:SMService:PTPoint[:MTERminated]:CONTents .

Predefined Point-to-Point Text Messages

There are two predefined point-to-point text messages. The ASCII text strings of these messages are as follows:

  • Predefined text message 1 ( Text1 ) -

    01234567890ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz

  • Predefined text message 2 ( Text2 ) -

    Agilent Technologies, your partner in wireless solutions.

User Defined Text Message (Custom Text Message)

You can also customize the text sent in the sms message using the Custom Text message. You can define the text for the custom message using the following GPIB command:

CALL:SMService:PTPoint[:MTERminated]:TEXT:CUSTom .

The custom text message can be defined only via the remote user interface. The maximum length for the user defined text messages is 160 characters.

The default custom text message is:

Enter your text here

NOTE
SMS text messages exchanged between the test set and the mobile station are encoded using the ETSI Default Alphabet character set. The ETSI Default Alphabet encoding shares the majority of its character codes with those used by the ASCII character set. Between the two character sets, all alphanumeric characters and most punctuation characters have identical codes.

For user defined text messages, the test set accepts a 7-bit ASCII string. This string is then encoded using the ETSI Default Alphabet before it is transmitted. The ASCII code for each character in this string is mapped to the ETSI Default Alphabet character with the same code. Characters present in the user defined text message whose ASCII and ETSI Default Alphabet codes are not identical will be received and displayed by the mobile station as the ETSI Default Alphabet character with the original ASCII character's code. This behavior is only noticeable with certain user defined text messages as all of the predefined text messages use only alphanumeric and basic punctuation characters.

Defining the User Data (TP-UD) content for Binary SMS Applications

Transmission of SMS messages necessary for concatenated and binary SMS applications like WAP Push, MMS notifications, ringtones, picture messaging, as well as character based languages such as Chinese, Japanese, and Hebrew that use UCS2 can be done by specifying the entire contents of the Deliver PDU's User Data field, including header information, in hexadecimal characters. You can define the content for the Custom Data parameter using the following GPIB command:

CALL:SMService:PTPoint[:MTERminated]:DATA:CUSTom .

The custom user data can be defined only via the remote user interface. The maximum length for the user data is 280 ASCII formatted hexadecimal characters.

The default custom user data is:

00

Related Topics

Short Message Service (SMS)

Point-to-Point SMS

Cell Broadcast Service (CBS)

How to use the Short Message Service Features

CALL:SMService


Multimedia Service (MMS) Messages

Multimedia Service (MMS) Messages

Last updated: December 20, 2004

This section is only applicable to the lab applications

The Multimedia Service (MMS) is a WAP based application running on a wireless network. MMS makes use of the Short Message Service provided by the wireless network to notify the mobile station when an MMS is available for it to download from a server. Otherwise, MMS messages operate just like any other data transfer in the wireless network.

The test set can be used as a component in a system to verify the MMS capability of a mobile station. Other components required for such a system may include:

  • an SMS Gateway to generate and route the MMS notification message to a receiving mobile station,
  • an external software program simulating a Multimedia Service Center (MMSC) to act as the server and to generate the URL from which the MMS can be retrieved, and
  • a WAP Gateway to provide a means to download the compiled MMS from the MMSC

It is worth noting that for MMS verification, the HTTP or GPIB interfaces to the test set are only used for the mobile terminated (MT) SMS message containing the MMS notification. If you originate an MMS from the mobile station to an external receiving entity, the SMS protocol stack in the test set and therefore, the interfaces accessing that stack are never used.

MMS using the HTTP Interface

The HTTP interface in the test set provides a full IP based end-to-end test solution for MMS.

The test set's IP data channels are used to send MMS messages between the mobile station and an MMS server on a LAN/WAN.

The MMS Notification is a mobile terminated SMS message. See HTTP Interface Configuration for Mobile Terminated SMS for information on external software requirements and test set configuration.

MMS using the GPIB Interface

Similar to SMS, an external controller must parse the MMS notification into the appropriate GPIB commands for interfacing with the test set. An external MMSC is also required to exchange the MMS messages with the mobile station.

The MMS Notification is a mobile terminated SMS message. See Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station for information on external software requirements and test set configuration.

Related Topics

Point-to-Point SMS


Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

Last updated: December 20, 2004

This section is only applicable to the lab applications.

This section describes the test set's support for mobile originated short message service (MO SMS). The topics discussed in this section include:

  • Receiving Messages from the Mobile Station
  • Test Set Configuration for Mobile Originated SMS

Receiving Messages from the Mobile Station

Mobile Originated SMS messages are received by the test set after being transmitted over the air by the mobile station. The test set displays much of the content of these messages on the front panel, makes them available for query via GPIB, or when using the HTTP interface, acts as the SMSC and routes the message to a receiving entity. (See HTTP Interface Configuration for Mobile Originated SMS for more information about using the HTTP interface with MO SMS messages.)

  • Transportation
  • Last Received Message Parameters
  • Message Content (TP-User Data) Handling

Transportation

If the SMS message is originated by the mobile station, the transportation mechanism that was used by the mobile station is displayed on the front panel display and can also be queried (See CALL:SMService:PTPoint:MORiginated[:MESSage]:TRANsport? ).

As an example, in the following graphic you can see the details for the Last Received Message . Notice that the Transportation field contains the value CS Domain . This indicates that the CS domain was used to deliver this message from the mobile station.

Last Received Message Parameters

The header and message elements of mobile originated SMS Submit messages made available to you by the test set are listed below:

  • Coding Scheme
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:DCSCheme?
  • Length
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:LENGth?
  • Destination
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:DESTination?
  • Content
    • See Message Content (TP-User Data) Handling for more information
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:CONTents? or CALL:SMService:PTPoint:MORiginated[:MESSage]:TEXT?
  • Reference No
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:MREFerence?
  • UDHI
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHind?
  • Protocol Identifier
    • available using GPIB only
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:PIDentifier?
  • Status
    • See Status Report Mode
    • available via GPIB only
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:SRRequest?
  • User Data Header Length
    • available via GPIB only
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHLength?

Message Content (TP-User Data) Handling

To provide uplink support for any format of message encoding, the content of all types of received MO SMS messages can be retrieved via GPIB. Unless predetermined, it is necessary to query a received message's format or data coding scheme results before determining how the contents should be interpreted.

The raw content of each MO SMS message received by the test set is made available for query as an ASCII formatted string of hex characters. This hex string represents the entire TP-UD from the message and includes any User Data Header and fill bits that may be present in the content. To aid in extracting any present header data from the content, the User Data Header Length query (see CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHLength? ) is provided which returns the length (in bytes) of the received messages user data header. For example, if this query returns <x> then the first <x> * 2 characters of the returned hex string are the user data header.

For messages encoded as 7-bit text (with or without a User Data Header), a separate query is also provided to return the ASCII string representing the actual text in the message. Note that this returned string does not include any User Data Header or fill bits found in the original content, only the ASCII representation of the actual text in the message content is returned. This query returns an empty string for all non 7-bit text based messages received.

The following queries are provided for retrieving the contents of received MO SMS messages:

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:CONTents? - for retrieving an ASCII formatted string of hexadecimal characters
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:TEXT? - for retrieving a string of ASCII text characters

Test Set Configuration for Mobile Originated SMS

You can configure the following parameters in the test set to control handling of mobile originated SMS messages:

  • Message Loopback
  • Message Queue
  • Submit Report Mode
  • Status Report Mode
  • Submit Report Type

Message Loopback

This feature gives you the ability to simulate the complete transfer of an SMS message from an originating mobile station to a destination mobile station through the network. The test set takes the message it receives from the mobile station and sends it back to the mobile station.

This feature also allows you to perform basic tests on data formats such as binary or UCS2 as the data type received from the mobile station is returned to it using the loopback feature.

Message Queue

Individual messages from a larger concatenated message or otherwise may arrive at the test set within relatively short periods of time from one another. If an external controller responding to these messages via a polling or interrupt mechanism does not react quickly enough to the arrival of each message, it is conceivable that results for some individual messages may be overwritten in the test set before the controller has had time to extract them. In this scenario, messages can effectively be lost and it may not be possible to rebuild a complete concatenated message at the controller.

To provide complete test support for concatenated SMS, a queuing capability for MO SMS messages is provided in the test set via the GPIB interface.

Parameter | GPIB Command
Turn message queuing ON and OFF | CALL:SMService:PTPoint:MORiginated:QUEue[:STATe]
Extract the next message from the queue | CALL:SMService:PTPoint:MORiginated:QUEue:NEXT
Query the current number of messages in the queue | CALL:SMService:PTPoint:MORiginated:QUEue:COUNt?

Using the message queue

When MO SMS message queuing is ON, any received SMS-SUBMIT message from the mobile station are placed into a queue rather than overwriting existing results. The queue functions as follows:

  • You can extract messages from the queue in the order they were received from the mobile station. Only the results from the last message extracted from the queue are made available for query at any one time.
  • When a controller is finished reading the results for the current message it must inform the test set that it is finished with that message via the CALL:SMService:PTPoint:MORiginated:QUEue:NEXT command. When this command is received at the test set, the message at the head of the queue is extracted (if one exists) and its results become available for query. If no messages are present in the queue at this point then the previously available results are instead cleared.
  • When queuing messages, interrupts/polling function as follows:
    • If a message is received from the mobile station when no previous messages results are available (i.e. no previous messages have been received or a controller has indicated that it has finished reading ALL previously received messages) the newly received message's results are immediately made available for query and an interrupt is generated / polling bit is set to 1.
    • If a message is received from the mobile station when a previous message's results are still available then the message is added to the queue and no interrupt is generated/polling bit does not change (i.e. remains at 1).
    • Upon receipt of the CALL:SMService:PTPoint:MORiginated:QUEue:NEXT command informing the test set that the controller is finished reading the current message, the polling bit remains set if there was a message waiting in the queue, the results of which have now been extracted and are available for query. If no further messages were waiting in the queue at this point then the polling bit is cleared back to 0.
    • It should be noted that when queuing is `ON', no interrupts are ever generated for messages arriving at the test set when a previous messages results are still available. It is the users responsibility to make use of the polling bit to ensure such messages are all read by a controller before exiting an instance of the interrupt/polling procedure.

    NOTE
    When MO SMS message queuing is OFF, interrupts occur and the polling bit is set at the time each MO message is received from the mobile station. The polling bit used varies depending on the state of message queuing, if message queuing is ON then the CONDition bit should be used, if message queuing is OFF the EVENt bit should be used (which is cleared to 0 after being read). While message queuing is OFF, the CONDition bit is glitched (from 0 to 1 then back to 0) each time a message is received.

The maximum number of messages that can be present in the queue at any one time is 255 individual (non concatenated) messages. This guarantees queuing in the worst case for a single maximum size concatenated message regardless of external controller synchronization. In reality it is unlikely the queue will ever hold this many messages when used with the interrupt or polling mechanisms as the rate messages can be received from the mobile station is limited and a controller should be extracting and handling messages at a similar speed if not faster than they are received from the mobile station. In the case of a queue overflow, a GPIB error is returned and the newly arrived message is discarded. A status bit is included in the SMS STATus subsystem to enable interrupts/polling based on overflow of the queue, see STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments for further details.

Message queuing does not effect the operation of the existing MO loopback feature.

Related Topics

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station


Responding to Mobile Originated SMS Messages

Responding to Mobile Originated SMS Messages

Last updated: December 20, 2004

This section is only applicable to the lab applications.

Submit Report and Status Report messages are both mobile terminated (MT) SMS messages sent in response to a request from the mobile station. The test set allows you to configure how it responds to these requests, either in a predetermined fashion or in a way that you specify. See the following sections for more details:

  • Submit Report Mode
  • Status Report Mode

Submit Report Mode

SMS-SUBMIT-REPORT messages are sent in response to a SMS-SUBMIT message from the mobile station to report either successful or unsuccessful reception of the message.

You can configure how the test set handles SMS-SUBMIT-REPORT responses. Two modes are available for use:

  • AUTO - SMS-SUBMIT-REPORT messages are sent automatically by the test set in response to SMS-SUBMIT messages received from the mobile station.
  • MANUAL - You control the sending of SMS-SUBMIT-REPORT messages in response to received SMS-SUBMIT messages from the mobile station. MANUAL mode allows you to specify the Submit Report Type. See Submit Report Type

Negative submit reports (sent via RP-ERR) are only explicitly sendable under the MANUAL mode of operation. When using AUTO mode, positive submit reports are sent (via an RP-ACK message) to the mobile station upon successful reception of a MO SMS message at the test set. If the test set cannot successfully receive the message (for example, if the message is corrupted) a negative submit report is returned with the relevant failure cause. It should be noted that when using AUTO mode, any value you have set for the TP-Failure Cause parameter is not used in constructing the submit report.

There are network (TR2N) and mobile station (TR2M) timers associated with the return of a SMS-SUBMIT-REPORT message. You should ensure that the time taken to respond to a SMS-SUBMIT message when using the MANUAL mode outlined above is well within the limits of these timers (by at least a couple of seconds). If a request to send an SMS-SUBMIT-REPORT is received at the test set outside these time constraints, the message will not be sent to the mobile station and the error "+240: Operation rejected; Attempting to send SMS submit report after timer TR2N expired" is returned. Given the timing associated with MANUAL mode, it should only be used in conjunction with polling or interrupts.

When using MANUAL mode, it is important that the SMS-SUBMIT-REPORT message have the Message Reference and Recipient Address fields configured to match those of the mobile originated SMS-SUBMIT message to which it is responding. Without this information, the mobile station can not correlate the report to the correct message.

As an additional testing scenario for MANUAL mode, you may want to intentionally NOT send a submit report to the mobile station to force the timeout and verify your mobile station responds appropriately. This simulates the SMSC in a real network losing its ability to respond properly.

The following GPIB command is available for configuring the submit report mode:

CALL:SMService:PTPoint:MORiginated:REPort:MODE:SUBMit

Submit Report Type

  • RP-ACK - Positive submit report to indicate the MO SMS message was received correctly.
  • RP-ERROR - Negative submit report to indicate the MO SMS message was not received correctly and to return the TP-Failure Cause parameter. You can specify the value of this parameter to be returned to the mobile station. See Failure Cause for more information.

The following GPIB command is available for configuring the submit report type:

CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE:SUBReport:RPTYpe

Status Report Mode

SMS-STATUS-REPORT messages are sent in response to a previous SMS-SUBMIT message from the mobile station which requested a status report. Requesting a status report is a mobile station feature. You may configure your mobile station to request a `receipt' or `report' for mobile originated messages. This is a mobile station configuration depending on how the feature is accessible from the user interface or proprietary interface.

Handling of SMS-STATUS-REPORT messages is configurable with two modes being provided for use:

  • AUTO - SMS-STATUS-REPORT messages are sent automatically by the test set in response to all SMS-SUBMIT messages received from the mobile station which request status reports.
  • MANUAL - You can configure the SMS-STATUS-REPORT messages sent in response to received messages from the mobile station. See Message Type for more information.

As the sending of status reports is an asynchronous event, the timing issues outlined in the previous section for submit reports is not relevant to the sending of status reports. The following setting is provided:

CALL:SMService:PTPoint:MORiginated:REPort:MODE:STATus .

Related Topics

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station


Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station

Last updated: December 20, 2004

This section is only applicable to the lab applications.

This section describes the test set's support for mobile terminated short message service (MT SMS). The topics discussed in this section include:

  • SMS Message State Synchronization
  • Transportation
  • Message Type
  • Sending a Text Message
  • Sending SMS messages for binary applications
  • Header Parameters
  • Message Parameters Managed by the Test Set

The operating mode must be Active Cell to send a mobile terminated SMS message.

SMS Message State Synchronization

When sending SMS messages programmatically, you should use the SMS Message State query (see Mobile Terminated SMS Delivery Status for more information) to delay the sending of each message until the previous message send has been acknowledged by the phone. If the command to send the message is received before the sending of a previous message has been acknowledged/rejected or timed out, the current message may not be sent.

Transportation

You can choose to send Point-to-Point SMS messages in either the CS (Circuit Switched) or PS (Packet Switched) domain. The domain to be used is configurable by specifying the Transportation mechanism (see CALL:SMService:PTPoint[:MTERminated]:TRANsport ).

The SMS layer uses the services of the GMM or MM layer to establish an RRC Connection between the test set and UE. Once the connection is established, the SMS messages are carried in RRC Direct Transfer messages over RB 3.

The test set supports SMS messaging while in idle state and also over an existing connection. You may send an SMS message to the UE while on a circuit switched call (AMR voice, RB test mode or video call), if Transportation is set to CS Domain. Similarly, you may send an SMS message to the UE while on a packet switched connection if Transportation is set to PS Domain. However, the test set does not support simultaneous CS and PS connections. If you attempt to send an SMS message with Transportation set to PS Domain , while on a CS call, an error will be posted. Similarly, you may not send an SMS message with Transportation set to CS Domain while on a PS connection.

Message Type

You can define the Message Type used for the SMS message sent from the test set to the mobile station. The Message types are defined as PDU types in 3GPP TS 23.040 Section 9.2.2. The Message types defined for MT SMS messages are:

  • Deliver - sending a short message from the network to the mobile station
  • Submit Report (not available when using the HTTP interface)- sends information as part of an acknowledgment to a Submit mobile originated (MO) SMS message. The header parameters in this Message Type are different depending on RP Type, which can be either RP-ERROR or RP-ACK. You can configure the value for this parameter in the test set (See CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE:SUBReport:RPTYpe for GPIB command information.). When the RP Type is RP-ERROR a failure cause is included with other header information. The structure of Submit Report PDUs is defined in 3GPP TS 23.040 Section 9.2.2.2. Refer to Header Parameters for all the user configurable Submit Report elements.

    See Submit Report Mode for additional information about configuring Submit Reports.

  • Status Report (not available when using the HTTP interface)- sent in response to a previous SMS-SUBMIT message from the mobile station which requested a status report. Refer to Header Parameters for all the user configurable Status Report elements. Refer to Message Parameters Managed by the Test Set for the elements automatically configured by the test set.

    See Status Report Mode for additional information about configuring Status Reports.

Sending a Text Message

The default values for the message header parameters are appropriate for sending a text message. However, when sending a text message, you may want to configure whether the message is delivered in either the CS or PS domain (see Transportation ). You may also want to specify the text message sent to the mobile station. One of two predefined messages can be sent or you can define a text message yourself. See Short Message Service (SMS) Messages for more information on selecting and defining the content for text messages.

See Procedure A: Sending a Text Message to the Mobile Station for an example of how to send an ASCII Text Message to the mobile station using the front panel.

See The test set as the server: for a simple example of how to send an ASCII Text Message to the mobile station using the HTTP interface.

Sending SMS messages for binary applications

When sending messages using binary data, such as WAP Push, smart messaging, ringtones, or MMS notifications, you may want to configure some of the header values. All the parameters configurable using the test set are listed in Header Parameters .

You must configure the following parameters to successfully send a binary SMS message:

  • Data Coding Scheme (DCS)
  • User Data Header Indicator
  • Custom User Data - The Custom Data parameter is a hexadecimal string. This string, including the appropriate header information, or the UDH (User Data Header), may be generated using an SMS gateway, or you can create the string yourself. See Short Message Service (SMS) Messages for more information on selecting and defining this parameter.

Header Parameters

Unless otherwise noted, all the following parameters can be configured when you are using the HTTP interface as well as the GPIB and front panel interfaces.

  • Data Coding Scheme (DCS)
    • Used to identify the coding scheme used by the SMS message contents.

      NOTE
      There is no coupling between the Data Coding Scheme value and the content type selected to be included in mobile terminated SMS messages. See Short Message Service (SMS) Messages for more information on content type.

    • It is important for you to configure the Data Coding Scheme parameter in order for the mobile station to know what type of message it is receiving. Some examples of parameter values that you are likely to use are:
      0 | ASCII Text Messages (concatenated or non-concatenated)
      4 | General binary messages (ringtones, vcards, bitmap picture messages, etc.)
      8 | UCS2 (Unicode) messages (Chinese, Japanese, Hebrew, etc.)
      245

      WAP Push and MMS notification messages

      247

      The Message Class for mobile terminated SMS messages is determined by two bits in the middle of the 8-bit DCS field. Therefore, the Message Class is determined by the value you specify for the DCS parameter.

    • Applicable to the following message types: Deliver, Submit Report, and Status Report. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:DCSCheme
  • Failure CauseUsed to identify the reason for the failure of a previous mobile originated short message.
    • not available in HTTP interface because Submit Report message type is not supported
    • Applicable to the Submit Report message type only. RP type must be set to RP-ERR. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:FCAuse
  • Message Reference Used to identify the previously submitted mobile o
    • riginated short message.
    • not available in HTTP interface because Status Report message type is not supported
    • if you are sending status reports via GPIB or the front panel, the Message Reference setting must be configured to match the value of the Message Reference of the mobile originated message to which you are responding.
    • Applicable to only the Status Report message type. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:MREFerence
  • More Messages to Send
    • This element is used to indicate to the mobile station if there are more messages waiting to be sent from the test set after the current message.
    • Applicable to the following message types: Deliver, Submit Report, and Status Report. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:MMTSend
  • Originating AddressUsed to identify the sender of the message.
    • Applicable to only the Deliver message type. See Message Type for more information.
    • GPIB commands
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:PLAN
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:TYPE
  • Parameter Indicator
    • Used to identify the presence of optional elements within SMS-SUBMIT-REPORT and SMS-STATUS-REPORT messages. The value you specify for this parameter determines the inclusion of the Data Coding Scheme, User Data Length, and Protocol Identifier elements for all SMS-SUBMIT-REPORT messages sent from the test set.
    • Applicable to the following message types: Submit Report and Status Report. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:PINDicator
  • Protocol IdentifierUsed to identify the higher layer protocol being used, or to indicate interworking with a particular type of telematic device.
    • Applicable to the following message types: Deliver, Submit Report, and Status Report. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:PIDentifier
  • Recipient Address
    • Used to identify the recipient of the previously submitted SMS message.
    • Not available in HTTP interface because Status Report message type is not supported
    • Applicable to only the Status Report message type. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress
  • Reply PathUsed to indicate if a Reply Path exists.
    • Applicable to only the Deliver message type. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RPATh
  • StatusUsed to describe the status of the previously sent mobile originated short message.
    • not available in HTTP interface because Status Report message type is not supported
    • Applicable to only the Status Report message type. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:STATus
  • Status Report IndicationUsed to indicate if a status report has been requested from the entity sending the SMS message to the mobile station.
    • Applicable to only the Deliver message type. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SREPort
  • User Data Header Indicator
    • This header field indicates to the mobile station that the message content contains further header information. This should be set to 1 for any type of binary message, including concatenated text messages, as they also contain additional header information.
    • Applicable to the following message types: Deliver, Submit Report, and Status Report. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:UDHind

Message Parameters Managed by the Test Set

Some header parameters are automatically calculated by the test set and included in all SMS messages sent from the test set. These header elements are:

All MT SMS message types

  • Message Type Indicator (TP-MTI) - You can configure the message type used by the test set for MT SMS messages. The test set configures this parameter to reflect the Message Type that you have indicated. (See Message Type .) Since the HTTP interface only supports the Deliver message type for MT SMS messages, the value for this parameter always indicates the Deliver message type when the HTTP interface is used.
  • Service Centre Timestamp (TP-SCTS) - This element is configured to represent the time at which the test set received the command to send the message (either over GPIB or the front panel). (3GPP 23.040 Section 9.2.3.11)
  • User Data Length (TP-UDL) - This element is set by the test set to correctly describe the size of the user data (TP-UD) included in the message. This element may be omitted for Submit Report or Status Report message types depending on the value of the TP-Parameter Indicator parameter. (See Protocol Identifier ). (3GPP 23.040 Section 9.2.3.16)

Status Report message type

See Status Report Mode for more information about configuring how the test set sends Status Report messages.

  • Status Report Qualifier (TP-SRQ) - This header parameter is always included and is always set to 0, indicating the status report is the result of a Submit message from the mobile station. (3GPP 23.040 Section 9.2.3.26)
  • Discharge Time (TP-DT) - This header parameter is always included and always set to the current time. The current time is determined by the date and time set on the test set's System Config screen. See Configuring System Time and Date . (3GPP 23.040 Section 9.2.3.13)

Related Topics

Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

Short Message Service (SMS) Messages

Mobile Terminated SMS Delivery Status

Logging SMS Messages

How to use the Short Message Service Features


Short Message Service (SMS)

Short Message Service (SMS)

Last updated: December 20, 2004

This section is only applicable to the lab application.

Short Message Service (SMS) Overview

  • Cell Broadcast Service (CBS)
  • Point-to-Point SMS
    • Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station
      • Mobile Terminated SMS Delivery Status
    • Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station
      • Responding to Mobile Originated SMS Messages
    • Short Message Service (SMS) Messages
    • HTTP Interface for SMS - Introduction
      • HTTP Interface Configuration for Mobile Terminated SMS
      • HTTP Interface Configuration for Mobile Originated SMS
        • HTTP SMS Router Web-based Configuration Interface


Point-to-Point SMS

Point-to-Point SMS

Last updated: December 20, 2004

This section is only applicable to the lab applications.

The Short Message Service (SMS) as specified in 3GPP TS 23.040 version 3.9.0 provides a means for the exchange of short messages between mobile stations and a network. The test set can simulate an SMSC (Short Message Service Center) which provides for the transmission of short messages to, or reception of short messages from an intended mobile station, and the return of acknowledgments and error messages.

The test set supports the two services that comprise SMS:

  • Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station
    • MT SMS are SMS messages sent to the mobile station.
    • The test set allows you to specify several SMS message parameters, including the type of message, the content, and header parameters. This allows you to send SMS messages of various usages and configurations.
    • See Mobile Terminated Point-to-Point Message Transfer for simple examples to get started.
  • Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station
    • MO SMS are SMS messages sent by the mobile station.
    • See Mobile Originated Point-to-Point Message Transfer for simple examples to get started.

Interfaces for Point-to-Point SMS

The test set provides two interfaces for point-to-point SMS:

  • HTTP Interface
  • GPIB Interface

These interfaces provide methods for you to control and access SMS messages sent to and received from the mobile station. These interfaces are a requirement for the test set to be able to communicate with external components used in any system for verifying the SMS capability of a mobile station.

The majority of parameters available through the GPIB interface are also accessible from the test set's front panel.

HTTP Interface

The HTTP Interface in the test set allows you to configure SMS message parameters and content, send, and receive SMS messages using HTTP protocol. This interface is useful for SMS verification because HTTP protocol is used by most commercially available SMS Gateways. The HTTP interface also allows SMS Gateways to be configured as if the test set is a Short Message Service Center (SMSC), eliminating the need for custom external software to route messages to the correct test set. This emulation of an SMSC makes it possible to route messages directly from the HTTP output interface of one test set to the HTTP input interface of another test set. Additionally, the HTTP interface also facilitates MMS message transfer to and from a mobile station if used in conjunction with compatible MMSC (Multimedia Message Service Center) software.

For more information on this interface in the test set, see the following sections:

  • HTTP Interface for SMS - Introduction
  • HTTP Interface Configuration for Mobile Terminated SMS
  • HTTP Interface Configuration for Mobile Originated SMS
  • Multimedia Service (MMS) Messages

GPIB Interface

There is also a GPIB interface for configuring SMS message parameters and content and sending and receive SMS messages, acknowledgments, and error messages. The GPIB interface provides support for Deliver, Submit, Deliver Report, Status Report, and Submit Report message types.

When using the GPIB interface, you need to generate your own message content and set the correct header parameters for each message you send.

You may still use the GPIB interface with an SMS Gateway. To accomplish this, you must create an external software program to translate between GPIB and a protocol supported by the SMS Gateway.

  • Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station
  • Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

Related Topics

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station

Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

Short Message Service (SMS)

Cell Broadcast Service (CBS)

Short Message Service (SMS) Messages

How to use the Short Message Service Features

CALL:SMService


Mobile Terminated SMS Delivery Status

Mobile Terminated SMS Delivery Status

Last updated: December 20, 2004

This section is only applicable to the lab applications.

The test set provides the delivery status of mobile terminated SMS messages on the front panel, or it is accessible via the GPIB or HTTP interfaces.

  • MT SMS Message States
  • Using the GPIB Interface
  • Using the HTTP Interface
  • Reject Cause

MT SMS Message States

There are six possible MT SMS message states.

  • "IDLE" - An SMS message has not been successfully sent from the test set since power-up, preset, or SMS clear.
  • "SEND" - The test set has initiated the process of sending an SMS message.
  • "ACK" - The SMS message sent by the test set was acknowledged by the mobile station before timeout.
  • "NACK" - The SMS message sent by the test set was NOT acknowledged by the mobile station and send timeout.
  • "REJ" - The SMS message sent by the test set was rejected by the mobile station. A cause value for the reject is also reported by the mobile station. See Reject Cause .
  • "FAIL" - A command to send an SMS message has been received by the test set, but it cannot send the SMS message over the air because of an error. An example of a situation that would produce such an error is if the mobile station is not connected to the test set.

Using the GPIB Interface

The CALL:SMService:PTPoint[:MTERminated]:SEND:STATe? query returns a string indicating the state of the last message sent from the test set to the mobile station.

If the delivery status returned is "REJ", you can use the CALL:SMService:PTPoint[:MTERminated]:RCAuse? query to retrieve the reject cause value returned by the mobile station. See Reject Cause for the meanings of the possible cause values.

Using the HTTP Interface

The state of the last MT SMS message sent from the test set to the mobile station can be queried from the test set using an HTTP GET request with the following URL:

/sms/mtstate

The delivery state is returned in the body of the HTTP response.

Example using an internet browser

You can query the MT SMS delivery state through the HTTP interface using an internet browser by entering the following URL:

http://<x.x.x.x>/sms/mtstate

where <x.x.x.x> is the IP address of the test set sending the SMS to the mobile station. This example is illustrated in the following figure.

If the state returned is "REJ", the body of the HTTP response also contains the reject cause value as an integer. The reject cause value is placed in the response body after the REJ characters and separated from them by a single space character. For example, "REJ 211" is returned in the HTTP response if the MT SMS was rejected with a cause value of 211. See the following figure.

See Reject Cause for the meanings of the possible cause values.

Reject Cause

Reject Cause | Hex equivalent | Description
129 | 81 | Short message Type 0 not supported
130 | 82 | Cannot replace short message
143 | 8F | Unspecified TP-PID error
145 | 90 | Message class not supported
159 | 9F | Unspecified TP-DCS error
176 | B0 | TPDU not supported
208 | D0 | (U)SIM SMS storage full
209 | D1 | No SMS storage capability in (U)SIM
210 | D2 | Error in MS
211 | D3 | Memory Capacity Exceeded
212 | D4 | (U)SIM Application Toolkit Busy
213 | D5 | (U)SIM data download error
224-254 | E0-FE | Values specific to an application
255 | FF | Unspecified error cause

Related Topics

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station


Trigger Output Setup

Trigger Output Setup

Last updated: December 20, 2004

The test set provides a 5 V, 16.5 us pulse at the TRIG OUT rear panel connector for triggering other test equipment from the test set. This pulse is generated according to the Trigger Output Setup setting:

  • System Frame Clock - a pulse is generated every 10 ms, in alignment with the first symbol period of each frame.
  • Measurement Generated - pulses are generated when certain measurements are initiated or are running. The following measurements send a defined trigger signal to the TRIG OUT connector when Trigger Output Setup is set to Measurement Generated :

    • Out-of-Synch Handling of Output Power Measurement Description

    NOTE
    When Trigger Output Setup is set to Measurement Generated , the signal present at the TRIG OUT connector is undefined when any measurements other than those listed above are triggered or running.

To access Trigger Output Setup from the front panel, press the CALL SETUP key, press the More key until you reach the Call Control 2 of 4 menu, and then select Trig Output Setup ( F6 ).

Related Topics

CALL:TRIGger


UE Expected Open Loop Transmit Power

UE Expected Open Loop Transmit Power

Last updated: December 22, 2004

The UE uses open loop power control to determine the transmit power of the first PRACH preamble and of the DPCH as it is first turned on. Once the DPCH is established its power is controlled solely by closed loop power control (see Uplink Closed Loop Power Control Parameters and UE Target Power ).

Open Loop Power Control

The test set calculates the expected transmit power of the first PRACH preamble and of the DPCH (at turn-on the DPCH consists only of the DPCCH) and displays them in the UE Expected Open Loop Transmit Power window on the Call Setup Screen .

Initial PRACH Tx Power

The test set calculates the expected transmit power of the first PRACH preamble using the following formula:

Initial PRACH Tx Power = Primary CPICH TX power - CPICH RSCP + Uplink Interference + Constant value

Three parameters are user settable: Primary CPICH TX Power , Uplink Interference , and Constant Value .

NOTE
Ensure that you do not set these parameters such that the UE would be required to transmit its PRACH at a power level equal to or greater than its maximum transmit power or the power specified by the Maximum Uplink Transmit Power Level setting. See Call Setup Fails Due to Transmission of Single PRACH Preamble .

The fourth parameter, CPICH RSCP (Received Signal Code Power) , is the result of the UE reported measurement of the CPICH code channel power.

Initial DPCCH Tx Power

The test set calculates the expected initial transmit power of the DPCCH using the following formula:

Initial DPCCH Tx Power = DPCCH Power Offset - CPICH RSCP

where

DPCCH Power Offset = MS Target Power + 20 log (Manual Uplink DPCH Bc/(Manual Uplink DPCH Bc + Manual Uplink DPCH Bd)) + CPICH RSCP.

Thus,

Initial DPCCH Tx Power = MS Target Power + 20 log (Manual Uplink DPCH Bc/(Manual Uplink DPCH Bc + Manual Uplink DPCH Bd))

All three parameters are user settable: UE Target Power , Manual Uplink DPCH Bc , and Manual Uplink DPCH Bd .

Related Topics

How Do I Change UE TX Power Levels


Uplink Channel (UARFCN)

Uplink Channel (UARFCN)

Last updated: December 20, 2004

Uplink Channel

The Uplink Channel setting specifies the uplink UTRA Absolute RF Channel Number (UARFCN). This automatically sets the test set's receivers to the expected UE transmit frequency.

The relationship between UARFCN and uplink frequency is described in 3GPP TS 25.101 section 5.

Uplink Frequency and UARFCN, and Uplink Channel Range
Band | TS 25.101 DL to UL Frequency Separation (MHz) | TS 25.101 Center Frequency Range (MHz) | TS 25.101 UARFCN Equation | TS 25.101 UARFCN Range | Test Set's "Uplink Channel" Range (increment = 1 for all)
I (IMT-2000) | 190 | 1922.4 - 1977.6, increment = 0.2 | 5 * (center freq in MHz) | 9612 - 9888, increment = 1 | 9225 - 9925
II (U.S. PCS) | 80 | 1852.4 - 1907.6, increment = 0.2 | 5 * (center freq in MHz) | 9262 - 9538, increment = 1 | 9225 - 9925
 |  | 1852.5 - 1907.5, increment = 5 | 5 * ((center freq in MHz) - 1850.1 MHz) | 12 - 287, increment = 25 | 12 - 287
III (DCS/PCS) | 95 | 1712.4 - 1782.6, increment = 0.2 | 5 * (center freq in MHz) | 8562 - 8913, increment = 1 | 8525 - 8950
IV | 400 | 1712.4 - 1752.6, increment = 0.2 | 5 * (center freq in MHz) | 8562 - 8763, increment = 1 | 8525 - 8950
 |  | 1712.5 - 1752.5, increment = 5 | 5 * ((center freq in MHz) - 1480.1 MHz) | 1162 - 1362, increment = 25 | Not supported
V (US Cellular) | 45 | 826.4 - 846.6, increment = 0.2 | 5 * (center freq in MHz) | 4132 - 4233, increment = 1 | 4095 - 4270
 |  | 826.5, 827.5, 831.5, 832.5, 837.5, 842.5 | 5* ((center freq in MHz) - 670.1 MHz) | 782, 787, 807, 812, 837, 862 | 812 - 837
VI (Japan 800) | 45 | 832.4 - 837.6, increment = 0.2 | 5 * (center freq in MHz) | 4162 - 4188, increment = 1 | 4095 - 4270
 |  | 832.5, 837.5 | 5 * ((center freq in MHz) - 670.1 MHz) | 812, 837 | 812 - 837
The test set also supports an Uplink Channel range of 4375 - 4600, which corresponds to a center frequency range of 875 - 920 MHz (UARFCN = 5 * (center freq in MHz)).

You can specify the uplink UARFCN in one of two ways:

  • Uplink Channel

    Directly set the Uplink Channel setting to a specific uplink UARFCN value.

    GPIB command: CALL:UPLink:CHANnel[:MCHannel]

  • Uplink Separation

    With Uplink Channel set to manual control (not set to Auto ), choose an Uplink Separation , then set Uplink Channel to Auto . The uplink UARFCN is then determined by subtracting the Uplink Separation value from the downlink frequency determined by the DL Channel setting.

    GPIB commands: CALL:UPLink:CHANnel:CONTrol:AUTO , CALL:UPLink:CHANnel:SEParation

To query the current uplink channel number via GPIB command, see CALL:STATus:UPLink:CHANnel? .

When in FDD Test operating mode, the expected uplink frequency can also be set by manually entering the Uplink Frequency (see Receiver Control ).

To set the uplink channel number from the front panel, see Setting DL Channel, Uplink Channel and Uplink Separation .

Operating Considerations

  • These settings cannot be changed while in active cell operating mode. Attempting to change these settings while in this mode results in an error and the test set rejects the change. Use the Cell Off operating mode when changing these settings. See CALL:OPERating to select operating modes.
  • To hand over to a new uplink channel while on a connection, you must perform a Physical Channel Reconfiguration . After successful completion of a handover to a new UL UARFCN, the Uplink Channel and Uplink Separation settings are overwritten with the values of Handoff Uplink UARFCN and Handoff Uplink Separation .
  • If Uplink Channel is set to Auto , and you attempt to set Uplink Separation to a value that would result in an Uplink Channel that is not within the supported range (based on the current DL Channel setting), an error is posted and the change is rejected. Similarly, if you attempt to set Uplink Channel to Auto when the current DL Channel and Uplink Separation values would result in an Uplink Channel that is not within the supported range, an error is posted and the change is rejected. With Uplink Channel not set to Auto , set DL Channel and Uplink Separation to a valid combination, then set Uplink Channel to Auto .
  • If the Uplink Channel setting results in an UL/DL offset of less than 30 MHz when compared with the DL Channel setting, the warning message "Performance not specified for UL/DL frequency offset <30 MHz" is issued.

Related Topics

Manual Operation: Setting DL Channel, Uplink Channel and Uplink Separation

CALL:UPLink:CHANnel[:MCHannel]

CALL:STATus:UPLink:CHANnel?

Troubleshooting Call Processing Operations

Downlink Channel (UARFCN)

Handoffs (Handover)


Uplink Parameters

Uplink Parameters

Last updated: December 20, 2004

Uplink parameters define configuration of the Physical Random Access Channel (PRACH) and the uplink Dedicated Physical Channel (DPCH) used to set up a call. To set the uplink parameters using the test set's front panel, see How Do I Change Uplink Parameters? .

PRACH Parameters

The uplink Physical Random Access Channel (PRACH) carries the Random Access Channel (RACH) information which is transmitted by the mobile station during registrations or BS originated calls. A PRACH is composed of two parts: a number of preambles and a message portion. The preambles are a series of RF power "steps" which increase in power according to the power step setting until the maximum number of preambles is reached or the base station acknowledges receiving the preamble on the acquisition indication channel (AICH). Once the UE receives a positive indication on the AICH, it transmits the message portion of the PRACH which consists of message data and control data (pilot bit and TFCI) with independent power gain control.

Changing some of the following PRACH settings while in active cell operating mode will result in the execution of the BCCH Update procedure (see Broadcast Channel (BCCH) Update Procedure ). All of these settings can only be changed when call status is Idle.

  • PRACH Power Ramp Step

    PRACH power ramp step is used to increase the transmit power of the PRACH preamble when no response is received from the test set.

    GPIB command: CALL:UPLink:PRAChannel:POWer[:RAMP]:STEP[:LEVel] .

  • PRACH Signature

    As specified in 3GPP TS 25.211 section 5.2.2.1.2, the PRACH preamble is of length 4096 chips and consists of 256 repetitions of a signature of length 16 chips. There are a maximum of 16 available signatures that the UE can use for its PRACH preamble. 3GPP TS 25.213 section 4.3.3.3 defines these 16 signatures, which are numbered from 0 to 15.

    You may specify which of the 16 signatures are available to the UE. The UE may then choose any one signature for a PRACH preamble. As defined in 3GPP TS 25.331 section 10.3.6.52, a 16-bit mask is available to specify which of the 16 signatures are available to the UE ( PRACH Signatures, Upper (Bit Mask) and PRACH Signatures, Lower (Bit Mask) from the front panel). Setting the upper-most bit of the mask to 1 indicates that signature 15 is available, setting the lower-most bit of the mask to 1 indicates that signature 0 is available. You may set any one or all of the bits in the mask to 1. For example, setting the mask to 0010001100100011 indicates that signatures 13, 9, 8, 5, 1 and 0 are available to the UE.

    For the lab application only, the test set reports which signature is used by the UE on its final PRACH burst, see Detected PRACH Signature . If the PRACH Signature setting specifies a single PRACH signature, then Detected PRACH Signature and PRACH Signature should be the same.

    For the lab application only, the PRACH preamble analysis measurement also reports the signature used by the UE for the PRACH burst it has analyzed (see PRACH Preamble Analysis Measurement Description ). If the PRACH Signature setting specifies a single PRACH signature, then the PRACH signature reported by the measurement, Detected PRACH Signature and PRACH Signature should be the same.

    GPIB command: CALL:UPLink:PRAChannel:SMASk .

  • PRACH Scrambling Codeword

    Scrambling code used to spread the Signature when creating a PRACH preamble.

    GPIB command: CALL:UPLink:PRAChannel:SCODe .

  • PRACH Bc/Bd Control

    Used to select whether manually or automatically to adjust the gain settings for the message portion of the PRACH. GPIB command: CALL:UPLink:PRAChannel:BETA:AUTo . When Manual is selected, then:

    • Manual PRACH Bc

      Used to specify the gain setting for the control data of the message portion of the PRACH.

      GPIB command: CALL:UPLink:PRAChannel:MANual:CBETa .

    • Manual PRACH Bd

      Used to specify the gain setting for the message data of the message portion of the PRACH.

      GPIB command: CALL:UPLink:PRAChannel:MANual:DBETa .

  • Uplink Timing Offset

    The Uplink Timing Offset allows you to specify the offset of the UE's PRACH transmission from the start of the access slot. The range is -256 to +256 chips.

    For the lab application only, you can use the PRACH Preamble Analysis measurement to calculate your UE's offset (see Timing Error (in chips) ).

    Uplink Timing Offset can not be changed in Active Cell operating mode. You must change the Uplink Timing Offset value while in an operating mode other than active cell. The change is then applied when you switch to active cell operating mode.

    GPIB command: CALL:UPLink:PRAChannel:TIMing[:OFFSet]

  • PRACH Preambles

    Specifies the maximum number of preambles to be sent during one PRACH Ramping Cycle when no response is received from the test set.

    GPIB command: CALL:UPLink:PRAChannel:PREambles:NUMBer .

  • PRACH Ramping Cycles (MMAX)

    Specifies the maximum number of preamble sequences to be repeated when no response is received from the test set.

    GPIB command: CALL:UPLink:PRAChannel:PREambles:RCYCles[:MMAX] .

  • Available Subchannels (Bit Mask)

    Specifies which of the twelve PRACH Access Subchannels are available for UE PRACH access. A setting of "1" indicates the corresponding subchannel is available, while a setting of "0" means the subchannel is unavailable. For example, a setting of "111111111111" means all twelve subchannels are available.

    GPIB command: CALL:UPLink:PRAChannel:ASUBchannels .

  • Maximum Uplink Transmit Power Level

    This setting tells the UE the maximum transmit power that it is allowed to use while camped on the cell.

    NOTE
    This setting affects whether the UE can camp to the test set. To ensure that your UE will camp to the test set at low cell power levels, set Maximum Uplink Transmit Power Level to the maximum transmit power for your UE. See UE Does Not Camp to Test Set at Low Cell Power Levels .

    3GPP TS 25.101 6.2.1 specifies the following maximum transmit powers per power class:

    Maximum Transmit Power vs. Power Class
    Power Class | Maximum Transmit Power (dBm)
    1 | +33
    2 | +27
    3 | +24
    4 | +21

    To aid in successful call completion, ensure that your UE does not begin its PRACH preamble sequence at the Maximum Uplink Transmit Power Level or its maximum transmit power (see Call Setup Fails Due to Transmission of Single PRACH Preamble ).

    GPIB command: CALL:UPLink:TXPower:LEVel:MAXimum .

DPCH Parameters

The uplink Dedicated Physical Channel (DPCH) consists of the Dedicated Physical Data Channel (DPDCH) which carries the user data, and the Dedicated Physical Control Channel (DPCCH) which carries the physical layer control information (pilot data, TFCI and TPC).

  • Uplink DPCH Scrambling Code

    Scrambling code used to provide a unique channelization required for each UE (must be in cell off mode).

    GPIB command: CALL:UPLink:DPCHannel:SCODe .

  • Uplink DPCH Bc/Bd Control

    Used to select whether manually or automatically to adjust the gain settings for DPCH.

    GPIB command: CALL:UPLink:DPCHannel:BETA:AUTo .

    When Manual is selected, the following two settings are available (must be in cell off mode):

    • Manual Uplink DPCH Bc

      Used to specify the gain setting for the DPCCH.

      GPIB command: CALL:UPLink:DPCHannel:MANual:CBETa .

    • Manual Uplink DPCH Bd

      Used to specify the gain setting for the DPDCH.

      GPIB command: CALL:UPLink:DPCHannel:MANual:DBETa .

Operating Considerations

Uplink parameters are used during Active Cell operation to set up a call, but can only be changed during Cell Off mode operation, or while the call status is Idle in Active Cell mode. See CALL:OPERating to select operating modes.

To prevent the test set from responding to the PRACH request before reaching the maximum number of preambles as specified, you can turn the Call Limit State on. See Call Limit State .

Related Topics

How Do I Change Uplink Parameters?


Uplink Closed Loop Power Control Parameters and UE Target Power

Uplink Closed Loop Power Control Parameters and UE Target Power

Last updated: December 22, 2004

Once the DPCH is established, the test set transmits power control information on the DPCCH to control the UE's transmit power (see UE Expected Open Loop Transmit Power ).

UL CL Power Control Mode

UL CL Power Ctrl Mode controls what power control bit pattern is sent to the UE. It can be set to the following:

  • Active bits - the test set sends the power control bits required to maintain the UE's average power at the value entered for UE Target Power .
  • Alternating bits - the test set sends alternating power-up and power-down bits to the UE. This causes the UE to continuously transmit at a fixed power level (the power level it was transmitting at when Alternating bits was activated). When in Alternating bits mode, you can instruct the UE to increase or decrease its transmit power level by 1 dB using the Send Step Up TPC Bit Pattern or Send Step Down TPC Bit Pattern commands (see Send Step Up/Down TPC Bit Pattern ).
  • All Up bits - the test set sends a continuous pattern of power-up bits. This is often used to drive the UE to transmit at its maximum power level.
  • All Down bits - the test set sends a continuous pattern of power-down bits. This is often used to drive the UE to transmit at its minimum power level.
  • 10 Up/Down bits - the test set sends a repeating pattern of 10 power-up bits and 10 power-down bits. The pattern always begins on a frame boundary.

UL CL Power Ctrl Algorithm

UL CL Power Ctrl Algorithm specifies which power control algorithm the UE should use while under closed loop power control (see 3GPP TS 25.214 5.1.2.2.1). The power control algorithm determines the method the UE uses to derive a single TPC_cmd for each slot from the TPC commands received from the cell. See UL CL Power Ctrl Stepsize for information regarding how TPC_cmd is then translated into a UE transmit power change.

UL CL Power Ctrl Algorithm can be set to:

  • One - When using power control algorithm one to process TPC commands, the UE determines TPC_cmd for each slot based on the TPC commands received in that slot (if the UE is in soft handover, it will receive more than one TPC command in each slot).
    If only one TPC command is received in the slot and is equal to 0, then TPC_cmd for that slot is -1. If only one TPC command is received in the slot and is equal to 1, then TPC_cmd for that slot is 1. (See 3GPP TS 25.214 5.1.2.2.2 for more information about how the UE combines TPC commands received in a slot.)
    Some measurements may give unexpected results when the UE is using power control algorithm one, because power control algorithm one may cause the UE's output power to change during the measurement interval.
  • Two - When using power control algorithm two to process TPC commands, the UE processes TPC commands on a 5-slot cycle, where the set of 5 slots is aligned to a frame boundary. If only one TPC command is received in each slot, TPC_cmd is derived as follows: TPC_cmd for the first 4 slots in the 5-slot set is always 0. For the fifth slot in the set, TPC_cmd is 1 if the TPC commands for all 5 slots are 1, is -1 if the TPC commands for all 5 slots are 0, and is 0 otherwise.

This setting can only be changed while in Idle state or Cell Off Operating Mode .

This setting applies to both cell 1 and cell 2 (for the lab application only).

UL CL Power Ctrl Stepsize

When UL CL Power Ctrl Algorithm is set to One , you can specify the size of the change in UE power for each TPC_cmd. You can set UL CL Power Ctrl Stepsize to 1 dB or 2 dB, which sets [image] TPC to 1 dB or 2 dB, respectively. For algorithm two, [image] TPC is always set to 1 dB.

The UE determines its required change in output power by multiplying [image] TPC by TPC_cmd. The change in power is applied in the slot adjacent to the slot in which TPC_cmd was received.

This setting can only be changed while in Idle state or Cell Off Operating Mode .

This setting applies to both cell 1 and cell 2 (cell 2 is present in the lab application only).

Cell 2 UL CL Power Ctrl Mode

For the lab application only, the test set can send power control bit patterns to the UE on cell 2. The same modes are available as the UL CL Power Control Mode setting.

When Cell 2 Power Ctrl is set to Active bits , the same power control bits are sent on the cell 1 DPCCH and the cell 2 DPCCH.

See Cell 2 Overview .

Send Step Up/Down TPC Bit Pattern

Send Step Up TPC Bit Pattern and Send Step Down TPC Bit Pattern can send individual transmit power control (TPC) commands (on the cell 1 DPCCH) to change the UE's power up or down by 1 dB. These functions can only be used when UL CL Power Control Mode is set to Alternating bits .

UE Target Power

UE Target Power specifies the expected power level from the UE. It is also used to set the expected power level into the test set's receiver (see Expected Power ).

When operating in Active Cell mode, if UL CL Power Control Mode is set to Active bits , the test set sends the required transmit power control bits to the UE to drive its transmit power to the level set by UE Target Power . UL CL Power Ctrl Mode must be set to Active Bits in order for the test set to command the UE to output at the specified UE Target Power .

When operating in FDD test mode, this setting sets the UE expected power into the test set's receiver when using automatic receiver control. This setting is not used during manual receiver control. See Receiver Control .

GPIB Commands for Setting These Parameters

  • UL CL Power Ctrl Mode - CALL[:CELL]:CLPControl:UPLink:MODE
  • UL CL Power Ctrl Algorithm - CALL[:CELL]:CLPControl:UPLink:ALGorithm
  • UL CL Power Ctrl Stepsize - CALL[:CELL]:CLPControl:UPLink:STEPsize
  • Cell 2 Power Ctrl - CALL:CELL2:CLPControl
  • Send Step Up TPC Bit Pattern - CALL[:CELL]:CLPControl:UPLink[:IMMediate]:UP
  • Send Step Down TPC Bit Pattern - CALL[:CELL]:CLPControl:UPLink[:IMMediate]:DOWN
  • UE Target Power - CALL:MS:POWer

Related Topics

Manual Operation: How Do I Change UE TX Power Levels

UE Expected Open Loop Transmit Power

Receiver Control

Cell 2 Overview

Active Cell Operating Mode


Compressed Mode Ladder Diagrams

Compressed Mode Ladder Diagrams

Last updated: December 20, 2004

This section is only applicable to the lab application.

  • TGPS Definition during Call Setup, Compressed Mode Activated without UE Measurements
  • TGPS Definition after Call Is Established, Compressed Mode Activated without UE Measurements
  • TGPS Definition during Call Setup, Compressed Mode Activated with UE Measurements
  • TGPS Definition after Call Is Established, Compressed Mode Activated with UE Measurements
  • Deactivating Compressed Mode

There are four different ways that compressed mode can be enabled in the test set and UE (see Summary of Options for Enabling Compressed Mode and UE Measurements ).

TGPS Definition during Call Setup, Compressed Mode Activated without UE Measurements

TGPS Definition after Call Is Established, Compressed Mode Activated without UE Measurements

TGPS Definition during Call Setup, Compressed Mode Activated with UE Measurements

TGPS Definition after Call Is Established, Compressed Mode Activated with UE Measurements

Deactivating Compressed Mode

Related Topics

Compressed Mode


Handoff Ladder Diagrams

Handoff Ladder Diagrams

Last updated: December 20, 2004

  • Physical Channel Reconfiguration (Inter-frequency Hard Handoff)
  • Transport Channel Reconfiguration
  • System Handoff from W-CDMA RB Test Mode to GSM Voice (with RB Test Mode to GSM Handoff Alerting State = On)
  • System Handoff from W-CDMA RB Test Mode to GSM Voice (with RB Test Mode to GSM Handoff Alerting State = Off)
  • System Handoff from W-CDMA AMR Voice to GSM Voice

Physical Channel Reconfiguration (Inter-frequency Hard Handoff)

Transport Channel Reconfiguration

System Handoff from W-CDMA RB Test Mode to GSM Voice (with RB Test Mode to GSM Handoff Alerting State = On)

System Handoff from W-CDMA RB Test Mode to GSM Voice (with RB Test Mode to GSM Handoff Alerting State = Off)

System Handoff from W-CDMA AMR Voice to GSM Voice

Related Topics

Handoffs (Handover)


Handoffs (Handovers)

Handoffs (Handovers)

Last updated: December 21, 2004

There are four types of handoffs (handovers) available in the test set:

  • Physical Channel Reconfiguration
  • Transport Channel Reconfiguration
  • System Handoff (GSM/GPRS_W-CDMA fast switching test and lab applications only)
  • Soft Handoff (lab application only)

Physical Channel Reconfiguration

Inter-frequency hard handoffs are supported in all Service Types , and are accomplished by performing a physical channel reconfiguration (you can not simply change the DL Channel and/or Uplink Channel settings while on a call, you must perform a physical channel reconfiguration).

You must be on a call to perform a physical channel reconfiguration.

To execute a physical channel reconfiguration, you must first specify the:

  • Handoff Downlink Channel (UARFCN)

    GPIB command: CALL:SETup:CHANnel<[:SELected]|:FDD>:DOWNlink .

  • Uplink UARFCN to which to handoff. You can specify the uplink UARFCN to handoff to in one of two ways:

    • Handoff Uplink Channel (UARFCN)

      Directly set the Handoff Uplink Channel (UARFCN) setting to a specific uplink UARFCN value.

      GPIB command: CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink[:MCHannel] .

    • Handoff Uplink Separation

      With Handoff Uplink Channel (UARFCN) not set to Auto , choose a Handoff Uplink Separation , then set Handoff Uplink Channel (UARFCN) to Auto . The uplink UARFCN to handoff to is then determined by subtracting the Handoff Uplink Separation value from the handoff downlink frequency determined by the Handoff Downlink Channel (UARFCN) setting.

You must then select Execute Handoff ( F5 ) or send the CALL:HANDoff:PCReconfig[:IMMediate] command to initiate the reconfiguration.

NOTE
In order for the physical channel reconfiguration to be successful, some UEs may require that you include the Handoff Downlink UARFCN in the SIB11 Inter-Freq Cell Info List (see Inter-frequency Cells ).

When the physical channel reconfiguration is complete, the DL Channel , Uplink Channel and Uplink Separation values are updated to the new channels as specified by the Handoff Downlink Channel (UARFCN) , Handoff Uplink Channel (UARFCN) and Handoff Uplink Separation settings. Similarly, the Handoff Downlink Channel (UARFCN) , Handoff Uplink Channel (UARFCN) and Handoff Uplink Separation parameters are updated to the prior values for DL Channel , Uplink Channel and Uplink Separation , to make it easy for you to quickly handoff back and forth between two sets of channel settings by repeatedly selecting Execute Handoff ( F5 ) or sending the CALL:HANDoff:PCReconfig[:IMMediate] command.

NOTE
In order for these repeated physical channel reconfigurations to be successful, some UEs may require that you include the Handoff Downlink UARFCN and original DL Channel used to establish the call in the SIB11 Inter-Freq Cell Info List (see Inter-frequency Cells ).

Physical Channel Reconfiguration Operating Considerations

  • Any measurements that have been initiated are aborted when a physical channel reconfiguration is initiated.
  • If you attempt any of the following, an error is posted and the change is rejected:
    • With Handoff Uplink Channel (UARFCN) set to Auto , set Handoff Downlink Channel (UARFCN) to a value that would result in a Handoff Uplink Channel (UARFCN) that is not within the supported range (based on the current Handoff Uplink Separation setting).
    • With Handoff Uplink Channel (UARFCN) set to Auto , set Handoff Uplink Separation to a value that would result in a Handoff Uplink Channel (UARFCN) that is not within the supported range (based on the current Handoff Downlink Channel (UARFCN) setting).
    • Set Handoff Uplink Channel (UARFCN) to Auto when the current Handoff Downlink Channel (UARFCN) and Handoff Uplink Separation values would result in a Handoff Uplink Channel (UARFCN) that is not within the supported range.

    You must instead do the following: with Handoff Uplink Channel (UARFCN) not set to Auto , set Handoff Downlink Channel (UARFCN) and Handoff Uplink Separation to a valid combination, then set Handoff Uplink Channel (UARFCN) to Auto .

  • If the Handoff Downlink Channel (UARFCN) and Handoff Uplink Channel (UARFCN) settings result in an UL/DL offset of less than 30 MHz, the warning message "Performance not specified for UL/DL frequency offset <30 MHz" is issued.

Transport Channel Reconfiguration

The transport channel reconfiguration allows you to move between Symmetrical RMCs while on a Radio Bearer Test Mode call (you can not hand off between Asymmetrical RMCs ). You must be on an RB test mode (symmetrical RMC) call to perform a transport channel reconfiguration.

To execute a transport channel reconfiguration, you first must specify the following parameter:

  • Handoff RB Test Mode RAB: see CALL:SETup:TCReconfig:RBTest:RAB .

You must then select Execute Handoff ( F5 ) or send the CALL:HANDoff:TCReconfig[:IMMediate] command to initiate the reconfiguration.

When the transport channel reconfiguration is complete, the Channel Type setting is updated to reflect the current RMC connection.

System Handoff

This functionality is only available in GSM/GPRS_W-CDMA fast switching test and lab applications.

The system handoff functionality allows you to move from a W-CDMA Radio Bearer Test Mode or W-CDMA AMR Voice call to a GSM voice call. You must be on a Radio Bearer Test Mode or AMR Voice call to perform a system handoff.

Before executing a system handoff you must specify the following parameters: (see How Do I Perform a Handoff (Handover)? )

  • RB Test Mode to GSM Handoff Alerting State
    • On: When this parameter is set to On , when performing a handoff from W-CDMA RB test mode to a GSM voice call, the UE will ring. You must answer the ring for the connection to be completed and testing to progress.
      This occurs because the radio bearer test mode connection terminates in the Test Control (TC) protocol entity, rather than the Call Control (CC) protocol entity used for voice communication. Thus, the UE's CC entity is in the idle state. When the handoff from RB test mode to GSM voice is executed, the test set first performs the handoff in the RR Connected state. If RB Test Mode to GSM Handoff Alerting State is set to On , the test set then continues to establish a CC Connection for voice service. As a result, once the test set and UE have transitioned to GSM service, the UE will alert. See System Handoff from W-CDMA RB Test Mode to GSM Voice (with RB Test Mode to GSM Handoff Alerting State = On) .
    • Off: When this parameter is set to Off , when performing a handoff from W-CDMA RB test mode to a GSM voice call, the UE will not ring. When the handoff is completed, the connection is left in the RR Connected state. Data loopback (for BER testing) is available in this state, but voice echo is not. See System Handoff from W-CDMA RB Test Mode to GSM Voice (with RB Test Mode to GSM Handoff Alerting State = Off) .

    GPIB command: CALL:SETup:SYSTem:GSM:ALERting[:STATe] .

  • GSM BCC (Base Station Color Code): see CALL[:CELL]:BCCode . Note, you MUST include the mnemonic :GSM at the end of this command, i.e. you must issue the command as CALL[:CELL]:BCCode:GSM.
  • GSM NCC (Network Color Code): see CALL[:CELL]:NCCode:GSM . Note, you MUST include the mnemonic :GSM at the end of this command, i.e. you must issue the command as CALL[:CELL]:NCCode:GSM.
  • GSM Cell Band: see CALL[:CELL]:BAND[:SELected] . Note, you MUST include the mnemonic :GSM at the end of this command, i.e. you must issue the command as CALL[:CELL]:BAND:GSM.
  • GSM Broadcast Chan: see CALL[:CELL]:BCHannel[:ARFCn][:SELected] . Note, you MUST include the mnemonic :GSM at the end of this command, i.e. you must issue the command as CALL[:CELL]:BCHannel[:ARFCn]:GSM.
  • GSM Traffic Band: see CALL:TCHannel:BAND .
  • GSM Traffic Channel: see CALL:TCHannel[:ARFCn][:SELected] .
  • GSM TCH Timeslot: see CALL:TCHannel:TSLot .
  • GSM Channel Mode: see CALL:TCHannel:CMODe[:VALue] .
  • GSM Half Rate Speech Sub Channel: see CALL:TCHannel:CMODe:HRSPeech:SCHannel .
  • GSM MS TX Level: see CALL:MS:TXLevel[:SELected] .

NOTE
Changing any of these settings while operating in the W-CDMA format changes the corresponding parameter settings in the GSM/GPRS format of the fast switching application.
Presetting the test set while operating in the W-CDMA format will not reset these parameters to their default settings. Presetting the test set while operating in the GSM/GPRS format will reset these parameters to their default values.
When operating in the W-CDMA format, these settings are not saved when using the SAVE REGISTERS utility.

You must also ensure that the GSM/GPRS format is set to Active Cell (GSM) operating mode.

You must then select Execute Handoff ( F5 ) or send the CALL:HANDoff:SYSTem:GSM[:IMMediate] command to initiate the handoff.

Soft Handoff

This functionality is only available in the lab application. See Soft Handoff .

Related Topics

How Do I Perform a Handoff (Handover)?

Step 6: Reconfigure Test Set and UE Connection Parameters

CALL:SETup

CALL:HANDoff

Handoff Ladder Diagrams

Troubleshooting Handoffs (Handovers)


Call Processing Status

Call Processing Status

Last updated: December 20, 2004

Call Processing Status

The Call Processing Status window on the Call Setup screen displays the following information when in Active Cell Operating Mode :

  • Current Service Type

    Reports the current service type. See Service Types .

    GPIB query: CALL:STATus:SERVice:TYPe? .

  • GMM State

    This functionality is present in the lab application only.

    GMM State indicates the result of the most recent GPRS attach or detach. It is set to Attached when the UE has successfully completed the GPRS Attach procedure and Detached on completion of the GPRS Detach procedure. If the UE sends the test set an Attach Request but never responds to the Attach Accept with an Attach Complete, then it is set to Attach Incomplete . GMM state is cleared when you clear the UE information (see Clearing the UE Information ) and is set to None on power up and preset.

    See GPRS Packet Data Service .

    GPIB command: CALL:STATus[:GMM]:ATTached:STATe? .

  • Soft Handoff State

    This functionality is present in the lab application only. See Soft Handoff .

    GPIB command: CALL:STATus:SHANdoff:STATe? .

  • Compressed Mode State

    This functionality is present in the lab application only. See Compressed Mode .

    GPIB command: CALL:STATus:COMPressed:STATe? .

  • RRC State

    This functionality is present in the lab application only.

    RRC State indicates whether the RB Test Mode service has set the UE up into a CELL_FACH or CELL_DCH state, or is Idle . See RB Test Mode RRC State Setting .

    GPIB command: CALL:STATus:RRC:STATe? .

  • MM Status

    MM Status indicates the result of the last MM procedure that the UE performed. Only a subset of MM procedures are tracked by this result: Updated (Normal) , Updated (Periodic) , IMSI Attached , IMSI Detached , None . MM state is cleared when you clear the UE information (see Clearing the UE Information ).

    See Performing a Location Update (Registration) .

    GPIB command: CALL:STATus:MM? .

Active Cell Call Processing State

Additional call processing state information is also displayed in the small Active Cell window at the bottom of the Call Setup screen, and may be queried using the CALL:STATus[:STATe][:VOICe]? , CALL:STATus[:STATe]:DATA? and CALL:CONNected[:STATe] queries.

The active cell call processing state can be any of the following:

Call States

  • Alerting (CALL)

    Alerting is returned when the test set is alerting the UE to an incoming AMR voice call request.

  • Connected (CONN)

    Connected is returned when the test set and UE are connected on a call.

  • Handoff (HAND)

    Handoff is returned when the test set is in the process of handing off the UE.

  • Idle (IDLE)

    Idle is returned when the test set is not on a call.

  • Paging (PAG)

    Paging is returned when the test set is in the process of paging the UE.

  • Registering (REG)

    Registering is returned when the test set is in the process of performing a registration with the UE.

  • Releasing (REL)

    Releasing is returned when the test set is in the process of releasing the UE from a call using over the air signalling as part of a UE or test set originated release procedure.

  • Setup Request (SREQ)

    Setup Request is returned when the test set is in the process of assigning a channel to the UE as part of a page or a UE-originated call setup.

Data Channel States

These states are only applicable to the lab application.

  • Idle (IDLE)
  • Attaching (ATTG)
  • Detaching (DET)
  • PDP Activating (PDPAG)
  • PDP Active (PDP)

    See Activate PDP Context Reject .

  • PDP Deactivating (PDPD)

Related Topics

CALL:STATus


Call Processing Ladder Diagrams

Call Processing Ladder Diagrams

Last updated: December 20, 2004

The following diagrams illustrates the primary procedures used for call processing operation.

  • RRC Connection Setup Procedure
  • Location Update (Registration) Procedure
  • Paging Procedure
  • Radio Bearer Setup Procedure
  • BS Release from RB Test Mode Procedure

The definitions below apply for the terms used in the diagrams.

  • UE (User Equipment) - mobile station that is under test.
  • 8960 - Wireless Communications Test Set (SS (System Simulator) specified in the 3GPP standard).
  • User - test user, who handles the test and measurement process via the logical test interface (test set front panel or GPIB interface).
  • RB (Radio Bearer) - the service provided by Layer 2 (RLC and MAC) for transfer of user data between UE and UTRAN (RF interface).
  • TC (Test Control): UE protocol entity used by the SS to control the UE specific testing functions, such as UE test loop function and UE radio bearer test mode function.
    • The UE test loop function provides access to isolated functions of the UE via the radio interface without introducing new physical interfaces just for the reason of conformance testing.
    • The RB test mode is specified to be used together with the UE test loop function. The purpose of the RB test mode is to put the UE into a mode where: SS can set up radio bearers to be terminated in the UE test loop function without having to involve CC or SM; and to disable any control mechanisms in NAS protocols or in any UE applications that otherwise could cause the RRC connection to be released.

RRC Connection Setup Procedure

Location Update (Registration) Procedure

Paging Procedure

Radio Bearer Setup Procedure

BS Release from RB Test Mode Procedure

Related Topics

W-CDMA Concepts


Performing a Location Update (Registration)

Performing a Location Update (Registration)

Last updated: December 20, 2004

Once the UE has camped on a cell it decides whether or not it needs to register with the network. If the ATT (IMSI Attach) Flag State is Set , the UE will always register. If the ATT (IMSI Attach) Flag State is Not Set , then the UE will only register when it determines that it has camped on a new cell. The UE uses the Mobile Network Code (MNC) , Mobile Country Code (MCC) , and Local Area Code (LAC) broadcast by the cell to determine if the cell is new.

In the W-CDMA system registration is performed using the Location Update Procedure (see Location Update (Registration) Procedure ).

During registration the UE informs the network of its identity. The UE's identity consists of its IMSI and IMEI. The IMSI is needed for the network to page the UE.

You can also specify whether or not to perform security operations during UE registration. See Security Setup .

When registration has completed, the UE Information window displays the registration data received from the UE, such as its power class, IMSI, and IMEI. (see UE Information ).

NOTE
Call Limit must be OFF for any random access procedure, such as Location Update or BS Origination (paging) to be successful. See Call Limit State .

Related Topics

CALL:PAGing


Establishing a Connection with the UE

Establishing a Connection with the UE

Last updated: December 20, 2004

Test Set-Originated Connection

Before originating a call from the test set to the UE, you may specify what type of service you want to establish using the Paging Service setting.

If you know the UE's International Mobile Subscriber Identity (IMSI), you can enter it under Paging IMSI (see CALL:PAGing:IMSI[:SELected] ) and proceed directly to originating a call even if the UE has not registered. Otherwise, you must wait for the UE to report its IMSI value upon registering with the test set. See Performing a Location Update (Registration) .

To originate a call from the test set, select Originate Call or send the CALL:ORIGinate command.

For the lab application only, for circuit-switched services, you may choose to set Calling Party Number Inclusion to Include and specify a Calling Party Number for display on the UE's screen (see Calling Party Number Parameters ).

UE-Originated Connection

The Paging Service setting does not apply to UE-originated connections. When the UE originates a connection, the test set establishes the type of service requested by the UE.

Current Service Type indicates the type of service for the established connection (see Service Types ).

For the lab application only, the Called Party Number indicates the number dialed into the UE when establishing the call.

Connection Status

During connection establishment, the status display at the bottom of the screen will indicate the current call processing state. If the call is successful, it will display Connected . If the call is unsuccessful, an error message will be displayed and the call processing state will return to Idle . See Active Cell Call Processing State .

Once there is an active link between the UE and test set, you can instruct the UE to report the measurement results for CPICH Ec/No, CPICH RSCP, Pathloss, and DTCH BLER Report. See UE Reported Measurements .

NOTE
Call Limit must be OFF for any random access procedure such as Location Update or BS Origination (paging) to be successful. See Call Limit State .

Related Topics

Manual Operation: How Do I Set Up a Call and Make a Connection?

Programming: Step 4: Make a Connection

Troubleshooting Call Processing Operations

CALL:ORIGinate

Call Processing State Synchronization

Call Processing Event Synchronization

Base Station Originated Call Setup Flowchart

Call Processing Ladder Diagrams

Video Call

Called Party Number

Calling Party Number Parameters


Base Station Originated Call Setup Flowchart

Base Station Originated Call Setup Flowchart

Last updated: December 22, 2004

The following diagrams illustrate the key steps and messaging to establish a base station initiated call (BS Origination) to the UE (mobile station).

Click on the blue text for more information on that topic.

Related Topics

W-CDMA Concepts


Video Call

Video Call

Last updated: December 20, 2004

This section is only applicable to the lab application and to a test application with the required feature license.

Overview

The Synchronous/Transparent CS Data Service can be used to make an 3G-324M (derived from H.324M) UE-to-UE video call. Before making a video call, you must first establish an External Device Connection between two 8960s. The external device connection allows the two 8960s to coordinate the setup and release of the CS data service and exchange the traffic plane data being sent by the UEs. This configuration allows the 3G-324M layers in the two UEs to communicate as they would in a real network to provide a video call service.

Video Call Protocol Stack Diagram

Once you have established an external device connection between the two 8960s and have camped the UEs to the 8960s, you can originate a video call from one of the UEs, and answer the call on the other. The 8960 connected to the originating UE commands the other 8960 to set up a CS data synchronous/transparent call to its UE. Once the call has been connected (the UE has responded to the page and you've answered the call), the call setup is completed to the originating UE and 3G-324M traffic data begins to flow (see Video Call Origination ladder diagram). You can release the video call from either of the UEs (see UE-Initiated Video Call Release ladder diagram), or from either of the 8960s (see Test Set-Initiated Video Call Release ladder diagram).

Video Call Setup

For the lab application only, the number dialed into the UE originating the call is displayed in the UE Information area under Called Party Number , and if Calling Party Number Inclusion is set to Include , the Calling Party Number is displayed on the screen of the UE receiving the call (see Calling Party Number Parameters ). Once a video call is established, the Current Service Type becomes CS Data - UE to UE Video Call (see Service Types ).

While on a video call, you can perform many transmitter measurements on the UEs. For the lab application only, you can also monitor the over-the-air messaging between the 8960s and UEs using the Wireless Protocol Advisor's (WPA) Protocol Logging functionality. You must have one WPA for each 8960. The WPA will not capture the proprietary messages sent between the two 8960s, nor will it decode the 3G-324M application layer messages from the UEs.

Other Considerations

The 8960 receiving the video call origination must be in Active Cell Operating Mode , in Idle state.

If one of the 8960s is partially preset while up on a video call, the call to its UE is dropped with no over-the-air signaling. If the other UE does not recognize that the call has dropped (and thus ends the call), you should manually end the call or partially preset its 8960 as well.

If one of the 8960s is fully preset while up on a video call, the external device connection is disconnected, which causes both 8960s to end the call with their respective UEs.

Related Topics

Manual Operation: How Do I Make a Video Call?

Video Call Ladder Diagrams

CALL:STATus:SERVice:TYPe?

Troubleshooting Video Call

External Device Connection

Synchronous/Transparent CS Data Service


Video Call Ladder Diagrams

Video Call Ladder Diagrams

Last updated: December 20, 2004

This section is only applicable to the lab application and to a test application with the required feature license.

  • Video Call Origination
  • UE-Initiated Video Call Release
  • Test Set-Initiated Video Call Release

Video Call Origination

UE-Initiated Video Call Release

Test Set-Initiated Video Call Release

Related Topics

Video Call


Digital Bus Information

Digital Bus Information

Last updated: December 20, 2004

Description

A test set equipped with cdma2000 or W-CDMA lab applications can perform mobile station tests that require faded signals. The test set must be equipped with a rear panel that includes a connector labeled Digital Bus.

NOTE
For detailed setup and operating instructions pertaining to faded signal generation, refer to

E5515C Fading Solution Application Guide

It can be downloaded at http://cp.literature.agilent.com/litweb/pdf/1000-1894.pdf .

When a faded signal from the test set is needed, the forward baseband signal path from the Test Set is diverted to a PC running Baseband Studio software. This software is capable of digitally adding fading patterns requested by the user.

Fader Setup

Baseband Studio software also controls the test set's call parameters and digital bus signal path switching modes. The status of the various digital bus parameters and the controls themselves are made available by selecting Digital Bus Info from the Call Control screen.

  • Baseband Studio Summary - The current values in use for baseband signal level adjustments.
  • Digital Bus Summary - The current data and clock rates for the modulation type of the faded signal.

With the Digital Bus Information screen displayed, the following fading parameters are displayed:

The Bbio Control menu provides three settings:

  • Digital Bus Path - Must be Internal for non-faded signal operation.

  • ALC Mode - Must be Closed Loop for non-faded signal operation.

  • Calibrate Open Loop ALC - Used to generate calibration tables that are needed when ALC Mode is Open Loop.

IMPORTANT
The Digital Bus Path and ALC Mode fields are controlled by the Baseband Studio software when a faded signal is generated by the test set. The only time these field settings will need to be manually changed is during certain diagnostic routines. Refer to the Installation Note (E5515-90243) shipped with the Option 504 kit for instructions on performing diagnostic tests.


Front Panel Connectors

Front Panel Connectors

Last updated: December 20, 2004

Description

AUDIO IN

The input to the audio analyzer is a floating input differential amplifier. Both the AUDIO IN High and AUDIO IN Low BNC connectors should be connected to provide noise immunity. Refer to the Technical Specifications in the Application Datasheet for more information.

AUDIO OUT

This BNC connector accesses the test set's Audio Generator and FM Demod signals. The Audio Generator is used to stimulate a system to measure audio performance characteristics. The FM Demod allows the user to access the demodulated FM signal for external analysis and baseband processing. Refer to the Technical Specifications in the Application Datasheet for more information.

NOTE
There will be no guaranteed performance for the signal present at the AUDIO OUT connector when FM Demod signal is selected for output.

DATA

This RJ-45 connector provides front panel access to the rear panel LAN connection. This connector is used for downloading firmware upgrades, or new test applications into the test set. No other types of communication are possible with the LAN port.

The the DATA connector on the front panel is connected internally to the ETHERNET TO FRONT PANEL connector on the rear panel. In order to use the front panel DATA connector, connect the rear panel LAN PORT, to the rear panel ETHERNET TO FRONT PANEL connector with the LAN jumper cable.

The LAN jumper cable, part number E5515-61160, is supplied with the test set.

DVM

Not functional for this release.

RF IN/OUT

This Type-N connector is the default path for all RF signals out of the test set, and is always used as the RF input. Refer to the Technical Specifications in the Application Datasheet for more information. See also RF OUT ONLY .

RF OUT ONLY

NOTE
This port cannot be used with the E1960A GSM test application or with the GSM personality in a test application suite (such as the E1985A GSM_AMPS/136_GPRS suite).

This Type-N connector is an optional path for all RF signals out of the test set. It is intended to be used for duplexed testing. Front panel selection of this port is provided by the RF Output Port ( F6 ) control on the System Config screen, and by the RFGenerator:OUTPut[:DESTination] IO/OUT command. The same amplitude offsets and output power settings are used for either selected port (RF IN/OUT or RF OUT ONLY). Refer to the Technical Specifications in the Application Datasheet for more information.

Related Topics

RFGenerator Subsystem (RF OUT ONLY control)

Amplitude Offset (RF amplitude offsets)


Help Mode

Help Mode

Last updated: December 20, 2004

Description

This section explains:

  • What is Help Mode?
  • How do I use the help mode?

What is Help Mode?

The help mode implemented in your test set provides context sensitive GPIB command syntax assistance. When you put the test set into help mode, the test set displays the GPIB command syntax necessary to perform an action remotely for each action you perform from the front panel.

For example, if you put the test set into help mode and then select the test set's GPIB address, the GPIB command syntax for changing it remotely appears in the bottom left hand corner of the test set's screen.

NOTE
Operating the test set in Help Mode does not prevent you from changing parameters from the front panel. The parameters you change while in Help Mode are applied just as they would be normally.

How do I use the help mode?

  1. Put the test set into help mode by pressing the HELP key on the front panel.

    The Help annunciator should now be displayed in the bottom of the screen.

  2. Navigate to the screen and perform the action for which you would like to know the GPIB command syntax. For example, you could navigate to the Audio Generator instrument, and select Frequency ( F3 ). The GPIB command syntax to perform this action remotely appears in the bottom left of the screen.

    Refer to the user documentation on each command for more information.


Preset Descriptions

Preset Descriptions

Last updated: December 20, 2004

Description

The test set is capable of accepting several different preset commands.

At no time during a preset operation, does transmit power exceed the last user setting of the transmit power. The input power is not set to any value lower than the last user setting of the input power. This is to avoid power spikes on the output and possible receiver damage on the input during transitions associated with preset operations.

Partial Preset

Partial preset saves setup time because measurement setup parameters remain unchanged. This is the recommended way to place the test set in a known condition.

When you fast switch between formats in a fast switching test application the test set behaves as if a partial preset has occurred. The table below lists some key partial preset results.

Example

OUTPUT 714;"SYSTEM:PRESET3" !Command for a partial preset when user in
                            !remote operation.

SYSTEM:PRESET3 is the recommended command for a partial preset operation. The SYSTEM:PRESET[1] command is not recommended for use at this time.

Press the green Preset key on the front panel to perform a partial preset.

Partial Preset Behavior
Function | Partial Preset Result
Trigger Arm | no change
Measurement parameters | no change
Calibration data | no change
Enable registers | no change
Positive Transition Filter registers | no change
Negative Transition Filter registers | no change
Contents of RAM | no change
Contents of output queue | no change
Contents of error queue | no change
Maskable Message Display State | no change
Operating Mode | Active Cell
Measurements | aborted and inactivated
Measurement results | NAN
Measurement integrity indicator | 1 = no result available
Transmit Power State | ON
Cell Activated State | ON
Call in progress | aborted
Call Control Status | Idle
Call Counters | cleared
Call Error Counters | cleared
SACCH | cleared
Pending Service request | not cleared

Full Preset

A full preset requires you to select new measurements and configure their parameters. If measurement parameters do not need to be changed, use a partial preset to save time.

Example

OUTPUT 714;"*RST" !Recommended command for a full preset, sets trigger arm to single.

OUTPUT 714;"SYSTEM:PRESET2" !Command for a full preset, sets trigger arm to continuous.

The *RST common command is the recommended command for a full preset operation.

NOTE
Transmit power is not set to OFF during a full preset, transmit power is set to the default value.

Full Preset Behavior
Function | Full Preset Result
Trigger Arm | Continuous (manual operation full preset or SYSTEM:PRESET2 command)
Trigger Arm | Single (remote operation full preset, *RST command)
Measurement Parameters | all set to defaults
Maskable Message Display State | On (manual operation full preset)
Maskable Message Display State | Off (remote operation full preset)

Status Preset

The STATUS:PRESET command sets the status system as defined in "SCPI 1995 Volume 2: Command Reference" section 20.7. All of the enable registers are set to 0, all PTR registers are set to 1, and all NTR registers are set to 0.

Example

OUTPUT 714;"STATUS:PRESET" !Presets the STATus subsystem.

Related Topics

SYSTem:PRESet


Instrument Status Area

Instrument Status Area

Last updated: December 20, 2004

Description

The Instrument status area is found on the bottom center of the test set's display.

Status Area of the Test Set Display

Background

Users are able to initiate more than one measurement at a time with the test set. The test set's display will show a maximum of 2 measurements. When 3 or more measurements are initiated, or the MEASUREMENT screen is not displayed, the Background annunciator reminds you that measurements are active but not displayed.

<Operating Mode> Status

The call processing status and the operating modes are displayed in this area. This area may change (depending on the TA that is active) in order to provide TA specific information.

Shift

This annunciator indicates that the blue SHIFT key has been pressed, and that the next key you press will perform the shifted function indicated, also in blue.

Ext Ref

When a suitable external time base is connected to the rear panel 10MHz REF IN connector, this annunciator will turn on.

Int Ref

When a suitable external time base is not connected to the rear panel 10MHz REF IN connector, this annunciator will turn on.

Offset

Indicates that the Amplitude Offset state is set to On.

R L T S

This annunciator indicates the state of four different conditions of the test set:

  • Remote annunciator. `R' turns on when the test set is operated remotely.
  • Listen annunciator. `L' turns on when the test set is listening to a command.
  • Talk annunciator. `T' turns on when the test set is providing information over GPIB.
  • SRQ annunciator. `S' turns on when an SRQ is active.


How Do I Use the Data Throughput Monitor?

How Do I Use the Data Throughput Monitor?

Last updated: December 20, 2004

This section is only applicable to the lab application.

Description

The following procedure illustrates typical usage of the data throughput monitor.

Accessing the Monitor Controls

  1. Press the Instrument selection key.
  2. Select Data Throughput Monitor .

    The data throughput monitor is displayed with the default settings as shown above.

    NOTE
    Once you have opened the data throughput monitor instrument, it can always be accessed by pressing the MEASUREMENT key, followed by the Swap Window Positions ( F5 ) key if necessary. The Swap Window Positions ( F5 ) is displayed only when another measurement or instrument is active.

  3. Set the axis control as needed for your testing situation using the Axis Control ( F1 ) key to access the Time Span ( F1 ), Start Data Rate ( F2 ) Stop Data Rate ( F3 ) keys. For example, if you expect data rates to exceed the default value of 100 kbps, press the ( F1 ) key followed by the ( F3 ) key and enter a new value in the Stop Data Rate field using the DATA ENTRY keys.
  4. Press the Return ( F6 ) key to exit the Axis Control menu.
  5. Select the traces you would like to display by pressing the Trace Control ( F2 ) key followed by the Trace Display ( F1 ) key. To select a trace, turn the value to On. There are four color-coded traces and any combination can be selected:
    • OTA Tx - (Over The Air Transmitted bits-per-second). This is the rate of link-layer bit transfer sent from the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000, or RLC (Radio Link Control) protocol in WCDMA and GPRS, or PPP in GSM. Tx refers to the reverse or uplink channel direction.
    • OTA Rx - (Over The Air Received bits-per-second). This is the rate of link-layer bit transfer received by the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000, or RLC (Radio Link Control) protocol in WCDMA and GPRS, or PPP in GSM. Rx refers to the forward or downlink channel direction.
    • IP Tx - Internet Protocol Transmitted. This is the rate of network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.
    • IP Rx - Internet Protocol Received. This is the rate of network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.

    By default, the OTA Tx and OTA Rx traces are the only traces turned on.

  6. Press the Close Menu ( F6 ) key to close the Trace Display menu.
  7. Press the Return ( F6 ) key to exit the Trace Control menu.

  8. Establish a data connection with the mobile.

    The Data Throughput Monitor begins displaying numerical and graphical information. The numerical information pertains to the period of time beginning with the establishment of the first data connection, and the graphical traces represent up to 600 seconds of the latest data throughput statistics.

  9. Set a marker.

    Using the Trace Control menu, select a marker by pressing the corresponding F2 , F3 , F4 , or F5 keys. Either use the Data Entry keys to enter a specific time (must be negative because the data represented on the graph is in the past) or press the Data Entry key labeled ON and then use the knob to move the marker to the position you desire.

    Press the Return ( F6 ) key.

    After allowing the monitor to accumulate throughput for at least one minute, change the Time Span to 50 seconds (see step 3 above). This will expand the graphical view to improve resolution.

    Press the Return ( F6 ) key.

  10. Freeze the graph.

    Press the Freeze Graph (F4) key.

    Turn the knob to adjust the position of the marker. Marker results will be displayed in the summary table

  11. Press the Return ( F6 ) key to exit the Trace Control menu.
  12. Press the Resume Graph ( F4 ) key to display the most recent trace data.
  13. Press the Clear Graph ( F3 ) key to reset the traces and the numeric counters.

Changing Data Rates

Data throughput can be analyzed under various call processing and RF conditions. This section illustrates the steps required to change data rates.

It is assumed that the data throughput monitor is displayed and a data call is connected.

  1. Press the CALL SETUP key.
  2. Change the data rate (see Related Topics).
  3. Press the MEASUREMENT key.

Related Topics

Data Throughput Monitor Description


How Do I Perform a Loopback BER Measurement?

How Do I Perform a Loopback BER Measurement?

Last updated: December 20, 2004

Measuring Loopback Bit Error Ratio

  1. Press the Measurement selection key.
  2. Select the Loopback Bit Error Ratio measurement.
  3. Select Bit Error Setup ( F1 ).
    • Set Number of Bits to Test to 10000 .
    • Set Trigger Arm to Single .
    • Set Confidence Level to 99.80% (press the ON key).
    • Set BER Requirement to 0.10% .
    • Set Bad DUT Factor to 1.5 .
    • Set Uplink DTCH RMC CRC Presence to Present and UE Loopback Type to Type 1 .

    Select Close Menu ( F6 ).

  4. Establish an RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  5. Set UE Target Power to +21 dBm (for a Power Class 4 UE).
  6. Set Cell Power ( F7 ) to -106 dBm (for Operating Band I).
  7. Press the START SINGLE key to begin the measurement.
  8. If the Confidence Test Result is Max Bits Tested , start the measurement again. You may need to increase the Number of Bits to Test to enable a Pass or Fail result.
  9. Adjust Cell Power ( F7 ), AWGN Power ( F4 ), Soft Handoff ( F3 ) and Cell 2 Power ( F2 ) as desired.

An example measurement result is shown below:

Related Topics

Loopback Bit Error Ratio Measurement Description


How Do I Perform a Block Error Ratio (BLER) Measurement?

How Do I Perform a Block Error Ratio (BLER) Measurement?

Last updated: December 20, 2004

Measuring Block Error Ratio

  1. Press the Measurement selection key.
  2. Select the Block Error Ratio measurement.
  3. Select Block Error Setup ( F1 ) and set the measurement parameters as needed.
    • For Symmetrical RMCs , you must set Uplink DTCH RMC CRC Presence to Used for Data and UE Loopback Type to Type 2 .
    • Select Close Menu ( F6 ).
  4. Establish an RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  5. If Trigger Arm is set to Single , you must press the START SINGLE key to begin the measurement.
  6. Adjust Cell Power ( F7 ), AWGN Power ( F4 ), Soft Handoff ( F3 ) and Cell 2 Power ( F2 ) as desired.

An example measurement result is shown below:

For an example of performing BLER measurements while on a faded channel, refer to the:

E5515C Fading Solution Application Guide

It can be downloaded at http://cp.literature.agilent.com/litweb/pdf/1000-1894.pdf .

Related Topics

Block Error Ratio Measurement Description


How Do I Make a Change of TFC (Transport Format Combination) Measurement?

How Do I Make a Change of TFC (Transport Format Combination) Measurement?

Last updated: December 20, 2004

This section is only applicable to the lab application.

NOTE
Before performing a Change Of TFC measurement, ensure that the test set has been properly calibrated (see Calibrating the Test Set ).

Measuring Change Of TFC

  1. Set Uplink Dummy DCCH Data to Off (this is the default setting).
  2. Set Uplink DPCH Bc/Bd Control to Auto (this is the default setting).
  3. Set UL CL Power Ctrl Algorithm to Two (this is the default setting).
  4. Establish a 12.2k RMC RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  5. Set UE Target Power to 0 dBm .
  6. Set UL CL Power Control Mode to Alternating bits .
  7. Press the Measurement selection key.
  8. Select Change Of TFC .
  9. Select Change Of TFC Setup ( F1 ) and set the measurement parameters as needed. Select Close Menu ( F6 ).
  10. Press the START SINGLE key to begin the measurement.

    A typical result is shown below.

  11. To perform a change of TFC measurement on a different RMC, perform a Transport Channel Reconfiguration (Change of RMC) or end the call and bring up a call on the new RMC, then press START SINGLE again.

Related Topics

Change of TFC (Transport Format Combination) Measurement Description


How Do I Make a Dynamic Power Analysis Measurement?

How Do I Make a Dynamic Power Analysis Measurement?

Last updated: December 20, 2004

NOTE
Before performing a dynamic power analysis measurement, ensure that the measurement has been properly calibrated (see Calibrating the Test Set ).

Measuring Dynamic Power Analysis

  1. Place your UE into a test mode which will force it to transmit the power sequence you desire to test.
  2. Press the Measurement selection key.
  3. Select the Dynamic Power Analysis measurement.
  4. Select Dynamic Power Setup ( F1 ) and set the measurement parameters as needed. Select Close Menu ( F6 ).
  5. If Trigger Arm is set to Single , you must press the START SINGLE key to begin the measurement.
  6. Select Axis Control ( F2 ). Set the axis control parameters as needed. Select Return ( F6 ).
  7. Select Marker ( F3 ) to turn on the marker on the graphical display.

A typical result is shown below:

Related Topics

Dynamic Power Analysis Measurement Description


How Do I Make an Inner Loop Power Measurement?

How Do I Make an Inner Loop Power Measurement?

Last updated: December 20, 2004

NOTE
Before performing an Inner Loop Power measurement, ensure that the measurement has been properly calibrated (see Calibrating the Test Set ).

Measuring Inner Loop Power

  1. Establish an RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  2. Press the Measurement selection key.
  3. Select Inner Loop Power .
  4. Select Inner Loop Power Setup ( F1 ).
    • Set Test Segment to A.
    • Set Number of Slots as needed.
    • Select Close Menu ( F6 ).
  5. Press the START SINGLE key.
  6. Select Axis Control ( F2 ).
    • Set Start , Span , Reference and dB/div as needed to properly display the (blue) absolute power trace.
    • Press the More key to move to Axis Control 2 of 2 . Set Relative Power ( F1 ) as needed to properly display the (yellow) relative power trace.
    • Select Return ( F6 ).
  7. Select Marker ( F3 ) to turn on the marker on the graphical display and move the highlighted bar in the numerical results display area.
  8. Select Inner Loop Power Setup ( F1 ).
    • Set Test Segment to B.
    • Select Close Menu ( F6 ).
  9. Press the START SINGLE key.
  10. Select Axis Control ( F2 ). Set the axis control parameters as needed. Select Return ( F6 ).
  11. Repeat steps 8, 9 and 10 for test segments C, E, F, G and H.

A typical result is shown below.

Related Topics

Inner Loop Power Measurement Description


How Do I Make an IQ Tuning Measurement?

How Do I Make an IQ Tuning Measurement?

Last updated: December 20, 2004

NOTE
Before performing an IQ Tuning measurement, ensure that the measurement has been properly calibrated (see Calibrating the Test Set ).

Measuring IQ Tuning

  1. Establish an RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  2. Press the Measurement selection key.
  3. Select IQ Tuning .
  4. If Trigger Arm is set to Single , you must press the START SINGLE key to begin the measurement.
  5. Select IQ Tuning Setup ( F1 ) and set the measurement parameters as needed. Select Close Menu ( F6 ).
  6. Set Cell Power ( F7 ) as needed.
  7. Select Axis Control ( F2 ). Set the axis control parameters as needed. Select Return ( F6 ).
  8. Select Marker ( F3 ) to turn on the marker on the graphical display. The EVM for the selected chip is displayed.

A typical result is shown below.

Related Topics

IQ Tuning Measurement Description


How Do I Make a PRACH Transmit On/Off Power Measurement?

How Do I Make a PRACH Transmit On/Off Power Measurement?

Last updated: December 20, 2004

NOTE
Before performing a PRACH Transmit On/Off Power measurement, ensure that the measurement has been properly calibrated (see Calibrating the Test Set ).

Measuring PRACH Tx On/Off Power

  1. Connect the UE to the test set, power it on and wait for it to camp to the test set's signal, but do not originate a call between the test set and UE (see How Do I Set Up a Call and Make a Connection? ).
  2. Set Cell Power ( F1 ) as needed.
  3. Set CPICH Level as needed (see How Do I Change Generator Information? ).
  4. Set Primary CPICH TX Power , Uplink Interference and Constant Value as needed (see How Do I Change Cell Parameters? ).
  5. Press the Measurement selection key.
  6. Select PRACH Transmit On/Off Power .
  7. Select PRACH Tx On/Off Pwr Setup ( F1 ) and set the measurement parameters as needed. Select Close Menu ( F6 ).
  8. Press the START SINGLE key to begin the measurement.

A typical result is shown below.

Related Topics

PRACH Transmit On/Off Power Measurement Description


How Do I Make an Out-of-Synch Handling of Output Power Measurement?

How Do I Make an Out-of-Synch Handling of Output Power Measurement?

Last updated: December 20, 2004

This section is only applicable to the lab application.

Measuring Out-of-Synch Handling of Output Power

Connect the Test Set, Spectrum Analyzer and UE

  1. Connect the UE to the test set's RF IN/OUT port and to the spectrum analyzer's RF INPUT port via an RF splitter.
  2. Connect the test set's rear panel TRIG OUT port to the spectrum analyzer's TRIGGER IN port.

Configure the Spectrum Analyzer

This example uses an Agilent E4443A PSA Series Spectrum Analyzer.

  1. Press the MODE key. Select Spectrum Analysis .
  2. Press the FREQUENCY key. Set Center Freq to 1.95 GHz (or to the appropriate frequency for your test setup).
  3. Press the Amplitude key.
    • Select More to move to the 2 of 3 menu. Set REF Lvl OFFst to 9 dB to account for the loss due to the RF splitter (or to the appropriate value for your test setup).
    • Select More to move to the 1 of 3 menu. Set Ref Level to -30 dBm (or to the appropriate level for your test setup to allow accurate measurement of the UE's off power).
  4. Press the SPAN key and select Zero Span .
  5. Press the Det/Demod key. Set Detector to Man and choose Average (Log/RMS/V) (this also sets BW/Avg : Avg/VBW Type to Pwr Avg (RMS) ).
  6. Press the BW/Avg key. Set Res BW to 5 MHz .
  7. Press the Sweep key.
    • Set Sweep Time to 20 s .
    • Set Points to 8001 . Select Enter .
  8. Press the Trig key and select Ext Rear or Ext Front .

Configure the Test Set

  1. Set the RF IN/OUT Amplitude Offset to -9 dB to account for the loss due to the RF splitter (or to the appropriate value for your test setup).
  2. Select Cell Parameters ( F2 ) from the Call Control 2 of 4 menu.
    • Set N313 UE Out-Of-Sync Counter to S200 .
    • Set T313 UE Link Reestablishment Timer to 15 .
    • Set N315 UE In-Sync Counter to S1 .

    Select Close Menu ( F6 ).

  3. Select Generator Info ( F3 ). Select Connected DL Channel Levels ( F4 ) (see Setting Downlink Channel Levels ).
    • Set Cell 1 Connected CPICH Level to -10.00 dB .
    • Set Cell 1 Connected P-CCPCH/SCH Level to -12.00 dB .
    • Set Cell 1 Connected S-CCPCH Level to Off .
    • Set Cell 1 Connected PICH Level to -15.00 dB .
    • Set Cell 1 Connected DPCH Level to -16.60 dB .

    Select Close Menu ( F6 ) and Return ( F6 ).

  4. Set Trigger Output Setup ( F6 ) to Measurement Generated .
  5. Establish a 12.2k RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  6. Set UE Target Power ( F7 on the Call Parms 3 of 3 menu) to 28 dBm .
  7. Select UL CL Power Ctrl Parameters ( F8 ). Set UL CL Power Control Mode to All Up bits .
  8. Set Cell Power ( F7 on the Call Parms 1 of 3 menu) to -61 dBm .
  9. Select Generator Info ( F3 on the Call Control 2 of 4 menu) and set AWGN Power ( F5 ) to -60 dBm.

Initiate the Measurement from the Test Set

  1. Press the Measurement selection key and choose Out-of-Synch Handling of Output Power .
  2. Select Out-of-Sync Power Setup and set the parameters as needed. The default values are those specified by 3GPP TS 34.121 5.4.4. Select Close Menu ( F6 ).
  3. Press the START SINGLE key.

View the Measurement Results on the Spectrum Analyzer

A typical result is shown below.

  1. Press the Marker key.
    • Enter 5.2 s for Marker 1 . Ensure that the UE's output power is off at this marker position.
    • Select Marker 2 . Select Normal . Enter 15.4 s . Ensure that the UE's output power is on at this marker position.

Return Test Set Settings to Their Pre-Measurement Values

If desired, when you have completed the measurement, select End Call ( F3 ) and return the following settings to their pre-measurement values:

  • Select Cell Parameters ( F2 ) from the Call Control 2 of 4 menu.
    • Set N313 UE Out-Of-Sync Counter to S2 .
    • Set T313 UE Link Reestablishment Timer to 3 .
    • Set N315 UE In-Sync Counter to S50 .

    Select Close Menu ( F6 ).

  • Select Generator Info ( F3 ). Select Connected DL Channel Levels ( F4 ).
    • Set Cell 1 Connected CPICH Level to -3.30 dB .
    • Set Cell 1 Connected P-CCPCH/SCH Level to -5.35 dB .
    • Set Cell 1 Connected S-CCPCH Level to Off .
    • Set Cell 1 Connected PICH Level to -8.33 dB .
    • Set Cell 1 Connected DPCH Level to -10.30 dB .

    Select Close Menu ( F6 ) and Return ( F6 ).

  • Set Trig Output Setup ( F6 ) to Sys Frame Clock .
  • Set Call Drop Timer ( F11 on the Call Parms 2 of 3 menu) to On (NOTE: This is only required for the current pre-release firmware, due to a defect. The final release of the firmware will automatically turn the call drop timer off during the measurement).
  • Select UL CL Power Ctrl Parameters ( F8 ). Set UL CL Power Ctrl Mode to Active bits .
  • Set UE Target Power ( F7 on the Call Parms 3 of 3 menu) as desired.
  • Set Cell Power ( F7 on the Call Parms 1 of 3 menu) as desired.
  • Select Generator Info ( F3 on the Call Control 2 of 4 menu) and set AWGN Power ( F5 ) as desired.

Related Topics

Out-of-Synch Handling of Output Power Measurement Description

Out-of-Synch Handling of Output Power Troubleshooting

What 3GPP W-CDMA Conformance Tests Are Supported?


How Do I Make a Phase Discontinuity Measurement?

How Do I Make a Phase Discontinuity Measurement?

Last updated: December 20, 2004

NOTE
Before performing a phase discontinuity measurement, ensure that the measurement has been properly calibrated (see Calibrating the Test Set ).

Measuring Phase Discontinuity

  1. Establish an RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  2. Set UL CL Power Control Mode to Active Bits (this is the default setting).
  3. Set UE Target Power to the UE's maximum output power (for example, 21 dBm ).
  4. Press the Measurement selection key.
  5. Select the Phase Discontinuity measurement.
  6. Select Phase Discont. Setup ( F1 )
    • Set Power Control Pattern to 5DOWN/4UP .
    • Set Number of Pattern Repetitions to 10 .
    • Select Close Menu ( F6 ).
  7. Press the START SINGLE key to begin the measurement.
  8. Select Graph Control ( F2 ).
  9. Select Axis Control ( F1 ) to set the axis control parameters as needed:
    • Start ( F1 ) determines the first slot result displayed.
    • Span ( F2 ) determines the number of timeslots for which results are displayed.
    • Phase Reference ( F3 on Axis Control 1 of 2 ).
    • Phase Range ( F4 on Axis Control 1 of 2 ).
    • Power Ref ( F3 on Axis Control 2 of 2 ).
    • Power Range ( F4 on Axis Control 2 of 2 ).

    Select Return ( F6 ).

  10. Select Trace Show/Hide ( F4 ) to choose which of the 3 available traces to display ( Phase Discontinuity , Phase and Power ). Select Close Menu ( F6 ).
  11. Select Marker ( F2 ) to turn on the marker on the graphical display and move the highlighted bar in the numerical results display area. Scroll through the numerical data and locate the orange values indicating worst case phase discontinuity and worst case EVM to determine whether the UE has met specifications for this portion of the test.

  12. Select Table ( F3 ) to scroll through the 9 columns of numerical results available, as needed.

    A typical result is pictured below:

  13. Select Return ( F6 ).

  14. Repeat steps 7-12 until the UE reaches its minimum output power (for example, -49 dBm). You can easily determine the UE's output power level by noting the UE Target Power level ( F7 on the Call Parms 3 of 3 menu), because at the completion of the measurement, the test set sets MS Target Power to the UE's output power in the final measured slot).

    You may choose to overlap the test subsequences by starting at an MS Target Power that is offset from the ending power level, see Key 3GPP Tests Performed Using the Phase Discontinuity Measurement for more information.

  15. Select Phase Discont. Setup ( F1 )
    • Set Power Control Pattern to 5UP/4DOWN .
    • Set Number of Pattern Repetitions to 10 .
    • Select Close Menu ( F6 ).
  16. Repeat steps 7-12 until the UE reaches its maximum output power.

Related Topics

Phase Discontinuity Measurement Description


How Do I Make a PRACH Preamble Analysis Measurement?

How Do I Make a PRACH Preamble Analysis Measurement?

Last updated: December 20, 2004

This section is only applicable to the lab application.

NOTE
Before performing a PRACH preamble analysis measurement, ensure that the measurement has been properly calibrated (see Calibrating the Test Set ).

Measuring PRACH Preamble Analysis

  1. Power the UE on and wait for it to camp to the test set, but DO NOT establish a connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  2. Press the right More key until you reach the Call Parms 2 of 3 menu. Ensure that Call Limit State ( F2 ) is set to Off .
  3. Press the left More key until you reach the Call Control 2 of 4 menu. Select Uplink Parameters ( F4 ).
  4. Set the PRACH Signature parameters as needed.
  5. Set PRACH Preambles to at least 3.
  6. Set Available Subchannels (Bit Mask) to specify only one available subchannel. Select Close Menu ( F6 ).
  7. Press the Measurement selection key.
  8. Select the PRACH Preamble Analysis measurement.
  9. Select PRACH Preamble Setup ( F1 ) and set the measurement parameters as needed. Select Close Menu ( F6 ).
  10. Set Cell Power ( F7 ) as needed.
  11. Press the START SINGLE key to begin the measurement.
  12. Select Graph Control ( F2 ).
  13. Select Axis Control ( F1 ). Set the axis control parameters as needed. Select Return ( F6 ).
  14. Select Marker ( F2 ) to turn on the marker on the graphical displays.
  15. Select View Select ( F3 ) and then Zoom View ( F4 ) to zoom on one of the graphical display results.

Related Topics

PRACH Preamble Analysis Measurement Description


How Do I Change Call Parameters?

How Do I Change Call Parameters?

Last updated: December 21, 2004

  • Setting Call Parameters
  • Setting Call Parameters that Can Only Be Changed in Cell Off Mode
  • Setting DL Channel, Uplink Channel and Uplink Separation

Setting Call Parameters

  1. Press the CALL SETUP key.
  2. Press the right More key to move between the Call Parms menus and set the call parameters as needed.

Setting Call Parameters that Can Only Be Changed in Cell Off Mode

  1. Press the CALL SETUP key.
  2. Set Operating Mode ( F1 ) to Cell Off .
  3. Press the right More key to move between the Call Parms menus and change the call parameters as needed.
  4. Set Operating Mode ( F1 ) to Active Cell .

Setting DL Channel, Uplink Channel and Uplink Separation

You can set DL Channel and Uplink Channel independently, or set DL Channel and then specify the uplink frequency's offset from the downlink frequency using the Uplink Separation setting.

To set the DL Channel and Uplink Channel independently:

  1. Press the CALL SETUP key.
  2. Set Operating Mode ( F1 ) to Cell Off .
  3. Select Uplink Channel ( F11 ) and enter the desired UARFCN using the front panel DATA ENTRY keys.
  4. Select DL Channel ( F10 ) and enter the desired UARFCN using the front panel DATA ENTRY keys.
  5. Set Operating Mode ( F1 ) to Active Cell .

To set the DL Channel and Uplink Channel using a fixed frequency offset:

  1. Press the CALL SETUP key.
  2. Set Operating Mode ( F1 ) to Cell Off .
  3. Select Uplink Channel ( F11 ) to highlight it, then press the OFF ( MANUAL ) key on the front panel. This sets Uplink Channel to manual control, so that you can then set DL Channel and Uplink Separation to a valid combination.
  4. Select DL Channel ( F10 ) and enter the desired UARFCN using the front panel DATA ENTRY keys.
  5. Select Uplink Separation ( F12 ) and choose the desired frequency separation.
  6. Select Uplink Channel ( F11 ) to highlight it, then press the ON ( AUTO ) key on the front panel. This returns Uplink Channel to automatic control.
  7. Set Operating Mode ( F1 ) to Active Cell .

Related Topics

Channel Type and Paging Service

Downlink Channel (UARFCN)

Uplink Channel (UARFCN)

Signalling Radio Bearer (SRB) Configuration

Other Downlink Parameters

Uplink Closed Loop Power Control Parameters and UE Target Power


How Do I Change Cell Parameters?

How Do I Change Cell Parameters?

Last updated: December 20, 2004

  1. Press CALL SETUP .
  2. If required (some cell parameters can be changed only in Cell Off operating mode), press Operating Mode ( F1 ) and select Cell Off .
  3. Press More on left side and go to Call Control screen 2 of 4 .
  4. Press Cell Parameters ( F2 ).
  5. Turn the knob to highlight a parameter as desired, and then press the knob.
  6. Enter a value or selection and press the knob.
  7. Select Close Menu ( F6 ).

Related Topics

Cell Parameters


How Do I Enable Compressed Mode and Obtain UE Measurement Results?

How Do I Enable Compressed Mode and Obtain UE Measurement Results?

Last updated: December 20, 2004

This section is only applicable to the lab application.

  • A. Choose an Acceptable DPCH Channelization Code
  • B. Configure Neighbor Cells
  • C. Configure Compressed Mode and UE Measurements Setup Parameters
  • D. Establish a Call
  • E. Enable Compressed Mode
  • G. View UE Measurement Results
  • H. Perform Other Operations While in Compressed Mode

A. Choose an Acceptable DPCH Channelization Code

  1. Set the DPCH 30 ksps Channelization Code to 20, 29, 37, 45, 60, 70, 76, 87 or 93 (see How Do I Change Generator Information? ).

B. Configure Neighbor Cells

  1. Configure the SIB11 Inter Freq Cell Info List and SIB11 GSM Cell Info List as needed (see How Do I Change the SIB11 Cell Info List? ).

C. Configure Compressed Mode and UE Measurements Setup Parameters

  1. Press the CALL SETUP key.
  2. Press the left More key until you reach the Call Control 4 of 4 menu.
  3. Select Compressed Mode Info ( F4 ).
  4. Select Compressed Mode Parameters ( F2 ) and configure the parameters as needed.
  5. Select UE Meas Setup ( F3 ) and configure the parameters as needed (be sure to set UE Measurements in Compressed Mode to On if you want the UE to report measurement results).

D. Establish a Call

  • Establish a 12.2k RMC call between the test set and UE (see How Do I Set Up a Call and Make a Connection? ).

E. Enable Compressed Mode

  1. Return to the Compressed Mode Info menu ( F4 on Call Control 4 of 4 ).
  2. Select Enable Compressed Mode ( F1 ).

G. View UE Measurement Results

If you enabled UE measurements in step C. Configure Compressed Mode and UE Measurements Setup Parameters , then you can view the UE measurement results for either GSM RSSI or FDD measurements (depending upon whether you set Compressed Mode Meas Purpose to GSM RSSI or FDD Meas in step C. Configure Compressed Mode and UE Measurements Setup Parameters ).

  1. To view GSM RSSI measurement results, select GSM Meas Results Screen ( F4 ).
  2. To view FDD measurement results, select FDD Inter-freq Meas Results ( F5 ).

H. Perform Other Operations While in Compressed Mode

At this point, you may also choose to perform receiver testing on the UE (see Performing Individual Measurements Manually ), or perform call processing operations such as soft handoff (see How Do I Perform a Soft Handoff? ), or handover to a new frequency or RMC (see How Do I Perform a Handoff (Handover)? ). However please note that compressed mode will be disabled after handover to the new frequency or RMC is complete.

Related Topics

Compressed Mode


How Do I Configure the AUDIO OUT Port?

How Do I Configure the AUDIO OUT Port?

Last updated: December 20, 2004

A. Select a signal to output to the AUDIO OUT port.

  1. Press the SYSTEM CONFIG key.
  2. Press the More key on the left side of the display for additional system parameters.
  3. Press the Audio Out Port ( F1 ) key.
  4. Turn the knob to highlight a selection and then press the knob.

NOTE
Selection of FM Demod signal routed to the front-panel AUDIO OUT port is useful only in AMPS system. There will be no guaranteed performance for the signal present at the Audio Out Port when FM Demod is selected for output.

B. Set FM Demod signal.

When FM Demod signal is selected for output to the front-panel AUDIO OUT port, a bandpass filter, expander circuit, and de-emphasis circuit can be individually inserted or bypassed in the FM Demod signal path.

  1. Press the SYSTEM CONFIG key.
  2. Press the More key.
  3. Press the FM Demod Setup ( F2 ) key.
  4. Turn the knob to highlight a selection and then press the knob.
  5. Enter a value or selection and press the knob.
  6. Press the Close Menu ( F6 ) key.

NOTE
If the FM Demod Setup settings are changed while the Audio Out Port selection is not FM Demod (see A. Select a signal to output to the AUDIO OUT port. ), the values will be stored for use when Audio Out Port is set to FM Demod.

Related Topics

Configuring the Test Set's AUDIO OUT port


How Do I Make an External Device Connection?

How Do I Make an External Device Connection?

Last updated: December 20, 2004

This section is only applicable to the lab application and to a test application with the required feature license.

Description

External Device Connection Setup

  1. It is recommended that you connect 8960 #1 and 8960 #2 via a hub, rather than through a gateway or WAN link (or connect them directly using a LAN crossover cable), to help minimize the risk of lost data due to delayed packets.
  2. Go to the External Device Connection Setup screen on 8960 #1 and 8960 #2:
    • Press the SYSTEM CONFIG key.
    • Press the left More key until you reach the Control 2 of 2 menu.
    • Select External Device Connection ( F4 ).
  3. 8960 #1: Select Ext 8960 IP Addr ( F1 ) and enter the LAN IP address of 8960 #2. (The LAN IP address of 8960 #2 is displayed in the LAN Connection Information window of 8960 #2 under LAN (Self) IP Address .)
  4. 8960 #1: Select Connect to External 8960 ( F3 ).
  5. Ensure that the External Device Conn Status is Connected on both 8960s.

Note that the Connected Device IP Address on 8960 #1 is the LAN IP Address of 8960 #2, and is also equal to the Ext 8960 IP Addr setting of 8960 #1 because 8960 #1 initiated the connection (see 8960 #1 External Device Connection Setup Screen ).

8960 #1 External Device Connection Setup Screen

Note that Connected Device IP Address on 8960 #2 is the LAN IP Address of 8960 #1, but is not necessarily equal to the Ext 8960 IP Addr setting of 8960 #2, as 8960 #2 did not initiate the connection (see 8960 #2 External Device Connection Setup Screen ).

8960 #2 External Device Connection Setup Screen

Related Topics

External Device Connection

Troubleshooting External Device Connection

How Do I Ping a Device From the Test Set?

Manual Operation: How Do I Make a Video Call?


How Do I Perform Calling Party Number Verification?

How Do I Perform Calling Party Number Verification?

Last updated: December 20, 2004

This section is only applicable to the lab application.

Procedure

  1. Press the Call Setup key.
  2. Press the left More key to move to the Call Control Menu 4 of 4.
  3. Press Calling Party Number Parms ( F5 ). The Calling Party Number Parameters menu is displayed. See Parameter Descriptions for details.
  4. Select Calling Party Number Inclusion .
    • Turn the knob and select Include from the drop down menu.
  5. If required, select the Calling Party Number and enter a desired value.
    • Up to 20 characters from the set of 0123456789abc*# can be entered in the entry box. The digits of 0-9 are entered from the DATA ENTRY keys and the characters of "abc*#" are entered from the newly displayed softkeys on the right of the screen.
      Enter the value in the Calling Party Number text entry

      Once the entry box goes away, the Calling Party Number field can display up to 14 characters. If the length of the entered string is greater than 14 characters, only the first 11 characters followed by a "..." are displayed in the Calling Party Number field. Use the GPIB command ( CALL:CPNumber<[:SELected]> ) to query the whole string.

  6. If required, select other parameters and set them to the desired value. In this example, the default settings are used.
  7. Press the Close Menu ( F6 ).
  8. (Optional) To capture a protocol log for further analysis, start a capture in the Wireless Protocol Advisor (WPA) software (see Protocol Logging ) and then perform the following steps.
  9. Set up the Call Control and Call Parms as needed for the UE to camp to the test set. Power the UE on and wait for it to camp to the test set.
  10. Verify that Paging Service ( F9 ) is set to AMR Voice for this example.
  11. Press Originate Call ( F3). The test set originates a call to the UE.
  12. Observe the UE's screen. Verify that the mobile station receives and displays the calling party number. If the Calling Party Number is not displayed on the mobile station' screen, ensure that Presentation Indicator is set to "Allowed". Answer the call on the UE, if desired.
  13. Stop WPA.
  14. If you start a WPA capture in step 5, verify that the test set sends an SETUP message with the calling party number parameters. An example log file is shown as below.

Related Topics

Calling Party Number Parameters


How Do I Configure Test Signals in CW Operating Mode?

How Do I Configure Test Signals in CW Operating Mode?

Last updated: December 20, 2004

  1. Press the CALL SETUP key.
  2. Press the Operating Mode ( F1 ) key and set the operating mode to CW .
  3. Press the Test Signal ( F9 ) key to select a signal for output to the front panel RF connector currently selected. See Front Panel Connectors to select either RF IN/OUT or RF OUT ONLY connector.
  4. Select a test signal from the menu and confirm the selection by selecting Yes in the dialog box.
    NOTE

    Changing test signal requires several seconds to complete.

  5. Press the Cell Power ( F7 ) key and set the signal output power level to meet your testing needs.
  6. Press the RF Gen Freq ( F8 ) key and set the signal output center frequency to meet your testing needs.
  7. Press the Receiver Control ( F12 ) key and manually set the test set's receiver control parameters (such as expected CW power, measurement receiver frequency, and reverse link receiver frequency) to the desired values (see Manual Receiver Control ).

Related Topics

CW Operating Mode

Receiver Control


End a Connection

End a Connection

Last updated: December 20, 2004

  1. Press the CALL SETUP key.
  2. Press the End Call ( F3 ) key, or end the call from the UE.
  3. Check for Idle in the Active Cell field.


How Do I Change Generator Information?

How Do I Change Generator Information?

Last updated: December 20, 2004

A. Set Parameters Requiring Cell Off Operating Mode: Downlink Channel Codes and Downlink Channel Levels.

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Cell Off .
  3. Press the left More key until you reach the Call Control ( 2 of 4 ) menu.
  4. Select Generator Info ( F3 ).
  5. Press the Downlink Channel Codes ( F2 ) key, and set the channel codes.
  6. Press the Downlink Channel Levels ( F3 ) key, and set the power levels for the downlink channels.
  7. Press the Close Menu ( F6 ) key.
  8. Select Return ( F6 ).
  9. Change the operating mode back to Active Cell if desired.

B. Change Parameters Allowed in Active Cell Mode: Connected Downlink Channel Levels and AWGN Power.

  1. Press the CALL SETUP key.
  2. Press the left More key until you reach the Call Control ( 2 of 4 ) menu.
  3. Press Generator Info ( F3 ).
  4. Press the Connected DL Channel Levels ( F4 ) key, and change the power levels for the downlink channels while a call is connected in order to test the UE's response.
  5. Press the AWGN Power ( F5 ) key to set AWGN power as needed.
  6. Press Return ( F6 ).

Related Topics

Cell Power and AWGN Power


How Do I Perform a Handoff (Handover)?

How Do I Perform a Handoff (Handover)?

Last updated: December 21, 2004

  • Physical Channel Reconfiguration (Inter-frequency Hard Handoff)
  • Transport Channel Reconfiguration (Change of RMC)
  • System Handoff

Physical Channel Reconfiguration (Inter-frequency Hard Handoff)

  1. Establish a call with the UE and verify that Connected is shown in the Active Cell field (see How Do I Set Up a Call and Make a Connection? ).
  2. Press the CALL SETUP key.
  3. Select Handoffs ( F5 ).
  4. Select Physical Chann Reconfig ( F1 ).

  5. You can set Handoff Downlink Channel (UARFCN) and Handoff Uplink Channel (UARFCN) independently, or set Handoff Downlink Channel (UARFCN) and then specify the handoff uplink frequency's offset from the handoff downlink frequency using the Handoff Uplink Separation setting.

    To set the Handoff Downlink Channel (UARFCN) and Handoff Uplink Channel (UARFCN) independently:

    1. Select Handoff Downlink Channel (UARFCN) and enter the desired UARFCN using the front panel DATA ENTRY keys.
    2. Select Handoff Uplink Channel (UARFCN) and enter the desired UARFCN using the front panel DATA ENTRY keys.

    To set the Handoff Downlink Channel (UARFCN) and Handoff Uplink Channel (UARFCN) using a fixed frequency offset:

    1. Select Handoff Uplink Channel (UARFCN) to highlight it, then press the OFF ( MANUAL ) key on the front panel. This sets Handoff Uplink Channel (UARFCN) to manual control, so that you can then set Handoff Downlink Channel (UARFCN) and Handoff Uplink Separation to a valid combination.
    2. Select Handoff Downlink Channel (UARFCN) and enter the desired UARFCN using the front panel DATA ENTRY keys.
    3. Select Handoff Uplink Separation and choose the desired frequency separation.
    4. Select Handoff Uplink Channel (UARFCN) to highlight it, then press the ON ( AUTO ) key on the front panel. This returns Handoff Uplink Channel (UARFCN) to automatic control.
  6. Select Execute Handoff ( F5 ).
  7. Verify that Connected is still shown in the Active Cell field.

Transport Channel Reconfiguration (Change of RMC)

  1. Establish an RB test mode call with the UE and verify that Connected is shown in the Active Cell field (see How Do I Set Up a Call and Make a Connection? ).
  2. Press the CALL SETUP key.
  3. Select Handoffs ( F5 ).
  4. Select Transport Chann Reconfig ( F2 ).
  5. Set Handoff RB Test Mode RAB as needed.
  6. Select Execute Handoff ( F5 ).
  7. Verify that Connected is still shown in the Active Cell field.

System Handoff

  1. Confirm that the GSM/GPRS format is in active cell operating mode (press the SYSTEM CONFIG key, select Format Switch ( F2 ), select GSM/GPRS , and set Operating Mode ( F1 ) to Active Cell (GSM) ). Return to the W-CDMA format by pressing the SYSTEM CONFIG key.
  2. Establish an RB test mode or AMR voice call with the UE and verify that Connected is shown in the Active Cell field (see How Do I Set Up a Call and Make a Connection? ).
  3. Press the CALL SETUP key.
  4. Select Handoffs ( F5 ).
  5. Select System Handoff ( F3 ).
  6. Set the GSM system parameters as needed.
  7. Select Execute Handoff ( F5 ).
  8. When performing a handoff from W-CDMA RB test mode to a GSM voice call with RB Test Mode to GSM Handoff Alerting State set to On, the UE will ring. You must answer the ring for the connection to be completed and testing to progress.
  9. Verify that Connected is still shown in the Active Cell field.

Related Topics

Handoffs (Handovers)


Enabling the HTTP Interface

Enabling the HTTP Interface

Last updated: December 20, 2004

This section contains the following:

  • Enabling the HTTP Interface for Mobile Terminated SMS
  • Enabling the HTTP Interface for Mobile Originated SMS

Enabling the HTTP Interface for Mobile Terminated SMS

  1. Press the Call Setup key to go the Call Setup screen.
  2. Go to menu ( 4 of 4 ) of the Call Control menu by pressing the More key on the lower left corner of the test set.
  3. Select Short Message Service by pressing the softkey F6 .
  4. Select HTTP Setup ( F3 ). The SMS HTTP Setup menu appears.
  5. Select HTTP SMS Input State . The Input State menu appears.
  6. Select On .

Enabling the HTTP Interface for Mobile Originated SMS

  1. Press the Call Setup key to go the Call Setup screen.
  2. Go to menu ( 4 of 4 ) of the Call Control menu by pressing the More key on the lower left corner of the test set.
  3. Select Short Message Service by pressing the softkey F6 .
  4. Select HTTP Setup ( F3 ). The SMS HTTP Setup menu appears.
  5. Select HTTP SMS Output State . The Output State menu appears.
  6. Select On .

Related Topics

HTTP Interface Configuration for Mobile Terminated SMS


How Do I Make Measurements on a UE?

How Do I Make Measurements on a UE?

Last updated: December 20, 2004

A. Establish a Connection.

See How Do I Set Up a Call and Make a Connection? .

B. Select measurements.

  1. Press the Measurement selection key.
  2. Highlight a measurement and press the knob.
  3. Repeat steps 1 and 2 to add measurements.


How Do I Change the Measurement Setup?

How Do I Change the Measurement Setup?

Last updated: December 20, 2004

A. Select a measurement.

  1. Press the Measurement selection key.
  2. Highlight a measurement to set up and press the knob.

B. Set up the measurement.

  1. Press the measurement's setup key ( F1).
  2. Highlight a parameter and press the knob.

  3. Enter a value or selection and press the knob.

    Note : For statistical measurement results, change the Multi-Measurement Count parameter from Off to a number >1.

  4. Press the Close Menu (F6) key.


How Do I Configure the Radio Bearer Test Mode?

How Do I Configure the Radio Bearer Test Mode?

Last updated: December 20, 2004

  1. Press the CALL SETUP key.
  2. Press the More key until you reach the Call Control 3 of 4 menu.
  3. Select RB Test Mode Setup ( F6 ).
  4. Configure the parameters as needed.

Related Topics

Radio Bearer Test Mode Setup


How Do I Change Receiver Control Parameters?

How Do I Change Receiver Control Parameters?

Last updated: December 20, 2004

In some instances you may want to control the test set's receiver settings manually rather than allowing the test set to automatically control them. This ability is referred to as manual receiver control (see Receiver Control ).

Manual Receiver Control in Active Cell, Cell Off or FDD Test Operating Mode

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell, or Cell Off, or FDD Test .
  3. Press the More key two times until 3 of 3 is displayed.
  4. Press the Receiver Control ( F12 ) key.
  5. To manually set the receiver's expected power, highlight the Power Control field and select Manual , then enter a a desired value in the Manual Power field by using the knob or numeric keys.
  6. To manually set the receiver's measurement downconverter frequency, highlight the Measurement Frequency field and enter a desired value to replace the Auto with the knob or numeric keys.
  7. (In FDD Test mode only) To manually set the receiver's demodulation downconverter tune frequency, turn the knob to highlight the Uplink Frequency field and enter a desired value to replace the Auto with the knob or numeric keys.

Manual Receiver Control in CW Operating Mode

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select CW .
  3. Press the Receiver Control ( F12 ) key.
  4. To set the receiver's expected power, turn the knob to highlight the Expected CW Power field and press the knob, then enter a desired value by using the knob or numeric keys and press the knob.
  5. To set the measurement downconverter's tune frequency, turn the knob to highlight the Measurement Frequency field and press the knob, then enter a desired value by using the knob or numeric keys and press the knob.
  6. To set the demodulation downconverter's tune frequency, turn the knob to highlight the Uplink Frequency field and press the knob, then enter a desired value by using the knob or numeric keys and press the knob.
  7. Press Close Menu ( F6 ).

Related Topics

Receiver Control


How do I Change Security Setup Parameters

How do I Change Security Setup Parameters

Last updated: December 20, 2004

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell or Cell Off .
  3. Press More ( 1 of 4 ) until you reach the fourth menu.
  4. Press the Security Setup ( F1 ).
  5. Press the Security Settings ( F1 ).
  6. Select the desired parameter and change the parameter as needed using the knob and/or keypad.
  7. Press Close Menu ( F6 ).
  8. Your settings are displayed in the Security Settings table on the Security window.
  9. If desired, press Reset Authen. SQN ( F2 ) key to reset the authentication sequence number (SQN) to zero.
  10. Press Return ( F6 ).

Related Topics

Security Setup


How Do I Set Up a Call and Make a Connection?

How Do I Set Up a Call and Make a Connection?

Last updated: December 20, 2004

  1. Press the CALL SETUP key.
  2. Press the left More key to move to the Call Control 2 of 4 menu.
  3. Select Cell Parameters ( F2 ).
    • Set ATT (IMSI Attach) Flag State to Set , if required for your UE to register with the test set.
    • Set any other cell parameters as needed.
    • Select Close Menu ( F6 ).

      NOTE
      Some cell parameters can only be set when Operating Mode ( F1 ) is set to Cell Off .

  4. Set the call parameters as needed, using the right More key to move between the three Call Parms menus.

    NOTE
    Some call parameters can only be set when Operating Mode ( F1 ) is set to Cell Off .

  5. Connect the UE to the front panel RF IN/OUT port and power it on.
  6. After a few seconds the UE should register with the test set. The test set should then display UE Information such as IMSI and IMEI , and the MM Status should change from None to IMSI Attached .
  7. You can establish the call in one of two ways:
    • Test set originated call -
      • Select Paging Service ( F9 ) and set as needed.
      • If Paging Service is set to RB Test Mode , select Channel Type ( F8 ) and set as needed.
      • Select Originate Call ( F3 ).
      • For the lab application only, if Paging Service is set to AMR Voice , and Calling Party Number Inclusion is set to Include , the Calling Party Number is displayed on the UE's screen (see How Do I Perform Calling Party Number Verification? ).
      • Answer the call if necessary, and verify that Connected is displayed in the Active Cell window.
    • UE initiated call -
      • Dial a number into the UE and press send.
      • Verify that Connected is displayed in the Active Cell window.
      • For the lab application only, the Called Party Number is displayed under UE Information .

Related Topics

Establishing a Connection with the UE

Troubleshooting Call Processing Operations

How Do I Change Call Parameters?

How Do I Change Cell Parameters?

How Do I Make a Video Call?

Active Cell Operating Mode


How Do I Change the SIB11 Cell Info List?

How Do I Change the SIB11 Cell Info List?

Last updated: December 20, 2004

  1. Press the CALL SETUP key.
  2. Press the left MORE key until you reach the Call Control 4 of 4 menu.
  3. Select SIB11 Cell Info List ( F3 ).
  4. Set Cell Info List ( F1 ), SIB11 Intra-freq Cell Info List ( F2 ), SIB11 Inter-freq Cell Info List ( F3 ) and SIB11 GSM Cell Info List ( F4) settings as needed.

Related Topics

SIB11 Cell Info List


How Do I Use the Spectrum Monitor?

How Do I Use the Spectrum Monitor?

Last updated: December 20, 2004

The following procedure shows a typical usage of the spectrum monitor in each of its two modes of operation; Swept Mode and Zero Span mode.

  1. Establish a call with the mobile.

    NOTE
    The spectrum monitor can also be used with any of the test set's test mode operating modes.

  2. Press the Instrument selection key.
  3. Select Spectrum Monitor .

    The spectrum monitor is displayed with the default settings as shown above. The center frequency is initially set at the expected frequency maintained by the test set's base station emulator. The Swap Window Positions ( F5 ) key is only displayed when other measurements are active at the same time as the spectrum monitor.

  4. Set the axis control as needed for your testing situation using the Frequency Span ( F1 ), Reference ( F2 ), and dB/div ( F3 ) keys. For example, if you want to set the reference level manually ( Auto is the default), press the Reference ( F2) key then use the DATA ENTRY keys to enter the value you want.
  5. Press the Trigger Setup ( F4 ) key to access the Trigger Setup menu.
  6. Set the trigger settings to meet your testing needs. For example:

    • If you want the Spectrum Monitor to sweep immediately and continuously, ensure that Trigger Arm ( F3 ) is set to Continuous .
    • If you want to use external triggering, so that the Spectrum Monitor is triggered from a signal applied to the TRIG IN connector on the test set's rear panel, set Trigger Source ( F1 ) to External .
    • Trigger Delay ( F2 ) allows you to specify the point, relative to the trigger event where samples are taken (a negative trigger delay value collects pre-trigger samples). The same trigger delay setting is used for swept mode and zero span mode.

  7. Press the Return ( F6 ) key to exit the Trigger Setup menu.
  8. Press the Display ( F6 ) key to access the display settings.

    A typical spectrum monitor trace display is shown above. In this case, the Display menu is open allowing you to access all of the display control settings using the ( F1 ) through ( F12 ) keys.

    The following list provides examples of some of the settings you may want to adjust:

    • Peak Threshold ( F4 ) and Peak Excursion ( F5 ) set the peak threshold and peak excursion levels respectively. A peak is identified by using the peak threshold and peak excursion value. A point is only marked as a peak if it rises and falls more than the peak excursion value from the peak threshold value.

    • Marker Mode ( F8 ) sets the mode of the active marker. Position mode activates a single frequency marker. Delta mode freezes the active marker at its current location and uses it as a reference marker. A second marker is created at the position of the reference marker and is used as a delta marker, reporting any change in amplitude or frequency from that of the reference marker.

    • Peak Search ( F10 ) moves the active marker to the highest peak on the spectrum monitor display, returning the numeric amplitude and frequency values.

    • Marker -> Expected Freq ( F11 ) sets the base station emulator's expected frequency to the frequency of the active marker.

    • Marker -> Expected Power ( F12 ) sets the base station emulator's expected power level to the amplitude of the active marker.

    A typical swept mode spectrum monitor display is shown above. In this case, the active marker is marker 1, which is set to Delta mode.

  9. Press the Return ( F6 ) key to exit the Display menu.
  10. To set the spectrum monitor to zero span mode, press the Frequency Span ( F1 ) key and use the numeric DATA ENTRY keys to enter a value of 0 MHz , or use the down-arrow key to reduce the span to zero.

    A typical zero span mode spectrum monitor display is shown above. Like swept mode, the Y-axis represents absolute amplitude. However, the X-axis now represents time rather than frequency.

  11. Press the Trigger Setup ( F6 ) key. In zero span mode, additional trigger setup controls are available to you:
    • If you want to change the view window over which you are looking at the signal, use the Time Span ( F8 ) and Time Offset ( F9 ) keys. The measurement is made for the duration of the time span, beginning at the time defined by the trigger event plus the trigger delay plus the time offset.
    • If you want to change the resolution bandwidth, press the Zero Span RBW ( F7 ) key and select a value. (To measure the total power of a signal you must select a resolution bandwidth greater than or equal to the signal bandwidth.) Note that changing the zero span resolution bandwidth does not modify the swept mode resolution bandwidth.

    A typical zero span mode spectrum monitor display showing a bursted signal. The viewing window has been adjusted to zoom in on a single burst.

    If the temperature of the test set drifts outside the calibrated temperature range of the spectrum monitor, a Measurement Uncalibrated message is displayed. To calibrate the spectrum monitor for the current temperature, press the Calibrate Measurement ( F11 ) key on the Trigger Setup menu.

Related Topics

Spectrum Monitor Description


How to use the Short Message Service Features

How to use the Short Message Service Features

Last updated: December 20, 2004

This section is only applicable to the lab applications.

This section describes general procedures for using SMS features from the test set's front panel.

  • Mobile Terminated Point-to-Point Message Transfer
  • Mobile Originated Point-to-Point Message Transfer
  • Cell Broadcast Message Transfer
  • Cell Broadcast Updated Message Transfer

Mobile Terminated Point-to-Point Message Transfer

The following procedures,

  • Procedure A: Sending a Text Message to the Mobile Station and
  • Procedure B: Sending a WAP Push Message to the Mobile Station
can be used to simulate exchanging SMS messages between the test set and the mobile station attached to the test set's RF port.

Procedure A: Sending a Text Message to the Mobile Station

  1. If you would like a log of the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set and power it on.
  3. After the mobile station has camped, go to the Call Setup screen by pressing the Call Setup key.
  4. Go to menu ( 4 of 4 ) of the Call Control menu by pressing the More key on the lower left corner of the test set.
  5. Select Short Message Service by pressing the softkey F6 .
  6. Select the Point to Point SMS messaging by pressing the softkey F1 .
  7. Select Mobile Terminated by pressing the softkey F2 .The Mobile Terminated SMS menu appears.
  8. Choose to use either the CS Domain or PS Domain for sending the SMS message using by selecting the Transportation parameter and scrolling to the desired value.
  9. Choose the message to send by selecting the Content parameter. Select Text2 . For additional information about the message options available, see Short Message Service (SMS) Messages .
  10. Press the Send Message softkey ( F1 ) to send the message. Observe the mobile station for indications that the message has been received. The test set display also gives an indication.
  11. If you are capturing a log, stop logging.

Procedure B: Sending a WAP Push Message to the Mobile Station

  1. If the Pt to Pt SMS control screen is not visible on the test set's front panel, use steps 1 thru 6 of Procedure A: Sending a Text Message to the Mobile Station .
  2. Select Mobile Terminated by pressing the softkey F2 .The Mobile Terminated SMS menu appears.
  3. Choose the message to send by selecting the Content parameter. Select Custom Data . Configuring the content of your custom data requires a GPIB command. See Defining the User Data (TP-UD) content for Binary SMS Applications for information on configuring custom data.
  4. Select the Data Coding Scheme parameter and use the test set's keypad to enter 245 . This entry indicates that this message is a WAP Push message.
  5. Select the User Data Header Indicator parameter. Select 1 . This indicates that this message has a User Data Header.
  6. Press the Send Message softkey ( F1 ) to send the message. Observe the mobile station for indications that the message has been received. The test set display also gives an indication.
  7. If you are capturing a log, stop logging.

Mobile Originated Point-to-Point Message Transfer

  1. If you would like a log of the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set and power it on.
  3. After the mobile station has camped, go to the Call Setup screen by pressing the Call Setup key.
  4. Go to menu ( 4 of 4 ) of the Call Control menu by pressing the More key on the lower left corner of the test set.
  5. Select Short Message Service by pressing the softkey F6 .
  6. If you want the message received by the test set to be resent to the mobile station, first, select the Point to Point SMS messaging by pressing the softkey F1 , then select Mobile Originated by pressing the softkey F3 , then select the Loopback parameter and scroll to On .
  7. Use the mobile station to send a point-to-point message of "Hello" to any address.
  8. Observe the test set for indications that the message has been received. If the loopback option is enabled, observe the mobile station for indications that the message has been received.
  9. If you are capturing a log, stop logging.

Cell Broadcast Message Transfer

  1. If you would like a log of the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set and power it on.
  3. Go to the Call Setup screen by pressing the Call Setup key.
  4. Go to the fourth page of the Call Control menu by pressing the More key on the lower left corner of the test set.
  5. Select Short Message Service by pressing the softkey F6 .
  6. Select Cell Broadcast by pressing the softkey F2 . The Broadcast SMS menu appears. You can select setup menus for three different messages.
  7. To select the setup menu, press the softkey next to the menu item labeled Message X Setup where X can be 1, 2, or 3. The menu for the selected message appears:
  8. See Message Setup for more information about each parameter in the message setup.
  9. Set the parameters as desired for each message.
  10. Start the broadcast message using the Start Cell Broadcast softkey ( F1 ).
  11. Observe the display on the mobile station to confirm that the message(s) were received.

    NOTE
    This could take up to 30 seconds.

  12. If required, stop the broadcast by pressing the Stop Cell Broadcast softkey ( F1 ).
  13. If you are capturing a log, stop logging.

Cell Broadcast Updated Message Transfer

  1. If you would like a log of the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set and power it on.
  3. Go to the Call Setup screen by pressing the Call Setup key.
  4. Go to the fourth page of the Call Control menu by pressing the More key on the lower left corner of the test set.
  5. Select Short Message Service by pressing the softkey F6 .
  6. Select Cell Broadcast by pressing the softkey F2 .
  7. Set parameters as desired. To choose the messages to be sent, select Message Setup for that message and set Message State to On .
  8. Select the message to be sent using the Message Text menu for each message.
  9. Start the broadcast message using the Start Cell Broadcast softkey ( F1 ).
  10. Observe the display on the mobile station to confirm that the message(s) were received.
  11. Select Message Setup for each message to be sent as an update.
  12. Set the Update Number for these messages higher than their previous value. The update number wraps from 15 to 0.
  13. Observe the display on the mobile station to confirm that the updated message(s) have replaced the first versions.
  14. If required, stop the broadcast by pressing the Stop Cell Broadcast softkey ( F1 ).
  15. If you are capturing a log, stop logging.

Related Topics

Short Message Service (SMS)

Point-to-Point SMS

Cell Broadcast Service (CBS)

Logging SMS Messages

Short Message Service (SMS) Messages


How Do I Configure the Test Set for My Test System?

How Do I Configure the Test Set for My Test System?

Last updated: December 20, 2004

A. Configure instrument information and setup.

  1. Press the SYSTEM CONFIG key.
  2. Press the Instrument Setup ( F1 ) key.
  3. Adjust an instrument setting and then press the Close Menu ( F6 ) key.

CAUTION
Always verify that the test set is responding to a new LAN IP Address by pinging the test set. If the test set does not respond to the ping, cycle power. This will ensure that the test set will respond to the new LAN IP Address.

B. Set amplitude offsets.

  1. On the Configuration Summary Screen, press the RF IN/OUT Amptd Offset ( F5 ) key.
  2. On the RF IN/OUT Amplitude Offset screen, press the RF IN/OUT Amptd Offset Setup ( F2 ) key.
  3. Enter the amplitude offset for the test frequencies you use.
  4. Press the Close Menu ( F6 ) key.
  5. Press the Return ( F6 ) key.

C. Check the message log.

  1. Press the Message Log ( F7 ) key and view the message log.
  2. Press the Return ( F12 ) key.


How Do I Turn Off a Measurement?

How Do I Turn Off a Measurement?

Last updated: December 20, 2004

  1. Press the Measurement selection key.
  2. Highlight the measurement you want to turn off.
  3. Press the Close Measurement ( F4 ) key.
  4. Press the Close Menu ( F6 ) key.


How Do I Change UE TX Power Levels

How Do I Change UE TX Power Levels

Last updated: December 20, 2004

A. Using Closed Loop Power Control

  1. Press the CALL SETUP key.
  2. Press the More key on the right side two times to go to Call Parms ( 3 of 3) .
  3. Press the UE Target Power ( F7 ) key, and set the desired average transmit power of the UE (see UE Target Power ).
  4. Press the UL CL Power Ctrl Parameters ( F8 ) key.
  5. Highlight the UL CL Power Ctrl Mode and select Active bits . This activates the uplink closed loop power control.
  6. Highlight the UL CL Power Ctrl Algorithm and select power control algorithm as desired. If algorithm One is selected for power control, you can also specify the UL CL Power Ctrl Stepsize to either 1 dB or 2 dB.
  7. Now, the UE's transmit power will be controlled automatically by the closed loop power control to maintain the UE's average power at the value entered for the UE Target Power .

B. Controlling the UE's TX Power Manually

  1. Press the CALL SETUP key.
  2. Press the More key on the right side two times to go to screen 3 of 3 .
  3. Press the UL CL Power Ctrl Parameters ( F8 ) key.
  4. Highlight the UL CL Power Ctrl Mode and select a power control mode other than Active bits . This allows you to control the UE's transmit power manually.
  5. Highlight the UL CL Power Ctrl Algorithm and select power control algorithm as desired. If algorithm One is selected for power control, you can also specify the UL CL Power Ctrl Step Size to either 1 dB or 2 dB.
  6. If you've chosen Alternating bits as the power control mode, you can use the Send Step Up TPC Bit Pattern ( F10 ) key or the Send Step Down TPC Bit Pattern ( F11 ) key to change the UE's transmit power either up or down by one step.

Related Topics

Uplink Closed Loop Power Control Parameters and UE Target Power


How Do I Order and Retrieve UE Reported Measurement Results?

How Do I Order and Retrieve UE Reported Measurement Results?

Last updated: December 20, 2004

  • Lab Application - Cell 1/Cell 2 Measurements
  • Lab Application - Compressed Mode Measurements (Inter Frequency and GSM Cells)
  • Test Application - Cell 1 Measurements

Lab Application - Cell 1/Cell 2 Measurements

  1. Establish a call between the test set and UE (see How Do I Set Up a Call and Make a Connection? )
  2. Select Handoffs ( F5 ) from the Call Control 1 of 4 menu.
  3. Select Soft Handoff Info ( F4 ).
  4. Turn Cell 2 Power ( F1 ) on if you would like to retrieve UE measurement results for cell 2 as well as cell 1.
  5. Press the More key under Soft Info to move to the 2 of 2 menu.
    • Set Report Measurement Type ( F2 ) and SFN-SFN OTD Measurement Type ( F4 ) to specify which measurements the UE should perform when Send Meas Request ( F5 ) is selected.
    • If you specified that the UE should measure DTCH BLER , set the BLER Rep Intrvl ( F1 ) as needed.
    • Select Send Meas Request ( F5 ) (this will only be present if you have a call connected). UE reported measurement results are displayed.

Lab Application - Compressed Mode Measurements (Inter Frequency and GSM Cells)

See How Do I Enable Compressed Mode and Obtain UE Measurement Results? .

Test Application - Cell 1 Measurements

  1. Establish a call between the test set and UE (see How Do I Set Up a Call and Make a Connection? )
  2. Press the left More key until you reach the Call Control 2 of 4 menu.
  3. Select UE Rep Meas ( F5 ).
  4. Set Report Measurement Type ( F2 ) to specify which measurements the UE should perform when Send Meas Request is selected.
  5. If you specified that the UE should measure DTCH BLER , set the BLER Rep Intrvl ( F1 ) as needed.
  6. Select Send Meas Request ( F5 ) (this will only be present if you have a call connected). UE reported measurement results are displayed.

Related Topics

UE Reported Measurements


How Do I Change Uplink Parameters?

How Do I Change Uplink Parameters?

Last updated: December 20, 2004

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Cell Off .
  3. Press More key on the left to go to Call Control ( 2 of 4 ).
  4. Press the Uplink Parameters ( F 4 ) to access the settings for uplink PRACH and DPCH channels.
  5. Turn the knob to highlight a parameter and then press the knob.
  6. Enter a value or selection as desired and press the knob.
  7. Press Close Menu ( F6 ).
  8. Change the operating mode back to Active Cell if needed.

Related Topics

Uplink Parameters


How Do I Make a Video Call?

How Do I Make a Video Call?

Last updated: December 20, 2004

This section is only applicable to the lab application and to a test application with the required feature license.

Video Call Setup

  1. Establish an external device connection between 8960 #1 and 8960 #2 (see How Do I Make an External Device Connection? ).
  2. Connect UE #1 to 8960 #1.
  3. Connect UE #2 to 8960 #2.
  4. Turn on the UEs and wait for each to camp to its 8960 (see How Do I Set Up a Call and Make a Connection? ).
  5. Originate a video call from UE #1 (you may choose to originate the call from either UE, this example assumes the call is originated from UE #1). The video call can not be initiated from either of the 8960s. Note: originating a video call on your UE will likely require different key presses than originating a voice call.
  6. If Calling Party Number Inclusion is set to Include (see How Do I Perform Calling Party Number Verification? ), the Calling Party Number is displayed on the screen of UE #2. Answer the call on UE #2.
  7. Note the following on the Call Setup Screen of both 8960s:
    • Call processing state is Connected .
    • Current System Type (displayed in the Call Processing Status window) is CS Data - UE to UE Video Call .
    • The Called Party Number you dialed when originating the call is displayed in the UE Information window.
  8. If desired, initiate transmitter measurements on both 8960s and measure the UEs' performance.
  9. You can end the video call from either UE, or by selecting End Call ( F3 ) on either 8960.

Related Topics

Video Call

Troubleshooting Video Call

Manual Operation: How Do I Make an External Device Connection?


Printing Screens

Printing Screens

Last updated: December 20, 2004

Printing and Saving Screen Images

The test set's local area network (LAN) connection can be used to dump the currently-displayed screen image into a personal computer's web browser. The computer must either be connected to an existing LAN or have a LAN adapter installed that can be connected directly to the test set.

Computer Requirements for LAN Communications with the Test Set

The computer used to capture screen images from the test set must meet the following requirements:

  • 10 Base-T, IEEE 802.3 compliant, ethernet network interface using TCP/IP protocol and configured to run in half-duplex mode.
  • Windows 95, 98, 2000 or NT 4.0 (Windows 95, Windows 98, Windows 2000 and Windows NT 4.0 are U.S. registered trademarks of Microsoft Corporation.)

Test Set to Computer Connections

The test set's LAN connection can be made at either the rear-panel LAN PORT or at the front-panel DATA port. When using the DATA port, be sure to have the factory supplied jumper cable installed between the rear-panel LAN PORT and the ETHERNET TO FRONT PANEL port.

Connections from the test set to the computer must be made using the correct type of LAN cable:

  • If the test set is being connected to the computer through an existing network, use a standard LAN cable.
  • If the test set is being connected directly to the computer's LAN adapter, use a crossover LAN cable (such as the one shipped with the test set or with an older test application upgrade kit).

Capturing the Screen Image

  1. Press the test set's SYSTEM CONFIG key to display the test set's LAN settings, and record the LAN IP Address for use later in this procedure.
  2. Start a web browser application on your computer.
  3. Display the test set screen that you want to capture.
  4. Enter the following address/location into your web browser: http://<lan address>/display.htm
    where <lan address> is the LAN IP address of the test set .
  5. Within a few seconds, the test set's screen image appears in your browser. If the image does not appear on your browser within 30 seconds, refer to Test Your LAN Connections and Configuration by "Pinging" the Test Set below.
  6. To print the image, select File , Print .
  7. To save the file:
    1. Select File , or right-click on the image, and select Save As or Save Picture As .
    2. Enter the desired file name and directory path for saving the image as a GIF file.

The image can now be retrieved from your directory and used as needed.

Test Your LAN Connections and Configuration by "Pinging" the Test Set

Perform this operation only if you were not successful in downloading the test set screen image into your browser.

  1. Display the Command Prompt window on your computer. This is typically done in the Microsoft Windows operating system by selecting Start -> Programs -> Command Prompts .
  2. At the command prompt, enter the following command: ping <lan address>. The <lan address> is the test set's LAN IP address. (The command prompt does not have to be at the root (c:\) level before entering the command.)

    This example shows what should happen when you enter the ping command for a test set with the LAN IP address of 111.22.333.44. The test set should reply back to the Command Prompt screen indicating that data was received.
  3. If the message " Request Timed Out " is displayed instead of a reply from the test set, try entering the command again. If the request times out again, your LAN connections are incorrect and/or your LAN settings for the two devices do not match.

Troubleshooting LAN Connections

If your web browser did not display the test set's screen, or you could not "ping" your test set from your browser, refer to the following information to find the cause and fix the problem.

Try Altering Connections

  • If you are using the test set's front panel DATA port, make sure the jumper between the rear-panel LAN PORT and ETHERNET TO FRONT PANEL port is in place; or try connecting directly to the rear-panel LAN PORT.
  • Try using a different type of LAN cable. If you were using a crossover cable, try using a standard LAN cable; if using a standard LAN cable, try using a crossover cable. If this doesn't fix the problem, be sure to replace the cable with the type recommended in Test Set to Computer Connections above.

Reconfigure the Computer and Test Set LAN Settings

If the test set's image is still not displayed on your web browser, and the ping command still indicates that the test set is not communicating with the computer, you need to verify that the LAN settings for the computer and the test set are compatible. The following sections provide general guidelines in getting the LAN settings configured for both instruments to communicate with each other.

Perform the configuration in the following order:

  1. Configure the computer's LAN settings.
  2. Restart Windows on the computer to start using the new LAN configuration.
  3. Configure the test set's LAN settings to work with the computer's settings. (It is important that the computer be configured and re-started before configuring the test set's LAN settings.)
  4. Turn the test set off and back on to make sure it finds the computer's newly-configured LAN card on power up.

LAN Setting Guidelines

  • It is highly recommended that the Subnet Mask be set to 255.255.248.0 for the test set and the computer when using a direct computer-to-test set connection.
  • The first three groups of numbers for the LAN IP Address of the test set and the computer must match. Example; if the test set's LAN IP Address is set to 130.29.189.33, the computer's LAN IP address must begin with 130.29.189.

    The number in the fourth group of digits in the computer's and test set's LAN IP Addresses must NOT match. Example; if the test set is set to LAN IP Address 130.29.189.33, set the computer's LAN IP Address to 130.29.183.34 (or 130.29.183.77, 130.29.183.42...- just so the last number is not also set to 33). The last entry in the IP Address must not be >254 or 0.

Changing the LAN Setting on Your Computer

Network configuration procedures vary between operating systems. You may have to refer to your computer's help system, or your LAN adapter card's documentation, for assistance.

Perform the following steps to alter the network settings for most PCs using a Microsoft Windows operating system.

Access the Network Settings

  1. Double-click on the My Computer icon on the Windows desk top.
  2. Double-click on the Control Panel icon.
  3. Double-click on the Network icon.
  4. Select the TCP/IP -> [your Ethernet network adapter] entry from the list of components. Note: Do not select TCP/IP Dial-Up Adapter settings if present.
  5. Select Properties to access the TCP/IP settings screen.
Accessing Your Computer's LAN Settings

Set the IP Address and Subnet Mask

  1. Select the IP Address tab on the TCP/IP Properties screen.
  2. Select Specify an IP Address .
  3. Enter the IP Address for the computer. Remember, the last entry in the IP Address must not be >254 or 0.
  4. Enter the Subnet Mask (255.255.248.0).
Specifying the Computer's IP Address and Subnet Mask

Remove Any Gateway Setting

  1. Select the Gateway tab.
  2. If present, remove any existing setting.
  3. Click OK until you have closed the Network settings window.
Accessing the Gateway Setting

Restart Windows

Depending on your LAN network adapter, your computer may or may not apply the network configuration changes as they are made. It is import that you restart Windows NOW to make sure new LAN settings are in effect when you try to connect to the test set.

Changing the LAN Settings on Your Test Set

  1. Press the SYSTEM CONFIG key on the test set to display the current LAN settings.
  2. Press the F1 ( Instrument Setup ) key.

    NOTE
    Changing the LAN IP Address may alter the Subnet Mask setting. Therefore, change the LAN IP Address first, then change the Subnet Mask. Also, The last entry in the IP Address must not be >254 or 0.

  3. Turn the knob to highlight the setting you want to change.
  4. Press the knob to select the setting.
  5. Enter the new value using the keypad, and press the knob to complete the setting.
  6. Turn the test set off and back on to start using the new settings.

Related Topics

Configuring the Test Set's LAN


Rear Panel Connectors

Rear Panel Connectors

Last updated: December 20, 2004

Description

BASEBAND I/O

Four pins are functional on this connector:

  • I channel (pin 9)
  • Q channel (pin 26)
  • Ground
  • Ground

CLK IN

Not functional for this release.

COUNTER IN

Not functional for this release.

DATA IN

Not functional for this release.

DATA VALID IN

Not functional for this release.

ETHERNET TO FRONT PANEL

This RJ-45 connector is used with a separate LAN jumper cable to connect the front panel DATA connector to the rear panel LAN PORT.

The the DATA connector on the front panel is connected internally to the ETHERNET TO FRONT PANEL connector on the rear panel. In order to use the front panel DATA connector the user must connect the rear panel LAN PORT, to the rear panel ETHERNET TO FRONT PANEL connector with the LAN jumper cable.

The LAN jumper cable, part number E5515-61160, is supplied with the test set.

EXT INTERFACE CONTROL

Not functional for this release.

EXT SIG GEN/FRAME SYNCH

Not functional for this release.

FM MOD IN

This BNC connector allows you to use an external signal to frequency modulate the test set's RF generator. It has a fixed sensitivity of 20 KHz/volt, and a frequency range of 100Hz to 20 KHz.

GPIB

This GPIB connector allows test set control with compatible devices.

LAN PORT

This RJ-45 connector provides connection for downloading firmware upgrades, or new test applications into the test set. No other types of communication are possible with the LAN port.

PRINTER

Not functional for this release.

SERIAL 1

Not functional for this release.

SERIAL 2

Not functional for this release.

SERIAL 3

Not functional for this release.

TEST SET SYNCH IN

Not functional for this release.

TEST SET SYNCH OUT

Not functional for this release.

TIMEBASE ADJUST

This is the timebase adjust cover. Removing this screw allows access for timebase adjustment.

TRIG IN

This BNC connector provides the capability for you to trigger measurements or instruments from an external source. Setting the Trigger Source setting to External for measurements or instruments which support this feature causes the measurement or instrument to trigger when a positive-going TTL compatible pulse is applied to this connector. Currently, the only measurement or instrument which supports this feature is the Spectrum Monitor.

TRIG OUT

This BNC connector allows you to synchronize the test set to other equipment via a trigger signal.

VGA OUT

This DB-15 connector allows you to simultaneously route the test set's display to another monitor.

10 MHZ REF IN

This BNC connector accepts an external 10 MHz timebase signal. The nominal input impedance is 50 ohm. This version of test set can only accept a 10 MHz timebase signal.

10 MHZ REF OUT

This BNC connector provides a 10 MHz timebase signal to external test equipment. The accuracy of this signal is determined by the timebase used. The nominal output impedance is 50 ohm with a typical level of 0.5 V rms.

Related Topics

ETHERNET TO FRONT PANEL, LAN PORT: Configuring the Test Set's LAN

GPIB: Configuring the Test Set's GPIB

TRIG OUT: Trigger Output Setup


Remote/Local Mode

Remote/Local Mode

Last Updated: December 20, 2004

Description

Remote Mode

When the test set is operated remotely, all of the keys on the front panel of the test set are disabled (except the LOCAL key and the power switch). During remote operation the test set is controlled by the Remote User Interface, (RUI).

Any open menus are be closed, and any manual entries are be aborted when the test set transitions from local mode to remote mode.

The remote annunciator (R) will appear in the Instrument Status Area of the test set's display indicating that the test set is in remote mode.

When the test set is in remote mode press the LOCAL key on the front panel in order to gain manual control.

Local Mode

During local mode all front panel keys and the knob are enabled. During local operation the test set is controlled by the Manual User Interface, (MUI).

The remote annunciator (R) is turned off when the test set is operated in local mode.


Save and Recall Registers

Save and Recall Registers

Last updated: December 20, 2004

Description

The test set provides up to five save/recall registers . Each register is identified by a number (1-5).

Recalling Saved Registers

Press the Register recall hardkey.

Use the knob to scroll to a register that is labeled Full and press the knob.

When a register is recalled, the test set will clear all active measurements and display the Call Setup Screen.

CAUTION
If the test set has had hardware options installed since the last time a registers were saved, delete the registers and re-save them. Failure to perform this step could result in a non-recoverable firmware "assert" when performing a register recall.

Deleting Saved Registers

Pressing the DELETE hardkey will display a menu indicating which registers have been saved (they are labeled "Full").

Use the knob to scroll to a register and press the knob. Select Yes to confirm the selection.

Settings that are Saved

All functions and parameters that have an associated static state or settable value will be saved. For example:

  • Cell parameters (System ID, Network ID, etc.)
  • Call control parameters (System Type, Operating Mode, etc.)
  • Measurement setup parameters (Trigger Arm state, Measurement Timeout, etc.)
  • Call Parms (Cell Power, Cell Band, etc.)

Settings that are not Saved

Functions that trigger immediate actions, such as originating a call or calibrating a measurement are not saved.

Settings saved in non-volatile memory (settings that are unchanged when power is cycled or the test set is preset) are not saved. For example:

  • LAN IP Address
  • Date/Time
  • RF IN/OUT Amplitude Offset
  • All other settings on the Instrument Setup menu on the System Config screen.
  • Measurement results
  • Call status
  • Active measurements

Read-only call processing results such as Mobile Station Information tables are not saved.

Saving Current Settings to a Register

To save the current state of the test set, press the SAVE hardkey.

A menu will be displayed that shows the status of all five registers. If the register status is "Full", the register has had instrument settings saved to it. If the register status is "Empty", it does not currently contain any instrument settings.

Use the knob to scroll to a register and press the knob. If the selected register is currently Full, select Yes in the Overwrite Save Reg? window and it will be overwritten.

CAUTION
When a test set application is upgraded using the 8960 File Utility Program, the new revision of the application will not automatically retain save/recall registers from the old revision. Prior to the application upgrade, it is recommended that you record the critical settings (such as call setup information) from registers that you will want to re-save after the test application upgrade.

Related Topics

SYSTem:REGister


UE Information

UE Information

Last updated: December 20, 2004

When the UE registers with the test set, the following information is reported by the UE. You can query this information via GPIB commands, or view it on the Call Setup Screen under UE Information .

IMSI

International Mobile Subscriber Identity.

GPIB command: CALL:MS:REPorted:IMSI[:SELected]?

IMEI

International Mobile Equipment Identity.

GPIB command: CALL:MS:REPorted:IMEI[:SELected]?

Power Class

The UE's power class defines its nominal maximum output power (see 3GPP TS 25.101 6.2).

GPIB command: CALL:MS:REPorted:PCLass[:SELected]?

Detected PRACH Signature

This feature is only applicable to the lab application.

When the UE sends a PRACH preamble, it uses one of the PRACH signatures that the test set has specified using the PRACH Signature parameter. If the test set has specified that more than one PRACH signature is available to the UE, in a series of PRACH bursts, the UE will randomly select which PRACH signature to use for any given burst.

The Detected PRACH Signature result is an integer representing the PRACH signature used by the UE on its final PRACH burst (the one that the test set responded to). If the PRACH Signature setting specifies a single PRACH signature, then Detected PRACH Signature and PRACH Signature should be the same.

For the lab application only, the PRACH preamble analysis measurement also reports the signature used by the UE for the PRACH burst it has analyzed (see PRACH Preamble Analysis Measurement Description ). If the PRACH Signature setting specifies a single PRACH signature, then the PRACH signature reported by the measurement, Detected PRACH Signature and PRACH Signature should be the same.

GPIB command: CALL:MS:REPorted:PRAChannel:SIGnature? .

Called Party Number

This feature is only applicable to the lab application.

This is the number the user dialed into the UE when a UE-originated call was established with the test set. If the user dialed 911, 112 or 999, the string "Emergency Call" is displayed.

See Calling Party Number Parameters for related information.

GPIB command: CALL:MS:REPorted:ONUMber<[:SELected]|WCDMa>?

Clearing the UE Information

To clear the UE reported information, select Clear MS Info ( F6 ) from the Call Setup screen, or send the CALL:MS:REPorted:CLEar[:ALL]<[:SELected]|:WCDMa> command.

Related Topics

Establishing a Connection with the UE


UE Reported Measurements

UE Reported Measurements

Last updated: December 20, 2004

When there is an active link between the UE and the test set, the UE can perform measurements on the test set's (cell 1) downlink signal and report the measurement results. You can view the UE measurement results from the front panel (see How Do I Order and Retrieve UE Reported Measurement Results? ) or retrieve them using the appropriate GPIB syntax queries (see CALL:MS:REPorted ).

With the lab application only, the UE can report measurement results for both cell 1 and cell 2.

With the lab application only, in addition to measuring cell 1 and cell 2 from the test set, if the UE supports compressed mode operation (see Compressed Mode ), the UE can perform measurements on inter frequency neighbor cells or GSM neighbor cells (see Inter-frequency Cells and GSM Cells ). To enable this, you must specify these neighbor cells in the test set's BCCH messaging (see SIB11 Cell Info List ), and then use an external source to provide these neighbor cells to the UE (you may also order the UE to measure these neighbor cells without actually providing them via an external source, but the UE will simply give results indicating that there was no usable signal at the specified neighbor cell). The test set can retrieve the UE's measurement results for up to 8 inter frequency neighbor cells and 8 GSM neighbor cells.

Cell 1/Cell 2 UE Reported Measurements

Once you have established a connection between the test set and UE, you can order the UE to perform measurements on cell 1 (and cell 2 if you are using the lab application) by selecting Send Measurement Request (see How Do I Order and Retrieve UE Reported Measurement Results? and CALL:MS:REPorted:MEASurement:REQuest ). When you select Send Measurement Request , the test set sends a Measurement Control Message to the UE indicating which measurements to perform, based on the following settings:

  • Report Measurement Type
    • Intra-frequency : When Report Measurement Type is set to Intra-frequency , the UE will make CPICH Ec/No , CPICH RSCP (Received Signal Code Power) and Pathloss measurements and return the results.
    • Quality : When Report Measurement Type is set to Quality , the UE will measure DTCH BLER (Block Error Ratio) Report and return the result.
    • All : When Report Measurement Type is set to All , the UE will measure CPICH Ec/No , CPICH RSCP (Received Signal Code Power) , Pathloss and DTCH BLER (Block Error Ratio) Report and return the results.

    GPIB command: CALL:MS:REPorted:MEASurement:TYPe .

  • SFN-SFN OTD Measurement Type

    This setting is applicable to the lab application only.

    • None : When SFN-SFN OTD Measurement Type is set to None , the UE will not measure SFN-SFN OTD.
    • Type 1 : When SFN-SFN OTD Measurement Type is set to Type 1 , the UE will perform a Type 1 SFN-SFN Observed Time Difference (OTD) measurement and return the result.
    • Type 2 : When SFN-SFN OTD Measurement Type is set to Type 2 , the UE will perform a Type 2 SFN-SFN Observed Time Difference (OTD) measurement and return the result.

    GPIB command: CALL:MS:REPorted:MEASurement:OTDifference:TYPE .

Cell 1/Cell 2 Measurement Results

  • CPICH Ec/No

    CPICH Ec/No is the ratio of the received energy per PN chip for the CPICH to the total received power spectral density at the UE antenna connector. The reporting range for CPICH Ec/No is -24 dB to 0 dB (0 to 49)

    CPICH Ec/No Reported Value Mapping to Measured Quantity
    CPICH Ec/No Reported Value | Measured Quantity Value | Unit
    0 | CPICH Ec/No < -24 | dB
    1 | -24 </= CPICH Ec/No < -23.5 | dB
    ... ... ...
    48 | -0.5 </= CPICH Ec/No < 0 | dB
    49 | 0 </= CPICH Ec/No | dB

    GPIB command: CALL:MS:REPorted[:CELL[1]]:CPICh:ECNO? and CALL:MS:REPorted:CELL2:CPICh:ECNO? .

  • CPICH RSCP (Received Signal Code Power)

    This is the absolute power level of the CPICH as received by the UE. The reporting range for CPICH RSCP is -115 dBm to -25 dBm (0 to 91).

    CPICH RSCP Reported Value Mapping to Measured Quantity
    CPICH RSCP Reported Value | Measured Quantity Value | Unit
    0 | CPICH RSCP < -115 | dBm
    1 | -115 </= CPICH RSCP < -114 | dBm
    ... ... ...
    90 | -26 </= CPICH RSCP < -25 | dBm
    91 | -25 </= CPICH RSCP | dBm

    GPIB command: CALL:MS:REPorted[:CELL[1]]:CPICh:RSCP? and CALL:MS:REPorted:CELL2:CPICh:RSCP? .

  • Pathloss

    This is the pathloss between the cell and UE. It is calculated by comparing the UE's measurement of CPICH RSCP and the Primary CPICH Tx Power (the power level of the CPICH at the cell, as reported by the cell).
    Pathloss (dB) = Primary CPICH Tx Power (dBm) - CPICH RSCP (dBm)
    (See UE Expected Open Loop Transmit Power for more information about Primary CPICH Tx Power ).
    Range is 46 dB to 158 dB.

    GPIB commands: CALL:MS:REPorted[:CELL[1]]:PATHloss? and CALL:MS:REPorted:CELL2:PATHloss? .

  • DTCH BLER (Block Error Ratio) Report

    This is a measure of the UE's ability to receive the DTCH without errors. The reporting range for BLER is 0 to 1 (0 to 63). For the lab application, if you have enabled soft handoff (see Soft Handoff ), the DTCH BLER Report result includes both cell 1 and cell 2.

    DTCH BLER Reported Value Mapping to Measured Quantity
    DTCH BLER Reported Value Measured Quantity Value Unit
    0 BLER = 0 -
    1 -infinity < Log10(BLER) < -4.03 -
    2 -4.03 </= Log10(BLER) < -3.965 -
    ... ... ...
    61 -0.195 </= Log10(BLER) < -0.13

    62 -0.13 </= Log10(BLER) < -0.065 -
    63 -0.065 </= Log10(BLER) < -0 -

    GPIB command: CALL:MS:REPorted[:CELL[1]]:DTCH:BLER? .

    To set the BLER reporting interval (the UE's observation period for determining BLER), see How Do I Order and Retrieve UE Reported Measurement Results? or CALL:DTCHannel:BLER:REPorting:INTerval .

  • SFN-SFN Observed Time Difference (OTD)

    This measurement result is available in the lab application only. As defined in 3GPP TS 25.215 5.1.9, the UE can measure the timing difference (in chips) between cell 1 and cell 2. There are two types of SFN-SFN OTD measurements:

    • Type 1: With Type 1 OTD, the UE measures the timing difference between the P-CCPCHs of cell 1 and cell 2. This type is only available on a CELL_FACH connection (see RB Test Mode RRC State Setting ). Although you can not perform a soft handoff while on a CELL_FACH connection, you can turn cell 2 power on so that the UE can measure the timing difference between cell 1 and cell 2. While on a CELL_FACH connection, the Measurement Control Message is sent to the UE on the FACH, and the UE's measurement results are returned on the RACH.
    • Type 2: With Type 2 OTD, the UE measures the timing difference between the CPICHs of cell 1 and cell 2. This type is applicable to both CELL_DCH and CELL_FACH connections (see RB Test Mode RRC State Setting ). With either connection type, if there is power in cell 2, the UE can measure the timing difference between the two cells. While on a CELL_DCH connection, the UE can measure OTD while in soft handoff with cells 1 and 2.

    You can change the time offset between cell 1 and cell 2 using the Cell 2 Time Offset setting. Note, while Cell 2 Time Offset can be set to a negative value, the OTD measurement result gives the absolute timing difference between cell 1 and cell 2.

    GPIB commands: CALL:MS:REPorted:CELL2:OTDifference[:VALue]? and CALL:MS:REPorted:CELL2:OTDifference:TYPE? .

Compressed Mode UE Reported Measurements

In the lab application only, you can enable compressed mode operation in the test set and UE, order the UE to perform measurements on Inter-frequency Cells or GSM Cells , and then retrieve the UE's measurement results (see UE Measurements During Compressed Mode Operation ).

A single measurement report from the UE can return results for up to 8 GSM neighbor cells or 8 inter frequency neighbor cells.

See How Do I Enable Compressed Mode and Obtain UE Measurement Results? .

Inter Frequency Neighbor Cell Measurement Results

  • Total number of inter frequency cells (see CALL:MS:REPorted:ITRFrequency:CELLs? ).
  • Scrambling code for cells 1-8 (see CALL:MS:REPorted:ITRFrequency:SCODe? ).
  • DL channel for cells 1-8 (see CALL:MS:REPorted:ITRFrequency:DOWNlink:CHANnel? ).
  • RSSI for cells 1-8 (see CALL:MS:REPorted:ITRFrequency:RSSI? ). See 3GPP TS 25.133 9.1.3.3 for a mapping of returned value to actual value.
  • Ec/No for cells 1-8 (see CALL:MS:REPorted:ITRFrequency:ECNO? ). See 3GPP TS 25.133 9.1.2.3 for a mapping of returned value to actual value.
  • RSCP for cells 1-8 (see CALL:MS:REPorted:ITRFrequency:RSCP? ). See 3GPP TS 25.133 9.1.2.3 for a mapping of returned value to actual value.
  • Pathloss for cells 1-8 (see CALL:MS:REPorted:ITRFrequency:PATHloss? ).

GSM Neighbor Cell Measurement Results

  • Total number of GSM cells (see CALL:MS:REPorted:GSMSystem:CELLs? ).
  • BCH ARFCN for cells 1-8 (see CALL:MS:REPorted:GSMSystem:BCHannel? ).
  • RSSI for cells 1-8 (see CALL:MS:REPorted:GSMSystem:RSSI? ). See 3GPP TS 05.08 8.1.4 for a mapping of returned value to actual value.

Related Topics

Manual Operation: How Do I Order and Retrieve UE Reported Measurement Results?
and How Do I Enable Compressed Mode and Obtain UE Measurement Results?

GPIB Syntax: CALL:MS:REPorted

Troubleshooting UE Reported Measurements

Establishing a Connection with the UE

Cell 2 Overview

Compressed Mode

SIB11 Cell Info List


Getting Started with the W-CDMA Test and Lab Applications

Getting Started with the W-CDMA Test and Lab Applications

Last updated: December 22, 2004

This online user's guide provides detailed information about your application's features and functionality, as well as how to use these features to test your wireless device.

The Contents box provides access to all of the information contained within this online user's guide. The following is a description of these Contents topics, as well as links to getting started information for many of the topics.

  • Protocol Logging : (lab application only) Describes how to capture the exchange of data and control information between the test set and wireless device. See Getting Started with Protocol Logging .
  • Data Channel : (lab application only) Describes how to use the test set as a router while you exchange data between your wireless device and remote servers. See Getting Started with the Data Channel .
  • Measurements : Describes the measurements and instruments available within your application. Provides a list of which key conformance tests are supported by the test set. See Getting Started with Measurements .
  • Call Processing : Describes how to configure the test set's base station emulator and perform key call processing operations. See Getting Started with Call Processing .
  • Programming : Describes how to configure the test set and perform call processing operations and measurements by remote program. See Getting Started with Programming .
  • GPIB Commands : Provides details on all of the GPIB syntax available to control the test set by remote program.
  • Manual Operation : Describes how to configure the test set and perform call processing operations and measurements from the front panel. See Getting Started with Manual Operation .
  • Troubleshooting : Provides troubleshooting information for performing measurements and key call processing events. Includes a test set block diagram.
  • Configuration : Describes how to set amplitude offsets, switch between applications, and configure the test set (such as GPIB and LAN ports).
  • Fast Switching : Explains how to use fast switching test and lab applications.
  • Release Notes : Lists the features and functionality of the applications for each release of the firmware.
  • Downloadable Manuals : Provides a portable version of this online user's guide, which you may download to your computer.

For pricing and availability, brochures and datasheets for these applications, visit these product pages:

  • E1963A W-CDMA Mobile Test Application


ABORt

ABORt

Last updated: December 20, 2004

Diagram Conventions

ABORt[:ALL]

Function

Stops all measurements that are active.

If the trigger arm is set to single, the measurements will go to the idle state.

If the trigger arm is set to continuous, the measurements will re-arm and initiate again.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"ABORT:ALL"
! Aborts all active measurements in progress.

ABORt:<measurement mnemonic>

Function

Stops the selected measurement if it is active.

If the trigger arm is set to single, the measurements will go to the idle state.

If the trigger arm is set to continuous the measurements will re-arm and initiate again.

  • AFANalyzer - Audio Frequency Analyzer measurements
  • FSTability - Frequency Stability measurement
  • SAUDio - Swept Audio measurement
  • SMONitor - Spectrum Monitor measurement
  • WACLeakage - Adjacent Channel Leakage
  • WBERror - Loopback Bit Error Ratio measurement
  • WBLerror - Loopback Block Error Ratio measurement
  • WCDomain - Code Domain measurements
  • WCPower - Channel Power measurement
  • WCTFormat - Change of TFC (lab application only)
  • WDPAnalysis - Dynamic Power Analysis
  • WILPower - Inner Loop Power measurement
  • WIQTuning - IQ Tuning measurement
  • WOBWidth - Occupied Bandwidth measurement
  • WOOPower - PRACH Transmit On/Off Power measurement
  • WOOSynch - Out-of-Synch Handling of Output Power
  • WPDiscon - Phase Discontinuity
  • WPPAnalysis - PRACH Preamble Analysis (lab application only)
  • WSEMask - Spectrum Emission Mask measurement
  • WTPower - Thermal Power measurement
  • WWQuality - Waveform Quality measurement

Requirements

Test Application Revision A.01 and above.

Test Application Revision A.02 and above, added WCDomain, WSEMask, and WOBWidth.

Test Application Revision A.03 and above, added WIQTuning, WILPower, WOOPower, and SMONitor.

Test Application Revision A.05 and above added WBLerror, WDPAnalysis and WPDiscon.

Test Application Revision A.06 and above added FSTability

Lab Application Revision: A.01 and above.

Lab Application Revision B.01 and above added WBLerror, WDPAnalysis, WPDiscon, and WPPAnalysis.

Lab Application Revision C.01 and above added FSTability, WCTFormat and WOOSynch.

Programming Example

OUTPUT 714;"ABORT:WWQUALITY"
! Aborts the waveform quality measurements.


ABORt Subsystem

ABORt Subsystem

Last updated: December 20, 2004

Description

The ABORt command causes a measurement cycle in progress to stop. If the measurement is not being continuously armed (trigger arm set to single) , the measurement will remain in the idle state after this event. If the measurement is being continuously armed (trigger arm set to continuous), a new measurement cycle will begin after ABORt. If an ABORt command is issued from any measurement state other than measuring, the command is ignored.

Other Commands that Execute an ABORt Action

INITiate:<meas> will execute an ABORt:<meas> as part of the INITiate:<meas> command.

READ:<meas>? will execute an ABORt:<meas> action that aborts just one trigger sequence and then combines the INITiate and FETCh? commands.

Syntax Diagram and Command Descriptions

ABORt


AFGenerator

AFGenerator

Last updated: December 20, 2004

Diagram Conventions

AFGenerator:COUPling

Function

 Sets the output of the audio generator to be ac or dc coupled to the front-panel AUDIO OUT port.
Setting

Range: AC or DC
Query

Range: AC|DC
*RST setting DC

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:COUPling AC" !Sets the audio generator coupling to AC.

AFGenerator:FREQuency

Function

 Sets/queries the frequency of the audio generator. The units (HZ|KHZ|MHZ|GHZ) are optional. If no units are specified, then units default to HZ.
Setting

Range: 1 Hz to 20 kHz

Resolution: 0.1 HZ
Query

Range: 1 Hz to 20 kHz

Resolution: 0.1 Hz
*RST setting 1 kHz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:FREQUENCY 1000" !Sets the audio generator frequency to 1000 Hz.

AFGenerator:PULSe[:STATe]

Function

Sets/queries the audio generator pulse state.

The pulse state must be on when the test set's audio generator is used for audio stimulation during a decoded audio measurement.

When the state is on, the audio signal from the test set is pulsed at a 10 Hz rate with a 50% duty cycle.

Setting | Range: 0 | OFF | 1 |ON

Query

Range: 0|1
*RST setting | 0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:PULSE ON" !Sets the audio generator pulse to ON.

AFGenerator:VOLTage[:SAMPlitude]

Function

 Sets /queries the amplitude of the audio generator in volts and turns the state to on. The units (V|mV) are optional. If no units are specified, then units default to V.
Setting

Range: 0 to 9 V pk.

Resolution:

  • 0.5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
Query

Range: 0 to 9 V pk.

Resolution:

  • 0.5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
*RST setting 0 V

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:VOLTAGE 2.1" !Sets the state to on and the output
                                     !voltage to 2.1 volts.

AFGenerator:VOLTage:AMPlitude

Function

 Sets/queries the amplitude for the audio generator when the audio generator state is on. The units (V|mV) are optional. If no units are specified, then units default to V.
Setting

Range: 0 to 9 V pk.

Resolution:

  • 0.5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
Query

Range: 0 to 9 V pk.

Resolution:

  • 0.5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
*RST setting 0 V

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:VOLTAGE:AMPLITUDE 1.414" !Sets the audio generator output
                                                 !voltage to 1.414 volts peak.

AFGenerator:VOLTage:STATe

Function

 Sets/queries the audio generator state
Setting | 0 | OFF | 1 |ON

Query

0|1
*RST setting | 0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:VOLTAGE:STATE ON" !Set the audio generator state to ON.


AFGenerator Subsystem

AFGenerator Subsystem

Last updated: December 20, 2004

Description

The AFGenerator subsystem is used to control an audio source that can be routed to the AUDIO OUT port on the test set's front panel (see also SYSTem:AUDio:OUTPut:SOURce ).

Syntax Diagram and Command Descriptions

AFGenerator


CALCulate Subsystem

CALCulate Subsystem

Last updated: December 20, 2004

Description

The CALCulate subsystem is used to perform data processing on the measurement results. For example in the Spectrum Monitor the CALCulate subsystem uses the markers to find the peaks and read back their values.

Syntax Diagram and Command Descriptions

CALCulate:SMONitor


CALCulate:SMONitor

CALCulate:SMONitor

Last updated: December 20, 2004

Diagram Conventions

CALCulate:SMONitor:MARKer:ALL:STATe

Function

This command determines whether all markers are turned on or turned off.
Setting

Range: 1|ON|0|OFF

Query

Range: 1|ON|0|OFF
*RST Setting OFF

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:ALL:STATe 1"

!Turns on all markers.

CALCulate:SMONitor:MARKer[<n>] :AMPLitude?

Function

This query returns the amplitude for marker <n>, where <n> is a number 1 through 3. When no marker number is specified, marker 1 is used.

If you are using delta marker mode, the result is the delta marker amplitude result. (See CALCulate:SMONitor:MARKer[<n>] :MODE .)

Query

Range

  • Position Mode: -180 dBm to +37 dBm

  • Delta Mode: -200 dB to +200 dB

Resolution: 0.01 dB

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:AMPLitude?" !Returns the amplitude of marker 2.

CALCulate:SMONitor:MARKer[<n>]:FREQuency

Function

This command sets/queries the frequency of marker <n>. where <n> is a number 1 through 3. When no marker number is specified, marker 1 is used.

If you are using delta marker mode, this command sets/queries the offset frequency of the delta marker. (See CALCulate:SMONitor:MARKer[<n>] :MODE .)
Query

Range:

  • Position Mode

    Range: This is dependent on the settings of the center frequency and the frequency span. The markers frequency range is therefore equal to the center frequency +/- half the frequency span.

    Resolution: 0.001 MHz

  • Delta Mode:

    Range: The range is dependent on the center frequency, the frequency span and the position of the reference marker.

    Resolution: 0.001 MHz

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:FREQuency?"

!Queries the frequency of marker 1.

CALCulate:SMONitor:MARKer[<n>] :MODE

Function

This command sets the mode of the marker.

Position mode activates a single frequency marker at the center frequency.

Delta mode freezes the marker at its current location and uses it as a reference marker. A second marker is created at the position of the reference marker and is used a delta marker.

Setting

Range: POSition|DELTa|OFF

Query

Range: POS|DELT|OFF
*RST Setting Off

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:MODE DELT"

!Sets a reference marker and creates a delta marker.

CALCulate:SMONitor:MARKer:PEAK:EXCursion[:LEVel]

Function

This command sets the peak excursion level. A peak is identified by using the peak threshold and peak excursion value. A point is only marked as a peak if it rises and falls more than the peak excursion value from the peak threshold value. Setting this command to DEFault sets it to 6 dB.
Setting

Range: 1 to 100 dB | DEFault

Resolution: 0.1 dB

Query

Range: 1 to 100 dBResolution: 0.1 dB
*RST Setting

6 dB

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:PEAK:EXCursion 20DB"

!Sets the peak excursion level to 20 dB.

CALCulate:SMONitor:MARKer[<n>] :PEAK:MAXimum

Function

This command moves the specified marker <n> (1 to 3) to the highest peak value. If no marker <n> is specified, then marker 1 is moved.

An error message is returned if no peaks were found in the trace.

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:PEAK:MAXimum"

!Moves marker 2 to the highest peak value on the selected trace.

CALCulate:SMONitor:MARKer:PEAK:THReshold[:LEVel]

Function

This command sets peak threshold level. A peak is identified by using the peak threshold and peak excursion value. A point is only marked as a peak if it rises and falls more than the peak excursion value from the peak threshold value. Setting this command to DEFault sets it to -90 dBm.
Setting

Range: -120 to +37 dBm | DEFault

Resolution: 0.1

Query

Range: -120 to +37 dBmResolution: 0.1
*RST Setting

-90 dBm

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:PEAK:THReshold:LEVel 10DBM"

CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:POWer

Function

This command sets the base station emulator's expected power to the amplitude of the specified marker.

There are three markers <n> (1 to 3) that can be set. If no <n> is specified, marker 1 is used.

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:EXPected:POWer"

CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:FREQuency

Function

This command sets the base station emulator's expected frequency to the frequency of the specified marker.

There are three markers <n> (1 to 3) that can be set. If no <n> is specified, marker 1 is used.

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer3:EXPected:FREQuency"

CALCulate:SMONitor:MARKer[<n>]:STATe

Function

This command sets which markers are turned on.

There are three markers <n> (1 to 3) that can be set. If no <n> is specified, marker 1 is used.
Setting

Range: 1|ON|0|OFF

Query

Range: 1|ON|0|OFF
*RST Setting OFF

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:STATE 1" !Turns on marker 2.

CALCulate:SMONitor:MARKer[<n>]:TIME

Function

This command sets/queries the time at marker <n>. where <n> is a number 1 through 3. When no marker number is specified, marker 1 is used.

If you are using delta marker mode, this command sets/queries the delta offset time. (See CALCulate:SMONitor:MARKer[<n>] :MODE .)
Setting

Range: -50 ms to 10070 ms
Resolution: 0.25 us

Query

Range: -50 ms to 10070 ms
Resolution: 0.25 us
*RST Setting 5 ms

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:TIME 30" !Places marker 2 at 30 ms.


CALibration

CALibration

Last updated: December 20, 2004

Diagram Conventions

CALibration:MEASurements?

Function

Starts the measurement calibration routine. This calibration is used for all transmitter measurements except thermal power.

It is important that no power is applied to the RF IN/OUT connector during calibration.

Returns a value indicating success or failure of the measurement calibration.

Zero indicates the calibration completed successfully. See Measurement Calibration Indicator values for information about non-zero results.

Query

Range: 0 through 6, -340

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALIBRATION:MEASUREMENTS?" !Starts the measurement calibration.

CALibration:SMONitor

Function

Starts the spectrum monitor calibration routine. See Spectrum Monitor Calibration . It is important that no power is applied to the RF IN/OUT connector during calibration.

Query

Range: 0 through 10, and -340

  • 0 (Spectrum Monitor calibration completed successfully)
  • 1 (Spectrum Monitor calibration failed due to temperature drift. Wait for temperature to stabilize)
  • 2 (Spectrum Monitor calibration failed due to oven out of range)
  • 3 (Spectrum Monitor calibration failed due to loopback switch problem)
  • 4 (Spectrum Monitor calibration failed due to under range condition)
  • 5 (Spectrum Monitor calibration failed due to over range condition)
  • 6 (Spectrum Monitor calibration failed due to correlation problem)
  • 7 (Spectrum Monitor calibration failed due to source level problem)
  • 8 (Spectrum Monitor calibration failed due to IF filter coefficient problem)
  • 9 (Spectrum Monitor calibration failed due to IF frequency response problem)
  • 10 (Spectrum Monitor calibration failed due to waveform quality problem)
  • -340 (Spectrum Monitor calibration failed)

Programming Example

OUTPUT 714;"CALibration:SMONitor?" !Queries the spectrum monitor calibration.


CALibration Subsystem

CALibration Subsystem

Last updated: December 20, 2004

Calibration Strategy

Various calibration routines must be run to ensure measurement accuracy. The type of calibration and appropriate intervals for performing calibrations vary with each application. See Calibrating the Test Set for more information.

Syntax Diagram and Command Descriptions

CALibration


CALL:AICHannel

CALL:AICHannel

Last updated: December 20, 2004

Diagram Conventions

CALL:AICHannel[:SLEVel]

Function

Sets/queries the acquisition indicator channel's initial power offset. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -9.9 dB

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:AICHANNEL:SLEVEL -13DB" !Sets the acquisition indicator channel's power offset to -13 dB.

CALL:AICHannel:CCODe

Function

Sets/queries the acquisition indicator channel's channelization code.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected While in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: CODE3|CODE6|CODE7|CODE8|CODE9|CODE10|CODE11

Query

Range: CODE3|CODE6|CODE7|CODE8|CODE9|CODE10|CODE11

*RST Setting

 CODE10

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:AICHANNEL:CCODE CODE6"

CALL:AICHannel:LEVel

Function

Sets/queries the acquisition indicator channel's initial power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -9.9 dB

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:AICHANNEL:LEVEL -5"

CALL:AICHannel:STATe

Function

Sets/queries the acquisition indicator channel's state.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:AICHANNEL:STATE ON"


CALL:ATTFlag

CALL:ATTFlag

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL]:ATTFlag[:STATe]

Function

Sets/queries the state of the IMSI Attach flag on the BCCH. When IMSI Attach flag is set to on, the test set will signal the UE (mobile station) to perform location update (registration) every time it camps. When the IMSI Attach flag is set to off, the UE will only register when it determines that it has camped on a new cell. See Performing a Location Update (Registration) .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

Setting

 Range: 1|ON|0|OFF

Query

Range: 0|1

*RST Setting

 0 (OFF)
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:ATTFlag ON" !Set the IMSI Attach flag state to on.


CALL:AWGNoise

CALL:AWGNoise

Last updated: December 20, 2004

Diagram Conventions

CALL:AWGNoise[:INTernal]:POWer[:SAMPlitude][:SELected]

Function

The setting form of this command performs two functions: (1) sets the additive white gaussian noise (AWGN) level and (2) turns the AWGN on/off state to on. The query form returns the desired AWGN power level. (See Cell Power and AWGN Power for more information about desired versus current power levels.)

Setting

Range: -165 dBm/3.84 MHz to +35 dBm/3.84 MHz (this is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source).

Resolution: 0.01 dB

Query

Same as setting

*RST Setting

 See CALL:AWGNoise[:INTernal]:POWer:AMPLitude[:SELected] and CALL:AWGNoise[:INTernal]:POWer:STATe[:SELected] .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:AWGNoise:POWer -80"
! Sets the AWGN power level to -80 dBM/3.84 MHz and turns the state on.

CALL:AWGNoise[:INTernal]:POWer:AMPLitude[:SELected]

Function

Sets/queries the desired additive white gaussian noise (AWGN) level. (See Cell Power and AWGN Power for more information about desired versus current power levels.)

Setting

Range: -165 dBm/3.84 MHz to +35 dBm/3.84 MHz, NAN (this is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source).

Resolution: 0.01 dB

Query

Same as setting

*RST Setting

 -75 dBm/3.84 MHz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:AWGNoise:POWer:AMPLitude -80"
! Set the AWGN level to -80 dBM/3.84 MHz.

CALL:AWGNoise[:INTernal]:POWer:STATe[:SELected]

Function

Sets/queries the additive white gaussian noise (AWGN) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (OFF)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:AWGNoise:POWer:STATe ON"
!Turns on AWGN.


CALL:BCCHannel

CALL:BCCHannel

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL[1]]:BCCHannel:CELLlist

Function

 Sets/queries the Cell Info List setting.

Setting

Range: PRESent|ABSent

Query

Range: PRES|ABS

*RST Setting

 PRES
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:CELLlist PRESent"
! Selects BCCH Cell Info List to preset on the BCCH.

CALL[:CELL[1]]:BCCHannel:GSMSystem:BAND

Function

Sets/queries the band for each of the 8 GSM neighbor cells (see GSM Cells ).

Setting

Range: DCS1800|PCS1900,DCS1800|PCS1900,DCS1800|PCS1900,
DCS1800|PCS1900,DCS1800|PCS1900,DCS1800|PCS1900,
DCS1800|PCS1900,DCS1800|PCS1900

The command must be issued with a comma-separated list of 8 valid settings.

Query

Range: same as setting

*RST Setting

 DCS1800,DCS1800,DCS1800,DCS1800,DCS1800,DCS1800,DCS1800,DCS1800,

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:GSMSystem:BAND PCS1900,PCS1900,PCS1900,PCS1900,PCS1900,
PCS1900,PCS1900,PCS1900"
! Sets the band for each of the 8 GSM neighbor cells to PCS1900.

CALL[:CELL[1]]:BCCHannel:GSMSystem:BCC

Function

Sets/queries the BCC for each of the 8 GSM neighbor cells (see GSM Cells ).

Setting

Range: 0 to 7

Resolution: 1

The command must be issued with a comma-separated list of 8 valid settings.

Query

Range: same as setting

*RST Setting

 5,0,1,2,3,4,6,7

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:GSMSystem:BCC 4,1,3,6,0,7,2,5"
! Sets the BCC for the first GSM neighbor cell to 4,
! sets the BCC for the second GSm neighbor cell to 1, etc.

CALL[:CELL[1]]:BCCHannel:GSMSystem:BCHannel

Function

Sets/queries the BCH ARFCN for each of the 8 GSM neighbor cells (see GSM Cells ).

Setting

Range: 0 to 1023

Resolution: 1

The command must be issued with a comma-separated list of 8 valid settings.

Query

Range: same as setting

*RST Setting

 20,30,40,50,60,70,80,90

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:GSMSystem:BCHannel 22,32,42,52,62,72,82,92"
! Sets the BCH ARFCN for the first GSM neighbor cell to 22,
! sets the BCC for the second GSm neighbor cell to 32, etc.

CALL[:CELL[1]]:BCCHannel:GSMSystem:NCC

Function

Sets/queries the NCC for each of the 8 GSM neighbor cells (see GSM Cells ).

Setting

Range: 0 to 7

Resolution: 1

The command must be issued with a comma-separated list of 8 valid settings.

Query

Range: same as setting

*RST Setting

 1, 0, 2, 3, 4, 5, 6, 7

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:GSMSystem:NCC 7,1,6,3,0,4,5,2"
! Sets the NCC for the first GSM neighbor cell to 7,
! sets the NCC for the second GSm neighbor cell to 1, etc.

CALL[:CELL[1]]:BCCHannel:GSMSystem:STATe

Function

Sets/queries whether each of the 8 GSM neighbor cells is included in the cell info list (see GSM Cells ).

Setting

Range: 1|ON|0|OFF

The command must be issued with a comma-separated list of 8 valid settings.

Query

Range: 1|0

*RST Setting

 1,0,0,0,0,0,0,0

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:GSMSystem:STATe 1,1,1,1,1,1,1,1"
! Includes all 8 GSM neighbor cells in the cell info list.

CALL[:CELL[1]]:BCCHannel:INTERFREQ:DOWNlink:CHANnel

Function

THIS COMMAND IS OBSOLETE. Please use the CALL[:CELL[1]]:BCCHannel:ITRFrequency:DOWNlink:CHANnel command.

Sets/queries the downlink channel number (DL UARFCN) of the Inter-frequency cell info list which is included in the System Information Block (SIB) 11 on the BCCH. The Inter-frequency cell info list contains only one cell.

This setting is available only when the BCCH SIB 11 Cell Info List is set to "Present" (see CALL[:CELL[1]]:BCCHannel:CELLlist ).

If this setting is changed while the Operating Mode is "Active Cell.", the test set will perform the BCCH Update procedure.

Setting

Range:

  • 412 - 687
  • 4320 - 4495
  • 4600 - 4825
  • 9000 - 9425
  • 9625 - 9975
  • 10,525 - 10,875

Query

Range: Same as settings

*RST Setting

10730
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:INTERFREQ:DOWNlink:CHANnel 10735"
! Sets the BCCH Inter-frequency Cell DL UARFCN to 10735.

CALL[:CELL[1]]:BCCHannel:INTERFREQ:SCODe

Function

THIS COMMAND IS OBSOLETE. Please use the CALL[:CELL[1]]:BCCHannel:ITRFrequency:SCODe command.

Sets/queries the primary scrambling code of the Inter-frequency cell info list which is included in the System Information Block (SIB) 11 on the BCCH. The Inter-frequency cell info list contains only one cell.

This setting is available only when the BCCH SIB 11 Cell Info List is set to "Present" (see CALL[:CELL[1]]:BCCHannel:CELLlist ).

If this setting is changed while the Operating Mode is "Active Cell.", the test set will perform the BCCH Update procedure.

Setting

Range: 0 - 511

Resolution: 1

Query

Range: same as settings

*RST Setting

63

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:INTERFREQ:SCODe 63"
! Sets the BCCH Inter-frequency Cell Scrambling Code to 63.

CALL[:CELL[1]]:BCCHannel:INTRAFREQ:CELL2:SCODe

Function

THIS COMMAND IS OBSOLETE. Please use the CALL[:CELL[1]]:BCCHannel:ITAFrequency:SCODe command.

Sets/queries the primary scrambling code of the 2nd cell in the Intra-frequency cell info list which is included in the System Information Block (SIB) 11 on the BCCH. This setting is available only when the BCCH SIB 11 Cell Info List is set to "Present" (see CALL[:CELL[1]]:BCCHannel:CELLlist ).

The Intra-frequency cell info list contains three cells. As required by the W-CDMA specifications, Cell 1 in this list is always the serving cell so the cell information is automatically set to match the test set's cell.

If this setting is changed while the Operating Mode is "Active Cell.", the test set will perform the BCCH Update procedure.

Setting

Range: 0 - 511

Resolution: 1

Query

Range: same as settings

*RST Setting

127

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:INTRAFREQ:CELL2:SCODe 130"
! Sets the BCCH Intra-frequency Cell 2 Scrambling Code to 130.

CALL[:CELL[1]]:BCCHannel:INTRAFREQ:CELL3:SCODe

Function

THIS COMMAND IS OBSOLETE. Please use the CALL[:CELL[1]]:BCCHannel:ITAFrequency:SCODe command.

Sets/queries the primary scrambling code of the 3rd cell in the Intra-frequency cell info list which is included in the System Information Block (SIB) 11 on the BCCH. This setting is available only when the BCCH SIB 11 Cell Info List is set to "Present" (see CALL[:CELL[1]]:BCCHannel:CELLlist ).

The Intra-frequency cell info list contains three cells. As required by the W-CDMA specifications, Cell 1 in this list is always the serving cell so the cell information is automatically set to match the test set's cell.

If this setting is changed while the Operating Mode is "Active Cell.", the test set will perform the BCCH Update procedure.

Setting

Range: 0 - 511

Resolution: 1

Query

Range: same as settings

*RST Setting

511

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:INTRAFREQ:CELL3:SCODe 500"
! Sets the BCCH Intra-frequency Cell 3 Scrambling Code to 500.

CALL[:CELL[1]]:BCCHannel:ITAFrequency:SCODe

Function

Sets/queries the primary scrambling code for each of the 8 intra frequency neighbor cells (see Intra-frequency Cells ).

Setting

Range: 0 to 511

Resolution: 1

The command must be issued with a comma-separated list of 8 valid settings.

Query

Range: same as setting

*RST Setting

 0,127,191,255,319,383,447,511

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:ITAFrequency:SCODe 0,127,192,255,320,384,448,511"
! Sets the scrambling code for the first intra frequency neighbor
! cell to 0, sets the scrambling code for the second intra
! frequency neighbor cell to 127, etc.

CALL[:CELL[1]]:BCCHannel:ITAFrequency:STATe

Function

Sets/queries whether each of the 8 intra frequency neighbor cells is included in the cell info list (see Intra-frequency Cells ).

Setting

Range: 1|ON|0|OFF

The command must be issued with a comma-separated list of 8 valid settings.

Query

Range: 1|0

*RST Setting

 1,1,0,0,0,0,0,0

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:ITAFrequency:STATe 1,1,1,1,1,1,1,1"
! Includes all 8 intra frequency neighbor cells in the
! cell info list.

CALL[:CELL[1]]:BCCHannel:ITRFrequency:DOWNlink:CHANnel

Function

Sets/queries the UARFCN for each of the 8 inter frequency neighbor cells (see Inter-frequency Cells ).

Setting

Range:

  • 412 - 687
  • 1037 - 1062
  • 4320 - 4495
  • 4600 - 4825
  • 9000 - 9425
  • 9625 - 9975
  • 10,525 - 10,875

Resolution: 1

The command must be issued with a comma-separated list of 8 valid settings.

Query

Range: same as setting

*RST Setting

 10730,10730,10730,10730,10730,10730,10730,10730

Requirements

Test Application Revision: A.05 and above.

Test Application Revision: A.05.28 and above, added 1037 - 1062.

Lab Application Revision: B.01 and above

Lab Application Revision: B.01.29 and above, added 1037 - 1062.

Programming Example

OUTPUT 714;"CALL:BCCHannel:ITRFrequency:DOWNlink:CHANnel 10874,10874,10874,10874,
10874,10874,10874,10874"
! Sets the UARFCN for each of the 8 inter frequency neighbor
! cells to 10874.

CALL[:CELL[1]]:BCCHannel:ITRFrequency:SCODe

Function

Sets/queries the primary scrambling code for each of the 8 inter frequency neighbor cells (see Inter-frequency Cells ).

Setting

Range: 0 to 511

Resolution: 1

The command must be issued with a comma-separated list of 8 valid settings.

Query

Range: same as setting

*RST Setting

 0,127,191,255,319,383,447,511

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:ITRFrequency:SCODe 0,127,192,255,320,384,448,511"
! Sets the scrambling code for the first inter frequency neighbor
! cell to 0, sets the scrambling code for the second inter
! frequency neighbor cell to 127, etc.

CALL[:CELL[1]]:BCCHannel:ITRFrequency:STATe

Function

Sets/queries whether each of the 8 inter frequency neighbor cells is included in the cell info list (see Inter-frequency Cells ).

Setting

Range: 1|ON|0|OFF

The command must be issued with a comma-separated list of 8 valid settings.

Query

Range: 1|0

*RST Setting

 1,0,0,0,0,0,0,0

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:ITRFrequency:STATe 1,1,1,1,1,1,1,1"
! Includes all 8 inter frequency neighbor cells in the
! cell info list.

CALL[:CELL[1]]:BCCHannel:N313

Function

Sets/queries the N313 UE Out-Of-Sync Counter .

This parameter can only be set when call status is idle.

Setting

Range: S1|S2|S4|S10|S20|S50|S100|S200

Query

 Same as setting

*RST Setting

 S2

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:N313 S200"
! Sets the N313 UE Out-Of-Sync Counter to S200

CALL[:CELL[1]]:BCCHannel:N315

Function

Sets/queries the N315 UE In-Sync Counter .

This parameter can only be set when call status is idle.

Setting

Range: S1|S2|S4|S10|S20|S50|S100|S200|S400|S600|S800|S1000

Query

 Same as setting

*RST Setting

 S50

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:N315 S1"
! Sets N315 UE In-Sync Counter to S1.

CALL[:CELL[1]]:BCCHannel:T313

Function

Sets/queries the T313 UE Link Reestablishment Timer .

This parameter can only be set when call status is idle.

Setting

Range: 0 to 15 seconds

Resolution: 1 second

Query

 Same as setting

*RST Setting

 3 seconds

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:T313 15"
! Sets the T313 UE Link Reestablishment Timer to 15 seconds.

CALL[:CELL[1]]:BCCHannel:UPDAtepage

Function

Sets/queries the BCCH Update Page state (see BCCH Update Page and Broadcast Channel (BCCH) Update Procedure ).

Setting

Range: AUTO|INHibit

Query

Range: AUTO|INH

*RST Setting

 INH

Requirements

Test Application Revision: A.04 and above

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:UPDAtepage AUTO"
! Instructs the test set to send a Paging Type 1 message
! to the UE when a BCCH Update has occurred.


CALL:CCPChannel

CALL:CCPChannel

Last updated: December 20, 2004

Diagram Conventions

CALL:CCPChannel:PRIMary[:SLEVel]

Function

Sets/queries the initial power offset of the primary common control physical channel. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -5.3 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Test Application Revision A.06 changed *RST Setting to -5.3 dB.

Lab Application Revision C.01 changed *RST Setting to -5.3 dB.

Programming Example

OUTPUT 714;"CALL:CCPCHANNEL:PRIMARY:SLEVEL -15DB" !Enables and sets the initial P-CCPCH power offset to -15 dB.

CALL:CCPChannel:PRIMary:LEVel

Function

Sets/queries the primary common control physical channel's initial power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this setting.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -5.3 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.06 changed *RST Setting to -5.3 dB.

Lab Application Revision C.01 changed *RST Setting to -5.3 dB.

Programming Example

OUTPUT 714;"CALL:CCPCHANNEL:PRIMARY:LEVEL -15DB" !Sets the initial P-CCPCH power offset to -15 dB.

CALL:CCPChannel:PRIMary:STATe

Function

Sets/queries the primary common control physical channel's state.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this setting.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CCPCHANNEL:PRIMARY:STATE ON"

CALL:CCPChannel:SECondary[:SLEVel]

Function

Sets/queries the initial power offset of the secondary common control physical channel. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this setting.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting.

*RST Setting

 -10.3 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.06 changed *RST Setting to -10.3 dB.

Lab Application Revision C.01 changed *RST Setting to -10.3 dB.

Programming Example

OUTPUT 714;"CALL:CCPCHANNEL:SECONDARY:SLEVEL -10DB" !Sets P-CCPCH initial power offset to -10 dB.

CALL:CCPChannel:SECondary:CCODe

Function

Sets/queries the secondary common control physical channel's channelization code.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this setting.

Setting

Range: CODE6|CODE7|CODE9|CODE16|CODE17|CODE26|CODE57

Query

Range: CODE6|CODE7|CODE9|CODE16|CODE17|CODE26|CODE57

*RST Setting

 CODE7
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CCPCHANNEL:SECONDARY:CCODE CODE6"
! Sets the S-CCPCH channelization code to 6.

CALL:CCPChannel:SECondary:LEVel

Function

Sets/queries the secondary common control physical channel's initial power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this setting.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -10.3 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.06 changed *RST Setting to -10.3 dB.

Lab Application Revision C.01 changed *RST Setting to -10.3 dB.

Programming Example

OUTPUT 714;"CALL:CCPCHANNEL:SECONDARY:LEVEL -5" !Sets the intial common control physical channel level to -5 dB.

CALL:CCPChannel:SECondary:STATe

Function

Sets/queries the secondary common control physical channel's state.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this setting.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CCPCHANNEL:SECONDARY:STATE ON" !Enables the secondary common control physical channel.


CALL:CHANnel

CALL:CHANnel

Diagram Conventions

CALL:CHANnel

Function

Sets/queries the downlink channel number ( DL Channel ).

If CALL:UPLink:CHANnel:CONTrol:AUTO is set to on (auto) and you attempt to set DL Channel to a value that would result in an invalid uplink channel based on the current CALL:UPLink:CHANnel:SEParation setting, an error is posted. With CALL:UPLink:CHANnel:CONTrol:AUTO set to off (manual), set DL Channel and CALL:UPLink:CHANnel:SEParation to a valid combination, then set CALL:UPLink:CHANnel:CONTrol:AUTO to on.

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

If the Uplink Channel and DL Channel settings have an uplink/downlink offset of less than 30 MHz, the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range:

  • 412 - 687
  • 1037 - 1062
  • 4320 - 4495
  • 4600 - 4825
  • 9000 - 9425
  • 9625 - 9975
  • 10,525 - 10,875

Resolution: 1

Query

 Same as setting

*RST Setting

10700

Requirements

Test Application Revision: A.02 and above.

Test Application Revision: A.05.28 and above, added 1037 - 1062.

Lab Application Revision: A.01 and above

Lab Application Revision: B.01.29 and above, added 1037 - 1062.

Programming Example

OUTPUT 714;"CALL:CHANnel 4320"
! Sets the downlink channel number to 4320.


CALL:CLPControl

CALL:CLPControl

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL]:CLPControl:UPLink[:IMMediate]:DOWN

Function

Sets the uplink inner loop power control to decrease power in one step (see CALL[:CELL]:CLPControl:UPLink:STEPsize ).

This function is only used when the UL CL power control is set to use alternating bits (see CALL[:CELL]:CLPControl:UPLink:MODE ).

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:CLPCONTROL:UPLINK:IMMEDIATE:DOWN"

CALL[:CELL]:CLPControl:UPLink[:IMMediate]:UP

Function

Sets the uplink inner loop power control to increase power in one step (see CALL[:CELL]:CLPControl:UPLink:STEPsize ).

This function is only used when the UL CL power control is set to use alternating bits (see CALL[:CELL]:CLPControl:UPLink:MODE ).

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:CLPCONTROL:UPLINK:IMMEDIATE:UP"

CALL[:CELL]:CLPControl:UPLink:MODE

Function

Sets/queries the uplink closed loop power control mode while in the Active Cell operating mode. See Uplink Closed Loop Power Control Parameters and UE Target Power for more information.

Setting

Range:

  • ACTive (activates closed loop power control)
  • UDOWn (alternating bits)
  • UP (all up bits)
  • DOWN (all down bits)
  • UDOWn10 (ten up/ten down bits)

Query

Range: Same as setting range.

*RST Setting

ACTive

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:CLPControl:UPLink:MODE ACTive"
!Sets the uplink closed loop power control to active.

CALL[:CELL]:CLPControl:UPLink:ALGorithm

Function

Sets/queries the uplink power control algorithm to be used by the UE. See UL CL Power Ctrl Algorithm .

This setting can only be changed while the Cell Operating Mode is "Cell Off", or while the cell operating mode is "Active Cell" and the call status is IDLE. Attempting to change this setting while in any other mode will result in an error.

Setting

Range:

  • ALG1
  • ALG2

Query

Same as setting

*RST Setting

ALG2

Requirements

Test or Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:CELL:CLPControl:UPLink:ALGOrithm ALG1"
! Sets the uplink closed loop power control algorithm to 1.

CALL[:CELL]:CLPControl:UPLink:STEPsize

Function

Sets/queries the uplink power control step size when power control algorithm 1 is selected (see CALL[:CELL]:CLPControl:UPLink:ALGorithm ).

This setting can only be changed while the Cell Operating Mode is "Cell Off", or while the cell operating mode is "Active Cell" and the call status is IDLE. Attempting to change this setting while in any other mode will result in an error.

Setting

Range: 1 to 2 dB

Resolution: 1 dB

Query

Same as setting

*RST Setting

1 dB

Requirements

Test or Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:UPLink:STEPsize 2"
! Sets the uplink closed loop power control step size to 2 dB.


CALL:COMPressed

CALL:COMPressed

Last updated: December 20, 2004

This section is only applicable to the lab application.

Diagram Conventions

CALL:COMPressed:ENABle

Function

Enables/disables compressed mode (see Compressed Mode Operation in the Test Set ).

To query the current status of compressed mode, use the CALL:STATus:COMPressed:STATe? query.

Setting

Range: 1|ON|0|OFF

*RST Setting

 0
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:ENABle ON"
! Enables compressed mode.

CALL:COMPressed:MEASurement:GSMSystem:RSSI:RINTerval

Function

Sets/queries the GSM RSSI Measurement Reporting Interval .

Setting

Range: RIQuarter|RIHalf|RI1|RI2|RI3|RI4|RI6|RI8|RI12|RI16
|RI20|RI24|RI28|RI32|RI64

(RIQuarter = 0.25 s, RIHalf = 0.5 s, RI1 = 1 s etc.)

Query

Range: RIQ|RIH|RI1|RI2|RI3|RI4|RI6|RI8|RI12|RI16
|RI20|RI24|RI28|RI32|RI64

*RST Setting

 RI2
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:GSMSystem:RSSI:RINTerval RI4"
! Sets the GSM RSSI measurement reporting interval to 4 seconds.

CALL:COMPressed:MEASurement:GSMSystem:RSSI:RQUantity

Function

Sets/queries GSM RSSI Measurement Reporting Quantity .

Setting

Range: RQ1|RQ2|RQ4|RQ8|RQ16|RQ32|RQ64|RQINfinity

(RQ1 = 1 report, RQ2 = 2 reports, RQINfinity = infinite number of reports, etc.)

Query

Range: RQ1|RQ2|RQ4|RQ8|RQ16|RQ32|RQ64|RQIN

*RST Setting

 RQIN
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:GSMSystem:RSSI:RQUantity RQ1"
! Sets the number of reports to 1.

CALL:COMPressed:MEASurement:ITRFrequency:RINTerval

Function

Sets/queries the Interfreq Measurement Reporting Interval .

Setting

Range: RIQuarter|RIHalf|RI1|RI2|RI3|RI4|RI6|RI8|RI12|RI16
|RI20|RI24|RI28|RI32|RI64

(RIQuarter = 0.25 s, RIHalf = 0.5 s, RI1 = 1 s etc.)

Query

Range: RIQ|RIH|RI1|RI2|RI3|RI4|RI6|RI8|RI12|RI16
|RI20|RI24|RI28|RI32|RI64

*RST Setting

 RI2
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:ITRFrequency:RINTerval RI4"
! Sets the interfreq measurement reporting interval to 4 seconds.

CALL:COMPressed:MEASurement:ITRFrequency:RQUantity

Function

Sets/queries Interfreq Measurement Reporting Quantity .

Setting

Range: RQ1|RQ2|RQ4|RQ8|RQ16|RQ32|RQ64|RQINfinity

(RQ1 = 1 report, RQ2 = 2 reports, RQINfinity = infinite number of reports, etc.)

Query

Range: RQ1|RQ2|RQ4|RQ8|RQ16|RQ32|RQ64|RQIN

*RST Setting

 RQIN
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:ITRFrequency:RQUantity RQ1"
! Sets the number of reports to 1.

CALL:COMPressed:MEASurement:STATe

Function

Sets/queries UE Measurements in Compressed Mode .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:STATe ON"
! Sets the UE measurements in compressed mode state to on.

CALL:COMPressed:MEASurement:TYPe

Function

Sets/queries Compressed Mode Measurement Purpose .

Setting

Range: FDDMeas|GSMRssi

Query

 Same as setting

*RST Setting

 GSMR
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:TYPe FDDMeas"
! Sets the compressed mode measurement purpose to FDD Meas.

CALL:COMPressed:TGPSequence:DEFinition

Function

Sets/queries TGPS Definition During Call Setup .

Setting

Range: RBSetup|OFF

Query

 Same as setting

*RST Setting

 OFF
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:DEFinition RBSetup"
! Sets TGPS definition during call setup to RB Setup.

CALL:COMPressed:TGPSequence:TGLength

Function

Sets/queries Transmission Gap Length (TGL) .

Setting

Range: 1 to 14 slots

Resolution: 1 slot

Query

 Same as setting

*RST Setting

 7 slots
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:TGLength 5"
! Sets TGL to 5 slots.

CALL:COMPressed:TGPSequence:TGPLength

Function

Sets/queries Transmission Gap Pattern Length (TGPL) .

Setting

Range: 1 to 144 frames

Resolution: 1 frame

Query

 Same as setting

*RST Setting

 4 frames
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:TGPLength 6"
! Sets TGPL to 6 frames.

CALL:COMPressed:TGPSequence:TGSNumber

Function

Sets/queries Transmission Gap Starting Slot Number (TGSN) .

Setting

Range: 0 to 14 (slot 0 to slot 14)

Resolution: 1

Query

 Same as setting

*RST Setting

 11 (slot 11)
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:TGSNumber 10"
! Sets TGSN to slot 10.


CALL:CONNected

CALL:CONNected

Last updated: December 20, 2004

Diagram Conventions

CALL:CONNected[:STATe]

Function

Queries the connected/disconnected state of the call. A one is returned if the call is in the connected state. A zero is returned if the call is in the idle (disconnected) state. If the call is in any state other than connected or idle, the query will hang until the call state transitions to the connected or idle state.

When used in conjunction with the CALL:CONNected:ARM and CALL:CONNected:TIMeout commands, the CALL:CONNected:STATe? command allows the control program to synchronize to call connection/disconnection. See Connected/Idle Query and Call State Change Detector .

Query

Range: 0|1

*RST Setting

0
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:STATE?"
! returns 1 if call is connected, 0 if call is idle.

CALL:CONNected:ARM[:IMMediate]

Function

Sets (arms) the call-state-change detector. Arming this detector allows the control program to tell the test set that it is expecting a change in the state of a call, prior to initiating the state change.

Once armed, the detector remains armed until there is a call state change to Idle or Connected from one of the transitory states, nor is it disarmed by any transitions from Idle to Idle or Connected to Connected.

When used in conjunction with the CALL CONNected:STATe? and the CALL:CONNected: TIMeout commands, the CALL:CONNected:ARM command allows the control program to synchronize with call processing state changes. See Call State Change Detector .

For an explanation of the :DONE?, :OPComplete?, :SEQuential, and :WAIT commands, s ee Call Processing Event Synchronization .
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:ARM:IMMEDIATE"
! Arms the call-state-change detector.

CALL:CONNected:ARM:STATe?

Function

Queries the arm state of the call-state-change detector. This command never hangs and immediately returns a one if the detector is armed, or a zero if the detector is not armed. See Call State Change Detector

Query

Range: 1|0

*RST Setting

0
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONN:ARM:STATE?"
! Returns arm state of the call-state-change detector.

CALL:CONNected:TIMeout

Function

Sets/queries the maximum time the test set will wait for a hanging CALL:CONNected:STATe? query to complete. Default setting units are seconds. To set timeout time in units other than seconds, include an optional unit specifier in the command string.

A timeout timer is started whenever the call-state-change detector becomes armed or gets rearmed when already armed. The duration of this timeout is set using the CALL:CONNected:TIMeout command and should be greater than the maximum amount of time the control program needs to wait between arming the call-state-change detector and the connect/disconnect operation starting. Once the process starts and the call state has moved to one of the transitory states, the W-CDMA defined protocol timers take over and prevent the call state from staying in a transitory state forever. See Call Processing State Synchronization .

Setting

Range: 0 to 100 seconds
Resolution: 0.1 seconds

Query

Range: 0 to 100 seconds
Resolution: 0.1 seconds

*RST Setting

10 seconds
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:TIMEOUT 3"
! Sets the CALL:CONNected:STATe? query timeout time to 3 seconds.

OUTPUT 714;"CALL:CONNECTED:TIMEOUT 500 MS"
! Sets the Sets the CALL:CONNected:STATe? query timeout time to 500 milliseconds.

CALL:CONNected:DROP:TIMer[:STATe][:SELected]

Function

Sets/queries the call drop timer. The call drop timer indicates loss of uplink. This timer also determines when the demodulation of the uplink has been unsuccessful for a fixed period.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:DROP:TIMER:STATE 0"

CALL:CONNected:DROP:TIMer[:STATe]:WCDMa

Function

Sets/queries the call drop timer for the WCDMA format, whether or not that format is active. The call drop timer indicates loss of uplink. This timer also determines when the demodulation of the uplink has been unsuccessful for a fixed period.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:DROP:TIMER:STATE:WCDMA 0"

CALL:CONNected:CCPChannel:PRIMary[:SLEVel]

Function

Sets/queries the power offset of the primary common control physical channel to use while a call is connected. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -5.35 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:CCPCHANNEL:PRIMARY:SLEVEL -7"
! Sets P-CCPCH connected power offset.

CALL:CONNected:CCPChannel:PRIMary:LEVel

Function

Sets/queries the primary common control physical channel's power offset to use while a call is connected. This command sets the power offset level.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -5.35 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:CCPCHANNEL:PRIMARY:LEVEL -7"

CALL:CONNected:CCPChannel:PRIMary:STATe

Function

Sets/queries the primary common control physical channel's state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:CCPCHANNEL:PRIMARY:STATE ON"

CALL:CONNected:CCPChannel:SECondary[:SLEVel]

Function

Sets/queries the connected power offset of the secondary common control physical channel to use while a call is connected. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -20.00 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:CCPCHANNEL:SECONDARY:SLEVEL -10"
! Sets P-CCPCH connected power offset to -10 dB.

CALL:CONNected:CCPChannel:SECondary:LEVel

Function

Sets/queries the secondary common control physical channel's power offset to use while a call is connected. This command sets the power offset level.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -20.00 dB (off)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:CCPCHANNEL:SECONDARY:LEVEL -5"

CALL:CONNected:CCPChannel:SECondary:STATe

Function

Sets/queries the secondary common control physical channel's state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:CCPCHANNEL:SECONDARY:STATE OFF"

CALL:CONNected:CPIChannel[:SLEVel]

Function

Sets/queries the power offset of the common pilot channel to use while a call is connected. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -3.30 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:CPICHANNEL:SLEVEL -7"
! Sets CPIC connected power offset.

CALL:CONNected:CPIChannel:LEVel

Function

Sets/queries the common pilot channel's power offset to use while a call is connected. This command sets the power offset level.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -3.30 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:CPICHANNEL:LEVEL -7"

CALL:CONNected:CPIChannel:STATe

Function

Sets/queries the common pilot channel's state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (ON)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:CPICHANNEL:STATE ON"

CALL:CONNected:DPCHannel[:SLEVel]

Function

Sets/queries the power offset of the dedicated physical channel to use while a call is connected. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -3.30 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:DPCHANNEL:SLEVEL -7"
! Sets DPCH connected power offset.

CALL:CONNected:DPCHannel:LEVel

Function

Sets/queries the dedicated physical channel's power offset to use while a call is connected. This command sets the power offset level.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -3.30 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:DPCHANNEL:LEVEL -7"

CALL:CONNected:DPCHannel:STATe

Function

Sets/queries the dedicated physical channel's state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:DPCHANNEL:STATE ON"

CALL:CONNected:LIMit[:STATe][:SELected]

Function

Sets/queries the call limit state for current selected format (only WCDMA format is available now).

When the call limit state is on, the test set does not respond to PRACH preambles for paging responses from the UE. It forces the UE to repeatedly send PRACH preambles.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (OFF)
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:LIMIT:STATE 1"

CALL:CONNected:LIMit[:STATe]:WCDMa

Function

Sets/queries the call limit state for the WCDMA format, whether or not that format is active.

When the call limit state is on, the test set does not respond to PRACH preambles from the UE. This allows you to make power measurements on the PRACH preambles.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (OFF)
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:LIMIT:STATE:WCDMA 1"

CALL:CONNected:PICHannel[:SLEVel]

Function

Sets/queries the power offset of the page indicator channel to use while a call is connected. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -8.30 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:PICHANNEL:SLEVEL -7"
! Sets PICH connected power offset.

CALL:CONNected:PICHannel:LEVel

Function

Sets/queries the page indicator channel's power offset to use while a call is connected. This command sets the power offset level.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -8.30 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:PICHANNEL:LEVEL -7"

CALL:CONNected:PICHannel:STATe

Function

Sets/queries the page indicator channel's state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (ON)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:PICHANNEL:STATE OFF"


CALL:CONTrol

CALL:CONTrol

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL]:CONTrol:DOWNlink:FREQuency:AUTO

Function

Sets/queries whether the user or the base station emulator is in control of the RF generator's downlink channel frequency setting. If set to on (1), the base station emulator is in control and the frequency will automatically be set by the test set.

If set to off (0), the downlink channel frequency is directly settable. Refer to CALL:RFGenerator to set the downlink channel frequency.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

1 (auto)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:CONTROL:DOWNLINK:FREQUENCY:AUTO OFF"
!Enables manual frequency setting.


CALL:COUNt:DTMonitor

CALL:COUNt:DTMonitor

This section is only applicable to the lab application.

Last updated: December 20, 2004

Diagram Conventions

CALL:COUNt:DTMonitor:CLEar

Function

This command clears all traces from the data throughput monitor display and resets the numeric summary table values to zero.

Requirements

 Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:CLEar"

!Clears all Data Throughput Monitor results.

CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe<:STARt|:STOP>

Function

This command sets the data rate range (y-axis) for the data throughput monitor graphical display.

Setting

Start Range: 0 to 499 kbps
Stop Range: 1 to 500 kbps

Query

Start Range: 0 to 499 kbps
Stop Range: 1 to 500 kbps
*RST Setting

Start: 0 kbps
Stop: 100 kbps

Requirements

 Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALCulate:COUNt:DTMonitor:ALL DISPlay:DRATe:STOP 50"

!Sets the data throughput monitor range to stop at 50 kbps.

CALL:COUNt:DTMonitor[:ALL]:DISPlay:SPAN:TIME

Function

This command sets the time span (x-axis) for the data throughput monitor graphical display.

Setting

Range: 5 to 600 seconds

Query

Range: 5 to 600 seconds
*RST Setting 600 seconds

Requirements

 Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:ALL:DISPlay:SPAN:TIME 100"

!Sets the data throughput monitor time span to 100 seconds.

CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:DISPlay:STATe

Function

This command sets which data throughput traces are displayed.

Setting

Range: 1|ON|0|OFF
*RST Setting

OTA Tx - ON

OTA Rx - ON

IP Tx - OFF

IP RX - OFF

Requirements

 Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:IPTX:DISPlay:STATe ON
! Turns the IP TX display state ON.

CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:DRATe?

Function

Query results will be returned in a comma-separated string with values in the following order:

  • Average data throughput (bps)

  • Current data throughput (bps)

  • Peak data throughput (bps)

  • Total data transfer (bytes)

This query returns the summary table values (except for Marker) for any of the four traces:

  • OTA Tx

  • OTA Rx

  • IP Tx

  • IP Rx

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: B.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTATx:DRATe?
!Queries OTA Tx summary

OUTPUT 714;"CALL:COUNt:DTMonitor:OTARx:DRATe?
!Queries OTA Rx summary

OUTPUT 714;"CALL:COUNt:DTMonitor:IPTX:DRATe?
!Queries IP Tx summary

OUTPUT 714;"CALL:COUNt:DTMonitor:IPRX:DRATe?
!Queries IP Rx summary

CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:TRACe?

Function

This query returns 600 comma-separated trace values for spreadsheet plotting. These values represent the most recent 10 minute trace data collection period.

If the graph is frozen (see Accessing the Monitor Controls ), this command will not return values representative of the graph. If you would like to see the graph this command will return values for, resume the graph then query the trace values.

Trace values can be obtained for any of the four traces:

  • OTA Tx

  • OTA Rx

  • IP Tx

  • IP Rx

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: B.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTATx:TRACe?
! Queries OTA Tx trace data

CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory?

Function

This query returns 600 comma-separated trace values for the 10-minute trace data collection period captured prior to the most recent. To find out how many 10-minute periods have elapsed, see CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory?

Trace values can be obtained for any of the four traces:

  • OTA Tx

  • OTA Rx

  • IP Tx

  • IP Rx

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: B.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory:UNUMber?
! Queries OTA Tx trace data

CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:TRACe:HISTory:UNUMber?

Function

This query returns the number of 10-minute trace data collection periods since the last time the monitor was enabled or cleared.

Query

Range: 0 to 2,147,483,647 10-minute periods, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: B.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:TRACe:HISTory?
! Queries the number of 10-minute collection periods


CALL:CPIChannel

CALL:CPIChannel

Diagram Conventions

CALL:CPIChannel[:SLEVel]

Function

Sets/queries the common pilot channel's initial power offset. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting.

*RST Setting

 -3.3 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.06 changed *RST Setting to -3.3 dB.

Lab Application Revision C.01 changed *RST Setting to -3.3 dB.

Programming Example

OUTPUT 714;"CALL:CPICHANNEL:SLEVEL -10"

CALL:CPIChannel:LEVel

Function

Sets/queries the common pilot channel's initial power offset. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

-3.3 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.06 changed *RST Setting to -3.3 dB.

Lab Application Revision C.01 changed *RST Setting to -3.3 dB.

Programming Example

OUTPUT 714;"CALL:CPICHANNEL:LEVEL -5"

CALL:CPIChannel:STATe

Function

Sets/queries the common pilot channel's state.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CPICHANNEL:STATE ON"


CALL:CPNumber

CALL:CPNumber

Last updated: December 20, 2004

Diagram Conventions

CALL:CPNumber<[:SELected]>

Function

Sets/queries the ASCII representation of the calling party number.

The value is included in the SETUP message to the called mobile station when INCLude is selected by CALL:CPNumber:INCLusion .

It is displayed on the called mobile station's screen when "ALLowed" is selected by CALL:CPNumber:PRESentation[:INDicator] .

Setting

Range: 0 to 20 characters enclosed by quotes, each character from the set of 0123456789abc*#

Query

Range: 0 to 20 characters enclosed by quotes, each character from the set of 0123456789abc*#

*RST Setting

"5099214001"

Requirements

 Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber '#0123456789*'"
!Sets the calling party number to #0123456789*.

CALL:CPNumber:INCLusion

Function

Sets/queries whether to include the calling party number information record.

The value is not included in the message to the called mobile station. When "INCLude" is selected, the calling party number parameters configured by CALL:CPNumber<[:SELected]> , CALL:CPNumber:PLAN , CALL:CPNumber:PRESentation[:INDicator] , CALL:CPNumber:SCReening[:INDicator] and CALL:CPNumber:TYPE is sent to the mobile station.

Setting

Range: INCLude|EXCLude

Query

Range: INCL|EXCL

*RST Setting

EXCL

Requirements

 Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber:INCLusion INCLude"
!Set to include the calling party number to the called mobile station.

CALL:CPNumber:PLAN

Function

Sets/queries the numbering plan used for the calling party number. See Parameter Descriptions for details.

The value is included in the SETUP message to the called mobile station when INCLude is selected by CALL:CPNumber:INCLusion .

Setting

Range: UNKNown|ISDN|NATional|PRIVate|TELex|DATA

Query

Range: UNKN|ISDN|NAT|PRIV|TEL|DATA

*RST Setting

UNKN

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber:PLAN PRIVate"
!Set the numbering plan for calling party number to private.

CALL:CPNumber:PRESentation[:INDicator]

Function

Sets/queries the presentation indicator (PI) used for the calling party number. See Parameter Descriptions for details.

The value is included in the SETUP message to the called mobile station when INCLude is selected by CALL:CPNumber:INCLusion .

Setting

Range: ALLowed|RESTricted|NNAVailable

Query

Range: ALL|REST|NNAV

*RST Setting

ALL

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber:PRESentation RESTricted"
!Set the presentation indicator of Calling Party Number to restricted.

CALL:CPNumber:SCReening[:INDicator]

Function

Sets/queries the screening indicator (SI) for the calling party number. See Parameter Descriptions for details.

The value is included in the SETUP message to the called mobile station when INCLude is selected by CALL:CPNumber:INCLusion .

Setting

Range: UNSCreened|UVPassed|UVFailed|NETWork

Query

Range: UNSC|UVP|UVF|NETW

*RST Setting

UNSC

Requirements

 Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber:SCReening NETWork"
!Set the screening indicator of calling party number to network.

CALL:CPNumber:TYPE

Function

Sets/queries the number type of the calling party number. See Parameter Descriptions for details.

The value is included in the SETUP message to the called mobile station when INCLude is selected by CALL:CPNumber:INCLusion .

Setting

Range: UNKNown|INATional|NATional|NETWork|DEDicated

Query

Range: UNKN|INAT|NAT|NETW|DED

*RST Setting

UNKN

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber:TYPE NATional"
!Set the number type of calling party number to national.


CALL:CVALue

CALL:CVALue

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL[1]]:CVALue

Function

Sets/queries the BCCH Constant Value which are used by the UE to determine the initial transmit power of the first PRACH preamble. See Initial PRACH Tx Power .

Changing this setting while in active cell operating mode and the Call Status is other than IDLE will result in the execution of the BCCH Update procedure (see Cell Parameters ).

Setting

Range: -35 dB to -10 dB

Resolution: 1 dB

Query

Range: -35 dB to -10 dB

Resolution: 1 dB

*RST Setting

 -10 dB
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CVALue -20" !Sets the constant value to -20 dB.


CALL Subsystem

CALL Subsystem

Last updated: December 20, 2004

Description

The CALL subsystem handles all setup, control, and query functions for call processing. This includes UE and Base Station (cell) functions.

Syntax Diagrams and Command Descriptions

CALL:AICHannel | CALL:MCCode
CALL:ATTFlag | CALL:MNCode
CALL:AWGNoise | CALL:MS:IP:ADDRess (Lab App only)
CALL:BCCHannel | CALL:MS:LOOPback
CALL:CCPChannel | CALL:MS:POWer
CALL:CELL2:CCPChannel (Lab App only) | CALL:MS:REPorted
CALL:CELL2:CLPControl (Lab App only) | CALL:OCNSource
CALL:CELL2:CPIChannel (Lab App only) | CALL:OPERating
CALL:CELL2:DPCHannel (Lab App only) | CALL:ORIGinate
CALL:CELL2:OCNSource (Lab App only) | CALL:PAGing
CALL:CELL2:POWer (Lab App only) | CALL:PCTPower
CALL:CELL2:SCODe (Lab App only) | CALL:PICHannel
CALL:CELL2:TOFFset (Lab App only) | CALL:PLOGging (Lab App only)
CALL:CHANnel | CALL:POWer
CALL:CLPControl | CALL:PSDomain
CALL:COMPressed (Lab App only) | CALL:RACode (Lab App only)
CALL:CONNected | CALL:RFGenerator
CALL:CONTrol | CALL:RLC
CALL:COUNt (Lab App only) | CALL:SCODe
CALL:COUNt:DTMonitor (Lab App only) | CALL:SECurity
CALL:CPIChannel | CALL:SERVice
CALL:CPNumber | CALL:SETup
CALL:CVALue | CALL:SHANdoff (Lab App only)
CALL:DATA:PING (Lab App only) | CALL:SMService (Lab App only)
CALL:DPCHannel | CALL:SRBearer
CALL:DRX | CALL:STATus
CALL:DTCHannel | CALL:SYSTem
CALL:END | CALL:TOTal:POWer
CALL:FDDTest | CALL:TRIGger
CALL:HANDoff | CALL:UINTerferenc
CALL:IDENtity | CALL:UPLink
CALL:LACode | CALL:WAVeform


CALL:DPCHannel

CALL:DPCHannel

Last updated: December 20, 2004

Diagram Conventions

CALL:DPCHannel[:SLEVel]

Function

Sets/queries the dedicated physical channel's (DPCH) initial downlink offset, and sets its state to ON.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -30.00 dB to 0 dB (Prior to A.03, the range is -20.00 dB to 0 dB)

Resolution: 0.01
Query

Range: -30.00 dB to 0 dB (Prior to A.03, the range is -20.00 dB to 0 dB)

Resolution: 0.01

*RST Setting

 -12.00 dB (off)

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:SLEVEL -12"

CALL:DPCHannel:LEVel

Function

Sets/queries the dedicated physical channel's (DPCH) initial downlink offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -30.00 dB to 0 dB (Prior to A.03, the range is -20.00 dB to 0 dB)

Resolution: 0.01
Query

Range: -30.00 dB to 0 dB (Prior to A.03, the range is -20.00 dB to 0 dB)

Resolution: 0.01

*RST Setting

 -12.00 dB

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:LEVEL -12"

CALL:DPCHannel:STATe

Function

Sets/queries the dedicated physical control channel's state.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 1|ON | 0|OFF

Query

Range: 1|ON | 0|OFF

*RST Setting

 0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:STAT 1"

CALL:DPCHannel:TYPe

Function

THIS COMMAND IS OBSOLETE. Please use the CALL:SERVice:RBTest:RAB command to set/query channel type.

Sets/queries the dedicated physical control channel's channel type. See Channel Type .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range:

  • RMC12
  • RMC64
  • RMC384

Query

 Same as setting.

*RST Setting

 RMC12

Requirements

Test Application Revision: A.01 and above

Test Application Revision A.02 added RMC64

Test Application Revision A.04 added RMC384

Lab Application Revision: A.01 and above.

Lab Application Revision A.02 added RMC384

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:TYPE RMC12"
! Selects the 12.2 RMC for the DPCH.

CALL:DPCHannel:RMC12:CCODe

Function

Sets/queries the dedicated physical control channel's channelization code for the 12.2 kbps reference measurement channel, the 12.2k AMR Voice channel, 33k No Coding RMC and 13.6k DCCH (SRB). See Setting Downlink Channel Codes .

The type of bearer service being carried by the WCDMA link drives the configuration of the DTCH and DCCH logical channels, the DCH Transport channel, and the DPCH physical channel. The test set supports only symmetrical channels, and only one type of bearer service at a time.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: CODE6|CODE9|CODE10|CODE20|CODE29|CODE37|CODE45
|CODE54|CODE60|CODE63|CODE70|CODE76|CODE87|CODE93
|CODE112|CODE118

Query

Range: CODE6|CODE9|CODE10|CODE20|CODE29|CODE37|CODE45
|CODE54|CODE60|CODE63|CODE70|CODE76|CODE87|CODE93
|CODE112|CODE118

*RST Setting

 CODE9

Requirements

Test Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:RMC12:CCODE CODE3"
! Sets the 12.2 RMC's channelization code.

CALL:DPCHannel:RMC64:CCODe

Function

Sets/queries the dedicated physical control channel's 64 kbps reference measurement channel's channelization code.

The type of bearer service being carried by the WCDMA link drives the configuration of the DTCH and DCCH logical channels, the DCH Transport channel, and the DPCH physical channel. The test set supports only symmetrical channels, and only one type of bearer service at a time.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: CODE6|CODE10|CODE12|CODE14|CODE16|CODE18
|CODE20|CODE22|CODE24|CODE25|CODE26|CODE27

Query

 Same as setting

*RST Setting

 CODE6

Requirements

Test Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:RMC64:CCODE CODE10"
! Sets the 64 RMC's channelization code.

CALL:DPCHannel:RMC144:CCODe

Function

Sets/queries the DPCH 144k RMC Channelization Code (see Setting Downlink Channel Codes ).

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: CODE12|CODE13

Query

 Same as setting

*RST Setting

 CODE12

Requirements

Test Application Revision: A.05 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:RMC144:CCODE CODE13"
! Sets the 144k RMC's channelization code to 13.

CALL:DPCHannel:RMC384:CCODe

Function

Sets/queries the dedicated physical control channel's 384 kbps reference measurement channel's channelization code.

The type of bearer service being carried by the WCDMA link drives the configuration of the DTCH and DCCH logical channels, the DCH Transport channel, and the DPCH physical channel. The test set supports only symmetrical channels, and only one type of bearer service at a time.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: CODE6

Query

 Same as setting

*RST Setting

 CODE6

Requirements

Test Application Revision: A.04 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:RMC384:CCODE CODE6"
! Sets the 384k RMC's channelization code.

CALL:DPCHannel:KSPS15[:CCODe]

Function

Sets/queries the channelization code for the downlink DPCH with a physical data rate of 15 ksps.

See Setting Downlink Channel Codes .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: CODE12|CODE13|CODE20|CODE21|CODE40|CODE43|CODE58
|CODE126|CODE127|CODE142|CODE153|CODE174|CODE235|CODE255

Query

 Same as setting

*RST Setting

 CODE12

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:KSPS15:CCODE CODE13"

CALL:DPCHannel:KSPS30[:CCODe]

Function

Sets/queries the channelization code for the downlink DPCH with a physical data rate of 30 ksps.

See Setting Downlink Channel Codes .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: CODE6|CODE9|CODE10|CODE20|CODE29|CODE37|CODE45
|CODE54|CODE60|CODE63|CODE70|CODE76|CODE87|CODE93
|CODE112|CODE118

Query

 Same as setting

*RST Setting

 CODE9

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:KSPS30:CCODE CODE10"

CALL:DPCHannel:KSPS120[:CCODe]

Function

Sets/queries the channelization code for the downlink DPCH with a physical data rate of 120 ksps.

See Setting Downlink Channel Codes .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: CODE6|CODE10|CODE12|CODE14|CODE16|CODE18
|CODE20|CODE22|CODE24|CODE25|CODE26|CODE27

Query

 Same as setting

*RST Setting

 CODE6

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:KSPS120:CCODE CODE10"

CALL:DPCHannel:KSPS240[:CCODe]

Function

Sets/queries the DPCH 240 ksps Channelization Code (see Setting Downlink Channel Codes ).

Setting

Range: CODE12|CODE13

Query

 Same as setting

*RST Setting

 CODE12

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:KSPS240:CCODE CODE13"
! Sets the 240 ksps channelization code to 13.

CALL:DPCHannel:KSPS480[:CCODe]

Function

Sets/queries the channelization code for the downlink DPCH with a physical data rate of 480 ksps.

See Setting Downlink Channel Codes .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: CODE6

Query

 Same as setting

*RST Setting

 CODE6

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:KSPS480:CCODE CODE6"


CALL:DRX

CALL:DRX

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL]:DRX:CLENgth

Function

Sets/queries the DRX Cycle Length (CN Domain) .

This parameter can only be set when call status is Idle .

Setting

Range: FRAMes64|FRAMes128|FRAMes256|FRAMes512

Query

Range: FRAM64|FRAM128|FRAM256|FRAM512

*RST Setting

FRAM64

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DRX:CLENgth FRAMes512"
! Sets the DRX Cycle Length to 512 frames.


CALL:DTCHannel

CALL:DTCHannel

Last updated: December 20, 2004

Diagram Conventions

CALL:DTCHannel:DATA

Function

Sets/queries the downlink dedicated traffic channel's data type. See DL DTCH Data .

Setting

Range: INCRement|ONES|PRBS9|PRBS15|ZERos

Query

Range: INCR|ONES|PRBS9|PRBS15|ZER

*RST Setting

 PRBS15

Requirements

Test Application Revision: A.01 and above

Test Application Revision A.04 added INCrement

Lab Application Revision: A.01 and above

Lab Application Revision A.02 added INCrement

Programming Example

OUTPUT 714;"CALL:DTCHANNEL:DATA ZER"
! Sets the DTCH data pattern to continuous zeroes.

CALL:DTCHannel:BLER:REPorting:INTerval

Function

Sets/queries the observation period for UE reported DTCH BLER measurements (see DTCH BLER (Block Error Ratio) Report for details).

It is in the unit of millisecond. This setting is only useful after a Measurement Request (see CALL:MS:REPorted:MEASurement:REQuest ).

Setting

Range: (INT250 = 250 ms)
INT250|INT500|INT1000|INT2000|INT3000|INT4000|INT6000|INT8000
|INT12000|INT16000|INT20000|INT24000|INT28000|INT32000|INT64000

Query

Range: same as setting

*RST Setting

 INT250

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:DTCHannel:BLER:REPorting:INTerval INT1000"
! Sets the DTCH BLER observation period to 1000 miliseconds.


CALL:END

CALL:END

Last updated: December 20, 2004

Diagram Conventions

CALL:END

Function

Disconnects any calls or connections in progress. Aborts any outstanding registrations or base station pages in progress as well as mobile station originations.
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:END"


CALL:FDDTest

CALL:FDDTest

Last updated: December 20, 2004

Diagram Conventions

CALL:FDDTest:CCPChannel:PRIMary[:SLEVel]

Function

Sets/queries the test mode power offset of the primary common control physical channel during FDD test mode operation. This command sets the power offset level and turns on the power offset.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTEST:CCPCHANNEL:PRIMARY:SLEVEL" !Sets P-CCPCH test mode power offset.

CALL:FDDTest:CCPChannel:PRIMary:LEVel

Function

Sets/queries the primary common control physical channel's test mode power offset during FDD test mode operation. This command sets the power offset level and turns on the power offset.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTEST:CCPCHANNEL:PRIMARY:LEVEL -5"

CALL:FDDTest:CCPChannel:PRIMary:STATe

Function

Sets/queries the primary common control physical channel's state during FDD test mode operation.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTEST:CCPCHANNEL:PRIMARY:STATE ON"

CALL:FDDTest:CLPControl:UPLink:MODE

Function

Sets/queries the uplink inner loop power control mode during FDD test mode operation.

When UP is selected, the test set sends all 0 (up) power control bits.

When DOWN is selected, the test set sends all 1 (down) power control bits.

When UDOWn is selected, the test set sends alternating up/down power control bits.

When UDOWn10 is selected, the test set sends alternating 10 up/down power control bits.

Setting

Range: UP|DOWN|UDOWn|UDOWn10

Query

Range:UP|DOWN|UDOW|UDOW10

*RST Setting

 UDOW

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:CLPCONTROL:REVERSE:MODE UDOWN"
!Sets the closed loop power control mode to alternating up, down bits.

CALL:FDDTest:COMPressed:DACTivation:TYPe

Function

Sets/queries Deactivation Type .

Setting

Range:

  • IMM (Immediate)
  • CFN (Specific CFN)

Query

 Same as setting.

*RST Setting

 IMM

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:COMPressed:DACTivation:TYPe CFN"

! Sets deactivation type to CFN.

CALL:FDDTest:COMPressed:ECFNumber

Function

Sets/queries Ending CFN .

Setting

Range: 0 to 255

Resolution: 1

Query

 Same as setting.

*RST Setting

 0

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:COMPressed:ECFNumber 16"

CALL:FDDTest:COMPressed:SCFNumber

Function

Sets/queries Starting CFN .

Setting

Range: 0 to 255

Resolution: 1

Query

 Same as setting.

*RST Setting

 0

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:COMPressed:SCFNumber 4"

CALL:FDDTest:CPIChannel[:SLEVel]

Function

Sets/queries the test mode power offset of the common pilot channel during FDD test mode operation. This command sets the power offset level and turns on the power offset.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -3.3 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTEST:CPICHANNEL:SLEVEL -10"

CALL:FDDTest:CPIChannel:LEVel

Function

Sets/queries the common pilot channel's test mode power offset during FDD test mode operation. This command sets the power offset level and turns on the power offset.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -3.3 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTEST:CPICHANNEL:LEVEL -5"

CALL:FDDTest:CPIChannel:STATe

Function

Sets/queries the common pilot channel's state during FDD test mode operation.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTEST:CPICHANNEL:STATE OFF"

CALL:FDDTest:DPCHannel[:SLEVel]

Function

Sets/queries the test mode power offset of the dedicated physical channel during FDD test mode operation. This command sets the power offset level and turns on the power offset.

Setting

Range: -30.00 dB to 0 dB (Prior to A.03, the range is -20.00 dB to 0 dB)

Resolution: 0.01

Query

Range: -30.00 dB to 0 dB (Prior to A.03, the range is -20.00 dB to 0 dB)

Resolution: 0.01

*RST Setting

 -10.3 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTEST:DPCHANNEL:SLEVEL -7"

CALL:FDDTest:DPCHannel:LEVel

Function

Sets/queries the dedicated physical channel's test mode power offset during FDD test mode operation. This command sets the power offset level and turns on the power offset.

Setting

Range: -30.00 dB to 0 dB (Prior to A.03, the range is -20.00 dB to 0 dB)

Resolution: 0.01

Query

Range: -30.00 to 0 dB (Prior to A.03, the range is -20.00 dB to 0 dB)

Resolution: 0.01

*RST Setting

 -10.3 dB

Requirements

Test or Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"CALL:FDDTEST:DPCHANNEL:LEVEL -7"

CALL:FDDTest:DPCHannel:STATe

Function

Sets/queries the dedicated physical channel's state during FDD test mode operation.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTEST:DPCHANNEL:STATE OFF"

CALL:FDDTest:PICHannel[:SLEVel]

Function

Sets/queries the test mode power offset of the page indicator channel during FDD test mode operation. This command sets the power offset level and turns on the power offset.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -8.3 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTEST:CPICHANNEL:SLEVEL -10"

CALL:FDDTest:PICHannel:LEVel

Function

Sets/queries the page indicator channel's test mode power offset during FDD test mode operation. This command sets the power offset level and turns on the power offset.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -8.3 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTEST:CPICHANNEL:LEVEL -5"

CALL:FDDTest:PICHannel:STATe

Function

Sets/queries the page indicator channel's state during FDD test mode operation.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTEST:CPICHANNEL:STATE OFF"

CALL:FDDTest:PICHannel:DATA

Function

Sets/queries the page indicator channel's data pattern. The pattern can be set to either all ones or all zeros.

Setting

Range: ALLZERO|ALLONE

Query

Range: ALLZERO|ALLONE

*RST Setting

 All Zeros

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:PICHannel:DATA ALLONE"
! Sets the paging indicator channel data to all ones.

CALL:FDDTest:TFCIndicator

Function

Sets/queries the transport format combination indicator (TFCI) during FDD test mode operation.

Setting

Range: 000 to 3FF

(0 to 3 characters from the set 0123456789aAbBcCdDeEfF, up to 3FF)

Query

Range: "000" to "3FF"

(The return string is always 3 characters from the set 0123456789ABCDEF, up to 3FF)

*RST Setting

 "000"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTEST:TFCINDICATOR '2DE'"


CALL:HANDoff

CALL:HANDoff

Last updated: December 20, 2004

Diagram Conventions

CALL:HANDoff[:IMMediate]

Function

THIS COMMAND IS OBSOLETE. Please use the CALL:HANDoff:PCReconfig[:IMMediate] and CALL:HANDoff:SYSTem:GSM[:IMMediate] commands to perform physical channel reconfigurations and system handoffs.

Initiates a handoff while on a call (and in Active Cell mode). Any measurements that have been initiated are aborted when a handoff is initiated. See Handoffs (Handover) .

A handoff can initiate a change of downlink UARFCN ( CALL:SETup:CHANnel<[:SELected]|:FDD>:DOWNlink ), a change of uplink UARFCN ( CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink[:MCHannel] ), or a change from W-CDMA system to GSM system ( CALL:SETup[:HANDoff]:SYSTem[:TYPE] ) while maintaining the connection.

The W-CDMA to GSM handoff is only available when both the E1963A and E1968A test applications (TAs) are present in the test set and licensed for operation.
Requirements

Test Application Revision: A.03 and above: add handoff from W-CDMA to GSM.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:HANDoff"

CALL:HANDoff:PCReconfig[:IMMediate]

Function

 Performs a Physical Channel Reconfiguration . You must be on a call to perform a physical channel reconfiguration.
Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:HANDoff:PCReconfig"

CALL:HANDoff:SYSTem:GSM[:IMMediate]

Function

 Performs a System Handoff . You must be on a Radio Bearer Test Mode or AMR Voice call to perform a system handoff.
Requirements

GSM/GPRS_W-CDMA Fast Switching Test Application Revision: B.04 and above.

GSM/GPRS_W-CDMA Fast Switching Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:HANDoff:SYSTem:GSM"

CALL:HANDoff:TCReconfig[:IMMediate]

Function

 Performs a Transport Channel Reconfiguration . You must be on a RB test mode call to perform a transport channel reconfiguration (see Paging Service ).
Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:HANDoff:TCReconfig"


CALL:IDENtity

CALL:IDENtity

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL]:IDENtity

Function

Sets/queries Cell Identity .

Setting

Range: 0 to 268435455

Resolution: 1

Query

 Same as setting

*RST Setting

 1

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:IDENtity 3"
! Sets Cell Identity to 3 (0000 0000 0000 0000 0000 0000 0011).


CALL:LACode

CALL:LACode

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL]:LACode[:SELected]

Function

Sets/queries the local area code (LAC), for the currently selected test application.

If this setting is changed while the Operating Mode is "Active Cell.", the test set will perform the BCCH Update procedure.

Setting

Range: 0 to 65535

Query

Range: 0 to 65535

*RST Setting

 1
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL:LACODE 310" !Sets the local area code to 310.

CALL[:CELL]:LACode:WCDMa

Function

Sets/queries the local area code (LAC), when using the W-CDMA test application.
This setting cannot be changed while the Operating Mode is set to "Active Cell." This setting can only be changed when the Operating Mode is set to Cell Off.

Setting

WCDMa Range: 0 to 65535

Query

Range: 0 to 65535

*RST Setting

 1
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL:LACODE:WCDMA 310" !Sets the WCDMA local area code to 310.


CALL:MCCode

CALL:MCCode

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL]:MCCode[:SELected]

Function

Sets/queries the mobile country code (MCC) for the currently selected test application.

If this setting is changed while the Operating Mode is "Active Cell.", the test set will perform the BCCH Update procedure.

Setting

Range: 0 to 999

Query

Range: 0 to 999

*RST Setting

 1
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL:MCCODE 310" !Sets the mobile country code to 310.

CALL[:CELL]:MCCode:WCDMa

Function

Sets/queries the mobile country code (MCC) when using the W-CDMA test application.

If this setting is changed while the Operating Mode is "Active Cell.", the test set will perform the BCCH Update procedure.

Setting

Range: 0 to 999

Query

Range: 0 to 999

*RST Setting

 1
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL:MCCODE:WCDMa 310" !Sets the W-CDMA mobile country code to 310.


CALL:MNCode

CALL:MNCode

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL]:MNCode

Function

Sets/queries the mobile network code (MNC) for the currently selected test application.

If this setting is changed while the Operating Mode is "Active Cell.", the test set will perform the BCCH Update procedure.

Setting

Range: 0 to 99

Query

Range: 0 to 99

*RST Setting

 1
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL:MNCODE 10" !Sets the current MNC setting to 10.

CALL[:CELL]:MNCode:WCDMa

Function

Sets/queries the mobile network code (MNC), when using the W-CDMA test application.

This setting cannot be changed while Operating Mode is set to "Active Cell." This setting can only be changed when the Operating Mode is set to Cell Off (CALL:OPERating:MODE OFF).

Setting

Range: 0 to 99

Query

Range: 0 to 99

*RST Setting

 1
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL:MNCODE:WCDMA 10" !Sets the WCDMA mobile network code to 10.


CALL:MS:LOOPback

CALL:MS:LOOPback

Last updated: December 20, 2004

Diagram Conventions

CALL:MS:LOOPback:TYPE

Function

Sets/queries the UE Loopback Type .

Setting

Range: TYPE1|TYPE2

Query

 Same as setting.

*RST Setting

 TYPE1

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:MS:LOOPback:TYPE TYPE2"
! Sets the MS Loopback Type to Type 2.


CALL:MS:POWer

CALL:MS:POWer

Last updated: December 20, 2004

Diagram Conventions

CALL:MS:POWer:TARGet[: AMPLitude]?

Function

Sets/queries the expected power level from the UE (mobile station). See UE Target Power .

Query

Range: -50 dBm to +24 dBm

Resolution: 1 dB

*RST Setting

-5 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:MS:POWER:TARGET:AMPLITUDE -20"


CALL:MS:REPorted

CALL:MS:REPorted

Last updated: December 20, 2004

Diagram Conventions

CALL:MS:REPorted:AUTHenticate:FAILcause?

Function

Queries the UE (mobile station) reported authentication fail cause. See Security Setup for more description on the fail causes.

Query

Range: 1 to 255, 9.91E +37

*RST Setting

9.91E +37
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:AUTHenticate:FAILcause?"
!Queries the authentication fail cause.

CALL:MS:REPorted[:CELL[1]]:ALL?

Function

Queries the UE (mobile station) reported measurement results after a successful Measurement Request (see CALL:MS:REPorted:MEASurement:REQuest ). The measurement results returned include CPICH Ec/No, Pathloss and CPICH RSCP (see UE Reported Measurements for more descriptions).

After a successful Measurement Request, three comma separated results are returned in the order of CPICH Ec/No, Pathloss, and CPICH RSCP. See CALL:MS:REPorted[:CELL[1]]:CPICh:ECNO? , CALL:MS:REPorted[:CELL[1]]:PATHloss? , and CALL:MS:REPorted[:CELL[1]]:CPICh:RSCP? for more information.

To obtain DTCH BLER results, see CALL:MS:REPorted[:CELL[1]]:DTCH:BLER? .

Query

CPICH Ec/No:

  • Range: 0 to 49, 9.91E +37

Pathloss:

  • Range: 46 to 158 dB, 9.91E +37
  • Resolution: 1 dB

CPICH RSCP:

  • Range: 0 to 91, 9.91E +37

*RST Setting

 9.91E +37
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:ALL?"

CALL:MS:REPorted[:CELL[1]]:CPICh:ECNO?

Function

Queries the UE (mobile station) reported CPICH Ec/No measurement result which is an index to a range of Ec/No values. See CPICH Ec/No for the mapping of this report value to actual Ec/No range.

Query

Range: 0 to 49, or 9.91 E+37

*RST Setting

 9.91E +37
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:CPICh:ECNO?"

CALL:MS:REPorted[:CELL[1]]:CPICh:RSCP?

Function

Queries the UE (mobile station) reported CPICH RSCP measurement result which is an index to a range of RSCP values. See CPICH RSCP (Received Signal Code Power) for the mapping of this report value to actual RSCP range.

Query

Range: 0 to 91, or 9.91 E+37

*RST Setting

 9.91E +37
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:CPICh:RSCP?"

CALL:MS:REPorted[:CELL[1]]:PATHloss?

Function

Queries the UE (mobile station) reported Pathloss measurement result in the unit of dB. See Pathloss for more details.

Query

Range: 46 to 158 dB, or 9.91 E+37

Resolution: 1 dB

*RST Setting

 9.91E +37
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:PATHloss?"

CALL:MS:REPorted[:CELL[1]]:DTCH:BLER?

Function

Queries the UE (mobile station) reported DTCH BLER measurement result which is an index to a range of BLER values. See DTCH BLER (Block Error Ratio) Report for the mapping of this report value to actual BLER range.

Query

Range: 0 to 63, or 9.91 E+37

*RST Setting

 9.91E +37
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:DTCH:BLER?"

CALL:MS:REPorted:CELL2:ALL?

Function

Queries the cell 2 UE (mobile station) reported measurement results after a successful Measurement Request (see CALL:MS:REPorted:MEASurement:REQuest ). The supported measurements include CPICH Ec/No, Pathloss and CPICH RSCP (see Cell 1/Cell 2 UE Reported Measurements for more information).

After a successful Measurement Request, three comma separated results are returned in the order of CPICH Ec/No, Pathloss, and CPICH RSCP. See CALL:MS:REPorted[:CELL[1]]:CPICh:ECNO? , CALL:MS:REPorted[:CELL[1]]:PATHloss? , and CALL:MS:REPorted[:CELL[1]]:CPICh:RSCP? for more information.

To obtain DTCH BLER results, see CALL:MS:REPorted[:CELL[1]]:DTCH:BLER? .

Query

CPICH Ec/No:

  • Range: 0 to 49, 9.91E +37

Pathloss:

  • Range: 46 to 158 dB, 9.91E +37
  • Resolution: 1 dB

CPICH RSCP:

  • Range: 0 to 91, 9.91E +37

*RST Setting

 9.91E +37
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:CELL2:ALL?"

CALL:MS:REPorted:CELL2:CPICh:ECNO?

Function

Queries the cell 2 UE (mobile station) reported CPICH Ec/No measurement result which is an index to a range of Ec/No values. See CPICH Ec/No for the mapping of this report value to actual Ec/No range.

Query

Range: 0 to 49, 9.91E +37

*RST Setting

 9.91E +37
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:CELL2:CPICh:ECNO?"

CALL:MS:REPorted:CELL2:CPICh:RSCP?

Function

Queries the cell 2 UE (mobile station) reported CPICH RSCP measurement result which is an index to a range of RSCP values. See CPICH RSCP (Received Signal Code Power) for the mapping of this report value to actual RSCP range.

Query

Range: 0 to 91, 9.91E +37

*RST Setting

 9.91E +37
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:CELL2:CPICh:RSCP?"

CALL:MS:REPorted:CELL2:OTDifference[:VALue]?

Function

Queries the UE reported SFN-SFN Observed Time Difference (OTD) measurement result. The type of OTD measurement performed by the UE can be queried using the CALL:MS:REPorted:CELL2:OTDifference:TYPE? command.

Query

Range: 0 to 9830399 chips, 9.91E +37

Resolution: 1 chip

*RST Setting

 9.91E +37
Requirements Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:CELL2:OTDifference?"

CALL:MS:REPorted:CELL2:OTDifference:TYPE?

Function

Queries the type of SFN-SFN Observed Time Difference (OTD) measurement performed by the UE. The UE reported OTD measurement result can be queried using the CALL:MS:REPorted:CELL2:OTDifference[:VALue]? command.

Query

Range: NONE|TYPE1|TYPE2

*RST Setting

 NONE
Requirements Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:CELL2:OTDifference:TYPE?"

CALL:MS:REPorted:CELL2:PATHloss?

Function

Queries the cell 2 UE reported Pathloss measurement result.

Query

Range: 46 to 158 dB, 9.91E +37

Resolution: 1 dB

*RST Setting

 9.91E +37
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:CELL2:PATHloss?"

CALL:MS:REPorted:CLEar[:ALL]<[:SELected]|:WCDMa>

Function

 Clears the UE (mobile) reported information. See Clearing the UE Information .
Requirements

Test Application Revision: A.04 and above

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:CLEar"

CALL:MS:REPorted:FREQuency[: SEParation]?

Function

Queries the "Band A" transmit/receive frequency separation. The specified frequencies are as follows: 190 MHz (MHZ190, fixed frequency separation), 174.8 to 205.2 MHz (MHZV205, variable frequency separation within this range), 134 to 245.2 MHz (MHZV245, variable frequency separation within this range).

Query

 Range: MHZ190|MHZV245|MHZV205|NONE

*RST Setting

 NONE
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:FREQUENCY:SEPARATION?"

CALL:MS:REPorted:GSMSystem:BCHannel?

Function

 Queries the mobile reported BCH ARFCN for GSM cells 1-8 (see GSM Neighbor Cell Measurement Results ).

Query

Range: 0 to 1023, 9.91E+37

Resolution: 1

*RST Setting

 9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:GSMSystem:BCHannel?"

CALL:MS:REPorted:GSMSystem:CELLs?

Function

 Queries the mobile reported total number of GSM cells (see GSM Neighbor Cell Measurement Results ).

Query

Range: 0 to 8

Resolution: 1

*RST Setting

 0
Requirements

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:GSMSystem:CELLs?"

CALL:MS:REPorted:GSMSystem:RSSI?

Function

 Queries the mobile reported RSSI for GSM cells 1-8 (see GSM Neighbor Cell Measurement Results ).

Query

Range: 0 to 63, 9.91E+37

Resolution: 1

*RST Setting

 9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:GSMSystem:RSSI?"

CALL:MS:REPorted:IMEI[:SELected]?

Function

Queries the mobile reported IMEI .

Query

Range: "0" to "FFFFFFFFFFFFFF" (0 to 15 characters from the set 0123456789ABCDEF) or "" (null string)

*RST Setting

"" (null string)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:IMEI:SELECTED?"

CALL:MS:REPorted:IMSI[:SELected]?

Function

Queries the mobile reported IMSI .

Query

Range: "0" to "FFFFFFFFFFFFFF" (0 to 15 characters from the set 0123456789ABCDEF) or "" (null string)

*RST Setting

 "" (null string)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:IMSI:SELECTED?"

CALL:MS:REPorted:ITRFrequency:CELLs?

Function

 Queries the mobile reported total number of inter frequency cells (see Inter Frequency Neighbor Cell Measurement Results ).

Query

Range: 0 to 32

Resolution: 1

*RST Setting

 0
Requirements

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:ITRFrequency:CELLs?"

CALL:MS:REPorted:ITRFrequency:DOWNlink:CHANnel?

Function

 Queries the mobile reported DL channel for inter frequency cells 1-8 (see Inter Frequency Neighbor Cell Measurement Results ).

Query

Range: 0 to 16383, 9.91E+37

Resolution: 1

*RST Setting

 9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:ITRFrequency:DOWNlink:CHANnel?"

CALL:MS:REPorted:ITRFrequency:ECNO?

Function

 Queries the mobile reported Ec/No for inter frequency cells 1-8 (see Inter Frequency Neighbor Cell Measurement Results ).

Query

Range: 0 to 49, 9.91E+37

Resolution: 1

*RST Setting

 9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:ITRFrequency:ECNO?"

CALL:MS:REPorted:ITRFrequency:PATHloss?

Function

 Queries the mobile reported pathloss for inter frequency cells 1-8 (see Inter Frequency Neighbor Cell Measurement Results ).

Query

Range: 46 to 158 dB, 9.91E+37

Resolution: 1 dB

*RST Setting

 9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:ITRFrequency:PATHloss?"

CALL:MS:REPorted:ITRFrequency:RSCP?

Function

 Queries the mobile reported RSCP for inter frequency cells 1-8 (see Inter Frequency Neighbor Cell Measurement Results ).

Query

Range: 0 to 91, 9.91E+37

Resolution: 1

*RST Setting

 9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:ITRFrequency:RSCP?"

CALL:MS:REPorted:ITRFrequency:RSSI?

Function

 Queries the mobile reported RSSI for inter frequency cells 1-8 (see Inter Frequency Neighbor Cell Measurement Results ).

Query

Range: 0 to 76, 9.91E+37

Resolution: 1

*RST Setting

 9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:ITRFrequency:RSSI?"

CALL:MS:REPorted:ITRFrequency:SCODe?

Function

 Queries the mobile reported scrambling code for inter frequency cells 1-8 (see Inter Frequency Neighbor Cell Measurement Results ).

Query

Range: 0 to 511, 9.91E+37

Resolution: 1

*RST Setting

 9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:ITRFrequency:SCODe?"

CALL:MS:REPorted:MEASurement:OTDifference:TYPE

Function

Sets/queries the SFN-SFN OTD Measurement Type performed by the UE when the CALL:MS:REPorted:MEASurement:REQuest command is sent.
Setting | Range: NONE|TYPE1|TYPE2
Query | Same as setting.
*RST Setting | NONE
Requirements

Lab Application Revision: C.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:OTDifference:TYPE TYPE2"
! Sets SFN-SFN OTD Measurement Type to Type 2.

CALL:MS:REPorted:MEASurement:REQuest

Function

Sends a Measurement Control message, which orders the UE to perform measurements on cell 1 (and cell 2 if you are using the lab application). Which measurements are performed by the UE is determined by the CALL:MS:REPorted:MEASurement:TYPe and CALL:MS:REPorted:MEASurement:OTDifference:TYPE commands.
See Cell 1/Cell 2 UE Reported Measurements .
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:REQuest"

CALL:MS:REPorted:MEASurement:TYPe

Function

 Sets/queries the Report Measurement Type , which determines which measurements are performed by the UE when the CALL:MS:REPorted:MEASurement:REQuest command is sent.
Setting

Range: ALL|INTRAFREQ|QUAL

Query

 Same as setting.

*RST Setting

 INTRAFREQ
Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEASurement:TYPe ALL"

CALL:MS:REPorted:ONUMber<[:SELected]|WCDMa>?

Function

Queries the Called Party Number .

Query

Range: 0 to 20 characters enclosed by double quotes, from the set 0123456789.*# or "Emergency Call" or "" (null string).

*RST Setting

 "" (null string)
Requirements

Lab Application Revision: C.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPorted:ONUMber?"

CALL:MS:REPorted:PCLass[:SELected]?

Function

Queries the mobile reported Power Class .

Query

Range: 1, 2, 3, 4, 9.91E+37

*RST Setting

 9.91E+37
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:PCLASS:SELECTED?"

CALL:MS:REPorted:PRAChannel:SIGnature?

Function

Queries the Detected PRACH Signature .

Query

Range: 0 to 15, 9.91E+37

*RST Setting

9.91E+37
Requirements Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:PRAChannel:SIGnature?"


CALL:OCNSource

CALL:OCNSource

Last updated: December 20, 2004

Diagram Conventions

CALL:OCNSource:LEVel?

Function

Queries the calculated level of the UTRA FDD composite orthogonal channel noise simulator (OCNS).

The OCNS level is a calculated value used to balance the relative power levels of the following channels to sum to 100%:

  • OCNS
  • Common Pilot Channel (CPICH)
  • Primary Common Control Physical Channel (P-CCPCH
  • Synchronization Channel (SCH)
  • Page Indicator Channel (PICH)
  • Dedicated Physical Channel (DPCH)

If the contribution of OCNS is calculated to be -30 dB or less, the OCNS state is turned off.

Query

Range: 0 to -29 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:OCNSOURCE:LEVEL?" !Queries the calculated OCNS level.

CALL:OCNSource:STATe?

Function

Queries the on/off state of the calculated UTRA FDD composite orthogonal channel noise simulator (OCNS).

The OCNS level is a calculated value used to balance the relative power levels of the following channels to sum to 100%:

  • OCNS
  • Common Pilot Channel (CPICH)
  • Primary Common Control Physical Channel (P-CCPCH
  • Synchronization Channel (SCH)
  • Page Indicator Channel (PICH)
  • Dedicated Physical Channel (DPCH)

If the contribution of OCNS is calculated to be -30 dB or less, the OCNS state is turned off.

Setting

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:OCNSOURCE:STATE?"


CALL:OPERating

CALL:OPERating

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL]:OPERating:MODE

Function

Sets/queries the operating mode of the base station emulator. If a call is in progress during a change in operating mode it will be dropped.

Setting

 Range:
Active Cell Mode = CALLUTRA FDD Test Mode = FDDTestCW Mode = CWCell Off Mode = OFF

Query

Range: CALL|CW|FDDT|OFF

*RST Setting

 CALL

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:OPERATING:MODE FDDTEST" !Selects UTRA FDD test mode.


CALL:ORIGinate

CALL:ORIGinate

Last updated: December 20, 2004

Diagram Conventions

CALL:ORIGinate

Function

Generates a page attempt to the mobile station. See Establishing a Connection with the UE .

If the call attempt fails, the test set will return to the idle call processing state.

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:ORIGINATE" !pages the mobile station

CALL:ORIGinate:DONE?

Function

 See Call Processing Event Synchronization

Query

Range: 1|0
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:ORIGINATE:DONE?"

CALL:ORIGinate:OPComplete?

Function

 See Call Processing Event Synchronization

Query

Range: 1
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:ORIGINATE:OPCOMPLETE?"

CALL:ORIGinate:SEQuential

Function

See Call Processing Event Synchronization

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:ORIGINATE:SEQUENTIAL"

CALL:ORIGinate:WAIT

Function

 See Call Processing Event Synchronization

Setting

Range:

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:ORIGINATE:WAIT"


CALL:PAGing

CALL:PAGing

Diagram Conventions

CALL:PAGing:IMSI[:SELected]

Function

Sets/queries the paging international mobile subscriber identity (IMSI). See Paging IMSI .

Paging IMSI will be overwritten by the mobile station's reported IMSI during a location update or call setup.

Setting

Range: 000000 to 9999999999999999
(6 to 15 characters from the set 0123456789)

Query

Range: "000000" to "9999999999999999"
(6 to 15 characters from the set 0123456789)

*RST Setting

 "001012345678901"
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:PAGing:IMSI '023389832394287'"

CALL:PAGing:REPeat[:STATe][:SELected]

Function

Sets/queries the repeat paging state. When repeat paging is off, the test set sends a single Paging Type 1 message in response to the user's page command. When repeat paging is on, the test set will begin sending Paging Type 1 messages in response to the user's page command and will repeat the message every discontinuous reception (DRX) cycle until either: 1) the UE (mobile station) responds with PRACH preambles and a valid RRC connection request or, 2) if it is enabled, the call drop timer expires or, 3) the user issues a CALL:END command to the test set.

Changing the repeat paging state to "Off" during a paging attempt has the same effect as CALL:END .

Setting

 Range: 0|ON|1|OFF

Query

Range: 0|1

*RST Setting

 0 (off)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:PAGING:REPEAT ON"

CALL:PAGing:SERVice[:TYPE]

Function

Sets/queries the Paging Service .

Setting

Range:

  • AMR: AMR Voice
  • GPRS: UMTS/GPRS Packet Data (Lab Application only)
  • RBTest: RB Test Mode

Query

Range: AMR|GPRS|RBT

*RST Setting

 RBT
Requirements

Test Application Revision: A.04 and above.

Lab Application Revision: A.01 and above.

Lab Application Revision A.02 added AMR.

Programming Example

OUTPUT 714;"CALL:PAGing:SERVice AMR"
! Sets the paging service type to AMR voice.


CALL:PCTPower

CALL:PCTPower

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL[1]]:PCTPower

Function

Sets/queries the BCCH Primary CPICH TX Power in the unit of dBm. This setting is used by the UE to determine the initial transmit power of the first PRACH preamble. See Initial PRACH Tx Power .

Changing this setting while in active cell operating mode and the Call Status is other than IDLE will result in the execution of the BCCH Update procedure (see Cell Parameters ).

Setting

Range: -10 dBm to +50 dBm

Resolution: 1 dB

Query

Range: -10 dBm to +50 dBm

Resolution: 1 dB

*RST Setting

 +19 dBm
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:PCTPower 20" !Sets the Primary CPICH TX Power to 20 dBm.


CALL:PICHannel

CALL:PICHannel

Last updated: December 20, 2004

Diagram Conventions

CALL:PICHannel[:SLEVel]

Function

Sets/queries the page indicator channel's initial power offset, and turns its state to ON.

This setting cannot be changed while in active cell operating mode (when available). Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: - 20 to 0 dB

Resolution: 0.01

Query

Range: -20 to 0 dB

Resolution: 0.01

*RST Setting

 -8.3 dB

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.06 changed *RST Setting to -8.3 dB.

Lab Application Revision C.01 changed *RST Setting to -8.3 dB.

Programming Example

OUTPUT 714;"CALL:PICHANNEL -12DB"

CALL:PICHannel:CCODe

Function

Sets/queries the page indicator channel's channelization code.

This setting cannot be changed while in active cell operating mode (when available). Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: CODE14|CODE15|CODE16|CODE17

Query

Range: CODE14|CODE15|CODE16|CODE17

*RST Setting

 CODE16

Requirements

Test Application Revision: A.01 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:PICHANNEL:CCODE CODE17"

CALL:PICHannel:LEVel

Function

Sets/queries the page indicator channel's initial power offset.

This setting cannot be changed while in active cell operating mode (when available). Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: - 20 to 0 dB

Resolution: 0.01

Query

Range: -20 to 0 dB

Resolution: 0.01

*RST Setting

 -8.3 dB

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.06 changed *RST Setting to -8.3 dB.

Lab Application Revision C.01 changed *RST Setting to -8.3 dB.

Programming Example

OUTPUT 714;"CALL:PICHANNEL:LEVEL -10DB"

CALL:PICHannel:STATe

Function

Sets/queries the state of the page indicator channel's initial power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 1|ON | 0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:PICHANNEL:STAT OFF"


CALL:POWer

CALL:POWer

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL]:POWer[:SAMPLitude]

Function

The setting form of this command performs two functions: (1) sets the desired cell power level and (2) turns the cell power on/off state to on. The query form returns the desired cell power level or NAN. (See Cell Power and AWGN Power for more information about desired versus current power levels.)

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type (see CALL[:CELL]:SYSTem[:TYPE]? ). The cell power settings for the CW operating mode are independent of the cell power settings for the other operating modes.

Setting

Range: (This is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source

  • FDD: -165 dBm/3.84MHz to +37 dBm/3.84MHz
  • CW: -177 dBm to +40 dBm

Resolution: 0.01 dBm/3.84 MHz

Query

Same as setting

*RST Setting

See CALL[:CELL]:POWer:AMPLitude[:SELected] and CALL[:CELL]:POWer:STATe[:SELected] .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:POWER:SAMPLITUDE -30"
! Sets the cell power level -30 dBm and turns it on.

CALL[:CELL]:POWer:AMPLitude[:SELected]

Function

Sets/queries the desired cell power level. (See Cell Power and AWGN Power for more information about desired versus current power levels.)

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type (see CALL[:CELL]:SYSTem[:TYPE]? ). The cell power settings for the CW operating mode are independent of the cell power settings for the other operating modes.

Setting

Range: (This is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source

  • FDD: -165 dBm/3.84MHz to +37 dBm/3.84MHz
  • CW: -177 dBm to +40 dBm

Resolution: 0.01 dBm/3.84 MHz

Query

Same as setting

*RST Setting

  • FDD: -75 dBm/3.84MHz
  • CW: -50 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:POWER:AMPLITUDE -30"
!Sets the cell power level -30 dBm.

CALL[:CELL]:POWer:STATe[:SELected]

Function

Sets/queries the cell power state.

The optional [:SELected] keyword in this command specifies that the cell power state being set or queried applies to the current system type (see CALL[:CELL]:SYSTem[:TYPE]? ). The cell power settings for the CW operating mode are independent of the cell power settings for the other operating modes.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

ON

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:POWER:STATE OFF" !Turns off cell power.


CALL:PSDomain

CALL:PSDomain

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL]:PSDomain

Function

Sets/queries PS Domain Information .

Setting

Range: ABSent|PRESent

Query

 Range: ABS|PRES

*RST Setting

 PRES

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PSDomain ABSent"
! Sets PS Domain Information to Absent.


CALL:RFGenerator

CALL:RFGenerator

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL]:RFGenerator:FREQuency

Function

Sets/queries the RF generator downlink channel frequency. If no units are specified the setting defaults to Hz.

The test set will tune to the frequency entered using this command when the CALL:CONTrol command is set to manual.

Setting

Range: 292 MHz to 2700 MHz
Resolution: 0.1 Hz

Query

Range: 292 MHz to 2700 MHz
Resolution: 0.1 Hz

*RST Setting

851 MHz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:RFGENERATOR:FREQUENCY 450 MHZ" !Set downlink channel frequency to 450 MHz.


CALL:RLC

CALL:RLC

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL[1]]:RLC:REEStablish

Function

Sets/queries the RLC re-establishment state. RLC re-establishment procedure typically occurs during the radio bearer setup portion of call establishment as the DPCH is reconfigured from the signalling radio bearer to the actual service configuration.

Attempting to change this setting to OFF results in the following error message: "+257, RLC behavior not compliant to 3GPP specifications for 3.4k or 13.6k SRB". When this setting is off, the test set will not perform the RLC re-establishment procedure even if the conditions would otherwise require it. This may result in unspecified behavior including loss of data.

Setting

Range: AUTO|OFF

Query

Range: AUTO|OFF

*RST Setting

AUTO
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:RLC:REEStablish OFF"
!Inhibit to perform the RLC re-establishement procedure.


CALL:SCODe

CALL:SCODe

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL]:SCODe[:PRIMary]

Function

Sets/queries the primary scrambling code.

The actual code number for the primary scrambling code is 16 times the value of this setting. See 3GPP TS 25.213, "Spreading and Modulation (FDD)" for a complete description of the relationship between this index and the actual spreading code number.

This setting cannot be changed while the active cell operating mode. Attempting to change this setting while in this mode will result in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this setting.

Setting

Range: 0 to 511

Query

Range: 0 to 511

*RST Setting

0

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:SCODe 10" !Sets the primary scrambling code to 10.


CALL:SECurity

CALL:SECurity

Last updated: December 20, 2004

Diagram Conventions

CALL:SECurity:AUTHenticate[:KEY]

Function

Sets/queries the authentication key.

This setting is not useful until the security operation mode is set to other than "NONE". See CALL:SECurity:OPERation .

Setting

Range: 0 to FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
(1 to 32 characters from the set 0123456789aAbBcCdDeEfF)

Query

Range: "00000000:00000000:00000000:00000000" to FFFFFFFF:FFFFFFFF:FFFFFFFF:FFFFFFFF
(The return string is always four colon separated groups in the order of upper, upper middle, lower middle and lower, each group with 8 characters from the set 0123456789ABCDEF)

*RST Setting

"4147494C:454E5420:54454348:4E4F0000"
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate '4147494C454E5420544543484E4F0000'"
! Sets the authentication key to 4147494C:454E5420:54454348:4E4F0000.

CALL:SECurity:AUTHenticate:ALGorithm

Function

Sets/queries the authentication algorithm to be used for security operation. Milenage (Rijndael) is the normal operation authentication algorithm, and the TEST34108 is the conformance test algorithm described in TS 34.108.

This setting is not useful until the security operation mode is set to other than "NONE". See CALL:SECurity:OPERation .

Setting

Range:

  • RIJNdael (Milenage)
  • TEST34108

Query

Range: RIJN|TEST34108

*RST Setting

TEST34108
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:ALGorithm RIJN"
!Sets the authentication algorithm to Milenage (Rijndael).

CALL:SECurity:AUTHenticate:AMF

Function

Sets/queries the value of the AMF parameter.

This setting is not useful until the security operation mode is set to other than "NONE". See CALL:SECurity:OPERation .

Setting

Range: 0 to FFFF
(1 to 4 characters from the set 0123456789aAbBcCdDeEfF)

Query

Range: "0000" to "FFFF"
(The return string is always 4 characters from the set 0123456789ABCDEF)

*RST Setting

"0000"
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:AMF 'FFFF'"
!Sets the AMF value to FFFF.

CALL:SECurity:AUTHenticate:OPVariant:PTYPe

Function

Sets/queries the Operator Variant Authentication Parameter type.

This setting is not useful until the security operation mode is set to other than "NONE". See CALL:SECurity:OPERation .

Setting

Range: OP|OPC

Query

Range: OP|OPC

*RST Setting

OPC
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:OPVariant:PTYPe OP"
!Sets the Operator Variant Authentication Parameter type to OP.

CALL:SECurity:AUTHenticate:OPVariant:PVALue

Function

Sets/queries the value of the Operator Variant Authentication Parameter.

This setting is not useful until the security operation mode is set to other than "NONE". See CALL:SECurity:OPERation .

Setting

Range: 0 to FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
(1 to 32 characters from the set 0123456789aAbBcCdDeEfF)

Query

Range: "00000000:00000000:00000000:00000000" to "FFFFFFFF:FFFFFFFF:FFFFFFFF:FFFFFFFF"
(The return string is always four colon separated groups in the order of upper, upper middle, lower middle and lower, each group with 8 characters from the set 0123456789ABCDEF)

*RST Setting

"00000000:00000000:00000000:00000000"
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:OPVariant:PVALue '10F'"
! Sets the value of Operator Variant Authentication
! Parameter to 00000000:00000000:00000000:0000010F.

CALL:SECurity:AUTHenticate:RANDom

Function

Sets/queries the value of the random (RAND) parameter.

This setting is not useful until the security operation mode is set to other than "NONE". See CALL:SECurity:OPERation .

Setting

Range: 0 to FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
(1 to 32 characters from the set 0123456789aAbBcCdDeEfF)

Query

Range: "00000000:00000000:00000000:00000000" to "FFFFFFFF:FFFFFFFF:FFFFFFFF:FFFFFFFF"
(The return string is always four colon separated groups in the order of upper, upper middle, lower middle and lower, each group with 8 characters from the set 0123456789ABCDEF)

*RST Setting

"00000000:00000000:00000000:00000001"
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:RANDom 'A'"
!Sets the random value of the Authentication Parameter to 00000000:00000000:00000000:0000000A.

CALL:SECurity:AUTHenticate:RESult:GMM?

Function

Queries the GMM (for GPRS service) authentication result.

Query

Range: SUCCess|MSFAILMAC|MSFAILSYNC|MSFAILUNKNOWN|RESLENERR|
RESNOTMATCH|NULL

  • SUCCess - MS Authentication Success
  • MSFAILMAC - MS Authentication Failure, with a reject cause of MAC Does not Match
  • MSFAILSYNC - MS Authentication Failure, with a reject cause of Synch Failure
  • MSFAILUNKNOWN - MS Authentication Failure, with a reject cause of Unknown
  • RESLENERR - MS Authentication Failure, with a reject cause of Incorrect RES Length
  • RESNOTMATCH - MS Authentication Failure, with a reject cause of RES does not Match

*RST Setting

NULL
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:RESult:GMM?"
!Queries the GMM authentication result.

CALL:SECurity:AUTHenticate:RESult[:MM]?

Function

Queries the MM (for non-GPRS service) authentication result.

Query

Range: SUCCess|MSFAILMAC|MSFAILSYNC|MSFAILUNKNOWN|RESLENERR|
RESNOTMATCH|NULL

  • SUCCess - MS Authentication Success
  • MSFAILMAC - MS Authentication Failure, with a reject cause of MAC Does not Match
  • MSFAILSYNC - MS Authentication Failure, with a reject cause of Synch Failure
  • MSFAILUNKNOWN - MS Authentication Failure, with a reject cause of Unknown
  • RESLENERR - MS Authentication Failure, with a reject cause of Incorrect RES Length
  • RESNOTMATCH - MS Authentication Failure, with a reject cause of RES does not Match

*RST Setting

NULL
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:RESult?"
!Queries the MM authentication result.

CALL:SECurity:AUTHenticate:SQN:RESet[:IMMediate]

Function

Resets the authentication sequence number (SQN) to zero.The SQN is set to zero each time the test set is powered on. It then increments each time an authentication procedure is performed.

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:SQN:RESet"
!Resets the authentication SQN.

CALL:SECurity:OPERation

Function

Sets/queries whether or not to perform the security procedure during UE registration. The security procedure is performed only if this setting is set to other than NONE, either with authentication only or with authentication and integrity protection.

Setting

Range: NONE|AUTHONLY|AUTHINTNONE - No security procedures are performed

  • AUTHONLY - Authentication only
  • AUTHINT - Authentication and integrity protection

Query

Range: NONE|AUTHONLY|AUTHINT

*RST Setting

AUTHINT
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Test Application Revision: A.06 and above, *RST value changed from NONE to AUTHINT

Lab Application Revision: C.01 and above, *RST value changed from NONE to AUTHINT

Programming Example

OUTPUT 714;"CALL:SECurity:OPERation AUTHONLY"
!Sets the security procedure with authentication only.


CALL:SETup

CALL:SETup

Diagram Conventions

CALL:SETup:CHANnel<[:SELected]|:FDD>:DOWNlink

Function

Sets/queries the Handoff Downlink Channel (UARFCN) .

If CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to on (auto) and you attempt to set Handoff Downlink Channel (UARFCN) to a value that would result in an invalid handoff uplink channel based on the current CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:SEParation setting, an error is posted. With CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO set to off (manual), set Handoff Downlink Channel (UARFCN) and CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:SEParation to a valid combination, then set CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO to on.

If the entered Handoff Downlink UARFCN has an uplink/downlink offset of less than 30 MHz when compared with the Handoff Uplink Channel (UARFCN) , the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range:

  • 412 - 687
  • 1037 - 1062
  • 4320 - 4495
  • 4600 - 4825
  • 9000 - 9425
  • 9625 - 9975
  • 10,525 - 10,875

Resolution: 1

Query

 Same as setting

*RST Setting

10730
Requirements

Test Application Revision: A.02 and above.

Test Application Revision: A.05.28 and above, added 1037 - 1062.

Lab Application Revision: A.01 and above.

Lap Application Revision: B.01.29 and above, added 1037 - 1062.

Programming Example

OUTPUT 714;"CALL:SETup:CHANnel:DOWNlink 4600"

CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink[:MCHannel]

Function

The setting form of this command performs two functions: (1) sets Handoff Uplink Channel (UARFCN) to a specific UARFCN (see CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CHANnel ), and (2) sets handoff uplink channel control to off (manual) (see CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO ).

The query form of this command returns the handoff uplink UARFCN that is used by the test set when CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to off (manual). Note, when CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to on (auto), the handoff uplink UARFCN used by the test set is determined by CALL:SETup:CHANnel<[:SELected]|:FDD>:DOWNlink and CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:SEParation . The handoff uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:SETup:CHANnel<[:SELected]|:FDD>UPLink? .

If the entered handoff Handoff Uplink UARFCN has an uplink/downlink offset of less than 30 MHz when compared with the Handoff Downlink Channel (UARFCN) , the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range: see CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CHANnel

Query

 Same as setting

*RST Setting

Handoff uplink UARFCN = 9780, handoff uplink channel control = on (auto)
Requirements

Test Application Revision: A.02 and above.

Test Application Revision: A.05.28 and above, added 812 - 837.

Lab Application Revision: A.01 and above.

Lab Application Revision: B.01.29 and above, added 812 - 837.

Programming Example

OUTPUT 714;"CALL:SETup:CHANnel:UPLink 4375"
! Sets the handoff uplink channel UARFCN to 4375 and selects manual control mode
! for handoff uplink channel.

CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CHANnel

Function

The setting form of this command sets Handoff Uplink Channel (UARFCN) to a specific UARFCN.

Note, this handoff uplink UARFCN is only used by the test set when CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to off (manual). When CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to on (auto), the handoff uplink UARFCN used by the test set is determined by CALL:SETup:CHANnel<[:SELected]|:FDD>:DOWNlink and CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:SEParation .

The query form of this command returns the handoff uplink UARFCN that is used by the test set when CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to off (manual). The handoff uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:SETup:CHANnel<[:SELected]|:FDD>UPLink? .

If the entered handoff Handoff Uplink UARFCN has an uplink/downlink offset of less than 30 MHz when compared with the Handoff Downlink Channel (UARFCN) , the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range:

  • 12 - 287
  • 812 - 837
  • 4095 - 4270
  • 4375 - 4600
  • 8525 - 8950
  • 9225 - 9925

Resolution: 1

Query

 Same as setting

*RST Setting

 9780
Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SETup:CHANnel:UPLink:CHANnel 4380"
! Sets the handoff uplink channel UARFCN to 4380.

CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO

Function

Sets/queries the Handoff Uplink Channel (UARFCN) control mode.

  • Auto - handoff uplink UARFCN is determined by CALL:SETup:CHANnel<[:SELected]|:FDD>:DOWNlink and CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:SEParation .
  • Manual - handoff uplink UARFCN is determined by CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CHANnel .

The handoff uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:SETup:CHANnel<[:SELected]|:FDD>UPLink? .

This setting cannot be changed to on (auto) when the settings for CALL:SETup:CHANnel<[:SELected]|:FDD>:DOWNlink and CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:SEParation would result in an invalid handoff uplink channel.

Setting

Range:

  • 1|ON (auto)
  • 0|OFF (manual)

Query

 Range: 1|0

*RST Setting

1 (auto)
Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SETup:CHANnel:UPLink:CONTrol:AUTO OFF"
! Sets handoff uplink control mode to manual.

CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:SEParation

Function

Sets/queries Handoff Uplink Separation .

When CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to on (auto), the handoff uplink UARFCN used by the test set is determined by this Handoff Uplink Separation setting and by CALL:SETup:CHANnel<[:SELected]|:FDD>:DOWNlink .

If CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to on (auto) and you attempt to set Handoff Uplink Separation to a value that would result in an invalid handoff uplink channel based on the current CALL:SETup:CHANnel<[:SELected]|:FDD>:DOWNlink setting, an error is posted. With CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO set to off (manual), set CALL:SETup:CHANnel<[:SELected]|:FDD>:DOWNlink and Handoff Uplink Separation to a valid combination, then set CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO to on.

Setting

Range: MHZ45|MHZ80|MHZ95|MHZ190|MHZ400

Query

 Same as setting

*RST Setting

 MHZ190
Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SETup:CHANnel:UPLink:SEParation MHZ80"

CALL:SETup[:HANDoff]:SYSTem[:TYPE]

Function

THIS COMMAND IS OBSOLETE. Please use the CALL:HANDoff:SYSTem:GSM[:IMMediate] command to perform a system handoff.

Sets/queries the system type that the mobile station will be handed off to when the CALL:HANDoff command is used. The intersystem handoff can be performed only from W-CDMA to GSM.

This setting cannot be changed to GSM while the E1968A test applications (TA) are not present in the test set and licensed for operation. Attempting to change this setting while the E1968A TA is not available will result in an error message to alert you this condition.

Setting

Range: FDD|GSM

Query

Range: FDD|GSM

*RST Setting

 FDD
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SETup:SYSTem GSM" !Selects GSM as the handoff system type.

CALL:SETup:SYSTem:GSM:ALERting[:STATe]

Function

Sets/queries RB Test Mode to GSM Handoff Alerting State .

Setting

Range: 1|ON|0|OFF

Query

 1|0

*RST Setting

 1 (On)
Requirements

Test Application Revision: A.06 and above.

Lab Application Revision: C.01 and above.

Programming Example

OUTPUT 714;"CALL:SETup:SYSTem:GSM:ALERting OFF"
! Sets RB Test Mode to GSM Alerting State to Off (the UE will not ring).

CALL:SETup:TCReconfig:RBTest:RAB

Function

Sets/queries the Handoff RB Test Mode RAB (see Transport Channel Reconfiguration ).

Setting

Range:

  • RMC12 (12.2k RMC)
  • RMC64 (64k RMC)
  • RMC144 (144k RMC)
  • RMC384 (384k RMC)
  • RMC33NC (33k No Coding RMC)

Query

 Same as setting

*RST Setting

 RMC12
Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:RBTest:RAB RMC64"
! Sets the handoff RB test mode RAB to 64k RMC.


CALL:SRBearer

CALL:SRBearer

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL]:SRBearer:CCHannel:DEDicated:BPS3400[:CCODe]

Function

Sets/queries the downlink dedicated physical channel's (DPCH) channelization code during the "setup" phase of connection setup when CALL[:CELL]:SRBearer:CCHannel:DEDicated:DRATe is set to BPS3400 or BPS2200.

When CALL[:CELL]:SRBearer:CCHannel:DEDicated:DRATe is set to BPS13600, the DPCH channelization code will be determined by the UTRA FDD DL DPCH 12.2 RMC channelization code ( CALL:DPCHannel:RMC12:CCODe ).

See Signalling Radio Bearer (SRB) Configuration .

This setting cannot be changed while the active cell operating mode. Attempting to change this setting while in this mode will result in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode to change this setting.

To set the DPCH channelization code for the SRB when using the Lab Application, see CALL:DPCHannel:KSPS15[:CCODe] and CALL:DPCHannel:KSPS30[:CCODe] .

Setting

Range:

CODE12|CODE13CODE20|CODE21|CODE40|CODE43|CODE58|CODE126|CODE127|
CODE142|CODE153|CODE174|CODE235|CODE255

Query

Range:

CODE12|CODE13CODE20|CODE21|CODE40|CODE43|CODE58|CODE126|CODE127|
CODE142|CODE153|CODE174|CODE235|CODE255

*RST Setting

CODE12

Requirements

Test Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:CELL:SRBearer:CCHannel:DEDicated:BPS3400:CCODE CODE58"

CALL[:CELL]:SRBearer:CCHannel:DEDicated:DRATe

Function

Sets/queries the initial signaling radio bearer (SRB) configuration: 2.2 kbps (BPS2200), 3.4 kbps (BPS3400) or 13.4 kbps (BPS 13400).

Setting

Range: BPS2200|BPS3400|BPS13600

Query

Range: BPS2200|BPS3400|BPS13600

*RST Setting

BPS3400

Requirements

Test or Lab Application Revision: A.01 and above.

Test Application Revision A.03 added BPS2200 setting.

Programming Example

OUTPUT 714;"CALL:CELL:SRBEARER:CCHANNEL:DEDICATED:DRATE BPS13600"


CALL:STATus

CALL:STATus

Last updated: December 20, 2004

NOTE
The CALL:STATus commands are query only. They return values that indicate the test set's actual hardware settings. Actual hardware settings can differ from settings the user has entered, most frequently due to an error condition. When no error conditions exist, the commands used to enter values will return the same results as the commands used to query actual hardware settings. For example, "CALL:AWGNoise:POWer?" will return the same value as "CALL:STATus:AWGNoise:POWer?" when no error conditions exist.

Diagram Conventions

CALL:STATus[:STATe][:VOICe]?

Function

Queries the status of the call. See Call States .

Query

Range: CALL|CONN|HAND|IDLE|PAG|REG|REL|SREQ

Only IDLE is returned in FDD Test operating mode.

*RST Setting

 IDLE

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision: A.05 and above added CALL

Lab Application Revision: B.01 and above added CALL

Programming Example

OUTPUT 714;"CALL:STATUS?"
! Returns the current call processing state.

CALL:STATus[:STATe]:DATA?

Function

Queries the status of the data connection. See Data Channel States .

Query

Range: IDLE|ATTG|DET|PDPAG|PDP|PDPD

*RST Setting

 IDLE

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:DATA?"
! Returns the current data connection state.

CALL:STATus[:GMM]:ATTached:STATe?

Function

Queries the attached state of the UE. See GMM State .

Query

Range:

  • ATT - attached
  • ATTINC - attach incomplete
  • DET - detached
  • NONE

*RST Setting

 NONE

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:STATus:ATTached:STATe?"

CALL:STATus:COMPressed:STATe?

Function

Queries Compressed Mode State (see Compressed Mode Operation in the Test Set ).

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:COMPressed:STATe?"

CALL:STATus:MM?

Function

Queries MM Status .

Query

Range:

  • MMSTATUS1 (Updated (Normal))
  • MMSTATUS2 (Updated (Periodic))
  • MMSTATUS3 (IMSI Attached)
  • MMSTATUS4 (IMSI Detached)
  • MMSTATUS5 (None)

*RST Setting

 MMSTATUS5

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:STATus:MM?"

CALL:STATus:RRC:STATe?

Function

Queries RRC State .

Query

Range: DCH|FACH|IDLE

*RST Setting

 IDLE

Requirements

 Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:STATus:RRC:STATe?"

CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude]?

Function

Queries the current power level of the additive white Gaussian noise (AWGN) source. AWGN power level is set using the CALL:AWGNoise commands.

See Cell Power and AWGN Power for more information about desired versus current power levels.

Query

Range:

  • -165 dBm/3.84 MHz to +35 dBm/3.84 MHz, NAN (this is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source)
  • 9.91 E+37 (NAN) is returned if CALL:STATus:AWGNoise[:INTernal]:POWer:STATe? is OFF

Resolution: 0.01 dB

*RST Setting

 9.91 E+37 (NAN)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:AWGNOISE:POWER:AMPLITUDE?"
!Queries the current AWGN power.

CALL:STATus:AWGNoise[:INTernal]:POWer:STATe?

Function

Queries the current on/off state of the additive white Gaussian noise (AWGN) source. AWGN power level on/off state is set using the CALL:AWGNoise commands.

See Cell Power and AWGN Power for more information about desired versus current power levels.

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:AWGNOISE:POWER:STATE?"

CALL:STATus:CELL:POWer[:AMPLitude]?

Function

Queries the current cell power level. Cell power is set using the CALL:POWer commands.

See Cell Power and AWGN Power for more information about desired versus current power levels.

Query

Range:

  • -165 dBm/3.84 MHz to +37 dBm/3.84 MHz, NAN (this is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source)
  • 9.91 E+37 (NAN) is returned if CALL:STATus:CELL:POWer:STATe? is OFF

Resolution: 0.01 dB

*RST Setting

 -75.00 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CELL:POWER:AMPLITUDE?"

CALL:STATus:CELL:POWer:STATe?

Function

Queries the current state of the cell power setting. Cell power state is set using the CALL:POWer commands.

See Cell Power and AWGN Power for more information about desired versus current power levels.

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CELL:POWER:STATE?"

CALL:STATus:CELL:SYSTem[:TYPE]?

Function

Queries the current system type that the test set is currently emulating.

When the test set is in active cell operating mode (see CALL:OPERating ) the current system type is selected by the CALL:SYSTem command. (Active cell operating mode is not available in the initial W-CDMA test application release.)

When the test set is in any test mode operating mode (see CALL:OPERating ) or CW operating mode, this command will return the corresponding system type.

Query

Range: FDD|CW

*RST Setting

 FDD

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CELL:SYSTEM:TYPE?"

CALL:STATus:CELL2:POWer[:AMPLitude]?

Function

Queries the current cell 2 power level. (See Cell 2 Overview ).

Query

Range:

  • -165 dBm/3.84 MHz to +37dBm/3.84 MHz, 9.91 E+37
    (-115 dBm/3.84 MHz to -13 dBm/3.84 MHz actual hardware range with amplitude offset = 0)

    The actual power range is defined by adding the value of the associated amplitude offset to the range above. For example, if amplitude offset is -3.5 dB, then the power range will be -118.5 dBm/3.84 MHz to -16.5 dBm/3.84 MHz.

Resolution: 0.01 dBm/3.84 MHz

*RST Setting

 9.91E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CELL2:POWER:AMPLITUDE?"

CALL:STATus:CELL2:POWer:STATe?

Function

Queries the current state of the cell 2 power setting. (See Cell 2 Overview ).

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CELL2:POWER:STATE?"

CALL:STATus:SERVice:TYPe?

Function

Queries the type of service that is currently active. See Channel Type and Paging Service .

The current service type will be set to NONE when an event occurs that causes the service to be stopped. These events include:

  • End Call
  • A call processing error that results in a dropped call
  • UE initiated end of service
  • Full or Partial Preset

Query

Range:

  • AMR: AMR Voice
  • CSDA: CS Data - Async (only applicable to the lab application)
  • CSDV: CS Data - UE to UE Video Call (only applicable to the lab application and to a test application with the required feature license)
  • GPRS: UMTS/GPRS Packet Data (only applicable to the lab application)
  • RBT: RB Test Mode
  • NONE

*RST Setting

 NONE

Requirements

Test Application Revision: A.01 and above

Test Application Revision A.04 added AMR

Lab Application Revision: A.01 and above

Lab Application Revision A.02 added AMR

Lab Application Revision C.01 added CSDV

Programming Example

OUTPUT 714;"CALL:STATus:SERVice:TYPe?"
! Returns the current service type.

CALL:STATus:SETup:CHANnel<[:SELected]|:FDD>UPLink?

Function

Queries the handoff uplink UARFCN currently being used by the test set.

When CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to on (auto), the handoff uplink UARFCN is determined by CALL:SETup:CHANnel<[:SELected]|:FDD>:DOWNlink and CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:SEParation . When CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to off (manual), the handoff uplink UARFCN is determined by CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CHANnel .

Query

Range: see CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CHANnel

*RST Setting

 see CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:CHANnel

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:SETup:CHANnel:UPLink?"

CALL:STATus:SHANdoff:EVENt?

Function

Queries the most recent Intra Frequency Event identifier. Events can be:

  • 1a
  • 1b
  • 1c
  • 1d
  • 1e
  • 1f
  • None

(See Event Triggering ).

Query

Range: 1A|1B|1C|1D|1E|1F|NONE

*RST Setting

 NONE

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:SHANdoff:EVENt?" !Returns the most recent event.

CALL:STATus:SHANdoff:EVENt:CELLid?

Function

 Queries the cell that triggered the most recent event. (See Event Triggering ).

Query

Range: CELL1|CELL2|NONE

*RST Setting

 NONE

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:SHANdoff:EVENt:CELLid?"

CALL:STATus:SHANdoff:STATe?

Function

 Queries Soft Handoff State .

Query

Range: 1|0

*RST Setting

 0

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:SHANdoff:STATe?"

CALL:STATus:TOTal:POWer[:AMPLitude]?

Function

Queries the current total RF power for the specified system type. The total RF power is equal to the sum of the cell power setting (see CALL:POWer ) and the AWGN setting (see CALL:AWGNoise ).

See Cell Power and AWGN Power for more information about desired versus current power levels.

Query

Range:

  • -165 dBm/3.84 MHz to +42 dBm/3.84 MHz, NAN (this is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source)
  • 9.91 E+37 (NAN) is returned if CALL:STATus:TOTal:POWer:STATe? is OFF

Resolution: 0.01 dB

*RST Setting

 -75.00 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:TOTAL:POWER?"

CALL:STATus:UPLink:CHANnel?

Function

Queries the uplink UARFCN currently being used by the test set.

When CALL:UPLink:CHANnel:CONTrol:AUTO is set to on (auto), the uplink UARFCN is determined by CALL:CHANnel and CALL:UPLink:CHANnel:SEParation . When CALL:UPLink:CHANnel:CONTrol:AUTO is set to off (manual), the uplink UARFCN is determined by CALL:UPLink:CHANnel:CHANnel .

Query

Range: see CALL:UPLink:CHANnel:CHANnel

*RST Setting

 see CALL:UPLink:CHANnel:CHANnel

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:UPLink:CHANnel?"

CALL:STATus:TOTal:POWer:STATe?

Function

Queries the current total RF power measurement's state for the currently selected system type.

This query will return a 1 (on) if the current cell power ( CALL:POWer ) power state is on.

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:TOTAL:POWER:STATE?"

CALL:STATus:AICHannel[:LEVel]?

Function

Queries the current level of the acquisition indicator channel. This setting is not used in FDD Test operating mode.

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 -9.9 dB

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:AICHANNEL:LEVEL?"

CALL:STATus:AICHannel:STATe?

Function

Queries the current state of the acquisition indicator channel. This setting is not used in FDD Test operating mode.

Query

Range: 0|1

*RST Setting

 1 (on)

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:AICHANNEL:STATE?"

CALL:STATus:CCPChannel:PRIMary[:LEVel]?

Function

Queries the current level of the primary common control physical channel.

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 -5.3 dB

Requirements

Test or Lab Application Revision: A.01 and above.

Test Application Revision A.06 changed *RST Setting to -5.3 dB.

Lab Application Revision C.01 changed *RST Setting to -5.3 dB.

Programming Example

OUTPUT 714;"CALL:STATUS:CCPCHANNEL:PRIMARY:LEVEL?"

CALL:STATus:CCPChannel:PRIMary:STATe?

Function

Queries the current state of the primary common control physical channel.

Query

Range: 0|1

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CCPCHANNEL:PRIMARY:STATE?"

CALL:STATus:CCPChannel:PRIMary:CELL2[:LEVel]?

Function

Queries the current level of the cell 2 primary common control physical channel. (See Cell 2 Overview ).

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CCPCHANNEL:PRIMARY:CELL2:LEVEL?"

CALL:STATus:CCPChannel:PRIMary:CELL2:STATe?

Function

Queries the current state of the cell 2 primary common control physical channel. (See Cell 2 Overview ).

Query

Range: 0|1

*RST Setting

 0 (off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CCPCHANNEL:PRIMARY:CELL2:STATE?"

CALL:STATus:CCPChannel:SECondary[:LEVel]?

Function

Queries the current level of the secondary common control physical channel.

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 -10.3 dB

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above

Test Application Revision A.06 changed *RST Setting to -10.3 dB.

Lab Application Revision C.01 changed *RST Setting to -10.3 dB.

Programming Example

OUTPUT 714;"CALL:STATUS:CCPCHANNEL:SECONDARY:LEVEL?"

CALL:STATus:CCPChannel:SECondary:STATe?

Function

Queries the current state of the secondary common control physical channel.

Query

Range: 0|1

*RST Setting

 1 (on)

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CCPCHANNEL:SECONDARY:STATE?"

CALL:STATus:CPIChannel[:LEVel]?

Function

Queries the current common pilot channel's power.

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 -3.3 dB

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision A.06 changed *RST Setting to -3.3 dB.

Lab Application Revision C.01 changed *RST Setting to -3.3 dB.

Programming Example

OUTPUT 714;"CALL:STATUS:CPICHANNEL:LEVEL?"

CALL:STATus:CPIChannel:STATe?

Function

Queries the current state of the common pilot channel.

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CPICHANNEL:STATE?"

CALL:STATus:CPIChannel:CELL2[:LEVel]?

Function

Queries the current cell 2 common pilot channel's power. (See Cell 2 Overview ).

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CPICHANNEL:CELL2:LEVEL?"

CALL:STATus:CPIChannel:CELL2:STATe?

Function

Queries the current state of the cell 2 common pilot channel. (See Cell 2 Overview ).

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CPICHANNEL:CELL2:STATE?"

CALL:STATus:DPCHannel[:LEVel]?

Function

Queries the current dedicated physical channel's power.

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:DPCHANNEL:LEVEL?"

CALL:STATus:DPCHannel:STATe?

Function

Queries the current state of the dedicated physical channel.

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:DPCHANNEL:STATE?"

CALL:STATus:DPCHannel:CELL2[:LEVel]?

Function

Queries the current cell 2 dedicated physical channel's power. (See Cell 2 Overview ).

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:DPCHANNEL:CELL2:LEVEL?"

CALL:STATus:DPCHannel:CELL2:STATe?

Function

Queries the current state of the cell 2 dedicated physical channel.

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:DPCHANNEL:CELL2:STATE?"

CALL:STATus:DPCHannel:CURCbeta?

Function

Queries the current power gain of the dedicated physical control channel (DPCCH) see Uplink DPCH Bc/Bd Control .

Query

Range: 2 to 15

Resolution: 1

*RST Setting

 8

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:DPCHannel:CURCbeta?"

CALL:STATus:DPCHannel:CURDbeta?

Function

Queries the current power gain of the dedicated physical data channel (DPDCH) see Uplink DPCH Bc/Bd Control .

Query

Range: 0 to 15

Resolution: 1

*RST Setting

 15

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:DPCHannel:CURDbeta?"

CALL:STATus:OCNSource[:LEVel]?

Function

Queries the orthogonal channel noise source (OCNS) level for the selected system type.

The OCNS level is set using the CALL:OCNSource commands.

The optional [:SELected] keyword in this command specifies that the OCNS channel level being queried applies to the current system type.

Query

Range: 0 to -20 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision A.06 changed *RST Setting to 9.91 E+37.

Lab Application Revision C.01 changed *RST Setting to 9.91 E+37.

Programming Example

OUTPUT 714;"CALL:STATUS:OCNSOURCE:LEVEL?"

CALL:STATus:OCNSource:STATe?

Function

Queries the current on/off state of the orthogonal channel noise simulator channel (OCNS).

The OCNS channel on/off state is set using the CALL:OCNSource commands.

The optional [:SELected] keyword in this command specifies that the OCNS channel state being queried applies to the current system type.

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:OCNS:STATE?"

CALL:STATus:OCNSource:CELL2[:LEVel]?

Function

Queries the cell 2 orthogonal channel noise source (OCNS) level for the selected system type.

The OCNS level is set using the CALL:CELL2:OCNSource commands.

The optional [:SELected] keyword in this command specifies that the OCNS channel level being queried applies to the current system type.

(See Cell 2 Overview ).

Query

Range: 0 to -20 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:OCNSOURCE:CELL2:LEVEL?"

CALL:STATus:OCNSource:CELL2:STATe?

Function

Queries the current cell 2 on/off state of the orthogonal channel noise simulator channel (OCNS).

The OCNS channel on/off state is set using the CALL:CELL2:OCNSource commands.

The optional [:SELected] keyword in this command specifies that the OCNS channel state being queried applies to the current system type.

(See Cell 2 Overview ).

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:OCNS:CELL2:STATE?"

CALL:STATus:PICHannel[:LEVel]?

Function

Queries the current downlink page indicator channel's power.

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 -8.3 dB

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision A.06 changed *RST Setting to -8.3 dB.

Lab Application Revision C.01 changed *RST Setting to -8.3 dB.

Programming Example

OUTPUT 714;"CALL:STATUS:PICHANNEL:LEVEL?"

CALL:STATus:PICHannel:STATe?

Function

Queries the current state of the downlink page indicator channel.

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:PICHANNEL:STATE?"

CALL:STATus:PRAChannel:CURCbeta?

Function

Queries the current power gain for the control data of the message portion of the uplink physical random access channel (PRACH) see PRACH Bc/Bd Control .

Query

Range: 2 to 15

Resolution: 1

*RST Setting

 15

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:PRAChannel:CURCbeta?"

CALL:STATus:PRAChannel:CURDbeta?

Function

Queries the current power gain for the message data of the message portion of the uplink physical random access channel (PRACH) see PRACH Bc/Bd Control .

Query

Range: 0 to 15

Resolution: 1

*RST Setting

 15

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:PRAChannel:CURDbeta?"


CALL:SYSTem

CALL:SYSTem

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL]:SYSTem[:TYPE]?

Function

 Queries the type of cell the system is emulating when in active cell mode. This command is query only because only one active cell system type (UTRA FDD) is supported at this time.

Query

Range: FDD

*RST Setting

 FDD

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL:SYSTEM:TYPE?"


CALL:TOTal:POWer

CALL:TOTal:POWer

Last updated: December 20, 2004

Diagram Conventions

CALL:TOTal:POWer[:AMPLitude]?

Function

Queries the desired total RF power for the current system type.

Total RF Power is a calculated value, that is the sum of cell power and AWGN power settings. (See Cell Power, AWGN Power and Total RF Power Ranges for more information about desired versus current power levels.)

Query

Range:

  • -165 dBm/3.84 MHz to +42 dBm/3.84 MHz
  • 9.91 E+37 (NAN) is returned if both Cell Power and AWGN power are set to OFF

Resolution: 0.01 dBm/3.84 MHz

*RST Setting

 -75 dBm/3.84 MHz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:TOTAL:POWER:AMPLITUDE?"

CALL:TOTal:POWer:STATe?

Function

Queries the total RF power state for the current system type.

The total RF power state is 1 (on) if either cell power or AWGN power is on.

The return value for this query is not necessarily the total power state at the moment this command is processed by the test set. To query the power state of the test set at the moment, use the CALL:STATus:TOTal:POWer:STATe? command.

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:TOTAL:POWER:STATE?"


CALL:TRIGger

CALL:TRIGger

Last updated: December 20, 2004

Diagram Conventions

CALL:TRIGger[:OUTPut]:SIGNal

Function

Sets/queries Trigger Output Setup .

Setting

Range: SFCLock|MGENerated

Query

 Range: SFCL|MGEN

*RST Setting

 SFCL

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:TRIGger:SIGNal MGENerated"
! Sets Trigger Output Setup to Measurement Generated.


CALL:UINTerferenc

CALL:UINTerferenc

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL[1]]:UINTerferenc

Function

Sets/queries the BCCH uplink interference power level in the unit of dBm. This setting is used by the UE to determine the initial transmit power of the first PRACH preamble. See Initial PRACH Tx Power .

Changing this setting while in active cell operating mode and the Call Status is other than IDLE will result in the execution of the BCCH Update procedure (see Cell Parameters ).

Setting

Range: -110 dBm to -70 dBm

Resolution: 1 dBm

Query

Range: -110 dBm to -70 dBm

Resolution: 1 dBm

*RST Setting

 -110 dBm
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UINTerferenc -70"
! Sets the uplink interference power level to -70 dBm.


CALL:UPLink

CALL:UPLink

Diagram Conventions

CALL:UPLink:CHANnel[:MCHannel]

Function

The setting form of this command performs two functions: (1) sets Uplink Channel to a specific UARFCN (see CALL:UPLink:CHANnel:CHANnel ), and (2) sets uplink channel control to off (manual) (see CALL:UPLink:CHANnel:CONTrol:AUTO ).

The query form of this command returns the uplink UARFCN that is used by the test set when CALL:UPLink:CHANnel:CONTrol:AUTO is set to off (manual). Note, when CALL:UPLink:CHANnel:CONTrol:AUTO is set to on (auto), the uplink UARFCN used by the test set is determined by CALL:CHANnel and CALL:UPLink:CHANnel:SEParation . The uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:UPLink:CHANnel? .

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

If the Uplink Channel and DL Channel settings have an uplink/downlink offset of less than 30 MHz, the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range: see CALL:UPLink:CHANnel:CHANnel

Query

 Same as setting

*RST Setting

Uplink UARFCN = 9750, uplink channel control = on (auto)

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision: A.05.28 and above, added 812 - 837

Lab Application Revision: B.01.29 and above, added 812 - 837

Programming Example

OUTPUT 714;"CALL:UPLink:CHANnel 4375"
! Sets the uplink channel UARFCN to 4375 and selects manual control mode for uplink channel.

CALL:UPLink:CHANnel:CHANnel

Function

The setting form of this command sets Uplink Channel to a specific UARFCN.

Note, this uplink UARFCN is only used by the test set when CALL:UPLink:CHANnel:CONTrol:AUTO is set to off (manual). When CALL:UPLink:CHANnel:CONTrol:AUTO is set to on (auto), the uplink UARFCN used by the test set is determined by CALL:CHANnel and CALL:UPLink:CHANnel:SEParation .

The query form of this command returns the uplink UARFCN that is used by the test set when CALL:UPLink:CHANnel:CONTrol:AUTO is set to off (manual). The uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:UPLink:CHANnel? .

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

If the Uplink Channel and DL Channel settings have an uplink/downlink offset of less than 30 MHz, the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range:

  • 12 - 287
  • 812 - 837
  • 4095 - 4270
  • 4375 - 4600
  • 8525 - 8950
  • 9225 - 9925

Resolution: 1

Query

 Same as setting

*RST Setting

9750

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:UPLink:CHANnel:CHANnel 4375"
! Sets the uplink channel UARFCN to 4375.

CALL:UPLink:CHANnel:CONTrol:AUTO

Function

Sets/queries the Uplink Channel control mode.

  • Auto - uplink UARFCN is determined by CALL:CHANnel and CALL:UPLink:CHANnel:SEParation .
  • Manual - uplink UARFCN is determined by CALL:UPLink:CHANnel:CHANnel .

The uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:UPLink:CHANnel? .

This setting cannot be changed to on (auto) when the settings for CALL:CHANnel and CALL:UPLink:CHANnel:SEParation would result in an invalid uplink channel.

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

Setting

Range:

  • 1|ON (auto)
  • 0|OFF (manual)

Query

 Range: 1|0

*RST Setting

1 (auto)

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:UPLink:CHANnel:CONTrol:AUTO OFF"
! Sets uplink channel control mode to manual.

CALL:UPLink:CHANnel:SEParation

Function

Sets/queries Uplink Separation .

When CALL:UPLink:CHANnel:CONTrol:AUTO is set to on (auto), the uplink UARFCN used by the test set is determined by this Uplink Separation setting and by CALL:CHANnel .

If CALL:UPLink:CHANnel:CONTrol:AUTO is set to on (auto) and you attempt to set Uplink Separation to a value that would result in an invalid uplink channel based on the current CALL:CHANnel setting, an error is posted. With CALL:UPLink:CHANnel:CONTrol:AUTO set to off (manual), set CALL:CHANnel and Uplink Separation to a valid combination, then set CALL:UPLink:CHANnel:CONTrol:AUTO to on.

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

Setting

Range: MHZ45|MHZ80|MHZ95|MHZ190|MHZ400

Query

 Same as setting

*RST Setting

 MHZ190

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:UPLink:CHANnel:SEParation MHZ80"

CALL:UPLink:DCCHannel:DDATa

Function

Sets/queries the Uplink Dummy DCCH Data state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 0 (off)

Requirements

Test Application Revision: A.04 and above

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:UPLink:DCCHannel:DDATa OFF"

CALL:UPLink:DPCChannel:POWer:INITial?

Function

Queries the expected initial power level for the uplink dedicated physical control channel.

Query

Range: -50 to 24 dBm and 9.91E+37 (NAN)

Requirements

Test Application Revision: A.02.25 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLINK:DPCC:POWER:INITIAL?"

CALL:UPLink:DPCHannel:BETA:AUTo

Function

Sets/queries the power gain control mode for the uplink dedicated physical channel (DPCH) which consists of the dedicated physical data channel (DPDCH) and the dedicated physical control channel (DPCCH). See Uplink Parameters for details.

ON = automatic
OFF = manual

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (on)

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:DPCHannel:BETA:AUTo OFF
! Enables manual control of the DPCH power gain.

CALL:UPLink:DPCHannel:MANual:CBETa

Function

Sets/queries the power gain of the dedicated physical control channel (DPCCH) when the DPCH power gain control mode is MANual (see CALL:UPLink:DPCHannel:BETA:AUTo ).

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

Setting

Range: 2 to 15

Resolution: 1

Query

Range: 2 to 15
*RST setting 8

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:DPCHannel:MANual:CBETa 10"
! Sets manual control of power gain for the DPCCH to 10.

CALL:UPLink:DPCHannel:MANual:DBETa

Function

Sets/queries the power gain of the dedicated physical data channel (DPDCH) when the DPCH power gain control mode is MANual (see CALL:UPLink:DPCHannel:BETA:AUTo ).

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

Setting

Query

Range: 0 to 15
*RST setting 15

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:DPCHannel:MANual:DBETa 5"
! Sets manual control of power gain for the DPDCH to 5.

CALL:UPLink:DPCHannel:SCODe

Function

Sets/queries the uplink dedicated physical channel's scrambling code. See Uplink Parameters for details.

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

Setting

Range: 0 to 16777215

Query

 Same as setting

*RST Setting

1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLINK:DPCH:SCODE 10"
! Sets the uplink DPCH scrambling code to 10.

CALL:UPLink:PRAChannel:ASUBchannels

Function

Sets/queries the available subchannels for the uplink random access request. The bits with 1 settings indicate that the corresponding subchannels are available for use, while the bits with 0 settings indicate that the corresponding subchannels can not be used. See Uplink Parameters for details.

Setting

Range: 0 to 111111111111
(1 to 12 characters from the set 0 and 1).

Query

Range: "000000000000" to "111111111111"
(The returned string is always 12 characters from the set 0 and 1).

*RST Setting

"000000000001"

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:ASUBchannels '111111111111'"
! Sets all twelve PRACH access subchannels avai1able for use.

CALL:UPLink:PRAChannel:BETA:AUTo

Function

Sets/queries the power gain control mode for the message portion of the uplink physical random access channel (PRACH). See Uplink Parameters for details.

ON = automatic
OFF = manual

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (automatic)

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:BETA:AUTo OFF"
! Enables manual control of the PRACH power level.

CALL:UPLink:PRAChannel:MANual:CBETa

Function

Sets/queries the power gain setting for the control data of the message portion of the uplink physical random access channel (PRACH) when the PRACH power gain control mode is MANual (see CALL:UPLink:PRAChannel:BETA:AUTo ).

Setting

Range: 2 to 15

Resolution: 1

Query

Range: 2 to 15
*RST setting 15

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:MANual:CBETa 10"
! Sets manual control of power gain for the control data
! of the message portion of the PRACH to 10.

CALL:UPLink:PRAChannel:MANual:DBETa

Function

Sets/queries the power gain setting for the message data of the message portion of the uplink physical random access channel (PRACH) when the PRACH power gain control mode is MANual (see CALL:UPLink:PRAChannel:BETA:AUTo ).

Setting

Range: 0 to 15

Resolution: 1

Query

Range: 0 to 15
*RST setting 15

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:MANual:DBETa 5"
! Sets manual control of power gain for message data of
! the message portion of the PRACH to 5.

CALL:UPLink:PRAChannel:POWer:INITial?

Function

Queries the expected initial power level for the uplink physical random access channel.

Query

Range: -50 to 24 dBm and 9.91E+37 (NAN)

Requirements

Test Application Revision: A.02.25 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLINK:PRAC:POWER:INITIAL?"

CALL:UPLink:PRAChannel:POWer[:RAMP]:STEP[:LEVel]

Function

Sets/queries the uplink physical random access channel's preamble power step size in dB. See Uplink Parameters for details.

Setting

Range: 1 to 8

Resolution: 1

Query

Range: 1 to 8

*RST Setting

3

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:POWer:STEP:LEVel 5"

CALL:UPLink:PRAChannel:PREambles:NUMBer

Function

Sets/queries the PRACH Preambles, which is the maximum number of preambles in a single PRACH Ramping Cycle (see CALL:UPLink:PRAChannel:PREambles:RCYCles[:MMAX] ) per PRACH access channel request. See Uplink Parameters for details.

Setting

Range: 1 to 64

Resolution: 1

Query

Range: 1 to 64

*RST Setting

64

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:PREambles:NUMBer 15"
! Sets the maximum number of preambles per
! PRACH Ramping Cycle to 15.

CALL:UPLink:PRAChannel:PREambles:RCYCles[:MMAX]

Function

Sets/queries the PRACH Ramping Cycles, which is the number of PRACH preamble sequences the UE (mobile station) will transmit per PRACH access channel request. See Uplink Parameters for details.

Setting

Range: 1 to 32

Resolution: 1

Query

Range: 1 to 32

*RST Setting

2

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:PREambles:RCYCles 5"
! Sets the PRACH ramping cycles per PRACH access request to 5.

CALL:UPLink:PRAChannel:SCODe

Function

Sets/queries the uplink physical random access channel's scrambling code. See Uplink Parameters for details.

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

Setting

Range: 0 to 8191

Resolution: 1

Query

Range: 0 to 8191

*RST Setting

0

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:SCODe 5"

CALL:UPLink:PRAChannel:SIGNature

Function

This command is obsolete, please use the CALL:UPLink:PRAChannel:SMASk command instead.

Sets/queries the uplink physical random access channel's preamble signature. Changing this setting changes the CALL:UPLink:PRAChannel:SMASk setting as well.

While in the active cell operating mode, this setting can only be changed when the call status is Idle.

Setting

Range: 0 to15

Resolution: 1

Query

 Same as setting

*RST Setting

0

Requirements

Test Application Revision: A.02 and above, obsolete as of A.05.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:SIGNature 11"
! Set the PRACH signature to 11.

CALL:UPLink:PRAChannel:SMASk

Function

Sets/queries the uplink physical random access channel's signature mask, which represents the available PRACH preamble signatures. See PRACH Signature for details.

While in the active cell operating mode, this setting can only be changed when the call status is Idle.

Setting

Range: 0 to 1111111111111111

(1 to 16 characters from the set 0 and 1)

Query

Range: "0000000000000000" to "1111111111111111"

(The return string is always 16 characters from the set 0 and 1)

*RST Setting

 "0000000000000001"

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:SMASk '0000000000000001'"

CALL:UPLink:PRAChannel:TIMing[:OFFSet]

Function

Sets/queries the uplink physical random access channel's timing offset. See Uplink Timing Offset for details.

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

Setting

Range: -256 to +256

Query

 Same as setting

*RST Setting

0 chips

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:UPLink:TIMing 16"

CALL:UPLink:TXPower:LEVel:MAXimum

Function

Sets/queries Maximum Uplink Transmit Power Level .

Setting

Range: -50 to +33 dBm

Query

 Same as setting

*RST Setting

 33 dBm

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:UPLink:TXPower:LEVel:MAXimum 24"
! Sets Maximum Uplink Transmit Power Level to +24 dBm.


CALL:WAVeform

CALL:WAVeform

Last updated: December 20, 2004

Diagram Conventions

CALL[:CELL[1]]:WAVeform:TYPE:CW

Function

Sets/queries the type of test signals to be output to the currently selected front-panel RF connector while in CW operating mode. See CW Operating Mode for details.

The test signals include:

  • CW generates an unmodulated continuous sine waveform signal.
  • AM generates an amplitude modulated signal with 56% depth and 20 kHz modulation rate.
  • DSB generates a dual side-band suppressed carrier signal with 20 kHz spacing between the two carriers.

When in CW operating mode, switching test signals requires a few seconds. A few seconds of delay is also encountered when changing operating modes if the current test signal is not CW.

Requirements

Test Application Revision: A.04 or above

Lab Application Revision: A.02 or above

Setting

Range: CW|AM|DSB

Query

Range: CW|AM|DSB

*RST Setting

CW

Programming Example

OUTPUT 714;"CALL:WAVeform:TYPE:CW AM"
! Sets the test signal to AM.


IEEE 488.2 Common Commands

IEEE 488.2 Common Commands

Description

*CLS

The *CLS, clear status command, is defined in "IEEE Std 488.2-1992", 10.3. This command will also clear and close the error message screen on the test set's display.

*ESE

The *ESE, standard event status enable command, is defined in "IEEE Std 488.2-1992", 10.10.

*ESE?

The *ESE?, standard event status enable query, is defined in "IEEE Std 488.2-1992", 10.11.

*ESR?

The *ESR?, standard event status register query, is defined in "IEEE Std 488.2-1992 ",10.12.

*IDN?

The *IDN?, identification query, is defined in "IEEE Std 488.2-1992", 10.14.*IDN? is used to retrieve information about the test set in ASCII format.

*IDN?, returns ASCII codes 32 through 126 excluding comma and semicolon in four comma separated fields. Field 1 returns the manufacturer, field 2 returns the instrument model number, field 3 returns the serial number, field 4 returns 0.

*OPC

The *OPC, operation complete command, is defined in "IEEE 488.2-1992", 10.18. *OPC causes the test set to continuously sense the No Operation Pending flag. When the No Operation Pending flag becomes TRUE, the OPC event bit in the standard event status register (ESR) is set to indicate that the state of all pending operations is completed. The *OPC common command is not recommended for use as an overlapped command.

*OPC?

The *OPC?, operation complete query, is defined in "IEEE Std 488.2-1992", 10.19. The *OPC? query allows synchronization between the controller and the test set using either the message available (MAV) bit in the status byte, or a read of the output OPC?. The *OPC? query does not effect the OPC event bit in the Standard Event Status Register (ESR). The *OPC? common command is not recommended for use as an overlapped command.

*OPT?

The *OPT?, option identification query, is defined in "IEEE Std 488.2-1992", 10.20. Each option will have a unique name, that name will be retuned with the query.

*RST

The *RST, full preset command, is defined in "IEEE Std 488.2-1992", 10.32. *RST is the recommended command when performing a full preset on the test set. A *RST restores the majority of settings to their default values.

  • *RST sets trigger arm to single
  • PRESet2 sets trigger arm to continuous

*SRE

The *SRE, service request enable command, is defined in "IEEE Std 488.2-1992", 10.34. The parameter range for this command is 0 through 255.

*SRE?

The *SRE?, service request enable query, is defined in "IEEE Std 488.2-1992", 10.35. Values returned by this query range from 0 through 255.

*STB?

The *STB?, read status byte query, is defined in "IEEE Std 488.2-1992", 10.36. Values returned by this query range from 0 through 255.

*WAI

The *WAI, wait-to-continue command, is defined in "IEEE Std 488.2-1992", 10.39. The *WAI command prevents the test set from executing any further commands or queries until all pending operation flags are false. The *WAI common command is not recommended for use as an overlapped command.

See also

Obtaining Identification Information (*IDN)

Preset Descriptions


DISPlay

DISPlay

Diagram Conventions

DISPlay:BRIGhtness

Function

Sets/queries the test set's display brightness.

A display backlight dimming feature lowers the display brightness after approximately 10 minutes without any manual user interaction with the test set. See Display Backlight Dimming .

Setting

Range: MEDium | HIGH

Query

Range: MED | HIGH

Factory setting

HIGH (this parameter is not affected by any reset operation and can only be changed by direct user access)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"DISPLAY:BRIGHTNESS MEDIUM" !Sets display brightness to medium.

DISPlay:MESSage:MASKable:STATe

Function

Blocks maskable messages from appearing on the test set display screen but not from the Message Log. Maskable messages are reported to the Message Log in either state. See Error Messages .

Setting

Range: On | Off

Query

Range: On | Off

Factory setting

On

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"DISPLAY:MESSAGE:MASKABLE:STATE OFF"
!Prevents certain messages from appearing on the display.

DISPlay:MODE

Function

Sets/queries the test set's display mode.

See Display Mode (Track/Fast) for a description of fast and track display modes.

Setting

 Range: FAST | TRACK

Query

 Range: FAST | TRAC
*RST setting TRACK

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"DISPLAY:MODE FAST" !Sets display mode to fast.

DISPlay:WINDow:ERRor:CLEar

Function

Clears the error message from the display screen but not from the Message Log.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"DISPLAY:WINDOW:ERROR:CLEAR" !Clears an error message from the display.

DISPlay:OPERator:MESSage

Function

 Allows the operator to enter up to four messages, each up to 30 characters in length. These messages will be printed to the display when the command is sent and DISPlay:MODE is set to FAST.

Setting

1|2 |3|4

1=uppermost field, 4=lowermost field
Factory setting Each message is initialized to a null string. Nothing will be displayed until one or more of the four GPIB messages is sent to the test set.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"DISP:OPER:MESS1`Press F6 to stop test'"
!Writes the message "Press F6 to stop test" to the uppermost display field.


DISPlay Subsystem

DISPlay Subsystem

Description

The DISPlay subsystem is used to configure the test set's display mode or display brightness . Use of the DISPlay subsystem is not required to set or query any data or results.

Display Backlight Dimming

The test set's display brightness parameter has two settings at this time, high and medium. The life of the display's backlight will be maximized when brightness is set to medium. The test set has an auto dimming feature that will lower the display brightness automatically if approximately 10 minutes pass without a key being pressed on the test set's front panel. The display will return to the brightness level shown in the Display Brightness field when the test set is set to local and any front panel key is pressed. There is no other user control for this feature.

Syntax Diagram and Command Descriptions

DISPlay


FETCh:AFANalyzer

FETCh:AFANalyzer

Diagram Conventions

FETCh:AFANalyzer[:ALL]?

Function

Queries the AF analyzer measurements.

Measurement results are returned in the following order: integrity, average audio level, average SINAD, average distortion.

Query

Average analog audio level

  • Range: 0 to 20 volts, 9.91 E+37

  • Resolution: The lesser of 4 significant digits or 10 uV

Average SINAD

  • Range:-99 to 99 dB, 9.91 E+37

  • Resolution: 0.01 dB

Average audio distortion

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:ALL?"
!Returns integrity, average audio level, average SINAD,and average audio distortion.

FETCh:AFANalyzer:DISTortion[:AVERage]?

Function

Queries the average audio distortion measurement.

Query

Average audio distortion

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:AVERAGE?"

FETCh:AFANalyzer:DISTortion:ALL?

Function

Queries the audio distortion measurements.

The measurement results are returned in the following order: minimum distortion, maximum distortion, average distortion, standard deviation distortion.

Query

Minimum, maximum, and average audio distortion:

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Standard deviation audio distortion:

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.001%

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:ALL?"
!Returns mininum, maximum, average, and standard deviation audio distortion.

FETCh:AFANalyzer:DISTortion:MAXimum?

Function

Queries the maximum audio distortion.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.01%

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:MAXIMUM?"

FETCh:AFANalyzer:DISTortion:MINimum?

Function

Queries the minimum audio distortion.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.01%

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:MINIMUM?"

FETCh:AFANalyzer:DISTortion:SDEViation?

Function

Queries the standard deviation audio distortion.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.001%

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:SDEVIATION?"

FETCh:AFANalyzer:FREQuency[:AVERage]?

Function

Queries the average audio frequency measurement.

Query

Average audio frequency

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.1 Hz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:AVERAGE?"

FETCh:AFANalyzer:FREQuency:ALL?

Function

Queries the audio frequency measurements.

The measurement results are returned in the following order: minimum frequency, maximum frequency, average frequency, standard deviation frequency.

Query

Minimum, maximum, and average audio frequency:

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.1 Hz

Standard deviation audio frequency:

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.01 Hz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:ALL?"
!Returns mininum, maximum, average, and standard deviation audio frequency.

FETCh:AFANalyzer:FREQuency:MAXimum?

Function

Queries the maximum audio frequency.

Query

Range: 0 to 99999 Hz, 9.91 E+37

Resolution: 0.1 Hz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:MAXIMUM?"

FETCh:AFANalyzer:FREQuency:MINimum?

Function

Queries the minimum audio frequency.

Query

Range: 0 to 99999 Hz, 9.91 E+37

Resolution: 0.1 Hz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:MINIMUM?"

FETCh:AFANalyzer:FREQuency:SDEViation?

Function

Queries the standard deviation audio frequency.

Query

Range: 0 to 99999 Hz, 9.91 E+37

Resolution: 0.01 Hz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:SDEVIATION?"

FETCh:AFANalyzer:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

Query

Range: 0 to 999

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:ICOUNT?"

FETCh:AFANalyzer:INTegrity?

Function

Queries the measurement integrity indicator for the last AF analyzer measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 1 through 16

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANalyzer:INTegrity?"
!Query the inegrity indicator for the AF analyzer results.

FETCh:AFANalyzer:SINAD[:AVERage]?

Function

Queries the average SINAD measurement.

Query

Average SINAD

  • Range:-99 to 99 dB, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:AVERAGE?"

FETCh:AFANalyzer:SINAD:ALL?

Function

Queries the SINAD measurements.

Measurement results are returned in the following order: minimum SINAD, maximum SINAD, average SINAD, and standard deviation SINAD.

Query

Minimum, maximum, average SINAD:

  • Range: -99 to 99 dB, 9.91 E+37

  • Resolution: 0.01 dB

Standard deviation SINAD

  • Range: -99 to 99 dB, 9.91 E+37

  • Resolution: 0.001 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:ALL?"
!Returns mininum, maximum, average, and standard deviation SINAD.

FETCh:AFANalyzer:SINAD:MAXimum?

Function

Queries the maximum SINAD measurements.

Query

Range: -99 to 99 dB, 9.91 E+37

Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:MAXIMUM?"

FETCh:AFANalyzer:SINAD:MINimum?

Function

Queries the minimum SINAD measurements.

Query

Range: -99 to 99 dB, 9.91 E+37

Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:MINIMUM?"

FETCh:AFANalyzer:SINAD:SDEViation?

Function

Queries the standard deviation SINAD measurements.

Query

Range: 0 to 99 dB, 9.91 E+37

Resolution: 0.001 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:SDEVIATION?"

FETCh:AFANalyzer:VOLTage[:AVERage]?

Function

Queries the average audio level measurement.

Query

Range: 0 to 20 volts, 9.91 E+37

Resolution: the lesser of 4 significant digits or 10 uV

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:AVERAGE?"

FETCh:AFANalyzer:VOLTage:ALL?

Function

Queries the audio level measurements.

Measurement results are returned in the following order: minimum audio level, maximum audio level, average audio level, standard deviation audio level.

Query

Range: 0 to 20 V, 9.91 E+37

Resolution: 4 significant digits

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:ALL?"
!Returns minimum, maximum, average, and standard deviation audio level.

FETCh:AFANalyzer:VOLTage:MAXimum?

Function

Queries the maximum audio level measurement.

Query

Range: 0 to 20 V, 9.91 E+37

Resolution: 4 significant digits

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:MAXIMUM?"

FETCh:AFANalyzer:VOLTage:MINimum?

Function

Queries the minimum audio level measurement.

Query

Range: 0 to 20 V, 9.91 E+37

Resolution: 4 significant digits

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:MINIMUM?"

FETCh:AFANalyzer:VOLTage:SDEViation?

Function

Queries the standard deviation audio level measurement.

Query

Range: 0 to 20 V, 9.91 E+37

Resolution: 4 significant digits

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:SDEVIATION?"


FETCh? Subsystem

FETCh? Subsystem

Description

The FETCh? query is a function that allows users to query results from a measurement that was previously INITiated or READ. It does NOT begin a measurement. If no measurement is in progress it will return the integrity and measurement values from the last measurement made, or return an integrity of No Result Available and results of NAN. If a measurement is in process, the query will hang until the results are available, or the measurement fails or times out. The exact results returned with a FETCh? will depend on the specific measurement. A measurement may have a number of different results or combination of results for a FETCh?. The FETCh? queries are intended to be used to provide overlapped operation access to measurement results from the test set. When used along with SETup and INITiate commands , FETCh? is the primary way for the user to retrieve measurement results. In order to use the test set's concurrent test capabilities the overlapped commands of INITiate and FETCh? must be used. Overlapped commands allow the user to send commands and not wait for completion.

Syntax Diagrams and Command Descriptions

FETCh:AFANalyzer (AF Analyzer measurements)

FETCh:FSTability (Frequency Stability measurement)
FETCh:SAUDio (Swept Audio measurement)

FETCh:SMONitor (Spectrum Monitor measurements)

FETCh:WACLeakage (Adjacent Channel Leakage measurements)

FETCh:WBERror (Loopback Bit Error Ratio measurements)
FETCh:WBLerror (Loopback Block Error Ratio measurement)

FETCh:WCDomain (Code Domain measurements)

FETCh:WCPower (Channel Power measurements)

FETCh:WCTFormat (Change Of TFC) Lab App only
FETCh:WDPAnalysis (Dynamic Power Analysis measurement)

FETCh:WILPower (Inner Loop Power measurements)

FETCh:WIQTuning (IQ Tuning measurements)

FETCh:WOBWidth (Occupied Bandwidth measurements)

FETCh:WOOPower (PRACH Transmit On/Off Power measurements)
FETCh:WPDiscon (Phase Discontinuity measurement)
FETCh:WPPAnalysis (PRACH Preamble Analysis measurement) Lab App only

FETCh:WSEMask (Spectrum Emission Mask measurements)

FETCh:WTPower (Thermal Power measurements)

FETCh:WWQuality (Waveform Quality measurements)


FETCh:FSTability

FETCh:FSTability

December 21, 2004

Diagram Conventions

FETCh:FSTability[:ALL]?

Function

Queries the frequency stability measurement. Returns integrity, worst-case frequency error, and average frequency.

Query

Worst-case frequency error:

  • Range: -500 to 500 parts per million (ppm)

  • Resolution: 0.01 ppm

Average frequency:

  • Range: 100 E+6 to 3 E+9 Hz

  • Resolution: 0.01 ppm
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:ALL?"
!Returns integrity, worst-case frequency error, and average frequency.

FETCh:FSTability:FERRor[:WORSt]?

Function

Queries the frequency stability frequency error measurement.

Query

Range: -500 to 500 parts per million (ppm)

Resolution: 0.01 ppm
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:WORST?"

FETCh:FSTability:FERRor:ALL?

Function

Queries the frequency stability frequency error measurements.

Measurement results are returned in the following order: minimum frequency error, maximum frequency error, average frequency error, worst-case frequency error.

Query

Maximum, minimum frequency error:

  • Range: -500 E+3 to 500 E+3 Hz

  • Resolution: 1 Hz

Average frequency error:

  • Range: -500 E+3 to 500 E+3 Hz

  • Resolution: 1 Hz

Worst-case frequency error:

  • Range: -500 to 500 parts per million (ppm)

  • Resolution: 0.01
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:ALL?"
!Returns minimum, maximum, average, and worst-case frequency error.

FETCh:FSTability:FERRor:AVERage?

Function

Queries the average frequency error measurement.

Query

Range: -500 E+3 to 500 E+3 Hz

Resolution: 1 Hz
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:AVERAGE?"

FETCh:FSTability:FERRor:MAXimum?

Function

Queries the maximum frequency error measurement.

Query

Range: -500 E+3 to 500 E+3 Hz

Resolution: 1 Hz
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:MAXIMUM?"

FETCh:FSTability:FERRor:MINimum?

Function

Queries the minimum frequency error measurement.

Query

Range: -500 E+3 to 500 E+3 Hz

Resolution: 1 Hz
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"" !.

FETCh:FSTability:FREQuency[:AVERage]?

Function

Queries the frequency stability average frequency measurement.

Query

Range: 100 E+6 to 3 E+9 Hz

Resolution: 1 Hz
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:AVERAGE?"

FETCh:FSTability:FREQuency:ALL?

Function

Queries the frequency stability frequency measurement.

Measurement results are returned in the following order: minimum frequency, maximum frequency, average frequency, and standard deviation frequency.

Query

Minimum, maximum, average frequency:

  • Range: 100 E+6 to 3 E+9

  • Resolution: 1 Hz

Standard deviation frequency:

  • Range: 0 to 500 E+3 Hz

  • Resolution: 0.1 Hz
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:ALL?"
!Returns minimum, maximum, average, and standard deviation frequency.

FETCh:FSTability:FREQuency:MAXimum?

Function

Queries the maximum frequency stability frequency.

Query

Range: 100 E+6 to 3 E+9

Resolution: 1 Hz
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:MAXIMUM?"

FETCh:FSTability:FREQuency:MINimum?

Function

Queries the minimum frequency stability frequency.

Query

Range: 100 E+6 to 3 E+9

Resolution: 1 Hz
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:MINIMUM?"

FETCh:FSTability:FREQuency:SDEViation?

Function

Queries the standard deviation frequency stability frequency.

Query

Range: 0 to 500 E+3 Hz

Resolution: 0.1 Hz
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:SDEVIATION?"

FETCh:FSTability:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

Query

Range: 0 to 999
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:ICOUNT?"

FETCh:FSTability:INTegrity?

Function

Queries the measurement integrity indicator for the last frequency stability measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 1 through 16
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:INTEGRITY"
!Returns the integrity indicator for the frequency stability measurement.


FETCh:SAUDio

FETCh:SAUDio

December 21, 2004

Diagram Conventions

FETCh:SAUDio[:ALL]?

Function

This query returns the swept audio measurement results. This query returns results in the following order: integrity indicator, average swept audio level and average distortion for the first frequency point, average swept audio level and average distortion for the second frequency point, and so on. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.

For frequencies above 10 kHz, this measurement returns 9.91 E+37.

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Average audio level

  • Range: 1 mV to 20 V, 9.91 E+37
  • Resolution: the lesser of 4 significant digits or 10 uV

Average distortion

  • Range: 0 to 99.9%, 9.91 E+37
  • Resolution: 0.01%

FETCh:SAUDio:DISTortion[:AVERage]?

Function

This query returns a comma separated list of the audio distortion measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.

For frequencies above 10 kHz, this measurement returns 9.91 E+37.

Query

Average audio distortion

  • Range: 0 to 99.9%, 9.91 E+37

  • Resolution: 0.01%

FETCh:SAUDio:DISTortion:MAXimum?

Function | This query returns a comma separated list of the maximum audio distortion measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command. For frequencies above 10 kHz, this measurement returns 9.91 E+37.
Query | Range: 0 to 99.9%, 9.91 E+37 Resolution: 0.01%

FETCh:SAUDio:DISTortion:MINimum?

Function | This query returns a comma separated list of the minimum audio distortion measured at each frequency point in the sweep. For frequencies above 10 kHz, this measurement returns 9.91 E+37.
Query | Range: 0 to 99.9%, 9.91 E+37 Resolution: 0.01%

FETCh:SAUDio:DISTortion:SDEViation?

Function | This query returns a comma separated list of the standard deviation audio distortion measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command. For frequencies above 10 kHz, this measurement returns 9.91 E+37.
Query | Range: 0 to 99.9%, 9.91 E+37 Resolution: 0.001%

FETCh:SAUDio:ICOunt?

Function | This query returns the intermediate count of swept audio multi-measurements completed. The total measurement count is the number of measurements specified in with the multi-measurement count command, SETup:SAUDio:COUNt[:SNUMber] , times the number of frequency points specified with the SETup:SAUDio:FREQuency:POINts . Therefore, when completing a 5 point sweep with multi-measurements turned off, the measurement will return 5 not 1. See also SETup:SAUDio:ICOunt:MAXimum? .
Query | Range: 1 to 999 x 60 Resolution: 1

FETCh:SAUDio:INTegrity?

Function | This query returns the integrity indicator for the last swept audio measurement completed. Zero indicates a normal measurement. See Integrity Indicator for descriptions of non-zero integrity indicators.
Query | Range: See Integrity Indicator . Resolution: 1

FETCh:SAUDio:SINAD[:AVERage]?

Function

This query returns a comma separated list of the average SINAD measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.

Query

Average SINAD

  • Range: -99.99 to 99.99 dB, 9.91 E+37

  • Resolution: 0.01 dB

FETCh:SAUDio:SINAD:MAXimum?

Function | This query returns a comma separated list of the maximum SINAD measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: -99.99 to 99.99 dB, 9.91 E+37 Resolution: 0.01 dB

FETCh:SAUDio:SINAD:MINimum?

Function | This query returns a comma separated list of the minimum SINAD measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: -99.99 to 99.99 dB, 9.91 E+37 Resolution: 0.01 dB

FETCh:SAUDio:SINAD:SDEViation?

Function | This query returns a comma separated list of the standard deviation of SINAD measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: 0 to 99.99 dB, 9.91 E+37 Resolution: 0.001 dB

FETCh:SAUDio:VOLTage[:AVERage]?

Function | This query returns a comma separated list of the average swept audio level measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command. Value is returned in units of V.
Query | Range: 1 mV to 20, 9.91 E+37 Resolution: 4 significant digits

FETCh:SAUDio:VOLTage:MAXimum?

Function | This query returns a comma separated list of the maximum audio voltage measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: 1 mV to 20 V, 9.91 E+37 Resolution: 4 significant digits

FETCh:SAUDio:VOLTage:MINimum?

Function | This query returns a comma separated list of minimum audio voltage measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: 1 mV to 20 V, 9.91 E+37 Resolution: 4 significant digits

FETCh:SAUDio:VOLTage:SDEViation?

Function | This query returns a comma separated list of the standard deviation of audio voltage measured at each point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: 1 mV to 20 V, 9.91 E+37 Resolution: 4 significant digits


FETCh:SMONitor

FETCh:SMONitor

Diagram Conventions

FETCh:SMONitor:INTegrity?

Function | Returns the integrity indicator value for the last spectrum monitor measurement performed. Zero indicates a normal result. See Integrity Indicator for descriptions of non-zero integrity indicators.
Query | Range: See Integrity Indicator . Resolution: 1

FETCh:SMONitor:TRACe?

Function

 Queries the spectrum monitor and returns 401 points representing the amplitude results (in dBm) of the trace data.

Query

Range:

  • For spans of 125 kHz and 500 kHz

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: -50 to +55 dB

  • For all other spans

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: (reference level - 60 dB) to +55 dB


FETCh:WACLeakage

FETCh:WACLeakage

Diagram Conventions

FETCh:WACLeakage[:ALL]?

Function

Queries a adjacent channel leakage ratio (ACLR) measurement result.

This query returns an integrity indicator followed by -5 MHz offset power ratio maximum, +5 MHz offset power ratio maximum, -10 MHz offset power ratio maximum, +10 MHz offset power ratio maximum.

If the multi-measurement state is on, the result represents the average of a number of adjacent channel leakage measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WACLeakage:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WACLEAKAGE:ALL?" !Returns integrity, ACLR measurements.

FETCh:WACLeakage:AVERage[:ALL]?

Function

Queries the average adjacent channel leakage ratio at the following offsets: -5 MHz, +5 MHz, -10 MHz, +10 MHz.

To set the number of measurement to average, use the command SETup:WACLeakage:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WACLEAKAGE:AVERAGE:ALL?"
!Queries the average adjacent channel leakage ratio.

FETCh:WACLeakage:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

To set up multi-measurements, see SETup:WACLeakage:COUNt[:SNUMber] .

Query

Range: 0 to 999

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WACLEAKAGE:ICOUNT?"
!Returns the intermediate count of adjacent channel leakage ratio multi-measurements.

FETCh:WACLeakage:INTegrity?

Function

Queries the measurement integrity indicator for the last adjacent channel leakage measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WACLEAKAGE:INTegrity?"
!Queries the integrity indicator for the adjacent channel leakage ratio results.

FETCh:WACLeakage:SDEViation[:ALL]?

Function

Queries the standard deviation of several adjacent channel leakage ratio measurements at the following offsets: -5 MHz, +5 MHz, -10 MHz, +10 MHz.

To set the number of measurement to compare, use the command SETup:WACLeakage:COUNt[:SNUMber] .

Query

  • Range: 0 to 99 dB, 9.91 E+37

  • Resolution: 0.001 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WACLEAKAGE:SDEVIATION:ALL?"
!Queries the standard deviation of power for the adjacent channel leakage ratio !measurements.


FETCh:WBERror

FETCh:WBERror

Diagram Conventions

FETCh:WBERror<[:ALL]|:INTegrity|:RATio|:COUNt|:BITS>?

Function

Queries the Loopback BER Measurement Results .

[:ALL] returns measurement results in the following order: integrity, bit error ratio, bit error count, bits tested.

Instead of querying [:ALL] results, you may query an individual result using the appropriate keyword (for example, FETCh:WBERror:RATio? returns the bit error ratio result only).
Query

Range

  • Integrity: see Integrity Indicator .
  • Bit Error Ratio: 0 to 99.0000%, 9.91 E+37
  • Bit Error Count: 0 to 999999999, 9.91 E+37
  • Bits Tested: 0 to 999999999, 9.91 E+37

Resolution

  • Integrity: 1
  • Bit Error Ratio: 0.0001%
  • Bit Error Count: 1
  • Bits Tested: 1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WBERROR:ALL?"

FETCh:WBERror:RATio:FAIL?

Function

Queries the Confidence Test Result .

Query

Range:

  • 0 (Pass)
  • 1 (Fail)
  • 2 (Max Bits)
  • 9.91 E+37

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WBERror:RATio:FAIL?"

FETCh:WBERror:CRCerrors?

Function

Queries the CRC Errors result. See CRC Errors .

Query

Range: 0 to 999999, 9.91 E+37

Resolution: 1

Requirements

Test Application Revision: A.04 and above

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCh:WBERror:CRCerrors?"

FETCh:WBERror:ICOunt?

Function

Queries the intermediate count of bits tested.

To set up the total number of bits to test, see SETup:WBERror:COUNt .

Query

Range: 0 to 999999999

Resolution: 1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WBERROR:ICOUNT?"

FETCh:WBERror:LDELay?

Function

Queries the Loopback Delay result.

Loopback Delay results can not be obtained when DL DTCH Data is set to All Zeros or All Ones (see CALL:DTCHannel:DATA ).

Query

Range: 0 to 50 frames, 9.91 E+37

Resolution: 1

Requirements

Test Application Revision: A.04 and above

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCh:WBERror:LDELay?"

FETCh:WBERror:MBLocks?

Function

Queries the Missing Blocks result.

Query

Range: 0 to 999999, 9.91 E+37

Resolution: 1

Requirements

Test Application Revision: A.04 and above

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCh:WBERror:MBLocks?"


FETCh:WBLerror

FETCh:WBLerror

Diagram Conventions

FETCh:WBLerror<[:ALL]|:INTegrity|:RATio|:COUNt|:BLOCks|:MBLocks>?

Function

Queries a block error ratio measurement result.

Measurement results are returned in the following order: integrity, block error ratio, block error count, blocks tested, uplink missing blocks.

These results may also be queried individually using the appropriate command, as indicated in the diagram above. For example, to query the block error ratio result only, use the FETCh:WBLerror:RATio? command.

See Block Error Ratio Measurement Results .
Query

Range

  • Integrity: see Integrity Indicator .
  • Block Error Ratio: 0 to 99%, 9.91 E+37
  • Block Error Count: 0 to 99000, 9.91 E+37
  • Blocks Tested: 0 to 99000, 9.91 E+37
  • Uplink Missing Blocks: 0 to 99000, 9.91 E+37

Resolution

  • Integrity: 1
  • Block Error Ratio: 0.0001%
  • Block Error Count: 1
  • Blocks Tested: 1
  • Uplink Missing Blocks: 1

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"FETCh:WBLerror?"

FETCh:WBLerror:ICOunt?

Function

Queries the intermediate count of blocks tested.

To set up the total number of blocks to test, see SETup:WBLerror:COUNt .

Query

Range: 0 to 99000

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"FETCh:WBLerror:ICOunt?"


FETCh:WCDomain

FETCh:WCDomain

Diagram Conventions

FETCh:WCDomain[:ALL]?

Function

Queries the code domain measurements.

Measurement results are returned in the following order: integrity, EVM maximum, frequency error worst case, origin offset maximum, phase error maximum, worst case timing error, peak code domain error maximum.

Query

Integrity

  • Range: 0 to 23

  • Resolution: 1

EVM Maximum

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Frequency Error worst case

  • Range: -99.99 to 99.99 kHz, 9.91 E+37

  • Resolution: 0.1

Origin Offset Maximum

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error Maximum

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Timing Error Maximum

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Peak Code Domain Error Maximum

  • Range: -99.0 to 0.0 dB, 9.91 E+37

  • Resolution: 0.1

Requirements

Test Application Revision: A.02 and above

Test Application Revision: A.03, timing error is returned in chips instead of seconds

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:ALL?"

FETCh:WCDomain:BETas?

Function

Queries the code domain betas Bc1, Bd1, Bd2, Bd3, Bd4, Bd5, Bd6. Only the control channel (Bc1)and 1 data channel (Bd1) are active. The other betas are reserved for future use. There are no units for the betas relative amplitude levels.

Query

Range: 0 to 1

Resolution: 0.001

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:BETAS?"

FETCh:WCDomain:CERRor:ICHannel[:ALL]?

Function

Queries the code domain error in each of the 256 "I" code channels (0 through 255).

Query

Range: -99 to 0 dB

Resolution: 0.01

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:CERROR:ICHANNEL:ALL?"

FETCh:WCDomain:CERRor:QCHannel[:ALL]?

Function

Queries the code domain error in each of the 256 "Q" code channels (0 through 255).

Query

Range: -99 to 0 dB

Resolution: 0.01

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:CERROR:QCHANNEL:ALL?"

FETCh:WCDomain:EVM?

Function

Queries the maximum error vector magnitude (EVM).

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:EVM?" !Returns maximum EVM.

FETCh:WCDomain:FERRor?

Function

Queries the worst case frequency error.

Query

Range: -99 to 99 kHz, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:FERROR?" !Returns worst case frequency error.

FETCh:WCDomain:INTegrity?

Function

Queries the measurement integrity indicator for the last code domain measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:INTEGRITY?"
!Queries the integrity indicator for the code domain measurement results.

FETCh:WCDomain:MERRor?

Function

Queries the maximum magnitude error.

Query

Range: 0.0 to 99.0%

Resolution: 0.1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:MERRor?" !Returns maximum magnitude error.

FETCh:WCDomain:OOFFset?

Function

Queries the maximum origin offset.

Query

Range: -99 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:OOFFSET?" !Returns maximum origin offset.

FETCh:WCDomain:PCERror[:ALL]?

Function

Queries the peak code domain error measurement. There are four numbers returned for each measurement. The first three numbers describe channel at which the peak error result was measured (channelization code, spread factor, I/Q channel type), and the last number is the peak error.

Results are returned in the following order: channelization code, spread factor, I/Q channel type, and peak code domain error.

Query

Channelization Code

  • Range: 0 to 255, 9.91 E+37

Spread Factor

  • Range: 4 to 256, 9.91 E+37

I/Q Channel Type

  • Range: 0 = I, 1= Q, 9.91 E+37

Peak Code Domain Error

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:PCERROR:ALL?"
!Returns Channelization code, spread factor, I/Q channel type, and peak error.

FETCh:WCDomain:PCERror:CHANnel?

Function

Returns the orthogonal variable spreading factor (OVSF) code number (channelization code) at which the peak code domain error was detected.

Query

Range: 0 to 255

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:PCERROR:CHANNEL?" !Returns channel at which peak error was detected.

FETCh:WCDomain:PCERror:ERRor?

Function

Queries the maximum peak code domain error.

Query

Range: -99 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:PCERROR:ERRor?" !Returns maximum peak code domain error.

FETCh:WCDomainPERRor?

Function

Queries the maximum peak code domain error.

Query

Range: 0 to 180 degrees, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:PERROR?" !Returns maximum phase error.

FETCh:WCDomain:POWer:ICHannel[:ALL]?

Function

Queries the code domain power in each of the 256 "I" code channels (0 through 255).

Query

Range: -99 to 0 dB

Resolution: 0.01

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:POWER:ICHANNEL:ALL?"

FETCh:WCDomain:POWer:QCHannel[:ALL]?

Function

Queries the code domain power in each of the 256 "Q" code channels (0 through 255).

Query

Range: -99 to 0 dB

Resolution: 0.01

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:POWER:QCHANNEL:ALL?"

FETCh:WCDomain:TERRor?

Function

Queries the worst case timing error.

Query

Range: -99.99 to 99.99 chips, 9.91 E+37

Resolution: 0.01 chips

Requirements

Test Application Revision: A.02 and above

Test Application Revision: A.03, timing error is returned in chips instead of seconds

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:TERROR?" !Returns worst case timing error.


FETCh:WCPower

FETCh:WCPower

Diagram Conventions

FETCh:WCPower[:ALL]?

Function

Queries a channel power measurement result.

This query returns an integrity indicator followed by the average channel power measurement result.

If the multi-measurement state is on, the result represents the average of a number of channel power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WCPower:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCPOWER:ALL?" !Returns integrity, channel power measurement.

FETCh:WCPower:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

To set up multi-measurements, see SETup:WCPower:COUNt[:SNUMber] .

Query

Range: 0 to 999

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCPOWER:ICOUNT?"
!Returns the intermediate count of channel power multi-measurements.

FETCh:WCPower:INTegrity?

Function

Queries the measurement integrity indicator for the last channel power measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCPOWER:INTegrity?"
!Queries the integrity indicator for the channel channel power results.

FETCh:WCPower:POWer[:AVERage]?

Function

Queries the average of the results of several channel power measurements. To set the number of measurement to average, use the command SETup:WCPower:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCPOWER:POWER:AVERAGE?"
!Queries the average power for the channel power results.

FETCh:WCPower:POWer:ALL?

Function

Queries the statistical measurement results for several channel power measurements.

To set the number of measurements to gather statistics for, use the command SETup:WCPower:COUNt[:SNUMber] .

Results are returned in the following order: minimum, maximum, average, and standard deviation channel power.

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCPOWER:POWER:ALL?"
!Queries the statistical measurement results for channel power measurement.

FETCh:WCPower:POWer:MAXimum?

Function

Queries the maximum power of several channel power measurements. To set the number of measurement to average, use the command SETup:WCPower:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCPOWER:POWER:MAXIMUM?"
!Queries the inegrity indicator for the channel power results.

FETCh:WCPower:POWer:MINimum?

Function

 Queries the minimum power of several channel power measurements. To set the number of measurement to compare, use the command SETup:WCPower:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCPOWER:POWER:MINIMUM?"
!Queries the minimum channel power.

FETCh:WCPower:POWer:SDEViation?

Function

Queries the standard deviation of several channel power measurements. To set the number of measurement to compare, use the command SETup:WCPower:COUNt[:SNUMber] .

Query

  • Range: 0 to 99 dB, 9.91 E+37

  • Resolution: 0.001 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCPOWER:POWER:SDEVIATION?"
!Queries the standard deviation of power for the channel power measurements.


FETCh:WCTFormat

FETCh:WCTFormat

Last updated: December 22, 2004

This section is only applicable to the lab application.

Diagram Conventions

FETCh:WCTFormat[:ALL]?

Function

Queries a change of TFC measurement result and returns the following comma separated values: Integrity Indicator, Step Down Relative Power (average result if SETup:WCTFormat:COUNt[:SNUMber] is greater than 0), Step Down Error, Step Down Pass/Fail, Step Up Relative Power (average result if SETup:WCTFormat:COUNt[:SNUMber] is greater than 0), Step Up Error, Step Up Pass/Fail.

See Change of TFC Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

Step Down Relative Power

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Step Down Error

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Step Down Pass/Fail

  • Range: 0 (pass), 1 (fail), 9.91E+37

Step Up Relative Power

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Step Up Error

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Step Up Pass/Fail

  • Range: 0 (pass), 1 (fail), 9.91E+37

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat?"

FETCh:WCTFormat:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

To set up multi-measurements, see SETup:WCTFormat:COUNt[:SNUMber] .

Query

Range: 0 to 999

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat:ICOunt?"
! Returns the intermediate count of change of TFC multi-measurements.

FETCh:WCTFormat:INTegrity?

Function

Returns the Integrity Indicator for a change of TFC measurement result.

Query

Range: 0 to the number of available integrity indicators.

Resolution: 1

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat:INTegrity?"

FETCh:WCTFormat:STEP:DOWN:RELative:POWer<[:AVERage]|:ALL|:MAXimum|:MINimum|:SDEViation>?

Function

Queries a change of TFC measurement result and returns the following Step Down Relative Power (in dB) result(s):

  • [:AVERage] - average
  • :ALL - minimum, maximum, average, standard deviation
  • :MAXimum - maximum
  • :MINimum - minimum
  • :SDEViation - standard deviation

To set up multi-measurements, see SETup:WCTFormat:COUNt[:SNUMber] .

Query

Minimum, maximum, average

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Standard deviation

  • Range: 0.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat:STEP:DOWN:RELative:POWer?"
! Returns the Step Down Relative Power average result in dB.

OUTPUT 714;"FETCh:WCTFormat:STEP:DOWN:RELative:POWer:MAXimum?"
! Returns the Step Down Relative Power maximum result in dB.

FETCh:WCTFormat:STEP:DOWN:ERRor?

Function

Queries a change of TFC measurement result and returns the Step Down Error (in dB) result.

Query
  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat:STEP:DOWN:ERRor?"

FETCh:WCTFormat:STEP:DOWN:FAIL?

Function

Queries a change of TFC measurement result and returns the Step Down Pass/Fail result.

Query

 Range: 0 (pass), 1 (fail), 9.91E+37

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat:STEP:DOWN:FAIL?"

FETCh:WCTFormat:STEP:UP:RELative:POWer<[:AVERage]|:ALL|:MAXimum|:MINimum|:SDEViation>?

Function

Queries a change of TFC measurement result and returns the following Step Up Relative Power (in dB) result(s):

  • [:AVERage] - average
  • :ALL - minimum, maximum, average, standard deviation
  • :MAXimum - maximum
  • :MINimum - minimum
  • :SDEViation - standard deviation

To set up multi-measurements, see SETup:WCTFormat:COUNt[:SNUMber] .

Query

Minimum, maximum, average

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Standard deviation

  • Range: 0.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat:STEP:UP:RELative:POWer?"
! Returns the Step Up Relative Power average result in dB.

OUTPUT 714;"FETCh:WCTFormat:STEP:UP:RELative:POWer:MAXimum?"
! Returns the Step Up Relative Power maximum result in dB.

FETCh:WCTFormat:STEP:UP:ERRor?

Function

Queries a change of TFC measurement result and returns the Step Up Error (in dB) result.

Query
  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat:STEP:UP:ERRor?"

FETCh:WCTFormat:STEP:UP:FAIL?

Function

Queries a change of TFC measurement result and returns the Step Up Pass/Fail result.

Query

 Range: 0 (pass), 1 (fail), 9.91E+37

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat:STEP:UP:FAIL?"


FETCh:WDPAnalysis

FETCh:WDPAnalysis

Diagram Conventions

FETCh:WDPAnalysis<[:ALL]|:INTegrity|:STEPs>?

Function

Queries a dynamic power analysis measurement result.

The [:ALL] query returns an integrity indicator, the number of steps measured, and a comma-separated list of average power values for each step measured (in dBm).

You may also query the integrity indicator and number of steps measured using the INTegrity and STEPs mnemonics, respectively.

See Dynamic Power Analysis Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

Number of Steps

  • Range: 0 to 100
  • Resolution: 1

Average Power

  • Range: -99.99 to 99.99 dBm, 9.91E+37
  • Resolution: 0.01 dBm

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:WDPAnalysis?"
! Returns integrity, number of steps measured,
! average power for each step

OUTPUT 714;"FETCh:WDPAnalysis:STEPs?"
! Returns number of steps measured


FETCh:WILPower

FETCh:WILPower

Diagram Conventions

FETCh:WILPower[:ALL]?

Function

Queries the Inner Loop Power measurements. Inner Loop Power Control consists of TPC (Transmit Power Control) commands that are sent to the UE on the downlink to control UE transmitter power on the uplink.

This measurement verifies that the UE derives the transmitter power control command (TPC_cmd) correctly and that the inner loop power control drives the UE to the correct level relative to the adjacent timeslot.

Inner Loop Power measurements are made over the period of time between 25 microsecond transient durations, which begin and end at the timeslot boundaries.

The test set returns absolute and relative-to-previous values for each timeslot and performs aggregate power control measurements over 10 TPC_cmd groups. See FETCh:WILPower:TRACe:REL10TPC?

Measurement results are returned in the following order:

Query

Integrity

  • Range: 0 to 23

  • Resolution: 1

Overall pass/fail

  • Range: 0 to 1

  • Resolution: 1

Worst case slot number (based on each adjacent timeslot measurements)

  • Range: 1 to 150, 9.91 E+37

  • Resolution: 1

Absolute power (based on worst case adjacent timeslot measurements)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Relative power (based on worst case adjacent timeslot measurements)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Worst case slot number (based on worst case Rel Pwr 10 TPC (dB) measurements)

  • Range: 1 to 150, 9.91 E+37

  • Resolution: 1

Absolute power (based on worst case Rel Pwr 10 TPC (dB) measurements)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Relative power (based on worst case Rel Pwr 10 TPC (dB) measurements)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower?"
! Returns all Inner Loop Power control measurement results.

FETCh:WILPower:INTegrity?

Function

Queries the measurement integrity indicator for the last IQ tuning measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

 0 to 23

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower:INT?"
!Returns the Inner Loop Power control integrity indicator

FETCh:WILPower:NSLOTs?

Function

 Returns the number of timeslots tested during the last Inner Loop Power control measurement

Query

Resolution: 1

Range: 1 to 150, 9.91 E+37

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower:NSLOTs?"
!Returns the number of slots tested.

FETCh:WILPower:TRACe[:ABSolute]?

Function

 Returns the absolute power levels of each timeslot measured during the last Inner Loop Power measurement.

Query

Absolute power (for up to 150 timeslots, see FETCh:WILPower:NSLOTs? )

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower:TRACe?"
!Returns the absolute power levels of all timeslots.

FETCh:WILPower:TRACe:RELative?

Function

 Returns the power levels of each timeslot measured during the last Inner Loop Power measurement relative to the adjacent, previous timeslot.

Query

Relative power for up to 150 timeslots. See FETCh:WILPower:NSLOTs? .

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower:TRACe:RELative?"
!Returns the relative power levels of all timeslots.

FETCh:WILPower:TRACe:REL10TPC?

Function

 For each timeslot measured during the last Inner Loop Power measurement, returns the aggregate power level of the previous 10 TPC_cmd groups, relative to the first timeslot in a set of 10 TPC_cmd groups. TPC_cmd groups can occur at a rate of one group per timeslot (Algorithm One) or one group per five-timeslots (Algorithm Two).

The first timeslot that has a 10 TPC measurement result will either be slot 10 (Algorithm One) or slot 50 (Algorithm Two). Timeslots are numbered beginning with zero.

Depending on which algorithm is used and the number of timeslots tested, the number of results returned by this command will vary.

Query

Relative power (for up to 150 timeslots). See FETCh:WILPower:NSLOTs? .

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower:TRACe:REL10TPC?"
! returns the aggregate power level of 10 TPC_cmd groups for
! each timeslot relative to the first timeslot
! in a set of 10 TPC_cmd groups.

FETCh:WILPower:TRACe:MASK?

Function

Returns relative power measurement pass/fail indications for each timeslot based on previous, adjacent timeslot power.

Each pass/fail indication includes a result for both the adjacent and 10 TPC measurements. They are coded as follows:

  • 0 = Both measurements passed
  • 1 = Adjacent timeslot measurement failed
  • 2 = 10 TPC measurement failed
  • 3 = Both measurements failed

Query

Pass/Fail (for up to 150 timeslots). See FETCh:WILPower:NSLOTs? .

  • Range: 0 to 3, 9.91 E+37

  • Resolution: 1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower:TRACe:MASK?"
!returns pass/fail indications for relative power measurements.

FETCh:WILPower:SLOT?<sp><timeslot number>

Function

 Returns the following measurement results in the following order for the timeslot number (timeslots are numbered beginning with 0) specified in the command:

Query

Absolute power

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Relative power (based on the adjacent timeslot measurement)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Relative power (based on Rel Pwr 10 TPC (dB) measurements)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Pass/Fail

  • Range: 0 to 3 (see FETCh:WILPower:TRACe:MASK? for the return value definitions.)

  • Resolution: 1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower:SLOT? 10"
!returns measurement results for timeslot 10.


FETCh:WIQTuning

FETCh:WIQTuning

Diagram Conventions

FETCh:WIQTuning[:ALL]?

Function

Queries the IQ tuning measurement.

Measurement results are returned in the following order: Integrity, EVM (RMS), EVM (peak), Frequency Error, Origin Offset, Phase Error, Magnitude Error, Time Error, Peak Code Domain Error, IQ Gain Imbalance, IQ Phase Imbalance.

Query

Integrity

  • Range: 0 to 23

  • Resolution: 1

EVM (RMS)

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.1

EVM (Peak)

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.1

Frequency Error

  • Range: -99.0 to 99.0 kHz, 9.91 E+37

  • Resolution: 0.1

Origin Offset

  • Range: -99.0 to 0.0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Magnitude Error

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.1

Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Peak Code Domain Error

  • Range: -99.0 to 0 dB, 9.91 E+37

  • Resolution: 0.1

IQ Gain Imbalance

  • Range: -99 to 99, 9.91 E+37

  • Resolution: 0.001 dB

IQ Phase Imbalance

  • Range: 0 to 180, 9.91 E+37

  • Resolution: 0.001 deg

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:ALL?"
! Queries the IQ tuning measurement results.

FETCh:WIQTuning:INTegrity?

Function

Queries the measurement integrity indicator for the last IQ tuning measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:INTegrity?"
!Queries the integrity indicator for the IQ tuning measurement results.

FETCh:WIQTuning:EVM:PEAK?

Function

Queries the peak IQ tuning measurement EVM.

Query

Range: 0 to 99.0%, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WIQTuning:EVM:RMS?" !Returns rms EVM.

FETCh:WIQTuning:EVM[:RMS]?

Function

Queries the rms IQ tuning measurement EVM.

Query

Range: 0 to 99.0%, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WIQTuning:EVM?" !Returns peak EVM.

FETCh:WIQTuning:FERRor?

Function

Queries the IQ tuning measurement frequency error.

Query

Range: -99.0 to 99.0 kHz, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:FERRor?" !Returns frequency error.

FETCh:WIQT:OOFFset?

Function

Queries the IQ tuning measurement origin offset.

Query

Range:-99.0 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:OOFFset?" !Returns origin offset.

FETCh:WIQTuning:PERRor?

Function

Queries the IQ tuning measurement phase error.

Query

  • Range: 0 to 180.0 degrees, 9.91 E+37

  • Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:PERRor?"
!Returns IQ tuning measurement phase error.

FETCh:WIQTuning:MERRor?

Function

Queries the IQ tuning measurement magnitude error.

Query

Range: 0 to 99.0%

Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:MERRor?" !Queries magnitude error.

FETCh:WIQTuning:TERRor?

Function

Queries the IQ tuning measurement timing error.

Query

Range: -99.99 to 99.99 chips, 9.91 E+37

Resolution: 0.01 chips

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:TERRor?" !Returns IQ tuning measurement timing error.

FETCh:WIQTuning:PCERror[:ALL]?

Function

Queries the IQ tuning measurement peak code domain error. There are four numbers returned for each measurement. The first three numbers describe the channel where the peak error result was measured (OVSF channelization code, spreading factor, I/Q channel type), and the last number is the peak error.

Results are returned in the following order: OVFS channelization code, spreading factor, I/Q channel type, and peak code domain error.

Query

Channelization Code

  • Range: 0 to 255, 9.91 E+37

Spread Factor

  • Range: 4 to 256, 9.91 E+37

I/Q Channel Type

  • Range: 0 = I, 1= Q, 9.91 E+37

Peak Code Domain Error

  • Range: -99.0 to 0 dB, 9.91 E+37
  • Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:PCERror?"
!Returns Channelization code, spread factor, I/Q channel type, and peak error.

FETCh:WIQTuning:PCERror:CHANnel?

Function

Returns the orthogonal variable spreading factor (OVSF) code number (channelization code) where the peak code domain error was detected.

Query

Range: 0 to 255, 9.91 E+37

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:PCERror:CHANnel?" !Returns channel where peak error was detected.

FETCh:WIQTuning:PCERror:ERRor?

Function

Queries the IQ tuning measurement peak code domain error.

Query

  • Range: -99.0 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:PCERror:ERRor?"
!Returns peak code domain error.

FETCh:WIQTuning:BETas?

Function

Queries the IQ tuning measurement betas Bc1, Bd1, Bd2, Bd3, Bd4, Bd5, Bd6. Only the control channel (Bc1)and one data channel (Bd1) are active. The other betas are reserved for future use. There are no units for the betas relative amplitude levels.

Query

Range: 0 to 1

Resolution: 0.001

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WIQTuning:BETas?"

FETCh:WIQTuning:IQGain?

Function

Queries the IQ tuning measurement IQ modulator gain imbalance.

Query

Range: -99.0 to +99.0 dB

Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:IQGain?" !Queries the IQ tuning measurment IQ gain imbalance.

FETCh:WIQTuning:IQPhase?

Function

Queries the IQ tuning measurement IQ modulator phase imbalance.

Query

Range: -180.0 to +180.0 deg

Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:IQGain?" !Queries the IQ tuning measurment IQ gain imbalance.

FETCh:WIQTuning:TRACe?

Function

Queries the IQ tuning measurement EVM for each chip up to 2560 chips.

IQ constellation data can be derived from this measurement result.

Query

Range: 0 to 99.0%

Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:TRACe?" !Queries the IQ tuning measurment EVM for 2560 chips.


FETCh:WOBWidth

FETCh:WOBWidth

Diagram Conventions

FETCh:WOBWidth[:ALL]?

Function

Queries an occupied bandwidth measurement result.

This query returns an integrity indicator followed by the average occupied bandwidth measurement result.

If the multi-measurement state is on, the result represents the average of a number of occupied bandwidth measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WOBWidth:COUNt[:SNUMber] .

Query

  • Range: 0.0 to 10.0 MHz, 9.91 E+37

  • Resolution: 0.0001

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WOBWIDTH:ALL?" !Returns integrity, occupied bandwidth measurement.

FETCh:WOBWidth:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

To set up multi-measurements, see SETup:WOBWidth:COUNt[:SNUMber] .

Query

Range: 0 to 999

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WOBWIDTH:ICOUNT?"
!Returns the intermediate count of occupied bandwidth multi-measurements.

FETCh:WOBWidth:INTegrity?

Function

Queries the measurement integrity indicator for the last occupied bandwidth measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WOBWIDTH:INTegrity?"
!Queries the integrity indicator for the channel occupied bandwidth results.

FETCh:WOBWidth:BANDwidth[:AVERage]?

Function

Queries the average of the results of several occupied bandwidth measurements. To set the number of measurement to average, use the command SETup:WOBWidth:COUNt[:SNUMber] .

Query

  • Range: 0.0 to 10.0 MHz, 9.91 E+37

  • Resolution: 0.0001

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WOBWIDTH:BANDWIDTH:AVERAGE?"
!Queries the average power for the occupied bandwidth results.

FETCh:WOBWidth:BANDwidth:ALL?

Function

Queries the statistical measurement results for several occupied bandwidth measurements.

To set the number of measurements to gather statistics for, use the command SETup:WOBWidth:COUNt[:SNUMber] .

Results are returned in the following order: minimum, maximum, average, and standard deviation occupied bandwidth.

Query

  • Range: 0.0 to 10.0 MHz, 9.91 E+37

  • Resolution: 0.0001

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WOBWIDTH:BANDWIDTH:ALL?"
!Queries the statistical measurement results for occupied bandwidth measurement.

FETCh:WOBWidth:BANDwidth:MAXimum?

Function

Queries the maximum bandwidth of several occupied bandwidth measurements. To set the number of measurement to average, use the command SETup:WOBWidth:COUNt[:SNUMber] .

Query

  • Range: 0.0 to 10.0 MHz, 9.91 E+37

  • Resolution: 0.0001

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WOBWIDTH:BANDWIDTH:MAXIMUM?"
!Queries the maximum occupied bandwidth result for statistical measurements.

FETCh:WOBWidth:BANDwidth:MINimum?

Function

 Queries the minimum bandwidth of several occupied bandwidth measurements. To set the number of measurement to compare, use the command SETup:WOBWidth:COUNt[:SNUMber] .

Query

  • Range: 0.0 to 10.0 MHz, 9.91 E+37

  • Resolution: 0.0 to 10.0 MHz

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WOBWIDTH:BANDWIDTH:MINIMUM?"
!Queries the minimum occupied bandwidth result for statistical measurements.

FETCh:WOBWidth:BANDwidth:SDEViation?

Function

Queries the standard deviation of several occupied bandwidth measurements. To set the number of measurement to compare, use the command SETup:WOBWidth:COUNt[:SNUMber] .

Query

  • Range: 0.0 to 10.0 MHz, 9.91 E+37

  • Resolution: 0.0001

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WOBWIDTH:BANDWIDTH:SDEVIATION?"
!Queries the standard deviation of power for the occupied bandwidth measurements.


FETCh:WOOPower

FETCh:WOOPower

Diagram Conventions

FETCh:WOOPower[:ALL]?

Function

Queries the PRACH transmit on/off power measurement results. See PRACH Transmit On/Off Power Measurement Results .

[:ALL] returns measurement results in the following order: Integrity, Pre Burst Off Power level, Pre Burst Off Power pass/fail, Burst On Power, Open Loop Power Error value, Open Loop Power Error pass/fail, Post Burst Off Power level, Post Burst Off Power pass/fail.

Instead of returning [:ALL] results, you may query the result for any particular measurement result individually using the appropriate keywords (for example, FETCh:WOOPower:OFF:PRE[:BURSt]?).

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Query

Integrity: see Integrity Indicator

Pre Burst Off Power level

  • Range: -99.99 to 00.00 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Pre Burst Off Power pass/fail

  • Range: 0 (pass), 1 (fail), 9.91 E+37

Burst On Power

  • Range: -99.99 to 99.99 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Open Loop Power Error value

  • Range: -99.99 to +99.99 dB, 9.91E+37
  • Resolution: 0.01 dB

Open Loop Power Error pass/fail

  • Range: 0 (pass), 1 (fail), 9.91 E+37

Post Burst Off Power level

  • Range: -99.99 to 00.00 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Post Burst Off Power pass/fail

  • Range: 0 (pass), 1 (fail), 9.91 E+37

Programming Example

OUTPUT 714;"FETCh:WOOPower?"
! returns Integrity, Pre Burst Off Power level, Pre Burst Off Power pass/fail,
! Burst On Power, Open Loop Power Error value, Open Loop Power Error pass/fail,
! Post Burst Off Power level, Post Burst Off Power pass/fail

OUTPUT 714;"FETCh:WOOPower:INTegrity?"
! returns Integrity

OUTPUT 714;"FETCh:WOOPower:OFF:PRE?"
! returns Pre Burst Off Power level


FETCh:WPDiscon

FETCh:WPDiscon

Diagram Conventions

FETCh:WPDiscon[:ALL]?

Function

Queries a phase discontinuity measurement result and returns the following comma separated values: Integrity Indicator, Number of Slots Measured, Worst Case Phase Discontinuity Slot Number, Worst Case Phase Discontinuity in degrees, Worst Case EVM Slot Number, Worst Case EVM in % rms.

See Phase Discontinuity Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

Number of Slots Measured

  • Range: 2 to 91, 9.91E+37
  • Resolution: 1

Worst Case Phase Discontinuity Slot Number

  • Range: 0 to 90, 9.91E+37
  • Resolution: 1

Worst Case Phase Discontinuity

  • Range: -180.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Worst Case EVM Slot Number

  • Range: 0 to 90, 9.91E+37
  • Resolution: 1

Worst Case EVM

  • Range: 0.0 to 99.0% rms, 9.91E+37
  • Resolution: 0.1% rms

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:WPDiscon?"
! Returns Integrity Indicator, Number of Slots Measured,
! Worst Case Phase Discontinuity Slot Number, Worst Case Phase Discontinuity in degrees,
! Worst Case EVM Slot Number, Worst Case EVM in % rms

FETCh:WPDiscon:INTegrity?

Function

Returns the Integrity Indicator for a phase discontinuity measurement result.

See Phase Discontinuity Measurement Description .

Query

 Range: See Integrity Indicator .

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:WPDiscon:INTegrity?"

FETCh:WPDiscon:SLOT?<sp><slot num>

Function

Queries a phase discontinuity measurement result and returns the following comma separated values for the slot specified by <slot num>: Integrity Indicator, Phase Discontinuity in degrees, Phase in degrees, Power in dBm, EVM in % rms, Phase Error in degrees, Frequency Error in Hz,
Magnitude Error in %, Timing Error in chips, Origin Offset in dB.

<Slot num> range is 0 to 90.

See Phase Discontinuity Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

Phase Discontinuity

  • Range: -180.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Phase

  • Range: -180.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Power

  • Range: -99.0 to 99.0 dBm, 9.91E+37
  • Resolution: 0.1 dBm

EVM

  • Range: 0.0 to 99.0% rms, 9.91E+37
  • Resolution: 0.1% rms

Phase Error

  • Range: 0.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Frequency Error

  • Range: -99.0000 to +99.0000 kHz, 9.91E+37
  • Resolution: 0.1 Hz

Magnitude Error

  • Range: 0.0 to 99.0%, 9.91E+37
  • Resolution: 0.1%

Timing Error

  • Range: -99.00 to 99.00 chips, 9.91E+37
  • Resolution: 0.01 chips

Origin Offset

  • Range: -99.0 to 0.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:WPDiscon:SLOT? 3"
! Returns the following results for slot 3 (the fourth slot measured): Integrity Indicator,
Phase Discontinuity in degrees, Phase in degrees, Power in dBm, EVM in % rms,
Phase Error in degrees, Frequency Error in Hz, Magnitude Error in %,
Timing Error in chips, Origin Offset in dB

FETCh:WPDiscon:TRACe?<sp>DISC|PHASE|POW|EVM|PERR|FERR|MERR|TERR|OOFF

Function

Queries a phase discontinuity result and returns a comma separated list of values (one for each slot measured) for the measurement result indicated by appending the following to the query:

  • DISC (phase discontinuity)
  • PHASE (phase)
  • POW (power)
  • EVM (EVM)
  • PERR (phase error)
  • FERR (frequency error)
  • MERR (magnitude error)
  • TERR (timing error)
  • OOFF (origin offset)

See Phase Discontinuity Measurement Results .

The Number of Slots Measured can be determined by the FETCh:WPDiscon[:ALL]? command.

Query

 Range/Resolution: See FETCh:WPDiscon:SLOT?<sp><slot num> for the range and resolution of the various measurement results.

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:WPDiscon:TRACe? DISC"
! Returns comma separated list of phase discontinuity results
! for each slot measured.

OUTPUT 714; "FETCh:WPDiscon:TRACe? EVM"
! Returns comma separated list of EVM results for each slot measured.


FETCh:WPPAnalysis

FETCh:WPPAnalysis

This section is applicable to the lab application only.

Diagram Conventions

FETCh:WPPAnalysis<[:ALL]|:INTegrity|:EVM[:RMS]|:EVM:PEAK|:FERRor|:OOFFset|:PERRor|:MERRor|:TERRor|:IQGain|:IQPHase|:SIGNAture>?

Function

The [:ALL] mnemonic queries a PRACH preamble analysis measurement result and returns the following comma separated values: Integrity Indicator, EVM (rms) in % rms, EVM (peak) in %, Frequency Error in Hz, Origin Offset in dB, Phase Error (rms) in degrees, Magnitude Error in %, Timing Error in chips, IQ Gain Imbalance in dB, IQ Phase Imbalance in degrees, Signature.

You may also query the individual measurement results using the appropriate mnemonic.

See PRACH Preamble Analysis Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

EVM (rms)

  • Range: 0.0 to 100.0% rms, 9.91E+37
  • Resolution: 0.1% rms

EVM (peak)

  • Range: 0.0 to 100.0%, 9.91E+37
  • Resolution: 0.1%

Frequency Error

  • Range: -9.999 kHz to +9.999 kHz, 9.91E+37
  • Resolution: 0.1 Hz

Origin Offset

  • Range: -100.0 to 0.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Phase Error

  • Range: -180.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Magnitude Error

  • Range: 0.0 to 100.0%, 9.91E+37
  • Resolution: 0.1%

Timing Error

  • Range: -383.62 to +383.62 chips, 9.91E+37
  • Resolution: 0.01 chips

IQ Gain Imbalance

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

IQ Phase Imbalance

  • Range: -180.0 to 180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Signature

  • Range: 0 to 15, 9.91E+37
  • Resolution: 1

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:WPPAnalysis?"
! Returns Integrity Indicator, EVM (rms) in % rms, EVM (peak) in %,
! Frequency Error in Hz, Origin Offset in dB, Phase Error (rms) in degrees,
! Magnitude Error in %, Timing Error in chips, IQ Gain Imbalance in dB,
! IQ Phase Imbalance in degrees, Signature

OUTPUT 714;"FETCh:WPPAnalysis:EVM?"
! Returns EVM (rms) in % rms.

FETCh:WPPAnalysis:TRACe<:EVM|:PHASe|:IQ|:POWer>?

Function

Queries a PRACH preamble analysis result and returns: number of chips measured, relative chip location of the first data point, and a variable length list of measured data for the measurement result indicated by appending:

  • EVM (EVM in %)
  • PHASe (Relative Phase in degrees)
  • IQ (IQ Constellation)
  • POWer (Relative Power in dB)
to the query.

For EVM, relative phase and relative power, one data point is returned for each chip measured (maximum is 4096 data points for EVM and relative phase, 4296 data points for relative power). For IQ constellation, two data points are returned for each chip measured (maximum is 2 x 4096 data points).

See PRACH Preamble Analysis Measurement Results .

Query

EVM

  • Range: 0.0 to 100.0% rms, 9.91E+37
  • Resolution: 0.1% rms

Relative Phase

  • Range: -180.0 to 180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

IQ Constellation

  • Range: -1.0000 to 1.0000, 9.91E+37
  • Resolution: 0.0001

Relative Power

  • Range: -100.0 to 0.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:WPPAnalysis:TRACe:EVM?"
! Returns number of chips measured, relative chip location of the first data point,
! and a maximum of 4096 EVM values (one for each chip measured).


FETCh:WSEMask

FETCh:WSEMask

Diagram Conventions

FETCh:WSEMask:[:ALL]?

Function

Returns the spectrum emissions mask measurement results.

Measurement results are returned in the following order: integrity, overall pass/fail (0 = pass, 1 = fail, 9.91 E+37 = no result available), in-channel power (in dBm/3.84 MHz), and pass/fail results for frequency ranges 1, 2, 3, and 4.

In-channel power is returned in dBm/3.84 MHz.

The four frequency ranges for this measurement are as follows:

  • Range 1: +/- 2.5 to 3.5 MHz
  • Range 2: +/- 3.5 to 7.5 MHz
  • Range 3: +/- 7.5 to 8.5 MHz
  • Range 4: +/- 8.5 to 12.5 MHz

If the multi-measurement state is on, the result represents the average of a number of spectrum emission measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WSEMask:COUNt[:SNUMber] .

Query

Range: -99.00 to +99.00 dBc

Resolution: 0.01

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:ALL?"

FETCh:WSEMask:BAND[:ALL]?

Function

Returns the power level vectors relative to in-channel power for all of the bands. Results are in dBc. The total number of results returned is 266.

Query

Range: -99.00 to +99.00 dBc

Resolution: 0.01

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:BAND:ALL?"

FETCh:WSEMask:BAND:LOWer[1]?

Function

Returns the power level vectors relative to in-channel power for the specified band. Results are in dBc. Result vector size is as follows:

  • LOWer 4: -12.000 to -8.500 MHz (step size 250 kHz, BW 1 MHz) 1:15
  • LOWer 3: -8.500 to -7.500 MHz (step size 250 kHz, BW 1 MHz) 1:5
  • LOWer 2: -7.500 to -4.000 MHz (step size 250 kHz, BW 1 MHz) 1:15
  • LOWer[1]: -3.485 to -2.515 MHz (step size 10 kHz, BW 30 kHz) 1:98

Query

Range: -99.00 to +99.00 dBc

Resolution: 0.01

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:BAND:LOW2?"

FETCh:WSEMask:BAND:UPPer[1]?

Function

Returns the power level vectors relative to in-channel power for the specified band. Results are in dBc. Result vector size is as follows:

  • UPPer[1]: 2.515 to 3.485 MHz (step size 10 kHz, BW 30 kHz) 1:98
  • UPPer 2: 4.000 to 7.500 MHz (step size 250 kHz, BW 1 MHz) 1:15
  • UPPer 3: 7.500 to 8.500 MHz (step size 250 kHz, BW 1 MHz) 1:5
  • UPPer 4: 8.500 to 12.000 MHz (step size 250 kHz, BW 1 MHz) 1:15

Query

Range: -99.00 to +99.00 dBc

Resolution: 0.01

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:BAND:UPP?"
! Returns power level in the UPPer1 band.

FETCh:WSEMask:FAIL?

Function

Queries the measurement integrity and the overall pass/fail result for the spectrum emissions mask measurement.

Measurement results are returned in the following order: integrity, overall pass/fail (0 = Pass, 1 = Fail)

Query

Range: 0|1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:FAIL?"

FETCh:WSEMask:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

To set up multi-measurements, see SETup:WSEMask:COUNt[:SNUMber] .

Query

Range: 0 to 999

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:ICOUNT?"
!Returns the intermediate count of spectrum emissions mask multi-measurements.

FETCh:WSEMask:ICPower?

Function

Queries the in-channel absolute power. To set the number of measurement to average, use the command SETup:WSEMask:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:ICPOWER?"
!Queries the in-channel power for the spectrum emissions mask results.

FETCh:WSEMask:INTegrity?

Function

Queries the measurement integrity indicator for the last spectrum emissions mask measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:INTegrity?"
!Queries the integrity indicator for the channel spectrum emissions mask results.

FETCh:WSEMask:RANGe[:ALL]?

Function

Returns the following for each of the four measurement ranges: level (in dBc), frequency offset (in MHz), mask margin (in dB), pass fail result.

The level results are the relative power that is associated with the largest mask error in the range. Fail is indicated anytime the mask offset is negative.

Query

Level

  • Range: -99.00 to +99.00 dBc, 9.91 E+37
  • Resolution: 0.01

Frequency Offset

  • Range 1: +/- 2.515 to 3.485 MHz
  • Range 2: +/- 4.000 to 7.500 MHz
  • Range 3: +/- 7.500 to 8.500 MHz
  • Range 4: +/- 8.500 to 12.500 MHz
  • Resolution, all ranges: 0.001

Mask Margin

  • Range: -99.00 to +99.00 dB, 9.91 E+37
  • Resolution: 0.01 dB

Pass/Fail Result

  • Range: 0 = pass, 1 =f fail, 9.91 E+37 = undetermined

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:RANGE:ALL?"

FETCh:WSEMask:RANGe:RANGe[1]?

Function

Returns the following results for the specified range: level (in dBc), frequency offset (in MHz), mask margin (in dB), pass/fail result.

Query

Level

  • Range: -99.00 to +99.00 dBc, 9.91 E+37
  • Resolution: 0.01

Frequency Offset

  • Range 1: +/- 2.515 to 3.485 MHz
  • Range 2: +/- 4.000 to 7.500 MHz
  • Range 3: +/- 7.500 to 8.500 MHz
  • Range 4: +/- 8.500 to 12.500 MHz
  • Resolution, all ranges: 0.001

Mask Margin

  • Range: -99.00 to +99.00 dB, 9.91 E+37
  • Resolution: 0.01 dB

Pass/Fail Result

  • Range: 0 = pass, 1 =fail, 9.91 E+37 = undetermined

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:RANGE:RANG3?"
! Returns power level in the range 3.


FETCh:WTPower

FETCh:WTPower

Diagram Conventions

FETCh:WTPower[:ALL]?

Function

Queries a thermal power measurement result.

This query returns an integrity indicator followed by a thermal power measurement result (if results are available).

If the multi-measurement state is on, the result represents the average of a number of thermal power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WTPower:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WTPOWER:ALL?" !Returns integrity, thermal power.

FETCh:WTPower:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

The multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WTPower:COUNt[:SNUMber]

Query

Range: 0 to 999

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WTPOWER:ICOUNT?"

FETCh:WTPower:INTegrity?

Function

Queries the measurement integrity indicator for the last thermal power measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 1 through 16

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WTPOWER:INTegrity?"
!Queries the inegrity indicator for the thermal power results.

FETCh:WTPower:POWer[:AVERage]?

Function

Queries the average of the results of several thermal power measurements. To set the number of measurement to average, use the command SETup:WTPower:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WTPOWER:POWER:AVERAGE?"
!Queries the thermal power for the thermal power results.

FETCh:WTPower:POWer:ALL?

Function

Queries the statistical measurement results for several thermal power measurements.

To set the number of measurements to gather statistics for, use the command SETup:WTPower:COUNt[:SNUMber] .

Results are returned in the following order: minimum, maximum, average, and standard deviation thermal power.

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WTPOWER:POWER:ALL?"
!Queries the statistical measurement results for thermal power measurement.

FETCh:WTPower:POWer:MAXimum?

Function

Queries the maximum power of several thermal power measurements. To set the number of measurement to average, use the command SETup:WTPower:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WTPOWER:POWER:MAXIMUM?"
!Queries the inegrity indicator for the thermal power results.

FETCh:WTPower:POWer:MINimum?

Function

 Queries the minimum power of several thermal power measurements. To set the number of measurement to compare, use the command SETup:WTPower:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WTPOWER:POWER:MINIMUM?"
!Queries the minimum thermal power.

FETCh:WTPower:POWer:SDEViation?

Function

Queries the standard deviation of several thermal power measurements. To set the number of measurement to compare, use the command SETup:WTPower:COUNt[:SNUMber] .

Query

  • Range: 0 to 99 dB, 9.91 E+37

  • Resolution: 0.001 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WTPOWER:POWER:SDEVIATION?"
!Queries the standard deviation of power for the thermal power measurements.


FETCh:WWQuality

FETCh:WWQuality

Diagram Conventions

FETCh:WWQuality[:ALL]?

Function

Queries the waveform quality measurements.

Measurement results are returned in the following order: integrity, EVM maximum, worst case frequency error, origin offset maximum, phase error maximum, magnitude error maximum, worst case timing error, and peak code domain error maximum.

If the multi-measurement state is on, each result represents the average of a number of waveform quality measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WWQuality:COUNt[:SNUMber] .

Query

Integrity

  • Range: 0 to 23

  • Resolution: 1

EVM Maximum

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.1

Frequency Error worst case

  • Range: -99.0 to 99.0 kHz, 9.91 E+37

  • Resolution: 0.1

Origin Offset Maximum

  • Range: -99.0 to 0.0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error Maximum

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Magnitude Error Maximum

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.1

Timing Error Worst Case

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Peak Code Domain Error Maximum

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Requirements

Test Application Revision: A.01 and above

Test Application Revision: A.02 added peak code domain error and timing error

Test Application Revision: A.02.25, timing error is returned in chips instead of seconds.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:ALL?"

FETCh:WWQuality:BETas?

Function

Queries the waveform quality betas Bc1, Bd1, Bd2, Bd3, Bd4, Bd5, Bd6. Only the control channel (Bc1)and 1 data channel (Bd1) are active. The other betas are reserved for future use. There are no units for the betas relative amplitude levels.

Query

Range: 0 to 1

Resolution: 0.001

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:BETAS?"

FETCh:WWQuality:EVM[:MAXimum]?

Function

Queries the maximum EVM.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:EVM:MAXIMUM?"
! Returns maximum EVM.

FETCh:WWQuality:EVM:ALL?

Function

Queries the EVM measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation error vector magnitude.

Query

Minimum EVM

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Maximum EVM

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Average EVM

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Standard Deviation EVM

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:EVM:ALL?"
! Returns all EVM measurement results.

FETCh:WWQuality:EVM:AVERage?

Function

Queries the average EVM.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:EVM:AVERAGE?"
! Returns average EVM.

FETCh:WWQuality:EVM:MINimum?

Function

Queries the minimum EVM.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:EVM:MINIMUM?"
! Returns mininum EVM.

FETCh:WWQuality:EVM:SDEViation?

Function

Queries the standard deviation of results for EVM measurements.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:EVM:SDEVIATION?"
! Returns standard deviation EVM.

FETCh:WWQuality:FERRor[:WORSt]?

Function

Queries the worst case frequency error. (The test set returns either the Minimum or Maximum Frequency Error result, whichever is furthest from zero).

Query

Range: -99 to 99 kHz, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:FERROR:WORSt?"
! Returns worst case frequency error.

FETCh:WWQuality:FERRor:ALL?

Function

Queries the frequency error measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation and worst case frequency error.

Query

Minimum Frequency Error

  • Range: -99 to 99 kHz, 9.91 E+37

  • Resolution: 0.1

Maximum Frequency Error

  • Range: -99 to 99 kHz, 9.91 E+37

  • Resolution: 0.1

Average Frequency Error

  • Range: -99 to 99 kHz, 9.91 E+37

  • Resolution: 0.1

Standard Deviation Frequency Error

  • Range: -99 to 99 kHz, 9.91 E+37

  • Resolution: 0.01

Worst Case Frequency Error

  • Range: -99 to 99 kHz, 9.91 E+37

  • Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:FERROR:ALL?"
! Returns mininum, maximum, average,
! standard deviation and worst case frequency error.

FETCh:WWQuality:FERRor:AVERage?

Function

Queries the average frequency error.

Query

Range: -99 to 99 kHz, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:FERROR:AVERAGE?"
! Returns average frequency error.

FETCh:WWQuality:FERRor:MAXimum?

Function

Queries the average frequency error.

Query

Range: -99 to 99 kHz, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:FERROR:MAXIMUM?"
! Returns maximum frequency error.

FETCh:WWQuality:FERRor:MINimum?

Function

Queries the minimum frequency error.

Query

Range: -99 to 99 kHz, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:FERROR:MINIMUM?"
! Returns minimum frequency error.

FETCh:WWQuality:FERRor:SDEViation?

Function

Queries the standard deviation of frequency error measurements.

Query

Range: 0 to 99 kHz, 9.91 E+37

Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:FERROR:SDEViation?"
! Returns standard deviation frequency error.

FETCh:WWQuality:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

Query

Range: 0 to 999

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:ICOUNT?"

FETCh:WWQuality:INTegrity?

Function

Queries the measurement integrity indicator for the last waveform quality measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:INTEGRITY?"
!Queries the integrity indicator for the channel channel power results.

FETCh:WWQuality:MERRor[:MAXimum]?

Function

Queries the average magnitude error.

Query

Range: 0 to 99%

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:MERRor:MAXIMUM?"
! Returns maximum magnitude error.

FETCh:WWQuality:MERRor:ALL?

Function

Queries the magnitude error measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation magnitude error.

Query

Minimum Magnitude Error

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Maximum Magnitude Error

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Average Magnitude Error

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Standard Deviation Magnitude Error

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:MERRor:ALL?"
! Returns mininum, maximum, average, and
! standard deviation magnitude error.

FETCh:WWQuality:MERRor:AVERage?

Function

Queries the average magnitude error.

Query

Range: 0 to 99%

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:MERRor:AVERAGE?"
! Returns average magnitude error.

FETCh:WWQuality:MERRor:MINimum?

Function

Queries the minimum magnitude error.

Query

Range: 0 to 99%

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:MERRor:MINIMUM?"
! Returns minimum magnitude error.

FETCh:WWQuality:MERRor:SDEViation?

Function

Queries the standard deviation of magnitude error measurements.

Query

Range: 0 to 99%

Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:MERRor:SDEVIATION?"
! Returns standard deviation magnitude error.

FETCh:WWQuality:OOFFset[:MAXimum]?

Function

Queries the average origin offset.

Query

Range:-99 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:OOFFSET:MAXIMUM?"
! Returns maximum origin offset.

FETCh:WWQuality:OOFFset:ALL?

Function

Queries the origin offset measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation origin offset.

Query

Minimum Origin Offset

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Maximum Origin Offset

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Average Origin Offset

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Standard Deviation Origin Offset

  • Range: 0 to 99 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:OOFFSET:ALL?"
! Returns mininum, maximum, average, and
! standard deviation origin offset.

FETCh:WWQuality:OOFFset:AVERage?

Function

Queries the average origin offset.

Query

Range: -99 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:OOFFSET:AVERAGE?"
! Returns average origin offset.

FETCh:WWQuality:OOFFset:MINimum?

Function

Queries the minimum origin offset.

Query

Range:-99 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:OOFFSET:MINIMUM?"
! Returns minimum origin offset.

FETCh:WWQuality:OOFFset:SDEViation?

Function

Queries the standard deviation of results for origin offset measurements.

Query

Range: 0 to 99 dB, 9.91 E+37

Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:OOFFSET:SDEVIATION?"
! Returns standard deviation origin offset.

FETCh:WWQuality:PCERror[:ALL]?

Function

Queries the peak code domain error measurement. There are four number returned for each measurement. The first three numbers describe channel at which the peak error result was measured (OVFS channelization code, spreading factor, I/Q channel type), and the last number is the peak error.

Results are returned in the following order: OVFS channelization code, spreading factor, I/Q channel type, and peak code domain error.

Query

Channelization Code

  • Range: 0 to 255, 9.91 E+37

Spread Factor

  • Range: 4 to 256, 9.91 E+37

I/Q Channel Type

  • Range: 0 = I, 1= Q, 9.91 E+37

Peak Code Domain Error

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Requirements

Test or Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:PCERROR:ALL?"
! Returns Channelization code, spread factor, I/Q channel type, and peak error.

FETCh:WWQuality:PCERror:CHANnel?

Function

Returns information about the channel at which the peak code domain error result occurred. The following three results are returned: OVFS channelization code, spreading factor and I/Q channel type.

Query

Channelization Code

  • Range: 0 to 255, 9.91 E+37

Spread Factor

  • Range: 4 to 256, 9.91 E+37

I/Q Channel Type

  • Range: 0 = I, 1= Q, 9.91 E+37

Requirements

Test or Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:PCERROR:CHANNEL?"
! Returns channel at which peak error was detected.

FETCh:WWQuality:PCERror:MAXimum?

Function

Queries the maximum peak code domain error.

Query

Range: -99 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:PCERROR:MAXIMUM?"
! Returns maximum peak code domain error.

FETCh:WWQuality:PERRor[:MAXimum]?

Function

Queries the maximum phase error measurement.

Query

Range: 0 to 180 degrees, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:PERROR:MAXIMUM?"
! Returns maximum phase error.

FETCh:WWQuality:PERRor:ALL?

Function

Queries the phase error measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation phase error.

Query

Minimum Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Maximum Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Average Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Standard Deviation Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:PERROR:ALL?"
! Returns mininum, maximum, average, and
! standard deviation phase error.

FETCh:WWQuality:PERRor:AVERage?

Function

Queries the average phase error.

Query

Range: 0 to 180 degrees, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:PERROR:AVERAGE?"
! Returns average phase error.

FETCh:WWQuality:PERRor:MINimum?

Function

Queries the minimum phase error.

Query

Range: 0 to 180 degrees, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:PERROR:MINIMUM?"
! Returns minimum phase error.

FETCh:WWQuality:PERRor:SDEViation?

Function

Queries the standard deviation of results for phase error measurements.

Query

Range: 0 to 180 degrees, 9.91 E+37

Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:PERROR:SDEVIATION?"
! Returns standard deviation phase error.

FETCh:WWQuality:TERRor[:WORSt]?

Function

Queries the worst case timing error. (The test set returns either the Minimum or Maximum Timing Error result, whichever is furthest from zero).

Query

Range: -99.99 to 99.99 chips, 9.91 E+37

Resolution: 0.01 chips

Requirements

Test Application Revision: A.02 and above

Test Application Revision: A.02.25, timing error is returned in chips instead of seconds

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:TERROR:WORSt?"
! Returns worst case timing error.

FETCh:WWQuality:TERRor:ALL?

Function

Queries the timing error measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation timing error.

Query

Minimum Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Maximum Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Average Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Standard Deviation Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Requirements

Test Application Revision: A.02 and above

Test Application Revision: A.02.25, timing error is returned in chips instead of seconds

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:TERROR:ALL?"
! Returns mininum, maximum, average, and
! standard deviation timing error.

FETCh:WWQuality:TERRor:AVERage?

Function

Queries the average timing error.

Query

Range: -99.99 to 99.99 chips, 9.91 E+37

Resolution: 0.01 chips

Requirements

Test Application Revision: A.02 and above

Test Application Revision: A.02.25, timing error is returned in chips instead of seconds

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:TERROR:AVERAGE?"
! Returns average timing error.

FETCh:WWQuality:TERRor:MAXimum?

Function

Queries the average timing error.

Query

Range: -99.99 to 99.99 chips, 9.91 E+37

Resolution: 0.01 chips

Requirements

Test Application Revision: A.02 and above

Test Application Revision: A.02.25, timing error is returned in chips instead of seconds

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:TERROR:MAXIMUM?"
! Returns maximum timing error.

FETCh:WWQuality:TERRor:MINimum?

Function

Queries the minimum timing error.

Query

Range: -99.99 to 99.99 chips, 9.91 E+37

Resolution: 0.01 chips

Requirements

Test Application Revision: A.02 and above

Test Application Revision: A.02.25, timing error is returned in chips instead of seconds

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:TERROR:MINIMUM?"
! Returns minimum timing error.

FETCh:WWQualityTERRor:SDEViation?

Function

Queries the standard deviation of timing error measurements.

Query

Range: 0 to 99.99 chips, 9.91 E+37

Resolution: 0.01 chips

Requirements

Test Application Revision: A.02 and above

Test Application Revision: A.02.25, timing error is returned in chips instead of seconds

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:TERROR:SDEViation?"
! Returns standard deviation time error.


INITiate

INITiate

Diagram Conventions

INITiate:<measurement mnemonic>[:ON]

Function

These commands initiate (start) the following measurements:

  • AFANalyzer - Audio Frequency Analyzer measurements
  • FSTability - Frequency Stability measurement
  • SAUDio - Swept Audio measurement
  • SMONitor - Spectrum Monitor measurement
  • WACLeakage - Adjacent Channel Leakage
  • WBERror - Loopback Bit Error Ratio measurement
  • WBLerror - Block Error Ratio measurement
  • WCDomain - Code Domain measurements
  • WCPower - Channel Power measurement
  • WCTFormat - Change of TFC
  • WDPAnalysis - Dynamic Power Analysis
  • WILPower - Inner Loop Power measurement
  • WIQTuning - IQ Tuning measurement
  • WOBWidth - Occupied Bandwidth measurement
  • WOOPower - PRACH Transmit On/Off Power measurement
  • WOOSynch - Out-of-Synch Handling of Output Power measurement
  • WPDiscon - Phase Discontinuity
  • WPPAnalysis - PRACH Preamble Analysis (lab application only)
  • WSEMask - Spectrum Emission Mask measurement
  • WTPower - Thermal Power measurement
  • WWQuality - Waveform Quality measurement

This command also queries the active state using the ON? keyword in place of a measurement mnemonic.

The INITiate command is associated with the SETup SETup Subsystem and the FETCh? Subsystem .

One or more measurements can be initiated with the same program line (see Concurrent Measurements and the Programming Example below).

This command is also used to activate a measurement. See INITiate Programming Examples (how INIT commands are used) .

Requirements

Test Application Revision A.01 and above.

Test Application Revision A.02 and above, added WCDomain, WSEMask, and WOBWidth.

Test Application Revision A.03 and above, added WIQTuning, WILPower, WOOPower, and SMONitor.

Test Application Revision A.05 and above added WBLerror, WDPAnalysis and WPDiscon.

Test Application Revision A.06 and above added FSTability

Lab Application Revision: A.01 and above.

Lab Application Revision B.01 and above added WBLerror, WDPAnalysis, WPDiscon, and WPPAnalysis.

Lab Application Revision C.01 and above added FSTability, WCTFormat and WOOSynch.

Programming Example

OUTPUT 714;"INITIATE:WCPOWER;WQUALITY:ON"
! Initiates a channel power and a waveform quality measurement.

INITiate:ON?

Function

Queries the measurements that are on. Returns a comma separated list of measurement mnemonics.

Query

Range: AFAN|FST|SAUD|SMON|WACL|WBER|WBL|WCD|WCP|WCTF**|WDPA
|WILP|WIQT|WOBW|WOOP|WOOS**|WPD|WPPA**|WSEM|WTP|WWQ|NONE

** This query return is only applicable to the lab application.

Requirements

Test Application Revision A.01 and above.

Test Application Revision A.02 and above, added WCDomain, WSEMask, and WOBWidth.

Test Application Revision A.03 and above, added WIQTuning, WILPower, WOOPower, and SMONitor.

Test Application Revision A.05 and above added WBLerror, WDPAnalysis and WPDiscon.

Test Application Revision A.06 and above added FSTability

Lab Application Revision: A.01 and above.

Lab Application Revision B.01 and above added WBLerror, WDPAnalysis, WPDiscon, and WPPAnalysis.

Lab Application Revision C.01 and above added FSTability, WCTFormat and WOOSynch.

Programming Example

OUTPUT 714;"INITIATE:ON?"

INITiate:<measurement mnemonic>:OFF

Function

Deactivates the selected measurement. See Measurement States .

Only one measurement can be deactivated at a time. To stop one or more measurements and leave them in the active state, use ABORt .

Requirements

Test Application Revision A.01 and above.

Test Application Revision A.02 and above, added WCDomain, WSEMask, and WOBWidth.

Test Application Revision A.03 and above, added WIQTuning, WILPower, WOOPower, and SMONitor.

Test Application Revision A.05 and above added WBLerror, WDPAnalysis and WPDiscon.

Test Application Revision A.06 and above added FSTability

Lab Application Revision: A.01 and above.

Lab Application Revision B.01 and above added WBLerror, WDPAnalysis, WPDiscon, and WPPAnalysis.

Lab Application Revision C.01 and above added FSTability, WCTFormat and WOOSynch.

Programming Example

OUTPUT 714;"INITIATE:WCPOWER:OFF"
! Deactivates the channel power measurement.

INITiate:COUNt?

Function

Queries the number of measurements that have been initiated (are active). See Measurement States .

Query

Range: 0 to the number of measurements available in the application

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"INITIATE:COUNT?"

INITiate:DONE?

Function | Queries (one at a time) which measurements, if any, are finished or have timed-out. See Measurement Event Synchronization for how to use this command. See Measurement States to understand the test set's measurement states. See INITiate:DONE:FLAG:<measurement mnemonic> for include or exclude commands.
Requirements | Test Application Revision A.01 and above. Test Application Revision A.02 and above, added WCDomain, WSEMask, and WOBWidth. Test Application Revision A.03 and above, added WIQTuning, WILPower, WOOPower, and SMONitor. Test Application Revision A.05 and above added WBLerror, WDPAnalysis and WPDiscon. Test Application Revision A.06 and above added FSTability Lab Application Revision: A.01 and above. Lab Application Revision B.01 and above added WBLerror, WDPAnalysis, WPDiscon, and WPPAnalysis. Lab Application Revision C.01 and above added FSTability, WCTFormat and WOOSynch.
Query | Range: AFAN|FST|SAUD|SMON|WACL|WBER|WBL|WCD|WCP|WCTF**|WDPA |WILP|WIQT|WOBW|WOOP|WOOS**|WPD|WPPA**|WSEM|WTP|WWQ|NONE|WAIT ** This query return is only applicable to the lab application.

INITiate:DONE:CLEar

Function

Clears the done flag from all measurements.

Requirements

Test Application Revision A.01 and above.

Test Application Revision A.02 and above, added WCDomain, WSEMask, and WOBWidth.

Test Application Revision A.03 and above, added WIQTuning, WILPower, WOOPower, and SMONitor.

Test Application Revision A.05 and above added WBLerror, WDPAnalysis and WPDiscon.

Test Application Revision A.06 and above added FSTability

Lab Application Revision: A.01 and above.

Lab Application Revision B.01 and above added WBLerror, WDPAnalysis, WPDiscon, and WPPAnalysis.

Lab Application Revision C.01 and above added FSTability, WCTFormat and WOOSynch.

Programming Example

OUTPUT 714;"INITIATE:DONE:CLEAR"
! Clears the done flag.

INITiate:DONE:FLAG[:ALL]

Function

Specifies that all measurements are either included or excluded when the INITitate:DONE? query is sent.

If a measurement trigger arm is left in continuous mode, the done flag for that measurement will toggle between DONE and WAIT. The INITiate:DONE? query will probably not be able to catch the measurement at the instant it is done; therefore, the measurement will never appear to be done. If a measurement's triggering must be continuously armed, you should exclude the measurement using INITiate:DONE:FLAG:<measurement mnemonic> .

Use INITitate:DONE:FLAG:ALL EXCLude to exclude all measurements.

Once INITiate:DONE:FLAG has been set to EXCLude for a measurement, the user must send the INCLude command for that measurement in order to query that measurement with the INITiate:DONE? query. The test set will not reset any excluded measurement with any type of preset.

Setting

Range: INCLude|EXCLude

Requirements

Test Application Revision A.01 and above.

Test Application Revision A.02 and above, added WCDomain, WSEMask, and WOBWidth.

Test Application Revision A.03 and above, added WIQTuning, WILPower, WOOPower, and SMONitor.

Test Application Revision A.05 and above added WBLerror, WDPAnalysis and WPDiscon.

Test Application Revision A.06 and above added FSTability

Lab Application Revision: A.01 and above.

Lab Application Revision B.01 and above added WBLerror, WDPAnalysis, WPDiscon, and WPPAnalysis.

Lab Application Revision C.01 and above added FSTability, WCTFormat and WOOSynch.

Programming Example

OUTPUT 714;"INITIATE:DONE:FLAG:ALL INCLUDE"
! Includes all measurements in the INITIATE:DONE? query.

INITiate:DONE:FLAG:<measurement mnemonic>

Function

Specifies if a measurement done flag is considered (using the INCLude or EXCLude settings) when the INITitate:DONE? query is sent.

If more than one measurement is active, and one or more measurement trigger arm states is continuous, the INITiate:DONE? query may not be effective. The best solution is to change the arm state of all measurements to single using the SETup:CONTinuous command. However, if a measurement must be continuously triggered, you should exclude the measurement using the EXCLude setting provided by this command if you want to use INITiate:DONE? to query measurement done status.

The test set will not reset any excluded measurement to included with any type of preset.

Setting

Range: INCLude|EXCLude

Requirements

Test Application Revision A.01 and above.

Test Application Revision A.02 and above, added WCDomain, WSEMask, and WOBWidth.

Test Application Revision A.03 and above, added WIQTuning, WILPower, WOOPower, and SMONitor.

Test Application Revision A.05 and above added WBLerror, WDPAnalysis and WPDiscon.

Test Application Revision A.06 and above added FSTability

Lab Application Revision: A.01 and above.

Lab Application Revision B.01 and above added WBLerror, WDPAnalysis, WPDiscon, and WPPAnalysis.

Lab Application Revision C.01 and above added FSTability, WCTFormat and WOOSynch.

Programming Example

OUTPUT 714;"INITIATE:DONE:FLAG:WTP EXCLUDE"
! Excludes the thermal power measurement from responding
! to the INITIATE:DONE? query.


INITiate Subsystem

INITiate Subsystem

Syntax Diagrams and Command Descriptions

INITiate

Description

INITiate Command Functions

The INITiate subsystem is used to:

  • Start (activate) individual or multiple (concurrent) measurements.

  • Turn individual measurements off.

  • Determine the number of measurements currently active (INIT:COUNT?).

  • Determine the names of the measurements currently active (INIT:ON?).

  • Determine which measurements are finished (INIT:DONE?).

What Happens When a Measurement is INITiated?

When a measurement is started using INITiate commands, a new measurement cycle is started. If the selected measurement is currently in a measurement cycle, it is aborted. If a timeout is specified, the timeout period begins when a measurement is initiated.

NOTE
The INITiate subsystem is derived from SCPI, but has some modifications to make it more compatible with the manual operation of the test set. Most notably, the choice of single or continuous measurement triggering is made using the SETup subsystem.

INITiate Programming Examples (how INIT commands are used)

The INITiate command is used to start measurements. INITiate commands allow multiple measurements to be started without waiting for other measurement processes to complete. For example, the following code starts the Digital Average Power and Waveform Quality measurements, and then uses the INITiate:DONE? command in a loop to query the status of these measurements, see Measurement Event Synchronization .

When the measurements are done, the FETCh command is used to acquire the results, and the results are entered into variables in the controlling application. The program ends when the INITiate:DONE? command returns the string "NONE" indicating that all initiated measurements have gone through the measuring state see Measurement States .

Trigger arming for each measurement is controlled in the SETup subsystem. The choices are single or continuous. The best practice (during remote operation) is to use single measurement mode. This simplifies the tasks of starting concurrent measurements, then using the INIT subsystem commands to determine which measurements are ready to be FETChed.

10 OUTPUT 714;"SETup:ALL:CONTinuous:OFF" ! selects single trigger  mode.
20 OUTPUT 714;"INITiate:WBERror;WCPower" ! starts loopback BER  and
30                                       !channel power  measurements.
40 LOOP
50 OUTPUT 714;"INITiate:DONE?" !query to find out if any measurements are done.
60 ENTER 714;Meas_complete$
70 SELECT Meas_complete$
80 CASE "WBER" !tests for the string "WBER", indicating loopback BER measurement is done.
90 OUTPUT 714;"FETCh:WBERror?" !Queries loopback BER results.
100 ENTER 714;Integrity,Ber,Ber_count,Bits_tested
110 CASE "WCP" !tests for the string "WCP", indicating channel power measuremenet is done.
120 OUTPUT 714;"FETCh:WCPow?" !Queries the channel power results.
130 ENTER 714;Integrity,Avg_chan_pow
140 END SELECT
150 EXIT IF Meas_complete$="NONE"
160 END LOOP
170 END


READ

READ

Diagram Conventions

READ:AFANalyzer[:ALL]?

Function

Initiates and fetches an audio frequency analyzer measurement as a sequential operation.

Measurement results are returned in the following order: integrity, average audio level, average SINAD, average audio distortion.
Query

Integrity: see Integrity Indicator

Average audio level

  • Range: 0 to 20 volts, 9.91 E+37
  • Resolution: the lesser of 4 significant digits or 10 uV.

Average SINAD

  • Range: -99.00 to 99.00 dB, 9.91 E+37
  • Resolution: 0.01 dB

Average audio distortion

  • Range: 0.00 to 99.00%, 9.91 E+37
  • Resolution: 0.01%

Requirements

Test or Lab Application Revision: A.01 and above

READ:FSTability[:ALL]?

Function

Initiates and fetches a frequency stability measurement as a sequential operation.

Measurement results are returned in the following order: integrity, worst-case frequency error, average frequency.
Query

Worst-case frequency error

  • Range: -500 to 500 parts per million (ppm)
  • Resolution: 0.01

Average frequency

  • Range: 100 E+6 to 3 E+9 Hz
  • Resolution: 1 Hz

READ:SAUDio[:ALL]?

Function

Initiates and fetches a swept audio measurement as a sequential operation.

Measurement results are returned in the following order: integrity indicator, average swept audio level and average distortion for the first frequency point, average swept audio level and average distortion for the second frequency point, and so on. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.

For frequencies above 10 kHz, this measurement returns 9.91 E+37.

Query

Integrity indicator: see Integrity Indicator

Average audio level

  • Range: 1 mV to 20 V, 9.91 E+37
  • Resolution: the lesser of 4 significant digits or 10 uV

Average distortion

  • Range: 0 to 99.9%, 9.91 E+37
  • Resolution: 0.01%

READ:SMONitor:TRACe?

Function

Queries (initiates and fetches) one spectrum monitor measurement as a sequential operation.

Returns a comma separated list of 401 points representing the amplitude results of the trace data.

Query

Range:

  • For spans of 125 kHz and 500 kHz

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: -50 to +55 dB

  • For all other spans

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: (reference level - 60 dB) to +55 dB

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above.

READ:WACLeakage[:ALL]?

Function

Initiates and fetches an adjacent channel leakage ratio measurement as a sequential operation.

Measurement results are returned in the following order: integrity, -5 MHz minimum offset power ratio, +5 MHz maximum offset power ratio, -10 MHz minimum offset power ratio,
+10 MHz maximum offset power ratio.

If the measurement state of any offset is set to OFF, the result for that offset will be 9.91 E+37.
Query
  • Range: -100 to 100 dBm
  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

READ:WBERror[:ALL]?

Function

Initiates and fetches a loopback bit error ratio measurement as a sequential operation.

Measurement results are returned in the following order: integrity, bit error ratio, bit error count, bits tested.
Query

Range

  • Integrity: 1 to 23
  • Bit Error Ratio: 0 to 99%, 9.91 E+37
  • Bit Error Count: 0 to 999999, 9.91 E+37
  • Bits Tested: 0 to 999999, 9.91 E+37

Resolution

  • Integrity: 1
  • Bit Error Ratio: 0.0001 dB
  • Bit Error Count: 1
  • Bits Tested: 1

Requirements

Test or Lab Application Revision: A.01 and above

READ:WBLerror[:ALL]?

Function

Initiates and fetches a loopback block error ratio measurement as a sequential operation.

Measurement results are returned in the following order: integrity, block error ratio, block error count, blocks tested, uplink missing blocks.

See Block Error Ratio Measurement Results .
Query

Range

  • Integrity: see Integrity Indicator .
  • Block Error Ratio: 0 to 99%, 9.91 E+37
  • Block Error Count: 0 to 99000, 9.91 E+37
  • Blocks Tested: 0 to 99000, 9.91 E+37
  • Uplink Missing Blocks: 0 to 99000, 9.91 E+37

Resolution

  • Integrity: 1
  • Block Error Ratio: 0.0001%
  • Block Error Count: 1
  • Blocks Tested: 1
  • Uplink Missing Blocks: 1

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"READ:WBLerror?"

READ:WCDomain[:ALL]?

Function

Initiates and fetches a code domain measurement as a sequential operation.

Measurement results are returned in the following order: integrity, EVM, frequency error, origin offset, phase error, magnitude error, time error, peak code domain error.

Query

Integrity

  • Range: 0 to 23

  • Resolution: 1

EVM Maximum

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Frequency Error worst case

  • Range: -99.99 to 99.99 kHz, 9.91 E+37

  • Resolution: 0.1

Origin Offset Maximum

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error Maximum

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Time Error Maximum

  • Range: -99 to 99 µ s, 9.91 E+37

  • Resolution: 1 ns

Peak Code Domain Error Maximum

  • Range: -99.0 to 0.0 dB, 9.91 E+37

  • Resolution: 0.1

Requirements

Test Application Revision:

Lab Application Revision: A.01 and above.

READ:WCPower[:ALL]?

Function

Initiates and fetches a channel power measurement as a sequential operation.

Measurement results are returned in the following order: integrity, average channel power.

If the multi-measurement state is on, the result represents the average of a number of channel power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WCPower:COUNt[:SNUMber] .

Query
  • Range: -99 to 99 dBm
  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

READ:WCTFormat[:ALL]?

Function

Initiates and fetches a change of TFC measurement as a sequential operation.

Measurement results are returned in the following order: Integrity Indicator, Step Down Relative Power (average result if SETup:WCTFormat:COUNt[:SNUMber] is greater than 0), Step Down Error, Step Down Pass/Fail, Step Up Relative Power (average result if SETup:WCTFormat:COUNt[:SNUMber] is greater than 0), Step Up Error, Step Up Pass/Fail.

See Change of TFC Measurement Results .

Query

Integrity Indicator - see Integrity Indicator .

Step Down Relative Power

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Step Down Error

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Step Down Pass/Fail

  • Range: 0 (pass), 1 (fail), 9.91E+37

Step Up Relative Power

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Step Up Error

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Step Up Pass/Fail

  • Range: 0 (pass), 1 (fail), 9.91E+37

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"READ:WCTFormat?"

READ:WDPAnalysis[:ALL]?

Function

Initiates and fetches a dynamic power analysis measurement as a sequential operation.

Measurement results are returned in the following order: integrity indicator, the number of steps measured, and a comma-separated list of average power values for each step measured (in dBm).

See Dynamic Power Analysis Measurement Results .

Query

Integrity Indicator - see Integrity Indicator .

Number of Steps

  • Range: 0 to 100
  • Resolution: 1

Average Power

  • Range: -99.99 to 99.99 dBm, 9.91E+37
  • Resolution: 0.01 dBm

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"READ:WDPAnalysis?"
! Returns integrity, number of steps measured,
! average power for each step

READ:WILPower[:ALL]?

Function

Initiates and fetches an Inner Loop Power control measurement as a sequential operation.

Measurement results are returned in the following order:

Query

Integrity

  • Range: 0 to 23

  • Resolution: 1

Overall pass/fail

  • Range: 0 to 1

  • Resolution: 1

Worst case slot number (based on each adjacent timeslot measurement)

  • Range: 1 to 150, 9.91 E+37

  • Resolution: 1

Absolute power (based on each adjacent timeslot measurement)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Relative power (based on each adjacent timeslot measurement)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Worst case slot number (based on Rel Pwr 10 TPC (dB) measurements)

  • Range: 1 to 150, 9.91 E+37

  • Resolution: 1

Absolute power (based on Rel Pwr 10 TPC (dB) measurements)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Relative power (based on Rel Pwr 10 TPC (dB) measurements)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower:ALL?"

READ:WIQTuning[:ALL]?

Function

Initiates and fetches an IQ tuning measurement as a sequential operation.

Measurement results are returned in the following order: Integrity, EVM, Frequency Error, Origin Offset, Phase Error, Magnitude Error, Time Error, Peak Code Domain Error, IQ Gain Imbalance, IQ Phase Imbalance.

Query

Integrity

  • Range: 0 to 23

  • Resolution: 1

EVM

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.1

Frequency Error

  • Range: -99.0 to 99.0 kHz, 9.91 E+37

  • Resolution: 0.1

Origin Offset

  • Range: -99.0 to 0.0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Magnitude Error

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.1

Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Peak Code Domain Error

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

IQ Gain Imbalance

  • Range:

  • Resolution:

IQ Phase Imbalance

  • Range:

  • Resolution:

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"READ:WIQTuning:ALL?" !Queries the IQ tuning measurement results.

READ:WOBWidth[:ALL]?

Function

Initiates and fetches an occupied bandwidth measurement as a sequential operation.

Measurement results are returned in the following order: integrity, average occupied bandwidth.

If the multi-measurement state is on, the result represents the average of a number of channel power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WOBWidth:COUNt[:SNUMber] .

Query
  • Range: 0.0 to 10.0 MHz
  • Resolution:.0001

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

READ:WOOPower[:ALL]?

Function

Initiates and fetches a PRACH transmit on/off power measurement as a sequential operation.

Measurement results are returned in the following order: Integrity, Pre Burst Off Power level, Pre Burst Off Power pass/fail, Burst On Power, Open Loop Power Error value, Open Loop Power Error pass/fail, Post Burst Off Power level, Post Burst Off Power pass/fail (see PRACH Transmit On/Off Power Measurement Results ).

Query

Integrity

  • Range: 0 to 23

  • Resolution: 1

Pre Burst Off Power level

  • Range: -99.99 to 00.00 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Pre Burst Off Power pass/fail

  • Range: 0 (pass), 1 (fail), 9.91 E+37

Burst On Power

  • Range: -99.99 to 99.99 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Open Loop Power Error value

  • Range: -99.99 to +99.99 dB
  • Resolution: 0.01 dB

Open Loop Power Error pass/fail

  • Range: 0 (pass), 1 (fail), 9.91 E+37

Post Burst Off Power level

  • Range: -99.99 to 00.00 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Post Burst Off Power pass/fail

  • Range: 0 (pass), 1 (fail), 9.91 E+37

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

READ:WPDiscon[:ALL]?

Function

Initiates and fetches a phase discontinuity measurement as a sequential operation.

Measurement results are returned as a comma separated list of values: Integrity Indicator, Number of Slots Measured, Worst Case Phase Discontinuity Slot Number, Worst Case Phase Discontinuity in degrees, Worst Case EVM Slot Number, Worst Case EVM in % rms.

See Phase Discontinuity Measurement Results .

Query

Integrity Indicator - see Integrity Indicator .

Number of Slots Measured

  • Range: 2 to 91, 9.91E+37
  • Resolution: 1

Worst Case Phase Discontinuity Slot Number

  • Range: 0 to 90, 9.91E+37
  • Resolution: 1

Worst Case Phase Discontinuity

  • Range: -180.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Worst Case EVM Slot Number

  • Range: 0 to 90, 9.91E+37
  • Resolution: 1

Worst Case EVM

  • Range: 0.0 to 99.0% rms, 9.91E+37
  • Resolution: 0.1% rms

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"READ:WPDiscon?"

READ:WPPAnalysis[:ALL]?

Function

Initiates and fetches a PRACH preamble analysis measurement as a sequential operation.

Measurement results are returned in the following order: Integrity Indicator, EVM (rms) in % rms, EVM (peak) in %, Frequency Error in Hz, Origin Offset in dB, Phase Error (rms) in degrees, Magnitude Error in %, Timing Error in chips, IQ Gain Imbalance in dB, IQ Phase Imbalance in degrees, Signature.

See PRACH Preamble Analysis Measurement Results .

Query

Integrity Indicator - see Integrity Indicator .

EVM (rms)

  • Range: 0.0 to 100.0% rms, 9.91E+37
  • Resolution: 0.1% rms

EVM (peak)

  • Range: 0.0 to 100.0%, 9.91E+37
  • Resolution: 0.1%

Frequency Error

  • Range: -9.999 kHz to +9.999 kHz, 9.91E+37
  • Resolution: 0.1 Hz

Origin Offset

  • Range: -100.0 to 0.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Phase Error

  • Range: -180.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Magnitude Error

  • Range: 0.0 to 100.0%, 9.91E+37
  • Resolution: 0.1%

Timing Error

  • Range: -383.62 to +383.62 chips, 9.91E+37
  • Resolution: 0.01 chips

IQ Gain Imbalance

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

IQ Phase Imbalance

  • Range: -180.0 to 180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Signature

  • Range: 0 to 15, 9.91E+37
  • Resolution: 1

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"READ:WPPAnalysis?"
! Returns Integrity Indicator, EVM (rms) in % rms, EVM (peak) in %,
! Frequency Error in Hz, Origin Offset in dB, Phase Error (rms) in degrees,
! Magnitude Error in %, Timing Error in chips, IQ Gain Imbalance in dB,
! IQ Phase Imbalance in degrees, Signature

READ:WSEMask[:ALL]?

Function

Initiates and fetches a spectrum emissions mask measurement as a sequential operation.

Measurement results are returned in the following order: integrity, overall pass/fail, in-channel power, and pass/fail results for each of the four frequency ranges.

In-channel power is returned in dBm/3.84 MHz.

The four frequency ranges for this measurement are as follows:

  • Range 1: +/- 2.515 to 3.485 MHz
  • Range 2: +/- 4.000 to 7.500 MHz
  • Range 3: +/- 7.500 to 8.500 MHz
  • Range 4: +/- 8.500 to 12.500 MHz

If the multi-measurement state is on, the result represents the average of a number of spectrum emissions measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WSEMask:COUNt[:SNUMber] .

Query

Integrity

  • Range: 0 to 23

Overall Pass/Fail

  • Range: 0|1

In-Channel Power (dBm/3.84 MHz)

  • Range: -99.00 to +99.00 dBm, 9.91 E+37
  • Resolution: 0.01

Range Pass/Fail

  • Range: 0|1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

READ:WSEMask:FAIL?

Function

Initiates and fetches a spectrum emissions mask measurement as a sequential operation.

Measurement results are returned in the following order: integrity, overall pass/fail (0 = Pass, 1 = Fail).

If the multi-measurement state is on, the result represents the average of a number of thermal power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WSEMask:COUNt[:SNUMber] .

Query
  • Range: 0|1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

READ:WTPower[:ALL]?

Function

Initiates and fetches a thermal power measurement as a sequential operation.

Measurement results are returned in the following order: integrity, thermal transmit power.

If the multi-measurement state is on, the result represents the average of a number of thermal power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WTPower:COUNt[:SNUMber] .

Query
  • Range: -99 to 99 dBm, 9.91 E+37
  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

READ:WWQuality[:ALL]?

Function

Initiates and fetches the waveform quality measurements as a sequential operation.

Measurement results are returned in the following order: integrity, EVM maximum, frequency error worst case, origin offset maximum, phase error maximum, magnitude error maximum.

If the multi-measurement state is on, each result represents the average of a number of waveform quality measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WWQuality:COUNt[:SNUMber] .

Query

Integrity

  • Range: 0 to 16

  • Resolution: 1

EVM Maximum

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Frequency Error worst case

  • Range-99.99 to 99.99 kHz, 9.91 E+37

  • Resolution: 0.1

Origin Offset Maximum

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error Maximum

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Magnitude Error Maximum

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above


READ? Subsystem

READ? Subsystem

Syntax Diagram and Command Descriptions

READ

Description

The READ? command provides a sequential method to make measurements and retrieve the results. READ? will hang the GPIB bus until the measurement is completed, or until the timeout value has been exceeded. Associated SETup commands (for each measurement) are used with the READ? command to retrieve desired measurement results in a sequential manner.

Sending a READ? command is equivalent to an INITiate/FETCh cycle for a measurement. A READ? command executes an abort action on that measurement followed by an INITiate and a FETCH?.

READ? commands can be mixed with FETCH? queries in order to make combinations of sequential and overlapped operations. One measurement can be issued a READ? command (sequential), and the next measurement can be issued INITiate/FETCh? commands (overlapped), if necessary.

The advantage of using the READ? commands to obtain measurement results, as opposed to the INITiate/FETCh method is:

  • It is simpler. Fewer commands are required to obtain measurement results.

Some disadvantages of using READ? over INITiate and FETCh are:

  • The test set does not process any additional GPIB commands until the requested measurement results are available.
  • The sequential nature of the READ? command does not allow the user to make concurrent measurements. Concurrent measurements require the overlapped commands INITiate, DONE? and FETCh? .
  • The READ? command does not provide measurement results such as statistics that are available using the INITiate/FETCh method.
  • The READ? commands have pre-defined measurement results. If additional results are needed from a measurement they may be obtained with a FETCh? query.

NOTE
Trigger arming for each measurement is controlled in the SETup subsystem. Best practice during remote operation is to set trigger arm to single (Continuous Off).

Program Example - READ:WTPower?

OUTPUT 714;"READ:WTPower?" !Starts a thermal power measurement. As soon as the
                           !measurement cycle has completed, the test set
                           !provides the thermal power measurement results to the
                           !controlling application.
ENTER 714;Integrity, Thermal_power !Enters the integity indicator and the
                                      !thermal power measurement values into
                                      !the controlling application.


RFANalyzer

RFANalyzer

Diagram Conventions

RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO

Function

Turns on/off the auto Meas Frequency feature which determines the measurement downconverter signal path frequency control mode. (See Block Diagram .)

ON = automatic

OFF = manual

Setting

 Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO OFF"
!Enables manual control of the measurement signal path tune frequency.

RFANalyzer:CONTrol:POWer:AUTO

Function

Sets/queries the test set's receiver input power control mode.

ON = automatic

OFF = manual

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:CONTROL:POWER:AUTO OFF"

!Enables manual control of the expected input power level.

RFANalyzer:CONTrol:UPLink:FREQuency:AUTO

Function

Sets/queries the test set's demodulation signal path tune frequency control mode.

ON = automatic

OFF = manual.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:CONTROL:UPLINK:FREQUENCY:AUTO OFF" !Enables manual control of the demodulation signal path tune frequency.

RFANalyzer:CW:EXPected:POWer

Function

Sets/queries the expected CW receiver input power. This setting is only used when the Operating Mode is set to CW. (See CALL:OPERating .)

Setting

Range: -60 dBm to +53 dBm

Query

Range: -60 dBm to +53 dBm
*RST setting +13 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:CW:EXPECTED:POWER -20"

RFANalyzer:MANual:POWer[:SELected]

Function

Sets/queries the receiver expected input power when the test set's receiver input power control mode is set to manual. See Power Control (Except for CW Mode) .

The optional [:SELected] keyword in this command specifies that the expected input power setting being queried applies to the current system type.

The test set's receiver power control mode is set by the RFANalyzer:CONTrol:POWer:AUTO command.

The test set's measuring receiver will consider any amplitude offsets that are defined along with this setting to calculate input power range settings.

Setting

Range: Test application and system type dependent (approximately -25 to +43 dBm).

Resolution: 0.01 dBm

Query

 Range: Test application and system type dependent (approximately -25 to +43 dBm).
*RST setting -75 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:POWER:SELECTED 24 DBM" !Sets the manual power control mode expected input power level for the currently selected system type to 24 dBm.

RFANalyzer:MANual:POWer:FDD

Function

Sets/queries the sets the measurement and demod receivers expected input power when UTRA FDD is the current system type and the receiver input power control is set to Manual. See Power Control (Except for CW Mode) .

The test set's receiver power control mode is set by the RFANalyzer:CONTrol:POWer:AUTO command.

The test set's measuring receiver will consider any amplitude offsets that are defined along with this setting to calculate input power range settings.

Setting

Range: -129 to +80 dBm (-79 dBm to +30 dBm actual hardware range with amplitude offset = 0)

Resolution: 0.01 dBm

Query

 Range: -129 to +80 dBm (-79 dBm to +30 dBm actual hardware range with amplitude offset = 0)
*RST setting 0 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:POWER:FDD 24 DBM"
!Sets the manual power control mode expected input power level for the FDD system type to
!24 dBm.

RFANalyzer:MANual:MEASurement[:MFRequency]

Function

The setting form of this command performs two functions: (1) sets the Meas Frequency of the test set's measurement signal path, and (2) selects manual (auto off) tune mode for the test set's measurement signal path. (See Block Diagram .)

The query form of this command returns the tune frequency of the test set's measurement signal path.

The tune mode for the test set's measurement signal path can be returned to auto using the RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO command.

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

 Range: 292.5 MHz to 2700 MHz
*RST setting 896 MHz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:MEASUREMENT:MFREQUENCY 942.6 MHZ"
!Enables manual control of the measurement signal path tune frequency and sets the tune frequency to 942.6 MHz.

RFANalyzer:MANual:MEASurement:FREQuency

Function

Sets/queries Meas Frequency, the measurement downconverter signal path frequency control mode. (See Block Diagram .)

This setting is applied when manual mode is selected (see RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO ).

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

 Range: 292.5 MHz to 2700 MHz
*RST setting 896 MHz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:MEASUREMENT:FREQUENCY 942.6 MHZ"
!Sets the measurement signal path tune frequency to 942.6 MHz when manual control mode is used.

RFANalyzer:MANual:UPLink[:MFRequency]

Function

The setting form of this command performs two functions: (1) sets the tune frequency of the test set's demodulation signal path, and (2) selects manual tune mode for the test set's demodulation signal path.

The query form of this command returns the tune frequency of the test set's demodulation signal path.

The tune mode for the test set's demodulation path can be returned to auto using the RFANalyzer:CONTrol:UPLink:FREQuency:AUTO command.

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

 Range: 292.5 MHz to 2700 MHz
*RST setting 896 MHz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:UPLINK:MFREQUENCY 1955.030 MHZ"

!Enables manual control of the demodulation signal path tune frequency and sets the tune frequency
!to 1955.030 MHz.

RFANalyzer:MANual:UPLink:FREQuency

Function

Sets/queries the tune frequency of the test set's demodulation signal path.

This setting is applied when manual mode is selected (see RFANalyzer:CONTrol:UPLink:FREQuency:AUTO ).

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

Range: 292.5 MHz to 2700 MHz
*RST setting 896 MHz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:UPLINK:FREQUENCY 942.6 MHZ"
!Sets the test set's demodulation signal path tune frequency to 942.6 MHz.


RFANalyzer Subsystem

RFANalyzer Subsystem

Description

The RFANalyzer command subsystem performs "lower-level" functions that control the test set's measuring receiver. The measuring receiver includes three separate signal paths:

  • Power detector
  • Demodulation
  • Measurement

Refer to the Block Diagram for a description of the signal paths.

The RFANalyzer commands allow manual settings to the tune frequency or expected power level to each of these paths if it is necessary to override automatic settings.

Syntax Diagrams and Command Descriptions

RFANalyzer


RFGenerator: OUTPut

RFGenerator: OUTPut

Diagram Conventions

RFGenerator:OUTPut[:DESTination]

Function

Sets/queries the RF output port destination: RF IN/OUT (IO) or RF OUT ONLY (OUT).

If the correct hardware is not installed when trying to change to the RF OUT ONLY port, the test set displays the following error: Hardware error; RFIO version does not support RF out only selection.

The query form will always return a value, regardless of the hardware version.

Setting

Range: IO | OUT

Query

Range: IO |OUT

*RST Setting

 IO

Requirements

Test or Lab Application Revision: A.01 and above

Hardware: RF Input/Output module with second RF output connector, modified front panel.

Programming Example

OUTPUT 714;"RFGenerator:OUTPut OUT"
!Sets the RF generator's output destination to the RF Out Only port.


RFGenerator Subsystem

RFGenerator Subsystem

Description

The RFGenerator subsystem selects the RF generator output port on test sets equipped with both the RF IN/OUT port and the RF OUT ONLY port. If the test set does not have the RF OUT ONLY port, an error message is generated when attempting to switch output ports.

The RF OUT ONLY port may not be used with some test applications or lab applications. In that case, a message is displayed that tells you that the port could not be switched.

Syntax Diagrams and Command Descriptions

RFGenerator: OUTPut


SETup:AFANalyzer

SETup:AFANalyzer

SETup Subsystem

SETup:AFANalyzer:CONTinuous

Function

Sets/queries the trigger arm state for the AF analyzer measurement. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:AFANalyzer:COUNt[:SNUMber]

Function

Sets/queries the number of AF analyzer measurements to be made in a multi-measurement setup. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:AFANalyzer:COUNt:NUMBer

Function

Sets/queries the number of AF analyzer measurements to be made when multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:COUNT:NUMBER 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:AFANalyzer:COUNt:STATe

Function

Sets/queries the multi-measurement state of the AF analyzer measurement.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:COUNT:STATE ON" !Turns on multi-measurements.

SETup:AFANalyzer:DEMPhasis:STATe

Function

Sets/queries whether 750 us de-emphasis is enabled.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:DEMPHASIS:STATE ON"

SETup:AFANalyzer:DETector[:TYPE]

Function

Sets/queries the detector type for audio level measurements.

Setting

Range: RMS|PEAK

Query

Range: RMS|PEAK

*RST setting

RMS

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:DETECTOR:TYPE PEAK"

SETup:AFANalyzer:EXPandor[:SRLevel]

Function

Sets/queries the expandor's reference level and automatically sets the expandor's state to ON.

Setting

Range: 10 mV to 10 V

Resolution: 1 mV

Query

Range: 10 mV to 10 V

*RST setting

1 V

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:EXPANDOR:SRLEVEL 5V"
!Sets expandor state to on and level to 5 V.

SETup:AFANalyzer:EXPandor:RLEVel

Function

Sets/queries the expandor's reference level to be used when the expandor's state is set to ON.

Setting

Range: 10 mV to 10 V

Resolution: 1 mV

Query

Range: 10 mV to 10 V

*RST setting

1 V

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:EXPANDOR:RLEVEL 5V" !Sets expandor reference level to 5 V.

SETup:AFANalyzer:EXPandor:STATe

Function

Sets/queries whether the expandor is enabled.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:EXPANDOR:STATE ON"

SETup:AFANalyzer:FILTer[:TYPE]

Function

Sets/queries the filter type for audio measurements. Filter choices are as follows: 100 Hz tunable bandpass filter (TBP), C-message filter (CMES), 50 Hz to 15 kHz bandpass filter (BPAS50), 300 Hz to 15 kHz bandpass filter (BPAS300).

Setting

Range: NONE|TBPass|CMESsage|BPASs50|BPASs300

Query

Range: NONE|TBP|CMES|BPAS50|BPAS300

*RST setting

NONE

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:FILTER:TYPE BPASS50"
!Selects the 50 Hz to 15 kHz bandpass filter.

SETup:AFANalyzer:FILTer:TBPass[:FREQuency]

Function

Sets/queries the center frequency for the 100 Hz tunable bandpass filter (TBPass).

Setting

Range: 300.0 to 20000 Hz

Resolution: 0.1

Query

Range: 300.0 to 20000 Hz

*RST setting

1000

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

10 OUTPUT 714;"SETUP:AFANALYZER:FILTER:TBPASS:FREQUENCY 300HZ"

SETup:AFANalyzer:FREQuency:STATe

Function

Sets/queries whether the audio frequency measurement is enabled.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:FREQUENCY:STATE ON"

SETup:AFANalyzer:PEAK:VOLTage

Function

Sets/queries the expected peak voltage for audio measurements.

Setting

Range: 0.001 to 20 Vpk

Resolution: 0.001

Query

Range: 0.001 to 20 Vpk

*RST setting

20

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

10 OUTPUT 714;SETUP:AFANALYZER:PEAK:VOLTAGE 10V"

SETup:AFANalyzer:SDIStortion:FREQuency

Function

Sets/queries the fundamental frequency setting for the SINAD/distortion measurement.

Setting

Range: 100.0 to 10000 Hz

Resolution: 0.1

Query

Range: 100.0 to 10000 Hz

*RST setting

1000

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

10 OUTPUT 714;SETUP:AFANALYZER:SDISTORTION:FREQUENCY 300HZ"

SETup:AFANalyzer:SDIStortion:STATe

Function

Sets/queries whether the SINAD/distortion measurement is enabled.

Setting

Range: 1|0N|0|OFF

Query

Range: 1|0

*RST setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

10 OUTPUT 714;SETUP:AFANALYZER:SDISTORTION:STATE ON"

SETup:AFANalyzer:TIMeout[:STIMe]

Function

Sets/queries the AF analyzer measurement's timeout setting and automatically sets the timeout state to ON.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds, on

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:TIMEOUT:STIME 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:AFANalyzer:TIMeout:STATe

Function

Sets/queries the AF analyzer measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:TIMEOUT:STATE ON"

SETup:AFANalyzer:TIMeout:TIME

Function

Sets/queries the AF analyzer measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:TIMEOUT:TIME 5S"


SETup:CONTinuous

SETup:CONTinuous

Diagram Conventions

SETup[:ALL]:CONTinuous

Function

Sets/queries the trigger arm state for all measurements. Determines whether all measurements will make one measurement then stop (OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (ON (continuous)).

This setting overrides previously set trigger arm settings for individual measurements.

Setting

Range: ON, OFF

Programming Example

OUTPUT 714;"SETup:ALL:CONTinuous:OFF" !Sets all measurements to single trigger mode.


SETup Subsystem

SETup Subsystem

Description

The SETup subsystem is used to configure the test set for each measurement. Typical settings include:

  • Multi-Measurement Count, how many measurements will be made each time a measurement is initiated.
  • Trigger Arm, determines if a measurement will make one measurement then return to idle (single), or automatically rearm on completion of a measurement and repeat the process (continuous).
  • Trigger Source, how a measurement is triggered.
  • Trigger Delay, controls the delay time between the trigger and the start of sampling.
  • Measurement Timeout, length of time before a measurement times out.

NOTE
Trigger arming for each measurement is controlled in the SETup subsystem. The choices are single or continuous. In most cases, it is a best practice (during remote operation) to use "single" measurement mode. This simplifies the tasks of starting concurrent measurements, using the INIT subsystem commands to determine which measurements are ready to be fetched, then using the FETCh subsystem to obtain results. The command "SETup:CONTinuous:OFF sets all measurements to "single" trigger mode.

Syntax Diagrams and Command Descriptions

SETup:CONTinuous

SETup:AFANalyzer (AF Analyzer measurements)

SETup:FSTability (Frequency Stability measurement)
SETup:SAUDio (Swept Audio measurement)

SETup:SMONitor (Spectrum Monitor measurements)

SETup:WACLeakage (Adjacent Channel Leakage measurements)

SETup:WBERror (Loopback Bit Error Ratio measurements)
SETup:WBLerror (Loopback Block Error Ratio measurement)

SETup:WCDomain (Code Domain measurements)

SETup:WCPower (Channel Power measurements)

SETup:WCTFormat (Change Of TFC) Lab App only
SETup:WDPAnalysis (Dynamic Power Analysis measurement)

SETup:WILPower (Inner Loop Power measurements)

SETup:WIQTuning (IQ Tuning measurements)

SETup:WOBWidth (Occupied Bandwidth measurements)

SETup:WOOPower (PRACH Transmit On/Off Power measurements)

SETup:WOOSynch (Out-of-Synch Handling of Output Power) Lab App only
SETup:WPDiscon (Phase Discontinuity measurement)
SETup:WPPAnalysis (PRACH Preamble Analysis measurement) Lab App only

SETup:WSEMask (Spectrum Emission Mask measurements)

SETup:WTPower (Thermal Power measurements)

SETup:WWQuality (Waveform Quality measurements)


SETup:FSTability

SETup:FSTability

December 21, 2004

Diagram Conventions

SETup:FSTability:CONTinuous

Function

Sets/queries the trigger arm state for the frequency stability measurement. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:CONTINUOUS ON"
!Sets measurement to continuous trigger mode.

SETup:FSTability:COUNt[:SNUMber]

Function

Sets/queries the number of frequency stability measurements to be made in a multi-measurement setup. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

10, on
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:FSTability:COUNt:NUMBer

Function

Sets/queries the number of frequency stability measurements to be made when milt-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:COUNT:NUMBER 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:FSTability:COUNt:STATe

Function

Sets/queries the multi-measurement state of the frequency stability measurement.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:COUNT:STATE ON" !Turns on multi-measurements.

SETup:FSTability:TIMeout[:STIMe]

Function

Sets/queries the frequency stability measurement's timeout setting and automatically sets the timeout state to ON.

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds, on
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:TIMEOUT:STIME 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:FSTability:TIMeout:STATe

Function

Sets/queries the frequency stability measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:TIMEOUT:STATE ON"

SETup:FSTability:TIMeout:TIME

Function

Sets/queries the frequency stability measurement's timeout setting.

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 second

*RST Setting

10 seconds, on
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:TIMEOUT:TIME 5S"


SETup:SAUDio

SETup:SAUDio

December 21, 2004

Diagram Conventions

SETup:SAUDio:CONTinuous

Function

Sets/queries the trigger arm state for the swept audio measurement. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:SAUDIO:CONTINUOUS ON" !Turns on continuous triggering.

SETup:SAUDio:COUNt[:SNUMber]

Function

Sets/queries the number of audio measurements to perform at each measurement point in a single multi-measurement sweep. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETUP:SAUDIO:COUNT:SNUMBER 5" !Turns on multi-measurements and makes 5 measurements at each frequency point in the sweep.

SETup:SAUDio:COUNt:NUMBer

Function

Sets/queries the number of audio measurements to perform at each measurement point in a single multi-measurement sweep when the SETup:SAUDio:COUNt:STATe is set to 1 (on).

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

10

Programming Example

OUTPUT 714;"SETUP:SAUDIO:COUNT:NUMBER 5" !Makes 5 measurements at each frequency point in the sweep.

SETup:SAUDio:COUNt:STATe

Function

Selects/queries the swept audio measurement's multi-measurement count state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:SAUDIO:COUNT:STATE ON" !Turns on multi-measurement for the swept audio measurement.

SETup:SAUDio:COUPling

Function

Sets/queries the audio generator's coupling to the AUDIO OUT port.

Setting

Range: AC|DC

Query

Range: AC|DC

*RST Setting

 DC

Programming Example

OUTPUT 714;"SETUP:SAUDIO:COUPLING AC" !Select AC coupling to the AUDIO OUT port.

SETup:SAUDio:DETector[:TYPE]

Function

Sets/queries the type of level detector used in swept audio measurements.

Setting

Range: RMS|PEAK

Query

Range: RMS|PEAK

*RST Setting

 RMS

Programming Example

OUTPUT 714;"SETUP:SAUDIO:DETECTOR:TYPE PEAK" !Select the peak detector for the AF analzyer.

SETup:SAUDio:FILTer[:TYPE]

Function

Sets/queries the type of filter on the sampled data, before any measurements are performed.

The filter choices are: none, TBPass (100 Hz bandwidth bandpass), CMESsage (C-Message), BPASs50 (50 Hz to 15 kHz bandpass), BPASs300 (300 Hz to 15 kHz bandpass)

Setting

Range: NONE|TBPass|CMESsage|BPASs50|BPASs300

Query

Range: NONE|TBP|CMES|BPAS50|BPAS300

*RST Setting

None

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FILTER:TYPE TBPASS" !Selects the 100 Hz bandpass filter.

SETup:SAUDio:FREQuency[:VALue]?

Function

Returns a comma-separated list of the generated frequency for each frequency point (see SETup:SAUDio:FREQuency:POINts ).

When you specify the start frequency, stop frequency, and the number of measurement points, the test set calculates the intermediate frequencies that are generated. You cannot directly set the intermediate frequencies using this command, you can only query them.

Query

Range: up to 60 comma separated values

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FREQUENCY:VALUE?" !Queries the list of generated frequencies.

SETup:SAUDio:FREQuency:POINts

Function

Sets/queries the number of evenly-spaced frequency points in the sweep. If this value is set to 1, only the start frequency is used in the sweep.

Setting

Range: 1 to 60

Query

Range: 1 to 60

*RST Setting

5

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FREQUENCY:POINTS 20" !Make audio measurements at 20 frequency points in the sweep.

SETup:SAUDio:FREQuency:STARt

Function

Sets/queries the frequency at which to begin the sweep. The default units are Hz.

It is possible to set the start frequency higher than the stop frequency. If this is done, the sweep starts at the higher frequency and stops at the lower frequency.

Setting

Range: 300.0 to 15000.0 Hz

Query

Range: 300.0 to 15000.0 Hz

*RST Setting

300 Hz

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FREQUENCY:START 450HZ" !Start the frequency sweep at 450 Hz.

SETup:SAUDio:FREQuency:STOP

Function

Sets/queries the frequency at which to end the sweep. The default units are Hz.

It is possible to set the stop frequency lower than the start frequency. If this is done, the sweep starts at the higher frequency and stops at the lower frequency.

Setting

Range: 300.0 to 15000.0 Hz

Query

Range: 300.0 to 15000.0 Hz

*RST Setting

 3000 Hz

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FREQUENCY:STOP 1500HZ" !Stop the frequency sweep at 1500 Hz.

SETup:SAUDio:ICOunt:MAXimum?

Function

Queries the total multi-measurement count. This is equal to the number of frequency points in the sweep multiplied by the multi-measurement count set for the swept audio measurement.

Query

Range: 1 to 59940 (60 measurement points multiplied by 999 multi-measurements)

*RST Setting

 5

Programming Example

OUTPUT 714;"SETUP:SAUDIO:ICOUNT:MAXIMUM?" !Queries the total number of measurements made.

SETup:SAUDio:PEAK:VOLTage

Function

Sets/queries the expected peak voltage of the swept audio measurement. This determines the range and resolution of the sampled voltage values.

Setting

Range: 1 mV to 20 V

Resolution: 1 mV

Query

Range: 1 mV to 20 V

*RST Setting

20 V peak

Programming Example

OUTPUT 714;"SETUP:SAUDIO:PEAK:VOLTAGE 5V"

SETup:SAUDio:SETTling[:TIMe]

Function

Sets/queries how long swept audio measurements wait to start an audio measurement after setting the audio source's frequency. A setting of 0.0 seconds let's swept audio measurements run at maximum speed.

Settling time may be needed when testing a device that has a time delay through the audio path. Path delays can cause the audio generator's signal to change frequencies before the output signal can be analyzed at that frequency. Specifying a settling time ensures that the audio generator stays at each frequency point long enough for the audio analyzer to correctly measure the device's audio output.

Setting

Range: 0.0 to 999 ms

Resolution: 1 ms

Query

Range: 0.0 to 999 ms

*RST Setting

0 ms

Programming Example

OUTPUT 714;"SETUP:SAUDIO:SETTLING:TIME 20MS"

SETup:SAUDio:SDIStortion:STATe

Function

Sets/queries whether SINAD and distortion measurements are enabled. Turning on SINAD/Distortion measurements will cause the swept audio measurement to run significantly slower because of added sampling and calculation times.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:SAUDIO:SDISTORTION:STATE ON"

SETup:SAUDio:TIMeout[:STIMe]

Function

 Selects/queries the timeout value in seconds that is used for swept audio measurements and sets the timeout state to ON. Units (S|MS) are optional, if no units are specified then units default to S (seconds).

Setting

Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

*RST Setting

 10 seconds

Programming Example

OUTPUT 714;"SETUP:SAUDIO:TIMEOUT:STIME 10" !Enables timeouts and sets the value to 10 seconds.

SETup:SAUDio:TIMeout:TIME

Function

 Selects/queries the timeout value in seconds that is used for swept audio measurements when the timeout state is set to ON. Units (S|MS) are optional, if no units are specified then units default to S (seconds).

Setting

Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

*RST Setting

 10 seconds

Programming Example

OUTPUT 714;"SETUP:SAUDIO:TIMEout:TIME 10" !Sets the timeout value to 10 seconds.

SETup:SAUDio:TIMeout:STATe

Function

 Selects/queries the swept audio measurement timeout state. Timeout is set using the SETup:SAUDio:TIMeout:TIME command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:SAUDIO:TIMEOUT:STATE ON" !Enables timeouts for swept audio measurements.

SETup:SAUDio:VOLTage:AMPLitude

Function

Sets/queries the output level (peak voltage) of the audio generator when it is turned on. This command does not turn on the audio generator.

Setting

Range: 0.0 to 9.0 V peak (R L > 600 ohms)

Resolution:

  • < 0.5 mV peak (less than or equal to 1 V peak output)
  • < 5 mV peak (greater than 1 V peak output)

Query

Range: 0.0 to 9.0 V peak (R L > 600 ohms)

*RST Setting

0.0 V peak

Programming Example

OUTPUT 714;"SETUP:SAUDIO:VOLTAGE:AMPLITUDE 1V" !Set the audio generator's output to 1Vpeak.


SETup:SMONitor

SETup:SMONitor

Diagram Conventions

SETup:SMONitor:AMPLitude:PDIVision

Function

This command sets the scale of the spectrum monitor's display in dB per division (dB/div).
Setting

Range: 0.1 to 20 dB

Resolution: 0.1

Query

Range: 0.1 to 20 dBResolution: 0.1
*RST Setting

10 dB

Programming Example

OUTPUT 714;"SETup:SMONitor:AMPLitude:PDIVision 1DB"

!Sets scale of the spectrum monitor's display to 1 dB per division.

SETup:SMONitor:AMPLitude:RLEVel:AUTO

Function

This command allows you to set whether or not the spectrum monitor's reference level is selected automatically by the test set.
Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting

OFF

Programming Example

OUTPUT 714;"SETup:SMONitor:AMPLitude:RLEVel:AUTO ON"

!Sets spectrum monitor's reference level to set automatically.

SETup:SMONitor:AMPLitude:RLEVel:MANual

Function

This command allows you to set the spectrum monitors actual reference level in dBm. The range settings are coupled to the amplitude offset value for the current value of the expected frequency (set using SYSTem:CORRection:[:SGAin] ). Changing the amplitude offset value does not change the reference value, unless the new value for the amplitude offset forces the current value of the reference level to exceed the range limits. If this happens the reference level is set to its limit.
Setting

Range: (-50 dBm + Amplitude Offset) to +37 dBm

Resolution: 0.1 dB

Query

Range: (-50 dBm + Amplitude Offset) to +37 dBmResolution: 0.1 dB
*RST Setting

+37 dB + Amplitude Offset

Programming Example

OUTPUT 714;"SETup:SMONitor:AMPLitude:RLEVel:MANual -20DBM"

!Sets spectrum monitor's reference level to -20 dBm.

SETup:SMONitor:BANDwidth[:RES]
SETup:SMONitor:BWIDth[:RES]

Function

Queries the resolution bandwidth being used by the spectrum monitor measurement.

Query

Range: 1 kHz to 5 MHz
*RST Setting 30000 Hz

Programming Example

OUTPUT 714;"SETup:SMONitor:BAND?"

SETup:SMONitor:BANDwidth|BWIDth:ZSPan[:RESolution]

Function

This command sets/queries the resolution bandwidth when the spectrum monitor is operating in zero span mode. To measure the total power of a signal you must select a resolution bandwidth greater than or equal to the signal bandwidth. To resolve two spectral components the resolution bandwidth must be less than the difference between them. The units (HZ|KHZ|MHZ) are optional, if no units are specified then the default is HZ.
To change the spectrum monitor to zero span mode, us the command SETup:SMONitor:FREQuency:SPAN , to set the frequency span to 0 Hz.

Any setting you enter is rounded to the nearest of the three settings.
Setting

Range: 100 kHz | 300 kHz | 1 MHz

Query

Range: 100 kHz | 300 kHz | 1 MHz

*RST Setting 300 kHz

Programming Example

OUTPUT 714;"SETup:SMONitor:BAND:ZSPan 100 KHZ"

!Sets spectrum monitor's zero span resolution bandwidth to 100 kHz.

SETup:SMONitor:COUNt[:SNUMber]

Function

This command sets/queries the averaging count and turns on averaging.

Setting

Range: 1 to 999

Query

Range: 1 to 999
*RST Setting

100

Programming Example

OUTPUT 714;"SETup:SMONitor:COUNt 200"

!Sets the averaging count to 200 and sets the averaging the state to on.

SETup:SMONitor:COUNt:NUMber

Function

This command sets/queries the averaging count used when the averaging is turned on.
Setting

Range: 1 to 999

Query

Range: 1 to 999
*RST Setting

100

Programming Example

OUTPUT 714;"SETup:SMONitor:COUNt:NUMBer 200" !Sets the averaging count to 200.

SETup:SMONitor:COUNt:STATe

Function

This command sets/queries the averaging state.
Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting

OFF

Programming Example

OUTPUT 714;"SETup:SMONitor:COUNt:STATe 1" !Turns on averaging.

SETup:SMONitor:CONTinous

Function

This command arms triggering for a measurement sweep. Trigger arming can be single (OFF) or continuous (ON). With single triggering, the measurement sweep starts when an INITiate or READ command is received. With continuous triggering, measurement sweeps initiate immediately and continuously.

The *RST (remote full preset) default setting is single triggering. At power-on or after a front-panel preset, the default setting is continuous triggering.
Setting

Range: ON|1|OFF|0

Query

Range: 1|0
*RST Setting OFF

Programming Example

OUTPUT 714;"SETup:SMONitor:CONTinuous ON" ! Sets the trigger mode to continuous.

SETup:SMONitor:FREQuency:SPAN

Function

This command sets/queries the spectrum monitor's frequency span.

Setting

Range: A value in the range 125 kHz to 100 MHz can be entered, however the value is rounded to the nearest of:

  • 125 kHz, 500 kHz, 1.25 MHz, 2.5 MHz, 4 MHz, 5 MHz, 10 MHz, 12 MHz, 20 MHz, 40 MHz,
    80 MHz, 100 MHz
Query

Range: Same as setting range.
*RST Setting 5 MHz

Programming Example

OUTPUT 714;"SETup:SMONitor:FREQuency:SPAN 10MHZ" ! Sets the frequency span to 10 MHz.

SETup:SMONitor:TIME:OFFSet

Function

 This command sets/queries the time offset. You can specify the time window for viewing the signal using this command and the SETup:SMONitor:TIME:SPAN . The measurement is made for the duration of the time span, beginning at the time defined by the trigger event plus the trigger delay plus the time offset. The units (S|MS|US|NS) are optional, if no units are specified then the default is S.
Setting

Range: 0 us to 10 s

Resolution: 0.1 us
Query

Range: 0 us to 10 s

Resolution: 0.1 us
*RST Setting 0 us

Programming Example

OUTPUT 714;"SETup:SMONitor:TIME:OFFSet 25 MS"
! Sets the spectrum monitor's time offset to 25 millisecond.

SETup:SMONitor:TIME:SPAN

Function

 This command sets/queries the span of the time display. The units (S|MS|US) are optional, if no units are specified then the default is S.
Setting

Range: 50 us to 70 ms

Resolution: 0.250 us
Query

Range: 50 us to 70 ms

Resolution: 0.250 us
*RST Setting 10 ms

Programming Example

OUTPUT 714;"SETup:SMONitor:TIME:SPAN 30MS"
! Sets the spectrum monitor's time span to 30 millisecond.

SETup:SMONitor:TIMeout[:STIMe]

Function

This command sets/queries the spectrum monitor's timeout interval and turns on the timeout state. The units (S|MS|US) are optional, if no units are specified then the default is S.
Setting

Range: 1 to 999 seconds

Resolution: 0.1 second
Query

Range: 1 to 999 seconds

Resolution: 0.1 second
*RST Setting 10 s

Programming Example

OUTPUT 714;"SETup:SMONitor:TIMeout:STIMe 12S"
! Turns on the timeout timer and sets the timer to expire in 12 seconds.

SETup:SMONitor:TIMeout:STATe

Function

This command sets/queries the state of the spectrum monitor's timeout timer.
Setting

Range: 1|ON|0|OFF
Query

Range: 1|0
*RST Setting OFF

Programming Example

OUTPUT 714;"SETup:SMONitor:TIMeout:STATe 1" ! Turns on the timeout timer.

SETup:SMONitor:TIMeout:TIME

Function

This command sets/queries the spectrum monitor's timeout interval. The units (S|MS|US) are optional, if no units are specified then the default is S.
Setting

Range: 1 to 999 seconds

Resolution: 0.1 seconds
Query

Range: 1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting 10 seconds

Programming Example

OUTPUT 714;"SETup:SMONitor:TIMeout:TIME 20S"
! Generates a timeout error if no results are reported within 20 seconds.

SETup:SMONitor:TRACe:MODE

Function

This command sets/queries the trace update parameter.

  • WRITe (Clear-write) erases any data previously stored in the selected trace.
  • MAXHold (maximum hold) maintains the maximum level for each trace point of the selected trace and updates each trace point if a new maximum level is detected in successive sweeps.
  • MINHold (minimum hold) maintains the minimum level for each trace point of the selected trace and updates each trace point if a new minimum level is detected in successive sweeps.

If you change the center, start, or the frequency span, or the resolution bandwidth, the MAXHold and MINHold traces are restarted. These traces are not restarted if you change only the reference level or the scale.
Setting

Range: WRITe|MAXHold|MINHold
Query

Range: WRIT|MAXH|MINH
*RST Setting WRITe

Programming Example

OUTPUT 714;"SETup:SMONitor:TRACe:MODE MAXH"
! Sets the update method to maximim hold.

SETup:SMONitor:TRiGger:DELay

Function

This command sets/queries the trigger delay. This command allows you to add a time delay following the trigger event before samples are taken. The delay can be positive or negative. The units (S|MS|US) are optional, if no units are specified then the default is S.
Setting

Range: -50 ms to +50 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
Query

Range: -50 ms to +50 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
*RST Setting 350 us

Programming Example

OUTPUT 714;"SETup:SMONitor:TRIGger:DELay 1MS" ! Sets the trigger delay to 1 millisecond.

SETup:SMONitor:TRiGger:SOURce

Function

This command sets the trigger source. Immediate triggering happens as soon as the measurement is armed. RF rise triggering is initiated by the rising edge of an RF burst. With protocol triggering, sampling is initiated by a signaling event such as the start of a burst. An external trigger is used when set to external.
Setting

Range: IMMediate|PROTocol|RISE|EXTernal
Query

Range: IMM|PROT|RISE|EXT
*RST Setting IMMediate

Programming Example

OUTPUT 714;"SETup:SMONitor:TRIGger:SOURce RISE"
! Sets the measurement to trigger on the rising edge of an RF burst.


SETup:WACLeakage

SETup:WACLeakage

Diagram Conventions

SETup:WACLeakage:CONTinuous

Function

Sets/queries the trigger arm state for the adjacent channel leakage measurement. The trigger arm state determines whether the adjacent channel leakage measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:WACLeakage:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of adjacent channel leakage measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of adjacent channel leakage multi-measurements to be made when multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:WACLeakage:COUNt:NUMBer

Function

Sets/queries the number of adjacent channel leakage measurements to be made when the multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:COUNT:NUMBER 5"
!Sets the number of adjacent channel leakage multi-measurements to 5.

SETup:WACLeakage:COUNt:STATe

Function

Sets/queries the adjacent channel leakage multi-measurement state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:COUNT:STATE ON" !Turns on adjacent channel leakage multi-measurements.

SETup:WACLeakage:LOWer[1]:STATe

Function

Sets/queries the 1st lower adjacent channel's state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:LOW1:STATE 0" !Turns off the lower 1st adjacent channel.

SETup:WACLeakage:LOWer2:STATe

Function

Sets/queries the 2nd lower adjacent channel's state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:LOW2:STATE 0" !Turns off the lower 2nd adjacent channel.

SETup:WACLeakage:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the adjacent channel leakage measurement's timeout (see Measurement Timeouts ) value, and (2) sets the adjacent channel leakage measurement's timeout STATe to 1 (on).

The query form returns the adjacent channel leakage measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WACLeakage:TIMeout:STATe

Function

Sets/queries the adjacent channel leakage measurement's timeout (see Measurement Timeouts ) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:TIMEOUT:STATE ON"

SETup:WACLeakage:TIMeout:TIME

Function

Sets/queries the adjacent channel leakage measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:TIMEOUT:TIME 5 S"

SETup:WACLeakage:TRIGger:DELay

Function

Sets/queries the adjacent channel leakage measurement's trigger delay setting.

This setting can be used to delay the measurement trigger in order to to start a measurement during a specific timeslot in the frame. For example, a 1.333 ms delay would cause the trigger to wait until after the first two timeslots have elapsed.

Setting

Range: -10 to 10 milliseconds

Resolution: 0.0001 millisecond

Query

Range: -10 to 10 milliseconds

*RST Setting

0 seconds

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:TRIGGER:DELAY 1MS"

SETup:WACLeakage:TRIGger:SOURce

Function

Sets/queries the adjacent channel leakage measurement's trigger source.

Setting

Range: IMMediate|PROTocol|AUTO

Query

Range: IMM|PROT|AUTO

*RST Setting

 AUTO

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:TRIGGER:SOURCE IMMEDIATE"

SETup:WACLeakage:UPPer[1]:STATe

Function

Sets/queries the 1st upper adjacent channel's state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:UPP1:STATE 0" !Turns off the upper 1st adjacent channel.

SETup:WACLeakage:UPPer2:STATe

Function

Sets/queries the 2nd upper adjacent channel's state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:UPP2:STATE 0" !Turns off the upper 2nd adjacent channel.


SETup:WBERror

SETup:WBERror

Diagram Conventions

SETup:WBERror:CONFidence[:SLEVel]

Function

Sets/queries Confidence Level . This command sets the Confidence Level and turn on Confidence State .

Setting

Range: 80.00 to 99.99%

Resolution: 0.01%

Query

 Same as setting.

*RST Setting

 99.80% (Off)

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WBERror:CONFidence 99.5"
! Sets Confidence Level to 99.5% and turns Confidence State On.

SETup:WBERror:CONFidence:LEVel

Function

Sets/queries Confidence Level .

Setting

Range: 80.00 to 99.99%

Resolution: 0.01%

Query

 Same as setting.

*RST Setting

 99.80%

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WBERror:CONFidence:LEVel 99.5"
! Sets Confidence Level to 99.5%.

SETup:WBERror:CONFidence:STATe

Function

Sets/queries Confidence State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (Off)

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WBERror:CONFidence:STATe OFF"
! Sets Confidence State to Off.

SETup:WBERror:CONFidence:DUTFactor

Function

Sets/queries Bad DUT Factor .

This setting is only available when Confidence State is On .

Setting

Range: 1.0 to 5.0

Resolution: 0.1

Query

 Same as setting

*RST Setting

 1.5

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WBERror:CONFidence:DUTFactor 2.0"
! Sets the DUT Factor to 2.0.

SETup:WBERror:CONTinuous

Function

Sets/queries the trigger arm state for the loopback bit error ratio measurement. The trigger arm state determines whether the bit error measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)). See Trigger Arm (Single or Continuous) Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WBERROR:CONTINUOUS ON"
!Sets measurement to continuous trigger mode.

SETup:WBERror:COUNt

Function

 Sets/queries the Number of Bits to Test .

Setting

Range: 1000 to 999999999

Query

 Same as setting.

*RST Setting

 10000

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision A.06 and Lab Application Revision C.01 changed upper limit to 999999999.

Programming Example

OUTPUT 714;"SETUP:WBERROR:COUNT 5000"

SETup:WBERror[:RATio]:REQuirement

Function

Sets/queries the BER Requirement .

This setting is only available when Confidence State is On .

Setting

Range: 0.10 to 50.00%

Resolution: 0.01%

Query

 Same as setting.

*RST Setting

 0.10%

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WBERror:REQuirement 0.3"
! Sets BER Requirement to 0.3%.

SETup:WBERror:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the loopback bit error ratio measurement's timeout (see Measurement Timeouts ) value, and (2) sets the loopback bit error ratio measurement's timeout STATe to 1 (on).

The query form returns the loopback bit error rate measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

20 seconds, off

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WBERROR:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WBERror:TIMeout:STATe

Function

Sets/queries the loopback bit error ratio measurement's timeout state (see Measurement Timeouts ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WBERROR:TIMEOUT:STATE ON"

SETup:WBERror:TIMeout:TIME

Function

Sets/queries loopback bit error ratio measurement's timeout setting to be used when the timeout state is set to ON (see Measurement Timeouts ).

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

20 seconds

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WBERROR:TIMEOUT:TIME 5 S"


SETup:WBLerror

SETup:WBLerror

Diagram Conventions

SETup:WBLerror:CONTinuous

Function

Sets/queries the trigger arm state for the block error ratio measurement. The trigger arm state determines whether the block error ratio measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)). See Trigger Arm (Single or Continuous) Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WBLerror:CONTinuous ON"
! Sets measurement to continuous trigger mode.

SETup:WBLerror:COUNt

Function

 Sets/queries the number of blocks to test in the block error ratio test. See Number of Blocks to Test .

Setting

Range: 1 to 99,000 blocks

Resolution: 1 block

Query

Same as setting

*RST Setting

 500 blocks

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WBLerror:COUNt 1000"

SETup:WBLerror:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the block error ratio measurement's timeout (see Measurement Timeouts ) value, and (2) sets the block error ratio measurement's timeout STATe to 1 (on).

The query form returns the block error ratio measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

20 seconds, off

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WBLerror:TIMeout 5"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WBLerror:TIMeout:STATe

Function

Sets/queries the block error ratio measurement's timeout state (see Measurement Timeouts ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WBLerror:TIMeout:STATe ON"

SETup:WBLerror:TIMeout:TIME

Function

Sets/queries block error ratio measurement's timeout setting to be used when the timeout state is set to ON (see Measurement Timeouts ).

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Same as setting

*RST Setting

20 seconds

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WBLerror:TIMeout:TIME 5"


SETup:WCDomain

SETup:WCDomain

Diagram Conventions

SETup:WCDomain:CONTinuous

Function

Sets/queries the trigger arm state for the code domain measurement. The trigger arm state determines whether the bit error measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WCDOMAIN:CONTINUOUS ON"
!Sets measurement to continuous trigger mode.

SETup:WCDomain:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the code domain measurement's timeout (see Measurement Timeouts ) value, and (2) sets the adjacent channel leakage measurement's timeout STATe to 1 (on).

The query form returns the loopback bit error rate measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

20 seconds, off

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WCDOMAIN:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WCDomain:TIMeout:STATe

Function

Sets/queries the code domain measurement's timeout state (see Measurement Timeouts ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WCDOMAIN:TIMEOUT:STATE ON"

SETup:WCDomain:TIMeout:TIME

Function

Sets/queries code domain measurement's timeout setting to be used when the timeout state is set to ON (see Measurement Timeouts ).

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

20 seconds

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WCDOMAIN:TIMEOUT:TIME 5 S"

SETup:WCDomain:TSLot

Function

 Sets/queries the timeslot to test in the code domain test.

Setting

Range: 0 to 14

Query

Range: 0 to 14

*RST Setting

 0

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WCDOMAIN:TSLot"


SETup:WCPower

SETup:WCPower

Diagram Conventions

SETup:WCPower:CONTinuous

Function

Sets/queries the trigger arm state for the channel power measurement. The trigger arm state determines whether the channel power measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:WCPower:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of channel power measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of channel power multi-measurements to be made when multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:WCPower:COUNt:NUMBer

Function

Sets/queries the number of channel power measurements to be made when the multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:COUNT:NUMBER 5"
!Sets the number of channel power multi-measurements to 5.

SETup:WCPower:COUNt:STATe

Function

Sets/queries the channel power multi-measurement state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:COUNT:STATE ON" !Turns on channel power multi-measurements.

SETup:WCPower:FILTer[:RRC]

Function

Sets/queries the state of the root-raised cosine (RRC) filter.

Setting

Range: ON|OFF

Query

Range: ON|OFF

*RST Setting

 OFF

Requirements

Test or Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:FILTER:RRC ON" !Turns on the RRC filter.

SETup:WCPower:INTerval:TIME

Function

Sets/queries the channel power measurement interval. 10 milliseconds represents a full frame.

Setting

Range: 0.1 to 10 milliseconds

Resolution: 100 nanoseconds (minimum)

Query

Range: 0.01 to 10 milliseconds

*RST Setting

0.6667 ms (one slot interval)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:INTERVAL:TIME 10MS"
!Sets interval time to 10 milliseconds.

SETup:WCPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the channel power measurement's timeout (see Measurement Timeouts ) value, and (2) sets the channel power measurement's timeout STATe to 1 (on).

The query form returns the channel power measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WCPower:TIMeout:STATe

Function

Sets/queries the channel power measurement's timeout (see Measurement Timeouts ) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:TIMEOUT:STATE ON"

SETup:WCPower:TIMeout:TIME

Function

Sets/queries the channel power measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:TIMEOUT:TIME 5 S"

SETup:WCPower:TRIGger:DELay

Function

Sets/queries the channel power measurement's trigger delay setting.

This setting can be used to delay the measurement trigger in order to start a measurement during a specific timeslot in the frame. For example, a 1.333 ms delay would cause the trigger to wait until after the first two timeslots have elapsed.

Setting

Range: -10 to 10 milliseconds

Resolution: 0.0001 millisecond

Query

Range: -10 to 10 milliseconds

*RST Setting

0 seconds

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:TRIGGER:DELAY 1MS"

SETup:WCPower:TRIGger:SOURce

Function

Sets/queries the channel power measurement's trigger source.

Setting

Range: IMMediate|PROTocol|RISE|AUTO

Query

Range: IMM|PROT|RISE|AUTO

*RST Setting

 AUTO

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:TRIGGER:SOURCE IMMEDIATE"


SETup:WCTFormat

SETup:WCTFormat

This section is only applicable to the lab application.

Diagram Conventions

SETup:WCTFormat:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of change of TFC measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of change of TFC multi-measurements to be made when multi-measurement state is ON.

See Multi-Measurement Count .

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:COUNt 5"
! Turns on multi-measurements and sets the number of measurements to 5.

SETup:WCTFormat:COUNt:NUMBer

Function

Sets/queries the number of change of TFC measurements to be made when the multi-measurement state is ON. See Multi-Measurement Count .

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:COUNt:NUMBer 5"
! Sets the number of change of TFC multi-measurements to 5.

SETup:WCTFormat:COUNt:STATe

Function

Sets/queries the change of TFC multi-measurement state. See Multi-Measurement Count .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:COUNt:STATe ON"
! Turns on change of TFC multi-measurements.

SETup:WCTFormat:RMCHannel<12|33|64|144|384>:STEP:DOWN[:SIZE]

Function

Sets/queries the Step Down Size .

Setting

Range: -15.0 to 0.0 dB

Resolution: 0.1 dB

Query

 Same as setting.

*RST Setting
  • RMCHannel12: -7.0 dB
  • RMCHannel33: -7.0 dB
  • RMCHannel64: -10.0 dB
  • RMCHannel144: -12.0 dB
  • RMCHannel384: -12.0 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:RMCHannel12:STEP:DOWN -8"
! Sets the 12.2k RMC Step Down Size to -8 dB.

OUTPUT 714;"SETup:WCTFormat:RMCHannel384:STEP:DOWN -13"
! Sets the 384k RMC Step Down Size to -13 dB.

SETup:WCTFormat:RMCHannel<12|33|64|144|384>:STEP:UP[:SIZE]

Function

Sets/queries the Step Up Size .

Setting

Range: 0.0 to 15.0 dB

Resolution: 0.1 dB

Query

 Same as setting.

*RST Setting
  • RMCHannel12: 7.0 dB
  • RMCHannel33: 7.0 dB
  • RMCHannel64: 10.0 dB
  • RMCHannel144: 12.0 dB
  • RMCHannel384: 12.0 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:RMCHannel12:STEP:UP 8"
! Sets the 12.2k RMC Step Up Size to 8 dB.

OUTPUT 714;"SETup:WCTFormat:RMCHannel384:STEP:UP 13"
! Sets the 384k RMC Step Up Size to 13 dB.

SETup:WCTFormat:RMCHannel<12|33|64|144|384>:STEP:ERRor:LIMit:LOWer

Function

Sets/queries the Step Error Limit: Lower .

Setting

Range: -15.0 to 0.0 dB

Resolution: 0.1 dB

Query

 Same as setting.

*RST Setting
  • RMCHannel12: -2.0 dB
  • RMCHannel33: -2.0 dB
  • RMCHannel64: -2.0 dB
  • RMCHannel144: -3.0 dB
  • RMCHannel384: -3.0 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:RMCHannel12:STEP:ERRor:LIMit:LOWer -3"
! Sets the 12.2k RMC Step Error Limit: Lower to -3 dB.

OUTPUT 714;"SETup:WCTFormat:RMCHannel384:STEP:ERRor:LIMit:LOWer -4"
! Sets the 384k RMC Step Error Limit: Lower to -4 dB.

SETup:WCTFormat:RMCHannel<12|33|64|144|384>:STEP:ERRor:LIMit:UPPer

Function

Sets/queries the Step Error Limit: Upper .

Setting

Range: 0.0 to 15.0 dB

Resolution: 0.1 dB

Query

 Same as setting.

*RST Setting
  • RMCHannel12: 2.0 dB
  • RMCHannel33: 2.0 dB
  • RMCHannel64: 2.0 dB
  • RMCHannel144: 3.0 dB
  • RMCHannel384: 3.0 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:RMCHannel12:STEP:ERRor:LIMit:UPPer 3"
! Sets the 12.2k RMC Step Error Limit: Upper to 3 dB.

OUTPUT 714;"SETup:WCTFormat:RMCHannel384:STEP:ERRor:LIMit:UPPer 4"
! Sets the 384k RMC Step Error Limit: Upper to 4 dB.

SETup:WCTFormat:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the change of TFC measurement's timeout value, and (2) sets the change of TFC measurement's timeout STATe to 1 (on).

The query form returns the change of TFC measurement's timeout value.

See Measurement Timeout .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

10 seconds, (off)

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:TIMeout 5"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WCTFormat:TIMeout:STATe

Function

Sets/queries the change of TFC measurement's timeout state. See Measurement Timeout .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:TIMeout:STATe ON"
! Sets the change of TFC measurement's timeout state to ON.

SETup:WCTFormat:TIMeout:TIME

Function

Sets/queries the change of TFC measurement's timeout setting to be used when the timeout state is set to ON. See Measurement Timeout .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Same as setting

*RST Setting

10 seconds

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:TIMeout:TIME 5"
! Sets the change of TFC measurement's timeout to five seconds.


SETup:WDPAnalysis

SETup:WDPAnalysis

Diagram Conventions

SETup:WDPAnalysis:CONTinuous

Function

Sets/queries the trigger arm state for the dynamic power analysis measurement. The trigger arm state determines whether the dynamic power analysis measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

See Trigger Arm (Single or Continuous) Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (on)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:CONTinuous OFF"
! Sets measurement to single trigger mode.

SETup:WDPAnalysis:FOFFset

Function

Sets/queries the dynamic power analysis frequency offset. See Frequency Offset .

Setting

Range: -5 MHz to +5 MHz

Resolution: 1 Hz

Query

 Same as setting

*RST Setting

 0 Hz

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:FOFFset 960 KHZ"
! Sets the frequency offset to +960 kHz.

SETup:WDPAnalysis:INTerval

Function

Sets/queries the dynamic power analysis measurement interval. See Measurement Interval .

Setting

Range: 100 us to 10 ms

Resolution: 1 ns

Query

 Same as setting

*RST Setting

 +3E-4 s (300 us)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:INTerval 200 US"
! Sets the measurement interval to 200 microseconds.

SETup:WDPAnalysis:LENGth

Function

Sets/queries the dynamic power analysis step length. See Step Length .

The product of Steps and Step Length must not exceed 58.260 ms.

Setting

Range: 100 us to 10 ms

Resolution: 1 ns

Query

 Same as setting

*RST Setting

 +6.66667E-4 s (666.667 us)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:LENGth 700 US"
!Sets the step length to 700 microseconds.

SETup:WDPAnalysis:RRCfilter

Function

Sets/queries the state of the root-raised cosine (RRC) filter. See RRC Filter .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (On)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:RRCfilter OFF"
! Turns the RRC filter off.

SETup:WDPAnalysis:STEPs

Function

Sets/queries the number of steps in the UE's power sequence. See Steps .

The product of Steps and Step Length must not exceed 58.260 ms.

Setting

Range: 1 to 100

Resolution: 1

Query

 Same as setting

*RST Setting

 30

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:STEPs 20"
!Sets the number of steps to 20.

SETup:WDPAnalysis:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the dynamic power analysis measurement's timeout (see Measurement Timeouts ) value, and (2) sets the dynamic power analysis measurement's timeout STATe to 1 (on).

The query form returns the dynamic power analysis measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TIMEout 5"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WDPAnalysis:TIMeout:STATe

Function

Sets/queries the dynamic power analysis measurement's timeout (see Measurement Timeouts ) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TIMEout:STATe ON"

SETup:WDPAnalysis:TIMeout:TIME

Function

Sets/queries the dynamic power analysis measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TIMEout:TIME 5"

SETup:WDPAnalysis:TRIGger:DELay

Function

Sets/queries the dynamic power analysis measurement's trigger delay setting. See Trigger Delay .

Setting

Range: -10 to 10 ms

Resolution: 1 ns

Query

 Same as setting

*RST Setting

 1.83333E-4 s (183.333 us)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TRIGger:DELay 200 US"
! Sets trigger delay to 200 microseconds.

SETup:WDPAnalysis:TRIGger:QUALify:STATe

Function

Sets/queries the trigger qualification state. See Trigger Qualification State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TRIGger:QUALify:STATe ON"
! Turns trigger qualification state on.

SETup:WDPAnalysis:TRIGger:QUALify:TYPe

Function

Sets/queries the trigger qualification type. See Trigger Qualification Type .

Setting

Range: FALL|RISE|RISEFALL

Query

 Same as setting

*RST Setting

 RISE

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TRIGger:QUALify:TYPe FALL"
! Sets the trigger qualification type to RF fall.

SETup:WDPAnalysis:TRIGger:QUALify:FALL

Function

Sets/queries the trigger qualification fall threshold. See Trigger Qualification Fall Threshold .

Setting

Range: 0 to 50 dB

Resolution: 0.01 dB

Query

 Same as setting

*RST Setting

 10 dB

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TRIGger:QUALify:FALL 15"
!Sets the trigger qualification fall threshold to 15 dB.

SETup:WDPAnalysis:TRIGger:QUALify:RISE

Function

Sets/queries the trigger qualification rise threshold. See Trigger Qualification Rise Threshold .

Setting

Range: 0 to 50 dB

Resolution: 0.01 dB

Query

 Same as setting

*RST Setting

 10 dB

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TRIGger:QUALify:RISE 15"
!Sets the trigger qualification rise threshold to 15 dB.

SETup:WDPAnalysis:TRIGger:SOURce

Function

Sets/queries the dynamic power analysis measurement's trigger source. See Trigger Source .

Setting

Range: EXTernal|RISE

Query

Range: EXT|RISE

*RST Setting

 RISE

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TRIGger:SOURce EXTernal"
! Sets the trigger source to external

SETup:WDPAnalysis:TRIGger:THReshold

Function

Sets/queries the RF rise trigger threshold. See RF Rise Trigger Threshold .

Setting

Range: -61.0 dBm to +28 dBm

Resolution: 0.01 dBm

Query

 Same as setting

*RST Setting

 0 dBm

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TRIGger:THReshold 10"
! Sets the RF rise trigger threshold to 10 dBm.


SETup:WILPower

SETup:WILPower

Diagram Conventions

SETup:WILPower:ALGorithm

Function

Sets/queries the power control algorithm for uplink channels. This setting is useful only when the test segment is set to Manual (see SETup:WILPower:SEGment ) and the start power is different from the stop power. See Inner Loop Power Measurement Description for more information.

Setting

Range: ALG1|ALG2

Query

Range: ALG1|ALG2

*RST Setting

ALG2

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:ALGorithm ALG1"
!Sets Power control algorithm to use algorithm 1.

SETup:WILPower:NSLOts

Function

Sets/queries the number of timeslots to be measured which equals to the total number of TPC commands sent for the chosen test segments. This setting is used only during two test configurations: when Test Segment A is selected and when Test Segment Manual is selected with Start Power and Stop Power set to the same values. See Inner Loop Power Measurement Description for more information.

The following sequence of TPC commands are sent in accordance with the selected number of timeslots:

  • 100000101010101 (Number of Slots = 15)
  • 100000101010101111101000001010 (Number of Slots = 30)
  • 100000101010101111101000001010101011111010000 (Number of Slots = 45)
  • 100000101010101111101000001010101011111010000010101010111110 (Num of Slots = 60)

Setting

Range: S15|S30|S45|S60

Query

Range: S15|S30|S45|S60

*RST Setting

 S45

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:NSLOts S60"
!Sets the number of timeslots to be measured to 60.

SETup:WILPower:SEGment

Function

Sets/queries the Inner Loop Power control measurement configuration. With Manual selected, you can build a custom test segment to run. If you select a test segment other than Manual, the test set will run a single test segment as specified in the standard (referred to as Test Steps in the standard). See Inner Loop Power Measurement Description for more information.

Setting

Range: MANual|A|B|C|E|F|G|H

Query

Range: MANual|A|B|C|E|F|G|H

*RST Setting

 A

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:SEGment MAN"
!Sets the segment to be measured to manual.

SETup:WILPower:STEP

Function

Sets/queries the power control step size for the UE transmitter which is the change in the UE transmitter output power in response to a single TPC_cmd derived at UE. ONE is the change of 1 dB and TWO is the change of 2 dB.

This setting is useful only when the test segment is set to Manual (see SETup:WILPower:SEGment ) and the power control algorithm is set to ALG1 (see SETup:WILPower:ALGorithm . See Inner Loop Power Measurement Description for more information.

Setting

Range: ONE|TWO

Query

Range: ONE|TWO

*RST Setting

TWO

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:STEP ONE"
!Sets Power control step size to 1 dB.

SETup:WILPower:STARt

Function

Sets/queries the start power for the measurement in manual mode (see SETup:WILPower:SEGment ). The UE will be instructed to the start power and make the measurements while ramping up/down the power to the specified stop power. See Inner Loop Power Measurement Description for more information.

Setting

Range: -61 dBm to +30 dBm (-50 dBm to +24 dBm for Class 1 UE)

Resolution: 1 dBm

Query

Range: -61 dBm to +30 dBm (-50 dBm to +24 dBm for Class 1 UE)

*RST Setting

+24 dBm

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:STARt 10"
!Sets Power control algorithm to use algorithm 1.

SETup:WILPower:STOP

Function

Sets/queries the stop power for the measurement in manual mode (see SETup:WILPower:SEGment ). The UE will be instructed to the start power and make the measurements while ramping up/down the power to the specified stop power. See Inner Loop Power Measurement Description for more information.

Setting

Range: -61 dBm to +30 dBm (-50 dBm to +24 dBm for Class 1 UE)

Resolution: 1 dBm

Query

Range: -61 dBm to +30 dBm (-50 dBm to +24 dBm for Class 1 UE)

*RST Setting

+24 dBm

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:STOP 0"

SETup:WILPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the Inner Loop Power control measurement's timeout (see Measurement Timeouts ) value, and (2) sets the Inner Loop Power control measurement's timeout STATe to 1 (on).

The query form returns the Inner Loop Power control measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WILPOWER:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WILPower:TIMeout:STATe

Function

Sets/queries the Inner Loop Power control measurement's timeout (see Measurement Timeouts ) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WILPOWER:TIMEOUT:STATE ON"

SETup:WILPower:TIMeout:TIME

Function

Sets/queries the Inner Loop Power control measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WILPOWER:TIMEOUT:TIME 5 S"

SETup:WILPower:TRIGger:DELay

Function

Sets/queries the Inner Loop Power control measurement's trigger delay setting.

This setting can be used to delay the measurement trigger in order to start a measurement during a specific timeslot in the frame. For example, a 1.333 ms delay would cause the trigger to wait until after the first two timeslots have elapsed.

Setting

Range: -10 to 10 milliseconds

Resolution: 0.0001 millisecond

Query

Range: -10 to 10 milliseconds

*RST Setting

0 seconds

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WILPOWER:TRIGGER:DELAY 1MS"


SETup:WIQTuning

SETup:WIQTuning

Diagram Conventions

SETup:WIQTuning:CONTinuous

Function

Sets/queries the trigger arm state for the IQ tuning measurement. The trigger arm state determines whether the IQ tuning measurement will be made once then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WIQTuning:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:WIQTuning:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the IQ tuning measurement's timeout value, and (2) sets the IQ tuning measurement's timeout STATe to 1 (on).

The query form returns the waveform quality measurement's timeout value.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds, off

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WIQTuning:TIMEout:STIMe 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WIQTuning:TIMeout:STATe

Function

Sets/queries the IQ tuning measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WIQTuning:TIMeout:STATe ON"

SETup:WIQTuning:TIMeout:TIME

Function

Sets/queries the IQ tuning measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WIQTuning:TIMeout:TIME 5S"

SETup:WIQTuning:TSLot

Function

Selects which one of the 15 timeslots found in the frame to make measurements on. The measurement interval is defined to be 1 timeslot long.

Setting

Range: 0 to 14

Resolution: 1

Query

Range: 0 to 14

*RST Setting

1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WIQTuning:TSLot 10"

SETup:WIQTuning:TRIGger:SOURce

Function

Sets/queries the waveform quality measurement's trigger source.

Setting

Range: IMMediate|PROTocol|EXTernal|AUTO

Query

Range: IMM|PROT|EXT|AUTO

*RST Setting

 AUTO

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WIQTuning:TRIGger:SOURce AUTO" !selects auto triggering


SETup:WOBWidth

SETup:WOBWidth

Diagram Conventions

SETup:WOBWidth:CONTinuous

Function

Sets/queries the trigger arm state for the occupied bandwidth measurement. The trigger arm state determines whether the occupied bandwidth measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:WOBWidth:PERcent:TOTal:POWer

Function

Sets/queries the percentage of total power parameter used in the occupied bandwidth measurement.

Setting

Range: 70.0 to 99.0 percent

Query

Range: 70.0 to 99.0 percent

*RST Setting

99 percent

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WOBWidth:PERcent:TOTal:POWer 99"
!Sets percentage of total power to 99%.

SETup:WOBWidth:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of occupied bandwidth measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of occupied bandwidth multi-measurements to be made when multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:WOBWidth:COUNt:NUMBer

Function

Sets/queries the number of occupied bandwidth measurements to be made when the multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:COUNT:NUMBER 5"
!Sets the number of occupied bandwidth multi-measurements to 5.

SETup:WOBWidth:COUNt:STATe

Function

Sets/queries the occupied bandwidth multi-measurement state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:COUNT:STATE ON" !Turns on occupied bandwidth multi-measurements.

SETup:WOBWidth:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the occupied bandwidth measurement's timeout (see Measurement Timeouts ) value, and (2) sets the occupied bandwidth measurement's timeout STATe to 1 (on).

The query form returns the occupied bandwidth measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WOBWidth:TIMeout:STATe

Function

Sets/queries the occupied bandwidth measurement's timeout (see Measurement Timeouts ) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:TIMEOUT:STATE ON"

SETup:WOBWidth:TIMeout:TIME

Function

Sets/queries the occupied bandwidth measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:TIMEOUT:TIME 5 S"

SETup:WOBWidth:TRIGger:DELay

Function

Sets/queries the occupied bandwidth measurement's trigger delay setting.

This setting can be used to delay the measurement trigger in order to start a measurement during a specific timeslot in the frame. For example, a 1.333 ms delay would cause the trigger to wait until after the first two timeslots have elapsed.

Setting

Range: -10 to 10 milliseconds

Resolution: 1 nanosecond

Query

Range: -10 to 10 milliseconds

*RST Setting

0 seconds

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:TRIGGER:DELAY 1MS"

SETup:WOBWidth:TRIGger:SOURce

Function

Sets/queries the occupied bandwidth measurement's trigger source.

Setting

Range: IMMediate|PROTocol|AUTO

Query

Range: IMM|PROT|AUTO

*RST Setting

 AUTO

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:TRIGGER:SOURCE IMMEDIATE"


SETup:WOOPower

SETup:WOOPower

Diagram Conventions

SETup:WOOPower:OFF:POWer:LIMit

Function

Sets/queries the Off Power Limit (see Off Power Limit ).
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Setting

Range: -99.99 to 99.0

Resolution: 0.1

Query

Same as setting.

*RST Setting

-55 dBm

Programming Example

OUTPUT 714;"SETup:WOOPower:OFF:POWer:LIMit -54"
! Sets the Off Power Limit to -54 dBm.

SETup:WOOPower:OPEN:LOOP:POWer:LIMit

Function

This command sets symmetrical upper and lower pass/fail limits for the difference between the "on" power and the expected power.

NOTE
This command has been replaced by two separate commands which allow you to independently set the upper and lower pass/fail limits for this measurement result. This command is still available for backwards-compatibility, but we recommend that you use these two new commands instead: SETup:WOOPower:OPEN:LOOP:POWer:UPPer:LIMit SETup:WOOPower:OPEN:LOOP:POWer:LOWer:LIMit .
Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above

Setting

Range: 0.0 to 99.9

Resolution: 0.1

Query

Same as setting.

*RST Setting

 9.0 dB

Programming Example

OUTPUT 714;"SETup:WOOPower:OPEN:LOOP:POWer:LIMit 10"
! Sets the Open Loop Power Error Upper and Lower Limits to 10 dB.

SETup:WOOPower:OPEN:LOOP:POWer:UPPer:LIMit

Function

Sets/queries the Open Loop Power Error Upper Limit (see Open Loop Power Error Upper Limit ).
Requirements

Test Application Revision: A.04 and above

Lab Application Revision: A.02 and above

Setting

Range: 0.0 to 99.9

Resolution: 0.1

Query

Same as setting.

*RST Setting

 9.0 dB

Programming Example

OUTPUT 714;"SETup:WOOPower:OPEN:LOOP:POWer:UPPer:LIMit 10"
! Sets the Open Loop Power Error Upper Limit to 10 dB.

SETup:WOOPower:OPEN:LOOP:POWer:LOWer:LIMit

Function

Sets/queries the Open Loop Power Error Lower Limit (see Open Loop Power Error Lower Limit ).
Requirements

Test Application Revision: A.04 and above

Lab Application Revision: A.02 and above

Setting

Range: -99.9 to 0.0

Resolution: 0.1

Query

Same as setting.

*RST Setting

 -9.0 dB

Programming Example

OUTPUT 714;"SETup:WOOPower:OPEN:LOOP:POWer:LOWer:LIMit -10"
! Sets the Open Loop Power Error Lower Limit to -10 dB.

SETup:WOOPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the PRACH transmit on/off power measurement's timeout value (see Measurement Timeouts ), and (2) sets the timeout STATe to 1 (on).

The query form returns the PRACH transmit on/off power measurement's timeout value.
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

10 seconds, 0 (off)

Programming Example

OUTPUT 714;"SETup:WOOPower:TIMeout 5"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WOOPower:TIMeout:STATe

Function

Sets/queries the PRACH transmit on/off power measurement's timeout state (see Measurement Timeouts ).
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:WOOPower:TIMeout:STATe ON"

SETup:WOOPower:TIMeout:TIME

Function

Sets/queries the PRACH transmit on/off power measurement's timeout setting (see Measurement Timeouts ) to be used when the timeout state is set to ON.
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETup:WOOPower:TIMeout:TIME 5"


SETup:WOOSynch

SETup:WOOSynch

This section is only applicable to the lab application.

Last updated: December 21, 2004

Diagram Conventions

SETup:WOOSynch:INTerval:AB

Function

 Sets/queries Segment Ta-b Interval .

Setting

Range: 0.04 to 5.00 seconds

Resolution: 0.04 seconds

Query

 Same as setting

*RST Setting

 5.00 seconds

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:INTerval:AB 3.5"
! Sets Segment Ta-b Interval to 3.52 s (because the resolution is 0.04 seconds).

SETup:WOOSynch:INTerval:CD

Function

 Sets/queries Segment Tc-d Interval .

Setting

Range: 0.04 to 5.00 seconds

Resolution: 0.04 seconds

Query

 Same as setting

*RST Setting

 5.00 seconds

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:INTerval:CD 3.5"
! Sets Segment Tc-d Interval to 3.52 s (because the resolution is 0.04 seconds).

SETup:WOOSynch:INTerval:DE

Function

 Sets/queries Segment Td-e Interval .

Setting

Range: 0.04 to 5.00 seconds

Resolution: 0.04 seconds

Query

 Same as setting

*RST Setting

 5.00 seconds

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:INTerval:DE 3.5"
! Sets Segment Td-e Interval to 3.52 s (because the resolution is 0.04 seconds).

SETup:WOOSynch:RATio:AB

Function

 Sets/queries DPCCH Quality Ratio Qa-b .

Setting

Range: -10.0 to -30.0 dB

Resolution: 0.1 dB

Query

 Same as setting

*RST Setting

 -21.6 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:RAT:AB -22.0"
! Sets DPCCH Quality Ratio Qa-b to -22.0 dB.

SETup:WOOSynch:RATio:BD

Function

 Sets/queries DPCCH Quality Ratio Qb-d .

Setting

Range: -10.0 to -30.0 dB

Resolution: 0.1 dB

Query

 Same as setting

*RST Setting

 -28.40 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:RATio:BD -28.0"
! Sets DPCCH Quality Ratio Qb-d to -28.0 dB.

SETup:WOOSynch:RATio:DE

Function

 Sets/queries DPCCH Quality Ratio Qd-e .

Setting

Range: -10.0 to -30.0 dB

Resolution: 0.1 dB

Query

 Same as setting

*RST Setting

 -24.40 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:RATio:DE -24.0"
! Sets DPCCH Quality Ratio Qd-e to -24.0 dB.

SETup:WOOSynch:RATio:E

Function

 Sets/queries DPCCH Quality Ratio Qe+ .

Setting

Range: -10.0 to -30.0 dB

Resolution: 0.1 dB

Query

 Same as setting

*RST Setting

 -17.60 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:RATio:E -18.0"
! Sets DPCCH Quality Ratio Qe+ to -18.0 dB.

SETup:WOOSynch:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the measurement's timeout (see Measurement Timeouts ) value, and (2) sets the measurement's timeout STATe to 1 (on).

The query form returns the measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

20 seconds, (off)

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:TIMeout 5"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WOOSynch:TIMeout:STATe

Function

Sets/queries the measurement's timeout state (see Measurement Timeouts ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:TIMeout:STATe ON"
! Sets the measurement's timeout state to ON.

SETup:WOOSynch:TIMeout:TIME

Function

Sets/queries the measurement's timeout setting to be used when the timeout state is set to ON (see Measurement Timeouts ).

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Same as setting

*RST Setting

20 seconds

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:TIMeout:TIME 5"
! Sets the measurement's timeout to five seconds.


SETup:WPDiscon

SETup:WPDiscon

Diagram Conventions

SETup:WPDiscon:INTerval

Function

Sets/queries the Measurement Interval .

This setting is only applicable when SETup:WPDiscon:PCPattern is set to NONE .

Setting

Range: 2 to 90 slots

Resolution: 1 slot

Query

 Same as setting.

*RST Setting

2 slots

Requirements

Test Application Revision: A.05 and above

Test Application Revision A.06 changed range upper limit from 75 to 90

Lab Application Revision: B.01 and above

Lab Application Revision C.01 changed range upper limit from 75 to 90

Programming Example

OUTPUT 714;"SETup:WPDiscon:INTerval 6"
! Sets the measurement interval to 6 slots.

SETup:WPDiscon:NPRepetition

Function

Sets/queries the Number of Pattern Repetitions .

This setting is only applicable when SETup:WPDiscon:PCPattern is set to DN5_4UP or UP5_4DN .

Setting

Range: 1 to 10

Resolution: 1

Query

 Same as setting.

*RST Setting

2

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:NPRepetition 10"
! Sets the Number of Pattern Repetitions to 10.

SETup:WPDiscon:PCPattern

Function

Sets/queries the Power Control Pattern .

Setting

Range: DN5_4UP|NONE|UP5_4DN

Query

 Same as setting.

*RST Setting

NONE

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:PCPattern DN5_4UP"
! Sets the Power Control Pattern to 5DOWN/4UP.

SETup:WPDiscon:RTIMeslot

Function

Sets/queries the Reference Timeslot .

This setting is only applicable when SETup:WPDiscon:PCPattern is set to NONE .

Setting

Range: 0 to 14

Resolution: 1

Query

 Same as setting.

*RST Setting

 0

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:RTIMeslot 8"
! Sets the reference timeslot to the 9th slot of the first available frame.

SETup:WPDiscon:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the phase discontinuity measurement's timeout (see Measurement Timeouts ) value, and (2) sets the phase discontinuity measurement's timeout STATe to 1 (on).

The query form returns the phase discontinuity measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

10 seconds, (off)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:TIMeout 5"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WPDiscon:TIMeout:STATe

Function

Sets/queries the phase discontinuity measurement's timeout state (see Measurement Timeouts ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:TIMeout:STATe ON"
! Sets the phase discontinuity measurement's timeout state to ON.

SETup:WPDiscon:TIMeout:TIME

Function

Sets/queries the phase discontinuity measurement's timeout setting to be used when the timeout state is set to ON (see Measurement Timeouts ).

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Same as setting

*RST Setting

10 seconds

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:TIMeout:TIME 5"
! Sets the phase discontinuity measurement's timeout to five seconds.

SETup:WPDiscon:TRIGger:SOURce

Function

Sets/queries the Trigger Source .

Setting

Range: PROTocol|EXTernal

Query

Range: PROT|EXT

*RST Setting

 PROT

Requirements

Test Application Revision: A.05 and above

Test Application Revision A.06 changed *RST setting from AUTO to PROT

Lab Application Revision: B.01 and above

Lab Application Revision C.01 changed *RST setting from AUTO to PROT

Programming Example

OUTPUT 714;"SETup:WPDiscon:TRIGger:SOURce PROTocol"
! Sets the phase discontinuity measurement trigger source to PROTocol.


SETup:WPPAnalysis

SETup:WPPAnalysis

This section is only applicable to the lab application.

Diagram Conventions

SETup:WPPAnalysis:TRANsient

Function

Sets/queries the Transient Period setting.

Setting

Range: INCLude|EXCLude

Query

Range: INCL|EXCL

*RST Setting

EXCL

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPPAnalysis:TRANsient EXCLude"
! Excludes PRACH preamble transient periods from PRACH analysis.

SETup:WPPAnalysis:TRIGger:DELay

Function

 Sets/queries the Trigger Delay . This setting is applied only when SETup:WPPAnalysis:TRIGger:SOURce is set to RISE.

Setting

Range: -5120 to 5120 chips

Resolution: 1 chip

Query

Same as setting

*RST Setting

 0 chips

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPPAnalysis:Trigger:DELay 284"

SETup:WPPAnalysis:TRIGger:SOURce

Function

 Sets/queries the Trigger Source .

Setting

Range: PROTocol|EXTernal|RISE

Query

Range: PROT|EXT|RISE

*RST Setting

 PROT

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPPAnalysis:TRIGger:SOURce RISE"
! Sets the PRACH preamble analysis trigger to RF rise.

SETup:WPPAnalysis:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the PRACH preamble analysis timeout (see Measurement Timeouts ) value, and (2) sets the PRACH preamble analysis timeout STATe to 1 (on).

The query form returns the PRACH preamble analysis timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

10 seconds, off

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPPAnalysis:TIMeout 5"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WPPAnalysis:TIMeout:STATe

Function

Sets/queries the PRACH preamble analysis timeout state (see Measurement Timeouts ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPPAnalysis:TIMeout:STATe ON"
! Sets the timeout state to ON.

SETup:WPPAnalysis:TIMeout:TIME

Function

Sets/queries PRACH preamble analysis timeout setting to be used when the timeout state is set to ON (see Measurement Timeouts ).

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Same as setting

*RST Setting

10 seconds

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPPAnalysis:TIMeout:TIME 5"
! Sets the timeout to 5 seconds.


SETup:WSEMask

SETup:WSEMask

Diagram Conventions

SETup:WSEMask:CONTinuous

Function

Sets/queries the trigger arm state for the spectrum emission mask measurement. The trigger arm state determines whether the spectrum emission mask measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:WSEMask:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of spectrum emission mask measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of spectrum emission mask multi-measurements to be made when multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:WSEMask:COUNt:NUMBer

Function

Sets/queries the number of spectrum emission mask measurements to be made when the multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:COUNT:NUMBER 5"
!Sets the number of spectrum emission mask multi-measurements to 5.

SETup:WSEMask:COUNt:STATe

Function

Sets/queries the spectrum emission mask multi-measurement state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:COUNT:STATE ON"
! Turns on spectrum emission mask multi-measurements.

SETup:WSEMask:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the spectrum emission mask measurement's timeout (see Measurement Timeouts ) value, and (2) sets the spectrum emission mask measurement's timeout STATe to 1 (on).

The query form returns the spectrum emission mask measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:TIMEOUT:STIME 5 S"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WSEMask:TIMeout:STATe

Function

Sets/queries the spectrum emission mask measurement's timeout (see Measurement Timeouts ) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:TIMEOUT:STATE ON"

SETup:WSEMask:TIMeout:TIME

Function

Sets/queries the spectrum emission mask measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:TIMEOUT:TIME 5 S"

SETup:WSEMask:TRIGger:DELay

Function

Sets/queries the spectrum emission mask measurement's trigger delay setting.

This setting can be used to delay the measurement trigger in order to start a measurement during a specific timeslot in the frame. For example, a 1.333 ms delay would cause the trigger to wait until after the first two timeslots have elapsed.

Setting

Range: -10 to 10 milliseconds

Resolution: 1 nanosecond

Query

Range: -10 to 10 milliseconds

*RST Setting

0 seconds

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:TRIGGER:DELAY 1MS"

SETup:WSEMask:TRIGger:SOURce

Function

Sets/queries the spectrum emission mask measurement's trigger source.

Setting

Range: IMMediate|PROTocol|AUTO

Query

Range: IMM|PROT|AUTO

*RST Setting

 AUTO

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:TRIGGER:SOURCE IMMEDIATE"

SETup:WSEMask:LIMit:BWIDTH30

Function

Sets/queries the spectrum emission mask measurement's pass/fail limits for the 30 kHz bandwidth filter frequency offsets.

There are two 30 kHz bandwidth filter pass/fail settings, one for the +/-2.5 MHz offset and one for the +/-3.5 MHz offset.

Setting

Range: -90 to 0 dBc

Resolution: 0.01 dBc

Query

Range: -90 to 0

*RST Setting

 -35 dBc (+/-2.5 MHz offset), -50 dBc(+/-3.5 MHz offset)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:LIMit:BWIDTH30 -35,-34"
! Sets the +/-2.5 MHz frequency offset pass/fail limit to -35
! and sets the +/-3.5 MHz frequency offset to -34

SETup:WSEMask:LIMit:BWIDTH1000

Function

Sets/queries the spectrum emission mask measurement's pass/fail limits for the 1 MHz bandwidth filter frequency offsets.

There are four 1 MHz bandwidth filter pass/fail settings

  • +/-3.5 MHz offset
  • +/-7.5 MHz offset
  • +/-8.5 MHz offset
  • +/-12.5 MHz offset

Setting

Range: -90 to 0 dBc

Resolution: 0.01 dBc

Query

Range: -90 to 0

*RST Setting

 -35 dBc (+/-3.5 MHz offset), -39 dBc (+/-7.5 MHz offset), -49 dBc (+/-8.5 MHz offset), -49 dBc(+/-12.5 MHz offset)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:LIMit:BWIDTH1000 -35,-34,-45,-45"
! Sets the pass/fail limits for the four SEM 1 MHz filter frequency offsets.


SETup:WTPower

SETup:WTPower

Diagram Conventions

SETup:WTPower:CONTinuous

Function

Sets/queries the trigger arm state for the thermal power measurement. The trigger arm state determines whether the thermal power measurement will be made once then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WTPOWER:CONTINUOUS ON"
!Sets measurement to single trigger mode.

SETup:WTPower:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of thermal power measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of thermal power multi-measurements to be made when multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WTPOWER:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:WTPower:COUNt:NUMBer

Function

Sets/queries the number of thermal power measurements to be made when the multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WTPOWER:COUNT:NUMBER 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:WTPower:COUNt:STATe

Function

Sets/queries the multi-measurement state of the thermal power measurement.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WTPOWER:COUNT:STATE ON" !Turns on multi-measurements.

SETup:WTPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the thermal power measurement's timeout value, and (2) sets the thermal power measurement's timeout STATe to 1 (on).

The query form returns the channel power measurement's timeout value.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds, off

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WTPOWER:TIMEOUT:STIME 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WTPower:TIMeout:STATe

Function

Sets/queries the thermal power measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WTPOWER:TIMEOUT:STATE ON"

SETup:WTPower:TIMeout:TIME

Function

Sets/queries the thermal power measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WTPOWER:TIMEOUT:TIME 5S"


SETup:WWQuality

SETup:WWQuality

Diagram Conventions

SETup:WWQuality:CONTinuous

Function

Sets/queries the trigger arm state for the waveform quality measurement. The trigger arm state determines whether the waveform quality measurement will be made once then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:WWQuality:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of waveform quality measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of waveform quality multi-measurements to be made when multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:WWQuality:COUNt:NUMBer

Function

Sets/queries the number of waveform quality measurements to be made when the multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:COUNT:NUMBER 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:WWQuality:COUNt:STATe

Function

Sets/queries the multi-measurement state of the waveform quality measurement.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:COUNT:STATE ON" !Turns on multi-measurements.

SETup:WWQuality:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the waveform quality measurement's timeout value, and (2) sets the waveform quality measurement's timeout STATe to 1 (on).

The query form returns the waveform quality measurement's timeout value.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds, off

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:TIMEOUT:STIME 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WWQuality:TIMeout:STATe

Function

Sets/queries the waveform quality measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:TIMEOUT:STATE ON"

SETup:WWQuality:TIMeout:TIME

Function

Sets/queries the waveform quality measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:TIMEOUT:TIME 5S"

SETup:WWQuality:TSLot

Function

Selects which one of the 15 timeslots found in the frame to make measurements on. The measurement interval is defined to be 1 timeslot long.

Setting

Range: 0 to 16

Resolution: 1

Query

Range: 0 to 14

*RST Setting

1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:TSLOT 10"

SETup:WWQuality:TRIGger:SOURce

Function

Sets/queries the waveform quality measurement's trigger source.

Setting

Range: IMMediate|PROTocol|EXTernal|AUTO

Query

Range: IMM|PROT|EXT|AUTO

*RST Setting

 AUTO

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:TRIGGER:SOURCE AUTO"


CALL:SMService

CALL:SMService

This section is only applicable to the lab application.

Diagram Conventions

CALL:SMService:CBRoadcast:MESSage[<n>]:CODE

Function

This sets the code for Cell Broadcast Message n, where n can be 1, 2, or 3.

Setting

 Range: 0 to 1023

Query

 Range: 0 to 1023

*RST setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:CODE 1000"
! Sets the Cell Broadcast Message 1 to have 1000 as the code.

CALL:SMService:CBRoadcast:MESSage[<n>]:IDENtifier

Function

This sets the message identifier for Cell Broadcast Message n (where n can be 1,2, or 3).

Setting

 Range: 0 to 65534

Query

 Range: 0 to 65534

*RST setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:IDENtifier 1500"
! Sets the message identifier for Cell Broadcast Message 1 to 1500.

CALL:SMService:CBRoadcast:MESSage[<n>]:LANGuage

Function

This sets the language for Cell Broadcast Message n, where n can be 1, 2, or 3.

Setting

 Fixed string (see table below)

Query

 Fixed string

*RST setting

 ENGLish
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:LANGuage ENGLish"
! Sets the language to English for the Cell Broadcast Message 1.

Language values
Parameter Form | Query Value
GERMan | GERM
ENGLish | ENGL
ITALian | ITAL
FRENch | FREN
SPANish | SPAN
DUTCh | DUTC
SWEDish | SWED
DANish | DAN
PORTuguese | PORT
FINNish | FINN
NORWegian | NORW
GREek | GRE
TURKish | TURK
HUNGarian | HUNG
POLish | POL
UNSPecified | UNSP

CALL:SMService:CBRoadcast:MESSage[<n>]:STATe

Function

Enables Cell Broadcast Message n, where n is 1, 2 or 3. Cell Broadcast service must be started for a message to be sent. See CALL:SMService:CBRoadcast:STARt .

Setting

 0|OFF|1|ON

Query

 0||1

*RST setting

Message 1 is ON; Messages 2 and 3 are OFF
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage2:STATe ON"
! Sets the state for the Cell Broadcast Message 2 to ON,
! which is necessary to allow a message to be sent

CALL:SMService:CBRoadcast:MESSage[<n>]:TEXT

Function

Selects the text to be transmitted for Cell Broadcast Message n, where n is 1, 2 or 3.

Setting

 TXT1|TXT2|CUSTom

Query

 TXT1|TXT2|CUST

*RST setting

Message 2 is TXT2; Messages 1and 3 are TXT1
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:TEXT TXT2"
! Sets the Cell Broadcast Message 1 to contain the predefined TXT2 text.

CALL:SMService:CBRoadcast:MESSage[<n>]:UPDate

Function

This sets the Update number for Cell Broadcast Message n, where n can be 1, 2, or 3.

Setting

 Range: 0 to 15

Query

 Range: 0 to 15

*RST setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:UPDate 10"
! Sets the Message Update number to 10 for the Cell Broadcast Message 1.

CALL:SMService:CBRoadcast:STARt

Function

Starts the Cell Broadcast Service
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:STARt"
! Starts the Cell Broadcast Service.

CALL:SMService:CBRoadcast:STOP

Function

 Stops the Cell Broadcast Service
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:CBRoadcast:STOP"
! Stops the Cell Broadcast Service.

CALL:SMService:CBRoadcast:TEXT:CUSTom

Function

This sets the string of the custom text which can be sent with any of the Cell Broadcast Messages.

Setting

 String: 7 bit ACSII characters up to 93 characters in length in quotes.

Query

 String: 7 bit ACSII characters up to 93 characters in length.

*RST Setting

 "Enter your text here"
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:CBRoadcast:TEXT:CUSTom "Hello World" "
! Sets `Hello World' as a custom text which can be sent with
! any of the Cell Broadcast Messages.

CALL:SMService:CBRoadcast:TXT1?

Function

This queries the fixed Text Message 1.

Query

 Returns a string.
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:TXT1?"
! Queries for the fixed Text Message 1.

CALL:SMService:CBRoadcast:TXT2?

Function | This queries the fixed Text Message 2.
Query | Returns a string.
Requirements | Lab Application Revision: C.01 and above
Programming Example OUTPUT 714;"CALL:SMService:CBRoadcast:TXT2?" ! Queries for the fixed Text Message 2.

CALL:SMService:HTTProtocol:INPut

Function

Enables or disables the HTTP input interface for mobile terminated SMS.

Setting

 0|OFF|1|ON

Query

 0|1

*RST setting

OFF
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:HTTProtocol:INPut ON"
! Enables the HTTP input interface for mobile terminated SMS

CALL:SMService:HTTProtocol:OUTPut

Function | Enables or disables the HTTP output interface for mobile originated SMS.
Setting | 0|OFF|1|ON
Query | 0|1
*RST setting | OFF
Requirements | Lab Application Revision: C.01 and above
Programming Example OUTPUT 714;"CALL:SMService:HTTProtocol:OUTPut 1" ! Enables the HTTP output interface for mobile originated SMS.

CALL:SMService:PTPoint:MORiginated:LOOPback

Function

Enables the loopback of a point-to-point message. The message is sent to the mobile station with the same parameters as the most recently received text message.

Setting

 0|OFF|1|ON

Query

 0|1

*RST setting

 0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:LOOPback ON"
! Enable loopback of a point to point message.

CALL:SMService:PTPoint:MORiginated[:MESSage]:CLEar[:ALL]

Function

Clears all Received Message data. This includes Transport, Length, Format, Contents, Text, Destination Address, Message Count, More Messages to Send Indication, Data Coding Scheme, User Data Header Indication, User Data Header Length, Status Report Request, and Message Reference.

Empties the message queue if it is enabled.

Clears the mobile terminated send state (See CALL:SMService:PTPoint[:MTERminated]:SEND:STATe? ).
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:CLEar"
! Clears all Received Message Data.

CALL:SMService:PTPoint:MORiginated[:MESSage]:CONTents?

Function

Queries the contents of the last mobile originated message and returns the raw message content.
Query Returns an ASCII formatted string of hexadecimal characters.
Range: 0 to 280 characters

*RST setting

 Empty string.
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:CONTents?"
! Returns the raw content of the last mobile originates message.

CALL:SMService:PTPoint:MORiginated[:MESSage]:COUNt?

Function

Queries the number of messages received by the test set.
Query Range: 0 to 255
Resolution: 1

*RST setting

 0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:COUNt?"
! Returns the number of messages received by the test set.

CALL:SMService:PTPoint:MORiginated[:MESSage]:DCSCheme?

Function

Queries the Data Coding Scheme (TP-DCS) of the last message received by the test set or the current message available in the message queue.
Query Range: 0 to 255 or 9.91E+37 (NAN)
Resolution: 1

*RST setting

 9.91E+37
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:DCSCheme?"
! Queries the Data Coding Scheme of the last message received
! by the test set or the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated[:MESSage]:DESTination?

Function

Queries the destination address of the last SMS message received by the test set.
Query Returns a string.

*RST setting

 "" (null string)
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:DESTination?"
! Queries the destination address of the last SMS message received by the test set.

CALL:SMService:PTPoint:MORiginated[:MESSage]:FORMat?

Function

Queries the Last Received Message Format.

Query

 ASC|BIN|UCS2|INV|UNKN

ASC: 7 bit ASCII string
BIN: Binary data
UCS2: Unicode Character Set 2
INV: Invalid (returned when no messages have been received
UNKN: Unknown message format

*RST setting

 INV
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:FORMat?"
! Queries the Last Received Message Format.

CALL:SMService:PTPoint:MORiginated[:MESSage]:LENGth?

Function

Queries the Last Received Message Length.
Query Returns a number value or 9.91E+37 (NAN).

ASCII - the number of characters in the ASCII text message
Binary/UCS2 - the number of octets of data in the message
No message received - NAN

*RST setting

 9.91E37
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:LENGth?"
! Queries the Last Received Message Length.

CALL:SMService:PTPoint:MORiginated[:MESSage]:MREFerence?

Function

Queries the Message Reference (TP-MR) of the last message received by the test set or the current message available in the message queue.
Query Range: 0 to 255 or 9.91E+37 (NAN)

*RST setting

 9.91E+37
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:MREFerence?"
! Queries the Message Reference (TP-MR) of the last message received
! by the test set or the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated[:MESSage]:PIDentifier?

Function

Queries the Protocol Identifier (TP-PID) of the last message received by the test set or the current message available in the message queue.
Query Range: 0 to 255 or 9.91E+37 (NAN)

*RST setting

 9.91E+37
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:PIDentifier?"
!Queries the Protocol Identifier (TP-PID) of the last message received
! by the test set or the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated[:MESSage]:SRRequest?

Function

Queries the Status Report Request (TP-SRR) of the last message received by the test set or the current message available in the message queue.
Query 0 | 1 | 9.91E+37 (NAN)

*RST setting

 9.91E+37
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:SRRequest?"
! Queries the Status Report Request (TP-SRR) of the last message received
! by the test set or the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated[:MESSage]:TEXT?

Function

Queries the text from the last SMS message received by the test set.
Query Returns a string.

*RST setting

 "" (null string)
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:TEXT?"
! Queries the text from the last SMS message received by the test set.

CALL:SMService:PTPoint:MORiginated[:MESSage]:TRANsport?

Function

Queries the reported transportation mechanism used by the mobile station when it originates a point-to-point SMS message.
Query Range: CSD|INV|PSD

CSD: CS Domain was used
INV: Invalid (returned when no messages have been received by the test set)
PSD: PS Domain was used
*RST Setting INV
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:TRANsport?"
! Queries the reported transportation mechanism used by the mobile station
! when it originates a point-to-point SMS message.

CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHind?

Function

Queries the User Data Header Indication (TP-UDHI) of the last message received by the test set or the current message available in the message queue.
Query 0 | 1 | 9.91E+37 (NAN)

*RST setting

 9.91E+37
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:UDHind?"
! Queries the User Data Header Indication (TP-UDHI) of the last message
! received by the test set or the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHLength?

Function

Queries the User Data Header Length of the last message received by the test set or the current message available in the message queue.
Query Range: 0 to 140 bytes or 9.91E+37 (NAN)

*RST setting

 9.91E+37
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:UDHLength?"
! Queries the User Data Header Length of the last message received
! by the test set or the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated:QUEue[:STATe]

Function

 Enables SMS message queuing. This causes the test set to put received SMS-SUBMIT messages into a queue instead of overwriting existing messages.

Setting

 0|OFF|1|ON
Query | Range: 0|1
*RST Setting | 0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:QUEue 1"
! Enables SMS message queuing. This causes the test set to put received
! SMS-SUBMIT messages into a queue instead of overwriting existing messages.

CALL:SMService:PTPoint:MORiginated:QUEue:COUNt?

Function

Queries the current number of SMS messages held in the message queue.
Query Range: 0 to 255
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:QUEue:COUNt?"
! Enables SMS message queuing. This causes the test set to put received
! SMS-SUBMIT messages into a queue instead of overwriting existing messages.

CALL:SMService:PTPoint:MORiginated:QUEue:NEXT

Function

Extracts the next message in the queue, making it available for query. Sending this command clears the previously available message results.
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:QUEue:NEXT"
! Enables SMS message queuing. This causes the test set to put received
! SMS-SUBMIT messages into a queue instead of overwriting existing messages.

CALL:SMService:PTPoint:MORiginated:REPort:MODE:STATus

Function

Sets/queries the method used to send Status Reports.
Setting | AUTO | MANual
Query | AUTO | MAN
*RST Setting | AUTO
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:REPort:MODE:STATus MANual"
! Sets/queries the method used to send Status Reports to Manual.

CALL:SMService:PTPoint:MORiginated:REPort:MODE:SUBMit

Function

Sets/queries the method used to send Submit Reports.
Setting | AUTO | MANual
Query | AUTO | MAN
*RST Setting | AUTO
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:REPort:MODE:SUBMit AUTO" !Sets/queries the method used to send Submit Reports to Auto.

CALL:SMService:PTPoint[:MTERminated]:CONTents

Function | This selects the content to be sent in mobile terminated SMS messages.
Setting | Range: TXT1 | TXT2 | CTEXt | CDATa
Query | Range: TXT1 | TXT2 | CTEX | CDAT
*RST Setting | TXT1
Requirements | Lab Application Revision: C.01 and above
Programming Example OUTPUT 714;"CALL:SMService:PTPoint:CONTents TXT1" ! Selects TXT1 to be be sent in subsequent mobile terminated SMS messages.

CALL:SMService:PTPoint[:MTERminated]:DATA:CUSTom

Function

Sets/queries the data to be sent in mobile terminated SMS messages. SMS data is formatted in octets, therefore there must be and even number of characters in the string.

This data is only sent to the mobile station if the CALL:SMService:PTPoint[:MTERminated]:CONTents is set to CDATA.

Setting

Range: 0 to 280 ASCII formatted hexadecimal characters

Query

Range: 0 to 280 ASCII formatted hexadecimal characters

*RST Setting

"00"
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:DATA:CUSTom `112A'"
! This sets the hex data 112A to be sent in subsequent mobile terminated SMS messages.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:DCSCheme

Function

Configures the TP-DCS (Data Coding Scheme) header element, used to identify the coding scheme used in the message contents.

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:DCSCheme 75"
! Configures the TP-DCS (Data Coding Scheme) header element, used to identify the coding scheme used in the message contents to 75.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:FCAuse

Function

Configures the TP-FCS (Failure Cause) header element, used to identify the reason for a previous SMS-SUBMIT failure. This setting is only relevant to the Submit Report message type. It is not relevant to either Deliver or Status Report message types.

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

255
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:FCAuse 20"
! Sets the TP-FCS (Failure Cause) header element, used to identify
! the reason for a previous SMS-SUBMIT failure.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:MMTSend

Function

Configures the TP-MMS (More Messages to Send) header element.

Setting

 0 | 1
0: More messages to send
1: No more messages

Query

 0 | 1

*RST Setting

1
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MMTSend 1"
! Sets the TP-MMS (More Messages to Send) header element to
! indicate that there are no more messages.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:MREFerence

Function

Configures the TP-MR (Message Reference) header element. This element is only included in mobile terminated SMS messages if their message type is SMS-STATUS REPORT. It is used to identify the previously submitted mobile originated SMS to which the status report message relates.

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MREFerence 100"
! Sets the TP-MR (Message Reference) header element for
! subsequent mobile terminated SMS messages.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress

Function

Configures the address value portion of the TP-OA (Originating Address) header element, used to identify the sender of the message.

Setting

 ASCII string of digits 0-9, the symbols * and #, and the lower case characters a, b, and c.
Range: 2 to 20 characters

Query

 ASCII string

*RST Setting

"8960"
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:OADDress "abc" "
! Changes the address value portion of the TP-OA (Originating Address) header
! element to abc, which is used to identify the sender of the message.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:PLAN

Function

Configures the number plan identification bits of the Type of Address field of the TP-OA (Originating Address) header element, used to identify the sender of the message.

Setting

 Range: UNKNown | ISDN | DATA | TELex | PRIVate | NATional

Query

 Range: UNKN | ISDN | DATA | TEL | PRIV | NAT

*RST Setting

UNKN
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:OADDress:PLAN NATional"
! Sets the number plan identification bits of the Type of Address field of the
! TP-OA (Originating Address) header element to National, which is used to
! identify the sender of the message.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:TYPE

Function

Configures the Type of Number bits of the Type of Address field of the TP-OA (Originating Address) header element, used to identify the sender of the message.

Setting

 Range: UNKNown | INATional | NATional | NETWork | SUBScriber

Query

 Range: UNKN | INAT | NAT | NETW | SUBS

*RST Setting

 UNKN
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:OADDress:TYPE SUBScriber"
! Sets the Type of Number bits of the Type of Address field of the TP-OA (Originating Address)
! header element to `Suscriber', which is used to identify the sender of the message.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:PIDentifier

Function

Configures the TP-PID (Protocol Identifier) header element, used to identify the higher layer protocol used to send the SMS message.

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MTERminated:MESSage:PIDentifier 100"
! Configures the TP-PID (Protocol Identifier) header element, used to identify the
! higher layer protocol used to send the SMS message.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:PINDicator

Function

Configures the TP-PI (Parameter Indicator) header element, used to identify the presence of optional elements within SMS-SUBMIT-REPORT and SMS-STATUS-REPORT messages.

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

7
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:PINDicator 5"
! Sets the TP-PI (Parameter Indicator) header element to `5', which is used to identify
! the presence of optional elements within SMS-SUBMIT-REPORT and
! SMS-STATUS-REPORT messages.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress

Function

Configures the TP-RA (Recipient Address) header element, used to identify the recipient of the previously submitted SMS message.

Setting

 ASCII string of digits 0-9, the symbols *, #, and +, and the letters a, b, and c.
Range: 2 to 20 characters

Query

 ASCII string

*RST Setting

"8960"
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:RADDress `abc'"
! Configures the TP-RA (Recipient Address) header element,
! used to identify the recipient of the previously submitted SMS messages.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:RPATh

Function

Configures the TP-RP (Reply Path) header element.

Setting

 0 | 1
0: A reply path does not exist
1: A reply path exists

Query

 0 | 1

*RST Setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:RPATh 1"
! Configures the TP-RP (Rely Path) header element to indicate the existence
! of a reply path.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:SREPort

Function

Configures the TP-SRI (Status Report Indication) header element, used to indicate to the mobile station that a status report was requested for this message by the sender.

Setting

 0 | 1
0: Status report not requested
1: Status report requested

Query

 0 | 1

*RST Setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:SREPort 1"
! Sets the state of the TP-SRI (Status Report Indication) header element to 1,
! which is used to indicate that the mobile station should send a status report to the test set.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:STATus

Function

Configures the TP-ST (Status) header element, used to describe the status of the previously originated mobile SMS.

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:STATus 30"
! Sets the TP-ST (Status) header element to 30, which is used to describe
! the status of the previously originated mobile SMS.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE

Function

Sets the type of SMS message sent from the test set to the mobile station.

Setting

 DELiver | SUBReport | STATReport

Query

 DEL | SUBR |STATR

*RST Setting

 DELiver
Requirements

Lab Application Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TYPE"
! Sets the type of SMS message sent from the test set to the mobile station to DELiver.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE:SUBReport:RPTYpe

Function

Sets the RP type to use when sending an SMS-SUBMIT-REPORT message from the test set to the mobile station.

Setting

 ERRor | ACK

Query

 ERR | ACK

*RST Setting

 ACK
Requirements

Lab Application Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TYPE:SUBReport:RPTYpe ACK"
! Sets the RP type to `ACK' to use when sending an SMS-SUBMIT-REPORT
! message from the test set to the mobile station.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:UDHind

Function

Configures the TP-UDHI (User Data Header Indication) header element. The TP-UDHI is used to indicate that the user data sent to the mobile station contains header information. This command is used when binary or concatenated messages are sent, but not with simple text messages.

Setting

 0 | 1
0: Content does not include header
1: Content includes header

Query

 0 | 1

*RST Setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:UDHind 1"
! Sets the TP-UDHI (User Data Header Indication) header element to 1,
! which is used to indicate that the user data sent to the mobile station does
! contain header information.

CALL:SMService:PTPoint[:MTERminated]:RCAuse?

Function

Queries the reject cause value when a mobile terminated message is rejected by the mobile station. If the last message sent to the mobile station was not rejected, NAN is returned for the reject cause value. If the last message sent to the mobile station was rejected, this query returns the decimal value of the reject cause.

Query

 Range: 0 to 255 (decimal) See Reject Cause
and 9.91 E+37 (NAN)

*RST Setting

9.91 E+37 (NAN)
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:RCAuse?"
! Queries the reject cause decimal value when a mobile terminated message is rejected by the
! mobile station. If the last message sent to the mobile was not rejected, the query returns NAN.

CALL:SMService:PTPoint[:MTERminated]:SEND[:IMMediate]

Function

 Sends a Point to Point SMS message.
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:SEND"
! Sends a Point to Point SMS message .

CALL:SMService:PTPoint[:MTERminated]:SEND:STATe?

Function

Queries the state of the last message sent to the mobile station.

Query

Range: IDLE | SEND | ACK | NACK | REJ | FAIL
IDLE: No message has been sent
SEND: Message send in progress
ACK: Message acknowledged by mobile station
NACK: Message was not acknowledged by mobile station and send timed out
REJ: Message was rejected by the mobile station
FAIL: Message could not be sent

*RST Setting

IDLE
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:SEND:STATe?"
! Queries the state of the last message sent to the mobile station. .

CALL:SMService:PTPoint[:MTERminated]:TEXT:CUSTom

Function

This sets the text of the custom message to be sent.

Setting

 String: 7 bit ACSII characters up to 160 characters in length in quotes.

Query

 String: 7 bit ACSII characters up to 160 characters in length.

*RST Setting

 "Enter your text here"
Requirements

Lab Application Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TEXT:CUSTom `Hello World'"

CALL:SMService:PTPoint[:MTERminated]:TRANsport

Function

Selects the transportation mechanism to be used.

Setting

Range: CSDomain|PSDomain

Query

Range: CSD|PSD

*RST Setting

 PSD
Requirements

Lab Application Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TRANsport GSM"
! Selects GSM to be the transportation mechanism used.

CALL:SMService:PTPoint[:MTERminated]:TXT1?

Function

This queries the fixed Text Message 1.

Query

 Returns a string.

*RST Setting

 "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz"
Requirements

Lab Application Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TXT1"
! This queries the fixed Text Message 1.

CALL:SMService:PTPoint[:MTERminated]:TXT2?

Function

This queries the fixed Text Message 2.

Query

 Returns a string.

*RST Setting

 "Agilent Technologies, your partner in wireless solutions"
Requirements

Lab Application Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TXT2?"
! This queries the fixed Text Message 2.


STATus Subsystem Description

STATus Subsystem Description

Description

The STATus subsystem is used to communicate current test set status information to the controlling application program.

Syntax Diagrams and Command Descriptions

STATus:OPERation

STATus:PRESet

STATus:QUEStionable

Status Byte Register
Standard Event Status Register

Related Topics

Status Subsystem Overview


STATus:OPERation

STATus:OPERation

Diagram Conventions

STATus:OPERation Register Bit Assignments

The OPERation status register set contains bits which give an indication of conditions that are part of the test set's normal operation.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | KEYPressed Summary | This bit is the summary bit for the STATus:OPERation:KEYPressed register.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | SYSTem:SYNChronized | This condition bit is "pulsed" by the SYSTem:SYNChronized command. This will allow the status system to indicate that the input buffer is synchronized to the point where this command is parsed and that all prior sequential commands are completed and all prior overlapped commands have started.
11 | 2048 | HARDware Summary | This bit is the summary bit for the STATus:OPERation:HARDware register.
10 | 1024 | CALL Summary | This bit is the summary bit for the STATus:OPERation:CALL register.
9 | 512 | NMRReady (New Measurement Result Ready) Summary | This bit is the summary bit for the STATus:OPERation:NMRReady register.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation

OUTPUT 714;"STATUS:OPERATION:EVENT?" !Queries the Operation Event Register.
OUTPUT 714;"STATUS:OPERATION:CONDITION?" !Queries the Operation Condition Register.
OUTPUT 714;"STATUS:OPERATION:ENABLE 1024" !Sets the Operation Enable Register for bit 10.
OUTPUT 714;"STATUS:OPERATION:NTR 1024" !Sets the Operation Negative Transition
                                       !Register for bit 10.
OUTPUT 714;"STATUS:OPERATION:PTR 512" !Sets the Operation Event Positive Transition
                                      !Register for bit 9.

STATus:OPERation:CALL Condition Register Bit Assignment

The STATus:OPERation:CALL register bits will be used to indicate status of processes that occur during normal call processing operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | WCDMa Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:WCDMa register.
10 | 1024 | FDD Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:TA136 register.
4 | 16 | DIGital136 Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:DIGITAL136 register.
3 | 8 | AMPS Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:GSM register.
1 | 2 | COMMon Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:COMMon register.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:CALL

OUTPUT 714;"STATUS:OPERATION:CALL:EVENT?" !Queries the Operation Call Event !Register.
OUTPUT 714;"STATUS:OPERATION:CALL:CONDITION?" !Queries the Operation Call Condition Register.
OUTPUT 714;"STATUS:OPERATION:CALL:ENABLE 4"
    !Sets the Operation Call Enable Register for bit 2.
OUTPUT 714;"STATUS:OPERATION:CALL:NTR 4" !Sets the Negative Transition Register for bit 2.
OUTPUT 714;"STATUS:OPERATION:CALL:PTR 256" !Sets the Positive Transition Register for bit 8.

STATus:OPERation:CALL:COMMon Condition Register Bit Assignment

The STATus:OPERation:CALL:COMMon register bits will be used to indicate status of processes that occur during normal call processing operations.

Bit Number

Binary Weighting

Condition

Description

15

32768

Not Used. Defined by SCPI.

This bit is always 0.

14

16384

Data Summary

 This bit is the summary message bit for the STATus:QUEStionable:CALL:GSM:DATA register.

13

8192

 Call Control Status Access Probe

This bit is a 1 when the test set is in the call control status access probe state.

12

4096

Call Control Status Set Up Request

This bit is a 1 when the test set is in the call control status set up request state.

11

2048

Call Control Status Releasing

This bit is a 1 when the test set is in the call control status releasing state.

10

1024

Call Control Status Paging

This bit is a 1 when the test set is in the call control status paging state.

9

512

Registering (BS initiated)

This bit is set to a 1 when the Base Station initiates registration.

8

256

 Call Control Status Dormant

7

128

BS Originating

This bit is a 1 when:

  • Active Cell mode - the call processing state leaves the idle state

  • Test mode - the test set has noted a base station origination.

6

64

 Call Control Status Changing

This bit is a 1 when the test set is in the call control status changing state.

5

32

Call Control Status Handover/Handoff

This bit is a 1 when the test set is in the call control handover or handoff state.

4

16

Call Control Status Registering

This bit will be a 1 when the test set is in the call control status registering state.

3

8

Call Control Status is "Alerting"

This bit is a 1 when the test set is in the call alerting state (ringing).

2

4

Call Control Status is "Connected"

This bit is a 1 when the test set is in the call connected state.

1

2

Call Control Status is "Idle"

This bit is a 1 when the test set is in the call idle state.

0

1

Extension Bit

This bit is always 0.

Program Examples - STATus:OPERation:CALL:COMMon

OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:EVENT?" !Queries the Operation Call Common Event
                                          !Register.
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:CONDITION?" !Queries the Operation Call Common
                                              !Condition Register.
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:ENABLE 8" !Sets the Operation Call Common Enable
                                            !Register for bit 3.
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:NTR 8" !Sets the Negative Transition
                                         !Register for bit 3.
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:PTR 256" !Sets the Positive Transition
                                           !Register for bit 8.

STATus:OPERation:CALL:COMMon:DATA Condition Register Bit Assignment

The STATus:OPERation:CALL:COMMon:DATA register bits are used to indicate status of processes that occur during normal data connection processing operations.

Bit Number

Binary Weighting

Condition

Description

15

32768

Not Used. Defined by SCPI.

This bit is always 0.

14

16384

 Ping Active

13

8192

Reserved for future use.

This bit is always 0.

12

4096

Reserved for future use.

This bit is always 0.

11

2048

Reserved for future use.

This bit is always 0.

10

1024

Reserved for future use.

This bit is always 0.

9

512

 Data Connection Status Session Open

This bit is always 0.

8

256

 Data Connection Status PDP Active

This bit is always 0.

7

128

Starting Data Connection

This bit is a 1 when:

  • Active Cell mode - the data connection status leaves the idle state

  • Test mode - the test set has noted a base station origination.

6

64

Data Connection Status Changing

This bit is set to a 1 when the data connection status change detector has been armed.

5

32

 Data Connection Status Off This bit is set to 1 when the test set is in the call control status handover/handoff state.

4

16

 Data Connection Status Data Connected

This bit is set to 1 when data connection status data is in the connected state.

3

8

Data Connection Status Transferring

This bit is set to 1 when the data connection status is Transferring.

2

4

Data Connection Status Attached

This bit is set to 1 when the data connection status is Attached.

1

2

Data Connection Status Idle

This bit is set to 1 when the data connection status is Idle.

0

1

Extension Bit

This bit will always be 0.

Program Examples STATus:OPERation:CALL:COMMon:DATA

OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:EVENT?" !Queries and clears the Operation
                                                      !Call Common Data Event Register
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:CONDITION?" !Queries and clears the Operation
                                                          !Call Common Data Condition
                                                          !Register
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:ENABLE 128" !Sets the Operation Call Common
                                                          !Data Enable Register for bit 7
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:NTRANSITION 2" !Sets the Operation Call Common
                                                        !Data Negative Transition Filter
                                                        !Register for bit 1
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:PTRANSITION 2" !Set the Operation Call Common
                                                        !Data Positive Transition Filter
                                                        !Register for bit 1

STATus:OPERation:FEATures Register Bit Assignments

The STATus:OPERation:FEATures register bits are used to access miscellaneous Features Registers.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | COMMon Summary Bit | This bit is the summary bit for the STATus:OPERation:FEATures:COMMon register. (see STATus:OPERation:FEATures:COMMon Register Bit Assignments )
0 | 1 | Extension Bit | This bit is always 0.

STATus:OPERation:FEATures:COMMon Register Bit Assignments

The STATus:OPERation:FEATures:COMMon register bits indicate the status of processes that occur during various operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | SMService Summary bit | This bit is the summary message bit for the STATus:OPERation:FEATures:COMMon:SMService register. (see STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments )
0 | 1 | Extension Bit | This bit is always 0.

STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments

The STATus:OPERation:FEATures:COMMon:SMService register bits indicate the status of processes that occur during SMS operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Mobile-Originated SMS Message Queue Overflow | The CONDition bit moves from 0 to 1 and back to 0 when the event takes place.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Mobile-Originated Message Received/Ready to be Returned | If message queuing is "OFF", the CONDition bit moves from 0 to 1 and back to 0 when the event takes place. If message queuing is "ON", the CONDition bit is set to 1 and remains there until the test set is informed by the controller that all received messages have been read.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

STATus:OPERation:HARDware Condition Register Bit Assignments

The STATus:OPERation:HARDware register bits indicate when a softkey on the test set's front panel has been pressed while the test set is in remote operating mode.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | External Timebase in use | This bit is a 1 if a suitable external timebase is connected to the test set's 10 MHz REF IN connector on the rear panel of the test set.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:HARDware

OUTPUT 714;"STATUS:OPERATION:HARDware:EVENT?"
    !Queries the HARDware Event Register.
OUTPUT 714;"STATUS:OPERATION:HARDware:CONDITION?"
    !Queries the HARDware Condition Register.
OUTPUT 714;"STATUS:OPERATION:HARDware:ENABLE 16"
    !Sets HARDware Enable register for bit 4.
OUTPUT 714;"STATUS:OPERATION:HARDware:NTR 2"
    !Sets the HARDware Negative Transition Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:HARDware:PTR 4"
    !Sets the HARDware Positive Transition Register for bit 2

STATus:OPERation:KEYPressed Register Bit Assignments

The STATus:OPERation:KEYPressed register bits indicate when a softkey on the test set's front panel has been pressed while the test set is in remote operating mode.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | F12 softkey | This bit is a 1 when the test set's F12 softkey has been pressed.
10 | 1024 | F11 softkey | This bit is a 1 when the test set's F11 softkey has been pressed.
9 | 512 | F10 softkey | This bit is a 1 when the test set's F10 softkey has been pressed.
8 | 256 | F9 softkey | This bit is a 1 when the test set's F9 softkey has been pressed.
7 | 128 | F8 softkey | This bit is a 1 when the test set's F8 softkey has been pressed.
6 | 64 | F7 softkey | This bit is a 1 when the test set's F7 softkey has been pressed.
5 | 32 | F6 softkey | This bit is a 1 when the test set's F6 softkey has been pressed.
4 | 16 | F5 softkey | This bit is a 1 when the test set's F5 softkey has been pressed.
3 | 8 | F4 softkey | This bit is a 1 when the test set's F4 softkey has been pressed.
2 | 4 | F3 softkey | This bit is a 1 when the test set's F3 softkey has been pressed.
1 | 2 | F2 softkey | This bit is a 1 when the test set's F2 softkey has been pressed.
0 | 1 | F1 softkey | This bit is a 1 when the test set's F1 softkey has been pressed.

Program Examples - STATus:OPERation:KEYPressed

OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:EVENT?"
    !Queries the Keypressed Event Register.
OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:CONDITION?"
    !Queries the Keypressed Condition Register.
OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:ENABLE 16"
    !Sets Keypressed Enable register for bit 4.
OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:NTR 2"
    !Sets the Keypressed Negative Transition Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:PTR 4"
    !Sets the Keypressed Positive Transition Register for bit 2

STATus:OPERation:NMRReady Register Bit Assignments

The STATus:OPERation:NMRReady register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | WCDMa Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:WCDMa register.
10 | 1024 | FDD Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:TA136 register.
4 | 16 | DIGITAL136 Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:DIGITAL136 register.
3 | 8 | AMPS Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:GSM register.
1 | 2 | COMMON Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:COMMon register.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady

OUTPUT 714;"STATUS:OPERATION:NMRREADY:EVENT?" !Queries the New Measurement
                                              !Results Ready Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CONDITION?" !Queries the New Measurement
                                                  !Results Ready
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:ENABLE 16" !Sets New Measurement Results
                                                 !Ready Enable Regigter
                                                 !for bit 4.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:NTR 2" !Sets the New Measurement Results
                                             !Ready Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:PTR 4" !Sets the New Measurement
                                             !Results Ready Positive
                                             !Transition Register
                                             !for bit 2

STATus:OPERation:NMRReady:AMPS Condition Register Bit Assignment

The STATus:OPERation:NMRReady:AMPS register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Frequency Modulation New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
2 | 4 | Frequency Stability New Measurement Result Ready | This is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
1 | 2 | Analog Transmit Power New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:AMPS

OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:EVENT?" !Queries the New Measurement
                                              !Results Ready AMPS Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:CONDITION?" !Queries the New Measurement
                                                  !Results Ready AMPS
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:ENABLE 8" !Sets New Measurement Results
                                                 !Ready AMPS Enable Register
                                                 !for bit 3.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:NTR 2" !Sets the New Measurement Results
                                             !Ready AMPS Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:PTR 4" !Sets the New Measurement
                                             !Results Ready AMPS Positive
                                             !Transition Register
                                             !for bit 2.

STATus:OPERation:NMRReady:COMMon Register Bit Assignments

The STATus:OPERation:NMRReady:COMMon register bits indicate when a measurement has been completed and new measurement results are available. See Triggering of Measurements for related information.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Spectrum Monitor New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
2 | 4 | Swept Audio New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
1 | 2 | Audio Analyzer New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:COMMon

OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:EVENT?" !Queries the New Measurement
                                              !Results Ready Common Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:CONDITION?" !Queries the New Measurement
                                                  !Results Ready Common
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:ENABLE 2" !Sets New Measurement Results
                                                 !Ready Common Enable Register
                                                 !for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:NTR 2" !Sets the New Measurement Results
                                             !Ready Common Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:PTR 2" !Sets the New Measurement
                                             !Results Ready Common Positive
                                             !Transition Register
                                             !for bit 1

STATus:OPERation:NMRReady:FDD Register Bit Assignments

The STATus:OPERation:NMRReady:FDD register bits indicate when a measurement has been completed and new measurement results are available. See Triggering of Measurements for related information.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | WPDiscon New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
12 | 4096 | WPPAnalysis New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
11 | 2048 | WOOPower New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
10 | 1024 | WIQTuning New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
9 | 512 | WILPower New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
8 | 256 | WCDomain New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
7 | 128 | WOBWidth New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
6 | 64 | WSEMask New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
5 | 32 | WBERror New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
4 | 16 | WCPower New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
3 | 8 | WWQuality New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
2 | 4 | WACLeakage New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
1 | 2 | WTPower New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
0 | 1 | FDD2 Summary | This bit is the summary bit for the STATus:OPERation:NMRReady:FDD2 register.

Program Examples - STATus:OPERation:NMRReady:FDD

OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD:EVENT?" !Queries the New Measurement
                                              !Results Ready FDD Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD:CONDITION?" !Queries the New
                                                  !Measurement Results Ready FDD
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD:ENABLE 8" !Sets New Measurement Results
                                                 !Ready FDD Enable Register
                                                 !for bit 3.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD:NTR 2" !Sets the New Measurement Results
                                             !Ready FDD Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD:PTR 4" !Sets the New Measurement
                                             !Results Ready FDD Positive
                                             !Transition Register
                                             !for bit 2

STATus:OPERation:NMRReady:FDD2 Register Bit Assignments

The STATus:OPERation:NMRReady:FDD2 register bits indicate when a measurement has been completed and new measurement results are available. See Triggering of Measurements for related information.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | WDPAnalysis New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
2 | 4 | WCTFormat New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
1 | 2 | WBLerror New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:FDD2

OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD2:EVENT?" !Queries the New Measurement
                                              !Results Ready FDD Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD2:CONDITION?" !Queries the New
                                                  !Measurement Results Ready FDD
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD2:ENABLE 8" !Sets New Measurement Results
                                                 !Ready FDD Enable Register
                                                 !for bit 3.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD2:NTR 2" !Sets the New Measurement Results
                                             !Ready FDD Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD2:PTR 4" !Sets the New Measurement
                                             !Results Ready FDD Positive
                                             !Transition Register
                                             !for bit 2


STATus:PRESet

STATus:PRESet

Diagram Conventions

STATus:PRESet

Function

Presets the status subsystem.

Presetting the status subsystem performs the following functions:

  • All enable registers are set to 0 (not enabled)
  • All Positive Transition Registers (PTR's) are set to 1 (positive transitions enabled).
  • All Negative Transition Registers (NTR's) are set to 0 (negative transitions disabled).

Requirements

Test Application Revision: A.01 and above


STATus:QUEStionable

STATus:QUEStionable

Diagram Conventions

STATus:QUEStionable Condition Register Bit Assignment

The STATus:QUEStionable register contains bits which give an indication that the data currently being acquired or generated is of questionable quality due to some condition affecting the functionality associated with that bit.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | QUEStionable:HARDware summary | This bit is the summary message bit for the STATus:QUEStionable:HARDware register.
10 | 1024 | QUEStionable:CALL summary | This bit is the summary message bit for the STATus:QUEStionable:CALL register.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | QUEStionable:ERRors summary | This bit is the summary message bit for the STATus:QUEStionable:ERRors register.
0 | 1 | Reserved for future use. | This bit is always 0.

Program Example - STATus:QUEStionable Register Bit Assignments

OUTPUT 714;"STATUS:QUESTIONABLE:EVENT?" !Queries and clears the Questionable Event
                                        !Register
OUTPUT 714;"STATUS:QUESTIONABLE:CONDITION?" !Queries and clears the Questionable Condition
                                            !Register
OUTPUT 714;"STATUS:QUESTIONABLE:ENABLE 1024" !Sets the Questionable Enable Register
                                             !for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:NTRANSITION 2" !Sets the Questionable Negative
                                               !Transition Filter Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:PTRANSITION 2" !Sets the Questionable Positive
                                               !Transition Filter Register for bit 1

STATus:QUEStionable:CALL Condition Register Bit Assignment

The STATus:QUEStionable:CALL registers will contain information about which event(s) occurred during call processing that indicate what call processing procedure failed

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | WCDMa Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:WCDMa register.
10 | 1024 | FDD Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:CALL:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:CALL:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:TA136 register.
4 | 16 | DIGital136 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:DIGital136 register.
3 | 8 | AMPS Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:GSM register.
1 | 2 | COMMon Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:COMMon register.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:CALL Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:CALL:EVENT?" !Queries and clears the Questionable
                                             !Call Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:CONDITION?" !Queries and clears the Questionable
                                                 !Call Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:ENABLE 1024" !Sets the Questionable
                                                  !Call Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:NTRANSITION 2" !Sets the Questionable Call
                                                    !Negative Transition Filter Register
                                                    !for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:PTRANSITION 2" !Sets the Questionable Call
                                                    !Positive Transition Filter Register
                                                    !for bit 1

STATus:QUEStionable:ERRors Condition Register Bit Assignment

The STATus:QUEStionable:ERRors register bits will be used to indicate information about test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | WCDMa Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:WCDMa register.
10 | 1024 | FDD Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:TA136 register.
4 | 16 | DIGital136 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:DIGital136 register.
3 | 8 | AMPS Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:GSM register.
1 | 2 | COMMon Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:ERRors register.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors Register Bit Assignments

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:EVENT?" !Queries and clears the Questionable
                                               !Errors Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:CONDITION?" !Queries and clears the Questionable
                                                   !Errors Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:ENABLE 1024" !Sets the Questionable
                                                    !Errors Enable
                                                    !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:NTRANSITION 2" !Sets the Questionable Errors
                                                      !Negative Transition Filter Register
                                                      !for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:PTRANSITION 2" !Sets the Questionable Errors
                                                      !Positive Transition Filter Register
                                                      !for bit 1

STATus:QUEStionable:ERRors:COMMon Register Bit Assignments

The STATus:QUEStionable:ERRors:COMMon register bits will be used to indicate information about the COMMon test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors:COMMon Register Bit Assignments

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:EVENT?" !Queries and clears the Questionable
                                                      !Errors Common Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:CONDITION?" !Queries the and clears the
                                                          !Questionable Errors
                                                          !Common Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:ENABLE 1024" !Sets the Questionable
                                                           !Errors Common Enable
                                                           !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:NTRANSITION 2" !Sets the Questionable Errors
                                                             !Common Negative Transition
                                                             !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:PTRANSITION 2" !Sets the Questionable Errors
                                                             !Common Positive Tranasition
                                                             !Register for bit 1

STATus:QUEStionable:ERRors:FDD Register Bit Assignments

The STATus:QUEStionable:ERRors:FDD register bits will be used to indicate information about FDD related test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | MUI Maskable Message. |
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. Query the Event Register to find out if one of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors:FDD Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:FDD:EVENT?" !Queries and clears the
                                                          !Questionable Errors
                                                          !FDD Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:FDD:CONDITION?" !Queries and clears the
                                                              !Qestionable Errors
                                                              !FDD Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:FDD:ENABLE 1024" !Sets the Questionable
                                                               !Errors FDD Enable
                                                               !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:FDD:NTRANSITION 2" !Sets the Questionable
                                                                 !Errors FDD Negative
                                                                 !Transition Filter
                                                                 !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:FDD:PTRANSITION 2" !Sets the Questionable
                                                                 !Errors FDD Positive
                                                                 !Transition Filter
                                                                 !Register for bit 1

STATus:QUEStionable:ERRors:WCDMa Register Bit Assignments

The STATus:QUEStionable:ERRors:WCDMa register bits will be used to indicate information about WCDMA related test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | MUI Maskable Message. |
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. Query the Event Register to find out if one of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors:WCDMA Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:WCDMA:EVENT?" !Queries and clears the
                                                          !Questionable Errors
                                                          !WCDMA Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:WCDMA:CONDITION?" !Queries and clears the
                                                              !Qestionable Errors
                                                              !WCDMA Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:WCDMA:ENABLE 1024" !Sets the Questionable
                                                               !Errors WCDMA Enable
                                                               !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:WCDMA:NTRANSITION 2" !Sets the Questionable
                                                                 !Errors WCDMA Negative
                                                                 !Transition Filter
                                                                 !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:WCDMA:PTRANSITION 2" !Sets the Questionable
                                                                 !Errors WCDMA Positive
                                                                 !Transition Filter
                                                                 !Register for bit 1

STATus:QUEStionable:HARDware Condition Register Bit Assignment

The STATus:QUEStionable:HARDware register bits give an indication that the data/signals currently being acquired or generated are of questionable quality.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit will always be 0.
11 | 2048 | Reserved for future use. | This bit will always be 0.
10 | 1024 | Reserved for future use. | This bit will always be 0.
9 | 512 | Reserved for future use. | This bit will always be 0.
8 | 256 | Reserved for future use. | This bit will always be 0.
7 | 128 | Reserved for future use. | This bit will always be 0.
6 | 64 | Reserved for future use. | This bit will always be 0.
5 | 32 | Reserved for future use. | This bit will always be 0.
4 | 16 | Power-up Self Test(s) Failed | This bit will be a 1 if the power-up self tests failed.
3 | 8 | Reserved for future use. | This bit will always be 0.
2 | 4 | Reserved for future use. | This bit will always be 0.
1 | 2 | Reserved for future use. | This bit will always be 0.
0 | 1 | Extension Bit. | This bit will always be 0.

Program Example - STATus:QUEStionable:HARDware Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:EVENT?" !Queries and clears the Questionable
                                                 !Hardware Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:CONDITION?" !Queries and clears the Questionable
                                                     !Hardware Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:ENABLE 1024" !Sets the Questionable
                                                      !Hardware Enable
                                                      !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:NTRANSITION 2" !Sets the Questionable
                                                        !Hardware Negative Transition Filter
                                                        !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:PTRANSITION 2" !Sets the Questionable
                                                        !Hardware Positive Transition Filter
                                                        !Register for bit 1


Status Byte Register

Status Byte Register

*STB?

NOTE
The Status Byte Register can also be read with a serial poll. For example, the command "Status_byte = SPOLL(714)" would perform a serial poll of the Status Byte Register, returning and releasing RQS (bit 6).

Status Byte Register Bit Assignments

Bit Number | Binary Weighting | Label | Description
7 | 128 | STATus: OPERation | Summarizes the STATus: OPERationStatus Register, which fans out to theNMRReady and CALL Status Registers.
6 | 64 | RQS (SRQ TRUE?)/Master Summary Status | RQS is read by a serial poll (SPOLL)Master Summary Status is read by a *STB? query - defined by IEEE 488.2
5 | 32 | Standard Event Status Register | Summarizes the Standard Event Status Register
4 | 16 | Message Available | SCPI - Defined
3 | 8 | STATus: QUEStionableStatus Register | Summary Message comes from theSTATus: QUEStionable Status Register,which fans out to the CALL andHARDware Status Registers
2 | 4 | Error/ Event Queue | SCPI - Defined
1 | 2 | Reserved |
0 | 1 | Reserved |

Program Example - Status Byte Register Bit Assignments

OUTPUT 714;"*STB?" !Queries the Status Byte.


Standard Event Status Register

Standard Event Status Register

*ESR?

*ESE?

*ESE

Diagram Conventions

Standard Event Status Register Bit Assignment

Bit Number

Binary Weighting

Condition

Description

15

32768

Reserved by IEEE.

This bit will always be 0.

14

16384

Reserved by IEEE.

This bit will always be 0.

13

8192

Reserved by IEEE.

This bit will always be 0.

12

4096

Reserved by IEEE.

This bit will always be 0.

11

2048

Reserved by IEEE.

This bit will always be 0.

10

1024

Reserved by IEEE.

This bit will always be 0.

9

512

Reserved by IEEE.

This bit will always be 0.

8

256

Reserved by IEEE.

This bit will always be 0.

7

128

Power On

This bit is set to 1 if the power supply has been turned off and on since the last time this register was read or otherwise cleared. Defined in "IEEE Std. 488.2-1992",11.5.1.1.2

6

64

Reserved for future use.

This bit will always be 0.

5

32

Command Error

This bit is set to 1 if the test set detects an error while trying to process a command. The following events cause a command error:

  • An IEEE 488.2 syntax error. The test set received a message that did not follow the syntax defined by the standard.

  • A semantic error. For example the test set received an incorrectly spelled command.

  • The test set received a group execution trigger (GET) inside a program message

4

16

Execution Error

This bit is set to 1 if the test set detects an error while trying to execute a command. The following events cause a execution error:

  • A <PROGRAM DATA> element received in a command is outside the legal range for the test set, or it is inconsistent with the operation of the test set.

  • The test set could not execute a valid command due to some test set hardware/firmware condition.

3

8

Device Dependent Error

This bit is set to 1 if a test set operation does not execute properly due to an internal condition (such as, overrange). This bit indicates that the error was not a command, query, or execution error.

2

4

Query Error

This bit is set to 1 if an error has occurred while trying to read the test set's output queue. The following events cause a query error:

  • An attempt is made to read data from the output queue when no data is present or is pending.

  • Data in the output queue has been lost. An example of this would be an output queue overflow.

1

2

Reserved for future use.

This bit will always be 0.

0

1

Operation Complete

This bit is set to 1 when the test set has completed all pending operations and is ready to accept new commands. This bit is only generated in response to the *OPC IEEE 488.2 common command.

Program Example - Standard Event Status Register

OUTPUT 714;"*ESR?" !Queries (reads) the Standard Event Status Register.


Diagram Conventions

Diagram Conventions

Description

Diagram Description

Mnemonics are connected by lines. Each line can be followed in only one direction, as indicated by the arrow at the end of the line. Any combination of mnemonics that can be generated by starting at the root mnemonic and following the line in the direction of the arrow is syntactically correct.

The drawings show the proper use of spaces. Where spaces are required they are indicated by <sp>, otherwise no spaces are allowed between mnemonics.

Complex Command Description

A complex command sets the state of the parameter to ON, and is used to set a value for that parameter. These parameters; amplitude, frequency, gain, number, time, and value can be used as a complex command. Refer to the specific command for the parameter that applies.

Developing Code

It is recommended that you set the test set's operating environment to debug. When debug mode is on, the error message displayed on the test set's front panel when incorrect GPIB syntax is sent to the test set is enhanced with additional information to help you correct the syntax error. To set the test set debug mode to "ON" use the following syntax:

SYSTem:COMMunicate:GPIB:DEBug ON

Data Type Description

num value

Integer, float or scientific values.

For example,

CALL:POWer -55.5

CALL:POWer -5.55E+001

CALL:CHANnel 525

string

Characters. The string will often need to be enclosed in single or double quotes, depending upon your programming environment.

For example,

CALL:CIDentity "#0123456789*"

CALL:UPLink:PRAChannel:ASUBchannels '111111111111'

The string returned by the test set is enclosed by double quotes.
choice1|choice2|choice3

Specific character choices.

For example,

CALL:OPERating:MODE D2KTest

SYSTem:COMMunicate:GPIB:DEBug ON


SYSTem:APPLication

SYSTem:APPLication

Diagram Conventions

SYSTem:APPLication[:CURRent][:NAME]?

Function

Queries the name of the currently running application.

To query the revision of the currently running application, see SYSTem:APPLication[:CURRent]:REVision? .

To switch applications, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication?"

SYSTem:APPLication[:CURRent]:REVision?

Function

Queries the revision of the currently running application.

To query the name of the currently running application, see SYSTem:APPLication[:CURRent][:NAME]? .

To switch to a different revision of an application, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:REVision?"

SYSTem:APPLication:CATalog[:NAME]?

Function

Queries the names of the applications stored on the test set.

This query returns a comma-separated list of double-quoted strings (one for each application stored on the test set).

To query the number of applications stored on the test set, see SYSTem:APPLication:CATalog[:NAME]:COUNt? .

To switch applications, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: One or more of the following strings, separated by commas -

  • "1xEV-DO Terminal Test"
  • "AMPS/136 Mobile Test"
  • "CDMA 2000 Lab App"
  • "CDMA 2000 Lab App B"
  • "CDMA 2000 Mobile Test"
  • "CDMA 2000_1xEV-DO"
  • "EGPRS Lab App"
  • "Fast Switch Test App"
  • "GPRS Lab Application"
  • "GPRS Lab App B"
  • "GPRS Mobile Test"
  • "GSM Mobile Test"
  • "GSM/GPRS Lab App C"
  • "GSM/GPRS Lab App D"
  • "GSM/GPRS Mobile Test"
  • "GSM/GPRS RF Modem"
  • "GSM/GPRS_AMPS/136"
  • "GSM/GPRS_AMPS/136_WCDMA"
  • "GSM/GPRS_CDMA 2000"
  • "GSM/GPRS_WCDMA Lab App"
  • "GSM/GPRS_WCDMA Lab App B"
  • "GSM/GPRS_WCDMA Lab App C"
  • "WCDMA Lab App"
  • "WCDMA Lab App B"
  • "WCDMA Lab App C"
  • "WCDMA Mobile Test"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog?"

SYSTem:APPLication:CATalog[:NAME]:COUNt?

Function

Queries the total number of applications stored on the test set.

To query the names of the applications stored on the test set, see SYSTem:APPLication:CATalog[:NAME]? .

Query

Range: 0 through 30

Resolution: 1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:COUNt?"

SYSTem:APPLication:CATalog:FORMat?

Function

Queries the names of the formats in the current application.

This query returns a comma-separated list of double-quoted strings (one for each format in the application).

To query the number of formats in the current application, see SYSTem:APPLication:CATalog:FORMat:COUNt? .

To switch formats in a fast switching application, see SYSTem:APPLication:FORMat[:NAME] .

Query

Range: One or more of the following strings separated by commas -

  • "1xEV-DO"
  • "AMPS/136"
  • "GSM/GPRS" (Note: this query return represents GSM, GPRS and EGPRS formats)
  • "IS-2000/IS-95/AMPS"
  • "IS-856"
  • "WCDMA"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:FORMat?"

SYSTem:APPLication:CATalog:FORMat:COUNt?

Function

Queries the number of formats in the current application.

To query the names of the formats in the current application, see SYSTem:APPLication:CATalog:FORMat? .

Query

Range: 0 to 30

Resolution: 1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:FORMat:COUNt?"

SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>'

Function

Queries the license status for the specified application/revision. The application/revision does not have to be installed in the test set.

The query must include a parameter for the application name and revision, enclosed by single quotes and separated by a comma. For application names and revisions, see SYSTem:APPLication:CATalog[:NAME]? and SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' . Note that the application name and revision parameters are not case-sensitive.

Query

Range: LIC|NLIC|PART|UNKN

  • "LIC" indicates this is a licensed application/revision.
  • "NLIC" indicates this is not a licensed application/revision.
  • "PART" indicates that not all of the formats in this application/revision are licensed. (To determine the license status of each format, see SYSTem:APPLication:FORMat:LICense?<sp>'<format name>' .)
  • "UNKN" indicates that license status is unknown.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense? 'CDMA 2000 Mobile Test','B.07.00'"

SYSTem:APPLication:CATalog:LICense:APPLication:ALL?

Function

Queries the names of the applications, formats and features that are licensed for the test set. The applications, formats and features do not have to be installed in the test set to be returned by this query.

This query returns a comma-separated list of double-quoted strings (two for each application, one for each format or feature).

To query the number of licensed applications, formats and features for the test set, see SYSTem:APPLication:CATalog:LICense:APPLication:COUNt? .

Query

Range: One or more of the following strings, separated by commas -

Applications -

  • "E1960A","GSM Mobile Test"
  • "E1961A","AMPS/136 Mobile Test"
  • "E1962B","CDMA 2000 Mobile Test"
  • "E1963A","WCDMA Mobile Test"
  • "E1964A","GPRS Mobile Test"
  • "E1966A","1xEV-DO Terminal Test"
  • "E1968A","GSM/GPRS Mobile Test"
  • "E1985A","GSM/GPRS_AMPS/136"
  • "E1985B","GSM/GPRS_AMPS/136_WCDMA"
  • "E1985C","GSM/GPRS_CDMA 2000"
  • "E1985E","CDMA 2000_1xEV-DO"
  • "E1987A","Fast Switch Test App"
  • "E6590A","GSM/GPRS RF Modem"
  • "E6701A","GPRS Lab Application"
  • "E6701B","GPRS Lab App B"
  • "E6701C","GSM/GPRS Lab App C"
  • "E6701D","GSM/GPRS Lab App D"
  • "E6702A","CDMA 2000 Lab App"
  • "E6702B","CDMA 2000 Lab App B"
  • "E6703A","WCDMA Lab App"
  • "E6703B","WCDMA Lab App B"
  • "E6703C","WCDMA Lab App C"
  • "E6704A","EGPRS Lab App"
  • "E6785A","GSM/GPRS_WCDMA Lab App"
  • "E6785B","GSM/GPRS_WCDMA Lab App B"
  • "E6785C","GSM/GPRS_WCDMA Lab App C"
Query (continued)

Formats -

  • "E1968A-101","GSM TA"
  • "E1968A-102","GPRS TA"
  • "E1968A-103","EGPRS TA"
  • "E1968A-201","GSM TA and GPRS TA"
  • "E1968A-202","GSM TA and GPRS TA and EGPRS TA"
  • "E6590A-101","GSM/GPRS"
  • "E6590A-102","EGPRS"
  • "E6590A-103","RF Modem"

Features -

  • "E1962B-401","CDMA 2000 Release A"
  • "E1963A-401","WCDMA Video Phone Test"

Requirements

Test Application Revision: B.08 and above

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:ALL?"

SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?

Function

Queries the number of applications, formats and features that are licensed for the test set. The applications, formats and features do not have to be installed in the test set to be included in the query result.

To query the names of the licensed applications, formats and features for the test set, see SYSTem:APPLication:CATalog:LICense:APPLication:ALL? .

Query

Range: 0 to 300

Resolution: 1

Requirements

Test Application Revision: B.08 and above

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?"

SYSTem:APPLication:CATalog:REVision?<sp>'<application name>'

Function

Queries the revisions stored on the test set for the specified application.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

This query returns a comma-separated list of double-quoted strings (one for each revision of the application).

Note, if you have several revisions of the application stored on the test set, you may need to increase your GPIB controller's timeout time to avoid a timeout condition.

To query the number of revisions stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>' .

To switch to a different revision of an application, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

 Range: Comma-separated list of 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01","A.02.01"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:REVision? 'CDMA 2000 MOBILE TEST'"

SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>'

Function

Queries the number of revisions stored on the test set for the specified application.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

To query the revision numbers stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' .

Query

Range: 0 to 30

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:REVision:COUNt? 'CDMA 2000 MOBILE TEST'"

SYSTem:APPLication:FORMat[:NAME]

Function

Switches to the specified format (in the current application). Only fast switching applications include more than one format. To determine what formats are available in the current application, see SYSTem:APPLication:CATalog:FORMat? . To determine the license status of a format, see SYSTem:APPLication:FORMat:LICense?<sp>'<format name>' .

Queries the name of the currently active format in the current application.

Setting

Range: See SYSTem:APPLication:CATalog:FORMat?

Query

Range: same as setting

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:FORMat 'IS-2000/IS-95/AMPS'"

OUTPUT 714;"SYSTem:APPLication:FORMat?"

SYSTem:APPLication:FORMat:LICense?<sp>'<format name>'

Function

Queries the license status of the specified format in the current application.

The query must include a parameter for the format name enclosed by single quotes. For format names, see SYSTem:APPLication:CATalog:FORMat? . Note that the format name parameter is not case-sensitive.

Query

Range: LIC|NLIC|UNKN

  • "LIC" indicates this is a licensed format.
  • "NLIC" indicates this is not a licensed format.
  • "UNKN" indicates that the license status is unknown.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:FORMat:LICense? 'IS-2000/IS-95/AMPS'"

SYSTem:APPLication:SELect[:NAME]

Function

Switches to the specified application (this includes a reboot of the test set). To determine what applications are stored on the test set, see SYSTem:APPLication:CATalog[:NAME]? . The revision that is switched to is determined by SYSTem:APPLication:SELect:REVision . To determine the license status of the application/revision, see SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>' .

Queries the name of the application that will be loaded after the next reboot of the test set.

Setting

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Query

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect 'CDMA 2000 MOBILE TEST'"

OUTPUT 714;"SYSTem:APPLication:SELect?"

SYSTem:APPLication:SELect:REVision

Function

Sets the revision that will be loaded when the application is switched to using the SYSTem:APPLication:SELect[:NAME] command.

To determine what application is to be switched to, see SYSTem:APPLication:SELect[:NAME] . To determine what revisions are stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' . To determine the license status of a revision, see SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>' .

To query the revision that will be loaded when an application is switched to, see SYSTem:APPLication:SELect:REVision?<sp>'<application name>' .

NOTE
GSM Mobile Test revisions prior to A.04.00 did not have application switching and provide no way to return to revisions that have switching. If you switch to a GSM Mobile Test application revision prior to A.04.00, the only way to return to a newer revision is by downloading it using the process for upgrading firmware.

Setting

Range: see SYSTem:APPLication:CATalog[:NAME]? and SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect:REVision 'CDMA 2000 Mobile Test','B.06.30'"

SYSTem:APPLication:SELect:REVision?<sp>'<application name>'

Function

Queries the revision that will be loaded when the specified application is switched to using the SYSTem:APPLication:SELect[:NAME] command.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

To set the revision that will be loaded when the specified application is switched to, see SYSTem:APPLication:SELect:REVision .

NOTE
GSM Mobile Test revisions prior to A.04.00 did not have application switching and provide no way to return to revisions that have switching. If you switch to a GSM Mobile Test application revision prior to A.04.00, the only way to return to a newer revision is by downloading it using the process for upgrading firmware.

Query

 Range: 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect:REVision? `CDMA 2000 MOBILE TEST'"

Related Topics

Application Switching


SYSTem:AUDio

SYSTem:AUDio

Diagram Conventions

SYSTem:AUDio:OUTPut:SOURce

Function

Set/queries whether the audio generator signal or the FM demodulation signal is selected to be routed to the AUDIO OUT port of the test set's front panel.

When audio generator is selected for output at the front-panel AUDIO OUT port, use AFGenerator Subsystem to control the audio generator.

NOTE
The selection of FM Demod signal is useful only in AMPS system. A bandpass filter, expander circuit, and deemphasis circuit can be individually inserted or bypassed in the FM Demod signal path. Use the command SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe to insert the bandpass filter. Use the command SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe to insert the expandor circuit. Use the command SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe to insert the deemphasis filter.

NOTE
There will be no guaranteed performance for the signal present at the Audio Out port when FM Demod is selected for output.

Requirements

Test Application Revision: A.03 or above.

Lab Application Revision: A.01 or above.

Setting

AFGenerator|FMDemod

Query

AFG|FMD

*RST Setting

AFG

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:SOURce FMDemod"

!Selects FM Demod signal for output at the front panel AUDIO OUT port.

SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe

Function

Sets/queries whether the fixed bandpass filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port (see SYSTem:AUDio:OUTPut:SOURce ).

When the state is ON, a 300 Hz to 3 KHz bandpass filter is inserted in the audio signal path. When the state is OFF, the bandpass filter is bypassed in the audio signal path

Requirements

Test Application Revision: A.03 or above.

Lab Application Revision: A.01 or above.
Setting | Range: 0|OFF|1|ON

Query

Range: 0|1
*RST setting | 0 (OFF)

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe ON"

!Sets the bandpass filter state to ON.

SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe

Function

Sets/queries whether the expandor filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port (see SYSTem:AUDio:OUTPut:SOURce ).

When the state is ON, the expandor filter is inserted in the audio signal path. When the state is OFF, the expandor filter is bypassed in the audio signal path.

Requirements

Test Application Revision: A.03 or above.

Lab Application Revision: A.01 or above.
Setting | Range: 0|OFF|1|ON

Query

Range: 0|1
*RST setting | 0 (OFF)

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe ON" !Sets the expandor filter state to ON.

SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe

Function

Sets/queries whether the deemphasis filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port (see SYSTem:AUDio:OUTPut:SOURce ).

When the state is ON, the deemphasis filter is inserted in the audio signal path. When the state is OFF, the deemphasis filter is bypassed in the audio signal path.

Requirements

Test Application Revision: A.03 or above.

Lab Application Revision: A.01 or above.
Setting | Range: 0|OFF|1|ON

Query

Range: 0|1
*RST setting | 0 (OFF)

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe ON"

!Sets the deemphasis filter state to ON.


SYSTem:BEEPer

SYSTem:BEEPer

Diagram Conventions

SYSTem:BEEPer:STATe

Function

Sets/queries the beeper state of the test set.

Setting

0|OFF | 1|ON

Query

0|1

*RST Setting

1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:BEEPER:STATE OFF" !Sets beeper state to off.


SYSTem:COMMunicate

SYSTem:COMMunicate

Diagram Conventions

SYSTem:COMMunicate:GPIB:[:SELF]:ADDRess

Function

 Sets/queries the test set's GPIB address. Configuring the Test Set's GPIB

Setting

Range: 0 to 30

Resolution: 1

Query

Range: 0 to 30

Resolution: 1

Factory setting

14 (this parameter is not affected by any reset operation and can only be changed by direct user access)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:GPIB:SELF:ADDRESS 14"
! Sets the GPIB address to 14.

SYSTem:COMMunicate:GPIB:DEBug[:STATe]

Function

Sets/queries the test set's SCPI debugger state.

When the state is on; enhanced error messages (generated from GPIB commands with syntax errors) are shown the test set display.

The error message is printed along with the syntax. <ERR> is displayed at the end of the incorrect node. Non-printable characters will be replaced with the $ symbol. See Error Messages for a list of the errors.

The debugger state should be set to on only during GPIB code development. Test times will increase if the debugger state is left on.

Setting

 Range: 0|OFF | 1|ON
Query 0|1

*RST setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:GPIB:DEBUG:STATE ON"
! Sets debugger to on.

SYSTem:COMMunicate:LAN[:SELF]:ADDRess

Function

Sets/queries the test set's LAN IP address. The value of A is used to determine the subnet mask, see SYSTem:COMMunicate:LAN[:SELF]:SMASk .

If the LAN address is changed the subnet mask should be checked to insure that it is set to the proper class for that LAN address.

Configuring the Test Set's LAN

Setting

Range: 15 characters formatted as follows: A.B.C.D where A= 0 to 126 and 128 to 223, B.C.D = 0 to 255 (no embedded spaces), blank field.

Query

Range: 15 characters formatted as follows: "A.B.C.D" where A= 0 to 126 and 128 to 223, B.C.D = 0 to 255 (no embedded spaces), "".

Factory setting

"" (this parameter is not affected by any reset operation and can only be changed by direct user access)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:ADDRESS '130.015.156.255'"
! Sets the LAN IP address.

SYSTem:COMMunicate:LAN[:SELF]:DGATeway

Function

Sets/queries the LAN IP router/gateway address for the test set.

Configuring the Test Set's LAN

Setting

Range: 15 characters formatted as follows: A.B.C.D where A= 0 to 223, B,C,D = 0 to 255 (no embedded spaces), blank field.

Query

Range: 15 characters formatted as follows: "A.B.C.D" where A= 0 to 223, B,C,D = 0 to 255 (no embedded spaces), "".

Factory setting

"" (this parameter is not affected by any reset operation and can only be changed by direct user access)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:DGATEWAY '130.2.6.200'"

SYSTem:COMMunicate:LAN[:SELF]:SMASk

Function

Sets/queries the subnet mask of the test set based on the LAN IP address selected. The subnet mask changes according to the value of A used for the LAN IP address.

If A is less than 127, the default subnet mask is 255.0.0.0.

If A is greater than 127 and less or equal to 191, the default subnet mask is 222.255.0.0.

If A is greater than 191, the default subnet mask is 255.255.255.0.

If the LAN address is changed the subnet mask should be checked to insure that it is set to the proper class for that LAN address.

Configuring the Test Set's LAN

Setting

Range: 15 characters formatted as follows: A.B.C.D where A,B,C,D are between = 0 to 255 (no embedded spaces), blank field.

Query

Range: 15 characters formatted as follows: "A.B.C.D" where A,B,C,D are between = 0 to 255 (no embedded spaces), "".

Factory setting

"" (this parameter is not affected by any reset operation and can only be changed by direct user access)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:SMASK '255.2.6.200'"

SYSTem:COMMunicate:LAN:EXTernal:ADDRess

Function

Sets/queries the External 8960 IP Address .

Setting

Range: 15 characters formatted as follows: A.B.C.D where A= 0 to 126 and 128 to 223, B.C.D = 0 to 255 (no embedded spaces), blank field.

Query

Range: 15 characters formatted as follows: "A.B.C.D" where A= 0 to 126 and 128 to 223, B.C.D = 0 to 255 (no embedded spaces), "".

Factory setting

"" (this parameter is not affected by any reset operation and can only be changed by direct user access)

Requirements

Lab Application Revision: C.01 and above

Test Application Revision: A.06 and above, with the required feature license

Programming Example

OUTPUT 714;"SYSTem:COMMunicate:LAN:EXTernal:ADDRess '130.015.156.255'"
! Sets the External 8960 IP Address.

SYSTem:COMMunicate:LAN:EXTernal:CONNect

Function

 Initiates the Connect to External 8960 immediate action.

Requirements

Lab Application Revision: C.01 and above

Test Application Revision: A.06 and above, with the required feature license

Programming Example

OUTPUT 714;"SYSTem:COMMunicate:LAN:EXTernal:CONNect"

SYSTem:COMMunicate:LAN:EXTernal:DCONnect

Function

 Initiates the Disconnect from External 8960 immediate action.

Requirements

Lab Application Revision: C.01 and above

Test Application Revision: A.06 and above, with the required feature license

Programming Example

OUTPUT 714;"SYSTem:COMMunicate:LAN:EXTernal:DCONnect"


SYSTem:CONFigure

SYSTem:CONFigure

Diagram Conventions

SYSTem:CONFigure:INFormation:HARDware:VERBose?

Function

Query the manufacturer, model number, model number of the test application running, serial number, revision, board ID, and cal file information. The information provided by the query represents the configuration that existed when the test set was powered up.

*RST Setting

Resets have no effect on this information. The information is gathered during the power up cycle.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:CONFIGURE:INFORMATION:HARDWARE:VERBOSE?" !Queries system hardware.

Related Topics

Hardware Configuration Report


SYSTem:CORRection

SYSTem:CORRection

Diagram Conventions

SYSTem:CORRection:[:SGAin]

Function

Sets/queries up to 20 comma-separated amplitude offset values in dB. This command sets the state to On.

See Amplitude Offset .

The units, dB, are optional. If no units are specified then units default to dB.

Sending a null list (no values) sets the state of all offsets to Off.

Setting

Range: 0 to 20 values between -100 to +100

Resolution: 0.01

Query

Range: 1 to 20 values between -100 to +100, and NAN (9.91E+37)

Resolution: 0.01

Factory Setting

Offsets 1 through 20, are set to 0.00 dB, state is set to Off

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:SGAIN -2.55,-3.12,-3.68,-4.23,-4.74,-5.3"
!A complex command that sets up to 20 comma separated offsets
!and sets the state to On for the frequencies, offsets and
!RF IN/OUT Amplitude Offset State

OUTPUT 714;"SYSTEM:CORRECTION:SGAIN"
!Sets the state for all frequencies and offsets to Off

SYSTem:CORRection:FREQuency

Function

Sets/queries up to 20 comma-separated frequency values in MHz. Each frequency value corresponds with a gain setting. See SYSTem:CORRection:GAIN .

The units, (GHz, MHz, kHz, Hz) are optional. If no units are specified, units default to Hz.

See Amplitude Offset .

Sending a null list (no values) sets the state of all frequencies to Off.

Setting

Range: 0 to 20 comma separated values ranging from 292.5 MHz to 2700 MHz

Resolution: 1 Hz

Query

Range: 1 to 20 comma separated values ranging from 292.5 MHz to 2700 MHz, and NAN (9.91E+37)

Resolution: 1 HZ

Factory Setting
  1. 800.00 MHz Off
  2. 810.00 MHz Off
  3. 820.00 MHz Off
  4. 830.00 MHz Off
  5. 840.00 MHz Off
  6. 850.00 MHz Off
  7. 860.00 MHz Off
  8. 870.00 MHz Off
  9. 880.00 MHz Off
  10. 890.00 MHz Off
  11. 900.00 MHz Off
  12. 910.00 MHz Off
  13. 920.00 MHz Off
  14. 930.00 MHz Off
  15. 940.00 MHz Off
  16. 950.00 MHz Off
  17. 960.00 MHz Off
  18. 970.00 MHz Off
  19. 980.00 MHz Off
  20. 990.00 MHz Off

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:FREQUENCY 1784.8 MHZ,1879.8 MHZ"
!Sets up to 20 comma separated frequencies

OUTPUT 714;"SYSTEM:CORRECTION:FREQUENCY"
!Sets the state for all frequencies and offsets to Off

SYSTem:CORRection:GAIN

Function

Sets/queries the up to 20 comma separated offset gain values in units of dB. Each gain value corresponds with a frequency setting. See SYSTem:CORRection:FREQuency .

See Amplitude Offset .

The units, dB, are optional. If no units are specified, units default to dB.

Sending a null list (no values) sets the state of all offsets to Off.

Setting

Range: 0 to 20 values between -100 to +100

Resolution: 0.01

Query

Range: 1 to 20 values between -100 to +100, and NAN (9.91E+37)

Resolution: 0.01

Factory Setting

Offsets 1 through 20, are set to 0.00 dB, state is set to off

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:GAIN -3.12,-3.68,-4.23"
!Sets up to 20 comma separated offset values.

OUTPUT 714;"SYSTEM:CORRECTION:GAIN"
!Sets the state for all frequencies and offsets to Off.

SYSTem:CORRection:POINts

Function

Query returns the number of offsets that are in their On state when the RF IN/OUT Amplitude Offset State is also set to On.

See Amplitude Offset .

Query

Range: 1 to 20, and NAN (9.91E+37)

Resolution: 1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:POINTS?"

!Returns the number of frequencies and offsets with their state set to On.

SYSTem:CORRection:SFRequency

Function

Sets/queries up to 20 comma separated frequency values in MHz. This command sets the state to On.

The units (GHz, MHz, kHz, Hz) are optional. If no units are specified, units default to MHz.

See Amplitude Offset .

Sending a null list (no values) sets the state of all frequencies to Off.

Setting

Range: 0 to 20 comma separated values from 292.5 MHz to 2700 MHz

Resolution: 1 Hz

Query

Range: 1 to 20 comma separated values from 292.5 MHz to 2700 MHz, and NAN (9.91E+37)

Resolution: 1 HZ

Factory Setting
  1. 800.00 MHz Off
  2. 810.00 MHz Off
  3. 820.00 MHz Off
  4. 830.00 MHz Off
  5. 840.00 MHz Off
  6. 850.00 MHz Off
  7. 860.00 MHz Off
  8. 870.00 MHz Off
  9. 880.00 MHz Off
  10. 890.00 MHz Off
  11. 900.00 MHz Off
  12. 910.00 MHz Off
  13. 920.00 MHz Off
  14. 930.00 MHz Off
  15. 940.00 MHz Off
  16. 950.00 MHz Off
  17. 960.00 MHz Off
  18. 970.00 MHz Off
  19. 980.00 MHz Off
  20. 990.00 MHz Off

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:SFREQUENCY 1710.2 MHZ,1805.2 MHZ,1784.8 MHZ,1879.8 MHZ"
!Sets up to 20 comma separated frequencies and sets the state to On for the frequency,
!offset, and RF IN/OUT Amplitude Offset State

OUTPUT 714;"SYSTEM:CORRECTION:SFREQUENCY"
!Sets the state for all frequencies and offsets to Off

SYSTem:CORRection:STATe

Function

Sets/queries the RF IN/OUT Amplitude Offset State. The state must be On before any of the offsets are active regardless of the state for any of the frequencies or offsets.

When the RF IN/OUT Amplitude Offset State is On, the Instrument Status Area will indicate "Offset" regardless of the state for any of the frequencies or offsets.

Setting any of the frequency or offset states to On will set the RF IN/OUT Amplitude Offset State to On.

See Amplitude Offset .

Setting

0|OFF | 1|ON

Query

0|1

Factory Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:STATE ON" !Sets the RF IN/OUT
                                        !Amplitude Offset State to On


SYSTem:CURRent:TA

SYSTem:CURRent:TA

Diagram Conventions

SYSTem:CURRent:TA:MODel?

Function | Query the model number of the test application running. Printable ASCII characters up to a 15 character string.
Query | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting | non volatile, read from the test set's hard disk
Requirements | Test or Lab Application Revision: A.01 and above

SYSTem:CURRent:TA:NAME?

Function | Query the name of the test application running. Printable ASCII characters up to a 25 character string. This command is not recommended see SYSTem:APPLication .
Query | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting | non volatile, read from the test set's hard disk
Requirements | Test or Lab Application Revision: A.01 and above

SYSTem:CURRent:TA:REVision?

Function | Query the coordinated codeware revision for the test application running. Printable ASCII characters up to a 20 character string. This command is not recommended see SYSTem:APPLication .
Query | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting | non volatile, read from the test set's hard disk.
Requirements | Test or Lab Application Revision: A.01 and above


SYSTem:DATE

SYSTem:DATE

Diagram Conventions

SYSTem:DATE

Function

Sets/queries the date.

Setting

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

Query

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

*RST Setting

 This feature is not affected by instrument preset

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:DATE 2001,9,27" !Sets the date to September 27,2001.

OUTPUT 714;"SYSTEM:DATE? !Returns "+2001,+9,+27" if the date has been set to September 27,2001.

Related Topics

SYSTem:UTC:DATE


SYSTem Subsystem

SYSTem Subsystem

Description

The SYSTem subsystem collects the functions that are not related to test set performance. Examples include functions for performing general housekeeping and functions related to setting global configurations, such as TIME or CORRection (amplitude offset).

Syntax Diagrams and Command Descriptions

SYSTem:APPLication

SYSTem:AUDio

SYSTem:BEEPer
SYSTem:COMMunicate
SYSTem:CONFigure
SYSTem:CORRection
SYSTem:CURRent:TA
SYSTem:DATE
SYSTem:ERRor?
SYSTem:MEASurement:RESet
SYSTem:PRESet

SYSTem:REGister

SYSTem:ROSCillator
SYSTem:STATus (Lab Application only)
SYSTem:SYNChronized
SYSTem:TIME
SYSTem:TZONe
SYSTem:UTC


SYSTem:ERRor?

SYSTem:ERRor?

Last updated: December 21, 2004

Diagram Conventions

SYSTem:ERRor?

Function

Queries the contents of the Error/Event Queue. The Error/Event Queue may contain one or more messages with an error or event description.

Manual users may view the Message Log from the SYSTEM CONFIG screen. The contents of the Error/Event Queue and the Message log may not match. Example, manual user errors are not displayed with SYSTem:ERRor? they are viewed from the Message Log. See Error Messages .
Query

Error/Event Queue

  • Range: 0 to 100 messages up to 255 characters in length

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:ERROR?" !Queries the contents of the Error/Event Queue


SYSTem:MEASurement:RESet

SYSTem:MEASurement:RESet

Diagram Conventions

SYSTem:MEASurement:RESet

Function | Sets all measurements to abort. If continous triggering is enabled, measurements will begin a new measurement cycle.
Setting | These results are set to their default values when measurement reset occurs.
Requirements | Test or Lab Application Revision: A.01 and above


SYSTem:PRESet

SYSTem:PRESet

Diagram Conventions

SYSTem:PRESet2

Function

Performs a full preset of the test set. This is the remote equivalent of pressing the SHIFT Preset keys on the front panel of the test set.

All parameters are set to their default values. All measurements are aborted the trigger arm is set to continuous. See Trigger Arm (Single or Continuous) Description .

The *RST command will set the trigger arm to single.
Related Topics See Full Preset for details about the *RST full preset.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:PRESET2" !Full preset, trigger arm set to continuous.

SYSTem:PRESet3

Function

Performs a partial preset. This is the recommended command for users when a partial preset is needed during remote operation of the test set.

Any call in process is disconnected and all measurements are aborted and inactivated. Measurement parameters are not changed.

A partial preset will not modify any measurement settings including trigger arm.

Related Topics

See Partial Preset for more details.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:PRESET3" !Partial preset when in remote operation.


SYSTem:REGister

SYSTem:REGister

Diagram Conventions

SYSTem:REGister:SAVe

Function

Saves the current test set settings to one of five available registers.

If this command is used to save to a register that is already full, the old contents of the register will be overwritten.

Setting

1|2|3|4|5

Query

No query

*RST Setting

 Not applicable

Requirements

Test Application Revision: A.03 or above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SYSTem:REGister:SAVe 1" !Saves the current test set configuration to save register 1.

SYSTem:REGister:RECall

Function

Recalls a saved register from one of five registers.

If this command is used to recall a register that is empty, an error message will be displayed.

Setting

1|2|3|4|5

Query

No query

*RST Setting

 Not applicable

Requirements

Test Application Revision: A.03 or above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SYSTem:REGister:RECall 1" !Recalls register 1.

SYSTem:REGister:DELete

Function

Deletes any contents saved in the selected register.

Setting

1|2|3|4|5

Query

No query

*RST Setting

 Not applicable

Requirements

Test Application Revision: A.03 or above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SYSTem:REGister:DELete 1" !Deletes register 1.

Related Topics

Save and Recall Registers


SYSTem:ROSCillator

SYSTem:ROSCillator

Diagram Conventions

SYSTem:ROSCillator[:TIMebase]?

Function

Queries the timebase source.

If an external timebase is used, it must have these characteristics:

  • an output level of 0 to +13 dBm

  • frequency of 10 MHz

Query

Range:

INT = internal source

EXT = external source

Requirements

Test or Lab Application Revision: A.01 and above

SYSTem:ROSCillator:LOCKed?

Function | Queries the timebase to find out if it is locked or unlocked. Returns 0 or 1.
Query | Range: 0 = unlocked 1 = locked
Requirements | Test or Lab Application Revision: A.01 and above


SYSTem:STATus

SYSTem:STATus

This section is only applicable to the lab application and to a test application with the required feature license.

Diagram Conventions

SYSTem:STATus:COMMunicate:LAN:EXTernal[:STATe]

Function

 Queries External Device Connection Status .

Query

Range:

  • CONG - Connecting
  • CONN - Connected
  • DISC - Disconnecting
  • NCON - Not Connected

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTem:STATus:COMMunicate:LAN:EXTernal?"

SYSTem:STATus:COMMunicate:LAN:EXTernal:CONNected:ADDRess

Function

 Queries Connected Device IP Address .

Query

Range: 15 characters formatted as follows: "A.B.C.D" where A= 0 to 126 and 128 to 223, B.C.D = 0 to 255 (no embedded spaces), "".

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SYSTem:STATus:COMMunicate:LAN:EXTernal:CONNected:ADDRess?"


SYSTem:SYNChronized

SYSTem:SYNChronized

Diagram Conventions

SYSTem:SYNChronized

Function | Sets/queries the test set to see that all prior sequential commands have completed or that all prior overlapped commands have started, indicating that the input buffer is synchronized.
Setting | Bit 12 of the status operation condition register is pulsed.
Query | Range: 1
Requirements | Test or Lab Application Revision: A.01 and above


SYSTem:TIME

SYSTem:TIME

Diagram Conventions

SYSTem:TIME

Function

Sets/queries the local time of day.

UTC time will track changes made directly to local time settings. Also, if new settings are made to UTC time, local time will track UCT time.

Changes to time zone will cause changes to local time, but will not directly affect UTC time.

Setting

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

The resolution of local time setting is minutes. A number within the parameter range must be entered for <second> but it will not affect the minute setting.

Query

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

  • The resolution of the local time setting is minutes. The value returned for <second> will not provide useful information.

*RST Setting

 This feature is not affected by instrument preset

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:TIME 7,30,0" !Sets local time to 7:30

OUTPUT 714;"SYSTEM:TIME?" !Returns "+7,+30,+0" if local time has been set to 7:30.

Related Topics

SYSTem:UTC[:TIME]


SYSTem:TZONe

SYSTem:TZONe

Diagram Conventions

SYSTem:TZONe

Function

Sets/queries the time zone.

Changes to time zone will cause changes to local time, but will not directly affect UTC time.

Setting

Range:

  • <hour> -12 to +15
  • <minute> 0 to 59

Query

Range:

  • <hour> -12 to +15
  • <minute> 0 to 59

*RST Setting

 This feature is not affected by instrument preset

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:TZONe 8,0" !Sets time zone to 8 hours and 0 minutes.

OUTPUT 714;"SYSTEM:TZONe?" !Returns "+8,+0" if time zone has been set to 8 hours.

Related Topics

SYSTem:TIME


SYSTem:UTC

SYSTem:UTC

Diagram Conventions

SYSTem:UTC[:TIME]

Function

Sets/queries the Universal Coordinated Time (UTC) time of day. (UTC is also known as UCT, Zulu, and Greenwich Mean Time.)

Local time will track UTC time settings. Also, if new settings are made to local time, UTC time will track local time.

Setting

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

The resolution of the UTC time setting is minutes. A number within the parameter range must be entered for <second> but it will not affect the minute setting.

Query

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

  • The resolution of the UTC time setting is minutes. The value returned for <second> will not provide useful information.

*RST Setting

 This feature is not affected by instrument preset

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:UTC:TIME 7,30,0" !Sets UCT time to 7:30

OUTPUT 714;"SYSTEM:UTC:TIME?" !Returns "+7,+30,+0" if UTC time has been set to 7:30.

SYSTem:UTC:DATE

Function

Sets/queries the Universal Coordinated Time (UTC) date. (UTC is also known as UCT, Zulu, and Greenwich Mean Time.)

Setting

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

Query

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

*RST Setting

 This feature is not affected by instrument preset

Requirements

 Test Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:UTC:DATE 2001,9,27" !Sets the UTC date to September 27,2001.

OUTPUT 714;"SYSTEM:UTC:DATE? !Returns "+2001,+9,+27" if the UTC date has been set to September 27,2001.

Related Topics

SYSTem:DATE


Performing Individual Measurements Manually

Performing Individual Measurements Manually

The following step-by-step procedures explain how to perform specific measurements available on the W-CDMA Test Application.

The test set and the UE must be synchronized before the UE can generate an uplink signal that can be measured in the following procedures. See How Do I Make Measurements on a UE? .

Detailed descriptions for each measurement and the FDD Test operating mode are provided in the Reference information on the documentation CD-ROM and at the Agilent 8960 support website (www.agilent.com/find/8960support).

Setup parameters for each measurement are assumed to be set to their default (full preset) values unless otherwise stated.

The following measurement procedures are provided:

  • Measuring Adjacent Channel Leakage Ratio
  • Measuring Channel Power
  • Measuring Thermal Power
  • Measuring Waveform Quality
  • Measuring Spectrum Emission
  • Measuring Occupied Bandwidth
  • Measuring Code Domain Power and Error

Measuring Adjacent Channel Leakage Ratio

  1. Configure the mobile station to generate a 12.2 kbps or 64 kbps reference measurement channel (RMC).
  2. Press the Measurement selection key.
  3. Select the Adjacent Channel Leakage Ratio measurement.
  4. Press the ACLR Setup ( F1 ) key.
  5. Set the measurement parameters as needed for your measurement situation, such as turning the measurements on or off for the different frequency offsets.
  6. Press the Change View ( F2 ) key to display the measurement results in either graphical or numeric format.
  7. If using the graphical display, press Graph Limits ( F5 ) to enter the pass/fail measurement limit for each of the four frequency offsets (shown in the graphical measurements example below as the thin lines above each measurement).

Typical adjacent channel leakage ratio results using graphical and numeric format.

Measuring Channel Power

  1. Configure the mobile station to generate a 12.2 kbps or 64 kbps reference measurement channel (RMC).
  2. Press the Measurement selection key.
  3. Select the Channel Power measurement.
  4. Press the Channel Power Setup ( F1 ) key.
  5. Set the measurement parameters as needed for your measurement situation.

A typical channel power measurement result is shown above.

Measuring Thermal Power

  1. Configure the mobile station to generate a 12.2 kbps or 64 kbps reference measurement channel (RMC).
  2. Press the Measurement selection key.
  3. Select the Thermal Power measurement.
  4. Press the Thermal Power Setup ( F1 ) key.
  5. Set the measurement parameters as needed for your measurement situation.

A typical thermal power measurement result is shown above.

Measuring Waveform Quality

  1. Configure the mobile station to generate a 12.2 kbps or 64 kbps reference measurement channel (RMC).
  2. Press the Measurement selection key.
  3. Select the Waveform Quality measurement.
  4. Press the WWQ Setup ( F1 ) key.
  5. Set the measurement parameters as needed for your measurement situation.

Typical waveform quality results are shown above.

Measuring Spectrum Emission

  1. Configure the mobile station to generate a 12.2 kbps or 64 kbps reference measurement channel (RMC).
  2. Press the Measurement selection key.
  3. Select the Spectrum Emission Mask measurement.
  4. Press the SEM Setup ( F1 ) key.
  5. Set the measurement parameters as needed for your measurement situation.
  6. Press the Change View ( F2 ) key to display the measurement results in either graphical or numeric format.

Typical adjacent channel leakage ratio results using graphical and numeric format.

Measuring Occupied Bandwidth

  1. Configure the mobile station to generate a 12.2 kbps or 64 kbps reference measurement channel (RMC).
  2. Press the Measurement selection key.
  3. Select the Occupied Bandwidth measurement.
  4. Press the Occupied BW Setup ( F1 ) key.
  5. Set the measurement parameters as needed for your measurement situation.

Typical waveform quality results are shown above.

Measuring Code Domain Power and Error

  1. Configure the mobile station to generate a 12.2 kbps or 64 kbps reference measurement channel (RMC).
  2. Press the Measurement selection key.
  3. Select the Code Domain measurement.
  4. Press the Code Domain Setup ( F1 ) key.
  5. Set the measurement parameters as needed for your measurement situation.

    Typical waveform quality results are shown above.


Getting Started with Manual Operation

Getting Started with Manual Operation

The test set can be operated using front panel controls and a large video display to perform call processing functions and obtain measurement results. Help Mode provides context sensitive GPIB command syntax assistance. Save and Recall Registers provide a way to return to frequently used setups.

For instructions on configuring the test set's base station emulator, see Call Processing Configuration .

For instructions on performing key call processing operations, see Call Processing Operations .

For instructions on performing a specific measurement, see Making Measurements .

TO RETURN TO THE MAIN MANUAL OPERATION PAGE, click here: Manual Operation .


Audio Level Measurement Description

Audio Level Measurement Description

How is an Audio Level measurement made?

Audio Level measures the AC voltage of the signal applied to the front-panel AUDIO IN connectors, and is one of the Audio Analyzer measurements. Audio Level can be measured for signals in the frequency range of
100 Hz to 20 kHz, at levels from 1 mV peak to 20V peak . The measurement is made after any filtering is applied, and can be made using an rms or peak detector. The type of detector being used for the measurement is displayed next to the measurement value.

When measuring very low voltages, it may be helpful to use the Audio Analyzer's adjustable bandpass filter and the rms detector to reduce noise components.

This measurement is not affected by the Amplitude Offset setting.

Related Topics

Programming an Audio Level Measurement


Adjacent Channel Leakage Ratio Measurement Description

Adjacent Channel Leakage Ratio Measurement Description

How is an adjacent channel leakage ratio measurement made?

Adjacent channel leakage ratio measures the relative power at ± 5 MHz and ± 10 MHz offsets from the uplink channel. Power is measured through a Root-Raised Cosine (RRC) filter with a rolloff of a=0.22, and a bandwidth equal to the chip rate (3.84 MHz). The ± 5 MHz measurements are referred to as the upper and lower first adjacent channels; the ± 10 MHz measurements are referred to as the upper and lower second adjacent channels. This measurement is defined in 3GPP TS 34.121, section 5.10, v3.2.0, Adjacent Channel Power Leakage Ratio (ACLR).

Measurements for individual offsets can be turned off to increase measurement speed when these measurements are not needed.

Measurements can be displayed in either numeric or graphical form. When the graphical display is used (shown below), limits can be set for each offset to form a "limit line." When a limit is exceeded, the status changes from "Pass" to "Fail."

Input Signal Requirements

  • For this measurement the test set's receiver uses autoranging to adjust for the level of the signal being measured; therefore, the expected signal level does not need to be specified during measurement setup.
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, or from 1700 MHz to 1990 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of +5 dBm to +28 dBm, in a 3.84 MHz bandwidth.

Trigger Source

The trigger source defaults to Auto for the adjacent channel leakage ratio measurement, and tries to use protocol triggering if the mobile station (UE) is synchronized to the test set. Immediate triggering is used if the mobile station is not synchronized.

Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function ( CALibration:MEASurements? ) when the temperature has changed by ± 10° C or more since the last calibration. If this situation exists, the integrity indicator value becomes 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

  • Programming an Adjacent Channel Leakage Ratio Measurement
  • Adjacent Channel Leakage Ratio Troubleshooting
  • What 3GPP W-CDMA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator


Audio Analyzer Block Diagram

Audio Analyzer Block Diagram

Related Topics

Audio Analyzer Measurement Description


Audio Analyzer Measurement Description

Audio Analyzer Measurement Description

How is an analog audio measurement made?

The Audio Analyzer can measure Audio Level (V), SINAD (dB), Distortion (%), and Audio Frequency. Measurements are made through the test set's front panel AUDIO IN connectors. When measuring a mobile's audio output, the audio signal may come from either an acoustic coupler or from a test interface connection to the mobile's audio circuitry.

See Audio Analyzer Block Diagram .

The AUDIO IN connectors feed the inputs to a floating-input differential amplifier, with each input having an impedance of about 100,000 ohms to chassis ground. For best noise immunity, connect the audio signal and its ground reference to the two input ports through shielded coaxial cables, or input the signal to the AUDIO IN HI connector and ground the AUDIO IN LO connector's center contact.

None of the analog audio measurement results are affected by the Amplitude Offset setting.

SINAD/Distortion State

Select On or Off to enable or disable the SINAD and Distortion measurements. When On, these measurement results are displayed below the Audio Level measurement and the SINAD/Distortion Fundamental Frequency must be entered to specify the audio frequency for the measurement (range: 100 Hz to 10 kHz). When Off, four dashes are displayed in place of the measurement results.

Audio Frequency State

Select On or Off to enable or disable the Audio Frequency measurement.

Filter Type

  • None - no filtering is provided (default).
  • 100 Hz BW Band Pass Filter (Tunable) - The 100 Hz BW BPF Center Frequency setting is available when this filter is selected, and can be set in the range of 300 Hz to 15 kHz.
  • C-Message
  • 50 Hz to 15 kHz
  • 300 Hz to 15 kHz

Detector Type

Select either Peak or RMS (default) for making and displaying an Audio Level measurement (does not affect other measurements). The type of detector selected is displayed next to the Audio Level measurement results. A 1-volt rms sinewave input signal would measure 1.414 V Peak when the Peak detector is used. A 1-volt peak input signal would measure 0.707 V RMS when the RMS detector is used.

Expected Peak Voltage

The Expected Amplitude sets the analog audio clipping level and must be set. This voltage is always the absolute peak audio input signal voltage expected at the AUDIO IN connectors, and must be in the range of 7.07 mV peak (5 mVrms) to 20 V peak . Remember, measuring a 1-volt rms sinewave input signal would require a 1.414 V peak expected voltage value to avoid clipping (over-driving) the input.

De-Emphasis State

Set to On or Off (default) to enable or disable 750 microsecond de-emphasis.

Expandor Reference Level

Set value from 10 mV/kHz to 10 V/kHz, or Off (default). Entering a numeric value automatically turns the state to On. Entering Off disables the expandor (state = off).

Trigger Source

Audio Analyzer measurements use immediate triggering and are continuously re-triggered by the analyzer any time the Trigger Arm parameter is set to Continuous. Trigger timing is independent of any mobile protocol signaling.

Related Topics

Audio Analyzer Block Diagram

AFANalyzer Troubleshooting

Audio Level Measurement Description

Audio Frequency Measurement Description

SINAD Measurement Description

Distortion Measurement Description

Programming an Audio Frequency Measurement

Programming an Audio Level Measurement

Programming a SINAD Measurement

Programming a Distortion Measurement

Statistical Measurement Results (Multi-measurements)


Audio Frequency Measurement Description

Audio Frequency Measurement Description

How is an Audio Frequency measurement made?

Audio Frequency measures the frequency of the signal applied to the front-panel AUDIO IN connectors, and is one of the Audio Analyzer measurements. Audio frequency can be measured for signals in the frequency range of 100 Hz to 15 kHz, at levels from 7.1 mV peak to 20V peak, and with a signal-to-noise ratio of 30 dB or greater.

The audio frequency measurement is made after any filtering and processing are selected for the Audio Analyzer.

Related Topics

Programming an Audio Frequency Measurement


Calibrating the Test Set

Calibrating the Test Set

Calibration Strategy

Various calibration routines must be run to ensure measurement accuracy. The type of calibration and appropriate intervals for performing calibrations vary with each application.

Description

There are three calibrations that must be performed periodically on the test set:

  • Measurement Calibration
  • I/Q Calibration
  • Spectrum Monitor Calibration

Calibration Procedures

  • Measurement Calibration

    Measurement calibration takes about two minutes.

    During this calibration no power should be applied to the front panel.

    This calibration generates calibration data for the following measurements:

    • Adjacent Channel Leakage Ratio Measurement Description
    • Channel Power Measurement Description
    • Change of TFC (Transport Format Combination) Measurement Description (lab application only)
    • Code Domain Measurement Description
    • Dynamic Power Analysis Measurement Description
    • Inner Loop Power Measurement Description
    • IQ Tuning Measurement Description
    • Occupied Bandwidth Measurement Description
    • Phase Discontinuity Measurement Description
    • PRACH Preamble Analysis Measurement Description (lab application only)
    • PRACH Transmit On/Off Power Measurement Description
    • Spectrum Emission Mask Measurement Description
    • Waveform Quality Measurement Description
    • Spectrum Monitor Description

    During calibration the internal temperature of the test set is measured and calibration data is generated for the measurements' amplitude and frequency ranges.

    Integrity bit 19 is set true and is returned with measurement results when the measurement is uncalibrated due to temperature drift. See Integrity Indicator .

    You can remotely initiate the measurement calibration routine using the CALibration:MEASurements? query. This query returns a numeric value indicating the outcome of the calibration attempt.

    Measurement Calibration Indicator values
    Measurement Calibration Indicator | Measurement Calibration Message
    0 | Measurement's calibration completed successfully.
    1 | Measurement's calibration failed due to temperature drift. Wait for temperature to stabilize.
    2 | Measurement's calibration failed due to oven out of range.
    3 | Measurement's calibration failed due to loopback switch problem.
    4 | Measurement's calibration failed due to under range condition.
    5 | Measurement's calibration failed due to over range condition.
    6 | Measurement's calibration failed due to correlation problem.

    -340

             Measurement's calibration failed. This is a SCPI defined value indicating an unexpected case.

    You can also manually initiate the measurement calibration by initiating one of the above measurements and then pressing the Calibrate Measurements (F4) softkey.

  • I/Q Calibration

    This calibration is required if the baseband generator or the vector output modules are serviced or swapped. IQ calibration should not be used as part of frequent (i.e. daily, weekly or monthly) test set calibration.

    The IQ calibration routines can be manually initiated by pressing the SYSTEM CONFIG key, then pressing the 1 of 2 ( More ) key, then pressing the Service ( F7 ) key.

  • Spectrum Monitor Calibration

    The spectrum monitor must be calibrated for each test application or lab application in your test set, as well as for each format within in a fast switching test application or lab application. For example, if you calibrate the spectrum monitor while the GSM format of the GSM_AMPS/136_GPRS_W-CDMA fast switching test application is active, you must also calibrate the spectrum monitor while the AMPS/136, GPRS, and W-CDMA formats are active, individually.

    The spectrum monitor is automatically calibrated when performing a measurement calibration (see Measurement Calibration ).

    To perform the spectrum monitor calibration from the front panel, initiate the spectrum monitor by pressing Instrument selection , and then selecting Spectrum Monitor from the menu. Next, select Trigger Setup ( F4 ), then Calibrate Measurement (F11). To perform this calibration from a remote program, use the CALibration:SMONitor command. During spectrum monitor calibration, no power should be applied to the front panel RF IN/OUT connector.

    The spectrum monitor calibration takes less than 5 minutes.

    For more information on the spectrum monitor, see Spectrum Monitor Description .

Recommended Calibration Intervals

Condition: | Measurement Calibration | I/Q Calibration | Spectrum Monitor Calibration
When Test Set is being used for the first time (allow 30-minute warm-up period). |  |  |
After firmware is upgraded or after switching between revisions of the application (see Application Revisions and Licenses ) |  |  |
If the ambient temperature changes more than 10 degrees C since latest calibration |  |  |
Once every month |  |  |
If Baseband Generator or Vector Output modules are serviced |  |  |

Related Topics

CALibration Subsystem


Channel Power Measurement Description

Channel Power Measurement Description

How is a Channel Power Measurement Made?

The channel power measurement is made on the RF input signal after frequency downconversion and an analog to digital conversion (see Block Diagram ). The actual power measurement is performed by the test set's digital signal processor (DSP). The signal can be filtered in the DSP with a root-raised cosine (RRC) filter with a rolloff of 0.22 and a bandwidth equal to the chip rate (3.84 MHz) to comply with 3GPP 34.121 conformance specifications that require RRC filtered power. The filter can also be turned off for conformance specifications requiring a mean power measurement. When the RRC filter is Off, the bandwidth of the Channel Power measurement is greater than (1+alpha) times the chiprate, where alpha=0.22.

Differences between the Channel Power and Thermal Power Measurements

When the RRC filter for the channel power measurement is turned on, the results are typically about 0.25 dB lower than the thermal power measurement results.

Thermal power performance is only specified for signals down to -10 dBm, while the channel power measurement is able to accurately measure signals down to -61 dBm.

Input Signal Requirements

  • This measurement does not autorange, therefore the expected power level from the mobile station (UE) is set using the current MS Target Power setting, or by using manual receiver power control and specifying the expected power level. See Receiver Control .
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, or from 1700 MHz to 1990 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of -61 dBm to +28 dBm, measured in a 3.84 MHz bandwidth.

Trigger Source

The trigger source defaults to Auto for the channel power measurement, and tries to use protocol triggering if the mobile station (UE) is synchronized to the test set. Immediate triggering is used if the mobile station is not synchronized.

RF Rise triggering is provided to measure power during PRACH bursts. The burst's on state level must be >-40 dBm, and the off state level must be <-60 dBm, for this trigger to work correctly.

This measurement can be made over a period of .1 ms to 10 ms (the default is 1 timeslot or 666.7 ms) by altering the Measurement Interval. The measurement can be made during a specific timeslot by changing the Trigger Delay.

Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function ( CALibration:MEASurements? ) when the temperature has changed by ± 10° C or more since the last calibration. If this situation exists, the integrity indicator value becomes 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

  • Programming a Channel Power Measurement
  • Channel Power Troubleshooting
  • What 3GPP W-CDMA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator


Code Domain Measurement Description

Code Domain Measurement Description

How is the code domain measurement made?

Code domain power (CDP) is an analysis of the distribution of signal power projected on a code-space of a particular dimension, normalized to the total signal power. To analyze the composite waveform, each channel is decoded using a code-correlation algorithm. This algorithm determines the correlation coefficient for each code. Once the channels are decoded, the power in each code channel is determined.

Code domain error (CDE) measurements are made by sampling the down-converted input signal, then applying DSP (Digital Signal Processing) techniques to determine the original data input to the UE transmitter's OVSF code spreading function for each channel. The DSP uses the original data and coding to generate a representation of the original waveform. This is the reference waveform for the code domain error measurements.

CDE is determined by comparing the reference waveform with the waveform being measured to determine the error vector. The error vector is projected onto the code domain at the same spreading factor used to determine CDP. The error vector for each power code is defined as the ratio to the mean power of the reference waveform expressed in dB.

Code domain measurements are not specified by 3GPP for W-CDMA. Some of the measurement results are common with the Waveform Quality measurement. This is because the method of test is the Global In-Channel TX-Test defined in 3GPP 34.121 Annex B. Code domain power and code domain error are measurement results of this method, and are therefore provided in the test set even though they are not conformance specifications for W-CDMA UEs.

Code domain measurement results

  • Graph of Code Domain Power and Code Domain Error results.
    • The x axis always has a resolution of 256 codes (SF=256).
    • The CDP and CDE are computed in the correct spreading factor for the DPCCH and DPDCH as defined for the channel type used. For example, in the graph below the 64k RMC is used. Therefore, the DPDCH occupies Cch,16,4 as defined in the 3GPP standards. (Cch,Spreading Factor,Code Number)
  • Code Domain Power (CDP)
  • Code Domain Error (CDE)
  • All of the measurement results of the Waveform Quality measurement. Waveform Quality Measurement Description

Input Signal Requirements

  • For this measurement the test set's receiver uses auto-ranging to adjust for the level of the signal being measured; therefore the expected signal level does not need to be specified during measurement setup.
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, or from 1700 MHz to 1990 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of +5 dBm to +28 dBm, in a 3.84 MHz bandwidth.
  • Maximum measurable EVM = 35%
  • Maximum measurable frequency error = ± 1 kHz

Trigger Source

Triggering choices for the Waveform Quality measurement are immediate, protocol, external, and auto. Auto triggering is the default choice. In most cases, auto triggering provides the optimum measurement triggering condition for the Waveform Quality measurement. For example, if the UE is synchronized to the test set, protocol triggering is used. Immediate triggering is used if the UE is not synchronized.

When immediate triggering is used, the measurement result returned for timing error is always NAN (Not a Number) because it is not possible to evaluate a timing error in this measurement situation.

The measurement is performed during one timeslot. The timeslot to use for the measurement is selectable (0 to 14).

Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function ( CALibration:MEASurements? ) when the temperature has changed by ± 10° C or more since the last calibration. If this situation exists, the integrity indicator value becomes 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

  • Programming a Code Domain Measurement
  • Code Domain Troubleshooting
  • What 3GPP W-CDMA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator


Distortion Measurement Description

Distortion Measurement Description

How is a Distortion measurement made?

Distortion is an audio quality measurement that compares the audio signal level from the mobile at a specified (desired) frequency to the level of signals present at other frequencies. The audio signals from the mobile are typically measured after digital demodulation of the traffic channel.

The test set makes two measurements to determine distortion. First, the test set measures the total audio signal level into the Audio Analyzer. Next, a precise notch filter is then used to remove the signal at the specified frequency. The remaining signal level indicates the level of unwanted signals (distortion). Distortion is expressed as a percentage of the total audio signal.

Distortion can be measured in the range of 100 Hz to 10 kHz. For information on using the Audio Analyzer, see Audio Analyzer Measurement Description .

The distortion measurement can be used to perform the audio harmonic distortion test. For example, in the AMPS system two audio signals are used: a 1004 Hz tone and the 6000 Hz SAT. The 1004 Hz tone is notched out to make the measurement.

Related Topics

Audio Analyzer Measurement Description


Data Throughput Monitor Description

Data Throughput Monitor Description

This section is only applicable to the lab application.

Description

What is Data Throughput?

As part of the test set's lab application, a data throughput monitor is provided to analyze data transfer rates under various RF and call processing conditions. The monitor is selected by pressing the Instrument selection key, and accessed by pressing the MEASUREMENT key.

Data throughput is the rate of data transfer to and from a wireless device.

This feature does not attempt to monitor application layer data throughput (FTP, HTTP, TELNET, etc.)

Four statistical results are available from the data throughput monitor:

  • OTA Rx and OTA Tx

    OTA (Over the Air) throughput counts the data received and transmitted by the test set protocol stack. The location of the measurement point in the protocol stack is dependent on system type; this data could be a byte stream from RLP (Radio LInk Protocol) or RLC (Radio Link Control) or PPP (point to point protocol). OTA throughput does not count physical layer overhead such a mid-amble, guard, or tail bits, or bits added by the encoding process.

  • IP Rx and IP Tx

    IP (Internet Protocol) throughput counts the data received and transmitted by the test set. It measures the IP data transferred between the external LAN connector and the protocol stack. It provides a measure of the IP data packets being transferred to/from the wireless device.

How is Data Throughput Displayed?

When the Data Throughput Monitor is selected and a data call is connected, the test set begins to accumulate data throughput statistics. If a data call is disconnected, data accumulation will be suspended until another connection is made and data accumulation continues. Data accumulation can be cleared by performing a measurement reset or clearing the graph.

The test set provides two tools to analyze data throughput:

  • Graphical trace
  • Summary table

Graphical trace

The graphical trace presents up to the most recent 600 seconds (10 minutes) of data throughput statistics. Each of the following color-coded traces can be turned on or off:

  • OTA Tx - (Over The Air Transmitted bits-per-second). This is the rate of link-layer bit transfer sent from the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000, or RLC (Radio Link Control) protocol in WCDMA and GPRS, or PPP in GSM. Tx refers to the reverse or uplink channel direction.
  • OTA Rx - (Over The Air Received bits-per-second). This is the rate of link-layer bit transfer received by the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000, or RLC (Radio Link Control) protocol in WCDMA and GPRS, or PPP in GSM. Rx refers to the forward or downlink channel direction.
  • IP Tx - Internet Protocol Transmitted. This is the rate of network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.
  • IP Rx - Internet Protocol Received. This is the rate of network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.

A marker can be assigned to each trace to display instantaneous numeric data throughput values. Markers can be used in conjunction with the Freeze Graph feature to analyze points of interest on traces.

Summary table

The summary table provides the latest statistics for the four monitored measurements. Each measurement is displayed with the following statistics:

  • Marker

    The data rate at the measurement's marker position in bits-per-second.

  • Current

    The measurement's instantaneous data in bits-per-second.

  • Average

    The measurement's average data rate in bits-per-second over the length of the data connection or since the last time the measurement was cleared.

  • Peak

    The measurement's peak data rate in bits-per-second over the length of the data connection or since the last time the measurement was cleared.

  • Data Transfer

    The measurement's total data throughput count, in bytes, over the length of the data connection or since the last time the measurement was cleared

Related Topics

How Do I Use the Data Throughput Monitor?


Frequency Stability Measurement Description

Frequency Stability Measurement Description

Description

How is a Frequency Stability measurement made?

The Frequency Stability measurement displays the frequency of an RF signal applied to the test set's front panel RF IN/OUT input port. After each measurement the input signal's absolute RF freqency is displayed with 1000 Hz resolution on the test set's front panel and 1 Hz resolution when queried over the GPIB.

The absolute RF signal frequency obtained during each Frequency Stability measurement is compared to the expected (measurement downconverter) frequency of the test set's measuring receiver. The difference between the expected frequency and the measured frequency is displayed as frequency error with 1 Hz resolution.

Frequency Stability Measurement

If the device under test is a mobile station on a call, the expected frequency can be automatically set by the base station emulator (using the RF Channel setting).

If the device under test is not on a call, the expected frequency must be set by manually controlling the receiver (manual measurement frequency).

Operating Considerations

Front Panel Access

Frequency Stability measurements are accessed manually by pressing the front-panel Measurement selection key.

NOTE
In some test set applications it is necessary to select an analog System Type (for example, AMPS) or an analog Operating Mode (for example, AVC Test or CW) to access the Frequency Stability measurement.

Input Signal Requirements

The Frequency Stability measurement is designed to measure non-bursted analog signals. For example, this measurement can be made on an AMPS cellular mobile station while it is on an active AVC (analog voice channel) with or without SAT or other frequency modulation. It is not desiged to measure AM (amplitude modulated) signals.

When a mobile station is on a call, the test set has the ability to predict the power level and frequency that is present on the RF input and automatically adjust attenuator and measurement downconverter settings. However, for test operating modes or CW (continuous wave) the test set is not functioning as a base station emulator. In the absence of call control, it is likely that the test set's receiver will need to be manually tuned to the input signal.

To meet Frequency Stability measurement performance specifications, the input signal must be:

  • Within the frequency interval 293 MHz to 2.7 GHz.
  • Within 200 kHz of the expected frequency.
  • Greater than -30 dBm.
  • Within 3 dB of the expected power.
  • Within an FM index of three (if FM is applied).
  • Within 100 Hz and 15 kHz modulating frequency (if FM is applied).

Multi-measurement Use

When multi-measurement count is turned on during a Frequency Stability measurement, the test set returns statistical data acquired over a number of measurements, including the worst case frequency error, in ppm (parts per million).

Frequency Stability Measurement With Multi-measurements

Related Topics

Programming a Frequency Stability Measurement

Frequency Stability Troubleshooting

Receiver Control


Getting Started with Measurements

Getting Started with Measurements

The test set includes many measurements and instruments for testing your wireless device.

For information about each measurement, such as how it is performed, setup parameters and the measurement results available, see Measurement Descriptions .

For a listing of conformance tests that are supported by the test set, see What 3GPP W-CDMA Conformance Tests Are Supported? .

TO RETURN TO THE MAIN MEASUREMENTS PAGE, click here: Measurements .


Inner Loop Power Measurement Description

Inner Loop Power Measurement Description

What is the Inner Loop Power Control?

Inner loop power control in the uplink is the ability of the UE to adjust its output power in accordance with one or more TPC (transport power control) commands received in the downlink. When the UE is not in soft handover, only one TPC command is received in each timeslot. The UE's output power changes in response to a single TPC command, TPC_cmd, derived at the UE based on the Power Control Algorithm. TPC_cmd, along with the Power Control Step size, determines the UE transmit output power. The power change is applied in the timeslot adjacent to the timeslot in which the TPC command is received. For example, the power change derived from a TPC command in the 10th timeslot is applied to the 11th timeslot.

How is an Inner Loop Power Measurement Made?

The inner loop power measurement is made through a root-raised cosine (RRC) filter with a roll off of alpha=0.22 and a bandwidth equal to the chip rate (3.84 MHz). The test set measures the mean power in each timeslot, excluding the transient duration. The transient duration is from 25 microseconds before the slot boundary to 25 microseconds after the slot boundary. The relative power difference is calculated for adjacent TPC_cmds and also for 10 TPC_cmd groups (10 timeslots if using algorithm 1 and 50 slots if using algorithm 2).

You can run the inner loop power measurement in Auto or Manual mode.

The inner loop power test process recommended in the standard consists of a series of test segments (referred to as Test Steps in the standard, see Inner Loop Power Control Test Steps ). The test set allows you to run one segment at a time.

Inner Loop Power Control Test Steps

Auto Mode

Auto mode is used to run a single test segment as specified in the standard. This is achieved by selecting any one of the test segments (referred to as Test Steps in the standard) from the Test Segment menu and then initiating the measurement. You can perform the entire "Inner Loop Power Control in the Uplink" test by piecing the test segments together. In auto mode, Start Power , Stop Power , Power Control Algorithm and Step Size can not be changed, they are automatically configured by the test set.

The test set behavior for each Test Segment is described in the table below. When you initiate the measurement with one of these test segments selected, the test set drives the UE to the proper Start Power for the test segment (if it is not already at the proper Start Power ) and automatically sets Power Control Algorithm and Step Size to the proper values for the test segment before sending the specified TPC command sequence to the UE.

Test Segment Descriptions
Test Segment | Power Control Algorithm | Step Size | Start Power | TPC Command Sequence Sent by Test Set
A | Two | 1 dB | -10 dBm (+/- 1 dB) | The TPC commands sent depend upon the Number of Slots setting, as follows: Number of Slots = 15: 100000101010101 Number of Slots = 30: 100000101010101111101000001010 Number of Slots = 45: 100000101010101111101000001010 101011111010000 Number of Slots = 60: 100000101010101111101000001010 101011111010000010101010111110
B | Two | 1 dB | -10 dBm (+/- 1 dB) | 50 TPC commands with value 1
C | Two | 1 dB | 0 dBm (+/- 1 dB) | 50 TPC commands with value 0
Note: Test Segment can not be set to D. Step D in 3GPP TS 34.121 5.4.2 is automatically performed when you initiate Test Segment E. I.e., when Test Segment E is initiated, the test set sets Power Control Algorithm to One , Step Size to 1 dB , and sends TPC commands with a value of 1 until the UE reaches its maximum power. The test set then sends the TPC command sequence for Step E.
E | One | 1 dB | 30 dBm or max power, + whichever is lower | Up to 300 TPC commands with value 0 *
F | One | 1 dB | -61 dBm or min power, # whichever is higher | Up to 300 TPC commands with value 1 *
G | One | 2 dB | 30 dBm or max power, + whichever is lower | Up to 150 TPC commands with value 0 *
H | One | 2 dB | -61 dBm or min power, # whichever is higher | Up to 150 TPC commands with value 1 *
+ The test set sends all up bits to the UE until the UE stops increasing its output power (is stable within +/- 1 dB), or until its output power reaches 30 dBm (+/- 1 dB). # The test set sends all down bits to the UE until the UE stops decreasing its output power (is stable within +/- 1 dB), or until its output power reaches -61 dBm (+/- 1 dB). * The test set stops sending bits when the UE's power changes by less than 1/4 the ordered step size, followed by 9 subsequent power changes that are less than 1/2 the ordered step size. Note: to maintain accuracy, the test set re-ranges its receiver during these sequences. During this re-ranging time, the test set sends a series of alternating power control bits to the UE to hold its output power level.

Manual Mode

Manual mode allows you to build a custom test segment. This is achieved by selecting Manual from the Test Segment menu. In manual mode, the UE will be instructed to go to start power before starting the test and test the UE's response by sending the TPC commands with a step size and power control algorithm specified by the user until the expected target power is equal to stop power. In manual mode,

  • you can change the following measurement settings: Start Power, Stop Power, Power Control Algorithm and Power Control Step Size (valid only when Algorithm 1 selected).
  • if the Start Power is set to the same as Stop Power, the Power Control Algorithm and Power Control Step Size settings can not be changed and are set to Algorithm 2 and 1 dB step size. The Number of Slots setting can be changed and the following sequence of TPC commands are used with the selected Number of Slots.
    • 100000101010101 (Number of Slots = 15)
    • 100000101010101111101000001010 (Number of Slots = 30)
    • 100000101010101111101000001010101011111010000 (Number of Slots = 45)
    • 100000101010101111101000001010101011111010000010101010111110 (Num of Slots = 60)

UE (Mobile Station) Control During FDD Test Operation Mode

When the measurement is made in FDD Test mode, UE should be capable of deriving TPC_cmd commands in test mode. You need to configure the UE to use the proper power control algorithm and the step size before initiating a measurement.

Measurement Results Display

The test set can run a single one of the test segments at a time resulting in a pass/fail and trace data that can be accessed via the MUI or RUI.

  • Overall Pass/Fail result for the specified test segment. If any timeslot in the test segment does not comply with the standard, the entire segment test fails.
  • Number of slots: Indicates the total number of TPC commands (number of timeslots tested) sent for the chosen test segment.
  • Results associated with each timeslot in which a TPC command is sent for making this measurement:
    • Slot number: Used as an index to the results reported in each timeslot. Slot 0 would be the reference timeslot. Response to the TPC command sequence are from Slot 1.
    • Absolute Pwr (dBm): Indicates mean output power level for the current slot excluding the transient time (25 us from either side of the slot boundary).
    • Relative Pwr (dB): The difference between the mean power in the current slot and the mean power in the previous slot.
    • Rel Pwr 10 TPC (dB): The change in mean power over 10 TPC_cmd groups. (NAN for the first 9 results when in Algorithm 1 mode and NAN for the first 49 results when in Algorithm 2 mode.)
    • P/F: Indicates whether the change in the UE transmit power level is within the prescribed range as specified in the 3GPP TS 34.121, section 5.4.2 standard. (Pass/Fail result: 0 = pass, 1 = fail adj TPC_cmds, 2 = fail 10 TPC_cmd groups result, 3 = fail in both adj TPC_cmds and 10 TPC_cmd groups test)
  • Worst case results (closest to failing or farthest from the standard specifications if it failed). See FETCh:WILPower[:ALL]? command.
    • Timeslot number of the worst case adjacent TPC_cmds result in which the worst case relative power for adjacent TPC_cmds is returned.
    • Absolute power level associated with the worst case TPC_cmds timeslot
    • Relative power level for adjacent TPC_cmds associated with the worst case TPC_cmds timeslot
    • Relative power level for 10 TPC_cmd groups associated with the worst case TPC_cmds timeslot
    • Timeslot number of the worst case 10 TPC_cmd groups result in which the worst case relative power for 10 TPC_cmd groups is returned.
    • Absolute power level associated with the worst case 10 TPC_cmd groups timeslot
    • Relative power level for adjacent TPC_cmds associated with the worst case 10 TPC_cmd groups timeslot
    • Relative power level for 10 TPC_cmd groups associated with the worst case 10 TPC_cmd groups timeslot

You can use the Axis Control ( F2 ) settings to control the graph trace window and use the Marker ( F3 ) setting to control the range of measurement results shown in the measurement results list (up to 12 measurement results at one time). The measurement result list will scroll with the marker. If the marker setting is greater than the number of results that can be displayed, the result list will show the previous measurement results.

Measurement Behavior

No other measurements can be running during Inner Loop Power measurement. If any measurements are running when an Inner Loop Power measurement is initiated, they will be closed and a message will be displayed to indicate that they are closed.

To use this measurement in Active Cell mode, UE needs to be up on a call. To use the measurement in FDD Test Mode, UE should be capable of deriving TPC commands in FDD test mode. You needs to configure the UE to use the right power control algorithm and the step size before initiating a measurement.

The test set does not support testing the UE in compressed mode with this measurement, therefore 3 dB power control step size will not be allowed.

RF IN/OUT Amplitude Offset settings apply to any of the Inner Loop Power absolute power measurement and do NOT apply to the relative power measurement results.

Input Signal Requirements

  • For this measurement the test set's receiver uses autoranging to adjust for the level of the signal being measured; therefore, the expected signal level does not need to be specified during measurement setup.
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, or from 1700 MHz to 1990 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of -61 dBm to +28 dBm, in a 3.84 MHz bandwidth.

Trigger Delay

You can adjust the beginning of the measurement interval for each slot measured using the Trigger Delay setting. This is useful if your UE's output power change in response to TPC commands is delayed. You can then shift the measurement interval to match the delay in the UE's response.

NOTE
Trigger Delay should only be set to a non-zero value if your UE's output power response to TPC commands is delayed (i.e. if your UE is not operating properly). If your UE is behaving correctly in the timing of power changes in response to TPC commands, non-zero values of the Trigger Delay setting can cause unspecified results.

Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function ( CALibration:MEASurements? ) when the temperature has changed by ± 10° C or more since the last calibration. If this situation exists, the integrity indicator value becomes 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

  • Manual Operation: How Do I Make an Inner Loop Power Measurement?
  • Programming an Inner Loop Power Measurement
  • Inner Loop Power Troubleshooting
  • What 3GPP W-CDMA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator


IQ Tuning Measurement Description

IQ Tuning Measurement Description

How is an IQ Tuning Measurement Made?

The IQ tuning measurement is made during one user-selected timeslot (0 - 14). It includes all of the measurements available in the Waveform Quality measurement (see Waveform Quality Measurement Description ), along with the following measurement results:

  • IQ gain imbalance
  • IQ phase imbalance
  • Peak EVM
  • Chip EVM
  • IQ constellation diagram

IQ gain imbalance and IQ phase imbalance measurements are determined by comparing the received signal's IQ modulation characteristics with an ideal signal (IQ gain imbalance, IQ phase imbalance and Origin Offset are solved for using the parameter estimator described in Estimation of Amplitude Imbalance, Phase Imbalance, and Origin Offset of a Complex Signal Relative to an Ideal Reference by R. A. Birgenheier, Jan. 4, 2000). Chip EVM is the calculated EVM at each chip in the measured timeslot. Peak EVM is the maximum chip EVM. The IQ constellation is the measured IQ signal with origin offset included.

Chip EVM is measured as a 2560 element array of 32-bit floating point numbers. The first element in the array corresponds to the measured EVM for the first chip in the measured time slot, the second element to the EVM for the second chip in the measured time slot, and so on. These results will be available graphically on the front panel display and numerically via the GPIB commands.

IQ constellation is measured as a 2560 element array of ordered pairs. Each ordered pair consists of two 32-bit floating point numbers corresponding to one point in the IQ constellation. The first member in the ordered pair is the I coordinate, the second is the Q coordinate. The array is scaled so all points fall within a unit circle. The first ordered pair in the IQ constellation array corresponds to the first chip in the measured time slot, the second ordered pair in the array corresponds to the second chip in the measured time slot, and so on. The IQ constellation result will only be available graphically on the front panel display. It will not be accessible via the GPIB commands.

Measurement Results Display

Chip EVM and the IQ constellation will be graphed together on the same screen. See figure IQ Tuning Graph Display for an example display. You can use the Axis Control ( F2 ) and the Marker ( F3 ) settings to control the Chip EVM trace graph and the IQ constellation diagram. IQ constellation diagram will always be redrawn to reflect the latest Chip EVM settings. For example, if the chip EVM for chips 512 through 1023 are plotted, then the IQ constellation will be shown for just chips 512 through 1023. The I and Q values for the IQ constellation will all range between -1.0 and +1.0.

IQ Tuning Graph Display

Input Signal Requirements

  • For this measurement the test set's receiver uses auto-ranging to adjust for the level of the signal being measured; therefore the expected signal level does not need to be specified during measurement setup.
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, or from 1700 MHz to 1990 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of -25 dBm to +28 dBm, in a 3.84 MHz bandwidth.
  • Maximum measurable EVM = 35%

Trigger Source

The trigger source for the IQ tuning measurement defaults to Auto which provides the optimum measurement triggering condition. For example, if the UE is synchronized to the test set, protocol triggering is used. Immediate triggering is used if the UE is not synchronized.

When immediate triggering is used, the measurement result returned for timing error is always NAN (Not a Number) because it is not possible to evaluate a timing error in this measurement situation.

Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function ( CALibration:MEASurements? ) when the temperature has changed by ± 10° C or more since the last calibration. If this situation exists, the integrity indicator value becomes 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

  • Manual Operation: How Do I Make an IQ Tuning Measurement?
  • Programming an IQ Tuning Measurement
  • IQ Tuning Measurement Troubleshooting
  • What 3GPP W-CDMA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator


Loopback Bit Error Ratio Measurement Description

Loopback Bit Error Ratio Measurement Description

  • How Is a Loopback Bit Error Ratio Measurement Made?
  • Loopback BER Measurement Parameters
  • Loopback BER Measurement Results
  • Input Signal Requirements

How Is a Loopback Bit Error Ratio Measurement Made?

3GPP TS 34.121, F.6.1.1 defines bit error ratio (BER) as follows: "The Bit Error Ratio is defined as the ratio of the bits wrongly received to all data bits sent. The bits are the information bits above the convolutional/turbo decoder."

When the test set measures loopback bit error ratio, it sends a known data pattern (see DL DTCH Data ) on the downlink dedicated traffic channel (DTCH) to a UE that is configured in loopback mode 1 or 2. (Although the measurement will operate with UE Loopback Type set to 2 , all TS 34.121 tests utilizing the BER measurement require loopback mode 1). The UE decodes the data and re-transmits it on the uplink DTCH. The test set analyzes the uplink data to see how closely it matches the data bits originally sent on the downlink. The test set compares the downlink and uplink data one transport block at a time and reports the Bit Error Ratio .

To decrease test time, you may set Confidence State to On and specify Confidence Level , BER Requirement and Bad DUT Factor , which allow the test set to stop testing when an early pass or early fail event occurs, and to report a Confidence Test Result (see 3GPP TS 34.121 F.6 and 3GPP TS 34.901).

3GPP TS 34.121 Figure F.6.1.9

Because the test set must compare the UE's uplink data with the corresponding downlink data, the measurement must be able to synchronize to the UE's signal (align received uplink transport blocks with their corresponding downlink transport blocks. In doing so, the test set determines the UE's Loopback Delay ). See Input Signal Requirements .

When testing the UE's receiver performance, it is assumed that the uplink is error free. Any errors occurring on the uplink invalidate the receiver test. The loopback BER measurement returns information about uplink CRC Errors to assist in ensuring that the uplink is error free (to perform the loopback BER measurement, you must set Uplink DTCH RMC CRC Presence to Present so that an uplink CRC is generated).

To perform the loopback BER measurement while in Active Cell Operating Mode , you must be on an RB test mode call, with Channel Type set to a symmetrical RMC. Loopback BER can not be measured for Asymmetrical RMCs .

The trigger source for this measurement is always protocol-based (see Trigger Source Description ).

UE Control During FDD Test Mode Operation

The FDD Test Operating Mode does not provide radio bearer setup control of the UE for test mode operation. You must configure the UE in loopback mode 1 or 2 and synchronize it to the test set's downlink signal in order to make this measurement in FDD test operating mode.

The uplink transport format must include both the DTCH and the DCCH; however, only the DTCH information is used for the loopback bit error ratio measurement.

Loopback BER Measurement Parameters

  • Number of Bits to Test

    When Confidence State is Off , you may set the number of data bits to test during the measurement using the Number of Bits to Test setting. However, the actual number of bits tested is always the largest multiple of the number of bits needed to fill a DTCH transport block for the transmitted format. For example, for the 12.2 kbps reference measurement channel (RMC) the transport block is 244 bits. If you set the number of bits to test to 1000, the actual number of bits tested will be 1220 (1000 bits/244 bits per block = 4.1 blocks, so 5 blocks are required to test at least 1000 bits. 5 blocks x 244 bits per block = 1220 bits).

    When Confidence State is On , you may set the maximum number of bits to test during the measurement using the Number of Bits to Test setting. However, the actual number of bits tested will be less than this number if an early pass or early fail event occurs (see Confidence Test Result ). If a Confidence Test Result of Max Bits Tested is returned, then the actual number of bits tested is the largest multiple of the number of bits needed to fill a DTCH transport block for the transmitted format, as explained above.

    GPIB command: SETup:WBERror:COUNt

  • Trigger Arm - see Trigger Arm (Single or Continuous) Description .
  • Measurement Timeout - see Measurement Timeouts .

  • Confidence State

    To decrease test time, you may set Confidence State to On and specify Confidence Level , BER Requirement and Bad DUT Factor , which allow the test set to stop testing when an early pass or early fail event occurs, and to report a Confidence Test Result (see 3GPP TS 34.121 F.6 and 3GPP TS 34.901).

    From the front panel, Confidence State can be set by pressing the ON or OFF key while Confidence Level is selected, or by simply entering a valid value for Confidence Level .

    GPIB commands: SETup:WBERror:CONFidence[:SLEVel] , SETup:WBERror:CONFidence:STATe

  • Confidence Level

    3GPP TS 34.121 F.6 defines:
    F = probability of a wrong decision
    (1 - F) = probability of a correct decision
    The probability (risk) to fail a good DUT shall be </= F according to the following definition: A DUT is failed, accepting a probability of </= F that the DUT is still better than the specified error ratio (Test requirement (see BER Requirement )).
    The probability to pass a bad DUT shall be </= F according to the following definition: A DUT is passed, accepting a probability of </= F that the DUT is still worse than M times the specified error ratio (see BER Requirement ). (M>1 is the bad DUT factor (see Bad DUT Factor )).

    The Confidence Level parameter is equivalent to (1 - F). 3GPP TS 34.121 table F.6.1.8 specifies an F of 0.2% ( Confidence Level of 99.8% ) for all Receiver and Performance Characteristics tests in 3GPP TS 34.121 sections 6 and 7 (except for the fail limit for 6.5 Blocking Characteristics).

    GPIB commands: SETup:WBERror:CONFidence[:SLEVel] , SETup:WBERror:CONFidence:LEVel

  • BER Requirement

    3GPP TS 34.121 F.6 defines TR = Test Requirement. As testing progresses, the bit error ratio trajectory converges to a value (see 3GPP TS 34.121 Figure F.6.1.9 ). The BER value that the UE is converging to shall not exceed the Test Requirement. The BER Requirement parameter is equivalent to Test Requirement expressed as a percentage. 3GPP TS 34.121 table F.6.1.8 specifies a Test Requirement of between 0.001 and 0.1 (0.1% and 10% BER Requirement ) for the Receiver and Performance Characteristics tests in 3GPP TS 34.121 sections 6 and 7.

    This setting is only available when Confidence State is On .

    GPIB command: SETup:WBERror[:RATio]:REQuirement

  • Bad DUT Factor

    3GPP TS 34.121 F.6 defines M = bad DUT factor. A Bad DUT Factor of greater than 1 shifts the early pass limit curve up (the early pass limit curve is defined by 3GPP TS 34.121 F.6.1.5 equation (2). See also 3GPP TS 34.121 Figure F.6.1.9 .) This allows an early pass event to occur after fewer bits have been tested for a given number of errors, which results in a higher bit error ratio (see the early pass equation for NL( ne ) in 3GPP TS 34.121 F.6.1.9). As a result, the test set may return a Confidence Test Result of Pass even when the Bit Error Ratio result is above the specified BER Requirement if Bad DUT Factor is set to a very high level. As M is increased, a greater number of bad DUTs are passed. 3GPP TS 34.121 table F.6.1.8 specifies a Bad DUT Factor of 1.5 for all Receiver and Performance Characteristics tests in 3GPP TS 34.121 sections 6 and 7.

    This setting is only available when Confidence State is On .

    GPIB command: SETup:WBERror:CONFidence:DUTFactor

  • Uplink DTCH RMC CRC Presence
  • UE Loopback Type

Loopback BER Measurement Results

  • Integrity Indicator
  • Bit Error Ratio

    The ratio of incorrectly received bits to the Bits Tested , expressed as a percentage (%).

    GPIB command: FETCh:WBERror<[:ALL]|:INTegrity|:RATio|:COUNt|:BITS>?

  • Confidence Test Result

    The Confidence Test Result is only available when Confidence State is On .

    • Pass : Few enough bit errors were detected for a large enough number of Bits Tested that the test set is able to predict (with the specified Confidence Level ) that the bit error ratio trajectory is converging to a value below the BER Requirement . An early pass event is determined according to 3GPP TS 34.121 5.6.1.5 equation (2).
    • Fail : Enough bit errors were detected for the number of Bits Tested that the test set is able to predict (with the specified Confidence Level ) that the bit error ratio trajectory is converging to a value above the BER Requirement . An early fail event is determined according to 3GPP TS 34.121 5.6.1.5 equation (1).
    • Max Bits Tested : After testing the number of bits specified by Number of Bits to Test , the test set is unable to predict (with the specified Confidence Level ) whether the bit error ratio trajectory is converging to a value above or below the BER Requirement .

    GPIB command: FETCh:WBERror:RATio:FAIL?

  • Bit Error Count

    The number of incorrectly received bits.

    GPIB command: FETCh:WBERror<[:ALL]|:INTegrity|:RATio|:COUNt|:BITS>?

  • Bits Tested

    Number of bits tested to determine the Bit Error Count and Bit Error Ratio results.

    GPIB command: FETCh:WBERror<[:ALL]|:INTegrity|:RATio|:COUNt|:BITS>?

  • Missing Blocks

    The UE sends a TFCI for each uplink DTCH transport block. When operating in Active Cell Operating Mode , the test set monitors the uplink TFCI, and can report uplink missing blocks. If the TFCI indicates that there is no data block sent for that TTI, the test set reports a missing block. When a missing block occurs, Bit Error Count and the number of Bits Tested are not incremented. The test set returns a Questionable MS-to-Cell Data Integrity Indicator .

    When in FDD Test Operating Mode , the test set does not monitor the uplink TFCI; rather, it assumes that a data block is sent in every TTI. However, when a missing block occurs, the test set detects a CRC error. Thus, the data within the block is not analyzed, and the number of Bits Tested is not incremented.

    GPIB command: FETCh:WBERror:MBLocks?

  • CRC Errors

    To determine if an uplink CRC error has occurred, the test set calculates the CRC for the data sent in the uplink DTCH transport block, and compares the result to the CRC sent by the UE for that transport block. When a CRC error occurs, the data within the block is not analyzed, and the number of Bits Tested is not incremented. If a CRC error occurs, the test set returns a Questionable MS-to-Cell Data Integrity Indicator .

    GPIB command: FETCh:WBERror:CRCerrors?

  • Loopback Delay

    3GPP TS 25.211 section 7.6.3 specifies that the uplink frame transmission take place 1024 chips after reception of the corresponding downlink frame. In reality, there is often a larger delay before the UE is able to transmit the uplink frame. 3GPP TS 34.109, 5.3.2.9 specifies this delay between received downlink radio frames and their corresponding uplink radio frames (produced from the received data) as the loopback delay. Loopback delay is measured at the UE antenna connector and is specified in units of radio frames. While the UE test loop is closed and the radio bearer configuration is not changed, the UE is required to maintain a fixed loopback delay, which must not exceed the number of radio frames corresponding to 10 times the TTI (Transmission Timing Interval) of the actual transport channel configuration. For example, if TTI is 10 ms, the UE is required to maintain a fixed loopback delay not to exceed 10 radio frames (the test set can actually tolerate a loopback delay of up to 50 TTI).

    To calculate loopback delay, the test set correlates the data in the uplink radio frame to the data sent in the downlink radio frame. Thus, the data sent by the test set must be different for each radio frame ( DL DTCH Data must not be set to All Zeros or All Ones ).

    GPIB command: FETCh:WBERror:LDELay?

Input Signal Requirements

  • The expected power into the test set must be set in order to maintain the link with the UE. This is done using the MS Target Power setting or by using manual receiver power control and specifying the expected power level. See Receiver Control .
  • The test set can synchronize to the UE's signal only if the bit error ratio is less than 10% on a block-by-block basis for three consecutive blocks, and the loopback delay is less than 50 transmission time intervals of the DTCH.

Related Topics

Manual Operation: How Do I Perform a Loopback BER Measurement?

Programming a Loopback Bit Error Ratio Measurement

Loopback Bit Error Ratio Troubleshooting

Radio Bearer Test Mode Setup

Block Error Ratio Measurement Description

What 3GPP W-CDMA Conformance Tests Are Supported?


Occupied Bandwidth Measurement Description

Occupied Bandwidth Measurement Description

How is the occupied bandwidth measurement made?

As defined by 3GPP TS 34.121 section 5.8 Occupied Bandwidth (OBW) is the bandwidth containing 99% of the total integrated power of the transmitted spectrum, centered on the assigned channel frequency. The test set allows the percentage of total integrated power to be adjusted from 70.0 to 99.0%.

During this measurement, a Gaussian filter with a bandwidth greater than 10MHz and a resolution bandwidth (RBW) of 30 kHz or less is used to measure the distribution of the power spectrum.

First, the total power found in the measured frequency range is calculated. Then, starting at the lowest frequency in the range and moving upward, the power distributed in each frequency is summed until this sum is 0.5% of the total power. This gives the lower frequency value. Next, starting at the highest frequency in the range and moving downward, the power distributed in each frequency is summed until 0.5% of the total power is reached. This gives the upper frequency value. The bandwidth between the 0.5% power frequency points is the occupied bandwidth.

Input Signal Requirements

  • For this measurement the test set's receiver uses autoranging to adjust for the level of the signal being measured; therefore the expected signal level does not need to be specified during measurement setup.
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, or from 1700 MHz to 1990 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of +5 dBm to +28 dBm, in a 3.84 MHz bandwidth.

Trigger Source

The trigger source defaults to Auto and tries to use protocol triggering if the UE is synchronized to the test set. Immediate triggering is used if the UE is not synchronized.

If you want to measure the occupied bandwidth for a specific timeslot, use the trigger delay parameter.

Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function (see CALibration:MEASurements? ) when the temperature has changed by ± 10° C or more since the last calibration. If this situation exists, the integrity indicator value is changed to 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

  • Programming an Occupied Bandwidth Measurement
  • Occupied Bandwidth Troubleshooting
  • What 3GPP W-CDMA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator


PRACH Transmit On/Off Power Measurement Description

PRACH Transmit On/Off Power Measurement Description

  • How is a PRACH Transmit On/Off Power Measurement Made?
  • PRACH Transmit On/Off Power Measurement Parameters
  • PRACH Transmit On/Off Power Measurement Results
  • Key 3GPP Tests Performed Using the PRACH Transmit On/Off Power Measurement
  • Input Signal Requirements
  • Measurement Calibration

How is a PRACH Transmit On/Off Power Measurement Made?

Before initiating a PRACH transmit on/off measurement, turn the UE on and wait for it to camp to the test set's signal. When the PRACH transmit on/off power measurement is initiated, the test set sets Call Limit State to On to prevent successful call connection, then pages the UE. This forces the UE to transmit PRACH preamble bursts.

The test set then measures the "on" power of the first PRACH preamble burst from the UE. The test set measures the average power (without an RRC filter present) from 25 µs after the start of the PRACH access slot, to 25 µs before the end of the PRACH preamble burst (see Burst On Power Measurement Interval ).

Burst On Power Measurement Interval

The test set then measures the "off" power before and after a subsequent PRACH preamble burst ("Pre Burst Off Power" and "Post Burst Off Power," respectively). The test set measures the average power with an RRC filter in place (Root-Raised Cosine filter response with a roll off of alpha = 0.22 and a bandwidth equal to the chip rate). The Pre Burst Off Power is measured from 642 µs before the start of the PRACH access slot to 25 µs before the start of the PRACH access slot. The Post Burst Off Power is measured from 100 µs after the end of the PRACH preamble burst to 642 µs after the end of the PRACH preamble burst. (In order to prevent false "off" power measurements in the case where a compliant UE transmits power up to the limit of the +25 µs transient period, the start of the "off" power measurement period is delayed slightly to allow for recovery from receiver re-ranging.) See Burst Off Power Measurement Intervals .

Burst Off Power Measurement Intervals

The PRACH transmit on/off power measurement is triggered by a combination of RF rise and protocol. The test set must first receive an RF rise which is at least -45 dBm, and which is no more than 9 dB below the expected power ( Initial PRACH Tx Power if Power Control is set to Auto, or Manual Power if Power Control is set to Manual, see Receiver Control ). The test set then uses this RF rise to determine in which PRACH access slot the PRACH preamble burst is contained. The protocol trigger then triggers the measurement on that access slot.

Measurement Behavior

The UE must be camped to the test set and in idle mode before performing the PRACH Transmit On/Off Power measurement.

To perform the PRACH transmit on/off power measurement, you must set PRACH Preambles to at least 3. You must also set Available Subchannels (Bit Mask) to only allow one available subchannel. It is recommended that you set Call Limit State to Off before initiating this measurement (see Importance of Setting Call Limit State to Off before Initiating a PRACH Measurement ).

No other measurements can be running when a PRACH transmit on/off power measurement is performed. If any measurements are running when a PRACH transmit on/off power measurement is initiated, they are closed and a message is displayed to indicate that they were closed.

PRACH Transmit On/Off Power Measurement Parameters

  • Measurement Timeout: (see Measurement Timeouts )
  • Off Power Limit

    Sets the requirement (in dBm) for the measured "off" power ( Pre Burst Off Power and Post Burst Off Power ).

  • Open Loop Power Error Upper Limit

    Sets the upper limit (in dB) for the difference between the measured "on" power ( Burst On Power ) and the expected power ( Initial PRACH Tx Power if Power Control is set to Auto, or Manual Power if Power Control is set to Manual, see Receiver Control ).

  • Open Loop Power Error Lower Limit

    Sets the lower limit (in dB) for the difference between the measured "on" power ( Burst On Power ) and the expected power ( Initial PRACH Tx Power if Power Control is set to Auto, or Manual Power if Power Control is set to Manual, see Receiver Control ).

PRACH Transmit On/Off Power Measurement Results

  • Pre Burst Off Power

    This result returns the RRC filtered average "off" power (in dBm) before the PRACH preamble burst (see How is a PRACH Transmit On/Off Power Measurement Made? ); as well as pass or fail which indicates whether the power is below the requirement set by Off Power Limit .

  • Burst On Power

    This result returns the average "on" power (in dBm) (see How is a PRACH Transmit On/Off Power Measurement Made? ).

  • Open Loop Power Error

    This result returns the difference between the Burst On Power and the expected power based on open loop power control, as well as pass or fail which indicates whether the error is within the limits set by Open Loop Power Error Upper Limit and Open Loop Power Error Lower Limit .

  • Post Burst Off Power

    This result returns the RRC filtered average "off" power (in dBm) after the PRACH preamble burst (see How is a PRACH Transmit On/Off Power Measurement Made? ), as well as pass/fail, indicating whether the power is below the requirement set by Off Power Limit (see PRACH Transmit On/Off Power Measurement Parameters ).

Key 3GPP Tests Performed Using the PRACH Transmit On/Off Power Measurement

The "on" power measurement tests the open loop power control of the UE (3GPP TS 34.121, 5.4.1), while the "off" power measurement tests for unnecessary system signal leakage power (3GPP TS 34.121, 5.5). This measurement measures both the "on" power of the first PRACH preamble burst and the "off" power immediately prior to and just following any given PRACH preamble. It meets the requirements defined in 3GPP TS 34.121, section 5.5, Transmit ON/OFF Power and section 5.4.1, Open Loop Power Control in the Uplink . In order to prevent false "off" power measurements in the case where a compliant UE transmits power up to the limit of the +25 µs transient period, the start of the "off" power measurement period is delayed slightly to allow for recovery from receiver re-ranging.

Input Signal Requirements

  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, or from 1700 MHz to 1990 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of -45 dBm to +28 dBm for "on" power, and in the range of -61 dBm to -50 dBm for "off" power.

Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function ( CALibration:MEASurements? ) when the temperature has changed by more than ± 10° C since the last calibration. If this situation exists, the integrity indicator value becomes 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

  • Manual Operation: How Do I Make a PRACH Transmit On/Off Power Measurement?
  • Programming a PRACH Transmit On/Off Power Measurement
  • PRACH Transmit On/Off Power Troubleshooting
  • What 3GPP W-CDMA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Integrity Indicator


Swept Audio Measurement Description

Swept Audio Measurement Description

Description

How are swept audio measurements made?

Swept audio measurements synchronize the frequencies of the test set's audio generator and audio analyzer instruments to automatically make measurements at up to 60 frequency points. Audio level, SINAD, and distortion measurements can be performed at each measurement point in the sweep.

This measurement only generates and analyzes audio signals; no modulation of the RF generator, or demodulation by the receiver, is performed. A representation of this operation is shown below.

Swept Audio Measurements Block Diagram

To perform the swept audio measurements, you must route audio generator signal to the AUDIO OUT port (not the FM Demod signal). See Interactions with the Audio Analyzer and Audio Generator Instruments . The audio signal from the device under test is sent to the audio analyzer through the AUDIO IN ports.

The start and stop frequencies for the sweep define the frequency range. The user specifies the number of measurement points, which are evenly spaced through the specified frequency range.

Measurement settling time can be set to specify how long the audio signal is generated at each frequency before a measurement is made by the audio analyzer. This is used to account for settling time in the device being tested and any signal delay through the device. Increasing the settling time increases the sweep time.

If the 100 Hz BW bandpass filter is selected, the center frequency of the filter is synchronized to the audio generator and audio analyzer frequencies.

Typical applications include measuring the audio distortion of a mobile station across several frequencies and measuring the frequency response of an audio filter or amplifier.

This is not a measurement procedure specified in the EIA/TIA standards.

Operating Considerations

Front Panel Access

Swept Audio measurements are accessed manually by pressing the front-panel Instrument selection key.

Multi-measurement Use

When multi-measurements are used with the swept audio measurement, the AF analyzer makes the number of measurements specified at each point in the sweep. For example, if five measurement points are specified, and the multi-measurement count is set to 20, a total of 100 measurements are performed during the sweep.

Interactions with the Audio Analyzer and Audio Generator Instruments

To route Audio Generator signal to the front panel AUDIO OUT port, use the "SYSTem:AUDio:OUTPut:SOURce" command or press the System Config hardkey, then select Audio Out Port ( F1 ) on the System Config Screen (2 of 2).

The Swept Audio measurement and the Audio Analyzer instrument cannot be used at the same time to make audio measurements. If you enable either function while the other function is already enabled, the first function is turned off and a message is displayed that informs you of this situation.

Selecting the Swept Audio measurement will automatically adjust Audio Generator instrument settings. These settings will not be restored to their original values when the Swept Audio measurement is closed.

The amplitude of the Audio Generator instrument can be changed while the Swept Audio measurement is enabled. However, trying to change the Audio Generator instrument's frequency while using swept audio measurements is not allowed, and causes an error message to be displayed.

Specifying a Specific Measurement Frequency Point Within a Sweep

If you need to make sure that a measurement is performed at a specific frequency within the sweep, you can use the following algorithms to calculate the values to enter:

For example if you wanted to make a measurement at 1004 Hz (F) during a sweep of 15 points (P) that begins at 300 Hz (S) and ends after 3 kHz (Emin), the first algorithm tells you that 1004 Hz occurs at the fourth point in the sweep (n). Use the second algorithm to calculate the actual stop frequency (E) you would enter for that sweep (3585.333 Hz).

Related Topics

Programming a Swept Audio Measurement

Swept Audio Measurement Troubleshooting

Audio Analyzer Measurement Description

Audio Level Measurement Description

Distortion Measurement Description

SINAD Measurement Description


SINAD Measurement Description

SINAD Measurement Description

How is a SINAD measurement made?

SINAD is a receiver audio quality measurement that is typically used for mobile stations operating on an analog system, such as AMPS. It is the ratio of Signal+Noise+Distortion divided by Noise+Distortion, expressed in dB. SINAD is measured using the test set's Audio Analyzer. SINAD can be measured in the range of 100 Hz to 10 kHz. For information on using the Audio Analyzer, see Audio Analyzer Measurement Description .

The SINAD measurement is used to determine receiver RF sensitivity. SINAD is usually measured either of two ways:

  • Reduce the Cell Power from the test set until 12 dB SINAD is displayed (re-triggering for each measurement), or
  • Set the Cell Power from the test set to a specified low level and verify a 12 dB SINAD reading.

Difference in Agilent 8960 Series 10 and 8920B Test Set SINAD Measurements

If you have previously used the Agilent 8920B RF Communications Test Set to measure SINAD, you may notice that the Agilent 8960 Series 10 test set's SINAD value may be lower by up to 0.8 dB when measuring 12 dB SINAD. This is due to the more precise digital notch filter used by the 8960, causing a more accurate noise measurement to be made. The 8920B uses an analog filter that does not have as tight a filter notch as the 8960.

Related Topics

Programming a SINAD Measurement


Spectrum Monitor Description

Spectrum Monitor Description

How is the spectrum monitor (SMON) used?

The Spectrum Monitor (SMON) can be used to locate, identify and measure transmitted signals from a device under test. The Spectrum Monitor can be used while a call is in progress.

The Spectrum Monitor is intended to be used for indication only. The Spectrum Monitor does not have the same level accuracy specifications as other measurements provided by the test set, and should therefore not be used when parametric accuracy is required (for example, calibration of a mobile). It is recommended that you use the other wireless format-specific measurements when you require accurate parametric measurements.

The Spectrum Monitor has the following two modes of operation:

  • Swept mode, in which the X axis represents frequency , and the Y axis represents absolute amplitude.
  • Zero span mode, in which the X axis represents time and the Y axis represents absolute amplitude.

You can use the markers on the Spectrum Monitor's graphical display to set the expected frequency and power levels that are used by the test or lab application for parametric measurements.

The center frequency used by the Spectrum Monitor is initially set at the expected frequency maintained by the test set's base station emulator. The expected frequency range is 292.5 MHz to 2700 MHz.

The range of frequencies which the spectrum monitor is calibrated to measure is determined by the range of traffic band frequencies supported by the specific test or lab application that is currently running. For example, if you are using the GSM Test Application, any of the frequencies used by the GSM traffic bands are available for you to monitor accurately. You can view signals which fall outside of any of the frequencies used by GSM, but the Spectrum Monitor will not be calibrated.

From the test set's front panel, the Spectrum Monitor can be accessed by pressing the Instrument Selection key, then selecting Spectrum Monitor . If you require more details on manual operation of the Spectrum Monitor, see How Do I Use the Spectrum Monitor? .

Single or Multi-Measurements

The Spectrum Monitor can return either single or averaged results.

  • If you set the averaging state OFF then the trace represents a single measurement sweep.

  • If you set the averaging state ON, and the averaging count number to a value greater than one, then the trace represents the rolling average of the specified number of sweeps.

Input Signal Requirements

The Spectrum Monitor will complete and meet its accuracy specifications under the following input signal conditions.

  • The signal is within 40 dB of the reference level.
  • The measurement frequency is within the traffic band frequencies supported by the specific lab or test application that is currently running, and the expected frequency is tuned to the carrier.

Trigger Source

Triggering choices available for the Spectrum Monitor are Immediate, Protocol, RF Rise, and External.

For more information on measurement triggering, refer to Triggering of Measurements .

Calibrating the Spectrum Monitor

See Spectrum Monitor Calibration .

Related Topics

How Do I Use the Spectrum Monitor?


Spectrum Emission Mask Measurement Description

Spectrum Emission Mask Measurement Description

What is the spectrum emission mask?

The UE conformance specifications in 3GPP TS 34.121, Section 5.9 define a mask for out of channel emissions. This mask is defined relative to the in-channel power. The graphic below is an example of out-of-channel measurement results you might see on the test set. The spectrum emission mask for each of the four frequency bands is visible in green.

How is the spectrum emission mask measurement made?

In-channel power

The in-channel power is measured on the RF input signal which is filtered with a 3.84 MHz bandwidth Root-Raised Cosine (RRC) filter with a rolloff of alpha = 0.22.

Out-of-channel emissions

The out-of-channel emissions found in frequencies between 2.5 and 12.5 MHz away from the center channel frequency are determined in four symmetrical bands on each side of the carrier.

The emissions are measured with either a 30 kHz or 1 MHz bandwidth Gaussian measurement filter. The spectrum emission mask measurement's pass/fail limits for the 30 kHz bandwidth filter and 1 MHz bandwidth filter are settable. See Spectrum Emission Mask in E1963A for details of the spectrum emission mask measurement in the E1963A.

Spectrum Emission Mask in E1963A
 | Frequency Offset from carrier | Measurement Bandwidth | Resolution Bandwidth (RBW)
Range 1 | 2.5 - 3.5 MHz | 30 kHz | 10 kHz
Range 2 | 3.5 - 7.5 MHz | 1 MHz | 250 kHz
Range 3 | 7.5 - 8.5 MHz | 1 MHz | 250 kHz
Range 4 | 8.5 - 12.5 MHz | 1 MHz | 250 kHz

NOTE
The resolution bandwidth(RBW) may also be referred to as the measurement step size.

The compliance of Range 1 with the specified mask is determined using the following measurement procedure. A 30 kHz Gaussian measurement filter is centered 2.515 MHz away from the carrier frequency on both sides. The filter is shifted by 10 kHz for each measurement until the 30 kHz filter is centered at a 3.485 MHz offset from the carrier. This provides 98 measurement points on each side of the carrier for evaluating mask compliance.

The remaining frequency ranges are evaluated in the same manner. However, a 1 MHz Gaussian measurement filter is used and the resolution bandwidth is 250 kHz instead of 10 kHz. The measurements begin with the filter centered at 4 MHz and end with it centered at 12 MHz. This provides 33 unique measurement points on each side of the carrier for evaluating mask compliance. However, there are redundant points at 7.5 MHz and 8.5 MHz. Therefore, 35 measurement points are available when measurement results are queried via GPIB, while 33 points are visible on the test set's spectrum emission mask measurement graphic.

Spectrum Emission Mask Measurement Results

  • Pass/Fail for the overall spectrum emission mask. If any out-of-channel frequency range does not comply with the standard, the entire mask fails.
  • In-channel power
  • Pass/Fail for each of the four individual frequency ranges.
  • Power level vectors relative to in-channel power for each frequency range. These vectors contain the power measured at each frequency offset in the individual ranges. The value of each frequency offset is determined by the starting measurement position and the resolution bandwidth. For example, range 3 (7.5 MHz to 8.5 MHz) starts at 7.5 MHz and has a resolution bandwidth of 250 kHz. Therefore, relative power measurements are returned for offsets 7.5, 7.75, 8, 8.25, and 8.5 MHz from the carrier frequency.
  • Results for each frequency range. The relative power level and the frequency offset of the largest mask error, the margin of that error, and whether or not the range passed or failed the spectrum emission mask specifications are the available results.

Input Signal Requirements

  • For this measurement the test set's receiver uses autoranging to adjust for the level of the signal being measured; therefore the expected signal level does not need to be specified during measurement setup.
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, or from 1700 MHz to 1990 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of +5 dBm to +28 dBm, in a 3.84 MHz bandwidth.

Trigger Source

The trigger source defaults to Auto and tries to use protocol triggering if the UE is synchronized to the test set. Immediate triggering is used if the UE is not synchronized.

If you want to measure the spectrum emissions for a specific timeslot, use the trigger delay parameter. This measurement can be made over a period of 1 ms to 10 ms by altering the measurement interval parameter.

Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function ( CALibration:MEASurements? ) when the temperature has changed by ± 10° C or more since the last calibration. If this situation exists, the integrity indicator value becomes 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

  • Programming a Spectrum Emission Mask Measurement
  • Spectrum Emission Mask Troubleshooting
  • What 3GPP W-CDMA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator


What 3GPP W-CDMA Conformance Tests Are Supported?

What 3GPP W-CDMA Conformance Tests Are Supported?

Last updated: December 21, 2004

This table shows the standard tests as given in 3GPP TS 34.121. Shown are the W-CDMA applications' testing capabilities, as well as the measurements used to make the test.

Transmitter Characteristics
3GPP TS 34.121 | Test Description | Supported in Test Set? | Measurement
5.2 | Maximum Output Power | Yes | Thermal Power Measurement Description
5.3 | Frequency Error | Yes | Waveform Quality Measurement Description
5.4.1 | Open Loop Power Control in the Uplink | Yes | PRACH Transmit On/Off Power Measurement Description
5.4.2 | Inner Loop Power Control in the Uplink | Partially | Inner Loop Power Measurement Description (does not support 3 dB step size)
5.4.3 | Minimum Output Power | Yes | Channel Power Measurement Description (with RRC filter OFF)
5.4.4 | Out-of-synchronization handling of output power | Yes +, ** | Out-of-Synch Handling of Output Power Measurement Description (Establish a connection between the test set and UE, initiate the measurement from the test set, measure the UE's output power using the spectrum analyzer)
5.5.1 | Transmit OFF Power | Yes | PRACH Transmit On/Off Power Measurement Description
5.5.2 | Transmit ON/OFF Time mask | Yes | PRACH Transmit On/Off Power Measurement Description
5.6 | Change of TFC | Yes + | Change of TFC (Transport Format Combination) Measurement Description
5.7 | Power setting in uplink compressed mode | No |
5.8 | Occupied Bandwidth (OBW) | Yes | Occupied Bandwidth Measurement Description
5.9 | Spectrum Emission Mask | Yes | Spectrum Emission Mask Measurement Description
5.10 | Adjacent Channel Leakage Power Ratio (ACLR) | Yes | Adjacent Channel Leakage Ratio Measurement Description
5.11 | Spurious Emissions | Yes** | Camp to test set, measure spurious emissions using external spectrum analyzer
5.12 | Transmit Intermodulation | Yes* , ** | Camp to the test set, inject tones using external signal generator, measure transmit intermodulation using external spectrum analyzer
5.13.1 | Error Vector Magnitude (EVM) | Yes | Waveform Quality Measurement Description
5.13.2 | Peak code domain error | Partially | Waveform Quality Measurement Description (only for a single DPCH)
5.13.3 | UE Phase Discontinuity | Yes | Phase Discontinuity Measurement Description
5.13.4 | PRACH Preamble Quality | Partially + | PRACH Preamble Analysis Measurement Description (measurement is not performed on first preamble, AICH transmission timing is fixed to 0, measurement does not determine if correct access slot was used)
Receiver Characteristics
3GPP TS 34.121 | Test Description | Supported in Test Set? | Measurement
6.2 | Reference Sensitivity Level | Yes | Loopback Bit Error Ratio Measurement Description
6.3 | Maximum Input Level | Yes | Loopback Bit Error Ratio Measurement Description
6.4 | Adjacent Channel Selectivity (ACS) | Yes* | Loopback Bit Error Ratio Measurement Description (plus W-CDMA signal from a signal generator)
6.5 | Blocking Characteristics | Yes* | Loopback Bit Error Ratio Measurement Description (plus W-CDMA signal from a signal generator)
6.6 | Spurious Response | Yes* | Loopback Bit Error Ratio Measurement Description (plus a CW signal from a signal generator)
6.7 | Intermodulation Characteristics | Yes* | Loopback Bit Error Ratio Measurement Description (plus 2 CW signals from signal generators)
6.8 | Spurious Emissions | No |
Performance Requirements
3GPP TS 34.121 | Test Description | Supported in Test Set? | Measurement
7.2 | Demodulation in Static Propagation Conditions | Yes | Block Error Ratio Measurement Description
7.3 | Demodulation of DCH in Multi-Path Fading Propagation Conditions | Partially +, *** | Block Error Ratio Measurement Description (plus multi-path fading simulator and external AWGN noise source) (only for tests with phase reference = P-CPICH)
7.4 | Demodulation of DCH in Moving Propagation Conditions | Yes +, *** | Block Error Ratio Measurement Description (plus multi-path fading simulator and external AWGN noise source)
7.5 | Demodulation of DCH in Birth-Death Propagation Conditions | Yes +, *** | Block Error Ratio Measurement Description (plus multi-path fading simulator and external AWGN noise source)
7.6.1 | Demodulation of DCH in Open-Loop Transmit Diversity Mode | No |
7.6.2 | Demodulation of DCH in Closed Loop Transmit Diversity Mode | No |
7.6.3 | Demodulation of DCH in Site Selection Diversity Transmission Power Control Mode | No |
7.7.1 | Demodulation of DCH in Inter-Cell Soft Handover | Yes +, *** | Block Error Ratio Measurement Description (plus multi-path fading simulator and external AWGN noise source)
7.7.2 | Combining of TPC Commands from Radio Links of Different Radio Link Sets | No |
7.8.1 | Power Control in the Downlink, Constant BLER Target | No |
7.8.2 | Power Control in the Downlink, Initial Convergence | No |
7.8.3 | Power Control in the Downlink, Wind Up Effects | No |
7.9 | Downlink Compressed Mode | No |
7.10 | Blind Transport Format Detection | No |
7.11 | Demodulation of Paging Channel (PCH) | No |
7.12 | Detection of Acquisition Indicator (AI) | No |

+ This test is supported in the lab application only.

* Requires also an external signal generator, such as the E4438C ESG Vector Signal Generator.

** Requires also an external spectrum analyzer, such as the E4445A PSA Spectrum Analyzer.

*** Requires also a multi-path fading simulator and external AWGN source, such as the N5115A Fading Solution.


Thermal Power Measurement Description

Thermal Power Measurement Description

How is a thermal power measurement made?

Thermal power is a broadband, unfiltered measurement that measures all power present at the test set's RF IN/OUT connector using a thermal detector. Because of its high accuracy when measuring power up to +28 dBm, this is the preferred measurement to use for higher power measurements, such as the Maximum Output Power test (3GPP TS 34.121, section 5.2, v3.2.0).

The 3GPP standard specifies that this measurement be made over at least 1 timeslot (667 µs). The implementation of this measurement in the test set measures over 10 ms with the UE in power control algorithm 2.

The thermal power measurement automatically zeroes itself for each measurement; no other calibration is required. To meet specified performance, the test set must be operated in the temperature range of 20° C to 55° C.

The thermal power measurement is not as fast as the channel power measurement, and is not intended to measure signal levels below -10 dBm. Use the channel power measurement to measure power levels from -11 dBm to -61 dBm, or when maximum measurement speed is required. See Channel Power Measurement Description .

Differences in Thermal Power and Channel Power Measurement Results

Because the thermal power measurement is an unfiltered measurement, its results are typically about 0.25 dB higher than the filtered channel power measurement results.

Input Signal Requirements

  • For this measurement the test set's receiver uses auto-ranging to adjust for the level of the signal being measured; therefore the expected signal level does not need to be specified during measurement setup.
  • For specified accuracy, the frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, or 1700 MHz to 1990 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of -10 dBm to +28 dBm for greatest accuracy (although signals can be measured down to -20 dBm with degraded accuracy).
  • This measurement is unfiltered, so all signals present at the RF IN/OUT connector affect the measurement results.

Trigger Source

No synchronization between the test set and the mobile station (UE) is needed, so immediate triggering is always used for this measurement. No trigger delay is available.

Related Topics

Programming a Thermal Power Measurement

Thermal Power Troubleshooting

Statistical Measurement Results

Triggering of Measurements

What 3GPP W-CDMA Conformance Tests Are Supported?


Block Error Ratio Measurement Description

Block Error Ratio Measurement Description

  • How is a Block Error Ratio Measurement Made?
  • Block Error Ratio Measurement Parameters
  • Block Error Ratio Measurement Results
  • Block Error Ratio Input Signal Requirements

How is a Block Error Ratio Measurement Made?

3GPP TS 34.121, F.6.1.1 defines block error ratio (BLER) as follows: "A Block Error Ratio is defined as the ratio of the number of erroneous blocks received to the total number of blocks sent. An erroneous block is defined as a Transport Block, the cyclic redundancy check (CRC) of which is wrong."

To perform a block error ratio measurement, you must be on a Radio Bearer Test Mode call. The block error ratio measurement can be performed for both Symmetrical RMCs and Asymmetrical RMCs .

Symmetrical RMCs

For Symmetrical RMCs (which use Transparent Mode (TM) RLC entities on the DTCH), the test set measures block error ratio by sending data and CRC bits in the downlink transport blocks to a UE that is configured in loopback mode 2 ( UE Loopback Type must be set to Type 2 ). The UE then loops the data bits and CRC bits from the downlink transport blocks into the uplink transport blocks and transmits them in the uplink. The test set then generates a CRC from the data bits received in the uplink transport block and compares this calculated CRC against the CRC received in the uplink transport block (this CRC is the downlink CRC for the downlink transport block, looped back up by the UE). If the CRCs do not match, the transport block is defined to be a "block error."

To perform the block error ratio measurement for symmetrical RMCs, Uplink DTCH RMC CRC Presence must be set to Used for Data . This disables the uplink CRC, to allow room for the UE to loop back the downlink CRC for each block (there are an equal number of available bits in the uplink and downlink, if the UE were to transmit an uplink CRC, it would not be able to loop back the downlink CRC).

The block error ratio measurement can not be performed on the 33k No Coding RMC .

Asymmetrical RMCs

For Asymmetrical RMCs (which use Acknowledged Mode (AM) RLC entities on the DTCH), the test set increments the Block Error Count when it receives a retransmission request from the UE. (The UE generates a CRC from the data bits received in the downlink transport block, and compares this calculated CRC against the CRC received in the downlink transport block. If the CRCs do not match, the UE sends a retransmission request to the test set.)

UE Control During FDD Test Mode Operation

The FDD Test Operating Mode does not provide radio bearer setup control of the UE for test mode operation. You must configure the UE in loopback mode 2 and synchronize it to the test set's downlink signal in order to make this measurement in FDD test operating mode.

The uplink transport format must include both the DTCH and the DCCH; however, only the DTCH information is used for the block error ratio measurement.

Note that Asymmetrical RMCs are not available in FDD test operating mode.

Block Error Ratio Measurement Parameters

  • Number of Blocks to Test

    Sets the number of blocks to test during the measurement.

    You may set the number of blocks to test during the measurement. However, for Asymmetrical RMCs , the actual number of Blocks Tested may be greater than the Number of Blocks to Test . Every 200 ms the UE indicates to the test set whether the blocks received in the last 200 ms period were received correctly or if any retransmissions are required. Depending upon the alignment of this 200 ms measurement period with the TTI boundary, and depending upon how many blocks are sent every 200 ms (based on data rate), it is quite likely that the UE will provide acknowledgment/retransmission information for more blocks than requested by the Number of Blocks to Test . These extra blocks are included in the Blocks Tested , Block Error Ratio and Block Error Count results.

  • Trigger Arm - see Trigger Arm (Single or Continuous) Description .
  • Measurement Timeout

    See Measurement Timeouts .

  • Uplink DTCH RMC CRC Presence
  • UE Loopback Type

The trigger source for this measurement is always protocol-based (see Trigger Source Description ).

Block Error Ratio Measurement Results

  • Integrity Indicator
  • Block Error Ratio

    The ratio of incorrectly received blocks to the total blocks sent to the UE, expressed as a percentage (%).

  • Block Error Count

    The number of incorrectly received blocks, or "block errors".

  • Blocks Tested

    Number of blocks tested to determine the Block Error Ratio and Block Error Count results.

  • Uplink Missing Blocks

    The UE sends a TFCI for each uplink DTCH transport block. When operating in Active Cell Operating Mode , the test set monitors the uplink TFCI, and can report uplink missing blocks. For Symmetrical RMCs , if the TFCI indicates that there is no data block sent for that TTI, the test set reports a missing block. When an uplink missing block occurs, no block comparison is done on the block, and the number of Blocks Tested is not incremented. The test set returns a Questionable MS-to-Cell Data Integrity Indicator .

    The Uplink Missing Blocks result does not apply to Asymmetrical RMCs , because data is not returned on the uplink, only periodic status reports.

    When in FDD Test Operating Mode , the test set does not monitor the uplink TFCI; rather, it assumes that a data block is sent in every TTI. Thus, errors resulting from uplink missing blocks are included in the Block Error Count result when in FDD test operating mode.

Block Error Ratio Input Signal Requirements

  • The expected power into the test set must be set in order to maintain the link with the UE. This is done using the MS Target Power setting or by using manual receiver power control and specifying the expected power level. See Receiver Control .

Related Topics

Manual Operation: How Do I Perform a Block Error Ratio (BLER) Measurement?

Programming a Block Error Ratio Measurement

Block Error Ratio Troubleshooting

Radio Bearer Test Mode Setup

Loopback Bit Error Ratio Measurement Description

What 3GPP W-CDMA Conformance Tests Are Supported?


Change of TFC (Transport Format Combination) Measurement Description

Change of TFC (Transport Format Combination) Measurement Description

Last updated: December 21, 2004

This section is only applicable to the lab application.

  • How is a Change of TFC Measurement Made?
  • Change of TFC Measurement Parameters
  • Change of TFC Measurement Results
  • Change of TFC Measurement Input Signal Requirements
  • Change of TFC Measurement Calibration

How is a Change of TFC Measurement Made?

When a UE changes its TFC, it must change its output power in accordance with any resulting change in data rate. The 3GPP TS 34.121 5.6 Change of TFC test addresses the case of an uplink 12.2k RMC operating in DTX (Discontinuous Transmission) mode, wherein the DPDCH is periodically turned off. The test confirms that the UE's output power level changes properly when its DPDCH is turned off.

The change of TFC measurement requires an RB Test Mode connection between the test set and UE, in either loopback mode 1 or 2. When the measurement is initiated, the test set stops sending a constant stream of data (to be looped back by the UE), and instead sends a block of data, then a block of no data, repeatedly. This causes the UE to turn its DPDCH on and off on a block-by-block basis. The test set monitors the uplink TFCI and the change of TFC measurement is triggered when the TFCI indicates no data is present on the DPDCH (the DPDCH is thus off for that block). The test set then measures the mean power in the timeslot before and after the transition from DPDCH on to DPDCH off, and before and after the transition from DPDCH off to DPDCH on. The power measurements do not include the transient periods of 25 us on either side of the timeslot boundaries. Thus, the measurement interval is 2368 chips, or 617 us. The measurement then reports the step change in power ( [image] P as described in 3GPP TS 34.121 5.6) for both transitions (see Step Down Relative Power (in dB) and Step Up Relative Power (in dB) ).

3GPP TS 34.121 5.6.2 Transmit template during DTX

Required Initial Conditions

Before performing the change of TFC measurement, you must:

  • Set Operating Mode to Active Cell Operating Mode .
  • Establish a Radio Bearer Test Mode connection.
  • Set Uplink Dummy DCCH Data to Off .
  • Ensure that the initial output level of your UE is such that its output power level with DPDCH on and off falls within the measurement's required input level (see Change of TFC Measurement Input Signal Requirements ).

Recommended Initial Conditions

The following settings are recommended based on the 3GPP TS 34.121 5.6 requirements:

  • UE Target Power = 0 dBm .
  • UL CL Power Control Mode = Alternating bits .
  • UL CL Power Ctrl Algorithm = Two .
  • Uplink DPCH Bc/Bd Control = Auto . This ensures that [image] and [image] are (automatically) set to the values specified by the standards (for example, 0.5333 and 1.0 for 12.2k RMC).

No other measurements can be running when a change of TFC measurement is performed. If any measurements are running when a change of TFC measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while a change of TFC measurement is running, the change of TFC measurement is closed and a message is displayed.

Change of TFC Measurement Parameters

  • Multi-Measurement Count

    See Statistical Measurement Results . When multi-measurement count is on, the test set measures the mean power in the timeslot before and after the transition from DPDCH on to DPDCH off, and before and after the transition from DPDCH off to DPDCH on, and then repeats for the next available DPDCH on/off/on transition until the requested number of samples has been taken.

  • Measurement Timeout

    See Measurement Timeouts .

The following four parameters can be independently set for the 12.2k RMC, 33k No Coding RMC, 64k RMC, 144k RMC and 384k RMCs:

  • Step Down Size

    You can specify the expected step down change in power for each RMC. Step Down Pass/Fail is determined using this Step Down Size setting and the Step Error Limit: Upper and Step Error Limit: Lower settings.

  • Step Up Size

    You can specify the expected step up change in power for each RMC. Step Up Pass/Fail is determined using this Step Up Size setting and the Step Error Limit: Upper and Step Error Limit: Lower settings.

  • Step Error Limit: Upper

    You can specify the upper limit for the difference between the expected Step Down Size or Step Up Size and the measured step change in power for each RMC. Step Down Pass/Fail and Step Up Pass/Fail are determined using this Step Error Limit: Upper setting and the Step Error Limit: Lower setting.

  • Step Error Limit: Lower

    You can specify the lower limit for the difference between the expected Step Down Size or Step Up Size and the measured step change in power for each RMC. Step Down Pass/Fail and Step Up Pass/Fail are determined using the Step Error Limit: Upper setting and this Step Error Limit: Lower setting.

Change of TFC Measurement Results

  • Step Down Relative Power (in dB)

    The Step Down Relative Power is the mean power while the DPDCH is off minus the mean power while the DPDCH is on, for an on-to-off transition.

  • Step Down Error (in dB)

    The Step Down Error is the difference between the measured Step Down Relative Power (in dB) and the Step Down Size setting. If Multi-Measurement Count is on, the error of the greatest magnitude is reported.

  • Step Down Pass/Fail

    Fail is returned if Step Down Error (in dB) is greater than Step Error Limit: Upper or less than Step Error Limit: Lower .

    Pass is returned if Step Down Error (in dB) is less than or equal to Step Error Limit: Upper and greater than or equal to Step Error Limit: Lower .

  • Step Up Relative Power (in dB)

    The Step Up Relative Power is the mean power while the DPDCH is on minus the mean power while the DPDCH is off, for an off-to-on transition.

  • Step Up Error (in dB)

    The Step Up Error is the difference between the measured Step Up Relative Power (in dB) and the Step Up Size setting. If Multi-Measurement Count is on, the error of the greatest magnitude is reported.

  • Step Up Pass/Fail

    Fail is returned if Step Up Error (in dB) is greater than Step Error Limit: Upper or less than Step Error Limit: Lower .

    Pass is returned if Step Up Error (in dB) is less than or equal to Step Error Limit: Upper and greater than or equal to Step Error Limit: Lower .

Change of TFC Measurement Input Signal Requirements

  • Frequency: 800 to 1000 MHz, 1700 to 1990 MHz.
  • Input level: -61 dBm to +28 dBm.
  • Step change in power when transitioning between DPDCH off and on states must not exceed 15 dB.

Change of TFC Measurement Calibration

You must calibrate this measurement using the measurement calibration procedure (see Calibrating the Test Set ).

Related Topics

Manual Operation: How Do I Make a Change of TFC (Transport Format Combination) Measurement?

Programming a Change of TFC (Transport Format Combination) Measurement

Change of TFC (Transport Format Combination) Troubleshooting

What 3GPP W-CDMA Conformance Tests Are Supported?

Triggering of Measurements

Integrity Indicator


Dynamic Power Analysis Measurement Description

Dynamic Power Analysis Measurement Description

  • How is a Dynamic Power Analysis Measurement Made?
  • Dynamic Power Analysis Measurement Parameters
  • Dynamic Power Analysis Measurement Results
  • Dynamic Power Analysis Measurement Input Signal Requirements
  • Dynamic Power Analysis Measurement Calibration

How is a Dynamic Power Analysis Measurement Made?

The dynamic power analysis measurement aids in power calibration of your UE. The measurement is not performed with a call established between the test set and UE. Rather, you must place your UE into a test mode which forces it to transmit the power sequence you desire to test, and then analyze the resulting UE output power using the test set.

The UE's power sequence may or may not include trigger pulses (to aid in triggering the test set). The power sequence may step up or down, and may have varying power step sizes. You must specify the number of steps in your sequence and their duration using the Steps and Step Length settings.

Example UE Power Sequence (No Trigger Pulses)

The test set autoranges the dynamic power analysis measurement. To assist in this autoranging, the UE must transmit its power sequence continuously until a measurement result for the power sequence is returned by the test set. The first time the power sequence is transmitted, the test set attempts to autorange by looking at one complete UE power sequence, determining the maximum power that will be transmitted during the sequence and adjusting its receiver accordingly. To ensure proper autoranging, it is important that you set Steps equal or greater than the number of steps in your UE's power sequence so that the entire power sequence is evaluated during the autoranging. If autoranging is successful, the test set then attempts to trigger on the power sequence and measure the average power of each step.

The test set includes a flexible RF rise trigger which you must configure to allow the test set to properly trigger on your UE's power sequence (see Specifying the Measurement Triggering ).

The dynamic power analysis measurement measures the absolute power at each step, averaged over the measurement interval set by Measurement Interval , at the position determined by Trigger Delay , and either with or without the RRC (Root Raised Cosine) filter in place (see RRC Filter ).

The UE's signal may or may not be modulated with an uplink DPCH signal. If the signal is not modulated with an uplink DPCH signal and is offset in frequency from the expected measurement frequency, you may need to use the Frequency Offset setting to ensure the most accurate power measurements possible.

You can perform the dynamic power analysis measurement in Active Cell Operating Mode and FDD Test Operating Mode . However, since this measurement does not utilize any overhead signalling to control the UE's power or frequency, you must manually set the test set's Expected Power and Measurement Receiver Frequency in either operating mode.

Dynamic Power Analysis Measurement Parameters

Specifying the Measurement Duration for the Power Sequence

  • Steps

    You must specify the total number of steps to be measured. Note, the number of steps to measure must include any trigger pulses or separation steps included in the UE's power sequence. It is important that you set Steps equal or greater than the number of steps in your UE's power sequence so that the entire power sequence is evaluated during autoranging of the measurement (see How is a Dynamic Power Analysis Measurement Made? ).

    The time duration of one step is determined by Step Length . If Step Length is set to 666.666... us, then the number of Steps to measure is equivalent to the number of timeslots to measure.

  • Step Length

    This setting specifies the time duration of one step in the UE's power sequence (in seconds). Each step in the power sequence must be identical in length. See Example UE Power Sequence (No Trigger Pulses) .

    Step Length must be greater than or equal to Measurement Interval .

The product of Steps and Step Length must not exceed 58.260 ms.

Specifying the Measurement Characteristics for Each Step

  • Measurement Interval

    When measuring the average power of each step, you can specify how long a period of time over which to average the power for each step using the Measurement Interval setting. This setting is applied to the measurement of every step.

    Measurement Interval must be less than or equal to Step Length .

  • Trigger Delay

    When measuring the average power of each step, you can specify how long a period of time over which to average the power for each step using the Measurement Interval setting, and then place the measurement interval at the desired position within the step's duration in time using the Trigger Delay setting. In other words, the Trigger Delay setting specifies the how long after the start of the power sequence step the power measurement should begin. This setting is applied to the measurement of every step.

    For example, the default settings of Step Length = 666.7 us , Measurement Interval = 300 us and Trigger Delay = 183.3 us cause the test set to measure power for 300 us centered in the middle of the step:

    Example Step Length, Measurement Interval and Trigger Delay Settings
  • RRC Filter

    You may choose to measure the average power of each step with or without the RRC (Root Raised Cosine) filter in place. The RRC filter has an alpha of 0.22 and a bandwidth equal to the chip rate of 3.84 MHz.

  • Frequency Offset

    If you are testing a UE signal that is shifted in frequency from the expected Measurement Receiver Frequency , you must set the Frequency Offset setting accordingly, to allow for the most accurate power measurements possible.

Specifying the Measurement Triggering

  • Trigger Source

    You may set Trigger Source to RF Rise or External (see Trigger Source Description ). If Trigger Source is set to RF Rise, you may characterize the trigger using the parameters described below.

    NOTE
    When Trigger Source is set to RF Rise , it is highly recommended that you use trigger qualification for robust triggering (see Trigger Qualification State ).

  • RF Rise Trigger Threshold

    When Trigger Source is set to RF Rise , you must set the RF Rise Trigger Threshold to the power level (in dBm) at which you want the measurement to trigger. When the power of the UE's signal rises above the RF Rise Trigger Threshold level, the measurement is triggered.

    The test set assumes a crest factor of 3.1 dB for the signal (as is typical for an uplink DPCH signal relative to a CW signal) and thus actually triggers when the input signal reaches the RF Rise Trigger Threshold level plus 3.1 dB. If the UE's signal has a crest factor other than 3.1 dB, you must set the RF Rise Trigger Threshold level accordingly.

    RF Rise Trigger Threshold must be set to within 0 dB to -25 dB of the Expected Power .

    This setting is only available when Trigger Source is set to RF Rise .

  • Trigger Qualification State

    For complex UE power sequences, you may choose to further define the measurement trigger using trigger qualification. Instead of the measurement triggering when the UE's signal simply rises above the RF Rise Trigger Threshold value, you can specify that the UE's signal must meet some additional criteria as well before the measurement is triggered. See Trigger Qualification Type below.

    This setting is only available when Trigger Source is set to RF Rise .

  • Trigger Qualification Type
    • RF Rise : If you choose a Trigger Qualification Type of RF Rise , then the measurement will not trigger unless the UE's signal rises above the RF Rise Trigger Threshold value AND crosses this level with a positive change in power equal to or greater than the Trigger Qualification Rise Threshold . For example, if RF Rise Trigger Threshold is set to 0 dBm and Trigger Qualification Rise Threshold is set to 10 dB , then the measurement will not trigger until the UE's signal rises above 0 dBm AND increases in power by at least 10 dB within the qualification interval. The qualification interval is one Step Length before the transition across the RF Rise Trigger Threshold and one Step Length after the transition. (The power measurements performed in the qualification interval are performed according to the Measurement Interval , Trigger Delay , and RRC Filter settings, see Specifying the Measurement Characteristics for Each Step ).
      Example Trigger Scenarios with Trigger Qualification Type Set to RF Rise
    • RF Fall : If you choose a Trigger Qualification Type of RF Fall , then the measurement will not trigger unless the UE's signal rises above the RF Rise Trigger Threshold value AND then exhibits a negative change in power equal to or greater than the Trigger Qualification Fall Threshold during the qualification interval. The qualification interval is the two Step Lengths immediately after the transition across the RF Rise Trigger Threshold .
    • RF Rise and Fall : If you choose a Trigger Qualification Type of RF Rise and Fall , then the measurement will not trigger unless the UE's signal rises above the RF Rise Trigger Threshold value AND crosses this level with a positive change in power equal to or greater than the Trigger Qualification Rise Threshold AND then exhibits a negative change in power equal to or greater than the Trigger Qualification Fall Threshold . In other words, both requirements of a Trigger Qualification Type of RF Rise and RF Fall as explained above must be met

    No matter which type is chosen for the Trigger Qualification Type , if the requirements are met, then the measurement will trigger at the point at which the RF Rise Trigger Threshold was crossed.

    This setting is only available when Trigger Qualification State is set to On .

  • Trigger Qualification Rise Threshold

    This setting specifies the positive change in power that must occur for the measurement to trigger when the RF Rise Trigger Threshold is crossed, when Trigger Qualification Type is set to RF Rise or RF Rise and Fall .

  • Trigger Qualification Fall Threshold

    This setting specifies the negative change in power that must occur for the measurement to trigger when the RF Rise Trigger Threshold is crossed, when Trigger Qualification Type is set to RF Fall or RF Rise and Fall .

Other Measurement Parameters

  • Trigger Arm (see Trigger Arm (Single or Continuous) Description )
  • Measurement Timeout (see Measurement Timeouts )

Dynamic Power Analysis Measurement Results

  • Integrity Indicator (see Integrity Indicator )
  • Number of Steps Measured

    You can query the number of steps measured using the FETCh:WDPAnalysis commands. The number of steps measured is also displayed on the front panel graphical display (see How Do I Make a Dynamic Power Analysis Measurement? ).

    The number of steps measured is determined by the Steps setting.

  • Average Power for Each Step (in dBm)

    Once the dynamic power analysis measurement has autoranged and triggered on the UE's power sequence, the test set then measures the average power for each step in the sequence as specified by the Measurement Interval , Trigger Delay , and RRC Filter settings. (See Specifying the Measurement Characteristics for Each Step .)

    You can retrieve the average power measured for each step using the FETCh:WDPAnalysis commands or from the front panel (see How Do I Make a Dynamic Power Analysis Measurement? ).

A typical measurement result is shown below:

Dynamic Power Analysis Measurement Input Signal Requirements

The dynamic power analysis measurement can measure power between -61 dBm and +28 dBm.

The dynamic range for any one measurement is approximately 25 dB (the UE's power may not vary by more than ~25 dB in a single power sequence).

Dynamic Power Analysis Measurement Calibration

You must calibrate the dynamic power analysis measurement using the measurement calibration procedure (see Calibrating the Test Set ).

Related Topics

Manual Operation: How Do I Make a Dynamic Power Analysis Measurement?

Programming the Dynamic Power Analysis Measurement

Dynamic Power Analysis Troubleshooting

What 3GPP W-CDMA Conformance Tests Are Supported?

Triggering of Measurements

Integrity Indicator


Waveform Quality Measurement Description

Waveform Quality Measurement Description

How is a waveform quality measurement made?

This measurement compares the received signal's IQ modulation characteristics to an ideal signal. Waveform quality provides the following measurement results: error vector magnitude (EVM), frequency error, origin offset, phase error, magnitude error, timing error, peak code domain error, and bc and bd1-6. (bc and bd1-6 are available through GPIB query only.)

The frequency error result satisfies the requirements for 3GPP TS 34.121, section 5.3, v3.0.1, Frequency Error . The error vector magnitude result satisfies the requirements for 3GPP TS 34.121, section 5.13.1, v3.0.1, Error Vector Magnitude . Waveform quality conforms to the method of test for EVM and Peak Code Domain Error defined under Transmit Modulation (section 5.13) with the following exception: Peak Code Domain Error (section 5.13.2) specifies the use of the 768 kbps RMC which supports multiple DPDCHs. The peak code domain error (PCDE) is to be determined by projecting the error vector power onto the code domain at the maximum spreading factor, which is 4 for the 768 kbps RMC. The test set doesn't yet support the 768 kbps RMC, so the PCDE is computed by projecting the error vector power onto the code domain at the spreading factor equal to the DPDCH. Therefore, the PCDE for the 12.2 kbps RMC is determined uses a spreading factor of 64 while the PCDE for the 64 kbps RMC is calculated using a spreading factor of 16.

The measurement is made during one user-selected timeslot.

Input Signal Requirements

  • For this measurement the test set's receiver uses auto-ranging to adjust for the level of the signal being measured; therefore the expected signal level does not need to be specified during measurement setup.
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, or from 1700 MHz to 1990 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of -25 dBm to +28 dBm, in a 3.84 MHz bandwidth.
  • Maximum measurable EVM = 35%
  • Maximum measurable frequency error = ± 1 kHz

Trigger Source

Triggering choices for the Waveform Quality measurement are immediate, protocol, external, and auto. Auto triggering is the default choice. In most cases, auto triggering provides the optimum measurement triggering condition for the Waveform Quality measurement. For example, if the UE is synchronized to the test set, protocol triggering is used. Immediate triggering is used if the UE is not synchronized.

When immediate triggering is used, the measurement result returned for timing error is always NAN (Not a Number) because it is not possible to evaluate a timing error in this measurement situation.

The measurement is performed during one timeslot. The timeslot to use for the measurement is selectable (0 to 14).

Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function ( CALibration:MEASurements? ) when the temperature has changed by ± 10° C or more since the last calibration. If this situation exists, the integrity indicator value becomes 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

  • Programming a Waveform Quality Measurement
  • Waveform Quality Troubleshooting
  • What 3GPP W-CDMA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator


Out-of-Synch Handling of Output Power Measurement Description

Out-of-Synch Handling of Output Power Measurement Description

Last updated: December 21, 2004

This section is only applicable to the lab application.

  • How is an Out-of-Synch Handling of Output Power Measurement Made?
  • Out-of-Synch Handling of Output Power Measurement Parameters
  • Out-of-Synch Handling of Output Power Measurement Results
  • Key 3GPP Tests Performed Using the Out-of-Synch Handling of Output Power Measurement

How is an Out-of-Synch Handling of Output Power Measurement Made?

Out-of-synchronization handling of output power measures the UE's ability to monitor the downlink DPCCH quality and turn its transmitter on or off based on the quality level.

3GPP TS 34.121 5.4.4.2 states: "When the UE estimates the DPCCH quality over the last 160 ms period to be worse than a threshold Qout, the UE shall shut its transmitter off within 40 ms. The UE shall not turn its transmitter on again until the DPCCH quality exceeds an acceptable level Qin. When the UE estimates the DPCCH quality over the last 160 ms period to be better than a threshold Qin, the UE shall again turn its transmitter on within 40 ms."

"The UE shall not shut its transmitter off before point B. The UE shall shut its transmitter off before point C, which is Toff = 200 ms after point B. The UE shall not turn its transmitter on between points C and E. The UE shall turn its transmitter on before point F, which is Ton = 200 ms after point E."

The UE's transmitter is considered to be "off" if the transmitted power is below -55 dBm and "on" if the transmitted power is above -49 dBm.

3GPP TS 34.121 Figure 5.4.4.1 Test case for out-of-synch handling in the UE

The Out-of-Synch Handling of Output Power measurement allows you to specify the time intervals and DPCCH_Ec/Ior levels between points A and F (see Out-of-Synch Handling of Output Power Measurement Parameters ). When the measurement is initiated, the test set varies its DPCCH level according to these settings. You must then measure the UE's power response using an external spectrum analyzer to determine if the UE turned its power off and on as required (see Out-of-Synch Handling of Output Power Measurement Results ).

Required Initial Conditions

Before performing the out-of-synch measurement, you must:

  • Connect the test set's rear panel TRIG OUT port to the TRIGGER IN port of an external spectrum analyzer (the external spectrum analyzer is required to measure the UE's output power and obtain measurement results, see Out-of-Synch Handling of Output Power Measurement Results ).
  • Connect the UE to the test set's RF IN/OUT port and to the spectrum analyzer's RF INPUT port via an RF splitter, and specify the loss due to the RF splitter in both the test set and the spectrum analyzer.
  • Set Trigger Output Setup to Measurement Generated .
  • Establish a Radio Bearer Test Mode connection (3GPP TS 34.121 5.4.4 specifies a 12.2k RMC connection).

Recommended Initial Conditions

The following settings are recommended based on the 3GPP TS 34.121 5.4.4 requirements. Note that some of these parameters must be set before establishing a connection.

  • Set Connected DL Channel Levels as specified by 3GPP TS 34.121 Table E.3.3 and Table 5.4.4.3:
    • Cell 1 Connected CPICH Level = -10.00 dB .
    • Cell 1 Connected P-CCPCH/SCH Level = -12.00 dB .
    • Cell 1 Connected S-CCPCH Level = Off .
    • Cell 1 Connected PICH Level = -15.00 dB .
    • Cell 1 Connected DPCH Level = -16.60 dB . (This sets DPCCH_Ec/Ior before point A to -16.6 dB, because PO1 = PO2 = PO3 = 0, which makes DPCH_Ec/Ior = DPCCH_Ec/Ior).

    See Setting Downlink Channel Levels .

  • Set (T313 + N313*10 ms) > (Ta-b + 200 ms + Tc-d + Td-e + N315*10 ms) to ensure that the UE will not drop the call when the measurement in initiated (see UE Timers and Out-of-Synch Handling of Output Power Measurement Parameters for more information on these settings). The UE may drop the call if the UE timers specify a drop time that is less than the time that the test set's DPCCH_Ec/Ior value is low, plus the time required for the UE to receive N315 "in sync" indicators. 3GPP TS 34.121 Table 5.4.4.2A specifies a value of 15 s for T313 and a value of 200 for N313.
  • Leave the Out-of-Synch Handling of Output Power Measurement Parameters set to their default values, (which correspond to 3GPP TS 34.121 section 5.4.4.2, 5.4.4.4.2 and Table 5.4.4.3):
    • Segment Ta-b Interval = 5.000 s
    • Segment Tc-d Interval = 5.000 s
    • Segment Td-e Interval = 5.000 s
    • DPCCH Quality Ratio Qa-b = -21.60
    • DPCCH Quality Ratio Qb-d = -28.40
    • DPCCH Quality Ratio Qd-e = -24.40
    • DPCCH Quality Ratio Qe+ = -17.60
  • Set UE Target Power to the maximum output power for your UE and set UL CL Power Control Mode to All Up bits .
  • Set Cell Power ( F7 on the Call Parms 1 of 3 menu) to -61 dBm .
  • Select Generator Info ( F3 on the Call Control 2 of 4 menu) and set AWGN Power ( F5 ) to -60 dBm.

No other measurements can be running when an out-of-synch handling of output power measurement is performed. If any measurements are running when an out-of-synch handling of output power measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while an out-of-synch handling of output power measurement is running, the out-of-synch handling of output power measurement is closed and a message is displayed.

FDD Test Mode Operating Considerations

The out-of-synch handling of output power measurement can be performed while in FDD Test Operating Mode , however you must configure the UE such that its output power will respond appropriately to the changes in the test set's DPCCH_Ec/Ior.

Out-of-Synch Handling of Output Power Measurement Parameters

See 3GPP TS 34.121 Figure 5.4.4.1 Test case for out-of-synch handling in the UE for a definition of points A - F.

  • Segment Ta-b Interval

    Time between points A and B. The test set's DPCCH_Ec/Ior is set to DPCCH Quality Ratio Qa-b for the time Segment Ta-b Interval .

  • Segment Tc-d Interval

    Time between points C and D. The test set's DPCCH_Ec/Ior is set to DPCCH Quality Ratio Qb-d for 200 ms plus Segment Tc-d Interval (because Tb-c = Toff = 200 ms).

  • Segment Td-e Interval

    Time between points D and E. The test set's DPCCH_Ec/Ior is set to DPCCH Quality Ratio Qd-e for the time Segment Td-e Interval .

  • DPCCH Quality Ratio Qa-b

    DPCCH_Ec/Ior between points A and B. (Note: the DPCCH quality ratio before point A is determined by the value that Cell 1 Connected DPCH Level is set to before the measurement is initiated, see Setting Downlink Channel Levels .)

  • DPCCH Quality Ratio Qb-d

    DPCCH_Ec/Ior between points B and D.

  • DPCCH Quality Ratio Qd-e

    DPCCH_Ec/Ior between points D and E.

  • DPCCH Quality Ratio Qe+

    DPCCH_Ec/Ior after point E.

  • Measurement Timeout: see Measurement Timeouts .

Out-of-Synch Handling of Output Power Measurement Results

The Out-of-Synch Handling of Output Power measurement does not return any measurement results at this time. Initiating the measurement only causes the test set to change its DPCCH_Ec/Ior as specified by the Out-of-Synch Handling of Output Power Measurement Parameters . You must use an external spectrum analyzer to measure the UE's resulting output power. When the Out-of-Synch Handling of Output Power measurement is initiated from the test set, the test set generates a trigger at point A that you can route to the test set's rear panel TRIG OUT connector using the Trigger Output Setup setting, to trigger the spectrum analyzer. See How Do I Make an Out-of-Synch Handling of Output Power Measurement? .

Key 3GPP Tests Performed Using the Out-of-Synch Handling of Output Power Measurement

3GPP TS 34.121 5.4.4 Out-of-synchronisation handling of output power.

Related Topics

Manual Operation: How Do I Make an Out-of-Synch Handling of Output Power Measurement?


Phase Discontinuity Measurement Description

Phase Discontinuity Measurement Description

  • How is a Phase Discontinuity Measurement Made?
  • Phase Discontinuity Measurement Parameters
  • Phase Discontinuity Measurement Results
  • Key 3GPP Tests Performed Using the Phase Discontinuity Measurement
  • Phase Discontinuity Measurement Input Signal Requirements
  • Phase Discontinuity Measurement Calibration

How is a Phase Discontinuity Measurement Made?

3GPP TS 34.121 5.13.3.1 states: "Phase discontinuity is the change in phase between any two adjacent timeslots. The EVM for each timeslot (excluding the transient periods of 25 us on either side of the nominal timeslot boundaries), shall be measured according to subclause 5.13.2. The frequency, absolute phase, absolute amplitude and chip clock timing used to minimise the error vector are chosen independently for each timeslot. The phase discontinuity result is defined as the difference between the absolute phase used to calculate EVM for the preceding timeslot, and the absolute phase used to calculate EVM for the succeeding timeslot."

Graphical Description of Phase Discontinuity (3GPP TS 34.121 5.13.3.1)

"The best-fit rate of change of phase for each timeslot is calculated using the same process as used to minimize the EVM. This best-fit rate of change of phase is by definition the frequency error result for the timeslot. Due to the presence of power steps in the test, the data used for the best-fit calculation shall exclude the 25 us transition period at the beginning and end of each timeslot. The best-fit rate of change of phase for each timeslot is then extrapolated in both directions onto the timeslot boundaries. The phase discontinuity result at any one slot boundary is the difference between the extrapolated phase at the end of the timeslot preceding the slot boundary and the extrapolated phase at the start of the timeslot following the slot boundary."

The phase discontinuity measurement in the test set measures the change in phase between adjacent slots as prescribed in the test standard. Therefore the phase discontinuity reported for any given slot is the extrapolated starting phase of that slot minus the extrapolated ending phase of the previous slot.

The phase discontinuity measurement also returns the extrapolated starting phase of each slot (normalized to the extrapolated starting phase of the Reference Timeslot ), the power of each slot, and several waveform quality results for each slot (see Phase Discontinuity Measurement Results ).

The total number of timeslots measured when the measurement is initiated is determined by Number of Pattern Repetitions or by Measurement Interval , depending upon the Power Control Pattern setting.

Operating Mode Considerations

The phase discontinuity measurement is supported in Active Cell Operating Mode and FDD Test Operating Mode .

In Active Cell Operating Mode , you must be on a call before running the phase discontinuity measurement. To set the UE to the proper power level before running the measurement, set UL CL Power Control Mode to Active Bits and UE Target Power to the desired level.

In FDD Test Operating Mode , you must ensure that the UE is synchronized to the downlink frame clock before running the measurement. To properly range the test set's receiver before running the measurement, set the Expected Power and the UE's output power level accordingly.

Phase Discontinuity Measurement Parameters

  • Power Control Pattern

    When Power Control Pattern is set to 5UP/4DOWN or 5DOWN/4UP :

    • When the measurement is initiated, the test set sends a repeating pattern of 5 up bits then 4 down bits or 5 down bits then 4 up bits.
    • The total number of timeslots measured by the test set is determined by the Number of Pattern Repetitions .
    • The Reference Timeslot (first timeslot measured) is always slot 14 of the frame prior to the start of the power control pattern.
    • When the measurement is initiated, the test set sets UL CL Power Ctrl Algorithm to One and UL CL Power Ctrl Stepsize to 1 dB (and sends the UE a Physical Channel Reconfiguration message with these values). When the measurement completes, the values are returned to their pre-measurement states.
    • When the measurement completes, in an attempt to maintain the connection with the UE, the test set sets UE Target Power to the UE's output power in the final measured slot and sets UL CL Power Control Mode to Active Bits when in Active Cell Operating Mode or to Alternating Bits when in FDD Test Operating Mode .

    When Power Control Pattern is set to NONE :

    • The power control pattern sent to the UE when the measurement is initiated is determined by the UL CL Power Control Mode setting.
    • The total number of timeslots measured by the test set is determined by the Measurement Interval setting.
    • The Reference Timeslot (first timeslot measured) is determined by the Reference Timeslot setting.

  • Number of Pattern Repetitions

    When Power Control Pattern is set to 5UP/4DOWN or 5DOWN/4UP , the Number of Pattern Repetitions setting determines the number of times the chosen pattern is sent to the UE. The measurement ends once the specified number of pattern repetitions has been sent, so this setting determines the total number of timeslots measured by the test set. The total number of timeslots measured is equal to the Reference Timeslot plus 9*( Number of Pattern Repetitions ). The maximum number of timeslots that can be measured is thus 91.

    When Power Control Pattern is set to NONE , this setting is ignored.

  • Reference Timeslot

    When Power Control Pattern is set to NONE , the Reference Timeslot setting determines the first timeslot to be measured (within the first available frame after the measurement is initiated). For example, if you set Reference Timeslot to 4 , then the first slot measured will be the 5th slot of the frame (because the slots are numbered 0 to 14 in a frame).

    When Power Control Pattern is set to 5UP/4DOWN or 5DOWN/4UP , the Reference Timeslot is always slot 14 of the frame prior to the start of the power control pattern. Thus, this setting is ignored.

    The test set compares all other slots to the Reference Timeslot when determining the Phase (in degrees) result.

  • Measurement Interval

    When Power Control Pattern is set to NONE , the Measurement Interval setting determines the number of adjacent slots for the test set to measure. The test set measures the number of slots specified by the Measurement Interval setting, starting with the timeslot specified by Reference Timeslot .

    When Power Control Pattern is set to 5UP/4DOWN or 5DOWN/4UP , this setting is ignored.

  • Trigger Source

    Trigger Source can be set to Protocol or External (see Trigger Source Description ).

    When Power Control Pattern is set to NONE and Trigger Source is set to Protocol , the test set uses the 10 ms frame clock to trigger the measurement on the first available frame. When Power Control Pattern is set to 5UP/4DOWN or 5DOWN/4UP and Trigger Source is set to Protocol , the measurement triggers on the frame in which the pattern transmission starts.

  • Measurement Timeout (see Measurement Timeouts ).

Phase Discontinuity Measurement Results

The following results are available via the FETCh:WPDiscon[:ALL]? command, or from the front panel (see How Do I Make a Phase Discontinuity Measurement? ).

  • Number of Slots Measured

    The test set reports the number of slots measured. The number of slots measured depends upon the Measurement Interval or Number of Pattern Repetitions setting.

  • Worst Case Phase Discontinuity Slot Number: Indicates which of the measured slots had the worst phase discontinuity. The measured slots are numbered 0 to ( Number of Slots Measured - 1). So, for example, if the reported Worst Case Phase Discontinuity Slot Number is 5 , the 6th slot measured had the worst phase discontinuity result.
  • Worst Case Phase Discontinuity (in degrees): Provides the phase discontinuity result for the measured slot with the worst phase discontinuity.
  • Worst Case EVM Slot Number: Indicates which of the measured slots had the worst EVM. The measured slots are numbered 0 to ( Number of Slots Measured - 1). So, for example, if the reported Worst Case EVM Slot Number is 90 , the 91st slot measured had the worst phase discontinuity result.
  • Worst Case EVM (in % rms): Provides the EVM result for the measured slot with the worst EVM.

Results Returned for Each Slot Measured:

The following results are available via the FETCh:WPDiscon:SLOT?<sp><slot num> and FETCh:WPDiscon:TRACe?<sp>DISC|PHASE|POW|EVM|PERR|FERR|MERR|TERR|OOFF commands, or from the front panel graphical display and table of numeric data (see How Do I Make a Phase Discontinuity Measurement? ).

  • Phase Discontinuity (in degrees)

    The phase discontinuity reported for any given slot is the extrapolated starting phase of that slot minus the extrapolated ending phase of the previous slot. Thus, no phase discontinuity is reported for the first slot (the Reference Timeslot ).

  • Phase (in degrees)

    The phase reported for any given slot is the extrapolated starting phase of that slot normalized to the extrapolated starting phase of the Reference Timeslot . Thus, the phase of the Reference Timeslot is always zero.

  • Power (in dBm)

    The average power is reported for each timeslot (this is a channel power measurement over the timeslot, excluding the transient periods of 25 us on either side of the nominal timeslot boundaries, with the RRC filter out).

  • EVM (in % rms)
  • Phase Error (in degrees)
  • Frequency Error (in Hz)
  • Magnitude Error (in %)
  • Time Error (in chips)
  • Origin Offset (in dB)

Key 3GPP Tests Performed Using the Phase Discontinuity Measurement

The phase discontinuity measurement can be used to test 3GPP TS 34.121 5.13.3, as well as the 3GPP TS 25.101 6.8.4.1 minimum requirement:

Phase Discontinuity Minimum Requirement
Phase Discontinuity (in degrees) | Maximum Allowed Rate of Occurrence (in Hz)
Phase Discontinuity </= 30 | 1500
30 < Phase Discontinuity </= 60 | 300
Phase Discontinuity > 60 | 0

3GPP TS 34.121 5.13.3.4.2 specifies:

"NOTE: In order to make it practical to measure the entire power control dynamic range (between min power threshold and max power threshold with suitable margins), it is permissible to segment the power control sequences into smaller subsequences. Except when within 5 dB of the upper or lower thresholds, segmentation will require sufficient overlap such that every power step in one direction is followed by four steps in the other direction."

This overlap ensures that the full dynamic range of the UE is tested, as there is some uncertainty in the actual UE output power based on Active Bits closed loop power control. Without overlapping the subsequence ending and starting powers, some portion of the UE's output power range may not be tested.

To implement the specified overlap, after running the Phase Discontinuity measurement with Power Control Pattern set to 5UP/4DOWN ( or 5DOWN/4UP ), instead of immediately running the measurement again to test the next subsequence, first set UE Target Power to 4 dB below (or above) the ending power of the prior test subsequence.

A faster method of ensuring that the full dynamic range of the UE is tested is as follows: after testing two subsequences, compare the Power (in dBm) of the first slot in the current subsequence with the power of the last slot in the prior subsequence to ensure that they are equal or have some overlap. If not, set MS Target Power accordingly and retest the subsequence.

Phase Discontinuity Measurement Input Signal Requirements

  • This measurement does not autorange, therefore the expected power level from the mobile station (UE) is set using the current MS Target Power setting, or by using manual receiver power control and specifying the expected power level. See Receiver Control .
  • Frequency: 800 to 1000 MHz, 1700 to 1990 MHz
  • Input level: -25 dBm to +28 dBm
  • Maximum measurable EVM: 35%
  • Maximum measurable frequency error: +/- 1 kHz
  • Maximum measurable timing error: +/- 10 us

Phase Discontinuity Measurement Calibration

You must calibrate the phase discontinuity measurement using the measurement calibration procedure (see Calibrating the Test Set ).

Related Topics

Manual Operation: How Do I Make a Phase Discontinuity Measurement?


PRACH Preamble Analysis Measurement Description

PRACH Preamble Analysis Measurement Description

This section is only applicable to the lab application.

  • How is a PRACH Preamble Analysis Measurement Made?
  • PRACH Preamble Analysis Measurement Parameters
  • PRACH Preamble Analysis Measurement Results
  • Key 3GPP Tests Performed Using the PRACH Preamble Analysis Measurement
  • PRACH Preamble Analysis Measurement Input Signal Requirements
  • PRACH Preamble Analysis Measurement Calibration

How is a PRACH Preamble Analysis Measurement Made?

3GPP TS 25.101, 6.8 states "Transmit modulation defines the modulation quality for expected in-channel RF transmissions from the UE. The requirements apply to all transmissions including the PRACH/PCPCH pre-amble and message parts and all other expected transmissions. In cases where the mean power of the RF signal is allowed to change versus time e.g. PRACH, DPCH in compressed mode, change of TFC and inner loop power control, the EVM and Peak Code Domain Error requirements do not apply during the 25 us period before and after the nominal time when the power is expected to change."

The PRACH preamble analysis measurement determines the modulation and timing errors between the transmitted signal of the UE and the ideal signal. The measurement algorithm is similar to that used in the waveform quality and IQ tuning measurements (see Waveform Quality Measurement Description and IQ Tuning Measurement Description ), except that the measurement is performed on a PRACH preamble burst, rather than over a timeslot of the DPCH transmission.

You can choose whether to include the "transient periods" of 96 chips (25 us) on either side of the PRACH preamble in the measurement using the Transient Period setting (for all measurement results except Relative Power (in dB) ). The measurement can thus be performed over the entire PRACH preamble burst, (4096 chips, or 1066.7 us), or only over 3904 chips (1016.7 us).

Before initiating a PRACH preamble analysis measurement, turn the UE on and wait for it to camp to the test set's signal. When you initiate the PRACH preamble measurement by pressing START SINGLE or sending the INITiate command, the test set sets Call Limit State to On to prevent successful call connection, then pages the UE (the test set returns Call Limit State to its prior setting after completion of the measurement). This forces the UE to transmit PRACH preamble bursts.

After the measurement is triggered by a burst (see Trigger Source ) it must determine which signature the UE used to transmit the PRACH preamble so that it can decode the burst data. To do this, it attempts to correlate the data to each of the signatures specified by the PRACH Signature setting. The measurement will execute fastest if you only specify one available signature.

When operating in FDD Test Operating Mode , you do not have access to the PRACH Signature setting, as the test set does not send this type of signalling to the UE in FDD test operating mode. However, when you initiate the measurement in FDD test operating mode, the measurement uses the value last set in the PRACH signature setting to determine which signatures to try to correlate to the PRACH preamble burst. Thus, before running this measurement in FDD test operating mode, you must switch to Active Cell Operating Mode and ensure that the PRACH Signature setting includes the signature that your UE will transmit.

To perform the PRACH preamble analysis measurement, you must set PRACH Preambles to at least 3. You must also set Available Subchannels (Bit Mask) to only allow one available subchannel. It is recommended that you set Call Limit State to Off before initiating this measurement (see Importance of Setting Call Limit State to Off before Initiating a PRACH Measurement ).

No other measurements can be running when a PRACH preamble analysis measurement is performed. If any measurements are running when a PRACH preamble analysis measurement is initiated, they are closed and a message is displayed to indicate that they were closed.

PRACH Preamble Analysis Measurement Parameters

  • Trigger Source

    You can set Trigger Source as follows:

    • Protocol : If trigger source is set to protocol, the test set monitors every available access slot (as determined by the Available Subchannels (Bit Mask) setting) to see if a significant change in power occurs (which would indicate a PRACH preamble burst is present in that access slot). If a burst is present, the measurement is triggered on the access slot boundary.
    • External : see Trigger Source Description .
    • RF Rise : If trigger source is set to RF rise, the measurement is triggered when the UE's power rises to within 9 dB of the expected power (the expected power is equal to Initial PRACH Tx Power if Power Control is set to Auto , or Manual Power if Power Control is set to Manual ; see Receiver Control ). When Trigger Source is set to RF Rise, you may specify a Trigger Delay . When trigger source is set to RF rise, the Timing Error (in chips) result is not available.

  • Trigger Delay

    Trigger delay is only available when Trigger Source is set to RF Rise. The trigger delay setting specifies when to begin the measurement relative to the trigger event. If trigger delay is set to 0 chips, the measurement will begin immediately after the trigger event. See Trigger Delay Description for additional information about trigger delays.

  • Measurement Timeout: (see Measurement Timeouts )
  • Transient Period

    The transient period setting determines whether to include the "transient periods" of 96 chips (25 us) on either side of the PRACH preamble in the measurement. If Transient Period is set to Include , the measurement is performed over the entire PRACH preamble, 4096 chips (1066.7 us). If Transient Period is set to Exclude , the measurement is performed over only 3904 chips (1016.7 us).

    NOTE
    The transient period affects the measurement interval for all measurement results except Relative Power (in dB) . Relative Power is always measured over 4096 chips.

PRACH Preamble Analysis Measurement Results

  • EVM (rms) (in %)

    This result is the rms EVM for the entire PRACH preamble burst (either 4096 or 3904 chips, depending upon the Transient Period setting).

    The EVM for each chip measured in the burst is also available (see EVM (in %) ).

  • EVM (peak) (in %)

    This result is the worst EVM reported for any chip in the burst (either 3904 or 4096 chips are compared, depending upon the Transient Period setting). See EVM (in %) .

  • Frequency Error (in Hz)
  • Origin Offset (in dB)
  • Phase Error (rms) (in degrees)
  • Magnitude Error (in %)
  • Timing Error (in chips)

    This result is the difference in time of the PRACH data relative to the expected timing for the given subchannel setting (see Available Subchannels (Bit Mask) ). See 3GPP TS 25.211, 5.2.2 and 7.3 and 3GPP TS 25.214, 6.1.

    Timing error is not available when Trigger Source is set to RF Rise .

  • IQ Gain Imbalance (in dB)
  • IQ Phase Imbalance (in degrees)
  • Signature: The test set reports the PRACH signature used by the UE for the preamble burst being analyzed. This result may differ from the Detected PRACH Signature result if more than one signature is specified as available by the PRACH Signature setting.

Results Returned for Each Chip Measured

  • Relative Power (in dB)

    The measurement always measures the power in all 4096 chips of the PRACH preamble (regardless of the Transient Period setting), and also measures the power in up to 100 chips before and after the PRACH preamble (if there is a substantial amount of timing error, then fewer than 100 chips before or after the PRACH preamble will be measured and reported). The measurement reports the power in each chip relative to the greatest power measured in any of the chips.

  • EVM (in %)

    This result is the EVM for each measured chip (either 3904 or 4096 chips, depending upon the Transient Period setting).

    The rms EVM (see EVM (rms) (in %) ) and the peak EVM (see EVM (peak) (in %) ) for the entire PRACH preamble burst is also available.

  • Phase Error (in degrees): The measurement calculates the phase difference between each measured chip (either 3904 or 4096 chips, depending upon the Transient Period setting) and its corresponding chip in the ideal signal.
  • IQ Constellation: The measurement plots the I-Q coordinates for each measured chip (either 3904 or 4096 chips, depending upon the Transient Period setting).

A typical measurement result is shown below:

Key 3GPP Tests Performed Using the PRACH Preamble Analysis Measurement

3GPP TS 34.121 5.13.4 PRACH Preamble Quality.

PRACH Preamble Analysis Measurement Input Signal Requirements

  • This measurement does not autorange, therefore the expected power level from the mobile station (UE) is set using the current MS Target Power setting, or by using manual receiver power control and specifying the manual power level. See Receiver Control .
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, or from 1700 MHz to 1990 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of -25 dBm to +28 dBm, in a 3.84 MHz bandwidth.
  • Maximum measurable EVM = 35%.
  • Maximum measurable frequency error = +/- 1 kHz.
  • Maximum measurable timing error = +/- 96 chips (25 us).

PRACH Preamble Analysis Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function ( CALibration:MEASurements? ) when the temperature has changed by more than ± 10° C since the last calibration. If this situation exists, the integrity indicator value becomes 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

Manual Operation: How Do I Make a PRACH Preamble Analysis Measurement?

Programming the PRACH Preamble Analysis Measurement

PRACH Preamble Analysis Troubleshooting

What 3GPP W-CDMA Conformance Tests Are Supported?

Triggering of Measurements

Integrity Indicator


Programming an Audio Level Measurement

Programming an Audio Level Measurement

This section provides an example of how to make an audio level measurement with the Audio Analyzer (AFANalyzer) via GPIB.

The following procedure assumes that an audio source is connected to the AUDIO IN connectors. See Audio Analyzer Measurement Description .

  1. Configure audio analyzer measurement parameters using the SETup subsystem. Even though default settings exist for each parameter, it is a good idea to deliberately set each parameter to make sure the setting is correct for the specific audio analyzer measurement you are making.
  2. Start the audio analyzer measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain audio analyzer measurement results.

Programming Example

10  OUTPUT 714;"SETup:AFANalyzer:CONTinuous OFF" !Set the audio analyzer
20                                           !measurements to single trigger mode.
30  OUTPUT 714;"SETup:AFANalyzer:PEAK:VOLTage 3V" !Set the Expected Amplitude level for
40                                                !audio input voltage in Vpeak.
50  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:STATe OFF" !Turn off the SINAD and
60                                                  !distortion measurements since
70                                                  !they are not being used.
80  OUTPUT 714;"SETup:AFANalyzer:FILTer NONE" !Bypass all audio filters.
90  OUTPUT 714;"SETup:AFANalyzer:DEMPhasis:STATe OFF" !Turn off de-emphasis.
100 OUTPUT 714;"SETup:AFANalyzer:EXPandor:STATe OFF" !Turn off the expandor.
110 OUTPUT 714;"SETup:AFANalyzer:DETector RMS" !Specify the RMS detector for the
120                                            !audio measurement.
130 OUTPUT 714;"SETup:AFANalyzer:TIMeout 3S" !Set a timeout value of 3 seconds
140                                      !in case the measurement cannot be made.
150 OUTPUT 714;"INITiate:AFANalyzer" !Start the AF Analyzer measurement.
160 OUTPUT 714;"FETCh:AFANalyzer:VOLTage?" !Fetch the Audio Level result.
170 ENTER 714;Audio_level  !Enter the returned value into a variable.
180 END

Returned Values

The results returned by this program are:

  • Integrity returns the measurement integrity indicator (0 means a successful measurement with no errors). See Integrity Indicator .
  • Audio_level returns the analog audio level in volts rms.

Related Topics

Audio Analyzer Measurement Description

AFANalyzer Troubleshooting

INITiate

SETup:AFANalyzer

FETCh:AFANalyzer

Control Program Example


Programming an Adjacent Channel Leakage Ratio Measurement

Programming an Adjacent Channel Leakage Ratio Measurement

This section provides an example of how to make an adjacent channel leakage ratio measurement via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is transmitting an uplink signal.

The program example demonstrates how individual offsets, such as the ± 10 MHz measurements, can be turned off to increase measurement speed, but would normally be left on when making the 3GPP TS 34.121, 5.10 measurement.

The basic procedure to test adjacent channel leakage ratio is as follows:

  1. Set the adjacent channel leakage ratio setup parameters as desired using the SETup:WACLeakage commands.
  2. Use the INITiate:WACLeakage command to start the measurement.
  3. Use the FETCh:WACLeakage? query to obtain the measurement results.

Programming Example

10    OUTPUT 714;"SETup:WACLeakage:CONTinuous OFF"   !Set the adjacent
20                 !channel leakage ratio measurement to single trigger mode.
30    OUTPUT 714;"SETup:WACLeakage:TIMeout 1S"!Set a timeout value of 1 second
40                                  !in case the measurement cannot be made.
50    OUTPUT 714;"SETup:WACLeakage:COUNt 5"!Set multi-measurements to 5 and
60                                     !enable multi-measurements.
70    OUTPUT 714;"SETup:WACLeakage:TRIGger:SOURce AUTO" !Set the trigger source
80                                                   !to use automatic triggering.
90    OUTPUT 714;"SETup:WACLeakage:LOWer2:STATe OFF"  !Turn off the lower
100                              !second alternate (-10 MHz) measurement.
110   OUTPUT 714;"SETup:WACLeakage:UPPer2:STATe OFF"  !Turn off the upper
120                              !second alternate (+10 MHz) measurement.
130   OUTPUT 714;"INITiate:WACLeakage"!Start the adjacent channel leakage
140                                   !ratio measurement.
150   OUTPUT 714;"FETCh:WACLeakage?"!Query the returned integrity indicator, and the
160                                             !measurement values for each offset.
170   ENTER 714;Integrity,Low_1st_alt,Hi_1st_alt,Low_2nd_alt,Hi_2nd_alt  !Enter the
180                                             !returned values into variables.
190   IF Integrity<>0 THEN !Integrity <> 0 indicates  an invalid measurement.
200     PRINT "Measurement problem; check for signal level over/under range condition."
210   ELSE
220   END IF
230   END

Returned Values

  • Integrity stores the returned integrity indicator value (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Because multi-measurements are being used, Low_1st_alt and Hi_1st_alt (± 5 MHz) measurements return the average adjacent channel leakage ratio measurement values for those offsets, in dB. If multi-measurements were not being used, the returned values would be a single measurement value for each frequency offset.
  • Because the Low_2nd_alt and Hi_2nd_alt (± 10 MHz) measurements are turned off in this example, the returned values are always 9.91E+37 (NAN).

Related Topics

  • Adjacent Channel Leakage Ratio Troubleshooting
  • Adjacent Channel Leakage Ratio Measurement Description
  • SETup:WACLeakage
  • INITiate
  • FETCh:WACLeakage
  • Amplitude Offset
  • Integrity Indicator


Programming an Audio Frequency Measurement

Programming an Audio Frequency Measurement

This section provides an example of how to make an audio frequency measurement with the Audio Analyzer (AFANalyzer) via GPIB.

The following procedure assumes that an audio source is connected to the AUDIO IN connectors. See Audio Analyzer Measurement Description .

  1. Configure audio analyzer measurement parameters using the SETup subsystem. When more than one audio frequency signal may be present, use the 100 Hz bandpass filter to isolate the desired signal for measurement (see the Programming Example below).
  2. Start the audio analyzer measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain audio analyzer measurement results.

Programming Example

10  OUTPUT 714;"SETup:AFANalyzer:CONTinuous OFF" !Set the audio analyzer
20                                           !measurements to single trigger mode.
30 ! OUTPUT 714;"SETup:AFANalyzer:PEAK:VOLTage 3V" !Set the Expected peak voltage
40                                                !for the audio input level in Vpeak.
50  OUTPUT 714;"SETup:AFANalyzer:FREQuency:STATe ON" !Enable audio frequency meausurement.
60  OUTPUT 714;"SETup:AFANalyzer:FILTer TBPass" !Select the 100 Hz bandpass filter.
70  OUTPUT 714;"SETup:AFANalyzer:FILTer:TBPass 6000 Hz" !Set the 100 Hz bandpass
80     !filter's center frequency to 6 kHz (example; to measure SAT frequency).
90  OUTPUT 714;"SETup:AFANalyzer:TIMeout 3S" !Set a timeout value of 3 seconds
100                                      !in case the measurement cannot be made.
110 OUTPUT 714;"INITiate:AFANalyzer" !Start the AF Analyzer measurement.
120 OUTPUT 714;"FETCh:AFANalyzer:FREQuency?" !Fetch the Audio Frequency  result.
130 ENTER 714;Audio_frequency !Enter the returned value into a variable.
140 END

Related Topics

Audio Frequency Measurement Description

AFANalyzer Troubleshooting

Audio Analyzer Measurement Description

INITiate

SETup:AFANalyzer

FETCh:AFANalyzer

Control Program Example


Programming a Channel Power Measurement

Programming a Channel Power Measurement

This section provides an example of how to make channel power measurements via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is transmitting an uplink signal.

The basic procedure to test channel power is as follows:

  1. Set the channel power Setup parameters as desired using the SETup:WCPower commands.
  2. Use the INITiate:WCPower command to start the measurement.
  3. Use the FETCh:WCPower? query to obtain the measurement results.

Programming Example

10    OUTPUT 714;"SETup:WCPower:CONTinuous OFF"!Set the channel power
20                                     !measurement to single trigger mode.
30    OUTPUT 714;"SETup:WCPower:TIMeout 1S"!Set a timeout value of 1 second
40                                  !in case the measurement cannot be made.
50    OUTPUT 714;"SETup:WCPower:COUNt 5"!Set multi-measurements to 5 and
60                                     !enable multi-measurements.
70    OUTPUT 714;"SETup:WCPower:INTerval:TIME 666.7US"!Set the measurement interval
80                                                   !for 1 timeslot (666.7 us).
90    OUTPUT 714;"SETup:WCPower:TRIGger:SOURce AUTO" !Set the trigger source
100                                                  !to use automatic triggering.
110   OUTPUT 714;"INITiate:WCPower"!Start the channel power measurement.
120   OUTPUT 714;"FETCh:WCPower?"!Query the returned integrity indicator and the
130                              !average channel power measurement.
140   ENTER 714;Integrity,Wcpower!Enter the returned values into variables.
150   IF Integrity<>0 THEN !Integrity <> 0 indicates an invalid measurement.
170     PRINT "Measurement problem; check for signal level over/under range condition."
171   ELSE
180   END IF
190   END

Returned Values

  • Integrity stores the returned integrity indicator value (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Wcpower returns the average channel power measurement value in dBm.

Related Topics

  • Channel Power Troubleshooting
  • Channel Power Measurement Description
  • SETup:WCPower
  • INITiate
  • FETCh:WCPower
  • Amplitude Offset
  • Integrity Indicator


Programming a Code Domain Measurement

Programming a Code Domain Measurement

This section provides an example of how to make code domain measurements via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is synchronized to the test set and is transmitting an uplink signal.

The basic procedure is as follows:

  1. Set the code domain setup parameters as desired using the SETup:WCDomain commands.
  2. Use the INITiate:WCDomain command to start the measurement.
  3. Use FETCh:WCDomain? queries to obtain the measurement results.

Programming Example

10    ! Set trigger mode to single for the Code Domain measurement
20    OUTPUT 714;"SETup:WCDomain:CONTinuous OFF"
30    ! Set a timout value of 5 seconds and enable the timeout state
40    OUTPUT 714;"SETup:WCDomain:TIMeout 5"
50    ! Set the trigger source to automatically select the appropriate
60    !  trigger
70    OUTPUT 714;"SETup:WCDomain:TRIGger:SOURce AUTO"
80    ! Set the timeslot to be measured
90    OUTPUT 714;"SETup:WCDomain:TSLot 7"
100   ! Initiate the Code Domain measurement
110   OUTPUT 714;"INITiate:WCDomain"
120   ! Fetch the integrity indicator and the results of the measurement
130   OUTPUT 714;"FETCh:WCDomain:INTegrity?;BETas?"
140   ENTER 714;Integrity,Bc1,Bd1,Bd2,Bd3,Bd4,Bd4,Bd5
150   ! Check the integrity indicator to ensure the results are valid
160   IF Integrity<>0 THEN
170     PRINT "Measurement failed."
180   ELSE
190   ! Process the measurement results.
200   END IF
210   END

Returned Values

  • Integrity stores the returned integrity indicator value (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Bc1 returns the relative amplitude level for the DPCCH (bc).
  • Bd1 returns the relative amplitude level for the DPDCH (bd1).
  • Bd2 - Bd6 returns "NAN" (Not A Number). These are reserved for use in the future.

Related Topics

  • Code Domain Troubleshooting
  • Code Domain Measurement Description
  • SETup:WCDomain
  • INITiate
  • FETCh:WCDomain
  • Amplitude Offset
  • Integrity Indicator


Programming a Distortion Measurement

Programming a Distortion Measurement

This section provides an example of how to make distortion measurements via GPIB. Distortion measurements are not typically made when testing W-CDMA mobiles, but are more common when testing AMPS or other analog mobiles. The programming example below is typical for an AMPS mobile.

SINAD and Distortion measurements are affected by the same STATe and INITiate commands, so both measurements are enabled and triggered at the same time. However, measurement results are queried separately. See Audio Analyzer Measurement Description .

The following procedure assumes that the mobile's audio output is connected to the AUDIO IN connectors and the mobile is on an analog voice channel (AVC). The AVC is being modulated with a 1004 Hz tone at ± 8 kHz peak deviation, and a 6000 Hz SAT at ± 2 kHz peak deviation. It is also assumed that the Cell Power from the test set is set to -50 dBm (IS-137 standard).

  1. Configure audio analyzer measurement parameters using the SETup subsystem.
  2. Start the audio analyzer measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain audio analyzer measurement results.

Programming Example

10  OUTPUT 714;"SETup:AFANalyzer:CONTinuous OFF" !Set the audio analyzer
20                                           !measurements to single trigger mode.
30  OUTPUT 714;"SETup:AFANalyzer:PEAK:VOLTage 3V" !Set the Expected Amplitude level for
40                                                !audio input voltage in Vpeak.
50  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:STATe ON" !Turn on the SINAD and
60                                                  !distortion measurements.
70  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:FREQuency 1004 HZ" !Specify the audio
80                                      !frequency to use for the measurements.
90  OUTPUT 714;"SETup:AFANalyzer:FILTer CMessage" !Select the c-message filter.
100 OUTPUT 714;"SETup:AFANalyzer:DEMPhasis:STATe OFF" !Turn off de-emphasis.
110 OUTPUT 714;"SETup:AFANalyzer:EXPandor:STATe OFF" !Turn off the expandor.
120 OUTPUT 714;"SETup:AFANalyzer:TIMeout 3S" !Set a timeout value of 3 seconds
130                                      !in case the measurement cannot be made.
140 OUTPUT 714;"INITiate:AFANalyzer" !Start the AF Analyzer measurement.
150 OUTPUT 714;"FETCh:AFANalyzer:INTegrity?" !Query the integrity indicator to
160                           !verify that a reliable measurement was made.
170 ENTER 714;Integrity  !Enter the returned value into a variable for comparison
180                      !with possible integrity indicator values (not shown here).
190 IF Integrity=0 THEN  !Only fetch measurement result if integrity indicator is 0.
200 OUTPUT 714;"FETCh:AFANalyzer:DISTortion?" ! Fetch the Distortion result.
210 ENTER 714;Distortion !Enter the returned value into a variable.
220 END IF
230 END

Returned Values

The results returned by this program are:

  • Integrity returns the measurement integrity indicator; 0 means a successful measurement with no errors. See Integrity Indicator .
  • Distortion returns the Distortion measurement value in percent (%).

Related Topics

Audio Analyzer Measurement Description

AFANalyzer Troubleshooting

Distortion Measurement Description

INITiate

SETup:AFANalyzer

FETCh:AFANalyzer

Control Program Example


Programming a Frequency Stability Measurement

Programming a Frequency Stability Measurement

December 21, 2004

This section provides an example of how to make Frequency Stability measurements via GPIB.

The following program example assumes that a signal within the measurement range in connected to the RF IN/OUT connector (see Input Signal Requirements ).

The basic procedure to test Frequency Stability is as follows:

  1. Set the expected frequency and power.
  2. Define the Frequency Stability Setup parameters as desired for measurement timeout and multi-measurements.
  3. Use the INITiate:FSTability command to start the measurement.
  4. Use the FETCh? command to obtain the measurement results.

Programming Example

10  !Set the expected frequency and power.
20  OUTPUT 714;"SETup:FSTability:CONTinuous OFF" !Set the frequency stability
30                                           !measurement to single trigger mode.
40  OUTPUT 714;"SETup:FSTability:TIMeout 1 S" !Set a timeout value of 1 second
50                                       !in case the measurement cannot be made.
60  OUTPUT 714;"SETup:FSTability:COUNt 5" !Set multi-measurements to 5.
70  OUTPUT 714;"INITiate:FSTability" !Start the measurement.
80  OUTPUT 714;"FETCh:FSTability?" !Query the returned integrity indicator and the
90         !Worst Case Frequency Error and average Frequency measurements.
100 ENTER 714;Integrity,Freq_error,Frequency  !Enter the returned values into variables.
110 IF Integrity=0 THEN  !See if the integrity value = 0 (valid measurement).
120 ELSE
130 PRINT "Measurement problem; check for signal level over/under range condition."
140 END IF
150 END

Returned Values

The measurements returned by this program are:

  • Integrity returns the measurement integrity indicator (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Freq_error returns the worst case frequency error in parts per million (PPM). Frequency returns the average frequency.

Related Topics

Frequency Stability Measurement Description

Frequency Stability Troubleshooting

INITiate

SETup:FSTability

FETCh:FSTability

Receiver Control


Dealing With Semicolon Separated Response Data Lists

Dealing With Semicolon Separated Response Data Lists

Description

In accordance with IEEE 488.2-1992 Section 8.4.1 the test set uses the semicolon (;) as the response message unit separator (RMUS). The RMUS separates sequential response message unit elements from one another when multiple response message unit elements are sent in a response message. This condition would occur when combining multiple queries into a single GPIB transaction.

Query Response Data Types Used By Test Set

The test set can return the following data types in response to queries:

  • character data (char): ASCII characters A-Z (65-90 decimal), underscore (95 decimal), digits (48-57 decimal).

  • string data: ASCII characters enclosed in quotes (for example, "5551212" or "PGSM")

  • numeric response data (nr1): numeric data in the form +/- dddddddd

  • numeric response data (nr3): numeric data in the form +/- ddd.ddd E +/- dddd

Semicolon Separated Response Data Lists Containing Mixed Data Types

Problems can occur when trying to enter semicolon separated response data lists containing mixed data types.

For example: If the following command string is sent to the test set, the test set will respond by constructing a response message which contains multiple response message unit elements (that is, one response message unit element for each query item contained in the command string). Some response message unit elements are string data type, some are character data type and some are nr3 data type.

OUTPUT 714;"CALL:MS:REP:IMSI?;PCL?;REV?;SBAN?;ONUM?;MCC?;MNC?;LAC?"

An example response message generated by the test set in response to the above OUTPUT statement would be:

"001012345678901";+4.00000000E+000;PHAS1;"PGSM";"5551212";9.91E37;9.91E37;9.91E37

Constructing the following data entry statement will account for multiple responses from the query:

ENTER 714;Imsi$,Pcl,Rev$,Sban$,Onum$,Mcc,Mnc,Lac

In the Basic programming environment the above ENTER statement will fail with an `Insufficient data for ENTER' error. Some programming languages, Basic for example, cannot use the semicolon character as a data item terminator for string variables. In this example Basic will attempt to enter data into Imsi$ until it sees a LF (line feed) data item terminator. The test set does not send the LF until all the data has been sent. Consequently when Basic sees the LF it terminates entry of data into Imsi$ and starts to look for data to enter into Pcl. Since the test set is no longer sending any data the error message `Insufficient data for ENTER' is generated.

One possible workaround is to enter all the data into a single string variable, replace all semicolons with line feeds and then enter the data from the string into the individual data items. For example:

DIM Response$[500]
!
!
OUTPUT 714;"CALL:MS:REP:IMSI?;PCL?;REV?;SBAN?;ONUM?;MCC?;MNC?;LAC?"
ENTER 714;Response$
Semicolon=POS(Response$,";")
WHILE Semicolon
Response$[Semicolon,Semicolon]=CHR$(10)
Semicolon=POS(Response$,";")
END WHILE
ENTER Response$;Imsi$,Pcl,Rev$,Sban$,Onum$,Mcc,Mnc,La

Semicolon Separated Response Data Lists Containing Only Numeric Data Types

Semicolon separated response data lists containing only numeric data types do not present the types of problem associated with semicolon separated response data lists containing mixed data types. The number building routines in most languages will use any non-numeric character (that is, anything other than +/- 0123456789 E .) as the data item terminator. Consequently when the number building routines encounter the semicolon the data item is terminated. The following example illustrates this:

OUTPUT 714;"FETCH:TXP:INT?;POW:MIN?;MAX?"
ENTER 714;Integrity,Min_power,Max_power


Concurrent Measurements

Concurrent Measurements

Description

A number of measurements can be initiated (with the INITiate command) while other measurements are being made, and the test set will perform as many operations simultaneously as its architecture allows. This technique is referred to as concurrency. Performing measurements concurrently can greatly improve test throughput.

Operating Considerations

The test set has three parallel signal paths to improve measurement throughput.

  • Demodulation downconverter path.
  • Measurement downconverter path.
  • Power detector path.

Since measurements are DSP (digital signal processor) based, and there are four A/D converters available to digitize or "sample" the input signal for analysis by the DSP, the test set will always have the capability to perform one transmitter measurement, one receiver measurement, and maintain the radio link concurrently. The test set's ability to perform multiple transmitter, or multiple receiver tests concurrently will depend on the availability of resources within the test set and availability of the signal to be tested.

Concurrent Measurements for the W-CDMA Applications

This table shows the concurrency considerations for the W-CDMA applications.

W-CDMA Concurrency Considerations
 | W W Q | W T P | W S E M | W P P A | W P D | W O O S | W O O P | W O B W | W I Q T | W I L P | W D P A | W C T F | W C P | W C D | W B L | W B E R | W A C L | S M O N | S A U D | F S T | D T M | A F G | A F A N
AFAN (Audio Analyzer) | B | Y | B | D | D | D | D | B | B | D | B | D | B | B | Y | Y | B | B | A | B | Y | Y | ...
AFG (Audio Generator) | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | E | Y | Y | ... | ...
DTM (Data Throughput Monitor) | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | ... | ... | ...
FST (Frequency Stability) | B | Y | B | D | D | D | D | B | B | D | B | D | B | B | Y | Y | B | B | B | ... | ... | ... | ...
SAUD (Swept Audio) | B | Y | B | D | D | D | D | B | B | D | B | D | B | B | Y | Y | B | B | ... | ... | ... | ... | ...
SMON (Spectrum Monitor) | B | Y | B | D | D | D | D | B | B | D | B | D | B | B | Y | Y | B | ... | ... | ... | ... | ... | ...
WACL (Adjacent Channel Leakage Ratio) | B | Y | B | D | D | D | D | B | B | D | B | D | B | B | Y | Y | ... | ... | ... | ... | ... | ... | ...
WBER (Loopback BER) | Y | Y | Y | D | D | D | D | Y | Y | D | B | D | Y | Y | A | ... | ... | ... | ... | ... | ... | ... | ...
WBL (BLER) | Y | Y | Y | D | D | D | D | Y | Y | D | B | D | Y | Y | ... | ... | ... | ... | ... | ... | ... | ... | ...
WCD (Code Domain) | B | Y | B | D | D | D | D | B | B | D | B | D | B | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WCP (Channel Power) | B | Y | B | D | D | D | D | B | B | D | B | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WCTF (Change of TFC) | D | D | D | D | D | D | D | D | D | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WDPA (Dynamic Power Analysis) | B | B | B | D | D | D | D | B | B | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WILP (Inner Loop Power) | D | D | D | D | D | D | D | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WIQT (IQ Tuning) | B | Y | B | D | D | D | D | B | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WOBW (Occupied Bandwidth) | B | Y | B | D | D | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WOOP (PRACH Transmit On/Off Power) | D | D | D | D | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WOOS (Out-of-Synch Handling of Output Power) | D | D | D | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WPD (Phase Discontinuity) | D | D | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WPPA (PRACH Preamble Analysis) | D | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WSEM (Spectrum Emission Mask) | B | Y | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WTP (Thermal Power) | Y | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WWQ (Waveform Quality) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...

Table Key

Y: These measurements can operate concurrently with no conflicts.

A: Cannot operate concurrently. The measurement which is initiated most recently will cause all other conflicting measurements to be closed.

B: These measurements share a sampler path. If multiple measurements are initiated at the same time, they will execute sequentially. However, if multiple measurements are configured to operate off the same trigger event and only a single occurrence of that event happens, only the first initiated measurement will complete .

D: When this measurement is initiated, all other measurements are closed.

E: Swept audio automatically adjusts the audio generator, therefore adjusting the audio generator's frequency while using swept audio will generate an error message. Also, once the swept audio measurement has completed, it does not reset the audio generator values back to what they were before it adjusted them.

Related Topics

Block Diagram


Integrity Indicator

Integrity Indicator

Description

The test set can evaluate its own performance and make a determination as to the validity of a measurement result. The test set evaluates the conditions surrounding a measurement and reports to the user its evaluation of these conditions in a parameter called the measurement integrity indicator. A measurement integrity indicator value is returned for every completed measurement. It is recommended that the user take advantage of this feature in every measurement.

The returned value defines whether or not a problem was encountered by the measurement process. It is not, however, guaranteed to be the only or root cause of the measurement problem. This is because some of the conditions surrounding a measurement may interact, and the test set may have insufficient information to determine the root cause of the measurement problem. However, in most cases, the value returned is the most likely cause of the problem.

Not all of the integrity indicator values are available for each measurement or test application, if a value doesn't apply it will not be available.

Integrity Indicator Values

NOTE
GSM, GPRS and EGPRS measurements return integrity indicators (8, 9, 11) when the measurement synchronization is set to midamble.

Integrity Indicator Number

Integrity Indicator Message

0

Normal: Indicates the measurement completed successfully without error and the result is accurate.

1

No Result Available: Indicates that there is no measurement result and returns NAN (not a number).

2

Measurement Timeout: Indicates that a measurement has timed out. The measurement timeout state must be set to ON.

3

Hardware Not Installed: Indicates that a piece of hardware is not installed in the test set, or the hardware has failed in a way which leads the instrument controller to believe it isn't installed.

4

Hardware Error: Indicates that a hardware failure has occurred. These include failures such as a phase lock loop out-of-lock, defective DSP samplers, or power detectors that can not be calibrated.

5

Over Range: Indicates that the input signal is over range. The amplitude of the device-under test's (DUT's) signal is causing the voltage at a DSP sampler to be above its maximum input level or the frequency is too high or the voltage measured is beyond the maximum voltmeter range, either positive or negative.

6

Under Range: Indicates that the input signal is under range. The amplitude of the DUT's signal is not high enough for the DSP sampler to produce accurate results with the measurement algorithm.

7

Burst Short: Indicates that the burst duration is too short, or part of the burst was not sampled due to improper triggering.

8

Trigger Early or Fall Early: Indicates that the DUT's burst amplitude fell prematurely or, due to an early trigger (early relative to a transmitted burst) the measurement sampling operation terminated before the falling edge of the burst.

9

Trigger Late or Rise Late: Indicates that either the rising edge of the DUT's burst was late or, due to a late trigger (late relative to a transmitted burst) the measurement sampling operation didn't start until after the rising edge of the transmitted burst.

10

Signal Too Noisy: Indicates that the measurement algorithm has found the signal measured to be too noisy to provide accurate results.

11

Sync Not Found: Indicates that the midamble was not found therefore the measurement was not synchronized.

12

Oven Out of Range: Indicates that a temperature controlled oven (other than the internal timebase oven) is outside of its operating range. The power meter's oven is checked and its condition reported with this value. (The internal timebase generates a temporary error message (out of lock) that is sent to the system error queue and the display. This is not an integrity indicator value, it is an error message.)

13

Unidentified Error: Indicates errors which are not covered by the other integrity values. Examples include: parameter errors, algorithm memory errors (too many measurements), measurements unavailable (unable to control), autorange unable to converge, default calibration data used.
14

PCM Full Scale Warning: Indicates that the PCM signal has reached plus or minus full scale. The measurement made will be accurate on the PCM signal but would typically indicate an overdriven or oscillating element in the DUT.
15

Questionable Result for Phase 1 Mobile: Indicates that the user attempted to make an FBER measurement in a phase 1 system. FBER is only possible in a phase 2 GSM system. This indicator is available only when the selected broadcast band is PGSM.

16

Questionable Result:
1. Indicates that the channel mode was NOT set to Full Rate Speech while a Decoded Audio measurement was active. Decoded Audio is only supported for FS Speech.
2. For the cdma2000 lab application, this integrity indicator is used to indicate that the Digital Average Power measurement result is questionable if the reverse channel is in 1/8 rate gated transmission in radio configuration 3 and above or the test set can not determine whether the reverse channel is in gated transmission (for example, while in a voice call).
3. For the GPRS Bit Error and GPRS Block Error measurements, this integrity indicator is returned when the Connection Type is set to an invalid parameter, i.e. SRB Loopback.

17

Can not Correlate: Indicates that the test sets internally generated reference signal does not correlate with the received signal.

Some conditions that could cause this integrity indicator result include the following:

  • an input signal that is corrupted
  • the input signal is extremely distorted
  • the input signal is off by more than 10 ms.
  • the frequency of the input signal deviates more than allowed
  • something is wrong with the long-code mask coming from the mobile ID

18

Frequency Out Of Range: Indicates that a Channel Power Measurement was attempted at a frequency for which there is no calibration data. The test set display will indicate 4 dashes.

19

Uncalibrated Due To Temperature: Indicates that the ambient temperature changes more than 10 degrees C since latest calibration, when attempting a Channel Power Measurement.

20

 Potential Receiver Saturation: Indicates that an input signal immediately prior to the measured input was high enough to potentially saturate the receiver hardware.

21

Parameter Error: Indicates that a measurement setup parameter has been set in a way that gives invalid measurement results.

22

Unsupported Configuration: Indicates that some parameter, other than a measurement setup parameter has been set so that it causes an invalid measurement result. Typically this would be a base station emulator parameter.

For example, in cdma2000 lab application, initiating the multi-tone audio measurement when the service option (SO3) is selected with the Voice SO Mode set to Multi-Tone or Null Frames will result in the measurement integrity indicator value of Unsupported Configuration (22). This is because Agilent Technologies, Inc. does not obtain the license to use the EVRC vocoder algorithms.

23

Call Processing Operation Failed: Indicates that a call processing operation, (base station emulator) needed in the course of making the measurement could not complete.

24

Calibration Error

25

 Burst Not Found
26 | Missing Loopback Packets or AT Buffer Overflow: Indicates that Loopback Packets are missing, or the Access Terminal had an overflow. This integrity indicator was added for the 1xEV-DO Packet Error Rate measurement.

27

No AT Loopback Packets: Indicates that no Loopback Packets from the Access Terminal were detected for a period of several seconds. This integrity indicator was added to provide an early termination criteria for the 1xEV-DO Packet Error Rate measurement.

28

 Questionable MS-to-Cell Data: Indicates that a condition exists on the uplink or reverse channel that has caused the measurement results to be in question. In the case of the WCDMA Loopback BER measurement, an example condition that could cause this integrity indicator would be detection of a CRC error in an uplink transport block.
30 | Trigger Missed: Indicates one or more triggers were missed during the measurement. In the case of the CDMA TX dynamic power measurement, an example condition that may cause this integrity indicator would be GPIB or LAN activities occur during the measurement. This integrity indicator was added to prevent the CDMA TX dynamic power measurement from hanging forever and provide an early termination criteria for the measurement.

Related Topics

Error Messages


Measurement Timeouts

Measurement Timeouts

Description

The primary use of measurement timeouts is to regain control of the test set's GPIB in cases where the bus could potentially "hang."

The time normally required for a measurement to complete may vary greatly depending on the individual measurement, its settings, it's multiple measurement count value, and so forth. Because of this, you may need to set the timeout longer than the default for measurements where a large number of multiple measurements are requested or where measurement triggers may be infrequent.

Be careful when setting a timeout that is shorter than the default. It is possible to specify a timeout that is so short the measurement does not even have a chance to begin. Measurement timeouts should always be at least several seconds long.

Timeout units default to S (seconds). The seconds suffix is an optional part of the command. If you want MS (milliseconds), US (microseconds) or NS (nanoseconds), you must specify these units in the suffix.

Timeout Values

All measurements in the W-CDMA Mobile Test application default to a timeout value of 10 seconds, except Loopback BER, Block Error Ratio and Out-of-Synch Handling of Output Power. For these measurements the timeout default is 20 seconds.

Related Topics

Integrity Indicator


Step 1: Set Up the Test Set

Step 1: Set Up the Test Set

The following information provides additional details on Step 1 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you initialize the test set and set up the general operating conditions.

Contents

  • Initialize the Test Set
  • Set Up General Operating Conditions

Initialize the Test Set

  • Fully Preset the Test Set

    It is important to get the test set to a known state before each production session.

    Sending the *RST command fully presets the test set, which ends all call processing and measurement processes and restores all values to defaults.

  • Clear the Error Queue

    Before each production session, it is useful to clear the error queue of any old messages. That way, you know that any messages logged are relevant to the current production session.

    Sending the *CLS command clears the error queue.

Set Up General Operating Conditions

  • Turn Debugger On

    While developing your code, it is very useful to enable the GPIB debugger using the
    SYST:COMM:GPIB:DEB ON command. When the debugger is on, the test set alerts you when you send an incorrect command, and it also tells you which symbol or letter in the command is incorrect.

NOTE
You should turn the debugger off once you have finished development and your code is stable.

  • Set Operating Mode

    The test set contains a base station emulator (BSE), whose primary purpose is to provide enough call processing to allow parametric measurements of a mobile station's RF signal.

    An important characteristic of the test set's base station emulator is its operating mode. The operating mode sets the way in which the base station emulator interacts with the mobile station.

    Active cell mode is used when emulating a normal cell. Active cell mode allows active signaling between the mobile station and BSE. The mobile station camps to the BSE signal, and an actual call is established.

    In test mode, the mobile station synchronizes to the BSE signal and transmits an appropriate signal which the test set analyzes.

    The test set's operating mode is set using the following command:

    Command to Set the Test Set's Operating Mode

    Command

             Example

    CALL:OPER:MODE <operating mode>

    CALL:OPER:MODE CELL

  • Set Amplitude Offsets

    To achieve accurate measurement results, it is important to account for losses in the cabling and fixturing between the mobile station and test set. You must determine what the losses are for your test setup and then specify the appropriate frequency-dependent amplitude offset values.

    You can specify amplitude offsets for up to 20 frequencies using the following commands:

    Commands to Set Amplitude Offsets

    Command

             Example

    SYST:CORR:FREQ <freq1>, <freq2>, <freq3>

    SYST:CORR:FREQ 800MHz, 1800MHz,
    1900MHz

    SYST:CORR[:SGAin] <offset1>,
    <offset2>, <offset3>

             SYST:CORR -0.7, -1.0, -1.2

  • Set Display Mode

    To achieve a slightly faster test execution speed, you can disable the front panel display on the test set using the DISP:MODE FAST command.


Step 2: Configure Test Set and Mobile Station Parameters

Step 2: Configure Test Set and Mobile Station Parameters

The following information provides additional details on Step 2 of the Programming Flowchart. This information is applicable to all test and lab applications.

Description

In this step you configure the parameters that allow a connection to be made between the test set and mobile station. This mainly involves setting up channels and power levels.

Contents

  • Set Up Channels
  • Set Cell Power
  • Set Mobile Station Transmit Power
  • Set Up Additional Connection Parameters

Set Up Channels

For many technologies, setting up channels involves specifying the channel associated with every band and channel type (for example, analog or digital), and then setting the active band and channel type. For some technologies, such as W-CDMA, you simply specify the downlink and uplink UARFCNs (channels).

  • Specify Channel Numbers

    All of the test set's test applications can test in more than one frequency band (for example, US Cellular, US PCS, or Korean PCS). To produce the most efficient code, you should configure the channel information for each band in advance. Then, to move to a new band during testing, you only need to send the command to change bands. You do not need to also specify the channel of the new band. This reduces test time.

    To set up the channel number for the various bands, use one of the following commands (depending upon which test application you are using):

    Commands to Set the Channel for a Band

    Command

             Example Technology

    CALL:<channel mnemonic>:<band mnemonic>
    <num value>

    CALL:TCH:EGSM 124

             GSM/GPRS/EGPRS

    CALL:SET:<channel type mnemonic>:<band
    mnemonic> <num value>

    CALL:SET:DTC:PCS 777

             AMPS/136

    CALL:CHAN:<channel type mnemonic>:<band
    mnemonic> <num value>

    CALL:CHAN:DIG2000:K
    PCS 384

             cdma2000/IS-95/AMPS

    This practice also applies to test applications which test both analog and digital channel types. In this case you should specify the channel for the analog and digital channel types in advance. Then, switching between them requires only one command to initiate the change, and not an additional change to specify the channel of the new channel type.

    If you specify channels in advance as described, the only time you need to specify a channel during testing is if you move to a new channel within the same band and channel type.

  • Set Active Band and Mode

    Once you have specified the channel information for each band and channel type, you must set the active band using one of the following commands (depending upon which test application you are using):

    Commands to Set the Active Band

    Command

             Example Technology

    CALL:<channel mnemonic>:BAND <band mnemonic>

    CALL:TCH:BAND
    EGSM

             GSM/GPRS/EGPRS

    CALL:SET:<channel type mnemonic>:BAND <band
    mnemonic>

             CALL:SET:DTC:BAND
    PCS     		AMPS/136
    CALL:BAND:<channel mnemonic> <band mnemonic>

    CALL:BAND:DIG2000
    KPCS

             cdma2000/IS-95/AMPS

    If the test application you are using supports testing of both analog and digital channel types, then you must also set the channel type using the following command:

    Command to Set the Active Channel Type

    Command

             Example

    CALL:<channel mnemonic>:TYPE <channel type
    mnemonic>

    CALL:TCH:TYPE
    DTC

  • Active Cell and Test Mode Considerations

    The function of the CALL commands differ depending upon whether you are in active cell or test mode.

    In active cell mode, when you use the CALL commands to set the channel numbers, the test set's output frequency and receiver frequency are set. A message is also sent to the mobile station to set its frequency.

    However, in test mode, since the BSE does not send call processing information to the mobile station, the CALL commands only configure the test set's output frequency and receiver frequency. You need to also send the appropriate test mode commands to the mobile station to set it to the correct frequency.

    In test mode, instead of using the CALL commands to configure the test set's frequencies, you may prefer to manually control the RF generator and RF analyzer using the CALL:RFG and RFAN commands, respectively. In either case, you must still send the appropriate test mode commands to the mobile station to move it to the proper frequency.

Set Cell Power

To set the output power of the test set, use the following command:

Command to Set Cell Power
Command | Example
CALL:POW <num value> | CALL:POW -75

  • Active Cell and Test Mode Considerations

    You can use the CALL:POW command to set the cell power in both active cell and test mode. However, in test mode you may prefer to manually control the output power of the test set using the CALL:RFG commands.

Set Mobile Station Transmit Power

In active cell mode, use one of the following commands to set the mobile station transmit power level (depending upon which test application you are using):

Commands to Set Mobile Station Transmit Power
Command | Example | Technology
CALL:MS:TXL:<band mnemonic> <num value> | CALL:MS:TXL:DCS <num value> | GSM
CALL:SET:MS:<channel type mnemonic>:TXL:<band mnemonic> <num value> | CALL:SET:MS:DIG:TXL:PCS <num value> | AMPS/136
CALL:<channel mnemonic>:MS:TXL:<band mnemonic>:BURS <num value> | CALL:PDTCH:MS:TXL:DCS: BURS <num value> | GPRS/EGPRS

In addition to setting the mobile station transmit level, these commands also automatically configure the test set's receiver at the expected input level, whether in active cell or test mode. However, in test mode, you must also send the appropriate test mode commands to the mobile station to command it to output at the correct level. This is due to the fact that the BSE is not transmitting call processing commands to the mobile station.

  • Manually Setting Expected Power

    Sending the CALL commands in Commands to Set Mobile Station Transmit Power automatically sets the expected input level of the test set's receiver. However, there is another option for setting the receiver's input level in both active cell and test mode. It is often beneficial to manually set the expected input power level using the RFAN commands, rather than using the CALL commands.

    When you set the expected power manually, you tell the test set exactly what power level to expect. Whereas the CALL commands simply tell the test set the range of input level to expect, based on the definition of the mobile station power level (for example, an AMPS/136 mobile station transmitting at power level 3 has an output level in the range of +20 dBm to +26 dBm).

Set Up Additional Connection Parameters

Depending upon the test application you are using, there may be other connection parameters to specify, such as timeslot, timing advance, vocoder, or data rates and types.

In active cell mode, you may also choose to set up network parameters, such as base station identifier numbers (for example, SID) and color codes.

All of these parameters are configured using the CALL subsystem.


Step 3: Set Measurement Parameters

Step 3: Set Measurement Parameters

The following information provides additional details on Step 3 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you set up the conditions under which the measurements operate. You do this by configuring measurement parameters.

Contents

  • Measurement Parameters Overview
  • Generic Measurement Parameters
  • Measurement-Specific Measurement Parameters

Measurement Parameters Overview

There are two different types of measurement parameters:

  • Generic Measurement Parameters
  • Measurement-Specific Measurement Parameters

The SETup subsystem is used to configure measurement parameters. Each individual measurement parameter can be set and queried using the associated SETup subsystem command. The general hierarchy of the SETup subsystem command structure is as follows:

SETup:<measurement mnemonic>:<measurement parameter> <parameter setting/value>

NOTE
Not all measurements use all measurement parameters. Refer to the GPIB syntax listing for the detailed list of measurement parameters for individual measurements.

Generic Measurement Parameters

There are three types of generic measurement parameters:

  • Measurement Count (used by most measurements)
    Measurement Count State
    Measurement Count Number

  • Measurement Timeout (used by all measurements)
    Measurement Timeout State
    Measurement Timeout Time

  • Measurement Trigger (used by most measurements)
    Trigger Arm (used by all measurements)
    Trigger Source (not applicable to analog measurements)
    Trigger Delay (not applicable to analog measurements)

Measurement Count Parameters

The measurement count parameters control measurement averaging. The STATe command turns averaging on or off, and the NUMBer command determines the number of averages. The SNUMber command is a complex command which allows you to turn averaging on and set the number of averages in one command.

Statistical Measurement Results Parameters
Parameter | Command Syntax
Measurement Count State | SETup:<meas-mnemonic>:COUNt:STATe <ON|1|OFF|0>
Measurement Count Number | SETup:<meas-mnemonic>:COUNt:NUMBer <numeric value>
Measurement Count Number and State | SETup:<meas-mnemonic>:COUNt[:SNUMber] <numeric value>
Programming Example:

OUTPUT Test_set;"SET:DTXP:COUN 10"

sets the multi-measurement count state to ON and set the number of averages to 10 for the digital transmit power measurement.

Measurement Timeout Parameters

Measurement timeout parameters control the maximum time that a measurement executes. TIMe sets the amount of time and STATe determines if the timeout is in use. The STIMe command is a complex command which enables you to set both parameters in one command.

Measurement Timeout Parameters
Parameters | Command Syntax
Measurement Timeout Time and State | SETup:<meas-mnemonic>:TIMeout[:STIMe] <numeric value>[<suffix>]
Measurement Timeout State | SETup:<meas-mnemonic>:TIMeout:STATe <ON|1|OFF|0>
Measurement Timeout Time | SETup:<meas-mnemonic>:TIMeout:TIME <numeric value>[<suffix>]
Programming Example:

OUTPUT Test_set;"SET:DTXP:TIM 10"

sets the measurement timeout state to ON and set the measurement timeout time to 10 seconds for the digital transmit power measurement.

Measurement Trigger Parameters

There are three measurement trigger parameters. They control the arming of a measurement, the source of the trigger, and the trigger's delay.

  • The trigger arm parameter determines whether the test set makes one measurement and then stops (single), or automatically re-arms upon completion of one measurement and repeats the process (continuous). The recommended setting when writing a control program is single (CONTinuous OFF).

  • The trigger source parameter selects the source of the measurement trigger signal. The recommended Trigger Source setting when writing a control program is AUTO.

NOTE
Trigger source is always IMMediate for analog measurements and cannot be changed by the user.

  • The trigger delay parameter controls the delay between the trigger event (the point in time at which the trigger signal is received) and the start of sampling. Negative values indicate that the sampling should occur prior to the trigger event.

NOTE
Trigger delay is not applicable to analog measurements.

Measurement Trigger Parameters
Parameter | Command Syntax
Trigger Arm | SETup:<meas-mnemonic>:CONTinuous <ON|1|OFF|0>
Trigger Source | SETup:<meas-mnemonic>:TRIGger:SOURce <AUTO|IMMediate|PROTocol|RISE>
Trigger Delay | SETup:<meas-mnemonic>:TRIGger:DELay <numeric value>[<suffix>]

NOTE
You can set the Trigger Arm for all measurements to single (CONTinuous OFF) using the following command syntax:

SETup[:ALL]:CONTinuous:OFF

Programming Example:

OUTPUT Test_set;"SET:CONT:OFF"

sets the trigger arm to single for all measurements.

Programming Example:

OUTPUT Test_set;"SET:DTXP:TRIG:SOUR AUTO"

sets the trigger source to AUTO for the digital transmit power measurement.

Programming Example:

OUTPUT Test_set;"SET:DTXP:TRIG:DEL 10 US"

sets the trigger delay to 10 microseconds for the digital transmit power measurement.

Measurement-Specific Measurement Parameters

Measurement-specific measurement parameters set up operating conditions for a specific measurement. For example:

  • Setting the channel power measurement speed in IS-2000
  • Setting ORFS frequency offsets in GPRS
  • Setting number of bits for the FBER measurement in GSM

Refer to the GPIB syntax listing for the detailed list of measurement parameters for individual measurements.

Programming Example:

OUTPUT Test_set;"SET:CPOW:MSP FAST"

sets the IS-2000 channel power measurement speed to fast.

Programming Example:

OUTPUT Test_set;"SET:ORFS:SWIT:FREQ 400 KHZ"

sets the first ORFS offset to 400 kHz.

Programming Example:

OUTPUT Test_set;"SET:FBER:COUN 10000"

sets the number of fast BER bits to test to 10,000 bits.

Program Example Setting Both Generic and Measurement-Specific Measurement Parameters

! Set trigger arm to single for all measurements:
!
OUTPUT Test_set;"SET:CONT:OFF"
!
! *****************************************************
! Configure Modulation Accuracy Measurement:
!
OUTPUT Test_set;"SET:MACC:COUN 5"
! Example of using a complex command to set both the
! measurement count state and number at the same time.
!
OUTPUT Test_set;"SET:MACC:TRIG:SOUR AUTO"
! Sets trigger source to auto.
!
OUTPUT Test_set;"SET:MACC:TIM 15"
! Sets timeout state to ON and time to 15 sec.
!
OUTPUT Test_set;"SET:MACC:EVM10:STAT ON"
! Turns the EVM10 State ON
!
! ******************************************************
! Configure Digital TX Power Measurement:
!
OUTPUT Test_set;"SET:DTXP:COUN 5"
OUTPUT Test_set;"SET:DTXP:TRIG:SOUR AUTO"
OUTPUT Test_set;"SET:DTXP:TIM 5"
!
! ******************************************************
! Configure Frequency Stability Measurement:
!
OUTPUT Test_set;"SET:FST:COUN 3"
OUTPUT Test_set;"SET:FST:TIM 10"
!
! ******************************************************
! Configure Analog TX Power Measurement:
!
OUTPUT Test_set;"SET:ATXP:COUN 5"
OUTPUT Test_set;"SET:ATXP:TRIG:SOUR AUTO"
OUTPUT Test_set;"SET:ATXP:TIM 15"


Step 4: Make Connection

Step 4: Make Connection

The following information provides additional details on Step 4 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you make a connection between the mobile station and test set. How you do this depends upon whether you are in active cell or test mode. In active cell mode you establish a phone call between the test set and mobile station. In test mode, you command the mobile station to synchronize to the test set's signal and begin transmitting back an appropriate signal.

Contents

  • Establish a Call in Active Cell Mode
  • Make a Test Mode Connection

Establish a Call in Active Cell Mode

To test a mobile station in active cell mode, you must first establish a call between the test set and mobile station. Your control program must issue the commands necessary to initiate the call connection process, either to the test set (for a base station originated call) or to the mobile station (for a mobile station originated call). Your control program must then determine when the call has successfully connected so that it can proceed to testing. The control program must also determine if the call has not been successfully connected so that it can take appropriate action.

Call States

At any instant in time a call can be in a stable state such as the idle or the connected state, or in one of many transitory states such as alerting, handoff, registering, releasing or paging. These are referred to as transitory states because the amount of time which the call can spend in any of these states is limited by the mobile station's protocol. The call is not allowed to stay in a transitory state indefinitely.

NOTE
If repeat paging or repeat registration are on, it is possible for the call process to stay in one of the transitory states beyond the time specified by the mobile station's protocol timers.

Call Connection Synchronization Commands

The test set has a set of commands designed specifically for call connection and release synchronization.

Call Connection Synchronization Commands
Synchronization Command | Command Syntax
Call-Connected-State Query | CALL:CONNected[:STATe]?
Call-State-Change Detector Arm | CALL:CONNected:ARM[:IMMediate]
Call-State-Change Detector Timeout | CALL:CONNected:TIMeout

  • Call-Connected-State Query

    The CALL:CONN? query allows the control program to determine if a call is in the connected state or in the idle state.

    Responses Returned by the CALL:CONN? Query
    Response | Meaning
    1 | The call is in the connected state.
    0 | The call is in the idle state.

    If the call is in one of the transitory states, the query waits until the call reaches the idle state or connected state before returning a value.

  • Call-State-Change Detector Arm Command

    The test set has a call-state-change detector which can be used to temporarily hold the response to a CALL:CONN? query until the call state has moved from idle to connected or vice versa.

    Without the call-state-change detector, the CALL:CONN? query only hangs if the call is in a transitory state. Otherwise, it immediately returns a 1 or 0. Therefore, if a call connection process is started and the CALL:CONN? query is sent before the call state has transitioned from idle to one of the transitory states, the query immediately returns a 0. This indicates that the call is in the idle state (and therefore that the connection attempt failed). In reality, the call likely connected, but not until after the CALL:CONN? query immediately returned a 0.

    When the call-state-change detector is armed during a connection attempt, if the CALL:CONN? query is sent while the call state is still idle, the query waits until the state changes to connected, and then returns a 1.

    The CALL:CONNected:ARM[:IMMediate] command is used to arm this call-state-change detector.

  • Call-State-Change Detector Timeout Command

    If the call-state-change detector is armed and a call connection is attempted but the call state never changes from the idle state, the CALL:CONN? query hangs the bus. This easily happens if the mobile is badly broken, the mobile is not connected to the test set, or no one pushes the send button on the mobile.

    The CALL:CONNected:TIMeout command is used to set the timeout value for the call-state-change detector.

    The timeout timer is started whenever the call-state-change detector is armed, and should be set to the maximum amount of time the control program should wait between arming the detector and the beginning of the connection process (when the call state moves from the idle state). If the timer expires before the call state has moved from the idle or connected state, the call-state-change detector is disarmed, which releases the CALL:CONN? query if it is currently hanging.

Process for Making a Base Station Originated Call

Process for Making a Base Station Originated Call

NOTE
It is not necessary for you to send the CALL:CONN:TIM and CALL:CONN:ARM commands as they are automatically sent by the test set during a base station originated call or base station release.

Programming Example

OUTPUT Test_set;"CALL:PAG:PNUM `0000574016'"! Set paging number
OUTPUT Test_set;"CALL:PAG:REP ON" ! Set paging repeat state
OUTPUT Test_set;"CALL:ORIG" ! Start a base station originated call
OUTPUT Test_set;"CALL:CONN?"  ! Hanging GPIB query
ENTER Test_set;Call_connected      ! Program hangs here until
                                   ! origination passes or fails
IF NOT Call_connected THEN
   OUTPUT Test_set;"CALL:END"
! <put error handler here>
END IF
! Call is connected so proceed with control program

Process for Making a Mobile Station Originated Call

Process for Making a Mobile Station Originated Call

NOTE
The test set cannot originate a call from the mobile station. You must physically dial a number on the mobile station and press send, or send commands to a test bus built into the mobile station. For mobile station originated calls where the call is originated by physically dialing a number (as opposed to using a test bus) ensure that the call-state-change detector timeout time is long enough to allow the number to be dialed.

Programming Example

OUTPUT Test_set;"CALL:CONN:TIM 10"         ! Set timeout time to 10 seconds
OUTPUT Test_set;"CALL:CONN:ARM"            ! Arm the change detector
DISP "Initiate a call from the mobile"
OUTPUT Test_set;"CALL:CONN?"          ! Initiate a call connected state query
ENTER Test_set;Call_connected              ! Program hangs here until
                                           ! origination passes or fails
IF NOT Call_connected THEN
   OUTPUT Test_set;"CALL:END"
! <put error handler here>
END IF
! Call is connected.  Proceed with the control program.

Make a Test Mode Connection

To make a connection between the test set and mobile station in test mode, you must send the appropriate test mode commands to the mobile station to command it to synchronize to the test set's signal and begin transmitting.

You may also want to make a quick power measurement to ensure that the connection has been made.


Step 5: INITiate and FETCh Measurements

Step 5: INITiate and FETCh Measurements

The following information provides additional details on Step 5 of the Programming Flowchart. This information is applicable to all test applications.

Description

This step involves making measurements on the mobile station.

The test set has multiple signal paths and processors, which means you can make measurements concurrently and reduce test time. Making concurrent measurements involves starting a group of measurements, fetching the results of the measurements as they complete, and then verifying that the results are valid.

In this step you may also choose to make measurements in a more sequential way.

Contents

  • Concurrent Measurement Process
  • Alternative Measurement Process

Concurrent Measurement Process

Process for Making Concurrent Measurements

Start a Set of Concurrent Measurements

The INITiate command is used to start measurements. Each individual measurement can be started using the INITiate command. For starting measurements, the syntax of the INITiate command is as follows:

INITiate:<measurement mnemonic>[:ON]

More than one measurement can be started using a single INITiate command. For example:

OUTPUT Test_set;"INIT:TXP;PFER"

starts the transmit power measurement and the phase and frequency error measurement. These measurements then run concurrently.

Determine if a Measurement Is Done

Use the INITiate:DONE? query command to determine which measurement has completed.

This command is a query only and returns only one response per query. The responses returned and their meanings are shown in the following table:

Responses Returned from INITiate:DONE? Query
Response String | Meaning
<MEASUREMENT1 mnemonic> | MEASUREMENT1 is done.
<MEASUREMENT2 mnemonic> | MEASUREMENT2 is done.
WAIT | There are one or more measurements that are in progress, but none of those measurements are done yet.
NONE | No measurements are in progress.

Once a measurement is reported as being complete via the INITiate:DONE? query it is removed from the done list (it is not reported again). To use the INITiate:DONE? query properly, your control program should immediately fetch a measurement's results once it is reported as being complete.

Obtain a Set of Measurement Results

In order to minimize bus traffic and reduce test time, the test set's measurements are designed to return multiple measured values in response to a single measurement request.

For example, if a transmit power measurement with averaging is initiated there are five measurement results available. These are:

  1. Measurement integrity value
  2. Average value
  3. Minimum value
  4. Maximum value
  5. Standard deviation value

The test set can return the measurement results in a variety of formats to suit your needs using the FETCh? subsystem. The general structure of the FETCh? command is as follows:

FETCh:<measurement mnemonic>:<result format>?

For example, the transmitter power measurement results can be returned as:

Example FETCh? Result Formats
Command | Results Returned
FETC:TXP? | Measurement integrity and average value
FETC:TXP:POW:ALL? | Minimum, maximum, average and standard deviation values
FETC:TXP:POW:AVER? | Average value only
FETC:TXP:POW:MIN? | Minimum value only
FETC:TXP:POW:MAX? | Maximum value only
FETC:TXP:POW:SDEV? | Standard deviation value only
FETC:TXP:INT? | Measurement integrity value only
Concurrent Measurement Process Programming Example

! Start a Set of Concurrent Measurements:
!
OUTPUT Test_set;"INIT:TXP;PFER"
!
! Determine if a Measurement Is Done:
!
LOOP
  OUTPUT Test_set;"INIT:DONE?"
  ENTER Test_set;Meas_done$
!
! Obtain a Set of Measurement Results:
!
  SELECT Meas_done$
    CASE "TXP"
      OUTPUT Test_set;"FETC:TXP:POW?"
      ENTER Test_set;Avg_tx_power
    CASE "PFER"
      OUTPUT Test_set;"FETC:PFER:RMS?"
      ENTER Test_set;Max_rms_phas_er
  END SELECT
EXIT IF Meas_done$="NONE"
END LOOP

Validate Measurement Results

Validating measurement results is extremely important. The test set returns a result if it is capable of making a measurement, even if this result is obtained under adverse conditions.

The measurement integrity indicator is a measurement result and therefore is queried using the FETCh subsystem. A value of 0 indicates that the measurement is valid. A value other than 0 indicates that an error occurred during the measurement process.

Example Integrity Indicators
Value Returned | Description (message also appears on test set)
0 | Normal
1 | No Result Available
2 | Measurement Timeout
5 | Over Range
6 | Under Range
Programming Example

OUTPUT Test_set;"FETC:DTXP?"
ENTER Test_set;Integrity,Avg_dig_pow
IF Integrity=0 THEN
   PRINT "AVG DIG POW= ";Avg_dig_pow
ELSE
   PRINT "DTXP Measurement Error"
   PRINT "DTXP Measurement Integrity is ";Integrity
END IF

Alternative Measurement Process

You may choose to test in a sequential way rather than use the concurrent measurement process.

For instance, instead of using the INIT:DONE? query to determine when a measurement is complete, you may choose to initiate a set of measurements and then simply fetch them sequentially.

Programming Example

OUTPUT Test_set; "INIT:DTXP;MACC"
OUTPUT Test_set; "FETC:DTXP:POW?"
ENTER Test_set;Avg_dig_pow
OUTPUT Test_set; "FETC:MACC:EVM[1]?"
ENTER Test_set;Max_EVM1

In this example, the test set starts both measurements at the same time. However, if the MACC measurement finishes first, the results are not fetched until the DTXP measurement finishes. Therefore, this process requires that you understand the order in which measurements will complete in order to optimize your testing speed.


Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Last updated: December 21, 2004

The following information provides additional details on Step 6 of the Programming Flowchart. This information is applicable to all test applications.

Description

After performing a set of measurements on the mobile station using the configuration established in step 2, you may want to change this configuration and test the mobile station again. This step involves changing testing conditions such as channel, mobile station transmit power level, or cell power.

Contents

  • Change Channels
  • Change Other Connection Parameters

Change Channels

In a manufacturing environment it is common to test a mobile station on more than one channel. Some or all of the tests may be performed on multiple channels, to verify the mobile station's performance in a range of operating frequencies.

Perform a Handoff (Handover) in Active Cell Mode

If you are operating in active cell mode, to change channels you perform a handoff (handover) to the new channel. The control program sends the commands to initiate the handoff (handover), and then determines whether the transition was successfully completed. This is accomplished using the CALL:STATus? query.

The CALL:STATus? query immediately returns the state of the call at the time the query is received.

Example Responses Returned from the CALL:STAT? Query
Response | Meaning
IDLE | The call is in the Idle state
ALER | The call is in the Alerting transitory state.
HAND | The call is in the Handoff transitory state.
PAG | The call is in the Paging transitory state.
CONN | The call is in the Connected state.

After issuing the commands to perform a handoff (handover), you should send the CALL:STAT? query to verify that the call is still connected before resuming testing.

Process for Performing a Handoff (Handover)

Test Mode Considerations

In test mode, you can either change the test set's frequencies by using the handoff (handover) commands, or directly control the RF generator and RF analyzer.

In either case, you must also send the appropriate test mode commands to the mobile station to move it to the new channel.

Change Other Connection Parameters

You may also choose to change the mobile station transmit power level or cell power, or other connection parameters such as timeslot or timing advance.


Step 7: End Connection

Step 7: End Connection

The following information provides additional details on Step 7 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you release the call (in active cell mode) or end the mobile station transmission (in test mode).

Contents

  • Release the Call in Active Cell Mode
  • End the Mobile Station Test Mode Transmission
  • Partially Preset the Test Set

Release the Call in Active Cell Mode

In active cell mode, you can release the call with the mobile station in one of two ways:

  • Release from the Base Station

  • Release from the Mobile Station

Releasing an Active Call from the Base Station

Process for Releasing an Active Call from the Base Station
Programming Example

OUTPUT Test_set;"CALL:END"        ! Initiate a base station release.
OUTPUT Test_set;"CALL:CONN?" 	 	! Send call connected state query.
ENTER Test_set;Call_connected     ! Program hangs here until state
                                  ! change or timer expires.
IF Call_connected THEN            ! Check if disconnection successful
! <put error handler here>
END IF
! Call is disconnected so proceed with control program

Releasing an Active Call from the Mobile Station

Process for Terminating an Active Call from the Mobile Station

NOTE
The test set cannot initiate a call disconnection from the mobile station. You must manually push the end button on the mobile station or send commands to a test bus built into the mobile station. For a mobile station release where the call is terminated by physically pushing a button on the phone (as opposed to using a test bus) ensure that the call-state-change-detector timeout time is long enough to allow the end button to be pushed.

Programming Example

OUTPUT Test_set;"CALL:CONN:TIM 5" !Set timeout time to 5 seconds.
OUTPUT Test_set;"CALL:CONN:ARM"   !Arm the change detector.
DISP "Terminate the call from the mobile station."
OUTPUT Test_set;"CALL:CONN?" !Initiate call connected state query.
ENTER Test_set;Call_connected     !Program hangs here until state
                                  !change or timer expires.
IF Call_connected THEN            !Check if disconnection successful.
! <put error handler here>
END IF
! Call is disconnected so proceed with control program

End the Mobile Station Test Mode Transmission

In test mode, you must send the necessary test mode commands to end the mobile station transmission.

Partially Preset the Test Set

At this point, it is good practice to partially preset the test set by sending the SYST:PRES3 command. This command stops all measurement and call processing processes, but does not reset all values to default.


Getting Started with Programming

Getting Started with Programming

The test set is programmable through a GPIB (General Purpose Interface Bus) located on the rear panel.

A general approach to setting up a connection and obtaining measurement results programmatically is provided in the Programming: Getting Started Guide for W-CDMA Mobile Test . The guide gives an overview of how to configure the test set's base station emulator, perform key call processing operations, and perform measurements. The guide is built around a complete control program for testing a wireless device in a manufacturing environment. To download this complete control program, click here: Control Program Example .

For details on programming a specific measurement, see Programming Examples for Individual Measurements .

For details on synchronizing your test set, wireless device, and control program, see Test System Synchronization .

For details on any specific GPIB command, see GPIB Commands .

TO RETURN TO THE MAIN PROGRAMMING PAGE, click here: Programming .


wcdma_prog_getting_started_flowchart

Programming: Getting Started Guide for
W-CDMA Mobile Test

Introduction

Last updated: December 21, 2004

The Getting Started Guide is organized around the basic set of tasks a control program normally performs when testing a mobile station in a manufacturing environment.

Click on any step in the flowchart below to learn more about how to program the Agilent Technologies 8960 to perform these tasks.

Programming Flowchart

  • Step 1: Set Up the Test Set
  • Step 2: Configure Test Set and UE Parameters
  • Step 3: Set Measurement Parameters
  • Step 4: Make a Connection
  • Step 5: INITiate and FETCh Measurements
  • Step 6: Reconfigure Test Set and UE Connection Parameters
  • Step 7: End the Connection

You can also use the buttons on each page to navigate between steps, return to the flowchart, or to find more detailed information about each step.

Conventions used in this Getting Started Guide

Throughout this Getting Started Guide the term "test set" refers to an Agilent Technologies 8960 Series 10 wireless communications test set with the E1963A W-CDMA mobile test application installed.

UE refers to W-CDMA user equipment like a mobile station, for example.

The variable Testset used in the steps of the Getting Started Guide refers to the test set's GPIB address.

About the Programming Examples Presented in this Guide

Programming Language:

Programming examples presented in this guide are written in the HP BASIC programming language, also known as RMB or Rocky Mountain BASIC. The use of HP BASIC is not an endorsement of the HP BASIC product.

Line Numbers

All of the programming examples in the guide with line numbers are sections from a control program example available on-line for you to download.

Code that is not part of the download control program example does not have line numbers. This code may represent an alternate method of performing the task or may illustrate a feature not used by the control program example.

Syntax used in Programming Examples:

  • The programming examples use the shortened form of the command syntax to minimize GPIB bus transactions. The shortened form of a command is defined by use of capital letters in the command syntax. For the command syntax:

 RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO?

    the shortened form would be:

 RFAN:CONT:MEAS:FREQ:AUTO?
  • The programming examples do not include optional nodes. Optional nodes in the command syntax are defined by enclosing the node inside the [ ] brackets. For example, the command syntax:

 CALL[:CELL]:POWer[:SAMPlitude] -80dBm

    appears in the programming examples as:

 CALL:POW -80dBm

  • Programming examples make extensive use of compound commands using the ; and the ;: separators. Refer to the on-line information for the definition and use of these command separators.

Complex Commands

Complex commands are used to configure the state and assign values to parameters simultaneously. Complex commands can be used to save programming steps and minimize GPIB bus transactions.

  • The syntax below turns the state of the parameter on.

    OUTPUT Test_set;"SET:DTXP:TIM:STAT ON"

  • The syntax below is used to assign a value to the parameter.

    OUTPUT Test_set;"SET:DTXP:TIM:STAT 10 S"

  • Both of the above actions can be accomplished with one syntax command:

    OUTPUT Test_set;"SET:DTXP:TIM:STAT 10 S"

    The command above sets the parameter state to ON and the value of the parameter to 10 seconds. Note that in this example the optional command mnemonic :STIMe has been included to clarify that this complex command was used to set both the state and the value.

  • This command can be shortened further by removing the optional command mnemonic :STIMe, as shown below.

    OUTPUT Test_set;"SET:DTXP:TIM 10 S"

    This is the format that will be used throughout this guide.


Step 1: Set Up the Test Set

Step 1: Set Up the Test Set

In this step you initialize the test set and set up general operating conditions.

  • Initialize the Test Set
  • Set Up General Operating Conditions

Initialize the Test Set

Fully Preset the Test Set

It is important to start each production session with the test set in a known state. Sending the *RST command resets all parameters to their default values, ends all measurement processes, and sets all measurement triggers to single.

Clear the Error Queue

At the start of each production session it is useful to clear the error queue so that you know any messages logged are relevant to the current production session.

Programming Example

210   OUTPUT Testset;"*RST"
220   OUTPUT Testset;"*CLS"

Set Up General Operating Conditions

Turn Debugger On

The debugger is useful while you are developing code. When it is on, the test set alerts you when you send an incorrect command. You should turn it off once your code is complete.

Set Operating Mode

There are four operating modes available: Active Cell, FDD Test Mode, CW Mode, or Cell Off Mode.

Some cell and connection parameters can not be set unless the operating mode is set to Cell Off.

Set Amplitude Offsets

You can account for path loss in your system by setting amplitude offsets. You can specify up to 20 frequency/amplitude pairs.

Programming Example

230   OUTPUT Testset;"SYST:COMM:GPIB:DEB ON"
240   OUTPUT Testset;"CALL:OPER:MODE OFF"
250   OUTPUT Testset;"SYST:CORR:FREQ 2000MHZ"
260   OUTPUT Testset;"SYST:CORR -1"


Step 2: Configure Test Set and UE Parameters

Step 2: Configure Test Set and UE Parameters

In this step you configure the parameters that allow a connection to be made between the test set and UE.

  • Set up the Cell Parameters
  • Set Generator Info Parameters
  • Set Uplink Parameters
  • Set up Call Parameters
  • Set Uplink Channel Levels
  • Set up Call Control

Set up the Cell Parameters

The example below illustrates how to set up the cell parameters. You can set cell parameters like the MCC, MNC, and LAC as well as specify whether single or repeat paging should be used when paging the UE.

The operating mode must be Cell Off to set up the cell parameters. See Set Operating Mode . If you do not set the operating mode to Cell Off, the test set generates the following error:

Command Rejected. Change Not Allowed in Active Cell Mode.

320   ! Cell Parameters
330   OUTPUT Testset;"CALL:LAC 30865" !Correct LAC avoids Location Update
340   OUTPUT Testset;"CALL:MCC 234"
350   OUTPUT Testset;"CALL:MNC 56"
360   OUTPUT Testset;"CALL:PAG:REP:STAT:WCDMA ON

Set Generator Info Parameters

There are several downlink physical channels and an AWGN (Additive White Gaussian Noise) source which you can configure. You can set the power level of each physical channel (relative to cell power) and the absolute power level of the AWGN source. You can also specify that these channels use different power levels once an Active Cell connection has been established. For some of the physical channels you can also specify the channelization code. The downlink channel codes and levels required the operating mode be set to Cell Off for configuring.

370   ! Generator Info
380   !   -Downlink Channel Codes
390   OUTPUT Testset;"CALL:SCOD:PRIM 0"
400   OUTPUT Testset;"CALL:SRB:CCH:DED:BPS3400:CCOD CODE12"
410   OUTPUT Testset;"CALL:CCPC:SEC:CCOD CODE7"
420   OUTPUT Testset;"CALL:PICH:CCOD CODE16"
430   OUTPUT Testset;"CALL:AICH:CCOD CODE10"
440   OUTPUT Testset;"CALL:DPCH:RMC12:CCOD CODE9"
450   !   -Downlink Channel Levels
460   OUTPUT Testset;"CALL:CPIC -4.8"
470   OUTPUT Testset;"CALL:CCPC:PRIM -7.1"
480   OUTPUT Testset;"CALL:CCPC:SEC -6.9"
490   OUTPUT Testset;"CALL:PICH -9.9"
500   OUTPUT Testset;"CALL:AICH -9.9"
510   OUTPUT Testset;"CALL:DPCH -12"
520   !   -Connected DL Channel Levels
530   OUTPUT Testset;"CALL:CONN:CPIC -3.3"
540   OUTPUT Testset;"CALL:CONN:CCPC:PRIM -5.35"
550   OUTPUT Testset;"CALL:CONN:PICH -20" !Change PICH to give OCNS
560   OUTPUT Testset;"CALL:CONN:DPCH -10.3"
570   !   -AWGN Power
580   OUTPUT Testset;"CALL:AWGN:POW:STAT OFF"

Set Uplink Parameters

The example below illustrates how to configure the PRACH and how to indicate what primary scrambling code the UE is using. The operating mode must be Cell Off to set these parameters.

590   ! Uplink Parameters
600   OUTPUT Testset;"CALL:UPL:PRAC:POW:STEP 3"
610   OUTPUT Testset;"CALL:UPL:PRAC:SIGN 0"
620   OUTPUT Testset;"CALL:UPL:PRAC:SCOD 0"
630   OUTPUT Testset;"CALL:UPL:DPCH:SCOD 0"

Set up Call Parameters

You must set the frequency at which the downlink will transmit, by specifying either the UARFCN or the frequency.

You must indicate to the 8960 at what frequency the UE will transmit. (Unlike other technologies, in W-CDMA the uplink channel is not automatically determined based on the downlink channel. The offset between the uplink and downlink may vary based upon which band class you are operating in. So, you must specify the uplink frequency.) You can specify the expected uplink frequency by UARFCN or by frequency.

You can specify the downlink DPCH type (such as 12.2k RMC) and data type (such as PRBS15).

650   ! Call Parameters
660   OUTPUT Testset;"CALL:POW ";Rf_level
670   OUTPUT Testset;"CALL:DPCH:TYP RMC12"
680   OUTPUT Testset;"CALL:CHAN 10563"
690   OUTPUT Testset;"CALL:UPL:CHAN 9613"
700   OUTPUT Testset;"CALL:DTCH:DATA PRBS15"
710   OUTPUT Testset;"CALL:SRB:CCH:DED:DRAT BPS3400"

Set Uplink Channel Levels

As the example below illustrates, you can specify which closed loop power control bit sequence is sent on the downlink DPCCH.

It is important for you to specify what uplink power level the test set should expect by setting the MS Target Power. (In Active Cell mode, this command forces the UE to the specified output power. In FDD Test Mode, since the 8960 is not performing active closed loop power control of the uplink, this command does not change the UE's output power.) Setting the MS Target Power automatically sets the receiver's expected power accordingly.

720   ! Uplink Channel Levels
730   OUTPUT Testset;"CALL:CLPC:UPL:MODE ACT"
740   OUTPUT Testset;"CALL:MS:POW:TARG 0 DBM"

Set up Call Control

Finally, for performing the test set originated connection in Step 4: Make a Connection , you specify the UE's IMSI and change the operating mode back to Active Cell.

750   ! Call Control
760   OUTPUT Testset;"CALL:PAG:IMSI `1234567890'"
770   OUTPUT Testset;"CALL:OPER:MODE CALL"


Step 3: Set Measurement Parameters

Step 3: Set Measurement Parameters

In this step you set up measurement parameters. This configures the measurements so that they are ready to execute in Step 5: INITiate and FETCh Measurements .

Many of the measurements have only generic measurement parameters available, such as measurement count, timeout, trigger arm and trigger source.

There is a command available to set all measurement triggers to single ( SET:CONT:OFF ), which is the recommended trigger arm configuration for remote use of the test set. However, if you sent the *RST command in Step 1: Set Up the Test Set , all measurement triggers will already be set to single.

Some measurements have measurement-specific parameters available. Consult the programming reference material available on the Internet to find out more about measurement-specific parameters.

Programming Example

830   ! Set all measurement triggers to single
840   OUTPUT Testset;"SET:CONT:OFF"
850   ! Set up the Thermal Power measurement
860   OUTPUT Testset;"SET:WTP:TIM 7;COUN 1"
870   ! Set up the Channel Power measurement
880   OUTPUT Testset;"SET:WCP:TIM 7;COUN 1"
890   OUTPUT Testset;"SET:WCP:INT:TIME .667 MS"
900   OUTPUT Testset;"SET:WCP:FILT ON" ! Turn the RRC filter on
910   ! Set up the Waveform Quality measurement
920   OUTPUT Testset;"SET:WWQ:TIM 7;COUN 1;TSL 1"
930   ! Set up the ACLR measurement
940   OUTPUT Testset;"SET:WACL:TIM 7;COUN 1"
950   ! Set up the Loopback BER measurement
960   OUTPUT Testset;"SET:WBER:TIM 7;COUN 10000"
970   ! Set up the Occupied Bandwidth measurement
980   OUTPUT Testset;"SET:WOBW:TIM 7;COUN 1"
990   ! Set up the Spectrum Emission Mask measurement
1000  OUTPUT Testset;"SET:WSEM:TIM 7;COUN 1"


Step 4: Make a Connection

Step 4: Make a Connection

In this step you establish communication between the test set and user equipment such that measurements can be made. There are two possible ways to make a connection with the UE.

  • Originating a Connection from the Test Set
  • Make a Connection using Test Mode Commands

Originating a Connection from the Test Set

The code below illustrates how to make a connection by originating a call from the test set and taking advantage of the repeat paging feature to decrease connection speed.

Origination is performed in a subroutine to allow the use of a timeout separate from the control program's GPIB timeout. This is necessary because the use of repeat paging prevents the use of the state change detector and it's associated timeout (activated by the CALL:CONN? hanging query). Therefore, to prevent GPIB bus from hanging indefinitely, which could occur if the UE is not turned on or badly broken, a timeout is implemented in the subroutine on line 2790. The :SEQ sequential command is appended to the CALL:ORIG command to prevent subsequent commands from being accepted by the test set before repeated pages can be used to originate a connection.

1060  PRINT "Turn the UE on now."
1070  Originate ! Subroutine to originate a connection

2810  SUB Originate
2820    COM /Address/ INTEGER Testset
2830    ON TIMEOUT 7,10 CALL Orig_failed
2840    OUTPUT Testset;"CALL:ORIG:SEQ"
2850    OUTPUT Testset;"CALL:CONN?"
2860    ENTER Testset;Connected
2870    IF NOT Connected THEN
2880      PRINT "Call origination not successful."
2890      STOP
2900    END IF
2910  SUBEND

If the origination fails

By using repeat paging, a situation has been introduced in which the test set will not respond to subsequent GPIB commands until the origination is successful. Once the origination attempt has timed out, it becomes necessary to send the test set a Device Clear remote command (IEEE 488.2 Section 6.1.4.2.6) to free up the remote user interface. In HP BASIC this is the CLEAR command, see line 1900. Subsequently, you can send the CALL:END command to stop paging the UE and proceed with the control program.

1920  SUB Orig_failed
1930    COM /Address/ INTEGER Testset
1940    CLEAR Testset
1950    OUTPUT Testset;"CALL:END"
1960    PRINT "Origination failed. Check conditions and run again."
1970    STOP
1980  SUBEND

Make a Connection using Test Mode Commands

When the test set is operating in FDD Test Mode, you do not send any commands to the test set for this step. The test set should already be properly configured and transmitting its downlink signal so that the UE can detect and synchronize to it. In this step you either implement a pause in your program and wait for the UE to be manually configured and begin transmitting, or send appropriate test mode commands to configure the UE and begin its transmission.

The method used to synchronize the UE with the test set is proprietary to the UE manufacturer. The test set has no direct control of synchronization when the UE is operating in test mode.


Step 5: INITiate and FETCh Measurements

Step 5: INITiate and FETCh Measurements

In this step you INITiate measurements, FETCh the results, and verify the results are valid.

  • INITiate a Set of Concurrent Measurements
  • FETCh Measurement Results

INITiate a Set of Concurrent Measurements

The test set is capable of performing concurrent measurements. To start the measurement process you INITiate a set of concurrent measurements.

1190    OUTPUT Testset;"INIT:WBER;WTP;WWQ;WACL;WOBW;WSEM"
1200    Fetch_results! Go to a subroutine to handle the results

FETCh Measurement Results

To retrieve measurement results as they complete, you must set up a loop using the INIT:DONE? query. Depending upon the output of the query, the program will either wait for a measurement to complete, FETCh the result of a completed measurement, or continue the program once all measurements are complete. Once a measurement result is FETChed, you should check its integrity indicator to verify that the result is valid.

1990  SUB Fetch_results
2000    COM /Address/ INTEGER Testset
2010    REPEAT
2020      OUTPUT Testset;"INIT:DONE?"
2030      ENTER Testset;Measdone$
2040      SELECT Measdone$
2050      CASE "WTP"
2060        OUTPUT Testset;"FETC:WTP:INT?;POW?"
2070        ENTER Testset;Integrity,Power
2080        IF Integrity=0 THEN
2090          Print_results(Measdone$,Power)
2100        ELSE
2110          Meas_error(Measdone$,Integrity)
2120        END IF
2130      CASE "WCP"
2140        OUTPUT Testset;"FETC:WCP:INT?;POW?"
2150        ENTER Testset;Integrity,Power
2160        IF Integrity=0 THEN
2170          Print_results(Measdone$,Power)
2180        ELSE
2190          Meas_error(Measdone$,Integrity)
2200        END IF
2210      CASE "WWQ"
2220        OUTPUT Testset;"FETC:WWQ?"
2230        ENTER Testset;Integrity,Evm,Ferr,Ooff,Perr,Merr
2240        IF Integrity=0 THEN
2250          Print_results(Measdone$,Evm,Ferr,Ooff,Perr,Merr)
2260        ELSE
2270          Meas_error(Measdone$,Integrity)
2280        END IF
2290      CASE "WACL"
2300        OUTPUT Testset;"FETC:WACL:INT?;AVER?"
2310        ENTER Testset;Integrity,Negfive,Posfive,Negten,Posten
2320        IF Integrity=0 THEN
2330          Print_results(Measdone$,Negfive,Posfive,Negten,Posten)
2340        ELSE
2350          Meas_error(Measdone$,Integrity)
2360        END IF
2370      CASE "WBER"
2380        OUTPUT Testset;"FETC:WBER?"
2390        ENTER Testset;Integrity,Ber
2400        IF Integrity=0 THEN
2410          Print_results(Measdone$,Ber)
2420        ELSE
2430          Meas_error(Measdone$,Integrity)
2440        END IF
2450      CASE "WOBW"
2460        OUTPUT Testset;"FETC:WOBW?"
2470        ENTER Testset;Integrity,Obw
2480        IF Integrity=0 THEN
2490          Print_results(Measdone$,Obw)
2500        ELSE
2510          Meas_error(Measdone$,Integrity)
2520        END IF
2530      CASE "WSEM"
2540        OUTPUT Testset;"FETC:WSEM?"
2550        ENTER Testset;Integrity,Overall,Pow,Range1,Range2,Range3,Range4
2560        IF Integrity=0 THEN
2570          Print_results(Measdone$,Overall)
2580        ELSE
2590          Meas_error(Measdone$,Integrity)
2600        END IF
2610      END SELECT
2620    UNTIL Measdone$="NONE"
2630  SUBEND


Step 6: Reconfigure Test Set and UE Connection Parameters

Step 6: Reconfigure Test Set and UE Connection Parameters

In this step you change characteristics of the link between the test set and UE differently depending on your test set operating mode.

  • Reconfigure the Connection when using Active Cell
  • Reconfigure the Connection when using Test Mode

Reconfigure the Connection when using Active Cell

The example below illustrates how to change the downlink and uplink channels. The process used to reconfigure the connection is to first change the parameter settings with CALL:SET commands. These new parameters are activated when the CALL:HAND command is sent. The CALL:STAT? query is used to ensure the call is still connected. If the connection is compromised, the subroutine Dropped_call is called.

1260  !Use deferred commands to set up new channels
1270    OUTPUT Testset;"CALL:SET:CHAN:DOWN 10526"
1280    OUTPUT Testset;"CALL:SET:CHAN:UPL 9626"
1290    OUTPUT Testset;"CALL:HAND:PCR" ! Executes the handoff
1300    OUTPUT Testset;"CALL:STAT?" ! Verify the handoff success
1310    ENTER Testset;Call_state$
1320    IF Call_stat$<>"CONN" THEN Dropped_call

Reconfigure the Connection when using Test Mode

If you change the test set configuration, such as downlink frequency or primary scrambling code, you must configure the test set and then allow the user equipment to find the new configuration and synchronize to it before proceeding with measurements. It is not necessary to use the CALL:HAND command used when the UE is on an active call.


Step 7: End the Connection

Step 7: End the Connection

You can end the connection in one of two ways:

  • Ending the Connection from the Test Set
  • Ending the Connection from the UE

Ending the Connection from the Test Set

The CALL:END command is used to end the connection. Here you use the CALL:CONN? query for call synchronization. This query returns a 0 if the call ended successfully and a 1 if the call is not ended.

1390  OUTPUT Testset;"CALL:END"
1400  OUTPUT Testset;"CALL:CONN?"
1410  ENTER Testset;Callstate
1420  IF Callstate=1 THEN
1430    PRINT "Make sure the phone has released the call."
1440    OUTPUT Testset;"SYST:PRES3"
1450  END IF

Ending the Connection from the UE

Because the connection is being ended from the UE, it is important to set a timeout value and arm the change detector. More information about using these commands to achieve call synchronization is available in the additional details about this step available on the Internet.

OUTPUT Testset;"CALL:CONN:TIM 5" !Set timeout time to 5 seconds.
OUTPUT Testset;"CALL:CONN:ARM"   !Arm the change detector.
DISP "Terminate the call from the mobile station."
OUTPUT Testset;"CALL:CONN?" !Initiate call connect state query.
ENTER Testset;Call_connected     !Program will hang here until state
                                  !change or timer expires.
!Check if disconnect successful.
IF Call_connected THEN OUTPUT Testset;"SYST:PRES3"


Programming an Inner Loop Power Measurement

Programming an Inner Loop Power Measurement

This section provides an example of how to make inner loop power measurements via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is transmitting an uplink signal.

The basic procedure to test inner loop power is as follows:

  1. Set up the inner loop power measurement parameters as desired using the SETup:WILPower commands.
  2. Use the INITiate:WILPower command to start the measurement.
  3. Use the FETCh:WILPower? query to obtain the measurement results.

Programming Example

10    RE-SAVE "c:\temp\programs\ilp_example"
20    CLEAR SCREEN
30    !Select which test segment to test (or Manual mode)
40    OUTPUT 714;"SETup:WILPower:SEGMent A"
50    !Select the number of timeslots to test
60    OUTPUT 714;"SETup:WILPower:NSLots S15"
70    !Initiate Inner Loop Power control test
80    OUTPUT 714;"INITiate:WILPower"
90    !Query all Inner Loop Power control test results
100   OUTPUT 714;"FETCh:WILPower?"
110   !Read back all Inner Loop Power control test results
120   ENTER 714;Integrity,Pf,Wcslot1,Abspow1,Relpow1,Wcslot2,Abspow2,Relpow2
130   PRINT "Integrity Indicator = ";Integrity
140   PRINT "Pass/Fail results = ";Pf
150   PRINT "Worst case slot number for adjacent timeslot measurements = ";Wcslot1
160   PRINT "Absolute power level for adjacent timeslot measurements = ";Abspow1
170   PRINT "Relative power level for adjacent timeslot measurements = ";Relpow1
180   PRINT "Worst case slot number for 10 TPC measurements = ";Wcslot2
190   PRINT "Absolute power level for 10 TPC measurements = ";Abspow2
200   PRINT "Relative power level for 10 TPC measurements = ";Relpow2
210   END

Returned Values

See FETCh:WILPower

Related Topics

  • Inner Loop Power Troubleshooting
  • Inner Loop Power Measurement Description
  • Manual Operation: How Do I Make an Inner Loop Power Measurement?
  • SETup:WILPower
  • INITiate
  • FETCh:WILPower
  • Amplitude Offset
  • Integrity Indicator


Invalid Measurement Results

Invalid Measurement Results

Description

Invalid measurement results are returned by the test set when conditions such as signal level are not within the present measurement range. Three different invalid measurement results are provided in order to help you understand the condition that caused the invalid result.

  • 9.9E+37 = INFinity (Infinity)
  • -9.9E+37 = NINF (Negative Infinity)
  • 9.91E+37 = NAN (Not A Number)

9.9E+37 (INFinity)

9.9E+37 is returned by the test set when the measurement is out of range and results are far above the present measurement range.

-9.9E+37 (NINFinity)

-9.91E+37 is returned by the test set when the measurement is out of range and results are far below the present measurement range.

9.91E+37 (NAN)

9.91E+37 is returned by the test set when the measurement is out of range but it can not be determined if measurement results are far above, or far below the measurement range.

If a measurement exceeds its measurement timeout value before a valid result is determined, 9.91E+37 is returned.

FETCH? and READ? Invalid Results

When a FETCH? or READ? query is performed on a measurement with invalid results, the integrity indicator returns a value of 1, indicating No Result Available.

Manual Users Invalid Results

Manual users will generally see four dashes , "----" on the test set display. When the measurement timeout value has been exceeded, "Measurement Timeout" is displayed as well as the four dashes.


Programming an IQ Tuning Measurement

Programming an IQ Tuning Measurement

This section provides an example of how to make IQ tuning measurements via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is transmitting an uplink signal.

The basic procedure to test IQ tuning is as follows:

  1. Set up the IQ tuning measurement parameters as desired using the SETup:WIQTuning commands.
  2. Use the INITiate:WIQTuning command to start the measurement.
  3. Use the FETCh:WIQTuning? query to obtain the measurement results.

Programming Example

10    RE-SAVE "c:\temp\programs\iqt_example"
20    CLEAR SCREEN
30    !Select which timeslot will be measured
40    OUTPUT 714;"SETup:WIQTuning:TSLot 14"
50    !Initiate the IQ tuning measurement
60    OUTPUT 714;"INITiate:WIQTuning"
70    !Query all IQ tuning measurement results.
80    OUTPUT 714;"FETCh:WIQTuning?"
90    !Read back all IQ tuning measurement results.
100   ENTER 714;Int,Rms_evm,Pk_evm,F_err,O_ofs,P_err,M_err,T_err,Pk_cd_err,Iq_gn_im,Iq_ph_im
110   PRINT "Integrity indicator = ";Int
120   PRINT "RMS error vector magnitude = ";Rms_evm
130   PRINT "Peak error vector magnitude = ";Pk_evm
140   PRINT "Frequency error = ";F_err
150   PRINT "Origin offset = ";O_ofs
160   PRINT "Phase error = ";P_err
170   PRINT "Magnitude error = ";M_err
180   PRINT "Timing error = ";T_err
190   PRINT "Peak code domain error = ";Pk_cd_err
200   PRINT "IQ gain imbalance = ";Iq_gn_im
210   PRINT "IQ phase imbalance = ";Iq_ph_im
220   END

Returned Values

See FETCh:WIQTuning .

Related Topics

  • IQ Tuning Measurement Troubleshooting
  • IQ Tuning Measurement Description
  • Manual Operation: How Do I Make an IQ Tuning Measurement?
  • SETup:WIQTuning
  • INITiate
  • FETCh:WIQTuning
  • Amplitude Offset
  • Integrity Indicator


Programming a Loopback Bit Error Ratio Measurement

Programming a Loopback Bit Error Ratio Measurement

This section provides an example of how to make loopback bit error ratio (BER) measurements via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector.

The basic procedure to test loopback BER is as follows:

  1. Set Uplink DTCH RMC CRC Presence to Present (see CALL:SERVice:RBTest:DTCHannel:CRC[:PRESence] ).
  2. Set UE Loopback Type to Type 1 (see CALL:MS:LOOPback:TYPE ).
  3. Set the loopback BER setup parameters as desired using the SETup:WBERror commands.
  4. Prompt the user to establish an RB Test Mode connection.
  5. Set UE Target Power and Cell Power as needed.
  6. Use the INITiate:WBERror command to start the measurement (see INITiate ).
  7. Use the FETCh:WBERror ? query to obtain the measurement results (or use the READ:WBERror[:ALL]? command to both initiate the measurement and fetch key measurement results as a sequential operation).

Programming Example

10     ! Loopback Bit Error Ratio Measurement Programming Example
20     !
30       Testset=714
40     !
50     !***Set up test parameters***
60     !
70       OUTPUT Testset;"CALL:SERVice:RBTest:DTCHannel:CRC:PRESence PRESent"
80          ! Set Uplink DTCH RMC CRC Presence to Present.
90       OUTPUT Testset;"CALL:MS:LOOPback:TYPE TYPE1"
100         ! Set UE Loopback Type to Type 1.
110     !
120     !***Set up measurement parameters***
130     !
140       OUTPUT Testset;"SETup:WBERror:COUNt 10000"
150         ! Set Number of Bits to Test to 10000.
160       OUTPUT Testset;"SETup:WBERror:CONTinuous OFF"
170         ! Set Trigger Arm to Single.
180       OUTPUT Testset;"SETup:WBERror:CONFidence 99.80"
190         ! Turn Confidence State On and set Confidence Level to 99.80%.
200       OUTPUT Testset;"SETup:WBERror:REQuirement 0.10"
210         ! Set BER Requirement to 0.10%.
220       OUTPUT Testset;"SETup:WBERror:CONFidence:DUTFactor 1.5"
230         ! Set Bad DUT Factor to 1.5.
240     !
250     !***Establish a connection***
260       PRINT "Establish an RB Test Mode connection between the UE and test set."
270       PRINT "Press F2 to continue."
280       PAUSE
290     !
300     !***Set up test parameters***
310     !
320       OUTPUT Testset;"CALL:MS:POWer:TARGet 21"
330         ! Set UE Target Power to +21 dBm.
340       OUTPUT Testset;"CALL:POWer -106"
350         ! Set Cell Power to -106 dBm.
360     !
370     !***INITiate and FETCh measurements***
380     !
390       OUTPUT Testset;"INITiate:WBERror"
400         ! INITiate the measurement
410       OUTPUT Testset;"FETCh:WBERror?"
420       ENTER Testset;Integ,Ber,Error_count,Bits_tested
430       OUTPUT Testset;"FETCh:WBERror:RATio:FAIL?"
440       ENTER Testset;Conf_test
450         ! FETCh and READ Loopback BER measurement results
460     !
470     !***Print measurement results***
480     !
490       CLEAR SCREEN
500       PRINT "Loopback BER Measurement Results:"
510       PRINT
520       PRINT "Integrity Indicator                   = ",Integ
530       PRINT "Bit Error Ratio (%)                   = ",Ber
540       PRINT "Bit Error Count                       = ",Error_count
550       PRINT "Bits Tested                           = ",Bits_tested
560       PRINT "Confidence Test Result                = ",Conf_test
570       PRINT "(0=Pass, 1=Fail, 2=Max Bits Tested)"
580     !
590       END

Related Topics

  • Loopback Bit Error Ratio Troubleshooting
  • Loopback Bit Error Ratio Measurement Description
  • How Do I Perform a Loopback BER Measurement?
  • Amplitude Offset
  • Integrity Indicator


Measurement Progress Report

Measurement Progress Report

Description

The measurement progress report is a query of how far along a multi-measurement cycle has progressed. When the multi-measurement count is greater than one, the measurement progress report will indicate the number of measurements that have completed. The returned value will be the last update and not the actual number, because the value is updated periodically and not for each multi-measurement cycle. Every measurement has the measurement progress report available.

Programming Example

OUTPUT 714;"FETCh:WACLeakage:ICOunt?" !Returns the approximate number of
    !Adjacent Leakage Ratio (ACLR) measurements completed while using
    !multi-measurements.

Related Topics

Statistical Measurement Results


Measurement Event Synchronization

Measurement Event Synchronization

Description

Measurement event synchronization saves time by controlling the communication between the controller, the test set, and the mobile station, so that no device does something before it is supposed to (which can cause errors or do something well after it could have). Because some measurements can run concurrently, it is necessary that the control program know when individual measurement results are available.

Measurement event synchronization is accomplished using the INITiate subsystem's command INITiate:DONE? or the STATus:OPERation:NMRReady status registers.

INITiate:DONE?

The INITiate:DONE? query returns a string that indicates what, if any, measurements are ready to be fetched. This query should be used inside a loop, checking each measurement that was initiated. See INITiate for more details about this query.

The INITiate:DONE? query returns at least one of the following indicators for each pass through the loop:

  • "AFAN" - The audio frequency analyzer measurement results are available.
  • "SMON" - The spectrum monitor measurement results are available.
  • "WACL" - The adjacent channel leakage measurement results are available.
  • "WBER" - The loopback bit error ratio measurement results are available.
  • "WCD" - The code domain measurement results are available
  • "WCP" - The channel power measurement results are available.
  • "WILP" - The inner loop power measurement results are available.
  • "WIQT" - The IQ tuning measurement results are available.
  • "WOBW" - The occupied bandwidth measurement results are available.
  • "WOOP" - The PRACH transmit On/Off power measurement results are available.
  • "WSEM" - The spectrum emission mask measurement results are available.
  • "WTP" - The thermal power measurement results are available.
  • "WWQ" - The waveform quality measurement results are available
  • "WAIT" - There are one or more measurements which are in the measuring state which are not excluded from the query. See INITiate:DONE:FLAG:<measurement mnemonic> . When WAIT is returned at least one measurement is not ready to be fetched yet.
  • "NONE" - There are no measurements currently in the measuring state. This assumes no measurements have been excluded. See INITiate:DONE:FLAG:<measurement mnemonic> . This would indicate that all measurements results are available or none have been initiated.

Programming Example

The following example assumes that the UE is transmitting and no measurements other than channel power (WCP) and waveform quality (WWQ) are being triggered. See Transition Filters .

10  OUTPUT 714;"SETup:WCPower:CONTinuous OFF" !Sets channel power
20                                            !trigger mode to single.
30  OUTPUT 714;"SETUP:WWQuality:CONTinuous OFF" !Sets waveform quality
40                                       !trigger mode to single.
50  OUTPUT 714;"INITiate:WCPower;WWQuality" !Begin channel power and
60                                      !waveform quality measurements.
70  REPEAT
80    OUTPUT 714;"INITiate:DONE?" !Queries the test set for
90                                !measurements that have completed
100   ENTER 714;Meas_done$ !String value representing DONE measurements,
110                      ! NONE if no measurements are done.
120   SELECT Meas_done$ !This variable will have a value of  WAIT until
130                   !a measurement is DONE.
140   CASE "WCP" !Characters must be upper case.
150     OUTPUT 714;"FETCH:WCPower?" !If this case is selected,
160             !channel power results are FETCHed.
170     ENTER 714;Integrity,Wcpower_meas
180     PRINT "Average Channel Power is ";Wcpower_meas
190   CASE "WWQ" !Characters must be uppercase.
200     OUTPUT 714;"FETCH:WWQuality:EVM?" !If this case is selected,
210             !the Max EVM measurement is FETCHed.
220     ENTER 714;Evm_meas
230     PRINT "Maximum Error Vector Magnitude is ";Evm_meas
240   END SELECT
250 UNTIL Meas_done$="NONE"   !When all triggered measurements have completed,
260                           !the INITiate:DONE? query returns NONE.
270 END

STATus:OPERation:NMRReady:FDD

The STATus:OPERation:NMRReady:FDD command allows the program to immediately branch to the next operation or command without continuing through a loop as in INITiate:DONE? See STATus:OPERation:NMRReady:FDD Register Bit Assignments for more details about this command.

You must enable the following so that as soon as the enabled NMRReady bit is true the program moves on.

  • Positive or negative transition filter. See Transition Filters .
  • STATus:OPERation:NMRReady:FDD bit for the measurement desired.
  • STATus:OPERation:NMRReady bit (1024 for FDD) for the required system. See STATus Subsystem Description or Description .
  • STATus:OPERation bit (512 for NMRReady).
  • Service Request Enabling (*SRE 128 for NMRReady).

The STATus:OPERation:NMRReady:FDD Register Bit Assignments status register provides status reporting on the following measurement completions:

  • Adjacent Channel Leakage Ratio
  • Channel Power
  • Code Domain
  • Loopback Bit Error Ratio
  • Occupied Bandwidth
  • Spectrum Emission Mask
  • Thermal Power
  • Waveform Quality

Operating Considerations

Only one indicator is returned per query.

All active measurements must be set to single trigger mode. This ensures that when a measurement completes it remains in the "DONE" state rather than restarting. Sending the "*RST" command at the beginning of the test code or using the "SETup:CONTinous:OFF" command during measurement setups are ways to set the trigger to single for all measurements.

Related Topics

INITiate Command Functions


Control Program Example

Control Program Example

HP BASIC

For your convenience we have combined the programming examples shown in the Getting Started Guide into one program. This program, written using HP BASIC, is a fully functional W-CDMA control program. You can use this as a starting point for developing your own program. Click on the link below entitled "Getting Started Guide Control Program Example" to view this program. The other programming example uses FDD Test Mode in the test set and requires test mode control of the UE.

  • Getting Started Guide Control Program Example
  • FDD Test Mode Control Program Example


Test System Synchronization

Test System Synchronization

  • Measurement Event Synchronization


Obtaining Measurement Results

Obtaining Measurement Results

  • Concurrent Measurements
  • Measurement Timeouts
  • Measurement Progress Report
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator
  • Invalid Measurement Results
  • Dealing With Semicolon Separated Response Data Lists


Programming an Occupied Bandwidth Measurement

Programming an Occupied Bandwidth Measurement

This section provides an example of how to make occupied bandwidth measurements via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is synchronized to the test set and is transmitting an uplink signal.

The basic procedure is as follows:

  1. Set the occupied bandwidth setup parameters as desired using the SETup:WOBWidth commands.
  2. Use the INITiate:WOBWidth command to start the measurement.
  3. Use the FETCh:WOBWidth? query to obtain the measurement results.

Programming Example

10    ! Set trigger mode to single for the Occupied Bandwidth meas
20    OUTPUT 714;"SETup:WOBWidth:CONTinuous OFF"
30    ! Set a timout value of 5 seconds and enable the timeout state
40    OUTPUT 714;"SETup:WOBWidth:TIMeout 5"
50    ! Set the trigger source to automatically select the appropriate
60    !  trigger
70    OUTPUT 714;"SETup:WOBWidth:TRIGger:SOURce AUTO"
80    ! Turn on multi-measurements and set the count number
90    OUTPUT 714;"SETup:WOBWidth:COUNt 5"
100   ! Initiate the Occupied Bandwidth measurement
110   OUTPUT 714;"INITiate:WOBWidth"
120   ! Fetch the integrity indicator and the statistical results of
130   !  the measurement
140   OUTPUT 714;"FETCh:WOBWidth:INTegrity?;BANDwidth:ALL?"
150   ENTER 714;Integrity,Min,Max,Avg,Sdev
160   ! Check the integrity indicator to ensure the results are valid
170   IF Integrity<>0 THEN
180     PRINT "Measurement failed."
190   ELSE
200   ! Process the measurement results.
210   END IF
220   END

Returned Values

  • Integrity stores the returned integrity indicator value (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Min returns the minimum occupied bandwidth result in MHz.
  • Max returns the maximum occupied bandwidth result in MHz.
  • Avg returns the average occupied bandwidth result in MHz.
  • Sdev returns the standard deviation of the occupied bandwidth results in MHz.

Related Topics

  • Occupied Bandwidth Troubleshooting
  • Occupied Bandwidth Measurement Description
  • SETup:WOBWidth
  • INITiate
  • FETCh:WOBWidth
  • Amplitude Offset
  • Integrity Indicator


Programming a PRACH Transmit On/Off Power Measurement

Programming a PRACH Transmit On/Off Power Measurement

This section provides an example of how to make PRACH transmit on/off power measurements via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector.

The basic procedure to test PRACH transmit on/off power is as follows:

  1. Set the PRACH transmit on/off power setup parameters as desired using the SETup:WOOPower commands.
  2. Use the INITiate:WOOPower commands to start the measurement.
  3. Use the FETCh:WOOPower? query to obtain the measurement results.

Programming Example

10   ! PRACH Transmit On/Off Power Measurement Programming Example
20   ! This example assumes that the UE is camped to the test set, and in idle mode.
30   ! (The test set must first be configured to allow the UE to camp to the
40   ! test set - sufficient cell power level, proper cell parameters etc.)
50   !
60       Testset=714
70   !
80   !***Set up test parameters***
90   !
100       OUTPUT Testset;"CALL:OPERating:MODE OFF"
110              ! Set operating mode to cell off
120       OUTPUT Testset;"CALL:UPLink:PRAChannel:PREambles:RCYCles 1"
130              ! Set number of PRACH Ramping Cycles to 1
140       OUTPUT Testset;"CALL:UPLink:PRAChannel:PREambles:NUMBer 3"
150              ! Set number of PRACH Preambles to 3
160       OUTPUT Testset;"CALL:UPLink:PRAChannel:ASUBchannels `000000000001'"
170              ! Set available subchannels to 1
180       OUTPUT Testset;"CALL:OPERating:MODE CALL"
190              ! Set operating mode to active cell
200    !
210    !***Set up measurement parameters***
220    !
230       OUTPUT Testset;"SETup:WOOPower:TIMeout 5"
240              ! Set timeout to 5 seconds
250       OUTPUT Testset;"SETup:WOOPower:OFF:POWer:LIMit -55"
260              ! Set the Off Power Limit to -55 dBm
270       OUTPUT Testset;"SETup:WOOPower:OPEN:LOOP:POWer:UPPer:LIMit 9"
280              ! Set the Open Loop Power Error Upper Limit to 9 dB
290       OUTPUT Testset;"SETup:WOOPower:OPEN:LOOP:POWer:LOWer:LIMit -9"
300              ! Set the Open Loop Power Error Lower Limit to -9 dB
310    !
320    !***INITiate and FETCh measurements***
330    !
340       OUTPUT Testset;"INITiate:WOOPower"
350              ! Initiate a PRACH transmit on/off power measurement
360       OUTPUT Testset;"FETCh:WOOPower?"
370              ! Fetch PRACH transmit power measurement results
380       ENTER Testset;Integrity,Pre_off_pow,Pre_off_pf,On_pow,
                            Ol_pow_err,Ol_pf,Post_off_pow,Post_off_pf
390              ! Read results
400    !
410    !***Print measurement results***
420    !
430       CLEAR SCREEN
440       PRINT "PRACH Transmit On/Off Power Measurement Results:"
450       PRINT
460       PRINT "Integrity Indicator                     = ",Integrity
470       PRINT "Pre Burst Off Power (dBm)               = ",Pre_off_pow
480       PRINT "Pre Burst Off Power Pass (0)/Fail (1)   = ",Pre_off_pf
490       PRINT "Burst On Power (dBm)                    = ",On_pow
500       PRINT "Open Loop Power Error (dB)              = ",Ol_pow_err
510       PRINT "Open Loop Power Error Pass (0)/Fail (1) = ",Ol_pf
520       PRINT "Post Burst Off Power (dBm)              = ",Post_off_pow
530       PRINT "Post Burst Off Power Pass (0)/Fail (1)  = ",Post_off_pf
540    !
550       END

Related Topics

  • PRACH Transmit On/Off Power Troubleshooting
  • PRACH Transmit On/Off Power Measurement Description
  • SETup:WOOPower
  • INITiate
  • FETCh:WOOPower
  • Amplitude Offset
  • Integrity Indicator


Programming a Swept Audio Measurement

Programming a Swept Audio Measurement

December 21, 2004

This section provides an example of how to make swept audio measurements via the GPIB.

The following example assumes that some device under test is connected between the test set's AUDIO OUT and AUDIO IN ports. The default audio level measurement, and the optional SINAD and distortion measurements, are performed at each frequency point in the sweep.

  1. Configure the swept audio measurement using the SETup subsystem.
  2. Start the measurement using the INITiate subsystem.
  3. Use the FETCh subsystem to obtain the audio analyzer's results for all points in the sweep.

Programming Example

10    OUTPUT 714;"SETup:SAUDio:FREQuency:STARt 300 Hz" !Start the frequency
20                                         !sweep at 300 Hz.
30    OUTPUT 714;"SETup:SAUDio:FREQuency:STOP 4 kHz" !Stop the frequency
40                                         !sweep at 4 kHz.
50    OUTPUT 714;"SETup:SAUDio:FREQuency:POINts 5"  !Make measurements at 5 frequencies
60                       !spaced evenly between the start and stop frequencies.
70    OUTPUT 714;"SETup:SAUDio:SETTling 1.5 ms" !Set a settling time of
80                                          !1.5 milliseconds.
90    OUTPUT 714;"SETup:SAUDio:VOLTage:AMPLitude 1 V" !SET the audio generator
100                                         !voltage to 1 volt peak.
110   OUTPUT 714;"SETup:SAUDio:DETector PEAK" !Select the peak detector for
120                                         !the audio analyzer.
130   OUTPUT 714;"SETup:SAUDio:FILTer TBPass" !Select the AF analyzer's 100 Hz bandwidth
140    !band pass filter for making the measurements. The center frequency for the filter
150                                !automatically tracks the AF generator's frequency.
160   OUTPUT 714;"SETup:SAUDio:PEAK:VOLTage 1 V" !Set the expected peak voltage
170                                         !at the AUDIO IN port.
180   OUTPUT 714;"SETup:SAUDio:SDIStortion:STATe ON" !Turn on the SINAD
190                                         !and distortion measurements.
200   OUTPUT 714;"SETup:SAUDio:CONTinuous OFF" !Set the swept audio
210                                         !measurement to single trigger mode.
220   OUTPUT 714;"SETup:SAUDio:TIMeout 5 S" !Set a measurement timeout of
230                                      !5 seconds in case the measurement cannot be made.
240   OUTPUT 714;"INITiate:SAUDio"          !Start the swept audio measurements.
250   OUTPUT 714;"FETCh:SAUDio?"            !Query the audio level and distortion results.
260   ENTER 714;Integrity,Lev1,Dist1,Lev2,Dist2,Lev3,Dist3,Lev4,Dist4,Lev5,Dist5 !Enter the
270                        !returned integrity value, and the level and distortion values
280                        !for each of the five measurement points, into variables.
290   OUTPUT 714;"FETCh:SAUDio:SINAD?"       !Query the SINAD results.
300   ENTER 714;Sinad1,Sinad2,Sinad3,Sinad4,Sinad5 !Enter the 5 returned SINAD values
310                                          !into variables.
320   END

Returned Values

The results returned by this program are:

  • Integrity returns the measurement integrity indicator (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Lev1 through Lev5 return the audio level (voltage) at each of the five measurement points. In this example, the value is returned in volts peak because the peak detector was specified.
  • Dist1 through Dist5 return the distortion value at each of the five measurement points.
  • Sinad1 through Sinad5 return the SINAD value at each of the five measurement points.

The example program uses the single FETCh:SAUDio[:ALL]? query to return the integrity value, the audio level (voltage) values, and the distortion values, at one time. These values can also be queried separately if required. The SINAD value is always queried separately.

Related Topics

Swept Audio Measurement Description

Swept Audio Measurement Troubleshooting

INITiate

SETup:SAUDio

FETCh:SAUDio


Programming a SINAD Measurement

Programming a SINAD Measurement

This section provides an example of how to make SINAD measurement via GPIB. SINAD measurements are not typically made when testing W-CDMA mobiles but, are more common when testing AMPS or other analog mobiles. The programming example below is typical for an AMPS mobile.

SINAD and Distortion measurements are affected by the same STATe and INITiate commands, so both measurements are enabled and triggered at the same time. However, measurement results are queried separately. See Audio Analyzer Measurement Description .

The following procedure assumes that the mobile's audio output is connected to the AUDIO IN connectors and the mobile is on an analog voice channel (AVC) that is being modulated with a 1004 Hz tone at +/-8 kHz peak deviation. It is also assumed that the Cell Power from the test set is set to a minimum usable level (typically about -116 dBm).

  1. Configure audio analyzer measurement parameters using the SETup subsystem.
  2. Start the audio analyzer measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain audio analyzer measurement results.

Programming Example

10  OUTPUT 714;"SETup:AFANalyzer:CONTinuous OFF" !Set the audio analyzer
20                                           !measurements to single trigger mode.
30  OUTPUT 714;"SETup:AFANalyzer:PEAK:VOLTage 3V" !Set the Expected Amplitude level for
40                                                !audio input voltage in Vpeak.
50  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:STATe ON" !Turn on the SINAD and
60                                                  !distortion measurements.
70  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:FREQuency 1004 HZ" !Specify the audio
80                                      !frequency to use for the measurements.
90  OUTPUT 714;"SETup:AFANalyzer:FILTer CMESsage" !Select the c-message filter.
100 OUTPUT 714;"SETup:AFANalyzer:DEMPhasis:STATe OFF" !Turn off de-emphasis.
110 OUTPUT 714;"SETup:AFANalyzer:EXPandor:STATe OFF" !Turn off the expandor.
120 OUTPUT 714;"SETup:AFANalyzer:TIMeout 3S" !Set a timeout value of 3 seconds
130                                      !in case the measurement cannot be made.
140 OUTPUT 714;"INITiate:AFANalyzer" !Start the AF Analyzer measurement.
150 OUTPUT 714;"FETCh:AFANalyzer:INTegrity?" !Query the integrity indicator to
160                           !verify that a reliable measurement was made.
170 ENTER 714;Integrity  !Enter the returned value into a variable for comparison
180                      !with possible integrity indicator values (not shown here).
190 IF Integrity=0 THEN !Only fetch measurement result if integrity indicator is 0.
200 OUTPUT 714;"FETCh:AFANalyzer:SINAD?" !Fetch the SINAD result.
210 ENTER 714;Sinad  !Enter the returned value into a variable.
220 END IF
230 END

Returned Values

The results returned by this program are:

  • Integrity returns the integrity indicator (0 means a successful measurement with no errors). See Integrity Indicator .
  • SINAD returns the SINAD value in dB.

Related Topics

Audio Analyzer Measurement Description

AFANalyzer Troubleshooting

INITiate

SETup:AFANalyzer

FETCh:AFANalyzer

Control Program Example


Programming the Spectrum Monitor

Programming the Spectrum Monitor

This section provides an example of how to use the Spectrum Monitor via the GPIB.

The following procedure assumes that the mobile station's antenna output is connected to the RF IN/OUT connector, and that the mobile station is transmitting a forward channel signal.

  1. Configure the Spectrum Monitor parameters using the SETup subsystem.
  2. Start the Spectrum Monitor using the INITiate subsystem.
  3. Use the INITiate:DONE? command to determine if Spectrum Monitor results are available.
  4. Use the FETCh? commands to obtain Spectrum Monitor results.
  5. Use the CALCulate commands to set and query the Spectrum Monitor markers.

Programming Example

10  REAL Amplitudes(400) ! Set up array to hold amplitude results (trace data)
20  OUTPUT 714;"SETUP:SMONITOR:CONTINUOUS OFF" !Configures the Spectrum Monitor to
30                                             !single trigger mode.
40  OUTPUT 714;"SETUP:SMONITOR:COUNT:NUMBER 20" !Configures a multi-measurement
50                                               !of 20.
60  OUTPUT 714;"SETUP:SMONITOR:TRIGGER:SOURCE IMMEDIATE" !Configure trigger source
70                                                  !to immediate.
80  OUTPUT 714;"SETUP:SMONITOR:FREQUENCY:SPAN 20 MHz" !Set frequency span
90  OUTPUT 714;"INITIATE:SMONITOR"  !Start the Spectrum Monitor
100   REPEAT
110     OUTPUT 714;"INIT:DONE?"
120     ENTER 714;Meas_complete$
130   UNTIL Meas_complete$="SMON"
140 OUTPUT 714;"FETCH:SMONITOR:INTEGRITY?" !Fetch SMON Integrity
150 ENTER 714;Integrity
160 PRINT "Spectrum Monitor Integrity: ";Integrity
170 IF Integrity=0 THEN                    !Fetch results if SMON
180   OUTPUT 714;"FETCH:SMONITOR:TRACE?"   !has valid integrity.
190   ENTER 714;Amplitudes(*)  !Load valid results into array
200   PRINT "Trace Data Amplitude Results (dB):"
210   PRINT "--------------------------------------------------"
220   PRINT Amplitudes(*)
230   PRINT "--------------------------------------------------"
240 ELSE
250   PRINT "Bad Integrity value =";Integrity
260   STOP
270 END IF
280 ! Move the marker to the signal peak and query the frequency and level
290 OUTPUT 714;"CALCULATE:SMONITOR:MARKER1:PEAK:MAXIMUM"
300 OUTPUT 714;"CALCULATE:SMONITOR:MARKER1:FREQUENCY?"
310 ENTER 714;Peak_frequency
320 PRINT "Maximum Peak Frequency (MHz): ";Peak_frequency
330 OUTPUT 714;"CALCULATE:SMONITOR:MARKER1:AMPLITUDE?"
340 ENTER 714;Peak_amplitude
350 PRINT "Maximum Peak Amplitude (dBm): ";Peak_amplitude
360 END

Returned Values

The results returned by this program are:

  • Integrity returns the Spectrum Monitor Integrity Indicator (0 means that the Spectrum Monitor completed with no errors).
  • Amplitudes() returns 401 points representing the amplitude results (in dBm) of the trace data.
  • Peak_frequency returns the frequency in MHz at marker 1. In this case, marker 1 is positioned at the highest peak value.
  • Peak_amplitude returns the amplitude in dBm at marker 1. In this case, marker 1 is positioned at the highest peak value.

Related Topics

Spectrum Monitor Description

SETup:SMONitor

INITiate

FETCh:SMONitor

CALCulate:SMONitor


Programming a Spectrum Emission Mask Measurement

Programming a Spectrum Emission Mask Measurement

This section provides an example of how to make a spectrum emission mask measurement via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is transmitting an uplink signal.

The basic procedure is as follows:

  1. Set the spectrum emission mask setup parameters as desired using the SETup:WSEMask commands.
  2. Use the INITiate:WSEMask command to start the measurement.
  3. Use the FETCh:WSEMask? query to obtain the measurement results.

Programming Example

10    ! Set trigger mode to single for the Spectrum Emission Mask meas.
20    OUTPUT 714;"SETup:WSEMask:CONTiuous OFF"
30    ! Set the multi-measurement count to 10
40    OUTPUT 714;"SETup:WSEMask:COUNt 10"
50    ! Set a timout value of 5 seconds and enable the timeout state
60    OUTPUT 714;"SETup:WSEMask:TIMeout 5"
70    ! Set the trigger source to automatically select the appropriate
80    !  trigger
90    OUTPUT 714;"SETup:WSEMask:TRIGger:SOURce AUTO"
100   ! Initiate the Spectrum Emission Mask measurement
110   OUTPUT 714;"INITiate:WSEMask"
120   ! Fetch the integrity indicator and the results of the measurement
130   OUTPUT 714;"FETCh:WSEMask?"
140   ENTER 714;Integrity,Wsemask,Chan_power,R1,R2,R3,R4
150   ! Check the integrity indicator to ensure the results are valid
160   IF Integrity<>0 THEN
170     PRINT "Measurement failed."
180   ELSE
190   ! Process the measurement results.
200   END IF
210   END

Returned Values

  • Integrity stores the returned integrity indicator value (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Because multi-measurements are being used, R1, R2, R3, and R4 indicate a mask pass or fail for each frequency range based on the average of the power levels associated with the largest mask error for each measurement. Mask pass or fail for each frequency range is determined from the average of the measurement results. The average of the relative power level results for the number of measurements specified is taken. This average is used to determine if that frequency range passed or failed the mask. If multi-measurements were not being used, the mask result would be based on a single measurement value for each frequency range.

Related Topics

  • Spectrum Emission Mask Troubleshooting
  • Spectrum Emission Mask Measurement Description
  • SETup:WSEMask
  • INITiate
  • FETCh:WSEMask
  • Amplitude Offset
  • Integrity Indicator


Statistical Measurement Results

Statistical Measurement Results

Description

Most measurements have a setup window that provides for the entry of a multi-measurement count value. This specifies how many measurements the test set will perform to obtain a set of values from which to calculate the following statistical measurement results:

  • Average (arithmetic mean) of measurement set
  • Minimum value from measurement set
  • Maximum value from measurement set
  • Standard Deviation of measurement set

Operating Considerations

The advantages of using the multi-measurement feature to obtain statistical measurement data include: reduced time associated with GPIB bus traffic, and reduced time configuring hardware. This is because the number of measurements specified in the multi-measurement count value are performed during one measurement cycle.

Programming Example

OUTPUT 714;"SETUP:WACLeakage:COUNt 10" !Enters an Adjacent Channel
!Leakage Ratio (ACLR) count of 10, and turns the multi-measurement
!count state on.

Related Topics

Measurement Progress Report


Status Subsystem Overview

Status Subsystem Overview

Last updated: December 22, 2004

The following pages present an overview of the entire status subsystem, including applications which may or may not be loaded in your test set.

Description

Overview of STATus Reporting Structure

Status Reporting Structure For STATus QUEStionable Registers

Status Reporting Structure For STATus OPERation Registers

Status Reporting Structures for the COMMon Registers

Status Reporting Structure for the SMService Register

Status Reporting Structure for the GSM Registers

Status Reporting Structure For the GPRS Registers

Status Reporting Structure for the AMPS Registers

Status Reporting Structure for the DIGital136 Registers

Status Reporting Structures for the TA136 Registers

Status Reporting Structure for the DIGital95 Registers

Status Reporting Structure for the DIGital 2000 Registers

Status Reporting Structure for the CDMA Registers

Status Reporting Structure for the TA 2000 Registers

Status Reporting Structure for the FDD Registers

Status Reporting Structure for the WCDMA Registers

Status Data Structure - Register Model

The generalized status register model consists of a Condition Register, Transition Filters, an Event Register, an Enable Register, and a Summary Message Bit.

Condition Register

A condition is a test set state that is either TRUE or FALSE (a GPIB command error has occurred or a GPIB command error has not occurred). Each bit in a Condition Register is assigned to a particular test set state. A Condition Register continuously monitors the hardware and firmware states assigned to it. There is no latching or buffering of any bits in a Condition Register; it is updated in real time. Condition Registers are read-only. Condition Registers in the test set are 16 bits long and may contain unused bits. All unused bits return a zero value when read.

Transition Filters

In the test set, the Transition Filters are implemented as two registers: a 16-bit positive transition (PTR) register and a 16-bit negative transition (NTR) register.

For each bit in the Condition Register, a Transition Filter bit determines the state transitions which will set a corresponding bit in the Event Register. Transition Filters may be set to pass positive transitions (PTR), negative transitions (NTR) or either (PTR or NTR). A positive transition refers to a condition bit which has changed from 0 to 1. A negative transition refers to a condition bit which has changed from 1 to 0.

A positive transition of a bit in the Condition register will be latched in the Event Register if the corresponding bit in the positive transition filter is set to 1. A positive transition of a bit in the Condition register will not be latched in the Event Register if the corresponding bit in the positive transition filter is set to 0.

A negative transition of a bit in the Condition register will be latched in the Event Register if the corresponding bit in the negative transition filter is set to 1. A negative transition of a bit in the Condition register will not be latched in the Event Register if the corresponding bit in the negative transition filter is set to 0. Either transition (PTR or NTR) of a bit in the Condition Register will be latched in the Event Register if the corresponding bit in both transition filters is set to 1. No transitions (PTR or NTR) of a bit in the Condition Register will be latched in the Event Register if the corresponding bit in both transition filters is set to 0.

Transition Filters are read-write.

Transition Filters are unaffected by a *CLS (clear status) command.

Transitions Filters are set to pass positive transitions (all 16 bits of the PTR register are set to 1 and all 16 bits of the NTR register are set to 0) at power on or after receiving the *RST (reset) command.

Event Register

The Event Register captures bit-state transitions in the Condition Register as defined by the Transition Filters. Each bit in the Event Register corresponds to a bit in the Condition Register. Bits in the Event Register are latched, and, once set, they remain set until cleared by a query of the Event Register or a *CLS (clear status) command. This guarantees that the application can't miss a bit-state transition in the Condition Register. There is no buffering; so while an event bit is set, subsequent transitions in the Condition Register corresponding to that bit are ignored. Event Registers are read-only. Event Registers in the test set are 16 bits long and may contain unused bits. All unused bits return a zero value when read.

Event Enable Register

The Event Enable Register defines which bits in the Event Register will be used to generate the Summary Message. Each bit in the Enable Register has a corresponding bit in the Event Register. The test set logically ANDs corresponding bits in the Event and Enable registers and then performs an inclusive OR on all the resulting bits to generate the Summary Message. By using the enable bits the application program can direct the test set to set the Summary Message to the 1 or TRUE state for a single event or an inclusive OR of any group of events. Enable Registers are read-write. Enable Registers in the test set are 16 bits long and may contain unused bits which correspond to unused bits in the associated Event Register. All unused bits return a zero value when read and are ignored when written to. Enable Registers are unaffected by a *CLS (clear status) command or queries.

Standard Event Status Register Model

Summary Message Bit

The Summary Message is a single-bit message which indicates whether or not one or more of the enabled events have occurred since the last reading or clearing of the Event Register. The test set logically ANDs corresponding bits in the Event and Enable registers and then performs an inclusive OR on all the resulting bits to generate the Summary Message. By use of the enable bits, the application program can direct the test set to set the Summary Message to the 1, or TRUE, state for a single event or an inclusive OR of any group of events.

The Summary Message is TRUE, logic 1, if the register contains some information and an enabled event in the Event Register is set TRUE.

The Summary Message is FALSE, logic 0, if the queue is empty and no enabled events are TRUE. Registers can be cleared by reading all the information from the queue. Registers can also be cleared using the *CLS (clear status) command.

Service Request Enabling Register Model

Status Byte Register

The Status Byte Register is an 8 bit register that provides single bit summary messages, each summary message summarizes and overlaying status data structure. Summary messages always track the current status of the associated status data structure. Service request enabling determines if one or more of the summary messages will generate a message. Device status reporting is defined in IEEE 488.2-1992, 11.1.

The Status Byte Register contains the STB and RQS (or MSS) messages from the test set. The Status Byte Register can be read with either a serial poll or the *STB? common query. The value for bit 6 is dependent on which method used.

When reading with a serial poll the status byte and the RQS message are returned as a single data byte. The RQS message indicates if the SRQ is TRUE. The Status Byte Register is not affected by a serial poll, the RQS is set to FALSE when polled.

The *STB? query allows you to read the status byte and the MSS. The response represents the sum of the binary weighted values of the Status Byte Register from bit 0-5 and 7.

The Master Summary Status (MSS) message from bit 6 indicates when there is at least one reason for requesting service.

The Message Available (MAV) summary message from bit 4 is TRUE when there is a message is in the output queue.

The Status Byte Register is cleared with the *CLS common command. The output queue and the MAV are not affected by the *CLS command.

Service Request Enable Register

The Service Request Enable Register is an 8 bit register that enables corresponding summary messages in the Status Byte Register. Enabling the service request with the *SRE command allows you to choose which bits in the Status Byte Register will trigger a service request.

The Service Request Enable Register is read with the *SRE? query. The returned value is the sum of the binary weighted values of the Service Request Enable Register, with a range of 0 through 63 or 128 through 191.

The value of the unused bit 6 will always be zero.

System Synchronization Bit

Bit 12 of the status operation condition register is "pulsed" when the SYSTem:SYNChronized command is sent. This allows the status system to indicate that:

  • the input buffer is synchronized to the point where this command is parsed
  • all prior sequential commands are completed
  • all prior overlapped commands have started

Related Topics

STATus Subsystem Description


Call Processing Event Synchronization

Call Processing Event Synchronization

Description

Using the call processing subsystem overlapped command synchronization commands, you can query the test set to find out when an overlapped command operation is done (:DONE?, :OPC?), force the test set to not execute any more commands until an overlapped command operation has completed (:WAIT), or simply force an overlapped command to behave as a sequential command (:SEQ).

Pending Operation Flags

Associated with each overlapped command, the test set maintains a binary indicator known as a pending operation flag. A pending operation flag is set true when the operation started by the overlapped command is executing, and is set false when the operation is no longer executing.

NOTE
In addition to the call processing subsystem overlapped commands, the test set also provides the measurement-related INITiate <measurement> overlapped commands.

Call Processing Subsystem Overlapped Command Synchronization Commands

Overlapped Commands
Command Purpose Of Command

Example

:DONE?

Returns a 0 if the associated command's pending operation flag is true, or a 1 if it is false.

10 OUTPUT 714;"CALL:TCH 65"
20 OUTPUT 714;"SETUP:TXP:CONT OFF"
30 OUTPUT 714;"SETUP:PFER:CONT OFF"
40 REPEAT
50 OUTPUT 714;"CALL:TCH:DONE?"
60 ENTER 714;Process_done
70 UNTIL Process_done
80 OUTPUT 714;INIT:TXP;PFER"
90 END

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and execute two setup commands. After the two setup commands have finished, the :DONE? command is used to find out if the handover is finished

:SEQuential

Forces an overlapped command to execute in a sequential manner. No subsequent commands will be executed until the pending operation flag for this operation is false.

OUTPUT 714;"CALL:TCH:SEQ 65"

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and to not execute any more commands until the pending operation flag associated with the CALL:TCH command is false.

:WAIT

Forces the test set to wait until the associated command's pending operation flag is false before executing any more commands.

10 OUTPUT 714;"CALL:TCH 65"
20 OUTPUT 714;"SETUP:TXP:CONT OFF"
30 OUTPUT 714;"SETUP:PFER:CONT OFF"
40 OUTPUT 714;"CALL:TCH:WAIT"
50 OUTPUT 714;"INIT:TXP;PFER"
60 END

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and execute two setup commands. After the two setup commands have finished, the :WAIT command is sent to prevent the test set from executing the INITiate command until the handover is finished.

:OPComplete?

Places a 1 in the test set's output queue when the associated command's pending operation flag goes false. Controlling program hangs on this query until the 1 is retrieved.

10 OUTPUT 714;"CALL:TCH 65"
20 OUTPUT 714;"SETUP:TXP:CONT OFF"
30 OUTPUT 714;"SETUP:PFER:CONT OFF"
40 OUTPUT 714;"CALL:TCH:OPC?"
50 ENTER 714;Op_complete
60 OUTPUT 714;"INIT:TXP;PFER"
70 END

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and execute two setup commands. After the two setup commands have finished, the :OPC? command is sent to hang program execution until a 1 is put in the test set's output queue, satisfying the ENTER statement and allowing program execution to continue with the INITiate command.

Operating Considerations

When using the call processing subsystem overlapped command synchronization commands, check the conditions that set the operation's pending operation flag (POF) false to avoid unexpected results.

Call Processing Subsystem Overlapped Commands

Overlapped Commands
Call Processing Command | Purpose Of Command | Pending Operation Flag (POF) is false when
CALL:ORIGinate See CALL:ORIGinate . | Performs a base station call origination. | The call processing state leaves the Idle state (when the operating mode is active cell), or The test set has noted this parameter change (when the operating mode is test mode).
CALL:CONNected:ARM[:IMMediate] See CALL:CONNected:ARM[:IMMediate] . | Arms the call control status change detector. | The call control status change detector has been disarmed. See Connected/Idle Query .

Related Topics

Call Processing State Synchronization


Call Processing State Synchronization

Call Processing State Synchronization

Call Processing State Query

The CALL:STATus[:STATe][:VOICe]? query returns the current call processing state (see Call States ).

For the lab application only, the CALL:STATus[:STATe]:DATA? query returns the current data connection state (see Data Channel States ).

Description

Connected/Idle Query

This query will determine if a call is connected or disconnected by returning an integer value. The value indicates if the call state is idle or connected, not if any call state change has occurred.

Query returns one of the following:

  • 0 = idle
  • 1 = connected

If the call is in the setup request, proceeding, alerting, or disconnecting state, this command will not return a value until the call status proceeds to either connected or idle.

OUTPUT 714;"CALL:CONNECTED:STATE?"

Base Station Originated Call - Using the Connected/Idle Query

The following example illustrates the use of the connected/idle query for a base station originated call. This code originates a call, then waits for the connected/idle query to return a result.

Note that this code does not include the CALL:CONNECTED:TIME (timeout timer) or the CALL:CONNECTED:ARM (change detector arm) commands. These commands are unnecessary since the change detector is armed automatically by the CALL:ORIGINATE command, and the timeout timer value is never applicable since a base station originated call guarantees a state change.

10    OUTPUT 714;"CALL:ORIGINATE" ! Begin the BS originated call.
20    OUTPUT 714;"CALL:CONNECTED:STATE?" ! The connect/idle query.
30    ENTER 714;Call_connected ! Program will hang here until state
40                             ! change or protocol timer expires.
50    !************************************************************
60    ! If mobile is not set to auto-answer, answer the call.
70    !************************************************************
80    IF NOT Call_connected THEN
90      DISP "CALL NOT CONNECTED."
100   ELSE
110     DISP "CALL IS CONNECTED."
120   END IF
130   END

Call State Change Detector

This feature provides a method for holding off the Connected/Idle Query results until a change in call processing states is detected. Arming the call state change detector is useful only for mobile station originated calls or disconnects only. It is armed automatically when call processing functions originating from the test set are requested.

The call state change detector becomes disarmed when any of the following conditions have been met:

  • the call processing state has changed to either connected or idle

    or...

  • the attempt to connect or disconnect a call has failed, and one of the test set's Fixed Timers has timed out

    or...

  • no call processing state changes occurred within the time period specified by the Call State Change Detector Timeout .

The following command arms the call state change detector:

OUTPUT 714;"CALL:CONNECTED:ARM[:IMMEDIATE]"

Mobile Station Originated Call - Arming the Change Detector

The following example illustrates the use of the call state change detector along with the connected/idle query to synchronize a controlling application with a call processing state change during a mobile station originated call.

When the CALL:CONNECTED:ARM command is received by the test set, the detector becomes armed and configures the test set to hold off on returning a result for the CALL:CONNECTED:STATE? query until the detector is disarmed by one of the three events described above.

10    OUTPUT 714;"CALL:CONNECTED:TIMEOUT 10S" ! Sets the time out
20                                            ! time to 10 seconds.
30    OUTPUT 714;"CALL:CONNECTED:ARM" ! Arm the change detector.
40    DISP "Make a mobile station orginated call. Continue when done."
50    PAUSE
60    OUTPUT 714;"CALL:CONNECTED:STATE?" ! The connected/idle query.
70    ENTER 714;Call_connected
80    IF Call_connected=1 THEN
90      DISP "Call is connected."
100     WAIT 2
110   ELSE
120     DISP "Call is not connected."
130     WAIT 2
140   END IF
150   END

Call State Change Detector Timeout

If a state change does not occur, the user needs a way to control how long to wait for the change detector. The change detector is disarmed by the timeout timer. After a timeout, the connected/idle query will return a 1 for connected or a 0 for idle. The timeout timer is user settable, but the user setting is only applied during mobile station originated call processing operations. For base station originated call processing operations, the timeout timer is automatically set to 60 seconds by the test set.

Related Topics

CALL:CONNected:TIMeout


Test System Synchronization Overview

Test System Synchronization Overview

Description

Typical test systems include an external controller with a GPIB connection to the test set, an RF (and possible AF) connection between the test set and a mobile station under test, and a serial connection between the mobile station and the external controller.

Synchronizing an external controller with the test set and a mobile station under test ensures that no device does something before it is supposed to, which can cause errors, or does something well after it could have, which wastes time.

Test System

Sequential versus overlapped commands

The test set uses both sequential and overlapped commands:

  • Sequential commands must finish executing before the next command starts to execute.
  • Overlapped commands do not finish executing before the next command starts to execute.

Overlapped commands are more difficult to synchronize because an overlapped operation that started several commands earlier may still be executing as subsequent commands are being parsed out from the input buffer and executed. This can present a problem unless the external controller is properly synchronized to the test set's execution of commands. Overlapped commands allow the test set to use its internal resources as efficiently as possible.

Methods for synchronization

The test set's GPIB command set supports the following methods to achieve synchronization for overlapped commands. In some cases, combinations of these methods will provide the best results:

Methods one and two do not require the external controller to query the test set, nor to perform any branching or decision-making associated with information acquired from the test set.

Methods three through six rely on responses from the test set to an external controller, indicating that some event has occurred. The external controller can then make decisions based on these responses to control the flow of commands to the test set and other devices in the test system.

  1. Force the test set to execute overlapped commands sequentially.
  2. Force the test set to wait until an overlapped command is done executing before executing any more commands.
  3. Query the test set to determine when a command has finished executing.
  4. Query the test set to determine when all commands sent to it have at least begun executing.
  5. Query the test set to determine the current call or data connection processing state.
  6. Program the test set to generate a service request when an operation has completed or the test set is in a certain state.

Commands used for synchronization:

  • CALL:STATus
    This command queries the test set's current call processing state. This command supports synchronization method five. See Call Processing State Synchronization .

  • CALL:STATus
    This command determines the connected/idle state of a call. A feature called the change detector provides the user with a way to hold off the response to this query until a call processing state transition has taken place. See Connected/Idle Query . This command supports synchronization method five.

  • :DONE? and :OPC?
    These specialized commands can be appended to call processing overlapped commands to support synchronization method three. See Call Processing Subsystem Overlapped Command Synchronization Commands .

  • :WAIT
    This specialized command can be appended to call processing overlapped commands to support synchronization method two.
    See Call Processing Subsystem Overlapped Command Synchronization Commands .

  • :SEQ
    This specialized command can be appended to call processing overlapped commands to support synchronization method one.
    See Call Processing Subsystem Overlapped Command Synchronization Commands .

  • INITiate:DONE?
    This specialized command causes the test set to return a mnemonic indicating if a measurement is done. If not, the returned mnemonic will indicate if the measurement is still executing. This command supports synchronization method three.
    See INITiate:DONE? .

  • STATUS:<register>
    Status bits in the register are provided to indicate the test set's call processing state. These bits support synchronization methods five and six.
    Status bits in the STATus:OPERation:NMRReady Register Bit Assignments are provided to indicate when a measurement is ready to be fetched. These bits support synchronization method three and six.
    Many other status bits are provided in the GPIB status subsystem that are useful for synchronization. See STATus Subsystem Description .

  • SYSTem:SYNChronized
    This specialized command puts a 1 in the test set's output queue, the test set responds to the query by sending a 1 to the external controller indicating that all prior sequential commands have completed, and all prior overlapped commands have at least begun execution. The condition bit is set then cleared. See STATus:OPERation Register Bit Assignments . This command supports synchronization four and six.

  • *OPC and *OPC? , and *WAI (not recommended)
    Note: These commands look at all of the test set's operations collectively. Because multiple processes are likely to be executing at the same time, it is recommended that the other commands above be used instead.

Related Topics

Call Processing State Synchronization


Programming a Thermal Power Measurement

Programming a Thermal Power Measurement

This section provides an example of how to make thermal power measurements via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is transmitting an uplink signal.

The basic procedure to test thermal power is as follows:

  1. Set the thermal power setup parameters as desired for triggering, measurement timeout, and multi-measurements using the SETup:WTPower commands.
  2. Use the INITiate:WTPower command to start the measurement.
  3. Use the FETCh:WTPower? query to obtain the measurement results.

Programming Example

10    OUTPUT 714;"SETup:WTPower:CONTinuous Off"!Set the thermal power
20                                     !measurement to single trigger mode.
30    OUTPUT 714;"SETup:WTPower:TIMeout 2S"!Set a timeout value of 2 secondS
40                  !and enable timeouts in case the measurement cannot be made.
50    OUTPUT 714;"SETup:WTPower:COUNt 5"!Set multi-measurements to 5 and
60                                     !enable multi-measurements.
70    OUTPUT 714;"INITiate:WTPower"!Start the measurement.
80    OUTPUT 714;"FETCh:WTPower?"!Query the returned integrity indicator and the
90                               !average thermal power measurement.
100   ENTER 714;Integrity,Wtpower!Enter the returned values into variables.
110   IF Integrity<>0 THEN !Integrity <> 0 indicates an  invalid measurement.
120     PRINT "Measurement problem; check for signal level over/under range condition."
130   ELSE
140   END IF
150   END

Returned Values

  • Integrity stores the returned integrity indicator value (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Because multi-measurements are being used in this example, Wtpower stores the returned average thermal power measurement value in dBm. If multi-measurements were not being used, the returned value would be a single thermal power measurement value.

Related Topics

  • Thermal Power Troubleshooting
  • Thermal Power Measurement Description
  • SETup:WTPower
  • INITiate
  • FETCh:WTPower
  • Amplitude Offset
  • Integrity Indicator


Triggering of Measurements

Triggering of Measurements

Description

  • Trigger Source Description
  • Triggering Process Description
  • Trigger Arm (Single or Continuous) Description
  • Trigger Delay Description
  • Trigger Qualifier Description

Trigger Source Description

A measurement trigger causes hardware (for example, a sampler) to capture data which is used by a measurement algorithm to produce a measurement result. Not all of the trigger source choices are available in every measurement, or every test application.

RF Rise Trigger Source:

When RF rise triggering is selected, a measurement dependent threshold is used to define the trigger point on the envelope of the signal being measured. The envelope amplitude must fall below this threshold and remain there for a measurement-dependent period of time before the trigger is armed. After the trigger is armed, a trigger will occur as the envelope amplitude increases and passes through the threshold.

Protocol Trigger Source:

When protocol triggering is selected, a data capture is triggered by a protocol generated signal. The test set's protocol engine knows when the DUT's signal should be present and generates a trigger signal for use by the measurement to trigger the data capture.

External Trigger Source:

When external triggering is selected, the user supplies an external trigger signal via the rear panel TRIG IN connector in order to trigger data capture. The trigger will occur on the rising edge of this signal.

Immediate Trigger Source:

When immediate triggering selected, the trigger occurs as soon as any pre-trigger samples required by the measurement algorithm are taken. Data capture is triggered when the measurement is initiated.

Auto Trigger Source:

When auto triggering is selected, the test set automatically chooses the best trigger source for that measurement. This trigger source setting is convenient because the measurement trigger doesn't need to be changed when switching parameters. Auto trigger source is the best choice for most users.

Triggering Process Description

The triggering process controls the present and future states of the test set during the measurement cycle. Triggers are set up using the SETup commands and can be set up when a measurement is in the inactive state. A measurement is activated (selected) with an INITiate command. If a measurement is initiated while in its measurement cycle, it will terminate that measurement and restart it. The active state is not a single state but a collection of any state other than the inactive state. Deactivating (de-selecting) the measurement is accomplished through an INITiate:<MEAS>:OFF command.

Manually, a measurement is activated by selecting it from the Measurement Selection menu. A measurement is deactivated by pressing the Measurement Selection key, scrolling to measurement in the Measurement Selection menu, and then pressing F4 (Close Measurement) .

The Test Set's Measurement States

Measurement States

The following examples describe states of the test set under various conditions. Refer to The Test Set's Measurement States .

Inactive State

If the test set has just been powered on, or any form of preset has been performed, then the measurement state is inactive.

Wait for Trigger State

If a measurement has been initiated with the INITiate command but has not been triggered, or a measurement has been selected from the Measurement Selection menu but has not been triggered, then the measurement state is wait for trigger.

Measuring and Idle States (Trigger Arm Single)

If the trigger arm is set to single, the trigger source is available, and the trigger qualifier (optional) is satisfied, the measurement state transitions to measuring and measurement results are now available to the user. The state then transitions to idle (awaiting another INITiate).

Measuring State (Trigger Arm Continuous)

If the trigger arm is set to continuous, the trigger source is available, and the trigger qualifier (optional) is satisfied, the measurement state transitions to measuring and measurement results are now available to the user. The measurement is continually triggered until the measurement is deactivated. Measurement results are only available after the measurement completes and before it rearms. The measurement is deactivated using the INITiate:<MEAS>:OFF. or Close Measurement .

Trigger Arm (Single or Continuous) Description

Trigger arm determines if a measurement will make one measurement then return to idle (single), or automatically rearm on completion of a measurement and repeat the process (continuous).

NOTE
When operating the test set remotely, the recommended setting for the trigger arm parameter is single. This ensures proper operation of the INIT:DONE? query which is used to control the retrieval of measurement results when measurements are initiated concurrently.

When a continuously armed measurement gets a result, it is available to any currently pending (waiting, hanging) FETCh? query. Then another measurement cycle is started immediately. At this point the results are no longer valid. The INIT:DONE? query is used to determine when there is a completed measurement with valid results that can be fetched. If you look for a continuously armed measurement with valid results that can be fetched using INIT:DONE? then you are unlikely to get anything but WAIT. Each time the Test Set is queried, it is 99% likely to be making another measurement. Even if it did return a measurement name, by the time the control program determines which FETCh? query to send, it is too late to fetch the results and the FETCh? query just hangs until the next measurement cycle is done, nullifying the efficiency provided by the INIT:DONE? query.

Pressing the Start Single key on the front panel will cause all currently active measurements with trigger arm set to single to arm and make the measurement.

Pressing Shift, Start Single (Stop) causes all measurements with trigger arm set to single to abort the measurement.

It is unnecessary for you to arm a measurement if the trigger arm is set to continuous. When in continuous mode, the measurement is automatically rearmed after completing a measurement.

Trigger Arm Default Settings
Action | Trigger Arm Default Setting
Power up of test set | Continuous
Manual Full Preset | Continuous
*RST (Remote) Full Preset | Single
Partial Preset | No change

Trigger Delay Description

Trigger delay controls the delay time between the trigger and the start of sampling. Resolution is 1 nanosecond per measurement and the units are in seconds. A negative value indicates the sampling should occur prior to the trigger. The default is zero seconds which is preferred for most measurements.

Trigger Qualifier Description

When the trigger qualifier is on, the test set samples the input signal when a trigger is received. It then determines if the input signal was valid by looking at its power level. If the power level during sampling did not meet the requirements of a valid signal, the state returns to wait for trigger without processing the samples. Trigger qualifier is available for GSM/GPRS TX Power and Phase Frequency Error measurements only.

If a valid signal is present, then it is qualified, and the samples are processed.

Related Topics

Integrity Indicator


Programming a Block Error Ratio Measurement

Programming a Block Error Ratio Measurement

  1. Set MS Loopback Type to Type 2 using the CALL:MS:LOOPback:TYPE command.
  2. Set Uplink DTCH RMC CRC Presence to Used for Data using the CALL:SERVice:RBTest:DTCHannel:CRC[:PRESence] command.
  3. Prompt the user to power the UE on and wait for it to camp to the test set, then continue the program.
  4. Set Paging Service to RB Test Mode using the CALL:PAGing:SERVice[:TYPE] command.
  5. Set Channel Type to 12.2k RMC using the CALL:SERVice:RBTest:RAB command.
  6. Originate a call using the CALL:ORIGinate command.
  7. Set Cell Power as needed using the CALL[:CELL]:POWer[:SAMPLitude] command.
  8. Set up the measurement using the SETup:WBLerror commands.
  9. INITiate the measurement using the INITiate command.
  10. FETCh the measurement results using the FETCh:WBLerror commands.

Related Topics

Block Error Ratio Measurement Description


Programming a Change of TFC (Transport Format Combination) Measurement

Programming a Change of TFC (Transport Format Combination) Measurement

Last updated: December 21, 2004

This section is only applicable to the lab application.

This section provides an example of how to make change of TFC measurements via GPIB.

The basic procedure to perform change of TFC measurements is as follows:

  1. Ensure that Uplink Dummy DCCH Data is set to Off ( CALL:UPLink:DCCHannel:DDATa ).
  2. Establish an RB test mode connection between the UE and test set (see Step 4: Make a Connection ).
  3. Configure the change of TFC measurement parameters as desired using the SETup:WCTFormat commands.
  4. Use the INITiate :WCTFormat command to start the measurement.
  5. Use the FETCh:WCTFormat query to obtain the measurement results (or use the READ:WCTFormat[:ALL]? command to both initiate and fetch the measurement as a sequential operation).

Programming Example

10 ! Change of TFC Measurement Programming Example
20 ! This programming example assumes that Uplink Dummy DCCH Data is
30 ! set to Off, Uplink DPCH Bc/Bd Control is set to Auto, UL CL Power
40 ! Ctrl Algorithm is set to Two, and that there is an RB Test Mode
50 ! connection between the test set and UE.
60 !
70 Testset=714
80 !
90 ! *** Set Up Test Parameters ***
100 !
110 OUTPUT Testset;"CALL:MS:POWer:TARGet 0"
120 ! Set MS Target Power to 0 dBm.
130 OUTPUT Testset;"CALL:CLPControl:UPLink:MODE UDOWn"
140 ! Set UL CL Power Ctrl Mode to Alternating.
150 !
160 ! *** Set Up Measurement Parameters ***
170 !
180 OUTPUT Testset;"SETup:WCTFormat:COUNt 5"
190 ! Set Multi-Measurement Count to 5.
200 !
210 ! *** INITiate and FETCh Measurements ***
220 !
230 OUTPUT Testset;"INITiate:WCTFormat"
240 ! Initiate a Change of TFC measurement.
250 OUTPUT Testset;"FETCh:WCTFormat?"
260 ! Fetch Change of TFC measurement results.
270 ENTER Testset;Int,Down_pwr,Down_err,Down_pf,Up_pwr,Up_err,Up_pf
280 ! Retrieve the results.
290 !
300 ! *** Print Measurement Results ***
310 !
320 CLEAR SCREEN
330 PRINT "Change of TFC Measurement Results:"
340 PRINT
350 PRINT "Integrity Indicator                      = ",Int
360 PRINT "Step Down Relative Power (in dB)         = ",Down_pwr
370 PRINT "Step Down Error (in dB)                  = ",Down_err
380 PRINT "Step Down Pass/Fail (0 = pass, 1 = fail) = ",Down_pf
390 PRINT "Step Up Relative Power (in dB)           = ",Up_pwr
400 PRINT "Step Up Error (in dB)                    = ",Up_err
410 PRINT "Step Up Pass/Fail (0 = pass, 1 = fail)   = ",Up_pf
420 !
430 END

Related Topics

  • Change of TFC (Transport Format Combination) Troubleshooting
  • Change of TFC (Transport Format Combination) Measurement Description
  • Manual Operation: How Do I Make a Change of TFC (Transport Format Combination) Measurement?


Programming the Dynamic Power Analysis Measurement

Programming the Dynamic Power Analysis Measurement

  1. Prompt the user to place the UE into a test mode which will force it to transmit the power sequence you desire to test.
  2. Set up the measurement using the SETup:WDPAnalysis commands.
  3. INITiate the measurement using the INITiate command.
  4. FETCh the measurement results using the FETCh:WDPAnalysis commands.

Related Topics

Dynamic Power Analysis Measurement Description


Programming the Phase Discontinuity Measurement

Programming the Phase Discontinuity Measurement

This section provides an example of how to make phase discontinuity measurements via GPIB.

The basic procedure to perform phase discontinuity measurements is as follows:

  1. Establish an RB test mode connection between the UE and test set (see Step 4: Make a Connection ).
  2. Set UL CL Power Control Mode to Active Bits ( CALL[:CELL]:CLPControl:UPLink:MODE ).
  3. Set UE Target Power to the appropriate level ( CALL:MS:POWer:TARGet[: AMPLitude]? ).
  4. Set up the measurement using the SETup:WPDiscon commands.
  5. INITiate the measurement using the INITiate command.
  6. FETCh the measurement results using the FETCh:WPDiscon commands (or use the READ:WPDiscon[:ALL]? command to both initiate and fetch the measurement as a sequential operation).

Programming Example

10 ! Phase Discontinuity Measurement Programming Example
20 ! This programming example assumes that there is an RB
30 ! Test Mode connection between the test set and UE.
40 !
50 Testset=714
60 !
70 ! *** Set Up Test Parameters ***
80  !
90 OUTPUT Testset;"CALL:CLPControl:UPLink:MODE ACTive"
100 ! Set UL CL Power Ctrl Mode to Active Bits.
110 OUTPUT Testset;"CALL:MS:POWer:TARGet 21"
120 ! Set MS Target Power to +21 dBm.
130 !
140 ! *** Set Up Measurement Parameters ***
150 !
160 OUTPUT Testset;"SETup:WPDiscon:PCPattern DN5_4UP"
170 ! Set Power Control Pattern to 5DOWN/4UP.
180 OUTPUT Testset;"SETup:WPDiscon:NPRepetition 10"
190 ! Set the Number of Pattern Repetitions to 10.
200 !
210 ! *** INITiate and FETCh Measurements ***
220 !
230 OUTPUT Testset;"INITiate:WPDiscon"
240 ! Initiate a Phase Discontinuity measurement.
250 OUTPUT Testset;"FETCh:WPDiscon?"
260 ! Fetch Phase Discontinuity measurement results.
270 ENTER Testset;Int,Num_slts,Wc_pd_slt,Wc_pd,Wc_evm_slt,Wc_evm
280 ! Retrieve the results.
290 !
300 ! *** Print Measurement Results ***
310 !
320 CLEAR SCREEN
330 PRINT "Phase Discontinuity Measurement Results:"
340 PRINT
350 PRINT "Integrity Indicator                         = ",Int
360 PRINT "Number of Slots Measured                    = ",Num_slts
370 PRINT "Worst Case Phase Discontinuity Slot Number  = ",Wc_pd_slt
380 PRINT "Worst Case Phase Discontinuity (in degrees) = ",Wc_pd
390 PRINT "Worst Case EVM Slot Number                  = ",Wc_evm_slt
400 PRINT "Worst Case EVM (in % rms)                   = ",Wc_evm
410 !
420 END

Related Topics

Phase Discontinuity Troubleshooting

Phase Discontinuity Measurement Description

Manual Operation: How Do I Make a Phase Discontinuity Measurement?


Programming the PRACH Preamble Analysis Measurement

Programming the PRACH Preamble Analysis Measurement

This section is only applicable to the lab application.

  1. Set Call Limit State to Off using the CALL:CONNected:LIMit[:STATe][:SELected] command.
  2. Set PRACH Signature as needed using the CALL:UPLink:PRAChannel:SMASk command.
  3. Set PRACH Preambles to at least 3 using the CALL:UPLink:PRAChannel:PREambles:NUMBer command.
  4. Set Available Subchannels (Bit Mask) to specify only one available subchannel using the CALL:UPLink:PRAChannel:ASUBchannels command.
  5. Prompt the user to power the UE on and wait for it to camp to the test set, then continue the program.
  6. Set Cell Power as needed using the CALL[:CELL]:POWer[:SAMPLitude] command.
  7. Set up the measurement using the SETup:WPPAnalysis commands.
  8. INITiate the measurement using the INITiate command.
  9. FETCh the measurement results using the FETCh:WPPAnalysis commands.

Related Topics

PRACH Preamble Analysis Measurement Description


Programming a Waveform Quality Measurement

Programming a Waveform Quality Measurement

This section provides an example of how to make waveform quality measurements via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is synchronized to the test set and is transmitting an uplink signal.

The basic procedure to test waveform quality is as follows:

  1. Set the waveform quality setup parameters as desired using the SETup:WWQuality commands.
  2. Use the INITiate:WWQuality command to start the measurement.
  3. Use the FETCh:WWQuality? query to obtain the measurement results.

Programming Example

10    OUTPUT 714;"SETup:WWQuality:CONTinuous Off"   !Set the waveform quality
20                                       !measurement to single trigger mode.
30    OUTPUT 714;"SETup:WWQuality:TIMeout 1S"!Set a timeout value of 1 second
40                                  !in case the measurement cannot be made.
50    OUTPUT 714;"SETup:WWQuality:COUNt 5"  !Set multi-measurements to 5 and
60                                          !enable multi-measurements.
70    OUTPUT 714;"SETup:WWQuality:TSLot 11" !Set the measurement to
80                                !measure waveform quality during timeslot 11.
90    OUTPUT 714;"INITiate:WWQuality" !Start the waveform quality measurement.
100   OUTPUT 714;"FETCh:WWQuality?"  !Query the integrity indicator and all
110                               !results for the waveform quality measurement.
120   ENTER 714;Integrity,Evm,Ferr,Ooff,Perr,Merr,Terr,Pcde !Enter the
130          !returned integrity indicator and measurement values into variables.
140   IF Integrity<>0 THEN !Check the integrity value.
150   PRINT "Measurement problem; check for signal level over/under range condition."
160   ELSE
170   ! Process measurement results
180   END IF
190   END

Returned Values

  • Integrity stores the returned integrity indicator value (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Evm returns the maximum error vector magnitude result.
  • Ferr returns the worst case frequency error result.
  • Ooff returns the maximum origin offset result.
  • Perr returns the maximum phase error result.
  • Merr returns the maximum magnitude error result.
  • Terr returns the worst case timing error in chips.
  • Pcde returns the maximum peak code domain error.

Related Topics

  • Waveform Quality Troubleshooting
  • Waveform Quality Measurement Description
  • SETup:WWQuality
  • INITiate
  • FETCh:WWQuality
  • Amplitude Offset
  • Integrity Indicator


E1963A and E6703B W-CDMA Applications: GPIB Command Revision Information

E1963A and E6703B W-CDMA Applications: GPIB Command Revision Information

Last updated: December 21, 2004

The tables below indicate new and revised GPIB commands for the W-CDMA test and lab applications at each release.

  • GPIB Changes for E1963A A.05.28, E6703B B.01.29 - April 2004
  • GPIB Changes for E1963A A.05, E6703B B.01 - December 2003
GPIB Changes for E1963A A.05.28, E6703B B.01.29 - April 2004
GPIB Command | New | Revised | Test Application | Lab Application
CALL[:CELL[1]]:BCCHannel:ITRFrequency:DOWNlink:CHANnel |  | X | X | X
CALL:CHANnel |  | X | X | X
CALL:SETup:CHANnel<[:SELected]|:FDD>:DOWNlink |  | X | X | X
CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink[:MCHannel] |  | X | X | X
CALL:UPLink:CHANnel[:MCHannel] |  | X | X | X
GPIB Changes for E1963A A.05, E6703B B.01 - December 2003
GPIB Command | New | Revised | Test Application | Lab Application
ABORt:<measurement mnemonic> |  | X | X | X
CALL[:CELL[1]]:BCCHannel:GSMSystem:BAND | X |  | X | X
CALL[:CELL[1]]:BCCHannel:GSMSystem:BCC | X |  | X | X
CALL[:CELL[1]]:BCCHannel:GSMSystem:NCC | X |  | X | X
CALL[:CELL[1]]:BCCHannel:GSMSystem:STATe | X |  | X | X
CALL[:CELL[1]]:BCCHannel:INTRAFREQ:CELL2:SCODe . This command is now obsolete. |  | X | X | X
CALL[:CELL[1]]:BCCHannel:INTRAFREQ:CELL3:SCODe . This command is now obsolete. |  | X | X | X
CALL[:CELL[1]]:BCCHannel:INTERFREQ:DOWNlink:CHANnel . This command is now obsolete. |  | X | X | X
CALL[:CELL[1]]:BCCHannel:INTERFREQ:SCODe . This command is now obsolete. |  | X | X | X
CALL[:CELL[1]]:BCCHannel:INTERFREQ:UPLink:CHANnel. This command is now obsolete. |  | X | X | X
CALL[:CELL[1]]:BCCHannel:ITAFrequency:SCODe | X |  | X | X
CALL[:CELL[1]]:BCCHannel:ITAFrequency:STATe | X |  | X | X
CALL[:CELL[1]]:BCCHannel:ITRFrequency:DOWNlink:CHANnel | X |  | X | X
CALL[:CELL[1]]:BCCHannel:ITRFrequency:SCODe | X |  | X | X
CALL[:CELL[1]]:BCCHannel:ITRFrequency:STATe | X |  | X | X
CALL:COMPressed:ENABle | X |  |  | X
CALL:COMPressed:MEASurement:GSMSystem:RSSI:RINTerval | X |  |  | X
CALL:COMPressed:MEASurement:GSMSystem:RSSI:RQUantity | X |  |  | X
CALL:COMPressed:MEASurement:ITRFrequency:RQUantity | X |  |  | X
CALL:COMPressed:MEASurement:ITRFrequency:RINTerval | X |  |  | X
CALL:COMPressed:MEASurement:STATe | X |  |  | X
CALL:COMPressed:MEASurement:TYPe | X |  |  | X
CALL:COMPressed:TGPSequence:DEFinition | X |  |  | X
CALL:COMPressed:TGPSequence:TGLength | X |  |  | X
CALL:COMPressed:TGPSequence:TGPLength | X |  |  | X
CALL:COMPressed:TGPSequence:TGSNumber | X |  |  | X
CALL:DPCHannel:RMC144:CCODe | X |  | X |
CALL:DPCHannel:KSPS240[:CCODe] | X |  |  | X
CALL:COUNt:DTMonitor:CLEar | X |  |  | X
CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe<:STARt|:STOP> | X |  |  | X
CALL:COUNt:DTMonitor[:ALL]:DISPlay:SPAN:TIME | X |  |  | X
CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:DISPlay:STATe | X |  |  | X
CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:DRATe? | X |  |  | X
CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:TRACe? | X |  |  | X
CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory? | X |  |  | X
CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:TRACe:HISTory:UNUMber? | X |  |  | X
CALL:DPCHannel:TYPe . This command is now obsolete. | X |  | X | X
CALL:FDDTest:COMPressed:DACTivation:TYPe | X |  |  | X
CALL:FDDTest:COMPressed:ECFNumber | X |  |  | X
CALL:FDDTest:COMPressed:SCFNumber | X |  |  | X
CALL:HANDoff[:IMMediate] . This command is now obsolete. |  | X | X | X
CALL:HANDoff:PCReconfig[:IMMediate] | X |  | X | X
CALL:HANDoff:SYSTem:GSM[:IMMediate] | X |  | X | X
CALL:HANDoff:TCReconfig[:IMMediate] | X |  | X | X
CALL:MS:LOOPback:TYPE | X |  | X | X
CALL:MS:REPorted:MEASurement:TYPe | X |  | X | X
CALL:MS:REPorted:GSMSystem:BCHannel? | X |  |  | X
CALL:MS:REPorted:GSMSystem:CELLs? | X |  |  | X
CALL:MS:REPorted:GSMSystem:RSSI? | X |  |  | X
CALL:MS:REPorted:ITRFrequency:CELLs? | X |  |  | X
CALL:MS:REPorted:ITRFrequency:DOWNlink:CHANnel? | X |  |  | X
CALL:MS:REPorted:ITRFrequency:ECNO? | X |  |  | X
CALL:MS:REPorted:ITRFrequency:PATHloss? | X |  |  | X
CALL:MS:REPorted:ITRFrequency:RSCP? | X |  |  | X
CALL:MS:REPorted:ITRFrequency:RSSI? | X |  |  | X
CALL:MS:REPorted:ITRFrequency:SCODe? | X |  |  | X
CALL:SERVice:CSData:MODE:ASYNchronous:OUTput | X |  |  | X
CALL:SERVice:CSData:PPPMode. This command is now obsolete. |  | X |  | X
CALL:SERVice:CSData:RAB. This command is now obsolete. |  | X |  | X
CALL:SERVice:GPRS:RAB |  | X |  | X
CALL:SERVice:RBTest:DTCHannel:CRC[:PRESence] | X |  | X | X
CALL:SERVice:RBTest:RAB | X |  | X | X
CALL:SERVice:RBTest:RRC:STATe | X |  |  | X
CALL:SETup[:HANDoff]:SYSTem[:TYPE] . This command is now obsolete. |  | X | X | X
CALL:SETup:TCReconfig:RBTest:RAB | X |  | X | X
CALL:STATus[:GMM]:ATTached:STATe? |  | X |  | X
CALL:STATus:COMPressed:STATe? | X |  |  | X
CALL:STATus:MM? | X |  | X | X
CALL:STATus:RRC:STATe? | X |  |  | X
CALL:STATus:SERVice:TYPe? |  | X | X | X
CALL:STATus:SHANdoff:STATe? | X |  |  | X
CALL:UPLink:TXPower:LEVel:MAXimum | X |  | X | X
FETCh:WBLerror | X |  | X | X
FETCh:WDPAnalysis | X |  | X | X
FETCh:WPDiscon | X |  | X | X
FETCh:WPPAnalysis | X |  |  | X
INITiate:DONE? |  | X | X | X
INITiate:DONE:FLAG:<measurement mnemonic> |  | X | X | X
INITiate:<measurement mnemonic>[:ON] |  | X | X | X
INITiate:ON? |  | X | X | X
INITiate:<measurement mnemonic>:OFF |  | X | X | X
READ:WBLerror[:ALL]? | X |  | X | X
READ:WDPAnalysis[:ALL]? | X |  | X | X
READ:WPDiscon[:ALL]? | X |  | X | X
READ:WPPAnalysis[:ALL]? | X |  |  | X
SETup:WBLerror | X |  | X | X
SETup:WDPAnalysis | X |  | X | X
SETup:WPDiscon | X |  | X | X
SETup:WPPAnalysis | X |  |  | X


E1963A W-CDMA Test Application Revision Information

E1963A W-CDMA Test Application Revision Information

This document describes the features in the Agilent Technologies E1963A W-CDMA Mobile Test Application releases. This document contains the original features, as well as enhancements that have been added over time.

CAUTION
You may need to upgrade the hardware in your test set before installing the application firmware described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up.
  • The application may not run.
  • Some features in the application may be inaccessible, or may not perform to specifications.

To determine if a hardware upgrade is required for your testing needs, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Select the appropriate link below to view the required release.

  • A.06 Release - January 2005
  • A.05.33 Release - July 2004
  • A.05.28 Release - April 2004
  • A.05.16 Release - January 2004
  • A.05.14 Release - December 2003
  • A.04 Release - June 2003
  • A.03 Release - February 2003
  • A.02.35 Release - August 2002
  • A.02 Release - June 2002
  • A.01 Release - November 2001 (Initial Test Application Release)

A.06 Release - January 2005

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Video Call
  • Asymmetrical RMCs .
  • Uplink Separation .
  • RB Test Mode to GSM Handoff Alerting State .
  • DRX Cycle Length (CN Domain) .
  • Cell Identity .
  • PS Domain Information .
  • UE timers: N313 UE Out-Of-Sync Counter , T313 UE Link Reestablishment Timer , and N315 UE In-Sync Counter .
  • Trigger Output Setup .

Transmitter Measurements

  • Frequency Stability measurement (see Frequency Stability Measurement Description ).
  • Phase Discontinuity measurement enhancements (see Phase Discontinuity Measurement Description ):
    • New Power Control Pattern and Number of Pattern Repetitions settings.
    • Phase due to frequency errors of previous slots no longer removed when determining Phase (in degrees) result. Previously, each phase result was adjusted to remove the accumulated phase due to the frequency error of the previous timeslot. The phase result was, in effect, the accumulation of the phase discontinuity results. The Phase result is now equal to the phase estimate that results from the minimization of the EVM result for each slot.

Receiver Measurements

  • Loopback Bit Error Ratio measurement now supports confidence testing (see Loopback Bit Error Ratio Measurement Description ).
  • Block Error Ratio measurement now supports Asymmetrical RMCs (see Block Error Ratio Measurement Description ).

A.05.33 Release - July 2004

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Resolved Known Issues

  • Assert if partial preset is initiated while call status is Releasing .
  • Assert if UE initiates a release while the call status is Setup during a UE-initiated AMR voice call.
  • Test set-originated AMR voice call is dropped by UE if user does not answer the alert quickly enough.
  • Incorrect downlink CRC and DTCH block size configuration when Uplink DTCH RMC CRC Presence is set to Used for Data .
  • Test set does not send Open UE Test Loop message during release of RB test mode call.
  • Hard handover fails due to missing IE (related to Timing Indication) in Phys Chan Reconfig message.
  • AMR voice call origination fails due to incorrect extraction of security algorithm capability parameters.

For more information, visit the 8960 Known Issues web site:

http://wireless.agilent.com/rfcomms/issues

A.05.28 Release - April 2004

Summary of GPIB command changes for this release: GPIB Changes for E1963A A.05.28, E6703B B.01.29 - April 2004

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Support for 800 MHz channels (Band VI). See DL Channel , Uplink Channel and Physical Channel Reconfiguration .

Resolved Known Issues

  • Handoff and current UARFCNs not updated on failed handoff.

For more information, visit the 8960 Known Issues web site:

http://wireless.agilent.com/rfcomms/issues

A.05.16 Release - January 2004

The functionality present in the A.05.16 release is identical to that in the A.05.14 release (see A.05.14 Release - December 2003 and GPIB Changes for E1963A A.05, E6703B B.01 - December 2003 ).

A.05.14 Release - December 2003

Summary of GPIB command changes for this release: GPIB Changes for E1963A A.05, E6703B B.01 - December 2003

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • New RB test mode Channel Types (see Radio Bearer Test Mode ):
    • 144k RMC
    • 33k No Coding RMC
  • Support for Loopback Type 2 (see UE Loopback Type ) and Uplink DTCH RMC CRC Presence .
  • Handoff changes:
    • New Transport Channel Reconfiguration capability (handoff to new RMC).
    • Ability to configure GSM cell from front panel of W-CDMA format for System Handoff . System handoffs now accessible via new Handoffs menu.
    • New Physical Channel Reconfiguration menu for hard handoffs, accessible via new Handoffs menu.
  • GSM and inter frequency neighbor cell configuration (see SIB11 Cell Info List ).
  • UE reported measurements:
    • New UE Reported Measurements screen (see UE Reported Measurements and How Do I Order and Retrieve UE Reported Measurement Results? ).
    • New Report Measurement Type setting (see Cell 1/Cell 2 UE Reported Measurements ).
  • New Call Setup Screen layout:
    • Call Processing Status area includes new MM Status .
    • UE reported measurement results moved to new UE Reported Measurements screen.
  • New Maximum Uplink Transmit Power Level setting.
  • PRACH Signature mask functionality added to test application.
  • Uplink Interference default setting changed from -75 dBm to -110 dBm.

Transmitter Measurements

  • Phase Discontinuity. See Phase Discontinuity Measurement Description .
  • Dynamic Power Analysis. See Dynamic Power Analysis Measurement Description .
  • Autoranging for Waveform Quality, IQ Tuning and Code Domain Power. See Waveform Quality Measurement Description , IQ Tuning Measurement Description and Code Domain Measurement Description ).

Receiver Measurements

  • Loopback Block Error Ratio. See Block Error Ratio Measurement Description .

A.04 Release - June 2003

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • AMR Voice service support. See AMR Voice and CALL:PAGing:SERVice[:TYPE] .
  • Support for 384k RMC in active cell operating mode. See Channel Type and Paging Service .
  • BCCH Update Page field - If BCCH Update Page is set to Inhibit, when you change a parameter that causes a BCCH Update, the test set updates its BCCH information but does NOT send a Paging Type I message to the UE. See BCCH Update Page .
  • Downlink DTCH Data type "Incrementing." See DL DTCH Data .
  • Clear MS Info. See Clearing the UE Information .
  • Uplink Dummy DCCH Data support. See Uplink Dummy DCCH Data .

Transmitter Measurements

  • Loopback BER enhancements:
    • Loopback Delay result.
      See Loopback Delay and FETCh:WBERror:LDELay? .
    • CRC Errors result.
      See CRC Errors and FETCh:WBERror:CRCerrors? .
    • Missing Blocks result.
      See Missing Blocks and FETCh:WBERror:MBLocks? .
  • PRACH Transmit On/Off Power enhancements:
    • Open Loop Power Error Upper Limit.
      See Open Loop Power Error Upper Limit and SETup:WOOPower:OPEN:LOOP:POWer:UPPer:LIMit .
    • Open Loop Power Error Lower Limit.
      See Open Loop Power Error Lower Limit and SETup:WOOPower:OPEN:LOOP:POWer:LOWer:LIMit .

Other Features

  • Support for calibration of wireless devices that use Qualcomm's radioOne Zero Intermediate Frequency (Zero IF) architecture. See CW Operating Mode , How Do I Configure Test Signals in CW Operating Mode? , and CALL[:CELL[1]]:WAVeform:TYPE:CW .

A.03 Release - February 2003

This firmware release provides you with improved call processing from the previous release, three new measurements (Inner Loop Power, PRACH Transmit On/Off Power, and IQ Tuning), and enhancements to the Spectrum Emission Mask and Occupied Bandwidth measurements. The newly added Spectrum Monitor instrument provides additional transmitter measurement functionality. Also, save/recall function is available in this release. By working with the E1968A test application, this revision allows to make an inter-system handoff from W-CDMA to GSM.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Support for inter-system hard handoff from W-CDMA to GSM. See Handoffs (Handovers) for more information.
  • Support for user selectable "Registration" or "IMSI Attach". See Performing a Location Update (Registration) .
  • Support for security operation control (security procedure with authentication and integrity protection). See Security Setup .
  • Support for UE (mobile station) reported measurement results for current cell: DPCH BLER, CPICH RSCP, CPICH Ec/No, and Pathloss. See CALL:MS:REPorted:MEASurement:REQuest .
  • Support for user settable open loop power control parameters used to determine the initial transmit power of the first PRACH preamble. See Initial PRACH Tx Power for more information.
  • Added 2.2k DCCH Signalling Radio Bear configuration for no RLC Reset during Radio Bear Setup. See Signalling Radio Bearer (SRB) Configuration for more information.
  • User settable power gain controls (beta-c and beta-d) for uplink channels (PRACH and DPCH). See Uplink Parameters .

Transmitter Measurements

  • Inner Loop PowerFor more information about this measurement, refer to Inner Loop Power Measurement Description .
  • PRACH Transmit On/Off PowerFor more information about this measurement, refer to PRACH Transmit On/Off Power Measurement Description .
  • IQ TuningFor more information about this measurement, refer to IQ Tuning Measurement Description .
  • Spectrum Emission MaskSupport for adjustable mask limits for each range. For more information, refer to Spectrum Emission Mask Measurement Description .
  • Occupied BandwidthSupport for adjustable percentage of total integrated power from 70.0 to 99.0%. For more information, refer to Occupied Bandwidth Measurement Description .
  • Spectrum Monitor MeasurementThe Spectrum Monitor measurement feature has been added. This allows you to find, identify and measure transmitted signals from your UE (mobile phone). It can also be used for spur measurements in the transmit band. See Spectrum Monitor Description .

Other Features

  • Save/Recall

    This function allows you to store the test set's current settings to a register and retrieve them later, eliminating the task of reconfiguring the test set. See Save and Recall Registers .

A.02.35 Release - August 2002

This firmware release provides you with improved call processing from the previous release.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • 64k RMC capability has been improved in both active cell and test mode.
  • Call limit state

    This allows you to make power measurements on PRACH preambles by not permitting the test set to respond. See Call Limit State for more information.

  • Expected values for open loop power control are now available on the display and via GPIB. See:
    • CALL:UPLink:DPCChannel:POWer:INITial?
    • CALL:UPLink:PRAChannel:POWer:INITial?
  • PRACH signature capability has been improved.

Measurements

  • Timing error is now returned in chips instead of seconds for the Waveform Quality and Code Domain measurements.

A.02 Release - June 2002

This firmware release provides you with call processing, including base station originate, base station release, and closed loop power control, an additional reference measurement channel, 64k RMC, three new measurements, Spectrum Emission Mask, Occupied Bandwidth, and Code Domain Power, and enhancements to the Waveform Quality and Channel Power measurements. Also, a GPIB help mode exists in this firmware. This revision works with the E1985A fast switching test application.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Network initiated origination

    This allows you to originate a call from the test set. See CALL:ORIGinate .

  • Network initiated release.

    This allows you to end a call from the test set. See CALL:END .

  • Closed loop power control

    For more information, refer to Uplink Closed Loop Power Control Parameters and UE Target Power .

  • Support for a 64k Reference Measurement Channel (RMC) has been added in this release. Refer to CALL:DPCHannel:TYPe for more information.
  • Hard handoff capability is available in this release. Only handoffs to new downlink and uplink channels are supported. It is not possible to switch between the 12.2k and 64k RMC while on a call. A new command has been added to initiate the handoff. (See CALL:HANDoff .)
  • UE reported information

    This command allows you to query the test set for information the UE has sent about its identification, power class, etc. For more information, refer to CALL:MS:REPorted .

  • Cell parameters that can be configured include the following:
    • Local Area Code (See CALL:LACode )
    • Mobile Country Code (See CALL:MCCode )
    • Mobile Network Code (See CALL:MNCode )
    • Repeat Paging (See CALL:PAGing:REPeat[:STATe][:SELected] )
  • New downlink signal parameters that can be configured:
    • AICH Channelizaton Code, Initial Channel Level (See CALL:AICHannel )
    • DPCH Initial Channel Level (See CALL:DPCHannel:LEVel )
    • P-CCPCH Initial Channel Level (See CALL:CCPChannel:PRIMary:LEVel )
    • S-CCPCH Channelization Code, Initial Channel Level (See CALL:CCPChannel )
    • CPICH Initial Channel Level (See CALL:CPIChannel )
    • PICH Channelization Code, Initial Channel Level (See CALL:PICHannel )
    • Connected Channel Level for P-CCPCH, S-CCPCH, CPICH, PICH, and DPCH (See CALL:CONNected )
    • Signaling Radio Bearer Channelization Code, Data Rate (See CALL:SRBearer )
  • Uplink signal parameters that can be configured:
    • Uplink Channel (See CALL:UPLink:CHANnel[:MCHannel] )
    • Uplink DPCH Scrambling Code (See CALL:UPLink:DPCHannel:SCODe )
    • PRACH Power Step (See CALL:UPLink:PRAChannel:POWer[:RAMP]:STEP[:LEVel]
    • PRACH Signature (See CALL:UPLink:PRAChannel:SIGNature )
    • PRACH Scrambling Code (See CALL:UPLink:PRAChannel:SCODe )
    • PRACH Timing Offset (See CALL:UPLink:PRAChannel:TIMing[:OFFSet]

Measurements

  • Spectrum Emission Mask

    For more information about this measurement, refer to Spectrum Emission Mask Measurement Description .

  • Occupied Bandwidth

    For more information about this measurement, refer to Occupied Bandwidth Measurement Description .

  • Code Domain

    For more information about this measurement, refer to Code Domain Measurement Description .

  • The Waveform Quality measurement now makes timing error and peak code domain error available as measurement results. Support for immediate triggering for making asynchronous EVM measurements has been added. For more information, refer to the Waveform Quality Measurement Description .
  • The Channel Power measurement has been enhanced to allow you to turn the RRC filter on and off. For more information refer to SETup:WCPower:FILTer[:RRC] .

Other

  • Help Mode

    This release enables the HELP key on the test set's front panel. When in help mode, the test set provides GPIB syntax assistance. For more information, refer to Help Mode .

  • This release gives you the first revision of the W-CDMA Test Application that can be used with the E1985A GSM_136/AMPS_GPRS fast switching test application. This release when used with the E1985A GSM_AMPS/136_GPRS_WCDMA fast switching test application allows you to switch quickly between GSM, AMPS/136, GPRS, and W-CDMA formats.

    When writing program code for use with the E1985A, there are several parameters which require the format identifier, :WCDMA, to be appended. For details on these commands, refer to the user documentation for the GSM_AMPS/136_GPRS_WCDMA fast switching test application.

  • Measurements have to be recalibrated when you switch to the E1963A W-CDMA Test Application from the E1962B CDMA2000 Test Application of release revisions B.05 or lower.

A.01 Release - November 2001 (Initial Test Application Release)

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

This release of the W-CDMA test application does not provide call processing. Therefore, call processing operations, such as base station origination (paging) and registration, are not available to establish a connection between the test set and the user equipment (UE).

A frequency division duplex (FDD) test mode is available to provide a downlink signal that a properly configured UE can synchronize to in order to transmit a corresponding uplink signal. The test set can then demodulate the uplink signal and make waveform quality and loopback bit error ratio measurements. See FDD Test Operating Mode for a description of this feature.

Transmitter Measurements

  • Thermal Power. This is an unfiltered, broad-banded power measurement that uses a thermal detector to measure the total power of all signals present at the test set's RF IN/OUT connector down to -10 dBm. Because of its high accuracy, this is the preferred power measurement for the Maximum Output Power test (3GPP TS 34.121, section 5.2, v3.2.0) to verify that the UE is transmitting at the correct level when transmitting at its highest output level. See Thermal Power Measurement Description .
  • Channel Power. This is a filtered power measurement that can be used to measure high level and low level signals within a 3.84 MHz bandwidth. This measurement is used in the Transmit Off Power test (3GPP TS 34.121, section 5.5.1, v3.2.0). It can also be used for calibrating mobile TX power. These tests require specific power levels to be measured within the 3.84 MHz channel bandwidth. See Channel Power Measurement Description .
  • Adjacent Channel Leakage Ratio. Power is measured within a 3.84 MHz bandwidth at +/-5 MHz and +/-10 MHz offsets from the center frequency. The measurement results can be displayed in either numeric and graphical formats. This measurement is defined in 3GPP TS 34.121, section 5.10, v3.2.0, Adjacent Channel Leakage Power Ratio (ACLR) , which verifies that the mobile station is not transmitting too much power outside of its 3.84 MHz channel bandwidth, which could interfere with other frequency channels. See Adjacent Channel Leakage Ratio Measurement Description .
  • Waveform Quality. This measurement returns the composite error vector magnitude (EVM), frequency error, origin offset, phase error, and magnitude error of the received signal. This measurement is used for the Error Vector Magnitude (EVM) test in 3GPP TS 34.121, section 5.13.1, and for the Frequency Error test in 3GPP TS 34.121, section 5.3, v3.2.0. These measurements verify the accuracy of the transmitter's modulation circuitry and RF source. For this FDD test mode release, this measurement can only be performed on a 12.2 kbps reference measurement channel (RMC) that is synchronized to the downlink signal from the test set. See Waveform Quality Measurement Description .

Receiver Measurements

  • Loopback bit error ratio (BER). This measurement uses the UE in loopback mode 1 to test the sensitivity of its receiver. The receiver sensitivity test is described in 3GPP TS 34.121, section 6.2, v3.2.0, Reference Sensitivity Level . When using the test set's FDD Test operating mode, the user must configure the UE in the loopback mode 1 to perform this measurement; no provision is made to send messages over the downlink signal to the UE to configure it. See Loopback Bit Error Ratio Measurement Description .

Other Features

Base Station Emulation in FDD Test Operating Mode

Base station emulation for this release is limited to sending a configurable downlink signal that the UE can synchronize to in order to transmit a corresponding uplink signal. The downlink does not send any commands to the UE to configure it for testing. All control of the UE must be provided by the user.

Downlink signal parameters that can be configured include the following settings:

  • Downlink channel codes:
    • Primary Scrambling Code
    • PICH Channelization Code
    • DPCH 12.2 RMC Channelization Code
  • Downlink channel levels:
    • FDD Test CPICH Level
    • FDD Test P-CCPCH/SCH Level
    • FDD Test PICH Level
    • FDD Test DPCH Level
  • Orthogonal Channel Noise Simulator - OCNS is automatically turned on and off, and the level set, as the downlink channel levels are changed. See Noise Sources on the Downlink .
  • Additive White Gaussian Noise (AWGN)
  • Downlink Transport Format Combination Indicator (TFCI)
  • Downlink channel
  • Downlink DTCH data type
  • Downlink PICH data pattern

Power control bit patterns can also be configured on the downlink. This allows you to vary the value being sent for the uplink closed loop power control data, and to send step up and step down power control sequences.

CW Operating Mode

CW operating mode provides an unmodulated RF generator signal with an adjustable level from -10 dBm to -127 dBm.


Adjacent Channel Leakage Ratio Troubleshooting

Adjacent Channel Leakage Ratio Troubleshooting

Possible Setup Issues

During remote operation of the adjacent channel leakage ratio measurement, you should configure the trigger arm to single. See SETup:WACLeakage .

If the trigger arm is not set to single, you may not be able to retrieve measurement results during remote use if you are using the INIT:DONE? query. When the trigger arm is continuous, the measurement rearms itself and starts another measurement cycle, causing the INIT:DONE? query to always return "WAIT". See Trigger Arm (Single or Continuous) Description for more explanation.

The trigger source defaults to Auto for the adjacent channel leakage ratio measurement, and tries to use protocol triggering if the mobile station (UE) is synchronized to the test set. Immediate triggering is used if the mobile station is not synchronized. While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to Immediate or External .

The measurement results are the calculated ratios between the in-channel power and adjacent channels and are therefore not adjusted by any amplitude offsets that are entered.

Interpreting Integrity Indicator Values

This measurement uses auto-ranging to automatically set the expected level into the test set.

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. See Measurement Calibration Indicator values .

See Integrity Indicator .

Related Topics

Adjacent Channel Leakage Ratio Measurement Description


AFANalyzer Troubleshooting

AFANalyzer Troubleshooting

Possible Setup Issues

During remote operation of the Audio Analyzer, you should always set the Trigger Arm to Single. The length of time required to return a measurement over GPIB using continuous triggering varies, but is always longer than when using single triggering. Continuous triggering can also cause problems when the INITiate:DONE? query is used.

The Detector Type selected (peak or rms) also sets how Audio Level measurements are displayed; as a peak value or an rms value. When comparing returned values over GPIB to your specifications, be sure to take into account the type of detector being used.

The Expected Peak Voltage is always set in V peak , regardless of the Detector Type selected, and cannot exceed 20 V peak (14.1 V rms ).

For accurate measurements, always set all Audio Analyzer setup parameters to their proper settings for the measurement being made. The SINAD and Distortion measurements typically use different settings than the Audio Level measurement. See Audio Analyzer Measurement Description and Audio Analyzer Block Diagram .

For very low level audio signals, use the 100 Hz BW BPF filter to reduce the affects of noise (see Audio Level Measurement Description ).

For accurate Audio Frequency measurements where more than one signal may be present, use the 100 Hz BW BPF filter to isolate the desired signal (see Audio Level Measurement Description ).

Interpreting Integrity Indicator Values

See Integrity Indicator .

If over range (5) is returned, the input level is greater than 4.9 dB above the Expected Peak Amplitude value or the maximum input level of 20 volts peak.

If under range (6) is returned, the input level is lower than 8 dB below the Expected Peak Amplitude value.

If the signal has both over range and under range conditions, only the over range condition (5) is indicated.


Error Message Log

Error Message Log

Description

When an error message is displayed, it is also logged in the error message log. This log is only accessible manually; it is not available through GPIB. The error message log can be displayed by pressing the F7 menu key from the SYSTEM CONFIG screen. Next Page and Previous Page controls are provided.

All errors and events that are generated are displayed in the error message log. When the log is full a new message is sent to the log and the oldest message is removed from the log. The log is cleared when the test set powers up or when you press F10 (Clear Error Message Log).

Related Topics

Error Messages


Troubleshooting Call Processing Operations

Troubleshooting Call Processing Operations

  • Base Station Emulator Configuration
  • Registration
  • Establishing a Call

Base Station Emulator Configuration

  • DL Channel , Uplink Separation or Uplink Channel settings will be rejected, and an error posted, if you attempt any of the following:
    • With Uplink Channel set to Auto , set DL Channel to a value that would result in an Uplink Channel that is not within the supported range (based on the current Uplink Separation setting).
    • With Uplink Channel set to Auto , set Uplink Separation to a value that would result in an Uplink Channel that is not within the supported range (based on the current DL Channel setting).
    • Set Uplink Channel to Auto when the current DL Channel and Uplink Separation values would result in an Uplink Separation that is not within the supported range.

    You must instead do the following: with Uplink Channel not set to Auto , set DL Channel and Uplink Separation to a valid combination, then set Uplink Channel to Auto .

Registration

  • Call Limit must be OFF for any random access procedure such as Location Update or BS Origination (paging) to be successful. See Call Limit State .

  • UE Does Not Register with Test Set

    If your UE does not register with the test set, you may need to:

    • Set ATT (IMSI Attach) Flag State to Set , and then turn the UE's power off and on.
    • Increase the Cell Power level.

  • UE Does Not Camp to Test Set at Low Cell Power Levels

    To determine whether to camp to a cell, the UE measures the CPICH RSCP for the cell, and then compares it to the minimum CPICH RSCP required to camp to the cell (the test set specifies a minimum CPICH RSCP of -115 dBm). If the UE's maximum transmit power is less than the Maximum Uplink Transmit Power Level specified by the test set, then the UE must subtract this difference from it's CPICH RSCP value before comparing it to the minimum requirement of -115 dBm. For example, if Maximum Uplink Transmit Power Level is set to +33 dBm, the UE's maximum transmit power is +24 dBm, and the UE measures a CPICH RSCP of -111 dBm, then it will not camp to the test set (-111 dBm - (33 dBm - 24 dBm) = -120 dBm, which is less than the minimum required level of -115 dBm). If Maximum Uplink Transmit Power Level were set to +24 dBm, then the UE would camp to the test set (-111 dBm is greater than the minimum required level of -115 dBm). To ensure that your UE will camp to the test set at low cell power levels, set Maximum Uplink Transmit Power Level to the maximum transmit power for your UE.

  • Test Set in Cell Barred List

    If Call Limit State is set to On and you page the UE, the test set will not respond to the UE's PRACH sequence. If the UE reaches the end of its sequence without an acknowledgment from the test set, it may place the test set into its cell barred list. (This may need to occur several times before the UE places the test set into its cell barred list). This means the UE will not look for the test set on its next attempt to camp to a base station. (After a certain amount of time, the UE will resume its consideration of the test set when trying to camp to a base station). If the test set has been added to the UE's cell barred list, you may need to:

    • Change the Local Area Code (LAC) of the test set.
    • Turn the UE off, then back on.
    • With the UE powered on, wait until the UE's cell barred timer expires (this can be as much as 20 minutes), such that it will then search for the test set when trying to camp.

  • UE Registers Continuously Due to Integrity Protection Expectation

    If the UE expects integrity protection to be enabled then it will continually attempt to register (as often as every 30 seconds) until the location update procedure successfully starts integrity protection. For integrity protection to be successfully started, the Security Operations setting must be 'Auth+Int' and the rest of the parameters on the Security Settings menu (excluding 'RAND') must match those in the uSIM. See Security Setup .

Establishing a Call

  • Call Limit must be OFF for any random access procedure such as Location Update or BS Origination (paging) to be successful. See Call Limit State .

  • UE Does Not Connect to Test Set

    To successfully establish a call, you may need to:

    • Set RLC Reestablish to Off .
    • Set Uplink Timing Offset to match your UE PRACH signal's offset from the access slot.

  • UE Does Not Respond to Test Set's Page

    If your UE registers with the test set, but does not respond to the test set's page, try this alternate (and usually faster) test set-originated connection procedure:

    1. Connect the UE to the test set, but do not power it on.
    2. Set Operating Mode to Cell Off .
    3. Set Repeat Paging to On .
    4. Set ATT (IMSI Attach) Flag State to Set .
    5. Set Operating Mode to Active Cell .
    6. Select Originate Call and power on the UE.

    After the UE registers with the test set (performs a Location Update), rather than releasing the RRC connection, it will immediately move to connecting the RB test mode call as there is a page request outstanding.

  • To establish an RB Test Mode call, you must set Paging Service to RB Test Mode and originate the call from the test set. You can not originate an RB Test Mode call from the UE.

  • Call Setup Fails Due to Transmission of Single PRACH Preamble

    To aid in successful call completion, ensure that your UE does not begin its PRACH preamble sequence at the Maximum Uplink Transmit Power Level or its maximum transmit power (the maximum power it is physically able to transmit). If the UE supports early termination of the PRACH procedure, it will terminate the PRACH preamble sequence once it reaches the maximum transmit level for the cell (as specified by Maximum Uplink Transmit Power Level ) or is maximum transmit power. If a UE supporting early termination begins its PRACH transmission at either of these maximum levels, it will only transmit one PRACH preamble, causing the call setup procedure to fail (the test set requires two consecutive preambles before it will issue a positive indication on the AICH). See Initial PRACH Tx Power .

Related Topics

Performing a Location Update (Registration)


Channel Power Troubleshooting

Channel Power Troubleshooting

Possible Setup Issues

During remote operation of the channel power measurement you should configure the trigger arm to single. See SETup:WCPower .

If the trigger arm is not set to single, you may not be able to retrieve measurement results during remote use if you are using the INIT:DONE? query. When the trigger arm is continuous, the measurement rearms itself and starts another measurement cycle, causing the INIT:DONE? query to always return "WAIT". See Trigger Arm (Single or Continuous) Description for more explanation.

The trigger source defaults to Auto for the channel power measurement, and tries to use protocol triggering if the mobile station (UE) is synchronized to the test set. Immediate triggering is used if the mobile station is not synchronized. While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to Immediate or RF Rise .

RF Rise triggering should only be used when a burst is sent, such as a PRACH burst.

Autoranging is not available for this measurement. The expected input level is determined by either the MS Target Power setting, when automatic receiver control is used (default), or by the Manual Power setting when manual receiver control is selected. See Receiver Control .

Measurement results are affected by any amplitude offsets that are entered. See Amplitude Offset .

The channel power measurement value may be slightly lower than the thermal power measurement's value (typically about 0.25 dB). This is because the channel power measurement is band-limited, rejecting the additional power that may be in the uplink signal's sidebands.

Interpreting Integrity Indicator Values

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. See Measurement Calibration Indicator values .

See Integrity Indicator .

Related Topics

Channel Power Measurement Description


Code Domain Troubleshooting

Code Domain Troubleshooting

Possible Setup Issues

During remote operation of the code domain measurement, you should configure the trigger arm to single. See SETup:WCDomain .

If the trigger arm is not set to single, you may not be able to retrieve measurement results during remote use if you are using the INIT:DONE? query. When the trigger arm is continuous, the measurement rearms itself and starts another measurement cycle, causing the INIT:DONE? query to always return "WAIT". See Trigger Arm (Single or Continuous) Description for more explanation.

The mobile station (UE) must be synchronized to the test set for this measurement to operate correctly.

While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to Immediate or External .

Timing Error results are not available when Trigger Source is set to Immediate .

Interpreting Integrity Indicator Values

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Cannot Correlate (17) is returned, the test set cannot demodulate the signal from the mobile station (UE). Make sure the uplink scrambling code from the mobile station matches the UL Scrambling setting on the test set (see CALL:UPLink ).

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. See Measurement Calibration Indicator values .

See Integrity Indicator .

Related Topics

Code Domain Measurement Description


Troubleshooting Compressed Mode Operation

Troubleshooting Compressed Mode Operation

This section is only applicable to the lab application

  • Compressed mode can only be activated when the UE and test set are on a 12.2k RMC call in RB test mode (see Channel Type and Paging Service and Establishing a Connection with the UE ).
  • Compressed mode can only be activated when the DPCH channelization code is 20, 29, 37, 45, 60, 70, 76, 87 or 93. Any other channelization codes may cause compressed frames to collide with other downlink channels (see Setting Downlink Channel Codes ). Before beginning compressed mode testing, you must place the test set in Cell Off Operating Mode , and change the DPCH channelization code to an acceptable value.
  • If Compressed Mode State is On but no UE measurement results are displayed on the measurement results screens, consider the following:
    • To retrieve UE compressed mode measurement results, you must first enable UE measurements during compressed mode activation using the UE Measurements in Compressed Mode parameter.
    • The UE will only perform measurements on EITHER the GSM neighbor cells OR the Inter Freq neighbor cells, but not both. You must specify which cells to measure and report using the Compressed Mode Measurement Purpose parameter.

  • While in compressed mode operation, the uplink closed loop power control algorithms function normally. Note however that the test set does not send power control bits during transmission gaps. If you request the test set to send a power control sequence such as continuous 10 Up/Down bits during compressed mode operation, when a transmission gap occurs, the test set will stop sending power control bits during the transmission gap, and then continue sending the power control bits in the sequence after the transmission gap is over (it does not restart the 10 up/down pattern, it continues where it left off before the transmission gap occurred). This means the 10 up/down pattern will no longer be aligned to a 20 ms TTI boundary. When you deactivate compressed mode, the 10 up/down pattern will remain unaligned to the 20 ms TTI boundary. To reestablish alignment, you must select another pattern, such as Alternating bits , then reselect 10 Up/Down bits .

Related Topics

Compressed Mode


Troubleshooting External Device Connection

Troubleshooting External Device Connection

This section is only applicable to the lab application and to a test application with the required feature license.

Description

  • When connecting two 8960s, it is recommended that you connect them via a hub, rather than through a gateway or WAN link, or connect them directly using a LAN crossover cable. This helps minimize the risk of lost data due to delayed packets.
  • Before initiating an external device connection between two 8960s, you can verify that the two test sets are able to communicate by pinging one test set from the other. To do so, on 8960 #1:
    • Press the Call Setup key, then the left More key until the Ping menu is available.
    • Select Ping , then Ping Setup ( F1 ).
    • Set Device to Ping to Alternate ( CALL:DATA:PING:SETup:DEVice ).
    • Set the Alternate Ping Address to the IP address of 8960 #2 ( CALL:DATA:PING:SETup:ALTernate:IP:ADDRess ).
    • Select Start Ping ( F3 ) ( CALL:DATA:PING:STARt ).
  • When you select Connect to External 8960 , if the External Device Conn Status moves from Not Connected to Connecting to Connected and then immediately moves to Disconnecting and then Not Connected , check the other 8960 for an error condition. The 8960 you are attempting to connect to may not have the hardware or license required for the External Device Connection feature.
  • Ensure that Ext 8960 IP Addr on the 8960 originating the connection is equal to the LAN IP Address of the 8960 you wish to connect to (the LAN IP Address of each 8960 is shown in the LAN Connection Information window of the External Device Connection Setup screen as LAN (Self) IP Address , and also viewable/settable from the Instrument Setup ( F1 ) menu of the System Config screen).
  • Ensure that Subnet Mask and Default Gateway are configured properly for each test set.
  • Ext 8960 IP Addr and Connected Device IP Address will always be equal on the display of the test set that initiated the external device connection. However, Ext 8960 IP Addr and Connected Device IP Address can be different on the test set that was connected to, as Ext 8960 IP Add is only used when initiating an external device connection.
  • Ext 8960 IP Addr can not be set to the same value as LAN IP Address or DUT IP Address . If LAN IP Address is set to the value of Ext 8960 IP Addr , Ext 8960 IP Addr is reset to a blank field.
  • The external device connection is not affected by a partial preset. However, the external device connection is disconnected as a result of a full preset.

Related Topics

External Device Connection


Fixed Timer Messages

Fixed Timer Messages

Description

This is the list of fixed timers with a brief explanation and their values. A timer expiry message appears in its own window, on the test set display. The user has no access to these values and can not change them. None of the fixed timers are active when operating mode is Test Mode.

Timer Name | Description | Value
T100 RADIO-LINK-TIMEOUT | Detects the presence of the radio link by detecting SACCH frames every 480 ms. | 4 SACCH multiframes. That is 1.92 seconds if the SACCH is completely absent.
T200 Data link timer | Used for re-transmission on the data link. The value varies depending on the message type. | 155 ms for FACCH
T301 Alerting (ringing) timer | Timer used to limit the amount of time a user has to answer a call. | 20 seconds
T303 Mobility Management connection timer | Time the network waits after sending a CM SERVICE REQUEST until receiving a response. This occurs before initiating call clearing procedures towards the MS. | 10 seconds
T305 Release timer | Time the network waits after transmitting a DISCONNECT message until receiving a RELEASE message. | 10 seconds
T306 In-band tones release timer | Time the network waits after transmitting a DISCONNECT message while in-band tones/announcements are provided, until receiving a RELEASE message. | 10 seconds
T308 Release timer | Time the network waits after sending a RELEASE message until receiving a RELEASE COMPLETE message. This occurs before re-transmitting the RELEASE or releasing the Mobility Management connection. | 10 seconds
T310 Call proceeding timer | Time the network waits after receiving a CALL CONFIRMED message until receiving a ALERTING, CONNECT, or DISCONNECT message before initiating clearing procedures towards the MS. | 10 seconds
T313 Connect acknowledge timer | Time the network waits after transmitting a CONNECT message until receiving the CONNECT ACKNOWLEDGE message before performing clearing procedures with the MS. | 10 seconds
T323 Modify complete timer | Time the network waits after sending a MODIFY message during call mode changes, until receiving a MODIFY COMPLETE or MODIFY REJECT message before initiating call clearing procedures. | 10 seconds
T3101 Immediate assignment timer | Time the network waits after sending the IMMEDIATE ASSIGNMENT or IMMEDIATE ASSIGNMENT EXTENDED message until the main signalling link is established before releasing the newly allocated channels. | 1 second
T3103 Handover timer | Time the network waits after transmitting a HANDOVER COMMAND message until receiving HANDOVER COMPLETE or HANDOVER FAILURE or the MS re-establishes the call before the old channels are released. If the timer expires and the network has not received a correctly decoded L2 (format A or B) or TCH frame, then the newly allocated channels are released. | 2 seconds
T3105 Physical information repetition timer | Time the network waits after sending the PHYSICAL INFORMATION message until receiving a correctly decoded L2 (format A or B) or TCH frame. This occur before re-transmitting the PHYSICAL INFORMATION message or releasing the newly allocated channels. | 50 ms
T3107 Channel assignment timer | Time the network waits after transmitting an ASSIGNMENT COMMAND message until receiving the ASSESSMENT FAILURE message or the MS re-establishes the call before releasing the old and the new channels. | 3 seconds
T3109 Signalling disconnection timer | Time the network waits after sending the CHANNEL RELEASE message before disconnecting the signalling link. | 5 seconds
T3111 Channel deactivation after disconnection timer | Time the network waits after disconnecting the signalling link before deactivating the channel. | 500 ms
T3113 Paging timer | Time the network waits after transmitting the PAGING REQUEST message until receiving the PAGING RESPONSE message. This occurs before re-transmitting the PAGING REQUEST (if the maximum number of re-transmissions have not been exceeded). | 5 seconds
T3212 Location update timer | The location update timer is set to zero, periodic location update by the MS are disabled. If the MS camps to the BCH and decodes a new MCC or MNC from the one it last camped on, it should perform a location update. | zero = infinite time
T3250 TMSI reallocation timer | Time the network waits after sending the TMSI REALLOCATION COMMAND until receiving TMSI REALLOCATION COMPLETE. This occurs before aborting the procedure and releasing the Radio Resource connection. | 5 seconds
T3260 Authentication response timer | Time the network waits after an AUTHENTICATION REQUEST until receiving AUTHENTICATION RESPONSE. This occurs before aborting the procedure and releasing the Radio Resource connection. | 5 seconds


Error Messages

Error Messages

Error Message Descriptions

Fixed Timer Messages

Manual User Error Messages

-400 through -499 Error Message Descriptions

-300 through -399 Error Message Descriptions

-200 through -299 Error Message Descriptions

-100 through -199 Error Message Descriptions

+100 through +199 Error Message Descriptions

+200 through +299 Error Message Descriptions

+300 through +399 Link Control Device-Specific Error

+400 through +499 Error Message Descriptions

+500 through +599 Test Application Hardware Device-Specific Error

+600 through +699 Error Message Descriptions

+700 through +799 Error Message Descriptions

+800 through +899 Error Message Descriptions

Description

Reading Error Messages

Each error message that is generated is recorded in either the error/event queue or the message log or both. Error messages are shown in a message window at the center of the test set's display.

When an error message is displayed, an audio beep occurs; the beeper state of the test set can be set to on or off.

The error/event queue is read remotely using the SYSTem:ERRor? query. The error/event queue is able to hold 100 messages. To read the entire error/event queue use the following program.

10 DIM Err_msg$[255]
20 REPEAT
30 OUTPUT 714;"SYSTEM:ERROR?"
40 ENTER 714; Err_num,Err_msg$
50 PRINT Err_num,Err_msg$
60 UNTIL Err_num = 0

The message log may be viewed on the test set's display by pressing the SYSTEM CONFIG screen's Message Log key. The message log can display up to 24 entries over two pages.

Error messages can be cleared from the test set's display using the DISPlay:WINDow:ERRor:CLEar command. Pressing any functional front panel key, i.e. the LOCAL key, will clear an error message from the test set's display.

Classes of Errors

Error messages are divided into classes, each class of error is handled differently by the test set. The message log is cleared when the test set is power cycled.

Measurement Integrity Indicators

These messages occur as a result of a measurement, they indicate the validity of the measurement. Measurement integrity indicators are read with the FETCh command.

Non-Persistent Errors

These messages are generated when a condition occurs that is incorrect, but has no serious or long lasting effect on the test set's operation. Examples could include an out of range value to a parameter, or an invalid GPIB mnemonic. The message window is cleared when any front panel key is pressed.

Persistent Errors

These errors are generated when a non-transitory error condition exists. Persistent errors occur when a hardware failure is found, or when damage or injury to a person or the test set may occur.

The test set displays these errors in the error message window and as a prompt at the bottom of the display screen where it remains until the error condition no longer exists.

Fatal Errors

When these errors occur no further operation of the test set is possible without cycling the power switch. Fatal errors are not saved in the error message log. The test set display will provide the user with information about what to do next and some details about what the test set was doing when the fatal error occurred.

Maskable Messages

These messages are intended to inform the user of a condition within the test set. They are generally meant to provide information to the user. The user will need to decide if this condition is undesirable and if they want the message to appear.

Maskable Message Display State

The Maskable Messages Display State found in the Instrument Setup menu gives users a way to block these messages and the associated beep from ever happening. When the state is Off these messages and their associated beep will be blocked. The Maskable Message Display State can be set manually or with the following GPIB command:

OUTPUT 714;"DISPLAY:MESSAGE:MASKABLE:STATE OFF"
! Prevents certain messages from appearing on the display.

Instrument Maskable Messages

  • Instrument warning: Audio Generator instrument has been closed.
  • Instrument warning: Audio Analyzer instrument has been closed.
  • Instrument warning: Analog Audio instrument has been closed.

Related Topics

SYSTem:ERRor?


Manual User Error Messages

Manual User Error Messages

Description

These messages are intended to be displayed on the manual user interface only, and are not entered into the Error/Event Queue.

Error Message | Description
The function you requested is not yet available. | The test set does not have this capability.
IQ Calibration completed successfully for modulator <N> | <N> is the IQ modulator number that you are attempting to calibrate, <N> is 1 or 2.
IQ Calibration failed for modulator <N> | <N> is the IQ modulator number that you are attempting to calibrate, <N> is 1 or 2.
The function you requested is not available in this TA. | This function is used in another Test Application.
IQ Calibration for modulator 1 in progress (10 minutes). Call processing disabled. | This error is cleared by either the; IQ Calibration completed successfully for modulator <N>, or IQ Calibration failed for modulator <N>.
IQ Calibration for modulator 2 in progress (6 minutes). Call processing disabled. | This error is cleared by either the; IQ Calibration completed successfully for modulator <N>, or IQ Calibration failed for modulator <N>.
Instrument warning: Audio generator instrument has been closed. | The audio generator instrument was closed automatically by the test set.
Measurement warning: Audio Analyzer instrument has been closed. | The audio analyzer instrument was closed automatically by the test set.
Measurement warning: Analog audio measurement has been closed. | Analog audio measurements have been closed by the test set.
Protocol warning: Setting change has terminated the link with the DUT | Some setting change has caused the call to disconnect.
Warning; Call processing disabled | The call processing functions are not active because the test set is performing calibration operations.
IQ first modulator calibration X% | IQ modulator calibration in progress, X represents the percent complete.
IQ second modulator calibration X% | IQ modulator calibration in progress, X represents the percent complete.

WCDMA and FDD Manual User Messages

Error Message | Description
WCDMA common measurements calibration completed successfully. | The calibration procedure for WCDMA measurements completed without problems.
WCDMA common measurements calibration failed due to temperature drift. Wait for temperature to stabilize. | The temperature in the test set was changing during calibration, causing the calibration to fail.
WCDMA common measurements calibration failed due to oven out of range. | Indicates an internal problem during measurement calibration.
WCDMA common measurements calibration failed due to loopback switch problem. | Indicates an internal problem during measurement calibration.
WCDMA common measurements calibration failed due to under range condition. | Indicates an internal problem during measurement calibration.
WCDMA common measurements calibration failed due to over range condition. | Indicates an internal problem during measurement calibration.
WCDMA common measurements calibration failed due to correlation problem. | Indicates an internal problem during measurement calibration.
WCDMA common measurements calibration failed. | The measurement calibration procedure failed for an unspecified reason.
WCDMA common measurements calibration in progress. Do not apply RF power during calibration | Tells you to not apply power during measurement calibration.
WCDMA common measurements calibration <x>%. | Progress indicator for the measurement calibration routine.
FDD measurement warning; Thermal Power measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict. This message is typically generated when thermal power measurements are initiated.
FDD measurement warning; Adjacent Channel Leakage Ratio measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict. This message is typically generated when adjacent channel leakage ratio measurements are initiated.
FDD measurement warning; Waveform Quality measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict. This message is typically generated when waveform quality measurements are initiated.
FDD measurement warning; Channel Power measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict. This message is typically generated when channel power measurements are initiated.
FDD measurement warning; Loopback Bit Error Ratio measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict. This message is typically generated when loopback bit error ratio measurements are initiated.
FDD measurement warning; Spectrum Emission Mask measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict. This message is typically generated when spectrum emission mask measurements are initiated.
FDD measurement warning; Code Domain measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict. This message is typically generated when code domain measurements are initiated.
FDD measurement warning; Occupied Bandwidth measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict. This message is typically generated when occupied bandwidth measurements are initiated.


-100 through -199 Error Message Descriptions

-100 through -199 Error Message Descriptions

Description

A command error indicates that the test set's GPIB parser has detected an IEEE 488.2 syntax error.

When one of these errors is generated, the command error bit in the event status register is set.

Error Message | Description
-100 Command error | This event bit (Bit 5) indicates a syntax error, or a semantic error, or a GET command was entered, see IEEE 488.2, 11.5.1.1.4.
-101 Invalid character | Indicates a syntactic elements contains a character which is invalid for that type.
-102 Syntax error | Indicates that an unrecognized command or data type was encountered. For example, a string was received when the device does not accept strings.
-103 Invalid separator | The parser was expecting a separator and encountered an illegal character. For example, the semicolon was omitted after a program message unit.
-104 Data type error | The parser recognized a data element different than one allowed. For example, numeric or string data was expected but block data was encountered.
-105 Get not allowed | Indicates a Group Execute Trigger was received within a program message. Correct the program so that the GET does not occur within the program code.
-108 Parameter not allowed | Indicates that more parameters were received than expected for the header. For example, *ESE common command only accepts one parameter, so *ESE 0,1 is not allowed.
-109 Missing parameter | Indicates that less parameters were received than required for the header. For example, *ESE requires one parameter, *ESE is not allowed.
-110 Command header error | Indicates an error was detected in the header. This error is used when the device cannot detect the more specific errors -111 through -119.
-111 Header separator error | Indicates that a character that is not a legal header separator was encountered while parsing the header.
-112 Program mnemonic too long | Indicates that the header contains more that twelve characters, see IEEE 488.2, 7.6.1.4.1.
-113 Undefined header | Indicates the header is syntactically correct, but it is undefined for this specific device. For example, *XYZ is not defined for any device.
-114 Header suffix out of range | Indicates the value of a header suffix attached to a program mnemonic makes the header invalid.
-120 Numeric data error | This error, as well as errors -121 through -129, are generated when parsing a data element which appears to be numeric, including non-decimal numeric types. This particular error is used if the device cannot detect a more specific error.
-121 Invalid character in number | Indicates an invalid character for the data type being parsed was encountered. For example, an alpha in a decimal numeric or a "9" in octal data.
-123 Exponent too large | Indicates the magnitude of an exponent was greater than 32000, see IEEE 488.2, 7.7.2.4.1.
-124 Too many digits | Indicates the mantissa of a decimal numeric data element contained more than 255 digits excluding leading zeros, see IEEE 488.2, 7.7.2.4.1.
-128 Numeric data not allowed | Indicates that a legal numeric data element was received, but the device does not accept one in this position for the header.
-130 Suffix error | This error, as well as errors -131 through -139, are generated when parsing a suffix. This particular error message is used if the device cannot detect a more specific error.
-131 Invalid suffix | Indicates the suffix does not follow the syntax described in IEEE 488.2, 7.7.3.2, or the suffix is inappropriate for this device.
-134 Suffix too long | Indicates the suffix contain more than 12 characters, see IEEE 488.2, 7.7.3.4.
-138 Suffix not allowed | Indicates that a suffix was encountered after a numeric element that does not allow suffixes.
-140 Character data error | This error, as well as errors -141 through -149, are generated when parsing a character data element. This particular error message is used if the device cannot detect a more specific error.
-141 Invalid character data | Indicates that the character data element contains an invalid character or the particular element received is not valid for the header.
-144 Character data too long | Indicates the character data element contains more than twelve characters, see IEEE 488.2, 7.7.1.4.
-148 Character not allowed | Indicates a legal character data element was encountered where prohibited by the device.
-150 String data error | This error, as well as errors -151 through -159, are generated when parsing a string data element. This particular error message is used if the device cannot detect a more specific error.
-151 Invalid string data | Indicates that a string data element was expected, but was invalid, see IEEE 488.2, 7.7.5.2. For example, an END message was received before the terminal quote character.
-158 String data not allowed | Indicates that a string data element was encountered but was not allowed by the device at this point in parsing.
-160 Block data error | This error, as well as errors -161 through -169, are generated when parsing a block data element. This particular error message is used if the device cannot detect a more specific error.
-161 Invalid block data | Indicates a block data element was expected, but was invalid, see IEEE 488.2, 7.7.6.2. For example, and END message was received before the end length was satisfied.
-168 Block data not allowed | Indicates a legal block data element was encountered, but not allowed by the device at this point in parsing.
-170 Expression error | This error, as well as errors -171 through -179, are generated when parsing an expression data element. This particular error message is used if the device cannot detect a more specific error.
-171 Invalid expression | Indicates the expression data element was invalid, see IEEE 488.2, 7.7.7.2. For example, unmatched parentheses or an illegal character.
-178 Expression data not allowed | Indicates a legal expression data was encountered, but was not allowed by the device at this point in parsing.
-180 Macro error | This error, as well as error -181 through -189, are generated when defining a macro or execution a macro. This particular error message is used if the device cannot detect a more specific error.
-181 Invalid output macro definition | Indicates that a macro parameter place holder was encountered outside of a macro definition.
-183 Invalid inside macro definition | Indicates that the program message unit sequence, sent with a *DDT or a *DMC command, is syntactically invalid, see IEEE 488.2, 10.7.6.3.
-184 Macro parameter error | Indicates that a command inside the macro definition had the wrong number or type of parameters.


-200 through -299 Error Message Descriptions

-200 through -299 Error Message Descriptions

Description

These errors are generated when something occurs that is incorrect in the current state of the instrument. These errors may be generated by a user action from either the remote or the manual user interface.

Error Message | Description
-200 Execution error | This event bit (Bit 4) indicates a PROGRAM DATA element following a header was outside the legal input range or otherwise inconsistent with the device's capabilities, see IEEE 488.2, 11.5.1.1.5.
-203 Command protected | Indicates that a legal password-protected program command or query could not be executed because the command was disabled.
-220 Parameter error | Indicates that a program data element related error occurred.
-221 Setting conflict | Indicates that a legal program data element was parsed but could not be executed due to the current device state.
-222 Data out of range | Indicates that a legal program data element was parsed but could not be executed because the interpreted value was outside the legal range defined by the devices
-223 Too much data | Indicates that a legal program data element of block, expression, or string type was received that contained more data than the device could handle due to memory or related device-specific requirements.
-224 Illegal parameter value | Indicates that the value selected was not part of the list of values given.
-225 Out of memory | The device has insufficient memory to perform the requested operation.
-226 Lists not the same length | Attempted to use LIST structure having individual LIST's of unequal lengths.
-230 Data corrupt or stale | Indicates invalid data, a new reading started but not completed since the last access.
-231 Data questionable | Indicates that measurement accuracy is suspect.
-233 Invalid version | Indicates that a legal program data element was parsed but could not be executed because the version of the data is incorrect to the device. For example, a not supported file version, a not supported instrument version.
-240 Hardware error | Indicates that a legal program command or query could not be executed because of a hardware problem in the device.
-241 Hardware missing | Indicates that a legal program command or query could not be executed because of missing device hardware. For example, an option was not installed.
-250 Mass storage error | Indicates that a mass storage error occurred. The device cannot detect the more specific errors described for errors -251 through -259.
-251 Missing mass storage | Indicates that a legal program command or query could not be executed because of missing mass storage.
-252 Missing media | Indicates that a legal program command or query could not be executed because of missing media. For example, no disk.
-253 Corrupt media | Indicates that a legal program command or query could not be executed because of corrupt media. For example, bad disk or wrong format.
-254 Media full | Indicates that a legal program command or query could not be executed because the media is full. For example, there is no room left on the disk.
-255 Directory full | Indicates that a legal program command or query could not be executed because the media directory was full.
-256 File name not found | Indicates that a legal program command or query could not be executed because the file name was not found on the media.
-257 File name error | Indicates that a legal program command or query could not be executed because the file name on the device media was in error. For example, an attempt was made to read or copy a nonexistent file.
-258 Media protected | Indicates that a legal program command or query could not be executed because the media was protected. For example, the write-protect switch on a memory card was set.
-270 Macro error | Indicates that a macro related execution error occurred.
-271 Macro syntax error | Indicates that a syntactically legal macro program data sequence, according to IEEE 488.2, 10.7.2, could not be executed due to a syntax error within the macro definition.
-272 Macro execution error | Indicates that a syntactically legal macro program data sequence could not be executed due to some error in the macro definition, see IEEE 488.2, 10.7.6.3.
-273 Illegal macro label | Indicates that the macro label was not accepted, it did not agree with the definition in IEEE 488.2, 10.7.3
-274 Macro parameter error | Indicates that the macro definition improperly used a macro parameter placeholder, see IEEE 4882, 10.7.3.
-275 Macro definition too long | Indicates that a syntactically legal macro program data sequence could not be executed because the string of block contents were too long for the device to handle, IEEE 488.2, 10.7.6.1.
-276 Macro recursion error | Indicates that a syntactically legal macro program data sequence count not be executed because it would be recursive, see IEEE 488.2, 10.7.6.6.
-277 Macro redefinition not allowed | Indicates that redefining an existing macro label, see IEEE 488.2, 10.7.6.4.
-278 Macro header not found | Indicates that a legal macro label in the *GMS?, see IEEE 488.2, 10.13, could not be executed because the header was not previously defined.


-300 through -399 Error Message Descriptions

-300 through -399 Error Message Descriptions

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error. When one of these errors is generated, the device specific error bit in the event status register is set.

Error Message | Description
-300 Device specific error | This event bit (Bit 3) indicates that a device operation did not properly complete due to some condition, such as overrange see IEEE 488.2, 11.5.1.1.6.
-311 Memory error | Indicates some physical fault in the devices memory, such as a parity error.
-312 PUD memory lost | Indicates protected user data saved by the *PUD command has been lost, see IEEE 488.2, 10.27.
-313 Calibration memory lost | Indicates that nonvolatile calibration data used by the *CAL? command has been lost, see IEEE 488.2, 10.2.
-314 Save/recall memory lost | Indicates that the nonvolatile data saved by the *SAV command has been lost, see IEEE 488.2, 10.33.
-315 Configuration memory lost | Indicates that nonvolatile configuration data saved by the device has been lost.
-320 Storage fault | Indicates that the firmware detected a fault when using data storage. This is not an indication of physical damage or failure of any mass storage element.
-321 Out of memory | An internal operation needed more memory than was available
-330 Self test failed | Indicates a problem with the device that is not covered by a specific error message. The device may require service.
-340 Calibration failed | Indicates a problem during calibration of the device that is not covered by a specific error.
-350 Queue overflow | Indicates that there is no room in the queue and an error occurred but was not recorded. This code is entered into the queue in lieu of the code that caused the error.
-360 Communication error | This is the generic communication error for devices that cannot detect the more specific errors described for error -361 through -363.
-361 Parity error in program message | Parity bit not correct when data received for example, on a serial port.
-362 Framing error in program message | A stop bit was not detected when data was received for example, on a serial port (for example, a baud rate mismatch).
-363 Input buffer overrun | Software or hardware input buffer on serial port overflows with data caused by improper or nonexistent pacing.


-400 through -499 Error Message Descriptions

-400 through -499 Error Message Descriptions

Description

A Query error is generated either when data in the instrument's GPIB output queue has been lost, or when an attempt is being made to read data from the output queue when no output is present or pending.

Error Message | Description
-400 Query error | This event bit (Bit 2) indicates that an attempt to read data from the Output Queues when no output is present or pending, to data in the Output Queue has been lost see IEEE488.2, 11.5.1.1.7.
-410 Query INTERRUPTED | Indicates the test set has been interrupted by a new program message before it finishes sending a RESPONSE MESSAGE see IEEE 488.2, 6.3.2.3.
-420 Query UNTERMINATED | Indicates an incomplete Query in the program see IEEE 488.2, 6.3.2.2.
-430 Query DEADLOCKED | Indicates that the Input Buffer and Output Queue are full see IEEE 488.2, 6.3.1.7.
-440 Query UNTERMINATED after indefinite response | Indicates that a query was received in the same program message after a query requesting an indefinite response was executed see IEEE 488.2, 6.5.7.5.


+100 through +199 Error Message Descriptions

+100 through +199 Error Message Descriptions

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error.

These are general errors generated by the core instrument. When one of these errors is generated, the `+100 errors' bit in the questionable error status register is set.

Error Message

Description

+101 Assert; Cycle power. Assert message<message1>

<message1> will appear as:

;P:DSP T:<task ID> E:<error code> C:<error classif.> F1:<flag 1> F2:<flag 2> if the DSP generated the assert.

;P:Protocol T:<task ID> L:<line number> F:<file name> if the Protocol processor generated the assert.

;P:Host T:<task ID> L:<line number> F:<file name> if the Host processor generated the assert.

+102 Exception; Cycle power. Exception message<message2>

<message2> will appear as: T:<task ID> or V:<vector number> or PC:<program counter> or DA:<data adrs reg value>.

Vector number, program counter and data address register values are hexadecimal format.

+103 Failure; No measurements or settings can be made

Indicates none of the VI's are operational because a serious problem exists.

+104 Failure; No settling operations will take place

Indicates none of the VI's are operational because a serious problem exists.

+105 Failure; No measurements or setting can be made for the function selected

Indicates none of the VI's are operational because a serious problem exists.

+110 Input pacing; Internal communication queue overflow likely

Indicates that GPIB commands are too fast for the device input queue and should be slowed.

+111 Input pacing; Internal communication queue overflow imminent. Pacing increased

Indicates that GPIB commands were too fast and the device input queue has not kept pace.

+112 Internal error; Protocol error <message3>

<message3> is an eight digit hexadecimal number that is the error code reported by protocol.

+113 Internal error; <VI NAME> forced inactive

Indicates that a VI is inactivated when not executed.

<VI NAME> includes: "IntVmVI","GprsBsEmulVI", "GsmComBsEmulVI","GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI", "TdmaTaBsEmulVI".

+114 Internal error; <VI NAME> not responding

Indicates that a VI has not been instantiated or the state is not available.

<VI NAME> includes: "IntVmVI","GprsBsEmulVI", "GsmComBsEmulVI", "GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI", "TdmaTaBsEmulVI", "RfHwAccessVI".

+115 Internal error; <VI NAME> inactive

Indicates that a VI has been made inactive.

<VI NAME> includes: "IntVmVI", "GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI".

+120 Warning; Receiver over range due to requested settings

Indicates the total received power (a combination of received power and amplitude offset) is above the range of the test set.

+121 Warning; Receiver under range due to requested settings

Indicates the total received power (a combination of received power and amplitude offset) is below the range of the test set.
+122 Warning; Reference out of lock

Indicates the test set's internal reference is out of lock.

+123 Warning; Duplicate RF IN/OUT Amplitude Offset Frequency entry. First frequency entry in RF IN/OUT Amplitude Offset table will be used.

Indicates that an amplitude offset value for that frequency has already been entered. The test set will use the amplitude offset value entered first.

+124 Warning; Source over range due to requested settings

The setting selected for total transmit power (a combination of cell power, AWGN power, amplitude offset) is above the test set's range.

+125 Warning; Source under range due to requested settings

The setting selected for total transmit power (a combination of cell power, AWGN power, amplitude offset) is below the test set's range.

+129 Configuration warning: License will expire soon

The temporary license is about to expire. This message will give the license number and the number of days before it is scheduled to expire.

+130 Configuration error; Unable to switch to indicated Test Application

The test application selected is not available for this test set.

+131 Configuration error; Current Test Application is not licensed (License = N). Select another Test Application

The test application selected is not licensed. Select another revision or test application that is licensed (License = L).

+132 Configuration error; Selected Test Application Format is not available.

Indicates that the fast switching operation will not activate a particular radio format. Check the revision number of the test application associated with the radio format, does the revision correspond with what the fast switching test application needs?
+133 Configuration error; Selected Test Application Format is not licensed, (License = N).

The radio format selected is not licensed. Select another revision or obtain a licensed revision of the test application test application that is licensed (License = L).

+134 Configuration error; Unable to switch to selected Test Application Format

The Test Application Format name used is correct but for some reason the test set can not switch to that format.

+137 Configuration error; The license has expired for the selected format

When a license expires you must switch applications by pressing the SYSTEM CONFIG key and then selecting Format Switch (F2) or Application Selection (F3).

+138 Configuration error; Selected format is not licensed due to unexpected system time change

 This message is displayed when a temporary license expires due to a change occurring to system time.

+139 Configuration error; Functionality is not available

+140 Operation rejected; Command is not supported in this operating mode

+141 Operation Rejected; A Measurement Is Currently Controlling This Setting. | An attempt has been made to access a setting that is being controlled by a measurement.

+142 Configuration error; Functionality not available

An attempt has been made to access lab application functions from a test application.

+143 Operation Rejected; Selected measurement is not available in the current measurement selection list

An attempt has been made to access a measurement that is not available in the current application.

+144 Operation rejected; PC connection not established

+145 Operation rejected; Feature is not licensed. See www.agilent.com/find/8960upgrades for additional information

The feature you are attempting to access is not licensed in your test set. Visit www.agilent.com/find/8960upgrades to find out how to acquire the required license.

+146 Operation rejected; External 8960 connection feature is not licensed. See www.agilent.com/find/8960upgrades for additional information

The external 8960 connection feature requires a license in a test application. Visit www.agilent.com/find/8960upgrades to find out how to acquire the required license.

+150 Calibration operation; Recalibrating due to present temperature

Indicates that the test set is recalibrating due to hardware inaccuracies based on temperature changes. Any measurements that are running will be temporarily aborted and then restarted after the recalibration is complete.

+160 Save/Recall error; File operation error

 Occurs if there is any disk read or write problems when trying to save, recall or delete a register.

+161 Save/Recall error; Recalling available (empty) register

 Occurs if an attempt is made to recall any register that has not been saved.
+162 Save/Recall error; Functionality is not yet available for current application. | Occurs when an attempt to save a save/recall register while using an application that has not implemented this feature.


+200 through +299 Error Message Descriptions

+200 through +299 Error Message Descriptions

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error.

When one of these errors is generated, the +200 errors bit in the questionable error status register is set.

+200 through +299 Error Messages

Error Message

Description

+201 WCDMA call processing error; No Response to RRC Connection Setup

No "RRC Connection Complete" message was received from the UE. However, the BS Origination process is allowed to proceed.
+202 WCDMA call disconnected; No Response to RRC Connection Release

No "RRC Connection Release Complete" message was received from the UE. However, the BS Release process is allowed to proceed.
+203 WCDMA call processing error; No Response to Activate RB Test Mode

No "Activate Radio Bearer Test Mode Complete" message was received from the UE. However, the BS Origination process is allowed to proceed.
+204 WCDMA call processing error; No Response to De-Activate RB Test Mode

No "De-Activate Radio Bearer Test Mode Complete" message was received from the UE. However, the BS Release process is allowed to proceed.
+205 WCDMA call processing error; No Response to Close UE Test Loop

No "Close UE Test Loop Complete" message was received from the UE. However, the BS Origination process is allowed to proceed.

If this error occurs during a Transport Channel Reconfiguration , the UE did not send the Close UE Test Loop Complete message to the test set within 6 seconds. The test set will terminate the procedure.
+206 WCDMA call processing error; No Response to Radio Bearer Setup

No "Radio Bearer Setup Complete" message was received from the UE. However, the BS Origination process is allowed to proceed.
+207 WCDMA call processing error; No response to Radio Bearer Release

+208 WCDMA call processing error; No response to Identity Request

The test set did not receive an identity response message from the UE. However, the Location Update process is allowed to proceed.
+209 WCDMA Call Disconnected. No Signal Found on Uplink DPCH

The test set could not find a valid DPCH signal within 2 seconds of sending the "RRC Connection Setup" message during a BS Origination procedure.

If this errors occurs during a Physical Channel Reconfiguration , the test set could not find a valid DPCH signal within 5 seconds of sending the Physical Channel Reconfiguration message. The call status will be returned to idle.
+210 WCDMA Call Disconnected; Signal Lost on Uplink DPCH

The test set determined that a link failure occurred due to loss of synchronization with the embedded pilot in the uplink DPCH.
+211 Call Disconnected; No Response to registration request. | The call is dropped by the test set as a result of the UE not responding to a registration request message.
+212 WCDMA Call Disconnected. Max No. RLC Retransmissions Exceeded. Starting RLC Reset Proc | The single RLC retransmission attempted by the test set is not acknowledged by the UE.
+213 WCDMA Call Disconnected; RLC Reset Procedure failed

The single RLC retransmission request from the test set resulted in a second incorrectly received PDU.
+214 FDD call operation rejected; Change not allowed in Active Cell Mode

+214 WCDMA call operation rejected; Change Not Allowed in Active Cell Mode | This setting can not be changed by the user while the Cell Operating Mode is "Active Cell".

+215 Call Disconnected; No Response to Page

The test set did not receive either a valid PRACH preamble or the "RRC Connection Request" message within 2 seconds.

+217 Call Disconnected; Unexpected Call Release By the External Device

This error is posted on the 8960 connected to the UE that originated the Video Call if the call between the receiving UE and its 8960 is unexpectedly released (for example, if the RF cable is disconnected).

+217 FDD warning; Performance not specified for UL/DL frequency offset < 30 MHz

 Performance is not specified when the difference in the uplink and downlink frequencies is less than
30 MHz.
+218 Call Disconnected; Signal With The External Device Has Been Lost | This error is returned if during a Video Call , a message from one UE to the other is not received even though there is a valid External Device Connection between the two 8960s.

+218 FDD Settings Deferred: Cell power and AWGN power > 10 dB apart.

AWGN and Cell Power settings must be within 10 dB of each other.

+220 FDD call operation rejected; UL Power Control is active

Step up or step down TPC bit patterns can not be sent when uplink closed loop power control is active.

+221 FDD Settings Deferred: Test mode channel power levels sum to > +0.03 dB

The sum of the code channels cannot exceed +0.03 dB. Reduce one or more channel levels.
+222 WCDMA call processing error; No Physical Channel Reconfiguration Complete

The uplink DPCH is found but the appropriate "Reconfiguration Complete" message is not received from the UE after a sending a physical channel reconfiguration. However, the test set assumes the reconfiguration was successful and attempts to maintain the connection. See Physical Channel Reconfiguration .

+223 FDD settings deferred; Initial Active Cell code channel power levels sum to > +0.03 dB

The sum of the code channels cannot exceed +0.03 dB. Reduce one or more channel levels.

+224 FDD Settings Deferred: One or more code channel power levels > 30 dB below total RF power

The power of at least one code channel is more than 30 dB below the total RF power, exceeding the test set's limits.

+225 FDD settings deferred; One or more Initial Active Cell code channel power levels > 30 dB below total RF power

The power of at least one code channel is more than 30 dB below the total RF power, exceeding the test set's limits.

+226 FDD settings deferred; Connected Active Cell code channel power levels sum to > +0.03 dB

The sum of the code channels cannot exceed +0.03 dB. Reduce one or more channel levels.

+227 FDD settings deferred; One or more Connected Active Cell code channel power levels > 30 dB below total RF power

The power of at least one code channel is more than 30 dB below the total RF power, exceeding the test set's limits.
+229 WCDMA call disconnected; Setup aborted

+230 Call operation rejected; Action not possible

+231 Call operation rejected; Call processing in progress

+232 Call operation rejected; Protocol request ignored

+233 Call operation rejected; External 8960 has an invalid configuration for the requested end-to-end service | This error is returned when attempting to establish a Video Call with an 8960 that is not properly configured to receive the video call (the 8960 must be in active cell operating mode, and in the idle state). The call with the originating UE is disconnected.
+233 WCDMA call processing error; No response to Authentication Request

+234 Call operation rejected; Called MS is not responding | This error is returned when attempting to establish a Video Call if the 8960 receiving the page request sends a page message to its UE and the UE does not respond. The connection to the originating UE is released.
+234 WCDMA call processing error; Security Mode not completed

+235 WCDMA call processing error; No CC Call Confirmed received from the UE
+236 WCDMA Call processing error; No CC ALerting received from the UE
+236 Call Disconnected; Called MS Did Not Answer | This error is returned while attempting to set up a Video Call , if during the alerting phase of the call setup procedure the called UE does not answer. The connections to both UEs will release.
+237 WCDMA call processing error; No CC Connect received from the UE

+238 WCDMA call processing error; No CC Release received from the UE

+239 Operation rejected; Starting ping not allowed with current configuration

+240 Operation rejected; Attempting to send SMS submit report after timer TR2N expired

There are network (TR2N) and mobile station (TR2M) timers associated with the return of a SMS-SUBMIT-REPORT message. You should ensure that the time taken to respond to a SMS-SUBMIT message when using MANUAL mode is well within the limits of these timers (by at least a couple of seconds). If a request to send an SMS-SUBMIT-REPORT is received at the test set outside these time constraints, the message will not be sent to the mobile station.

+241 Operation rejected; Attempting to send SMS submit report while mode set to Auto

+242 Operation rejected; Attempting to send SMS status report while mode set to Auto

+243 Operation rejected; Too many outstanding requests, could not send SMS message

+243 WCDMA Call Operation Rejected; Handoff To GSM Requires A Multi-Format Application With Both GSM And WCDMA.

+244 FDD call processing error; No response to Active Set Update

+245 FDD call processing error; Active Set Update Failure occurred

+248 WCDMA call processing error; No response to Activate PDP Context request

+249 WCDMA protocol failure; UE reported protocol error occurred

+250 Protocol failure; Unknown error

+250 WCDMA call processing error; UE Event Measurement Control Failure Occurred | The UE returned a Measurement Control Failure. If this occurs during activation of compressed mode, then compressed mode is still activated, but UE measurements have not been properly enabled.
+251 WCDMA call processing error; PDP Context rejected

+252 FDD settings deferred; Cell 1 power and Cell 2 power > 10 dB apart

+253 FDD settings deferred; Cell 2 power and AWGN power > 10 dB apart

+254 FDD settings deferred; Cell 2 Active Cell code channel power levels sum to > +0.03 dB

+255 FDD settings deferred; One or more Cell 2 Active Cell code channel power levels > 30 dB below total RF power

+256 WCDMA call processing error; Authentication failed

+258 FDD warning; RLC behavior not compliant to 3GPP specifications if 3.4k or 13.6k SRB is used

+259 WCDMA call operation rejected; Invalid DUT IP address

+260 WCDMA call processing error; No response to CC connect

+261 WCDMA call disconnected; Bearer Capability Not Supported | If this error occurs during CS Data operation, the UE has requested an unsupported rate or configuration. See CS (Circuit Switched) Data Service .
+262 WCDMA call processing error; No response to CC Release

+263 WCDMA call processing error; No response to CC Reject

+264 WCDMA call processing error; No response to CC Disconnect

+265 WCDMA call processing error; UE periodic Measurement Control Failure occurred

+266 FDD call operation rejected; Change Allowed Only When Call Status Is Idle

+267 FDD call operation rejected; Step size 2 is not allowed when in Algorithm 2 mode

+268 WCDMA call processing error; No response to CM Service Accept

+270 WCDMA call processing error; No response to Deactivate PDP Context request

+271 WCDMA call operation rejected; Inter-System Handoff only allowed while in RB Test Mode service

+272 WCDMA call operation rejected; Inter-System Handoff only allowed with RMC Channel Types

+273 WCDMA call processing error; Attach not completed

+274 WCDMA call processing error; Security Mode failed

+275 WCDMA warning; Measurement Not Available in This Configuration | If this error occurs when trying to run the loopback BER or loopback BLER measurement, ensure that you have properly set Uplink DTCH RMC CRC Presence and UE Loopback Type .
+276 WCDMA call disconnected; No Response To Open UE Test Loop Message | This error occurs during a Transport Channel Reconfiguration if the UE does not send the Open UE Test Loop Complete message to the test set within 6 seconds. The test set will continue with the procedure.
+277 WCDMA call processing error; Transport Channel Reconfiguration Message Not Received From The UE. | This error occurs during a Transport Channel Reconfiguration if the UE does not send the Transport Channel Reconfiguration Complete message to the test set within 6 seconds. The test set will drop the connection.
+278 FDD call operation rejected. Functionality Not Yet Supported In Current Service Type.

You must be on an RB test mode call to perform a Transport Channel Reconfiguration (see Paging Service ). You must be on an RB test mode or AMR voice call to perform a GSM handover (see System Handoff ).
+279 WCDMA call processing error; No response to RLC Poll

+280 FDD call operation rejected; Compressed Mode Can Only Be Activated When in Connected Mode | You can not enable compressed mode until the test set and UE are on a 12.2k RMC call in RB test mode.
+281 FDD call operation rejected; Compressed Mode Not Supported In This Service Type | You can not enable compressed mode until the test set and UE are on a 12.2k RMC call in RB test mode.
+282 FDD call operation rejected; Compressed Mode Not Supported In This Channel Type | You can not enable compressed mode until the test set and UE are on a 12.2k RMC call in RB test mode.
+283 FDD call operation rejected; Compressed Mode Not Active | This is returned if you try to disable compressed mode when it is not active.
+284 FDD call operation rejected; Parameter Cannot Be Changed While Compressed Mode Is Active | If TGPS Definition During Call Setup is set to Off , then the Transmission Gap Parameters can only be configured if Compressed Mode State is Off (so that the transmission gap definition can then be provided to the UE when compressed mode is subsequently activated).
+285 FDD call operation rejected; When TGPS Is Defined Via Call Setup This Parameter Can Only Be Changed When Call Status Is Idle | If TGPS Definition During Call Setup is set to RB Setup , then you can only configure the Transmission Gap Parameters when the call status is Idle (so that the transmission gap definition can then be provided to the UE when the call is subsequently established).
+286 FDD call operation rejected; Invalid Compressed Mode Parameter (Gap In First Frame Is Too Long) | A single frame must not have more than one gap, and a gap in any one frame must not exceed 7 slots. (14 - TGSN) > 7 and TGL1 > 1 not allowed.
+287 FDD call operation rejected; Invalid Compressed Mode Parameter (Gap In Second Frame Is Too Long) | A single frame must not have more than one gap, and a gap in any one frame must not exceed 7 slots. TGL1 - (14 - TGSN) > 7 not allowed.
+288 FDD call operation rejected; Invalid Compressed Mode Parameter (Two Gaps In Same Frame) | A single frame must not have more than one gap, and a gap in any one frame must not exceed 7 slots. TGPL1 < 2 and TGL1 > (14 - TGSN) not allowed.

+289 FDD call operation rejected; Operation not supported in CELL_FACH state

+290 FDD call processing error; Physical Channel Reconfiguration Failure Message Received From UE | The UE returned a Physical Channel Reconfiguration Failure message instead of a Physical Channel Reconfiguration Complete message. If this occurs during activation of compressed mode, then compressed mode is not activated. If this occurs when compressed mode is already enabled, then compressed mode is deactivated. If this occurs during deactivation of compressed mode, then compressed mode is left activated.
+291 FDD call processing error; No Response To Physical Channel Reconfiguration | The UE did not respond to the Physical Channel Reconfiguration message. If this occurs during activation of compressed mode, then compressed mode is still activated in the test set at the signaled CFN, and the Measurement Control message is still sent to the UE (if you have set Compressed Mode Meas - UE Setup to On).
+292 FDD call processing error; Layer 1 reported Compressed Mode Failure

+293 FDD call processing error; Received Compressed Mode Measurement Control failure

+294 FDD Call Operation Rejected; CFN Must Be Aligned To A 40 ms Boundary | The starting CFN mod 4 must be 0.
+295 FDD call operation rejected; Compressed Mode Not Supported on This Channel Code (Only Supported on 20, 29, 37, 45, 60, 70, 76, 87 & 93) | Compressed mode can only be activated when the DPCH channelization code is 20, 29, 37, 45, 60, 70, 76, 87 or 93. Any other channelization codes could potentially cause compressed frames to collide with other downlink channels.
+296 FDD call operation rejected; Calculated UL Channel is invalid. With UL Channel not set to Auto, set DL Channel and UL Separation to a valid combination, then set UL Channel to Auto

+297 FDD call operation rejected; Calculated Handoff UL Channel is invalid. With Handoff UL Channel not set to Auto, set Handoff DL Channel and Handoff UL Separation to a valid combination, then set Handoff UL Channel to Auto

+298 FDD call operation rejected; Functionality not yet supported on an asymmetric RMC


+300 through +399 Link Control Device-Specific Error

+300 through +399 Link Control Device-Specific Error

These errors are generated when a problem occurs in maintaining the link between the test set and a DUT. These errors generally occur when a message is received from the DUT that is unexpected.

When one of these errors is generated, the `+300 errors' bit in the questionable error status register is set. Refer to Standard Event Status Register for information on this register.

+300 through +399 Error Messages
Error Message | Description
+320 WCDMA call processing error; Point-to-Point SMS is not supported over a CS domain while connected on a PS service |
+321 WCDMA call processing error; Point-to-Point SMS is not supported over a PS domain while connected on a CS service |


+400 through +499 Error Message Descriptions

+400 through +499 Error Message Descriptions

Description

These errors are generated when a problem occurs in one of the test set's hardware modules that is part of the test set's core instrument.

When one of these errors is generated, the `+400 errors' bit in the questionable error status register is set.

Error Message | Description
+400 Hardware failure; Hardware is not available |
+401 Hardware failure; Protocol processor hardware is not responding |
+402 Hardware failure; Demod receiver hardware is not responding |
+403 Hardware failure; Measurement receiver hardware is not responding |
+404 Hardware failure; RF source 1 hardware is not responding |
+405 Hardware failure; RF source 1 digital modulation hardware is not responding |
+406 Hardware failure; RF source 1 level hardware is not responding |
+407 Hardware failure; DSP demod control hardware is not responding |
+408 Hardware failure; 2nd demod receiver hardware is not responding |
+409 Hardware failure; Base station emulator trigger hardware is not responding |
+410 Hardware failure; Audio source hardware is not responding |
+411 Hardware failure; RF source 2 hardware is not responding |
+412 Hardware failure; Internal voltmeter hardware is not responding |
+413 Hardware failure; Fixed timebase input is not responding |
+414 Hardware failure; Fixed external reference output is not responding |
+415 Hardware failure; Instrument reference is not responding |
+416 Hardware failure; Bit clock A is not responding |
+417 Hardware failure; RF source 2 frequency hardware is not responding |
+418 Hardware failure; RF source 2 digital modulation hardware is not responding |
+419 Hardware failure; RF source 2 level hardware is not responding |
+420 Hardware failure; RF source hopping hardware is not responding |
+421 Hardware failure; Digital demod hopping hardware is not responding |
+422 Hardware failure; Misc VI hardware is not responding |
+423 Hardware failure; Unable to access networking information |
+424 Hardware failure; Bit clock B is not responding |
+425 Hardware failure; Invalid EEPROM checksum <EEPROM board ID> | See the list of EEPROM board ID names below.
+426 Hardware failure; Unable to write to EEPROM <EEPROM board ID> | See the list of EEPROM board ID names below.
+427 Hardware failure; Unable to read from EEPROM <EEPROM board ID> | See the list of EEPROM board ID names below.
+428 Hardware failure; Board not identified <board ID> | See the list of board ID names below.
+429 Hardware failure; Could not create board identification <board ID> | See the list of board ID names below.
+430 Hardware failure; Control version not compatible with FW <board ID> | See the list of board ID names below.
+431 Hardware failure; RF IO DAC cannot be calibrated due to present temperature |
+432 Hardware failure; RF hardware is not responding |
+433 Hardware failure; RF source FM hardware is not responding |
+434 Hardware failure; Audio source FM hardware is not responding |
+460 Hardware failure; Hardware doesn't support requested operation. See www.agilent.com/find/8960upgrades for additional information | This error occurs when an action is attempted that is not possible with the test set's hardware. Visit www.agilent.com/find/8960upgrades to find out how to acquire the necessary hardware.
+461 Hardware failure; Link subsystem hardware is not responding. Call processing functionality not operational. | This error occurs any time the link subsystem is not operating correctly. The message is persistent to warn the user that any call processing operations will not work.
+462 Hardware error; Hardware not supported; <board ID><part_number> | This error appears when an operation was attempted that requires hardware that is not installed in the test set.
+463 Hardware error: RFIO version does not support loopback switching. |
+464 Hardware error: RFIO version does not support RF out only selection. | This error occurs when trying to select the RF OUT ONLY port when the test set has the RF I/O module that only has the RF IN/OUT port.
+470 Hardware error; Hardware doesn't support requested operation. Feature is not licensed. See www.agilent.com/find/8960upgrades for additional information | This error occurs you attempt to access a feature which is not licensed in the test set and is not possible with the test set's hardware. Visit www.agilent.com/find/8960upgrades to find out how to acquire the necessary hardware and license.

<board ID> names

3 GHZ ATTENUATOR 1| ;3GHZ ATTENUATOR 2| ;AUDIO BD| ;ROM BASEBAND GENERATOR 1| ;ROM BASEBAND GENERATOR 2| ;DEMOD DOWNCONVERTER| ;VECTOR OUTPUT BOARD 1| ;VECTOR OUTPUT BOARD 2| ;IVF MEASUREMENT| ;MEASUREMENT DOWCONVERTER| ;RF POWER DETECTORS| ;REFERENCE MODULE| ;SYNTH DOUBLER 1| ;SYNTH DOUBLER 2| ;TIMING REF| ;MOMENTUM INSTRUMENT| ;RF MOTHER BOARD| ;JUMPER BOARD| ;DIGITAL MOTHER BOARD| ;FLAT PANEL ADAPTER| ;REAR PANEL BOARD

<EEPROM board ID> names

Instrument Eeprom ID State| ;Atten 1 Eeprom ID State| ;Atten 2 Eeprom ID State| ;Audio Eeprom ID State| ;BaseBandGen 1 Eeprom ID State| ;BaseBandGen 2 Eeprom ID State| ;Demod DC Eeprom ID State| ;Digital Mother Board Eeprom ID State| ;IQ Output 1 Eeprom ID State| ;IQ Output 2 Eeprom ID State| ;IVF Meas Eeprom ID State| ; Jumper Board Eeprom ID State| ; Meas DC Eeprom ID State| ;RF Mother Board Eeprom ID State| ;RF Interface Eeprom ID State| ; Ref Mod Eeprom ID State| ;Sig Gen 1 Eeprom ID State| ; Sig Gen 2 Eeprom ID State| ;Time Ref Eeprom ID State| ;Display Interface Eeprom ID State| ;Rear Panel Eeprom ID State


+500 through +599 Test Application Hardware Device-Specific Error

+500 through +599 Test Application Hardware Device-Specific Error

Last updated: December 21, 2004

Description

These errors are generated when a problem occurs with a hardware module that is required for a particular application.When one of these errors is generated, the `+500 errors' bit in the questionable error status register is set.

+500 through +599 Error Messages
Error Message | Description
+501 Protocol logging failure; No observation points enabled | This error message is displayed for information purposes only.
+520 Configuration error; DUT IP address must be on same subnet as instrument | This error message is generated if the DUT IP address is not on the same subnet as the instrument. This situation may arise because the instrument IP address was set after the DUT IP address, or the instrument subnet mask changed.
+521 Configuration error; DUT IP address cannot be the same as the instrument LAN address | This error message is generated if the DUT IP address and the instrument IP address are the same. This situation may arise because the instrument IP address was set after the DUT IP address.
+522 Configuration Error; Operation Rejected Due To Invalid IP Address | This error is returned when attempting to Connect to External 8960 if the Ext 8960 IP Addr is invalid.
+527 Operation rejected; External PDSN state change to on not allowed if external PDSN IP address is undefined | This error message is displayed for information purposes only.
+528 Operation rejected; External PDSN service not available; external PDSN state set to off | This error message is displayed for information purposes only
+529 Warning; External PDSN control connection dropped; external PDSN state set to off. | This error message is associated with a lost control connection between test set and MOB-IP-SIM.
+532 Warning; External PDSN data connection dropped | This error message is associated with a lost data connection between MOB-IP-SIM and MS.
+533 Operation rejected; ping DUT functionality is not available while external PDSN state is on. | This error message is displayed for information purposes only.
+534 Operation Rejected; No Response From The External Device | This error is returned when attempting to Connect to External 8960 if the external 8960 does not respond to the connection request.
+535 Operation Rejected; The Device Rejected The Connection Request | This error is returned when attempting to Connect to External 8960 if the external 8960 rejects the connection request (this would happen, for example, if the external 8960 already has a connection to another 8960).
+536 Warning; Connection Is Already Established With The External Device | This error is returned when attempting to Connect to External 8960 if your test set is already connected to the external 8960.
+537 Operation Rejected; Change Allowed Only When A Connection To An External Device Does Not Exist | This error is returned when attempting to set the Ext 8960 IP Addr while External Device Conn Status is not Disconnected .
+538 Operation Rejected; External 8960 Test Set IP Address Cannot Be The Same As Instrument LAN IP Address | This error is returned when attempting to set the Ext 8960 IP Addr to the same value as LAN IP Address .
+539 Operation Rejected; Connection To The External Device Has Been Lost; All Calls Have Been Disconnected | This error occurs if the External Device Connection is broken (for example, if you disconnect the LAN cable from the test set).
+540 Operation Rejected; Cannot Process Request While Attempting To Connect To Or Disconnect From The External Device | This error is returned when attempting to Connect to External 8960 or Disconnect from External 8960 if the External Device Conn Status is Connecting or Disconnecting .
+541 Operation Rejected; External 8960 Test Set IP Address Cannot Be The Same As The DUT IP Address | This error is returned when attempting to set the Ext 8960 IP Addr to the same value as DUT IP Address .
+542 Operation Rejected; Service Not Available Without A Connection To An External Device | This error is returned when attempting to originate an end-to-end service without an External Device Connection in place.
+543 HTTP Client Error; failed to create socket |
+544 HTTP Client Error; failed to connect to the socket |
+545 HTTP Client Error; invalid IP address specified |
+546 HTTP Client Error; timeout |
+547 HTTP Client Error; could not access socket |
+548 HTTP Client Error; bad request URL |
+549 HTTP SMS request ignored; Illegal parameter in request | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface containing a parameter that is not supported.
+550 HTTP SMS request ignored; Request parameter out of range | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface containing a parameter value out of the supported range.
+551 HTTP SMS request ignored; Incompatible parameters in request | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface containing parameters that can not be used together in the same request URL.
+552 HTTP SMS request ignored; Missing mandatory parameter in request | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface that does not contain parameters required by the test set.
+553 HTTP SMS warning; Output message URL exceeded maximum length and has been truncated | This error is generated when the constructed URL received by the test set's HTTP interface for a mobile originated SMS message exceeds the maximum size of 1500 characters. This generally occurs if one or more tags have been duplicated in the output URL format string, causing the length restriction to be exceeded.


+600 through +699 Error Message Descriptions

+600 through +699 Error Message Descriptions

Description

These errors are generated when a problem occurs that is specific to one of the test set's instruments. These errors are part of the test set's core. Note that these measurements may not be present in every test application and therefore, these errors may not be present in every test application. There is no plan at present to support test application specific instruments.

An instrument in this context refers to the measurement-like functionality such as the audio generator and not to the test set as a whole.

When one of these errors is generated, the `+600 errors' bit in the questionable error status register is set.

Error Message | Description
+601 Instrument failure; Audio generator hardware is not responding | Indicates a problem occurs when attempting to control the test set's audio generator.
+602 Data out of range; Spectrum Monitor; No peaks left |
+603 Data out of range; Spectrum Monitor; No peaks right |
+604 Data out of range; Spectrum Monitor; No peaks found |
+605 Operation rejected; Spectrum Monitor; Receiver power currently set to Auto |
+606 Operation rejected; Spectrum Monitor; Meas frequency currently set to Auto |
+607 Operation rejected; Spectrum Monitor; Marker Frequency out of Meas Frequency tune range |
+608 Operation rejected; Spectrum Monitor instrument is inactive |
+620 Data out of range; Total multi-tone audio downlink level upper limit exceeded; no change |
+621 Data out of range; Total multi-tone audio uplink level upper limit exceeded; no change |
+622 Warning; Multi-tone audio downlink level over range due to requested setting |
+623 Operation rejected; Multi-tone audio downlink levels cannot be set when total level state is on |
+624 Operation rejected; Multi-tone audio uplink levels cannot be set when total level state is on |


+700 through +799 Error Message Descriptions

+700 through +799 Error Message Descriptions

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error.

When one of these errors is generated, the +700 errors bit in the questionable error status register is set.

FDD System Measurement Errors
Error Message | Description
+701 FDD measurement failure; Thermal Power hardware is not responding | A hardware failure associated with this measurement is suspected. Rerun the measurement to verify this error.
+702 FDD measurement failure; Adjacent Channel Leakage Ratio hardware is not responding | A hardware failure associated with this measurement is suspected. Rerun the measurement to verify this error.
+703 FDD measurement failure; Waveform Quality hardware is not responding | A hardware failure associated with this measurement is suspected. Rerun the measurement to verify this error.
+704 FDD measurement failure; Channel Power hardware is not responding | A hardware failure associated with this measurement is suspected. Rerun the measurement to verify this error.
+705 FDD measurement failure; Loopback Bit Error Ratio hardware is not responding | A hardware failure associated with this measurement is suspected. Rerun the measurement to verify this error.
+706 FDD measurement failure; Spectrum Emission Mask hardware is not responding | A hardware failure associated with this measurement is suspected. Rerun the measurement to verify this error.
+707 FDD measurement failure; Occupied Bandwidth hardware is not responding | A hardware failure associated with this measurement is suspected. Rerun the measurement to verify this error.
+708 FDD measurement failure; Code Domain hardware is not responding | A hardware failure associated with this measurement is suspected. Rerun the measurement to verify this error.
+709 FDD measurement failure; IQ Tuning hardware is not responding |
+710 FDD measurement failure; Inner Loop Power hardware is not responding |
+711 FDD measurement failure; Transmit ON/OFF Power hardware is not responding |
+712 FDD measurement failure; PRACH Preamble Analysis hardware is not responding |
+715 FDD measurement failure; Phase Discontinuity hardware is not responding |
+716 FDD measurement failure; Block Error Ratio hardware is not responding |
+717 FDD measurement failure; Dynamic Power Analysis hardware is not responding |
+718 FDD measurement failure; Change of Transport Format hardware is not responding |
+750 FDD Measurement failure; Incorrect PRACH Preambles setting. Valid range: >= 3 |
+751 FDD Measurement failure; Incorrect Available Subchannels setting. Valid range: any single subchannel. |
+752 FDD Measurement failure; Measurement only available in Idle call state. |
+753 FDD Measurement failure; Measurement only available in Active Cell Operating Mode |
+754 FDD Measurement failure; Measurement only available when the receiver control measurement frequency is: 1) set to the uplink channel frequency OR 2) set to AUTO mode |
+755 FDD Measurement failure; Call not connected |
+756 FDD Measurement failure; Sync not found |
+758 FDD Measurement failure; Receiver power control changed to AUTO |
+759 FDD measurement failure; Measurement only available in Service Type RB Test Mode |
+760 FDD measurement failure; Measurement only available when Uplink Dummy DCCH Data set to Off |
+761 FDD measurement failure; Loopback BER measurement is not available in current configuration |
+762 FDD measurement failure; Loopback BER measurement, run from within WCTF, failed to complete successfully |
+763 FDD measurement failure; Trigger Source must be set to External when in FDD Test Operating Mode |
+764 FDD measurement failure; Measurement not available using Channel Type: 33K No Coding RMC |
+765 FDD Measurement Failure; Measurement Only Available When Call Is In Connected State | A measurement which requires a connection in active cell operating mode has been requested to run without a connection in place.
+766 FDD Measurement Failure; Measurement not available in CW or Cell Off Operating Modes | A measurement has been requested to run in an operating mode in which it is not available.
+768 FDD measurement warning; UL CL Power Control is not set to ALL_UP |
+769 FDD measurement warning; Channel Type is not 12.2k |
+770 FDD measurement warning; UE Call Drop Timer setting too short |


+800 through +899 Error Message Descriptions

+800 through +899 Error Message Descriptions

Description

These errors are generated when a problem occurs that is specific to one of the test set's core measurements (such as analog audio).

When one of these errors is generated, the `+800 errors' bit in the questionable error status register is set.

Error Message | Description
+801 Measurement failure; Analog audio hardware is not responding | Indicates that a problem occurs when attempting to control the measurement's hardware.
+802 Measurement failure; Audio analyzer hardware is not responding | Indicates that a problem occurs when attempting to control the measurement's hardware.
+803 Measurement failure; Signal Finder hardware is not responding |
+805 Measurement failure; Multi-tone audio hardware is not responding |


Frequency Stability Troubleshooting

Frequency Stability Troubleshooting

December 21, 2004

Possible Setup Issues

The Trigger Arm should always be set to Single for GPIB operation (not Continuous ).

If Trigger Arm is set to single, you must press START SINGLE to start the measurement from the front panel.

This measurement can only be used for analog signals.

The expected signal frequency and input level must be specified for accurate measurements (see Receiver Control ).

Ensure that the input signal meets the Input Signal Requirements .

Related Topics

Frequency Stability Measurement Description


Troubleshooting Handoffs (Handovers)

Troubleshooting Handoffs (Handovers)

Last updated: December 21, 2004

Physical Channel Reconfiguration

  • You must be on a call to perform a physical channel reconfiguration.
  • You can not change DL Channel or Uplink Channel while on a call. To change channels while on a call, you must perform a physical channel reconfiguration by setting Handoff Downlink UARFCN and/or Handoff Uplink UARFCN , then issuing the Execute Handoff command (see Physical Channel Reconfiguration ).
  • In order for the physical channel reconfiguration to be successful, some UEs may require that you include the Handoff Downlink Channel (UARFCN) in the SIB11 Inter-Freq Cell Info List (see Inter-frequency Cells ). Further, if you are toggling between two sets of handoff channels (see Physical Channel Reconfiguration ), then you may need to include Handoff Downlink Channel (UARFCN) and the original DL Channel used to establish the call in the SIB11 Inter-Freq Cell Info List .
  • If you attempt any of the following, an error is posted and the change is rejected:
    • With Handoff Uplink Channel (UARFCN) set to Auto , set Handoff Downlink Channel (UARFCN) to a value that would result in a Handoff Uplink Channel (UARFCN) that is not within the supported range (based on the current Handoff Uplink Separation setting).
    • With Handoff Uplink Channel (UARFCN) set to Auto , set Handoff Uplink Separation to a value that would result in a Handoff Uplink Channel (UARFCN) that is not within the supported range (based on the current Handoff Downlink Channel (UARFCN) setting).
    • Set Handoff Uplink Channel (UARFCN) to Auto when the current Handoff Downlink Channel (UARFCN) and Handoff Uplink Separation values would result in a Handoff Uplink Channel (UARFCN) that is not within the supported range.

    You must instead do the following: with Handoff Uplink Channel (UARFCN) not set to Auto , set Handoff Downlink Channel (UARFCN) and Handoff Uplink Separation to a valid combination, then set Handoff Uplink Channel (UARFCN) to Auto .

  • Any measurements that have been initiated are aborted when a physical channel reconfiguration is initiated.
  • Ensure that the Handoff Downlink UARFCN and Handoff Uplink UARFCN are set to proper values for your UE. The default DL Channel of 10700 and default Handoff Downlink UARFCN of 10730 are 6 MHz apart (the default uplink channels are also 6 MHz apart). If you wish to handover to channels that are 5 MHz from the default channels, set Handoff Downlink UARFCN to 10725 and Handoff Uplink UARFCN to 9775 .
  • If the test set recognizes the physical channel reconfiguration as illegal for any reason, an error is posted, the reconfiguration is rejected and the test set remains in its state prior to the initiation of the reconfiguration. Conversely, if the UE simply does not respond as expected during a reconfiguration, an error is posted and the test set proceeds with the procedure as if the expected response was received.

Transport Channel Reconfiguration

  • You must be on an RB test mode call, with Channel Type set to a symmetrical RMC, to perform a transport channel reconfiguration.

System Handoffs

This functionality is only available in GSM/GPRS_W-CDMA fast switching test and lab applications.

  • You must be on a Radio Bearer Test Mode or AMR Voice call to perform a system handoff.
  • Before performing the handoff, you must ensure that the GSM/GPRS format is set to Active Cell (GSM) operating mode.
  • When performing a handoff from W-CDMA RB test mode to a GSM voice call with RB Test Mode to GSM Handoff Alerting State set to On, the UE will ring. You must answer the ring for the connection to be completed and testing to progress.
  • When performing a handoff from W-CDMA RB test mode to a GSM voice call with RB Test Mode to GSM Handoff Alerting State set to Off, when the handoff is completed, the connection is left in the RR Connected state. Data loopback (for BER testing) is available in this state, but voice echo is not.
  • Presetting the test set while operating in the W-CDMA format will not reset the System Handoff parameters to their default settings. Presetting the test set while operating in the GSM/GPRS format will reset these parameters to their default values.
  • When operating in the W-CDMA format, the System Handoff parameter settings are not saved when using the SAVE REGISTERS utility.

Related Topics

Handoffs (Handovers)


Inner Loop Power Troubleshooting

Inner Loop Power Troubleshooting

Possible Setup Issues

No other measurements can be running when an inner loop power measurement is performed. If any measurements are running when an inner loop power measurement is initiated, they are closed and a message is displayed to indicate that they were closed.

To use this measurement in Active Cell mode, UE (mobile station) needs to be up on a call. To use the measurement in FDD Test Mode, UE should be capable of deriving TPC commands in FDD test mode. You needs to configure the UE to use the right power control algorithm and the step size before initiating a measurement.

Inner Loop Power measurement will try to reconfigure the UE to the desired algorithm mode and power step size (if it is required) before running the measurement. If the UE does not receive or acknowledge this request, the test set will issue an error "No Physical channel reconfig complete Received".

The test set does not support testing the UE in compressed mode with this measurement, therefore 3 dB power control step size will not be allowed.

Trigger Delay should only be set to a non-zero value if your UE's output power response to TPC commands is delayed (i.e. if your UE is not operating properly). If your UE is behaving correctly in the timing of power changes in response to TPC commands, non-zero values of the Trigger Delay setting can cause unspecified results.

Absolute measurement results are affected by any amplitude offsets that are entered (relative measurement results are not). See Amplitude Offset .

This measurement does not provide valid results while on a faded channel (see Digital Bus Information ).

Interpreting Integrity Indicator Values

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. Measurement Calibration Indicator values

See Integrity Indicator .

Related Topics

  • Inner Loop Power Measurement Description


IQ Tuning Measurement Troubleshooting

IQ Tuning Measurement Troubleshooting

Possible Setup Issues

During remote operation of the IQ tuning measurement you should configure the trigger arm to single. See SETup:WIQTuning .

If the trigger arm is not set to single, you may not be able to retrieve measurement results during remote use if you are using the INIT:DONE? query. When the trigger arm is continuous, the measurement rearms itself and starts another measurement cycle, causing the INIT:DONE? query to always return "WAIT". See Trigger Arm (Single or Continuous) Description for more explanation.

The mobile station (UE) must be synchronized to the test set for this measurement to operate correctly.

RF In/Out Amplitude offsets entered do not affect these measurement results unless the received signal level becomes too low to accurately detect relative I/Q modulation vector transitions.

While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to Immediate or External .

Timing Error results are not available when Trigger Source is set to Immediate .

Interpreting Integrity Indicator Values

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Cannot Correlate (17) is returned, the test set cannot demodulate the signal from the mobile station (UE). Make sure the uplink scrambling code from the mobile station matches the UL Scrambling setting on the test set (see CALL:UPLink ).

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. See Measurement Calibration Indicator values .

See Integrity Indicator .

Related Topics

  • IQ Tuning Measurement Description


Loopback Bit Error Ratio Troubleshooting

Loopback Bit Error Ratio Troubleshooting

Possible Setup Issues

  • To perform the Loopback BER measurement while in Active Cell Operating Mode , you must be on an RB test mode call, with Channel Type set to a symmetrical RMC. Loopback BER can not be measured for Asymmetrical RMCs .
  • The UE must be configured in loopback mode 1 or 2 (see UE Loopback Type ). When using FDD Test Operating Mode , you must manually configure the UE during testing; no overhead messaging or signaling is provided to set up the mobile station in this operating mode. See UE Control During FDD Test Mode Operation .
  • If the Confidence Test Result is Max Bits Tested , you may need to increase the Number of Bits to Test to enable a Pass or Fail result.
  • Uplink DTCH RMC CRC Presence must be set to Present .
  • Loopback Delay results can not be obtained when DL DTCH Data is set to All Zeros or All Ones .
  • During remote operation of the loopback bit error ratio measurement, you should configure the trigger arm to single. See SETup:WBERror and Triggering of Measurements .
  • This measurement always uses protocol triggering. A measurement cannot be made unless the UE is synchronized to the test set's downlink signal and is transmitting a corresponding uplink signal.
  • Measurement results are affected by any amplitude offsets that are entered, since the level into the UE is altered.

Other Considerations

  • During front panel operation of the loopback BER measurement, intermediate results are always displayed (i.e. as bit errors are detected the current bit error ratio for the test is updated). This may cause the bit error ratio to vary throughout execution of the measurement. You should use the final bit error ratio reported to determine the BER result for the measurement, not the intermediate results.

    NOTE
    If trigger arm is set to continuous, it may be difficult to determine the final bit error ratio result. Watching the bits tested increment will help you determine when the measurement is reporting the final result. (The test set will then immediately begin the next measurement.)

  • The test set may return a Confidence Test Result of Max Bits Tested even when the Bit Error Ratio result is above the specified BER Requirement . This is because as testing progresses, the bit error ratio trajectory converges to a value (see 3GPP TS 34.121 Figure F.6.1.9 ). The test set attempts to predict if the BER value the UE is converging to will be above or below the BER Requirement . The BER trajectory may temporarily exceed the BER Requirement yet still converge to a value below the BER Requirement . A result of Max Bits Tested is returned by the test set if it can not accurately predict whether the trajectory is converging to a value above or below the BER Requirement .
  • The test set may return a Confidence Test Result of Pass even when the Bit Error Ratio result is above the specified BER Requirement if Bad DUT Factor is set to a very high level. This is because a Bad DUT Factor of greater than 1 shifts the early pass limit (defined in 3GPP TS 34.121 F.6.1.5 equation (2)) up.

  • When Confidence State is Off , you may set the number of data bits to test during the measurement using the Number of Bits to Test setting. However, the actual number of bits tested is always the largest multiple of the number of bits needed to fill a DTCH transport block for the transmitted format. For example, for the 12.2 kbps reference measurement channel (RMC) the transport block is 244 bits. So if you set the number of bits to test to 1000, the actual number of bits tested will be 1220 (1000 bits/244 bits per block = 4.1 blocks, so 5 blocks are required to test at least 1000 bits. 5 blocks x 244 bits per block = 1220 bits).

    When Confidence State is On , you may set the maximum number of bits to test during the measurement using the Number of Bits to Test setting. However, the actual number of bits tested will be less than this number if an early pass or early fail event occurs (see Confidence Test Result ). If a Confidence Test Result of Max Bits Tested is returned, then the actual number of bits tested is the largest multiple of the number of bits needed to fill a DTCH transport block for the transmitted format.

  • The loopback block error ratio and loopback bit error ratio measurements can not be run concurrently. If a BLER measurement is initiated while a BER measurement is active, the BER measurement will be aborted and the measurement will be closed (and vice versa).

Interpreting Integrity Indicator Values

  • If Measurement Timeout (2) is returned:
    • The measurement timeout value you entered for the measurement may be too small for the number of bits being used. In this case, either reduce the number of bits to test or increase the timeout value.
    • The measurement may not have started because it could not align the received data with the transmitted data. This happens if any of the following conditions occur:
      • The test set is unable to synchronize to the uplink signal. The test set can synchronize to the UE's signal only if the loopback delay is less than 50 transmission time intervals of the DTCH and the bit error ratio is less than 10% on a block-by-block basis for three consecutive blocks. If necessary, increase Cell Power or decrease AWGN Power to decrease BER and allow the test set to synchronize to the uplink signal.
      • The UE is not configured for the proper loopback mode.
      • The UE is not configured for the proper uplink transport format.
  • Questionable MS-to-Cell Data (28) is returned if a CRC Error or Missing Block is detected (see CRC Errors and Missing Blocks ).

Related Topics

Integrity Indicator


Occupied Bandwidth Troubleshooting

Occupied Bandwidth Troubleshooting

Possible Setup Issues

During remote operation of the occupied bandwidth measurement, you should configure the trigger arm to single. See SETup:WOBWidth .

If the trigger arm is not set to single, you may not be able to retrieve measurement results during remote use if you are using the INIT:DONE? query. When the trigger arm is continuous, the measurement rearms itself and starts another measurement cycle, causing the INIT:DONE? query to always return "WAIT". See Trigger Arm (Single or Continuous) Description for more explanation.

The trigger source defaults to Auto for the occupied bandwidth measurement, and tries to use protocol triggering if the mobile station (UE) is synchronized to the test set. Immediate triggering is used if the mobile station is not synchronized. While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to Immediate or External .

Interpreting Integrity Indicator Values

This measurement uses auto-ranging to automatically set the expected level into the test set.

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. CALibration Subsystem

See Integrity Indicator .

Related Topics

  • Occupied Bandwidth Measurement Description


PRACH Transmit On/Off Power Troubleshooting

PRACH Transmit On/Off Power Troubleshooting

Possible Setup Issues

  • Before performing a PRACH transmit on/off measurement, turn the UE on and wait for it to camp to the test set's signal. When the PRACH transmit on/off power measurement is initiated, the test set pages the UE. The UE must be camped to the test set and in idle mode before performing the PRACH Transmit On/Off Power measurement.
  • The measurement requires a minimum of 3 PRACH preambles, so PRACH Preambles must be no less than 3.
  • Importance of Setting Call Limit State to Off before Initiating a PRACH Measurement

    It is recommended that you set Call Limit State to Off before initiating this measurement. Then, when the measurement completes, if the UE is still sending PRACH preambles to the test set, the test set will acknowledge the UE. (Note, when the test set acknowledges the UE, the call is not completed because the UE is attempting to establish a BS originated call, whereas the test set acknowledges the UE expecting a MS originated call. You will see the call status move from Paging to Idle , Setup , Releasing and then back to Idle .) Acknowledging the UE helps prevent the UE from placing the test set into its cell barred list (see Test Set in Cell Barred List ).

    Setting call limit mode to off before initiating the measurement also avoids another issue: When the measurement completes, if you try to send signalling to the UE while it is still sending PRACH preambles to the test set, the UE will ignore the incoming messages and the signalling will fail. If call limit mode is set to off, the test set will acknowledge the UE and cause it to stop sending PRACH preambles, and then send the signalling you have requested to the UE.

  • Available Subchannels (Bit Mask) must be set to only one available subchannel.
  • No other measurements can be running when a PRACH transmit on/off power measurement is performed. If any measurements are running when a PRACH transmit On/Off power measurement is initiated, they are closed and a message is displayed to indicate that they were closed.
  • An RF rise to a level within 9 dB of the expected power ( Initial PRACH Tx Power if Power Control is set to Auto, or Manual Power if Power Control is set to Manual, see Receiver Control ) is required to allow the measurement to then trigger based on protocol. If your UE is not transmitting at the expected Initial PRACH Tx Power level, you may need to set expected power manually.
  • Absolute measurement results are affected by any amplitude offsets that are entered (relative measurement results are not). See Amplitude Offset .

Other Considerations

  • If the UE registers after the measurement has completed, the measurement results will no longer be viewable from the front panel or accessible via the FETCh:WOOPower commands. This will occur if the UE expects integrity protection to be enabled. See UE Registers Continuously Due to Integrity Protection Expectation .
  • If the PRACH transmit on/off power measurement timeout is not on, the PRACH transmit on/off measurement will hang until it is triggered by a PRACH burst. You can reset the measurement by pressing the MEASUREMENT RESET key.
  • This measurement does not provide valid results while on a faded channel (see Digital Bus Information ).

Interpreting Integrity Indicator Values

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. Calibrating the Test Set

See Integrity Indicator .

Related Topics

  • PRACH Transmit On/Off Power Measurement Description


Swept Audio Measurement Troubleshooting

Swept Audio Measurement Troubleshooting

December 21, 2004

Possible Setup Issues

During remote operation of the Swept Audio measurement, you should always set the Trigger Arm setting to Single. The length of time required to return a measurement over GPIB using continuous triggering varies, but is always longer than when using single triggering. Continuous triggering can also cause problems when the INITiate:DONE? query is used.

If digital measurements are active, turn them off or set their trigger source to Immediate. See Triggering of Measurements .

The Detector Type selected (peak or rms) also sets how Audio Level measurements are displayed; as a peak value or an rms value. When comparing returned values over GPIB to your specifications, be sure to take into account the type of detector being used.

The Expected Peak Voltage is always set in V peak , regardless of the Detector Type selected, and cannot exceed 20 V peak (14.1 V rms ).

For accurate measurements, always set the Detector Type, Filter Type, and other audio analyzer settings for the type of measurement being made. The SINAD and Distortion measurements typically use different settings than the Audio Level measurement. See Audio Analyzer Measurement Description and Audio Analyzer Block Diagram .

For very low level audio signals, or for measurements made in a noisy environment, use the 100 Hz BW BPF filter to reduce the affects of noise (see Audio Analyzer Measurement Description ).

Interpreting Integrity Indicator Values

See Integrity Indicator .

If over range (5) is returned, the input level is greater than 4.9 dB above the Expected Peak Amplitude value or the maximum input level of 20 volts peak.

If under range (6) is returned, the input level is lower than 8 dB below the Expected Peak Amplitude value.

If the signal has both over range and under range conditions, only the over range condition (5) is indicated.


Spectrum Monitor Troubleshooting

Spectrum Monitor Troubleshooting

Possible Setup Issues

During remote operation of the Spectrum Monitor you should configure the trigger arm to single, see SETup:SMONitor .

If the trigger arm is not set to single, the Spectrum Monitor may not return a result. When trigger arm is continuous the Spectrum Monitor rearms itself and starts another measurement cycle, during remote operation the fetch query may not be synchronized to the measurement cycle, see Measurement States .

If trigger source immediate is used for burst modulated signals the results returned will be unreliable. Burst modulated signals should be measured with Trigger Source set to RF Rise or Auto. For RF Rise triggering to work correctly, the signal should be no less than 20 dB below the reference and greater than -20 dBm.

While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to Immediate , External or RF Rise .

Interpreting Integrity Indicator values

See Integrity Indicator .

Related Topics

Spectrum Monitor Description


Spectrum Emission Mask Troubleshooting

Spectrum Emission Mask Troubleshooting

Possible Setup Issues

During remote operation of the spectrum emission mask measurement, you should configure the trigger arm to single. See SETup:WSEMask .

If the trigger arm is not set to single, you may not be able to retrieve measurement results during remote use if you are using the INIT:DONE? query. When the trigger arm is continuous, the measurement rearms itself and starts another measurement cycle, causing the INIT:DONE? query to always return "WAIT". See Trigger Arm (Single or Continuous) Description for more explanation.

The trigger source defaults to Auto for the spectrum emission mask measurement, and tries to use protocol triggering if the mobile station (UE) is synchronized to the test set. Immediate triggering is used if the mobile station is not synchronized. While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to Immediate or External .

Measurement results for the mask are not affected by any amplitude offsets that are entered because they are all relative to the in-channel power. The absolute in-channel power returned by the measurement will reflect any amplitude offset settings for the appropriate frequency range.

Interpreting Integrity Indicator Values

This measurement uses auto-ranging to automatically set the expected level into the test set.

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. See Calibration Strategy

See Integrity Indicator .

Related Topics

  • Spectrum Emission Mask Measurement Description


Test Set Lockup Due to Hardware Incompatibility

Test Set Lockup Due to Hardware Incompatibility

Description

Loading application firmware onto your test set that is not compatible with your test set's hardware configuration can cause your test set to lock up.

For information on application firmware and test set hardware compatibility, see:

http://www.agilent.com/find/8960upgrades

Test sets shipped after February, 2004 include a lockup recovery utility in the event that a test set lockup occurs due to hardware incompatibility. When the test set is powered on, the following text will be displayed for five seconds:

"Press `SYSTEM CONFIG' key to enter application selection utility."

If you press the SYSTEM CONFIG key within five seconds from the time this message is first displayed, a menu of installed applications will be displayed allowing you to select another application. Select one that is compatible with hardware option E5515CU-KO3.

Select an application that is compatible with your test set's hardware by entering the appropriate number listed on the display using the Data Entry keys.


Thermal Power Troubleshooting

Thermal Power Troubleshooting

Possible Setup Issues

During remote operation of the thermal power measurement you should configure the trigger arm to single. See SETup:WTPower .

If the trigger arm is not set to single, the measurement may not return a result. When trigger arm is continuous, the measurement rearms itself and starts another measurement cycle; possibly interrupting the FETCh operation during remote use. See Measurement States .

The trigger source is always immediate for the thermal power measurement. No synchronization or external signals are required.

Measurement results are affected by any RF In/Out amplitude offsets that are entered. See Amplitude Offset .

The thermal power measurement value may be slightly higher than the channel power measurement's value (typically about 0.25 dB). This is because the channel power measurement is band-limited, rejecting the additional power that may be in the uplink signal's sidebands.

This is a broadband, unfiltered power measurement. Therefore, virtually any signal present at the RF IN/OUT connector will affect this measurement. If the measured level exceeds the channel power measurement by more than 0.25 dBm, verify that the only signal present is the mobile station's (UE) uplink signal.

Interpreting Integrity Indicator Values

This measurement uses autoranging to automatically set the expected level into the test set.

If Over Range (5) is returned, the signal exceeds the maximum allowable level for the test set.

If Under Range (6) is returned, the measured signal is below -21 dBm. The thermal power measurement is specified to operate accurately down to -10 dBm, and will operate with degraded accuracy down to -20 dBm. Use the channel power measurement for measuring lower level signals.

See Integrity Indicator .

Related Topics

Thermal Power Measurement Description


Troubleshooting UE Reported Measurements

Troubleshooting UE Reported Measurements

  • When you issue the Send Meas Request command (see Cell 1/Cell 2 UE Reported Measurements ), if no measurement results are displayed for cell 1 (or cell 2 when using the lab application), consider the following:

    When you issue the Send Meas Request command, the UE is directed to perform measurements on the neighbor cells specified in SIB 11 (see SIB11 Cell Info List ). It should also report measurement results for any other detected cells not on the neighbor list. However some UEs may require that the cell be in the neighbor list in order to perform measurements on it. Thus, ensure that you have entered cell 1's Primary Scrambling Code in the Intra-frequency Cells list (and/or cell 2's primary scrambling code, see "Cell 2 Overview" on page 1 ).

    For cell 2, see also Cell 2 Power is on, but no Mobile Station Reported Pilot Level Information is being displayed for Cell 2 .

  • While Cell 2 Time Offset can be set to a negative value, the SFN-SFN Observed Time Difference (OTD) measurement result gives the absolute value of the timing difference between cell 1 and cell 2.

Related Topics

UE Reported Measurements


Troubleshooting Video Call

Troubleshooting Video Call

This section is only applicable to the lab application and to a test application with the required feature license.

  • The 8960 receiving the video call origination must be in Active Cell Operating Mode , in Idle state.
  • If one of the 8960s is partially preset while up on a video call, the call to its UE is dropped with no over-the-air signaling. If the other UE does not recognize that the call has dropped (and thus ends the call), you should manually end the call or partially preset its 8960 as well.
  • If one of the 8960s is fully preset while up on a video call, the external device connection is disconnected, which causes both 8960s to end the call with their respective UEs.
  • Originating a video call on your UE may require different key presses than originating a voice call.

Related Topics

Video Call


Block Error Ratio Troubleshooting

Block Error Ratio Troubleshooting

Possible Setup Issues

  • When performing the block error ratio measurement for Symmetrical RMCs :
    • The UE must be configured in loopback mode 2 (see UE Loopback Type ).
    • Uplink DTCH RMC CRC Presence must be set to Used for Data .
  • When using FDD Test Operating Mode , you must manually configure the UE during testing; no overhead messaging or signaling is provided to set up the mobile station in this operating mode. See UE Control During FDD Test Mode Operation .
  • For Asymmetrical RMCs , the test set will stop sending downlink transport blocks to the UE if it does not receive an acknowledgment or retransmission request from the UE for a significant period of time. If the UE does not then drop the call, the measurement will hang. You must increase the downlink signal-to-noise ratio (e.g. increase Cell Power or decrease AWGN Power so that the UE can detect the downlink transport blocks and send acknowledgments or retransmission requests to the test set). You must also disconnect and then reconnect the call, then re-initiate the measurement. To prevent the measurement from hanging again in the future, enable the Measurement Timeout . Note, however, that before re-initiating the measurement you will still need to increase the downlink signal-to-noise ratio, then disconnect and reconnect the call.
  • The block error ratio measurement can not be performed on the 33k No Coding RMC .
  • During remote operation of the block error ratio measurement, you should configure the trigger arm to single. See SETup:WBLerror and Triggering of Measurements .
  • During front panel operation of this measurement, if Trigger Arm is set to Single (see Trigger Arm (Single or Continuous) Description ), you must press the START SINGLE key to initiate the measurement.
  • Measurement results are influenced by any amplitude offsets that are entered, since the level into the UE is altered.

Interpreting Integrity Indicator Values

  • If Measurement Timeout (2) is returned:
    • The Measurement Timeout value you entered for the measurement may be too small for the number of blocks being used. In this case, either reduce the number of blocks to test or increase the timeout value.
  • Questionable MS-to-Cell Data (28) is returned if a missing block is detected (see Uplink Missing Blocks ).

Other Considerations

  • The block error ratio and loopback bit error ratio measurements can not be run concurrently. If a BLER measurement is initiated while a BER measurement is active, the BER measurement will be aborted and the measurement will be closed (and vice versa).

  • It is not necessary to synchronize the test set and UE when performing the block error ratio measurement (it is not necessary to align received uplink transport blocks with their corresponding downlink transport blocks), whereas the test set must align the uplink and downlink blocks before performing the loopback BER measurement. Thus, the measurement does not determine the UE's Loopback Delay , whereas the loopback BER measurement does.
  • To perform the block error ratio measurement for symmetrical RMCs, Uplink DTCH RMC CRC Presence must be set to Used for Data . This disables the uplink CRC. Thus, the block error ratio measurement does not report any uplink CRC Errors , whereas the loopback BER measurement does. Thus, it is very important that you ensure the uplink is robust (error free).
  • The Uplink Missing Blocks result does not apply to Asymmetrical RMCs .

Related Topics

Integrity Indicator


Change of TFC (Transport Format Combination) Troubleshooting

Change of TFC (Transport Format Combination) Troubleshooting

This section is only applicable to the lab application.

Possible Setup Issues

  • Before performing the change of TFC measurement, you must ensure the following:

    • Operating Mode = Active Cell Operating Mode .
    • Current Service Type = Radio Bearer Test Mode (you must be on an RB Test Mode connection).
    • Uplink Dummy DCCH Data = Off .
    • Initial output level of your UE is such that its output power level with DPDCH on and off falls within the measurement's required input level (see Change of TFC Measurement Input Signal Requirements ).

  • The following settings are recommended based on the 3GPP TS 34.121 5.6 requirements:

    • UE Target Power = 0 dBm .
    • UL CL Power Control Mode = Alternating bits .
    • UL CL Power Ctrl Algorithm = Two .
    • Uplink DPCH Bc/Bd Control = Auto . This ensures that [image] and [image] are (automatically) set to the values specified by the standards (for example, 0.5333 and 1.0 for 12.2k RMC).
  • During front panel operation of this measurement, you must press the START SINGLE key to initiate the measurement.
  • The change of TFC measurement is triggered when the TFCI indicates no data is present on the DPDCH. If the UE does not properly set the TFCI bit to indicate when data is present on the DPDCH, the measurement will hang. To prevent the measurement from hanging indefinitely, set the Measurement Timeout . You can reset the measurement, if needed, by pressing the MEASUREMENT RESET key.
  • This measurement does not provide valid results while on a faded channel (see Digital Bus Information ).

Other Considerations

  • No other measurements can run while a change of TFC measurement is being performed. If any measurements are running when a change of TFC measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while a change of TFC measurement is running, the change of TFC measurement is closed and a message is displayed.
  • Ensure that the UE is meeting the Change of TFC Measurement Input Signal Requirements .
  • The change of TFC measurement must be properly calibrated (see Change of TFC Measurement Calibration )

Related Topics

  • Change of TFC (Transport Format Combination) Measurement Description


Dynamic Power Analysis Troubleshooting

Dynamic Power Analysis Troubleshooting

Possible Setup Issues

  • To ensure proper triggering when Trigger Source is set to RF Rise , it is highly recommended that you use trigger qualification for robust triggering (see Trigger Qualification State ).
  • The product of Steps and Step Length must not exceed 58.260 ms.
  • The UE's signal may or may not be modulated with an uplink DPCH signal. If the signal is not modulated with an uplink DPCH signal and is offset in frequency from the expected measurement frequency, you may need to use the Frequency Offset setting to ensure the most accurate power measurements possible.
  • To ensure proper autoranging, you must specify the number of steps in your sequence and their duration using the Steps and Step Length settings. It is important that you set Steps equal or greater than the number of steps in your UE's power sequence so that the entire power sequence is evaluated during the autoranging.
  • Each step in the power sequence must be identical in length.
  • Measurement Interval must be less than or equal to Step Length .
  • The test set assumes a crest factor of 3.1 dB for the signal (as is typical for an uplink DPCH signal relative to a CW signal) and thus actually triggers when the input signal reaches the RF Rise Trigger Threshold level plus 3.1 dB. If the UE's signal has a crest factor other than 3.1 dB, you must set the RF Rise Trigger Threshold level accordingly.
  • RF Rise Trigger Threshold must be set to within 0 dB to -25 dB of the Expected Power .
  • During front panel operation of this measurement, if Trigger Arm is set to Single (see Trigger Arm (Single or Continuous) Description ), you must press the START SINGLE key to initiate the measurement.

Other Considerations

  • You can perform the dynamic power analysis measurement in Active Cell Operating Mode and FDD Test Operating Mode . However, since this measurement does not utilize any overhead signalling to control the UE's power or frequency, you must manually set the test set's Expected Power and Measurement Receiver Frequency ) in either operating mode.
  • Absolute measurement results are affected by any amplitude offsets that are entered (relative measurement results are not). See Amplitude Offset .

Related Topics

Dynamic Power Analysis Measurement Description

Dynamic Power Analysis Measurement Input Signal Requirements

Dynamic Power Analysis Measurement Calibration

Integrity Indicator

Amplitude Offset


Out-of-Synch Handling of Output Power Troubleshooting

Out-of-Synch Handling of Output Power Troubleshooting

This section is only applicable to the lab application.

Possible Setup Issues

  • The Out-of-Synch Handling of Output Power measurement does not return any measurement results at this time. Initiating the measurement only causes the test set to change its DPCCH_Ec/Ior as specified by the Out-of-Synch Handling of Output Power Measurement Parameters . You must use an external spectrum analyzer to measure the UE's resulting output power. When the Out-of-Synch Handling of Output Power measurement is initiated from the test set, the test set generates a trigger at point A that you can route to the test set's rear panel TRIG OUT connector using the Trigger Output Setup setting, to trigger the spectrum analyzer. See How Do I Make an Out-of-Synch Handling of Output Power Measurement? .
  • Before performing the out-of-synch measurement, you must:
    • Connect the test set's rear panel TRIG OUT port to the rear panel TRIGGER IN port of an external spectrum analyzer (the external spectrum analyzer is required to measure the UE's output power and obtain measurement results, see Out-of-Synch Handling of Output Power Measurement Results ).
    • Connect the UE to the test set's RF IN/OUT port and to the spectrum analyzer's RF INPUT port via an RF splitter, and specify the loss due to the RF splitter in both the test set and the spectrum analyzer.
    • Set Trigger Output Setup to Measurement Generated .
    • Establish a Radio Bearer Test Mode connection (3GPP TS 34.121 5.4.4 specifies a 12.2k RMC connection).
  • The following settings are recommended based on the 3GPP TS 34.121 5.4.4 requirements. Note that some of these parameters must be set before establishing a connection.
    • Set Connected DL Channel Levels as specified by 3GPP TS 34.121 Table E.3.3 and Table 5.4.4.3:
      • Cell 1 Connected CPICH Level = -10.00 dB .
      • Cell 1 Connected P-CCPCH/SCH Level = -12.00 dB .
      • Cell 1 Connected S-CCPCH Level = Off .
      • Cell 1 Connected PICH Level = -15.00 dB .
      • Cell 1 Connected DPCH Level = -16.60 dB . (This sets DPCCH_Ec/Ior before point A to -16.6 dB, because PO1 = PO2 = PO3 = 0, which makes DPCH_Ec/Ior = DPCCH_Ec/Ior).

      See Setting Downlink Channel Levels .

    • Set (T313 + N313*10 ms) > (Ta-b + 200 ms + Tc-d + Td-e + N315*10 ms) to ensure that the UE will not drop the call when the measurement in initiated (see UE Timers and Out-of-Synch Handling of Output Power Measurement Parameters ). The UE may drop the call if the UE timers specify a drop time that is less than the time that the test set's DPCCH_Ec/Ior value is low, plus the time required for the UE to receive N315 "in sync" indicators. 3GPP TS 34.121 Table 5.4.4.2A specifies a value of 15 s for T313 and a value of 200 for N313.
    • Leave the Out-of-Synch Handling of Output Power Measurement Parameters set to their default values, (which correspond to 3GPP TS 34.121 section 5.4.4.2, 5.4.4.4.2 and Table 5.4.4.3):
      • Segment Ta-b Interval = 5.000 s
      • Segment Tc-d Interval = 5.000 s
      • Segment Td-e Interval = 5.000 s
      • DPCCH Quality Ratio Qa-b = -21.60
      • DPCCH Quality Ratio Qb-d = -28.40
      • DPCCH Quality Ratio Qd-e = -24.40
      • DPCCH Quality Ratio Qe+ = -17.60
    • Set UE Target Power to the maximum output power for your UE and set UL CL Power Control Mode to All Up bits .
    • Set Cell Power ( F7 on the Call Parms 1 of 3 menu) to -61 dBm .
    • Select Generator Info ( F3 on the Call Control 2 of 4 menu) and set AWGN Power ( F5 ) to -60 dBm.
  • During front panel operation of this measurement, you must press the START SINGLE key to initiate the measurement.

Other Considerations

  • The out-of-synch handling of output power measurement can be performed while in FDD Test Operating Mode , however you must configure the UE such that its output power will respond appropriately to the changes in the test set's DPCCH_Ec/Ior.

  • No other measurements can be running when an out-of-synch handling of output power measurement is performed. If any measurements are running when an out-of-synch handling of output power measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while an out-of-synch handling of output power measurement is running, the out-of-synch handling of output power measurement is closed and a message is displayed.
  • If the measurement is aborted, the UE could be left in an off state if the pre-measurement value of Cell 1 Connected DPCH Level is less than Qin.
  • The measurement will timeout unless Measurement Timeout > Segment Ta-b Interval + 200 ms + Segment Tc-d Interval + Segment Td-e Interval + 200 ms.
  • This measurement does not provide valid results while on a faded channel (see Digital Bus Information ).

Related Topics

  • Out-of-Synch Handling of Output Power Measurement Description


Phase Discontinuity Troubleshooting

Phase Discontinuity Troubleshooting

Possible Setup Issues

  • In Active Cell Operating Mode , you must be on a call before initiating the measurement.
  • In FDD Test Operating Mode , you must ensure that the UE is synchronized to the downlink frame clock before running the measurement.
  • During front panel operation of this measurement, you must press the START SINGLE key to initiate the measurement.
  • Ensure that you have met the Phase Discontinuity Measurement Input Signal Requirements .
  • Before performing a phase discontinuity measurement, ensure that the measurement has been properly calibrated (see Calibrating the Test Set ).

Other Considerations

  • No other measurements can be running when a phase discontinuity measurement is performed. If any measurements are running when a phase discontinuity measurement is initiated, they are closed and a message is displayed to indicate that they were closed.
  • Absolute measurement results are affected by any amplitude offsets that are entered (relative measurement results are not). See Amplitude Offset .
  • The Phase (in degrees) result is always zero for the Reference Timeslot .
  • No Phase Discontinuity (in degrees) result is reported for the Reference Timeslot .
  • When Power Control Pattern is set to 5UP/4DOWN or 5DOWN/4UP , when the measurement completes, in an attempt to maintain the connection with the UE, the test set sets UE Target Power to the UE's output power in the final measured slot and sets UL CL Power Control Mode to Active Bits when in Active Cell Operating Mode or to Alternating Bits when in FDD Test Operating Mode .
  • While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to External .

Related Topics

  • Phase Discontinuity Measurement Description


PRACH Preamble Analysis Troubleshooting

PRACH Preamble Analysis Troubleshooting

This section is only applicable to the lab application.

Possible Setup Issues

  • Before performing a PRACH preamble analysis measurement, turn the UE on and wait for it to camp to the test set's signal. When the PRACH preamble analysis measurement is initiated, the test set pages the UE. The UE must be camped to the test set and in idle mode before performing the PRACH preamble analysis measurement.
  • The measurement requires a minimum of 3 PRACH preambles, so PRACH Preambles must be no less than 3.
  • Importance of Setting Call Limit State to Off before Initiating a PRACH Measurement

    It is recommended that you set Call Limit State to Off before initiating this measurement. Then, when the measurement completes, if the UE is still sending PRACH preambles to the test set, the test set will acknowledge the UE. (Note, when the test set acknowledges the UE, the call is not completed because the UE is attempting to establish a BS originated call, whereas the test set acknowledges the UE expecting a MS originated call. You will see the call status move from Paging to Idle , Setup , Releasing and then back to Idle .) Acknowledging the UE helps prevent the UE from placing the test set into its cell barred list (see Test Set in Cell Barred List ).

    Setting call limit mode to off before initiating the measurement also avoids another issue: when the measurement completes, if you try to send signalling to the UE while it is still sending PRACH preambles to the test set, the UE will ignore the incoming messages and the signalling will fail. If call limit mode is set to off, the test set will acknowledge the UE and cause it to stop sending PRACH preambles, and then send the signalling you have requested to the UE.

  • Available Subchannels (Bit Mask) must be set to only one available subchannel.
  • During front panel operation of this measurement, you must press the START SINGLE key to initiate the measurement.
  • No other measurements can be running when a PRACH preamble analysis measurement is performed. If any measurements are running when a PRACH preamble analysis measurement is initiated, they are closed and a message is displayed to indicate that they were closed.

Other Considerations

  • The measurement will execute fastest if you only specify one available signature using the PRACH Signature setting.
  • The PRACH preamble analysis measurement reports the PRACH signature used by the UE for the preamble burst being analyzed. This result may differ from the Detected PRACH Signature result if more than one signature is specified as available by the PRACH Signature setting.
  • While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to RF Rise or External .
  • Timing error is not reported when Trigger Source is set to RF Rise .
  • FDD Test Operating Mode Considerations
    • When operating in FDD Test Operating Mode , you do not have access to the PRACH Signature setting, as the test set does not send this type of signalling to the UE in FDD test operating mode. However, when you initiate the measurement in FDD test operating mode, the measurement uses the value last set in the PRACH signature setting to determine which signatures to try to correlate to the PRACH preamble burst. Thus, you must switch to Active Cell Operating Mode and ensure that the PRACH Signature setting includes the signature that your UE will transmit before running this measurement in FDD test operating mode.
  • If the PRACH preamble analysis measurement timeout is not on, the PRACH preamble analysis measurement will hang until it is triggered by a PRACH burst. You can reset the measurement by pressing the MEASUREMENT RESET key.

Interpreting Integrity Indicator Values

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. Calibrating the Test Set

See Integrity Indicator .

Related Topics

  • PRACH Preamble Analysis Measurement Description


Waveform Quality Troubleshooting

Waveform Quality Troubleshooting

Possible Setup Issues

During remote operation of the waveform quality measurement you should configure the trigger arm to single. See SETup:WWQuality .

If the trigger arm is not set to single, you may not be able to retrieve measurement results during remote use if you are using the INIT:DONE? query. When the trigger arm is continuous, the measurement rearms itself and starts another measurement cycle, causing the INIT:DONE? query to always return "WAIT". See Trigger Arm (Single or Continuous) Description for more explanation.

The mobile station (UE) must be synchronized to the test set for this measurement to operate correctly.

RF In/Out Amplitude offsets entered do not affect these measurement results unless the received signal level becomes too low to accurately detect relative I/Q modulation vector transitions.

While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to Immediate or External .

Timing Error results are not available when Trigger Source is set to Immediate .

Interpreting Integrity Indicator Values

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Cannot Correlate (17) is returned, the test set cannot demodulate the signal from the mobile station (UE). Make sure the uplink scrambling code from the mobile station matches the UL Scrambling setting on the test set (see CALL:UPLink ).

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. See Measurement Calibration Indicator values .

See Integrity Indicator .

Related Topics

Waveform Quality Measurement Description


UI Log

UI Log

Description

To help you troubleshoot or optimize your GPIB control programs, you can configure the test set to capture GPIB interface traffic and store it in the UI (User Interface) Log. To enable GPIB logging, see Step 2: Turn On UI Log GPIB State .

The UI log buffer can store up to 51200 bytes of information. If the buffer is full, the oldest entry is removed from the top of the log and the newest entry is added to the end.

You can reset and access the UI Log through either the GPIB interface or a Web Browser.

The following procedures demonstrate how to reset and access the UI Log.

  • Step 1: Clear UI Log Data
  • Step 2: Turn On UI Log GPIB State
  • Step 3-1: Get UI Log Data
  • Step 3 - 2: Get Other UI Log Information (Optional)
  • Step 4: Save UI Log Data

Step 1: Clear UI Log Data

Before capturing new GPIB traffic, you can clear the residual information in UI Log storage. Two methods are valid to clear UI Log data storage in the test set.

  • Clear the UI Log via Local Area Network (LAN)

    • Connect you computer to the test set via LAN or directly via a LAN crossover cable.
    • Go to the URL of the test set using a web browser such as Internet Explorer.
      URL in Web Browser to Clear UI Log Data
      Command | Example
      http:// <test_set_ip_address> /uilogclear | http://111.222.333.444/uilogclear

    Clear UI Log Data

  • Clear the UI log via GPIB

    • Connect your computer to the test set via a GPIB interface.
    • Send the GPIB command in the following table to the test set and the log is cleared
    GPIB Command to Clear the UI Log
    Command | Example
    SYSTem:LOG:UI:CLEAR | SYST:LOG:UI:CLEAR
    .

Step 2: Turn On UI Log GPIB State

  • Send the GPIB command in the following table to the test set before you run your test program or send it from the point in your program where it is desired to start GPIB logging.

    The Log GPIB state is reset to OFF after cycling power. It is not reset by a full preset.

    UI Log GPIB State Command
    Command Example

    SYSTem:LOG:UI:GPIB[:STATe] ON|OFF

    SYST:LOG:UI:GPIB:STAT ON

Step 3-1: Get UI Log Data

  • Go to the URL of the test set using your web browser to retrieve the GPIB log. The GPIB log is displayed in the browser window.
    NOTE

    You must ensure the computer is connected to the test set either via Ethernet LAN or a direct connection using a LAN crossover cable.

    URL in Web Browser to get the UI Log Data
    Command | Example
    http:// <test_set_LAN_IP_Address> /uilog | http://111.222.333.444/uilog
    Display UI Log Data in Web Browser

    NOTE
    In addition to GPIB traffic information, the UI Log also includes data regarding the key presses, knob turns and error messages that occur as you operate your test set from the front panel. Only the lines with the prefix "rem:" indicate the GPIB commands.

The UI Log display is not real time, therefore the latest UI log does not display automatically in the web browser. To capture multiple logs, click Refresh in the View menu.

Step 3 - 2: Get Other UI Log Information (Optional)

You can get more information about UI log data by sending the GPIB queries.

  • Query the number of lines containing GPIB commands in the UI Log

    The GPIB query in the following table returns the number of lines in the log since the latest time the log is cleared and before receiving this query.

    Query the numbers of GPIB commands in the UI Log
    Command Example

    SYSTem:LOG:UI:COUNt?

    SYST:LOG:UI:COUN?
  • Query the string at the specified line in the UI Log

    The GPIB query in the following table returns the string located at the line you specified in the log.

    Query the string in the UI Log
    Command Example

    SYSTem:LOG:UI:REPort? <sp><number value>

    SYST:LOG:UI:REP? 11

Step 4: Save UI Log Data

To save the log in the Web Browser to a file:

  1. In the File menu, click Save As....
  2. In the Save as type: box, select Text File (*.txt).
  3. In the File name: box, type the file name.
  4. Click the Save button.


Activate PDP Context Reject

Activate PDP Context Reject

Last updated: December 22, 2004

This section is only applicable to the lab application.

You may configure the test set to simulate a network rejection of an Activate PDP Context Request from the UE by setting Activate PDP Context Reject State to On . You can choose what value is sent in the SM Cause information element of the Activate PDP Context Reject message using the Activate PDP Context Reject SM Cause setting. Use this function in parallel with Protocol Logging to verify that the UE behaves in a manner conforming to the standards for this situation and for each associated SM Cause value.

Activate PDP Context Reject SM Cause

When Activate PDP Context Reject State is On , you may specify what value is sent in the SM Cause information element using the Activate PDP Context Reject SM Cause setting. From the front panel, you may choose from the valid causes specified in 3GPP TS 24.008 10.5.6.6.

Activate PDP Context Reject SM Cause
Cause Value (decimal) | Cause Value (bits) | Cause
25 | 00011001 | LLC or SNDCP Failure
26 | 00011010 | Insufficient Resources
27 | 00011011 | Missing or Unknown APN
28 | 00011100 | Unknown PDP Address or PDP Type
29 | 00011101 | User Authentication Failed
30 | 00011110 | Activation Rejected By GGSN
31 | 00011111 | Activation Rejected, Unspecified
32 | 00100000 | Service Option Not Supported
33 | 00100001 | Requested Service Opt Not Subscribed
34 | 00100010 | Service Opt Temporarily Out of Order
35 | 00100011 | NSAPI Already Used
36 | 00100100 | Regular Deactivation
37 | 00100101 | QoS Not Accepted
38 | 00100110 | Network Failure
39 | 00100111 | Reactivation Required
40 | 00101000 | Feature Not Supported
41 | 00101001 | Semantic Error in TFT Operation
42 | 00101010 | Syntactical Error in TFT Operation
43 | 00101011 | Unknown PDP Context
44 | 00101100 | Semantic Error in Packet Filter(s)
45 | 00101101 | Syntactical Errors in Packet Filters(s)
46 | 00101110 | PDP Context Without TFT Already Activated
81 | 01010001 | Invalid Transaction Identifier Value
95 | 01011111 | Semantically Incorrect Message
96 | 01100000 | Invalid Mandatory Information
97 | 01100001 | Msg Type Non-existent/Not Implemented
98 | 01100010 | Msg Type Not Compatible With Protocol State
99 | 01100011 | IE Non-existent or Not Implemented
100 | 01100100 | Conditional IE Error
101 | 01100101 | Msg Not Compatible With Protocol State
111 | 01101111 | Protocol Error, Unspecified

If you select Custom Value from the front panel, a value of 0 is sent to the UE.

The CALL:SERVice:GPRS:REJect:CAUSe command allows you to send any value between 0 and 255 to the UE, even those not mapped to a cause in the standard. If you send a value other than those listed in the above table via the GPIB command, the front panel setting displays CUSTOM .

Related Topics

Ladder Diagram: UE Initiated GPRS Service, Activate PDP Context Reject

How Do I Configure the Data Channel?

GPRS Packet Data Service

CALL:SERVice

Call Processing Status


Data Channel Applications

Data Channel Applications

This section is only applicable to the lab application.

WAP Functional Test

The WCDMA Data Channel facilitates the functional test of a Wireless Application Protocol (WAP) device such as a WAP-enabled mobile station.

Logging data during this process provides protocol data at useful points in the stack, which may help in debugging a WCDMA device.

Before you use the data channel for WAP functional test, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network (not the same as the WAP gateway)
  • a valid IP address for the DUT
  • the default WAP gateway address (this may be required by the WCDMA device)

Modem Functional Test

The data channel feature enables testing of wireless modems or WCDMA devices with built-in modems.This test typically involves using a dial-up connection. If the modem is not built-in, it is usually controlled from another device such as a PC.

Before you use the Data channel for modem testing, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network
  • a valid IP address for the modem or its controlling PC (even though the modem is the Device Under Test (DUT), typically a PC will be assigned the IP address)

Base Station Emulation

You can use the Data Channel and the test set to emulate a base station. This is particularly useful when you want to have a base station available, for example when demonstrating a wireless application, or when functionally testing wireless devices on a workbench. You may also want to vary key parameters of the cell, such as transmit power, and observe how the DUT performs.

Before you use the Data Channel for Base Station Emulation, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network
  • a valid IP address for the DUT

FTP Functional Test

The Data Channel facilitates File Transfer Protocol (FTP) via the device. Typically this is done with a dial-up connection to an external PC using a GPRS PCMCIA modem or an external GPRS modem.

With appropriate evaluation tools on the Control PC, you can measure the throughput of the modem. Many commercial FTP programs provide detailed information on transfer speed.

To empirically measure the throughput, the performance of the network must be known. For this reason, it is not recommended to perform this evaluation while connected to the Internet. A direct connection or Intranet connection should be used instead.


CS (Circuit Switched) Data Service

CS (Circuit Switched) Data Service

The test set supports two types of CS data service:

  • Asynchronous/Non-Transparent CS Data Service
  • Synchronous/Transparent CS Data Service

The synchronous/transparent service is used by 3G-324M multi-media applications (for example, video phones), whereas the asynchronous/non-transparent service is used by more bursty data, such as IP traffic. The primary difference between the two services is that they use different radio bearer configurations, and the asynchronous/non-transparent configuration includes the RLP layer above the RLC entities (the RLC entities connect directly to the application in the synchronous/transparent configuration).

Asynchronous/Non-Transparent CS Data Service

The test set only supports UE-originated asynchronous/non-transparent CS data service, but both test set and UE-initiated release from the CS data service are supported.

Two radio bearers are supported: 57.6k UL/57.6k DL CS Data RAB (see 3GPP TS 34.108, 6.10.2.4.1.17) and 14.4k UL/14.4k DL CS Data RAB (see 3GPP TS 34.108, 6.10.2.4.1.15). You may specify the downlink DPCH channel codes for these two RABs using the DPCH 120 ksps Channelization Code and DPCH 30 ksps Channelization Code settings (see Downlink Channel Codes and Levels ).

Async CS Data Source

You may choose what application protocol uses the CS data service using the Async CS Data Source setting. This setting can only be changed when the call status is idle. This setting allows you to specify the access point to the traffic plane data stream as follows:

  • Serial Port - connects the top of the L2R/RLP layer directly to the rear panel SERIAL 3 port of the test set. When Async CS Data Source is set to Serial Port , debug access to the serial port is shut off, and the serial port is configured for CS data operation (data rate of 115,000 bps, 8 bits, no parity, 1 stop bit).
    Software flow control (i.e. XON/XOFF characters) is used across the serial port to control the data flow. The L2R/RLP entity obeys the flow control commands from the UE and will similarly command the UE to stop sending data if its internal buffers begin to fill up.
  • IP - connects the top of the L2R/RLP layer to a PPP/IP layer that is fed to the test set's LAN PORT . The PPP layer operates in asynchronous framing mode.

GPIB command: CALL:SERVice:CSData:MODE:ASYNchronous:OUTput .

CS Data Asynchronous Bearer User Plane Protocol Configuration

Synchronous/Transparent CS Data Service

This section is only applicable to the lab application and to a test application with the required feature license.

The synchronous/transparent CS data service allows you to make an 3G-324M Video Call between two UEs that are connected to two 8960s that have an External Device Connection .

One radio bearer is supported: 64k UL/DL CS Data RAB (see 3GPP TS 34.108, 6.10.2.4.1.13). You may specify the downlink DPCH channel code for this RAB using the DPCH 120 ksps Channelization Code setting (see Downlink Channel Codes and Levels ).

Related Topics

Manual Operation: How Do I Configure the Data Channel?

Video Call

Downlink Channel Codes and Levels

CALL:SERVice

Rear Panel Connectors


Getting Started with the Data Channel

Getting Started with the Data Channel

The data channel feature allows you to use the test set as an IP router, exchanging data between a wireless device and remote servers.

To review the setup and use of the data channel feature, see GPRS Packet Data Service Example Procedure .

TO RETURN TO THE MAIN DATA CHANNEL PAGE, click here: Data Channel .


GPRS Packet Data Service Ladder Diagrams

GPRS Packet Data Service Ladder Diagrams

Last updated: December 22, 2004

This section is only applicable to the lab application.

  • GPRS Attach
  • Test Set Initiated GPRS Detach
  • UE Initiated GPRS Detach
  • Test Set Initiated GPRS Service
  • UE Initiated GPRS Service
  • UE Initiated GPRS Service, Activate PDP Context Reject

GPRS Attach

Test Set Initiated GPRS Detach

UE Initiated GPRS Detach

Test Set Initiated GPRS Service

UE Initiated GPRS Service

UE Initiated GPRS Service, Activate PDP Context Reject

Related Topics

GPRS Packet Data Service


GPRS Packet Data Service

GPRS Packet Data Service

This section is only applicable to the lab application.

The WCDMA Lab Application's packet data service is a complete end-to-end service conforming to the GPRS Packet Data Service described in 3GPP TS 23.060 specification. The lab application does not provide any applications support or network services above TCP/IP packet handling.

PS Domain Information must be set to Present before a UE will initiate PS services with the test set.

For an example of establishing a packet data connection, see GPRS Packet Data Service Example Procedure

Related Topics

GPRS Packet Data Service Ladder Diagrams

How Do I Configure the Data Channel?


GPRS Packet Data Service Example Procedure

GPRS Packet Data Service Example Procedure

Last updated: December 22, 2004

This section is only applicable to the lab application.

The following procedure is an example of how to use the test set for IP packet data transfer. The following steps outline the requirements for data service using a WCDMA mobile station as a wireless modem. The mobile station will be connected to the USB port on a laptop computer (PC) running USB port software developed by the manufacturer of the mobile station.

All test sets capable of running the WCDMA Lab Application have an internal server with an 8960 web site. This web site provides screen capture images and supports printouts. This procedure will demonstrate how to access this web site via the RF interface using packet data service.

The purpose of this procedure is to serve as an overview of the tasks required for a typical data channel application. If your particular application involves accessing internet or intranet sites via the test set's LAN interface, additional requirements such as getting through corporate firewalls may complicate setup procedures.

A. PC Setup

Install and Configure Device Driver

The laptop has to be configured to include the wireless modem in its list of networks. In this application, the wireless modem manufacturer produced software that runs on the PC. When run for the first time, the software prompts the user for setup information. When properly configured, the PC will recognize the wireless modem on the USB (or other) port.

Configure the PC for a dial-up connection to the Internet via the mobile station

The laptop has to be configured to include the wireless modem in its list of networks. The network dial-up connection properties must be configured according to the requirements of the mobile station and the data port driver. When the PC is properly configured, the "Network and Dial-up Connections menu" should include the wireless modem in its list of connections.

B. Hardware Connections

There are many different configurations for testing wireless modems (or other UE such as WAP enabled mobile stations) data handling performance. See Modem Functional Test for a diagram of the configuration used for this example.

RF (Wireless Modem to Test Set)

  1. Connect the wireless modem RF cable to the test set's RF In/Out port.

PC to Wireless Modem

  1. For this example, the USB port provides the connection. Connect the USB port from the wireless modem to the PC.

C. Test Set Setup

  1. Press the Call Setup key to go to the Call Setup screen on the test set.
  2. Press the left More key to go to the 3 of 3 screen of the Control menu.
  3. Select DUT IP Setup to open the DUT IP Setup menu on the test set.
  4. Set the DUT IP Address in the DUT IP Setup menu on the test set. For this procedure, The DUT IP Address must be unique in that no other host on the network is using that same address. In this example the network consists of only two IP addresses, the PC and the Test Set. The DUT IP Address must be different than the LAN IP Address found in the Instrument Setup menu. See IP Address Requirements .
  5. In this application, the DUT IP Address will be sent to the laptop computer if you set the Internet Protocol (TCP/IP) Properties to "Obtain an IP address automatically" menu.

  6. The following script was used to set up the Test Set's base station emulator for the wireless modem selected for this example. These settings are UE dependent, and are provided for reference only.

"CALL:CELL:OPERating:MODE OFF"
! Operating Mode

"CALL:UPLink:PRAChannel:TIMing:OFFSet Normal"
! Uplink Timing Offset

"CALL:CELL:MCCode:WCDMa 440"
! Cell Parameters, MCC

"CALL:CELL:MNCode:WCDMa 79"
! Cell Parameters, MNC

"CALL:CELL:LACode:WCDMa 9"
! Cell Parameters, LAC

"CALL:CELL:POWer:AMPLitude:FDD -60.0"
! Cell Power

"CALL:CHANnel 10563"
! DL Channel

"CALL:UPLink:CHANnel 9613"
! Uplink Channel

"CALL:CELL:SCODe:PRIMary 0"
! Primary Scrambling Code

"CALL:UPLink:PRAChannel:SCODe 2"
! PRACH Scrambling Codeword

"CALL:CELL:CLPControl:UPLink:ALGorithm ALG1"
! UL CL Power Ctrl Algorithm

"CALL:SECurity:AUTHenticate:ALGorithm RIJNdael"
! Authentication Algorithm

"CALL:SECurity:OPERation AUTHINT"
! Security Operations, Authentication and Integrity On

"CALL:MS:POWer:TARGet 5"
! MS Target Power

"CALL:CELL:RLC:REEStablish OFF"
! RLC Reestablish

"CALL:CELL:OPERating:MODE CALL"
! Operating Mode

D. Functional Test

In order to test the functioning of the wireless modem, it must first complete a GPRS attach (see GPRS Attach ).

  1. Turn the wireless modem on and wait for the Attached State field to read "Attached" on the test set's front panel display. Some wireless modems may need to attempt data transfer before attaching to the test set.

    Once a GPRS attach has occurred, packet data service can be started.

  2. Use the laptop computer's "Network and Dial-up Connections" menu to make a dial up connection.

    The wireless modem will request an activation and the PDP Context will become active. This can be observed by looking for "PDP Active" in the Active Cell Status: field.

  3. Open the browser on the PC. Enter the IP address of the test set in the PC browser Address window. The PC browser should display the following screen:

  4. As data is transferred, the Counters window keeps a running count of data in both the uplink and downlink:

  5. You can also perform all transmitter measurements with PDP Active. (BER measurements are not supported with PDP Active).

Related Topics

GPRS Packet Data Service

GPRS Packet Data Service Ladder Diagrams

How Do I Configure the Data Channel?


Ping

Ping

This section is only applicable to the lab application.

Ping Description

Ping is a tool to help check system interconnects. The test set has a Ping feature that allows you to ping either the DUT or an alternate address. It sends an IP datagram (technically an ICMP message: Internet Control Message Protocol) from the test set to the ping target expecting a response from the target. If a response is received it is recorded on the test set's display. This feature is controlled through the front panel or through GPIB control (see CALL:DATA:PING ).

To Ping the DUT From the Test Set

See How Do I Ping a Device From the Test Set?

How to Read the Ping Results

In response to a ping the DUT will return a packet to the test set and the packet transfer information will be displayed on the test set's screen. In the example below ping count was set to 1. Note that it took 2700 ms to complete the ping.

Related Topics

Manual Operation: How Do I Ping a Device From the Test Set?


Data Channel Troubleshooting

Data Channel Troubleshooting

This section is only applicable to the lab application.

  • PS Domain Information must be set to Present before a UE will initiate PS services with the test set.

GPRS Attach

GPRS attach is a UE initiated procedure. There are three errors conditions during GPRS attach that will generate error messages. These error conditions will not stop the GPRS attach procedure:

  • The test set does not receive the RRC Connection Complete message from the UE within 6 seconds from the time of sending the RRC Connection Setup message. This will generate error +201, No Response to RRC Connection Setup.
  • The test set does not receive the Identity Response message from the UE within 6 seconds from the time of sending the Identity Request message. This will generate error +208, No Response to Identity Request.
  • The test set does not receive the RRC Connection Release Complete message from the UE within 6 seconds from the time of sending the RRC Connection Release message. This will generate error +208, No Response to RRC Connection Release.

Ping

  • If your data channel application does not seem to be working, try pinging the device. The test set has a ping feature, and so do most computer operating systems. See Ping for more information.
  • Ping log has an unknown IP address: If you log a Ping that originated from the test set, the Ping Downlink Source Address and the Uplink Destination Address have a fixed value of 0x821DB5CB. This is because the test set uses an internal address to originate IP data from the test set to the mobile station.
  • Ping does not work although the mobile station is attached: The device must be PDP activated. This may require that you initiate a data transfer from the mobile station. Also, Ping and Data Channel are only available in when the connection type is set to Auto .

Frequently Asked Questions

  • Can't find where to set the mobile station address: Switch the Conn Type to Auto first.
  • BER measurements wrong when using the data channel: The BER measurement is not supported during data connections.
  • What is the APN (Access Point Name) that I need to include with the dial string when using dial-up? No APN is needed.

Related Topics

GPRS Packet Data Service

CS (Circuit Switched) Data Service


How Do I Configure the AMR Voice Radio Access Bearer?

How Do I Configure the AMR Voice Radio Access Bearer?

Last updated: December 21, 2004

This section is applicable to the lab application only.

  1. Press the CALL SETUP key.
  2. Press the More key under Call Control two times to move to the 3 of 4 menu.
  3. Select AMR RAB ( F5 ). At this time, the AMR RAB is fixed to a maximum rate of 12.2 kbps.

Related Topics

AMR Voice


How Do I Configure Cell 2?

How Do I Configure Cell 2?

Last updated: December 21, 2004

This section is only applicable to the lab application.

  • Set Cell 2 Power, Cell 2 Primary Scrambling Code, and Cell 2 Time Offset
  • Set Cell 2 Downlink Channel Levels
  • Set Cell 2 Closed Loop Power Control Mode

Set Cell 2 Power, Cell 2 Primary Scrambling Code, and Cell 2 Time Offset

  1. Press the CALL SETUP key.
  2. Select Handoffs ( F5 ) on the Call Control menu, then Soft Handoff Info ( F4 ).
  3. Set Cell 2 Power ( F1 ) to the desired value.
  4. Select SHO / Event Parameters ( F2 ).
    • Set Cell 2 Primary Scrambling Code to the desired value.
    • Set Cell 2 Time Offset to the desired value.

    Select Close Menu ( F6 ).

Set Cell 2 Downlink Channel Levels

  1. Press the CALL SETUP key.
  2. Press the left More key until you reach the Call Control ( 2 of 4 ) menu.
  3. Press Generator Info ( F3 ).
  4. Press the Connected DL Channel Levels ( F4 ) key, and change the power levels for the downlink channels, as needed.
  5. Select Close Menu ( F6 ).

Set Cell 2 Closed Loop Power Control Mode

  1. Press the CALL SETUP key.
  2. Press the right More key until you reach the Call Parms ( 3 of 3 ) menu.
  3. Select UL CL Power Ctrl Parameters ( F8 ).
  4. Set Cell 2 Power Ctrl to the desired setting.
  5. Select Close Menu ( F6 ).

Related Topics

Soft Handoff

How Do I Perform a Soft Handoff?

How Do I Configure and Enable (Start) Event Reporting?

Configuring Cell 1: How Do I Change Generator Information?


How Do I Configure the Data Channel?

How Do I Configure the Data Channel?

Last updated: December 21, 2004

This section is only applicable to the lab application.

  • GPRS Packet Data Service
  • CS (Circuit Switched) Data Service

GPRS Packet Data Service

  1. Press the CALL SETUP key.
  2. Press the More key on the left until you reach the Call Parms ( 3 of 4 ) menu.
  3. Press Data Channels ( F4 ).

  4. Press Packet Data Setup ( F1 ).

  5. Set GPRS Radio Access Bearer to the desired value.
  6. If you would like to simulate a network rejection of an Activate PDP Context Request from a UE, set Activate PDP Context Reject State to On , and set Activate PDP Context Reject SM Cause to the desired value.
  7. Select Close Menu ( F6 ).

CS (Circuit Switched) Data Service

  1. Press the CALL SETUP key.
  2. Press the More key on the left until you reach the Call Parms ( 3 of 4 ) menu.
  3. Press Data Channels ( F4 ).
  4. Press CS Data Setup ( F2 ).

  5. Set the CS data settings as needed.

  6. Select Close Menu ( F6 ).

Related Topics

GPRS Packet Data Service


How Do I Configure and Enable (Start) Event Reporting?

How Do I Configure and Enable (Start) Event Reporting?

Last updated: December 21, 2004

This section is only applicable to the lab application.

  • A. Configure Event Parameters
  • B. Enable Event Reporting
  • C. Change Event Parameters

A. Configure Event Parameters

  1. Go to the Soft Handoff Information Screen

  2. Select SHO / Event Parameters ( F2 ).

  3. Set event parameters as needed.

B. Enable Event Reporting

  1. Go to the Soft Handoff Information Screen
  2. Set Event State ( F4 ) to On . The test set sends a Measurement Control message to the UE with the event parameter configuration specified in step A. Configure Event Parameters .

The UE reports events for cell 1 and cell 2 as they occur, as well as MS reported measurement results for each cell.

C. Change Event Parameters

  1. A. Configure Event Parameters .
  2. Select Send Event Config ( F5 if Event State is On ), to send a new Measurement Control message to the UE, specifying the changes to the event parameters.

NOTE
You can also send a new Measurement Control message to the UE by toggling Event State off and on.

Related Topics

Soft Handoff


How Do I Ping a Device From the Test Set?

How Do I Ping a Device From the Test Set?

Last updated: December 21, 2004

This section is only applicable to the lab application.

How To Ping the DUT From the Test Set

  1. Press the Call Setup key.
  2. Press the left More key until 3 of 3 is displayed.
  3. Select Ping.
  4. Select Ping Setup.
  5. In the Ping Setup menu, select the Device to Ping. If you select DUT, the IP Address entered in the DUT IP Address field will be pinged. If you select Alternate, the IP Address entered in the Alternate Ping Address field will be pinged.
  6. Set the Ping Count, Timeout, and Packet Size.
  7. Select Start Ping .

Related Topics

Ping


How Do I Perform a Soft Handoff?

How Do I Perform a Soft Handoff?

Last updated: December 21, 2004

This section is only applicable to the lab application.

  • Make a Call
  • Go to the Soft Handoff Information Screen
  • Configure Cell 2 and Turn Cell 2 Power On
  • Enable Soft Handoff
  • (Optional) Perform Loopback BER or BLER Testing

Make a Call

See How Do I Set Up a Call and Make a Connection?

Go to the Soft Handoff Information Screen

  1. Press the CALL SETUP key.
  2. Select Handoffs ( F5 ) on the Call Control menu, then Soft Handoff Info ( F4 ).

Configure Cell 2 and Turn Cell 2 Power On

See How Do I Configure Cell 2?

Enable Soft Handoff

  1. Go to the Soft Handoff Information Screen
  2. Set Soft Handoff ( F3 ) to On .

(Optional) Perform Loopback BER or BLER Testing

  1. Configure and initialize the loopback BER (or BLER) measurement (see How Do I Perform a Loopback BER Measurement? and How Do I Perform a Block Error Ratio (BLER) Measurement? ).
  2. Set Soft Handoff ( F3 ) to Off .
  3. Set Cell Power ( F7 ) to -110 dBm/3.84 MHz .
  4. Set Cell2 Power ( F2 ) to -103.5 dBm/3.84 MHz . Note as you increase cell 2 power or decrease cell 1 power, BER increases.
  5. Set Soft Handoff ( F3 ) to On . BER should decrease significantly, as the cell 2 signal is now combined with the cell 1 signal, rather than acting as interference. (If cell 2 level is too high, the messaging to order a soft handoff may not be properly received by the UE and an error will be posted. If this is the case, simply decrease cell 2 power, enable soft handoff, then return cell 2 its previous level)

Related Topics

Soft Handoff

How Do I Configure Cell 2?

How Do I Configure and Enable (Start) Event Reporting?

How Do I Perform a Loopback BER Measurement?

How Do I Perform a Block Error Ratio (BLER) Measurement?


Soft Handoff

Soft Handoff

This section is only applicable to the lab application.

  • Cell 2 Overview
  • Soft Handoff Overview
  • Mobile Station Reported Pilot Information
  • Enabling Soft Handoff
  • Soft Handoff State
  • Loopback BER and BLER Testing in Soft Handoff
  • Event Triggering

Cell 2 Overview

The lab application includes two sectors, cell 1 and cell 2. Cell 1 is a full sector, supporting all call processing functionality available in the test set. Cell 2 is provided to allow the test set to perform a soft handoff. Cell 2 alone can not be used for call processing events, such as establishing a call or handing off to a new frequency. Cell 2 can only be used in conjunction with cell 1 to test the UE's soft handoff capability. The table below summarizes the features of cell 1 and cell 2, and indicates if the features are user-settable.

Cell 1 and Cell 2 Features
Feature |  | Cell 1 | Cell 2
DL Channel |  | User-settable (see Downlink Channel (UARFCN) ) | Equals cell 1 setting
CPICH | Level | User-settable | User-settable (see CALL:CELL2:CPIChannel ).
P-CCPCH/SCH | Level | User-settable | User-settable (see CALL:CELL2:CCPChannel ).
S-CCPCH | Channelization Code | User-settable | No S-CCPCH
 | Level | User-settable | No S-CCPCH
PICH | Channelization Code | User-settable | No PICH
 | Level | User-settable | No PICH
AICH | Channelization Code | User-settable | No AICH
 | Level | User-settable | No AICH
DPCH | Channelization Code | User-settable | Equals cell 1 setting
 | Level | User-settable | User-settable (see CALL:CELL2:DPCHannel ).
Composite OCNS |  | 16 channels (see Orthogonal Channel Noise Simulator (OCNS) ) | 1 channel at OVSF [128,2] (see CALL:CELL2:OCNSource )
Primary Scrambling Code |  | User-settable | User-settable (see CALL:CELL2:SCODe ).
Cell Power |  | User-settable | User-settable. Cell 2 power must be within 10 dB of cell 1 power. Cell 2 is turned off if cell 1 is turned off. (see CALL:CELL2:POWer )
Closed Loop Power Control |  | User-settable: All Up, All Down, Alternating, 10 Up/10 Down, Active, Single Up, Single Down (see Uplink Closed Loop Power Control Parameters and UE Target Power ). | User-settable: All Up, All Down, Alternating, 10 Up/10 Down, Active. When set to "Active," the TPC bits transmitted are the same as those transmitted by cell 1 (see Cell 2 UL CL Power Ctrl Mode and CALL:CELL2:CLPControl ).
Cell 2 Time Offset |  | You can specify a time offset which offsets the cell 2 signal in time relative to the cell 1 signal (see How Do I Configure Cell 2? and CALL:CELL2:TOFFset ). The test set can then order the UE to measure and report the SFN-SFN Observed Time Difference (OTD) .

See How Do I Configure Cell 2? for more information about configuring cell 2 from the front panel. See Downlink Channel Codes and Levels for more information about cell 1 channelization codes and levels.

The test set's total RF output power is a combination of the power of cell 1, cell 2 and AWGN power:
Total RF Power (dBm/3.84 MHz) = [Cell 1 Power + Cell 2 Power + AWGN Power] (dBm/3.84 MHz)
(see Cell Power and AWGN Power for more information about cell power and AWGN power).

Soft Handoff Overview

The soft handoff functionality is accessible through the Soft Handoff Information screen (select Handoffs ( F5 ) on the Call Control menu, then Soft Handoff Info ( F4 ).)

Generated Pilot Information

The Generated Pilot Information window reports:

  • Total RF Power
  • Cell 1 CPICH Power (Cell Power + CPICH Level (or Cell 1 Connected CPICH Level))
  • Cell 2 CPICH Power (Cell 2 Power + Cell 2 CPICH Level)
  • Delta Power (the difference between the CPICH and Total RF Power)
  • Primary Scrambling Code

See Cell Power and AWGN Power , Downlink Channel Codes and Levels and CALL:STATus .

Mobile Station Reported Pilot Information

When a connection is established between the test set and UE, you may request measurement results from the UE, including CPICH RSCP , CPICH Ec/No , Pathloss , OTD , OTD Type and DTCH BLER (see Cell 1/Cell 2 UE Reported Measurements ). When you request MS reported measurement results, results for CPICH RSCP, CPICH Ec/No and Pathloss are returned for both cell 1 and cell 2 (if cell 2 is set to a non-zero power level). If you have enabled soft handoff (see Enabling Soft Handoff ), the DTCH BLER Report result includes both cell 1 and cell 2 (there is only one DTCH in soft handoff because soft combining of the two radio links in the UE occurs before the point where the DTCH is extracted and BLER is calculated).

Enabling Soft Handoff

After establishing a call between the test set's cell 1 and the UE, and configuring cell 2 (power, primary scrambling code, time offset, etc., see Cell 2 Overview ), you may turn soft handoff on (see How Do I Perform a Soft Handoff? and CALL:SHANdoff:ENABle ). This orders the UE to try to demodulate the signal from cell 2. You can only perform a soft handoff while on a CELL_DCH call (see RB Test Mode RRC State Setting ).

Soft Handoff State

If the soft handoff was successful (the UE responded correctly to the Active Set Update procedure), then a status of On is displayed for Soft Handoff State :

Loopback BER and BLER Testing in Soft Handoff

You can test Loopback BER and BLER while in soft handoff (see How Do I Perform a Soft Handoff? , Loopback Bit Error Ratio Measurement Description and Block Error Ratio Measurement Description ). When soft handoff is not enabled, as you increase cell 2 power, you will see an increase in BER/BLER (because cell 2 acts as an interferer). When you enable soft handoff, the BER/BLER result should improve, as the UE is then able to soft combine the signals from both cells. (If cell 2 level is too high, the messaging to order a soft handoff may not be properly received by the UE and an error will be posted. If this is the case, simply decrease cell 2 power, enable soft handoff, then return cell 2 to its previous level).

Event Triggering

The soft handoff functionality present in the test set also allows you to enable/disable event reporting (by turning Event State on and off), and to configure event parameters (such as Event 1a State , R 1a etc.).

When event reporting is enabled, the UE reports to the test set when an event occurs (if you have enabled that event by turning its state on. For example: if you have set Event 1a State to On , then the UE will report when a 1a event occurs). When you turn Event State on (enable event reporting), the test set sends a Measurement Control message to the UE with the following user-settable event information:

  • 1a (A Primary CPICH enters the Reporting Range): Event 1a State, W, R 1a , H 1a
  • 1b (A Primary CPICH leaves the Reporting Range): Event 1b State, W, R 1b , H 1b
  • 1c (A Non-active Primary CPICH becomes better than an active Primary CPICH): Event 1c State, H 1c
  • 1d (Change of best cell): Event 1d State, H 1d
  • 1e (A Primary CPICH becomes better than an absolute threshold): Event 1e State, T 1e , H 1e
  • 1f (A Primary CPICH becomes worse than an absolute threshold): Event 1f State, T 1f , H 1f

(see How Do I Configure and Enable (Start) Event Reporting? and CALL:SHANdoff )

NOTE
After changing event parameters, you must send a new Measurement Control message to the UE by selecting Send Event Config ( F5 when viewing the SHO/Event Parameters menu with Event State on) or by toggling Event State off and on.

The Measurement Control message sent by the test set orders the UE to use the RSCP measurement result to determine whether an event has occurred. When an event occurs, the UE reports the requested MS reported measurement results - CPICH Ec/No, CPICH RSCP, Pathloss and/or DTCH BLER Report (see Mobile Station Reported Pilot Information ).

Related Topics

How Do I Configure Cell 2?

How Do I Configure and Enable (Start) Event Reporting?

How Do I Perform a Soft Handoff?

CALL:SHANdoff

UE Reported Measurements

Troubleshooting Soft Handoff

Loopback Bit Error Ratio Measurement Description


CALL:CELL2:CCPChannel

CALL:CELL2:CCPChannel

December 21, 2004

Diagram Conventions

CALL:CELL2:CCPChannel:PRIMary[:SLEVel]

Function

Sets/queries the initial power offset of the cell 2 primary common control physical channel. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

See Cell 2 Overview .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -5.35 dB
Requirements

Lab Application Revision: A.01 and above.

Lab Application Revision C.01 and above, changed default value to -5.35 dB.

Programming Example

OUTPUT 714;"CALL:CELL2:CCPCHANNEL:PRIMARY:SLEVEL -15DB" !Enables and sets the initial P-CCPCH power offset to -15 dB.

CALL:CELL2:CCPChannel:PRIMary:LEVel

Function

Sets/queries the cell 2 primary common control physical channel's initial power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this setting.

See Cell 2 Overview .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -5.35 dB
Requirements

Lab Application Revision: A.01 and above.

Lab Application Revision C.01 and above, changed default value to -5.35 dB.

Programming Example

OUTPUT 714;"CALL:CELL2:CCPCHANNEL:PRIMARY:LEVEL -15DB" !Sets the initial P-CCPCH power offset to -15 dB.

CALL:CELL2:CCPChannel:PRIMary:STATe

Function

Sets/queries the cell 2 primary common control physical channel's state.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this setting.

See Cell 2 Overview .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL2:CCPCHANNEL:PRIMARY:STATE ON"


CALL:CELL2:CLPControl

CALL:CELL2:CLPControl

December 21, 2004

Diagram Conventions

CALL:CELL2:CLPControl:UPLink:MODE

Function

Sets/queries the cell 2 uplink power control setting when using the Active Cell operating mode. See Cell 2 Overview .

Setting

Range:

  • ACTive (activates closed loop power control)
  • UDOWn (alternating bits)
  • UP (all up bits)
  • DOWN (all down bits)
  • UDOWn10 (ten up/ten down bits)

Query

Range: Same as setting range.

*RST Setting

ACTive

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:CLPControl:UPLink:MODE ACTive"
!Sets the uplink closed loop power control to active.


CALL:CELL2:CPIChannel

CALL:CELL2:CPIChannel

Diagram Conventions

CALL:CELL2:CPIChannel[:SLEVel]

Function

Sets/queries the cell 2 common pilot channel's initial power offset. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

(See Cell 2 Overview ).

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -3.3 dB
Requirements

Lab Application Revision: A.01 and above.

Lab Application Revision C.01 and above, changed default value to -3.3 dB.

Programming Example

OUTPUT 714;"CALL:CELL2:CPICHANNEL:SLEVEL -10"

CALL:CPIChannel:LEVel

Function

Sets/queries the common pilot channel's initial power offset. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

(See Cell 2 Overview ).

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -3.3 dB
Requirements

Lab Application Revision: A.01 and above.

Lab Application Revision C.01 and above, changed default value to -3.3 dB.

Programming Example

OUTPUT 714;"CALL:CPICHANNEL:LEVEL -5"

CALL:CPIChannel:STATe

Function

Sets/queries the common pilot channel's state.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

(See Cell 2 Overview ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CPICHANNEL:STATE ON"


CALL:CELL2:DPCHannel

CALL:CELL2:DPCHannel

Diagram Conventions

CALL:CELL2:DPCHannel[:SLEVel]

Function

 Sets/queries the cell 2 dedicated physical channel's (DPCH) initial downlink offset, and sets its state to ON. (See Cell 2 Overview ).

Setting

Range: -30.00 dB to 0 dB

Resolution: 0.01
Query Same as setting

*RST Setting

 -10.30 dB

Requirements

Lab Application Revision: A.01 and above.

Lab Application Revision C.01 and above, changed default value to -10.30 dB.

Programming Example

OUTPUT 714;"CALL:CELL2:DPCHANNEL:SLEVEL -12"

CALL:CELL2:DPCHannel:LEVel

Function

 Sets/queries the cell 2 dedicated physical channel's (DPCH) initial downlink offset. (See Cell 2 Overview ).

Setting

Range: -30.00 dB to 0 dB

Resolution: 0.01
Query Same as setting

*RST Setting

 -10.30 dB

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:DPCHANNEL:LEVEL -12"

CALL:DPCHannel:STATe

Function

Sets/queries the dedicated physical control channel's state.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

(See Cell 2 Overview ).

Setting

Range: 1|ON | 0|OFF

Query

Range: 1| 0

*RST Setting

 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:STAT 1"


CALL:CELL2:OCNSource

CALL:CELL2:OCNSource

Diagram Conventions

CALL:CELL2:OCNSource:LEVel?

Function

Queries the cell 2 calculated level of the UTRA FDD composite orthogonal channel noise simulator (OCNS).

The OCNS level is a calculated value used to balance the relative power levels of the following channels to sum to 100%:

  • OCNS
  • Common Pilot Channel (CPICH)
  • Primary Common Control Physical Channel (P-CCPCH)
  • Synchronization Channel (SCH)
  • Dedicated Physical Channel (DPCH)

If the contribution of OCNS is calculated to be -30 dB or less, the OCNS state is turned off.

(See Cell 2 Overview ).

Query

Range: 0 to -29 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:OCNSOURCE:LEVEL?" !Queries the cell 2 calculated OCNS level.

CALL:CELL2:OCNSource:STATe?

Function

Queries the cell 2 on/off state of the calculated UTRA FDD composite orthogonal channel noise simulator (OCNS).

The OCNS level is a calculated value used to balance the relative power levels of the following channels to sum to 100%:

  • OCNS
  • Common Pilot Channel (CPICH)
  • Primary Common Control Physical Channel (P-CCPCH)
  • Synchronization Channel (SCH)
  • Dedicated Physical Channel (DPCH)

If the contribution of OCNS is calculated to be -30 dB or less, the OCNS state is turned off.

(See Cell 2 Overview ).

Setting

Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:OCNSOURCE:STATE?"


CALL:CELL2:POWer

CALL:CELL2:POWer

December 21, 2004

Diagram Conventions

CALL:CELL2:POWer[:SAMPLitude]

Function

Sets/queries the cell 2 power level (including compensation for amplitude offset), and sets its state to ON. (See Cell 2 Overview ).

Setting

Range:

  • -165 dBm/3.84MHz to +37dBm/3.84MHz, 9.91 E+37

    (-115 dBm/3.84MHz to -13 dBm/3.84MHz actual hardware range with amplitude offset = 0)

    The actual power range is defined by adding the value of the associated Amplitude Offset to the range in the table. For example, if amplitude offset is -3.5 dB, then the power range will be -118.5 dBm/3.84 MHz to -16.5 dBm/3.84MHz.

Resolution: 0.01 dBm/3.84 MHz

Query

Range: Same as setting range.

Resolution: Same as setting range.

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:POWER:SAMPLITUDE -30"
! Sets the cell 2 power level -30 dBm and turns it on.

CALL:CELL2:POWer:AMPLitude[:SELected]

Function

Sets/queries the cell 2 power level (including compensation for amplitude offset).

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type. The current system type can be changed using the CALL[:CELL]:SYSTem[:TYPE]? command.

(See Cell 2 Overview ).

Setting

Range:

  • -165 dBm/3.84MHz to +37dBm/3.84MHz, 9.91 E+37

    (-115 dBm/3.84MHz to -13 dBm/3.84MHz actual hardware range with amplitude offset = 0)

    The actual power range is defined by adding the value of the associated Amplitude Offset to the range in the table. For example, if amplitude offset is -3.5 dB, then the power range will be -118.5 dBm/3.84 MHz to -16.5 dBm/3.84MHz.

Resolution: 0.01 dBm/3.84 MHz

Query

Range: Same as setting range.

Resolution: Same as setting range.

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:POWER:AMPLITUDE -30"
!Sets the cell 2 power level -30 dBm.

CALL:CELL2:POWer:STATe[:SELected]

Function

Sets/queries the cell 2 power state.

The optional [:SELected] keyword in this command specifies that the cell 2 power state being set or queried applies to the current system type. The current system type can be changed using the CALL[:CELL]:SYSTem[:TYPE]? command.

(See Cell 2 Overview ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

OFF

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:POWER:STATE ON"
! Turns on cell 2 power.


CALL:CELL2:SCODe

CALL:CELL2:SCODe

December 21, 2004

Diagram Conventions

CALL:CELL2:SCODe[:PRIMary]

Function

Sets/queries the cell 2 primary scrambling code.

The actual code number for the primary scrambling code is 16 times the value of this setting. See 3GPP TS 25.213, "Spreading and Modulation (FDD)" for a complete description of the relationship between this index and the actual spreading code number.

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode will result in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this setting.

(See Cell 2 Overview ).

Setting

Range: 0 to 511

Query

Range: 0 to 511

*RST Setting

127

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:SCODe 10"
! Sets the cell 2 primary scrambling code to 10.


CALL:CELL2:TOFFset

CALL:CELL2:TOFFset

December 21, 2004

Diagram Conventions

CALL:CELL2:TOFFset

Function

Sets/queries the cell 2 time offset. (See Cell 2 Overview ).

Setting

Range: -16 to +16 chips

Query

Range: -16 to +16 chips

*RST Setting

0 chips

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:TOFFset 10" !Sets the cell 2 time offset to 10.


CALL:COUNt

CALL:COUNt

Last updated:December 21, 2004

Diagram Conventions

CALL:COUNt:MS:IP[:ALL]?

Function

Queries the number of IP (Internet Protocol) packets and bytes transferred between the test set and the wireless device on both the uplink and downlink. Results are returned in the following order:

1. Downlink packets
2. Downlink bytes
3. Uplink packets
4. Uplink bytes

Power up, full preset, or the clear counters command will clear the counters.

When IP counters reach their maximum value, they remain at that value until cleared.

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP:ALL?" !Queries the packet and byte count on the downlink and uplink.

CALL:COUNt:MS:IP:RX?

Function

Queries the number of IP (Internet Protocol) packets and bytes transferred between the wireless device and the test set on the uplink channel. Results are returned in the following order:

1. Packets
2. Bytes

Power up, full preset, or the clear counters command will clear the counters.

When IP counters reach their maximum value, they remain at that value until cleared.

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP:RX?" !Queries the packet and byte count on the downlink.

CALL:COUNt:MS:IP:TX?

Function

Queries the number of IP (Internet Protocol) packets and bytes transferred between the wireless device and the test set on the downlink channel. Results are returned in the following order:

1. Packets
2. Bytes

Power up, full preset, or the clear counters command will clear the counters.

When IP counters reach their maximum value, they remain at that value until cleared.

Query

Range: 0 to 9,999,999,999, 9.91 E+37

Resolution: 1

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP:TX?" !Queries the packet and byte count on the downlink.

CALL:COUNt:CLEar:MS:IP

Function

 Clears the data counters.

Programming Example

OUTPUT 714;"CALL:COUNt:CLEar:MS:IP" !Clears the IP counters.


CALL:DATA:PING

CALL:DATA:PING

Diagram Conventions

CALL:DATA:PING[:ALL]?

Function

This command returns the following results: packets transmitted, packets received, percent packets lost, minimum round trip time (in seconds), average round trip time (in seconds), maximum round trip time (in seconds).

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:ALL?"

ENTER 714;Pxmit,Prcvd,Plost,Min_time,Avg_time,Max_time

CALL:DATA:PING:ICOunt?

Function

This command queries the value that is available when the query is received.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:ICOUNT?"

ENTER 714;variable_name

CALL:DATA:PING:PACKets:RX?

Function

This command queries the number of packets received from the device being tested or from the alternate device if CALL:DATA:PING:SETup:DEVice is set to ALTernate.

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:PACKETS:RX?"

ENTER 714;variable_name

!Queries the number of packets received from the device being tested.

CALL:DATA:PING:PACKets:TX?

Function

This queries the number of packets transmitted from the test set.

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:PACKETS:TX?"

ENTER 714;variable_name

!Queries the number of packets transmitted from the test set.

CALL:DATA:PING:PLOSs?

Function

This command queries the percentage of packets lost during the ping session.

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:PLOSS?" !Queries the percentage of lost packets.

ENTER 714;variable_name

CALL:DATA:PING:SETup:ALTernate:IP:ADDRess

Function

This sets/queries the alternate internet protocol (IP) address. This address will be used as the address to ping instead of the device under test if the CALL:DATA:PING:SETup:DEVice command is set to ALT.

Setting

Range: IP v4 address in dotted decimal format.

Query

Range: IP v4 address in dotted decimal format.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:ALTERNATE:IP:ADDRESS `192.168.16.57'"

CALL:DATA:PING:SETup:COUNt

Function

This command set/queries the number of ping IP messages sent for each uninterrupted invocation of the CALL:DATA:PING:STARt command.

Setting

Range: 1 to 1000

Query

Range: 1 to 1000
Requirements Lab Application Revision: A.01 and above

*RST Setting

 10

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:COUNT 20"

CALL:DATA:PING:SETup:DEVice

Function

This command sets/queries which device address is used in the ping IP packets, the address of the device under test, or the address of an alternate device.

Setting

Range: DUT|ALTernate

Query

Range: DUT|ALT
Requirements Lab Application Revision: A.01 and above

*RST Setting

 DUT

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:DEVice ALT"

CALL:DATA:PING:SETup:TIMeout

Function

This command sets or queries how long the test set will wait before ending a ping session.

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.

Setting

Range: 1 to 100 seconds

Query

Range: 1 to 100 seconds
Requirements Lab Application Revision: A.01 and above

*RST Setting

 5 seconds

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:TIMEOUT 10"

CALL:DATA:PING:STARt

Function

This command starts a ping session.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:START"

CALL:DATA:PING:STOP

Function

This command immediately stops a ping session. The ping results will not include counts for any ping message that has not yet received a response.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:STOP"

CALL:DATA:PING:TIME[:AVERage]?

Function

This command queries the average round trip time (in seconds) for a series of pings.

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:TIME:AVERAGE?"

ENTER 714;variable_name

CALL:DATA:PING:TIME:MAXimum?

Function

This command queries the maximum round trip time (in seconds) for a series of pings.

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:TIME:MAXIMUM?"

ENTER 714;variable_name

CALL:DATA:PING:TIME:MINimum?

Function

This command queries the minimum round trip time (in seconds).

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:TIME:MINIMUM?"

ENTER 714;variable_name


CALL:MS:IP:ADDRess

CALL:MS:IP:ADDRess

Diagram Conventions

CALL:MS:IP:ADDRess

Function

Sets/queries the DUT (Device Under Test) IP address.

This command is used to set up a wireless device's IP address.

Setting

Range: 15 characters formatted as follows: A.B.C.D. The range of values for A= 0 to 126 and 128 to 223. The range of values for B,C,D = 0 to 255 (no embedded spaces)

Query

Range: 15 characters formatted as follows: A.B.C.D. The range of values for A= 0 to 166 and 168 to 223. The range of values for B,C,D = 0 to 255 (no embedded spaces)

*RST Setting

 Non-volatile

Programming Example

OUTPUT 714;"CALL:MS:IP:ADDRess `130.29.179.219'"
!Sets the DUT IP Address to 130.29.179.219.


CALL:PLOGging

CALL:PLOGging

Diagram Conventions

CALL:PLOGging:STARt

Function

This command will cause the test set to transition to the Active logging state. Once in the Active Logging state the test set can begin forwarding messages to the protocol logging software.

The protocol logging software must be in real-time mode (not post-capture mode) and a real-time logging session must be connected before transition to the Active logging state is possible.

A real-time logging session is connected by entering the IP Address of the test set in the Tools, Configuration window found in the protocol logging software. When a real-time logging session is connected, the test set's front panel logging annunciator will display Logging:Idle (see the Idle description in CALL:PLOGging<:STATus|:STATe>? .)

After the transition from the Idle to Active logging state has occurred, the test set's front paned logging annunciator will appear as follows:

Logging:Active

Note

The test set can also be transitioned to the Active logging state by clicking on the REC (record) button located in the protocol logging software

Note

Requirements Lab Application Revision: A.01.20 and above

Programming Example

 OUTPUT 714;"CALL:PLOGGING:START" !Starts protocol logging.

CALL:PLOGging:STOP

Function

This command will cause the test set to transition to the Idle logging state.

The test set must be in the Active state before transition to the Idle logging state is possible.

After the transition from the Active to the Idle logging state, the test set's front panel logging annunciator will appear as follows

Logging:Idle

Note

The test set can also be transitioned to the Idle logging state by clicking on the STOP button located in the protocol logging software

Note

Requirements Lab Application Revision: A.01.20 and above

Programming Example

 OUTPUT 714;"CALL:PLOGGING:STOP"!Stops protocol logging.

CALL:PLOGging<:STATus|:STATe>?

Function

This command queries the status of the test set's protocol logging data source. The logging status can be viewed on the test set front panel's logging annunciator.

Possible query results are:DISC

  • (Disconnected) - There is no real-time protocol logging session established between the test set and the protocol logging software.
  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.
  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.
  • STRTG (Starting) - This is a transitional state while the protocol logging software attempts to start logging test set protocol messages.
  • STPG (Stopping) - This is a transitional state while the protocol logging software attempts to stop logging test set protocol messages.

Requirements Lab Application Revision: A.01.20 and above

Query

 Range: DISC|IDLE|ACT|STRTG|STPG

Programming Example

 OUTPUT 714;"CALL:PLOGGING:STATe?"!Queries the protocol logging state.

CALL:PLOGging:CONNected?

Function

This query returns an integer value of 1 if the status of the test set's protocol logging data source is either:

  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.
  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.

See CALL:PLOGging<:STATus|:STATe>? .

If the state of the test set's protocol logging data source is not one of the above, this query will "hang" until a transition to one of these states occurs, or a bus timeout or device clear terminates the query attempt.
Requirements Lab Application Revision: A.01.20 and above

Query

 Range: 1

Programming Example

 OUTPUT 714;"CALL:PLOGGING:CONN?"!Queries the connected state.

CALL:PLOGging:ACTive?

Function

This query returns an integer value of 1 if the status of the test set's protocol logging data source is:

  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.

See CALL:PLOGging<:STATus|:STATe>? .

If the state of the test set's protocol logging data source is not Active, this query will "hang" until a transition to the Active state occurs, or a bus timeout or device clear terminates the query attempt.
Requirements Lab Application Revision: A.01.20 and above

Query

 Range: 1

Programming Example

 OUTPUT 714;"CALL:PLOGGING:ACT?"!Queries the Active state.

CALL:PLOGging:DONE?

Function

This query returns an integer value of 1 if the status of the test set's protocol logging data source is either:

  • DISC (Disconnected) - There is no real-time protocol logging session established between the test set and the protocol logging software.
  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.

See CALL:PLOGging<:STATus|:STATe>? .

If the state of the test set's protocol logging data source is not one of the above, this query will "hang" until a transition to one of these states occurs, or a bus timeout or device clear terminates the query attempt.
Requirements Lab Application Revision: A.01.20 and above

Query

 Range: 1

Programming Example

 OUTPUT 714;"CALL:PLOGGING:DONE?"!Queries the done (logging) state.


CALL:RACode

CALL:RACode

Diagram Conventions

CALL[:CELL]:RACode<[:SELected]|:WCDMa>

Function

Sets/queries the Routing Area Code (RAC) .

This setting can only be changed when PS Domain Information is set to Present and while in Idle mode.

Setting

Range: 0 to 255

Query

 Same as setting.

*RST Setting

 1
Requirements Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:RACODE 2"
! Sets the routing area code to 2.


CALL:SERVice

CALL:SERVice

Diagram Conventions

CALL:SERVice:AMR:RAB

Function

This command sets/queries the AMR service radio access bearer. AMR Voice .

Currently, the only choice for AMR RAB is 12.2k.

Setting

Range: AMR12K

Query

Range: AMR12K
*RST Setting | AMR12K
Requirements | Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:SERVice:AMR:RAB AMR12K"
! Sets the AMR voice radio access bearer to 12.2k.

CALL:SERVice:CSData:MODE:ASYNchronous:OUTput

Function

Sets/queries Async CS Data Source .

Setting

Range: IP|SERIAL

Query

 Same as setting.
*RST Setting | IP
Requirements | Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:SERVice:CSData:MODE:ASYNchronous:OUTput SERIAL"

CALL:SERVice:GPRS:RAB

Function

This command configures the UTRA FDD GPRS Service Radio Access Bearer. See GPRS Packet Data Service .

Setting

Range:

  • GPRSRAB1: 64K PS UL/DL DPCH
  • GPRSRAB2: 64K RMC UL/384K RMC DL DPCH
  • GPRSRAB3: 64K PS UL/384K PS DL DPCH

Query

 Same as setting
*RST Setting GPRSRAB1
Requirements

Lab Application Revision: A.01 and above.

Lab Application Revision A.02 added GPRSRAB2.

Lab Application Revision B.01 added GPRSRAB3.

Programming Example

OUTPUT 714;"CALL:SERVice:GPRS:RAB GPRSRAB2"
! Sets the GPRS Radio Access Bearer to 64k RMC UL/384k RMC DL on DPCH.

CALL:SERVice:GPRS:REJect[:STATe]

Function

This command sets/queries the Activate PDP Context Reject State (see Activate PDP Context Reject ). The SM Cause is determined by CALL:SERVice:GPRS:REJect:CAUSe .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting

0 (Off)
Requirements

Lab Application Revision: A.01 and above

Lab Application Revision C.01 and above, added the ability to set this to ON.

Programming Example

OUTPUT 714;"CALL:SERVice:GPRS:REJect ON"
! Sets Activate PDP Context Reject State to On.

CALL:SERVice:GPRS:REJect:CAUSe

Function

This command sets/queries the Activate PDP Context Reject SM Cause .

This command is only applicable when CALL:SERVice:GPRS:REJect[:STATe] is ON.

Setting

Range: 0 to 255.

Query

 Same as setting
*RST Setting | 111
Requirements | Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SERVice:GPRS:REJect:CAUSe 40"
! Sets Activate PDP Context Reject SM Cause to 40.

CALL:SERVice:RBTest:DTCHannel:CRC[:PRESence]

Function

This command sets/queries the Uplink DTCH RMC CRC Presence .

Setting

Range:

  • PRESent
  • DATa: (Used for Data)

Query

 Range: PRES|DAT
*RST Setting PRES
Requirements

Test Application Revision: A.05 and above

Test Application Revision: A.06 and above, :PRESence is optional

Lab Application Revision: B.01 and above

Lab Application Revision: C.01 and above, :PRESence is optional

Programming Example

OUTPUT 714;"CALL:SERVice:RBTest:DTCHannel:CRC DATa"
! Sets the Uplink DTCH RMC CRC Presence to Used for Data.

CALL:SERVice:RBTest:RAB

Function

This command sets/queries the Channel Type .

Setting

Range:

  • RMC12 (12.2k RMC)
  • RMC64 (64k RMC)
  • RMC144 (144k RMC)
  • RMC384 (384k RMC)
  • RMC33NC (33k No Coding RMC)
  • RMCAM1264 (12.2k UL/64k DL AM RMC) (active cell operating mode only)
  • RMCAM12144 (12.2k UL/144k DL AM RMC) (active cell operating mode only)
  • RMCAM12384 (12.2k UL/384k DL AM RMC) (active cell operating mode only)
  • RMCAM64384 (64k UL/384k DL AM RMC) (active cell operating mode only)

Query

 Same as setting
*RST Setting RMC12
Requirements

Test Application Revision: A.05 and above.

Test Application Revision A.06 added
RMCAM1264|RMCAM12144|RMCAM12384|RMCAM64384.

Lab Application Revision: B.01 and above.

Lab Application Revision C.01 added RMCAM1264|RMCAM12144|RMCAM12384|RMCAM64384.

Programming Example

OUTPUT 714;"CALL:SERVice:RBTest:RAB RMC64"
! Sets channel type to 64k RMC.

CALL:SERVice:RBTest:RRC:STATe

Function

This command sets/queries the RB Test Mode RRC State Setting .

Setting

Range: DCH|FACH

Query

 Same as setting
*RST Setting DCH
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:SERVice:RBTest:RRC:STATe FACH"


CALL:SHANdoff

CALL:SHANdoff

Diagram Conventions

CALL:SHANdoff:ENABle

Function

Turns Soft Handoff On or Off. (See Enabling Soft Handoff )

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

 OFF

Programming Example

OUTPUT 714;"CALL:SHANdoff:ENABle ON"
!Turns Soft Handoff ON.

CALL:SHANdoff:EVENt:ENABle

Function

Turns Event State On or Off (enables/disables event reporting). (See Event Triggering )

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

 OFF

Programming Example

OUTPUT 714;"CALL:SHANdoff:EVENt:ENABle ON"
!Turns Event State ON.

CALL:SHANdoff:EVENt:SEND:CONFig

Function

Sends a Measurement Control message. You must send this command after configuring an event parameter (CALL:SHANdoff:EVent1A - 1F commands) for the new event parameter value to be implemented by the UE. (See Event Triggering ).

Programming Example

OUTPUT 714;"CALL:SHANdoff:EVENt:SEND:CONFig"
!Sends a Measurement Control message.

CALL:SHANdoff:EVent1A:STATe

Function

Controls the UTRA FDD Event 1a ON/OFF State. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

 ON

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1A:STATe ON"
!Turns the Event 1a State ON.

CALL:SHANdoff:EVent1A:REPorting:RANGe

Function

Controls the UTRA FDD Event 1a Reporting Range Constant. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: 0.0 to 14.5 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 0.0 dB
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 14.5 dB

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1A:REPorting:RANGe 3"
!Sets the UTRA FDD Event 1a Reporting Range Constant to 3 dB.

CALL:SHANdoff:EVent1A:HYSTeresis

Function

Controls the UTRA FDD Event 1a Hysteresis. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: 0.0 dB to 7.5 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 1.5 dB
Requirements Lab Application Revision: C.01 and above, new range 0 to 7.5 dB

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1A:HYSTeresis 4"
!Sets the UTRA FDD Event 1a Hysteresis to 4 dB.

CALL:SHANdoff:EVent1A:WVALue

Function

Controls the UTRA FDD Event 1a "W" Value. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: 0.0 to 2.0

Resolution: 0.1

Query

 Same as setting

*RST Setting

 0.0
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 2.0

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1A:WVALue 0.5"
!Sets the UTRA FDD Event 1a "W" Value to 0.5.

CALL:SHANdoff:EVent1B:STATe

Function

Controls the UTRA FDD Event 1b ON/OFF State. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

 ON

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1B:STATe ON"
!Turns the Event 1b State ON.

CALL:SHANdoff:EVent1B:REPorting:RANGe

Function

Controls the UTRA FDD Event 1b Reporting Range Constant. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: 0.0 to 14.5 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 0.0 dB
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 14.5 dB

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1B:REPorting:RANGe 3"
!Sets the UTRA FDD Event 1b Reporting Range Constant to 3 dB.

CALL:SHANdoff:EVent1B:HYSTeresis

Function

Controls the UTRA FDD Event 1b Hysteresis. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: 0.0 dB to 7.5 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 1.5 dB
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 7.5 dB

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1B:HYSTeresis 4"
!Sets the UTRA FDD Event 1b Hysteresis to 4.0 dB.

CALL:SHANdoff:EVent1B:WVALue

Function

Controls the UTRA FDD Event 1b "W" Value. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: 0.0 to 2.0

Resolution: 0.1

Query

 Same as setting
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 2.0

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1B:WVALue 5"
!Sets the UTRA FDD Event 1b "W" Value to 0.5 dB.

CALL:SHANdoff:EVent1C:STATe

Function

Controls the UTRA FDD Event 1c ON/OFF State. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

 ON

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1C:STATe ON"
!Turns the Event 1c State ON.

CALL:SHANdoff:EVent1C:HYSTeresis

Function

Controls the UTRA FDD Event 1c Hysteresis. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: 0.0 dB to 7.5 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 1.5 dB
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 7.5 dB

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1C:HYSTeresis 4"
!Sets the UTRA FDD Event 1c Hysteresis to 4.0 dB.

CALL:SHANdoff:EVent1D:STATe

Function

Controls the UTRA FDD Event 1d ON/OFF State. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

 ON

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1D:STATe ON"
!Turns the Event 1d State ON.

CALL:SHANdoff:EVent1D:HYSTeresis

Function

Controls the UTRA FDD Event 1c Hysteresis. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: 0.0 dB to 7.5 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 1.5 dB
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 7.5 dB

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1D:HYSTeresis 4"
!Sets the UTRA FDD Event 1d Hysteresis to 4.0 dB.

CALL:SHANdoff:EVent1E:STATe

Function

Controls the UTRA FDD Event 1e ON/OFF State. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

 ON

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1E:STATe ON"
!Turns the Event 1e State ON.

CALL:SHANdoff:EVent1E:HYSTeresis

Function

Controls the UTRA FDD Event 1e Hysteresis. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: 0.0 dB to 7.5 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 1.5 dB
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 7.5 dB

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1E:HYSTeresis 4"
!Sets the UTRA FDD Event 1e Hysteresis to 4.0 dB.

CALL:SHANdoff:EVent1E:THREshold

Function

Controls the UTRA FDD Event 1e Threshold. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: -115 to -25 dBm

Resolution: 1

Query

 Same as setting

*RST Setting

 -60 dBm
Requirements Lab Application Revision: C.01 and above, new range -115 to -25 dBm

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1E:THREshold -70"
!Sets the UTRA FDD Event 1e Threshold to -70 dBm.

CALL:SHANdoff:EVent1F:STATe

Function

Controls the UTRA FDD Event 1f ON/OFF State. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

 ON

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1F:STATe ON"
!Turns the Event 1f State ON.

CALL:SHANdoff:EVent1F:HYSTeresis

Function

Controls the UTRA FDD Event 1f Hysteresis. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: 0.0 dB to 7.5 dB

Resolution: 0.5

Query

 Same as setting

*RST Setting

 1.5 dB
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 7.5 dB

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1F:HYSTeresis 4"
!Sets the UTRA FDD Event 1f Hysteresis to 4.0 dB.

CALL:SHANdoff:EVent1F:THREshold

Function

Controls the UTRA FDD Event 1f Threshold. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Triggering ).

Setting

Range: -115 to 165 dBm

Resolution: 1

Query

 Same as setting

*RST Setting

 -80 dBm

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1F:THREshold -70"
!Sets the UTRA FDD Event 1f Threshold to -70 dBm.


Getting Started with Protocol Logging

Getting Started with Protocol Logging

You can use a PC software application, the Wireless Protocol Advisor, to analyze communication between a wireless device and the test set. If you're using the data channel feature of the test set as an IP router to exchange data between the wireless device and a network server, then the WPA can also monitor these communications.

The software connects with the test set through the LAN port, to capture messages and data used to set up and maintain links and transfer data. Messages and data can be filtered to include specific protocol layers and message fields. Refer to:

Agilent E6584A Wireless Protocol Advisor Operation Guide

[http://cp.literature.agilent.com/litweb/pdf/1000-1868.pdf]

TO RETURN TO THE MAIN PROTOCOL LOGGING PAGE, click here: Protocol Logging .


Protocol Logging Requirements

Protocol Logging Requirements

This section is only applicable to the lab application.

The lab application enables the test set to log protocol messages. Protocol messages are forwarded to the Wireless Protocol Advisor (WPA) software, which is required for message display and analysis. This software is included with the lab application and will run on PCs that meet the following system requirements:

Summary of Requirements for the Wireless Protocol Advisor

NOTE
These requirements are subject to change or addition without notice. Always refer to the product web page for the latest information.

  • PC Operating System:
    • Microsoft , Windows , 98
    • Microsoft , Windows , NT 4 SP3/4/5
    • Microsoft , Windows , 2000
  • 300 MHz Pentium or equivalent recommended
  • 128 MB RAM recommended
  • 250 MB available disk space required for installation
  • 100 MB available disk space recommended for storing logged information
  • Video resolution minimum 800 by 600 pixels with at least 256 colors
  • LAN or WAN connectivity required to connect to the test set


Activating Protocol Logging From the Test Set

Activating Protocol Logging From the Test Set

This section is only applicable to the lab application.

Once a connection is established between the PC running the WPA (Wireless Protocol Advisor) and the test set, a logging session can be activated (or deactivated) by selecting the start (or stop) softkey from the test set's front panel or by sending GPIB commands that perform the same functions:

NOTE
The WPA software performs the same start/stop functions when the REC (RECord) button is selected. Refer to the WPA on-line Help for details.

Test Set Control of Protocol Logging

If a PC with the WPA software has not yet connected with the test set, an error message will be generated if an attempt is made to start protocol logging. Exactly one PC/WPA can be connected to a test set at one time.

Front Panel Control of Protocol Logging

  1. Press the CALL SETUP key to go to the Call Setup screen.
  2. Press the More key on the left hand Call Control menu two times to go to menu 3.
  3. Select Protocol Logging ( F1 ).
  4. Select Start Protocol Logging ( F1 ) to begin logging.

Remote Control of Protocol Logging

The GPIB command to control Protocol Logging is CALL:PLOGging .


E6703C W-CDMA Lab Application Revision Information

E6703C W-CDMA Lab Application Revision Information

This document describes features and functionality that are part of the Agilent Technologies E6703C W-CDMA Lab Application releases. This document contains the original features, as well as enhancements that have been added over time.

CAUTION
You may need to upgrade the hardware in your test set before installing the application firmware described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up.
  • The application may not run.
  • Some features in the application may be inaccessible, or may not perform to specifications.

To determine if a hardware upgrade is required for your testing needs, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Select the appropriate link below to view the required release.

  • C.01 Release - January 2005
  • B.01.34 Release (E6703B) - July 2004
  • B.01.29 Release (E6703B) - April 2004
  • B.01.16 Release (E6703B) - January 2004
  • B.01.14 Release (E6703B) - December 2003
  • A.02 Release (E6703A)
  • A.01 Release (E6703A) - Initial Lab Application Release

C.01 Release - January 2005

The E6703C Release C.01 includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.06 (see A.06 Release - January 2005 ). The unique features of the E6703C Lab Application are indicated below.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Video Call (An additional feature license is required to enable this functionality in a licensed test application.)
  • Short Message Service (SMS)
  • Calling Party Number (see Calling Party Number Parameters ).
  • UE-reported SFN-SFN Observed Time Difference (OTD) ).
  • Activate PDP Context Reject SM Cause .

Transmitter Measurements

  • Change Of TFC measurement (see Change of TFC (Transport Format Combination) Measurement Description ).
  • Out-of-Synch Handling of Output Power measurement (see Out-of-Synch Handling of Output Power Measurement Description ).

Other Features

  • Supports signal fading. For details, download the:

    E5515C Fading Solution Application Guide

    (available at http://cp.literature.agilent.com/litweb/pdf/1000-1894.pdf ).

B.01.34 Release (E6703B) - July 2004

The E6703B Release B.01.34 includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.05.33 (see A.05.33 Release - July 2004 ). The unique features of the E6703B Lab Application are indicated below.

Resolved Known Issues

  • Assert if UE attempts to register while RB Test Mode RRC State Setting is CELL_FACH .
  • Cell 1 output power level affected by state of Cell 2 Power setting.

For more information, visit the 8960 Known Issues web site:

http://wireless.agilent.com/rfcomms/issues

B.01.29 Release (E6703B) - April 2004

The E6703B Release B.01.29 includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.05.28 (see A.05.28 Release - April 2004 ). The unique features of the E6703B Lab Application are indicated below.

Summary of GPIB command changes for this release: GPIB Changes for E1963A A.05.28, E6703B B.01.29 - April 2004

Resolved Known Issues

  • No uplink power control on packet data connection.

For more information, visit the 8960 Known Issues web site:

http://wireless.agilent.com/rfcomms/issues

B.01.16 Release (E6703B) - January 2004

The functionality present in the B.01.16 release is identical to that in the B.01.14 release (see B.01.14 Release (E6703B) - December 2003 and GPIB Changes for E1963A A.05, E6703B B.01 - December 2003 ).

B.01.14 Release (E6703B) - December 2003

The E6703B Release B.01.14 includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.05.14 (see A.05.14 Release - December 2003 ). The unique features of the E6703B Lab Application are indicated below.

Summary of GPIB command changes for this release: GPIB Changes for E1963A A.05, E6703B B.01 - December 2003

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Call origination to CELL_FACH state via new RB Test Mode RRC State Setting .
  • Data channel:
    • New 64k PS UL/384k PS DL GPRS DPCH RAB (see GPRS Packet Data Service ).
    • New asynchronous/non-transparent CS data service (see CS (Circuit Switched) Data Service ).
  • Compressed mode operation including GSM and inter frequency neighbor cell measurement reporting (see Compressed Mode ).
  • New Call Setup Screen layout:
    • Call Processing Status area includes new Soft Handoff State , Compressed Mode State , and RRC State .
    • UE reported measurement results available from Soft Handoff Information screen only (no longer available from main Call Setup Screen ). See UE Reported Measurements and How Do I Order and Retrieve UE Reported Measurement Results? .
  • Soft Handoff functionality now accessible via new Handoffs menu.

Transmitter Measurements

  • PRACH Preamble Analysis. See PRACH Preamble Analysis Measurement Description .

Instruments

  • Data Throughput Monitor. See Data Throughput Monitor Description .

A.02 Release (E6703A)

The E6703A Release A.02 includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.04 (see A.04 Release - June 2003 ). The unique features of the E6703A Lab Application are indicated below.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • AMR Voice service RAB configuration. See AMR Voice , CALL:PAGing:SERVice[:TYPE] and CALL:SERVice:AMR:RAB .
  • Supports Data Channel GPRS Radio Access Bearer 64k UL/384k DL DPCH. See CALL:SERVice:GPRS:RAB .
  • Detected PRACH Signature - The test set detects which PRACH signature is used by the UE and returns an integer representing that signature. See Detected PRACH Signature .
  • PRACH Signature Mask - a 16-bit mask to specify which of the 16 PRACH preamble signatures are available to the UE. See PRACH Signature and CALL:UPLink:PRAChannel:SMASk .
  • Attached State reported. See GMM State and CALL:STATus[:GMM]:ATTached:STATe? .

A.01 Release (E6703A) - Initial Lab Application Release

These are the original features of the Agilent E6703A.

The E6703A Release A.01 includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.03 (see A.03 Release - February 2003 ). The unique features of the E6703A Lab Application are indicated below.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Protocol Logging: (see Protocol Logging )

    The E6703A Lab Application enables the test set to capture the exchange of control and data information between the test set and a UE (user equipment). Captured information is forwarded to a software application that runs on a personal computer under the Windows operating system.

    The software application is referred to as the WPA (Wireless Protocol Advisor). It is tailored for the capture, display, and analysis of message exchange protocols between the test set (emulating a base station), and a UE.

  • Data Channel: (see Data Channel )

    The data channel feature allows you to use the test set as a router while you exchange data between the UE and remote servers.

  • Soft Handoff: (see Soft Handoff )

    The E6703A Lab Application includes two sectors which allow you to perform a soft handoff. The lab application also supports event reporting.


Troubleshooting Soft Handoff

Troubleshooting Soft Handoff

This section is only applicable to the lab application.

Possible Setup Issues

  • Some UEs require Cell 2 Primary Scrambling Code = Intra Freq 2nd Cell Scrambling Code

    When ordered to perform a soft handoff with a cell, some UEs require that they have previously measured the cell before handing off to it. When the UE is directed to perform measurements on the neighbor cells specified in SIB 11 (see SIB11 Cell Info List ), it should also report measurement results for any other detected cells not on the neighbor list. However some UEs may require that the cell be in the neighbor list in order to perform measurements on it. Thus, some UES require that cell 2 be in the neighbor list for soft handoff to be successful.

  • Cell 2 Power is on, but no Mobile Station Reported Pilot Level Information is being displayed for Cell 2

    To aid in the UE's detection of cell 2, ensure that cell 2's primary scrambling code is included in the intra frequency neighbor cell list (see Cell 2 Overview and SIB11 Cell Info List ), and that cell 2's power is high enough to be detected (you may need to set it to a value higher than cell 1).

  • You can only perform a soft handoff while on a CELL_DCH call (see RB Test Mode RRC State Setting ).

Related Topics

Soft Handoff