E1963A, E6703A/B/C/D/E/F/G/U W-CDMA/HSPA User's Guide

Revision: April 1, 2012

What's New in the User's Guide?

  • The contents have been updated and now include documentation for the E1963A W-CDMA Test Application revision A.19.12 and E6703H W-CDMA/HSPA Lab Application revision H.01.12. An additional feature option is required to enable HSDPA and HSPA in a licensed test application.

  • Note: If you have an older W-CDMA application, then this guide will contain features that are not available in your application. Refer to the Release Notes to determine what these features are and to download the guide that is specific to your application.

  • Please visit www.agilent.com/find/8960manuals for a complete set of 8960 online user's guides.

Take Advantage of Your W-CDMA/HSPA Mobile Test and Lab Applications

  • Use the Contents and Search tabs to find specific information about your test and lab applications.

  • If you are unfamiliar with these products, or don't know where to find the information you need, click here: Getting Started with the W-CDMA/HSPA Mobile Test and Lab Applications

  • To download a portable version of this online user's guide, go to http://www.home.agilent.com/agilent/editorial.jspx?cc=US&lc=eng&ckey=1000002486:epsg:man&nid=-34317.536881879&id=1000002486:epsg:man.

© Agilent Technologies, Inc. 2012


Legal Information

Acknowledgements

Microsoft ® is a U.S. registered trademark of Microsoft Corporation

Windows ® and MS Windows ® are U.S. registered trademarks of Microsoft Corporation.

Adobe ® Acrobat ® are trademarks of Adobe Systems Incorporated.

Notice

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as "Commercial computer software" as defined in DFAR 252.227-7014 (June 1995), or as a "commercial item" as defined in FAR 2.101(a) or as "Restricted computer software" as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

© Agilent Technologies, Inc. 2001


Call Processing

Call Processing

Last updated: January 8, 2012

This page provides links to descriptions of the numerous settings and operations available in the test set for base station emulation and call processing including: Test Set Operating Modes , Base Station Emulator Configuration , Call Processing Status and Operations , UE Information and W-CDMA/HSDPA/HSUPA/DC-HSDPA Concepts .

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide. If you are new to using the test set, it may be helpful to review the Getting Started with Call Processing page.

For details about to which revisions of the 3GPP specifications the test set is compliant, see 3GPP Compliance .

Test Set Operating Modes

  • Active Cell Operating Mode
    • HSDPA in Active Cell Operating Mode (lab application or feature-licensed test application only)
    • HSPA in Active Cell Operating Mode (lab application or feature-licensed test application only)
  • FDD Test Operating Mode
    • HSDPA in FDD Test Operating Mode (lab application or feature-licensed test application only)
    • HSPA in FDD Test Operating Mode (lab application or feature-licensed test application only)
  • CW Operating Mode
  • Cell Off Operating Mode

Base Station Emulator Configuration

Call Control Call Parms

Paging Parameters

Cell Power

Additional Screens:
Channel (UARFCN) Information

HSPA Information ( lab application or feature-licensed test application only )
HSUPA Information and HSUPA Happy Bit Information
HSDPA Information / DC-HSDPA Information

E-TFCI Recording Information ( lab application or feature-licensed test application only )

Channel Type

Cell Information (lab application only)
Cell Parameters
Reselection Parameters (lab application only)
 Access Restriction Parameters (lab application only)
UE Timer and Constant Parameters (lab application only)
Message Reply Control (lab application only)
SIB19 Information (lab application only)

Paging Service

Generator Information
Downlink Channel Codes
Downlink Channel Levels
Connected DL Channel Levels
AWGN Power
Downlink Power Control Information (lab application only)

HSPA Parameters (lab application or feature-licensed test application only)
HSUPA Parameters
HSUPA PS Data Setup (lab application only)
HSUPA RB Test Mode Setup
Common HSUPA Parameters
Serving Grant
E-TFCI Recording
E-RNTI Parameters
HSDPA Parameters
HSDPA PS Data Setup (lab application only)
HSDPA RB Test Mode Setup
UE Category Parameters
MAC-hs Parameters
HSDPA Uplink Parameters
H-RNTI Parameters

Uplink Parameters

34.121 Preset Call Configurations (lab application or feature-licensed test application only)

Trigger Output Setup

Channel (UARFCN) Parameters :
DL Channel
Uplink Channel
Band Arbitrator
Frequency Band Indicator State

AMR Setup
AMR Voice Ladder Diagrams

Other Downlink Parameters (DL DTCH Data, RLC Reestablish, Call Limit State, Call Drop Timer)

Radio Bearer Test Mode Setup

Signalling Radio Bearer (SRB) Parameters

Security Information
Security Ladder Diagrams

UE Target Power

Digital Bus Information (lab application with rear panel digital bus only)

UL CL Power Ctrl Parameters

SIB11 Info

  • SIB11 Cell Info List
  • SIB11 FACH Measurement Occasion Information (lab application only)

Send Step Up/Down TPC Bit Pattern

Calling Party Number Parameters (lab application only)

Receiver Control

Network Identity and Time Zone (lab application only)

E-UTRAN / WCDMA Interworking (lab application only)

HS-SCCH Order

UE Information

  • UE Information
  • Clear UE Info
  • UE Expected Open Loop Transmit Power
  • UE Reported Measurements
    • UE Reported Measurements Ladder Diagrams

Call Processing Status and Operations

  • Current Service Type
  • Call Processing Status
  • Performing a Location Update (CS Domain Registration)
  • Establishing a Connection with the UE
    • Call Processing Ladder Diagrams : RRC Connection Setup, Location Update, Paging, Radio Bearer Setup, BS Release from RB Test Mode
  • Handovers
    • Physical Channel Reconfiguration
    • Transport Channel Reconfiguration
    • System Handover
      • Handover Ladder Diagrams
    • Soft Handover (lab application only)
      • Soft Handover Ladder Diagrams ( lab application only )
    • Radio Bearer Reconfiguration ( lab application or feature-licensed test application only )
    • External 8960 Handover ( lab application or feature-licensed test application only )
    • External PS Handover (lab application only)
  • Two-Cell Test System ( lab application or feature-licensed test application only )
    • Two-Cell Test System Ladder Diagrams
  • Video Call ( lab application or feature-licensed test application only )
    • Video Call Ladder Diagrams ( lab application or feature-licensed test application only )
  • Digital Audio Interface (DAI) Description (lab application only)
  • Real-Time Vocoder (lab application only)
  • UMA/GAN Test System (lab application only)
    • UMA/GAN Procedures Ladder Diagrams (lab application only)
  • Simultaneous Services (lab application only)
    • Simultaneous Services Ladder Diagrams ( lab application only )
  • Compressed Mode (lab application only)
    • Compressed Mode Ladder Diagrams (lab application only)
  • Short Message Service (SMS) (lab application only)
  • Broadcast Channel (BCCH) Update Procedure (SIB Contents)
  • FM Broadcast
  • Single Channel GPS Source ( lab application or feature-licensed test application only )
  • Equivalent PLMN List (lab application only)

W-CDMA/HSDPA/HSUPA/DC-HSDPA Concepts

  • W-CDMA Concepts
  • Downlink and Uplink Channels Overview
  • Base Station Originated Call Setup Flowchart
  • HSDPA Concepts
  • HSUPA Concepts
  • Dual Cell HSDPA Concepts


Measurements

Measurements

Last updated: October 25, 2010

The test set includes many measurements and instruments for testing your wireless device. This page provides links to measurement information including: 3GPP TS 34.121 Tests Supported by the test set, Measurement Descriptions (how the measurement is performed by the test set, setup parameters, and the measurement results available), Measurement Calibration and Amplitude Offset .

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

3GPP TS 34.121 Tests Supported

  • What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?

Measurement Descriptions

  • Adjacent Channel Leakage Ratio (ACLR) Measurement Description
  • Audio Analyzer Measurement Description
    • Audio Analyzer Block Diagram
    • Audio Frequency Measurement Description
    • Audio Level Measurement Description
    • Distortion Measurement Description
    • SINAD Measurement Description
  • Block Error Ratio (BLER) Measurement Description
  • Change of TFC (Transport Format Combination) Measurement Description ( lab application only )
  • Channel Power Measurement Description
  • Code Domain Measurement Description
  • Data Throughput Monitor Description ( lab application only )
  • Dynamic Power Analysis Measurement Description
  • Extended Range Dynamic Power Measurement Description
  • Fast Device Tune Measurement Description ( lab application or feature-licensed test application only )
  • Frequency Stability Measurement Description
  • HSDPA Block Error Ratio Measurement Description ( lab application or feature-licensed test application only )
  • HSDPA Reporting of Channel Quality Indicator Measurement Description ( lab application only )
  • Inner Loop Power Measurement Description
  • IQ Tuning Measurement Description
  • Loopback Bit Error Ratio (BER) Measurement Description
  • Occupied Bandwidth (OBW) Measurement Description
  • Out-of-Synch Handling of Output Power Measurement Description ( lab application only )
  • Perceptual Evaluation of Speech Quality (PESQ) Measurement Description ( Only applicable to the feature-licensed lab application or test application )
  • Phase Discontinuity Measurement Description
  • PRACH Preamble Analysis Measurement Description ( lab application only )
  • PRACH Transmit On/Off Power Measurement Description
  • QPSK EVM Measurement Description
  • Spectrum Emission Mask Measurement Description
  • Spectrum Monitor Description
  • Swept Audio Measurement Description
  • Thermal Power Measurement Description
  • TX Dynamic Power Measurement Description
  • Waveform Quality Measurement Description

Measurement Calibration

  • Calibrating the Test Set
  • Verifying the Test Set

Amplitude Offset

  • Amplitude Offset


Manual Operation

Last updated: January 16, 2009

This page provides links to information on using the test set from the front panel including: Call Processing Operations (such as making a call, handovers), Call Processing Configuration (configuring the test set's base station emulator), Making Measurements (how to use the measurements in general, and also how to perform 3GPP TS 34.121 tests, see Performing Individual Measurements and 3GPP TS 34.121 Tests ), Data Channel , Test Set Configuration (such as amplitude offsets, GPIB and LAN ports), General Manual Operation (such as Help Mode, which provides context-sensitive GPIB command syntax assistance, and Save and Recall Registers, which provide a way to return to frequently used setups).

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

Call Processing Operations

  • How Do I Set Up a Call and Make a Connection?
  • How Do I End a Connection?
  • How Do I Perform a Handover?
  • Soft Handover ( lab application only ):
    • How Do I Configure Cell 2? ( lab application only )
    • How Do I Perform a Soft Handover? ( lab application only )
    • How Do I Configure and Enable (Start) Event Reporting? ( lab application only )
  • How Do I Set Up the Two-Cell Test System and Perform Cell Transitions? ( lab application only )
  • How Do I Order and Retrieve UE Reported Measurement Results?
  • How Do I Enable Compressed Mode and Obtain UE Measurement Results? ( lab application only )
  • How to use the Digital Audio Interface Features (lab application only)
  • How Do I Use the Real-Time Vocoder? (lab application only)
  • How Do I Make a Video Call? ( lab application only )
  • How to use the UMA/GAN Features (lab application only)
  • How Do I Establish a Simultaneous Services Connection? ( lab application only )
  • Short Message Service ( lab application only ):
    • How to use the Short Message Service Features
    • Enabling the HTTP Interface

Call Processing Configuration

  • How Do I Change Cell Info?
    • How Do I Change Cell Parameters?
  • How Do I Change Paging Parameters?
  • How Do I Change Call Parameters?
  • How Do I Change HSUPA Parameters? ( lab application or feature-licensed test application only )
  • How Do I Change HSDPA Parameters? ( lab application or feature-licensed test application only )
  • How Do I Configure the Radio Bearer Test Mode?
  • How Do I Configure the AMR Radio Access Bearer? ( lab application only )
  • How Do I Change Generator Information?
  • How Do I Change Uplink Parameters?
  • How Do I Change UE TX Power Levels?
  • How Do I Change Security Info Parameters?
  • How Do I Change the SIB11 Cell Info List?
  • How Do I Perform Calling Party Number Verification? ( lab application only )
  • How Do I Use the 34.121 Preset Call Configurations? ( lab application or feature-licensed test application only )

Making Measurements

  • Performing Individual Measurements and 3GPP TS 34.121 Tests [image] click here for step-by-step instructions for performing 3GPP TS 34.121 tests!
  • How Do I Make Measurements on a UE?
  • How Do I Change the Measurement Setup?
  • How Do I Turn Off a Measurement?

Data Channel

  • How Do I Configure the Data Channel? ( lab application only )
  • Establishing a Packet Data Connection ( lab application only )
  • How Do I Ping a Device From the Test Set? ( lab application only )

Test Set Configuration

  • How Do I Configure the Test Set for My Test System? (GPIB address, amplitude offsets, etc.)
  • How Do I Configure the AUDIO OUT Port?
  • How Do I Configure Test Signals in CW Operating Mode?
  • How Do I Make an External Device Connection? ( lab application only )
  • How Do I Make a FM Broadcast test?

General Manual Operation

  • How Do I Change Receiver Control Parameters?
  • Help Mode
  • Front Panel Connectors
  • Rear Panel Connectors
  • Remote/Local Mode
  • Printing Screens
  • Save and Recall Registers
  • Instrument Status Area
  • Preset Descriptions


Programming

Last updated: January 16, 2009

The test set is programmable through the GPIB (General Purpose Interface Bus) located on the rear panel. This page provides links to documentation to help you program the test set including: Programming Guide and Comprehensive Example , Programming Examples for Individual Measurements and General Programming (including test system synchronization).

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

Programming Guide and Comprehensive Example

  • Programming: Getting Started Guide for W-CDMA Mobile Test : This guide provides a general approach to setting up a connection and obtaining measurement results programmatically. It gives an overview of how to configure the test set's base station emulator, perform key call processing operations, and perform measurements. The guide is built around a complete control program for testing a wireless device in a manufacturing environment. To download this complete control program, click here:
  • Control Program Example

Programming Examples for Individual Measurements

  • Programming an Audio Frequency Measurement
  • Programming an Audio Level Measurement
  • Programming a Distortion Measurement
  • Programming a SINAD Measurement
  • Programming an Adjacent Channel Leakage Ratio Measurement
  • Programming a Block Error Ratio Measurement
  • Programming a Change of TFC (Transport Format Combination) Measurement ( lab application only )
  • Programming a Channel Power Measurement
  • Programming a Code Domain Measurement
  • Programming a Digital Audio Interface (DAI) Test
  • Programming the Dynamic Power Analysis Measurement
  • Programming an Extended Range Dynamic Power Measurement
  • Programming a Fast Device Tune Measurement ( lab application or feature-licensed test application only )
  • Programming a Frequency Stability Measurement
  • Programming an HSDPA Block Error Ratio Measurement ( lab application or feature-licensed test application only )
  • Programming an HSDPA Reporting of Channel Quality Indicator Measurement (lab application only)
  • Programming an Inner Loop Power Measurement
  • Programming an IQ Tuning Measurement
  • Programming a Loopback Bit Error Ratio Measurement
  • Programming an Occupied Bandwidth Measurement
  • Programming the Phase Discontinuity Measurement
  • Programming the PRACH Preamble Analysis Measurement ( lab application only )
  • Programming a PRACH Transmit On/Off Power Measurement
  • Programming a Spectrum Emission Mask Measurement
  • Programming the Spectrum Monitor
  • Programming a Swept Audio Measurement
  • Programming a Thermal Power Measurement
  • Programming a TX Dynamic Power Measurement
  • Programming a Waveform Quality Measurement

General Programming

  • Preset Descriptions
  • Receiver Control
  • Status Subsystem Overview
  • Obtaining Measurement Results
  • Test System Synchronization
  • User Interface (UI) Log
  • Using GPIB Command Debug Mode


GPIB Commands

Last updated: January 16, 2009

This page provides links to all of the test set's GPIB subsystems. Select a subsystem link below for a description of the subsystem and links to all of the GPIB commands within that subsystem.

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

GPIB Command Conventions

  • GPIB Command Conventions to understand how GPIB commands are represented.

Call Processing

  • CALL Subsystem to control the mobile and set up and control the cell.

Measurement Control

  • ABORt Subsystem to stop a measurement.
  • CALCulate Subsystem to perform data processing on measurement results.
  • FETCh? Subsystem or READ? Subsystem to get measurement results.
  • INITiate Subsystem or READ? Subsystem to start a measurement.
  • SETup Subsystem to configure a measurement.
  • STATus Subsystem Description to communicate test set status.

IEEE 488.2 Common Commands

  • IEEE 488.2 Common Commands

Test Set Configuration

  • AFGenerator Subsystem
  • RFANalyzer Subsystem (not controlled as an instrument)
  • RFGenerator Subsystem (not controlled as an instrument)
  • CALibration Subsystem
  • DISPlay Subsystem
  • SYSTem Subsystem
  • Help Mode


Protocol Logging

Protocol Logging

Last updated: January 16, 2009

This section is only applicable to the lab application.

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

With a lab application, the test set can capture the protocol messages exchanged between the test set and a wireless device. The protocol messages are forwarded via the test set's LAN port to the Wireless Protocol Advisor (WPA) software (which is included with your lab application), so that they can be displayed and analyzed. If you're using the data channel feature of the test set as an IP router to exchange data between the wireless device and a network server, then the WPA can also monitor these communications.

The Wireless Protocol Advisor software runs on a personal computer under the Windows operating system. It is tailored for the capture, display, and analysis of message exchange protocols between the test set (emulating a base station), and a wireless device. The software connects with the test set through the LAN port, to capture messages and data used to set up and maintain links and transfer data. Messages and data can be filtered to include specific protocol layers and message fields.

IMPORTANT
Most of the information necessary to establish a connection and to display, filter, store, print, and analyze the message exchange between the test set and a UE is accessible through the Help feature available on-line when the WPA application is running.

This on-line help is also available for download at:

http://www.agilent.com/find/e6584a/

To help you get started using the WPA, the Agilent E6584A Wireless Protocol Advisor Operating Guide is available at:

http://cp.literature.agilent.com/litweb/pdf/1000-1868.pdf

Additional information, including PC operating system requirements and additional protocol logging reference information is listed below.

PC Operating System Requirements

Logging protocol messages requires an external PC with the following system requirements:

  • Protocol Logging Requirements

Starting and Stopping Protocol Logging

There are several ways to control the logging of signaling messages.

The primary method for starting and stopping is through features found in the WPA software.

The following information describes features available through the test set's remote and manual user interface for performing these functions:

  • Activating Protocol Logging From the Test Set


Data Channel

Data Channel

Last updated: January 7, 2012

This section is only applicable to the lab application.

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

The data channel feature allows you to use the test set as an IP router, exchanging data between a wireless device and remote servers.

Data Channel Capabilities

  • The test set supports two data channel services:
    • Packet Switched Data
      • HSDPA Packet Switched Data
      • HSPA Packet Switched Data
    • Circuit Switched Data Service
  • The test set includes a data channel troubleshooting tool called Ping .
  • Automatic RRC State Transitions
  • Data Throughput Monitor Description
  • Data Channel Applications
  • DUT Routing State
  • TCP Data Flood

Data Channel Setup

  • Packet Data Setup
  • CS Data Setup
    • Async CS Data Source
  • Multiple PDP Contexts Information
  • IP Addressing Info
    • Instrument IP Info/Instrument IP Setup
    • DUT IP Setup

Manual Operation

  • Establishing a Packet Data Connection

For Reference

  • DUT IP Address


Troubleshooting

Troubleshooting

Last updated: October 25, 2010

This page provides links to troubleshooting information including: Contact Information , Measurement Troubleshooting , Call Processing Troubleshooting , Error Indicators and Other Troubleshooting Information (such as block diagrams and known issues).

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

IMPORTANT
If you install application firmware on a test set with incompatible hardware, the test set may lock up. See Test Set Lockup During Power Up Sequence .

Some features may be inaccessible or may not perform to specifications without a hardware upgrade to your test set or a proper license. For more details, please see:

http://www.agilent.com/find/8960upgrades

Contact Information

  • Contact Us

Measurement Troubleshooting

  • AFANalyzer Troubleshooting
  • Adjacent Channel Leakage Ratio Troubleshooting
  • Block Error Ratio Troubleshooting
  • Change of TFC (Transport Format Combination) Troubleshooting (lab application only)
  • Channel Power Troubleshooting
  • Code Domain Troubleshooting
  • Dynamic Power Analysis Troubleshooting
  • Extended Range Dynamic Power Measurement Troubleshooting
  • Fast Device Tune Troubleshooting ( lab application or feature-licensed test application only )
  • Frequency Stability Troubleshooting
  • HSDPA Block Error Ratio Troubleshooting ( lab application or feature-licensed test application only )
  • HSDPA Reporting of Channel Quality Indicator Troubleshooting (lab application only)
  • Inner Loop Power Troubleshooting
  • IQ Tuning Measurement Troubleshooting
  • Loopback Bit Error Ratio Troubleshooting
  • Occupied Bandwidth Troubleshooting
  • Out-of-Synch Handling of Output Power Troubleshooting (lab application only)
  • Perceptual Evaluation of Speech Quality Measurement Troubleshooting ( Only applicable to the feature-licensed lab application or test application )
  • Phase Discontinuity Troubleshooting
  • PRACH Preamble Analysis Troubleshooting (lab application only)
  • PRACH Transmit On/Off Power Troubleshooting
  • Spectrum Emission Mask Troubleshooting
  • Spectrum Monitor Troubleshooting
  • Swept Audio Measurement Troubleshooting
  • Thermal Power Troubleshooting
  • TX Dynamic Power Measurement Troubleshooting
  • Waveform Quality Troubleshooting

Call Processing Troubleshooting

  • Troubleshooting UE Reported Measurements
  • Troubleshooting Call Processing Operations
  • Troubleshooting Handovers
  • Troubleshooting Soft Handover (lab application only)
  • Troubleshooting the Two-Cell Test System ( lab application only )
  • Troubleshooting Compressed Mode Operation (lab application only)
  • Data Channel Troubleshooting (lab application only)
  • Troubleshooting External Device Connection (lab application only)
  • Troubleshooting Video Call (lab application only)
  • Troubleshooting Simultaneous Services (lab application only)
  • Cell Broadcast Service (CBS) Troubleshooting (lab application only)

Error Indicators

  • Error Messages
  • Error Message Log
  • Integrity Indicator

Other Troubleshooting Information

  • Using GPIB Command Debug Mode
  • User Interface (UI) Log
  • Block Diagram
  • Calibrating the Test Set
  • Verifying the Test Set
  • 8960 Known Issues


Configuration

Last updated: May 25, 2009

This page provides link to configuration information including: Test Set Configuration Information (test set identification, hardware configuration), Control (items in the Control menu, such as GPIB and LAN configuration, amplitude offsets and application/format switching) and Utilities (items in the Utilities menu, such as message log, calibrations and self test).

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

Test Set Configuration Information

  • Obtaining Identification Information (*IDN)
  • Hardware Configuration Report
  • Timebase Description/Configuration
  • User Calibration Summary
  • Instrument IP Info/Instrument IP Setup

Control

  • Instrument Setup
    • Configuring the Test Set's GPIB
    • Configuring the Test Set's LAN
    • Display Mode (Track/Fast)
    • Adjusting the Brightness of the Test Set's Display
    • Test Set Beeper
    • Configuring System Time and Date
    • Restart on Fatal Error
  • Format Switch/Application Selection
    • Application Switching
    • Application Revisions and Licenses
    • Application Name
  • Amplitude Offset
  • Audio Out Port/FM Demodulation Setup: Configuring the Test Set's AUDIO OUT port
  • External Device Connection ( lab application or feature-licensed test application only )

Utilities

  • Error Message Log
  • Service: IQ Calibrations , Burst Mod Offset 1 Calibration


Release Notes

Last updated: January 16, 2009

The links below contain information on the new features in the test and lab applications for each release of the firmware.

Features and Functionality

  • E1963A W-CDMA/HSPA Test Application Revision Information


comp_ex

10 !***************************************************************

20 ! Comprehensive Example Program

30 ! 8960 W-CDMA Loopback Test Mode

40 !

50 ! This is a program to demonstrate the use of the 8960

60 ! with E1963A W-CDMA TA testing a FDD W-CDMA UE call processing.

70 ! The 8960 uses test control protocol to perform testing.

80 !

90 !***************************************************************

100 !

110 COM /Address/ INTEGER Testset

120 Testset=714

130 ON TIMEOUT 7,20 GOSUB Timeout

140 Rf_level=-35

150 CLEAR SCREEN

160 !

170 !***************************************************************

180 ! Step 1: Set Up Test Set

190 !***************************************************************

200 !

210 OUTPUT Testset;"*RST"

220 OUTPUT Testset;"*CLS"

230 OUTPUT Testset;"SYST:COMM:GPIB:DEB ON"

240 OUTPUT Testset;"CALL:OPER:MODE OFF"

250 OUTPUT Testset;"SYST:CORR:FREQ 2000MHZ"

260 OUTPUT Testset;"SYST:CORR -1"

270 !

280 !***************************************************************

290 ! Step 2: Configure Test Set and UE Parameters

300 !***************************************************************

310 !

320 ! Cell Parameters

330 OUTPUT Testset;"CALL:LAC 30865" !Correct LAC avoids Location Update

340 OUTPUT Testset;"CALL:MCC 234"

350 OUTPUT Testset;"CALL:MNC 56"

360 OUTPUT Testset;"CALL:PAG:REP:STAT:WCDMA ON"

370 ! Generator Info

380 ! -Downlink Channel Codes

390 OUTPUT Testset;"CALL:SCOD:PRIM 0"

400 OUTPUT Testset;"CALL:SRB:CCH:DED:BPS3400:CCOD CODE12"

410 OUTPUT Testset;"CALL:CCPC:SEC:CCOD CODE7"

420 OUTPUT Testset;"CALL:PICH:CCOD CODE16"

430 OUTPUT Testset;"CALL:AICH:CCOD CODE10"

440 OUTPUT Testset;"CALL:DPCH:RMC12:CCOD CODE9"

450 ! -Downlink Channel Levels

460 OUTPUT Testset;"CALL:CPIC -4.8"

470 OUTPUT Testset;"CALL:CCPC:PRIM -7.1"

480 OUTPUT Testset;"CALL:CCPC:SEC -6.9"

490 OUTPUT Testset;"CALL:PICH -9.9"

500 OUTPUT Testset;"CALL:AICH -9.9"

510 OUTPUT Testset;"CALL:DPCH -12"

520 ! -Connected DL Channel Levels

530 OUTPUT Testset;"CALL:CONN:CPIC -3.3"

540 OUTPUT Testset;"CALL:CONN:CCPC:PRIM -5.35"

550 OUTPUT Testset;"CALL:CONN:PICH -20" !Change PICH to give OCNS

560 OUTPUT Testset;"CALL:CONN:DPCH -10.3"

570 ! -AWGN Power

580 OUTPUT Testset;"CALL:AWGN:POW:STAT OFF"

590 ! Uplink Parameters

600 OUTPUT Testset;"CALL:UPL:PRAC:POW:STEP 3"

610 OUTPUT Testset;"CALL:UPL:PRAC:SIGN 0"

620 OUTPUT Testset;"CALL:UPL:PRAC:SCOD 0"

630 OUTPUT Testset;"CALL:UPL:DPCH:SCOD 0"

640 !

650 ! Call Parameters

660 OUTPUT Testset;"CALL:POW ";Rf_level

670 OUTPUT Testset;"CALL:DPCH:TYP RMC12"

680 OUTPUT Testset;"CALL:CHAN 10563"

690 OUTPUT Testset;"CALL:UPL:CHAN 9613"

700 OUTPUT Testset;"CALL:DTCH:DATA PRBS15"

710 OUTPUT Testset;"CALL:SRB:CCH:DED:DRAT BPS3400"

720 ! Uplink Channel Levels

730 OUTPUT Testset;"CALL:CLPC:UPL:MODE ACT"

740 OUTPUT Testset;"CALL:MS:POW:TARG 0 DBM"

750 ! Call Control

760 OUTPUT Testset;"CALL:PAG:IMSI '1234567890'"

770 OUTPUT Testset;"CALL:OPER:MODE CALL"

780 !

790 !***************************************************************

800 ! Step 3: Measurement Parameters

810 !***************************************************************

820 !

830 ! Set all measurement triggers to single

840 OUTPUT Testset;"SET:CONT:OFF"

850 ! Set up the Thermal Power measurement

860 OUTPUT Testset;"SET:WTP:TIM 7;COUN 1"

870 ! Set up the Channel Power measurement

880 OUTPUT Testset;"SET:WCP:TIM 7;COUN 1"

890 OUTPUT Testset;"SET:WCP:INT:TIME .667 MS"

900 OUTPUT Testset;"SET:WCP:FILT ON" ! Turn the RRC filter on

910 ! Set up the Waveform Quality measurement

920 OUTPUT Testset;"SET:WWQ:TIM 7;COUN 1;TSL 1"

930 ! Set up the ACLR measurement

940 OUTPUT Testset;"SET:WACL:TIM 7;COUN 1"

950 ! Set up the Loopback BER measurement

960 OUTPUT Testset;"SET:WBER:TIM 7;COUN 10000"

970 ! Set up the Occupied Bandwidth measurement

980 OUTPUT Testset;"SET:WOBW:TIM 7;COUN 1"

990 ! Set up the Spectrum Emission Mask measurement

1000 OUTPUT Testset;"SET:WSEM:TIM 7;COUN 1"

1010 !

1020 !***************************************************************

1030 ! Step 4: Make a Connection

1040 !***************************************************************

1050 !

1060 PRINT "Turn the UE on now."

1070 Originate ! Subroutine to originate a connection

1080 !

1090 !***************************************************************

1100 ! Step 5: INITiate and FETCh Measurements

1110 !***************************************************************

1120 !

1130 CLEAR SCREEN

1140 PRINT "W-CDMA Test Results:"

1150 PRINT

1160 Time1=TIMEDATE ! Start a timer for evaluating test times

1170 !

1180 FOR I=1 TO 1 !Change index depending on # of freq/power levels"

1190 OUTPUT Testset;"INIT:WBER;WTP;WWQ;WACL;WOBW;WSEM"

1200 Fetch_results! Go to a subroutine to handle the results

1210 !

1220 !***************************************************************

1230 ! Step 6: Reconfigure Test Set and UE Connection Parameters

1240 !***************************************************************

1250 !

1260 !Use deferred commands to set up new channels

1270 OUTPUT Testset;"CALL:SET:CHAN:DOWN 10526"

1280 OUTPUT Testset;"CALL:SET:CHAN:UPL 9626"

1290 OUTPUT Testset;"CALL:HAND:PCR" ! Executes the handoff

1300 OUTPUT Testset;"CALL:STAT?" ! Verify the handoff success

1310 ENTER Testset;Call_state$

1320 IF Call_stat$<>"CONN" THEN Dropped_call

1330 NEXT I

1340 !

1350 !****************************************************************

1360 ! Step 7: End the Connection

1370 !****************************************************************

1380 !

1390 OUTPUT Testset;"CALL:END"

1400 OUTPUT Testset;"CALL:CONN?"

1410 ENTER Testset;Callstate

1420 IF Callstate=1 THEN

1430 PRINT "Make sure the phone has released the call."

1440 OUTPUT Testset;"SYST:PRES3"

1450 END IF

1460 PRINT ""

1470 PRINT "Testing Complete."

1480 Testtime=PROUND(TIMEDATE-Time1,-2)

1490 PRINT ""

1500 PRINT "Test time was ";Testtime;" seconds."

1510 STOP

1520 Timeout: !Comes here only when program times out

1530 PRINT "Program time out."

1540 END

1550 !

1560 !*****************************************************************

1570 ! Subroutine Section

1580 !*****************************************************************

1590 !

1600 SUB Print_results(Meas_name$,Res1,OPTIONAL Res2,Res3,Res4,Res5,Res6)

1610 SELECT Meas_name$

1620 CASE "WTP"

1630 PRINT USING "5X,""Thermal Power:"",9X,M2D.2D,"" dBm""";Res1

1640 CASE "WWQ"

1650 PRINT USING "5X,""Max EVM:"",15X,M2D.2D,"" %""";Res1

1660 PRINT USING "5X,""Worst Freq Error:"",5X,M3D.2D,"" Hz""";Res2

1670 PRINT USING "5X,""Max Origin Offset:"",5X,M2D.2D,"" dB""";Res3

1680 PRINT USING "5X,""Max Phase Error:"",7X,M2D.2D,"" Deg""";Res4

1690 PRINT USING "5X,""Max Mag. Error:"",8X,M2D.2D,"" %""";Res5

1700 CASE "WACL"

1710 PRINT USING "5X,""ACLR -5 MHz Offset:"",4X,M2D.2D,"" dBc""";Res1

1720 PRINT USING "5X,""ACLR +5 MHz Offset:"",4X,M2D.2D,"" dBc""";Res2

1730 PRINT USING "5X,""ACLR -10 MHz Offset:"",3X,M2D.2D,"" dBc""";Res3

1740 PRINT USING "5X,""ACLR +10 MHz Offset:"",3X,M2D.2D,"" dBc""";Res4

1750 CASE "WCP"

1760 PRINT USING "5X,""Channel Power:"",9X,M2D.2D,"" dBm""";Res1

1770 CASE "WBER"

1780 PRINT USING "5X,""Loopback BER:"",9X,M3D.2D,"" %""";Res1

1790 CASE "WOBW"

1800 PRINT USING "5X,""Occupied Bandwidth:"",4X,M1D.3D,"" MHz""";Res1

1810 CASE "WSEM"

1820 IF Res1=0 THEN Res1$="PASS"

1830 IF Res1=1 THEN Res1$="FAIL"

1840 PRINT " Spectrum Emission Mask: ";Res1$

1850 END SELECT

1860 SUBEND

1870 SUB Dropped_call

1880 PRINT " "

1890 PRINT "Call was dropped. Program aborted."

1900 STOP

1910 SUBEND

1920 SUB Orig_failed

1930 COM /Address/ INTEGER Testset

1940 CLEAR Testset

1950 OUTPUT Testset;"CALL:END"

1960 PRINT "Origination failed. Check conditions and run again."

1970 STOP

1980 SUBEND

1990 SUB Fetch_results

2000 COM /Address/ INTEGER Testset

2010 REPEAT

2020 OUTPUT Testset;"INIT:DONE?"

2030 ENTER Testset;Measdone$

2040 SELECT Measdone$

2050 CASE "WTP"

2060 OUTPUT Testset;"FETC:WTP:INT?;POW?"

2070 ENTER Testset;Integrity,Power

2080 IF Integrity=0 THEN

2090 Print_results(Measdone$,Power)

2100 ELSE

2110 Meas_error(Measdone$,Integrity)

2120 END IF

2130 CASE "WCP"

2140 OUTPUT Testset;"FETC:WCP:INT?;POW?"

2150 ENTER Testset;Integrity,Power

2160 IF Integrity=0 THEN

2170 Print_results(Measdone$,Power)

2180 ELSE

2190 Meas_error(Measdone$,Integrity)

2200 END IF

2210 CASE "WWQ"

2220 OUTPUT Testset;"FETC:WWQ?"

2230 ENTER Testset;Integrity,Evm,Ferr,Ooff,Perr,Merr

2240 IF Integrity=0 THEN

2250 Print_results(Measdone$,Evm,Ferr,Ooff,Perr,Merr)

2260 ELSE

2270 Meas_error(Measdone$,Integrity)

2280 END IF

2290 CASE "WACL"

2300 OUTPUT Testset;"FETC:WACL:INT?;AVER?"

2310 ENTER Testset;Integrity,Negfive,Posfive,Negten,Posten

2320 IF Integrity=0 THEN

2330 Print_results(Measdone$,Negfive,Posfive,Negten,Posten)

2340 ELSE

2350 Meas_error(Measdone$,Integrity)

2360 END IF

2370 CASE "WBER"

2380 OUTPUT Testset;"FETC:WBER?"

2390 ENTER Testset;Integrity,Ber

2400 IF Integrity=0 THEN

2410 Print_results(Measdone$,Ber)

2420 ELSE

2430 Meas_error(Measdone$,Integrity)

2440 END IF

2450 CASE "WOBW"

2460 OUTPUT Testset;"FETC:WOBW?"

2470 ENTER Testset;Integrity,Obw

2480 IF Integrity=0 THEN

2490 Print_results(Measdone$,Obw)

2500 ELSE

2510 Meas_error(Measdone$,Integrity)

2520 END IF

2530 CASE "WSEM"

2540 OUTPUT Testset;"FETC:WSEM?"

2550 ENTER Testset;Integrity,Overall,Pow,Range1,Range2,Range3,Range4

2560 IF Integrity=0 THEN

2570 Print_results(Measdone$,Overall)

2580 ELSE

2590 Meas_error(Measdone$,Integrity)

2600 END IF

2610 END SELECT

2620 UNTIL Measdone$="NONE"

2630 SUBEND

2640 SUB Meas_error(Measdone$,Integrity)

2650 SELECT Integrity

2660 CASE 2

2670 Err$=" Meas Timeout"

2680 CASE 5

2690 Err$=" Over Range"

2700 CASE 6

2710 Err$=" Under Range"

2720 CASE 17

2730 Err$=" Cannot Correlate"

2740 CASE 19

2750 Err$=" Temp Drift"

2760 CASE ELSE

2770 Err$=""

2780 END SELECT

2790 PRINT Measdone$;" Integrity is";Integrity;Err$

2800 SUBEND

2810 SUB Originate

2820 COM /Address/ INTEGER Testset

2830 ON TIMEOUT 7,10 CALL Orig_failed

2840 OUTPUT Testset;"CALL:ORIG:SEQ"

2850 OUTPUT Testset;"CALL:CONN?"

2860 ENTER Testset;Connected

2870 IF NOT Connected THEN

2880 PRINT "Call origination not successful."

2890 STOP

2900 END IF

2910 SUBEND


E6703U User Documentation

Last updated: January 15, 2009

  • Overview
  • 3.6 Mbps and 7.2 Mbps HSDPA IP Data Throughput
  • LAN 2 PORT
  • Additional GPRS Radio Access Bearers
  • Compressed Mode
  • External Device Connection/Two-Cell Test System Considerations
  • Simultaneous Services
  • HSUPA PS Data Setup

Overview

The features and functionality present in the E6703U Special High Data Rate W-CDMA/HSDPA Lab Application are identical to those offered in the E6703E W-CDMA/HSDPA Lab Application, with the exceptions described in this document. For information on how to use the features that are common to the E6703E and E6703U, see the W-CDMA/HSDPA online user's guide located at:

http://wireless.agilent.com/rfcomms/refdocs/wcdma/default.html

The E6703U can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Contact your local Agilent Sales Representative for more information, or visit www.agilent.com/find/8960upgrades.

In a test set with Special High Data Rate Hardware, the standard Protocol Processor is replaced with a High Data Rate Protocol Processor, and the test set's rear panel is modified to include a new LAN 2 PORT , which you must use for sending data to the test set (previously the LAN 1 PORT was used for this purpose).

3.6 Mbps and 7.2 Mbps HSDPA IP Data Throughput

The E6703U Special High Data Rate W-CDMA/HSDPA Lab Application (along with the appropriate hardware option) supports the maximum IP data throughput of HSDPA UE categories 1-8, 11 and 12. This allows you to test 3.6 Mbps HSDPA IP data throughput for category 5 and 6 UEs, and 7.2 Mbps HSDPA IP data throughput for category 7 and 8 UEs.

To achieve these maximum rates:

  • You must use one of the additional GPRS Radio Access Bearers available in the E6703U, which provide a higher uplink data rate for TCP acknowledgments: 128k UL/HSDPA DL PS or 384k UL/HSDPA DL PS . Note that some UEs perform best using the 128k UL/HSDPA PS RAB, as the 384k UL/HSDPA DL PS RAB more greatly stresses the UE's CPU.
  • For 3.6 Mbps, you must set PS Data Configuration Type to 22 . For 7.2 Mbps, you must set CQI Value to 25 (and PS Data HS-DSCH MAC-d PDU Size to 656 bits if required by your UE for optimum performance - a PDU size of 656 bits may help reduce CPU loading in your UE).
  • You must ensure that your client PC's TCP receive window and your server PC's socket buffer are sufficiently large for the IP data throughput you are trying to achieve. For 7.2 Mbps, it is recommended that you set the TCP Receive Window to 116,800 bytes. Important: for optimum performance do not exceed this value; doing so could cause the test set's internal buffer to overflow, resulting in lost IP packets and reduced data throughput).
  • Some UEs require additional power be placed in the downlink HS-SCCH 1 and/or HS-PDSCHs in order to achieve maximum IP data throughput (see HSDPA Connected DL Channel Levels ).

LAN 2 PORT

The Special High Data Rate Hardware required to run the E6703U includes a modified rear panel with a new LAN 2 PORT . To use the E6703U Data Channels functionality (to establish an HSDPA PS Data connection, for example), you must connect your data server to the LAN 2 PORT , rather than to the LAN 1 PORT as in the past. You must also use the LAN 2 PORT to establish an External Device Connection between two test sets.

LAN 1 PORT is still used for all other LAN operations such as protocol logging, firmware downloads and screen captures.

The LAN 2 PORT connects directly to the test set's High Data Rate protocol processor, as shown in the block diagram below.

LAN IP Address 2 (Data+)

You must configure the address of the LAN 2 PORT using the LAN IP Address 2 (Data+) setting (see Configuring the Test Set's LAN for general information about LAN IP addresses). LAN IP Address 2 (Data+) must not be identical to the LAN IP Address setting, and must be on the same subnet as the LAN IP Address setting. If LAN IP Address or Subnet Mask is changed such that LAN IP Address 2 (Data+) is identical to or is no longer on the same subnet as LAN IP Address , then LAN IP Address 2 (Data+) is set to 0.0.0.0 and a warning is posted.

Manual operation: LAN IP Address 2 (Data+) is accessible from the Instrument Setup menu on the System Config Screen .

GPIB command: SYSTem:COMMunicate:LAN[:SELF]:ADDRess2<sp><string> . See SYSTem:COMMunicate:GPIB[:SELF]:ADDRess for range information.

Additional GPRS Radio Access Bearers

The E6703U supports the following GPRS Radio Access Bearers. If you attempt to select these RABs in the E6703E, an error is posted. See GPRS Radio Access Bearer .

  • 384k UL/384k DL PS
  • 128k UL/HSDPA DL PS
  • 384k UL/HSDPA DL PS
  • HSUPA UL / HSDPA DL PS

Compressed Mode

The E6703U (along with the appropriate hardware option) supports compressed mode for 384k downlink channels. If you try to enable compressed mode while on a 384k downlink channel in the E6703E, an error is posted. Note that neither the E6703U nor the E6703E support compressed mode for the 384k RMC, 384k UL/384k DL PS or 384k UL/HSDPA DL PS channels. These channels are not compressible by spread factor reduction because the uplink 384k DPCH already uses the minimum DPCH spreading factor of 4.

The following table summarizes the additional channels available in compressed mode in the E6703U and the valid downlink DPCH channelization codes. The E6703U also supports compressed mode for all of the channels shown in Channel Types Supported in Compressed Mode and Valid Channelization Codes .

Additional Channel Types Supported in Compressed Mode and Valid Channelization Codes
Channel Type | Valid Compressed Mode Channelization Codes | Lab Application Front Panel Setting
12.2k UL/384k DL AM RMC | 6 * | DPCH 480 ksps (OVSF 8) Channelization Code
64k UL/384k DL AM RMC | 6 * | DPCH 480 ksps (OVSF 8) Channelization Code
64k UL/384k DL RMC | 6 * | DPCH 480 ksps (OVSF 8) Channelization Code
64k UL/384k DL PS | 6 * | DPCH 480 ksps (OVSF 8) Channelization Code
128k UL/384k DL PS | 6 * | DPCH 480 ksps (OVSF 8) Channelization Code
128k UL/HSDPA DL PS (3.4k SRB used while on an HSDPA packet data connection) | 40, 43, 58 (all values are valid) | HSDPA DPCH 15 ksps (OVSF 256) Channelization Code,
* When compressed mode is enabled on a 384k downlink channel, the cell 1 Orthogonal Channel Noise Simulator (OCNS) channels are moved from their default channelization codes: 2, 11, 17, 23, 31, 38, 47, 55, 62, 69, 78, 85, 94, 113, 119, and 125 (OVSF of 128), to alternate channelization codes: 2, 11, 17, 23, 31, 38, 47, 55, 62, 69, 78, 85, 88, 90, 92, and 94 (OVSF of 128), to avoid collisions with the downlink DPCH, which is fixed at channel code 6 (OVSF of 8). The OCNS channels remain at the alternate channelization codes until compressed mode is disabled (in other words, while compressed mode is enabled, the OCNS channels are at the alternate channelization codes during both compressed and normal frames). When compressed mode is disabled, the OCNS channels are moved back to their default channelization codes. Also, compressed mode cannot be enabled on a 384k downlink channel if S-CCPCH Channelization Code is set to 57.

External Device Connection/Two-Cell Test System Considerations

  • When establishing an External Device Connection using one or more test sets running the E6703U, you must connect both the LAN 1 PORT and LAN 2 PORT to the LAN switch.
  • When establishing an External Device Connection from a test set running the E6703U, the destination test set displays the E6703U's LAN IP Address 2 (Data+) under Connected Device IP Address .
  • When establishing an External Device Connection to a test set running the E6703U, you must set the originating test set's Ext 8960 IP Addr to the LAN IP Address 2 (Data+) of the E6703U test set (unless you've connected the two test sets via a hub and have connections to the E6703U test set's LAN 1 PORT and LAN 2 PORT ; in that case you can set Ext 8960 IP Addr to the E6703U test set's LAN IP Address or LAN IP Address 2 (Data+) .)
  • When performing two-cell PS data transfer cell reselections (see Two-Cell Test System ), the data rate is limited by the data rate capability of the test set that established the PDP context with the mobile. This is because when a mobile has an active PDP context with one test set and transitions to another, a tunnel is created to route data to and from the mobile via the originating test set. The originating test set must continue to act as the end-point for the IP connection, regardless of the location of the mobile, and to forward any received packets to the test set currently serving the mobile. Thus, to achieve high data rates during cell reselection using a high data rate test set and a standard test set, you must start the PDP context on the high data rate test set.


Getting Started with Call Processing

Getting Started with Call Processing

Last updated: January 15, 2009

Most of the information in the Call Processing section describes the features and functionality available while in Active Cell Operating Mode and FDD Test Operating Mode . While in these modes, the test set includes a base station emulator which allows you to establish a connection between the test set and your wireless device (with signalling when in Active Cell Operating Mode or by the device synchronizing to the downlink when in FDD Test Mode ).

The base station emulator can be configured by changing various parameters. Most of these parameters are described at the following links: Cell Parameters , Downlink Channel Codes and Levels , Cell Power and AWGN Power , Uplink Parameters , and Security Information . To find information on a specific parameter, you can also use the search field at the top of this page to search the contents of this guide.

For more details on establishing a call in Active Cell Operating Mode , see Current Service Type , Call Processing Status , and Establishing a Connection with the UE .

You can perform many other call processing operations, such as "Handovers" on page 1 , UE Reported Measurements , Compressed Mode , Calling Party Number Parameters , Short Message Service (SMS) , and Video Call .

For general technology information to help you become more familiar with the W-CDMA system, see W-CDMA/HSDPA/HSUPA Concepts .

For details about to which revisions of the 3GPP specifications the test set is compliant, see 3GPP Compliance .


wcdma_comp_ex

10 !***************************************************************

20 !

30 ! Comprehensive Example Program

40 ! 8960 W-CDMA FDD Test Mode (E1963A)

50 ! (Rev. 09/13/01)

60 !

70 ! This is a program to demonstrate the use of the 8960

80 ! with E1963A W-CDMA TA testing a FDD W-CDMA UE in FDD test mode

90 !

100 !***************************************************************

110 !

120 COM /Address/ INTEGER Testset

130 Testset=714

140 ON TIMEOUT 7,20 GOSUB Timeout

150 Rf_level=-106.7

160 CLEAR SCREEN

170 !

180 !***************************************************************

190 ! Step 1: Set Up the Test Set

200 !***************************************************************

210 !

220 !***************************************************************

230 ! Initialize the Test Set

240 !***************************************************************

250 ! Fully preset the test set

260 OUTPUT Testset;"*RST"

270 ! Clear the error queue

280 OUTPUT Testset;"*CLS"

290 !***************************************************************

300 ! Set Up General Operating Conditions

310 !***************************************************************

320 ! Turn debugger on

330 OUTPUT Testset;"SYST:COMM:GPIB:DEB ON"

340 ! Set operating mode to FDD Test Mode

350 OUTPUT Testset;"CALL:OPER:MODE FDDT"

360 ! Set amplitude offsets

370 OUTPUT Testset;"SYST:CORR:FREQ 800MHZ,900MHZ,1900MHZ,2000MHZ"

380 OUTPUT Testset;"SYST:CORR:SGA -0.7,-0.8,-1.0,-1.1"

390 !

400 !***************************************************************

410 ! Step 2: Configure Test Set and Mobile Station Parameters

420 !***************************************************************

430 !

440 !***************************************************************

450 ! Set Up the Downlink

460 !***************************************************************

470 ! Set downlink power

480 OUTPUT Testset;"CALL:POW ";Rf_level

490 ! Set downlink frequency

500 OUTPUT Testset;"CALL:CONT:DOWN:FREQ:AUTO OFF"

510 OUTPUT Testset;"CALL:RFG:FREQ 2.0 GHZ"

520 ! Set downlink primary scrambling code

530 OUTPUT Testset;"CALL:SCOD:PRIM 1"

540 ! Set up DPCH

550 OUTPUT Testset;"CALL:DPCH:TYP RMC12"

560 OUTPUT Testset;"CALL:DPCH:RMC12:CCOD CODE9"

570 OUTPUT Testset;"CALL:FDDT:DPCH -10.3"

580 OUTPUT Testset;"CALL:DTCH:DATA PRBS15"

590 ! Set up CPICH

600 OUTPUT Testset;"CALL:FDDT:CPIC -3.3"

610 ! Set up P-CCPCH

620 OUTPUT Testset;"CALL:FDDT:CCPC:PRIM -5.35"

630 ! Set up PICH

640 OUTPUT Testset;"CALL:PICH:CCOD CODE16"

650 OUTPUT Testset;"CALL:FDDT:PICH -8.35"

660 ! Set up AWGN

670 OUTPUT Testset;"CALL:AWGN:POW:STAT OFF"

680 !***************************************************************

690 ! Set Up the Uplink

700 !***************************************************************

710 ! Set power control bits to all up to force UE to max power

720 OUTPUT Testset;"CALL:FDDT:CLPC:UPL:MODE UP"

730 ! Set expected uplink power

740 OUTPUT Testset;"RFAN:CONT:POW:AUTO OFF"

750 OUTPUT Testset;"RFAN:MAN:POW:FDD 0"

760 ! Set expected uplink frequency and measurement frequency

770 OUTPUT Testset;"RFAN:CONT:UPL:FREQ:AUTO OFF"

780 OUTPUT Testset;"RFAN:MAN:UPL:FREQ 1.9 GHZ"

790 OUTPUT Testset;"RFAN:CONT:MEAS:FREQ:AUTO OFF"

800 OUTPUT Testset;"RFAN:MAN:MEAS:FREQ 1.9 GHZ"

810 ! Set expected uplink primary scrambling code

820 OUTPUT Testset;"CALL:UPL:DPCH:SCOD 0"

830 !

840 !***************************************************************

850 ! Step 3: Set Measurement Parameters

860 !***************************************************************

870 !

880 ! Set all measurement triggers to single

890 OUTPUT Testset;"SET:CONT:OFF"

900 ! Set up thermal power

910 OUTPUT Testset;"SET:WTP:TIM 3;COUN 1"

920 ! Set up channel power

930 OUTPUT Testset;"SET:WCP:TIM 3;COUN 1;TRIG:SOUR IMM"

940 OUTPUT Testset;"SET:WCP:INT:TIME 10 MS"

950 ! Set up waveform quality

960 OUTPUT Testset;"SET:WWQ:TIM 3;COUN 1;TSL 1"

970 ! Set up ACLR

980 OUTPUT Testset;"SET:WACL:TIM 3;COUN 1;TRIG:SOUR IMM"

990 ! Set up Loopback BER

1000 OUTPUT Testset;"SET:WBER:TIM 10;COUN 15000"

1010 !

1020 !***************************************************************

1030 ! Step 4: Make Connection

1040 !***************************************************************

1050 !

1060 PRINT "Configure UE for 12.2k RMC Now."

1070 PRINT

1080 PRINT "UE Synchronization required for Waveform Quality."

1090 PRINT "UE loopback Mode 1 required for loopback BER."

1100 PRINT

1110 PRINT "8960 DL is 2.0 GHz"

1120 PRINT "8960 UL Expected Frequency: 1.9 GHz"

1130 PRINT "8960 UL Expected Power: 0 dBm"

1140 PRINT "8960 UL Expected Primary Scrambling Code: 0"

1150 PRINT

1160 PRINT "When UE is configured and transmitting, press 'F2'."

1170 PAUSE

1180 !

1190 !***************************************************************

1200 ! Step 5: INITiate and FETCh Measurements

1210 !***************************************************************

1220 !

1230 CLEAR SCREEN

1240 PRINT "Test Results for UL Frequency 1.9 GHz:"

1250 PRINT

1260 !

1270 FOR I=1 TO 2

1280 ! INITiate a set of concurrent measurements

1290 OUTPUT Testset;"INIT:WTP;WWQ;WACL;WBER"

1300 ! FETCh the measurement results (using a subroutine)

1310 Fetch_results

1320 IF I=1 THEN

1330 PRINT

1340 PRINT "1.9 GHz Testing Complete."

1350 !

1360 !***************************************************************

1370 ! Step 6: Reconfigure Test Set and Mobile Station Connection

1380 !***************************************************************

1390 !

1400 PRINT

1410 PRINT "Change UE UL Frequency to 1.850 GHz."

1420 PRINT

1430 PRINT "UE Synchronization required for Waveform Quality."

1440 PRINT "UE loopback Mode 1 required for loopback BER."

1450 PRINT

1460 PRINT "When UE is configured and transmitting, press 'F2'."

1470 PAUSE

1480 ! Change expected uplink frequency

1490 OUTPUT Testset;"RFAN:MAN:MEAS:FREQ 1.85 GHZ"

1500 OUTPUT Testset;"RFAN:MAN:UPL:FREQ 1.85 GHZ"

1510 PRINT

1520 PRINT "Test Results for UL Frequency 1.85 GHz:"

1530 ELSE

1540 PRINT

1550 PRINT "1.85 GHz Testing Complete."

1560 END IF

1570 NEXT I

1580 !

1590 !****************************************************************

1600 ! Step 7: End the Connection

1610 !****************************************************************

1620 !

1630 PRINT "Testing complete, end UE transmission."

1640 ! Partially preset the test set

1650 OUTPUT Testset;"SYST:PRES3"

1660 !

1670 !****************************************************************

1680 !

1690 STOP

1700 Timeout: !Program only comes here on 20 second timeout

1710 PRINT "Program timeout."

1720 END

1730 !

1740 !*****************************************************************

1750 ! Subroutine Section

1760 !*****************************************************************

1770 !

1780 SUB Fetch_results

1790 REPEAT

1800 ! Determine if any measurements are done

1810 OUTPUT 714;"INIT:DONE?"

1820 ENTER 714;Measdone$

1830 SELECT Measdone$

1840 CASE "WTP"

1850 ! FETCh measurement result

1860 OUTPUT 714;"FETC:WTP:INT?;POW?"

1870 ENTER 714;Integrity,Power

1880 ! Verify measurement result is valid

1890 IF Integrity=0 THEN

1900 ! For valid result, print result to screen (using a subroutine)

1910 Print_results(Measdone$,Power)

1920 ELSE

1930 ! For invalid result, invoke error handler (using a subroutine)

1940 Meas_error(Measdone$,Integrity)

1950 END IF

1960 CASE "WCP"

1970 OUTPUT 714;"FETC:WCP:INT?;POW?"

1980 ENTER 714;Integrity,Power

1990 IF Integrity=0 THEN

2000 Print_results(Measdone$,Power)

2010 ELSE

2020 Meas_error(Measdone$,Integrity)

2030 END IF

2040 CASE "WWQ"

2050 OUTPUT 714;"FETC:WWQ?"

2060 ENTER 714;Integrity,Evm,Ferr,Ooff,Perr,Merr

2070 IF Integrity=0 THEN

2080 Print_results(Measdone$,Evm,Ferr,Ooff,Perr,Merr)

2090 ELSE

2100 Meas_error(Measdone$,Integrity)

2110 END IF

2120 CASE "WACL"

2130 OUTPUT 714;"FETC:WACL:INT?;AVER?"

2140 ENTER 714;Integrity,Negfive,Posfive,Negten,Posten

2150 IF Integrity=0 THEN

2160 Print_results(Measdone$,Negfive,Posfive,Negten,Posten)

2170 ELSE

2180 Meas_error(Measdone$,Integrity)

2190 END IF

2200 CASE "WBER"

2210 OUTPUT 714;"FETC:WBER?;WBER:INT?"

2220 ENTER 714;Ber,Integrity

2230 IF Integrity=0 THEN

2240 Print_results(Measdone$,Ber)

2250 ELSE

2260 Meas_error(Measdone$,Integrity)

2270 END IF

2280 END SELECT

2290 ! Exit loop when all measurements are complete

2300 UNTIL Measdone$="NONE"

2310 SUBEND

2320 !

2330 SUB Print_results(Meas_name$,Res1,OPTIONAL Res2,Res3,Res4,Res5,Res6)

2340 SELECT Meas_name$

2350 CASE "WTP"

2360 PRINT USING "5X,""Thermal Power:"",9X,M2D.2D,"" dBm""";Res1

2370 CASE "WWQ"

2380 PRINT USING "5X,""Max EVM:"",15X,M2D.2D,"" %""";Res1

2390 PRINT USING "5X,""Worst Freq Error:"",5X,M3D.2D,"" Hz""";Res2

2400 PRINT USING "5X,""Max Origin Offset:"",5X,M2D.2D,"" dB""";Res3

2410 PRINT USING "5X,""Max Phase Error:"",7X,M2D.2D,"" Deg""";Res4

2420 PRINT USING "5X,""Max Mag. Error:"",8X,M2D.2D,"" %""";Res5

2430 CASE "WACL"

2440 PRINT USING "5X,""ACLR -5 MHz Offset:"",4X,M2D.2D,"" dBc""";Res1

2450 PRINT USING "5X,""ACLR +5 MHz Offset:"",4X,M2D.2D,"" dBc""";Res2

2460 PRINT USING "5X,""ACLR -10 MHz Offset:"",3X,M2D.2D,"" dBc""";Res3

2470 PRINT USING "5X,""ACLR +10 MHz Offset:"",3X,M2D.2D,"" dBc""";Res4

2480 CASE "WCP"

2490 PRINT USING "5X,""Channel Power:"",9X,M2D.2D,"" dBm""";Res1

2500 CASE "WBER"

2510 PRINT USING "5X,""Loopback BER:"",5X,M3D.2D,"" %""";Res1

2520 END SELECT

2530 SUBEND

2540 !

2550 SUB Meas_error(Measdone$,Integrity)

2560 SELECT Integrity

2570 CASE 2

2580 Err$=" Meas Timeout"

2590 CASE 5

2600 Err$=" Over Range"

2610 CASE 6

2620 Err$=" Under Range"

2630 CASE 17

2640 Err$=" Cannot Correlate"

2650 CASE 19

2660 Err$=" Temp Drift"

2670 CASE ELSE

2680 Err$=""

2690 END SELECT

2700 PRINT Measdone$;" Integrity is";Integrity;Err$

2710 SUBEND


Configuring the Test Set's AUDIO OUT port

Configuring the Test Set's AUDIO OUT port

Last updated: January 15, 2009

Description

The AUDIO OUT connector on the test set's front panel can be configured to carry one of two signals:

  • Audio Generator
  • FM Demod

By default, the AUDIO OUT connector is configured to carry the output from the built in audio generator. This signal is typically used to stimulate a system to measure its audio performance. When the audio generator's signal is selected for output at the front panel AUDIO OUT connector, use the AFGenerator commands to control the signal.

When testing AMPS systems, it may be useful to configure the AUDIO OUT connector to carry the analog FM Demod signal. This provides the demodulated FM signal for external analysis and baseband processing. Fixed bandwidth bandpass, expandor, and de-emphasis filters can be selected to control the FM Demod signal. When the FM Demod signal is selected for output at the front panel AUDIO OUT connector, use the SYSTem:AUDio:OUTPut commands to control the signal.

For front panel operation, to select the signal source for output to the AUDIO OUT connector, press System Config hardkey, then select Audio Out Port ( F1 ) on the System Config Screen (2 of 2).

Programmatically, to select the signal source for output to the AUDIO OUT connector, use the SYSTem:AUDio:OUTPut:SOURce commands.

Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:SOURce AFGenerator" !Selects Audio Generator signal for output
                                                    !at the front panel AUDIO OUT port.

NOTE
Refer to the Technical Specifications in the Application Datasheet for specifications of the AUDIO OUT connector. There will be no guaranteed performance for the signal present at the AUDIO OUT connector when FM Demod signal is selected for output.

Related Topics

How Do I Configure the AUDIO OUT Port?


Restart on Fatal Error

Restart on Fatal Error

Last updated: January 15, 2009

Description

The Restart on Fatal Error feature provides the ability to configure the test set to automatically restart when a fatal error occurs. Restart on Fatal Error does not apply when a fatal error occurs during the test set's power up sequence.

The Restart on Fatal Error State is retained regardless of whether the test set is restarted manually or through the Restart on Fatal Error feature. The test set's default setting for the Restart on Fatal Error State is Off. If the Restart on Fatal Error State is set to On and a fatal error occurs, the test set prints the fatal error condition on the test set's front panel. The test set then waits 25 seconds before restarting.

The following error message is then displayed on the test set's front panel once the test set completes its power up sequence: " Warning; 8960 has been restarted after a non-recoverable error occurred. " All errors in the error/event queue can be queried using the command SYSTem:ERRor? .

Configurable Parameters

Restart on Fatal Error State is the only parameter that needs to be configured to allow the test set to restart if a fatal error is encountered. The command to set this parameter is SYSTem:FATal:ERRor:RESTart .

How Do I Configure the Test Set to Restart State?

The following procedure details how to configure the test set to automatically restart if a fatal error is encountered during operation.

  1. Press SYSTEM CONFIG .
  2. Press Instrument Setup ( F1 ).
  3. Scroll down and highlight the Restart on Fatal Error State parameter.
  4. Press the knob to change the state to On as shown in the figure below.

Related Topics

SYSTem:FATal:ERRor:RESTart


Test Set Beeper

Test Set Beeper

Last updated: January 15, 2009

Description

This parameter allows you to change the beeper state to on or off. A beep will indicate error conditions caused during manual or remote operation of the test set.

A 100 ms, 1.24 kHz audible tone (beep) is generated when an error message is logged and the beeper state is set to on. If two errors are generated in quick succession, two beeps are generated to indicate that more than one error has been logged.

The beeper state can be manually set in the Instrument Setup window found in the SYSTEM CONFIG screen.

Example

OUTPUT 714;"SYSTEM:BEEPER:STATE OFF"

Related Topics

SYSTem:BEEPer


Adjusting the Brightness of the Test Set's Display

Adjusting the Brightness of the Test Set's Display

Last updated: January 15, 2009

Description

This parameter allows you to adjust the brightness of the test set's display. The test set's display screen has two brightness settings:

  • medium brightness
  • high brightness

Example

OUTPUT 714;"DISPLAY:BRIGHTNESS MEDIUM" ! sets screen brightness to medium.

Related Topics

DISPlay


Display Mode (Track/Fast)

Display Mode (Track/Fast)

Last updated: January 15, 2009

Description

There are two display modes to select from when operating the test set remotely.

  • Display mode fast
  • Display mode track

Fast Mode

When operating remotely, there is often no need for the display to be updated as measurements are made. Using the fast display mode will increase the speed of the test set when it is operated remotely.

Fast mode is designed for remote use only. The test set returns to track mode if you change to manual operation.

  • No screen or menu items are visible (except error messages).
  • Error messages will be displayed in their normal location.
  • "This instrument is being operated remotely" will be displayed at the bottom of the screen.

Example

OUTPUT 714;"DISPLAY:MODE FAST" !Selects fast mode

Track Mode

The track display mode is used to allow users to see what the test set is doing while it is being controlled remotely. Track mode is the default mode of the test set.

  • Any changes made remotely will be updated on the screen if that screen is displayed.
  • The error message window will be displayed as required when an error occurs.

Example

OUTPUT 714;"DISPLAY:MODE TRACK"!Selects track mode

Writing Messages to the Display

The capability to write up to four 30-character lines of text to the front panel display for operator messages is available when the display is in Fast Mode . This feature can be used to control the flow of software running on an external controller by pressing softkeys on the test set's front panel.

For example, by displaying a message that prompts the operator to press a front panel softkey and then monitoring that softkey through status register bits, the programmer can design code that starts measurements, stops measurements, or branches to a selected routine or function without the need for access to the external computer's keyboard.

The GPIB commands for writing messages to the display are found in the DISPlay:OPERator:MESSage table.

The status bit register GPIB commands and bit definitions for monitoring the test set's softkeys are found in the STATus:OPERation:KEYPressed Register Bit Assignments table.

Related Topics

DISPlay


External Device Connection

External Device Connection

Last updated: January 13, 2012

This section is only applicable to the lab application and to a test application with the required feature license.

Description

You can connect your 8960 test set to external devices (such as another 8960 test set) over an IP network. Once you've established this connection, you can test supported end-to-end services between two wireless devices (such as W-CDMA end-to-end video calls), or configure a two-cell test system to test a single mobile's cell transitions, such as handovers and cell selections/reselections.

You can establish an External Device Connection while your test set is in any operating mode. However, most services utilizing the External Device Connection feature require active cell mode operation.

When establishing an External Device Connection using one or more test sets, it is recommended that you connect both the LAN 1 PORT and LAN 2 PORT to the LAN switch.

External Device Connection Setup for Two 8960s

External 8960 Connection Setup

  • External 8960 IP Address

    Before establishing a connection with another 8960, you must first specify its IP address.

    Ext 8960 IP Addr cannot be set to the same value as LAN IP Address or DUT IP Address . If LAN IP Address is set to the value of Ext 8960 IP Addr , Ext 8960 IP Addr is reset to a blank field.

    GPIB command: SYSTem:COMMunicate:LAN:EXTernal:ADDRess

  • Connect to External 8960

    This action establishes a TCP/IP connection with the 8960 at the address specified by External 8960 IP Address .

    If the External Device Connection Status/External Device 2 Connection Status is Connected , then this action is ignored by the test set.

    GPIB command: SYSTem:COMMunicate:LAN:EXTernal:CONNect

  • Disconnect from External 8960

    This action disconnects the TCP/IP connection with the connected external 8960.

    If the External Device Connection Status/External Device 2 Connection Status is Disconnected , then this action is ignored by the test set.

    GPIB command: SYSTem:COMMunicate:LAN:EXTernal:DCONnect

LAN Connection Information

  • External Device Connection Status/External Device 2 Connection Status

    The External Device Conn Status is displayed in the LAN Connection Information window of both tests sets, regardless of which test set initiated the connection. External Device 2 Conn Status displays the connection status of a second external device. The possible states of the external device connections are: Not Connected , Connecting , Connected and Disconnecting .

    When the External Device Connection status is Connected , ExtDev is displayed in the Instrument Status Area of both test sets:

    GPIB command: SYSTem:STATus:COMMunicate:LAN:EXTernal[1]|2[:CONNected][:STATe]?

  • Connected Device IP Address/Connected Device 2 IP Address

    Once a connection has been established between the two test sets, the LAN IP address or the LAN 2 IP Address (depending on whether LAN 2 PORT is supported) of each test set is displayed in the other test set's LAN Connection Information window. Connected Device 2 IP Address displays the IP Address of a second external device when connected.

    GPIB command: SYSTem:STATus:COMMunicate:LAN:EXTernal[1]|2[:CONNected]:ADDRess?

  • LAN (Self) IP Address

    For your convenience, the IP address of the test set is shown in its LAN Connection Information window. This is a duplicate display of its LAN IP Address setting, which you set from the Instrument Setup ( F1 ) menu on its System Config screen, or using the SYSTem:COMMunicate:LAN[:SELF]:ADDRess command.

DUT IP Address Information

The DUT IP Address Information window indicates the IP address(es) currently in use by the DUT, and whether the IP address was assigned by the current test set or the external test set. Note that DUT IP Address must be set to a different value in both test sets.

Once an IP route is established between a test set and a device on the LAN, internet protocols do not provide a mechanism to re-establish the connection with another test set. Thus, when a mobile has an active PDP context with one test set and transitions to another, a tunnel is created to route data to and from the mobile via the originating test set. The originating test set must continue to act as the end-point for the IP connection, regardless of the location of the mobile, and to forward any received packets to the test set currently serving the mobile. This forwarding of packets is referred to as "tunneling".

During tunneling, the mobile uses the DUT IP Address provided by the originating test set, not the DUT IP Address of the serving test set. To help indicate this situation, the DUT IP Address setting on the serving test set is grayed out. Also, DUT IP Address Origin on the serving test set displays External 8960 and the IP address currently in use by the mobile is displayed under DUT IP Address 1 .

  • DUT IP Address Origin

    Displays either This 8960 or External 8960 to indicate which test set assigned the IP address currently in use by the mobile.

  • DUT IP Address 1

    Displays the IP address currently in use by the mobile.

  • DUT IP Address 2
  • DUT IP Address 3
  • DUT IP Address 4

External Device Connection/Two-Cell Test System Considerations

The external device connection is not affected by a partial preset. However, the external device connection is disconnected as a result of a full preset.

Before initiating an external device connection between two test sets, you can verify that the two test sets are able to communicate by pinging one test set from the other. To do so, on test set #1:

  • Press the Call Setup key, then the left More key until the Ping menu is available.
  • Select Ping , then Ping Setup ( F1 ).
  • Set Device to Ping to Alternate ( CALL:DATA:PING:SETup:DEVice ).
  • Set the Alternate Ping Address to the IP address of test set #2 ( CALL:DATA:PING:SETup:ALTernate:IP:ADDRess ).
  • Select Start Ping ( F3 ) ( CALL:DATA:PING:STARt ).

When establishing an External Device Connection, if the destination test set supports the LAN 2 PORT :

  • you must connect both the LAN 1 PORT and the LAN 2 PORT of the destination test set to the hub before the external device connection;
  • on the originating test set, you can set the External 8960 IP Address to either the LAN IP Address or the LAN IP Address 2 (Data+) of the destination test set. However, any way you choose, after a successful connection, the originating test set displays the LAN IP Address 2 (Data+) of the destination test set under Connected Device IP Address .

When performing two-cell PS data transfer cell reselections (see Two-Cell Test System ), the data rate is limited by the data rate capability of the test set that established the PDP context with the mobile. This is because when a mobile has an active PDP context with one test set and transitions to another, a tunnel is created to route data to and from the mobile via the originating test set. The originating test set must continue to act as the end-point for the IP connection, regardless of the location of the mobile, and to forward any received packets to the test set currently serving the mobile. Thus, to achieve high data rates during cell reselection using a high data rate test set and a standard test set, you must start the PDP context on the high data rate test set.

Related Topics

Manual Operation: How Do I Make an External Device Connection?

SYSTem:COMMunicate

SYSTem:STATus

Troubleshooting External Device Connection

Video Call

Two-Cell Test System

Data Throughput Monitor Description

Configuring the Test Set's LAN


Configuring the Test Set's GPIB

Configuring the Test Set's GPIB

Last updated: January 15, 2009

Description

The GPIB address is an integer between 0 and 30. The test set comes with a default address of 14 and may be set/queried using the SYSTem subsystem or manually through the system configuration screen by selecting the parameter and changing the number with the knob or the keypad.

The GPIB address is a non-volatile parameter. The GPIB address is not affected by any reset operation and can only be changed by direct access to the parameter itself.

Related Topics

SYSTem:COMMunicate


Hardware Configuration Report

Hardware Configuration Report

Last updated: January 15, 2009

Description

You can generate a list of the test set's hardware configuration over the LAN or GPIB.

The LAN query is the easiest and most direct way to query the test set's hardware configuration. This method uses your web browser to display a formatted report.

The GPIB query returns an unformatted character string that must be buffered and saved to an HTML file to provide formatted text.

LAN Query

  1. Refer to the SYSTEM CONFIG screen to determine the LAN address.
  2. Open a web browser and enter <LAN address>/iconfig. For example, if your LAN address is 130.2.2.147, you would enter:

    130.2.2.147/iconfig

  3. The web browser will then display formatted text. A partial list of the hardware configuration information is shown below:

GPIB Query

Use the following Basic example as a model to store the test set's configuration as an HTML file.

GPIB Example:

10    DIM Buf1$[20000],Buf2$[20000] ! This is the minimum space for the arrays
20    OUTPUT 714;"SYSTEM:CONFIGURE:INFORMATION:HARDWARE:VERBOSE?"
30    ENTER 714;Buf1$,Buf2$
40    CREATE "HW.htm",1              ! Create an HTML file
50    ASSIGN @File TO "HW.htm"
60    OUTPUT @File;Buf1$,Buf2$
70    END

In the future, the hardware configuration report may increase in length. More space would then need to be allocated for the arrays.

Display the HTML file using a web browser or HTML text editor.

Related Topics

SYSTem:CONFigure


Obtaining Identification Information (*IDN)

Obtaining Identification Information (*IDN)

Last updated: January 15, 2009

Description

Test set information is returned from a *IDN? query. The *IDN? query provides information about the Manufacturer, Model Number, Serial Number, and Firmware Revision. *IDN? is defined in IEEE Std. 488.2-1992, 10.14.

Test Set Information

*IDN? query returns identification information as a comma separated string.

DIM A$[100]
OUTPUT 714;"*IDN?" !returns manufacturer,model number, serial number and "0"
                   !separated by commas
ENTER 714;A$
PRINT A$           !prints, for example "Agilent Technologies, 8960 Series 10 E5515B,
                   !US38020105,0
  • Agilent Technologies is the manufacturer.
  • Printable ASCII characters excluding comma and semicolon up to a 25-character string.
    Model number example: 8960 Series 10 E5515B
  • Printable ASCII characters excluding comma and semicolon up to a 10-character string.
    Serial number example: US00000123
  • Printable ASCII characters excluding comma and semicolon up to a 20-character string.
    Firmware revision example: 0

NOTE
The *IDN? query will always indicate that the firmware revision is zero. SYSTem:APPLication[:CURRent]:REVision? is the recommended way to query the firmware revision.

Related Topics

Hardware Configuration Report


Instrument IP Info/Instrument IP Setup

Instrument IP Info/Instrument IP Setup

Description

The test set supports both IPv4 and IPv6 for IP connection. This page describes how to set up the IP parameters and get the IP information of the test set.

See the related topics at the bottom of this page on how to configure the LAN of the test set, the IPv4 and IPv6 addressing requirements.

Manual Operation: Instrument IP Info can be accessed by first pressing the SYSTEM CONFIG hardkey, go to Control 2 of 2 for the Instrument IP Info (F3) , and then press Instrument IP Setup for the Instrument IP Setup menu. Besides, LAN IP Address , LAN IP Address 2 (Data+) , Subnet Mask and Default Gateway in the Instrument IP Setup menu can also be accessed through Instrument Setup in Control 1 of 2 of SYSTEM CONFIG .

A typical display for the Instrument Setup menu and the Instrument IP Addressing screen is shown as below:

You can view the configured or derived IP information of the test set on the Instrument IP Addressing screen.

NOTE
On the Instrument IP Addressing screen, the IPv6 address (IID) for the LAN and LAN 2 are both derived from the MAC address of the test set. Besides, the IPv6 Link Local Prefix is showed as a fixed value.

Instrument IP Setup

  • LAN IP Address: sets the IPv4 address of the test set' LAN Port. GPIB example:

OUTPUT 714;"SYSTem:COMMunicate:LAN:SELF:ADDRess '130.015.156.255'"
  • LAN IP Address 2 (Data+): sets the IPv4 address of the test set's LAN 2 Port. Note that this setting is grayed out if your hardware does not support LAN 2 Port. If this setting is not grayed out, please make sure to set it correctly if you want to setup a packet data connection. This setting must not be identical to the LAN IP Address setting, and must be on the same subnet as the LAN IP Address setting. GPIB example:

OUTPUT 714;"SYSTem:COMMunicate:LAN:SELF:ADDRess2 '130.015.156.255'"
  • Subnet Mask: sets the Subnet Mask of the test set. GPIB example:

OUTPUT 714;"SYSTem:COMMunicate:LAN:SELF:SMASK '255.2.6.200'"
  • Default Gateway: sets the default gateway of the subnet. GPIB example:

OUTPUT 714;"SYSTem:COMMunicate:LAN:SELF:DGATEWAY '130.2.6.200'"
  • IPv6 Prefix, Upper/Lower (Hex)

    This parameter is an 8-digit number in hexadecimal which sets the upper or the lower part of the IPv6 prefix. The full-length IPv6 prefix is showed in the Instrument IP Addressing screen.

    If you leave this parameter blank, the test set will assign an all-zero IPv6 address prefix and an error will be displayed. You can only change the IPv6 prefix when the data connection status is Idle.

    You are not allowed to change the IPv6 prefix of the test set if the IPv6 Router State is On .

    This parameter is stored in the test set's non-volatile RAM and is not affected by power cycle, full preset or save/recall operations. GPIB example:

OUTPUT 714;"SYSTem:COMMunicate:LAN:ADDRess:IP6:PREFix '2009:8960:8960:8960'"
  • IPv6 Default Router Interface ID, Upper/Lower (Hex)

    The IPv6 Default Router Interface ID identifies the IPv6 default Router to which the test set sends packets. This is similar to the Default Gateway in IPv4. This parameter is an 8-digit number in hexadecimal which sets the upper or the lower part of the IPv6 Default Router Interface ID. The full-length IPv6 Default Router Interface ID is shown in the Instrument IP Addressing screen. GPIB example:

OUTPUT 714;" SYSTem:COMMunicate:LAN:DGATeway:IP6:IID '0000:0000:821D:B001'"

  • IPv6 Router State

    This setting is only applicable to the lab application .

    This setting enables or disables the IPv6 router state of the test set.

    If the IPv6 Router State is set to On , the test set acts as an IPv6 router, and the IPv6 servers in the same IPv6 segment will use it as a default IPv6 router to send the IPv6 packets. The IPv6 Router State is set to Off by default.

    Operating Considerations: When you don't need the test set to be an IPv6 router, it is strongly recommended you set the IPv6 Router State to Off . This is because if it is left On, the test set periodically broadcasts a Router Advertisement (RA) message and declares to the whole subnet that it is the default IPv6 router of the subnet. Turning it off can avoid the potential interference of the IPv6 routers and hosts in the same subnet. Besides, very quick back-and-forth operations (for instance a quick On-Off-On switching) is not recommended for this setting.

    GPIB example:

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:ROUTER:STATE:IP6 ON"

Related Topics

SYSTem:COMMunicate


IPv6 Address Requirements

IPv6 Address Requirements

  • IPv6 Address Representation
    • Zero compression
    • IPv4-compatible IPv6 addresses
  • IPv6 Address Structure
  • Types of IPv6 Addresses

IP version 4 (known as IPv4) has been widely used for decades of years and it is proven to be robust, easily implemented and interoperable. However, as the increasingly growth of the internet, IPv4 faces many problems: the impending exhaustion address space, large routing tables etc. IP version 6 (known as IPv6) is developed by Internet Engineering Task Force (IETF) to solve these problems.

IPv6 Address Representation

IPv6 addresses are 128-bit identifiers for interfaces and sets of interfaces. These 128 bit is divided to eight 16-bit blocks with each block is represented by a 4-digital hexadecimal number and separated by colons. For example: 2001:0DB8:0000:2F3B:02AA:00FF:FE28:9C5A. Uppercase or lower case is not sensitive for IPv6 addresses.

Zero compression

For the IPv6 addresses with long sequences of `0', double-colon "::" is used to compress the `0's in the contiguous sequence of 16-bit block to further simplify the representation. "::" indicates one or more groups of 16 bits of `0's and can also be used at the leading or trailing part of an address. For example: FE80:0:0:0:2AA:FF:FE9A:4CA2 can be further simplified by `0' compressing and turns to: FE80::2AA:FF:FE9A:4CA2.

The following formula can be used if you want to determine how many `0's are represented by the "::" :

the number of bits expressed by "::" = (8-number of blocks in the address)*16.

For example: in the address FE80::2AA:FF:FE9A:4CA2, there are 5 blocks. The number of bits expressed by the "::" is 48 (i.e. (8-5)*16=48).

Note that this compression can only appear once in a given IPv6 address, or you could not determine how many `0's are represented by each instance of "::".

IPv4-compatible IPv6 addresses

When dealing with a mixed environment of IPv4 and IPv6 nodes, x:x:x:x:x:x:d.d.d.d can be used as a more convenient form, where the 'x's are the hexadecimal values of the six high-order 16-bit pieces of the address, and the 'd's are the decimal values of the four low-order 8-bit pieces of the address (standard IPv4 representation). For example: "0:0:0:0:0:FFFF:129.144.52.38" and the compressed form "::FFFF:129.144.52.38" are all valid addresses.

IPv6 Address Structure

An IPv6 address is comprised of two portion: IPv6 Prefix and IPv6 interface ID.

  • An IPv6 prefix indicates the block of address space or a network. The IPv6 prefix follows the general IPv6 addressing rules and is represented as:

    IPv6 address/prefix length.

    Where IPv6 address represents the hexadecimal 128-bit address, and prefix length is a decimal value that indicates the number of contiguous, higher-order bits of the address that make up the network portion of the address. For example, "21DA:D3::/48" and "21DA:D3:0:2F3B::/64" are IPv6 address prefixes.

  • IPv6 Interface ID indicates the specific interface which is unique to the IPv6 prefix of the IPv6 address.

Types of IPv6 Addresses

In general, there are three types of IPv6 address: Unicast IPv6 Addresses, Multicast IPv6 Addresses and Anycast IPv6 Addresses.

  • An unicast address identifies a single interface within the scope of the type of unicast address. A packet sent to a unicast address is delivered to the interface identified by that address.

    For the Unicast IPv6 Addresses, there are many types: Global unicast addresses, Link local addresses etc. Global unicast addresses are globally routable and reachable on the IPv6 portion of the Internet.

    A prefix for link local addresses is always FE80::/64 with the interface ID be 64-bit length.

  • A multicast address identifies multiple interfaces (typically belonging to different nodes). A packet sent to an anycast address is delivered to one of the interfaces identified by that address.
  • An anycast address identifies a set of interfaces (typically belonging to different nodes). A packet sent to a multicast address is delivered to all interfaces identified by that address.

Related Topics

Instrument IP Info/Instrument IP Setup


Configuring the Test Set's LAN

Configuring the Test Set's LAN

Last updated: May 30, 2011

Description

LAN IP Address

CAUTION
Always verify that the test set is responding to a new LAN IP Address by pinging the test set. If the test set does not respond to the ping, cycle power. This will ensure that the test set will respond to the new LAN IP Address.

The LAN address is a character string with a maximum of 15 characters and a format of A.B.C. D where A is between 0 and 223 (excluding 127, which is assigned for use as the Internet host loopback address), and B, C, and D are between 0 and 255. No embedded spaces are allowed. The address may be manually set/viewed in the system configuration screen. The LAN address can be set/queried using the SYSTem subsystem.

The LAN address is a non-volatile parameter. The LAN address is not affected by any reset operation and can only be changed by direct access to the parameter itself.

NOTE
If the LAN address is set to a different network class, the subnet mask will change to the default net mask for the new network class.

For convenience the DATA port on the front panel may be configured as a LAN port. When an RJ45 jumper cable, (part number E5515-61160) is connected from the LAN PORT on the rear panel, to the ETHERNET TO FRONT PANEL port also on the rear panel, the user has LAN access from the front panel of the test set. Without the RJ45 jumper cable, the test set connection to a LAN is the rear-panel, LAN PORT connector.

The LAN address cannot be changed when the Operating Mode is set to Active Cell .

LAN Default Gateway

The LAN router, (default gateway), is a character string with a maximum of 15 characters and a format of A, B, C, D, where A is between 0 and 223 , and B, C, and D are between 0 and 255, no embedded spaces are allowed. If the default gateway is set to a format not allowed with the LAN address or the subnet mask that have been selected, the default gateway will be set to a null string, indicated by a blank field on the test set display. The address may be manually set/viewed in the system configuration screen. The LAN default gateway can be set/queried using the SYSTem subsystem.

The LAN default gateway is the address of a router that routes messages between networks and or subnets. If this value is not specified, LAN communications will be limited to the network and subnet specified by the LAN IP address and the subnet mask. Your network administrator will know if a default gateway is needed and if so, the address of the router. If the default gateway address is not needed by your network, it may be disabled by entering any of the following values: "0" (zero), "" (null string), "0.0.0.0"

The LAN default gateway is a non-volatile parameter. The LAN default gateway is not affected by any reset operation and can only be changed by direct access to the parameter itself.

LAN Subnet Mask

The LAN subnet mask address is a character string with a maximum of 15 characters and a format of A, B, C, D, where A , B, C, and D are between 0 and 255. No embedded spaces are allowed. The address may be manually set/viewed in the system configuration screen. The LAN subnet mask address can be set/queried using the SYSTem subsystem.

The subnet mask number combined with the IP address identifies which network and subnet your computer is on. Contact your system administrator for the correct subnet mask for your network.

The subnet mask determines the boundaries between the subnet ID and the host ID.

The LAN subnet mask is a non-volatile parameter. The LAN subnet mask is not affected by any reset operation and can only be changed by direct access to the parameter itself or by changes to the LAN IP Address.

NOTE
If the LAN address is set to a different network class, the subnet mask will change to the default net mask for the new network class.

The subnet mask number is obtained from your network administrator.

LAN 2 PORT

NOTE
You may not be able to set the LAN 2 PORT address due to hardware restriction. Contact your sales representative for more information.

The LAN 2 PORT allows you to use the Data Channel functionality with High Data Rate. To use the Data Channel functionality (to establish a Packet Data connection, for example), you must connect your data server to the LAN 2 PORT , rather than to the LAN 1 PORT as in the past.

Tip: The easiest way to identify whether the test set supports LAN 2 PORT is as follows: press the SYSTEM CONFIG hardkey, then press F1 ( Instrument Setup ) and go to the bottom of the Instrument IP Setup middle menu. Check if the LAN IP Address 2 (Data+) setting exists under the Restart on Fatal Error State setting, if not, then the test set does not support the LAN 2 PORT.

LAN 1 PORT is still used for all other LAN operations such as protocol logging, firmware downloads and screen captures.

The LAN 2 PORT connects directly to the test set's protocol processor.

You must configure the address of the LAN 2 PORT using the LAN IP Address 2 (Data+) setting (see LAN IP Address for general information about LAN IP addresses). LAN IP Address 2 (Data+) must not be identical to the LAN IP Address setting, and must be on the same subnet as the LAN IP Address setting. If LAN IP Address or Subnet Mask is changed such that LAN IP Address 2 (Data+) is identical to or is no longer on the same subnet as LAN IP Address , then LAN IP Address 2 (Data+) is set to 0.0.0.0 and a warning is posted.

Related Topics

SYSTem:COMMunicate


Amplitude Offset

Amplitude Offset

Last updated: January 7, 2010

Description

Amplitude offsets compensate for loss or gain between the test set's RF IN/OUT front panel connector and the mobile station's RF connector.

To access the amplitude offset feature, press the SYSTEM CONFIG key, followed by the RF IN/OUT Amptd Offset ( F5 ) key.

Amplitude offset settings are preserved during power cycles or instrument preset.

Setting Up Amplitude Offsets and Frequency Points

Up to 60 frequency points can be assigned an amplitude offset. Negative amplitude offset values should be entered when there is a loss through the RF cabling and test fixtures and positive values should be entered when there is a gain.

The RF IN/OUT Amplitude Offset table displays the current (on/off) state of the amplitude offset feature. You can also enter frequencies and the corresponding offset values from the front panel.

To set up amplitude offsets remotely, one comma-separated string is sent to set up frequency points and another comma-separated string assigns the corresponding amplitudes.

GPIB Commands

OUTPUT 714;"SYSTEM:CORRECTION:SFREQUENCY 1710.2 MHZ,1805.2 MHZ,1784.8 MHZ,1879.8 MHZ"
!sets the first 4 frequencies in the amplitude offset table.

OUTPUT 714;"SYSTEM:CORRECTION:SGAIN -2.55,-3.12,-3.68,-4.23"
!sets the first 4 amplitude offsets in the amplitude offset table.

Turning amplitude offsets on/off

When the RF IN/OUT Amplitude Offset State is on, all offsets that are not individually turned off are applied and the word "Offset" appears in the Instrument Status Area of the test set's display.

If the RF IN/OUT Amplitude Offset State is off, none of the amplitude offsets are applied.

GPIB Command

OUTPUT 714;"SYSTEM:CORRECTION:STATE ON"
!Sets the RF IN/OUT Amplitude Offset State to On

NOTE
If the RF IN/OUT Amplitude Offset State is turned off , none of the amplitude offsets are on, even if values are entered for the individual offsets.

Examples of Amplitude Offset Behavior

When the amplitude offset table entries accurately represent the loss in all components (cabling, connectors, and test fixturing) in the signal path between the test set and the mobile station, the test set will make the necessary adjustments in both receiver and transmitter measurements.

Mobile Station Receiver Example

When you set a transmit power level, the test set uses the amplitude offset value to adjust the power so that the test set's transmit power level refers to the power level received at the mobile station.

As shown in Amplitude Offset Mobile Station Receiver Example , with the test set's transmit power set to -85 dBm and a -3 dB amplitude offset the actual power level transmitted from the test set will be automatically offset to -82 dBm. With a 3 dB loss in the signal path the mobile station will receive -85 dBm, the actual setting.

Amplitude Offset Mobile Station Receiver Example

Mobile Station Transmitter Example

When you measure power from the mobile station, the displayed and queried values are offset to show the level at the mobile station.

As shown in Amplitude Offset Mobile Station Transmitter Example , with the mobile station transmitting 12 dBm and a -3 dB amplitude offset is entered, the measured power at the test set would be 9 dBm. The displayed power level is automatically adjusted to 12 dBm to show the level at the mobile station.

If the expected power, which can be set manually or automatically is 12 dBm, the test set's internal hardware adjusts itself to receive 9 dBm which is the actual power from the mobile station after 3 dB loss in the network.

Amplitude Offset Mobile Station Transmitter Example

Amplitude Offsets Between Frequency Settings

If mobile station testing is performed at frequencies that do not have amplitude offsets assigned to them, the test set will estimate an amplitude offset based on the nearest settings. For example, the following screen shows five amplitude offsets for frequencies ranging from 890.2 MHz to 1710.2 MHz.

RF IN/OUT Amplitude Offset Setup

For test frequencies between the lowest (890.2 MHz) and highest (1710.2 MHz) frequency points that are not entered in the table, the test set will calculate offsets using piece-wise linear interpolation.

The graph shown in Amplitude Offset Interpolation is a conceptual representation of the test set's amplitude offset configuration using the settings from the RF IN/OUT Amplitude Offset table in RF IN/OUT Amplitude Offset Setup . Each of the five points are shown on a non-scaled frequency versus amplitude offset graph. At a test frequency of 890.4 MHz, which is midway between point number one (-1 dB) and point number two (-2 dB) the test set applies an offset of -1.5 dB. Be aware that since amplitude offsets are in units of dB, this piece-wise linear interpolation does not produce a linear transition from point to point.

Amplitude Offset Interpolation

If testing is done outside the range of frequencies bounded by the lowest and highest frequency entries, the test set simply uses the amplitude offset that is paired with the nearest frequency point.

IMPORTANT
It is highly recommended that amplitude offsets are set up for each test frequency. This eliminates inaccuracies due to the mismatch between the test set's linear interpolation and the actual frequency response of the RF path between the test set and mobile station.

Related Topics

SYSTem:CORRection


Application Name

Application Name

Last updated: January 15, 2009

Description

The following queries give you details about the application name. To query or switch applications you must use the application's name as it appears in the catalog (without regard to case).

  • To query the name of the all applications installed in the test set use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME?"

  • To query the name of the selected application (running or not) use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME?"
  • To query the name of the currently running application use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:CURRENT:NAME?"

  • To query the number of applications installed in the test set use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME:COUNT?"

The application names can also be displayed in the Application Setup menu on the test set's display.

Related Topics

SYSTem:APPLication


Application Revisions and Licenses

Application Revisions and Licenses

Last updated: April 29, 2009

Description

Different revisions of the applications in your test set provide different capabilities. The selected application revision is loaded after the next application switch or power cycle of the test set. Once you select a revision the revision does not change unless you select another revision.

You can query the selected revision, all available revisions, and the total count of available revisions for a selected application. These queries are helpful when selecting revisions but are not usually necessary when switching applications.

NOTE
The Agilent E1960A GSM Mobile Test Application revisions prior to A.04.00 do not support application switching. If you select a revision prior to A.04.00 you will not have a path to switch back to later revisions.

If you accidentally switch to a non-supported revision, use the firmware upgrade process to load firmware with the correct revision.

Application Revision Queries and Commands

These are commands to query revision information or select a revision.

  • To query a selected application revision (running or not) use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION? `AMPS/136 MOBILE TEST'"
  • To query the revision of the application currently running use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:CURRENT:REVISION?"
  • To query all of the revisions available for a application use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION? `AMPS/136 MOBILE TEST'"
  • To select a revision of an application use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION `GSM mobile test','A.04.01'"

    After switching to a different revision of your application, you may need to calibrate the test set. See the on-line reference guide for your application for more information.

  • To query the number of revisions for a specified application:

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION:COUNT? `GSM MOBILE TEST'"

Application License Status Query

The application license status can be queried for a particular application and revision using the following GPIB query:

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:LICENSE? `GSM mobile test','A.04.01'"

This query returns one of the following:

  • "LIC" - This revision of application appears to have a LICense. The application may have been developed before licensing and therefore needs no license.
  • "NLIC" - This application does not appear to have a license. Selecting a Not LICensed revision will result in an error +130.
  • "PART" - Some PART of the application does not appear to have a license.
  • "UNKN" - This application has UNKNown license status.

You can also query a list of all licensed applications, formats and features using the following GPIB query:

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:ALL?"

NOTE
If you switch to a not licensed revision the test set will reboot to the SYSTEM CONFIG screen. You will be unable to select any other screen or make any measurements. Query or view the Application Setup menu to determine the licensed versions of applications available.

Revision and license information can be viewed and selected from the SYSTEM CONFIG screen, by selecting the Application Setup menu. Revisions are shown with their license status. After the revision number is a letter. That letter indicates the revision license status; Licensed "L", Not Licensed "N", or Unknown "U".

  • "L"- This revision of application appears to have a License. The application may have been developed before licensing and therefore needs no license.
  • "N" - This application does not appear to have a license. Selecting a Not licensed revision will result in an error +130.
  • "P" - Some Part of the application does not appear to have a license.
  • "U" - This application has Unknown license status.

Test Application Revision To Current (R2C) license

Agilent Revision To Current (R2C) is an agilent service to provide licensing for general test application functionalities added to the test set through a specified timeframe. R2C license information is displayed in the Instrument Information and License Status window after you press the SYSTEM CONFIG hardkey, or you can continue to press ( F10 ) License Status Detail and then ( F9 ) R2C License Coverage Info to get a display of the R2C license information.

  • Revision To Current (R2C) license coverage: The R2C license coverage is associated with a timeframe indicating that all test application functionalities before that timeframe are licensed.
  • Revision To Current (R2C) license status: indicates the status or authority of the R2C license installed in the test set.
    • L: Fully licensed. Installed R2C license enables access to all installed R2C licensed functionalities.
    • N: Not Licensed. No R2C license is installed on the test set. Access to R2C licensed functionalities will be restricted.
    • P: Installed R2C license enables access to some installed R2C-licensed functionalities.Access will be restricted for the R2C functionalities added after the R2C license coverage date.

These are commands to query the Revision To Current (R2C) license information.

  • To query the R2C license status, use this GPIB command:

OUTPUT 714;"SYSTem:APPLication:CATalog:R2Current:STATus?"
  • To query the coverage date of the installed R2C license, use this GPIB command:

OUTPUT 714;"SYSTem:APPLication:CATalog:R2Current:COVerage?"

Related Topics

Application Switching


Configuring System Time and Date

Configuring System Time and Date

Last updated: January 15, 2009

Description

The test set provides the following time and date settings:

  • Time

    This field provides entry of the local time in hours and minutes.

    The Universal Coordinated Time field will track changes made to the Time field.

  • Date

    This field provides entry of the local date.

  • Universal Coordinated Time (UTC)

    Also known as Zulu, Greenwich Mean Time, or UCT, this field provides entry of universal time in hours and minutes.

    The Time field will track changes made to the Universal Coordinated Time (UTC) field.

  • Universal Coordinated Time (UTC) Date
  • Time Zone

    The Time Zone field provides entry of a time offset to the universal coordinated time (UTC). Based on each new time zone setting and the current UTC, a new local time value is calculated and automatically entered into the Time field.

These features are accessed by pressing the SYSTEM CONFIG hardkey followed by the Instrument Setup ( F1 ) softkey.

Related Topics

SYSTem:DATE


Application Switching

Application Switching

Last updated: January 15, 2009

Description

Different radio formats (such as GSM, AMPS, CDMA 2000 or TIA/EIA 136) can be tested when additional applications are purchased from Agilent Technologies. The test set allows you to switch between different applications. A reboot is necessary to make a newly selected application functional. The reboot happens automatically when the you tell the test set to switch applications. Switching to another application takes about one minute.

Some radio formats are combined as fast switching applications. Switching formats in a fast switching application takes less than 2 seconds.

Application Switching GPIB Command

In order to switch to another application use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME `GSM MOBILE TEST'"

Sending this command causes the test set to reboot.

Application Revision and Licensing

Each application must have a valid license and revision to function. Licensed revisions of applications are available from Agilent Technologies.

It may take several seconds before revision, model, and name information is returned.

Application Switching Programming Example

This program example shows you how to switch to the GSM Mobile Test Application.

  1. Query the list of application names to get exact spelling of the GSM Mobile Test Application. This is not necessary if you already know the exact name.
  2. Query the test set to get a list of all revisions for "GSM Mobile Test." This is not necessary if you are not changing revisions.
  3. Select a revision of "GSM Mobile Test." This is required if you are changing revisions.
  4. Select the GSM test application. This will switch applications and cause the test set to reboot.

10    OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME?"
20    !Queries all of the application names
30    ENTER 714;N$
40    PRINT "The CATALOG names that are loaded are ";N$
50    OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION? `GSM MOBILE TEST'"
60    !Queries all revisions of GSM MOBILE TEST
70    ENTER 714;Cat_rev$
80    PRINT "The revisions for the GSM Mobile Test Application are ";Cat_rev$
90    OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION `GSM MOBILE TEST','A.04.01'"
100   !Selects a revision
110   OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME `GSM MOBILE TEST'"
120   !Switches the application to GSM MOBILE TEST
130   END

Related Topics

Application Revisions and Licenses


Timebase Description/Configuration

Timebase Description/Configuration

Last updated: January 15, 2009

Description

The time base source is selected by the test set, either an internal time base or an external source (if a suitable signal is detected) is used as the reference oscillator. If a 10 MHz +/- 100 ppm signal, that has an input level from 0 to +13 dBm is connected to the 10 MHz REF IN connector on the rear panel, the test set will automatically select the external timebase.

You can read the status window at the bottom of the test set display for the EXT REF indicator, or query the test set to verify if it is using an external time base or an internal time base. You may also query the test set to verify if the time base is locked. The reference oscillator functionality is controlled through the SYSTEM subsystem.

Example:

OUTPUT 714;"SYSTEM:ROSCILLATOR[:TIMEBASE]?" !returns INT or EXT
                                            !(internal or external) timebase.
OUTPUT 714;"SYSTEM:ROSCILLATOR:LOCKED?" !returns 1 or 0 (locked or unlocked)
                                        !condition for timebase

Related Topics

SYSTem:ROSCillator


User Calibration Summary

User Calibration Summary

Description

The test set provides the summary of the calibration that have been performed, which includes:

  • The exact time and temperature at which the calibration are performed, and whether the calibration is passed
  • CDMA GPSOne Time offset for both US Cellular and PCS band
  • Current Operating Temperature

The calibration summary are accessed by pressing the SYSTEM CONFIG hardkey followed by the User Calibration Summary ( F11 ) softkey. The following figure shows a typical user calibration summary.

Related Topics

Calibrating the Test Set


DUT IP Address

DUT IP Address

Last updated: February 13, 2012

This section is only applicable to the lab application.

Description

The test set provides a field for entering the IP Address for a wireless device being tested using the packet and CS (circuit switched) data channels.

There are two requirements for the DUT IP Address field:

  1. The network portion (see IP Address Formatting ) of the wireless device's DUT IP address must be the same as the network and subnet portion of the test set's LAN IP Address.
  2. The host portion of the wireless device's DUT IP address must be unique. (It should not be the same as any other host on the network or subnet that the test set is connected to.) In other words, DUT IP Address must be set to a different value in all test sets within the same network. Further, each DUT IP Address within the test set ( DUT IP Address , DUT IP Address 2 , etc.) must be set to a different value.

How Network Addresses Are Assigned

Network IDs are assigned by the NIC (Network Information Center). The network portion (first two bytes) of the class B address in the example above would be acquired from the NIC by a network administrator to avoid conflicts with other networks. The network administrator is then free to allocate subnets as needed since subnetting is not visible outside the network.

If you do not know the IP address the test set and/or DUT should be set to, or which unique host IDs are available, you should contact your network administrator.

How to Interpret IP Addresses

The network portion of the LAN IP Address depends on the address classification as shown below:

LAN IP Address Classification

Class A = 1.0.0.0 to 127.255.255.255
Class B = 128.0.0.0 to 191.255.255.255
Class C = 192.0.0.0 to 223.255.255.255
Class D = 224.0.0.0 to 247.255.255.255

An IP Address consists of a 4-byte (32 bit) number. Each byte is in a decimal form separated from other bytes by a dot. This is referred to as a "dotted decimal" format.

NOTE
The test set does not allow LAN IP Addresses in the range of 127.0.0.0 to 127.255.255.255 because these addresses are assigned for use as the Internet host loopback address.

The IP address class defines which bytes contain the network portion of the address. For Class A addresses, the first byte from the left identifies the network. For class B it is the first two bytes from the left, and for class C it is the first three bytes. Class D addresses are multicast, which are used when a datagram is directed to multiple hosts. See IP Address Formatting .

IP Address Formatting
Class | Byte 1 | Byte 2 | Byte 3 | Byte 4
A | Network | Host
B | Network |  | Host
C | Network |  |  | Host
D | Multicast

Determining the Test Set's Network Address

If the test set's LAN IP Address is set to 130.29.183.121, as shown below, the first two bytes represent the network portion since this is a Class B address.

If the test set is on a subnet, the Subnet Mask must be applied to determine the subnet address. This is done by performing bit-wise AND logic between the binary values of the LAN IP Address and Subnet Mask. See Applying the Subnet Address .

Applying the Subnet Address
LAN IP Address | 130 |  |  |  |  |  |  |  | 29 |  |  |  |  |  |  |  | 183 |  |  |  |  |  |  |  | 121
Subnet Mask | 255 |  |  |  |  |  |  |  | 255 |  |  |  |  |  |  |  | 255 |  |  |  |  |  |  |  | 0
Subnet Mask (Binary) | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
LAN IP Address (Binary) | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 1 | 0 | 1 | 1 | 1 | 1 | 0 | 0 | 1
Subnet Address (Binary) | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
Subnet Address | Network130 |  |  |  |  |  |  |  | Network 29 |  |  |  |  |  |  |  | Subnet 183 |  |  |  |  |  |  |  | Host 0

As shown in the table above, the Subnet Mask splits the 16 bit host portion of the class B address into an 8-bit subnet ID and an 8-bit host ID.

In this example the DUT IP Address would need to be set to 130.29.183.XXX to match the test set's subnet ID. The host portion of the LAN IP Address is identified by the bits corresponding to the 0 bits in the Subnet Mask. Therefore, the last byte in the DUT IP Address must not be 121 or any address that corresponds with any other host on the subnet at 130.29.183.XXX

This setting is non-volatile (it persists across partial and full presets and power-cycling the test set).

Additional Information

The IP address currently in use by the DUT is displayed in the DUT IP Address Information window.

When two test sets are connected using an External Device Connection , the DUT IP Address setting is inaccessible if the DUT is connected to the current test set using an IP address assigned by the other test set.

GPIB command: CALL:MS:IP:ADDRess

Related Topics

DUT IP Setup


3GPP Compliance

3GPP Compliance

Last updated: January 15, 2009

The test set's call processing behaviors and protocol message encoding are compliant with the 2002-03 release of the 3GPP R99 specifications.

For HSDPA features (lab application or feature-licensed test application only) , the test set is compliant with the 2004-12 release of the 3GPP Release 5 specifications.

For HSPA features (lab application or feature-licensed test application only) , the test set is compliant with the 2006-12 release of the 3GPP Release 6 specifications.

However, the test set always sends R99 variants of RRC messages unless specific Release 5 or Release 6 parameters need to be signaled.

Refer to the various "Ladder Diagrams" in this online guide for more details about protocol message sequences for specific call processing operations.

The test set's measurements are continually evolved to support 3GPP TS 34.121. See What 3GPP W-CDMA/HSPA Conformance Tests Are Supported? for more details.


Block Diagram

Block Diagram

Last updated: February 13, 2012

Description

RF Interface Module

Input and output signals are routed through the RF Interface module. The RF Interface module consists of:

  • A directional bridge for sampling incoming power.
  • Hybrid power splitters which create 4 bidirectional ports (two receiver ports and two source ports). The directional bridge couples power to the Power Detector.
  • RF amplifiers.
  • Video gain circuits.
  • Fast and thermal power detectors.

The RF Interface module provides two identical RF Source path connections to the In/Out port of the instrument. There is about 25 dB of isolation between the two source paths. There is about 35 dB of isolation between the source paths and either receiver path. The RFIO module has nominally 23 dB of insertion loss in the source path. A temperature sensing circuit facilitates compensation for path loss variation with temperature.

The source signals can be looped back through the input signal path to cross-calibrate the Measurement Downconverter and the Power Detector.

The sampled input power from the directional bridge can be amplified by as many as two 18 dB range amplifiers and then can be directed to the fast detector or the thermal detector. The input power to the fast detector is detected by a diode detector that is part of a feedback loop. The input to the thermal detector is measured in a bridge using a pair of RMS thermal detectors in a feedback loop.

Signal Downconversion

The test set's downconversion receiver section has two downconversion modules; a Measurement Downconversion Module for making measurements, and a Demodulation Downconversion Module for maintaining the radio link.

Demodulation Downconverter Module

The Demodulation Downconverter module is used as part of the demodulation receiver that maintains the radio link.

Measurement Downconverter Module

The Measurement Downconverter module provides high quality (wide dynamic range, spurious free) signals to the Analog To Digital Converter module's measurement sampler input.

The Measurement Downconverter module is designed for very high performance operation to ensure accurate and repeatable measurement results. The Measurement Downconverter module contains two downconversion stages, two local oscillators, and a logarithmic IF envelope detector . Both first and second LO synthesizers are tunable. The first LO is used when tuning to the RF input frequency, and the second LO is used when setting second IF frequency, which is fed to the measurement sampler on the Analog To Digital Converter module.

Link Subsystem

The Link Subsystem maintains the radio link for all CDMA formats. The Link Subsystem has two parts:

  • Protocol Processor
  • Optional Link Subsystem hardware

The Protocol Processor module is responsible for maintaining the radio link between the test set and the mobile station under test. The primary tasks of the Protocol Processor module are:

  • Generating the protocol messaging necessary for the forward channel and sending that protocol stream to the test set's RF source for transmission to the mobile station.
  • Decoding the protocol messaging received from the mobile station under test on the reverse channel.
  • Computing measurement results which are associated with data bits contained within the mobile stations messaging, such as bit error ratio and frame error rate.

The optional Link Subsystem hardware provides additional signaling link control for CDMA signaling formats. These include:

  • Layer 1 digital signal processing.
  • Providing I/Q baseband signals which are sent to the I/Q modulator in the RF Source

Analog To Digital Converter Module

Following the Measurement Downconverter and Demodulation Downconverter IF 1 is the Analog to Digital Converter module. The purpose of the Analog to Digital Converter module is to convert the downconverted analog signals into digital data streams which can be processed by the Digital Signal Processing module.

In order to maintain the radio link of non-CDMA formats, the downconversion path through the Demodulation Downconverter module has a dedicated A/D conversion path.

To optimize measurement throughput, the fast RF power detector also has a single dedicated A/D path. This allows power measurements, in many cases, to be made concurrently with other measurements. The two outputs from the Measurement Downconverter module and the Audio In signal share a single multiplexed A/D path.

The outputs of the various analog to digital converters on the Analog to Digital Converter module share a common data bus with the Digital Signal Processing module.

Digital Signal Processing Module

The Digital Signal Processing (DSP) module is responsible for a variety of tasks within the overall test set architecture. These tasks are:

  • Demodulate data from the radio under test (data received from the Demodulation Downconverter module) and sending the demodulated data bits to the Protocol Processor module.
  • For some systems, perform audio measurements using audio information sent to the DSP module from the Protocol Processor module.
  • Execute a variety of signal processing algorithms to perform measurements on the radio system of the currently loaded TA (data received from the power detector ADC, the measurement ADC and, in some cases, data received from the Demodulation Downconverter ADC).

The DSP processor communicates with the Host Processor and the Protocol Processor, as well as controlling the configuration and synchronization of the Analog To Digital Converter module.

Host Processor Module

The Host Processor module is responsible for a variety of tasks within the overall test set architecture. These tasks include:

  • Control of the manual user interface (MUI).
  • Executing commands and processing data received from the LAN interface.
  • Executing commands and processing data received from the GPIB interface.
  • Controlling hard disk access.
  • Control of all RF and audio hardware modules.
  • Routing measurement results received form the Digital Signal Processing and Protocol Processor modules to the appropriate output device (display, GPIB, LAN, serial, etc.).

Voltmeter/Counter

Voltmeter

The voltmeter is used to measure internal voltages for instrument self-diagnostics.

Frequency Counter

The Frequency Counter is used to measure external frequencies from the front panel Audio IN, High or Low BNC connectors, and to measure internal signals for diagnostics. The external input can receive a signal between 20 Hz and 50 MHz, with a level from 25 mV to 8 V rms.

Audio Section

Audio Analysis Path

Externally applied audio signals can be analyzed through the test set's DSP module for such characteristics as AC level, SINAD, or distortion.

The audio signal to be analyzed is input to the test set using the front panel Audio IN High/Low connectors. The signal is then routed to the Analog To Digital Converter module's measurement sampler for analysis by the DSP module.

The Audio In connector accepts signals from 20 Hz to 15 KHz, at input levels from 10 mV to 20 V peak.

Audio 1 Path

The Audio 1 path provides analog baseband signals used for frequency modulation of the test set's RF sources. Up to four separate audio sources may be summed together in any combination to provide the composite Audio 1 output. These include the external FM input, internal direct digital synthesis (DDS,) regenerated SAT, and audio echo input.

The external FM input accepts an externally supplied audio signal with a peak voltage between 0.25 and 2 V peak.

The internal DDS generates low distortion audio signals from DC to 20 KHz with 0.1 Hz resolution. One to four signals may be generated and internally summed, with independent level control of each waveform.

The SAT regeneration circuit outputs a signal which is phase-locked to a received SAT signal. This is useful for testing situations where the test set needs to emulate a mobile station.

The audio echo input is used for retransmitting the received audio after a selectable time delay, to check both radio transmit and receive paths simultaneously.

For most applications, only one or two of these Audio 1 path sources are enabled at any given time.

Audio 2 Path

The Audio 2 path provides a secondary means for sending analog baseband signals to the FM modulator. Audio 2 contains only one source, a DDS similar to that used for Audio 1.

Typically, the Audio 2 path DDS is used for cases where multiple signals must be summed together with the lowest possible distortion. Another potential use of Audio 2 would be to obtain higher output levels than Audio 1 is capable of (up to twice as much), assuming the two outputs are set to the same frequency and phase, and then summed together at the Baseband Generator module.

Audio 2 is rarely used in practice because the DDS used for Audio 2 is the same DDS that is used for the front panel audio output.

Audio Out Path

Any one of four inputs may be coupled to the front panel audio output connector. These include a 4 channel DDS (shared with Audio 2), receiver discriminator audio from the Demodulation Downconverter module, audio echo from the Analog To Digital Converter module, and audio vocoder.

The front panel output is capable of providing signal levels up to 9 V peak into > 600 ohm loads, and up to 0.8 V peak into an 8 ohm load (e.g. speaker). The output level is calibrated for all modes except discriminator audio,
The discriminator audio has an uncalibrated volume control provided due to the high tolerances involved.

Typically the DDS mode is used to feed the MIC input of a radio, or it may simply be used as a general purpose low distortion function generator.

Audio echo can be selected to route the received audio to the front panel audio output connector.

RF Sources

The test set has up to two identical RF sources. The RF sources are used to provide analog or digitally modulated RF carriers for use in parametric testing of mobile stations encompassing a variety of cellular radio formats. In general, the sources have a frequency range of 292 MHz to 2.7 GHz and an amplitude range of -10 dBm to -127 dBm.

The RF sources consist of a Synthesized Signal Generator module followed by a Vector Output module and an RF Attenuator module. Baseband modulation information is supplied to the RF sources from a Baseband Generator module preceded by an Audio Section module.

Baseband Generators

The purpose of the Baseband Generator module is to provide, for the modulation type currently in effect, properly formatted baseband signals to the modulation circuits on the RF Source modules.

The Baseband Generator performs several functions related to the generation and processing of these base-band modulation signals. These are:

  • Transform data and clock signals from the Protocol Processor module into base-band analog I/Q modulation signals for the I/Q modulator in the Vector Output module
  • Transform data from the Protocol Processor module into baseband FSK modulation for the FM modulator in the Signal Generator module
  • Provide baseband FM path source selection, gain adjustment and summing node for analog FM signals from the Audio module and internally generated baseband FSK signals which are output to the FM modulator in the Signal Generator module
  • Transform burst and adjacent timeslot signals from the Protocol Processor module into baseband burst modulation signals for the burst modulator in the Vector Output module


34.121 Preset Call Configurations

34.121 Preset Call Configurations

Last updated: December 22, 2011

This section is only applicable to the lab application or feature-licensed test application.

  • HSDPA 34.121 Preset Call Configurations
  • HSPA 34.121 Preset Call Configurations
  • HSPA+ 34.121 Preset Call Configurations
  • DC-HSDPA 34.121 Preset Call Configurations

The 34.121 Preset Call Configurations make it much simpler to configure the test set for 3GPP TS 34.121 HSPA tests from the front panel (the 34.121 Preset Call Configurations are only available from the front panel; there are no GPIB commands to configure these presets).

NOTE
To move between the preset configurations or between sub-tests while on a call, you must use the Transport Channel Reconfiguration to change the parameters that differ between the different preset configurations and sub-tests.

Operating Mode must be set to Cell Off before selecting one of the 34.121 preset call configurations.

HSDPA 34.121 Preset Call Configurations

The presets configure the test set as per 3GPP TS 34.121 v7.5.0.

HSDPA 34.121 Preset Call Configurations_1

5.2A, 5.2AA, 5.9A, 5.10A with QPSK 5.2C, 5.7A, 5.13.1A, 5.13.1AA, 5.13.2A with QPSK 5.2A, 5.2AA, 5.9A, 5.10A with 16QAM 5.2C, 5.7A, 5.13.1A, 5.13.1AA, 5.13.2A with 16QAM

6.3A with 16QAM

Call Parameters:

Channel Type

12.2k RMC + HSDPA

12.2k RMC + HSDPA

12.2k RMC + HSDPA

12.2k RMC + HSDPA

12.2k RMC + HSDPA

UL CL Power Ctrl Algorithm

Algorithm 2

Algorithm 2

Algorithm 2

Algorithm 2

Algorithm 2

HSDPA Parameters:

RB Test HS-DSCH Configuration Type

FRC

FRC

FRC

FRC

FRC

FRC Type

H-Set 1 QPSK

H-Set 1 QPSK

H-Set 1 16QAM

H-Set 1 16QAM

H-Set 1 16QAM

Number of Transmissions

4

4

4

4

1

RV Sequence

0,2,5,6,0,0,0,0 0,2,5,6,0,0,0,0

6,2,1,5,0,0,0,0

6,2,1,5,0,0,0,0

6,0,0,0,0,0,0,0

DeltaACK

8

8

8

8

8

DeltaNACK

8 8 8 8

8

DeltaCQI

8

7

8

7

8

Ack-Nack Repetition Factor

3

1

3

1

3

CQI Feedback Cycle (k)

4 ms

4 ms

4 ms

4 ms

4 ms

CQI Repetition Factor

2

1

2

1

2
Cell Parameters:

Default DPCH Offset (DOFF)

3 x 512 chips

3 x 512 chips

3 x 512 chips

3 x 512 chips

3 x 512 chips

Generator Info:

HSDPA Cell 1 Connected CPICH Level

-10 dB

-10 dB

-10 dB

-10 dB

-10 dB

HSDPA Cell 1 Connected DPCH Level

-9 dB -9 dB -9 dB -9 dB

-9 dB

HSDPA Cell 1 Connected PICH Level

-15 dB

-15 dB

-15 dB

-15 dB

-15 dB

HSDPA Cell 1 Connected P-CCPCH/SCH Level

-12 dB

-12 dB

-12 dB

-12 dB

-12 dB

HSDPA Cell 1 Connected HS-PDSCHs Level (Sum)

-3 dB

-3 dB

-3 dB

-3 dB

-3 dB

HSDPA Cell 1 Connected HS-SCCH 1 Level

-8 dB

-8 dB

-8 dB

-8 dB

-8 dB
HSDPA Cell 1 Connected HS-SCCH 2 Level State Off Off Off Off

Off
HSDPA Cell 1 Connected HS-SCCH 3 Level State Off Off Off Off

Off
HSDPA Cell 1 Connected HS-SCCH 4 Level State Off Off Off Off

Off

Uplink Parameters:

Uplink DPCH Bc/Bd Control

Manual

Manual

Manual

Manual

Manual

Manual Uplink DPCH Bc

  • Sub-test 1: 2
  • Sub-test 2: 12
  • Sub-test 3: 15
  • Sub-test 4: 15
  • Sub-test 1: 2
  • Sub-test 2: 12
  • Sub-test 3: 15
  • Sub-test 4: 15
  • Sub-test 1: 2
  • Sub-test 2: 12
  • Sub-test 3: 15
  • Sub-test 4: 15
  • Sub-test 1: 2
  • Sub-test 2: 12
  • Sub-test 3: 15
  • Sub-test 4: 15
 15

Manual Uplink DPCH Bd

  • Sub-test 1: 15
  • Sub-test 2: 15
  • Sub-test 3: 8
  • Sub-test 4: 4
  • Sub-test 1: 15
  • Sub-test 2: 15
  • Sub-test 3: 8
  • Sub-test 4: 4
  • Sub-test 1: 15
  • Sub-test 2: 15
  • Sub-test 3: 8
  • Sub-test 4: 4
  • Sub-test 1: 15
  • Sub-test 2: 15
  • Sub-test 3: 8
  • Sub-test 4: 4
 8

RB Test Mode Setup:

Maximum Uplink Transmit Power Level

+21 dBm

+21 dBm

+21 dBm

+21 dBm

+21 dBm

UE Loopback Type

Type 1

Type 1

Type 1

Type 1

Type 1

HSDPA 34.121 Preset Call Configurations_2
 | s9.3.1 (Cat 1 to 6): HSDPA: 16QAM | s9.3.1 (Cat 7 to 8): HSDPA: 16QAM | s9.3.1 (Cat 11 to 12): HSDPA: QPSK | s9.3.1 (Cat 9, 10, 13, 14, 17, 18): HSDPA: 16QAM | s9.3.1 (Cat 13, 14, 17, 18): HSDPA: 64QAM
AWGN Power | -60 dBm/3.84 MHz | -60 dBm/3.84 MHz | -60 dBm/3.84 MHz | -60 dBm/3.84 MHz | -60 dBm/3.84 MHz
HSDPA Cell 1Connected HS-PDSCHs (Sum) | -3 dB | -3 dB | -3 dB | -3 dB | -2 dB
HSDPA Cell 1 Connected HS-SCCH 1 Level | -10 dB | -10 dB | -10 dB | -10 dB | -12 dB
HSDPA Cell 1 Connected HS-SCCH 2 Level | OFF | OFF | OFF | OFF | OFF
HSDPA Cell 1 Connected HS-SCCH 3 Level | OFF | OFF | OFF | OFF | OFF
HSDPA Cell 1 Connected HS-SCCH 4 Level | OFF | OFF | OFF | OFF | OFF
HSDPA Cell 1 Connected DPCH Level | -10 dB | -10 dB | -10 dB | -10 dB | -12 dB
HSDPA Cell 1 Connected CPICH Level | -10 dB | -10 dB | -10 dB | -10 dB | -10 dB
HSDPA Cell 1 Connected P-CCPCH/SCH Level | -12 dB | -12 dB | -12 dB | -12 dB | -12 dB
HSDPA Cell 1 Connected PICH Level | -15 dB | -15 dB | -15 dB | -15 dB | -15 dB
Channel Type | 12.2k RMC + HSDPA | 12.2k RMC + HSDPA | 12.2k RMC + HSDPA | 12.2k RMC + HSDPA | 12.2k RMC + HSDPA
Default DPCH Offset (DOFF) | 3 x 512 chips | 3 x 512 chips | 3 x 512 chips | 3 x 512 chips | 3 x 512 chips
Uplink DPCH Bc/Bd Control | Manual | Manual | Manual | Manual | Manual
Manual Uplink DPCH Bc | 8 | 8 | 8 | 8 | 8
Manual Uplink DPCH Bd | 15 | 15 | 15 | 15 | 15
Maximum Uplink Transmit Power Level | +33 dBm | +33 dBm | +33 dBm | +33 dBm | +33 dBm
UL CL Power Ctrl Algorithm | Algorithm 1 | Algorithm 1 | Algorithm 1 | Algorithm 1 | Algorithm 1
Number of Transmissions | 1 | 1 | 1 | 1 | 1
RV Sequence | 0 | 0 | 0 | 0 | 0
DeltaACK | 3 | 3 | 3 | 3 | 3
DeltaNACK | 3 | 3 | 3 | 3 | 3
DeltaCQI | 5 | 5 | 5 | 5 | 5
Ack-Nack Repetition Factor | 1 | 1 | 1 | 1 | 1
CQI Feedback Cycle (k) | 2 ms | 2 ms | 2 ms | 2 ms | 2 ms
CQI Repetition Factor | 1 | 1 | 1 | 1 | 1
RB Test HS-DSCH Configuration Type | User Defined | User Defined | User Defined | User Defined | User Defined
User Defined Transport Block Size Index | 8 | 8 | 43 | 8 | 9
User Defined Modulation Type | 16QAM | 16QAM | QPSK | 16QAM | 16QAM
User Defined Inter-TTI Interval | 3 | 3 | 3 | 3 | 3
User Defined Number of HARQ Processes | 2 | 2 | 2 | 2 | 2
User Defined UE IR Buffer Allocation | Explicit | Explicit | Explicit | Explicit | Explicit
User Defined Explicit UE IR Buffer Size | 9600 | 19200 | 4800 | 28800 | 44000
User Defined HS-DSCH MAC Entity | MAC-hs | MAC-hs | MAC-hs | MAC-hs | MAC-ehs
User Defined Number of Active HS-PDSCHs | 5 | 5 | 5 | 5 | 5
Meas Pow Offset | AUTO | AUTO | AUTO | AUTO | AUTO
HS-SCCH 1 Channelization Code | 2 | 2 | 2 | 2 | 2
Cell Power | -50 dBm | -50 dBm | -50 dBm | -50 dBm | -45 dBm
statDTX Reception Behavior | Handle As ACK | Handle As ACK | Handle As ACK | Handle As ACK | Handle As ACK
RB Test Mode First HS-PDSCH Channel Code | 5 | 5 | 5 | 5 | 5
User Defined 64QAM State | - | - | - | - | On

HSPA 34.121 Preset Call Configurations

The presets configure the test set as per 3GPP TS 34.121 v8.10.0.

HSPA 34.121 Preset Call Configurations

5.2B, 5.9B, 5.10B, and 5.13.2B:HSPA:QPSK 5.2D:HSPA:QPSK

Call Parameters:

Channel Type

  • sub test 1 to 4: 12.2k RMC + HSPA
  • sub test 5: HSPA
 12.2k RMC + HSPA

UL CL Power Ctrl Algorithm

  • sub test 1 to 4: Algorithm 2
  • sub test 5: Algorithm 1
 Algorithm 2

HSDPA Parameters:

RB Test HS-DSCH Configuration Type

FRC

FRC

FRC Type

H-Set 1 QPSK

H-Set 1 QPSK

Number of Transmissions

4

4

RV Sequence

0,2,5,6,0,0,0,0 0,2,5,6,0,0,0,0

DeltaACK

  • sub test 1 to 4: 8
  • sub test 5: 0
 8

DeltaNACK

  • sub test 1 to 4: 8
  • sub test 5: 0
 8

DeltaCQI

  • sub test 1 to 4: 8
  • sub test 5: 0
 8

Ack-Nack Repetition Factor

3

3

CQI Feedback Cycle (k)

4 ms

4 ms

CQI Repetition Factor

2

2

Generator Info:

HSPA Cell 1 Connected CPICH Level

-10 dB

-10 dB

HSPA Cell 1 Connected P-CCPCH/SCH Level

-12 dB

-12 dB

HSPA Cell 1 Connected PICH Level

-15 dB

-15 dB

HSPA Cell 1 Connected DPCH Level

-10 dB -10 dB
HSPA Cell 1 Connected E-AGCH Level | -20 dB | -20 dB
HSPA Cell 1 Connected E-HICH Level | -20 dB | -20 dB
HSPA Cell 1 Connected E-RGCH Level | Off | Off

HSPA Cell 1 Connected HS-PDSCHs Level (Sum)

-3 dB

-3 dB

HSPA Cell 1 Connected HS-SCCH 1 Level

-8 dB

-8 dB
HSPA Cell 1 Connected HS-SCCH 2 Level State | Off | Off
HSPA Cell 1 Connected HS-SCCH 3 Level State | Off | Off
HSPA Cell 1 Connected HS-SCCH 4 Level State | Off | Off

Uplink Parameters:

Uplink DPCH Bc/Bd Control

Manual

Manual

Manual Uplink DPCH Bc

  • Sub-test 1: 11
  • Sub-test 2: 6
  • Sub-test 3: 15
  • Sub-test 4: 2
  • Sub-test 5: 15
  • Sub-test 1: 11
  • Sub-test 2: 6
  • Sub-test 3: 15
  • Sub-test 4: 2

Manual Uplink DPCH Bd

  • Sub-test 1: 15
  • Sub-test 2: 15
  • Sub-test 3: 9
  • Sub-test 4: 15
  • Sub-test 5: 0
  • Sub-test 1: 15
  • Sub-test 2: 15
  • Sub-test 3: 9
  • Sub-test 4: 15

RB Test Mode Setup:

Maximum Uplink Transmit Power Level

+21 dBm

+21 dBm

UE Loopback Type

Type 1

Type 1
HSUPA Parameters:

RB Test Mode E-RGCH Information State | Off | Off

RB E-DPDCH Max Channel Codes (12.2k + HSPA)

  • Sub-test 1: 2SF4
  • Sub-test 2: 2SF4
  • Sub-test 3: 2SF4
  • Sub-test 4: 2SF4
  • Sub-test 5: SF4 ( RB E-DPDCH Max Channel Codes (HSPA) )
  • Sub-test 1: 2SF4
  • Sub-test 2: 2SF4
  • Sub-test 3: 2SF4
  • Sub-test 4: 2SF4
RB E-DPDCH Max Channel Codes (HSPA) | 2936 | 2936

E-DCH TTI

  • Sub-test 1: 10 ms
  • Sub-test 2: 10 ms
  • Sub-test 3: 10 ms
  • Sub-test 4: 10 ms
  • Sub-test 5: 10 ms
 NA
E-DPCCH/DPCCH Power Offset (DeltaE-DPCCH)
  • Sub-test 1: 6
  • Sub-test 2: 8
  • Sub-test 3: 8
  • Sub-test 4: 5
  • Sub-test 5: 0
  • Sub-test 1: 6
  • Sub-test 2: 8
  • Sub-test 3: 8
  • Sub-test 4: 5

E-TFCI Table Index (10 ms TTI)

  • Sub-test 1: 0
  • Sub-test 2: 0
  • Sub-test 3: 0
  • Sub-test 4: 0
  • Sub-test 5: 0
 NA
Predefined Reference E-TFCI Power Offsets
  • Sub-test 1: Definition 34121-01: v7.4.0 Table 5.2B.2
  • Sub-test 2: Definition 34121- 01:34.121 v7.4.0 Table 5.2B.2
  • Sub-test 3: Definition 34121- 02:34.121 v7.4.0 Table 5.2B.3
  • Sub-test 4: Definition 34121- 01:34.121 v7.4.0 Table 5.2B.2
  • Sub-test 5: Definition 34.121- 03:34.121 v8.8.0 Table 5.2B.3A
  • Sub-test 1: Definition 34121- 01:34.121 v7.4.0 Table 5.2B.2
  • Sub-test 2: Definition 34121- 01:34.121 v7.4.0 Table 5.2B.2
  • Sub-test 3: Definition 34121- 01:34.121 v7.4.0 Table 5.2B.3
  • Sub-test 4: Definition 34121- 01:34.121 v7.4.0 Table 5.2B.2
AG Mode
  • Sub-test 1: Single
  • Sub-test 2: Single
  • Sub-test 3: Single
  • Sub-test 4: Single
  • Sub-test 5: Single
  • Sub-test 1: Pattern
  • Sub-test 2: Pattern
  • Sub-test 3: Pattern
  • Sub-test 4: Pattern

Single Shot AG

  • Sub-test 1: Index 20: (119/15)^2
  • Sub-test 2: Index 12: (47/15)^2
  • Sub-test 3: Index 15: (67/15)^2
  • Sub-test 4: Index 17: (84/15)^2
  • Sub-test 5: Index 12: (47/15)^2
 NA
RB Setup AG
  • Sub-test 1: 26: (119/15)^2
  • Sub-test 2: 18: (47/15)^2
  • Sub-test 3: 21: (67/15)^2
  • Sub-test 4: 23: (84/15)^2
  • Sub-test 5: 18:(47/15)^2
  • Sub-test 1: 26: (119/15)^2
  • Sub-test 2: 18: (47/15)^2
  • Sub-test 3: 21: (67/15)^2
  • Sub-test 4: 23: (84/15)^2
Absolute Grant Pattern - Length | N/A | 20: (119/15)^2
Absolute Grant Pattern - Value 2 (See Absolute Grant Pattern Values )
  • Sub-test 1: Ind 31:((168/15)^2)x6
  • Sub-test 2: Ind 31: ((168/15)^2)x6
  • Sub-test 3: Ind 31: ((168/15)^2)x6
  • Sub-test 4: Ind 31: ((168/15)^2)x6
  • Sub-test 5: Ind 31: ((168/15)^2)x6
  • Sub-test 1: Ind 20: (119/15)^2
  • Sub-test 2: Ind 12: (47/15)^2
  • Sub-test 3: Ind 15: (67/15)^2
  • Sub-test 4: Ind 17: (84/15)^2
E-TFCI Rec Count | 15 | 15

HSPA+ 34.121 Preset Call Configurations

The presets configure the test set as per 3GPP TS 34.121.

HSPA+ 34.121 Preset Call Configurations

s6.3B: HSPA+: 64QAM 5.2E:HSPA+:UL 16QAM 5.13.1AAA,5.13.2C:HSPA+:UL 16QAM

Uplink DPCH Bc/Bd Control

Manual

Manual

Manual

Reference E-TFCI Power Offset Control

Predefind

Predefind

Manual Uplink DPCH Bc

8
  • Sub-test 1: 15

  • Sub-test 1: 15

Manual Uplink DPCH Bd

15

Channel Type

12.2k RMC + HSDPA

HSPA

HSPA

UE Loopback Type

Type 1

Type 1

Type 1

RB Test HS-DSCH Configuration Type

FRC

FRC

FRC

FRC Type

H-Set 8 64QAM

H-Set 1 QPSK

H-Set 1 QPSK

Number of Transmissions

1

4

4

RV Sequence

6,0,0,0,0,0,0,0

0,2,5,6,0,0,0,0

0,2,5,6,0,0,0,0

DeltaACK

3

8

8

DeltaNACK

3

8

8

DeltaCQI

5

8

8

Ack-Nack Repetition Factor

1

3

3

CQI Feedback Cycle (k)

2 ms

4 ms

4 ms
CQI Repetition Factor

1

2

2
Default DPCH Offset (DOFF)

3 x 512 chips

UL CL Power Ctrl Algorithm

Algorithm 2

Algorithm 2

Algorithm 2

HSDPA Cell 1 Connected CPICH Level

-10 dB

-10 dB

-10 dB

HSDPA Cell 1 Connected DPCH Level

-13 dB

-10 dB

-10 dB

HSDPA Cell 1 Connected PICH Level

-15 dB

-15 dB

-15 dB

HSDPA Cell 1 Connected P-CCPCH/SCH Level

-12 dB

-12 dB

-12 dB

HSDPA Cell 1 Connected HS-PDSCHs Level (Sum)

-2 dB

-3 dB

-3 dB

HSDPA Cell 1 Connected HS-SCCH 1 Level

-13 dB

-8 dB

-8 dB
HSDPA Cell 1 Connected HS-SCCH 2 Level | Off | Off | Off
HSDPA Cell 1 Connected HS-SCCH 3 Level | Off | Off | Off
HSDPA Cell 1 Connected HS-SCCH 4 Level | Off | Off | Off

HSPA Cell 1 Connected E-AGCH Level

-20.0 dB

-20.0 dB

" HSPA Cell 1 Connected E-HICH Level

-20.0 dB

-20.0 dB

HSPA Cell 1 Connected E-RGCH Level

Off

Off

Maximum Uplink Transmit Power Level

+33 dBm +21 dBm +21 dBm

E-TFCI Recording Count

15

15

E-DCH RLC SDU Size

8808

8808

RB Test Mode E-RGCH Information State

Off

Off

Predefined Reference E-TFCI Power Offsets

Definition 34121-04:34.121 v8.10.0 Table 5.2E.2

Definition 34121-04:34.121v8.10.0 Table 5.2E.2

HSUPA TTI Mode

2ms TTI

2ms TTI
Absolute Grant Mode

Pattern

Single Shot

Absolute Grant Pattern - Value 1 (Alternative)

1: Zero_Grant

BetaEd Gain E-AGCH Table

1

1

E-TFC Boost Info State

On

On
Delta T2TP

2

2
RB Test Mode First HS-PDSCH Channel Code 1

E-DPCCH/DPCCH Power Offset (DeltaE-DPCCH)

  • Sub-test 1: 8

  • Sub-test 1: 8
E-DCH 16QAM State

  • Sub-test 1: On
  • Sub-test 1: On

E-TFCI Table Index (2ms TTI with 16QAM)

  • Sub-test 1: 2
  • Sub-test 1: 2

Initial (RB Setup) Absolute Grant (16QAM)

  • Sub-test 1: 17: (75/15)^2

  • Sub-test 1: 17: (75/15)^2

Absolute Grant Pattern - Value 2 (Alternative)

  • Sub-test 1: 14: (75/15)^2
  • Sub-test 1: 14: (75/15)^2
E-TFCI Boost

  • Sub-test 1: 105
  • Sub-test 1: 105
E-DPDCH Power Calculation Formula"

  • Sub-test 1: Extrapolation

  • Sub-test 1: Extrapolation

DC-HSDPA 34.121 Preset Call Configurations

The presets configure the test set as per 3GPP TS 34.121 v7.5.0.

DC-HSDPA 34.121 Preset Call Configurations
 | 6.3C:DC-HSDPA:16QAM | 6.3D:DC-HSDPA:64QAM
Call Parameters:
Cell Power | -25.7 dBm / 3.84 MHz | -25.7 dBm / 3.84 MHz
Channel Type | 12.2k RMC + HSDPA | 12.2k RMC + HSDPA
UE Target Power | - | 0 dBm
UL CL Power Ctrl Algorithm | Two | Two
HSDPA Parameters:
RB Test HS-DSCH Configuration Type | User Defined | FRC
FRC Type | - | H-Set 8A 64QAM
RB Test User Defined DC-HSDPA State | On | -
RB Test Mode DC-HSDPA DPCH Loopback State | On | On
RB Test User Defined HS-DSCH MAC entity | MAC-ehs | -
RB Test User Defined HARQ Processes | 2 | -
RB Test User Defined UE IR Buffer Allocation | Explicit | -
RB Test User Defined Explicit UE IR Buffer Size | 9600 | -
HSDPA Parameters -> HSDPA RB Test Mode Setup -> Serving Cell Parms
RB Test User Defined 64QAM State | Off | -
RB Test User Defined MAC-ehs HS-DSCH TB size table | Bit Aligned | -
RB Test User Defined Active HS-PDSCHs | 4 | -
RB Test User Def Transport Block Size Index | 36 | -
RB Test User Defined Modulation Type | 16QAM | -
RB Test User Defined Inter-TTI Interval | 3 | -
HSDPA Parameters -> HSDPA RB Test Mode Setup -> Secondary Cell Parms
RB Test User Def Secondary Cell 64QAM State | Off | -
RBTM User Def Sec Cell HS-DSCH TBS Table | Bit Aligned | -
RBTM User Def Sec Cell Active HS-PDSCHs | 4 | -
RBTM User Def Sec Cell TB Size Index | 36 | -
RBTM User Def Sec Cell Modulation Type | 16QAM | -
RBTM User Def Sec Cell Inter-TTI Interval | 3 | -
HSDPA Parameters -> Meas Pow Offsets Parameters
Serving Cell Meas Power Offset | 6,0 dB(Manual) | 6,0 dB(Manual)
Secondary Serving Cell Meas Power Offset | 6,0 dB(Manual) | 6,0 dB(Manual)
HSDPA Parameters -> MAC-(e)hs Parameters
Number of Transmissions | 1 | 1
RV Sequence | 6,0,0,0,0,0,0,0 | 6,0,0,0,0,0,0,0
HSDPA Parameters -> HSDPA Uplink Parameters
DeltaACK | 3 | 3
DeltaNACK | 3 | 3
DeltaCQI | 5 | 5
Ack-Nack Repetition Factor | 3 | 3
CQI Feedback Cycle (k) | 2 ms | 2 ms
CQI Repetition Factor | 1 | 1
HSDPA Parameters -> Secondary Serv Cell Parms
Secondary Serving Cell Power (dBm/3.84 MHz) | -25.7 dBm | -25.7 dBm
Cell Parameters
Default DPCH Offset (DOFF) | 3 x 512 chips | 3 x 512 chips
Downlink Channel Codes
PICH Channelization Code | - | 2
HSDPA/HSPA DPCH 30 ksps (OVSF 128) Code | - | 4
RB Test Mode First HS-PDSCH Channel Code | - | 1
HS-SCCH 1 Channelization Code | - | 2
HS-SCCH 2 Channelization Code | - | 3
RBTM Secondary Cell First HS-PDSCH Chan Code | - | 1
Downlink Channel Levels -> Connected DL Channel Levels -> HSDPA Conn DL Channel Levels
HSDPA Cell 1 Connected CPICH Level |  |
HSDPA Cell 1 Connected CPICH Level | -10 dB | -10 dB
HSDPA Cell 1 Connected P-CCPCH/SCH Level | -12 dB | -12 dB
HSDPA Cell 1 Connected PICH Level | -15 dB | -15 dB
HSDPA Cell 1 Connected DPCH Level | -13.0 dB | -13.0 dB
HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) | -3 dB | -2 dB
HSDPA Cell 1 Connected HS-SCCH 1 Level | -13.0 dB | -13.0 dB
HSDPA Cell 1 Connected HS-SCCH 2 Level | Off | -13.0 dB
HSDPA Cell 1 Connected HS-SCCH 3 Level State | Off | Off
HSDPA Cell 1 Connected HS-SCCH 4 Level State | Off | Off
Secondary Cell HSDPA Conn CPICH Level | -10.0 dB | -10.0 dB
Secondary Cell HSDPA Conn PCCPCH/SCH Level | -12.0 dB | -12.0 dB
Secondary Cell HSDPA Conn PICH Level | -15.0 dB | -15.0 dB
Secondary Cell HSDPA Conn HS-PDSCHs Lvl (Sum) | -3.0 dB | -2.0 dB
Secondary Cell HSDPA Conn HS-SCCH 1 Level | -13.0 dB | -13.0 dB
Secondary Cell HSDPA Conn HS-SCCH 2 Level | Off | -13.0 dB
Secondary Cell HSDPA Conn HS-SCCH 3 Level | Off | Off
Secondary Cell HSDPA Conn HS-SCCH 4 Level | Off | Off
Uplink Parameters:
Uplink DPCH Bc/Bd Control | Manual | Manual
Manual Uplink DPCH Bc | 8 | 8
Manual Uplink DPCH Bd | 15 | 15
Maximum Uplink Transmit Power Level | +33 dBm | +33 dBm
RB Test Mode Setup:
UE Loopback Type | Type 1 | Type 1

Related Topics

Manual Operation: How Do I Use the 34.121 Preset Call Configurations?


Active Cell Operating Mode

Active Cell Operating Mode

Last updated: May 30, 2011

  • Active Cell Overview
  • Active Cell Features
  • Active Cell Operating Considerations
  • HSDPA in Active Cell Operating Mode ( lab application or feature-licensed test application only )
  • HSPA in Active Cell Operating Mode (lab application or feature-licensed test application only)

Active Cell Overview

The Active Cell Operating Mode allows you to make a signalling connection between the test set (emulating a base station (BS) in a network) and a UE (mobile station). The types of connections available are described in Current Service Type . When connected (and during the connection process for some measurements), the UE's performance can be measured using the suite of measurements shown when the Measurement selection key or Instrument selection key is pressed.

The following example selects Active Cell Operating Mode via GPIB:

OUTPUT 714;"CALL:OPERating:MODE CALL"

Active Cell Features

You can configure the test set's base station emulator using the parameters described in Base Station Emulator Configuration .

While operating in Active Cell mode the test set is capable of performing many call processing operations (such as Performing a Location Update (CS Domain Registration) , Establishing a Connection with the UE , and Handovers ) as described in Call Processing Status and Operations .

Active Cell Operating Considerations

Many of the settings used in active cell mode cannot be changed during active cell mode operation. A message is displayed to alert you to this situation if you try to change them. These are settings that must be set before attempting to get the UE connected on a call, or settings that are not normally changed during base station operation in a network. Use the Cell Off operating mode to change these settings. See CALL:OPERating to select operating modes.

HSDPA in Active Cell Operating Mode

This section is only applicable to the lab application or feature-licensed test application.

HSDPA Activation in Active Cell

In active cell operating mode, HSDPA is active when HS-SCCHs are being generated by the test set (even if HSDPA Cell 1 Connected HS-SCCH 1 Level is turned off). HS-SCCHs are created when an RB Setup message is sent to the UE as part of a service setup that includes an HSDPA channel configuration.

In active cell operating mode, you can establish two types of HSDPA connections:

  • HSDPA RB Test Mode connection ( lab application or feature-licensed test applications only ) - see Establishing an HSDPA Connection for instructions on establishing the connection and Call Processing Ladder Diagrams to see when the RB Setup message is sent.
  • HSDPA Packet Data connection ( lab application only ) - see Establishing a Packet Data Connection for instructions on establishing the connection and GPRS Packet Data Service Ladder Diagrams to see when the RB Setup message is sent.

HSDPA Operation in Active Cell

When on an HSDPA RB Test Mode connection, in addition to the 12.2k RMC and common channels, the test set transmits HS-PDSCHs (the number is determined by the FRC Type or User Defined Number of Active HS-PDSCHs settings). When on an HSDPA Packet Data connection ( lab application only ), in addition to the common channels, the test set transmits HS-PDSCHs (the number is determined by the PS Data Configuration Type setting and the Current UE HS-DSCH Category ).

The test set can transmit up to 4 HS-SCCHs (you directly specify how many HS-SCCHs you want the test set to transmit using the HSDPA Connected DL Channel Levels ). However, HS-SCCH 1 is the only HS-SCCH ever directed to the UE (see H-RNTI Parameters ).

When HSDPA is active, the test set also generates a six-channel OCNS as specified by 3GPP TS 34.121 sE.5.2 (codes 122 - 127, spreading factor 128), rather than the OCNS defined in sE.3.6 (see OCNS in HSDPA/HSPA ).

You can configure the downlink code channel levels and channelization codes that are used when HSDPA is active using the HSDPA/HSPA DL Channel Codes and HSDPA Connected DL Channel Levels .

You can configure many aspects of the HSDPA functionality using the HSDPA Parameters :

  • HSDPA PS Data Setup ( lab application only )
  • HSDPA RB Test Mode Settings
  • MAC-hs Parameters
  • HSDPA Uplink Parameters
  • H-RNTI Parameters

The HSDPA Information screen displays UE HS-DSCH category information as well as counters to help you monitor the HSDPA connection status.

You can vary the timing between the uplink DPCH and uplink HS-DPCCH using the Default DPCH Offset (DOFF) parameter.

HSPA in Active Cell Operating Mode

This section is only applicable to the lab application or feature-licensed test application.

When on an HSPA RB Test Mode connection or HSPA PS Data connection, in addition to the 12.2k RMC and common channels the test set transmits HSDPA channels (HS-PDSCHs and HS-SCCHs) and HSUPA channels (E-HICH, E-AGCH, and E-RGCH). The test set also generates the same six-channel OCNS used for HSDPA connections (3GPP TS 34.121 sE.5.2).

You can configure the downlink code channel levels and channelization codes that are used when HSPA is active using the HSDPA/HSPA DL Channel Codes and HSPA Connected DL Channel Levels .

You can configure many aspects of the HSPA functionality using the HSUPA Parameters :

  • HSUPA RB Test Mode Setup for HSPA RB Test Mode connections or HSUPA PS Data Setup for HSPA PS Data connections
  • Common HSUPA Parameters
  • Serving Grant
  • E-TFCI Recording
  • E-RNTI Parameters

The HSUPA Information and HSUPA Happy Bit Information screen displays UE reported E-DCH category, counters to help you monitor the HSUPA connection status, as well as other HSUPA status indicators.

The test set supports all UE E-DCH categories; however at this time, the test set only support an HSUPA TTI of 10 ms.

The following call processing procedures are supported while on an HSPA RB Test Mode or HSPA PS Data connection.

Call Processing Procedures | Supported for HSPA RB Test Mode connections | Supported for HSPA PS Data Connections
Physical Channel Reconfiguration | Yes | Yes
Transport Channel Reconfiguration | Yes | No
System Handover | Yes | No
Radio Bearer Reconfiguration | Yes | No
Intra-frequency UE Reported Measurements | Yes* | Yes*
Inter-RAT Handovers (See Two-Cell Test System ) | No | Yes
Compressed Mode | Yes | Yes
* Soft Handover is supported for HSUPA connections but only to simulate a network scenario for when a UE performs a soft handover with cell 2 but the HSUPA channels remainconfined to the cell 1 (serving cell).

HSPA Downlink Channel Details

E-AGCH: While on an HSPA connection the test set transmits an E-AGCH. A real network only transmits on the E-AGCH when it wants to send a new absolute grant to a UE; if it has nothing to send, there is no power in the E-AGCH. To keep OCNS power constant in the test set (as required by many test specifications), the test set continuously transmits the E-AGCH. When it wants to send an absolute grant to the UE, it transmits the E-AGCH using the Primary E-RNTI (Hex) . When the test set is not transmitting an absolute grant to the UE, it transmits the E-AGCH using the Alternate E-RNTI (Hex) . When transmitting using the Alternate E-RNTI , the test set always sends an Absolute Grant Value of 15 and an Absolute Grant Scope of "All HARQ Processes".

E-HICH/E-RGCH: In a real network, DTX is used on the E-HICH and E-RGCH channels in some circumstances. However to keep OCNS power constant in the test set, DTX is not used. In the following circumstances the network would DTX the entire E-HICH or E-RGCH frame:

  • On the E-HICH when the UE did not transmit during the corresponding uplink frame.
  • On the E-HICH when a cell in the non-serving RLS is trying to communicate a nack.
  • On the E-RGCH when the network wants to communicate a "Hold" command to the UE.

Information is signaled to the UE on the E-RGCH and E-HICH channels using a 40 bit orthogonal signature that can be completely transmitted in a single timeslot. There are 40 different signatures available to the network (see 3GPP TS 25.211 s5.3.2.4 Table 16A) and the two channels use a different signature in any given slot. This way both the E-RGCH and E-HICH can share the same channelization code. Rather than use a single static signature for a channel, the network hops between 3 different signatures. The UE knows which signature to expect for each channel in any given slot from a signature index it is assigned at call setup and its knowledge of the signature hopping pattern defined in 3GPP TS 25.211 s5.3.2.4 Table 16B. The UE is given a different signature index for the E-HICH and E-RGCH to ensure the two channels remain orthogonal. 3GPP TS 25.212 s4.11 & 4.12 define the mapping from logical value (for example ack or nack), to a specific numeric value that is then multiplied with the signature. For instance, on the E-HICH transmitted from a serving cell, an ack is signalled by a 1 and a nack by a -1. These values are then multiplied with the 40 bit orthogonal signature, which means an ack is signaled by the presence of the expected signature and a nack by the presence of the inverse of the expected signature. From the perspective of the UE listening to these channels, DTX is detected by the absence of the 40 bit orthogonal signature that it was expecting (inverted or non-inverted). However, because the signatures are all orthogonal to each other it is possible for the network to transmit a signature that the UE is not expecting and the UE will still detect DTX. This explains why the E-HICH/E-RGCH can utilize the same code channel. As long as the two channels are assigned different signature indices in the UE they remain orthogonal to each other despite occupying the same space in the OVSF code tree. A network also utilizes the orthogonal property of the signatures to multiplex multiple UEs onto the same E-HICH/E-RGCH code, again by assigning different UEs unique signature indices. Therefore in all the whole-frame DTX situations outlined above, the test set communicates DTX by transmitting a signature that the UE is not expecting (Alternate E-HICH Signature Sequence of 2), Alternate E-RGCH Signature Sequence of 3). This keeps the power in the E-HICH and E-RGCH constant, and thus OCNS remains constant, while still giving the test set the ability to signal DTX to the UE. The other situation where a real network will use DTX is in slots 13-15 of the E-HICH and E-RGCH. Both the E-HICH and E-RGCH (if the E-RGCH is being generated from a serving cell), are defined to transmit only during the first 12 slots of the 15-slot frame when 10ms TTIs are used. However, to keep the power in the E-HICH and E-RGCH constant, the test set transmits during slots 13-15 using the signatures defined in 3GPP TS 25.211 s5.3.2.4 Table 16B "E-HICH and E-RGCH signature hopping pattern". The same signature hopping index that is used for slots 1-12 is used for slots 13-15.

Related Topics

How Do I Set Up a Call and Make a Connection?

Call Processing Status

Packet Switched Data

Cell Off Operating Mode

FDD Test Operating Mode

W-CDMA Concepts


Assisted GPS (A-GPS)

Assisted GPS (A-GPS)

Last updated: January 15, 2009

This section is only applicable to the lab application.

  • A-GPS Overview

A-GPS Overview

Assisted GPS (A-GPS) consists of techniques for providing information to a UE, to give assistance in making GPS based location measurements. The assistance data may speed up the measurement process or provide greater accuracy. A-GPS can be divided into two categories, User Plane A-GPS and Control Plane A-GPS. These are described in the following sections.

User Plane A-GPS

User plane A-GPS provides assistance to the UE using the Secure User Plane Location (SUPL) protocol. SUPL communicates with the UE using a standard packet data connection and does not require any additional cellular functionality. Therefore full support for this capability in the test set is already available using the existing packet data channel features. No additional test set support is currently required. More information on SUPL can be obtained from the Open Mobile Alliance at http://cms.openmobilealliance.org/technical/release_program/supl_v1_0.aspx

Control Plane A-GPS

Control plane A-GPS makes use of signaling mechanisms defined within a specific radio access technology. For WCDMA, several messages can be used to provide assistance data and retrieve results from the UE. These include:

  • Assistance Data Delivery
  • Measurement Control
  • Measurement Report
  • Measurement Control Failure

The test set supports A-GPS by making use of the RRC pipe to transport externally coded messages to and from the UE. The test set does not encode or decode these messages more than is necessary to provide reliable routing.

It is expected you will want to make use of this functionality in conjunction with an external satellite simulator, and will provide GPS information to the UE using the messages listed above. The messages listed above can also be used in conjunction with the RRC Pipe to retrieve assistance data measurement results from the UE.

For more information on the specific messages and commands associated with this feature, refer to CALL:PPRocedure .

Related Topics

CALL:PPRocedure


AMR Setup

AMR Setup

Last updated: December 29, 2009

AMR Source

The following AMR Sources are available in the test set:

  • Echo

    While in ECHO , the test set loops the transport blocks arriving from the UE on the uplink back down to the UE (unaltered) on the downlink. There is a fixed voice echo delay of 0.5 seconds.

  • Real-Time Vocoder
  • External 8960

    While in External 8960, the traffic data is routed from one UE through an 8960, over the LAN interface to a second 8960 and then to the second UE. The data flow is bidirectional and so the behaviour at each UE is like that of a real speech call.

  • PESQ

    While in PESQ (Perceptual Evaluation of Speech Quality), the test set generates the speech signal which complies with the ITU-T P.862 standard for the Perceptual Evaluation of Speech Quality measurement. See Perceptual Evaluation of Speech Quality (PESQ) Measurement Description .

GPIB command: CALL:SERVice:AMR:SOURce

This parameter can only be set when call/data status is idle.

AMR Radio Access Bearer

The AMR Radio Access Bearer can be set to:

  • 12.2k Voice (3GPP TS 34.108 s6.10.2.4.1.4)
  • 10.2k Voice(3GPP TS 34.108 s6.10.2.4.1.5)
  • 7.95k Voice (3GPP TS 34.108 s6.10.2.4.1.6)
  • 7.4k Voice (3GPP TS 34.108 s6.10.2.4.1.7)
  • 6.7k Voice (3GPP TS 34.108 s6.10.2.4.1.8)
  • 5.9k Voice (3GPP TS 34.108 s6.10.2.4.1.9)
  • 5.15k Voice(3GPP TS 34.108 s6.10.2.4.1.10)
  • 4.75k Voice (3GPP TS 34.108 s6.10.2.4.1.11)
  • Multi-rate AMR - 12.2k Voice, 7.95k Voice, 5.9k Voice, 4.75k Voice (34.108 v8.0.0 s6.10.2.4.1.4a)
  • Multi-rate Wideband AMR - 12.65k Voice, 8.85k Voice, 6.6k Voice (25.993 v7.4.0 s7.1.106)
  • Multi-rate Wideband AMR - 15.85k Voice, 2.65k Voice, 8.85k Voice, 6.6k Voice (25.993 v7.4.0 s7.1.107)
  • Multi-rate Wideband AMR - 23.85k Voice, 12.65k Voice, 8.85k Voice, 6.6k Voice (25.993 v7.4.0 s7.1.108)

GPIB command: CALL:SERVice:AMR:RAB

This parameter can only be set when call/data status is idle. Note: "k" refers to kbps.

Related Topics

Manual Operation: How Do I Configure the AMR Radio Access Bearer?

AMR Voice Ladder Diagrams

Downlink Channel Codes and Levels

Current Service Type

Establishing a Connection with the UE

Paging Service


AMR Voice Ladder Diagrams

AMR Voice Ladder Diagrams

Last updated: January 15, 2009

  • Test Set Initiated AMR Voice Service Start
  • UE Initiated AMR Voice Service Start
  • Test Set Release from AMR Voice
  • UE Release from AMR Voice

Test Set Initiated AMR Voice Service Start

UE Initiated AMR Voice Service Start

Test Set Release from AMR Voice

UE Release from AMR Voice

Related Topics

AMR Setup


Broadcast Channel (BCCH) Update Procedure (SIB Contents)

Broadcast Channel (BCCH) Update Procedure (SIB Contents)

Last updated: January 15, 2009

While in active cell operating mode, the test set broadcasts the System Information Message on the BCCH. The System Information Message consists of a Master Information Block (MIB) and several System Information Blocks (SIBs 1, 2, 3, 5, 7 and 11). The information in these SIBs helps the UE (mobile station) successfully communicate with the network.

The user-settable parameters contained in the MIB and SIBs are listed in the table below. When you change any of these parameters, the test set changes the information it sends on the BCCH accordingly. Some of these parameters can not be changed while in active cell operating mode (you must first switch to cell off operating mode). Changing any of the other parameters causes the test set to perform a BCCH update procedure if the call status is idle and BCCH Update Page is set to Auto (if the test set is on a connection with a UE, the test set will post an error if you try to change any of these parameters). During a BCCH update procedure, the test set sends a Paging Type I message to the UE indicating that it needs to re-read the BCCH. If your UE does not support the BCCH update procedure, you may set BCCH Update Page to Inhibit , which prevents the test set from sending a Paging Type I message to the UE (the test set still updates the BCCH). However, note that the UE will then be unaware of the changes in the BCCH. See BCCH Update Page for more information.

BCCH Settable Parameters
 | Change Prompts BCCH Update?
MIB Settable Parameters:
Mobile Country Code (MCC) | Yes
Mobile Network Code (MNC) | Yes
SIB 1 Settable Parameters:
ATT (IMSI Attach) Flag State | Yes
DRX Cycle Length (CN Domain) | Yes
Local Area Code (LAC) | Yes
N313 Successive Out-Of-Sync Reception Max | Yes
N315 Successive In-Sync Reception Counter | Yes
Network Mode of Operation | Yes
PS Domain Information | Yes
Routing Area Code (RAC) | Yes
T313 Out-Of-Sync Reception Timer | Yes
T3212 Periodic Location Update Timer ( lab application only ) | Yes
SIB 3 Settable Parameters:
Cell Barred State ( lab application only ) | Yes
Cell Barred Timer (Tbarred) ( lab application only ) | Yes
Cell Identity | Yes
Hysteresis 1 (Qhyst1) ( lab application only ) | Yes
Hysteresis 2 (Qhyst2) ( lab application only ) | Yes
Intra-frequency Cell Reselection Indicator ( lab application only ) | Yes
Maximum Uplink Transmit Power Level | Yes
Minimum Required Quality Level (Qqualmin) ( lab application only ) | Yes
Minimum Required Rx Level (Qrxlevmin) ( lab application only ) | Yes
Quality Measure ( lab application only ) | Yes
Sintersearch ( lab application only ) | Yes
Sintrasearch ( lab application only ) | Yes
Timer (Treselection) ( lab application only ) | Yes
SIB 5 Settable Parameters: Note, the Transmit SIB5bis setting determines whether SIB5 or SIB5bis is transmitted by the test set. Changing Transmit SIB5bis causes a BCCH update.
AICH Channelization Code | No (this setting can not be changed in active cell operating mode)
AICH Level | No (this setting can not be changed in active cell operating mode)
Available Subchannels (Bit Mask) | Yes
Constant Value | Yes
E-DCH Cell Indicator (lab application or feature-licensed test application only) | Yes
Frequency Band Indicator and Frequency Band Indicator 2 (see Frequency Band Indicator State ). | No (this setting can not be changed in active cell operating mode)
HSDPA Cell Indicator (lab application or feature-licensed test application only) | Yes
Manual PRACH Bc | Yes
Manual PRACH Bd | Yes
PICH Channelization Code | No (this setting can not be changed in active cell operating mode)
PICH Level | No (this setting can not be changed in active cell operating mode)
PRACH Bc/Bd Control | Yes
PRACH Power Ramp Step | Yes
PRACH Preambles | Yes
PRACH Ramping Cycles (MMAX) | Yes
PRACH Scrambling Codeword | No (this setting can not be changed in active cell operating mode)
PRACH Signature | Yes
Primary CPICH TX Power | Yes
S-CCPCH Channelization Code | No (this setting can not be changed in active cell operating mode)
SIB 7 Settable Parameters:
Uplink Interference | Yes
SIB 11 Settable Parameters:
Cell Info List | Yes
GSM <num> Cell BCC | Yes
GSM <num> Cell BCH ARFCN | Yes
GSM <num> Cell Cell Reselection Min Rx Level ( lab application only ) | Yes
GSM <num> Cell NCC | Yes
GSM <num> Cell Shared ARFCN Indicator | Yes
GSM <num> Cell State | Yes
Inter-freq <num> Cell Cell Reselection Offset1 ( lab application only ) | Yes
Inter-freq <num> Cell Cell Reselection Offset2 ( lab application only ) | Yes
Inter-freq <num> Cell DL Channel | Yes
Inter-freq <num> Cell Scrambling Code | Yes
Inter-freq <num> Cell State | Yes
Intra-freq <num> Cell Cell Reselection Offset1 ( lab application only ) | Yes
Intra-freq <num> Cell Cell Reselection Offset2 ( lab application only ) | Yes
Intra-freq <num> Cell Scrambling Code | Yes
Intra-freq <num> Cell State | Yes
Quality Measure ( lab application only ) | Yes

Related Topics

How Do I Change Cell Parameters?


HTTP Interface for Cell Broadcast Service - Introduction

HTTP Interface for Cell Broadcast Service - Introduction

Last updated: January 15, 2009

This section is only applicable to the lab application.

This section explains HTTP interface for configuring and sending cell broadcast messages. You can use the HTTP interface to interface with custom programs. You can also use the HTTP interface to control the test set's cell broadcast service parameters through the address bar of an internet browser.

HTTP Overview

HTTP is the client/server based protocol used to deliver virtually all files and data on the World Wide Web. If you'd like a more detailed description of HTTP protocol, refer to Internet RFCs `HTTP/1.0 - RFC 1945' and `HTTP/1.1 - RFC 2616', which can be downloaded from http://www.rfc-editor.org/rfc.html.

When you use HTTP in a web browser, you enter the "address" for the web page you wish to view. These addresses can be generalized into the following format:

In this example, the web browser is the HTTP client and it uses the information in this address to open a connection to an HTTP server and send a request.

  • "http://" is the protocol specifier, telling the browser what protocol to use for the request.
  • <ip_address> is the IP address of the server.
  • <port> is the port number on which to communicate with the server. The default port for HTTP is 80.
  • <request_URL> provides information to the server on the location of the resource that's being requested and can also be used to provide information to the resource.

HTTP for Cell Broadcast Messages

The test set acts as a server for cell broadcast messages. If you have a PC and your test set connected to a network or directly connected together, you can open a web browser (client) and send a request to the test set using the test set's IP address and a correctly configured request URL. For example, Once the sets set is configured to allow the use of the HTTP interface and cell broadcast service is enabled in the test set, you might send the following from the web browser if your test set's IP address was 111.111.111.112.

NOTE
It is not necessary to specify a port number because the test set uses 80, which is the default port for HTTP.

Setting the message 1 state to ON, starting the cell broadcast service, and sending the above URL causes an cell broadcast message to arrive at the mobile station attached to the test set's RF port. This message contains the text "Hello".

For instructions on how to configure URL messages for the HTTP interface, see HTTP Interface Configuration for Cell Broadcast Service Messages .

Related Topics

Cell Broadcast Service (CBS)


HTTP Interface Configuration for Cell Broadcast Service Messages

HTTP Interface Configuration for Cell Broadcast Service Messages

Last updated: January 15, 2009

This section is only applicable to the lab applications.

Please keep in mind that an HTTP address requires all the components shown in the URL below, and that this section focuses on the request URL portion of the address. See HTTP Overview for more information regarding other components of the HTTP address.

If you wish to use the HTTP interface to configure and send cell broadcast messages to the mobile station attached to the test set's RF port, you must do the following:

  1. Enable the Test Set's HTTP Interface
  2. Enable the Cell Broadcast Service
  3. Configure the Request URL

Enable the Cell Broadcast Service

Once the HTTP interface is enabled (see Enable the Test Set's HTTP Interface ), you can do the following through the HTTP interface:

  • Enable the Cell Broadcast Service

    You can do this by sending an HTTP command to the test set with the following request URL format:

    /cbsms/start

    If the cell broadcast format started successfully, the following message is displayed in your internet browser:

    Cell Broadcast service started OK

  • Disable the Cell Broadcast Service

    You can do this by sending an HTTP command to the test set with the following request URL format:

    /cbsms/stop

    If the cell broadcast format started successfully, the following message is displayed in your internet browser:

    Cell Broadcast service stopped

Configure the Request URL

When using the HTTP interface in the test set for sending cell broadcast messages, you must configure a request URL.

Requests to send cell broadcast messages to the mobile station attached to the test set using the HTTP interface must be configured using the following rules:

  1. The request URL format accepted by the test set is:

    /cbsms/message<n>/?parameter1=value1&parameter2=value2&parameter3=value3......

    NOTE
    "/cbsms/message<n>/?" must be specified at the beginning of the request URL (following the IP address and port number) in order for the test set to recognize the HTTP request as a request to send a cell broadcast message to the mobile station. The <n> represents the message number which must be 1,2, or 3.

    The parameters and values variables provides the content of the cell broadcast message as well as additional information for header configuration and test set configuration. All configurable parameters and values are detailed in Request URL Parameters .

  2. An HTTP error code of 400 (Bad Request) is returned to the client initiating an HTTP request and the message is not forwarded on to the mobile station if any parameter values in the request URL do not adhere to the constraints detailed in Request URL Parameters .
  3. Parameters in the request URL can be in any order.
  4. When a text message is being submitted via the `TEXT' parameter, HTTP URL escaping restrictions apply. Therefore, all space characters must be replaced with the `%20' character sequence. Other characters that require escape characters when used in URLs are detailed in the following table.

    Character to URL Escape Sequence Mapping

  5. Accepted HTPP request methods

    Both POST and GET HTTP requests are accepted by the test set for sending cell broadcast messages.

    If POST is used as the request method, the URL request parameters detailed in Request URL Parameters are not included in the request URL, but are included in the request body instead. Therefore, the request URL in POST requests contains only `cbsms/message<n>' (when <n> must be a 1, 2 or 3).

Request URL Parameters

Parameter Use and expected value Inclusion
CODE Specifies the 10-bit message code element of the cell broadcast message's serial number.Expected value: decimal number in the range 0-1023

Optional (default*= 0)

Including this parameter affects the setting for CALL:SMService:CBRoadcast:MESSage[<n>]:CODE .
DATA Specifies the binary data to be sent in the message.Expected value: 0-2460 length character string of ASCII formatted hexadecimal characters

Optional -This parameter cannot be included in the same request as the TEXT parameter.

Including this parameter affects the settings for CALL:SMService:CBRoadcast:MESSage[<n>]:CONTent and CALL:SMService:CBRoadcast:MESSage[<n>]:CDATa .
DCS Specifies the 8-bit data coding scheme of the cell broadcast message.Expected value: Decimal number in the range 0-255

Optional -This parameter cannot be included in the same request as the DCSHEX parameter. (default*= 1)

Including this parameter affects the settings for CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme[:SPECify] and CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:VALue .
DCSHEX Specifies the 8-bit data coding scheme of the cell broadcast message.Expected value: string of hex characters in the range 0 - FF

Optional -This parameter cannot be included in the same request as the DCS parameter. (default*= not used).

Including this parameter affects the settings for CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme[:SPECify] and CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:VALue .
GSCOPE Specifies the 2-bit geographical scope element of the cell broadcast message's serial number.Expected value: decimal number in the range 0-3

Optional (default*= 0)

Including this parameter affects the setting for CALL:SMService:CBRoadcast:MESSage[<n>]:GSCope .
ID Specifies the 16-bit message identifier of the cell broadcast message.Expected value: Decimal number in the range 0-65535

Optional -This parameter cannot be included in the same request as the IDHEX parameter. (default*= 0)

Including this parameter affects the setting for CALL:SMService:CBRoadcast:MESSage[<n>]:IDENtifier .
IDHEX Specifies the 16-bit message identifier for the cell broadcast message.Expected value: String of hex characters in the range 0 - FFFF

Optional -This parameter cannot be included in the same request as the ID parameter. (default*= not used)

Including this parameter affects the setting for CALL:SMService:CBRoadcast:MESSage[<n>]:IDENtifier .
REPETITION Specifies the repetition period for the message in seconds. This parameter may be included in HTTP requests to configure any of the individual cell broadcast messages however the associated value is be applied to ALL of the messages regardless of which message the HTTP request was for.Expected value: Decimal number in the range 1 - 1800

Optional -This parameter cannot be included in the same request as the REPUNITS parameter. (default*= 30)

Including this parameter affects the setting for CALL:SMService:CBRoadcast:REPetition[:SEConds] .
STATE Specifies if the message should be transmitted when the cell broadcast service is running.Expected value: Decimal number in the range 0 - 1 where 0=OFF, 1=ON.

Optional (default*: Message 1=ON, Message 2 and 3 = OFF)

Including this parameter affects the setting for CALL:SMService:CBRoadcast:MESSage[<n>]:STATe .
TEXT

Specifies the text to be sent in the message.

Expected Value: 0 to 1395 length character string of 7-bit text characters.

Optional -This parameter cannot be included in the same request as the DATA parameter.

Including this parameter affects the setting for CALL:SMService:CBRoadcast:MESSage[<n>]:CONTent and CALL:SMService:CBRoadcast:MESSage[<n>]:CTEXt .
UPDATE Specifies the 4-bit update number element of the cell broadcast message's serial number.Expected value: Decimal number in the range 0-15

Optional (default*= 0)

Including this parameter affects the setting for CALL:SMService:CBRoadcast:MESSage[<n>]:UPDate .

*This value is the setting for the parameter when the test set is powered on. If a parameter is not included, the setting for the parameter does not revert to the default settings, but retains the current parameter settings.

Example Cell Broadcast Request URL Strings

Example Text Cell Broadcast Request URL

To send a text based cell broadcast message with the following message details:

  • Geographic Scope: Cell Wide/Normal
  • Message Code: 5
  • Update Number: 1
  • Message ID: 2
  • Data Coding Scheme: 1
  • Text: "This is a text message for message one"
  • State: On (message 1)
  • Repetition Period: 10 seconds

you would format the cell broadcast HTTP request URL as follows:

/cbsms/message1/?GEOSCOPE=3&CODE=5&UPDATE=1&ID=2&DCS=1&TEXT=This%20is%20a%20text%20message%20for%20message%20one&REPETITION=10

Example Binary Cell Broadcast Request URL

To send a binary message with the following message details:

  • Geographic Scope: PLMN Wide / Normal Display
  • Message Code: 13
  • Update Number: 1
  • Message ID: 6
  • Data Coding Scheme: 245
  • Data: 014FA553000FF110
  • State: On (message 2) Message 1 is on by default, so it does not need to be included in the above URL.

you would format the cell broadcast message as follows:

/cbsms/message2/?GEOSCOPE=1&CODE=13&UPDATE=1&ID=6&DCS=245&DATA=014FA553000FF110&STATE=1

Subsequent Message Configuration

Messages can be updated over HTTP while the cell broadcast service is enabled and running. For example, if message 1 and message 2 are configured as described in Example Text Cell Broadcast Request URL and Example Binary Cell Broadcast Request URL and you wish to change the contents of the text message sent in message 1 to "This is an updated text message for message one", you would send the following URL:

/cbsms/message1/?TEXT=This%20is%20an%20updated%20text%20message%20for%20message%20one&UPDATE=2

Notice that the update number has changed from 1 to 2 to indicate to the mobile station that the contents of the message have been altered.

If you wish to stop transmitting message 2, you would send the following URL:

/cbsms/message2/?STATE=0

Related Topics

HTTP Interface for Cell Broadcast Service - Introduction


Cell Information

Cell Information

Last updated: May 3, 2011

  • Cell Parameters
  • Reselection Parameters (lab application only)
  • Access Restriction Parameters (lab application only)
  • UE Timer and Constant Parameters (lab application only)
  • Message Reply Control (lab application only)
  • SIB19 Information (lab application only)

Reselection Parameters

This section is only applicable to the lab application.

These settings can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change these settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change these settings while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

  • Sintersearch

    You can specify whether the S intersearch information element (see 3GPP TS 25.331 10.3.2.3 and 3GPP TS 25.304 5.2.6.1.5) is sent in SIB3 by the test set, and if included, what value is sent. S intersearch controls whether the UE must make measurements of inter-frequency cells while camped. If the quality of the serving cell is above S intersearch , then the UE will not measure other inter-frequency cells while camped. If S intersearch is not present, the UE must make inter-frequency measurements while camped. Note that if the UE does not make measurements on other cells, it will not reselect away from the current cell, even if there is another cell at a higher signal level. See 3GPP TS 25.304 5.2.6.1.1.

    When Sintersearch is On , it can be set to any even number value between -32 dB and +20 dB, but any negative value will be interpreted by the UE as 0 dB.

    When Sintersearch is Off , the S intersearch information element is not included in SIB3.

    Note, the Sintersearch parameter does not affect measurements performed by the UE while on a connection (see UE Reported Measurements ).

    GPIB command: CALL[:CELL]:BCCHannel:SERSearch[:SVALue] .

  • Sintrasearch

    You can specify whether the S intrasearch information element (see 3GPP TS 25.331 10.3.2.3 and 3GPP TS 25.304 5.2.6.1.5) is sent in SIB3 by the test set, and if included, what value is sent. S intrasearch controls whether the UE must make measurements of intra-frequency cells while camped. If the quality of the serving cell is above S intrasearch , then the UE will not measure other intra-frequency cells while camped. If S intrasearch is not present, the UE must make intra-frequency measurements while camped. Note that if the UE does not make measurements on other cells, it will not reselect away from the current cell, even if there is another cell at a higher signal level. See 3GPP TS 25.304 5.2.6.1.1.

    When Sintrasearch is On , it can be set to any even number value between -32 dB and +20 dB, but any negative value will be interpreted by the UE as 0 dB.

    When Sintrasearch is Off , the S intrasearch information element is not included in SIB3.

    Note, the Sintrasearch parameter does not affect measurements performed by the UE while on a connection (see UE Reported Measurements ).

    GPIB commands: CALL[:CELL]:BCCHannel:SRASearch[:SVALue] .

  • Quality Measure

    This parameter sets the 3GPP TS 25.331 s10.3.2.3, "Cell selection and reselection quality measure" information element. This parameter specifies whether the UE should use CPICH Ec/N0 or CPICH RSCP as the quality measure for determining which cell to choose when performing a cell selection or mobile-initiated cell reselection.

    Note, this setting does not affect what measurements are reported to the test set by the UE. When Report Measurement Type is set to Intra-frequency or All , the UE will make both CPICH Ec/N0 and CPICH RSCP measurements, regardless of the Quality Measure setting (the Measurement Control message sent by the test set instructs it to do so).

    GPIB command: CALL[:CELL]:RESelection:QUALity:MEASure .

  • Hysteresis 1 (Qhyst1)

    This parameter sets the 3GPP TS 25.331 s10.3.2.3 "Qhyst1" information element. Qhyst1 specifies the hysteresis value to be used by the UE if Quality Measure is CPICH RSCP.

    GPIB command: CALL[:CELL]:RESelection:HYSTeresis[1] .

  • Hysteresis 2 (Qhyst2)

    This parameter sets the 3GPP TS 25.331 s10.3.2.3 "Qhyst2" information element. Qhyst2 specifies the hysteresis value to be used by the UE if Quality Measure is CPICH Ec/N0.

    GPIB command: CALL[:CELL]:RESelection:HYSTeresis2 .

  • Minimum Required Quality Level (Qqualmin)

    This parameter sets 3GPP TS 25.331 s10.3.2.3 "Qqualmin" for FDD in the "Cell selection and re-selection info for SIB11/12" information element (see 25.331 s10.3.2.4). According to 3GPP TS 25.304 s5.2.6.1.4, Qqualmin is the "minimum required quality level in the cell (dB)". If Quality Measure is set to CPICH Ec/N0, the UE compares the CPICH Ec/N0 it measures for the cell with Qqualmin to determine if it may select/reselect to the cell.

    GPIB command: CALL[:CELL]:RESelection:QUALity:LMINimum .

  • Minimum Required Rx Level (Qrxlevmin)

    This parameter sets 3GPP TS 25.331 s10.3.2.3 "Qrxlevmin" for FDD in the "Cell selection and re-selection info for SIB11/12" information element (see 25.331 s10.3.2.4). According to 3GPP TS 25.304 s5.2.6.1.4, Qrxlevmin is the "minimum required RX level in the cell (dBm)". If Quality Measure is set to CPICH RSCP, the UE compares the CPICH RSCP it measures for the cell with Qrxlevmin to determine if it may select/reselect to the cell.

    GPIB command: CALL[:CELL]:RESelection:RLMinimum .

  • Timer (Treselection)

    This parameter sets the 3GPP TS 25.331 s10.3.2.3 "Treselection" information element. 3GPP TS 25.304 s5.2.6.1.4 states that the UE shall only reselect to a cell if it "is better ranked than the serving cell during a time interval Treselection".

    GPIB command: CALL[:CELL]:RESelection:TIMer .

Access Restriction Parameters

This section is only applicable to the lab application.

These settings can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change these settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change these settings while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

These parameters are sent in the Cell Access Restriction information element on SIB3. See 3GPP TS 25.331 s10.3.2.1.

  • Cell Barred State

    According to 3GPP TS 25.304, a "Barred Cell" is "a cell a UE is not allowed to camp on." A UE is not allowed to camp on a barred cell, not even for emergency calls. If a cell on which a UE is currently camped becomes barred, a cell reselection is triggered.

    This parameter controls whether the test set is a barred cell. It sets the 3GPP TS 25.331 s10.3.2.1 "Cell Barred" information element.

    GPIB command: CALL[:CELL]:AREStriction:BARRed:STATe .

  • Cell Barred Timer (Tbarred)

    This parameter sets the 3GPP TS 25.331 s10.3.2.1 "T barred " information element. T barred specifies the time the UE must wait before considering a barred cell for reselection (see 3GPP TS 25.304 s5.3.1.1).

    This setting is only applicable when Cell Barred State is set to On .

    GPIB command: CALL[:CELL]:AREStriction:BARRed:TIMer .

  • Intra-frequency Cell Reselection Indicator

    This parameter set the 3GPP TS 25.331 s10.3.2.1 "Intra-frequency cell re-selection indicator" information element. According to 3GPP TS 25.304 s5.3.1.1, if a cell is barred, the UE must select another cell as follows:

    • If the "Intra-frequency cell re-selection indicator" IE in Cell Access Restriction IE is set to value "allowed", the UE may select another cell on the same frequency
    • If the "Intra-frequency cell re-selection indicator" IE is set to "not allowed" the UE shall not re-select a cell on the same frequency as the barred cell. During an ongoing emergency call, the Intra-frequency cell re-selection indicator IE" shall be ignored, i.e. even if it is set to "not allowed" the UE may select another intra-frequency cell.

    This setting is only applicable when Cell Barred State is set to On .

    GPIB command: CALL[:CELL]:AREStriction:ITAFrequency:CRINdicator .

UE Timer and Constant Parameters

The following settings, with the exception of the T3312 Periodic RA Update Timer and T3312 Periodic RA Update Units settings, can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change these settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change these settings while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

  • T300 RRC Conn Req Retransmit Timer

    This setting is only applicable to the lab application.

    This setting determines how long the UE waits for the RRC Connection Setup after sending an RRC Connection Setup Request.

    T300 can be set to one of the following values: 100, 200, 400, 600, 800, 1000, 1200, 1400, 1600, 1800, 2000, 3000, 4000, 6000, or 8000 ms.

    GPIB command: CALL[:CELL]:BCCHannel:T300

  • N300 RRC Conn Req Max Retransmits

    This setting is only applicable to the lab application.

    This setting specifies the maximum number of retransmissions of the RRC Connection Request message.

    N300 can be set to any integer value from 0 to 7.

    GPIB command: CALL[:CELL]:BCCHannel:N300

  • T312 Link Establishment Timer (Idle)

    This setting is only applicable to the lab application.

    This setting determines how long the UE waits for an N312 "in-sync" indication from layer 1 when establishing a dedicated channel and the connection status is idle. According to 3GPP TS 25.331 table 10.3.3.43, zero (0) can be signaled in the SIB1 message but has no meaning.

    T312 can be set to any integer value from 1 to 15.

    GPIB command: CALL[:CELL]:BCCHannel:T312[:IDLE]

  • N312 Link Establishment In-Sync Count (Idle)

    This setting is only applicable to the lab application.

    This setting specifies the number of " in-syncs" required when establishing a dedicated channel when the connection status is in Idle mode.

    N312 can be set to one of the following values: 1, 2, 4, 10, 20, 50, 100, 200, 400, 600, 800, or 1000.

    GPIB command: CALL[:CELL]:BCCHannel:N312[:IDLE]

  • T308 RRC Conn Release Comp Retransmit Timer

    This setting is only applicable to the lab application.

    This setting specifies the amount of time between transmissions of the RRC Connection Release Complete message.

    T308 can be set to one of the following values: 40, 80, 160, or 320 ms.

    GPIB command: CALL[:CELL]:BCCHannel:T308

  • N308 RRC Conn Release Comp Max Retransmits

    This setting is only applicable to the lab application.

    This setting specifies the maximum number of times the RRC Connection Release Complete message is sent.

    N308 can be set to any integer value from 1 to 8.

    GPIB command: CALL[:CELL]:RRC:CRELease:N308

  • RRC Connection Release Complete Wait Count

    This setting is only applicable to the lab application.

    This setting determines whether the test set keeps the uplink DPCH active until it has received all the RRC Connection Release Complete messages or whether it releases the DPCH and returns to Idle mode as soon as the first RRC Connection Release Complete message is received. Note: This parameter only controls the test set's behavior; it is not signaled to the UE.

    You can choose from the following settings:

    • N308 ( N308 ): The test set keeps the DPCH active until all the RRC Connection Release Complete messages have been received.
    • 1 ( RETRansmit1 ): The test set releases the DPCH upon the reception of the first RRC Connection Release Complete Message.

    GPIB command: CALL[:CELL]:RRC:CRELease:CWCount

  • T313 Out-Of-Sync Reception Timer

    3GPP TS 25.331 8.5.6 states that after receiving N313 consecutive "out of sync" indications from layer 1 (see N313 Successive Out-Of-Sync Reception Max ), the UE shall start the T313 timer. Upon receiving N315 successive "in sync" indications from layer 1 ( N315 Successive In-Sync Reception Counter ), the UE shall stop and reset the T313 timer. If T313 expires, a "Radio Link failure" has occurred, and the UE shall drop the call. See 3GPP TS 25.214 4.3.1.2 for more details regarding "in sync" and "out of sync" indications.

    T313 can be set to an integer value between 0 and 15 seconds.

    GPIB command: CALL[:CELL]:BCCHannel:T313

  • N313 Successive Out-Of-Sync Reception Max

    N313 can be set to one of the following integer values: 1, 2, 4, 10, 20, 50, 100, 200.

    GPIB command: CALL[:CELL]:BCCHannel:N313

  • N315 Successive In-Sync Reception Counter

    N315 can be set to one of the following integer values: 1, 2, 4, 10, 20, 50, 100, 200, 400, 600, 800, 1000.

    GPIB command: CALL[:CELL]:BCCHannel:N315

  • T309 CCO From UTRAN to 2G Connect Timer

    This setting is only applicable to the lab application.

    This setting determines the amount of time the UE waits to establish a connection on the 2G side after a Cell Change Order from UTRAN.

    The T309 timer can be set to any integer from 0 to 8 seconds.

    GPIB command: CALL[:CELL]:BCCHannel:T309

  • T3212 Periodic Location Update Timer

    This setting is only applicable to the lab application.

    T3212 controls how often the UE performs the periodic location update procedure (see Performing a Location Update (CS Domain Registration) ). It can be set between 0 and 255 decihours (1 decihour = 6 minutes). T3212 is signaled in SIB1 as part of the "CS domain specific system information" information element. If T3212 is set to zero, 3GPP TS 24.008 indicates that the UE shall interpret this as infinity (never perform a periodic location update).

    GPIB command: CALL[:CELL]:BCCHannel:T3212

  • T3312 Periodic RA Update Timer

    This setting is only applicable to the lab application.

    This setting determines the value of the periodic Routing Area (RA) update timer. 3GPP TS 24.008 s4.7.2.2 states that "The value of timer T3312 is sent by the network to the MS in messages ATTACH ACCEPT and ROUTING AREA UPDATE ACCEPT."

    The increment value of this parameter is set by the T3312 Periodic RA Update Units parameters.

    The T309 timer can be set to any integer from 0 to 31.

    GPIB command: CALL[:CELL]:BCCHannel:T3312[:VALue]

  • T3312 Periodic RA Update Units

    This setting is only applicable to the lab application.

    This setting specifies the unit that the T3312 Periodic RA Update Timer is incremented.

    The following settings are available:

    • 2 Seconds ( SEC2 ): The T3312 Periodic RA Update Timer is incremented every 2 seconds.
    • Minutes ( MINutes ): The T3312 Periodic RA Update Timer is incremented every minute.
    • Decihours ( DHOurs ): The T3312 Periodic RA Update Timer is incremented every decihour (1 decihour = 6 minutes).
    • Deactivated ( DEACtivated ): The T3312 Periodic RA Update Timer is deactivated.

    GPIB command: CALL[:CELL]:BCCHannel:T3312:UNITs

  • T305 Periodic Cell Update Timer

    This setting is only applicable to the lab application.

    T305 specifies the length of the periodical cell update timer. T305 starts while the UE is in CELL_FACH state. When T305 expires, the UE initiates the cell update procedure.

    GPIB command: CALL[:CELL]:BCCHannel:T305

Related Topics

How Do I Change Cell Info?


Cell Parameters

Cell Parameters

Last updated: June 16, 2011

The test set broadcasts cell-specific information on the BCCH. This information is needed by the UE to successfully communicate with the network.

The Cell Parameters fall into one of four categories:

  • Settings that cannot be changed while in Active Cell Operating Mode (switch to Cell Off Operating Mode to change these settings):
    CTCH Allocation Period ( lab application only )
    CBS Frame Offset ( lab application only )
    AICH Transmission Timing ( lab application only )
    SCCPCH/PRACH Configuration ( lab application only )

  • Settings that can be changed in Active Cell Operating Mode, but only when the call status is idle:
    Default DPCH Offset (DOFF)
  • Settings that can be changed in Active Cell Operating Mode, but only when the call status is idle. If BCCH Update Page is set to Auto and you change these settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change these settings while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).
    PS Domain Information Mobile Country Code (MCC)
    Mobile Network Code (MNC)
    Local Area Code (LAC) Routing Area Code (RAC) Cell Identity ATT (IMSI Attach) Flag State DRX Cycle Length (CN Domain) Primary CPICH TX Power Uplink Interference Constant Value Network Mode of Operation Equipment Identity Request
  • Settings that can be changed at any time (including while on a call in active cell operating mode):
    BCCH Update Page
    RB Setup Timing Indication (CFN Handling)

Cell Parameter Descriptions

  • BCCH Update Page

    If BCCH Update Page is set to Auto , when you change a parameter that causes a Broadcast Channel (BCCH) Update Procedure (SIB Contents) (which only occurs when call status is idle), the test set updates its BCCH information and sends a Paging Type I message to the UE telling it to re-read the BCCH. If BCCH Update Page is set to Inhibit , when you change a BCCH parameter that would normally cause a BCCH Update procedure, the test set updates its BCCH information but does NOT send a Paging Type I message to the UE.

    If your UE does not support the BCCH Update procedure, set this field to Inhibit . However, note that the UE will then be unaware of the changes to the BCCH. To force your UE to re-read the BCCH, you can do one of the following:

    • Originate a call and then release it.
    • Cause the UE to perform a cell re-selection by changing the Primary Scrambling Code and Cell Identity .
    • Turn the UE off and then back on.

    You may also use this field to reduce the amount of signalling between the test set and UE as follows: if you need to change many BCCH parameters, set this field to Inhibit , change all of the parameters except one, set this field to Auto , then change the final parameter. That way, only one Paging Type I message is sent to the UE. See Broadcast Channel (BCCH) Update Procedure (SIB Contents)

    GPIB command: CALL[:CELL]:BCCHannel:UPDAtepage .

    This parameter can be changed at any time.

  • PS Domain Information

    This setting indicates to the UE what type of services are supported by the test set. When PS Domain Information is set to Absent , the CN Domain System Information List sent by the test set in SIB 1 (see 3GPP TS 25.331 10.2.48.8.4) includes CN Domain System Information for the CN Domain Identity of CS Domain only (see 3GPP TS 25.331 10.3.1.2). When PS Domain is set to Present , the CN Domain System Information List also includes CN Domain System Information for the CN Domain Identity of PS Domain.

    Setting PS Domain Information to Present allows UEs that require both of these CN Domain Identities to camp to the test set (see Performing a Location Update (CS Domain Registration) ). PS Domain Information must be set to Present before a UE will initiate PS services with the test set.

    Note, some UEs will automatically perform a PDP Context Activation if PS Domain Information is set to Present . If so, before establishing an RB Test Mode or AMR Voice call, you must first select End Call .

    The test application supports the PS Domain Information setting even though it does not support UE-initiated PS services (feature-licensed test applications support test set-initiated HSPA connections in the PS domain). If the UE attempts to initiate a PS service, the test application allows it to attach, but if the UE attempts an Activate PDP Context Request, it is rejected with a cause of "Feature Not Supported" (see Activate PDP Context Control ).

    NOTE
    PS Domain Information     is set to Absent by default in the Test Application (it is set to Present by default in the Lab Application).

    GPIB command: CALL[:CELL]:PSDomain .

    This parameter can only be set when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

  • Mobile Country Code (MCC)

    GPIB command: CALL:MCCode .

    This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

  • Mobile Network Code (MNC)

    GPIB command: CALL:MNCode .

    This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

  • Local Area Code (LAC)

    GPIB command: CALL:LACode .

    This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

  • Routing Area Code (RAC)

    The RAC is a fixed length code (of 1 octet) identifying a routing area within a location area (see 3GPP TS 23.003 4.2). The CN Domain identifier for Packet Switching (PS) consists of the PLMN-Id, Local Area Code (LAC) and the RAC (see 3GPP TS 23.003 12.2).

    GPIB command: CALL:RACode .

    This parameter can only be set when PS Domain Information is set to Present and call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

  • Cell Identity

    3GPP TS 25.331 10.3.2.2 defines cell identity as a 28 bit number which unambiguously identifies a cell within a PLMN (Public Land Mobile Network). The Cell Identity parameter in the test set allows you to input a decimal value between 0 and 268435455, which is then transmitted to the UE as a 28 bit number, identifying the test set.

    GPIB command: CALL[:CELL]:IDENtity .

    This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

  • ATT (IMSI Attach) Flag State

    IMSI Attach is a core network procedure that utilizes the Location Update procedure (see Performing a Location Update (CS Domain Registration) ). When ATT (IMSI Attach) Flag State is Set , the test set signals the UE to perform IMSI Attach. While the test set does not actually perform the core network IMSI Attach procedure, signalling the UE to perform IMSI Attach causes it to perform a Location Update every time it camps to the test set. If the UE is IMSI Attached, in some circumstances it will request an IMSI Detach before proceeding with other call processing operations. If the UE sends the test set an IMSI Detach Indication while the call status is idle, the test set simply releases the RRC Connection and then returns to Idle.

    If ATT (IMSI Attach) Flag State is Not Set , the UE will only register when it determines that it has camped to a new cell (indicated by the Mobile Network Code (MNC) , Mobile Country Code (MCC) and Local Area Code (LAC) settings).

    GPIB command: CALL:ATTFlag .

    This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

  • DRX Cycle Length (CN Domain)

    DRX (Discontinuous Reception) Cycle is defined in 3GPP TS 25.304 3.1 as "Individual time interval between monitoring Paging Occasion for a specific UE." 3GPP TS 25.331 8.6.3.1a states "The UE shall determine its idle mode paging occasions and PICH monitoring occasions for that CN domain..., based on the stored CN domain specific DRX cycle length, when using DRX in idle mode." This setting determines the length of the DRX cycle that the UE uses while in idle mode.

    This parameter is useful for idle mode battery drain testing.

    See Page Indicator Channel (PICH) and Repeat Paging for related information.

    Note, this setting does not configure the UTRAN DRX Cycle length coefficient described in 3GPP TS 25.331 8.6.3.2.

    GPIB command: CALL[:CELL]:DRX:CLENgth .

    This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

  • Open loop power control settings - these settings are used by the UE to determine the initial transmit power of the first PRACH preamble. See 3GPP TS 25.331 8.5.7 and Initial PRACH TX Power .

    These settings can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change these settings while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change these settings while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

    • Primary CPICH TX Power

      GPIB command: CALL:PCTPower .

      Primary CPICH Tx Power is a parameter transmitted to the UE on the BCCH by the test set. It is not the actual transmit power level of the test set's CPICH.

    • Uplink Interference

      In an actual W-CDMA system, the base station measures the interference present in its cell and then reports this value to the UE. In the test set, you must set this value manually.

      GPIB command: CALL:UINTerferenc .

    • Constant Value

      The Constant Value allows you to specify an offset in the power level of the UE's initial PRACH transmission.

      GPIB command: CALL:CVALue .

  • RB setup Timing Indication (CFN Handling):

    Background Information

    While connected to a cell, the UE maintains a CFN (Connection Frame Number) counter which is based upon the cell's SFN (System Frame Number). According to 3GPP TS 25.331 8.5.15.2, for FDD: CFN = (SFN - (DOFF div 38400)) mod 256).

    When the UE is handed off to a new cell while in the CELL_DCH state, it can be ordered to maintain its CFN counter (continue to increase CFN by 1 every frame) or to re-initialize it based on the SFN of the target cell (the UE must read the BCCH of the target cell to do so). The UE is ordered to maintain or re-initialize its CFN counter by the Timing Indication information element sent in the message that initiates the handover (Timing Indication is also called cfnHandling, see 3GPP TS 25.331 s10.3.6.18, 10.3.6.24, 10.2.22, 10.2.33, and 10.2.50).

    If Timing Indication is set to Initialise, the UE must read the BCCH of the target cell and re-initialize its CFN counter (this is called a "Timing Re-Initialised Hard Handover," see 3GPP TS 25.331 8.3.5.1). If Timing Indication is set to Maintain, the UE maintains its CFN counter (this is called a "Timing Maintained Hard Handover," see 3GPP TS 25.331 8.3.5.2).

    Test Set Implementation

    From the test set, you may specify whether the UE should initialise or maintain its CFN counter for several events associated with handing off to a new cell. Note that the UE does not actually hand off to a new cell for any of these events, it is still being served by the test set. Thus, whether the UE initialises or maintains its CFN counter, its CFN counter always simply increments by 1 each frame because it is always determined by the test set's SFN. (Note that in the test set, DOFF is never greater than 2560, see Current DPCH Offset . Thus, DOFF div 38400 is 0, and CFN = SFN mod 256.) When the UE initializes its CFN, it reads the test set's BCCH to determine the SFN. When the UE maintains it CFN, it does not read the test set's BCCH. The resulting CFN is the same either way.

    Note that according to 3GPP 25.331 v5.17.0 s8.6.6.28, timing re-initialized reconfigurations are intended to be exclusively used for hard handovers (i.e. where the UE changes UARFCNs and/or all Primary Scrambling Codes for all links in the active set as part of the reconfiguration, see 3GPP TS 25.331 v5.17.0 s8.6.6.3a). 25.331 states that the UE's behavior is undefined if the network sets the Timing Indication IE to Initialise on a non-hard handover (i.e. where the UARFCNs and one or more Primary Scrambling Codes remain unchanged as part of the reconfiguration).

    You can specify whether Timing Indication is set to Maintain or Initialise for several events using the following settings:

    • PCR Timing Indication (CFN Handling)
    • CM PCR Timing Indication (CFN Handling)
    • TCR Timing Indication (CFN Handling)
    • RBR Timing Indication (CFN Handling)
    • RB Setup Timing Indication (CFN Handling)

      You can specify whether the Timing Indication information element sent in the RB Setup message is set to Maintain or Initialise. See RB setup Timing Indication (CFN Handling): above for more details.

      The most common usage scenario includes a Timing Indication of Maintain in the RB Setup message, wherein the UE is instructed to use the timing from the same cell it used for its RRC Connection. A Timing Indication of Initialise would indicate to the UE that it is being moved between cells between the RRC Connection and RB Setup stages of call establishment. Since 25.331 states that a timing re-initialised non-hard handover is undefined, if you establish a call with RB Setup Timing Indication (CFN Handling) set to Initialise , the call attempt may fail or be rejected by the UE.

      GPIB command: CALL[:CELL]:RBSetup:CFNHandling .

      This parameter can be changed at any time.

    Note that setting Timing Indication to Initialise for any of these messages may cause an increase in the time it takes to complete any associated procedures (such as making a call or performing a hard handover).

  • Default DPCH Offset (DOFF)

    This setting determines the value of the Default DPCH Offset information element (3GPP TS 25.331 s10.3.6.16). The Default DPCH Offset information element is signalled to the UE in the RRC Connection Setup and RB Setup messages. Default DPCH Offset can be used to change the DPCH Frame Offset (tau DPCH ) to 0, 1, 2, 3, 4 or 5 x 512 chips during call establishment. See Current DPCH Offset for more information.

    GPIB command: CALL:DPCHannel:DOFFset

    This parameter can only be set when call status is Idle . To change the DPCH Frame Offset while on a connection, see Transport Channel Reconfiguration .

  • CTCH Allocation Period

    This setting is only applicable to the lab application.

    The CTCH Allocation period specifies the frames within a 4096 system frame cycle that is allocated to the CTCH. This parameter, along with the CBS Frame Offset determine which TTI intervals in the FACH to be utilized by the CTCH. The the range for this parameter is 1 to 4096 minus the CBS Frame Offset. Additionally, this setting must be greater than the CBS Frame Offset.

    GPIB command: CALL[:CELL[1]]:CTCHannel:APERiod

    This parameter can only be set when operating mode is Cell Off .

  • CBS Frame Offset

    This setting is only applicable to the lab application.

    The CTCH Frame offset indicates which frame within the system frame to begin the CTCH allocation. This parameter, along with the CTCH Frame offset determine which TTI intervals in the FACH to be utilized by the CTCH. The setting range for this parameter is 0 to one less than the CTCH Allocation Period.

    GPIB command: CALL[:CELL[1]]:CTCHannel:FOFFset

    This parameter can only be set when operating mode is Cell Off .

  • Network Mode of Operation

    A UMTS network can operate in either Network Mode I or Mode II. In Mode I the MSC (Mobile Switching Centre) and the SGSN (Serving GPRS Support Node) are connected together. In Mode II these two network elements are not inter-connected. The primary consequence of Mode I is that UEs are allowed to perform combined GPRS Attach & IMSI Attach procedures and combined Location Update & Routing Area Update procedures. A combined procedure is a single over-the-air procedure that the network treats as if two separate procedures have occurred. For instance a UE that does a Combined GPRS Attach is treated by the network as having done both a GMM GPRS Attach and a MM IMSI Attach. For a combined procedure to work the SGSN network node (which tracks GPRS Attached status) must have a link to its associated MSC (which tracks IMSI Attach status). Then when the SGSN receives a Combined GPRS Attach message it can inform the MSC that the UE has also done an IMSI Attach. In Mode II the MSC and SGSN are not inter-connected so the UE is forced into doing separate GPRS Attach and IMSI Attach procedures and separate Routing Area Update and Location Area Update procedures. In Mode I the UE is not required by the standards to use the combined procedures, although it is likely to do so. For a UE to initiate a combined procedure it must have both of the separate procedures outstanding.

    In the test set, Mode I allows the UE to perform a Combined Attach (a GPRS Attach with Attach Type set to Combined Attach in the Attach Request message) to register in both the PS and CS Domains simultaneously. During a Combined Attach, the Data Connection State transitions as follows: Idle-Setup-Attaching-Idle. Upon completion of the Combined Attach, MM Status is IMSI Attached and GMM State is Attached . Note, PS Domain Information must be set to Present for the UE to perform a Combined Attach. If PS Domain Information is set to Absent and Network Mode of Operation is set to 1 when the UE registers, the UE simply performs an IMSI Attach.

    In Mode II, the UE must perform separate GPRS Attach and IMSI Attach procedures to register in both the PS and CS Domains. During this process, the Call Connection State transitions as follows: Idle-Setup-Registering-Releasing-Idle, then the Data Connection State transitions as follows: Idle-Setup-Attaching-Idle (often several seconds later).

    Note that in Mode I it is likely that only IMSI will be reported by the UE (and not IMEI); whereas in Mode II it is likely that both IMSI and IMEI will be reported by the UE. This is because in response to a registration attempt from the UE (Location Update Request or GPRS Attach Request) the test set sends a single Identity Request, which requests the UE's IMSI unless the UE already included its IMSI in its Location Update Request or GPRS Attach Request. Only if the UE already included its IMSI will the test set request the UE's IMEI in the Identity Request message. Thus, in Mode II when the UE performs a Location Update Request (which usually includes its IMSI), the test set requests the UE's IMEI with its Identity Request. In Mode I, the UE usually sends a P-TMSI in its Attach Request, so the test set requests the IMSI with its Identity Request instead of the IMEI.

    GPIB command: CALL[:CELL]:NMOPeration

    This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

  • Equipment Identity Request

    This parameter can be set to any of the following:

    • IMEI - The application requests the IMEI only. This behavior is the same as firmware releases prior to E.00.
    • EISV - The application requests the International Mobile Equipment Identity and Software Version Number (IMEISV). The IMEI is extracted from the IMEISV for use by the test set's front panel user interface.
    • ALL - The application requests both the IMEI and IMEISV using two separate identity request procedures.

    This setting applies to the following procedures: Location update, GPRS attach, Routing area update, CS paging response, PS paging response, and CS/PS Service request.

    GPIB Command: CALL[:CELL]:EIDentity:REQuest]

  • AICH Transmission Timing

    This setting controls the acquisition indicator channel's transmission timing in SIB5. This determines the timing of the uplink PRACH preamble-to-preamble and preamble-to-message part:

    • When set to 0, preamble-to-preamble timing = preamble-to-msg = 15360 chips (3 access slots); preamble-to-acquisition indicator = 7680 chips
    • When set to 1, preamble-to-preamble timing = preamble-to-msg = 20480 chips (4 access slots); preamble-to-acquisition indicator = 12800 chips

    Therefore there are 2 slots difference between the uplink PRACH and AICH burst when the AICH transmission timing is 1.

    GPIB Command: CALL:AICHannel:TRANsmission:TIMing

  • SCCPCH/PRACH Configuration

    This setting determines the configuration of the SCCPCH and PRACH channels:

    • When set to Signaling Only, the historical SCCPCH/PRACH configuration that only supports the PCCH/CCCH/DCCH logical channels is used.
    • When set to Signaling + Traffic, then the SCCPCH and PRACH are configured to support PS data DTCHs as well as the PCCH/CCCH/DCCH logical channels. The Signaling + Traffic mode is required for use with the CELL_FACH state on a PDP Context, however it also works for all other call types.

    GPIB Command: CALL:CCPChannel:SECondary:CONFigure

  • C-RNTI (Hex)

    The cell RNTI (C-RNTI) identifies a UE having a RRC connection within a cell. C-RNTI is one of the parameters used by UE to calculate FACH measurement occasions according to the equation in 3GPP TS 25.331.

    GPIB Command: CALL[:CELL]:CRNTi

  • Unexpected Page Response

    You can configure the test set to respond or to ignore some unexpected page response messages from the UE.

    • If Ignore (default value) is selected, the test set will ignore such messages as these messages typically indicate some fault in the UE, for example when the UE is unable to respond to a paging message before the test set times out.
    • If Respond is selected, the test set permits the acceptance and subsequent processing of Page Response bursts when there is no outstanding connection pending on a page response. For example, when performing the LTE CS fallback tests, the test set is not aware that the UE is paged by another RAT, so you should set the Unexpected Page Response to Respond so that the test set can respond appropriately.

    GPIB Command: CALL[:CELL]:DCHannel:UPRach

Related Topics

Manual Operation: How Do I Change Cell Parameters?


Cell Off Operating Mode

Cell Off Operating Mode

Last updated: January 15, 2009

Cell Off operating mode and Active Cell operating mode share the same settings. However, Cell Off mode allows you to change the parameters that cannot be changed during Active Cell operation but used for call processing, such as downlink and uplink channel number (UARFCN), reference measurement channel configuration (Channel Type), signalling radio bearer configuration, etc.

Use Cell Off operating mode to set up those downlink and uplink parameters before establishing a connection to the UE (mobile station). After making the settings, switch to Active Cell operating mode to begin generating the downlink signal. Use CALL:OPERating to select operating modes.

NOTE
No signal is generated by the test set during Cell Off operation, regardless of the Cell Power setting. All settings are deferred until the Active Cell operating mode or FDD Test operating mode is used.

Related Topics

Active Cell Operating Mode


Downlink and Uplink Channels Overview

Downlink and Uplink Channels Overview

Last updated: May 5, 2010

The "Downlink" refers to a radio link for the transmission of signals from the test set to a UE (mobile station) while the "Uplink" refers to a radio link for the transmission of signals from a UE (mobile station) to the test set. Table below summarizes the downlink and uplink channels supported by the test set in Active Cell operating mode and the FDD Test operating mode, and the following figures show the channel structures respectively.

In FDD test operating mode, when Channel Type is set to 12.2k RMC + HSDPA ( for lab applications or feature-licensed test applications only ), the test set also transmits up to 5 HS-PDSCHs (as determined by the FDD Test "FRC Type" on page 1 setting) and up to 4 HS-SCCHs.

Physical Channels in Active Cell and FDD Test Operating Modes
Active Cell Operating Mode |  | FDD Test Operating Mode
Downlink Channels | Uplink Channels | Downlink Channels | Uplink Channels
CPICH | PRACH | CPICH |
P-CCPCH/SCH | DPCH | P-CCPCH/SCH | DPCH
S-CCPCH |  |  |
PICH |  | PICH |
AICH |  |  |
DPCH |  | DPCH |
Comp. OCNS |  | Comp. OCNS |

Active Cell Mode Downlink Channel Structure

FDD Test Mode Downlink Channel Structure

Active Cell Mode W-CDMA Uplink Channel Structure

FDD Test Mode W-CDMA Uplink Channel Structure

Downlink Channels

The downlink channels transmitted by the test set in Active Cell operating mode (see Active Cell Mode Downlink Channel Structure ) are different from the downlink channels in FDD Test operating mode (see FDD Test Mode Downlink Channel Structure ). To configure the downlink channel codes and levels, see

  • Common pilot channel (CPICH): Used by the UE (mobile station) to find the primary scrambling code and to help determine its transmit power during open loop power control.
  • Primary common control physical channel (P-CCPCH): Contains the broadcast channel (BCH) that normally provides system information to the UE. In FDD Test operating mode, this channel consists of pseudo-random bit sequence (PRBS) data and a valid system frame number (SFN).
  • Secondary common control physical channel (S-CCPCH)

    Carries the signalling information used to set up the connection with the UE. This channel is not used in FDD Test Mode.

  • Synchronization channel (SCH): Includes the primary and secondary synchronization channels (PSC and SSC) that contain timing information to allow the UE to synchronize to the test set (or base station).
  • Page Indicator Channel (PICH)

    Used to alert the UE that it is possibly being paged. The UE must then read the Secondary common control physical channel (S-CCPCH) to determine if it is being paged.

    In Active Cell mode, the PICH contents are initially set to "no page" in all paging indicators. Once call origination is initiated, all of the page indicators in each valid access frame are set to indicate a page. The valid access frames occur at times specified by the DRX Cycle Length (CN Domain) setting. Once the UE has responded to the page, the paging indicators are returned to "no page."

    In FDD Test mode, the PICH contents are determined by the DL PICH Data setting.

  • Acquisition Indicator Channel (AICH): Used in response to a UE's PRACH Preambles to indicate to the UE that it may continue with call setup. This channel is not used in FDD Test Mode.
  • Dedicated physical channel (DPCH): Contains the dedicated physical control channel (DPCCH) which includes the transmit power control (TPC) and transmit format combination indicator (TFCI), and the dedicated physical data channel (DPDCH) which contains the user data.

Interference Sources on the Downlink

  • Additive White Gaussian Noise (AWGN) - can be summed into the downlink signal to simulate interference from other cells when enabled. See Cell Power and AWGN Power .
  • Orthogonal Channel Noise Simulator (OCNS) - used to simulate additional users on the downlink. OCNS is automatically enabled when the sum of the levels of all the enabled downlink physical channels is less than the cell power setting. See Orthogonal Channel Noise Simulator (OCNS) .

Uplink Channels

The test set recognizes two types of uplink physical channels, the Physical Random Access Channel (PRACH) and the Dedicated Physical Channel (DPCH). However, the Active Cell Mode W-CDMA Uplink Channel Structure is different from the FDD Test Mode W-CDMA Uplink Channel Structure .

  • Physical Random Access Channel (PRACH) - used by the UE to request registration on the network. The test set only responds to the PRACH in Active Cell Mode.
  • Dedicated Physical Channel (DPCH) - is the combination of the Dedicated Physical Data Channel (DPDCH) which carries the user data/signalling, and the Dedicated Physical Control Channel (DPCCH) which contains physical channel control information. In Active Cell Mode the test set will configure the Uplink DPCH by sending signalling information to the UE during Call Setup (see Channels Used for Call Setup ). In FDD Test Mode the Test Set assumes that the UE's uplink has been properly configured to match the expected configuration. The expected configuration is determined by the Channel Type setting.

Related Topics

W-CDMA Concepts


Channel (UARFCN) Information

Channel (UARFCN) Information

Last updated: January 15, 2009

The Channel (UARFCN) Information screen is a tool to help you identify what channels the test set is currently using (generating in the downlink or tuned to in the uplink), and in what band it is currently operating. It also provides a quick summary of how you've configured the Physical Channel Reconfiguration , Transport Channel Reconfiguration and Radio Bearer Reconfiguration handover channel settings.

  • Current Info, DL: Channel and Frequency
    • DL: Channel simply reflects the current DL Channel setting. It is shown for your convenience.
    • DL: Frequency reflects the downlink frequency that corresponds with the downlink channel setting.
  • Current Info, UL: Channel and Frequency

    • UL: Channel indicates the uplink channel that the test set is currently tuned to receive. If Uplink Channel is set to Auto , then this value is determined by the DL Channel setting (when Uplink Channel is set to Auto , the uplink UARFCN is automatically determined by the DL Channel setting - the test set subtracts the frequency separation associated with the DL Channel 's band from the DL Channel setting). Otherwise, this value is determined by the Uplink Channel setting.

      GPIB command: CALL:STATus:UPLink:CHANnel? .

    • UL: Frequency reflects the uplink frequency that corresponds with the uplink channel.
  • Current Info, DL/UL Frequency Separation

    Current Info, DL/UL Frequency Separation indicates what the current frequency separation is between the uplink and downlink channels. If Uplink Channel is set to Auto , this value is determined by the DL Channel setting (when Uplink Channel is set to Auto , the uplink UARFCN is automatically determined by the DL Channel setting - the test set subtracts the frequency separation associated with the DL Channel 's band from the DL Channel setting). Otherwise, this value is determined by the DL Channel and Uplink Channel settings. If you've chosen a combination of DL Channel and Uplink Channel that results in a separation other than those defined by 3GPP TS 25.101, Non Std is displayed.

    GPIB command: CALL:STATus:UPLink:SEParation? .

  • Current Info, Frequency Band

    Current Info, Frequency Band indicates what Frequency Band Indicator is sent by the test set when Frequency Band Indicator State is set to On .

    GPIB command: CALL:STATus:FBINdicator? .

  • PCR Info, DL: Channel and Frequency

    • DL: Channel simply reflects the current Handover Downlink Channel (UARFCN) setting. It is shown for your convenience.
    • DL: Frequency reflects the frequency that corresponds to the current Handover Downlink Channel (UARFCN) setting. It is shown for your convenience.

  • PCR Info, UL: Channel and Frequency

    • UL: Channel indicates the uplink channel the test set will tune to when a Physical Channel Reconfiguration is executed. If Handover Uplink Channel (UARFCN) is set to Auto , then this value is determined by the Handover Downlink Channel (UARFCN) setting (when Handover Uplink Channel (UARFCN) is set to Auto , the handover uplink UARFCN is automatically determined by the Handover Downlink Channel (UARFCN) setting - the test set subtracts the frequency separation associated with the handover downlink channels' band from the Handover Downlink Channel (UARFCN) setting). Otherwise, this value is determined by the Handover Uplink Channel (UARFCN) setting.

      GPIB command: CALL:STATus:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>UPLink[:CHANnel]? .

    • UL: Frequency indicates the frequency that corresponds to the uplink channel the test set will tune to when a Physical Channel Reconfiguration is executed.
  • PCR Info, DL/UL Frequency Separation

    PCR Info, DL/UL Frequency Separation indicates what the current frequency separation is between the handover uplink and downlink channels. If Handover Uplink Channel (UARFCN) is set to Auto , this value is determined by the Handover Downlink Channel (UARFCN) setting (when Handover Uplink Channel (UARFCN) is set to Auto , the handover uplink UARFCN is automatically determined by the Handover Downlink Channel (UARFCN) setting - the test set subtracts the frequency separation associated with the handover downlink channels' band from the Handover Downlink Channel (UARFCN) setting). Otherwise, this value is determined by the Handover Downlink Channel (UARFCN) and Handover Uplink Channel (UARFCN) settings. If you've chosen a combination of Handover Downlink Channel (UARFCN) and Handover Uplink Channel (UARFCN) that results in a separation other than those defined by 3GPP TS 25.101, Non Std is displayed.

    GPIB command: CALL:STATus:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>UPLink:SEParation?

  • PCR Info, Frequency Band

    PCR Info, Frequency Band indicates what Frequency Band Indicator is sent by the test set after the handover is complete when Frequency Band Indicator State is set to On .

    GPIB command: CALL:STATus:SETup[:PCReconfig]:FBINdicator?

  • TCR Info, DL: Channel and Frequency

    • DL: Channel simply reflects the current TCR Downlink Channel (UARFCN) setting. It is shown for your convenience.

    • DL: Frequency reflects the frequency that corresponds to the TCR Downlink Channel (UARFCN) setting.

  • TCR Info, UL: Channel and Frequency

    • UL: Channel indicates the uplink channel the test set will tune to when a Transport Channel Reconfiguration is executed (if TCR Channel (UARFCN) State is set to On ). If TCR Uplink Channel (UARFCN) is set to Auto , then this value is determined by the TCR Downlink Channel (UARFCN) setting (when TCR Uplink Channel (UARFCN) is set to Auto , the handover uplink UARFCN is automatically determined by the TCR Downlink Channel (UARFCN) setting - the test set subtracts the frequency separation associated with the handover downlink channels' band from the TCR Downlink Channel (UARFCN) setting). Otherwise, this value is determined by the TCR Uplink Channel (UARFCN) setting.

      GPIB command: CALL:STATus:SETup:TCReconfig:CHANnel:UPLink[:CHANnel]?

    • UL: Frequency indicates frequency that corresponds to the uplink channel that the test set will tune to when a transport channel reconfiguration occurs.
  • TCR Info, DL/UL Frequency Separation

    TCR Info, DL/UL Frequency Separation indicates what the current frequency separation is between the handover uplink and downlink channels. If TCR Uplink Channel (UARFCN) is set to Auto , this value is determined by the TCR Downlink Channel (UARFCN) setting (when TCR Uplink Channel (UARFCN) is set to Auto , the handover uplink UARFCN is automatically determined by the TCR Downlink Channel (UARFCN) setting - the test set subtracts the frequency separation associated with the handover downlink channels' band from the TCR Downlink Channel (UARFCN) setting). Otherwise, this value is determined by the TCR Downlink Channel (UARFCN) and TCR Uplink Channel (UARFCN) settings. If you've chosen a combination of TCR Downlink Channel (UARFCN) and TCR Uplink Channel (UARFCN) that results in a separation other than those defined by 3GPP TS 25.101, Non Std is displayed.

    GPIB command: CALL:STATus:SETup:TCReconfig:CHANnel:UPLink:SEParation?

  • TCR Info, Frequency Band

    TCR Info, Frequency Band indicates what Frequency Band Indicator is sent by the test set after the handover is complete when Frequency Band Indicator State is set to On .

    GPIB command: CALL:STATus:SETup:TCReconfig:FBINdicator?

  • RBR Info, DL: Channel and Frequency

    • DL: Channel simply reflects the current RBR Downlink Channel (UARFCN) setting. It is shown for your convenience.

    • DL: Frequency reflects the frequency that corresponds to the RBR Downlink Channel (UARFCN) setting.
  • RBR Info, UL: Channel and Frequency

    • UL: Channel indicates the uplink channel the test set will tune to when a Radio Bearer Reconfiguration is executed (if RBR Channel (UARFCN) State is set to On ). If RBR Uplink Channel (UARFCN) is set to Auto , then this value is determined by the RBR Downlink Channel (UARFCN) setting (when RBR Uplink Channel (UARFCN) is set to Auto , the handover uplink UARFCN is automatically determined by the RBR Downlink Channel (UARFCN) setting - the test set subtracts the frequency separation associated with the handover downlink channels' band from the RBR Downlink Channel (UARFCN) setting). Otherwise, this value is determined by the RBR Uplink Channel (UARFCN) setting.

      GPIB command: CALL:STATus:SETup:RBReconfig:CHANnel:UPLink[:CHANnel]?

    • UL: Frequency indicates the frequency that corresponds to the uplink channel the test set will tune to when a Radio Bearer Reconfiguration is executed.
  • RBR Info, DL/UL Frequency Separation

    RBR Info, DL/UL Frequency Separation indicates what the current frequency separation is between the handover uplink and downlink channels. If RBR Uplink Channel (UARFCN) is set to Auto , this value is determined by the RBR Downlink Channel (UARFCN) setting (when RBR Uplink Channel (UARFCN) is set to Auto , the handover uplink UARFCN is automatically determined by the RBR Downlink Channel (UARFCN) setting - the test set subtracts the frequency separation associated with the handover downlink channels' band from the RBR Downlink Channel (UARFCN) setting). Otherwise, this value is determined by the RBR Downlink Channel (UARFCN) and RBR Uplink Channel (UARFCN) settings. If you've chosen a combination of RBR Downlink Channel (UARFCN) and RBR Uplink Channel (UARFCN) that results in a separation other than those defined by 3GPP TS 25.101, Non Std is displayed.

    GPIB command: CALL:STATus:SETup:RBReconfig:CHANnel:UPLink:SEParation?

  • RBR Info, Frequency Band

    RBR Info, Frequency Band indicates what Frequency Band Indicator is sent by the test set after the handover is complete when Frequency Band Indicator State is set to On .

    GPIB command: CALL:STATus:SETup:RBReconfig:FBINdicator?

Manual Operation

To access the Channel (UARFCN) Information screen from the front panel:

  • Active Cell operating mode - press the More key until you reach the Call Control 2 of 5 menu, then select Channel (UARFCN) Info ( F1 ). The Channel (UARFCN) Information screen is also displayed when you select Handovers ( F5 on Call Control 1 of 5 ).
  • FDD Test operating mode - press the More key until you reach the Call Control 2 of 2 menu, select Additional Screens ( F1 ), then Channel (UARFCN) Info ( F1 )

Related Topics

Channel (UARFCN) Parameters


Channel (UARFCN) Parameters

Channel (UARFCN) Parameters

Last updated: February 3, 2009

The Channel (UARFCN) Parameters allow you to configure the downlink and uplink channels, and specify the frequency band. For more information on these parameters, see:

  • DL Channel
  • Uplink Channel
  • Band Arbitrator
  • Frequency Band Indicator State
  • Transmit SIB5bis

To help you configure the frequency band and channels, the Channel (UARFCN) Information screen displays the downlink and uplink channels currently in use by the test set, the current handover settings, and in what frequency band the test set is currently operating.

The following table summarizes the frequency bands and UARFCNs specified in 3GPP TS 25.101, and whether they are supported in the test set.

3GPP TS 25.101 Band/UARFCN Support in the Test Set
Band | DL to UL Frequency Separation (MHz) | 3GPP TS 25.101 Downlink UARFCN Range | 3GPP TS 25.101 Uplink UARFCN Range | Supported in the Test Set?
I (IMT-2000) | 190 | 10562 - 10838 | 9612 - 9888 | Yes
II (U.S. PCS) | 80 | 9662 - 9938 | 9262 - 9538 | Yes
 |  | 412, 437, 462, 487, 512, 537, 562, 587, 612, 637, 662, 687 | 12, 37, 62, 87, 112, 137, 162, 187, 212, 237, 262, 287 | Yes
III (DCS/PCS) | 95 | 1162 - 1513 | 937 - 1288 | Yes
IV | 400 | 1537 - 1738 | 1312 - 1513 | Yes *
 |  | 1887, 1912, 1937, 1962, 1987, 2012, 2037, 2062, 2087 | 1662, 1687, 1712, 1737, 1762, 1787, 1812, 1837, 1862
V (US Cellular) | 45 | 4357 - 4458 | 4132 - 4233 | Yes #
 |  | 1007, 1012, 1032, 1037, 1062, 1087 | 782, 787, 807, 812, 837, 862
VI (Japan 800) | 45 | 4387 - 4413 | 4162 - 4188 | Yes +
 |  | 1037, 1062 | 812, 837
VII | 120 | 2237 - 2563 | 2012 - 2338 | Yes
 |  | 2587, 2612, 2637, 2662, 2687, 2712, 2737, 2762, 2787, 2812, 2837, 2862, 2887, 2912 | 2362, 2387, 2412, 2437, 2462, 2487, 2512, 2537, 2562, 2587, 2612, 2637, 2662, 2687
VIII | 45 | 2937 - 3088 | 2712 - 2863 | Yes
IX | 95 | 9237 - 9387 | 8762 - 8912 | Yes*
X | 400 | 3112 - 3388 | 2887 - 3163 | Yes*
 |  | 3412, 3437, 3462, 3487, 3512, 3537, 3562, 3587, 3612, 3637, 3662, 3687 | 3187, 3212, 3237, 3262, 3287, 3312, 3337, 3362, 3387, 3412, 3437, 3462
XI | 48 | 3712 - 3812 | 3487 - 3587 | Yes
XII | 30 | 3837 - 3903 | 3612 - 3678 | Yes
 |  | 3927, 3932, 3957, 3962, 3987, 3992 | 3702, 3707, 3732, 3737, 3762, 3767
XIII | 31 | 4017 - 4043 | 3792 - 3818 | Yes
 |  | 4067, 4092 | 3842, 3867
XIV | 30 | 4117 - 4143 | 3892 - 3918 | Yes
 |  | 4167, 4192 | 3942, 3967

# In order to ensure a Frequency Band Indicator of Band V is sent in SIB5, set Frequency Band Indicator State to On and Band Arbitrator to Band V .

+ In order to ensure a Frequency Band Indicator of Band VI is sent in SIB5, set Frequency Band Indicator State to On and Band Arbitrator to Band VI .

* Ensure that the Transmit SIB5bis parameter is set accordingly for your UE.

Related Topics

Channel (UARFCN) Information


Compressed Mode

Compressed Mode

Last updated: January 15, 2012

This section is only applicable to the lab application.

  • Compressed Mode Overview
  • Enabling/Disabling Compressed Mode
  • Compressed Mode Parameters:
    • Shared Compressed Mode Parameters
    • TGPS Parameters
      • Key Considerations when Specifying the Transmission Gap Pattern Sequences
  • UE Measurement Setup
  • Compressed Mode Preset Configurations
  • Additional Considerations While in Compressed Mode Operation
  • Compressed Mode Operation While in FDD Test Operating Mode

Compressed Mode Overview

Compressed mode places gaps in the downlink and uplink transmissions that allow a UE, while on a call, to perform measurements on neighboring cells of a different frequency than its current serving cell. The UE can perform measurements on neighboring GSM, W-CDMA or E-UTRAN cells.

The network specifies the transmission gap pattern sequences (TGPSs), which control when the transmission gaps occur and their duration. During radio frames that contain transmission gaps, the UE and network use a lower spreading factor to avoid losing any data due to the smaller transmit/receive window caused by the transmission gap.

The compressed mode feature allows you to specify up to 4 TGPSs, each with a different measurement purpose, if desired. Each TGPS consists of repetitions of one transmission gap pattern, which can include one or two transmission gaps.

The test set supports compressed mode by spreading factor reduction in both the downlink and uplink. Note, however, that the test set does not transmit downlink compressed frames at an increased power level; compressed frames are transmitted at the same power level as non-compressed frames - the power level determined by the Cell Power setting. Additionally, the test set's DPCH is not turned off during the transmission gaps. The test set supports compressed mode on the following connection types and channel configurations: RB Test Mode, HSDPA RB Test Mode, HSUPA RB Test Mode, AMR voice, CS Data/Video Call, PS Data, HSDPA PS Data and HSUPA PS Data. The 384k RMC is not supported as it is not compressible by spread factor reduction because the uplink 384k DPCH already uses the minimum DPCH spreading factor of 4 (3GPP TS 25.212 s4.4.3.2 states, "The spreading factor (SF) can be reduced by 2 during one compressed radio frame to enable the transmission of the information bits in the remaining time slots of the compressed frame. This method is not supported for SF=4.").

The test set supports compressed mode for 384k downlink channels. Note that the test set does not support compressed mode for the 384k RMC, 384k UL/384k DL PS or 384k UL/HSDPA DL PS channels. These channels are not compressible by spread factor reduction because the uplink 384k DPCH already uses the minimum DPCH spreading factor of 4.

A consequence of the SF/2 spreading factor reduction method is that during compressed frames, the DPCH takes up twice as much code channel space as in non-compressed frames. As the downlink channels have to share the same code space care must be taken to ensure that compressed frames do not collide with other connected mode channels (for example, OCNS).

The test set uses an arbitrary channelization code allocation with collision detection scheme. The test set does not block any operations that cause code collision (such as the operation to activate Compressed Mode) but instead permits collisions.

However, when the test set has detected that a collision has occured, a persistent error message is generated,and since the UEs behaviour is unpredictable, any measurement results provided by the test set will not be reliable.

To avoid the possibility of collision, it is recommended that you use the test set's Downlink Channel Code Preset Configurations before enabling compressed mode. For example, a preset configuration is provided for Compressed Mode with 384k DL DPCH (Non-HSDPA) . You may also find it useful to refer to 3GPP TS 34.121 Annex E.6 "Downlink Physical Channels Code Allocation".

The following table summarizes the vaild channel code ranges that are available for use in compressed mode according to the specifications. See Downlink Channel Codes for additional information about channelization codes.

Channel Types Supported in Compressed Mode and Channelization Code Range
Channel Type | Valid Compressed Mode Channelization Code Range | Lab Application Front Panel Setting
5.9k - 4.75k AMR Voice | 2 to 255 (The following codes will avoid the possibility of a collision: 12, 13, 20, 21, 40, 43, 58, 126, 127, 142, 153, 174, 235, 255) | DPCH 15 ksps (OVSF 256) Channelization Code
12.2k RMC 33k No Coding RMC 12.2k - 6.7k AMR Voice 14.4k UL/14.4k DL CS Data RAB | 1 to 127 (The following codes will avoid the possibility of a collision: 20, 29, 37, 45, 60, 70, 76, 87, 93. Please note that the default value of 9 is not valid.) | DPCH 30 ksps (OVSF 128) Channelization Code
12.2k RMC + HSDPA | 1 to 127 (The following codes will avoid the possibility of a collision: 20, 29, 37, 45, 54) | HSDPA DPCH 30 ksps (OVSF 128) Channelization Code
64k/HSDPA PS (3.4k SRB used while on an HSDPA packet data connection) 128k UL/HSDPA DL PS (3.4k SRB used while on an HSDPA packet data connection) | 2 to 255 (The following codes will avoid the possibility of a collision: 40, 43, 58) | HSDPA DPCH 15 ksps (OVSF 256) Channelization Code,
64k RMC 12.2k UL/64k DL AM RMC 57.6k UL/57.6k DL CS Data RAB 64k UL/64k DL CS Data RAB 64k UL/64k DL PS Data RAB | 1 to 31 (The following codes will avoid the possibility of a collision: 24, 25, 26, 27) | DPCH 120 ksps (OVSF 32) Channelization Code
144k RMC 12.2k UL/144k DL AM RMC | 1 to 15 (The following codes will avoid the possibility of a collision: 12, 13) | DPCH 240 ksps (OVSF 16) Channelization Code
12.2k UL/384k DL AM RMC 64k UL/384k DL AM RMC 64k UL/384k DL RMC 64k UL/384k DL PS 128k UL/384k DL PS | 6 | DPCH 480 ksps (OVSF 8) Channelization Code

See Current Service Type for more information about the various channel types available in the test set.

Enabling/Disabling Compressed Mode

Once on a connection, you may enable (or disable) compressed mode operation by selecting Enable Compressed Mode (or Disable Compressed Mode ) or using the CALL:COMPressed:ENABle command. Upon successful activation of compressed mode, the Overall CM state changes to On in the Compressed Mode TGPS Information window, and any active TGPSs are displayed as On .

The Call Setup Screen also displays Compressed Mode State (which corresponds to Overall CM ) under Call Processing Status . Compressed Mode State/Overall CM can be queried using the CALL:STATus:COMPressed:STATe? command. If one or more TGPSs is active, Compressed Mode State/Overall CM is displayed as On . You can query which TGPSs are active using the CALL:STATus:COMPressed:TGPSequence:ALL:STATe? command. Note that if <num> TG Pattern Repetition Count (TGPRC) is non-zero, when the specified number of transmission gap pattern repetitions have occurred, the state of that TGPS changes from On to Off .

The message that activates compressed mode specifies a starting time that gives the UE sufficient time to respond with the proper messaging before compressed mode is enabled. If the proper messaging is received, Compressed Mode State/Overall CM changes to On .

You are not allowed to enable/disable compressed mode while Dual Cell HSDPA is configured.

Shared Compressed Mode Parameters

  • TGPS Definition During Call Setup

    Activation of compressed mode in the UE involves two steps:

    1. TGPS definition: the network (test set) supplies the TGPS definition(s).
    2. TGPS activation: the network (test set) orders the UE to activate a particular TGPS(s).

    These actions may be combined within a single message (Physical Channel Reconfiguration message while on a call) or in separate messages (TGPS definitions supplied in an RB Setup message during call setup and TGPS activation ordered in a Measurement Control or Physical Channel Reconfiguration message once on a call).

    You may specify whether to define the TGPSs during call setup or while on a call using the TGPS Definition During Call Setup parameter.

    If TGPS Definition During Call Setup is set to RB Setup , then the test set supplies the TGPS definitions to the UE in the RB Setup message during call setup.

    If TGPS Definition During Call Setup is set to Off , then the test set supplies the TGPS definitions to the UE after the call is established.

    See Summary of Options for Enabling Compressed Mode and UE Measurements .

    GPIB command: CALL:COMPressed:TGPSequence:DEFinition .

    This parameter can only be set when the connection status is idle.

  • CM PCR Timing Indication (CFN Handling)

    When compressed mode is enabled using a Physical Channel Reconfiguration message (see Summary of Options for Enabling Compressed Mode and UE Measurements ), you may specify whether the UE should maintain or initialise its CFN counter using the CM PCR Timing Indication (CFN Handling) parameter. This setting specifies whether the Timing Indication information element sent in the Physical Channel Reconfiguration message sent to enable/disable compressed mode is set to Maintain or Initialise.

    Note that 3GPP TS 25.331 v5.17.0 s8.6.6.28 states that the UE's behavior is undefined if the network sets the Timing Indication IE to Initialise on a non-hard handover (i.e. where the UARFCNs and one or more Primary Scrambling Codes remain unchanged as part of the reconfiguration). Thus, if you perform a Physical Channel Reconfiguration to enable/disable comprised mode with CM PCR Timing Indication (CFN Handling) set to Initialise , the UE may drop the call, ignore or reject the reconfiguration request, or report a reconfiguration failure. See RB setup Timing Indication (CFN Handling): for additional details.

    GPIB command: CALL:COMPressed:PCReconfig:CFNHandling .

  • Downlink Frame Structure Type

    The Downlink Frame Structure Type setting determines the frame structure signalled to the UE (which determines what the UE looks for during the downlink transmission gaps, see 3GPP TS 25.212 s4.4.2). Changing the Downlink Frame Structure Type setting does not change the structure of the downlink signal from the test set. Regardless of the Downlink Frame Structure Type setting, during compressed mode frames the test set sends the TPC field and pilot field in every slot (even the slots that occur during the transmission gap).

    GPIB command: CALL:COMPressed:TGPSequence:DFSType

    If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

  • HSDPA Downlink Transmission Mode

    This setting controls how HSDPA downlink channels transmit when working on compressed mode. When set to N-Skip TG , the test set transmits on HSDPA downlink channels regardless of transmission gap, that is, the test set always transmits on HSDPA downlink channels. When set to Skip TG , the test set will DTX on HSDPA downlink channels if it overlaps a transmission gap.

    GPIB Command: CALL:COMPressed:HSDPa:TRANsmission:MODE

  • HSUPA Downlink Transmission Mode (2ms TTI)

    This setting controls how the AG/RG command is transmitted when working on HSUPA 2ms TTI Compressed mode. When set to N-Skip TG , the test set transmits an AG/RG command on an E-AGCH/E-RGCH regardless of transmission gap. When set to Skip TG , the test set transmits an AG/RG command only on subframes that do not overlap with the transmission gap.

    GPIB Command: CALL:COMPressed:HSUPa:TRANsmission:MODE:MS2

TGPS Parameters

As per 3GPP TS 25.215 s6.1.1.2, "A transmission gap pattern sequence consists of consecutive occurrences of transmission gap pattern 1, where transmission gap pattern 1 consists of one or two transmission gaps."

If TGPS Definition During Call Setup is set to Off , the following parameters can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , the following parameters can only be changed when the connection status is idle.

  • <num> TGPS State

    You can enable up to four TGPSs. This setting controls which TGPSs are included in the compressed mode configuration signalled to the UE. You must set at least one TGPS state to On before enabling compressed mode.

    GPIB command: CALL:COMPressed:TGPSequence:ALL:STATe or CALL:COMPressed:TGPSequence([1]|2|3|4):STATe .

  • <num> TG Measurement Purpose (TGMP)

    You must specify what type of measurement the UE is to perform during the transmission gaps of each of the TGPSs (see 3GPP TS 25.215 s6.1.1.2 and 25.302 s7.3). For each TGPS, <num> TG Measurement Purpose (TGMP) can be set to:

    • FDD Meas

      Indicates that the purpose of the TGPS is for the UE to measure the inter-frequency (W-CDMA) cells you've specified in the SIB11 inter-frequency cell info list.

    • GSM RSSI

      Indicates that the purpose of the TGPS is for the UE to measure RSSI (GSM Cells) for the GSM cells you've specified in the SIB11 GSM cell info list.

    • GSM Initial BSIC ID

      Indicates that the purpose of the TGPS is for the UE to perform the Initial BSIC Identification procedure (see 3GPP TS 25.133 s8.1.2.5.2) for the GSM cells you've specified in the SIB11 GSM cell info list. Depending upon your UE's compressed mode implementation, you may need to set GSM Meas BSIC Verification to verifiedBSIC before your UE will perform the Initial BSIC Identification procedure.

    • GSM BSIC Reconfirmation

      Indicates that the purpose of the TGPS is for the UE to perform the BSIC Reconfirmation procedure (see 3GPP TS 25.133 s8.1.2.5.2) for the GSM cells you've specified in the SIB11 GSM cell info list. Depending upon your UE's compressed mode implementation, you may need to set GSM Meas BSIC Verification to verifiedBSIC before your UE will perform the BSIC Reconfirmation procedure.

    • EUTRA

      Indicates that the purpose of the TGPS is for the UE to measure the E-UTRAN cells you've specified in the SIB19 inter-frequency cell info list.

    Note that the UE will not send any Measurement Reports to the test set unless UE Measurements in Compressed Mode is set to On when compressed mode is enabled. Also, note that the Measurement Reports from the UE will only contain measurement results for either GSM, W-CDMA (FDD) or E-UTRAN neighbor cells, based on the Measurement Configuration setting. Thus, to receive UE reported measurement results when compressed mode is enabled, ensure that UE Measurements in Compressed Mode is set to On , and that the Measurement Configuration setting matches the TG Measurement Purpose for at least one active TGPS.

    GPIB command: CALL:COMPressed:TGPSequence:ALL:TGMPurpose or CALL:COMPressed:TGPSequence([1]|2|3|4):TGMPurpose .

The following parameters, (described in 3GPP TS 25.215 s6.1.1.2), characterize the transmission gap pattern:

  • <num> TG Starting Slot Number (TGSN)

    TGSN specifies the placement (slot 0 through slot 14) of TGL1.

    GPIB command: CALL:COMPressed:TGPSequence:ALL:TGSNumber or CALL:COMPressed:TGPSequence([1]|2|3|4):TGSNumber .

  • <num> TG Pattern Length (TGPL)

    TGPL specifies the duration of the transmission gap pattern (in frames). TGPL effectively specifies the number of frames between consecutive occurrences of TGL1. Note, TGPL must be long enough to encompass all of TGL1 and TGL2.

    GPIB command: CALL:COMPressed:TGPSequence:ALL:TGPLength or CALL:COMPressed:TGPSequence([1]|2|3|4):TGPLength .

  • <num> Transmission Gap Length 1 (TGL1)

    TGL1 specifies the length (in slots) of the first transmission gap in the transmission gap pattern. Note, there cannot be more than 7 transmission gap slots within one frame.

    GPIB command: CALL:COMPressed:TGPSequence:ALL:TGLength[1] or CALL:COMPressed:TGPSequence([1]|2|3|4):TGLength[1] .

  • <num> Transmission Gap Length 2 (TGL2)

    TGL2 specifies the length (in slots) of the second transmission gap in the transmission gap pattern. Note, there cannot be more than 7 transmission gap slots within one frame. Also, if TGL2 is non-zero, you must specify a valid <num> TG Start Distance (TGD) .

    GPIB command: CALL:COMPressed:TGPSequence:ALL:TGLength2 or CALL:COMPressed:TGPSequence([1]|2|3|4):TGLength2 .

  • <num> TG Start Distance (TGD)

    TGD sets the number of slots between the starting slots of TGL1 and TGL2. This setting is only applicable when TGL2 is non-zero. Note, you cannot place TGL1 and TGL2 within the same frame.

    GPIB command: CALL:COMPressed:TGPSequence:ALL:TGDistance or CALL:COMPressed:TGPSequence([1]|2|3|4):TGDistance .

The following parameters, (described in 3GPP TS 25.215 s6.1.1.2), control the transmission gap pattern sequence start and repetition:

  • <num> TG Relative CFN (TGCFN)

    Relative TGCFN (Transmission Gap Connection Frame Number) sets the position of the TGPS relative to the first frame for which compressed mode could be enabled. TGCFN is specified in number of frames.

    Typically, TGCFN for the first TGPS is set to 0, to start compressed mode as soon as possible. The other three TGPSs must then be offset so that there is never more than one transmission gap in a frame. Otherwise, an error will occur when the transmission gaps collide, see Key Considerations when Specifying the Transmission Gap Pattern Sequences .

    GPIB command: CALL:COMPressed:TGPSequence:ALL:TGCFn:RELative or CALL:COMPressed:TGPSequence([1]|2|3|4):TGCFn:RELative .

  • <num> TG Pattern Repetition Count (TGPRC)

    The test set allows one transmission gap pattern for each TGPS. TGPRC specifies how many times the transmission gap pattern is repeated. In other words, a TGPS is made up of TGPRC repetitions of the transmission gap pattern. A setting of zero indicates that the pattern repeats indefinitely. Note that if TGPRC is non-zero, when the specified number of transmission gap pattern repetitions have occurred, the state of that TGPS changes from On to Off (see Enabling/Disabling Compressed Mode ).

    GPIB command: CALL:COMPressed:TGPSequence:ALL:TGPRc or CALL:COMPressed:TGPSequence([1]|2|3|4):TGPRc .

In addition to the parameters described above, for downlink power control in compressed mode, the target SIR needs to be changed in several frames. The four values DeltaSIR1, DeltaSIRafter1, DeltaSIR2 and DeltaSIRafter2 are signalled by the test set to the UE (3GPP TS 25.331 s10.3.6.33). DeltaSIR2 and DeltaSIRafter2 are not transmitted by the test set.

  • <num> TG Delta SIR 1

    This parameter specifies the Delta in DL SIR target value to be set in the UE during compressed frames due to the first transmission gap.

    GPIB Command: CALL:COMPressed:TGPSequence:ALL:DSIR1 or CALL:COMPressed:TGPSequence([1]|2|3|4):DSIR1 .

  • <num> TG Delta SIR After 1

    This parameter specifies the Delta in DL SIR target value to be set in the UE one frame after the compressed frames due to the first transmission gap.

    GPIB Command: CALL:COMPressed:TGPSequence:ALL:DSIR1:AFTer or CALL:COMPressed:TGPSequence([1]|2|3|4):DSIR1:AFTer .

The following figure shows two sample TGPSs and the resulting compressed mode UE waveform as measured by the phase discontinuity measurement (see How Do I Make a Phase Discontinuity Measurement? ).

Key Considerations when Specifying the Transmission Gap Pattern Sequences

  • 3GPP TS 25.215 s6.1.1.2 and 25.302 s7.3 specify that only one transmission gap can occur in a frame. If you try to place more than one transmission gap in a frame, the following occurs:
    • An error is posted if you attempt to place TGL1 and TGL2 for a given TGPS within the same frame; in other words, if (TGSN + TGL1) > 15 and TGL2 > 0 and (TGSN + TDG) < 30, an error is posted.
    • If you place two transmission gaps from different TGPSs within a single frame, an error is not immediately posted. Rather, an error is posted when the transmission gap collision occurs after enabling compressed mode (the collision may not occur for several seconds, depending upon the TGCFN and TGPL settings). Once the collision occurs, the test set immediately disables the overlapping TGPS with the highest TGPSI (Transmission Gap Pattern Sequence Identifier), and proceeds to deactivate the entire compressed mode sequence (so that the test set and UE do not end up in an unsynchronized state if the UE does not properly handle the invalid configuration). You must change the invalid setting(s) before enabling compressed mode again. Note that if this type of deactivation occurs, some UEs require that you end and then re-establish the call before enabling compressed mode with the new settings.
    • An error is posted if you specify a transmission gap that crosses a frame boundary with TGPL set to 1; in other words, if TGL1 > (15 - TGSN) and TGPL < 2, an error is posted.
    • An error is posted if TGPL is not large enough to encompass both TGL1 and TGL2; in other words, if TGL2 > 0 and ceiling[(TGSN + TGD + TGL2)/15)] > TGPL, an error is posted.
  • 3GPP TS 25.212 s4.4.3 and s4.4.4 specify that there can not be more than 7 transmission gap slots in a frame. Thus, an error is posted if you attempt to place more than 7 transmission gap slots within a frame; in other words, if (15 - TGSN) > 7 and (TGL1 > 7) or if (TGL1 - (15 - TGSN)) > 7, an error is posted.
  • If <num> Transmission Gap Length 2 (TGL2) is greater than zero, you must enter a valid value for TGD. A warning is posted if <num> TG Start Distance (TGD) is set to 270 (Undefined) with TGL2 > 0.

UE Measurement Setup

When you enable compressed mode, the UE compresses its output according to the transmission gap pattern information it has been given by the test set (in the RB Setup or Physical Channel Reconfiguration message, as determined by the TGPS Definition During Call Setup setting). However, the UE will not send any Measurement Reports to the test set unless UE Measurements in Compressed Mode is set to On when compressed mode is enabled (the UE Measurements in Compressed Mode setting determines whether compressed mode is activated using a Measurement Control message, which orders the UE to return Measurement Reports, or using a Physical Channel Reconfiguration message, which does not request Measurement Reports).

The following table summarizes the options for enabling compressed mode and UE measurements:

Summary of Options for Enabling Compressed Mode and UE Measurements
TGPS Definition During Call Setup | UE Measurements in Compressed Mode | TGPS Definition occurs in which message? | TGPS Activation occurs in which message? | Result
RB Setup | Off | RB Setup message | Physical Channel Reconfiguration message | TGPS definition occurs during call setup, compressed mode is activated without UE measurements.
Off | Off | Physical Channel Reconfiguration message | Physical Channel Reconfiguration message | TGPS definition occurs after the call is established, compressed mode is activated without UE measurements.
RB Setup | On | RB Setup message | Measurement Control message | TGPS definition occurs during call setup, compressed mode is activated with UE measurements.
Off | On | Physical Channel Reconfiguration message | Measurement Control message | TGPS definition occurs after the call is established, compressed mode is activated with UE measurements.
See Compressed Mode Ladder Diagrams for more information about the messages exchanged during these operations.

To receive measurement results from the UE, as mentioned above you must set UE Measurements in Compressed Mode to On , but you must also ensure that the Measurement Configuration setting matches the <num> TG Measurement Purpose (TGMP) for at least one active TGPS.

When you enable compressed mode with UE measurements, the test set sends a Measurement Control message to the UE which includes a list of cells to measure (the SIB11 cell info list for inter-frequency cells or for GSM cells, or SIB19 cell info list for E-UTRAN cells, depending upon the Measurement Configuration setting). Thus, before enabling compressed mode with UE measurements, ensure that the cells in the SIB11 for SIB19 cell info lists are in a frequency band that is supported by your UE.

As the UE returns Measurement Reports, the results are posted to the front panel and available via GPIB (see Compressed Mode UE Reported Measurements ).

  • UE Measurements in Compressed Mode

    The UE Measurements in Compressed Mode parameter determines whether a Measurement Control message is used to activate compressed mode, or a Physical Channel Reconfiguration message.

    If UE Measurements in Compressed Mode is set to On , the test set sends a Measurement Control message to the UE to activate compressed mode. The Measurement Control message instructs the UE to send Measurement Reports for either inter-RAT (GSM), inter-frequency (W-CDMA) cells or inter-RAT E-UTRAN, as specified by the Measurement Configuration parameter, and includes the cells to measure (from either the SIB11 GSM Cell Info List, the SIB11 Inter-frequency Cell Info List , or SIB19 E-UTRA Info List ).

    If UE Measurements in Compressed Mode is set to Off , the test set sends a Physical Channel Reconfiguration message to the UE to activate compressed mode. No Measurement Control message is sent to the UE. Thus, no Measurement Reports are sent to the test set by the UE (so no UE measurement results are available).

    GPIB command: CALL:COMPressed:MEASurement:STATe .

  • Measurement Configuration

    The Measurement Configuration parameter determines the value signalled for the MeasurementType information element (interRATMeasurement, interFrequencyMeasurement or Inter RAT EUTRA Measurement) in the Measurement Control message used to activate compressed mode (if UE Measurements in Compressed Mode is set to On ). The Measurement Configuration parameter also determines which cells are included in the Measurement Control message (either the contents of the SIB11 GSM Cell Info List, the contents of the SIB11 Inter-frequency Cell Info List , or the content of the SIB19 E-UTRA Info List ).

    To receive UE reported measurement results, ensure that one or more of the TGPSs you've specified include a <num> TG Measurement Purpose (TGMP) corresponding to the Measurement Configuration you desire.

    The Measurement Control message can only contain one value for the MeasurementType information element, either interRATMeasurement (GSM cells), interFrequencyMeasurement (W-CDMA cells) or Inter RAT EUTRA Measurement (E-UTRAN cells). Thus, for a given compressed mode activation, the test set can only order the UE to measure either W-CDMA, GSM or E-UTRAN cells. For a given compressed mode activation you can include multiple TGPSs with FDD (W-CDMA) and GSM measurement purposes, but to change which type of cells are being measured by the UE, you must disable compressed mode, change Measurement Configuration , then enable compressed mode.

    GPIB command: CALL:COMPressed:MEASurement:CONFig:RATechnology

    This parameter can only be changed when compressed mode is not active.

  • GSM Meas BSIC Verification

    This parameter specifies whether the 3GPP TS 25.331 s10.3.7.29 "BSIC verification required" information element is set to "required" or "not required".

    Per 3GPP TS 25.331 s8.6.7.5, if GSM Meas BSIC Verification is set to verifiedBSIC , the UE will only report measurement results for cells for which it was able to decode the BSIC and match it to the NCC and BCC specified in the SIB11 GSM cell info list. If your UE does not support BSIC verification and you set GSM Meas BSIC Verification to verifiedBSIC , your UE will likely return empty Measurement Reports. If your UE supports BSIC verification you may still receive empty Measurement Reports when GSM BSIC Verification is set to verifiedBSIC if you do not include an active TGPS with a <num> TG Measurement Purpose (TGMP) of GSM Initial BSIC ID or GSM BSIC Reconfirmation (see 3GPP TS 25.331 s8.6.7.6).

    GPIB command: CALL:COMPressed:MEASurement:GSMSystem:BSIC:VERification

    This parameter can only be changed when compressed mode is not active.

  • GSM Meas N_Identify_Abort

    According to 3GPP TS 25.331 s10.3.6.33 and s14.3.2.2, "The parameter "N identify abort" in the IE "DPCH compressed mode info" indicates the maximum number of repeats of patterns that the UE shall use to attempt to decode the unknown BSIC of the GSM cell in the initial BSIC identification procedure." If the UE is unable to decode the BSIC within GSM Meas N_Identify_Abort attempts, it aborts the identification attempts for that particular cell and moves on to the next cell.

    GPIB command: CALL:COMPressed:MEASurement:GSMSystem:NIABort

    This parameter can only be changed when compressed mode is not active.

  • GSM Meas T_Re_Confirm_Abort (x0.5 seconds)

    According to 3GPP TS 25.331 s10.3.6.33 and s14.3.2.3, "The parameter "T reconfirm abort" in the IE "DPCH compressed mode info" indicates the maximum time allowed for the re-confirmation of the BSIC of one GSM cell in the BSIC re-confirmation procedure. The time is given in steps of 0.5 seconds." If the UE is unable to re-confirm the BSIC within GSM Meas T_Re_Confirm_Abort seconds, it aborts the re-confirmation attempts for that particular cell and treats that cell as a new GSM cell requiring initial BSIC identification.

    GPIB command: CALL:COMPressed:MEASurement:GSMSystem:TRCabort

    This parameter can only be changed when compressed mode is not active.

The UE performs periodic measurements on the neighbor cells that you specify. You may configure how many measurements are reported, and how often, using the following parameters:

  • GSM RSSI Measurement Reporting Quantity

    This setting determines how many Measurement Reports the UE returns when compressed mode is enabled with Measurement Configuration set to InterRATmeas . After the UE has returned the number of reports specified by this parameter, it stops reporting measurement results.

    GPIB command: CALL:COMPressed:MEASurement:GSMSystem:RSSI:RQUantity .

    This parameter can only be changed when compressed mode is not active.

  • GSM RSSI Measurement Reporting Interval

    This setting determines the period (in seconds) between measurement reports when compressed mode is enabled with Measurement Configuration set to InterRATmeas .

    GPIB command: CALL:COMPressed:MEASurement:GSMSystem:RSSI:RINTerval .

    This parameter can only be changed when compressed mode is not active.

  • Interfreq Measurement Reporting Quantity

    This setting determines how many Measurement Reports the UE returns when compressed mode is enabled with Measurement Configuration set to Interfrequencymeas . After the UE has returned the number of reports specified by this parameter, it stops reporting measurement results.

    GPIB command: CALL:COMPressed:MEASurement:ITRFrequency:RQUantity .

    This parameter can only be changed when compressed mode is not active.

  • Interfreq Measurement Reporting Interval

    This setting determines the period (in seconds) between measurement reports when compressed mode is enabled with Measurement Configuration set to Interfrequencymeas .

    GPIB command: CALL:COMPressed:MEASurement:ITRFrequency:RINTerval .

    This parameter can only be changed when compressed mode is not active.

  • E-UTRA Measurement Quantity

    Two types of E-UTRA measurements can be measured:

    • RSRP: this is a basic physical layer measurement of the linear average (in watts) of the downlink reference signals (RS) across the channel bandwidth.
    • RSRQ: RSRQ provides a measure of signal quality, defined as the ratio of RSRP to the E-UTRA carrier received signal strength indicator.

    GPIB command: CALL:COMPressed:MEASurement:EUTRa:QUANtity

  • E-UTRA Reporting Quantity

    This setting directs the UE as to what it should report to the network (as to perform the RSRQ mesurement it is necessary to first perform the RSRP measurement, hence both results will be available in the UE).

    GPIB command: CALL:COMPressed:MEASurement:EUTRa:RQUantity

  • E-UTRA Measurement Reporting Amount

    This setting determines how many measurement reports the UE will return after the measurement has been activated. This is the inter RAT measurement reporting amount within the measurement control message.

    GPIB command: CALL:COMPressed:MEASurement:EUTRa:RAMount

  • E-UTRA Measurement Reporting Interval

    This setting determines the period, in seconds, between measurement reports when the measurement is active in the UE.

    GPIB command: CALL:COMPressed:MEASurement:EUTRa:RINTerval

Compressed Mode Preset Configurations

From the front panel only, you can select the following preset configurations for compressed mode to quickly configure the test set for one of six typical compressed mode measurement scenarios.

Compressed Mode Preset Configurations
Setting | Compressed Mode Preset Configuration
 | Inter-freq FDD Meas | Inter-RAT Meas (GSM - Carrier RSSI) | Inter-RAT Meas (GSM - Init BSIC ID) | Inter-RAT Meas (GSM - BSIC Reconfirm) | Inter-RAT GSM Meas | Inter-freq FDD & Inter-RAT GSM Meas
3GPP reference | TS 34.121 Table C.5.2 Set 1 | TS 34.108 Table 6.8.6, TS 34.121 Table C.5.2 Set 2 | TS 34.108 Table 6.8.6 | TS 34.108 Table 6.8.6 | TS 34.108 Table 6.8.6 | TS 34.108 Table 6.8.7
TGPS State | 1,0,0,0 | 1,0,0,0 | 1,0,0,0 | 1,0,0,0 | 1,1,1,0 | 1,1,1,1
Meas Purpose | FDDM,GSMR, GIBI,GBR | GSMR,GIBI, GBR,FDDM | GIBI,GSMR, GBR,FDDM | GBR,GIBI, GSMR,FDDM | GBR,GSMR, GIBI,FDDM | FDDM,GSMR, GBR,GIBI
UE Meas in Comp Mode | On | On | On | On | On | On
Meas Config | Inter-freq | Inter-RAT | Inter-RAT | Inter-RAT | Inter-RAT | Inter-RAT (to perform inter-freq measurements you must disable comp mode, change this setting to inter-freq, then enable comp mode)
TGPRC | 0,0,0,0 | 0,0,0,0 | 0,0,0,0 | 0,0,0,0 | 0,0,0,0 | 0,0,0,0
TGCFN | 0,4,15,18 | 0,4,15,18 | 0,4,15,18 | 0,4,15,18 | 0,2,4,8 | 0,4,15,18
TGSN | 4,4,4,4 | 4,4,4,4 | 4,4,4,4 | 4,4,4,4 | 4,4,4,4 | 8,8,8,8
TGL1 | 7,7,7,7 | 7,7,7,7 | 7,7,7,7 | 7,7,7,7 | 7,7,7,7 | 14,14,14,14
TGL2 | 0,0,0,0 | 0,0,0,0 | 0,0,0,0 | 0,0,0,0 | 0,0,0,0 | 0,14,0,14
TGD | 270,270, 270,270 | 270,270, 270,270 | 270,270, 270,270 | 270,270, 270,270 | 270,270, 270,270 | 270,60, 270,45
TGPL | 3,8,8,8 | 12,8,8,8 | 8,8,8,8 | 8,8,8,8 | 8,12,8,8 | 12,24,24,24
Downlink Frame Structure Type | Type A | Type A | Type A | Type A | Type A | Type A

Additional Considerations While in Compressed Mode Operation

  • All call processing features that are normally available while on a call (such as handovers to a new frequency or RMC) are available during compressed mode operation, with the following exceptions and considerations:
    • Physical Channel Reconfiguration is available during compressed mode operation. As per the 3GPP standards, when PCR Timing Indication (CFN Handling) is set to Initialise , the test set automatically disables compressed mode operation upon completion of the handover (and expects the UE to do the same). When PCR Timing Indication (CFN Handling) is set to Maintain , compressed mode remains active after the PCR is complete.
    • When compressed mode is enabled, you cannot execute a Transport Channel Reconfiguration or Radio Bearer Reconfiguration with TCR or RBR Timing Indication (CFN Handling) set to Maintain . You can execute a Transport Channel Reconfiguration or Radio Bearer Configuration with TCR or RBR Timing Indication (CFN Handling) set to Initialise . As per the 3GPP standards, the test set automatically disables compressed mode operation upon completion of the handover (and expects the UE to do the same).
    • System Handover is available during compressed mode operation. Compressed mode is automatically disabled after the handover is complete (as compressed mode is a W-CDMA system functionality).
    • Soft Handover is available during compressed mode operation. Note that setting a non-zero Cell 2 Time Offset results in a corresponding time offset between the transmission gaps of the two cells.
  • While in compressed mode, the test set sends TPC fields in every slot, even slots that occur during transmission gaps. During transmission gaps, the test set sends TPC bits as prescribed by the UL CL Power Control Mode setting, except when UL CL Power Control Mode is set to Active bits . When UL CL Power Control Mode is set to Active bits , the test set transmits alternating bits during the transmission gaps. Note, the UE is not required to monitor TPC bits during transmission gaps. Thus, when UL CL Power Control Mode is set to All Up bits , All Down bits or 10 Up/Down bits , the UE's output power will not follow the specified pattern during transmission gaps.
  • Performing measurements while in compressed mode:
    • While in compressed mode, all transmitter measurements performed while on a call work intermittently, as the measurement may sample the uplink while the UE is not transmitting.
    • Receiver measurements (such as Loopback BER, BLER and HSDPA BLER) function completely during compressed mode operation. However, note that the downlink DPCH coding gain is reduced during compressed frames because the downlink DPCH spread factor is reduced, but the downlink power remains constant.
    • As compressed mode can only be enabled while on a call, measurements performed while not on a call (such as PRACH transmit on/off power and PRACH preamble analysis) are not affected by compressed mode operation.
  • 3GPP TS 25.214 s6A.3 specifies that the UE shall ignore HS-SCCH and HS-PDSCH transmissions that occur during a transmission gap on the downlink DPCH. The UE shall also not transmit its HS-DPCCH if the transmission would occur during a transmission gap on the uplink DPCH. When configured for an HSDPA RB Test Mode or HSDPA PS Data channel, the test set transmits HSDPA data regardless of the location of downlink or uplink transmission gaps. Therefore, when operating in compressed mode on an HSDPA channel, HSDPA BLER is artificially high due to additional statDTXs.

Compressed Mode Operation While in FDD Test Operating Mode

In FDD Test Operating Mode , you can configure up to 4 TGPSs using the TGPS Parameters (except TGMP and TGCFN) or the Compressed Mode Preset Configurations . Note that when you enable compressed mode in FDD test operating mode, the test set does not order the UE to enter compressed mode. Rather, enabling compressed mode simply causes the test set to start compressing its downlink DPCH according to the TGPSs you've specified and to expect the same compressed mode pattern(s) in the uplink DPCH. Before enabling compressed mode operation, you must synchronize your UE to the test set's signal and configure the UE's compressed mode transmission to match the TGPSs you've specified in the test set. Then, when you enable compressed mode in the test set you must also order your UE to begin compressing its signal on the <num> TG Starting CFN frame.

The <num> TG Relative CFN (TGCFN) settings are not applicable to FDD test operating mode. You must use the <num> TG Starting CFN settings to specify when compressed mode operation begins, and ensure that your UE is set to begin compressed mode operation at the CFN that matches this setting.

Because there is no signaling in FDD test operating mode, the UE can not perform neighbor cell measurements during compressed mode (the test set can not send a Measurement Control message to the UE to start neighbor cell measurements). Thus, the <num> TG Measurement Purpose (TGMP) settings are not applicable to FDD test operating mode.

The following settings are only available in FDD test operating mode.

  • <num> TG Starting CFN

    This setting determines the frame upon which the TGPS starts. TG Starting CFN can be set to any value between 0 and 255. Note that some UEs require that the starting CFN be aligned to a 40 ms boundary, as the DCCH of the RMC channels have a 40 ms TTI.

    GPIB command: CALL:FDDTest:COMPressed:TGPSequence:ALL:SCFNumber or CALL:FDDTest:COMPressed:TGPSequence([1]|2|3|4):SCFNumber .

  • Deactivation Type

    This setting controls whether compressed mode is deactivated immediately after you select Disable Compressed Mode , or upon a specific CFN (as specified by Ending CFN ). Note, if you change the Channel Type while compressed mode is active, it is immediately deactivated.

    GPIB command: CALL:FDDTest:COMPressed:DACTivation:TYPe .

  • Ending CFN

    When Deactivation Type is set to Specified CFN , the Ending CFN parameter specifies the specific CFN upon which compressed mode is deactivated after you select Disable Compressed Mode .

    GPIB command: CALL:FDDTest:COMPressed:ECFNumber .

Related Topics

Manual Operation: How Do I Enable Compressed Mode and Obtain UE Measurement Results?

Compressed Mode UE Reported Measurements

Compressed Mode Ladder Diagrams

Troubleshooting Compressed Mode Operation

CALL:COMPressed

CALL:STATus

CALL:FDDTest

SIB11 Cell Info List


W-CDMA Concepts

W-CDMA Concepts

Last Updated: January 15, 2009

W-CDMA Protocol Structure

The W-CDMA protocol has a layered structure designed to give the system a great deal of flexibility. The two major parts are the Core Network (CN) and Radio Access Network (RAN). The structure of the RAN and the relationship of several key terms to it are illustrated in W-CDMA Protocol Structure . It is important to recognize that this figure is only an illustration. The exact structure, including the number and type of channels, number and type of user services, and the configuration of blocks in the structure will vary over time to meet the current needs of the system. The structures of the uplink and downlink are very similar; however, some types of channels exist in only one direction; while others exist in both.

W-CDMA Protocol Structure

The WCDMA structure is divided vertically into an "Access Stratum" and a "Non-Access Stratum", and horizontally into a "Control Plane" and a "User Plane". Protocol Layers 1 and 2 are in the Access Stratum. Protocol Layer three is divided between the Access and Non-Access strata. In layers 2 and 3 control plane and user plane information is carried on separate channels. Within layer 1 some channels carry only control plane information, while others carry both user and control plane data.

Radio Bearer Test Mode, TC, and Reference Measurement Channels

Radio Bearer Test Mode is a special mode of operation defined by the W-CDMA specifications. Its purpose is to provide for efficient manufacturing testing of a W-CDMA UE by offering a simplified mode of operation wherein the Test Set has complete control of the necessary UE functions. A Radio Bearer Test Mode connection to the UE is done via a special Test Control (TC) protocol entity and any User Plane radio bearers are terminated in a layer 3 loopback entity, rather than being connected through to a real service. In radio Bearer Test Mode the protocol structure appears as shown in W-CDMA Protocol Structure in Radio Bearer Test Mode

W-CDMA Protocol Structure in Radio Bearer Test Mode

While it is still possible to configure layers 1 and 2 in any valid configuration in Radio Bearer Test Mode, the typical use of this mode is to set up the special test configurations known as "Reference Measurement Channels". The reference measurement channels are a defined set of configurations of layers 1 and 2 that provide stable, predictable behavior for radio testing. All aspects of these layers are explicitly defined by the definition of the Reference Measurement Channels given in the W-CDMA system specifications. The protocol structure of the Reference Measurement Channels is shown in W-CDMA Reference Measurement Channel Protocol Structure

W-CDMA Reference Measurement Channel Protocol Structure

W-CDMA Channels

"Channel" has several meanings in the W-CDMA system.

W-CDMA System Channels
Channel Name | Channel Type | Exists in Uplink | Exists in Downlink
CPICH | Physical Channel |  | *
P-CCPCH/SCH | Physical Channel |  | *
S-CCPCH | Physical Channel |  | *
PICH | Physical Channel |  | *
AICH | Physical Channel |  | *
DPCH | Physical Channel | * | *
PRACH | Physical Channel | * |
DCH | Transport Channel | * | *
RACH | Transport Channel | * |
PCH | Transport Channel |  | *
BCH | Transport Channel |  | *
FACH | Transport Channel |  | *
DTCH | Logical Channel | * | *
DCCH | Logical Channel | * | *
CCCH | Logical Channel | * | *
PCCH | Logical Channel |  | *
BCCH | Logical Channel |  | *

Downlink Overhead Channels

The overhead channels are transmitted continuously in each cell. They are used by the UE to synchronize to the cell, to identify the cell and the network, and to obtain information about how to access the cell.

W-CDMA Downlink Overhead Channels

  • Common Pilot Channel (CPICH) - used to transmit timing and frequency reference information to UEs (mobile stations) which are used by the UE (mobile station) to find the primary scrambling code and to help determine its transmit power during open loop power control.
  • Synchronization channel (SCH): includes the primary and secondary synchronization channels (PSC and SSC) that contain timing information to allow the UE to synchronize to the test set (or base station). It is time multiplexed with P-CCPCH.
  • Primary Common Control Physical Channel (P-CCPCH) - used to transmit Broadcast transport channel (BCH) which provides system information to the UE. It is time multiplexed with Synchronization Channel (SCH) which is used to aid the UE synchronization to the network. In FDD Test operating mode, this channel consists of pseudo-random bit sequence (PRBS) data and a valid system frame number (SFN).

Channels Used for Call Setup

After the UE has identified a cell that it wants to access and has read the access information from the Broadcast Channel, it must register. Registration informs the network of the presence of the UE and is performed using the Location Update Procedure.

In order for there to be any communication between the mobile and the network a control connection must be established between the RRC entities in the network and the UE. This step is the same whether the purpose is registration, mobile initiated call setup, or network originated call setup. These channels are shown in W-CDMA Connection Setup Channels

W-CDMA Connection Setup Channels

  • Acquisition Indication Channel (AICH) - used to acknowledge UE access request.
  • Paging Indication Channel (PICH) - used to alert the UE of a forthcoming page message. In FDD test mode, the test set only provides a user specified bit pattern to allow the operator to verify that the UE is correctly decoding this channel.
  • Secondary Common Control Physical Channel (S-CCPCH) - used to transmit pages and signalling to idling UEs.
  • Physical Random Access Channel - used by the UE to make its initial transmissions to the network.


Calling Party Number Parameters

Calling Party Number Parameters

Last updated: January 15, 2009

This section is only applicable to the lab application.

The test set allows you to specify the calling party number (CPN) parameters sent to the called mobile station so that you can evaluate the mobile station's behavior in response to the CPN (for example, to see whether the mobile station displays the calling party's number as expected).

When you originate a call from the test set, the calling party number parameter is sent to the called mobile station via the SETUP message. See How Do I Perform Calling Party Number Verification? for the detailed procedure.

When you send SMS messages, the test set also allows you to enter the originating address. The address setting for messages is different from that for calling party number. See Originating Address for more information.

Operating Considerations

The Calling Party Number feature is only applicable to UE-terminated CS services ( AMR Setup and the called UE when establishing a Video Call ).

Parameter Descriptions

The following gives the parameter and value descriptions defined in 3GPP TS 24.008 Section 10.5.4.9.

  • Calling Party Number Inclusion ("CALL:CPNumber:INCLusion" on page 8): specifies whether or not the calling party number parameters ( CALL:CPNumber[:SELected] , CALL:CPNumber:PLAN , CALL:CPNumber:PRESentation[:INDicator] , CALL:CPNumber:SCReening[:INDicator] and CALL:CPNumber:TYPE ) are sent to the called mobile station. If Exclude is selected, the parameters are not included in the message.
    Calling Party Number is Excluded

    If Include is selected, the parameters are filled in the message that is sent out to the mobile station.

    Calling Party Number is Included
  • Calling Party Number ( CALL:CPNumber[:SELected] ): indicates the ASCII representation of each character in the calling party number.
  • Number Type ( CALL:CPNumber:TYPE ): specifies the type of number used for the calling party number.
    Number Type

    Test Set's front panel

    Description

    NUMBER_TYPE Field Value

    Unknown

    Unknown number type

    000

    International

    International number

    001

    National

    National number

    010

    Network

    Network specific number

    011

    Dedicated

    Dedicated PAD access, short code

    100
  • Number Plan ( CALL:CPNumber:PLAN ): specifies the numbering plan used for the calling party number.
    Number Plan
    Test Set's front panel Description

    NUMBER_PLAN Field Value

    Unknown

    Unknown numbering plan

    0000

    ISDN/Telephony

    ISDN/Telephony numbering plan

    0001

    Data

    Data numbering plan

    0011

    Telex

    Telex Numbering plan

    0100

    Private

    Private numbering plan

    1001

    National

    National numbering plan

             1000
  • Presentation Indicator ( CALL:CPNumber:PRESentation[:INDicator] ): specifies whether or not to allow the calling party number to be displayed on the called mobile station's screen.
    Presentation Indicator
    Test Set's front panel

    Description

    PI Field Value

    Allowed

    Presentation allowed

    00

    Restricted

    Presentation restricted

    01

    Number Not Avail

    Address not available

    10
  • Screening Indicator ( CALL:CPNumber:SCReening[:INDicator] ): specifies how the calling number is screened.
    Screening Indicator
    Test Set's front panel

    Description

    SI Field Value

    User No Screen

    User provided, not screened

    00

    User Verify Pass

    User provided, verified passed

    01
    User Verify Fail

    User provided, verified and failed

             10

    Network

    Network provided

    11

Related Topics

How Do I Perform Calling Party Number Verification?


CW Operating Mode

CW Operating Mode

January 15, 2009

Description

When in CW operating mode, the test set operates like a signal generator. The basic features provided by CW operating mode are:

  • No over the air signaling is used. Therefore there is no synchronization between the mobile station and test set.
  • No demodulation or channel decoding is available.
  • No automatic receiver control is provided. Expected CW power, measurement receiver frequency, and uplink receiver frequency are available as manual settings only.

    Manual receiver control settings made while using the CW operating mode can affect manual receiver settings made in other operating modes. When changing operating modes and using manual receiver settings, always verify that the manual receiver settings are correct for the new operating mode.

  • Any one of three test signals can be generated while analyzing another signal (at the same frequency or at a different frequency). No interaction exists between these controls.
  • All test set measurements are available while in CW operating mode. However, measurements requiring protocol triggering cannot be made. Immediate triggering should be used for most measurements because no overhead signaling is occurring. Protocol triggering will timeout or report an integrity indicator other than zero.

Test Signals Description

The test set in CW operating mode provides any one of three test signals: CW (no modulation), AM (fixed 56% amplitude modulation), and DSB-SC (dual side-band suppressed carrier). An example usage of the test signals is for calibrating mobile stations that use Qualcomm's radioOne™ Zero Intermediate Frequency (Zero IF) architecture.

You can select any one of three signals with adjustable power level and frequency for output to the currently selected front panel RF connector.

  • With CW test signal selected (the default setting), the test set provides an unmodulated carrier. With either AM or DSB-SC test signal selected, the test set will modulate the signal as shown in the following figure.
  • For any of the test signals selected, the output power level is controlled by the Cell Power ( F7 ). The Cell Power refers to the power found in the entire signal including sidebands if applicable.
  • For any of the test signals selected, the frequency is adjusted by changing the RF Gen Freq ( F8 ).
    • With the CW or AM signal selected, the RF Gen Freq setting represents the center frequency of the signal (fc).
    • With the DSB-SC signal selected, the RF Gen Freq setting represents the frequency of the lower sideband signal (fL). The upper sideband (fh) is 20 kHz above the RF Gen Freq setting, that is fh = fL+20 kHz.

Programming Usage

Use the following commands to control each function for CW operating mode:

  • Select CW operating mode: CALL[:CELL]:OPERating:MODE
  • Set the cell power output level to be transmitted by the test set: CALL:POWer
  • Set the RF generator frequency: CALL[:CELL]:RFGenerator:FREQuency
  • Set the expected CW power level to be received by the test set: RFANalyzer:CW:EXPected:POWer
  • Set the measurement receiver frequency: RFANalyzer:MANual:MEASurement[:MFRequency]

Calibrating the Test Set

See Burst Mod Offset 1 Calibration .

Related Topics

Effects on Receiver Control When Changing Operating Mode


Digital Audio Interface (DAI) Description

Digital Audio Interface (DAI) Description

Last updated: January 15, 2009

This section is only applicable to the lab applications.

Digital Audio Interface (DAI) is a special interface that is used to perform the bit exact test of the speech coder/decoder and to test the SLR/RLR (Sending/Receiving Loudness Rating) performance of the analog and acoustic devices. You can insert and extract speech data in both the transmit and receive directions through DAI. Note that only the speech coder/decoder test is discussed in this section.

  • Digital Audio Interface (DAI) Overview
  • Digital Audio Interface (DAI) Typical Test Configuration
    • Digital Audio Interface (DAI) Downlink Test
    • Digital Audio Interface (DAI) Uplink Test
  • Digital Audio Interface (DAI) Parameters

Digital Audio Interface (DAI) Overview

The following figure shows the location of Digital Audio Interface in the Mobile Station. You can test the codec implementation of the UE based on a number of digital audio files sending or receiving through the Digital Audio Interface.

The data exchanged on the Digital Audio Interface are 13 bit linear PCM at 8000 samples per second, which, in order to keep the pin count low, are transferred on a duplex set of serial lines at 104 kbit/s.

The figure below shows the hardware aspect of the Digital Audio Interface:

The Reset line resets the speech transcoder and the speech A/D and D/A functions. Data is read in by the Mobile Station (MS) or System Simulator (SS) at the rising edge and are output by the SS or MS at the failing edge of the clock, as showed in the figure above.

To initiate a test, the SS applies the appropriate test control signals through the Digital Audio Interface or sends the appropriate layer 3 messages over the air interface to interrupt the normal speech data paths, and then, more than 1 second later, applies a reset pulse. Upon release of the reset pulse, the UE subsequently starts the test by issuing clock pulses when data is required or when ready.

Digital Audio Interface (DAI) Typical Test Configuration

The following diagram shows a typical Digital Audio Interface test configuration.

The customer test station (TS) acts as the control center of the DAI test. The TS connects with the test set through a GPIB interface. The TS can start the DAI test, command the test set to start/stop playing or recording the digital audio files, and query the play or record status of the digital audio file by sending GPIB command to the test set.

The TS connects with the UE via Digital Audio Interface. The TS sends reset pulses to command the mobile station to start sending or receiving the digital audio file through Digital Audio Interface.

Both the TS and the test set must be connected to the LAN. The TS can upload or download a digital audio file to or from the test set via an http interface.

  • To upload a COD reference file to the test set, the following HTTP client request should be made with the body containing the file itself depending on the codec type:
    • dai/upload/amr
  • To download a COD file from the test set, the following HTTP client request should be made, the response body shall contain the file "/dai/upload/amr".

The figure below shows the detailed view of the Digital Audio Interface test path.

You can test the Speech Decoder by performing the Digital Audio Interface (DAI) Downlink Test and the Speech Encoder by performing the Digital Audio Interface (DAI) Uplink Test .

Digital Audio Interface (DAI) Downlink Test

DAI Downlink Test is used to test the performance of the Speech Decoder in the Mobile Station (MS). To perform a downlink test, follow the steps below:

  1. Select which AMR Radio Access Bearer is to be tested in the test set.
  2. Instruct the TS to load the COD reference file into the test set via the HTTP interface, indicating which codec it applies to. An error message is displayed if the parse checking failed on the COD reference file.
  3. Start a voice call between the test set and the DUT (either Mobile Originated or Mobile Terminated).
  4. Command the TS to apply a reset pulse to DUT to prepare it for receiving the digital audio file from the test set.
  5. Command the TS to start recording the OUT file from the Mobile Station via the DAI.
  6. Instruct the test set to start playing the COD reference file which has been uploaded to it.
  7. Wait until the test set stops playing the COD reference file.
  8. Instruct the TS to stop recording the OUT files from MS and processes results.
  9. End the voice call connection.

See Programming a Downlink DAI Test for instructions on how to program an automated DAI Downlink Test.

Digital Audio Interface (DAI) Uplink Test

DAI Uplink Test is used to test the performance of the Speech Encoder in the Mobile Station. To perform an uplink test, follow the steps below:

  1. Select which AMR Radio Access Bearer is to be tested in the test set.
  2. Start a voice call between the test set and the DUT (either Mobile Originated or Mobile Terminated).
  3. Command the TS to apply reset pulse to DUT which forces the DUT to start transmitting the INP file.
  4. Instruct the test set to start recording the COD file it received from the DUT.
  5. Instruct the TS to start transferring the INP file to the Mobile Station.
  6. Instruct the test set to stop recording the COD file.
  7. Instruct the TS to retrieve the COD file from the test set via HTTP interface.
  8. End the call connection

See Programming a Uplink DAI Test for instructions on how to program an automated DAI Uplink Test.

Operating Considerations

The Digital Audio Interface test is only available in active cell operating mode. If the Operating Mode is changed to anything other than Active Cell, any active playing or recording of COD files is stopped.

On either full or partial preset the following actions are taken:

  • any uploaded COD file is removed.
  • any recorded (or partially recorded) COD file is removed.
  • playing or recording is stopped
  • play and record indicators go to `idle', and Progress and Record Buffer Usage indicators go to `0%'.

Digital Audio Interface (DAI) Parameters

  • Start COD Play

    This parameter is used to start playing the COD reference file in the test set.

    The following conditions are checked if you attempt to start playing a COD file. If one of these conditions is not met, an error message is generated:

    • COD reference file has been loaded.
    • COD reference file matches the currently set 'Logical Speech Channel'.
    • If 'Logical Speech Channel' is `AMR' then the COD file refers to only those AMR codec rates specified in the codec set and all codec rate changes are on odd or even frames.

    The GPIB command to set this parameter is CALL:DAINterface:PLAY:STARt .

  • Stop COD Play

    This parameter is used to stop playing the COD reference file in the test set.

    The GPIB command to set this parameter is CALL:DAINterface:PLAY:STOP .

  • Playing StatusThis parameter queries the Playing Status of the COD reference file.

    The GPIB command to set this parameter is CALL:DAINterface:PLAY:STATus? .

  • Start COD Record

    This parameter is used to start recording the COD file in the test set.

    The GPIB command to set this parameter is CALL:DAINterface:RECord:STARt .

  • Stop COD Record

    This parameter is used to stop recording the COD file in the test set.

    The GPIB command to set this parameter is CALL:DAINterface:RECord:STOP .

  • Recording Status

    This parameter queries the Recording Status of the COD file.

    The GPIB command to set this parameter is CALL:DAINterface:RECord:STATus? .

  • Playing / Recording Progress

    The Playing Progress indicates how far through playing the uploaded COD reference file the test set is.

    The Recording Progress indicates how far through the maximum possible capture COD file the test set is.

    The Playing / Recording Progress indicators are displayed on the front panel and updated frequently.

Related Topics

Manual Operation: How to use the Digital Audio Interface Features


Dual Cell HSDPA Concepts

Dual Cell HSDPA Concepts

Last updated: January 7, 2012

This section is only applicable to the lab application or feature-licensed test application.

Dual carrier HSDPA, also referred as dual cell HSDPA or DC-HSDPA in the test standard, is a WCDMA release 8 feature that allows the network to transmit HSDPA data from two cells simultaneously. The peak rate is doubled from 21Mbps to 42Mbps without the use of MIMO.

Dual cell operation require UE categories to be from 21 to 24 (See 3GPP TS 25.306).

See How Does the Test Set Supports DC-HSDPA for what functionalities are supported by the test set.

DC-HSDPA Architecture

  • Signal Transmission and Reception
  • MAC Layer
  • Layer 1 Timing
  • Signaling
  • 3GPP TS 34.121 Conformance Test
  • 3GPP References

Signal Transmission and Reception

While operating in DC-HSDPA mode, the UE receives HSDPA transmissions from two cells. The two cells transmit on separate but adjacent carriers while potentially having different cell powers. DC-HSDPA assumes that the two cells are served by the same Node-B. While the serving cell has a full set of common channels (SCH, P-CCPCH, CPICH, PICH, etc.), the UE must assume that the secondary serving cell only transmit CPICH (i.e., the UE cannot rely on the presence of an SCH/P-CCPCH).

Both cells can transmit HS-PDSCH and HS-SCCH to the UE simultaneously. Each cell's HS-PDSCH carries independent data. The UE determines the configuration of each cell's HS-PDSCH by reading each cell's HS-SCCH with independently assigned H-RNTI. As with single carrier HSDPA (SC-HSDPA), the UE monitors up to 4 HS-SCCHs from each cell, however the standard specifies that the UE can only monitor a total of 6 HS-SCCHs across both cells (see 3GPP TS 25.214 s6A.1.1).

On the uplink the UE transmits a single HS-DPCCH to the serving cell. This HS-DPCCH carries 1 or 2 Ack/Nack bits depending on how many HS-PDSCH transmissions the UE attempts to decode. The HS-DPCCH also carries 2 CQI reports, one for each cell (see 3GPP TS 25.212 s4.7). Despite more information on the HS-DPCCH in DC-HSDPA than SC-HSDPA, the underlying physical channel remains unchanged. Instead more code points are added to the Ack/Nack and CQI fields. While the secondary serving cell is active the UE uses deltaAck+1, deltaNack+1 or deltaCQI+1 (3GPP TS 25.214 s5.1.2.5A) to determine the HSDPA gain factor (Ahs). Ahs=38/15 with index 9 has been added to the table in 3GPP TS 25.213 s4.2.1.2.

MAC Layer

To the MAC-ehs layer (DC-HSDPA requires MAC-ehs), the two cells essentially look like two HS-DSCH transport channels. Each of these HS-DSCH channels are controlled by their own independent HARQ process entity, with each entity containing a unique set of HARQ processes. Each of the two HARQ process entities are fed by a common priority queue which means that the rest of the stack from MAC-d upwards is unaware that two carriers are being used to transmit data to the UE.

To restrict the amount of soft memory that can be allocated to single HARQ process (and thus limit the amount of data that has to be transferred across the UE's internal data buses), the standard specifies that when setting up a DC-HSDPA call with the implicit HARQ memory partitioning the network must configure 6, 7, or 8 HARQ processes per cell (3GPP TS 25.331 s10.3.5.7a). For the explicit HARQ memory partitioning case, the number of HARQ processes can be 1 through 8, but the memory size for each HARQ process can not be greater than the number of soft channel bits for an implicit memory partitioning with 6 processes per HS-DSCH channel (3GPP TS 25.331 s8.6.5.6b).

Layer 1 Timing

For a secondary serving HS-DSCH cell, the nominal radio frame timing for CPICH and the timing reference are the same as the radio frame timing for CPICH and timing reference for the serving HS-DSCH cell (3GPP TS 25.211 s7.1).

Signaling

With signaling, the UE indicates whether it supports DC-HSDPA in the RRC Connection Setup Request message and then signals its DC-HSDPA category in the RRC Connection Setup Complete message.

The network enables and activates DC-HSDPA at call setup in the RRC Connection Setup or RB Setup message. Once on a connection, DC-HSDPA can be enabled or disabled by all the reconfiguration messages (Radio Bearer Reconfiguration (RBR), Transport Channel Reconfiguration (TCR) and Physical Channel Reconfiguration (PCR)), or by using the RB Release or Active Set Update message.

When DC-HSDPA is enabled, the secondary serving cell can also be activated or deactivated using HS-SCCH orders that can be sent on either the serving or secondary serving cell (the UE.s behavior is undefined if it receives conflicting orders).

The DRX status and activation and deactivation of the DRX with HS-SCCH is common to both serving and secondary serving cells, and the related HS-SCCH signaling can be sent on either the serving or the secondary serving HS-DSCH cell.

3GPP TS 34.121 Conformance Test

3GPP TS 34.121-1 added new test cases in both chapter 6 (Receiver Characteristics) and chapter 9 (Performance Requirements for HSDPA) for DC-HSDPA devices testing. New FRC channel configurations are also defined, namely H-Set 3A, H-Set 6A, H-Set 8A, H-Set 10A, and H-Set 12. For each of the H-sets, the same parameters are used for each of the cells, for example: H-Set 3A is formed by applying H-Set 3 parameters to each of the cells.

Reference sensitivity levels have been raised by 4 dB for DC-HSDPA tests. BLER must be measured independently for each cell. Two new Reporting of CQI tests verify the UE.s ability to accurately report CQI for both cells. 3GPP TS 34.108 s7.3.13 defines a call setup procedure for DC-HSDPA RF conformance testing that is almost identical to the regular HSDPA call setup procedure with the exception that the loop is not closed on the 12.2 kbps reference measurement channel (RMC). Instead, each test is required to specify loopback conditions.

3GPP References

Refer to the following 3GPP documents if you want to know more about DC-HSDPA:

  • 3GPP TR 25.825 Dual-Cell HSDPA operation
  • 3GPP TS 25.211 Physical channels and mapping of transport channels onto physical channels (FDD) (Release 8) V8.7.0 (2010-09)
  • 3GPP TS 25.212 Multiplexing and channel coding (FDD) (Release 8) V8.6.0 (2009-09)
  • 3GPP TS 25.213 Spreading and modulation (FDD) (Release 8) V8.5.0 (2009-12)
  • 3GPP TS 25.214 Physical layer procedures (FDD) (Release 8)
  • 3GPP TS 25.306 UE Radio Access capabilities (Release 8) V8.10.0 (2010-09)
  • 3GPP TS 25.331 Radio Resource Control (RRC) Protocol Specification (Release 8) V8.12.0 (2010-09)
  • 3GPP TS 34.108 Common test environments for User Equipment (UE) Conformance testing (Release 8) V8.10.0 (2010-03)
  • 3GPP TS 34.121-1 V9.2.0 (2010-09) User Equipment (UE) conformance specification; Radio transmission and reception (FDD); Part 1: Conformance specification

How Does the Test Set Supports DC-HSDPA

The test set supports DC-HSDPA with the following functionalities:

  • FDD test and Active cell operating mode
  • 42 Mbps maximum downlink data rate and 11 Mbps maximum uplink data rate
  • In Active Cell operating mode, RB test mode and PS data connection with detailed DC-HSDPA information display. See HSDPA RB Test Mode Settings , HSDPA PS Data Setup and DC-HSDPA Information (PS data connection is lab application only)
  • HSDPA BLER measurement, see HSDPA Block Error Ratio Measurement Description
  • Data throughput monitor. See Data Throughput Monitor Description (lab application only)
  • 3GPP TS 34.121-1 DC-HSDPA test cases, including chapter 6 receiver measurements (6.2A , 6.3C , 6.3D , 6.4B , 6.5A , 6.6A and 6.7A) and chapter 9 Performance requirements for HSDPA (s9.2.1FA and s9.2.1LA with external fading). See What 3GPP W-CDMA/HSPA Conformance Tests Are Supported? .
  • 3GPP TS 34.121 preset call configurations for s6.3C and s6.3D. See DC-HSDPA 34.121 Preset Call Configurations .
  • Activate and De-activate the secondary serving cell using HS-SCCH orders. See Activate/De-activate the Secondary Serving Cell
  • Serving cell and secondary serving cell on adjacent channels in any band, I through XIV and XIX through XXI
  • H-Sets 3A, 6A, 8A, 10A, and 12. See FRC Type .
  • HS-DSCH categories 21 through 24. See Manual UE DC-HSDPA HS-DSCH Category .
  • Selectable loopback of 12.2k RMC with DC-HSDPA downlink active. See DC-HSDPA DPCH Loopback State
  • Physical Channel Reconfiguration (PCR) procedure. See HSDPA Secondary Cell Handover DL UARFCN
  • CELL_DCH, CELL_FACH, CELL_PCH and URA_PCH RRC states and transitions including fast dormancy
  • Ciphering
  • IPv6
  • Multiple PDP contexts
  • Simultaneous services (CS voice + PS data)
  • SMS
  • Wireless Protocol Advisor (WPA) for protocol logging

Related Topics

W-CDMA Concepts


DC-HSDPA Information

DC-HSDPA Information

Last updated: January 6, 2012

Manual Operation: When the required license is available, you can view the DC-HSDPA Information by CALL SETUP -> Call Control 2 of 6 -> Additional Screens ( F1 ) -> HSDPA Information ( F4 ) -> DC-HSDPA Information ( F4 ).

These results are cleared by the Clear UE Info action.

Secondary Serving Cell Status

  • Current Secondary Serving Cell Status

    This result indicates the state of the state of the DC-HSDPA secondary serving cell, whether to be Not Configured (No DC-HSDPA connection in place), Configured-Inactive or Configured-Active (the test set and UE agrees that a DC-HSDPA connection is set up)

    Once a DC-HSDPA connection is set up, you can activate or de-activate the secondary serving cell by HS-SCCH orders, see Send Activate Secondary Cell and Deactivate Secondary Cell .

    GPIB command: CALL:STATus:SSCell?

DC-HSDPA Counters

The DC-HSDPA Information window displays counters to help you monitor the DC-HSDPA connection status. The results are continually updated until one of the following occurs:

  • You establish a new connection in active cell operating mode (or change the Channel Type from 12.2k RMC + HSDPA in FDD Test Operating Mode ).
  • Blocks Transferred - Summary reaches 150,000.

When one of these events occurs, the counters reset to zero and then resume counting.

  • You press the MEASUREMENT RESET key ( SYSTem:MEASurement:RESet ).
  • You select Clear UE Info ( CALL:MS:REPorted:CLEar[:ALL]<[:SELected]|:WCDMa> ).
  • You change operating mode.
  • You establish a new connection in active cell operating mode (or change the Channel Type from 12.2k RMC + HSDPA in FDD Test Operating Mode ).

When one of these events occurs, the counters reset to NaN and then resume counting.

The DC-HSDPA information provide the following results:

DC-HSDPA Real Time Results with GPIB
 | Summary | Serving Cell | Secondary Serving Cell
Block Error Ratio | CALL:HSDPa:MS:REPorted:HBLerror:RATio? | CALL:HSDPa:MS:REPorted:SCELl:HBLerror:RATio? | CALL:HSDPa:MS:REPorted:SSCell:HBLerror:RATio?
Throughput | CALL:HSDPa:MS:REPorted:IBTHroughput? | CALL:HSDPa:MS:REPorted:SCELl:IBTHroughput? | CALL:HSDPa:MS:REPorted:SSCell:IBTHroughput?
Blocks Transferred | CALL:HSDPa:MS:REPorted:BLOCks? | CALL:HSDPa:MS:REPorted:SCELl:BLOCks? | CALL:HSDPa:MS:REPorted:SSCell:BLOCks?
ACKs Received | CALL:HSDPa:MS:REPorted:ACK? | CALL:HSDPa:MS:REPorted:SCELl:ACK? | CALL:HSDPa:MS:REPorted:SSCell:ACK?
NACKs Received | CALL:HSDPa:MS:REPorted:NACK? | CALL:HSDPa:MS:REPorted:SCELl:NACK? | CALL:HSDPa:MS:REPorted:SSCell:NACK?
statDTXs Received | CALL:HSDPa:MS:REPorted:SDTX? | CALL:HSDPa:MS:REPorted:SCELl:SDTX? | CALL:HSDPa:MS:REPorted:SSCell:SDTX?
Count of Reported CQI Limitations | CALL:STATus:REPorted:CQI:LIMitation:COUNt? | CALL:STATus:REPorted:SCELl:CQI:LIMitation:COUNt? | CALL:STATus:REPorted:SSCell:CQI:LIMitation:COUNt?
Last received CQI | - | CALL:HSDPa:MS:REPorted:SCELl:CQI[:LAST]?] | CALL:HSDPa:MS:REPorted:SSCell:CQI[:LAST]?]
Maximum Allowed CQI | - | CALL:STATus:MAXimum:ALLowed:CQI:VALue? | CALL:STATus:SSCell:MAXimum:ALLowed:CQI:VALue?
Test Mode User Def TB Size | - | CALL:STATus:HSDSchannel:TBSize? (Active Cell) or CALL:FDDTest:HSDSchannel:UDEFined:TBSize:INDex (FDD Test) | CALL:STATus:SSCell:HSDSchannel:TBSize? (Active Cell) or CALL:FDDTest:SSCell:HSDSchannel:UDEFined:TBSize:INDex (FDD Test)
PS Data User Def TB Size | - | CALL:STATus:HSDSchannel:TBSize:PSData? | CALL:STATus:SSCell:HSDSchannel:TBSize:PSData?
Last Signaled Measurement Power Offset | - | CALL:STATus:MPOWer:OFFSet:SIGNaled? | CALL:STATus:SSCell:MPOWer:OFFSet:SIGNaled?

Related Topics

HSDPA Parameters


Downlink Channel (UARFCN)

Downlink Channel (UARFCN)

Last updated: January 12, 2011

DL Channel

The DL Channel setting specifies the downlink UTRA Absolute RF Channel Number (UARFCN). This determines at what frequency the test set's RF generator will transmit the downlink signal.

The relationship between UARFCN and downlink frequency is described in 3GPP TS 25.101 section 5.

Downlink Frequency and UARFCN, and DL Channel Range
Band TS 25.101
DL to UL Frequency Separation (MHz) 		TS 25.101
Center Frequency Range (MHz) 		TS 25.101
UARFCN Equation 		TS 25.101
UARFCN Range 		Test Set "DL Channel" Range
I
(IMT-2000) 		190 2112.4 - 2167.6,
increment = 0.2 		5 * (center freq in MHz)

10562 - 10838

10562 - 10838
II
(U.S. PCS) 		80 1932.4 - 1987.6,
increment = 0.2 		5 * (center freq in MHz) 9662 - 9938 9662 - 9938
1932.5 - 1987.5,
increment = 5 		5 * ((center freq in MHz) - 1850.1 MHz) 412, 437, 462, 487, 512, 537, 562, 587, 612, 637, 662, 687 412, 437, 462, 487, 512, 537, 562, 587, 612, 637, 662, 687
III
(DCS/PCS) 		95 1807.4 - 1877.6,
increment = 0.2 		5 * ((center freq in MHz) - 1575 MHz) 1162 - 1513 1162 - 1513
IV 400 2112.4 - 2152.6,
increment = 0.2 		5 * ((center freq in MHz) - 1805 MHz) 1537 - 1738 1537 - 1738 *
2112.5 - 2152.5,
increment = 5 		5 * ((center freq in MHz) - 1735.1 MHz) 1887, 1912, 1937, 1962, 1987, 2012, 2037, 2062, 2087 1887, 1912, 1937, 1962, 1987, 2012, 2037, 2062, 2087 *
V
(US Cellular) 		45 871.4 - 891.6,
increment = 0.2 		5 * (center freq in MHz) 4357 - 4458 4357 - 4458 #
871.5, 872.5, 876.5, 877.5, 882.5, 887.5 | 5* ((center freq in MHz) - 670.1 MHz) | 1007, 1012, 1032, 1037, 1062, 1087 | 1007, 1012, 1032, 1037, 1062, 1087 #
VI
(Japan 800) 		45 877.4 - 882.6,
increment = 0.2 		5 * (center freq in MHz) 4387 - 4413 4387 - 4413 +
877.5, 882.5 | 5 * ((center freq in MHz) - 670.1 MHz) | 1037, 1062 | 1037, 1062 +
VII 120 2622.4 - 2687.6,
increment = 0.2 		5 * ((center freq in MHz) - 2175 MHz) 2237 - 2563 2237 - 2563
2622.5 - 2687.5,
increment = 5 		5 * ((center freq in MHz) - 2105.1 MHz) 2587, 2612, 2637, 2662, 2687, 2712, 2737, 2762, 2787, 2812, 2837, 2862, 2887, 2912 2587, 2612, 2637, 2662, 2687, 2712, 2737, 2762, 2787, 2812, 2837, 2862, 2887, 2912
VIII 45 927.4 - 957.6,
increment = 0.2 		5 * ((center freq in MHz) - 340 MHz) 2937 - 3088 2937 - 3088
IX 95 1847.4 - 1877.4,
increment = 0.2 		5 * (center freq in MHz) 9237 - 9387 9237 - 9387 *
X 400 2112.4 - 2167.6,
increment = 0.2 		5 * ((center freq in MHz) - 1490 MHz) 3112 - 3388 3112 - 3388 *
2112.5 - 2167.5,
increment = 5 		5 * ((center freq in MHz) - 1430.1 MHz) 3412, 3437, 3462, 3487, 3512, 3537, 3562, 3587, 3612, 3637, 3662, 3687 3412, 3437, 3462, 3487, 3512, 3537, 3562, 3587, 3612, 3637, 3662, 3687 *

XI

48

1478.4 - 1498.4, increment = 0.2

 5 * ((center freq in MHz) - 736 MHz)

3712 - 3812

3712 - 3812

XII

30

730.4 - 743.6, , increment = 0.2

 5 * ((center freq in MHz) + 37 MHz)

3837 - 3903

3837 - 3903
730.5, 731.5, 736.5, 737.5, 742.5, 743.5 | 5 * ((center freq in MHz) + 54.9 MHz) | 3927, 3932, 3957, 3962, 3987, 3992 | 3927, 3932, 3957, 3962, 3987, 3992

XIII

31

748.4 - 753.6, , increment = 0.2

5 * ((center freq in MHz) + 55 MHz)

4017 - 4043

4017 - 4043
748.5, 753.5 | 5 * ((center freq in MHz) + 64.9 MHz) | 4067, 4092 | 4067, 4092

XIV

30

760.4 - 765.6, , increment = 0.2

 5 * ((center freq in MHz) + 63 MHz)

4117 - 4143

4117 - 4143
760.5, 765.5 | 5 * ((center freq in MHz) + 72.9 MHz) | 4167, 4192 | 4167, 4192

XIX

45

877.4- 887.6

5 * ((center freq in MHz) - 735 MHz)

 712 to 763

712 to 763

877.5, 882.5, 887.5

5 * ((center freq in MHz) - 720.1 MHz)

787, 812, 837

787, 812, 837

XX

41

793.4 - 818.6

5 * ((center freq in MHz) + 109 MHz)

4512 to 4638

4512 to 4638

XXI

48

1498.4 - 1508.4

5 * ((center freq in MHz) - 1326 MHz)

 862 to 912

862 to 912

# In order to ensure a Frequency Band Indicator of Band V is sent in SIB5 when DL Channel is set to any of these UARFCNs, set Frequency Band Indicator State to On and Band Arbitrator to Band V .

+ In order to ensure a Frequency Band Indicator of Band VI is sent in SIB5 when DL Channel is set to any of these UARFCNs, set Frequency Band Indicator State to On and Band Arbitrator to Band VI .

* Ensure that the Transmit SIB5bis parameter is set accordingly for your UE.

When in FDD Test operating mode, the downlink frequency can also be set by setting RF Gen Freq Ctrl to Manual and then manually entering the RF Gen Freq .

To set the downlink channel number via GPIB command, see CALL:CHANnel .

Operating Considerations

  • This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in an error and the test set rejects the change. Use the Cell Off operating mode when changing this setting. See CALL:OPERating to select operating modes.
  • To hand over to a new downlink channel while on a connection, you must perform a Physical Channel Reconfiguration , Transport Channel Reconfiguration or Radio Bearer Reconfiguration . After successful completion of a handover to a new DL UARFCN, the DL Channel setting is overwritten with the value of the handover downlink channel .
  • If the DL Channel setting results in an UL/DL offset of less than 30 MHz when compared with the Uplink Channel setting, the warning message "Performance not specified for UL/DL frequency offset <30 MHz" is issued.

Related Topics

Manual Operation: Setting Call Parameters that Can Only Be Changed in Cell Off Mode

CALL:CHANnel

Channel (UARFCN) Parameters

Channel (UARFCN) Information

Uplink Channel (UARFCN)

Handovers


Downlink Channel Codes and Levels

Downlink Channel Codes and Levels

Last updated: January 8, 2012

You can specify the channel code, state and level of most of the downlink channels generated by the test set (some are fixed). Some of the downlink channels can have a different code, state or level depending upon the state of the test set.

Downlink Channel Codes and Levels for each Test Set State
Operating Mode | Call State | Connection Type | Codes | State/Levels
FDD Test |  |  | FDD Test Operating Mode
Active Cell | Idle |  | Shared DL Channel Codes | Downlink Channel Levels
 | Connected | non-HSDPA/ non-HSPA | Shared DL Channel Codes , WCDMA DL Channel Codes | WCDMA Connected DL Channel Levels
 | Connected | HSDPA | Shared DL Channel Codes , HSDPA/HSPA DL Channel Codes | HSDPA Connected DL Channel Levels
 | Connected | HSPA | Shared DL Channel Codes , HSDPA/HSPA DL Channel Codes | HSPA Connected DL Channel Levels

Use the Downlink Channel Code Preset to easily configure the 3GPP TS 34.121-1 channel codes from the front panel.

If the sum of the downlink channel levels is less than the cell power setting, Orthogonal Channel Noise Simulator (OCNS) power is automatically added.

Downlink Channel Codes

Downlink Channel Codes can not be changed in Active Cell operating mode (use Cell Off operating mode to change the active cell downlink channel codes). The downlink channel codes currently in use are displayed in the Downlink Code Channel Information window.

Shared DL Channel Codes

  • Primary Scrambling Code

    GPIB command: CALL:SCODe

  • S-CCPCH Channelization Code

    The S-CCPCH OVSF (Orthogonal Variable Spreading Factor) is fixed at 64. This parameter cannot be set to 26 when RB Test Mode First HS-PDSCH Channel Code or PS Data First HS-PDSCH Channel Code is set to 5 or 6.

    GPIB command: CALL:CCPChannel:SECondary:CCODe:CODE

  • PICH Channelization Code

    The PICH OVSF is fixed at 256.

    GPIB command: CALL[:CELL]:PICHannel:CCODe:CODE

  • AICH Channelization Code

    The AICH OVSF is fixed at 256.

    GPIB command: CALL:AICHannel:CCODe:CODE

The CPICH OVSF/channelization code is fixed at 256,0.

The P-CCPCH/SCH OVSF/channelization code is fixed at 256,1.

WCDMA DL Channel Codes

The method for setting downlink DPCH channel codes differs between the test application and lab application. The following table illustrates the valid channelization codes for each type of DPCH channel, and indicates the GPIB commands and front panel fields used to set the channelization codes, for both the test application and lab application (see How Do I Change Generator Information? to help you find these fields from the front panel).

Downlink DPCH Channel Types vs. Channelization Code Selection
Downlink Channel Type | Valid Channelization Code | Test Application Front Panel Setting and GPIB Command | Lab Application Front Panel Setting and GPIB Command
Signalling Radio Bearers: (see Signalling Radio Bearer (SRB) Parameters )
2.2k DCCH | 12/13/20/21/40/43/ 58/126/127/142/ 153/174/235/255 | 3.4k SRB Channelization Code, CALL:SRBearer | DPCH 15 ksps (OVSF 256) Channelization Code, CALL:DPCHannel:KSPS15[:CCODe]:CODE
3.4k DCCH | 12/13/20/21/40/43/ 58/126/127/142/ 153/174/235/255 | 3.4k SRB Channelization Code, CALL:SRBearer | DPCH 15 ksps (OVSF 256) Channelization Code, CALL:DPCHannel:KSPS15[:CCODe]:CODE
13.6k DCCH | 6/9/10/20/29/37/ 45/54/60/63/70/76/ 87/93/112/118 | DPCH 12.2k RMC & 33k NC RMC Channelization Code, CALL:DPCHannel:RMC12:CCODe | DPCH 30 ksps (OVSF 128) Channelization Code, CALL:DPCHannel:KSPS30[:CCODe]:CODE
Radio Bearer Test Mode Reference Measurement Channels: (see Radio Bearer Test Mode )
12.2k RMC | 6/9/10/20/29/37/ 45/54/60/63/70/76/ 87/93/112/118 | DPCH 12.2k RMC & 33k NC RMC Channelization Code, CALL:DPCHannel:RMC12:CCODe | DPCH 30 ksps (OVSF 128) Channelization Code, CALL:DPCHannel:KSPS30[:CCODe]:CODE
64k RMC | 6/10/12/14/16/18/ 20/22/24/25/26/27 | DPCH 64k RMC Channelization Code, CALL:DPCHannel:RMC64:CCODe | DPCH 120 ksps (OVSF 32) Channelization Code, CALL:DPCHannel:KSPS120[:CCODe]:CODE
144k RMC | 12/13 | DPCH 144k RMC Channelization Code, CALL:DPCHannel:RMC144:CCODe | DPCH 240 ksps (OVSF 16) Channelization Code, CALL:DPCHannel:KSPS240[:CCODe]:CODE
384k RMC | 6 | DPCH 384k RMC Channelization Code, CALL:DPCHannel:RMC384:CCODe | DPCH 480 ksps (OVSF 8) Channelization Code, CALL:DPCHannel:KSPS480[:CCODe]:CODE
33k No Coding RMC | 6/9/10/20/29/37/ 45/54/60/63/70/76/ 87/93/112/118 | DPCH 12.2k RMC & 33k NC RMC Channelization Code, CALL:DPCHannel:RMC12:CCODe | DPCH 30 ksps (OVSF 128) Channelization Code, CALL:DPCHannel:KSPS30[:CCODe]:CODE
12.2k UL/64k DL AM RMC | 6/10/12/14/16/18/ 20/22/24/25/26/27 | DPCH 64k RMC Channelization Code, CALL:DPCHannel:RMC64:CCODe | DPCH 120 ksps (OVSF 32) Channelization Code, CALL:DPCHannel:KSPS120[:CCODe]:CODE
12.2k UL/144k DL AM RMC | 12/13 | DPCH 144k RMC Channelization Code, CALL:DPCHannel:RMC144:CCODe | DPCH 240 ksps (OVSF 16) Channelization Code, CALL:DPCHannel:KSPS240[:CCODe]:CODE
12.2k UL/384k DL AM RMC | 6 | DPCH 384k RMC Channelization Code, CALL:DPCHannel:RMC384:CCODe | DPCH 480 ksps (OVSF 8) Channelization Code, CALL:DPCHannel:KSPS480[:CCODe]:CODE
64k UL/384k DL AM RMC | 6 | DPCH 384k RMC Channelization Code, CALL:DPCHannel:RMC384:CCODe | DPCH 480 ksps (OVSF 8) Channelization Code, CALL:DPCHannel:KSPS480[:CCODe]:CODE
AMR Radio Access Bearer: (see AMR Setup )
12.2k Voice | 6/9/10/20/29/37/ 45/54/60/63/70/76/ 87/93/112/118 | DPCH 12.2k RMC & 33k NC RMC Channelization Code, CALL:DPCHannel:RMC12:CCODe | DPCH 30 ksps (OVSF 128) Channelization Code, CALL:DPCHannel:KSPS30[:CCODe]:CODE
10.2k Voice | 6/9/10/20/29/37/ 45/54/60/63/70/76/ 87/93/112/118 | DPCH 12.2k RMC & 33k NC RMC Channelization Code, CALL:DPCHannel:RMC12:CCODe | DPCH 30 ksps (OVSF 128) Channelization Code, CALL:DPCHannel:KSPS30[:CCODe]:CODE
7.95k Voice | 6/9/10/20/29/37/ 45/54/60/63/70/76/ 87/93/112/118 | DPCH 12.2k RMC & 33k NC RMC Channelization Code, CALL:DPCHannel:RMC12:CCODe | DPCH 30 ksps (OVSF 128) Channelization Code, CALL:DPCHannel:KSPS30[:CCODe]:CODE
7.4k Voice | 6/9/10/20/29/37/ 45/54/60/63/70/76/ 87/93/112/118 | DPCH 12.2k RMC & 33k NC RMC Channelization Code, CALL:DPCHannel:RMC12:CCODe | DPCH 30 ksps (OVSF 128) Channelization Code, CALL:DPCHannel:KSPS30[:CCODe]:CODE
6.7k Voice | 6/9/10/20/29/37/ 45/54/60/63/70/76/ 87/93/112/118 | DPCH 12.2k RMC & 33k NC RMC Channelization Code, CALL:DPCHannel:RMC12:CCODe | DPCH 30 ksps (OVSF 128) Channelization Code, CALL:DPCHannel:KSPS30[:CCODe]:CODE
5.9k Voice | 12/13/20/21/40/43/ 58/126/127/142/ 153/174/235/255 | 3.4k SRB Channelization Code, CALL:SRBearer | DPCH 15 ksps (OVSF 256) Channelization Code, CALL:DPCHannel:KSPS15[:CCODe]:CODE
5.15k Voice | 12/13/20/21/40/43/ 58/126/127/142/ 153/174/235/255 | 3.4k SRB Channelization Code, CALL:SRBearer | DPCH 15 ksps (OVSF 256) Channelization Code, CALL:DPCHannel:KSPS15[:CCODe]:CODE
4.75k Voice | 12/13/20/21/40/43/ 58/126/127/142/ 153/174/235/255 | 3.4k SRB Channelization Code, CALL:SRBearer | DPCH 15 ksps (OVSF 256) Channelization Code, CALL:DPCHannel:KSPS15[:CCODe]:CODE
Circuit Switched Data Radio Access Bearers: (see Circuit Switched Data Service )
14.4k UL/14.4k DL CS Data RAB | 6/9/10/20/29/37/ 45/54/60/63/70/76/ 87/93/112/118 | Not applicable to the test application. | DPCH 30 ksps (OVSF 128) Channelization Code, CALL:DPCHannel:KSPS30[:CCODe]:CODE
57.6k UL/57.6k DL CS Data RAB | 6/10/12/14/16/18/ 20/22/24/25/26/27 | Not applicable to the test application. | DPCH 120 ksps (OVSF 32) Channelization Code, CALL:DPCHannel:KSPS120[:CCODe]:CODE
64k UL/64k DL CS Data RAB | 6/10/12/14/16/18/ 20/22/24/25/26/27 | DPCH 64k RMC Channelization Code, CALL:DPCHannel:RMC64:CCODe (feature license required) | DPCH 120 ksps (OVSF 32) Channelization Code, CALL:DPCHannel:KSPS120[:CCODe]:CODE
GPRS Radio Access Bearers: (see Packet Switched Data )
64k UL/64k DL PS Data RAB | 6/10/12/14/16/18/ 20/22/24/25/26/27 | Not applicable to the test application. | DPCH 120 ksps (OVSF 32) Channelization Code, CALL:DPCHannel:KSPS120[:CCODe]:CODE
64k UL/384k DL RMC | 6 | Not applicable to the test application. | DPCH 480 ksps (OVSF 8) Channelization Code, CALL:DPCHannel:KSPS480[:CCODe]:CODE
64k UL/384k DL PS Data RAB | 6 | Not applicable to the test application. | DPCH 480 ksps (OVSF 8) Channelization Code, CALL:DPCHannel:KSPS480[:CCODe]:CODE
128k UL/384k DL PS Data RAB * | 6 | Not applicable to the test application. | DPCH 480 ksps (OVSF 8) Channelization Code, CALL:DPCHannel:KSPS480[:CCODe]:CODE
384k UL/384k DL PS Data RAB | 6 | Not applicable to the test application. | DPCH 480 ksps (OVSF 8) Channelization Code, CALL:DPCHannel:KSPS480[:CCODe]:CODE

HSDPA/HSPA DL Channel Codes

This section is only applicable to the lab application or feature-licensed test application.

The method for setting downlink DPCH channel codes used during HSDPA and HSPA connections differs between the test application and lab application. The following table illustrates the valid channelization codes for each type of DPCH channel used during HSDPA and HSPA connections, and indicates the GPIB commands and front panel fields used to set the channelization codes, for both the test application and lab application (see How Do I Change Generator Information? to help you find these fields from the front panel).

HSDPA/HSPA Downlink DPCH Channel Types vs. Channelization Code Selection
Downlink Channel Type | Valid Channelization Codes | Test Application Front Panel Setting and GPIB Command | Lab Application Front Panel Setting and GPIB Command
Radio Bearer Test Mode Reference Measurement Channels: (see Radio Bearer Test Mode )
12.2k RMC + HSDPA | 20/29/37/45/54 | HSDPA/HSPA DPCH 12.2k RMC Channelization Code, CALL:DPCHannel:RMC12:CCODe:HSDPa | HSDPA/HSPA DPCH 30 ksps (OVSF 128) Channelization Code, CALL:DPCHannel:KSPS30[:CCODe]:CODE:HSDPa
12.2k RMC + HSPA | 20/29/37/45/54 | HSDPA/HSPA DPCH 12.2k RMC Channelization Code, CALL:DPCHannel:RMC12:CCODe:HSDPa | HSDPA/HSPA DPCH 30 ksps (OVSF 128) Channelization Code, CALL:DPCHannel:KSPS30[:CCODe]:CODE:HSDPa
GPRS Radio Access Bearers: (see Packet Switched Data )
3.4k SRB used while on an HSDPA or HSPA packet data connection | 40/43/58 | Not applicable to the test application. | HSDPA/HSPA DPCH 15 ksps (OVSF 256) Channelization Code, CALL:DPCHannel:KSPS15[:CCODe]:CODE:HSDPa

You can also set the channel code for the following downlink HSDPA and HSPA channels:

  • E-AGCH Channelization Code

    This setting controls the channelization code of the E-AGCH. The E-AGCH has a spreading factor of 256.

    GPIB command: CALL[:CELL]:EAGChannel:CCODe:CODE

  • E-HICH/E-RGCH Channelization Code

    This setting controls the channelization code of the E-HICH and E-RGCH. These channels have a spreading factor of 128 and by definition use the same channelization code (see 3GPP TS 25.213 s5.2.1). 40 bit signatures are used to provide orthogonality between the two channels (see HSPA Downlink Channel Details ).

    GPIB command: CALL[:CELL]:EHIChannel:CCODe:CODE

  • PS Data First HS-PDSCH Channel Code

    This parameter sets the channelization code of the first HS-PDSCH when on an HSDPA packet data connection. If more than one HS-PDSCH is being generated, the other HS-PDSCHs are assigned to the subsequent channelization codes.

    This parameter cannot be set to 5 or 6 when S-CCPCH Channelization Code is set to 26. Also, the number of HS-PDSCHs specified by the PS Data Configuration Type , when added to the PS Data First HS-PDSCH Channel Code cannot exceed 15 (otherwise the HS-PDSCHs would collide with the downlink OCNS channels).

    GPIB command: CALL:HSDPa:SERVice:PSData:HSPDschannel:CCODe:CODE

  • RB Test Mode First HS-PDSCH Channel Code

    This parameter sets the channelization code of the first HS-PDSCH when on an HSDPA RB Test Mode connection. If more than one HS-PDSCH is being generated, the other HS-PDSCHs are assigned to the subsequent channelization codes.

    This parameter cannot be set to 5 or 6 when S-CCPCH Channelization Code is set to 26. This parameter cannot be set to 5 when HSDPA DPCH 12.2k RMC Channelization Code is set to 45 or 54, and cannot be set to 6 when HSDPA DPCH 12.2k RMC Channelization Code is set to 54. Also, the number of HS-PDSCHs specified by the FRC Type or User Defined Number of Active HS-PDSCHs settings, when added to the RB Test Mode First HS-PDSCH Channel Code cannot exceed 16 (otherwise the HS-PDSCHs would collide with the downlink OCNS channels).

    GPIB command: CALL:HSDPa:SERVice:RBTest:HSPDschannel:CCODe:CODE

  • HS-SCCH 1 Channelization Code

    GPIB command: CALL:HSSCchannel[1]:CCODe:CODE

  • HS-SCCH 2 Channelization Code

    GPIB command: CALL:HSSCchannel2:CCODe:CODE

  • HS-SCCH 3 Channelization Code

    GPIB command: CALL:HSSCchannel3:CCODe:CODE

  • HS-SCCH 4 Channelization Code

    GPIB command: CALL:HSSCchannel4:CCODe:CODE

  • Secondary Serving Cell PICH Chan Code

    GPIB command: CALL:SSCell:PICHannel:CCODe:CODE

  • PSD Secondary Cell First HS-PDSCH Chan Code

    GPIB command: CALL:HSDPa:SSCell:PSData:HSPDschannel:CCODe:CODE

  • RBTM Secondary Cell First HSPDSCH Chan Code

    GPIB command: CALL:HSDPa:SSCell:RBTest:HSPDschannel:CCODe:CODE

  • Secondary Serving Cell HS-SCCH 1 Chan Code

    GPIB command: CALL:SSCell:HSSCchannel1:CCODe:CODE

  • Secondary Serving Cell HS-SCCH 2 Chan Code

    GPIB command: CALL:SSCell:HSSCchannel2:CCODe:CODE

  • Secondary Serving Cell HS-SCCH 3 Chan Code

    GPIB command: CALL:SSCell:HSSCchannel3:CCODe:CODE

  • Secondary Serving Cell HS-SCCH 4 Chan Code

    GPIB command: CALL:SSCell:HSSCchannel4:CCODe:CODE

Downlink Channel Code Preset

The downlink channel code preset (front panel: DL Chan Code Preset Configs ) allows you to configure the test set for 3GPP TS 34.121-1 channel code much easier (the DL Channel Code Preset Configurations are only available from the front panel; there are no GPIB commands to configure these presets).

The Operating Mode must be set to Cell Off before selecting one of the DL channel code preset configurations.

  • DL Channel Code Preset Configurations from 3GPP TS 34.121-1 (These presets configure the test set as defined in 3GPP TS 34.121-1 for non-HSDPA, HSDPA with 10 HS-PDSCHs, HSDPA with 15 HS-PDSCHs, and E-DCH with 5 HS-PDSCHs.)
  • DL Channel Code Preset Configuration for Compressed Mode (This preset configures the test set for use with compressed mode on a DL 384 kbps channel. See Channel Type for supported DL 384 kbps channels.)

DL Channel Code Preset Configurations from 3GPP TS 34.121-1
 | 34.121 Table E.6.1.1(Non-HSDPA) | 34.121 Tables E.6.2.1,2(HSDPA 10 HS-PDSCHs) | 34.121 Tables E.6.2.3,4(HSDPA 15 HS-PDSCHs) | 34.121 Tables E.6.3.1,2(E-DCH 5 HS-PDSCHs)
Shared DL Channel Codes
S-CCPCH Channelization Code | 2 | 2 | 2 | 2
PICH Channelization Code | 2 | 2 | 2 | 2
AICH Channelization Code | 3 | 3 | 3 | 3
WCDMA DL Channel Codes
DPCH 15 ksps (OVSF 256) Channelization Code | 192 | 192 | 14 | 192
DPCH 30 ksps (OVSF 128) Channelization Code | 96 | 96 | 7 | 96
DPCH 120 ksps (OVSF 32) Channelization Code | 24 |  |  |
DPCH 240 ksps (OVSF 16) Channelization Code | 12 |  |  |
DPCH 480 ksps (OVSF 8) Channelization Code | 6 |  |  |
HSDPA/HSPA DL Channel Codes
HSDPA/HSPA (F-)DPCH 15 ksps (OVSF 256) Code |  | 192 | 14 | 192
HSDPA/HSPA DPCH 30 ksps (OVSF 128) Code |  | 96 | 7 | 96
E-AGCH Channelization Code |  |  |  | 14
E-HICH/E-RGCH Channelization Code |  |  |  | 6
RB Test Mode First HS-PDSCH Channel Code |  | 1 | 1 | 1
HS-SCCH 1 to 4 Channelization Codes |  | 2,3,6,7 | 2,3 | 2,3
OCNS Codes
Cell 1 WCDMA OCNS 1 to 16 Channelization Codes | 2, 11, 17, 23, 31, 38, 47, 55, 62, 69, 78, 85, 94, 125, 113, 119 |  |  |
Cell 1 HSDPA/HSPA OCNS 1 to 6 Channelization Codes |  | 122 to 127 | 6 | 122 to 127
DL Channel Configuration
Conn S-CCPCH Config | On | On | On | On
HS-SCCH 1 to 4 Channel Config States |  | On, On, On, On | On, On, Off, Off | On, On, Off, Off
HSDPA/HSPA OCNS 1 to 6 Channel Config States |  | On, On, On, On, On, On | On, Off, Off, Off, Off, Off | On, On, On, On, On, On
HSDPA Connected DL Channel Levels
HSDPA Cell 1 Connected HS-SCCH 3 Level |  |  | Off | Off
HSDPA Cell 1 Connected HS-SCCH 4 Level |  |  | Off | Off
HSPA Connected DL Channel Levels
HSPA Cell 1 Connected HS-SCCH 3 Level |  |  | Off | Off
HSPA Cell 1 Connected HS-SCCH 4 Level |  |  | Off | Off
HSDPA RB Test Settings
RB Test HS-DSCH Configuration Type |  | User Defined | User Defined | User Defined
RB Test User Defined Number of Active HS-PDSCHs |  | 10 | 15 | 5
DL Channel Code Preset Configuration for Compressed Mode
 | Compressed Mode with 384k DL DPCH(Non-HSDPA)
Shared DL Channel Codes
S-CCPCH Channelization Code | 7
PICH Channelization Code | 16
AICH Channelization Code | 10
WCDMA DL Channel Codes
DPCH 15 ksps (OVSF 256) Channelization Code | 12
DPCH 30 ksps (OVSF 128) Channelization Code | 9
DPCH 480 ksps (OVSF 8) Channelization Code | 6
OCNS Codes
Cell 1 WCDMA OCNS 1 to 16 Channelization Codes | 2, 11, 17, 23, 31, 38, 47, 55, 62, 69, 78, 85, 94, 92, 88, 90
DL Channel Configuration
Conn S-CCPCH Config | On

Downlink Channel Levels

The relative level of all downlink channels can be individually set or turned off (except that the P-CCPCH and the SCH are time multiplexed, and use the same level for both channels). The level of each active channel is a fraction of the Cell Power (Îor) setting, expressed in dB. If the summed level of all channels is less than one, the orthogonal coded noise source (OCNS) is turned on to account for the difference (see Orthogonal Channel Noise Simulator (OCNS) ).

The downlink code channel levels currently in use (as well as the "desired" levels) are displayed in the Downlink Code Channel Information screen.

The downlink channel levels for idle mode (no DPCH is present) may be different than the levels used during a call (DPCH is present). Thus, there are two different level settings for the downlink channels in active cell operating mode: Downlink Channel Levels and Connected DL Channel Levels .

Considerations When Setting Code Channel States and Levels

  • All code channels can be set between 0 and -20 dB, except the relative power level of the DPCH channel which can be set from 0 to -30 dB.
  • Any code channel powers that are On must not be greater than 30 dB below the Total RF Power .
  • The sum of the relative levels of the code channels cannot be greater than 100% of the cell power.
  • If you set a code channel state to Off , the test set will not automatically turn it back on if it is needed to perform a call processing operation you've requested (for example, if you turn PICH Level to Off , the Originate Call procedure will fail).

Downlink Channel Levels

The Downlink Channel Levels set of power levels is used when RRC State is Idle or CELL_FACH .

These levels cannot be changed in the Active Cell operating mode. You can query these settings via GPIB and view them on the front panel during Active Cell mode operation, but attempting to change the levels during Active Cell mode operation results in an error message (use the Cell Off operating mode to change the active cell downlink channel levels).

  • CPICH Level

    GPIB command: CALL:CPIChannel

  • P-CCPCH/SCH Level

    GPIB command: CALL:CCPChannel:PRIMary[:SLEVel]

  • S-CCPCH Level

    GPIB command: CALL:CCPChannel:SECondary[:SLEVel]

  • PICH Level

    GPIB command: CALL[:CELL]:PICHannel[:SLEVel]

  • AICH Level

    GPIB command: CALL:AICHannel

  • DPCH Level

    Note: no DPCH is generated before the call is established. Setting DPCH Level to a non-zero value simply adds that power to the OCNS.

    GPIB command: CALL:DPCHannel[:SLEVel]

Connected DL Channel Levels

The Connected DL Channel Levels are used when RRC State is CELL_DCH . These levels are applied after the RRC Connection Setup message is sent by the test set during the RRC Connection Setup Procedure , directing the UE to go into CELL_DCH (i.e. once a DPCH has been established). When the DPCH channel is released, the test set transitions back to the Downlink Channel Levels set.

These levels can be changed in any operating mode, including Active Cell . This allows you to vary the relative channel levels while a call is connected in order to test the UE's response.

These settings specify the connected downlink channel levels relative to Cell Power (Îor).

WCDMA Connected DL Channel Levels

  • Cell 1 Connected CPICH Level

    GPIB command: CALL:CONNected:CPIChannel[:SLEVel]

  • Cell 1 Connected P-CCPCH/SCH Level

    GPIB command: CALL:CONNected:CCPChannel:PRIMary[:SLEVel]

  • Cell 1 Connected S-CCPCH Level

    GPIB command: CALL:CONNected:CCPChannel:SECondary[:SLEVel]

  • Cell 1 Connected PICH Level

    GPIB command: CALL:CONNected:PICHannel[:SLEVel]

  • Cell 1 Connected DPCH Level

    Note: PO1, PO2 and PO3, which define the offset of the TFCI, TPC and pilot fields of the DPCCH relative to the DPDCH's power (see 3GPP TS 25.214 5.2.1.1) are always set to 0 in the test set (as specified by 3GPP TS 25.101 A.3 and 34.121 C.3).

    GPIB command: CALL:CONNected:DPCHannel[:SLEVel]

  • Cell 2 CPICH Level ( lab application only , see Cell 2 Overview )
  • Cell 2 P-CCPCH/SCH Level ( lab application only , see Cell 2 Overview )
  • Cell 2 DPCH Level ( lab application only , see Cell 2 Overview )

HSDPA Connected DL Channel Levels

These settings are only applicable to the lab application or feature-licensed test application.

  • HSDPA Cell 1 Connected CPICH Level

    GPIB command: CALL:CONNected:CPIChannel[:SLEVel]:HSDPa

  • HSDPA Cell 1 Connected P-CCPCH/SCH Level

    GPIB command: CALL:CONNected:CCPChannel:PRIMary[:SLEVel]:HSDPa

  • HSDPA Cell 1 Connected S-CCPCH Level

    GPIB command: CALL:CONNected:CCPChannel:SECondary[:SLEVel]:HSDPa

  • HSDPA Cell 1 Connected PICH Level

    GPIB command: CALL:CONNected:PICHannel[:SLEVel]:HSDPa

  • HSDPA Cell 1 Connected DPCH Level

    Note: PO1, PO2 and PO3, which define the offset of the TFCI, TPC and pilot fields of the DPCCH relative to the DPDCH's power (see 3GPP TS 25.214 5.2.1.1) are always set to 0 in the test set (as specified by 3GPP TS 25.101 A.3 and 34.121 C.3).

    GPIB command: CALL:CONNected:DPCHannel[:SLEVel]:HSDPa

  • HSDPA Cell 1 Connected HS-PDSCHs Level (Sum)

    This parameter sets the total amount of power in all HS-PDSCHs. The power is equally split between all HS-PDSCHs active during each subframe.

    Note, if you set this level to Off , but do not turn HSDPA Cell 1 Connected HS-SCCH 1 Level Off , the UE will NACK the packets assigned to it by HS-SCCH 1 (because the packets are not being sent to it on the HS-PDSCHs, as their power level is off).

    GPIB command: CALL:CONNected:HSPDschannel[:SLEVel]

  • HSDPA Cell 1 Connected HS-SCCH 1 Level

    Note, if you set this level to Off , the UE will not read the HS-PDSCHs for any packets assigned to it. Depending upon the CQI Feedback Cycle (k) setting, the UE may still transmit CQI data.

    GPIB command: CALL:CONNected:HSSCchannel[1][:SLEVel]

  • HSDPA Cell 1 Connected HS-SCCH 2 Level

    GPIB command: CALL:CONNected:HSSCchannel2[:SLEVel]

  • HSDPA Cell 1 Connected HS-SCCH 3 Level

    GPIB command: CALL:CONNected:HSSCchannel3[:SLEVel]

  • HSDPA Cell 1 Connected HS-SCCH 4 Level

    GPIB command: CALL:CONNected:HSSCchannel4[:SLEVel]

  • Secondary Cell HSDPA Conn CPICH Level

    GPIB command: CALL:SSCell:CONNected:CPIChannel:LEVel:HSDPa

  • Secondary Cell HSDPA Conn PCCPCH/SCH Level

    GPIB command: CALL:SSCell:CONNected:CCPChannel:PRIMary:LEVel:HSDPa

  • Secondary Cell HSDPA Conn PICH Level

    GPIB command: CALL:SSCell:CONNected:PICHannel:LEVel:HSDPa

  • Secondary Cell HSDPA Conn HSPDSCHs Lvl (Sum)

    GPIB command: CALL:SSCell:CONNected:HSPDschannel:LEVel:HSDPa

  • Secondary Cell HSDPA Conn HSSCCH 1 Level

    GPIB command: CALL:SSCell:CONNected:HSSCchannel[1]:LEVel:HSDPa

  • Secondary Cell HSDPA Conn HSSCCH 2 Level

    GPIB command: CALL:SSCell:CONNected:HSSCchannel2:LEVel:HSDPa

  • Secondary Cell HSDPA Conn HSSCCH 3 Level

    GPIB command: CALL:SSCell:CONNected:HSSCchannel3:LEVel:HSDPa

  • Secondary Cell HSDPA Conn HSSCCH 4 Level

    GPIB command: CALL:SSCell:CONNected:HSSCchannel4:LEVel:HSDPa

HSPA Connected DL Channel Levels

These settings are only applicable to the lab application or feature-licensed test application.

  • HSPA Cell 1 Connected CPICH Level

    GPIB command: CALL:CONNected:CPIChannel[:SLEVel]:HSPA

  • HSPA Cell 1 Connected P-CCPCH/SCH Level

    GPIB command: CALL:CONNected:CCPChannel:PRIMary[:SLEVel]:HSPA

  • HSPA Cell 1 Connected S-CCPCH Level

    GPIB command: CALL:CONNected:CCPChannel:SECondary[:SLEVel]:HSPA

  • HSPA Cell 1 Connected PICH Level

    GPIB command: CALL:CONNected:PICHannel[:SLEVel]:HSPA

  • HSPA Cell 1 Connected DPCH Level

    Note: PO1, PO2 and PO3, which define the offset of the TFCI, TPC and pilot fields of the DPCCH relative to the DPDCH's power (see 3GPP TS 25.214 5.2.1.1) are always set to 0 in the test set (as specified by 3GPP TS 25.101 A.3 and 34.121 C.3).

    GPIB command: CALL:CONNected:DPCHannel[:SLEVel]:HSPA

  • HSPA Cell 1 Connected E-AGCH Level

    GPIB command: CALL:CONNected:EAGChannel[:SLEVel]

  • HSPA Cell 1 Connected E-HICH Level

    The E-HICH and E-RGCH share the same channelization code (see E-HICH/E-RGCH Channelization Code ). The power in that channelization code is the sum of the HSPA Cell 1 Connected E-HICH Level and HSPA Cell 1 Connected E-RGCH Level.

    GPIB command: CALL:CONNected:EHIChannel[:SLEVel]

  • HSPA Cell 1 Connected E-RGCH Level

    The E-HICH and E-RGCH share the same channelization code (see E-HICH/E-RGCH Channelization Code ). The power in that channelization code is the sum of the HSPA Cell 1 Connected E-HICH Level and HSPA Cell 1 Connected E-RGCH Level.

    You must set RB Test Mode E-RGCH Information State to on in order for the UE to listen to the E-RGCH while on an HSPA RB Test Mode connection.

    You must set PS Data E-RGCH Information State to on in order for the UE to listen to the E-RGCH while on an HSPA PS Data connection.

    GPIB command: CALL:CONNected:ERGChannel[:SLEVel]

  • HSPA Cell 1 Connected HS-PDSCHs Level (Sum)

    This parameter sets the total amount of power in all HS-PDSCHs. The power is equally split between all HS-PDSCHs active during each subframe.

    Note, if you set this level to Off , but do not turn HSPA Cell 1 Connected HS-SCCH 1 Level Off , the UE will NACK the packets assigned to it by HS-SCCH 1 (because the packets are not being sent to it on the HS-PDSCHs, as their power level is off).

    GPIB command: CALL:CONNected:HSPDschannel[:SLEVel]:HSPA

  • HSPA Cell 1 Connected HS-SCCH 1 Level

    Note, if you set this level to Off , the UE will not read the HS-PDSCHs for any packets assigned to it. Depending upon the CQI Feedback Cycle (k) setting, the UE may still transmit CQI data.

    GPIB command: CALL:CONNected:HSSCchannel[1][:SLEVel]:HSPA

  • HSPA Cell 1 Connected HS-SCCH 2 Level

    GPIB command: CALL:CONNected:HSSCchannel2[:SLEVel]:HSPA

  • HSPA Cell 1 Connected HS-SCCH 3 Level

    GPIB command: CALL:CONNected:HSSCchannel3[:SLEVel]:HSPA

  • HSPA Cell 1 Connected HS-SCCH 4 Level

    GPIB command: CALL:CONNected:HSSCchannel4[:SLEVel]:HSPA

  • Secondary Cell HSPA Conn CPICH Level

    GPIB command: CALL:SSCell:CONNected:CPIChannel:LEVel:HSPA

  • Secondary Cell HSPA Cell 1 Connected P-CCPCH/SCH Level

    GPIB command: CALL:SSCell:CONNected:CCPChannel:PRIMary:LEVel:HSPA

  • Secondary Cell HSPA Conn PICH Level

    GPIB command: CALL:SSCell:CONNected:PICHannel:LEVel:HSPA

  • Secondary Cell HSPA Conn HSPDSCHs Levels (Sum)

    GPIB command: CALL:SSCell:CONNected:HSPDschannel:LEVel:HSPA

  • Secondary Cell HSPA Conn HSSCCH 1 Level

    GPIB command: CALL:SSCell:CONNected:HSSCchannel[1]:LEVel:HSPA

  • Secondary Cell HSPA Conn HSSCCH 2 Level

    GPIB command: CALL:SSCell:CONNected:HSSCchannel2:LEVel:HSPA

  • Secondary Cell HSPA Conn HSSCCH 3 Level

    GPIB command: CALL:SSCell:CONNected:HSSCchannel3:LEVel:HSPA

  • Secondary Cell HSPA Conn HSSCCH 4 Level

    GPIB command: CALL:SSCell:CONNected:HSSCchannel4:LEVel:HSPA

  • GPIB command:

  • GPIB command:

  • GPIB command:

Orthogonal Channel Noise Simulator (OCNS)

OCNS is used to simulate additional users on the downlink. OCNS is automatically enabled when the sum of the levels of all the enabled downlink physical channels is less than the cell power setting.

Cell 1 OCNS is made up of the following 16 separate code channels: 2, 11, 17, 23, 31, 38, 47, 55, 62, 69, 78, 85, 94, 113, 119, and 125, with an OVSF of 128. The fraction of the composite OCNS power that is allocated to each of the code channels making up the composite OCNS are as specified by 3GPP TS 34.121 sE.3.6.

Cell 2 OCNS ( lab application only ) consists of a single channel at OVSF 128,2.

As individual downlink channel levels are adjusted, the composite OCNS level is automatically set to a value equal to the difference between the summed downlink channel levels and the cell power setting (when the sum of the downlink code channel levels is such that the composite OCNS is less than -30 dB, it is set to Off ).

The OCNS currently in use (as well as the "desired" level) is displayed in the Downlink Code Channel Information window.

GPIB command: CALL:OCNSource (query only)

OCNS in HSDPA/HSPA

This section is only applicable to the lab application or feature-licensed test application.

When HSDPA or HSPA is active (see HSDPA Activation in FDD Test and HSDPA Activation in Active Cell ), the cell 1 OCNS is made up of the following 7 separate code channels: 122, 123, 124, 125, 126, and 127, with an OVSF of 128, rather than the code channels described in Orthogonal Channel Noise Simulator (OCNS) above. The fraction of the composite OCNS power that is allocated to each of the code channels making up the composite OCNS are as specified by 3GPP TS 34.121 sE.5.2.

Related Topics

Generator Information

How Do I Change Generator Information?

Cell Power and AWGN Power

Signalling Radio Bearer (SRB) Parameters

Active Cell Operating Mode

Cell Off Operating Mode


Other Downlink Parameters

Other Downlink Parameters

Last updated: January 15, 2009

The following parameters are provided to define the contents of the downlink signal to the UE (mobile station) while the call is connected, and to control the call connection behavior. To access these parameters from the front panel, see How Do I Change Call Parameters? .

DL DTCH Data

The data pattern of the DTCH data (user data) sent on the DPCH can be set to:

  • CCITT PRBS15 - a 15-bit pseudo-random bit sequence.
  • CCITT PRBS9 - a 9-bit pseudo-random bit sequence.
  • All Zeroes - a continuous series of 0's. This setting can be used to help quickly find CRC errors when viewing the UL DTCH data using the Protocol Logging functionality of the lab application.
  • All Ones - a continuous series of 1's.
  • Incrementing - a 16 bit data pattern that starts at 0000 0000 0000 0000 and increments by 1 each TTI (i.e. 0000 0000 0000 0001, 0000 0000 0000 0010 etc.). This setting can be used to identify a missing block or shifted bit pattern.
You can use the test set's loopback bit error ratio measurement (see Loopback Bit Error Ratio (BER) Measurement Description ) or use your UE's built-in bit error reporting (if available) to determine if the UE has correctly decoded the data stream.

When on an HSDPA or HSPA RB test mode connection (see HSDPA RMCs and HSPA RMCs ), the DL DTCH Data setting only configures the data on the RMC portion of the channel. To configure the data being sent on the FRC, use the HS-DSCH Data Pattern setting ( lab application or feature-licensed test application only ).

RLC Reestablish

The RB Setup message that establishes the Radio Access Bearers (RABs) may specify a DCCH RLC Block Size that differs from the DCCH RLC Block Size that was being used when only a Signalling Radio Bearer (SRB) was present. If the RB Setup message specifies a change in the DCCH RLC block size from the stand-alone SRB configuration, the UE and network must change the DCCH RLC block size and then perform an RLC Re-establishment procedure to reset the RLC buffers (see 3GPP TS 25.322 9.7.7).

If your UE does not support changing DCCH RLC block size during connection setup and the RB Setup specifies a change in the DCCH RLC block size, the connection attempt will fail (to avoid this, you must establish the call using an SRB with a DCCH RLC block size that is equal to the DCCH RLC block size defined for the service you wish to establish, see Signalling Radio Bearer (SRB) Parameters ).

If your UE supports changing DCCH RLC block size during connection setup, but does not support the RLC Re-establishment procedure, you must either use an SRB that matches your desired service as explained above, or set RLC Reestablish to Off .

  • If RLC Reestablish is set to Off , the test set does not perform the RLC Re-establishment procedure. If your UE supports changing DCCH RLC block size during connection setup, the DCCH RLC Block Size is changed even if the RLC Re-establishment is not performed. However, some signalling data may be lost if the block size is changed without an RLC Re-establishment procedure.
  • If RLC Reestablish is set to On , if the RB Setup specifies a change in the DCCH RLC block size, the test set performs the RLC Re-establishment procedure.

Call Limit State

When the call limit state is on, the test set does not respond to any PRACH preambles from the UE. Call Limit must be OFF for any random access procedure, such as Location Update or BS Origination to be successful (see Establishing a Connection with the UE ).

Once the random access procedure has been initiated with Call Limit set to "ON", the Test Set will appear to be "hung" indefinitely. You must end the call to terminate the procedure and return the Call Status to "IDLE". (See How Do I End a Connection? or CALL:END .)

Call Drop Timer

The call drop timer can be turned off or on. When turned on, anytime the uplink signal is not detected, the test set only waits the length of the timer before assuming the call has been dropped by the UE. This timer is optimized for the manufacturing test environment. The timers defined in the 3GPP standards for determining that a call has been dropped are much longer. Turning on the call drop timer allows you to quickly identify UEs that can not maintain a call and remove them from your test area.

GPIB Commands for Setting DTCH Parameters

  • Downlink DTCH Data - CALL:DTCHannel:DATA
  • Downlink Paging Indicator Channel Data - CALL:PICHannel
  • RLC Reestablish - CALL[:CELL[1]]:RLC:REEStablish
  • Call Limit State - CALL:CONNected:LIMit[:STATe][:SELected]
  • Call Drop Timer - CALL:CONNected:DROP:TIMer[:STATe][:SELected]

Related Topics

How Do I Change Call Parameters?


Cell Power and AWGN Power

Cell Power and AWGN Power

Last updated: January 15, 2009

The test set's base station emulator provides control over the following RF power levels:

  • Cell Power

    Î or is defined in 3GPP TS 25.101 as the received power spectral density of the downlink as measured at the UE (mobile station) antenna connector. The downlink contains one or more downlink physical channels. The Cell Power setting sets the absolute level (in dBm) of the physical channels. The individual physical channel levels account for fractions of this setting, and are set in dB relative to the cell power (see Downlink Channel Codes and Levels ). If you have accounted for path loss (see Amplitude Offset ) between the test set output port and the UE antenna connector, then cell power is equivalent to Î or .

    GPIB command: CALL:POWer

  • AWGN Power

    I oc is defined in 3GPP TS 25.101 as the power spectral density of a band-limited white noise source (simulating interference from other cells) as measured at the UE antenna connector. If you have accounted for path loss, then AWGN (Additive White Gaussian Noise) power is equivalent to I oc .

    GPIB command: CALL:AWGNoise

  • Total RF Power

    I o is defined in 3GPP TS 25.101 as the total received power spectral density, including signal and interference, as measured at the UE antenna connector. The total RF power is the sum of cell power and AWGN power. If you have accounted for path loss, then total RF power is equivalent to I o .

    GPIB command: CALL:TOTal:POWer[:AMPLitude]? (query only)

NOTE
No signal is generated by the test set during Cell Off operation, regardless of the Cell Power setting. All settings are deferred until the Active Cell operating mode or FDD Test operating mode is used.

To access the cell power parameter using the test set's front panel, see How Do I Change Call Parameters? .

To access the AWGN power parameter using the test set's the front panel, How Do I Change Generator Information?

The power levels currently in use by the test set (as well as the "desired" levels) are displayed in the Generated Power Level Information window.

For the lab application only, the test set has the ability to simulate two individual cells (see Soft Handover ). In the lab application, the total RF power consists of Cell 1 power, Cell 2 power and the AWGN power if their states are on.

For the lab application, an external AWGN value is displayed when the test set is configured to generate faded forward channel signals with AWGN enabled. This setup requires a rear panel digital bus connection to an external PC running Baseband Studio software. For details, see Digital Bus Information .

Cell Power, AWGN Power and Total RF Power Ranges

The range of values that you can set these power levels to differs from the actual hardware range of the source. This is due to compensation for path loss between the test set RF output port and the UE antenna connector (see Amplitude Offset ).

For example, if you enter a value of -30 dBm for desired CW cell power, this indicates that you want -30 dBm of power at the UE antenna connector. So, if you have indicated an amplitude offset of -3.5 dB exists between the test set's RF In/Out port and the UE antenna connector, the source will actually have to output -26.5 dB in order to deliver -30 dB to the UE's antenna connector. Thus, with an amplitude offset of -3.5 dB, the settable range of CW cell power is -130.5 dB to -13.5 dB. The actual power range at a given time is defined by adding the value of the associated amplitude offset to the actual hardware range. If you select an invalid combination of power levels and amplitude offsets, an error message will appear at the bottom of the screen to alert you to this condition.

Range of Power Levels
Parameter | Actual Hardware Range with Amplitude Offset = 0 (RF In/Out Port) | Setting (or Query) Range
Cell Power (CW) | -127 dBm to -10 dBm | -177 dBm to +40 dBm
Cell Power (W-CDMA) | -115 dBm/3.84 MHz to -13 dBm/3.84 MHz | -165 dBm/3.84 MHz to +37 dBm/3.84 MHz
AWGN Power | -115 dBm/3.84 MHz to -15 dBm/3.84 MHz | -165 dBm/3.84 MHz to +35 dBm/3.84 MHz
Total RF Power | -115 dBm/3.84 MHz to -10.88 dBm/3.84 MHz | -165 dBm/3.84 MHz to +42 dBm/3.84 MHz

Considerations When Setting Power Levels

  • AWGN power must not be more than 10 dB above or 20 dB below cell power when both power states are set to ON.
  • The total RF power and amplitude offset must not set the source outside its valid hardware range.

Related Topics

Generator Information

Manual Operation: How Do I Change Generator Information?

Manual Operation: How Do I Change Call Parameters?


Signalling Radio Bearer (SRB) Parameters

Signalling Radio Bearer (SRB) Parameters

Last updated: January 15, 2009

A Signalling Radio Bearer (SRB) is a radio bearer that carries DCCH signalling data. An SRB is used during connection establishment to establish the Radio Access Bearers (RABs) and then also to deliver signalling while on the connection (for example, to perform a handover, reconfiguration or release).

The test set supports three SRBs:

  • 3.4k DCCH - see 3GPP TS 34.108 6.10.2.4.1.2
  • 13.6k DCCH - see 3GPP TS 34.108 6.10.2.4.1.3
  • 2.2k DCCH - this signalling radio bearer has the following properties:
2.2k DCCH SRB Properties
Transport Channel Parameters:
TrCH Type | DCH (DCCH)
TB size | 100
TF 0 | 0 x 100
TF 1 | 1 x 100
TTI (ms) | 40
Coding Type | Conv, 1/3
CRC | 12 bit
Downlink Physical Channel:
DTX Position | n/a
TFCI | used
Slot Structure | 5
SF | 256
Uplink Physical Channel:
Min Spreading Factor | 256
DPCCH slot format | 0
TFCI | used

During connection establishment, an RRC Connection Setup procedure establishes the SRB. The SRB is then used to send all subsequent signalling to start the desired service and establish the radio bearers for the service (see Call Processing Ladder Diagrams ). Establishment of the radio bearers is achieved using an RB Setup procedure. The RB Setup procedure configures how both the DCCH and DTCH will be carried on the radio bearers.

The RB Setup may specify a different DCCH RLC block size from the DCCH RLC block size that was being used when only an SRB was present. For example, the DCCH RLC block size for the default 3.4k DCCH SRB is 144 bits, but all RMCs (Reference Measurement Channels) call for a DCCH RLC block size of 96 bits. If the RB Setup specifies a change in the DCCH RLC block size from the stand-alone SRB configuration, the UE and network must change the DCCH RLC block size and then perform an RLC Re-establishment procedure to reset the RLC buffers. If your UE does not support changing the DCCH RLC block size during connection setup, you must establish the call using an SRB with a DCCH RLC block size that is equal to the DCCH RLC block size defined for the service you wish to establish.

SRB DCCH RLC Block Size
SRB | DCCH RLC Block Size
2.2k DCCH | 96 bits
3.4k DCCH | 144 bits
13.6k DCCH | 144 bits
RAB DCCH RLC Block Size
RAB | DCCH RLC Block Size
All RMCs (Reference Measurement Channels) See Radio Bearer Test Mode and Packet Switched Data | 96 bits
All PS Data RABs (Radio Access Bearers) See Packet Switched Data | 144 bits
All CS RABs See Circuit Switched Data Service | 144 bits
All AMR Radio Access Bearers See AMR Setup | 144 bits

If your UE supports changing RLC block size during connection setup, but does not support the RLC Re-establishment procedure, you must either use an SRB that matches your desired service as explained above, or set RLC Reestablish to Off .

To set the channelization code for the signalling radio bearers, see Downlink Channel Codes .

Manual operation: Select SRB Parameters ( F12 on Call Parms 2 of 3 ).

SRB Configuration Control

Some UEs can only move to an RMC at the RB Setup phase of the connection if they were assigned to a 2.2k DCCH SRB (i.e. some UEs do not support changing the DCCH RLC block size during connection setup). These same UEs would require a 3.4k DCCH SRB be assigned before establishing any other service type, such as AMR Radio Access Bearer, CS data or PS data. The SRB Configuration Control = Auto setting can be used to automatically change which SRB the UE is assigned based on the anticipated service.

If SRB Configuration Control is set to Auto , the test set assigns the UE to a 2.2k DCCH SRB if call status is Paging and Paging Service Type is set to RB Test Mode . Otherwise, the test set assigns the UE to a 3.4k SRB.

If SRB Configuration Control is set to Manual , the test set assigns the UE to the SRB specified by the Manual SRB Configuration setting.

Note, if your UE does not support changing RLC block size during connection setup and you wish to establish a 64k UL / 384k DL RMC (3GPP TS 25.101 A.2.2 and A.3.4) connection, you must set SRB Configuration Control to Manual and set Manual SRB Configuration to 2.2k DCCH . The Auto setting for SRB Configuration Control does not account for this particular channel configuration.

GPIB command: CALL[:CELL]:SRBearer:CCHannel:DEDicated:DRATe[:MANual]

Manual SRB Configuration

When SRB Configuration Control is set to Manual , this parameter determines what SRB the test set establishes with the UE.

GPIB command: CALL[:CELL]:SRBearer:CCHannel:DEDicated:DRATe[:MANual]

Operating Considerations

  • These settings cannot be changed during Active Cell operation. Instead, use the Cell Off operating mode when changing these settings. Attempting to change these settings while in Active Cell operating mode results in an error issued and the test set will reject the change. See CALL:OPERating to select operating modes.

Related Topics

Downlink Channel Codes


Equivalent PLMN List

Equivalent PLMN List

Last updated: November 11, 2009

This section is only applicable to the lab application.

  • Equivalent PLMN List Overview
  • Equivalent PLMN List Parameters
  • Operating Considerations

Equivalent PLMN List Overview

The Equivalent PLMN (E-PLMN) list allows a network to provide the UE with a list of PLMN identities. A PLMN is identified by the combination of Mobile Country Code (MCC), and Mobile Network Code (MNC) that the UE should treat as equivalent for the purposes of PLMN selection, cell selection/reselection and handover. The UE adds the PLMN of the current network to the received E-PLMN list before storing it.

The E-PLMN list can be signaled to the UE as part of the location area update, routing area update or GPRS attach procedures. It is not signaled on the broadcast channel. Specifically, it can be included in the Location Updating Accept, Routing Area Updating Accept and Attach Accept messages.

Equivalent PLMN List Parameters

This section is only applicable to the lab application.

The E-PLMN list can contain up to 15 entries. Each entry in the PLMN list is comprised of three settings, where <n> is a value between 1 and 15:

  • PLMN <n> MCC State / Value

    This parameter sets the MCC state and value for the specified entry in the list.

    GPIB command: CALL[:CELL]:PLMNetwork[:LIST][:EXTended]

  • PLMN <n> MNC State / Value

    This parameter sets the MNC state and value for the specified entry in the list.

    GPIB command: CALL[:CELL]:PLMNetwork[:LIST][:EXTended]

  • PLMN <n> MNC Length

    If an MNC length of Auto is selected, and the MNC value is 99 or less, then the test set uses 2 digits to represent the associated MNC, or 3 digits otherwise. If an MNC length of 3 Digits (1) is selected then the test set uses 3 digits to represent the associated MNC with leading added zeros as necessary.

    GPIB command: CALL[:CELL]:PLMNetwork[:LIST][:EXTended]

Operating Considerations

The Equivalent PLMN List is only applicable when the operating mode is set to Active Cell. If the Operating Mode is changed to anything other than Active Cell, you can still set up the Equivalent PLMN List, but this will have no effect on the message content.

The E-PLMN list is specified as a single variable length GPIB command that specifies the complete list (that is, it is not possible to edit a single entry using the GPIB command).

Related Topics

CALL:PLMNetwork


E-TFCI Recording Information

E-TFCI Recording Information

Last updated: November 11, 2010

This section is only applicable to the lab application or feature-licensed test application.

The Recorded E-TFCI Information screen displays the E-TFCI Recording State , Current E-TFCI Boost , Recorded E-TFCI Values and Number of E-TFCI Results Recorded . These results are set to their default values if you select Measurement Reset , when the Operating Mode changes, when a new HSPA connection is established in Active Cell Operating Mode , or when Channel Type changes to/from 12.2k RMC + HSPA while in FDD Test Operating Mode . The results are also set to their default values if you select Clear UE Info when the test set is not recording.

  • E-TFCI Recording State

    This result indicates whether the test set is currently recording a sequence of E-TFCI values from the UE. Possible states include Recording and Idle.

    GPIB command: CALL:STATus:ETFCi:RECord[:STATe]?

  • Current E-TFCI Boost

    GPIB command: CALL:STATus:ETFCi:BOOSt?

  • Recorded E-TFCI Values

    This result returns the sequence of E-TFCI values recorded when the Start Recording E-TFCI Values action was initiated.

    GPIB command: CALL:STATus:ETFCi:RECord:ALL?

  • Number of E-TFCI Results Recorded

    The number of E-TFCI results recorded is displayed at the bottom of the Recorded E-TFCI Values window (as shown circled above). When recording is active, this result is updated every 0.5 s. When recording is idle, this result indicates the number of E-TFCIs in the Recorded E-TFCI Values result.

    GPIB command: CALL:STATus:ETFCi:RECord:COUNt?

Related Topics

E-TFCI Recording


FDD Test Operating Mode

FDD Test Operating Mode

Last updated: January 7, 2012

  • FDD Test Overview
  • Synchronizing the UE to the Test Set's Downlink to Make Measurements
  • Additional FDD Test Mode Settings
  • FDD Test Operating Considerations
  • HSDPA in FDD Test Operating Mode (lab application or feature-licensed test application only)
  • HSPA in FDD Test Operating Mode (lab application or feature-licensed test application only)

FDD Test Overview

In FDD Test (frequency division duplex) Operating Mode , the test set does not send any signalling information on the downlink. Any changes to the UE configuration, such as channel, loopback type, or dedicated physical channel (DPCH) scrambling code, must be accomplished by directly sending commands to the UE from a system controller (usually a personal computer) through a proprietary digital interface.

Upon entry into test mode, the test set begins continuously transmitting a downlink signal which consists of a dedicated physical channel (DPCH) configured as the specified symmetrical reference measurement channel (see Symmetrical RMCs ) and several overhead channels required to allow the UE to synchronize to the test set and decode transmitted data (see Downlink and Uplink Channels Overview ). When HSDPA is active ( for lab applications and feature-licensed test applications only ), the test set also transmits up to 5 HS-PDSCHs (as determined by the FDD Test "FRC Type" on page 1 setting) and up to 4 HS-SCCHs (see HSDPA in FDD Test Operating Mode ).

The UE must synchronize to the transmitted downlink channels and transmit the proper corresponding uplink signal(s). The UE's performance can then be measured using the suite of measurements available in the test set. To emulate interference from other cells or users, two noise sources (OCNS and AWGN) can be added as desired.

The following example selects FDD Test operating mode via GPIB:

OUTPUT 714;"CALL:OPERating:MODE FDDT"

Synchronizing the UE to the Test Set's Downlink to Make Measurements

The following test set controls must match your UE configuration to allow it to synchronize to the test set's downlink signal and transmit an uplink signal that the test set can receive and measure:

  • Cell Power - The power level out of the test set must be high enough for the UE to receive the downlink signal and decode the data.

  • Channel Type - The UE must support Symmetrical RMCs . The UE must be configured to transmit the RMC to which Channel Type is set.

  • Uplink DPCH Scrambling Code - You must set this to the scrambling code the UE is using to transmit its uplink signal. This setting tells the test set which scrambling code to use to decode the uplink signal from the UE.

  • RF Gen Freq Ctrl

    The RF Gen Freq Ctrl setting is only applicable to the FDD Test operating mode. When changing between operating modes, the RF Gen Freq Ctrl setting is returned to its default value of Auto .

    GPIB command: CALL[:CELL]:CONTrol:DOWNlink:FREQuency:AUTO .

    Manual operation: F11 on the Call Parms 3 of 3 menu.

    The UE must be set to receive the downlink signal on the proper frequency. You can set the downlink frequency manually or automatically, depending upon the RF Gen Freq Ctrl setting.

    • When RF Gen Freq Ctrl is set to Auto , the downlink frequency is determined by the DL Channel setting.
    • RF Gen Freq

      When RF Gen Freq Ctrl is set to Manual , the downlink frequency is determined by the RF Gen Freq setting. The RF Gen Freq setting is only applicable to FDD Test operating mode and CW Operating Mode (in CW operating mode, generator frequency control is always manual).

      GPIB command: CALL[:CELL]:RFGenerator:FREQuency .

      Manual operation: F7 under Channel (UARFCN) Parms ( F12 on the Call Parms 1 of 3 menu).

  • Uplink Frequency / Uplink Channel - You must indicate at what frequency the UE is transmitting. You can specify the uplink frequency or uplink channel.

  • Measurement Frequency - You must indicate at what frequency the test set should perform measurements. You can specify this frequency manually, or automatically set the measurement frequency to match the Uplink Channel setting.

  • Downlink Channel Codes - The UE must be set to expect the following code settings from the test set on the downlink:

    • Shared DL Channel Codes : Primary Scrambling Code - This value must match the downlink scrambling code the UE expects in order for the UE to decode the downlink channels and synchronize to the test set.
    • Shared DL Channel Codes : PICH Channelization Code - You can not perform the Paging procedure while in FDD test operating mode, but you may choose to send DL PICH Data on the PICH. If so, you must specify the PICH channelization code the UE expects.
    • WCDMA DL Channel Codes : DPCH channelization code - This value must match the DPCH channelization code the UE expects.

  • DPCH Frame Offset

    You can set the DPCH Frame Offset to 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, or 10 x 256 chips (see Current DPCH Offset for more information about DPCH Frame Offset). Note, you must then also set this DPCH Frame Offset in the UE so that it can successfully decode the test set's signal; the test set does not provide any signalling to the UE in FDD test operating mode and thus will not signal the DPCH Frame Offset setting to the UE.

    GPIB command: CALL:FDDTest:DPCHannel:FOFFset

  • Power Control / Manual Power / UE Target Power - You must indicate the power level at which the UE is expected to transmit, so the test set can properly range its receivers.

  • UE Loopback Type - When performing receiver tests, you must set UE Loopback Type to the loopback type the UE is set to use (the test set does not signal the loopback type to the UE).

  • UL CL Power Ctrl Parameters

    See Uplink Closed Loop Power Control Parameters and UE Target Power .

    • FDD Test UL CL Power Ctrl Mode

      If you set FDD Test UL CL Power Ctrl Mode to Active bits , be sure to set FDD Test UL CL Power Ctrl Algorithm and FDD Test UL CL Power Ctrl Stepsize to the values being used by the UE, so that the test set can successfully drive the UE's power to the UE Target Power setting. The test set does not signal the power control algorithm or step size to the UE. Also, if Uplink DPCH Bc/Bd Control is set to Manual , ensure that Manual Uplink DPCH Bc and Manual Uplink DPCH Bd are set to match your UE's operation.

      GPIB command: CALL:FDDTest:CLPControl:UPLink:MODE .

    • FDD Test UL CL Power Ctrl Algorithm

      GPIB command: CALL:FDDTest:CLPControl:UPLink:ALGorithm .

    • FDD Test UL CL Power Ctrl Stepsize

      GPIB command: CALL:FDDTest:CLPControl:UPLink:STEPsize .

    • Send Step Up/Down TPC Bit Pattern

  • Uplink Parameters - Ensure that Bc and Bd are set to match your UE's configuration.

    • Uplink DPCH Bc/Bd Control
    • Manual Uplink DPCH Bc
    • Manual Uplink DPCH Bd

  • DL TFCI Pattern

    This setting is only applicable to FDD Test Operating Mode .

    You must indicate what value the test set should transmit in the TFCI field (see 3GPP TS 25.331 10.3.5.16). You can set DL TFCI Pattern to any value between 000 and 3FF (0 to 1023). You must set DL TFCI Pattern to the value that corresponds to the RMC Transport Format Combination in the Transport Combination Set (TFCS) you've provided to the UE.

    GPIB command: CALL:FDDTest:TFCIndicator .

    Manual operation: F5 on the Call Control 1 of 2 menu.

  • Uplink TFCI Control

    This setting is only applicable to FDD Test Operating Mode .

    When Uplink TFCI Control is set to Auto , the test set uses the TFCI value sent by the UE on the DPCCH. The test set uses the standard RMC TFCI table to interpret the received TFCI:

    When Uplink TFCI Control is set to Manual , the test set ignores the TFCI value sent by the UE and uses the value specified by the Manual Uplink TFCI setting.

    GPIB command: CALL:FDDTest:UPLink:TFCIndicator:CONTrol:AUTO

    Manual operation: Uplink Parameters (F4) on the Call Control 2 of 2 menu.

  • Manual Uplink TFCI

    This setting is only applicable to FDD Test Operating Mode .

    When Uplink TFCI Control is set to Manual , this setting determines whether the test set expects just the DTCH ( DTCH Only ) or the DTCH plus DCCH ( DTCH + DCCH ) on the uplink DPCH.

    GPIB command: CALL:FDDTest:UPLink:TFCIndicator:MANual

    Manual operation: Uplink Parameters (F4) on the Call Control 2 of 2 menu.

Additional FDD Test Mode Settings

  • DL DTCH Data

  • DL PICH Data

    This setting is only applicable to FDD Test Operating Mode .

    The paging indicator channel can be set to transmit either all zeroes or all ones.

    GPIB command: CALL:FDDTest:PICHannel:DATA .

    Manual operation: F8 on the Call Parms 2 of 3 menu.

  • Downlink Channel Levels :

    • WCDMA DL Channel Levels
      • FDD Test CPICH Level

        GPIB command: CALL:FDDTest:CPIChannel[:SLEVel] .

      • FDD Test P-CCPCH/SCH Level

        GPIB command: CALL:FDDTest:CCPChannel:PRIMary[:SLEVel] .

      • FDD Test PICH Level

        GPIB command: CALL:FDDTest:PICHannel[:SLEVel] .

      • FDD Test DPCH Level

        GPIB command: CALL:FDDTest:DPCHannel[:SLEVel] .

    • AWGN Power

  • Uplink DTCH RMC CRC Presence

  • Compressed Mode (lab application only) - see Compressed Mode Operation While in FDD Test Operating Mode .

  • Trigger Output Setup

FDD Test Operating Considerations

The test set can perform loopback bit error ratio (BER) measurements if the UE provides a loopback mode that conforms to 3GPP TS 34.109, section 5.3.2.6.2, Loopback of RLC SDUs . Additionally, the uplink DPDCH transport format must be set so both the dedicated traffic channel (DTCH) and dedicated control channel (DCCH) are present (however, the test set will ignore the contents of the DCCH so the actual content of this channel is not relevant).

When the test set and the UE are synchronized, the UE uplink frame starts 1024 chips after the receiving the corresponding downlink frame. Measurements that require synchronization will not trigger correctly (or at all) if this timing relationship does not exist.

In FDD Test operating mode, the test set does not negotiate with the UE to set up a call, or provide any other form of interactive control of the UE (other than uplink closed loop power control, see UL CL Power Ctrl Parameters ). You can select the transport format indication (TFCI) pattern sent to the UE on the downlink, but the test set does not assume or verify that the UE responded. The test set ignores transport format combination indicator (TFCI) and transmit power control (TPC) bits sent on the uplink.

HSDPA in FDD Test Operating Mode

This section is only applicable to the lab application or feature-licensed test application.

HSDPA Activation in FDD Test

In FDD Test operating mode, HSDPA is active when Channel Type is set to 12.2k RMC + HSDPA .

HSDPA Operation in FDD Test

When HSDPA is active, in addition to the 12.2k RMC and common channels, the test set transmits up to 5 HS-PDSCHs (as determined by the FDD Test "FRC Type" on page 1 or FDDT "User Defined Number of Active HS-PDSCHs" on page 4 settings) and up to 4 HS-SCCHs. The test set also generates a six-channel OCNS as specified by 3GPP TS 34.121 sE.5.2 (codes 122 - 127, spreading factor 128), rather than the OCNS defined in sE.3.6 (see OCNS in HSDPA/HSPA ).

When HSDPA is active, the test set expects the UE to transmit a 12.2k RMC as well as an HS-DPCCH that contains ACK/NACK information corresponding to the downlink HS-PDSCH data. The HSDPA Information window displays counters to help you monitor the HSDPA connection status. Note, the test set expects an uplink DPCCH to be present when an uplink HS-DPCCH is transmitted (otherwise the HS-DPCCH can not be decoded as there are no pilot bits in the HS-DPCCH).

In FDD Test operating mode, the test set does not signal the Ack-Nack Repetition Factor to the UE, you must set the value manually in the UE. To ensure valid HSDPA BLER results, you must ensure that the minimum inter-TTI of the active HSDPA channel is greater than or equal to 2 ms * Ack-Nack Repetition Factor (so that there is sufficient space on the uplink for the ACK/NACK repeats to be transmitted). See Ack-Nack Repetition Factor for more information about this requirement.

In FDD Test operating mode, the test set does not signal the CQI Feedback Cycle (k) or CQI Repetition Factor to the UE, you must set the values manually in the UE. To ensure a valid Median CQI result, you must ensure that CQI Feedback Cycle (k) is greater than or equal to CQI Repetition Factor * 2ms (so that there are no collisions between new and repeated CQI information). See CQI Transmission Settings for more information about this requirement.

The following diagram illustrates the HSDPA FDD test mode configuration in the test set, as well as the expected channels from the UE:

To test HSDPA UEs in FDD test mode, you must synchronize the UE and test set as described in Synchronizing the UE to the Test Set's Downlink to Make Measurements .

Additionally, you must consider the following:

  • Channel Type must be set to 12.2k RMC + HSDPA ( CALL:SERVice:RBTest:RAB ).

  • You must ensure that you have properly configured the HSDPA Parameters ( F10 on the HSPA Parameters menu):

    HS-DSCH Parameters

    • FDD Test RB Test HS-DSCH Configuration Type

      GPIB command: CALL:FDDTest:HSDSchannel:CONFig[:TYPE]

    • FDD Test FRC Type

      GPIB command: CALL:FDDTest:FRC:TYPE .

    • FDD Test

      GPIB command: CALL:FDDTest:HSDSchannel:UDEFined:DCHSdpa[:STATe]

    • FDD Test User Defined HS-DSCH MAC Entity

      GPIB Command: CALL:FDDTest:HSDSchannel:UDEFined:MAC

    • FDD Test User Defined 64QAM State

      GPIB Command: CALL:FDDTest:HSDSchannel:UDEFined:QAM64:STATe

    • FDD Test User Defined MAC-ehs HS-DSCH TB Size Table

      GPIB Command: CALL:FDDTest:HSDSchannel:UDEFined:MACEHS:TBSTable:ALIGnment

    • FDDT User Defined Number of Active HS-PDSCHs

      GPIB command: CALL:FDDTest:HSDSchannel:UDEFined:HSPDschannel:COUNt

    • FDDT User Defined Transport Block Size Index

      GPIB command: CALL:FDDTest:HSDSchannel:UDEFined:TBSize:INDex

    • FDD Test User Defined Modulation Type

      GPIB command: CALL:FDDTest:HSDSchannel:UDEFined:MODulation[:TYPE]

    • FDD Test User Defined Inter-TTI Interval

      GPIB command: CALL:FDDTest:HSDSchannel:UDEFined:ITTI[:INTerval]

    • FDD Test User Defined Number of HARQ Processes

      GPIB command: CALL:FDDTest:HSDSchannel:UDEFined:HARQ:PROCess:COUNt

    • FDD Test User Defined UE IR Buffer Allocation

      Controls how the IR buffer size for each active HARQ process is determined.

      When FDD Test User Defined UE IR Buffer Allocation is set to Implicit , the total IR buffer size for the FDD Test UE HS-DSCH Category ("total number of soft channel bits" in 3GPP TS 25.306 Table 5.1a) is divided equally among the active HARQ processes. Note that to configure the user defined downlink to emulate an FRC, you may need to set User Defined UE IR Buffer Allocation to Explicit , and then set FDDT "User Defined Explicit UE IR Buffer Size" accordingly (see Example User Defined Configuration: Configuring the Downlink as an FRC ).

      When FDD Test User Defined UE IR Buffer Allocation is set to Explicit , the IR buffer size allocated to each active HARQ process is determined directly by the FDDT "User Defined Explicit UE IR Buffer Size" setting. This setting allows you to allocate less than your UE's maximum total IR buffer size (which may be required if you wish to emulate an FRC, see Example User Defined Configuration: Configuring the Downlink as an FRC ).

      GPIB command: CALL:FDDTest:HSDSchannel:UDEFined:MS:IREDundancy:BUFFer:ALLocation

    • FDDT User Defined Explicit UE IR Buffer Size

      GPIB command: CALL:FDDTest:HSDSchannel:UDEFined:MS:IREDundancy:BUFFer:SIZE[:EXPLicit]

    • FDD Test UE HS-DSCH Category

      When FDD Test User Defined UE IR Buffer Allocation is set to Implicit , this setting specifies the UE category to use for determining the IR buffer size.

      GPIB command: CALL:FDDTest:HSDSchannel:MS:CATegory

    • FDD Test HS-DSCH Data Pattern

      GPIB command: CALL:FDDTest:HSDSchannel:DATA

    • FDD Test F-DPCH State

      When the Channel Type is set to HSPA , this setting controls whether the F-DPCH is configured instead of the associated DPCH in the downlink while operating in FDD Test Mode.

      When FDD Test "RB Test User Defined DC-HSDPA State" on page 3 is "ON", you can not set this parameter to "ON" because F-DPCH is not available with MAC-ehs.

      GPIB Command: "CALL:FDDTest:FDPChannel:STATe" on page 366

    • FDD Test User Def Secondary Cell 64QAM State

      This parameter controls whether the 64QAM encoding format defined in 3GPP TS 25.212 v8.6.0 s4.6 should be used for the secondary serving cell HS-SCCH. This setting is also used to determine the actual transport block size as described in .

      This setting is also involved in determining the HS-DSCH TB size table.

      If FDD Test User Def Secondary Cell Modulation Type is "64QAM", you can not set this parameter to "Off".

      GPIB Command:

    • FDD Test User Def Secondary Cell HS-DSCH TBS Table

      This setting selects the HS-DSCH TB size table when FDD Test User Def Secondary Cell 64QAM State is "Off". This setting is also used to determine the actual transport block size as described in .

      GPIB Command:

    • FDD Test User Def Secondary Cell Active HS-PDSCHs

      This setting controls how many HS-PDSCHs are active on the secondary serving cell.

      You can not change this setting to a value that when added to the FDD Test First HS-PDSCH Channelization Code is greater than 16.

      If you changes this setting to a new value results in a change the number of HS-PDSCHs such that there would be a collision in code-space, the test set will not block your operation and will still transmit using requested number of HS-PDSCHs, but the test set should detect collision and issue persistent error message. The persistent error message will be removed once the test set detected no collisions currently active channels.

      GPIB Command: CALL:FDDTest:SSCell:HSDSchannel:UDEFined:HSPDschannel:COUNt

    • FDD Test User Def Secondary Cell TB Size Index

      This setting controls the transport block size index of the secondary serving cell and is used to determine the actual transport block size as described in .

      GPIB Command: CALL:FDDTest:SSCell:HSDSchannel:UDEFined:TBSize:INDex

    • FDD Test User Def Secondary Cell Modulation Type

      This setting controls the modulation type of the currently active HS-PDSCH channels on the secondary serving cell and is used to determine the actual transport block size as described in .

      If FDD Test User Def Secondary Cell 64QAM State is "Off", setting this parameter to "64QAM" will be rejected.

      GPIB Command: CALL:FDDTest:SSCell:HSDSchannel:UDEFined:MODulation[:TYPE]

    • FDD Test Def Sec Cell Inter-TTI Interval

      This setting controls the absolute inter-TTI interval between transmitting blocks to the UE on the secondary serving cell HS-PDSCHs.

      GPIB Command: CALL:FDDTest:SSCell:HSDSchannel:UDEFined:ITTI[:INTerval]

    MAC-hs Parameters

    • FDD Test Number of Transmissions

      GPIB command: CALL:FDDTest:MACHs:NTRans

    • FDD Test RV Sequence

      GPIB command: CALL:FDDTest:MACHs:RVSequence

    • MAC-hs Transmit Window Size

      This setting is only used when MAC-hs Header is set to Present (when MAC-hs Header is set to Data , the transmit window size is infinite).

      MAC-hs Transmit Window Size can be set to 4, 6, 8, 12, 16, 24, or 32. In accordance with 3GPP TS 25.321 11.6.2.3.2, the test set will not retransmit a block with a TSN that is outside the transmit window.

      GPIB command: CALL:FDDTest:MACHs:WSIZe:TRANsmit

    • MAC-hs Header

      You may choose to fill the MAC-hs header with dummy data (such as PRBS, to ensure that there are no repeating patterns of data in each MAC-hs frame, or simply to provide an uninterrupted stream of PRBS data) or include a header with valid content.

      • Present

        When MAC-hs Header is set to Present , each MAC-hs block contains a valid MAC-hs header formatted with the following values (see 3GPP TS 25.321 9.2.2):

        The TSN (Transmission Sequence Number) field is incremented each time a new block is sent by a HARQ process. When MAC-hs Header is set to Present , the test set uses the MAC-hs Transmit Window Size to control its window size.

      • Data

        When MAC-hs Header is set to Present , the MAC-hs header space for each block is filled with FDD Test "HS-DSCH Data Pattern" data.

      GPIB command: CALL:FDDTest:MACHs:HEADer .

    • FDD Test statDTX Reception Behavior

      GPIB command: CALL:FDDTest:MACHs:SDTX:RBEHavior

    HSDPA Uplink Parameters

    These values are not signalled to the UE in FDD Test mode; rather, you must ensure that the UE is using the same values as these settings.

    • DeltaACK
    • DeltaNACK
    • DeltaCQI

    Secondary Serving Cell Parameters

    • Secondary Serving Cell Power

      GPIB command:

    • FDD Test Secondary Serving Cell Downlink UARFCN

      GPIB command:

    • Secondary Serving Cell Primary Scrambling Code

      GPIB command: CALL:SSCell:SCODe[:PRIMary] .

    H-RNTI Parameters

    • FDD Test Primary H-RNTI (Hex)

      GPIB command: CALL:FDDTest:HRNTi[:PRIMary]

    • FDD Test Alternate H-RNTI (Hex)

      GPIB command: CALL:FDDTest:HRNTi:ALTernate

    • FDD Test HS-SCCH1 Alternate H-RNTI (Hex)

      GPIB command: CALL:FDDTest:HRNTi:ALTernate:HSSCCH1

    • FDD Test HS-SCCH2 Alternate H-RNTI (Hex)

      GPIB command: CALL:FDDTest:HRNTi:ALTernate:HSSCCH2

    • FDD Test HS-SCCH3 Alternate H-RNTI (Hex)

      GPIB command: CALL:FDDTest:HRNTi:ALTernate:HSSCCH3

    • FDD Test HS-SCCH4 Alternate H-RNTI (Hex)

      GPIB command: CALL:FDDTest:HRNTi:ALTernate:HSSCCH4

    • FDD Test Secondary Serving Cell H-RNTI (Hex)

      GPIB command:

  • You must set the HSDPA/HSPA DL Channel Codes ( Generator Info ( F2 )>> Downlink Channel Codes ( F2 ), F4 ).

    • FDD Test First HS-PDSCH Channelization Code

      This parameter sets the channelization code of the first HS-PDSCH when on an FDD Test Mode connection. If more than one HS-PDSCH is being generated, the other HS-PDSCHs are assigned to the subsequent channelization codes.

      This parameter cannot be set to 5 when HSDPA DPCH 12.2k RMC Channelization Code is set to 45 or 54, and cannot be set to 6 when HSDPA DPCH 12.2k RMC Channelization Code is set to 54. Also, the number of HS-PDSCHs specified by the FDD Test "FRC Type" on page 1 or FDDT "User Defined Number of Active HS-PDSCHs" on page 4 settings, when added to the FDD Test First HS-PDSCH Channelization Code cannot exceed 15 (otherwise the HS-PDSCHs would collide with the downlink OCNS channels).

      GPIB command: CALL:FDDTest:HSPDschannel:CCODe

  • To set the downlink channel levels, you must use the HSDPA Connected DL Channel Levels settings ( Generator Info ( F2 )>> Downlink Channel Levels ( F3 ), F4 ).

    • HSDPA FDD Test CPICH Level : CALL:FDDTest:CPIChannel[:SLEVel]:HSDPa .
    • HSDPA FDD Test P-CCPCH/SCH Level : CALL:FDDTest:CCPChannel:PRIMary[:SLEVel]:HSDPa .
    • HSDPA FDD Test PICH Level : CALL:FDDTest:PICHannel[:SLEVel]:HSDPa .
    • HSDPA FDD Test DPCH Level : CALL:FDDTest:DPCHannel[:SLEVel]:HSDPa .
    • HSDPA FDD Test HS-PDSCHs Level (Sum) : CALL:FDDTest:HSPDschannel[:SLEVel] .
    • HSDPA FDD Test HS-SCCH 1 Level : CALL:FDDTest:HSSCchannel[1][:SLEVel] .
    • HSDPA FDD Test HS-SCCH 2 Level : CALL:FDDTest:HSSCchannel2[:SLEVel] .
    • HSDPA FDD Test HS-SCCH 3 Level : CALL:FDDTest:HSSCchannel3[:SLEVel] .
    • HSDPA FDD Test HS-SCCH 4 Level : CALL:FDDTest:HSSCchannel4[:SLEVel] .
    • HSDPA FDD Test Secondary Cell CPICH Level :
    • HSDPA FDD Test Secondary Cell P-CCPCH/SCH Level : .
    • HSDPA FDD Test Secondary Cell PICH Level : .
    • HSDPA FDD Test Secondary Cell HS-PDSCHs Level(Sum) : .
    • HSDPA FDD Test Secondary Cell HS-SCCH 1 Level : .
    • HSDPA FDD Test Secondary Cell HS-SCCH 2 Level : .
    • HSDPA FDD Test Secondary Cell HS-SCCH 3 Level : .
    • HSDPA FDD Test Secondary Cell HS-SCCH 4 Level : .

  • You can vary the timing between the uplink DPCH and HS-DPCCH using the DPCH Frame Offset setting.

HSPA in FDD Test Operating Mode

This section is only applicable to the lab application or feature-licensed test application.

HSPA Activation in FDD Test

In FDD Test operating mode, HSPA is active when Channel Type is set to 12.2k RMC + HSPA .

HSPA Operation in FDD Test

When HSPA is active, the test set operates a fully functional Layer1 plus MAC-e solution, in that E-DCH blocks are decoded according to the E-TFCI and the appropriate ack or nack is sent on the E-HICH. The test set discards any blocks received on the E-DCH after transmitting the ack or nack. This means that the UE may use any value it likes for the DDI, N and TSN fields in the MAC-e/es PDU. There is no signaling on the control plane above MACe/es.

While on an HSPA channel in FDD Test Mode, the HSDPA downlink operates much as it does for an HSDPA-only channel type. The primary difference is that while on an HSPA channel the HS-DSCH transmits RLC PDUs that contain valid RLC UM headers. This is in contrast to HSDPA-only FDD test mode where there are no RLC headers sent on the HS-DSCH (PRBS data is sent instead). The headers are necessary so that the UE can loop back the downlink data received on the HS-DSCH back onto the uplink E-DCH. The loopback point in HSPA FDD test mode is expected to be immediately above the UE's RLC layer (which is the same place as for active cell). This means the RLC layer must deliver complete blocks to the loopback entity for there to be data on the E-DCH. The UE's RLC UM entity can only deliver blocks up to its loopback entity if it is receiving consistent header data (not PRBS data) that allows it to recreate complete SDUs. While operating on an HSPA channel type in FDD test mode the test set therefore transmits valid RLC UM headers. The RLC PDU size is 336 bits when an HSDPA FRC is configured (this matches the specification for FRCs in 3GPP TS 34.121) or 112 bits when an HSDPA user defined configuration is used. The downlink RLC SDU size is set to 2936 bits (just like in active cell operating mode). As many RLC PDUs are packed in a single MAC-hs PDU as will fit, subject to the same limits as described in HSPA Radio Bearer Test Mode . The same MAC-hs header format as described in MAC-hs Header above is used with the exception that the N field is set to the actual number of RLC PDUs packed in the MAC-hs PDU.

To test HSPA UEs in FDD test mode, you must synchronize the UE and test set as described in Synchronizing the UE to the Test Set's Downlink to Make Measurements .

Additionally, you must consider the following:

  • Channel Type must be set to 12.2k RMC + HSPA ( CALL:SERVice:RBTest:RAB ).

  • You must ensure that you have properly configured the HSDPA Parameters as described above in HSDPA Operation in FDD Test .

  • You must ensure that you have properly configured the HSUPA Parameters ( HSPA Parameters ( F10 ), F9 ): Common HSUPA Parameters , Serving Grant , E-TFCI Recording , E-RNTI Parameters and

    HSUPA FDD Test Mode Setup

    • FDD Test E-DPDCH Max Channel Codes

      This setting is used to inform the test set (while operating in FDD Test mode) what value the UE is using for E-DPDCH Max Channelisation Codes. Knowledge of this value is necessary to be able to translate the E-TFCI value that the UE transmits on the E-DPCCH to the spreading factor and number of channels used on the E-DPDCH.

      GPIB command: CALL:FDDTest:EDPDchannel:CCODes:MAX

  • You must set the HSDPA/HSPA DL Channel Codes ( Generator Info ( F2 )>> Downlink Channel Codes ( F2 ), F4 ). See FDD Test First HS-PDSCH Channelization Code above.

  • To set the downlink channel levels, you must use the HSPA Connected DL Channel Levels settings ( Generator Info ( F2 )>> Downlink Channel Levels ( F3 ), F5 ).

    • HSPA FDD Test CPICH Level : CALL:FDDTest:CPIChannel[:SLEVel]:HSPA .
    • HSPA FDD Test P-CCPCH/SCH Level : CALL:FDDTest:CCPChannel:PRIMary[:SLEVel]:HSPA .
    • HSPA FDD Test PICH Level : CALL:FDDTest:PICHannel[:SLEVel]:HSPA .
    • HSPA FDD Test DPCH Level : CALL:FDDTest:DPCHannel[:SLEVel]:HSPA .
    • HSPA FDD Test E-AGCH Level : CALL:FDDTest:EAGChannel[:SLEVel] .
    • HSPA FDD Test E-HICH Level : CALL:FDDTest:EHIChannel[:SLEVel] .
    • HSPA FDD Test E-RGCH Level : CALL:FDDTest:ERGChannel[:SLEVel] .
    • HSPA FDD Test HS-PDSCHs Level (Sum) : CALL:FDDTest:HSPDschannel[:SLEVel]:HSPA .
    • HSPA FDD Test HS-SCCH 1 Level : CALL:FDDTest:HSSCchannel[1][:SLEVel]:HSPA .
    • HSPA FDD Test HS-SCCH 2 Level : CALL:FDDTest:HSSCchannel2[:SLEVel]:HSPA .
    • HSPA FDD Test HS-SCCH 3 Level : CALL:FDDTest:HSSCchannel3[:SLEVel]:HSPA .
    • HSPA FDD Test HS-SCCH 4 Level : CALL:FDDTest:HSSCchannel4[:SLEVel]:HSPA .
    • HSPA FDD Test Secondary Cell CPICH Level :
    • HSPA FDD Test Secondary Cell P-CCPCH/SCH Level : .
    • HSPA FDD Test Secondary Cell PICH Level : .
    • HSPA FDD Test Secondary Cell HS-PDSCHs Level(Sum) : .
    • HSPA FDD Test Secondary Cell HS-SCCH 1 Level : .
    • HSPA FDD Test Secondary Cell HS-SCCH 2 Level : .
    • HSPA FDD Test Secondary Cell HS-SCCH 3 Level : .
    • HSPA FDD Test Secondary Cell HS-SCCH 4 Level : .

  • You can vary the timing between the uplink DPCH and HS-DPCCH using the DPCH Frame Offset setting.

Related Topics

Cell Power and AWGN Power


FM Broadcast

FM Broadcast

Last updated: January 15, 2009

  • Description
  • FM Broadcast Parameters

Description

You can use the test set coupled with the audio measurement features to test the Mobile Station with full range of FM (frequency modulated) Broadcast signals. The FM Broadcast signals are generated by utilizing two RF sources in the test set and an external mixing device (E5520 FM Adaptor).

FM Broadcast test system

The following diagram shows a typical FM Broadcast test system configuration.

The FM Broadcast test system is made up of the test set, FM Adapter and Mobile Station. The FM Adapter connects to the RF OUT ONLY port of the test set directly. The Mobile Station connects to the output of the FM Adapter with RF antenna. To make measurement on the received audio signal, the Mobile Station's demodulated FM output connects to the High AUDIO IN connector of the test set.

When the test set is in CW operating mode and FM broadcast mode, one of the test set's RF sources is fixed at 1 GHz and the other source provides an FM signal from 890 MHz to 990 MHz. The FM Adapter mixes the 1 GHz Local Oscillator signal with the FM signal, then the filters it to provide a stable and accurate resultant signal at the user specified FM broadcast frequency (10 MHz to 110 MHz). The test set also allows you to set parameters such as internal frequency deviation, FM broadcast power and amplitude offset when the test set is in FM Broadcast mode. Once the test set is generating the FM signal and is properly connected to the Mobile Station, the Mobile Station's FM receiver performance is ready to analyzed. A common method of analyzing the FM signal that has been demodulated by the Mobile Station is to connect the Mobile Station's demodulated FM output to the test set's High AUDIO INPUT connector, perform and run the appropriate Audio Analyzer measurements.

NOTE
The FM Broadcast test is only available when the operating mode is set to CW .

FM Broadcast Parameters

RF Output Config

There are two RF generator configuration settings:

  • Normal: This mode is the normal CW operating mode in which the test set generates a CW signal.
  • FM broadcast: In this mode, the test set generates the signals that are sent through the RF OUT ONLY port to the FM Adapter to produce an FM Broadcast signal. The FM Broadcast parameters do not appear on the front panel of the test set and the GPIB command that set the FM Broadcast parameters do not apply until the RF Output Configure parameter is set to this mode.

This parameter only applies when RF Output Configure is set to FM Broadcast.

The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:CONFigure .

FM Broadcast Frequency

This parameter sets the frequency at which the test set broadcasts the FM signal.

This parameter only applies when RF Output Configure is set to FM Broadcast.

The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:FREQuency .

FM Broadcast Power

  • FM Broadcast Power State

    This parameter sets whether the FM Broadcast Power setting is applied.

    This parameter only applies when RF Output Configure is set to FM Broadcast.

    The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:STATe .

  • FM Broadcast Power

    This parameter sets the power at which the test set broadcasts the FM signal.

    This parameter only applies when RF Output Configure is set to FM Broadcast.

    The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:AMPLitude .

FM Broadcast Amplitude Offset menu

  • Adapter Conversion Gain

    This parameter sets the loss of the FM Adapter. The test set compensates for the loss by increasing the signal strength at the RF OUT ONLY port.

    This parameter only applies when RF Output Configure is set to FM Broadcast.

    The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:ADAPter:GAIN .

  • Amplitude Offset State

    This parameter sets whether the FM Broadcast mode Amplitude Offset setting is applied.

    This parameter only applies when RF Output Configure is set to FM Broadcast.

    The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:STATe .

  • Amplitude Offset

    This parameter sets the FM Broadcast mode Amplitude Offset setting that is applied to the RF OUT ONLY port.

    This parameter only applies when RF Output Configure is set to FM Broadcast.

    The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:GAIN .

Internal FM Deviation

  • Internal FM Deviation State

    This parameter sets whether the FM Broadcast mode Internal FM Deviation setting is applied.

    This parameter only applies when RF Output Configure is set to FM Broadcast.

    The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:STATe .

  • Internal FM Deviation

    This parameter is used to control the FM Deviation of the internal audio source. The internal audio source is the amount the modulated signal deviates from the carrier frequency.

    This parameter only applies when RF Output Configure is set to FM Broadcast.

    The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:DEViation .

Internal FM Frequency

This parameter sets the test set's internal FM frequency. (This is simply the modulation frequency.)

This parameter only applies when RF Output Configure is set to FM Broadcast.

The GPIB command to set this parameter is CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:FREQuency .

Related Topics

How Do I Make a FM Broadcast test?


Frequency Band Indicator State

Frequency Band Indicator State

Last updated: January 15, 2009

You can specify whether the test set sends a frequency band indicator using the Frequency Band Indicator State setting. When Frequency Band Indicator State is Off , the test set does not send a frequency band indicator. When Frequency Band Indicator State is On , the test set sends the frequency band indicator corresponding to the band of the current DL Channel setting.

3GPP TS 25.307 specifies that all UEs supporting Bands IV and above be capable of decoding either Frequency Band Indicator or Frequency Band Indicator 2. As per 3GPP TS 25.331 s10.3.6.35b/c, the test set transmits the Frequency Band Indicator (RadioFrequencyBandFDD) information element for Bands I through VII, and the Frequency Band Indicator 2 (RadioFrequencyBandFDD2) information element for Band VIII and above.

GPIB command: CALL[:CELL]:BCCHannel:FBINdicator:STATe .

This setting cannot be changed in active cell operating mode.

Manual operation: Select Channel (UARFCN) Parameters ( F12 on the Call Parms 1 of 3 menu), then select Freq Band Ind ( F10 ).

Transmit SIB5bis

SIB5bis was introduced by 3GPP as a way to allow new frequency bands to be created that overlap existing frequency bands. For example, when Band IV was introduced it overlapped Band I. To prevent older Band I UEs from camping on Band IV cells (and then transmitting their PRACH messages on the wrong uplink frequency due to a different Tx/Rx frequency separation), Band IV networks transmit SIB5bis instead of SIB5. Band IV UEs expect SIB5bis and can camp to the cell, but older Band I mobiles simply see that SIB5 is missing and thus do not camp to the Band IV cell. SIB5bis is identical to SIB5 except for the SIB type.

The Frequency Band Indicator/Frequency Band Indicator 2 information element is sent in either SIB5 or SIB5bis. Whether SIB5 or SIB5bis is transmitted by the test set is determined by the Transmit SIB5bis setting. 3GPP TS 25.331 v7.3.0 table 8.1.1 states "System information block type 5bis is sent instead of system information block type 5 in cells that use Band IV or Band IX or Band X." Thus, when Transmit SIB5bis is set to its default value of Standard Bands , the test set transmits SIB5bis (rather than SIB5) when the DL Channel is set to a band IV, IX or X UARFCN. You can also specify that the test set transmit SIB5bis for No Bands , Band IV , Band IX , Band X , Bands IV & IX or All Bands .

GPIB command: CALL[:CELL]:BCCHannel:SIB5:BIS

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Manual operation: Select Channel (UARFCN) Parameters ( F12 on the Call Parms 1 of 3 menu), then select Transmit SIB5bis ( F11 ).

Band Arbitrator

All of the Band VI UARFCNs (downlink: 1037, 1062, 4387 - 4413 and uplink: 812, 837, 4162 - 4188) are also used by Band V.

Thus, when you set DL Channel to a value in Band VI, you must specify whether you want the test set to send a Band V or Band VI Frequency Band Indicator using the Band Arbitrator setting (note that a frequency band indicator will only be sent if Frequency Band Indicator State is set to On ).

GPIB command: CALL[:CELL]:BARBitrator

This setting can only be changed when call status is Idle (to change it while on a connection, you must perform a Physical Channel Reconfiguration , Transport Channel Reconfiguration or Radio Bearer Reconfiguration ). If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Manual operation: Select Channel (UARFCN) Parameters ( F12 on the Call Parms 1 of 3 menu), then select Band Arbitrator ( F9 ).

Related Topics

Channel (UARFCN) Parameters


Generator Information

Generator Information

Last updated: January 15, 2009

  • Downlink Channel Codes
  • Downlink Channel Levels
  • Connected DL Channel Levels
  • Generated Power Level Information (Generated Power Info Screen)
  • Downlink Code Channel Information (DL Code Channel Info Screen)
  • AWGN Power

The Generator Information screen allows you to set the test set's Downlink Channel Codes and Levels and AWGN Power .

It also displays the "current" power levels in use by the test set and the "desired" levels you've input, as explained below.

Generated Power Level Information

This section of the Generator Information screen displays the "current" and "desired" cell power, AWGN power and total power levels. To view this screen, you must select Generated Power Info Screen ( F1 ) from the Generator Information screen.

If you request an invalid combination of power levels, the test set posts a persistent error and places the settings you've requested in the Desired Level column. The set of levels in use by the test set does not change until you request a valid combination of levels. At that point, the values in the Current Level and Desired Level columns will match.

The following requirements determine if the combination of power levels is valid:

  • AWGN power must not be more than 10 dB above or 20 dB below cell power when both power states are set to ON.
  • The total RF power and amplitude offset must not set the source outside its valid hardware range (see Cell Power, AWGN Power and Total RF Power Ranges ).

To query the "desired" power levels, use the GPIB commands for setting/querying the levels (see Cell Power and AWGN Power ).

To query the "current" power levels, use the following commands:

  • Cell power level: CALL:STATus:CELL[1]:POWer[:AMPLitude]? , CALL:STATus:CELL2:POWer:STATe?
  • AWGN power level: CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude]([:SELected]|:FDD)?
  • Total power level: CALL:STATus:TOTal:POWer[:AMPLitude]?

Downlink Code Channel Information

This section of the Generator Information screen displays the Primary Scrambling Code and downlink channel codes currently in use by the test set, as well as the "current" and "desired" downlink code channel levels (including OCNS). To view this screen, you must select DL Code Channel Info Screen ( F1 ) from the Generator Information screen.

The relative power levels of the downlink code channels must add up to 100% of Cell Power (in the lab application, the relative power levels of the cell 2 downlink code channels must also add up to 100% of Cell 2 Power ). When any code channel level is changed, the test set adds the relative levels of the code channels for that cell, and calculates a composite OCNS level that allows all of the code channels to sum to 100% of the power in that cell. Note that even if a code channel is not currently being generated, if its state is On , its power level is included in the OCNS calculation.

If the composite OCNS cannot be set such that the summation is 100% (i.e. the sum of the relative levels of the code channels is greater than 100%), the set of levels you've requested is invalid. The test set then posts a persistent error and places the settings you've requested in the Desired Level column. The set of levels in use by the test set does not change until you request a valid combination of levels. At that point, the values in the Current Level and Desired Level columns will match.

The set of levels is also invalid if you set any code channel level to greater than 30 dB below the Total RF Power .

To query the "desired" downlink code channel levels, use the GPIB commands for setting/querying the levels (see Downlink Channel Levels and Connected DL Channel Levels ).

To query the "current" downlink code channel levels, use the following commands:

  • Current CPICH level: CALL:STATus:CPIChannel[:CELL[1]][:LEVel]? , CALL:STATus:CPIChannel:CELL2[:LEVel]?
  • Current P-CCPCH/SCH level: CALL:STATus:CCPChannel:PRIMary[:CELL[1]][:LEVel]? , CALL:STATus:CCPChannel:PRIMary:CELL2[:LEVel]?
  • Current S-CCPCH level: CALL:STATus:CCPChannel:SECondary[:CELL][:LEVel]?
  • Current PICH level: CALL:STATus:PICHannel[:CELL][:LEVel]?
  • Current AICH level: CALL:STATus:AICHannel[:CELL][:LEVel]?
  • Current DPCH level: CALL:STATus:DPCHannel[:LEVel]? , CALL:STATus:DPCHannel:CELL2[:LEVel]?
  • Current E-AGCH level: CALL:STATus:EAGChannel[:CELL][:LEVel]? ( lab application or feature-licensed test application only )
  • Current E-HICH level: CALL:STATus:EHIChannel[:CELL][:LEVel]? ( lab application or feature-licensed test application only )
  • Current E-RGCH level: CALL:STATus:ERGChannel[:CELL][:LEVel]? ( lab application or feature-licensed test application only )
  • Current HS-SCCH 1 level: CALL:STATus:HSSCchannel[1][:CELL][:LEVel]? ( lab application or feature-licensed test application only )
  • Current HS-SCCH 2 level: CALL:STATus:HSSCchannel2[:CELL][:LEVel]? ( lab application or feature-licensed test application only )
  • Current HS-SCCH 3 level: CALL:STATus:HSSCchannel3[:CELL][:LEVel]? ( lab application or feature-licensed test application only )
  • Current HS-SCCH 4 level: CALL:STATus:HSSCchannel4[:CELL][:LEVel]? ( lab application or feature-licensed test application only )
  • Current level of sum of active HS-PDSCHs: CALL:STATus:HSPDschannel[:CELL][:LEVel]? ( lab application or feature-licensed test application only )
  • Current OCNS: CALL:STATus:OCNSource[:CELL][:LEVel]([:SELected]|:FDD)? , CALL:STATus:OCNSource:CELL2[:LEVel]([:SELected]|:FDD)?

Related Topics

Manual Operation: How Do I Change Generator Information?


Single Channel GPS Source

Single Channel GPS Source

Last updated: March 24, 2009

This section is only applicable to the lab application or test application with the required feature license.

  • Description
  • GPS Parameters
  • How Do I Set up the GPS Feature?
  • Related Topics

Description

The Single Channel GPS Source function allows you to generate GPS signals to calibrate the GPS receiver of the mobile.

GPS system employs 37 satellites in orbit to provide positioning services. Satellite GPS signal has 3 components: L1 (1575.42MHz) / L2 (1227.60MHz) carrier signals, ranging codes and navigation message. Two kinds of ranging codes are defined: coarse/acquisition (C/A) code for normal positioning and precision (P) code for finer positioning purpose. The L1 is used to carry the C/A code with 1.023Mcps spreading rate, while L2 is usually used to carry the P code with 10.23Mcps spreading rate. For each satellite, a unique Space Vehicle Identifier (SV-ID) is assigned and will be used to determine the phase of spreading code for this specific satellite. The navigation messages usually contain positioning parameters.

Normally P code and L2 are only designed for military use, so the test set only simulates single satellite signal containing C/A code carried by L1 with default navigation messages, and pseudo random sequence data for the calibration of GPS receivers.

NOTE
The GPS feature is only available in the CW operating mode.

GPS Info

The following diagram shows the GPS parameter information.

  • GPS RF Generator Frequency:

    Since the test set only simulates single satellite signal containing C/A code carried by L1, the frequency is fixed at 1575.42MHz. It's a non-configurable parameter.

  • GPS Power:

    This parameter defines the cell power of GPS signal. The power range of GPS signal is -125dBm to -70dBm.

    NOTE
    The power range that you can set on the test set is affected when there is an Amplitude Offset.

  • GPS Satellite ID (SV ID):

    This setting defines which satellite is generating the GPS signal.

  • GPS Navigation Message Type:

    This setting defines the actual navigation message that will be transmitted on GPS frame. If Default Navigation is selected, the GPS frames is filled with the default navigation message defined in the GPS standard. If Raw is selected, the GPS frames is filled with PN sequence.

  • GPS Raw Payload Pattern:

    This setting defines the data type that will be transmitted on GPS frames when Raw data payload is selected. You can select PN9 or PN15.

  • GPS Baseband Filter Type:

    This setting defines the filter that will be used to filter the GPS baseband signal when the GPS signal is generated. A Gaussian or Rectangle filter with 10 MHz bandwidth is supported in this feature.

GPS Parameters

The following table lists all the configurable GPS parameters.

Parameter | GPIB Command
RF Gen Configure | CALL[:CELL]:RFGenerator:CONFigure
GPS Power | CALL[:CELL]:RFGenerator:GPS:POWer:AMPLitude
GPS Power State | CALL[:CELL]:RFGenerator:GPS:POWer:STATe
GPS Power & State | CALL[:CELL]:RFGenerator:GPS:POWer[:SAMPLitude]
GPS Satellite ID (SV ID) | CALL[:CELL]:RFGenerator:GPS:SVID
GPS Navigation Message Type | CALL[:CELL]:RFGenerator:GPS:NMESsage
GPS Raw Payload Pattern | CALL[:CELL]:RFGenerator:GPS:RAW:PPATtern
GPS Baseband Filter Type | CALL[:CELL]:RFGenerator:GPS:BFILter
GPS RF Generator Frequency | CALL[:CELL]:RFGenerator:GPS:FREQuency2?
GPS RF Generator Frequency 2 | CALL[:CELL]:RFGenerator:GPS:FREQuency2?

How Do I Set up the GPS Feature?

The following procedure details how to access the GPS feature.

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select CW .
  3. Press RF Gen Configure ( F10 ) from the Control Parms menu, then select GPS menu.
  4. Press GPS Parameters ( F9 ), Use the knob to highlight the parameter and change the value.

Related Topics

CW Operating Mode


HSDPA Concepts

HSDPA Concepts

Last updated: January 7, 2012

This section is only applicable to the lab application or feature-licensed test application.

  • HSDPA Transport and Physical Channels
  • MAC-hs
  • UE Categories
  • UE IR Memory
  • 3GPP Specification References

HSDPA Transport and Physical Channels

High Speed Downlink Packet Access (HSDPA) is a Release 5 feature of 3GPP that adds higher speed downlink data rates specifically for packet switched services. It does this by adding a new type of transport channel, the High Speed Downlink Shared Channel (HS-DSCH) that utilizes techniques such as adaptive modulation and hybrid ARQ to achieve high throughput.

The HS-DSCH transport channel is mapped onto one or more High Speed Physical Downlink Shared Channels (HS-PDSCHs) depending on the instantaneous data rate. The HS-PDSCHs operate on a 2ms sub-frame rather than the standard 10ms W-CDMA frame and have a fixed spreading factor of 16. The modulation format used on the HS-PDSCH can either be QPSK or the higher capacity 16QAM. One of the features of HSDPA is that the network can vary the number and modulation format of the HS-PDSCHs that are used for a particular UE on a subframe by subframe basis.

UEs in a cell share the same set of HS-PDSCHs, so a companion set of High Speed Shared Control Channels (HS-SCCHs) are used to indicate which UE should read which HS-PDSCH during a particular 2ms subframe. On call establishment each UE is assigned a unique identifier called the H-RNTI and a set of HS-SCCHs to monitor. Whenever the network wishes to send the UE some data it will code up the HS-SCCH using that UE's identity and the necessary information for the UE to be able to decode the HS-PDSCHs (for example, number of HS-PDSCHs, their channelization codes, the HARQ process number, etc.).

On the uplink the UE transmits an HS-DPCCH channel that is used to convey ACKS/NACKS and channel quality information to the MAC-hs layer in the network.

MAC-hs

Whenever an HS-DSCH block is transmitted to a UE, the UE's L1 will attempt to decode it and will pass the result to a Hybrid ARQ (HARQ) process that is running in the MAC-hs layer. Depending on whether the block was received correctly or not, the UE's HARQ process will tell its L1 to transmit an ACK or NACK on the uplink HS-DPCCH channel. The UE may also include information about the channel in the Channel Quality Indicator field in the HS-DPCCH.

A peer HARQ process in the network uses the HS-DPCCH data to decide whether to retransmit the same block or send the next block in the transmit queue. There are between 1 and 8 HARQ processes running in parallel on any given UE connection.

The MAC-hs HARQ processes in the network also control which Redundancy Version (RV) is used by L1 when a block is transmitted. The RV parameter controls exactly which bits are transmitted to the UE (the systematic bits vs. the convolutionally coded bits) and, for the 16QAM modulation, which symbols are mapped to which modulation points. By selecting a different RV each time a block is retransmitted, the network increases the chances that the turbo decoder in the UE will be able to recover the original block. Alternatively the network can use the same RV for each retransmission and the UE will use chase combining on the received bits to increase the likelihood of receiving the block correctly.

MAC-hs does not guarantee transmission of a block, so once a block has been retransmitted the maximum number of times, the network will move onto the next block in the transmit queue even if the last transmission was NACK'ed by the UE. If this happens the higher level RLC layer is used to recover or skip over the lost block.

The MAC-hs layer in a real network dynamically adjusts the data rate going to a particular UE based on the amount of data waiting to be transmitted to it and the RF conditions that UE is experiencing. The amount of data transmitted to a UE during a particular subframe is defined by the choice of modulation scheme, number of HS-PDSCHs used and a transport block size index known as the Transport Format and Resource Indicator (TFRI) value, all of which are signaled on the HS-SCCH. From these elements the UE can compute the HS-DSCH transport block size that it has been sent (unlike regular DCHs only a single transport block can be transmitted during a TTI on an HS-DSCH).

To aid the network in block size selection the UE transmits a CQI (Channel Quality Indicator) on the uplink HS-DPCCH that tells the network how much data it can receive. The CQI indicates the modulation format, number of HS-PDSCHs and block size that the UE could have received during the previous 2ms subframe with a 90% chance of success. The 3GPP standards do not define how the CQI information shall be used; similar to handovers, each network is free to implement their own algorithm. The simplest algorithm would be to simply use the reported CQI as the next TFRI on the downlink.

UE Categories

HSDPA allows a very wide range of data rates. To give UE manufacturers some flexibility over how much functionality they choose to put in their device, 3GPP TS 25.306 Table 5.1a defines a set of HSDPA UE Categories that restrict those data rates by specifying attributes such as the minimum inter-TTI value that a UE can support, the maximum number of HS-PDSCHs it can receive, the size of its Incremental Redundancy memory, etc. A network must ensure that it respects a UE's capabilities when transmitting to it.

UE IR Memory

One of the parameters defined for each UE category is the size of its Incremental Redundancy memory. Each HARQ process has exclusive use of a portion of the IR memory. As data is received on the HS-PDSCH it is written into the IR memory associated with the target HARQ process. Subsequent transmissions of a block are added to IR buffer until the block is successfully decoded or the network transmits a new block (which is indicated by setting the New Data Indicator on the HS-SCCH). Using signaling messages the network can tell the UE to either equally divide the available IR memory across all HARQ processes or it can allocate specific amounts of memory to each process.

3GPP Specification References

As HSDPA works alongside existing W-CDMA functionality, 3GPP largely defined it by augmenting existing specifications. The only stand-alone HSDPA specification is 25.308 - HSDPA Overall Description. In Layer 1 the most useful specifications with HSDPA content are:

25.211 - Physical Channels & Transport Channel Mapping (definition of HS-PDSCH and HS-DSCH)

25.212 - Multiplexing and Channel Coding (describes HS-DSCH channel coding)

25.214 - Physical Layer Procedures (describes HS-DSCH procedures, including CQI reporting)

25.306 - UE Radio Access Capabilities (includes HSDPA UE Category definitions)

In the upper layers HSDPA content is largely concentrated in 25.321 - MAC Protocol Specification (which describes the MAC-hs layer) and 25.331 - Radio Resource Control Protocol Specification.

Related Topics

W-CDMA Concepts


HSDPA Information

HSDPA Information

Last updated: January 4, 2012

This section is only applicable to the lab application or feature-licensed test application.

These results are cleared by the Clear UE Info action.

UE Reported HS-DSCH Category

This result contains the UE HS-DSCH Physical Layer Category reported by the UE in the Physical Channel Capability IE in the RRC Connection Setup Complete message. If the UE did not report a category, then the result is 9.91E+37 (----).

GPIB command: CALL:HSDPa:MS:REPorted:HSDSchannel:CATegory?

Current UE HS-DSCH Category

This result contains the UE category currently in use by the test set. For examples of how the test set uses the Current UE HS-DSCH Category , see HSDPA Packet Switched Data and User Defined Configuration of the HS-DSCH .

If UE HS-DSCH Category Control is set to Auto and the category reported by the UE is valid (1-14, 17 or 18, 21-24), the Current UE HS-DSCH Category is equal to the UE Reported HS-DSCH Category .

Otherwise, the Current UE HS-DSCH Category indicates the Manual UE HS-DSCH Category setting.

The UE categories are defined in 3GPP TS 25.306 Table 5.1a.

GPIB command: CALL:STATus:MS:HSDSchannel:CATegory?

HSDPA Counters

The HSDPA Information window displays counters to help you monitor the HSDPA connection status. The results are continually updated until one of the following occurs:

  • You press the MEASUREMENT RESET key ( SYSTem:MEASurement:RESet ).
  • You select Clear UE Info ( CALL:MS:REPorted:CLEar[:ALL]<[:SELected]|:WCDMa> ).
  • You change operating mode.
  • You establish a new connection in active cell operating mode (or change the Channel Type from 12.2k RMC + HSDPA in FDD Test Operating Mode ).
  • Blocks Transferred reaches 150,000.

When one of these events occurs, the counters reset to zero and then resume counting.

The HSDPA counters provide similar results to the HSDPA BLER measurement (see HSDPA Block Error Ratio Measurement Description ). However, note that because they are being calculated for a different set of blocks (the HSDPA counters are typically calculated over a much greater number of blocks), the results will often vary.

  • Block Error Ratio

    This result reports the block error ratio of the HSDPA connection.

    3GPP TS 34.121 F.6.3.2 defines the HSDPA block error ratio as:

    GPIB command: CALL:HSDPa:MS:REPorted:HBLerror:RATio?

  • Throughput

    This result reports the data throughput of the HSDPA connection. 3GPP TS 34.121 F.6.3.1 defines Information Bit Throughput R as "the sum (in kilobits) of the information bit payloads (excluding the 24-bit HS-DSCH CRC) successfully received during the test interval, divided by the duration of the test interval (in seconds)."

    Each time the test set receives an ACK from the UE, it increments a counter called "totalBits" by the size of the data block (in bits) that was positively acknowledged. Each time the test set does not transmit a block in a TTI it increments a counter called regDTX.

    Throughput (in kbps) is then calculated as follows:

    GPIB command: CALL:HSDPa:MS:REPorted:IBTHroughput?

  • Blocks Transferred

    This result counts how many blocks have been transmitted to the UE. It is incremented by one every time a data block is transmitted on the HS-PDSCHs. A transmission of a new block of data or retransmission of an old block of data both count as a block transmission. When Blocks Transferred reaches 150,000, all of the HSDPA counters are reset.

    GPIB command: CALL:HSDPa:MS:REPorted:BLOCks?

  • ACKs Received

    This result counts how many ACKs have been received on the uplink HS-DPCCH since the counters were reset.

    GPIB command: CALL:HSDPa:MS:REPorted:ACK?

  • NACKs Received

    This result counts how many NACKs have been received on the uplink HS-DPCCH since the counters were reset.

    GPIB command: CALL:HSDPa:MS:REPorted:NACK?

  • statDTXs Received

    This result counts how many statDTXs have been received on the uplink HS-DPCCH since the counters were reset.

    GPIB command: CALL:HSDPa:MS:REPorted:SDTX?

Current Test Mode Transport Block Size

This result represents the (MAC-hs) transport block size currently in use by the test set, which, as defined in 3GPP TS 25.321 s9.2.3.1 is affected by the User Defined Number of Active HS-PDSCHs , User Defined Transport Block Size Index , and User Defined Modulation Type settings.

GPIB command: CALL:STATus:HSDSchannel:TBSize?

Current PS Data Transport Block Size

This result represents the current (MAC-hs) transport block size currently in use by the test set, which, as defined in 3GPP TS 25.321 s9.2.3.1 is affected by the PS Data User Defined Active HS-PDSCHs , PS Data User Def Transport Block Size Index , and PS Data User Defined Modulation Type settings.

GPIB command: CALL:STATus:HSDSchannel:TBSize:PSData?

Last Signaled Measurement Power Offset

This result represents the most recent Measurement Power Offset (see Meas Pow Offset ) that was signaled to the UE during a call setup or a part of a Transport Channel Reconfiguration procedure.

GPIB command: CALL:STATus:MPOWer:OFFSet:SIGNaled?

Manual Operation

To access the HSDPA Information from the front panel, press the left More key until you reach the Call Control 2 of 5 menu, select Additional Screens ( F1 ), then HSPA Information ( F2 ). Some of the HSDPA Information results are also available on the main Call Setup Screen .

Related Topics

HSDPA Parameters


HSDPA Parameters

HSDPA Parameters

Last updated: December 31, 2011

This section is only applicable to the lab application or feature-licensed test application.

  • HSDPA PS Data Setup ( lab application only )
  • HSDPA RB Test Mode Settings
  • HSDPA Pattern Parameters
  • UE Category Parameters
  • MAC-hs Parameters
  • MAC-ehs Parameters
  • HSDPA Uplink Parameters
  • Measurement Power Offset ( lab application only )
  • H-RNTI Parameters

UE Category Parameters

  • UE HS-DSCH Category Control

    If UE HS-DSCH Category Control is set to Auto , the UE category in use by the test set ( Current UE HS-DSCH Category ), is equal to the UE Reported HS-DSCH Category if the category reported by the UE is valid. Otherwise, if the UE reported an invalid category or did not report a category, the Current UE HS-DSCH Category is equal to the Manual UE HS-DSCH Category setting.

    If UE HS-DSCH Category Control is set to Manual , the UE category in use by the test set ( Current UE HS-DSCH Category ), is equal to the Manual UE HS-DSCH Category setting.

    GPIB command: CALL:HSDPa:MS:HSDSchannel:CATegory:CONTrol:AUTO

    This parameter can only be set when the data/call status is Idle .

  • Manual UE HS-DSCH Category

    This setting determines the UE category in use by the test set ( Current UE HS-DSCH Category ) when UE HS-DSCH Category Control is set to Manual or if the UE Reported HS-DSCH Category is invalid.

    GPIB command: CALL:HSDPa:MS:HSDSchannel:CATegory:MANual

    This parameter can only be set when the data/call status is Idle .

  • Manual UE DC-HSDPA HS-DSCH Category

    This parameter is only used when DC-HSDPA is active. You can set HS-DSCH category for DC-HSDPA capable UEs when UE HS-DSCH Category Control is set to Manual or if the UE Reported HS-DSCH Category is invalid.

    GPIB command: CALL:HSDPa:MS:HSDSchannel:CATegory:DCHSdpa:MANual

The UE category currently in use by the test set is reported by the Current UE HS-DSCH Category result.

MAC-hs Parameters

The test set schedules new blocks and retransmissions based on the acknowledge/negative acknowledge (ACK/NACK) information on the uplink HS-DPCCH. If a NACK is received and the block has not been transmitted more than the Number of Transmissions setting allows (and if the TSN to be transmitted is within the transmit window, see MAC-hs Window Size ), the HARQ process retransmits the block using the next redundancy version (RV) from the RV Sequence list. If a NACK is received and the block has been retransmitted the maximum number of allowed times (or if the TSN lies outside the transmit window), or if an ACK is received, the MAC-hs layer transmits a new block using the first RV in the list. If the expected HS-DPCCH transmission is not received on the uplink at the appropriate time, the test set reacts according to the statDTX Reception Behavior setting. The test set records the number of ACKs, NACKs, and statDTXs and displays them in the HSDPA Information window and reports them to the HSDPA BLER measurement (see HSDPA Block Error Ratio Measurement Description ).

  • Number of Transmissions

    The number of times a MAC-hs HARQ process will attempt to transmit a particular data block (one to eight).

    GPIB command: CALL:HSDPa:MACHs:NTRans

  • RV Sequence

    As described in 3GPP TS 25.212, the RV parameter controls exactly which bits are transmitted to the UE (i.e. the systematic bits versus the convolutionally coded bits) and for 16QAM modulation, which symbols are mapped to which modulation points. By selecting a different RV each time a block is retransmitted, the network increases the chance that the turbo decoder in the UE will be able to recover the original block. Alternatively, the network can use the same RV for each retransmission and the UE uses chase combining on the received bits to increase the likelihood of receiving the block correctly.

    The RV Sequence setting indicates the sequence of RV parameters to be used by the test set for block transmissions. You may specify up to eight integer values (between zero and seven), but the number of RV parameters actually used by the test set is determined by the Number of Transmissions setting (the RV parameters at the end of the sequence are not used if the Number of Transmissions setting is less than the number of RV parameters in the sequence). If you enter fewer than eight values for the RV sequence, the test set fills the remaining values with zeroes. The default RV sequence matches 3GPP TS 34.121 s9.2.1.

    GPIB command: CALL:HSDPa:MACHs:RVSequence

  • MAC-hs Window Size

    MAC-hs Window Size can be set to 4, 6, 8, 12, 16, 24, or 32. In accordance with 3GPP TS 25.321 11.6.2.3.2, the test set will not retransmit a block with a TSN that is outside the transmit window. This parameter sets both the MAC-hs transmit and receive window sizes.

    GPIB command: CALL:HSDPa:MPOWer:OFFSet:MANual

    This parameter can only be set when the data/call status is Idle .

  • MAC-hs T1

    This parameter controls the value of the MAC-hs T1 timer that is signaled to the UE in the Radio Bearer Setup message. 3GPP TS 25.331 s10.3.5.1a defines T1 as "Timer (in milliseconds) when PDUs are released to the upper layers even though there are outstanding PDUs with lower TSN values."

    The behavior of T1 (the "re-ordering release timer") is defined in 3GPP TS 25.321 s11.6.2.3.

    GPIB command: CALL:HSDPa:MACHs:T1

    This parameter can only be set when the data/call status is Idle .

  • statDTX Reception Behavior

    You can configure how the test set responds to a statDTX from the UE (the options are as defined in 3GPP TS 34.121 Table 9.2.1.2).

    • Handle as ACK

      When statDTX Reception Behavior is set to Handle as ACK , when a statDTX occurs, the test set transmits a new block from the MAC-hs transmit queue using the first entry in the RV Sequence and resets the transmission counter to one.

      Note, if you would like the test set to continuously transmit a stream of new (PRBS) data regardless of the uplink HS-DPCCH presence (to allow you to measure BER in an external program, for example), set statDTX Reception Behavior to Handle as ACK , set Number of Transmissions to 1 , FDD Test "HS-DSCH Data Pattern" to CCITT PRBS15 or CCITT PRBS9 , and MAC-hs Header to Data .

    • Handle as NACK

      When statDTX Reception Behavior is set to Handle as NACK , when a statDTX occurs, if the transmission counter is less than the Number of Transmissions setting, the test set transmits the same block using the next entry in the RV Sequence and increments the transmission counter by one. If the transmission counter equals the Number of Transmissions setting, then the Handle as ACK process is followed instead.

    • Handle as statDTX

      When statDTX Reception Behavior is set to Handle as statDTX , when a statDTX occurs, the test set transmits the same block using the same entry in the RV Sequence and does not increment the transmission counter.

      Note that when statDTX Reception Behavior is set to Handle as statDTX , if the UE never transmits an ACK or NACK, the test set will continuously transmit the same block (even if you change HS-DSCH Data Pattern ).

    GPIB command: CALL:HSDPa:MACHs:SDTX:RBEHavior

MAC-ehs Parameters

  • MAC-ehs Segmentation Strategy

    This setting specifies the segmentation strategy at the MAC-ehs layer in Active Cell mode.

    The following settings are available:

    • Standard : Segmentation at the MAC-ehs layer is done as required to fit as many re-ordering SDUs as possible into the MAC-ehs PDU.
    • Minimum : Segmentation at the MAC-ehs is avoided as much as possible. The test set fits as many re-ordering SDUs as possible into the MAC-ehs PDU. Each of the SDUs contains only a single complete MAC-d PDU. However, if the MAC-ehs PDU size is smaller than the MAC-d PDU size, segmentation is performed.

    This parameter can only be set when call status is Idle .

    GPIB Command: CALL:HSDPa:MACEHS:SEGMentation

Secondary Serving Cell Parameters

  • Secondary Serving Cell Power

    The parameter Secondary Serving Cell Power State sets the state of the secondary serving cell power. This parameter only affects the power of the DC-HSDPA secondary serving cell while a DC-HSDPA call is established, it does not affect whether the UE is told to enable DC-HSDPA or not. When the Secondary Serving Cell Power State is set to ON, the parameter Secondary Serving Cell Power sets the absolute power of the secondary serving cell.

    GPIB Command: CALL:SSCell:POWer[:SAMPLitude]

  • Secondary Serving Cell Downlink UARFCN

    This parameter sets the downlink UARFCN of the secondary serving cell which must be adjacent to the serving cell.

    GPIB Command: CALL:SSCell:CHANnel:ADJacent

    This parameter can only be set while the call status is Idle .

  • Secondary Serving Cell Primary Scrambling Code

    The actual code number for the primary scrambling code is 16 times the value of this setting.

    GPIB Command: CALL:SSCell:SCODe[:PRIMary]

    This setting is only available in the lab application.

Measurement Power Offset

  • Meas Pow Offset

    This setting is the difference in power levels of the CPICH and HS-PDSCH channels. The UE assumes this value to be the power level that the test set uses when transmitting the HS-PDSCHs, and therefore uses this parameter in its HSDPA CQI measurement algorithm.

    The Meas Power Offset ,Gamma (defined in 3GPP TS 25.214 s6A.2), that is used by the UE is signaled at call setup and remains unchanged unless a Transport Channel Reconfiguration procedure is performed.

    The parameters that are used to calculate the Meas Power Offset if its control state is set to Auto depend on the service type (see Current Service Type ).

    • If the service type is either Radio Bearer Test Mode - HSDPA or Packet Switched Data - HSDPA, then the automatic value for the Meas Power Offset is the difference of HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) minus HSDPA Cell 1 Connected CPICH Level . Note: If either of the two parameters used in the calculation of the Meas Power Offset is set to Off , then the test set uses a value of -20 dB for the corresponding parameter.

    • If the service type is either Radio Bearer Test Mode - HSPA or Packet Switched Data - HSPA, then the automatic value for the Meas Power Offset is the difference of HSPA Cell 1 Connected HS-PDSCHs Level (Sum) minus HSPA Cell 1 Connected CPICH Level . Note: If either of the two parameters used in the calculation of the Meas Power Offset is set to Off , then the test set uses a value of -20 dB for the corresponding parameter.

    GPIB Command: CALL:HSDPa:MPOWer[:MOFFset]

    This parameter can only be set while the call status is Idle .

    This setting is only available in the lab application. (In the test application the measurement power offset is set to -6 dB.)

H-RNTI Parameters

  • Primary H-RNTI (Hex)

    Identifier used by the test set to transmit to the UE under test. The test set only transmits to the UE under test on HS-SCCH 1.

    GPIB command: CALL:HSDPa:HRNTi[:PRIMary]

    This parameter can only be set when call status is Idle .

  • Alternate H-RNTI (Hex)

    During TTIs where data is not transmitted to the UE under test (when inter-TTI is greater than one), the test set transmits dummy data on HS-SCCH 1 using the Alternate H-RNTI. The content of the HS-SCCH 1 when the Alternative H-RNTI is in use is the same as the data that was used the last time the Primary H-RNTI (Hex) was used.

    HS-SCCH 2-4, when turned on, are always transmitted using the Alternate H-RNTI . The content of HS-SCCH 2-4 is fixed as follows:

    • Code set: 0b1101110
    • Modulation scheme: 0b0
    • Transport block size: 0b010010
    • HARQ process information: 0b101
    • RV information: 0b111
    • New data: 0b0

    When not transmitting data to the UE under test, the test set sends a fixed pattern of uncoded PRBS data on the HS-PDSCHs. The number of HS-PDSCHs transmitted is the same as the number of HS-PDSCHs transmitted during the last subframe that contained data directed to the UE under test.

    GPIB command: CALL:HSDPa:HRNTi:ALTernate

    This parameter can only be set when call status is Idle .

  • HS-SCCH1 Alternate H-RNTI (Hex)

    This parameter controls the alternate H-RNTI that is used on the HS-SCCH 1. The test set use this parameter in Active Cell when it wishes to indicate that the HS-SCCH1 is not for the UE under test.

    This parameter can not be set to be same as Primary H-RNTI (Hex) or Secondary Serving Cell H-RNTI (Hex) .

    GPIB command: CALL:HSDPa:HRNTi:ALTernate:HSSCCH1

    This parameter can only be set when call status is Idle .

  • HS-SCCH2 Alternate H-RNTI (Hex)

    This parameter controls the alternate H-RNTI that is used on the HS-SCCH2. The test set use this parameter in Active Cell when it wishes to indicate that the HS-SCCH2 is not for the UE under test.

    This parameter can not be set to be same with Primary H-RNTI (Hex) or Secondary Serving Cell H-RNTI (Hex) .

    GPIB command: CALL:HSDPa:HRNTi:ALTernate:HSSCCH2

    This parameter can only be set when call status is Idle .

  • HS-SCCH3 Alternate H-RNTI (Hex)

    This parameter controls the alternate H-RNTI that is used on the HS-SCCH3. The test set use this parameter in Active Cell when it wishes to indicate that the HS-SCCH3is not for the UE under test.

    This parameter can not be set to be same with Primary H-RNTI (Hex) or Secondary Serving Cell H-RNTI (Hex) .

    GPIB command: CALL:HSDPa:HRNTi:ALTernate:HSSCCH3

    This parameter can only be set when call status is Idle .

  • HS-SCCH4 Alternate H-RNTI (Hex)

    This parameter controls the alternate H-RNTI that is used on the HS-SCCH4. The test set use this parameter in Active Cell when it wishes to indicate that the HS-SCCH4 is not for the UE under test.

    This parameter can not be set to be same with Primary H-RNTI (Hex) or Secondary Serving Cell H-RNTI (Hex) .

    GPIB command: CALL:HSDPa:HRNTi:ALTernate:HSSCCH4

    This parameter can only be set when call status is Idle .

  • Secondary Serving Cell H-RNTI (Hex)

    Controls the primary H-RNTI of the secondary serving cell.

    The Primary H-RNTI cannot be the same as the Alternate H-RNTI. If you attempt to set this parameter to a value that is same with any FDD Test Mode HS-SCCH Alternate H-RNTI; i.e. HS-SCCH1 Alternate H-RNTI (Hex) , HS-SCCH2 Alternate H-RNTI (Hex) , HS-SCCH3 Alternate H-RNTI (Hex) and HS-SCCH4 Alternate H-RNTI (Hex) , the attempt will be rejected.

    GPIB command: CALL:HSDPa:SSCell:HRNTi

    This parameter can only be set when call status is Idle .

Related Topics

Manual Operation: How Do I Change HSDPA Parameters?

HSDPA in Active Cell Operating Mode

HSDPA in FDD Test Operating Mode

HSDPA/HSPA DL Channel Codes

HSDPA Connected DL Channel Levels


HSDPA PS Data Setup

HSDPA PS Data Setup

Last updated: January 8, 2012

This section is only applicable to the lab application.

  • HSDPA PS Data Parameters
  • Serving Cell Parameters
  • Secondary Serving Cell Parameters

HSDPA PS Data Parameters

  • PS Data Configuration Type

    This parameter controls how the HS-DSCH is configured. There are three settings:

    • CQI Value

      This setting uses the value assigned to CQI Value (separate parameter) along with the Current UE HS-DSCH Category to automatically configure the HS-DSCH based on tables defined in 3GPP TS 25.214. In order for the test set to accept this setting, the MAC-hs block size must be large enough to carry at least a single MAC-d PDU.

    • Reported CQI

      This setting is similar to the CQI Value setting except that the test set uses the UE reported CQI values received on the HS-DPCCH channel rather than the assigned CQI Value .

      The test set continually adjusts the HS-DSCH configuration to match the CQI table in 3GPP TS 25.214 that corresponds to the Current UE HS-DSCH Category. If the test set has not yet received a CQI report from the UE, it uses a CQI value of 8 to configure the HS-DSCH each time a call is connected. Note: The test set cannot receive CQI reports if the CQI Feedback Cycle (k) is set to zero.

      The test set ensures that the MAC-hs block size is large enough to contain at least one MAC-d PDU. Therefore, the smallest CQI value the test set uses for a 336 bit MAC-d PDUs is 5 and the smallest CQI value the test set uses for 656 bit MAC-d PDUs is 8 regardless of whether the UE reports smaller CQI values.

    • User Defined

      When this setting is selected, the test set applies the user defined PS data parameters ( PS Data User Defined Active HS-PDSCHs , PS Data User Def Transport Block Size Index , and PS Data User Defined Modulation Type ) rather than automatically configuring them as is done when the PS Data Configuration Type is set to CQI Value or Reported CQI . In order for the test set to accept this setting, the MAC-hs block size must be large enough to carry at least a single MAC-d PDU

    GPIB command: CALL:HSDPa:SERVice:PSData:HSDSchannel:CONFig[:TYPE]

  • CQI Value

    This parameter is only applicable when the PS Data Configuration Type is set to CQI Value . The test set supports an HSDPA packet data connection as defined by 3GPP TS 34.108 6.10.2.4.5.1 (see GPRS Radio Access Bearer ). You must specify some aspects of the channel configuration by specifying a CQI Value .

    Based on the CQI Value setting and the Current UE HS-DSCH Category , the test set sets the MAC-hs transport block size, number of HS-PDSCHs, modulation type and IR buffer size (N IR ) to the values in 3GPP TS 25.214 s6A.2 Tables 7A-E. The test set uses the Current UE HS-DSCH Category to set the inter-TTI interval, number of HARQ processes, and IR buffer size (N IR ) as described in GPRS Radio Access Bearer .

    CQI Value cannot be set to 7 or less if PS Data HS-DSCH MAC-d PDU Size is set to 656 bits (because doing so would cause the MAC-hs transport block size to be too small to carry even a single MAC-d PDU). The number of HS-PDSCHs specified by the CQI Value , when added to the PS Data First HS-PDSCH Channel Code cannot exceed 15 (otherwise the HS-PDSCHs would collide with the downlink OCNS channels).

    Note that when you select a CQI Value that is defined by 3GPP TS 25.214 to have a non-zero "Reference power adjustment", the test set decreases the power present in the HS-PDSCHs accordingly (as expected, throughput no longer increases once you pass this point in the CQI table; rather, throughput decreases as HS-PDSCH power decreases). This change in power is reflected in the Conn Desired column of the Downlink Code Channel Information screen. For example, for a category 12 UE, if you set CQI Value to 18 , the power in the HS-PDSCHs is reduced from the HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) setting of -3 dB to -6 dB.

    CQI Value can be set between 5 and 30. The following table, MAC-hs and IP Bit Rates (kbps) versus CQI Value and UE Category , summarizes the MAC-hs and IP bit rates achieved for each CQI Value , based on UE category.

    The MAC-hs bit rate is determined by multiplying the MAC-hs block size by the number of MAC-hs blocks transmitted per second. If inter-TTI interval * number of HARQ processes < 6, the number of MAC-hs blocks transmitted in 12 ms is equal to the number of HARQ processes, and the following formula applies:

    MAC-hs bit rate = (MAC-hs block size in bits)*(number of HARQ processes)/12 ms

    The maximum theoretical IP bit rate is determined by multiplying the number of IP bits delivered in each MAC-hs block by the number of MAC-hs blocks transmitted per second. If inter-TTI interval * number of HARQ processes < 6, then the following formula applies:

    IP bit rate = FLOOR[((MAC-hs block size in bits) - (21 MAC-hs header bits))/(MAC-d PDU Size)]*(MAC-d PDU Size - 16 header bits)*(number of HARQ processes)/12 ms

    Note that although the bit rates are equal between categories 1/2, 3/4, and 5/6, due to the larger IR buffer size of categories 2, 4 and 6, in a network these categories may realize higher actual data rates.

    MAC-hs and IP Bit Rates (kbps) versus CQI Value and UE Category

    UE Category

            1, 2 3, 4 5, 6 7, 8 9, 13, 17 (64QAM/MIMO not configured) 10, 14, 18 (64QAM/MIMO not configured) 11 12 13, 17 (64QAM configured) 14, 18 (64QAM configured)
    CQI Value MAC-hs (kbps) IP (kbps) MAC-hs (kbps) IP (kbps) MAC-hs (kbps) IP (kbps) MAC-hs (kbps) IP (kbps)
    MAC-d
    PDU Size = 336 bits     		IP (kbps)
    MAC-d
    PDU Size = 656 bits     		MAC-hs (kbps) IP (kbps)
    MAC-d
    PDU Size = 336 bits     		IP (kbps)
    MAC-d
    PDU Size = 656 bits     		MAC-hs (kbps) IP (kbps)
    MAC-d
    PDU Size = 336 bits     		IP (kbps)
    MAC-d
    PDU Size = 656 bits     		MAC-hs (kbps) IP (kbps) MAC-hs (kbps) IP (kbps) MAC-hs (kbps) IP (kbps)
    MAC-d
    PDU Size = 336 bits     		IP (kbps)
    MAC-d
    PDU Size = 656 bits     		MAC-hs (kbps) IP (kbps)
    MAC-d
    PDU Size = 336 bits     		IP (kbps)
    MAC-d
    PDU Size = 656 bits
    5 | 63 | 53 | 94 | 80 | 189 | 160 | 189 | 160 | N/A | 189 | 160 | N/A | 189 | 160 | N/A | 94 | 80 | 189 | 160 | 188 | 160 | N/A | 188 | 160 | N/A
    6 | 77 | 53 | 115 | 80 | 231 | 160 | 231 | 160 | N/A | 231 | 160 | N/A | 231 | 160 | N/A | 115 | 80 | 231 | 160 | 232 | 160 | N/A | 232 | 160 | N/A
    7 | 108 | 53 | 163 | 80 | 325 | 160 | 325 | 160 | N/A | 325 | 160 | N/A | 325 | 160 | N/A | 163 | 80 | 325 | 160 | 324 | 160 | N/A | 324 | 160 | N/A
    8 | 132 | 107 | 198 | 160 | 396 | 320 | 396 | 320 | 320 | 396 | 320 | 320 | 396 | 320 | 320 | 198 | 160 | 396 | 320 | 396 | 320 | 320 | 396 | 320 | 320
    9 | 155 | 107 | 233 | 160 | 466 | 320 | 466 | 320 | 320 | 466 | 320 | 320 | 466 | 320 | 320 | 233 | 160 | 466 | 320 | 464 | 320 | 320 | 464 | 320 | 320
    10 | 210 | 160 | 316 | 240 | 631 | 480 | 631 | 480 | 320 | 631 | 480 | 320 | 631 | 480 | 320 | 316 | 240 | 631 | 480 | 632 | 480 | 320 | 632 | 480 | 320
    11 | 247 | 213 | 371 | 320 | 742 | 640 | 742 | 640 | 640 | 742 | 640 | 640 | 742 | 640 | 640 | 371 | 320 | 742 | 640 | 744 | 640 | 640 | 744 | 640 | 640
    12 | 290 | 267 | 436 | 400 | 871 | 800 | 871 | 800 | 640 | 871 | 800 | 640 | 871 | 800 | 640 | 436 | 400 | 871 | 800 | 872 | 800 | 640 | 872 | 800 | 640
    13 | 380 | 320 | 570 | 480 | 1140 | 960 | 1140 | 960 | 960 | 1140 | 960 | 960 | 1140 | 960 | 960 | 570 | 480 | 1140 | 960 | 1144 | 960 | 960 | 1144 | 960 | 960
    14 | 431 | 373 | 646 | 560 | 1292 | 1120 | 1292 | 1120 | 960 | 1292 | 1120 | 960 | 1292 | 1120 | 960 | 646 | 560 | 1292 | 1120 | 1296 | 1120 | 960 | 1296 | 1120 | 960
    15 | 553 | 480 | 830 | 720 | 1660 | 1440 | 1660 | 1440 | 1600 | 1660 | 1440 | 1600 | 1660 | 1440 | 1600 | 830 | 720 | 1660 | 1440 | 1664 | 1440 | 1600 | 1664 | 1440 | 1600
    16 594 533 891 800 1783 1600 1783 1600 1600 1783

    1600

            1600 1783 1600 1600 830 * 720 * 1660 * 1440 * 1788 1600 1600 1788 1600 1600
    17 | 698 | 640 | 1047 | 960 | 2095 | 1920 | 2095 | 1920 | 1920 | 2095 | 1920 | 1920 | 2095 | 1920 | 1920 | 830 * | 720 * | 1660 * | 1440 * | 2100 | 1920 | 1920 | 2100 | 1920 | 1920
    18 | 777 | 693 | 1166 | 1040 | 2332 | 2080 | 2332 | 2080 | 2240 | 2332 | 2080 | 2240 | 2332 | 2080 | 2240 | 830 * | 720 * | 1660 * | 1440 * | 2336 | 2080 | 2240 | 2336 | 2080 | 2240
    19 | 881 | 800 | 1322 | 1200 | 2644 | 2400 | 2644 | 2400 | 2560 | 2644 | 2400 | 2560 | 2644 | 2400 | 2560 | 830 * | 720 * | 1660 * | 1440 * | 2648 | 2400 | 2560 | 2648 | 2400 | 2560
    20 | 981 | 907 | 1472 | 1360 | 2944 | 2720 | 2944 | 2720 | 2560 | 2944 | 2720 | 2560 | 2944 | 2720 | 2560 | 830 * | 720 * | 1660 * | 1440 * | 2948 | 2720 | 2560 | 2948 | 2720 | 2560
    21 | 1092 | 1013 | 1639 | 1520 | 3277 | 3040 | 3277 | 3040 | 2880 | 3277 | 3040 | 2880 | 3277 | 3040 | 2880 | 830 * | 720 * | 1660 * | 1440 * | 3284 | 3040 | 2880 | 3284 | 3040 | 2880
    22 | 1195 | 1120 | 1792 | 1680 | 3584 | 3360 | 3584 | 3360 | 3200 | 3584 | 3360 | 3200 | 3584 | 3360 | 3200 | 830 * | 720 * | 1660 * | 1440 * | 3592 | 3360 | 3200 | 3592 | 3360 | 3200
    23 | 1195 * | 1120 * | 1792 * | 1680 * | 3584 * | 3360 * | 4860 | 4480 | 4480 | 4860 | 4480 | 4480 | 4860 | 4480 | 4480 | 830 * | 720 * | 1660 * | 1440 * | 4868 | 4480 | 4480 | 4868 | 4480 | 4480
    24 | 1195 * | 1120 * | 1792 * | 1680 * | 3584 * | 3360 * | 5709 | 5280 | 5440 | 5709 | 5280 | 5440 | 5709 | 5280 | 5440 | 830 * | 720 * | 1660 * | 1440 * | 5716 | 5280 | 5440 | 5716 | 5280 | 5440
    25 | 1195 * | 1120 * | 1792 * | 1680 * | 3584 * | 3360 * | 7206 | 6720 | 6720 | 7206 | 6720 | 6720 | 7206 | 6720 | 6720 | 830 * | 720 * | 1660 * | 1440 * | 7212 | 6720 | 6720 | 7212 | 6720 | 6720
    26 1195 * 1120 * 1792 * 1680 * 3584 * 3360 * 7206 * 6720 * 6720 *

    8619

            8160 8320 8619 8160 8320 830 * 720 * 1660 * 1440 * 7888 7360 7680 7888 7360 7680
    27 | 1195 * | 1120 * | 1792 * | 1680 * | 3584 * | 3360 * | 7206 * | 6720 * | 6720 * | 8619* | 8160* | 8320* | 10877 | 10240 | 10560 | 830 * | 720 * | 1660 * | 1440 * | 10884 | 10240 | 10560 | 10884 | 10240 | 10560
    28 | 1195 * | 1120 * | 1792 * | 1680 * | 3584 * | 3360 * | 7206 * | 6720 * | 6720 * | 8619* | 8160* | 8320* | 11685 | 11040 | 11200 | 830 * | 720 * | 1660 * | 1440 * | 13252 | 12480 | 12800 | 13252 | 12480 | 12800
    29 | 1195 * | 1120 * | 1792 * | 1680 * | 3584 * | 3360 * | 7206 * | 6720 * | 6720 * | 8619* | 8160* | 8320* | 12111 | 11520 | 11520 | 830 * | 720 * | 1660 * | 1440 * | 16132 | 15200 | 15680 | 16132 | 15200 | 15680
    30 1195 * 1120 * 1792 * 1680 * 3584 * 3360 * 7206 * 6720 * 6720 * 8619* 8160*

    8320*

            12779 12160 12160 830 * 720 * 1660 * 1440 * 16132* 15200* 15680* 19288 18240 18560
    * denotes that a "Reference power adjustment" is specified by the CQI Value (in other words, although the bit rate is the same as the bit rate for the preceding CQI Value , the power in the HS-PDSCHs is reduced).
    Bold font denotes 16QAM modulation. Emphasis font denotes 64QAM modulation.

    GPIB command: CALL:HSDPa:SERVice:PSData:CQI[:VALue]

  • PS Data User Defined Active HS-PDSCHs

    Sets the number of HS-PDSCHs transmitted by the test set. This setting affects the transport block size (see PS Data User Def Transport Block Size Index ). You can change this setting while on a connection.

    The number of HS-PDSCHs specified by this setting, when added to the PS Data First HS-PDSCH Channel Code cannot exceed 15 (otherwise the HS-PDSCHs would collide with the downlink OCNS channels).

    This parameter is only applicable when the PS Data Configuration Type is set to User Defined .

    GPIB command: CALL:HSDPa:SERVice:PSData:UDEFined:HSPDschannel:COUNt

  • PS Data User Def Transport Block Size Index

    Sets k i (transport block size index) as described in 3GPP TS 25.321 s9.2.3. You can change this setting while on a connection.

    You cannot directly set the HS-DSCH (MAC-hs) transport block size. Rather, you must set the PS Data User Defined Active HS-PDSCHs , PS Data User Defined Modulation Type , and PS Data User Def Transport Block Size Index . The test set then calculates the HS-DSCH transport block size from these three settings. You can query the transport block size using the CALL:STATus:HSDSchannel:TBSize? command.

    3GPP TS 25.321 Annex A provides a mapping of the index k t to HS-DSCH transport block size. 25.321 s9.2.3.1 specifies that k t = k i + k 0,i . 25.321 Table 9.2.3.1 provides values for k 0,i for different modulation types and number of active HS-PDSCHs. Thus, the HS-DSCH transport block size can be directly determined from the modulation type, number of active HS-PDSCHs, and transport block size index. For example, for a modulation type of 16QAM and 5 HS-PDSCHs, k 0,i = 131. Choosing a value of k i = 48 results in a value of 179 for k t , which is an HS-DSCH transport block size of 7298 bits.

    Note, if you set PS Data User Def Transport Block Size Index to a value that results in a transport block size that exceeds the maximum value for the Current UE HS-DSCH Category (see 3GPP TS 25.306 Table 5.1a), the test set will post a warning, but will still transmit using the requested block size. Transmitting too large of a block to the UE will likely result in undesirable behavior (the UE may stop its HS-DSCH reception altogether, and you may need to end and re-establish the connection with a smaller block size).

    Note, the test set ensures that the transport block size index does not cause the MAC-hs to become too small to carry a single MAC-d PDU (configured using the PS Data HS-DSCH MAC-d PDU Size parameter). Therefore, if a change is made to this parameter that results in too small of MAC-hs block size it will be rejected by the test set.

    GPIB command: CALL:HSDPa:SERVice:RBTest:UDEFined:TBSize:INDex

    This parameter is only applicable when the PS Data Configuration Type is set to User Defined .

    GPIB command: CALL:HSDPa:SERVice:PSData:UDEFined:TBSize:INDex

  • PS Data User Defined Modulation Type

    Sets the modulation type used on the HS-PDSCHs. This setting affects the transport block size (see PS Data User Def Transport Block Size Index ). You can change this setting while on a connection.

    Note, not all UE categories support 16QAM. If you set PS Data User Defined Modulation Type to 16QAM when Current UE HS-DSCH Category is reporting a category that does not support 16QAM (see 3GPP TS 25.306 Table 5.1a), the test set will post a warning, but will still transmit using 16QAM modulation.

    Note, if you set PS Data User Defined Modulation Type to a value that results in a transport block size that exceeds the maximum value for the Current UE HS-DSCH Category (see 3GPP TS 25.306 Table 5.1a), the test set will post a warning, but will still transmit using the requested block size. See PS Data User Def Transport Block Size Index for more details.

    This parameter is only applicable when the PS Data Configuration Type is set to User Defined .

    GPIB command: CALL:HSDPa:SERVice:PSData:UDEFined:MODulation[:TYPE]

  • PS Data DC-HSDPA State

    This parameter controls whether to set up a DC-HSDPA PS Data call. DC-HSDPA operation requires:

    • The serving cell and the secondary serving cell are in the same frequency band;
    • The total number of HS-SCCHs configured for both the cells be 6 or less;
    • PS Data HS-DSCH MAC entity is set to Mac-ehs ;
    • The Number of HARQ Processes shall be more than 6 when PS Data UE IR Buffer Allocation is set to Implicit . when PS Data UE IR Buffer Allocation is set to Explicit , the number of HARQ processes can be 1 through 8, but the memory size for each HARQ process can not be greater than the number of soft channel bits for an implicit memory partitioning with 6 processes per HS-DSCH channel (3GPP TS 25.331 s8.6.5.6b).
    • The current UE HS-DSCH Category is between 21 to 24.

    This parameter can only be changed when Call Status is idle.

    GPIB command: CALL:HSDPa:SERVice:PSData:DCHSdpa[:STATe]

  • PS Data MAC-d PDU Size Control

    This setting determines whether PS Data HS-DSCH MAC-d PDU Size or PS Data HS-DSCH MAC-d PDU Size Manual is to be used on HS-DSCH channel.

    GPIB command: CALL:HSDPa:SERVice:PSData:MACD:PDUSize:CONTrol

  • PS Data HS-DSCH MAC-d PDU Size

    This parameter specifies the size of the MAC-d PDU that is used on the DTCH that is mapped to the HS-DSCH for an HSDPA PS data connection. The DTCH is the logical channel that carries the downlink user traffic data (for example, IP datagrams).

    Some UEs require a 656 bit MAC-d PDU size to achieve maximum data throughput (because sending fewer blocks reduces the load on the UE's CPU). 3GPP TS 34.108 s6.10.2.4.5.1 lists 656 bits as an alternate MAC-d PDU size. PS Data HS-DSCH MAC-d PDU Size cannot be changed to 656 bits if PS Data Configuration Type is set to 7 or less (because doing so would cause the MAC-d PDU to be too large for the MAC-hs block).

    This parameter can only be changed when connection status is idle.

    GPIB command: CALL:HSDPa:SERVice:PSData:MACD:PDUSize

  • PS Data MAC-d PDU Size Manual

    When PS Data HS-DSCH MAC-d PDU Size Control is set to Manual , this setting determines the size of the MAC-d PDU that is used on the DTCH that is mapped to the HS-DSCH for a HSDPA PS data connection.

    GPIB command: CALL:HSDPa:SERVice:PSData:MACD:PDUSize:MANual

  • PS Data Minimum Inter-TTI Interval

    This parameter sets the control state and value of the of the minimum inter-TTI interval used on the downlink.

    The control state can be set to Auto or Manual mode. When in Auto mode, the minimum inter-TTI used on an HSDPA or HSPA PS data call is the minimum inter-TTI supported by the Current UE HS-DSCH Category. When in set to a value (manual mode), this parameter controls the absolute inter-TTI interval.

    Note, not all UE categories support an inter-TTI interval of less than 3 (see 3GPP TS 25.306 Table 5.1a). If you set PS Data Minimum Inter-TTI Interval to a value that is not supported by the Current UE HS-DSCH Category , the test set will post a warning, but will still transmit using the specified inter-TTI interval.

    You can change this setting while on a connection.

    GPIB commands:
    Control State: CALL:HSDPa:SERVice:PSData:ITTI[:INTerval]:MINimum:CONTrol:AUTO
    Manual Setting: CALL:HSDPa:SERVice:PSData:ITTI[:INTerval]:MINimum:MANual

  • PS Data Number of HARQ Processes

    Sets the control state and value for the number of active HARQ processes.

    The control state can be set to Auto or Manual mode. When the control state is set to Auto, the number of HARQ processes active in the MAC-hs layer is set such that the fewest number of HARQ processes are used that will still result in maximum throughput based on the Current UE HS-DSCH Category. These values for the AUTO control state are as follows.

    UE Category

    Number of HARQ Processes

    (if the control state is AUTO)

    1

    2

    2

    2

    3

    3

    4

    3

    5

    6

    6

    6

    7

    6

    8

    6

    9

    6

    10

    6

    11

    3

    12

    6

    13

    6

    14

    6

    17

    6

    18

    6

    21

    6

    22

    6
    23

    6
    24

    6

    When the control state is set to a value (manual mode), the test set uses this value for the number of HARQ processes active in the MAC-hs layer.

    See PS Data DC-HSDPA State on restrictions with DC-HSDPA operation.

    This setting can only be changed when the call status is idle.

    GPIB command:
    Control State: CALL:HSDPa:SERVice:PSData:HARQ:PROCess:COUNt:CONTrol:AUTO
    Manual Setting: CALL:HSDPa:SERVice:PSData:HARQ:PROCess:COUNt:MANual

  • PS Data UE IR Buffer Allocation

    Controls how the IR buffer size for each active HARQ process is determined.

    When PS Data UE IR Buffer Allocation is set to Implicit , the total IR buffer size for the Current UE HS-DSCH Category ("total number of soft channel bits" in 3GPP TS 25.306 Table 5.1a) is divided equally among the active HARQ processes. For DC-HSDPA, the soft memory buffer is initially equally partitioned among the HS-DSCH transport channels and then equally partitioned among the HARQ processes per HS-DSCH transport channel. Using this setting helps ensure that the HSDPA connection will be successfully established, as the IR buffer size used by the test set is automatically set to match the current UE category. However, to configure the size of the IR buffer allocated to each HARQ process in the user defined downlink, you may need to set PS Data UE IR Buffer Allocation to Explicit , and then set PS Data Explicit UE IR Buffer Size accordingly.

    When PS Data UE IR Buffer Allocation is set to Explicit , the IR buffer size allocated to each active HARQ process is determined directly by the PS Data Explicit UE IR Buffer Size setting. This setting allows you to allocate less than your UE's maximum total IR buffer size. Note that if you set the PS Data Explicit UE IR Buffer Size beyond your UE's capability (based on the number of HARQ processes), the HSDPA connection attempt will fail.

    See PS Data DC-HSDPA State on restrictions with DC-HSDPA operation.

    This setting can only be changed when call status is idle.

    GPIB command: CALL:HSDPa:SERVice:PSData:MS:IREDundancy:BUFFer:ALLocation

  • PS Data Explicit UE IR Buffer Size

    When PS Data UE IR Buffer Allocation is set to Explicit , this setting determines the size of the IR buffer allocated to each HARQ process. The total IR buffer size is thus determined by multiplying the PS Data Explicit UE IR Buffer Size by the PS Data Number of HARQ Processes .

    Note, different UE categories support different total IR buffer sizes ("total number of soft channel bits" in 3GPP TS 25.306 Table 5.1a). If you set the total IR buffer size beyond the specified limit for the Current UE HS-DSCH Category , the test set will post a warning, but will still allocate the total IR buffer size you've set. This will cause the HSDPA connection attempt to fail. The limits for the IR buffer size based on the UE category are listed in the table below. UE Categories 21,22,23 and 24 support DC-HSDPA.

    UE Category

             IR Buffer Size Limit

    1

    19200

    2

    28800

    3

    28800

    4

    38400

    5

    57600

    6

    67200

    7

    115200

    8

    134400

    9

    172800

    10

    172800

    11

    14400

    12

    28800

    13

    259200

    14

    259200

    17

    259200

    18

    259200

    21

    345600

    22

    345600

    23

    518400

    24

    518400

    The range for this setting is 800-16000 by step of 800, 17600-32000 by step of 1600, 36000-80000 by step of 4000, 88000-160000 by step of 8000, and 176000-304000 by step of 16000, as per 3GPP TS 25.331 s10.3.5.7a.

    See PS Data DC-HSDPA State on restrictions with DC-HSDPA operation.

    This setting can only be changed when call status is idle.

    GPIB command: CALL:HSDPa:SERVice:PSData:MS:IREDundancy:BUFFer:SIZE[:EXPLicit]

  • PS Data HS-DSCH MAC entity

    If PS Data DC-HSDPA State is set to On , you can not set this parameter to MAC-hs because DC-HSDPA must be configured with MAC-ehs.

    This setting can only be changed when call status is idle.

    GPIB command: CALL:HSDPa:SERVice:PSData:HSDSchannel:MAC

  • PS Data HS-DSCH 64QAM Configured State

    GPIB command: CALL:HSDPa:SERVice:PSData:QAM64:STATe

  • PS Data HS-DSCH TB Size Table

    GPIB command: CALL:HSDPa:SERVice:PSData:MACEHS:HSDSchannel:TBSTable:ALIGnment

  • Downlink AM RLC Mode

    GPIB command: CALL:HSDPa:SERVice:PSData:RLC:DOWNlink:MODE

  • DL Flexible RLC Header Extension Special Value

    GPIB command: CALL:HSDPa:SERVice:PSData:RLC:DOWNlink:HEXTension:SVALue

  • DL Max PDU Payload Size

    This setting is only available when the PS Data HS-DSCH MAC entity is set to MAC-ehs and the Downlink AM RLC Mode is Flexible .

    This setting determines the downlink maximum flexible AM RLC PDU payload size. If the AM RLC SDU size is greater than the DL Max PDU Payload Size , it is segmented to multiple RLC PDUs so that the payload in each PDU is equal to or less than the DL Max PDU Payload Size . The payload size in those PDUs which are not the last one is set to DL Max PDU Payload Size , and the remaining segment will be put into the last RLC PDU.

    This setting can only be changed when call status is idle.

    GPIB command: CALL:HSDPa:SERVice:PSData:RLC:DOWNlink:MAXimum:PDU:PSIZe

Serving Cell Parameters

  • PS Data HS-DSCH Configuration Type

    GPIB command: CALL:HSDPa:SERVice:PSData:HSDSchannel:CONFig[:TYPE]

  • CQI Value

    GPIB command: CALL:HSDPa:SERVice:PSData:CQI[:VALue]

  • PS Data User Defined Active HS-PDSCHs

    GPIB command: CALL:HSDPa:SERVice:PSData:UDEFined:HSPDschannel:COUNt

  • PS Data User Def Transport Block Size Index

    GPIB command: CALL:HSDPa:SERVice:PSData:UDEFined:TBSize:INDex

  • PS Data User Defined Modulation Type

    GPIB command: CALL:HSDPa:SERVice:PSData:UDEFined:MODulation[:TYPE]

  • PS Data Minimum Inter-TTI Interval

    GPIB commands:
    Control State: CALL:HSDPa:SERVice:PSData:ITTI[:INTerval]:MINimum:CONTrol:AUTO
    Manual Setting: CALL:HSDPa:SERVice:PSData:ITTI[:INTerval]:MINimum:MANual

  • PS Data HS-DSCH 64QAM Configured State

    GPIB command: CALL:HSDPa:SERVice:PSData:QAM64:STATe

  • PS Data HS-DSCH TB Size Table

    GPIB command: CALL:HSDPa:SERVice:PSData:MACEHS:HSDSchannel:TBSTable:ALIGnment

Secondary Serving Cell Parameters

  • Secondary Serving Cell HS-DSCH Configuration Type

    GPIB command: CALL:HSDPa:SSCell:PSData:HSDschannel:CONFig[:TYPE]

  • Secondary Serving Cell CQI Value

    GPIB command: CALL:HSDPa:SSCell:PSData:CQI[:VALue]

  • PS Data User Defined Secondary Cell Active HS-PDSCHs

    GPIB command: CALL:HSDPa:SSCell:PSData:UDEFined:HSPDschannel:COUNt

  • PS Data User Def Secondary Cell TB Size Index

    GPIB command: CALL:HSDPa:SSCell:PSData:UDEFined:TBSize:INDex

  • PS Data User Defined Secondary Cell Modulation Type

    GPIB command: CALL:HSDPa:SSCell:PSData:UDEFined:MODulation[:TYPE]

  • PSD Secondary Cell Minimum Inter-TTI Interval

    GPIB commands:
    Control State: CALL:HSDPa:SSCell:PSData:ITTI[:INTerval]:MINimum:CONTrol:AUTO
    Manual Setting: CALL:HSDPa:SSCell:PSData:ITTI[:INTerval]:MINimum:MANual

  • PSD Secondary Cell HS-DSCH 64QAM Configured State

    GPIB command: CALL:HSDPa:SSCell:PSData:UDEFined:QAM64:STATe

  • PSD Secondary Cell HS-DSCH TB Size Table

    GPIB command: CALL:HSDPa:SSCell:PSData:MACEHS:HSDSchannel:TBSTable:ALIGnment

Related Topics

HSDPA Parameters


HSDPA RB Test Mode Setup

HSDPA RB Test Mode Setup

Last updated: December 31, 2011

This section is only applicable to the lab application or feature-licensed test application.

  • HSDPA RB Test Mode Settings
  • HSDPA Pattern Parameters
  • Serving Cell Parms
  • Secondary Cell Parms

HSDPA Pattern Parameters

  • Transmission Mode

    This setting allows you to activate some specific transmission pattern on the HSDPA channel. The transmission pattern consists of two segments which are transmitted periodically. You can set the length or type of each segment. The transmission pattern is defined by Initial SFN , Initial Subframe , First Segment Length , First Segment Type , Second Segment Length and Second Segment Type .

    To apply the transmission pattern, you must set up an RB test mode connection and set the RB Test HS-DSCH Configuration Type to User Defined . Besides, it is strongly recommended you set User Defined Inter-TTI Interval to 1 and User Defined Number of HARQ Processes to 6 (or more than 6), respectively.

    Once the transmission pattern is applied, the transmission will not take into account the compressed mode gap or the CPC DRX reception gap. In other words, an HSDPA block will be transmitted in the TTI indicated to be "transmission" pattern even this TTI is a compressed mode transmission gap or CPC DRX reception gap.

    This setting can be changed only when the Call Status is Idle or Connected .

    GPIB Command: CALL:HSDPa:SERVice:RBTest:UDEFined:TMODe

  • Initial SFN

    This setting, together with Initial Subframe , determines the TTI when to start the transmission pattern.

    This setting can not be changed when the Transmission Mode is set to Pattern .

    GPIB Command: CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:INITial:SFNumber

  • Initial Subframe

    This setting, together with Initial SFN , determines the TTI when to start the transmission pattern.

    This setting can not be changed when the Transmission Mode is set to Pattern .

    GPIB Command: CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:INITial:SUBFrame

  • First Segment Length

    First Segment Length defines the length of the first segment (in HSDPA TTI (2ms)).

    This setting can not be changed when the Transmission Mode is set to Pattern .

    GPIB Command: CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent[1]:LENGth

  • First Segment Type

    If the First Segment Type is set to Transmit , the test set transmits the HSDPA blocks during the first segment. If the First Segment Type is set to DTX , the test set uses alternative H-RNTI to transmit HSDPA blocks which means DTX for the UE.

    This setting can not be changed when the Transmission Mode is set to Pattern .

    GPIB Command: CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent[1]:TYPE

  • Second Segment Length

    Second Segment Length defines the length of the second segment (in HSDPA TTI (2ms)).

    This setting can not be changed when the Transmission Mode is set to Pattern .

    GPIB Command: CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent2:LENGth

  • Second Segment Type

    If the Second Segment Type is set to Transmit , the test set transmits the HSDPA blocks during the second segment. If the Second Segment Type is set to DTX , the test set uses alternative H-RNTI to transmit HSDPA blocks which means DTX for the UE.

    This setting can not be changed when the Transmission Mode is set to Pattern .

    GPIB Command: CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent2:TYPE

Serving Cell Parms

When RB Test User Defined DC-HSDPA State is set to On , the following parameters are grouped as the serving cell paramerters:

  • User Defined 64QAM State
  • User Defined MAC-ehs HS-DSCH TB Size Table
  • User Defined Number of Active HS-PDSCHs
  • User Defined Explicit UE IR Buffer Size
  • User Defined Modulation Type
  • User Defined Inter-TTI Interval

Secondary Cell Parms

When RB Test User Defined DC-HSDPA State is set to On , the following parameters are available as the secondary serving cell paramerters:

  • RB Test User Def Secondary Cell 64QAM State

    GPIB Command: CALL:HSDPa:SSCell:RBTest:UDEFined:QAM64:STATe

  • RBTM User Def Sec Cell HS-DSCH TBS Table

    GPIB Command: CALL:HSDPa:SSCell:RBTest:MACEHS:HSDSchannel:TBSTable:ALIGnment

  • RBTM User Def Sec Cell Active HS-PDSCHs

    GPIB Command: CALL:HSDPa:SSCell:RBTest:UDEFined:HSPDschannel:COUNt

  • RBTM User Def Sec Cell TB Size Index

    GPIB Command: CALL:HSDPa:SSCell:RBTest:UDEFined:TBSize:INDex

  • RBTM User Def Sec Cell Modulation Type

    GPIB Command: CALL:HSDPa:SSCell:RBTest:UDEFined:MODulation[:TYPE]

  • RBTM User Def Sec Cell Inter-TTI Interval

    GPIB Command: CALL:HSDPa:SSCell:RBTest:UDEFined:ITTI[:INTerval]

Related Topics

Manual Operation: How Do I Change HSDPA Parameters?


HSDPA RB Test Mode Settings

HSDPA RB Test Mode Settings

Last updated: January 6, 2012

This section is only applicable to the lab application or feature-licensed test application.

  • RB Test HS-DSCH Configuration Type
  • Configuring the HS-DSCH as an FRC
  • Configuring the DC-HSDPA RB Test Mode Settings
  • User Defined Configuration of the HS-DSCH
    • Data Transmission Pattern Based on Inter-TTI Interval and Number of HARQ Processes
    • User Defined Settings to Configure the Downlink as an FRC
    • User Defined Settings to Achieve Maximum Data Rate for each UE Category
  • General HSDPA RB Test Mode Settings

RB Test HS-DSCH Configuration Type

You can configure the HSDPA RB Test Mode downlink HS-DSCH in one of two ways. You can specify an FRC, which automatically configures the downlink properties, or you can manually define the downlink properties such as Number of HARQ Processes, Modulation Type, Transport Block Size Index etc. using the "User Defined" parameters.

When HS-DSCH Configuration Type is set to FRC , the downlink channel is configured as the FRC specified by the FRC Type setting. When HS-DSCH Configuration Type is set to User Defined , the downlink channel is configured according to the settings described in User Defined Configuration of the HS-DSCH .

GPIB command: CALL:HSDPa:SERVice:RBTest:HSDSchannel:CONFig[:TYPE]

This parameter can only be changed while the call status is idle.

Configuring the HS-DSCH as an FRC

  • FRC Type

    The test set supports the following H-Sets defined in 3GPP TS 34.121 sC.8: H-Sets 1-3 (QPSK and 16QAM), H-Sets 4 and 5 (QPSK), H-Set 6 (QPSK and 16QAM), H-Set 8 (64QAM), H-Set 10 (QPSK and 16QAM) and the DC-HSDPA H-Sets 3A, 6A, 8A 10A and 12.

    The test set sets the Inter-TTI Distance, Number of HARQ Processes, Information Bit Payload, Number of SMLs per HARQ Process, Number of Physical Channel Codes, etc. to the values specified by 34.121 for each FRC. It is essential that you set FRC Type to match the capabilities of your UE (the UE categories are defined in 3GPP TS 25.306 Table 5.1a.).

    Note that changing FRC Type may change the number of active HS-PDSCHs. You must set RB Test Mode First HS-PDSCH Channel Code to 5 before you can set FRC Type to H-Set 6 (because H-Set 6 utilizes 10 HS-PDSCHs).

    GPIB command: CALL:HSDPa:SERVice:RBTest:FRC:TYPE

    This parameter can only be set when call status is Idle , and is only applicable when RB Test HS-DSCH Configuration Type is set to FRC .

  • FRC MAC-d PDU Size

    While on an RB Test Mode connection, the test set sends as many MAC-d PDUs as it can pack into the MAC-hs PDU, up to the maximum of 70 allowed by 3GPP TS 25.321 s9.2.2. Each MAC-d PDU consists of a single RLC UM PDU (which may or may not include an RLC header, as determined by the RLC Header on HS-DSCH setting). The data pattern used to fill the data fields of the RLC UM PDU is specified by the HS-DSCH Data Pattern setting.

    When RB Test HS-DSCH Configuration Type is set to FRC , the MAC-hs PDU size is determined by the FRC Type .

    When HS-DSCH Configuration Type is set to FRC , you can set the size of the MAC-d PDU to 112 bits, 336 bits, 656 bits, or maximize the size of the MAC-d PDU (when HS-DSCH Configuration Type is set to User Defined , the MAC-d PDU size is fixed to 112 bits). When FRC MAC-d PDU Size is set to Maximize , the MAC-d PDU size is set to the largest multiple of 8 bits that doesn't exceed the MAC-hs PDU size minus 21 MAC-hs header bits, or 5000 bits (3GPP TS 25.331 s10.3.5.1a specifies a maximum MAC-d PDU size of 5000 bits).

    MAC-hs PDU size and maximum MAC-d PDU size for each FRC type
    FRC Type MAC-hs PDU size MAC-d PDU size when FRC MAC-d PDU Size = Maximize

    H-Set 1-5 QPSK

             3202 3176

    H-Set 1-3 16QAM

             4664 4640

    H-Set 6 QPSK

             6438 5000

    H-Set 6 16QAM

             9377 5000

    If the MAC-d PDU plus the MAC-hs header does not completely fill the MAC-hs PDU, the test set fills the unused portion with padding that consists of the payload data of the next UM RLC PDU(s). The following diagram provides an example for a MAC-d PDU Size of 112 bits, no RLC header and a MAC-hs PDU size of 3202:

    GPIB command: CALL:HSDPa:SERVice:RBTest:FRC:MACD:PDUSize

    This parameter can only be set when call status is Idle , and is only applicable when RB Test HS-DSCH Configuration Type is set to FRC .

Configuring the DC-HSDPA RB Test Mode Settings

When the required feature license is available, you can set the DC-HSDPA RB test mode settings as below. See Serving Cell Parms and Secondary Cell Parms for the parameters of each cell.

  • RB Test User Defined DC-HSDPA State

    This parameter allows you to enable or disable DC-HSDPA operation.

    Note: You must set the User Defined Number of HARQ Processes and User Defined HS-DSCH MAC Entity correctly before setting RB Test User Defined DC-HSDPA State to On .

    GPIB command: CALL:HSDPa:SERVice:RBTest:UDEFined:DCHSdpa[:STATe]

    This parameter can only be changed when call status is Idle .

  • DC-HSDPA DPCH Loopback State

    This parameter controls whether the loopback procedure for 12.2k RMC should be performed during the "CS/PS Combined Call Setup Procedure" for the DC-HSDPA call setup. When this setting is set to On , the loopback procedure is performed.

    GPIB command: CALL:HSDPa:SERVice:RBTest:UDEFined:DCHSdpa:DPCH:LOopback[:STATe]

    This parameter can only be changed when call status is Idle .

User Defined Configuration of the HS-DSCH

The following parameters are only applicable when RB Test HS-DSCH Configuration Type is set to User Defined .

  • User Defined Number of Active HS-PDSCHs

    Sets the number of HS-PDSCHs being transmitted by the test set. This setting affects the transport block size (see User Defined Transport Block Size Index ). You can change this setting while on a connection.

    The number of HS-PDSCHs specified by this setting, when added to the RB Test Mode First HS-PDSCH Channel Code cannot exceed 16 (otherwise the HS-PDSCHs would collide with the downlink OCNS channels).

    GPIB command: CALL:HSDPa:SERVice:RBTest:UDEFined:HSPDschannel:COUNt

  • User Defined Transport Block Size Index

    Sets k i (transport block size index) as described in 3GPP TS 25.321 s9.2.3. You can change this setting while on a connection.

    You cannot directly set the HS-DSCH (MAC-hs) transport block size. Rather, you must set the User Defined Number of Active HS-PDSCHs , User Defined Modulation Type , and User Defined Transport Block Size Index . The test set then calculates the HS-DSCH transport block size from these three settings. You can query the transport block size using the CALL:STATus:HSDSchannel:TBSize? command.

    3GPP TS 25.321 Annex A provides a mapping of the index k t to HS-DSCH transport block size. 25.321 s9.2.3.1 specifies that k t = k i + k 0,i . 25.321 Table 9.2.3.1 provides values for k 0,i for different modulation types and number of active HS-PDSCHs. Thus, the HS-DSCH transport block size can be directly determined from the modulation type, number of active HS-PDSCHs, and transport block size index. For example, for a modulation type of 16QAM and 5 HS-PDSCHs, k 0,i = 131. Choosing a value of k i = 48 results in a value of 179 for k t , which is an HS-DSCH transport block size of 7298 bits.

    Note, if you set User Defined Transport Block Size Index to a value that results in a transport block size that exceeds the maximum value for the Current UE HS-DSCH Category (see 3GPP TS 25.306 Table 5.1a), the test set will post a warning, but will still transmit using the requested block size. Transmitting too large of a block to the UE will likely result in undesirable behavior (the UE may stop its HS-DSCH reception altogether, and you may need to end and re-establish the connection with a smaller block size).

    See Example User Defined Configuration: Maximum Data Rate for each UE Category to determine the settings to achieve the highest data rate for your UE.

    Note, the MAC-d PDU size for the user defined channel is fixed to 112 bits.

    GPIB command: CALL:HSDPa:SERVice:RBTest:UDEFined:TBSize:INDex

  • User Defined Modulation Type

    Sets the modulation type used on the HS-PDSCHs. This setting affects the transport block size (see User Defined Transport Block Size Index ). You can change this setting while on a connection.

    Note, not all UE categories support 16QAM. If you set User Defined Modulation Type to 16QAM when Current UE HS-DSCH Category is reporting a category that does not support 16QAM (see 3GPP TS 25.306 Table 5.1a), the test set will post a warning, but will still transmit using 16QAM modulation.

    Note, if you set User Defined Modulation Type to a value that results in a transport block size that exceeds the maximum value for the Current UE HS-DSCH Category (see 3GPP TS 25.306 Table 5.1a), the test set will post a warning, but will still transmit using the requested block size. See User Defined Transport Block Size Index for more details.

    GPIB command: CALL:HSDPa:SERVice:RBTest:UDEFined:MODulation[:TYPE]

  • User Defined Flexible RLC SDU Size

    Sets the RLC SDU size in octets of the DTCH that will be mapped to HS-DSCH. The range of this setting is 1 byte to 1503 bytes.

    This parameter can only be set when the data/call status is Idle , and is only applicable when User Defined HS-DSCH MAC Entity is set to MAC-ehs .

    GPIB Command: CALL:HSDPa:SERVice:RBTest:UDEFined:MACEHS:RLC:SDU[:SIZE]

  • User Defined Inter-TTI Interval

    Sets the inter-TTI interval used on the downlink. For example, an inter-TTI interval of 1 indicates that data will be transmitted to the UE in every TTI (if there are enough active HARQ processes to provide data in every TTI). How often data is actually transmitted to the UE depends also upon the User Defined Number of HARQ Processes . See Interaction of Inter-TTI Interval and Number of HARQ Processes . You can change this setting while on a connection.

    Note, not all UE categories support an inter-TTI interval of less than 3 (see 3GPP TS 25.306 Table 5.1a). If you set User Defined Inter-TTI Interval to a value that is not supported by the Current UE HS-DSCH Category , the test set will post a warning, but will still transmit using the specified inter-TTI interval.

    GPIB command: CALL:HSDPa:SERVice:RBTest:UDEFined:ITTI[:INTerval]

  • User Defined Number of HARQ Processes

    Sets the number of HARQ processes that are active. The number of HARQ processes, along with the User Defined Inter-TTI Interval , affects how often data is transmitted to the UE. See Interaction of Inter-TTI Interval and Number of HARQ Processes .

    Note: For DC-HSDPA, when User Defined UE IR Buffer Allocation is set to Implicit , you are not allowed to set the number of HARQ processes to a value less than 6, and vice versa. Also, When User Defined UE IR Buffer Allocation is set to Explicit , the number of HARQ processes can be 1 through 8, but the memory size for each HARQ process can not be greater than the number of soft channel bits for an implicit memory partitioning with 6 processes per HS-DSCH channel (3GPP TS 25.331 s8.6.5.6b).

    GPIB command: CALL:HSDPa:SERVice:RBTest:UDEFined:HARQ:PROCess:COUNt

    This setting can only be changed when call status is idle (to change this value while on a call, you must perform a Transport Channel Reconfiguration ).

  • User Defined UE IR Buffer Allocation

    Controls how the IR buffer size for each active HARQ process is determined.

    When User Defined UE IR Buffer Allocation is set to Implicit , the total IR buffer size for the Current UE HS-DSCH Category ("total number of soft channel bits" in 3GPP TS 25.306 Table 5.1a) is divided equally among the active HARQ processes. Using this setting helps ensure that the HSDPA connection will be successfully established, as the IR buffer size used by the test set is automatically set to match the current UE category. However, please note that to configure the user defined downlink to emulate an FRC, you may need to set User Defined UE IR Buffer Allocation to Explicit , and then set User Defined Explicit UE IR Buffer Size accordingly (see Example User Defined Configuration: Configuring the Downlink as an FRC ).

    When User Defined UE IR Buffer Allocation is set to Explicit , the IR buffer size allocated to each active HARQ process is determined directly by the User Defined Explicit UE IR Buffer Size setting. This setting allows you to allocate less than your UE's maximum total IR buffer size (which may be required if you wish to emulate an FRC, see Example User Defined Configuration: Configuring the Downlink as an FRC ). Note that if you set the User Defined Explicit UE IR Buffer Size beyond your UE's capability (based on the number of HARQ processes), the HSDPA connection attempt will fail.

    See User Defined Number of HARQ Processes on DC-HSDPA operating restrictions.

    GPIB command: CALL:HSDPa:SERVice:RBTest:UDEFined:MS:IREDundancy:BUFFer:ALLocation

    This setting can only be changed when call status is idle (to change this value while on a call, you must perform a Transport Channel Reconfiguration ).

  • User Defined Explicit UE IR Buffer Size

    When User Defined UE IR Buffer Allocation is set to Explicit , this setting determines the size of the IR buffer allocated to each HARQ process. The total IR buffer size is thus determined by multiplying the User Defined Explicit UE IR Buffer Size by the User Defined Number of HARQ Processes .

    Note, different UE categories support different total IR buffer sizes ("total number of soft channel bits" in 3GPP TS 25.306 Table 5.1a). If you set the total IR buffer size beyond the specified limit for the Current UE HS-DSCH Category , the test set will post a warning, but will still allocate the total IR buffer size you've set. This will cause the HSDPA connection attempt to fail.

    The range for this setting is 800-16000 by step of 800, 17600-32000 by step of 1600, 36000-80000 by step of 4000, 88000-160000 by step of 8000, and 176000-304000 by step of 16000, as per 3GPP TS 25.331 s10.3.5.7a.

    For DC-HSDPA, if the Current Secondary Serving Cell State is Configured-Active or Configured-Inactive , the User Defined Explicit UE IR Buffer Size can not be greater than the number of soft channel bits for an implicit memory partitioning with 6 processes per HS-DSCH channel (Total Available IR Buffer Size divided by 2 and then by the number of HARQ processes). Or an warning message will pop up reminding you that the Explicit UE IR Buffer Size exceeds the limit.

    GPIB command: CALL:HSDPa:SERVice:RBTest:UDEFined:MS:IREDundancy:BUFFer:SIZe[:EXPLicit]

    This setting can only be changed when call status is idle (to change this value while on a call, you must perform a Transport Channel Reconfiguration ).

  • User Defined HS-DSCH MAC Entity

    This setting controls the HS-DSCH MAC entity to be used, either MAC-hs or MAC-ehs. This setting also determines the HS-DSCH TB size table.

    DC-HSDPA operation requires the MAC-ehs to be configured. You must set the User Defined HS-DSCH MAC Entity to MAC-ehs before setting the Configuring the DC-HSDPA RB Test Mode Settings to On .

    GPIB command: CALL:HSDPa:SERVice:RBTest:UDEFined:HSDSchannel:MAC

  • User Defined 64QAM State

    When the User Defined HS-DSCH MAC Entity is set to MAC-ehs , this setting controls whether or not the 64QAM modulation encoding format is used.

    GPIB command: CALL:HSDPa:SERVice:RBTest:UDEFined:QAM64:STATe

  • User Defined MAC-ehs HS-DSCH TB Size Table

    When the User Defined HS-DSCH MAC Entity is set to MAC-ehs, and the User Defined 64QAM State is set to Off, this setting controls the HS-DSCH TB size table.

    GPIB command: CALL:HSDPa:SERVice:RBTest:UDEFined:MACEHS:HSDSchannel:TBSTable:ALIGnment

Interaction of Inter-TTI Interval and Number of HARQ Processes

How often data is transmitted to the UE depends upon the inter-TTI interval and number of HARQ processes. The following table, Data Transmission Pattern Based on Inter-TTI Interval and Number of HARQ Processes , indicates how often data is transmitted to the UE under test depending upon the User Defined Inter-TTI Interval and the User Defined Number of HARQ Processes settings.

In the table, "0" represents HARQ0 data directed to the UE under test (using the Primary H-RNTI (Hex) ), "1" represents HARQ1 data directed to the UE under test, "2" represents HARQ2 data directed to the UE under test, etc. "*" represents data sent by the test set that is not directed to the UE under test (i.e. data directed to the Alternate H-RNTI (Hex) ).

The bottom of each cell also explicitly indicates how often the HARQ0 process transmits for each combination of settings. Note that when inter-TTI interval * number of HARQ processes > 6, HARQ0 does not transmit every 12 ms.

Data Transmission Pattern Based on Inter-TTI Interval and Number of HARQ Processes
 | Number of HARQ Processes
Inter-TTI Interval | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8
1 | 0***** 0***** (12 ms) | 01**** 01**** (12 ms) | 012*** 012*** (12 ms) | 0123** 0123** (12 ms) | 01234* 01234* (12 ms) | 012345 012345 (12 ms) | 012345 601234 (14 ms) | 012345 670123 (16 ms)
2 | 0***** 0***** (12 ms) | 0*1*** 0*1*** (12 ms) | 0*1*2* 0*1*2* (12 ms) | 0*1*2* 3*0*1* (16 ms) | 0*1*2* 3*4*0* (20 ms) | 0*1*2* 3*4*5* 0*1*2* (24 ms) | 0*1*2* 3*4*5* 6*0*1* (28 ms) | 0*1*2* 3*4*5* 6*7*0* (32 ms)
3 | 0***** 0***** (12 ms) | 0**1** 0**1** (12 ms) | 0**1** 2**0** (18 ms) | 0**1** 2**3** 0**1** (24 ms) | 0**1** 2**3** 4**0** (30 ms) | 0**1** 2**3** 4**5** 0**1** (36 ms) | 0**1** 2**3** 4**5** 6**0** (42 ms) | 0**1** 2**3** 4**5** 6**7** 0**1** (48 ms)

Example User Defined Configuration: Configuring the Downlink as an FRC

The following table, User Defined Settings to Configure the Downlink as an FRC , indicates the settings required to configure the user defined downlink channel as an FRC.

Note that 3GPP TS 34.121 Annex C refers to transport block size as "Information Bit Payload (N INF )".

Note that 3GPP TS 34.121 Annex C refers to UE IR buffer size as "Number of SML's per HARQ Process". Depending upon the category of your UE, you may need to set User Defined UE IR Buffer Allocation to Explicit (and manually set the User Defined Explicit UE IR Buffer Size to the appropriate value), to achieve the "Number of SML's per HARQ Process" specified by 34.121 for the FRC you are emulating.

The data transmission pattern column indicates how often data is transmitted to the UE under test, and by which HARQ process. See Interaction of Inter-TTI Interval and Number of HARQ Processes for more information.

The Nominal Avg. Inf. Bit Rate is determined by multiplying the transport block size by the number of blocks transmitted per second. For an FRC, the number of blocks transmitted in 12 ms is equal to the number of HARQ processes (this is because for FRCs, inter-TTI interval * number of HARQ processes < 6). Thus, for an FRC, the Nominal Avg. Inf. Bit Rate is equal to: (transport block size in bits)*(number of HARQ processes)/12 ms.

User Defined Settings to Configure the Downlink as an FRC
FRC Number
of Active
HS-PDSCHs 		Modulation Type Transport
Block Size
Index k i
(Corresponding
Transport
Block Size) 		Inter-TTI Interval Number of
HARQ Processes 		User Defined
Explicit UE IR
Buffer Size
(per HARQ
process) 		Data transmission pattern Nominal Avg. Inf. Bit Rate
H-Set 1 QPSK 5 QPSK 41
(3202 bits) 		3 2 9600 0**1**

534 kbps
H-Set 1 16QAM 4 16QAM 36
(4664 bits) 		3 2 9600 0**1** 777 kbps
H-Set 2 QPSK 5 QPSK 41
(3202 bits) 		2 3 9600 0*1*2* 801 kbps
H-Set 2 16QAM 4 16QAM 36
(4664 bits) 		2 3 9600 0*1*2* 1.17 Mbps
H-Set 3 QPSK 3 5 QPSK 41
(3202 bits) 		1 6 9600 012345 1.60 Mbps
H-Set 3 16QAM 3 4 16QAM 36
(4664 bits) 		1 6 9600 012345 2.33 Mbps
H-Set 4 QPSK 5 QPSK 41
(3202 bits) 		2 2 7200 0**1** 534 kbps
H-Set 5 QPSK 5 QPSK 41
(3202 bits) 		1 3 9600 012*** 801 kbps
H-Set 6 QPSK 3 10 1 QPSK 41
(643815 bits) 		1 6 19200 012345 3.22 Mbps
H-Set 6 16QAM 3 8 16QAM 36
(9377 bits) 		1 6 19200 012345 4.69 Mbps

H-Set 8 64QAM 3

15 2

64QAM

 36 (26504 bits)

1

6

 259200

012345

13.25Mbps

H-Set 10 QPSK 3

15 2

16QAM

36 (17548 bits)

1

6

28800

012345

8.77 Mbps

H-Set 10 16QAM 3

15 2

QPSK

 42 (9719 bits) 1 6

28800

012345

4.86 Mbps

H-Set 12 (QPSK) 3

1

QPSK

 0 (120 bits)

1

6

3200

012345

60 kbps

1 You must set RB Test Mode First HS-PDSCH Channel Code to 6 before you can set Number of Active HS-PDSCHs to 10.

2 You must set RB Test Mode First HS-PDSCH Channel Code to 1 before you can set Number of Active HS-PDSCHs to 15.

3 For H-Set 12 and other DC-HSDPA H-Sets (H-Set 3A, 6A, 8A, 10A), the parameter settings are for each of the serving cells (carriers).

Example User Defined Configuration: Maximum Data Rate for each UE Category

The following table, User Defined Settings to Achieve Maximum Data Rate for each UE Category , indicates the settings required to configure the user defined downlink channel to achieve the maximum data rate for each UE category supported by the test set.

The data transmission pattern column indicates how often data is transmitted to the UE under test, and by which HARQ process. See Interaction of Inter-TTI Interval and Number of HARQ Processes for more information.

The Nominal Avg. Inf. Bit Rate is determined by multiplying the transport block size by the number of blocks transmitted per second. If inter-TTI interval * number of HARQ processes < 6, the number of blocks transmitted in 12 ms is equal to the number of HARQ processes, and Nominal Avg. Inf. Bit Rate is equal to: (transport block size in bits)*(number of HARQ processes)/12 ms. Note that although the Nominal Avg. Inf. Bit Rate is equal between categories 1/2, 3/4, and 5/6, due to the larger IR buffer size of categories 2, 4 and 6, in a network these categories may realize a higher actual data rate.

Note, you may need to increase the test set's Cell 1 Sum of Active Conn HS-PDSCH Levels setting to allow the UE to reliably receive the test set's downlink and therefore achieve the UE's maximum data rate.

User Defined Settings to Achieve Maximum Data Rate for each UE Category
UE Category Number
of
Active
HS-PDSCHs 		Modulation Type Transport
Block Size
Index k i
(Corresponding
Transport
Block Size) 		Inter-TTI Interval Number
of
HARQ
Processes 		User Defined
Explicit UE IR
Buffer Size
(per HARQ process) 		Data transmission pattern Nominal Avg. Inf. Bit Rate
1 5 16QAM 48
(7298 bits) 		3 2 19200/2=9600 0**1** 1.22 Mbps
2 5 16QAM 48
(7298 bits) 		3 2 28800/2=14400 0**1** 1.22 Mbps
3 5 16QAM 48
(7298 bits) 		2 3 28800/3=9600 0*1*2* 1.83 Mbps
4 5 16QAM 48
(7298 bits) 		2 3 38400/3=12800 0*1*2* 1.83 Mbps
5 5 16QAM 48
(7298 bits) 		1 6 57600/6=9600 012345

3.65 Mbps
6 5 16QAM 48
(7298 bits) 		1 6 67200/6=11200 012345

3.65 Mbps
7 10 1 16QAM 48
(14411 bits) 		1 6 115200/6=19200 012345 7.21 Mbps
8 10 1 16QAM 48
(14411 bits) 		1 6 134400/6=22400 012345 7.21 Mbps

9

 15 2

16QAM

 44 (20251 bits)

1

6

172800/6=28800

012345

10.13 Mbps

10

15 2

16QAM

 62 (27952 bits)

1

6

172800/6=28800

012345

13.976 Mbps
11 5 QPSK 48
(3630 bits) 		2 3 14400/3=4800 0*1*2*

908 kbps
12 5 QPSK 48
(3630 bits) 		1 6 28800/6=4800 012345

1.82 Mbps

13

15 2

64QAM

 52 (35280 bits)

1

6

259200/6=43200

012345

17.640 Mbps

14

15 2

64QAM

 62 (42192 bits)

1

6

259200/6=43200

012345

21.096 Mbps

21 3

15 2

16QAM 52 (23370 bits) 1

6

 345600/2/6=28800 012345

23.4 Mbps (two cells combined)

22 3

15 2

16QAM

62 (27952 bits)

 1

6

345600/2/6=28800

 012345

28 Mbps (two cells combined)

23 3

15 2

64QAM 52 (35280 bits) 1

6

 518400/2/6=43200 012345

35.3 Mbps (two cells combined)

24 3

15 2

64QAM

62 (42192 bits)

1

6

518400/2/6=43200

 012345

42.2 Mbps (two cells combined)

1 You must set RB Test Mode First HS-PDSCH Channel Code to 6 before you can set Number of Active HS-PDSCHs to 10.

2 You must set RB Test Mode First HS-PDSCH Channel Code to 1 before you can set Number of Active HS-PDSCHs to 15.

3 For UE Categories 21 to 24 that support DC-HSDPA, the parameter settings are for each of the serving cells (carriers).

General HSDPA RB Test Mode Settings

  • CN Domain

    Non-HSDPA/non-HSPA RB test mode connections are always established using CS domain entities (see Radio Bearer Test Mode Origination to CELL_DCH - CS Domain (Non-HSPA or HSDPA) ). In contrast, an HSDPA RB test mode connection can be established using CS domain entities, PS domain entities, or both, as determined by the CN Domain (Core Network Domain) setting.

    • If CN Domain is set to PS Domain , the connection is established as shown in Radio Bearer Test Mode Origination to CELL_DCH - PS Domain (HSDPA) . The PS domain is used to establish the RMC and FRC.
    • If CN Domain is set to CS Domain , the connection is established as shown in Radio Bearer Test Mode Origination to CELL_DCH - CS Domain (Non-HSPA or HSDPA) . The CS domain is used to establish the RMC and FRC.
    • If CN Domain is set to CS/PS Domain , the connection is established as shown in Radio Bearer Test Mode Origination to CELL_DCH - CS/PS Domain (HSDPA or HSPA) . The CS domain is used to establish the RMC and the PS domain is used to establish the FRC.

    Note that HSPA RB Test Mode connections are always established using both the CS and PS domains, so this setting is not applicable to HSPA RB Test Mode.

    Many 3GPP TS 34.121 tests specify the CS/PS Domain connection procedure (by reference to 3GPP TS 34.108 s7.3.6). However, using the CS Domain or PS Domain connection procedures do not compromise the results of the 34.121 tests. Regardless of which domain is used to establish the connection, the resulting channel configuration (radio bearers) is identical.

    Using the CS Domain procedure offers two advantages:

    • The CS Domain procedure allows the UE to be paged without first going through the Attach procedure (which reduces the total time from UE power-up to establishing an HSDPA connection). To use this alternate method, set PS Domain Information to Absent (to prevent the UE from attaching upon power-up), enter the appropriate Paging IMSI , power on the UE and then select Originate Call . To further speed up the connection process, you can set Repeat Paging to On , select Originate Call , then power on the UE.
    • The CS Domain procedure allows you to perform a System Handover to GSM/GPRS/EGPRS when you have completed your W-CDMA/HSDPA testing, if desired ( fast switching applications only ).

    Note, if CN Domain is set to PS Domain or CS/PS Domain , the UE must have performed the Attach procedure before you can page it ( PS Domain Information must be set to Present when the UE registers with the test set).

    If FRC Type is set to one of the DC-HSDPA type (H-Set 3A, 6A, 8A, 10A or 12) or if the RB Test User Defined DC-HSDPA State is set to On , this parameter is not applicable and the test set uses "CS(RMC) / PS(FRC)" as the CN domain.

    GPIB command: CALL:HSDPa:SERVice:RBTest:CNDomain

    This parameter can only be set when call status is Idle .

  • Uplink 0k DTCH for HSDPA Loopback State

    This setting only applies to an HSDPA RB Test Mode connection, it does not apply to an HSPA RB Test Mode connection (because on an HSPA RB Test Mode connection, the downlink HSDPA channel is looped back onto the uplink HSUPA channel).

    • When Uplink 0k DTCH for HSDPA Loopback State is set to On , the RB Setup message sent to establish the HSDPA RB test mode connection includes a 0k DTCH, onto which the UE is instructed to loop back the downlink HSDPA radio bearer with a Loopback SDU size of 0 (ensuring no data is transmitted on the 0k DTCH). This DTCH is defined identically to the Uplink 64k DTCH for HSDPA Loopback, except only the 0 block transport format is defined in the transport format set.

    • Off : When this parameter is set to Off , the UE analyzes the data it receives on the HSDPA downlink radio bearer so that it can respond with ACK/NACK information on the uplink HS-DPCCH, but then discards the data (the UE loopback function sits above the RLC layer so the data is discarded after it has been processed at the MAC-hs layer).

    GPIB command: CALL:HSDPa:SERVice:RBTest:DTCHannel0:HLOopback:STATe

    This parameter can only be set when call status is Idle , and cannot be set to On when Uplink 64k DTCH for HSDPA Loopback State is set to On .

  • Uplink 64k DTCH for HSDPA Loopback State

    This setting only applies to an HSDPA RB Test Mode connection, it does not apply to an HSPA RB Test Mode connection (because on an HSPA RB Test Mode connection, the downlink HSDPA channel is looped back onto the uplink HSUPA channel).

    • When Uplink 64k DTCH for HSDPA Loopback State is set to On , the RB Setup message sent to establish the HSDPA RB test mode connection includes a 64k DTCH, onto which the UE is instructed to loop back the downlink HSDPA radio bearer with a Loopback SDU size of 0 (ensuring no data is transmitted on the 64k DTCH). See 3GPP TSG-RAN5 R5-050720.

      HSDPA RB Test Mode Channel Configuration with Uplink 64k DTCH for Loopback State On

      You must set this parameter to On if your UE does not support closing the test loop on a unidirectional radio bearer (if your UE was implemented according to 3GPP TS 34.109 v5.4.0 which did not specify what the UE should do when told to close the test loop on a unidirectional radio bearer). Note: even if an uplink DTCH is provided for the HSDPA radio bearer to loop onto, no data is ever sent on this channel as the Loopback SDU size is zero for the HSDPA radio bearer (this ensures the uplink DPCH consists solely of a 12.2k RMC).

    • Off : When this parameter is set to Off , the UE analyzes the data it receives on the HSDPA downlink radio bearer so that it can respond with ACK/NACK information on the uplink HS-DPCCH, but then discards the data (the UE loopback function sits above the RLC layer so the data is discarded after it has been processed at the MAC-hs layer).

      HSDPA RB Test Mode Channel Configuration with Uplink 64k DTCH for Loopback State Off

    GPIB command: CALL:HSDPa:SERVice:RBTest[:DTCHannel64]:HLOopback:STATe

    This parameter can only be set when call status is Idle , and cannot be set to On when Uplink 0k DTCH for HSDPA Loopback State is set to On .

  • HS-DSCH Data Pattern

    You can specify the data pattern sent in each HS-DSCH transport block on the downlink HS-PDSCH(s). HS-DSCH Data Pattern can be set to: CCITT PRBS23 , CCITT PRBS20 , CCITT PRBS15 , CCITT PRBS9 , All Zeros , All Ones , Incrementing , or Alternating .

    For PRBS data types, the seed that is used to initialize the PRBS generator for each RLC UM PDU is the seed that the generator had at the point when it finished creating the bits that were placed into the data field of the previously transmitted RLC UM PDU. This means that the PRBS sequence is continuous across the RLC UM PDU data fields (if you were to extract all of the data fields from the transmitted RLC UM PDUs, you would observe an unbroken PRBS sequence).

    GPIB command: CALL:HSDPa:SERVice:RBTest:HSDSchannel:DATA

  • RLC Header on HS-DSCH

    The RLC Header on HS-DSCH parameter allows you to configure whether the RLC UM block contains a valid UM header or whether that header is filled with data according to the HS-DSCH Data Pattern setting.

    Note: As part of Release 6, 3GPP introduced an alternative interpretation of the E-bit in the RLC header to improve transmission efficiency for the specific case when an SDU always fits into a PDU. The network tells the UE whether or not to use the alternative at call setup. This alternative E-bit representation is not used in the test set.

    GPIB command: CALL:HSDPa:SERVice:RBTest:HSDSchannel:RLCHeader

    This parameter can only be set when call status is Idle .

  • RB Test Mode F-DPCH State

    This setting is used to indicate whether the F-DPCH is configured instead of the associated DPCH in the downlink when an HSPA RB Test Mode call is activated.

    When this parameter is set to Off , the F-DPCH is not configured and SRBs will be mapped onto the E-DCH/DCH in the uplink and downlink respectively.

    When this parameter is set to On , the F-DPCH is configured and SRBs will be mapped onto the E-DCH/HS-DSCH in the uplink and downlink respectively.

    If FRC Type is set to one of the DC-HSDPA type (H-Set 3A, 6A, 8A, 10A or 12) or if the RB Test User Defined DC-HSDPA State is set to On , you are not allowed to set this parameter to On because F-DPCH is not available with MAC-ehs.

    This parameter can only be set when call status is Idle .

    GPIB Command: CALL:HSDPa:SERVice:RBTest:FDPChannel:STATe

  • Target Quality On F-DPCH

    This parameter determines the TPC command error rate target, which is sent to UE via the RadioBearSetup message when F-DPCH is configured.

    This setting is only available when the RB Test Mode F-DPCH State is set to On .

    GPIB Command: CALL:HSDPa:SERVice:RBTest:FDPChannel:TARGet[:QUALity]

Related Topics

Manual Operation: How Do I Change HSDPA Parameters?


HSDPA Uplink Parameters

HSDPA Uplink Parameters

Last updated: January 15, 2009

This section is only applicable to the lab application or feature-licensed test application.

All of these parameters can only be changed when the connection status is idle. To change the value of these parameters while on an HSDPA RB test mode connection, you must perform a Transport Channel Reconfiguration .

  • HS-DPCCH Gain Settings

    You can specify the change in power of the uplink signal when an ACK, NACK or CQI occurs using the DeltaACK , DeltaNACK and DeltaCQI settings, respectively. 3GPP TS 25.213 s4.2.1.2 Table 1A provides mappings of the signalled values for Delta ACK , Delta NACK and Delta CQI to the resulting quantized amplitude ratio A hs = Beta hs /Beta c . For example, a signalled value of Delta ACK = 8 corresponds to an A hs value of 30/15. A signalled value of Delta CQI = 7 corresponds to an A hs value of 24/15.

    The total change in uplink power (DPCH + HS-DPCCH) when an ACK, NACK or CQI occurs can be determined by:

    Power Change Due to HS-DPCCH = 10log 10 (Beta d ^2 + Beta c ^2 + Beta hs ^2) - 10log 10 (Beta d ^2 + Beta c ^2)

    Where Beta hs is dependent upon the DeltaACK, DeltaNACK or DeltaCQI setting (depending upon whether an ACK, NACK or CQI was transmitted, respectively).

    The following table shows the total change in uplink power for each of the four sub-tests defined in 3GPP 34.121 v7.2.0 Table C.10.1.4.

    Total Uplink Power Change for 3GPP TS 34.121 v7.2.0 Table C.10.1.4 Sub-Tests 1-4
    Sub-Test

    Delta ACK
    Delta NACK

            Delta CQI Beta c Beta d Beta hs

    Total Uplink Power Change (dB)
    1 8 8 2/15 15/15

    4/15

             0.29
    2 | 8 | 8 | 12/15 * | 15/15 | 24/15 | 4.08
    3 | 8 | 8 | 15/15 | 8/15 | 30/15 | 6.14
    8 7
    (5.7A, 5.13.1A, 5.13.1AA)

    15/15

             8/15 24/15

    4.76
    4 | 8 | 8 | 15/15 | 4/15 | 30/15 | 6.75
    * Note 4 of 34.121 Table C.10.1.4 indicates: "For sub-test 2 the Bc/Bd ratio of 12/15 for the TFC during the measurement period (TF1, TF0) is achieved by setting the signalled gain factors for the reference TFC (TF1, TF1) to Bc = 11/15 and Bd = 15/15."
    The test set does not signal gain factors using reference TFCs. Rather the test set always uses the test set's values for Bc and Bd to explicitly set betac and betad for every TFC (except TFC (TF0, TF0) which always has Bc=15 and Bd=0). Thus, setting Manual Uplink DPCH Bc to 12/15 properly configures the test set for sub-test 2.

    See Uplink DPCH Bc/Bd Control for more information on Beta c and Beta d and UE Target Power in HSDPA .

    • DeltaACK

      This parameter controls the Delta ACK power control value signalled to the UE (see 3GPP TS 25.214 s5.1.2.5A and 25.213 s4.2.1.2).

      GPIB command: CALL:HSDPa:UPLink:DACK

    • DeltaNACK

      This parameter controls the Delta NACK power control value signalled to the UE (see 3GPP TS 25.214 s5.1.2.5A and 25.213 s4.2.1.2).

      GPIB command: CALL:HSDPa:UPLink:DNACk

    • DeltaCQI

      This parameter controls the Delta CQI power control value signalled to the UE (see 3GPP TS 25.214 s5.1.2.5A and 25.213 s4.2.1.2).

      GPIB command: CALL:HSDPa:UPLink:DCQI

  • Ack-Nack Repetition Factor

    This parameter sets the Ack-Nack repetition factor (N_acknack_transmit) value signalled to the UE, which controls how often the UE repeats each ACK or NACK (see 3GPP TS 25.214 s6A.1.1).

    The test set only analyzes the ACK/NACK information sent by the UE for subframes that the test set directed data to the UE. If Ack-Nack Repetition Factor is set to >1, the UE repeats ACK/NACK information during subframes not directed to it by the test set, but the test set does not analyze this repeated ACK/NACK information.

    3GPP TS 25.214 s6A.1.1 specifies that the UE will not decode blocks from the HS-PDSCHs during subframes that correspond to HS-DPCCH subframes in which it is repeating ACK/NACK information. Thus, to prevent incorrect HSDPA BLER results, you must ensure that the minimum inter-TTI of the active HSDPA channel is greater than or equal to Ack-Nack Repetition Factor * 2 ms (so that there are sufficient unused subframes on the uplink for the ACK/NACK repeats to be transmitted without colliding with new ACK/NACK information). Otherwise, the repeated ACK/NACK information will be sent by the UE when the test set expects ACK/NACK information for the block it just transmitted to the UE (a block that the UE ignored because it was sending an ACK or NACK repeat for a prior block). The test set would then treat the ACK/NACK repeat like ACK/NACK information for the current block, resulting in incorrect HSDPA BLER results.

    GPIB command: CALL:HSDPa:UPLink:ANACk:RFACtor

  • CQI Transmission Settings

    The CQI Feedback Cycle (k) and CQI Repetition Factor settings determine how often new and repeated CQI information is transmitted on the uplink. The test set checks for a CQI transmission in every subframe and uses every CQI transmission in the calculation of Median CQI , regardless of the CQI Feedback Cycle (k) and CQI Repetition Factor settings. In other words, every CQI transmission by the UE is treated as a separate CQI report; repeated CQI information is not ignored or evaluated differently. As long as CQI Feedback Cycle (k) is greater than or equal to CQI Repetition Factor * 2ms (there are no collisions between new and repeated CQI information), the CQI repetitions do not affect the Median CQI result. If you try to set either parameter such that CQI Feedback Cycle (k) is less than CQI Repetition Factor * 2ms (except for the case when CQI Feedback Cycle (k) equals 0 ms), the test set ignores the request and posts an error.

    • CQI Feedback Cycle (k)

      This parameter sets the CQI feedback cycle (k) value signalled to the UE, which controls how often the UE transmits new CQI information on the uplink (see 3GPP TS 25.214 s6A.1.2). A value of zero means that the UE shall not transmit any CQI information.

      When CQI Feedback Cycle (k) is not zero, it must be greater than or equal to CQI Repetition Factor * 2ms.

      GPIB command: CALL:HSDPa:UPLink:CQI:FCYCle

    • CQI Repetition Factor

      This parameter sets the CQI repetition factor (N_cqi_transmit) signalled to the UE, which controls how often the UE repeats CQI information on the uplink (see 3GPP TS 25.214 s6A.1.2).

      When CQI Feedback Cycle (k) is not zero, it must be greater than or equal to CQI Repetition Factor * 2ms.

      GPIB command: CALL:HSDPa:UPLink:CQI:RFACtor

Related Topics

Manual Operation: How Do I Change HSDPA Parameters?


HSPA Information

HSPA Information

Last updated: January 15, 2009

This section is only applicable to the lab application or feature-licensed test application.

  • HSUPA Information and HSUPA Happy Bit Information


HSPA Parameters

HSPA Parameters

Last updated: January 15, 2009

This section is only applicable to the lab application or feature-licensed test application.

  • E-DCH Cell Indicator
  • HSDPA Cell Indicator
  • HSUPA Parameters
  • HSDPA Parameters

E-DCH Cell Indicator

This setting controls the E-DCH Cell Indicator in SIB5/SIB5bis. The intent of this parameter in SIB5/SIB5bis is to allow UEs to display a visual cue that HSUPA functionality is available in the current cell. According to 3GPP TS 25.331 s10.2.48.8.8, this indicator will not be used by the UE for any purposes other than for "display indication". Although release 6 added this indication to SIB5/SIB5bis as a mandatory parameter, it will only be comprehended by release 6 UEs (it will be in an opaque part of SIB5/SIB5bis to other UEs).

GPIB command: CALL[:CELL]:EDCHannel:CINDicator

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

HSDPA Cell Indicator

This setting controls the HSDPA Cell Indicator in SIB5/SIB5bis. The intent of this parameter in SIB5/SIB5bis is to allow UEs to display a visual cue that HSDPA functionality is available in the current cell. According to 3GPP TS 25.331 s10.2.48.8.8, this indicator will not be used by the UE for any purposes other than for "display indication". Although release 6 added this indication to SIB5/SIB5bis as a mandatory parameter, it will only be comprehended by release 6 UEs (it will be in an opaque part of SIB5/SIB5bis to other UEs).

GPIB command: CALL:HSDPa:CINDicator

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).


HS-SCCH Order

HS-SCCH Order

Last updated: January 6, 2012

This section is only applicable to the lab application or feature-licensed test application.

  • Send Activate Secondary Cell
  • Deactivate Secondary Cell
  • HS-SCCH Order Information (lab application only)

Activate/De-activate the Secondary Serving Cell

During a DC-HSDPA call setup, besides the serving cell, the secondary serving cell information is also communicated with the UE, and the UE is told to monitor the common channels and traffic channels of the secondary serving cell. Once a DC-HSDPA connection is established, you can activate or de-activate the secondary serving cell using HS-SCCH orders (See "Send Activate Secondary Cell" on page 1 and "Deactivate Secondary Cell" on page 1 ). Moreover, you can set to de-activate the secondary serving cell from either the serving cell or the secondary serving cell. Once the secondary serving cell is deactivated under this condition, the test set will still maintains the secondary serving cell and transmits data on the common and traffic channels of the secondary serving cell, while all HS-SCCH channels are transmitted using an alternate H-RNTI.

If a DC-HSDPA connection is released, there will be no RF power from the secondary serving cell.

When the RF Output Port is set to RF In/Out . RF signals of both the serving cell and the secondary serving cell are from the RF IN/OUT port. When RF Output Port is set to RF Out Only , RF signals of both the serving cells are from the RF OUT ONLY port.

Send Activate Secondary Cell

Use this action to send an HS-SCCH Order to activate the secondary serving cell.

You can perform this action while Secondary Serving Cell Status is Configured-Active or Configured-Inactive .

The HS-SCCH order to activate the secondary serving cell will be sent from the serving cell.

This setting is also applicable to FDD Test operating mode.

GPIB command: CALL:HSDPa:HSSCchannel:ORDer:SSCell:ACTivate:SEND[:IMMediate]]

Deactivate Secondary Cell

Use this action to send an HS-SCCH Order to de-activate the secondary serving cell.

You can perform this action while Secondary Serving Cell Status is Configured-Active or Configured-Inactive .

This setting is also applicable to FDD Test operating mode.

GPIB command: CALL:HSDPa:HSSCchannel:ORDer:SSCell:DEACtivate:SEND[:IMMediate]]

  • Send Deact Secondary Cell HS-SCCH Order From

    This parameter allows you to select which cell to use to send the HS-SCCH Order.

    This setting is also applicable to FDD Test operating mode.

    GPIB command: CALL:HSDPa:HSSCchannel:ORDer:DSSCell:FROM]

HS-SCCH Order Information

  • DTX Order Info

    This setting is to control what order will be sent on HS-SCCH to control the UL DTX operation when UL DTX is configured to the UE. According to the coding rules in 3GPP TS 25.121 V790 section 4.6C, 0 corresponds to an UL DTX deactivation order, while 1 corresponds to an UL DTX activation order.

    GPIB command: CALL:CPC:DTX:ORDer

  • DRX Order Info

    This setting is used to configure which order will be sent on HS-SCCH to control the DL DRX operation when DL DTX is configured to the UE. According to the coding rules in 3GPP 25.121 V790 section 4.6C, 0 corresponds to an DL DRX deactivation order, while 1 corresponds to an DL DRX activation order.

    GPIB command: CALL:CPC:DRX:ORDer

  • Send HS-SCCH Order

    This action causes the test set to transmit a L1 order on HS-SCCH to the UE. The order information is from DTX Order Info , DRX Order Info , HS-SCCH Less Order Info and depending on the current CPC mode.

    When CPC Mode is set to UL DTX+DL DRX or UL DTX+DL DTX+HS-SCCH-less , if the DTX Order Info is 0 but the DRX Order Info is 1 , you can not send an HS-SCCH order.

    GPIB command: CALL:CPC:HSSCchannel:ORDer:SEND[:IMMediate]

Related Topics

Dual Cell HSDPA Concepts


Common HSUPA Parameters

Common HSUPA Parameters

Last updated: November 22, 2010

This section is only applicable to the lab application or feature-licensed test application.

  • E-DCH TTI

    This setting controls the HSUPA TTI mode that will be configured. Two HSUPA TTI modes, 2ms TTI and 10ms TTI, are specified in the 3GPP Release 6 specifications. Support of 10ms TTI is mandatory for each UE, whereas support of 2ms TTI is an optional capability for each UE that is defined in terms of E-DCH category. So far, only UEs with E-DCH category 2, 4, 6 can support 2ms TTI mode (25.306 s5.1 Table 5.1g) 2ms TTI mode is used to accelerate packet scheduling and reduce latency. The HSUPA TTI mode is signaled to the UE at call setup by the RRC message.

    GPIB Command: CALL:HSUPa:EDCHannel:TTI

  • E-DCH 16QAM State

    This setting controls whether the test set signals the UE to operate in UL 16QAM mode for E-DCH. This parameter is only applicable for the E-DCH TTI to be 2 ms .

    GPIB Command: CALL:HSUPa:EDCHannel:QAM16[:STATe]

  • E-DPCCH/DPCCH Power Offset (DeltaE-DPCCH)

    This setting controls the value that is signaled in the E-DPCCH/DPCCH power offset RRC information element at call setup (also known as deltaE-DPCCH in L1). It is used by the UE to derive the Betaec value that is used to set the relative power of the E-DPCCH in the uplink, see 3GPP TS 25.213 s4.2.1.3 and UE Target Power in HSPA .

    GPIB command: CALL:HSUPa:EDPCchannel[:DPCChannel]:POFFset

    This setting can only be changed when the connection status is idle.

  • Happy Bit Delay Condition

    This setting controls the length of the Happy Bit Delay Condition (see 3GPP TS 25.321 s 11.1.8.5 and 3GPP TS 25.331 s 10.3.6.98) duration.

    This setting can only be changed when the connection status is idle.

    This setting is only applicable to the lab application.

    GPIB command: CALL:HSUPa:HBIT:DCONdition

  • Happy Bit Averaging Period

    This setting controls the averaging period used to calculate the Happy Bit Ratio . Changing this setting causes the Happy Bit Ratio result for the current averaging period to be NaN and also causes the averaging period to restart.

    This setting is only applicable to the lab application.

    GPIB command: CALL:HSUPa:HBIT:APERiod

  • E-TFCI Table Index (10 ms TTI)

    This setting determines which E-DCH Transport Block Size Table (in 3GPP TS 25.321 Annex B) the UE is instructed to use when E-DCH TTI is set to 10 ms:

    • 0: B.3 10ms TTI E-DCH Transport Block Size Table 0
    • 1: B.4 10ms TTI E-DCH Transport Block Size Table 1

    GPIB command: CALL:HSUPa:ETFCi:TINDex

    This setting can only be changed when the connection status is idle.

  • E-TFCI Table Index (2 ms TTI) / E-TFCI Table Index (2 ms TTI with 16QAM)

    This setting is only available when the E-DCH TTI is set to 2 ms .

    • When the E-DCH UL 16QAM State is set to Off , the E-TFCI Table Index (2 ms TTI) setting determines which E-DCH Transport Block Size Table (in 3GPP TS 25.321 Annex B) the UE is instructed to use when the E-DCH TTI is set to 2 ms :
      • 0: B.3 2ms TTI E-DCH Transport Block Size Table 0
      • 1: B.4 2ms TTI E-DCH Transport Block Size Table 1

      GPIB command: CALL:HSUPa:ETFCi:TINDex:MS2

      This setting can only be changed when the connection status is idle.

    • When the E-DCH UL 16QAM State is set to On , the E-TFCI Table Index (2 ms TTI with 16QAM) setting determines whether the UE is instructed to use 2ms TTI E-DCH Transport Block Size Table 2 or 3 (in 3GPP TS 25.321 v7a0 Annex B) when the E-DCH TTI is set to 2 ms .

      GPIB command: CALL:HSUPa:ETFCi:TINDex:MS2:QAM16

      This setting can only be changed when the connection status is idle.

  • E-DCH Minimum Set E-TFCI Information State

    This setting controls whether the E-DCH minimum set E-TFCI IE is signaled to the UE during HSPA call setup. The default value is set to match 3GPP TS 34.108 s9.1 and s9.2.

    GPIB Command: CALL:HSUPa:EDCHannel:ETFCi:MSET:STATe

    This setting can only be changed when the connection status is idle.

  • E-DCH Minimum Set E-TFCI (10ms TTI)

    This setting controls the value for the E-DCH Minimum Set E-TFCI parameter that is signaled to the UE at call setup when E-DCH Minimum Set E-TFCI Information State is On and E-DCH TTI is set to 10 ms. This parameter essentially sets a minimum serving grant that the UE will assume is always available to it regardless of what the network signals to it over the E-AGCH or E-RGCH.

    GPIB command: CALL:HSUPa:EDCHannel:ETFCi:MSET

    This setting can only be changed when the connection status is idle.

  • E-DCH Minimum Set E-TFCI (2ms TTI)

    This setting controls the value for the E-DCH Minimum Set E-TFCI parameter that is signaled to the UE at call setup when E-DCH Minimum Set E-TFCI Information State is On and E-DCH TTI is set to 2 ms. This parameter essentially sets a minimum serving grant that the UE will assume is always available to it regardless of what the network signals to it over the E-AGCH or E-RGCH.

    GPIB command: CALL:HSUPa:EDCHannel:ETFCi:MSET

    This setting can only be changed when the connection status is idle.

  • Reference E-TFCI Power Offset Control

    If this parameter is set to Predefined , Predefined Reference E-TFCI Power Offsets is used to configure the reference E-TFCI and power offset for the UE.If this parameter is set to Manual , the settings "Reference E-TFCI 1 to 8 States", "Reference E-TFCI" and "Reference E-TFCI Power Offset" are used to configure the reference E-TFC table for the UE.

    GPIB Command: CALL:HSUPa:ETFCi:POFFsets:REFerence:CONTrol

  • Predefined Reference E-TFCI Power Offsets

    The reference E-TFCI power offsets, which are communicated to the UE at call setup, specify a set of E-TFCI and E-DPDCH/DPCCH power offset pairs. An E-TFCI value has a one-to-one correspondence with an E-DCH block size, so the network is essentially defining the Betaed value that the UE shall use when transmitting that block size. There are 128 possible E-TFCI values, but the network can only signal a maximum of 8 E-TFCI/Power Offset pairs in the call setup signaling. These are known as the Reference E-TFCIs. The UE uses an interpolation algorithm to determine the power offsets for the remaining E-TFCIs.

    Definition 34108-01: 34.108 v7.0.0 s9.1
    E-TFCI | Power Offset
    11 | 4
    83 | 16
    Definition 34108-02: 34.108 v7.0.0 s9.2
    E-TFCI | Power Offset
    11 | 4
    Definition 34121-01: 34.121 v7.4.0 Table 5.2B.2
    E-TFCI | Power Offset
    11 | 4
    67 | 18
    71 | 23
    75 | 26
    81 | 27
    Definition 34121-02: 34.121 v7.4.0 Table 5.2B.3
    E-TFCI | Power Offset
    11 | 4
    92 | 18
    Definition 34121-03: 34.121 v8.8.0 Table 5.2B.3A
    E-TFCI | Power Offset
    67 | 18
    Definition 34121-04: 34.121 v8.10.0 Table 5.2E.2
    E-TFCI | Power Offset
    105 | 12

    116

    14

    127

    16

    GPIB command: CALL:HSUPa:ETFCi:POFFsets:REFerence

    This setting can only be changed when the connection status is idle.

  • Scheduling Information Periodicity (No Grant)

    This setting controls the length of the MAC-e periodic Scheduling Information trigger T_SING (see 3GPP TS 25.321 s11.8.1.6.1). This trigger is active when the UE's Serving Grant is set to Zero_Grant. When T_SING expires, the UE attempts to transmit Scheduling Information in a MAC-e PDU unless it has any data waiting to be transmitted in its buffer, in which case the no Scheduling Information is transmitted.

    Available settings for this parameter include No Report ( NREPort ), Every E-DCH TTI ( EETTi ), and at various TTI intervals.The 4 ms TTI is not supported on the E-DCH, but it is available as an option for this parameter. This is made due to the fact that 3GPP TS 23.331 s10.3.6.99 states that "if the Periodicity is set to 4 ms and the E-DCH is set to 10 ms, the UE shall interpret the periodicity value as 10 ms."

    Scheduling Information can be transmitted due to causes other than the T_SING trigger, see 3GPP TS s11.8.1.3 for more information.

    This setting can only be changed when the connection status is idle.

    This setting is only applicable to the lab application. This setting is fixed in the test application to No Report.

    GPIB command: CALL:HSUPa:SIPeriod:NGRant

  • Scheduling Information Periodicity (Grant)

    This setting controls the length of the MAC-e periodic Scheduling Information trigger T_SIG (see 3GPP TS 25.321 s11.8.1.6.2). This trigger is active when the UE's Serving Grant is not set to Zero_Grant. When T_SIG expires, the UE attempts to transmit Scheduling Information in a MAC-e PDU unless it has any data waiting to be transmitted in its buffer, in which case the no Scheduling Information is transmitted.

    Available settings for this parameter include No Report ( NREPort ), Every E-DCH TTI ( EETTi ), and at various TTI intervals. The 4 ms TTI is not supported on the E-DCH, but it is available as an option for this parameter. This is available due to the fact that 3GPP TS 23.331 s10.3.6.99 states that "if the Periodicity is set to 4 ms and the E-DCH is set to 10 ms, the UE shall interpret the periodicity value as 10 ms."

    Scheduling Information can be transmitted due to causes other than the T_SIG trigger, see 3GPP TS s11.8.1.3 for more information.

    This setting can only be changed when the connection status is idle.

    This setting is only applicable to the lab application. This setting is fixed in the test application to No Report.

    GPIB command: CALL:HSUPa:SIPeriod:GRANt

  • HARQ Maximum Number of Retransmissions

    This setting controls the maximum number of retransmissions a HARQ process in the UE will perform for a block of data before moving on to a new block of data.

    This setting can only be changed when the connection status is idle.

    GPIB command: CALL:HSUPa:HARQ:RETRans:MAXimum

  • E-HICH Behavior

    This setting controls what the test set sends on the E-HICH channel.

    • When set to Active , the test set sends an Ack if it received a block on the E-DPDCH that passed its CRC check or a Nack if it received a block that failed its CRC check.
    • When set to All Nacks , the test set always sends a Nack on the E-HICH regardless of whether the block passed its CRC check. While operating in this mode, the MAC-e/es layer in the test set does not pass up any blocks to the MAC-d layer. Consequently, any active PS data connection will eventually drop due to an unrecoverable RLC error.
    • When set to All Acks , the test set always sends an Ack on the E-HICH regardless of whether the block passed its CRC check. While operating in this mode, the MAC-e/es layer in the test set only passes up blocks to the MAC-d layer that pass their CRC check.

    Regardless of how this setting is configured, the test set always sends a DTX on the E-HICH using an alternate E-HICH signature (as described in HSPA Downlink Channel Details ) if the UE did not transmit a block during a particular frame.

    GPIB command: CALL[:CELL]:EHIChannel:BEHavior

  • E-TFCI Boost Information State

    This setting controls whether the test set signals the E-TFC Boost Info IE to the UE. When set to Off, the boosting of E-DPCCH is disabled.

    This setting can only be changed when the connection status is idle.

    GPIB command: CALL:HSUPa:ETFCi:BOOSt:INFormation[:STate]

  • E-TFCI Boost Value

    This setting is only available when the E-TFCI Boost Information State is set to On . E-TFCI Boost Value indicates the E-TFCI threshold beyond which boosting of E-DPCCH is enabled.

    This setting can only be changed when the connection status is idle.

    GPIB command: CALL:HSUPa:ETFCi:BOOSt[:VALue]

  • Delta T2TP

    This setting is only available when the E-TFCI Boost Information State is set to On and the E-TFCI Boost Value is other than 127 . The quantization values for each signalled value are defined in 3GPP TS 25.213v770 table 1B.0 as follows:

    This setting can only be changed when the connection status is idle.

    GPIB command: CALL:HSUPa:ETFCi:BOOSt:DT2Tp

  • BetaEd Gain E-AGCH Table Selection

    This setting is only applicable when the E-DCH TTI is 2 ms and the E-DCH 16QAM State is set to On .

    This setting determines which table in the 3GPP standard 25.212 v7b0 the UE will use to interpret the absolute grant value indices signalled on E-AGCH.

    • When it is set to 0 , the UE uses Table 16B: Mapping of Absolute Grant Value;
    • When it is set to 1 , the UE uses Table 16B.1: Alternative Mapping of Absolute Grant Value.

    This setting can only be changed when the connection status is Idle .

    GPIB command: CALL:HSUPa:BEDGain:EAGChannel:TSELection

  • E-DPDCH Power Calculation Formula

    This setting controls the formula the UE uses to calculate the E-DPDCH power.

    This setting can only be changed when the connection status is idle.

    GPIB command: CALL:HSUPa:EDPDchannel:PCFormula

HSUPA Fixed Values

There are several HSUPA parameters that have fixed values when on an HSPA connection:

  • PLnonmax = 0.84
  • E-DCH MAC-d flow power offset = 0
  • deltaHARQ = 0
  • Power Offset for Scheduling Info = 0
  • Secondary E-RNTI: not assigned
  • Primary/Secondary Grant Selector: Primary
  • Transmission Grant: Scheduled
  • E-RGCH Signature Sequence = 0 (Alternate E-RGCH Signature Sequence = 3)
  • E-HICH Signature Sequence = 1 (Alternate E-HICH Signature Sequence = 2)
  • 2- and 3-Index-Step Threshold: not present
  • HARQ RV Configuration = rv0

Related Topics

HSUPA Parameters


HSUPA Concepts

HSUPA Concepts

Last updated: January 15, 2009

This section is only applicable to the lab application or feature-licensed test application.

  • HSUPA Transport and Physical Channels
  • UE Categories
  • Fast Scheduling
  • Fast Retransmit
  • MAC Layer

HSUPA Transport and Physical Channels

HSUPA (High Speed Uplink Packet Access) is essentially the equivalent of HSDPA for the uplink (see HSDPA Concepts ). It adds an efficient mechanism for transferring bursty packet data traffic over the W-CDMA uplink. HSUPA is officially referred to as E-DCH (Enhanced Dedicated Channel) in the specifications, although in the industry it is typically referred to as HSUPA. The term HSPA (High Speed Packet Access) has become the predominant term used in the industry to refer to both HSDPA and HSUPA as a single entity. Although they are technically independent features, HSUPA is currently always used alongside HSDPA, hence the popularity of the HSPA term.

HSUPA was added as part of Release 6 of the 3GPP specifications. It was designed to be backwards-compatible with existing functionality, so a non-HSUPA UE can still communicate with a HSUPA-capable base station and vice versa. Similar to HSDPA, HSUPA adds a set of new physical channels that provide efficient transfer of packet data traffic over a new transport channel, the E-DCH (Enhanced Dedicated Channel).

In the uplink the following channels are added:

  • E-DPDCH, Enhanced Dedicated Physical Data Channel -This carries the user data bits to the network (the bits from this channel end up being delivered up to MAC-e/es through the E-DCH transport channel). This channel is variable spreading factor and variable in number. The UE will select the most appropriate configuration based on its current non-scheduled grant or scheduled Serving Grant and the amount of data it has waiting to be sent. Maximum HSUPA data rate is achieved with 2*SF2 codes plus 2*SF4 codes.
  • E-DPCCH, Enhanced Dedicated Physical Control Channel - This channel contains the L1 control information necessary for the base station to be able to demod and decode the variable E-DPDCH.

In the downlink the following channels are added:

  • E-HICH, Enhanced Hybrid Indicator Channel - This signals the ACKs and NACKs to the UE.
  • E-AGCH, Enhanced Absolute Grant Channel - This is a shared channel that signals absolute values for the Serving Grant. Each UE is assigned a unique E-RNTI identity at call setup which is used to direct transmissions on the E-AGCH to specific devices.
  • E-RGCH, Enhanced Relative Grant Channel - This signals the incremental up/down/hold adjustments to the UE's Serving Grant.

The E-RGCH and E-HICH share the same code space in the OVSF tree. Orthogonality between the two channels is provided by the use of orthogonal 40 bit signatures that can be transmitted as-is or inverted to signal +1 or -1. Not transmitting a signature in a TTI results in a 0 being assumed by the UE (this is also called DTX in the specifications). The definition of the E-HICH and E-RGCH channels provide the mapping from -1, 0, +1 to the logical values of Up/Down/Hold or ACK/NACK. As there are a total of 40 orthogonal signatures available it is possible to multiplex up to 20 UEs onto a single E-HICH/E-RGCH OVSF code.

UE Categories

3GPP TS 25.306 Table 5.1g defines a set of HSUPA UE categories that restrict the UE's data rate by specifying attributes such as the maximum number of E-DPDCHs, minimum E-DPDCH spread factor, 10 ms vs. 2 ms TTI support, etc.

Fast Scheduling

Although HSUPA is similar in many respects to HSDPA, HSUPA has one very significant difference which the name of the new transport channel, Enhanced Dedicated Channel, hints at. Unlike HSDPA, HSUPA does not utilize a shared channel for data transfer in the uplink. In W-CDMA each UE already uses a unique scrambling code in the uplink so each UE already has a dedicated uplink connection to the network with more than ample code channel space in that connection. This is in contrast to the downlink where the Node B uses a single scrambling code and then assigns different OVSF channelization codes to different UEs. The shared resource in the uplink is actually the interference level at the Node B, which the network manages through the fast closed loop power control algorithm. The fact that the UE has a dedicated connection to the network in the uplink influences the design of HSUPA quite considerably. The goals of HSUPA were to support fast scheduling (which allows the network to rapidly change which UEs are transmitting and at what rate) and to reduce the overall transmission delay. Transmission delay reduction is achieved through fast hybrid ARQ retransmissions, in a manner very similar to HSDPA, and an optional shorter 2ms TTI. As the primary shared resource on the uplink is the total power arriving at the base station, HSUPA scheduling is performed by directly controlling the maximum amount of power that a UE can use to transmit at any given point in time.

The network has two methods for controlling the UE's transmit power on the E-DPDCH; it can either use a non-scheduled grant or a scheduled grant. In the non-scheduled grant the network simply tells the UE the maximum block size that it can transmit on the E-DCH during a TTI. This block size is signaled at call setup and the UE can then transmit a block of that size or less in each TTI until the call ends or the network modifies the non-scheduled grant via an RRC reconfiguration procedure. The block size deterministically maps to a power level, which is also configured by the network during call setup. The non-scheduling grant is most suited for constant-rate delay-sensitive application such as voice-over-IP.

The more interesting method is the scheduled grant. In this case the UE maintains a Serving Grant that it updates based on information received from the network. The Serving Grant directly specifies the maximum power the UE can use on the E-DPDCH in the current TTI. As E-DCH block sizes map deterministically to power levels, the UE can translate its Serving Grant to the maximum E-DCH block size it can use in a TTI (the mapping of power levels is determined by the E-TFCI Reference Power Offsets that are signaled at call setup).

There are two ways the network can control the UE's Serving Grant. The first is through an absolute grant, transmitted on the shared E-AGCH downlink channel, which signals a specific, absolute number for the Serving Grant. The other way is through relative grants, transmitted using the downlink E-RGCH channels, that incrementally adjust a UE's Serving Grant up or down from its current value. At any given point in time the UE will be listening to a single E-AGCH from its serving cell and to one or more E-RGCHs. The E-AGCH is a shared channel so the UE will only update its Serving Grant if it receives a block on the E-AGCH that is destined for it (the E-RNTI identity signaled at call setup is used on the E-AGCH to direct transmissions to particular UEs). The E-RGCH is also shared by multiple UEs but on this channel the UE is listening for a particular orthogonal signature rather than a higher layer identity. If it does not detect its signature in a given TTI it interprets this as a "Hold" command, and thus makes no change to its Serving Grant.

Typically each cell that the UE is in soft handover with will transmit an E-RGCH (although it is possible for the UE to receive only a DPCH from a cell that it is in soft handover with). HSUPA has the concept of a serving Radio Link Set (RLS) and a non-serving Radio Link Set. The group of cells from which the UE can soft combine E-RGCH commands form the serving RLS. The serving RLS by definition includes the serving cell from which the UE is receiving the E-AGCH. Obviously the cells in the serving RLS must all transmit the same E-RGCH command each TTI so typically the serving RLS consists of those cells that are controlled by the same Node B that also controls the serving cell. All other cells that transmit an E-RGCH to the UE form the non-serving RLS.

Cells in the serving RLS can give E-RGCH commands to raise, lower or hold the current Serving Grant. Cells in the non-serving RLS can only give hold or down commands. Thus from the perspective of cells in the non-serving RLS the E-RGCH is primarily an overload control mechanism. If the UE receives a "Down" command from any cell then it must lower its Serving Grant regardless of what the other cells say, if it receives a "Hold" from all cells it will leave its Serving Grant unchanged and if it receives an "Up" command and no "Down" commands (all the cells either transmit "Up" or "Hold") then it will raise its Serving Grant. Up and Down commands are communicated on the E-RGCH transmitting a 40 bit orthogonal signature. Hold is actually communicated by the absence of the expected signature. Although the 3GPP standards define how the network communicates a Serving Grant to a UE, the algorithm by which the network determines which commands should be sent on the E-AGCH/E-RGCH is not defined. This is left for the network infrastructure vendors and operators to design, much the same as was done with the algorithms that trigger handovers.

However, measurement reporting functionality is defined in the standards to allow the UEs to communicate their current status which can then be fed into the algorithm. UE status reporting takes two forms, Scheduling Information transmitted on the E-DCH along with the user data, and a happy bit transmitted on the E-DPCCH L1 physical channel.

The Scheduling Information provides an indication of how much data is waiting to be transmitted in the UE and how much additional network capacity the UE could make use of (if the UE is already transmitting at full power then it would be wasteful to increase its Serving Grant as the UE would be unable to make use of the additional power). This Scheduling Information is typically tacked onto the end of the user data at the end of the MAC-e PDU that is transmitted over the E-DCH. It is sent both opportunistically in bits that would otherwise be spare and periodically as configured by the RRC layer at call setup.

The other status reporting mechanism is the happy bit. This is a single bit that is transmitted on the E-DPCCH physical channel. It can only indicate "happy" or "unhappy" but it is sent every time the UE transmits to the network. A UE considers itself to be unhappy if it is not transmitting at maximum power and it cannot empty its transmit buffer with the current Serving Grant within a certain period of time. The period of time is known as the Happy Bit Delay Condition and is signaled by the RRC layer during call setup. Thus the happy bit is a crude indication of whether the UE could make good use of additional uplink power.

Fast Retransmit

The fast retransmit goal of HSUPA is achieved through a HARQ scheme that runs inside the Node B and works much the same as it does in HSDPA. There are a number of stop-and-wait HARQ processes that operate in parallel (4 for 10ms TTI and 8 for 2ms TTI). Each time the UE transmits, the receiving HARQ process in the network will attempt to decode the data block. If it succeeds, the base station transmits an ACK to the UE over the E-HICH channel and that HARQ process in the UE will move onto the next data block. If the decode fails then the base station transmits a NACK to the UE on the E-HICH. If the maximum number of retransmissions has not been reached then the UE will retransmit the data block again. The UE will either use chase combining (transmission of the exact same bits again) or incremental redundancy (transmission of a different set of bits) depending on how the RRC layer configured the link at call setup. The HARQ process that transmits in a particular frame is determined from the current SFN (this is unlike HSDPA where each HARQ process transmits in a round-robin fashion).

MAC Layer

HSUPA adds a new transport channel, the E-DCH. This layer 1 transport channel connects up to a new MAC sublayer, MAC-e/es. In the UE MAC-e/es are considered one single sublayer, however in the network side MAC-e and MAC-es are considered separate. This is to allow the more real-time critical functionality of MAC-e to be placed into the Node-B and allow MAC-es to run in the RNC.

In the network the MAC-e sublayer contains the HARQ processes, some demultiplexing functionality and the fast scheduling algorithm. MAC-es primarily provides reordering and combining and also disassembly of MAC-es PDUs into individual MAC-d PDUs. HSUPA supports soft handover so it is possible that one or more Node Bs will successfully receive the same MAC-e block from the UE and forward it on to the RNC. MAC-es is where these duplicates are removed. Similarly due to the parallel nature of the HARQ processes it is possible for MAC-e PDUs to arrive out of order so the MAC-es sublayer performs reordering to ensure MAC-d sees PDUs in the order they were originally transmitted (this is important to avoid triggering of spurious retransmissions at the RLC layer).

In the UE, MAC-e and MAC-es are combined into a single MAC-e/es sublayer. This sublayer contains the HARQ processes, performs selection of the uplink data rate based on maintaining the current Serving Grant and provides the status reporting. In any given frame the MAC-e/es layer in the UE will select the block size that it will use for the next transmission on the E-DCH. The choice of block size is determined by the amount of data waiting to be transmitted, the minimum allowed spreading factor (which is signaled at call setup) and the current Serving Grant. What this means is that in a particular TTI the UE has a large range of block sizes that it can pick from. Each block size is transmitted using a specific amount of power which increases as the number of bits in the block goes up. As the network has no way to predict which block size the UE will choose it also has no way to predict the power level at which the UE will transmit. This ultimately means that the base station has to be able to demodulate and make accurate measurements across a wide dynamic range of power levels.

Related Topics

W-CDMA Concepts


HSUPA Information and HSUPA Happy Bit Information

HSUPA Information and HSUPA Happy Bit Information

Last updated: November 25, 2010

This topic is only applicable to the lab application or feature-licensed test application.

This topic includes information on:

  • HSUPA Information
  • HSUPA Happy Bit Information

HSUPA Information

The HSUPA Information window displays counters to help you monitor the HSUPA connection status. The results are continually updated. When one of the following events occurs, the counters reset to zero and then resume counting:

  • You press the MEASUREMENT RESET key ( SYSTem:MEASurement:RESet ).
  • You select Clear UE Info ( CALL:MS:REPorted:CLEar[:ALL]<[:SELected]|:WCDMa> ).
  • You change operating mode.
  • You establish a new connection in active cell operating mode (or change the Channel Type from 12.2k RMC + HSPA in FDD Test Operating Mode ).
  • NACKs Transmitted or ACKs Transmitted reaches 150,000.

The following HSUPA information are displayed:

  • Last Block Size

    This result returns the size of the E-DCH transport block that most recently passed its CRC check and resulted in the test set transmitting an Ack on the E-HICH (note that when E-HICH Behavior is set to All Nacks , no Acks are ever sent on the E-HICH).

    This result is updated every 0.5 seconds. If a block has not been Ack'd on the E-HICH during the most recent 0.5 s, then 9.91E+37 (NAN) is returned. NAN is also returned if an E-DCH is not currently active (because a call is not active or because the current call does not utilize HSUPA).

    GPIB command: CALL:STATus:EDCHannel[:CELL]:BLOCk:SIZE[:LAST]?

  • Avg Block Size

    This result returns the average size of all the E-DCH transport blocks that passed their CRC check and resulted in the test set transmitting an Ack on the E-HICH (since the result was last reset). Note that when E-HICH Behavior is set to All Nacks , no Acks are ever sent on the E-HICH.

    This result is updated every 0.5 s and is rounded to the nearest integer number of bits (0.5 bits is rounded down).

    GPIB command: CALL:STATus:EDCHannel[:CELL]:BLOCk:SIZE:AVERage?

  • Min Block Size

    This result returns the smallest E-DCH transport block that passed its CRC check and resulted in the test set transmitting an Ack on the E-HICH (since the result was last reset). Note that when E-HICH Behavior is set to All Nacks , no Acks are ever sent on the E-HICH.

    This result is updated every 0.5 s.

    GPIB command: CALL:STATus:EDCHannel[:CELL]:BLOCk:SIZE:MINimum?

  • Max Block Size

    This result returns the largest E-DCH transport block that passed its CRC check and resulted in the test set transmitting an Ack on the E-HICH (since the result was last reset). Note that when E-HICH Behavior is set to All Nacks , no Acks are ever sent on the E-HICH.

    This result is updated every 0.5 s.

    GPIB command: CALL:STATus:EDCHannel[:CELL]:BLOCk:SIZE:MAXimum?

  • Queued Relative Grants

    This result contains the number of "Up" or "Down" relative grant commands in the relative grant queue (see Relative Grant Transmission ).

    GPIB command: CALL:STATus:SGRant:RELative:QUEued:COUNt?

  • Cur Betaed Gain E-AGCH Table

    This result indicates the BetaEd Gain E-AGCH Table currently in use by the UE to interpret the absolute grant value indices signalled on E-AGCH.

    GPIB command: CALL:STATus:BEDGain:EAGChannel:TSELection?

  • Rep EDCH Cat/Ext

    The two slash-separated results indicate the UE reported E-DCH Category and E-DCH Category Extension that the UE supports. These results are from the RRC Connection Setup Complete message (see 3GPP TS 25.306 s5.1 Table 5.1g).

    If the UE did not report an E-DCH Category or E-DCH Category extension, then Unreported is displayed. For the UE reported E-DCH Category, if the UE is not capable of E-DCH (the PhysicalChannelCapability-edch-r6 information element is present but the "unsupported" is indicated) then Unsupported is displayed.

    Each of These two results will be reset to Unreported by Clear UE Info action.

    GPIB command: CALL:HSUPa:MS:REPorted:EDCHannel:CATegory? / CALL:HSUPa:MS:REPorted:EDCHannel:CATegory:EXTension?

  • Throughput

    This result returns the average data rate received on the E-DCH since the result was last reset. The average data rate is calculated by taking the total number of bits in blocks that passed their CRC and were Ack'd on the E-HICH, divided by the time since the result was last reset. Blocks that passed their CRC but were Nack'd because E-HICH Behavior is set to All Nacks are not counted.

    This result is updated every 0.5 s.

    GPIB command: CALL:STATus:EDCHannel[:CELL]:IBTHroughput?

  • ACKs Transmitted

    This result returns the total number of Acks transmitted on the E-HICH since the result was last reset. This includes Acks transmitted for blocks with failed CRC checks when E-HICH Behavior is set to All Acks .

    This result is updated every 0.5 s.

    GPIB command: CALL:STATus:EHIChannel[:CELL]:ACK[:COUNt]?

  • NACKs Transmitted

    This result returns the total number of Nacks transmitted on the E-HICH since the result was last reset. This includes Nacks transmitted for blocks with passed CRC checks when E-HICH Behavior is set to All Nacks .

    This result is updated every 0.5 s.

    GPIB command: CALL:STATus:EHIChannel[:CELL]:NACK[:COUNt]?

  • E-HICH Behavior

    This result indicates the E-HICH Behavior setting's current value.

  • Current E-TFCI Boost

    This result indicates the current E-TFCI Boost being used.

    GPIB command: CALL:STATus:ETFCi:BOOSt?

  • Last Received E-TFCI

    This result returns the most recently received E-TFCI value that was decoded from a non-DTX'd E-DPCCH frame. If an E-DPCCH/E-DPDCH is not active on the current call type (or if Channel Type is not set to 12.2k RMC + HSPA in FDD Test Operating Mode ) or if an E-TFCI has not yet been successfully received since the E-DPCCH/E-DPDCH was activated, then 9.91E+37 (NAN) is returned.

    This result is updated every 0.5 s.

    See also E-TFCI Recording .

    GPIB command: CALL:STATus:ETFCi[:LAST]?

HSUPA Happy Bit Information

This section is only applicable to the lab application.

These results are cleared by the Clear UE Info action.

  • Happy Bit Delay Cond

    This result returns the duration of the Happy Bit Delay Condition .

    GPIB command: CALL:HSUPa:HBIT:DCONdition

  • Happy Bit Avg Period

    This result returns the Happy Bit Averaging Period .

    GPIB command: CALL:HSUPa:HBIT:APERiod

  • Happy Bit Ratio

    The happy bit is a single bit that indicates whether the UE is happy with its current Serving Grant. The happy bit is reported on the E-DPCCH and therefore is sent each time the UE transmits a data block on the E-DCH. The definition of happy, for a UE on an HSUPA call is whether it can empty its buffers within the Happy Bit Delay Condition period using the Serving Grant. If the UE cannot empty its buffers within that time and the transmit power can be increased, then it considers itself unhappy.

    This result returns the percentage of sampled happy bits to the total number of sample results received during the most recent Happy Bit Averaging Period . For a sample to be included in this result, it must have arrived in a non-DTX'd E-DPCCH frame. If no samples are received, or a complete Happy Bit Averaging Period has not occurred since the E-DCH was started, the test set will return NaN.

    This value is reset to NaN when the following actions occur: a new call is started, Clear UE Info or Measurement Reset is pressed, the Operating Mode is changed, the Happy Bit Averaging Period is changed, or when the Channel Type is changed to or from 12.2k RMC + HSDPA . Clear UE Info forces the test set to start calculating a new Happy Bit Ratio result using a new Happy Bit Averaging Period .

    This result is only updated at the end of a Happy Bit Averaging Period .

    GPIB command: CALL:HSUPa:MS:REPorted:HBIT:RATio?

  • Last Happy Bit

    This result returns the most recent UE reported happy bit that arrived in a non-DTX'd E-DPCCH frame.

    This result is updated every 0.5 s. If no happy bit was received during the last 0.5 seconds, then the test set returns None . Possible reasons why no happy bit was received are because the UE did not transmit during this time or because an E-DCH is not active (either because the UE is not on a call or it is on a call but the E-DCH is not active).

    This value is reset to None when the following actions occur: a new call is started, Clear UE Info or Measurement Reset is pressed, the Operating Mode is changed, the Happy Bit Averaging Period is changed, or when the Channel Type is changed to or from 12.2k RMC + HSDPA .

    GPIB command: CALL:HSUPa:MS:REPorted:HBIT[:LAST]?

Manual Operation

To access the
 HSUPA Information
or the HSUPA Happy Bit Information from the front panel, press
Call Setup
 and then press the left
 More
key until you reach the
 Call Control 2 of 5
menu, select
 Additional Screens
(
F1
), then
 HSPA Information
(
F2
). Some of the

 HSUPA Information
and HSUPA Happy Bit Information
results are also available on the main
 Call Setup Screen
.

Related Topics

HSDPA Information


HSUPA Parameters

HSUPA Parameters

Last updated: January 15, 2009

This section is only applicable to the lab application or feature-licensed test application.

  • HSUPA PS Data Setup (lab application only)
  • HSUPA RB Test Mode Setup
  • Common HSUPA Parameters
  • Serving Grant
  • E-TFCI Recording
  • E-RNTI Parameters

E-TFCI Recording

The test set allows you to record a sequence of E-TFCI values sent by the UE. Only E-TFCI values corresponding to blocks that pass their CRC check are recorded.

Before you Start Recording E-TFCI Values , set the E-TFCI Rec Count to the number of E-TFCI values you wish to record. You can then view the results on the E-TFCI Recording Information screen.

See also: Last Received E-TFCI and Send Step Up/Down TPC Bit Pattern .

  • E-TFCI Rec Count

    This setting controls how many E-TFCI values to record when the Start Recording E-TFCI Values action is initiated.

    GPIB command: CALL:HSUPa:ETFCi:RECord:COUNt

    This setting can only be changed when E-TFCI Recording State is idle.

  • Start Recording E-TFCI Values

    This action immediately starts E-TFCI recording. You must be on an HSPA connection to record E-TFCI values. Upon successful start of E-TFCI recording, Recorded E-TFCI Values and Number of E-TFCI Results Recorded are set to their default values, and E-TFCI Recording State is set to Recording .

    GPIB command: CALL:HSUPa:ETFCi:RECord:STARt

  • Stop Recording E-TFCI Values

    This action stops E-TFCI recording. E-TFCI recording is also automatically stopped if the call ends.

    GPIB command: CALL:HSUPa:ETFCi:RECord:STOP

E-RNTI Parameters

  • Primary E-RNTI (Hex)

    This setting controls the primary E-RNTI that the UE is assigned when an E-DCH is configured (see 3GPP TS 25.331 s10.3.3.10a). When the test set wants to send an absolute grant to the UE, it transmits the E-AGCH using the primary E-RNTI (the Alternate E-RNTI (Hex) is used on the E-AGCH for all other frames).

    Primary E-RNTI (Hex) and Alternate E-RNTI (Hex) cannot be set to the same value.

    GPIB command: CALL:HSUPa:ERNTi[:PRIMary]

    This setting can only be changed when the connection status is idle.

  • Alternate E-RNTI (Hex)

    This setting controls the alternate E-RNTI that the test set uses on the E-AGCH when it does not wish to transmit to the UE on that channel (see HSPA Downlink Channel Details for more information).

    Primary E-RNTI (Hex) and Alternate E-RNTI (Hex) cannot be set to the same value.

    GPIB command: CALL:HSUPa:ERNTi:ALTernate

    This setting can only be changed when the connection status is idle.

Related Topics

HSPA Parameters


HSUPA PS Data Setup

HSUPA PS Data Setup

Last updated: November 9, 2010

This section is only applicable to the lab application.

  • PS Data E-RGCH Information State

    This setting determines whether the E-RGCH Information IE is signaled to the UE during the setup of a PDP context. If this IE is signaled, the UE will listen for up/down/hold commands on the E-RGCH. If it is not signaled, then the UE will not listen to an E-RGCH (and thus will determine its serving grant solely based upon the E-AGCH).

    Note, this setting only affects whether the UE will listen to an E-RGCH. It does not affect whether an E-RGCH is transmitted by the test set. To transmit an E-RGCH from the test set, you must set HSPA Cell 1 Connected E-RGCH Level to on (it is on by default).

    GPIB command: CALL:HSUPa:SERVice:PSData:ERGChannel:INFormation[:STATe]

    This setting can only be changed when the connection status is Idle.

  • PS Data E-DPDCH Max Channel Codes

    This setting is used to control the value for E-DPDCH Max Channelisation Codes that is signaled to the UE during the setup of a PDP context that uses a 10 ms TTI on the E-DCH.

    GPIB command: CALL:HSUPa:SERVice:PSData:EDPDchannel:CCODes:MAX

    This setting can only be changed when the connection status is Idle.

  • PS Data Max Number of HARQ Retransmissions

    GPIB command: CALL:HSUPa:HARQ:RETRans:MAXimum

  • PS Data SRB Mapping Mode

    GPIB command: CALL:SERVice:PSData:SRBearer:MAPPing

  • PS Data MAC-d PDU Size

    GPIB command: CALL:HSUPa:SERVice:PSData:MACD:PDUSize

Related Topics

HSUPA Parameters


HSUPA RB Test Mode Setup

HSUPA RB Test Mode Setup

Last updated: November 19, 2010

This section is only applicable to the lab application or feature-licensed test application.

  • RB Test Mode E-RGCH Information State

    This setting determines whether the E-RGCH Information IE is signaled to the UE during HSPA RB Test Mode call setup. If this IE is signaled, the UE will listen for up/down/hold commands on the E-RGCH. If it is not signaled, then the UE will not listen to an E-RGCH (and thus will determine its serving grant solely based upon the E-AGCH).

    Note, this setting only affects whether the UE will listen to an E-RGCH. It does not affect whether an E-RGCH is transmitted by the test set. To transmit an E-RGCH from the test set, you must set HSPA Cell 1 Connected E-RGCH Level to on (it is off by default).

    GPIB command: CALL:HSUPa:SERVice:RBTest:ERGChannel:INFormation[:STATe]

    This setting can only be changed when the connection status is Idle.

  • RB E-DPDCH Max Channel Codes (12.2k + HSPA)

    This setting is used to control the value for E-DPDCH Max Channelisation Codes that is signaled to the UE during the setup of an HSPA RB Test Mode call.

    GPIB command: CALL:HSUPa:SERVice:RBTest:EDPDchannel:CCODes:MAX

    This setting can only be changed when the connection status is Idle.

  • RB E-DPDCH Max Channel Codes (HSPA)

    This setting controls the value for E-DPDCH Max Channelisation Codes that is signaled to the UE at the setup of an RB Test Mode call when Channel Type is set to HSPA . The default value for this parameter is set to match 3GPP TS 34.108 s9.2.This parameter is only applicable to the channel types of HSPA.

    GPIB command: CALL:HSUPa:SERVice:RBTest:EDPDchannel:CCODes:MAX:HSPA

  • E-DCH RLC SDU Size

    This setting controls the uplink RLC SDU size specified for the E-DCH transport channel in the Close UE Test Loop message sent during the setup of an HSPA RB Test Mode call.

    To achieve 2 Mbps in the uplink with the downlink configured to H-Set 1 QPSK (534 kbps), set E-DCH RLC SDU Size to at least 4 x 2936 bits = 11744 bits. Note that you must also set RB Test Mode E-DPDCH Max Channel Codes = 2SF2 , grant the UE a large enough serving grant to allow this data rate, and ensure that the UE's transmit power is low enough that the HSUPA channels do not get scaled down. See HSPA Radio Bearer Test Mode for more information.

    GPIB command: CALL:HSUPa:SERVice:RBTest:RLCSdu:SIZE

    This setting can only be changed when the connection status is Idle.

Related Topics

HSUPA Parameters


Serving Grant

Serving Grant

Last updated: November 22, 2010

This section is only applicable to the lab application or feature-licensed test application.

To change the UE's serving grant while on a connection you can send a single shot or pattern absolute grant on the E-AGCH, perform a Transport Channel Reconfiguration (see TCR Absolute Grant ) or send the UE up/down commands on the E-RGCH.

Relative Grant Transmission

The test set can only transmit to the UE on the E-RGCH when it knows the UE will act on the command. Thus, the test set maintains a FIFO (First-In-First-Out) queue of relative grant commands that are transmitted on the E-RGCH as opportunities arise (the test set transmits using the alternate E-RGCH signature in all other E-RGCH frames, which signifies a "Hold" to the UE under test, see HSPA Downlink Channel Details ). At each transmission opportunity, the oldest relative grant command is removed from the relative grant queue and transmitted to the UE on the E-RGCH. Note that queued relative grant commands are not collapsed by the test set (in other words, two "Up" commands followed by one "Down" command are not transmitted as a single "Up"; the test set transmits every relative grant command).

According to 3GPP TS 25.321 s11.8.1.3.1, the UE will only act on a relative grant command if all of the following are true:

  • The current serving grant is not set to ZERO_GRANT.
  • The UE has not received a new absolute grant within 1 HARQ Round Trip Time (40 ms for 10 ms TTI, 16 ms for 2 ms TTI).
  • The UE was expecting to receive an ack/nack on the E-HICH at the same time as the network sent the E-RGCH command (an ack/nack sent for a E-DPDCH transmission that just contained MAC-e Scheduling Information alone does not meet this criteria).

Thus, the test set will only transmit a relative grant command on the E-RGCH during a TTI that also includes an ack/nack on the E-HICH (for a block that does not consist of only Scheduling Information) and if the most recent E-AGCH transmission occurred more than 40 ms ago and the most recent absolute grant command was not ZERO_GRANT. Note that when AG Mode is set to Pattern , the E-AGCH is transmitted continuously unless one or more of the pattern values is set to DTX (Alt E-RNTI) , thus causing all relative grant commands to be queued.

The relative grant queue is reset to empty when the connection is ended (or if the connection changes to a non-HSPA connection), or when the Clear Queued Relative Grants action is initiated.

The relative grant queue holds up to 1000 relative grant commands; any additional commands are discarded and an error is posted. You can determine how many relative grant commands are in the queue using the Queued Relative Grants result.

Serving Grant Parameters

  • AG Mode

    The test set supports two modes of operation on the E-AGCH, Single Shot and Pattern .

    • When AG Mode is set to Single Shot , when you initiate the Send Single Shot AG action the Single Shot AG absolute grant value is sent to the UE.
    • When AG Mode is set to Pattern , the test set transmits a continuous sequence of values to the UE over the E-AGCH. The values that are transmitted to the UE are defined by AG Pattern Parameters . These absolute grant values are alternately sent every TTI (10 ms). Upon transition to the Pattern state, Absolute Grant Pattern - Value 1 is always the first value transmitted on the E-AGCH, always on an even SFN. Upon transition away from the Pattern state (to Single Shot ), the last value sent to the UE is indeterminate as the transmission of the pattern is ended immediately. Note that when AG Mode is set to Pattern the E-AGCH is transmitted continuously to the UE (unless one or more of the pattern values is set to DTX (Alt E-RNTI) ), thus causing all relative grant commands to be queued (see Relative Grant Transmission ).

    GPIB command: CALL:HSUPa:SGRant:ABSolute:MODE

  • Single Shot AG

    Commonly, this setting determines the next absolute grant sent to the UE on the E-AGCH when the Send Single Shot AG action is initiated ( AG Mode must be set to Single Shot ). The UE interprets this value according to the table in 3GPP TS 25.212 s4.10.1A.1.

    GPIB command: CALL:HSUPa:SGRant:ABSolute:SSHot[:VALue]

    When the E-DCH TTI is 2 ms , the E-DCH 16QAM State is On and the BetaEd Gain E-AGCH Table Selection is set to 1, an alternate set of Single Shot AG is available to sent to the UE. The UE interprets the value according to 3GPP TS 25.212 v7b0 Table 16B.1. See also the GPIB command: CALL:HSUPa:SGRant:ABSolute:ALTernative:SSHot[:VALue] .

  • Send Single Shot AG

    This action causes the test set to immediately transmit the current value of the Single Shot AG setting to the UE on the E-AGCH (when AG Mode is set to Single Shot and an HSPA connection is active). The value is only transmitted over a single TTI and has a scope of "All HARQ Processes" (the only legal value when 10 ms TTI is used). If the absolute grant is to be sent during the same frame as a relative grant then the absolute grant is sent and the relative grant is pended (see Relative Grant Transmission ).

    GPIB command: CALL:HSUPa:SGRant:ABSolute:SSHot:SEND[:IMMediate]

  • RB Setup AG

    Commonly, this setting controls the serving grant that the UE is given during call setup in the RB Setup message. This serving grant is specified in terms of the 3GPP TS 25.321 s9.2.5.2.1.1 Scheduling Grant Table (and is not determined by the 3GPP TS 25.212 s4.10.1A.1 table that is used to communicate absolute grants on the E-AGCH). It is set to the highest possible value by default to give the UE full access to the entire uplink.

    GPIB command: CALL:HSUPa:SGRant:ABSolute:RBSetup[:VALue]

    When the E-DCH TTI is 2 ms and the E-DCH 16QAM State is set to On , an alternate set of RB Setup Absolute Grant (16QAM) values is available. See also the GPIB command: CALL:HSUPa:SGRant:ABSolute:RBSetup:QAM16[:VALue] .

    This setting can only be changed when the connection status is idle.

  • AG Pattern Parameters

    Commonly, the AG Pattern Parameters are provided as follows:

    • Absolute Grant Pattern - Length

      When the AG Mode is Pattern , this parameter controls the number of values in a pattern on the E-AGCH that are transmitted to the UE. The values in the pattern are taken consecutively from the list. For example, if it is set to 4, then the first 4 values (Value1, Value 2, Value 3, Value 4) are sent consecutively.

      GPIB Command: CALL:HSUPa:SGRant:ABSolute:PATTern:LENGth

    • Absolute Grant Pattern Values

      Each of these setting determines the corresponding value in the pattern of absolute grants sent to the UE on the E-AGCH when AG Mode is set to Pattern . If set to DTX (Alt E-RNTI) , the test set still transmits the absolute grant value during the slot, but it uses the Alternate E-RNTI (Hex) (thus appearing to the UE as if the E-AGCH was DTX'd during this frame).

      GPIB command series: CALL:HSUPa:SGRant:ABSolute:PATTern:VALue[1] , etc.

      These settings cannot be changed when AG Mode is set to Pattern .

    When the E-DCH TTI is 2 ms , the E-DCH 16QAM State is On and the BetaEd Gain E-AGCH Table Selection is set to 1, an alternate set of AG Pattern Parameters are provided, and the UE will interpret the value according to the Table 16B.1 in 3GPP TS 25.212 v7b0. See also the GPIB command series CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue[1] etc.

  • RG Mode

    The test set supports two modes of operation on the E-RGCH, Single Shot and Pattern .

    • When RG Mode is set to Single Shot , you can initiate the Send Relative Grant Up or Send Relative Grant Down action over the E-RGCH to the UE.
    • When RG Mode is set to Pattern , the test set transmits a continuous sequence of values to the UE over the E-RGCH. The values that are transmitted to the UE are defined by RG Pattern .

    GPIB command: CALL:HSUPa:SGRant:RELative:MODE

  • RG Pattern

    This parameter controls what relative grant pattern will be transmitted on E-RGCH when the RG Mode is set to Pattern . The 12 Downs+8 Holds option is provided here to facilitate the 3GPP TS 34.121 test case 10.3.2.

    Note: You must set this setting correctly during your tests, as the test set will send the relative grant value regardless of whether the unit acts as the E-DCH Serving Cell or not.

    GPIB command: CALL:HSUPa:SGRant:RELative:PATTern

  • Send Relative Grant Up

    This action instructs the test set to transmit an "Up" relative grant command to the UE. The command is transmitted by the test set at the first available opportunity, or added to the relative grant queue if other relative grant commands are already pending (see Relative Grant Transmission ).

    By default there is no power present in the E-RGCH ( HSPA Cell 1 Connected E-RGCH Level is set to Off by default). If you initiate this action when HSPA Cell Connected E-RGCH Level is set to Off , a warning is posted but the relative grant command is still transmitted/queued.

    The UE only listens to the E-RGCH if RB Test Mode E-RGCH Information State was set to On when the connection was established (it is set to Off by default). Thus, this action is rejected if RB Test Mode E-RGCH Information State is Off .

    For HSPA PS data connections, the UE only listens to the E-RGCH if PS Data E-RGCH Information State was set to On when the connection was established (it is set to On by default). Thus, this action is rejected if PS Data E-RGCH Information State is Off .

    GPIB command: CALL:HSUPa:SGRant:RELative:UP:SEND[:IMMediate]

  • Send Relative Grant Down

    This action instructs the test set to transmit a "Down" relative grant command to the UE. The command is transmitted by the test set at the first available opportunity, or added to the relative grant queue if other relative grant commands are already pending (see Relative Grant Transmission ).

    By default there is no power present in the E-RGCH ( HSPA Cell 1 Connected E-RGCH Level is set to Off by default). If you initiate this action when HSPA Cell Connected E-RGCH Level is set to Off , a warning is posted but the relative grant command is still transmitted/queued.

    For HSPA RB test mode connections, the UE only listens to the E-RGCH if RB Test Mode E-RGCH Information State was set to On when the connection was established (it is set to Off by default). Thus, this action is rejected if RB Test Mode E-RGCH Information State is Off .

    For HSPA PS data connections, the UE only listens to the E-RGCH if PS Data E-RGCH Information State was set to On when the connection was established (it is set to On by default). Thus, this action is rejected if PS Data E-RGCH Information State is Off .

    GPIB command: CALL:HSUPa:SGRant:RELative:UP:SEND[:IMMediate]

  • Clear Queued Relative Grants

    Clears the relative grant queue.

    GPIB command: CALL:HSUPa:SGRant:RELative:QUEued:CLEar

Related Topics

HSUPA Parameters


Idle Periods in the Downlink (IPDL)

Idle Periods in the Downlink (IPDL)

Last updated: January 15, 2009

This section is only applicable to the lab application.

  • IPDL Overview
  • IPDL Parameters

IPDL Overview

Idle Periods in the Downlink (IPDL) is a feature whereby the Node-B intermittently switches off its transmitter for all channels (common and dedicated) for short periods of time, known as idle periods. This gives the UE an opportunity to make more accurate measurements of neighboring cells that are required for applications such as position determination. IPDL is different from compressed mode in that with IPDL the system makes no attempt to avoid data loss.3GPP TS 25.214 Section 8, "Idle periods for IPDL location method" is the primary 3GPP specification reference for this functionality. This defines an equation by which the 8960 can determine when the idle periods will occur and their length (which is either 5 or 10 CPICH symbols). This equation includes a pseudo random number generator to introduce irregularities in the idle period spacing, however the nature of the random number generator is predictable and thus the start position of the idle periods can always be unambiguously determined.

There are two modes in which IPDL can operate, continuous or burst. The test set supports both of these modes. Additional parameters allow you to control the length and frequency of the bursts. Continuous mode is essentially a single burst that spans the full 4096 SFN cycle.

In the test set, IPDL is a layer 1 only feature. There is no associated Layer 3 signaling to inform the UE about when the idle periods will occur. Support for the Layer 3 signaling is provided independently through the SIB15.s message support You must ensure that the contents of the SIB15.x messages match the test set's Layer 1 configuration.

You can start and stop the idle periods at any time (including on a call). However the parameters of the idle periods can only be changed when IPDL is not active. When IPDL is active the test set reduces its transmit power by switching off modulation during the idle periods.

IPDL is supported in both Active Cell and FDD Test Mode Cell Operating Modes.

IPDL Parameters

This section is only applicable to the lab application.

  • IPDL State

    This parameter controls whether IPDL is active or not.

    GPIB command: CALL[:CELL]:CONTrol:IPDownlink[:STATe]

  • IPDL Mode

    This parameter sets the IPDL mode, either Burst or Continuous.

    GPIB command: CALL[:CELL]:CONTrol:IPDownlink:STATus

    This setting cannot be changed while IPDL is active. If you attempt to change this setting while the IPDL State is On then the test set will reject the change and an error will be reported.

  • IP Spacing

    This parameter sets the spacing between idle periods.

    This setting cannot be changed while IPDL is active. If you attempt to change this setting while the IPDL State is On then the test set will reject the change and an error will be reported.

    GPIB command: CALL[:CELL]:CONTrol:IPDownlink:IPSPacing

  • IP Offset

    This parameter defines a static offset used in the calculation of idle period start positions (used to synchronize idle periods across sectors).

    This setting cannot be changed while IPDL is active. If you attempt to change this setting while the IPDL State is On then the test set will reject the change and an error will be reported.

    GPIB command: CALL[:CELL]:CONTrol:IPDownlink:IPOFfset

  • IP Length

    This parameter controls the length of the idle periods and is specified in CPICH symbols.

    This setting cannot be changed while IPDL is active. If you attempt to change this setting while the IPDL State is On then the test set will reject the change and an error will be reported.

    GPIB command: CALL[:CELL]:CONTrol:IPDownlink:IPLength

  • Seed

    This parameter sets the seed for the random number generator used when calculating the idle period start positions.

    This setting cannot be changed while IPDL is active. If you attempt to change this setting while the IPDL State is On then the test set will reject the change and an error will be reported.

    GPIB command: CALL[:CELL]:CONTrol:IPDownlink:RNGenerator:SEED

  • Burst Start

    This parameter sets the start of the first burst (start system frame number (SFN) = 256 * Burst Start).

    This setting cannot be changed while IPDL is active. If you attempt to change this setting while the IPDL State is On then the test set will reject the change and an error will be reported.

    GPIB command: CALL[:CELL]:CONTrol:IPDownlink:BSTart[:FRAMes256]

  • Burst Length

    This parameter sets the number of idle periods in a burst.

    This setting cannot be changed while IPDL is active. If you attempt to change this setting while the IPDL State is On then the test set will reject the change and an error will be reported.

    GPIB command: CALL[:CELL]:CONTrol:IPDownlink:BLENgth[:PERiods]

  • Burst Frequency

    This parameter influences the frequency of bursts within the SFN cycle (it defines the number of radio frames * 256 between bursts).

    This setting cannot be changed while IPDL is active. If you attempt to change this setting while the IPDL State is On then the test set will reject the change and an error will be reported.

    GPIB command: CALL[:CELL]:CONTrol:IPDownlink:BFRequency[:FRAMes256]

Related Topics

CALL:CONTrol


Message Reply Control

Message Reply Control

Last updated: May 26, 2010

This section is only applicable to the lab application.

  • Attach Accept Non-GPRS IMSI Reject

    GPIB Command: CALL:SERVice:GPRS:AAReject[:STATe]

  • Attach Accept Reject GMM Cause

    GPIB Command: CALL:SERVice:GPRS:AAReject:CAUSe

  • Attach Ignore State

    When set to On , the test set will ignore any GPRS attach request from the UE, and will not send any message back to the UE. Attach Ignore State and Attach Reject State can not be set to On simultaneously.

    GPIB Command: CALL:SERVice:GPRS:AIGNore[:STATe]

  • Attach Reject State

    When set to On , the test set will reject any GPRS attach request from the UE, and send a GPRS ATTACH REJECT message to the UE. Attach Reject State and Attach Ignore State can not be set to On simultaneously.

    GPIB Command: CALL:SERVice:GPRS:AREJect[:STATe]

  • Attach Reject GMM Cause

    If Attach Reject State is set to On, this setting is used to populate the GMM cause field in the GPRS ATTACH ACCEPT message sent from the test set to the UE.

    The CALL:SERVice:GPRS:AREJect:CAUSe command allows you to send any value between 0 and 255 to the UE, even those not mapped to a cause in the standard.

  • Location Area Update Ignore State

    When set to On , the test set will ignore any Location Updating request from the UE, and will not send any message back to the UE.. Location Area Update Ignore State and Location Area Update Reject State can not be set to On simultaneously.

    GPIB Command: CALL[:CELL]:LAUPdate:IGNore[:STATe]

  • Location Area Update Reject State

    When set to On , the test set will reject any Location Updating request from the UE, and will send a Location Updating Reject message to the UE. Location Area Update Reject State and Location Area Update Ignore State can not be set to On simultaneously.

    GPIB Command: CALL[:CELL]:LAUPdate:REJect[:STATe]

  • Location Area Update Reject Cause

    When Location Area Update Reject State is set to On, this setting is used to populate the reject cause field in the Location Updating Reject message sent from the test set to the UE.

    The CALL[:CELL]:LAUPdate:REJect:CAUSe command allows you to send any value between 0 and 255 to the UE, even those not mapped to a cause in the standard. The standard specified causes are in 3GPP TS 24.008.

  • Routing Area Update Ignore State

    When set to On , the test set will ignore any routing area update request from the UE, and will not send any message back to the UE. Routing Area Update Ignore State and Routing Area Update Reject State can not be set to On simultaneously.

    GPIB Command: CALL:SERVice:GPRS:RAUPdate:IGNore[:STATe]

  • Routing Area Update Reject State

    When set to On , the test set will reject any routing area update request from the UE, and send a ROUTING AREA UPDATE REJECT message back to the UE. Routing Area Update Reject State and Routing Area Update Ignore State can not be set to On simultaneously.

    GPIB Command: CALL:SERVice:GPRS:RAUReject[:STATe]

  • Routing Area Update Reject GMM Cause

    When Routing Area Update Reject State is set to On, this setting is used to populate the GMM cause field in the ROUTING AREA UPDATE REJECT message sent from the test set to the UE.

    The CALL:SERVice:GPRS:RAUReject:CAUSe command allows you to send any value between 0 and 255 to the UE, even those not mapped to a cause in the standard.

Related Topics

Manual Operation: How Do I Change Cell Parameters?


Message Reject Setup

Message Reject Setup

Last updated: November 11, 2009

This section is only applicable to the lab application.

  • Message Reject Setup Parameters

Message Reject Setup Parameters

This section is only applicable to the lab application.

  • Location Area Update Reject State

    This parameter sets the Location Updating Forced Reject State. While it is On, the test set will reject any Location Updating request from the UE.

    GPIB command: CALL[:CELL]:LAUPdate:REJect[:STATe]

  • Location Area Update Reject Cause

    Sets/queries the Location Updating Forced Reject Cause.

    GPIB command: CALL[:CELL]:LAUPdate:REJect:CAUSe

Related Topics

CALL:LAUPdate


Network Identity and Time Zone

Network Identity and Time Zone

Last updated: February 23, 2009

This section is only applicable to the lab application.

  • Network Identity and Time Zone Overview
  • NITZ Parameters
  • Operating Considerations

Network Identity and Time Zone Overview

The test set allows Network Identity and Time Zone (NITZ) information to be included in the MM and GMM Information messages sent to a UE, so that the UE can store and use this information. The NITZ information includes universal time (UT), daylight saving time (DST), and local time zone (LTZ).

There are several IEs in the GMM and MM Information messages that are used for NITZ. From these, only two are used for transferring time information; the `Universal time and local time zone' IE and the `Network Daylight Saving Time' IE.

See 3GPP TS 24.008 for more information on MM and GMM Information messages.

NITZ Parameters

You can configure the NITZ parameters in the test set to control the conditions under which the NITZ information is sent. The following parameters are available:

  • Send NITZ UT

    This parameter forces the NITZ Information to be immediately sent to the UE depending on the call state. Valid call states for this action are Connected, PDP Active, or simultaneous Connected/PDP Active.

    GPIB Command: CALL[:CELL]:NITZone:SEND[:IMMediate]

  • Set NITZ UT to UTC

    Sets the NITZ Universal Time and Date to the Universal Coordinated Time and Date as found on the test set's System Configuration screen. This is available as a convenience for setting the NITZ time and date.

    GPIB Command: CALL[:CELL]:NITZone:UTIMe:UTC[:IMMediate]

  • NITZ Universal Time - Date

    This parameter defines the Universal Time-Date for the NITZ feature. The format of entry is yyyy.mm.dd.

    GPIB Command: CALL[:CELL]:NITZone:UTIMe:DATE[:SELected]

  • NITZ Universal Time - Time

    This parameter sets the Universal Time-Time for the Network Identity and Time Zone (NITZ) feature. The format of entry is hh,mm,ss using the 24-hour clock. This setting is included in the Universal Time and Local Time Zone Information Exchange.

    GPIB Command: CALL[:CELL]:NITZone:UTIMe:TIME[:SELected]

  • NITZ Local Time Zone

    This parameter sets the Network Identity and Time Zone (NITZ) local time zone. The format of entry is hh,mm or -hh,-mm and the resolution is 15 minutes. Therefore, any entry that does not fall evenly on a 15 minute (quarter hour) boundary is rounded to the nearest 15 minutes.

    GPIB Command: CALL[:CELL]:NITZone:TZONe[:LOCal][:SELected]

  • NITZ Daylight Saving Time Include State

    This parameter sets whether or not the Network Daylight Saving Time Information Element is included in the GMM or MM information message.

    GPIB Command: CALL[:CELL]:NITZone:DSTime[:HOURs]:STATe[:SELected]

  • NITZ Daylight Saving Time

    This parameter sets the Daylight Saving Time value for the Network Identity and Time Zone (NITZ) feature. This setting is included in the Network Daylight Saving Time Information Exchange.

    GPIB Command: CALL[:CELL]:NITZone:DSTime[:HOURs]:VALue[:SELected]

  • NITZ Send on PS Registration

    This parameter sets whether or not the NITZ information should be sent during a Packet Switched Registration. Packet Switched Registration includes the following procedures: GPRS Attach and Routing Area Update.

    GPIB Command: CALL[:CELL]:NITZone:SEND:PS:REGistration[:STATe][:SELected]

  • NITZ Send on PS Call Origination

    This parameter defines whether or not the NITZ information should be sent during a Packet Switched Call Origination.

    GPIB Command: CALL[:CELL]:NITZone:SEND:PS:ORIGination[:STATe][:SELected]

  • NITZ Send on CS Registration

    This parameter defines if the NITZ information should be sent during a Circuit Switched Registration (including the procedures: IMSI Attach and Location Area Update).

    GPIB Command: CALL[:CELL]:NITZone:SEND:CS:REGistration[:STATe][:SELected]

  • NITZ Send on CS Call Origination

    This parameter defines if the NITZ information should be sent during a Circuit Switched Call Origination (including the procedures : Voice, CSD Sync, CSD Async, and SMS over CS).

    GPIB Command: CALL[:CELL]:NITZone:SEND:CS:ORiGination[:STATe][:SELected]

  • NITZ Send Immediate Domain Priority

    This parameter defines which domain has priority during a NITZ Send Immediate in the case where the call state is both Connected and PDP Active simultaneously. That is, if a NITZ Send Immediate is performed when the call state is both Connected and PDP Active, this parameter determines if the NITZ Information is sent in an MM Info (CS) or GMM Info (PS) message.

    GPIB Command: CALL[:CELL]:NITZone:SEND:DOMain[:PRIority][:SELected]

Operating Considerations

The NITZ feature is only available in Active Cell operating mode.

NOTE
When the NITZ information is sent using MM and GMM Information messages, the `Universal time and local time zone' IE is always included. The `Network Daylight Saving Time' IE is only included when the NITZ Daylight Saving Time Include State parameter is set to ON.

Related Topics

CALL:NITZone


Paging Parameters

Paging Parameters

Last updated: January 15, 2009

  • CS Paging Identity Type

    This setting determines whether the UE is paged using its IMSI or a TMSI (see Test Set-Originated Connection ). If you wish to page the UE using a TMSI, the test set must first assign a TMSI to the UE during registration ( TMSI Assignment must be set to On when the UE registers with the test set, see Performing a Location Update (CS Domain Registration) ). The TMSI used to page the UE is determined by the TMSI setting.

    GPIB command: CALL:PAGing:IDENtity[:TYPE] .

    This parameter can only be set when call status is Idle .

  • Paging IMSI

    If you know the UE's International Mobile Subscriber Identity (IMSI), you can enter it under Paging IMSI and proceed directly to originating a call even if the UE has not registered. Otherwise, you must wait for the UE to report its IMSI value upon registering with the test set. See Performing a Location Update (CS Domain Registration) and Establishing a Connection with the UE .

    GPIB command: CALL:PAGing:IMSI[:SELected]

  • TMSI Assignment

    This setting determines whether the test set assigns a TMSI to the UE during the Location Update Procedure (see Performing a Location Update (CS Domain Registration) ). If TMSI Assignment is set to On , when the UE registers with the test set, the test set assigns the UE a TMSI in the Location Update Accept message. The TMSI assigned to the UE is determined by the TMSI setting.

    You must set TMSI Assignment to On before the UE registers in order for a TMSI to be assigned.

    If you do not plan to page the UE using a TMSI, it is recommended that you leave TMSI Assignment set to Off so that the Location Update procedure executes as quickly as possible (if TMSI Assignment is On , the UE must send a TMSI Reallocation Complete message).

    GPIB command: CALL[:CELL]:TMSI:ASSignment .

    This parameter can only be set when call status is Idle .

  • TMSI

    TMSI (Temporary Mobile Subscriber Identity) is described in 3GPP TS 25.331 10.3.1.17. It is a 32 bit number, but 3GPP TS 23.003 2.4 indicates "The network shall not allocate a TMSI with all 32 bits equal to 1 (this is because the TMSI must be stored in the SIM, and the SIM uses 4 octets with all bits equal to 1 to indicate that no valid TMSI is available)." Thus, TMSI may be set to any value between 0 and 4294967294.

    When TMSI Assignment is set to On , this setting determines the TMSI that is assigned to the UE during the Location Update Procedure (see Performing a Location Update (CS Domain Registration) ).

    When CS Paging Identity Type is set to TMSI , this setting determines the TMSI that is used to page the UE (see Test Set-Originated Connection ).

    GPIB command: CALL[:CELL]:TMSI[:VALue] .

    This parameter can only be set when call status is Idle .

  • Repeat Paging

    When Repeat Paging is set to Off, the test set issues a single PICH page indication and Paging Type I message when you select Originate Call ( CALL:ORIGinate[:AUTO] ).

    When Repeat Paging is set to On, when you select Originate Call ( CALL:ORIGinate[:AUTO] ), the test set sends PICH page indications and Paging Type I messages every DRX Cycle Length (CN Domain) until the UE responds with PRACH preambles and a valid RRC Connection request (see RRC Connection Setup Procedure ) or until End Call ( CALL:END[:AUTO] ) is selected.

    GPIB command: CALL:PAGing:REPeat[:STATe][:SELected]

    This parameter can only be set when operating mode is Cell Off .

Related Topics

Manual Operation: How Do I Change Paging Parameters?


Paging Service

Paging Service

Last updated: December 29, 2009

The Paging Service setting is used to set which type of service is initiated when the test set pages the UE. The Paging Service setting does not apply to UE-originated connections (see Establishing a Connection with the UE ).

Paging Service can be set to RB Test Mode (see Radio Bearer Test Mode ), UMTS/GPRS Packet Data , or AMR Voice (see AMR Setup ).

For the lab application only, Paging Service can also be set to UMTS/GPRS Packet Data (the test set only supports UE-origination of CS Data services, so CS Data is not an option for Paging Service ).

Related Topics

Manual Operation: How Do I Change Call Parameters?


Radio Bearer Test Mode and Channel Type

Radio Bearer Test Mode and Channel Type

Last updated: March 1, 2011

  • Radio Bearer Test Mode
  • HSDPA Radio Bearer Test Mode (lab application or feature-licensed test application only)
  • HSPA Radio Bearer Test Mode (lab application or feature-licensed test application only)
  • Channel Type

Radio Bearer Test Mode

The W-CDMA specifications (3GPP TS 34.109) define a Radio Bearer Test Mode which includes a suite of uplink (UL) and downlink (DL) reference measurement channels (RMCs) to use for UE transmitter and receiver conformance test. See Radio Bearer Test Mode, TC, and Reference Measurement Channels .

The test set supports the following RMCs:

  • Symmetrical RMCs

    The symmetrical RMCs are typically used for transmitter testing and for receiver testing using BER (via loopback type 1) or BLER (using loopback type 2).

    The symmetrical RMCs always use Transparent Mode (TM) RLC entities on the DTCH. The UE must send the Close UE Test Loop Complete message to the test set before it will start transmitting data on the downlink DTCH.

    • 12.2 kbps (3GPP TS 25.101 A.2.1 and A.3.1)
    • 64k kbps (3GPP TS 25.101 A.2.2 and A.3.2)
    • 144 kbps (3GPP TS 25.101 A.2.3 and A.3.3)
    • 384 kbps (3GPP TS 25.101 A.2.4 and A.3.4)
    • 33k No Coding RMC

      This Agilent proprietary RMC does not use convolutional coding on the downlink data, to allow for raw BER testing (see Loopback Bit Error Ratio (BER) Measurement Description ).

  • Asymmetrical RMCs

    The asymmetrical RMCs allow high data rate receiver testing in UEs that don't support rates above 64 kbps in the uplink. The asymmetrical RMCs use Acknowledged Mode (AM) RLC entities on the DTCH. When the asymmetrical RMCs are used, the BLER measurement calculates the block error ratio by counting the number of retransmission requests that the UE makes on its DTCH.

    The 12.2k uplink channel used in the asymmetrical RMCs is not the same as the 12.2k uplink channel used by the symmetrical RMCs, as that channel has a DTCH block size that is not a multiple of 8 bits (to use AM RLC entities, the data block size must be a multiple of 8 bits). Asymmetrical RMCs use the 12.2k Aux-MC which is essentially a regular 12.2k RMC but with a slightly different DTCH block size that is a multiple of 8 bits.

    You can specify whether the loopback is closed for asymmetrical RMCs using the Asymmetric RMC Loopback Messaging parameter.

    Asymmetrical RMCs are not available in FDD test operating mode.

    • 12.2 kbps UL/64 kbps DL (3GPP TS 34.121 C.6.7 and 3GPP TS 34.121 C.3.2 (table C.3.2.3))
    • 12.2 kbps UL/144 kbps DL (3GPP TS 34.121 C.6.7 and 3GPP TS 34.121 C.3.3 (table C.3.3.3))
    • 12.2 kbps UL/384 kbps DL (3GPP TS 34.121 C.6.7 and 3GPP TS 34.121 C.3.4 (table C.3.4.3))
    • 64 kbps UL/384 kbps DL (3GPP TS 34.121 C.2.2 (table C.2.2.3) and 3GPP TS 34.121 C.3.4 (table C.3.4.3))

Use the Channel Type setting to specify which RMC to use when establishing an RB Test Mode connection with the UE.

Radio Bearer Test Mode Setup

You can configure the following characteristics of the RMC channels when operating in RB Test Mode . These parameters can only be changed when the call status is idle.

See HSDPA RB Test Mode Settings and HSUPA RB Test Mode Setup for information on other settings available for configuring the HSDPA and HSPA Radio Bearer Test Mode connections ( lab application or feature-licensed test application only ).

  • RB Test Mode RRC State Setting

    In the lab application only, this setting controls whether the RB Test Mode service will configure the UE into a CELL_FACH or CELL_DCH state. The CELL_DCH state is used for all 3GPP TS 34.121 RF tests except Receiver Spurious Emissions, which requires the use of CELL_FACH. See Radio Bearer Test Mode Origination to CELL_DCH - CS Domain (Non-HSPA or HSDPA) and Radio Bearer Test Mode Origination to CELL_FACH .

    GPIB command: CALL:SERVice:RBTest:RRC:STATe .

    To query the current RRC State, see RRC State .

  • Uplink DTCH RMC CRC Presence

    This setting controls whether the uplink transport channel carrying the DTCH has a Cyclic Redundancy Check (CRC) field or whether the bits that would normally be used for this CRC field are used to carry data instead. If this parameter is set to Present , then the test set assumes that the bits in the CRC field are actual CRC bits for the uplink transport block. If the parameter is set to Used for Data , then the test set assumes that the bits in the CRC field are just data bits. In other words, the UE is NOT sending uplink CRC bits, but instead is sending more data bits in their place (such as looped back downlink CRC bits).

    Uplink DTCH RMC CRC Presence must be set to Present when performing the loopback BER measurement (see Loopback Bit Error Ratio (BER) Measurement Description ) so that the measurement can detect and report any uplink CRC errors that occur while the measurement is running (any uplink errors that occur during receiver testing invalidate the results, and must be considered).

    Uplink DTCH RMC CRC Presence must be set to Used for Data when performing the loopback block error ratio measurement for Symmetrical RMCs (see Block Error Ratio (BLER) Measurement Description ). This disables the uplink CRC, to allow room for the UE to loop back the downlink CRC for each block (there are an equal number of bits in the uplink and downlink transport blocks, if the UE were to transmit an uplink CRC, it would not be able to loop back the downlink CRC).

    When on an HSDPA RB test mode connection (see HSDPA RMCs ), the Uplink DTCH RMC CRC Presence setting only controls the presence of the CRC on the RMC portion of the channel. It is not possible to control the presence of the CRC on the FRC.

    GPIB command: CALL:SERVice:RBTest:DTCHannel:CRC[:PRESence] .

    This setting can be changed using a Radio Bearer Reconfiguration .

  • Uplink Dummy DCCH Data

    3GPP TS 34.109 section 5.3.2.8 specifies that when UE test loop mode 1 or 2 is active, if DCCH dummy mode is enabled and there is no DCCH data to be sent, then the UE shall set all bits in the uplink DCH transport block associated with a DCCH to 1. Thus, if the Uplink Dummy DCCH Data parameter in the test set is set to On, the test set discards any received DCH transport blocks associated with a DCCH having its bits set to 1.

    GPIB command: CALL:UPLink:DCCHannel:DDATa .

    This setting can be changed using a Radio Bearer Reconfiguration .

  • UE Loopback Type

    This setting controls which loopback mode the Test control (TC) protocol layer instructs the UE to go into. This is signaled to the UE in the Close UE Test Loop message. In Type 1 loopback mode, the loopback point is just above the traffic plane RLC entities (see 3GPP TS 34.109, 5.3.2.6). In Type 2 loopback mode, the loopback point is just above the layer 1 transport channels (see 3GPP TS 34.109, 5.3.2.7).

    Typically, you should set MS Loopback Type to Type 1 when performing the loopback bit error ratio measurement (see Loopback Bit Error Ratio (BER) Measurement Description ).

    You must set MS Loopback Type to Type 2 when performing the loopback block error ratio measurement for Symmetrical RMCs (see Block Error Ratio (BLER) Measurement Description ).

    The UE Loopback Type setting does not apply when loopback is closed for asymmetrical RMCs. Asymmetrical RMCs are always closed with a loopback type of 1.

    GPIB command: CALL:MS:LOOPback:TYPE .

    This setting can be changed using a Radio Bearer Reconfiguration .

  • Asymmetric RMC Loopback Messaging

    The Asymmetric RMC Loopback Messaging parameter allows you to specify whether Open/Close UE Test Loop messages are used for asymmetrical RMCs.

    3GPP TS 34.108 and 34.121 state that even for an asymmetrical RMC, the call setup shall include the Close UE Test Loop message (and the call release shall include the Open UE Test Loop message). The Close UE Test Loop message must contain a loopback SDU size of zero to prevent any data from actually being looped back (so that the uplink is left free for the RLC Acks and Nacks). The loopback type is always 1 for asymmetrical RMCs (as the SDU size is not controllable for loopback type 2). Thus, the UE Loopback Type setting does not apply to the asymmetrical RMCs.

    This parameter does not affect the call setup/release procedures for symmetrical RMCs.

    • If Asymmetric RMC Loopback Messaging is set to Close/Open , the test set sends the UE a Close UE Test Loop message with the loopback type set to 1 and the SDU size set to zero bits during the asymmetrical RMC call setup.
    • If Asymmetric RMC Loopback Messaging is set to None , the test set does not send the UE a Close UE Test Loop message or an Open UE Test Loop message during asymmetrical RMC call setup/release. This setting provides for faster call setup/release procedures. Note, if a Close UE Test Loop message is not sent to the UE when establishing the asymmetrical RMC, you can not send an Open UE Test Loop message as part of a Physical Channel Reconfiguration (see RB Test Mode PCR Loopback Messaging State ).

    GPIB command: CALL:SERVice:RBTest:ARMC:LMESsaging

    This setting can only be changed while call status is idle.

HSDPA Radio Bearer Test Mode

This section is only applicable to the lab application or feature-licensed test application.

HSDPA Radio Bearer Test Mode uses an HSDPA RMC that combines a 12.2 kbps symmetrical RMC with an HSDPA channel that you can configure as a Fixed Reference Channel (FRC) or to a user-defined configuration of your choice (as determined by the RB Test HS-DSCH Configuration Type setting). Once you've set Channel Type to 12.2k RMC + HSDPA , you must then specify the HS-DSCH Configuration Type , then either set FRC Type or the User Defined Configuration of the HS-DSCH settings as desired. See HSDPA Parameters for information on other settings available for configuring the HSDPA Radio Bearer Test Mode connection.

The test set supports the following HSDPA RMCs:

  • HSDPA RMCs
    • 12.2k RMC + HSDPA
      • 12.2 kbps RMC (3GPP TS 34.121 sC.2.1 and sC.3.1)
      • FRC H-Set 1 (3GPP TS 34.121 sC.8.1.1)
      • FRC H-Set 2 (3GPP TS 34.121 sC.8.1.2)
      • FRC H-Set 3 (3GPP TS 34.121 sC.8.1.3)
      • FRC H-Set 4 (3GPP TS 34.121 sC.8.1.4)
      • FRC H-Set 5 (3GPP TS 34.121 sC.8.1.5)
      • FRC H-Set 6 (3GPP TS 34.121 sC.8.1.6)

HSPA Radio Bearer Test Mode

This section is only applicable to the lab application or feature-licensed test application.

HSPA RB Test Mode combines a 12.2 kbps symmetrical RMC with an HSDPA channel and an HSUPA channel. The HSDPA channel can be configured as an FRC or to a user-defined configuration as explained in HSDPA Radio Bearer Test Mode above. The HSUPA channel is configured as per 3GPP TS 34.121 sC.11, and can be further configured using the HSUPA Parameters .

While on an HSPA RB Test Mode connection the UE is instructed to loop the downlink RMC DPCH onto the uplink RMC DPCH and the downlink HSDPA channel onto the uplink HSUPA channel (the downlink HS-DSCH is used as the data source for the uplink E-DCH). As HSDPA and HSUPA do not have symmetrical data rates it is not possible to precisely match the downlink data rate to the uplink data rate (as you can for a regular RMC). It is desirous to ensure that the UE always has enough data in its transmission buffers to let it fully utilize its current serving grant (so that the E-AGCH and E-RGCH control the output level of the UE). The test set supports two downlink configurations to ensure sufficient traffic on the uplink:

  • When RB Test HS-DSCH Configuration Type is set to FRC and FRC Type = H-Set 1 QPSK , the downlink RLC SDU size is 2936 bits and the downlink RLC PDU size is 336 bits. The test set packs a continuous stream of RLC SDUs into the RLC PDUs (thus a PDU may contain the end of one SDU and the beginning of the next SDU). Each RLC PDU is then packed into a MAC-d PDU, and as many MAC-d PDUs are packed into the MAC-hs PDU as will fit (subject to the maximum limit of 70 PDUs as per 3GPP TS 35.321 s9.2.2). This configuration conforms strictly to 3GPP TS 34.108 and 34.121.
  • When the HSDPA channel is configured otherwise, the downlink RLC PDU size is 336 bits for an FRC or 112 bits for a user defined channel. The downlink RLC SDU is sized such that a single RLC SDU completely fits within the downlink RLC PDU with zero padding. A single RLC PDU is then packed into the MAC-hs PDU with any remaining space in the MAC-hs PDU marked as padding.

Regardless of the downlink configuration, the uplink RLC SDU size varies between 2936 and 35232 (based upon the RB E-DPDCH Max Channel Codes (HSPA) setting). The uplink RLC PDU size is 336 bits. Because HSPA RB Test Mode connections use loopback type I, it is possible for the UE to transmit more data on the E-DCH than it is receiving on the HS-DSCH by setting a large E-DCH RLC SDU Size (the UE simply repeats data if the uplink SDU is larger than the downlink SDU, see 3GPP TS 34.109 v6.3.0 s5.3.2.6.2). This feature of loopback type I allows the second downlink configuration described above to drive the uplink at sufficiently high rates.

This feature of loopback type I also allows you to achieve 2 Mbps in the uplink with less than 2 Mbps in the downlink (H-Set 1 QPSK downlink data rate = 534 kbps). For example, to achieve 2 Mbps in the uplink with the downlink configured to H-Set 1 QPSK (534 kbps), set E-DCH RLC SDU Size to at least 4 x 2936 bits = 11744 bits. Note that you must also set RB Test Mode E-DPDCH Max Channel Codes = 2SF2 , grant the UE a large enough serving grant to allow this data rate, and ensure that the UE's transmit power is low enough that the HSUPA channels do not get scaled down.

The test set supports the following HSPA RMCs:

  • HSPA RMCs
    • 12.2k RMC + HSPA
      • 12.2 kbps RMC (3GPP TS 34.121 sC.2.1 and sC.3.1)
      • HSDPA: FRC definitions as shown above or user-defined configuration
      • HSUPA: (3GPP TS 34.121 sC.11)

Channel Type

The Channel Type setting allows you to specify which RMC to use while operating in Radio Bearer Test Mode . Channel Type can be set to:

  • Symmetrical RMCs :
    • 12.2k RMC
    • 64k RMC
    • 144k RMC
    • 384k RMC
    • 33k No Coding RMC
  • Asymmetrical RMCs :

    The asymmetrical RMCs are not available in FDD Test Operating Mode . If Channel Type is set to an asymmetrical RMC and you move to FDD Test Operating Mode , Channel Type is changed to 12.2k RMC .

    • 12.2k UL/64k DL AM RMC
    • 12.2k UL/144k DL AM RMC
    • 12.2k UL/384k DL AM RMC
    • 64k UL/384k DL AM RMC
  • HSDPA RMCs : ( lab application or feature-licensed test application only )
    • 12.2k RMC + HSDPA
  • HSPA RMCs : ( lab application or feature-licensed test application only )
    • 12.2k RMC + HSPA
    • HSPA

This setting can not be changed while on a call. To move between channel types while on a connection, see Handovers .

GPIB command: CALL:SERVice:RBTest:RAB

Related Topics

How Do I Configure the Radio Bearer Test Mode?

How Do I Change Call Parameters?

CALL:SERVice

Downlink Channel Codes and Levels

Current Service Type

HSDPA RB Test Mode Settings

HSUPA RB Test Mode Setup

Establishing a Connection with the UE

Paging Service


Receiver Control

Receiver Control

Last updated: January 15, 2009

You can manually tune the test set's receiver frequency and attenuation settings for the frequency and power level that you want to test. Or, you can have the test set automatically tune its receiver's frequency and attenuation settings based on other settings such as Uplink Channel and UE Target Power .

Automatic Receiver Control

Automatic receiver control is the default for all operating modes except CW Operating Mode (only manual receiver control is available in CW operating mode). With automatic receiver control, the test set automatically tunes to the correct frequencies for making measurements and maintaining a call based on the Uplink Channel setting. Also, the test set adjusts attenuation settings according to the power level that should be present at the RF IN/OUT port given the current settings. This power level is referred to as the Expected Power .

Manual Receiver Control

In some instances, you may want to control the test set's receiver settings manually rather than allowing the test set to automatically control them. This ability is referred to as manual receiver control. Manual receiver settings can be used to override some or all of the automatic receiver settings. You can manually set the Expected Power , the measurement downconverter's tune frequency ( Measurement Frequency ), and the demodulation downconverter's tune frequency ( Uplink Frequency ).

In CW operating mode, you must always specify what frequencies and power the receiver should tune to, there is no automatic receiver control.

Receiver Control Settings

The following settings control the test set's receivers:

Power Control

Available in Active Cell , FDD Test and Cell Off operating modes.

When Power Control is set to Auto , the Expected Power from the UE is automatically determined by the test set. When Power Control is set to Manual , the expected power is determined by the Manual Power setting.

Note, when you switch between operating modes, Power Control is returned to its default value of Auto .

GPIB command: RFANalyzer:CONTrol:POWer:AUTO

Manual Power

Available in Active Cell , FDD Test and Cell Off operating modes.

When Power Control is set to Manual , the Expected Power from the UE is determined by the Manual Power setting. Note, when you switch between operating modes, Power Control is returned to its default value of Auto .

GPIB command: RFANalyzer:MANual:POWer[:SELected]

Expected CW Power

Available in CW operating mode.

The Expected CW Power setting determines the Expected Power while in CW operating mode.

GPIB command: RFANalyzer:CW:EXPected:POWer

NOTE
You can set the Expected CW Power and Manual Power levels beyond the actual capability of the test set's hardware. This is because these settings are intended to reflect the potential range of RF power at the UE. This range of RF power is meant to accommodate the use of a gain or loss network between the mobile station and the test set (see Amplitude Offset ). The upper and lower limits of these settings provide boundaries for the combination of amplitude offset and expected power from the UE.

Measurement Frequency

Available in all operating modes.

The Measurement Frequency setting is used to manually tune the test set's measurement downconverter input signal path (see Block Diagram ).

GPIB commands:

  • RFANalyzer:MANual:MEASurement[:MFRequency] - Specifies a measurement frequency and sets control mode to manual.

  • RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO - Specifies manual or auto control mode. When in auto control mode, the measurement frequency is automatically determined by the Uplink Channel setting.

  • RFANalyzer:MANual:MEASurement:FREQuency - Specifies a measurement frequency.

Note, when you switch between operating modes, Measurement Frequency is returned to its default value of Auto .

Uplink Frequency

Available in FDD Test and CW operating modes.

The Uplink Frequency setting is used to manually tune the test set's demodulation downconverter input signal path (see Block Diagram ). The demodulation downconverter signal path is used to establish and maintain the call (RF link) between the UE and test set.

GPIB commands:

  • RFANalyzer:MANual:UPLink[:MFRequency] - Specifies an uplink frequency and sets control mode to manual.

  • RFANalyzer:CONTrol:UPLink:FREQuency:AUTO - Specifies manual or auto mode. When in auto control mode, the uplink frequency is automatically determined by the Uplink Channel setting.

  • RFANalyzer:MANual:UPLink:FREQuency - To specify an uplink frequency.

Note, when you switch between operating modes, Uplink Frequency is returned to its default value of Auto .

Expected Power

To make accurate measurements, the test set needs to know how much power to expect at its RF IN/OUT port; this is referred to as the expected power. If a measurement uses autoranging, the expected power level is calibrated by the test set before making the measurement and does not need to be set by the user. For measurements that do not use autoranging, the test set determines the expected power level in one of several ways:

  • For Active Cell operating mode:
    • when Power Control is set to Manual , expected power is determined by the Manual Power setting.
    • when Power Control is set to Auto :
      • if the call status is Idle , expected power is determined by Initial PRACH TX Power or Initial DPCCH TX Power .
      • if the call status is Connected , expected power is determined by the UE Target Power setting.
  • For FDD Test operating mode:
    • when Power Control is set to Manual , expected power is determined by the Manual Power setting.
    • when Power Control is set to Auto , expected power is determined by the UE Target Power setting.
  • For CW operating mode, expected power is always determined by the Expected CW Power setting.
If the received signal is above or below the acceptable range for expected power, an Over Range or Under Range message is displayed and the measurement's Integrity Indicator is set to 5 or 6, respectively.

Effects on Receiver Control When Changing Operating Mode

After selecting the operating mode and setting one or more receiver controls to manual, the receiver control settings remain as you set them until you change operating mode. Changing operating mode causes some or all receiver parameters to return to automatic control.

Related Topics

Manual Operation: How Do I Change Receiver Control Parameters?

RFANalyzer

UE Expected Open Loop Transmit Power

Uplink Closed Loop Power Control Parameters and UE Target Power

Active Cell Operating Mode

CW Operating Mode

FDD Test Operating Mode

RF Gen Freq Ctrl


RRC Pipe

RRC Pipe

Last updated: January 14, 2010

This section is only applicable to the lab application.

  • RRC Pipe Overview
  • Downlink RRC Pipe Data Format
  • RRC Pipe Parameters

RRC Pipe Overview

The RRC pipe mechanism allows you to send and receive RRC messages and/or message contents, that are not explicitly supported (or only partially supported) by the test set. When the pipe is enabled, you can externally encode specified RRC messages and deliver them to the UE using the test set. In addition, certain messages can also be received from the UE and made available to you for querying over the remote user interface (subject to any conditions that are specific to each message).

The test set supports Assisted GPS (A-GPS) by using the RRC Pipe to transport externally coded messages to and from the UE.

The RRC pipe can only be used when an RRC connection is active, and when CALL:PPRocedure:RRC:PIPE[:STATe] is set to "On". If a request to send data is received when either of these conditions is not met, the request will be ignored.Similiarly, if UE data corresponding to a message that would normally be delivered to you using the RRC pipe is received, but CALL:PPRocedure:RRC:PIPE[:STATe] is set to "Off", the messages will be handled as normal by the protocol stack, but then discarded without making the data available on the uplink RRC pipe.The maximum length of the RRC pipe data block passed either to or from the user over the remote user interface is 1000 bytes.

Downlink RRC Pipe Data Format

All downlink RRC Pipe messages should adhere to the following requirements:

  • The message should consist of a data block (hex character string) and a length field describing the number of relevant bits in the data block, beginning with the most significant bit of the first hex character.
  • The data block should not include the following fields. These will be added by the test set if required:
    • 1-bit Integrity IE presence flag
    • Optional 36-bit Integrity IE
    • 5-bit MessageType

This means that the first bit of the data block should represent the bit that will immediately follow the 5-bit message type in the completed message. The message structure is illustrated in the following graphic.

Graphical Representation of Downlink RRC Pipe Message

RRC Pipe Parameters

This section is only applicable to the lab application.

  • RRC Pipe State

    This parameter sets the state of the RRC Pipe. When set to On, external data received for downlink transmission over the RRC pipe is processed according to the requirements of the specific message. When set to Off, the message is ignored.

    GPIB command: CALL:PPRocedure:RRC:PIPE[:STATe]

  • Measurement Control Message

    This parameter sets the the measurement identity, length (in bits), and the contents of the Measurement Control Message. If the Measurement Control Message is received while CALL:PPRocedure:RRC:PIPE[:STATe] is set to On and an RRC connection is present, the test set adds the appropriate message type parameter and integrity information if applicable. The resulting message is sent to the UE. Otherwise the message is ignored.

    GPIB command: CALL:PPRocedure:RRC:PIPE:MCMessage[:DATA]

  • Assistance Data Delivery Message

    This parameter sets the length (in bits) and the contents of the Assistance Data Delivery Message. If the Assistance Data Delivery Message is received while CALL:PPRocedure:RRC:PIPE[:STATe] is set to On and an RRC connection is present, the test set adds the appropriate message type parameter and integrity information if applicable, and sends the resulting message to the UE. Otherwise the message is ignored.

    GPIB command: CALL:PPRocedure:RRC:PIPE:ADDMessage[:DATA]

  • Measurement Control Message (MCM) Response

    This result provides Measurement Report and Measurement Control Failure messages received from the UE. Typically these messages will be sent by the UE in response to Measurement Control messages sent over the downlink RRC pipe.

    GPIB command: CALL:PPRocedure:RRC:PIPE:MCMessage:RESPonse[:DATA]?

  • Measurement Control Message (MCM) Response Clear

    This action performs a Measurement Control Message (MCM) Response Clear event. This event removes all stored messages from the MCM response buffer. When the event is received all the stored messages are discarded and the buffer is emptied.

    GPIB command: CALL:PPRocedure:RRC:PIPE:MCMessage:RESPonse:CLEar

Related Topics

CALL:PPRocedure


Security Ladder Diagrams

Security Ladder Diagrams

Last updated: January 15, 2009

  • Security Procedure with Authentication Only
  • Security Procedure with Authentication and Integrity Protection

Security Procedure with Authentication Only

Security Procedure with Authentication and Integrity Protection

Related Topics

Security Information


Security Information

Security Information

Last updated: November 16, 2010

The test set can perform security procedures during the following call processing operations:

  • Location Update (Registration) Procedure
  • Radio Bearer Test Mode Origination to CELL_DCH - CS Domain (Non-HSPA or HSDPA)
  • Test Set Initiated AMR Voice Service Start
  • UE Initiated AMR Voice Service Start
  • UE-Initiated UE-to-UE Video Call Origination Ladder Diagram ( lab application or feature-licensed test application only )
  • GPRS Attach ( lab application only )
  • Test Set Initiated GPRS Detach ( lab application only )
  • UE Initiated GPRS Detach ( lab application only )
  • Test Set Initiated GPRS Service ( lab application only )
  • UE Initiated GPRS Service ( lab application only )
  • UE Initiated GPRS Service, Activate PDP Context Reject ( lab application only )
  • UE Initiated CS Data Service Start Procedure ( lab application only )

You can specify which security procedures are performed during these operations ( None , Auth & Int , or Auth Only ) using the Security Operations setting. Authentication and integrity protection are described in 3GPP TS 35.206, 24.008, 33.102, 25.331, and 35.202.

During authentication, both the UE and the network confirm that the other is valid by a series of computations based on a shared secret Authentication Key (K). The computations are performed using one of two Authentication Algorithm s, with K, SQN and the signalled values for Random (RAND) Value and AMF Value as inputs.

When integrity protection is enabled, the network encodes every RRC message with a digital signal (IK, which is derived from K, SQN, RAND and AMF). The UE rejects all RRC messages (except TC messages) that do not bear the proper digital signal.

Security Parameters

  • Security Operations

    Security Operations can be set to:

    • None : No security procedures are performed during call processing operations.
    • Auth & Int : Both authentication and integrity protection are performed during call processing operations.
    • Auth Only : Only authentication is performed during call processing operations.
    • Auth, Int, & Ciph: Authentication, Integrity Protection and Ciphering is performed during call processing operations.

    GPIB command: CALL:SECurity:OPERation

  • Authentication Algorithm

    The test set supports both the normal operation authentication algorithm ( Milenage (Rijndael) ) and the conformance test algorithm described in 3GPP TS 34.108 ( Test 34.108 ).

    GPIB command: CALL:SECurity:AUTHenticate:ALGorithm

  • Authentication Key

    32 hex digits representing the 128-bit subscriber key (K). The default value of Authentication Key matches the Agilent USIM's "Applicative Key" as described at www.agilent.com/find/usim.

    GPIB command: CALL:SECurity:AUTHenticate[:KEY]

  • Operator Variant Parm Type

    This setting specifies whether the Operator Variant Auth Alg contains the OP or OPc. If Operator Variant Auth Alg contains OP, the test set calculates OPc as per 3GPP TS 35.206.

    GPIB command: CALL:SECurity:AUTHenticate:OPVariant:PTYPe

  • Operator Variant Auth Alg

    32 hex digits representing either the 128-bit OP or OPc. You must indicate, using the Operator Variant Parm Type setting, whether this setting contains OP or OPc.

    GPIB command: CALL:SECurity:AUTHenticate:OPVariant:PVALue

  • Random (RAND) Value

    32 hex digits representing the 128-bit random challenge.

    GPIB command: CALL:SECurity:AUTHenticate:RANDom

  • AMF Value

    4 hex digits representing the 16-bit authentication management field.

    GPIB command: CALL:SECurity:AUTHenticate:AMF

Reset Authentication SQN

The authentication sequence number (SQN) is set to zero each time the test set is powered on. It then increments each time an authentication procedure is performed. The SQN can be reset to zero by selecting Reset Authen. SQN or sending the CALL:SECurity:AUTHenticate:SQN:RESet[:IMMediate] command.

Security Results

During the authentication procedure (see Security Ladder Diagrams ), the test set sends an Authentication Request message to the UE which contains RAND and AUTN (which is derived by the test set from K, SQN, AMF and RAND). If the UE determines that the AUTN contains a valid SQN and MAC, it sends an Authentication Response message to the test set, which includes RES. If the test set determines that the RES is valid, it returns an Authentication Result: MM or Authentication Result: GMM result (depending upon which domain has been authenticated) of Success . Otherwise, the test set sends the UE an Authentication Reject message and returns an Authentication Result of Incorrect RES Length or RES Does Not Match .

If the AUTN sent by the test set to the UE contains an invalid MAC or SQN, the UE sends an Authentication Failure message with the appropriate Cause information element (and AUTS if the failure cause is Synch Failure ; the test set then initiates the re-synchronization procedure). The test set then reports this Cause value in both the Authentication Result (MM or GMM) and in the UE Reported Failure Cause result. For example, you can induce a MAC Does Not Match authentication failure as shown below by changing the Authentication Key setting in the test set to NOT match that in the UE's USIM (note that when using the Test 34.108 Authentication Algorithm , the mismatch must occur in the first 8 hex digits in order for authentication to fail).

Authentication Result

The authentication results reported by the test set include:

  • Success
  • MAC Does Not Match: if UE Reported Failure Cause = 20.
  • Synch Failure: if UE Reported Failure Cause = 21.
  • Unknown: if UE Reported Failure Cause is any value other than 20 or 21.
  • Incorrect RES Length: if the RES Length is other than 8 bytes.
  • RES Does Not Match

Authentication results are reported separately for the packet switched (PS) and circuit switched (CS) domains:

  • Authentication Result: MM

    This result indicates the success or failure of the UE and test set to authenticate in the CS domain.

    GPIB command: CALL:SECurity:AUTHenticate:RESult[:MM]?

  • Authentication Result: GMM

    This result indicates the success or failure of the UE and test set to authenticate in the PS domain.

    GPIB command: CALL:SECurity:AUTHenticate:RESult:GMM?

UE Reported Failure Cause

The UE Reported Failure Cause can be any number between 1 and 255. 3GPP TS 24.008 s10.5.3.6 and s10. 5.5.14 provide mappings of the numeric values to their equivalent causes. The causes relevant to authentication are shown below (see 3GPP TS 24.008 s4.3.2.5.1 and sG.3).

GPIB command: CALL:MS:REPorted:AUTHenticate:FAILcause?

UE Reported Failure Cause
UE Reported Failure Cause | Description |
20 | MAC failure | "If the MS considers the MAC code (supplied by the core network in the AUTN parameter) to be invalid, it shall send an AUTHENTICATION FAILURE message to the network, with the reject cause 'MAC failure'."
21 | Synch failure | "If the MS considers the SQN (supplied by the core network in the AUTN parameter) to be out of range, it shall send a AUTHENTICATION FAILURE message to the network, with the reject cause 'Synch failure' and a re-synchronization token AUTS provided by the USIM (see 3GPP TS 33.102 [5a])."
23 | GSM authentication unacceptable | "In UMTS, an MS with a USIM inserted shall reject the authentication challenge if no Authentication Parameter AUTN IE was present in the AUTHENTICATION REQUEST message (i.e. a GSM authentication challenge has been received when the MS expects a UMTS authentication challenge). In such a case, the MS shall send the AUTHENTICATION FAILURE message to the network, with the reject cause "GSM authentication unacceptable"."

Integrity Key

If the Security Operations is set to Auth & Int or Auth, Int, & Ciph for the security procedure, the test set reports the Integrity Key being used. This results can also be queried by CALL:SECurity:RESult:INTegrity:KEY? .

Ciphering Key

If the Security Operations is set to Auth, Int, & Ciph for the security procedure, the test set reports the Ciphering Key being used. This results can also be queried by CALL:SECurity:RESult:CIPHering:KEY? .

Related Topics

Manual Operation: How Do I Change Security Info Parameters?


SIB11 Cell Info List

SIB11 Cell Info List

Last updated: January 15, 2009

You can specify neighbor cell information for the test set to broadcast in SIB11 on the BCCH.

There are three cell lists that the test set can send in SIB11: intra-frequency cell info list, inter-frequency cell info list and inter-RAT (GSM) cell list. To specify the details of these cell lists, see:

  • Intra-frequency Cells
  • Inter-frequency Cells
  • GSM Cells

These settings can only be changed when the call status is idle. Changing any of these settings while in active cell operating mode will result in the execution of the BCCH Update procedure (see Broadcast Channel (BCCH) Update Procedure (SIB Contents) ).

You can also specify that no cell lists are included using the Cell Info List setting.

Note that regardless of the Cell Info List setting, the test set does not actually generate any of these neighbor cells, it simply broadcasts a list of neighbor cells to the UE. However if you set Intra-freq 1st Cell Scrambling Code to the same value as the Primary Scrambling Code for cell 1 (see Downlink Channel Codes and Levels ), then the Intra-freq 1st neighbor cell is mapped to the actual cell 1 signal from the test set. Also, for the lab application only, if you set Intra-freq 2nd Cell Scrambling Code to the same value as Cell2 Primary Scrambling Code then the Intra-freq 2nd neighbor cell is mapped to the actual cell 2 signal from the test set. Mapping the intra-frequency neighbor cells to cell 1 and cell 2 in this way allows you to most closely emulate a real network situation. Also, for some devices, mapping cell 2 in this way may be required to allow successful soft handover (see Some UEs require Cell 2 Primary Scrambling Code = Intra Freq 2nd Cell Scrambling Code )

Cell Numbering Convention

Note, the information specified by Intra-freq 1st Cell State and Intra-freq 1st Cell Scrambling Code is transmitted in SIB11 as the information pertaining to "intra-frequency cell id" = 0 , as the "intra-frequency cell id" Information Element begins its numbering at 0; see 3GPP TS 25.331 10.3.7.33). Likewise, the information specified by Intra-freq 2nd Cell State and Intra-freq 2nd Cell Scrambling Code is transmitted in SIB11 as the information pertaining to "intra-frequency cell id" = 1 , etc. If you set the state of a cell to Off , then no information is sent for the "intra-frequency cell id" corresponding to that cell. This numbering convention is also true for the "inter-frequency cell id" for inter-frequency cells (see 3GPP TS 25.331 10.3.7.13) and "inter-RAT cell id" for GSM cells (see 3GPP TS 25.331 10.3.7.23).

Cell Lists

  • Intra-frequency Cells

    Intra-frequency cells are WCDMA neighbor cells on the same frequency as the serving cell, but with a different primary scrambling code.

    The intra-frequency cell info list sent in SIB11 can include up to 8 cells, indexed from 0 to 7.

    • Intra-freq <num> Cell State

      You can specify that some or all of the 8 intra-frequency neighbor cells are present ( Intra-freq <num> Cell State = On ) or not present ( Intra-freq <num> Cell State = Off ) in the intra-frequency cell info list.

      GPIB command: CALL[:CELL]:BCCHannel:ITAFrequency:STATe

    • Intra-freq <num> Cell Scrambling Code

      You can specify each intra-frequency cell's primary scrambling code. You may include the serving cell (test set) in the intra-frequency cell info list by including its primary scrambling code as one of the Intra-freq <num> Cell Scrambling Code entries.

      GPIB command: CALL[:CELL]:BCCHannel:ITAFrequency:SCODe

    • Intra-freq <num> Cell Cell Reselection Offset1

      In the lab application only, this setting specifies the Qoffset1 value signalled for each intra-frequency cell (see 3GPP TS 25.304 s5.2.6.1.4). This setting is only used by the UE when Quality Measure is set to CPICH RSCP.

      GPIB command: CALL[:CELL]:BCCHannel:ITAFrequency:CRESelection:OFFSet[1]

    • Intra-freq <num> Cell Cell Reselection Offset2

      In the lab application only, this setting specifies the Qoffset2 value signalled for each intra-frequency cell (see 3GPP TS 25.304 s5.2.6.1.4). This setting is only used by the UE when Quality Measure is set to CPICH Ec/N0.

      GPIB command: CALL[:CELL]:BCCHannel:ITAFrequency:CRESelection:OFFSet2

  • Inter-frequency Cells

    Inter-frequency cells are W-CDMA neighbor cells on a different frequency than the serving cell, and possibly with a different primary scrambling code.

    The inter-frequency cell info list sent in SIB11 can include up to 8 cells, indexed from 0 to 7.

    • Inter-freq <num> Cell State

      You can specify that some or all of the 8 inter-frequency neighbor cells are present ( Inter-freq <num> Cell State = On ) or not present ( Intra-freq <num> Cell State = Off ) in the inter-frequency cell info list.

      GPIB command: CALL[:CELL]:BCCHannel:ITRFrequency:STATe

    • Inter-freq <num> Cell Scrambling Code

      You can specify each inter-frequency cell's primary scrambling code.

      GPIB command: CALL[:CELL]:BCCHannel:ITRFrequency:SCODe

    • Inter-freq <num> Cell DL Channel

      You can specify each inter-frequency cell's downlink channel.

      GPIB command: CALL[:CELL]:BCCHannel:ITRFrequency:DOWNlink:CHANnel

    • Inter-freq <num> Cell Cell Reselection Offset1

      In the lab application only, this setting specifies the Qoffset1 value signalled for each inter-frequency cell (see 3GPP TS 25.304 s5.2.6.1.4). This setting is only used by the UE when Quality Measure is set to CPICH RSCP.

      GPIB command: CALL[:CELL]:BCCHannel:ITRFrequency:CRESelection:OFFSet[1]

    • Inter-freq <num> Cell Cell Reselection Offset2

      In the lab application only, this setting specifies the Qoffset2 value signalled for each inter-frequency cell (see 3GPP TS 25.304 s5.2.6.1.4). This setting is only used by the UE when Quality Measure is set to CPICH Ec/N0.

      GPIB command: CALL[:CELL]:BCCHannel:ITRFrequency:CRESelection:OFFSet2

  • GSM Cells

    The inter-RAT cell list sent in SIB 11 can include up to 8 GSM cells, indexed from 0 to 7.

    • GSM <num> Cell State

      You can specify that some or all of the 8 inter-RAT neighbor cells are present ( GSM <num> Cell State = On ) or not present ( GSM <num> Cell State = Off ) in the inter-RAT cell list.

      GPIB command: CALL[:CELL]:BCCHannel:GSMSystem:STATe

    • GSM <num> Cell NCC

      You can specify each GSM cell's NCC.

      GPIB command: CALL[:CELL]:BCCHannel:GSMSystem:NCC

    • GSM <num> Cell BCC

      You can specify each GSM cell's BCC.

      GPIB command: CALL[:CELL]:BCCHannel:GSMSystem:BCC

    • GSM <num> Cell Shared ARFCN Indicator

      You can specify each GSM cell's Shared ARFCN Indicator.

      GPIB command: CALL[:CELL]:BCCHannel:GSMSystem:BAND

    • GSM <num> Cell BCH ARFCN

      You can specify each GSM cell's BCH ARFCN.

      GPIB command: CALL[:CELL]:BCCHannel:GSMSystem:BCHannel

    • GSM <num> Cell Cell Reselection Min Rx Level

      This parameter is only available in the lab application.

      This parameter sets 3GPP TS 25.331 s10.3.2.3 "Qrxlevmin" for GSM in the "Cell selection and re-selection info for SIB11/12" information element (see 25.331 s10.3.2.4). According to 3GPP TS 25.304 s5.2.6.1.4, Qrxlevmin is the "minimum required RX level in the cell (dBm)". For GSM cells, the UE compares the RSSI it measures for the cell with Qrxlevmin to determine if it may select/reselect to the cell. (Note that this is similar to the RXLEV_ACCESS_MIN parameter defined in 3GPP TS 44.018 s10.5.2.4 and 45.008 s6.4 and s9.)

      GPIB command: CALL[:CELL]:BCCHannel:GSMSystem:CRESelection:RLMinimum

You can specify whether or not the test set broadcasts these neighbor cell lists in SIB11 using the following setting:

  • Cell Info List

    You may set this setting to Present (all three neighbor cell lists are included in SIB11) or Absent (no neighbor cell lists are included in SIB11).

    GPIB syntax: CALL[:CELL]:BCCHannel:CELLlist

Related Topics

Manual Operation: How Do I Change the SIB11 Cell Info List?

GPIB Syntax: CALL:BCCHannel

Broadcast Channel (BCCH) Update Procedure (SIB Contents)

Compressed Mode (Lab Application only)


Short Message Service (SMS)

Short Message Service (SMS)

Last updated: January 15, 2009

This section is only applicable to the lab application or feature-licensed test application.

The Short Message Service (SMS) testing capability available in the test set allows you to test both the cell broadcast and point-to-point (mobile terminated and mobile originated messages) SMS capability of your mobile station. The point-to-point testing capability is extensive, including support for concatenated and binary SMS applications like WAP Push, MMS notifications, ringtones, picture messaging, as well as character based languages such as Chinese, Japanese, and Hebrew. In addition to the standard GPIB and front panel interface, an HTTP interface is available providing easy connectivity with commercially available SMS Gateways. Support is also available for capturing logs of the protocol messages exchanged between the test set and the mobile station during SMS verification.

  • Cell Broadcast Service (CBS)
  • Point-to-Point SMS - Includes information on how to send and receive point-to-point SMS messages in either the CS (Circuit Switched) or PS (Packet Switched) domain.
    • Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station - Includes specific information on sending messages to the mobile station.
    • Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station - Includes specific information on receiving messages from the mobile station.
    • HTTP Interface for SMS - Introduction - Includes information on the HTTP interface available in the test set for sending and receiving SMS messages.
  • Multimedia Service (MMS) Messages
  • Logging SMS Messages

Related Topics

How to use the Short Message Service Features


Cell Broadcast Service (CBS)

Cell Broadcast Service (CBS)

Last updated: March 14, 2011

This section is only applicable to the lab applications.

You can test a mobile station's ability to receive Cell Broadcast messages using the Cell Broadcast Service capability in the test set.

Cell Broadcast Service (CBS) Overview

The Cell Broadcast Service in the test set allows you to send cell broadcast messages to the mobile station that are transmitted at a defined repetition interval (see Cell Broadcast Setup - General for more information). This allows the mobile station to receive the message even if entering the cell after the first transmission. The cell broadcast messages can be from one to fifteen pages in length, and are transmitted by the test set until the cell broadcast service is disabled or the state of the message(s) being transmitted is set to OFF.

The test set can enable up to three different messages to be transmitted each Repetition Period using the Cell Broadcast Service. The repetition period can potentially be set smaller than the time it takes to transmit all enabled messages, so priority is given to the messages in the following order (from high to low): message 1, message 2, then message 3. If there is not enough space to transmit the enabled messages, the test set either truncates the lowest priority messages or does not send them.

There are several message parameters that the test set allows you to set. It is important that you configure your mobile station to receive cell broadcast messages. This is done by enabling reception of messages in your mobile station and specifying the message parameters that it can receive, and set the parameters according to the type of cell broadcast message your mobile station is allow to receive. Cell broadcast messages are not acknowledged by the mobile station.

In addition to the pre-defined text strings, you can specify a custom text string and custom data to be sent in a cell broadcast message. See Cell Broadcast Messages -Content for more information on configuring the contents of the cell broadcast message.

WCDMA Cell Broadcast Messaging

The Cell Broadcast messages are transmitted by the Broadcast and Multicast Control (BMC) protocol layer over the CTCH (Common Traffic Channel) logical channel. The messages are sent using DRX (Discontinuous Reception) on the CTCH, and the CBS Schedule message states which fragments of CBS messages will be sent in specific frames. The MAC layer multiplexes the CTCH onto the FACH transport channel with the CCCH (Common Control Channel) logical channel. The FACH is then multiplexed onto the S-CCPCH (Secondary Common Control Physical Channel) with the PCH (Paging Channel) transport channel, which also uses DRX to transmit in particular frames. The test set gives priority to the PCH over the FACH. Thus, it is possible that CBS data might not be transmitted in the intended slot because the slot contains PCH data instead. If this occurs, the CBS data is sent in the subsequent slot, and the CBS data for the subsequent slot is discarded by the test set.

The BMC is responsible for the handling, scheduling and transmission of CBS messages. Its purpose is to allow the UE to selectively receive messages using Discontinuous Reception (DRX), by broadcasting a CBS Schedule Message in addition to the CBS message. The CBS schedule message contains information about subsequent CBS messages, including the timing of each transmission in the next schedule period. Each schedule period consists of transmission blocks called Common Traffic Channel Block Sets (CTCH-BS), and contains information about the subsequent scheduling period. The number of blocks in the scheduling period is limited by the 8-bit "Length of CBS Scheduling Period"; the value range being 1 to 256. Additionally, the CBS Schedule Message contains an 8-bit field "Offset to Begin CTCH-BS Index", ranging from 1 to 255, which points to the starting block of the next CBS Schedule period.

The CTCH is defined by 3GPP TS 25.301 as a point to multipoint unidirectional channel for the transfer of dedicated user information for all or a group of specified UEs. For CBS, the MAC layer multiplexes the CTCH onto the FACH with a fixed transport block size and TTI, where TTI is the transmission time interval that the FACH carries the CTCH. The TTI for the FACH is fixed at 10 ms in the test set, and can therefore transmit data 100 times a second. The actual TTI intervals in the FACH to be utilized by the CTCH are determined by the CTCH Allocation Period and the CBS Frame Offset parameter settings.

For example, in the figure below the CTCH Allocation period is 6, the CTCH Frame Offset is 2, and the number of radio frames in the TTI of the FACH that are used for the CTCH is 1.

The block size of the FACH is fixed in the test set so that 20 octets of data are available for each CTCH interval. Some of this space is used up for RLC headers. The formula to determine the number of blocks needed to carry a message of size X octets is: Number of Blocks = (X+20)/19 . The repetition period and allocation period both affect the bandwidth of CBS messages. If there is space to transmit only a portion of a message, the test set will truncate the message where possible and lower priority messages are not sent.

Cell Broadcast Message Setup

All three of the messages available for use in the test set's Cell Broadcast Service can be configured independently. The content of each message can include either one of two predefined text messages, a custom text message or a custom binary/UCS2 message.

There are several configurable parameters for each cell broadcast message. The serial number is made up of three of these parameters: Geographical Scope, Message Code, and Update Number as shown in the diagram below. Refer to 3GPP TS 23.041 version 9.6.0 section 9.4.1.2 for more information about cell broadcast message parameters.

Serial Number
Octet 1 |  |  |  |  |  |  |  | Octet 2
7 | 6 | 5 | 4 | 3 | 2 | 1 | 0 | 7 | 6 | 5 | 4 | 3 | 2 | 1 | 0
GS |  | Message Code |  |  |  |  |  |  |  |  |  | Update Number

Additionally, each message is classified by topic and allocated a message identifier, data coding scheme, and message content. The following list contains all the configurable cell broadcast message parameters offered by the test set.

  • State - allows you to configure which messages are sent using CBS. The message state must be ON for each message you want to send. The State for Message 1 is set to ON by default.

    The GPIB command for this parameter is CALL:SMService:CBRoadcast:MESSage[<n>]:STATe .

  • Geographical Scope (GS)

    This parameter indicates the geographical area over which the message code is unique and the mode that should be used by the mobile station when displaying the cell broadcast message.

    The following list contains the settings available for the Geographical Scope parameter.

    • Cell Wide / Immediate (CIMMediate) - Similar messages received in any other cell is regarded as new. The immediate display setting indicates that the cell broadcast message is displayed on the mobile station at all times. This setting corresponds to a GSCOPE request URL equal to 0.
    • PLMN Wide / Normal (PNORmal)- The message code and/or update number must change in the next cell for the cell broadcast message to be considered new. The cell broadcast message is displayed on the mobile station only when the user wants to see it.This setting corresponds to a GSCOPE request URL equal to 1.
    • Service Area Wide/Normal (SNORmal) - The cell broadcast messages with the same message code and update number are considered new only if the next cell is in a different location area than the current cell. The normal display mode displays the message only when the user wants to see it.This setting corresponds to a GSCOPE request URL equal to 2.
    • Cell Wide / Normal (CNORmal) - Similar messages received in any other cell is regarded as new. The normal display mode displays the message when the user wants to see it. This setting corresponds to a GSCOPE request URL equal to 3.

    The GPIB command for this parameter is CALL:SMService:CBRoadcast:MESSage[<n>]:GSCope .

  • Message Code

    The Message Code distinguishes messages from the same source and that are different types or themes. For more information on this parameter, refer to 3GPP TS 23.041 version 9.6.0 section 9.4.1.2.1.

    The GPIB command for this parameter is CALL:SMService:CBRoadcast:MESSage[<n>]:CODE .

  • Update Number

    This parameter is used to identify a particular version of a message. This is useful for reporting a dynamic situation, where a message may be reporting one event (such as road works or road construction ahead), but the details change periodically (the length of the tail-back or traffic jam caused, for example). A mobile station which remains in one cell for a length of time receives messages with the same message code but increments the update numbers as updated versions of the same message are received. A mobile station that has just entered a cell receives only the most recent version of the message, followed by any subsequent versions. The update number wraps from 15 to 0.

    The GPIB command for this parameter is CALL:SMService:CBRoadcast:MESSage[<n>]:UPDate .

  • Message Identifier

    The parameter is a header number identifying the message topic (such as 'Weather Report' or 'Traffic Information').

    Several categories of message topics are identified in 3GPP TS 23.041 version 9.6.0 section 9.4.1.2.2. The main topics are location services (LCS), the earthquake and tsunami warning system (ETWS), and the commercial mobile alert system (CMAS). Many message identifier values are reserved for future use but will likely be specified in future releases of 3GPP TS 23.041.

    Message identifier values in the decimal range 1000 to 1003 are used for LCS.

    ETWS and CMAS are part of the public warning system (PWS) required for use in the United States. Message identifier values in the decimal range 4352 to 4356 are used for ETWS. CMAS defines three classes of warning notification: presidential, imminent threat and child abduction emergency (e.g. Amber Alert). Message identifier values within the decimal range 4370 to 4399 are used for CMAS. The exact meaning of each message identifier value is specified in 3GPP TS 23.041 version 9.6.0 section 9.4.1.2.2.

    The test set allows entry of any message identifier value within the full decimal range specified by 3GPP TS 23.041: 0 to 65535.

    The GPIB command for this parameter is CALL:SMService:CBRoadcast:MESSage[<n>]:IDENtifier .

  • Data Coding Scheme Specification

    This parameter indicates the method used to set the data coding scheme. The methods available are Language (see Data Coding Scheme Language ) and Value (see Data Coding Scheme Value ).

    The GPIB command to specify the which method is used is CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme[:SPECify] .

  • Data Coding Scheme Language

    This parameter sets the data coding scheme value associated with the indicated language. The data coding scheme indicates the intended handling of messages, the alphabet and coding of the message content, and the associated language of the text. Changing this parameter does not translate the text of a message or change the message contents; it is used to configure the message's data coding scheme value.

    Although this method is only appropriate for configuring text messages, no error message is displayed if you set a data coding scheme value when the message content is set to data.

    Refer to 3GPP TS 23.038 version 9.1.1 section 5 for details about setting the CBS Data Coding Scheme.

    The GPIB command to specify the how the mobile station interprets the content of received text messages by specifying a language is CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:LANGuage .

  • Data Coding Scheme Value

    This parameter sets the 8-bit data coding scheme value that indicates the intended handling of messages, the alphabet and coding of the message content, and the associated language of the text. Changing this parameter does not translate the text of a message, it is used to automatically configure the message's data coding scheme.

    Refer to 3GPP TS 23.038 version 9.1.1 section 5 for details about setting the CBS Data Coding Scheme.

    The GPIB command to specify the how the mobile station interprets the content of received text messages by specifying the data coding scheme value is CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:VALue .

  • Content associates the message with the actual data to be sent by the test set. See Cell Broadcast Messages -Content for more specific information on the cell broadcast messages that can be sent from the test set.

    The GPIB command for this parameter is CALL:SMService:CBRoadcast:MESSage[<n>]:CONTent .

Cell Broadcast Setup - General

The settings for the parameters explained in this section apply to all cell broadcast messages.

  • Repetition Period

    The repetition period determines how often the cell broadcast messages are transmitted. The repetition period is applied to all cell broadcast messages. The test set checks the value of the repetition period every time a schedule is built. If the value has changed from its previous value, then the next message repetition time is recalculated based on the new repetition period setting.

Cell Broadcast Messages -Content

Several Cell Broadcast Service (CBS) message options are available which allow you to choose or create messages to be sent. You can set the Content parameter to Text1 , Text2 , Custom Text, or Custom Data . See the sections below for more information about these settings.

Predefined Cell Broadcast Text Messages

User Defined Text Message (Custom Text)

User Defined Text Message (Custom Data)

Predefined Cell Broadcast Text Messages

There are two predefined cell broadcast text messages. The ASCII text strings of these messages are as follows:

  • Predefined text message 1 ( Text1 )

    The quick brown fox jumps over the lazy dog

  • Predefined text message 2 ( Text2 )

    This instrument provides functional testing of cell broadcast SMS by sending up to three broadcast messages to the device under test. Two fixed text messages and user defined text or binary/UCS2 messages are available for selection. The second fixed message spans multiple pages.

User Defined Text Message (Custom Text)

You can set the cell broadcast message to send a customized text message by setting the Content parameter to Custom Text . You can define the text for the custom text cell broadcast message using the following GPIB command:

CALL:SMService:CBRoadcast:MESSage[<n>]:CTEXt .

A custom text message can be defined only via the remote user interface and HTTP. The maximum length for the cell broadcast user defined messages is 1395 characters.

The default the custom text message is:

" Enter your text here"

NOTE
Text messages sent from the test set to the mobile station are encoded using the ETSI Default Alphabet character set. The ETSI Default Alphabet encoding shares the majority of its character codes with those used by the ASCII character set. Between the two character sets, all alphanumeric characters and most punctuation characters have identical codes.

For the custom user defined text message, the test set accepts a 7-bit ASCII string. This string is then encoded using the ETSI Default Alphabet before it is transmitted. The ASCII code for each character in this string is mapped to the ETSI Default Alphabet character with the same code. Characters present in the user defined text message whose ASCII and ETSI Default Alphabet codes are not identical will be received and displayed by the mobile station as the ETSI Default Alphabet character with the original ASCII character's code. This behavior is only noticeable with certain user defined text messages as all of the predefined text messages use only alphanumeric and basic punctuation characters.

User Defined Text Message (Custom Data)

You can set the cell broadcast message to send a customized data message by setting the Content parameter to Custom Data . You can define the binary data/UCS2 for the custom data cell broadcast message using the following GPIB command:

CALL:SMService:CBRoadcast:MESSage[<n>]:CDATa .

A custom data message can be defined only via the remote user interface. The maximum length for the cell broadcast user defined messages is 2460 hexadecimal characters.

The default custom data message is an empty string.

Related Topics

HTTP Interface for Cell Broadcast Service - Introduction

Short Message Service (SMS)

Point-to-Point SMS

How to use the Short Message Service Features

Cell Broadcast Service (CBS) Troubleshooting

CALL:SMService


HTTP Interface for SMS - Introduction

HTTP Interface for SMS - Introduction

Last updated: January 15, 2009

The HTTP interface in the test set provides an industry standard interface for interfacing the base station simulation capability of the test set with necessary external components for verifying SMS capability in a mobile station. The HTTP implementation in the test set also provides SMS routing capability, simulating a simple Short Message Service Center (SMSC).

Introduction to HTTP

HTTP is the client/server based protocol used to deliver virtually all files and data on the World Wide Web. If you'd like a more detailed description of HTTP protocol, refer to Internet RFCs `HTTP/1.0 - RFC 1945' and `HTTP/1.1 - RFC 2616', which can be downloaded from http://www.rfc-editor.org/rfc.html.

When you use HTTP in a web browser, you enter the "address" for the web page you wish to view. These addresses can be generalized into the following format:

In this example, the web browser is the HTTP client and it uses the information in this address to open a connection to an HTTP server and send a request.

  • "http://" is the protocol specifier, telling the browser what protocol to use for the request.
  • <ip_address> is the IP address of the server.
  • <port> is the port number on which to communicate with the server. The default port for HTTP is 80.
  • <request_URL> provides information to the server on the location of the resource that's being requested and can also be used to provide information to the resource.

HTTP Interface for SMS verification

The test set acts as both a server and a client, depending on which operation it is performing.

The test set as the server:

If you have a PC and your test set connected to a network or directly connected together, you can open a web browser (client) and send a request to the test set using the test set's IP address and a correctly configured request URL. For example, you might send the following from the web browser if your test set's IP address was 111.111.111.112.

NOTE
It is not necessary to specify a port number because the test set uses 80, which is the default port for HTTP.

Sending the URL causes an SMS message to arrive at the mobile station attached to the test set's RF port. This message contains the text "hello".

The test set acts as the server for mobile terminated SMS messages. While this is a simple example, this same information is necessary to configure an SMS Gateway or proprietary software for interfacing with the test set via HTTP.

For configuration information see:

  • HTTP Interface Configuration for Mobile Terminated SMS .

The test set as the client:

SMS messages originating from the mobile station attached to the test set are sent out the test set's LAN port as HTTP requests to the IP address for the intended receiving entity.

For configuration information see:

  • HTTP Interface Configuration for Mobile Originated SMS

Related Topics

HTTP Interface Configuration for Mobile Terminated SMS


HTTP Interface Configuration for Mobile Originated SMS

HTTP Interface Configuration for Mobile Originated SMS

Last updated: January 15, 2009

Information must be provided to the test set in order for mobile originated SMS messages to be correctly routed by the HTTP SMS Router to the receiving entity. The test set's HTTP interface must be enabled before it can be used to send messages and the HTTP Interface must be configured with information about where to route the messages.

See the following sections for more information about configuring the HTTP interface for mobile originated messages.

  • Enable the Test Set's HTTP Interface
  • HTTP Interface Settings - General
  • HTTP Interface Settings for Using an SMS Gateway
  • Configuring Message URL
  • Example Text Message URL
  • Example Binary Message URL

Enable the Test Set's HTTP Interface

You must enable the HTTP interface output in the test set. This can be done via a GPIB command (see CALL:SMService:HTTProtocol:OUTPut ) or from the test set's front panel (see Enabling the HTTP Interface for Mobile Originated SMS ).

If the interface is not enabled, messages received from a mobile station are not output over HTTP.

HTTP Interface Settings - General

See HTTP SMS Router Web-based Configuration Interface for information on how to change the settings described in this section. Two of the settings are general and apply to every testing scenario:

  • DUT Sender address
  • Other 8960 IP Address or Alternative Device Destination (SMS Gateway) IP Address

DUT Sender address

The DUT Sender address setting allows you to associate a phone number with the mobile station originating the messages. This setting may not be required by the receiving entity, but is useful to allow mobile originated messages to be `replied' to correctly in a test system configuration making use of a gateway and more than two mobile stations and test sets.

Setting Type | String
Factory Setting | "1000"
Range | 0 - 20 character ASCII formatted string of BCD digits from 0-9, *, #, A-C

Other 8960 IP Address or Alternative Device Destination (SMS Gateway) IP Address

The IP Address where the HTTP SMS Router is to send the mobile originated message. You can only specify one destination IP address, therefore, if you want to use more than two test sets in a test system, you must use an intermediate SMS gateway or other software to route the messages.

If you have a test system with two test sets and are not using an SMS Gateway, you would specify the Other 8960 IP Address to be the other test set's IP Address. If you are sending the messages to another entity for routing, like an SMS Gateway, specify the IP Address of the PC on which that entity is running.

Setting Type | String
Factory Setting | ""
Range | Any valid IP address

HTTP Interface Settings for Using an SMS Gateway

See HTTP SMS Router Web-based Configuration Interface for information on how to change the settings described in this section. The following settings are only used when Alternative Device Destination (SMS Gateway) as been selected for the Output Destination. When Other 8960 is selected, these parameters are automatically configured internal to the test set.

  • Destination Port
  • Text Message URL
  • Binary Message URL
  • Request Method

Destination Port

The TCP/IP port on which the receiving entity listens for web/HTTP requests.

Setting Type | Numeric
Factory Setting | 80
Range | 0-65534

Text Message URL

Defines the URL format for SMS text messages accepted by the receiving entity, which might be an SMS gateway or proprietary software. The test set automatically selects this URL if the type of message received from the mobile station is a text message. See Example Text Message URL for more information on specifying this URL.

Setting Type | String
Factory Setting | ""
Range | 0 - 256 character ASCII formatted string

Binary Message URL

Defines the URL format for SMS binary messages accepted by the receiving entity, which might be an SMS gateway or proprietary software. The test set automatically selects this URL if the type of message received from the mobile station is any type of binary or Unicode message. See Example Binary Message URL for more information on specifying this URL.

Setting Type | String
Factory Setting | ""
Range | 0 - 256 character ASCII formatted string

Request Method

Allows you to select which HTTP request method the test set's HTTP interface is to use when sending SMS messages over HTTP. The method to use is dependent on the format accepted by the receiving entity.

Setting Type | Enum
Factory Setting | GET
Range | GET|POST

Configuring Message URL

Just as the test set requires a specific format for request URLs received at it's HTTP interface, so do SMS Gateways or customer programs receiving request URLs from the test set. This is very similar to the URL requests configuration discussed for mobile terminated SMS messages (see Configure the Request URL ).

In order to configure the text and binary URLs for the test set's HTTP interface, you must know the receiving entity's requirements for request URLs. If the message is being sent directly to another test set, it is not necessary to configure the message URLs.

Use the tags defined in the following table, Message URL Tags , when configuring the text and message URLs. When a mobile originated message arrives at the test set, the tags in the message URL are replaced with the respective message content before the request URL is sent to the receiving entity.

Message URL Tags

Tag | Replaced with
@@TEXT@@ | The ASCII text of a received text message (reformatted to meet URL escaping requirements). Should only be used for 7-bit text messages and will return the same as the @@DATA@@ tag if used for binary messages.
@@DATA@@ | The message content as a string of hex characters, not including any user data header present in the content. Should only be used for binary messages and will return the same as the @@TEXT@@ tag if used for 7-bit text messages
@@NUMBER@@ | The destination phone number of the message.
@@SENDER@@ | The assigned originating phone number of the message as defined by the Sender Address setting detailed in section 4.2.3.2
@@UDH@@ | The User Data Header of the message as a string of hex characters. Should only be used for binary messages, will return an empty string if used otherwise.
@@UHDI@@ | The User Data Header indicator of the received message, either 0 (UDH not present) or 1 (UDH present).
@@PID@@ | The Protocol Identifier of the received message as a decimal number.
@@PIDHEX@@ | The Protocol Identifier of the received message as a string of hex characters.
@@DCS@@ | The Data Coding Scheme of the received message as a decimal number.
@@DCSHEX@@ | The Data Coding Scheme of the received message as a string of hex characters.
@@SRR@@ | The Status Report Request flag of the received message, either 0 or 1.
@@MREF@@ | The Message Reference number of the message as a decimal number
@@MREFHEX@@ | The Message Reference number of the message as a string of hex characters.
@@TRANSPORT@@ | The transport that was used by the DUT when originally sending the message, this parameter is replaced with a text string of "CS Domain" or "PS Domain" if included in the format string.

Example Text Message URL

You might configure your text message URL to look like the following:

If a text message is sent from the mobile station attached to the test set with the following information:

  • Destination number: 12345
  • Message Text: "This is a text message"

And the DUT Sender Address is configured to be `1000', the following URL request is sent by the test set to the receiving entity at the currently configured IP Address and Port Number:

/?PhoneNumber=12345&Text=This%20is%20a%20text%20message&Sender=1000

Example Binary Message URL

You might configure your binary message URL to look like the following:

Note the `Binary=1', `User=user535', and `Password=pass' parameters at the end of the format string. These do not contain any test set defined tags (see Message URL Tags ), but it can be useful to specify such extra parameters if the receiving entity, like an SMS gateway for example, requires username and password information included in URL requests or a specific flag to inform it the message is binary.

If a binary message is sent from the mobile station attached to the test set with the following information:

  • Destination number: 54321
  • Message Content: 140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C65000701 03424243206D6F62696C652073697465000101
  • User Data Header: 0605040B8423F0
  • Protocol ID: 0
  • Data Coding Scheme: 245

The following URL request is sent by the test set to the receiving entity at the currently configured IP Address and Port Number:

/?PhoneNumber=54321&Data=140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C6500070103424243206D6F62696C652073697465000101&UDH=0605040B8423F0&PID=00&DCS=245&Binary=1&User=user535&Password=pass

Related Topics

HTTP SMS Router Web-based Configuration Interface


HTTP SMS Router Web-based Configuration Interface

HTTP SMS Router Web-based Configuration Interface

Last updated: January 15, 2009

This section explains how to use the web-based interface provided for configuring the HTTP SMS Router for mobile originated SMS messages. To configure the HTTP Interface for Mobile Originated SMS, you must have an active LAN connection to the test set in order to access its http server. You can access the HTML pages for configuration via any standard internet browser.

  • Accessing the web-based HTTP SMS Router Interface
  • Current Configuration
  • Change Configuration
  • Configuration Error

Accessing the web-based HTTP SMS Router Interface

  1. Access the instrument home page for your test by directing an internet browser to http://x.x.x.x, where `x.x.x.x' is the IP address of the test set to which the mobile station is attached that is sending the mobile originated message. The test set's home page is displayed in the browser window, as shown below.

  2. Click on SMS (circled in red in the previous figure). This opens the HTTP SMS Router Current Configuration page.

Current Configuration

The current HTTP Interface Settings are summarized on the Current Configuration page. See Change Configuration for information on changing these settings.

NOTE
Although the enabled or disabled state of both the HTTP Input interface and the HTTP Output interface is displayed on the Current Configuration page, these settings cannot be changed using the web-based interface. For instructions on changing these settings, see Enable the Test Set's HTTP Interface .

Change Configuration

The following parameters are configured using the HTTP SMS Router Web-based Configuration Interface. For more detailed explanation of each of these parameters, see HTTP Interface Settings - General .

  • DUT Sender address
  • Other 8960 IP Address
  • Alternative Device Destination IP Address
  • Destination Port
  • Text Message URL
  • Binary Message URL
  • Request Method

Click on the Change button from the HTTP SMS Router Current Configuration page to access the HTTP SMS Router Change Configuration page.

The HTTP SMS Router Change Configuration page, shown in the figure below, allows changes to be made to the HTTP Interface Settings.

The HTTP SMS Router Change Configuration page is divided into two sections: General and Output Destination.

General

This section controls the number that is associated with the mobile station for messages output over the HTTP interface.

Output Destination

This section allows you to specify the destination for mobile originated SMS messages. If this is another test set, only the IP address of the destination test set is required for this section. For other destinations, such as an SMS Gateway running on a PC, more specific details are required.

Click the Apply Changes button to save any configuration changes you have made. The browser returns to the HTTP SMS Router Current Configuration page.

Alternatively, use the Cancel button to discard any changes you have made that you do not want saved.

Configuration Error

If any of the settings specified on the HTTP SMS Router Change Configuration page contain illegal values when the Apply Changes button is clicked, the HTTP SMS Router Configuration Error page is displayed. This page provides a description of the first error found when verifying the updated settings. Press the Back button to return to the HTTP SMS Router Change Configuration page to correct any errors.

Example Configuration Error page

Related Topics

HTTP Interface Configuration for Mobile Originated SMS


HTTP Interface Configuration for Mobile Terminated SMS

HTTP Interface Configuration for Mobile Terminated SMS

Last updated: January 15, 2009

If you wish to use the HTTP interface in the test set to route SMS messages to the mobile station attached to the test set's RF port you must do the following:

  1. Enable the Test Set's HTTP Interface
  2. Specify the SMSC IP Address and Port
  3. Configure the Request URL

Enable the Test Set's HTTP Interface

You must enable the HTTP interface in the test set. This can be done via a GPIB command (see CALL:SMService:HTTProtocol:INPut ) or from the test set's front panel (see Enabling the HTTP Interface ).

If the interface is not enabled, HTTP SMS requests sent to the test set are rejected and the HTTP error code 503 (Service Unavailable) is returned to the client issuing the request.

Specify the SMSC IP Address and Port

Several different types of clients could be used to send SMS messages to the test set. Some examples are:

  • SMS Gateway
  • another test set
  • a custom http client

When setting up any of these clients, it is necessary to specify the IP Address and port number on which the test set is listening for incoming messages. These parameters are always to be configured as follows:

  • IP Address/Host Name: The IP address of the test set receiving the messages
  • Port number: 80

NOTE
When configuring an SMS Gateway, these parameters apply to the SMSC configuration. In a test system with more than one test set, each test set may be thought of as a separate SMSC and configured as such in the gateway.

Configure the Request URL

When using the HTTP interface in the test set for sending SMS messages, you must configure a request URL.

Requests to send SMS messages to the mobile station attached to the test set using the HTTP interface must be configured using the following rules:

  1. The request URL format accepted by the test set is:

    /sms/send/?parameter1=value1&parameter2=value2&parameter3=value3......

    NOTE
    "/sms/send/?" must be specified at the beginning of the request URL in order for the test set to recognize the HTTP request as a request to send an SMS message to the mobile station.

    The parameters and values variables provides the content of the SMS message as well as additional information for header configuration and test set configuration. All configurable parameters and values are detailed in Request URL Parameters .

  2. Mandatory parameters must be included in the request URL. The mandatory parameters depend on the content of the SMS message you are sending.
    SMS Message Content Type | Mandatory Parameters
    7-bit text | TEXT
    8 or 16 bit data | DATA and/or UDH
  3. An HTTP error code of 400 (Bad Request) is returned to the client initiating an HTTP request and the message is not forwarded on to the mobile station if one or both of the following is true:
    • any parameter values in the request URL do not adhere to the constraints detailed in Request URL Parameters , or
    • any mandatory parameters are not present.
  4. Optional parameters may be set equal to an empty value in the request URL. For example, if parameter2 is an optional parameter, then /sms/send/?parameter1=value1&parameter2=&parameter3=value3 is a valid request URL. The test set uses the default value for optional parameters when they have been set to empty values.
    Optional Parameters
    UDHI
    PIDHEX or PID
    DCSHEX or DCS
    SENDER
    MMTS
    SRI
    RPATH
    TRANSPORT
  5. Parameters in the request URL can be in any order.
  6. When a text message is being submitted via the `TEXT' parameter, HTTP URL escaping restrictions apply. Therefore, all space characters must be replaced with the `%20' character sequence. Other characters that require escape characters when used in URLs are detailed in the following table.

    Character to URL Escape Sequence Mapping

    NOTE
    It is only necessary for you to use the escape characters when building a request URL manually. If you are sending messages to the mobile station through either an SMS gateway or from another 8960, the escaping is performed automatically.

Request URL Parameters

Parameter | Use and expected value | Inclusion
TEXT | 0-160 character string of 7-bit text characters. The underlying character codes specified here are used directly when sending the message OTA and will be interpreted by a receiving mobile station as per the ETSI default Alphabet specification. | This parameter must be included in all HTTP requests to send 7-bit text based SMS messages. It must not be included in the same request as either of the DATA or UDH parameters outlined below.
DATA | 0-280 ASCII formatted hex characters (the length of the combined UDH and DATA values must not exceed 280 characters) | One or both of these parameters must be included in all HTTP requests to send binary SMS messages. The UDH and data for a message may be encoded as a single hex string and specified via either of these parameters, or may instead be specified separately and sent via both parameters. Neither of these parameters may be present in the same request as the TEXT parameter outlined above.
UDH | 0-280 ASCII formatted hex characters representing the User Data Header to be included in the message content (the length of the combined UDH and DATA parameters must not exceed 280 characters)
UDHI | The User Data Header Indicator (TP-UDHI) of the message. Should be either 0 or 1 to indicate the presence of a User Data Header in the message content. If a UDH parameter (see above) containing a non-empty value is present in the request URL, the UDHI used when sending the message OTA is always 1 regardless of the presence/value of the this parameter. | Optional (Default = 0)
PIDHEX | The Protocol Identifier (TP-PID) of the message as a string of hex characters | Both of these parameters are optional but at most one may be included in any request. (Default = 0)
PID | The Protocol Identifier (TP-PID) of the message as a decimal number
DCSHEX | The Data Coding Scheme (TP-DCS) of the message as a string of hex characters | Both of these parameters are optional but at most one may be included in any request. (Default = 0)
DCS | The Data Coding Scheme (TP-DCS) of the message as a decimal number
SENDER | The phone number of the sending client as a 0 - 20 character ASCII formatted string of BCD digits from 0-9, *, #, a, b, c | Optional (Default = 1000)
MMTS | The More Messages to Send value for the SMS PDU header. Should be either 0 or 1. | Optional (Default = 1)
SRI | The Status Report Indication value for the SMS PDU header. Should be either 0 or 1. | Optional (Default = 0)
RPATH | The reply path value for the SMS PDU header. Should be either 0 or 1. | Optional (Default = 0)
TRANSPORT | The transport mechanism to use when sending the message, valid value is either `CS Domain' or `PS Domain'. | Optional (Default = Whatever SMS transport is currently set for use in the instrument receiving the request)

Example request URL strings

Text message:

To send a text based SMS message with the following message details:

  • Originating number: 1001
  • Message Text: "This is a simple text message"

you would format the HTTP request URL as follows:

/sms/send/?TEXT=This%20is%20a%20simple%20text%20message&SENDER=1001

Binary message:

To send a binary message with the following message details:

  • Originating number: 987654321
  • Message Content: 140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C6500070103424243206D6F62696C652073697465000101
  • User Data Header: 0605040B8423F0
  • Protocol ID: 0
  • Data Coding Scheme: 245

you would format the HTTP request URL as follows:

/sms/send/?DATA=140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C6500070103424243206D6F62696C652073697465000101&PID=0&DCS=245&SENDER=987654321&UDH=0605040B8423F0

or, the test set also allows you to include the User Data Header as part of the `DATA' parameter as explained in the table Request URL Parameters . Therefore, the HTTP request URL could instead be configured as follows:

/sms/send/?DATA=0605040B8423F0140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C6500070103424243206D6F62696C652073697465000101&UDHI=1&PID=0&DCS=245&SENDER=987654321

Accepted HTTP request methods

Both POST and GET HTTP requests are accepted by the test set for sending SMS messages.

If POST is used as the request method, the URL request parameters detailed in Request URL Parameters are not included in the request URL, but are included in the request body instead. Therefore, the request URL in POST requests contains only `sms/send'.

Related Topics

HTTP Interface for SMS - Introduction


Logging SMS Messages

Logging SMS Messages

Last updated: January 15, 2009

This section is only applicable to the lab applications.

You can use the Wireless Protocol Advisor (WPA) to log SMS messages.

  • SMS Logging Control
  • Setting Up the Wireless Protocol Advisor (WPA)
    • SMS Message Log
    • Cell Broadcast Message Log

SMS Logging Control

The test set gives you access to the protocol layers necessary to allow you to observe the SMS cell broadcast and point-to-point messages. You can capture all the messages exchanged between either the GMM or MM and these protocol layers:

  • CM - Connection Management
  • SMRL - Short Message Relay Layer
  • SMTL - Short Message Transport Layer

SMS Message Support

The messages in the following tables are examples of messages related to SMS. The table indicates whether each is supported in the test set. There may be more messages supported by the test set or by the Wireless Protocol Advisor. In addition, certain parameters in these messages may not be supported.

SMS Point-to-Point Messages
Messages | Supported
SMS_CP_DATA | Yes
SMS_CP_ERROR | Yes
SMS_CP_ACK | Yes
SMS_RL_MS2N_DATA | Yes
SMS_RL_N2MS_DATA | Yes
SMS_RL_MS2N_ERROR | Yes
SMS_RL_N2MS_ERROR | Yes
SMS_RL_MS2N_ACK | Yes
SMS_RL_N2MS_ACK | Yes
SMS_RL_MS2N_SMMA | Yes
SMS_TP_DELIVER | Yes
SMS_TP_SUBMIT_RPT | Yes
SMS_TP_STATUS_RPT | Yes
SMS_TP_DELIVER_RPT | Yes
SMS_TP_SUBMIT | Yes
SMS_TP_COMMAND | No
User Configurable SMS Message Parameters
Mobile-Terminated SMS Parameters on Test Set | Parameters in 3GPP TS 23.040 | Message Types
Content | TP-User Data (TP-UD) - 9.2.3.24 | Deliver, Submit Report, Status Report
Message Type | TP-Message Type Indicator (TP-MTI) - 9.2.3.1 | Deliver, Submit Report, Status Report
Data Coding Scheme | TP-Data Coding Scheme (TP-DCS) - 9.2.3.10 (Defined in 3GPP TS 23.038) | Deliver, Submit Report, Status Report
Failure Cause | TP-Failure Cause (TP-FCS) - 9.2.3.22 | Submit Report if RP type is set to RP-ERR
Message Reference | TP-Message Reference (TP-MR) - 9.2.3.6 | Status Report
More Messages to Send | TP-More Messages to Send (TP-MMS) - 9.2.3.2 | Deliver, Status Report
Parameter Indicator | TP-Parameter Indicator (TP-PI) - 9.2.3.27 | Submit Report, Status Report
Protocol Identifier | TP-Protocol Identifier (TP-PID) - 9.2.3.9 | Deliver, Submit Report
Reply Path | TP-Reply Path (TP-RP) - 9.2.3.17 | Deliver
Status | TP-Status (TP-ST) - 9.2.3.15 | Status Report
Status Report Indication | TP-Status Report Indication (TP-SRI) - 9.2.3.4 | Deliver
User Data Header Indicator | TP-User Data Header Indication (TP-UDHI) - 9.2.3.23 | Deliver, Submit Report, Status Report
Originating Address | TP-Originating Address (TP-OA) - 9.2.3.7 | Deliver
Recipient Address | TP-Recipient Address (TP-RA) - 9.2.3.14 | Status Report
Mobile Originated Parameters
Mobile-Originated SMS Parameters available for query from the test set | Parameters in 3GPP TS 23.040
Coding Scheme | TP-Data Coding Scheme (TP-DCS) - 9.2.3.10 (Defined in 3GPP TS 23.038)
User Data Length | TP-User Data Length (TP-UDL) - 9.2.3.24
Destination | TP- Destination Address (TP-DA) - 9.2.3.8
Content | TP-User Data (TP-UD) - 9.2.3.24
Reference No. | TP-Message Reference (TP-MR) - 9.2.3.6
UDHI | TP-User Data Header Indication (TP-UDHI) - 9.2.3.23
Protocol Identifier | TP-Protocol Identifier (TP-PID) - 9.2.3.9
Status | TP-Status Report Request (TP-SRR) - 9.2.3.5

Setting Up the Wireless Protocol Advisor (WPA)

You can use the Wireless Protocol Advisor (WPA) to log the messages exchanged between the test set and the mobile station during SMS procedures. This tool provides a means to evaluate the mobile station's performance and to troubleshoot problems.

You can set up the WPA to capture and display as much or little information as you want. For this example, the logging filter is defined to capture only SMS protocol messages. The view filter is configured to only display the CP-Data messages. This allows you to view only the messages that contain the SMS message contents being exchanged between the mobile station and the test set.

Test Set Message Filter Setup

The test set filter is useful for limiting the amount of data sent over the LAN connecting the test set and the WPA. In the example below, all messages are sent from the test set to the WPA.

All filters are accessed from the Measurement Setup view. This can be accessed from the menu bar by clicking:

WPA Logging Filter Setup

The logging filter is useful for limiting what messages get captured in your log. Using this filter, you can choose to only log certain types of messages from certain protocol layers. In this example, we are using the logging filter to limit the captured log to SMS protocol messages.

WPA View Filter Setup

The view filter has no effect on what messages are captured. It simply limits the messages that are visible on the WPA's traffic overview. The view filter can easily be enabled and disabled by right clicking your mouse in the traffic overview and selecting View Filter Enabled from the menu that appears.

In the following view filter example, the messages in the traffic overview are limited to the CP-Data messages.

SMS Message Log

For the step-by-step procedure for setting up the test set to capture this log, refer to Mobile Originated Point-to-Point Message Transfer .

The captured log allows you to determine exactly what is being exchanged between the test set and the mobile station. In this example, an SMS message was sent from the test set to the mobile station. You can look in the decode of the captured message to verify all the parameters associated with that message. The following data is only a portion of the decode belonging to the captured message. In this data, you can see the text message that was sent to the mobile station.

Cell Broadcast Message Log

Agilent's Wireless Protocol Advisor (WPA) allows you to capture the cell broadcast messages sent from the test set to the mobile station, and can be used to troubleshoot the handling of received messages. The figure below is a protocol log captured from WPA when the Cell Broadcast Service has been started and the repetition period is set to 15 seconds. The test set sends the message in segments governed by the size of the RLC block. The message decode of the selected portion of a message (dark blue) is shown in the bottom portion of the figure. The message decode shows several parameters, including the number of pages, message ID, geographical scope, and the content of the message, which is a three page text message. The following data is only shows a portion of the decode belonging to the captured message. These portions show the 3-page text message divided into pages. Piecing these pages together combines to make the following message:

This instrument provides functional testing of cell broadcast SMS by sending up to three broadcast messages to the device under test. Two fixed text messages and user defined text or binary/UCS2 messages are available for selection. The second fixed message spans multiple pages.

Related Topics

Protocol Logging


Short Message Service (SMS) Messages

Short Message Service (SMS) Messages

Last updated: January 15, 2009

This section is only applicable to the lab application or feature-licensed test application.

Several Short Message Service (SMS) message options are available which allow you to choose or create the message content to be sent to the mobile station.

The Content parameter for SMS includes the following selections:

  • Text1 - see Predefined Point-to-Point Text Messages
  • Text2 - - see Predefined Point-to-Point Text Messages
  • Custom Text - see User Defined Text Message (Custom Text Message)
  • Custom Data - Defining the User Data (TP-UD) content for Binary SMS Applications

You can use the following GPIB command to select the content type to be used in mobile terminated SMS messages:

CALL:SMService:PTPoint[:MTERminated]:CONTents .

Predefined Point-to-Point Text Messages

There are two predefined point-to-point text messages. The ASCII text strings of these messages are as follows:

  • Predefined text message 1 ( Text1 ) -

    01234567890ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz

  • Predefined text message 2 ( Text2 ) -

    Agilent Technologies, your partner in wireless solutions.

User Defined Text Message (Custom Text Message)

You can also customize the text sent in the sms message using the Custom Text message. You can define the text for the custom message using the following GPIB command:

CALL:SMService:PTPoint[:MTERminated]:TEXT:CUSTom .

The custom text message can be defined only via the remote user interface. The maximum length for the user defined text messages is 160 characters.

The default custom text message is:

Enter your text here

NOTE
SMS text messages exchanged between the test set and the mobile station are encoded using the ETSI Default Alphabet character set. The ETSI Default Alphabet encoding shares the majority of its character codes with those used by the ASCII character set. Between the two character sets, all alphanumeric characters and most punctuation characters have identical codes.

For user defined text messages, the test set accepts a 7-bit ASCII string. This string is then encoded using the ETSI Default Alphabet before it is transmitted. The ASCII code for each character in this string is mapped to the ETSI Default Alphabet character with the same code. Characters present in the user defined text message whose ASCII and ETSI Default Alphabet codes are not identical will be received and displayed by the mobile station as the ETSI Default Alphabet character with the original ASCII character's code. This behavior is only noticeable with certain user defined text messages as all of the predefined text messages use only alphanumeric and basic punctuation characters.

Defining the User Data (TP-UD) content for Binary SMS Applications

Transmission of SMS messages necessary for concatenated and binary SMS applications like WAP Push, MMS notifications, ringtones, picture messaging, as well as character based languages such as Chinese, Japanese, and Hebrew that use UCS2 can be done by specifying the entire contents of the Deliver PDU's User Data field, including header information, in hexadecimal characters. You can define the content for the Custom Data parameter using the following GPIB command:

CALL:SMService:PTPoint[:MTERminated]:DATA:CUSTom .

The custom user data can be defined only via the remote user interface. The maximum length for the user data is 280 ASCII formatted hexadecimal characters.

The default custom user data is:

00

Related Topics

Short Message Service (SMS)

Point-to-Point SMS

Cell Broadcast Service (CBS)

How to use the Short Message Service Features

CALL:SMService


Multimedia Service (MMS) Messages

Multimedia Service (MMS) Messages

Last updated: January 15, 2009

This section is only applicable to the lab applications

The Multimedia Service (MMS) is a WAP based application running on a wireless network. MMS makes use of the Short Message Service provided by the wireless network to notify the mobile station when an MMS is available for it to download from a server. Otherwise, MMS messages operate just like any other data transfer in the wireless network.

The test set can be used as a component in a system to verify the MMS capability of a mobile station. Other components required for such a system may include:

  • an SMS Gateway to generate and route the MMS notification message to a receiving mobile station,
  • an external software program simulating a Multimedia Service Center (MMSC) to act as the server and to generate the URL from which the MMS can be retrieved, and
  • a WAP Gateway to provide a means to download the compiled MMS from the MMSC

It is worth noting that for MMS verification, the HTTP or GPIB interfaces to the test set are only used for the mobile terminated (MT) SMS message containing the MMS notification. If you originate an MMS from the mobile station to an external receiving entity, the SMS protocol stack in the test set and therefore, the interfaces accessing that stack are never used.

MMS using the HTTP Interface

The HTTP interface in the test set provides a full IP based end-to-end test solution for MMS.

The test set's IP data channels are used to send MMS messages between the mobile station and an MMS server on a LAN/WAN.

The MMS Notification is a mobile terminated SMS message. See HTTP Interface Configuration for Mobile Terminated SMS for information on external software requirements and test set configuration.

MMS using the GPIB Interface

Similar to SMS, an external controller must parse the MMS notification into the appropriate GPIB commands for interfacing with the test set. An external MMSC is also required to exchange the MMS messages with the mobile station.

The MMS Notification is a mobile terminated SMS message. See Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station for information on external software requirements and test set configuration.

Related Topics

Point-to-Point SMS


Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

Last updated: January 15, 2009

This section is only applicable to the lab application or feature-licensed test application.

This section describes the test set's support for mobile originated short message service (MO SMS). The topics discussed in this section include:

  • Receiving Messages from the Mobile Station
  • Test Set Configuration for Mobile Originated SMS

Receiving Messages from the Mobile Station

Mobile Originated SMS messages are received by the test set after being transmitted over the air by the mobile station. The test set displays much of the content of these messages on the front panel, makes them available for query via GPIB, or when using the HTTP interface, acts as the SMSC and routes the message to a receiving entity. (See HTTP Interface Configuration for Mobile Originated SMS for more information about using the HTTP interface with MO SMS messages.)

  • Transportation
  • Last Received Message Parameters
  • Message Content (TP-User Data) Handling

Transportation

If the SMS message is originated by the mobile station, the transportation mechanism that was used by the mobile station is displayed on the front panel display and can also be queried (See CALL:SMService:PTPoint:MORiginated[:MESSage]:TRANsport? ).

When the UE sends an SMS point-to-point mobile-originated message while it is not on an active call (that is, idle) the SMS layer in the 8960 uses the services of the GMM or MM layer to establish an RRC connection between the test set and the UE. Once the connection is established the SMS messages are carried in the RRC Direct Transfer messages over RB3. The connection type, circuit-switched or packet-switched, is determined by the UE. The test set supports SMS point-to-point mobile-originated messaging while in the Idle call state or over an active circuit-switched or active packet-switched connection. You may receive an SMS point-to-point mobile-originated message from the UE while on a circuit switched connection (AMR Voice, RB Test Mode, or UE-to-UE Video). You may receive an SMS point-to-point mobile-originated message from the UE while on a packet-switched connection (UMTS/GPRS Packet Data). The test set supports receiving SMS point-to-point mobile-originated messages over existing or non-existing circuit-switched or packet-switched connections. It is therefore possible to receive an SMS point-to-point mobile-originated message from the UE under the following conditions:

  • while on a circuit-switched call using the existing circuit-switched connection if the UE is sending the message on the existing circuit-switched connection.
  • while on a packet-switched call using the existing packet-switched connection if the UE is sending the message on the existing packet-switched connection.
  • using a temporary circuit-switched connection while on a packet-switched call if the UE is sending the message on a circuit-switched connection and the UE is IMSI Attached.
  • using a temporary packet-switched connection while on a circuit-switched call if the UE is sending the message on a packet-switched connection and the UE is GMM Attached.
  • while on a Simultaneous Services circuit-switched/packet-switched call using the existing circuit-switched connection.
  • while on a Simultaneous Services circuit-switched/packet-switched call using the existing packet-switched connection.

In the following graphic you can see the details for the Last Received Message . Notice that the Transportation field contains the value CS Domain . This indicates that the CS domain was used to deliver this message from the mobile station.

Last Received Message Parameters

The header and message elements of mobile originated SMS Submit messages made available to you by the test set are listed below:

  • Coding Scheme
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:DCSCheme?
  • Length
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:LENGth?
  • Destination
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:DESTination?
  • Content
    • See Message Content (TP-User Data) Handling for more information
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:CONTents? or CALL:SMService:PTPoint:MORiginated[:MESSage]:TEXT?
  • Reference No
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:MREFerence?
  • UDHI
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHind?
  • Protocol Identifier
    • available using GPIB only
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:PIDentifier?
  • Status
    • See Status Report Mode
    • available via GPIB only
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:SRRequest?
  • User Data Header Length
    • available via GPIB only
    • CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHLength?

Message Content (TP-User Data) Handling

To provide uplink support for any format of message encoding, the content of all types of received MO SMS messages can be retrieved via GPIB. Unless predetermined, it is necessary to query a received message's format or data coding scheme results before determining how the contents should be interpreted.

The raw content of each MO SMS message received by the test set is made available for query as an ASCII formatted string of hex characters. This hex string represents the entire TP-UD from the message and includes any User Data Header and fill bits that may be present in the content. To aid in extracting any present header data from the content, the User Data Header Length query (see CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHLength? ) is provided which returns the length (in bytes) of the received messages user data header. For example, if this query returns <x> then the first <x> * 2 characters of the returned hex string are the user data header.

For messages encoded as 7-bit text (with or without a User Data Header), a separate query is also provided to return the ASCII string representing the actual text in the message. Note that this returned string does not include any User Data Header or fill bits found in the original content, only the ASCII representation of the actual text in the message content is returned. This query returns an empty string for all non 7-bit text based messages received.

The following queries are provided for retrieving the contents of received MO SMS messages:

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:CONTents? - for retrieving an ASCII formatted string of hexadecimal characters
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:TEXT? - for retrieving a string of ASCII text characters

Test Set Configuration for Mobile Originated SMS

You can configure the following parameters in the test set to control handling of mobile originated SMS messages:

  • Message Loopback
  • Message Queue
  • Submit Report Mode
  • Status Report Mode
  • Submit Report Type

Message Loopback

This feature gives you the ability to simulate the complete transfer of an SMS message from an originating mobile station to a destination mobile station through the network. The test set takes the message it receives from the mobile station and sends it back to the mobile station.

This feature also allows you to perform basic tests on data formats such as binary or UCS2 as the data type received from the mobile station is returned to it using the loopback feature.

Message Queue

Individual messages from a larger concatenated message or otherwise may arrive at the test set within relatively short periods of time from one another. If an external controller responding to these messages via a polling or interrupt mechanism does not react quickly enough to the arrival of each message, it is conceivable that results for some individual messages may be overwritten in the test set before the controller has had time to extract them. In this scenario, messages can effectively be lost and it may not be possible to rebuild a complete concatenated message at the controller.

To provide complete test support for concatenated SMS, a queuing capability for MO SMS messages is provided in the test set via the GPIB interface.

Parameter | GPIB Command
Turn message queuing ON and OFF | CALL:SMService:PTPoint:MORiginated:QUEue[:STATe]
Extract the next message from the queue | CALL:SMService:PTPoint:MORiginated:QUEue:NEXT
Query the current number of messages in the queue | CALL:SMService:PTPoint:MORiginated:QUEue:COUNt?

Using the message queue

When MO SMS message queuing is ON, any received SMS-SUBMIT message from the mobile station are placed into a queue rather than overwriting existing results. The queue functions as follows:

  • You can extract messages from the queue in the order they were received from the mobile station. Only the results from the last message extracted from the queue are made available for query at any one time.
  • When a controller is finished reading the results for the current message it must inform the test set that it is finished with that message via the CALL:SMService:PTPoint:MORiginated:QUEue:NEXT command. When this command is received at the test set, the message at the head of the queue is extracted (if one exists) and its results become available for query. If no messages are present in the queue at this point then the previously available results are instead cleared.
  • When queuing messages, interrupts/polling function as follows:
    • If a message is received from the mobile station when no previous messages results are available (i.e. no previous messages have been received or a controller has indicated that it has finished reading ALL previously received messages) the newly received message's results are immediately made available for query and an interrupt is generated / polling bit is set to 1.
    • If a message is received from the mobile station when a previous message's results are still available then the message is added to the queue and no interrupt is generated/polling bit does not change (i.e. remains at 1).
    • Upon receipt of the CALL:SMService:PTPoint:MORiginated:QUEue:NEXT command informing the test set that the controller is finished reading the current message, the polling bit remains set if there was a message waiting in the queue, the results of which have now been extracted and are available for query. If no further messages were waiting in the queue at this point then the polling bit is cleared back to 0.
    • It should be noted that when queuing is `ON', no interrupts are ever generated for messages arriving at the test set when a previous messages results are still available. It is the users responsibility to make use of the polling bit to ensure such messages are all read by a controller before exiting an instance of the interrupt/polling procedure.

    NOTE
    When MO SMS message queuing is OFF, interrupts occur and the polling bit is set at the time each MO message is received from the mobile station. The polling bit used varies depending on the state of message queuing, if message queuing is ON then the CONDition bit should be used, if message queuing is OFF the EVENt bit should be used (which is cleared to 0 after being read). While message queuing is OFF, the CONDition bit is glitched (from 0 to 1 then back to 0) each time a message is received.

The maximum number of messages that can be present in the queue at any one time is 255 individual (non concatenated) messages. This guarantees queuing in the worst case for a single maximum size concatenated message regardless of external controller synchronization. In reality it is unlikely the queue will ever hold this many messages when used with the interrupt or polling mechanisms as the rate messages can be received from the mobile station is limited and a controller should be extracting and handling messages at a similar speed if not faster than they are received from the mobile station. In the case of a queue overflow, a GPIB error is returned and the newly arrived message is discarded. A status bit is included in the SMS STATus subsystem to enable interrupts/polling based on overflow of the queue, see STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments for further details.

Message queuing does not effect the operation of the existing MO loopback feature.

Related Topics

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station


Responding to Mobile Originated SMS Messages

Responding to Mobile Originated SMS Messages

Last updated: January 15, 2009

This section is only applicable to the lab applications.

Submit Report and Status Report messages are both mobile terminated (MT) SMS messages sent in response to a request from the mobile station. The test set allows you to configure how it responds to these requests, either in a predetermined fashion or in a way that you specify. See the following sections for more details:

  • Submit Report Mode
  • Status Report Mode

Submit Report Mode

SMS-SUBMIT-REPORT messages are sent in response to a SMS-SUBMIT message from the mobile station to report either successful or unsuccessful reception of the message.

You can configure how the test set handles SMS-SUBMIT-REPORT responses. Two modes are available for use:

  • AUTO - SMS-SUBMIT-REPORT messages are sent automatically by the test set in response to SMS-SUBMIT messages received from the mobile station.
  • MANUAL - You control the sending of SMS-SUBMIT-REPORT messages in response to received SMS-SUBMIT messages from the mobile station. MANUAL mode allows you to specify the Submit Report Type. See Submit Report Type

Negative submit reports (sent via RP-ERR) are only explicitly sendable under the MANUAL mode of operation. When using AUTO mode, positive submit reports are sent (via an RP-ACK message) to the mobile station upon successful reception of a MO SMS message at the test set. If the test set cannot successfully receive the message (for example, if the message is corrupted) a negative submit report is returned with the relevant failure cause. It should be noted that when using AUTO mode, any value you have set for the TP-Failure Cause parameter is not used in constructing the submit report.

There are network (TR2N) and mobile station (TR2M) timers associated with the return of a SMS-SUBMIT-REPORT message. You should ensure that the time taken to respond to a SMS-SUBMIT message when using the MANUAL mode outlined above is well within the limits of these timers (by at least a couple of seconds). If a request to send an SMS-SUBMIT-REPORT is received at the test set outside these time constraints, the message will not be sent to the mobile station and the error "+240: Operation rejected; Attempting to send SMS submit report after timer TR2N expired" is returned. Given the timing associated with MANUAL mode, it should only be used in conjunction with polling or interrupts.

When using MANUAL mode, it is important that the SMS-SUBMIT-REPORT message have the Message Reference and Recipient Address fields configured to match those of the mobile originated SMS-SUBMIT message to which it is responding. Without this information, the mobile station can not correlate the report to the correct message.

As an additional testing scenario for MANUAL mode, you may want to intentionally NOT send a submit report to the mobile station to force the timeout and verify your mobile station responds appropriately. This simulates the SMSC in a real network losing its ability to respond properly.

The following GPIB command is available for configuring the submit report mode:

CALL:SMService:PTPoint:MORiginated:REPort:MODE:SUBMit

Submit Report Type

  • RP-ACK - Positive submit report to indicate the MO SMS message was received correctly.
  • RP-ERROR - Negative submit report to indicate the MO SMS message was not received correctly and to return the TP-Failure Cause parameter. You can specify the value of this parameter to be returned to the mobile station. See Failure Cause for more information.

The following GPIB command is available for configuring the submit report type:

CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE:SUBReport:RPTYpe

Status Report Mode

SMS-STATUS-REPORT messages are sent in response to a previous SMS-SUBMIT message from the mobile station which requested a status report. Requesting a status report is a mobile station feature. You may configure your mobile station to request a `receipt' or `report' for mobile originated messages. This is a mobile station configuration depending on how the feature is accessible from the user interface or proprietary interface.

Handling of SMS-STATUS-REPORT messages is configurable with two modes being provided for use:

  • AUTO - SMS-STATUS-REPORT messages are sent automatically by the test set in response to all SMS-SUBMIT messages received from the mobile station which request status reports.
  • MANUAL - You can configure the SMS-STATUS-REPORT messages sent in response to received messages from the mobile station. See Message Type for more information.

As the sending of status reports is an asynchronous event, the timing issues outlined in the previous section for submit reports is not relevant to the sending of status reports. The following setting is provided:

CALL:SMService:PTPoint:MORiginated:REPort:MODE:STATus .

Related Topics

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station


Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station

Last updated: January 15, 2009

This section is only applicable to the lab application or feature-licensed test application.

This section describes the test set's support for mobile terminated short message service (MT SMS). The topics discussed in this section include:

  • SMS Message State Synchronization
  • Transportation
  • Message Type
  • Sending a Text Message
  • Sending SMS messages for binary applications
  • Header Parameters
  • Message Parameters Managed by the Test Set

The operating mode must be Active Cell to send a mobile terminated SMS message.

SMS Message State Synchronization

When sending SMS messages programmatically, you should use the SMS Message State query (see Mobile Terminated SMS Delivery Status for more information) to delay the sending of each message until the previous message send has been acknowledged by the phone. If the command to send the message is received before the sending of a previous message has been acknowledged/rejected or timed out, the current message may not be sent.

Transportation

You can choose to send Point-to-Point SMS messages in either the CS (Circuit Switched) or PS (Packet Switched) domain. The domain to be used is configurable by specifying the Transportation mechanism (see CALL:SMService:PTPoint[:MTERminated]:TRANsport ).

When you send an SMS message to the mobile when the test set is in the idle call state, the SMS layer uses the services of the GMM or MM layer to establish an RRC Connection between the test set and UE. Once the connection is established, the SMS messages are carried in RRC Direct Transfer messages over RB 3.

The test set supports SMS point-to-point mobile-terminated messaging while in the Idle call state or over an active circuit-switched or active packet-switched connection. You may send an SMS point-to-point mobile-terminated message to the UE while on a circuit switched connection (AMR Voice, RB Test Mode, or UE-to-UE Video) if Transportation is set to CS Domain. You may send an SMS point-to-point mobile-terminated message to the UE while on a packet-switched connection (UMTS/GPRS Packet Data) if Transportation is set to PS Domain. The test set supports sending SMS point-to-point mobile-terminated messages over existing or non-existing circuit-switched or packet-switched connections. It is therefore possible to send the UE an SMS point-to-point mobile-terminated message under the following conditions:

  • while on a circuit-switched call (for example, an AMR Voice, an RB Test Mode or a UE-to-UE Video call) using the existing circuit-switched connection if Transportation is set to CS Domain.
  • while on a packet-switched call using the existing packet-switched connection if Transportation is set to PS Domain.
  • using a temporary circuit-switched connection while on a packet-switched call if Transportation is set to CS Domain and the UE is IMSI Attached.
  • using a temporary packet-switched connection while on a circuit-switched call if Transportation is set to PS Domain and the UE is GMM Attached.
  • while on a Simultaneous Services circuit-switched/packet-switched call using the existing circuit-switched connection if Transportation is set to CS Domain.
  • while on a Simultaneous Services circuit-switched/packet-switched call using the existing packet-switched connection if Transportation is set to PS Domain.

Message Type

You can define the Message Type used for the SMS message sent from the test set to the mobile station. The Message types are defined as PDU types in 3GPP TS 23.040 Section 9.2.2. The Message types defined for MT SMS messages are:

  • Deliver - sending a short message from the network to the mobile station
  • Submit Report (not available when using the HTTP interface)- sends information as part of an acknowledgment to a Submit mobile originated (MO) SMS message. The header parameters in this Message Type are different depending on RP Type, which can be either RP-ERROR or RP-ACK. You can configure the value for this parameter in the test set (See CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE:SUBReport:RPTYpe for GPIB command information.). When the RP Type is RP-ERROR a failure cause is included with other header information. The structure of Submit Report PDUs is defined in 3GPP TS 23.040 Section 9.2.2.2. Refer to Header Parameters for all the user configurable Submit Report elements.

    See Submit Report Mode for additional information about configuring Submit Reports.

  • Status Report (not available when using the HTTP interface)- sent in response to a previous SMS-SUBMIT message from the mobile station which requested a status report. Refer to Header Parameters for all the user configurable Status Report elements. Refer to Message Parameters Managed by the Test Set for the elements automatically configured by the test set.

    See Status Report Mode for additional information about configuring Status Reports.

Sending a Text Message

The default values for the message header parameters are appropriate for sending a text message. However, when sending a text message, you may want to configure whether the message is delivered in either the CS or PS domain (see Transportation ). You may also want to specify the text message sent to the mobile station. One of two predefined messages can be sent or you can define a text message yourself. See Short Message Service (SMS) Messages for more information on selecting and defining the content for text messages.

See Procedure A: Sending a Text Message to the Mobile Station for an example of how to send an ASCII Text Message to the mobile station using the front panel.

See The test set as the server: for a simple example of how to send an ASCII Text Message to the mobile station using the HTTP interface.

Sending SMS messages for binary applications

When sending messages using binary data, such as WAP Push, smart messaging, ringtones, or MMS notifications, you may want to configure some of the header values. All the parameters configurable using the test set are listed in Header Parameters .

You must configure the following parameters to successfully send a binary SMS message:

  • Data Coding Scheme (DCS)
  • User Data Header Indicator
  • Custom User Data - The Custom Data parameter is a hexadecimal string. This string, including the appropriate header information, or the UDH (User Data Header), may be generated using an SMS gateway, or you can create the string yourself. See Short Message Service (SMS) Messages for more information on selecting and defining this parameter.

Header Parameters

Unless otherwise noted, all the following parameters can be configured when you are using the HTTP interface as well as the GPIB and front panel interfaces.

  • Data Coding Scheme (DCS)
    • Used to identify the coding scheme used by the SMS message contents.

      NOTE
      There is no coupling between the Data Coding Scheme value and the content type selected to be included in mobile terminated SMS messages. See Short Message Service (SMS) Messages for more information on content type.

    • It is important for you to configure the Data Coding Scheme parameter in order for the mobile station to know what type of message it is receiving. Some examples of parameter values that you are likely to use are:
      0 | ASCII Text Messages (concatenated or non-concatenated)
      4 | General binary messages (ringtones, vcards, bitmap picture messages, etc.)
      8 | UCS2 (Unicode) messages (Chinese, Japanese, Hebrew, etc.)
      245

      WAP Push and MMS notification messages

      247

      The Message Class for mobile terminated SMS messages is determined by two bits in the middle of the 8-bit DCS field. Therefore, the Message Class is determined by the value you specify for the DCS parameter.

    • Applicable to the following message types: Deliver, Submit Report, and Status Report. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:DCSCheme
  • Failure Cause
    • Used to identify the reason for the failure of a previous mobile originated short message.
    • not available in HTTP interface because Submit Report message type is not supported
    • Applicable to the Submit Report message type only. RP type must be set to RP-ERR. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:FCAuse
  • Message Reference
    • Used to identify the previously submitted mobile originated short message.
    • not available in HTTP interface because Status Report message type is not supported
    • if you are sending status reports via GPIB or the front panel, the Message Reference setting must be configured to match the value of the Message Reference of the mobile originated message to which you are responding.
    • Applicable to only the Status Report message type. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:MREFerence
  • More Messages to Send
    • This element is used to indicate to the mobile station if there are more messages waiting to be sent from the test set after the current message.
    • Applicable to the following message types: Deliver, Submit Report, and Status Report. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:MMTSend
  • Originating Address
    • Used to identify the sender of the message.
    • Applicable to only the Deliver message type. See Message Type for more information.
    • GPIB commands
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:PLAN
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:TYPE
  • Parameter Indicator
    • Used to identify the presence of optional elements within SMS-SUBMIT-REPORT and SMS-STATUS-REPORT messages. The value you specify for this parameter determines the inclusion of the Data Coding Scheme, User Data Length, and Protocol Identifier elements for all SMS-SUBMIT-REPORT messages sent from the test set.
    • Applicable to the following message types: Submit Report and Status Report. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:PINDicator
  • Protocol Identifier
    • Used to identify the higher layer protocol being used, or to indicate interworking with a particular type of telematic device.
    • Applicable to the following message types: Deliver, Submit Report, and Status Report. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:PIDentifier
  • Recipient Address
    • Used to identify the recipient of the previously submitted SMS message.
    • Not available in HTTP interface because Status Report message type is not supported
    • Applicable to only the Status Report message type. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress
  • Reply Path
    • Used to indicate if a Reply Path exists.
    • Applicable to only the Deliver message type. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RPATh
  • Status
    • Used to describe the status of the previously sent mobile originated short message.
    • not available in HTTP interface because Status Report message type is not supported
    • Applicable to only the Status Report message type. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:STATus
  • Status Report Indication
    • Used to indicate if a status report has been requested from the entity sending the SMS message to the mobile station.
    • Applicable to only the Deliver message type. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SREPort
  • User Data Header Indicator
    • This header field indicates to the mobile station that the message content contains further header information. This should be set to 1 for any type of binary message, including concatenated text messages, as they also contain additional header information.
    • Applicable to the following message types: Deliver, Submit Report, and Status Report. See Message Type for more information.
    • CALL:SMService:PTPoint[:MTERminated][:MESSage]:UDHind
  • SMSC Address
    • The SMSC Address (RP-Originating Address) is used to identify the originating SMS Service Center address for MT transfers.
    • Applicable to the following message types: Deliver, Submit Report, and Status Report. See Message Type for more information.
    • GPIB commands
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:PLAN
      • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:TYPE

Message Parameters Managed by the Test Set

Some header parameters are automatically calculated by the test set and included in all SMS messages sent from the test set. These header elements are:

All MT SMS message types

  • Message Type Indicator (TP-MTI) - You can configure the message type used by the test set for MT SMS messages. The test set configures this parameter to reflect the Message Type that you have indicated. (See Message Type .) Since the HTTP interface only supports the Deliver message type for MT SMS messages, the value for this parameter always indicates the Deliver message type when the HTTP interface is used.
  • Service Centre Timestamp (TP-SCTS) - This element is configured to represent the time at which the test set received the command to send the message (either over GPIB or the front panel). (3GPP 23.040 Section 9.2.3.11)
  • User Data Length (TP-UDL) - This element is set by the test set to correctly describe the size of the user data (TP-UD) included in the message. This element may be omitted for Submit Report or Status Report message types depending on the value of the TP-Parameter Indicator parameter. (See Protocol Identifier ). (3GPP 23.040 Section 9.2.3.16)

Status Report message type

See Status Report Mode for more information about configuring how the test set sends Status Report messages.

  • Status Report Qualifier (TP-SRQ) - This header parameter is always included and is always set to 0, indicating the status report is the result of a Submit message from the mobile station. (3GPP 23.040 Section 9.2.3.26)
  • Discharge Time (TP-DT) - This header parameter is always included and always set to the current time. The current time is determined by the date and time set on the test set's System Config screen. See Configuring System Time and Date . (3GPP 23.040 Section 9.2.3.13)

Related Topics

Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

Short Message Service (SMS) Messages

Mobile Terminated SMS Delivery Status

Logging SMS Messages

How to use the Short Message Service Features


Short Message Service (SMS)

Short Message Service (SMS)

Last updated: January 15, 2009

This section is only applicable to the lab application or feature-licensed test application.

Short Message Service (SMS) Overview

  • Cell Broadcast Service (CBS)
    • HTTP Interface for Cell Broadcast Service - Introduction
      • HTTP Interface Configuration for Cell Broadcast Service Messages
  • Point-to-Point SMS
    • Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station
      • Mobile Terminated SMS Delivery Status
    • Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station
      • Responding to Mobile Originated SMS Messages
    • Short Message Service (SMS) Messages
    • HTTP Interface for SMS - Introduction
      • HTTP Interface Configuration for Mobile Terminated SMS
      • HTTP Interface Configuration for Mobile Originated SMS
        • HTTP SMS Router Web-based Configuration Interface


Point-to-Point SMS

Point-to-Point SMS

Last updated: January 15, 2009

This section is only applicable to the lab application or feature-licensed test application.

The Short Message Service (SMS) as specified in 3GPP TS 23.040 version 3.9.0 provides a means for the exchange of short messages between mobile stations and a network. The test set can simulate an SMSC (Short Message Service Center) which provides for the transmission of short messages to, or reception of short messages from an intended mobile station, and the return of acknowledgments and error messages.

The test set supports the two services that comprise SMS:

  • Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station
    • MT SMS are SMS messages sent to the mobile station.
    • The test set allows you to specify several SMS message parameters, including the type of message, the content, and header parameters. This allows you to send SMS messages of various usages and configurations.
    • See Mobile Terminated Point-to-Point Message Transfer for simple examples to get started.
  • Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station
    • MO SMS are SMS messages sent by the mobile station.
    • See Mobile Originated Point-to-Point Message Transfer for simple examples to get started.

Interfaces for Point-to-Point SMS

The test set provides two interfaces for point-to-point SMS:

  • HTTP Interface
  • GPIB Interface

These interfaces provide methods for you to control and access SMS messages sent to and received from the mobile station. These interfaces are a requirement for the test set to be able to communicate with external components used in any system for verifying the SMS capability of a mobile station.

The majority of parameters available through the GPIB interface are also accessible from the test set's front panel.

HTTP Interface

The HTTP Interface in the test set allows you to configure SMS message parameters and content, send, and receive SMS messages using HTTP protocol. This interface is useful for SMS verification because HTTP protocol is used by most commercially available SMS Gateways. The HTTP interface also allows SMS Gateways to be configured as if the test set is a Short Message Service Center (SMSC), eliminating the need for custom external software to route messages to the correct test set. This emulation of an SMSC makes it possible to route messages directly from the HTTP output interface of one test set to the HTTP input interface of another test set. Additionally, the HTTP interface also facilitates MMS message transfer to and from a mobile station if used in conjunction with compatible MMSC (Multimedia Message Service Center) software.

For more information on this interface in the test set, see the following sections:

  • HTTP Interface for SMS - Introduction
  • HTTP Interface Configuration for Mobile Terminated SMS
  • HTTP Interface Configuration for Mobile Originated SMS
  • Multimedia Service (MMS) Messages

GPIB Interface

There is also a GPIB interface for configuring SMS message parameters and content and sending and receive SMS messages, acknowledgments, and error messages. The GPIB interface provides support for Deliver, Submit, Deliver Report, Status Report, and Submit Report message types.

When using the GPIB interface, you need to generate your own message content and set the correct header parameters for each message you send.

You may still use the GPIB interface with an SMS Gateway. To accomplish this, you must create an external software program to translate between GPIB and a protocol supported by the SMS Gateway.

  • Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station
  • Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

Related Topics

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station

Mobile Originated SMS (MO SMS)- Receiving Messages Transmitted by the Mobile Station

Short Message Service (SMS)

Cell Broadcast Service (CBS)

Short Message Service (SMS) Messages

How to use the Short Message Service Features

CALL:SMService


Mobile Terminated SMS Delivery Status

Mobile Terminated SMS Delivery Status

Last updated: January 15, 2009

This section is only applicable to the lab applications.

The test set provides the delivery status of mobile terminated SMS messages on the front panel, or it is accessible via the GPIB or HTTP interfaces.

  • MT SMS Message States
  • Using the GPIB Interface
  • Using the HTTP Interface
  • Reject Cause

MT SMS Message States

There are six possible MT SMS message states.

  • "IDLE" - An SMS message has not been successfully sent from the test set since power-up, preset, or SMS clear.
  • "SEND" - The test set has initiated the process of sending an SMS message.
  • "ACK" - The SMS message sent by the test set was acknowledged by the mobile station before timeout.
  • "NACK" - The SMS message sent by the test set was NOT acknowledged by the mobile station and send timeout.
  • "REJ" - The SMS message sent by the test set was rejected by the mobile station. A cause value for the reject is also reported by the mobile station. See Reject Cause .
  • "FAIL" - A command to send an SMS message has been received by the test set, but it cannot send the SMS message over the air because of an error. An example of a situation that would produce such an error is if the mobile station is not connected to the test set.

Using the GPIB Interface

The CALL:SMService:PTPoint[:MTERminated]:SEND:STATe? query returns a string indicating the state of the last message sent from the test set to the mobile station.

If the delivery status returned is "REJ", you can use the CALL:SMService:PTPoint[:MTERminated]:RCAuse? query to retrieve the reject cause value returned by the mobile station. See Reject Cause for the meanings of the possible cause values.

Using the HTTP Interface

The state of the last MT SMS message sent from the test set to the mobile station can be queried from the test set using an HTTP GET request with the following URL:

/sms/mtstate

The delivery state is returned in the body of the HTTP response.

Example using an internet browser

You can query the MT SMS delivery state through the HTTP interface using an internet browser by entering the following URL:

http://<x.x.x.x>/sms/mtstate

where <x.x.x.x> is the IP address of the test set sending the SMS to the mobile station. This example is illustrated in the following figure.

If the state returned is "REJ", the body of the HTTP response also contains the reject cause value as an integer. The reject cause value is placed in the response body after the REJ characters and separated from them by a single space character. For example, "REJ 211" is returned in the HTTP response if the MT SMS was rejected with a cause value of 211. See the following figure.

See Reject Cause for the meanings of the possible cause values.

Reject Cause

Reject Cause | Hex equivalent | Description
129 | 81 | Short message Type 0 not supported
130 | 82 | Cannot replace short message
143 | 8F | Unspecified TP-PID error
145 | 90 | Message class not supported
159 | 9F | Unspecified TP-DCS error
176 | B0 | TPDU not supported
208 | D0 | (U)SIM SMS storage full
209 | D1 | No SMS storage capability in (U)SIM
210 | D2 | Error in MS
211 | D3 | Memory Capacity Exceeded
212 | D4 | (U)SIM Application Toolkit Busy
213 | D5 | (U)SIM data download error
224-254 | E0-FE | Values specific to an application
255 | FF | Unspecified error cause

Related Topics

Mobile Terminated SMS (MT SMS)- Sending a Message to the Mobile Station


Current Service Type

Current Service Type

Last updated: March 3, 2009

Current Service Type indicates the type of service that is currently active. While in Active Cell Operating Mode , Current Service Type is displayed on the Call Setup Screen (and can be queried using the CALL:STATus:SERVice:TYPe? command). Current Service Type is set to the active service type upon completion of the establishment of the service.

The test set supports the following service types:

  • AMR Voice (see AMR Setup )
  • AMR Voice + PS Data (see Simultaneous Services ) (lab application only)
  • Radio Bearer Test Mode
  • Radio Bearer Test Mode - HSDPA ( lab application or feature-licensed test application only )
  • Radio Bearer Test Mode - HSPA (lab application or feature-licensed test application only)
  • Circuit Switched Data Service - Video Call (lab application only or feature-licensed test application only)
  • Circuit Switched Data Service - Asynchronous (lab application only)
  • Packet Switched Data (lab application only)
  • Packet Switched Data - HSDPA ( lab application only )
  • Packet Switched Data - HSPA ( lab application only )

Current Service Type is set to None whenever an event occurs that causes the service to be stopped. For example:

  • End Call (base station release).
  • Any call processing error resulting in a dropped call.
  • UE-initiated end of service.
  • Full or partial preset.

Related Topics

Establishing a Connection with the UE


Trigger Output Setup

Trigger Output Setup

Last updated: January 15, 2009

The test set provides a 5 V, 16.5 us pulse at the TRIG OUT rear panel connector for triggering other test equipment from the test set.

This pulse is generated according to the Trigger Output Setup setting:

  • System Frame Clock

    When Trigger Output Setup is set to System Frame Clock , a pulse is generated every 10 ms, in alignment with the first symbol period of each frame.

  • Measurement Generated

    When Trigger Output Setup is set to Measurement Generated , pulses are generated when certain measurements are initiated or are running, or for other special situations, as outlined below:

    • Out-of-Synch Handling of Output Power measurement:

      When Out-of-Synch Handling of Output Power is initiated, the test set generates a trigger pulse at point "A" (see Out-of-Synch Handling of Output Power Measurement Description for more details).

      Note, when Trigger Output Setup is set to Measurement Generated and HSDPA is not active, the signal present at the TRIG OUT connector is undefined when any measurements other than Out-of-Synch Handling of Output Power is triggered or running.

    • HSDPA ( lab application or feature-licensed test application only ):

      When HSDPA is active, a trigger pulse is generated every time the test set sends data using the HARQ0 process.

      When on an HSDPA or HSPA RB Test Mode connection with RB Test HS-DSCH Configuration Type set to FRC , downlink HARQ0 subframes occur every 12 ms. Thus, the downlink HARQ0 rear panel trigger occurs every 12 ms. However, with HS-DSCH Configuration Type set to User Defined , or while on an HSDPA or HSPA packet data connection, downlink HARQ0 subframes do not necessarily occur every 12 ms (for example, if you are not continuously sending data on a packet data connection, the HARQ0 process is not invoked every 12 ms).

      For a definition of when HSDPA is active for active cell operating mode and FDD test operating mode, see HSDPA Activation in Active Cell and HSDPA Activation in FDD Test , respectively.

      Note, the rear panel trigger is NOT affected by the HS-DPCCH Trigger Subframe Alignment settings present in many measurements (which allow you to move the measurement trigger relative to the downlink HARQ0 subframe). When present, the rear panel trigger is always aligned to the start of the downlink HARQ0 subframes.

To access Trigger Output Setup from the front panel, press the CALL SETUP key, press the More key until you reach the Call Control 2 of 5 menu, and then select Trig Output Setup ( F6 ).

Related Topics

CALL:TRIGger


Two-Cell Test System Ladder Diagrams

Two-Cell Test System Ladder Diagrams

Last updated: January 15, 2009

This section is only applicable to the lab application.

Description

  • Mobile-Initiated Cell Reselection from W-CDMA/HSPA to GSM/GPRS/EGPRS or W-CDMA/HSPA (Idle Mode: Camped or Attached)
  • Mobile-Initiated Cell Reselection from GSM/GPRS/EGPRS to W-CDMA/HSPA (PDP Active, with or without Data Flow)
  • Network-Initiated Cell Reselection from W-CDMA/HSPA to GSM/GPRS/EGPRS (PDP Active, with or without Data Flow)
  • Network-Initiated Cell Reselection from GSM/GPRS/EGPRS to W-CDMA/HSPA (PDP Active, with or without Data Flow)
  • Network-Initiated Handover from W-CDMA/HSPA to GSM/GPRS/EGPRS
  • Network-Initiated Handover from GSM/GPRS/EGPRS to W-CDMA/HSPA

Mobile-Initiated Cell Reselection from W-CDMA/HSPA to GSM/GPRS/EGPRS or W-CDMA/HSPA
(Idle Mode: Camped or Attached)

Mobile-Initiated Cell Reselection from GSM/GPRS/EGPRS to W-CDMA/HSPA
(PDP Active, with or without Data Flow)

Network-Initiated Cell Reselection from W-CDMA/HSPA to GSM/GPRS/EGPRS
(PDP Active, with or without Data Flow)

Network-Initiated Cell Reselection from GSM/GPRS/EGPRS to W-CDMA/HSPA
(PDP Active, with or without Data Flow)

Network-Initiated Handover from W-CDMA/HSPA to GSM/GPRS/EGPRS

Network-Initiated Handover from GSM/GPRS/EGPRS to W-CDMA/HSPA

Related Topics

Two-Cell Test System


Two-Cell Test System

Two-Cell Test System

Last updated: January 15, 2012

This section is only applicable to the lab application, unless otherwise stated.

Description

The range of transmission of a battery-powered mobile device is limited. Hence for good coverage, it is necessary for the mobile to efficiently move from one cell to another as it roams around the network. The mobile must transition to new cells as users cross cell boundaries and RF conditions in the current cell degrade. Some cell transitions can be performed autonomously by the mobile, as a result of the measurements it has made on its serving cell and the surrounding cells. Cell transitions may also be ordered by the network based on measurement reports from the mobile (note that in the two-cell test system, you must order the network-initiated cell transitions; it is not possible for the test sets to automatically order the transitions based on measurement reports from the mobile).

As a mobile moves around the network, it constantly updates the network by sending measurement reports regarding the serving cell as well as any neighbor cells specified in the serving cell's neighbor cell list. When the mobile is idle (not sending data), it can easily measure the RF conditions of the current cell and surrounding neighbor cells. While transmitting data, a GSM/GPRS/EGPRS mobile must make measurements in free timeslots, a W-CDMA/HSPA mobile must use compressed mode to make measurements on surrounding cells, or simply perform "blind" handovers (handover as directed by the network, without first measuring the target cell).

The two-cell test system provides a way to test a mobile's cell transition and cell selection procedures between cells of the same or different Radio Access Technologies (RATs). Cell selection and transition procedures are documented in 3GPP TS 51.010 (GSM/GPRS/EGPRS), and 3GPP TS 34.121 section 8 and 34.123 (W-CDMA/HSPA). GSM/GPRS/EGPRS mobile measurements for cell reselection, the criteria for cell selection and reselection, and cell reselection algorithms that determine when to initiate the cell transition process are defined in 3GPP TS 05.08. W-CDMA/HSPA cell reselection information is available in 3GPP TS 25.304.

Overview of Cell Transitions

This section describes various cell transitions that a mobile may perform, either autonomously (without being ordered by the network) or by network initiation. Cell transitions may occur while the mobile is in idle mode or actively transferring data.

Cell selection does not involve transitioning between cells; rather, it is the process by which the mobile selects a serving cell once it has completed its power-up sequence. When the mobile is powered on, it must determine which cell to camp to (register with and/or attach to).

Handover refers to a cell transition that occurs when a circuit-switched (CS) connection is in place (such as CS voice, CS data, or Dual Transfer Mode). Handovers can only be initiated by the network. During a handover, the network sends the mobile a Handover command, which provides information about the destination cell, including the traffic channel configuration (in the two-cell test system, this information is determined by the destination test set's current configuration; the originating test set retrieves this information from the destination test set before ordering the handover).

Handovers Available in the Two-Cell Test System
 |  | Destination cell : GSM/GPRS/EGPRS |  | Destination cell : W-CDMA/HSPA
 | Mobile State | Network-Initiated | Mobile-Initiated | Network-Initiated | Mobile-Initiated
Originating cell : GSM/GPRS/EGPRS | CS Voice | Yes 3 | N/A 1 | Yes 3 | N/A 1
 | CS Data | No |  | No
 | Dual Transfer Mode | Yes |  | Yes 2
Originating cell : W-CDMA/HSPA | CS Voice | Yes 3 |  | No
 | CS Data | Yes |  | No
 | Simultaneous Services | Yes |  | No
1 Handovers can only be initiated by the network, as defined by 3GPP. 2 A successful handover from Dual Transfer Mode to W-CDMA/HSPA requires a Packet Data RAB to be selected that supports Simultaneous Services. 3 This function is applicable to the lab application or feature-licensed test application.

Cell reselection is the process of changing the mobile's serving cell (either in idle mode or while actively transmitting data). Cell reselections can be initiated by the mobile or network. When the network initiates a cell reselection, it sends a Packet Cell Change Order (GPRS/EGPRS) or a Cell Change Order (W-CDMA/HSPA), which provides the parameters necessary for the mobile to find and synchronize to the destination cell. If the mobile was actively transferring data at the time of the cell reselection, any subsequent allocation of traffic channel resources to continue the packet data transfer are handled by signaling between the mobile and destination cell, and does not involve the origination cell.

Idle mode cell reselection refers to cell transitions that occur when the mobile is in idle mode.

In mobile-initiated idle mode cell reselection, the mobile decides on the basis of its own measurements to move from one cell to another to achieve improved RF quality. The network is not aware of the reselection until the mobile appears on the destination cell. The alternate cells a mobile may search for and transition to are determined by the serving cell's broadcast list of neighbors.

In network-initiated idle mode cell reselection, the network orders the mobile to transition to a new cell while in idle mode, using a Packet Cell Change Order (PCCO) or a Cell Change Order (CCO).

Idle Mode Cell Reselections Available in the Two-Cell Test System

Destination cell : GSM/GPRS/EGPRS Destination cell : W-CDMA/HSPA

Mobile State Network-Initiated Mobile-Initiated Network-Initiated Mobile-Initiated
Originating cell : GSM/GPRS/EGPRS | Camped but not attached | N/A 1 | Yes | N/A 1 | Yes
Attached | Yes | Yes | Yes | Yes
PDP active | Yes | Yes | Yes | Yes
Originating cell : W-CDMA/HSPA | Camped but not attached | N/A 2 | Yes | N/A 2 | Yes
Attached | Yes | Yes
PDP active (but not actively transferring data) | Yes | N/A 3 | No | N/A 3

1 In a GSM/GPRS/EGPRS cell, network-initiated cell reselection is only possible when the mobile is attached or PDP active, as defined by 3GPP.

2 In a W-CDMA/HSPA cell, for Release 99 mobiles, network-initiated cell reselection is only possible when the mobile is PDP active, as defined by 3GPP.

3 Mobile-initiated cell reselection is not possible from a W-CDMA/HSPA cell when the mobile is PDP active in CELL_DCH, as defined by 3GPP. Note that if you turn off the serving W-CDMA/HSPA test set's cell power, the mobile will find the other test set and establish radio resources with it to continue data transfer on the existing PDP context; however, this is not the same as a mobile-initiated reselection to the other test set.

PS data transfer mode cell reselection refers to cell transitions that occur when the mobile is PDP active and actively transferring PS data (such as GPRS, HSPA, or W-CDMA PS data). Whether the cell reselection is initiated by the mobile or by the network, the mobile is responsible for aborting the current data flow and restarting it upon arrival in the new cell. Any data packets routed to the old cell are lost and it is assumed that the higher layer protocol that was generating packets manages retransmission of any lost data to the mobile once it complete its transition to the new cell. A cell update procedure is performed by the mobile upon arrival to the new cell. The new cell is not responsible for re-establishing the PDP context, but rather the mobile or the network entity it was communicating with (for example, FTP server).

In network-initiated PS data transfer mode cell reselections, the current serving cell sends the mobile a PCCO or CCO to command it to change cells.

PS Data Transfer Mode Cell Reselections Available in the Two-Cell Test System
 |  | Destination cell : GSM/GPRS/EGPRS |  | Destination cell : W-CDMA/HSPA
 | Mobile State | Network-Initiated | Mobile-Initiated | Network-Initiated | Mobile-Initiated
Originating cell : GSM/GPRS/EGPRS | Actively transferring PS Data | Yes | Yes | Yes | Yes
Originating cell : W-CDMA/HSPA | Actively transferring PS Data | Yes | N/A 1 | Yes | N/A 1
1 Mobile-initiated cell reselection is not possible from a W-CDMA/HSPA cell when the mobile is PDP active in CELL_DCH, as defined by 3GPP. Note that if you turn off the serving W-CDMA/HSPA test set's cell power, the mobile will find the other test set and establish radio resources with it to continue data transfer on the existing PDP context; however, this is not the same as a mobile-initiated reselection to the other test set.

Two-Cell Test System Overview

You can connect two test sets via an External Device Connection to test your mobile's cell selection and cell transition behavior. The test sets can be configured to emulate two GSM/GPRS/EGPRS cells, or one GSM/GPRS/EGPRS cell and a W-CDMA/HSPA cell (the appropriate lab application must be installed on each test set). At this time you cannot emulate transitions between two W-CDMA/HSPA cells.

Once the system is configured (see Two-Cell Test System Physical Layout and Requirements ) and the mobile is powered on, the mobile performs the cell selection process by selecting one of the test sets in the system with which to communicate. After the mobile has camped on a test set, the mobile's cell transition procedures are ready to be tested.

To influence mobile-initiated cell transitions, you can change the properties of each cell (such as lowering, or turning off Cell Power in one of the test sets, or changing Cell Parameters , Reselection Parameters and Access Restriction Parameters ). Note however that to cause a network-initiated cell transition, you must manually order the transition using the Execute External 8960 Handover immediate action ( CALL:HANDoff:EXTernal[:IMMediate] ). The test sets do not automatically order cell transitions based upon the mobile's measurement reports, you must initiate the transition. However, you can monitor the mobile's measurement reports on the test sets as you change the properties of the two-cell system.

Two-Cell Test System Physical Layout and Requirements

The figure below shows the recommended system layout of the two-cell test system.

The requirements for the physical layout of the two-cell test system are as follows:

  • Two Test Sets

    The two-cell test system requires two test sets which emulate the two cells for the mobile to transition between. The inter-RAT two cell test system scenarios assume that one test set is running a GSM/GPRS/EGPRS application/format while the other is running a W-CDMA/HSPA application/format.

  • Ethernet (LAN) Connection

    The two-cell test system relies on an ethernet connection ( External Device Connection ) between the two test sets to allow them to exchange control messages during cell reselections and handovers. Before establishing the External Device Connection , you must set the originating test set's Ext 8960 IP Addr to the LAN IP Address 2 (Data+) of the destination test set (unless you've connected the two test sets using a hub and have connections to the test set's LAN 1 PORT and LAN 2 PORT ; in that case you can set Ext 8960 IP Addr to the destination test set's LAN IP Address or LAN IP Address 2 (Data+) .) The destination test set displays the originating test set's LAN IP Address 2 (Data+) under Connected Device IP Address .

    It is recommended that you connect the test sets via an ethernet switch or hub, rather than through a gateway or WAN link, to minimize the chance of data loss due to delayed packets. You can also connect the test sets directly via a cross-over cable, however it is then not possible to capture any protocol message logs from the Wireless Protocol Advisor (WPA), or to communicate with external servers.

  • RF Interface

    The mobile must be able to communicate with both test sets. To accomplish this, it is recommended that you use an RF splitter to connect the mobile to both test sets simultaneously.

  • GPIB Connection

    GPIB connection between both test sets and a controlling PC are necessary if remote control of the instruments in the system is required.

  • Ethernet Switch or Hub

    An Ethernet switch or hub is needed in order for the mobile to connect to external servers as well as for connecting the PC running WPA to the test sets.

Operating Considerations

  • Important : DUT IP Address must be set to a different value in each test set in the two-cell test system.
  • The operating mode in both test sets must be set to Active Cell in order to perform cell transitions, as this is the only operating mode that provides signaling to the mobile.
  • While operating in the GSM/GPRS/EGPRS application/format, the connection type must be set to Auto in both test sets of the two-cell test system in order to maintain IP-based data connections during cell reselection. Any other connection type setting terminates the active data connection during cell reselection and does not restart the data connection once cell reselection is complete.
  • The DUT IP Address setting is inaccessible if the mobile is connected to the current test set but using an IP address originally assigned by the other test set. Refer to the External Device Connection documentation ("DUT IP Address Information") for additional information.
  • It is recommended that you configure the neighbor cell list in each test set to contain the other test set's information (using the SIB 11 Cell Info List in W-CDMA/HSPA or the Cell Lists in GSM/GPRS/EGPRS). This enables the mobile to measure the other test set before transitioning to it (some mobiles will not perform a "blind" handover) and allows you to view the mobile's measurement reports for the test set. Ensure that you have properly configured the mobile measurement reports to match the destination test set's configuration (using the Compressed Mode settings in W-CDMA/HSPA or the Measurement Reports settings in GSM/GPRS/EGPRS).
  • Network Control Order in the GSM/GPRS/EGPRS application determines how the mobile should perform cell reselections. If Network Control Order is set to NC0 or NC1 in the test set to which the mobile is currently attached, it may not respond to network-initiated attempts at cell reselection. Also, if the test set to which the mobile is attached has Network Control Order set to NC2 , the mobile may not perform autonomous cell reselection.

Related Topics

How Do I Set Up the Two-Cell Test System and Perform Cell Transitions?

Troubleshooting the Two-Cell Test System

Two-Cell Test System Ladder Diagrams

External 8960 Handover

External Device Connection

DUT IP Address

GSM/GPRS/EGPRS Cell Configuration:

  • Cell Parameters
  • Cell Identification

W-CDMA/HSDPA Cell Configuration:

  • Cell Parameters
  • Reselection Parameters
  • Access Restriction Parameters

GSM/GPRS/EGPRS Neighbor List Configuration:

  • Cell Lists

W-CDMA/HSDPA Neighbor List Configuration:

  • SIB11 Cell Info List

GSM/GPRS/EGPRS Mobile-Reported Measurements:

  • Measurement Reports

W-CDMA/HSDPA Mobile-Reported Measurements:

  • UE Reported Measurements


UE Expected Open Loop Transmit Power

UE Expected Open Loop Transmit Power

Last updated: January 15, 2009

The UE uses open loop power control to determine the transmit power of the first PRACH preamble and of the DPCH as it is first turned on. Once the DPCH is established its power is controlled solely by closed loop power control (see Uplink Closed Loop Power Control Parameters and UE Target Power ).

Open Loop Power Control

The test set calculates the expected transmit power of the first PRACH preamble and of the DPCH (at turn-on the DPCH consists only of the DPCCH) and displays them in the UE Expected Open Loop Transmit Power window on the Call Setup Screen .

Initial PRACH TX Power

The test set calculates the expected transmit power of the first PRACH preamble using the following formula (see 3GPP TS 25.331 8.5.7):

Initial PRACH TX Power = Primary CPICH TX power - CPICH RSCP + Uplink Interference + Constant value

Three parameters are directly user-settable: Primary CPICH TX Power , Uplink Interference , and Constant Value .

The fourth parameter, CPICH RSCP (Received Signal Code Power) , is the result of the UE reported measurement of the CPICH code channel power. You can change the test set's CPICH code channel power by varying Cell Power and/or CPICH Level (see Downlink Channel Levels and CALL:STATus:CPIChannel[:CELL[1]]:POWer[:AMPLitude]? ).

NOTE
Ensure that you do not set these parameters such that the UE would be required to transmit its PRACH at a power level equal to or greater than its maximum transmit power or the power specified by the Maximum Uplink Transmit Power Level setting. See Call Setup Fails Due to Transmission of Single PRACH Preamble .

GPIB command: CALL:UPLink:PRAChannel:POWer:INITial?

Initial DPCCH TX Power

Per 3GPP TS 25.331 s8.5.3, the UE determines its initial DPCCH transmit power using the following formula:

DPCCH_Initial_power = DPCCH_Power_offset - CPICH_RSCP

The UE determines "CPICH_RSCP" by measuring the test set's CPICH code channel power. "DPCCH_Power_offset" is signalled by the test set in the RRC Connection Setup and Radio Bearer Setup messages used to establish the connection. The test set signals a value for DPCCH_Power_offset that places the UE's initial transmission near the UE Target Power setting (because the test set's receiver is ranged based on the UE Target Power setting). Thus, to determine what DPCCH_Power_offset value to signal during call establishment, the test set considers the UE Target Power setting, as well as the Cell Power and CPICH Level settings (which determine the CPICH RSCP the UE will measure).

As mentioned above, the test set signals a value for DPCCH_Power_offset that places the UE's initial transmission near the UE Target Power setting. The UE's initial transmission consists only of the DPCCH. The UE Target Power setting is the level you wish for the UE's DPCCH+DPDCH transmission. Thus, the test set places the initial transmit power of the UE's DPCCH slightly lower than the UE Target Power setting so that when the DPDCH is turned on, the total UE power matches the UE Target Power setting. The initial DPCCH power can thus be determined by the following formula:

Initial DPCCH TX Power = UE Target Power + 10 log (Beta c ^2/(Beta c ^2 + Beta d ^2))

All three parameters are user settable, see UE Target Power and Uplink DPCH Bc/Bd Control .

As an example, when Cell Power = -75 dBm, CPICH Level = -3.3 dB, UE Target Power = -5 dBm, Betac = 8/15 and Betad = 15/15, the value signalled for DPCCH_Power_offset is -44 (-88 dB) so that the Initial DPCCH TX Power is near -11.55 dBm (note that the actual level achieved is within 2 dB due to the fact that the information element's range is specified in steps of 2).

GPIB command: CALL:UPLink:DPCChannel:POWer:INITial?

Related Topics

How Do I Change UE TX Power Levels?


Uplink Channel (UARFCN)

Uplink Channel (UARFCN)

Last updated: January 12, 2011

Uplink Channel

The Uplink Channel setting specifies the uplink UTRA Absolute RF Channel Number (UARFCN). This automatically sets the test set's receivers to the expected UE transmit frequency.

The relationship between UARFCN and uplink frequency is described in 3GPP TS 25.101 section 5.

Uplink Frequency and UARFCN, and Uplink Channel Range
Band | TS 25.101 DL to UL Frequency Separation (MHz) | TS 25.101 Center Frequency Range (MHz) | TS 25.101 UARFCN Equation | TS 25.101 UARFCN Range | Test Set "Uplink Channel" Range
I (IMT-2000) | 190 | 1922.4 - 1977.6, increment = 0.2 | 5 * (center freq in MHz) | 9612 - 9888 | 9612 - 9888
II (U.S. PCS) | 80 | 1852.4 - 1907.6, increment = 0.2 | 5 * (center freq in MHz) | 9262 - 9538 | 9262 - 9538
 |  | 1852.5 - 1907.5, increment = 5 | 5 * ((center freq in MHz) - 1850.1 MHz) | 12, 37, 62, 87, 112, 137, 162, 187, 212, 237, 262, 287 | 12, 37, 62, 87, 112, 137, 162, 187, 212, 237, 262, 287
III (DCS/PCS) | 95 | 1712.4 - 1782.6, increment = 0.2 | 5 * ((center freq in MHz) - 1525 MHz) | 937 - 1288 | 937 - 1288
IV | 400 | 1712.4 - 1752.6, increment = 0.2 | 5 * ((center freq in MHz) - 1450 MHz) | 1312 - 1513 | 1312 - 1513
 |  | 1712.5 - 1752.5, increment = 5 | 5 * ((center freq in MHz) - 1380.1 MHz) | 1662, 1687, 1712, 1737, 1762, 1787, 1812, 1837, 1862 | 1662, 1687, 1712, 1737, 1762, 1787, 1812, 1837, 1862
V (US Cellular) | 45 | 826.4 - 846.6, increment = 0.2 | 5 * (center freq in MHz) | 4132 - 4233 | 4132 - 4233
 |  | 826.5, 827.5, 831.5, 832.5, 837.5, 842.5 | 5* ((center freq in MHz) - 670.1 MHz) | 782, 787, 807, 812, 837, 862 | 782, 787, 807, 812, 837, 862
VI (Japan 800) | 45 | 832.4 - 837.6, increment = 0.2 | 5 * (center freq in MHz) | 4162 - 4188 | 4162 - 4188
 |  | 832.5, 837.5 | 5 * ((center freq in MHz) - 670.1 MHz) | 812, 837 | 812, 837
VII | 120 | 2502.4 - 2567.6, increment = 0.2 | 5 * ((center freq in MHz) - 2100 MHz) | 2012 - 2338 | 2012 - 2338
 |  | 2502.5 - 2567.5, increment = 5 | 5 * ((center freq in MHz) - 2030.1 MHz) | 2362, 2387, 2412, 2437, 2462, 2487, 2512, 2537, 2562, 2587, 2612, 2637, 2662, 2687 | 2362, 2387, 2412, 2437, 2462, 2487, 2512, 2537, 2562, 2587, 2612, 2637, 2662, 2687
VIII | 45 | 882.4 - 912.6 | 5 * ((center freq in MHz) - 340 MHz) | 2712 - 2863 | 2712 - 2863
IX | 95 | 1752.4 - 1782.4, increment = 0.2 | 5 * (center freq in MHz) | 8762 - 8912 | 8762 - 8912
X | 400 | 1712.4 - 1767.6, increment = 0.2 | 5 * ((center freq in MHz) - 1135 MHz) | 2887 - 3163 | 2887 - 3163
 |  | 1712.5-1767.5, increment = 5 | 5 * ((center freq in MHz) - 1075.1 MHz) | 3187, 3212, 3237, 3262, 3287, 3312, 3337, 3362, 3387, 3412, 3437, 3462 | 3187, 3212, 3237, 3262, 3287, 3312, 3337, 3362, 3387, 3412, 3437, 3462
XI | 48 | 1430.4 - 1450.4, increment = 0.2 | 5 * ((center freq in MHz) - 733 MHz) | 3487 - 3587 | 3487 - 3587
XII | 30 | 700.4 - 713.6, increment = 0.2 | 5 * ((center freq in MHz) + 22 MHz) | 3612 - 3678 | 3612 - 3678
 |  | 700.5, 701.5, 706.5, 707.5, 712.5, 713.5 | 5 * ((center freq in MHz) + 39.9 MHz) | 3702, 3707, 3732, 3737, 3762, 3767 | 3702, 3707, 3732, 3737, 3762, 3767
XIII | 31 | 779.4 - 784.6, increment = 0.2 | 5 * ((center freq in MHz) - 21 MHz) | 3792 - 3818 | 3792 - 3818
 |  | 779.5, 784.5 | 5 * ((center freq in MHz) - 11.1 MHz) | 3842, 3867 | 3842, 3867
XIV | 30 | 790.4 - 795.6, increment = 0.2 | 5 * ((center freq in MHz) - 12 MHz) | 3892 - 3918 | 3892 - 3918
 |  | 790.5, 795.5 | 5 * ((center freq in MHz) - 2.1 MHz) | 3942, 3967 | 3942, 3967
XIX | 45 | 832.4 - 842.6 | 5 * ((center freq in MHz) - 770 MHz) | 312 - 363 | 312 - 363
 |  | 832.5, 837.5, 842.5 | 5 * ((center freq in MHz) - 755.1 MHz) | 387, 412, 437 | 387, 412, 437
XX | 41 | 834.4 - 859.6 | 5 * ((center freq in MHz) + 23 MHz) | 4287 - 4413 | 4287 - 4413
XXI | 48 | 1450.4 - 1460.4 | 5 * ((center freq in MHz) - 1358 MHz) | 462 - 512 | 462 - 512

You can specify the uplink UARFCN in one of two ways:

  • Uplink Channel

    Directly set the Uplink Channel setting to a specific uplink UARFCN value.

    GPIB commands: CALL:UPLink:CHANnel[:MCHannel]

  • Automatically Determined by DL Channel Setting

    When Uplink Channel is set to Auto , the uplink UARFCN is automatically determined by the DL Channel setting (the test set subtracts the frequency separation associated with the DL Channel 's band from the DL Channel setting).

    GPIB command: CALL:UPLink:CHANnel:CONTrol:AUTO

To query the current uplink channel number via GPIB command, see CALL:STATus:UPLink:CHANnel? . Current Info, UL: Channel and Frequency is also displayed on the Channel (UARFCN) Information screen.

When in FDD Test operating mode, the expected uplink frequency can also be set by manually entering the Uplink Frequency (see Receiver Control ).

Operating Considerations

  • These settings cannot be changed while in active cell operating mode. Attempting to change these settings while in this mode results in an error and the test set rejects the change. Use the Cell Off operating mode when changing these settings. See CALL:OPERating to select operating modes.
  • To hand over to a new uplink channel while on a connection, you must perform a Physical Channel Reconfiguration , Transport Channel Reconfiguration or Radio Bearer Reconfiguration . After successful completion of a handover to a new UL UARFCN, the Uplink Channel setting is overwritten with the value of the handover uplink channel .
  • If the Uplink Channel setting results in an UL/DL offset of less than 30 MHz when compared with the DL Channel setting, the warning message "Performance not specified for UL/DL frequency offset <30 MHz" is issued.

Related Topics

Manual Operation: Setting Call Parameters that Can Only Be Changed in Cell Off Mode

CALL:UPLink:CHANnel[:MCHannel]

CALL:STATus:UPLink:CHANnel?

Channel (UARFCN) Parameters

Channel (UARFCN) Information

Downlink Channel (UARFCN)

Handovers


Uplink Parameters

Uplink Parameters

Last updated: January 15, 2009

  • PRACH Parameters
  • DPCH Parameters

Uplink parameters define configuration of the Physical Random Access Channel (PRACH) and the uplink Dedicated Physical Channel (DPCH). Uplink parameters are used during Active Cell operation, but many can only be changed during Cell Off mode operation, or while the call status is Idle, as indicated in the descriptions below.

To configure the uplink HS-DPCCH, used during HSDPA operation ( lab application or feature-licensed test application only ), see HSDPA Uplink Parameters .

PRACH Parameters

The uplink Physical Random Access Channel (PRACH) carries the Random Access Channel (RACH) information which is transmitted by the UE during registrations or BS originated calls. A PRACH is composed of two parts: a number of preambles and a message portion. The preambles are a series of RF power "steps" which increase in power according to the power step setting until the maximum number of preambles is reached or the base station acknowledges receiving the preamble on the acquisition indication channel (AICH). Once the UE receives a positive indication on the AICH, it transmits the message portion of the PRACH which consists of message data and control data (pilot bit and TFCI) with independent power gain control.

  • PRACH Power Ramp Step

    PRACH power ramp step is used to increase the transmit power of the PRACH preamble when no response is received from the test set.

    GPIB command: CALL:UPLink:PRAChannel:POWer[:RAMP]:STEP[:LEVel] .

    This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

  • PRACH Signature

    As specified in 3GPP TS 25.211 section 5.2.2.1.2, the PRACH preamble is of length 4096 chips and consists of 256 repetitions of a signature of length 16 chips. There are a maximum of 16 available signatures that the UE can use for its PRACH preamble. 3GPP TS 25.213 section 4.3.3.3 defines these 16 signatures, which are numbered from 0 to 15.

    You may specify which of the 16 signatures are available to the UE. The UE may then choose any one signature for a PRACH preamble. As defined in 3GPP TS 25.331 section 10.3.6.52, a 16-bit mask is available to specify which of the 16 signatures are available to the UE ( PRACH Signatures, Upper (Bit Mask) and PRACH Signatures, Lower (Bit Mask) from the front panel). Setting the upper-most bit of the mask to 1 indicates that signature 15 is available, setting the lower-most bit of the mask to 1 indicates that signature 0 is available. You may set any one or all of the bits in the mask to 1. For example, setting the mask to 0010001100100011 indicates that signatures 13, 9, 8, 5, 1 and 0 are available to the UE.

    For the lab application only, the test set reports which signature is used by the UE on its final PRACH burst, see Detected PRACH Signature . If the PRACH Signature setting specifies a single PRACH signature, then Detected PRACH Signature and PRACH Signature should be the same.

    For the lab application only, the PRACH preamble analysis measurement also reports the signature used by the UE for the PRACH burst it has analyzed (see PRACH Preamble Analysis Measurement Description ). If the PRACH Signature setting specifies a single PRACH signature, then the PRACH signature reported by the measurement, Detected PRACH Signature and PRACH Signature should be the same.

    GPIB command: CALL:UPLink:PRAChannel:SMASk .

    This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

  • PRACH Scrambling Codeword

    Scrambling code used to spread the Signature when creating a PRACH preamble.

    GPIB command: CALL:UPLink:PRAChannel:SCODe .

    This parameter can not be changed in active cell operating mode (use cell off operating mode).

  • PRACH Bc/Bd Control

    This parameter selects whether the gain settings for the message portion of the PRACH are set manually or automatically by the test set. When PRACH Bc/Bd Control is set to Auto , Beta c and Beta d are both set to 15.

    When PRACH Bc/Bd Control is set to Manual :

    • Manual PRACH Bc

      Used to specify the gain setting for the control data of the message portion of the PRACH (Beta c ).

      GPIB command: CALL:UPLink:PRAChannel:MANual:CBETa .

    • Manual PRACH Bd

      Used to specify the gain setting for the message data of the message portion of the PRACH (Beta d ).

      GPIB command: CALL:UPLink:PRAChannel:MANual:DBETa .

    This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

    GPIB commands: CALL:UPLink:PRAChannel:BETA:AUTo , CALL:STATus:PRAChannel[:CELL]:CURCbeta? and CALL:STATus:PRAChannel[:CELL]:CURDbeta? .

  • Uplink Timing Offset

    The Uplink Timing Offset allows you to specify the offset of the UE's PRACH transmission from the start of the access slot. The range is -256 to +256 chips.

    For the lab application only, you can use the PRACH Preamble Analysis measurement to calculate your UE's offset (see Timing Error (in chips) ).

    This parameter can not be changed in active cell operating mode (use cell off operating mode).

    GPIB command: CALL:UPLink:PRAChannel:TIMing[:OFFSet]

  • PRACH Preambles

    Specifies the maximum number of preambles to be sent during one PRACH ramping cycle (see PRACH Ramping Cycles (MMAX) ) when no response is received from the test set. To prevent the test set from responding to the PRACH request, turn Call Limit State on.

    GPIB command: CALL:UPLink:PRAChannel:PREambles:NUMBer .

    This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

  • PRACH Ramping Cycles (MMAX)

    Specifies the maximum number of preamble sequences to be repeated when no response is received from the test set. To prevent the test set from responding to the PRACH request, turn Call Limit State on.

    GPIB command: CALL:UPLink:PRAChannel:PREambles:RCYCles[:MMAX] .

    This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

  • Available Subchannels (Bit Mask)

    Specifies which of the twelve PRACH subchannels are available for UE PRACH access. The PRACH is divided up into 15 timeslots known as access slots. Each PRACH subchannel consists of a group of access slots. The more subchannels the UE is allowed to use, the more often it can transmit on the PRACH (see 3GPP TS 25.214 s6.1.1).

    A setting of "1" indicates the corresponding subchannel is available, while a setting of "0" means the subchannel is unavailable. For example, a setting of "111111111111" means all twelve subchannels are available. A setting of "000000000001" means that only subchannel 0 is available. See 3GPP TS 25.331 s10.3.6.52.

    GPIB command: CALL:UPLink:PRAChannel:ASUBchannels .

    This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

  • Maximum Uplink Transmit Power Level

    The Maximum Uplink Transmit Power Level setting determines the value of the "Maximum allowed UL TX power" information element sent in SIB3 by the test set (see 3GPP TS 25.331 s8.6.6.8 and s10.3.6.39). Per 3GPP TS 25.331 s8.1.1.6.3-4, the UE shall use the contents of SIB3 while in idle mode. Thus, the UE must use the value of "Maximum allowed UL TX power" signalled in SIB3 to determine the maximum power at which it may transmit its PRACH (referred to as UE_TXPWR_MAX_RACH in 3GPP TS 25.304 and 25.331).

    Note that when establishing a connection, the test set always sends a value of +33 dBm for the "Maximum allowed UL TX power" information element sent in the RRC Connection Setup message. Thus, the UE's maximum DPCH transmit power is always limited to +33 dBm, regardless of the Maximum Uplink Transmit Power Level setting.

    NOTE
    This setting affects whether the UE can camp to the test set. To ensure that your UE will camp to the test set at low cell power levels, set Maximum Uplink Transmit Power Level to the maximum transmit power for your UE. See UE Does Not Camp to Test Set at Low Cell Power Levels .

    3GPP TS 25.101 6.2.1 specifies the following maximum transmit powers per power class:

    Maximum Transmit Power vs. Power Class
    Power Class | Maximum Transmit Power (dBm)
    1 | +33
    2 | +27
    3 | +24
    4 | +21

    Note that Maximum Uplink Transmit Power Level can be set to +33 dBm (for example, to ensure that your UE can properly process this value), but none of the test set's measurements are specified beyond +28 dBm.

    To aid in successful call completion, ensure that your UE does not begin its PRACH preamble sequence at the Maximum Uplink Transmit Power Level or its maximum transmit power (see Call Setup Fails Due to Transmission of Single PRACH Preamble ).

    GPIB command: CALL:UPLink:TXPower:LEVel:MAXimum .

    This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

DPCH Parameters

The uplink Dedicated Physical Channel (DPCH) consists of the Dedicated Physical Data Channel (DPDCH) which carries the user data, and the Dedicated Physical Control Channel (DPCCH) which carries the physical layer control information (pilot data, TFCI and TPC).

  • Uplink DPCH Scrambling Code

    Scrambling code used to provide a unique channelization required for each UE.

    GPIB command: CALL:UPLink:DPCHannel:SCODe .

    This setting can only be changed while in Cell Off or FDD Test Operating Mode .

  • Uplink DPCH Bc/Bd Control

    This parameter selects whether the DPCH gain settings are set manually or automatically by the test set. When Uplink DPCH Bc/Bd Control is set to Auto , the gain settings are automatically set by the test set.

    For example, for a 12.2k RMC, 3GPP TS 34.121 sC.2.1 specifies a DPCCH/DPDCH power ratio of -5.46 dB. A DPCCH/DPDCH power ratio of -5.46 dB is achieved if the amplitude ratio B c /B d is 8/15:

    DPCCH/DPDCH power ratio = 20log 10 (B c /B d ) = -5.46 dB --> B c /B d = 0.5333 = 8/15

    Thus, if Channel Type is set to an RMC including a 12.2k uplink and Uplink DPCH Bc/Bd Control is set to Auto , the test set automatically sets B c to 8 (8/15) and B d to 15 (15/15).

    The following table specifies the settings used for each downlink channel type when Uplink DPCH Bc/Bd Control is set to Auto .

    Automatic Beta Values for each Downlink Channel Type

    Downlink Channel Type

    B c

    B d

    2.2k DCCH SRB

    8

             15

    3.4k DCCH SRB

             8 15

    13.6k DCCH SRB

             8 15

    12.2k RMC

             8 15

    64k RMC

             5 15

    144k RMC

             4 15

    384k RMC

             4 15

    33k No Coding RMC

             8 15

    12.2k UL/64k DL AM RMC

    8

             15

    12.2k UL/144k DL AM RMC

    8

             15

    12.2k UL/384k DL AM RMC

    8

             15

    64k UL/384k DL AM RMC

    5

             15

    12.2k Voice

             8 15

    10.2k Voice

             8 15

    7.95k Voice

             8 15

    7.4k Voice

             8 15

    6.7k Voice

             8 15

    5.9k Voice

             8 15

    5.15k Voice

             8 15

    4.75k Voice

             8 15

    64k UL/64k DL CS Data RAB

             5 15

    64k UL/64k DL PS Data RAB

            5 15

    64k UL/384k DL RMC

             5 15

    64k UL/384k DL PS Data RAB

             5 15

    When Manual is selected, the following two settings are available:

    • Manual Uplink DPCH Bc

      Used to specify the gain setting for the DPCCH (beta c ). Range is 1 to 15 (see 3GPP TS 25.213 s4.2.1.1 Table 1 for a mapping of the signalled values to the resulting quantized amplitude ratios).

      GPIB command: CALL:UPLink:DPCHannel:MANual:CBETa .

    • Manual Uplink DPCH Bd

      Used to specify the gain setting for the DPDCH (beta d ). Range is 0 to 15 (see 3GPP TS 25.213 s4.2.1.1 Table 1 for a mapping of the signalled values to the resulting quantized amplitude ratios).

      GPIB command: CALL:UPLink:DPCHannel:MANual:DBETa .

    Note that according to 3GPP TS 25.213 s4.2.1.1, "At every instant in time, at least one of the values Beta c and Beta d has the amplitude 1.0" (which corresponds to a signalling value of 15). However, the test set does not constrain you in this way; you may set Manual Uplink DPCH Bc to any value between 1 and 15 and independently set Manual Uplink DPCH Bd to any value between 0 and 15. Note that configuring Bc and Bd such that neither is set to 15 is undefined in the standards, and may result in unexpected behavior.

    Also note that according to 3GPP TS 25.213 s4.2.1.1 Table 1, if Beta c or Beta d is signalled as 0, the DPCCH or DPDCH (respectively) is switched off.

    These parameters cannot be changed in active cell operating mode. You must switch to cell off or FDD test operating mode to change these parameters. To change the gain settings signalled to the UE while in active cell operating mode, you must perform a Transport Channel Reconfiguration or Radio Bearer Reconfiguration .

    You can query the beta c and beta d values currently being signalled to the UE by the test set using the CALL:STATus:DPCHannel[:CELL]:CURCbeta? and CALL:STATus:DPCHannel[:CELL]:CURDbeta? commands.

    GPIB command: CALL:UPLink:DPCHannel:BETA:AUTo

Related Topics

How Do I Change Uplink Parameters?


Uplink Closed Loop Power Control Parameters and UE Target Power

Uplink Closed Loop Power Control Parameters and UE Target Power

Last updated: January 15, 2009

Once the DPCH is established, the test set transmits power control information on the DPCCH to control the UE's transmit power (see UE Expected Open Loop Transmit Power for information regarding UE power levels before the DPCH is established).

UL CL Power Ctrl Parameters

UL CL Power Control Mode

UL CL Power Ctrl Mode controls what power control bit pattern is sent to the UE. It can be set to the following:

  • Active bits - the test set sends the power control bits required to maintain the UE's DPDCH+DPCCH power at the value entered for UE Target Power . Note that when on an HSDPA or HSPA connection, the UE's total output power will be greater than this value when power is present in the uplink HS-DPCCH. See UE Target Power for additional information.
    When UL CL Power Control Mode is set to Active bits , the test set measures the UE's DPCCH level and uses the uplink Beta c and Beta d values (see Uplink DPCH Bc/Bd Control ) to determine what power control bits to send to the UE to drive its DPDCH+DPCCH power to the UE Target Power (for UL CL Power Ctrl Algorithm = Two , the test set does not order the UE to change its power unless its power is more than +/- 0.75 dB away from UE Target Power ).
  • Alternating bits - the test set sends alternating power-up and power-down bits to the UE. When UL CL Power Ctrl Algorithm is set to Two , the UE is thus instructed to transmit at a fixed power level (the power level at which it was transmitting when Alternating bits was activated). When UL CL Power Ctrl Algorithm is set to One , the UE is thus instructed to vary its power around the power level at which it was transmitting when Alternating bits was activated by 1 or 2 dB (depending upon the UL CL Power Ctrl Stepsize setting). When in Alternating bits mode, you can instruct the UE to increase or decrease its transmit power level by 1 dB using the Send Step Up TPC Bit Pattern or Send Step Down TPC Bit Pattern commands (see Send Step Up/Down TPC Bit Pattern ).
  • All Up bits - the test set sends a continuous pattern of power-up bits. This is often used to drive the UE to transmit at its maximum power level. Note, the test set will continuously send up bits to the UE in this mode, even if the UE exceeds the test set's specified measurement limit of +28 dBm.
  • All Down bits - the test set sends a continuous pattern of power-down bits. This is often used to drive the UE to transmit at its minimum power level.
  • 10 Up/Down bits - the test set sends a repeating pattern of 10 power-up bits and 10 power-down bits. The pattern always begins on a frame boundary.

GPIB commands: CALL[:CELL]:CLPControl:UPLink:MODE and CALL:FDDTest:CLPControl:UPLink:MODE .

UL CL Power Ctrl Algorithm

UL CL Power Ctrl Algorithm specifies which power control algorithm the UE should use while under closed loop power control (see 3GPP TS 25.214 5.1.2.2.1). The power control algorithm determines the method the UE uses to derive a single TPC_cmd for each slot from the TPC commands received from the test set. See UL CL Power Ctrl Stepsize for information regarding how TPC_cmd is then translated into a UE transmit power change.

UL CL Power Ctrl Algorithm can be set to:

  • One - When using power control algorithm one to process TPC commands, the UE determines TPC_cmd for each slot based on the TPC commands received in that slot (if the UE is in soft handover, it will receive more than one TPC command in each slot).

    If only one TPC command is received in the slot and is equal to 0, then TPC_cmd for that slot is -1. If only one TPC command is received in the slot and is equal to 1, then TPC_cmd for that slot is 1. (See 3GPP TS 25.214 5.1.2.2.2 for more information about how the UE combines TPC commands received in a slot.) The UE then uses the UL CL Power Ctrl Stepsize value to determine whether to change its power by a magnitude of 1 or 2 dB.

    Note, some measurements may give unexpected results when the UE is using power control algorithm one, because power control algorithm one may cause the UE's output power to change during the measurement interval.

  • Two - When using power control algorithm two to process TPC commands, the UE processes TPC commands on a 5-slot cycle, where the set of 5 slots is aligned to a frame boundary.

    If only one TPC command is received in each slot, TPC_cmd is derived as follows: TPC_cmd for the first 4 slots in the 5-slot set is always 0. For the fifth slot in the set, TPC_cmd is 1 if the TPC commands for all 5 slots are 1, is -1 if the TPC commands for all 5 slots are 0, or is 0 otherwise. The change in power is always 0 or of magnitude 1 dB.

This setting can only be changed while in Idle state. To change the power control step size while on a connection, you must perform a Physical Channel Reconfiguration . After completion of the Physical Channel Reconfiguration procedure, successful or not, the UL CL Power Ctrl Algorithm setting is overwritten with the value of Handover UL CL Power Ctrl Algorithm .

This setting applies to both cell 1 and cell 2 (for the lab application only).

GPIB commands: CALL[:CELL]:CLPControl:UPLink:ALGorithm and CALL:FDDTest:CLPControl:UPLink:ALGorithm .

UL CL Power Ctrl Stepsize

When UL CL Power Ctrl Algorithm is set to One , you can specify the size of the change in UE power for each TPC_cmd. You can set UL CL Power Ctrl Stepsize to 1 dB or 2 dB, which sets Delta TPC to 1 dB or 2 dB, respectively. For algorithm two, Delta TPC is always set to 1 dB.

The UE determines its required change in output power by multiplying Delta TPC by TPC_cmd. The change in power is applied in the slot adjacent to the slot in which TPC_cmd was received.

This setting can only be changed in Idle state, and when UL CL Power Ctrl Stepsize is set to One . To change the power control step size while on a connection, you must perform a Physical Channel Reconfiguration . After completion of the Physical Channel Reconfiguration procedure, successful or not, the UL CL Power Ctrl Step Size setting is overwritten with the value of Handover UL CL Power Ctrl Step Size .

If UL CL Power Ctrl Stepsize is set to Two , this setting is returned to its default value of 1 dB .

This setting applies to both cell 1 and cell 2 (cell 2 is present in the lab application only).

GPIB command: CALL[:CELL]:CLPControl:UPLink:STEPsize .

Cell 2 UL CL Power Ctrl Mode

For the lab application only, the test set can send power control bit patterns to the UE on cell 2. The same modes are available as the UL CL Power Control Mode setting.

When Cell 2 Power Ctrl is set to Active bits , the same power control bits are sent on the cell 1 DPCCH and the cell 2 DPCCH.

See Cell 2 Overview .

GPIB command: CALL:CELL2:CLPControl .

Send Step Up/Down TPC Bit Pattern

Send Step Up TPC Bit Pattern and Send Step Down TPC Bit Pattern can send individual transmit power control (TPC) commands (on the cell 1 DPCCH) to change the UE's power up or down by 1 dB. These functions can only be used when UL CL Power Control Mode is set to Alternating bits .

GPIB commands: CALL[:CELL]:CLPControl:UPLink[:IMMediate]:UP and CALL[:CELL]:CLPControl:UPLink[:IMMediate]:DOWN .

UE Target Power

When Power Control is set to Auto , the test set sets its receiver input power level to the value of the UE Target Power setting (see Expected Power ).

When UL CL Power Control Mode is set to Active bits , the test set measures the UE's DPCCH level and uses the uplink Beta c and Beta d values (see Uplink DPCH Bc/Bd Control ) to determine what power control bits to send to the UE to drive its DPDCH+DPCCH power to the UE Target Power (the test set measures the UE's DPCCH, then calculates at what total power level the UE should be transmitting based on the Beta c and Beta d values; the test set assumes the UE is transmitting a DPDCH at the proper power level). The test set assumes an UL DPDCH is always present and transmitting at the level prescribed by Beta c and Beta d when sending power control bits to control the UE's total transmit power. Because of this, in cases where the UE's DPDCH is not always present (for example, when on a packet data connection), Active bits power control does not drive the UE's total transmit power as expected.

UL CL Power Ctrl Mode must be set to Active Bits in order for the test set to command the UE to output at the specified UE Target Power .

The maximum setting allowed for UE Target Power is +28 dBm , as that is the upper limit for all of the test set's measurement specifications.

UE Target Power in HSDPA

When on an HSDPA connection, the UE's total output power is composed of DPCCH + DPDCH + HS-DPCCH. Thus, when on an HSDPA connection, you must set UE Target Power as follows:

UE Target Power = ( Desired Total UE Power ) - ( Power Change Due to HS-DPCCH )

Where Desired Total UE Power is the total output power level you desire from the UE, including DPCCH, DPDCH and HS-DPCCH.

Power Change Due to HS-DPCCH can be determined from Beta c , Beta d and Beta hs as described in HS-DPCCH Gain Settings .

UE Target Power in HSPA

When on an HSPA connection, the UE's total output power is composed of DPCCH + DPDCH + HS-DPCCH + E-DPCCH + E-DPDCH. Thus, when on an HSPA connection, you must set UE Target Power as follows:

UE Target Power = ( Desired Total UE Power ) - ( Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH )

Where Desired Total UE Power is the total output power level you desire from the UE, including DPCCH, DPDCH, HS-DPCCH, E-DPCCH and E-DPDCH.

Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH = 10log 10 (Beta c ^2 + Beta d ^2 + Beta hs ^2 + Beta ec ^2 + Beta ed ^2) - 10log 10 (Beta d ^2 + Beta c ^2)

Beta ec is set using E-DPCCH/DPCCH Power Offset (DeltaE-DPCCH) (as per 3GPP TS 25.213 Table 1B).

Beta ed is set by sending the corresponding absolute grant (as per 3GPP TS 34.121 Table C.11.1.3) see Serving Grant .

GPIB command: CALL:MS:POWer .

Related Topics

Manual Operation: How Do I Change UE TX Power Levels?

UE Expected Open Loop Transmit Power

Receiver Control

Cell 2 Overview

Active Cell Operating Mode


UMA/GAN Test System

UMA/GAN Test System

Last updated: January 15, 2009

This section is only applicable to the lab applications.

The UMA/GAN Test System is intended for use in lab based functional, application, and pre-conformance testing of dual mode enabled UMA/GAN handsets.

  • UMA/GAN Concept
  • UMA/GAN Typical Test Configuration
  • UMA/GAN related procedures
  • UMA/GAN Parameters

UMA/GAN Concept

The Unlicensed Mobile Access (UMA) is an extension of GSM/GPRS mobile services into the customer's premises. It is achieved by tunnelling GSM/GPRS protocols through a broadband IP network and an unlicensed radio link in the customer's premises. Additional protocols control and manage the UMA access network, and carry bearer traffic over IP. UMA is therefore a complement to traditional GSM/GPRS radio coverage - used to enhance customer premises coverage, increase network capacity and potentially lower costs.

The first UMA specifications were published in September 2004 (R1.0.0). After the initial release, the UMA specifications were contributed to the 3GPP organization as part of 3GPP work item "Generic Access to A/Gb interfaces". On 8th April 2005, the 3GPP approved specifications for Generic Access to A/Gb interfaces for inclusion in 3GPP Release 6 (3GPP TS 43.318). There were only trivial terminology changes made to the UMA protocol and architecture specifications during the transition to 3GPP.

Under 3GPP, what was previously known as UMA is now instead referred to as Generic Access Network or GAN and the UMA Network Controller (UNC) entity is instead referred to as a Generic Access Network Controller or GANC.

The following figure gives the functional architecture of a Generic Access Network.

Two new entities are introduced by the GAN architecture:

  • UMA/GAN-enabled and dual-mode mobile station. The mobile station must be able to run procedures that detect when the user is roaming in and out of a Bluetooth or Wi-Fi network so that it can switch to and from UTRAN mode.
  • Generic Access Network Controller (GANC). The GANC is equivalent in function to a Base Station Controller in a typical UTRAN network; unlike a BSC however, the front end of the GANC connects to the MS via an IP access network. The GANC essentially acts as a bridge between the Bluetooth/Wi-Fi and cellular network. The GANC also includes a Security Gateway (SEGW) that terminates secure remote access tunnels for the mobile station, providing mutual authentication, encryption and data integrity for signalling, voice and data traffic.

UMA/GAN Typical Test Configuration

The figure above provides a pictorial overview of the system, the premise of which is to provide integrated lab based emulation of both a UTRAN cell and a GAN "cell" for use by a connected MS. The system is designed to allow a connected MS to make either UTRAN or GAN based voice, data and signaling connections as well as to exercise all applicable GAN <-> UTRAN mode transitions. The system achieves this aim through simulation or inclusion of all real-world network components that are required for such procedures.

The UMA/GAN test system is comprised of the following components:

  • A test set running E6703E Lab Application Firmware.

    The system is built around the test set's existing capabilities to provide UTRAN cell and core mobile network emulation. All existing controls at the test set to configure its UTRAN cell and control core PLMN operation (voice call initiation, SMS, data routing etc.) remain available for use within the system as per their existing behavior in the test set.

  • One or more commercial or proprietary WLAN or Bluetooth access point.

    There are no changes required to off-the-shelf wireless access points for use in UMA/GAN, the only recommendations are that for voice operation and battery life optimization; access points that support QoS features are likely to exhibit better performance.

  • Zero or more commercial or proprietary SEGWs and AAA servers.
  • A standard PC running proprietary Agilent GANC software.

    To aid in simulation of the GAN `cell' in the system, Agilent provide proprietary test focused GANC emulation software for use with the system. This software is capable of communicating with a connected MS using the standardized GAN Up interface protocols, namely GA-RC, GA-CSR, and GA-PSR. The Agilent GANC also connects the test set in the system to make use of its core network capabilities via the same BSSAP & BSSGP protocols that are designed for this purpose in a real network (although these are run over a proprietary IP connection in the system rather than SS7 as would normally be used). The combination of these interfaces at the GANC allow a connected MS to fully make use of the GANC for accessing the test set's core network to perform GAN based speech, data and signaling procedures.

  • Any number of further networked devices (typically PCs) running network servers such as FTP, HTTP, MMSC etc. for use in end to end GAN data throughput and application test of the handset, and
  • A dual-mode GAN enabled handset.

Note: Only the test set, its associated firmware and the GANC application software in such a system are supplied by Agilent. All other components must be supplied and configured independently by yourself.

UMA/GAN related procedures

The procedures supported in the UMA/GAN Test System include:

  • GAN discovery and registration procedures
  • MO and MT voice calls over GAN
  • MO and MT Circuit Switched SMS support over GAN
  • GAN Rove-in / Rove-out procedures
  • Network initiated voice handover from UTRAN to GAN (Handover-in)
  • MS/GANC initiated voice handover from GAN to UTRAN (Handover-out)
  • Network initiated voice handover from GAN to UTRAN
  • View MS reports sent to GANC
  • View current MS GAN status
  • GAN protocol logging via Ethereal (a free third party software), cellular signaling and traffic logging via WPA.

See UMA/GAN Procedures Ladder Diagrams for the message sequence chart of UMA/GAN related procedures.

Refer to the user guide of GAN Controller (E6962A) for details on how to perform the above test procedures.

UMA/GAN Parameters

  • Access Stratum reporting

    This parameter is used to report the current access stratum in use by a connected mobile station. This is the only parameters on the test set side.

    The GPIB command to set this parameter is CALL:ACCess:STRatum? .

  • GANC configuration and report parameters.

    Refer to the user guide of GAN Controller (E6962A).

Operating Considerations

The existing data throughput monitor at the test set can be used in the UMA/GAN test system to monitor data connections made by the MS over both GAN and UTRAN access stratums.

The Wireless Protocol Analyzer can log the UTRAN signaling and traffic protocols. For GAN logging, you can choose Wireshark (formerly known as Ethreal). Wireshark is a free network protocol analyzer widely used throughout the communications and IT industry. Wireshark provides very good support for logging all GAN signaling and user data messages sent between the MS and GANC and also does a pretty good job of decoding any embedded UTRAN core network destined messages contained within them.

Transmitter and Receiver Measurements are available at all times at the test set in the test system as per existing test set's behavior. However, the measurement results are only available at the test set when the MS is operating in UTRAN mode as otherwise there is no RF channel available to measure.

Related Topics

How to use the UMA/GAN Features


Compressed Mode Ladder Diagrams

Compressed Mode Ladder Diagrams

Last updated: January 15, 2009

This section is only applicable to the lab application.

  • TGPS Definition during Call Setup, Compressed Mode Activated without UE Measurements
  • TGPS Definition after Call Is Established, Compressed Mode Activated without UE Measurements
  • TGPS Definition during Call Setup, Compressed Mode Activated with UE Measurements
  • TGPS Definition after Call Is Established, Compressed Mode Activated with UE Measurements
  • Deactivating Compressed Mode

There are four different ways that compressed mode can be enabled in the test set and UE (see Summary of Options for Enabling Compressed Mode and UE Measurements ).

TGPS Definition during Call Setup, Compressed Mode Activated without UE Measurements

TGPS Definition after Call Is Established, Compressed Mode Activated without UE Measurements

TGPS Definition during Call Setup, Compressed Mode Activated with UE Measurements

TGPS Definition after Call Is Established, Compressed Mode Activated with UE Measurements

Deactivating Compressed Mode

Related Topics

Compressed Mode


Handover Ladder Diagrams

Handover Ladder Diagrams

Last updated: January 15, 2009

  • Physical Channel Reconfiguration (Inter-frequency Hard Handover)
  • Transport Channel Reconfiguration
  • System Handover from W-CDMA RB Test Mode to GSM Voice (with RB Test Mode to GSM Handover Alerting State = On)
  • System Handover from W-CDMA RB Test Mode to GSM Voice (with RB Test Mode to GSM Handover Alerting State = Off)
  • System Handover from W-CDMA AMR Voice to GSM Voice
  • Radio Bearer Reconfiguration from CS Domain or CS/PS Domain HSDPA RB Test Mode Connection or HSPA RB Test Mode Connection (lab application or feature-licensed test application only)

Physical Channel Reconfiguration (Inter-frequency Hard Handover)

Transport Channel Reconfiguration

System Handover from W-CDMA RB Test Mode to GSM Voice (with RB Test Mode to GSM Handover Alerting State = On)

System Handover from W-CDMA RB Test Mode to GSM Voice (with RB Test Mode to GSM Handover Alerting State = Off)

System Handover from W-CDMA AMR Voice to GSM Voice

Radio Bearer Reconfiguration from CS Domain or CS/PS Domain HSDPA RB Test Mode Connection or HSPA RB Test Mode Connection

Related Topics

Handovers


Handovers

Handovers

Last updated: December 22, 2011

The following handovers are available in the test set:

  • Physical Channel Reconfiguration
  • Transport Channel Reconfiguration
  • System Handover ( GSM/GPRS_W-CDMA fast switching test and lab applications only )
  • Soft Handover ( lab application only )
  • Radio Bearer Reconfiguration ( lab application or feature-licensed test application only )
  • External 8960 Handover ( lab application only )
  • External PS Handover ( lab application only )

The following table outlines the RAB reconfigurations that may be performed within a single test set while on a connection. For information on handovers available between two test sets ( lab application only ), see Two-Cell Test System .

Summary of RAB Reconfigurations Available in a Single Test Set

Originating Service Type

Destination Service Type
GSM Voice
( Fast Switching applications only )

RB Test Mode:
Symmetrical RMC

HSDPA
RB Test Mode:
FRC (CS Domain)

HSDPA
RB Test Mode:
FRC (PS Domain)

 HSDPA RB Test Mode:
FRC (CS/PS Domain) 		HSDPA RB Test Mode:
User Defined (CS Domain) 		HSDPA RB Test Mode:
User Defined (PS Domain) 		HSDPA RB Test Mode:
User Defined (CS/PS Domain) 		HSPA
RB Test
Mode

AMR Radio Access Bearer

 System Handover

RB Test Mode:
Symmetrical RMC

 System Handover Transport Channel Reconfig

HSDPA RB Test Mode:
FRC (CS Domain)

 System Handover Radio Bearer Reconfig Transport Channel Reconfig 2 Transport Channel Reconfig 2

HSDPA RB Test Mode:
FRC (PS Domain)

 Transport Channel Reconfig 2 Transport Channel Reconfig 2

HSDPA RB Test Mode:
FRC (CS/PS Domain)

 System Handover 1 Radio Bearer Reconfig Transport Channel Reconfig 2 Transport Channel Reconfig 2

HSDPA RB Test Mode:
User Defined (CS Domain)

 System Handover Radio Bearer Reconfig Transport Channel Reconfig 2 Transport Channel Reconfig

HSDPA RB Test Mode:
User Defined (PS Domain)

 Transport Channel Reconfig 2 Transport Channel Reconfig

HSDPA RB Test Mode:
User Defined (CS/PS Domain)

 System Handover 1 Radio Bearer Reconfig Transport Channel Reconfig 2 Transport Channel Reconfig

HSPA RB Test Mode

 System Handover Radio Bearer Reconfig

1 You can perform a System Handover while on an CS/PS Domain HSDPA RB Test Mode connection. However, if you end the resulting GSM/GPRS/EGPRS connection and switch back to the W-CDMA format, your initial attempt to establish a CS Domain or CS/PS Domain HSDPA RB Test Mode connection may fail; you may need to initiate the connection attempt a second time.

2 This RAB reconfiguration cannot be performed when HS-DSCH Config Type = FRC , but the same effect can be realized by using the User Defined settings to simulate an FRC (see User Defined Settings to Configure the Downlink as an FRC ), then using a Transport Channel Reconfiguration to change the User Defined settings that can't be changed while on a connection.

Additional reconfiguration notes:

  • GPRS Radio Access Bearer cannot be changed while on a PS Data or HSPA PS Data connection.
  • AMR RAB cannot be changed while on an AMR Radio Access Bearer voice connection.
  • The only reconfiguration available while on an asymmetrical RMC is System Handover.

Physical Channel Reconfiguration

A Physical Channel Reconfiguration can be used for inter-frequency hard handovers and also to change power control algorithm and step size while on a connection (you cannot simply change the DL Channel and Uplink Channel or power control algorithm settings while on a call, you must perform a handover to change them).

You must be on a call to perform a Physical Channel Reconfiguration.

Before executing a Physical Channel Reconfiguration, you must first specify the settings you wish to change (for example, downlink and uplink UARFCNs to which to handover). You must then select Execute Handover ( F5 ) or send the CALL:HANDoff:PCReconfig[:IMMediate] command to initiate the reconfiguration.

Upon completion of the handover (successful or not, and regardless of any errors), the handover settings are copied to their corresponding non-handover parameters (for example, the DL Channel and Uplink Channel settings are set to the value of Handover Downlink Channel (UARFCN) and Handover Uplink Channel (UARFCN) upon completion of the Physical Channel Reconfiguration).

  • Handover Downlink Channel (UARFCN)

    This setting determines the downlink channel the UE is instructed to use after completion of the Physical Channel Reconfiguration. See DL Channel for more information.

    GPIB command: CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:DOWNlink .

  • You can specify the handover uplink UARFCN in one of two ways:
    • Handover Uplink Channel (UARFCN)

      You can directly set the Handover Uplink Channel (UARFCN) setting to a specific uplink UARFCN value. The UE is instructed to use this uplink channel after completion of the Physical Channel Reconfiguration.

      GPIB command: CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink[:MCHannel] .

    • Automatic handover uplink channel

      When Handover Uplink Channel is set to Auto , the handover uplink UARFCN is automatically determined by the Handover Downlink Channel (UARFCN) setting. The test set subtracts the frequency separation associated with the handover downlink channel's band from the Handover Downlink Channel (UARFCN) setting, and instructs the UE to use this uplink channel after completion of the Physical Channel Reconfiguration.

      GPIB command: CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO

    See Uplink Channel for more information.

  • Handover Band Arbitrator

    When you set Handover Downlink Channel (UARFCN) to a value in Band VI, you must specify whether you want the test set to send a Band V or Band VI Frequency Band Indicator using the Handover Band Arbitrator setting. See Band Arbitrator for more information.

    GPIB command: CALL:SETup[:PCReconfig]:CHANnel:BARBitrator

  • Handover UL CL Power Ctrl Algorithm

    This setting determines the closed loop power control algorithm the UE is instructed to use after completion of the Physical Channel Reconfiguration procedure. See UL CL Power Ctrl Algorithm for more information.

    GPIB command: CALL:SETup:CLPControl:UPLink:ALGorithm

  • Handover UL CL Power Ctrl Step Size

    This setting determines the power control step size the UE is instructed to use after completion of the Physical Channel Reconfiguration procedure when Handover UL CL Power Ctrl Algorithm is set to One . This setting can only be changed when Handover UL CL Power Ctrl Algorithm is set to One . Also, if Handover UL CL Power Ctrl Algorithm is set to Two , this setting is returned to its default value of 1 dB . See UL CL Power Ctrl Stepsize for more information .

    GPIB command: CALL:SETup:CLPControl:UPLink:STEPsize

  • PCR Timing Indication (CFN Handling)

    You can specify whether the UE should maintain or initialise its CFN counter when performing the Physical Channel Reconfiguration. See RB setup Timing Indication (CFN Handling): for additional details. Note that 3GPP 25.331 v5.17.0 s8.6.6.28 states that the UE's behavior is undefined if the network sets the Timing Indication IE to Initialise on a non-hard handover (i.e. where the UARFCNs and one or more Primary Scrambling Codes remain unchanged as part of the reconfiguration).

    • Auto: When PCR Timing Indication (CFN Handling) is set to Auto , the Timing Indication information element sent in the Physical Channel Reconfiguration message is set to Initialise if Handover Downlink Channel (UARFCN) and Handover Uplink Channel (UARFCN) are set such that a hard handover will occur (UARFCNs will change). Otherwise, the Timing Indication information element sent in the Physical Channel Reconfiguration message is set to Maintain.
    • Initialise: the Timing Indication information element sent in the Physical Channel Reconfiguration message is set to Initialise.
    • Maintain: the Timing Indication information element sent in the Physical Channel Reconfiguration message is set to Maintain.

    GPIB command: CALL:HANDoff:PCReconfig:CFNHandling .

  • RB Test Mode PCR Loopback Messaging State

    You can specify whether the UE loopback is opened and closed as part of a Physical Channel Reconfiguration. This parameter only affects the Physical Channel Reconfiguration procedure when an RB Test Mode call is active (as the loopback is never closed on any other call type).

    • On : The test set sends an Open UE Test Loop message before sending the Physical Channel Reconfiguration message and a Close UE Test Loop message after receiving the Physical Channel Reconfiguration Complete message from the UE.

      Note, opening and closing the UE test loop clears the UE's buffer and resets its loopback delay (see BER Synchronization requirements ).

      Note, if a Close UE Test Loop message is not sent to the UE when establishing an asymmetrical RMC, you cannot send an Open UE Test Loop message as part of the Physical Channel Reconfiguration (see Asymmetric RMC Loopback Messaging ). If RB Test Mode PCR Loopback Messaging State is set to On and Asymmetric RMC Loopback Messaging is set to Off and the current connection is an asymmetrical RMC, the test set will not send the Open/Close UE Test Loop messages.

    • Off : The test set does not send any loopback control messages as part of the Physical Channel Reconfiguration procedure.

    GPIB command: CALL:HANDoff:PCReconfig:RBTest:LMESsaging:STATe

  • PCR Activation Time

    This parameter allows you to set the Activation Time that is signaled to the UE in the Physical Channel Reconfiguration message (see 3GPP TS 25.331 s10.3.3.1). Activation Time controls the frame number at which the operation caused by the related message shall take effect (in other words, how long the UE should wait before moving to the new frequency). It can be set between 0 and 255, and indicates the absolute value of the CFN (Connection Frame Number) at which the UE should perform the handover. If set to 0, the Activation Time IE is not sent in the Physical Channel Reconfiguration message.

    For most UEs, an Activation Time of 0 ("now") is appropriate. But for some UEs, the handover will fail if Activation Time is left at its default value of 0, as explained in the following:

    When the test set orders a Physical Channel Reconfiguration, it takes a finite amount of time for the test set to move to and settle at the new frequency. When the Physical Channel Reconfiguration is ordered, most UEs wait a time of T312 at the new frequency before determining that the handover has failed (T312 is signalled by the test set in SIB1 with a value of 5 seconds). If your UE does not wait once moving to the new frequency, the handover may fail. If it does, set the Activation Time as needed to cause the UE to wait until the test set has moved to the new frequency (a setting of 100 (100 x 10 ms = 1 s) is usually sufficient).

    Do not set PCR Activation Time to a value other than 0 unless necessary, as it slows down the handover procedure.

    GPIB command: CALL:HANDoff:PCReconfig:ATIMe

  • HSDPA Secondary Cell Handover DL UARFCN

    This parameter is used for Dual Cell HSDPA operation. You can specify the target downlink UARFCN of the secondary serving cell, whether to be Adjacent Higher or Adjacent Lower compared to the serving cell, by physical channel reconfiguration. In 3GPP Release 8, the carrier of the serving cell and the secondary serving cell must be adjacent.

    GPIB command: CALL:SETup[:PCReconfig]:SSCell:CHANnel:ADJacent

Physical Channel Reconfiguration Operating Considerations

  • In order for an inter-frequency hard handover to be successful, some UEs may require that you include the handover downlink channel in the SIB11 Inter-Freq Cell Info List (see Inter-frequency Cells ).
  • Any measurements that have been initiated are aborted when a Physical Channel Reconfiguration is initiated.
  • If the handover downlink and uplink channels result in an UL/DL offset of less than 30 MHz, the warning message "Performance not specified for UL/DL frequency offset <30 MHz" is issued.

Transport Channel Reconfiguration

The Transport Channel Reconfiguration provides three main functions:

  • Switching Between Symmetrical RMCs while on an RB Test Mode Connection
  • Changing Parameters that Require Cell Off Operating Mode or Idle Connection Status while on a Connection
  • Changing HSPA Parameters that Require Idle Connection Status while on a Connection ( lab application or feature-licensed test application only )

Before executing a Transport Channel Reconfiguration, you must first specify the settings you wish to change (for example, RMC to which to handover). You must then select Execute Handover ( F5 ) or send the CALL:HANDoff:TCReconfig[:IMMediate] command to initiate the reconfiguration.

Upon completion of the Transport Channel Reconfiguration (successful or not, and regardless of any errors), the handover settings are copied to their corresponding non-handover parameters (for example, the Channel Type setting is set to the value of the RB Test Mode TCR RAB setting).

Switching Between Symmetrical RMCs while on an RB Test Mode Connection

The Transport Channel Reconfiguration operation allows you to handover between Symmetrical RMCs while on a Radio Bearer Test Mode call. You must be on a (non-HSDPA/non-HSPA) RB test mode symmetrical RMC connection to perform a Transport Channel Reconfiguration between RMCs.

  • RB Test Mode TCR RAB

    This setting determines the symmetrical RMC the UE is instructed to use after completion of the Transport Channel Reconfiguration. See Channel Type for more information.

    GPIB command: CALL:SETup:TCReconfig:RBTest:RAB

Changing Parameters that Require Cell Off Operating Mode or Idle Connection Status while on a Connection

Some Cell Parameters and Uplink Parameters cannot be changed when in Active Cell Operating Mode or while on a connection. The Transport Channel Reconfiguration operation allows you to change some of the key cell and uplink settings while on a connection. The Transport Channel Reconfiguration also allows you to perform an inter-frequency hard handover.

You must be on an RB test mode symmetrical RMC connection (non-HSDPA, HSDPA or HSPA) to change these settings.

  • TCR Channel (UARFCN) State

    You can perform a hard handover (change UARFCNs) as part of the Transport Channel Reconfiguration. This allows you to perform a legal timing re-initialised handover (see RB setup Timing Indication (CFN Handling): and Current DPCH Offset for more details).

    When TCR Channel (UARFCN) State is set to On , TCR Downlink Channel (UARFCN) and TCR Uplink Channel (UARFCN) are signalled to the UE during the Transport Channel Reconfiguration if either differs from the current UARFCNs. When TCR Channel (UARFCN) State is set to Off , no UARFCN information is sent to the UE.

    GPIB command: CALL:HANDoff:TCReconfig:CHANnel:STATe

  • TCR Downlink Channel (UARFCN)

    This setting determines the downlink channel the UE is instructed to use after completion of the Transport Channel Reconfiguration. See DL Channel for more information.

    GPIB command: CALL:SETup:TCReconfig:CHANnel:DOWNlink

    This setting is only applicable when TCR Channel (UARFCN) State is set to On .

  • You can specify the handover uplink UARFCN in one of two ways:
    • TCR Uplink Channel (UARFCN)

      You can directly set the TCR Uplink Channel (UARFCN) setting to a specific uplink UARFCN value. The UE is instructed to use this uplink channel after completion of the Transport Channel Reconfiguration.

      GPIB command: CALL:SETup:TCReconfig:CHANnel:UPLink[:MCHannel]

      This setting is only applicable when TCR Channel (UARFCN) State is set to On .

    • Automatic handover uplink channel

      When TCR Uplink Channel is set to Auto , the handover uplink UARFCN is automatically determined by the TCR Downlink Channel (UARFCN) setting. The test set subtracts the frequency separation associated with the handover downlink channel's band from the TCR Downlink Channel (UARFCN) setting, and instructs the UE to use this uplink channel after completion of the Transport Channel Reconfiguration.

      GPIB command: CALL:SETup:TCReconfig:CHANnel:UPLink:CONTrol:AUTO

      This setting is only applicable when TCR Channel (UARFCN) State is set to On .

    See Uplink Channel for more information.

  • TCR Band Arbitrator

    When you set TCR Downlink Channel (UARFCN) to a value in Band VI, you must specify whether you want the test set to send a Band V or Band VI Frequency Band Indicator using the TCR Band Arbitrator setting. See Band Arbitrator for more information.

    GPIB command: CALL:SETup:TCReconfig:CHANnel:BARBitrator

  • TCR DPCH Bc/Bd Control

    This parameter selects whether the DPCH gain settings signalled to the UE during the Transport Channel Reconfiguration are set manually (using the TCR Manual Uplink DPCH Bc and TCR Manual Uplink DPCH Bd settings) or automatically by the test set (using the RB Test Mode TCR RAB setting). Note that configuring Bc and Bd such that neither is set to 15 is undefined in the standards, and may result in unexpected behavior. See Uplink DPCH Bc/Bd Control for more information about how the test set automatically determines the gain settings.

    You can query the beta c and beta d values that the test set will signal to the UE during the Transport Channel Reconfiguration using the CALL:STATus:SETup:TCReconfig:DPCHannel:CBETa? and CALL:STATus:SETup:TCReconfig:DPCHannel:DBETa? commands.

    GPIB command: CALL:SETup:TCReconfig:DPCHannel:BETA:AUTO

  • TCR Manual Uplink DPCH Bc

    When TCR DPCH Bc/Bd Control is set to Manual , this parameter controls the uplink DPCCH gain setting (beta c ) signalled to the UE during the Transport Channel Reconfiguration. Range is 1 to 15 (see 3GPP TS 25.213 s4.2.1.1 Table 1 for a mapping of the signalled values to the resulting quantized amplitude ratios).

    See Manual Uplink DPCH Bc for more information.

    GPIB command: CALL:SETup:TCReconfig:DPCHannel:MANual:CBETa

  • TCR Manual Uplink DPCH Bd

    When TCR DPCH Bc/Bd Control is set to Manual , this parameter controls the uplink DPDCH gain setting (beta d ) signalled to the UE during the Transport Channel Reconfiguration.

    See Manual Uplink DPCH Bd for more information.

    GPIB command: CALL:SETup:TCReconfig:DPCHannel:MANual:DBETa

  • TCR Timing Indication (CFN Handling)

    You can specify whether the UE should maintain or initialise its CFN counter when performing the Transport Channel Reconfiguration. See RB setup Timing Indication (CFN Handling): for additional details. Note that 3GPP 25.331 v5.17.0 s8.6.6.28 states that the UE's behavior is undefined if the network sets the Timing Indication IE to Initialise on a non-hard handover (i.e. where the UARFCNs and one or more Primary Scrambling Codes remain unchanged as part of the reconfiguration).

    • Auto: When TCR Timing Indication (CFN Handling) is set to Auto , the Timing Indication information element sent in the Transport Channel Reconfiguration message is set to Initialise if TCR Downlink Channel (UARFCN) and TCR Uplink Channel (UARFCN) are set such that a hard handover will occur (UARFCNs will change) or if TCR Default DPCH Offset (DOFF) is set to a value other than the Current DPCH Offset (this latter condition is to maintain backwards-compatibility with earlier releases). Otherwise, the Timing Indication information element sent in the Transport Channel Reconfiguration message is set to Maintain.
    • Initialise: the Timing Indication information element sent in the Transport Channel Reconfiguration message is set to Initialise.
    • Maintain: the Timing Indication information element sent in the Transport Channel Reconfiguration message is set to Maintain.

    GPIB command: CALL:HANDoff:TCReconfig:CFNHandling .

  • TCR Default DPCH Offset (DOFF)

    When TCR Timing Indication (CFN Handling) is set to Initialise , the test set includes both the Default DPCH Offset and DPCH Frame Offset information elements in the Transport Channel Reconfiguration message. Both information elements are sent with a value equal to the TCR Default DPCH Offset (DOFF) setting. Note, however, that the resolution of the Default DPCH Offset information element is 512 chips and the resolution of the DPCH Frame Offset information element is 256 chips. Thus, if TCR Default DPCH Offset (DOFF) is set to 3 x 512 chips, for example, then Default DPCH Offset is sent with a value of 3 (x 512 chips) and DPCH Frame Offset is sent with a value of 6 (x 256 chips). Thus, the TCR Default DPCH Offset (DOFF) setting can be used to change the DPCH Frame Offset (tau DPCH ) to 0, 1, ..., 75 x 512 chips while on a connection.

    The Current DPCH Offset result indicates the DPCH Frame Offset currently in use by the test set (for the current operating mode).

    Note, 3GPP TS 25.331 v5.17.0 s8.6.6.28 states that the timing re-initialized reconfiguration required to send the Default DPCH Offset IE must also include a change in UARFCN or Primary Scrambling Code, or the UE's behavior is undefined.

    GPIB command: CALL:SETup:TCReconfig:DPCHannel:DOFFset

  • TCR Relative DPCH Frame Offset

    When TCR Timing Indication (CFN Handling) is set to Maintain , the test set sends only the DPCH Frame Offset information element in the Transport Channel Reconfiguration message. The value of the DPCH Frame Offset information element is determined by the Current DPCH Offset and the TCR Relative DPCH Frame Offset setting. The TCR Relative DPCH Frame Offset setting can be used to change the current DPCH Frame Offset (tau DPCH ) by -256, 0 or +256 chips while on a connection.

    The Current DPCH Offset result indicates the DPCH Frame Offset currently in use by the test set (for the current operating mode).

    GPIB command: CALL:SETup:TCReconfig:DPCHannel:RFOFfset

  • RB Test Mode TCR Loopback Messaging State

    This parameter controls whether the UE loopback is opened and closed as part of a Transport Channel Reconfiguration procedure.

    • On - the test set will send an Open UE Test Loop message before sending the Transport Channel Reconfiguration message and a Close UE Test Loop message after receiving the Transport Channel Reconfiguration Complete message from the UE.
    • Off - the test set will not send any loopback control messages as part of the Transport Channel Reconfiguration procedure.

    GPIB command: CALL:HANDoff:TCReconfig:RBTest:LMESsaging:STATe

Changing HSPA Parameters that Require Idle Connection Status while on a Connection

This section is only applicable to the lab application or feature-licensed test application.

Some of the HSPA parameters cannot be changed while on a connection. The Transport Channel Reconfiguration operation allows you to change these parameters while on a connection.

You must be on an HSDPA or HSPA RB Test Mode connection to change these settings using a Transport Channel Reconfiguration.

  • TCR DeltaACK

    Controls the DeltaACK value signalled to the UE during the Transport Channel Reconfiguration.

    GPIB command: CALL:SETup:TCReconfig:UPLink:DACK

  • TCR DeltaNACK

    Controls the DeltaNACK value signalled to the UE during the Transport Channel Reconfiguration.

    GPIB command: CALL:SETup:TCReconfig:UPLink:DNACk

  • TCR DeltaCQI

    Controls the DeltaCQI value signalled to the UE during the Transport Channel Reconfiguration.

    GPIB command: CALL:SETup:TCReconfig:UPLink:DCQI

  • TCR Ack-Nack Repetition Factor

    Controls the Ack-Nack Repetition Factor value signalled to the UE during the Transport Channel Reconfiguration.

    GPIB command: CALL:SETup:TCReconfig:UPLink:ANACk:RFACtor

  • TCR CQI Feedback Cycle (k)

    Controls the CQI Feedback Cycle (k) value signalled to the UE during the Transport Channel Reconfiguration. TCR CQI Feedback Cycle (k) must be greater than or equal to TCR CQI Repetition Factor * 2ms (except for the case when TCR CQI Feedback Cycle (k) equals 0 ms).

    GPIB command: CALL:SETup:TCReconfig:UPLink:CQI:FCYCle

  • TCR CQI Repetition Factor

    Controls the CQI Repetition Factor value signalled to the UE during the Transport Channel Reconfiguration. TCR CQI Feedback Cycle (k) must be greater than or equal to TCR CQI Repetition Factor * 2ms (except for the case when TCR CQI Feedback Cycle (k) equals 0 ms).

    GPIB command: CALL:SETup:TCReconfig:UPLink:CQI:RFACtor

The following parameters are only available while on a User Defined HSDPA or HSPA RB Test Mode connection.

  • TCR Number of HARQ Processes

    Controls the User Defined Number of HARQ Processes value signalled to the UE during the Transport Channel Reconfiguration.

    GPIB command: CALL:SETup:TCReconfig:HARQ:PROCess:COUNt

  • TCR UE IR Buffer Allocation

    Controls the User Defined UE IR Buffer Allocation value signalled to the UE during the Transport Channel Reconfiguration.

    GPIB command: CALL:SETup:TCReconfig:MS:IREDundancy:BUFFer:ALLocation

  • TCR Explicit UE IR Buffer Size

    Controls the User Defined Explicit UE IR Buffer Size value signalled to the UE during the Transport Channel Reconfiguration.

    GPIB command: CALL:SETup:TCReconfig:MS:IREDundancy:BUFFer:SIZe[:EXPLicit]

    This setting is only applicable when TCR UE IR Buffer Allocation is set to Explicit .

  • TCR Measurement Power Offset

    Controls the Meas Pow Offset value signaled to the UE during the Transport Channel Reconfiguration.

    GPIB commands: CALL:SETup:TCReconfig:MPOWer[:MOFFset] , CALL:SETup:TCReconfig:MPOWer:OFFSet:CONTrol:AUTO , CALL:SETup:TCReconfig:MPOWer:OFFSet:MANual

The following parameters are only available while on an HSPA RB Test Mode connection:

  • TCR E-DPCCH/DPCCH Power Offset

    Controls the E-DPCCH/DPCCH Power Offset (DeltaE-DPCCH) signalled to the UE during the Transport Channel Reconfiguration.

    GPIB command: CALL:SETup:TCReconfig:EDPCchannel[:DPCChannel]:POFFset

  • TCR Reference E-TFCI Power Offsets

    Controls the Predefined Reference E-TFCI Power Offsets signalled to the UE during the Transport Channel Reconfiguration.

    GPIB command: CALL:SETup:TCReconfig:ETFCi:POFFsets:REFerence

  • TCR 16QAM State

    Controls whether the test set signals the UE to operate in UL 16QAM mode for E-DCH during Transport Channel Reconfiguration procedure.

    This parameter should be set while the HSPA call is setup and the E-DCH TTI is 2 ms .

    GPIB command: CALL:SETup:TCReconfig:EDCHannel:QAM16[:STATE]

  • TCR Absolute Grant

    Controls the serving grant that is signalled to the UE during the Transport Channel Reconfiguration. This serving grant is specified in terms of the 3GPP TS 25.321 s9.2.5.2.1.1 Scheduling Grant Table (and is not determined by the 3GPP TS 25.212 s4.10.1A.1 table that is used to communicate absolute grants on the E-AGCH). See Serving Grant for more information.

    Unlike the other Transport Channel Reconfiguration parameters, the value of this setting is not copied to any of the serving grant parameters (such as Single Shot AG or RB Setup AG ) upon completion of the Transport Channel Reconfiguration.

    GPIB command: CALL:SETup:TCReconfig:SGRant:ABSolute[:VALue]

  • TCR Absolute Grant (16QAM)

    Controls the serving grant that is signalled to the UE when the E-DCH TTI is 2 ms and the TCR 16QAM State is On . If any of the condition is not met, TCR Absolute Grant will be sent to the UE.

    GPIB command: CALL:SETup:TCReconfig:SGRant:ABSolute:QAM16[:VALue]

  • RB TCR E-DPDCH Max Channelisation Codes

    When the Channel Type is 12.2k RMC + HSPA , this parameter control the value of E-DPDCH Max Channelisation Codes that is signalled to the UE during Transport Channel Reconfiguration procedure.

    GPIB Command: CALL:SETup:TCReconfig:RBTest:EDPDchannel:CCODes:MAX[:HSPARMC12]

  • RB TCR E-DPDCH Max Channelisation Codes (HSPA Only)

    When the Channel Type is HSPA , this parameter control the value of E-DPDCH Max Channelisation Codes that is signalled to the UE during Transport Channel Reconfiguration procedure.

    GPIB Command: CALL:SETup:TCReconfig:RBTest:EDPDchannel:CCODes:MAX:HSPA

Transport Channel Reconfiguration Operating Considerations

  • The Transport Channel Reconfiguration operation in the test set includes opening and closing the UE test loop (see the Transport Channel Reconfiguration ladder diagram). After the Transport Channel Reconfiguration is executed:
    • If the test set does not receive the Open UE Test Loop Complete message from the UE within 6 seconds, an error is posted, but the test set continues the procedure.
    • If the test set does not receive the Transport Channel Reconfiguration Complete message from the UE within 6 seconds, an error is posted and the test set drops the connection (to avoid the test set and UE having different transport channel configurations).
    • If the test set does not receive the Close UE Test Loop Complete message from the UE within 6 seconds, an error is posted, and the test set ends the procedure.
  • In order for an inter-frequency hard handover to be successful, some UEs may require that you include the handover downlink channel in the SIB11 Inter-Freq Cell Info List (see Inter-frequency Cells ).
  • If the handover downlink and uplink channels result in an UL/DL offset of less than 30 MHz, the warning message "Performance not specified for UL/DL frequency offset <30 MHz" is issued.

System Handover

This functionality is only available in GSM/GPRS_W-CDMA fast switching test and lab applications.

The System Handover functionality allows you to handover to a GSM voice call from any of the following connection types:

  • AMR Setup
  • (non-HSDPA/non-HSPA) Radio Bearer Test Mode
  • HSDPA Radio Bearer Test Mode with CN Domain set to CS Domain ( lab application or feature licensed test application only )
  • HSPA Radio Bearer Test Mode ( lab application or feature licensed test application only )

You must be on one of these types of connections to perform a System Handover.

Before executing a System Handover you must specify the characteristics of the target GSM cell. You must also ensure that the GSM/GPRS format is set to Active Cell operating mode. You must then select Execute Handover ( F5 ) or send the CALL:HANDoff:SYSTem[:GSM][:IMMediate] command to initiate the handover.

Changing any of the GSM cell settings while operating in the W-CDMA format changes the corresponding parameter settings in the GSM/GPRS format of the fast switching application. Presetting the test set while operating in the W-CDMA format will not reset these parameters to their default settings. Presetting the test set while operating in the GSM/GPRS format will reset these parameters to their default values. When operating in the W-CDMA format, these settings are not saved when using the SAVE REGISTERS utility.

  • RB Test Mode to GSM Handover Alerting State
    • On: When this parameter is set to On , when performing a handover from (non-HSDPA) RB test mode to a GSM voice call, the UE will ring. You must answer the ring for the connection to be completed and testing to progress (note also that the fast switch between the two applications will not complete until you answer the ring).
      This occurs because the radio bearer test mode connection terminates in the Test Control (TC) protocol entity, rather than the Call Control (CC) protocol entity used for voice communication. Thus, the UE's CC entity is in the idle state. When the handover from RB test mode to GSM voice is executed, the test set first performs the handover in the RR Connected state. If RB Test Mode to GSM Handover Alerting State is set to On , the test set then continues to establish a CC Connection for voice service. As a result, once the test set and UE have transitioned to GSM service, the UE will alert. See System Handover from W-CDMA RB Test Mode to GSM Voice (with RB Test Mode to GSM Handover Alerting State = On) .
    • Off: When this parameter is set to Off , when performing a handover from (non-HSDPA) RB test mode to a GSM voice call, the UE will not ring. When the handover is completed, the connection is left in the RR Connected state. Data loopback (for BER testing) is available in this state, but voice echo is not. See System Handover from W-CDMA RB Test Mode to GSM Voice (with RB Test Mode to GSM Handover Alerting State = Off) .

    GPIB command: CALL:SETup:SYSTem:GSM:ALERting[:STATe] .

  • Wait for RLC Ack of Handover From UTRAN

    This parameter controls whether the test set waits for the UE to confirm reception of the Handover From UTRAN Command message before initiating the fast switch to the GSM/GPRS/EGPRS format (see Handover Ladder Diagrams ) or whether it switches immediately upon sending the Handover From UTRAN Command message. By default, the test set does not initiate the switch from the W-CDMA to GSM/GPRS/EGPRS application until it receives an RLC Ack confirming reception of the Handover From UTRAN Command message. To shorten the handover time, some UEs do not send any W-CDMA layer 2 acknowledgments for the handover command. If your UE does not acknowledge the Handover From UTRAN command, you must set Wait for RLC Ack of Handover From UTRAN to Off . Otherwise, the test set will not continue with the handover until it receives the expected acknowledgment, and the handover will fail.

    Setting Wait for RLC Ack of Handover From UTRAN to Off speeds up the System Handover, but is a less robust handover method.

    GPIB command: CALL:HANDoff:SYSTem[:GSM]RLCack:WAIT[:STATe]

  • GSM BCC (Base Station Color Code): See

    CALL[:CELL]:BCCode

    Note, you MUST include the mnemonic :GSM at the end of this command, i.e. you must issue the command as CALL:BCCode:GSM.

  • GSM NCC (Network Color Code): See

    CALL[:CELL]:NCCode

    Note, you MUST include the mnemonic :GSM at the end of this command, i.e. you must issue the command as CALL:NCCode:GSM.

  • GSM Cell Band: See

    CALL[:CELL]:BAND

    Note, you MUST include the mnemonic :GSM at the end of this command, i.e. you must issue the command as CALL:BAND:GSM.

  • GSM Broadcast Chan: See

    CALL:BCHannel[:ARFCn]

    Note, you MUST include the mnemonic :GSM at the end of this command, i.e. you must issue the command as CALL:BCHannel[:ARFCn]:GSM.

  • GSM Traffic Band: See

    CALL:TCHannel:BAND

  • GSM Traffic Channel: See

    CALL:TCHannel[:ARFCn]

  • GSM TCH Timeslot: See

    CALL:TCHannel:TSLot

  • GSM Logical Speech Channel: See

    CALL:TCHannel:CMODe:LSPeech:CHANnel

  • GSM Half Rate Speech Sub Channel: See

    CALL:TCHannel:CMODe:HRSPeech:SCHannel

  • GSM MS TX Level: See

    CALL:MS:TXLevel

Soft Handover

This functionality is only available in the lab application. See Soft Handover .

Radio Bearer Reconfiguration

This section is only applicable to the lab application or feature-licensed test application.

The Radio Bearer Reconfiguration allows you to handover from a CS Domain or CS/PS Domain HSDPA RB Test Mode connection or HSPA RB Test Mode connection to a (non-HSDPA/non-HSPA) symmetrical RMC. See CN Domain and the following ladder diagram: Radio Bearer Reconfiguration from CS Domain or CS/PS Domain HSDPA RB Test Mode Connection or HSPA RB Test Mode Connection . The Radio Bearer Reconfiguration also allows you to change many other parameters as part of the reconfiguration.

Before executing the Radio Bearer Reconfiguration, you must specify to which symmetrical RMC you wish to handover, and set any other reconfiguration parameters as desired. You must then select Execute Handover ( F5 ) or send the CALL:HANDoff:RBReconfig[:IMMediate] command to initiate the reconfiguration.

Upon completion of the Radio Bearer Reconfiguration (successful or not, and regardless of any errors), the handover settings are copied to their corresponding non-handover parameters (for example, the Channel Type setting is set to the value of the RB Test Mode RBR RAB setting).

  • RB Test Mode RBR RAB

    This setting determines the (non-HSDPA) symmetrical RMC the UE is instructed to use after completion of the Radio Bearer Reconfiguration. See Channel Type for more information.

    GPIB command: CALL:SETup:RBReconfig:RBTest:RAB

  • RBR Channel (UARFCN) State

    You can perform a hard handover (change UARFCNs) as part of the Radio Bearer Reconfiguration. The change in UARFCNs is performed as part of the RB Setup portion of the procedure (see Radio Bearer Reconfiguration from CS Domain or CS/PS Domain HSDPA RB Test Mode Connection or HSPA RB Test Mode Connection ). This allows you to perform a legal timing re-initialised handover (see RB setup Timing Indication (CFN Handling): and Current DPCH Offset for more details).

    When RBR Channel (UARFCN) State is set to On , RBR Downlink Channel (UARFCN) and RBR Uplink Channel (UARFCN) are signalled to the UE during the Radio Bearer Reconfiguration if either differs from the current UARFCNs. When RBR Channel (UARFCN) State is set to Off , no UARFCN information is sent to the UE.

    GPIB command: CALL:HANDoff:RBReconfig:CHANnel:STATe

  • RBR Downlink Channel (UARFCN)

    This setting determines the downlink channel the UE is instructed to use after completion of the Radio Bearer Reconfiguration. See DL Channel for more information.

    GPIB command: CALL:SETup:RBReconfig:CHANnel:DOWNlink

    This setting is only applicable when RBR Channel (UARFCN) State is set to On .

  • You can specify the handover uplink UARFCN in one of two ways:
    • RBR Uplink Channel (UARFCN)

      You can directly set the RBR Uplink Channel (UARFCN) setting to a specific uplink UARFCN value. The UE is instructed to use this uplink channel after completion of the Radio Bearer Reconfiguration.

      GPIB command: CALL:SETup:RBReconfig:CHANnel:UPLink[:MCHannel]

      This setting is only applicable when RBR Channel (UARFCN) State is set to On .

    • Automatic handover uplink channel

      When RBR Uplink Channel is set to Auto , the handover uplink UARFCN is automatically determined by the RBR Downlink Channel (UARFCN) setting. The test set subtracts the frequency separation associated with the handover downlink channel's band from the RBR Downlink Channel (UARFCN) setting, and instructs the UE to use this uplink channel after completion of the Radio Bearer Reconfiguration.

      GPIB command: CALL:SETup:RBReconfig:CHANnel:UPLink:CONTrol:AUTO

      This setting is only applicable when RBR Channel (UARFCN) State is set to On .

    See Uplink Channel for more information.

  • RBR Band Arbitrator

    When you set RBR Downlink Channel (UARFCN) to a value in Band VI, you must specify whether you want the test set to send a Band V or Band VI Frequency Band Indicator using the RBR Band Arbitrator setting. See Band Arbitrator for more information.

    GPIB command: CALL:SETup:RBReconfig:CHANnel:BARBitrator

  • RBR Uplink DTCH RMC CRC Presence

    This setting determines the Uplink DTCH RMC CRC Presence state the UE is instructed to use after completion of the Radio Bearer Reconfiguration.

    GPIB command: CALL:SETup:RBReconfig:DTCHannel:CRC[:PRESence]

  • RBR UE Loopback Type

    This setting determines the UE Loopback Type the UE is instructed to use after completion of the Radio Bearer Reconfiguration.

    GPIB command: CALL:SETup:RBReconfig:MS:LOOPback:TYPE

  • RBR Uplink Dummy DCCH Data

    This setting determines the Uplink Dummy DCCH Data state the UE is instructed to use after completion of the Radio Bearer Reconfiguration.

    GPIB command: CALL:SETup:RBReconfig:UPLink:DCCHannel:DDATa

  • RBR Uplink DPCH Bc/Bd Control

    This parameter selects whether the DPCH gain settings signalled to the UE during the Radio Bearer Reconfiguration are set manually (using the RBR Manual Uplink DPCH Bc and RBR Manual Uplink DPCH Bd settings) or automatically by the test set (using the RB Test Mode RBR RAB setting). Note that configuring Bc and Bd such that neither is set to 15 is undefined in the standards, and may result in unexpected behavior. See Uplink DPCH Bc/Bd Control for more information about how the test set automatically determines the gain settings.

    GPIB command: CALL:SETup:RBReconfig:DPCHannel:BETA:AUTO

  • RBR Manual Uplink DPCH Bc

    When RBR Uplink DPCH Bc/Bd Control is set to Manual , this parameter controls the uplink DPCCH gain setting (beta c ) signalled to the UE during the Radio Bearer Reconfiguration. Range is 1 to 15 (see 3GPP TS 25.213 s4.2.1.1 Table 1 for a mapping of the signalled values to the resulting quantized amplitude ratios).

    See Manual Uplink DPCH Bc for more information.

    GPIB command: CALL:SETup:RBReconfig:DPCHannel:MANual:CBETa

  • RBR Manual Uplink DPCH Bd

    When RBR Uplink DPCH Bc/Bd Control is set to Manual , this parameter controls the uplink DPDCH gain setting (beta d ) signalled to the UE during the Radio Bearer Reconfiguration. See Manual Uplink DPCH Bd for more information.

    GPIB command: CALL:SETup:RBReconfig:DPCHannel:MANual:DBETa

  • RBR Timing Indication (CFN Handling)

    You can specify whether the UE should maintain or initialise its CFN counter when performing the Radio Bearer Reconfiguration. See RB setup Timing Indication (CFN Handling): for additional details. Note that 3GPP 25.331 v5.17.0 s8.6.6.28 states that the UE's behavior is undefined if the network sets the Timing Indication IE to Initialise on a non-hard handover (i.e. where the UARFCNs and one or more Primary Scrambling Codes remain unchanged as part of the reconfiguration).

    • Auto: When RBR Timing Indication (CFN Handling) is set to Auto , the Timing Indication information element sent in the RB Setup message (sent as part of the Radio Bearer Reconfiguration) is set to Initialise if RBR Downlink Channel (UARFCN) and RBR Uplink Channel (UARFCN) are set such that a hard handover will occur (UARFCNs will change) or if RBR Default DPCH Offset (DOFF) is set to a value other than the Current DPCH Offset (this latter condition is to maintain backwards-compatibility with earlier releases). Otherwise, the Timing Indication information element sent in the RB Setup message (sent as part of the Radio Bearer Reconfiguration) is set to Maintain.
    • Initialise: the Timing Indication information element sent in the RB Setup message (sent as part of the Radio Bearer Reconfiguration) is set to Initialise.
    • Maintain: the Timing Indication information element sent in the RB Setup message (sent as part of the Radio Bearer Reconfiguration) is set to Maintain.

    A timing-maintained Radio Bearer Reconfiguration cannot be performed when compressed mode is enabled.

    GPIB command: CALL:HANDoff:RBReconfig:CFNHandling

  • RBR Default DPCH Offset (DOFF)

    When RBR Timing Indication (CFN Handling) is set to Initialise , the test set includes both the Default DPCH Offset and DPCH Frame Offset information elements in the RB Setup message sent as part of the Radio Bearer Reconfiguration. Both information elements are sent with a value equal to the RBR Default DPCH Offset (DOFF) setting. Note, however, that the resolution of the Default DPCH Offset information element is 512 chips and the resolution of the DPCH Frame Offset information element is 256 chips. Thus, if RBR Default DPCH Offset (DOFF) is set to 3 x 512 chips, for example, then Default DPCH Offset is sent with a value of 3 (x 512 chips) and DPCH Frame Offset is sent with a value of 6 (x 256 chips). Thus, the RBR Default DPCH Offset (DOFF) setting can be used to change the DPCH Frame Offset (tau DPCH ) to 0, 1, ..., 75 x 512 chips (or 0, 2, 4, ..., 150 x 256 chips) while on a connection.

    The Current DPCH Offset result indicates the DPCH Frame Offset currently in use by the test set (for the current operating mode).

    Note, 3GPP TS 25.331 v5.17.0 s8.6.6.28 states that the timing re-initialized reconfiguration required to send the Default DPCH Offset IE must also include a change in UARFCN or Primary Scrambling Code, or the UE's behavior is undefined.

    GPIB command: CALL:SETup:RBReconfig:DPCHannel:DOFFset

  • RBR Relative DPCH Frame Offset

    When RBR Timing Indication (CFN Handling) is set to Maintain , the test set sends only the DPCH Frame Offset information element in the RB Setup message sent as part of the Radio Bearer Reconfiguration. The value of the DPCH Frame Offset information element is determined by the Current DPCH Offset and the RBR Relative DPCH Frame Offset setting. The RBR Relative DPCH Frame Offset setting can be used to change the current DPCH Frame Offset (tau DPCH ) by -256, 0 or +256 chips while on a connection.

    The Current DPCH Offset result indicates the DPCH Frame Offset currently in use by the test set (for the current operating mode).

    GPIB command: CALL:SETup:RBReconfig:DPCHannel:RFOFfset

Radio Bearer Reconfiguration Operating Considerations

  • The Radio Bearer Reconfiguration operation in the test set includes opening and closing the UE test loop (see the Radio Bearer Reconfiguration from CS Domain or CS/PS Domain HSDPA RB Test Mode Connection or HSPA RB Test Mode Connection ladder diagram). After the Radio Bearer Reconfiguration is executed:
    • If the test set does not receive the Open UE Test Loop Complete message from the UE within 6 seconds, an error is posted, but the test set continues the procedure.
    • If the test set does not receive the Radio Bearer Release Complete message from the UE within 6 seconds, an error is posted, but the test set continues the procedure. Note that it is possible that the UE and test set may be in different channel configurations if this error occurs.
    • If the test set does not receive the Radio Bearer Setup Complete message from the UE within 6 seconds, an error is posted, but the test set continues the procedure. Note that it is possible that the UE and test set may be in different channel configurations if this error occurs.
    • If the test set does not receive the Close UE Test Loop Complete message from the UE within 6 seconds, an error is posted, and the test set ends the procedure.
  • In order for an inter-frequency hard handover to be successful, some UEs may require that you include the handover downlink channel in the SIB11 Inter-Freq Cell Info List (see Inter-frequency Cells ).
  • If the handover downlink and uplink channels result in an UL/DL offset of less than 30 MHz, the warning message "Performance not specified for UL/DL frequency offset <30 MHz" is issued.

External 8960 Handover

This section is only applicable to the lab application.

You can connect two test sets using an External Device Connection to create a Two-Cell Test System for testing your UE's ability to transition between cells while in idle mode and while actively transferring data.

You must have an External Device Connection between the two test sets to perform the Execute External 8960 Handover immediate action. Also, your UE must have an active PDP context (or simply be attached if your test set is emulating a GSM/GPRS/EGPRS cell), or be actively transferring data (voice, PS data, HSDPA, etc.) before initiating the external 8960 handover.

When the Execute External 8960 Handover action is performed, the originating test set queries the configuration of the destination test set to determine what type of handover/cell reselection to order. Note that while strictly speaking, a handover is the process by which a mobile transitions from one cell to another while maintaining a circuit-switched call, the same Execute External 8960 Handover action is used both to initiate a handover and to perform a network-initiated cell reselection, depending upon the configuration of the two test sets and the UE's current connection state.

Note that the contents of the Handover command (circuit-switched connections) or Cell Change Order (packet-switched connections) sent by the originating test set during an external 8960 handover are not based on the information in its neighbor cell lists; it is strictly based on the configuration of the destination test set. However, it is recommended that you configure the
SIB11 Cell Info List
 to contain the other test set's information. This enables the mobile to measure the other test set before transitioning to it (some mobiles will not perform a "blind" handover) and allows you to view the mobile's measurement reports for the test set.

See
Two-Cell Test System
 for more information on the external 8960 handover.

When performing a circuit-switched handover, you can specify the following setting in the Handover from UTRAN message:

  •

Activation Time

This parameter allows you to set the Activation Time that is signaled to the UE in the Handover from UTRAN message (see 3GPP TS 25.331 s10.3.3.1). Activation Time controls the frame number at which the operation caused by the related message shall take effect (in other words, how long the UE should wait before performing the handover). It can be set between 0 and 255, and indicates the absolute value of the CFN (Connection Frame Number) at which the UE should perform the handover. If set to 0, the Activation Time IE is not sent in the Handover from UTRAN message.

GPIB command:
CALL:HANDoff:EXTernal:ATIMe

This parameter can only be changed when connection status is idle.

    •

External PS Handover

This section is only applicable to the lab application.

You can use the test set as a WCDMA network simulator to test the WCDMA/LTE Packet Switched (PS) handover capabilities of your UE, by setting up a connection between the test set and the Agilent E6621A PXT. See
E-UTRAN / WCDMA Interworking
 on how to set up the connections.

See
SIB19 Information
on how to set up the inter-RAT frequency and priority information.

PS Handovers requires the target cell to setup dedicated resources for an incoming UE. The source cell queries the target cell for the resources, and then communicate them to the UE to access the target cell. This bypasses the RRC connection setup procedure, hence minimize the data flow interruptions.The test set supports two types of PS handover:

  •
Inbound handover is for the UE at another RAT to move to WCDMA.
    •

  •

Outbound handover, on the other hand, is for the UE in a WCDMA cell to move to another RAT. Outbound handover can only be initiated by the test set, and is restricted to handover from LTE.
    •

For external PS handover, the parameters and actions available to you include:

  •

Setup Inbound

This action causes the test set into a "handover" state. The test set sets up dedicated resources and prepares for the UE's handover from another RAT. The dedicated channels are setup according to the general system settings, and as per the information queried via the external EPC.

During the "handover" state, the content of the
HANDOVER TO UTRAN COMMAND
 message (ACSII hex string) can be queried by
CALL:HANDoff:PS:INBound:HOCommand?
 (GPIB command only).

The test set remains in the "handover" state until an
Abort Inbound
 or preset occurs, or a successful handover.

GPIB Command:
CALL:HANDoff:PS:INBound[:IMMediate]

    •

  •

Abort Inbound

This immediate action aborts the pending inbound PS handover event.

GPIB Command:
CALL:HANDoff:PS:INBound:ABORt

    •

  •

Outbound PS Handover

    •

Activation Time

This parameter specifies the time delay (in frames) from issuing the outbound handover command to the handover actually taking effect. If this value is set to
0
, the outbound PS handover takes effect immediately.

GPIB Command:
CALL:HANDoff:PS:OUTBound:ATIMe

      •

    •

Execute Handover

Issues the
HANDOVER FROM UTRAN COMMAND
 command to the UE. You must use the
CALL:HANDoff:PS:OUTBound:TMessage
 command to set up the
HANDOVER FROM UTRAN COMMAND
 message before attempting to execute the handover (This is a GPIB command only).

GPIB Command:
CALL:HANDoff:PS:OUTBound[:IMMediate]

      •

    •

Related Topics

How Do I Perform a Handover?

Step 6: Reconfigure Test Set and UE Connection Parameters

CALL:SETup

CALL:HANDoff

Channel (UARFCN) Information

Handover Ladder Diagrams

Troubleshooting Handovers


Call Processing Status

Call Processing Status

Last updated: January 15, 2009

  • Call Processing Status
  • Active Cell Connection State
    • Call Connection State
    • Data Connection State ( lab application only )

Call Processing Status

The Call Processing Status window on the Call Setup screen displays the following information when in Active Cell Operating Mode :

  • RRC State

    This functionality is present in the lab application only.

    RRC State indicates whether the RB Test Mode service has set the UE up into a CELL_FACH or CELL_DCH state, or is Idle . See RB Test Mode RRC State Setting and Radio Bearer Test Mode Origination to CELL_FACH .

    GPIB command: CALL:STATus:RRC:STATe? .

  • MM Status

    MM Status indicates whether the UE has registered, and what type of registration (Location Updating procedure) was last performed (see Performing a Location Update (CS Domain Registration) ). When the UE registers with the network, its Location Updating Request message includes a Location Updating Type information element that can have a value of "Normal location updating", "Periodic updating" or "IMSI attach" (see 3GPP TS 24.008 s4.4.1, s9.2.15 and s10.5.3.5).

    • Updated (normal) : Indicates that the last Location Updating procedure was of the type "Normal location updating". Normal location updating is used to update the network with the actual Location Area of a UE (for example when the UE enters a new location area).
    • Updated (periodic) : Indicates that the last Location Updating procedure was of the type "Periodic updating" (the UE performed a timer-based registration). Periodic updating is used to notify periodically the availability of the UE to the network. The procedure is controlled by the T3212 Periodic Location Update Timer .
    • IMSI Attached : Indicates that the last Location Updating procedure was of the type "IMSI attach" (the UE performed a power-up registration). The IMSI attach procedure is used to indicate the IMSI as active in the network.
    • IMSI Detached : Indicates that the UE sent an IMSI Detach Indication message to the test set (the UE performed a power-down registration). This occurs when the UE was IMSI Attached and then was powered down or its USIM was removed.
    • None : The UE has not registered with the test set ( MM Status is also set to None when you clear the UE information (see Clear UE Info ).

    GPIB command: CALL:STATus:MM? .

  • GMM State

    GMM State indicates the result of the most recent GPRS attach or detach. It is set to Attached when the UE has successfully completed the GPRS Attach procedure and Detached on completion of the GPRS Detach procedure. If the UE sends the test set an Attach Request but never responds to the Attach Accept with an Attach Complete, then it is set to Attach Incomplete . GMM state is cleared when you clear the UE information (see Clear UE Info ) and is set to None on power up and preset.

    See Packet Switched Data .

    GPIB command: CALL:STATus[:GMM]:ATTached:STATe? .

  • Soft Handover State

    This functionality is present in the lab application only. See Soft Handover .

    GPIB command: CALL:STATus:SHANdoff:STATe? .

  • Compressed Mode State

    This functionality is present in the lab application only. See Compressed Mode .

    GPIB command: CALL:STATus:COMPressed:STATe? .

  • Current DPCH Offset

    Current DPCH Offset reports the DPCH Frame Offset (tau DPCH ) currently in use by the test set (for the current operating mode).

    DPCH Frame Offset is the offset of the DL DPCH to the P-CCPCH (see 3GPP TS 25.331 s10.3.6.21 and 25.211 Figure 29). 3GPP prescribes several rules around changing DPCH Frame Offset, which can be changed using the Default DPCH Offset IE (which has a resolution of 512 chips) or the DPCH Frame Offset IE (which has a resolution of 256 chips).

    Per 3GPP, during a timing re-initialized reconfiguration (Timing Indication IE = Initialise), the Default DPCH Offset IE and DPCH Frame Offset IE in the reconfiguration message must be set to the same value. This means the resolution of the timing adjustment on a timing re-initialized reconfiguration is 512 chips. See 3GPP TS 25.331 s8.3.5.1.2.

    Per 3GPP, during a timing maintained reconfiguration (Timing Indication IE = Maintain), the reconfiguration message must not include a Default DPCH Offset IE; only the DPCH Frame Offset IE is signalled. However, if the UE is ordered to adjust its timing by more than 256 chips, then it will reject the reconfiguration. This means the resolution of the timing adjustment on a timing maintained reconfiguration is 256 chips, but the maximum timing change is 256 chips. See 3GPP TS 25.331 s8.2.2.3.

    Per 3GPP, there is a further constraint on when DPCH Frame Offset can be changed. According to 3GPP 25.331 v5.17.0 s8.6.6.28, timing re-initialized reconfigurations are intended to be exclusively used for hard handovers (i.e. where the UE changes UARFCNs and/or all Primary Scrambling Codes for all links in the active set as part of the reconfiguration, see 3GPP TS 25.331 v5.17.0 s8.6.6.3a). 25.331 states that the UE's behavior is undefined if the network sets the Timing Indication IE to Initialise on a non-hard handover (i.e. where the UARFCNs and one or more Primary Scrambling Codes remain unchanged as part of the reconfiguration). Therefore, to change DPCH Frame Offset using the Default DPCH Offset IE (i.e. to a value of 0, 1, 2, 3, 4, or 5 x 512 chips), you must also change UARFCNs or Primary Scrambling Codes during the reconfiguration.

    In active cell operating mode, the test set can signal the DPCH Frame Offset to the UE in one of two ways:

    • During call establishment, using the Default DPCH Offset (DOFF) setting: Sets DPCH Frame Offset to 0, 1, 2, 3, 4 or 5 x 512 chips during call establishment (you cannot change the Default DPCH Offset (DOFF) setting while on a connection, you must set it before establishing the connection).
    • While on a connection, using the following settings:
      • RBR or TCR Default DPCH Offset (DOFF) : Sets DPCH Frame Offset to 0, 1, 2, 3, 4 or 5 x 512 chips while on a connection (using a Radio Bearer Reconfiguration or Transport Channel Reconfiguration, respectively). Note, 3GPP TS 25.331 v5.17.0 s8.6.6.28 states that the timing re-initialized reconfiguration required to send the Default DPCH Offset IE must also include a change in UARFCN or Primary Scrambling Code, or the UE's behavior is undefined. Both the Radio Bearer Reconfiguration and Transport Channel Reconfiguration can be used to change UARFCNs.
      • RBR or TCR Relative DPCH Frame Offset : Changes the current DPCH Frame Offset by -256, 0 or +256 chips while on a connection (using a Radio Bearer Reconfiguration or Transport Channel Reconfiguration, respectively).

    In FDD test operating mode, you can set DPCH Frame Offset to 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, or 10 x 256 chips using the DPCH Frame Offset setting. Note, you must then also set this DPCH Frame Offset in the UE so that it can successfully decode the test set's signal; the test set does not provide any signalling to the UE in FDD Test Operating Mode and thus will not signal the DPCH Frame Offset setting to the UE. Current DPCH Offset is not displayed on the front panel screen while in FDD test operating mode because in FDD test operating mode, Current DPCH Offset is always equal to the DPCH Frame Offset setting.

    In active cell operating mode, if a DL DPCH is not active, Current DPCH Offset simply reflects the value of the Default DPCH Offset (DOFF) setting.

    GPIB command: CALL:STATus:DPCHannel:OFFSet?

    Implications of the Current DPCH Offset

    The UL DPCH is always transmitted 1024 chips after the DL DPCH. Thus, changing DPCH Frame Offset, which offsets the DL DPCH from the P-CCPCH, changes the offset between the UL DPCH and P-CCPCH by the same amount.

    When on an HSDPA or HSPA connection (lab application or feature licensed test application only) , changing the DPCH Frame Offset results in a change in the offset between the UL DPCH and HS-DPCCH, because the HS-DPCCH is always transmitted 12.5 slots after the start of the HS-SCCH (which is always aligned to the P-CCPCH). In other words, changing the DPCH Frame Offset shifts the UL DPCH's position in time relative to the HS-DPCCH.

    The following table indicates the time offset present between the HS-DPCCH and UL DPCH for the various DPCH Frame Offset values available in the test set.

    HS-DPCCH/DPCCH Alignment vs. DPCH Frame Offset

    DPCH Frame Offset

             HS-DPCCH to UL DPCH Alignment

    0 chips = 0 x 256 chips = 0 x 512 chips

    +0.1 slot (the HS-DPCCH slot boundary occurs
    66.7 us/256 chips after the UL DPCH slot boundary)

    256 chips = 1 x 256 chips

    0.0 slot (the HS-DPCCH and UL DPCH slot boundaries
    are aligned)

    512 chips = 2 x 256 chips = 1 x 512 chips

    -0.1 slot (the HS-DPCCH slot boundary occurs
    66.7 us/256 chips before the UL DPCH slot boundary)
    768 chips = 3 x 256 chips

    -0.2 slot (the HS-DPCCH slot boundary occurs
    133.3 us/512 chips before the UL DPCH slot boundary)
    1024 chips = 4 x 256 chips = 2 x 512 chips

    -0.3 slot (the HS-DPCCH slot boundary occurs
    200 us/768 chips before the UL DPCH slot boundary)
    1280 chips = 5 x 256 chips

    -0.4 slot (the HS-DPCCH slot boundary occurs
    266.7 us/1024 chips before the UL DPCH slot boundary)
    1536 chips = 6 x 256 chips = 3 x 512 chips

    -0.5 slot (the HS-DPCCH slot boundary occurs
    333.3 us/1280 chips before the UL DPCH slot boundary)
    1792 chips = 7 x 256 chips

    -0.6 slot (the HS-DPCCH slot boundary occurs
    400 us/1536 chips before the UL DPCH slot boundary)
    2048 chips = 8 x 256 chips = 4 x 512 chips

    -0.7 slot (the HS-DPCCH slot boundary occurs
    466.7 us/1792 chips before the UL DPCH slot boundary)
    2304 chips = 9 x 256 chips

    -0.8 slot (the HS-DPCCH slot boundary occurs
    533.3 us/2048 chips before the UL DPCH slot boundary)
    2560 chips = 10 x 256 chips = 5 x 512 chips

    -0.9 slot (the HS-DPCCH slot boundary occurs
    600 us/2304 chips before the UL DPCH slot boundary)

Active Cell Connection State

Additional call processing state information is also displayed in the small Active Cell window at the bottom of the Call Setup screen. Note that for single services, the respective Call Connection State or Data Connection State is displayed. When Simultaneous Services is active the Active Cell window displays both the call connection state and the data connection state (in that order) separated by a "/".

Call Connection State

The call connection state can transition between the following states:

  • Alerting (CALL)

    Alerting is returned when the test set is alerting the UE to an incoming AMR voice call request.

  • Connected (CONN)

    Connected is returned when the test set and UE are connected on a call.

  • Handoff (HAND)

    Handoff is returned when the test set is in the process of handing off the UE.

  • Idle (IDLE)

    Idle is returned when the test set is not on a call.

  • Paging (PAG)

    Paging is returned when the test set is in the process of paging the UE.

  • Registering (REG)

    Registering is returned when the test set is in the process of performing a registration with the UE.

  • Releasing (REL)

    Releasing is returned when the test set is in the process of releasing the UE from a call using over the air signalling as part of a UE or test set originated release procedure.

  • Setup Request (SREQ)

    Setup Request is returned when the test set is in the process of assigning a channel to the UE as part of a page or a UE-originated call setup.

GPIB commands: CALL:STATus[:STATe][:VOICe]? and CALL:CONNected[:STATe]

Data Connection State

The data connection state can transition between the following states:

  • Idle (IDLE)
  • Attaching (ATTG)
  • Detaching (DET)
  • Off (OFF) - state when the test set powers up or is preset
  • PDP Activating (PDPAG)
  • PDP Active (PDP)

    See Activate PDP Context Reject .

  • PDP Deactivating (PDPD)

GPIB command: CALL:STATus[:STATe]:DATA?

Related Topics

CALL:STATus


Call Processing Ladder Diagrams

Call Processing Ladder Diagrams

Last updated: January 15, 2009

The following diagrams illustrate the procedures used by the test set for several key call processing operations.

  • RRC Connection Setup Procedure
  • Location Update (Registration) Procedure
  • Paging Procedure
  • Radio Bearer Test Mode Origination to CELL_DCH - CS Domain (Non-HSPA or HSDPA)
  • Radio Bearer Test Mode Origination to CELL_DCH - PS Domain (HSDPA) ( lab application or feature-licensed test application only )
  • Radio Bearer Test Mode Origination to CELL_DCH - CS/PS Domain (HSDPA or HSPA) ( lab application or feature-licensed test application only )
  • Radio Bearer Test Mode Origination to CELL_FACH ( lab application only )
  • BS Release from Radio Bearer Test Mode in CELL_DCH
  • BS Release from Radio Bearer Test Mode in CELL_FACH ( lab application only )

RRC Connection Setup Procedure

Location Update (Registration) Procedure

Paging Procedure

Radio Bearer Test Mode Origination to CELL_DCH - CS Domain (Non-HSPA or HSDPA)

See 3GPP TS 34.108 s7.3.2.3 "For UE supporting CS"

Radio Bearer Test Mode Origination to CELL_DCH - PS Domain (HSDPA)

See 3GPP TS 34.108 s7.3.2.3 "For UE supporting PS only"

Radio Bearer Test Mode Origination to CELL_DCH - CS/PS Domain (HSDPA or HSPA)

Radio Bearer Test Mode Origination to CELL_FACH

BS Release from Radio Bearer Test Mode in CELL_DCH

BS Release from Radio Bearer Test Mode in CELL_FACH

Related Topics

W-CDMA Concepts


Performing a Location Update (CS Domain Registration)

Performing a Location Update (CS Domain Registration)

Last updated: January 15, 2009

NOTE
The Call Limit State must be OFF for any random access procedure, such as Location Update or test set origination (Paging), to be successful.

Once the UE has camped on a cell it decides whether or not it needs to register with the network. If the ATT (IMSI Attach) Flag State is Set , the UE will always register. If the ATT (IMSI Attach) Flag State is Not Set , then the UE will only register when it determines that it has camped on a new cell. The UE uses the Mobile Network Code (MNC) , Mobile Country Code (MCC) , and Local Area Code (LAC) broadcast by the cell to determine if the cell is new.

The UE registers by performing a Location Update Procedure (see Location Update (Registration) Procedure and 3GPP TS 24.008 s4.4.1). MM Status indicates whether the UE has registered, and what type of registration was last performed.

You can control how often the UE performs the periodic location update procedure using the T3212 Periodic Location Update Timer .

During registration the UE informs the network of its identity. The UE's identity consists of its IMSI and IMEI . The UE can then be paged using its IMSI (see Test Set-Originated Connection ).

The UE can also be paged using a TMSI if one has been assigned to it during the Location Update (Registration) Procedure . If you set TMSI Assignment to On , the test set assigns the UE a TMSI in the Location Updating Accept message. If you do not plan to page the UE using a TMSI, it is recommended that you leave TMSI Assignment set to Off so that the Location Update procedure executes as quickly as possible (if TMSI Assignment is On , the UE must send a TMSI Reallocation Complete message).

You can specify whether or not to perform security operations during UE registration. See Security Information .

When registration has completed, the UE Information window displays the registration data received from the UE, such as its power class, IMSI, and IMEI.

You can specify whether the UE can also register in the PS domain ( GPRS Attach ) using the PS Domain Information setting.

Related Topics

CALL:PAGing


Real-Time Vocoder

Real-Time Vocoder

Last updated: October 26, 2010

This section is only applicable to the lab applications and the test application with a required feature license.

  • Overview
  • Setting Real-Time Vocoder Parameters
  • Real-Time Vocoder Headroom Information
  • Operating Consideration

Overview

The real-time vocoder allows you to perform the audio test in two aspects:

  • Perform the functional test for the analog voice capability of the mobile station.
  • Calculate the audio input gain, audio output gain and internal codec loopback gain of the Test Set, which help you to perform the acoustic measurement in 3GPP TS 26.131 and TS 26.132

Real-Time Encoding and Decoding

The real-time vocoder functionality allows you to perform the functional test for the analog voice capability of the mobile station when the Operating Mode of the real-time vocoder is set to Normal :

  • the test set can real-timely encode the analog audio signal applied at the test set's AUDIO IN connector using the appropriate vocoder algorithm (depending upon the selected voice service option) and then sends the encoded audio frames to the mobile station. See A Simplified Signal Flow for Real-Time Encoding .
  • Also, the test set can simultaneously decode the encoded audio frames that is received on the traffic channel using the appropriate vocoder algorithm (depending upon the selected voice service option) and then converts to an analog signal output at the test set's AUDIO OUT connector. See A Simplified Signal Flow for Real-Time Decoding .

A Simplified Signal Flow for Real-Time Encoding

A Simplified Signal Flow for Real-Time Decoding

Vocoder Calibration

The real-time vocoder functionality allows you to calibrate the audio output gain, audio input gain and internal codec loopback gain of the test set when the Operating Mode of the real-time vocoder is set to Calibration .

  • Audio Output Gain Calibration

    The audio output gain calibration is performed when the Calibration Type is set to Audio out Path . The test set sends a full scale sinewave to the AUDIO OUT port. The audio output gain can be determined by measuring the output analog signal.

    The audio output gain calibration result helps to perform the acoustic measurements of the mobile station, for example, the sending sensitivity frequency response.

    Audio Output Gain Calibration
  • Audio Input Gain Calibration:

    You can get the audio input gain of the test set in two ways:

    • Option 1: Set the Calibration Type to Audio In Path . The test set samples the input signal from the AUDIO IN port and loops them back to the AUDIO OUT port via the DAC. If an audio output path calibration has already been done, the audio input gain can be derived from the loopback gain and the audio output gain.
    • Option 2: Set the Calibration Type to Audio Out Path , looping the full scale sinewave from the AUDIO OUT port to the AUDIO IN port. As the audio output gain can be obtained by audio output path calibration, the audio input gain can be determined by reading the Encoder Headroom

    The audio input gain calibration result helps to perform the acoustic measurements of the mobile station, for example, the receiving sensitivity frequency response.

    Audio Input Gain Calibration
  • Internal Codec Loopback gain Calibration

    The internal codec loopback gain calibration is performed when the Calibration Type is set to Internal Codec. The test set samples the input signal from the AUDIO IN port, encodes the samples with the voice encoder and loops them back to the voice decoder, then sends the signals to the AUDIO OUT port via the DAC.

    The internal codec loopback gain calibration result helps to perform the acoustic measurements of the mobile station, for example, the echo loss.

    Internal Codec Loopback gain Calibration

Setting Real-Time Vocoder Parameters

The following parameters can be set from the Real-Time Vocoder Parameters menu. To access the Real-Time Vocoder Parameters menu, see How Do I Use the Real-Time Vocoder? .

  • Expected Audio In Peak Voltage

    Sets the peak voltage of the analog audio signal that is applied at the test set's AUDIO IN connector when the test set is in the real-time vocoder mode. It is used to adjust the audio input path gain for real-time encoding. Whenever you change this setting, it is not applied until the test set is set to the real-time vocoder mode.

    GPIB command: CALL:RTVocoder:INPut:VOLTage[:EXPected][:SELected]

  • Maximum Audio Out Peak Voltage

    Sets the maximum peak voltage of the analog audio signal that is expected to output at the test set's AUDIO OUT connector when the test set is in the real-time vocoder mode. Whenever you change this setting, it is not applied until the test set is set to the real-time vocoder mode.

    Setting this value makes the test set adjust the audio output path gain to achieve the desired audio output level at the test set's AUDIO OUT port. However, the actual output signal also depends on the voice signal decoded from the received voice data. The decoded signal may not be normalized to DAC (Digital to Analog Converter) full scale range. So it is possible that the final signal level is lower than the configured level.

    GPIB command: CALL:RTVocoder:OUTPut:VOLTage[:MAXimum][:SELected]

  • Voice Activity Detection (VAD) Algorithm

    Sets the VAD Algorithm used in the speech codec. The process of separating conversational speech and silence is called the Voice Activity Detection (VAD). The primary function of a voice activity detector is to provide an indication of speech presence in order to facilitate speech processing as well as possibly providing delimiters for the beginning and end of a speech segment. Refer to 3GPP TS 26.094 section 3 and 4 for more information about the VAD options.

    GPIB Command: CALL:RTVocoder:VADetection:AMRate:ALGorithm[:SELected]

  • Voice Activity Detection (VAD) State

    Sets whether or not the voice activity detection is implemented in the speech codec.

    GPIB Command: CALL:RTVocoder:VADetection[:STATe][:SELected]

  • Operating Mode

    Sets the operating mode of the Real-Time vocoder.

    • When Normal is selected, you can perform the normal functional test for the analog voice capability of the mobile station.
    • When Calibration is selected, you can calibrate the audio input gain, audio output gain and the internal codec loopback gain of the test set.

    GPIB Command: CALL:RTVocoder:OPERating:MODE

  • Calibration Type

    When the Operating Mode is set to Calibration , Calibration Type determines whether the audio output path, the audio input path or the internal codec loopback gain of the test set is calibrated.

    GPIB Command: CALL:RTVocoder:CALibration:TYPE

  • Audio Out Frequency

    When the Operating Mode is set to Calibration and the Calibration Type is set to Audio Out Path, Audio Out Frequency sets the frequency of the sinewave sent out by the test set.

    GPIB Command: CALL:RTVocoder:OUTPut:FREQuency

Real-Time Vocoder Headroom Information

The following results are displayed on the Real-Time Vocoder Information window when a voice call is established and the test set is in the real-time vocoder mode.

  • Encoder Headroom

    Indicates the headroom of the audio samples to the full scale of the ADC (Analog to Digital Converter). This result is updated at about one second period and calculated as follows:

    Encoder Headroom (dB) = 20 *Log ((ADC full scale) / (maximum absolute value of the input sample))

    When the input signal is over-range, the headroom is clipped to zero.

    GPIB command: CALL:RTVocoder:ENCoder:HEADroom[:SELected]?

  • Decoder Headroom

    Indicates the headroom of the decoded data samples to the full scale of the DAC (Digital to Analog Converter). This result is updated at about one second period and calculated as follows:

    Decoder Headroom (dB) = 20 *Log ((DAC full scale) / (maximum absolute value of the output sample)).

    GPIB command: CALL:RTVocoder:DECoder:HEADroom[:SELected]?

Operating Consideration

  • The Operation Mode must be set to Active Cell to use with the real-time vocoder.

  • The real-time vocoder can work along with the complementary Digital Audio Interface to perform live end to end testing (including microphone and loudspeaker if desired). See Digital Audio Interface (DAI) Description .

  • The real-time vocoder supports all current Speech Channels.
  • The test set is configured in real-time vocoder mode when the Speech Source is set to "Real-Time Vocoder".
  • When a voice call is established with the AMR Source to be Real-Time Vocoder or PESQ , it is highly recommended that you do not run any measurement at the same time, except for the Frame Error Rate measurement, Audio Generator and Data throughput Monitor. This is because many of the DSP resources are consumed to meet the real-time requirements for vocoder frame delivery or analog audio generation.
  • When the AMR Source is set to Real-Time Vocoder , you can not change the audio source parameters such as output level and the source to be routed to the AUDIO OUT connector (see AFGenerator Subsystem ).
  • When the input signal is over-range, the headroom value is equal to zero.
  • When the Expected Audio In Peak Voltage parameter is changed, you should re-calibrate the audio input gain.
  • When the Maximum Audio Out Peak Voltage parameter is changed, you should re-calibrate the audio output gain

Related Topics

How Do I Use the Real-Time Vocoder?


Establishing a Connection with the UE

Establishing a Connection with the UE

Last updated: January 15, 2009

  • Test Set-Originated Connection
  • UE-Originated Connection
  • Connection Status

NOTE
The Call Limit State must be OFF for any random access procedure, such as Location Update or test set origination (Paging), to be successful.

Test Set-Originated Connection

Before originating a call from the test set to the UE, specify what type of service you want to establish using the Paging Service setting. If Paging Service is set to RB Test Mode , you must also set Channel Type to the appropriate setting.

The UE can be paged using either an IMSI (International Mobile Subscriber Identity) or TMSI (Temporary Mobile Subscriber Identity).

To page the UE using its IMSI, set CS Paging Identity Type to IMSI . If you know the UE's IMSI, you can enter it under Paging IMSI ( CALL:PAGing:IMSI[:SELected] ) and proceed directly to originating a call even if the UE has not registered. Otherwise, you must wait for the UE to report its IMSI upon registering with the test set (see Performing a Location Update (CS Domain Registration) ).

To page the UE using a TMSI, the UE must first be assigned a TMSI during the Location Update procedure (see TMSI Assignment and Performing a Location Update (CS Domain Registration) ). You must then set CS Paging Identity Type to TMSI , then originate a call from the test set.

To originate a call from the test set, select Originate Call or send the CALL:ORIGinate[:AUTO] command.

The PICH contents are initially set to all zeroes in all paging indicators ("no page"). Once call origination is initiated, all of the page indicators in each valid access frame are set to all ones indicating a page. The valid access frames occur at times specified by the DRX Cycle Length (CN Domain) . Once the UE has responded to the page the paging indicators return to "no page".

For the lab application only, for circuit-switched services, you may choose to set Calling Party Number Inclusion to Include and specify a Calling Party Number for display on the UE's screen (see Calling Party Number Parameters ).

UE-Originated Connection

The Paging Service setting does not apply to UE-originated connections. When the UE originates a connection, the test set establishes the type of service requested by the UE. Current Service Type indicates the type of service established.

If you want the UE to originate the connection using a TMSI in its RRC Connection Request message, the test set must first assign a TMSI to the UE during the Location Update procedure (see TMSI Assignment and Performing a Location Update (CS Domain Registration) ).

For the lab application only, the Called Party Number indicates the number dialed into the UE when establishing the call.

Connection Status

The connection status is displayed at all times at the bottom of the front panel screens and is available via GPIB query (see Active Cell Connection State ).

Related Topics

Manual Operation: How Do I Set Up a Call and Make a Connection?

Manual Operation: Establishing an HSDPA Connection

Programming: Step 4: Make a Connection

Troubleshooting Call Processing Operations

Call Processing State Synchronization

Call Processing Event Synchronization

Base Station Originated Call Setup Flowchart

Call Processing Ladder Diagrams

Video Call


Base Station Originated Call Setup Flowchart

Base Station Originated Call Setup Flowchart

Last updated: January 15, 2009

The following diagrams illustrate the key steps and messaging to establish a base station initiated call (BS Origination) to the UE (mobile station).

Click on the blue text for more information on that topic.

Related Topics

W-CDMA Concepts


Simultaneous Services

Simultaneous Services

Last updated: March 5, 2012

This section is only applicable to the lab application.

  • Overview
  • Important things to Consider

Overview

Simultaneous services provides the capability to simultaneously support a circuit switched (CS) AMR voice connection and packet switched (PS) data connection. When simultaneous services is active the Current Service Type becomes AMR Voice + PS Data and the Active Cell Connection State becomes Connected/PDP Active .

Important things to Consider

  • The test set only supports simultaneous services when the GPRS Radio Access Bearer is set to one of the following configurations:
    • 64k PS Data RAB
    • 64k UL/384k DL PS Data RAB
    • HSUPA UL / HSDPA DL PS

  • When the GPRS Radio Access Bearer is set to HSUPA UL / HSDPA DL PS , the PS Data SRB Mapping Mode must be set to UL DCH/DL DCH .

  • Compressed Mode must be disabled in order to transition from a single service to simultaneous services, or vice versa. This setting can be enabled or disabled while simultaneous services is active.

  • Soft Handover State must be Off in order to transition from single service to simultaneous services. This setting can be enabled or disabled while simultaneous services is active.

Related Topics

Manual Operation: How Do I Establish a Simultaneous Services Connection?

CALL:ORIGinate

CALL:END

Simultaneous Services Ladder Diagrams

Troubleshooting Simultaneous Services


Simultaneous Services Ladder Diagrams

Simultaneous Services Ladder Diagrams

Last updated: March 3, 2009

This section is only applicable to the lab application.

  • Initiating Simultaneous Services [CS to CS + PS (MO)] Ladder Diagram
  • Initiating Simultaneous Services [CS to CS+PS] Rejection Ladder Diagram
  • Initiating Simultaneous Services [PS to CS (MT) + PS] Ladder Diagram
  • Initiating Simultaneous Services [PS to CS (MO) +PS] Ladder Diagram
  • Releasing Simultaneous Services [CS + PS to CS] Ladder Diagram
  • Releasing Simultaneous Services [CS + PS to PS] Ladder Diagram
  • Releasing Simultaneous Services [CS + PS to Idle] Ladder Diagram

Initiating Simultaneous Services [CS to CS + PS (MO)] Ladder Diagram

Initiating Simultaneous Services [CS to CS+PS] Rejection Ladder Diagram

Initiating Simultaneous Services [PS to CS (MT) + PS] Ladder Diagram

Initiating Simultaneous Services [PS to CS (MO) +PS] Ladder Diagram

Releasing Simultaneous Services [CS + PS to CS] Ladder Diagram

Releasing Simultaneous Services [CS + PS to PS] Ladder Diagram

Releasing Simultaneous Services [CS + PS to Idle] Ladder Diagram

Related Topics

Simultaneous Services


Video Call

Video Call

Last updated: February 26, 2012

  • Video Call Type
  • UE-to-UE Video Call
  • UE-to-8960LAN Video Call
  • Loopback Video Call

Video Call Type

This section is only applicable to the lab application.

In the lab application only, the Synchronous/Transparent CS Data Service supports three types of video calls, UE-to-UE video calls, UE-to-8960LAN video calls, and Loopback video calls. A test application with the required feature license supports only UE-to-UE video calls.

When the test set receives a request from the UE for a video call connection, the Video Call Type setting determines whether the test set attempts to set up the connection as a UE-to-UE video call (the test set must have an External Device Connection with another test set for this to succeed), a UE-to-8960LAN video call, or a Loopback video call.

GPIB command: CALL:VIDeo:TYPE

This setting can only be changed when call status is idle.

UE-to-UE Video Call

This section is only applicable to the lab application and to a test application with the required feature license.

The Synchronous/Transparent CS Data Service can be used to make an 3G-324M (derived from H.324M) UE-to-UE video call. Before making a UE-to-UE video call, you must first establish an External Device Connection between two 8960s. The external device connection allows the two 8960s to coordinate the setup and release of the CS data service and exchange the traffic plane data being sent by the UEs. This configuration allows the 3G-324M layers in the two UEs to communicate as they would in a real network to provide a video call service.

UE-to-UE Video Call Protocol Stack Diagram

Once you have established an external device connection between the two 8960s and have camped the UEs to the 8960s, you can originate a UE-to-UE video call from one of the UEs, and answer the call on the other. The 8960 connected to the originating UE commands the other 8960 to set up a CS data synchronous/transparent call to its UE. Once the call has been connected (the UE has responded to the page and you've answered the call), the call setup is completed to the originating UE and 3G-324M traffic data begins to flow (see UE-Initiated UE-to-UE Video Call Origination Ladder Diagram ladder diagram). You can release the UE-to-UE video call from either of the UEs (see UE-Initiated UE-to-UE Video Call Release Ladder Diagram ladder diagram), or from either of the 8960s (see Test Set-Initiated UE-to-UE Video Call Release Ladder Diagram ladder diagram).

UE-to-UE Video Call Setup

For the lab application only, the number dialed into the UE originating the call is displayed in the UE Information area under Called Party Number , and if Calling Party Number Inclusion is set to Include , the Calling Party Number is displayed on the screen of the UE receiving the call (see Calling Party Number Parameters ). Once a UE-to-UE video call is established, the Current Service Type becomes CS Data - UE to UE Video Call.

While on a UE-to-UE video call, you can perform many transmitter measurements on the UEs. For the lab application only, you can also monitor the over-the-air messaging between the 8960s and UEs using the Wireless Protocol Advisor's (WPA) Protocol Logging functionality. The WPA will not capture the proprietary messages sent between the two 8960s, nor will it decode the 3G-324M application layer messages from the UEs.

Other Considerations

The 8960 receiving the UE-to-UE video call origination must be in Active Cell Operating Mode , in Idle state.

If one of the 8960s is partially preset while up on a UE-to-UE video call, the call to its UE is dropped with no over-the-air signaling. If the other UE does not recognize that the call has dropped (and thus ends the call), you should manually end the call or partially preset its 8960 as well.

If one of the 8960s is fully preset while up on a UE-to-UE video call, the external device connection is disconnected, which causes both 8960s to end the call with their respective UEs.

UE-to-8960LAN Video Call

This section is only applicable to the lab application.

The UE-to-8960LAN video call feature is used to establish a 3G-324M (derived from H.324M) video call between a UE and an external device via the test set's LAN 2 PORT . The test set processes the signalling required to establish a Synchronous/Transparent CS Data Service bearer. The UE and external device then exchange signalling and 3G-324M data over this bearer.

The UE-to-8960LAN feature includes two interfaces: the control interface and the data interface.

UE-to-8960LAN Video Call System Configuration and Protocol Stack Diagram

The control interface sends and receives control messages to and from the external device. The following messages can be sent between the test set and external device control interfaces:

Establish Video Call Request

You can originate a UE-to-8960LAN video call from your UE (see UE-Initiated UE-to-8960LAN Video Call Origination Ladder Diagram ). You can also originate a UE-to-8960LAN video call from your external device by sending an "Establish Video Call Request", which is formatted as follows:

The test set then pages the UE and establishes the CS data bearer. See External Device-Initiated UE-to-8960LAN Video Call Origination Ladder Diagram .

Allow Remote Call Origination State must be set to On to originate a UE-to-8960LAN video call from your external device.

Terminate Video Call Request

You can release the UE-to-8960LAN video call from your UE (see UE-Initiated UE-to-8960LAN Video Call Release Ladder Diagram ) and from the test set (by selecting End Call ( F3 ), see Test Set-Initiated UE-to-8960LAN Video Call Release Ladder Diagram ). You can also release the UE-to-8960LAN video call from your external device by sending a "Terminate Video Call Request", which is formatted as follows:

The test set then sends a Disconnect message to the UE and releases the CS data bearer. See External Device-Initiated UE-to-8960LAN Video Call Release Ladder Diagram .

Allow Remote Call Release State must be set to On to release the UE-to-8960LAN video call from your external device.

Video Call Established Indication

If you set Sending of Call Status Indication State to On , after the CS data bearer is established (call status changes to Connected ), the test set will send a "Video Call Established Indication" to the external device, which is formatted as follows:

See UE-Initiated UE-to-8960LAN Video Call Origination Ladder Diagram and External Device-Initiated UE-to-8960LAN Video Call Origination Ladder Diagram . Note that the timing between the "Video Call Established Indication" and the arrival of the first data message on the data interface is not specified; either message can arrive at the external device first.

Video Call Terminated Indication

If you set Sending of Call Status Indication State to On , after the CS data bearer is released (call status changes to Idle ), the test set will send a "Video Call Terminated Indication" to the external device, which is formatted as follows:

See UE-Initiated UE-to-8960LAN Video Call Release Ladder Diagram , Test Set-Initiated UE-to-8960LAN Video Call Release Ladder Diagram and External Device-Initiated UE-to-8960LAN Video Call Release Ladder Diagram . Note that the timing between the "Video Call Terminated Indication" and the arrival of the last data message on the data interface is not specified; either message can arrive at the external device last.

UE-to-8960LAN Control Parameters

  • Allow Remote Call Origination State

    Allow Remote Call Origination State must be set to On before you can originate a UE-to-8960LAN video call from your external device (using an Establish Video Call Request ). If Allow Remote Call Origination State is set to Off , if the external device sends an "Establish Video Call Request", an error is posted by the test set.

    GPIB command: CALL:VIDeo:LAN:CONTrol:RCORiginate[:STATe]

    This setting can only be changed when call status is idle.

  • Allow Remote Call Release State

    Allow Remote Call Release State must be set to On before you can release the UE-to-8960LAN video call from your external device (using a Terminate Video Call Request ). If Allow Remote Call Release State is set to Off , if the external device sends a "Terminate Video Call Request", an error is posted by the test set.

    GPIB command: CALL:VIDeo:LAN:CONTrol:RCRelease[:STATe]

    This setting can only be changed when call status is idle.

  • Sending of Call Status Indications State

    If you set Sending of Call Status Indication State to On , the test set sends Video Call Established Indication and Video Call Terminated Indication messages to the external device as the call status changes.

    GPIB command: CALL:VIDeo:LAN:CONTrol:CSISend[:STATe]

    This setting can only be changed when call status is idle.

  • Control Message Receiving UDP Port

    This setting controls the UDP port number that the test set uses to receive control messages from the external device. The IP address that the test set uses to receive control messages from the external device is determined by the LAN IP Address setting. Ensure that your external device is set to send control messages to the UDP port and IP address specified by these two settings.

    GPIB command: CALL:VIDeo:LAN:CONTrol:RECeive:UDP:PORT

    This parameter can only be changed when call status is idle. This parameter is a non-volatile parameter; it is not affected by any reset operation and can only be changed by direct access to the parameter itself.

  • Control Message Destination IP Address

    This setting controls the IP address that the test set uses to send control messages to the external device. Ensure that your external device is set to receive control messages at the IP address specified by this setting.

    GPIB command: CALL:VIDeo:LAN:CONTrol:SEND:IP:ADDRess

    This parameter can only be changed when call status is idle. This parameter is a non-volatile parameter; it is not affected by any reset operation and can only be changed by direct access to the parameter itself.

  • Control Message Destination UDP Port

    This setting controls the UDP port number that the test set uses to send control messages to the external device. Ensure that your external device is set to receive control messages at the UDP port number specified by this setting.

    GPIB command: CALL:VIDeo:LAN:CONTrol:SEND:UDP:PORT

    This parameter can only be changed when call status is idle. This parameter is a non-volatile parameter; it is not affected by any reset operation and can only be changed by direct access to the parameter itself.

UE-to-8960LAN Data Parameters

The data interface routes the CS data packets that contain the 3G-32M data between the UE and external device. The test set supports one type of data message: 160 byte (1280 bits) comprising two RLC blocks of the 64k UL/DL CS data service. The data message does not have any header fields.

  • Data Message Receiving UDP Port

    This setting controls the UDP port number that the test set uses to receive data messages from the external device. The IP address that the test set uses to receive data messages from the external device is determined by the LAN IP Address setting. Ensure that your external device is set to send data messages to the UDP port and IP address specified by these two settings.

    GPIB command: CALL:VIDeo:LAN:DATA:RECeive:UDP:PORT

    This parameter can only be changed when call status is idle. This parameter is a non-volatile parameter; it is not affected by any reset operation and can only be changed by direct access to the parameter itself.

  • Data Message Destination IP Address

    This setting controls the IP address that the test set uses to send data messages to the external device. Ensure that your external device is set to receive data messages at the IP address specified by this setting.

    GPIB command: CALL:VIDeo:LAN:DATA:SEND:IP:ADDRess

    This parameter can only be changed when call status is idle. This parameter is a non-volatile parameter; it is not affected by any reset operation and can only be changed by direct access to the parameter itself.

  • Data Message Destination UDP Port

    This setting controls the UDP port number that the test set uses to send data messages to the external device. Ensure that your external device is set to receive data messages at the UDP port number specified by this setting.

    GPIB command: CALL:VIDeo:LAN:DATA:SEND:UDP:PORT

    This parameter can only be changed when call status is idle. This parameter is a non-volatile parameter; it is not affected by any reset operation and can only be changed by direct access to the parameter itself.

Loopback Video Call

This section is only applicable to the lab application.

The loopback video call provides a way for a UE to establish an H.324M video call directly with the test set without requiring any external entities (as are required for UE-to-UE video calls and UE-to-8960LAN video calls).

For this type of video call, the video and audio streams are simply looped back from the uplink to the downlink. That is, the UE will display the same data that its video camera is sending. The test set mimics a true H.325M peer to UE since it has the control plane layer (H.245) and the multiplexing layer (H.223) fully implemented. Since the test set is looping back data sent from the UE rather than generating data, it relies on the UE to initiate the H.324 procedures and simply agrees to any requests from the UE.

Related Topics

Manual Operation: How Do I Make a Video Call?

Video Call Ladder Diagrams

CALL:STATus:SERVice:TYPe?

Troubleshooting Video Call

External Device Connection

Synchronous/Transparent CS Data Service


Video Call Ladder Diagrams

Video Call Ladder Diagrams

Last updated: January 15, 2009

These sections are only applicable to the lab application or to a test application with the required feature license:

  • UE-Initiated UE-to-UE Video Call Origination Ladder Diagram
  • UE-Initiated UE-to-UE Video Call Release Ladder Diagram
  • Test Set-Initiated UE-to-UE Video Call Release Ladder Diagram

These sections are only applicable to the lab application:

  • UE-Initiated UE-to-8960LAN Video Call Origination Ladder Diagram
  • External Device-Initiated UE-to-8960LAN Video Call Origination Ladder Diagram
  • UE-Initiated UE-to-8960LAN Video Call Release Ladder Diagram
  • Test Set-Initiated UE-to-8960LAN Video Call Release Ladder Diagram
  • External Device-Initiated UE-to-8960LAN Video Call Release Ladder Diagram

UE-Initiated UE-to-UE Video Call Origination Ladder Diagram

UE-Initiated UE-to-UE Video Call Release Ladder Diagram

Test Set-Initiated UE-to-UE Video Call Release Ladder Diagram

UE-Initiated UE-to-8960LAN Video Call Origination Ladder Diagram

External Device-Initiated UE-to-8960LAN Video Call Origination Ladder Diagram

UE-Initiated UE-to-8960LAN Video Call Release Ladder Diagram

Test Set-Initiated UE-to-8960LAN Video Call Release Ladder Diagram

External Device-Initiated UE-to-8960LAN Video Call Release Ladder Diagram

Related Topics

Video Call


Digital Bus Information

Digital Bus Information

Last updated: January 15, 2009

Description

A test set equipped with cdma2000, 1xEV-DO or W-CDMA lab applications can perform mobile station tests that require faded signals. The test set must be equipped with a rear panel that includes a connector labeled Digital Bus.

NOTE
For detailed setup and operating instructions pertaining to faded signal generation, refer to

E5515C Fading Solution Application Guide

It can be downloaded at http://cp.literature.agilent.com/litweb/pdf/1000-1894.pdf .

When a faded signal from the test set is needed, the forward baseband signal path from the Test Set is diverted to a PC running Baseband Studio software. This software is capable of digitally adding fading patterns requested by the user.

Fader Setup

Baseband Studio software also controls the test set's call parameters and digital bus signal path switching modes. The status of the various digital bus parameters and the controls themselves are made available by selecting Digital Bus Info from the Call Control screen.

  • Baseband Studio Summary - The current values in use for baseband signal level adjustments.
  • Digital Bus Summary - The current data and clock rates for the modulation type of the faded signal.

With the Digital Bus Information screen displayed, the following fading parameters are displayed:

The Bbio Control menu provides three settings:

  • Digital Bus Path - Must be Internal for non-faded signal operation.

  • ALC Mode - Must be Closed Loop for non-faded signal operation.

  • Calibrate Open Loop ALC - Used to generate calibration tables that are needed when ALC Mode is Open Loop.

IMPORTANT
The Digital Bus Path and ALC Mode fields are controlled by the Baseband Studio software when a faded signal is generated by the test set. The only time these field settings will need to be manually changed is during certain diagnostic routines. Refer to the Installation Note (E5515-90243) shipped with the Option 504 kit for instructions on performing diagnostic tests.


Front Panel Connectors

Front Panel Connectors

Last updated: February 13, 2012

Description

AUDIO IN

The input to the audio analyzer is a floating input differential amplifier. Both the AUDIO IN High and AUDIO IN Low BNC connectors should be connected to provide noise immunity. Refer to the Technical Specifications in the Application Datasheet for more information.

AUDIO OUT

This BNC connector accesses the test set's Audio Generator and FM Demod signals. The Audio Generator is used to stimulate a system to measure audio performance characteristics. The FM Demod allows the user to access the demodulated FM signal for external analysis and baseband processing. Refer to the Technical Specifications in the Application Datasheet for more information.

NOTE
There will be no guaranteed performance for the signal present at the AUDIO OUT connector when FM Demod signal is selected for output.

DVM

Not functional for this release.

RF IN/OUT

This Type-N connector is the default path for all RF signals out of the test set, and is always used as the RF input. Refer to the Technical Specifications in the Application Datasheet for more information. See also RF OUT ONLY .

RF OUT ONLY

NOTE
This port cannot be used with the E1960A GSM test application or with the GSM personality in a test application suite (such as the E1985A GSM_AMPS/136_GPRS suite).

This Type-N connector is an optional path for all RF signals out of the test set. It is intended to be used for duplexed testing. Front panel selection of this port is provided by the RF Output Port ( F6 ) control on the System Config screen, and by the RFGenerator:OUTPut[:DESTination] IO/OUT command. The same amplitude offsets and output power settings are used for either selected port (RF IN/OUT or RF OUT ONLY). Refer to the Technical Specifications in the Application Datasheet for more information.

Related Topics

RFGenerator Subsystem (RF OUT ONLY control)

Amplitude Offset (RF amplitude offsets)


Help Mode

Help Mode

Last updated: January 15, 2009

Description

This section explains:

  • What is Help Mode?
  • How do I use the help mode?

What is Help Mode?

The help mode implemented in your test set provides context sensitive GPIB command syntax assistance. When you put the test set into help mode, the test set displays the GPIB command syntax necessary to perform an action remotely for each action you perform from the front panel.

For example, if you put the test set into help mode and then select the test set's GPIB address, the GPIB command syntax for changing it remotely appears in the bottom left hand corner of the test set's screen.

NOTE
Operating the test set in Help Mode does not prevent you from changing parameters from the front panel. The parameters you change while in Help Mode are applied just as they would be normally.

How do I use the help mode?

  1. Put the test set into help mode by pressing the HELP key on the front panel.

    The Help annunciator should now be displayed in the bottom of the screen.

  2. Navigate to the screen and perform the action for which you would like to know the GPIB command syntax. For example, you could navigate to the Audio Generator instrument, and select Frequency ( F3 ). The GPIB command syntax to perform this action remotely appears in the bottom left of the screen.

    Refer to the user documentation on each command for more information.


Preset Descriptions

Preset Descriptions

Last updated: January 15, 2009

Description

The test set is capable of accepting several different preset commands.

At no time during a preset operation, does transmit power exceed the last user setting of the transmit power. The input power is not set to any value lower than the last user setting of the input power. This is to avoid power spikes on the output and possible receiver damage on the input during transitions associated with preset operations.

Partial Preset

Partial preset saves setup time because measurement setup parameters remain unchanged. This is the recommended way to place the test set in a known condition.

When you fast switch between formats in a fast switching test application the test set behaves as if a partial preset has occurred. The table below lists some key partial preset results.

Example

OUTPUT 714;"SYSTEM:PRESET3" !Command for a partial preset when user in
                            !remote operation.

SYSTEM:PRESET3 is the recommended command for a partial preset operation. The SYSTEM:PRESET[1] command is not recommended for use at this time.

Press the green Preset key on the front panel to perform a partial preset.

Partial Preset Behavior
Function | Partial Preset Result
Trigger Arm | no change
Measurement parameters | no change
Calibration data | no change
Enable registers | no change
Positive Transition Filter registers | no change
Negative Transition Filter registers | no change
Contents of RAM | no change
Contents of output queue | no change
Contents of error queue | no change
Maskable Message Display State | no change
Operating Mode | Active Cell
Measurements | aborted and inactivated
Measurement results | NAN
Measurement integrity indicator | 1 = no result available
Transmit Power State | ON
Cell Activated State | ON
Call in progress | aborted
Call Control Status | Idle
Call Counters | cleared
Call Error Counters | cleared
SACCH | cleared
Pending Service request | not cleared

Full Preset

A full preset requires you to select new measurements and configure their parameters. If measurement parameters do not need to be changed, use a partial preset to save time.

Example

OUTPUT 714;"*RST" !Recommended command for a full preset, sets trigger arm to single.

OUTPUT 714;"SYSTEM:PRESET2" !Command for a full preset, sets trigger arm to continuous.

The *RST common command is the recommended command for a full preset operation.

NOTE
Transmit power is not set to OFF during a full preset, transmit power is set to the default value.

Full Preset Behavior
Function | Full Preset Result
Trigger Arm | Continuous (manual operation full preset or SYSTEM:PRESET2 command)
Trigger Arm | Single (remote operation full preset, *RST command)
Measurement Parameters | all set to defaults
Maskable Message Display State | On (manual operation full preset)
Maskable Message Display State | Off (remote operation full preset)

Status Preset

The STATUS:PRESET command sets the status system as defined in "SCPI 1995 Volume 2: Command Reference" section 20.7. All of the enable registers are set to 0, all PTR registers are set to 1, and all NTR registers are set to 0.

Example

OUTPUT 714;"STATUS:PRESET" !Presets the STATus subsystem.

Related Topics

SYSTem:PRESet


Instrument Status Area

Instrument Status Area

Last updated: April 17, 2009

Description

The instrument status area is found on the bottom center of the test set's display.

Status Area of the Test Set Display

Background

You can initiate more than one measurement at a time with the test set. The test set's display can show a maximum of 2 measurements. When 3 or more measurements are initiated, or the MEASUREMENT screen is not displayed, the Background annunciator reminds you that measurements are active but not displayed.

<Operating Mode> Status

The call processing status and the operating modes are displayed in this area. This area may change (depending on the application that is active) in order to provide application specific information.

Sys Type

The current system type is displayed in this area. This area may change (depending on the application that is active). It might be IS-856 (for 1xEV-DO), IS-95 , IS-2000 , GSM , GPRS , EGPRS , FDD (for W-CDMA), IS-136 , DIG-136 .

External Device Connection

When the test set is connected to another test set using an External Device Connection, this area contains ExtDev . Otherwise, this area is blank. For details, see the related links under Related Topics.

Logging

This annunciator indicates whether or not your lab application is connected to Wireless Protocol Advisor. When your lab application is connected to Wireless Protocol Advisor Logging: Active is displayed, when your Lab Application is not connected to Wireless Protocol Advisor Logging: Idle is displayed. If your Application is a test application, this area is blank.

Sync Annunciators

These annunciators indicate whether the test set has successfully completed a synchronization. This annunciator can contain " C OPC ", " S OPC " or " CS OPC ". For details, see the related links under Related Topics.

DBUS - INT

This annunciator turns on when Option 004 hardware is installed and the application is a cdma2000, 1xEV-DO, or W-CDMA lab application that supports this functionality. For details, see the related links under Related Topics.

Shift

This annunciator indicates that the blue SHIFT key has been pressed, and that the next key you press performs the shifted function indicated, also in blue.

Int Ref/Ext Ref

When the internal time base is used (there is no suitable external time base connected to the rear panel 10MHz REF IN connector), Int Ref turns on. When a suitable external time base is connected to the rear panel 10MHz REF IN connector, Ext Ref turns on.

Offset

This annunciator indicates that the Amplitude Offset state is set to On. For details, see the related links under Related Topics.

R L T S

This annunciator indicates the state of four different conditions of the test set:

  • Remote annunciator. ` R ' turns on when the test set is operated remotely.
  • Listen annunciator. ` L ' turns on when the test set is listening to a command.
  • Talk annunciator. ` T ' turns on when the test set is providing information over GPIB.
  • SRQ annunciator. ` S ' turns on when an SRQ is active.

Help

When the Help functionality is active, this annunciator turns on. Use the HELP hardkey to activate/deactivate the Help functionality. When the help functionality is active, when you select a setting the associated GPIB command is displayed at the bottom of the screen.

Physical Layer Subtype

This area is applicable to the 1xEV-DO applications. It indicates the current Physical Layer Subtype, either PLSub0 (Physical Layer Subtype 0), PLSub2 (Physical Layer Subtype 2) or PLSub3 (Physical Layer Subtype 3). For details, see the related links under Related Topics.

Application Type

This area is applicable to the 1xEV-DO applications. It indicates the current application being used, such as FTAP , RTAP , FETAP , RETAP , FMCTAP , RMCTAP or DPkt . For details, see the related links under Related Topics.

Related Topics

Background: How Do I Make Measurements on a UE?

<Operating Mode> Status: Active Cell Connection State

External Device Connection: External Device Connection

Logging: Protocol Logging

DBUS-INT: Digital Bus Information

Int Ref/Ext Ref: Timebase Description/Configuration

Offset: Amplitude Offset

Help: Help Mode


How Do I Use the Real-Time Vocoder?

How Do I Use the Real-Time Vocoder?

Last updated: October 26, 2010

This section is only applicable to the lab applications and the test application with a required feature license.

The following procedure provides an example usage of Real-Time Vocoder. It is assumed that a mobile station's antenna output is connected to the test set's RF IN/OUT connector, an external audio source (such as a microphone) is connected to the test set's AUDIO IN port, and an external audio receiver (such as a loudspeaker) is connected to the test set's AUDIO OUT port.

General Procedure

  1. Press the blue SHIFT key and then the green Preset key to fully reset the test set.
  2. Follow the procedure described in How Do I Set Up a Call and Make a Connection? to establish a voice call.
  3. Press the lower left More key until menu 3 of 6 of Call Control is displayed.
  4. Press Voice Call ( F5 ), and then AMR Setup ( F1 ).
  5. Set AMR Source to Real-Time Vocoder from the pop-up menu.
  6. Press Real-Time Vocoder Parms ( F3 ). The Real-Time Vocoder Parameters menu is displayed. Set the parameters as desired and then press the close menu ( F6 ) key when finished.
  7. Speak into the mobile station. Verify that the voice is heard from the loudspeaker. The voice encoded by the mobile station is sent to the test set over the RF link. The test set then demodulates, decodes the signal and converts it to an analog signal output to the AUDIO OUT connector. The signal is then played by the loudspeaker.
  8. Speak over the microphone (that is connected to AUDIO IN connector). The analog voice signal is input to the test set's AUDIO IN connector. The test set samples, encodes the signal, and modulates it onto the RF link. When the mobile station receives the RF signal, it demodulates, decodes, and converts the signal into an analog audio output to its speaker. Verify that the voice is heard from the mobile station's speaker.
  9. A typical display during real-time vocoder operation is shown below. For an explanation of the encoder headroom and decoder headroom results, see Real-Time Vocoder Headroom Information .

Related Topics

Real-Time Vocoder


How Do I Use the Data Throughput Monitor?

How Do I Use the Data Throughput Monitor?

Last updated: January 15, 2009

This section is only applicable to the lab application.

Description

The following procedure illustrates typical usage of the data throughput monitor.

Accessing the Monitor Controls

  1. Press the Instrument selection key.
  2. Select Data Throughput Monitor .

    The data throughput monitor is displayed with the default settings as shown above. The Swap Window Positions ( F5 ) is displayed only when another measurement or instrument is active.

    Once the data throughput monitor is selected, it can be accessed by pressing the MEASUREMENT key, followed by the Swap Window Positions ( F5 ) key if necessary.

  3. Set the axis control as needed for your testing situation using the Axis Control ( F1 ) key to access the Time Span ( F1 ), Start Data Rate ( F2 ) Stop Data Rate ( F3 ) keys. For example, if you expect data rates to exceed the default value of 100 kbps, press the ( F1 ) key followed by the ( F3 ) key and enter a new value in the Stop Data Rate field using the DATA ENTRY keys.
  4. Press the Return ( F6 ) key to exit the Axis Control menu.
  5. Select the traces you would like to display by pressing the Trace Control ( F2 ) key followed by the Trace Display ( F1 ) key. To select a trace, turn the value to On. There are six color-coded traces and any combination can be selected:
    • OTA Tx - (Over The Air Transmitted bits-per-second). This is the rate of link-layer bit transfer sent from the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in WCDMA and GPRS, or PPP in GSM. Tx refers to the reverse or uplink channel direction.
    • OTA Rx - (Over The Air Received bits-per-second). This is the rate of link-layer bit transfer received by the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in WCDMA and GPRS, or PPP in GSM. Rx refers to the forward or downlink channel direction.
    • IP Tx - Internet Protocol Transmitted. This is the rate of network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.
    • IP Rx - Internet Protocol Received. This is the rate of network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.
    • Context <n> Tx - Internet Protocol Context 1 Transmitted. This is the rate of context 1 network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.
    • Context <n> Rx - Internet Protocol Context 1 Received. This is the rate of context 1 network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.

    By default, the OTA Tx and OTA Rx traces are the only traces turned on.

  6. Press the Return ( F6 ) key to exit the Trace Control menu.

  7. Establish a data connection with the mobile.

    The Data Throughput Monitor will begin displaying numerical and graphical information. The numerical information pertains to the period of time beginning with the establishment of the first data connection, and the graphical traces represent up to 600 seconds of the latest data throughput statistics.

  8. Set a marker.

    Using the Trace Control menu, select a marker by pressing the corresponding F2 , F3 , F4 , or F5 keys followed by the Data Entry key labeled ON.

    Press the Return ( F6 ) key.

    After allowing the monitor to accumulate throughput for at least one minute, change the Time Span to 50 seconds (see step 3 above). This will expand the graphical view to improve resolution.

    Press the Return ( F6 ) key.

  9. Freeze the graph.

    Press the Freeze Graph (F4) key.

    Turn the knob to adjust the position of the marker. Marker results will be displayed in the summary table

  10. Press the Return ( F6 ) key to exit the Trace Control menu.
  11. Press the Resume Graph ( F4 ) key to display the most recent trace data.
  12. Press the Clear Graph ( F3 ) key to reset the traces and the numeric counters.

Changing Data Rates

Data throughput can be analyzed under various call processing and RF conditions. This section illustrates the steps required to change data rates.

It is assumed that the data throughput monitor is displayed and a data call is connected.

  1. Press the CALL SETUP key.
  2. Change the data rate (see Related Topics).
  3. Press the MEASUREMENT key.

Related Topics

Data Throughput Monitor Description


How Do I Make a Fast Device Tune Measurement?

How Do I Make a Fast Device Tune Measurement?

Last updated: January 15, 2009

NOTE
Before performing this measurement, ensure that the test set has been properly calibrated (see Calibrating the Test Set ).

Measuring Fast Device Tune

  1. Set Operating Mode ( F1 ) to FDD Test .
  2. Set Channel Type ( F8 ) to 12.2k RMC , 64k RMC , 144k RMC , 384k RMC or 33k No Coding RMC .
  3. Set the test set's receiver and generator control to manual mode:
    • Set RF Gen Freq Ctrl ( F11 on Call Parms 3 of 3 ) to Manual .
    • Select Receiver Control ( F12 on Call Parms 3 of 3 ).
    • Set Power Control to Manual (it is not necessary to set the Manual Power setting; it is not used by the measurement).
    • Select Measurement Frequency and press the front panel OFF ( MANUAL ) key (the particular frequency displayed is not used by the measurement).
  4. Press the Measurement selection key.
  5. Select the Fast Device Tune measurement.
  6. Select Fast Device Tune Setup ( F1 ) and set the measurement parameters as needed. Select Close Menu ( F6 ).
  7. Select Fast Device Tune MS TX/RX Parms ( F2 ), and configure the parameters as needed. Select Close Menu ( F6 ) and Return ( F6 ).
  8. Place your mobile into a test mode that causes it to transmit continuously at >20 dB below the power level of the first step in the MS TX Power Sequence.
  9. Press the START SINGLE key to initiate (arm) the measurement.
  10. Wait 2 seconds.
  11. Order your mobile to begin transmission of its MS TX Frequency/Power Series (the mobile should then increase its output power by more than 20 dB to reach the first step in the series, which triggers the measurement with an RF rise).

    IMPORTANT
    Do not send any GPIB commands to the test set or press any front panel keys until the measurement has completed.

  12. Select Graph Control ( F3 ). Set the axis control parameters as needed. Select Return ( F6 ).
  13. Select Marker ( F2 ) to turn on the marker on the graphical display.

A typical result is shown below:

Related Topics

Fast Device Tune Measurement Description


How Do I Make an HSDPA Block Error Ratio Measurement?

How Do I Make an HSDPA Block Error Ratio Measurement?

Last updated: December 14, 2011

This section is only applicable to the lab application or a test application with the required feature license.

  • Measuring 3GPP TS 34.121-1 6.3A Maximum Input Level for HS-PDSCH Reception (16QAM)
  • Measuring 3GPP TS 34.121-1 6.3B Maximum Input Level for HS-PDSCH Reception (64QAM)
  • Measuring 3GPP TS 34.121-1 6.3C Maximum Input Level for DC-HSDPA Reception (16QAM)
  • Measuring 3GPP TS 34.121-1 6.3D Maximum Input Level for DC-HSDPA Reception (64QAM)

Measuring 3GPP TS 34.121-1 6.3A Maximum Input Level for HS-PDSCH Reception (16QAM)

This example is for FDD Test Operating Mode . The measurement is also available in Active Cell Operating Mode .

  1. Set Operating Mode ( F1 ) to FDD Test .
  2. Set Cell Power ( F7 ) to -25.7 dB .
  3. Set Channel Type ( F8 ) to 12.2k RMC + HSDPA
  4. Set HSDPA Parameters ( HSPA Parameters ( F10 ), F10 ):
    • Set FRC Type ( F8 ) to H-Set 1 16QAM .
    • Set FDD Test Number of Transmissions (under MAC-hs Parameters ) to 1 .
    • Set FDD Test RV Sequence (under MAC-hs Parameters ) to 6,0,0,0,0,0,0,0 (simply enter 6 and then press the knob, the remaining values are automatically filled with zeros).
    • Set FDD Test Primary H-RNTI (Hex) (under H-RNTI Parameters ) as needed.
  5. Set Channel (UARFCN) Parms ( F12 ): set DL Channel and Uplink Channel to the proper mid range frequencies for your UE's operating band.
  6. Set UE Target Power ( F7 ) to 20 or 18 dBm , depending upon the class of your UE.
  7. Set FDD Test UL CL Power Ctrl Mode to Alternating bits and FDD Test UL CL Power Ctrl Algorithm to Two (under UL CL Power Ctrl Parameters ( F8 )) (these are the default values).
  8. Set HSDPA DL Channel Levels ( F4 under Downlink Channel Levels ):
    • Set HSDPA FDD Test CPICH Level to -10 dB (this is the default value).
    • Set HSDPA FDD Test P-CCPCH/SCH Level to -12 dB (this is the default value).
    • Set HSDPA FDD Test PICH Level to -15 dB (this is the default value).
    • Set HSDPA FDD Test DPCH Level to -13 dB .
    • Set Sum of Active FDD Test HS-PDSCH Levels to -3 dB (this is the default value).
    • Set FDD Test HS-SCCH 1 Level to -13 dB .
  9. Establish an RB Test Mode connection between the UE and test set. (In FDD Test operating mode the test set does not provide radio bearer setup control of the UE. You must configure the UE to synchronize to the test set, demodulate the downlink HS-SCCH and HS-PDSCH channels and generate the appropriate uplink HS-DPCCH. See Synchronizing the UE to the Test Set's Downlink to Make Measurements .)
  10. Press the Measurement selection key.
  11. Select HSDPA Block Error Ratio .
  12. Select HSDPA Blk Error Ratio Setup ( F1 )
    • Set Number of blocks to test to 500.
    • Set Trigger Arm to Single .
    • Select Close Menu ( F6 ).
  13. Press the START SINGLE key to begin the measurement. Wait approximately 3 seconds for the measurement to complete. Determine if the throughput exceeds 700 kbps, as required by 3GPP TS 34.121.

The following example shows results for an FRC Type of H-Set 5 QPSK :

Measuring 3GPP TS 34.121-1 6.3B Maximum Input Level for HS-PDSCH Reception (64QAM)

This example is for Active Cell Operating Mode . The measurement is also available in FDD Test Operating Mode .

  1. Set Operating Mode ( F1 ) to Cell Off .
  2. Select DL Chan Code Preset Configs ( Call Control 2 of 6 , Generator Info ( F3 ), Downlink Channel Configs ( F4 ), F5 ) and select 34.121 Tables E.6.2.3,4 (HSDPA 15 HS-PDSCHs) . You man then skip any steps marked with [DL Chan Code Config] in this procedure.
  3. Select 34.121 Preset Call Configs ( F11 on Call Parms 1 of 3 ) and select 6.3B:HSPA+:64QAM . You may then skip any steps marked with [34.121 Call Config] in this procedure.
  4. Set Operating Mode ( F1 ) to Active Cell .
  5. Set Cell Power ( F7 ) to -25.7 dB .
  6. [34.121 Call Config] Set Channel Type ( F8 ) to 12.2k RMC + HSDPA .
  7. [DL Chan Code Config] Set Downlink Channel Configs ( Call Control 2 of 6 , Generator Info ( F3 ), F4 ):
    • [DL Chan Code Config] Set HS-SCCH 3 and HS-SCCH 4 Channel Config State to Off (under HS-SCCH Configs ( F3 )).
    • [DL Chan Code Config] Set HSDPA/HSPA OCNS 2 through HSDPA/HSPA OCNS 6 Chan Config State to Off (under HSDPA/HSPA OCNS Configs ( F4 )).
  8. [DL Chan Code Config] Set Downlink Channel Codes ( F6 twice, then Generator Info ( F2 ), F2 ):
    • [DL Chan Code Config] Set PICH Channelization Code to 2 (under Shared DL Channel Codes ( F2 )).
    • [DL Chan Code Config] Set HSDPA/HSPA Downlink Channel Codes ( F4 ):
      • [DL Chan Code Config] Set HSDPA/HSPA (F-)DPCH 15 ksps (OVSF 256) Code to 14 .
      • [DL Chan Code Config] Set HSDPA/HSPA DPCH 30 ksps (OVSF 128) Code to 7 .
      • [DL Chan Code Config] Set RB Test Mode First HS-PDSCH Channel Code to 1 .
      • [DL Chan Code Config] Set HS-SCCH 1 Channelization Code to 2 .
      • [DL Chan Code Config] Set HS-SCCH 2 Channelization Code to 3 .
  9. [34.121 Call Config] Set HSDPA RB Test Mode Settings ( HSPA Parameters ( F10 ), HSDPA Parameters ( F10 ), HSDPA RB Test Mode Setup ( F8 ), F8 ):
    • [34.121 Call Config] Set RB Test HS-DSCH Configuration Type to FRC .
    • [34.121 Call Config] Set FRC Type to H-Set 8 64QAM .
  10. [34.121 Call Config] Set MAC-(e)hs Parameters ( Return ( F12 ), F10 ):
    • [34.121 Call Config] Set Number of Transmissions to 1 .
    • [34.121 Call Config] Set RV Sequence to 6,0,0,0,0,0,0,0 (simply enter 6 and then press the knob, the remaining values are automatically filled with zeros).
    • [34.121 Call Config] Set MAC-hs Transmit Window Size to 16 (this is the default value).
    • [34.121 Call Config] Set MAC-hs T1 to 50 ms (this is the default value).
  11. Set DL Channel and Uplink Channel to the proper mid range frequencies for your UE's operating band (under Channel (UARFCN) Parms ( CALL SETUP , F12 ).
  12. [34.121 Call Config] Set UL CL Power Ctrl Algorithm to Two (under Call Parms 3 of 3 , UL CL Power Ctrl Parameters ( F8 ) (this is the default value).
  13. [34.121 Call Config] Set HSDPA Conn DL Channel Levels ( CALL SETUP , Call Control 2 of 6 , Generator Info ( F3 ), Downlink Channel Levels ( F3 ), Connected DL Channel Levels ( F3 ), F3 ):
    • [34.121 Call Config] Set HSDPA Cell 1 Connected CPICH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSDPA Cell 1 Connected P-CCPCH/SCH Level to -12 dB (this is the default value).
    • [34.121 Call Config] Set HSDPA Cell 1 Connected PICH Level to -15 dB (this is the default value).
    • [34.121 Call Config] Set HSDPA Cell 1 Connected DPCH Level to -13 dB .
    • [34.121 Call Config] Set HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) to -2 dB .
    • [34.121 Call Config] Set HSDPA Cell 1 Connected HS-SCCH 1 Level to -13 dB .
    • [34.121 Call Config] Set HSDPA Cell 1 Connected HS-SCCH 2 Level to Off .
  14. Set any other parameters needed to establish a connection with your UE, then power on the UE and wait for it to register (attach).
  15. . Select Originate Call ( F3 on Call Control 1 of 6 ).
  16. Set UL CL Power Ctrl Mode to Active bits (under Call Parms 3 of 3 , UL CL Power Control Parameters ( F8 ) (this is the default value).
  17. Set UE Target Power ( Call Parms 3 of 3 , F7 ) to -2 dBm . This value is determined as follows. UE Target Power only sets the DPCCH+DPDCH power level of the UE. In order to achieve a total output power of 0 dBm as required by 3GPP TS 34.121-1 table 6.3B.4, you must set UE Target Power to 0 dBm - Power change due to HS-DPCCH . Power Change Due to HS-DPCCH = 10log 10 (Beta c ^2 + Beta d ^2 + Beta hs ^2) - 10log 10 (Beta d ^2 + Beta c ^2) = 2 dB, so you must set UE Target Power to -2 dBm .
  18. Set UL CL Power Ctrl Mode to Alternating bits .
  19. Press the Measurement Selection key and select Channel Power .
  20. Select Channel Power Setup ( F1 ).
    • Set Auto Range to On .
    • Verify the UE's Channel Power is 0 dBm ± 1 dB.
  21. Press the Measurement Selection key and select HSDPA Block Error Ratio .
  22. Select HSDPA Blk Error Ratio Setup ( F1 ).
    • Set Number of blocks to test to 500 .
    • Set Trigger Arm to Single .
    • Select Close Menu ( F6 ).
  23. Press the START SINGLE key to begin the measurement. Wait approximately 3 seconds for the measurement to complete. Verify that the Information Bit Throughput exceeds 11800 kbps, as required by 3GPP TS 34.121-1 table 6.3B.2.

Measuring 3GPP TS 34.121-1 6.3C Maximum Input Level for DC-HSDPA Reception (16QAM)

This example is for Active Cell Operating Mode. The measurement is also available in FDD Test Operating Mode.

  1. Set Operating Mode ( F1 ) to Cell Off .
  2. Select DL Chan Code Preset Configs ( Call Control 2 of 6 , Generator Info ( F3 ), Downlink Channel Configs ( F4 ), F5 ) and select 34.121 Tables E.6.2.3,4 (HSDPA 15 HS-PDSCHs) . You man then skip any steps marked with [DL Chan Code Config] in this procedure. This step mainly aims to avoid a possible code collision. Use the following 34.121 Preset settings to overwrite some of the parameters especially for 6.3C.
  3. Select 34.121 Preset Call Configs ( F11 on Call Parms 1 of 3 ) and select 6.3C:DC-HSDPA:16QAM . You may then skip any steps marked with [34.121 Call Config] in this procedure.
  4. [34.121 Call Config] Set Cell Power ( F7 ) to -25.7 dB.
  5. [34.121 Call Config] Set Channel Type ( F8 ) to 12.2k RMC + HSDPA .
  6. [DL Chan Code Config] Set Downlink Channel Configs ( Call Control 2 of 6 , Generator Info ( F3 ), F4 ):
    • [DL Chan Code Config] Set HS-SCCH 3, HS-SCCH 4 Channel Config State to Off . Leave the Secondary Cell H-SCCH 1 to 4 Channel Config State as default (under HS-SCCH Configs ( F3 )).
    • [DL Chan Code Config] Set HSDPA/HSPA OCNS 2 through HSDPA/HSPA OCNS 6 Chan Config State and Sec Cell HSDPA/HSPA OCNS 2 through HSDPA/HSPA OCNS 6 Chan Config State to Off (under HSDPA/HSPA OCNS Configs ( F4 )).
  7. [DL Chan Code Config] Set Downlink Channel Codes ( F6 twice, then F2 ):
    • [DL Chan Code Config] Set S-CCPCH Channelization Code to 2 , and set PICH Channelization Code to 2 and AICH Channelization Code to 3 (under Shared DL Channel Codes ( F2 )).
    • [DL Chan Code Config] Set HSDPA/HSPA Downlink Channel Codes ( F4 ):
      • [DL Chan Code Config] Set HSDPA/HSPA (F-)DPCH 15 ksps (OVSF 256) Code to 14 .
      • [DL Chan Code Config] Set HSDPA/HSPA DPCH 30 ksps (OVSF 128) Code to 7 .
      • [DL Chan Code Config] Set RB Test Mode First HS-PDSCH Channel Code to 1 .
      • [DL Chan Code Config] Set HS-SCCH 1 Channelization Code to 2 .
      • [DL Chan Code Config] Set HS-SCCH 2 Channelization Code to 3 .
      • [DL Chan Code Config] Set Secondary Serving Cell PICH Chan Code to 2 .
      • [DL Chan Code Config] Set RBTM Secondary Cell First HS-PDSCH Chan Code to 1 .
      • [DL Chan Code Config] Set Secondary Serving Cell HS-SCCH 1 Chan Code to 2 .
      • [DL Chan Code Config] Set Secondary Serving Cell HS-SCCH 2 Chan Code to 3 .
    • [DL Chan Code Config] Set OCNS Channel Codes ( F5 ). Select Cell1 HSDPA/HSPA OCNS Codes ( F3 ):
      • [DL Chan Code Config] Set HSDPA/HSPA OCNS 1 Channelization Code to 6 .
      • [DL Chan Code Config] Set Secondary Cell HSDPA/HSPA OCNS 1 Chan Code to 6 .
  8. [34.121 Call Config] Set HSDPA RB Test Mode Settings ( HSPA Parameters ( F10 ), HSDPA Parameters ( F10 ), HSDPA RB Test Mode Setup ( F8 ), F8 ):
    • [34.121 Call Config] Set RB Test HS-DSCH Configuration Type to User Defined .
    • [34.121 Call Config] Set RB Test User Defined HS-DSCH MAC entity to MAC-ehs .
    • [34.121 Call Config] Set RB Test User Defined HARQ Processes to 2 . (this is the default value)
    • [34.121 Call Config] Set RB Test User Defined UE IR Buffer Allocation to Explicit .
    • [34.121 Call Config] Set RB Test User Defined Explicit UE IR Buffer Size to 9600 .
    • [34.121 Call Config] Set RB Test User Defined DC-HSDPA State to On .
    • [34.121 Call Config] Set RB Test Mode DC-HSDPA DPCH Loopback State to On .
  9. [34.121 Call Config] Set Serving Cell Parms ( F10 ):
    • [34.121 Call Config] Set RB Test User Defined 64QAM State to Off .
    • [34.121 Call Config] Set RB Test User Defined MAC-ehs HS-DSCH TB size table to Bit Aligned .
    • [34.121 Call Config] Set RB Test User Defined Active HS-PDSCHs to 4 .
    • [34.121 Call Config] Set R B Test User Def Transport Block Size Index to 36 .
    • [34.121 Call Config] Set RB Test User Defined Modulation Type to 16QAM .
    • [34.121 Call Config] Set RB Test User Defined Inter-TTI Interval to 3 (this is the default value).
  10. [34.121 Call Config] Set Secondary Cell Parms ( F11 ):
    • [34.121 Call Config] Set RB Test User Def Secondary Cell 64QAM State to Off (this is the default value).
    • [34.121 Call Config] Set RBTM User Def Sec Cell HS-DSCH TBS Table to Bit Aligned .
    • [34.121 Call Config] Set RBTM User Def Sec Cell Active HS-PDSCHs to 4 .
    • [34.121 Call Config] Set RBTM User Def Sec Cell TB Size Index to 36 .
    • [34.121 Call Config] Set RBTM User Def Sec Cell Modulation Type to 16QAM . (this is the default value)
    • [34.121 Call Config] Set RBTM User Def Sec Cell Inter-TTI Interval to 3 . (this is the default value)
  11. [34.121 Call Config] Set MAC-(e)hs Parameters ( Return ( F12 ), F10 ):
    • [34.121 Call Config] Set Number of Transmissions to 1 .
    • [34.121 Call Config] Set RV Sequence to 6,0,0,0,0,0,0,0 (simply enter 6 and then press the knob, the remaining values are automatically filled with zeros).
    • [34.121 Call Config] Leave other MAC-(e)hs Parameters as default.
  12. [34.121 Call Config] Set Secondary Serv Cell Parms ( HSDPA Parms 2 of 2 , F8 ):
    • [34.121 Call Config] Set Secondary Serving Cell Power (dBm/3.84 MHz) to -25.7 dBm .
  13. [34.121 Call Config] Set UL CL Power Ctrl Algorithm to Two (under Call Parms 3 of 3 , UL CL Power Ctrl Parameters ( F8 ) (this is the default value).
  14. [34.121 Call Config] Set HSDPA Conn DL Channel Levels ( CALL SETUP , Call Control 2 of 6 , Generator Info ( F3 ), Downlink Channel Levels ( F3 ), Connected DL Channel Levels ( F3 ), F3 ):
    • [34.121 Call Config] Set HSDPA Cell 1 Connected CPICH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSDPA Cell 1 Connected P-CCPCH/SCH Level to -12 dB (this is the default value).
    • [34.121 Call Config] Set HSDPA Cell 1 Connected PICH Level to -15 dB (this is the default value).
    • [34.121 Call Config] Set HSDPA Cell 1 Connected DPCH Level to -13 dB .
    • [34.121 Call Config] Set HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) to -3 dB (this is the default value).
    • [34.121 Call Config] Set HSDPA Cell 1 Connected HS-SCCH 1 Level to -13 dB .
    • [34.121 Call Config] Set HSDPA Cell 1 Connected HS-SCCH 2 to Off . (this is the default value)
    • [34.121 Call Config] Set Secondary Cell HSDPA Conn CPICH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set Secondary Cell HSDPA Conn PCCPCH/SCH Level to -12 dB (this is the default value).
    • [34.121 Call Config] Set Secondary Cell HSDPA Conn PICH Level to -15 dB (this is the default value).
    • [34.121 Call Config] Set Secondary Cell HSDPA Conn HS-PDSCHs Lvl (Sum) to -3 dB (this is the default value).
    • [34.121 Call Config] Set Secondary Cell HSDPA Conn HS-SCCH 1 Level to -13 dB .
    • [34.121 Call Config] Set Secondary Cell HSDPA Conn HS-SCCH 2 Level to Off . (this is the default value)
  15. Set DL Channel and Uplink Channel to the proper mid range frequencies for your UE's operating band (under Channel (UARFCN) Parms ( CALL SETUP , F12 ).
  16. Set Operating Mode ( F1 ) to Active Cell .
  17. Set any other parameters needed to establish a connection with your UE, then power on the UE and wait for it to register (attach).
  18. Select Originate Call ( F3 on Call Control 1 of 6 ).
  19. Set UL CL Power Ctrl Mode to Active bits (under Call Parms 3 of 3 , UL CL Power Control Parameters ( F8 ) (this is the default value).
  20. Set UE Target Power ( Call Parms 3 of 3 , F7 ) to 18 dBm (for class 3 UE). This value is determined as follows. UE Target Power only sets the DPCCH+DPDCH power level of the UE. In order to achieve a total output power of 20 dBm as required by 3GPP TS 34.121-1 table 6.3C.4, you must set UE Target Power to 20 dBm - Power change due to HS-DPCCH. Power Change Due to HS-DPCCH = 10log 10 (Beta c ^2 + Beta d ^2 + Beta hs ^2) - 10log 10 (Beta d ^2 + Beta c ^2) = 2 dB, so you must set UE Target Power to 18 dBm . For Class 4 UE, set the UE Target Power to 16 dBm .
  21. Set UL CL Power Ctrl Mode to Alternating bits .
  22. Press the Measurement Selection key and select Channel Power .
  23. Select Channel Power Setup ( F1 ).
    • Set Auto Range to On .
    • Verify the UE's Channel Power is 20 dBm ± 1 dB for Class 3 UE.
  24. Press the Measurement Selection key and select HSDPA Block Error Ratio .
  25. Select HSDPA Blk Error Ratio Setup ( F1 ).
    • Set Number of blocks to test to 1000 . (this is the default value)
    • Set Trigger Arm to Single .
  26. Select Change View ( F2 ), then DC-HSDPA BLER ( F2 ).
  27. Press the START SINGLE key to begin the measurement. Wait approximately 3 seconds for the measurement to complete. Verify that the Information Bit Throughput on either Serving Cell or Sec Serv Cell exceeds 700 kbps, as required by 3GPP TS 34.121-1 table 6.3C.2.

Measuring 3GPP TS 34.121-1 6.3D Maximum Input Level for DC-HSDPA Reception (64QAM)

This example is for Active Cell Operating Mode. The measurement is also available in FDD Test Operating Mode.

  1. Set Operating Mode ( F1 ) to Cell Off .
  2. Select DL Chan Code Preset Configs ( Call Control 2 of 6 , Generator Info ( F3 ), Downlink Channel Configs ( F4 ), F5 ) and select 34.121 Tables E.6.2.3,4 (HSDPA 15 HS-PDSCHs) . You man then skip any steps marked with [DL Chan Code Config] in this procedure. This step mainly aims to avoid a possible code collision. Use the following 34.121 Preset settings to overwrite some of the parameters especially for 6.3D.
  3. Set Conn S-CCPCH Cfg to Off . Note: You must set this step after step 2 above, because the 34.121 Tables E.6.2.3,4 (HSDPA 15 HS-PDSCHs) preset will set the Conn S-CCPCH Cfg to On, in which case the code collision would occur.
  4. Select 34.121 Preset Call Configs ( F11 on Call Parms 1 of 3 ) and select 6.3D: DC-HSDPA: 64QAM . You may then skip any steps marked with [34.121 Call Config] in this procedure.
  5. [34.121 Call Config] Set Cell Power ( F7 ) to -25.7 dB .
  6. [34.121 Call Config] Set Channel Type ( F8 ) to 12.2k RMC + HSDPA .
  7. [DL Chan Code Config] Set Downlink Channel Configs ( Call Control 2 of 6 , Generator Info ( F3 ), F4 ):
    • [DL Chan Code Config] Set HSDPA/HSPA OCNS 2 through HSDPA/HSPA OCNS 6 Chan Config State and Sec Cell HSDPA/HSPA OCNS 2 through HSDPA/HSPA OCNS 6 Chan Config State to Off (under HSDPA/HSPA OCNS Configs ( F4 )).
    • [DL Chan Code Config] Set HS-SCCH 3 and HS-SCCH 4 Channel Config State to Off (under HS-SCCH Configs ( F3 )). Leave the Secondary Cell H-SCCH 1 to 4 Channel Config State as default (under HS-SCCH Configs ( F3 )).
  8. [34.121 Call Config] Set Downlink Channel Codes ( F6 twice, then Generator Info ( F2 ), F2 ):
    • [34.121 Call Config] Set PICH Channelization Code to 2 and AICH Channelization Code to 3 (under Shared DL Channel Codes ( F2 )).
    • [34.121 Call Config] Set HSDPA/HSPA Downlink Channel Codes ( F4 ):
      • [34.121 Call Config] Set HSDPA/HSPA DPCH 30 ksps (OVSF 128) Code to 4 .
      • [34.121 Call Config] Set RB Test Mode First HS-PDSCH Channel Code to 1 .
      • [34.121 Call Config] Set HS-SCCH 1 Channelization Code to 2 .
      • [34.121 Call Config] Set HS-SCCH 2 Channelization Code to 3 .
      • [DL Chan Code Config] Set Secondary Serving Cell PICH Chan Code to 2 .
      • [DL Chan Code Config] Set RBTM Secondary Cell First HS-PDSCH Chan Code to 1 .
      • [DL Chan Code Config] Set Secondary Serving Cell HS-SCCH1 Chan Code to 2 .
      • [DL Chan Code Config] Set Secondary Serving Cell HS-SCCH2 Chan Code to 3 .
    • [DL Chan Code Config] Set OCNS Channel Codes ( F5 ). Select Cell1 HSDPA/HSPA OCNS Codes ( F3 ):
      • [DL Chan Code Config] Set HSDPA/HSPA OCNS 1 Channelization Code to 6 .
      • [DL Chan Code Config] Set Secondary Cell HSDPA/HSPA OCNS1 Chan Code to 6 .
  9. [34.121 Call Config] Set HSDPA RB Test Mode Settings ( HSPA Parameters ( F10 ), HSDPA Parameters ( F10 ), HSDPA RB Test Mode Setup ( F8 ), F8 ):
    • [34.121 Call Config] Set RB Test HS-DSCH Configuration Type to FRC .
    • [34.121 Call Config] Set FRC Type to H-Set 8A 64QAM .
    • [34.121 Call Config] Set RB Test Mode DC-HSDPA DPCH Loopback State to On .
  10. [34.121 Call Config] Set MAC-(e)hs Parameters ( Return ( F12 ), F10 ):
    • [34.121 Call Config] Set Number of Transmissions to 1 .
    • [34.121 Call Config] Set RV Sequence to 6,0,0,0,0,0,0,0 (simply enter 6 and then press the knob, the remaining values are automatically filled with zeros).
    • [34.121 Call Config] Leave other MAC-hs parameters as default.
  11. [34.121 Call Config] Set Secondary Serv Cell Parms ( HSDPA Parms 2 of 2 , F8 ):
    • [34.121 Call Config] Set Secondary Serving Cell Power (dBm/3.84 MHz) to -25.7 dBm .
  12. [34.121 Call Config] Set UL CL Power Ctrl Algorithm to Two (under Call Parms 3 of 3 , UL CL Power Ctrl Parameters ( F8 ) (this is the default value).
  13. [34.121 Call Config] Set HSDPA Conn DL Channel Levels ( CALL SETUP , Call Control 2 of 6 , Generator Info ( F3 ), Downlink Channel Levels ( F3 ), Connected DL Channel Levels ( F3 ), F3 ):
    • [34.121 Call Config] Set HSDPA Cell 1 Connected CPICH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSDPA Cell 1 Connected P-CCPCH/SCH Level to -12 dB (this is the default value).
    • [34.121 Call Config] Set HSDPA Cell 1 Connected PICH Level to -15 dB (this is the default value).
    • [34.121 Call Config] Set HSDPA Cell 1 Connected DPCH Level to -13 dB .
    • [34.121 Call Config] Set HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) to -2 dB .
    • [34.121 Call Config] Set HSDPA Cell 1 Connected HS-SCCH 1 Level to -13 dB .
    • [34.121 Call Config] Set HSDPA Cell 1 Connected HS-SCCH 2 Level to -13 dB .
    • [34.121 Call Config] Set Secondary Cell HSDPA Conn CPICH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set Secondary Cell HSDPA Conn PCCPCH/SCH Level to -12 dB (this is the default value).
    • [34.121 Call Config] Set Secondary Cell HSDPA Conn PICH Level to -15 dB (this is the default value).
    • [34.121 Call Config] Set Secondary Cell HSDPA Conn HS-PDSCHs Lvl (Sum) to -2 dB .
    • [34.121 Call Config] Set Secondary Cell HSDPA Conn HS-SCCH 1 Level to -13 dB .
    • [34.121 Call Config] Set Secondary Cell HSDPA Conn HS-SCCH 2 Level to -13 dB .
  14. Set DL Channel and Uplink Channel to the proper mid range frequencies for your UE's operating band (under Channel (UARFCN) Parms ( CALL SETUP , F12 ).
  15. Set Operating Mode ( F1 ) to Active Cell .
  16. Set any other parameters needed to establish a connection with your UE, then power on the UE and wait for it to register (attach).
  17. Select Originate Call ( F3 on Call Control 1 of 6 ).
  18. Set UL CL Power Ctrl Mode to Active bits (under Call Parms 3 of 3 , UL CL Power Control Parameters ( F8 ) (this is the default value).
  19. [34.121 Call Config] Set UE Target Power ( Call Parms 3 of 3 , F7 ) to -2 dBm. This value is determined as follows. UE Target Power only sets the DPCCH+DPDCH power level of the UE. In order to achieve a total output power of 0 dBm as required by 3GPP TS 34.121-1 table 6.3D.4, you must set UE Target Power to 0 dBm - Power change due to HS-DPCCH. Power Change Due to HS-DPCCH = 10log 10 (Beta c ^2 + Beta d ^2 + Beta hs ^2) - 10log 10 (Beta d ^2 + Beta c ^2) = 2 dB, so you must set UE Target Power to -2 dBm .
  20. Set UL CL Power Ctrl Mode to Alternating bits .
  21. Press the Measurement Selection key and select Channel Power.
  22. Select Channel Power Setup ( F1 ).
    • Set Auto Range to On .
    • Verify the UE's Channel Power is 0 dBm ± 1 dB.
  23. Press the Measurement Selection key and select HSDPA Block Error Ratio .
  24. Select HSDPA Blk Error Ratio Setup ( F1 ).
    • Set Number of blocks to test to 1000 .
    • Leave the Block to Test Specified Per Serving Cell to its default Off .
    • Set Trigger Arm to Single .
  25. Select Change View ( F2 ), then DC-HSDPA BLER ( F2 ).
  26. Press the START SINGLE key to begin the measurement. Wait approximately 3 seconds for the measurement to complete. Verify that the Information Bit Throughput on either the Serving Cell or the Sec Serv Cell exceeds 11800 kbps, as required by 3GPP TS 34.121-1 table 6.3D.2.

Related Topics

HSDPA Block Error Ratio Measurement Description


How Do I Make an HSDPA Reporting Channel Quality Indicator Measurement?

How Do I Make an HSDPA Reporting Channel Quality Indicator Measurement?

Last updated: January 15, 2009

Measuring 3GPP TS 34.121 9.3.1 Single Link Performance -AWGN Propagation Conditions

  1. Ensure that you have specified the proper Amplitude Offset for your test setup.
  2. Ensure that the test set has been properly calibrated (see Calibrating the Test Set ).
  3. Set the non-measurement specific parameters that are called out in the 3GPP standards. See Parameters that Affect the HSDPA Reporting of Channel Quality Indicator Measurement .
  4. Establish an RB Test Mode - HSDPA connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  5. Press the Measurement selection key.
  6. Select Reporting of Channel Quality Indicator .
  7. Select HSDPA Reporting of CQI Setup ( F1 ).

    • Configure the setup parameters as shown in the figure below (these default settings align with the settings described in 3GPP TS 34.121 9.3.1):

    • Select Close Menu ( F6 ).
  8. Press the START SINGLE key.
  9. Verify that the overall test result is Pass .

Related Topics

HSDPA Reporting of Channel Quality Indicator Measurement Description


How Do I Make a Loopback Bit Error Ratio (BER) Measurement?

How Do I Make a Loopback Bit Error Ratio (BER) Measurement?

Last updated: January 15, 2009

Measuring Loopback Bit Error Ratio

  1. Press the Measurement selection key.
  2. Select the Loopback Bit Error Ratio measurement.
  3. Select Bit Error Setup ( F1 ).
    • Set Number of Bits to Test to 10000 .
    • Set Trigger Arm to Single .
    • Set Confidence Level to 99.80% (press the ON key).
    • Set BER Requirement to 0.10% .
    • Set Uplink DTCH RMC CRC Presence to Present and UE Loopback Type to Type 1 .

    Select Close Menu ( F6 ).

  4. Establish an RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  5. Set UE Target Power to +21 dBm (for a Power Class 4 UE).
  6. Set Cell Power ( F7 ) to -106 dBm (for Operating Band I).
  7. Press the START SINGLE key to begin the measurement.
  8. If the Confidence Test Result is Max Bits Tested , start the measurement again. You may need to increase the Number of Bits to Test to enable a Pass or Fail result.
  9. Adjust Cell Power ( F7 ), AWGN Power ( F4 ), Soft Handover ( F3 ) and Cell 2 Power ( F2 ) as desired.

An example measurement result is shown below:

Related Topics

Loopback Bit Error Ratio (BER) Measurement Description


How Do I Make an Adjacent Channel Leakage Ratio (ACLR) Measurement?

How Do I Make an Adjacent Channel Leakage Ratio (ACLR) Measurement?

Last updated: February 12, 2011

  • Measuring Adjacent Channel Leakage Ratio
  • Measuring 3GPP TS 34.121-1 (v8.10.0) 5.10B Adjacent Channel Leakage Ratio (ACLR) with E-DCH (lab application or feature-licensed test application only)

NOTE
Before performing this measurement, ensure that the test set has been properly calibrated (see Calibrating the Test Set ).

Measuring Adjacent Channel Leakage Ratio

  1. Establish an RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  2. Press the Measurement selection key.
  3. Select Adjacent Channel Leakage Ratio .
  4. Select ACLR Setup ( F1 ):
    • Set the measurement parameters as needed for your measurement situation, such as turning the measurements on or off for the different frequency offsets.
    • Select Close Menu ( F6 ).
  5. If Trigger Arm is set to Single , you must press the START SINGLE key to begin the measurement.
  6. Press the Change View ( F2 ) key to display the measurement results in either graphical or numeric format.
  7. If using the graphical display, press Graph Limits ( F5 ) to enter the pass/fail measurement limit for each of the four frequency offsets (shown in the graphical measurements example below as the thin lines above each measurement).

A typical result is shown below.

Measuring 3GPP TS 34.121-1 (v8.10.0) 5.10B Adjacent Channel Leakage Ratio (ACLR) with E-DCH

This section is applicable to the lab application or feature-licensed test application only.

  1. Set parameters that can only be set in cell off operating mode (and other parameters that are set from the same menu):
    • Set Operating Mode ( F1 ) to Cell Off .
    • Select 34.121 Preset Call Configurations ( F11 on Call Parms 1 of 3 ) and select 5.2B, 5.9B, 5.10B, and 5.13.2B:HSPA:QPSK , then select the desired sub-test. You may then skip any steps marked with [34.121 Call Config] in this procedure.
    • Select Channel (UARFCN) Parms ( F12 on Call Parms 1 of 3 ). Set DL Channel ( F7 ) to the appropriate "low range" frequency for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band II set DL Channel = 9663 ).
    • [34.121 Call Config] Select Uplink Parameters ( F4 on Call Control 2 of 6 ).
      • [34.121 Call Config] Set Uplink DPCH Bc/Bd Control to Manual .
      • [34.121 Call Config] Set Manual Uplink DPCH Bc to 11 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
      • [34.121 Call Config] Set Manual Uplink DPCH Bd to 15 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
      • [34.121 Call Config] Set Maximum Uplink Transmit Power Level to 21 dBm .
    • Set Operating Mode to Active Cell (pressing the CALL SETUP key quickly brings you back to the top level Call Control menu).
  2. Set Cell Power ( F7 on Call Parms 1 of 3 ) to -86 dBm/3.84 MHz .
  3. [34.121 Call Config] Set Channel Type ( F8 ) to 12.2k RMC + HSPA (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
  4. [34.121 Call Config] Select Generator Info ( F3 on Call Control 2 of 6 ), select Downlink Channel Levels ( F3 ), select Connected DL Channel Levels ( F3 ), then select HSPA Conn DL Channel Levels ( F4 ).
    • [34.121 Call Config] Set HSPA Cell 1 Connected CPICH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected P-CCPCH/SCH Level to -12 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected PICH Level to -15 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected (F-)DPCH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-AGCH Level to -20 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-HICH Level to -20 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-RGCH Level to Off (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected HS-PDSCHs Level (Sum) to -3 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected HS-SCCH 1 Level to -8 dB .
  5. [34.121 Call Config] Select HSUPA Parameters ( HSPA Parameters ( F10 ), F9 ).
    • [34.121 Call Config] Select HSUPA RB Test Mode Setup ( F8 ).
      • [34.121 Call Config] Set E-DCH RLC SDU Size to 2936 (this is the default value).
    • [34.121 Call Config] Select Common HSUPA Parameters ( F9 ).
      • [34.121 Call Config] Set E-DPCCH/DPCCH Power Offset (DeltaE-DPCCH) to 6 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1). Note, 34.121-1 Table C.11.1.3 provides Beta ec (209/225 for sub-test 1). To determine what value of DeltaE-DPCCH corresponds to this, use 3GPP TS 25.213 Table 1B and the value of Beta c from 34.121-1 Table C.11.1.3 (11/15 for sub-test 1). For sub-test 1, A ec = Beta ec /Beta c = (209/225)/(11/15) = 19/15; therefore DeltaE-DPCCH = 6.
      • [34.121 Call Config] Set Reference E-TFCI Power Offsets to Definition 34.121-01 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
    • [34.121 Call Config] Select Serving Grant ( F10 ).
      • [34.121 Call Config] Set RB Setup AG to 26: (119/15)^2 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1). Note, 34.121-1 Table C.11.1.3 AG Index corresponds to 3GPP TS 25.212 s4.10.1A.1 Table 16B, which maps the Absolute Grants sent on the E-AGCH. To send the equivalent Absolute Grant in the RB Setup message, you must use the AG Index in 3GPP TS 25.321 s9.2.5.2.1 Table 9.2.5.2.1.1.
  6. [34.121 Call Config] Select HSDPA Parameters ( HSPA Parameters ( F10 ), F10 ).
    • [34.121 Call Config] Select HSDPA RB Test Mode Setup ( F8 ), then select HSDPA RB Test Mode Settings ( F8 ).
      • [34.121 Call Config] Set RB Test HS-DSCH Configuration Type to FRC (this is the default value).
      • [34.121 Call Config] Set FRC Type to H-Set 1 QPSK (this is the default value).
    • [34.121 Call Config] Select HSDPA Uplink Parameters ( F11 ).
      • [34.121 Call Config] Set DeltaACK , DeltaNACK and DeltaCQI to 8 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
      • [34.121 Call Config] Set Ack-Nack Repetition Factor to 3 .
      • [34.121 Call Config] Set CQI Feedback Cycle (k) to 4 ms .
      • [34.121 Call Config] Set CQI Repetition Factor to 2 .
  7. Test Application: Select Cell Parameters ( F2 ).
    Lab Application: Select Cell Info ( F2 ), then Cell Parameters ( F2 ).
    ( from the Call Control 2 of 6 menu)
    • Set PS Domain Information to Present (this is the default value in the lab application).
    • Qqualmin and Qrxlevmin are fixed to -24 dB and -115 dBm, respectively, in the test application. In the lab application these are the default values for these parameters. They are accessible from Cell Info , Reselection Parameters ( F3 ).
  8. [34.121 Call Config] Select RB Test Mode Setup ( F6 on Call Control 3 of 6 ) and set UE Loopback Type to Type 1 (this is the default value).
  9. [34.121 Call Config] Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Algorithm to Two (this is the default value) (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
  10. Set any other parameters needed to establish a connection with your UE, then power on the UE and wait for it to register (attach). See Establishing an HSPA Connection .
    Note, before you can establish a connection in the PS domain (as is required for HSPA connections), the UE must attach to the test set. To enable this, the PS Domain Information parameter must be set to Present when the UE registers (attaches) with the test set.
  11. Select Originate Call ( F3 on Call Control 1 of 6 ).
  12. Drive the UE to maximum power:
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Mode to Active bits (this is the default value).
    • Set UE Target Power ( F7 on Call Parms 3 of 3 ) to 2 dBm (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1, power class 3 UE). This value is determined as follows: Maximum power for a power class 3 UE is +24 dBm, but UE Target Power only sets the DPCCH+DPDCH power level of the UE. In order to achieve a total output power of +16.5 dBm (24 dBm - 7.5 dB), you must set UE Target Power to at most 16.5 dBm - Power change due to HS-DPCCH, E-DPCCH and E-DPDCH .
      Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH = 10log 10 (Beta c ^2 + Beta d ^2 + Beta hs ^2 + Beta ec ^2 + Beta ed ^2) - 10log 10 (Beta d ^2 + Beta c ^2) = 14 dB for sub-test 1, so you must set UE Target Power to 2 dBm for sub-test 1.
      The UE Target Power values for sub-tests 2-5 are as follows: sub-test 2: 11 dBm, sub-test 3: 3 dBm, sub-test 4: 14 dBm, sub-test 5: 6 dBm.
    • Wait 150 ms.
    • Press the Measurement selection key and select Channel Power .
    • Set up the measurement:
      • Select Channel Power Setup ( F1 ).
      • Set Auto Range = On (or leave Auto Range = Off and set Manual Power Range to the Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH value calculated above).
      • Select Close Menu ( F6 ).
    • Observe the channel power measurement result to ensure that the UE's output power is at least 7.5 dB below max power (<18 dBm for power class 3 UEs).
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to Alternating bits (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
    • Select Additional Screens ( F1 from Call Control 2 of 6 ), select HSPA Information ( F2 ) and observe the Last Received E-TFCI (it should be 75 for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1, 67 for sub-test 2, 92 for sub-test 3, 71 for sub-test 4 and 67 for sub-test 5).
    • Select E-TFCI Recording Information ( F3 ) (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
    • Select HSPA Parameters ( F10 ), HSUPA Parameters ( F9 ), E-TFCI Recording ( F11 ), E-TFCI Recording Parameters ( F7 ) (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1):
      • [34.121 Call Config] Set E-TFCI Recording Count ( F7 ) to 15 (this is the default value).
      • Select Send Step Up TPC Bit Pattern ( F10 ) and then Start Recording E-TFCI Values ( F8 ).
      • Observe whether the UE sent any decreased E-TFCI. If not, send another up TPC bit and record E-TFCI. Repeat until the UE sends at least one decreased E-TFCI.
      • Select Send Step Down TPC Bit Pattern ( F11 ) and then Start Recording E-TFCI Values ( F8 ).
      • Observe whether the UE sent any decreased E-TFCI. If it did, then send another down TPC bit, then continue to the next step. If not, continue to the next step.
      • Confirm that the E-TFCI is equal to the target E-TFCI of 75 for sub-test 1. If not, fail the UE. Note that an E-TFCI of 75 corresponds to an uplink data rate of 2421 bits/10 ms = 242 kbps. The uplink data rate for sub-test 2 = 175 kbps, sub-test 3 = 483 kbps, sub-test 4 = 206 kbps and sub-test 5 = 175 kbps.
  13. Press the Measurement selection key and select Adjacent Channel Leakage Ratio .
  14. Measure ACLR and determine whether the result is within the range specified by 3GPP TS 34.121 table 5.10B.2.
  15. To repeat this test for sub-tests 2-5:
    • Perform a Transport Channel Reconfiguration ( Handovers ( F5 )) to change the following settings:
      Sub-test 2-5 Transport Channel Reconfiguration settings
      Setting | Sub-test 2 | Sub-test 3 | Sub-test 4 | Sub-test 5
      TCR DPCH Bc/Bd Control | Manual | Manual | Manual | Manual
      TCR Manual Uplink DPCH Bc | 6 | 15 | 2 | 15
      TCR Manual Uplink DPCH Bd | 15 | 9 | 15 | 0
      TCR DeltaACK, DeltaNACK, DeltaCQI | 8 | 8 | 8 | 0
      TCR Ack-Nack Repetition Factor | 3 | 3 | 3 | 3
      TCR CQI Feedback Cycle (k) | 4 ms | 4 ms | 4 ms | 4 ms
      TCR CQI Repetition Factor | 2 | 2 | 2 | 2
      TCR E-DPCCH/DPCCH Power Offset | 8 | 8 | 5 | 0
      TCR Reference E-TFCI Power Offsets | 34121-01 | 34121-02 | 34121-01 | 34121-03
      TCR Absolute Grant | 18: (47/15)^2 | 21: (67/15)^2 | 23: (84/15)^2 | 18: (47/15)^2
    • For sub-tests 2-4, repeat steps 12 and 14.
    • For sub-test 5, end the call ( F3 ) and proceed as follows.
      • Set Channel Type ( F8 ) to HSPA .
      • Select HSUPA RB Test Mode Setup ( F8 ) and set RB E-DPDCH Max Channel Codes (HSPA) to SF4 .
      • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Algorithm to One .
      • Select Originate Call ( F3 on Call Control 1 of 6 ).
      • Drive the UE to maximum power:
        • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Mode to Active bits .
        • Set UE Target Power ( F7 on Call Parms 3 of 3 ) to 6 dBm (for power class 3 UE).
        • Wait 150 ms.
        • Observe the channel power measurement result (pressing the MEASUREMENT key quickly brings you to the channel power measurement screen) to ensure that the UE's output power is at least 7.5 dB below max power (<16.5 dBm for power class 3 UEs).
        • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to All Up bits .
        • Wait 150 ms.
      • Repeat step 15.
  16. End the call ( F3 ).
  17. Repeat the testing at mid and high range frequencies.

Related Topics

Adjacent Channel Leakage Ratio (ACLR) Measurement Description


How Do I Make a Block Error Ratio (BLER) Measurement?

How Do I Make a Block Error Ratio (BLER) Measurement?

Last updated: January 15, 2009

Measuring Block Error Ratio

  1. Press the Measurement selection key.
  2. Select the Block Error Ratio measurement.
  3. Select Block Error Setup ( F1 ) and set the measurement parameters as needed.
    • For Symmetrical RMCs , you must set Uplink DTCH RMC CRC Presence to Used for Data and UE Loopback Type to Type 2 .
    • Select Close Menu ( F6 ).
  4. Establish an RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  5. If Trigger Arm is set to Single , you must press the START SINGLE key to begin the measurement.
    NOTE

    The time for the measurement to complete increases linearly with the Number of Blocks to Test . For example, to test 500 blocks while on a 12.2k RMC takes approximately 10 seconds (500 blocks x 20 ms/block = 10 seconds). A measurement result is not displayed until the Number of Blocks to Test has been tested. If you are testing more than 500 blocks, the block counter increments every 500 blocks to indicate measurement progress.

  6. Adjust Cell Power ( F7 ), AWGN Power ( F4 ), Soft Handover ( F3 ) and Cell 2 Power ( F2 ) as desired.

An example measurement result is shown below:

For an example of performing BLER measurements while on a faded channel, refer to the:

E5515C Fading Solution Application Guide

It can be downloaded at http://cp.literature.agilent.com/litweb/pdf/1000-1894.pdf .

Related Topics

Block Error Ratio (BLER) Measurement Description


How Do I Make a Code Domain Measurement?

How Do I Make a Code Domain Measurement?

Last updated: June 9, 2011

  • Measuring Code Domain
  • Measuring 3GPP TS 34.121-1 (v8.10.0) 5.2D UE Relative Code Domain Power Accuracy for HS-DPCCH and E-DCH (lab application or feature-licensed test application only)
  • Measuring 3GPP TS 34.121-1 (v8.10.0) s5.2E UE Relative Code Domain Power Accuracy for HS-DPCCH and E-DCH with 16QAM (lab application or feature-licensed test application only)
  • Measuring 3GPP TS 34.121-1 (v8.10.0) s5.13.1AAA EVM and IQ origin offset for HS-DPCCH and E-DCH with 16 QAM (lab application or feature-licensed test application only)
  • Measuring 3GPP TS 34.121-1 (v8.10.0) 5.13.2B Relative Code Domain Error with HS-DPCCH and E-DCH (lab application or feature-licensed test application only)
  • Measuring 3GPP TS 34.121-1 (v8.10.0) s5.13.2C Relative Code Domain Error for HS-DPCCH and E-DCH with 16QAM (lab application or feature-licensed test application only)

NOTE
Before performing a code domain measurement, ensure that the test set has been properly calibrated (see Calibrating the Test Set ).

Measuring Code Domain

  1. Establish an RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  2. Press the Measurement selection key.
  3. Select Code Domain .
  4. Select Code Domain Setup ( F1 ) and set the measurement parameters as needed. Select Close Menu ( F6 ).
  5. Set Cell Power ( F7 ) as needed.
  6. If Trigger Arm is set to Single , you must press the START SINGLE key to begin the measurement.
  7. Select Axis Control ( F2 ). Set the axis control parameters as needed. Select Return ( F6 ).
  8. Select Marker ( F3 ) to turn on the marker on the graphical display.

A typical result is shown below.

Measuring 3GPP TS 34.121-1 (v8.10.0) 5.2D UE Relative Code Domain Power Accuracy for HS-DPCCH and E-DCH

This section is applicable to the lab application or feature-licensed test application only.

  1. Set parameters that can only be set in cell off operating mode (and other parameters that are set from the same menu):
    • Set Operating Mode ( F1 ) to Cell Off .
    • Select 34.121 Preset Call Configurations ( F11 on Call Parms 1 of 3 ) and select 5.2D:HSPA:QPSK . You may then skip any steps marked with [34.121 Call Config] in this procedure.
    • Select Channel (UARFCN) Parms ( F12 on Call Parms 1 of 3 ). Set DL Channel ( F7 ) to the appropriate "mid range" frequency for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band II set DL Channel = 9800 ).
    • [34.121 Call Config] Select Uplink Parameters ( F4 on Call Control 2 of 6 ).
      • [34.121 Call Config] Set Uplink DPCH Bc/Bd Control to Manual .
      • [34.121 Call Config] Set Manual Uplink DPCH Bc to 11 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
      • [34.121 Call Config] Set Manual Uplink DPCH Bd to 15 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
      • [34.121 Call Config] Set Maximum Uplink Transmit Power Level to +21 dBm .
    • Set Operating Mode to Active Cell (pressing the CALL SETUP key quickly brings you back to the top level Call Control menu).
  2. Set Cell Power ( F7 on Call Parms 1 of 3 ) to -86 dBm/3.84 MHz .
  3. [34.121 Call Config] Set Channel Type ( F8 ) to 12.2k RMC + HSPA .
  4. [34.121 Call Config] Select Generator Info ( F3 on Call Control 2 of 6 ), select Downlink Channel Levels ( F3 ), select Connected DL Channel Levels ( F3 ), then select HSPA Conn DL Channel Levels ( F4 ).
    • [34.121 Call Config] Set HSPA Cell 1 Connected CPICH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected P-CCPCH/SCH Level to -12 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected PICH Level to -15 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected (F-)DPCH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-AGCH Level to -20 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-HICH Level to -20 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-RGCH Level to Off (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected HS-PDSCHs Level (Sum) to -3 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected HS-SCCH 1 Level to -8 dB .
  5. Select HSUPA Parameters ( HSPA Parameters ( F10 ), F9 ).
    • [34.121 Call Config] Select HSUPA RB Test Mode Setup ( F8 ).
      • [34.121 Call Config] Set E-DCH RLC SDU Size to 2936 (this is the default value).
    • [34.121 Call Config] Select Common HSUPA Parameters ( F9 ).
      • [34.121 Call Config] Set E-DPCCH/DPCCH Power Offset (DeltaE-DPCCH) to 6 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1). Note, 34.121-1 Table C.11.1.3 provides Beta ec (209/225 for sub-test 1). To determine what value of DeltaE-DPCCH corresponds to this, use 3GPP TS 25.213 Table 1B and the value of Beta c from 34.121-1 Table C.11.1.3 (11/15 for sub-test 1). For sub-test 1, A ec = Beta ec /Beta c = (209/225)/(11/15) = 19/15; therefore DeltaE-DPCCH = 6.
      • [34.121 Call Config] Set Reference E-TFCI Power Offsets to Definition 34.121-01 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
    • Select Serving Grant ( F10 ).
      • [34.121 Call Config] Set RB Setup AG to 26: (119/15)^2 (for34.121-1 v8.10.0 Table C.11.1.3 sub-test 1). Note, 34.121-1 Table C.11.1.3 AG Index corresponds to 3GPP TS 25.212 s4.10.1A.1 Table 16B, which maps the Absolute Grants sent on the E-AGCH. To send the equivalent Absolute Grant in the RB Setup message, you must use the AG Index in 3GPP TS 25.321 s9.2.5.2.1.1 Table 9.2.5.2.1.1.
      • Set AG Mode ( F7 ) to Single Shot (this is the default value).
      • Select AG Pattern Parameters ( F11 ):
        • Set Absolute Grant Pattern - Value 1 to 20: (119/15)^2 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
        • Set Absolute Grant Pattern - Value 2 to 1: ZERO_GRANT (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
  6. [34.121 Call Config] Select HSDPA Parameters ( HSPA Parameters ( F10 ), F10 ).
    • [34.121 Call Config] Select HSDPA RB Test Mode Setup ( F8 ), then select HSDPA RB Test Mode Settings ( F8 ).
      • [34.121 Call Config] Set RB Test HS-DSCH Configuration Type to FRC (this is the default value).
      • [34.121 Call Config] Set FRC Type to H-Set 1 QPSK (this is the default value).
    • [34.121 Call Config] Select HSDPA Uplink Parameters ( F11 ).
      • [34.121 Call Config] Set DeltaACK , DeltaNACK and DeltaCQI to 8 .
      • [34.121 Call Config] Set Ack-Nack Repetition Factor to 3 .
      • [34.121 Call Config] Set CQI Feedback Cycle (k) to 4 ms .
      • [34.121 Call Config] Set CQI Repetition Factor to 2 .
  7. Test Application: Select Cell Parameters ( F2 ).
    Lab Application: Select Cell Info ( F2 ), then Cell Parameters ( F2 ).
    (from the Call Control 2 of 6 menu)
    • Set PS Domain Information to Present (this is the default value in the lab application).
    • Qqualmin and Qrxlevmin are fixed to -24 dB and -115 dBm, respectively, in the test application. In the lab application these are the default values for these parameters. They are accessible from Cell Info , Reselection Parameters ( F3 ).
  8. [34.121 Call Config] Select RB Test Mode Setup ( F6 on Call Control 3 of 6 ) and set UE Loopback Type to Type 1 (this is the default value).
  9. [34.121 Call Config] Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Algorithm to Two (this is the default value).
  10. Set any other parameters needed to establish a connection with your UE, then power on the UE and wait for it to register (attach). See Establishing an HSPA Connection .
    Note, before you can establish a connection in the PS domain (as is required for HSPA connections), the UE must attach to the test set. To enable this, the PS Domain Information parameter must be set to Present when the UE registers (attaches) with the test set.
  11. Select Originate Call ( F3 on Call Control 1 of 6 ).
  12. Drive the UE to 15 dBm +/- 2 dB output power:
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Mode to Active bits (this is the default value) .
    • Set UE Target Power ( F7 on Call Parms 3 of 3 ) to 1 dBm (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1). This value is determined as follows: UE Target Power only sets the DPCCH+DPDCH power level of the UE. In order to achieve a total output power of +15 dBm +/-24 dB, you must set UE Target Power to 15 dBm - Power change due to HS-DPCCH, E-DPCCH and E-DPDCH .
      Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH = 10log 10 (Beta c ^2 + Beta d ^2 + Beta hs ^2 + Beta ec ^2 + Beta ed ^2) - 10log 10 (Beta d ^2 + Beta c ^2) = 14 dB for sub-test 1, so you must set UE Target Power to 1 dBm for sub-test 1.
      The UE Target Power values for sub-tests 2-4 are as follows: sub-test 2: 10 dBm, sub-test 3: 2 dBm, sub-test 4: 13 dBm.
    • Select Additional Screens ( F1 from Call Control 2 of 6 ), select HSPA Information ( F2 ) and observe the Last Received E-TFCI (it should be 75 for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1, 67 for sub-test 2, 92 for sub-test 3, and 71 for sub-test 4). If the E-TFCI value is not correct, fail the UE. Note that an E-TFCI of 75 corresponds to an uplink data rate of 2421 bits/10 ms = 242 kbps. The uplink data rate for sub-test 2 = 175 kbps, sub-test 3 = 483 kbps, and sub-test 4 = 206 kbps.
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to Alternating bits .
  13. Select HSPA Parameters ( F10 ), HSUPA Parameters ( F9 ), Serving Grant ( F10 ) and set AG Mode ( F7 ) to Pattern .
  14. Press the Measurement selection key and select Code Domain .
  15. Select Code Domain Setup ( F1 ) and set Trigger Source to Even Frame .
  16. Measure RCDPA for the following code domain measurement configurations:
    Measurement Points
    Measurement Point | Timeslot | SFN Alignment
    1 | 14 | Odd
    2 | 0 | Even
    3 | 0 | Odd
    • If desired, show the NCDP measurement result by selecting Graph Control ( F2 ) and set Table ( F3 ) to 2 (so that you can compare the NCDP result with 3GPP TS 34.121-1 table 5.2D.7).
    • Use the Marker ( F2 under Graph Control ( F2 )) to ensure that the RCDPA result for each code channel meets the specified requirements in 34.121-1 table 5.2D.8. The code channels are located as follows:
      Code Channels
      Code Channel | Location | Marker
      DPCCH | Q Cch,256,0 | 0
      DPDCH | I Cch,64,16 | 64
      HS-DPCCH | Q Cch,256,64 | 64
      E-DPCCH | I Cch,256,1 | 1
      E-DPDCH1 | I Cch,4,2 | 128
      E-DPDCH2 | Q Cch,4,2 | 128
  17. To repeat this test for sub-tests 2-4 (sub-test 5 is not used with 34.121-1 V8.10.0 5.2D):
    • Select HSPA Parameters ( F10 ), HSUPA Parameters ( F9 ), Serving Grant ( F10 ) and set AG Mode ( F7 ) to Single Shot .
    • Perform a Transport Channel Reconfiguration ( Handovers ( F5 )) to change the following settings:
      Sub-test 2-4 Transport Channel Reconfiguration settings
      Setting | Sub-test 2 | Sub-test 3 | Sub-test 4
      TCR DPCH Bc/Bd Control | Manual | Manual | Manual
      TCR Manual Uplink DPCH Bc | 6 | 15 | 2
      TCR Manual Uplink DPCH Bd | 15 | 9 | 15
      TCR DeltaACK, DeltaNACK, DeltaCQI | 8 | 8 | 8
      TCR Ack-Nack Repetition Factor | 3 | 3 | 3
      TCR CQI Feedback Cycle (k) | 4 ms | 4 ms | 4 ms
      TCR CQI Repetition Factor | 2 | 2 | 2
      TCR E-DPCCH/DPCCH Power Offset | 8 | 8 | 5
      TCR Reference E-TFCI Power Offsets | 34121-01 | 34121-02 | 34121-01
      TCR Absolute Grant | 18: (47/15)^2 | 21: (67/15)^2 | 23: (84/15)^2
    • Repeat step 12.
    • Select HSPA Parameters ( F10 ), HSUPA Parameters ( F9 ), Serving Grant ( F10 ), AG Pattern Parameters ( F11 ) and set Absolute Grant Pattern - Value 1 to 12: (47/15)^2 for sub-test 2, 15: (67/15)^2 for sub-test 3 and 17: (84/15)^2 for sub-test 4.
    • Set AG Mode ( F7 ) to Pattern .
    • Repeat step 16.

Measuring 3GPP TS 34.121-1 (v8.10.0) s5.2E UE Relative Code Domain Power Accuracy for HS-DPCCH and E-DCH with 16QAM

This section is applicable to the lab application or feature-licensed test application only.

UE Relative Code Domain Power Accuracy for HS-DPCCH and E-DCH with 16QAM from 3GPP TS 34.121-1 s5.2E measures RCDPA on any release 7 or later UE that supports E-DCH category 7, 16QAM with HSUPA.

The test is performed with the UE transmitting at the maximum power.

  1. Set parameters that can only be set in cell off operating mode (and other parameters that are set from the same menu):
    • Set Operating Mode ( F1 ) to Cell Off .
    • Select 34.121 Preset Call Configurations ( F11 on Call Parms 1 of 3 ) and select 5.2E:HSPA+:UL 16QAM . You may then skip any steps marked with [34.121 Call Config] in this procedure.
    • Select Channel (UARFCN) Parms ( F12 on Call Parms 1 of 3 ). Set DL Channel ( F7 ) to the appropriate "mid range" frequency for your UE's operating band, as specified by 3GPP TS 34.108 s5.1.1 (for example, for operating band II set DL Channel = 9800 ).
    • [34.121 Call Config] Select Uplink Parameters ( F4 on Call Control 2 of 6 ).
      • [34.121 Call Config] Set Uplink DPCH Bc/Bd Control to Manual .
      • [34.121 Call Config] Set Manual Uplink DPCH Bc to 15 (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1).
      • [34.121 Call Config] Manual Uplink DPCH Bd can remain at its default value. 34.121-1 v8.10.0 table C.11.1.4 sub-test 1 requires Beta d set to zero. This is configured by selecting a DL channel type with no DPDCH. The value set here for Beta d is not used because no DL DPDCH is generated.
      • [34.121 Call Config] Set Maximum Uplink Transmit Power Level to +21 dBm .
    • Set Operating Mode to Active Cell (pressing the CALL SETUP key quickly brings you back to the top level Call Control menu).
  2. Set Cell Power ( F7 on Call Parms 1 of 3 ) to -86 dBm/3.84 MHz .
  3. [34.121 Call Config] Set Channel Type ( F8 ) to HSPA .
  4. [34.121 Call Config] Select Generator Info ( F3 on Call Control 2 of 6 ), select Downlink Channel Levels ( F3 ), Connected DL Channel Levels ( F3 ), then select HSPA Conn DL Channel Levels ( F4 ).
    • [34.121 Call Config] Set HSPA Cell 1 Connected CPICH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected P-CCPCH/SCH Level to -12 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected PICH Level to -15 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected (F-)DPCH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-AGCH Level to -20 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-HICH Level to -20 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-RGCH Level to Off (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected HS-PDSCHs Level (Sum) to -3 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected HS-SCCH 1 Level to -8 dB .
  5. [34.121 Call Config] Select Generator Info ( F3 on Call Control 2 of 6 ), select Downlink Channel Configs ( F4 ), and then select HS-SCCH Configs ( F3 ).
    • [34.121 Call Config] Set HS-SCCH 2 Channel Config State to Off .
    • [34.121 Call Config] Set HS-SCCH 3 Channel Config State to Off .
    • [34.121 Call Config] Set HS-SCCH 4 Channel Config State to Off .
  6. [34.121 Call Config] Select HSUPA Parameters ( HSPA Parameters ( F10 ), F9 ).
    • [34.121 Call Config] Select HSUPA RB Test Mode Setup ( F8 ).
      • [34.121 Call Config] Set RB Test Mode E-RGCH Information State to Off (this is the default value).
      • [34.121 Call Config] Set RB E-DPDCH Max Channel Codes (HSPA) to 2SF2 + 2SF4 (this is the default value).
      • [34.121 Call Config] Set E-DCH RLC SDU Size to 8808 .
    • [34.121 Call Config] Select Common HSUPA Parameters ( F9 ).
      • [34.121 Call Config] Set E-DCH TTI to 2 ms .
      • [34.121 Call Config] Set E-DCH 16QAM State to On .
      • [34.121 Call Config] Set E-DPCCH/DPCCH Power Offset (DeltaE-DPCCH) to 8 (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1). Note, 34.121-1 table C.11.1.4 provides Beta ec (30/15 for sub-test 1). To determine what value of DeltaE-DPCCH corresponds to this, use 3GPP TS 25.213 table 1B and the value of Beta c from 34.121-1 table C.11.1.4 (15/15 for sub-test 1). For sub-test 1, A ec = Beta ec /Beta c = (30/15)/(15/15) = 30/15; therefore DeltaE-DPCCH = 8.
      • [34.121 Call Config] Set E-TFCI Table Index (2 ms TTI with 16QAM) to 2 (this is the default value).
      • [34.121 Call Config] Set Reference E-TFCI Power Offset Control to Predefined (this is the default value).
      • [34.121 Call Config] Set Reference E-TFCI Power Offsets to Definition 34.121-04 (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1).
      • [34.121 Call Config] Set E-TFCI Boost Information State to On .
      • [34.121 Call Config] Set E-TFCI Boost Value to 105 .
      • [34.121 Call Config] Set DeltaT2TP to 2 (this is the default value).
      • [34.121 Call Config] Set BetaEd Gain E-AGCH Table Selection to 1 (this is the default value).
      • [34.121 Call Config] Set E-DPDCH Power Calculation Formula to Extrapolation (this is the default value).
    • Select Serving Grant ( F10 ).
      • Set AG Mode ( F7 ) = Single Shot (this is the default value).
      • [34.121 Call Config] Set RB Setup AG to 17: (75/15)^2 (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1). Note, 34.121-1 table C.11.1.4 AG Index corresponds to 3GPP TS 25.212 s4.10.1A.1 table 16B.1, which maps the Absolute Grants sent on the E-AGCH. To send the equivalent Absolute Grant in the RB Setup message, you must use the AG Index in 3GPP TS 25.321 s9.2.5.2.1.1 table 9.2.5.2.1.2.
      • Select AG Pattern Parameters ( F8 ):
        • Set Absolute Grant Pattern - Value 1 to 14: (75/15)^2 (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1).
        • Set Absolute Grant Pattern - Value 2 to 1: ZERO_GRANT (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1).
  7. [34.121 Call Config] Select HSDPA Parameters ( HSPA Parameters ( F10 ), F10 ).
    • [34.121 Call Config] Select HSDPA RB Test Mode Setup ( F8 ), then HSDPA RB Test Mode Settings ( F8 ).
      • [34.121 Call Config] Set HS-DSCH Configuration Type to FRC (this is the default value).
      • [34.121 Call Config] Set FRC Type to H-Set 1 QPSK (this is the default value).
    • [34.121 Call Config] Return ( F12 ) then select MAC-(e)hs Parameters ( F10 ).
      • [34.121 Call Config] Set Number of Transmissions to 4 (this is the default value).
      • [34.121 Call Config] Set RV Sequence to 0,2,5,6,0,0,0,0 (this is the default value).
    • [34.121 Call Config] Select HSDPA Uplink Parameters ( F11 ).
      • [34.121 Call Config] Set DeltaACK , DeltaNACK and DeltaCQI to 8 .
      • [34.121 Call Config] Set Ack-Nack Repetition Factor to 3 .
      • [34.121 Call Config] Set CQI Feedback Cycle (k) to 4 ms .
      • [34.121 Call Config] Set CQI Repetition Factor to 2 .
  8. Test Application: Select Cell Parameters ( F2 ).

    Lab Application: Select Cell Info ( F2 ), then Cell Parameters ( F2 ) from the Call Control 2 of 6 menu.

    • Set PS Domain Information to Present (this is the default value in the lab application).
    • Qqualmin and Qrxlevmin are fixed to -24 dB and -115 dBm, respectively, in the test application. In the lab application these are the default values for these parameters. They are accessible from Cell Info , Reselection Parameters ( F3 ).
  9. [34.121 Call Config] Select RB Test Mode Setup ( F6 on Call Control 3 of 6 ) and set UE Loopback Type to Type 1 (this is the default value).
  10. [34.121 Call Config] Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Algorithm to Two (this is the default value).
  11. Set any other parameters needed to establish a connection with your UE, then power on the UE and wait for it to register (attach).
  12. Select Originate Call ( F3 on Call Control 1 of 6 ).
  13. Drive the UE to maximum power:
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Mode to Active bits (this is the default value).
    • Set UE Target Power ( F7 on Call Parms 3 of 3 ) to 3 dBm (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1, power class 3 UE). This value is determined as follows: Maximum power for a power class 3 UE is +24 dBm, but UE Target Power only sets the DPCCH+DPDCH power level of the UE. In order to achieve a total output power of +16.5 dBm (24 dBm - 7.5 dB as required in 34.121-1 s5.2B.4.2), you must set UE Target Power to at most 16.5 dBm - Power change due to HS-DPCCH, E-DPCCH and E DPDCH.

      Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH = 10log 10 (Beta c ^2 + Beta d ^2 + Beta hs ^2 + Beta ec ^2 + Beta ed1 ^2 + Beta ed2 ^2 + Beta ed3 ^2 + Beta ed4 ^2) - 10log 10 (Beta d ^2 + Beta c ^2) = 13.4 dB for sub-test 1, so you must set UE Target Power to 3 dBm for sub-test 1.

    • Wait 150 ms.
    • Press the Measurement selection key and select Channel Power .
    • Set up the measurement:
      • Select Channel Power Setup ( F1 ).
      • Set Auto Range = On (or leave Auto Range = Off and set Manual Power Range to the Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH value calculated above).
      • Select Close Menu ( F6 ).
    • Observe Channel Power to ensure that the UE's output power is at least 7.5 dB below maximum power (<16.5 dBm for power class 3 UEs).
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to Alternating bits .
    • Select Additional Screens ( F1 from Call Control 2 of 6 ), select HSPA Information ( F2 ) and observe the Last Received E-TFCI (it should be 105 for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1).
    • Select E-TFCI Recording Information ( F3 ).
    • Select HSPA Parameters ( F10 ), HSUPA Parameters ( F9 ), E-TFCI Recording ( F11 ), E-TFCI Recording Parameters ( F7 ).
      • [34.121 Call Config] Set E-TFCI Recording Count to 15 (this is the default value).
      • Set E-TFCI Recording Behavior to All .
      • Select Send Step Up TPC Bit Pattern ( F10 ) and then Start Recording E-TFCI Values ( F8 ).
      • Observe whether the UE sent any decreased E-TFCI. If not, send another up TPC bit and record E TFCI. Repeat until the UE sends at least one decreased E TFCI.
      • Select Send Step Down TPC Bit Pattern ( F11 ) and then Start Recording E-TFCI Values ( F8 ).
      • Observe whether the UE sent any decreased E-TFCI. If it did, then send another down TPC bit, then continue to the next step. If not, continue to the next step.
      • Confirm that the E-TFCI is equal to the target E-TFCI of 105 for sub-test 1. If not, fail the UE. Note that an E TFCI of 105 corresponds to a transport block size of 9185 bits (3GPP TS 25.321 table B.2a). The corresponding uplink data rate is 9185 bits/2 ms = 4.59 Mbps.
  14. Select HSPA Parameters ( F10 ), HSUPA Parameters ( F9 ), Serving Grant ( F10 ) and set AG Mode to Pattern ( F7 ).
  15. Press the Measurement selection key and select Code Domain.
    • Select Code Domain Setup ( F1 ).
      • Set Transient Period to Exclude .
      • Set Trigger Source to Even Frame .
    • Measure RCDPA for the following code domain measurement configurations:
      Measurement Points
      Measurement Point | Timeslot | SFN Alignment
      1 | 14 | Odd
      2 | 0 | Even
      3 | 0 | Odd
    • If desired, show NCDP by selecting Graph Control ( F2 ) and setting Table ( F3 ) = 2 so that you can compare NCDP with 3GPP TS 34.121 table 5.2D.7.
    • Use the Marker ( F2 under Graph Control ( F2 ) ) to ensure that RCDPA for each code channel meets the specified requirements in 34.121-1 table 5.2E.6. The code channels are located as follows (as defined in 3GPP TS 25.213):
      Code Channels
      Code Channel | Location | Marker
      DPCCH | Q Cch,256,0 | 0

      HS-DPCCH

      Q Cch,256,33

      33
      E-DPCCH | I Cch,256,1 | 1
      E-DPDCH1 | I Cch,2,1 | 128
      E-DPDCH2 | Q Cch,2,1 | 128
      E-DPDCH3 | I Cch,4,1 | 64
      E-DPDCH4 | Q Cch,4,1 | 64

Measuring 3GPP TS 34.121-1 (v8.10.0) s5.13.1AAA EVM and IQ origin offset for HS-DPCCH and E-DCH with 16 QAM

This section is applicable to the lab application or feature-licensed test application only.

EVM and IQ Origin Offset for H-DPCCH and E-DCH with 16QAM from 3GPP TS 34.121-1 s5.13.1AAA measures EVM and IQ origin offset power on any release 7 or later UE that supports E-DCH category 7, 16QAM with HSUPA.

The test is performed with the UE transmitting at -28 dBm.

  1. Set parameters that can only be set in cell off operating mode (and other parameters that are set from the same menu):
    • Set Operating Mode ( F1 ) to Cell Off .
    • Select 34.121 Preset Call Configurations ( F11 on Call Parms 1 of 3 ) and select 5.13.1AAA, 5.13.2C:HSPA+:UL 16QAM . You may then skip any steps marked with [34.121 Call Config] in this procedure.
    • Select Channel (UARFCN) Parms ( F12 on Call Parms 1 of 3 ). Set DL Channel ( F7 ) and Uplink Channel ( F8 ) to the appropriate "low range" frequencies for your UE's operating band, as specified by 3GPP TS 34.108 s5.1.1 (for example, for operating band II, set DL Channel = 9663 ).
    • [34.121 Call Config] Select Uplink Parameters ( F4 on Call Control 2 of 6 ).
      • [34.121 Call Config] Set Uplink DPCH Bc/Bd Control to Manual .
      • [34.121 Call Config] Set Manual Uplink DPCH Bc to 15 (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1).
      • [34.121 Call Config] Manual Uplink DPCH Bd can remain at its default value. 34.121-1 v8.10.0 table C.11.1.4 sub-test 1 requires Beta d set to zero. This is configured by selecting a DL channel type with no DPDCH. The value set here for Beta d is not used because no DL DPDCH is generated.
      • [34.121 Call Config] Set Maximum Uplink Transmit Power Level to +21 dBm .
    • Set Operating Mode to Active Cell (pressing the CALL SETUP key quickly brings you back to the top level Call Control menu).
  2. Set Cell Power ( F7 on Call Parms 1 of 3 ) to -86 dBm/3.84 MHz .
  3. [34.121 Call Config] Set Channel Type ( F8 ) to HSPA .
  4. [34.121 Call Config] Select Generator Info ( F3 on Call Control 2 of 6 ), select Downlink Channel Levels ( F3 ), Connected DL Channel Levels ( F3 ), then select HSPA Conn DL Channel Levels ( F4 ).
    • [34.121 Call Config] Set HSPA Cell 1 Connected CPICH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected P-CCPCH/SCH Level to -12 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected PICH Level to -15 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected (F-)DPCH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-AGCH Level to -20 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-HICH Level to -20 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-RGCH Level to Off (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected HS-PDSCHs Level (Sum) to -3 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected HS-SCCH 1 Level to -8 dB .
  5. [34.121 Call Config] Select Generator Info ( F3 on Call Control 2 of 6 ), select Downlink Channel Configs ( F4 ), and then select HS-SCCH Configs ( F3 ).
    • [34.121 Call Config] Set HS SCCH-2 Channel Config State to Off .
    • [34.121 Call Config] Set HS SCCH-3 Channel Config State to Off .
    • [34.121 Call Config] Set HS SCCH-4 Channel Config State to Off .
  6. [34.121 Call Config] Select HSUPA Parameters ( HSPA Parameters ( F10 ), F9 ).
    • [34.121 Call Config] Select HSUPA RB Test Mode Setup ( F8 ).
      • [34.121 Call Config] Set RB Test Mode E-RGCH Information State to Off (this is the default value).
      • [34.121 Call Config] Set RB E-DPDCH Max Channel Codes (HSPA) to 2SF2 + 2SF4 (this is the default value).
      • [34.121 Call Config] Set E-DCH RLC SDU Size to 8808 .
    • [34.121 Call Config] Select Common HSUPA Parameters ( F9 ).
      • [34.121 Call Config] Set E-DCH TTI to 2 ms .
      • [34.121 Call Config] Set E-DCH 16QAM State to On .
      • [34.121 Call Config] Set E-DPCCH/DPCCH Power Offset (DeltaE-DPCCH) to 8 (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1). Note, 34.121-1 table C.11.1.4 provides Beta ec (30/15 for sub-test 1). To determine what value of DeltaE-DPCCH corresponds to this, use 3GPP TS 25.213 table 1B and the value of Beta c from 34.121-1 table C.11.1.4 (15/15 for sub-test 1). For sub-test 1, A ec = Beta ec /Beta c = (30/15)/(15/15) = 30/15; therefore DeltaE-DPCCH = 8.
      • [34.121 Call Config] Set E-TFCI Table Index (2 ms TTI with 16QAM) to 2 (this is the default value).
      • [34.121 Call Config] Set Reference E-TFCI Power Offset Control to Predefined (this is the default value).
      • [34.121 Call Config] Set Reference E-TFCI Power Offsets to Definition 34.121-04 (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1). 34.121-1 v8.10.0 table 5.2E.2 is used for this configuration; however, this table is identical to 34.121-1 table 5.13.1AAA.3.
      • [34.121 Call Config] Set E-TFCI Boost Information State to On .
      • [34.121 Call Config] Set E-TFCI Boost Value to 105 .
      • [34.121 Call Config] Set DeltaT2TP to 2 (this is the default value).
      • [34.121 Call Config] Set BetaEd Gain E-AGCH Table Selection to 1 (this is the default value).
      • [34.121 Call Config] Set E-DPDCH Power Calculation Formula to Extrapolation (this is the default value).
    • [34.121 Call Config] Select Serving Grant ( F10 ).
      • [34.121 Call Config] Set AG Mode to Single Shot (this is the default value).
      • [34.121 Call Config] Set Single Shot AG to 14: (75/15)^2 (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1).
      • [34.121 Call Config] Set RB Setup AG to 17: (75/15)^2 (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1). Note, 34.121-1 table C.11.1.4 AG Index corresponds to 3GPP TS 25.212 s4.10.1A.1 table 16B.1, which maps the Absolute Grants sent on the E-AGCH. To send the equivalent Absolute Grant in the RB Setup message, you must use the AG Index in 3GPP TS 25.321 s9.2.5.2.1.1 table 9.2.5.2.1.2.
  7. [34.121 Call Config] Select HSDPA Parameters ( HSPA Parameters ( F10 ), F10 ).
    • [34.121 Call Config] Select HSDPA RB Test Mode Setup ( F8 ), then HSDPA RB Test Mode Settings ( F8 ).
      • [34.121 Call Config] Set HS-DSCH Configuration Type to FRC (this is the default value).
      • [34.121 Call Config] Set FRC Type to H-Set 1 QPSK (this is the default value).
    • [34.121 Call Config] Return ( F12 ) then select MAC-(e)hs Parameters ( F10 ).
      • [34.121 Call Config] Set Number of Transmissions to 4 (this is the default value).
      • ? [34.121 Call Config] Set RV Sequence to 0,2,5,6,0,0,0,0 (this is the default value).
    • [34.121 Call Config] Select HSDPA Uplink Parameters ( F11 ).
      • [34.121 Call Config] Set DeltaACK , DeltaNACK , and DeltaCQI to 8 .
      • [34.121 Call Config] Set Ack-Nack Repetition Factor to 3 .
      • [34.121 Call Config] Set CQI Feedback Cycle (k) to 4 ms .
      • [34.121 Call Config] Set CQI Repetition Factor to 2 .
  8. Test Application: Select Cell Parameters ( F2 ).

    Lab Application: Select Cell Info ( F2 ), then Cell Parameters ( F2 ) from the Call Control 2 of 6 menu.

    • Set PS Domain Information to Present (this is the default value in the lab application).
    • Qqualmin and Qrxlevmin are fixed to -24 dB and -115 dBm, respectively, in the test application. In the lab application these are the default values for these parameters. They are accessible from Cell Info , Reselection Parameters ( F3 ).
  9. [34.121 Call Config] Select RB Test Mode Setup ( F6 on Call Control 3 of 6 ) and set UE Loopback Type to Type 1 (this is the default value).
  10. [34.121 Call Config] Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Algorithm to Two (this is the default value).
  11. Set any other parameters needed to establish a connection with your UE, then power on the UE and wait for it to register (attach).
  12. Select Originate Call ( F3 on Call Control 1 of 6 ).
  13. Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Mode to Active bits (this is the default value).
  14. Set UE Target Power ( F7 on Call Parms 3 of 3 ) to -41 dBm. This value is determined as follows: 34.121-1 s5.13.1AAA requires a UE output power of -28 dBm ± 2 dB, but UE Target Power only sets the DPCCH+DPDCH power level of the UE. In order to achieve a total output power of -28 dBm, you must set UE Target Power to at most -28 dBm - Power change due to HS-DPCCH, E-DPCCH and E-DPDCH.Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH = 10log 10 (Beta c ^2 + Beta d ^2 + Beta hs ^2 + Beta ec ^2 + Beta ed1 ^2 + Beta ed2 ^2 + Beta ed3 ^2 + Beta ed4 ^2) - 10log 10 (Beta d ^2 + Beta c ^2) = 13.4 dB for sub-test 1, so you must set UE Target Power to -41 dBm.
  15. Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Mode to Alternating bits .
  16. Press the Measurement selection key and select Code Domain .
    • Select Code Domain Setup ( F1 ).
      • Set Transient Period to Exclude .
      • Set Trigger Source to Even Frame .
    • Ensure the Origin Offset meets the requirement in 34.121-1 v8.10.0 table 5.13.1AAA.6.
    • If desired, ensure the EVM meets the requirement in 34.121-1 v8.10.0 s5.13.1AAA.2.
  17. To repeat the test case at "mid range" and "high range" frequencies, use Physical Channel Reconfig ( F5 on Call Control 1 of 6 , F1 ) to perform a hard handover to the next channel. Set the Handover Downlink Channel (UARFCN) and Handover Uplink Channel (UARFCN) parameters to the appropriate "mid range" or "high range" frequencies for your UE's operating band, as specified by 3GPP TS 34.108 s5.1.1. Execute Handover ( F5 ) and then repeat steps 13 through 16.

Measuring 3GPP TS 34.121-1 (v8.10.0) 5.13.2B Relative Code Domain Error with HS-DPCCH and E-DCH

This section is applicable to the lab application or feature-licensed test application only.

  1. Set parameters that can only be set in cell off operating mode (and other parameters that are set from the same menu):
    • Set Operating Mode ( F1 ) to Cell Off .
    • Select 34.121 Preset Call Configurations ( F11 on Call Parms 1 of 3 ) and select 5.2B, 5.9B, 5.10B, and 5.13.2B:HSPA:QPSK , then select the desired sub-test. You may then skip any steps marked with [34.121 Call Config] in this procedure.
    • Select Channel (UARFCN) Parms ( F12 on Call Parms 1 of 3 ). Set DL Channel ( F7 ) to the appropriate "low range" frequency for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band II set DL Channel = 9663 ).
    • [34.121 Call Config] Select Uplink Parameters ( F4 on Call Control 2 of 6 ).
      • [34.121 Call Config] Set Uplink DPCH Bc/Bd Control to Manual .
      • [34.121 Call Config] Set Manual Uplink DPCH Bc to 11 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
      • [34.121 Call Config] Set Manual Uplink DPCH Bd to 15 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
      • [34.121 Call Config] Set Maximum Uplink Transmit Power Level to 21 dBm .
    • Set Operating Mode to Active Cell (pressing the CALL SETUP key quickly brings you back to the top level Call Control menu).
  2. Set Cell Power ( F7 on Call Parms 1 of 3 ) to -86 dBm/3.84 MHz .
  3. [34.121 Call Config] Set Channel Type ( F8 ) to 12.2k RMC + HSPA .
  4. [34.121 Call Config] Select Generator Info ( F3 on Call Control 2 of 6 ), select Downlink Channel Levels ( F3 ), select Connected DL Channel Levels ( F3 ), then select HSPA Conn DL Channel Levels ( F4 ).
    • [34.121 Call Config] Set HSPA Cell 1 Connected CPICH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected P-CCPCH/SCH Level to -12 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected PICH Level to -15 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected (F-)DPCH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-AGCH Level to -20 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-HICH Level to -20 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-RGCH Level to Off (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected HS-PDSCHs Level (Sum) to -3 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected HS-SCCH 1 Level to -8 dB .
  5. [34.121 Call Config] Select HSUPA Parameters ( HSPA Parameters ( F10 ), F9 ).
    • [34.121 Call Config] Select HSUPA RB Test Mode Setup ( F8 ).
      • [34.121 Call Config] Set E-DCH RLC SDU Size to 2936 (this is the default value).
    • [34.121 Call Config] Select Common HSUPA Parameters ( F9 ).
      • [34.121 Call Config] Set E-DPCCH/DPCCH Power Offset (DeltaE-DPCCH) to 6 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1). Note, 34.121-1 Table C.11.1.3 provides Beta ec (209/225 for sub-test 1). To determine what value of DeltaE-DPCCH corresponds to this, use 3GPP TS 25.213 Table 1B and the value of Beta c from 34.121-1 Table C.11.1.3 (11/15 for sub-test 1). For sub-test 1, A ec = Beta ec /Beta c = (209/225)/(11/15) = 19/15; therefore DeltaE-DPCCH = 6.
      • [34.121 Call Config] Set Reference E-TFCI Power Offsets to Definition 34.121-01 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
    • [34.121 Call Config] Select Serving Grant ( F10 ).
      • [34.121 Call Config] Set RB Setup AG to 26: (119/15)^2 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1). Note, 34.121-1 Table C.11.1.3 AG Index corresponds to 3GPP TS 25.212 s4.10.1A.1 Table 16B, which maps the Absolute Grants sent on the E-AGCH. To send the equivalent Absolute Grant in the RB Setup message, you must use the AG Index in 3GPP TS 25.321 s9.2.5.2.1.1 Table 9.2.5.2.1.1.
  6. [34.121 Call Config] Select HSDPA Parameters ( HSPA Parameters ( F10 ), F10 ).
    • [34.121 Call Config] Select HSDPA RB Test Mode Setup ( F8 ), then select HSDPA RB Test Mode Settings ( F8 ).
      • [34.121 Call Config] Set RB Test HS-DSCH Configuration Type to FRC (this is the default value).
      • [34.121 Call Config] Set FRC Type to H-Set 1 QPSK (this is the default value).
    • [34.121 Call Config] Select HSDPA Uplink Parameters ( F11 ).
      • [34.121 Call Config] Set DeltaACK , DeltaNACK and DeltaCQI to 8 .
      • [34.121 Call Config] Set Ack-Nack Repetition Factor to 3 .
      • [34.121 Call Config] Set CQI Feedback Cycle (k) to 4 ms .
      • [34.121 Call Config] Set CQI Repetition Factor to 2 .
  7. Test Application: Select Cell Parameters ( F2 ).
    Lab Application: Select Cell Info ( F2 ), then Cell Parameters ( F2 ).
    ( from the Call Control 2 of 6 menu)
    • Set PS Domain Information to Present (this is the default value in the lab application).
    • Qqualmin and Qrxlevmin are fixed to -24 dB and -115 dBm, respectively, in the test application. In the lab application these are the default values for these parameters. They are accessible from Cell Info , Reselection Parameters ( F3 ).
  8. [34.121 Call Config] Select RB Test Mode Setup ( F6 on Call Control 3 of 6 ) and set UE Loopback Type to Type 1 (this is the default value).
  9. [34.121 Call Config] Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Algorithm to Two (this is the default value).
  10. Set any other parameters needed to establish a connection with your UE, then power on the UE and wait for it to register (attach). See Establishing an HSPA Connection .
    Note, before you can establish a connection in the PS domain (as is required for HSPA connections), the UE must attach to the test set. To enable this, the PS Domain Information parameter must be set to Present when the UE registers (attaches) with the test set.
  11. Select Originate Call ( F3 on Call Control 1 of 6 ).
  12. Drive the UE to 15 dBm +/- 2 dB ouput power:
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Mode to Active bits (this is the default value).
    • Set UE Target Power ( F7 on Call Parms 3 of 3 ) to 1 dBm (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1). This value is determined as follows: UE Target Power only sets the DPCCH+DPDCH power level of the UE. In order to achieve a total output power of +15 dBm, you must set UE Target Power to at most 15 dBm - Power change due to HS-DPCCH, E-DPCCH and E-DPDCH .
      Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH = 10log 10 (Beta c ^2 + Beta d ^2 + Beta hs ^2 + Beta ec ^2 + Beta ed ^2) - 10log 10 (Beta d ^2 + Beta c ^2) = 14 dB for sub-test 1, so you must set UE Target Power to 1 dBm for sub-test 1.
      The UE Target Power values for sub-tests 2-4 are as follows: sub-test 2: 10 dBm, sub-test 3: 2 dBm, sub-test 4: 13 dBm.
    • Wait 150 ms.
    • Select Additional Screens ( F1 from Call Control 2 of 6 ), select HSPA Information ( F2 ) and confirm that the Last Received E-TFCI is equal to the target E-TFCI (it should be 75 for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1, 67 for sub-test 2, 92 for sub-test 3, and 71 for sub-test 4).
    • Select E-TFCI Recording Information ( F3 ).
    • If not, fail the UE. Note that an E-TFCI of 75 corresponds to an uplink data rate of 2421 bits/10 ms = 242 kbps. The uplink data rate for sub-test 2 = 175 kbps, sub-test 3 = 483 kbps,, and sub-test 4 = 206 kbps.
  13. Press the Measurement selection key and select Code Domain .
  14. Measure RCDE:
    • Show the NCDP and ECDP measurement results by selecting Graph Control ( F2 ) and set Table ( F3 ) to 2 (so that you can compare the NCDP and ECDP results with 3GPP TS 34.121-1 table 5.13.2B.8).

    • Use the Marker ( F2 under Graph Control ( F2 )) to ensure that the RCDE result for each code channel meets the specified requirements in 34.121-1 table 5.13.2B.9.

    • The code channels are located as follows:

      Code Channels
      Code Channel | Location | Marker
      DPCCH | Q Cch,256,0 | 0
      DPDCH | I Cch,64,16 | 64
      HS-DPCCH | Q Cch,256,64 | 64
      E-DPCCH | I Cch,256,1 | 1
      E-DPDCH1 | I Cch,4,2 | 128
      E-DPDCH2 | Q Cch,4,2 | 128
  15. To repeat this test for sub-tests 2-4:
    • Perform a Transport Channel Reconfiguration ( Handovers ( F5 )) to change the following settings:
      Sub-test 2-4 Transport Channel Reconfiguration settings
      Setting | Sub-test 2 | Sub-test 3 | Sub-test 4
      TCR DPCH Bc/Bd Control | Manual | Manual | Manual
      TCR Manual Uplink DPCH Bc | 6 | 15 | 2
      TCR Manual Uplink DPCH Bd | 15 | 9 | 15
      TCR DeltaACK, DeltaNACK, DeltaCQI | 8 | 8 | 8
      TCR Ack-Nack Repetition Factor | 3 | 3 | 3
      TCR CQI Feedback Cycle (k) | 4 ms | 4 ms | 4 ms
      TCR CQI Repetition Factor | 2 | 2 | 2
      TCR E-DPCCH/DPCCH Power Offset | 8 | 8 | 5
      TCR Reference E-TFCI Power Offsets | 34121-01 | 34121-02 | 34121-01
      TCR Absolute Grant | 18: (47/15)^2 | 21: (67/15)^2 | 23: (84/15)^2
    • Repeat step 12 (drive the UE to 15 dBm output power) and step 14 (measure RCDE for each code channel).
  16. Perform a Transport Channel Reconfiguration ( Handovers ( F5 )) to change the following settings:
    Sub-test 1 Transport Channel Reconfiguration settings
    Setting | Sub-test 1
    TCR DPCH Bc/Bd Control | Manual
    TCR Manual Uplink DPCH Bc | 11
    TCR Manual Uplink DPCH Bd | 15
    TCR DeltaACK, DeltaNACK, DeltaCQI | 8
    TCR Ack-Nack Repetition Factor | 3
    TCR CQI Feedback Cycle (k) | 4 ms
    TCR CQI Repetition Factor | 2
    TCR E-DPCCH/DPCCH Power Offset | 6
    TCR Reference E-TFCI Power Offsets | 34121-01
    TCR Absolute Grant | 26: (119/15)^2
  17. Drive UE output power to -18 dBm:
    • Set UE Target Power ( F7 on Call Parms 3 of 3 ) to -32 dBm (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1). In order to achieve a total output power of -18 dBm, you must set UE Target Power to -18 dBm - Power change due to HS-DPCCH, E-DPCCH and E-DPDCH .
      Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH = 10log 10 (Beta c ^2 + Beta d ^2 + Beta hs ^2 + Beta ec ^2 + Beta ed ^2) - 10log 10 (Beta d ^2 + Beta c ^2) = 14 dB for sub-test 1, so you must set UE Target Power to -32 dBm for sub-test 1.
      The UE Target Power values for sub-tests 2-4 are as follows: sub-test 2: -23 dBm, sub-test 3: -31 dBm, sub-test 4: -20 dBm.
    • Wait 150 ms.
  18. Repeat step 14 (measure RCDE for each code channel).
  19. To repeat this test for sub-tests 2-4:
    • Perform a Transport Channel Reconfiguration ( Handovers ( F5 )) to change the following settings:
      Sub-test 2-4 Transport Channel Reconfiguration settings
      Setting | Sub-test 2 | Sub-test 3 | Sub-test 4
      TCR DPCH Bc/Bd Control | Manual | Manual | Manual
      TCR Manual Uplink DPCH Bc | 6 | 15 | 2
      TCR Manual Uplink DPCH Bd | 15 | 9 | 15
      TCR DeltaACK, DeltaNACK, DeltaCQI | 8 | 8 | 8
      TCR Ack-Nack Repetition Factor | 3 | 3 | 3
      TCR CQI Feedback Cycle (k) | 4 ms | 4 ms | 4 ms
      TCR CQI Repetition Factor | 2 | 2 | 2
      TCR E-DPCCH/DPCCH Power Offset | 8 | 8 | 5
      TCR Reference E-TFCI Power Offsets | 34121-01 | 34121-02 | 34121-01
      TCR Absolute Grant | 18: (47/15)^2 | 21: (67/15)^2 | 23: (84/15)^2
    • Repeat step 17 (drive UE to -18 dBm) and step 14 (measure RCDE for each code channel).
  20. Perform a Physical Channel Reconfiguration or other handover ( Handovers ( F5 )) to repeat the testing at mid and high range frequencies.

Measuring 3GPP TS 34.121-1 (v8.10.0) s5.13.2C Relative Code Domain Error for HS-DPCCH and E-DCH with 16QAM

This section is applicable to the lab application or feature-licensed test application only.

Relative Code Domain Error for HS-DPCCH and E-DCH with 16QAM from 3GPP TS 34.121-1 s5.13.2C measures RCDE on any release 7 or later UE that supports E-DCH category 7, 16QAM with HSUPA.

The test is performed with the UE transmitting at maximum power and then repeated with the UE transmitting at -18 dBm.

  1. Set parameters that can only be set in cell off operating mode (and other parameters that are set from the same menu):
    • Set Operating Mode ( F1 ) to Cell Off .
    • Select 34.121 Preset Call Configurations ( F11 on Call Parms 1 of 3 ) and select 5.13.1AAA, 5.13.2C:HSPA+:UL 16QAM . You may then skip any steps marked with [34.121 Call Config] in this procedure.
    • Select Channel (UARFCN) Parms ( F12 on Call Parms 1 of 3 ). Set DL Channel ( F7 ) to the appropriate "low range" frequency for your UE's operating band, as specified by 3GPP TS 34.108 s5.1.1 (for example, for operating band II set DL Channel = 9663 ).
    • [34.121 Call Config] Select Uplink Parameters ( F4 on Call Control 2 of 6 ).
      • [34.121 Call Config] Set Uplink DPCH Bc/Bd Control to Manual .
      • [34.121 Call Config] Set Manual Uplink DPCH Bc to 15 (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1).
      • [34.121 Call Config] Manual Uplink DPCH Bd can remain at its default value. 34.121-1 v8.10.0 table C.11.1.4 sub-test 1 requires Beta d set to zero. This is configured by selecting a DL channel type with no DPDCH. The value set here for Beta d is not used because no DL DPDCH is generated.
      • [34.121 Call Config] Set Maximum Uplink Transmit Power Level to +21 dBm .
    • Set Operating Mode to Active Cell (pressing the CALL SETUP key quickly brings you back to the top level Call Control menu).
  2. Set Cell Power ( F7 on Call Parms 1 of 3 ) to -86 dBm/3.84 MHz .
  3. [34.121 Call Config] Set Channel Type ( F8 ) to HSPA .
  4. [34.121 Call Config] Select Generator Info ( F3 on Call Control 2 of 6 ), select Connected DL Channel Levels ( F4 ), and then select HSPA Conn DL Channel Levels ( F5 ).
    • [34.121 Call Config] Set HSPA Cell 1 Connected CPICH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected P-CCPCH/SCH Level to -12 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected PICH Level to -15 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected DPCH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-AGCH Level to -20 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-HICH Level to -20 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-RGCH Level to Off (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected HS-PDSCHs Level (Sum) to -3 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected HS-SCCH 1 Level to -8 dB .
  5. [34.121 Call Config] Select Generator Info ( F3 on Call Control 2 of 6 ), select Downlink Channel Configs ( F4 ), and then then select HS-SCCH Configs ( F3 ).
    • [34.121 Call Config] Set HS-SCCH 2 Channel Config State to Off .
    • [34.121 Call Config] Set HS-SCCH 3 Channel Config State to Off .
    • [34.121 Call Config] Set HS-SCCH 4 Channel Config State to Off .
  6. [34.121 Call Config] Select HSUPA Parameters ( HSPA Parameters ( F10 ), F9 ).
    • [34.121 Call Config] Select HSUPA RB Test Mode Setup ( F8 ).
      • [34.121 Call Config] Set RB Test Mode E RGCH Information State to Off (this is the default value).
      • [34.121 Call Config] Set RB E DPDCH Max Channel Codes (HSPA) to 2SF2 + 2SF4 (this is the default value).
      • [34.121 Call Config] Set E-DCH RLC SDU Size to 8808 .
    • [34.121 Call Config] Select Common HSUPA Parameters ( F9 ).
      • [34.121 Call Config] Set E-DCH TTI to 2 ms.
      • [34.121 Call Config] Set E-DCH 16QAM State to On .
      • [34.121 Call Config] Set E-DPCCH/DPCCH Power Offset (DeltaE-DPCCH) to 8 (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1). Note, 34.121-1 table C.11.1.4 provides Beta ec (30/15 for sub-test 1). To determine what value of DeltaE-DPCCH corresponds to this, use 3GPP TS 25.213 table 1B and the value of Beta c from 34.121-1 table C.11.1.4 (15/15 for sub-test 1). For sub-test 1, A ec = Beta ec /Beta c = (30/15)/(15/15) = 30/15; therefore DeltaE-DPCCH = 8.
      • [34.121 Call Config] Set E-TFCI Table Index (2 ms TTI with 16QAM) to 2 (this is the default value).
      • [34.121 Call Config] Set Reference E-TFCI Power Offset Control to Predefined (this is the default value).
      • [34.121 Call Config] Set Reference E-TFCI Power Offsets to Definition 34.121-04 (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1). 34.121-1 v8.10.0 table 5.2E.2 is used for this configuration; however, this table is identical to 34.121-1 table 5.13.2C.4.
      • [34.121 Call Config] Set E-TFCI Boost Information State to On .
      • [34.121 Call Config] Set E-TFCI Boost Value to 105 .
      • [34.121 Call Config] Set DeltaT2TP to 2 (this is the default value).
      • [34.121 Call Config] Set BetaEd Gain E-AGCH Table Selection to 1 (this is the default value).
      • [34.121 Call Config] Set E-DPDCH Power Calculation Formula to Extrapolation (this is the default value).
    • [34.121 Call Config] Select Serving Grant ( F10 ).
      • [34.121 Call Config] Set AG Mode to Single Shot (this is the default value).
      • [34.121 Call Config] Set Single Shot AG to 14: (75/15)^2 (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1).
      • [34.121 Call Config] Set RB Setup AG to 17: (75/15)^2 (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1). Note, 34.121-1 table C.11.1.4 AG Index corresponds to 3GPP TS 25.212 s4.10.1A.1 table 16B.1, which maps the Absolute Grants sent on the E-AGCH. To send the equivalent Absolute Grant in the RB Setup message, you must use the AG Index in 3GPP TS 25.321 s9.2.5.2.1.1 table 9.2.5.2.1.2.
  7. [34.121 Call Config] Select HSDPA Parameters ( HSPA Parameters ( F10 ), F10 ).
    • [34.121 Call Config] Select HSDPA RB Test Mode Setup ( F8 ) then HSDPA RB Test Mode Settings ( F8 ).
      • [34.121 Call Config] Set HS-DSCH Configuration Type to FRC (this is the default value).
      • [34.121 Call Config] Set FRC Type to H-Set 1 QPSK (this is the default value).
    • [34.121 Call Config] Return ( F12 ) then select MAC-(e)hs Parameters ( F10 ).
      • [34.121 Call Config] Set Number of Transmissions to 4 (this is the default value).
      • [34.121 Call Config] Set RV Sequence to 0,2,5,6,0,0,0,0 (this is the default value).
    • [34.121 Call Config] Select HSDPA Uplink Parameters ( F11 ).
      • [34.121 Call Config] Set DeltaACK , DeltaNACK and DeltaCQI to 8 .
      • [34.121 Call Config] Set Ack-Nack Repetition Factor to 3 .
      • [34.121 Call Config] Set CQI Feedback Cycle (k) to 4 ms .
      • [34.121 Call Config] Set CQI Repetition Factor to 2 .
  8. Test Application: Select Cell Parameters ( F2 ).

    Lab Application: Select Cell Info ( F2 ) , then Cell Parameters ( F2 ) from the Call Control 2 of 6 menu.

    • Set PS Domain Information to Present (this is the default value in the lab application).
    • Qqualmin and Qrxlevmin are fixed to -24 dB and -115 dBm, respectively, in the test application. In the lab application these are the default values for these parameters. They are accessible from Cell Info , Reselection Parameters ( F3 ).

  9. [34.121 Call Config] Select RB Test Mode Setup ( F6 on Call Control 3 of 6 ) and set UE Loopback Type to Type 1 (this is the default value).
  10. [34.121 Call Config] Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Algorithm to Two (this is the default value).
  11. Set any other parameters needed to establish a connection with your UE, then power on the UE and wait for it to register (attach).
  12. Select Originate Call ( F3 on Call Control 1 of 6 ).
  13. Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Mode to Active bits (this is the default value).
  14. Drive the UE to maximum power:
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Mode to Active bits (this is the default value).
    • Set UE Target Power ( F7 on Call Parms 3 of 3 ) to 3 dBm (for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1, power class 3 UE). This value is determined as follows: Maximum power for a power class 3 UE is +24 dBm, but UE Target Power only sets the DPCCH+DPDCH power level of the UE. In order to achieve a total output power of +16.5 dBm (24 dBm - 7.5 dB as required by 34.121-1 s5.2B.4.2), you must set UE Target Power to at most 16.5 dBm - Power change due to HS-DPCCH, E-DPCCH and E-DPDCH.

      Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH = 10log 10 (Beta c ^2 + Beta d ^2 + Beta hs ^2 + Beta ec ^2 + Beta ed1 ^2 + Beta ed2 ^2 + Beta ed3 ^2 + Beta ed4 ^2) - 10log 10 (Beta d ^2 + Beta c ^2) = 13.4 dB for sub-test 1, so you must set UE Target Power to 3 dBm for sub-test 1.

    • Wait 150 ms.
    • Press the Measurement selection key and select Channel Power .
    • Set up the measurement:
      • Select Channel Power Setup ( F1 ).
      • Set Auto Range = On (or leave Auto Range = Off and set Manual Power Range to the Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH value calculated above).
      • Select Close Menu ( F6 ).
    • Observe Channel Power to ensure that the UE's output power is at least 7.5 dB below maximum power (<16.5 dBm for power class 3 UEs).
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to Alternating bits .
    • Select Additional Screens ( F1 from Call Control 2 of 6 ), select HSPA Information ( F2 ) and observe the Last Received E-TFCI (it should be 105 for 34.121-1 v8.10.0 table C.11.1.4 sub-test 1).
    • Select E-TFCI Recording Informatio n ( F3 ).
    • Select HSPA Parameters ( F10 ), HSUPA Parameters ( F9 ), E-TFCI Recording ( F11 ), E-TFCI Recording Parameters ( F7 ).
      • [34.121 Call Config] Set E-TFCI Recording Count to 15 (this is the default value).
      • Set E-TFCI Recording Behavior to All .
      • Select Send Step Up TPC Bit Pattern ( F10 ) and then Start Recording E-TFCI Values ( F8 ).
      • Observe whether the UE sent any decreased E-TFCI. If not, send another up TPC bit and record E-TFCI. Repeat until the UE sends at least one decreased E-TFCI.
      • Select Send Step Down TPC Bit Pattern ( F11 ) and then Start Recording E-TFCI Values ( F8 ).
      • Observe whether the UE sent any decreased E-TFCI. If it did, then send another down TPC bit, then continue to the next step. If not, continue to the next step.
      • Confirm that the E-TFCI is equal to the target E-TFCI of 105 for sub-test 1. If not, fail the UE. Note that an E-TFCI of 105 corresponds to a transport block size of 9185 bits (3GPP TS 25.321 table B.2a). The corresponding uplink data rate is 9185 bits/2 ms = 4.59 Mbps.
  15. Press the Measurement selection key and select Code Domain .
    • Select Code Domain Setup ( F1 ).
      • Set Transient Period to Exclude .
      • Set Trigger Source to Even Frame .
    • Show NCDP and ECDP by selecting Graph Control ( F2 ) and setting Table ( F3 ) = 2 so that you can compare NCDP and ECDP with 3GPP TS 34.121-1 table 5.13.2C.7.
    • Use the Marker ( F2 under Graph Control ( F2 ) ) to ensure that RCDE for each code channel meets the specified requirements in 34.121-1 tables 5.13.2C.8 and 5.13.2C.9.
    • The code channels are located as follows:
  16. Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Mode to Active bits (this is the default value).
  17. Set UE Target Power ( F7 on Call Parms 3 of 3 ) to -31 dBm . This value is determined as follows: 34.121-1 s5.13.1AAA requires a UE output power of -18 dBm, but UE Target Power only sets the DPCCH+DPDCH power level of the UE. In order to achieve a total output power of -18 dBm, you must set UE Target Power to at most -18 dBm - Power change due to HS-DPCCH, E-DPCCH and E DPDCH.Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH = 10log 10 (Beta c ^2 + Beta d ^2 + Beta hs ^2 + Beta ec ^2 + Beta ed1 ^2 + Beta ed2 ^2 + Beta ed3 ^2 + Beta ed4 ^2) - 10log 10 (Beta d ^2 + Beta c ^2) = 13.4 dB for sub-test 1, so you must set UE Target Power to -31 dBm .
  18. Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Mode to Alternating bits .
  19. Measure RCDE:
    • Show NCDP and ECDP by selecting Graph Control ( F2 ) and setting Table ( F3 ) = 2 so that you can compare NCDP and ECDP with 3GPP TS 34.121 table 5.13.2C.7.
    • Use the Marker ( F2 under Graph Control ( F2 ) ) to ensure that RCDE for each code channel meets the specified requirements in 34.121-1 tables 5.13.2C.8 and 5.13.2C.9.
  20. To repeat the test case at "mid range" and "high range" frequencies, use Physical Channel Reconfig ( F5 on Call Control 1 of 6 , F1 ) to perform a hard handover to the next channel. Set the Handover Downlink Channel (UARFCN) and Handover Uplink Channel (UARFCN) parameters to the appropriate "mid range" or "high range" frequencies for your UE's operating band, as specified by 3GPP TS 34.108 s5.1.1. Execute Handover ( F5 ) and then repeat steps 13 through 19.

Related Topics

Code Domain Measurement Description


How Do I Make a Channel Power Measurement?

How Do I Make a Channel Power Measurement?

Last updated: February 10, 2011

  • Measuring 3GPP TS 34.121 5.2A Maximum Output Power with HS-DPCCH (lab application or feature-licensed test application only)
  • Measuring 3GPP TS 34.121-1 (v8.10.0) 5.2B Maximum Output Power with HS-DPCCH and E-DCH (lab application or feature-licensed test application only)
  • Measuring 3GPP TS 34.121 5.4.3 Minimum Output Power

Before performing these procedures, ensure that you have specified the proper Amplitude Offset for your test setup, and that the test set has been properly calibrated (see Calibrating the Test Set ).

Measuring 3GPP TS 34.121 5.2A Maximum Output Power with HS-DPCCH

This section is applicable to the lab application or feature-licensed test application only.

3GPP TS 34.121 5.2A measures the UE's maximum output power when the HS-DPCCH is present. For ease of measurement, the test requires you to configure the UE such that the HS-DPCCH is always transmitted, and at a constant level. This is accomplished by setting DeltaACK , DeltaNACK and DeltaCQI to 8 , by setting CQI Feedback Cycle (k) to 4 ms and CQI Repetition Factor to 2 , and by setting Ack-Nack Repetition Factor to 3 (required because the test is performed using H-Set 1, which has an X00X00 data transmission pattern).

  1. Set parameters that can only be set in cell off operating mode (and other parameters that are set from the same menu):
    • Set Operating Mode ( F1 ) to Cell Off .
    • Select Channel (UARFCN) Parms ( F12 on Call Parms 1 of 3 ). Set DL Channel ( F7 ) and Uplink Channel ( F8 ) to the appropriate "low range" frequencies for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band II, set DL Channel = 9663 and Uplink Channel = 9263 ).
    • Select Uplink Parameters ( F4 on Call Control 2 of 5 ).
      • Set Uplink DPCH Bc/Bd Control to Manual .
      • Set Manual Uplink DPCH Bc to the value corresponding to the first 34.121 v7.0.0 Table C.10.1.4 sub-test you wish to test (for example, for sub-test 3, set Manual Uplink DPCH Bc to 15 ).
      • Set Manual Uplink DPCH Bd to the value corresponding to the first 34.121 v7.0.0 Table C.10.1.4 sub-test you wish to test (for example, for sub-test 3, set Manual Uplink DPCH Bd to 8 ).
      • Set Maximum Uplink Transmit Power Level to +21 dBm .
      • Note, Qqualmin and Qrxlevmin are fixed to -24 dB and -115 dBm, respectively, in the test set.
    • Set Operating Mode to Active Cell (pressing the CALL SETUP key quickly brings you back to the top level Call Control menu).
  2. Set Channel Type ( F8 ) to 12.2k RMC + HSDPA .
  3. Select HSDPA Parameters ( HSPA Parameters ( F10 ), F10 ).
    • Select HSDPA RB Test Mode Setup ( F8 ).
      • Set HS-DSCH Configuration Type to FRC (this is the default value).
      • Set FRC Type to H-Set 1 QPSK (this is the default value).
      • Set CN Domain as needed (by default it is set to PS Domain ). Note, before you can establish a connection in the PS domain, the UE must attach to the test set. To enable this, the PS Domain Information parameter (under Cell Parameters , F12 on Call Control 2 of 5 ) must be set to Present when the UE registers (attaches) with the test set.
    • Select HSDPA Uplink Parameters ( F11 ).
      • Set DeltaACK , DeltaNACK and DeltaCQI to 8 .
      • Set Ack-Nack Repetition Factor to 3 .
      • Set CQI Feedback Cycle (k) to 4 ms .
      • Set CQI Repetition Factor to 2 .
  4. Test Application: Press Cell Parameters ( F2 ).
    Lab Application: Press Cell Info ( F2 ), then Cell Parameters ( F2 ).
    ( from the Call Control 2 of 5 menu)
    • Set Default DPCH Offset (DOFF) to 3 x 512 chips .
    • Set PS Domain Information to Present (this is the default value in the lab application only) if you plan to establish the HSDPA connection in the PS domain (i.e. if you've set CN Domain to PS Domain in step 3 above).
  5. Select Generator Info ( F3 on Call Control 2 of 5 ), select Connected DL Channel Levels ( F4 ), then select HSDPA Conn DL Channel Levels ( F4 ).
    • Set Cell 1 Connected HSDPA CPICH Level to -10 dB (this is the default value).
    • Set Cell 1 Connected HSDPA P-CCPCH/SCH Level to -12 dB (this is the default value).
    • Set Cell 1 Connected HSDPA PICH Level to -15 dB (this is the default value).
    • Set Cell 1 Connected HSDPA DPCH Level to -9 dB .
    • Set Cell 1 Sum of Active Conn HS-PDSCH Levels to -3 dB (this is the default value).
    • Set Cell 1 Connected HS-SCCH 1 Level to -8 dB .
  6. Set any other parameters needed to establish a connection with your UE, then power on the UE and wait for it to register (attach). See Establishing an HSDPA Connection .
  7. Select Originate Call ( F3 on Call Control 1 of 5 ).
  8. Set Cell Power ( F7 on Call Parms 1 of 3 ) to -86 dBm/3.84 MHz .
  9. Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ).
    • Set UL CL Power Ctrl Mode to Active bits (this is the default value).
    • Set UL CL Power Ctrl Algorithm to Two (this is the default value). 34.121 specifies algorithm 1 in Annex I, but due to the fact that the test is performed with all up bits, either algorithm produces the same result.
  10. Set UE Target Power ( F7 on Call Parms 3 of 3 ) to a high value, such as 24 dBm . The test set drives the UE to the specified level (or simply continues to send all up bits if the UE does not reach that level), while also appropriately ranging the test set's measurement receiver.
  11. Select UL CL Power Ctrl Parameters ( F8 ). Set UL CL Power Ctrl Mode to All Up bits .
  12. Press the Measurement selection key.
  13. Select Channel Power .
  14. Set up the measurement:
    • Select Channel Power Setup (F1).
    • Set RRC Filter to Off (this is the default value), in order to measure "mean power".
    • Set Trigger Arm to Single , if desired.
    • Set Trigger Source to HS-DPCCH .
    • Set Measurement Interval to 666.7 us (one timeslot). This is the default value.
    • Select Close Menu ( F6 ).
  15. If you set Trigger Arm to Single , press the START SINGLE key to begin the measurement.
  16. Verify that the measured output power falls within the range specified by 34.121 Table 5.2A.2. For example, for sub-test 3 and a power class 3 UE, the output power must be 23 dBm +2.7/-3.7 dB.
  17. Repeat the test for "mid range" and "high range" frequencies (perform a Physical Channel Reconfiguration (Inter-frequency Hard Handover) , then repeat steps 14 and 15).
  18. Perform a Transport Channel Reconfiguration to change Beta c and Beta d to the values for any other 34.121 v7.0.0 Table C.10.1.4 sub-tests you wish to test (using the TCR Manual Uplink DPCH Bc and TCR Manual Uplink DPCH Bd settings), then repeat steps 14-16.
    Note, it is important that you properly configure all of the Transport Channel Reconfiguration parameters before executing the handover. For example, to maintain the proper settings for 5.2A, either set TCR Timing Indication (CFN Handling) to Maintain and TCR Relative DPCH Frame Offset to 0 chips or set TCR Default DPCH Offset (DOFF) to 3 x 512 chips . You must also set TCR DeltaACK , TCR DeltaNACK and TCR DeltaCQI to 8 , set TCR Ack-Nack Repetition Factor to 3 , set TCR CQI Feedback Cycle (k) to 4ms , and set TCR CQI Repetition Factor to 2 .

Measuring 3GPP TS 34.121-1 (v8.10.0) 5.2B Maximum Output Power with HS-DPCCH and E-DCH

This section is applicable to the lab application or feature-licensed test application only.

  1. Set parameters that can only be set in cell off operating mode (and other parameters that are set from the same menu):
    • Set Operating Mode ( F1 ) to Cell Off .
    • Select 34.121 Preset Call Configurations ( F11 on Call Parms 1 of 3 ) and select 5.2B, 5.9B, 5.10B, and 5.13.2B:HSPA:QPSK and then Sub-test 1 . You may then skip any steps marked with [34.121 Call Config] in this procedure.
    • Select Channel (UARFCN) Parms ( F12 on Call Parms 1 of 3 ). Set DL Channel ( F7 ) to the appropriate "low range" frequency for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band II set DL Channel = 9663 ).
    • [34.121 Call Config] Select Uplink Parameters ( F4 on Call Control 2 of 6 ).
      • [34.121 Call Config] Set Uplink DPCH Bc/Bd Control to Manual .
      • [34.121 Call Config] Set Manual Uplink DPCH Bc to 11 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
      • [34.121 Call Config] Set Manual Uplink DPCH Bd to 15 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
      • [34.121 Call Config] Set Maximum Uplink Transmit Power Level to 21 dBm .
    • Set Operating Mode to Active Cell (pressing the CALL SETUP key quickly brings you back to the top level Call Control menu).
  2. Set Cell Power ( F7 on Call Parms 1 of 3 ) to -86 dBm/3.84 MHz .
  3. [34.121 Call Config] Set Channel Type ( F8 ) to 12.2k RMC + HSPA (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
  4. [34.121 Call Config] Select Generator Info ( F3 on Call Control 2 of 6 ), select Downlink Channel Levels ( F3 ), and then Connected DL Channel Levels ( F3 ). Select HSPA Conn DL Channel Levels ( F4 ).
    • [34.121 Call Config] Set HSPA Cell 1 Connected CPICH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected P-CCPCH/SCH Level to -12 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected PICH Level to -15 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected (F-)DPCH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-AGCH Level to -20 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-HICH Level to -20 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-RGCH Level to Off (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected HS-PDSCHs Level (Sum) to -3 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected HS-SCCH 1 Level to -8 dB .
  5. [34.121 Call Config] Select HSUPA Parameters ( HSPA Parameters ( F10 ), F9 ).
    • [34.121 Call Config] Select HSUPA RB Test Mode Setup ( F8 ).
      • [34.121 Call Config] Set E-DCH RLC SDU Size to 2936 (this is the default value) (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
    • [34.121 Call Config] Select Common HSUPA Parameters ( F9 ).
      • [34.121 Call Config] Set E-DPCCH/DPCCH Power Offset (DeltaE-DPCCH) to 6 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1). Note, 34.121-1 Table C.11.1.3 provides Beta ec (209/225 for sub-test 1). To determine what value of DeltaE-DPCCH corresponds to this, use 3GPP TS 25.213 Table 1B and the value of Beta c from 34.121-1 Table C.11.1.3 (11/15 for sub-test 1). For sub-test 1, A ec = Beta ec /Beta c = (209/225)/(11/15) = 19/15; therefore DeltaE-DPCCH = 6.
      • [34.121 Call Config] Set Reference E-TFCI Power Offsets to Definition 34.121-01 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
    • [34.121 Call Config] Select Serving Grant ( F10 ).
      • [34.121 Call Config] Set RB Setup AG to Index 26: (119/15)^2 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1). Note, 34.121-1 Table C.11.1.3 AG Index corresponds to 3GPP TS 25.212 s4.10.1A.1 Table 16B, which maps the Absolute Grants sent on the E-AGCH. To send the equivalent Absolute Grant in the RB Setup message, you must use the AG Index in 3GPP TS 25.321 s9.2.5.2.1 Table 9.2.5.2.1.1.
  6. [34.121 Call Config] Select HSDPA Parameters ( HSPA Parameters ( F10 ), F10 ).
    • [34.121 Call Config] Select HSDPA RB Test Mode Setup ( F8 ), then HSDPA RB Test Mode Settings ( F8 ).
      • [34.121 Call Config] Set RB Test HS-DSCH Configuration Type to FRC (this is the default value).
      • [34.121 Call Config] Set FRC Type to H-Set 1 QPSK (this is the default value).
    • [34.121 Call Config] Select HSDPA Uplink Parameters ( F11 ).
      • [34.121 Call Config] Set DeltaACK , DeltaNACK and DeltaCQI to 8 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1). .
      • [34.121 Call Config] Set Ack-Nack Repetition Factor to 3 .
      • [34.121 Call Config] Set CQI Feedback Cycle (k) to 4 ms .
      • [34.121 Call Config] Set CQI Repetition Factor to 2 .
  7. Test Application: Select Cell Parameters ( F2 ).
    Lab Application: Select Cell Info ( F2 ), then Cell Parameters ( F2 ).
    ( from the Call Control 2 of 6 menu)
    • Set PS Domain Information to Present (this is the default value in the lab application).
    • Qqualmin and Qrxlevmin are fixed to -24 dB and -115 dBm, respectively, in the test application. In the lab application these are the default values for these parameters. They are accessible from Cell Info , Reselection Parameters ( F3 ).
  8. [34.121 Call Config] Select RB Test Mode Setup ( F6 on Call Control 3 of 6 ) and set UE Loopback Type to Type 1 (this is the default value).
  9. [34.121 Call Config] Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Algorithm to Two (this is the default value).
  10. Set any other parameters needed to establish a connection with your UE, then power on the UE and wait for it to register (attach). See Establishing an HSPA Connection .
    Note, before you can establish a connection in the PS domain (as is required for HSPA connections), the UE must attach to the test set. To enable this, the PS Domain Information parameter must be set to Present when the UE registers (attaches) with the test set.
  11. Select Originate Call ( F3 on Call Control 1 of 6 ).
  12. Drive the UE to the maximum power:
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Mode to Active bits (this is the default value) .
    • Set UE Target Power ( F7 on Call Parms 3 of 3 ) to 2 dBm (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1, power class 3 UE). This value is determined as follows: Maximum power for a power class 3 UE is +24 dBm, but UE Target Power only sets the DPCCH+DPDCH power level of the UE. In order to achieve a total output power of +16.5 dBm (24 dBm - 7.5 dB), you must set UE Target Power to at most 16.5 dBm - Power change due to HS-DPCCH, E-DPCCH and E-DPDCH .
      Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH = 10log 10 (Beta c ^2 + Beta d ^2 + Beta hs ^2 + Beta ec ^2 + Beta ed ^2) - 10log 10 (Beta d ^2 + Beta c ^2) = 14 dB for sub-test 1, so you must set UE Target Power to 2 dBm for sub-test 1.
      The UE Target Power values for sub-tests 2-5 are as follows: sub-test 2: 11 dBm, sub-test 3: 3 dBm, sub-test 4: 14 dBm, sub-test 5: 6 dBm.
    • Wait 150 ms.
    • Press the Measurement selection key and select Channel Power .
    • Set up the measurement:
      • Select Channel Power Setup ( F1 ).
      • Set Auto Range = On (or leave Auto Range = Off and set Manual Power Range to the Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH value calculated above).
      • Select Close Menu ( F6 ).
    • Observe the channel power measurement result to ensure that the UE's output power is at least 7.5 dB below max power (<16.5 dBm for power class 3 UEs).
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to Alternating bits (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
    • Select Additional Screens ( F1 from Call Control 2 of 6 ), select HSPA Information ( F2 ) and observe the Last Received E-TFCI (it should be 75 for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1, 67 for sub-test 2, 92 for sub-test 3, 71 for sub-test 4 and 67 for sub-test 5).
    • Select E-TFCI Recording Information ( F3 ) (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
    • Select HSPA Parameters ( F10 ), HSUPA Parameters ( F9 ), E-TFCI Recording ( F11 ), E-TFCI Recording Parameters ( F7 ) (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1):
      • [34.121 Call Config] Set E-TFCI Recording Count to 15 (this is the default value).
      • Select Send Step Up TPC Bit Pattern ( F10 ) and then Start Recording E-TFCI Values ( F8 ).
      • Observe whether the UE sent any decreased E-TFCI. If not, send another up TPC bit and record E-TFCI. Repeat until the UE sends at least one decreased E-TFCI.
      • Select Send Step Down TPC Bit Pattern ( F11 ) and then Start Recording E-TFCI Values ( F8 ).
      • Observe whether the UE sent any decreased E-TFCI. If it did, then send another down TPC bit, then continue to the next step. If not, continue to the next step.
      • Confirm that the E-TFCI is equal to the target E-TFCI of 75 for sub-test 1. If not, fail the UE. Note that an E-TFCI of 75 corresponds to an uplink data rate of 2421 bits/10 ms = 242 kbps. The uplink data rate for sub-test 2 = 175 kbps, sub-test 3 = 483 kbps, sub-test 4 = 206 kbps and sub-test 5 = 175 kbps.
  13. Measure channel power and determine whether the result is within the range specified by 3GPP TS 34.121-1 table 5.2B.5.
  14. To repeat this test for sub-tests 2-5:
    • Perform a Transport Channel Reconfiguration ( Handovers ( F5 )) to change the following settings:
      Sub-test 2-5 Transport Channel Reconfiguration settings
      Setting | Sub-test 2 | Sub-test 3 | Sub-test 4 | Sub-test 5
      TCR DPCH Bc/Bd Control | Manual | Manual | Manual | Manual
      TCR Manual Uplink DPCH Bc | 6 | 15 | 2 | 15
      TCR Manual Uplink DPCH Bd | 15 | 9 | 15 | 0
      TCR DeltaACK, DeltaNACK, DeltaCQI | 8 | 8 | 8 | 0
      TCR Ack-Nack Repetition Factor | 3 | 3 | 3 | 3
      TCR CQI Feedback Cycle (k) | 4 ms | 4 ms | 4 ms | 4 ms
      TCR CQI Repetition Factor | 2 | 2 | 2 | 2
      TCR E-DPCCH/DPCCH Power Offset | 8 | 8 | 5 | 0
      TCR Reference E-TFCI Power Offsets | 34121-01 | 34121-02 | 34121-01 | 34121-03
      TCR Absolute Grant | 18: (47/15)^2 | 21: (67/15)^2 | 23: (84/15)^2 | 18: (47/15)^2
    • For sub-tests 2-4, repeat steps 12 and 13.
    • For sub-test 5, end the call ( F3 ) and proceed as follows.
      • [34.121 Call Config] Set Channel Type ( F8 ) to HSPA .
      • [34.121 Call Config] Select HSUPA RB Test Mode Setup ( F8 ).
        • Set RB E-DPDCH Max Channel Codes (HSPA) to SF4 .
        • Set E-DCH RLC SDU Size to 11744 .
      • [34.121 Call Config] Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Algorithm to One .
      • Select Originate Call ( F3 on Call Control 1 of 6 ).
      • Drive the UE to the maximum power:
        • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Mode to Active bits .
        • Set UE Target Power ( F7 on Call Parms 3 of 3 ) to 6 dBm (for power class 3 UE).
        • Wait 150 ms.
        • Observe the channel power measurement result (pressing the MEASUREMENT key quickly brings you to the channel power measurement screen) to ensure that the UE's output power is at least 7.5 dB below max power (<16.5 dBm for power class 3 UEs).
        • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to All Up bits .
        • Wait 150 ms.
      • Repeat step 13.
  15. End the call ( F3 ) and repeat the testing at mid and high range frequencies.

Measuring 3GPP TS 34.121 5.4.3 Minimum Output Power

  1. Ensure that you have specified the proper Amplitude Offset for your test setup.
  2. Set the downlink and uplink channels:
    • Set Operating Mode ( F1 ) to Cell Off .
    • Set DL Channel ( F10 ) and Uplink Channel ( F11 ) to the appropriate "low range" frequencies for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band I, DL Channel = 10563 and Uplink Channel = 9613 ).
    • Set Operating Mode to Active Cell .
  3. Establish an RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  4. Ensure that the Connected DL Channel Levels are set to their default values, as required by 3GPP TS 34.121 Table E.3.1 (select Generator Info , F3 on Call Control 2 of 5 ).
  5. Set Cell Power ( F7 ) to -93 dBm .
  6. Set Call Drop Timer ( F11 on Call Parms 2 of 3 ) to Off .
  7. Set UE Target Power :
    • Ensure that UL CL Power Ctrl Mode is set to its default value of Active Bits (select UL CL Power Ctrl Parameters , F8 on the Call Parms 3 of 3 menu).
    • Set UE Target Power ( F7 ) to -55 dBm.

    The test set then drives the UE to the specified level, while also appropriately ranging its measurement receiver.

  8. Return to the UL CL Power Ctrl Parameters menu ( F8 ) and set UL CL Power Ctrl Mode to All Down bits and ensure that UL CL Power Ctrl Algorithm is set to Two . The test set then drives the UE to transmit at the lowest level possible.
  9. Press the Measurement selection key.
  10. Select Channel Power .
  11. Set up the measurement:
    • Select Channel Power Setup (F1).
    • Ensure that RRC Filter is set to its default value of Off (to measure "mean power").
    • Set Trigger Arm to Single .
    • Ensure that Measurement Interval is set to its default value of 666.7 us (one timeslot).
    • Select Close Menu ( F6 ).
  12. Press the START SINGLE key to begin the measurement.
  13. Verify that the measured output power is less than -49 dBm.
  14. Repeat the test for "mid range" and "high range" frequencies (perform a Physical Channel Reconfiguration (Inter-frequency Hard Handover) , then repeat steps 11 and 12).

Related Topics

Channel Power Measurement Description


How Do I Make a Change of TFC (Transport Format Combination) Measurement?

How Do I Make a Change of TFC (Transport Format Combination) Measurement?

Last updated: January 15, 2009

This section is only applicable to the lab application.

Measuring 3GPP TS 34.121 5.6 Change Of TFC

  1. Ensure that the test set has been properly calibrated (see Calibrating the Test Set ).
  2. Set the downlink and uplink channels:
    • Set Operating Mode ( F1 ) to Cell Off .
    • Set DL Channel ( F10 ) and Uplink Channel ( F11 ) to the appropriate "mid range" frequencies for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band I, DL Channel = 10700 and Uplink Channel = 9750 ).
    • Set Operating Mode to Active Cell .
  3. Ensure Uplink Dummy DCCH Data is set to its default value of Off (select RB Test Mode Setup , F6 on Call Control 3 of 5 ).
  4. Ensure Uplink DPCH Bc/Bd Control is set to its default value of Auto (select Uplink Parameters , F4 on Call Control 2 of 5 ).
  5. Ensure UL CL Power Ctrl Algorithm is set to its default value of Two (select UL CL Power Ctrl Parameters , F8 on Call Parms 3 of 3 ).
  6. Establish a 12.2k RMC RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  7. Ensure that the Connected DL Channel Levels are set to their default values, as required by 3GPP TS 34.121 Table E.3.1 (select Generator Info , F3 on Call Control 2 of 5 ).
  8. Set Cell Power ( F7 ) to -93 dBm .
  9. Set UE Target Power ( F7 on Call Parms 3 of 3 ) to 0 dBm . Ensure that UL CL Power Ctrl Mode is set to its default value of Active Bits (select UL CL Power Ctrl Parameters , F8 on Call Parms 3 of 3 ). The test set then drives the UE to 0 dBm, while also appropriately ranging its measurement receiver.
  10. Set UL CL Power Ctrl Mode to Alternating bits to hold the UE's power at 0 dBm.
  11. Press the Measurement selection key.
  12. Select Change Of TFC .
  13. Select Change Of TFC Setup ( F1 ).
    • Set Step Down Size to -7 dB.
    • Set Step Up Size to 7 dB.
    • Set Step Error Limit: Upper to 2 dB.
    • Set Step Error Limit: Lower to - 2 dB.
    • Select Close Menu ( F6 ).
  14. Press the START SINGLE key to begin the measurement.
  15. Verify that the Step Down Error and Step Up Error test results are Pass.

Related Topics

Change of TFC (Transport Format Combination) Measurement Description


How Do I Make a Dynamic Power Analysis Measurement?

How Do I Make a Dynamic Power Analysis Measurement?

Last updated: January 15, 2009

The dynamic power analysis measurement is a flexible tool that allows you to measure the output power of your UE versus time. This section provides examples for two main uses of the measurement, UE power calibration and HS-DPCCH power versus time measurement.

  • UE Power Calibration
  • Measuring 3GPP TS 34.121 v7.5.0 s5.7A HS-DPCCH

NOTE
Before performing a dynamic power analysis measurement, ensure that the measurement has been properly calibrated (see Calibrating the Test Set ).

UE Power Calibration

This procedure assumes that the test set is in Active Cell Operating Mode . However, this measurement is also available in FDD Test Operating Mode and CW Operating Mode .

  1. Set the test set's receiver to the proper power and frequency for your UE's power sequence:
    • Select Receiver Control ( F12 on Call Parms 3 of 3 ).
    • Set Power Control to Manual .
    • Set Manual Power to the initial transmit power of the UE's power sequence ( 0 dBm in the example pictured below).
    • Set Measurement Frequency to the frequency at which the UE will transmit its power sequence.
  2. Press the Measurement selection key.
  3. Select the Dynamic Power Analysis measurement.
  4. Select Dynamic Power Setup ( F1 ) and set the measurement parameters as needed. For example, to analyze the power sequence shown below, set the parameters as follows:
    • Set Steps to 23 .
    • Set Step Length to 666.7 us .
    • Set RF Rise Trigger Threshold to -10 dBm .
    • Set Trigger Qualification State to On .
    • Set Trigger Qualification Type to RF Rise and Fall .
    • Set Trigger Qualification Rise Threshold to 10 dB .
    • Set Trigger Qualification Fall Threshold to 10 dB .
    • Set Trigger Arm to Single .
    • Set Trigger Source to RF Rise .
  5. Select Close Menu ( F6 ).
  6. Place your UE into a test mode which will force it to continuously transmit the power sequence you desire to test. (To ensure that the measurement executes as quickly as possible, the UE should transmit its power sequence continuously until the measurement completes. This ensures that as soon as the measurement is done auto-ranging, another power sequence is immediately available for measurement. See Auto-ranging in the Dynamic Power Analysis Measurement for UE Power Calibration .)
  7. If Trigger Arm is set to Single , you must press the START SINGLE key to begin the measurement.
  8. Select Axis Control ( F2 ). Set the axis control parameters as needed. Select Return ( F6 ).
  9. Select Marker ( F3 ) to turn on the marker on the graphical display.

A typical result is shown below:

Measuring 3GPP TS 34.121 v7.5.0 s5.7A HS-DPCCH

This section is only applicable to the lab application or a test application with the required feature license.

Overview:

3GPP TS 34.121 s5.7A defines a specific UE output power waveform:

It then specifies the required relative power changes for the test points numbered above. The test is performed with the UE's DPCCH+DPDCH power equal to 0 dBm and also at maximum output power (the resulting power pattern and test points are altered somewhat at maximum power, but the ACK/CQI sequence is unchanged).

Procedure:

  1. Set parameters that can only be set in cell off operating mode (and other parameters that are set from the same menu):
    • Set Operating Mode ( F1 ) to Cell Off .
    • Select 34.121 Preset Call Configurations ( F11 on Call Parms 1 of 3 ) and select 5.2C, 5.7A, 5.13.1A, 5.13.1AA, 5.13.2A with QPSK . You may then skip any steps marked with [34.121 Call Config] in this procedure.
    • Select Channel (UARFCN) Parms ( F12 on Call Parms 1 of 3 ). Set DL Channel ( F7 ) and Uplink Channel ( F8 ) to the appropriate "mid range" frequencies for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band II, set DL Channel = 9800 ).
    • [34.121 Call Config] Select Uplink Parameters ( F4 on Call Control 2 of 5 ).
      • [34.121 Call Config] Set Uplink DPCH Bc/Bd Control to Manual .
      • [34.121 Call Config] Set Manual Uplink DPCH Bc to 15 (for 34.121 v7.5.0 Table C.10.1.4 sub-test 3).
      • [34.121 Call Config] Set Manual Uplink DPCH Bd to 8 (for 34.121 v7.5.0 Table C.10.1.4 sub-test 3).
      • [34.121 Call Config] Set Maximum Uplink Transmit Power Level to +21 dBm .
    • Set Operating Mode to Active Cell (pressing the CALL SETUP key quickly brings you back to the top level Call Control menu).
  2. [34.121 Call Config] Set Channel Type ( F8 ) to 12.2k RMC + HSDPA .
  3. Select HSDPA Parameters ( HSPA Parameters ( F10 ), F10 ).
    • Select HSDPA RB Test Mode Setup ( F8 ).
      • [34.121 Call Config] Set HS-DSCH Configuration Type to FRC (this is the default value).
      • [34.121 Call Config] Set FRC Type to H-Set 1 QPSK (this is the default value).
      • Set CN Domain as needed (by default it is set to PS Domain ). Note, before you can establish a connection in the PS domain, the UE must attach to the test set. To enable this, the PS Domain Information parameter (under Cell Parameters , F12 on Call Control 2 of 5 ) must be set to Present when the UE registers (attaches) with the test set.
    • [34.121 Call Config] Select HSDPA Uplink Parameters ( F11 ).
      • [34.121 Call Config] Set DeltaACK and DeltaNACK to 8 .
      • [34.121 Call Config] Set DeltaCQI to 7 .
      • [34.121 Call Config] Set Ack-Nack Repetition Factor to 1 (this is the default value).
      • [34.121 Call Config] Set CQI Feedback Cycle (k) to 4 ms .
      • [34.121 Call Config] Set CQI Repetition Factor to 1 (this is the default value).
  4. Test Application: Select Cell Parameters ( F2 ).
    Lab Application: Select Cell Info ( F2 ), then Cell Parameters ( F2 ).
    ( from the Call Control 2 of 5 menu)
    • [34.121 Call Config] Set Default DPCH Offset (DOFF) to 3 x 512 chips .
    • Set PS Domain Information to Present (this is the default value in the lab application) if you plan to establish the HSDPA connection in the PS domain (i.e. if you've set CN Domain to PS Domain or CS/PS Domain in step 3 above).
    • Qqualmin and Qrxlevmin are fixed to -24 dB and -115 dBm, respectively, in the test application. In the lab application these are the default values for these parameters. They are accessible from Cell Info , Reselection Parameters ( F3 ).
  5. [34.121 Call Config] Select Generator Info ( F3 on Call Control 2 of 5 ), select Connected DL Channel Levels ( F4 ), then select HSDPA Conn DL Channel Levels ( F4 ).
    • [34.121 Call Config] Set Cell 1 Connected HSDPA CPICH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set Cell 1 Connected HSDPA P-CCPCH/SCH Level to -12 dB (this is the default value).
    • [34.121 Call Config] Set Cell 1 Connected HSDPA PICH Level to -15 dB (this is the default value).
    • [34.121 Call Config] Set Cell 1 Connected HSDPA DPCH Level to -9 dB .
    • [34.121 Call Config] Set Cell 1 Sum of Active Conn HS-PDSCH Levels to -3 dB (this is the default value).
    • [34.121 Call Config] Set Cell 1 Connected HS-SCCH 1 Level to -8 dB .
  6. [34.121 Call Config] Select RB Test Mode Setup ( F6 on Call Control 3 of 5 ) and set UE Loopback Type to Type 1 (this is the default value).
  7. Set any other parameters needed to establish a connection with your UE, then power on the UE and wait for it to register (attach). See Establishing an HSDPA Connection .
  8. Select Originate Call ( F3 on Call Control 1 of 5 ).
  9. Set Cell Power ( F7 on Call Parms 1 of 3 ) to -86 dBm/3.84 MHz .
  10. Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ).
    • Set UL CL Power Ctrl Mode to Active bits (this is the default value).
    • [34.121 Call Config] Set UL CL Power Ctrl Algorithm to Two (this is the default value).
  11. To perform the test such that the DPCCH+DPDCH power is equal to 0 dBm, set UE Target Power ( F7 on Call Parms 3 of 3 ) to 0 dBm . The test set drives the UE's power to the specified value, while also appropriately ranging the test set's measurement receiver.
  12. Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to Alternating bits .
  13. Press the Measurement selection key.
  14. Select Dynamic Power Analysis .
  15. Set up the measurement:
    • Select Dynamic Power Setup ( F1 ).
    • Select 34.121 5.7A Measurement Configuration , then select Yes . You may then skip any steps marked with [34.121 Meas Config] .
    • [34.121 Meas Config] Set Steps to 37 .
    • [34.121 Meas Config] Set Step Length to 333.3 us .
    • [34.121 Meas Config] Set Measurement Interval to 283.3 us (to exclude the transient periods).
    • [34.121 Meas Config] Set RRC Filter to Off (to measure "mean power").
    • [34.121 Meas Config] Set Trigger Arm to Single , if desired.
    • [34.121 Meas Config] Set Trigger Source to HS-DPCCH .
    • [34.121 Meas Config] Set Trigger Delay to -308.3 us. (To trigger the measurement on the half slot just prior to subframe 0, a trigger delay of -333.3 us is required. To exclude the transient period after the slot boundary, a trigger delay of -333.3 us + 25 us = -308.3 us is required.)
    • [34.121 Meas Config] Set HS-DPCCH Trigger Subframe Alignment to subframe 0 (this is the default value).
    • Select Close Menu ( F6 ).
  16. If you set Trigger Arm to Single , press the START SINGLE key to begin the measurement.

  17. Adjust the Axis Control ( F2 ) as needed and use the Marker ( F3 ) to measure the power changes for each of the specified steps.

  18. To perform the test at the UE's maximum output power:
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to Active bits .
    • Set UE Target Power ( F7 on Call Parms 3 of 3 ) to a high value, such as 24 dBm . The test set drives the UE to the specified level (or simply continues to send all up bits if the UE does not reach that level), while also appropriately ranging the test set's measurement receiver.
    • Select UL CL Power Ctrl Parameters ( F8 ). Set UL CL Power Ctrl Mode to All Up bits .
    • Repeat steps 16 and 17.

Related Topics

Dynamic Power Analysis Measurement Description


How Do I Make an Extended Range Dynamic Power Measurement?

How Do I Make an Extended Range Dynamic Power Measurement?

Last updated: January 15, 2009

NOTE
Before performing an Extended Range Dynamic Power measurement, ensure that the test set has been properly calibrated (see Calibrating the Test Set ).

Measuring Extended Range Dynamic Power

This procedure assumes the test set is in Active Cell Operating Mode. However, this measurement is also available in FDD Test Operating Mode.

  1. Set the test set's receiver to the proper power and frequency for your UE's power sequence:
    • Select Receiver Control ( F12 on Call Parms 3 of 3 ).
    • Set Power Control to Manual .
    • Set Manual Power to the maximum power level expected in the first power sequence. For example, 13 dBm.
    • Set Measurement Frequency to the frequency at which the UE will transmit its power sequences (for example, 1 GHz).
  2. Press the Measurement selection key, select Extended Range Dynamic Power .
  3. Select Ext Range Dyn Power Setup ( F1 ) and set the measurement parameters as needed.
    • Set First Sequence Steps to the number of the steps in the UE's first power sequence (for example, 45). The number of the steps can be 1 to 84. NOTE: The total number of First Sequence Steps and Second Sequence Steps can not exceed 85.
    • Set Second Sequence Steps to the number of the steps in the UE's second power sequence (for example, 40). The number of the steps can be 1 to 84. NOTE: The total number of First Sequence Steps and Second Sequence Steps can not exceed 85.
    • Set Second Sequence Expected Power to the maximum power level expected in the UE's second power sequence (for example, -32 dBm). The test set requires re-ranging its receiver after completing the first power sequence and before measuring the second power sequence. You must command your UE to transmit for 15 power steps (timeslots) with constant or varied power levels between the two power sequences you desire to measure, to allow test set to re-range its receiver. The test set does not make any measurement during this period.
    • Set Trigger Source to RF Rise .
    • Set RF Rise Trigger Threshold as needed. It is recommended that you set RF Rise Trigger Threshold to approximately 10 dB below the Manual Power . For example, 3 dBm.
    • Select Close Menu ( F6 ).
  4. Place your UE into a test mode. To ensure that the measurement is successfully triggered, order your UE to transmit continuously at a low power level (for example, -20 dBm) so that the first power step in the power sequences will meet the requirements of the RF rise trigger (the trigger pulse should rise in power by at least 20 dB and above the RF Rise Trigger Threshold level. See Triggering the Extended Range Dynamic Power Measurement for details).
  5. Press the START SINGLE key to initiate (arm) the measurement.
  6. Order your UE to begin transmission of the power sequences (two power sequences to be measured and 15 power steps (timeslots) in the middle of the two power sequences for test set re-ranging its receiver. The test set does not make any measurement during the receiver re-ranging period).

    IMPORTANT
    Do not send any GPIB commands to the test set or press any front panel keys until the measurement has completed.

    When the measurement completes, the power results are displayed on the test set's screen. An example result is shown below.

  7. If needed, select Axis Control ( F2 ). Set the axis parameters as needed and then select Return ( F6 ).
  8. If needed, select Marker ( F3 ) to turn on the marker on the graphical display. The power level of the step as specified by the marker is also displayed at the top of the window.

Related Topics

Extended Range Dynamic Power Measurement Description


How Do I Make an Inner Loop Power Measurement?

How Do I Make an Inner Loop Power Measurement?

Last updated: January 15, 2009

Measuring 3GPP TS 34.121 5.4.2 Inner Loop Power Control in the Uplink

  1. Ensure that you have specified the proper Amplitude Offset for your test setup.
  2. Ensure that the test set has been properly calibrated (see Calibrating the Test Set ).
  3. Set the downlink and uplink channels:
    • Set Operating Mode ( F1 ) to Cell Off .
    • Set DL Channel ( F10 ) and Uplink Channel ( F11 ) to the appropriate "mid range" frequencies for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band I, DL Channel = 10700 and Uplink Channel = 9750 ).
    • Set Operating Mode to Active Cell .
  4. Establish an RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  5. Ensure that the Connected DL Channel Levels are set to their default values, as required by 3GPP TS 34.121 Table E.3.1 (select Generator Info , F3 on Call Control 2 of 5 ).
  6. Set Cell Power ( F7 ) to -93 dBm .
  7. Press the Measurement selection key.
  8. Select Inner Loop Power .
  9. Select Inner Loop Power Setup ( F1 ).
    • Set Test Segment to A.
    • Set Number of Slots as desired.
    • Select Close Menu ( F6 ).
  10. Press the START SINGLE key.
  11. Verify that the overall test segment result is Pass .
  12. If desired, select Axis Control ( F2 ).
    • Set Start , Span , Reference and dB/div as needed to properly display the (blue) absolute power trace.
    • Press the More key to move to Axis Control 2 of 2 . Set Relative Power ( F1 ) as needed to properly display the (yellow) relative power trace.
    • Select Return ( F6 ).
  13. If desired, select Marker ( F3 ) to turn on the marker on the graphical display and move the highlighted bar in the numerical results display area.
  14. Select Inner Loop Power Setup ( F1 ).
    • Set Test Segment to B.
    • Select Close Menu ( F6 ).
  15. Press the START SINGLE key.
  16. Verify that the overall test segment result is Pass .
  17. Repeat steps 14-16 for test segments C, E, F, G and H. Note: step D in 3GPP TS 34.121 5.4.2 is automatically performed as part of Test Segment E . For test segments E through H, ensure that Maximum Power Threshold for Test Control is set to Auto , Maximum Output Power Test Tolerance is set to 0.70 dB , Minimum Power Threshold for Test Control is set to Manual , and Minimum Power Threshold for Test Manual is set to -49 dBm (these are the default values), as required by 3GPP TS 34.121

Related Topics

Inner Loop Power Measurement Description


How Do I Make an IQ Tuning Measurement?

How Do I Make an IQ Tuning Measurement?

Last updated: January 15, 2009

NOTE
Before performing an IQ Tuning measurement, ensure that the measurement has been properly calibrated (see Calibrating the Test Set ).

Measuring IQ Tuning

  1. Establish an RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  2. Press the Measurement selection key.
  3. Select IQ Tuning .
  4. If Trigger Arm is set to Single , you must press the START SINGLE key to begin the measurement.
  5. Select IQ Tuning Setup ( F1 ) and set the measurement parameters as needed. Select Close Menu ( F6 ).
  6. Set Cell Power ( F7 ) as needed.
  7. Select Axis Control ( F2 ). Set the axis control parameters as needed. Select Return ( F6 ).
  8. Select Marker ( F3 ) to turn on the marker on the graphical display. The EVM for the selected chip is displayed.

A typical result is shown below.

Related Topics

IQ Tuning Measurement Description


How Do I Make an Occupied Bandwidth (OBW) Measurement?

How Do I Make an Occupied Bandwidth (OBW) Measurement?

Last updated: January 15, 2009

NOTE
Before performing this measurement, ensure that the test set has been properly calibrated (see Calibrating the Test Set ).

Measuring Occupied Bandwidth

  1. Establish an RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  2. Press the Measurement selection key.
  3. Select Occupied Bandwidth .
  4. Select Occupied BW Setup ( F1 ) and set the measurement parameters as needed. Select Close Menu ( F6 ).
  5. If Trigger Arm is set to Single , you must press the START SINGLE key to begin the measurement.

A typical result is shown below.

Related Topics

Occupied Bandwidth (OBW) Measurement Description


How Do I Make a PRACH Transmit On/Off Power Measurement?

How Do I Make a PRACH Transmit On/Off Power Measurement?

Last updated: January 15, 2009

Before performing any of these procedures, ensure that you have specified the proper Amplitude Offset for your test setup, and that the test set has been properly calibrated (see Calibrating the Test Set ).

  • Measuring 3GPP TS 34.121 5.4.1 Open Loop Power Control in the Uplink
  • Measuring 3GPP TS 34.121 5.5.1 Transmit OFF Power
  • Measuring 3GPP TS 34.121 5.5.2 Transmit ON/OFF Time Mask

Measuring 3GPP TS 34.121 5.4.1 Open Loop Power Control in the Uplink

  1. Set the downlink and uplink channels, and downlink channel levels:
    • Set Operating Mode ( F1 ) to Cell Off .
    • Set DL Channel ( F10 ) and Uplink Channel ( F11 ) to the appropriate "low range" frequencies for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band I, DL Channel = 10563 and Uplink Channel = 9613 ).
    • Ensure that the Downlink Channel Levels are set to their default values, as required by 3GPP TS 34.121 Table E.2.2 (select Generator Info , F3 on Call Control 2 of 5 ).
    • Set Operating Mode to Active Cell .
  2. Set uplink parameters:
    • Select Uplink Parameters ( F4 from the Call Control 2 of 5 menu).
    • Set PRACH Preambles to 4 .
    • Set PRACH Ramping Cycles (MMAX) to 1 (see Recommended PRACH Preambles and PRACH Ramping Cycles (MMAX) settings ).
    • Set Available Subchannels (Bit Mask) to only allow one available subchannel (for example, the default value of 000000000001).

    • Set Maximum Uplink Transmit Power Level to the specified maximum output power of your UE (for example, 21 dBm for power class 4).

      Note: Qqualmin and Qrxlevmin are fixed to -24 dB and -115 dBm in the test set, as required by 3GPP TS 34.121 Table 5.4.1.1a.

    • Select Close Menu ( F6 ).
  3. Set cell parameters:
    • Test Application: Press Cell Parameters ( F2 ).
      Lab Application: Press Cell Info ( F2 ), then Cell Parameters ( F2 ).
      ( from the Call Control 2 of 5 menu)
    • Ensure that Primary CPICH TX Power is set to its default value of 19 dBm .
    • Set Uplink Interference to -75 dBm .
    • Ensure that Constant Val ue is set to its default value of -10 dB .
    • Select Close Menu ( F6 ).
  4. Connect the UE to the test set, power it on and wait for it to camp to the test set's signal, but do not originate a call between the test set and UE (see How Do I Set Up a Call and Make a Connection? ).
  5. Set Cell Power ( F7 on Call Parms 1 of 3 ) to -25 dBm .
  6. Ensure that Call Limit State ( F10 on Call Parms 2 of 3 ) is set to its default value of Off (see Importance of Setting Call Limit State to Off before Initiating a PRACH Measurement ).
  7. Press the Measurement selection key.
  8. Select PRACH Transmit On/Off Power .
  9. Select PRACH TX On/Off Pwr Setup ( F1 ).
    • Ensure that Open Loop Power Error Upper Limit is set to its default value of 9 dB .
    • Ensure that Open Loop Power Error Lower Limit is set to its default value of -9 dB .
    • Select Close Menu ( F6 ).
  10. Press the START SINGLE key to begin the measurement.
  11. Verify that the Open Loop Power Error test result is Pass .
  12. To test "RX-middle" or "RX-Sensitivity level" cases:
    • Set cell parameters:
      • Press the CALL SETUP key.
      • Test Application: Press Cell Parameters ( F2 ).
        Lab Application: Press Cell Info ( F2 ), then Cell Parameters ( F2 ).
        ( from the Call Control 2 of 5 menu)
      • Set BCCH Update Page to Auto so the test set will notify the UE when you change the next two cell parameters.
      • Set Primary CPICH TX Power to 28 dBm or 19 dBm .
      • Set Uplink Interference to -101 dBm or -110 dBm .
      • Ensure that Constant Value is still set to -10 dB .
      • Select Close Menu ( F6 ).
    • Set Cell Power ( F7 ) to -65.7 dBm or -106.7 dBm .
    • Press the MEASUREMENT key to move to the Measurement/Instrument screen.
    • Ensure that the test set is in Idle state (see Test set may lock up if operations are attempted before the UE completes its PRACH sequence ), then press the START SINGLE key to begin the measurement.
    • Verify that the Open Loop Power Error test result is Pass .
  13. Repeat the test for "mid range" and "high range" frequencies. Note, if your UE does not camp to the test set at the new frequency, you may need to cycle the UE's power.

Measuring 3GPP TS 34.121 5.5.1 Transmit OFF Power

See Measuring 3GPP TS 34.121 5.5.2 Transmit ON/OFF Time Mask .

Measuring 3GPP TS 34.121 5.5.2 Transmit ON/OFF Time Mask

  1. Set the downlink and uplink channels, and downlink channel levels:
    • Set Operating Mode ( F1 ) to Cell Off .
    • Set DL Channel ( F10 ) and Uplink Channel ( F11 ) to the appropriate "low range" frequencies for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band I, DL Channel = 10563 and Uplink Channel = 9613 ).
    • Ensure that the Downlink Channel Levels are set to their default values as required by 3GPP TS 34.121 Table E.2.2. (select Generator Info , F3 on Call Control 2 of 5 ).
    • Set Operating Mode to Active Cell .
  2. Set uplink parameters:
    • Select Uplink Parameters ( F4 from the Call Control 2 of 5 menu).
    • Set PRACH Preambles to 4 .
    • Set PRACH Ramping Cycles (MMAX) to 1 (see Recommended PRACH Preambles and PRACH Ramping Cycles (MMAX) settings ).
    • Set Available Subchannels (Bit Mask) to only allow one available subchannel (for example, the default value of 000000000001).

    • Set Maximum Uplink Transmit Power Level to the specified maximum output power of your UE (for example, 21 dBm for power class 4).

      Note: Qqualmin and Qrxlevmin are fixed to -24 dB and -115 dBm in the test set, as required by 3GPP TS 34.121 Table 5.4.1.1a.

    • Select Close Menu ( F6 ).
  3. Set cell parameters:
    • Test Application: Press Cell Parameters ( F2 ).
      Lab Application: Press Cell Info ( F2 ), then Cell Parameters ( F2 ).
      ( from the Call Control 2 of 5 menu)
    • Ensure that Primary CPICH TX Power is set to its default value of 19 dBm .
    • Set Uplink Interference to the proper value for your UE's power class as required by 3GPP TS 34.121 Table 5.5.2.3 (for example, -98 dBm for power class 4).
    • Ensure that Constant Val ue is set to its default value of -10 dB .
    • Select Close Menu ( F6 ).
  4. Connect the UE to the test set, power it on and wait for it to camp to the test set's signal, but do not originate a call between the test set and UE (see How Do I Set Up a Call and Make a Connection? ).
  5. Set Cell Power ( F7 ) to -106.7 dBm .
  6. Ensure that Call Limit State ( F10 on Call Parms 2 of 3 ) is set to its default value of Off (see Importance of Setting Call Limit State to Off before Initiating a PRACH Measurement ).
  7. Press the Measurement selection key.
  8. Select PRACH Transmit On/Off Power .
  9. Select PRACH TX On/Off Pwr Setup ( F1 ).
    • Ensure that Off Power Limit is set to its default value of -55 dBm .
    • Set Open Loop Power Error Upper Limit to 1.7 or 2.7 dB , depending upon your UE's power class, as required by 3GPP TS 34.121 Table 5.2.2.
    • Ensure that Open Loop Power Error Lower Limit is set to its default value of -9 dB .
    • Select Close Menu ( F6 ).
  10. Press the START SINGLE key to begin the measurement.
  11. Verify that the Pre Burst Off Power , Open Loop Power Error and Post Burst Off Power test results are Pass .
  12. Repeat the test for "mid range" and "high range" frequencies. Note, if your UE does not camp to the test set at the new frequency, you may need to cycle the UE's power.

Related Topics

PRACH Transmit On/Off Power Measurement Description


How Do I Make an Out-of-Synch Handling of Output Power Measurement?

How Do I Make an Out-of-Synch Handling of Output Power Measurement?

Last updated: January 15, 2009

This section is only applicable to the lab application.

Measuring 3GPP TS 34.121 5.4.4 Out-of-Synchronization Handling of Output Power

Connect the Test Set, Spectrum Analyzer and UE

  1. Connect the UE to the test set's RF IN/OUT port and to the spectrum analyzer's RF INPUT port via an RF splitter.
  2. Connect the test set's rear panel TRIG OUT port to the spectrum analyzer's TRIGGER IN port.

Configure the Spectrum Analyzer

This example uses an Agilent E4443A PSA Series Spectrum Analyzer.

  1. Press the MODE key. Select Spectrum Analysis .
  2. Press the FREQUENCY key. Set Center Freq to the appropriate "mid range" frequency for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band I, 1950.0 MHz ).
  3. Press the Amplitude key.
    • Select More to move to the 2 of 3 menu. Set REF Lvl OFFst to 9 dB to account for the loss due to the RF splitter (or to the appropriate value for your test setup).
    • Select More to move to the 1 of 3 menu. Set Ref Level to -30 dBm (or to the appropriate level for your test setup to allow accurate measurement of the UE's off power).
  4. Press the SPAN key and select Zero Span .
  5. Press the Det/Demod key. Set Detector to Man and choose Average (Log/RMS/V) (this also sets BW/Avg : Avg/VBW Type to Pwr Avg (RMS) ).
  6. Press the BW/Avg key. Set Res BW to 5 MHz .
  7. Press the Sweep key.
    • Set Sweep Time to 20 s .
    • Set Points to 8001 . Select Enter .
  8. Press the Trig key and select Ext Rear or Ext Front .

Configure the Test Set

  1. Set the RF IN/OUT Amplitude Offset to -9 dB (or to the appropriate value for your test setup) to account for the loss due to the RF splitter (press the SYSTEM CONFIG key, then select RF IN/OUT Amptd Offset ( F5 )).
  2. Set the downlink channel:
    • Set Operating Mode ( F1 ) to Cell Off .
    • Set DL Channel ( F10 ) to the appropriate "mid range" frequency for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band I, DL Channel = 10700 ).
    • Set Operating Mode to Active Cell .
  3. Set Cell Parameters.
     Test Application: Press Cell Parameters ( F2 ).
    Lab Application: Press Cell Info ( F2 ), then Cell Parameters ( F2 ).
    ( from the Call Control 2 of 5 menu)
    • Set N313 Successive Out-Of-Sync Reception Max to S200 .
    • Set T313 Out-Of-Sync Reception Timer to 15 s .
    • Set N315 Successive In-Sync Reception Counter to S1 .

    Select Close Menu ( F6 ).

  4. Select Generator Info ( F3 ). Select Connected DL Channel Levels ( F4 ).
    • Set Cell 1 Connected CPICH Level to -10.00 dB .
    • Set Cell 1 Connected P-CCPCH/SCH Level to -12.00 dB .
    • Set Cell 1 Connected S-CCPCH Level to Off .
    • Set Cell 1 Connected PICH Level to -15.00 dB .
    • Set Cell 1 Connected DPCH Level to -16.60 dB .

    Select Close Menu ( F6 ) and Return ( F6 ).

  5. Set Trigger Output Setup ( F6 ) to Measurement Generated .
  6. Establish a 12.2k RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  7. Set UE Target Power ( F7 on the Call Parms 3 of 3 menu) to 28 dBm .
  8. Select UL CL Power Ctrl Parameters ( F8 ). Set UL CL Power Control Mode to All Up bits .
  9. Set Cell Power ( F7 on the Call Parms 1 of 3 menu) to -61 dBm .
  10. Select Generator Info ( F3 on the Call Control 2 of 5 menu) and set AWGN Power ( F5 ) to -60 dBm.

Initiate the Measurement from the Test Set

  1. Press the Measurement selection key and choose Out-of-Synch Handling of Output Power .
  2. Select Out-of-Sync Power Setup and set the parameters as needed. The default values are those specified by 3GPP TS 34.121 5.4.4. Select Close Menu ( F6 ).
  3. Press the START SINGLE key.

View the Measurement Results on the Spectrum Analyzer

A typical result is shown below.

  1. Press the Marker key.
    • Enter 5.2 s for Marker 1 . Ensure that the UE's output power is off (less than -55 dBm) at this marker position.
    • Select Marker 2 . Select Normal . Enter 15.4 s . Ensure that the UE's output power is on (greater than -49 dBm) at this marker position.

Return Test Set Settings to Their Pre-Measurement Values

If desired, when you have completed the measurement, select End Call ( F3 ) and return the following settings to their pre-measurement values:

  • Set Cell Parameters.
     Test Application: Press Cell Parameters ( F2 ).
    Lab Application: Press Cell Info ( F2 ), then Cell Parameters ( F2 ).
    ( from the Call Control 2 of 5 menu)
    • Set N313 UE Out-Of-Sync Counter to S2 .
    • Set T313 UE Link Reestablishment Timer to 3 .
    • Set N315 UE In-Sync Counter to S50 .

    Select Close Menu ( F6 ).

  • Select Generator Info ( F3 ). Select Connected DL Channel Levels ( F4 ).
    • Set Cell 1 Connected CPICH Level to -3.30 dB .
    • Set Cell 1 Connected P-CCPCH/SCH Level to -5.35 dB .
    • Set Cell 1 Connected S-CCPCH Level to Off .
    • Set Cell 1 Connected PICH Level to -8.33 dB .
    • Set Cell 1 Connected DPCH Level to -10.30 dB .

    Select Close Menu ( F6 ) and Return ( F6 ).

  • Set Trig Output Setup ( F6 ) to Sys Frame Clock .
  • Select UL CL Power Ctrl Parameters ( F8 ). Set UL CL Power Ctrl Mode to Active bits .
  • Set UE Target Power ( F7 on the Call Parms 3 of 3 menu) as desired.
  • Set Cell Power ( F7 on the Call Parms 1 of 3 menu) as desired.
  • Select Generator Info ( F3 on the Call Control 2 of 5 menu) and set AWGN Power ( F5 ) as desired.

Related Topics

Out-of-Synch Handling of Output Power Measurement Description

Out-of-Synch Handling of Output Power Troubleshooting

What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?


How Do I Make a Phase Discontinuity Measurement?

How Do I Make a Phase Discontinuity Measurement?

Last updated: January 15, 2009

  • Measuring Non-HSDPA Phase Discontinuity
  • Measuring 3GPP TS 34.121 v7.5.0 5.13.1AA Error Vector Magnitude (EVM) and Phase Discontinuity with HS-DPCCH ( lab application or feature-licensed test application only )

Before performing these procedures, ensure that you have specified the proper Amplitude Offset for your test setup, and that the test set has been properly calibrated (see Calibrating the Test Set ).

Measuring Non-HSDPA Phase Discontinuity

  1. Establish a non-HSDPA RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  2. Set UL CL Power Control Mode to Active Bits (this is the default setting).
  3. Set UE Target Power to the UE's maximum output power (for example, 21 dBm ).
  4. Press the Measurement selection key.
  5. Select the Phase Discontinuity measurement.
  6. Select Phase Discont. Setup ( F1 )
    • Set Trigger Source to Protocol .
    • Set Power Control Pattern to 5DOWN/4UP .
    • Set Number of Pattern Repetitions to 10 .
    • Select Close Menu ( F6 ).
  7. Press the START SINGLE key to begin the measurement.
  8. Select Graph Control ( F2 ).
  9. Select Axis Control ( F1 ) to set the axis control parameters as needed:
    • Start ( F1 ) determines the first slot result displayed.
    • Span ( F2 ) determines the number of timeslots for which results are displayed.
    • Phase Reference ( F3 on Axis Control 1 of 2 ).
    • Phase Range ( F4 on Axis Control 1 of 2 ).
    • Power Ref ( F3 on Axis Control 2 of 2 ).
    • Power Range ( F4 on Axis Control 2 of 2 ).

    Select Return ( F6 ).

  10. Select Trace Show/Hide ( F4 ) to choose which of the 3 available traces to display ( Phase Discontinuity , Phase and Power ). Select Close Menu ( F6 ).
  11. Select Marker ( F2 ) to turn on the marker on the graphical display and move the highlighted bar in the numerical results display area. Scroll through the numerical data and locate the orange values indicating worst case phase discontinuity and worst case EVM to determine whether the UE has met specifications for this portion of the test.

  12. Select Table ( F3 ) to scroll through the 9 columns of numerical results available, as needed.

    A typical result is pictured below:

  13. Select Return ( F6 ).

  14. Repeat steps 7-12 until the UE reaches its minimum output power (for example, -49 dBm). You can easily determine the UE's output power level by noting the UE Target Power level ( F7 on the Call Parms 3 of 3 menu), because at the completion of the measurement, the test set sets MS Target Power to the UE's output power in the final measured slot).

    You may choose to overlap the test subsequences by starting at an MS Target Power that is offset from the ending power level, see Key 3GPP Tests Performed Using the Phase Discontinuity Measurement for more information.

  15. Select Phase Discont. Setup ( F1 )
    • Set Power Control Pattern to 5UP/4DOWN .
    • Set Number of Pattern Repetitions to 10 .
    • Select Close Menu ( F6 ).
  16. Repeat steps 7-12 until the UE reaches its maximum output power.

Measuring 3GPP TS 34.121 v7.5.0 5.13.1AA Error Vector Magnitude (EVM) and Phase Discontinuity with HS-DPCCH

This section is applicable to the lab application or feature-licensed test application only.

This test is applicable to Release 6 and later HSDPA UEs. For Release 5 HSDPA UEs, see Measuring 3GPP TS 34.121 v7.5.0 s5.13.1A Error Vector Magnitude (EVM) with HS-DPCCH .

Overview:

3GPP TS 34.121 5.13.1AA measures EVM and phase discontinuity at four locations on a defined 12 ms UE power pattern:

The test is performed such that the 12 ms UE power pattern maximum corresponds to the UE's maximum output power as defined in 34.121 Table 5.2A.2. The test is also performed such that the 12 ms UE power pattern maximum corresponds to -18 dBm.

Procedure:

  1. Set parameters that can only be set in cell off operating mode (and other parameters that are set from the same menu):
    • Set Operating Mode ( F1 ) to Cell Off .
    • Select 34.121 Preset Call Configurations ( F11 on Call Parms 1 of 3 ) and select 5.2C, 5.7A, 5.13.1A, 5.13.1AA, 5.13.2A with QPSK . You may then skip any steps marked with [34.121 Call Config] in this procedure.
    • Select Channel (UARFCN) Parms ( F12 on Call Parms 1 of 3 ). Set DL Channel ( F7 ) and Uplink Channel ( F8 ) to the appropriate "low range" frequencies for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band II, set DL Channel = 9663 ).
    • [34.121 Call Config] Select Uplink Parameters ( F4 on Call Control 2 of 5 ).
      • [34.121 Call Config] Set Uplink DPCH Bc/Bd Control to Manual .
      • [34.121 Call Config] Set Manual Uplink DPCH Bc to 15 (for 34.121 v7.2.0 Table C.10.1.4 sub-test 3).
      • [34.121 Call Config] Set Manual Uplink DPCH Bd to 8 (for 34.121 v7.2.0 Table C.10.1.4 sub-test 3).
      • [34.121 Call Config] Set Maximum Uplink Transmit Power Level to +21 dBm .
    • Set Operating Mode to Active Cell (pressing the CALL SETUP key quickly brings you back to the top level Call Control menu).
  2. [34.121 Call Config] Set Channel Type ( F8 ) to 12.2k RMC + HSDPA .
  3. Select HSDPA Parameters ( HSPA Parameters ( F10 ), F10 ).
    • Select HSDPA RB Test Mode Setup ( F8 ).
      • [34.121 Call Config] Set HS-DSCH Configuration Type to FRC (this is the default value).
      • [34.121 Call Config] Set FRC Type to H-Set 1 QPSK (this is the default value).
      • Set CN Domain as needed (by default it is set to PS Domain ). Note, before you can establish a connection in the PS domain, the UE must attach to the test set. To enable this, the PS Domain Information parameter (under Cell Parameters , F12 on Call Control 2 of 5 ) must be set to Present when the UE registers (attaches) with the test set.
    • [34.121 Call Config] Select HSDPA Uplink Parameters ( F11 ).
      • [34.121 Call Config] Set DeltaACK and DeltaNACK to 8 .
      • [34.121 Call Config] Set DeltaCQI to 7 .
      • [34.121 Call Config] Set Ack-Nack Repetition Factor to 1 (this is the default value).
      • [34.121 Call Config] Set CQI Feedback Cycle (k) to 4 ms .
      • [34.121 Call Config] Set CQI Repetition Factor to 1 (this is the default value).
  4. Test Application: Select Cell Parameters ( F2 ).
    Lab Application: Select Cell Info ( F2 ) , then Cell Parameters ( F2 ).
    (from the Call Control 2 of 5 menu)
    • [34.121 Call Config] Set Default DPCH Offset (DOFF) to 3 x 512 chips .
    • Set PS Domain Information to Present (this is the default value in the lab application) if you plan to establish the HSDPA connection in the PS domain (i.e. if you've set CN Domain to PS Domain or CS/PS Domain in step 3 above).
    • Qqualmin and Qrxlevmin are fixed to -24 dB and -115 dBm, respectively, in the test application. In the lab application these are the default values for these parameters. They are accessible from Cell Info , Reselection Parameters ( F3 ).
  5. [34.121 Call Config] Select Generator Info ( F3 on Call Control 2 of 5 ), select Connected DL Channel Levels ( F4 ), then select HSDPA Conn DL Channel Levels ( F4 ).
    • [34.121 Call Config] Set Cell 1 Connected HSDPA CPICH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set Cell 1 Connected HSDPA P-CCPCH/SCH Level to -12 dB (this is the default value).
    • [34.121 Call Config] Set Cell 1 Connected HSDPA PICH Level to -15 dB (this is the default value).
    • [34.121 Call Config] Set Cell 1 Connected HSDPA DPCH Level to -9 dB .
    • [34.121 Call Config] Set Cell 1 Sum of Active Conn HS-PDSCH Levels to -3 dB (this is the default value).
    • [34.121 Call Config] Set Cell 1 Connected HS-SCCH 1 Level to -8 dB .
  6. Set any other parameters needed to establish a connection with your UE, then power on the UE and wait for it to register (attach). See Establishing an HSDPA Connection .
  7. Select Originate Call ( F3 on Call Control 1 of 5 ).
  8. Set Cell Power ( F7 on Call Parms 1 of 3 ) to -86 dBm/3.84 MHz .
  9. Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ).
    • Set UL CL Power Ctrl Mode to Active bits (this is the default value).
    • [34.121 Call Config] Set UL CL Power Ctrl Algorithm to Two (this is the default value).

  10. To perform the test such that the 12 ms UE power pattern maximum corresponds to the UE's maximum output power as defined in 34.121 Table 5.2A.1, set UE Target Power ( F7 on Call Parms 3 of 3 ) to the appropriate value for your UE's power class.

    Required UE Target Power Setting to Achieve Table 34.121 Table 5.2A.2 Maximum Power
    UE Power Class | 34.121 v7.5.0 Table C.10.1.4 Sub-Test | UE Target Power setting
    3 | 3 | 16.9 dBm
    4 | 3 | 13.9 dBm

    For example, for a power class 3 UE, set UE Target Power to 16.9 dBm (the test set rounds this value to 17 dBm). The test set drives the UE's DPCCH+DPDCH level to 17 dBm, which places the UE's DPCCH+DPDCH+HS-DPCCH level at 23.1 dBm, while also appropriately ranging the test set's measurement receiver.

  11. Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to Alternating bits .
  12. Press the Measurement selection key.
  13. Select Phase Discontinuity .
  14. Set up the phase discontinuity measurement:
    • Select Phase Discont Setup ( F1 ).
    • Set Trigger Source to HS-DPCCH .
    • Set HS-DPCCH Trigger Subframe Alignment to subframe 0 (this is the default value).
    • Set HS-DPCCH Trigger Slot Alignment to AckNack (this is the default value) .
    • Set HS-DPCCH Trigger Subslot Alignment to 0.0 slot (this is the default value) .
    • Set HS-DPCCH Measurement Step Interval to 0.5 slot (this is the default value) .
    • Set HS-DPCCH Measurement Step Count to 21 (this is the default value) .
    • Select Close Menu ( F6 ).
  15. Press the START SINGLE key to begin the measurement.
  16. Select Graph Control ( F2 ) and adjust Axis Control ( F1 ) as needed. Note that the Power Ref and Power Range can be adjusted by pressing the More ( 1 of 2 ) key. Select Return ( F6 ).
    Note the following example uses Trace Show/Hide ( F4 ) to hide the Phase trace.
  17. Use the Marker ( F2 ) to verify that the measured EVM is less than 17.5% for test points 1, 2, 3 and 4 (marker indices 0, 1, 20 and 21), and that the phase discontinuity across points A and B (marker indices 1 and 21) is less than 36 degrees.
  18. To perform the test such that the 12 ms UE power pattern maximum corresponds to -18 dBm:
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to Active bits .
    • Set UE Target Power ( F7 on Call Parms 3 of 3 ) to -24.1 dBm (for 34.121 v7.2.0 Table C.10.1.4 sub-test 3). The test set drives the UE's DPCCH+DPDCH level to -24 dBm, which places the UE's DPCCH+DPDCH+HS-DPCCH level at approximately -18 dBm, while also appropriately ranging the test set's measurement receiver.
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to Alternating bits .
    • Repeat steps 15-17.
  19. To perform the test for "mid range" and "high range" frequencies:
    • Perform a Physical Channel Reconfiguration (Inter-frequency Hard Handover) to the appropriate UARFCNs.
    • Repeat steps 9-18.

Related Topics

Phase Discontinuity Measurement Description

Phase Discontinuity Troubleshooting

Programming the Phase Discontinuity Measurement

Measuring 3GPP TS 34.121 v7.5.0 s5.13.1A Error Vector Magnitude (EVM) with HS-DPCCH (using the Waveform Quality measurement)


How Do I Make a PRACH Preamble Analysis Measurement?

How Do I Make a PRACH Preamble Analysis Measurement?

Last updated: January 15, 2009

This section is only applicable to the lab application.

NOTE
Before performing a PRACH preamble analysis measurement, ensure that the measurement has been properly calibrated (see Calibrating the Test Set ).

Measuring PRACH Preamble Analysis

  1. Power the UE on and wait for it to camp to the test set, but DO NOT establish a connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  2. Press the right More key until you reach the Call Parms 2 of 3 menu. Ensure that Call Limit State ( F2 ) is set to Off .
  3. Press the left More key until you reach the Call Control 2 of 5 menu. Select Uplink Parameters ( F4 ).
  4. Set the PRACH Signature parameters as needed.
  5. Set PRACH Preambles to at least 3.
  6. Set Available Subchannels (Bit Mask) to specify only one available subchannel. Select Close Menu ( F6 ).
  7. Press the Measurement selection key.
  8. Select the PRACH Preamble Analysis measurement.
  9. Select PRACH Preamble Setup ( F1 ) and set the measurement parameters as needed. Select Close Menu ( F6 ).
  10. Set Cell Power ( F7 ) as needed.
  11. Press the START SINGLE key to begin the measurement.
  12. Select Graph Control ( F2 ).
  13. Select Axis Control ( F1 ). Set the axis control parameters as needed. Select Return ( F6 ).
  14. Select Marker ( F2 ) to turn on the marker on the graphical displays.
  15. Select View Select ( F3 ) and then Zoom View ( F4 ) to zoom on one of the graphical display results.

Related Topics

PRACH Preamble Analysis Measurement Description


How Do I Make a Spectrum Emission Mask Measurement?

How Do I Make a Spectrum Emission Mask Measurement?

Last updated: February 12, 2011

  • Measuring Spectrum Emission Mask
  • Measuring 3GPP TS 34.121-1 (v8.10.0) 5.9B Spectrum Emission Mask with E-DCH (lab application or feature-licensed test application only)

NOTE
Before performing this measurement, ensure that the test set has been properly calibrated (see Calibrating the Test Set ).

Measuring Spectrum Emission Mask

  1. Establish an RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  2. Press the Measurement selection key.
  3. Select Spectrum Emission Mask .
  4. Select SEM Setup ( F1 ) and set the measurement parameters as needed. Select Close Menu ( F6 ).
  5. If Trigger Arm is set to Single , you must press the START SINGLE key to begin the measurement.
  6. Press the Change View ( F2 ) key to display the measurement results in either graphical or numeric format.

A typical result is shown below.

Measuring 3GPP TS 34.121-1 (v8.10.0) 5.9B Spectrum Emission Mask with E-DCH

This section is applicable to the lab application or feature-licensed test application only.

  1. Set parameters that can only be set in cell off operating mode (and other parameters that are set from the same menu):
    • Set Operating Mode ( F1 ) to Cell Off .
    • Select 34.121 Preset Call Configurations ( F11 on Call Parms 1 of 3 ) and select 5.2B, 5.9B, 5.10B, and 5.13.2B:HSPA:QPSK , then select the desired sub-test. You may then skip any steps marked with [34.121 Call Config] in this procedure.
    • Select Channel (UARFCN) Parms ( F12 on Call Parms 1 of 3 ). Set DL Channel ( F7 ) to the appropriate "low range" frequency for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band II set DL Channel = 9663 ).
    • [34.121 Call Config] Select Uplink Parameters ( F4 on Call Control 2 of 6 ).
      • [34.121 Call Config] Set Uplink DPCH Bc/Bd Control to Manual .
      • [34.121 Call Config] Set Manual Uplink DPCH Bc to 11 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
      • [34.121 Call Config] Set Manual Uplink DPCH Bd to 15 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
      • [34.121 Call Config] Set Maximum Uplink Transmit Power Level to +21 dBm .
    • Set Operating Mode to Active Cell (pressing the CALL SETUP key quickly brings you back to the top level Call Control menu).
  2. Set Cell Power ( F7 on Call Parms 1 of 3 ) to -86 dBm/3.84 MHz .
  3. [34.121 Call Config] Set Channel Type ( F8 ) to 12.2k RMC + HSPA (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
  4. [34.121 Call Config] Select Generator Info ( F3 on Call Control 2 of 6 ), select Downlink Channel Levels ( F3 ), select Connected DL Channel Levels ( F3 ), then select HSPA Conn DL Channel Levels ( F4 ).
    • [34.121 Call Config] Set HSPA Cell 1 Connected CPICH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected P-CCPCH/SCH Level to -12 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected PICH Level to -15 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected (F-)DPCH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-AGCH Level to -20 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-HICH Level to -20 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected E-RGCH Level to Off (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected HS-PDSCHs Level (Sum) to -3 dB (this is the default value).
    • [34.121 Call Config] Set HSPA Cell 1 Connected HS-SCCH 1 Level to -8 dB .
  5. [34.121 Call Config] Select HSUPA Parameters ( HSPA Parameters ( F10 ), F9 ).
    • [34.121 Call Config] Select HSUPA RB Test Mode Setup ( F8 ).
      • [34.121 Call Config] Set E-DCH RLC SDU Size to 2936 (this is the default value).
    • [34.121 Call Config] Select Common HSUPA Parameters ( F9 ).
      • [34.121 Call Config] Set E-DPCCH/DPCCH Power Offset (DeltaE-DPCCH) to 6 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1). Note, 34.121-1 Table C.11.1.3 provides Beta ec (209/225 for sub-test 1). To determine what value of DeltaE-DPCCH corresponds to this, use 3GPP TS 25.213 Table 1B and the value of Beta c from 34.121-1 Table C.11.1.3 (11/15 for sub-test 1). For sub-test 1, A ec = Beta ec /Beta c = (209/225)/(11/15) = 19/15; therefore DeltaE-DPCCH = 6.
      • [34.121 Call Config] Set Reference E-TFCI Power Offsets to Definition 34.121-01 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
    • [34.121 Call Config] Select Serving Grant ( F10 ).
      • [34.121 Call Config] Set RB Setup AG to 26: (119/15)^2 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1). Note, 34.121-1 Table C.11.1.3 AG Index corresponds to 3GPP TS 25.212 s4.10.1A.1 Table 16B, which maps the Absolute Grants sent on the E-AGCH. To send the equivalent Absolute Grant in the RB Setup message, you must use the AG Index in 3GPP TS 25.321 s9.2.5.2.1.1 Table 9.2.5.2.1.1.
  6. [34.121 Call Config] Select HSDPA Parameters ( HSPA Parameters ( F10 ), F10 ).
    • [34.121 Call Config] Select HSDPA RB Test Mode Setup ( F8 ), then select HSDPA RB Test Mode Settings ( F8 ).
      • [34.121 Call Config] Set RB Test HS-DSCH Configuration Type to FRC (this is the default value).
      • [34.121 Call Config] Set FRC Type to H-Set 1 QPSK (this is the default value).
    • [34.121 Call Config] Select HSDPA Uplink Parameters ( F11 ).
      • [34.121 Call Config] Set DeltaACK , DeltaNACK and DeltaCQI to 8 (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
      • [34.121 Call Config] Set Ack-Nack Repetition Factor to 3 .
      • [34.121 Call Config] Set CQI Feedback Cycle (k) to 4 ms .
      • [34.121 Call Config] Set CQI Repetition Factor to 2 .
  7. Test Application: Select Cell Parameters ( F2 ).
    Lab Application: Select Cell Info ( F2 ), then Cell Parameters ( F2 ).
    ( from the Call Control 2 of 6 menu)
    • Set PS Domain Information to Present (this is the default value in the lab application).
    • Qqualmin and Qrxlevmin are fixed to -24 dB and -115 dBm, respectively, in the test application. In the lab application these are the default values for these parameters. They are accessible from Cell Info , Reselection Parameters ( F3 ).
  8. [34.121 Call Config] Select RB Test Mode Setup ( F6 on Call Control 3 of 6 ) and set UE Loopback Type to Type 1 (this is the default value).
  9. [34.121 Call Config] Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Algorithm to Two (this is the default value) (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
  10. Set any other parameters needed to establish a connection with your UE, then power on the UE and wait for it to register (attach). See Establishing an HSPA Connection .
    Note, before you can establish a connection in the PS domain (as is required for HSPA connections), the UE must attach to the test set. To enable this, the PS Domain Information parameter must be set to Present when the UE registers (attaches) with the test set.
  11. Select Originate Call ( F3 on Call Control 1 of 6 ).
  12. Drive the UE to maximum power:
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Mode to Active bits (this is the default value).
    • Set UE Target Power ( F7 on Call Parms 3 of 3 ) to 2 dBm (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1, power class 3 UE). This value is determined as follows: Maximum power for a power class 3 UE is +24 dBm, but UE Target Power only sets the DPCCH+DPDCH power level of the UE. In order to achieve a total output power of +16.5 dBm (24 dBm - 7.5 dB), you must set UE Target Power to at most 16.5 dBm - Power change due to HS-DPCCH, E-DPCCH and E-DPDCH .
      Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH = 10log 10 (Beta c ^2 + Beta d ^2 + Beta hs ^2 + Beta ec ^2 + Beta ed ^2) - 10log 10 (Beta d ^2 + Beta c ^2) = 14 dB for sub-test 1, so you must set UE Target Power to 2 dBm for sub-test 1.
      The UE Target Power values for sub-tests 2-5 are as follows: sub-test 2: 11 dBm, sub-test 3: 3 dBm, sub-test 4: 14 dBm, sub-test 5: 6 dBm.
    • Wait 150 ms.
    • Press the Measurement selection key and select Channel Power .
    • Set up the measurement:
      • Select Channel Power Setup ( F1 ).
      • Set Auto Range = On (or leave Auto Range = Off and set Manual Power Range to the Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH value calculated above).
      • Select Close Menu ( F6 ).
    • Observe the channel power measurement result to ensure that the UE's output power is at least 7.5 dB below max power (<16.5 dBm for power class 3 UEs).
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to Alternating bits (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
    • Select Additional Screens ( F1 from Call Control 2 of 6 ), select HSPA Information ( F2 ) and observe the Last Received E-TFCI (it should be 75 for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1, 67 for sub-test 2, 92 for sub-test 3, 71 for sub-test 4 and 67 for sub-test 5).
    • Select E-TFCI Recording Information ( F3 ) (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1).
    • Select HSPA Parameters ( F10 ), HSUPA Parameters ( F9 ), E-TFCI Recording ( F11 ), E-TFCI Recording Parameters ( F7 ) (for 34.121-1 v8.10.0 Table C.11.1.3 sub-test 1):
      • [34.121 Call Config] Set E-TFCI Recording Count to 15 (this is the default value).
      • Select Send Step Up TPC Bit Pattern ( F10 ) and then Start Recording E-TFCI Values ( F8 ).
      • Observe whether the UE sent any decreased E-TFCI. If not, send another up TPC bit and record E-TFCI. Repeat until the UE sends at least one decreased E-TFCI.
      • Select Send Step Down TPC Bit Pattern ( F11 ) and then Start Recording E-TFCI Values ( F8 ).
      • Observe whether the UE sent any decreased E-TFCI. If it did, then send another down TPC bit, then continue to the next step. If not, continue to the next step.
      • Confirm that the E-TFCI is equal to the target E-TFCI of 75 for sub-test 1. If not, fail the UE. Note that an E-TFCI of 75 corresponds to an uplink data rate of 2421 bits/10 ms = 242 kbps. The uplink data rate for sub-test 2 = 175 kbps, sub-test 3 = 483 kbps, sub-test 4 = 206 kbps and sub-test 5 =175 kbps.
  13. Press the Measurement selection key and select Spectrum Emission Mask .
  14. Set up the measurement.
    • Select SEM Setup ( F1 ).
      • Set Measurement Fail Limit Mask to Basic and Additional .
    • Select Graph ( F3 ).
      • Select Trace Show/Hide ( F1 ), set Additional Requirement to On .
  15. Determine whether the results are within the range specified by 3GPP TS 34.121-1 tables 5.9B.3, 5.9B.3A, 5.9B.3B and 5.9B.3C.
  16. To repeat this test for sub-tests 2-5:
    • Perform a Transport Channel Reconfiguration ( Handovers ( F5 )) to change the following settings:
      Sub-test 2-5 Transport Channel Reconfiguration settings
      Setting | Sub-test 2 | Sub-test 3 | Sub-test 4 | Sub-test 5
      TCR DPCH Bc/Bd Control | Manual | Manual | Manual | Manual
      TCR Manual Uplink DPCH Bc | 6 | 15 | 2 | 15
      TCR Manual Uplink DPCH Bd | 15 | 9 | 15 | 0
      TCR DeltaACK, DeltaNACK, DeltaCQI | 8 | 8 | 8 | 0
      TCR Ack-Nack Repetition Factor | 3 | 3 | 3 | 3
      TCR CQI Feedback Cycle (k) | 4 ms | 4 ms | 4 ms | 4 ms
      TCR CQI Repetition Factor | 2 | 2 | 2 | 2
      TCR E-DPCCH/DPCCH Power Offset | 8 | 8 | 5 | 0
      TCR Reference E-TFCI Power Offsets | 34121-01 | 34121-02 | 34121-01 | 34121-03
      TCR Absolute Grant | 18: (47/15)^2 | 21: (67/15)^2 | 23: (84/15)^2 | 18: (47/15)^2
    • For sub-tests 2-4, repeat steps 12 and 15.
    • For sub-test 5, end the call ( F3 ) and proceed as follows.
      • Set Channel Type ( F8 ) to HSPA .
      • Select HSUPA RB Test Mode Setup ( F8 ) and set RB E-DPDCH Max Channel Codes (HSPA) to SF4 .
      • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Algorithm to One .
      • Select Originate Call ( F3 on Call Control 1 of 6 ).
      • Drive the UE to maximum power:
        • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ) and set UL CL Power Ctrl Mode to Active bits .
        • Set UE Target Power ( F7 on Call Parms 3 of 3 ) to 6 dBm (for power class 3 UE).
        • Wait 150 ms.
        • Observe the channel power measurement result (pressing the MEASUREMENT key quickly brings you to the channel power measurement screen) to ensure that the UE's output power is at least 7.5 dB below max power (<16.5 dBm for power class 3 UEs).
        • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to All Up bits .
        • Wait 150 ms.
      • Repeat step 15.
  17. End the call (F3).
  18. Repeat the testing at mid and high range frequencies.

Related Topics

Spectrum Emission Mask Measurement Description


How Do I Make a TX Dynamic Power Measurement?

How Do I Make a TX Dynamic Power Measurement?

Last updated: January 15, 2009

NOTE
Before performing a TX dynamic power measurement, ensure that the test set has been properly calibrated (see Calibrating the Test Set ).

Measuring TX Dynamic Power

This procedure assumes the test set is in Active Cell Operating Mode . However, this measurement is also available in FDD Test Operating Mode and CW Operating Mode .

  1. Set the test set's receiver to the proper power and frequency for your UE's power sequence:
    • Select Receiver Control ( F12 on Call Parms 3 of 3 ).
    • Set Power Control to Manual .
    • Set Manual Power to the initial transmit power of the UE's power sequence.
    • Set Measurement Frequency to the frequency at which the UE will transmit its power sequence.
  2. Press the Measurement selection key.
  3. Select TX Dynamic Power .
  4. Select TX Dynamic Pwr Setup ( F1 ).
    • Set Power Step Size to the size of the downward steps in the UE's power sequence.
    • Set Number of Power Steps to the number of steps down the UE will make in its power sequence.
    • Set Power Step Time to the duration of the steps in the UE's power sequence.
    • Select Close Menu ( F6 ).
  5. Connect your UE to the test set's front panel RF IN/OUT connector and power it on.
  6. Once the UE is on and transmitting the initial transmit power level continuously, press the START SINGLE key to initiate (arm) the measurement.
  7. Order your UE to create the necessary RF rise to trigger the measurement (see How is a TX Dynamic Power Measurement Made? ). The UE should then hold its power at the initial transmit power level for the duration of Power Step Time , then proceed with its step down power sequence. When the power sequence is complete, the power results are displayed on the test set's screen.

    IMPORTANT
    Do not send any GPIB commands to the test set or press any front panel keys until the measurement has completed.

    An example result is shown below. Note that the number of power results is always equal to the Number of Power Steps setting plus one, as the power in slot 0 is the initial power of the UE, before its first step down in power.

  8. Select Graph Control ( F2 ).
  9. Set Start Step ( F3 ) and Span ( F4 ) as needed to view some or all of the power sequence.
  10. Select Marker ( F2 ) to turn on the marker on the graphical display and move the highlighted bar in the numerical results display area.

Related Topics

TX Dynamic Power Measurement Description


How Do I Make a Thermal Power Measurement?

How Do I Make a Thermal Power Measurement?

Last updated: January 15, 2009

Measuring 3GPP TS 34.121 5.2 Maximum Output Power

  1. Ensure that you have specified the proper Amplitude Offset for your test setup.
  2. Set the downlink and uplink channels:
    • Set Operating Mode ( F1 ) to Cell Off .
    • Set DL Channel ( F10 ) and Uplink Channel ( F11 ) to the appropriate "low range" frequencies for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band I, DL Channel = 10563 and Uplink Channel = 9613 ).
    • Set Operating Mode to Active Cell .
  3. Establish an RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  4. Ensure that the Connected DL Channel Levels are set to their default values, as required by 3GPP TS 34.121 Table E.3.1 (select Generator Info , F3 on Call Control 2 of 5 ).
  5. Set Cell Power ( F7 ) to -93 dBm .
  6. Set UE Target Power :
    • Select UL CL Power Ctrl Parameters ( F8 on the Call Parms 3 of 3 menu) and set UL CL Power Ctrl Mode to Active bits .
    • Set UE Target Power ( F7 ) to the specified maximum output power for your UE (for example, 21 dBm for power class 4).

    The test set then drives the UE to the specified level, while also appropriately ranging its measurement receiver.

  7. Return to the UL CL Power Ctrl Parameters menu ( F8 ) and set UL CL Power Ctrl Mode to All Up bits and set UL CL Power Ctrl Algorithm to Two . The test set then drives the UE to transmit at the highest level possible.
  8. Press the Measurement selection key.
  9. Select Thermal Power .
  10. Select Thermal Power Setup (F1) and set Trigger Arm to Single . Select Close Menu ( F6 ).
  11. Press the START SINGLE key to begin the measurement.
  12. Verify that the measured output power is within the range specified by 3GPP TS 34.121 Table 5.2.2 (for example, 21 dBm +/- 2.7 dB for power class 4).
  13. Repeat the test for "mid range" and "high range" frequencies (perform a Physical Channel Reconfiguration (Inter-frequency Hard Handover) , then repeat steps 11 and 12).

Related Topics

Thermal Power Measurement Description


How Do I Make a Waveform Quality Measurement?

How Do I Make a Waveform Quality Measurement?

Last updated: June 5, 2009

  • Measuring 3GPP TS 34.121 5.3 Frequency Error
  • Measuring 3GPP TS 34.121 v7.5.0 s5.13.1A Error Vector Magnitude (EVM) with HS-DPCCH ( lab application or feature-licensed test application only )

Before performing these procedures, ensure that you have specified the proper Amplitude Offset for your test setup, and that the test set has been properly calibrated (see Calibrating the Test Set ).

Measuring 3GPP TS 34.121 5.3 Frequency Error

  1. Set the downlink and uplink channels:
    • Set Operating Mode ( F1 ) to Cell Off .
    • Set DL Channel ( F10 ) and Uplink Channel ( F11 ) to the appropriate "low range" frequencies for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band I, DL Channel = 10563 and Uplink Channel = 9613 ).
    • Set Operating Mode to Active Cell .
  2. Establish an RB Test Mode connection between the UE and test set (see How Do I Set Up a Call and Make a Connection? ).
  3. Ensure that the Connected DL Channel Levels are set to their default values, as required by 3GPP TS 34.121 Tables 5.3 and E.3.1 (select Generator Info , F3 on Call Control 2 of 5 ).
  4. Set Cell Power ( F7 ) to -106.7 dBm .
  5. Set UE Target Power :
    • Ensure that UL CL Power Ctrl Mode is set to its default value of Active Bits (select UL CL Power Ctrl Parameters , F8 on the Call Parms 3 of 3 menu).
    • Set UE Target Power ( F7 ) to the specified maximum output power for your UE (for example, 21 dBm for power class 4).

    The test set then drives the UE to the specified level, while also appropriately ranging its measurement receiver.

  6. Return to the UL CL Power Ctrl Parameters menu ( F8 ) and set UL CL Power Ctrl Mode to All Up bits and ensure that UL CL Power Ctrl Algorithm is set to Two . The test set then drives the UE to transmit at the highest level possible.
  7. Press the Measurement selection key.
  8. Select Waveform Quality .
  9. Select Waveform Quality Setup (F1) and set Trigger Arm to Single .
  10. Press the START SINGLE key to begin the measurement.
  11. Verify that the measured Frequency Error is less than +/- (0.1 ppm + 10 Hz). For an uplink frequency of 1922.6 MHz, this corresponds to a frequency error requirement of +/- 202.26 Hz.
  12. Repeat the test for "mid range" and "high range" frequencies (perform a Physical Channel Reconfiguration (Inter-frequency Hard Handover) , then repeat steps 12 and 13).

Measuring 3GPP TS 34.121 v7.5.0 s5.13.1A Error Vector Magnitude (EVM) with HS-DPCCH

This section is applicable to the lab application or feature-licensed test application only.

This test is applicable to Release 5 UEs only. For Release 6 and later UEs, see Measuring 3GPP TS 34.121 v7.5.0 5.13.1AA Error Vector Magnitude (EVM) and Phase Discontinuity with HS-DPCCH .

Overview:

3GPP TS 34.121 5.13.1A measures EVM at four locations on a defined 12 ms UE power pattern:

The test is performed such that the 12 ms UE power pattern maximum corresponds to the UE's maximum output power as defined in 34.121 Table 5.2A.2. The test is also performed such that the 12 ms UE power pattern maximum corresponds to -18 dBm.

Procedure:

  1. Set parameters that can only be set in cell off operating mode (and other parameters that are set from the same menu):
    • Set Operating Mode ( F1 ) to Cell Off .
    • Select 34.121 Preset Call Configurations ( F11 on Call Parms 1 of 3 ) and select 5.2C, 5.7A, 5.13.1A, 5.13.1AA, 5.13.2A with QPSK . You may then skip any steps marked with [34.121 Call Config] in this procedure.
    • Select Channel (UARFCN) Parms ( F12 on Call Parms 1 of 3 ). Set DL Channel ( F7 ) and Uplink Channel ( F8 ) to the appropriate "low range" frequencies for your UE's operating band, as specified by 3GPP TS 34.108 5.1.1 (for example, for operating band II, set DL Channel = 9663 ).
    • [34.121 Call Config] Select Uplink Parameters ( F4 on Call Control 2 of 5 ).
      • [34.121 Call Config] Set Uplink DPCH Bc/Bd Control to Manual .
      • [34.121 Call Config] Set Manual Uplink DPCH Bc to 15 (for 34.121 v7.2.0 Table C.10.1.4 sub-test 3).
      • [34.121 Call Config] Set Manual Uplink DPCH Bd to 8 (for 34.121 v7.2.0 Table C.10.1.4 sub-test 3).
      • [34.121 Call Config] Set Maximum Uplink Transmit Power Level to +21 dBm .
    • Set Operating Mode to Active Cell (pressing the CALL SETUP key quickly brings you back to the top level Call Control menu).
  2. [34.121 Call Config] Set Channel Type ( F8 ) to 12.2k RMC + HSDPA .
  3. Select HSDPA Parameters ( HSPA Parameters ( F10 ), F10 ).
    • Select HSDPA RB Test Mode Setup ( F8 ).
      • [34.121 Call Config] Set HS-DSCH Configuration Type to FRC (this is the default value).
      • [34.121 Call Config] Set FRC Type to H-Set 1 QPSK (this is the default value).
      • Set CN Domain as needed (by default it is set to PS Domain ). Note, before you can establish a connection in the PS domain, the UE must attach to the test set. To enable this, the PS Domain Information parameter (under Cell Parameters , F12 on Call Control 2 of 5 ) must be set to Present when the UE registers (attaches) with the test set.
    • [34.121 Call Config] Select HSDPA Uplink Parameters ( F11 ).
      • [34.121 Call Config] Set DeltaACK and DeltaNACK to 8 .
      • [34.121 Call Config] Set DeltaCQI to 7 .
      • [34.121 Call Config] Set Ack-Nack Repetition Factor to 1 (this is the default value).
      • [34.121 Call Config] Set CQI Feedback Cycle (k) to 4 ms .
      • [34.121 Call Config] Set CQI Repetition Factor to 1 (this is the default value).
  4. Test Application: Select Cell Parameters ( F2 ).
    Lab Application: Select Cell Info ( F2 ) , then Cell Parameters ( F2 ).
    (from the Call Control 2 of 5 menu)
    • [34.121 Call Config] Set Default DPCH Offset (DOFF) to 3 x 512 chips .
    • Set PS Domain Information to Present (this is the default value in the lab application) if you plan to establish the HSDPA connection in the PS domain (i.e. if you've set CN Domain to PS Domain or CS/PS Domain in step 3 above).
    • Qqualmin and Qrxlevmin are fixed to -24 dB and -115 dBm, respectively, in the test application. In the lab application these are the default values for these parameters. They are accessible from Cell Info , Reselection Parameters ( F3 ).
  5. [34.121 Call Config] Select Generator Info ( F3 on Call Control 2 of 5 ), select Connected DL Channel Levels ( F4 ), then select HSDPA Conn DL Channel Levels ( F4 ).
    • [34.121 Call Config] Set Cell 1 Connected HSDPA CPICH Level to -10 dB (this is the default value).
    • [34.121 Call Config] Set Cell 1 Connected HSDPA P-CCPCH/SCH Level to -12 dB (this is the default value).
    • [34.121 Call Config] Set Cell 1 Connected HSDPA PICH Level to -15 dB (this is the default value).
    • [34.121 Call Config] Set Cell 1 Connected HSDPA DPCH Level to -9 dB .
    • [34.121 Call Config] Set Cell 1 Sum of Active Conn HS-PDSCH Levels to -3 dB (this is the default value).
    • [34.121 Call Config] Set Cell 1 Connected HS-SCCH 1 Level to -8 dB .
  6. Set any other parameters needed to establish a connection with your UE, then power on the UE and wait for it to register (attach). See Establishing an HSDPA Connection .
  7. Select Originate Call ( F3 on Call Control 1 of 5 ).
  8. Set Cell Power ( F7 on Call Parms 1 of 3 ) to -86 dBm/3.84 MHz .
  9. Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ).
    • Set UL CL Power Ctrl Mode to Active bits (this is the default value).
    • [34.121 Call Config] Set UL CL Power Ctrl Algorithm to Two (this is the default value).

  10. To perform the test such that the 12 ms UE power pattern maximum corresponds to the UE's maximum output power as defined in 34.121 Table 5.2A.1, set UE Target Power ( F7 on Call Parms 3 of 3 ) to the appropriate value for your UE's power class.

    Required UE Target Power Setting to Achieve Table 34.121 Table 5.2A.2 Maximum Power
    UE Power Class | 34.121 v7.5.0 Table C.10.1.4 Sub-Test | UE Target Power setting
    3 | 3 | 16.9 dBm
    4 | 3 | 13.9 dBm

    For example, for a power class 3 UE, set UE Target Power to 16.9 dBm (the test set rounds this value to 17 dBm). The test set drives the UE's DPCCH+DPDCH level to 17 dBm, which places the UE's DPCCH+DPDCH+HS-DPCCH level at 23.1 dBm, while also appropriately ranging the test set's measurement receiver.

  11. Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to Alternating bits .

  12. You can you use the Dynamic Power Analysis measurement to quickly verify that your UE is transmitting the 12 ms power pattern specified by 5.13.1A. To do so, press the Measurement selection key and select Dynamic Power Analysis , then select Dynamic Power Setup ( F1 ) and select 34.121 5.7A Measurement Configuration , then Yes (or set Steps to 37 , Step Length to 333.3 us , Measurement Interval to 283.3 us , Trigger Source to HS-DPCCH , Trigger Delay to -308.3 us , and HS-DPCCH Trigger Subframe Alignment to subframe 0 ). Press START SINGLE and adjust the Axis Control ( F2 ) as needed.

    Once you have verified that your UE is transmitting the proper pattern, you can initiate the Waveform Quality measurement and adjust the Waveform Quality trigger settings to measure each test point:

  13. Press the Measurement selection key.
  14. Select Waveform Quality .
  15. Set up the Waveform Quality measurement:
    • Select Waveform Quality Setup ( F1 ).
    • To measure test point 1, select 34.121 5.13.1A Low of Low-High Transition , then select Yes . You may then skip any steps marked with [34.121 Meas Config] .
    • [34.121 Meas Config] Set Trigger Source to HS-DPCCH .
    • [34.121 Meas Config] Set Transient Period to Exclude .
    • [34.121 Meas Config] Set HS-DPCCH Measurement Interval to 0.5 slot .
    • Set Trigger Arm to Single , if desired.
    • Select Close Menu ( F6 ).
  16. If you set Trigger Arm to Single , press the START SINGLE key to begin the measurement.

  17. Verify that the measured EVM is less than 17.5% for each of the four test points, using the following settings:

    Waveform Quality Settings for the Four Test Points

            These settings are automatically set by the 34.121 Meas Configs

    Test Point

    34.121 Meas Config

             HS-DPCCH Trigger Subframe Alignment HS-DPCCH Trigger Slot Alignment HS-DPCCH Trigger Subslot Alignment
    1

    34.121 5.13.1A Low of Low-High Transition

             subframe 5 CQI2 0.5 slot
    2

    34.121 5.13.1A High of Low-High Transition

             subframe 0 AckNack 0.0 slot
    3

    34.121 5.13.1A High of High-Low Transition

             subframe 3 AckNack 0.5 slot
    4

    34.121 5.13.1A Low of High-Low Transition

             subframe 3 CQI1 0.0 slot
  18. To perform the test such that the 12 ms UE power pattern minimum corresponds to -18 dBm:
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to Active bits .
    • Set UE Target Power ( F7 on Call Parms 3 of 3 ) to -24.1 dBm (for 34.121 v7.2.0 Table C.10.1.4 sub-test 3). The test set drives the UE's DPCCH+DPDCH level to -24 dBm, which places the UE's DPCCH+DPDCH+HS-DPCCH level at approximately -18 dBm, while also appropriately ranging the test set's measurement receiver.
    • Select UL CL Power Ctrl Parameters ( F8 on Call Parms 3 of 3 ). Set UL CL Power Ctrl Mode to Alternating bits .
    • Repeat steps 12-17.
  19. To perform the test for "mid range" and "high range" frequencies:
    • Perform a Physical Channel Reconfiguration (Inter-frequency Hard Handover) to the appropriate UARFCNs.
    • Repeat steps 9-18.

Related Topics

Waveform Quality Measurement Description

Waveform Quality Troubleshooting

Programming a Waveform Quality Measurement

How Do I Make a Dynamic Power Analysis Measurement?

Measuring 3GPP TS 34.121 v7.5.0 5.13.1AA Error Vector Magnitude (EVM) and Phase Discontinuity with HS-DPCCH (using the Phase Discontinuity measurement)


How Do I Establish a Simultaneous Services Connection?

How Do I Establish a Simultaneous Services Connection?

Last updated: March 3, 2009

This section is only applicable to the lab application.

  1. Set the GPRS Radio Access Bearer to one of the following configurations:
    • 64k PS Data RAB
    • 64k UL/384k DL PS Data RAB
    • HSUPA UL / HSDPA DL PS

    This parameter can be accessed on the test set's front panel by pressing CALL SETUP , left-hand side More key until menu 3 of 5 appears, Data Channels ( F4 ), Packet Data Setup ( F1 ).

  2. Establish a AMR voice call and a PS data connection. The order in which these connections are established does not matter). Also, the AMR voice connection can be either mobile originated (MO) or mobile terminated (MT). (See How Do I Set Up a Call and Make a Connection? and Establishing a Packet Data Connection for more information.)

    Alternatively, you can establish an AMR voice call and a PS data connection from the Simultaneous Sevices menu by pressing Originate AMR Voice Call ( F3 ) to establish an AMR call or Originate PS Data Connection ( F4 ). The Simultaneous Services menu can be accessed on the test set's front panel by pressing CALL SETUP , left-hand side More key until menu 5 of 5 appears, Simultaneous Services ( F4 ).

    NOTE
    Pressing Originate Call ( F3 on the CALL SETUP screen) generates a page attempt to the mobile station based on the Paging Service parameter setting.

How to End One or Both Sevices of the Simultaneous Services Connection

  1. Open Simultaneous Sevices menu. This menu can be accessed on the test set's front panel by pressing CALL SETUP , left-hand side More key until menu 5 of 5 appears, Simultaneous Services ( F4 ).
  2. In the Simultaneous Sevices menu you can: end all active connections by pressing End All ( F1 ), end just the AMR call by pressing End AMR Voice Call ( F3 ), or end the PS Data connection by pressing End PS Data Connection ( F4 ).

    NOTE
    Pressing End Call ( F3 on the CALL SETUP screen) ends any single service that is active (CS or PS), however when simultaneous services is active, End Call only ends the CS connection (the PS data connection remains active).

Related Topics

Simultaneous Services


How Do I Use the 34.121 Preset Call Configurations?

How Do I Use the 34.121 Preset Call Configurations?

Last updated: January 15, 2009

This section is only applicable to the lab application or feature-licensed test application.

  1. Press the CALL SETUP key.
  2. Set Operating Mode ( F1 ) to Cell Off .
  3. Select 34.121 Preset Call Configs ( F11 ).
  4. Select the preset configuration with which you wish to start.
  5. Select Yes when asked to " Overwrite Current Parameters? ".
  6. Set Operating Mode ( F1 ) to Active Cell .
  7. Set any other parameters needed to allow your UE to camp to the test set and establish an HSDPA or HSPA RB test mode connection.
  8. Power on the UE and wait for it to register with the test set.
  9. Originate an HSDPA or HSPA RB test mode connection.
  10. Initiate the measurement(s) needed to perform the selected 34.121 test(s) and perform the test(s).
  11. To move between 34.121 sub-tests while on a call, use the Transport Channel Reconfiguration to change the parameters that differ between the sub-tests. The presets configure the test set for 3GPP TS 34.121 Table C.10.1.4 sub-test 3 (HSDPA) or Table C.11.1.3 sub-test 1 (HSPA).
  12. To move between the 34.121 preset call configurations while on a call, use the Transport Channel Reconfiguration to change the parameters that differ between the configurations. See 34.121 Preset Call Configurations for more information.

Related Topics

34.121 Preset Call Configurations


How Do I Change Call Parameters?

How Do I Change Call Parameters?

Last updated: January 15, 2009

  • Setting Call Parameters
  • Setting Call Parameters that Can Only Be Changed in Cell Off Mode

Setting Call Parameters

  1. Press the CALL SETUP key.
  2. Press the right More key to move between the Call Parms menus and set the call parameters as needed.

Setting Call Parameters that Can Only Be Changed in Cell Off Mode

  1. Press the CALL SETUP key.
  2. Set Operating Mode ( F1 ) to Cell Off .
  3. Press the right More key to move between the Call Parms menus and change the call parameters as needed.
  4. Set Operating Mode ( F1 ) to Active Cell .

Related Topics

Channel Type

Paging Service

How Do I Change HSUPA Parameters?

How Do I Change HSDPA Parameters?

Channel (UARFCN) Parameters

Signalling Radio Bearer (SRB) Parameters

Other Downlink Parameters

Uplink Closed Loop Power Control Parameters and UE Target Power


How Do I Change Cell Info?

How Do I Change Cell Info?

Last updated: January 15, 2009

This section is only applicable to the lab application.

  1. Press CALL SETUP .
  2. Press More on left side and go to Call Control screen 2 of 5 .
  3. Press Cell Info ( F2 ).
  4. Select Cell Parameters ( F2 ), Reselection Parameters ( F3 ) or Access Restriction Parameters ( F4 ). Turn the knob to highlight a parameter as desired, and then press the knob.
  5. Enter a value or selection and press the knob.
  6. Select Close Menu ( F6 ).

Related Topics

Cell Information


How Do I Change Cell Parameters?

How Do I Change Cell Parameters?

Last updated: January 15, 2009

  1. Press CALL SETUP .
  2. If required (some cell parameters can be changed only in Cell Off operating mode), press Operating Mode ( F1 ) and select Cell Off .
  3. Press More on the left side and go to the Call Control screen 2 of 5 .
  4. Test Application: Press Cell Parameters ( F2 ).
    Lab Application: Press Cell Info ( F2 ), then Cell Parameters ( F2 ).
  5. Turn the knob to highlight a parameter as desired, and then press the knob.
  6. Enter a value or selection and press the knob.
  7. Select Close Menu ( F6 ).
  8. If needed, return Operating Mode ( F1 ) to Active Cell .

Related Topics

Cell Parameters


How Do I Enable Compressed Mode and Obtain UE Measurement Results?

How Do I Enable Compressed Mode and Obtain UE Measurement Results?

Last updated: May 25, 2011

This section is only applicable to the lab application.

  • A. Configure DPCH Channel Code, Neighbor Cells and Call Parameters
  • B. Configure Compressed Mode and UE Measurements Setup Parameters
  • C. Establish a Call and Enable Compressed Mode
  • D. View UE Measurement Results
  • E. Perform Other Operations While in Compressed Mode

A. Configure DPCH Channel Code, Neighbor Cells and Call Parameters

  1. Set Operating Mode ( F1 ) to Cell Off .
  2. Select the type of connection you wish to establish : compressed mode is supported on the following channel types: RB Test Mode, HSDPA RB Test Mode, HSUPA RB Test Mode, AMR Radio Access Bearer, CS Data/Video Call, PS Data, HSDPA PS Data and HSUPA PS Data. It is not supported the 384k RMC and any channels with a 384k downlink . See Paging Service , Channel Type , AMR Radio Access Bearer and GPRS Radio Access Bearer .
  3. Choose an acceptable DPCH channelization code : for the channel type you've selected, you must choose a DPCH channelization code that will not cause collisions during compressed frames. For 12.2k RMC, 33k No Coding RMC, 12.2k - 6.7k AMR Voice or 14.4k UL/14.4k DL CS Data RAB, you must set DPCH 30 ksps (OVSF 128) Channelization Code to 20, 29, 37, 45, 60, 70, 76, 87 or 93. For 64k downlink channels or the 57.6k UL/57.6k DL CS Data RAB you must set DPCH 120 ksps (OVSF 32) Channelization Code to 24-27. For all other supported channel types, the default DPCH channelization codes are valid. See Channel Types Supported in Compressed Mode and Channelization Code Range and How Do I Change Generator Information? .
  4. Configure neighbor cells : the Measurement Control message sent to the UE to enable compressed mode measurements includes the cells the UE is to measure. This list of cells is populated using the SIB11 cell info lists. Thus, you must configure the SIB11 cell info lists with cells in a frequency band supported by your UE before enabling compressed mode measurements (some UEs will drop the connection if ordered to measure a cell in a frequency band they don't support). See How Do I Change the SIB11 Cell Info? . By default, one inter-frequency cell is present in the SIB11 inter-frequency cell info list, with a downlink channel of 10730 (Band I, IMT-2000) and one GSM cell is present in the SIB11 GSM cell list, with a BCH ARFCN of 20 (PGSM Band). Even if you do not have any actual neighbor cells present (this would require additional sources to act as neighbor cells), you can still include neighbor cells in SIB11 for the UE to measure. The UE should attempt to measure the specified cells, but then simply indicate that the power present in the neighbor cells is very low. If you do have additional sources (such as test sets) acting as neighbor cells, configure them to match the SIB11 neighbor cell information.
  5. Configure settings needed for call establishment , such as DL Channel , RLC Reestablish , etc. See How Do I Set Up a Call and Make a Connection? .
  6. Set Operating Mode ( F1 ) to Active Cell .

B. Configure Compressed Mode and UE Measurements Setup Parameters

  1. Select Compressed Mode Info ( F4 on Call Control 4 of 5 ).
  2. Select Compressed Mode Parameters ( F2 ).
    • Configure the Shared Comp Mode Parms ( F1 ) as desired.
    • Configure the First through Fourth TGPSs as desired (or use one of the Compressed Mode Preset Configs ( F5 ) from the main compressed mode menu to quickly configure the TGPSs to one of six pre-defined configurations).
      Note that you can only specify one transmission gap per frame (no matter whether the gaps are from the same or different TGPSs), and you can not place more than 7 transmission gap slots within one frame.
      Be sure to set <num> TGPS State and <num> TG Measurement Purpose (TGMP) accordingly for each TGPS.
  3. Select UE Meas Setup ( F3 ).
    • Set UE Measurements in Compressed Mode to On (so that the UE will report measurement results).
    • Set Measurement Configuration to InterfrequencyMeas or InterRATMeas , depending upon whether you want the UE to measure W-CDMA (inter-frequency) or GSM neighbor cells, respectively. The UE may perform measurements on either GSM or W-CDMA neighbor cells when you enable compressed mode, but not both. Ensure that you have a TGPS active with a TG Measurement Purpose that matches the Measurement Configuration setting.
    • Note, if your UE does not support BSIC verification and you set GSM Meas BSIC Verification to verifiedBSIC , your UE will likely return empty Measurement Reports. If your UE supports BSIC verification you may still receive empty Measurement Reports when GSM BSIC Verification is set to verifiedBSIC if you do not include an active TGPS with a TGMP of GSM Initial BSIC ID or GSM BSIC Reconfirmation .

C. Establish a Call and Enable Compressed Mode

  1. Establish the connection between the test set and UE.
  2. Return to the Compressed Mode Info menu ( F4 on Call Control 4 of 5 ).
  3. Select Enable Compressed Mode ( F1 ).
  4. Observe that Overall CM state changes to On , that the TGPSs you've specified are active, and no errors are posted (which would indicate that you've specified an invalid TGPS configuration that causes more than one transmission gap to occur in a single frame).

D. View UE Measurement Results

If you enabled UE measurements in step B. Configure Compressed Mode and UE Measurements Setup Parameters , then you can view the UE measurement results for either GSM or FDD (W-CDMA) neighbor cells (depending upon whether you set Measurement Configuration to InterRATMeas or InterfrequencyMeas ). To change which type of cells are being measured and reported by the UE, you must disable compressed mode, change the Measurement Configuration setting, then enable compressed mode.

  1. To view GSM neighbor cell results, select Compressed Mode Meas Results ( F5 ), then GSM Measurement Results ( F1 ). Note that the cells are reported in order of RSSI strength rather than by cell ID. The cell ID for each cell (numbered 1 to 8) is returned to help you quickly determine which neighbor cell is being reported by the UE.
  2. To view FDD measurement results, select Compressed Mode Meas Results ( F5 ), then FDD Inter-freq Meas Results (1 of 2) ( F2 ) or FDD Inter-freq Meas Results (2 of 2) ( F3 ).

E. Perform Other Operations While in Compressed Mode

At this point, you may choose to perform receiver or transmitter testing on the UE, or perform call processing operations such as handovers. See Additional Considerations While in Compressed Mode Operation for information on the availability of these features while in compressed mode.

Related Topics

Compressed Mode


How Do I Configure the AUDIO OUT Port?

How Do I Configure the AUDIO OUT Port?

Last updated: January 15, 2009

A. Select a signal to output to the AUDIO OUT port.

  1. Press the SYSTEM CONFIG key.
  2. Press the More key on the left side of the display for additional system parameters.
  3. Press the Audio Out Port ( F1 ) key.
  4. Turn the knob to highlight a selection and then press the knob.

NOTE
Selection of FM Demod signal routed to the front-panel AUDIO OUT port is useful only in AMPS system. There will be no guaranteed performance for the signal present at the Audio Out Port when FM Demod is selected for output.

B. Set FM Demod signal.

When FM Demod signal is selected for output to the front-panel AUDIO OUT port, a bandpass filter, expander circuit, and de-emphasis circuit can be individually inserted or bypassed in the FM Demod signal path.

  1. Press the SYSTEM CONFIG key.
  2. Press the More key.
  3. Press the FM Demod Setup ( F2 ) key.
  4. Turn the knob to highlight a selection and then press the knob.
  5. Enter a value or selection and press the knob.
  6. Press the Close Menu ( F6 ) key.

NOTE
If the FM Demod Setup settings are changed while the Audio Out Port selection is not FM Demod (see A. Select a signal to output to the AUDIO OUT port. ), the values will be stored for use when Audio Out Port is set to FM Demod.

Related Topics

Configuring the Test Set's AUDIO OUT port


How Do I Make an External Device Connection?

How Do I Make an External Device Connection?

Last updated: March 25, 2009

This section is only applicable to the lab application and to a test application with the required feature license.

Description

External Device Connection Setup for Two 8960s

  1. When establishing an External Device Connection using one or more test sets, it is recommended that you connect both the LAN 1 PORT and LAN 2 PORT to the LAN switch.
  2. Go to the External Device Connection Setup screen on 8960 #1 and 8960 #2:
    • Press the SYSTEM CONFIG key.
    • Press the left More key until you reach the Control 2 of 2 menu.
    • Select External Device Connection ( F4 ).
  3. 8960 #1: Select Ext 8960 IP Addr ( F1 ) and enter the LAN IP address of 8960 #2. (The LAN IP address of 8960 #2 is displayed in the LAN Connection Information window of 8960 #2 under LAN (Self) IP Address .)
  4. 8960 #1: Select Connect to External 8960 ( F3 ).
  5. Ensure that the External Device Conn Status is Connected on both 8960s.

Note that the Connected Device IP Address on 8960 #1 is the LAN IP Address of 8960 #2, and is also equal to the Ext 8960 IP Addr setting of 8960 #1 because 8960 #1 initiated the connection (see 8960 #1 External Device Connection Setup Screen ).

8960 #1 External Device Connection Setup Screen

Note that Connected Device IP Address on 8960 #2 is the LAN IP Address of 8960 #1, but is not necessarily equal to the Ext 8960 IP Addr setting of 8960 #2, as 8960 #2 did not initiate the connection (see 8960 #2 External Device Connection Setup Screen ).

8960 #2 External Device Connection Setup Screen

Related Topics

External Device Connection

Troubleshooting External Device Connection

How Do I Ping a Device From the Test Set?

Manual Operation: How Do I Make a Video Call?


How Do I Perform Calling Party Number Verification?

How Do I Perform Calling Party Number Verification?

Last updated: January 15, 2009

This section is only applicable to the lab application.

Procedure

  1. Press the Call Setup key.
  2. Press the left More key to move to the Call Control menu 4 of 5.
  3. Press Calling Party Number Parms ( F5 ). The Calling Party Number Parameters menu is displayed. See Parameter Descriptions for details.
  4. Select Calling Party Number Inclusion .
    • Turn the knob and select Include from the drop down menu.
  5. If required, select the Calling Party Number and enter a desired value.
    • Up to 20 characters from the set of 0123456789abc*# can be entered in the entry box. The digits of 0-9 are entered from the DATA ENTRY keys and the characters of "abc*#" are entered from the newly displayed softkeys on the right of the screen.
      Enter the value in the Calling Party Number text entry

      Once the entry box goes away, the Calling Party Number field can display up to 14 characters. If the length of the entered string is greater than 14 characters, only the first 11 characters followed by a "..." are displayed in the Calling Party Number field. Use the GPIB command ( CALL:CPNumber[:SELected] ) to query the whole string.

  6. If required, select other parameters and set them to the desired value. In this example, the default settings are used.
  7. Press the Close Menu ( F6 ).
  8. (Optional) To capture a protocol log for further analysis, start a capture in the Wireless Protocol Advisor (WPA) software (see Protocol Logging ) and then perform the following steps.
  9. Set up the Call Control and Call Parms as needed for the UE to camp to the test set. Power the UE on and wait for it to camp to the test set.
  10. Verify that Paging Service ( F9 ) is set to AMR Voice for this example.
  11. Press Originate Call ( F3). The test set originates a call to the UE.
  12. Observe the UE's screen. Verify that the mobile station receives and displays the calling party number. If the Calling Party Number is not displayed on the mobile station' screen, ensure that Presentation Indicator is set to "Allowed". Answer the call on the UE, if desired.
  13. Stop WPA.
  14. If you start a WPA capture in step 5, verify that the test set sends an SETUP message with the calling party number parameters. An example log file is shown as below.

Related Topics

Calling Party Number Parameters


How Do I Configure Test Signals in CW Operating Mode?

How Do I Configure Test Signals in CW Operating Mode?

Last updated: January 15, 2009

  1. Press the CALL SETUP key.
  2. Press the Operating Mode ( F1 ) key and set the operating mode to CW .
  3. Press the Test Signal ( F9 ) key to select a signal for output to the front panel RF connector currently selected. See Front Panel Connectors to select either RF IN/OUT or RF OUT ONLY connector.
  4. Select a test signal from the menu and confirm the selection by selecting Yes in the dialog box.
    NOTE

    Changing test signal requires several seconds to complete.

  5. Press the Cell Power ( F7 ) key and set the signal output power level to meet your testing needs.
  6. Press the RF Gen Freq ( F8 ) key and set the signal output center frequency to meet your testing needs.
  7. Press the Receiver Control ( F12 ) key and manually set the test set's receiver control parameters (such as expected CW power, measurement receiver frequency, and reverse link receiver frequency) to the desired values (see Manual Receiver Control ).

Related Topics

CW Operating Mode

Receiver Control


How to use the Digital Audio Interface Features

How to use the Digital Audio Interface Features

Last updated: January 15, 2009

This section is only applicable to the lab applications.

This section describes general procedures for performing the Digital Audio Interface (DAI) Test from the test set's front panel.

  • How to use the Digital Audio Interface (DAI) Downlink Test
  • How to use the Digital Audio Interface (DAI) Uplink Test

How to use the Digital Audio Interface (DAI) Downlink Test

  1. Connect the mobile station to the test set and power it on.
  2. The customer Test Station (TS) uploads the digital audio file (COD reference file) to the test set via HTTP interface.
  3. Start a voice call between the test set and the DUT.
  4. Wait for more than 1 second, use the TS to apply a reset pulse to the Mobile Station
  5. TS starts recording the digital audio file (OUT file) output from the Mobile Station.
  6. Command the test set to start playing the digital audio file (COD reference file).
    1. Press Call Setup
    2. Press the More key until screen 5 of 5 of the Call Control menu is displayed
    3. Press Digital Audio Interface ( F2 ), The following screen displayed

    4. Press Start COD Play ( F1 )
  7. Wait until the Play Progress reach 100% .
  8. TS stops the DUT recording and processes the results.
  9. End the Call.

How to use the Digital Audio Interface (DAI) Uplink Test

  1. Connect the mobile station to the test set and power it on.
  2. Start a voice call between the test set and the DUT.
  3. Wait for more than 1 second, then use the TS to apply a reset pulse to the Mobile Station
  4. Command the test set to start recording the digital audio file.
    1. Press Call Setup
    2. Press the More key until screen 5 of 5 of the Call Control menu is displayed
    3. Press Digital Audio Interface ( F2 ), The following screen displayed

    4. Press Start COD Record ( F2 ), notice that the softkey changes to Stop COD Record after the softkey is press.
  5. TS sends the digital audio file (INP file) to the Mobile Station.
  6. Stop the digital audio file (COD file) recording.
  7. TS downloads the digital audio file (COD file) from the test set via HTTP interface.
  8. End the Call Connection.

Related Topics

Digital Audio Interface (DAI) Description

Programming a Digital Audio Interface (DAI) Test

CALL:DAINterface


How Do I End a Connection?

How Do I End a Connection?

Last updated: January 15, 2009

  1. Press the CALL SETUP key.
  2. Press the End Call ( F3 ) key, or end the call from the UE.
  3. Check for Idle in the Active Cell field.


How Do I Make a FM Broadcast test?

How Do I Make a FM Broadcast test?

Last updated: January 15, 2009

This section is only applicable to GSM, GPRS or EGPRS TA applications.

  • How to configure the parameters to perform FM receiver testing?
  • How to set up and test the Mobile Station's demodulated FM output?

How to configure the parameters to perform FM receiver testing?

  1. Turn off RF IN/OUT Amplitude Offsets.

    1. Press SYSTEM CONFIG key .
    2. Press RF IN/OUT Amptd Offset ( F5 ).
    3. Press RF IN/OUT Amptd Offset Setup ( F2 ).
    4. Set the RF IN/OUT Amptd Offset State to Off.

  2. Set the Operating Mode to CW.

    1. Press CALL SETUP key .
    2. Set the Operating Mode to CW.

  3. Configure the FM Broadcast Parameters .

    1. Press RF GEN Configure ( F10 ), this displayed the RF GEN Configure menu .
    2. Use the knob to scroll to and highlight FM Broadcast. The test set is in the correct mode to perform FM receiver testing.
    3. All the FM Broadcast parameters are now visible in the control menu and you can use the knob to set the FM Broadcast Parameters .

How to set up and test the Mobile Station's demodulated FM output?

This procedure provides an example method for testing the Mobile Station's FM receiver performance. It involves the test set's audio analyzer measurement capability.

  1. Set up the FM Broadcast test system.
    1. Connect the FM Adapter to the test set's RF OUT ONLY port.
    2. Connect the Mobile Station's RF antenna to the output of the FM Adapter.
    3. Connect the Mobile Station's demodulated FM output to the test set's HI AUDIO INPUT connector.

    The test set's AUDIO INPUT connectors (HI or LO) are different inputs, therefore unless a different measurement is needed, it is recommended that you ground the LO connector and connect the audio signal to the HI connector.

  2. Initiate the Audio Analyzer measurement in the test set.

    1. Press Measurement Selection key .
    2. Select GSM Analog Audio.

  3. Press Analog Audio Setup ( F1 ), this displayed the Analog Audio Setup menu .

  4. Configure the GSM Analog Audio measurement parameters.

    For example, to view the measurement results for the SINAD Distortion Rate State, the state must be set to ON.

Related Topics

FM Broadcast


How Do I Change Generator Information?

How Do I Change Generator Information?

Last updated: January 15, 2009

A. Set Parameters Requiring Cell Off Operating Mode: Downlink Channel Codes and Downlink Channel Levels.

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Cell Off .
  3. Press the left More key until you reach the Call Control ( 2 of 5 ) menu.
  4. Select Generator Info ( F3 ).
  5. Select Downlink Channel Codes ( F2 ) and set the channel codes.
  6. Select Downlink Channel Levels ( F3 ) and set the power levels for the downlink channels.
  7. Press the Close Menu ( F6 ) key.
  8. Select Return ( F6 ).
  9. Change the operating mode back to Active Cell if desired.

B. Change Parameters Allowed in Active Cell Mode: Connected Downlink Channel Levels and AWGN Power.

  1. Press the CALL SETUP key.
  2. Press the left More key until you reach the Call Control ( 2 of 5 ) menu.
  3. Press Generator Info ( F3 ).
  4. Press the Connected DL Channel Levels ( F4 ) key, and change the power levels for the downlink channels while a call is connected in order to test the UE's response.
  5. Press the AWGN Power ( F5 ) key to set AWGN power as needed.
  6. Press Return ( F6 ).

Related Topics

Generator Information


How Do I Perform a Handover?

How Do I Perform a Handover?

Last updated: January 15, 2009

  • Physical Channel Reconfiguration (Inter-frequency Hard Handover)
  • Transport Channel Reconfiguration
  • System Handover
  • Soft Handover
  • Radio Bearer Reconfiguration
  • External 8960 Handover

Physical Channel Reconfiguration (Inter-frequency Hard Handover)

  1. Establish a call with the UE and verify that Connected is shown in the Active Cell field (see How Do I Set Up a Call and Make a Connection? ).
  2. Press the CALL SETUP key.
  3. Select Handovers ( F5 ).
  4. Select Physical Chan Reconfig ( F1 ).
  5. Set Handover Downlink Channel (UARFCN) and Handover Uplink Channel (UARFCN) (and Handover Band Arbitrator if needed).
  6. Set other PCR parameters as desired.
  7. Select Execute Handover ( F5 ).
  8. Verify that Connected is still shown in the Active Cell field.

Transport Channel Reconfiguration

  1. Establish an RB test mode call with the UE and verify that Connected is shown in the Active Cell field (see How Do I Set Up a Call and Make a Connection? ).
  2. Press the CALL SETUP key.
  3. Select Handovers ( F5 ).
  4. Select Transport Chan Reconfig ( F2 ).
  5. Set RB Test Mode TCR RAB as needed.
  6. Set other TCR parameters as desired.
  7. Select Execute Handover ( F5 ).
  8. Verify that Connected is still shown in the Active Cell field.

System Handover

  1. Confirm that the GSM/GPRS format is in active cell operating mode (press the SYSTEM CONFIG key, select Format Switch ( F2 ), select GSM/GPRS , and set Operating Mode ( F1 ) to Active Cell ). Return to the W-CDMA format by pressing the SYSTEM CONFIG key.
  2. Establish an RB test mode (non-HSDPA or HSDPA with CN Domain set to CS Domain or HSPA) or AMR Radio Access Bearer call with the UE and verify that Connected is shown in the Active Cell field (see How Do I Set Up a Call and Make a Connection? ).
  3. Press the CALL SETUP key.
  4. Select Handovers ( F5 ).
  5. Select System Handover ( F3 ).
  6. Set the GSM system parameters as needed.
  7. Select Execute Handover ( F5 ).
  8. When performing a handover from RB test mode to a GSM voice call with RB Test Mode to GSM Handover Alerting State set to On , the UE will ring. You must answer the ring for the connection to be completed and testing to progress.
  9. Verify that Connected is still shown in the Active Cell field.

Soft Handover

See How Do I Perform a Soft Handover? .

Radio Bearer Reconfiguration

This section is only applicable to the lab application or feature-licensed test application.

  1. Establish a CS Domain or CS/PS Domain HSDPA RB Test Mode connection or an HSPA RB Test Mode connection with the UE and verify that Connected is shown in the Active Cell field (see How Do I Set Up a Call and Make a Connection? ).
  2. Press the CALL SETUP key.
  3. Select Handovers ( F5 ).
  4. Select Radio Bearer Reconfig ( F5 ).
  5. Set RB Test Mode RBR RAB as needed.
  6. Set other RBR parameters as desired.
  7. Select Execute Handover ( F5 ).
  8. Verify that Connected is still shown in the Active Cell field.

External 8960 Handover

See How Do I Set Up the Two-Cell Test System and Perform Cell Transitions? .

Related Topics

Handovers


How Do I Change HSDPA Parameters?

How Do I Change HSDPA Parameters?

Last updated: January 15, 2009

This section is only applicable to the lab application or feature-licensed test application.

  1. Press CALL SETUP .
  2. Select HSPA Parameters ( F10 ).
  3. Select HSDPA Parameters ( F10 ).
  4. Select HSDPA PS Data Setup ( F7 ) (lab application only) , HSDPA RB Test Mode Setup ( F8 ), UE Category Parms ( F9 ) MAC-hs Parameters ( F10 ), HSDPA Uplink Parameters ( F11 ) or H-RNTI Parameters ( F11 under HSDPA Parms 2 of 2 ).
  5. Turn the knob to highlight a parameter as desired, then press the knob to select the parameter.
  6. Enter a value or selection and press the knob.
  7. Select Close Menu ( F6 ).
  8. Select Return ( F12 ).

Related Topics

HSDPA Parameters


How Do I Change HSUPA Parameters?

How Do I Change HSUPA Parameters?

Last updated: January 15, 2009

This section is only applicable to the lab application or feature-licensed test application.

  1. Press CALL SETUP .
  2. Select HSPA Parameters ( F10 ).
  3. Select HSUPA Parameters ( F9 ).
  4. Select HSUPA PS Data Setup ( F7 ) (lab application only) , HSUPA RB Test Mode Setup ( F8 ), Common HSUPA Parameters ( F9 ) Serving Grant ( F10 ), E-TFCI Recording ( F11 ) or E-RNTI Parameters ( F11 under HSUPA Parms 2 of 2 ).
  5. Turn the knob to highlight a parameter as desired, then press the knob to select the parameter.
  6. Enter a value or selection and press the knob.
  7. Select Close Menu ( F6 ).
  8. Select Return ( F12 ).

Related Topics

HSUPA Parameters


Enabling the HTTP Interface

Enabling the HTTP Interface

Last updated: January 15, 2009

This section contains the following:

  • Enabling the HTTP Interface for Mobile Terminated SMS
  • Enabling the HTTP Interface for Mobile Originated SMS

Enabling the HTTP Interface for Mobile Terminated SMS

  1. Press the Call Setup key to go the Call Setup screen.
  2. Go to menu ( 4 of 5 ) of the Call Control menu by pressing the More key on the lower left corner of the test set.
  3. Select Short Message Service by pressing the softkey F6 .
  4. Select HTTP Setup ( F3 ). The SMS HTTP Setup menu appears.
  5. Select HTTP SMS Input State . The Input State menu appears.
  6. Select On .

Enabling the HTTP Interface for Mobile Originated SMS

  1. Press the Call Setup key to go the Call Setup screen.
  2. Go to menu ( 4 of 5 ) of the Call Control menu by pressing the More key on the lower left corner of the test set.
  3. Select Short Message Service by pressing the softkey F6 .
  4. Select HTTP Setup ( F3 ). The SMS HTTP Setup menu appears.
  5. Select HTTP SMS Output State . The Output State menu appears.
  6. Select On .

Related Topics

HTTP Interface Configuration for Mobile Terminated SMS


How Do I Make Measurements on a UE?

How Do I Make Measurements on a UE?

Last updated: January 15, 2009

A. Establish a Connection.

See How Do I Set Up a Call and Make a Connection? .

B. Select measurements.

  1. Press the Measurement selection key.
  2. Highlight a measurement and press the knob.
  3. Repeat steps 1 and 2 to add measurements.


Measuring Perceptual Evaluation of Speech Quality (PESQ)

Measuring Perceptual Evaluation of Speech Quality (PESQ)

Last updated: October 26, 2010

This section is only applicable to the feature-licensed lab application or test application

There are three measurement modes for the Perceptual Evaluation of Speech Quality measurement: Uplink Audio, Downlink Audio and Both (see How is a PESQ measurement made? for details).

The following procedure assumes that mobile station's antenna output is connected to the test set's front-panel RF IN/OUT connector.

A. Connect the mobile phone with the test set.

  • For the uplink PESQ measurement, connect the mobile station's microphone to the test set's AUDIO OUT port.
  • For the downlink PESQ measurement, connect the analog audio from the mobile station's speaker to the test set's AUDIO IN port.
  • For measuring the downlink and uplink PESQ simultaneously, connect the mobile station's microphone to the test set's AUDIO OUT port and the analog audio from the mobile station's speaker to the test set's AUDIO IN port.

B. Establish a voice call with the mobile station.

  1. Follow the procedures as described in How Do I Set Up a Call and Make a Connection? to establish a voice call, with the following settings:
    • Set the Paging Service to AMR Voice
    • Go to Call Control 3 of 6 , press the Voice Call ( F5 ) Key and then AMR Setup ( F1 ), set the AMR Source to PESQ and the AMR Radio Access Bearer to the desired voice setting.

    When a call is successfully set up, verify that Connected is displayed in the Active Cell window.

D. Make the measurement.

  1. Press the Measurement selection key.
  2. Turn the knob to highlight the Perceptual Evaluation of Speech Quality measurement and press the knob.
  3. Press the F1 ( PESQ Setup ) to access the PESQ Setup menu.
  4. Set up the parameters for your test.
    • For the uplink PESQ measurement, set the Measurement Mode to Uplink Audio and set the Maximum Audio Out Peak Voltage to a proper value. See PESQ Setup example for the uplink PESQ measurement.
    • For the downlink PESQ measurement, set the Measurement Mode to Downlink Audio and set the Expected Audio In Peak Voltage to a proper value.
    • For measuring the downlink and uplink PESQ simultaneously, set the Measurement Mode to Both and set both the Expected Audio In Peak Voltage and Maximum Audio Out Peak Voltage to the proper values.
    PESQ Setup example for the uplink PESQ measurement.
  5. Set the Trigger Arm to Single and the Measurement Timeout to Off.
    NOTE

    If the Trigger Arm is set to Continuous, the measurement began executing as soon as you initialize the measurement. If single is selected in the Trigger Arm field, you need to press the START SINGLE to trigger each measurement.

    A single PESQ measurement will likely cost more than 10 seconds to be completed. If you want to set a measurement timeout, make sure the Measurement Timeout is set to a value more than that time.

  6. Press the START SINGLE key to begin the measurement. A typical display of a PESQ uplink measurement is shown as below.
  7. If desired, turn the measurement off after finishing the measurements. Press the Measurement selection key, then select Close Measurement ( F4 ).

Related Topics

Perceptual Evaluation of Speech Quality (PESQ) Measurement Description


How Do I Change the Measurement Setup?

How Do I Change the Measurement Setup?

Last updated: January 15, 2009

A. Select a measurement.

  1. Press the Measurement selection key.
  2. Highlight a measurement to set up and press the knob.

B. Set up the measurement.

  1. Press the measurement's setup key ( F1).
  2. Highlight a parameter and press the knob.

  3. Enter a value or selection and press the knob.

    Note : For statistical measurement results, change the Multi-Measurement Count parameter from Off to a number >1.

  4. Press the Close Menu (F6) key.


How Do I Change Paging Parameters?

How Do I Change Paging Parameters?

Last updated: January 15, 2009

  1. Press CALL SETUP .
  2. Press Paging Parameters ( F4 on Call Control 1 of 5 ).
  3. Turn the knob to highlight a parameter as desired, and then press the knob.
  4. Enter a value or selection and press the knob.
  5. Select Close Menu ( F6 ).

Related Topics

Paging Parameters


How Do I Configure the Radio Bearer Test Mode?

How Do I Configure the Radio Bearer Test Mode?

Last updated: January 15, 2009

  1. Press the CALL SETUP key.
  2. Press the More key until you reach the Call Control 3 of 5 menu.
  3. Select RB Test Mode Setup ( F6 ).
  4. Configure the parameters as needed.

Related Topics

Radio Bearer Test Mode and Channel Type


How Do I Change Receiver Control Parameters?

How Do I Change Receiver Control Parameters?

Last updated: January 15, 2009

In some instances you may want to control the test set's receiver settings manually rather than allowing the test set to automatically control them. This ability is referred to as manual receiver control (see Receiver Control ).

Manual Receiver Control in Active Cell, Cell Off or FDD Test Operating Mode

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell, or Cell Off, or FDD Test .
  3. Press the More key two times until 3 of 3 is displayed.
  4. Press the Receiver Control ( F12 ) key.
  5. To manually set the receiver's expected power, highlight the Power Control field and select Manual , then enter a a desired value in the Manual Power field by using the knob or numeric keys.
  6. To manually set the receiver's measurement downconverter frequency, highlight the Measurement Frequency field and enter a desired value to replace the Auto with the knob or numeric keys.
  7. (In FDD Test mode only) To manually set the receiver's demodulation downconverter tune frequency, turn the knob to highlight the Uplink Frequency field and enter a desired value to replace the Auto with the knob or numeric keys.

Manual Receiver Control in CW Operating Mode

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select CW .
  3. Press the Receiver Control ( F12 ) key.
  4. To set the receiver's expected power, turn the knob to highlight the Expected CW Power field and press the knob, then enter a desired value by using the knob or numeric keys and press the knob.
  5. To set the measurement downconverter's tune frequency, turn the knob to highlight the Measurement Frequency field and press the knob, then enter a desired value by using the knob or numeric keys and press the knob.
  6. To set the demodulation downconverter's tune frequency, turn the knob to highlight the Uplink Frequency field and press the knob, then enter a desired value by using the knob or numeric keys and press the knob.
  7. Press Close Menu ( F6 ).

Related Topics

Receiver Control


How Do I Change Security Info Parameters?

How Do I Change Security Info Parameters?

Last updated: January 15, 2009

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Active Cell or Cell Off .
  3. Press More ( 1 of 4 ) until you reach the fourth menu.
  4. Select Security Info ( F1 ).
  5. Select Security Parameters ( F1 ).
  6. Select the desired parameter and change the parameter as needed using the knob and/or keypad.
  7. Press Close Menu ( F6 ).
  8. Your settings are displayed in the Security Settings table on the Security window.
  9. If desired, press Reset Authen. SQN ( F2 ) key to reset the authentication sequence number (SQN) to zero.
  10. Press Return ( F6 ).

Related Topics

Security Information


How Do I Set Up a Call and Make a Connection?

How Do I Set Up a Call and Make a Connection?

Last updated: January 15, 2009

  • Establishing a Connection
  • Establishing an HSDPA Connection ( lab application or feature-licensed test application only )
  • Establishing an HSPA Connection ( lab application or feature-licensed test application only )

Establishing a Connection

Set Cell Parameters

  1. Press the CALL SETUP key.
  2. Press the left More key to move to the Call Control 2 of 5 menu.
  3. Test Application: Press Cell Parameters ( F2 ).
    Lab Application: Press Cell Info ( F2 ), then Cell Parameters ( F2 ).
    • Set BCCH Update Page to Auto , if desired, so that the UE will be notified of any changes to the BCCH information transmitted by the test set after the call is established.
    • Set ATT (IMSI Attach) Flag State to Set , if required for your UE to register with the test set.
    • Set Repeat Paging to On , if desired, to help ensure your UE will respond to the test set's page.
    • Set any other cell parameters as needed.
    • Select Close Menu ( F6 ).

      NOTE
      Some cell parameters can only be set when Operating Mode ( F1 ) is set to Cell Off .

Set Uplink Parameters

  1. Press the CALL SETUP key.
  2. Press the left More key to move to the Call Control 2 of 5 menu.
  3. Select Uplink Parameters ( F4 ).
    • Set Maximum Uplink Transmit Power Level to the appropriate value for your UE.
    • Set other uplink parameters as needed.
    • Select Close Menu ( F6 ).

Set Call Parameters

  1. Press the CALL SETUP key.
  2. Set Operating Mode ( F1 ) to Cell Off .
  3. Select Channel (UARFCN) Parms ( F12 ) and set the downlink and uplink channels to frequencies supported by your UE. Select Return ( F12 ).
  4. If required by your UE for successful call establishment:
    • Press the right More key to move to the Call Parms 2 of 3 menu.
    • Set RLC Reestablish ( F9 ) to Off .
    • Set SRB Config ( F12 ) to 2.2k DCCH .
  5. Use the right More key to move between the three Call Parms menus and set other call parameters as needed.
  6. Set Operating Mode ( F1 ) to Active Cell .

Establish the Call

  1. Connect the UE to the front panel RF IN/OUT port and power it on.
  2. After a few seconds the UE should register with the test set. The test set then displays UE Information such as IMSI and IMEI on the Call Setup screen and the MM Status should change from None to IMSI Attached .
  3. You can then establish the call in one of two ways:
    • Test set originated call -
      • Select Paging Service ( F9 ) and set as needed.
      • If Paging Service is set to RB Test Mode , select Channel Type ( F8 ) and set as needed.
      • Select Originate Call ( F3 ).
      • For the lab application only, if Paging Service is set to AMR Voice , and Calling Party Number Inclusion is set to Include , the Calling Party Number is displayed on the UE's screen (see How Do I Perform Calling Party Number Verification? ).
      • Answer the call if necessary, and verify that Connected is displayed in the Active Cell window.
    • UE initiated call -
      • Dial a number into the UE and press send.
      • Verify that Connected is displayed in the Active Cell window.
      • For the lab application only, the Called Party Number is displayed under UE Information .

Establishing an HSDPA Connection

This section is only applicable to the lab application or feature-licensed test application.

Before establishing an HSDPA connection, you may need to first set some of the parameters described in Set Cell Parameters , Set Uplink Parameters and Set Call Parameters .

Set HSDPA Parameters

  1. Press the CALL SETUP key.
  2. Select HSDPA Parameters ( HSPA Parameters ( F10 ), F10 ).
  3. Select HSDPA RB Test Mode Setup ( F8 ).
    • Set FRC Type to an H-Set supported by your UE or configure the user defined RB test mode channel as desired.
    • Set CN Domain as needed. Note, before you can establish a connection in the PS domain, the UE must have attached to the test set. To enable this, the PS Domain Information parameter must have been set to Present when the UE registered with the test set. Note that PS Domain Information is set to Absent by default in the Test Application (it is set to Present by default in the Lab Application).
    • Set Uplink 64k DTCH for HSDPA Loopback State as needed for your UE.
    • Set other HSDPA RB Test Mode Setup parameters as needed, then select Close Menu ( F6 ).
  4. Set MAC-hs Parameters ( F10 ), HSDPA Uplink Parameters ( F11 ) and H-RNTI Parameters ( F11 on HSDPA Parms 2 of 2 ) as needed, then select Return ( F12 ).

Establish the HSDPA Connection

  1. Connect the UE to the front panel RF IN/OUT port and power it on.
  2. After a few seconds the UE should register with the test set. If PS Domain Information is set to Absent , the UE registers in the CS domain and MM Status changes from None to IMSI Attached . If PS Domain Information is set to Present , the UE should register in the CS domain and then also will register in the PS domain if it supports PS services (which causes GMM State to change from None to Attached ).

    Ensure that the CN Domain parameter is set to CS Domain if the UE did not attach to the GMM (see Set HSDPA Parameters ).

  3. Set Paging Service ( F9 ) to RB Test Mode .
  4. Set Channel Type ( F8 ) to 12.2k RMC + HSDPA .
  5. Select Originate Call ( F3 ).
  6. Verify that Connected is displayed in the Active Cell window.

Establishing an HSPA Connection

This section is only applicable to the lab application or feature-licensed test application.

Before establishing an HSPA connection, you may need to first set some of the parameters described in Set Cell Parameters , Set Uplink Parameters and Set Call Parameters .

Set HSDPA Parameters

  1. Press the CALL SETUP key.
  2. Select HSDPA Parameters ( HSPA Parameters ( F10 ), F10 ).
  3. Select HSDPA RB Test Mode Setup ( F8 ).
    • Set FRC Type to an H-Set supported by your UE or configure the user defined RB test mode channel as desired.
    • Note that the CN Domain setting does not apply to HSPA connections (HSPA connections are always established in the PS Domain). However, before you can establish a connection in the PS domain, the UE must have attached to the test set. To enable this, the PS Domain Information parameter must have been set to Present when the UE registered with the test set. Note that PS Domain Information is set to Absent by default in the Test Application (it is set to Present by default in the Lab Application).
    • Set other HSDPA RB Test Mode Setup parameters as needed, then select Close Menu ( F6 ).
  4. Set MAC-hs Parameters ( F10 ), HSDPA Uplink Parameters ( F11 ) and H-RNTI Parameters ( F11 on HSDPA Parms 2 of 2 ) as needed, then select Return ( F12 ).

Set HSUPA Parameters

  1. Press the CALL SETUP key.
  2. Select HSUPA Parameters ( HSPA Parameters ( F10 ), F9 ).
  3. Select HSUPA RB Test Mode Setup ( F8 ).
    • Set RB Test Mode E-DPDCH Max Channel Codes as needed (to achieve 2 Mbps in the uplink this must be set to 2SF2 ).
    • Set E-DCH RLC SDU Size as needed (to achieve 2 Mbps in the uplink this must be set to at least 11744 ).
    • Set other HSUPA RB Test Mode Setup parameters as needed, then select Close Menu ( F6 ).
  4. Set Common HSUPA Parameters ( F9 ), Serving Grant parameters ( F11 ) and E-RNTI Parameters ( F11 on HSUPA Parms 2 of 2 ) as needed, then select Return ( F12 ).

Establish the HSPA Connection

  1. Connect the UE to the front panel RF IN/OUT port and power it on.
  2. After a few seconds the UE should register with the test set. If PS Domain Information is set to Present , the UE should register in the CS domain ( MM Status ) and then also will register in the PS domain if it supports PS services (which causes GMM State to change from None to Attached ).
  3. Set Paging Service ( F9 ) to RB Test Mode .
  4. Set Channel Type ( F8 ) to 12.2k RMC + HSPA .
  5. Select Originate Call ( F3 ).
  6. Verify that Connected is displayed in the Active Cell window and observe the HSUPA and HSDPA counters.

Related Topics

Establishing a Connection with the UE

Troubleshooting Call Processing Operations

How Do I Change Cell Parameters?

How Do I Change Uplink Parameters?

How Do I Change Call Parameters?

How Do I Make a Video Call?

Active Cell Operating Mode


How Do I Change the SIB11 Cell Info?

How Do I Change the SIB11 Cell Info?

Last updated: November 25, 2010

  • How Do I Change the SIB11 Cell Info List?
  • How Do I Change the SIB11 FACH Measurement Occasion Information? (lab application only)

How Do I Change the SIB11 Cell Info List?

  1. Press the CALL SETUP key.
  2. Press the left MORE key until you reach the Call Control 4 of 5 menu.
  3. Select SIB11 Cell Info List ( F3 ).
  4. Set Cell Info List ( F1 ), SIB11 Intra-freq Cell Info List ( F2 ), SIB11 Inter-freq Cell Info List ( F3 ) and SIB11 GSM Cell Info List ( F4) settings as needed.

How Do I Change the SIB11 FACH Measurement Occasion Information?

This section is only applicable to lab application.

  1. Press the CALL SETUP key.
  2. Press the left MORE key until you reach the Call Control 4 of 6 menu.
  3. Select SIB11 Cell Info ( F3 ).
  4. Select SIB11 FACH Meas Occasion Info ( F3 ). The SIB11 FACH Measurement Occasion Info menu is displayed in the center of the screen. Set each parameter as needed.

Related Topics

SIB11 Cell Info List


How Do I Use the Spectrum Monitor?

How Do I Use the Spectrum Monitor?

Last updated: January 15, 2009

The following procedure shows a typical usage of the spectrum monitor in each of its two modes of operation; Swept Mode and Zero Span mode.

  1. Establish a call with the mobile.

    NOTE
    The spectrum monitor can also be used with any of the test set's test mode operating modes.

  2. Press the Instrument selection key.
  3. Select Spectrum Monitor .

    The spectrum monitor is displayed with the default settings as shown above. The center frequency is initially set at the expected frequency maintained by the test set's base station emulator. The Swap Window Positions ( F5 ) key is only displayed when other measurements are active at the same time as the spectrum monitor.

  4. Set the axis control as needed for your testing situation using the Frequency Span ( F1 ), Reference ( F2 ), and dB/div ( F3 ) keys. See Frequency Span, Resolution Bandwidth and Dynamic Range for the valid Frequency Span entries. To set the reference level manually ( Auto is the default), press the Reference ( F2) key then use the DATA ENTRY keys to enter the value you want.
  5. Press the Trigger Setup ( F4 ) key to access the Trigger Setup menu.
  6. Set the trigger settings to meet your testing needs. For example:

    • If you want the Spectrum Monitor to sweep immediately and continuously, ensure that Trigger Arm ( F3 ) is set to Continuous .
    • If you want to use external triggering, so that the Spectrum Monitor is triggered from a signal applied to the TRIG IN connector on the test set's rear panel, set Trigger Source ( F1 ) to External .
    • Trigger Delay ( F2 ) allows you to specify the point, relative to the trigger event where samples are taken (a negative trigger delay value collects pre-trigger samples). The same trigger delay setting is used for swept mode and zero span mode.
    • Res Bw allows you to set the resolution bandwidth. If you want the resolution bandwidth coupled with the with the Frequency Span , set this field to AUTO by pressing the gray DATA ENTRY softkey labeled ON , otherwise use the knob or the numeric DATA ENTRY soft keys to set the resolution bandwidth. See Frequency Span, Resolution Bandwidth and Dynamic Range to find the valid entries for the resolution bandwidth while in swept mode. Note that changing the resolution bandwidth does not modify the zero span resolution bandwidth setting.

  7. Press the Return ( F6 ) key to exit the Trigger Setup menu.
  8. Press the Display ( F6 ) key to access the display settings.

    A typical spectrum monitor trace display is shown above. In this case, the Display menu is open allowing you to access all of the display control settings using the ( F1 ) through ( F12 ) keys.

    The following list provides examples of some of the settings you may want to adjust:

    • Detection Method ( F2 ) determines the algorithm used to find the value that represents each frequency bin. See Detection Method for more information.

    • Peak Threshold ( F4 ) and Peak Excursion ( F5 ) set the peak threshold and peak excursion levels respectively. A peak is identified by using the peak threshold and peak excursion value. A point is only marked as a peak if it rises and falls more than the peak excursion value from the peak threshold value.

    • Marker Mode ( F8 ) sets the mode of the active marker. Position mode activates a single frequency marker. Delta mode freezes the active marker at its current location and uses it as a reference marker. A second marker is created at the position of the reference marker and is used as a delta marker, reporting any change in amplitude or frequency from that of the reference marker.

    • Peak Search ( F10 ) moves the active marker to the highest peak on the spectrum monitor display, returning the numeric amplitude and frequency values.

    • Marker -> Expected Freq ( F11 ) sets the base station emulator's expected frequency to the frequency of the active marker.

    • Marker -> Expected Power ( F12 ) sets the base station emulator's expected power level to the amplitude of the active marker.

    A typical swept mode spectrum monitor display is shown above. In this case, the active marker is marker 1, which is set to Delta mode.

  9. Press the Return ( F6 ) key to exit the Display menu.
  10. To set the spectrum monitor to zero span mode, press the Frequency Span ( F1 ) key and use the numeric DATA ENTRY keys to enter a value of 0 MHz , or use the down-arrow key to reduce the span to zero.

    A typical zero span mode spectrum monitor display is shown above. Like swept mode, the Y-axis represents absolute amplitude. However, the X-axis now represents time rather than frequency.

  11. Press the Trigger Setup ( F6 ) key. In zero span mode, additional trigger setup controls are available to you:
    • If you want to change the view window over which you are looking at the signal, use the Time Span ( F8 ) and Time Offset ( F9 ) keys. The measurement is made for the duration of the time span, beginning at the time defined by the trigger event plus the trigger delay plus the time offset.
    • If you want to change the resolution bandwidth, press the Zero Span RBW ( F7 ) key and select a value. (To measure the total power of a signal you must select a resolution bandwidth greater than or equal to the signal bandwidth.) See Frequency Span, Resolution Bandwidth and Dynamic Range to find the valid entries for the resolution bandwidth while in zero span mode. Note that changing the zero span resolution bandwidth does not modify the swept mode resolution bandwidth.

    A typical zero span mode spectrum monitor display showing a bursted signal. The viewing window has been adjusted to zoom in on a single burst.

    If the temperature of the test set drifts outside the calibrated temperature range of the spectrum monitor, a Measurement Uncalibrated message is displayed. To calibrate the spectrum monitor for the current temperature, press the Calibrate Measurement ( F11 ) key on the Trigger Setup menu.

Related Topics

Spectrum Monitor Description


How to use the Short Message Service Features

How to use the Short Message Service Features

Last updated: January 15, 2009

This section is only applicable to the lab application or feature-licensed test application.

This section describes general procedures for using SMS features from the test set's front panel.

  • Mobile Terminated Point-to-Point Message Transfer
  • Mobile Originated Point-to-Point Message Transfer
  • Cell Broadcast Message Transfer
  • Cell Broadcast Updated Message Transfer

Mobile Terminated Point-to-Point Message Transfer

The following procedures,

  • Procedure A: Sending a Text Message to the Mobile Station and
  • Procedure B: Sending a WAP Push Message to the Mobile Station
can be used to simulate exchanging SMS messages between the test set and the mobile station attached to the test set's RF port.

Procedure A: Sending a Text Message to the Mobile Station

  1. If you would like a log of the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set and power it on.
  3. After the mobile station has camped, go to the Call Setup screen by pressing the Call Setup key.
  4. Go to menu ( 4 of 5 ) of the Call Control menu by pressing the More key on the lower left corner of the test set.
  5. Select Short Message Service by pressing the softkey F6 .
  6. Select the Point to Point SMS messaging by pressing the softkey F1 .
  7. Select Mobile Terminated by pressing the softkey F2 .The Mobile Terminated SMS menu appears.
  8. Choose to use either the CS Domain or PS Domain for sending the SMS message using by selecting the Transportation parameter and scrolling to the desired value.
  9. Choose the message to send by selecting the Content parameter. Select Text2 . For additional information about the message options available, see Short Message Service (SMS) Messages .
  10. Press the Send Message softkey ( F1 ) to send the message. Observe the mobile station for indications that the message has been received. The test set display also gives an indication.
  11. If you are capturing a log, stop logging.

Procedure B: Sending a WAP Push Message to the Mobile Station

  1. If the Pt to Pt SMS control screen is not visible on the test set's front panel, use steps 1 thru 6 of Procedure A: Sending a Text Message to the Mobile Station .
  2. Select Mobile Terminated by pressing the softkey F2 .The Mobile Terminated SMS menu appears.
  3. Choose the message to send by selecting the Content parameter. Select Custom Data . Configuring the content of your custom data requires a GPIB command. See Defining the User Data (TP-UD) content for Binary SMS Applications for information on configuring custom data.
  4. Select the Data Coding Scheme parameter and use the test set's keypad to enter 245 . This entry indicates that this message is a WAP Push message.
  5. Select the User Data Header Indicator parameter. Select 1 . This indicates that this message has a User Data Header.
  6. Press the Send Message softkey ( F1 ) to send the message. Observe the mobile station for indications that the message has been received. The test set display also gives an indication.
  7. If you are capturing a log, stop logging.

Mobile Originated Point-to-Point Message Transfer

  1. If you would like a log of the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set and power it on.
  3. After the mobile station has camped, go to the Call Setup screen by pressing the Call Setup key.
  4. Go to menu ( 4 of 5 ) of the Call Control menu by pressing the More key on the lower left corner of the test set.
  5. Select Short Message Service by pressing the softkey F6 .
  6. If you want the message received by the test set to be resent to the mobile station, first, select the Point to Point SMS messaging by pressing the softkey F1 , then select Mobile Originated by pressing the softkey F3 , then select the Loopback parameter and scroll to On .
  7. Use the mobile station to send a point-to-point message of "Hello" to any address.
  8. Observe the test set for indications that the message has been received. If the loopback option is enabled, observe the mobile station for indications that the message has been received.
  9. If you are capturing a log, stop logging.

Cell Broadcast Message Transfer

  1. If you would like a log of the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set and power it on.
  3. Go to the Call Setup screen by pressing the Call Setup key.
  4. Go to the fourth page of the Call Control menu by pressing the More key on the lower left corner of the test set.
  5. Select Short Message Service by pressing the softkey F6 .
  6. Select Cell Broadcast by pressing the softkey F2 . The Broadcast SMS menu appears. You can select setup menus for three different messages.
  7. To select the setup menu, press the softkey next to the menu item labeled Message X Setup where X can be 1, 2, or 3. The menu for the selected message appears. The figure below shows the Message 1 Setup menu.
  8. See Cell Broadcast Message Setup for more information about each parameter in the message setup.
  9. Set parameters according to the type of cell broadcast messages your mobile station is allowed to receive.

  10. To set the cell broadcast parameters that apply to all three messages, press Cell Broadcast Setup (F5). The following menu appears:

  11. Use the knob to change the Repetition Period , if desired.
  12. Start the broadcast message using the Start Cell Broadcast softkey ( F1 ).
  13. Observe the display on the mobile station to confirm that the message(s) were received.
  14. If required, stop the broadcast by pressing the Stop Cell Broadcast softkey ( F1 ).
  15. If you are capturing a log, stop logging.

Cell Broadcast Updated Message Transfer

This section assumes that you have configured your mobile station to receive cell broadcast messages. This is done by enabling reception of messages in your mobile station and specifying the message parameters that it can receive. In order for a phone to realize the contents of a message have been altered you also need to change either the Message Code or Update Number for the message.

  1. If you would like a log of the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set and power it on.
  3. Go to the Call Setup screen by pressing the CALL SETUP key.
  4. Go to the fourth page of the Call Control menu by pressing the More key on the lower left corner of the test set.
  5. Select Short Message Service by pressing the softkey F6 .
  6. Select Cell Broadcast by pressing the softkey F2 .
  7. Set parameters according to what type of cell broadcast messages your mobile station is allowed to receive. To enable a message to be sent, select Message Setup for the message you wish to send (message 1, 2, and/or 3) and set State to On . You can configure different message parameters in each of the Message Setup menus.
  8. Select the message to be sent using the Content menu for each message you want to update.

    The Custom Text and Custom Data strings are defined using the commands CALL:SMService:CBRoadcast:MESSage[<n>]:CTEXt and CALL:SMService:CBRoadcast:MESSage[<n>]:CDATa , respectively.

  9. Start the broadcast message using the Start Cell Broadcast softkey ( F1 ).
  10. Observe the display on the mobile station to confirm that the message(s) were received.
  11. Select Message Setup for each message to be sent as an update.
  12. Set the Update Number for these messages higher than their previous value. The update number wraps from 15 to 0.
  13. Observe the display on the mobile station to confirm that the updated message(s) have replaced the first versions.

    NOTE
    The amount of time the mobile station takes to display changes to the message(s) while the cell broadcast service is running depends on the repetition period parameter
    .

  14. If required, stop the broadcast by pressing the Stop Cell Broadcast softkey ( F1 ).
  15. If you are capturing a log, stop logging.

Related Topics

Short Message Service (SMS)

Point-to-Point SMS

Cell Broadcast Service (CBS)

Logging SMS Messages

Short Message Service (SMS) Messages


How Do I Configure the Test Set for My Test System?

How Do I Configure the Test Set for My Test System?

Last updated: January 15, 2009

A. Configure instrument information and setup.

  1. Press the SYSTEM CONFIG key.
  2. Press the Instrument Setup ( F1 ) key.
  3. Adjust an instrument setting and then press the Close Menu ( F6 ) key.

CAUTION
Always verify that the test set is responding to a new LAN IP Address by pinging the test set. If the test set does not respond to the ping, cycle power. This will ensure that the test set will respond to the new LAN IP Address.

B. Set amplitude offsets.

  1. On the Configuration Summary Screen, press the RF IN/OUT Amptd Offset ( F5 ) key.
  2. On the RF IN/OUT Amplitude Offset screen, press the RF IN/OUT Amptd Offset Setup ( F2 ) key.
  3. Enter the amplitude offset for the test frequencies you use.
  4. Press the Close Menu ( F6 ) key.
  5. Press the Return ( F6 ) key.

C. Check the message log.

  1. Press the Message Log ( F7 ) key and view the message log.
  2. Press the Return ( F12 ) key.


How Do I Turn Off a Measurement?

How Do I Turn Off a Measurement?

Last updated: January 15, 2009

  1. Press the Measurement selection key.
  2. Highlight the measurement you want to turn off.
  3. Press the Close Measurement ( F4 ) key.
  4. Press the Close Menu ( F6 ) key.


How Do I Set Up the Two-Cell Test System and Perform Cell Transitions?

How Do I Set Up the Two-Cell Test System and Perform Cell Transitions?

Last updated: January 15, 2009

This section is only applicable to the lab application.

Description

  • Set Up the Two-Cell Test System
  • Mobile-initiated Cell Selection/Reselection
    • Mobile-initiated Cell Selection
    • Mobile-initiated Cell Reselection (Idle Mode)
    • Mobile-initiated Cell Reselection (PS Data Transfer Mode)
  • Network-Initiated Cell Reselection and Handover
    • Network-initiated Cell Reselection (Idle Mode and PS Data Transfer Mode)
    • Handover (CS Voice and DTM)

Set Up the Two-Cell Test System

This procedure details how to set up the two-cell test system.

All of the procedures in this section require that you first set up the two-cell test system as follows:

  1. Connect the two test sets via an External Device Connection .
  2. If remote control of the test sets in the two-cell test system is required, connect each test set GPIB port to the controlling PC.
  3. Connect the mobile's RF port to both test sets in the two-cell test system via an RF splitter.
  4. Compensate for the losses through the splitter by setting the Amplitude Offset for each test set.
  5. Important : you must set DUT IP Address to a different value in each test set.
    In the GSM/GPRS/EGPRS application, DUT IP Address is accessible from DUT PDP Setup ( F2 ). In the W-CDMA/HSPA application, DUT IP Address is accessible from DUT IP Setup ( F2 ).
  6. If you wish to emulate a GSM/GPRS/EGPRS cell in one or both test sets:
    • Set Operating Mode ( F1 ) to Cell Off .
    • Set the BCH Cell Band to the proper value for your mobile, then set Broadcast Chan to a different value in each test set ( BCH Parameters ( F7 )).
    • Set TCH Traffic Channel and PDTCH Traffic Channel to a different value in each test set ( TCH Parameters ( F8 ) and PDTCH Parameters ( F9 )).
    • Set Cell Identity , LAC , RAC , NCC and BCC to a different value in each test set ( Cell Info ( F6 ), Cell Identification ( F3 )).
    • Set Persistent Attach State to On in both test sets ( Cell Info ( F6 ), Cell Operation ( F1 )).
    • Set IMSI Attach State to On in both test sets ( Cell Info ( F6 ), Cell Parameters ( F1 )).
    • Select Cell Info ( F6 ), Cell Lists ( F4 ):
      1. Select GSM Neighbours (BCH) ( F1 ), set Cell State to On and set Neighbor Cell 1 ARFCN , NCC and BCC to match the Broadcast Chan , NCC and BCC settings in the other test set (if both test sets are emulating a GSM/GPRS/EGPRS cell).
      2. Select 3G FDD Neighbors ( F4 ), set UARFCN State to On and set UARFCN and Cell 1 Scrambling Code to match the DL Channel and Primary Scrambling Code settings in the other test set (if the other test set is emulating a W-CDMA/HSPA cell).
    • Set Cell Parameters as desired to affect the cell selections/reselections ( Cell Info ( F6 )).
    • To allow mobile-initiated cell reselections, set Network Control Order to 0 or 1 ( Measurement Reports ( F6 ), Configure ( F2 ), General Meas Parameters ( F1 )).
    • Set Cell Power ( F7 ) as desired ( BCH Parameters ( F7 )).
    • Ensure that Data Connection Type ( F2 ) is set to Auto in both test sets.
    • Set Operating Mode ( F1 ) to Active Cell (GSM) , Active Cell (GPRS) or Active Cell (EGPRS) as desired in each test set.
  7. If you wish to emulate a W-CDMA/HSPA cell in one of the test sets:
    • Set Operating Mode ( F1 ) to Cell Off .
    • Set DL Channel to the proper value for your mobile ( Channel (UARFCN) Parms ( F12 ).
    • Set Primary Scrambling Code as desired ( Generator Info ( F3 ), Downlink Channel Codes ( F2 ), Shared Channel Codes ( F2 )).
    • Select SIB11 Cell Info List ( F3 ):
      1. Select SIB11 GSM Cells 1-4 Info List ( F4 ), set GSM 1st Cell State to On and set GSM 1st Cell NCC , BCC , Shared ARFCN Indicator and ARFCN to match the Broadcast Chan , NCC and BCC settings in the other test set.
    • Set LAC , RAC and Cell Identity to different values from the other test set, and set ATT (IMSI Attach) Flag State to Set ( Cell Info ( F2 ), Cell Parameters ( F1 )).
    • Set Cell Parameters , Reselection Parameters and Access Restriction Parameters as desired to affect the cell selections/reselections ( Cell Info ( F2 )).
    • Set Cell Power ( F7 ) as desired.
    • Set GPRS Radio Access Bearer as desired ( Data Channels ( F4 ), Packet Data Setup ( F1 )).
    • Set Operating Mode ( F1 ) to Active Cell .

Mobile-initiated Cell Selection/Reselection

Mobile-initiated Cell Selection

This procedure allows you to observe which cell the mobile selects from the two-cell test system once it has completed its power-up sequence.

  1. Set Up the Two-Cell Test System
  2. Power on the mobile.
  3. Wait for the mobile to perform its cell selection algorithms and camp on one of the test sets in the two-cell test system.
  4. Check to see which test set the mobile registers with/attaches to.

Mobile-initiated Cell Reselection (Idle Mode)

This procedure assumes that you have Set Up the Two-Cell Test System , the mobile has been powered on and is camped on one of the cells in the system as is described in the Mobile-initiated Cell Selection procedure.

Note, mobile-initiated cell reselection is not possible from a W-CDMA/HSPA cell when the mobile is PDP active. If you turn off the serving W-CDMA/HSPA test set's cell power, the mobile will find the other test set and establish a PDP Context with it; however, this is not the same as a mobile-initiated reselection to the other test set.

  1. Change the cell characteristics of one or both of the test sets in the two-cell test system such that the test set to which the mobile is not currently camped has more desirable characteristics than the one to which it is camped. For example, change the Cell Power of one or both of the test sets so that the test set that was not initially selected has a much stronger signal (or simply turn the cell power off in the test set the mobile is currently camped on).
  2. Verify that the mobile did in fact reselect the more appropriate cell by observing the changes in the connection status of both test sets in the two-cell test system. If the mobile automatically registers/attaches with the other test set, it is easy to see which cell the mobile is camped on by observing the connection status window. You can also originate a voice call from the mobile to determine to which cell it is currently camped.
  3. Repeat steps 1 and 2 if you want to force the mobile to return to the other test set in the two-cell test system.

Mobile-initiated Cell Reselection (PS Data Transfer Mode)

This procedure assumes that you have Set Up the Two-Cell Test System and the mobile has been powered on and is camped on one of the cells in the system as is described in the Mobile-initiated Cell Selection procedure.

Note, mobile-initiated cell reselection is not possible from a W-CDMA/HSPA cell when the mobile is PDP active. If you turn off the serving W-CDMA/HSPA test set's cell power, the mobile will find the other test set and establish a PDP Context with it; however, this is not the same as a mobile-initiated reselection to the other test set.

  1. Start a GPRS/EGPRS data connection between the mobile and the external server and configure the other test set for the type of data connection you wish to transfer to (by selecting the Operating Mode and Coding Scheme for GPRS/EGPRS or the GPRS Radio Access Bearer and CQI Value for W-CDMA/HSPA).
  2. Press the Instrument Selection key and select Data Throughput Monitor on both test sets. Observe the transfer of data on the current serving cell. You can also observe the DUT IP counters present on the Call Setup screen in GPRS/EGPRS or on the Data Channels screen in W-CDMA/HSPA.
  3. Change the cell characteristics of one or both of the test sets in the two-cell test system such that the test set which the mobile is not currently camped on has more desirable characteristics than the one it is currently camped on. For example, change the Cell Power of one or both of the test sets so that the test set that was not initially selected has much stronger signal (or simply turn the cell power off in the test set the mobile is currently camped on).
  4. Verify that the mobile did in fact reselect the more appropriate cell by observing the Data Throughput Monitor display and IP counters on both test sets.
  5. Repeat steps 1 through 4 if you want to force the mobile to return to the other test set in the two-cell test system.

Network-Initiated Cell Reselection and Handover

Network-initiated Cell Reselection (Idle Mode and PS Data Transfer Mode)

This procedure explains how to test both idle mode and packet-switched data transfer mode cell reselections. This procedure assumes that you have Set Up the Two-Cell Test System and the mobile has been powered on and is camped on one of the cells in the system as is described in the Mobile-initiated Cell Selection procedure. No CS voice call should be connected in this procedure.

Note, in a W-CDMA/HSPA cell, for Release 99 mobiles, network-initiated cell reselection is only possible when the mobile is PDP active.

  1. For idle mode cell reselections from a GSM/GPRS/EGPRS cell, ensure that the mobile is attached or PDP active. For idle mode cell reselection from a W-CDMA/HSPA cell, ensure that the mobile is PDP active. For PS data transfer mode cell reselection, ensure that there is an active GSM/GPRS/EGPRS or W-CDMA/HSPA data connection between the mobile and test set by observing the Data Throughput Monitor .
  2. If the current serving cell is GSM/GPRS/EGPRS, select Handover Parameters ( F10 ), Ext Handover Setup ( F9 ). If the current serving cell is W-CDMA/HSPA, select Handovers ( F5 ), 1 of 2 ( MORE ), External 8960 Handover ( F1 ).

    Note: The external handover menus are only available if the two test sets currently have an External Device Connection . This can be verified by observing the External Device Connection Setup screen ( SYSTEM CONFIG , More ( 1 of 2 ), External Device Connection ( F4 )), or the ExtDev status indicator in the Instrument Status Area :

  3. Press Ext Handover Execute or Execute Ext 8960 Handover ( F5 ). This instructs the network to send a PCCO message if the current serving cell is GPRS/EGPRS or a CCO message if the current serving cell is W-CDMA/HSPA.
  4. Ensure that the (packet) cell change order was successful by viewing connection status on both test sets (for idle mode cell reselection) or the Data Throughput Monitor display and IP counters on both test sets (for PS data transfer mode cell reselection).
  5. Repeat steps 1 through 4 if you want to force the mobile to return to the other test set in the two-cell test system.

Handover (CS Voice and DTM)

This procedure only applies to CS (Circuit-Switched) voice and DTM (Dual Transfer Mode) handovers. This procedure assumes that you have Set Up the Two-Cell Test System and the mobile has been powered on and is camped on one of the cells in the system as is described in the Mobile-initiated Cell Selection procedure.

Note, because simultaneous services in the W-CDMA/HSPA application do not support two-cell test system handovers, perfoming a handover from a GSM/GPRS/EGPRS DTM connection to a W-CDMA/HSPA cell is unsupported, and may result in undetermined behavior.

  1. Establish a mobile originated or mobile terminated CS voice call with one of the test sets, (or a DTM connection if your GSM/GPRS/EGPRS mobile supports it and your two-cell test system is emulating two GSM/GPRS/EGPRS cells). The voice connection status should display Connected (for a DTM connection, the connection status window displays the voice and data connection status in the form: voice/data).
  2. If the current serving cell is GSM/GPRS/EGPRS, select Handover Parameters ( F10 ), Ext Handover Setup ( F9 ). If the current serving cell is W-CDMA/HSPA, select Handovers ( F5 ), 1 of 2 ( MORE ), External 8960 Handover ( F1 ).

    Note: The external handover menus are only available if the two test sets currently have an External Device Connection . This can be verified by observing the External Device Connection Setup screen ( SYSTEM CONFIG , More ( 1 of 2 ), External Device Connection ( F4 )), or the ExtDev status indicator in the Instrument Status Area :

  3. Press Ext Handover Execute or Execute Ext 8960 Handover ( F5 ). This instructs the network to begin its handover procedure.
  4. Ensure that the handover was successful by viewing the connection status window. During the handover, both test sets display Handover . The destination test set then transitions to Connected , while the originating test set transitions to Idle .
  5. Repeat steps 1 through 4 if you want to force the mobile to return to the other test set in the two-cell test system.

Related Topics

Two-Cell Test System


How Do I Change UE TX Power Levels?

How Do I Change UE TX Power Levels?

Last updated: January 15, 2009

A. Using Closed Loop Power Control

  1. Press the CALL SETUP key.
  2. Press the More key on the right side two times to go to Call Parms ( 3 of 3) .
  3. Press the UE Target Power ( F7 ) key, and set the desired average transmit power of the UE (see UE Target Power ).
  4. Press the UL CL Power Ctrl Parameters ( F8 ) key.
  5. Highlight the UL CL Power Ctrl Mode and select Active bits . This activates the uplink closed loop power control.
  6. Highlight the UL CL Power Ctrl Algorithm and select power control algorithm as desired. If algorithm One is selected for power control, you can also specify the UL CL Power Ctrl Stepsize to either 1 dB or 2 dB.
  7. Now, the UE's transmit power will be controlled automatically by the closed loop power control to maintain the UE's average power at the value entered for the UE Target Power .

B. Controlling the UE's TX Power Manually

  1. Press the CALL SETUP key.
  2. Press the More key on the right side two times to go to screen 3 of 3 .
  3. Press the UL CL Power Ctrl Parameters ( F8 ) key.
  4. Highlight the UL CL Power Ctrl Mode and select a power control mode other than Active bits . This allows you to control the UE's transmit power manually.
  5. Highlight the UL CL Power Ctrl Algorithm and select power control algorithm as desired. If algorithm One is selected for power control, you can also specify the UL CL Power Ctrl Step Size to either 1 dB or 2 dB.
  6. If you've chosen Alternating bits as the power control mode, you can use the Send Step Up TPC Bit Pattern ( F10 ) key or the Send Step Down TPC Bit Pattern ( F11 ) key to change the UE's transmit power either up or down by one step.

Related Topics

Uplink Closed Loop Power Control Parameters and UE Target Power


How Do I Order and Retrieve UE Reported Measurement Results?

How Do I Order and Retrieve UE Reported Measurement Results?

Last updated: January 15, 2009

  • Lab Application - Cell 1/Cell 2 Measurements
  • Lab Application - Compressed Mode Measurements (Inter Frequency and GSM Cells)
  • Test Application - Cell 1 Measurements

Lab Application - Cell 1/Cell 2 Measurements

  1. Establish a call between the test set and UE (see How Do I Set Up a Call and Make a Connection? )
  2. Select Handovers ( F5 ) from the Call Control 1 of 5 menu.
  3. Select Soft Handover Info ( F4 ).
  4. Turn Cell 2 Power ( F1 ) on if you would like to retrieve UE measurement results for cell 2 as well as cell 1.
  5. Press the More key under Soft Info to move to the 2 of 2 menu.
    • Set Report Measurement Type ( F2 ) and SFN-SFN OTD Measurement Type ( F4 ) to specify which measurements the UE should perform when Send Meas Request ( F5 ) is selected.
    • If you specified that the UE should measure DTCH BLER , set the BLER Rep Intrvl ( F1 ) as needed.
    • Select Send Meas Request ( F5 ) (this will only be present if you have a call connected). UE reported measurement results are displayed.

Lab Application - Compressed Mode Measurements (Inter Frequency and GSM Cells)

See How Do I Enable Compressed Mode and Obtain UE Measurement Results? .

Test Application - Cell 1 Measurements

  1. Establish a call between the test set and UE (see How Do I Set Up a Call and Make a Connection? )
  2. Press the left More key until you reach the Call Control 2 of 5 menu.
  3. Select UE Rep Meas ( F5 ).
  4. Set Report Measurement Type ( F2 ) to specify which measurements the UE should perform when Send Meas Request is selected.
  5. If you specified that the UE should measure DTCH BLER , set the BLER Rep Intrvl ( F1 ) as needed.
  6. Select Send Meas Request ( F5 ) (this will only be present if you have a call connected). UE reported measurement results are displayed.

Related Topics

UE Reported Measurements


How Do I Change Uplink Parameters?

How Do I Change Uplink Parameters?

Last updated: January 15, 2009

  1. Press the CALL SETUP key.
  2. Press Operating Mode ( F1 ) and select Cell Off .
  3. Press More key on the left to go to Call Control ( 2 of 5 ).
  4. Press the Uplink Parameters ( F 4 ) to access the settings for uplink PRACH and DPCH channels.
  5. Turn the knob to highlight a parameter and then press the knob.
  6. Enter a value or selection as desired and press the knob.
  7. Press Close Menu ( F6 ).
  8. Change the operating mode back to Active Cell if needed.

Related Topics

Uplink Parameters


How to use the UMA/GAN Features

How to use the UMA/GAN Features

Last updated: January 15, 2009

This section is only applicable to the lab applications.

This section describes general procedures for performing the UMA/GAN Test from the test set's front panel.

  1. Connect the GANC to the test set. The "ExtDev" is displayed on the front panel when the connection between the test set and the GANC has been established. Refer to the Help File for the GANC software for details on how to set up the connection between the test set and the GANC.

    E6962A Help File

    IMPORTANT: Save the file to your desktop. For Windows XP, right-click on the file and select Properties>>Unblock.

  2. The "Sys Type" field displays "GAN" when the current access stratum used by the mobile station is GAN.
  3. The Voice/Data connection status display fields are used to report the current core network voice and data connection status to the MS regardless of the underlying access technology (GAN or GERAN).

Related Topics

UMA/GAN Test System

CALL:ACCess


How Do I Make a Video Call?

How Do I Make a Video Call?

Last updated: January 15, 2009

This topic includes instructions for performing a:

  • UE-to-UE Video Call
  • Loopback Video Call

UE-to-UE Video Call

This section is only applicable to the lab application and to a test application with the required feature license.

UE-to-UE Video Call Setup

  1. Establish an external device connection between 8960 #1 and 8960 #2 (see How Do I Make an External Device Connection? ).
  2. Connect UE #1 to 8960 #1.
  3. Connect UE #2 to 8960 #2.
  4. Turn on the UEs and wait for each to camp to its 8960 (see How Do I Set Up a Call and Make a Connection? ).
  5. Select Video Call Parameters ( F1 on Call Control 5 of 5 ) and set Video Call Type to UE-to-UE .
  6. Originate a video call from UE #1 (you may choose to originate the call from either UE, this example assumes the call is originated from UE #1). Note: originating a video call on your UE will likely require different key presses than originating a voice call. The UE-to-UE video call can not be initiated from either of the 8960s.
  7. If Calling Party Number Inclusion is set to Include (see How Do I Perform Calling Party Number Verification? ), the Calling Party Number is displayed on the screen of UE #2. Answer the call on UE #2.
  8. Note the following on the Call Setup Screen of both 8960s:
    • Call processing state is Connected .
    • Current System Type (displayed in the Call Processing Status window) is CS Data - UE to UE Video Call .
    • The Called Party Number you dialed when originating the call is displayed in the UE Information window.
  9. If desired, initiate transmitter measurements on both 8960s and measure the UEs' performance.
  10. You can end the UE-to-UE video call from either UE, or by selecting End Call ( F3 ) on either 8960.

Loopback Video Call

This section is only applicable to the lab application.

  1. Connect the UE to the test set.
  2. Turn on the UE and wait for it to camp to the test set (see How Do I Set Up a Call and Make a Connection? ). Note, if the UE automatically establishes a PDP context (the connection status displays PDP Active ), then press End Call ( F3 on the screen Call Setup screen )
  3. Select Video Call Parameters ( F1 on Call Control 5 of 5 ) and set Video Call Type to Loopback .
  4. Originate a video call from the UE. Note: originating a video call on your UE will likely require different key presses than originating a voice call. The loopback video call cannot be initiated from the test set.

Related Topics

Video Call

Troubleshooting Video Call

Manual Operation: How Do I Make an External Device Connection?


Printing Screens

Printing Screens

Last updated: January 15, 2009

Printing and Saving Screen Images

The test set's local area network (LAN) connection can be used to dump the currently-displayed screen image into a personal computer's web browser. The computer must either be connected to an existing LAN or have a LAN adapter installed that can be connected directly to the test set.

Computer Requirements for LAN Communications with the Test Set

The computer used to capture screen images from the test set must meet the following requirements:

  • 10 Base-T, IEEE 802.3 compliant, ethernet network interface using TCP/IP protocol and configured to run in half-duplex mode.
  • Windows 95, 98, 2000 or NT 4.0 (Windows 95, Windows 98, Windows 2000 and Windows NT 4.0 are U.S. registered trademarks of Microsoft Corporation.)

Test Set to Computer Connections

The test set's LAN connection can be made at either the rear-panel LAN PORT or at the front-panel DATA port. When using the DATA port, be sure to have the factory supplied jumper cable installed between the rear-panel LAN PORT and the ETHERNET TO FRONT PANEL port.

Connections from the test set to the computer must be made using the correct type of LAN cable:

  • If the test set is being connected to the computer through an existing network, use a standard LAN cable.
  • If the test set is being connected directly to the computer's LAN adapter, use a crossover LAN cable (such as the one shipped with the test set or with an older test application upgrade kit).

Capturing the Screen Image

  1. Press the test set's SYSTEM CONFIG key to display the test set's LAN settings, and record the LAN IP Address for use later in this procedure.
  2. Start a web browser application on your computer.
  3. Display the test set screen that you want to capture.
  4. Enter the following address/location into your web browser: http://<lan address>/display.htm
    where <lan address> is the LAN IP address of the test set .
  5. Within a few seconds, the test set's screen image appears in your browser. If the image does not appear on your browser within 30 seconds, refer to Test Your LAN Connections and Configuration by "Pinging" the Test Set below.
  6. To print the image, select File , Print .
  7. To save the file:
    1. Select File , or right-click on the image, and select Save As or Save Picture As .
    2. Enter the desired file name and directory path for saving the image as a GIF file.

The image can now be retrieved from your directory and used as needed.

Test Your LAN Connections and Configuration by "Pinging" the Test Set

Perform this operation only if you were not successful in downloading the test set screen image into your browser.

  1. Display the Command Prompt window on your computer. This is typically done in the Microsoft Windows operating system by selecting Start -> Programs -> Command Prompts .
  2. At the command prompt, enter the following command: ping <lan address>. The <lan address> is the test set's LAN IP address. (The command prompt does not have to be at the root (c:\) level before entering the command.)

    This example shows what should happen when you enter the ping command for a test set with the LAN IP address of 111.22.333.44. The test set should reply back to the Command Prompt screen indicating that data was received.
  3. If the message " Request Timed Out " is displayed instead of a reply from the test set, try entering the command again. If the request times out again, your LAN connections are incorrect and/or your LAN settings for the two devices do not match.

Troubleshooting LAN Connections

If your web browser did not display the test set's screen, or you could not "ping" your test set from your browser, refer to the following information to find the cause and fix the problem.

Try Altering Connections

  • If you are using the test set's front panel DATA port, make sure the jumper between the rear-panel LAN PORT and ETHERNET TO FRONT PANEL port is in place; or try connecting directly to the rear-panel LAN PORT.
  • Try using a different type of LAN cable. If you were using a crossover cable, try using a standard LAN cable; if using a standard LAN cable, try using a crossover cable. If this doesn't fix the problem, be sure to replace the cable with the type recommended in Test Set to Computer Connections above.

Reconfigure the Computer and Test Set LAN Settings

If the test set's image is still not displayed on your web browser, and the ping command still indicates that the test set is not communicating with the computer, you need to verify that the LAN settings for the computer and the test set are compatible. The following sections provide general guidelines in getting the LAN settings configured for both instruments to communicate with each other.

Perform the configuration in the following order:

  1. Configure the computer's LAN settings.
  2. Restart Windows on the computer to start using the new LAN configuration.
  3. Configure the test set's LAN settings to work with the computer's settings. (It is important that the computer be configured and re-started before configuring the test set's LAN settings.)
  4. Turn the test set off and back on to make sure it finds the computer's newly-configured LAN card on power up.

LAN Setting Guidelines

  • It is highly recommended that the Subnet Mask be set to 255.255.248.0 for the test set and the computer when using a direct computer-to-test set connection.
  • The first three groups of numbers for the LAN IP Address of the test set and the computer must match. Example; if the test set's LAN IP Address is set to 130.29.189.33, the computer's LAN IP address must begin with 130.29.189.

    The number in the fourth group of digits in the computer's and test set's LAN IP Addresses must NOT match. Example; if the test set is set to LAN IP Address 130.29.189.33, set the computer's LAN IP Address to 130.29.183.34 (or 130.29.183.77, 130.29.183.42...- just so the last number is not also set to 33). The last entry in the IP Address must not be >254 or 0.

Changing the LAN Setting on Your Computer

Network configuration procedures vary between operating systems. You may have to refer to your computer's help system, or your LAN adapter card's documentation, for assistance.

Perform the following steps to alter the network settings for most PCs using a Microsoft Windows operating system.

Access the Network Settings

  1. Double-click on the My Computer icon on the Windows desk top.
  2. Double-click on the Control Panel icon.
  3. Double-click on the Network icon.
  4. Select the TCP/IP -> [your Ethernet network adapter] entry from the list of components. Note: Do not select TCP/IP Dial-Up Adapter settings if present.
  5. Select Properties to access the TCP/IP settings screen.
Accessing Your Computer's LAN Settings

Set the IP Address and Subnet Mask

  1. Select the IP Address tab on the TCP/IP Properties screen.
  2. Select Specify an IP Address .
  3. Enter the IP Address for the computer. Remember, the last entry in the IP Address must not be >254 or 0.
  4. Enter the Subnet Mask (255.255.248.0).
Specifying the Computer's IP Address and Subnet Mask

Remove Any Gateway Setting

  1. Select the Gateway tab.
  2. If present, remove any existing setting.
  3. Click OK until you have closed the Network settings window.
Accessing the Gateway Setting

Restart Windows

Depending on your LAN network adapter, your computer may or may not apply the network configuration changes as they are made. It is import that you restart Windows NOW to make sure new LAN settings are in effect when you try to connect to the test set.

Changing the LAN Settings on Your Test Set

  1. Press the SYSTEM CONFIG key on the test set to display the current LAN settings.
  2. Press the F1 ( Instrument Setup ) key.

    NOTE
    Changing the LAN IP Address may alter the Subnet Mask setting. Therefore, change the LAN IP Address first, then change the Subnet Mask. Also, The last entry in the IP Address must not be >254 or 0.

  3. Turn the knob to highlight the setting you want to change.
  4. Press the knob to select the setting.
  5. Enter the new value using the keypad, and press the knob to complete the setting.
  6. Turn the test set off and back on to start using the new settings.

Related Topics

Configuring the Test Set's LAN


Rear Panel Connectors

Rear Panel Connectors

Last updated: February 26, 2012

Description

BASEBAND I/O

Four pins are functional on this connector:

  • I channel (pin 9)
  • Q channel (pin 26)
  • Ground
  • Ground

CLK IN

Not functional for this release.

COUNTER IN

Not functional for this release.

DATA IN

Not functional for this release.

DATA VALID IN

Not functional for this release.

EXT INTERFACE CONTROL

Not functional for this release.

EXT SIG GEN/FRAME SYNCH

Not functional for this release.

FM MOD IN

This BNC connector allows you to use an external signal to frequency modulate the test set's RF generator. It has a fixed sensitivity of 20 KHz/volt, and a frequency range of 100Hz to 20 KHz.

GPIB

This GPIB connector allows test set control with compatible devices.

LAN PORT

This RJ-45 connector provides a connection for downloading firmware upgrades, new applications and for acquiring screen captures. In the lab application only, the LAN PORT is also used for protocol logging.

LAN 2 PORT

This RJ-45 connector provides a connection for transferring data to the test set and for establishing an external device connection between two test sets.

LAN 3 PORT

For future use.

PRINTER

Not functional for this release.

SERIAL 1

Not functional for this release.

SERIAL 2

Not functional for this release.

SERIAL 3

Not functional for this release.

TEST SET SYNCH IN

Not functional for this release.

TEST SET SYNCH OUT

Not functional for this release.

TIMEBASE ADJUST

This is the timebase adjust cover. Removing this screw allows access for timebase adjustment.

TRIG IN

This BNC connector provides the capability for you to trigger measurements or instruments from an external source. Setting the Trigger Source setting to External for measurements or instruments which support this feature causes the measurement or instrument to trigger when a positive-going TTL compatible pulse is applied to this connector. Currently, the only measurement or instrument which supports this feature is the Spectrum Monitor.

TRIG OUT

This BNC connector allows you to synchronize the test set to other equipment via a trigger signal.

VGA OUT

This DB-15 connector allows you to simultaneously route the test set's display to another monitor.

10 MHZ REF IN

This BNC connector accepts an external 10 MHz timebase signal. The nominal input impedance is 50 ohm. This version of test set can only accept a 10 MHz timebase signal.

10 MHZ REF OUT

This BNC connector provides a 10 MHz timebase signal to external test equipment. The accuracy of this signal is determined by the timebase used. The nominal output impedance is 50 ohm with a typical level of 0.5 V rms.

Related Topics

ETHERNET TO FRONT PANEL, LAN PORT: Configuring the Test Set's LAN

GPIB: Configuring the Test Set's GPIB

TRIG OUT: Trigger Output Setup


Remote/Local Mode

Remote/Local Mode

Last Updated: January 15, 2009

Description

Remote Mode

When the test set is operated remotely, all of the keys on the front panel of the test set are disabled (except the LOCAL key and the power switch). During remote operation the test set is controlled by the Remote User Interface, (RUI).

Any open menus are be closed, and any manual entries are be aborted when the test set transitions from local mode to remote mode.

The remote annunciator (R) will appear in the Instrument Status Area of the test set's display indicating that the test set is in remote mode.

When the test set is in remote mode press the LOCAL key on the front panel in order to gain manual control.

Local Mode

During local mode all front panel keys and the knob are enabled. During local operation the test set is controlled by the Manual User Interface, (MUI).

The remote annunciator (R) is turned off when the test set is operated in local mode.


Save and Recall Registers

Save and Recall Registers

Last updated: January 7, 2010

Description

The test set provides up to ten save/recall registers. Each register is identified by a number (1-10).

This section details the following:

  • Recalling Saved Registers
  • Deleting Saved Registers
  • Settings that are Saved
  • Settings that are not Saved
  • Saving Current Settings to a Register
  • Setting register names

Recalling Saved Registers

Press the Register recall hardkey.

Use the knob to scroll to a register that is labeled Full and press the knob.

When a register is recalled, the test set will clear all active measurements and display the Call Setup Screen. Registers can only be recalled in the format they were saved in. For example, in a fast switching application, a register that is saved in a specific format must also be recalled in that same format. If a register is attempted to be recalled in a format other than the one it was saved in, the following error will occur:

CAUTION
If the test set has had hardware options installed since the last time a registers were saved, delete the registers and re-save them. Failure to perform this step could result in a non-recoverable firmware "assert" when performing a register recall.

Deleting Saved Registers

Pressing the DELETE hardkey will display a menu indicating which registers have been saved (they are labeled "Full").

Use the knob to scroll to a register and press the knob. Select Yes to confirm the selection.

Settings that are Saved

All functions and parameters that have an associated static state or settable value will be saved. For example:

  • Cell parameters (System ID, Network ID, etc.)
  • Call control parameters (System Type, Operating Mode, etc.)
  • Measurement setup parameters (Trigger Arm state, Measurement Timeout, etc.)
  • Call Parms (Cell Power, Cell Band, etc.)

Settings that are not Saved

Functions that trigger immediate actions, such as originating a call or calibrating a measurement are not saved.

Settings saved in non-volatile memory (settings that are unchanged when power is cycled or the test set is preset) are not saved. For example:

  • LAN IP Address
  • Date/Time
  • RF IN/OUT Amplitude Offset
  • All other settings on the Instrument Setup menu on the System Config screen.
  • Measurement results
  • Call status
  • Active measurements

Read-only call processing results such as Mobile Station Information tables are not saved.

Saving Current Settings to a Register

To save the current state of the test set, press the SAVE hardkey.

A menu will be displayed that shows the status of all five registers. If the register status is "Full", the register has had instrument settings saved to it. If the register status is "Empty", it does not currently contain any instrument settings.

Use the knob to scroll to a register and press the knob. If the selected register is currently Full, select Yes in the Overwrite Save Reg? window and it will be overwritten.

CAUTION
When a test set application is upgraded using the 8960 File Utility Program, the new revision of the application will not automatically retain save/recall registers from the old revision. Prior to the application upgrade, it is recommended that you record the critical settings (such as call setup information) from registers that you will want to re-save after the test application upgrade.

Setting register names

When the Save hardkey is pressed, you can also set a name for each register to easily identify your saved configuration.To set a name for a specific register, press the Save hardkey. The Save Registers menu is displayed for you to operate on each register. Highlight the register you want to allocate a name, press the Set Register Name softkey on the left, a middle menu is displayed for you to edit the register name.

  • Done: the assignment of the register name is done, select this option will get the middle menu to be closed.
  • Clear: delete the name associated with the register.
  • Backspace: delete the last letter of the name.
  • A to Z, Space and 0 to 9: the register name can be comprised of any of these characters, until the maximum length of 20 characters is reached.

You can set the register name with a maximum length of 20 characters.

Once you have assigned a name to the register, the name will be in parentheses after the register number.

Related Topics

SYSTem:REGister


UE Information

UE Information

Last updated: January 15, 2009

  • IMSI
  • IMEI
  • Power Class
  • Detected PRACH Signature
  • Called Party Number
  • Clear UE Info

When the UE registers with the test set (see Performing a Location Update (CS Domain Registration) ), the following information is reported by the UE. You can query this information via GPIB commands, or view it on the Call Setup Screen under UE Information .

IMSI

International Mobile Subscriber Identity (used by the network to page the UE). See Test Set-Originated Connection .

GPIB command: CALL:MS:REPorted:IMSI[:SELected]?

IMEI

International Mobile Equipment Identity.

GPIB command: CALL:MS:REPorted:IMEI[:SELected]?

Power Class

The UE's power class defines its nominal maximum output power (see 3GPP TS 25.101 6.2).

GPIB command: CALL:MS:REPorted:PCLass[:SELected]?

Detected PRACH Signature

This feature is only applicable to the lab application.

When the UE sends a PRACH preamble, it uses one of the PRACH signatures that the test set has specified using the PRACH Signature parameter. If the test set has specified that more than one PRACH signature is available to the UE, in a series of PRACH bursts, the UE will randomly select which PRACH signature to use for any given burst.

The Detected PRACH Signature result is an integer representing the PRACH signature used by the UE on its final PRACH burst (the one that the test set responded to). If the PRACH Signature setting specifies a single PRACH signature, then Detected PRACH Signature and PRACH Signature should be the same.

For the lab application only, the PRACH preamble analysis measurement also reports the signature used by the UE for the PRACH burst it has analyzed (see PRACH Preamble Analysis Measurement Description ). If the PRACH Signature setting specifies a single PRACH signature, then the PRACH signature reported by the measurement, Detected PRACH Signature and PRACH Signature should be the same.

GPIB command: CALL:MS:REPorted:PRAChannel:SIGnature? .

Called Party Number

This feature is only applicable to the lab application.

This is the number the user dialed into the UE when a UE-originated call was established with the test set. If the user dialed 911, 112 or 999, the string "Emergency Call" is displayed.

See Calling Party Number Parameters for related information.

GPIB command: CALL:MS:REPorted:ONUMber<[:SELected]|WCDMa>?

Clear UE Info

To clear the UE reported information and counters, select Clear UE Info ( F6 ) from the Call Setup screen, or send the CALL:MS:REPorted:CLEar[:ALL]<[:SELected]|:WCDMa> command.

Related Topics

Establishing a Connection with the UE


UE Reported Measurements Ladder Diagrams

UE Reported Measurements Ladder Diagrams

Last updated: January 15, 2009

Measurement Request

Related Topics

UE Reported Measurements


UE Reported Measurements

UE Reported Measurements

Last updated: January 15, 2012

  • Cell 1/Cell 2 UE Reported Measurements
  • Compressed Mode UE Reported Measurements

When there is an active link between the UE and the test set, the UE can perform measurements on the test set's (cell 1) downlink signal and report the measurement results. For non-HSDPA connections, you can view the UE measurement results from the front panel (see How Do I Order and Retrieve UE Reported Measurement Results? ) or retrieve them using the appropriate GPIB syntax queries (see CALL:MS:REPorted ).

With the lab application only, the UE can report measurement results for both cell 1 and cell 2.

With the lab application only, in addition to measuring cell 1 and cell 2 from the test set, if the UE supports compressed mode operation (see Compressed Mode ), the UE can perform measurements on inter frequency neighbor cells or GSM neighbor cells (see Inter-frequency Cells and GSM Cells ). To enable this, you must specify these neighbor cells in the test set's BCCH messaging (see SIB11 Cell Info List ), and then use an external source to provide these neighbor cells to the UE (you may also order the UE to measure these neighbor cells without actually providing them via an external source, but the UE will simply give results indicating that there was no usable signal at the specified neighbor cell). The test set can retrieve the UE's measurement results for up to 8 inter frequency neighbor cells and 8 GSM neighbor cells.

Cell 1/Cell 2 UE Reported Measurements

Once you have established a (non-HSDPA) connection between the test set and UE, you can order the UE to perform measurements on cell 1 (and cell 2 if you are using the lab application) by selecting Send Measurement Request (see How Do I Order and Retrieve UE Reported Measurement Results? and CALL:MS:REPorted:MEASurement:REQuest ). When you select Send Measurement Request , the test set sends a Measurement Control Message to the UE indicating which measurements to perform, based on the following settings:

  • Report Measurement Type
    • Intra-frequency : When Report Measurement Type is set to Intra-frequency , the UE will make CPICH Ec/No , CPICH RSCP (Received Signal Code Power) and Pathloss measurements and return the results.
    • Quality : When Report Measurement Type is set to Quality , the UE will measure DTCH BLER (Block Error Ratio) Report and return the result.
    • All : When Report Measurement Type is set to All , the UE will measure CPICH Ec/No , CPICH RSCP (Received Signal Code Power) , Pathloss and DTCH BLER (Block Error Ratio) Report and return the results.

    GPIB command: CALL:MS:REPorted:MEASurement:TYPe .

  • SFN-SFN OTD Measurement Type

    This setting is applicable to the lab application only. See 3GPP TS 25.133 s9.1.8.

    • None : When SFN-SFN OTD Measurement Type is set to None , the UE will not measure SFN-SFN OTD.
    • Type 1 : When SFN-SFN OTD Measurement Type is set to Type 1 , the UE will perform a Type 1 SFN-SFN Observed Time Difference (OTD) measurement and return the result.
    • Type 2 : When SFN-SFN OTD Measurement Type is set to Type 2 , the UE will perform a Type 2 SFN-SFN Observed Time Difference (OTD) measurement and return the result.

    GPIB command: CALL:MS:REPorted:MEASurement:OTDifference:TYPE .

Cell 1/Cell 2 Measurement Results

  • CPICH Ec/No

    CPICH Ec/No is the ratio of the received energy per PN chip for the CPICH to the total received power spectral density at the UE antenna connector. The reporting range for CPICH Ec/No is -24 dB to 0 dB (0 to 49). See 3GPP TS 25.133 s9.1.2.3. When the Cell 1 Connected CPICH Level setting is set to -3.30 dB , the UE should report a value of 42 (-3.5 </= CPICH Ec/No < -3).

    CPICH Ec/No Reported Value Mapping to Measured Quantity
    CPICH Ec/No Reported Value | Measured Quantity Value | Unit
    0 | CPICH Ec/No < -24 | dB
    1 | -24 </= CPICH Ec/No < -23.5 | dB
    ... ... ...
    48 | -0.5 </= CPICH Ec/No < 0 | dB
    49 | 0 </= CPICH Ec/No | dB

    GPIB command: CALL:MS:REPorted[:CELL[1]]:CPICh:ECNO? and CALL:MS:REPorted:CELL2:CPICh:ECNO? .

  • CPICH RSCP (Received Signal Code Power)

    This is the absolute power level of the CPICH as received by the UE. The reporting range for CPICH RSCP is -115 dBm to -25 dBm (0 to 91). See 3GPP TS 25.133 s9.1.1.3. When the Cell 1 Connected CPICH Level setting is set to -3.30 dB and Cell Power is set to -75.00 dBm , the UE should report a value of 37 (-79 </= CPICH RSCP < -78).

    CPICH RSCP Reported Value Mapping to Measured Quantity
    CPICH RSCP Reported Value | Measured Quantity Value | Unit
    0 | CPICH RSCP < -115 | dBm
    1 | -115 </= CPICH RSCP < -114 | dBm
    ... ... ...
    90 | -26 </= CPICH RSCP < -25 | dBm
    91 | -25 </= CPICH RSCP | dBm

    GPIB command: CALL:MS:REPorted[:CELL[1]]:CPICh:RSCP? and CALL:MS:REPorted:CELL2:CPICh:RSCP? .

  • Pathloss

    This is the pathloss between the cell and UE. It is calculated by comparing the UE's measurement of CPICH RSCP and the value of Primary CPICH Tx Power (the power level of the CPICH at the cell, as reported by the cell).

    Pathloss (dB) = Primary CPICH Tx Power (dBm) - CPICH RSCP (dBm)

    See 3GPP TS 25.331 s14.1.1.

    NOTE
    The Primary CPICH TX Power setting in the test set determines the Primary CPICH Tx Power value sent in SIB5 for cell 1. However, when making a Pathloss measurement the UE uses the Primary CPICH Tx Power value in its cell info list. The Measurement Control message sent by the test set to request UE measurements includes a cell info list with a value of +50 dBm for cell 1's Primary CPICH Tx Power and +26 dBm for cell 2's Primary CPICH Tx Power. Thus, the UE always uses a value of +50 dBm (cell 1) or +26 dBm (cell 2) for Primary CPICH Tx Power when determining Pathloss.

    The range of the Pathloss measurement result is 46 dB to 158 dB.

    GPIB commands: CALL:MS:REPorted[:CELL[1]]:PATHloss? and CALL:MS:REPorted:CELL2:PATHloss? .

  • DTCH BLER (Block Error Ratio) Report

    This is a measure of the UE's ability to receive the DTCH without errors. The reporting range for BLER is 0 to 1 (0 to 63). For the lab application, if you have enabled soft handover (see Soft Handover ), the DTCH BLER Report result includes both cell 1 and cell 2. See 3GPP TS 25.133 s9.1.5.

    DTCH BLER Reported Value Mapping to Measured Quantity
    DTCH BLER Reported Value Measured Quantity Value Unit
    0 BLER = 0 -
    1 -infinity < Log10(BLER) < -4.03 -
    2 -4.03 </= Log10(BLER) < -3.965 -
    ... ... ...
    61 -0.195 </= Log10(BLER) < -0.13

    62 -0.13 </= Log10(BLER) < -0.065 -
    63 -0.065 </= Log10(BLER) < -0 -

    GPIB command: CALL:MS:REPorted[:CELL[1]]:DTCH:BLER? .

    To set the BLER reporting interval (the UE's observation period for determining BLER), see How Do I Order and Retrieve UE Reported Measurement Results? or CALL:DTCHannel:BLER:REPorting:INTerval .

  • SFN-SFN Observed Time Difference (OTD)

    This measurement result is available in the lab application only. As defined in 3GPP TS 25.215 5.1.9, the UE can measure the timing difference (in chips) between cell 1 and cell 2. There are two types of SFN-SFN OTD measurements:

    • Type 1: With Type 1 OTD, the UE measures the timing difference between the P-CCPCHs of cell 1 and cell 2. This type is only available on a CELL_FACH connection (see RB Test Mode RRC State Setting ). Although you can not perform a soft handover while on a CELL_FACH connection, you can turn cell 2 power on so that the UE can measure the timing difference between cell 1 and cell 2. While on a CELL_FACH connection, the Measurement Control Message is sent to the UE on the FACH, and the UE's measurement results are returned on the RACH.
    • Type 2: With Type 2 OTD, the UE measures the timing difference between the CPICHs of cell 1 and cell 2. This type is applicable to both CELL_DCH and CELL_FACH connections (see RB Test Mode RRC State Setting ). With either connection type, if there is power in cell 2, the UE can measure the timing difference between the two cells. While on a CELL_DCH connection, the UE can measure OTD while in soft handover with cells 1 and 2.

    You can change the time offset between cell 1 and cell 2 using the Cell 2 Time Offset setting. Note, while Cell 2 Time Offset can be set to a negative value, the OTD measurement result gives the absolute timing difference between cell 1 and cell 2.

    GPIB commands: CALL:MS:REPorted:CELL2:OTDifference[:VALue]? and CALL:MS:REPorted:CELL2:OTDifference:TYPE? .

Compressed Mode UE Reported Measurements

In the lab application only, you can enable compressed mode operation in the uplink and downlink, order the UE to perform measurements on Inter-frequency Cells , GSM Cells or SIB19 E-UTRA Info List , and then retrieve the UE's measurement results (see Compressed Mode ).

A single measurement report from the UE can return results for up to 8 GSM neighbor cells, 8 inter-frequency neighbor cells or 8 cells across four different EARFCNs (the standard allows the UE to measure up to 16 E-UTRAN cells (3GPP TS 25.331), but the test set only reports the first 8 E-UTRAN cells).

See How Do I Enable Compressed Mode and Obtain UE Measurement Results? .

Inter-Frequency Neighbor Cell Measurement Results

  • Total Number of Inter-frequency Cells

    Returns the total number of inter-frequency cells reported by the UE. Although the UE can measure up to 32 inter-frequency cells at two different frequencies (as per 3GPP TS 25.133 s8.1.2.1), the test set will only display on the front panel and return by GPIB query the results for the first 8 cells measured. As the test set can only specify up to 8 neighbor cells for the UE to measure, it is expected that the UE will not return results for more than 8 cells. However, the results for all measured cells are available in the Measurement Reports returned by the UE, which are viewable using the Wireless Protocol Advisor (see Protocol Logging ).

    GPIB command: CALL:MS:REPorted:ITRFrequency:CELLs?

  • Scrambling Code

    The scrambling code is returned for each inter-frequency cell measured by the UE (up to 8 measured cells).

    GPIB command: CALL:MS:REPorted:ITRFrequency:SCODe?

  • DL Channel

    The downlink channel is returned for each inter-frequency cell measured by the UE (up to 8 measured cells).

    GPIB command: CALL:MS:REPorted:ITRFrequency:DOWNlink:CHANnel?

  • RSSI (Inter-frequency Cells)

    RSSI (Received Signal Strength Indicator) is returned for each inter-frequency cell measured by the UE (up to 8 measured cells). See 3GPP TS 25.133 table 9.12 for a mapping of returned value to actual value.

    GPIB command: CALL:MS:REPorted:ITRFrequency:RSSI?

  • Ec/No

    Ec/No is returned for each inter-frequency cell measured by the UE (up to 8 measured cells). See CPICH Ec/No .

    GPIB command: CALL:MS:REPorted:ITRFrequency:ECNO?

  • RSCP

    RSCP is returned for each inter-frequency cell measured by the UE (up to 8 measured cells). See CPICH RSCP (Received Signal Code Power) .

    GPIB command: CALL:MS:REPorted:ITRFrequency:RSCP?

  • Pathloss

    Pathloss is returned for each inter-frequency cell measured by the UE (up to 8 measured cells). See Pathloss .

    GPIB command: CALL:MS:REPorted:ITRFrequency:PATHloss?

GSM Neighbor Cell Measurement Results

  • Total Number of GSM Cells

    Returns the number of GSM cell measurement results available from the front panel and over GPIB (up to 8). Per 3GPP TS 25.133 s8.1.2.1, the UE can measure as many as 32 GSM neighbor cells. As the test set can only specify up to 8 neighbor cells for the UE to measure, it is expected that the UE will not return results for more than 8 cells. However, the results for all measured cells are available in the Measurement Reports returned by the UE, which are viewable using the Wireless Protocol Advisor (see Protocol Logging ).

    GPIB command: CALL:MS:REPorted:GSMSystem:CELLs?

  • BCH ARFCN

    The BCH ARFCN is returned for each GSM cell measured by the UE (up to 8 measured cells).

    GPIB command: CALL:MS:REPorted:GSMSystem:BCHannel?

  • Inter-RAT Cell ID

    Because the cells are reported in order of RSSI strength rather than by cell ID, the cell ID for each cell (numbered 1 to 8) is returned to help you quickly determine which neighbor cell is being reported by the UE.

    GPIB command: CALL:MS:REPorted:GSMSystem:CIDentity?

  • BSIC Verification

    A result of Verified indicates that the UE decoded the BSIC of the measured cell, and it matched the BSIC it expected based on the NCC and BCC values in the SIB11 GSM cell info list for that cell. Note, you may need to set GSM Meas BSIC Verification to verifiedBSIC and include a TGPS with a <num> TG Measurement Purpose (TGMP) of GSM Initial BSIC ID or GSM BSIC Reconfirmation in order for the UE to attempt to verify the BSIC of the GSM cells.

    GPIB command: CALL:MS:REPorted:GSMSystem:BSIC:VERification?

  • BSIC Value

    The BSIC Value result is not reported by the UE in the Measurement Reports. Rather, for your convenience, the test set calculates and posts the BSIC corresponding to the cell ID reported by the UE (the test set calculates the BSIC from the NCC and BCC values it signalled for that cell in the SIB11 GSM cell info list).

    As per 3GPP TS 25.331 s10.3.8.2 and 23.003 s4.3.2, BSIC (Base Station Identity Code) is a 6-bit concatenation of NCC (Network Colour Code) and BCC (Base Station Colour Code). For example, if NCC = 2 and BCC = 1, BSIC = 21. As NCC and BCC range between 0 and 7, the range of BSIC is thus 0-7, 10-17, 20-27, 30-37, 40-47, 50-57, 60-67 and 70-77.

    GPIB command: CALL:MS:REPorted:GSMSystem:BSIC:VALue?

  • RSSI (GSM Cells)

    The RSSI (Received Signal Strength Indicator) is returned for each GSM cell measured by the UE (up to 8 measured cells). See 3GPP TS 45.008 s8.1.4 for a mapping of returned value to actual value.

    GPIB command: CALL:MS:REPorted:GSMSystem:RSSI?

E-UTRA Measurement Results

  • UE Reported EARFCN for E-UTRA Cells 1 to 8

    This result indicates the EARFCN for the first 8 cells that are present in the measurement report.

    GPIB command: CALL:MS:REPorted:EUTRa:EARFcn?

  • UE Reported Cell ID for E-UTRA Cells 1 to 8

    This result indicates the Cell ID for the first 8 cells that are present in the measurement report.

    GPIB command: CALL:MS:REPorted:EUTRa:CID?

  • UE Reported RSRP for E-UTRA Cells 1 to 8

    This result indicates the RSRP for the first 8 cells that are present in the measurement report.

    GPIB command: CALL:MS:REPorted:EUTRa:RSRP?

  • UE Reported RSRQ for E-UTRA Cells 1 to 8

    This result indicates the RSRQ for the first 8 cells that are present in the measurement report.

    GPIB command: CALL:MS:REPorted:EUTRa:RSRQ?

  • Total Number of E-UTRA Cells Reported by the UE

    This result indicates the total number of E-UTRA cells that the UE included in its Measurement Result.

    GPIB command: CALL:MS:REPorted:EUTRa:CELLs?

Related Topics

Manual Operation: How Do I Order and Retrieve UE Reported Measurement Results?
and How Do I Enable Compressed Mode and Obtain UE Measurement Results?

GPIB Syntax: CALL:MS:REPorted

UE Reported Measurements Ladder Diagrams

Troubleshooting UE Reported Measurements

Establishing a Connection with the UE

Cell 2 Overview

Compressed Mode

SIB11 Cell Info List


UMA/GAN Procedures Ladder Diagrams

UMA/GAN Procedures Ladder Diagrams

Last updated: January 15, 2009

The following diagrams illustrate the procedures used by the test set and GANC for several key UMA/GAN operations.

  • UMA/GAN Discovery procedure
  • UMA/GAN Registration Procedure
  • UMA/GAN Mobile Originated Call Procedure
  • UMA/GAN Mobile Terminated Call
  • GERAN to GAN Handover Procedure
  • GAN to GERAN Handover Procedure

UMA/GAN Discovery procedure

UMA/GAN Registration Procedure

UMA/GAN Mobile Originated Call Procedure

UMA/GAN Mobile Terminated Call

GERAN to GAN Handover Procedure

GAN to GERAN Handover Procedure


UMTS Test USIM Card

UMTS Test USIM Card

Last updated: June 14, 2011

Introduction

The Agilent USIM has been configured to complement the operation of your 8960 test set when running any W-CDMA/HSDPA test or lab application. It can be ordered using part number E5515-10008 (contact your local Agilent sales representative or see www.agilent.com/find/contactus).

The USIM has several benefits:

  • UMTS security variables within the USIM match the default settings of the W-CDMA test and lab applications.
  • Setup time is reduced because the USIM is configured with the same default IMSI and PLMN values broadcast from the test set.
  • For dual-mode testing, GSM speech loopback is supported for GSM Bit Error Ratio (BER) measurements.

Installation

Refer to your UE's documentation for installing USIM cards.

Reference

The Agilent USIM supports operating voltages of 1.8, 3 and 5 volts (class AB).

The Agilent USIM is based on the Gemalto "GemXplore 3G V2.2", with some Agilent-specific settings. If desired, you can further modify the USIM's settings using the Gemalto "GemXplore Admin for 2G (with GemXplore 3G Option)" software, which you must purchase separately from Gemalto.

The USIM must be ordered using part number E5515-10008. The part number printed on your USIM simply indicates the revision of your USIM. Select the part number printed on your USIM to view its Agilent-specific settings:

  • USIM revision: E5515-10008
  • USIM revision: E5515-10007

USIM revision: E5515-10008

Agilent-Specific Settings within the USIM (revision E5515-10008)
Register | Description | Value
GPIN1 | Global PIN1 (code 1234, Unblock 11111111) | Disabled
LPIN1 | LOCAL PIN1 (code 5678, Unblock 22222222) | Enabled
0001 | Algorithm Identifier | 42 DUMMY (TS 34.108)
0001 | Applicative Key (Authentication Key) | 4147494C454E5420544543484E4F0000
6F07 | IMSI | 001012345678901
6F31 | HPLMN Search | Deactivated
6F38 | UST, Service #50 (RPLMN Last Used Technology) | Deactivated
6F46 | Service provider name | "Agilent TS34.108" and Required
6F60 | PLMNwAcT | 001 01 and UTRAN Available
6F61 | OPLMNwAcT | 001 01 and UTRAN Available
6F62 | HPLMNwAcT | 001 01 and UTRAN Available
6FAD | Administrative Mode | Type Approval with MNC length = 3
6FB7 | Emergency call codes | 112, 119, 911 and 999

USIM revision: E5515-10007

Agilent-Specific Settings within the USIM (revision E5515-10007)
Register | Description | Value
PIN 1 | Secret Code (1234) | Disabled
PUK 1 | Pin Unlock Code | 11111111
0001 | Algorithm Identifier | 42 DUMMY (TS 34.108)
0001 | Applicative Key (Authentication Key) | 4147494C454E5420544543484E4F0000
0010 | Local PIN1 | Deactivated and Disabled
6F07 | IMSI | 001012345678901
6F31 | HPLMN Search | Deactivated
6F46 | Service provider name | "Agilent USIM" and Required
6F60 | PLMNwAcT | 001 01 and UTRAN Available
6F61 | OPLMNwAcT | 001 01 and UTRAN Available
6F62 | HPLMNwAcT | 001 01 and UTRAN Available
6FAD | Administrative Mode | Type Approval with MNC length = 3
6FB7 | Emergency call codes | 112, 119, 911 and 999


Getting Started with the W-CDMA/HSPA Test and Lab Applications

Getting Started with the W-CDMA/HSPA Test and Lab Applications

Last updated: February 27, 2009

This online user's guide provides detailed information about your application's features and functionality, as well as how to use these features to test your wireless device.

The Contents menu on the left-hand side of this page provides access to all of the information contained within this online user's guide. The following is a description of these Contents topics. If you have trouble finding the information you need by navigating through the Contents topics, use the search field at the top of this page to search the contents of this guide.

  • Call Processing - Describes how to configure the test set's base station emulator and perform key call processing operations.
  • Measurements - Provides a list of which key conformance tests are supported by the test set. Describes the measurements and instruments available within your application.
  • Manual Operation - Describes how to configure the test set and perform call processing operations and measurements from the front panel.
  • Programming - Describes how to configure the test set and perform call processing operations and measurements by remote program.
  • GPIB Commands - Provides details on all of the GPIB commands available to control the test set by remote program.
  • Protocol Logging ( lab application only ) - Describes how to capture the exchange of data and control information between the test set and wireless device.
  • Data Channel ( lab application only ) - Describes how to use the test set as a router while you exchange data between your wireless device and remote servers.
  • Troubleshooting - Provides troubleshooting information for performing measurements and key call processing events. Includes a test set block diagram.
  • Configuration - Describes how to set amplitude offsets, switch between applications, and configure the test set (such as GPIB and LAN ports).
  • Fast Switching - Explains how to use fast switching test and lab applications.
  • Release Notes - Lists the features and functionality of the applications for each release of the firmware.
  • Downloadable Manuals - Provides a portable version of this online user's guide, which you may download to your computer.

For pricing and availability, brochures and datasheets for these applications, visit the 8960 product page:


ABORt

ABORt

Last updated: January 5, 2010

GPIB Command Conventions

  • ABORt[:ALL]
  • ABORt:<measurement mnemonic>

ABORt[:ALL]

Function

Stops all measurements that are active.

If the trigger arm is set to single, the measurements will go to the idle state.

If the trigger arm is set to continuous, the measurements will re-arm and initiate again.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"ABORt"
! Aborts all active measurements in progress.

ABORt:<measurement mnemonic>

Function

Stops the selected measurement if it is active.

If the trigger arm is set to single, the measurements will go to the idle state.

If the trigger arm is set to continuous the measurements will re-arm and initiate again.

  • AFANalyzer - Audio Frequency Analyzer measurements
  • CFDTune - Fast Device Tune measurement ( lab application or feature-licensed test application only )
  • EVMQpsk - QPSK EVM measurement ( lab application only )
  • FSTability - Frequency Stability measurement
  • HBLerror - HSDPA Block Error Ratio ( lab application or feature-licensed test application only )
  • HRCQuality - HSDPA Reporting of Channel Quality Indicator (lab application only)
  • SAUDio - Swept Audio measurement
  • SMONitor - Spectrum Monitor measurement
  • WACLeakage - Adjacent Channel Leakage
  • WBERror - Loopback Bit Error Ratio measurement
  • WBLerror - Loopback Block Error Ratio measurement
  • WCDomain - Code Domain measurements
  • WCPower - Channel Power measurement
  • WCTFormat - Change of TFC ( lab application only )
  • WDPAnalysis - Dynamic Power Analysis
  • WEDPower - Extended Range Dynamic Power
  • WILPower - Inner Loop Power measurement
  • WIQTuning - IQ Tuning measurement
  • WOBWidth - Occupied Bandwidth measurement
  • WOOPower - PRACH Transmit On/Off Power measurement
  • WOOSynch - Out-of-Synch Handling of Output Power
  • WPDiscon - Phase Discontinuity
  • WPESquality - Perceptual Evaluation of Speech Quality measurement
  • WPPAnalysis - PRACH Preamble Analysis ( lab application only )
  • WSEMask - Spectrum Emission Mask measurement
  • WTDPower - TX Dynamic Power measurement
  • WTPower - Thermal Power measurement
  • WWQuality - Waveform Quality measurement

Requirements

Test Application Revision A.01 and above.

Test Application Revision A.02 added WCDomain, WSEMask, and WOBWidth.

Test Application Revision A.03 added WIQTuning, WILPower, WOOPower, and SMONitor.

Test Application Revision A.05 added WBLerror, WDPAnalysis and WPDiscon.

Test Application Revision A.06 added FSTability

Test Application Revision A.07 added WTDPower

Test Application Revision A.08 with the required feature license, added HBLerror

Test Application Revision A.09 with the required feature license, added CFDTune

Lab Application Revision: A.01 and above

Lab Application Revision B.01 added WBLerror, WDPAnalysis, WPDiscon, and WPPAnalysis

Lab Application Revision C.01 added FSTability, WCTFormat and WOOSynch

Lab Application Revision C.02 added WTDPower

Lab Application Revision C.03 added HBLerror

Lab Application Revision C.04 and D.00.04 added CFDTune

Test Application Revision A.10 and Lab Application Revision D.01 and above, added WEDPower

Lab Application Revision E.00.16 and above added HRCQuality

Lab Application Revision F.00 added EVMQpsk

Lab Application Revision G.00 added WPESquality

Programming Example

OUTPUT 714;"ABORt:WWQuality"
! Aborts the waveform quality measurements.


ABORt Subsystem

ABORt Subsystem

Last updated: January 15, 2009

Description

The ABORt command causes a measurement cycle in progress to stop. If the measurement is not being continuously armed (trigger arm set to single) , the measurement will remain in the idle state after this event. If the measurement is being continuously armed (trigger arm set to continuous), a new measurement cycle will begin after ABORt. If an ABORt command is issued from any measurement state other than measuring, the command is ignored.

Other Commands that Execute an ABORt Action

INITiate:<meas> will execute an ABORt:<meas> as part of the INITiate:<meas> command.

READ:<meas>? will execute an ABORt:<meas> action that aborts just one trigger sequence and then combines the INITiate and FETCh? commands.

Syntax Diagram and Command Descriptions

ABORt


AFGenerator

AFGenerator

Last updated: January 15, 2009

GPIB Command Conventions

  • AFGenerator:COUPling

  • AFGenerator:FREQuency

  • AFGenerator:PULSe[:STATe]

  • AFGenerator:VOLTage[:SAMPlitude]
  • AFGenerator:VOLTage:AMPlitude
  • AFGenerator:VOLTage:STATe

AFGenerator:COUPling

Function

 Sets the output of the audio generator to be ac or dc coupled to the front-panel AUDIO OUT port.
Setting

Range: AC or DC
Query

Range: AC|DC
*RST setting DC

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:COUPling AC" !Sets the audio generator coupling to AC.

AFGenerator:FREQuency

Function

 Sets/queries the frequency of the audio generator. The units (HZ|KHZ|MHZ|GHZ) are optional. If no units are specified, then units default to HZ.
Setting

Range: 1 Hz to 20 kHz

Resolution: 0.1 HZ
Query

Range: 1 Hz to 20 kHz

Resolution: 0.1 Hz
*RST setting 1 kHz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:FREQUENCY 1000" !Sets the audio generator frequency to 1000 Hz.

AFGenerator:PULSe[:STATe]

Function

Sets/queries the audio generator pulse state.

The pulse state must be on when the test set's audio generator is used for audio stimulation during a decoded audio measurement.

When the state is on, the audio signal from the test set is pulsed at a 10 Hz rate with a 50% duty cycle.

Setting | Range: 0 | OFF | 1 |ON

Query

Range: 0|1
*RST setting | 0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:PULSE ON" !Sets the audio generator pulse to ON.

AFGenerator:VOLTage[:SAMPlitude]

Function

 Sets /queries the amplitude of the audio generator in volts and turns the state to on. The units (V|mV) are optional. If no units are specified, then units default to V.
Setting

Range: 0 to 9 V pk.

Resolution:

  • 0.5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
Query

Range: 0 to 9 V pk.

Resolution:

  • 0.5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
*RST setting 0 V

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:VOLTAGE 2.1" !Sets the state to on and the output
                                     !voltage to 2.1 volts.

AFGenerator:VOLTage:AMPlitude

Function

 Sets/queries the amplitude for the audio generator when the audio generator state is on. The units (V|mV) are optional. If no units are specified, then units default to V.
Setting

Range: 0 to 9 V pk.

Resolution:

  • 0.5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
Query

Range: 0 to 9 V pk.

Resolution:

  • 0.5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
*RST setting 0 V

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:VOLTAGE:AMPLITUDE 1.414" !Sets the audio generator output
                                                 !voltage to 1.414 volts peak.

AFGenerator:VOLTage:STATe

Function

 Sets/queries the audio generator state
Setting | 0 | OFF | 1 |ON

Query

0|1
*RST setting | 0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"AFGENERATOR:VOLTAGE:STATE ON" !Set the audio generator state to ON.


AFGenerator Subsystem

AFGenerator Subsystem

Last updated: January 15, 2009

Description

The AFGenerator subsystem is used to control an audio source that can be routed to the AUDIO OUT port on the test set's front panel (see also SYSTem:AUDio:OUTPut:SOURce ).

Syntax Diagram and Command Descriptions

AFGenerator


CALCulate Subsystem

CALCulate Subsystem

Last updated: January 15, 2009

Description

The CALCulate subsystem is used to perform data processing on the measurement results. For example in the Spectrum Monitor the CALCulate subsystem uses the markers to find the peaks and read back their values.

Syntax Diagram and Command Descriptions

CALCulate:SMONitor


CALCulate:SMONitor

CALCulate:SMONitor

Last updated: January 15, 2009

GPIB Command Conventions

  • CALCulate:SMONitor:MARKer:ALL:STATe
  • CALCulate:SMONitor:MARKer[<n>] :AMPLitude?
  • CALCulate:SMONitor:MARKer[<n>]:FREQuency
  • CALCulate:SMONitor:MARKer[<n>] :MODE
  • CALCulate:SMONitor:MARKer:PEAK:EXCursion[:LEVel]
  • CALCulate:SMONitor:MARKer[<n>] :PEAK:MAXimum
  • CALCulate:SMONitor:MARKer:PEAK:THReshold[:LEVel]
  • CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:POWer
  • CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:FREQuency
  • CALCulate:SMONitor:MARKer[<n>]:STATe
  • CALCulate:SMONitor:MARKer[<n>]:TIME

CALCulate:SMONitor:MARKer:ALL:STATe

Function

This command determines whether all markers are turned on or turned off.
Setting

Range: 1|ON|0|OFF

Query

Range: 1|ON|0|OFF
*RST Setting OFF

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:ALL:STATe 1"

!Turns on all markers.

CALCulate:SMONitor:MARKer[<n>] :AMPLitude?

Function

This query returns the amplitude for marker <n>, where <n> is a number 1 through 3. When no marker number is specified, marker 1 is used.

If you are using delta marker mode, the result is the delta marker amplitude result. (See CALCulate:SMONitor:MARKer[<n>] :MODE .)

Query

Range

  • Position Mode: -180 dBm to +37 dBm

  • Delta Mode: -200 dB to +200 dB

Resolution: 0.01 dB

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:AMPLitude?" !Returns the amplitude of marker 2.

CALCulate:SMONitor:MARKer[<n>]:FREQuency

Function

This command sets/queries the frequency of marker <n>. where <n> is a number 1 through 3. When no marker number is specified, marker 1 is used.

If you are using delta marker mode, this command sets/queries the offset frequency of the delta marker. (See CALCulate:SMONitor:MARKer[<n>] :MODE .)
Query

Range:

  • Position Mode

    Range: This is dependent on the settings of the center frequency and the frequency span. The markers frequency range is therefore equal to the center frequency +/- half the frequency span.

    Resolution: 0.001 MHz

  • Delta Mode:

    Range: The range is dependent on the center frequency, the frequency span and the position of the reference marker.

    Resolution: 0.001 MHz

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:FREQuency?"

!Queries the frequency of marker 1.

CALCulate:SMONitor:MARKer[<n>] :MODE

Function

This command sets the mode of the marker.

Position mode activates a single frequency marker at the center frequency.

Delta mode freezes the marker at its current location and uses it as a reference marker. A second marker is created at the position of the reference marker and is used a delta marker.

Setting

Range: POSition|DELTa|OFF

Query

Range: POS|DELT|OFF
*RST Setting Off

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:MODE DELT"

!Sets a reference marker and creates a delta marker.

CALCulate:SMONitor:MARKer:PEAK:EXCursion[:LEVel]

Function

This command sets the peak excursion level. A peak is identified by using the peak threshold and peak excursion value. A point is only marked as a peak if it rises and falls more than the peak excursion value from the peak threshold value. Setting this command to DEFault sets it to 6 dB.
Setting

Range: 1 to 100 dB | DEFault

Resolution: 0.1 dB

Query

Range: 1 to 100 dBResolution: 0.1 dB
*RST Setting

6 dB

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:PEAK:EXCursion 20DB"

!Sets the peak excursion level to 20 dB.

CALCulate:SMONitor:MARKer[<n>] :PEAK:MAXimum

Function

This command moves the specified marker <n> (1 to 3) to the highest peak value. If no marker <n> is specified, then marker 1 is moved.

An error message is returned if no peaks were found in the trace.

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:PEAK:MAXimum"

!Moves marker 2 to the highest peak value on the selected trace.

CALCulate:SMONitor:MARKer:PEAK:THReshold[:LEVel]

Function

This command sets peak threshold level. A peak is identified by using the peak threshold and peak excursion value. A point is only marked as a peak if it rises and falls more than the peak excursion value from the peak threshold value. Setting this command to DEFault sets it to -90 dBm.
Setting

Range: -120 to +37 dBm | DEFault

Resolution: 0.1

Query

Range: -120 to +37 dBmResolution: 0.1
*RST Setting

-90 dBm

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:PEAK:THReshold:LEVel 10DBM"

CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:POWer

Function

This command sets the base station emulator's expected power to the amplitude of the specified marker.

There are three markers <n> (1 to 3) that can be set. If no <n> is specified, marker 1 is used.

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:EXPected:POWer"

CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:FREQuency

Function

This command sets the base station emulator's expected frequency to the frequency of the specified marker.

There are three markers <n> (1 to 3) that can be set. If no <n> is specified, marker 1 is used.

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer3:EXPected:FREQuency"

CALCulate:SMONitor:MARKer[<n>]:STATe

Function

This command sets which markers are turned on.

There are three markers <n> (1 to 3) that can be set. If no <n> is specified, marker 1 is used.
Setting

Range: 1|ON|0|OFF

Query

Range: 1|ON|0|OFF
*RST Setting OFF

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:STATE 1" !Turns on marker 2.

CALCulate:SMONitor:MARKer[<n>]:TIME

Function

This command sets/queries the time at marker <n>. where <n> is a number 1 through 3. When no marker number is specified, marker 1 is used.

If you are using delta marker mode, this command sets/queries the delta offset time. (See CALCulate:SMONitor:MARKer[<n>] :MODE .)
Setting

Range: -50 ms to 10070 ms
Resolution: 0.25 us

Query

Range: -50 ms to 10070 ms
Resolution: 0.25 us
*RST Setting 5 ms

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:TIME 30" !Places marker 2 at 30 ms.


CALibration

CALibration

Last updated: March 4, 2009

GPIB Command Conventions

  • CALibration:BMOFfset?
  • CALibration:BMOFfset:INFormation?
  • CALibration:DAPower:INFormation?
  • CALibration:DATE
  • CALibration:IQ[1]?
  • CALibration:IQ1:INFormation?
  • CALibration:IQ2?
  • CALibration:IQ2:INFormation?
  • CALibration:MEASurements?
  • CALibration:SMONitor?
  • CALibration:SMONitor:INFormation?

CALibration:BMOFfset?

Function

Starts Burst Mod Offset 1 Calibration for RF source 1.

IMPORTANT
Ensure that your test set has warmed up at least 30 minutes and that no power is present at the front panel RF connectors before performing any calibrations.

When this calibration has completed, a value is returned to indicate the success or failure of the calibration. Zero indicates the calibration completed successfully.

Query

Range

  • 0 = Pass
  • -340 = Fail

Requirements

 Test Application Revision: A.06 and above
Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALibration:BMOFfset?"
! Initiates Burst Modulator Offset DAC calibration for RF source 1
! and returns a value (0 or -340) after completing the calibration.

CALibration:BMOFfset:INFormation?

Function

Queries the calibration information about Burst Modulation Offset 1.

The query returns 3 comma separated values: Data and Time, Temperature and Pass/Fail.

  • Date and Time indicates when the calibraiton is performed.
  • Temperature indicates the internal operating temperature when the calibration is performed.
  • Pass/Fail indicates whether the calibration is performed successfully.

Query

Range

  • Date and Time: "2000-01-01 00:00:00" to "2100-01-01 00:00:00"
  • Temperature: -60.0 to 100.0 (°C)
  • Pass/Fail: 1| 0

Requirements

 Test Application Revision: A.13 and above
Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALibration:BMOFfset:INFormation?"

CALibration:DAPower:INFormation?

Function

Queries the calibration information about Digital Average Power.

The query returns 3 comma separated values: Data and Time, Temperature and Pass/Fail.

  • Date and Time indicates when the calibraiton is performed.
  • Temperature indicates the internal operating temperature when the calibration is performed.
  • Pass/Fail indicates whether the calibration is performed successfully.

Query

Range

  • Date and Time: "2000-01-01 00:00:00" to "2100-01-01 00:00:00"
  • Temperature: -60.0 to 100.0 (°C)
  • Pass/Fail: 1| 0

Requirements

 Test Application Revision: A.13 and above
Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALibration:DAPower:INFormation?"

CALibration:DATE

Function

Sets/queries the date of the last system calibration done to the test set; not the user calibration date. Returns a comma separated list YYYY,MM,DD in that order.
Setting

Sets the system calibration date.

Range

  • Year = 0000 to 9999

  • Month = 01 to 12

  • Day = 01 to 31

Query

Returns the date when system calibration was performed.

Range

  • Year = 0000 to 9999

  • Month = 1 to 12

  • Day = 1 to 31

Programming Example

OUTPUT 714;"CALibration:DATE 1999,01,04"
! Sets the date of the last system calibration year, month and day.

CALibration:IQ[1]?

Function

Starts the calibration of the IQ modulator for RF generator 1. See IQ Calibrations .

IMPORTANT
Ensure that your test set has warmed up at least 30 minutes and that no power is present at the front panel RF connectors before performing any calibrations.

When this calibration has completed, a value is returned to indicate the success or failure of the calibration. Zero indicates the calibration completed successfully.

Query

Range:

  • 0 = Pass
  • -340 = Fail

Programming Example

OUTPUT 714;"CALibration:IQ1?"
! Performs a calibration of the IQ modulator for RF generator 1 and returns 0 or -340

CALibration:IQ1:INFormation?

Function

Queries the calibration information of the IQ modulator for RF generator 1. The command has a parameter string that indicates the name of the TA Partition. The parameter string is selected from "GSM/GPRS", "AMPS/136", "WCDMA", "IS-856" or "IS-2000/IS-95/AMPS".

The query returns 3 comma separated values: Data and Time, Temperature and Pass/Fail.

  • Date and Time indicates when the calibraiton is performed.
  • Temperature indicates the internal operating temperature when the calibration is performed.
  • Pass/Fail indicates whether the calibration is performed successfully.

Query

Range

  • Date and Time: "2000-01-01 00:00:00" to "2100-01-01 00:00:00"
  • Temperature: -60.0 to 100.0 (°C)
  • Pass/Fail: 1| 0

Requirements

 Test Application Revision: A.13 and above
Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALibration:IQ1:INFormation? 'WCDMA'"

CALibration:IQ2?

Function

Starts the calibration of the IQ modulator for RF generator 2. See IQ Calibrations .

IMPORTANT
Ensure that your test set has warmed up at least 30 minutes and that no power is present at the front panel RF connectors before performing any calibrations.

When this calibration has completed, a value is returned to indicate the success or failure of the calibration. Zero indicates the calibration completed successfully.

Query

Range:

  • 0 = Pass
  • -340 = Fail

Programming Example

OUTPUT 714;"CALibration:IQ2?"
! Performs a calibration of the IQ modulator for RF generator 2 and returns 0 or -340

CALibration:IQ2:INFormation?

Function

Queries the calibration information of the IQ modulator for RF generator 2. The command has a parameter string that indicates the name of the TA Partition. The parameter string is selected from "GSM/GPRS", "AMPS/136", "WCDMA", "IS-856" or "IS-2000/IS-95/AMPS".

The query returns 3 comma separated values: Data and Time, Temperature and Pass/Fail.

  • Date and Time indicates when the calibraiton is performed.
  • Temperature indicates the internal operating temperature when the calibration is performed.
  • Pass/Fail indicates whether the calibration is performed successfully.

Query

Range

  • Date and Time: "2000-01-01 00:00:00" to "2100-01-01 00:00:00"
  • Temperature: -60.0 to 100.0 (°C)
  • Pass/Fail: 1| 0

Requirements

 Test Application Revision: A.13 and above
Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALibration:IQ2:INFormation? 'WCDMA'"

CALibration:MEASurements?

Function

Starts the Calibrate Measurements routine.

IMPORTANT
Ensure that your test set has warmed up at least 30 minutes and that no power is present at the front panel RF connectors before performing any calibrations.

When this calibration has completed, a value is returned to indicate the success or failure of the calibration. Zero indicates the calibration completed successfully.

Query

Range:

  • 0: Measurement calibration completed successfully.
  • 1: Measurement calibration failed due to temperature drift. Wait for temperature to stabilize.
  • 2: Measurement calibration failed due to oven out of range.
  • 3: Measurement calibration failed due to loopback switch problem.
  • 4: Measurement calibration failed due to under range condition.
  • 5: Measurement calibration failed due to over range condition.
  • 6: Measurement calibration failed due to correlation problem.
  • -340: Measurement calibration failed. This is a SCPI defined value indicating an unexpected case.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALIBRATION:MEASUREMENTS?"
! Starts the measurement calibration and returns a value indicating success or failure..

CALibration:SMONitor?

Function

Starts the Spectrum Monitor Calibration routine.

IMPORTANT
Ensure that your test set has warmed up at least 30 minutes and that no power is present at the front panel RF connectors before performing any calibrations.

When this calibration has completed, a value is returned to indicate the success or failure of the calibration. Zero indicates the calibration completed successfully.

Query

Range:

  • 0 (Spectrum Monitor calibration completed successfully)
  • 1 (Spectrum Monitor calibration failed due to temperature drift. Wait for temperature to stabilize)
  • 2 (Spectrum Monitor calibration failed due to oven out of range)
  • 3 (Spectrum Monitor calibration failed due to loopback switch problem)
  • 4 (Spectrum Monitor calibration failed due to under range condition)
  • 5 (Spectrum Monitor calibration failed due to over range condition)
  • 6 (Spectrum Monitor calibration failed due to correlation problem)
  • 7 (Spectrum Monitor calibration failed due to source level problem)
  • 8 (Spectrum Monitor calibration failed due to IF filter coefficient problem)
  • 9 (Spectrum Monitor calibration failed due to IF frequency response problem)
  • 10 (Spectrum Monitor calibration failed due to waveform quality problem)
  • -340 (Spectrum Monitor calibration failed)

Programming Example

OUTPUT 714;"CALibration:SMONitor?"
! Starts the spectrum monitor calibration and returns a value indicating success or failure.

CALibration:SMONitor:INFormation?

Function

Queries the calibration information about Spectrum Monitor. The command has a parameter string that indicates the name of the TA Partition. The parameter string is selected from "GSM/GPRS", "AMPS/136", "WCDMA", "IS-856" or "IS-2000/IS-95/AMPS".

The query returns 3 comma separated values: Data and Time, Temperature and Pass/Fail.

  • Date and Time indicates when the calibraiton is performed.
  • Temperature indicates the internal operating temperature when the calibration is performed.
  • Pass/Fail indicates whether the calibration is performed successfully.

Query

Range

  • Date and Time: "2000-01-01 00:00:00" to "2100-01-01 00:00:00"
  • Temperature: -60.0 to 100.0 (°C)
  • Pass/Fail: 1| 0

Requirements

 Test Application Revision: A.13 and above
Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALibration:SMONitor:INFormation? 'WCDMA'"


CALibration Subsystem

CALibration Subsystem

Last updated: January 15, 2009

Calibration Strategy

Various calibration routines must be run to ensure measurement accuracy. The type of calibration and appropriate intervals for performing calibrations vary with each application. See Calibrating the Test Set for more information.

Syntax Diagram and Command Descriptions

CALibration


CALL:ACCess

CALL:ACCess

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL:ACCess:STRatum?

CALL:ACCess:STRatum?

Function

Queries the current access stratum in use by a connected mobile station.

  • NONE: Report not available
  • UTR: Last access stratum used was UTRAN
  • GAN: Last access stratum used was GAN

Query

Range: NONE|UTR|GAN

*RST Setting

 NONE

Requirements

Lab Application Revision: E.00.16 and above with the E6962A A.00.05

Programming Example

OUTPUT 714;"CALL:ACCess:STRatum?"


CALL:AICHannel

CALL:AICHannel

Last updated: March 16, 2009

GPIB Command Conventions

  • CALL:AICHannel[:SLEVel]
  • CALL:AICHannel:CCODe
  • CALL:AICHannel:CCODe:CODE
  • CALL:AICHannel:LEVel
  • CALL:AICHannel:STATe
  • CALL:AICHannel:TRANsmission:TIMing

CALL:AICHannel[:SLEVel]

Function

Sets/queries the acquisition indicator channel's initial power offset. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -9.9 dB

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:AICHannel -13DB" !Sets the acquisition indicator channel's power offset to -13 dB.

CALL:AICHannel:CCODe

Function

THIS COMMAND IS OBSOLETE. Please use CALL:AICHannel:CCODe:CODE .

Sets/queries the acquisition indicator channel's channelization code.

Setting

Range: CODE3|CODE6|CODE7|CODE8|CODE9|CODE10|CODE11

Query

Range: CODE3|CODE6|CODE7|CODE8|CODE9|CODE10|CODE11

*RST Setting

 CODE10

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:AICHannel:CCODe CODE6"

CALL:AICHannel:CCODe:CODE

Function

Sets/queries the acquisition indicator channel's channelization code. Codes 0 and 1 are reserved for the CPICH and SCH/PCCPCH respectively.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected While in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 2 to 255

Resolution: 1

Query

Range: 2 to 255

Resolution: 1

*RST Setting

 10

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:AICHannel:CCODe:CODE 10"

CALL:AICHannel:LEVel

Function

Sets/queries the acquisition indicator channel's initial power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -9.9 dB

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:AICHannel:LEVel -5"

CALL:AICHannel:STATe

Function

Sets/queries the acquisition indicator channel's state.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:AICHannel:STATe ON"

CALL:AICHannel:TRANsmission:TIMing

Function

Sets/queries AICH Transmission Timing .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 0|1

Query

Range: 0|1

*RST Setting

 0

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:AICHannel:TRANsmission:TIMing 0"


CALL:AREStriction

CALL:AREStriction

Last updated: January 15, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL[:CELL]:AREStriction:BARRed:STATe
  • CALL[:CELL]:AREStriction:BARRed:TIMer
  • CALL[:CELL]:AREStriction:ITAFrequency:CRINdicator

CALL[:CELL]:AREStriction:BARRed:STATe

Function

Sets/queries Cell Barred State .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (Off)

Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:AREStriction:BARRed:STATe 1"
! Sets Barred State to On.

CALL[:CELL]:AREStriction:BARRed:TIMer

Function

Sets/queries the Cell Barred Timer (Tbarred) .

This setting is only applicable when CALL[:CELL]:AREStriction:BARRed:STATe is set to On .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 10 s, 20 s, 40 s, 80 s, 160 s, 320 s, 640 s, 1280 s

Query

 Same as setting

*RST Setting

 40 s

Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:AREStriction:BARRed:TIMer 20s"
! Sets Barred Timer to 20 s.

CALL[:CELL]:AREStriction:ITAFrequency:CRINdicator

Function

Sets/queries the Intra-frequency Cell Reselection Indicator .

This setting is only applicable when CALL[:CELL]:AREStriction:BARRed:STATe is set to On .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: ALLowed|NALLowed

Query

Range: ALL|NALL

*RST Setting

 ALL

Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:AREStriction:ITAFrequency:CRINdicator NALLowed"
! Sets the Intra-frequency Cell Reselection Indicator to Not Allowed.


CALL:ATTFlag

CALL:ATTFlag

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL[:CELL]:ATTFlag[:STATe]

CALL[:CELL]:ATTFlag[:STATe]

Function

Sets/queries the ATT (IMSI Attach) Flag State .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

 Range: 1|ON|0|OFF

Query

Range: 0|1

*RST Setting

 0 (OFF)
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:ATTFlag ON" !Set the IMSI Attach flag state to on.


CALL:AWGNoise

CALL:AWGNoise

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL:AWGNoise[:INTernal]:POWer[:SAMPlitude][:SELected]
  • CALL:AWGNoise[:INTernal]:POWer:AMPLitude[:SELected]
  • CALL:AWGNoise[:INTernal]:POWer:STATe[:SELected]

CALL:AWGNoise[:INTernal]:POWer[:SAMPlitude][:SELected]

Function

The setting form of this command performs two functions: (1) sets the additive white gaussian noise (AWGN) level and (2) turns the AWGN on/off state to on. The query form returns the desired AWGN power level. (See Cell Power and AWGN Power for more information about desired versus current power levels.)

Setting

Range: -165 dBm/3.84 MHz to +35 dBm/3.84 MHz (this is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source).

Resolution: 0.01 dB

Query

Same as setting

*RST Setting

 See CALL:AWGNoise[:INTernal]:POWer:AMPLitude[:SELected] and CALL:AWGNoise[:INTernal]:POWer:STATe[:SELected] .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:AWGNoise:POWer -80"
! Sets the AWGN power level to -80 dBM/3.84 MHz and turns the state on.

CALL:AWGNoise[:INTernal]:POWer:AMPLitude[:SELected]

Function

Sets/queries the desired additive white gaussian noise (AWGN) level. (See Cell Power and AWGN Power for more information about desired versus current power levels.)

Setting

Range: -165 dBm/3.84 MHz to +35 dBm/3.84 MHz, NAN (this is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source).

Resolution: 0.01 dB

Query

Same as setting

*RST Setting

 -75 dBm/3.84 MHz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:AWGNoise:POWer:AMPLitude -80"
! Set the AWGN level to -80 dBM/3.84 MHz.

CALL:AWGNoise[:INTernal]:POWer:STATe[:SELected]

Function

Sets/queries the additive white gaussian noise (AWGN) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (OFF)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:AWGNoise:POWer:STATe ON"
!Turns on AWGN.


CALL:BARBitrator

CALL:BARBitrator

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL[:CELL]:BARBitrator

CALL[:CELL]:BARBitrator

Function

Sets/queries the Band Arbitrator .

This setting is only applicable when DL Channel is set to a channel in Band VI.

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: BAND5|BAND6

Query

 Same as setting

*RST Setting

BAND6
Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:BARBitrator BAND5"


CALL:BCCHannel

CALL:BCCHannel

Last updated: May 3, 2011

GPIB Command Conventions

  • CALL[:CELL]:BCCHannel:CELLlist

  • CALL[:CELL]:BCCHannel:FBINdicator:STATe

  • CALL[:CELL]:BCCHannel:FMOCcasion:CLCoeff
  • CALL[:CELL]:BCCHannel:FMOCcasion:CLCoeff:CONTrol
  • CALL[:CELL]:BCCHannel:FMOCcasion:CONTrol
  • CALL[:CELL]:BCCHannel:FMOCcasion:FDDIndicator
  • CALL[:CELL]:BCCHannel:FMOCcasion:RATIndicator:CONTrol

  • CALL[:CELL]:BCCHannel:GSMSystem:BAND
  • CALL[:CELL]:BCCHannel:GSMSystem:BCC
  • CALL[:CELL]:BCCHannel:GSMSystem:BCHannel
  • CALL[:CELL]:BCCHannel:GSMSystem:NCC
  • CALL[:CELL]:BCCHannel:GSMSystem:CRESelection:RLMinimum
  • CALL[:CELL]:BCCHannel:GSMSystem:STATe

  • CALL[:CELL]:BCCHannel:INTERFREQ:DOWNlink:CHANnel
  • CALL[:CELL]:BCCHannel:INTERFREQ:SCODe
  • CALL[:CELL]:BCCHannel:INTRAFREQ:CELL2:SCODe
  • CALL[:CELL]:BCCHannel:INTRAFREQ:CELL3:SCODe

  • CALL[:CELL]:BCCHannel:ITAFrequency:CRESelection:OFFSet[1]
  • CALL[:CELL]:BCCHannel:ITAFrequency:CRESelection:OFFSet2
  • CALL[:CELL]:BCCHannel:ITAFrequency:SCODe
  • CALL[:CELL]:BCCHannel:ITAFrequency:STATe
  • CALL[:CELL]:BCCHannel:ITRFrequency:CRESelection:OFFSet[1]
  • CALL[:CELL]:BCCHannel:ITRFrequency:CRESelection:OFFSet2
  • CALL[:CELL]:BCCHannel:ITRFrequency:DOWNlink:CHANnel
  • CALL[:CELL]:BCCHannel:ITRFrequency:SCODe
  • CALL[:CELL]:BCCHannel:ITRFrequency:STATe

  • CALL[:CELL]:BCCHannel:N300
  • CALL[:CELL]:BCCHannel:N312[:IDLE]
  • CALL[:CELL]:BCCHannel:N313
  • CALL[:CELL]:BCCHannel:N315

  • CALL[:CELL]:BCCHannel:SERSearch[:SVALue]
  • CALL[:CELL]:BCCHannel:SERSearch:STATe
  • CALL[:CELL]:BCCHannel:SERSearch:VALue

  • CALL[:CELL]:BCCHannel:SIB5:BIS

  • CALL[:CELL]:BCCHannel:SIB15:GPSystem:TIME:OFFset:TTOWeek
  • CALL[:CELL]:BCCHannel:SIB15:GPSystem:TIME:OFFSet:TOWeek:MSECond
  • CALL[:CELL]:BCCHannel:SIB15:GPSystem:TIME:OFFSet:UTRan
  • CALL[:CELL]:BCCHannel:SIB15:GPSystem:TIME:REFerence:UPDate[:STATe]
  • CALL[:CELL]:BCCHannel:SIB15:GPSystem:TIME:REFerence:SFN
  • CALL[:CELL]:BCCHannel:SIB15:MESSage:S15
  • CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point1
  • CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point2:MESSage1
  • CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point2:MESSage2
  • CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point3:MESSage1
  • CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point3:MESSage2
  • CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point4
  • CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point5
  • CALL[:CELL]:BCCHannel:SIB15:TRANsmit[:STATe]

  • CALL[:CELL]:BCCHannel:SIB19[:INFormation]
  • CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8[:STATe]
  • CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:DETection
  • CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:EARFcn
  • CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:MBWidth
  • CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:PRIority
  • CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:RLMinimum
  • CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:THReshold:HIGH
  • CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:THReshold:LOW
  • CALL[:CELL]:BCCHannel:SIB19:UTRA:SCEL1:PRIority
  • CALL[:CELL]:BCCHannel:SIB19:UTRA:SCEL1:SPSearch1
  • CALL[:CELL]:BCCHannel:SIB19:UTRA:SCEL1:SPSearch2[:SVALue]
  • CALL[:CELL]:BCCHannel:SIB19:UTRA:SCEL1:THReshold:LOW

  • CALL[:CELL]:BCCHannel:SRASearch[:SVALue]
  • CALL[:CELL]:BCCHannel:SRASearch:STATe
  • CALL[:CELL]:BCCHannel:SRASearch:VALue

  • CALL[:CELL]:BCCHannel:T300
  • CALL[:CELL]:BCCHannel:T305
  • CALL[:CELL]:BCCHannel:T308
  • CALL[:CELL]:BCCHannel:T309
  • CALL[:CELL]:BCCHannel:T312[:IDLE]
  • CALL[:CELL]:BCCHannel:T313
  • CALL[:CELL]:BCCHannel:T3212
  • CALL[:CELL]:BCCHannel:T3312[:VALue]
  • CALL[:CELL]:BCCHannel:T3312:UNITs

  • CALL[:CELL]:BCCHannel:UPDAtepage

CALL[:CELL]:BCCHannel:CELLlist

Function

Sets/queries the Cell Info List setting.

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: PRESent|ABSent

Query

Range: PRES|ABS

*RST Setting

 PRES
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:CELLlist PRESent"
! Selects BCCH Cell Info List to preset on the BCCH.

CALL[:CELL]:BCCHannel:FBINdicator:STATe

Function

Sets/queries the Frequency Band Indicator State setting.

This setting cannot be changed in active cell operating mode.

Setting

Range: 1|ON|0|OFF

Query

 1|0

*RST Setting

 1 (on)
Requirements

Test Application Revision: A.08 and above.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:BCCHannel:FBINdicator:STATe OFF"
! Turns Frequency Band Indicator State off.

CALL[:CELL]:BCCHannel:FMOCcasion:CLCoeff

Function

Sets/queries the BCCH SIB11 FACH measurement occasion cycle length coefficient.

This setting is used to calculate the measurement occasion cycle length.

Setting

Range: 1 to 12

Resolution: 1

Query

Range: same as setting

*RST Setting

 3

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:FMOCcasion:CLCoeff 3"
! Sets the BCCH SIB11 FACH measurement occasion cycle length coefficient to 3.

CALL[:CELL]:BCCHannel:FMOCcasion:CLCoeff:CONTrol

Function

Sets/queries the BCCH SIB11 FACH measurement occasion cycle length coefficient control setting.

This setting determines whether the "FACH measurement occasion cycle length coefficient" parameter should be present in "FACH measurement occasion info".

Setting

Range: PRESent|ABSent

Query

Range: PRES|ABS

*RST Setting

 PRESent
Requirements Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:FMOCcasion:CLCoeff:CONTrol PRESent"!

CALL[:CELL]:BCCHannel:FMOCcasion:CONTrol

Function

Sets/queries the BCCH SIB11 FACH measurement occasion info Present setting.

This setting determines whether the SIB11 includes the IE of "FACH measurement occasion info".

Setting

Range: PRESent|ABSent

Query

Range: PRES|ABS

*RST Setting

 ABSent
Requirements Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:FMOCcasion:CONTrol ABSent"

CALL[:CELL]:BCCHannel:FMOCcasion:FDDIndicator

Function

Sets/queries the BCCH SIB 11 Inter-frequency FDD measurement indicator:

  • When set to 1, the UE performs measurements and evaluate cell reselection criteria on inter-frequency FDD cells listed in SIB11 in CELL_FACH state.
  • When set to 0, the UE should neither perform measurements nor evaluate cell re-selection criteria on inter-frequency FDD cells in CELL_FACH state.

Setting

Range: 1|0

Query

 1|0

*RST Setting

 1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:FMOCcasion:FDDIndicator 1"

CALL[:CELL]:BCCHannel:FMOCcasion:RATIndicator:CONTrol

Function

Sets/queries the BCCH SIB 11 Inter-RAT measurement indicators control setting.

This setting determines whether "Inter-RAT measurement indicators" and the associated "RAT type" should be present in "FACH measurement occasion info". Currently, the "Inter-RAT measurement indicators" is fixed at 1 and the "RAT type" is fixed to GSM. If this setting is set to Present, the UE performs measurements and evaluates cell reselection criteria on GSM cells that are listed in SIB11 in CELL_FACH state.

Setting

Range: PRESent|ABSent

Query

Range: PRES|ABS

*RST Setting

 PRESent
Requirements Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:FMOCcasion:RATIndicator:CONTrol PRESent"
! Sets the BCCH SIB 11 Inter-RAT measurement indicators control setting to Present.

CALL[:CELL]:BCCHannel:GSMSystem:BAND

Function

Sets/queries the band for each of the 8 GSM neighbor cells (see GSM Cells ).

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: DCS1800|PCS1900,DCS1800|PCS1900,DCS1800|PCS1900,
DCS1800|PCS1900,DCS1800|PCS1900,DCS1800|PCS1900,
DCS1800|PCS1900,DCS1800|PCS1900

The command must be issued with a comma-separated list of 8 values. Each value in the list defines the band for the corresponding neighbor cell (cell 1 through cell 8). Whether each cell is actually present in the cell list transmitted by the test set is controlled by the CALL[:CELL]:BCCHannel:GSMSystem:STATe setting.

Query

Range: same as setting

*RST Setting

 DCS1800,DCS1800,DCS1800,DCS1800,DCS1800,DCS1800,DCS1800,DCS1800,

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:GSMSystem:BAND PCS1900,PCS1900,PCS1900,PCS1900,PCS1900,
PCS1900,PCS1900,PCS1900"
! Sets the band for each of the 8 GSM neighbor cells to PCS1900.

CALL[:CELL]:BCCHannel:GSMSystem:BCC

Function

Sets/queries the BCC for each of the 8 GSM neighbor cells (see GSM Cells ).

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: 0 to 7

Resolution: 1

The command must be issued with a comma-separated list of 8 values. Each value in the list defines the BCC for the corresponding neighbor cell (cell 1 through cell 8). Whether each cell is actually present in the cell list transmitted by the test set is controlled by the CALL[:CELL]:BCCHannel:GSMSystem:STATe setting.

Query

Range: same as setting

*RST Setting

 5,0,1,2,3,4,6,7

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:GSMSystem:BCC 4,1,3,6,0,7,2,5"
! Sets the BCC for the first GSM neighbor cell to 4,
! sets the BCC for the second GSm neighbor cell to 1, etc.

CALL[:CELL]:BCCHannel:GSMSystem:BCHannel

Function

Sets/queries the BCH ARFCN for each of the 8 GSM neighbor cells (see GSM Cells ).

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: 0 to 1023

Resolution: 1

The command must be issued with a comma-separated list of 8 values. Each value in the list defines the BCH ARFCN for the corresponding neighbor cell (cell 1 through cell 8). Whether each cell is actually present in the cell list transmitted by the test set is controlled by the CALL[:CELL]:BCCHannel:GSMSystem:STATe setting.

Query

Range: same as setting

*RST Setting

 20,30,40,50,60,70,80,90

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:GSMSystem:BCHannel 22,32,42,52,62,72,82,92"
! Sets the BCH ARFCN for the first GSM neighbor cell to 22,
! sets the BCC for the second GSm neighbor cell to 32, etc.

CALL[:CELL]:BCCHannel:GSMSystem:NCC

Function

Sets/queries the NCC for each of the 8 GSM neighbor cells (see GSM Cells ).

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: 0 to 7

Resolution: 1

The command must be issued with a comma-separated list of 8 values. Each value in the list defines the NCC for the corresponding neighbor cell (cell 1 through cell 8). Whether each cell is actually present in the cell list transmitted by the test set is controlled by the CALL[:CELL]:BCCHannel:GSMSystem:STATe setting.

Query

Range: same as setting

*RST Setting

 1, 0, 2, 3, 4, 5, 6, 7

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:GSMSystem:NCC 7,1,6,3,0,4,5,2"
! Sets the NCC for the first GSM neighbor cell to 7,
! sets the NCC for the second GSm neighbor cell to 1, etc.

CALL[:CELL]:BCCHannel:GSMSystem:CRESelection:RLMinimum

Function

Sets/queries GSM <num> Cell Cell Reselection Min Rx Level for each of the 8 GSM neighbor cells.

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: -115 to -25 dBm

Resolution: 1 dB

The command must be issued with a comma-separated list of 8 values. Each value in the list defines the Cell Reselection Min Rx Level for the corresponding neighbor cell (cell 1 through cell 8). Whether each cell is actually present in the cell list transmitted by the test set is controlled by the CALL[:CELL]:BCCHannel:GSMSystem:STATe setting.

Query

Range: same as setting

*RST Setting

 -104,-104,-104,-104,-104,-104,-104,-104 (dBm)

Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:GSMSystem:CRESelection:RLMinimum
-100,-100,-100,-100,-100,-100,-100,-100"
! Sets Cell Reselection Min Rx Level for the first GSM neighbor cell to -100 dBm,
! sets Cell Reselection Min Rx Level for the second GSM neighbor cell to -100 dBm, etc.

CALL[:CELL]:BCCHannel:GSMSystem:STATe

Function

Sets/queries whether each of the 8 GSM neighbor cells is included in the cell info list transmitted by the test set (see GSM Cells ).

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: 1|ON|0|OFF

The command must be issued with a comma-separated list of 8 valid settings.

Query

Range: 1|0

*RST Setting

 1,0,0,0,0,0,0,0

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:GSMSystem:STATe 1,1,1,1,1,1,1,1"
! Includes all 8 GSM neighbor cells in the cell info list.

CALL[:CELL]:BCCHannel:INTERFREQ:DOWNlink:CHANnel

Function

THIS COMMAND IS OBSOLETE. Please use the CALL[:CELL]:BCCHannel:ITRFrequency:DOWNlink:CHANnel command.

Sets/queries the downlink channel number (DL UARFCN) of the Inter-frequency cell info list which is included in the System Information Block (SIB) 11 on the BCCH. The Inter-frequency cell info list contains only one cell.

This setting is available only when the BCCH SIB 11 Cell Info List is set to "Present" (see CALL[:CELL]:BCCHannel:CELLlist ).

If this setting is changed while the Operating Mode is "Active Cell.", the test set will perform the BCCH Update procedure.

Setting

Range:

  • 412 - 687
  • 4320 - 4495
  • 4600 - 4825
  • 9000 - 9425
  • 9625 - 9975
  • 10,525 - 10,875

Query

Range: Same as settings

*RST Setting

10730
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:INTERFREQ:DOWNlink:CHANnel 10735"
! Sets the BCCH Inter-frequency Cell DL UARFCN to 10735.

CALL[:CELL]:BCCHannel:INTERFREQ:SCODe

Function

THIS COMMAND IS OBSOLETE. Please use the CALL[:CELL]:BCCHannel:ITRFrequency:SCODe command.

Sets/queries the primary scrambling code of the Inter-frequency cell info list which is included in the System Information Block (SIB) 11 on the BCCH. The Inter-frequency cell info list contains only one cell.

This setting is available only when the BCCH SIB 11 Cell Info List is set to "Present" (see CALL[:CELL]:BCCHannel:CELLlist ).

If this setting is changed while the Operating Mode is "Active Cell.", the test set will perform the BCCH Update procedure.

Setting

Range: 0 to 511

Resolution: 1

Query

Range: same as settings

*RST Setting

63

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:INTERFREQ:SCODe 63"
! Sets the BCCH Inter-frequency Cell Scrambling Code to 63.

CALL[:CELL]:BCCHannel:INTRAFREQ:CELL2:SCODe

Function

THIS COMMAND IS OBSOLETE. Please use the CALL[:CELL]:BCCHannel:ITAFrequency:SCODe command.

Sets/queries the primary scrambling code of the 2nd cell in the Intra-frequency cell info list which is included in the System Information Block (SIB) 11 on the BCCH. This setting is available only when the BCCH SIB 11 Cell Info List is set to "Present" (see CALL[:CELL]:BCCHannel:CELLlist ).

The Intra-frequency cell info list contains three cells. As required by the W-CDMA specifications, Cell 1 in this list is always the serving cell so the cell information is automatically set to match the test set's cell.

If this setting is changed while the Operating Mode is "Active Cell.", the test set will perform the BCCH Update procedure.

Setting

Range: 0 to511

Resolution: 1

Query

Range: same as settings

*RST Setting

127

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:INTRAFREQ:CELL2:SCODe 130"
! Sets the BCCH Intra-frequency Cell 2 Scrambling Code to 130.

CALL[:CELL]:BCCHannel:INTRAFREQ:CELL3:SCODe

Function

THIS COMMAND IS OBSOLETE. Please use the CALL[:CELL]:BCCHannel:ITAFrequency:SCODe command.

Sets/queries the primary scrambling code of the 3rd cell in the Intra-frequency cell info list which is included in the System Information Block (SIB) 11 on the BCCH. This setting is available only when the BCCH SIB 11 Cell Info List is set to "Present" (see CALL[:CELL]:BCCHannel:CELLlist ).

The Intra-frequency cell info list contains three cells. As required by the W-CDMA specifications, Cell 1 in this list is always the serving cell so the cell information is automatically set to match the test set's cell.

If this setting is changed while the Operating Mode is "Active Cell.", the test set will perform the BCCH Update procedure.

Setting

Range: 0 - 511

Resolution: 1

Query

Range: same as settings

*RST Setting

511

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:INTRAFREQ:CELL3:SCODe 500"
! Sets the BCCH Intra-frequency Cell 3 Scrambling Code to 500.

CALL[:CELL]:BCCHannel:ITAFrequency:CRESelection:OFFSet[1]

Function

Sets/queries Intra-freq <num> Cell Cell Reselection Offset1 for each of the 8 intra-frequency neighbor cells.

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: -50 to 50 dB

Resolution: 1 dB

The command must be issued with a comma-separated list of 8 values. Each value in the list defines the Cell Reselection Offset1 for the corresponding neighbor cell (cell 1 through cell 8). Whether each cell is actually present in the cell list transmitted by the test set is controlled by the CALL[:CELL]:BCCHannel:ITAFrequency:STATe setting.

Query

Range: same as setting

*RST Setting

 0,0,0,0,0,0,0,0 (dB)

Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:ITAFrequency:CRESelection:OFFSet -20,-20,-20,-20,-20,-20,-20,-20"
! Sets Cell Reselection Offset1 for the first intra-frequency neighbor cell to -20 dB,
! sets Cell Reselection Offset1 for the second intra-frequency neighbor cell to -20 dB, etc.

CALL[:CELL]:BCCHannel:ITAFrequency:CRESelection:OFFSet2

Function

Sets/queries Intra-freq <num> Cell Cell Reselection Offset2 for each of the 8 intra-frequency neighbor cells.

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: -50 to 50 dB

Resolution: 1 dB

The command must be issued with a comma-separated list of 8 values. Each value in the list defines the Cell Reselection Offset2 for the corresponding neighbor cell (cell 1 through cell 8). Whether each cell is actually present in the cell list transmitted by the test set is controlled by the CALL[:CELL]:BCCHannel:ITAFrequency:STATe setting.

Query

Range: same as setting

*RST Setting

 0,0,0,0,0,0,0,0 (dB)

Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:ITAFrequency:CRESelection:OFFSet2 -20,-20,-20,-20,-20,-20,-20,-20"
! Sets Cell Reselection Offset2 for the first intra-frequency neighbor cell to -20 dB,
! sets Cell Reselection Offset2 for the second intra-frequency neighbor cell to -20 dB, etc.

CALL[:CELL]:BCCHannel:ITAFrequency:SCODe

Function

Sets/queries the primary scrambling code for each of the 8 intra frequency neighbor cells (see Intra-frequency Cells ).

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: 0 to 511

Resolution: 1

The command must be issued with a comma-separated list of 8 values. Each value in the list defines the primary scrambling code for the corresponding neighbor cell (cell 1 through cell 8). Whether each cell is actually present in the cell info list transmitted by the test set is controlled by the CALL[:CELL]:BCCHannel:ITAFrequency:STATe setting.

Query

Range: same as setting

*RST Setting

 0,127,191,255,319,383,447,511

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:ITAFrequency:SCODe 0,127,192,255,320,384,448,511"
! Sets the scrambling code for the first intra frequency neighbor
! cell to 0, sets the scrambling code for the second intra
! frequency neighbor cell to 127, etc.

CALL[:CELL]:BCCHannel:ITAFrequency:STATe

Function

Sets/queries whether each of the 8 intra frequency neighbor cells is included in the cell info list transmitted by the test set (see Intra-frequency Cells ).

Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: 1|ON|0|OFF

The command must be issued with a comma-separated list of 8 valid settings.

Query

Range: 1|0

*RST Setting

 1,1,0,0,0,0,0,0

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:ITAFrequency:STATe 1,1,1,1,1,1,1,1"
! Includes all 8 intra frequency neighbor cells in the
! cell info list.

CALL[:CELL]:BCCHannel:ITRFrequency:CRESelection:OFFSet[1]

Function

Sets/queries Inter-freq <num> Cell Cell Reselection Offset1 for each of the 8 intra-frequency neighbor cells.

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: -50 to 50 dB

Resolution: 1 dB

The command must be issued with a comma-separated list of 8 values. Each value in the list defines the Cell Reselection Offset1 for the corresponding neighbor cell (cell 1 through cell 8). Whether each cell is actually present in the cell list transmitted by the test set is controlled by the CALL[:CELL]:BCCHannel:ITRFrequency:STATe setting.

Query

Range: same as setting

*RST Setting

 0,0,0,0,0,0,0,0 (dB)

Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:ITRFrequency:CRESelection:OFFSet -20,-20,-20,-20,-20,-20,-20,-20"
! Sets Cell Reselection Offset1 for the first inter-frequency neighbor cell to -20 dB,
! sets Cell Reselection Offset1 for the second inter-frequency neighbor cell to -20 dB, etc.

CALL[:CELL]:BCCHannel:ITRFrequency:CRESelection:OFFSet2

Function

Sets/queries Inter-freq <num> Cell Cell Reselection Offset2 for each of the 8 intra-frequency neighbor cells.

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: -50 to 50 dB

Resolution: 1 dB

The command must be issued with a comma-separated list of 8 values. Each value in the list defines the Cell Reselection Offset2 for the corresponding neighbor cell (cell 1 through cell 8). Whether each cell is actually present in the cell list transmitted by the test set is controlled by the CALL[:CELL]:BCCHannel:ITRFrequency:STATe setting.

Query

Range: same as setting

*RST Setting

 0,0,0,0,0,0,0,0 (dB)

Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:ITRFrequency:CRESelection:OFFSet2 -20,-20,-20,-20,-20,-20,-20,-20"
! Sets Cell Reselection Offset2 for the first inter-frequency neighbor cell to -20 dB,
! sets Cell Reselection Offset2 for the second inter-frequency neighbor cell to -20 dB, etc.

CALL[:CELL]:BCCHannel:ITRFrequency:DOWNlink:CHANnel

Function

Sets/queries the UARFCN for each of the 8 inter frequency neighbor cells (see Inter-frequency Cells ).

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range:

  • 412, 437, 462, 487, 512, 537, 562, 587, 612, 637, 662, 687
  • 1007, 1012, 1032, 1037, 1062, 1087
  • 1162 - 1513, resolution = 1
  • 1537 - 1738, resolution = 1
  • 1887, 1912, 1937, 1962, 1987, 2012, 2037, 2062, 2087
  • 2237 - 2563, resolution = 1
  • 2587, 2612, 2637, 2662, 2687, 2712, 2737, 2762, 2787, 2812, 2837, 2862, 2887, 2912
  • 2937 - 3088, resolution = 1
  • 3112 to 3388, resolution = 1
  • 3412, 3437, 3462, 3487, 3512, 3537, 3562, 3587, 3612, 3637, 3662, 3687
  • 3837 - 3903, resolution = 1
  • 3927, 3932, 3957, 3962, 3987, 3992
  • 4017 - 4043, resolution = 1
  • 4067, 4092
  • 4117 - 4143, resolution = 1
  • 4167, 4192
  • 4357 - 4458, resolution = 1
  • 9237 - 9387, resolution = 1
  • 9662 - 9938, resolution = 1
  • 10562 - 10838, resolution = 1

The command must be issued with a comma-separated list of 8 values. Each value in the list defines the UARFCN for the corresponding neighbor cell (cell 1 through cell 8). Whether each cell is actually present in the cell info list transmitted by the test set is controlled by the CALL[:CELL]:BCCHannel:ITRFrequency:STATe setting.

Query

Range: same as setting

*RST Setting

 10730,10730,10730,10730,10730,10730,10730,10730

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Test Application Revision: A.05.28 and above, added 1037 - 1062.

Lab Application Revision: B.01 and above

Lab Application Revision: B.01.29 and above, added 1037 - 1062.

Test Application Revision A.09 and Lab Application Revision C.04 and D.00, changed channel ranges to match 3GPP TS 25.101 v7.2.0 (previously, channels supported were: 412-687, 1037-1062, 4320-4495, 4600-4825, 9000-9425, 9625-9975, and 10,525-10,875, resolution = 1).

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, added 3112 to 3388, 3412, 3437, 3462, 3487, 3512, 3537, 3562, 3587, 3612, 3637, 3662, 3687

Test Application Revision A.14 and Lab Application Revision F.00, added 3837 - 3903, 3927, 3932, 3957, 3962, 3987, 3992, 4017 - 4043, 4067, 4092, 4117 - 4143, 4167, 4192

Programming Example

OUTPUT 714;"CALL:BCCHannel:ITRFrequency:DOWNlink:CHANnel 10730,10730,10730,10730,
10730,10730,10730,10730"
! Sets the UARFCN for each of the 8 inter frequency neighbor
! cells to 10730.

CALL[:CELL]:BCCHannel:ITRFrequency:SCODe

Function

Sets/queries the primary scrambling code for each of the 8 inter frequency neighbor cells (see Inter-frequency Cells ).

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: 0 to 511

Resolution: 1

The command must be issued with a comma-separated list of 8 values. Each value in the list defines the primary scrambling code for the corresponding neighbor cell (cell 1 through cell 8). Whether each cell is actually present in the cell info list transmitted by the test set is controlled by the CALL[:CELL]:BCCHannel:ITRFrequency:STATe setting.

Query

Range: same as setting

*RST Setting

 0,127,191,255,319,383,447,511

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:ITRFrequency:SCODe 0,127,192,255,320,384,448,511"
! Sets the scrambling code for the first inter frequency neighbor
! cell to 0, sets the scrambling code for the second inter
! frequency neighbor cell to 127, etc.

CALL[:CELL]:BCCHannel:ITRFrequency:STATe

Function

Sets/queries whether each of the 8 inter frequency neighbor cells is included in the cell info list transmitted by the test set (see Inter-frequency Cells ).

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: 1|ON|0|OFF

The command must be issued with a comma-separated list of 8 valid settings.

Query

Range: 1|0

*RST Setting

 1,0,0,0,0,0,0,0

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:ITRFrequency:STATe 1,1,1,1,1,1,1,1"
! Includes all 8 inter frequency neighbor cells in the
! cell info list.

CALL[:CELL]:BCCHannel:N300

Function

Sets/queries the N300 RRC Conn Req Max Retransmits .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 0 to 7

Resolution: 1

Query

 Same as setting

*RST Setting

 0

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:N300 0"
! Sets the N300 Constant to 0.

CALL[:CELL]:BCCHannel:N312[:IDLE]

Function

Sets/queries the N312 Link Establishment In-Sync Count (Idle) .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 1, 2, 4, 10, 20, 50, 100, 200, 400, 600, 800, 1000

Query

 Same as setting

*RST Setting

 50

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:N312 50"
! Sets the N312 Constant to 50.

CALL[:CELL]:BCCHannel:N313

Function

Sets/queries the T313 Out-Of-Sync Reception Timer .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: S1|S2|S4|S10|S20|S50|S100|S200

Query

 Same as setting

*RST Setting

 S2

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:N313 S200"
! Sets the N313 UE Out-Of-Sync Counter to S200

CALL[:CELL]:BCCHannel:N315

Function

Sets/queries the N315 Successive In-Sync Reception Counter .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: S1|S2|S4|S10|S20|S50|S100|S200|S400|S600|S800|S1000

Query

 Same as setting

*RST Setting

 S50

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:N315 S1"
! Sets N315 UE In-Sync Counter to S1.

CALL[:CELL]:BCCHannel:SERSearch[:SVALue]

Function

The setting form of this command performs two functions: (1) sets the Sintersearch value (see CALL[:CELL]:BCCHannel:SERSearch:VALue ) and (2) sets the Sintersearch state to on (see CALL[:CELL]:BCCHannel:SERSearch:STATe ).

The query form of this command returns the Sintersearch value.

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: -32 dB to 20 dB

Resolution: 2 dB

Sintersearch can be set to any even number value between -32 dB and +20 dB, but any negative value will be interpreted by the UE as 0 dB.

Query

 Same as setting

*RST Setting

Value = 0 dB

State = On

Requirements

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SERSearch 4"
! Sets Sintersearch state to on and sets Sintersearch value to 4 dB.

CALL[:CELL]:BCCHannel:SERSearch:STATe

Function

Sets/queries the Sintersearch state. The Sintersearch state can also be set using the CALL[:CELL]:BCCHannel:SERSearch[:SVALue] command.

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: 1|ON|0|OFF

Query

 1|0

*RST Setting

 1 (on)

Requirements

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SERSearch:STATe OFF"
! Turns Sintersearch state off.

CALL[:CELL]:BCCHannel:SERSearch:VALue

Function

Sets/queries the Sintersearch value. The Sintersearch value can also be set using the CALL[:CELL]:BCCHannel:SERSearch[:SVALue] command.

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: -32 dB to 20 dB

Resolution: 2 dB

Sintersearch can be set to any even number value between -32 dB and +20 dB, but any negative value will be interpreted by the UE as 0 dB.

Query

 Same as setting

*RST Setting

 0 dB

Requirements

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SERSearch:VALue 4 DB"
! Sets the Sintersearch value to 4 dB.

CALL[:CELL]:BCCHannel:SIB5:BIS

Function

Sets/queries Transmit SIB5bis .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range:

  • ALL - All Bands
  • BAND10 - Band X
  • BAND4 - Band IV
  • BAND9 - Band IX
  • BAND49 - Bands IV & IX
  • NONE - No Bands
  • SBANds - Standard Bands

Query

 Same as setting

*RST Setting

 SBAN

Requirements

Test Application Revision: A.01.01 and above

Lab Application Revision: D.00.04 and above

Test Application Revision A.11, Lab Application Revisions D.02 and E.00, added BAND10 and SBANds, changed default from BAND49 to SBANds.

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB5:BIS SBANds"
! Sets Transmit SIB5bis to Standard Bands.

CALL[:CELL]:BCCHannel:SIB15:GPSystem:TIME:OFFset:TTOWeek

Function

Sets/queries the GPS Transmission TOW Offset.

This defines a static offset in seconds that is applied to the transmissionTOW IE whenever it is updated in the SIB15.x messages.The purpose of this parameter is to allow you to introduce deliberate errors into the accuracy of GPS time signaled by this IE.

Setting

Range: -30 to +30

Resolution: 1

Query

 Same as setting

*RST Setting

 0

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB15:GPSystem:TIME:OFFset:TTOWeek 0"
! Sets the GPS Transmission TOW Offset to 0.

CALL[:CELL]:BCCHannel:SIB15:GPSystem:TIME:OFFSet:TOWeek:MSECond

Function

Sets/queries the GPS TOW 1ms Offset.

This defines a static offset in seconds that is applied to gps-tow-1msec IE whenever it is updated in the SIB15.X messages. The purpose of this parameter is to allow you to introduce deliberate errors into the accuracy of GPS time signaled by this IE.

Setting

Range: -5.0 to +5.0 seconds

Resolution: 0.1 seconds

Query

 Same as setting

*RST Setting

 0 seconds

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB15:GPSystem:TIME:OFFSet:TOWeek:MSECond 0"
! Sets the GPS TOW 1ms Offset to 0 seconds.

CALL[:CELL]:BCCHannel:SIB15:GPSystem:TIME:OFFSet:UTRan

Function

Sets/queries the UTRAN GPS TimingOfCell Offset.

This defines a static offset in micro-seconds that will be applied to the utran-GPSTimingOfCell IE (rounded to nearest chip). The purpose of this parameter is to allow you to introduce deliberate errors into the accuracy of GPS time signaled by this IE.

Setting

Range: -100 to +100 microseconds

Resolution: 1 microseconds

Query

 Same as setting

*RST Setting

 0 microseconds

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB15:GPSystem:TIME:OFFSet:UTRan 0"
! Sets the UTRAN GPS TimingOfCell Offset to 0 microseconds.

CALL[:CELL]:BCCHannel:SIB15:GPSystem:TIME:REFerence:UPDate[:STATe]

Function

Sets/queries the GPS Reference Time Update State.

This controls whether the test set updates the utran-GPSReferenceTime IE in SIB15 when the GPS Time Sync State is On. If this parameter is On, then the test set will assume that the encoded SIB15 you supply contains the optional utran-GPSReferenceTime IE.

This setting can only be changed while Section the SIB15.x Transmission State is Off. If you attempt to change this parameter while the SIB15.x Transmission State is On the application will reject the setting with the error "+XXX FDD Call processing error; This setting cannot be changed while SIB15.x messages are being transmitted."

Setting

Range: 1|ON|0|OFF

Query

 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB15:GPSystem:TIME:REFerence:UPDate OFF"
! Sets the GPS Reference Time Update State to Off.

CALL[:CELL]:BCCHannel:SIB15:GPSystem:TIME:REFerence:SFN

Function

Sets/queries the GPS Reference Time SFN.

This defines the SFN that is assumed when the test set updates the utran-GPSTimingOfCell parameters in the utran-GPSReferenceTime IE in SIB15. The test set does not set the SFN field in the utran-GPSReferenceTime IE but instead assumes that you have already configured that field in the encoded SIB15 to match this setting.

This setting can only be changed while SIB15.x Transmission State is Off. If you attempt to change this parameter while SIB15.x Transmission State is On, the application will reject the setting with the error "+XXX FDD Call processing error; This setting cannot be changed while SIB15.x messages are being transmitted."

Setting

Range: 0 to 4095

Resolution: 1

Query

 Same as setting

*RST Setting

 0

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB15:GPSystem:TIME:REFerence:SFN 0"
! Sets the GPS Reference Time SFN to 0.

CALL[:CELL]:BCCHannel:SIB15:MESSage:S15

Function

Sets/queries the SIB15 Message. This defines the encoded SIB15 message that the test set sends out.

Setting <length of encoded message in bits> to zero deletes the stored message.

The Reference Time Offset parameter contains the bit offset of where the ue-positioning-GPS-ReferenceTime IE starts.

This setting can only be changed while SIB15.x Transmission State is Off. If you attempt to change this parameter while SIB15.x Transmission State is On the application will reject the setting with the error "+XXX FDD call processing error; This setting cannot be changed while SIB15.x messages are being transmitted."

If the length of the message in bits rounded up to the next round number of 4 bits does not equal the number of bits in the message itself then the setting will be rejected with the error "+XXX FDD call processing error; The length of the message and the length field do not match."

If the length of the message is greater than 800 bits then the setting will be rejected with the error "+XXX FDD call processing error; Message size exceeds maximum length for this message type."

Setting

Range: <length of encoded message in bits>, <Reference Time Offset in bits>, <"ascii string of hex digits defining">

Query

 Same as setting

*RST Setting

 0, 0, ""

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB15:MESSage:S15 0, 0, """
! Sets the SIB15 message.

CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point1

Function

Sets/queries the SIB15.1 Message. This defines the encoded SIB15.1 message that the test set will send out.

Setting <length of encoded message in bits> to zero deletes the stored message.

This setting can only be changed while SIB15.x Transmission State is Off. If you attempt to change this parameter while SIB15.x Transmission State is On the application will reject the setting with the error "+XXX FDD call processing error; This setting cannot be changed while SIB15.x messages are being transmitted."

If the length of the message in bits rounded up to the next round number of 4 bits does not equal the number of bits in the message itself then the setting will be rejected with the error "+XXX FDD call processing error; The length of the message and the length field do not match."

If the length of the message is greater than 1200 bits then the setting will be rejected with the error "+XXX FDD call processing error; Message size exceeds maximum length for this message type."

Setting

Range: <length of encoded message in bits>, <"ascii string of hex digits defining SIB">

Query

 Same as setting

*RST Setting

 0, ""

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point2:MESSage1 0, """
! Sets the SIB15.1 Message to 0, "".

CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point2:MESSage1

Function

Sets/queries the First SIB15.2 Message.

This defines the first encoded SIB15.2 message that the test set will send out.

This setting can only be changed while SIB15.x Transmission State is Off. If you attempt to change this parameter while SIB15.x Transmission State is On the application will reject the setting with the error "+XXX FDD call processing error; This setting cannot be changed while SIB15.x messages are being transmitted."

If the length of the message in bits rounded up to the next round number of 4 bits does not equal the number of bits in the message itself then the setting will be rejected with the error "+XXX FDD call processing error; The length of the message and the length field do not match."

If the length of the message is greater than 800 bits then the setting will be rejected with the error "+XXX FDD call processing error; Message size exceeds maximum length for this message type."

Setting

Range: <length of encoded message in bits>, <"ascii string of hex digits defining SIB">

Query

 Same as setting

*RST Setting

 0, ""

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point2:MESSage1 0, """
! Sets the First SIB15.2 Message to 0, "".

CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point2:MESSage2

Function

Sets/queries the Second SIB15.2 Message.

This setting can only be changed while SIB15.x Transmission State is Off. If you attempt to change this parameter while SIB15.x Transmission State is On the application will reject the setting with the error "+XXX FDD call processing error; This setting cannot be changed while SIB15.x messages are being transmitted."

If the length of the message in bits rounded up to the next round number of 4 bits does not equal the number of bits in the message itself then the setting will be rejected with the error "+XXX FDD call processing error; The length of the message and the length field do not match."

If the length of the message is greater than 800 bits then the setting will be rejected with the error "+XXX FDD call processing error; Message size exceeds maximum length for this message type."

Setting

Range: <length of encoded message in bits>, <"ascii string of hex digits defining SIB">

Query

 Same as setting

*RST Setting

 0, ""

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point2:MESSage2 0, """
! Sets the Second SIB15.2 Message to 0, "".

CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point3:MESSage1

Function

Sets/queries the First SIB15.3 Message.

This setting can only be changed while SIB15.x Transmission State is Off. If you attempt to change this parameter while SIB15.x Transmission State is On the application will reject the setting with the error "+XXX FDD call processing error; This setting cannot be changed while SIB15.x messages are being transmitted."

If the length of the message in bits rounded up to the next round number of 4 bits does not equal the number of bits in the message itself then the setting will be rejected with the error "+XXX FDD call processing error; The length of the message and the length field do not match."

If the length of the message is greater than 3552 bits then the setting will be rejected with the error "+XXX FDD call processing error; Message size exceeds maximum length for this message type."

Setting

Range: <length of encoded message in bits>, <"ascii string of hex digits defining SIB">

Query

 Same as setting

*RST Setting

 0, ""

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point3:MESSage1 0, """
! Sets the First SIB15.3 Message to 0, "".

CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point3:MESSage2

Function

Sets/queries the Second SIB15.3 Message.

This setting can only be changed while SIB15.x Transmission State is Off. If you attempt to change this parameter while SIB15.x Transmission State is On the application will reject the setting with the error "+XXX FDD call processing error; This setting cannot be changed while SIB15.x messages are being transmitted."

If the length of the message in bits rounded up to the next round number of 4 bits does not equal the number of bits in the message itself then the setting will be rejected with the error "+XXX FDD call processing error; The length of the message and the length field do not match."

If the length of the message is greater than 3552 bits then the setting will be rejected with the error "+XXX FDD call processing error; Message size exceeds maximum length for this message type."

Setting

Range: <length of encoded message in bits>, <"ascii string of hex digits defining SIB">

Query

 Same as setting

*RST Setting

 0, ""

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point3:MESSage2 0, """
! Sets the Second SIB15.3 Message to 0, "".

CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point4

Function

Sets/queries the SIB15.4 Message.

This setting can only be changed while SIB15.x Transmission State is Off. If you attempt to change this parameter while SIB15.x Transmission State is On the application will reject the setting with the error "+XXX FDD call processing error; This setting cannot be changed while SIB15.x messages are being transmitted."

If the length of the message in bits rounded up to the next round number of 4 bits does not equal the number of bits in the message itself then the setting will be rejected with the error "+XXX FDD call processing error; The length of the message and the length field do not match."

If the length of the message is greater than 3552 bits then the setting will be rejected with the error "+XXX FDD call processing error; Message size exceeds maximum length for this message type."

Setting

Range: <length of encoded message in bits>, <"ascii string of hex digits defining SIB">

Query

 Same as setting

*RST Setting

 0, ""

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point4 0, """
! Sets the SIB15.4 Message to 0, "".

CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point5

Function

Sets/queries the SIB15.5 Message.

This setting can only be changed while SIB15.x Transmission State is Off. If you attempt to change this parameter while SIB15.x Transmission State is On the application will reject the setting with the error "+XXX FDD call processing error; This setting cannot be changed while SIB15.x messages are being transmitted."

If the length of the message in bits rounded up to the next round number of 4 bits does not equal the number of bits in the message itself then the setting will be rejected with the error "+XXX FDD call processing error; The length of the message and the length field do not match."

If the length of the message is greater than 3552 bits then the setting will be rejected with the error "+XXX FDD call processing error; Message size exceeds maximum length for this message type."

Setting

Range: <length of encoded message in bits>, <"ascii string of hex digits defining SIB">

Query

 Same as setting

*RST Setting

 0, ""

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL[:CELL]:BCCHannel:SIB15:MESSage:S15Point4 0, """
! Sets the SIB15.5 Message to 0, "".

CALL[:CELL]:BCCHannel:SIB15:TRANsmit[:STATe]

Function

Sets/queries the SIB15.x Transmission State.

This setting controls whether the user supplied SIB15.x messages will be transmitted by the application. Changing this setting (either to On or Off) will not affect any user supplied messages that have been stored by the application.If this setting is "On" and GPS Time Sync State is "On" then the application will update the GPS time parameters in the transmitted SIB15.X messages.This setting has no effect in any Cell Operating Mode other than Active Cell.

Setting

Range: 1|ON|0|OFF

Query

 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB15:TRANsmit 0"
! Sets the SIB15.x Transmission State to Off.

CALL[:CELL]:BCCHannel:SIB19[:INFormation]

Function

Sets/queries the SIB19 Info setting, see SIB19 Info .

This setting controls whether or not SIB19 shall be transmitted via the BCCH.

Setting

Range: PRESent|ABSent

Query

 Range: PRES|ABS

*RST Setting

 ABSent

Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB19:INFormation PRESent"
! Sets the SIB19 information to Off.

CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8[:STATe]

Function

Sets/queries the SIB19 E-UTRA Entries (1 to 8) State.

This setting controls the presence of E-UTRA Freq and Priority Info Entries (1 to 8) within the "E-UTRA Frequency and Priority" list of SIB19.

Setting

Range: On|Off

Query

 Range: On|Off

*RST Setting

 Off

Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB19:EUTRa2:STATe On"
! Sets the SIB19 E-UTRA Entry2 to On.

CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:DETection

Function

Sets/queries the SIB19 E-UTRA Entries (1 to 8) detection.

This setting controls the content of the detection field of E-UTRA Freq and Priority Info Entries (1 to 8) within the "E-UTRA Frequency and Priority" list of SIB19.

Setting

Range: On|Off

Query

 Range: On|Off

*RST Setting

 On

Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB19:EUTRa2:DETection Off"
! Sets the SIB19 E-UTRA Entry2 detection to Off.

CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:EARFcn

Function

Sets/queries the SIB19 E-UTRA Entries (1 to 8) EARFCN (E-UTRA Absolute Radio Frequency Channel Number).

This parameter specifies the Downlink EARFCN of the neighboring E-UTRA cell outlined with the E-UTRA Frequency and Priority Info Entries (1 to 8).

Setting

Range: 0 to 65535

Resolution: 1

Query

Range: 0 to 65535

Resolution: 1

*RST Setting

SIB19 E-UTRA EARFCN 1: 300

SIB19 E-UTRA EARFCN 2: 2175

SIB19 E-UTRA EARFCN 3: 3100

SIB19 E-UTRA EARFCN 4: 5230

SIB19 E-UTRA EARFCN 5: 5790

SIB19 E-UTRA EARFCN 6: 3975

SIB19 E-UTRA EARFCN 7: 900

SIB19 E-UTRA EARFCN 8: 1575

Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB19:EUTRa2:EARFcn 2000"
! Sets the SIB19 E-UTRA Entry2 EARFCN to 2000.

CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:MBWidth

Function

Sets/queries the SIB19 E-UTRA Entries (1 to 8) MeasBW.

This setting controls the specification of the measurement bandwidth of the E-UTRA Frequency and Priority Info Entries (1 to 8). The measurement bandwidth specifies the number of resource blocks over which the UE could measure.

Setting

Range: ABSent, MBW6, MBW15, MBW25, MBW50, MBW75, MBW100

Query

Range: ABSent, MBW6, MBW15, MBW25, MBW50, MBW75, MBW100

*RST Setting

 MBW50

Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB19:EUTRa2:MBWidth MBW75"
! Sets the SIB19 E-UTRA Entry2 MBWidth to MBW75.

CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:PRIority

Function

Sets/queries the SIB19 E-UTRA Entries (1 to 8) Priority.

This setting controls the reselection priority of the E-UTRA Frequency and Priority Info Entries (1 to 8).

Setting

Range:0 to 7

Query

Range:0 to 7

*RST Setting

 4

Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB19:EUTRa2:PRIority 1"
! Sets the SIB19 E-UTRA Entry2 PRIority to 1.

CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:RLMinimum

Function

Sets/queries the SIB19 E-UTRA Entries (1 to 8) QrxlevminEUTRA.

These settings control the QrxlevminEUTRA, which allows specification of the minimum required Rx level in the cell(s) associated with the E-UTRA Frequency and Priority Info Entries (1 to 8).

Setting

Range:-140 to -44 dBm

Resolution: 2

Query

Range:-140 to -44 dBm

Resolution: 2

*RST Setting

 -130

Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB19:EUTRa2:RLMinimum -100"
! Sets the SIB19 E-UTRA Entry2 RLMinimum to -100 dBm.

CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:THReshold:HIGH

Function

Sets/queries the SIB19 E-UTRA Entries (1 to 8) Thresh x,high .

These settings control the Thresh x,high of the E-UTRA Frequency and Priority Info Entries (1 to 8).

Setting

Range:0 to 62 dB

Resolution: 2

Query

Range:0 to 62 dB

Resolution: 2

*RST Setting

 4

Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB19:EUTRa2:THReshold:HIGH 62"
! Sets the SIB19 E-UTRA Entry2 Threshx,high
 to 62 dBm.

CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:THReshold:LOW

Function

Sets/queries the SIB19 E-UTRA Entries (1 to 8) Thresh x,low .

These settings control the Thresh x,low of the E-UTRA Frequency and Priority Info Entries (1 to 8).

Setting

Range:0 to 62 dB

Resolution: 2

Query

Range:0 to 62 dB

Resolution: 2

*RST Setting

 2

Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB19:EUTRa2:THReshold:LOW 0"
! Sets the SIB19 E-UTRA Entry2 Threshx,low
 to 0 dBm.

CALL[:CELL]:BCCHannel:SIB19:UTRA:SCEL1:PRIority

Function

Sets/queries the SIB19 UTRA Serving Cell Priority.

This setting controls reselection priority associated with the UTRA Serving Cell.

Setting

Range: 0 to 7

Resolution: Integer

Query

 Range: 0 to 7

*RST Setting

 3

Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB19:UTRA:SCEL1:PRIority 4"
! Sets the SIB19 SIB19 UTRA Serving Cell Priority to 4.

CALL[:CELL]:BCCHannel:SIB19:UTRA:SCEL1:SPSearch1

Function

Sets/queries the SIB19 UTRA Serving Cell Sprioritysearch1.

This setting influences the rate of inter-frequency and inter-RAT measurements when absolute priorities are used.

Setting

Range: 0 to 62 dB

Resolution: 2 dB

Query

Range: 0 to 62 dB

Resolution: 2 dB

*RST Setting

 0

Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB19:UTRA:SCEL1:SPSearch1 4"
! Sets the SIB19 SIB19 UTRA Serving Cell Sprioritysearch1 to 4.

CALL[:CELL]:BCCHannel:SIB19:UTRA:SCEL1:SPSearch2[:SVALue]

Function

This setting form of this command performs two function: (1) set the SIB19 UTRA Serving Cell Sprioritysearch2 State to On; (2) Sets/queries the value of SIB19 UTRA Serving Cell Sprioritysearch2.

Setting

Range: 0 to 7 dB

Query

Range: 0 to 7 dB

*RST Setting

 0

Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB19:UTRA:SCEL1:SPSearch2 4"
! Sets the SIB19 SIB19 UTRA Serving Cell Sprioritysearch2 to 4.

CALL[:CELL]:BCCHannel:SIB19:UTRA:SCEL1:THReshold:LOW

Function

Sets/queries the SIB19 UTRA Serving Cell Low Threshold.

This setting controls the threshold of the serving cell Rx level, below which the UE may perform cell reselection to cells specified with a lower associated absolute priority.

Setting

Range: 0 to 62 dB

Resolution: 2 dB

Query

Range: 0 to 62 dB

Resolution: 2 dB

*RST Setting

 0

Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SIB19:UTRA:SCEL1:THReshold 4"
! Sets SIB19 UTRA Serving Cell Low Threshold to 4.

CALL[:CELL]:BCCHannel:SRASearch[:SVALue]

Function

The setting form of this command performs two functions: (1) sets the Sintrasearch value (see CALL[:CELL]:BCCHannel:SRASearch:VALue ) and (2) sets the Sintrasearch state to on (see CALL[:CELL]:BCCHannel:SRASearch:STATe ).

The query form of this command returns the Sintrasearch value.

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: -32 dB to 20 dB

Resolution: 2 dB

Sintrasearch can be set to any even number value between -32 dB and +20 dB, but any negative value will be interpreted by the UE as 0 dB.

Query

 Same as setting

*RST Setting

Value = 0 dB

State = On

Requirements

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SRASearch 4"
! Sets Sintrasearch state to on and sets Sintrasearch value to 4 dB.

CALL[:CELL]:BCCHannel:SRASearch:STATe

Function

Sets/queries the Sintrasearch state. The Sintrasearch state can also be set using the CALL[:CELL]:BCCHannel:SRASearch[:SVALue] command.

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: 1|ON|0|OFF

Query

 1|0

*RST Setting

 1 (on)

Requirements

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SRASearch:STATe OFF"
! Turns Sintrasearch state off.

CALL[:CELL]:BCCHannel:SRASearch:VALue

Function

Sets/queries the Sintrasearch value. The Sintrasearch value can also be set using the CALL[:CELL]:BCCHannel:SRASearch[:SVALue] command.

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: -32 dB to 20 dB

Resolution: 2 dB

Sintrasearch can be set to any even number value between -32 dB and +20 dB, but any negative value will be interpreted by the UE as 0 dB.

Query

 Same as setting

*RST Setting

 0 dB

Requirements

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:SRASearch:VALue 4 DB"
! Sets the Sintrasearch value to 4 dB.

CALL[:CELL]:BCCHannel:T300

Function

Sets/queries the T300 RRC Conn Req Retransmit Timer .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: MS100 | MS200 | MS400 | MS600 | MS800 | MS1000 | MS1200 | MS1400 | MS1600 | MS1800 | MS2000 | MS3000 | MS4000 | MS6000 | MS8000

Query

 Same as setting

*RST Setting

 MS400

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:T300 MS400"
! Sets the T300 Timer to 400 ms.

CALL[:CELL]:BCCHannel:T305

Function

Sets/queries the T305 Periodic Cell Update Timer .

Setting

Range: MINS5 | MINS10 | MINS30 | MINS60 | MINS120 | MINS360 | MINS720 | INF

Query

 Same as setting

*RST Setting

 INF

Requirements

Lab Application Revision: F.00.00 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:T305 INF"
! Sets the T305 Timer to Infinity.

CALL[:CELL]:BCCHannel:T308

Function

Sets/queries the T308 RRC Conn Release Comp Retransmit Timer .

Setting

Range: MS40 | MS80 | MS160 | MS320

Query

 Same as setting

*RST Setting

 MS40

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:T308 MS40"
! Sets the T308 Timer to 40 ms.

CALL[:CELL]:BCCHannel:T309

Function

Sets/queries the T309 CCO From UTRAN to 2G Connect Timer .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 0 to 8 seconds

Resolution: 1 second

Query

 Same as setting

*RST Setting

 8 seconds

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:T309 8"
! Sets the T309 Timer to 8 seconds.

CALL[:CELL]:BCCHannel:T312[:IDLE]

Function

Sets/queries the T312 Link Establishment Timer (Idle) .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 1 to 15

Resolution: 1

Query

 Same as setting

*RST Setting

 5

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:T312 5"
! Sets the T308 Timer to 40 ms.

CALL[:CELL]:BCCHannel:T313

Function

Sets/queries the T313 Out-Of-Sync Reception Timer .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 0 to 15 seconds

Resolution: 1 second

Query

 Same as setting

*RST Setting

 3 seconds

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:T313 15"
! Sets the T313 UE Link Reestablishment Timer to 15 seconds.

CALL[:CELL]:BCCHannel:T3212

Function

Sets/queries the T312 Link Establishment Timer (Idle) .

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: 0 to 255

Resolution: 1

Query

 Same as setting

*RST Setting

 0

Requirements

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:T3212 10"
! Sets T3212 Periodic Location Update Timer to 10 decihours (1 hour).

CALL[:CELL]:BCCHannel:T3312[:VALue]

Function

Sets/queries the T3312 Periodic RA Update Timer .

To set the units for this timer, see CALL[:CELL]:BCCHannel:T3312:UNITs .

Setting

Range: 0 to 31

Resolution: 1

Query

 Same as setting

*RST Setting

 10

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:T3312 10"
! Sets T3312 Timer to 10.

CALL[:CELL]:BCCHannel:T3312:UNITs

Function

Sets/queries the T3312 Periodic RA Update Units .

To set the value for this timer, see CALL[:CELL]:BCCHannel:T3312[:VALue] .

Setting

Range: SEC2 | MINutes | DHOurs | DEACtivated

Query

 Range: SEC2 | MIN | DHO | DEAC

*RST Setting

 DEAC

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:T3312:UNITs DEAC"
! Sets T3312 timer's units to DEACtivated.

CALL[:CELL]:BCCHannel:UPDAtepage

Function

Sets/queries the BCCH Update Page state (see BCCH Update Page and Broadcast Channel (BCCH) Update Procedure (SIB Contents) ).

Setting

Range: AUTO|INHibit

Query

Range: AUTO|INH

*RST Setting

 INH

Requirements

Test Application Revision: A.04 and above

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:UPDAtepage AUTO"
! Instructs the test set to send a Paging Type 1 message
! to the UE when a BCCH Update has occurred.


CALL:CCPChannel

CALL:CCPChannel

Last updated: March 16, 2009

GPIB Command Conventions

  • CALL:CCPChannel:PRIMary[:SLEVel]
  • CALL:CCPChannel:PRIMary:LEVel
  • CALL:CCPChannel:PRIMary:STATe

  • CALL:CCPChannel:SECondary[:SLEVel]
  • CALL:CCPChannel:SECondary:CCODe
  • CALL:CCPChannel:SECondary:CCODe:CODE
  • CALL:CCPChannel:SECondary:CONFigure
  • CALL:CCPChannel:SECondary:CONNected:CONFig:STATe
  • CALL:CCPChannel:SECondary:LEVel
  • CALL:CCPChannel:SECondary:STATe

CALL:CCPChannel:PRIMary[:SLEVel]

Function

Sets/queries the initial power offset of the primary common control physical channel. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -5.3 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Test Application Revision A.06 changed *RST Setting to -5.3 dB.

Lab Application Revision C.01 changed *RST Setting to -5.3 dB.

Programming Example

OUTPUT 714;"CALL:CCPCHANNEL:PRIMARY:SLEVEL -15DB" !Enables and sets the initial P-CCPCH power offset to -15 dB.

CALL:CCPChannel:PRIMary:LEVel

Function

Sets/queries the primary common control physical channel's initial power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this setting.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -5.3 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.06 changed *RST Setting to -5.3 dB.

Lab Application Revision C.01 changed *RST Setting to -5.3 dB.

Programming Example

OUTPUT 714;"CALL:CCPCHANNEL:PRIMARY:LEVEL -15DB" !Sets the initial P-CCPCH power offset to -15 dB.

CALL:CCPChannel:PRIMary:STATe

Function

Sets/queries the primary common control physical channel's state.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this setting.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CCPCHANNEL:PRIMARY:STATE ON"

CALL:CCPChannel:SECondary[:SLEVel]

Function

Sets/queries the initial power offset of the secondary common control physical channel. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this setting.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting.

*RST Setting

 -10.3 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.06 changed *RST Setting to -10.3 dB.

Lab Application Revision C.01 changed *RST Setting to -10.3 dB.

Programming Example

OUTPUT 714;"CALL:CCPCHANNEL:SECONDARY:SLEVEL -10DB" !Sets P-CCPCH initial power offset to -10 dB.

CALL:CCPChannel:SECondary:CCODe

Function

THIS COMMAND IS OBSOLETE. Please use CALL:CCPChannel:SECondary:CCODe:CODE .

Sets/queries the secondary common control physical channel's channelization code.

Setting

Range: CODE6|CODE7|CODE9|CODE16|CODE17|CODE26|CODE57

Query

Range: CODE6|CODE7|CODE9|CODE16|CODE17|CODE26|CODE57

*RST Setting

 CODE7
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CCPCHANNEL:SECONDARY:CCODE CODE6"
! Sets the S-CCPCH channelization code to 6.

CALL:CCPChannel:SECondary:CCODe:CODE

Function

Sets/queries the secondary common control physical channel's channelization code. Code 0 is reserved for the CPICH.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected While in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 1 to 63

Resolution: 1

Query

Range: 1 to 63

Resolution: 1

*RST Setting

 7

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:CCPChannel:SECondary:CCODe:CODE 7"

CALL:CCPChannel:SECondary:CONFigure

Function

Sets/queries SCCPCH/PRACH Configuration .

Setting

Range: SIGNaling|STRaffic

Query

Range: SIGN|STR

*RST Setting

 SIGNaling
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:CCPChannel:SECondary:CONFigure SIGNaling"
! Sets the SCCPCH/PRACH Configuration to Signaling only.

CALL:CCPChannel:SECondary:CONNected:CONFig:STATe

Function

Sets/queries the Connected S-CCPH Channel Configuration State.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:CCPChannel:SECondary:CONNected:CONFig:STATe" !Enables the Connected S-CCPH Channel Configuration.

CALL:CCPChannel:SECondary:LEVel

Function

Sets/queries the secondary common control physical channel's initial power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this setting.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -10.3 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.06 changed *RST Setting to -10.3 dB.

Lab Application Revision C.01 changed *RST Setting to -10.3 dB.

Programming Example

OUTPUT 714;"CALL:CCPCHANNEL:SECONDARY:LEVEL -5" !Sets the intial common control physical channel level to -5 dB.

CALL:CCPChannel:SECondary:STATe

Function

Sets/queries the secondary common control physical channel's state.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this setting.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CCPCHANNEL:SECONDARY:STATE ON" !Enables the secondary common control physical channel.


CALL:CHANnel

CALL:CHANnel

Last updated: January 26, 2011

GPIB Command Conventions

  • CALL:CHANnel

CALL:CHANnel

Function

Sets/queries the downlink channel number ( DL Channel ).

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

If the Uplink Channel and DL Channel settings have an uplink/downlink offset of less than 30 MHz, the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range:

  • 412, 437, 462, 487, 512, 537, 562, 587, 612, 637, 662, 687
  • 712 to 763
  • 787, 812, 837
  • 862 to 912
  • 1007, 1012, 1032, 1037, 1062, 1087
  • 1162 - 1513, resolution = 1
  • 1537 - 1738, resolution = 1
  • 1887, 1912, 1937, 1962, 1987, 2012, 2037, 2062, 2087
  • 2237 - 2563, resolution = 1
  • 2587, 2612, 2637, 2662, 2687, 2712, 2737, 2762, 2787, 2812, 2837, 2862, 2887, 2912
  • 2937 - 3088, resolution = 1
  • 3112 - 3388, resolution = 1
  • 3412, 3437, 3462, 3487, 3512, 3537, 3562, 3587, 3612, 3637, 3662, 3687
  • 3837 - 3903, resolution = 1
  • 3927, 3932, 3957, 3962, 3987, 3992
  • 4017 - 4043, resolution = 1
  • 4067, 4092
  • 4117 - 4143, resolution = 1
  • 4167, 4192
  • 4357 - 4458, resolution = 1
  • 4512 to 4638
  • 9237 - 9387, resolution = 1
  • 9662 - 9938, resolution = 1
  • 10562 - 10838, resolution = 1

Query

 Same as setting

*RST Setting

10700

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above

Test Application Revision A.05.28 and Lab Application Revision B.01.29, added 1037 - 1062.

Test Application Revision A.08 and Lab Application Revision C.03, changed channel ranges to match 3GPP TS 25.101 v6.7.0 (previously, channels supported were: 412-687, 1037-1062, 4320-4495, 4600-4825, 9000-9425, 9625-9975, and 10,525-10,875 -- resolution = 1).

Test Application Revision A.09 and Lab Application Revisions C.04 and D.00, changed channel ranges to match 3GPP TS 25.101 v7.2.0 (previously channels supported were: 412, 437, 462, 487, 512, 537, 562, 587, 612, 637, 662, 687, 1007, 1012, 1032, 1037, 1062, 1087, 1462, 1487, 1512, 1537, 1562, 1587, 1612, 1637, 1662, 4357-4458 -- resolution = 1, 9037-9388 -- resolution = 1, 9662-9938 -- resolution = 1, and 10562-10838 -- resolution = 1).

Test Application Revision A.10 and Lab Application Revision D.01, added 2237 - 2563, 2587, 2612, 2637, 2662, 2687, 2712, 2737, 2762, 2787, 2812, 2837, 2862, 2887, 2912

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, added 3112 to 3388, 3412, 3437, 3462, 3487, 3512, 3537, 3562, 3587, 3612, 3637, 3662, 3687

Test Application Revision A.14 and Lab Application Revision F.00, added 3837 - 3903, 3927, 3932, 3957, 3962, 3987, 3992, 4017 - 4043, 4067, 4092, 4117 - 4143, 4167, 4192

Test Application Revision A.18.00 and above, added 712 to 763, 787, 812, 837, 4512 to 4638 and 862 to 912

Programming Example

OUTPUT 714;"CALL:CHANnel 10705"
! Sets the downlink channel number to 10705.


CALL:CLPControl

CALL:CLPControl

Last updated: May 21, 2010

GPIB Command Conventions

  • CALL[:CELL]:CLPControl:DOWNlink[:STATe]
  • CALL[:CELL]:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum[:WCDMa]
  • CALL[:CELL]:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum:HSDPa
  • CALL[:CELL]:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum:HSPA
  • CALL[:CELL]:CLPControl:DOWNlink:DPCHannel:LEVel:MINimum
  • CALL[:CELL]:CLPControl:DOWNlink:DTCHannel:TARGet[:QUALity]
  • CALL[:CELL]:CLPControl:DOWNlink:DCCHannel[:STATe]
  • CALL[:CELL]:CLPControl:DOWNlink:DCCHannel:TARGet[:QUALity]
  • CALL[:CELL]:CLPControl:DOWNlink:RMC012:STATe
  • CALL[:CELL]:CLPControl:DOWNlink:RMC012:DRATe
  • CALL[:CELL]:CLPControl:DOWNlink:RMC012[:SDRate]
  • CALL[:CELL]:CLPControl:DOWNlink:ECIor:RECord:STARt
  • CALL[:CELL]:CLPControl:DOWNlink:ECIor:RECord:COUNt
  • CALL[:CELL]:CLPControl:DOWNlink:ECIor:RECord:STOP
  • CALL[:CELL]:CLPControl:DOWNlink:ECIor:THReshold

  • CALL[:CELL]:CLPControl:UPLink[:IMMediate]:DOWN
  • CALL[:CELL]:CLPControl:UPLink[:IMMediate]:UP
  • CALL[:CELL]:CLPControl:UPLink:MODE
  • CALL[:CELL]:CLPControl:UPLink:ALGorithm
  • CALL[:CELL]:CLPControl:UPLink:STEPsize

CALL[:CELL]:CLPControl:DOWNlink[:STATe]

Function

Sets/queries the Downlink Power Control State setting. This parameter specifies whether to enable the Downlink Power Control for a RB test mode call.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 Off (0)

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:DOWNlink Off"
!Sets the Downlink Power Control State to Off.

CALL[:CELL]:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum[:WCDMa]

Function

Sets/queries the WCDMA Maximum DPCH Level setting. This parameter specifies the Maximum DPCH power that the average power of transmitted DPCH symbols over one time slot shall not exceed.

Setting

Range: -30.0 to 20.0 dB

Resolution: 0.01

Query

same as setting

*RST Setting

 -7

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum -7"
!Sets the Maximum DL Power to -7 dB.

CALL[:CELL]:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum:HSDPa

Function

Sets/queries the HSDPA Maximum (F-)DPCH Level . This parameter specifies the Maximum DPCH power that the average power of transmitted DPCH symbols over one time slot shall not exceed.

Setting

Range: -30.0 to 20.0 dB

Resolution: 0.01

Query

Range: same as setting

*RST Setting

 0

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum:HSDPa 0"
!Sets the Hsdpa Maximum (F-)DPCH Level to 0.

CALL[:CELL]:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum:HSPA

Function

Sets/queries the HSPA Maximum (F-)DPCH Level . This parameter specifies the Maximum DPCH power that the average power of transmitted DPCH symbols over one time slot should not exceed.

Setting

Range: -30.0 to 20.0 dB

Resolution: 0.01

Query

 same as setting

*RST Setting

 0

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum:HSPA 0"
!Sets the Hspa Maximum (F-)DPCH Level to 0.

CALL[:CELL]:CLPControl:DOWNlink:DPCHannel:LEVel:MINimum

Function

Sets/queries the Minimum (F-)DPCH Level setting. This parameter specifies the minimum DPCH power that the average power of transmitted DPCH symbols over one time slot should not go bellow.

Setting

Range: -30.0 to 20.0

Resolution: 0.01

Query

same as setting

*RST Setting

 -18.0

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:DOWNlink:DPCHannel:LEVel:MINimum -18"
!Sets the Minimum (F-)DPCH Level to -18.

CALL[:CELL]:CLPControl:DOWNlink:DTCHannel:TARGet[:QUALity]

Function

Sets/queries the Target Quality on DTCH , which is sent to UE via the RadioBearerSetup message.

Setting

Range: 0.01 to 100 Percent

Resolution: 0.01

Query

same as setting

*RST Setting

 1

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:DOWNlink:DTCHannel:TARGet 1"
!Sets the BLER target value on DTCH to 1%.

CALL[:CELL]:CLPControl:DOWNlink:DCCHannel[:STATe]

Function

Sets/queries the Target Quality on DCCH State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (Off)

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:DOWNlink:DCCHannel Off"
!Sets the Target Quality on DCCH State to Off.

CALL[:CELL]:CLPControl:DOWNlink:DCCHannel:TARGet[:QUALity]

Function

Sets/queries the Target Quality on DCCH .

Setting

Range: 0.01 to 100 Percent

Resolution: 0.01

Query

 same as setting

*RST Setting

 0.1

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:DOWNlink:DCCHannel:TARGet 0.1"
!Sets the Target Quality on DCCH. to 0.1%.

CALL[:CELL]:CLPControl:DOWNlink:RMC012:STATe

Function

Sets/queries whether the test set uses 12.2k + 0k RMC instead of 12.2k when you setup a 12.2k RB test mode call.

This is a GPIB Command only operation. This setting can only be changed when the call status is idle.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (Off)

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:DOWNlink:RMC012:STATe Off"
!Sets the 0k and 12.2k RMC State to Off.

CALL[:CELL]:CLPControl:DOWNlink:RMC012:DRATe

Function

Sets/queries the 0k and 12.2k RMC Data Rate. This parameter the information data rate on DL DTCH when CALL[:CELL]:CLPControl:DOWNlink:RMC012:STATe is set to On.

Setting

Range: KBPS12 | KBPS0

Query

Range: KBPS12 | KBPS0

*RST Setting

 KBPS12

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:DOWNlink:RMC012:DRATe KBPS12"
!Sets the 0k and 12.2k RMC Data Rate to 12.2k.

CALL[:CELL]:CLPControl:DOWNlink:RMC012[:SDRate]

Function

 This command perform to actions: 1) set the CALL[:CELL]:CLPControl:DOWNlink:RMC012:STATe to On and, 2) Set the CALL[:CELL]:CLPControl:DOWNlink:RMC012:DRATe

Setting

Range: KBPS12 | KBPS0

Query

Range: KBPS12 | KBPS0

*RST Setting

 KBPS12

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:DOWNlink:RMC012 KBPS12"
!Sets the 0k and 12.2k RMC state to On and set the data rate to 12.2k.

CALL[:CELL]:CLPControl:DOWNlink:ECIor:RECord:STARt

Function

 This action starts the recording of Real-time Downlink Power Control Info Statistic immediately. See Start/Stop Recording DPCH Ec/Ior .

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:DOWNlink:ECIor:RECord:STARt"
!perform the recording of Realtime Downlink Power Conrol Info Statistic.

CALL[:CELL]:CLPControl:DOWNlink:ECIor:RECord:COUNt

Function

Sets/queries how many real-time downlink power control information should be recorded each time the Start Recording DPCH Ec/Ior values action is performed.

Setting

Range: 1-30000

Query

Range: 1-30000

*RST Setting

 1500

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:DOWNlink:ECIor:RECord:COUNt 1500"
!Sets to record 1500 realtime downlink power control information each time.

CALL[:CELL]:CLPControl:DOWNlink:ECIor:RECord:STOP

Function

 This action stop the real-time Downlink Power Control Information statistic process. See Start/Stop Recording DPCH Ec/Ior .

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:DOWNlink:ECIor:RECord:STOP"
!Stop the the realtime Downlink Power Control Infomation statistic process.

CALL[:CELL]:CLPControl:DOWNlink:ECIor:THReshold

Function

Sets/queries the DPCH_Ec/Ior threshold for DPCH_Ec/Ior Info statistic recording.

Setting

Range: -30.0 to 0.0 dB

Query

 same as setting

*RST Setting

 -15.6

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:DOWNlink:ECIor:THReshold -15.6"
!Sets the DPCH_Ec/Ior threshold for DPCH_Ec/Ior Info statistic to -15.6.

CALL[:CELL]:CLPControl:UPLink[:IMMediate]:DOWN

Function

Sets the uplink inner loop power control to decrease power in one step (see CALL[:CELL]:CLPControl:UPLink:STEPsize ).

This function is only used when the UL CL power control is set to use alternating bits (see CALL[:CELL]:CLPControl:UPLink:MODE ).

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:CLPCONTROL:UPLINK:IMMEDIATE:DOWN"

CALL[:CELL]:CLPControl:UPLink[:IMMediate]:UP

Function

Sets the uplink inner loop power control to increase power in one step (see CALL[:CELL]:CLPControl:UPLink:STEPsize ).

This function is only used when the UL CL power control is set to use alternating bits (see CALL[:CELL]:CLPControl:UPLink:MODE ).

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:CLPCONTROL:UPLINK:IMMEDIATE:UP"

CALL[:CELL]:CLPControl:UPLink:MODE

Function

Sets/queries the UL CL Power Control Mode for Active Cell Operating Mode .

Setting

Range:

  • ACTive (Active bits)
  • DOWN (All Down bits)
  • UDOWn (Alternating bits)
  • UDOWn10 (10 Up/Down bits)
  • UP (All Up bits)

Query

Range: ACT|DOWN|UDOW|UDOW10|UP

*RST Setting

ACTive

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:CLPControl:UPLink:MODE ACTive"
!Sets the uplink closed loop power control to active.

CALL[:CELL]:CLPControl:UPLink:ALGorithm

Function

Sets/queries UL CL Power Ctrl Algorithm .

This setting can only be changed while the Cell Operating Mode is "Cell Off", or while the cell operating mode is "Active Cell" and the call status is IDLE. Attempting to change this setting while in any other mode will result in an error.

Setting

Range:

  • ALG1
  • ALG2

Query

Same as setting

*RST Setting

ALG2

Requirements

Test or Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:CELL:CLPControl:UPLink:ALGorithm ALG1"
! Sets the uplink closed loop power control algorithm to 1.

CALL[:CELL]:CLPControl:UPLink:STEPsize

Function

Sets/queries UL CL Power Ctrl Stepsize .

This setting can only be changed while the Cell Operating Mode is "Cell Off", or while the cell operating mode is "Active Cell" and the call status is IDLE. Attempting to change this setting while in any other mode will result in an error.

This setting can only be changed when CALL[:CELL]:CLPControl:UPLink:ALGorithm is set to ALG1 . Also, if CALL[:CELL]:CLPControl:UPLink:ALGorithm is set to ALG2 , this setting is returned to its default value of 1 dB .

Setting

Range: 1 to 2 dB

Resolution: 1 dB

Query

Same as setting

*RST Setting

1 dB

Requirements

Test or Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:UPLink:STEPsize 2"
! Sets the uplink closed loop power control step size to 2 dB.


CALL:COMPressed

CALL:COMPressed

Last updated: January 15, 2012

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:COMPressed:ENABle

  • CALL:COMPressed:HSDPa:TRANsmission:MODE
  • CALL:COMPressed:HSUPa:TRANsmission:MODE:MS2

  • CALL:COMPressed:MEASurement:EUTRa:QUANtity
  • CALL:COMPressed:MEASurement:EUTRa:RQUantity
  • CALL:COMPressed:MEASurement:EUTRa:RAMount
  • CALL:COMPressed:MEASurement:EUTRa:RINTerval
  • CALL:COMPressed:MEASurement:CONFig

  • CALL:COMPressed:MEASurement:GSMSystem:BSIC:VERification
  • CALL:COMPressed:MEASurement:GSMSystem:NIABort
  • CALL:COMPressed:MEASurement:GSMSystem:TRCabort
  • CALL:COMPressed:MEASurement:GSMSystem:RSSI:RINTerval
  • CALL:COMPressed:MEASurement:GSMSystem:RSSI:RQUantity

  • CALL:COMPressed:MEASurement:ITRFrequency:RINTerval
  • CALL:COMPressed:MEASurement:ITRFrequency:RQUantity

  • CALL:COMPressed:MEASurement:STATe

  • CALL:COMPressed:MEASurement:TYPe

  • CALL:COMPressed:PCReconfig:CFNHandling

  • CALL:COMPressed:TGPSequence:ALL:DSIR1
  • CALL:COMPressed:TGPSequence:ALL:DSIR1:AFTer
  • CALL:COMPressed:TGPSequence:ALL:STATe
  • CALL:COMPressed:TGPSequence:ALL:TGCFn:RELative
  • CALL:COMPressed:TGPSequence:ALL:TGDistance
  • CALL:COMPressed:TGPSequence:ALL:TGLength[1]
  • CALL:COMPressed:TGPSequence:ALL:TGLength2
  • CALL:COMPressed:TGPSequence:ALL:TGMPurpose
  • CALL:COMPressed:TGPSequence:ALL:TGPLength
  • CALL:COMPressed:TGPSequence:ALL:TGPRc
  • CALL:COMPressed:TGPSequence:ALL:TGSNumber

  • CALL:COMPressed:TGPSequence:DEFinition

  • CALL:COMPressed:TGPSequence:DFSType

  • CALL:COMPressed:TGPSequence([1]|2|3|4):DSIR1
  • CALL:COMPressed:TGPSequence([1]|2|3|4):DSIR1:AFTer
  • CALL:COMPressed:TGPSequence([1]|2|3|4):STATe
  • CALL:COMPressed:TGPSequence([1]|2|3|4):TGCFn:RELative
  • CALL:COMPressed:TGPSequence([1]|2|3|4):TGDistance
  • CALL:COMPressed:TGPSequence([1]|2|3|4):TGLength[1]
  • CALL:COMPressed:TGPSequence([1]|2|3|4):TGLength2
  • CALL:COMPressed:TGPSequence([1]|2|3|4):TGMPurpose
  • CALL:COMPressed:TGPSequence([1]|2|3|4):TGPLength
  • CALL:COMPressed:TGPSequence([1]|2|3|4):TGPRc
  • CALL:COMPressed:TGPSequence([1]|2|3|4):TGSNumber

CALL:COMPressed:ENABle

Function

Enables/disables compressed mode (see Enabling/Disabling Compressed Mode ).

To query the current status of compressed mode, use the CALL:STATus:COMPressed:STATe? query.

Setting

Range: 1|ON|0|OFF

*RST Setting

 0
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:ENABle ON"
! Enables compressed mode.

CALL:COMPressed:HSDPa:TRANsmission:MODE

Function

Sets/queries the HSDPA Downlink Transmission Mode .

This parameter can only be changed when compressed mode is not active.

Setting

Range: TGSKip|TGNSkip

*RST Setting

 TGNSkip
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CCALL:COMPressed:HSDPa:TRANsmission:MODE TGNSkip"
! Sets HSDPA Downlink Transmission Mode not to skip transmission gap.

CALL:COMPressed:HSUPa:TRANsmission:MODE:MS2

Function

Sets/queries the HSUPA Downlink Transmission Mode (2ms TTI) .

This parameter can only be changed when compressed mode is not active.

Setting

Range: TGSKip|TGNSkip

*RST Setting

 TGSKip
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:HSUPa:TRANsmission:MODE:MS2 TGSKip"
! Sets HSUPA 2ms TTI Downlink Transmission Mode to skip transmission gap.

CALL:COMPressed:MEASurement:EUTRa:QUANtity

Function

 Sets/queries the E-UTRA Measurement Quantity.

Setting

Range: RSRP | RSRQ

Query

 RSRP | RSRQ

*RST Setting

 RSRP
Requirements

Lab Application Revision: H.01.00 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:EUTRa:QUANtity RSRP"

CALL:COMPressed:MEASurement:EUTRa:RQUantity

Function

Sets/queries the E-UTRA Reporting Quantity.

The reporting quantity directs the UE as to what it should report to the network (as to perform the RSRQ mesurement it is necessary to first perform the RSRP measurement, hence both results will be available in the UE).

This parameter can only be changed when the Compressed Mode State result is "OFF".

Setting

Range: MEASured | BOTH

Query

 MEAS | BOTH

*RST Setting

 MEASured
Requirements

Lab Application Revision: H.01.00 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:EUTRa:RQUantity MEASured"

CALL:COMPressed:MEASurement:EUTRa:RAMount

Function

Sets/queries the E-UTRA Measurement Reporting Amount.

This parameter determines how many measurement reports the UE will return after the mea surement has been activated. This is the inter RAT measurement reporting amount within the measurement control message.This parameter can only be changed when the Compressed Mode State result is "OFF".

Setting

Range: RA1| RA2 | RA4 | RA8 | RA16 | RA32 | RA64 | RAINfinity

Query

 RA1| RA2 | RA4 | RA8 | RA16 | RA32 | RA64 | RAIN

*RST Setting

 RAINfinity
Requirements

Lab Application Revision: H.01.00 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:EUTRa:RAMount RAINfinity"

CALL:COMPressed:MEASurement:EUTRa:RINTerval

Function

Sets/queries the E-UTRA Measurement Reporting Interval.

This parameter determines the period, in seconds, between measurement reports when the measurement is active in the UE.

This parameter can only be changed when the Compressed Mode State result is"OFF",

Setting

Range: RIQuarter | RIHalf | RI1 | RI2 | RI3 | RI4 | RI6 | RI8 | RI12 | RI16 | RI20 | RI24 | RI28 | RI32 | RI64

Query

 RIQ | RIH | RI1 | RI2 | RI3 | RI4 | RI6 | RI8 | RI12 | RI16 | RI20 | RI24 | RI28 | RI32 | RI64

*RST Setting

 2
Requirements

Lab Application Revision: H.01.00 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:EUTRa:RINTerval 2"

CALL:COMPressed:MEASurement:CONFig

Function

 Another GPIB command is preferred for this setting, see CALL:COMPressed:MEASurement:CONFig:RATechnology .

Sets/queries Measurement Configuration .

This parameter can only be changed when compressed mode is not active.

Setting

Range: ITRFreq|ITRRat ITREutra

*RST Setting

 ITRR
Requirements

Lab Application Revision: D.00.04 and above
Lab Application Revision: H.01.00 and above, added ITREutra

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:CONFig ITRFreq"
! Sets Measurement Configuration to InterfrequencyMeas.

CALL:COMPressed:MEASurement:CONFig:RATechnology

Function

Sets/queries Measurement Configuration .

This parameter can only be changed when compressed mode is not active.

Setting

Range: WFREQ | GSM | EUTRa

*RST Setting

 WFRE | GSM | EUTR
Requirements

Lab Application Revision: H.01.00 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:CONFig:RATechnology"

CALL:COMPressed:MEASurement:GSMSystem:BSIC:VERification

Function

Sets/queries GSM Meas BSIC Verification .

This parameter can only be changed when compressed mode is not active.

Setting

Range: VERified|NVERified

*RST Setting

 NVER
Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:GSMSystem:BSIC:VERification VERified"
! Sets GSM Meas BSIC Verification to verifiedBSIC.

CALL:COMPressed:MEASurement:GSMSystem:NIABort

Function

Sets/queries GSM Meas N_Identify_Abort .

This parameter can only be changed when compressed mode is not active.

Setting

Range: 1 to 128

*RST Setting

 128
Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:GSMSystem:NIABort 100"
! Sets GSM Meas N_Identify_Abort to 100 attempts.

CALL:COMPressed:MEASurement:GSMSystem:TRCabort

Function

Sets/queries GSM Meas T_Re_Confirm_Abort (x0.5 seconds) .

This parameter can only be changed when compressed mode is not active.

Setting

Range: 1 to 20 (0.5 s to 10 s)

*RST Setting

 20 (10 s)
Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:GSMSystem:TRCabort 10"
! Sets GSM Meas T_Re_Confirm_Abort (x0.5 seconds) to 5 seconds.

CALL:COMPressed:MEASurement:GSMSystem:RSSI:RINTerval

Function

Sets/queries the GSM RSSI Measurement Reporting Interval .

Setting

Range: RIQuarter|RIHalf|RI1|RI2|RI3|RI4|RI6|RI8|RI12|RI16
|RI20|RI24|RI28|RI32|RI64

(RIQuarter = 0.25 s, RIHalf = 0.5 s, RI1 = 1 s etc.)

Query

Range: RIQ|RIH|RI1|RI2|RI3|RI4|RI6|RI8|RI12|RI16
|RI20|RI24|RI28|RI32|RI64

*RST Setting

 RI2
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:GSMSystem:RSSI:RINTerval RI4"
! Sets the GSM RSSI measurement reporting interval to 4 seconds.

CALL:COMPressed:MEASurement:GSMSystem:RSSI:RQUantity

Function

Sets/queries GSM RSSI Measurement Reporting Quantity .

Setting

Range: RQ1|RQ2|RQ4|RQ8|RQ16|RQ32|RQ64|RQINfinity

(RQ1 = 1 report, RQ2 = 2 reports, RQINfinity = infinite number of reports, etc.)

Query

Range: RQ1|RQ2|RQ4|RQ8|RQ16|RQ32|RQ64|RQIN

*RST Setting

 RQIN
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:GSMSystem:RSSI:RQUantity RQ1"
! Sets the number of reports to 1.

CALL:COMPressed:MEASurement:ITRFrequency:RINTerval

Function

Sets/queries the Interfreq Measurement Reporting Interval .

Setting

Range: RIQuarter|RIHalf|RI1|RI2|RI3|RI4|RI6|RI8|RI12|RI16
|RI20|RI24|RI28|RI32|RI64

(RIQuarter = 0.25 s, RIHalf = 0.5 s, RI1 = 1 s etc.)

Query

Range: RIQ|RIH|RI1|RI2|RI3|RI4|RI6|RI8|RI12|RI16
|RI20|RI24|RI28|RI32|RI64

*RST Setting

 RI2
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:ITRFrequency:RINTerval RI4"
! Sets the interfreq measurement reporting interval to 4 seconds.

CALL:COMPressed:MEASurement:ITRFrequency:RQUantity

Function

Sets/queries Interfreq Measurement Reporting Quantity .

Setting

Range: RQ1|RQ2|RQ4|RQ8|RQ16|RQ32|RQ64|RQINfinity

(RQ1 = 1 report, RQ2 = 2 reports, RQINfinity = infinite number of reports, etc.)

Query

Range: RQ1|RQ2|RQ4|RQ8|RQ16|RQ32|RQ64|RQIN

*RST Setting

 RQIN
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:ITRFrequency:RQUantity RQ1"
! Sets the number of reports to 1.

CALL:COMPressed:MEASurement:STATe

Function

Sets/queries UE Measurements in Compressed Mode .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:STATe ON"
! Sets the UE measurements in compressed mode state to on.

CALL:COMPressed:MEASurement:TYPe

Function

This command is obsolete. Please use CALL:COMPressed:TGPSequence:ALL:TGMPurpose or CALL:COMPressed:TGPSequence([1]|2|3|4):TGMPurpose .

Sets/queries Compressed Mode Measurement Purpose for TGPS 1.

Setting

Range: FDDMeas|GBR|GIBI|GSMRssi|EUTRa

Query

 Same as setting.

*RST Setting

 GSMR
Requirements

Lab Application Revision: B.01 and above
Lab Application Revision D.00.04, added GBR and GIBI
Lab Application Revision H.01.00, added EUTRa

Programming Example

OUTPUT 714;"CALL:COMPressed:MEASurement:TYPe FDDMeas"
! Sets the compressed mode measurement purpose to FDD Meas.

CALL:COMPressed:PCReconfig:CFNHandling

Function

Sets/queries CM PCR Timing Indication (CFN Handling) .

Setting

Range: INITialise|MAINtain

Query

Range: INIT|MAIN

*RST Setting

 MAIN
Requirements

Lab Application Revision: C.02 and above

Lab Application Revision D.02, changed default to MAIN.

Programming Example

OUTPUT 714;"CALL:COMPressed:PCReconfig:CFNHandling MAINtain"
! Sets CM PCR Timing Indication (CFN Handling) to Maintain.

CALL:COMPressed:TGPSequence:ALL:DSIR1

Function

Sets/queries <num> TG Delta SIR 1 for the first through fourth TGPSs (the first num value sets First Delta SIR1 , the second num value sets Second Delta SIR1 , etc.). You can set for an individual TGPS using the CALL:COMPressed:TGPSequence([1]|2|3|4):DSIR1 commands.

Setting

Range: 0.0 to 3.0 dB

Resolution: 0.1

Query

 Same as setting

*RST Setting

 0, 0, 0, 0
Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:ALL:DSIR1 0, 0, 0, 0"
! Sets the first through fourth TGPS Delta SIR1 to 0.

CALL:COMPressed:TGPSequence:ALL:DSIR1:AFTer

Function

Sets/queries <num> TG Delta SIR After 1 for the first through fourth TGPSs (the first num value sets First TG Delta SIR After 1 , the second num value sets Second TG Delta SIR After 1 , etc.). You can set for an individual TGPS using the CALL:COMPressed:TGPSequence([1]|2|3|4):DSIR1:AFTer commands.

Setting

Range: 0.0 to 3.0

Query

 Same as setting

*RST Setting

 0,0,0,0
Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:ALL:DSIR1:AFTer 0,0,0,0"
! Sets the first through fourth TG Delta SIR After 1 to 0.

CALL:COMPressed:TGPSequence:ALL:STATe

Function

Sets/queries <num> TGPS State for the first through fourth TGPSs (the first num value sets First TGPS State , the second num value sets Second TGPS State , etc.). You can set TGPS State for an individual TGPS using the CALL:COMPressed:TGPSequence([1]|2|3|4):STATe commands.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1,0,0,0
Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:ALL:STATe 1,1,1,0"
! Sets the first through third TGPS states to on, the fourth TGPS state to off.

CALL:COMPressed:TGPSequence:ALL:TGCFn:RELative

Function

Sets/queries <num> TG Relative CFN (TGCFN) for the first through fourth TGPSs (the first num value sets First TG Relative CFN (TGCFN) , the second num value sets Second TG Relative CFN (TGCFN) , etc.). You can set TG Relative CFN (TGCFN) for an individual TGPS using the CALL:COMPressed:TGPSequence([1]|2|3|4):TGCFn:RELative commands.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

The TGPSs must be offset so that there is never more than one transmission gap per frame.

Setting

Range: 0 to 255 frames

Resolution: 1 frame

Query

 Same as setting

*RST Setting

 0,2,6,14
Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:ALL:TGCFn:RELative 0,4,12,28"
! Sets the first through fourth TG Relative CFN (TGCFN) values
! to 0, 4, 12 and 28, respectively.

CALL:COMPressed:TGPSequence:ALL:TGDistance

Function

Sets/queries <num> TG Start Distance (TGD) for the first through fourth TGPSs (the first num value sets First TG Start Distance , the second num value sets Second TG Start Distance , etc.). You can set TG Start Distance for an individual TGPS using the CALL:COMPressed:TGPSequence([1]|2|3|4):TGDistance commands.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

This setting is only applicable when TGL2 is non-zero. Note, you cannot place TGL1 and TGL2 within the same frame.

Setting

Range: 15 to 269 slots, 270 (undefined)

Resolution: 1 slot

Query

 Same as setting

*RST Setting

 270,270,270,270
Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:ALL:TGDistance 30,45,60,270"
! Sets the first through fourth TG Start Distance (TGD) values to 30, 45, 60 slots
! and Undefined, respectively.

CALL:COMPressed:TGPSequence:ALL:TGLength[1]

Function

Sets/queries <num> Transmission Gap Length 1 (TGL1) for the first through fourth TGPSs (the first num value sets First Transmission Gap Length 1 (TGL1) , the second num value sets Second Transmission Gap Length 1 (TGL1) , etc.). You can set Transmission Gap Length 1 (TGL1) for an individual TGPS using the CALL:COMPressed:TGPSequence([1]|2|3|4):TGLength[1] commands.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

There cannot be more than 7 transmission gap slots within one frame.

Setting

Range: 1 to 14 slots

Resolution: 1 slot

Query

 Same as setting

*RST Setting

 7,7,7,7
Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:ALL:TGLength 7,3,7,5"
! Sets the first through fourth Transmission Gap Length 1 (TGL1) values to
! 7, 3, 7, and 5 slots, respectively.

CALL:COMPressed:TGPSequence:ALL:TGLength2

Function

Sets/queries <num> Transmission Gap Length 2 (TGL2) for the first through fourth TGPSs (the first num value sets First Transmission Gap Length 2 (TGL2) , the second num value sets Second Transmission Gap Length 2 (TGL2) , etc.). You can set Transmission Gap Length 2 (TGL2) for an individual TGPS using the CALL:COMPressed:TGPSequence([1]|2|3|4):TGLength2 commands.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

There cannot be more than 7 transmission gap slots within one frame. Also, if TGL2 is non-zero, you must specify a valid TGD.

Setting

Range: 0 to 14 slots

Resolution: 1 slot

Query

 Same as setting

*RST Setting

 0,0,0,0
Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:ALL:TGLength2 7,3,7,5"
! Sets the first through fourth Transmission Gap Length 2 (TGL2) values to
! 7, 3, 7, and 5 slots, respectively.

CALL:COMPressed:TGPSequence:ALL:TGMPurpose

Function

Sets/queries <num> TG Measurement Purpose (TGMP) for the first through fourth TGPSs (the first num value sets First TG Measurement Purpose (TGMP) , the second num value sets Second TG Measurement Purpose (TGMP) , etc.). You can set TG Measurement Purpose (TGMP) for an individual TGPS using the CALL:COMPressed:TGPSequence([1]|2|3|4):TGMPurpose commands.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

Setting

Range: FDDMeas|GSMRssi|GIBI|GBR|EUTRa

Query

 Same as setting.

*RST Setting

 GSMR, GIBI, GBR, FDDM
Requirements

Lab Application Revision: D.00.04 and above
Lab Application Revision H.01.00, added EUTRa

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:ALL:TGMPurpose GSMR, GSMR, GIBI, GBR"
! Sets the first through fourth TG Measurement Purpose (TGMP) values to
! GSM RSSI, GSM RSSI, GSM Initial BSIC ID, and GSM BSIC Reconfirmation, respectively.

CALL:COMPressed:TGPSequence:ALL:TGPLength

Function

Sets/queries <num> TG Pattern Length (TGPL) for the first through fourth TGPSs (the first num value sets First TG Pattern Length (TGPL) , the second num value sets Second TG Pattern Length (TGPL) , etc.). You can set TG Pattern Length (TGPL) for an individual TGPS using the CALL:COMPressed:TGPSequence([1]|2|3|4):TGPLength commands.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

TGPL must be long enough to encompass all of TGL1 and TGL2.

Setting

Range: 1 to 144 frames

Resolution: 1 frame

Query

 Same as setting

*RST Setting

 4, 8, 16, 16
Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:ALL:TGPLength 4,8,32,32"
! Sets the first through fourth TG Pattern Length (TGPL) values to
! 4, 8, 32, and 32 frames, respectively.

CALL:COMPressed:TGPSequence:ALL:TGPRc

Function

Sets/queries <num> TG Pattern Repetition Count (TGPRC) for the first through fourth TGPSs (the first num value sets First TG Pattern Repetition Count (TGPRC) , the second num value sets Second TG Pattern Repetition Count (TGPRC) , etc.). You can set TG Pattern Repetition Count (TGPRC) for an individual TGPS using the CALL:COMPressed:TGPSequence([1]|2|3|4):TGPRc commands.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

Setting

Range: 0 to 511 (0 = infinity)

Query

 Same as setting

*RST Setting

 0, 0, 0, 0
Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:ALL:TGPRc 20,0,0,0"
! Sets the first TG Pattern Repetition Count (TGPRC) to
! 20 repetitions, and the second through fourth TG Pattern
! Repetition Count (TGPRC) values to infinite repetitions.

CALL:COMPressed:TGPSequence:ALL:TGSNumber

Function

Sets/queries <num> TG Starting Slot Number (TGSN) for the first through fourth TGPSs (the first num value sets First TG Starting Slot Number (TGSN) , the second num value sets Second TG Starting Slot Number (TGSN) , etc.). You can set TG Starting Slot Number (TGSN) for an individual TGPS using the CALL:COMPressed:TGPSequence([1]|2|3|4):TGSNumber commands.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

Setting

Range: 0 to 14 (slot 0 to slot 14)

Resolution: 1

Query

 Same as setting

*RST Setting

 11, 11, 11, 11
Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:ALL:TGSNumber 0, 0, 11, 11"
! Sets the first through fourth TG Starting Slot Number (TGSN) values to
! slot 0, slot 0, slot 11, and slot 11, respectively.

CALL:COMPressed:TGPSequence:DEFinition

Function

Sets/queries TGPS Definition During Call Setup . This parameter can only be set when the connection status is idle.

Setting

Range: RBSetup|OFF

Query

 Same as setting

*RST Setting

 OFF
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:DEFinition RBSetup"
! Sets TGPS definition during call setup to RB Setup.

CALL:COMPressed:TGPSequence:DFSType

Function

Sets/queries Downlink Frame Structure Type . If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

Setting

Range: ATYPe|BTYPe

Query

 Same as setting

*RST Setting

 ATYP
Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:DFSType BTYPe"
! Sets Downlink Frame Structure Type to type B.

CALL:COMPressed:TGPSequence([1]|2|3|4):DSIR1

Function

Sets/queries <num> TG Delta SIR 1 for the first, second, third or fourth TGPS (sending :TGPSequence or :TGPSequence1 sets First TG Delta SIR 1 , sending :TGPSequence2 sets Second TG Delta SIR 1 , etc.). You can set TG Delta SIR 1 for all four TGPSs using the CALL:COMPressed:TGPSequence:ALL:DSIR1 command.

Setting

Range: 0.0 to 3.0 dB

Resolution: 0.1

Query

 Same as setting

*RST Setting
  • First TGPS: 0
  • Second TGPS: 0
  • Third TGPS: 0
  • Fourth TGPS: 0
Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:DSIR1 0"
! Sets the first TGPS Delta SIR 1 to 0.

CALL:COMPressed:TGPSequence([1]|2|3|4):DSIR1:AFTer

Function

Sets/queries <num> TG Delta SIR After 1 for the first, second, third or fourth TGPS (sending :TGPSequence or :TGPSequence1 sets First TGPS Delta SIR1 After , sending :TGPSequence2 sets Second Delta SIR1 After , etc.). You can set TG Delta SIR After 1 for all four TGPSs using the CALL:COMPressed:TGPSequence:ALL:DSIR1:AFTer command.

Setting

Range: 0.0 to 3.0 dB

Resolution: 0.1

Query

 Same as setting

*RST Setting
  • First TGPS: 0
  • Second TGPS: 0
  • Third TGPS: 0
  • Fourth TGPS: 0
Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence2:DSIR1:AFTer 0"
! Sets the second TG Delta SIR1 After 1 to 0.

CALL:COMPressed:TGPSequence([1]|2|3|4):STATe

Function

Sets/queries <num> TGPS State for the first, second, third or fourth TGPS (sending :TGPSequence or :TGPSequence1 sets First TGPS State , sending :TGPSequence2 sets Second TGPS State , etc.). You can set TGPS State for all four TGPSs using the CALL:COMPressed:TGPSequence:ALL:STATe command.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting
  • First TGPS: 1
  • Second TGPS: 0
  • Third TGPS: 0
  • Fourth TGPS: 0

Requirements

 Lab Application Revision: D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence4:STATe On"
! Sets Fourth TGPS State to On.

CALL:COMPressed:TGPSequence([1]|2|3|4):TGCFn:RELative

Function

Sets/queries <num> TG Relative CFN (TGCFN) for the first, second, third or fourth TGPS (sending :TGPSequence or :TGPSequence1 sets First TG Relative CFN (TGCFN) , sending :TGPSequence2 sets Second TG Relative CFN (TGCFN) , etc.). You can set TG Relative CFN (TGCFN) for all four TGPSs using the CALL:COMPressed:TGPSequence:ALL:TGCFn:RELative command.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

The TGPSs must be offset so that there is never more than one transmission gap per frame.

Setting

Range: 0 to 255 frames

Resolution: 1 frame

Query

 Same as setting

*RST Setting
  • First TGPS: 0
  • Second TGPS: 2
  • Third TGPS: 6
  • Fourth TGPS: 14

Requirements

 Lab Application Revision: D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence4:TGCFn:RELative 12"
! Sets Fourth TG Relative CFN (TGCFN) to 12.

CALL:COMPressed:TGPSequence([1]|2|3|4):TGDistance

Function

Sets/queries <num> TG Start Distance (TGD) for the first, second, third or fourth TGPS (sending :TGPSequence or :TGPSequence1 sets First TG Start Distance (TGD) , sending :TGPSequence2 sets Second TG Start Distance (TGD) , etc.). You can set TG Start Distance (TGD) for all four TGPSs using the CALL:COMPressed:TGPSequence:ALL:TGDistance command.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

This setting is only applicable when TGL2 is non-zero. Note, you cannot place TGL1 and TGL2 within the same frame.

Setting

Range: 15 to 269 slots, 270 (undefined)

Resolution: 1 slot

Query

 Same as setting

*RST Setting
  • First TGPS: 270
  • Second TGPS: 270
  • Third TGPS: 270
  • Fourth TGPS: 270

Requirements

 Lab Application Revision: D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence3:TGDistance 60"
! Sets Third TG Start Distance (TGD) to 60 slots.

CALL:COMPressed:TGPSequence([1]|2|3|4):TGLength[1]

Function

Sets/queries <num> Transmission Gap Length 1 (TGL1) for the first, second, third or fourth TGPS (sending :TGPSequence or :TGPSequence1 sets First Transmission Gap Length 1 (TGL1) , sending :TGPSequence2 sets Second Transmission Gap Length 1 (TGL1) , etc.). You can set Transmission Gap Length 1 (TGL1) for all four TGPSs using the CALL:COMPressed:TGPSequence:ALL:TGLength[1] command.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

There cannot be more than 7 transmission gap slots within one frame.

Setting

Range: 1 to 14 slots

Resolution: 1 slot

Query

 Same as setting

*RST Setting
  • First TGPS: 7
  • Second TGPS: 7
  • Third TGPS: 7
  • Fourth TGPS: 7
Requirements

Lab Application Revision: B.01 and above

Lab Application Revision D.00.04, added ([1]|2|3|4) and [1]

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence4:TGLength 5"
! Sets Fourth Transmission Gap Length 1 (TGL1) to 5 slots.

CALL:COMPressed:TGPSequence([1]|2|3|4):TGLength2

Function

Sets/queries <num> Transmission Gap Length 2 (TGL2) for the first, second, third or fourth TGPS (sending :TGPSequence or :TGPSequence1 sets First Transmission Gap Length 2 (TGL2) , sending :TGPSequence2 sets Second Transmission Gap Length 2 (TGL2) , etc.). You can set Transmission Gap Length 2 (TGL2) for all four TGPSs using the CALL:COMPressed:TGPSequence:ALL:TGLength2 command.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

There cannot be more than 7 transmission gap slots within one frame. Also, if TGL2 is non-zero, you must specify a valid TGD.

Setting

Range: 0 to 14 slots

Resolution: 1 slot

Query

 Same as setting

*RST Setting
  • First TGPS: 0
  • Second TGPS: 0
  • Third TGPS: 0
  • Fourth TGPS: 0
Requirements Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence4:TGLength2 5"
! Sets Fourth Transmission Gap Length 2 (TGL2) to 5 slots.

CALL:COMPressed:TGPSequence([1]|2|3|4):TGMPurpose

Function

Sets/queries <num> TG Measurement Purpose (TGMP) for the first, second, third or fourth TGPS (sending :TGPSequence or :TGPSequence1 sets First TG Measurement Purpose (TGMP) , sending :TGPSequence2 sets Second TG Measurement Purpose (TGMP) , etc.). You can set TG Measurement Purpose (TGMP) for all four TGPSs using the CALL:COMPressed:TGPSequence:ALL:TGMPurpose command.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

Setting

Range: FDDMeas|GSMRssi|GIBI|GBR|EUTRa

Query

 Same as setting

*RST Setting
  • First TGPS: GSMR
  • Second TGPS: GIBI
  • Third TGPS: GBR
  • Fourth TGPS: FDDM
Requirements Lab Application Revision: D.00.04 and above
Lab Application Revision: H.01.00 and above, added EUTRa

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence4:TGMPurpose GBR"
! Sets Fourth TG Measurement Purpose (TGMP) to GSM BSIC Reconfirmation.

CALL:COMPressed:TGPSequence([1]|2|3|4):TGPLength

Function

Sets/queries <num> TG Pattern Length (TGPL) for the first, second, third or fourth TGPS (sending :TGPSequence or :TGPSequence1 sets First TG Pattern Length (TGPL) , sending :TGPSequence2 sets Second TG Pattern Length (TGPL) , etc.). You can set TG Pattern Length (TGPL) for all four TGPSs using the CALL:COMPressed:TGPSequence:ALL:TGPLength command.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

TGPL must be long enough to encompass all of TGL1 and TGL2.

Setting

Range: 1 to 144 frames

Resolution: 1 frame

Query

 Same as setting

*RST Setting
  • First TGPS: 4 frames
  • Second TGPS: 8 frames
  • Third TGPS: 16 frames
  • Fourth TGPS: 16 frames
Requirements

Lab Application Revision: B.01 and above

Lab Application Revision D.00.04, added ([1]|2|3|4)

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:TGPLength 6"
! Sets First TG Pattern Length (TGPL) to 6 frames.

CALL:COMPressed:TGPSequence([1]|2|3|4):TGPRc

Function

Sets/queries <num> TG Pattern Repetition Count (TGPRC) for the first, second, third or fourth TGPS (sending :TGPSequence or :TGPSequence1 sets First TG Pattern Repetition Count (TGPRC) , sending :TGPSequence2 sets Second TG Pattern Repetition Count (TGPRC) , etc.). You can set TG Pattern Repetition Count (TGPRC) for all four TGPSs using the CALL:COMPressed:TGPSequence:ALL:TGPRc command.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

Setting

Range: 0 to 511 (0 = infinity)

Query

 Same as setting

*RST Setting
  • First TGPS: 0
  • Second TGPS: 0
  • Third TGPS: 0
  • Fourth TGPS: 0
Requirements Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence4:TGPRc 20"
! Sets Fourth TG Pattern Repetition Count (TGPRC) to 20 repetitions.

CALL:COMPressed:TGPSequence([1]|2|3|4):TGSNumber

Function

Sets/queries <num> TG Starting Slot Number (TGSN) for the first, second, third or fourth TGPS (sending :TGPSequence or :TGPSequence1 sets First TG Starting Slot Number (TGSN) , sending :TGPSequence2 sets Second TG Starting Slot Number (TGSN) , etc.). You can set TG Starting Slot Number (TGSN) for all four TGPSs using the CALL:COMPressed:TGPSequence:ALL:TGSNumber command.

If TGPS Definition During Call Setup is set to Off , this parameter can only be changed when compressed mode is not active. If TGPS Definition During Call Setup is set to RB Setup , this parameter can only be changed when the connection status is idle.

Setting

Range: 0 to 14 (slot 0 to slot 14)

Resolution: 1

Query

 Same as setting

*RST Setting
  • First TGPS: 11 (slot 11)
  • Second TGPS: 11 (slot 11)
  • Third TGPS: 11 (slot 11)
  • Fourth TGPS: 11 (slot 11)
Requirements

Lab Application Revision: B.01 and above

Lab Application Revision D.00.04, added ([1]|2|3|4)

Programming Example

OUTPUT 714;"CALL:COMPressed:TGPSequence:TGSNumber 10"
! Sets First TG Starting Slot (TGSN) to slot 10.


CALL:CONNected

CALL:CONNected

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL:CONNected[:STATe]

  • CALL:CONNected:ARM[:IMMediate]

  • CALL:CONNected:ARM:STATe?

  • CALL:CONNected:CCPChannel:PRIMary[:SLEVel]
  • CALL:CONNected:CCPChannel:PRIMary[:SLEVel]:HSDPa
  • CALL:CONNected:CCPChannel:PRIMary[:SLEVel]:HSPA
  • CALL:CONNected:CCPChannel:PRIMary:LEVel
  • CALL:CONNected:CCPChannel:PRIMary:LEVel:HSDPa
  • CALL:CONNected:CCPChannel:PRIMary:LEVel:HSPA
  • CALL:CONNected:CCPChannel:PRIMary:STATe
  • CALL:CONNected:CCPChannel:PRIMary:STATe:HSDPa
  • CALL:CONNected:CCPChannel:PRIMary:STATe:HSPA
  • CALL:CONNected:CCPChannel:SECondary[:SLEVel]
  • CALL:CONNected:CCPChannel:SECondary[:SLEVel]:HSDPa
  • CALL:CONNected:CCPChannel:SECondary[:SLEVel]:HSPA
  • CALL:CONNected:CCPChannel:SECondary:LEVel
  • CALL:CONNected:CCPChannel:SECondary:LEVel:HSDPa
  • CALL:CONNected:CCPChannel:SECondary:LEVel:HSPA
  • CALL:CONNected:CCPChannel:SECondary:STATe
  • CALL:CONNected:CCPChannel:SECondary:STATe:HSDPa
  • CALL:CONNected:CCPChannel:SECondary:STATe:HSPA

  • CALL:CONNected:CPIChannel[:SLEVel]
  • CALL:CONNected:CPIChannel[:SLEVel]:HSDPa
  • CALL:CONNected:CPIChannel[:SLEVel]:HSPA
  • CALL:CONNected:CPIChannel:LEVel
  • CALL:CONNected:CPIChannel:LEVel:HSDPa
  • CALL:CONNected:CPIChannel:LEVel:HSPA
  • CALL:CONNected:CPIChannel:STATe
  • CALL:CONNected:CPIChannel:STATe:HSDPa
  • CALL:CONNected:CPIChannel:STATe:HSPA

  • CALL:CONNected:DPCHannel[:SLEVel]
  • CALL:CONNected:DPCHannel[:SLEVel]:HSDPa
  • CALL:CONNected:DPCHannel[:SLEVel]:HSPA
  • CALL:CONNected:DPCHannel:LEVel
  • CALL:CONNected:DPCHannel:LEVel:HSDPa
  • CALL:CONNected:DPCHannel:LEVel:HSPA
  • CALL:CONNected:DPCHannel:STATe
  • CALL:CONNected:DPCHannel:STATe:HSDPa
  • CALL:CONNected:DPCHannel:STATe:HSPA

  • CALL:CONNected:DROP:TIMer[:STATe][:SELected]
  • CALL:CONNected:DROP:TIMer[:STATe]:WCDMa

  • CALL:CONNected:EAGChannel[:SLEVel]
  • CALL:CONNected:EAGChannel:LEVel
  • CALL:CONNected:EAGChannel:STATe

  • CALL:CONNected:EHIChannel[:SLEVel]
  • CALL:CONNected:EHIChannel:LEVel
  • CALL:CONNected:EHIChannel:STATe

  • CALL:CONNected:ERGChannel[:SLEVel]
  • CALL:CONNected:ERGChannel:LEVel
  • CALL:CONNected:ERGChannel:STATe

  • CALL:CONNected:HSPDschannel[:SLEVel]
  • CALL:CONNected:HSPDschannel[:SLEVel]:HSPA
  • CALL:CONNected:HSPDschannel:LEVel
  • CALL:CONNected:HSPDschannel:LEVel:HSPA
  • CALL:CONNected:HSPDschannel:STATe
  • CALL:CONNected:HSPDschannel:STATe:HSPA

  • CALL:CONNected:HSSCchannel[1][:SLEVel]
  • CALL:CONNected:HSSCchannel[1][:SLEVel]:HSPA
  • CALL:CONNected:HSSCchannel[1]:LEVel
  • CALL:CONNected:HSSCchannel[1]:LEVel:HSPA
  • CALL:CONNected:HSSCchannel[1]:STATe
  • CALL:CONNected:HSSCchannel[1]:STATe:HSPA
  • CALL:CONNected:HSSCchannel2[:SLEVel]
  • CALL:CONNected:HSSCchannel2[:SLEVel]:HSPA
  • CALL:CONNected:HSSCchannel2:LEVel
  • CALL:CONNected:HSSCchannel2:LEVel:HSPA
  • CALL:CONNected:HSSCchannel2:STATe
  • CALL:CONNected:HSSCchannel2:STATe:HSPA
  • CALL:CONNected:HSSCchannel3[:SLEVel]
  • CALL:CONNected:HSSCchannel3[:SLEVel]:HSPA
  • CALL:CONNected:HSSCchannel3:LEVel
  • CALL:CONNected:HSSCchannel3:LEVel:HSPA
  • CALL:CONNected:HSSCchannel3:STATe
  • CALL:CONNected:HSSCchannel3:STATe:HSPA
  • CALL:CONNected:HSSCchannel4[:SLEVel]
  • CALL:CONNected:HSSCchannel4[:SLEVel]:HSPA
  • CALL:CONNected:HSSCchannel4:LEVel
  • CALL:CONNected:HSSCchannel4:LEVel:HSPA
  • CALL:CONNected:HSSCchannel4:STATe
  • CALL:CONNected:HSSCchannel4:STATe:HSPA

  • CALL:CONNected:LIMit[:STATe][:SELected]
  • CALL:CONNected:LIMit[:STATe]:WCDMa

  • CALL:CONNected:PICHannel[:SLEVel]
  • CALL:CONNected:PICHannel[:SLEVel]:HSDPa
  • CALL:CONNected:PICHannel[:SLEVel]:HSPA
  • CALL:CONNected:PICHannel:LEVel
  • CALL:CONNected:PICHannel:LEVel:HSDPa
  • CALL:CONNected:PICHannel:LEVel:HSPA
  • CALL:CONNected:PICHannel:STATe
  • CALL:CONNected:PICHannel:STATe:HSDPa
  • CALL:CONNected:PICHannel:STATe:HSPA

  • CALL:CONNected:TIMeout

CALL:CONNected[:STATe]

Function

Queries the connected/disconnected state of the call. A one is returned if the call is in the connected state. A zero is returned if the call is in the idle (disconnected) state. If the call is in any state other than connected or idle, the query will hang until the call state transitions to the connected or idle state.

When used in conjunction with the CALL:CONNected:ARM and CALL:CONNected:TIMeout commands, the CALL:CONNected:STATe? command allows the control program to synchronize to call connection/disconnection. See Connected/Idle Query and Call State Change Detector .

Query

Range: 0|1

*RST Setting

0
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:STATE?"
! returns 1 if call is connected, 0 if call is idle.

CALL:CONNected:ARM[:IMMediate]

Function

Sets (arms) the call-state-change detector. Arming this detector allows the control program to tell the test set that it is expecting a change in the state of a call, prior to initiating the state change.

Once armed, the detector remains armed until there is a call state change to Idle or Connected from one of the transitory states, nor is it disarmed by any transitions from Idle to Idle or Connected to Connected.

When used in conjunction with the CALL CONNected:STATe? and the CALL:CONNected: TIMeout commands, the CALL:CONNected:ARM command allows the control program to synchronize with call processing state changes. See Call State Change Detector .

For an explanation of the :DONE?, :OPComplete?, :SEQuential, and :WAIT commands, s ee Call Processing Event Synchronization .
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:ARM:IMMEDIATE"
! Arms the call-state-change detector.

CALL:CONNected:ARM:STATe?

Function

Queries the arm state of the call-state-change detector. This command never hangs and immediately returns a one if the detector is armed, or a zero if the detector is not armed. See Call State Change Detector

Query

Range: 1|0

*RST Setting

0
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONN:ARM:STATE?"
! Returns arm state of the call-state-change detector.

CALL:CONNected:CCPChannel:PRIMary[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the Cell 1 Connected P-CCPCH/SCH Level (see CALL:CONNected:CCPChannel:PRIMary:LEVel ) and (2) sets the Cell 1 Connected P-CCPCH/SCH state to on (see CALL:CONNected:CCPChannel:PRIMary:STATe ).

The query form of this command returns the Cell 1 Connected P-CCPCH/SCH Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -5.35 dB (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:PRIMary -7"
! Sets P-CCPCH connected power offset to -7 dB and turns its state on.

CALL:CONNected:CCPChannel:PRIMary[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the HSDPA Cell 1 Connected P-CCPCH/SCH Level (see CALL:CONNected:CCPChannel:PRIMary:LEVel:HSDPa ) and (2) sets the HSDPA Cell 1 Connected P-CCPCH/SCH state to on (see CALL:CONNected:CCPChannel:PRIMary:STATe:HSDPa ).

The query form of this command returns the HSDPA Cell 1 Connected P-CCPCH/SCH Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -12 dB (on)
Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:PRIMary:HSDPa -7"
! Sets HSDPA P-CCPCH connected power offset to -7 dB and turns its state on.

CALL:CONNected:CCPChannel:PRIMary[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA Cell 1 Connected P-CCPCH/SCH Level (see CALL:CONNected:CCPChannel:PRIMary:LEVel:HSPA ) and (2) sets the HSPA Cell 1 Connected P-CCPCH/SCH state to on (see CALL:CONNected:CCPChannel:PRIMary:STATe:HSPA ).

The query form of this command returns the HSPA Cell 1 Connected P-CCPCH/SCH Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -12 dB (on)
Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:PRIMary:HSPA -7"
! Sets HSPA P-CCPCH connected power offset to -7 dB and turns its state on.

CALL:CONNected:CCPChannel:PRIMary:LEVel

Function

Sets/queries the Cell 1 Connected P-CCPCH/SCH Level .

The Cell 1 Connected P-CCPCH/SCH Level can also be set using the CALL:CONNected:CCPChannel:PRIMary[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -5.35 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:PRIMary:LEVel -7"

CALL:CONNected:CCPChannel:PRIMary:LEVel:HSDPa

Function

Sets/queries the HSDPA Cell 1 Connected P-CCPCH/SCH Level .

The HSDPA Cell 1 Connected P-CCPCH/SCH Level can also be set using the CALL:CONNected:CCPChannel:PRIMary[:SLEVel]:HSDPa command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -12 dB
Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:PRIMary:LEVel:HSDPa -7"

CALL:CONNected:CCPChannel:PRIMary:LEVel:HSPA

Function

Sets/queries the HSPA Cell 1 Connected P-CCPCH/SCH Level .

The HSPA Cell 1 Connected P-CCPCH/SCH Level can also be set using the CALL:CONNected:CCPChannel:PRIMary[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -12 dB
Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:PRIMary:LEVel:HSPA -7"

CALL:CONNected:CCPChannel:PRIMary:STATe

Function

Sets/queries the Cell 1 Connected P-CCPCH/SCH state.

The Cell 1 Connected P-CCPCH/SCH state can also be set using the CALL:CONNected:CCPChannel:PRIMary[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:PRIMary:STATe ON"

CALL:CONNected:CCPChannel:PRIMary:STATe:HSDPa

Function

Sets/queries the HSDPA Cell 1 Connected P-CCPCH/SCH state.

The HSDPA Cell 1 Connected P-CCPCH/SCH state can also be set using the CALL:CONNected:CCPChannel:PRIMary[:SLEVel]:HSDPa command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:PRIMary:STATe:HSDPa ON"

CALL:CONNected:CCPChannel:PRIMary:STATe:HSPA

Function

Sets/queries the HSPA Cell 1 Connected P-CCPCH/SCH state.

The HSPA Cell 1 Connected P-CCPCH/SCH state can also be set using the CALL:CONNected:CCPChannel:PRIMary[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:PRIMary:STATe:HSPA ON"

CALL:CONNected:CCPChannel:SECondary[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the Cell 1 Connected S-CCPCH Level (see CALL:CONNected:CCPChannel:SECondary:LEVel ) and (2) sets the Cell 1 Connected S-CCPCH state to on (see CALL:CONNected:CCPChannel:SECondary:STATe ).

The query form of this command returns the Cell 1 Connected S-CCPCH Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20.00 dB (off)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:SECondary -10"
! Sets S-CCPCH connected power offset to -10 dB and turns its state on.

CALL:CONNected:CCPChannel:SECondary[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the HSDPA Cell 1 Connected S-CCPCH Level (see CALL:CONNected:CCPChannel:SECondary:LEVel:HSDPa ) and (2) sets the HSDPA Cell 1 Connected S-CCPCH state to on (see CALL:CONNected:CCPChannel:SECondary:STATe:HSDPa ).

The query form of this command returns the HSDPA Cell 1 Connected S-CCPCH Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20.00 dB (off)
Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:SECondary:HSDPa -10"
! Sets HSDPA S-CCPCH connected power offset to -10 dB and turns its state on.

CALL:CONNected:CCPChannel:SECondary[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA Cell 1 Connected S-CCPCH Level (see CALL:CONNected:CCPChannel:SECondary:LEVel:HSPA ) and (2) sets the HSPA Cell 1 Connected S-CCPCH state to on (see CALL:CONNected:CCPChannel:SECondary:STATe:HSPA ).

The query form of this command returns the HSPA Cell 1 Connected S-CCPCH Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20.00 dB (off)
Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:SECondary:HSPA -10"
! Sets HSPA S-CCPCH connected power offset to -10 dB and turns its state on.

CALL:CONNected:CCPChannel:SECondary:LEVel

Function

Sets/queries the Cell 1 Connected S-CCPCH Level .

The Cell 1 Connected S-CCPCH Level can also be set using the CALL:CONNected:CCPChannel:SECondary[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20.00 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:SECondary:LEVel -5"

CALL:CONNected:CCPChannel:SECondary:LEVel:HSDPa

Function

Sets/queries the HSDPA Cell 1 Connected S-CCPCH Level .

The HSDPA Cell 1 Connected S-CCPCH Level can also be set using the CALL:CONNected:CCPChannel:SECondary[:SLEVel]:HSDPa command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20.00 dB
Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:SECondary:LEVel:HSDPa -5"

CALL:CONNected:CCPChannel:SECondary:LEVel:HSPA

Function

Sets/queries the HSPA Cell 1 Connected S-CCPCH Level .

The HSPA Cell 1 Connected S-CCPCH Level can also be set using the CALL:CONNected:CCPChannel:SECondary[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20.00 dB
Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:SECondary:LEVel:HSPA -5"

CALL:CONNected:CCPChannel:SECondary:STATe

Function

Sets/queries the Cell 1 Connected S-CCPCH state.

The Cell 1 Connected S-CCPCH state can also be set using the CALL:CONNected:CCPChannel:SECondary[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:SECondary:STATe OFF"

CALL:CONNected:CCPChannel:SECondary:STATe:HSDPa

Function

Sets/queries the HSDPA Cell 1 Connected S-CCPCH state.

The HSDPA Cell 1 Connected S-CCPCH state can also be set using the CALL:CONNected:CCPChannel:SECondary[:SLEVel]:HSDPa command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)
Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:SECondary:STATe:HSDPa OFF"

CALL:CONNected:CCPChannel:SECondary:STATe:HSPA

Function

Sets/queries the HSPA Cell 1 Connected S-CCPCH state.

The HSPA Cell 1 Connected S-CCPCH state can also be set using the CALL:CONNected:CCPChannel:SECondary[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)
Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:CCPChannel:SECondary:STATe:HSPA OFF"

CALL:CONNected:CPIChannel[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the Cell 1 Connected CPICH Level (see CALL:CONNected:CPIChannel:LEVel ) and (2) sets the Cell 1 Connected CPICH state to on (see CALL:CONNected:CPIChannel:STATe ).

The query form of this command returns the Cell 1 Connected CPICH Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -3.30 dB (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CPIChannel -7"
! Sets CPICH connected power offset to -7 dB and turns its state on.

CALL:CONNected:CPIChannel[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the HSDPA Cell 1 Connected CPICH Level (see CALL:CONNected:CPIChannel:LEVel:HSDPa ) and (2) sets the HSDPA Cell 1 Connected CPICH state to on (see CALL:CONNected:CPIChannel:STATe:HSDPa ).

The query form of this command returns the HSDPA Cell 1 Connected CPICH Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB (on)
Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CPIChannel:HSDPa -7"
! Sets HSDPA CPICH connected power offset to -7 dB and turns its state on.

CALL:CONNected:CPIChannel[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA Cell 1 Connected CPICH Level (see CALL:CONNected:CPIChannel:LEVel:HSPA ) and (2) sets the HSPA Cell 1 Connected CPICH state to on (see CALL:CONNected:CPIChannel:STATe:HSPA ).

The query form of this command returns the HSPA Cell 1 Connected CPICH Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB (on)
Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CPIChannel:HSPA -7"
! Sets HSPA CPICH connected power offset to -7 dB and turns its state on.

CALL:CONNected:CPIChannel:LEVel

Function

Sets/queries the Cell 1 Connected CPICH Level .

The Cell 1 Connected CPICH Level can also be set using the CALL:CONNected:CPIChannel[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -3.30 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CPIChannel:LEVel -7"

CALL:CONNected:CPIChannel:LEVel:HSDPa

Function

Sets/queries the HSDPA Cell 1 Connected CPICH Level .

The HSDPA Cell 1 Connected CPICH Level can also be set using the CALL:CONNected:CPIChannel[:SLEVel]:HSDPa command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB
Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CPIChannel:LEVel:HSDPa -7"

CALL:CONNected:CPIChannel:LEVel:HSPA

Function

Sets/queries the HSPA Cell 1 Connected CPICH Level .

The HSPA Cell 1 Connected CPICH Level can also be set using the CALL:CONNected:CPIChannel[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB
Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CPIChannel:LEVel:HSPA -7"

CALL:CONNected:CPIChannel:STATe

Function

Sets/queries the Cell 1 Connected CPICH state.

The Cell 1 Connected CPICH state can also be set using the CALL:CONNected:CPIChannel[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (ON)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CPIChannel:STATe ON"

CALL:CONNected:CPIChannel:STATe:HSDPa

Function

Sets/queries the HSDPA Cell 1 Connected CPICH state.

The HSDPA Cell 1 Connected CPICH state can also be set using the CALL:CONNected:CPIChannel[:SLEVel]:HSDPa command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (ON)
Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CPIChannel:STATe:HSDPa ON"

CALL:CONNected:CPIChannel:STATe:HSPA

Function

Sets/queries the HSPA Cell 1 Connected CPICH state.

The HSPA Cell 1 Connected CPICH state can also be set using the CALL:CONNected:CPIChannel[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (ON)
Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:CONNected:CPIChannel:STATe:HSPA ON"

CALL:CONNected:DPCHannel[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the Cell 1 Connected DPCH Level (see CALL:CONNected:DPCHannel:LEVel ) and (2) sets the Cell 1 Connected DPCH state to on (see CALL:CONNected:DPCHannel:STATe ).

The query form of this command returns the Cell 1 Connected DPCH Level .

See Connected DL Channel Levels .

Setting

Range: -30.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10.30 dB (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNected:DPCHannel -7"
! Sets DPCH connected power offset to -7 dB and turns its state on.

CALL:CONNected:DPCHannel[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the HSDPA Cell 1 Connected DPCH Level (see CALL:CONNected:DPCHannel:LEVel:HSDPa ) and (2) sets the HSDPA Cell 1 Connected DPCH state to on (see CALL:CONNected:DPCHannel:STATe:HSDPa ).

The query form of this command returns the HSDPA Cell 1 Connected DPCH Level .

See Connected DL Channel Levels .

Setting

Range: -30.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB (on)
Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:DPCHannel:HSDPa -7"
! Sets HSDPA DPCH connected power offset to -7 dB and turns its state on.

CALL:CONNected:DPCHannel[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA Cell 1 Connected DPCH Level (see CALL:CONNected:DPCHannel:LEVel:HSPA ) and (2) sets the HSPA Cell 1 Connected DPCH state to on (see CALL:CONNected:DPCHannel:STATe:HSPA ).

The query form of this command returns the HSPA Cell 1 Connected DPCH Level .

See Connected DL Channel Levels .

Setting

Range: -30.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB (on)
Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:DPCHannel:HSPA -7"
! Sets HSPA DPCH connected power offset to -7 dB and turns its state on.

CALL:CONNected:DPCHannel:LEVel

Function

Sets/queries the Cell 1 Connected DPCH Level .

The Cell 1 Connected DPCH Level can also be set using the CALL:CONNected:DPCHannel[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: -30.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10.30 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNected:DPCHannel:LEVel -7"

CALL:CONNected:DPCHannel:LEVel:HSDPa

Function

Sets/queries the HSDPA Cell 1 Connected DPCH Level .

The HSDPA Cell 1 Connected DPCH Level can also be set using the CALL:CONNected:DPCHannel[:SLEVel]:HSDPa command.

See Connected DL Channel Levels .

Setting

Range: -30.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB
Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:DPCHannel:LEVel:HSDPa -7"

CALL:CONNected:DPCHannel:LEVel:HSPA

Function

Sets/queries the HSPA Cell 1 Connected DPCH Level .

The HSPA Cell 1 Connected DPCH Level can also be set using the CALL:CONNected:DPCHannel[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: -30.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB
Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:DPCHannel:LEVel:HSPA -7"

CALL:CONNected:DPCHannel:STATe

Function

Sets/queries the Cell 1 Connected DPCH state.

The Cell 1 Connected DPCH state can also be set using the CALL:CONNected:DPCHannel[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNected:DPCHannel:STATe ON"

CALL:CONNected:DPCHannel:STATe:HSDPa

Function

Sets/queries the HSDPA Cell 1 Connected DPCH state.

The HSDPA Cell 1 Connected DPCH state can also be set using the CALL:CONNected:DPCHannel[:SLEVel]:HSDPa command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:DPCHannel:STATe:HSDPa ON"

CALL:CONNected:DPCHannel:STATe:HSPA

Function

Sets/queries the HSPA Cell 1 Connected DPCH state.

The HSPA Cell 1 Connected DPCH state can also be set using the CALL:CONNected:DPCHannel[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:DPCHannel:STATe:HSPA ON"

CALL:CONNected:DROP:TIMer[:STATe][:SELected]

Function

Sets/queries the call drop timer. The call drop timer indicates loss of uplink. This timer also determines when the demodulation of the uplink has been unsuccessful for a fixed period.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:DROP:TIMER:STATE 0"

CALL:CONNected:DROP:TIMer[:STATe]:WCDMa

Function

Sets/queries the call drop timer for the WCDMA format, whether or not that format is active. The call drop timer indicates loss of uplink. This timer also determines when the demodulation of the uplink has been unsuccessful for a fixed period.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:DROP:TIMER:STATE:WCDMA 0"

CALL:CONNected:EAGChannel[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the HSPA Cell 1 Connected E-AGCH Level (see CALL:CONNected:EAGChannel:LEVel ) and (2) sets the Cell 1 Connected E-AGCH state to on (see CALL:CONNected:EAGChannel:STATe ).

The query form of this command returns the HSPA Cell 1 Connected E-AGCH Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20 dB (on)

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:CONNected:EAGChannel -20"
! Sets the HSPA Cell 1 Connected E-AGCH Level
 to -20 dB and turns its state on.

CALL:CONNected:EAGChannel:LEVel

Function

Sets/queries the HSPA Cell 1 Connected E-AGCH Level .

The HSPA Cell 1 Connected E-AGCH Level can also be set using the CALL:CONNected:EAGChannel[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20 dB

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:CONNected:EAGChannel:LEVel -20"

CALL:CONNected:EAGChannel:STATe

Function

Sets/queries the HSPA Cell 1 Connected E-AGCH Level state.

The HSPA Cell 1 Connected E-AGCH Level state can also be set using the CALL:CONNected:EAGChannel[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:CONNected:EAGChannel:STATe ON"

CALL:CONNected:EHIChannel[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the HSPA Cell 1 Connected E-HICH Level (see CALL:CONNected:EHIChannel:LEVel ) and (2) sets the HSPA Cell 1 Connected E-HICH Level state to on (see CALL:CONNected:EHIChannel:STATe ).

The query form of this command returns the HSPA Cell 1 Connected E-HICH Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20 dB (on)

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:CONNected:EHIChannel -20"
! Sets the HSPA Cell 1 Connected E-HICH Level
 to -20 dB and turns its state on.

CALL:CONNected:EHIChannel:LEVel

Function

Sets/queries the HSPA Cell 1 Connected E-HICH Level .

The HSPA Cell 1 Connected E-HICH Level can also be set using the CALL:CONNected:EHIChannel[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20 dB

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:CONNected:EHIChannel:LEVel -20"

CALL:CONNected:EHIChannel:STATe

Function

Sets/queries the HSPA Cell 1 Connected E-HICH Level state.

The HSPA Cell 1 Connected E-HICH Level state can also be set using the CALL:CONNected:EHIChannel[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:CONNected:EHIChannel:STATe ON"

CALL:CONNected:ERGChannel[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the HSPA Cell 1 Connected E-RGCH Level (see CALL:CONNected:ERGChannel:LEVel ) and (2) sets the HSPA Cell 1 Connected E-RGCH Level state to on (see CALL:CONNected:ERGChannel:STATe ).

The query form of this command returns the HSPA Cell 1 Connected E-RGCH Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20 dB (off)

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:CONNected:ERGChannel -20"
! Sets the HSPA Cell 1 Connected E-RGCH Level
 to -20 dB and turns its state on.

CALL:CONNected:ERGChannel:LEVel

Function

Sets/queries the HSPA Cell 1 Connected E-RGCH Level .

The HSPA Cell 1 Connected E-RGCH Level can also be set using the CALL:CONNected:ERGChannel[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20 dB

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:CONNected:ERGChannel:LEVel -20"

CALL:CONNected:ERGChannel:STATe

Function

Sets/queries the HSPA Cell 1 Connected E-RGCH Level state.

The HSPA Cell 1 Connected E-RGCH Level state can also be set using the CALL:CONNected:ERGChannel[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:CONNected:ERGChannel:STATe OFF"

CALL:CONNected:HSPDschannel[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) (see CALL:CONNected:HSPDschannel:LEVel ) and (2) sets the HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) state to on (see CALL:CONNected:HSPDschannel:STATe ).

The query form of this command returns the HSDPA Cell 1 Sum of Active Conn HS-PDSCH Levels .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -3 dB (on)

Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:HSPDschannel -4"
! Sets the Cell 1 Sum of Active Conn HS-PDSCH Levels
 to -4 dB and turns its state on.

CALL:CONNected:HSPDschannel[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA Cell 1 Connected HS-PDSCHs Level (Sum) (see CALL:CONNected:HSPDschannel:LEVel:HSPA ) and (2) sets the HSPA Cell 1 Connected HS-PDSCHs Level (Sum) state to on (see CALL:CONNected:HSPDschannel:STATe:HSPA ).

The query form of this command returns the HSPA Cell 1 Sum of Active Conn HS-PDSCH Levels .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -3 dB (on)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:HSPDschannel:HSPA -4"
! Sets the HSPA Cell 1 Sum of Active Conn HS-PDSCH Levels
 to -4 dB and turns its state on.

CALL:CONNected:HSPDschannel:LEVel

Function

Sets/queries the HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) .

The HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) can also be set using the CALL:CONNected:HSPDschannel[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -3 dB

Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:HSPDschannel:LEVel -4"

CALL:CONNected:HSPDschannel:LEVel:HSPA

Function

Sets/queries the HSPA Cell 1 Connected HS-PDSCHs Level (Sum).

The HSPA Cell 1 Connected HS-PDSCHs Level (Sum) can also be set using the CALL:CONNected:HSPDschannel[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -3 dB

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:HSPDschannel:LEVel:HSPA -4"

CALL:CONNected:HSPDschannel:STATe

Function

Sets/queries the HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) state.

The HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) state can also be set using the CALL:CONNected:HSPDschannel[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:HSPDschannel:STATe ON"

CALL:CONNected:HSPDschannel:STATe:HSPA

Function

Sets/queries the HSPA Cell 1 Connected HS-PDSCHs Level (Sum) state.

The HSPA Cell 1 Connected HS-PDSCHs Level (Sum) state can also be set using the CALL:CONNected:HSPDschannel[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:HSPDschannel:STATe:HSPA ON"

CALL:CONNected:HSSCchannel[1][:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the HSDPA Cell 1 Connected HS-SCCH 1 Level (see CALL:CONNected:HSSCchannel[1]:LEVel ) and (2) sets the HSDPA Cell 1 Connected HS-SCCH 1 Level state to on (see CALL:CONNected:HSSCchannel[1]:STATe ).

The query form of this command returns the HSDPA Cell 1 Connected HS-SCCH 1 Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB (on)

Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel -11"
! Sets the Cell 1 Connected HS-SCCH 1 Level

 to -11 dB and turns its state on.

CALL:CONNected:HSSCchannel[1][:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA Cell 1 Connected HS-SCCH 1 Level (see CALL:CONNected:HSSCchannel[1]:LEVel:HSPA ) and (2) sets the HSPA Cell 1 Connected HS-SCCH 1 Level state to on (see CALL:CONNected:HSSCchannel[1]:STATe:HSPA ).

The query form of this command returns the HSPA Cell 1 Connected HS-SCCH 1 Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB (on)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel:HSPA -11"
! Sets the HSPA Cell 1 Connected HS-SCCH 1 Level

 to -11 dB and turns its state on.

CALL:CONNected:HSSCchannel[1]:LEVel

Function

Sets/queries the HSDPA Cell 1 Connected HS-SCCH 1 Level .

The HSDPA Cell 1 Connected HS-SCCH 1 Level can also be set using the CALL:CONNected:HSSCchannel[1][:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB

Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel:LEVel -11"

CALL:CONNected:HSSCchannel[1]:LEVel:HSPA

Function

Sets/queries the HSPA Cell 1 Connected HS-SCCH 1 Level .

The HSPA Cell 1 Connected HS-SCCH 1 Level can also be set using the CALL:CONNected:HSSCchannel[1][:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel:LEVel:HSPA -11"

CALL:CONNected:HSSCchannel[1]:STATe

Function

Sets/queries the HSDPA Cell 1 Connected HS-SCCH 1 Level state.

The HSDPA Cell 1 Connected HS-SCCH 1 Level state can also be set using the CALL:CONNected:HSSCchannel[1][:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel:STATe ON"

CALL:CONNected:HSSCchannel[1]:STATe:HSPA

Function

Sets/queries the HSPA Cell 1 Connected HS-SCCH 1 Level state.

The HSPA Cell 1 Connected HS-SCCH 1 Level state can also be set using the CALL:CONNected:HSSCchannel[1][:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel:STATe:HSPA ON"

CALL:CONNected:HSSCchannel2[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the HSDPA Cell 1 Connected HS-SCCH 2 Level (see CALL:CONNected:HSSCchannel2:LEVel ) and (2) sets the HSDPA Cell 1 Connected HS-SCCH 2 Level state to on (see CALL:CONNected:HSSCchannel2:STATe ).

The query form of this command returns the HSDPA Cell 1 Connected HS-SCCH 2 Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB (off)

Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel2 -11"
! Sets the Cell 1 Connected HS-SCCH 2 Level

 to -11 dB and turns its state on.

CALL:CONNected:HSSCchannel2[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA Cell 1 Connected HS-SCCH 2 Level (see CALL:CONNected:HSSCchannel2:LEVel:HSPA ) and (2) sets the HSPA Cell 1 Connected HS-SCCH 2 Level state to on (see CALL:CONNected:HSSCchannel2:STATe:HSPA ).

The query form of this command returns the HSPA Cell 1 Connected HS-SCCH 2 Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB (off)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel2:HSPA -11"
! Sets the HSPA Cell 1 Connected HS-SCCH 2 Level

 to -11 dB and turns its state on.

CALL:CONNected:HSSCchannel2:LEVel

Function

Sets/queries the HSDPA Cell 1 Connected HS-SCCH 2 Level .

The HSDPA Cell 1 Connected HS-SCCH 2 Level can also be set using the CALL:CONNected:HSSCchannel2[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB

Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel2:LEVel -11"

CALL:CONNected:HSSCchannel2:LEVel:HSPA

Function

Sets/queries the HSPA Cell 1 Connected HS-SCCH 2 Level .

The HSPA Cell 1 Connected HS-SCCH 2 Level can also be set using the CALL:CONNected:HSSCchannel2[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel2:LEVel:HSPA -11"

CALL:CONNected:HSSCchannel2:STATe

Function

Sets/queries the HSDPA Cell 1 Connected HS-SCCH 2 Level state.

The HSDPA Cell 1 Connected HS-SCCH 2 Level state can also be set using the CALL:CONNected:HSSCchannel2[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel2:STATe ON"

CALL:CONNected:HSSCchannel2:STATe:HSPA

Function

Sets/queries the HSPA Cell 1 Connected HS-SCCH 2 Level state.

The HSPA Cell 1 Connected HS-SCCH 2 Level state can also be set using the CALL:CONNected:HSSCchannel2[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel2:STATe:HSPA ON"

CALL:CONNected:HSSCchannel3[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the HSDPA Cell 1 Connected HS-SCCH 3 Level (see CALL:CONNected:HSSCchannel3:LEVel ) and (2) sets the HSDPA Cell 1 Connected HS-SCCH 3 Level state to on (see CALL:CONNected:HSSCchannel3:STATe ).

The query form of this command returns the HSDPA Cell 1 Connected HS-SCCH 3 Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB (off)

Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel3 -11"
! Sets the Cell 1 Connected HS-SCCH 3 Level

 to -11 dB and turns its state on.

CALL:CONNected:HSSCchannel3[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA Cell 1 Connected HS-SCCH 3 Level (see CALL:CONNected:HSSCchannel3:LEVel:HSPA ) and (2) sets the HSPA Cell 1 Connected HS-SCCH 3 Level state to on (see CALL:CONNected:HSSCchannel3:STATe:HSPA ).

The query form of this command returns the HSPA Cell 1 Connected HS-SCCH 3 Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB (off)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel3:HSPA -11"
! Sets the HSPA Cell 1 Connected HS-SCCH 3 Level

 to -11 dB and turns its state on.

CALL:CONNected:HSSCchannel3:LEVel

Function

Sets/queries the HSDPA Cell 1 Connected HS-SCCH 3 Level .

The HSDPA Cell 1 Connected HS-SCCH 3 Level can also be set using the CALL:CONNected:HSSCchannel3[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB

Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel3:LEVel -11"

CALL:CONNected:HSSCchannel3:LEVel:HSPA

Function

Sets/queries the HSPA Cell 1 Connected HS-SCCH 3 Level .

The HSPA Cell 1 Connected HS-SCCH 3 Level can also be set using the CALL:CONNected:HSSCchannel3[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel3:LEVel:HSPA -11"

CALL:CONNected:HSSCchannel3:STATe

Function

Sets/queries the HSDPA Cell 1 Connected HS-SCCH 3 Level state.

The HSDPA Cell 1 Connected HS-SCCH 3 Level state can also be set using the CALL:CONNected:HSSCchannel3[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel3:STATe ON"

CALL:CONNected:HSSCchannel3:STATe:HSPA

Function

Sets/queries the HSPA Cell 1 Connected HS-SCCH 3 Level state.

The HSPA Cell 1 Connected HS-SCCH 3 Level state can also be set using the CALL:CONNected:HSSCchannel3[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel3:STATe:HSPA ON"

CALL:CONNected:HSSCchannel4[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the HSDPA Cell 1 Connected HS-SCCH 4 Level (see CALL:CONNected:HSSCchannel4:LEVel ) and (2) sets the HSDPA Cell 1 Connected HS-SCCH 4 Level state to on (see CALL:CONNected:HSSCchannel4:STATe ).

The query form of this command returns the HSDPA Cell 1 Connected HS-SCCH 4 Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB (off)

Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel4 -11"
! Sets the Cell 1 Connected HS-SCCH 4 Level

 to -11 dB and turns its state on.

CALL:CONNected:HSSCchannel4[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA Cell 1 Connected HS-SCCH 4 Level (see CALL:CONNected:HSSCchannel4:LEVel:HSPA ) and (2) sets the HSPA Cell 1 Connected HS-SCCH 4 Level state to on (see CALL:CONNected:HSSCchannel4:STATe:HSPA ).

The query form of this command returns the HSPA Cell 1 Connected HS-SCCH 4 Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB (off)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel4:HSPA -11"
! Sets the HSPA Cell 1 Connected HS-SCCH 4 Level

 to -11 dB and turns its state on.

CALL:CONNected:HSSCchannel4:LEVel

Function

Sets/queries the HSDPA Cell 1 Connected HS-SCCH 4 Level .

The HSDPA Cell 1 Connected HS-SCCH 4 Level can also be set using the CALL:CONNected:HSSCchannel4[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB

Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel4:LEVel -11"

CALL:CONNected:HSSCchannel4:LEVel:HSPA

Function

Sets/queries the HSPA Cell 1 Connected HS-SCCH 4 Level .

The HSPA Cell 1 Connected HS-SCCH 4 Level can also be set using the CALL:CONNected:HSSCchannel4[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel4:LEVel:HSPA -11"

CALL:CONNected:HSSCchannel4:STATe

Function

Sets/queries the HSDPA Cell 1 Connected HS-SCCH 4 Level state.

The HSDPA Cell 1 Connected HS-SCCH 4 Level state can also be set using the CALL:CONNected:HSSCchannel4[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel4:STATe ON"

CALL:CONNected:HSSCchannel4:STATe:HSPA

Function

Sets/queries the HSPA Cell 1 Connected HS-SCCH 4 Level state.

The HSPA Cell 1 Connected HS-SCCH 4 Level state can also be set using the CALL:CONNected:HSSCchannel4[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:HSSCchannel4:STATe:HSPA ON"

CALL:CONNected:LIMit[:STATe][:SELected]

Function

Sets/queries the call limit state for current selected format (only WCDMA format is available now).

When the call limit state is on, the test set does not respond to PRACH preambles for paging responses from the UE. It forces the UE to repeatedly send PRACH preambles.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (OFF)
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:LIMIT:STATE 1"

CALL:CONNected:LIMit[:STATe]:WCDMa

Function

Sets/queries the call limit state for the WCDMA format, whether or not that format is active.

When the call limit state is on, the test set does not respond to PRACH preambles from the UE. This allows you to make power measurements on the PRACH preambles.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (OFF)
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:LIMIT:STATE:WCDMA 1"

CALL:CONNected:PICHannel[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the Cell 1 Connected PICH Level (see CALL:CONNected:PICHannel:LEVel ) and (2) sets the Cell 1 Connected PICH state to on (see CALL:CONNected:PICHannel:STATe ).

The query form of this command returns the Cell 1 Connected PICH Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -8.33 dB (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNected:PICHannel -7"
! Sets PICH connected power offset to -7 dB and turns its state on.

CALL:CONNected:PICHannel[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the HSDPA Cell 1 Connected PICH Level (see CALL:CONNected:PICHannel:LEVel:HSDPa ) and (2) sets the HSDPA Cell 1 Connected PICH state to on (see CALL:CONNected:PICHannel:STATe:HSDPa ).

The query form of this command returns the HSDPA Cell 1 Connected PICH Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB (on)
Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:PICHannel:HSDPa -7"
! Sets HSDPA PICH connected power offset to -7 dB and turns its state on.

CALL:CONNected:PICHannel[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA Cell 1 Connected PICH Level (see CALL:CONNected:PICHannel:LEVel:HSPA ) and (2) sets the HSPA Cell 1 Connected PICH state to on (see CALL:CONNected:PICHannel:STATe:HSPA ).

The query form of this command returns the HSPA Cell 1 Connected PICH Level .

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB (on)
Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:PICHannel:HSPA -7"
! Sets HSDPA PICH connected power offset to -7 dB and turns its state on.

CALL:CONNected:PICHannel:LEVel

Function

Sets/queries the Cell 1 Connected PICH Level .

The Cell 1 Connected PICH Level can also be set using the CALL:CONNected:PICHannel[:SLEVel] command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -8.33 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNected:PICHannel:LEVEL -7"

CALL:CONNected:PICHannel:LEVel:HSDPa

Function

Sets/queries the HSDPA Cell 1 Connected PICH Level .

The HSDPA Cell 1 Connected PICH Level can also be set using the CALL:CONNected:PICHannel[:SLEVel]:HSDPa command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB
Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:PICHannel:LEVEL:HSDPa -7"

CALL:CONNected:PICHannel:LEVel:HSPA

Function

Sets/queries the HSPA Cell 1 Connected PICH Level .

The HSPA Cell 1 Connected PICH Level can also be set using the CALL:CONNected:PICHannel[:SLEVel]:HSPA command.

See Connected DL Channel Levels .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB
Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:PICHannel:LEVEL:HSPA -7"

CALL:CONNected:PICHannel:STATe

Function

Sets/queries the Cell 1 Connected PICH state.

The Cell 1 Connected PICH state can also be set using the CALL:CONNected:PICHannel:STATe command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (ON)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNected:PICHannel:STATe OFF"

CALL:CONNected:PICHannel:STATe:HSDPa

Function

Sets/queries the HSDPA Cell 1 Connected PICH state.

The HSDPA Cell 1 Connected PICH state can also be set using the CALL:CONNected:PICHannel:STATe:HSDPa command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (ON)
Requirements

Test Application Revision: A.08.20 and above, with the required feature license.

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CONNected:PICHannel:STATe:HSDPa OFF"

CALL:CONNected:PICHannel:STATe:HSPA

Function

Sets/queries the HSPA Cell 1 Connected PICH state.

The HSPA Cell 1 Connected PICH state can also be set using the CALL:CONNected:PICHannel:STATe:HSPA command.

See Connected DL Channel Levels .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (ON)
Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:CONNected:PICHannel:STATe:HSPA OFF"

CALL:CONNected:TIMeout

Function

Sets/queries the maximum time the test set will wait for a hanging CALL:CONNected:STATe? query to complete. Default setting units are seconds. To set timeout time in units other than seconds, include an optional unit specifier in the command string.

A timeout timer is started whenever the call-state-change detector becomes armed or gets rearmed when already armed. The duration of this timeout is set using the CALL:CONNected:TIMeout command and should be greater than the maximum amount of time the control program needs to wait between arming the call-state-change detector and the connect/disconnect operation starting. Once the process starts and the call state has moved to one of the transitory states, the W-CDMA defined protocol timers take over and prevent the call state from staying in a transitory state forever. See Call Processing State Synchronization .

Setting

Range: 0 to 100 seconds
Resolution: 0.1 seconds

Query

Range: 0 to 100 seconds
Resolution: 0.1 seconds

*RST Setting

10 seconds
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONNECTED:TIMEOUT 3"
! Sets the CALL:CONNected:STATe? query timeout time to 3 seconds.

OUTPUT 714;"CALL:CONNECTED:TIMEOUT 500 MS"
! Sets the Sets the CALL:CONNected:STATe? query timeout time to 500 milliseconds.


CALL:CONTrol

CALL:CONTrol

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL[:CELL]:CONTrol:DOWNlink:CONFig:HSPA
  • CALL[:CELL]:CONTrol:DOWNlink:FREQuency:AUTO

  • CALL[:CELL]:CONTrol:IPDownlink[:STATe]
  • CALL[:CELL]:CONTrol:IPDownlink:BFRequency[:FRAMes256]
  • CALL[:CELL]:CONTrol:IPDownlink:BLENgth[:PERiods]
  • CALL[:CELL]:CONTrol:IPDownlink:BSTart[:FRAMes256]
  • CALL[:CELL]:CONTrol:IPDownlink:IPLength
  • CALL[:CELL]:CONTrol:IPDownlink:IPOFfset
  • CALL[:CELL]:CONTrol:IPDownlink:IPSPacing
  • CALL[:CELL]:CONTrol:IPDownlink:RNGenerator:SEED
  • CALL[:CELL]:CONTrol:IPDownlink:STATus

CALL[:CELL]:CONTrol:DOWNlink:CONFig:HSPA

Function

Sets/queries the HSPA Downlink Configuration for RB and FDD Test Mode. The AUTO setting uses the most appropriate configuration based on the tet set's installed hardware.

Please note that the Standard (STD) setting is not supported without the proper hardware installed in the test set. See www.agilent.com/find/8960upgrades for additional information.

Setting

Range: AUTO | STD (standard)| NSTD (non-standard)

Query

 Same as setting

*RST Setting

AUTO

Requirements

Lab Application Revision: E.01 and above

Test Application Revision: A.13 and above

Programming Example

OUTPUT 714;"CALL:CONTrol:DOWNlink:CONFig:HSPA AUTO"
!Sets the HSPA Downlink Configuration for RB and FDD Test Mode to Auto.

CALL[:CELL]:CONTrol:DOWNlink:FREQuency:AUTO

Function

Sets/queries RF Gen Freq Ctrl .

ON = automatic

OFF = manual (see CALL[:CELL]:RFGenerator:FREQuency )

The RF Gen Freq Ctrl setting is only applicable to the FDD Test operating mode.

Note, when changing between operating modes, the RF Gen Freq Ctrl setting is returned to its default value of Auto .

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

1 (auto)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CONTrol:DOWNlink:FREQuency:AUTO ON"
!Enables automatic frequency setting.

CALL[:CELL]:CONTrol:IPDownlink[:STATe]

Function

Sets/queries the Idle Periods in the Downlink (IPDL) state. This setting controls whether IPDL is active or not.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:CONTrol:IPDownlink OFF"
!Sets the IPDL state to Off.

CALL[:CELL]:CONTrol:IPDownlink:BFRequency[:FRAMes256]

Function

Sets/queries the burst frequency. This influences the frequency of bursts within the SFN cycle (it defines the number of radio frames * 256 between bursts).

This setting cannot be changed while IPDL is active. If you attempt to change this setting while the IPDL State is On then the test set will reject the change and an error will be reported.

Setting

Range: 1 to 16

Query

 Range: 1 to 16

*RST Setting

16

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:CONTrol:IPDownlink:BFRequency 16"
!Sets the burst frequency to 16.

CALL[:CELL]:CONTrol:IPDownlink:BLENgth[:PERiods]

Function

Sets/queries the number of idle periods in a burst.

This setting cannot be changed while IPDL is active. If you attempt to change this setting while the IPDL State is On then the test set will reject the change and an error will be reported.

Setting

Range: 10 to 25

Query

Range: 10 to 25

*RST Setting

10

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:CONTrol:IPDownlink:BLENgth:PERiods 10"
!Sets the number of idle periods in a burst to 10.

CALL[:CELL]:CONTrol:IPDownlink:BSTart[:FRAMes256]

Function

Sets/queries the start of the first burst (start system frame number (SFN) = 256 * Burst Start).

This setting cannot be changed while IPDL is active. If you attempt to change this setting while the IPDL State is On then the test set will reject the change and an error will be reported.

Setting

Range: 0 to 15

Query

Range: 0 to 15

*RST Setting

5

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:CONTrol:IPDownlink:BSTart 5"
!Sets the burst start parameter to 5. The start SFN will be 1280.

CALL[:CELL]:CONTrol:IPDownlink:IPLength

Function

Sets/queries the IP Length. This parameter controls the length of the idle periods and is specified in CPICH symbols.

This setting cannot be changed while IPDL is active. If you attempt to change this setting while the IPDL State is On then the test set will reject the change and an error will be reported.

Setting

Range: 5|10

Query

Range: 5|10

*RST Setting

5

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:CONTrol:IPDownlink:IPLength 5"
!Sets the IP length to 5.

CALL[:CELL]:CONTrol:IPDownlink:IPOFfset

Function

Sets/queries the IP Offset. This parameter defines a static offset used in the calculation of idle period start positions (used to synchronize idle periods across sectors).

This setting cannot be changed while IPDL is active. If you attempt to change this setting while the IPDL State is On then the test set will reject the change and an error will be reported.

Setting

Range: 0 to 9

Query

Range: 0 to 9

*RST Setting

0

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:CONTrol:IPDownlink:IPOFfset 0"
!Sets the IP offset to 0.

CALL[:CELL]:CONTrol:IPDownlink:IPSPacing

Function

Sets/queries the spacing between idle periods.

This setting cannot be changed while IPDL is active. If you attempt to change this setting while the IPDL State is On then the test set will reject the change and an error will be reported.

Setting

Range: FRAMes5|FRAMes7|FRAMes10|FRAMes15|FRAMes20|FRAMes30|FRAMes40|FRAMes50

Query

 Range: FRAM5|FRAM7|FRAM10|FRAM15|FRAM20|FRAM30|FRAM40|FRAM50

*RST Setting

FRAM20

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:CONTrol:IPDownlink:IPSPacing FRAMes20"
!Sets the IP spacing to 20.

CALL[:CELL]:CONTrol:IPDownlink:RNGenerator:SEED

Function

Sets/queries the seed for the random number generator used when calculating the idle period start positions.

This setting cannot be changed while IPDL is active. If you attempt to change this setting while the IPDL State is On then the test set will reject the change and an error will be reported.

Setting

Range: 0 to 63

Query

 Range: 0 to 63

*RST Setting

0

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:CONTrol:IPDownlink:RNGenerator:SEED 0"
!Sets the random number generator seed to 0.

CALL[:CELL]:CONTrol:IPDownlink:STATus

Function

Sets/queries the IPDL mode.

This setting cannot be changed while IPDL is active. If you attempt to change this setting while the IPDL State is On then the test set will reject the change and an error will be reported.

Setting

Range: BURSt|CONTinuous

Query

 Range: BURS|CONT

*RST Setting

CONT

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:CONTrol:IPDownlink:STATus CONTinuous"
!Sets the IPDL mode to Continuous.


CALL:COUNt:DTMonitor

CALL:COUNt:DTMonitor

Last updated:January 6, 2012

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:COUNt:DTMonitor:CLEar

  • CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe:STARt
  • CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe:STOP
  • CALL:COUNt:DTMonitor[:ALL]:DISPlay:SPAN:TIME
  • CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory:UNUMber?

  • CALL:COUNt:DTMonitor:OTATx:DISPlay:STATe
  • CALL:COUNt:DTMonitor:OTARx:DISPlay:STATe

  • CALL:COUNt:DTMonitor:IPTX:DISPlay:STATe
  • CALL:COUNt:DTMonitor:IPRX:DISPlay:STATe

  • CALL:COUNt:DTMonitor:OTATx:DRATe?
  • CALL:COUNt:DTMonitor:OTARx:DRATe?

  • CALL:COUNt:DTMonitor:IPTX:DRATe?
  • CALL:COUNt:DTMonitor:IPRX:DRATe?

  • CALL:COUNt:DTMonitor:OTA2Rx:DRATe?
  • CALL:COUNt:DTMonitor:OTRX:DRATe?

  • CALL:COUNt:DTMonitor:OTATx:TRACe?
  • CALL:COUNt:DTMonitor:OTARx:TRACe?

  • CALL:COUNt:DTMonitor:IPTX:TRACe?
  • CALL:COUNt:DTMonitor:IPRX:TRACe?

  • CALL:COUNt:DTMonitor:OTA2Rx:TRACe?
  • CALL:COUNt:DTMonitor:OTRX:TRACe?

  • CALL:COUNt:DTMonitor:OTATx:TRACe:HISTory?
  • CALL:COUNt:DTMonitor:OTARx:TRACe:HISTory?

  • CALL:COUNt:DTMonitor:IPTX:TRACe:HISTory?
  • CALL:COUNt:DTMonitor:IPRX:TRACe:HISTory?

  • CALL:COUNt:DTMonitor:OTRX:TRACe:HISTory?
  • CALL:COUNt:DTMonitor:OTA2Rx:TRACe:HISTory?
  • CALL:COUNt:DTMonitor:TRACe1|2|3|4|5|6:DISPlay:STATe

CALL:COUNt:DTMonitor:CLEar

Function

This command clears all traces from the data throughput monitor display and resets the numeric summary table values to zero.

Requirements

 Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:CLEar"
!Clears all Data Throughput Monitor results.

CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe:STARt

CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe:STOP

Function

These commands set the data rate range (y-axis) for the data throughput monitor graphical display.

Setting

Start Range: 0 to 4999 kbps
Stop Range: 1 to 5000 kbps

Query

Start Range: 0 to 4999 kbps
Stop Range: 1 to 5000 kbps
*RST Setting

Start: 0 kbps
Stop: 100 kbps

Requirements

 Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:DISPlay:DRATe:STARt 10"
!Sets the data throughput monitor range to start at 10 kbps.

OUTPUT 714;"CALL:COUNt:DTMonitor:DISPlay:DRATe:STOP 50"
!Sets the data throughput monitor range to stop at 50 kbps.

CALL:COUNt:DTMonitor[:ALL]:DISPlay:SPAN:TIME

Function

This command sets the time span (x-axis) for the data throughput monitor graphical display.

Setting

Range: 5 to 600 seconds

Query

Range: 5 to 600 seconds
*RST Setting 600 seconds

Requirements

 Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:DISPlay:SPAN:TIME 100"
!Sets the data throughput monitor time span to 100 seconds.

CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory:UNUMber?

Function

This query returns the number of 10-minute trace data collection periods since the last time the monitor was enabled or cleared.

Query

Range: 0 to 2,147,483,647 10-minute periods, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: B.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:TRACe:HISTory:UNUMber?"
!Queries the number of 10-minute collection periods.

CALL:COUNt:DTMonitor:OTATx:DISPlay:STATe

CALL:COUNt:DTMonitor:OTARx:DISPlay:STATe

CALL:COUNt:DTMonitor:IPTX:DISPlay:STATe

CALL:COUNt:DTMonitor:IPRX:DISPlay:STATe

Function

These commands set/query which data throughput traces are displayed.

Setting

Range: 1|ON|0|OFF
*RST Setting

OTA Tx - ON

OTA Rx - ON (When DC-HSDPA is active, this result is for the serving cell)

IP Tx - OFF

IP RX - OFF

Requirements

 Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:IPTX:DISPlay:STATe ON"
!Turns the IP TX display On.

OUTPUT 714;"CALL:COUNt:DTMonitor:IPRX:DISPlay:STATe ON"
!Turns the IP RX display On.

OUTPUT 714;"CALL:COUNt:DTMonitor:OTATx:DISPlay:STATe OFF"
!Turns the OTA TX display state Off.

OUTPUT 714;"CALL:COUNt:DTMonitor:OTARx:DISPlay:STATe ON"
!Turns the OTA RX display state Off.

CALL:COUNt:DTMonitor:OTATx:DRATe?

CALL:COUNt:DTMonitor:OTARx:DRATe?

CALL:COUNt:DTMonitor:IPTX:DRATe?

CALL:COUNt:DTMonitor:IPRX:DRATe?

Function

These query commands return the summary table values (except for Marker) for any of the four traces:

  • OTA Tx
  • OTA Rx (When DC-HSDPA is active, this result is for the serving cell)
  • IP Tx
  • IP Rx

The query results for each trace will be returned in a comma-separated string with values in the following order:

  • Average data throughput (bps)
  • Current data throughput (bps)
  • Peak data throughput (bps)
  • Total data transfer (bytes)

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: B.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTATx:DRATe?
!Queries OTA Tx summary

OUTPUT 714;"CALL:COUNt:DTMonitor:OTARx:DRATe?
!Queries OTA Rx summary

OUTPUT 714;"CALL:COUNt:DTMonitor:IPTX:DRATe?
!Queries IP Tx summary

OUTPUT 714;"CALL:COUNt:DTMonitor:IPRX:DRATe?
!Queries IP Rx summary

CALL:COUNt:DTMonitor:OTA2Rx:DRATe?

Function

These query commands return the summary table values (except for Marker) for the OTA2 Rx trace. When DC-HSDPA is active, these results are for the secondary serving cell.

The query results for each trace will be returned in a comma-separated string with values in the following order:

  • Average data throughput (bps)
  • Current data throughput (bps)
  • Peak data throughput (bps)
  • Total data transfer (bytes)

Query

 Range: 0 to 9999999999, 9.91 E+37Resolution: 1

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTA2Rx:DRATe?"

CALL:COUNt:DTMonitor:OTRX:DRATe?

Function

These query commands return the summary table values (except for Marker) for the OTA Rx Total trace. When DC-HSDPA is active, these results are for the combination of both serving cells.

The query results for each trace will be returned in a comma-separated string with values in the following order:

  • Average data throughput (bps)
  • Current data throughput (bps)
  • Peak data throughput (bps)
  • Total data transfer (bytes)

Query

 Range: 0 to 9999999999, 9.91 E+37Resolution: 1

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTA2Rx:TRACe?"
!Queries OTA2 Rx trace data values.

CALL:COUNt:DTMonitor:OTATx:TRACe?

CALL:COUNt:DTMonitor:OTARx:TRACe?

CALL:COUNt:DTMonitor:IPTX:TRACe?

CALL:COUNt:DTMonitor:IPRX:TRACe?

Function

These query commands return the trace data values for any of the four traces:

  • OTA Tx
  • OTA Rx (When DC-HSDPA is active, this result is for the serving cell)
  • IP Tx
  • IP Rx

The query results for each trace will be returned in a 600 comma-separated trace values for spreadsheet plotting. These values represent the most recent 10 minute trace data collection period.

NOTE
If the graph is frozen (see Accessing the Monitor Controls ), this command will not return values representative of the graph. If you would like to see the graph this command will return values for, resume the graph then query the trace values.

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: B.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTATx:TRACe?"
!Queries OTA Tx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:OTARx:TRACe?"
!Queries OTA Rx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:IPTX:TRACe?"
!Queries IP Tx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:IPRX:TRACe?"
!Queries IP Rx trace data values.

CALL:COUNt:DTMonitor:OTA2Rx:TRACe?

Function

These query commands return the trace data values for OTA2 Rx trace. This trace is for the secondary serving cell results in DC-HSDPA.

The query results for each trace will be returned in a 600 comma-separated trace values for spreadsheet plotting. These values represent the most recent 10 minute trace data collection period.

NOTE
If the graph is frozen (see Accessing the Monitor Controls ), this command will not return values representative of the graph. If you would like to see the graph this command will return values for, resume the graph then query the trace values.

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTA2Rx:TRACe?"
!Queries OTA2 Rx trace data values.

CALL:COUNt:DTMonitor:OTRX:TRACe?

Function

These query commands return the trace data values for OTA Rx Total trace. This trace is for the combined results of the serving cell and the secondary serving cell in DC-HSDPA.

The query results for each trace will be returned in a 600 comma-separated trace values for spreadsheet plotting. These values represent the most recent 10 minute trace data collection period.

NOTE
If the graph is frozen (see Accessing the Monitor Controls ), this command will not return values representative of the graph. If you would like to see the graph this command will return values for, resume the graph then query the trace values.

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTRX:TRACe?"
!Queries OTA Rx Total trace data values.

CALL:COUNt:DTMonitor:OTATx:TRACe:HISTory?

CALL:COUNt:DTMonitor:OTARx:TRACe:HISTory?

CALL:COUNt:DTMonitor:IPTX:TRACe:HISTory?

CALL:COUNt:DTMonitor:IPRX:TRACe:HISTory?

Function

These query commands return the trace data values for any of the four traces:

  • OTA Tx

  • OTA Rx (When DC-HSDPA is active, this result is for the serving cell)

  • IP Tx

  • IP Rx

The query results for each trace will be returned in a 600 comma-separated trace values for the last 10-minute trace data collection period captured since the data throughput monitor was enabled or cleared. To find out how many 10-minute periods have elapsed, see CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory:UNUMber?

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: B.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTATx:TRACe:HISTory?"
!Queries OTA Tx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:OTARx:TRACe:HISTory?"
!Queries OTA Rx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:IPTX:TRACe:HISTory?"
!Queries IP Tx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:IPRX:TRACe:HISTory?"
!Queries IP Rx trace data values.

CALL:COUNt:DTMonitor:OTRX:TRACe:HISTory?

Function

These query commands return the trace data values for any of the OTA Rx Total trace. When DC-HSDPA is active, this result is for the combination of both serving cells.

The query results will be returned in a 600 comma-separated trace values for the last 10-minute trace data collection period captured since the data throughput monitor was enabled or cleared. To find out how many 10-minute periods have elapsed, see CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory:UNUMber?

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: B.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTRX:TRACe:HISTory?"

CALL:COUNt:DTMonitor:OTA2Rx:TRACe:HISTory?

Function

These query commands return the trace data values for any of the OTA2 Rx trace. When DC-HSDPA is active, this result is for the secondary serving cell.

The query results will be returned in a 600 comma-separated trace values for the last 10-minute trace data collection period captured since the data throughput monitor was enabled or cleared. To find out how many 10-minute periods have elapsed, see CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory:UNUMber?

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTA2Rx:TRACe:HISTory?"

CALL:COUNt:DTMonitor:TRACe1|2|3|4|5|6:DISPlay:STATe

Function

 Sets the Trace display state.

Range

Range: 1|ON|0|OFF

Query

 1|0

Requirements

 Lab Application Revision: B.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:TRACe2:DISPlay:STATe 1"
!Sets the trace 2 display state to On.


CALL:CPC

CALL:CPC

Last updated: January 6, 2012

GPIB Command Conventions

  • CALL:CPC:CQI:DTX:TIMer
  • CALL:CPC:DRX:ORDer
  • CALL:CPC:DTX:ORDer
  • CALL:CPC:ENABling:DELay
  • CALL:CPC:HLESs:HSPDschannel:CODE[:SECond]
  • CALL:CPC:HLESs:NTRans
  • CALL:CPC:HLESs:ORDer
  • CALL:CPC:HLESs:TBSize:INDex
  • CALL:CPC:HSDSchannel:TTYPe
  • CALL:CPC:HSSCchannel:ORDer:FROM
  • CALL:CPC:HSSCchannel:ORDer:SEND[:IMMediate]

  • CALL:CPC:MAC:DTX:CYCLe[:MS10]
  • CALL:CPC:MAC:DTX:CYCLe:MS2
  • CALL:CPC:MAC:ITHReshold

  • CALL:CPC:MODE

  • CALL:CPC:MS:DPCChannel:BURSt[1]|2

  • CALL:CPC:MS:DRX:CYCLe
  • CALL:CPC:MS:DRX:CYCLe:ITHReshold
  • CALL:CPC:MS:DRX:GMONitoring

  • CALL:CPC:MS:DTX:CYCLe1[:MS10]
  • CALL:CPC:MS:DTX:CYCLe1:MS2
  • CALL:CPC:MS:DTX:CYCLe2:ITHReshold
  • CALL:CPC:MS:DTX:CYCLe2[:MS10]
  • CALL:CPC:MS:DTX:CYCLe2:MS2
  • CALL:CPC:MS:DTX:LPLength
  • CALL:CPC:MS:DTX:LPLength:INFormation[:STATe]

  • CALL:CPC:MS:GMONitoring:ITHReshold
  • CALL:CPC:MS:OFFSet

  • CALL:CPC:STATe

CALL:CPC:CQI:DTX:TIMer

Function

Sets/queries the CQI DTX Timer.

This parameter impacts the CQI reporting reduction functionality for UL DTX operation and defines the time duration in subframe unit after a downlink HS-DSCH reception during which the CQI reports have higher priority than the UL DTX pattern and are transmitted according to the regular CQI reporting pattern defined by CQI Feedback Cycle and CQI Repetition Factor. In particular the value "Infinite" provides the network with a chance to disable the CQI reporting reduction functionality at the UE side when running UL DTX operation.

Setting

Range: SUBFrames0|SUBFrames1|SUBFrames2|SUBFrames4|SUBFrames8|SUBFrames16| SUBFrames32|SUBFrames64|SUBFrames128|SUBFrames256|SUBFrames512|INFinite

Query

 SUBF0|SUBF1|SUBF2|SUBF4|SUBF8|SUBF16|SUBF32|SUBF64|SUBF128|SUBF256|SUBF512|INF
*RST Setting | SUBFrames32
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:CQI:DTX:TIMer SUBFrames32"

CALL:CPC:DRX:ORDer

Function

Sets/queries the DRX Order Info.

This setting is used to configure which order will be sent on HS-SCCH to control the DL DRX operation on the air after DL DRX has been configured to UE. Based on coding rules in 3GPP 25.212 v790 section 4.6C, 0 corresponds to a DL DRX deactivation order, while 1 corresponds to a DL DRX activation order.

Setting

Range: 1|0

Query

Range: 1|0
*RST Setting

0
Requirements Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:DRX:ORDer 0"
! Configures a DL DRX deactivation order.

CALL:CPC:DTX:ORDer

Function

Sets/queries the DTX Order Info.

This setting is used to configure which order will be sent on HS-SCCH to control the UL DTX operation on the air after UL DTX has been configured to UE. Based on coding rules in 3GPP 25.212 v790 section 4.6C, 0 corresponds to an UL DTX deactivation order, while 1 corresponds to an UL DTX activation order.

Setting

Range: 1|0

Query

Range: 1|0
*RST Setting

0
Requirements Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:DTX:ORDer 0"
! Configures a DL DTX deactivation order.

CALL:CPC:ENABling:DELay

Function

Sets/queries the Enabling Delay.

This parameter is common for UL DTX and DL DRX operation and defines an UL DTX or UL DTX + DL DRX activation delay after the network has configured the corresponding operation to the UE, this delay period allows for the stable synchronization and power control loop between UE and network.

Setting

Range: FRAMes0|FRAMes1|FRAMes2|FRAMes4|FRAMes8|FRAMes16|FRAMes32|FRAMes64|FRAMes128

Query

Range: FRAM0|FRAM1|FRAM2|FRAM4|FRAM8|FRAM16|FRAM32|FRAM64|FRAM128
*RST Setting | FRAMes0
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:ENABling:DELay FRAMes0"

CALL:CPC:HLESs:HSPDschannel:CODE[:SECond]

Function

Sets/queries the HS-PDSCH Second Code Support.

The standard specifies that at most two predefined HS-PDSCH codes are assigned per UE for HS-SCCH-less operation. The four comma-separated value indicates whether the second HS-PDSCH code will be used for the corresponding TB size indexed by CALL:CPC:HLESs:TBSize:INDex . "1" means that two HS-PDSCH codes will be used for the corresponding transport block, otherwise only one HS-PDSCH code will be used.

This setting is only applicable when the Current HS-SCCH-less Activated State is On and the HS-DSCH Transmission Type is "HS-SCCH-less".

Setting

 4 comma separated values in the range: 1|0

Query

 4 comma separated values in the range: 1|0
*RST Setting 0, 0, 0, 0
Requirements

Lab Application Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:CPC:HLESs:HSPDschannel:CODE 0, 0, 0, 0"

CALL:CPC:HLESs:NTRans

Function

Sets/queries the HS-SCCH-less Number of Transmission.

This setting controls the number of times a predefined transport block will be transmitted for the HS-SCCH-less operation.

Setting

Range: 1 to 3

Query

 Same as setting
*RST Setting | 2
Requirements | Lab Application Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:CPC:HLESs:NTRans 2"

CALL:CPC:HLESs:ORDer

Function

Sets/queries the "HS-SCCH Less Order Info" .

This setting is used to configure which order will be sent on HS-SCCH to control the HS-SCCH less operation on the air after HS-SCCH less operation has been configured to UE. In accordance with the standard 3GPP 25.212, 0 corresponds to an HS-SCCH less deactivation order, while 1 corresponds to an HSSCCH less activation order.

This setting is not available when the CPC Mode is set to UL DTX or UL DTX + DL DRX .

Setting

Range: 0 | 1

Query

 Same as setting
*RST Setting | 0
Requirements | Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:CPC:HLESs:ORDer?"

CALL:CPC:HLESs:TBSize:INDex

Function

Sets/queries the HS-SCCH-less TB Size Index.

Based on the specification, up to 4 transport block formats can be predefined for HS-SCCH-less operation in terms of transport block size and the HS-PDSCH codes used for this transport block transmission. Each entry in this list defines the index of a HS-DSCH transport block size that will be configured for HS-SCCH-less operation.

Setting

Up to 4 comma separated values in the range: 0 to 90.

Query

 Same as setting
*RST Setting | 20, 0, 0 ,0
Requirements | Lab Application Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:CPC:HLESs:TBSize:INDex 20, 0, 0, 0"

CALL:CPC:HSDSchannel:TTYPe

Function

Sets/queries the HS-DSCH Transmission Type. This setting is used to switch the HSDSCH transmission type after HS-SCCH-less operation has been enabled.

Setting

Range: HLESs|HSSCch

Query

Range: HLES|HSSC
*RST Setting | HLESs
Requirements | Lab Application Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:CPC:HSDSchannel:TTYPe HLESs"

CALL:CPC:HSSCchannel:ORDer:FROM

Function

This parameter controls which cell is used to send the HS-SCCH Order to activate/deactivate the DTX and DRX based on DTX Order Info and DRX Order Info .

Setting

Range: SCELl |SSCell | ALL

Query

 Same as setting

RST Setting

ALL

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:CPC:HSSCchannel:ORDer:FROM SSCell"
!Sets the Secondary Serving Cell to send the HS-SCCH Order to activate/deactivate the DTX and DRX.

CALL:CPC:HSSCchannel:ORDer:SEND[:IMMediate]

Function

Perform the Send HS-SCCH Order action.

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:HSSCchannel:ORDer:SEND"
!Initiates a Send HS-SCCH Order.

CALL:CPC:MAC:DTX:CYCLe[:MS10]

Function

Sets/queries the MAC DTX Cycle (10ms TTI).

This parameter defines the pattern of time instances at the start of new uplink EDCH transmission after an E-DCH inactive period is allowed when E-DCH TTI is 10ms. This E-DCH inactive period is defined by the "MAC Inactivity Threshold" parameter.

Setting

Range: SUBFrames5|SUBFrames10|SUBFrames20

Query

Range: SUBF5|SUBF10|SUBF20
*RST Setting | SUBFrames10
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:MAC:DTX:CYCLe SUBFrames10"

CALL:CPC:MAC:DTX:CYCLe:MS2

Function

Sets/queries the MAC DTX Cycle (2ms TTI).

This parameter defines the pattern of time instances where the start of new uplink EDCH transmission after an E-DCH inactive period is allowed when E-DCH TTI is 2ms, this E-DCH inactive period is defined by the "MAC Inactivity Threshold" parameter.

Setting

Range: SUBFrames1|SUBFrames4|SUBFrames5|SUBFrames8|SUBFrames10|SUBFrames16|SUBFrames20

Query

Range: SUBF1|SUBF4|SUBF5|SUBF8|SUBF10|SUBF16|SUBF20
*RST Setting | SUBFrames8
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:MAC:DTX:CYCLe:MS2 SUBFrames8"

CALL:CPC:MAC:ITHReshold

Function

Sets/queries the MAC Inactivity Threshold.

This parameter impacts the functionality of the UL DRX at NodeB when running a UL DTX operation and is used to define the E-DCH inactive period after which the UE can only start a new E-DCH transmission at given time instances controlled by the "MAC DTX Cycle (10ms TTI)" or "MAC DTX Cycle (2ms TTI)". The E-DCH inactive period is in E-DCH TTI units based on the value of the "HSUPA TTI Mode" parameter.The value "Infinite" allows the network to disable the UL DRX at NodeB functionality, which will introduce the negative impact on NodeB processing resource saving within the UL DTX context.

Setting

Range: ETTis1|ETTis2|ETTis4|ETTis8|ETTis16|ETTis32|ETTis64|ETTis128|ETTis256|ETTis512|INFinite

Query

Range: ETT1|ETT2|ETT4|ETT8|ETT16|ETT32|ETT64|ETT128|ETT256|ETT512|INF
*RST Setting | ETTis8
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:MAC:ITHReshold ETTis8"

CALL:CPC:MODE

Function

Sets/queries the CPC Operation Control.

This setting controls the CPC operation mode that will be configured and activated by the L3 RRC procedure.

Setting

Range:

  • DTX (UL DTX)
  • DTRX (UL DTX + DL DRX)
  • HLESs (HS-SCCH-less)
  • DTHLess (UL DTX + HS-SCCH-less)
  • DTRHless (UL DTX + DL DRX + HS-SCCH-less)

Query

Range: DTX|DTRX|HLES|DTHL|DTRH
*RST Setting DTX
Requirements

Lab Application Revision: F.00.19 and above

Lab Application Revision F.01 and above, added HLESs, DTHLess, and DTRHless

Programming Example

OUTPUT 714;"CALL:CPC:MODE DTX"

CALL:CPC:MS:DPCChannel:BURSt[1]|2

Function

Sets/queries the UE DPCCH for the specified burst.

This parameter defines the length of the UL DPCCH transmission when UE DTX cycle 1 or UE DTX cycle 2 is active in the subframe unit.

Setting

Range: SUBFrames1|SUBFrames2|SUBFrames5

Query

Range: SUBF1|SUBF2|SUBF5
*RST Setting | SUBFrames1
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:MS:DPCChannel:BURSt2 SUBFrames1"
!Sets the length of the UL DPCCH transmission to 1 subframe for UE DTX cycle 2.

CALL:CPC:MS:DRX:CYCLe

Function

Sets/queries the UE DRX Cycle.

This parameter defines the HS-SCCH reception pattern when running the DL DRX operation after an inactive period of HS-SCCH reception defined by the "Inactivity Threshold for UE DRX Cycle" parameter. This specifies how often the UE has to monitor one HS-SCCH subframe of its HSSCCH set.

Setting

Range: SUBFrames4|SUBFrames5|SUBFrames8|SUBFrames10|SUBFrames16|SUBFrames20

Query

Range: SUBF4|SUBF5|SUBF8|SUBF10|SUBF16|SUBF20
*RST Setting | SUBFrames10
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:MS:DRX:CYCLe SUBFrames10"

CALL:CPC:MS:DRX:CYCLe:ITHReshold

Function

Sets/queries the Inactivity Threshold for UE DRX Cycle.

When running a DL DRX operation, this parameter defines a time period in subframe units after the last HS-SCCH reception that was not a HS-SCCH order where the UE has to continuously monitor the HS-SCCH.

Setting

Range: SUBFrames0|SUBFrames1|SUBFrames2|SUBFrames4|SUBFrames8|SUBFrames16|SUBFrames32|SUBFrames64|SUBFrames128|SUBFrames256|SUBFrames512

Query

Range: SUBF0|SUBF1|SUBF2|SUBF4|SUBF8|SUBF16|SUBF32|SUBF64|SUBF128|SUBF256|SUBF512
*RST Setting | SUBFrames32
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:MS:DRX:CYCLe:ITHReshold SUBFrames32"

CALL:CPC:MS:DRX:GMONitoring

Function

Sets/queries the UE DRX Grant Monitoring.

When running the DL DRX operation, this parameter controls whether the UE is required to monitor E-AGCH/E-RGCH from serving E-DCH cell when they overlap with the start of an HS-SCCH reception as defined in the HS-SCCH reception pattern using the "UE DRX Cycle" parameter.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting

1 (On)
Requirements Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:MS:DRX:GMONitoring ON"
! Sets UE DRX Grant Monitoring to On.

CALL:CPC:MS:DTX:CYCLe1[:MS10]

Function

Sets/queries the UE DTX Cycle 1 (10ms TTI).

This parameter is a part of the UL DPCCH burst pattern definition for UL DTX operation that defines how often the UE has to transmit UL DPCCH slots when UE DTX cycle 1 is active for the 10 ms E-DCH TTI.

Setting

Range: SUBFrames1|SUBFrames5|SUBFrames10|SUBFrames20

Query

Range: SUBF1|SUBF5|SUBF10|SUBF20
*RST Setting | SUBFrames10
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CCALL:CPC:MS:DTX:CYCLe1 SUBFrames10"

CALL:CPC:MS:DTX:CYCLe1:MS2

Function

Sets/queries the UE DTX Cycle 1 (2ms TTI).

This parameter is a part of the UL DPCCH burst pattern definition for UL DTX operation that defines how often the UE has to transmit UL DPCCH slots when UE DTX cycle 1 is active for 2 ms E-DCH TTI.

Setting

Range: SUBFrames1|SUBFrames4|SUBFrames5|SUBFrames8|SUBFrames10|SUBFrames16|SUBFrames20

Query

Range: SUBF1|SUBF4|SUBF5|SUBF8|SUBF10|SUBF16|SUBF20
*RST Setting | SUBFrames8
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:MS:DTX:CYCLe1:MS2 SUBFrames8"

CALL:CPC:MS:DTX:CYCLe2:ITHReshold

Function

Sets/queries the Inactivity Threshold for UE DTX Cycle 2.

This parameter defines how long the UE will wait to transit from UE DTX cycle 1 to UE DTX cycle 2 after the last E-DCH transmission when running the UL DTX. This time period is in E-DCH TTI units based on the value of the HSUPA TTI Mode parameter.

Setting

Range: ETTis1|ETTis4|ETTis8|ETTis16|ETTis32|ETTis64|ETTis128|ETTis256

Query

 Range: ETT1|ETT4|ETT8|ETT16|ETT32|ETT64|ETT128|ETT256
*RST Setting | ETTis8
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:MS:DTX:CYCLe2:ITHReshold ETTis8"

CALL:CPC:MS:DTX:CYCLe2[:MS10]

Function

Sets/queries the UE DTX Cycle 2 (10ms TTI).

This parameter is a part of UL DPCCH burst pattern definition for UL DTX operation that defines how often the UE has to transmit UL DPCCH slots when UE DTX cycle 2 is active for 10ms E-DCH TTI.

Setting

Range: SUBFrames5|SUBFrames10|SUBFrames20|SUBFrames40|SUBFrames80|SUBFrames160

Query

 Range: SUBF5|SUBF10|SUBF20|SUBF40|SUBF80|SUBF160
*RST Setting | SUBFrames20
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:MS:DTX:CYCLe2[:MS10] SUBFrames20"

CALL:CPC:MS:DTX:CYCLe2:MS2

Function

Sets/queries the AMR Rate for SRB5 12.2k to 4.75k RAB.

Setting

Range: SUBFrames4|SUBFrames5|SUBFrames8|SUBFrames10|SUBFrames16|SUBFrames20 | SUBFrames32|SUBFrames40|SUBFrames64|SUBFrames80|SUBFrames128|SUBFrames160

Query

Range: SUBF4|SUBF5|SUBF8|SUBF10|SUBF16|SUBF20|SUBF32|SUBF40|SUBF64|SUBF80|SUBF128|SUBF160
*RST Setting | SUBFrames16
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:MS:DTX:CYCLe2:MS2 SUBFrames16"

CALL:CPC:MS:DTX:LPLength

Function

Sets/queries the UE DTX Long Preamble Length.

This parameter defines the long preamble length in slots that the UE uses when running UL DTX cycle 2 to aid synchronization.

Setting

Range: SLOTs4|SLOTs15

Query

Range: SLOT4|SLOT15
*RST Setting | SLOTs4
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:MS:DTX:LPLength SLOTs4"

CALL:CPC:MS:DTX:LPLength:INFormation[:STATe]

Function

Sets/queries the UE DTX Long Preamble Length Information State.

This setting controls whether the UE DTX long preamble length IE is signalled to the UE in an OTA RRC message when starting or reconfiguring a UL DTX operation:

  • When set to Off, the UE DTX long preamble length IE will be absent from a given RRC message to start or reconfigure the UL DTX operation. The UE will use '2 slots' as the DTX long preamble length default.
  • When set to On, the UE DTX long preamble length IE will be present, and the value for this parameter is defined using the "UE DTX Long Preamble Length" parameter.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting

1 (On)
Requirements Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:MS:DTX:LPLength:INFormation ON"
! Sets UE DTX Long Preamble Length Information State to On.

CALL:CPC:MS:GMONitoring:ITHReshold

Function

Sets/queries the Inactivity Threshold for UE Grant Monitoring.

When running the DL DRX this setting is used to configure a duration in E-DCH TTI units after an immediate scheduled E-DCH transmission in the UL where the UE has to listen to the E-AGCH from the serving E-DCH cell and the E-RGCH from all the cells in the E-DCH active cell.

Setting

Range: ETTis0|ETTis1|ETTis2|ETTis4|ETTis8|ETTis16|ETTis32|ETTis64|ETTis128|ETTis256

Query

Range: ETT0|ETT1|ETT2|ETT4|ETT8|ETT16|ETT32|ETT64|ETT128|ETT256
*RST Setting | ETTis8
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:MS:GMONitoring:ITHReshold AMR1220 ETTis8"

CALL:CPC:MS:OFFSet

Function

Sets/queries the UE DTX DRX Offset.

This parameter is common for UL DTX and DL DRX operation and defines a UE specific offset in subframe units for the UL DPCCH transmission pattern and DL HSSCCH reception pattern.

Setting

Range: 0 to 159

Query

 Same as setting
*RST Setting | 0
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:MS:OFFSet 0"

CALL:CPC:STATe

Function

Sets/queries the CPC State.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting

0 (Off)
Requirements Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CPC:STATe OFF"
! Sets CPC State to Off.


CALL:CPIChannel

CALL:CPIChannel

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL:CPIChannel[:SLEVel]
  • CALL:CPIChannel:LEVel
  • CALL:CPIChannel:STATe

CALL:CPIChannel[:SLEVel]

Function

Sets/queries the common pilot channel's initial power offset. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting.

*RST Setting

 -3.3 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.06 changed *RST Setting to -3.3 dB.

Lab Application Revision C.01 changed *RST Setting to -3.3 dB.

Programming Example

OUTPUT 714;"CALL:CPICHANNEL:SLEVEL -10"

CALL:CPIChannel:LEVel

Function

Sets/queries the common pilot channel's initial power offset. This command sets the power offset level and turns on the power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

-3.3 dB
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.06 changed *RST Setting to -3.3 dB.

Lab Application Revision C.01 changed *RST Setting to -3.3 dB.

Programming Example

OUTPUT 714;"CALL:CPICHANNEL:LEVEL -5"

CALL:CPIChannel:STATe

Function

Sets/queries the common pilot channel's state.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CPICHANNEL:STATE ON"


CALL:CPNumber

CALL:CPNumber

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL:CPNumber[:SELected]
  • CALL:CPNumber:INCLusion
  • CALL:CPNumber:PLAN
  • CALL:CPNumber:PRESentation[:INDicator]
  • CALL:CPNumber:SCReening[:INDicator]
  • CALL:CPNumber:TYPE

CALL:CPNumber[:SELected]

Function

Sets/queries the ASCII representation of the calling party number.

The value is included in the SETUP message to the called mobile station when INCLude is selected by CALL:CPNumber:INCLusion .

It is displayed on the called mobile station's screen when "ALLowed" is selected by CALL:CPNumber:PRESentation[:INDicator] .

Setting

Range: 0 to 20 characters enclosed by quotes, each character from the set of 0123456789abc*#

Query

Range: 0 to 20 characters enclosed by quotes, each character from the set of 0123456789abc*#

*RST Setting

"5099214001"

Requirements

 Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber '#0123456789*'"
!Sets the calling party number to #0123456789*.

CALL:CPNumber:INCLusion

Function

Sets/queries whether to include the calling party number information record.

The value is not included in the message to the called mobile station. When "INCLude" is selected, the calling party number parameters configured by CALL:CPNumber[:SELected] , CALL:CPNumber:PLAN , CALL:CPNumber:PRESentation[:INDicator] , CALL:CPNumber:SCReening[:INDicator] and CALL:CPNumber:TYPE is sent to the mobile station.

Setting

Range: INCLude|EXCLude

Query

Range: INCL|EXCL

*RST Setting

EXCL

Requirements

 Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber:INCLusion INCLude"
!Set to include the calling party number to the called mobile station.

CALL:CPNumber:PLAN

Function

Sets/queries the numbering plan used for the calling party number. See Parameter Descriptions for details.

The value is included in the SETUP message to the called mobile station when INCLude is selected by CALL:CPNumber:INCLusion .

Setting

Range: UNKNown|ISDN|NATional|PRIVate|TELex|DATA

Query

Range: UNKN|ISDN|NAT|PRIV|TEL|DATA

*RST Setting

UNKN

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber:PLAN PRIVate"
!Set the numbering plan for calling party number to private.

CALL:CPNumber:PRESentation[:INDicator]

Function

Sets/queries the presentation indicator (PI) used for the calling party number. See Parameter Descriptions for details.

The value is included in the SETUP message to the called mobile station when INCLude is selected by CALL:CPNumber:INCLusion .

Setting

Range: ALLowed|RESTricted|NNAVailable

Query

Range: ALL|REST|NNAV

*RST Setting

ALL

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber:PRESentation RESTricted"
!Set the presentation indicator of Calling Party Number to restricted.

CALL:CPNumber:SCReening[:INDicator]

Function

Sets/queries the screening indicator (SI) for the calling party number. See Parameter Descriptions for details.

The value is included in the SETUP message to the called mobile station when INCLude is selected by CALL:CPNumber:INCLusion .

Setting

Range: UNSCreened|UVPassed|UVFailed|NETWork

Query

Range: UNSC|UVP|UVF|NETW

*RST Setting

UNSC

Requirements

 Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber:SCReening NETWork"
!Set the screening indicator of calling party number to network.

CALL:CPNumber:TYPE

Function

Sets/queries the number type of the calling party number. See Parameter Descriptions for details.

The value is included in the SETUP message to the called mobile station when INCLude is selected by CALL:CPNumber:INCLusion .

Setting

Range: UNKNown|INATional|NATional|NETWork|DEDicated

Query

Range: UNKN|INAT|NAT|NETW|DED

*RST Setting

UNKN

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:CPNumber:TYPE NATional"
!Set the number type of calling party number to national.


CALL:CRNTi

CALL:CRNTi

Last updated: February 12, 2010

GPIB Command Conventions

  • CALL[:CELL]:CRNTi

CALL[:CELL]:CRNTi

Function

Sets/queries the C-RNTI.

The cell RNTI (C-RNTI) identifies a UE having a RRC connection within a cell. C-RNTI is one of the parameters used by UE to calculate FACH measurement occasions

Setting

Range: A hex string from 0 to FFFF

Query

Range: A hex string from 0 to FFFF

*RST Setting

 0001

Requirements

Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:CRNTi '0001'"


CALL:CTCHannel

CALL:CTCHannel

Last updated: January 15, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL[:CELL[1]]:CTCHannel:APERiod
  • CALL[:CELL[1]]:CTCHannel:FOFFset

CALL[:CELL[1]]:CTCHannel:APERiod

Function

Sets/queries the CTCH Allocation Period .

This setting can not be changed in active cell operating mode (use cell off operating mode).

Setting

Range: 1 to 4096

The maximum number of radio frames this parameter can accept is 4096 minus the CBS Frame Offset . The command to set the CBS Frame Offset is CALL[:CELL[1]]:CTCHannel:FOFFset .

Resolution: 1

Query

 Same as setting.

*RST Setting

50

Requirements

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CTCHannel:APERiod 50"
! Sets the CTCH Allocation Period to 50.

CALL[:CELL[1]]:CTCHannel:FOFFset

Function

Sets/queries the CBS Frame Offset .

This setting can not be changed in active cell operating mode (use cell off operating mode).

Setting

Range: 0 to 4095

The maximum value for this command is one less than the setting for the CTCH Allocation Period . The command to set the CTCH Allocation Period is CALL[:CELL[1]]:CTCHannel:APERiod .

Resolution: 1

Query

 Same as setting.

*RST Setting

0

Requirements

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:CTCHannel:FOFFset 7"
! Sets the CBS Frame Offset to 7.


CALL:CVALue

CALL:CVALue

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL[:CELL[1]]:CVALue

CALL[:CELL[1]]:CVALue

Function

Sets/queries the Constant Value . See Initial PRACH TX Power .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: -35 dB to -10 dB

Resolution: 1 dB

Query

Range: -35 dB to -10 dB

Resolution: 1 dB

*RST Setting

 -10 dB
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CVALue -20" !Sets the constant value to -20 dB.


CALL:DAINterface

CALL:DAINterface

Last updated: January 15, 2009

This topic is only applicable to the lab application.

GPIB Command Conventions

  • CALL:DAINterface:PLAY:STARt
  • CALL:DAINterface:PLAY:STATus?
  • CALL:DAINterface:PLAY:STOP
  • CALL:DAINterface:RECord:STARt
  • CALL:DAINterface:RECord:STATus?
  • CALL:DAINterface:RECord:STOP

CALL:DAINterface:PLAY:STARt

Function Commands the test set to start playing the digital audio file.

Requirements

Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:DAINterface:PLAY:STARt" !Command the test set to start playing the digital audio file.

CALL:DAINterface:PLAY:STATus?

Function

This command queries the playing status of the digital audio file in the test set.

Query

Range: IDLE|READ|PLAY|DONE
Requirements

Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:DAINterface:PLAY:STATus?" Query the playing status of the digital audio file.

CALL:DAINterface:PLAY:STOP

Function Commands the test set to stop playing the digital audio file.

Requirements

Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:DAINterface:PLAY:STOP" !Command the test set to stop playing the digital audio file.

CALL:DAINterface:RECord:STARt

Function Commands the test set to start recording the digital audio file.

Requirements

Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:DAINterface:RECord:STARt" !Command the test set to start recording the digital audio file.

CALL:DAINterface:RECord:STATus?

Function

This command queries the recording status of the digital audio file in the test set.

Query

Range: IDLE|REC|DONE
Requirements

Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:DAINterface:RECord:STATus?" Query the recording status of the digital audio file.

CALL:DAINterface:RECord:STOP

Function Commands the test set to stop recording the digital audio file.

Requirements

Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:DAINterface:RECord:STOP" !Command the test set to stop recording the digital audio file.


CALL Subsystem

CALL Subsystem

Last updated: January 8, 2012

Description

The CALL subsystem handles all setup, control, and query functions for call processing. This includes UE and Base Station (cell) functions.

Syntax Diagrams and Command Descriptions

  • CALL:ACCess ( lab application only )
  • CALL:AICHannel
  • CALL:AREStriction ( lab application only )
  • CALL:ATTFlag
  • CALL:AWGNoise
  • CALL:BARBitrator
  • CALL:BCCHannel
  • CALL:CCPChannel
  • CALL:CELL2:CCPChannel ( lab application only )
  • CALL:CELL2:CLPControl ( lab application only )
  • CALL:CELL2:CPIChannel ( lab application only )
  • CALL:CELL2:DPCHannel ( lab application only )
  • CALL:CELL2:OCNSource ( lab application only )
  • CALL:CELL2:POWer ( lab application only )
  • CALL:CELL2:SCODe ( lab application only )
  • CALL:CELL2:TOFFset ( lab application only )
  • CALL:CHANnel
  • CALL:CLPControl
  • CALL:COMPressed ( lab application only )
  • CALL:CONNected
  • CALL:CONTrol
  • CALL:COUNt ( lab application only )
  • CALL:COUNt:DTMonitor ( lab application only )
  • CALL:CPC ( lab application only )
  • CALL:CPIChannel
  • CALL:CPNumber
  • CALL:CRNTi
  • CALL:CTCHannel ( lab application only )
  • CALL:CVALue
  • CALL:DAINterface ( lab application only )
  • CALL:DATA:PING ( lab application only )
  • CALL:DPCHannel
  • CALL:DPEDchannel
  • CALL:DRX
  • CALL:DTCHannel
  • CALL:EAGChannel ( lab application or feature-licensed test application only )
  • CALL:EDCHannel ( lab application or feature-licensed test application only )
  • CALL:EHIChannel ( lab application or feature-licensed test application only )
  • CALL:EIDentity ( lab application only )
  • CALL:END
  • CALL:FDDTest
  • CALL:FDDTest:SSCell
  • CALL:HANDoff
  • CALL:HSDPa ( lab application or feature-licensed test application only )
  • CALL:HSSCchannel ( lab application or feature-licensed test application only )
  • CALL:HSUPa ( lab application or feature-licensed test application only )
  • CALL:IDENtity
  • CALL:LACode
  • CALL:LAUPdate ( lab application only )
  • CALL:MCCode
  • CALL:MCELI
  • CALL:MNCode
  • CALL:MS:DNSServer ( lab application only )
  • CALL:MS:IP:ADDRess ( lab application only )
  • CALL:MS:LOOPback
  • CALL:MS:POWer
  • CALL:MS:REPorted
  • CALL:NITZone ( lab application only )
  • CALL:NMOPeration
  • CALL:OCNSource
  • CALL:OPERating
  • CALL:ORIGinate
  • CALL:PAGing
  • CALL:PCTPower
  • CALL:PICHannel
  • CALL:PLMNetwork ( lab application only )
  • CALL:PLOGging ( lab application only )
  • CALL:POWer
  • CALL:PPRocedure ( lab application only )
  • CALL:PSDomain
  • CALL:RACode ( lab application only )
  • CALL:RBSetup
  • CALL:RESelection ( lab application only )
  • CALL:RFGenerator
  • CALL:RLC
  • CALL:RRC ( lab application only )
  • CALL:RTVocoder ( lab application only )
  • CALL:SCODe
  • CALL:SECurity
  • CALL:SERVice
  • CALL:SETup
  • CALL:SHANdoff ( lab application only )
  • CALL:SMService ( lab application only )
  • CALL:SSERvice ( lab application only )
  • CALL:SSCell
  • CALL:SRBearer
  • CALL:STATus
  • CALL:SYSTem
  • CALL:TIMing
  • CALL:TMSI
  • CALL:TOTal:POWer
  • CALL:TRIGger
  • CALL:UINTerferenc
  • CALL:UPLink
  • CALL:VIDeo ( lab application only )


CALL:DPCHannel

CALL:DPCHannel

Last updated: November 12, 2010

GPIB Command Conventions

  • CALL:DPCHannel[:SLEVel]

  • CALL[:CELL]:DPCHannel:ASET:ADD:AUX
  • CALL[:CELL]:DPCHannel:ASET:ADD:MAIN
  • CALL[:CELL]:DPCHannel:ASET:REMove:AUX
  • CALL[:CELL]:DPCHannel:ASET:REMove:MAIN

  • CALL:DPCHannel:DOFFset

  • CALL:DPCHannel:KSPS15[:CCODe]
  • CALL:DPCHannel:KSPS15[:CCODe]:CODE
  • CALL:DPCHannel:KSPS15[:CCODe]:CODE:HSDPa
  • CALL:DPCHannel:KSPS15[:CCODe]:HSDPa
  • CALL:DPCHannel:KSPS30[:CCODe]
  • CALL:DPCHannel:KSPS30[:CCODe]:CODE
  • CALL:DPCHannel:KSPS30[:CCODe]:CODE:HSDPa
  • CALL:DPCHannel:KSPS30[:CCODe]:HSDPa
  • CALL:DPCHannel:KSPS60[:CCODe]:CODE
  • CALL:DPCHannel:KSPS120[:CCODe]
  • CALL:DPCHannel:KSPS120[:CCODe]:CODE
  • CALL:DPCHannel:KSPS240[:CCODe]
  • CALL:DPCHannel:KSPS240[:CCODe]:CODE
  • CALL:DPCHannel:KSPS480[:CCODe]
  • CALL:DPCHannel:KSPS480[:CCODe]:CODE
  • CALL:DPCHannel:LEVel

  • CALL:DPCHannel:RMC12:CCODe
  • CALL:DPCHannel:RMC12:CCODe:HSDPa
  • CALL:DPCHannel:RMC64:CCODe
  • CALL:DPCHannel:RMC144:CCODe
  • CALL:DPCHannel:RMC384:CCODe

  • CALL:DPCHannel:STATe

  • CALL:DPCHannel:TYPe

CALL:DPCHannel[:SLEVel]

Function

Sets/queries the dedicated physical channel's (DPCH) initial downlink offset, and sets its state to ON.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -30.00 dB to 0 dB (Prior to A.03, the range is -20.00 dB to 0 dB)

Resolution: 0.01
Query

Range: -30.00 dB to 0 dB (Prior to A.03, the range is -20.00 dB to 0 dB)

Resolution: 0.01

*RST Setting

 -12.00 dB (off)

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:SLEVEL -12"

CALL[:CELL]:DPCHannel:ASET:ADD:AUX

Function

Performs an Add DPCH (Aux Node) to Active Set event.

The purpose of this event is to create a DPCH on the Aux node and signal to the UE to add it to the active set. This event is only valid when Multi-Cell UTRAN mode is active and a call is active on the Main node but no DPCH is currently assigned on the Aux node.If the operation is successful, the Multi-Cell UTRAN Status of the Aux node will change from "Aux" to "A-Act" to indicate dedicated channels are now assigned.
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:DPCHannel:ASET:ADD:AUX"

CALL[:CELL]:DPCHannel:ASET:ADD:MAIN

Function

Performs an Add DPCH (Main Node) to Active Setevent.

The purpose of this event is to create a DPCH on the main node and signal to the UE to add it to the active set. This event is only valid when Multi-Cell UTRAN mode is active and a call is active on an Aux node but no DPCH is currently assigned from the Main node.If the operation is successful, the Multi-Cell UTRAN Status of the main node will change from "M-Ext" to "M-SHO" to indicate dedicated channels are now assigned on both nodes
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:DPCHannel:ASET:ADD:MAIN"

CALL[:CELL]:DPCHannel:ASET:REMove:AUX

Function

Performs a Remove DPCH (Aux Node) from Active Set event.

The purpose of this event is to release the DPCH on the Aux node and signal to the UE to remove it from the active set. This event is only valid when Multi-Cell UTRAN mode is enabled and a call is active in which a DPCH from both the Main node and Aux node is present in the active set .If the operation is successful, the Aux node DPCH will be released and the Multi-Cell UTRAN Status will change from "A-Act" to "Aux". Meanwhile the status on the Main node will change to "M-Loc" indicating channels are only active on the Main node.
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:DPCHannel:ASET:REMove:AUX"

CALL[:CELL]:DPCHannel:ASET:REMove:MAIN

Function

Performs an Remove DPCH (Main Node) from Active Set event.

The purpose of this event is to release the DPCH on the main node and signal to the UE to remove it from the active set. This event is only valid when Multi-Cell UTRAN mode is enabled and a call is active in which a DPCH from both the Main node and Aux node is present in the active set.

If the operation is successful, the Main node DPCH will be released and the Multi-Cell UTRAN Status will change from "M-SHO" to "M-Ext". Meanwhile the status on the Aux node will remain at "A-Act" indicating channels are still active on the Aux node.
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:DPCHannel:ASET:REMove:MAIN"

CALL:DPCHannel:DOFFset

Function

Sets/queries Default DPCH Offset (DOFF) .

This setting cannot be changed when the data/call status is not idle.

Setting

Range: 0 to 75

Resolution: 1
Query Same as setting

*RST Setting

 0 (0 x 512 chips)

Requirements

Test Application Revision: A.08.20 and above
Lab Application Revision: C.03 and above
Test Application Revision: A.17.00 and above, extend the range from 5 to 75
Lab Application Revision: G.01.00 and above, extend the range from 5 to 75

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:DOFFset 3"
! Sets Default DPCH Offset (DOFF) to 3 x 512 chips.

CALL:DPCHannel:KSPS15[:CCODe]

Function

THIS COMMAND IS OBSOLETE. Please use CALL:DPCHannel:KSPS15[:CCODe]:CODE .

Sets/queries the channelization code for the downlink DPCH with a physical data rate of 15 ksps.

Setting

Range: CODE12|CODE13|CODE20|CODE21|CODE40|CODE43|CODE58
|CODE126|CODE127|CODE142|CODE153|CODE174|CODE235|CODE255

Query

 Same as setting

*RST Setting

 CODE12

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:KSPS15:CCODE CODE13"

CALL:DPCHannel:KSPS15[:CCODe]:CODE

Function

Sets/queries the channelization code for the downlink DPCH with a physical data rate of 15 ksps. Codes 0 and 1 are reserved for the CPICH and SCH/PCCPCH respectively.

See Downlink Channel Codes .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 2 to 255

Resolution: 1

Query

 Same as setting

*RST Setting

 12

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:KSPS15:CODE 12"

CALL:DPCHannel:KSPS15[:CCODe]:CODE:HSDPa

Function

Sets/queries the HSDPA/HSPA DPCH 15 ksps (OVSF 256) Channelization Code.

See Downlink Channel Codes .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 2 to 255

Resolution: 1

Query

 Same as setting

*RST Setting

 40

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:DPCHannel:KSPS15:CODE:HSDPa 40"

CALL:DPCHannel:KSPS15[:CCODe]:HSDPa

Function

THIS COMMAND IS OBSOLETE. Please use CALL:DPCHannel:KSPS15[:CCODe]:CODE:HSDPa .

Sets/queries the HSDPA/HSPA DPCH 15 ksps (OVSF 256) Channelization Code.

Setting

Range: CODE40|CODE43|CODE58

Query

 Same as setting

*RST Setting

 CODE40

Requirements

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:DPCHannel:KSPS15:HSDPa CODE43"

CALL:DPCHannel:KSPS30[:CCODe]

Function

THIS COMMAND IS OBSOLETE. Please use CALL:DPCHannel:KSPS30[:CCODe]:CODE .

Sets/queries the channelization code for the downlink DPCH with a physical data rate of 30 ksps.

Setting

Range: CODE6|CODE9|CODE10|CODE20|CODE29|CODE37|CODE45
|CODE54|CODE60|CODE63|CODE70|CODE76|CODE87|CODE93
|CODE112|CODE118

Query

 Same as setting

*RST Setting

 CODE9

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:KSPS30:CCODE CODE10"

CALL:DPCHannel:KSPS30[:CCODe]:CODE

Function

Sets/queries the channelization code for the downlink DPCH with a physical data rate of 30 ksps.

See Downlink Channel Codes .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 1 to 127

Resolution: 1

Query

 Same as setting

*RST Setting

 9

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:KSPS30:CODE 9"

CALL:DPCHannel:KSPS30[:CCODe]:CODE:HSDPa

Function

Sets/queries the HSDPA/HSPA DPCH 30 ksps (OVSF 128) Channelization Code.

See Downlink Channel Codes .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use cell off operating mode when changing this value.

Setting

Range: 1 to 127

Query

 Same as setting

*RST Setting

 20

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:KSPS30:CODE:HSDPa 20"

CALL:DPCHannel:KSPS30[:CCODe]:HSDPa

Function

THIS COMMAND IS OBSOLETE. Please use CALL:DPCHannel:KSPS30[:CCODe]:HSDPa .

Sets/queries the HSDPA/HSPA DPCH 30 ksps (OVSF 128) Channelization Code.

Setting

Range: CODE20|CODE29|CODE37|CODE45|CODE54

Query

 Same as setting

*RST Setting

 CODE20

Requirements

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:KSPS30:HSDPa CODE29"

CALL:DPCHannel:KSPS60[:CCODe]:CODE

Function

Sets/queries the channelization code for the downlink DPCH with a physical data rate of 60 ksps.

See Downlink Channel Codes .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 1 to 63

Resolution: 1

Query

 Same as setting

*RST Setting

 54

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:DPCHannel:KSPS60:CODE 54"

CALL:DPCHannel:KSPS120[:CCODe]

Function

THIS COMMAND IS OBSOLETE. Please use CALL:DPCHannel:KSPS120[:CCODe]:CODE .

Sets/queries the channelization code for the downlink DPCH with a physical data rate of 120 ksps.

Setting

Range: CODE6|CODE10|CODE12|CODE14|CODE16|CODE18
|CODE20|CODE22|CODE24|CODE25|CODE26|CODE27

Query

 Same as setting

*RST Setting

 CODE6

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:KSPS120 CODE10"

CALL:DPCHannel:KSPS120[:CCODe]:CODE

Function

Sets/queries the channelization code for the downlink DPCH with a physical data rate of 120 ksps.

See Downlink Channel Codes .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range:1 to 31

Resolution: 1

Query

 Same as setting

*RST Setting

 6

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:DPCHannel:KSPS120:CODE 6"

CALL:DPCHannel:KSPS240[:CCODe]

Function

THIS COMMAND IS OBSOLETE. Please use CALL:DPCHannel:KSPS240[:CCODe]:CODE .

Sets/queries the channelization code for the downlink DPCH with a physical data rate of 240 ksps.

Setting

Range: CODE12|CODE13

Query

 Same as setting

*RST Setting

 CODE12

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:KSPS240:CCODE CODE13"
! Sets the 240 ksps channelization code to 13.

CALL:DPCHannel:KSPS240[:CCODe]:CODE

Function

Sets/queries the channelization code for the downlink DPCH with a physical data rate of 240 ksps.

See Downlink Channel Codes .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range:1 to 15

Resolution: 1

Query

 Same as setting

*RST Setting

 12

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:DPCHannel:KSPS240:CODE 12"

CALL:DPCHannel:KSPS480[:CCODe]

Function

THIS COMMAND IS OBSOLETE. Please use CALL:DPCHannel:KSPS480[:CCODe]:CODE .

Sets/queries the channelization code for the downlink DPCH with a physical data rate of 480 ksps.

Setting

Range: CODE6

Query

 Same as setting

*RST Setting

 CODE6

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:KSPS480:CCODE CODE6"

CALL:DPCHannel:KSPS480[:CCODe]:CODE

Function

Sets/queries the channelization code for the downlink DPCH with a physical data rate of 480 ksps.

See Downlink Channel Codes .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range:6

Query

 Same as setting

*RST Setting

 6

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:DPCHannel:KSPS480:CODE 6"

CALL:DPCHannel:LEVel

Function

Sets/queries the dedicated physical channel's (DPCH) initial downlink offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: -30.00 dB to 0 dB (Prior to A.03, the range is -20.00 dB to 0 dB)

Resolution: 0.01
Query

Range: -30.00 dB to 0 dB (Prior to A.03, the range is -20.00 dB to 0 dB)

Resolution: 0.01

*RST Setting

 -12.00 dB

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:LEVEL -12"

CALL:DPCHannel:RMC12:CCODe

Function

Sets/queries the dedicated physical control channel's channelization code for the 12.2 kbps reference measurement channel, the 12.2k AMR Voice channel, 33k No Coding RMC and 13.6k DCCH (SRB). See Downlink Channel Codes .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: CODE6|CODE9|CODE10|CODE20|CODE29|CODE37|CODE45
|CODE54|CODE60|CODE63|CODE70|CODE76|CODE87|CODE93
|CODE112|CODE118

Query

Range: CODE6|CODE9|CODE10|CODE20|CODE29|CODE37|CODE45
|CODE54|CODE60|CODE63|CODE70|CODE76|CODE87|CODE93
|CODE112|CODE118

*RST Setting

 CODE9

Requirements

Test Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:RMC12:CCODE CODE6"
! Sets the 12.2 RMC's channelization code.

CALL:DPCHannel:RMC12:CCODe:HSDPa

Function

Sets/queries the HSDPA/HSPA DPCH 12.2k RMC Channelization Code. See Downlink Channel Codes and HSDPA in FDD Test Operating Mode .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: CODE20|CODE29|CODE37|CODE45|CODE54

Query

 Same as setting

*RST Setting

 CODE20

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:DPCHannel:RMC12:CCODe:HSDPa CODE29"
! Sets the HSDPA DPCH 12.2k RMC channelization code.

CALL:DPCHannel:RMC64:CCODe

Function

Sets/queries the dedicated physical control channel's 64 kbps reference measurement channel's channelization code.

The type of bearer service being carried by the WCDMA link drives the configuration of the DTCH and DCCH logical channels, the DCH Transport channel, and the DPCH physical channel. The test set supports only symmetrical channels, and only one type of bearer service at a time.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: CODE6|CODE10|CODE12|CODE14|CODE16|CODE18
|CODE20|CODE22|CODE24|CODE25|CODE26|CODE27

Query

 Same as setting

*RST Setting

 CODE6

Requirements

Test Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:RMC64:CCODE CODE10"
! Sets the 64 RMC's channelization code.

CALL:DPCHannel:RMC144:CCODe

Function

Sets/queries the DPCH 144k RMC Channelization Code (see Downlink Channel Codes ).

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: CODE12|CODE13

Query

 Same as setting

*RST Setting

 CODE12

Requirements

Test Application Revision: A.05 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:RMC144:CCODE CODE13"
! Sets the 144k RMC's channelization code to 13.

CALL:DPCHannel:RMC384:CCODe

Function

Sets/queries the dedicated physical control channel's 384 kbps reference measurement channel's channelization code.

The type of bearer service being carried by the WCDMA link drives the configuration of the DTCH and DCCH logical channels, the DCH Transport channel, and the DPCH physical channel. The test set supports only symmetrical channels, and only one type of bearer service at a time.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: CODE6

Query

 Same as setting

*RST Setting

 CODE6

Requirements

Test Application Revision: A.04 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:RMC384:CCODE CODE6"
! Sets the 384k RMC's channelization code.

CALL:DPCHannel:STATe

Function

Sets/queries the dedicated physical control channel's state.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 1|ON | 0|OFF

Query

Range: 1|ON | 0|OFF

*RST Setting

 0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:STAT 1"

CALL:DPCHannel:TYPe

Function

THIS COMMAND IS OBSOLETE. Please use the CALL:SERVice:RBTest:RAB command to set/query channel type.

Sets/queries the dedicated physical control channel's channel type. See Channel Type .

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range:

  • RMC12
  • RMC64
  • RMC384

Query

 Same as setting.

*RST Setting

 RMC12

Requirements

Test Application Revision: A.01 and above

Test Application Revision A.02 added RMC64

Test Application Revision A.04 added RMC384

Lab Application Revision: A.01 and above.

Lab Application Revision A.02 added RMC384

Programming Example

OUTPUT 714;"CALL:DPCHANNEL:TYPE RMC12"
! Selects the 12.2 RMC for the DPCH.


CALL:DPEDchannel

CALL:DPEDchannel

Last updated: January 7, 2010

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL[:CELL]:DPEDchannel:ASET:ADD:AUXiliary
  • CALL[:CELL]:DPEDchannel:ASET:ADD:MAIN
  • CALL[:CELL]:DPEDchannel:ASET:REMove:AUXiliary
  • CALL[:CELL]:DPEDchannel:ASET:REMove:MAIN

CALL[:CELL]:DPEDchannel:ASET:ADD:AUXiliary

Function

Adds the HSUPA Radio Link (Aux Node) to the Active Set.

The purpose of this event is to create a DPCH and E-DCH on the Aux node and signal to the UE to add it to the active set. This event is only valid when Multi-Cell UTRAN mode is active and a HSUPA call is active on the Main node (Main node is HSUPA Serving Cell) but no DPCH and E-DCH is currently assigned on the Aux node.

Requirements

 Lab Application Revision: G.00 and above

Programming Example

OUTPUT 714;"CALL:DPEDchannel:ASET:ADD:AUXiliary"
! Adds the HSUPA Radio Link (Aux Node) to the Active Set.

CALL[:CELL]:DPEDchannel:ASET:ADD:MAIN

Function

Adds the HSUPA Radio Link (Main Node) to the Active Set.

The purpose of this event is to create both a DPCH and E-DCH on the main node and signal to the UE to add it to the active set. This event is only valid when the Multi-Cell UTRAN mode is active and a HSUPA call is active on an Aux node (Aux node is the HSUPA Serving Cell) and no DPCH/E-DCH channel assigned on the Main node.
Requirements Lab Application Revision: G.00 and above

Programming Example

OUTPUT 714;"CALL:DPEDchannel:ASET:ADD:MAIN"
! Adds the HSUPA Radio Link (Main Node) to the Active Set.

CALL[:CELL]:DPEDchannel:ASET:REMove:AUXiliary

Function

Removes the HSUPA Radio Link (Aux Node) from Active Set.

The purpose of this event is to release the DPCH+E-DCH on the Aux node and signal to the UE to remove it from the active set. This event is only valid when Multi-Cell UTRAN mode is enabled and a HSUPA call is active in which a DPCH+E-DCH from both the Main node and Aux node is present in the active set and the Aux node is not the HSUPA Serving Cell.

Requirements

 Lab Application Revision: G.00 and above

Programming Example

OUTPUT 714;"CALL[:CELL]:DPEDchannel:ASET:REMove:AUXiliary"
! Removes the HSUPA Radio Link (Aux Node) from Active Set.

CALL[:CELL]:DPEDchannel:ASET:REMove:MAIN

Function

Removes the HSUPA Radio Link (Main Node) from the Active Set.

The purpose of this event is to release the DPCH+E-DCH on the main node and signal to the UE to remove it from the active set. This event is only valid when Multi-Cell UTRAN mode is enabled and a HSUPA call is active in which a DPCH+E-DCH from both the Main node and Aux node is present in the active set and the Main node is NOT the HSUPA Serving Cell.

Requirements

 Lab Application Revision: G.00 and above

Programming Example

OUTPUT 714;"CALL:DPEDchannel:ASET:REMove:MAIN"
! Removes the HSUPA Radio Link (Main Node) from the Active Set.


CALL:DRX

CALL:DRX

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL[:CELL]:DRX:CLENgth

CALL[:CELL]:DRX:CLENgth

Function

Sets/queries the DRX Cycle Length (CN Domain) .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: FRAMes64|FRAMes128|FRAMes256|FRAMes512

Query

Range: FRAM64|FRAM128|FRAM256|FRAM512

*RST Setting

FRAM64

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:DRX:CLENgth FRAMes512"
! Sets the DRX Cycle Length to 512 frames.


CALL:DTCHannel

CALL:DTCHannel

Last updated: April 15, 2011

GPIB Command Conventions

  • CALL:DTCHannel:DATA
  • CALL:DTCHannel:BLER:REPorting:INTerval
  • CALL[:CELL]:DCHannel:UPRach

CALL:DTCHannel:DATA

Function

Sets/queries the downlink dedicated traffic channel's data type. See DL DTCH Data .

Setting

Range: INCRement|ONES|PRBS9|PRBS15|PRBS20|PRBS23|ZERos

Query

Range: INCR|ONES|PRBS9|PRBS15|PRBS20|PRBS23|ZER

*RST Setting

 PRBS15

Requirements

Test Application Revision: A.01 and above

Test Application Revision A.04 added INCrement

Lab Application Revision: A.01 and above

Lab Application Revision A.02 added INCrement

Test Application Revision A.14 and Lab Application Revision F.00, added PRBS20 and PRBS23

Programming Example

OUTPUT 714;"CALL:DTCHANNEL:DATA ZER"
! Sets the DTCH data pattern to continuous zeroes.

CALL:DTCHannel:BLER:REPorting:INTerval

Function

Sets/queries the observation period for UE reported DTCH BLER measurements (see DTCH BLER (Block Error Ratio) Report for details).

It is in the unit of millisecond. This setting is only useful after a Measurement Request (see CALL:MS:REPorted:MEASurement:REQuest ).

Setting

Range: (INT250 = 250 ms)
INT250|INT500|INT1000|INT2000|INT3000|INT4000|INT6000|INT8000
|INT12000|INT16000|INT20000|INT24000|INT28000|INT32000|INT64000

Query

Range: same as setting

*RST Setting

 INT250

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:DTCHannel:BLER:REPorting:INTerval INT1000"
! Sets the DTCH BLER observation period to 1000 miliseconds.

CALL[:CELL]:DCHannel:UPRach

Function

Sets/queries the Unexpected Page Response parameter.

Setting

Range: IGNore | RESPond

Query

Range: IGN | RESP

*RST Setting

 IGNore

Requirements

Lab Application Revision: H.00.00 and above.

Programming Example

OUTPUT 714;"CALL:DCHannel:UPRach IGNore"
! Sets the Unexpected Page Response parameter to Ignore.


CALL:EAGChannel

CALL:EAGChannel

Last updated: February 9, 2009

This section is only applicable to the lab application or feature-licensed test application.

GPIB Command Conventions

  • CALL[:CELL]:EAGChannel:CCODe
  • CALL[:CELL]:EAGChannel:CCODe:CODE

CALL[:CELL]:EAGChannel:CCODe

Function

THIS COMMAND IS OBSOLETE. Please use CALL[:CELL]:EAGChannel:CCODe:CODE .

Sets/queries the E-AGCH Channelization Code .

Setting

Range: CODE2|CODE42

Query

 Same as setting.

*RST Setting

CODE42

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:EAGChannel:CCODe CODE42"
! Sets the E-AGCH Channelization Code to CODE42.

CALL[:CELL]:EAGChannel:CCODe:CODE

Function

Sets/queries the E-AGCH Channelization Code .

This setting cannot be changed in active cell operating mode.

Setting

Range: 2 to 255

Query

 Same as setting.

*RST Setting

42

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:EAGChannel:CCODe:CODE 42"
! Sets the E-AGCH Channelization Code to 42.


CALL:EDCHannel

CALL:EDCHannel

Last updated: January 15, 2009

This section is only applicable to the feature-licensed test application.

GPIB Command Conventions

  • CALL[:CELL]:EDCHannel:CINDicator

CALL[:CELL]:EDCHannel:CINDicator

Function

Sets/queries the E-DCH Cell Indicator .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: CAPable|CNINdicated

Query

 Range: CAP|CNIN

*RST Setting

CAP

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:EDCHannel:CINDicator CAPable"
! Sets the E-DCH Cell Indicator to Capable.


CALL:EHIChannel

CALL:EHIChannel

Last updated: January 7, 2010

This section is only applicable to the lab application or feature-licensed test application.

GPIB Command Conventions

  • CALL[:CELL]:EHIChannel:BEHavior
  • CALL[:CELL]:EHIChannel:CCODe
  • CALL[:CELL]:EHIChannel:CCODe:CODE

CALL[:CELL]:EHIChannel:BEHavior

Function

Sets/queries E-HICH Behavior .

Setting

Range: ACTive|ACKS|NACKs|DTX

Query

 Range: ACT|ACKS|NACK|DTX

*RST Setting

ACT

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Lab Application Revision: G.00.00 and above, added DTX

Programming Example

OUTPUT 714;"CALL:EHIChannel:BEHavior ACTive"
! Sets E-HICH Behavior to Active.

CALL[:CELL]:EHIChannel:CCODe

Function

THIS COMMAND IS OBSOLETE. Please use CALL[:CELL]:EHIChannel:CCODe:CODE .

Sets/queries the E-HICH/E-RGCH Channelization Code .

Setting

Range: CODE22|CODE23

Query

 Same as setting.

*RST Setting

CODE22

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:EHIChannel:CCODe CODE22"
! Sets the E-HICH/E-RGCH Channelization Code to 22.

CALL[:CELL]:EHIChannel:CCODe:CODE

Function

Sets/queries the E-HICH/E-RGCH Channelization Code .

This setting cannot be changed while in active cell operating mode.

Setting

Range: 1 to 127

Query

 Same as setting.

*RST Setting

22

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:EHIChannel:CCODe:CODE 22"
! Sets the E-HICH/E-RGCH Channelization Code to 22.


CALL:EIDentity

CALL:EIDentity

Last updated: March 16, 2009

GPIB Command Conventions

  • CALL[:CELL]:EIDentity:REQuest]

CALL[:CELL]:EIDentity:REQuest]

Function

Sets/queries Equipment Identity Request .

This setting cannot be changed when the cell operating mode is Active Cell and the call/data status is not IDLE. If you attempt to change this setting when the cell operating mode is Active Cell and the call/data status is not IDLE, the test set will reject the change and an error will be reported.

Setting

Range: IMEI|EISV|ALL

Query

 Range: IMEI|EISV|ALL

*RST Setting

 IMEI

Requirements

Lab Application Revision: E.00.34 and above

Test Application Revision: A.13 and above

Programming Example

OUTPUT 714;"CALL:CELL:EIDentity:REQuest IMEI"
!Sets the application to request the IMEI from the UE.


CALL:END

CALL:END

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL:END[:AUTO]
  • CALL:END:ALL
  • CALL:END:AMR
  • CALL:END:CSData:ASYNchronous
  • CALL:END:CSData:VIDeo
  • CALL:END:PSData
  • CALL:END:RBTest

CALL:END[:AUTO]

Function

Disconnects any single active service. When there are Simultaneous Services active, this command aborts only the AMR voice call (see AMR Setup ) service.

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Lab Application Revision U.00.13 added the optional AUTO mnemonic to this command.

Programming Example

OUTPUT 714;"CALL:END"

CALL:END:ALL

Function

Disconnects all calls or connections in progress. Aborts any outstanding registrations or base station pages in progress as well as mobile station originations.
Requirements

Lab Application Revision: U.00.13 and above.

Programming Example

OUTPUT 714;"CALL:END:ALL"

CALL:END:AMR

Function

Disconnects any AMR voice calls in progress. Aborts any outstanding registrations or base station pages in progress as well as mobile station originations. See AMR Setup for more information.)
Requirements

Lab Application Revision: U.00.13 and above.

Programming Example

OUTPUT 714;"CALL:END:AMR"

CALL:END:CSData:ASYNchronous

Function

Disconnects any asynchronous calls in progress. Aborts any outstanding registrations or base station pages in progress as well as mobile station originations. (See Circuit Switched Data Service for more information.)
Requirements

Lab Application Revision: U.00.13 and above.

Programming Example

OUTPUT 714;"CALL:END:CSData:ASYNchronous"

CALL:END:CSData:VIDeo

Function

Disconnects any Video Call that is in progress. Aborts any outstanding registrations or base station pages in progress as well as mobile station originations.
Requirements

Lab Application Revision: U.00.13 and above.

Programming Example

OUTPUT 714;"CALL:END:CSData:VIDeo"

CALL:END:PSData

Function

Disconnects any PS Data connection that is in progress. (See Packet Switched Data for more information.)
Requirements

Lab Application Revision: U.00.13 and above.

Programming Example

OUTPUT 714;"CALL:END:PSData"

CALL:END:RBTest

Function

Disconnects any RB Test Mode calls in progress. Aborts any outstanding registrations or base station pages in progress as well as mobile station originations. (See Radio Bearer Test Mode for more information.)
Requirements

Lab Application Revision: U.00.13 and above.

Programming Example

OUTPUT 714;"CALL:END:RBTest"


CALL:FDDTest

CALL:FDDTest

Last updated: January 11, 2012

GPIB Command Conventions

  • CALL:FDDTest:CCPChannel:PRIMary[:SLEVel]
  • CALL:FDDTest:CCPChannel:PRIMary[:SLEVel]:HSDPa
  • CALL:FDDTest:CCPChannel:PRIMary[:SLEVel]:HSPA
  • CALL:FDDTest:CCPChannel:PRIMary:LEVel
  • CALL:FDDTest:CCPChannel:PRIMary:LEVel:HSDPa
  • CALL:FDDTest:CCPChannel:PRIMary:LEVel:HSPA
  • CALL:FDDTest:CCPChannel:PRIMary:STATe
  • CALL:FDDTest:CCPChannel:PRIMary:STATe:HSDPa
  • CALL:FDDTest:CCPChannel:PRIMary:STATe:HSPA

  • CALL:FDDTest:CLPControl:UPLink:ALGorithm
  • CALL:FDDTest:CLPControl:UPLink:MODE
  • CALL:FDDTest:CLPControl:UPLink:STEPsize

  • CALL:FDDTest:COMPressed:DACTivation:TYPe

  • CALL:FDDTest:COMPressed:ECFNumber

  • CALL:FDDTest:COMPressed:SCFNumber

  • CALL:FDDTest:COMPressed:TGPSequence:ALL:SCFNumber
  • CALL:FDDTest:COMPressed:TGPSequence([1]|2|3|4):SCFNumber

  • CALL:FDDTest:CPC:ACFNumber
  • CALL:FDDTest:CPC:CONFigured
  • CALL:FDDTest:CPIChannel[:SLEVel]
  • CALL:FDDTest:CPIChannel[:SLEVel]:HSDPa
  • CALL:FDDTest:CPIChannel[:SLEVel]:HSPA

  • CALL:FDDTest:CPIChannel:LEVel
  • CALL:FDDTest:CPIChannel:LEVel:HSDPa
  • CALL:FDDTest:CPIChannel:LEVel:HSPA

  • CALL:FDDTest:CPIChannel:STATe
  • CALL:FDDTest:CPIChannel:STATe:HSDPa
  • CALL:FDDTest:CPIChannel:STATe:HSPA

  • CALL:FDDTest:DPCHannel[:SLEVel]
  • CALL:FDDTest:DPCHannel[:SLEVel]:HSDPa
  • CALL:FDDTest:DPCHannel[:SLEVel]:HSPA

  • CALL:FDDTest:DPCHannel:FOFFset

  • CALL:FDDTest:DPCHannel:LEVel
  • CALL:FDDTest:DPCHannel:LEVel:HSDPa
  • CALL:FDDTest:DPCHannel:LEVel:HSPA

  • CALL:FDDTest:DPCHannel:STATe
  • CALL:FDDTest:DPCHannel:STATe:HSDPa
  • CALL:FDDTest:DPCHannel:STATe:HSPA

  • CALL:FDDTest:EAGChannel[:SLEVel]
  • CALL:FDDTest:EAGChannel:LEVel
  • CALL:FDDTest:EAGChannel:STATe
  • CALL:FDDTest:EDPDchannel:CCODes:MAX
  • CALL:FDDTest:EDPDchannel:CCODes:MAX:HSPA
  • CALL:FDDTest:EHIChannel[:SLEVel]
  • CALL:FDDTest:EHIChannel:LEVel
  • CALL:FDDTest:EHIChannel:STATe
  • CALL:FDDTest:ERGChannel[:SLEVel]
  • CALL:FDDTest:ERGChannel:LEVel
  • CALL:FDDTest:ERGChannel:STATe
  • CALL:FDDTest:ETFCi:BOOSt[:VALue]
  • CALL:FDDTest:FDPChannel:SLOT:FORMat
  • CALL:FDDTest:FDPChannel:STATe
  • CALL:FDDTest:FRC:HSET8:MS:IREDundancy:BUFFer:SIZE
  • CALL:FDDTest:FRC:TYPE
  • CALL:FDDTest:HRNTi[:PRIMary]
  • CALL:FDDTest:HRNTi:ALTernate
  • CALL:FDDTest:HRNTi:ALTernate:HSSCCH1
  • CALL:FDDTest:HRNTi:ALTernate:HSSCCH2
  • CALL:FDDTest:HRNTi:ALTernate:HSSCCH3
  • CALL:FDDTest:HRNTi:ALTernate:HSSCCH4

  • CALL:FDDTest:HSDSchannel:CONFig[:TYPE]
  • CALL:FDDTest:HSDSchannel:DATA
  • CALL:FDDTest:HSDSchannel:MS:CATegory
  • CALL:FDDTest:HSDSchannel:UDEFined:DCHSdpa[:STATe]
  • CALL:FDDTest:HSDSchannel:UDEFined:HARQ:PROCess:COUNt
  • CALL:FDDTest:HSDSchannel:UDEFined:HSPDschannel:COUNt
  • CALL:FDDTest:HSDSchannel:UDEFined:ITTI[:INTerval]
  • CALL:FDDTest:HSDSchannel:UDEFined:MAC
  • CALL:FDDTest:HSDSchannel:UDEFined:MACEHS:TBSTable:ALIGnment
  • CALL:FDDTest:HSDSchannel:UDEFined:MODulation[:TYPE]
  • CALL:FDDTest:HSDSchannel:UDEFined:MS:IREDundancy:BUFFer:ALLocation
  • CALL:FDDTest:HSDSchannel:UDEFined:MS:IREDundancy:BUFFer:SIZE[:EXPLicit]
  • CALL:FDDTest:HSDSchannel:UDEFined:TBSize:INDex
  • CALL:FDDTest:HSDSchannel:UDEFined:QAM64:STATe
  • CALL:FDDTest:HSPDschannel[:SLEVel]

  • CALL:FDDTest:HSPDschannel[:SLEVel]:HSPA
  • CALL:FDDTest:HSPDschannel:CCODe
  • CALL:FDDTest:HSPDschannel:CCODe:CODE
  • CALL:FDDTest:HSPDschannel:LEVel
  • CALL:FDDTest:HSPDschannel:LEVel:HSPA
  • CALL:FDDTest:HSPDschannel:STATe
  • CALL:FDDTest:HSPDschannel:STATe:HSPA

  • CALL:FDDTest:HSSCchannel[1][:SLEVel]
  • CALL:FDDTest:HSSCchannel[1][:SLEVel]:HSPA
  • CALL:FDDTest:HSSCchannel[1]:CONFig:STATe
  • CALL:FDDTest:HSSCchannel[1]:LEVel
  • CALL:FDDTest:HSSCchannel[1]:LEVel:HSPA
  • CALL:FDDTest:HSSCchannel[1]:STATe
  • CALL:FDDTest:HSSCchannel[1]:STATe:HSPA
  • CALL:FDDTest:HSSCchannel2[:SLEVel]
  • CALL:FDDTest:HSSCchannel2[:SLEVel]:HSPA
  • CALL:FDDTest:HSSCchannel2:CONFig:STATe
  • CALL:FDDTest:HSSCchannel2:LEVel
  • CALL:FDDTest:HSSCchannel2:LEVel:HSPA
  • CALL:FDDTest:HSSCchannel2:STATe
  • CALL:FDDTest:HSSCchannel2:STATe:HSPA
  • CALL:FDDTest:HSSCchannel3[:SLEVel]
  • CALL:FDDTest:HSSCchannel3[:SLEVel]:HSPA
  • CALL:FDDTest:HSSCchannel3:CONFig:STATe
  • CALL:FDDTest:HSSCchannel3:LEVel
  • CALL:FDDTest:HSSCchannel3:LEVel:HSPA
  • CALL:FDDTest:HSSCchannel3:STATe
  • CALL:FDDTest:HSSCchannel3:STATe:HSPA
  • CALL:FDDTest:HSSCchannel4[:SLEVel]
  • CALL:FDDTest:HSSCchannel4[:SLEVel]:HSPA
  • CALL:FDDTest:HSSCchannel4:CONFig:STATe
  • CALL:FDDTest:HSSCchannel4:LEVel
  • CALL:FDDTest:HSSCchannel4:LEVel:HSPA
  • CALL:FDDTest:HSSCchannel4:STATe
  • CALL:FDDTest:HSSCchannel4:STATe:HSPA

  • CALL:FDDTest:MACHs:HEADer
  • CALL:FDDTest:MACHs:NTRans
  • CALL:FDDTest:MACHs:RVSequence
  • CALL:FDDTest:MACHs:SDTX:RBEHavior
  • CALL:FDDTest:MACHs:WSIZe:TRANsmit

  • CALL:FDDTest:PICHannel[:SLEVel]
  • CALL:FDDTest:PICHannel[:SLEVel]:HSDPa
  • CALL:FDDTest:PICHannel[:SLEVel]:HSPA
  • CALL:FDDTest:PICHannel:DATA
  • CALL:FDDTest:PICHannel:LEVel
  • CALL:FDDTest:PICHannel:LEVel:HSDPa
  • CALL:FDDTest:PICHannel:LEVel:HSPA
  • CALL:FDDTest:PICHannel:STATe
  • CALL:FDDTest:PICHannel:STATe:HSDPa
  • CALL:FDDTest:PICHannel:STATe:HSPA

  • CALL:FDDTest:TFCIndicator

  • CALL:FDDTest:UPLink:TFCIndicator:CONTrol:AUTO
  • CALL:FDDTest:UPLink:TFCIndicator:MANual

CALL:FDDTest:CCPChannel:PRIMary[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the FDD Test P-CCPCH/SCH Level (see CALL:FDDTest:CCPChannel:PRIMary:LEVel ) and (2) sets the FDD Test P-CCPCH/SCH state to on (see CALL:FDDTest:CCPChannel:PRIMary:STATe ).

The query form of this command returns the FDD Test P-CCPCH/SCH Level .

See FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -5.35 dB (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:CCPChannel:PRIMary -13"
! Sets the FDD Test P-CCPCH/SCH Level to -13 dB and turns its state on.

CALL:FDDTest:CCPChannel:PRIMary[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the HSDPA FDD Test P-CCPCH/SCH Level (see CALL:FDDTest:CCPChannel:PRIMary:LEVel:HSDPa ) and (2) sets the HSDPA FDD Test P-CCPCH/SCH state to on (see CALL:FDDTest:CCPChannel:PRIMary:STATe:HSDPa ).

The query form of this command returns the HSDPA FDD Test P-CCPCH/SCH Level .

See HSDPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -12 dB (on)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:CCPChannel:PRIMary:HSDPa -13"
! Sets the HSDPA FDD Test P-CCPCH/SCH Level to -13 dB and turns its state on.

CALL:FDDTest:CCPChannel:PRIMary[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA FDD Test P-CCPCH/SCH Level (see CALL:FDDTest:CCPChannel:PRIMary:LEVel:HSPA ) and (2) sets the HSPA FDD Test P-CCPCH/SCH state to on (see CALL:FDDTest:CCPChannel:PRIMary:STATe:HSPA ).

The query form of this command returns the HSPA FDD Test P-CCPCH/SCH Level .

See HSPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -12 dB (on)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:CCPChannel:PRIMary:HSPA -13"
! Sets the HSPA FDD Test P-CCPCH/SCH Level to -13 dB and turns its state on.

CALL:FDDTest:CCPChannel:PRIMary:LEVel

Function

Sets/queries the FDD Test P-CCPCH/SCH Level . See FDD Test Operating Mode .

The FDD Test P-CCPCH/SCH Level can also be set using the CALL:FDDTest:CCPChannel:PRIMary[:SLEVel] command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -5.35 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:CCPChannel:PRIMary:LEVel -7"

CALL:FDDTest:CCPChannel:PRIMary:LEVel:HSDPa

Function

Sets/queries the HSDPA FDD Test P-CCPCH/SCH Level . See HSDPA in FDD Test Operating Mode .

The HSDPA FDD Test P-CCPCH/SCH Level can also be set using the CALL:FDDTest:CCPChannel:PRIMary[:SLEVel]:HSDPa command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting.

*RST Setting

 -12 dB

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:CCPChannel:PRIMary:LEVel:HSDPa -7"

CALL:FDDTest:CCPChannel:PRIMary:LEVel:HSPA

Function

Sets/queries the HSPA FDD Test P-CCPCH/SCH Level . See HSPA in FDD Test Operating Mode .

The HSPA FDD Test P-CCPCH/SCH Level can also be set using the CALL:FDDTest:CCPChannel:PRIMary[:SLEVel]:HSPA command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting.

*RST Setting

 -12 dB

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:CCPChannel:PRIMary:LEVel:HSPA -7"

CALL:FDDTest:CCPChannel:PRIMary:STATe

Function

Sets/queries the FDD Test P-CCPCH/SCH state. See FDD Test Operating Mode .

The FDD Test P-CCPCH/SCH state can also be set using the CALL:FDDTest:CCPChannel:PRIMary[:SLEVel] command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:CCPChannel:PRIMary:STATe ON"

CALL:FDDTest:CCPChannel:PRIMary:STATe:HSDPa

Function

Sets/queries the HSDPA FDD Test P-CCPCH/SCH state. See HSDPA in FDD Test Operating Mode .

The HSDPA FDD Test P-CCPCH/SCH state can also be set using the CALL:FDDTest:CCPChannel:PRIMary[:SLEVel] command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:CCPChannel:PRIMary:STATe:HSDPa ON"

CALL:FDDTest:CCPChannel:PRIMary:STATe:HSPA

Function

Sets/queries the HSPA FDD Test P-CCPCH/SCH state. See HSPA in FDD Test Operating Mode .

The HSPA FDD Test P-CCPCH/SCH state can also be set using the CALL:FDDTest:CCPChannel:PRIMary[:SLEVel]:HSDPa command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:CCPChannel:PRIMary:STATe:HSPA ON"

CALL:FDDTest:CLPControl:UPLink:ALGorithm

Function

Sets/queries the FDD Test UL CL Power Ctrl Algorithm .

Setting

Range:

  • ALG1
  • ALG2

Query

 Same as setting

*RST Setting

 ALG2

Requirements

Test Application Revision A.07 and above

Lab Application Revision C.02 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:CLPControl:UPLink:ALGorithm ALG1"
! Sets FDD Test UL CL Power Ctrl Algorithm to One.

CALL:FDDTest:CLPControl:UPLink:MODE

Function

Sets/queries the FDD Test UL CL Power Ctrl Mode .

Setting

Range:

  • ACTive (Active bits)
  • DOWN (All Down bits)
  • UDOWn (Alternating bits)
  • UDOWn10 (10 Up/Down bits)
  • UP (All Up bits)

Query

Range: ACT|DOWN|UDOW|UDOW10|UP

*RST Setting

 UDOW

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision A.07 and above added ACTive

Lab Application Revision C.02 and above added ACTive

Programming Example

OUTPUT 714;"CALL:FDDTest:CLPCONTROL:UPLink:MODE UDOWN"
!Sets the closed loop power control mode to alternating up, down bits.

CALL:FDDTest:CLPControl:UPLink:STEPsize

Function

Sets/queries the FDD Test UL CL Power Ctrl Stepsize when FDD Test UL CL Power Ctrl Algorithm is set to One (see CALL:FDDTest:CLPControl:UPLink:ALGorithm ).

Setting

Range: 1 to 2 dB

Resolution: 1 dB

Query

 Same as setting

*RST Setting

 1 dB

Requirements

Test Application Revision A.07 and above

Lab Application Revision C.02 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:CLPControl:UPLink:STEPsize 2 dB"
! Sets FDD Test UL CL Power Ctrl Stepsize to 2 dB.

CALL:FDDTest:COMPressed:DACTivation:TYPe

Function

Sets/queries Deactivation Type .

Setting

Range:

  • IMM (Immediate)
  • CFN (Specific CFN)

Query

 Same as setting.

*RST Setting

 IMM

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:COMPressed:DACTivation:TYPe CFN"

! Sets deactivation type to CFN.

CALL:FDDTest:COMPressed:ECFNumber

Function

Sets/queries Ending CFN .

Setting

Range: 0 to 255

Resolution: 1

Query

 Same as setting.

*RST Setting

 0

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:COMPressed:ECFNumber 16"

CALL:FDDTest:COMPressed:SCFNumber

Function

This command is obsolete. Please use CALL:FDDTest:COMPressed:TGPSequence:ALL:SCFNumber or CALL:FDDTest:COMPressed:TGPSequence([1]|2|3|4):SCFNumber .

Sets/queries Starting CFN for TGPS 1.

Setting

Range: 0 to 255

Resolution: 1

Query

 Same as setting.

*RST Setting

 0

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:COMPressed:SCFNumber 4"

CALL:FDDTest:COMPressed:TGPSequence:ALL:SCFNumber

Function

Sets/queries <num> TG Starting CFN for the first through fourth TGPSs (the first num value sets First TG Starting CFN , the second num value sets Second TG Starting CFN , etc.). You can set TG Starting CFN for an individual TGPS using the CALL:FDDTest:COMPressed:TGPSequence([1]|2|3|4):SCFNumber commands.

Setting

Range: 0 to 255

Resolution: 1

Query

 Same as setting.

*RST Setting

 0,2,6,14

Requirements

 Lab Application Revision: D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:COMPressed:TGPSequence:ALL:SCFNumber 0,4,12,28"
! Sets First TG Starting CFN to 0, Second TG Starting CFN to 4,
! Third TG Starting CFN to 12, and Fourth TG Starting CFN to 28.

CALL:FDDTest:COMPressed:TGPSequence([1]|2|3|4):SCFNumber

Function

Sets/queries <num> TG Starting CFN for the first, second, third or fourth TGPS (sending :TGPSequence or :TGPSequence1 sets First TG Starting CFN , sending :TGPSequence2 sets Second TG Starting CFN , etc.). You can set TG Starting CFN for all four TGPSs using the CALL:FDDTest:COMPressed:TGPSequence:ALL:SCFNumber command.

Setting

Range: 0 to 255

Resolution: 1

Query

 Same as setting.

*RST Setting
  • First TGPS: 0
  • Second TGPS: 2
  • Third TGPS: 6
  • Fourth TGPS: 14

Requirements

 Lab Application Revision: D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:COMPressed:TGPSequence3:SCFNumber 12"
! Sets Third TG Starting CFN to 12.

CALL:FDDTest:CPC:ACFNumber

Function

Sets/queries the CPC Activation CFN. This setting controls the specific CFN used by the UE and test set to start the CPC operation immediately after radio frames determined by the "Enabling Delay" parameter has passed.

Setting

Range: 0 to 255

Resolution: 1

Query

 Same as setting.

*RST Setting

 0

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:CPC:ACFNumber 0"
! Sets the CPC Activation CFN to 0.

CALL:FDDTest:CPC:CONFigured

Function

Queries the CPC Configured parameter.

This setting determines whether to start or stop the CPC operation with the mode specified using the "CPC Mode" parameter.

Query

Range: 1|0

*RST Setting

 0

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:CPC:CONFigured 0"

CALL:FDDTest:CPIChannel[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the FDD Test CPICH Level (see CALL:FDDTest:CPIChannel:LEVel ) and (2) sets the FDD Test CPICH state to on (see CALL:FDDTest:CPIChannel:STATe ).

The query form of this command returns the FDD Test CPICH Level .

See FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -3.3 dB (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:CPIChannel -13"
! Sets the FDD Test CPICH Level to -13 dB and turns its state on.

CALL:FDDTest:CPIChannel[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the HSDPA FDD Test CPICH Level (see CALL:FDDTest:CPIChannel:LEVel:HSDPa ) and (2) sets the HSDPA FDD Test CPICH state to on (see CALL:FDDTest:CPIChannel:STATe:HSDPa ).

The query form of this command returns the HSDPA FDD Test CPICH Level .

See HSDPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB (on)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:CPIChannel:HSDPa -13"
! Sets the HSDPA FDD Test CPICH Level to -13 dB and turns its state on.

CALL:FDDTest:CPIChannel[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA FDD Test CPICH Level (see CALL:FDDTest:CPIChannel:LEVel:HSPA ) and (2) sets the HSPA FDD Test CPICH state to on (see CALL:FDDTest:CPIChannel:STATe:HSPA ).

The query form of this command returns the HSPA FDD Test CPICH Level .

See HSPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB (on)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:CPIChannel:HSPA -13"
! Sets the HSPA FDD Test CPICH Level to -13 dB and turns its state on.

CALL:FDDTest:CPIChannel:LEVel

Function

Sets/queries the FDD Test CPICH Level . See FDD Test Operating Mode .

The FDD Test CPICH Level can also be set using the CALL:FDDTest:CPIChannel[:SLEVel] command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -3.3 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:CPIChannel:LEVel -7"

CALL:FDDTest:CPIChannel:LEVel:HSDPa

Function

Sets/queries the HSDPA FDD Test CPICH Level . See HSDPA in FDD Test Operating Mode .

The HSDPA FDD Test CPICH Level can also be set using the CALL:FDDTest:CPIChannel[:SLEVel]:HSDPa command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:CPIChannel:LEVel:HSDPa -7"

CALL:FDDTest:CPIChannel:LEVel:HSPA

Function

Sets/queries the HSPA FDD Test CPICH Level . See HSPA in FDD Test Operating Mode .

The HSPA FDD Test CPICH Level can also be set using the CALL:FDDTest:CPIChannel[:SLEVel]:HSPA command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:CPIChannel:LEVel:HSPA -7"

CALL:FDDTest:CPIChannel:STATe

Function

Sets/queries the FDD Test CPICH state. See FDD Test Operating Mode .

The FDD Test CPICH state can also be set using the CALL:FDDTest:CPIChannel[:SLEVel] command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:CPIChannel:STATe ON"

CALL:FDDTest:CPIChannel:STATe:HSDPa

Function

Sets/queries the HSDPA FDD Test CPICH state. See HSDPA in FDD Test Operating Mode .

The HSDPA FDD Test CPICH state can also be set using the CALL:FDDTest:CPIChannel[:SLEVel]:HSDPa command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:CPIChannel:STATe:HSDPa ON"

CALL:FDDTest:CPIChannel:STATe:HSPA

Function

Sets/queries the HSPA FDD Test CPICH state. See HSPA in FDD Test Operating Mode .

The HSPA FDD Test CPICH state can also be set using the CALL:FDDTest:CPIChannel[:SLEVel]:HSPA command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:CPIChannel:STATe:HSPA ON"

CALL:FDDTest:DPCHannel[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the FDD Test DPCH Level (see CALL:FDDTest:DPCHannel:LEVel ) and (2) sets the FDD Test DPCH state to on (see CALL:FDDTest:DPCHannel:STATe ).

The query form of this command returns the FDD Test DPCH Level .

See FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10.3 dB (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:DPCHannel -13"
! Sets the FDD Test DPCH Level to -13 dB and turns its state on.

CALL:FDDTest:DPCHannel[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the HSDPA FDD Test DPCH Level (see CALL:FDDTest:DPCHannel:LEVel:HSDPa ) and (2) sets the HSDPA FDD Test DPCH state to on (see CALL:FDDTest:DPCHannel:STATe:HSDPa ).

The query form of this command returns the HSDPA FDD Test DPCH Level .

See HSDPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB (on)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:DPCHannel:HSDPa -13"
! Sets the HSDPA FDD Test DPCH Level to -13 dB and turns its state on.

CALL:FDDTest:DPCHannel[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA FDD Test DPCH Level (see CALL:FDDTest:DPCHannel:LEVel:HSPA ) and (2) sets the HSPA FDD Test DPCH state to on (see CALL:FDDTest:DPCHannel:STATe:HSPA ).

The query form of this command returns the HSPA FDD Test DPCH Level .

See HSPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB (on)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:DPCHannel:HSPA -13"
! Sets the HSPA FDD Test DPCH Level to -13 dB and turns its state on.

CALL:FDDTest:DPCHannel:FOFFset

Function

 Sets/queries DPCH Frame Offset .

Setting

Range: 0 to 149

Resolution: 1

Query

 Same as setting

*RST Setting

 0 (0 x 256 chips)

Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:DPCHannel:FOFFset 6"
! Sets DPCH Frame Offset to 6 x 256 chips.

CALL:FDDTest:DPCHannel:LEVel

Function

Sets/queries the FDD Test DPCH Level . See FDD Test Operating Mode .

The FDD Test DPCH Level can also be set using the CALL:FDDTest:DPCHannel[:SLEVel] command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10.3 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:DPCHannel:LEVel -7"

CALL:FDDTest:DPCHannel:LEVel:HSDPa

Function

Sets/queries the HSDPA FDD Test DPCH Level . See HSDPA in FDD Test Operating Mode .

The HSDPA FDD Test DPCH Level can also be set using the CALL:FDDTest:DPCHannel[:SLEVel]:HSDPa command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:DPCHannel:LEVel:HSDPa -7"

CALL:FDDTest:DPCHannel:LEVel:HSPA

Function

Sets/queries the HSPA FDD Test DPCH Level . See HSPA in FDD Test Operating Mode .

The HSPA FDD Test DPCH Level can also be set using the CALL:FDDTest:DPCHannel[:SLEVel]:HSPA command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:DPCHannel:LEVel:HSPA -7"

CALL:FDDTest:DPCHannel:STATe

Function

Sets/queries the FDD Test DPCH state. See FDD Test Operating Mode .

The FDD Test DPCH state can also be set using the CALL:FDDTest:DPCHannel[:SLEVel] command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:DPCHannel:STATe ON"

CALL:FDDTest:DPCHannel:STATe:HSDPa

Function

Sets/queries the HSDPA FDD Test DPCH state. See HSDPA in FDD Test Operating Mode .

The HSDPA FDD Test DPCH state can also be set using the CALL:FDDTest:DPCHannel[:SLEVel]:HSDPa command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:DPCHannel:STATe:HSDPa ON"

CALL:FDDTest:DPCHannel:STATe:HSPA

Function

Sets/queries the HSPA FDD Test DPCH state. See HSPA in FDD Test Operating Mode .

The HSPA FDD Test DPCH state can also be set using the CALL:FDDTest:DPCHannel[:SLEVel]:HSPA command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:DPCHannel:STATe:HSPA ON"

CALL:FDDTest:EAGChannel[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the HSPA FDD Test E-AGCH Level (see CALL:FDDTest:EAGChannel:LEVel ) and (2) sets the FDD Test E-AGCH state to on (see CALL:FDDTest:EAGChannel:STATe ).

The query form of this command returns the HSPA FDD Test E-AGCH Level .

See HSPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20 dB (on)

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:EAGChannel -20"
! Sets the HSPA FDD Test E-AGCH Level
 to -20 dB and turns its state on.

CALL:FDDTest:EAGChannel:LEVel

Function

Sets/queries the HSPA FDD Test E-AGCH Level .

The HSPA FDD Test E-AGCH Level can also be set using the CALL:FDDTest:EAGChannel[:SLEVel] command.

See HSPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20 dB

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:EAGChannel:LEVel -20"

CALL:FDDTest:EAGChannel:STATe

Function

Sets/queries the HSPA FDD Test E-AGCH Level state.

The HSPA FDD Test E-AGCH Level state can also be set using the CALL:FDDTest:EAGChannel[:SLEVel] command.

See HSPA in FDD Test Operating Mode .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:EAGChannel:STATe ON"

CALL:FDDTest:EDPDchannel:CCODes:MAX

Function

Sets/queries FDD Test E-DPDCH Max Channel Codes .

Setting

Range: SF64|SF32|SF16|SF8|SF4|TSF4|TSF2

Query

Same as setting

*RST Setting

 TSF4

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:EDPDchannel:CCODes:MAX TSF4"
! Sets FDD Test E-DPDCH Max Channel Codes to 2SF4.

CALL:FDDTest:EDPDchannel:CCODes:MAX:HSPA

Function

Sets/queries the FDD Test Mode E-DPDCH Max Channelisation Codes (HSPA Only).

This setting is used to inform the test set what value the UE is using for E-DPDCH Max Channelisation Codes while operating in FDD Test Mode with "UTRA FDD RB Test Mode Channel Type" set to"HSPA Only." This value is required to be able to translate the E-TFCI value that the UE transmits on the E-DPCCH to the spreading factor and number of channels used on the E-DPDCH.If "UTRA FDD RB Test Mode Channel Type" is set to "12.2k RMC + HSPA," this parameter is ignored.

Setting

Range: SF64|SF32|SF16|SF8|SF4|TSF4|TSF2|T2T4 (2SF2+2SF4)

Query

Same as setting

*RST Setting

 T2T4 (2SF2+2SF4)

Requirements

Test Application Revision A.13 and above, with the required feature license.

Lab Application Revision: E.01 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:EDPDchannel:CCODes:MAX:HSPA T2T4"
! Sets FDD Test E-DPDCH Max Channel Codes (HSPA Only) to 2SF2+2SF4.

CALL:FDDTest:EHIChannel[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the HSPA FDD Test E-HICH Level (see CALL:FDDTest:EHIChannel:LEVel ) and (2) sets the HSPA FDD Test E-HICH Level state to on (see CALL:FDDTest:EHIChannel:STATe ).

The query form of this command returns the HSPA FDD Test E-HICH Level .

See HSPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20 dB (on)

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:EHIChannel -20"
! Sets the HSPA FDD Test E-HICH Level
 to -20 dB and turns its state on.

CALL:FDDTest:EHIChannel:LEVel

Function

Sets/queries the HSPA FDD Test E-HICH Level .

The HSPA FDD Test E-HICH Level can also be set using the CALL:FDDTest:EHIChannel[:SLEVel] command.

See HSPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20 dB

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:EHIChannel:LEVel -20"

CALL:FDDTest:EHIChannel:STATe

Function

Sets/queries the HSPA FDD Test E-HICH Level state.

The HSPA FDD Test E-HICH Level state can also be set using the CALL:FDDTest:EHIChannel[:SLEVel] command.

See HSPA in FDD Test Operating Mode .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:EHIChannel:STATe ON"

CALL:FDDTest:ERGChannel[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the HSPA FDD Test E-RGCH Level (see CALL:FDDTest:ERGChannel:LEVel ) and (2) sets the HSPA FDD Test E-RGCH Level state to on (see CALL:FDDTest:ERGChannel:STATe ).

The query form of this command returns the HSPA FDD Test E-RGCH Level .

See HSPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20 dB (off)

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:ERGChannel -20"
! Sets the HSPA FDD Test E-RGCH Level
 to -20 dB and turns its state on.

CALL:FDDTest:ERGChannel:LEVel

Function

Sets/queries the HSPA FDD Test E-RGCH Level .

The HSPA FDD Test E-RGCH Level can also be set using the CALL:FDDTest:ERGChannel[:SLEVel] command.

See HSPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -20 dB

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:ERGChannel:LEVel -20"

CALL:FDDTest:ERGChannel:STATe

Function

Sets/queries the HSPA FDD Test E-RGCH Level state.

The HSPA FDD Test E-RGCH Level state can also be set using the CALL:FDDTest:ERGChannel[:SLEVel] command.

See HSPA in FDD Test Operating Mode .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision: A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:ERGChannel:STATe OFF"

CALL:FDDTest:ETFCi:BOOSt[:VALue]

Function

Sets/queries the E-TFCI Boost setting in the FDD Test Operating Mode. This setting determines the E-TFCI threshold beyond which boosting of E-DPCCH is enabled.

Setting

Range: 0 - 127

Query

Range: 0 - 127

*RST Setting

 127

Requirements

Test Application Revision: A.17.00 and above, with the required feature license.
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:ETFCi:BOOSt 127"

CALL:FDDTest:FDPChannel:SLOT:FORMat

Function

 Sets/queries FDD Test Mode F-DPCH Slot Format.

Setting

Range: 0 to 9

Resolution: 1

Query

 Same as setting

*RST Setting

 0

Requirements

Test Application Revision: A.15 and above

Lab Application Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:FDPChannel:SLOT:FORMat 0"
! Sets FDD Test Mode F-DPCH Slot Format to 0.

CALL:FDDTest:FDPChannel:STATe

Function

Sets/queries the FDD Test F-DPCH State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:FDPChannel:STATe OFF"

CALL:FDDTest:FRC:HSET8:MS:IREDundancy:BUFFer:SIZE

Function

Sets/queries the FDD Test Mode FRC H-Set 8 UE IR Buffer Size.

This Setting controls the FDD Test Mode H-Set 8 UE IR Buffer Size, either 40000 bits or as specified in 25.101v870. If this setting is Standard (STD), the test set will determine the IR buffer size per HARQ process.

Setting

Range: 40000|STD

Query

 Same as setting

*RST Setting

 40000

Requirements

Test Application Revision A.15 and above.

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:FRC:HSET8:MS:IREDundancy:BUFFer:SIZE 40000"
! Sets FDD Test Mode FRC H-Set 8 UE IR Buffer Size to 40000 bits.

CALL:FDDTest:FRC:TYPE

Function

Sets/queries the FDD Test "FRC Type" on page 1 .

Setting

Range:

QAM1|QAM2|QAM3|QAM3A |QAM6|QAM6A|QAM64H8|QAM64H8A|QAM16H10|

QAM16H10A|QPSK1|QPSK2 |QPSK3||QPSK3A|QPSK4|QPSK5|QPSK6|QPSK6A|

QPSKH10|QPSK10A|QPSKH12

Query

 Same as setting

*RST Setting

 QPSK1

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Test Application Revision A.10.01 and Lab Application Revision D.01.01 added QAM6 and QPSK6.

Lab Application Revision F.00 added QAM64H8, QAM16H10, QPSKH10.

Test Application Revision: A.19.00 and above with the required feature license and Lab Application Revision: H.01.00 and above, added QPSK3A, QAM16H3A, QPSK6A, QAM16H6A, QAM64H8A, QPSK10A, QAM16H10A, QPSK12.

Programming Example

OUTPUT 714;"CALL:FDDTest:FRC:TYPE QPSK2"
! Sets FRC Type to H-Set 2 QPSK.

CALL:FDDTest:HRNTi[:PRIMary]

Function

Sets/queries FDD Test Primary H-RNTI (Hex) .

Setting

Range: 0 to FFFF

(1 to 4 characters from the set 0123456789AaBbCcDdEeFf)

Query

Range: "0000" to "FFFF"

(The return string is always 4 characters from the set 0123456789ABCDEF, enclosed by double quotes.)

*RST Setting

 "AAAA"

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HRNTi 'EEEE'"
! Sets FDD Test Primary H-RNTI (Hex) to EEEE.

CALL:FDDTest:HRNTi:ALTernate

Function

Sets/queries FDD Test Alternate H-RNTI (Hex) .

Setting

Range: 0 to FFFF

(1 to 4 characters from the set 0123456789AaBbCcDdEeFf)

Query

Range: "0000" to "FFFF"

(The return string is always 4 characters from the set 0123456789ABCDEF, enclosed by double quotes.)

*RST Setting

 "5555"

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HRNTi:ALTernate '2222'"
! Sets FDD Test Alternate H-RNTI (Hex) to 2222.

CALL:FDDTest:HRNTi:ALTernate:HSSCCH1

Function

Sets/queries FDD Test "HS-SCCH1 Alternate H-RNTI (Hex)" .

Setting

Range: 0 to FFFF

(1 to 4 characters from the set 0123456789AaBbCcDdEeFf)

Query

Range: "0000" to "FFFF"

(The return string is always 4 characters from the set 0123456789ABCDEF, enclosed by double quotes.)

*RST Setting

 "5555"

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HRNTi:ALTernate '2222'"
! Sets FDD Test HS-SCCH 1 Alternate H-RNTI (Hex) to 2222.

CALL:FDDTest:HRNTi:ALTernate:HSSCCH2

Function

Sets/queries FDD Test "HS-SCCH2 Alternate H-RNTI (Hex)" .

Setting

Range: 0 to FFFF

(1 to 4 characters from the set 0123456789AaBbCcDdEeFf)

Query

Range: "0000" to "FFFF"

(The return string is always 4 characters from the set 0123456789ABCDEF, enclosed by double quotes.)

*RST Setting

 "5555"

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HRNTi:ALTernate '2222'"
! Sets FDD Test HS-SCCH 2 Alternate H-RNTI (Hex) to 2222.

CALL:FDDTest:HRNTi:ALTernate:HSSCCH3

Function

Sets/queries FDD Test "HS-SCCH2 Alternate H-RNTI (Hex)" .

Setting

Range: 0 to FFFF

(1 to 4 characters from the set 0123456789AaBbCcDdEeFf)

Query

Range: "0000" to "FFFF"

(The return string is always 4 characters from the set 0123456789ABCDEF, enclosed by double quotes.)

*RST Setting

 "5555"

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HRNTi:ALTernate '2222'"
! Sets FDD Test HS-SCCH 3 Alternate H-RNTI (Hex) to 2222.

CALL:FDDTest:HRNTi:ALTernate:HSSCCH4

Function

Sets/queries FDD Test "HS-SCCH4 Alternate H-RNTI (Hex)" .

Setting

Range: 0 to FFFF

(1 to 4 characters from the set 0123456789AaBbCcDdEeFf)

Query

Range: "0000" to "FFFF"

(The return string is always 4 characters from the set 0123456789ABCDEF, enclosed by double quotes.)

*RST Setting

 "5555"

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HRNTi:ALTernate '2222'"
! Sets FDD Test HS-SCCH 4 Alternate H-RNTI (Hex) to 2222.

CALL:FDDTest:HSDSchannel:CONFig[:TYPE]

Function

 Sets/queries FDD Test "RB Test HS-DSCH Configuration Type" on page 1 .

Setting

Range: FRC|UDEFined

Query

 Same as setting

*RST Setting

 FRC

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:HSDSchannel:CONFig UDEFined"
! Sets FDD Test HS-DSCH Configuration Type to User Defined.

CALL:FDDTest:HSDSchannel:DATA

Function

Sets/queries FDD Test "HS-DSCH Data Pattern" .

Setting

Range:

  • ABITs (Alternating)
  • INCRement (Incrementing)
  • ONES (All Ones)
  • PRBS23 (CCITT PRBS23)
  • PRBS20 (CCITT PRBS20)
  • PRBS15 (CCITT PRBS15)
  • PRBS9 (CCITT PRBS9)
  • ZERos (All Zeros)

Query

Range:

  • ABIT (Alternating)
  • INCR (Incrementing)
  • ONES (All Ones)
  • PRBS23 (CCITT PRBS23)
  • PRBS20 (CCITT PRBS20)
  • PRBS15 (CCITT PRBS15)
  • PRBS9 (CCITT PRBS9)
  • ZER (All Zeros)

*RST Setting

 PRBS15

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Lab Application Revision: F.00 added PRBS23 and PRBS20

Programming Example

OUTPUT 714;"CALL:FDDTest:HSDSchannel:DATA ONES"
! Sets FDD Test HS-DSCH Data Pattern to All Ones.

CALL:FDDTest:HSDSchannel:MS:CATegory

Function

Sets/queries FDD Test UE HS-DSCH Category .

This command is only applicable when CALL:FDDTest:HSDSchannel:UDEFined:MS:IREDundancy:BUFFer:ALLocation is set to IMPLicit .

Setting

Range: 1 to 14,17,18,21-24

Resolution: 1

Query

 Same as setting

*RST Setting

 1

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Test Application Revision A.10 and Lab Application Revision D.01 added UE categories 7 and 8

Test Application Revision: A.19.00 and above with the required feature license, added 21-24.
Lab Application Revision: H.01.00 and above, added 21-24.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSDSchannel:MS:CATegory 12"
! Sets FDD Test UE HS-DSCH Category to 12.

CALL:FDDTest:HSDSchannel:UDEFined:DCHSdpa[:STATe]

Function

Sets/queries whether the FDD Test Mode HSDPA/HSPA cell configuration should include DC-HSDPA. If it is set to ON, DC-HSDPA will be configured.

Setting

Range: 1|ON|0|OFF

Query

 Same as setting

*RST Setting

 0 (OFF)

Requirements

Test Application Revision: A.19.00 and above, with the required feature license

Lab Application Revision: H.01.00 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:HSDSchannel:UDEFined:DCHSdpa ON"
! Sets FDDT DC-HSDPA State to ON.

CALL:FDDTest:HSDSchannel:UDEFined:HARQ:PROCess:COUNt

Function

 Sets/queries FDD Test "User Defined Number of HARQ Processes" on page 5 .

Setting

Range: 1 to 8

Resolution: 1

Query

 Same as setting

*RST Setting

 2

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:HSDSchannel:UDEFined:HARQ:PROCess:COUNt 1"
! Sets FDD Test User Defined Number of HARQ Processes to 1.

CALL:FDDTest:HSDSchannel:UDEFined:HSPDschannel:COUNt

Function

 Sets/queries FDDT "User Defined Number of Active HS-PDSCHs" on page 4 .

Setting

Range: 1 to 10

Resolution: 1

Query

 Same as setting

*RST Setting

 5

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Test Application Revision A.10 and Lab Application Revision D.01 expanded range from "1 to 5" to "1 to 10"

Programming Example

OUTPUT 714;"CALL:FDDTest:HSDSchannel:UDEFined:HSPDschannel:COUNt 3"
! Sets FDDT User Defined Number of Active HS-PDSCHs to 3.

CALL:FDDTest:HSDSchannel:UDEFined:ITTI[:INTerval]

Function

 Sets/queries FDD Test "User Defined Inter-TTI Interval" on page 5 .

Setting

Range: 1 to 3

Resolution: 1

Query

 Same as setting

*RST Setting

 3

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:HSDSchannel:UDEFined:ITTI 1"
! Sets FDD Test User Defined Inter-TTI Interval to 1.

CALL:FDDTest:HSDSchannel:UDEFined:MAC

Function

 Sets/queries FDD Test "User Defined HS-DSCH MAC Entity" on page 7 .

Setting

Range: HSPeed | EHSPeed

Query

 Range: HSP | EHSP

*RST Setting

 HSPeed

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:FDDTest:HSDSchannel:UDEFined:MAC HSPeed"
! Sets the FDD Test Mode HS-DSCH MAC entity to MAC-hs.

CALL:FDDTest:HSDSchannel:UDEFined:MACEHS:TBSTable:ALIGnment

Function

 Sets/queries FDD Test "User Defined MAC-ehs HS-DSCH TB Size Table" on page 7 .

Setting

Range: BIT | OCTet

Query

 Range: BIT | OCT

*RST Setting

 OCTet

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:HSDSchannel:UDEFined:MACEHS:TBSTable:ALIGnment OCTet"
! Sets the FDD Test Mode MAC-ehs HS-DSCH TB size table to octet-aligned.

CALL:FDDTest:HSDSchannel:UDEFined:MODulation[:TYPE]

Function

 Sets/queries FDD Test "User Defined Modulation Type" on page 5 .

Setting

Range: QPSK|QAM16|QAM64

Query

 Same as setting

*RST Setting

 QPSK

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Lab Application Revision: F.00 and Test Application Revision: A.14, added QAM64

Programming Example

OUTPUT 714;"CALL:FDDTest:HSDSchannel:UDEFined:MODulation QAM16"
! Sets FDD Test User Defined Modulation Type to 16QAM.

CALL:FDDTest:HSDSchannel:UDEFined:MS:IREDundancy:BUFFer:ALLocation

Function

Sets/queries FDD Test User Defined UE IR Buffer Allocation .

When this command is set to IMPLicit , the UE IR buffer size is determined by the CALL:FDDTest:HSDSchannel:MS:CATegory setting.

When this command is set to EXPLicit , the UE IR buffer size is determined by the CALL:FDDTest:HSDSchannel:UDEFined:MS:IREDundancy:BUFFer:SIZE[:EXPLicit] setting.

Setting

Range: IMPLicit|EXPLicit

Query

 Same as setting

*RST Setting

 IMPLicit

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:HSDSchannel:UDEFined:MS:IREDundancy:BUFFer:ALLocation EXPLicit"
! Sets FDD Test User Defined UE IR Buffer Allocation to Explicit.

CALL:FDDTest:HSDSchannel:UDEFined:MS:IREDundancy:BUFFer:SIZE[:EXPLicit]

Function

Sets/queries FDDT "User Defined Explicit UE IR Buffer Size" .

This command is only applicable when CALL:FDDTest:HSDSchannel:UDEFined:MS:IREDundancy:BUFFer:ALLocation is set to EXPLicit .

Setting

Range: 800, 1600, 2400, 3200, 4000, 4800, 5600, 6400, 7200, 8000, 8800, 9600, 10400, 11200, 12000, 12800, 13600, 14400, 15200, 16000, 17600, 19200, 20800, 22400, 24000, 25600, 27200, 28800, 30400, 32000, 36000, 40000, 44000, 48000, 52000, 56000, 60000, 64000, 68000, 72000, 76000, 80000, 88000, 96000, 104000, 112000, 120000, 128000, 136000, 144000, 152000, 160000, 176000, 192000, 208000, 224000, 240000, 256000, 272000, 288000, 304000

Resolution: 1

Query

 Same as setting

*RST Setting

 19200

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:HSDSchannel:UDEFined:MS:IREDundancy:BUFFer:SIZE 9600"
! Sets FDDT User Defined Explicit UE IR Buffer Size to 9600.

CALL:FDDTest:HSDSchannel:UDEFined:TBSize:INDex

Function

Sets/queries FDDT "User Defined Transport Block Size Index" on page 4 .

You can query the transport block size using the CALL:STATus:HSDSchannel:TBSize? query.

Setting

Range: 0 to 62

Resolution: 1

Query

 Same as setting

*RST Setting

 62

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:HSDSchannel:UDEFined:TBSize:INDex 48"
! Sets FDDT User Defined Transport Block Size Index to 48.

CALL:FDDTest:HSDSchannel:UDEFined:QAM64:STATe

Function

Sets/queries FDD Test "User Defined 64QAM State" on page 7 . This parameter is used when CALL:FDDTest:HSDSchannel:UDEFined:MAC is set to EHSPeed (MAC-ehs).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (OFF)

Requirements

Test or Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:HSDSchannel:UDEFined:QAM64:STATe OFF"

CALL:FDDTest:HSPDschannel[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the HSDPA FDD Test HS-PDSCHs Level (Sum) (see CALL:FDDTest:HSPDschannel:LEVel ) and (2) sets the HSDPA FDD Test HS-PDSCHs Level (Sum) state to on (see CALL:FDDTest:HSPDschannel:STATe ).

The query form of this command returns the HSDPA FDD Test HS-PDSCHs Level (Sum) .

See HSDPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -3 dB (on)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSPDschannel -4"
! Sets the FDD Test HS-PDSCHs Level (Sum)
 to -4 dB and turns its state on.

CALL:FDDTest:HSPDschannel[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA FDD Test HS-PDSCHs Level (Sum) (see CALL:FDDTest:HSPDschannel:LEVel:HSPA ) and (2) sets the HSPA FDD Test HS-PDSCHs Level (Sum) state to on (see CALL:FDDTest:HSPDschannel:STATe:HSPA ).

The query form of this command returns the HSPA FDD Test HS-PDSCHs Level (Sum) .

See HSPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -3 dB (on)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSPDschannel:HSPA -4"
! Sets the HSPA FDD Test HS-PDSCHs Level (Sum)
 to -4 dB and turns its state on.

CALL:FDDTest:HSPDschannel:CCODe

Function

THIS COMMAND IS OBSOLETE. Please use CALL:FDDTest:HSPDschannel:CCODe:CODE .

Sets/queries FDD Test First HS-PDSCH Channelization Code .

Setting

Range: CODE5|CODE6|CODE7|CODE8|CODE9|CODE10|CODE11|CODE12|CODE13|CODE14

Query

 Same as setting

*RST Setting

 CODE7

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Test Application Revision A.10.01 and Lab Application Revision D.01.01 added CODE5 and CODE6.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSPDschannel:CCODe CODE8"
! Sets FDD Test First HS-PDSCH Channelization Code to 8.

CALL:FDDTest:HSPDschannel:CCODe:CODE

Function

Sets/queries FDD Test First HS-PDSCH Channelization Code .

Setting

Range: 1 to 15

Query

 Same as setting

*RST Setting

 7

Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:HSPDschannel:CCODe:CODE 7"
! Sets FDD Test First HS-PDSCH Channelization Code to 7.

CALL:FDDTest:HSPDschannel:LEVel

Function

Sets/queries the HSDPA FDD Test HS-PDSCHs Level (Sum) . See HSDPA in FDD Test Operating Mode .

The HSDPA FDD Test HS-PDSCHs Level (Sum) can also be set using the CALL:FDDTest:HSPDschannel[:SLEVel] command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -3 dB

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSPDschannel:LEVel -4"

CALL:FDDTest:HSPDschannel:LEVel:HSPA

Function

Sets/queries the HSPA FDD Test HS-PDSCHs Level (Sum) . See HSPA in FDD Test Operating Mode .

The HSPA FDD Test HS-PDSCHs Level (Sum) can also be set using the CALL:FDDTest:HSPDschannel[:SLEVel]:HSPA command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -3 dB

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSPDschannel:LEVel:HSPA -4"

CALL:FDDTest:HSPDschannel:STATe

Function

Sets/queries the HSDPA FDD Test HS-PDSCHs Level (Sum) state. See HSDPA in FDD Test Operating Mode .

The HSDPA FDD Test HS-PDSCHs Level (Sum) state can also be set using the CALL:FDDTest:HSPDschannel[:SLEVel] command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSPDschannel:STATe ON"

CALL:FDDTest:HSPDschannel:STATe:HSPA

Function

Sets/queries the HSPA FDD Test HS-PDSCHs Level (Sum) state. See HSPA in FDD Test Operating Mode .

The HSPA FDD Test HS-PDSCHs Level (Sum) state can also be set using the CALL:FDDTest:HSPDschannel[:SLEVel]:HSPA command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSPDschannel:STATe:HSPA ON"

CALL:FDDTest:HSSCchannel[1][:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the FDD Test HS-SCCH 1 Level (see CALL:FDDTest:HSSCchannel[1]:LEVel ) and (2) sets the FDD Test HS-SCCH 1 Level state to on (see CALL:FDDTest:HSSCchannel[1]:STATe ).

The query form of this command returns the FDD Test HS-SCCH 1 Level .

See HSDPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB (on)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel -11"
! Sets the FDD Test HS-SCCH 1 Level

 to -11 dB and turns its state on.

CALL:FDDTest:HSSCchannel[1][:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA FDD Test HS-SCCH 1 Level (see CALL:FDDTest:HSSCchannel[1]:LEVel:HSPA ) and (2) sets the HSPA FDD Test HS-SCCH 1 Level state to on (see CALL:FDDTest:HSSCchannel[1]:STATe:HSPA ).

The query form of this command returns the HSPA FDD Test HS-SCCH 1 Level .

See HSPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB (on)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel:HSPA -11"
! Sets the HSPA FDD Test HS-SCCH 1 Level

 to -11 dB and turns its state on.

CALL:FDDTest:HSSCchannel[1]:CONFig:STATe

Function

Sets/queries the FDD Test Mode HSDPA/HSPA HS-SCCH 1 Channel Configuration State.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Lab Application Revision: F.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel:CONFig:STATe ON"

CALL:FDDTest:HSSCchannel[1]:LEVel

Function

Sets/queries the FDD Test HS-SCCH 1 Level . See HSDPA in FDD Test Operating Mode .

The FDD Test HS-SCCH 1 Level can also be set using the CALL:FDDTest:HSSCchannel[1][:SLEVel] command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel:LEVel -11"

CALL:FDDTest:HSSCchannel[1]:LEVel:HSPA

Function

Sets/queries the HSPA FDD Test HS-SCCH 1 Level . See HSPA in FDD Test Operating Mode .

The HSPA FDD Test HS-SCCH 1 Level can also be set using the CALL:FDDTest:HSSCchannel[1][:SLEVel]:HSPA command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -10 dB

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel:LEVel:HSPA -11"

CALL:FDDTest:HSSCchannel[1]:STATe

Function

Sets/queries the FDD Test HS-SCCH 1 Level state. See HSDPA in FDD Test Operating Mode .

The FDD Test HS-SCCH 1 Level state can also be set using the CALL:FDDTest:HSSCchannel[1][:SLEVel] command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel:STATe ON"

CALL:FDDTest:HSSCchannel[1]:STATe:HSPA

Function

Sets/queries the HSPA FDD Test HS-SCCH 1 Level state. See HSPA in FDD Test Operating Mode .

The HSPA FDD Test HS-SCCH 1 Level state can also be set using the CALL:FDDTest:HSSCchannel[1][:SLEVel]:HSPA command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel:STATe:HSPA ON"

CALL:FDDTest:HSSCchannel2[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the FDD Test HS-SCCH 2 Level (see CALL:FDDTest:HSSCchannel2:LEVel ) and (2) sets the FDD Test HS-SCCH 2 Level state to on (see CALL:FDDTest:HSSCchannel2:STATe ).

The query form of this command returns the FDD Test HS-SCCH 2 Level .

See HSDPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB (off)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel2 -11"
! Sets the FDD Test HS-SCCH 2 Level

 to -11 dB and turns its state on.

CALL:FDDTest:HSSCchannel2[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA FDD Test HS-SCCH 2 Level (see CALL:FDDTest:HSSCchannel2:LEVel:HSPA ) and (2) sets the HSPA FDD Test HS-SCCH 2 Level state to on (see CALL:FDDTest:HSSCchannel2:STATe:HSPA ).

The query form of this command returns the HSPA FDD Test HS-SCCH 2 Level .

See HSPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB (off)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel2:HSPA -11"
! Sets the HSPA FDD Test HS-SCCH 2 Level

 to -11 dB and turns its state on.

CALL:FDDTest:HSSCchannel2:CONFig:STATe

Function

Sets/queries the FDD Test Mode HSDPA/HSPA HS-SCCH 2 Channel Configuration State.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Lab Application Revision: F.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel2:CONFig:STATe ON"

CALL:FDDTest:HSSCchannel2:LEVel

Function

Sets/queries the FDD Test HS-SCCH 2 Level . See HSDPA in FDD Test Operating Mode .

The FDD Test HS-SCCH 2 Level can also be set using the CALL:FDDTest:HSSCchannel2[:SLEVel] command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel2:LEVel -11"

CALL:FDDTest:HSSCchannel2:LEVel:HSPA

Function

Sets/queries the HSPA FDD Test HS-SCCH 2 Level . See HSPA in FDD Test Operating Mode .

The HSPA FDD Test HS-SCCH 2 Level can also be set using the CALL:FDDTest:HSSCchannel2[:SLEVel]:HSPA command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel2:LEVel:HSPA -11"

CALL:FDDTest:HSSCchannel2:STATe

Function

Sets/queries the FDD Test HS-SCCH 2 Level state. See HSDPA in FDD Test Operating Mode .

The FDD Test HS-SCCH 2 Level state can also be set using the CALL:FDDTest:HSSCchannel2[:SLEVel] command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel2:STATe ON"

CALL:FDDTest:HSSCchannel2:STATe:HSPA

Function

Sets/queries the HSPA FDD Test HS-SCCH 2 Level state. See HSPA in FDD Test Operating Mode .

The HSPA FDD Test HS-SCCH 2 Level state can also be set using the CALL:FDDTest:HSSCchannel2[:SLEVel]:HSPA command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel2:STATe:HSPA ON"

CALL:FDDTest:HSSCchannel3[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the FDD Test HS-SCCH 3 Level (see CALL:FDDTest:HSSCchannel3:LEVel ) and (2) sets the FDD Test HS-SCCH 3 Level state to on (see CALL:FDDTest:HSSCchannel3:STATe ).

The query form of this command returns the FDD Test HS-SCCH 3 Level .

See HSDPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB (off)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel3 -11"
! Sets the FDD Test HS-SCCH 3 Level

 to -11 dB and turns its state on.

CALL:FDDTest:HSSCchannel3[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA FDD Test HS-SCCH 3 Level (see CALL:FDDTest:HSSCchannel3:LEVel:HSPA ) and (2) sets the HSPA FDD Test HS-SCCH 3 Level state to on (see CALL:FDDTest:HSSCchannel3:STATe:HSPA ).

The query form of this command returns the HSPA FDD Test HS-SCCH 3 Level .

See HSPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB (off)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel3:HSPA -11"
! Sets the HSPA FDD Test HS-SCCH 3 Level

 to -11 dB and turns its state on.

CALL:FDDTest:HSSCchannel3:CONFig:STATe

Function

Sets/queries the FDD Test Mode HSDPA/HSPA HS-SCCH 3 Channel Configuration State.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Lab Application Revision: F.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel3:CONFig:STATe ON"

CALL:FDDTest:HSSCchannel3:LEVel

Function

Sets/queries the FDD Test HS-SCCH 3 Level . See HSDPA in FDD Test Operating Mode .

The FDD Test HS-SCCH 3 Level can also be set using the CALL:FDDTest:HSSCchannel3[:SLEVel] command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel3:LEVel -11"

CALL:FDDTest:HSSCchannel3:LEVel:HSPA

Function

Sets/queries the HSPA FDD Test HS-SCCH 3 Level . See HSPA in FDD Test Operating Mode .

The HSPA FDD Test HS-SCCH 3 Level can also be set using the CALL:FDDTest:HSSCchannel3[:SLEVel]:HSPA command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel3:LEVel:HSPA -11"

CALL:FDDTest:HSSCchannel3:STATe

Function

Sets/queries the FDD Test HS-SCCH 3 Level state. See HSDPA in FDD Test Operating Mode .

The FDD Test HS-SCCH 3 Level state can also be set using the CALL:FDDTest:HSSCchannel3[:SLEVel] command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel3:STATe ON"

CALL:FDDTest:HSSCchannel3:STATe:HSPA

Function

Sets/queries the HSPA FDD Test HS-SCCH 3 Level state. See HSPA in FDD Test Operating Mode .

The HSPA FDD Test HS-SCCH 3 Level state can also be set using the CALL:FDDTest:HSSCchannel3[:SLEVel]:HSPA command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel3:STATe:HSPA ON"

CALL:FDDTest:HSSCchannel4[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the FDD Test HS-SCCH 4 Level (see CALL:FDDTest:HSSCchannel4:LEVel ) and (2) sets the FDD Test HS-SCCH 4 Level state to on (see CALL:FDDTest:HSSCchannel4:STATe ).

The query form of this command returns the FDD Test HS-SCCH 4 Level .

See HSDPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB (off)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel4 -11"
! Sets the FDD Test HS-SCCH 4 Level

 to -11 dB and turns its state on.

CALL:FDDTest:HSSCchannel4[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA FDD Test HS-SCCH 4 Level (see CALL:FDDTest:HSSCchannel4:LEVel:HSPA ) and (2) sets the HSPA FDD Test HS-SCCH 4 Level state to on (see CALL:FDDTest:HSSCchannel4:STATe:HSPA ).

The query form of this command returns the HSPA FDD Test HS-SCCH 4 Level .

See HSPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB (off)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel4:HSPA -11"
! Sets the HSPA FDD Test HS-SCCH 4 Level

 to -11 dB and turns its state on.

CALL:FDDTest:HSSCchannel4:CONFig:STATe

Function

Sets/queries the FDD Test Mode HSDPA/HSPA HS-SCCH 4 Channel Configuration State.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Lab Application Revision: F.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel4:CONFig:STATe ON"

CALL:FDDTest:HSSCchannel4:LEVel

Function

Sets/queries the FDD Test HS-SCCH 4 Level . See HSDPA in FDD Test Operating Mode .

The FDD Test HS-SCCH 4 Level can also be set using the CALL:FDDTest:HSSCchannel4[:SLEVel] command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel4:LEVel -11"

CALL:FDDTest:HSSCchannel4:LEVel:HSPA

Function

Sets/queries the HSPA FDD Test HS-SCCH 4 Level . See HSPA in FDD Test Operating Mode .

The HSPA FDD Test HS-SCCH 4 Level can also be set using the CALL:FDDTest:HSSCchannel4[:SLEVel]:HSPA command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel4:LEVel:HSPA -11"

CALL:FDDTest:HSSCchannel4:STATe

Function

Sets/queries the FDD Test HS-SCCH 4 Level state. See HSDPA in FDD Test Operating Mode .

The FDD Test HS-SCCH 4 Level state can also be set using the CALL:FDDTest:HSSCchannel4[:SLEVel] command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel4:STATe ON"

CALL:FDDTest:HSSCchannel4:STATe:HSPA

Function

Sets/queries the HSPA FDD Test HS-SCCH 4 Level state. See HSPA in FDD Test Operating Mode .

The HSPA FDD Test HS-SCCH 4 Level state can also be set using the CALL:FDDTest:HSSCchannel4[:SLEVel]:HSPA command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:HSSCchannel4:STATe:HSPA ON"

CALL:FDDTest:MACHs:HEADer

Function

Sets/queries the MAC-hs Header .

Setting

Range: PRESent|DATA

Query

Range: PRES|DATA

*RST Setting

 PRES

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:MACHs:HEADer DATA"
! Sets the MAC-hs Header to Used for Data.

CALL:FDDTest:MACHs:NTRans

Function

Sets/queries the FDD Test Number of Transmissions .

Setting

Range: 1 to 8

Query

 Same as setting

*RST Setting

 4

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:MACHs:NTRans 2"
! Sets the FDD Test Number of Transmissions to 2.

CALL:FDDTest:MACHs:RVSequence

Function

Sets/queries the FDD Test RV Sequence .

Note: The number of RV parameters in the sequence that are used is determined by the FDD Test Number of Transmissions setting (see CALL:FDDTest:MACHs:NTRans ). The RV parameters at the end of the list are not used if FDD Test Number of Transmissions is less than 8.

Setting

Range: Comma separated list of 1 to 8 characters from the set 01234567.

Query

Range: Comma separated list of 8 characters from the set 01234567, enclosed by double quotes (if you enter fewer than 8 characters, the query result will fill the remaining characters with zeros).

*RST Setting

 0,2,5,6,0,0,0,0

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:MACHs:RVSequence '0,2,7,4,3,1'"
! Sets the FDD Test RV Sequence to 0,2,7,4,3,1,0,0.

CALL:FDDTest:MACHs:SDTX:RBEHavior

Function

Sets/queries the FDD Test statDTX Reception Behavior .

Setting

Range: ACK|NACK|SDTX

Query

 Same as setting

*RST Setting

 SDTX

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:MACHs:SDTX:RBEHavior ACK"
! Sets the FDD Test statDTX Reception Behavior to Handle as ACK.

CALL:FDDTest:MACHs:WSIZe:TRANsmit

Function

Sets/queries the MAC-hs Transmit Window Size . This setting is only applicable if CALL:FDDTest:MACHs:HEADer is set to Present .

Setting

Range: PDU4|PDU6|PDU8|PDU12|PDU16|PDU24|PDU32

Query

 Same as setting

*RST Setting

 PDU16

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:MACHs:WSIZe:TRANsmit PDU12"
! Sets the MAC-hs Transmit Window Size to 12.

CALL:FDDTest:OCNSource:CONFig:STATe:HSDPa

Function

Sets/queries the FDD Test HSDPA/HSPA OCNS 1 to 6 Channel Configuration States.

Setting

 Range: 1|ON|0|OFF

Query

Range: 0|1

*RST Setting

 1 (ON), 1 (ON), 1 (ON), 1 (ON), 1 (ON), 1 (ON)
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:CONFig:STATe:HSDPa 1, 1, 1, 1, 1, 1"

CALL:FDDTest:OCNSource:POFFset:HSDPa

Function

Sets/queries the FDD Test HSDPA/HSPA orthogonal channel noise simulator (OCNS) 1 to 6 Power Offsets (raletive levels).

Query

Range: 0 to -20 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 0 dB

Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:OCNSource:POFFset:HSDPa 0, 0, 0, 0, 0, 0"

CALL:FDDTest:PICHannel[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the FDD Test PICH Level (see CALL:FDDTest:PICHannel:LEVel ) and (2) sets the FDD Test PICH state to on (see CALL:FDDTest:PICHannel:STATe ).

The query form of this command returns the FDD Test PICH Level .

See FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -8.33 dB (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:PICHannel -13"
! Sets the FDD Test PICH Level to -13 dB and turns its state on.

CALL:FDDTest:PICHannel[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the HSDPA FDD Test PICH Level (see CALL:FDDTest:PICHannel:LEVel:HSDPa ) and (2) sets the HSDPA FDD Test PICH state to on (see CALL:FDDTest:PICHannel:STATe:HSDPa ).

The query form of this command returns the HSDPA FDD Test PICH Level .

See HSDPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB (on)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:PICHannel:HSDPa -13"
! Sets the HSDPA FDD Test PICH Level to -13 dB and turns its state on.

CALL:FDDTest:PICHannel[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the HSPA FDD Test PICH Level (see CALL:FDDTest:PICHannel:LEVel:HSPA ) and (2) sets the HSPA FDD Test PICH state to on (see CALL:FDDTest:PICHannel:STATe:HSPA ).

The query form of this command returns the HSPA FDD Test PICH Level .

See HSPA in FDD Test Operating Mode .

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB (on)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:PICHannel:HSPA -13"
! Sets the HSPA FDD Test PICH Level to -13 dB and turns its state on.

CALL:FDDTest:PICHannel:DATA

Function

Sets/queries the DL PICH Data . The pattern can be set to either all ones or all zeros.

Setting

Range: ALLZERO|ALLONE

Query

Range: ALLZERO|ALLONE

*RST Setting

 All Zeros

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:PICHannel:DATA ALLONE"
! Sets the paging indicator channel data to all ones.

CALL:FDDTest:PICHannel:LEVel

Function

Sets/queries the FDD Test PICH Level . See FDD Test Operating Mode .

The FDD Test PICH Level can also be set using the CALL:FDDTest:PICHannel[:SLEVel] command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -8.33 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:PICH:LEVel -7"

CALL:FDDTest:PICHannel:LEVel:HSDPa

Function

Sets/queries the HSDPA FDD Test PICH Level . See HSDPA in FDD Test Operating Mode .

The HSDPA FDD Test PICH Level can also be set using the CALL:FDDTest:PICHannel[:SLEVel]:HSDPa command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:PICH:LEVel:HSDPa -7"

CALL:FDDTest:PICHannel:LEVel:HSPA

Function

Sets/queries the HSPA FDD Test PICH Level . See HSPA in FDD Test Operating Mode .

The HSPA FDD Test PICH Level can also be set using the CALL:FDDTest:PICHannel[:SLEVel]:HSPA command.

Setting

Range: -20.00 dB to 0 dB, 9.91 E+37

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15 dB

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:PICH:LEVel:HSPA -7"

CALL:FDDTest:PICHannel:STATe

Function

Sets/queries the FDD Test PICH state. See FDD Test Operating Mode .

The FDD Test PICH state can also be set using the CALL:FDDTest:PICHannel[:SLEVel] command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTest:PICHannel:STATe ON"

CALL:FDDTest:PICHannel:STATe:HSDPa

Function

Sets/queries the HSDPA FDD Test PICH state. See HSDPA in FDD Test Operating Mode .

The HSDPA FDD Test PICH state can also be set using the CALL:FDDTest:PICHannel[:SLEVel]:HSDPa command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision A.08 and above, with the required feature license.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:PICHannel:STATe:HSDPa ON"

CALL:FDDTest:PICHannel:STATe:HSPA

Function

Sets/queries the HSPA FDD Test PICH state. See HSPA in FDD Test Operating Mode .

The HSPA FDD Test PICH state can also be set using the CALL:FDDTest:PICHannel[:SLEVel]:HSPA command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision A.12 and above, with the required feature license.

Lab Application Revision: E.00.16 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:PICHannel:STATe:HSPA ON"

CALL:FDDTest:TFCIndicator

Function

Sets/queries the DL TFCI Pattern .

Setting

Range: 000 to 3FF

(0 to 3 characters from the set 0123456789aAbBcCdDeEfF, up to 3FF)

Query

Range: "000" to "3FF"

(The return string is always 3 characters from the set 0123456789ABCDEF, up to 3FF)

*RST Setting

 "000"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FDDTEST:TFCINDICATOR '2DE'"

CALL:FDDTest:UPLink:TFCIndicator:CONTrol:AUTO

Function

Sets/queries Uplink TFCI Control .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (manual)

Requirements

Test Application Revision: A.10 and above

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:FDDTEST:UPLink:TFCIndicator:CONTrol:AUTO 1"
! Sets Uplink TFCI Control to Auto.

CALL:FDDTest:UPLink:TFCIndicator:MANual

Function

Sets/queries Manual Uplink TFCI .

This setting is only applicable when CALL:FDDTest:UPLink:TFCIndicator:CONTrol:AUTO is set to OFF (manual).

Setting

Range: DTCHannel (DTCH Only)|DTDCchannel (DTCH + DCCH)

Query

Range: DTCH|DTDC

*RST Setting

 DTDC

Requirements

Test Application Revision: A.10 and above

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:FDDTEST:UPLink:TFCIndicator:MANual DTCH"
! Sets Manual Uplink TFCI to DTCH Only.


CALL:FDDTest:SSCell

CALL:FDDTest:SSCell

Last updated: January 14, 2012

NOTE
The CALL:FDDTest:SSCell commands .

GPIB Command Conventions

  • CALL:FDDTest:SSCell:CHANnel:ADJacent

  • CALL:FDDTest:SSCell:HSPDschannel:CCODe:CODE

  • CALL:FDDTest:SSCell:HSSCchannel[1]:CONFig:STATe
  • CALL:FDDTest:SSCell:HSSCchannel2:CONFig:STATe
  • CALL:FDDTest:SSCell:HSSCchannel3:CONFig:STATe
  • CALL:FDDTest:SSCell:HSSCchannel4:CONFig:STATe
  • CALL:FDDTest:SSCell:OCNSource:CONFig:STATe:HSDPa

  • CALL:FDDTest:SSCell:CPIChannel:LEVel:HSDPa
  • CALL:FDDTest:SSCell:CPIChannel:STATe:HSDPa
  • CALL:FDDTest:SSCell:CPIChannel[:SLEVel]:HSDPa
  • CALL:FDDTest:SSCell:CPIChannel:LEVel:HSPA
  • CALL:FDDTest:SSCell:CPIChannel[:SLEVel]:HSPA
  • CALL:FDDTest:SSCell:CPIChannel:STATe:HSPA
  • CALL:FDDTest:SSCell:CCPChannel:PRIMary:LEVel:HSDPa
  • CALL:FDDTest:SSCell:CCPChannel:PRIMary:STATe:HSDPa
  • CALL:FDDTest:SSCell:CCPChannel:PRIMary[:SLEVel]:HSDPa
  • CALL:FDDTest:SSCell:CCPChannel:PRIMary:LEVel:HSPA
  • CALL:FDDTest:SSCell:CCPChannel:PRIMary:STATe:HSPA
  • CALL:FDDTest:SSCell:CCPChannel:PRIMary[:SLEVel]:HSPA
  • CALL:FDDTest:SSCell:PICHannel:LEVel:HSDPa
  • CALL:FDDTest:SSCell:PICHannel:STATe:HSDPa
  • CALL:FDDTest:SSCell:PICHannel[:SLEVel]:HSDPa
  • CALL:FDDTest:SSCell:PICHannel:LEVel:HSPA
  • CALL:FDDTest:SSCell:PICHannel:STATe:HSPA
  • CALL:FDDTest:SSCell:PICHannel[:SLEVel]:HSPA
  • CALL:FDDTest:SSCell:HSPDschannel:LEVel:HSDPa
  • CALL:FDDTest:SSCell:HSPDschannel:STATe:HSDPa
  • CALL:FDDTest:SSCell:HSPDschannel[:SLEVel]:HSDPa
  • CALL:FDDTest:SSCell:HSPDschannel:LEVel:HSPA
  • CALL:FDDTest:SSCell:HSPDschannel:STATe:HSPA
  • CALL:FDDTest:SSCell:HSPDschannel[:SLEVel]:HSPA
  • CALL:FDDTest:SSCell:HSSCchannel1:LEVel:HSDPa
  • CALL:FDDTest:SSCell:HSSCchannel1:STATe:HSDPa
  • CALL:FDDTest:SSCell:HSSCchannel1[:SLEVel]:HSDPa
  • CALL:FDDTest:SSCell:HSSCchannel1:LEVel:HSPA
  • CALL:FDDTest:SSCell:HSSCchannel1:STATe:HSPA
  • CALL:FDDTest:SSCell:HSSCchannel1[:SLEVel]:HSPA
  • CALL:FDDTest:SSCell:HSSCchannel2:LEVel:HSDPa
  • CALL:FDDTest:SSCell:HSSCchannel2:STATe:HSDPa
  • CALL:FDDTest:SSCell:HSSCchannel2[:SLEVel]:HSDPa
  • CALL:FDDTest:SSCell:HSSCchannel2:LEVel:HSPA
  • CALL:FDDTest:SSCell:HSSCchannel2:STATe:HSPA
  • CALL:FDDTest:SSCell:HSSCchannel2[:SLEVel]:HSPA
  • CALL:FDDTest:SSCell:HSSCchannel3:LEVel:HSDPa
  • CALL:FDDTest:SSCell:HSSCchannel3:STATe:HSDPa
  • CALL:FDDTest:SSCell:HSSCchannel3[:SLEVel]:HSDPa
  • CALL:FDDTest:SSCell:HSSCchannel3:LEVel:HSPA
  • CALL:FDDTest:SSCell:HSSCchannel3:STATe:HSPA
  • CALL:FDDTest:SSCell:HSSCchannel3[:SLEVel]:HSPA
  • CALL:FDDTest:SSCell:HSSCchannel4:LEVel:HSDPa
  • CALL:FDDTest:SSCell:HSSCchannel4:STATe:HSDPa
  • CALL:FDDTest:SSCell:HSSCchannel4[:SLEVel]:HSDPa
  • CALL:FDDTest:SSCell:HSSCchannel4:LEVel:HSPA CALL:FDDTest:SSCell:HSSCchannel4:LEVel:HSPA
  • CALL:FDDTest:SSCell:HSSCchannel4:STATe:HSPA
  • CALL:FDDTest:SSCell:HSSCchannel4[:SLEVel]:HSPA
  • CALL:FDDTest:SSCell:OCNSource:POFFset:HSDPa

  • CALL:FDDTest:SSCell:HRNTi

  • CALL:FDDTest:SSCell:HSDSchannel:UDEFined:MACEHS:TBSTable:ALIGnment
  • CALL:FDDTest:SSCell:HSDSchannel:UDEFined:QAM64:STATe
  • CALL:FDDTest:SSCell:HSDSchannel:UDEFined:ITTI[:INTerval]
  • CALL:FDDTest:SSCell:HSDSchannel:UDEFined:MODulation[:TYPE]
  • CALL:FDDTest:SSCell:HSDSchannel:UDEFined:TBSize:INDex
  • CALL:FDDTest:SSCell:HSDSchannel:UDEFined:HSPDschannel:COUNt

CALL:FDDTest:SSCell:CHANnel:ADJacent

Function

Sets/queries the downlink UARFCN of the secondary serving cell.

Setting

Range: Adjacent Higher Carrier|Adjacent Lower Carrier

Query

Same as setting

*RST Setting

Adjacent Higher Carrier

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:CHANnel:ADJacent HIGHer"
! Sets the downlink UARFCN of the secondary serving cell to Adjacent Higher Carrier.

CALL:FDDTest:SSCell:HSPDschannel:CCODe:CODE

Function

Sets/queries the channelization code of the first HS-PDSCH channel in FDD Test Mode. Code 0 is not allowed as it would collide with the CPICH and SCH/PCCPCH channels.

Setting

Range: 1 to 15

Query

Same as setting

*RST Setting

7

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSPDschannel:CCODe:CODE 1"
! Sets the FDD Test Mode Secondary Serving Cell First HS-PDSCH Channelization Code to 1.

CALL:FDDTest:SSCell:HSSCchannel[1]:CONFig:STATe

Function

Sets/queries the FDD Test Mode Secondary Serving Cell HSDPA/HSPA HS-SCCH 1 Channel Configuration state.

Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel:CONFig:STATe OFF"

CALL:FDDTest:SSCell:HSSCchannel2:CONFig:STATe

Function

Sets/queries the FDD Test Mode Secondary Serving Cell HSDPA/HSPA HS-SCCH 2 Channel Configuration state.

Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel2:CONFig:STATe OFF"

CALL:FDDTest:SSCell:HSSCchannel3:CONFig:STATe

Function

Sets/queries the FDD Test Mode Secondary Serving Cell HSDPA/HSPA HS-SCCH 3 Channel Configuration state.

Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel3:CONFig:STATe OFF"

CALL:FDDTest:SSCell:HSSCchannel4:CONFig:STATe

Function

Sets/queries the FDD Test Mode Secondary Serving Cell HSDPA/HSPA HS-SCCH 4 Channel Configuration state.

Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel4:CONFig:STATe OFF"

CALL:FDDTest:SSCell:OCNSource:CONFig:STATe:HSDPa

Function

Sets/queries the FDD Test Mode Secondary Serving Cell HSDPA/HSPA OCNS 1 to 6 Channel Configuration States.

Setting

Range: 1|On|0|Off

Query

Range: 0|1

*RST Setting

 1 (On), 1 (On), 1 (On), 1 (On), 1 (On), 1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:OCNSource:CONFig:STATe:HSDPa 1,0,0,0,0,0"

CALL:FDDTest:SSCell:CPIChannel:LEVel:HSDPa

Function

 Sets/queries the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell CPICH Power Offset.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-10 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:CPIChannel:LEVel:HSDPa -10"
! Sets the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell CPICH Power Offset to -10dB.

CALL:FDDTest:SSCell:CPIChannel:STATe:HSDPa

Function

Sets/queries the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell CPICH state.

Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:CPIChannel:STATe:HSDPa OFF"

CALL:FDDTest:SSCell:CPIChannel[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell CPICH Level (see CALL:FDDTest:SSCell:CPIChannel:LEVel:HSDPa ) and (2) sets the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell CPICH state to on (see CALL:FDDTest:SSCell:CPIChannel:STATe:HSDPa ).

The query form of this command returns the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell CPICH Level.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

 Same as setting

*RST Setting

-10 dB (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:CPIChannel:HSDPa -10"
! Sets the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell CPICH Level to -10dB and turn its state to on.

CALL:FDDTest:SSCell:CPIChannel:LEVel:HSPA

Function

Sets/queries the UTRA FDD Test Mode(HSPA) Secondary Serving Cell CPICH Power Offset.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-10 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:CPIChannel:LEVel:HSPA -10"
! Sets the UTRA FDD Test Mode(HSPA) Secondary Serving Cell CPICH Power Offset to -10dB.

CALL:FDDTest:SSCell:CPIChannel[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the UTRA FDD Test(HSPA) Secondary Serving Cell CPICH Level (see CALL:FDDTest:SSCell:CPIChannel:LEVel:HSPA ) and (2) sets the UTRA FDD Test(HSPA) Secondary Serving Cell CPICH state to on (see CALL:FDDTest:SSCell:CPIChannel:STATe:HSPA ).

The query form of this command returns the UTRA FDD Test(HSPA) Secondary Serving Cell CPICH Level.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

 Same as setting

*RST Setting

-10 dB (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:CPIChannel:HSPA -10"
! Sets the UTRA FDD Test Mode(HSPA) Secondary Serving Cell CPICH Level to -10 dB and turns its state on.

CALL:FDDTest:SSCell:CPIChannel:STATe:HSPA

Function

Sets/queries the UTRA FDD Test Mode(HSPA) Secondary Serving Cell CPICH state.
Setting

Range: 1|On0||Off

Query

Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:CPIChannel:STATe:HSPA OFF"

CALL:FDDTest:SSCell:CCPChannel:PRIMary:LEVel:HSDPa

Function

 Sets/queries the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell P-CCPCH/SCH Power Offset.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-12 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:CCPChannel:PRIMary:LEVel:HSDPa -10"
! Sets the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell P-CCPCH/SCH Power Offset to -10dB.

CALL:FDDTest:SSCell:CCPChannel:PRIMary:STATe:HSDPa

Function

Sets/queries the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell P-CCPCH/SCH state.
Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

1(On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:CCPChannel:PRIMary:STATe:HSDPa OFF"

CALL:FDDTest:SSCell:CCPChannel:PRIMary[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the UTRA FDD Test(HSDPA) Secondary Serving Cell P-CCPCH/SCH Level (see CALL:FDDTest:SSCell:CCPChannel:PRIMary:LEVel:HSDPa ) and (2) sets the UTRA FDD Test(HSDPA) Secondary Serving Cell P-CCPCH/SCH state to on (see CALL:FDDTest:SSCell:CCPChannel:PRIMary:STATe:HSDPa ).

The query form of this command returns the UTRA FDD Test(HSDPA) Secondary Serving Cell P-CCPCH/SCH Level.

Query

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-12 dB (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:CCPChannel:PRIMary:HSDPa -10"
! Sets the UTRA FDD Test(HSDPA) Secondary Serving Cell P-CCPCH/SCH Level to -10 dB and turns its state on.

CALL:FDDTest:SSCell:CCPChannel:PRIMary:LEVel:HSPA

Function

 Sets/queries the UTRA FDD Test Mode(HSPA) Secondary Serving Cell P-CCPCH/SCH Power Offset.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-12 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:CCPChannel:PRIMary:LEVel:HSPA -10"
! Sets the UTRA FDD Test Mode(HSPA) Secondary Serving Cell P-CCPCH/SCH Power Offset to -10dB.

CALL:FDDTest:SSCell:CCPChannel:PRIMary:STATe:HSPA

Function

Sets/queries the UTRA FDD Test Mode(HSPA) Secondary Serving Cell P-CCPCH/SCH state.
Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:CCPChannel:PRIMary:STATe:HSPA OFF"

CALL:FDDTest:SSCell:CCPChannel:PRIMary[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the UTRA FDD Test(HSPA) Secondary Serving Cell P-CCPCH/SCH Level (see CALL:FDDTest:SSCell:CCPChannel:PRIMary:LEVel:HSPA ) and (2) sets the UTRA FDD Test(HSPA) Secondary Serving Cell P-CCPCH/SCH state to on (see CALL:FDDTest:SSCell:CCPChannel:PRIMary:STATe:HSPA ).

The query form of this command returns the UTRA FDD Test(HSPA) Secondary Serving Cell P-CCPCH/SCH Level.

Query

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-12 dB (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:CCPChannel:PRIMary:HSPA -10"
! Sets the UTRA FDD Test(HSPA) Secondary Serving Cell P-CCPCH/SCH Level to -10 dB and turns its state on.

CALL:FDDTest:SSCell:PICHannel:LEVel:HSDPa

Function

Sets/queries the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell PICH Power Offset.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-15 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:PICHannel:LEVel:HSDPa -10"
! Sets the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell PICH Power Offset to -10dB.

CALL:FDDTest:SSCell:PICHannel:STATe:HSDPa

Function

Sets/queries the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell PICH state.
Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:PICHannel:STATe:HSDPa OFF"

CALL:FDDTest:SSCell:PICHannel[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the UTRA FDD Test(HSDPA) Secondary Serving Cell PICH Level (see CALL:FDDTest:SSCell:PICHannel:LEVel:HSDPa ) and (2) sets the UTRA FDD Test(HSDPA) Secondary Serving Cell PICH state to on (see CALL:FDDTest:SSCell:PICHannel:STATe:HSDPa ).

The query form of this command returns the UTRA FDD Test(HSDPA) Secondary Serving Cell PICH Level.

Query

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-15 dB (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:PICHannel:HSDPa -10"
! Sets the UTRA FDD Test(HSDPA) Secondary Serving Cell PICH Level to -10 dB and turns its state on.

CALL:FDDTest:SSCell:PICHannel:LEVel:HSPA

Function

Sets/queries the UTRA FDD Test Mode(HSPA) Secondary Serving Cell PICH Power Offset.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-15 dB

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:PICHannel:LEVel:HSPA -10"
! Sets the UTRA FDD Test Mode(HSPA) Secondary Serving Cell PICH Power Offset to -10dB.

CALL:FDDTest:SSCell:PICHannel:STATe:HSPA

Function

Sets/queries the UTRA FDD Test Mode(HSPA) Secondary Serving Cell PICH state.
Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:PICHannel:STATe:HSPA OFF"

CALL:FDDTest:SSCell:PICHannel[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the UTRA FDD Test(HSPA) Secondary Serving Cell PICH Level (see CALL:FDDTest:SSCell:PICHannel:LEVel:HSPA ) and (2) sets the UTRA FDD Test(HSPA) Secondary Serving Cell PICH state to on (see CALL:FDDTest:SSCell:PICHannel:STATe:HSPA ).

The query form of this command returns the UTRA FDD Test(HSPA) Secondary Serving Cell PICH Level.

Query

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-15 dB (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:PICHannel:HSPA -10"
! Sets the UTRA FDD Test(HSPA) Secondary Serving Cell PICH Level to -10 dB and turns its state on.

CALL:FDDTest:SSCell:HSPDschannel:LEVel:HSDPa

Function

Sets/queries the FDD Test Mode(HSDPA) Secondary Serving Cell HS-PDSCH Power Offset.

This parameter controls the total amount of power in all HS-PDSCHs of the carrier 2 in FDD Test Mode while HSDPA is active. The power will be equally split between all the active carrier 2 HS-PDSCHs during a sub-frame.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-3 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSPDschannel:LEVel:HSDPa -10"
! Sets the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell HS-PDSCH Power Offset to -10dB.

CALL:FDDTest:SSCell:HSPDschannel:STATe:HSDPa

Function

Sets/queries the FDD Test Mode(HSDPA) Secondary Serving Cell HS-PDSCH state.
Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSPDschannel:STATe:HSDPa OFF"

CALL:FDDTest:SSCell:HSPDschannel[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the FDD Test(HSDPA) Secondary Serving Cell HS-PDSCH Level (see CALL:FDDTest:SSCell:HSPDschannel:LEVel:HSDPa ) and (2) sets the FDD Test(HSDPA) Secondary Serving Cell HS-PDSCH state to on (see CALL:FDDTest:SSCell:HSPDschannel:STATe:HSDPa ).

The query form of this command returns the FDD Test(HSDPA) Secondary Serving Cell HS-PDSCH Level.

Query

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-3 dB (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSPDschannel:HSDPa -10"
! Sets the UTRA FDD Test(HSDPA) Secondary Serving Cell HS-PDSCH Level to -10 dB and turns its state on.

CALL:FDDTest:SSCell:HSPDschannel:LEVel:HSPA

Function

Sets/queries the UTRA FDD Test Mode(HSPA) Secondary Serving Cell HS-PDSCH Power Offset.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-3 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSPDschannel:LEVel:HSPA -10"
! Sets the UTRA FDD Test Mode(HSPA) Secondary Serving Cell HS-PDSCH Power Offset to -10dB.

CALL:FDDTest:SSCell:HSPDschannel:STATe:HSPA

Function

Sets/queries the UTRA FDD Test Mode(HSPA) Secondary Serving Cell HS-PDSCH state.
Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSPDschannel:STATe:HSPA OFF"

CALL:FDDTest:SSCell:HSPDschannel[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the UTRA FDD Test(HSPA) Secondary Serving Cell HS-PDSCH Level (see CALL:FDDTest:SSCell:HSPDschannel:LEVel:HSPA ) and (2) sets the UTRA FDD Test(HSPA) Secondary Serving Cell HS-PDSCH state to on (see CALL:FDDTest:SSCell:HSPDschannel:STATe:HSPA ).

The query form of this command returns the UTRA FDD Test(HSPA) Secondary Serving Cell HS-PDSCH Level.

Query

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-3 dB (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSPDschannel:HSPA -10"
! Sets the UTRA FDD Test(HSPA) Secondary Serving Cell HS-PDSCH Level to -10 dB and turns its state on.

CALL:FDDTest:SSCell:HSSCchannel1:LEVel:HSDPa

Function

Sets/queries the FDD Test Mode(HSDPA) Secondary Serving Cell HS-SCCH 1 Power Offset.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-10 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel1:LEVel:HSDPa -10"
! Sets the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell HS-SCCH 1 Power Offset to -10dB.

CALL:FDDTest:SSCell:HSSCchannel1:STATe:HSDPa

Function

Sets/queries the FDD Test Mode(HSDPA) Secondary Serving Cell HS-SCCH 1 state.
Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel1:STATe:HSDPa OFF"

CALL:FDDTest:SSCell:HSSCchannel1[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the FDD Test(HSDPA) Secondary Serving Cell HS-SCCH 1 Level (see CALL:FDDTest:SSCell:HSSCchannel1:LEVel:HSDPa ) and (2) sets the FDD Test(HSDPA) Secondary Serving Cell HS-SCCH 1 state to on (see CALL:FDDTest:SSCell:HSSCchannel1:STATe:HSDPa ).

The query form of this command returns the FDD Test(HSDPA) Secondary Serving Cell HS-SCCH Level.

Query

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-10 dB (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel:HSDPa -10"
! Sets the UTRA FDD Test(HSDPA) Secondary Serving Cell HS-SCCH 1 Level to -10 dB and turns its state on.

CALL:FDDTest:SSCell:HSSCchannel1:LEVel:HSPA

Function

Sets/queries the UTRA FDD Test Mode(HSPA) Secondary Serving Cell HS-SCCH 1 Power Offset.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-10 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel1:LEVel:HSPA -10"
! Sets the UTRA FDD Test Mode(HSPA) Secondary Serving Cell HS-SCCH 1 Power Offset to -10dB.

CALL:FDDTest:SSCell:HSSCchannel1:STATe:HSPA

Function

Sets/queries the UTRA FDD Test Mode(HSPA) Secondary Serving Cell HS-SCCH 1 state.
Setting

Range: 1|On|0|Off

Query

 Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel1:STATe:HSPA OFF"

CALL:FDDTest:SSCell:HSSCchannel1[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the UTRA FDD Test(HSPA) Secondary Serving Cell HS-SCCH 1 Level (see CALL:FDDTest:SSCell:HSSCchannel1:LEVel:HSPA ) and (2) sets the UTRA FDD Test(HSPA) Secondary Serving Cell HS-SCCH 1 state to on (see CALL:FDDTest:SSCell:HSSCchannel1:STATe:HSPA ).

The query form of this command returns the UTRA FDD Test(HSPA) Secondary Serving Cell HS-SCCH 1 Level.

Query

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-10 dB (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel:HSPA -10"
! Sets the UTRA FDD Test(HSPA) Secondary Serving Cell HS-SCCH 1 Level to -10 dB and turns its state on.

CALL:FDDTest:SSCell:HSSCchannel2:LEVel:HSDPa

Function

Sets/queries the FDD Test Mode(HSDPA) Secondary Serving Cell HS-SCCH 2 Power Offset.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-15 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel2:LEVel:HSDPa -10"
! Sets the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell HS-SCCH 2 Power Offset to -10dB.

CALL:FDDTest:SSCell:HSSCchannel2:STATe:HSDPa

Function

Sets/queries the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell HS-SCCH 2 state.
Setting

Range: 1|On|0|Off

Query

 Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel2:STATe:HSDPa OFF"

CALL:FDDTest:SSCell:HSSCchannel2[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the UTRA FDD Test(HSDPA) Secondary Serving Cell HS-SCCH 2 Level (see CALL:FDDTest:SSCell:HSSCchannel2:LEVel:HSDPa ) and (2) sets the UTRA FDD Test(HSDPA) Secondary Serving Cell HS-SCCH 2 state to on (see CALL:FDDTest:SSCell:HSSCchannel2:STATe:HSDPa ).

The query form of this command returns the UTRA FDD Test(HSDPA) Secondary Serving Cell HS-SCCH 2 Level.

Query

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-15 dB (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel2:HSDPa -10"
! Sets the UTRA FDD Test(HSDPA) Secondary Serving Cell HS-SCCH 2 Level to -10 dB and turns its state on.

CALL:FDDTest:SSCell:HSSCchannel2:LEVel:HSPA

Function

Sets/queries the UTRA FDD Test Mode(HSPA) Secondary Serving Cell HS-SCCH 2 Power Offset.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-15 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel2:LEVel:HSPA -10"
! Sets the UTRA FDD Test Mode(HSPA) Secondary Serving Cell HS-SCCH 2 Power Offset to -10dB.

CALL:FDDTest:SSCell:HSSCchannel2:STATe:HSPA

Function

Sets/queries the UTRA FDD Test Mode(HSPA) Secondary Serving Cell HS-SCCH 2 state.
Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel2:STATe:HSPA OFF"

CALL:FDDTest:SSCell:HSSCchannel2[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the UTRA FDD Test(HSPA) Secondary Serving Cell HS-SCCH 2 Level (see CALL:FDDTest:SSCell:HSSCchannel2:LEVel:HSPA ) and (2) sets the UTRA FDD Test(HSPA) Secondary Serving Cell HS-SCCH 2 state to on (see CALL:FDDTest:SSCell:HSSCchannel2:STATe:HSPA ).

The query form of this command returns the UTRA FDD Test(HSPA) Secondary Serving Cell HS-SCCH 2 Level.

Query

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-15 dB (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel2:HSPA -10"
! Sets the UTRA FDD Test(HSPA) Secondary Serving Cell HS-SCCH 2 Level to -10 dB and turns its state on.

CALL:FDDTest:SSCell:HSSCchannel3:LEVel:HSDPa

Function

Sets/queries the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell HS-SCCH 3 Power Offset.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-15 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel3:LEVel:HSDPa -10"
! Sets the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell HS-SCCH 3 Power Offset to -10dB.

CALL:FDDTest:SSCell:HSSCchannel3:STATe:HSDPa

Function

Sets/queries the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell HS-SCCH 3 state.
Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel3:STATe:HSDPa OFF"

CALL:FDDTest:SSCell:HSSCchannel3[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the UTRA FDD Test(HSDPA) Secondary Serving Cell HS-SCCH 3 Level (see CALL:FDDTest:SSCell:HSSCchannel3:LEVel:HSDPa ) and (2) sets the UTRA FDD Test(HSDPA) Secondary Serving Cell HS-SCCH 3 state to on (see CALL:FDDTest:SSCell:HSSCchannel3:STATe:HSDPa ).

The query form of this command returns the UTRA FDD Test(HSDPA) Secondary Serving Cell HS-SCCH 3 Level.

Query

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-15 dB (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel3:HSDPa -10"
! Sets the UTRA FDD Test(HSDPA) Secondary Serving Cell HS-SCCH 3 Level to -10 dB and turns its state on.

CALL:FDDTest:SSCell:HSSCchannel3:LEVel:HSPA

Function

Sets/queries the UTRA FDD Test Mode(HSPA) Secondary Serving Cell HS-SCCH 3 Power Offset.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-15 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel3:LEVel:HSPA -10"
! Sets the UTRA FDD Test Mode(HSPA) Secondary Serving Cell HS-SCCH 3 Power Offset to -10dB.

CALL:FDDTest:SSCell:HSSCchannel3:STATe:HSPA

Function

Sets/queries the UTRA FDD Test Mode(HSPA) Secondary Serving Cell HS-SCCH 3 state.
Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

 1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel3:STATe:HSPA OFF"

CALL:FDDTest:SSCell:HSSCchannel3[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the UTRA FDD Test(HSPA) Secondary Serving Cell HS-SCCH 3 Level (see CALL:FDDTest:SSCell:HSSCchannel3:LEVel:HSPA ) and (2) sets the UTRA FDD Test(HSPA) Secondary Serving Cell HS-SCCH 3 state to on (see CALL:FDDTest:SSCell:HSSCchannel3:STATe:HSPA ).

The query form of this command returns the UTRA FDD Test(HSPA) Secondary Serving Cell HS-SCCH 3 Level.

Query

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-15 dB (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel3:HSPA -10"
! Sets the UTRA FDD Test(HSPA) Secondary Serving Cell HS-SCCH 3 Level to -10 dB and turns its state on.

CALL:FDDTest:SSCell:HSSCchannel4:LEVel:HSDPa

Function

Sets/queries the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell HS-SCCH 4 Power Offset.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-15 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel4:LEVel:HSDPa -10"
! Sets the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell HS-SCCH 4 Power Offset to -10dB.

CALL:FDDTest:SSCell:HSSCchannel4:STATe:HSDPa

Function

Sets/queries the UTRA FDD Test Mode(HSDPA) Secondary Serving Cell HS-SCCH 4 state.
Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

 1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel4:STATe:HSDPa OFF"

CALL:FDDTest:SSCell:HSSCchannel4[:SLEVel]:HSDPa

Function

The setting form of this command performs two functions: (1) sets the UTRA FDD Test(HSDPA) Secondary Serving Cell HS-SCCH 4 Level (see CALL:FDDTest:SSCell:HSSCchannel4:LEVel:HSDPa ) and (2) sets the UTRA FDD Test(HSDPA) Secondary Serving Cell HS-SCCH 4 state to on (see CALL:FDDTest:SSCell:HSSCchannel4:STATe:HSDPa ).

The query form of this command returns the UTRA FDD Test(HSDPA) Secondary Serving Cell HS-SCCH 4 Level.

Query

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-15 dB (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel4:HSDPa -10"
! Sets the UTRA FDD Test(HSDPA) Secondary Serving Cell HS-SCCH 4 Level to -10 dB and turns its state on.

CALL:FDDTest:SSCell:HSSCchannel4:LEVel:HSPA

Function

Sets/queries the UTRA FDD Test Mode(HSPA) Secondary Serving Cell HS-SCCH 4 Power Offset.

Setting

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-15 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel4:LEVel:HSPA -10"
! Sets the UTRA FDD Test Mode(HSPA) Secondary Serving Cell HS-SCCH 4 Power Offset to -10dB.

CALL:FDDTest:SSCell:HSSCchannel4:STATe:HSPA

Function

Sets/queries the UTRA FDD Test Mode(HSPA) Secondary Serving Cell HS-SCCH 4 state.
Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel4:STATe:HSPA OFF"

CALL:FDDTest:SSCell:HSSCchannel4[:SLEVel]:HSPA

Function

The setting form of this command performs two functions: (1) sets the UTRA FDD Test(HSPA) Secondary Serving Cell HS-SCCH 4 Level (see CALL:FDDTest:SSCell:HSSCchannel4:LEVel:HSPA ) and (2) sets the UTRA FDD Test(HSPA) Secondary Serving Cell HS-SCCH 4 state to on (see CALL:FDDTest:SSCell:HSSCchannel4:STATe:HSPA ).

The query form of this command returns the UTRA FDD Test(HSPA) Secondary Serving Cell HS-SCCH 4 Level.

Query

Range:-20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1dB

Query

Same as setting

*RST Setting

-15 dB (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSSCchannel4:HSPA -10"
! Sets the UTRA FDD Test(HSPA) Secondary Serving Cell HS-SCCH 4 Level to -10 dB and turns its state on.

CALL:FDDTest:SSCell:OCNSource:POFFset:HSDPa

Function

Sets/queries the FDD Test Mode Secondary Serving Cell HSDPA/HSPA orthogonal channel noise simulator (OCNS) 1 to 6 Power Offsets.

Setting

Range: -20 to 0 dB

Resolution: 0.01 dB

Increment: 0.1 dB

Query

 Same as setting

*RST Setting

0 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:OCNSource:POFFset:HSDPa 0,0,0,0,0,0"

CALL:FDDTest:SSCell:HRNTi

Function

Sets/queries the primary H-RNTI of the secondary serving cell.

If you attempt to set this parameter to a value that is same as any FDD Test Mode HS-SCCH Alternate H-RNTI, the attempt will be rejected and the test set will post a error message.

Setting

Range: 0 to 0xFFFF.

Query

Same as setting

*RST Setting

0xAAAA

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HRNTi `AAAA'"
! Sets the primary H-RNTI of the secondary serving cell to AAAA.

CALL:FDDTest:SSCell:HSDSchannel:UDEFined:MACEHS:TBSTable:ALIGnment

Function

Sets/queries the FDD Test Mode Secondary Serving Cell MAC-ehs HS-DSCH TB size table when FDD Test User Def Secondary Cell 64QAM State is "Off".

Setting

Range: BIT | OCTet

Query

Same as setting

*RST Setting

 OCTet

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSDSchannel:UDEFined:MACEHS:TBSTable:ALIGnment BIT"
! Sets the FDD Test Mode Secondary Serving Cell MAC-ehs HS-DSCH TB size table to Bit-aligned.

CALL:FDDTest:SSCell:HSDSchannel:UDEFined:QAM64:STATe

Function

Sets/queries whether the 64QAM encoding format should be used for the secondary serving cell HS-SCCH.

Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSDSchannel:UDEFined:QAM64:STATe ON"
! Returns the FDD Test Mode Secondary Serving Cell 64QAM configured to on.

CALL:FDDTest:SSCell:HSDSchannel:UDEFined:ITTI[:INTerval]

Function

 Sets/queries the absolute inter-TTI interval between transmitting blocks to the UE on the secondary serving cell HS-PDSCH.

Setting

Range: 1 to 8

Query

Same as setting

*RST Setting

3

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSDSchannel:UDEFined:ITTI 2"
! Sets the FDD Test Mode Secondary Serving Cell Inter-TTI Interval to 2.

CALL:FDDTest:SSCell:HSDSchannel:UDEFined:MODulation[:TYPE]

Function

Sets/queries the modulation type of the currently active HS-PDSCH channels on the secondary serving cell and is used to determine the actual transport block size.

Setting

Range: QPSK | QAM16 | QAM64

Query

Same as setting

*RST Setting

QPSK

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSDSchannel:UDEFined:MODulation QPSK"
! Sets the FDD Test Mode Secondary Serving Cell Modulation Type to QPSK.

CALL:FDDTest:SSCell:HSDSchannel:UDEFined:TBSize:INDex

Function

Sets/queries the transport block size index of the secondary serving cell and determine the actual transport block size.

Setting

Range: 0 to 62

Query

Same as setting

*RST Setting

62

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSDSchannel:UDEFined:TBSize:INDex 62"
! Sets the FDD Test Mode Secondary Serving Cell Transport Block Size Index to 10.

CALL:FDDTest:SSCell:HSDSchannel:UDEFined:HSPDschannel:COUNt

Function

Sets/queries how many HS-PDSCHs are active on the secondary serving cell.

Setting

Range: 1 to 15

Query

Same as setting

*RST Setting

5

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:FDDTest:SSCell:HSDSchannel:UDEFined:HSPDschannel:COUNt 1"
! Sets FDD Test Mode Secondary Serving Cell Number of HS-PDSCHs to 1.


CALL:HANDoff

CALL:HANDoff

Last updated: May 9, 2011

GPIB Command Conventions

  • CALL:HANDoff[:IMMediate]

  • CALL:HANDoff:EXTernal[:IMMediate]
  • CALL:HANDoff:EXTernal:ATIMe

  • CALL:HANDoff:PCReconfig[:IMMediate]
  • CALL:HANDoff:PCReconfig:ATIMe
  • CALL:HANDoff:PCReconfig:CFNHandling
  • CALL:HANDoff:PCReconfig:RBTest:LMESsaging:STATe

  • CALL:HANDoff:PS:INBound[:IMMediate]
  • CALL:HANDoff:PS:INBound:ABORt
  • CALL:HANDoff:PS:INBound:HOCommand?
  • CALL:HANDoff:PS:OUTBound[:IMMediate]
  • CALL:HANDoff:PS:OUTBound:ATIMe
  • CALL:HANDoff:PS:OUTBound:TMessage

  • CALL:HANDoff:RBReconfig[:IMMediate]
  • CALL:HANDoff:RBReconfig:CFNHandling
  • CALL:HANDoff:RBReconfig:CHANnel:STATe

  • CALL:HANDoff:SYSTem[:GSM][:IMMediate]
  • CALL:HANDoff:SYSTem:GSM:ATIMe
  • CALL:HANDoff:SYSTem[:GSM]RLCack:WAIT[:STATe]

  • CALL:HANDoff:TCReconfig[:IMMediate]
  • CALL:HANDoff:TCReconfig:CFNHandling
  • CALL:HANDoff:TCReconfig:CHANnel:STATe
  • CALL:HANDoff:TCReconfig:RBTest:LMESsaging:STATe

CALL:HANDoff[:IMMediate]

Function

THIS COMMAND IS OBSOLETE. Please use the CALL:HANDoff:PCReconfig[:IMMediate] and CALL:HANDoff:SYSTem[:GSM][:IMMediate] commands to perform physical channel reconfigurations and system handoffs.

Initiates a handoff while on a call (and in Active Cell mode). Any measurements that have been initiated are aborted when a handoff is initiated. See Handovers .

A handoff can initiate a change of downlink UARFCN ( CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:DOWNlink ), a change of uplink UARFCN ( CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink[:MCHannel] ), or a change from W-CDMA system to GSM system ( CALL:SETup[:HANDoff]:SYSTem[:TYPE] ) while maintaining the connection.

The W-CDMA to GSM handoff is only available when both the E1963A and E1968A test applications (TAs) are present in the test set and licensed for operation.
Requirements

Test Application Revision: A.03 and above: add handoff from W-CDMA to GSM.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:HANDoff"

CALL:HANDoff:EXTernal[:IMMediate]

Function

 Initiates the Execute External 8960 Handover immediate action. See External 8960 Handover and Two-Cell Test System .
Requirements

Lab Application Revision: D.00.04 and above.

Test Application Revision: A.18.00 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HANDoff:EXTernal"

CALL:HANDoff:EXTernal:ATIMe

Function

Sets/queries the Activation Time .

This parameter can only be changed when connection status is idle.

Setting

Range: 0 to 255 frames

Resolution: 1 frame

Query

 Same as setting

*RST Setting

 0 frames

Requirements

Lab Application Revision: E.00 and above

Test Application Revision: A.18.00 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HANDoff:EXTernal:ATIMe 100"
! Sets Activation Time to 100 frames.

CALL:HANDoff:PCReconfig[:IMMediate]

Function

 Performs a Physical Channel Reconfiguration .
Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:HANDoff:PCReconfig"

CALL:HANDoff:PCReconfig:ATIMe

Function

Sets/queries the PCR Activation Time .

Setting

Range: 0 to 255

Resolution: 1

Query

 Same as setting

*RST Setting

 0

Requirements

Test Application Revision: A.08.20 and above

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:HANDoff:PCReconfig:ATIMe 100"
! Sets PCR Activation Time to 1 s (100 x 10 ms = 1 s).

CALL:HANDoff:PCReconfig:CFNHandling

Function

Sets/queries PCR Timing Indication (CFN Handling) .

Setting

Range: AUTO|INITialise|MAINtain

Query

Range: AUTO|INIT|MAIN

*RST Setting

 AUTO

Requirements

Test Application Revision: A.07 and above

Test Application Revision A.11, added AUTO, changed default from INIT to AUTO

Lab Application Revision: C.02 and above

Lab Application Revision D.02, added AUTO, changed default from INIT to AUTO

Programming Example

OUTPUT 714;"CALL:HANDoff:PCReconfig:CFNHandling MAINtain"
! Sets PCR Timing Indication (CFN Handling) to Maintain.

CALL:HANDoff:PCReconfig:RBTest:LMESsaging:STATe

Function

Sets/queries the RB Test Mode PCR Loopback Messaging State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision: A.08.20 and above

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:HANDoff:PCReconfig:RBTest:LMESsaging:STATe On"
! Sets RB Test Mode PCR Loopback Messaging State to On.

CALL:HANDoff:PS:INBound[:IMMediate]

Function

 For external PS handover, this command performs a Setup Inbound action.
Requirements

Lab Application Revision: H.00.00 and above.

Programming Example

OUTPUT 714;"CALL:HANDoff:PS:INBound"

CALL:HANDoff:PS:INBound:ABORt

Function

 For external PS handover, this command performs an Abort Inbound action.
Requirements

Lab Application Revision: H.00.00 and above.

Programming Example

OUTPUT 714;"CALL:HANDoff:PS:INBound:ABORt"

CALL:HANDoff:PS:INBound:HOCommand?

Function

For inbound PS handover (handover from another RAT to WCDMA), this command returns a hex string defining the HANDOVER TO UTRAN COMMAND message. The source RAT treats this as a transparent message to be blindly passed to the UE.

Note that the information contained in this message is only valid while the resources are set up for an inbound handover. It will be removed when the handover state is terminated (either by aborting, preset or a successful handover).

This setting is for GIPB command only. See also Setup Inbound .

Query

 A hex string describing the set up channels

*RST Setting

 Empty string

Requirements

Lab Application Revision: H.00.00 and above.

Programming Example

OUTPUT 714;"CALL:HANDoff:PS:INBound:HOCommand?"

CALL:HANDoff:PS:OUTBound[:IMMediate]

Function

 For external PS handover, this command performs an Outbound PS Handover action.
Requirements

Lab Application Revision: H.00.00 and above.

Programming Example

OUTPUT 714;"CALL:HANDoff:PS:OUTBound"

CALL:HANDoff:PS:OUTBound:ATIMe

Function

Sets/queries the Activation Time .

This parameter specifies the time delay (in frame) from issuing the outbound handover command to the handover actually taking effect . If this value is set to 0 , the outbound PS handover takes effect immediately.

Setting

Range: 0 - 255 frames

Query

 0 - 255

*RST Setting

 0

Requirements

Lab Application Revision: H.00.00 and above.

Programming Example

OUTPUT 714;"CALL:HANDoff:PS:OUTBound:ATIMe 0"
! Sets the outbound PS handover activation time to 0 frame.

CALL:HANDoff:PS:OUTBound:TMessage

Function

Sets/queries the transparent hex string to be copied to the HandoverFromUtranCommand message. This data will be generated by the target cell describing the waiting dedicated resources. The test set will not parse or act on any of the data contained in this message.

This setting is for GIPB command only. See also Execute Handover .

Setting

 Ascii string of hex digits defining the HandoverFromUtraCommand message.

Query

 Same as setting

*RST Setting

 Empty string

Requirements

Lab Application Revision: H.00.00 and above.

Programming Example

OUTPUT 714;"CALL:HANDoff:PS:OUTBound:TMESsage "200601C83A1008783200078880081000EA900E08482FF7F7F7F7D7D7D7D03A0B3B4B632B73A0280CE46B86D2C192805FB007888009180D55DE6000BA7B4381A93B80327A03EA05B1C419AA81C0""
! Sets up the transparent hex string to be copied to the HandoverFromUtranCommand message.

CALL:HANDoff:RBReconfig[:IMMediate]

Function

 Performs a Radio Bearer Reconfiguration .
Requirements

Test Application Revision: A.09 and above.

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:HANDoff:RBReconfig"

CALL:HANDoff:RBReconfig:CFNHandling

Function

Sets/queries the RBR Timing Indication (CFN Handling) .

Setting

Range: AUTO|INITialise|MAINtain

Query

Range: AUTO|INIT|MAIN

*RST Setting

 AUTO

Requirements

Test Application Revision: A.09 and above

Test Application Revision A.11, added AUTO, changed default from INIT to AUTO

Lab Application Revision: C.04 or D.00.04 and above

Lab Application Revision D.02, added AUTO, changed default from INIT to AUTO

Programming Example

OUTPUT 714;"CALL:HANDoff:RBReconfig:CFNHandling MAINtain"
! Sets RBR Timing Indication (CFN Handling) to Maintain.

CALL:HANDoff:RBReconfig:CHANnel:STATe

Function

Sets/queries the RBR Channel (UARFCN) State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.11 and above

Lab Application Revision D.02 and above

Programming Example

OUTPUT 714;"CALL:HANDoff:RBReconfig:CHANnel:STATe OFF"
! Sets RBR Channel (UARFCN) State to Off.

CALL:HANDoff:SYSTem[:GSM][:IMMediate]

Function

 Performs a System Handover .
Requirements

GSM/GPRS_W-CDMA Fast Switching Test Application Revision: B.04 and above.

E1987A GSM/GPRS_W-CDMA Fast Switching Test Application Revision A.03.20, :GSM is optional.

GSM/GPRS_W-CDMA Fast Switching Lab Application Revision: B.01 and above.

E6785C GSM/GPRS_W-CDMA Fast Switching Lab Application Revision C.03, :GSM is optional.

Programming Example

OUTPUT 714;"CALL:HANDoff:SYSTem"

CALL:HANDoff:SYSTem:GSM:ATIMe

Function

Sets/queries the activation time of a WCDMA to GSM handover. The UE will wait the specified number of frames before trying to find the GSM cell.

Setting

Range: 0 to 255

Resolution: 1

Query

 Same as setting

*RST Setting

 0

Requirements

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:HANDoff:SYSTem:GSM:ATIMe?"

CALL:HANDoff:SYSTem[:GSM]RLCack:WAIT[:STATe]

Function

 This command sets/queries Wait for RLC Ack of Handover From UTRAN .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements

E1987A GSM/GPRS_W-CDMA Fast Switching Test Application Revision A.03.20 and above.

E6785C GSM/GPRS_W-CDMA Fast Switching Lab Application Revision C.03 and above.

Programming Example

OUTPUT 714;"CALL:HANDoff:SYSTem:RLCack:WAIT Off"

! Sets Wait for RLC Ack of Handover From UTRAN to Off.

CALL:HANDoff:TCReconfig[:IMMediate]

Function

 Performs a Transport Channel Reconfiguration .
Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:HANDoff:TCReconfig"

CALL:HANDoff:TCReconfig:CFNHandling

Function

Sets/queries the TCR Timing Indication (CFN Handling) .

Setting

Range: AUTO|INITialise|MAINtain

Query

Range: AUTO|INIT|MAIN

*RST Setting

 AUTO

Requirements

Test Application Revision: A.07 and above

Test Application Revision A.11, added AUTO, changed default from INIT to AUTO

Lab Application Revision: C.02

Lab Application Revision D.02, added AUTO, changed default from INIT to AUTO

Programming Example

OUTPUT 714;"CALL:HANDoff:TCReconfig:CFNHandling MAINtain"
! Sets TCR Timing Indication (CFN Handling) to Maintain.

CALL:HANDoff:TCReconfig:CHANnel:STATe

Function

Sets/queries the TCR Channel (UARFCN) State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.11 and above

Lab Application Revision D.02 and above

Programming Example

OUTPUT 714;"CALL:HANDoff:TCReconfig:CHANnel:STATe OFF"
! Sets TCR Channel (UARFCN) State to Off.

CALL:HANDoff:TCReconfig:RBTest:LMESsaging:STATe

Function

Sets/queries the RB Test Mode TCR Loopback Messaging State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Programming Example

OUTPUT 714;"CALL:HANDoff:TCReconfig:RBTest:LMESsaging:STATe OFF"
! Sets RB Test Mode TCR Loopback Messaging State to Off.


CALL:HSDPa

CALL:HSDPa

Last updated: January 14, 2012

This section is only applicable to the lab application or feature-licensed test application.

GPIB Command Conventions

  • CALL:HSDPa:CINDicator

  • CALL:HSDPa:FDPChannel:SLOT:FORMat

  • CALL:HSDPa:HRNTi[:PRIMary]
  • CALL:HSDPa:HRNTi:ALTernate
  • CALL:HSDPa:HRNTi:ALTernate:HSSCCH1
  • CALL:HSDPa:HRNTi:ALTernate:HSSCCH2
  • CALL:HSDPa:HRNTi:ALTernate:HSSCCH3
  • CALL:HSDPa:HRNTi:ALTernate:HSSCCH4

  • CALL:HSDPa:HSSCchannel:ORDer:SSCell:ACTivate:SEND[:IMMediate]]
  • CALL:HSDPa:HSSCchannel:ORDer:SSCell:DEACtivate:SEND[:IMMediate]]
  • CALL:HSDPa:HSSCchannel:ORDer:DSSCell:FROM]

  • CALL:HSDPa:HRNTi:ALTernate:HSSCCH4

  • CALL:HSDPa:MACEHS:SEGMentation
  • CALL:HSDPa:MACHs:NTRans
  • CALL:HSDPa:MACHs:RVSequence
  • CALL:HSDPa:MACHs:SDTX:RBEHavior
  • CALL:HSDPa:MACHs:T1
  • CALL:HSDPa:MPOWer:OFFSet:MANual

  • CALL:HSDPa:MPOWer[:MOFFset]
  • CALL:HSDPa:MPOWer:OFFSet:CONTrol:AUTO
  • CALL:HSDPa:MPOWer:OFFSet:MANual

  • CALL:HSDPa:MS:HSDSchannel:CATegory:CONTrol:AUTO
  • CALL:HSDPa:MS:HSDSchannel:CATegory:MANual
  • CALL:HSDPa:MS:HSDSchannel:CATegory:DCHSdpa:MANual
  • CALL:HSDPa:MS:REPorted:ACK?
  • CALL:HSDPa:MS:REPorted:ALL?
  • CALL:HSDPa:MS:REPorted:BLOCks?
  • CALL:HSDPa:MS:REPorted:HBLerror:RATio?
  • CALL:HSDPa:MS:REPorted:HSDSchannel:CATegory?
  • CALL:HSDPa:MS:REPorted:HSDSchannel:CATegory:EXTension?
  • CALL:HSDPa:MS:REPorted:HSDSchannel:CATegory:EXTension2?
  • CALL:HSDPa:MS:REPorted:IBTHroughput?
  • CALL:HSDPa:MS:REPorted:NACK?
  • CALL:HSDPa:MS:REPorted:SDTX?
  • CALL:HSDPa:MS:REPorted:SCELl:CQI[:LAST]?]
  • CALL:HSDPa:MS:REPorted:SCELl[:ALL]?
  • CALL:HSDPa:MS:REPorted:SCELl:ACK?
  • CALL:HSDPa:MS:REPorted:SCELl:BLOCks?
  • CALL:HSDPa:MS:REPorted:SCELl:HBLerror:RATio?
  • CALL:HSDPa:MS:REPorted:SCELl:IBTHroughput?
  • CALL:HSDPa:MS:REPorted:SCELl:NACK?
  • CALL:HSDPa:MS:REPorted:SCELl:SDTX?
  • CALL:HSDPa:MS:REPorted:SSCell:CQI[:LAST]?]
  • CALL:HSDPa:MS:REPorted:SSCell[:ALL]?
  • CALL:HSDPa:MS:REPorted:SSCell:ACK?
  • CALL:HSDPa:MS:REPorted:SSCell:BLOCks?
  • CALL:HSDPa:MS:REPorted:SSCell:HBLerror:RATio?
  • CALL:HSDPa:MS:REPorted:SSCell:IBTHroughput?
  • CALL:HSDPa:MS:REPorted:SSCell:NACK?
  • CALL:HSDPa:MS:REPorted:SSCell:SDTX?

  • CALL:HSDPa:SERVice:PSData:CQI[:VALue]
  • CALL:HSDPa:SERVice:PSData:DCHSdpa[:STATe]
  • CALL:HSDPa:SERVice:PSData:HARQ:PROCess:COUNt:CONTrol:AUTO
  • CALL:HSDPa:SERVice:PSData:HARQ:PROCess:COUNt:MANual
  • CALL:HSDPa:SERVice:PSData:HSDSchannel:CONFig[:TYPE]
  • CALL:HSDPa:SERVice:PSData:HSDSchannel:MAC
  • CALL:HSDPa:SERVice:PSData:MACEHS:HSDSchannel:TBSTable:ALIGnment
  • CALL:HSDPa:SERVice:PSData:HSPDschannel:CCODe
  • CALL:HSDPa:SERVice:PSData:HSPDschannel:CCODe:CODE
  • CALL:HSDPa:SERVice:PSData:ITTI[:INTerval]:MINimum:CONTrol:AUTO
  • CALL:HSDPa:SERVice:PSData:ITTI[:INTerval]:MINimum:MANual
  • CALL:HSDPa:SERVice:PSData:MACD:PDUSize
  • CALL:HSDPa:SERVice:PSData:MACD:PDUSize:CONTrol
  • CALL:HSDPa:SERVice:PSData:MACD:PDUSize:MANual
  • CALL:HSDPa:SERVice:PSData:MS:IREDundancy:BUFFer:ALLocation
  • CALL:HSDPa:SERVice:PSData:MS:IREDundancy:BUFFer:SIZE[:EXPLicit]
  • CALL:HSDPa:SERVice:PSData:QAM64:STATe
  • CALL:HSDPa:SERVice:PSData:RLC:DOWNlink:HEXTension:SVALue
  • CALL:HSDPa:SERVice:PSData:RLC:DOWNlink:MAXimum:PDU:PSIZe
  • CALL:HSDPa:SERVice:PSData:RLC:DOWNlink:MODE
  • CALL:HSDPa:SERVice:PSData:UDEFined:HSPDschannel:COUNt
  • CALL:HSDPa:SERVice:PSData:UDEFined:MODulation[:TYPE]
  • CALL:HSDPa:SERVice:PSData:UDEFined:TBSize:INDex

  • CALL:HSDPa:SERVice:RBTest:CNDomain
  • CALL:HSDPa:SERVice:RBTest:DTCHannel0:HLOopback:STATe
  • CALL:HSDPa:SERVice:RBTest:FDPChannel:STATe
  • CALL:HSDPa:SERVice:RBTest:FRC:HSET8:MS:IREDundancy:BUFFer:SIZE
  • CALL:HSDPa:SERVice:RBTest:FRC:MACD:PDUSize
  • CALL:HSDPa:SERVice:RBTest:FRC:TYPE
  • CALL:HSDPa:SERVice:RBTest[:DTCHannel64]:HLOopback:STATe
  • CALL:HSDPa:SERVice:RBTest:HSPDschannel:CCODe
  • CALL:HSDPa:SERVice:RBTest:HSPDschannel:CCODe:CODE
  • CALL:HSDPa:SERVice:RBTest:HSDSchannel:CONFig[:TYPE]
  • CALL:HSDPa:SERVice:RBTest:HSDSchannel:DATA
  • CALL:HSDPa:SERVice:RBTest:HSDSchannel:RLCHeader
  • CALL:HSDPa:SERVice:RBTest:UDEFined:HARQ:PROCess:COUNt
  • CALL:HSDPa:SERVice:RBTest:UDEFined:HSDSchannel:MAC
  • CALL:HSDPa:SERVice:RBTest:UDEFined:HSPDschannel:COUNt
  • CALL:HSDPa:SERVice:RBTest:UDEFined:ITTI[:INTerval]
  • CALL:HSDPa:SERVice:RBTest:UDEFined:MACEHS:HSDSchannel:TBSTable:ALIGnment
  • CALL:HSDPa:SERVice:RBTest:UDEFined:MACEHS:RLC:SDU[:SIZE]
  • CALL:HSDPa:SERVice:RBTest:UDEFined:MODulation[:TYPE]
  • CALL:HSDPa:SERVice:RBTest:UDEFined:MS:IREDundancy:BUFFer:ALLocation
  • CALL:HSDPa:SERVice:RBTest:UDEFined:MS:IREDundancy:BUFFer:SIZe[:EXPLicit]
  • CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:INITial:SFNumber
  • CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:INITial:SUBFrame
  • CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent[1]:LENGth
  • CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent[1]:TYPE
  • CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent2:LENGth
  • CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent2:TYPE
  • CALL:HSDPa:SERVice:RBTest:UDEFined:QAM64:STATe
  • CALL:HSDPa:SERVice:RBTest:UDEFined:TBSize:INDex
  • CALL:HSDPa:SERVice:RBTest:UDEFined:DCHSdpa[:STATe]
  • CALL:HSDPa:SERVice:RBTest:DCHSdpa:DPCH:LOOPback[:STATe]
  • CALL:HSDPa:SERVice:RBTest:UDEFined:TMODe

  • CALL:HSDPa:SSCell:PSData:HSPDschannel:CCODe:CODE
  • CALL:HSDPa:SSCell:RBTest:HSPDschannel:CCODe:CODE
  • CALL:HSDPa:SSCell:HRNTi
  • CALL:HSDPa:SSCell:MPOWer:OFFSet:CONTrol:AUTO
  • CALL:HSDPa:SSCell:MPOWer:OFFSet:MANual
  • CALL:HSDPa:SSCell:MPOWer[:MOFFset]
  • CALL:HSDPa:SSCell:PSData:HSDschannel:CONFig[:TYPE]
  • CALL:HSDPa:SSCell:PSData:UDEFined:QAM64:STATe
  • CALL:HSDPa:SSCell:PSData:MACEHS:HSDSchannel:TBSTable:ALIGnment
  • CALL:HSDPa:SSCell:PSData:CQI[:VALue]
  • CALL:HSDPa:SSCell:PSData:ITTI[:INTerval]:MINimum:CONTrol:AUTO
  • CALL:HSDPa:SSCell:PSData:ITTI[:INTerval]:MINimum:MANual
  • CALL:HSDPa:SSCell:PSData:ITTI[:INTerval][:MMINimum]
  • CALL:HSDPa:SSCell:PSData:UDEFined:HSPDschannel:COUNt
  • CALL:HSDPa:SSCell:PSData:UDEFined:MODulation[:TYPE]
  • CALL:HSDPa:SSCell:PSData:UDEFined:TBSize:INDex
  • CALL:HSDPa:SSCell:RBTest:UDEFined:QAM64:STATe
  • CALL:HSDPa:SSCell:RBTest:MACEHS:HSDSchannel:TBSTable:ALIGnment
  • CALL:HSDPa:SSCell:RBTest:UDEFined:HSPDschannel:COUNt
  • CALL:HSDPa:SSCell:RBTest:UDEFined:ITTI[:INTerval]
  • CALL:HSDPa:SSCell:RBTest:UDEFined:MODulation[:TYPE]
  • CALL:HSDPa:SSCell:RBTest:UDEFined:TBSize:INDex

  • CALL:HSDPa:CINDicator
  • CALL:HSDPa:FDPChannel:SLOT:FORMat

  • CALL:HSDPa:HRNTi[:PRIMary]

  • CALL:HSDPa:HRNTi:ALTernate
  • CALL:HSDPa:MACEHS:SEGMentation
  • CALL:HSDPa:MACHs:NTRans

  • CALL:HSDPa:MACHs:RVSequence
  • CALL:HSDPa:MACHs:SDTX:RBEHavior
  • CALL:HSDPa:MACHs:T1
  • CALL:HSDPa:MPOWer:OFFSet:MANual
  • CALL:HSDPa:MPOWer[:MOFFset]
  • CALL:HSDPa:MPOWer:OFFSet:CONTrol:AUTO
  • CALL:HSDPa:MPOWer:OFFSet:MANual
  • CALL:HSDPa:MS:HSDSchannel:CATegory:CONTrol:AUTO
  • CALL:HSDPa:MS:HSDSchannel:CATegory:MANual
  • CALL:HSDPa:MS:REPorted:ACK?

  • CALL:HSDPa:MS:REPorted:ALL?
  • CALL:HSDPa:MS:REPorted:BLOCks?
  • CALL:HSDPa:MS:REPorted:HBLerror:RATio?
  • CALL:HSDPa:MS:REPorted:HSDSchannel:CATegory?
  • CALL:HSDPa:MS:REPorted:HSDSchannel:CATegory:EXTension?
  • CALL:HSDPa:MS:REPorted:IBTHroughput?
  • CALL:HSDPa:UPLink:DACK
  • CALL:HSDPa:UPLink:DCQI
  • CALL:HSDPa:UPLink:DNACk
  • CALL:HSDPa:UPLink:ANACk:RFACtor
  • CALL:HSDPa:UPLink:CQI:FCYCle
  • CALL:HSDPa:UPLink:CQI:RFACtor

CALL:HSDPa:CINDicator

Function

Sets/queries the HSDPA Cell Indicator .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: CAPable|CNINdicated

Query

Range: CAP|CNIN

*RST Setting

 CAP

Requirements

Test Application Revision A.12 and above, with the required feature license.

Programming Example

OUTPUT 714;"CALL:HSDPa:CINDicator CAPable"
! Sets HSDPA Cell Indicator to Capable.

CALL:HSDPa:FDPChannel:SLOT:FORMat

Function

 Sets/queries HSDPA F-DPCH Slot Format.

Setting

Range: 0 to 9

Resolution: 1

Query

 Same as setting

*RST Setting

 0

Requirements

Test Application Revision: A.15 and above

Lab Application Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:FDPChannel:SLOT:FORMat 0"
! Sets HSDPA F-DPCH Slot Format to 0.

CALL:HSDPa:HRNTi[:PRIMary]

Function

Sets/queries Primary H-RNTI (Hex) .

This parameter can only be set when call status is Idle .

Setting

Range: 0 to FFFF

(1 to 4 characters from the set 0123456789AaBbCcDdEeFf)

Query

Range: "0000" to "FFFF"

(The return string is always 4 characters from the set 0123456789ABCDEF, enclosed by double quotes.)

*RST Setting

 "AAAA"

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:HRNTi 'EEEE'"
! Sets Primary H-RNTI (Hex) to EEEE.

CALL:HSDPa:HRNTi:ALTernate

Function

Sets/queries the Alternate H-RNTI (Hex).

This parameter can only be set when call status is Idle .

Setting

Range: 0 to FFFF

(1 to 4 characters from the set 0123456789AaBbCcDdEeFf)

Query

Range: "0000" to "FFFF"

(The return string is always 4 characters from the set 0123456789ABCDEF, enclosed by double quotes.)

*RST Setting

 "5555"

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:HRNTi:ALTernate '2222'"
! Sets Alternate H-RNTI (Hex) to 2222.

CALL:HSDPa:HRNTi:ALTernate:HSSCCH1

Function

Sets/queries HS-SCCH1 Alternate H-RNTI (Hex) .

This parameter can only be set when call status is Idle .

Setting

Range: 0 to FFFF

(1 to 4 characters from the set 0123456789AaBbCcDdEeFf)

Query

Range: "0000" to "FFFF"

(The return string is always 4 characters from the set 0123456789ABCDEF, enclosed by double quotes.)

*RST Setting

 "5555"

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:HRNTi:ALTernate:HSSCCH1 '2222'"
! Sets HS-SCCH1 Alternate H-RNTI (Hex) to 2222.

CALL:HSDPa:HRNTi:ALTernate:HSSCCH2

Function

Sets/queries HS-SCCH2 Alternate H-RNTI (Hex) .

This parameter can only be set when call status is Idle .

Setting

Range: 0 to FFFF

(1 to 4 characters from the set 0123456789AaBbCcDdEeFf)

Query

Range: "0000" to "FFFF"

(The return string is always 4 characters from the set 0123456789ABCDEF, enclosed by double quotes.)

*RST Setting

 "5555"

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:HRNTi:ALTernate:HSSCCH2 '2222'"
! Sets HS-SCCH2 Alternate H-RNTI (Hex) to 2222.

CALL:HSDPa:HRNTi:ALTernate:HSSCCH3

Function

Sets/queries HS-SCCH3 Alternate H-RNTI (Hex) .

This parameter can only be set when call status is Idle .

Setting

Range: 0 to FFFF

(1 to 4 characters from the set 0123456789AaBbCcDdEeFf)

Query

Range: "0000" to "FFFF"

(The return string is always 4 characters from the set 0123456789ABCDEF, enclosed by double quotes.)

*RST Setting

 "5555"

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:HRNTi:ALTernate:HSSCCH3'2222'"
! Sets HS-SCCH3 Alternate H-RNTI (Hex) to 2222.

CALL:HSDPa:HRNTi:ALTernate:HSSCCH4

Function

Sets/queries HS-SCCH4 Alternate H-RNTI (Hex) .

This parameter can only be set when call status is Idle .

Setting

Range: 0 to FFFF

(1 to 4 characters from the set 0123456789AaBbCcDdEeFf)

Query

Range: "0000" to "FFFF"

(The return string is always 4 characters from the set 0123456789ABCDEF, enclosed by double quotes.)

*RST Setting

 "5555"

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:HRNTi:ALTernate:HSSCCH4 '2222'"
! Sets HS-SCCH4 Alternate H-RNTI (Hex) to 2222.

CALL:HSDPa:HSSCchannel:ORDer:SSCell:ACTivate:SEND[:IMMediate]]

Function

Sends the Send Activate Secondary Cell command.

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:HSSCchannel:ORDer:SSCell:ACTivate:SEND"
!Send the HS-SCCH Order to active the secondary serving cell.

CALL:HSDPa:HSSCchannel:ORDer:SSCell:DEACtivate:SEND[:IMMediate]]

Function

Sends the Deactivate Secondary Cell command.

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:HSSCchannel:ORDer:SSCell:DEACtivate:SEND"
!Send the HS-SCCH Order to deactive the secondary serving cell.

CALL:HSDPa:HSSCchannel:ORDer:DSSCell:FROM]

Function

This parameter controls which cell is used to send the HS-SCCH Order to deactivate the secondary serving cell.

Setting

Range: Serving Cell|Secondary Serving Cell

Query

Same as setting

*RST Setting

 Serving Cell

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:HSSCchannel:ORDer:DSSCell:FROM SSCell"
!Sets the Serving Cell to send the HS-SCCH Order to deactive the secondary seving cell.

CALL:HSDPa:MACEHS:SEGMentation

Function

Sets/queries the MAC-ehs Segmentation Strategy .

Setting

Range: STANdard|MINimum

Query

 Range: STAN|MIN

*RST Setting

 STANdard

Requirements

Lab Application Revision F.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MACEHS:SEGMentation STANdard"
! Sets the segmentation strategy to Standard.

CALL:HSDPa:MACHs:NTRans

Function

Sets/queries the Number of Transmissions .

Setting

Range: 1 to 8

Query

 Same as setting

*RST Setting

 4

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MACHs:NTRans 2"
! Sets the Number of Transmissions to 2.

CALL:HSDPa:MACHs:RVSequence

Function

Sets/queries the RV Sequence .

Note: how many of the RV parameters in the sequence are used is determined by the Number of Transmissions setting (see CALL:HSDPa:MACHs:NTRans ). The RV parameters at the end of the list are not used if Number of Transmissions is less than 8.

Setting

Range: Comma separated list of 1 to 8 characters from the set 01234567.

Query

Range: Comma separated list of 8 characters from the set 01234567, enclosed by double quotes (if you enter fewer than 8 characters, the query result will fill the remaining characters with zeros).

*RST Setting

 0,2,5,6,0,0,0,0

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MACHs:RVSequence '0,2,7,4,3,1'"
! Sets the RV Sequence to 0,2,7,4,3,1,0,0.

CALL:HSDPa:MACHs:SDTX:RBEHavior

Function

Sets/queries the statDTX Reception Behavior .

Setting

Range: ACK|NACK|SDTX

Query

 Same as setting

*RST Setting

 SDTX

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MACHs:SDTX:RBEHavior ACK"
! Sets the statDTX Reception Behavior to Handle as ACK.

CALL:HSDPa:MACHs:T1

Function

Sets/queries MAC-hs T1 .

This parameter can only be set when call status is Idle .

Setting

Range: 10, 20, 30, 40, 50, 60, 70, 80, 90, 100, 120, 140, 160, 200, 300, 400 ms

Note, the default unit for this command is seconds. If you enter a value without a unit (S|MS|US|NS), the test set assumes the value you've entered is in seconds.

Query

 Same as setting

*RST Setting

 50 ms

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MACHs:T1 10 MS"
! Sets MAC-hs T1 to 10 ms.

CALL:HSDPa:MACHs:WSIZe[:VALue]

Function

Sets/queries the MAC-hs Window Size .

This parameter can only be set when call status is Idle .

Setting

Range: PDU4|PDU6|PDU8|PDU12|PDU16|PDU24|PDU32

Query

 Same as setting

*RST Setting

 PDU16

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MACHs:WSIZe PDU12"
! Sets the MAC-hs Window Size to 12.

CALL:HSDPa:MPOWer[:MOFFset]

Function

Sets/queries the Meas Pow Offset .

This parameter can only be set either while the call status is Idle .

This setting only applies when CALL:HSDPa:MPOWer:OFFSet:CONTrol:AUTO is set to OFF (manual).

Alternatively, you can use CALL:STATus:MPOWer:OFFSet:SIGNaled? to query the Last Signaled Measurement Power Offset.

Setting

Range: -6.0 to +13.0 dB

Resolution: 0.1

Query

Range: -6.0 to +13.0 dB, 9.91E+37

Resolution: 0.5

*RST Setting

 -6 dB

Requirements

Lab Application Revision E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MPOWer -6"
! Sets the Measurement Power Offset to -6 dB.

CALL:HSDPa:MPOWer:OFFSet:CONTrol:AUTO

Function

Sets/queries the automatic control state for the Meas Pow Offset parameter.

ON = automatic

OFF = manual (see "CALL:HSDPa:MPOWer[:MOFFset]" or "CALL:HSDPa:MPOWer:OFFSet:MANual" )

This parameter can only be set either while the call status is Idle .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MPOWer:OFFSet:CONTrol:AUTO 0"
! Sets the Measurement Power Offset control state to manual.

CALL:HSDPa:MPOWer:OFFSet:MANual

Function

Sets/queries the Meas Pow Offset .

This parameter can only be set either while the call status is Idle .

This setting only applies when CALL:HSDPa:MPOWer:OFFSet:CONTrol:AUTO is set to OFF (manual).

Setting

Range: -6.0 to +13.0 dB

Resolution: 0.5

Query

Range: -6.0 to +13.0 dB, 9.91E+37

Resolution: 0.5

*RST Setting

 -6 dB

Requirements

Lab Application Revision E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MPOWer:OFFSet:MANual -6"
! Sets the Measurement Offset Power to -6 dB.

CALL:HSDPa:MS:HSDSchannel:CATegory:CONTrol:AUTO

Function

Sets/queries UE HS-DSCH Category Control .

This parameter can only be set when the data/call status is Idle .
Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (auto)

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:HSDSchannel:CATegory:CONTrol:AUTO 0"

CALL:HSDPa:MS:HSDSchannel:CATegory:MANual

Function

Sets/queries Manual UE HS-DSCH Category .

This setting is only applicable when CALL:HSDPa:MS:HSDSchannel:CATegory:CONTrol:AUTO is set to 0 (manual) or if the UE reports an invalid category.

This parameter can only be set when the data/call status is Idle .
Setting

Range: 1-20

Query

 Same as setting.

*RST Setting

 12

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Test Application Revision A.10 and Lab Application Revision D.01 added UE categories 7 and 8

Lab Application Revision F.00.07 expanded range from "1-8, 11, 12" to "1-14, 17, 18"

Test Application Revision A.19.00 with the required feature license and Lab Application Revision H.01.00, expanded range from "1-14, 17, 18" to "1-20".

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:HSDSchannel:CATegory:MANual 12"

CALL:HSDPa:MS:HSDSchannel:CATegory:DCHSdpa:MANual

Function

Sets/queries Manual UE DC-HSDPA HS-DSCH Category .

This setting is only applicable when UE HS-DSCH Category Control is set to 0 (manual) or if the UE reports an invalid category.

This parameter can only be set when the data/call status is Idle .
Setting

Range: 21-24

Query

 Same as setting

*RST Setting

 21

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.

Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:HSDSchannel:CATegory:DCHSdpa:MANual 23"

CALL:HSDPa:MS:REPorted:ACK?

Function

Queries the HSDPA Information: ACKs Received .

Query

Range: 0 to 150,000, 9.91 E+37 (NaN)

Resolution: 1

*RST Setting

 9.91E+37

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:ACK?"

CALL:HSDPa:MS:REPorted:ALL?

Function

Queries the HSDPA Counters information and returns six comma separated results in the following order: Block Error Ratio (in %), Throughput (in kbps), ACKs Received, NACKs Received, statDTXs Received, Blocks Transferred.

Query

Block Error Ratio

  • Range: 0 to 100%
  • Resolution: 1%

Throughput

  • Range: 0 to 99,999 kbps
  • Resolution: 1 kbps

ACKs Received

  • Range: 0 to 150,000
  • Resolution: 1

NACKs Received

  • Range: 0 to 150,000
  • Resolution: 1

statDTXs Received

  • Range: 0 to 150,000
  • Resolution: 1

Blocks Transferred

  • Range: 0 to 150,000
  • Resolution: 1

*RST Setting

 9.91E+37, 9.91E+37, 9.91E+37, 9.91E+37, 9.91E+37, 9.91E+37

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:ALL?"

CALL:HSDPa:MS:REPorted:BLOCks?

Function

Queries the HSDPA Information: Blocks Transferred .

Query

Range: 0 to 150,000, 9.91 E+37 (NaN)

Resolution: 1

*RST Setting

 9.91E+37

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:BLOCks?"

CALL:HSDPa:MS:REPorted:HBLerror:RATio?

Function

Queries the HSDPA Information: Block Error Ratio .

Query

Range: 0 to 100%, 9.91 E+37 (NaN)

Resolution: 1%

*RST Setting

 9.91E+37

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:HBLerror:RATio?"

CALL:HSDPa:MS:REPorted:HSDSchannel:CATegory?

Function

Queries the UE Reported HS-DSCH Category .

Query

Range: 1 to 64, 9.91E+37

Resolution: 1

*RST Setting

 9.91E+37

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:HSDSchannel:CATegory?"

CALL:HSDPa:MS:REPorted:HSDSchannel:CATegory:EXTension?

Function

Queries the UE Reported Extended HS-DSCH Category.

Query

Range: 1 to 64, 9.91E+37

Resolution: 1

*RST Setting

 9.91E+37

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:HSDSchannel:CATegory:EXTension?"

CALL:HSDPa:MS:REPorted:HSDSchannel:CATegory:EXTension2?

Function

Queries the UE Reported Extended HS-DSCH Category 2.

Query

Range: 1 to 64, 9.91E+37

Resolution: 1

*RST Setting

 9.91E+37

Requirements

Test Application Revision A.19.00 and above, with the required feature license.

Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:HSDSchannel:CATegory:EXTension2?"

CALL:HSDPa:MS:REPorted:IBTHroughput?

Function

Queries the HSDPA Information: Throughput .

Query

Range: 0 to 99,999 kbps, 9.91E+37 (NaN)

Resolution: 1 kbps

*RST Setting

 9.91E+37

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:IBTHroughput?"

CALL:HSDPa:MS:REPorted:NACK?

Function

Queries the HSDPA Information: NACKs Received .

Query

Range: 0 to 150,000, 9.91 E+37 (NaN)

Resolution: 1

*RST Setting

 9.91E+37

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:NACK?"

CALL:HSDPa:MS:REPorted:SDTX?

Function

Queries the HSDPA Information: statDTXs Received .

Query

Range: 0 to 150,000, 9.91 E+37 (NaN)

Resolution: 1

*RST Setting

 9.91E+37

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SDTX?"

CALL:HSDPa:MS:REPorted:SCELl:CQI[:LAST]?]

Function

Queries the mostly recently received CQI value from the UE for the serving cell.

This result is updated once per second when either dual cell or single cell HSDPA connection is active.

"NaN" is returned if a CQI value has not been received from the UE or if a HSDPA call is not active.

The conditions which will cause this result to be reset to "NaN" are described in DC-HSDPA Counters .

Query

Range: 0 to 255, 9.91E+37 (NaN)

*RST Setting

9.91E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SCELl:CQI?"

CALL:HSDPa:MS:REPorted:SCELl[:ALL]?

Function

Queries the serving cell reported measurement results after a successful Measurement Request. The supported measurements include BLER, Throughput, ACKs, NACKs, statDTXs and Transmitted blocks.

After a successful Measurement Request, six comma separated results are returned in the order of BLER, Throughput, ACKs, NACKs, statDTXs and Transmitted blocks. See CALL:HSDPa:MS:REPorted:SCELl:ACK? , CALL:HSDPa:MS:REPorted:SCELl:BLOCks? , CALL:HSDPa:MS:REPorted:SCELl:HBLerror:RATio? , CALL:HSDPa:MS:REPorted:SCELl:IBTHroughput? , CALL:HSDPa:MS:REPorted:SCELl:NACK? and CALL:HSDPa:MS:REPorted:SCELl:SDTX? for more information.

Query

BLER:

  • Range: 0 to 100 percent, 9.91E +37

Throughput:

  • Range: 0 to 99,999 kbit/sec, 9.91E +37

ACKs:

  • Range: 0 to 150,000 Blocks, 9.91E +37

NACKs:

  • Range: 0 to 150,000 Blocks, 9.91E +37

statDTXs:

  • Range: 0 to 150,000 Blocks, 9.91E +37

Transmitted blocks:

  • Range: 0 to 150,000 Blocks, 9.91E +37

*RST Setting

9.91E + 37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SCELl?

CALL:HSDPa:MS:REPorted:SCELl:ACK?

Function

Queries how many ACKs have been received on the uplink HS-DPCCH via the DC-HSDPA serving cell.

This result is updated only if Current Secondary Serving Cell Status is "Configured-Active" or "Configured-Inactive", which indicates that a DC-HSPA call is active.

Query

Range: 0 to 150,000 Blocks, 9.91E+37 (NaN)

*RST Setting

9.91E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SCELl:ACK?"

CALL:HSDPa:MS:REPorted:SCELl:BLOCks?

Function

Queries how many blocks have been transmitted to the UE via the DC-HSDPA serving cell. It is increased by one every time a data block is transmitted on the HS-PDSCHs. A transmission of a new block of data or a retransmission of an old block of data both count as a block transmission for the purposes of this counter.

This result is updated only if Current Secondary Serving Cell Status is "Configured-Active" or "Configured-Inactive", which indicates that a DC-HSPA call is active.

Query

Range: 0 to 150,000 Blocks, 9.91E+37 (NaN)

*RST Setting

9.91E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SCELl:BLOCks?"

CALL:HSDPa:MS:REPorted:SCELl:HBLerror:RATio?

Function

Queries the BLER of the serving cell HSDPA link.

This result is updated only if Current Secondary Serving Cell Status is "Configured-Active" or "Configured-Inactive", which indicates that a DC-HSPA call is active.

Query

Range: 0 to 150,000 Blocks, 9.91E+37 (NaN)

*RST Setting

9.91E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SCELl:HBLerror:RATio?"

CALL:HSDPa:MS:REPorted:SCELl:IBTHroughput?

Function

Queries the data throughput of the serving cell HSDPA link.

This result is updated only if Current Secondary Serving Cell Status is "Configured-Active" or "Configured-Inactive", which indicates that a DC-HSPA call is active.

Query

Range: 0 to 99,999 kbit/sec, 9.91E+37 (NaN)

*RST Setting

9.91E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SCELl:IBTHroughput?"

CALL:HSDPa:MS:REPorted:SCELl:NACK?

Function

Queries how many NACKs have been received on the uplink HS-DPCCH via the DC-HSDPA serving cell.

This result is updated only if Current Secondary Serving Cell Status is "Configured-Active" or "Configured-Inactive", which indicates that a DC-HSPA call is active.

Query

Range:0 to 150,000 Blocks, 9.91E+37 (NaN)

*RST Setting

9.91E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SCELl:NACK?"

CALL:HSDPa:MS:REPorted:SCELl:SDTX?

Function

Queries how many statDTXs have been received on the uplink HS-DPCCH via the DC-HSDPA serving cell.

This result is updated only if Current Secondary Serving Cell Status is "Configured-Active" or "Configured-Inactive", which indicates that a DC-HSPA call is active.

Query

Range: 0 to 150,000 Blocks, 9.91E+37 (NaN)

*RST Setting

9.91E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SCELl:SDTX?"

CALL:HSDPa:MS:REPorted:SSCell:CQI[:LAST]?]

Function

Queries the mostly recently received CQI value from the UE for the DC-HSDPA secondary serving cell.

This result is updated once per second when Current Secondary Serving Cell Status is "Configured-Active" or "Configured-Inactive".

Query

Range: 0 to 30, 9.91E+37 (NaN)

*RST Setting

9.91E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SSCell:CQI?"

CALL:HSDPa:MS:REPorted:SSCell[:ALL]?

Function

Queries the secondary serving cell reported measurement results after a successful Measurement Request. The supported measurements include BLER, Throughput, ACKs, NACKs, statDTXs and Transmitted blocks.

After a successful Measurement Request, six comma separated results are returned in the order of BLER, Throughput, ACKs, NACKs, statDTXs and Transmitted blocks. See CALL:HSDPa:MS:REPorted:SCELl:ACK? , CALL:HSDPa:MS:REPorted:SCELl:BLOCks? , CALL:HSDPa:MS:REPorted:SCELl:HBLerror:RATio? , CALL:HSDPa:MS:REPorted:SCELl:IBTHroughput? , CALL:HSDPa:MS:REPorted:SCELl:NACK? and CALL:HSDPa:MS:REPorted:SCELl:SDTX? for more information.

Query

BLER:

  • Range: 0 to 100 percent, 9.91E +37

Throughput:

  • Range: 0 to 99,999 kbit/sec, 9.91E +37

ACKs:

  • Range: 0 to 150,000 Blocks, 9.91E +37

NACKs:

  • Range: 0 to 150,000 Blocks, 9.91E +37

statDTXs:

  • Range: 0 to 150,000 Blocks, 9.91E +37

Transmitted blocks:

  • Range: 0 to 150,000 Blocks, 9.91E +37

*RST Setting

9.91E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SSCell?"

CALL:HSDPa:MS:REPorted:SSCell:ACK?

Function

Queries how many ACKs have been received on the uplink HS-DPCCH via the DC-HSDPA secondary serving cell.

This result is updated only if Current Secondary Serving Cell Status is "Configured-Active" or "Configured-Inactive", which indicates that a DC-HSPA call is active.

Query

Range: 0 to 150,000 Blocks, 9.91E+37 (NaN)

*RST Setting

9.91E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SSCell:ACK?"

CALL:HSDPa:MS:REPorted:SSCell:BLOCks?

Function

Queries how many blocks have been transmitted to the UE via the DC-HSDPA secondary serving cell. It is increased by one every time a data block is transmitted on the HS-PDSCHs. A transmission of a new block of data or a retransmission of an old block of data both count as a block transmission for the purposes of this counter.

This result is updated only if Current Secondary Serving Cell Status is "Configured-Active" or "Configured-Inactive".

Query

Range: 0 to 150,000 Blocks, 9.91E+37 (NaN)

*RST Setting

9.91E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SSCell:BLOCks?"

CALL:HSDPa:MS:REPorted:SSCell:HBLerror:RATio?

Function

Queries the BLER of the secondary serving cell HSDPA link.

This result is updated only if Current Secondary Serving Cell Status is "Configured-Active" or "Configured-Inactive".

Query

Range: 0 to 100 percent, 9.91E+37 (NaN)

*RST Setting

9.91E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SSCell:HBLerror:RATio?"

CALL:HSDPa:MS:REPorted:SSCell:IBTHroughput?

Function

Queries the data throughput of the secondary serving cell HSDPA link.

This result is updated only if Current Secondary Serving Cell Status is "Configured-Active" or "Configured-Inactive".

Query

Range: 0 to 99,999 kbit/sec, 9.91E+37 (NaN)

*RST Setting

9.91E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SSCell:IBTHroughput?"

CALL:HSDPa:MS:REPorted:SSCell:NACK?

Function

Queries how many NACKs have been received on the uplink HS-DPCCH via the DC-HSDPA secondary serving cell.

This result is updated only if Current Secondary Serving Cell Status is "Configured-Active" or "Configured-Inactive".

Query

Range:0 to 150,000 Blocks, 9.91E+37 (NaN)

*RST Setting

9.91E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SSCell:NACK?"

CALL:HSDPa:MS:REPorted:SSCell:SDTX?

Function

Queries how many statDTXs have been received on the uplink HS-DPCCH via the DC-HSDPA secondary serving cell.

Query

Range: 0 to 150,000 Blocks, 9.91E+37 (NaN)

*RST Setting

9.91E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:MS:REPorted:SSCell:SDTX?"

CALL:HSDPa:SERVice:PSData:CQI[:VALue]

Function

Sets/queries the PS Data Configuration Type .

This parameter cannot be set to 7 or less if CALL:HSDPa:SERVice:PSData:ITTI[:INTerval]:MINimum:CONTrol:AUTO is set to 656 bits.

The number of HS-PDSCHs specified by this command, when added to CALL:HSDPa:SERVice:PSData:HSPDschannel:CCODe cannot exceed 15.

Setting

Range: 5 to 30

Resolution: 1

Query

 Same as setting

*RST Setting

 15

Requirements

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:CQI 19"
! Sets CQI Value to 19.

CALL:HSDPa:SERVice:PSData:DCHSdpa[:STATe]

Function

Sets/queries the PS Data DC-HSDPA State .

This parameter can only be changed while the call status is idle.

This is a LA only setting.

Setting

Range: 1|On|0|Off

Query

 1|0

*RST Setting

 0 (Off)

Requirements

Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:DCHSdpa ON"
! Sets PS Data DC-HSDPA state to ON.

CALL:HSDPa:SERVice:PSData:HARQ:PROCess:COUNt:CONTrol:AUTO

Function

Sets/queries the control state for the PS Data Number of HARQ Processes .

This parameter can only be changed while the call status is idle.

Setting

Range: 1|ON|0|OFF

Query

 1|0

*RST Setting

 1

Requirements

Lab Application Revision: E.00.13 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:HARQ:PROCess:COUNt:CONTrol:AUTO 1"
! Sets PS Data Minimum Inter-TTI Interval control state to Auto (1).

CALL:HSDPa:SERVice:PSData:HARQ:PROCess:COUNt:MANual

Function

Sets/queries the value of the PS Data Number of HARQ Processes .

This setting can be changed in any operating mode, however when the operating mode is Active Cell this setting can only be changed while the call status is idle.

Setting

Range: 1 to 8

Query

 Range: 1 to 8

*RST Setting

 6

Requirements

Lab Application Revision: E.00.13 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:HARQ:PROCess:COUNt:MANual 6"
! Sets the value of the PS Data Number of HARQ Processes to 6.

CALL:HSDPa:SERVice:PSData:HSDSchannel:CONFig[:TYPE]

Function

Sets/queries PS Data Configuration Type .

Setting

Range: CQIValue|RCQI|UDEFined

Query

 Range: CQIV|RCQI|UDEF

*RST Setting

 CQIV

Requirements

Lab Application Revision: E.00.13 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:HSDSchannel:CONFig CQIValue"
! Sets PS Data First HS-DSCH Type to CQI Value.

CALL:HSDPa:SERVice:PSData:HSDSchannel:MAC

Function

Sets/queries the PS Data HS-DSCH MAC Entity.

This setting controls whether MAC-hs or MAC-ehs is to be used as the underlying MAC layer entity when working in HSDPA PS Data mode. This setting is also involved in determining the HS-DSCH TB Size table when the "PS Data HS-DSCH Configuration Type" is "User Defined".

Setting

Range: HSPeed (MAC-hs)|EHSPeed (MAC-ehs)

Query

Range: HSP)|EHSP

*RST Setting

 HSPeed

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:HSDSchannel:MAC HSPeed"
! Sets PS Data HS-DSCH MAC Entity to MAC-hs.

CALL:HSDPa:SERVice:PSData:MACEHS:HSDSchannel:TBSTable:ALIGnment

Function

Sets/queries the PS Data MAC-ehs HS-DSCH TB Size Table.

This setting is only used when the "PS Data HS-DSCH MAC Entity" parameter is "MAC-ehs", the "PS Data HS-DSCH 64QAM Configured State" is "Off", and the "PS Data HS-DSCH Configuration Type" is "User defined".This setting controls whether the bit-aligned HS-DSCH TB size table or octet-aligned HS-DSCH TB size table is used for a HSDPA PS Data call.

Setting

Range: BIT | OCTet

Query

Range: BIT | OCTet

*RST Setting

 OCTet

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:MACEHS:HSDSchannel:TBSTable:ALIGnment OCTet"
! PS Data MAC-ehs HS-DSCH TB Size Table to Octet aligned.

CALL:HSDPa:SERVice:PSData:HSPDschannel:CCODe

Function

THIS COMMAND IS OBSOLETE. Please use CALL:HSDPa:SERVice:PSData:HSPDschannel:CCODe:CODE .

Sets/queries PS Data First HS-PDSCH Channel Code .

Setting

Range: CODE5|CODE6|CODE7|CODE8|CODE9|CODE10

Query

 Same as setting

*RST Setting

 CODE5

Requirements

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Lab Application Revision E.00, added CODE5 and CODE6, changed the default to CODE5 (from CODE7).

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:HSPDschannel:CCODe CODE9"
! Sets PS Data First HS-PDSCH Channel Code to 9.

CALL:HSDPa:SERVice:PSData:HSPDschannel:CCODe:CODE

Function

Sets/queries PS Data First HS-PDSCH Channel Code .

This parameter can not be changed in active cell operating mode (use cell off operating mode or FDD test operating mode to change this parameter).

Setting

Range: 1 to 15

Query

 Same as setting

*RST Setting

 5

Requirements

Lab Application Revision F.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:HSPDschannel:CCODe:CODE 5"
! Sets PS Data First HS-PDSCH Channel Code to 5.

CALL:HSDPa:SERVice:PSData:ITTI[:INTerval]:MINimum:CONTrol:AUTO

Function

Sets/queries the control state for the PS Data Minimum Inter-TTI Interval .

Setting

Range: 1|ON|0|OFF

Query

 1|0

*RST Setting

 1

Requirements

Lab Application Revision: E.00.13 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:ITTI:MINimum:CONTrol:AUTO 1"
! Sets PS Data Minimum Inter-TTI Interval state to Auto (1).

CALL:HSDPa:SERVice:PSData:ITTI[:INTerval]:MINimum:MANual

Function

Sets/queries the value of the PS Data Minimum Inter-TTI Interval .

Setting

Range: 1 to 500

Query

 Range: 1 to 500

*RST Setting

 1

Requirements

Lab Application Revision: E.00.13 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:ITTI:MINimum:MANual 1"
! Sets PS Data Minimum Inter-TTI Interval value to 1.

CALL:HSDPa:SERVice:PSData:MACD:PDUSize

Function

Sets/queries PS Data HS-DSCH MAC-d PDU Size .

Setting

Range: BITS336|BITS656

Query

 Same as setting

*RST Setting

 BITS336

Requirements

Lab Application Revision: E.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:MACD:PDUSize BITS656"
! Sets PS Data HS-DSCH MAC-d PDU Size to 656 Bits.

CALL:HSDPa:SERVice:PSData:MACD:PDUSize:CONTrol

Function

Sets/queries PS Data HS-DSCH MAC-d PDU Size Control.

This setting controls whether PS Data HS-DSCH MAC-d PDU Size or PS Data HS-DSCH MAC-d PDU Size Manual is used on the HS-DSCH channel.

Setting

Range: PREDefined|MANual

Query

 Same as setting

*RST Setting

 PREDefined

Requirements

Lab Application Revision: G.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:MACD:PDUSize:CONTrol PREDefined"
! Sets PS Data HS-DSCH MAC-d PDU Size Control to Predefined.

CALL:HSDPa:SERVice:PSData:MACD:PDUSize:MANual

Function

Sets/queries PS Data HS-DSCH MAC-d PDU Size Manual.

This setting controls the size of the MAC-d PDU used on the DTCH that is mapped to the HS-DSCH for a HSDPA PS data connection when PS Data HS-DSCH MAC-d PDU Size Control is set to Manual. This DTCH is the logical channel that carries the downlink user traffic data (that is, the IP datagrams).

Setting

Range: 336 to 5000 in increments of 8.

Query

 Same as setting

*RST Setting

 336

Requirements

Lab Application Revision: G.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:MACD:PDUSize:MANual 336"
! Sets PS Data HS-DSCH MAC-d PDU Size Manual to 336 Bits.

CALL:HSDPa:SERVice:PSData:MS:IREDundancy:BUFFer:ALLocation

Function

Sets/queries PS Data UE IR Buffer Allocation .

Setting

Range: IMPLicit|EXPLicit

Query

Range: IMPLicit|EXPLicit

*RST Setting

 IMPLicit

Requirements

Lab Application Revision: E.00.13 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:MS:IREDundancy:BUFFer:ALLocation IMPLicit"
! Sets PS Data UE IR Buffer Allocation to Implicit.

CALL:HSDPa:SERVice:PSData:MS:IREDundancy:BUFFer:SIZE[:EXPLicit]

Function

Sets/queries PS Data Explicit UE IR Buffer Size .

Setting

800, 1600, 2400, 3200, 4000, 4800, 5600, 6400,7200, 8000, 8800, 9600, 10400, 11200, 12000, 12800, 13600, 14400, 15200, 16000, 17600, 19200, 20800, 22400, 24000, 25600, 27200, 28800, 30400, 32000, 36000, 40000, 44000, 48000, 52000, 56000, 60000, 64000, 68000, 72000, 76000, 80000, 88000, 96000, 104000, 112000, 120000, 128000, 136000, 144000, 152000, 160000, 176000, 192000, 208000, 224000, 240000, 256000, 272000, 288000, 304000

Query

 Same as setting

*RST Setting

 192000

Requirements

Lab Application Revision: E.00.13 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:MS:IREDundancy:BUFFer:SIZE 192000"
! Sets PS Data Explicit UE IR Buffer Size to 192000.

CALL:HSDPa:SERVice:PSData:QAM64:STATe

Function

Sets/queries PS Data HS-DSCH 64QAM Configured State.

This setting is only used when "PS Data HS-DSCH MAC Entity" is "MAC-ehs". This setting controls whether the "Downlink 64QAM configured" IE will be sent to the UE during a PS Data call setup procedure. This setting also controls the encoding format of HS-SCCH when the "PS Data HS-DSCH MAC Entity" is MAC-ehs.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:QAM64:STATe 0"
! Sets PS Data HS-DSCH 64QAM Configured State to off.

CALL:HSDPa:SERVice:PSData:RLC:DOWNlink:HEXTension:SVALue

Function

Sets/queries Downlink Flexible AM RLC Header Extension Special Value.

This setting controls whether the "Use Special HE Field Value" IE is present and configured to the UE in L3 signalling.

  • When set to EXCLude, this IE is not present when the test set configures the UE's RLC and a 15-bit Length Indicator (LI) is used for each AM RLC PDU.
  • When set to INCLude, the "Use Special HE field value" IE is included to configure the UE's RLC in L3 signalling. In this case, the Length Indicator (LI) is not included in the AM RLC PDU, instead, a special value of HE field (binary '10') is used to indicate the RLC PDU contains exactly one RLC SDU.

This setting is only used when the "PS Data HS-DSCH MACEntity" is "MAC-ehs" and the "Downlink AM RLC Mode" is "Flexible".

Setting

Range: INCLude | EXCLude

Query

Range: INCL | EXCL

*RST Setting

 EXCLude

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:RLC:DOWNlink:HEXTension:SVALue EXCLude"

CALL:HSDPa:SERVice:PSData:RLC:DOWNlink:MAXimum:PDU:PSIZe

Function

Sets/queries DL Maximum Flexible AM RLC PDU Payload Size.

This setting controls the downlink maximum flexible AM RLC PDU payload size. If the AM RLC SDU size is greater than this setting, it is segmented to multiple RLC PDUs so that the payload in each PDU is equal to or less than this setting. The payload size in those PDUs which are not the last one is set to this setting, the remaining segment will be put into the last RLC PDU.This setting is only available when PS Data HS-DSCH MAC Entity is MAC-ehs and Downlink AM RLC Mode is Flexible.

Setting

Range: 38 to 1503 bytes

Query

Range: 38 to 1503 bytes

*RST Setting

 1503

Requirements

 Lab Application Revision: G.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:RLC:DOWNlink:MAXimum:PDU:PSIZe 1503"
! Sets DL Maximum Flexible AM RLC PDU Payload Size to 1503 bytes.

CALL:HSDPa:SERVice:PSData:RLC:DOWNlink:MODE

Function

Sets/queries Downlink AM RLC Mode.

This setting is only used when the "PS Data HS-DSCH MAC Entity" is "MAC-ehs". This setting controls whether downlink AM RLC working in fixed mode or flexible mode:

  • When set to "fixed", the "PS Data HS-DSCH MAC-d PDU Size" will be used as the fixed mac-d pdu size (RLC PDU size).
  • When set to "flexible", the "PS Data HS-DSCH MAC-d PDU Size" will not be used any more. Instead, flexible AM RLC PDU Size will be used in the downlink AM RLC layer and RLC layer will not do segmentation based on RLC PDU size. Every AM RLC SDU will be exactly packed into a RLC PDU.

Setting

Range: FIXed | FLEXible

Query

Range: FIX | FLEX

*RST Setting

 FIXed

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:RLC:DOWNlink:MODE FIXed"
! Sets Downlink AM RLC Mode to Fixed.

CALL:HSDPa:SERVice:PSData:UDEFined:HSPDschannel:COUNt

Function

Sets/queries the PS Data User Defined Active HS-PDSCHs parameter.

Setting

Range: 1 to 10

Query

 Range: 1 to 10

*RST Setting

 5

Requirements

 Lab Application Revision E.00.13 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:UDEFined:HSPDschannel:COUNt 5"
! Sets the number of PS Data User Defined Active HS-PDSCHs to 5.

CALL:HSDPa:SERVice:PSData:UDEFined:MODulation[:TYPE]

Function

Sets/queries the PS Data User Defined Modulation Type .

Setting

Range: QAM16|QPSK|QAM64

Query

 Range: QAM16|QPSK|QAM64

*RST Setting

 QAM16

Requirements

Lab Application Revision E.00.13 and above

Lab Application Revision: F.00.19, added QAM64

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:PSData:UDEFined:MODulation QAM16"
! Sets PS Data User Defined Modulation Type to 16QAM.

CALL:HSDPa:SERVice:PSData:UDEFined:TBSize:INDex

Function

Sets/queries the PS Data User Def Transport Block Size Index .

Setting

Range: 0 to 62

Query

 Range: 0 to 62

*RST Setting

 48

Requirements

Lab Application Revision E.00.13 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:TBSize:INDex 48"
! Sets the PS Data User Def Transport Block Size Index to 48.

CALL:HSDPa:SERVice:RBTest:CNDomain

Function

Sets/queries CN Domain .

This parameter can only be set when call status is Idle .

Setting

Range: CSDomain|CSPSdomain|PSDomain

Query

 Range: CSD|CSPS|PSD

*RST Setting

 PSD

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Test Application Revision A.10.01 and Lab Application Revision D.01.01 added CSPSdomain.

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:CNDomain CSDomain"
! Sets CN Domain to CS Domain.

CALL:HSDPa:SERVice:RBTest:DTCHannel0:HLOopback:STATe

Function

Sets/queries Uplink 0k DTCH for HSDPA Loopback State .

This parameter cannot be set to On when CALL:HSDPa:SERVice:RBTest[:DTCHannel64]:HLOopback:STATe is set to On .

This parameter can only be set when call status is Idle .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.10.01 and above, with the required feature license

Lab Application Revision D.01.01 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:DTCHannel0:HLOopback:STATe 1"
! Turns Uplink 0k DTCH for HSDPA Loopback State on.

CALL:HSDPa:SERVice:RBTest:FDPChannel:STATe

Function

Sets/queries the RB Test Mode F-DPCH State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision F.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:FDPChannel:STATe OFF"
! Turns the RB Test Mode F-DPCH State off.

CALL:HSDPa:SERVice:RBTest:FDPChannel:TARGet[:QUALity]

Function

Sets/queries the Target Quality On F-DPCH .

Setting

Range: 1 to 10 %

Resolution: 1

Query

 Same as setting

*RST Setting

 4

Requirements

Lab Application Revision G.00.09 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:FDPChannel:TARGet 4"
! Sets the target quality on F-DPCH to 4%.

CALL:HSDPa:SERVice:RBTest:FRC:HSET8:MS:IREDundancy:BUFFer:SIZE

Function

Sets/queries the FRC H-Set 8 UE IR Buffer Size.

This Setting controls the RB Test Mode H-Set 8 UE IR Buffer Size, either 40000 bits or as specified in 25.101v870. If this setting is Standard (STD), the test set will determine the IR buffer size per HARQ process.

Setting

Range: 40000|STD

Query

 Same as setting

*RST Setting

 40000

Requirements

Test Application Revision A.15 and above.

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:FRC:HSET8:MS:IREDundancy:BUFFer:SIZE 40000"
! Sets FDD Test Mode FRC H-Set 8 UE IR Buffer Size to 40000 bits.

CALL:HSDPa:SERVice:RBTest:FRC:MACD:PDUSize

Function

Sets/queries FRC MAC-d PDU Size .

This parameter can only be set when call status is Idle , and is only applicable when CALL:HSDPa:SERVice:RBTest:HSDSchannel:CONFig[:TYPE] is set to FRC .

Setting

Range: BITS112|BITS336|BITS656|MHSMax

Query

Range: BITS112|BITS336|BITS656|MHSM

*RST Setting

 MHSM

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:FRC:MACD:PDUSize BITS112"
! Sets FRC MAC-d PDU Size to 112 bits.

CALL:HSDPa:SERVice:RBTest:FRC:TYPE

Function

Sets/queries FRC Type .

This parameter can only be set when call status is Idle .

Setting

Range:

QAM1|QAM2|QAM3|QAM3A|QAM6|QAM6A|QAM64H8|QAM64H8A|QAM16H10|
QAM16H10A|QPSK1|QPSK2|QPSK3|QPSK3A|QPSK4|QPSK5|QPSK6|QPSK6A|
QPSKH10|QPSKH10A|QPSKH12

Query

 Same as setting

*RST Setting

 QPSK1

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Test Application Revision A.10.01 and Lab Application Revision D.01.01 added QAM6 and QPSK6.

Lab Application Revision F.00 added QAM64H8, QAM16H10, QPSKH10

Test Application Revision: A.19.00 and above with the required feature license and Lab Application Revision: H.01.00 and above, added QPSK3A, QAM16H3A, QPSK6A, QAM16H6A, QAM64H8A, QPSK10A, QAM16H10A, QPSK12.

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:FRC:TYPE QPSK5"
! Sets FRC Type to H-Set 5 QPSK.

CALL:HSDPa:SERVice:RBTest[:DTCHannel64]:HLOopback:STATe

Function

Sets/queries Uplink 64k DTCH for HSDPA Loopback State .

This parameter cannot be set to On when CALL:HSDPa:SERVice:RBTest:DTCHannel0:HLOopback:STATe is set to On .

This parameter can only be set when call status is Idle .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Test Application Revision A.10.01 and Lab Application D.01.01 added [:DTCHannel64]

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:HLOopback:STATe 1"
! Turns Uplink 64k DTCH for HSDPA Loopback State on.

CALL:HSDPa:SERVice:RBTest:HSPDschannel:CCODe

Function

THIS COMMAND IS OBSOLETE. Please use CALL:HSDPa:SERVice:RBTest:HSPDschannel:CCODe:CODE .

Sets/queries RB Test Mode First HS-PDSCH Channel Code .

Setting

Range: CODE5|CODE6|CODE7|CODE8|CODE9|CODE10

Query

 Same as setting

*RST Setting

 CODE7

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Test Application Revision A.10.01 and Lab Application Revision D.01.01 added CODE5, CODE6

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:HSPDschannel:CCODe CODE9"
! Sets RB Test Mode First HS-PDSCH Channel Code to 9.

CALL:HSDPa:SERVice:RBTest:HSPDschannel:CCODe:CODE

Function

Sets/queries RB Test Mode First HS-PDSCH Channel Code .

This parameter can not be changed in active cell operating mode (use cell off operating mode or FDD test operating mode to change this parameter).

This parameter cannot be set to 5 or 6 when S-CCPCH Channelization Code is set to 26.

Setting

Range: 1 to 15

Query

 Same as setting

*RST Setting

 7

Requirements

Lab Application Revision F.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:HSPDschannel:CCODe:CODE 7"
! Sets RB Test Mode First HS-PDSCH Channel Code to 7.

CALL:HSDPa:SERVice:RBTest:HSDSchannel:CONFig[:TYPE]

Function

Sets/queries RB Test HS-DSCH Configuration Type .

This parameter can only be changed while the call status is idle.

Setting

Range: FRC|UDEFined

Query

Range: FRC|UDEF

*RST Setting

 FRC

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:HSDSchannel:CONFig UDEFined"
! Sets HS-DSCH Configuration Type to User Defined

CALL:HSDPa:SERVice:RBTest:HSDSchannel:DATA

Function

Sets/queries HS-DSCH Data Pattern .

Setting

Range:

  • ABITs (Alternating)
  • INCRement (Incrementing)
  • ONES (All Ones)
  • PRBS23 (CCITT PRBS23)
  • PRBS20 (CCITT PRBS20)
  • PRBS15 (CCITT PRBS15)
  • PRBS9 (CCITT PRBS9)
  • ZERos (All Zeros)

Query

Range:

  • ABIT (Alternating)
  • INCR (Incrementing)
  • ONES (All Ones)
  • PRBS23 (CCITT PRBS23)
  • PRBS20 (CCITT PRBS20)
  • PRBS15 (CCITT PRBS15)
  • PRBS9 (CCITT PRBS9)
  • ZER (All Zeros)

*RST Setting

 PRBS15

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Lab Application Revision: F.00 added PRBS23 and PRBS20

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:HSDSchannel:DATA PRBS9"
! Sets HS-DSCH Data Pattern to CCITT PRBS9.

CALL:HSDPa:SERVice:RBTest:HSDSchannel:RLCHeader

Function

Sets/queries RLC Header on HS-DSCH .

This parameter can only be set when call status is Idle .

Setting

Range: PRESent|DATA

Query

 Range: PRES|DATA

*RST Setting

 PRES

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:HSDSchannel:RLCHeader DATA"
! Sets RLC Header on HS-DSCH to Absent.

CALL:HSDPa:SERVice:RBTest:UDEFined:HARQ:PROCess:COUNt

Function

Sets/queries User Defined Number of HARQ Processes .

This setting can only be changed when call status is idle.

Setting

Range: 1 to 8

Resolution: 1

Query

 Same as setting

*RST Setting

 2

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:HARQ:PROCess:COUNt 1"
! Sets User Defined Number of HARQ Processes to 1.

CALL:HSDPa:SERVice:RBTest:UDEFined:HSDSchannel:MAC

Function

 Sets/queries the User Defined HS-DSCH MAC Entity .

Setting

Range: HSPeed | EHSPeed

Query

 Range: HSP | EHSP

*RST Setting

 HSPeed

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:HSDSchannel:MAC HSPeed"
! Sets the RB Test Mode HS-DSCH MAC entity to MAC-hs.

CALL:HSDPa:SERVice:RBTest:UDEFined:HSPDschannel:COUNt

Function

 Sets/queries User Defined Number of Active HS-PDSCHs .

Setting

Range: 1 to 10

Resolution: 1

Query

 Same as setting

*RST Setting

 5

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Test Application Revision A.10 and Lab Application Revision D.01 expanded range from "1 to 5" to "1 to 10"

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:HSPDschannel:COUNt 3"
! Sets User Defined Number of Active HS-PDSCHs to 3.

CALL:HSDPa:SERVice:RBTest:UDEFined:ITTI[:INTerval]

Function

 Sets/queries User Defined Inter-TTI Interval .

Setting

Range: 1 to 3

Resolution: 1

Query

 Same as setting

*RST Setting

 3

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:ITTI 2"
! Sets User Defined Inter-TTI Interval to 2.

CALL:HSDPa:SERVice:RBTest:UDEFined:MACEHS:HSDSchannel:TBSTable:ALIGnment

Function

 Sets/queries User Defined MAC-ehs HS-DSCH TB Size Table .

Setting

Range: BIT | OCTet

Query

 Range: BIT | OCT

*RST Setting

 OCTet

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:MACEHS:HSDSchannel:TBSTable:ALIGnment OCTet"
! Sets the RB Test Mode MAC-ehs HS-DSCH TB size table to octet-aligned.

CALL:HSDPa:SERVice:RBTest:UDEFined:MACEHS:RLC:SDU[:SIZE]

Function

 Sets/queries the User Defined Flexible RLC SDU Size .

Setting

Range: 1 to 1503

Resolution: 1

Query

 Same as setting

*RST Setting

 300

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:MACEHS:RLC:SDU 300"
! Sets the RB Test Mode Flexible RLC SDU Size to 300.

CALL:HSDPa:SERVice:RBTest:UDEFined:MODulation[:TYPE]

Function

 Sets/queries User Defined Modulation Type .

Setting

Range: QPSK|QAM16|QAM64

Query

 Same as setting

*RST Setting

 QPSK

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Lab Application Revision: F.00 and above added QAM64

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:MODulation QAM16"
! Sets User Defined Modulation Type to 16QAM.

CALL:HSDPa:SERVice:RBTest:UDEFined:MS:IREDundancy:BUFFer:ALLocation

Function

Sets/queries User Defined UE IR Buffer Allocation .

This setting can only be changed when call status is idle.

Setting

Range: IMPLicit|EXPLicit

Query

 Same as setting

*RST Setting

 IMPL

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:MS:IREDundancy:BUFFer:ALLocation EXPLicit"
! Sets User Defined UE IR Buffer Allocation to Explicit.

CALL:HSDPa:SERVice:RBTest:UDEFined:MS:IREDundancy:BUFFer:SIZe[:EXPLicit]

Function

Sets/queries User Defined Explicit UE IR Buffer Size .

This setting is only applicable when CALL:HSDPa:SERVice:RBTest:UDEFined:MS:IREDundancy:BUFFer:ALLocation is set to EXPLicit.

This setting can only be changed when call status is idle.

Setting

Range: 800, 1600, 2400, 3200, 4000, 4800, 5600, 6400, 7200, 8000, 8800, 9600, 10400, 11200, 12000, 12800, 13600, 14400, 15200, 16000, 17600, 19200, 20800, 22400, 24000, 25600, 27200, 28800, 30400, 32000, 36000, 40000, 44000, 48000, 52000, 56000, 60000, 64000, 68000, 72000, 76000, 80000, 88000, 96000, 104000, 112000, 120000, 128000, 136000, 144000, 152000, 160000, 176000, 192000, 208000, 224000, 240000, 256000, 272000, 288000, 304000

Query

 Same as setting

*RST Setting

 19200

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:MS:IREDundancy:BUFFer:SIZe 9600"
! Sets User Defined Explicit UE IR Buffer Size to 9600.

CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:INITial:SFNumber

Function

Sets/queries the Initial SFN setting when in RB Test Mode. This setting, together with CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:INITial:SUBFrame , determines the TTI when to start the transmission pattern.

This setting can not be changed when CALL:HSDPa:SERVice:RBTest:UDEFined:TMODe is set to PATTern.

Setting

Range: 0 - 4095

Query

 Same as setting

*RST Setting

 0

Requirements

Lab Application Revision G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:INITial:SFNumber 0"
! Sets the RB Test Mode Initial SFN to 0.

CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:INITial:SUBFrame

Function

Sets/queries the Initial Subframe setting when in RB Test Mode. This setting, together with CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:INITial:SFNumber , determines the TTI when to start the transmission pattern

This setting can not be changed when CALL:HSDPa:SERVice:RBTest:UDEFined:TMODe is set to PATTern.

Setting

Range: 0 - 4

Query

 Same as setting

*RST Setting

 0

Requirements

Lab Application Revision G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:INITial:SUBFrame 0"
! Sets the RB Test Mode Initial Subframe to 0.

CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent[1]:LENGth

Function

Sets/queries the First Segment Length (in HSDPA TTI (2ms)) setting when in RB Test Mode. The transmission pattern period is the addition of the First Segment Length and the Second Segment Length. See also CALL:HSDPa:SERVice:RBTest:UDEFined:TMODe .

This setting can not be changed when the Transmission Mode ( CALL:HSDPa:SERVice:RBTest:UDEFined:TMODe ) is set to Pattern .

Setting

Range: 1 - 64

Query

 Same as setting

*RST Setting

 10

Requirements

Lab Application Revision G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent:LENGth 10"
! Sets the RB Test Mode HSDPA Pattern First Segment Length to 10 TTI.

CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent[1]:TYPE

Function

Sets/queries the First Segment Type setting when in RB Test Mode. If the First Segment Type is set to Transmit , the test set transmits the HSDPA blocks during the first segment. If set to DTX , the test set uses the alternative H-RNTI to transmit HSDPA blocks, which means DTX for the UE. See also CALL:HSDPa:SERVice:RBTest:UDEFined:TMODe .

This setting can not be changed when the Transmission Mode ( CALL:HSDPa:SERVice:RBTest:UDEFined:TMODe ) is set to Pattern .

Setting

Range: TRANsmit | DTX

Query

 TRAN | DTX

*RST Setting

 TRANsmit

Requirements

Lab Application Revision G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent:TYPE TRANsmit"
! Sets the RB Test Mode HSDPA Pattern First Segment Type to TRANsmit

CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent2:LENGth

Function

Sets/queries the Second Segment Length setting when in RB Test Mode. The transmission pattern period is the addition of the First Segment Length and the Second Segment Length. See also CALL:HSDPa:SERVice:RBTest:UDEFined:TMODe .

This setting can not be changed when the Transmission Mode ( CALL:HSDPa:SERVice:RBTest:UDEFined:TMODe ) is set to Pattern .

Setting

Range: 1 - 64

Query

 Same as setting

*RST Setting

 10

Requirements

Lab Application Revision G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent2:LENGth 10"
! Sets the RB Test Mode HSDPA Pattern Second Segment Length to 10 TTI.

CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent2:TYPE

Function

Sets/queries the Second Segment Type setting when in RB Test Mode. If the Second Segment Type is set to Transmit , the test set transmits the HSDPA blocks during the Second segment. If set to DTX , the test set uses the alternative H-RNTI to transmit HSDPA blocks, which means DTX for the UE. See also CALL:HSDPa:SERVice:RBTest:UDEFined:TMODe .

This setting can not be changed when the Transmission Mode ( CALL:HSDPa:SERVice:RBTest:UDEFined:TMODe ) is set to Pattern .

Setting

Range: TRANsmit | DTX

Query

 TRAN | DTX

*RST Setting

 TRANsmit

Requirements

Lab Application Revision G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent2:TYPE TRANsmit"
! Sets the RB Test Mode HSDPA Pattern Second Segment Type to TRANsmit.

CALL:HSDPa:SERVice:RBTest:UDEFined:QAM64:STATe

Function

Sets/queries the User Defined 64QAM State .

This parameter is used when CALL:HSDPa:SERVice:RBTest:UDEFined:HSDSchannel:MAC is set to MAC-ehs.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (OFF)

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:QAM64:STATe OFF"

CALL:HSDPa:SERVice:RBTest:UDEFined:TBSize:INDex

Function

Sets/queries User Defined Transport Block Size Index .

You can query the transport block size using the CALL:STATus:HSDSchannel:TBSize? query.

Setting

Range: 0 to 62

Resolution: 1

Query

 Same as setting

*RST Setting

 62

Requirements

Test Application Revision: A.19.00 and above, with the required feature license

Lab Application Revision: H.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:TBSize:INDex 48"
! Sets User Defined Transport Block Size Index to 48.

CALL:HSDPa:SERVice:RBTest:UDEFined:DCHSdpa[:STATe]

Function

Sets/queries Configuring the DC-HSDPA RB Test Mode Settings .

This parameter can only be changed when call status is Idle .

Setting

Range: 1|On|0|Off

Query

 Range: 1|0

*RST Setting

 0 (Off)

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.Lab Application Revision: H.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:DCHSdpa ON"

CALL:HSDPa:SERVice:RBTest:DCHSdpa:DPCH:LOOPback[:STATe]

Function

Sets/queries DC-HSDPA DPCH Loopback State .

This parameter can only be changed when call status is Idle .

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 0 (Off)

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.Lab Application Revision: H.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSDP:SERV:RBT:DCHS:DPCH:LOOP On"
! Sets DC-HSDPA DPCH Loopback State to On.

CALL:HSDPa:SERVice:RBTest:UDEFined:TMODe

Function

Sets/queries the Transmission Mode setting in RB Test Mode. When Pattern is selected, you are allowed to specify the HSDPA transmission pattern, which is determined by the following settings: CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:INITial:SFNumber , CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:INITial:SUBFrame , CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent[1]:TYPE , CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent[1]:LENGth , CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent2:LENGth and CALL:HSDPa:SERVice:RBTest:UDEFined:PATTern:SEGMent2:LENGth .

To apply the transmission pattern, you must set up an RB test mode connection and set the CALL:HSDPa:SERVice:RBTest:HSDSchannel:CONFig[:TYPE] to UDEFined. Besides, it is strongly recommended you set CALL:HSDPa:SERVice:RBTest:UDEFined:ITTI[:INTerval] to 1 and CALL:HSDPa:SERVice:RBTest:UDEFined:HARQ:PROCess:COUNt to 6 (or more than 6), respectively.

This setting can be changed only when the Call Status is Idle or Connected .

Setting

Range: NORMal | PATTern

Query

 NORM | PATT

*RST Setting

 NORMal

Requirements

Lab Application Revision G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SERVice:RBTest:UDEFined:TMODe NORMal"
! Sets the RB Test Mode HSDPA Transmission Mode to Normal.

CALL:HSDPa:SSCell:PSData:HSPDschannel:CCODe:CODE

Function

Sets/queries the channelization code of the first HS-PDSCH channel while on a PS data call. Code 0 is not allowed as it would collide with the CPICH and SCH/PCCPCH channels.

If you attempt to change this setting to a value that when added to the PS Data User Defined Secondary Cell Active HS-PDSCHs is greater than 16, then the setting will be rejected.

This parameter can not be changed in active cell operating mode (use cell off operating mode or FDD test operating mode to change this parameter).

Setting

Range: 1 to 15

Query

 Same as setting

*RST Setting

 5

Requirements

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:PSData:HSPDschannel:CCODe:CODE 2"
! Sets PS Data Secondary Serving Cell First HS-PDSCH Channelization Code to 2.

CALL:HSDPa:SSCell:RBTest:HSPDschannel:CCODe:CODE

Function

Sets/queries the channelization code of the first HS-PDSCH channel while on a RB Test Mode Call. Code 0 is not allowed as it would collide with the CPICH and SCH/PCCPCH channels.

This parameter can not be changed in active cell operating mode (use cell off operating mode or FDD test operating mode to change this parameter).

Setting

Range: 1 to 15

Query

 Same as setting

*RST Setting

 7

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:RBTest:HSPDschannel:CCODe:CODE 9"
! Sets RB Test Mode Secondary Serving Cell First HS-PDSCH Channelization Code to 9.

CALL:HSDPa:SSCell:HRNTi

Function

Sets/queries Secondary Serving Cell H-RNTI (Hex) .

You can not set this parameter to a value that is same with any FDD Test Mode HS-SCCH Alternate H-RNTI, because when in FDD call operating, Primary H-RNTI cannot be the same as the Alternate H-RNTI".

This parameter can only be set when call status is Idle .

Setting

Range: 0 to FFFF

(1 to 4 characters from the set 0123456789AaBbCcDdEeFf)

Query

Range: "0000" to "FFFF"

(The return string is always 4 characters from the set 0123456789ABCDEF, enclosed by double quotes.)

*RST Setting

 "AAAA"

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:HRNTi 'EEEE'"
! Sets Secondary Serving Call H-RNTI to EEEE.

CALL:HSDPa:SSCell:MPOWer:OFFSet:CONTrol:AUTO

Function

Sets/queries the automatic control state for the Secondary Serving Cell Meas Pow Offset parameter.

ON=automatic

OFF=manual(see CALL:HSDPa:MACEHS:SEGMentation or CALL:HSDPa:MACHs:NTRans )

This parameter can only be set when call status is Idle .

This setting is only available in the Lab Application.

In the Test Application a Measurement Power Offset of +6dB is alwarys signaled to the UE.

Setting

Range: 1|ON|0|OFF

Query

Same as setting

*RST Setting

 0 (OFF)

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:MPOWer:OFFSet:CONTrol:AUTO 0"
! Sets the Secondary Serving Cell Measurement Power Offset to manual.

CALL:HSDPa:SSCell:MPOWer:OFFSet:MANual

Function

Sets/queries the value of the Measurement Power Offset parameter that is signaled to the UE at call setup when the Secondary Serving Cell Meas Pow Offset parameter is set to Manual.

This parameter can only be set when call status is Idle .

This setting only applies when CALL:HSDPa:HRNTi:ALTernate is set to OFF(manual). If the Secondary Serving Cell Meas Pow Offset parameter is set to Auto, this parameter has no effect.

Setting

Range: -6.0 to +13.0 dB

Increment: 0.5 dB

Query

 Same as setting

*RST Setting

 +6.0 dB

Requirements

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:MPOWer:OFFSet:MANual -6"
! Sets the Secondary Serving Cell Measurement Power Offset to -6dB.

CALL:HSDPa:SSCell:MPOWer[:MOFFset]

Function

Sets/queries the Secondary Serving Cell Meas Pow Offset .

This setting only applies when CALL:HSDPa:HRNTi:ALTernate is set to OFF(manual).

This parameter can only be set when call status is Idle .

Setting

Range: -6.0 to +13.0 dB

Increment: 0.5 dB

Query

 Same as setting

*RST Setting

 +6.0 dB

Requirements

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:MPOWer 2"
! Sets the Secondary Serving Cell Measurement Power Offset to 2.

CALL:HSDPa:SSCell:PSData:HSDschannel:CONFig[:TYPE]

Function

Sets/queries Secondary Serving Cell HS-DSCH Configuration Type.

This setting can be changed while Data Status is Idle or Active.

Setting

Range: CQIValue | RCQI | UDEFined

Query

Range: Same as setting

*RST Setting

 CQIValue

Requirements

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:PSData:HSDschannel:CONFig CQIValue"
! Sets Secondary Serving Cell PS Data First HS-DSCH Type to CQI Value

CALL:HSDPa:SSCell:PSData:UDEFined:QAM64:STATe

Function

Sets/queries PS Data Secondary Cell HS-DSCH 64QAM Configured State.

This setting controls whether "Downlink 64QAM configured" IE shall be sent to the UE during PS Data call setup procedure and whether the 64QAM encoding format is used for the secondary serving cell HS-SCCH. This setting also determines the actual transport block size and the HS-DSCH TB size table.

This parameter can only be set when call status is Idle .

Setting

Range: 1|ON|0|OFF

Query

 1|0

*RST Setting

 0 (OFF)

Requirements

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"call:hsdp:ssc:psd:qam64:stat on"
! Sets the PS Data Secondary Serving Cell HS-DSCH 64QAM Configured State to On.

CALL:HSDPa:SSCell:PSData:MACEHS:HSDSchannel:TBSTable:ALIGnment

Function

Sets/queries the PS Data User Def Secondary Cell TB Size Index when PS Data Secondary Cell HS-DSCH 64QAM Configured State is "Off".

This parameter can only be set when call status is Idle .

Setting

Range: BIT | OCTet

Query

 Same as setting

*RST Setting

 OCTet

Requirements

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:PSData:MACEHS:HSDSchannel:TBSTable:ALIGnment OCTet"
! Sets PS Data Secondary Serving Cell MAC-ehs HS-DSCH TB Size Table to OCTet-aligned.

CALL:HSDPa:SSCell:PSData:CQI[:VALue]

Function

Sets/queries the Secondary Serving Cell CQI Value.

This parameter can be changed when call status is Idle or Active.

Setting

Range: 5 to 30

Query

 Same as setting

*RST Setting

 5

Requirements

Lab Application Revision: H.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:PSData:CQI 5"
! Sets the Secondary Serving Cell HS-DSCH CQI Value to 5.

CALL:HSDPa:SSCell:PSData:ITTI[:INTerval]:MINimum:CONTrol:AUTO

Function

Sets/queries the Secondary Serving Cell Minimum Inter-TTI Interval State. When it is set to "Auto", the minimum inter-TTI interval of the secondary serving cell is set according to the minimum supported by each UE category. When it is set to "Manual", the minimum inter-TTI interval of the secondary serving cell is controlled by the CALL:HSDPa:MPOWer:OFFSet:CONTrol:AUTO command.

This parameter can be changed when call status is Idle or Active .

Setting

Range: 1|ON|0|OFF

Query

 1|0

*RST Setting

 1 (On)

Requirements

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:PSData:ITTI:MINimum:CONTrol:AUTO ON"
! Sets the Secondary Serving Cell Minimum Inter-TTI Interval State to Auto.

CALL:HSDPa:SSCell:PSData:ITTI[:INTerval]:MINimum:MANual

Function

Sets/queries the minimum inter-TTI interval between transmitting blocks to the UE on the secondary serving cell HS-PDSCHs.

This parameter can be changed when call status is Idle or Active.

Setting

Range: 1 to 500

Query

Same as setting

*RST Setting

 1

Requirements

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:PSData:ITTI:MINimum:MANual 1"
! Sets the Secondary Servig Cell Manual Minimum Inter-TTI Interval to 1.

CALL:HSDPa:SSCell:PSData:ITTI[:INTerval][:MMINimum]

Function

Sets/queries the PS Data Secondary Cell Minimum Inter-TTI Interval.

This parameter can only be set either while the call status is Idle .

This setting only applies when CALL:HSDPa:MPOWer:OFFSet:CONTrol:AUTO is set to OFF (manual).

Setting

Range: 1 to 500

Query

 Same as setting

*RST Setting

 1

Requirements

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:PSData:ITTI 1"
! Sets the PS Data Secondary Cell Minimum Inter-TTI Interval to 1.

CALL:HSDPa:SSCell:PSData:UDEFined:HSPDschannel:COUNt

Function

Sets/queries PS Data User Defined Secondary Cell Active HS-PDSCHs.

This parameter can be changed when call status is Idle or Active.
Setting

Range: 1 to 15

Query

 Same as setting

*RST Setting

 5

Requirements

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:PSData:UDEFined:HSPDschannel:COUNt 5"

CALL:HSDPa:SSCell:PSData:UDEFined:MODulation[:TYPE]

Function

Sets/queries PS Data User Defined Secondary Cell Modulation Type.

This parameter can be changed when call status is Idle or Active.
Setting

Range: QAM16 | QPSK | QAM64

Query

 Same as setting.

*RST Setting

 QAM16

Requirements

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:PSData:UDEFined:MODulation QAM16"

CALL:HSDPa:SSCell:PSData:UDEFined:TBSize:INDex

Function

Sets/queries the PS Data User Def Secondary Cell TB Size Index.

This parameter can be changed when call status is Idle or Active.

Setting

Range: 0 to 62

Query

 Same as setting

*RST Setting

 48

Requirements

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:PSData:UDEFined:TBSize:INDex 62"

CALL:HSDPa:SSCell:RBTest:UDEFined:QAM64:STATe

Function

Sets/queries the RB Test User Def Secondary Cell 64QAM State .

This parameter can only be set when call status is Idle .

Setting

 Range: 1|On|0|Off

Query

 1|0

*RST Setting

 0 (Off)

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:RBTest:UDEFined:QAM64:STATe Off"

CALL:HSDPa:SSCell:RBTest:MACEHS:HSDSchannel:TBSTable:ALIGnment

Function

Sets/queries the RBTM User Def Sec Cell HS-DSCH TBS Table .

This parameter can only be set when call status is Idle .

Setting

 BIT | OCTet

Query

 Same as setting

*RST Setting

 OCTet

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:RBTest:MACEHS:HSDSchannel:TBSTable:ALIGnment OCTet"

CALL:HSDPa:SSCell:RBTest:UDEFined:HSPDschannel:COUNt

Function

Sets/queries the RBTM User Def Sec Cell Active HS-PDSCHs .

This parameter can be changed when call status is Idle or Active.

Setting

 1 to 15

Query

 Same as setting

*RST Setting

 5

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:RBTest:UDEFined:HSPDschannel:COUNt 5"

CALL:HSDPa:SSCell:RBTest:UDEFined:ITTI[:INTerval]

Function

Sets/queries the RBTM User Def Sec Cell Inter-TTI Interval .

This parameter can be changed when call status is Idle or Active.

Setting

Range: 1 to 8

Query

Same as setting

*RST Setting

 3

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:RBTest:UDEFined:ITTI 3"

CALL:HSDPa:SSCell:RBTest:UDEFined:MODulation[:TYPE]

Function

Sets/queries the RBTM User Def Sec Cell Modulation Type .

This parameter can be changed when call status is Idle or Active.

Setting

Range: QAM16 | QPSK | QAM64

Query

 Same as setting

*RST Setting

 QPSK

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:RBTest:UDEFined:MODulation QPSK"

CALL:HSDPa:SSCell:RBTest:UDEFined:TBSize:INDex

Function

Sets/queries the RBTM User Def Sec Cell TB Size Index .

This parameter can be changed when call status is Idle or Active.

Setting

Range: 0 to 62

Query

Same as setting

*RST Setting

 62

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.

Lab Application Revision: H.01.00.

Programming Example

OUTPUT 714;"CALL:HSDPa:SSCell:RBTest:UDEFined:TBSize:INDex 62"

CALL:HSDPa:UPLink:DACK

Function

Sets/queries DeltaACK .

This parameter can only be set when call status is Idle .

Setting

Range: 0 to 8

Resolution: 1

Query

 Same as setting

*RST Setting

 3

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:UPLink:DACK 7"
! Sets DeltaACK to 7.

CALL:HSDPa:UPLink:DCQI

Function

Sets/queries DeltaCQI .

This parameter can only be set when call status is Idle .

Setting

Range: 0 to 8

Resolution: 1

Query

 Same as setting

*RST Setting

 5

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:UPLink:DCQI 3"
! Sets DeltaCQI to 3.

CALL:HSDPa:UPLink:DNACk

Function

Sets/queries DeltaNACK .

This parameter can only be set when call status is Idle .

Setting

Range: 0 to 8

Resolution: 1

Query

 Same as setting

*RST Setting

 3

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:UPLink:DNACk 5"
! Sets DeltaNACK to 5.

CALL:HSDPa:UPLink:ANACk:RFACtor

Function

Sets/queries Ack-Nack Repetition Factor .

This parameter can only be set when call status is Idle .

Setting

Range: 1 to 4

Resolution: 1

Query

 Same as setting

*RST Setting

 1

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:UPLink:ANACk:RFACtor 2"
! Sets ACK-NACK Repetition Factor to 2.

CALL:HSDPa:UPLink:CQI:FCYCle

Function

Sets/queries CQI Feedback Cycle (k) .

This parameter can only be set when call status is Idle .

CQI Feedback Cycle (k) must be greater than or equal to CQI Repetition Factor * 2ms (except for the case when CQI Feedback Cycle (k) equals 0 ms). See CALL:HSDPa:UPLink:CQI:RFACtor .

Setting

Range: 0, 2, 4, 8, 10, 20, 40, 80, 160 ms

Note, the default unit for this command is seconds. If you enter a value without a unit (S|MS|US|NS), the test set assumes the value you've entered is in seconds.

Query

 Same as setting

*RST Setting

 2 ms

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:UPLink:CQI:FCYCle 8 MS"
! Sets CQI Feedback Cycle (k) to 8 ms.

CALL:HSDPa:UPLink:CQI:RFACtor

Function

Sets/queries CQI Repetition Factor .

This parameter can only be set when call status is Idle .

CQI Feedback Cycle (k) must be greater than or equal to CQI Repetition Factor * 2ms (except for the case when CQI Feedback Cycle (k) equals 0 ms). See CALL:HSDPa:UPLink:CQI:FCYCle .

Setting

Range: 1 to 4

Resolution: 1

Query

 Same as setting

*RST Setting

 1

Requirements

Test Application Revision A.08.20 and above, with the required feature license.

Lab Application Revision C.03 and above

Programming Example

OUTPUT 714;"CALL:HSDPa:UPLink:CQI:RFACtor 2"
! Sets CQI Repetition Factor to 2.


CALL:HSSCchannel

CALL:HSSCchannel

Last updated: January 14, 2010

This section is only applicable to the lab application or feature-licensed test application.

GPIB Command Conventions

  • CALL:HSSCchannel[1]:CCODe
  • CALL:HSSCchannel[1]:CCODe:CODE
  • CALL:HSSCchannel[1]:CONFig:STATe
  • CALL:HSSCchannel2:CCODe
  • CALL:HSSCchannel2:CCODe:CODE
  • CALL:HSSCchannel2:CONFig:STATe
  • CALL:HSSCchannel3:CCODe
  • CALL:HSSCchannel3:CCODe:CODE
  • CALL:HSSCchannel3:CONFig:STATe
  • CALL:HSSCchannel4:CCODe
  • CALL:HSSCchannel4:CCODe:CODE
  • CALL:HSSCchannel4:CONFig:STATe

CALL:HSSCchannel[1]:CCODe

Function

THIS COMMAND IS OBSOLETE. Please use CALL:HSSCchannel[1]:CCODe:CODE .

Sets/queries the HS-SCCH 1 Channelization Code .

Setting

Range: CODE2|CODE6|CODE9|CODE10|CODE11|CODE16|CODE17

Query

 Same as setting.

*RST Setting

CODE2

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:HSSCchannel:CCODe CODE11"
! Sets the HS-SCCH 1 Channelization Code to 11.

CALL:HSSCchannel[1]:CCODe:CODE

Function

Sets/queries the HS-SCCH 1 Channelization Code .

This parameter can not be changed in active cell operating mode (use cell off operating mode or FDD test operating mode to change this parameter).

Setting

Range: 1 to 127

Query

 Same as setting.

*RST Setting

2

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HSSCchannel:CCODe:CODE 2"
! Sets the HS-SCCH 1 Channelization Code to 2.

CALL:HSSCchannel[1]:CONFig:STATe

Function

Sets/queries the FDD Test Mode HSDPA/HSPA HS-SCCH 1 Channel Configuration State.

Setting

 Range: 1|ON|0|OFF

Query

Range: 0|1

*RST Setting

 1 (ON)
Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HSSCchannel:CONFig:STATe"
!Sets the FDD Test Mode HSDPA/HSPA HS-SCCH 1 Channel Configuration State.to on.

CALL:HSSCchannel2:CCODe

Function

THIS COMMAND IS OBSOLETE. Please use CALL:HSSCchannel2:CCODe:CODE .

Sets/queries the HS-SCCH 2 Channelization Code .

Setting

Range: CODE2|CODE6|CODE9|CODE10|CODE11|CODE16|CODE17

Query

 Same as setting.

*RST Setting

CODE6

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:HSSCchannel2:CCODe CODE11"
! Sets the HS-SCCH 2 Channelization Code to 11.

CALL:HSSCchannel2:CCODe:CODE

Function

Sets/queries the HS-SCCH 2 Channelization Code .

This parameter can not be changed in active cell operating mode (use cell off operating mode or FDD test operating mode to change this parameter).

Setting

Range: 1 to 127

Query

 Same as setting.

*RST Setting

6

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HSSCchannel2:CCODe:CODE 6"
! Sets the HS-SCCH 2 Channelization Code to 6.

CALL:HSSCchannel2:CONFig:STATe

Function

Sets/queries the FDD Test Mode HSDPA/HSPA HS-SCCH 2 Channel Configuration State.

Setting

 Range: 1|ON|0|OFF

Query

Range: 0|1

*RST Setting

 1 (ON)
Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HSSCchannel2:CONFig:STATe"
!Sets the FDD Test Mode HSDPA/HSPA HS-SCCH 2 Channel Configuration State.to on.

CALL:HSSCchannel3:CCODe

Function

THIS COMMAND IS OBSOLETE. Please use CALL:HSSCchannel3:CCODe:CODE .

Sets/queries the HS-SCCH 3 Channelization Code .

Setting

Range: CODE2|CODE6|CODE9|CODE10|CODE11|CODE16|CODE17

Query

 Same as setting.

*RST Setting

CODE9

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:HSSCchannel3:CCODe CODE11"
! Sets the HS-SCCH 3 Channelization Code to 11.

CALL:HSSCchannel3:CCODe:CODE

Function

Sets/queries the HS-SCCH 3 Channelization Code .

This parameter can not be changed in active cell operating mode (use cell off operating mode or FDD test operating mode to change this parameter).

Setting

Range: 1 to 127

Query

 Same as setting.

*RST Setting

9

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HSSCchannel3:CCODe:CODE 9"
! Sets the HS-SCCH 3 Channelization Code to 9.

CALL:HSSCchannel3:CONFig:STATe

Function

Sets/queries the FDD Test Mode HSDPA/HSPA HS-SCCH 3 Channel Configuration State.

Setting

 Range: 1|ON|0|OFF

Query

Range: 0|1

*RST Setting

 1 (ON)
Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HSSCchannel3:CONFig:STATe"
!Sets the FDD Test Mode HSDPA/HSPA HS-SCCH 3 Channel Configuration State.to on.

CALL:HSSCchannel4:CCODe

Function

THIS COMMAND IS OBSOLETE. Please use CALL:HSSCchannel4:CCODe:CODE .

Sets/queries the HS-SCCH 4 Channelization Code .

Setting

Range: CODE2|CODE6|CODE9|CODE10|CODE11|CODE16|CODE17

Query

 Same as setting.

*RST Setting

CODE10

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:HSSCchannel4:CCODe CODE11"
! Sets the HS-SCCH 4 Channelization Code to 11.

CALL:HSSCchannel4:CCODe:CODE

Function

Sets/queries the HS-SCCH 4 Channelization Code .

This parameter can not be changed in active cell operating mode (use cell off operating mode or FDD test operating mode to change this parameter).

Setting

Range: 1 to 127

Query

 Same as setting.

*RST Setting

10

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HSSCchannel4:CCODe:CODE 10"
! Sets the HS-SCCH 4 Channelization Code to 10.

CALL:HSSCchannel4:CONFig:STATe

Function

Sets/queries the FDD Test Mode HSDPA/HSPA HS-SCCH 4 Channel Configuration State.

Setting

 Range: 1|ON|0|OFF

Query

Range: 0|1

*RST Setting

 1 (ON)
Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HSSCchannel4:CONFig:STATe"
!Sets the FDD Test Mode HSDPA/HSPA HS-SCCH 4 Channel Configuration State.to on.


CALL:HSUPa

CALL:HSUPa

Last updated: January 7, 2012

This section is only applicable to the lab application or feature-licensed test application.

GPIB Command Conventions

  • CALL:HSUPa:BEDGain:EAGChannel:TSELection
  • CALL:HSUPa:EDCHannel:ETFCi:MSET
  • CALL:HSUPa:EDCHannel:ETFCi:MSET:MS2
  • CALL:HSUPa:EDCHannel:ETFCi:MSET:STATe
  • CALL:HSUPa:EDCHannel:TTI
  • CALL:HSUPa:EDCHannel:QAM16[:STATe]

  • CALL:HSUPa:EDPCchannel[:DPCChannel]:POFFset

  • CALL:HSUPa:EDPDchannel:PCFormula

  • CALL:HSUPa:ERNTi[:PRIMary]
  • CALL:HSUPa:ERNTi:ALTernate

  • CALL:HSUPa:ETFCi:BOOSt[:VALue]
  • CALL:HSUPa:ETFCi:BOOSt:DT2Tp
  • CALL:HSUPa:ETFCi:BOOSt:INFormation[:STate]
  • CALL:HSUPa:ETFCi:POFFsets:REFerence
  • CALL:HSUPa:ETFCi:POFFsets:REFerence:CONTrol
  • CALL:HSUPa:ETFCi:POFFsets:REFerence:MANual:INDex
  • CALL:HSUPa:ETFCi:POFFsets:REFerence:MANual:POFFset
  • CALL:HSUPa:ETFCi:POFFsets:REFerence:MANual:STATe
  • CALL:HSUPa:ETFCi:RECord:BEHavior
  • CALL:HSUPa:ETFCi:RECord:COUNt
  • CALL:HSUPa:ETFCi:RECord:STARt
  • CALL:HSUPa:ETFCi:RECord:STOP
  • CALL:HSUPa:ETFCi:TINDex
  • CALL:HSUPa:ETFCi:TINDex:MS2
  • CALL:HSUPa:ETFCi:TINDex:MS2:QAM16
  • CALL:HSUPa:HARQ:RETRans:MAXimum
  • CALL:HSUPa:HBIT:APERiod
  • CALL:HSUPa:HBIT:DCONdition

  • CALL:HSUPa:MS:REPorted:EDCHannel:CATegory?
  • CALL:HSUPa:MS:REPorted:EDCHannel:CATegory:EXTension?
  • CALL:HSUPa:MS:REPorted:HBIT[:LAST]?
  • CALL:HSUPa:MS:REPorted:HBIT:RATio?

  • CALL:HSUPa:SERVice:PSData:EDPDchannel:CCODes:MAX
  • CALL:HSUPa:SERVice:PSData:ERGChannel:INFormation[:STATe]
  • CALL:HSUPa:SERVice:PSData:MACD:PDUSize

  • CALL:HSUPa:SERVice:RBTest:EDPDchannel:CCODes:MAX
  • CALL:HSUPa:SERVice:RBTest:EDPDchannel:CCODes:MAX:HSPA
  • CALL:HSUPa:SERVice:RBTest:ERGChannel:INFormation[:STATe]
  • CALL:HSUPa:SERVice:RBTest:HARQ:RETRans:MAXimum
  • CALL:HSUPa:SERVice:RBTest:RLCPdu:SIZE
  • CALL:HSUPa:SERVice:RBTest:RLCSdu:SIZE

  • CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue[1]
  • CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue2
  • CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue3
  • CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue4
  • CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue5
  • CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue6
  • CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue7
  • CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue8
  • CALL:HSUPa:SGRant:ABSolute:ALTernative:SSHot[:VALue]
  • CALL:HSUPa:SGRant:ABSolute:MODE
  • CALL:HSUPa:SGRant:ABSolute:PATTern:LENGth
  • CALL:HSUPa:SGRant:ABSolute:PATTern:VALue[1]
  • CALL:HSUPa:SGRant:ABSolute:PATTern:VALue2
  • CALL:HSUPa:SGRant:ABSolute:PATTern:VALue3
  • CALL:HSUPa:SGRant:ABSolute:PATTern:VALue4
  • CALL:HSUPa:SGRant:ABSolute:PATTern:VALue5
  • CALL:HSUPa:SGRant:ABSolute:PATTern:VALue6
  • CALL:HSUPa:SGRant:ABSolute:PATTern:VALue7
  • CALL:HSUPa:SGRant:ABSolute:PATTern:VALue8
  • CALL:HSUPa:SGRant:ABSolute:RBSetup[:VALue]
  • CALL:HSUPa:SGRant:ABSolute:RBSetup:QAM16[:VALue]
  • CALL:HSUPa:SGRant:ABSolute:SSHot[:VALue]
  • CALL:HSUPa:SGRant:ABSolute:SSHot:SEND[:IMMediate]

  • CALL:HSUPa:SGRant:RELative:DOWN:SEND[:IMMediate]
  • CALL:HSUPa:SGRant:RELative:MODE
  • CALL:HSUPa:SGRant:RELative:PATTern
  • CALL:HSUPa:SGRant:RELative:PATTern:PERiodic[:STATe]
  • CALL:HSUPa:SGRant:RELative:PATTern:SEND[:IMMediate]
  • CALL:HSUPa:SGRant:RELative:QUEued:CLEar
  • CALL:HSUPa:SGRant:RELative:UP:SEND[:IMMediate]

  • CALL:HSUPa:SIPeriod:GRANt
  • CALL:HSUPa:SIPeriod:NGRant

CALL:HSUPa:BEDGain:EAGChannel:TSELection

Function

Sets/queries the BetaEd Gain E-AGCH Table Selection setting. This setting determines which table in the 3GPP standard 25.212 v7b0 the UE will use to interpret the absolute grant value indices signalled on E-AGCH. 0 means that UE uses Mapping of Absolute Grant Value Table 16B, whereas 1 indicates that the reference table is the Alternative Mapping of Absolute Grant Value Table 16B.1.

This setting is only applicable when the CALL:HSUPa:EDCHannel:QAM16[:STATe] is set to ON.

This setting can only be changed when the connection status is idle.

Setting

Range: 0 | 1

Query

 Same as setting.

*RST Setting

 1

Requirements

Test Application Revision: A.17.00 and above
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:BEDGain:EAGChannel:TSELection 1"
! Sets the BetaEd Gain E-AGCH Table Selection to 1.

CALL:HSUPa:EDCHannel:ETFCi:MSET

Function

Sets/queries the E-DCH Minimum Set E-TFCI (10ms TTI) .

This setting can only be changed when the connection status is idle.

Setting

Range: 0 to 127

Resolution: 1

Query

 Same as setting.

*RST Setting

9

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:EDCHannel:ETFCi:MSET 9"
! Sets the E-DCH Minimum Set E-TFCI to 9.

CALL:HSUPa:EDCHannel:ETFCi:MSET:MS2

Function

Sets/queries the E-DCH Minimum Set E-TFCI (2ms TTI) .

This setting can only be changed when the connection status is idle.

Setting

Range: 0 to 127

Resolution: 1

Query

 Same as setting.

*RST Setting

10

Requirements

Test Application Revision: A.13 and above

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:EDCHannel:ETFCi:MSET:MS2 10"
! Sets the E-DCH Minimum Set E-TFCI (2ms TTI) to 10.

CALL:HSUPa:EDCHannel:ETFCi:MSET:STATe

Function

Sets/queries the E-DCH Minimum Set E-TFCI Information State .

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

1 (ON)

Requirements

Test Application Revision: A.13 and above

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:EDCHannel:ETFCi:MSET:STATe ON"
! Sets the E-DCH Minimum Set E-TFCI Information State to On.

CALL:HSUPa:EDCHannel:TTI

Function

Sets/queries the E-DCH TTI .

Setting

Range: MS10 (10 ms TTI)|MS2 (2 ms TTI)

Query

 Same as setting.

*RST Setting

MS10

Requirements

Test Application Revision: A.13 and above

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:EDCHannel:TTI MS10"
! Sets the HSUPA TTI mode to 10ms TTI.

CALL:HSUPa:EDCHannel:QAM16[:STATe]

Function

Sets/queries the E-DCH 16QAM State . This setting determines whether the test set signals the UE to operate in UL 16QAM mode for E-DCH.

This setting is only applicable when the CALL:HSUPa:EDCHannel:TTI is set to MS10.

Setting

Range: 1|ON|0|OFF

Query

 1|0

*RST Setting

 0|OFF

Requirements

Test Application Revision: A.17.00 and above, with the required feature license.
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:EDCHannel:QAM16 OFF"
! Sets the E-DCH 16QAM State to Off.

CALL:HSUPa:EDPCchannel[:DPCChannel]:POFFset

Function

Sets/queries the E-DPCCH/DPCCH Power Offset (DeltaE-DPCCH) .

This setting can only be changed when the connection status is idle.

Setting

Range: 0 to 8

Resolution: 1

Query

 Same as setting.

*RST Setting

0

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:EDPCchannel:POFFset 0"
! Sets E-DPCCH/DPCCH Power Offset (DeltaE-DPCCH) to 0.

CALL:HSUPa:EDPDchannel:PCFormula

Function

Sets/queries the E-DPDCH Power Calculation Formula setting. This setting determines what formula the UE uses to calculate the E-DPDCH power.

This setting can only be changed when the connection status is idle.

Setting

Range: EXTRapolation | INTerpolation

Query

Range: EXTR | INT

*RST Setting

 EXTRapolation

Requirements

Test Application Revision: A.17.00 and above, with the required feature license.
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:EDPDchannel:PCFormula EXTRapolation"
! Sets the E-DPDCH Power Calculation Formula to EXTRapolation.

CALL:HSUPa:ERNTi[:PRIMary]

Function

Sets/queries the Primary E-RNTI (Hex) .

This setting can only be changed when the connection status is idle.

Setting

Range: 0 to FFFF (1 to 4 characters from the set 0123456789AaBbCcDdEeFf)

Query

Range: "0000" to "FFFF" (The return string is always 4 characters from the set 0123456789AaBbCcDdEeFf, enclosed by double quotes.)

*RST Setting

"AAAA"

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:ERNTi 'AAAA'"
! Sets the Primary E-RNTI (Hex) to AAAA.

CALL:HSUPa:ERNTi:ALTernate

Function

Sets/queries the Alternate E-RNTI (Hex).

This setting can only be changed when the connection status is idle.

Setting

Range: 0 to FFFF (1 to 4 characters from the set 0123456789AaBbCcDdEeFf)

Query

Range: "0000" to "FFFF" (The return string is always 4 characters from the set 0123456789AaBbCcDdEeFf, enclosed by double quotes.)

*RST Setting

"5555"

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:ERNTi:ALTernate '5555'"
! Sets the Alternate E-RNTI (Hex) to 5555.

CALL:HSUPa:ETFCi:BOOSt[:VALue]

Function

Sets/queries the E-TFCI Boost setting. When CALL:HSUPa:ETFCi:BOOSt:INFormation[:STate] is set to On, this setting determines the E-TFCI threshold beyond which boosting of E-DPCCH is enabled.

This setting can only be changed when the connection status is idle.

Setting

Range: 0 to 127

Query

 Same as setting.

*RST Setting

 127

Requirements

Test Application Revision: A.17.00 and above
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;" CALL:HSUPa:ETFCi:BOOSt 127"
! Sets the E-TFCI Boost to 127.

CALL:HSUPa:ETFCi:BOOSt:DT2Tp

Function

Sets/queries the DeltaT2TP setting. When CALL:HSUPa:ETFCi:BOOSt:INFormation[:STate] is set to On and CALL:HSUPa:ETFCi:BOOSt[:VALue] is set to a value other than 127, this setting determines the Delta T2TP value that would be signalled to the UE. The power offset values (in dB) for each signalled value are defined in 3GPP 25.213 v770 Table 1B.0.

This setting can only be changed when the connection status is idle.

Setting

Range: 0 to 6

Query

 Same as setting.

*RST Setting

 2

Requirements

Test Application Revision: A.17.00 and above
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:ETFCi:BOOSt:DT2Tp 2"
! Sets the DeltaT2TP
 to 2.

CALL:HSUPa:ETFCi:BOOSt:INFormation[:STate]

Function

Sets/queries the E-TFC Boost Info State setting. This setting determines whether the test set enables the boosting of E-DPCCH.

This setting can only be changed when the connection status is idle.

Setting

1|ON|0|OFF

Query

 1|0

*RST Setting

 0|OFF

Requirements

Test Application Revision: A.17.00 and above
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:ETFCi:BOOSt:INFormation Off"
! Sets the E-TFC Boost Info State to Off.

CALL:HSUPa:ETFCi:POFFsets:REFerence

Function

Sets/queries the Predefined Reference E-TFCI Power Offsets .

Setting

Range: DEF3410801|DEF3410802|DEF3412101|DEF3412102|DEF3412103|DEF3412104

Query

 Same as setting.

*RST Setting

DEF3410802

Requirements

Test Application Revision: A.12 and above, with the required feature license
Lab Application Revision: E.00.16 and above
Lab Application Revision: G.00.09 and above, added DEF3412103
Lab Application Revision: G.01.00 and above, added DEF3412104

Programming Example

OUTPUT 714;"CALL:HSUPa:ETFCi:POFFsets:REFerence DEF3410802"
! Sets the Reference E-TFCI Power Offsets to match those in the Definition 34108-02.

CALL:HSUPa:ETFCi:POFFsets:REFerence:CONTrol

Function

Sets/queries the Reference E-TFCI Power Offset Control .

Setting

PDEFined | MANual

Query

 Same as setting.

*RST Setting

PDEFined

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:ETFCi:POFFsets:REFerence:CONTrol PDEFined"
! Sets the Reference E-TFC Configuration to Pre-defined.

CALL:HSUPa:ETFCi:POFFsets:REFerence:MANual:INDex

Function

Sets/queries the Reference E-TFCI.

Each entry in this list defines the Reference E-TFCI as part of Reference E-TFCIs IE that is signaled to UE at call setup. Whether the Reference E-TFCI is actually present in the RRC message is controlled by the "Reference E-TFCI 1 to 8 States" setting.The valid range for each entry in this list depends on the HSUPA TTI mode and E-DCH TB size table (3GPP TS 25.321 Annex B) in use (See Table below).

The default value comes from 3GPP TS 34.108 s9.2.

Setting

Range: 8 comma separated values (see table below for valid ranges))

Resolution: 1

Query

 Same as setting

*RST Setting

11,0,0,0,0,0,0,0

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:ETFCi:POFFsets:REFerence:MANual:INDex 11,0,0,0,0,0,0,0"
! Sets Reference E-TFCI to 11,0,0,0,0,0,0,0.

Reference E-TFCI Valid Ranges
HSUPA TTI Mode | E-TFCI Table Index | Valid Range ofReference E-TFCI
2ms TTI | 0 | 0 to 127
 | 1 | 0 to 125
10ms TTI | 0 | 0 to 127
 | 1 | 0 to 120

CALL:HSUPa:ETFCi:POFFsets:REFerence:MANual:POFFset

Function

Sets/queries the Reference E-TFCI Power Offset.

Each entry the in this list defines the Reference E-TFCI PO that is part of Reference E-TFCIs IE signaled to UE at call setup. Whether the Reference E-TFCI PO is actually present in the RRC message is controlled by the "Reference E-TFCI 1 to 8 States" setting.3GPP TS 25.213 Table 1B.1 defines the values for this parameter (also known as deltaE-DPDCH), which is used to determine the reference gain factor ßed,ref that is then used together with the reference E-TFCI to calculate the gain factor ßed for the selected E-TFCI based on the configured HARQ profile.The default value comes from 3GPP TS 34.108 s9.2.

Setting

Range: 8 comma separated values of 0 to 31

Resolution: 1

Query

 Same as setting

*RST Setting

4,0,0,0,0,0,0,0

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:ETFCi:POFFsets:REFerence:MANual:POFFset 4,0,0,0,0,0,0,0"
! Sets Reference E-TFCI Power Offset to 4,0,0,0,0,0,0,0.

CALL:HSUPa:ETFCi:POFFsets:REFerence:MANual:STATe

Function

Sets/queries the Reference E-TFCI 1 to 8 States.

A maximum of 8 reference E-TFCs can be signaled to UE according to the 3GPP specifications. So, each position in this parameter's list corresponds one of these 8 reference E-TFCs. Only those positions that are set to "1" will be present in the RRC message sent to the UE.The default value comes from 3GPP TS 34.108 s9.2.

Setting

Range: 8 comma separated states (1|ON|0|OFF)

Query

 Same as setting

*RST Setting

1,0,0,0,0,0,0,0

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:ETFCi:POFFsets:REFerence:MANual:STATe 1,0,0,0,0,0,0,0"
! Sets Reference E-TFCI state 1 to On, and states 2 to 8 to Off.

CALL:HSUPa:ETFCi:RECord:BEHavior

Function

Sets/queries the E-TFCI Recording Behavior. This setting determines whether all E-DPDCH subframes are recorded, or only those that pass CRC checks.

This setting can only be changed when E-TFCI Recording State is idle.

Setting

Range: ALL|GCRC (Good CRC only)

Query

 Same as setting.

*RST Setting

GCRC

Requirements

Lab Application Revision: E.00.34 and above

Test Application Revision: A.13 and above.

Programming Example

OUTPUT 714;"CALL:HSUPa:ETFCi:RECord:BEHavior GCRC"
! Sets all E-DPDCH subframe values that pass CRC checks to be recorded.

CALL:HSUPa:ETFCi:RECord:COUNt

Function

Sets/queries the E-TFCI Rec Count . This setting can only be changed when E-TFCI Recording State is idle.

Setting

Range: 1 to 50

Resolution: 1

Query

 Same as setting.

*RST Setting

15

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:ETFCi:RECord:COUNt 15"
! Sets the E-TFCI Rec Count to 15.

CALL:HSUPa:ETFCi:RECord:STARt

Function

Start Recording E-TFCI Values .

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:ETFCi:RECord:STARt"

CALL:HSUPa:ETFCi:RECord:STOP

Function

Stop Recording E-TFCI Values .

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:ETFCi:RECord:STOP"
! Stop Recording E-TFCI Values.

CALL:HSUPa:ETFCi:TINDex

Function

Sets/queries the E-TFCI Table Index (10 ms TTI) .

This setting can only be changed when the connection status is idle.

Setting

Range: 0 to 1

Resolution: 1

Query

 Same as setting.

*RST Setting

0

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:ETFCi:TINDex 0"
! Sets the E-TFCI Table Index (10 ms TTI) to Table 0.

CALL:HSUPa:ETFCi:TINDex:MS2

Function

Sets/queries the E-TFCI Table Index (2ms TTI). This setting controls whether the UE is instructed to use E-DCH Transport Block Size Table 0 or Table 1 from 3GPP TS 25.321 Annex B when the HSUPA TTI Mode is set to 2ms TTI (see CALL:HSUPa:EDCHannel:TTI ). The default value is set to match the generic RB Setup message from 3GPP TS 34.108 s9.1.

This setting can only be changed when the connection status is idle.

Setting

Range: 0 to 1

Resolution: 1

Query

 Same as setting.

*RST Setting

0

Requirements

Test Application Revision: A.13 and above

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:ETFCi:TINDex:MS2 0"
! Sets the E-TFCI Table Index (2 ms TTI) to Table 0.

CALL:HSUPa:ETFCi:TINDex:MS2:QAM16

Function

Sets/queries the E-TFCI Table Index (2 ms TTI with 16QAM) (See E-TFCI Table Index (2 ms TTI) / E-TFCI Table Index (2 ms TTI with 16QAM) ). This setting controls whether the UE is instructed to use 2ms TTI E-DCH Transport Block Size Table 2 or 3 (in 3GPP TS 25.321 v7a0 Annex B) when the E-DCH TTI is set to 2ms (see CALL:HSUPa:EDCHannel:TTI ).

This setting can only be changed when the connection status is idle.

Setting

Range: 2 |3

Query

 Same as setting.

*RST Setting

2

Requirements

Test Application Revision: A.17.00 and above
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:ETFCi:TINDex:MS2:QAM16 2"
! Sets the E-TFCI Table Index (2 ms TTI with 16QAM) to Table 2.

CALL:HSUPa:HARQ:RETRans:MAXimum

Function

Sets/queries the HARQ Maximum Number of Retransmissions .

Setting

Range: 0 to 15

Resolution: 1

Query

 Same as setting.

*RST Setting

 7

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:HARQ:RETRans:MAXimum 7"
! Sets HARQ Number of Retransmissions.

CALL:HSUPa:HBIT:APERiod

Function

Sets/queries the Happy Bit Avg Period .

Setting

Range: 0.5 to 3600 seconds

Resolution: 0.5 seconds

Query

 Same as setting.

*RST Setting

 1 second

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:HBIT:APERiod 1"
! Sets the Happy Bit Average Period to 1 seconds.

CALL:HSUPa:HBIT:DCONdition

Function

Sets/queries the Happy Bit Delay Cond .

Setting

Range: MS2 | MS10 | MS20 | MS50 | MS100 | MS200 | MS500 | MS1000

Query

 Same as setting.

*RST Setting

 MS100

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:HBIT:DCONdition MS100"
! Sets the Happy Bit Delay Condition to 100 MS.

CALL:HSUPa:MS:REPorted:EDCHannel:CATegory?

Function

Queries the UE reported E-DCH Category. See Rep EDCH Cat/Ext .

Query

 Range: CAT1|CAT2|CAT3|CAT4|CAT5|CAT6|NREP|NSUP

*RST Setting

NREP

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:MS:REPorted:EDCHannel:CATegory?"
! Queries the UE Reported E-DCH Category.

CALL:HSUPa:MS:REPorted:EDCHannel:CATegory:EXTension?

Function

Queries the UE reported E-DCH Category Extension. See Rep EDCH Cat/Ext .

Query

 CAT7 | NREP

*RST Setting

 NREP

Requirements

Test Application Revision: A.17 and above, with the required feature license
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:MS:REPorted:EDCHannel:CATegory:Extension?"
! Queries the UE Reported E-DCH Category Extension.

CALL:HSUPa:MS:REPorted:HBIT[:LAST]?

Function

Queries the Last Happy Bit .

Query

 HAPP |NHAP |NONE

*RST Setting

 NONE

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:MS:REPorted:HBIT?"
! Queries the Last Happy Bit.

CALL:HSUPa:MS:REPorted:HBIT:RATio?

Function

Queries the Happy Bit Ratio .

Query

Range: 0.0 to 100.0 %, 9.91E+37

Resolution: 0.1 %

*RST Setting

 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:MS:REPorted:HBIT:RATio?"
! Queries the Happy Bit Ratio.

CALL:HSUPa:SERVice:PSData:EDPDchannel:CCODes:MAX

Function

Sets/queries PS Data E-DPDCH Max Channel Codes .

This setting is used to control the value for E-DPDCH Max Channelisation Codes that is signaled to the UE at the setup of a PDP Context that uses 10ms TTI or 2ms TTI on the E-DCH depending on the setting of "HSUPA TTI Mode." The default for this parameter is set to allow the maximum data throughput that is possible when using 10ms TTI. When using 2ms TTI, in order to get maximum data throughput, this parameter must be set to "2SF2+2SF4."The value "2SF2+2SF4" is only available when "UTRA FDD GPRS Service Radio Access Bearer" is setto "HSUPA UL/HSDPA DL PS" and "HSPA PS Data SRB Mapping Mode" is set to "E-DCH/DCH," which means SRBs are mapped onto E-DCH/DCH and no uplink DPDCH is configured.If "UTRA FDD GPRS Service Radio Access Bearer" is not set to "HSUPA UL/HSDPA DL PS," this parameter is ignored.

This setting can only be changed when the connection status is Idle.

Setting

Range:

  • SF256|SF128|SF64|SF32|SF16|SF8|SF4
  • TSF4 (2sf4)
  • TSF2 (2sf2)
  • T2T4 (2sf2+2sf4)

Query

 Same as setting.

*RST Setting

TSF2

Requirements

Lab Application Revision: U.00.13 and above

Lab Application Revision: E.01 and above, added T2T4

Programming Example

OUTPUT 714;"CALL:HSUPa:SERVice:PSData:EDPDchannel:CCODes:MAX TSF2"
! Sets the PS Data E-DPDCH Max Channel Codes to 2sf2.

CALL:HSUPa:SERVice:PSData:ERGChannel:INFormation[:STATe]

Function

Sets/queries PS Data E-RGCH Information State .

This setting can only be changed when the connection status is Idle.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

1 (ON)

Requirements

Lab Application Revision: U.00.13 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SERVice:PSData:ERGChannel:INFormation ON"
! Sets the RB Test Mode E-RGCH Information State to On.

CALL:HSUPa:SERVice:PSData:MACD:PDUSize

Function

Sets/queries PS Data MAC-d PDU Size.

This setting controls the size of the E-DCH MAC-d PDU that is to be used to configure the UE in signalling message during HSUPA PS Data call setup procedure.

Setting

Range: 336 to 5000 in increments of 8.

Query

 Same as setting

*RST Setting

 336

Requirements

Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SERVice:PSData:MACD:PDUSize 336"
! Sets PS Data MAC-d PDU Size to 336 Bits.

CALL:HSUPa:SERVice:RBTest:EDPDchannel:CCODes:MAX

Function

Sets/queries RB E-DPDCH Max Channel Codes (12.2k + HSPA) .

This setting can only be changed when the connection status is Idle.

Setting

Range:

  • SF256|SF128|SF64|SF32|SF16|SF8|SF4
  • TSF4 (2sf4)
  • TSF2 (2sf2)

Query

 Same as setting.

*RST Setting

TSF4

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SERVice:RBTest:EDPDchannel:CCODes:MAX TSF4"
! Sets the RB Test Mode E-DPDCH Max Channel Codes to 2sf4.

CALL:HSUPa:SERVice:RBTest:EDPDchannel:CCODes:MAX:HSPA

Function

Sets/queries RB Test Mode E-DPDCH Max Channelisation Codes (HSPA Only). This setting is used to control the value for E-DPDCH Max Channelisation Codes that is signaled to the UE at the setup of an RB Test Mode call when "UTRA FDD RB Test Mode Channel Type" is set to "HSPA Only." The default value for this parameter is set to match 3GPP TS 34.108 s9.2.If "UTRA FDD RB Test Mode Channel Type" is set to"12.2k RMC+HSPA," this parameter is ignored.

Setting

Range:

  • SF256|SF128|SF64|SF32|SF16|SF8|SF4
  • TSF4 (2sf4)
  • TSF2 (2sf2)
  • T2T4 (2sf2+2sf4)

Query

 Same as setting.

*RST Setting

T2T4

Requirements

Test Application Revision: A.13 and above, with the required feature license

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SERVice:RBTest:EDPDchannel:CCODes:MAX:HSPA T2T4"
! Sets the RB Test Mode E-DPDCH Max Channel Codes (HSPA Only) to 2sf2+2sf4.

CALL:HSUPa:SERVice:RBTest:ERGChannel:INFormation[:STATe]

Function

Sets/queries the RB Test Mode E-RGCH Information State .

This setting can only be changed when the connection status is Idle.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

0

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SERVice:RBTest:ERGChannel:INFormation OFF"
! Sets the RB Test Mode E-RGCH Information State to Off.

CALL:HSUPa:SERVice:RBTest:HARQ:RETRans:MAXimum

Function

Sets/queries the RB Test Mode E-DCH Maximum Number of HARQ Retransmissions.

This setting controls the maximum number of retransmissions a HARQ process in the UE will perform for a given block of data before giving up and moving onto a new block of data under an HSUPA RB test mode call. The default value was chosen to match both 3GPP TS 34.108 s9.1 and s9.2.Note: This parameter applies to two MAC-d flows when SRBs are mapped onto E-DCH/DCH.This setting is only available in the lab application (LA). In the test application (TA) this parameter is fixed to 7.

Setting

Range: 0 to 15

Resolution: 1

Query

 Same as setting

*RST Setting

7

Requirements

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SERVice:RBTest:HARQ:RETRans:MAXimum 7"
! Sets the RB Test Mode E-DCH Maximum Number of HARQ Retransmissions to 7.

CALL:HSUPa:SERVice:RBTest:RLCPdu:SIZE

Function

Sets/queries the E-DCH RLC PDU Size.

Setting

Range: BITS336|BITS112

Query

 Same as setting.

*RST Setting

BITS336

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SERVice:RBTest:RLCPdu:SIZE BITS336"
! Sets the E-DCH RLC PDU Size to 336.

CALL:HSUPa:SERVice:RBTest:RLCSdu:SIZE

Function

Sets/queries the RB E-DPDCH Max Channel Codes (HSPA) .

This setting can only be changed when the connection status is Idle.

Setting

Range: BITS2936|BITS5872|BITS8808|BITS11744|BITS14765|BITS29360|BITS35232

Query

 Same as setting.

*RST Setting

BITS2936

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SERVice:RBTest:RLCSdu:SIZE BITS2936"
! Sets the E-DCH RLC SDU Size to 2936.

CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue[1]

Function

 When the E-DCH TTI is 2 ms , the E-DCH 16QAM State is On and the BetaEd Gain E-AGCH Table Selection is set to 1, this command sets/queries the Absolute Grant Pattern - Value 1. This setting cannot be changed when AG Mode is set to Pattern .

Setting

Range: DTXA[1]|ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

ZGR

Requirements

Test Application Revision: A.17 and above, with the required feature license

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue ZGRant"
! Sets the Absolute Grant Pattern - Value 1 to ZERO_GRANT.

CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue2

Function

When the E-DCH TTI is 2 ms , the E-DCH 16QAM State is On and the BetaEd Gain E-AGCH Table Selection is set to 1, this command sets/queries the Absolute Grant Pattern - Value 2. .This setting cannot be changed when AG Mode is set to Pattern .

Setting

Range: DTXA[1]|ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

 IND31

Requirements

Test Application Revision: A.17.00 and above, with the required feature license

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue2 ZGRant"
! Sets the Absolute Grant Pattern - Value 2 to ZERO_GRANT.

CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue3

Function

When the E-DCH TTI is 2 ms , the E-DCH 16QAM State is On and the BetaEd Gain E-AGCH Table Selection is set to 1, this command sets/queries the Absolute Grant Pattern - Value 3 . This setting cannot be changed when AG Mode is set to Pattern .

Setting

Range: DTXA[1]|ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

 IND31

Requirements

Test Application Revision: A.17.00 and above, with the required feature license

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue3 INDex31"
! Sets the Absolute Grant Pattern - Value 3 to 31:4(377/15)^2.

CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue4

Function

When the E-DCH TTI is 2 ms , the E-DCH 16QAM State is On and the BetaEd Gain E-AGCH Table Selection is set to 1, this command sets/queries the Absolute Grant Pattern - Value 4. This setting cannot be changed when AG Mode is set to Pattern .

Setting

Range: DTXA[1]|ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

 IND31

Requirements

Test Application Revision: A.17.00 and above, with the required feature license

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue4 INDex31"
! Sets the Absolute Grant Pattern - Value 4 to 31:4(377/15)^2.

CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue5

Function

When the E-DCH TTI is 2 ms , the E-DCH 16QAM State is On and the BetaEd Gain E-AGCH Table Selection is set to 1, this command sets/queries the Absolute Grant Pattern - Value 5. This setting cannot be changed when AG Mode is set to Pattern .

Setting

Range: DTXA[1]|ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

 IND31

Requirements

Test Application Revision: A.17.00 and above, with the required feature license

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue5 INDex31"
! Sets the Absolute Grant Pattern - Value 5 to 31:4(377/15)^2.

CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue6

Function

When the E-DCH TTI is 2 ms , the E-DCH 16QAM State is On and the BetaEd Gain E-AGCH Table Selection is set to 1, this command sets/queries the Absolute Grant Pattern - Value 6. This setting cannot be changed when AG Mode is set to Pattern .

Setting

Range: DTXA[1]|ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

 IND31

Requirements

Test Application Revision: A.17.00 and above, with the required feature license

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue6 INDex31"
! Sets the Absolute Grant Pattern - Value 6 to 31:4(377/15)^2.

CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue7

Function

When the E-DCH TTI is 2 ms , the E-DCH 16QAM State is On and the BetaEd Gain E-AGCH Table Selection is set to 1, this command sets/queries the Absolute Grant Pattern - Value 7. This setting cannot be changed when AG Mode is set to Pattern .

Setting

Range: DTXA[1]|ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

 IND31

Requirements

Test Application Revision: A.17.00 and above, with the required feature license

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue7 INDex31"
! Sets the Absolute Grant Pattern - Value 7 to 31:4(377/15)^2.

CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue8

Function

When the E-DCH TTI is 2 ms , the E-DCH 16QAM State is On and the BetaEd Gain E-AGCH Table Selection is set to 1, this command sets/queries the Absolute Grant Pattern - Value 8. This setting cannot be changed when AG Mode is set to Pattern .

Setting

Range: DTXA[1]|ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

 IND31

Requirements

Test Application Revision: A.17.00 and above, with the required feature license

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:ALTernative:PATTern:VALue8 INDex31"
! Sets the Absolute Grant Pattern - Value 8 to 31:4(377/15)^2.

CALL:HSUPa:SGRant:ABSolute:ALTernative:SSHot[:VALue]

Function

Sets/queries the Single Shot AG .

Setting

Range: ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

IND31

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:ALTernative:SSHot INDex31"
! Sets the Single Shot Absolute Grant to 31:6(168/15)^2.

CALL:HSUPa:SGRant:ABSolute:MODE

Function

Sets/queries the AG Mode .

Setting

Range: SSHot|PATTern

Query

 Same as setting.

*RST Setting

SSH

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:MODE SSHot"
! Sets the AG Mode to Single Shot.

CALL:HSUPa:SGRant:ABSolute:PATTern:LENGth

Function

Sets/queries the Absolute Grant Pattern Length.

This setting controls the number of values in a pattern on the E-AGCH that are transmitted to the UE when CALL:HSUPa:SGRant:ABSolute:MODE is set to PATTern.

Setting

Range: 2 to 8

Resolution: 1

Query

 Same as setting

*RST Setting

2

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:PATTern:LENGth 2"
! Sets the Absolute Grant Pattern Length to 2.

CALL:HSUPa:SGRant:ABSolute:PATTern:VALue[1]

Function

Sets/queries the Absolute Grant Pattern - Length . This setting cannot be changed when AG Mode is set to Pattern .

Setting

Range: DTXA[1]|ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

ZGR

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:PATTern:VALue ZGRant"
! Sets the Absolute Grant Pattern - Value 1 to ZERO_GRANT.

CALL:HSUPa:SGRant:ABSolute:PATTern:VALue2

Function

Sets/queries the Absolute Grant Pattern - Value 2 (see Absolute Grant Pattern Values ). This setting cannot be changed when AG Mode is set to Pattern .

Setting

Range: DTXA[1]|ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

IND31

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:PATTern:VALue2 INDex31"
! Sets the Absolute Grant Pattern - Value 2 to 31:6(168/15)^2.

CALL:HSUPa:SGRant:ABSolute:PATTern:VALue3

Function

Sets/queries the Absolute Grant Pattern - Value 3. This setting cannot be changed when AG Mode is set to Pattern .

Setting

Range: DTXA[1]|ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

IND31

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:PATTern:VALue3 INDex31"
! Sets the Absolute Grant Pattern - Value 2 to 31:6(168/15)^2.

CALL:HSUPa:SGRant:ABSolute:PATTern:VALue4

Function

Sets/queries the Absolute Grant Pattern - Value 4. This setting cannot be changed when AG Mode is set to Pattern .

Setting

Range: DTXA[1]|ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

IND31

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:PATTern:VALue4 INDex31"
! Sets the Absolute Grant Pattern - Value 2 to 31:6(168/15)^2.

CALL:HSUPa:SGRant:ABSolute:PATTern:VALue5

Function

Sets/queries the Absolute Grant Pattern - Value 5. This setting cannot be changed when AG Mode is set to Pattern .

Setting

Range: DTXA[1]|ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

IND31

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:PATTern:VALue5 INDex31"
! Sets the Absolute Grant Pattern - Value 2 to 31:6(168/15)^2.

CALL:HSUPa:SGRant:ABSolute:PATTern:VALue6

Function

Sets/queries the Absolute Grant Pattern - Value 6. This setting cannot be changed when AG Mode is set to Pattern .

Setting

Range: DTXA[1]|ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

IND31

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:PATTern:VALue6 INDex31"
! Sets the Absolute Grant Pattern - Value 2 to 31:6(168/15)^2.

CALL:HSUPa:SGRant:ABSolute:PATTern:VALue7

Function

Sets/queries the Absolute Grant Pattern - Value 7. This setting cannot be changed when AG Mode is set to Pattern .

Setting

Range: DTXA[1]|ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

IND31

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:PATTern:VALue7 INDex31"
! Sets the Absolute Grant Pattern - Value 2 to 31:6(168/15)^2.

CALL:HSUPa:SGRant:ABSolute:PATTern:VALue8

Function

Sets/queries the Absolute Grant Pattern - Value 8. This setting cannot be changed when AG Mode is set to Pattern .

Setting

Range: DTXA[1]|ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

IND31

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:PATTern:VALue8 INDex31"
! Sets the Absolute Grant Pattern - Value 2 to 31:6(168/15)^2.

CALL:HSUPa:SGRant:ABSolute:RBSetup[:VALue]

Function

Sets/queries the RB Setup AG . This setting can only be changed when the connection status is idle.

Setting

Range: ZGRant|INDex0|INDex1|INDex2|INDex3...|INDex37|INDex38

Query

 Same as setting.

*RST Setting

IND37

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Lab Application Revision: G.01 and above: Added INDex38

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:RBSetup INDex37"
! Sets the RB Setup Absolute Grant to 37:6(168/15)^2.

CALL:HSUPa:SGRant:ABSolute:RBSetup:QAM16[:VALue]

Function

Sets/queries the RB Setuo AG (16QAM). This set of values is used when the E-DCH TTI is 2 ms and the E-DCH 16QAM State is set to On .

This setting can only be changed when the connection status is idle.

Setting

Range: ZGRant|INDex0|INDex1|INDex2|INDex3...|INDex38

Query

 Same as setting.

*RST Setting

IND37

Requirements

Test Application Revision: A.17.00 and above
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:RBSetup:QAM16 INDex37"
! Sets the RB Setup Absolute Grant (16QAM)to 37:4(377/15)^2.

CALL:HSUPa:SGRant:ABSolute:SSHot[:VALue]

Function

Sets/queries the Single Shot AG .

Setting

Range: ZGRant|INDex2|INDex3...|INDex31

Query

 Same as setting.

*RST Setting

IND31

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:SSHot INDex31"
! Sets the Single Shot Absolute Grant to 31:6(168/15)^2.

CALL:HSUPa:SGRant:ABSolute:SSHot:SEND[:IMMediate]

Function

 Initiates the Send Single Shot AG action.

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:ABSolute:SSHot:SEND"
! Send Single Shot AG.

CALL:HSUPa:SGRant:RELative:DOWN:SEND[:IMMediate]

Function

Initiates the Send Relative Grant Down action.

This action is rejected if RB Test Mode E-RGCH Information State is Off . A warning is posted if you initiate this action when HSPA Cell 1 Connected E-RGCH Level is Off .

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:RELative:DOWN:SEND"
! Send Relative Grant Down

CALL:HSUPa:SGRant:RELative:MODE

Function

Sets/queries the RG Mode .

Setting

Range: SSHot|PATTern

Query

 Same as setting.

*RST Setting

SSH

Requirements

Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:RELative:MODE SSHot"
! Sets the RG Mode to Single Shot.

CALL:HSUPa:SGRant:RELative:PATTern

Function

Sets/queries the Relative Grant Pattern.

Setting

Range: HOLD|UP|DOWN|D12H8 | D4Hold8

Query

 Same as setting.

*RST Setting

HOLD

Requirements

Lab Application Revision: G.00.00 and above
Lab Application Revision: G.01.00: Added D12H8
Lab Application Revision H.01.00 and above: Added D4Hold8

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:RELative:PATTern HOLD"
! Sets the RG Pattern to All Holds.

CALL:HSUPa:SGRant:RELative:PATTern:PERiodic[:STATe]

Function

Sets/queries the E-RGCH Pattern Periodic Transmission State. If set to On , the test set transmits a periodic sequence of values to the UE over the E-RGCH immediately. If set to Off , when an CALL:HSUPa:SGRant:RELative:PATTern:SEND[:IMMediate] action is performed, the test set transmits a sequence of values to the UE over the E-RGCH only once. The values that are transmitted to the UE are defined by RG Pattern

This setting is only applicable when the RG Mode is set to Pattern and the RG Pattern is set to 12 Downs + 8 Holds .

This setting can not be changed while the RG Mode is set to Pattern .

This setting is GPIB only.

Setting

Range: 1|On|0|Off

Query

Range: 1|0

*RST Setting

1 (On)

Requirements

Test Application Revision: A.17.00 and above
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:RELative:PATTern:PERiodic On"
! Sets the RG Pattern Periodic Transmission State to On.

CALL:HSUPa:SGRant:RELative:PATTern:SEND[:IMMediate]

Function

Transmit a finite sequence of values to the UE over the E-RGCH. The values that are transmitted to the UE are defined by RG Pattern .

This setting is only applicable when the RG Mode is set to Pattern , the RG Pattern is set to 12 Downs + 8 Holds and the CALL:HSUPa:SGRant:RELative:PATTern:PERiodic[:STATe] is set to Off.

This setting is only applicable when the E-DCH is active.

Requirements

Test Application Revision: A.17.00 and above
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:RELative:PATTern:SEND"

CALL:HSUPa:SGRant:RELative:QUEued:CLEar

Function

Initiates the Clear Queued Relative Grants action.

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:RELative:QUEued:CLEar"
! Clear Queued Relative Grants.

CALL:HSUPa:SGRant:RELative:UP:SEND[:IMMediate]

Function

Initiates the Send Relative Grant Up action.

This action is rejected if RB Test Mode E-RGCH Information State is Off . A warning is posted if you initiate this action when HSPA Cell 1 Connected E-RGCH Level is Off .

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SGRant:RELative:UP:SEND"
! Send Relative Grant Up.

CALL:HSUPa:SIPeriod:GRANt

Function

Sets/queries the Scheduling Information Periodicity (Grant) .

Setting

Range: NREPort | EETTi|MS4 | MS10 | MS20 | MS50 | MS100 | MS200 | MS500 | MS1000

Query

 Same as setting.

*RST Setting

NREPort

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SIPeriod:GRANt NREPort"
! Sets the Scheduling Information Periodicity (Grant) to NREPort.

CALL:HSUPa:SIPeriod:NGRant

Function

Sets/queries the Scheduling Information Periodicity (No Grant) .

Setting

Range: NREPort | EETTi|MS4 | MS10 | MS20 | MS50 | MS100 | MS200 | MS500 | MS1000

Query

 Same as setting.

*RST Setting

NREPort

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:HSUPa:SIPeriod:NGRant NREPort"
! Sets the Scheduling Information Periodicity (No Grant) to NREPort.


CALL:IDENtity

CALL:IDENtity

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL[:CELL]:IDENtity

CALL[:CELL]:IDENtity

Function

Sets/queries Cell Identity .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 0 to 268435455

Resolution: 1

Query

 Same as setting

*RST Setting

 1

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:IDENtity 3"
! Sets Cell Identity to 3 (0000 0000 0000 0000 0000 0000 0011).


CALL:LACode

CALL:LACode

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL[:CELL]:LACode[:SELected]
  • CALL[:CELL]:LACode:WCDMa

CALL[:CELL]:LACode[:SELected]

Function

Sets/queries the Local Area Code (LAC) , for the currently selected application.

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 0 to 65535

Query

Range: 0 to 65535

*RST Setting

 1
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL:LACODE 310" !Sets the local area code to 310.

CALL[:CELL]:LACode:WCDMa

Function

Sets/queries the Local Area Code (LAC) , when using the W-CDMA application.

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

WCDMa Range: 0 to 65535

Query

Range: 0 to 65535

*RST Setting

 1
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL:LACODE:WCDMA 310" !Sets the WCDMA local area code to 310.


CALL:LAUPdate

CALL:LAUPdate

Last updated: May 18, 2010

GPIB Command Conventions

  • CALL[:CELL]:LAUPdate:IGNore[:STATe]
  • CALL[:CELL]:LAUPdate:REJect[:STATe]
  • CALL[:CELL]:LAUPdate:REJect:CAUSe

CALL[:CELL]:LAUPdate:IGNore[:STATe]

Function

Sets/queries the Location Area Update Ignore State . While it is On, the test set will ignore any Location Updating request from the UE.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0
Requirements

Lab Application Revision: G.00.09 and above.

Programming Example

OUTPUT 714;" CALL:LAUPdate:IGNore 0"

CALL[:CELL]:LAUPdate:REJect[:STATe]

Function

Sets/queries the Location Area Update Reject State . While it is On, the test set will reject any Location Updating request from the UE.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:LAUPdate:REJect 0"

CALL[:CELL]:LAUPdate:REJect:CAUSe

Function

Sets/queries the Location Area Update Reject Cause .

Setting

Range: 0 to 255

Query

Range: 0 to 255

*RST Setting

 111 (Protocol error, unspecified)
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:LAUPdate:REJect:CAUSe 111"


CALL:MCCode

CALL:MCCode

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL[:CELL]:MCCode[:SELected]
  • CALL[:CELL]:MCCode:WCDMa

CALL[:CELL]:MCCode[:SELected]

Function

Sets/queries the Mobile Country Code (MCC) for the currently selected application.

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 0 to 999

Query

Range: 0 to 999

*RST Setting

 1
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL:MCCODE 310" !Sets the mobile country code to 310.

CALL[:CELL]:MCCode:WCDMa

Function

Sets/queries the Mobile Country Code (MCC) when using the W-CDMA application.

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 0 to 999

Query

Range: 0 to 999

*RST Setting

 1
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL:MCCODE:WCDMa 310" !Sets the W-CDMA mobile country code to 310.


CALL:MCELI

CALL:MCELI

Last updated: September 2, 2009

GPIB Command Conventions

  • CALL[:CELL]:MCELl:DISable
  • CALL[:CELL]:MCELl:ENABle

CALL[:CELL]:MCELl:DISable

Function

Disables the Multi-Cell UTRAN Mode.
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:MCELl:DISable"

CALL[:CELL]:MCELl:ENABle

Function

Enables the Multi-Cell UTRAN Mode.
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:MCELl:ENABle"


CALL:MNCode

CALL:MNCode

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL[:CELL]:MNCode
  • CALL[:CELL]:MNCode:LENGth
  • CALL[:CELL]:MNCode:WCDMa

CALL[:CELL]:MNCode

Function

Sets/queries the Mobile Network Code (MNC) for the currently selected application.

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 0 to 99

Query

Range: 0 to 99

*RST Setting

 1
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL:MNCODE 10" !Sets the current MNC setting to 10.

CALL[:CELL]:MNCode:LENGth

Function

Sets/queries the length of the Mobile Network Code. When set to AUTO the test set transmits the MNC using 2 digits if the MNC is less than or equal to 99. Otherwise, 3 digits are transmitted. When set to "3 Digits" the test set always transmits the MNC using 3 digits, prefixed with one or two zeros if necessary.

Setting

Range: AUTO|DIGits3

Query

Range: AUTO|DIGits3

*RST Setting

 AUTO

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:MNCode:LENGth AUTO"

CALL[:CELL]:MNCode:WCDMa

Function

Sets/queries the Mobile Network Code (MNC) , when using the W-CDMA application.

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 0 to 99

Query

Range: 0 to 99

*RST Setting

 1
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL:MNCODE:WCDMA 10" !Sets the WCDMA mobile network code to 10.


CALL:MS:DNSServer

CALL:MS:DNSServer

Last updated: November 25, 2010

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:MS:DNSServer:PRIMary:IP:ADDRess
  • CALL:MS:DNSServer:PRIMary:IP:ADDRess:IP6
  • CALL:MS:DNSServer:SECondary:IP:ADDRess

CALL:MS:DNSServer:PRIMary:IP:ADDRess

Function

Sets/queries the DUT Primary DNS Server IP Address .

Setting

Range: 0 to 15 characters formatted as A.B.C.D
The range of values for A = 0 to 126 and 128 to 223. The range of values for B, C, and D = 0 to 255.

Query

 Same as setting.

*RST Setting

Non-volatile

Requirements

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:MS:DNSServer:PRIMary:IP:ADDRess '130.255.255.255'"
! Sets the DUT Primary DNS Server IP Address to 130.255.255.255.

CALL:MS:DNSServer:PRIMary:IP:ADDRess:IP6

Function

Sets/queries the DUT IPv6 DNS Server Address .

Setting

Range: 0 to 45 characters of an valid IPv6 address, this can be a normal 39- character IPv6 address, a zero compression IPv6 address or a up to 45-character IPv4 address-compatible address (see IPv6 Address Requirements ). Ranges are from

  • "" (Null) or
  • 2000:0000:0000:0000:0000:0000:0000:0000 to 3FFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF or
  • FC00:0000:0000:0000:0000:0000:0000:0000 to FDFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF or
  • FE80:0000:0000:0000:0000:0000:0000:0000 to FEBF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF

Query

 Same as setting.

*RST Setting

"" (Null)

Requirements

 Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:MS:DNSServer:PRIMary:IP:ADDRess:IP6 'FE80:1111:2222:3333:4444:5555:6666:7777'"
! Sets the DUT Primary DNS Server IPv6 Address to 'FE80:1111:2222:3333:4444:5555:6666:7777'.

CALL:MS:DNSServer:SECondary:IP:ADDRess

Function

Sets/queries the DUT Secondary DNS Server IP Address .

Setting

Range: 0 to 15 characters formatted as A.B.C.D
The range of values for A = 0 to 126 and 128 to 223. The range of values for B, C, and D = 0 to 255.

Query

 Same as setting.

*RST Setting

Non-volatile

Requirements

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:MS:DNSServer:SECondary:IP:ADDRess '130.254.255.255'"
! Sets the DUT Primary DNS Server IP Address to 130.254.255.255.


CALL:MS:LOOPback

CALL:MS:LOOPback

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL:MS:LOOPback:TYPE

CALL:MS:LOOPback:TYPE

Function

Sets/queries the UE Loopback Type .

Setting

Range: TYPE1|TYPE2

Query

 Same as setting.

*RST Setting

 TYPE1

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:MS:LOOPback:TYPE TYPE2"
! Sets the MS Loopback Type to Type 2.


CALL:MS:POWer

CALL:MS:POWer

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL:MS:POWer:TARGet[: AMPLitude]?

CALL:MS:POWer:TARGet[: AMPLitude]?

Function

Sets/queries the expected power level from the UE (mobile station). See UE Target Power .

Query

Range: -61 dBm to +28 dBm

Resolution: 1 dB

*RST Setting

-5 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:MS:POWER:TARGET:AMPLITUDE -20"


CALL:MS:REPorted

Last updated: January 15, 2012

GPIB Command Conventions

  • CALL:MS:REPorted:AUTHenticate:FAILcause?

  • CALL:MS:REPorted[:CELL[1]]:ALL?
  • CALL:MS:REPorted[:CELL[1]]:CPICh:ECNO?
  • CALL:MS:REPorted[:CELL[1]]:CPICh:RSCP?
  • CALL:MS:REPorted[:CELL[1]]:PATHloss?
  • CALL:MS:REPorted[:CELL[1]]:DTCH:BLER?

  • CALL:MS:REPorted:CELL2:ALL?
  • CALL:MS:REPorted:CELL2:CPICh:ECNO?
  • CALL:MS:REPorted:CELL2:CPICh:RSCP?
  • CALL:MS:REPorted:CELL2:OTDifference[:VALue]?
  • CALL:MS:REPorted:CELL2:OTDifference:TYPE?
  • CALL:MS:REPorted:CELL2:PATHloss?

  • CALL:MS:REPorted:CLEar[:ALL]<[:SELected]|:WCDMa>

  • CALL:MS:REPorted:CONText:SESSion:MAXimum?

  • CALL:MS:REPorted:DOWNlink:RDDepth?

  • CALL:MS:REPorted:EISV?
  • CALL:MS:REPorted:EISV:SVN?

  • CALL:MS:REPorted:EUTRa:EARFcn?
  • CALL:MS:REPorted:EUTRa:CID?
  • CALL:MS:REPorted:EUTRa:RSRP?
  • CALL:MS:REPorted:EUTRa:RSRQ?
  • CALL:MS:REPorted:EUTRa:CELLs?
  • CALL:MS:REPorted:FREQuency[:SEParation]?

  • CALL:MS:REPorted:GSMSystem:BCHannel?
  • CALL:MS:REPorted:GSMSystem:BSIC:VALue?
  • CALL:MS:REPorted:GSMSystem:BSIC:VERification?
  • CALL:MS:REPorted:GSMSystem:CIDentity?
  • CALL:MS:REPorted:GSMSystem:CELLs?
  • CALL:MS:REPorted:GSMSystem:RSSI?

  • CALL:MS:REPorted:IMEI[:SELected]?

  • CALL:MS:REPorted:IMSI[:SELected]?

  • CALL:MS:REPorted:ITRFrequency:CELLs?
  • CALL:MS:REPorted:ITRFrequency:DOWNlink:CHANnel?
  • CALL:MS:REPorted:ITRFrequency:ECNO?
  • CALL:MS:REPorted:ITRFrequency:PATHloss?
  • CALL:MS:REPorted:ITRFrequency:RSCP?
  • CALL:MS:REPorted:ITRFrequency:RSSI?
  • CALL:MS:REPorted:ITRFrequency:SCODe?

  • CALL:MS:REPorted:MEASurement:ITAFrequency:STATe
  • CALL:MS:REPorted:MEASurement:OTDifference:TYPE
  • CALL:MS:REPorted:MEASurement:QUALity:STATe
  • CALL:MS:REPorted:MEASurement:REQuest
  • CALL:MS:REPorted:MEASurement:TYPe

  • CALL:MS:REPorted:ONUMber<[:SELected]|WCDMa>?

  • CALL:MS:REPorted:PCLass[:SELected]?

  • CALL:MS:REPorted:PRAChannel:SIGnature?
  • CALL:MS:REPorted:RINDicator?
  • CALL:MS:REPorted:TRANsmit:POWer?

CALL:MS:REPorted:AUTHenticate:FAILcause?

Function

Queries the UE Reported Failure Cause .

Query

Range: 1 to 255, 9.91E +37

*RST Setting

9.91E +37

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:AUTHenticate:FAILcause?"
!Queries the authentication fail cause.

CALL:MS:REPorted[:CELL[1]]:ALL?

Function

Queries the UE (mobile station) reported measurement results after a successful Measurement Request (see CALL:MS:REPorted:MEASurement:REQuest ). The measurement results returned include CPICH Ec/No, Pathloss and CPICH RSCP (see UE Reported Measurements for more descriptions).

After a successful Measurement Request, three comma separated results are returned in the order of CPICH Ec/No, Pathloss, and CPICH RSCP. See CALL:MS:REPorted[:CELL[1]]:CPICh:ECNO? , CALL:MS:REPorted[:CELL[1]]:PATHloss? , and CALL:MS:REPorted[:CELL[1]]:CPICh:RSCP? for more information.

To obtain DTCH BLER results, see CALL:MS:REPorted[:CELL[1]]:DTCH:BLER? .

Query

CPICH Ec/No:

  • Range: 0 to 49, 9.91E +37

Pathloss:

  • Range: 46 to 158 dB, 9.91E +37
  • Resolution: 1 dB

CPICH RSCP:

  • Range: 0 to 91, 9.91E +37

*RST Setting

9.91E +37
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:ALL?"

CALL:MS:REPorted[:CELL[1]]:CPICh:ECNO?

Function

Queries the UE (mobile station) reported CPICH Ec/No measurement result which is an index to a range of Ec/No values. See CPICH Ec/No for the mapping of this report value to actual Ec/No range.

Query

Range: 0 to 49, or 9.91 E+37

*RST Setting

9.91E +37
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:CPICh:ECNO?"

CALL:MS:REPorted[:CELL[1]]:CPICh:RSCP?

Function

Queries the UE (mobile station) reported CPICH RSCP measurement result which is an index to a range of RSCP values. See CPICH RSCP (Received Signal Code Power) for the mapping of this report value to actual RSCP range.

Query

Range: 0 to 91, or 9.91 E+37

*RST Setting

9.91E +37
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:CPICh:RSCP?"

CALL:MS:REPorted[:CELL[1]]:PATHloss?

Function

Queries the UE (mobile station) reported Pathloss measurement result in the unit of dB. See Pathloss for more details.

Query

Range: 46 to 158 dB, or 9.91 E+37

Resolution: 1 dB

*RST Setting

9.91E +37
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:PATHloss?"

CALL:MS:REPorted[:CELL[1]]:DTCH:BLER?

Function

Queries the UE (mobile station) reported DTCH BLER measurement result which is an index to a range of BLER values. See DTCH BLER (Block Error Ratio) Report for the mapping of this report value to actual BLER range.

Query

Range: 0 to 63, or 9.91 E+37

*RST Setting

9.91E +37
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:DTCH:BLER?"

CALL:MS:REPorted:CELL2:ALL?

Function

Queries the cell 2 UE (mobile station) reported measurement results after a successful Measurement Request (see CALL:MS:REPorted:MEASurement:REQuest ). The supported measurements include CPICH Ec/No, Pathloss and CPICH RSCP (see Cell 1/Cell 2 UE Reported Measurements for more information).

After a successful Measurement Request, three comma separated results are returned in the order of CPICH Ec/No, Pathloss, and CPICH RSCP. See CALL:MS:REPorted[:CELL[1]]:CPICh:ECNO? , CALL:MS:REPorted[:CELL[1]]:PATHloss? , and CALL:MS:REPorted[:CELL[1]]:CPICh:RSCP? for more information.

To obtain DTCH BLER results, see CALL:MS:REPorted[:CELL[1]]:DTCH:BLER? .

Query

CPICH Ec/No:

  • Range: 0 to 49, 9.91E +37

Pathloss:

  • Range: 46 to 158 dB, 9.91E +37
  • Resolution: 1 dB

CPICH RSCP:

  • Range: 0 to 91, 9.91E +37

*RST Setting

9.91E +37
Requirements Lab Application Revision: A.01 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:CELL2:ALL?"

CALL:MS:REPorted:CELL2:CPICh:ECNO?

Function

Queries the cell 2 UE (mobile station) reported CPICH Ec/No measurement result which is an index to a range of Ec/No values. See CPICH Ec/No for the mapping of this report value to actual Ec/No range.

Query

Range: 0 to 49, 9.91E +37

*RST Setting

9.91E +37
Requirements Lab Application Revision: A.01 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:CELL2:CPICh:ECNO?"

CALL:MS:REPorted:CELL2:CPICh:RSCP?

Function

Queries the cell 2 UE (mobile station) reported CPICH RSCP measurement result which is an index to a range of RSCP values. See CPICH RSCP (Received Signal Code Power) for the mapping of this report value to actual RSCP range.

Query

Range: 0 to 91, 9.91E +37

*RST Setting

9.91E +37
Requirements Lab Application Revision: A.01 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:CELL2:CPICh:RSCP?"

CALL:MS:REPorted:CELL2:OTDifference[:VALue]?

Function

Queries the UE reported SFN-SFN Observed Time Difference (OTD) measurement result. The type of OTD measurement performed by the UE can be queried using the CALL:MS:REPorted:CELL2:OTDifference:TYPE? command.

Query

Range: 0 to 9830399 chips, 9.91E +37

Resolution: 1 chip

*RST Setting

9.91E +37
Requirements Lab Application Revision: C.01 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:CELL2:OTDifference?"

CALL:MS:REPorted:CELL2:OTDifference:TYPE?

Function

Queries the type of SFN-SFN Observed Time Difference (OTD) measurement performed by the UE. The UE reported OTD measurement result can be queried using the CALL:MS:REPorted:CELL2:OTDifference[:VALue]? command.

Query

Range: NONE|TYPE1|TYPE2

*RST Setting

NONE
Requirements Lab Application Revision: C.01 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:CELL2:OTDifference:TYPE?"

CALL:MS:REPorted:CELL2:PATHloss?

Function

Queries the cell 2 UE reported Pathloss measurement result.

Query

Range: 46 to 158 dB, 9.91E +37

Resolution: 1 dB

*RST Setting

9.91E +37
Requirements Lab Application Revision: A.01 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:CELL2:PATHloss?"

CALL:MS:REPorted:CLEar[:ALL]<[:SELected]|:WCDMa>

Function

Clears the UE (mobile) reported information. See Clear UE Info .
Requirements

Test Application Revision: A.04 and above

Lab Application Revision: A.02 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:CLEar"

CALL:MS:REPorted:CONText:SESSion:MAXimum?

Function

Queries the UE Reported Max Context Session.

This result is extracted from the "PDCP Capability" IE in the RRC Connection Setup Complete message. If the UE did not report this, NaN is returned. This value is used to determine the MAX_CID parameter for both uplink and downlink that will be used to configure the UE.

Query

Range: 1 to 16383, 9.91E +37

*RST Setting

9.91E +37

Requirements Lab Application Revision: F.00.19 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:CONText:SESSion:MAXimum?"
!Queries the UE Reported Max Context Session.

CALL:MS:REPorted:DOWNlink:RDDepth?

Function

Queries the UE Reported Downlink Reverse Decompression Depth.

This result is extracted from the "PDCP Capability" IE in the RRC Connection Setup Complete message. If the UE did not report this, NaN is returned.

Query

Range: 0 to 65535, 9.91E +37

*RST Setting

9.91E +37

Requirements Lab Application Revision: F.00.19 and above

Programming Example

 OUTPUT 714;"ALL:MS:REPorted:DOWNlink:RDDepth?"
!Queries the UE Reported Downlink Reverse Decompression Depth.

CALL:MS:REPorted:EISV?

Function

Queries the International Mobile station Equipment Identity and Software Version number (IMEISV) reported by the UE. This result is not available when CALL[:CELL]:EIDentity:REQuest] is set to "IMEI". The IMEISV is composed of the following elements:

- Type Allocation Code (TAC). Its length is 8 digits;- Serial Number (SNR) is an individual serial number uniquely identifying each equipment within each TAC. Its length is 6 digits;- Software Version Number (SVN) identifies the software version number of the mobile equipment. Its length is 2 digits.

Query

Range: 0 to FFFFFFFFFFFFFFFF (16 chars, '0'-'9', 'A'-'F' in each char), No Results Available

*RST Setting

No Results Available
Requirements

Lab Application Revision: E.00.34 and above.

Test Application Revision: A.13 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:EISV?"

CALL:MS:REPorted:EISV:SVN?

Function

Queries only the Software Version Number (SVN) element of the IMEISV reported by the UE. The SVN identifies the software version number of the mobile equipment. Its length is 2 digits.

This result is not available when CALL[:CELL]:EIDentity:REQuest] is set to "IMEI".

Query

Range: 0 to FF (2 chars, '0'-'9', 'A'-'F' in each char), No Results Available

*RST Setting

No Results Available
Requirements

Lab Application Revision: E.00.34 and above.

Test Application Revision: A.13 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:EISV:SVN?"

CALL:MS:REPorted:EUTRa:EARFcn?

Function

Queries the UE Reported EARFCN for E-UTRA Cells 1 to 8.

This result returns the first 8 cells that are present in the measurement report.

Query

Range: 0 to 65535

*RST Setting

No Results Available
Requirements Lab Application Revision: H.01.00 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:EUTRa:EARFcn?"

CALL:MS:REPorted:EUTRa:CID?

Function

Queries the UE Reported Cell ID for E-UTRA Cells 1 to 8.

This result is for the first 8 cells that are present in the measurement report.

Query

Range: 0 to 503
Requirements Lab Application Revision: H.01.00 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:EUTRa:CID?"

CALL:MS:REPorted:EUTRa:RSRP?

Function

Queries the UE Reported RSRP for E-UTRA Cells 1 to 8.

This result is for the first 8 cells that are present in the measurement report.

Query

Range: 0 to 97
Requirements Lab Application Revision: H.01.00 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:EUTRa:RSRP?"

CALL:MS:REPorted:EUTRa:RSRQ?

Function

Queries the UE Reported RSRQ for E-UTRA Cells 1 to 8.

This result is for the first 8 cells that are present in the measurement report.

Query

Range: 0 to 33
Requirements Lab Application Revision: H.01.00 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:EUTRa:RSRQ?"

CALL:MS:REPorted:EUTRa:CELLs?

Function

Queries the Total Number of E-UTRA Cells Reported by the UE.

This result returns the total number of E-UTRA cells that the UE included in its Measurement Result

Query

Range: 0 to 8
Requirements Lab Application Revision: H.01.00 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:EUTRa:CELLs?"

CALL:MS:REPorted:FREQuency[:SEParation]?

Function

Queries the "Band A" transmit/receive frequency separation. The specified frequencies are as follows: 190 MHz (MHZ190, fixed frequency separation), 174.8 to 205.2 MHz (MHZV205, variable frequency separation within this range), 134 to 245.2 MHz (MHZV245, variable frequency separation within this range).

Query

Range: MHZ190|MHZV205|MHZV245|NONE

*RST Setting

NONE
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:FREQuency?"

CALL:MS:REPorted:GSMSystem:BCHannel?

Function

Queries the BCH ARFCN result reported by the UE (for up to 8 GSM cells). Note that the cells are reported by the UE in order of RSSI strength. Use the CALL:MS:REPorted:GSMSystem:CIDentity? query to determine the Inter-RAT Cell ID for each of the reported cells.

Query

Range: 0 to 1023, 9.91E+37

Resolution: 1

*RST Setting

9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements

Lab Application Revision: B.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:GSMSystem:BCHannel?"

CALL:MS:REPorted:GSMSystem:BSIC:VALue?

Function

Queries the BSIC Value corresponding to the Inter-RAT Cell ID reported by the UE (for up to 8 GSM cells). Note that the cells are reported by the UE in order of RSSI strength. Use the CALL:MS:REPorted:GSMSystem:CIDentity? query to determine the Inter-RAT Cell ID for each of the reported cells.

Query

Range: 0 to 77, 9.91E+37

*RST Setting

9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements Lab Application Revision: D.00.04 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:GSMSystem:BSIC:VALue?"

CALL:MS:REPorted:GSMSystem:BSIC:VERification?

Function

Queries the BSIC Verification result reported by the UE (for up to 8 GSM cells). Note that the cells are reported by the UE in order of RSSI strength. Use the CALL:MS:REPorted:GSMSystem:CIDentity? query to determine the Inter-RAT Cell ID for each of the reported cells.

Query

Range:

  • VER - Verified
  • NVER - Not Verified
  • NREP - the cell was not measured by the UE

*RST Setting

NREP,NREP,NREP,NREP,NREP,NREP,NREP,NREP
Requirements Lab Application Revision: D.00.04 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:GSMSystem:BSIC:VERification?"

CALL:MS:REPorted:GSMSystem:CIDentity?

Function

GSM neighbor cells are reported by the UE in order of RSSI strength. This query returns the Inter-RAT Cell ID for each of the cells reported by the UE, to allow you to map the UE reported results to the SIB11 GSM cell info list neighbor cells.

Query

Range: 1 to 8, 9.91E+37

Resolution: 1

*RST Setting

9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements Lab Application Revision: D.00.04 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:GSMSystem:CIDentity?"

CALL:MS:REPorted:GSMSystem:CELLs?

Function

Queries the UE reported Total Number of GSM Cells .

Query

Range: 0 to 8

Resolution: 1

*RST Setting

0
Requirements

Lab Application Revision: B.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:GSMSystem:CELLs?"

CALL:MS:REPorted:GSMSystem:RSSI?

Function

Queries the RSSI (GSM Cells) result reported by the UE (for up to 8 GSM cells). Note that the cells are reported by the UE in order of RSSI strength. Use the CALL:MS:REPorted:GSMSystem:CIDentity? query to determine the cell ID for each of the reported cells.

Query

Range: 0 to 63, 9.91E+37

Resolution: 1

*RST Setting

9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements

Lab Application Revision: B.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:GSMSystem:RSSI?"

CALL:MS:REPorted:IMEI[:SELected]?

Function

Queries the mobile reported IMEI .

Query

Range: "0" to "FFFFFFFFFFFFFF" (0 to 15 characters from the set 0123456789ABCDEF) or "" (null string)

*RST Setting

"" (null string)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:IMEI?"

CALL:MS:REPorted:IMSI[:SELected]?

Function

Queries the mobile reported IMSI .

Query

Range: "0" to "FFFFFFFFFFFFFF" (0 to 15 characters from the set 0123456789ABCDEF) or "" (null string)

*RST Setting

"" (null string)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:IMSI?"

CALL:MS:REPorted:ITRFrequency:CELLs?

Function

Queries the mobile reported total number of inter frequency cells (see Inter-Frequency Neighbor Cell Measurement Results ).

Query

Range: 0 to 32

Resolution: 1

*RST Setting

0
Requirements

Lab Application Revision: B.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:ITRFrequency:CELLs?"

CALL:MS:REPorted:ITRFrequency:DOWNlink:CHANnel?

Function

Queries the mobile reported DL channel for inter frequency cells 1-8 (see Inter-Frequency Neighbor Cell Measurement Results ).

Query

Range: 0 to 16383, 9.91E+37

Resolution: 1

*RST Setting

9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements

Lab Application Revision: B.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:ITRFrequency:DOWNlink:CHANnel?"

CALL:MS:REPorted:ITRFrequency:ECNO?

Function

Queries the mobile reported Ec/No for inter frequency cells 1-8 (see Inter-Frequency Neighbor Cell Measurement Results ).

Query

Range: 0 to 49, 9.91E+37

Resolution: 1

*RST Setting

9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements

Lab Application Revision: B.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:ITRFrequency:ECNO?"

CALL:MS:REPorted:ITRFrequency:PATHloss?

Function

Queries the mobile reported pathloss for inter frequency cells 1-8 (see Inter-Frequency Neighbor Cell Measurement Results ).

Query

Range: 46 to 158 dB, 9.91E+37

Resolution: 1 dB

*RST Setting

9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements

Lab Application Revision: B.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:ITRFrequency:PATHloss?"

CALL:MS:REPorted:ITRFrequency:RSCP?

Function

Queries the mobile reported RSCP for inter frequency cells 1-8 (see Inter-Frequency Neighbor Cell Measurement Results ).

Query

Range: 0 to 91, 9.91E+37

Resolution: 1

*RST Setting

9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements

Lab Application Revision: B.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:ITRFrequency:RSCP?"

CALL:MS:REPorted:ITRFrequency:RSSI?

Function

Queries the mobile reported RSSI for inter frequency cells 1-8 (see Inter-Frequency Neighbor Cell Measurement Results ).

Query

Range: 0 to 76, 9.91E+37

Resolution: 1

*RST Setting

9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements

Lab Application Revision: B.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:ITRFrequency:RSSI?"

CALL:MS:REPorted:ITRFrequency:SCODe?

Function

Queries the mobile reported scrambling code for inter frequency cells 1-8 (see Inter-Frequency Neighbor Cell Measurement Results ).

Query

Range: 0 to 511, 9.91E+37

Resolution: 1

*RST Setting

9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37,9.91E+37
Requirements

Lab Application Revision: B.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:ITRFrequency:SCODe?"

CALL:MS:REPorted:MEASurement:INTernal:STATe

Function

Sets/queries the UTRA FDD UE Internal Measurement State.

This setting controls whether the UE internal measurement is requested from the UE the next time that the Send Measurement Request action is invoked.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: F.00.19 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:MEASurement:INTernal:STATe 0"
! Sets UTRA FDD UE Internal Measurement State to off.

CALL:MS:REPorted:MEASurement:ITAFrequency:STATe

Function

Sets/queries UTRA FDD Intra-frequency Measurement State.

This setting controls whether the intra-frequency measurement is requested from the UE the next time that the Send Measurement Request action is invoked.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (on)

Requirements

Lab Application Revision: F.00.19 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:MEASurement:ITAFrequency:STATe 1"
! Sets UTRA FDD Intra-frequency Measurement State to on.

CALL:MS:REPorted:MEASurement:OTDifference:TYPE

Function

Sets/queries the SFN-SFN OTD Measurement Type performed by the UE when the CALL:MS:REPorted:MEASurement:REQuest command is sent.

Setting | Range: NONE|TYPE1|TYPE2
Query | Same as setting.
*RST Setting | NONE
Requirements

Lab Application Revision: C.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:MEASurement:OTDifference:TYPE TYPE2"
! Sets SFN-SFN OTD Measurement Type to Type 2.

CALL:MS:REPorted:MEASurement:QUALity:STATe

Function

Sets/queries UTRA FDD Quality Measurement State.

This setting controls whether the quality measurement is requested from the UE the next time that the Send Measurement Request action is invoked.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: F.00.19 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:MEASurement:QUALity:STATe 0"
! Sets UTRA FDD Quality Measurement State to off.

CALL:MS:REPorted:MEASurement:REQuest

Function

Sends a Measurement Control message, which orders the UE to perform measurements on cell 1 (and cell 2 if you are using the lab application). Which measurements are performed by the UE is determined by the CALL:MS:REPorted:MEASurement:TYPe and CALL:MS:REPorted:MEASurement:OTDifference:TYPE commands.
See Cell 1/Cell 2 UE Reported Measurements .

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:MEASurement:REQuest"

CALL:MS:REPorted:MEASurement:TYPe

Function

Sets/queries the Report Measurement Type , which determines which measurements are performed by the UE when the CALL:MS:REPorted:MEASurement:REQuest command is sent.
Setting

Range: ALL|INTRAFREQ|QUAL

Query

Same as setting.

*RST Setting

INTRAFREQ
Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:MEASurement:TYPe ALL"

CALL:MS:REPorted:ONUMber<[:SELected]|WCDMa>?

Function

Queries the Called Party Number .

Query

Range: 0 to 20 characters enclosed by double quotes, from the set 0123456789.*# or "Emergency Call" or "" (null string).

*RST Setting

"" (null string)
Requirements

Lab Application Revision: C.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:ONUMber?"

CALL:MS:REPorted:PCLass[:SELected]?

Function

Queries the mobile reported Power Class .

Query

Range: 1, 2, 3, 4, 9.91E+37

*RST Setting

9.91E+37
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:PCLass?"

CALL:MS:REPorted:PRAChannel:SIGnature?

Function

Queries the Detected PRACH Signature .

Query

Range: 0 to 15, 9.91E+37

*RST Setting

9.91E+37

Requirements Lab Application Revision: A.02 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:PRAChannel:SIGnature?"

CALL:MS:REPorted:RINDicator?

Function

Queries the UE Reported Release Indicator.

During RRC Connection Setup procedure, the release 4 or later release UE can report the release number via message RRCConnectionRequest. UE can also report this indicator via message UECapabilityInformation.

Query

REL4 | REL5 | REL6 | REL7 | REL8 | 9.91E+37 (NAN)
Requirements Lab Application Revision H.01.00 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:RINDicator?"

CALL:MS:REPorted:TRANsmit:POWer?

Function

Queries the UTRA FDD UE Transmitted Power as an index.

The mapping of the reported value to actual UE transmission power range is provided in 3GPP TS 25.133 V7.d.0 section 9.1.6.2, "UE transmitted power measurement report mapping".

Query

Range: 0 to 104

Requirements Lab Application Revision: F.00.19 and above

Programming Example

 OUTPUT 714;"CALL:MS:REPorted:TRANsmit:POWer?"
!Queries the the UTRA FDD UE Transmitted Power.


CALL:NITZone

CALL:NITZone

Last updated: May 25, 2009

GPIB Command Conventions

  • CALL[:CELL]:NITZone:DSTime[:HOURs][:SVALue][:SELected]
  • CALL[:CELL]:NITZone:DSTime[:HOURs]:STATe[:SELected]
  • CALL[:CELL]:NITZone:DSTime[:HOURs]:VALue[:SELected]

  • CALL[:CELL]:NITZone:SEND[:IMMediate]

  • CALL[:CELL]:NITZone:SEND:CS:ORiGination[:STATe][:SELected]
  • CALL[:CELL]:NITZone:SEND:CS:REGistration[:STATe][:SELected]

  • CALL[:CELL]:NITZone:SEND:DOMain[:PRIority][:SELected]

  • CALL[:CELL]:NITZone:SEND:PS:ORIGination[:STATe][:SELected]
  • CALL[:CELL]:NITZone:SEND:PS:REGistration[:STATe][:SELected]

  • CALL[:CELL]:NITZone:TZONe[:LOCal][:SELected]

  • CALL[:CELL]:NITZone:UTIMe:DATE[:SELected]
  • CALL[:CELL]:NITZone:UTIMe:TIME[:SELected]
  • CALL[:CELL]:NITZone:UTIMe:UTC[:IMMediate]

CALL[:CELL]:NITZone:DSTime[:HOURs][:SVALue][:SELected]

Function

Sets/queries NITZ Daylight Saving Time , and sets its state to ON.

Setting

Range: 0 to 2

Query

 Range: 0 to 2

*RST Setting

0

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:NITZone:DSTIme 0"
!Sets the NITZ daylight saving time to 0 hours and turns it on.

CALL[:CELL]:NITZone:DSTime[:HOURs]:STATe[:SELected]

Function

Sets/queries NITZ Daylight Saving Time Include State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

OFF

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:NITZone:DSTIme:STATe 0"
!Sets the Network Daylight Saving Time Information Element not to be included
!in the GMM or MM information message.

CALL[:CELL]:NITZone:DSTime[:HOURs]:VALue[:SELected]

Function

Sets/queries NITZ Daylight Saving Time .

Setting

Range: 0 to 2

Query

 Range: 0 to 2

*RST Setting

0

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:NITZone:DSTIme:VALue 0"
!Sets the Daylight Saving Time value to 0 hours.

CALL[:CELL]:NITZone:SEND[:IMMediate]

Function

This setting forces the Network Identity and Time Zone (NITZ) Information to be immediately sent to the UE depending on the call state. Valid call states for this action are Connected, PDP Active, or simultaneous Connected/PDP Active.

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:NITZone:SEND"
!Forces the NITZ Information to be immediately sent to the UE depending on call state.

CALL[:CELL]:NITZone:SEND:CS:ORiGination[:STATe][:SELected]

Function

Sets/queries NITZ Send on CS Call Origination .

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

OFF

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:NITZone:SEND:CS:ORIGination OFF"
!Turns off NITZ Send on CS Call Origination.

CALL[:CELL]:NITZone:SEND:CS:REGistration[:STATe][:SELected]

Function

Sets/queries NITZ Send on CS Registration .

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

OFF

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:NITZone:SEND:CS:REGistration OFF"
!Turns Off NITZ Send on CS Registration.

CALL[:CELL]:NITZone:SEND:DOMain[:PRIority][:SELected]

Function

Sets/queries NITZ Send Immediate Domain Priority .

Setting

Range: CS|PS

CS: MM Info
PS: GMM Info

Query

Range: CS|PS

CS: MM Info
PS: GMM Info

*RST Setting

 PS

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:NITZone:SEND:DOMain PS"
!Sets the NITZ information to be sent in a GMM Info message when the call state
!is both Connected and PDP Active simultaneously.

CALL[:CELL]:NITZone:SEND:PS:ORIGination[:STATe][:SELected]

Function

Sets/queries NITZ Send on PS Call Origination .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

OFF

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:NITZone:SEND:PS:ORIGination OFF"
!Turns Off NITZ Send on PS Call Origination.

CALL[:CELL]:NITZone:SEND:PS:REGistration[:STATe][:SELected]

Function

Sets/queries NITZ Send on PS Registration .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

OFF

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:NITZone:SEND:PS:REGistration ON"
!Turns Off NITZ Send on Packet Switched Registration.

CALL[:CELL]:NITZone:TZONe[:LOCal][:SELected]

Function

Sets/queries NITZ Local Time Zone .

Setting

Range: +17,+45 to -19,-45

  • <hour> -19 to 0
  • <minute> -59 to 0

or

  • <hour> 0 to 17
  • <minute> 0 to 59

Query

Range: +17,+45 to -19,-45

  • <hour> -19 to 0
  • <minute> -59 to 0

or

  • <hour> 0 to 17
  • <minute> 0 to 59

*RST Setting

00,00

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:NITZone:TZONe 7,59"
!Sets the NITZ local time zone to 8 hours and 0 minutes,
!as the boundary is rounded to the nearest 15 minutes.

OUTPUT 714;"CALL:NITZone:TZONe?"
!Returns "+8,+0" if time zone has been set to 8 hours.

CALL[:CELL]:NITZone:UTIMe:DATE[:SELected]

Function

Sets/queries NITZ Universal Time - Date .

NOTE: The MM and GMM messages use semi-octet and BCD representation to carry two digits for each field (year, month, day). Thus, though not specifically called out, it is assumed that the two digits for year are appended to "20" to yield years 2000 - 2099. The message to the UE would include only the right two digits of the year and would exclude "20".This setting is included in the Universal time and local time zone IE.

Setting

Range: "2000,01,01" to "2099,12,31"

Query

Range: "2000,01,01" to "2099,12,31"

*RST Setting

"2008,01,01"

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:NITZone:UTIMe:DATE `2008,03,18'"
!Sets the NITZ Universal Time - Date to 18th March 2008.

CALL[:CELL]:NITZone:UTIMe:TIME[:SELected]

Function

Sets/queries NITZ Universal Time - Time .

Setting

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

The resolution of local time setting is minutes. A number within the parameter range must be entered for <second> but it will not affect the minute setting.

Query

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

  • The resolution of the local time setting is minutes. The value returned for <second> will not provide useful information.

*RST Setting

13,00,00

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:NITZone:UTIMe:TIME 7,30,0"
!Sets the NITZ universal time to 7:30.

OUTPUT 714;"CALL:NITZone:UTIMe:TIME?"
!Returns "+7,+30,+0" if NITZ universal time has been set to 7:30.

CALL[:CELL]:NITZone:UTIMe:UTC[:IMMediate]

Function

Sets the Network Identity and Time Zone (NITZ) Universal Time and Date to the Universal Coordinated Time and Date as found on the test set's System Configuration screen. This is provided as a convenience for setting the NITZ time and date.

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:NITZone:UTIMe:UTC"
!Sets the NITZ Universal Time and Date to the Universal Coordinated Time and Date.


CALL:NMOPeration

CALL:NMOPeration

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL[:CELL]:NMOPeration

CALL[:CELL]:NMOPeration

Function

Sets/queries Network Mode of Operation .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 1, 2

Query

 Same as setting.

*RST Setting

1

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:NMOPeration 2"
! Sets Network Mode of Operation to 2.


CALL:OCNSource

CALL:OCNSource

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL[:CELL]:OCNSource:CCODe:CODE
  • CALL[:CELL]:OCNSource:CCODe:CODE:HSDPa
  • CALL[:CELL]:OCNSource:CONFig:STATe:HSDPa
  • CALL[:CELL[1]]:OCNSource:LEVel([:SELected]|:FDD)?
  • CALL[:CELL]:OCNSource:POFFset:HSDPa
  • CALL[:CELL[1]]:OCNSource:STATe([:SELected]|:FDD)?

CALL[:CELL]:OCNSource:CCODe:CODE

Function

Sets/queries the Channelization codes for WCDMA orthogonal channel noise simulator (OCNS) 1 to 16.

This setting cannot be changed while in active cell operating mode (when available). Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 1 to 127

Query

Range: 1 to 127

*RST Setting

 2, 11, 17, 23, 31, 38, 47, 55, 62, 69, 78, 85, 94, 125, 113, 119

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:OCNSource:CCODe:CODE 2, 11, 17, 23, 31, 38, 47, 55, 62, 69, 78, 85, 94, 125, 113, 119"

CALL[:CELL]:OCNSource:CCODe:CODE:HSDPa

Function

Sets/queries the Channelization codes of HSDPA orthogonal channel noise simulator (OCNS) 1 to 6.

This setting cannot be changed while in active cell operating mode (when available). Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 1 to 127

Query

Range: 1 to 127

*RST Setting

 122, 123, 124, 125, 126, 127

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:OCNSource:CCODe:CODE:HSDPa 122, 123, 124, 125, 126, 127"

CALL[:CELL]:OCNSource:CONFig:STATe:HSDPa

Function

Sets/queries the HSDPA/HSPA OCNS 1 to 6 Channel Configuration States.

Setting

 Range: 1|ON|0|OFF

Query

Range: 0|1

*RST Setting

 1 (ON), 1 (ON), 1 (ON), 1 (ON), 1 (ON), 1 (ON)
Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:OCNSource:CONFig:STATe:HSDPa 1, 1, 1, 1, 1, 1"

CALL[:CELL[1]]:OCNSource:LEVel([:SELected]|:FDD)?

Function

Queries the calculated ( Desired ) level of the UTRA FDD composite orthogonal channel noise simulator (OCNS).

The optional [:SELected] keyword in this command specifies that the OCNS channel level being queried applies to the current system type.

The OCNS level is a calculated value used to balance the relative power levels of the following channels to sum to 100%:

  • OCNS
  • Common Pilot Channel (CPICH)
  • Primary Common Control Physical Channel (P-CCPCH
  • Synchronization Channel (SCH)
  • Page Indicator Channel (PICH)
  • Dedicated Physical Channel (DPCH)

If the contribution of OCNS is calculated to be -30 dB or less, the OCNS state is turned off.

See Orthogonal Channel Noise Simulator (OCNS) .

Query

Range: 0 to -29 dB, 9.91 E+37, -9.9E+37 (returned if no power is being placed into the OCNS channels)

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:OCNSOURCE:LEVEL?" !Queries the calculated OCNS level.

CALL[:CELL]:OCNSource:POFFset:HSDPa

Function

Sets/queries the HSDPA/HSPA orthogonal channel noise simulator (OCNS) 1 to 6 Power Offsets (raletive levels).

Query

Range: 0 to -20 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 0 dB

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"CALL:OCNSource:POFFset:HSDPa 0, 0, 0, 0, 0, 0"

CALL[:CELL[1]]:OCNSource:STATe([:SELected]|:FDD)?

Function

Queries the on/off state of the calculated UTRA FDD composite orthogonal channel noise simulator (OCNS).

The optional [:SELected] keyword in this command specifies that the OCNS state being queried applies to the current system type.

The OCNS level is a calculated value used to balance the relative power levels of the following channels to sum to 100%:

  • OCNS
  • Common Pilot Channel (CPICH)
  • Primary Common Control Physical Channel (P-CCPCH
  • Synchronization Channel (SCH)
  • Page Indicator Channel (PICH)
  • Dedicated Physical Channel (DPCH)

If the contribution of OCNS is calculated to be -30 dB or less, the OCNS state is turned off.

See Orthogonal Channel Noise Simulator (OCNS) .

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:OCNSOURCE:STATE?"


CALL:OPERating

CALL:OPERating

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL[:CELL]:OPERating:MODE

CALL[:CELL]:OPERating:MODE

Function

Sets/queries the operating mode of the base station emulator. If a call is in progress during a change in operating mode it will be dropped.

Setting

 Range:
Active Cell Mode = CALLUTRA FDD Test Mode = FDDTestCW Mode = CWCell Off Mode = OFF

Query

Range: CALL|CW|FDDT|OFF

*RST Setting

 CALL

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:OPERATING:MODE FDDTEST" !Selects UTRA FDD test mode.


CALL:ORIGinate

CALL:ORIGinate

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL:ORIGinate[:AUTO]
  • CALL:ORIGinate:AMR
  • CALL:ORIGinate:DONE?
  • CALL:ORIGinate:OPComplete?
  • CALL:ORIGinate:PSData
  • CALL:ORIGinate:SEQuential
  • CALL:ORIGinate:WAIT

CALL:ORIGinate[:AUTO]

Function

Generates a page attempt to the mobile station based on the Paging Service parameter setting. See Test Set-Originated Connection .

If the call attempt fails, the test set will return to the idle call processing state.

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Lab Application Revision U.00.13 adds the optional AUTO mnemonic.

Programming Example

OUTPUT 714;"CALL:ORIGinate" !pages the mobile station

CALL:ORIGinate:AMR

Function

Generates a AMR voice page attempt to the mobile station regardless of the Paging Service parameter setting. See Test Set-Originated Connection .

If the call attempt fails, the test set will return to the idle call processing state.

Requirements

Lab Application Revision: U.00.13 and above.

Programming Example

OUTPUT 714;"CALL:ORIGinate:AMR" !sends an AMR voice page the mobile station

CALL:ORIGinate:DONE?

Function

 See Call Processing Event Synchronization

Query

Range: 1|0
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:ORIGinate:DONE?"

CALL:ORIGinate:OPComplete?

Function

 See Call Processing Event Synchronization

Query

Range: 1
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:ORIGinate:OPComplete?"

CALL:ORIGinate:PSData

Function

Generates a PS Data page attempt to the mobile station regardless of the Paging Service parameter setting. See Test Set-Originated Connection .

If the page attempt fails, the test set will return to the idle call processing state.

Requirements

Lab Application Revision: U.00.13 and above.

Programming Example

OUTPUT 714;"CALL:ORIGinate:PSData" !sends an PS Data page the mobile station

CALL:ORIGinate:SEQuential

Function

See Call Processing Event Synchronization

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:ORIGinate:SEQuential"

CALL:ORIGinate:WAIT

Function

 See Call Processing Event Synchronization

Setting

Range:

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:ORIGinate:WAIT"


CALL:PAGing

CALL:PAGing

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL:PAGing:IDENtity[:TYPE]
  • CALL:PAGing:IMSI[:SELected]
  • CALL:PAGing:REPeat[:STATe][:SELected]
  • CALL:PAGing:SERVice[:TYPE]

CALL:PAGing:IDENtity[:TYPE]

Function

Sets/queries the CS Paging Identity Type .

This parameter can only be set when call status is Idle .

Setting

Range: IMSI|TMSI

Query

 Same as setting

*RST Setting

 IMSI
Requirements

Test Application Revision: A.07 and above.

Lab Application Revision: C.02 and above.

Programming Example

OUTPUT 714;"CALL:PAGing:IDENtity TMSI"
! Sets the CS Paging Identity Type to TMSI.

CALL:PAGing:IMSI[:SELected]

Function

Sets/queries the paging international mobile subscriber identity (IMSI). See Paging IMSI .

Paging IMSI will be overwritten by the mobile station's reported IMSI during a location update or call setup.

Setting

Range: 000000 to 9999999999999999
(6 to 15 characters from the set 0123456789)

Query

Range: "000000" to "9999999999999999"
(6 to 15 characters from the set 0123456789)

*RST Setting

 "001012345678901"
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:PAGing:IMSI '023389832394287'"

CALL:PAGing:REPeat[:STATe][:SELected]

Function

Sets/queries Repeat Paging .

This parameter can only be set when operating mode is Cell Off .

Setting

 Range: 0|ON|1|OFF

Query

Range: 0|1

*RST Setting

 0 (off)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:PAGING:REPEAT ON"

CALL:PAGing:SERVice[:TYPE]

Function

Sets/queries the Paging Service .

Setting

Range:

  • AMR: AMR Voice
  • GPRS: UMTS/GPRS Packet Data (Lab Application only)
  • RBTest: RB Test Mode

Query

Range: AMR|GPRS|RBT

*RST Setting

 RBT
Requirements

Test Application Revision: A.04 and above.

Lab Application Revision: A.01 and above.

Lab Application Revision A.02 added AMR.

Programming Example

OUTPUT 714;"CALL:PAGing:SERVice AMR"
! Sets the paging service type to AMR voice.


CALL:PCTPower

CALL:PCTPower

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL[:CELL[1]]:PCTPower

CALL[:CELL[1]]:PCTPower

Function

Sets/queries the Primary CPICH TX Power . See Initial PRACH TX Power .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: -10 dBm to +50 dBm

Resolution: 1 dB

Query

Range: -10 dBm to +50 dBm

Resolution: 1 dB

*RST Setting

 +19 dBm
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:PCTPower 20" !Sets the Primary CPICH TX Power to 20 dBm.


CALL:PICHannel

CALL:PICHannel

Last updated: February 9, 2009

GPIB Command Conventions

  • CALL[:CELL]:PICHannel[:SLEVel]
  • CALL[:CELL]:PICHannel:CCODe
  • CALL[:CELL]:PICHannel:CCODe:CODE
  • CALL[:CELL]:PICHannel:LEVel
  • CALL[:CELL]:PICHannel:STATe

CALL[:CELL]:PICHannel[:SLEVel]

Function

Sets/queries the page indicator channel's initial power offset, and turns its state to ON.

This setting cannot be changed while in active cell operating mode (when available). Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: - 20 to 0 dB

Resolution: 0.01

Query

Range: -20 to 0 dB

Resolution: 0.01

*RST Setting

 -8.3 dB

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.06 changed *RST Setting to -8.3 dB.

Lab Application Revision C.01 changed *RST Setting to -8.3 dB.

Programming Example

OUTPUT 714;"CALL:PICHANNEL -12DB"

CALL[:CELL]:PICHannel:CCODe

Function

THIS COMMAND IS OBSOLETE. Please use CALL[:CELL]:PICHannel:CCODe:CODE .

Sets/queries the page indicator channel's channelization code.

Setting

Range: CODE14|CODE15|CODE16|CODE17

Query

Range: CODE14|CODE15|CODE16|CODE17

*RST Setting

 CODE16

Requirements

Test Application Revision: A.01 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:PICHannel:CCODe CODE17"

CALL[:CELL]:PICHannel:CCODe:CODE

Function

Sets/queries the page indicator channel's channelization code.

This setting cannot be changed while in active cell operating mode (when available). Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 2 to 255

Query

Range: 2 to 255

*RST Setting

 16

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"CALL:PICHannel:CCODe:CODE 16"

CALL[:CELL]:PICHannel:LEVel

Function

Sets/queries the page indicator channel's initial power offset.

This setting cannot be changed while in active cell operating mode (when available). Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: - 20 to 0 dB

Resolution: 0.01

Query

Range: -20 to 0 dB

Resolution: 0.01

*RST Setting

 -8.3 dB

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.06 changed *RST Setting to -8.3 dB.

Lab Application Revision C.01 changed *RST Setting to -8.3 dB.

Programming Example

OUTPUT 714;"CALL:PICHANNEL:LEVEL -10DB"

CALL[:CELL]:PICHannel:STATe

Function

Sets/queries the state of the page indicator channel's initial power offset.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 1|ON | 0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:PICHANNEL:STAT OFF"


CALL:PLMNetwork

CALL:PLMNetwork

Last updated: November 11, 2009

GPIB Command Conventions

  • CALL[:CELL]:PLMNetwork[:LIST][:EXTended]
  • CALL[:CELL]:PLMNetwork[:LIST][:EXTended]:POINts?

CALL[:CELL]:PLMNetwork[:LIST][:EXTended]

Function

Sets/queries the Equivalent PLMN List .

The E-PLMN list is set using this single variable length command that specifies the complete list (that is, it is not possible to edit a single entry with this command).

Each entry in the list is specified as a triplet of MCC, MNC and MNC Length parameters. The first triplet defines the first entry in the E-PLMN list, the second triplet the second entry and so on up to 15 triplets (which corresponds to the maximum size that can be signaled over the air to the UE).

If an MNC length of Auto (0) is selected, and the MNC is 99 or less, then the test set uses 2 digits to represent the associated MNC, or 3 digits otherwise. If an MNC length of 3 Digits (1) is selected then the test set uses 3 digits to represent the associated MNC with leading added zeros as necessary.

An empty list clears all the entries in the E-PLMN list by setting all the MCC and MNC states to Off. If the list is empty then the query returns NaN.

If you specify a set of parameters that are not a multiple of 3 the test set will reject the command with the error "+216, FDD call operation rejected; Invalid equivalent PLMN list specified".

Setting

Range: A list of up to 15 triplets of MCC (0 to 999), MNC (0 to 999), and MNC Length (0 = Auto, 1 = 3 Digits)

Query

Range: A list of up to 15 triplets of MCC (0 to 999), MNC (0 to 999), and MNC Length (0 = Auto, 1 = 3 Digits)

*RST Setting

All MCC and MNC states are Off

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above.

Programming Example

OUTPUT 714;"CALL:PLMNetwork"
!Sets all MCC and MNC states to Off.

OUTPUT 714;"CALL:PLMNetwork 1, 2, 0, 1, 3, 0, 1, 4, 0, 1, 5, 0"
!Sets MCC and MNC entries for PLMN 1 to 4, and sets all other MCC and MNC states to Off.

CALL[:CELL]:PLMNetwork[:LIST][:EXTended]:POINts?

Function

Queries the number of entries in the current E-PLMN list stored in the test set. See Equivalent PLMN List .

Query

Range: 0 to 15

Requirements

Lab Application Revision: F.00 and above

Test Application Revision: A.14 and above.

Programming Example

OUTPUT 714;"CALL:PLMNetwork:POINts?"


CALL:POWer

CALL:POWer

Last updated: January 15, 2009

GPIB Command Conventions

  • CALL[:CELL]:POWer[:SAMPLitude][:SELected]
  • CALL[:CELL]:POWer[:SAMPLitude](:CW|:FDD)

  • CALL[:CELL]:POWer:AMPLitude[:SELected]
  • CALL[:CELL]:POWer:AMPLitude(:CW|:FDD)

  • CALL[:CELL]:POWer:STATe[:SELected]
  • CALL[:CELL]:POWer:STATe(:CW|:FDD)

CALL[:CELL]:POWer[:SAMPLitude][:SELected]

CALL[:CELL]:POWer[:SAMPLitude](:CW|:FDD)

Function

The setting form of this command performs two functions: (1) sets the desired cell power level (see CALL[:CELL]:POWer:AMPLitude[:SELected] ) and (2) turns the cell power on/off state to on (see CALL[:CELL]:POWer:STATe[:SELected] ). The query form returns the desired cell power level or NAN. (See Cell Power and AWGN Power for more information about desired versus current power levels.)

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type (see CALL[:CELL]:SYSTem[:TYPE]? ). The cell power settings for the CW operating mode are independent of the cell power settings for the other operating modes.

Setting

Range: (This is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source)

  • FDD: -165 dBm/3.84MHz to +37 dBm/3.84MHz
  • CW: -177 dBm to +40 dBm

Resolution: 0.01 dBm/3.84 MHz

Query

Same as setting

*RST Setting

See CALL[:CELL]:POWer:AMPLitude[:SELected] and CALL[:CELL]:POWer:STATe[:SELected] .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:POWER:SAMPLITUDE -30"
! Sets the cell power level -30 dBm and turns it on.

CALL[:CELL]:POWer:AMPLitude[:SELected]

CALL[:CELL]:POWer:AMPLitude(:CW|:FDD)

Function

Sets/queries the desired cell power level. (See Cell Power and AWGN Power for more information about desired versus current power levels.)

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type (see CALL[:CELL]:SYSTem[:TYPE]? ). The cell power settings for the CW operating mode are independent of the cell power settings for the other operating modes.

The desired cell power level can also be set using the CALL[:CELL]:POWer[:SAMPLitude][:SELected] command.

Setting

Range: (This is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source)

  • FDD: -165 dBm/3.84MHz to +37 dBm/3.84MHz
  • CW: -177 dBm to +40 dBm

Resolution: 0.01 dBm/3.84 MHz

Query

Same as setting

*RST Setting

  • FDD: -75 dBm/3.84MHz
  • CW: -50 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:POWER:AMPLITUDE -30"
!Sets the cell power level -30 dBm.

CALL[:CELL]:POWer:STATe[:SELected]

CALL[:CELL]:POWer:STATe(:CW|:FDD)

Function

Sets/queries the cell power state.

The optional [:SELected] keyword in this command specifies that the cell power state being set or queried applies to the current system type (see CALL[:CELL]:SYSTem[:TYPE]? ). The cell power settings for the CW operating mode are independent of the cell power settings for the other operating modes.

Cell power state can also be set to on using the CALL[:CELL]:POWer[:SAMPLitude][:SELected] command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

ON

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:POWER:STATE OFF" !Turns off cell power.


CALL:PPRocedure

CALL:PPRocedure

Last updated: November 1, 2010

GPIB Command Conventions

  • CALL:PPRocedure:GPSystem:MS:RESet

  • CALL:PPRocedure:PCTest:EXTernal:CTRL:STATe

  • CALL:PPRocedure:RRC:PIPE[:STATe]

  • CALL:PPRocedure:RRC:PIPE:ADDMessage[:DATA]
  • CALL:PPRocedure:RRC:PIPE:ADDMessage:FINE[:DATA]

  • CALL:PPRocedure:RRC:PIPE:MCMessage[:DATA]
  • CALL:PPRocedure:RRC:PIPE:MCMessage:FINE[:DATA]
  • CALL:PPRocedure:RRC:PIPE:MCMessage:RESPonse[:DATA]?
  • CALL:PPRocedure:RRC:PIPE:MCMessage:RESPonse:CLEar
  • CALL:PPRocedure:RRC:PIPE:UEPosition:CAPability?
  • CALL:PPRocedure:RRC:PIPE:TSTamp:DOWNlink[:DATA]?
  • CALL:PPRocedure:RRC:PIPE:TSTamp:DOWNlink:CLEar

CALL:PPRocedure:GPSystem:MS:RESet

Function

Initiates a Reset UE Positioning Stored Information procedure.

Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:PPRocedure:GPSystem:MS:RESet"
!Initiates a Reset UE Positioning Stored Information procedure.

CALL:PPRocedure:PCTest:EXTernal:CTRL:STATe

Function

Queriesthe PCT External Control Connection State.

This query returns the state of the PCT external control connection.

Query

 Range: 1|ON|0|OFF

*RST Setting

 0

Requirements

Lab Application Revision: G.01.00and above

Programming Example

OUTPUT 714;"CALL:PPRocedure:PCTest:EXTernal:CTRL:STATe?"

CALL:PPRocedure:RRC:PIPE[:STATe]

Function

Sets/queries RRC Pipe State .

This command also clears the measurement identity list, and resets the <sequence number> field used in the CALL:PPRocedure:RRC:PIPE:MCMessage:RESPonse[:DATA]? query to zero.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

OFF

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:PPRocedure:RRC:PIPE 0"
!Sets the RRC Pipe state to Off.

CALL:PPRocedure:RRC:PIPE:ADDMessage[:DATA]

Function

Sets/queries the length (in bits) and the contents of the Assistance Data Delivery Message . If the Assistance Data Delivery Message is received while CALL:PPRocedure:RRC:PIPE[:STATe] is set to On and an RRC connection is present, the test set adds the appropriate message type parameter and integrity information if applicable, and sends the resulting message to the UE. Otherwise the message is ignored.

Setting

Range: <length of encoded message in bits>, <"ascii string of hex digits defining message">

Maximum Data Length = 2300 characters

Query

Range: <length of encoded message in bits>, <"ascii string of hex digits defining message">

*RST Setting

0, ""

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:PPRocedure:RRC:PIPE:ADDMessage?"
!Queries the Assistance Data Delivery Message.

CALL:PPRocedure:RRC:PIPE:ADDMessage:FINE[:DATA]

Function

 In addition to the actual data block comprising the ADDM message, this command carries all the information required by the test set to over-write the UTRAN GPS Reference Time information element. The behavior of this command and the usage of each of the parameters, are the same as the equivalent Measurement Control Message (MCM) command.

Setting

Range: <length of encoded message in bits>, <bit offset to utran gps reference time>, <primary scrambling code of cell>, <utran gps chips at trigger (mspart: 10 bits)>, <utran gps chips at trigger (ls-part: 32 bits), <"ascii string of hex digits defining message">

Maximum Data Length = 1152 characters

Query

Range: Same as setting

Requirements

Lab Application Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:PPRocedure:RRC:PIPE:ADDMessage:FINE?"
!Queries ADDM for Fine Cell Time Assistance.

CALL:PPRocedure:RRC:PIPE:MCMessage[:DATA]

Function

Sets/queries the measurement identity, length (in bits), and the contents of the Measurement Control Message . If the Measurement Control Message is received while CALL:PPRocedure:RRC:PIPE[:STATe] is set to On and an RRC connection is present, the test set adds the appropriate message type parameter and integrity information if applicable. The resulting message is sent to the UE. Otherwise the message is ignored.

The hex string should begin with the bit immediately following the Message Type field. That is, it should not contain the Integrity or Message type fields, as these are added by the test set.

For more details on using the RRC Pipe, see RRC Pipe .

Setting

Range: <measurement identity>, <length of encoded message in bits>, <"ascii string of hex digits defining message">

Maximum Data Length = 2300 characters

Query

Range: <measurement identity>, <length of encoded message in bits>, <"ascii string of hex digits defining message">

*RST Setting

0, 0, ""

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:PPRocedure:RRC:PIPE:MCMessage?"
!Queries the Measurement Control Message.

CALL:PPRocedure:RRC:PIPE:MCMessage:FINE[:DATA]

Function

This command is used to send to the UE an MCM that includes "fine cell time" information with an accuracy of 10us. Specifically, this information constitutes the precise GPS time that applies at a specific UTRAN SFN.

Setting

Range: <measurement identity>, <length of encoded message in bits>, <bit offset to utran gps reference time>, <primary scrambling code of cell>, <utran gps chips at trigger (ms-part: 10 bits)>, <utran gps chips at trigger (ls-part: 32 bits), <"ascii string of hex digits defining message">

Maximum Data Length = 1152 characters

Query

Range: <measurement identity>, <length of encoded message in bits>, <bit offset to utran gps reference time>, <primary scrambling code of cell>, <utran gps chips at trigger (ms-part: 10 bits)>, <utran gps chips at trigger (ls-part: 32 bits), <"ascii string of hex digits defining message">

Requirements

Lab Application Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:PPRocedure:RRC:PIPE:MCMessage:FINE?"
!Queries the fine cell time information.

CALL:PPRocedure:RRC:PIPE:MCMessage:RESPonse[:DATA]?

Function

Queries Measurement Control Message (MCM) Response .

This query returns a single message, but the last 10 messages have been stored. Messages are returned using a FIFO method. Once a message is queried, it is deleted from the memory buffer. Note that if more than 10 messages are received and none have been queried, the oldest messages are deleted to make room for the latest messages.

The only Measurement Report messages that are made available over GPIB are those that appear to be associated with a Measurement Control Message that was previously originated over the RRC pipe. The application makes this determination based on the "Measurement Identity" field in the Measurement Report message. A list is maintained of all <measurement identity> messages that have been specified in any CALL:PPRocedure:RRC:PIPE:MCMessage[:DATA] commands received since the RRC pipe was enabled. When a Measurement Report message is received, the application checks the <measurement identity> field of the message and only makes it available if the identity appears in the list.

Query

Range: <length of encoded message in bits>, <sequence number>, <"ascii string of hex digits defining message">

Maximum Data Length = 2300 characters

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:PPRocedure:RRC:PIPE:MCMessage:RESPonse?"
!Queries the MCM Response.

CALL:PPRocedure:RRC:PIPE:MCMessage:RESPonse:DPTStamp?

Function

 Queries Measurement Report / Measurement Control Failure with Timestamps.

Query

Range: <measurement identity>, <length of encoded message in bits>, <"ascii string of hex digits defining message">, <timestamp1>, <timestamp2>

Requirements

Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:PPRocedure:RRC:PIPE:MCMessage:RESPonse:DPTStamp?"
!Queries Measurement Report/Measurement Control Failure with Timestamps.

CALL:PPRocedure:RRC:PIPE:MCMessage:RESPonse:CLEar

Function

Performs a Measurement Control Message (MCM) Response Clear .

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:PPRocedure:RRC:PIPE:MCMessage:RESPonse:CLEar"
!Performs an MCM Response Clear event.

CALL:PPRocedure:RRC:PIPE:UEPosition:CAPability?

Function

Queries UE Positioning Capability.
Query

Range: <length of encoded message in bits>, <"ascii string of hex digits defining message">

Requirements

Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:PPRocedure:RRC:PIPE:UEPosition:CAPability?"
!Queries UE Positioning Capability.

CALL:PPRocedure:RRC:PIPE:TSTamp:DOWNlink[:DATA]?

Function

Queries Downlink Measurement Control Message Timestamps.
Query

Range: <timestamp1>, <timestamp2>

Requirements

Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:PPRocedure:RRC:PIPE:TSTamp:DOWNlink?"
!Queries Downlink Measurement Control Message Timestamps.

CALL:PPRocedure:RRC:PIPE:TSTamp:DOWNlink:CLEar

Function

Performs a Downlink Measurement Control Message with Timestamps Clear event.

Requirements

Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:PPRocedure:RRC:PIPE:TSTamp:DOWNlink:CLEar"
!Performs a Downlink Measurement Control Message with Timestamps Clear event.


CALL:PSDomain

CALL:PSDomain

Last updated: January 16, 2009

GPIB Command Conventions

  • CALL[:CELL]:PSDomain

CALL[:CELL]:PSDomain

Function

Sets/queries PS Domain Information .

This parameter can only be set when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: ABSent|PRESent

Query

 Range: ABS|PRES

*RST Setting

Test Application: ABS

Lab Application: PRES

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:PSDomain ABSent"
! Sets PS Domain Information to Absent.


CALL:RBSetup

CALL:RBSetup

Last updated: January 7, 2012

GPIB Command Conventions

  • CALL[:CELL]:RBSetup:CFNHandling
  • CALL[:CELL]:RBSetup:RLC:CONFigure

CALL[:CELL]:RBSetup:CFNHandling

Function

Sets/queries the RB Setup Timing Indication (CFN Handling) .

Setting

Range: INITialise|MAINtain

Query

Range: INIT|MAIN

*RST Setting

 MAIN

Requirements

Test Application Revision: A.07 and above

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"CALL:RBSetup:CFNHandling INITialise"
! Sets RB Setup Timing Indication (CFN Handling) to Initialise.

CALL[:CELL]:RBSetup:RLC:CONFigure

Function

Sets/queries the Radio Bearer Setup Message RLC Configuration.

This setting controls the underlying RLC configuration of the Radio Bearer Setup message sent in the DL when PS domain radio bearers are set up.This setting can not be changed in Active Cell operating mode. This setting is remote control only.

Setting

Range: UMODe|AMODe

Query

Range: UMOD|AMOD

*RST Setting

 UMOD

Requirements

Test Application Revision: A.19.00 and above

Programming Example

OUTPUT 714;"CALL:RBSetup:RLC:CONFigure UMOD"


CALL:RESelection

CALL:RESelection

Last updated: January 5, 2010

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL[:CELL]:RESelection:GSM:SHCS[:SVALue]
  • CALL[:CELL]:RESelection:GSM:SHCS:STATe
  • CALL[:CELL]:RESelection:GSM:SHCS:VALue
  • CALL[:CELL]:RESelection:GSM:SLIMit
  • CALL[:CELL]:RESelection:GSM:SSEarch
  • CALL[:CELL]:RESelection:GSM:STATe

  • CALL[:CELL]:RESelection:HYSTeresis[1]
  • CALL[:CELL]:RESelection:HYSTeresis2
  • CALL[:CELL]:RESelection:QUALity:LMINimum
  • CALL[:CELL]:RESelection:QUALity:MEASure
  • CALL[:CELL]:RESelection:RLMinimum
  • CALL[:CELL]:RESelection:TIMer

CALL[:CELL]:RESelection:GSM:SHCS[:SVALue]

Function

Sets/queries the Shcs,rat (GSM), and sets its state to ON.

This setting controls the Shcs,rat parameter in SIB3. This parameter determines the serving cell RSCP level at which the UE does not need to make inter-RAT measurements.

This setting only affects SIB3 if both the "Inter-RAT (GSM) and "Shcs,rat (GSM) State" settings are On.

Setting

Range: - 105 to 91 (in increments of 2)

Query

Range: - 105 to 91 (in increments of 2)

*RST Setting

 0

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:RESelection:GSM:SHCS 0"
!Sets the Shcs,rat (GSM) to 0 and turns it on.

CALL[:CELL]:RESelection:GSM:SHCS:STATe

Function

Sets/queries the Shcs,rat (GSM) State.

This setting controls whether the Shcs,rat (GSM) parameter will be included in SIB3.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0
*RST Setting | 0 (off)
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:RESelection:GSM:SHCS:STATe OFF"
! Sets the Shcs,rat (GSM) State to Off.

CALL[:CELL]:RESelection:GSM:SHCS:VALue

Function

Sets/queries the Shcs,rat (GSM).

This setting controls the Shcs,rat parameter in SIB3. This parameter determines the serving cell RSCP level at which the UE does not need to make inter-RAT measurements.

This setting only affects SIB3 if both the "Inter-RAT (GSM) and "Shcs,rat (GSM) State" settings are On.

For a negative value which is one step offset to the nearest valid value, the actual value transmitted is the value entered plus one. For example, if -104 is entered, -103 will be transmitted.

For a positive value which is one step offset to the nearest valid value, the actual value transmitted is the value entered minus one. For example, if 2 is entered, 1 will be transmitted.

Setting

Range: - 105 to 91 (in increments of 2)

Query

Range: - 105 to 91 (in increments of 2)

*RST Setting

 0

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:RESelection:GSM:SHCS:VALue 0"
!Sets the Shcs,rat (GSM) to 0.

CALL[:CELL]:RESelection:GSM:SLIMit

Function

Sets/queries the Slimit,searchrat (GSM).

This parameter controls the Slimit,searchrat (GSM) parameter in SIB3.

For a negative value which is one step offset to the nearest valid value, the actual value transmitted is the value entered plus one.

For a positive value which is one step offset to the nearest valid value, the actual value transmitted is the value entered minus one. For example, if 1 is entered, 0 will be transmitted.

Setting

Range: -32 to 20 (in increments of 2)

Query

Range: -32 to 20 (in increments of 2)

*RST Setting

 0

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:RESelection:GSM:SLIMit"
!Sets the Slimit,searchrat (GSM) to 0.

CALL[:CELL]:RESelection:GSM:SSEarch

Function

Sets/queries the Ssearch,rat (GSM).

This setting controls the Ssearch,rat parameter in SIB3. This broadcast parameter determines the serving cell CPICH Ec/No level at which the UE does not need to make inter-RAT measurements.

For a negative value which is one step offset to the nearest valid value, the actual value transmitted is the value entered plus one. For example, if -31 is entered, - 30 will be transmitted.For a positive value which is one step offset to the nearest valid value, the actual value transmitted is the value entered minus one. For example, if 1 is entered, 0 will be transmitted.

Setting

Range: -32 to 20 (in increments of 2)

Query

Range: -32 to 20 (in increments of 2)

*RST Setting

 0

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:RESelection:GSM:SSEarch 0"
!Sets the Ssearch,rat (GSM) to 0.

CALL[:CELL]:RESelection:GSM:STATe

Function

Sets/queries the Inter-RAT (GSM) 'S' Parameters State.

This setting controls whether any of the inter-RAT cell selection/reselection parameters are included in SIB3.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0
*RST Setting | 0 (off)
Requirements | Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:RESelection:GSM:STATe OFF"
! Sets Inter-RAT (GSM) 'S' Parameters State to Off.

CALL[:CELL]:RESelection:HYSTeresis[1]

Function

Sets/queries Hysteresis 1 (Qhyst1) . This setting is only applicable when Quality Measure is set to CPICH RSCP .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

For a negative value which is one step offset to the nearest valid value, the actual value transmitted is the value entered plus one.

For a positive value which is one step offset to the nearest valid value, the actual value transmitted is the value entered minus one. For example, if 1 is entered, 0 will be transmitted.

Setting

Range: 0 dB to +40 dB

Resolution: 1 dB

Query

 Same as setting

*RST Setting

 0 dB

Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:RESelection:HYSTeresis 3"
! Sets the Hysteresis 1 (Qhyst1) to 3 dB.

CALL[:CELL]:RESelection:HYSTeresis2

Function

Sets/queries Hysteresis 2 (Qhyst2) . This setting is only applicable when Quality Measure is set to CPICH Ec/N0 .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

For a negative value which is one step offset to the nearest valid value, the actual value transmitted is the value entered plus one.

For a positive value which is one step offset to the nearest valid value, the actual value transmitted is the value entered minus one. For example, if 1 is entered, 0 will be transmitted.

Setting

Range: 0 dB to +40 dB

Resolution: 1 dB

Query

 Same as setting

*RST Setting

 0 dB

Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:RESelection:HYSTeresis2 3"
! Sets Hysteresis 2 (Qhyst2) to 3 dB.

CALL[:CELL]:RESelection:QUALity:LMINimum

Function

Sets/queries the Minimum Required Quality Level (Qqualmin) .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: -24 dB to 0 dB

Resolution: 1 dB

Query

 Same as setting

*RST Setting

 -24 dB

Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:RESelection:QUALity:LMINimum -10"
! Sets Minimum Required Quality Level (Qqualmin) to -10 dB.

CALL[:CELL]:RESelection:QUALity:MEASure

Function

Sets/queries the Quality Measure .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range:

  • ECN0 - sets Quality Measure (Qmeas) to CPICH Ec/N0
  • ECNO - sets Quality Measure (Qmeas) to CPICH Ec/N0
  • RSCP - sets Quality Measure (Qmeas) to CPICH RSCP

Query

Range: RCSP|ECN0

*RST Setting

 ECN0

Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:RESelection:QUALity:MEASure RSCP"
! Sets Quality Measure (Qmeas) to CPICH RSCP.

CALL[:CELL]:RESelection:RLMinimum

Function

Sets/queries the Minimum Required Rx Level (Qrxlevmin) .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

For a negative value which is one step offset to the nearest valid value, the actual value transmitted is the value entered plus one. For this setting, e.g. if -100 is entered, -99 will be transmitted.

For a positive value which is one step offset to the nearest valid value, the actual value transmitted is the value entered minus one.

Setting

Range: -115 dBm to -25 dBm

Resolution: 1 dB

Query

 Same as setting

*RST Setting

 -115 dBm

Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:RESelection:RLMinimum -100"
! Sets Minimum Required Rx Level (Qrxlevmin) to -100 dBm.

CALL[:CELL]:RESelection:TIMer

Function

Sets/queries the Timer (Treselection) .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 0 s to 31 s

Resolution: 1 s

Query

 Same as setting

*RST Setting

 0 s

Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:RESelection:TIMer 10"
! Sets Timer (Treselection) to 10 seconds.


CALL:RFGenerator

CALL:RFGenerator

Last updated: January 16, 2009

GPIB Command Conventions

  • CALL[:CELL]:RFGenerator:CONFigure
  • CALL[:CELL]:RFGenerator:FMBRoadcast:ADAPter:GAIN
  • CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:GAIN
  • CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:STATe
  • CALL[:CELL]:RFGenerator:FMBRoadcast:FREQuency
  • CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:DEViation
  • CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:FREQuency
  • CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:STATe
  • CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:AMPLitude
  • CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:STATe
  • CALL[:CELL]:RFGenerator:FREQuency
  • CALL[:CELL]:RFGenerator:GPS:BFILter
  • CALL[:CELL]:RFGenerator:GPS:FREQuency?
  • CALL[:CELL]:RFGenerator:GPS:FREQuency2?
  • CALL[:CELL]:RFGenerator:GPS:NMESsage
  • CALL[:CELL]:RFGenerator:GPS:POWer[:SAMPLitude]
  • CALL[:CELL]:RFGenerator:GPS:POWer:AMPLitude
  • CALL[:CELL]:RFGenerator:GPS:POWer:STATe
  • CALL[:CELL]:RFGenerator:GPS:RAW:PPATtern
  • CALL[:CELL]:RFGenerator:GPS:RAW:PPATtern
  • CALL[:CELL]:RFGenerator:GPS:SVID

CALL[:CELL]:RFGenerator:CONFigure

Function

Sets/queries the RF Generator mode:

Normal: This mode is the normal CW operating mode is in which the test set generates a CW signal.
FM broadcast: In this mode, the test set generates the signals that are sent through the PF OUT ONLY port to the FM Adapter to produce an FM Broadcast signal.

Operating mode = Test Mode and Downlink Function = CW. See CW Operating Mode .

See FM Broadcast for more information.

Setting

Range: NORMal | FMBRoadcast

Query

 Range: NORM | FMBR

*RST Setting

 NORMal
Requirements

Test Application Revision: A.13 and above

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:RFGENERATOR:CONFigure FMBRoadcast"
! Sets RF Generator mode to FM Broadcast.

CALL[:CELL]:RFGenerator:FMBRoadcast:ADAPter:GAIN

Function

Sets/queries the loss of the FM Adapter. This parameter compensates the loss by increasing the signal strength at the RF OUT ONLY port.

Operating mode = Test Mode and Downlink Function = CW. See CW Operating Mode .

See FM Broadcast for more information.

Setting

Range: -30 to -10 dB

Resolution: 0.01 dB

Query

Range: -30 to -10 dB

Resolution: 0.01 dB

*RST Setting

 -19.75 dB
Requirements

Test Application Revision: A.13 and above

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:RFGENERATOR:FMBRoadcast:ADAPter:GAIN -19.75"
! Sets FM Broadcast Adapter Gain to -19.75 dB.

CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:GAIN

CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection[:SGAIN]

Function

Sets/queries the FM Broadcast mode Amplitude Offset setting that is applied to the RF OUT ONLY port.

Operating mode = Test Mode and Downlink Function = CW. See CW Operating Mode .

See FM Broadcast for more information.

Setting

Range: -50 to 50 dB

Resolution: 0.01 dB

Query

Range: -50 to 50 dB

Resolution: 0.01 dB

*RST Setting

 0 dB
Requirements

Test Application Revision: A.13 and above

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:RFGENERATOR:FMBRoadcast:CORRection:GAIN 0"
! Sets FM Broadcast Correction Gain to 0 dB.

CALL[:CELL]:RFGenerator:FMBRoadcast:CORRection:STATe

Function

Sets/queries whether the FM Broadcast mode Amplitude Offset setting is applied.

Operating mode = Test Mode and Downlink Function = CW. See CW Operating Mode .

See FM Broadcast for more information.

Setting

Range: 1 | ON | 0 | OFF

Query

 Range: 1 | 0

*RST Setting

 OFF
Requirements

Test Application Revision: A.13 and above

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:RFGENERATOR:FMBRoadcast:CORRection:STATe 0"
! Sets FM Broadcast Correction State to OFF.

CALL[:CELL]:RFGenerator:FMBRoadcast:FREQuency

Function

Sets/queries the frequency at which the test set broadcasts the FM signal.

Operating mode = Test Mode and Downlink Function = CW. See CW Operating Mode .

The units (Hz|kHz|MHz|GHz) are optional, if no units are specified then units default to Hz.

See FM Broadcast for more information.

Setting

Range: 10 MHz to 110 MHz

Resolution: 1 Hz

Query

Range: 10 MHz to 110 MHz

Resolution: 1 Hz

*RST Setting

 98.1 MHz
Requirements

Test Application Revision: A.13 and above

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:RFGENERATOR:FMBRoadcast:FREQuency 100"
! Sets FM Broadcast Frequency to 100 Hz.

CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:DEViation

CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal[:SDEViation]

Function

Sets/queries FM Deviation of the internal audio source. The internal audio source is the amount the modulated signal deviates from the carrier frequency.

Operating mode = Test Mode and Downlink Function = CW. See CW Operating Mode .

The units (Hz|kHz|MHz|GHz) are optional, if no units are specified then units default to Hz.

See FM Broadcast for more information.

Setting

Range: 0 to 75 kHz

Resolution: 100 Hz

Query

Range: 0 to 75 kHz

Resolution: 100 Hz

*RST Setting

 22.5 kHz
Requirements

Test Application Revision: A.13 and above

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:RFGENERATOR:FMBRoadcast:FM:INTernal 22.5 kHz"
! Sets Internal FM Deviation to 22.5 kHz.

CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:FREQuency

Function

Sets/queries the test set's internal FM frequency.

Operating mode = Test Mode and Downlink Function = CW. See CW Operating Mode .

The units (Hz|kHz|MHz|GHz) are optional, if no units are specified then units default to Hz.

See FM Broadcast for more information.

Setting

Range: 50 to 20,000 Hz

Resolution: 1 Hz

Query

Range: 50 to 20,000 Hz

Resolution: 1 Hz

*RST Setting

 1 kHz
Requirements

Test Application Revision: A.13 and above

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:FMBRoadcast:FM:INTernal:FREQuency 1 kHz"
! Sets the Internal FM Frequency to 1 kHz.

CALL[:CELL]:RFGenerator:FMBRoadcast:FM:INTernal:STATe

Function

Sets/queries whether the FM Broadcast mode Internal FM Deviation setting is applied.

Operating mode = Test Mode and Downlink Function = CW. See CW Operating Mode .

See FM Broadcast for more information.

Setting

Range: 1 | ON | 0 | OFF

Query

 Range: 1 | 0

*RST Setting

 1 (ON)
Requirements

Test Application Revision: A.13 and above

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:RFGENERATOR:FMBRoadcast:FM:INTernal:STATe ON"
! Sets Internal FM Deviation State to ON.

CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:AMPLitude

CALL[:CELL]:RFGenerator:FMBRoadcast:POWer[:SAMPLitude]

Function

Sets/queries the power at which the test set broadcasts the FM signal.

Operating mode = Test Mode and Downlink Function = CW. See CW Operating Mode .

See FM Broadcast for more information.

When this parameters is set to > -30 and < -120, "Over Range" and "Under Range" error message is displayed respectively.

Setting

Range: -140 to -20 dBm

Resolution: 0.01 dBm

Query

Range: -140 to -20 dBm

Resolution: 0.01 dBm

*RST Setting

 -50 dBm
Requirements

Test Application Revision: A.13 and above

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:RFGENERATOR:FMBRoadcast:POWer -50 dBm
! Sets FM Broadcast Power Amplitude to -50 dBm.

CALL[:CELL]:RFGenerator:FMBRoadcast:POWer:STATe

Function

Sets/queries whether the FM Broadcast Power setting is applied.

Operating mode = Test Mode and Downlink Function = CW. See CW Operating Mode .

See FM Broadcast for more information.

Setting

Range: 1 | ON | 0 | OFF

Query

 Range: 1 | 0

*RST Setting

 1 (OFF)
Requirements

Test Application Revision: A.13 and above

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"CALL:RFGENERATOR:FMBRoadcast:POWer:STATe ON"
! Sets FM Broadcast Power State to ON.

CALL[:CELL]:RFGenerator:FREQuency

Function

Sets/queries RF Gen Freq .

This command is only applicable when CALL[:CELL]:CONTrol:DOWNlink:FREQuency:AUTO ( RF Gen Freq Ctrl ) is set to Off (manual).

If no units are specified the setting defaults to Hz.

This command is only available in FDD Test and CW operating modes.

Note, when changing between operating modes, the RF Gen Freq Ctrl setting is returned to its default value of Auto .

Setting

Range: 292 MHz to 2700 MHz
Resolution: 0.1 Hz

Query

Range: 292 MHz to 2700 MHz
Resolution: 0.1 Hz

*RST Setting

851 MHz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:FREQuency 450 MHZ" !Set downlink channel frequency to 450 MHz.

CALL[:CELL]:RFGenerator:GPS:BFILter

Function

Sets/queries the filter that is used to filter the GPS baseband signal. A Gaussian or Rectangle filter with 10 MHz bandwidth is supported in this setting.

Operating mode = CW. See CW Operating Mode .

RF Gen Config = GPS. See Global Position System .

Setting

Range: GAUSsian | RECTangle

Query

Range: GAUS | RECT

*RST Setting

 GAUSsian
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:BFILter GAUSsian"
! Sets the type of filter to be GAUSsian

CALL[:CELL]:RFGenerator:GPS:FREQuency?

Function

Queries the frequency of RF source 1. This parameter is fixed at 1575.42MHz and displayed on the MUI.

Operating mode = CW. See CW Operating Mode .

RF Gen Config = GPS. See Global Position System .

Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:FREQuency?"
! Queries the frequency of RF source 1. It will return the value:+1.57542000E+009

CALL[:CELL]:RFGenerator:GPS:FREQuency2?

Function

Queries the frequency of RF source 2. This parameter is fixed at 871MHz. RF source 2 is only available in those TA that use two RF Sources.

Operating mode = CW. See CW Operating Mode .

RF Gen Config = GPS. See Global Position System .

Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:FREQuency2?"
! Queries the frequency of RF source 2. It will return the value:+8.71000000E+008

CALL[:CELL]:RFGenerator:GPS:NMESsage

Function

Sets/queries the type of GPS navigation message that is transmitted on GPS frames.

Default Navigation (also called TLM): the GPS frames is filled according to the default navigation data (Alternating ones and zeros in word 3 through 10)

Raw: the GPS frames is filled with PN sequence.

Operating mode = CW. See CW Operating Mode .

RF Gen Config = GPS. See Global Position System .

Setting

Range: DEFault | RAW

Query

Range: DEF | RAW

*RST Setting

 DEFault
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:NMESsage RAW"
! Sets the type of GPS navigation message to be RAW

CALL[:CELL]:RFGenerator:GPS:POWer[:SAMPLitude]

Function

Sets/queries the power at which the test set generates the GPS signal. Setting this parameter is also set the GPS State to ON.

The actual power range is -125dBm to -70dBm. However, it is affected when there is an amplitude offset.

Operating mode = CW. See CW Operating Mode .

RF Gen Config = GPS. See Global Position System .

NOTE
When this parameter is set to > -70 or < -125 ( If Amplitude Offset = 0), a persistent error "Warning, Source under/over range due to requested setting" is displayed.

Setting

Range: -160dBm to -20dBm, after the Amplitude Offset (optional) has been included, see Amplitude Offset .

Resolution: 0.01 dBm

Query

Range: -160dBm to -20dBm, after the Amplitude Offset (optional) has been included, see Amplitude Offset .

Resolution: 0.01 dBm

*RST Setting

 -80 dBm
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:POWer -80 dBm
!Sets GPS Power State to ON and Amplitude to -80dBm.

CALL[:CELL]:RFGenerator:GPS:POWer:AMPLitude

Function

Sets/queries the power at which the test set generates the GPS signal.

The actual power range is -125dBm to -70dBm. However, it is affected when there is an amplitude offset.

Operating mode = CW. See CW Operating Mode .

RF Gen Config = GPS. See Global Position System .

NOTE
When this parameter is set to > -70 or < -125 ( If Amplitude Offset = 0), a persistent error "Warning, Source under/over range due to requested setting" is displayed.

Setting

Range: -160dBm to -20dBm, after the Amplitude Offset (optional) has been included, see Amplitude Offset .

Resolution: 0.01 dBm

Query

Range: -160dBm to -20dBm, after the Amplitude Offset (optional) has been included, see Amplitude Offset )

Resolution: 0.01 dBm

*RST Setting

 -80 dBm
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:POWer:AMPLitude -80 dBm
! Sets GPS Power Amplitude to -80dBm.

CALL[:CELL]:RFGenerator:GPS:POWer:STATe

Function

Sets/queries whether the GPS power setting is applied.

Operating mode = CW. See CW Operating Mode .

RF Gen Config = GPS. See Global Position System .

Setting

Range: 1 | ON | 0 | OFF

Query

Range: 1 | ON | 0 | OFF

*RST Setting

Range: 1 | 0
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:POWer:STATe ON"
! Sets GPS Power State to ON.

CALL[:CELL]:RFGenerator:GPS:RAW:PPATtern

Function

Sets/queries the date type that is transmitted on GPS frames.

Operating mode = CW. See CW Operating Mode .

RF Gen Config = GPS. See Global Position System .

GPS Navigation Message Type = RAW.

Setting

Range: PN9| PN15

Query

Range: PN9| PN15

*RST Setting

PN9

Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:RAW:PPATtern PN15"
! Sets the date type to be PN15

CALL[:CELL]:RFGenerator:GPS:SVID

Function

Sets/queries which satellite is generating the GPS signal.

Operating mode = CW. See CW Operating Mode .

RF Gen Config = GPS. See Global Position System .

Note: The SV ID will affect the spreading code phase.

Setting

Range: 1 to 37

Resolution: 1

Query

Range: 1 to 37

Resolution: 1

*RST Setting

 1
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:RFGenerator:GPS:SVID 2
!Sets GPS satellite ID to be 2.


CALL:RLC

CALL:RLC

Last updated: January 16, 2009

GPIB Command Conventions

  • CALL[:CELL[1]]:RLC:REEStablish

CALL[:CELL[1]]:RLC:REEStablish

Function

Sets/queries the RLC re-establishment state. RLC re-establishment procedure typically occurs during the radio bearer setup portion of call establishment as the DPCH is reconfigured from the signalling radio bearer to the actual service configuration.

Attempting to change this setting to OFF results in the following error message: "+257, RLC behavior not compliant to 3GPP specifications for 3.4k or 13.6k SRB". When this setting is off, the test set will not perform the RLC re-establishment procedure even if the conditions would otherwise require it. This may result in unspecified behavior including loss of data.

Setting

Range: AUTO|OFF

Query

Range: AUTO|OFF

*RST Setting

AUTO
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:RLC:REEStablish OFF"
!Inhibit to perform the RLC re-establishement procedure.


CALL:RRC

CALL:RRC

Last updated: January 16, 2009

This topic is only applicable to the lab application.

GPIB Command Conventions

  • CALL[:CELL]:RRC:CRELease:CWCount
  • CALL[:CELL]:RRC:CRELease:N308

CALL[:CELL]:RRC:CRELease:CWCount

Function

Sets/queries the RRC Connection Release Complete Wait Count .

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: RETRansmit1 | N308

Query

Range: RETR1 | N308

*RST Setting

 RETR1

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:RRC:CRELease:CWCount RETRansmit1"
! Sets the RRC Connection Release Complete Wait Count to RETRansmit1

CALL[:CELL]:RRC:CRELease:N308

Function

Sets/queries the N308 RRC Conn Release Comp Max Retransmits .

This parameter can only be set when call status is Idle . Changing this setting results in the execution of the Broadcast Channel (BCCH) Update Procedure (SIB Contents) if BCCH Update Page is set to Auto .

Setting

Range: 1 to 8

Resolution: 1

Query

 Same as setting

*RST Setting

 2

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:RRC:CRELease:N308 2"
! Sets the N308 constant to 2.


CALL:RTVocoder

CALL:RTVocoder

Last updated: January 14, 2010

This topic is only applicable to the lab application.

GPIB Command Conventions

  • CALL:RTVocoder:CALibration:TYPE ?
  • CALL:RTVocoder:DECoder:HEADroom[:SELected]?
  • CALL:RTVocoder:DECoder:HEADroom:WCDMa?

  • CALL:RTVocoder:ENCoder:HEADroom[:SELected]?
  • CALL:RTVocoder:ENCoder:HEADroom:WCDMa?

  • CALL:RTVocoder:INPut:VOLTage[:EXPected][:SELected]
  • CALL:RTVocoder:INPut:VOLTage[:EXPected]:WCDMa

  • CALL:RTVocoder:OPERating:MODE ?

  • CALL:RTVocoder:OUTPut:FREQuency ?
  • CALL:RTVocoder:OUTPut:VOLTage[:MAXimum][:SELected]
  • CALL:RTVocoder:OUTPut:VOLTage[:MAXimum]:WCDMa

  • CALL:RTVocoder:VADetection[:STATe][:SELected]
  • CALL:RTVocoder:VADetection[:STATe]:WCDMa

  • CALL:RTVocoder:VADetection:AMRate:ALGorithm[:SELected]
  • CALL:RTVocoder:VADetection:AMRate:ALGorithm:WCDMa

CALL:RTVocoder:CALibration:TYPE

Function

Queries the vocoder calibration type. See Calibration Type .

Setting

AOPath | AIPath | ICODec
Query | AOP | AIP | ICOD
*RST Setting | AOPath
Requirement | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:CALibration:TYPE AOP"
!Set the vocoder calibration type to Audio Out Path.

CALL:RTVocoder:DECoder:HEADroom[:SELected]?

CALL:RTVocoder:DECoder:HEADroom:WCDMa?

Function

Queries the headroom of the decoded data samples to the full scale of the DAC (Digital to Analog Converter). See Real-Time Vocoder Headroom Information .

Query

Range: 0.0 to 100 dB, 9.91E+37 (NAN)

Resolution: 0.1 dB
*RST Setting 9.91E+37 (NAN)

Requirements

 Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:DECoder:HEADroom?"
!Queries decoder headroom.

CALL:RTVocoder:ENCoder:HEADroom[:SELected]?

CALL:RTVocoder:ENCoder:HEADroom:WCDMa?

Function

Queries the headroom of the audio samples to the full scale of the ADC (Analog to Digital Converter). See Real-Time Vocoder Headroom Information .

Query

Range: 0.0 to 100 dB, 9.91E+37 (NAN)

Resolution: 0.1 dB
*RST Setting 9.91E+37 (NAN)

Requirements

 Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:ENCoder:HEADroom?"
!Queries encoder headroom.

CALL:RTVocoder:INPut:VOLTage[:EXPected][:SELected]

CALL:RTVocoder:INPut:VOLTage[:EXPected]:WCDMa

Function

Sets/queries the peak voltage of the analog audio signal that is applied at the test set's AUDIO IN connector. The units (V|mV) are optional. If no units are specified, then units default to V. See Real-Time Vocoder Headroom Information .

Setting

Range: 0.001 to 2.0 V

Resolution: 1 mV

Query

Range: 0.001 to 2.0 V

Resolution: 1 mV
*RST Setting 2.0 V

Requirements

 Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:INPut:VOLTage 350mV"
!Sets the peak level of Audio In signal to 350 mV.

CALL:RTVocoder:OPERating:MODE

Function

Sets/queries the vocoder operating mode. See Operating Mode .
Setting | Range: NORMal | CALibration
Query | Range: NORM | CAL
*RST Setting | NORMal
Requirement | Lab Application Revision: F.00.19 and above.

Programming Example

OUTPUT 714;"CALL:RTVocoder:OPER:MODE NORM"
!Sets the vocoder operating mode to Normal.

CALL:RTVocoder:OUTPut:FREQuency

Function

 Sets the vocoder Audio Out Frequency, see Audio Out Frequency .

Setting

Range: 300 Hz to 1100 Hz

Resolution: 1.0 Hz

Query

 same as setting

*RST Setting

 1000Hz
Requirement Test Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:OUTPut:FREQuency 1000Hz"
!Sets the vocoder Audio Out Frequency to 1000Hz.

CALL:RTVocoder:OUTPut:VOLTage[:MAXimum][:SELected]

CALL:RTVocoder:OUTPut:VOLTage[:MAXimum]:WCDMa

Function

Sets/queries the maximum audio peak output level that is produced on the test set's AUDIO OUT connector according to the voice data received on the R-Traffic/R-FCH channel. The units (V|mV) are optional. If no units are specified, then units default to V. See Setting Real-Time Vocoder Parameters .

Setting

Range: 0.0 to 5.0 V

Resolution: 0.1 mV

Query

Range: 0.0 to 5.0 V

Resolution: 0.1 mV
*RST Setting

0.0 V

Requirements

 Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:OUTPut:VOLTage 350MV"
!Sets the peak level of AUDIO OUT signal to 350 mV.

CALL:RTVocoder:VADetection[:STATe][:SELected]

CALL:RTVocoder:VADetection[:STATe]:WCDMa

Function

Sets/queries whether or not the voice activity detection algorithm is implemented in the speech codec. See Setting Real-Time Vocoder Parameters .

Setting

Range: 1|ON | 0|OFF

Query

Range: 1 | 0
*RST Setting 0|OFF

Requirements

 Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:VADetection ON"
!Enable the voice activity detection algorithm.

CALL:RTVocoder:VADetection:AMRate:ALGorithm[:SELected]

CALL:RTVocoder:VADetection:AMRate:ALGorithm:WCDMa

Function

Sets/queries the voice activity detection algorithm. See Setting Real-Time Vocoder Parameters .

Setting

Range: OPTion1 | OPTion2

Query

Range: OPT1 | OPT2
*RST Setting

OPT1

Requirements

 Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:VADetection:AMRate:ALGorithm OPT2"
!Select Option 2 VAD algorithm for AMR.


CALL:SCODe

CALL:SCODe

Last updated: January 16, 2009

GPIB Command Conventions

  • CALL[:CELL]:SCODe[:PRIMary]

CALL[:CELL]:SCODe[:PRIMary]

Function

Sets/queries the primary scrambling code.

The actual code number for the primary scrambling code is 16 times the value of this setting. See 3GPP TS 25.213, "Spreading and Modulation (FDD)" for a complete description of the relationship between this index and the actual spreading code number.

This setting cannot be changed while the active cell operating mode. Attempting to change this setting while in this mode will result in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this setting.

Setting

Range: 0 to 511

Query

Range: 0 to 511

*RST Setting

0

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:SCODe 10" !Sets the primary scrambling code to 10.


CALL:SECurity

CALL:SECurity

Last updated: November 19, 2010

GPIB Command Conventions

  • CALL:SECurity:AUTHenticate[:KEY]

  • CALL:SECurity:AUTHenticate:ALGorithm

  • CALL:SECurity:AUTHenticate:AMF

  • CALL:SECurity:AUTHenticate:OPVariant:PTYPe
  • CALL:SECurity:AUTHenticate:OPVariant:PVALue

  • CALL:SECurity:AUTHenticate:RANDom

  • CALL:SECurity:AUTHenticate:RESult:GMM?
  • CALL:SECurity:AUTHenticate:RESult[:MM]?

  • CALL:SECurity:AUTHenticate:SQN:RESet[:IMMediate]

  • CALL:SECurity:OPERation

  • CALL:SECurity:RESult:CIPHering:KEY?
  • CALL:SECurity:RESult:INTegrity:KEY?

CALL:SECurity:AUTHenticate[:KEY]

Function

Sets/queries the Authentication Key .

This setting is not useful until the security operation mode is set to other than "NONE". See CALL:SECurity:OPERation .

Setting

Range: 0 to FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
(1 to 32 characters from the set 0123456789aAbBcCdDeEfF)

Query

Range: "00000000:00000000:00000000:00000000" to FFFFFFFF:FFFFFFFF:FFFFFFFF:FFFFFFFF
(The return string is always four colon separated groups in the order of upper, upper middle, lower middle and lower, each group with 8 characters from the set 0123456789ABCDEF, enclosed by double quotes)

*RST Setting

"4147494C:454E5420:54454348:4E4F0000"
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate '4147494C454E5420544543484E4F0000'"
! Sets the authentication key to 4147494C:454E5420:54454348:4E4F0000.

CALL:SECurity:AUTHenticate:ALGorithm

Function

Sets/queries the Authentication Algorithm .

This setting is not useful until the security operation mode is set to other than "NONE". See CALL:SECurity:OPERation .

Setting

Range:

  • RIJNdael (Milenage)
  • TEST34108

Query

Range: RIJN|TEST34108

*RST Setting

TEST34108
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:ALGorithm RIJN"
!Sets the authentication algorithm to Milenage (Rijndael).

CALL:SECurity:AUTHenticate:AMF

Function

Sets/queries the AMF Value .

This setting is not useful until the security operation mode is set to other than "NONE". See CALL:SECurity:OPERation .

Setting

Range: 0 to FFFF
(1 to 4 characters from the set 0123456789aAbBcCdDeEfF)

Query

Range: "0000" to "FFFF"
(The return string is always 4 characters from the set 0123456789ABCDEF, enclosed by double quotes)

*RST Setting

"0000"
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:AMF 'FFFF'"
!Sets the AMF value to FFFF.

CALL:SECurity:AUTHenticate:OPVariant:PTYPe

Function

Sets/queries the Operator Variant Parm Type . You must then enter a value for Operator Variant Auth Alg ( CALL:SECurity:AUTHenticate:OPVariant:PVALue ).

This setting is not useful until the security operation mode is set to other than "NONE". See CALL:SECurity:OPERation .

Setting

Range: OP|OPC

Query

Range: OP|OPC

*RST Setting

OPC
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:OPVariant:PTYPe OP"
!Sets the Operator Variant Authentication Parameter type to OP.

CALL:SECurity:AUTHenticate:OPVariant:PVALue

Function

Sets/queries the value of the Operator Variant Auth Alg .

You must indicate, using the Operator Variant Parm Type setting ( CALL:SECurity:AUTHenticate:OPVariant:PTYPe ), whether this setting contains OP or OPc.

This setting is not useful until the security operation mode is set to other than "NONE". See CALL:SECurity:OPERation .

Setting

Range: 0 to FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
(1 to 32 characters from the set 0123456789aAbBcCdDeEfF)

Query

Range: "00000000:00000000:00000000:00000000" to "FFFFFFFF:FFFFFFFF:FFFFFFFF:FFFFFFFF"
(The return string is always four colon separated groups in the order of upper, upper middle, lower middle and lower, each group with 8 characters from the set 0123456789ABCDEF, enclosed by double quotes)

*RST Setting

"00000000:00000000:00000000:00000000"
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:OPVariant:PVALue '10F'"
! Sets the value of Operator Variant Authentication
! Parameter to 00000000:00000000:00000000:0000010F.

CALL:SECurity:AUTHenticate:RANDom

Function

Sets/queries the Random (RAND) Value .

This setting is not useful until the security operation mode is set to other than "NONE". See CALL:SECurity:OPERation .

Setting

Range: 0 to FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
(1 to 32 characters from the set 0123456789aAbBcCdDeEfF)

Query

Range: "00000000:00000000:00000000:00000000" to "FFFFFFFF:FFFFFFFF:FFFFFFFF:FFFFFFFF"
(The return string is always four colon separated groups in the order of upper, upper middle, lower middle and lower, each group with 8 characters from the set 0123456789ABCDEF, enclosed by double quotes)

*RST Setting

"00000000:00000000:00000000:00000001"
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:RANDom 'A'"
!Sets the random value of the Authentication Parameter to 00000000:00000000:00000000:0000000A.

CALL:SECurity:AUTHenticate:RESult:GMM?

Function

Queries the Authentication Result: GMM .

Query

Range: SUCCess|MSFAILMAC|MSFAILSYNC|MSFAILUNKNOWN|RESLENERR|
RESNOTMATCH|NULL

  • SUCCess - MS Authentication Success
  • MSFAILMAC - MS Authentication Failure, with a reject cause of MAC Does not Match
  • MSFAILSYNC - MS Authentication Failure, with a reject cause of Synch Failure
  • MSFAILUNKNOWN - MS Authentication Failure, with a reject cause of Unknown
  • RESLENERR - MS Authentication Failure, with a reject cause of Incorrect RES Length
  • RESNOTMATCH - MS Authentication Failure, with a reject cause of RES does not Match

*RST Setting

NULL
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:RESult:GMM?"
!Queries the GMM authentication result.

CALL:SECurity:AUTHenticate:RESult[:MM]?

Function

Queries the Authentication Result: MM .

Query

Range: SUCCess|MSFAILMAC|MSFAILSYNC|MSFAILUNKNOWN|RESLENERR|
RESNOTMATCH|NULL

  • SUCCess - MS Authentication Success
  • MSFAILMAC - MS Authentication Failure, with a reject cause of MAC Does not Match
  • MSFAILSYNC - MS Authentication Failure, with a reject cause of Synch Failure
  • MSFAILUNKNOWN - MS Authentication Failure, with a reject cause of Unknown
  • RESLENERR - MS Authentication Failure, with a reject cause of Incorrect RES Length
  • RESNOTMATCH - MS Authentication Failure, with a reject cause of RES does not Match

*RST Setting

NULL
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:RESult?"
!Queries the MM authentication result.

CALL:SECurity:AUTHenticate:SQN:RESet[:IMMediate]

Function

Resets the authentication sequence number (SQN) to zero (see Reset Authentication SQN ).
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:SQN:RESet"
!Resets the authentication SQN.

CALL:SECurity:OPERation

Function

Sets/queries Security Operations .

Setting

Range: NONE|AUTHONLY|AUTHINT|AICiphering

  • NONE - No security procedures are performed
  • AUTHONLY - Authentication only
  • AUTHINT - Authentication and integrity protection
  • AICiphering - Authentication, integrity protection and ciphering

Query

Range: NONE|AUTHONLY|AUTHINT|AIC

*RST Setting

AUTHINT
Requirements

Test Application Revision: A.03 and above.
Lab Application Revision: A.01 and above.
Test Application Revision: A.06 and above, *RST value changed from NONE to AUTHINT
Lab Application Revision: C.01 and above, *RST value changed from NONE to AUTHINT
Lab Application Revision: F.00.19 and above, added AICiphering: requires an additional feature license.

Programming Example

OUTPUT 714;"CALL:SECurity:OPERation AUTHONLY"
!Sets the security procedure with authentication only.

CALL:SECurity:RESult:INTegrity:KEY?

Function

Queries the Integrity Key .

This result is only applicable for the security operation mode of "Authentication and Integrity Protection" or "Authentication, Integrity Protection and Ciphering". See CALL:SECurity:OPERation .

Setting

Range: 0 to FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
(1 to 32 characters from the set 0123456789aAbBcCdDeEfF)

Query

Range: "00000000:00000000:00000000:00000000" to FFFFFFFF:FFFFFFFF:FFFFFFFF:FFFFFFFF
(The return string is always four colon separated groups in the order of upper, upper middle, lower middle and lower, each group with 8 characters from the set 0123456789ABCDEF, enclosed by double quotes)
Requirements

Test Application Revision: A.17.00 and above.
Lab Application Revision: G.01.00 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:RESult:INTegrity:key?"
! Query the integrity key.

CALL:SECurity:RESult:CIPHering:KEY?

Function

Queries the Ciphering Key .

This result is only applicable for the security operation mode of "Authentication, Integrity Protection and Ciphering". See CALL:SECurity:OPERation .

Setting

Range: 0 to FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
(1 to 32 characters from the set 0123456789aAbBcCdDeEfF)

Query

Range: "00000000:00000000:00000000:00000000" to FFFFFFFF:FFFFFFFF:FFFFFFFF:FFFFFFFF
(The return string is always four colon separated groups in the order of upper, upper middle, lower middle and lower, each group with 8 characters from the set 0123456789ABCDEF, enclosed by double quotes)
Requirements

Test Application Revision: A.17.00 and above.
Lab Application Revision: G.01.00 and above.

Programming Example

OUTPUT 714;"CALL:SECurity:RESult:CIPHering:key?"
! Sets the ciphering key.


CALL:SETup

CALL:SETup

Last updated: December 26, 2011

GPIB Command Conventions

  • CALL:SETup[:PCReconfig]:CHANnel:BARBitrator
  • CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:DOWNlink
  • CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink[:MCHannel]
  • CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CHANnel
  • CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO
  • CALL:SETup[:PCReconfig]:SSCell:CHANnel:ADJacent

  • CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:SEParation

  • CALL:SETup:CLPControl:UPLink:ALGorithm
  • CALL:SETup:CLPControl:UPLink:STEPsize

  • CALL:SETup:RBReconfig:CHANnel:BARBitrator
  • CALL:SETup:RBReconfig:CHANnel:DOWNlink
  • CALL:SETup:RBReconfig:CHANnel:UPLink[:MCHannel]
  • CALL:SETup:RBReconfig:CHANnel:UPLink:CHANnel
  • CALL:SETup:RBReconfig:CHANnel:UPLink:CONTrol:AUTO
  • CALL:SETup:RBReconfig:DPCHannel:BETA:AUTO
  • CALL:SETup:RBReconfig:DPCHannel:DOFFset
  • CALL:SETup:RBReconfig:DPCHannel:MANual:CBETa
  • CALL:SETup:RBReconfig:DPCHannel:MANual:DBETa
  • CALL:SETup:RBReconfig:DPCHannel:RFOFfset
  • CALL:SETup:RBReconfig:DTCHannel:CRC[:PRESence]
  • CALL:SETup:RBReconfig:MS:LOOPback:TYPE
  • CALL:SETup:RBReconfig:RBTest:RAB
  • CALL:SETup:RBReconfig:UPLink:DCCHannel:DDATa

  • CALL:SETup[:HANDoff]:SYSTem[:TYPE]

  • CALL:SETup:SYSTem:GSM:ALERting[:STATe]

  • CALL:SETup:TCReconfig:CHANnel:BARBitrator
  • CALL:SETup:TCReconfig:CHANnel:DOWNlink
  • CALL:SETup:TCReconfig:CHANnel:UPLink[:MCHannel]
  • CALL:SETup:TCReconfig:CHANnel:UPLink:CHANnel
  • CALL:SETup:TCReconfig:CHANnel:UPLink:CONTrol:AUTO

  • CALL:SETup:TCReconfig:DPCHannel:BETA:AUTO
  • CALL:SETup:TCReconfig:DPCHannel:DOFFset
  • CALL:SETup:TCReconfig:DPCHannel:MANual:CBETa
  • CALL:SETup:TCReconfig:DPCHannel:MANual:DBETa
  • CALL:SETup:TCReconfig:DPCHannel:RFOFfset

  • CALL:SETup:TCReconfig:EDCHannel:QAM16[:STATE]

  • CALL:SETup:TCReconfig:EDPCchannel[:DPCChannel]:POFFset

  • CALL:SETup:TCReconfig:ETFCi:POFFsets:REFerence

  • CALL:SETup:TCReconfig:HARQ:PROCess:COUNt

  • CALL:SETup:TCReconfig:MPOWer[:MOFFset]
  • CALL:SETup:TCReconfig:MPOWer:OFFSet:CONTrol:AUTO
  • CALL:SETup:TCReconfig:MPOWer:OFFSet:MANual

  • CALL:SETup:TCReconfig:MS:IREDundancy:BUFFer:ALLocation
  • CALL:SETup:TCReconfig:MS:IREDundancy:BUFFer:SIZe[:EXPLicit]

  • CALL:SETup:TCReconfig:RBTest:EDPDchannel:CCODes:MAX[:HSPARMC12]
  • CALL:SETup:TCReconfig:RBTest:EDPDchannel:CCODes:MAX:HSPA
  • CALL:SETup:TCReconfig:RBTest:RAB

  • CALL:SETup:TCReconfig:SGRant:ABSolute:QAM16[:VALue]
  • CALL:SETup:TCReconfig:SGRant:ABSolute[:VALue]

  • CALL:SETup:TCReconfig:UPLink:ANACk:RFACtor
  • CALL:SETup:TCReconfig:UPLink:CQI:FCYCle
  • CALL:SETup:TCReconfig:UPLink:CQI:RFACtor
  • CALL:SETup:TCReconfig:UPLink:DACK
  • CALL:SETup:TCReconfig:UPLink:DCQI
  • CALL:SETup:TCReconfig:UPLink:DNACk

CALL:SETup[:PCReconfig]:CHANnel:BARBitrator

Function

Sets/queries the Handover Band Arbitrator .

This setting is only applicable when Handover Downlink Channel (UARFCN) is set to a channel in Band VI.

Setting

Range: BAND5|BAND6

Query

 Same as setting

*RST Setting

BAND6
Requirements

Test Application Revision: A.09 and above

Test Application Revision A.11, added [:PCReconfig]

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Lab Application Revision D.02, added [:PCReconfig]

Programming Example

OUTPUT 714;"CALL:SETup:CHANnel:BARBitrator BAND5"

CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:DOWNlink

Function

Sets/queries the Handover Downlink Channel (UARFCN) .

If the entered Handover Downlink Channel (UARFCN) has an uplink/downlink offset of less than 30 MHz when compared with the Handover Uplink Channel (UARFCN) , the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range:

  • 412, 437, 462, 487, 512, 537, 562, 587, 612, 637, 662, 687
  • 712 to 763
  • 787, 812, 837
  • 862 to 912
  • 1007, 1012, 1032, 1037, 1062, 1087
  • 1162 - 1513, resolution = 1
  • 1537 - 1738, resolution = 1
  • 1887, 1912, 1937, 1962, 1987, 2012, 2037, 2062, 2087
  • 2237 - 2563, resolution = 1
  • 2587, 2612, 2637, 2662, 2687, 2712, 2737, 2762, 2787, 2812, 2837, 2862, 2887, 2912
  • 2937 - 3088, resolution = 1
  • 3112 to 3388, resolution = 1
  • 3412, 3437, 3462, 3487, 3512, 3537, 3562, 3587, 3612, 3637, 3662, 3687
  • 3837 - 3903, resolution = 1
  • 3927, 3932, 3957, 3962, 3987, 3992
  • 4017 - 4043, resolution = 1
  • 4067, 4092
  • 4117 - 4143, resolution = 1
  • 4167, 4192
  • 4357 - 4458, resolution = 1
  • 4512 to 4638
  • 9237 - 9387, resolution = 1
  • 9662 - 9938, resolution = 1
  • 10562 - 10838, resolution = 1

Query

 Same as setting

*RST Setting

10730
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.05.28, Lab Application Revision B.01.29, added 1037 - 1062.

Test Application Revision A.08 and Lab Application Revision C.03, changed channel ranges to match 3GPP TS 25.101 v6.7.0 (previously, channels supported were: 412-687, 1037-1062, 4320-4495, 4600-4825, 9000-9425, 9625-9975, and 10,525-10,875, resolution = 1).

Test Application Revision A.09 and Lab Application Revision C.04 and D.00, changed channel ranges to match 3GPP TS 25.101 v7.2.0 (previously channels supported were: 412, 437, 462, 487, 512, 537, 562, 587, 612, 637, 662, 687, 1007, 1012, 1032, 1037, 1062, 1087, 1462, 1487, 1512, 1537, 1562, 1587, 1612, 1637, 1662, 4357-4458 -- resolution = 1, 9037-9388 -- resolution = 1, 9662-9938 -- resolution = 1, and 10562-10838 -- resolution = 1).

Test Application Revision A.10 and Lab Application Revision D.01, added 2237 - 2563, 2587, 2612, 2637, 2662, 2687, 2712, 2737, 2762, 2787, 2812, 2837, 2862, 2887, 2912

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, added 3112 to 3388, 3412, 3437, 3462, 3487, 3512, 3537, 3562, 3587, 3612, 3637, 3662, 3687

Test Application Revision A.11 and Lab Application Revision D.02, added [:PCReconfig]

Test Application Revision A.14 and Lab Application Revision F.00, added 3837 - 3903, 3927, 3932, 3957, 3962, 3987, 3992, 4017 - 4043, 4067, 4092, 4117 - 4143, 4167, 4192

Test Application Revision A.18.00 and Lab Application Revision H.00.00 and above, added 712 to 763, 787, 812, 837, 4512 to 4638 and 862 to 912

Programming Example

OUTPUT 714;"CALL:SETup:CHANnel:DOWNlink 10735"

CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink[:MCHannel]

Function

The setting form of this command performs two functions: (1) sets Handover Uplink Channel (UARFCN) to a specific UARFCN (see CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CHANnel ), and (2) sets handover uplink channel control to off (manual) (see CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO ).

The query form of this command returns the handover uplink UARFCN that is used by the test set when CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to off (manual). Note, when CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to on (auto), the handover uplink UARFCN used by the test set is determined by CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:DOWNlink .

The handover uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>UPLink[:CHANnel]? .

If the entered handover Handover Uplink UARFCN has an uplink/downlink offset of less than 30 MHz when compared with the Handover Downlink Channel (UARFCN) , the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range: see CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CHANnel

Query

 Same as setting

*RST Setting

Handover uplink UARFCN = 9780, handover uplink channel control = on (auto)
Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.05.28 and Lab Application Revision B.01.29, added 812 - 837.

Test Application Revision A.08 and Lab Application Revision C.03, changed channel ranges to match 3GPP TS 25.101 v6.7.0 (previously, channels supported were: 12-287, 812-837, 4095-4270, 4375-4600, 8525-8950 and 9225-9925, resolution = 1).

Test Application Revision A.09 and Lab Application Revision C.04 and D.00, changed channel ranges to match 3GPP TS 25.101 v7.2.0 (previously channels supported were: 12, 37, 62, 87, 112, 137, 162, 187, 212, 237, 262, 287, 782, 787, 807, 812, 837, 862, 1162, 1187, 1212, 1237, 1262, 1287, 1312, 1337, 1362, 4132-4233 -- resolution = 1, 8562-8913 -- resolution = 1, 9262-9538 -- resolution = 1, 9612-9888 -- resolution = 1).

Test Application Revision A.10 and Lab Application Revision D.01, added 2012 - 2338, 2362, 2387, 2412, 2437, 2462, 2487, 2512, 2537, 2562, 2587, 2612, 2637, 2662, 2687

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, added 2887 to 3163, 3187, 3212, 3237, 3262, 3287, 3312, 3337, 3362, 3387, 3412, 3437, 3462

Test Application Revision A.11 and Lab Application Revision D.02, added [:PCReconfig]

Lab Application Revision: E.00.34 and above, added 3487 - 3587.

Programming Example

OUTPUT 714;"CALL:SETup:CHANnel:UPLink 9785"
! Sets the handover uplink channel UARFCN to 9785 and selects manual control mode
! for handover uplink channel.

CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CHANnel

Function

The setting form of this command sets Handover Uplink Channel (UARFCN) to a specific UARFCN.

Note, this handover uplink UARFCN is only used by the test set when CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to off (manual). When CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to on (auto), the handover uplink UARFCN used by the test set is determined by CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:DOWNlink .

The query form of this command returns the handover uplink UARFCN that is used by the test set when CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to off (manual).

The handover uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>UPLink[:CHANnel]? .

If the entered handover Handover Uplink UARFCN has an uplink/downlink offset of less than 30 MHz when compared with the Handover Downlink Channel (UARFCN) , the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range:

  • 12, 37, 62, 87, 112, 137, 162, 187, 212, 237, 262, 287
  • 312 to 363 387, 412, 437 462 to 512
  • 782, 787, 807, 812, 837, 862
  • 937 - 1288, resolution = 1
  • 1312 - 1513, resolution = 1
  • 1662, 1687, 1712, 1737, 1762, 1787, 1812, 1837, 1862
  • 2012 - 2338, resolution = 1
  • 2362, 2387, 2412, 2437, 2462, 2487, 2512, 2537, 2562, 2587, 2612, 2637, 2662, 2687
  • 2712 - 2863, resolution = 1
  • 2887 - 3163, resolution = 1
  • 3187, 3212, 3237, 3262, 3287, 3312, 3337, 3362, 3387, 3412, 3437, 3462
  • 3487 - 3587, resolution = 1
  • 3612 - 3678, resolution = 1
  • 3702, 3707, 3732, 3737, 3762, 3767
  • 3792 - 3818, resolution = 1
  • 3842, 3867
  • 3892 - 3918, resolution = 1
  • 3942, 3967
  • 4132 - 4233, resolution = 1
  • 4287 to 4413
  • 8762 - 8912, resolution = 1
  • 9262 - 9538, resolution = 1
  • 9612 - 9888, resolution = 1

Query

 Same as setting

*RST Setting

 9780
Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Test Application Revision A.08 and Lab Application Revision C.03, changed channel ranges to match 3GPP TS 25.101 v6.7.0 (previously, channels supported were: 12-287, 812-837, 4095-4270, 4375-4600, 8525-8950 and 9225-9925, resolution = 1).

Test Application Revision A.09 and Lab Application Revision C.04 and D.00, changed channel ranges to match 3GPP TS 25.101 v7.2.0 (previously channels supported were: 12, 37, 62, 87, 112, 137, 162, 187, 212, 237, 262, 287, 782, 787, 807, 812, 837, 862, 1162, 1187, 1212, 1237, 1262, 1287, 1312, 1337, 1362, 4132-4233 -- resolution = 1, 8562-8913 -- resolution = 1, 9262-9538 -- resolution = 1, 9612-9888 -- resolution = 1).

Test Application Revision A.10 and Lab Application Revision D.01, added 2012 - 2338, 2362, 2387, 2412, 2437, 2462, 2487, 2512, 2537, 2562, 2587, 2612, 2637, 2662, 2687

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, added 2887 to 3163, 3187, 3212, 3237, 3262, 3287, 3312, 3337, 3362, 3387, 3412, 3437, 3462

Test Application Revision A.11 and Lab Application Revision D.02, added [:PCReconfig]

Lab Application Revision: E.00.34 and above, added 3487 - 3587.

Test Application Revision A.14 and Lab Application Revision F.00 and above, added 3612 - 3678, 3702, 3707, 3732, 3737, 3762, 3767, 3792 - 3818, 3842, 3867, 3892 - 3918, 3942, 3967

Test Application Revision: A.18.00 and Lab Application Revision H.00.00 and above, added 312 to 363, 387, 412, 437, 4287 to 4413 and 462 to 512

Programming Example

OUTPUT 714;"CALL:SETup:CHANnel:UPLink:CHANnel 9785"
! Sets the handover uplink channel UARFCN to 9785.

CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO

Function

Sets/queries the Handover Uplink Channel (UARFCN) control mode.

  • Auto - handover uplink UARFCN is determined by CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:DOWNlink .
  • Manual - handover uplink UARFCN is determined by CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CHANnel .

The handover uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>UPLink[:CHANnel]? .

Setting

Range:

  • 1|ON (auto)
  • 0|OFF (manual)

Query

 Range: 1|0

*RST Setting

1 (auto)
Requirements

Test Application Revision: A.06 and above

Test Application Revision A.11, added [:PCReconfig]

Lab Application Revision: C.01 and above

Lab Application Revision D.02, added [:PCReconfig]

Programming Example

OUTPUT 714;"CALL:SETup:CHANnel:UPLink:CONTrol:AUTO OFF"
! Sets handover uplink control mode to manual.

CALL:SETup[:PCReconfig]:SSCell:CHANnel:ADJacent

Function

Sets/queries the HSDPA Secondary Cell Handover DL UARFCN .

Setting

Range:

  • HIGHer
  • LOWer

Query

Range:

  • HIGH
  • LOW

*RST Setting

HIGHer
Requirements

Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:SSCell:CHANnel:ADJacent HIGHer"
! Sets the DC-HSDPA secondary cell handover DL UARFCN to be adjacent higher than the serving cell.

CALL:SETup:CHANnel<[:SELected]|:FDD>:UPLink:SEParation

Function

THIS COMMAND IS OBSOLETE. The Handoff Uplink Separation (Band) setting has been replaced by the Handover Band Arbitrator setting ( CALL:SETup[:PCReconfig]:CHANnel:BARBitrator ). Setting CALL:SETup:CHANnel:UPLink:SEParation to VMHZ45 sets Handoff Band Arbitrator to Band 5 . Setting CALL:SETup:CHANnel:UPLink:SEParation to any other value sets Handoff Band Arbitrator to Band 6 .

Sets/queries Handoff Uplink Separation (Band) .

When CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to on (auto), the handoff uplink UARFCN used by the test set is determined by this Handoff Uplink Separation setting and by CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:DOWNlink .

If CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO is set to on (auto) and you attempt to set Handoff Uplink Separation to a value that would result in an invalid handoff uplink channel based on the current CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:DOWNlink setting, an error is posted. With CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO set to off (manual), set CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:DOWNlink and Handoff Uplink Separation to a valid combination, then set CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CONTrol:AUTO to on.

Setting

Range:

  • MHZ45 - 45 MHz (Band 6)
  • VMHZ45 - 45 MHz (Band 5)
  • MHZ80 - 80 MHz (Band 2)
  • MHZ95 - 95 MHz (Band 3)
  • MHZ190 - 190 MHz (Band 1)
  • MHZ400 - 400 MHz (Band 4)

Query

 Same as setting

*RST Setting

 MHZ190
Requirements

Test Application Revision: A.06 and above

Test Application Revision A.08 and Lab Application Revision C.03, added VMHZ45

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SETup:CHANnel:UPLink:SEParation MHZ80"

CALL:SETup:CLPControl:UPLink:ALGorithm

Function

Sets/queries Handover UL CL Power Ctrl Algorithm .

Setting

Range: ALG1|ALG2

Query

 Same as setting
*RST setting ALG2

Requirements

Test Application Revision: A.10.01 and above.

Lab Application Revision: D.01.01 and above.

Programming Example

OUTPUT 714;"CALL:SETup:CLPControl:UPLink:ALGorithm ALG1"
! Sets Handover UL CL Power Ctrl Algorithm to One.

CALL:SETup:CLPControl:UPLink:STEPsize

Function

Sets/queries Handover UL CL Power Ctrl Step Size .

This setting can only be changed when CALL:SETup:CLPControl:UPLink:ALGorithm is set to ALG1 . Also, if CALL:SETup:CLPControl:UPLink:ALGorithm is set to ALG2 , this setting is returned to its default value of 1 dB .

Setting

Range: 1 to 2 dB

Query

 Same as setting
*RST setting 1 dB

Requirements

Test Application Revision: A.10.01 and above.

Lab Application Revision: D.01.01 and above.

Programming Example

OUTPUT 714;"CALL:SETup:CLPControl:UPLink:STEPsize 2"
! Sets Handover UL CL Power Ctrl Step Size to 2 dB.

CALL:SETup:RBReconfig:CHANnel:BARBitrator

Function

Sets/queries the RBR Band Arbitrator .

This setting is only applicable when RBR Downlink Channel (UARFCN) is set to a channel in Band VI.

This setting is only applicable when RBR Channel (UARFCN) State is set to On .

Setting

Range: BAND5|BAND6

Query

 Same as setting

*RST Setting

BAND6
Requirements

Test Application Revision A.11 and above.

Lab Application Revision D.02 and above.

Programming Example

OUTPUT 714;"CALL:SETup:RBReconfig:CHANnel:BARBitrator BAND6"

CALL:SETup:RBReconfig:CHANnel:DOWNlink

Function

Sets/queries the RBR Downlink Channel (UARFCN) .

This setting is only applicable when RBR Channel (UARFCN) State is set to On .

If the entered RBR Downlink Channel (UARFCN) has an uplink/downlink offset of less than 30 MHz when compared with the RBR Uplink Channel (UARFCN) , the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range:

  • 412, 437, 462, 487, 512, 537, 562, 587, 612, 637, 662, 687
  • 712 to 763
  • 787, 812, 837
  • 862 to 912
  • 1007, 1012, 1032, 1037, 1062, 1087
  • 1162 - 1513, resolution = 1
  • 1537 - 1738, resolution = 1
  • 1887, 1912, 1937, 1962, 1987, 2012, 2037, 2062, 2087
  • 2237 - 2563, resolution = 1
  • 2587, 2612, 2637, 2662, 2687, 2712, 2737, 2762, 2787, 2812, 2837, 2862, 2887, 2912
  • 2937 - 3088, resolution = 1
  • 3112 - 3388, resolution = 1
  • 3412, 3437, 3462, 3487, 3512, 3537, 3562, 3587, 3612, 3637, 3662, 3687
  • 3837 - 3903, resolution = 1
  • 3927, 3932, 3957, 3962, 3987, 3992
  • 4017 - 4043, resolution = 1
  • 4067, 4092
  • 4117 - 4143, resolution = 1
  • 4167, 4192
  • 4357 - 4458, resolution = 1
  • 4512 to 4638
  • 9237 - 9387, resolution = 1
  • 9662 - 9938, resolution = 1
  • 10562 - 10838, resolution = 1

Query

 Same as setting

*RST Setting

10730
Requirements

Test Application Revision A.11 and above.

Lab Application Revision D.02 and above.

Test Application Revision A.14 and Lab Application Revision F.00, added 3837 - 3903, 3927, 3932, 3957, 3962, 3987, 3992, 4017 - 4043, 4067, 4092, 4117 - 4143, 4167, 4192

Test Application Revision A.18.00 and Lab Application Revision H.00.00 and above, added 712 to 763, 787, 812, 837, 4512 to 4638 and 862 to 912

Programming Example

OUTPUT 714;"CALL:SETup:RBReconfig:CHANnel:DOWNlink 10730"

CALL:SETup:RBReconfig:CHANnel:UPLink[:MCHannel]

Function

The setting form of this command performs two functions: (1) sets RBR Uplink Channel (UARFCN) to a specific UARFCN (see CALL:SETup:RBReconfig:CHANnel:UPLink:CHANnel ), and (2) sets RBR uplink channel control to off (manual) (see CALL:SETup:RBReconfig:CHANnel:UPLink:CONTrol:AUTO ).

The query form of this command returns the RBR uplink UARFCN that is used by the test set when CALL:SETup:RBReconfig:CHANnel:UPLink:CONTrol:AUTO is set to off (manual). Note, when CALL:SETup:RBReconfig:CHANnel:UPLink:CONTrol:AUTO is set to on (auto), the RBR uplink UARFCN used by the test set is determined by CALL:SETup:RBReconfig:CHANnel:DOWNlink .

This setting is only applicable when RBR Channel (UARFCN) State is set to On .

The RBR uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:SETup:RBReconfig:CHANnel:UPLink[:CHANnel]? .

If the entered RBR Uplink Channel (UARFCN) has an uplink/downlink offset of less than 30 MHz when compared with the RBR Downlink Channel (UARFCN) , the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range: see CALL:SETup:RBReconfig:CHANnel:UPLink:CHANnel

Query

 Same as setting

*RST Setting

RBR uplink UARFCN = 9780, RBR uplink channel control = on (auto)
Requirements

Test Application Revision A.11 and above.

Lab Application Revision D.02 and above.

Programming Example

OUTPUT 714;"CALL:SETup:RBReconfig:CHANnel:UPLink 9780"
! Sets the RBR uplink channel UARFCN to 9780 and selects manual control mode
! for RBR uplink channel.

CALL:SETup:RBReconfig:CHANnel:UPLink:CHANnel

Function

The setting form of this command sets RBR Uplink Channel (UARFCN) to a specific UARFCN.

This setting is only applicable when RBR Channel (UARFCN) State is set to On .

Note, this RBR uplink UARFCN is only used by the test set when CALL:SETup:RBReconfig:CHANnel:UPLink:CONTrol:AUTO is set to off (manual). When CALL:SETup:RBReconfig:CHANnel:UPLink:CONTrol:AUTO is set to on (auto), the RBR uplink UARFCN used by the test set is determined by CALL:SETup:RBReconfig:CHANnel:DOWNlink .

The query form of this command returns the RBR uplink UARFCN that is used by the test set when CALL:SETup:RBReconfig:CHANnel:UPLink:CONTrol:AUTO is set to off (manual).

The RBR uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:SETup:RBReconfig:CHANnel:UPLink[:CHANnel]? .

If the entered RBR Uplink Channel (UARFCN) has an uplink/downlink offset of less than 30 MHz when compared with the RBR Downlink Channel (UARFCN) , the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range:

  • 12, 37, 62, 87, 112, 137, 162, 187, 212, 237, 262, 287
  • 312 to 363
  • 387, 412, 437
  • 462 to 512
  • 782, 787, 807, 812, 837, 862
  • 937 - 1288, resolution = 1
  • 1312 - 1513, resolution = 1
  • 1662, 1687, 1712, 1737, 1762, 1787, 1812, 1837, 1862
  • 2012 - 2338, resolution = 1
  • 2362, 2387, 2412, 2437, 2462, 2487, 2512, 2537, 2562, 2587, 2612, 2637, 2662, 2687
  • 2712 - 2863, resolution = 1
  • 2887 - 3163, resolution = 1
  • 3187, 3212, 3237, 3262, 3287, 3312, 3337, 3362, 3387, 3412, 3437, 3462
  • 3487 - 3587, resolution = 1
  • 3612 - 3678, resolution = 1
  • 3702, 3707, 3732, 3737, 3762, 3767
  • 3792 - 3818, resolution = 1
  • 3842, 3867
  • 3892 - 3918, resolution = 1
  • 3942, 3967
  • 4132 - 4233, resolution = 1
  • 4287 to 4413
  • 8762 - 8912, resolution = 1
  • 9262 - 9538, resolution = 1
  • 9612 - 9888, resolution = 1

Query

 Same as setting

*RST Setting

 9780
Requirements

Test Application Revision A.11 and above.

Lab Application Revision D.02 and above.

Lab Application Revision: E.00.34 and above, added 3487 - 3587.

Test Application Revision A.14 and Lab Application Revision F.00 and above, added 3612 - 3678, 3702, 3707, 3732, 3737, 3762, 3767, 3792 - 3818, 3842, 3867, 3892 - 3918, 3942, 3967

Test Application Revision: A.18.00 and Lab Application Revision H.00.00 and above, added 312 to 363, 387, 412, 437, 4287 to 4413 and 462 to 512

Programming Example

OUTPUT 714;"CALL:SETup:RBReconfig:CHANnel:UPLink:CHANnel 9780"
! Sets the RBR uplink channel UARFCN to 9780.

CALL:SETup:RBReconfig:CHANnel:UPLink:CONTrol:AUTO

Function

Sets/queries the RBR Uplink Channel (UARFCN) control mode.

This setting is only applicable when RBR Channel (UARFCN) State is set to On .

  • Auto - RBR uplink UARFCN is determined by CALL:SETup:RBReconfig:CHANnel:DOWNlink .
  • Manual - RBR uplink UARFCN is determined by CALL:SETup:RBReconfig:CHANnel:UPLink:CHANnel .

The RBR uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:SETup:RBReconfig:CHANnel:UPLink[:CHANnel]? .

Setting

Range:

  • 1|ON (auto)
  • 0|OFF (manual)

Query

 Range: 1|0

*RST Setting

1 (auto)
Requirements

Test Application Revision A.11 and above.

Lab Application Revision D.02 and above.

Programming Example

OUTPUT 714;"CALL:SETup:RBReconfig:CHANnel:UPLink:CONTrol:AUTO ON"
! Sets RBR uplink control mode to auto.

CALL:SETup:RBReconfig:DPCHannel:BETA:AUTO

Function

Sets/queries RBR Uplink DPCH Bc/Bd Control .

ON = automatic
OFF = manual

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (auto)

Requirements

Test Application Revision: A.09 and above.

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:SETup:RBReconfig:DPCHannel:BETA:AUTO OFF"
! Sets RBR Uplink DPCH Bc/Bd Control to Manual.

CALL:SETup:RBReconfig:DPCHannel:DOFFset

Function

Sets/queries RBR Default DPCH Offset (DOFF) .

This command is only applicable when CALL:HANDoff:RBReconfig:CFNHandling is set to INITialise.

Setting

Range: 0 to 75

Resolution: 1

Query

 Same as setting

*RST Setting

 0 (0 x 512 chips)

Requirements

Test Application Revision: A.09 and above.
Lab Application Revision: C.04 or D.00.04 and above.
Test Application Revision: A.17.00 and above, extend the range from 5 to 75.
Lab Application Revision: G.01.00 and above, extend the range from 5 to 75.

Programming Example

OUTPUT 714;"CALL:SETup:RBReconfig:DPCHannel:DOFFset 3"
! Sets RBR Default DPCH Offset (DOFF) to 3 x 512 chips.

CALL:SETup:RBReconfig:DPCHannel:MANual:CBETa

Function

Sets/queries RBR Manual Uplink DPCH Bc .

This command is only applicable when CALL:SETup:RBReconfig:DPCHannel:BETA:AUTO is set to OFF (Manual).

Setting

Range: 1 to 15

Resolution: 1

Query

 Same as setting
*RST setting 8

Requirements

Test Application Revision: A.09 and above.

Lab Application Revision: C.04 or D.00.04 and above.

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, range is 1 to 15 (vs. 2 to 15)

Programming Example

OUTPUT 714;"CALL:SETup:RBReconfig:DPCHannel:MANual:CBETa 10"
! Sets RBR Manual Uplink DPCH Bc to 10.

CALL:SETup:RBReconfig:DPCHannel:MANual:DBETa

Function

Sets/queries RBR Manual Uplink DPCH Bd .

This command is only applicable when CALL:SETup:RBReconfig:DPCHannel:BETA:AUTO is set to OFF (Manual).

Setting

Range: 0 to 15

Resolution: 1

Query

 Same as setting
*RST setting 15

Requirements

Test Application Revision: A.09 and above.

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:SETup:RBReconfig:DPCHannel:MANual:DBETa 10"
! Sets RBR Manual Uplink DPCH Bd to 10.

CALL:SETup:RBReconfig:DPCHannel:RFOFfset

Function

Sets/queries RBR Relative DPCH Frame Offset .

This command is only applicable when CALL:HANDoff:RBReconfig:CFNHandling is set to MAINtain.

Setting

Range: -256, 0, 256

Query

 Same as setting

*RST Setting

 0 chips

Requirements

Test Application Revision: A.09 and above.

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:SETup:RBReconfig:DPCHannel:RFOFfset -256"
! Sets RBR Relative DPCH Frame Offset to -256 chips.

CALL:SETup:RBReconfig:DTCHannel:CRC[:PRESence]

Function

This command sets/queries the RBR Uplink DTCH RMC CRC Presence .

Setting

Range:

  • PRESent
  • DATa: (Used for Data)

Query

 Range: PRES|DAT
*RST Setting PRES
Requirements

Test Application Revision: A.09 and above.

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:SETup:RBReconfig:DTCHannel:CRC DATa"
! Sets RBR Uplink DTCH RMC CRC Presence to Used for Data.

CALL:SETup:RBReconfig:MS:LOOPback:TYPE

Function

Sets/queries the RBR UE Loopback Type .

Setting

Range: TYPE1|TYPE2

Query

 Same as setting.

*RST Setting

 TYPE1

Requirements

Test Application Revision: A.09 and above.

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:SETup:RBReconfig:MS:LOOPback:TYPE TYPE2"
! Sets RBR UE Loopback Type to Type 2.

CALL:SETup:RBReconfig:RBTest:RAB

Function

This command sets/queries the RB Test Mode RBR RAB .

Setting

Range:

  • RMC12 (12.2k RMC)
  • RMC64 (64k RMC)
  • RMC144 (144k RMC)
  • RMC384 (384k RMC)
  • RMC33NC (33k No Coding RMC)

Query

 Same as setting
*RST Setting RMC12
Requirements

Test Application Revision: A.09 and above.

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:SETup:RBReconfig:RBTest:RAB RMC64"
! Sets RB Test Mode RBR RAB to 64k RMC.

CALL:SETup:RBReconfig:UPLink:DCCHannel:DDATa

Function

Sets/queries the RBR Uplink Dummy DCCH Data state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 0 (off)

Requirements

Test Application Revision: A.09 and above.

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:SETup:RBReconfig:UPLink:DCCHannel:DDATa OFF"
! Sets RBR Uplink Dummy DCCH Data to Off

CALL:SETup[:HANDoff]:SYSTem[:TYPE]

Function

THIS COMMAND IS OBSOLETE. Please use the CALL:HANDoff:SYSTem[:GSM][:IMMediate] command to perform a system handoff.

Sets/queries the system type that the mobile station will be handed off to when the CALL:HANDoff command is used. The intersystem handoff can be performed only from W-CDMA to GSM.

This setting cannot be changed to GSM while the E1968A test applications (TA) are not present in the test set and licensed for operation. Attempting to change this setting while the E1968A TA is not available will result in an error message to alert you this condition.

Setting

Range: FDD|GSM

Query

Range: FDD|GSM

*RST Setting

 FDD
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:SETup:SYSTem GSM" !Selects GSM as the handoff system type.

CALL:SETup:SYSTem:GSM:ALERting[:STATe]

Function

Sets/queries RB Test Mode to GSM Handover Alerting State .

Setting

Range: 1|ON|0|OFF

Query

 1|0

*RST Setting

 1 (On)
Requirements

Test Application Revision: A.06 and above.

Lab Application Revision: C.01 and above.

Programming Example

OUTPUT 714;"CALL:SETup:SYSTem:GSM:ALERting OFF"
! Sets RB Test Mode to GSM Alerting State to Off (the UE will not ring).

CALL:SETup:TCReconfig:CHANnel:BARBitrator

Function

Sets/queries the TCR Band Arbitrator .

This setting is only applicable when TCR Downlink Channel (UARFCN) is set to a channel in Band VI.

This setting is only applicable when TCR Channel (UARFCN) State is set to On .

Setting

Range: BAND5|BAND6

Query

 Same as setting

*RST Setting

BAND6
Requirements

Test Application Revision A.11 and above.

Lab Application Revision D.02 and above.

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:CHANnel:BARBitrator BAND6"

CALL:SETup:TCReconfig:CHANnel:DOWNlink

Function

Sets/queries the TCR Downlink Channel (UARFCN) .

This setting is only applicable when TCR Channel (UARFCN) State is set to On .

If the entered TCR Downlink Channel (UARFCN) has an uplink/downlink offset of less than 30 MHz when compared with the TCR Uplink Channel (UARFCN) , the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range:

  • 412, 437, 462, 487, 512, 537, 562, 587, 612, 637, 662, 687
  • 712 to 763
  • 787, 812, 837
  • 862 to 912
  • 1007, 1012, 1032, 1037, 1062, 1087
  • 1162 - 1513, resolution = 1
  • 1537 - 1738, resolution = 1
  • 1887, 1912, 1937, 1962, 1987, 2012, 2037, 2062, 2087
  • 2237 - 2563, resolution = 1
  • 2587, 2612, 2637, 2662, 2687, 2712, 2737, 2762, 2787, 2812, 2837, 2862, 2887, 2912
  • 2937 - 3088, resolution = 1
  • 3112 - 3388, resolution = 1
  • 3412, 3437, 3462, 3487, 3512, 3537, 3562, 3587, 3612, 3637, 3662, 3687
  • 3837 - 3903, resolution = 1
  • 3927, 3932, 3957, 3962, 3987, 3992
  • 4017 - 4043, resolution = 1
  • 4067, 4092
  • 4117 - 4143, resolution = 1
  • 4167, 4192
  • 4357 - 4458, resolution = 1
  • 4512 to 4638
  • 9237 - 9387, resolution = 1
  • 9662 - 9938, resolution = 1
  • 10562 - 10838, resolution = 1

Query

 Same as setting

*RST Setting

10730
Requirements

Test Application Revision A.11 and above.

Lab Application Revision D.02 and above.

Test Application Revision A.14 and Lab Application Revision F.00, added 3837 - 3903, 3927, 3932, 3957, 3962, 3987, 3992, 4017 - 4043, 4067, 4092, 4117 - 4143, 4167, 4192

Test Application Revision A.18.00 and Lab Application Revision H.00.00 and above, added 712 to 763, 787, 812, 837, 4512 to 4638 and 862 to 912

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:CHANnel:DOWNlink 10730"

CALL:SETup:TCReconfig:CHANnel:UPLink[:MCHannel]

Function

The setting form of this command performs two functions: (1) sets TCR Uplink Channel (UARFCN) to a specific UARFCN (see CALL:SETup:TCReconfig:CHANnel:UPLink:CHANnel ), and (2) sets TCR uplink channel control to off (manual) (see CALL:SETup:TCReconfig:CHANnel:UPLink:CONTrol:AUTO ).

The query form of this command returns the TCR uplink UARFCN that is used by the test set when CALL:SETup:TCReconfig:CHANnel:UPLink:CONTrol:AUTO is set to off (manual). Note, when CALL:SETup:TCReconfig:CHANnel:UPLink:CONTrol:AUTO is set to on (auto), the TCR uplink UARFCN used by the test set is determined by CALL:SETup:TCReconfig:CHANnel:DOWNlink .

This setting is only applicable when TCR Channel (UARFCN) State is set to On .

The TCR uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:SETup:TCReconfig:CHANnel:UPLink[:CHANnel]? .

If the entered TCR Uplink Channel (UARFCN) has an uplink/downlink offset of less than 30 MHz when compared with the TCR Downlink Channel (UARFCN) , the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range: see CALL:SETup:TCReconfig:CHANnel:UPLink:CHANnel

Query

 Same as setting

*RST Setting

TCR uplink UARFCN = 9780, TCR uplink channel control = on (auto)
Requirements

Test Application Revision A.11 and above.

Lab Application Revision D.02 and above.

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:CHANnel:UPLink 9780"
! Sets the TCR uplink channel UARFCN to 9780 and selects manual control mode
! for TCR uplink channel.

CALL:SETup:TCReconfig:CHANnel:UPLink:CHANnel

Function

The setting form of this command sets TCR Uplink Channel (UARFCN) to a specific UARFCN.

This setting is only applicable when TCR Channel (UARFCN) State is set to On .

Note, this TCR uplink UARFCN is only used by the test set when CALL:SETup:TCReconfig:CHANnel:UPLink:CONTrol:AUTO is set to off (manual). When CALL:SETup:TCReconfig:CHANnel:UPLink:CONTrol:AUTO is set to on (auto), the TCR uplink UARFCN used by the test set is determined by CALL:SETup:TCReconfig:CHANnel:DOWNlink .

The query form of this command returns the TCR uplink UARFCN that is used by the test set when CALL:SETup:TCReconfig:CHANnel:UPLink:CONTrol:AUTO is set to off (manual).

The TCR uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:SETup:TCReconfig:CHANnel:UPLink[:CHANnel]? .

If the entered TCR Uplink Channel (UARFCN) has an uplink/downlink offset of less than 30 MHz when compared with the TCR Downlink Channel (UARFCN) , the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range:

  • 12, 37, 62, 87, 112, 137, 162, 187, 212, 237, 262, 287
  • 312 to 363
  • 387, 412, 437
  • 462 to 512
  • 782, 787, 807, 812, 837, 862
  • 937 - 1288, resolution = 1
  • 1312 - 1513, resolution = 1
  • 1662, 1687, 1712, 1737, 1762, 1787, 1812, 1837, 1862
  • 2012 - 2338, resolution = 1
  • 2362, 2387, 2412, 2437, 2462, 2487, 2512, 2537, 2562, 2587, 2612, 2637, 2662, 2687
  • 2712 - 2863, resolution = 1
  • 2887 - 3163, resolution = 1
  • 3187, 3212, 3237, 3262, 3287, 3312, 3337, 3362, 3387, 3412, 3437, 3462
  • 3487 - 3587, resolution = 1
  • 3612 - 3678, resolution = 1
  • 3702, 3707, 3732, 3737, 3762, 3767
  • 3792 - 3818, resolution = 1
  • 3842, 3867
  • 3892 - 3918, resolution = 1
  • 3942, 3967
  • 4132 - 4233, resolution = 1
  • 4287 to 4413
  • 8762 - 8912, resolution = 1
  • 9262 - 9538, resolution = 1
  • 9612 - 9888, resolution = 1

Query

 Same as setting

*RST Setting

 9780
Requirements

Test Application Revision A.11 and above.

Lab Application Revision D.02 and above.

Lab Application Revision: E.00.34 and above, added 3487 - 3587.

Test Application Revision A.14 and Lab Application Revision F.00 and above, added 3612 - 3678, 3702, 3707, 3732, 3737, 3762, 3767, 3792 - 3818, 3842, 3867, 3892 - 3918, 3942, 3967

Test Application Revision: A.18.00 and Lab Application Revision H.00.00 and above, added 312 to 363, 387, 412, 437, 4287 to 4413 and 462 to 512

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:CHANnel:UPLink:CHANnel 9780"
! Sets the TCR uplink channel UARFCN to 9780.

CALL:SETup:TCReconfig:CHANnel:UPLink:CONTrol:AUTO

Function

Sets/queries the TCR Uplink Channel (UARFCN) control mode.

This setting is only applicable when TCR Channel (UARFCN) State is set to On .

  • Auto - TCR uplink UARFCN is determined by CALL:SETup:TCReconfig:CHANnel:DOWNlink .
  • Manual - TCR uplink UARFCN is determined by CALL:SETup:TCReconfig:CHANnel:UPLink:CHANnel .

The TCR uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:SETup:TCReconfig:CHANnel:UPLink[:CHANnel]? .

Setting

Range:

  • 1|ON (auto)
  • 0|OFF (manual)

Query

 Range: 1|0

*RST Setting

1 (auto)
Requirements

Test Application Revision A.11 and above.

Lab Application Revision D.02 and above.

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:CHANnel:UPLink:CONTrol:AUTO ON"
! Sets TCR uplink control mode to auto.

CALL:SETup:TCReconfig:DPCHannel:BETA:AUTO

Function

Sets/queries TCR DPCH Bc/Bd Control .

Setting

Range: 1|ON|0|OFF

Query

 1|0

*RST Setting

 1 (auto)
Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:DPCHannel:BETA:AUTO OFF"
! Sets TCR DPCH Bc/Bd Control to Manual.

CALL:SETup:TCReconfig:DPCHannel:DOFFset

Function

Sets/queries TCR Default DPCH Offset (DOFF) .

This command is only applicable when CALL:HANDoff:TCReconfig:CFNHandling is set to INITialise.

Setting

Range: 0 to 75

Resolution: 1

Query

 Same as setting

*RST Setting

 0 (0 x 512 chips)

Requirements

Test Application Revision: A.09 and above
Lab Application Revision: C.04 and above
Lab Application Revision: D.00 and above
Test Application Revision: A.17.00 and above, extend the range from 5 to 75
Lab Application Revision: G.01.00 and above, extend the range from 5 to 75

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:DPCHannel:DOFFset 3"
! Sets TCR Default DPCH Offset (DOFF) to 3 x 512 chips.

CALL:SETup:TCReconfig:DPCHannel:MANual:CBETa

Function

Sets/queries TCR Manual Uplink DPCH Bc .

This command is only applicable when CALL:SETup:TCReconfig:DPCHannel:BETA:AUTO is set to MANual.

Setting

Range: 1 to 15

Resolution: 1

Query

 Same as setting

*RST Setting

 8
Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 and above

Lab Application Revision: D.00, range is 1 to 15 (but 1 is not recommended)

Lab Application Revision D.01, range is 2 to 15

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, range is 1 to 15 (vs. 2 to 15)

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:DPCHannel:MANual:CBETa 15"
! Sets TCR Manual Uplink DPCH Bc to 15.

CALL:SETup:TCReconfig:DPCHannel:MANual:DBETa

Function

Sets/queries TCR Manual Uplink DPCH Bd .

This command is only applicable when CALL:SETup:TCReconfig:DPCHannel:BETA:AUTO is set to MANual.

Setting

Range: 0 to 15

Resolution: 1

Query

 Same as setting

*RST Setting

 15
Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:DPCHannel:MANual:DBETa 8"
! Sets TCR Manual Uplink DPCH Bd to 8.

CALL:SETup:TCReconfig:DPCHannel:RFOFfset

Function

Sets/queries TCR Relative DPCH Frame Offset .

This command is only applicable when CALL:HANDoff:TCReconfig:CFNHandling is set to MAINtain.

Setting

Range: -256, 0, 256

Query

 Same as setting

*RST Setting

 0 chips

Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:DPCHannel:RFOFfset -256"
! Sets TCR Relative DPCH Frame Offset to -256 chips.

CALL:SETup:TCReconfig:EDCHannel:QAM16[:STATE]

Function

Sets/queries the TCR 16QAM State .

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

0

Requirements

Test Application Revision: A.17.00 and above

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:EDCHannel:QAM16 1"
! Sets the 16QAM State to On.

CALL:SETup:TCReconfig:EDPCchannel[:DPCChannel]:POFFset

Function

Sets/queries the TCR E-DPCCH/DPCCH Power Offset .

Setting

Range: 0 to 8

Resolution: 1

Query

 Same as setting.

*RST Setting

0

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:EDPCchannel:POFFset 0"
! Sets the TCR E-DPCCH/DPCCH Power Offset to 0.

CALL:SETup:TCReconfig:ETFCi:POFFsets:REFerence

Function

Sets/queries the TCR Reference E-TFCI Power Offsets .

Setting

Range: DEF3410801|DEF3410802|DEF3412101|DEF3412102|DEF3412103|DEF3412104

Query

 Same as setting.

*RST Setting

DEF3410802

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Test Application Revision: A.17 and above: Added DEF3412103 and DEF3412104

Lab Application Revision: G.01.00 and above: Added DEF3412103 and DEF3412104

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:ETFCi:POFFsets:REFerence DEF3410802"
! Sets the TCR Reference E-TFCI Power Offsets to Def 34108-02.

CALL:SETup:TCReconfig:HARQ:PROCess:COUNt

Function

Sets/queries TCR Number of HARQ Processes .

Setting

Range: 1 to 8

Resolution: 1

Query

 Same as setting

*RST Setting

 2

Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:HARQ:PROCess:COUNt 1"
! Sets TCR Number of HARQ Processes to 1.

CALL:SETup:TCReconfig:MPOWer[:MOFFset]

Function

Sets/queries the TCR Measurement Power Offset .

This parameter can only be set either while the call status is Idle .

This setting only applies when "CALL:SETup:TCReconfig:MPOWer:OFFSet:CONTrol:AUTO" on page 242 is set to OFF (manual).

Setting

Range: -6.0 to +13.0 dB

Resolution: 0.1

Query

Range: -6.0 to +13.0 dB, 9.91E+37

Resolution: 0.5

*RST Setting

 -6 dB

Requirements

Lab Application Revision E.00.16 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:MPOWer -6"
! Sets the TCR Measurement Power Offset to -6 dB.

CALL:SETup:TCReconfig:MPOWer:OFFSet:CONTrol:AUTO

Function

Sets/queries the automatic control state for the TCR Measurement Power Offset parameter.

ON = automatic

OFF = manual (see "CALL:SETup:TCReconfig:MPOWer[:MOFFset]" on page 240 or "CALL:SETup:TCReconfig:MPOWer:OFFSet:MANual" on page 242 )

This parameter can only be set either while the call status is Idle .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision E.00.16 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:MPOWer:OFFSet:CONTrol:AUTO 0"
! Sets the TCR Measurement Power Offset control state to manual.

CALL:SETup:TCReconfig:MPOWer:OFFSet:MANual

Function

Sets/queries the TCR Measurement Power Offset .

This parameter can only be set either while the call status is Idle .

This setting only applies when "CALL:SETup:TCReconfig:MPOWer:OFFSet:CONTrol:AUTO" on page 242 is set to OFF (manual).

Setting

Range: -6.0 to +13.0 dB

Resolution: 0.5

Query

Range: -6.0 to +13.0 dB, 9.91E+37

Resolution: 0.5

*RST Setting

 -6 dB

Requirements

Lab Application Revision E.00.16 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:MPOWer:OFFSet:MANual -6"
! Sets the TCR Measurement Offset Power to -6 dB.

CALL:SETup:TCReconfig:MS:IREDundancy:BUFFer:ALLocation

Function

Sets/queries TCR UE IR Buffer Allocation .

Setting

Range: IMPLicit|EXPLicit

Query

 Same as setting

*RST Setting

 IMPL

Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:MS:IREDundancy:BUFFer:ALLocation EXPLicit"
! Sets TCR UE IR Buffer Allocation to Explicit.

CALL:SETup:TCReconfig:MS:IREDundancy:BUFFer:SIZe[:EXPLicit]

Function

Sets/queries TCR Explicit UE IR Buffer Size .

This setting is only applicable when CALL:SETup:TCReconfig:MS:IREDundancy:BUFFer:ALLocation is set to EXPLicit.

Setting

Range: 800, 1600, 2400, 3200, 4000, 4800, 5600, 6400, 7200, 8000, 8800, 9600, 10400, 11200, 12000, 12800, 13600, 14400, 15200, 16000, 17600, 19200, 20800, 22400, 24000, 25600, 27200, 28800, 30400, 32000, 36000, 40000, 44000, 48000, 52000, 56000, 60000, 64000, 68000, 72000, 76000, 80000, 88000, 96000, 104000, 112000, 120000, 128000, 136000, 144000, 152000, 160000, 176000, 192000, 208000, 224000, 240000, 256000, 272000, 288000, 304000

Query

 Same as setting

*RST Setting

 19200

Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:MS:IREDundancy:BUFFer:SIZe 9600"
! Sets TCR Explicit UE IR Buffer Size to 9600.

CALL:SETup:TCReconfig:RBTest:EDPDchannel:CCODes:MAX[:HSPARMC12]

Function

Sets/queries the RB TCR E-DPDCH Max Channelisation Codes.

Setting

Range: SF256|SF128| SF64| SF32| SF16|SF8| SF4|TSF4|TSF2

Query

 Same as setting

*RST Setting

 TSF2
Requirements

Test Application Revision: A.18.00 and Lab Application Revision H.00.00 and above.

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:RBTest:EDPDchannel:CCODes:MAX TSF4"
! Sets the to 2SF4.

CALL:SETup:TCReconfig:RBTest:EDPDchannel:CCODes:MAX:HSPA

Function

Sets/queries the RB TCR E-DPDCH Max Channelisation Codes (HSPA Only).

Setting

Range: SF256|SF128| SF64| SF32| SF16|SF8| SF4|TSF4|TSF2|T2T4

Query

 Same as setting

*RST Setting

 T2T4
Requirements

Test Application Revision: A.18.00 and Lab Application Revision H.00.00 and above.

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:RBTest:EDPDchannel:CCODes:MAX:HSPA T2T4"
! Sets the RB TCR E-DPDCH Max Channelisation Codes (HSPA Only) to 2sf2+2sf4.

CALL:SETup:TCReconfig:RBTest:RAB

Function

Sets/queries the RB Test Mode TCR RAB .

Setting

Range:

  • RMC12 (12.2k RMC)
  • RMC64 (64k RMC)
  • RMC144 (144k RMC)
  • RMC384 (384k RMC)
  • RMC33NC (33k No Coding RMC)

Query

 Same as setting

*RST Setting

 RMC12
Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:RBTest:RAB RMC64"
! Sets the handover RB test mode RAB to 64k RMC.

CALL:SETup:TCReconfig:SGRant:ABSolute:QAM16[:VALue]

Function

Sets/queries the TCR Absolute Grant (16QAM) .

Setting

Range: ZGRant|INDex0|INDex1|INDex2|INDex3...|INDex37|INDex38

Query

 Same as setting.

*RST Setting

IND37: (377/15) 2 *4

Requirements

Test Application Revision: A.17.00 and above
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:SGRant:ABSolute:QAM16 INDex36"
! Sets the TCR Absolute Grant 16QAM to 37:4(377/15)^2.

CALL:SETup:TCReconfig:SGRant:ABSolute[:VALue]

Function

Sets/queries the TCR Absolute Grant .

Setting

Range: ZGRant|INDex0|INDex1|INDex2|INDex3...|INDex37

Query

 Same as setting.

*RST Setting

IND37

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:SGRant:ABSolute INDex37"
! Sets the TCR Absolute Grant to 37:6(168)^2.

CALL:SETup:TCReconfig:UPLink:ANACk:RFACtor

Function

 Sets/queries TCR Ack-Nack Repetition Factor .

Setting

Range: 1 to 4

Resolution: 1

Query

 Same as setting

*RST Setting

 1

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:UPLink:ANACk:RFACtor 3"
! Sets TCR Ack-Nack Repetition Factor to 3.

CALL:SETup:TCReconfig:UPLink:CQI:FCYCle

Function

 Sets/queries TCR CQI Feedback Cycle (k) . TCR CQI Feedback Cycle (k) must be greater than or equal to TCR CQI Repetition Factor * 2ms (except for the case when TCR CQI Feedback Cycle (k) equals 0 ms). See CALL:SETup:TCReconfig:UPLink:CQI:RFACtor .

Setting

Range: 0, 2, 4, 6, 8, 10, 20, 40, 80, 160 ms

Query

 Same as setting

*RST Setting

 0.002 seconds (2 ms)

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:UPLink:CQI:FCYCle 4MS"
! Sets TCR CQI Feedback Cycle (k) to 4 ms.

CALL:SETup:TCReconfig:UPLink:CQI:RFACtor

Function

 Sets/queries TCR CQI Repetition Factor . TCR CQI Feedback Cycle (k) must be greater than or equal to TCR CQI Repetition Factor * 2ms (except for the case when TCR CQI Feedback Cycle (k) equals 0 ms). See CALL:SETup:TCReconfig:UPLink:CQI:FCYCle .

Setting

Range: 1 to 4

Resolution: 1

Query

 Same as setting

*RST Setting

 1

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:UPLink:CQI:RFACtor 2"
! Sets TCR CQI Repetition Factor to 2.

CALL:SETup:TCReconfig:UPLink:DACK

Function

 Sets/queries TCR DeltaACK .

Setting

Range: 0 to 8

Resolution: 1

Query

 Same as setting

*RST Setting

 3

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:UPLink:DACK 8"
! Sets TCR DeltaACK to 8.

CALL:SETup:TCReconfig:UPLink:DCQI

Function

 Sets/queries TCR DeltaCQI .

Setting

Range: 0 to 8

Resolution: 1

Query

 Same as setting

*RST Setting

 5

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:UPLink:DCQI 7"
! Sets TCR DeltaCQI to 7.

CALL:SETup:TCReconfig:UPLink:DNACk

Function

 Sets/queries TCR DeltaNACK .

Setting

Range: 0 to 8

Resolution: 1

Query

 Same as setting

*RST Setting

 3

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:SETup:TCReconfig:UPLink:DNACk 8"
! Sets TCR DeltaNACK to 8.


CALL:SRBearer

CALL:SRBearer

Last updated: January 16, 2009

GPIB Command Conventions

  • CALL[:CELL]:SRBearer:CCHannel:DEDicated:BPS3400[:CCODe]
  • CALL[:CELL]:SRBearer:CCHannel:DEDicated:DRATe[:MANual]
  • CALL[:CELL]:SRBearer:CCHannel:DEDicated:DRATe:CONTrol:AUTO
  • CALL[:CELL]:SRBearer:GTRans

CALL[:CELL]:SRBearer:CCHannel:DEDicated:BPS3400[:CCODe]

Function

Sets/queries the downlink dedicated physical channel's (DPCH) channelization code during the "setup" phase of connection setup when CALL[:CELL]:SRBearer:CCHannel:DEDicated:DRATe[:MANual] is set to BPS3400 or BPS2200.

When CALL[:CELL]:SRBearer:CCHannel:DEDicated:DRATe[:MANual] is set to BPS13600, the DPCH channelization code will be determined by the UTRA FDD DL DPCH 12.2 RMC channelization code ( CALL:DPCHannel:RMC12:CCODe ).

See Signalling Radio Bearer (SRB) Parameters .

This setting cannot be changed while the active cell operating mode. Attempting to change this setting while in this mode will result in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode to change this setting.

To set the DPCH channelization code for the SRB when using the Lab Application, see CALL:DPCHannel:KSPS15[:CCODe] and CALL:DPCHannel:KSPS30[:CCODe] .

Setting

Range:

CODE12|CODE13CODE20|CODE21|CODE40|CODE43|CODE58|CODE126|CODE127|
CODE142|CODE153|CODE174|CODE235|CODE255

Query

 Same as setting

*RST Setting

CODE12

Requirements

Test Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:CELL:SRBearer:CCHannel:DEDicated:BPS3400:CCODE CODE58"

CALL[:CELL]:SRBearer:CCHannel:DEDicated:DRATe[:MANual]

Function

Sets/queries Manual SRB Configuration .

This setting is only applicable when CALL[:CELL]:SRBearer:CCHannel:DEDicated:DRATe:CONTrol:AUTO is set to Off (manual).

This setting cannot be changed in Active Cell Operating Mode.

Setting

Range: BPS2200|BPS3400|BPS13600

Query

Same as setting

*RST Setting

BPS3400

Requirements

Test or Lab Application Revision: A.01 and above.

Test Application Revision A.03 added BPS2200 setting.

Test Application Revision A.10.01 and Lab Application Revision D.01.01 added [:MANual]

Programming Example

OUTPUT 714;"CALL:CELL:SRBEARER:CCHANNEL:DEDICATED:DRATE BPS13600"
! Sets Manual SRB Configuration to 13.6K DCCH.

CALL[:CELL]:SRBearer:CCHannel:DEDicated:DRATe:CONTrol:AUTO

Function

Sets/queries SRB Configuration Control . When set to Off (manual), use the CALL[:CELL]:SRBearer:CCHannel:DEDicated:DRATe[:MANual] command to set the Manual SRB Configuration .

This setting cannot be changed in Active Cell Operating Mode.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (manual)

Requirements

Test Application Revision A.10.01 and above

Lab Application Revision D.01.01 and above

Programming Example

OUTPUT 714;"CALL:SRBearer:CCHannel:DEDicated:DRATe:CONTrol:AUTO ON"
! Sets SRB Configuration Control to Auto.

CALL[:CELL]:SRBearer:GTRans

Function

Sets/queries the SRB Transmission Grant configuration.

This setting cannot be changed when the cell operating mode is Active Cell and the call status is not IDLE. If you attempt to change this setting when the cell operating mode is Active Cell and the call status is not IDLE, the test set will reject the change and an error will be reported.

Setting

Range: SCHeduled|NSCHeduled

Query

Range: SCH|NSCH

*RST Setting

NSCHeduled)

Requirements

Lab Application Revision E.00.34 and above

Programming Example

OUTPUT 714;"CALL:SRBearer:GTRans NSCHeduled"
! Sets the SRB configuration to non-scheduled transmission.


CALL:SSCell

CALL:SSCell

Last updated: January 8, 2012

This topic is only applicable to the lab application.

GPIB Command Conventions

  • CALL:SSCell:CHANnel:ADJacent

  • CALL:SSCell:CONNected:CPIChannel:LEVel:HSDPa
  • CALL:SSCell:CONNected:CPIChannel:STATe:HSDPa
  • CALL:SSCell:CONNected:CPIChannel[:SLEVel]:HSDPa
  • CALL:SSCell:CONNected:CPIChannel:LEVel:HSPA
  • CALL:SSCell:CONNected:CPIChannel[:SLEVel]:HSPA
  • CALL:SSCell:CONNected:CPIChannel:STATe:HSPA
  • CALL:SSCell:CONNected:CCPChannel:PRIMary:LEVel:HSDPa
  • CALL:SSCell:CONNected:CCPChannel:PRIMary:STATe:HSDPa
  • CALL:SSCell:CONNected:CCPChannel:PRIMary[:SLEVel]:HSDPa
  • CALL:SSCell:CONNected:CCPChannel:PRIMary:LEVel:HSPA
  • CALL:SSCell:CONNected:CCPChannel:PRIMary:STATe:HSPA
  • CALL:SSCell:CONNected:CCPChannel:PRIMary[:SLEVel]:HSPA
  • CALL:SSCell:CONNected:PICHannel:LEVel:HSDPa
  • CALL:SSCell:CONNected:PICHannel:STATe:HSDPa
  • CALL:SSCell:CONNected:PICHannel[:SLEVel]:HSDPa
  • CALL:SSCell:CONNected:PICHannel:LEVel:HSPA
  • CALL:SSCell:CONNected:PICHannel:STATe:HSPA
  • CALL:SSCell:CONNected:PICHannel[:SLEVel]:HSPA
  • CALL:SSCell:CONNected:HSPDschannel:LEVel:HSDPa
  • CALL:SSCell:CONNected:HSPDschannel:STATe:HSDPa
  • CALL:SSCell:CONNected:HSPDschannel[:SLEVel]:HSDPa
  • CALL:SSCell:CONNected:HSPDschannel:LEVel:HSPA
  • CALL:SSCell:CONNected:HSPDschannel:STATe:HSPA
  • CALL:SSCell:CONNected:HSPDschannel[:SLEVel]:HSPA
  • CALL:SSCell:CONNected:HSSCchannel[1]:LEVel:HSDPa
  • CALL:SSCell:CONNected:HSSCchannel[1]:STATe:HSDPa
  • CALL:SSCell:CONNected:HSSCchannel[1][:SLEVel]:HSDPa
  • CALL:SSCell:CONNected:HSSCchannel[1]:LEVel:HSPA
  • CALL:SSCell:CONNected:HSSCchannel[1]:STATe:HSPA
  • CALL:SSCell:CONNected:HSSCchannel[1][:SLEVel]:HSPA
  • CALL:SSCell:CONNected:HSSCchannel2:LEVel:HSDPa
  • CALL:SSCell:CONNected:HSSCchannel2:STATe:HSDPa
  • CALL:SSCell:CONNected:HSSCchannel2[:SLEVel]:HSDPa
  • CALL:SSCell:CONNected:HSSCchannel2:LEVel:HSPA
  • CALL:SSCell:CONNected:HSSCchannel2:STATe:HSPA
  • CALL:SSCell:CONNected:HSSCchannel2[:SLEVel]:HSPA
  • CALL:SSCell:CONNected:HSSCchannel3:LEVel:HSDPa
  • CALL:SSCell:CONNected:HSSCchannel3:STATe:HSDPa
  • CALL:SSCell:CONNected:HSSCchannel3[:SLEVel]:HSDPa
  • CALL:SSCell:CONNected:HSSCchannel3:LEVel:HSPA
  • CALL:SSCell:CONNected:HSSCchannel3:STATe:HSPA
  • CALL:SSCell:CONNected:HSSCchannel3[:SLEVel]:HSPA
  • CALL:SSCell:CONNected:HSSCchannel4:LEVel:HSDPa
  • CALL:SSCell:CONNected:HSSCchannel4:STATe:HSDPa
  • CALL:SSCell:CONNected:HSSCchannel4[:SLEVel]:HSDPa
  • CALL:SSCell:CONNected:HSSCchannel4:LEVel:HSPA
  • CALL:SSCell:CONNected:HSSCchannel4:STATe:HSPA
  • CALL:SSCell:CONNected:HSSCchannel4[:SLEVel]:HSPA

  • CALL:SSCell:HSSCchannel1:CCODe:CODE
  • CALL:SSCell:HSSCchannel2:CCODe:CODE
  • CALL:SSCell:HSSCchannel3:CCODe:CODE
  • CALL:SSCell:HSSCchannel4:CCODe:CODE
  • CALL:SSCell:HSSChannel[1]:CONFig:STATe
  • CALL:SSCell:HSSChannel2:CONFig:STATe
  • CALL:SSCell:HSSChannel3:CONFig:STATe
  • CALL:SSCell:HSSChannel4:CONFig:STATe

  • CALL:SSCell:OCNSource:CCODe:CODE
  • CALL:SSCell:OCNSource:CONFig:STATe:HSDPa
  • CALL:SSCell:OCNSource:LEVel?
  • CALL:SSCell:OCNSource:POFFset:HSDPa
  • CALL:SSCell:OCNSource:STATe?

  • CALL:SSCell:PICHannel:CCODe:CODE
  • CALL:SSCell:POWer[:SAMPLitude]
  • CALL:SSCell:POWer:AMPLitude
  • CALL:SSCell:POWer:STATe
  • CALL:SSCell:SCODe[:PRIMary]
  • CALL:SSCell:TOTal:POWer[:AMPLitude]?
  • CALL:SSCell:TOTal:POWer:STATe?

CALL:SSCell:CHANnel:ADJacent

Function

Sets/queries the downlink UARFCN of the secondary serving cell.

In 3GPP Rel'8, the UARFCN of the secondary serving cell must be adjacent to the serving cell.

The DL UARFCN of the secondary serving cell must be in same frequency range with the currently active band.

This setting is only allowed to change when the Call Status is Idle .

Setting

Range: HIGHer | LOWer

Query

 Range: HIGH | LOW

*RST Setting

 HIGHer

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CHANnel:ADJacent HIGHer"

CALL:SSCell:CONNected:CPIChannel:LEVel:HSDPa

Function

Sets/queries the UTRA FDD (HSDPA) Secondary Serving Cell Connected CPICH Power Offset.

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -10

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:CPIChannel:LEVel:HSDPa -10"

CALL:SSCell:CONNected:CPIChannel:STATe:HSDPa

Function

Sets/queries the UTRA FDD (HSDPA) Secondary Serving Cell Connected CPICH State.

Setting

Range: 1|ON|0|OFF

Query

Same as setting

*RST Setting

 1|ON

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:CPIChannel:STATe:HSDPa On"

CALL:SSCell:CONNected:CPIChannel[:SLEVel]:HSDPa

Function

 The setting form of this command performs two functions: (1) sets the UTRA FDD (HSDPA) Secondary Serving Cell Connected CPICH Power Offset (see CALL:SSCell:CONNected:CPIChannel:LEVel:HSDPa ) and (2) sets the UTRA FDD (HSDPA) Secondary Serving Cell Connected CPICH State to on (see CALL:SSCell:CONNected:CPIChannel:STATe:HSDPa ).

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -10

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:CPIChannel:HSDPa -10"

CALL:SSCell:CONNected:CPIChannel:LEVel:HSPA

Function

Sets/queries the UTRA FDD (HSPA) Secondary Serving Cell Connected CPICH Power Offset

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -10

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:CPIChannel:LEVel:HSPA -10"

CALL:SSCell:CONNected:CPIChannel[:SLEVel]:HSPA

Function

 The setting form of this command performs two functions: (1) sets the UTRA FDD (HSPA) Secondary Serving Cell Connected CPICH Power Offset (see CALL:SSCell:CONNected:CPIChannel:LEVel:HSPA ) and (2) sets the UTRA FDD (HSPA) Secondary Serving Cell Connected CPICH State to on (see CALL:SSCell:CONNected:CPIChannel[:SLEVel]:HSPA ).

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -10

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:CPIChannel:HSPA -10"

CALL:SSCell:CONNected:CPIChannel:STATe:HSPA

Function

Sets/queries the UTRA FDD (HSPA) Secondary Serving Cell Connected CPICH State.

Setting

Range: 1|ON|0|OFF

Query

Same as setting

*RST Setting

 1|ON

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:CPIChannel:STATe:HSPA On"

CALL:SSCell:CONNected:CCPChannel:PRIMary:LEVel:HSDPa

Function

Sets/queries the UTRA FDD (HSDPA) Secondary Serving Cell Connected P-CCPCH/SCH Power Offset.

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -12

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:CCPChannel:PRIMary:LEVel:HSDPa -12"

CALL:SSCell:CONNected:CCPChannel:PRIMary:STATe:HSDPa

Function

Sets/queries the UTRA FDD (HSDPA) Secondary Serving Cell Connected P-CCPCH/SCH State

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 1 (ON)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:CCPChannel:PRIMary:STATe:HSDPa On"

CALL:SSCell:CONNected:CCPChannel:PRIMary[:SLEVel]:HSDPa

Function

 The setting form of this command performs two functions: (1) sets the UTRA FDD (HSDPA) Secondary Serving Cell Connected P-CCPCH/SCH Power Offset (see CALL:SSCell:CONNected:CCPChannel:PRIMary:LEVel:HSDPa ) and (2) sets the UTRA FDD (HSDPA) Secondary Serving Cell Connected P-CCPCH/SCH State to on (see CALL:SSCell:CONNected:CCPChannel:PRIMary:STATe:HSDPa ).

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -12

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:CCPChannel:PRIMary:HSDPa -12"

CALL:SSCell:CONNected:CCPChannel:PRIMary:LEVel:HSPA

Function

Sets/queries the UTRA FDD (HSPA) Secondary Serving Cell Connected P-CCPCH/SCH Power Offset.

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -12

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:CCPChannel:PRIMary:LEVel:HSPA -12"

CALL:SSCell:CONNected:CCPChannel:PRIMary:STATe:HSPA

Function

Sets/queries the UTRA FDD (HSPA) Secondary Serving Cell Connected P-CCPCH/SCH State.

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 1 (ON)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:CCPChannel:PRIMary:STATe:HSPA On"

CALL:SSCell:CONNected:CCPChannel:PRIMary[:SLEVel]:HSPA

Function

 The setting form of this command performs two functions: (1) sets the UTRA FDD (HSPA) Secondary Serving Cell Connected P-CCPCH/SCH Power Offset (see CALL:SSCell:CONNected:CCPChannel:PRIMary:LEVel:HSPA ) and (2) sets the UTRA FDD (HSPA) Secondary Serving Cell Connected P-CCPCH/SCH State to on (see CALL:SSCell:CONNected:CCPChannel:PRIMary:STATe:HSPA ).

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -12

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:CCPChannel:PRIMary:HSPA -12"

CALL:SSCell:CONNected:PICHannel:LEVel:HSDPa

Function

Sets/queries the UTRA FDD (HSDPA) Secondary Serving Cell Connected PICH Power Offset.

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -15

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:PICHannel:LEVel:HSDPa -15"

CALL:SSCell:CONNected:PICHannel:STATe:HSDPa

Function

Sets/queries the UTRA FDD (HSDPA) Secondary Serving Cell Connected PICH State.

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 1 (ON)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:PICHannel:STATe:HSDPa On"

CALL:SSCell:CONNected:PICHannel[:SLEVel]:HSDPa

Function

 The setting form of this command performs two functions: (1) sets the UTRA FDD (HSDPA) Secondary Serving Cell Connected PICH Power Offset (see CALL:SSCell:CONNected:PICHannel:LEVel:HSDPa ) and (2) sets the UTRA FDD (HSDPA) Secondary Serving Cell Connected PICH State to on (see CALL:SSCell:CONNected:PICHannel:STATe:HSDPa ).

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -15

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:PICHannel:HSDPa -15"

CALL:SSCell:CONNected:PICHannel:LEVel:HSPA

Function

Sets/queries the UTRA FDD (HSPA) Secondary Serving Cell Connected PICH Power Offset

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -15

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:PICHannel:LEVel:HSPA -15"

CALL:SSCell:CONNected:PICHannel:STATe:HSPA

Function

Sets/queries the UTRA FDD (HSPA) Secondary Serving Cell Connected PICH State.

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 1 (ON)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:PICHannel:STATe:HSPA On"

CALL:SSCell:CONNected:PICHannel[:SLEVel]:HSPA

Function

 The setting form of this command performs two functions: (1) sets the UTRA FDD (HSPA) Secondary Serving Cell Connected PICH Power Offset (see CALL:SSCell:CONNected:PICHannel:LEVel:HSPA ) and (2) sets the UTRA FDD (HSPA) Secondary Serving Cell Connected PICH State to on (see CALL:SSCell:CONNected:PICHannel:STATe:HSPA ).

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -15

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:PICHannel:HSPA -15"

CALL:SSCell:CONNected:HSPDschannel:LEVel:HSDPa

Function

Sets/queries the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-PDSCH Power Offset

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -3

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSPDschannel:LEVel:HSDPa -3"

CALL:SSCell:CONNected:HSPDschannel:STATe:HSDPa

Function

Sets/queries the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-PDSCH State

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 1 (ON)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSPDschannel:STATe:HSDPa On"

CALL:SSCell:CONNected:HSPDschannel[:SLEVel]:HSDPa

Function

 The setting form of this command performs two functions: (1) sets the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-PDSCH Power Offset (see CALL:SSCell:CONNected:HSPDschannel:LEVel:HSDPa ) and (2) sets the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-PDSCH State to on (see CALL:SSCell:CONNected:HSPDschannel:STATe:HSDPa ).

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -3

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSPDschannel:HSDPa -3"

CALL:SSCell:CONNected:HSPDschannel:LEVel:HSPA

Function

Sets/queries the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-PDSCH Power Offset

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -3

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSPDschannel:LEVel:HSPA -3"

CALL:SSCell:CONNected:HSPDschannel:STATe:HSPA

Function

Sets/queries the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-PDSCH State.

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 1 (ON)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSPDschannel:STATe:HSPA On"

CALL:SSCell:CONNected:HSPDschannel[:SLEVel]:HSPA

Function

 The setting form of this command performs two functions: (1) sets the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-PDSCH Power Offset (see CALL:SSCell:CONNected:HSPDschannel:LEVel:HSPA ) and (2) sets the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-PDSCH State to on (see CALL:SSCell:CONNected:HSPDschannel:STATe:HSPA ).

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -3

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSPDschannel:HSPA -3"

CALL:SSCell:CONNected:HSSCchannel[1]:LEVel:HSDPa

Function

Sets/queries the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-SCCH 1 Power Offset

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -10

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel[1]:LEVel:HSDPa -10"

CALL:SSCell:CONNected:HSSCchannel[1]:STATe:HSDPa

Function

Sets/queries the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-SCCH 1 State.

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 1 (ON)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel:STATe:HSDPa On"

CALL:SSCell:CONNected:HSSCchannel[1][:SLEVel]:HSDPa

Function

 The setting form of this command performs two functions: (1) sets the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-SCCH 1 Power Offset (see CALL:SSCell:CONNected:HSSCchannel[1]:LEVel:HSDPa ) and (2) sets the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-SCCH 1 State to on (see CALL:SSCell:CONNected:HSSCchannel[1]:STATe:HSDPa ).

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -10

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel:HSDPa -10"

CALL:SSCell:CONNected:HSSCchannel[1]:LEVel:HSPA

Function

Sets/queries the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-SCCH 1 Power Offset.

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -10

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel:LEVel:HSPA -10"

CALL:SSCell:CONNected:HSSCchannel[1]:STATe:HSPA

Function

Sets/queries the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-SCCH 1 State.

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 1 (ON)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel:STATe:HSPA On"

CALL:SSCell:CONNected:HSSCchannel[1][:SLEVel]:HSPA

Function

 The setting form of this command performs two functions: (1) sets the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-SCCH 1 Power Offset (see CALL:SSCell:CONNected:HSSCchannel[1]:LEVel:HSPA ) and (2) sets the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-SCCH 1 State to on (see CALL:SSCell:CONNected:HSSCchannel[1]:STATe:HSPA ).

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -10

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel:HSPA -10"

CALL:SSCell:CONNected:HSSCchannel2:LEVel:HSDPa

Function

Sets/queries the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-SCCH 2 Power Offset.

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -15

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel2:LEVel:HSDPa -15"

CALL:SSCell:CONNected:HSSCchannel2:STATe:HSDPa

Function

Sets/queries the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-SCCH 2 State.

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel2:STATe:HSDPa Off"

CALL:SSCell:CONNected:HSSCchannel2[:SLEVel]:HSDPa

Function

 The setting form of this command performs two functions: (1) sets the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-SCCH 2 Power Offset (see CALL:SSCell:CONNected:HSSCchannel2:LEVel:HSDPa ) and (2) sets the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-SCCH 2 State to on (see CALL:SSCell:CONNected:HSSCchannel2:STATe:HSDPa ).

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -10

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel2:HSDPa -10"

CALL:SSCell:CONNected:HSSCchannel2:LEVel:HSPA

Function

Sets/queries the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-SCCH 2 Power Offset

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -15

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel2:LEVel:HSPA -15"

CALL:SSCell:CONNected:HSSCchannel2:STATe:HSPA

Function

Sets/queries the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-SCCH 2 State.

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel2:STATe:HSPA Off"

CALL:SSCell:CONNected:HSSCchannel2[:SLEVel]:HSPA

Function

 The setting form of this command performs two functions: (1) sets the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-SCCH 2 Power Offset (see CALL:SSCell:CONNected:HSSCchannel2:LEVel:HSPA ) and (2) sets the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-SCCH 2 State to on (see CALL:SSCell:CONNected:HSSCchannel2:STATe:HSPA ).

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -10

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel2:HSPA -10"

CALL:SSCell:CONNected:HSSCchannel3:LEVel:HSDPa

Function

Sets/queries the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-SCCH 3 Power Offset

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -15

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel3:LEVel:HSDPa -15"

CALL:SSCell:CONNected:HSSCchannel3:STATe:HSDPa

Function

Sets/queries the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-SCCH 3 State.

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel3:STATe:HSDPa Off"

CALL:SSCell:CONNected:HSSCchannel3[:SLEVel]:HSDPa

Function

 The setting form of this command performs two functions: (1) sets the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-SCCH 3 Power Offset (see CALL:SSCell:CONNected:HSSCchannel3:LEVel:HSDPa ) and (2) sets the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-SCCH 3 State to on (see CALL:SSCell:CONNected:HSSCchannel3:STATe:HSDPa ).

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -10

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel3:HSDPa -10"

CALL:SSCell:CONNected:HSSCchannel3:LEVel:HSPA

Function

Sets/queries the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-SCCH 3 Power Offset.

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -15

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel3:LEVel:HSPA -15"

CALL:SSCell:CONNected:HSSCchannel3:STATe:HSPA

Function

Sets/queries the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-SCCH 3 State.

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel3:STATe:HSPA Off"

CALL:SSCell:CONNected:HSSCchannel3[:SLEVel]:HSPA

Function

 The setting form of this command performs two functions: (1) sets the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-SCCH 3 Power Offset (see CALL:SSCell:CONNected:HSSCchannel3:LEVel:HSPA ) and (2) sets the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-SCCH 3 State to On (see CALL:SSCell:CONNected:HSSCchannel3:STATe:HSPA ).

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -15

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel3:HSPA -15"

CALL:SSCell:CONNected:HSSCchannel4:LEVel:HSDPa

Function

Sets/queries the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-SCCH 4 Power Offset.

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -15

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel4:LEVel:HSDPa -15"

CALL:SSCell:CONNected:HSSCchannel4:STATe:HSDPa

Function

Sets/queries the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-SCCH 4 State.

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel4:STATe:HSDPa Off"

CALL:SSCell:CONNected:HSSCchannel4[:SLEVel]:HSDPa

Function

 The setting form of this command performs two functions: (1) sets the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-SCCH 4 Power Offset (see CALL:SSCell:CONNected:HSSCchannel4:LEVel:HSDPa ) and (2) sets the UTRA FDD (HSDPA) Secondary Serving Cell Connected HS-SCCH 4 State to on (see CALL:SSCell:CONNected:HSSCchannel4:STATe:HSDPa ).

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -15

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel4:HSDPa -15"

CALL:SSCell:CONNected:HSSCchannel4:LEVel:HSPA

Function

Sets/queries the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-SCCH 4 Power Offset

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -15

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel4:LEVel:HSPA -15"

CALL:SSCell:CONNected:HSSCchannel4:STATe:HSPA

Function

Sets/queries the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-SCCH 4 State.

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel4:STATe:HSPA Off"

CALL:SSCell:CONNected:HSSCchannel4[:SLEVel]:HSPA

Function

 The setting form of this command performs two functions: (1) sets the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-SCCH 4 Power Offset (see CALL:SSCell:CONNected:HSSCchannel4:LEVel:HSPA ) and (2) sets the UTRA FDD (HSPA) Secondary Serving Cell Connected HS-SCCH 4 State to on (see CALL:SSCell:CONNected:HSSCchannel4:STATe:HSPA ).

Setting

Range: -20.00 to 0 dB

Resolution 0.01

Query

Same as setting

*RST Setting

 -15

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:CONNected:HSSCchannel4:HSPA -15"

CALL:SSCell:HSSCchannel1:CCODe:CODE

Function

Sets/queries the Secondary Serving Cell HS-SCCH 1 Channelization Code.

Code 0 is not allowed as it would collide with the CPICH and SCH/PCCPCH channels.

This setting cannot be changed while the Operating Mode is Active Cell .

Setting

Range: 1-127

Query

Same as setting

*RST Setting

 2

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:HSSCchannel1:CCODe:CODE 2"

CALL:SSCell:HSSCchannel2:CCODe:CODE

Function

Sets/queries the Secondary Serving Cell HS-SCCH 2 Channelization Code.

Code 0 is not allowed as it would collide with the CPICH and SCH/PCCPCH channels.

This setting cannot be changed while the Operating Mode is Active Cell .

Setting

Range: 1-127

Query

Same as setting

*RST Setting

 6

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:HSSCchannel2:CCODe:CODE 6"

CALL:SSCell:HSSCchannel3:CCODe:CODE

Function

Sets/queries the Secondary Serving Cell HS-SCCH 3 Channelization Code.

Code 0 is not allowed as it would collide with the CPICH and SCH/PCCPCH channels.

This setting cannot be changed while the Operating Mode is Active Cell .

Setting

Range: 1-127

Query

Same as setting

*RST Setting

 9

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:HSSCchannel3:CCODe:CODE 9"

CALL:SSCell:HSSCchannel4:CCODe:CODE

Function

Sets/queries the Secondary Serving Cell HS-SCCH 4 Channelization Code.

Code 0 is not allowed as it would collide with the CPICH and SCH/PCCPCH channels.

This setting cannot be changed while the Operating Mode is Active Cell .

Setting

Range: 1-127

Query

Same as setting

*RST Setting

 10

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:HSSCchannel3:CCODe:CODE 10"

CALL:SSCell:HSSChannel[1]:CONFig:STATe

Function

Sets/queries the secondary serving cell HSDPA/HSPA HS-SCCH 1 Channel Configuration State.

You are not allowed to set the channel configuration to Off when all other HS-SCCH channels' configuration state is Off.

For DC-HSDPA, the number of configured HS-SCCHs across both cells should be 6 or less.

This setting can only be changed when the call status is Idle.

Setting

Range: 1|ON|0|OFF

Query

 0|1

*RST Setting

 1 (ON)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:HSSChannel:CONFig:STATe On"

CALL:SSCell:HSSChannel2:CONFig:STATe

Function

Sets/queries the secondary serving cell HSDPA/HSPA HS-SCCH 2 Channel Configuration State.

You are not allowed to set the channel configuration to Off when all other HS-SCCH channels' configuration state is Off.

For DC-HSDPA, the number of configured HS-SCCHs across both cells should be 6 or less.

This setting can only be changed when the call status is Idle.

Setting

Range: 1|ON|0|OFF

Query

 0|1

*RST Setting

 1 (ON)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:HSSChannel2:CONFig:STATe On"

CALL:SSCell:HSSChannel3:CONFig:STATe

Function

Sets/queries the secondary serving cell HSDPA/HSPA HS-SCCH 3 Channel Configuration State.

You are not allowed to set the channel configuration to Off when all other HS-SCCH channels' configuration state is Off.

For DC-HSDPA, the number of configured HS-SCCHs across both cells should be 6 or less.

This setting can only be changed when the call status is Idle.

Setting

Range: 1|ON|0|OFF

Query

 0|1

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:HSSChannel3:CONFig:STATe Off"

CALL:SSCell:HSSChannel4:CONFig:STATe

Function

Sets/queries the secondary serving cell HSDPA/HSPA HS-SCCH 4 Channel Configuration State.

You are not allowed to set the channel configuration to Off when all other HS-SCCH channels' configuration state is Off.

For DC-HSDPA, the number of configured HS-SCCHs across both cells should be 6 or less.

This setting can only be changed when the call status is Idle.

Setting

Range: 1|ON|0|OFF

Query

 0|1

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:HSSChannel4:CONFig:STATe Off"

CALL:SSCell:OCNSource:CCODe:CODE

Function

Sets/queries the Secondary Serving Cell HSDPA/HSPA OCNS 1-6 Channelization Code

Setting

Range: 1 to 127

Query

Same as setting

*RST Setting

 122, 123, 124, 125, 126, 127

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:OCNSource:CCODe:CODE 122, 123, 124, 125, 126, 127"

CALL:SSCell:OCNSource:CONFig:STATe:HSDPa

Function

Sets/queries the Secondary Serving Cell HSDPA/HSPA OCNS 1-6 Channel Configuration State

You are not allowed to set all the HSDPA/HSPA OCNS 1-6 Channel Configuration State for the Secondary Serving Cell to Off at the same time.

Setting

Range: 1|ON|0|OFF

Query

 Range: 0|1

*RST Setting

 1 (ON), 1 (ON), 1 (ON), 1 (ON), 1 (ON), 1 (ON)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:OCNSource:CONFig:STATe:HSDPa 1,1,1,1,1,1"

CALL:SSCell:OCNSource:LEVel?

Function

Queries the Calculated UTRA FDD Carrier 2 Composite OCNS Level.

Setting

Range: -20.00 to 0, -9.9E37 (NAN)

Query

Same as setting

*RST Setting

 -9.9E37

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:OCNSource:LEVel?"

CALL:SSCell:OCNSource:POFFset:HSDPa

Function

Sets/queries the Secondary Serving Cell HSDPA/HSPA OCNS 1-6 Power Offset

Setting

Range: -20.00 to 0 dB

Query

Same as setting

*RST Setting

 0, -2, -2, -4, -1, -3

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:OCNSource:POFFset:HSDPa 0, -2, -2, -4, -1, -3"

CALL:SSCell:OCNSource:STATe?

Function

Queries the Calculated UTRA FDD Carrier 2 Composite OCNS State.

Setting

Range: 1|ON|0|OFF

Query

Same as setting

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:OCNSource:STATe?"

CALL:SSCell:PICHannel:CCODe:CODE

Function

Sets/queries the PICH (SF 256) channelization code for the secondary serving cell. Codes 0 & 1 are not allowed as they are reserved for the CPICH and SCH/PCCPCH respectively.

This setting cannot be changed while the Operating Mode is "Active Cell".

Setting

Range: 2 - 255

Query

Same as setting

*RST Setting

 16

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:PICHannel:CCODe:CODE 16"

CALL:SSCell:POWer[:SAMPLitude]

Function

Sets/queries the absolute power of the secondary serving cell.

The setting form of this command performs two functions: (1) sets the desired cell power level and (2) turns the cell power on/off state to on.

This setting is also used in FDD Test Operating Mode.

This setting is used for DC-HSDPA operation.

Setting

Range: -165dBm/3.84MHz to +37dBm/3.84MHz

The actual power range is defined by adding the value of the associated Amplitude Offset to the range in the table. E.g. if Amplitude Offset is -3.5 dB, then the power range will be -118.5dBm/3.84 MHz to -16.5dBm/3.84MHz.

Query

Same as setting

*RST Setting

 -75.0 dBm/3.84 MHz

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:POWer -25.7"

CALL:SSCell:POWer:AMPLitude

Function

 Sets/queries the absolute power of the secondary serving cell.

This setting is also used in FDD Test Operating Mode.

This setting is used for DC-HSDPA operation.

Setting

Range: -165dBm/3.84MHz to +37dBm/3.84MHz

The actual power range is defined by adding the value of the associated Amplitude Offset to the range in the table. E.g. if Amplitude Offset is -3.5 dB, then the power range will be -118.5dBm/3.84 MHz to -16.5dBm/3.84MHz.

Query

Same as setting

*RST Setting

 -75.0 dBm/3.84 MHz

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:POWer:AMPLitude -25.7"

CALL:SSCell:POWer:STATe

Function

Sets/queries the state of the secondary serving cell power.

This parameter only affects the power of the DC-HSDPA secondary serving cell when a DC-HSDPA call is established. Setting this parameter to On/Off will not tell the UE to enable/disable DC-DSDPA operation.

This setting is also used in FDD Test Operating Mode.

Setting

Range: 1|ON|0|OFF

Query

 1|0

*RST Setting

 ON

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:POWer:STATe On"

CALL:SSCell:SCODe[:PRIMary]

Function

 Sets/queries the primary scrambling code of the secondary serving cell.The actual code number for the primary scrambling code is 16 times the value of this setting. See 3GPP TS 25.213, "Spreading and Modulation (FDD)" for a complete description of the relationship between this index and the actual spreading code number.

Setting

Range: 0 to 511

Increment: 1

Query

Same as setting

*RST Setting

 2

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:SCODe 2"

CALL:SSCell:TOTal:POWer[:AMPLitude]?

Function

Queries the desired total RF power of the secondary serving cell power for the current system type.

Query

Range: -165 dBm/3.84 MHz to +42 dBm/3.84 MHz or 9.91 E+37 (NAN)

Resolution: 0.01 dBm/3.84 MHz

The actual power range is shown taking the Amplitude Offset into consideration. E.g. if Amplitude Offset is -3.5 dB, then the power range will be -118.5dBm/3.84 MHz to -16.5dBm/3.84MHz.

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:TOTal:POWer?"

CALL:SSCell:TOTal:POWer:STATe?

Function

 Queries the total RF power state of the secondary serving cell power for the current system type.

Query

 Range: 1|0

*RST Setting

 1 (on)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSCell:TOTal:POWer:STATe?"


CALL:SSERvice

CALL:SSERvice

Last updated: November 12, 2010

GPIB Command Conventions

  • CALL:SSERvice:PIPE
  • CALL:SSERvice:PIPE:DATA:CMService:REQuest?
  • CALL:SSERvice:PIPE:DATA:RX?
  • CALL:SSERvice:PIPE:DATA:RX:AVAilable?
  • CALL:SSERvice:PIPE:DATA:TX
  • CALL:SSERvice:PIPE:DATA:TX:SEND
  • CALL:SSERvice:PIPE:DATA:TIMeout

CALL:SSERvice:PIPE

Function

Sets/queries the Supplementary Services (SS) Pipe State.

When this parameter is set to "On" any external data received for downlink transmission over the SS pipe will be processed according to the requirements of the specific message if there is an already existing MM-connection or MM/RRC connection (involved in AMR voice Call or RB Test Mode Call. Otherwise the message will be ignored. Similarly, any data received from the UE when this parameter is "On" is processed according to the requirements of the applicable message, and made available for querying over the RUI.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

OFF

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:PIPE 0"
!Sets the Supplementary Services (SS) Pipe State to Off.

CALL:SSERvice:PIPE:DATA:CMService:REQuest?

Function

Queries the CM Service Request. This query returns the latest CM Service Request received from the UE.

Query

Range: <length of encoded message in bits>, <"ascii string of hex digits defining message">

*RST Setting

0, ""

Requirements

 Lab Application Revision: G.00 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:PIPE:DATA:CMService:REQuest?"
!Queries the CM Service Request.

CALL:SSERvice:PIPE:DATA:RX?

Function

Queries the latest Supplementary Services (SS) Pipe message received from the UE. This command reports a value regardless of the "SS Pipe State" and MM connection state. An empty string will be returned if no message has been received from the UE. The Rx data remains unchanged when the SS Pipe State is changed. The Rx Data is stored when a message is received from the UE via the SS Pipe.The Rx Data is reset back to an empty string once it has been read using this command.

Query

Range: <"ascii string of hex digits defining message">

*RST Setting

""

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:PIPE:DATA:RX?"
!Queries the latest Supplementary Services (SS) Pipe message received from the UE.

CALL:SSERvice:PIPE:DATA:RX:AVAilable?

Function

Queries whether unread uplink Supplementary Services (SS) Pipe data is available. This command reports a value regardless of the "SS Pipe State" and MM connection state. The Rx data available flag is set to 1 when any data is received via the SS pipe and is available to read using this command: The Rx data available flag is reset to 0 after data has been read using this command:.The Rx data available flag remains unchanged when the "SS Pipe State" is changed..

Query

 Range: 1|0

*RST Setting

0

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:PIPE:DATA:RX:AVAilable?"
!Queries whether unread uplink Supplementary Services (SS) Pipe data is available.

CALL:SSERvice:PIPE:DATA:TX

Function

Sets/queries the raw data to be sent using the SS pipe. An empty string is returned if you query the Tx Data before it is set. The Tx Data exists until it is set to a new value using this command, even if it has been transmitted successfully one or more times.

Setting

Range: <"ascii string of hex digits defining message">

Query

Range: <"ascii string of hex digits defining message">

*RST Setting

""

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:PIPE:DATA:TX?"
!Queries the raw data to be sent using the SS pipe.

CALL:SSERvice:PIPE:DATA:TX:SEND

Function

Immediately sends the SS Pipe Message.

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:PIPE:DATA:TX:SEND"
!Immediately sends the SS Pipe Message.

CALL:SSERvice:PIPE:DATA:TIMeout

Function

This command sets the duration of the SS Pope inactivity timer. This setting is by GPIB only.

Setting

Range: 0 to 140 seconds

Query

Range: 0 to 140

*RST Setting

 10

Requirements

Test Application Revision: A.17.00 and above
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:PIPE:TIMeout 40"


CALL:STATus

CALL:STATus

Last updated: January 13, 2012

NOTE
The CALL:STATus commands are query only. They return values that indicate the test set's actual hardware settings. Actual hardware settings can differ from settings the user has entered, most frequently due to an error condition. When no error conditions exist, the commands used to enter values return the same results as the commands used to query actual hardware settings. For example, "CALL:AWGNoise:POWer?" returns the same value as "CALL:STATus:AWGNoise:POWer?" when no error conditions exist.

GPIB Command Conventions

  • CALL:STATus[:STATe][:VOICe]?

  • CALL:STATus:AICHannel[:CELL][:LEVel]?
  • CALL:STATus:AICHannel[:CELL]:STATe?

  • CALL:STATus[:GMM]:ATTached:STATe?

  • CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude]([:SELected]|:FDD)?
  • CALL:STATus:AWGNoise[:INTernal]:POWer:STATe?

  • CALL:STATus:BEDGain:EAGChannel:TSELection?

  • CALL:STATus:CCPChannel:PRIMary[:CELL[1]][:LEVel]?
  • CALL:STATus:CCPChannel:PRIMary[:CELL[1]]:STATe?
  • CALL:STATus:CCPChannel:PRIMary:CELL2[:LEVel]?
  • CALL:STATus:CCPChannel:PRIMary:CELL2:STATe?
  • CALL:STATus:CCPChannel:SECondary[:CELL][:LEVel]?
  • CALL:STATus:CCPChannel:SECondary[:CELL]:STATe?

  • CALL:STATus:CELL[1]:POWer[:AMPLitude]?
  • CALL:STATus:CELL[1]:POWer:STATe?

  • CALL:STATus:CELL:SYSTem[:TYPE]?

  • CALL:STATus:CELL2:POWer[:AMPLitude]?
  • CALL:STATus:CELL2:POWer:STATe?

  • CALL:STATus:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum?
  • CALL:STATus:CLPControl:DOWNlink:ECIor:RECord[:STATe]?
  • CALL:STATus:CLPControl:DOWNlink:ECIor:RECord:COUNt?
  • CALL:STATus:CLPControl:DOWNlink:ECIor:RATio?
  • CALL:STATus:CLPControl:DOWNlink:ECIor[:AVERage]?
  • CALL:STATus:CLPControl:DOWNlink:ECIor:MAXimum?
  • CALL:STATus:CLPControl:DOWNlink:ECIor:MINimum?

  • CALL:STATus:COMPressed:STATe?
  • CALL:STATus:COMPressed:TGPSequence:ALL:STATe?

  • CALL:STATus:CPC:DRX:ACTivated?
  • CALL:STATus:CPC:DTX:ACTivated?
  • CALL:STATus:CPC:DTX:TRANsition:C1Cycle2:COUNt?
  • CALL:STATus:CPC:HLESs:ACTivated?
  • CALL:STATus:CPC:HLESs:TBSize?
  • CALL:STATus:CPC:MS:CQI:MISSing:COUNt?
  • CALL:STATus:CPC:MS:CQI:MISSing:COUNt?
  • CALL:STATus:CPC:MS:CQI:POSTamble:INComplete:COUNt?
  • CALL:STATus:CPC:MS:CQI:INCorrect:TRANsmission:COUNt?
  • CALL:STATus:CPC:MS:DPCChannel:BURSt[1]:COUNt?
  • CALL:STATus:CPC:MS:DPCChannel:BURSt2:COUNt?
  • CALL:STATus:CPC:MS:DPCChannel:BURSt1:INComplete:POSTamble:COUNt?
  • CALL:STATus:CPC:MS:DPCChannel:BURSt1:INComplete:PREamble:COUNt?
  • CALL:STATus:CPC:MS:DPCChannel:BURSt2:INComplete:POSTamble:COUNt?
  • CALL:STATus:CPC:MS:DPCChannel:BURSt2:INComplete:PREamble:COUNt?
  • CALL:STATus:CPC:MS:DPCChannel:BURSt1:INComplete:COUNt?
  • CALL:STATus:CPC:MS:DPCChannel:BURSt2:INComplete:COUNt?
  • CALL:STATus:CPC:MS:DPCChannel:INCorrect:SLOT:COUNt?
  • CALL:STATus:CPC:MS:DRX:CONFigured?
  • CALL:STATus:CPC:MS:DTX:CONFigured?
  • CALL:STATus:CPC:MS:EDCHannel:POSTamble:INComplete:COUNt?
  • CALL:STATus:CPC:MS:EDCHannel:PREamble:INComplete:COUNt?
  • CALL:STATus:CPC:MS:EDCHannel:INCorrect:TRANsmission:COUNt?
  • CALL:STATus:CPC:MS:HLESs:CONFigured?
  • CALL:STATus:CPC:MS:HSDPcchannel:DTX:EXPected:COUNt?
  • CALL:STATus:CPC:MS:HSDPcchannel:DTX:EXPected:COUNt?
  • CALL:STATus:CPC:MS:HSDPcchannel:PREamble:INComplete:COUNt?
  • CALL:STATus:CPC:MS:HSDPcchannel:UNEXpected:COUNt?
  • CALL:STATus:CPC:MS:INCorrect:CMFRame:COUNt?

  • CALL:STATus:CPIChannel[:CELL[1]][:LEVel]?
  • CALL:STATus:CPIChannel[:CELL[1]]:POWer[:AMPLitude]?
  • CALL:STATus:CPIChannel[:CELL[1]]:STATe?
  • CALL:STATus:CPIChannel:CELL2[:LEVel]?
  • CALL:STATus:CPIChannel:CELL2:POWer[:AMPLitude]?
  • CALL:STATus:CPIChannel:CELL2:STATe?

  • CALL:STATus[:STATe]:DATA?

  • CALL:STATus:DOWNlink:FREQuency?
  • CALL:STATus:DPCHannel[:LEVel]?
  • CALL:STATus:DPCHannel:STATe?
  • CALL:STATus:DPCHannel:CELL2[:LEVel]?
  • CALL:STATus:DPCHannel:CELL2:STATe?
  • CALL:STATus:DPCHannel[:CELL]:CURCbeta?
  • CALL:STATus:DPCHannel[:CELL]:CURDbeta?
  • CALL:STATus:DPCHannel:OFFSet?

  • CALL:STATus:EAGChannel[:CELL][:LEVel]?
  • CALL:STATus:EAGChannel[:CELL]:STATe?

  • CALL:STATus:EDCHannel[:CELL]:BLOCk:SIZE[:LAST]?
  • CALL:STATus:EDCHannel[:CELL]:BLOCk:SIZE:AVERage?
  • CALL:STATus:EDCHannel[:CELL]:BLOCk:SIZE:MAXimum?
  • CALL:STATus:EDCHannel[:CELL]:BLOCk:SIZE:MINimum?
  • CALL:STATus:EDCHannel[:CELL]:IBTHroughput?

  • CALL:STATus:EHIChannel[:CELL][:LEVel]?
  • CALL:STATus:EHIChannel[:CELL]:STATe?
  • CALL:STATus:EHIChannel[:CELL]:ACK[:COUNt]?
  • CALL:STATus:EHIChannel[:CELL]:NACK[:COUNt]?

  • CALL:STATus:ERGChannel[:CELL][:LEVel]?
  • CALL:STATus:ERGChannel[:CELL]:STATe?

  • CALL:STATus:ETFCi[:LAST]?
  • CALL:STATus:ETFCi:BOOSt?
  • CALL:STATus:ETFCi:RECord[:STATe]?
  • CALL:STATus:ETFCi:RECord:ALL?
  • CALL:STATus:ETFCi:RECord:COUNt?
  • CALL:STATus:ETFCi:RECord:FRAMe:INDicator?

  • CALL:STATus:FBINdicator?

  • CALL:STATus:HSDSchannel:TBSize?
  • CALL:STATus:HSDSchannel:TBSize:PSData?

  • CALL:STATus:HSPDschannel[:CELL][:LEVel]?
  • CALL:STATus:HSPDschannel[:CELL]:STATe?

  • CALL:STATus:HSSCchannel[1][:CELL][:LEVel]?
  • CALL:STATus:HSSCchannel[1][:CELL]:STATe?
  • CALL:STATus:HSSCchannel2[:CELL][:LEVel]?
  • CALL:STATus:HSSCchannel2[:CELL]:STATe?
  • CALL:STATus:HSSCchannel3[:CELL][:LEVel]?
  • CALL:STATus:HSSCchannel3[:CELL]:STATe?
  • CALL:STATus:HSSCchannel4[:CELL][:LEVel]?
  • CALL:STATus:HSSCchannel4[:CELL]:STATe?

  • CALL:STATus:MAXimum:ALLowed:CQI:VALue?

  • CALL:STATus:MCELl?

  • CALL:STATus:MM?

  • CALL:STATus:MS:HSDSchannel:CATegory?

  • CALL:STATus:MS:IP:ADDRess:IP4?
  • CALL:STATus:MS:IP:ADDRess:IP6:IID?

  • CALL:STATus:MS:IP:ADDRess2:IP4?
  • CALL:STATus:MS:IP:ADDRess2:IP6:IID?

  • CALL:STATus:MS:PDPContext:ACTivated:COUNt?

  • CALL:STATus:MPOWer:OFFSet:SIGNaled?

  • CALL:STATus:OCNSource[:CELL][:LEVel]([:SELected]|:FDD)?
  • CALL:STATus:OCNSource[:CELL]:STATe([:SELected]|:FDD)?
  • CALL:STATus:OCNSource:CELL2[:LEVel]([:SELected]|:FDD)?
  • CALL:STATus:OCNSource:CELL2:STATe([:SELected]|:FDD)?

  • CALL:STATus:PICHannel[:CELL][:LEVel]?
  • CALL:STATus:PICHannel[:CELL]:STATe?

  • CALL:STATus:PRAChannel[:CELL]:CURCbeta?
  • CALL:STATus:PRAChannel[:CELL]:CURDbeta?

  • CALL:STATus:REPorted:CQI:LIMitation:COUNt?
  • CALL:STATus:REPorted:SCELl:CQI:LIMitation:COUNt?
  • CALL:STATus:REPorted:SSCell:CQI:LIMitation:COUNt?
  • CALL:STATus:DCARrier:TOTal:POWer[:AMPLitude]?
  • CALL:STATus:DCARrier:TOTal:STATe?

  • CALL:STATus:ROHC:DOWNlink:CID:LARGe?
  • CALL:STATus:ROHC:DOWNlink:CID:MAXimum?
  • CALL:STATus:ROHC:DOWNlink:RDDepth?
  • CALL:STATus:ROHC:UPLink:CID:LARGe?
  • CALL:STATus:ROHC:UPLink:CID:MAXimum?

  • CALL:STATus:RRC:STATe?

  • CALL:STATus:SERVice:TYPe?

  • CALL:STATus:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>UPLink[:CHANnel]?
  • CALL:STATus:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>UPLink:SEParation?
  • CALL:STATus:SETup[:PCReconfig]:FBINdicator?

  • CALL:STATus:SETup:RBReconfig:CHANnel:UPLink[:CHANnel]?
  • CALL:STATus:SETup:RBReconfig:CHANnel:UPLink:SEParation?
  • CALL:STATus:SETup:RBReconfig:DPCHannel:CBETa?
  • CALL:STATus:SETup:RBReconfig:DPCHannel:DBETa?
  • CALL:STATus:SETup:RBReconfig:FBINdicator?

  • CALL:STATus:SETup:TCReconfig:CHANnel:UPLink[:CHANnel]?
  • CALL:STATus:SETup:TCReconfig:CHANnel:UPLink:SEParation?
  • CALL:STATus:SETup:TCReconfig:DPCHannel:CBETa?
  • CALL:STATus:SETup:TCReconfig:DPCHannel:DBETa?
  • CALL:STATus:SETup:TCReconfig:FBINdicator?

  • CALL:STATus:SGRant:RELative:QUEued:COUNt?

  • CALL:STATus:SHANdoff:EVENt?
  • CALL:STATus:SHANdoff:EVENt:CELLid?
  • CALL:STATus:SHANdoff:STATe?
  • CALL:STATus:SSCell:POWer[:AMPLitude]?
  • CALL:STATus:SSCell:POWer:STATe?
  • CALL:STATus:SSCell:TOTal:POWer[:AMPLitude]?
  • CALL:STATus:SSCell:TOTal:POWer:STATe?
  • CALL:STATus:SSCell:UPLink:FREQuency?
  • CALL:STATus:SSCell:DOWNlink:FREQuency?
  • CALL:STATus:SSCell:CPIChannel:STATe?
  • CALL:STATus:SSCell:CPIChannel:[:LEVel]?
  • CALL:STATus:SSCell:CCPChannel:PRIMary:STATe?
  • CALL:STATus:SSCell:CCPChannel:PRIMary[:LEVel]?
  • CALL:STATus:SSCell:PICHannel:STATe?
  • CALL:STATus:SSCell:PICHannel:[:LEVel]?
  • CALL:STATus:SSCell:HSPDschannel:STATe?
  • CALL:STATus:SSCell:HSPDschannel:[LEVel]?
  • CALL:STATus:SSCell:HSSCchannel1:STATe?
  • CALL:STATus:SSCell:HSSCchannel1:[LEVel]?
  • CALL:STATus:SSCell:HSSCchannel2:STATe?
  • CALL:STATus:SSCell:HSSCchannel2:[LEVel]?
  • CALL:STATus:SSCell:HSSCchannel3:STATe?
  • CALL:STATus:SSCell:HSSCchannel3:[LEVel]?
  • CALL:STATus:SSCell:HSSCchannel4:STATe?
  • CALL:STATus:SSCell:HSSCchannel4:[LEVel]?
  • CALL:STATus:SSCell:OCNSource:LEVel?
  • CALL:STATus:SSCell:OCNSource:STATe?
  • CALL:STATus:SSCell:MPOWer:OFFSet:SIGNaled?
  • CALL:STATus:SSCell:HSDSchannel:TBSize:PSData?
  • CALL:STATus:SSCell:HSDSchannel:TBSize?
  • CALL:STATus:SSCell:MAXimum:ALLowed:CQI:VALue?
  • CALL:STATus:SSCell?

  • CALL:STATus[:STATe][:VOICe]?

  • CALL:STATus:AICHannel[:CELL][:LEVel]?
  • CALL:STATus:AICHannel[:CELL]:STATe?
  • CALL:STATus[:GMM]:ATTached:STATe?
  • CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude]([:SELected]|:FDD)?
  • CALL:STATus:AWGNoise[:INTernal]:POWer:STATe?
  • CALL:STATus:CCPChannel:PRIMary[:CELL[1]][:LEVel]?
  • CALL:STATus:CCPChannel:PRIMary[:CELL[1]]:STATe?
  • CALL:STATus:CCPChannel:PRIMary:CELL2[:LEVel]?
  • CALL:STATus:CCPChannel:PRIMary:CELL2:STATe?
  • CALL:STATus:CCPChannel:SECondary[:CELL][:LEVel]?
  • CALL:STATus:CCPChannel:SECondary[:CELL]:STATe?
  • CALL:STATus:CELL[1]:POWer[:AMPLitude]?
  • CALL:STATus:CELL[1]:POWer:STATe?
  • CALL:STATus:CELL:SYSTem[:TYPE]?
  • CALL:STATus:CELL2:POWer[:AMPLitude]?
  • CALL:STATus:CELL2:POWer:STATe?
  • CALL:STATus:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum?
  • CALL:STATus:CLPControl:DOWNlink:ECIor:RECord[:STATe]?
  • CALL:STATus:CLPControl:DOWNlink:ECIor:RECord:COUNt?
  • CALL:STATus:CLPControl:DOWNlink:ECIor:RATio?
  • CALL:STATus:CLPControl:DOWNlink:ECIor[:AVERage]?
  • CALL:STATus:CLPControl:DOWNlink:ECIor:MAXimum?
  • CALL:STATus:CLPControl:DOWNlink:ECIor:MINimum?
  • CALL:STATus:COMPressed:STATe?
  • CALL:STATus:COMPressed:TGPSequence:ALL:STATe?
  • CALL:STATus:COMPressed:TGPSequence:ALL:STATe?
  • CALL:STATus:CPC:DRX:ACTivated?
  • CALL:STATus:CPC:DTX:ACTivated?

  • CALL:STATus:TOTal:POWer[:AMPLitude]?
  • CALL:STATus:TOTal:POWer:STATe?

  • CALL:STATus:UPLink:CHANnel?
  • CALL:STATus:UPLink:FREQuency?
  • CALL:STATus:UPLink:SEParation?

CALL:STATus[:STATe][:VOICe]?

Function

Queries the status of the call. See Call Connection State .

Query

Range: CALL|CONN|HAND|IDLE|PAG|REG|REL|SREQ

Only IDLE is returned in FDD Test operating mode.

*RST Setting

 IDLE

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision: A.05 and above added CALL

Lab Application Revision: B.01 and above added CALL

Programming Example

OUTPUT 714;"CALL:STATus?"
! Returns the current call processing state.

CALL:STATus:AICHannel[:CELL][:LEVel]?

Function

Queries the current level of the acquisition indicator channel. This query is not applicable to FDD Test operating mode. See Downlink Code Channel Information .

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 -9.9 dB

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:AICHannel?"

CALL:STATus:AICHannel[:CELL]:STATe?

Function

Queries the current state of the acquisition indicator channel. This query is not applicable to FDD Test operating mode. See Downlink Code Channel Information .

Query

Range: 0|1

*RST Setting

 1 (on)

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:AICHannel:STATe?"

CALL:STATus[:GMM]:ATTached:STATe?

Function

Queries the attached state of the UE. See GMM State .

Query

Range:

  • ATT - attached
  • ATTINC - attach incomplete
  • DET - detached
  • NONE

*RST Setting

 NONE

Requirements

Test Application Revision: A.08.20 and above

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:STATus:ATTached:STATe?"

CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude]([:SELected]|:FDD)?

Function

Queries the current power level of the additive white Gaussian noise (AWGN) source. AWGN power level is set using the CALL:AWGNoise commands.

The optional [:SELected] mnemonic in this command specifies that the AWGN power level being queried applies to the current system type (FDD is currently the only system type available).

See Cell Power and AWGN Power for more information about desired versus current power levels.

Query

Range:

  • -165 dBm/3.84 MHz to +35 dBm/3.84 MHz, NAN (this is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source)
  • 9.91 E+37 (NAN) is returned if CALL:STATus:AWGNoise[:INTernal]:POWer:STATe? is OFF

Resolution: 0.01 dB

*RST Setting

 9.91 E+37 (NAN)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:AWGNoise:POWer?"
!Queries the current AWGN power.

CALL:STATus:AWGNoise[:INTernal]:POWer:STATe?

Function

Queries the current on/off state of the additive white Gaussian noise (AWGN) source. AWGN power level on/off state is set using the CALL:AWGNoise commands.

See Cell Power and AWGN Power for more information about desired versus current power levels.

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:AWGNoise:POWer:STATe?"

CALL:STATus:BEDGain:EAGChannel:TSELection?

Function

Queries the Current BetaEd Gain E-AGCH Table .

This result returns the BetaEd Gain E-AGCH Table currently in use by the UE to interpret the absolute grant value indices signalled on E-AGCH.

Query

Range: 0|1

*RST Setting

 0

Requirements

Test or Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:BEDGain:EAGChannel:TSELection?"

CALL:STATus:CCPChannel:PRIMary[:CELL[1]][:LEVel]?

Function

Queries the current level of the primary common control physical channel. See Downlink Code Channel Information .

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 -5.3 dB

Requirements

Test or Lab Application Revision: A.01 and above.

Test Application Revision A.06 changed *RST Setting to -5.3 dB.

Lab Application Revision C.01 changed *RST Setting to -5.3 dB.

Programming Example

OUTPUT 714;"CALL:STATus:CCPChannel:PRIMary?"

CALL:STATus:CCPChannel:PRIMary[:CELL[1]]:STATe?

Function

Queries the current state of the primary common control physical channel. See Downlink Code Channel Information .

Query

Range: 0|1

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CCPChannel:PRIMary:STATe?"

CALL:STATus:CCPChannel:PRIMary:CELL2[:LEVel]?

Function

Queries the current level of the cell 2 primary common control physical channel. See Cell 2 Overview and Downlink Code Channel Information .

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CCPChannel:PRIMary:CELL2?"

CALL:STATus:CCPChannel:PRIMary:CELL2:STATe?

Function

Queries the current state of the cell 2 primary common control physical channel. See Cell 2 Overview and Downlink Code Channel Information .

Query

Range: 0|1

*RST Setting

 0 (off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CCPChannel:PRIMary:CELL2:STATe?"

CALL:STATus:CCPChannel:SECondary[:CELL][:LEVel]?

Function

Queries the current level of the secondary common control physical channel. See Downlink Code Channel Information .

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 -10.3 dB

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above

Test Application Revision A.06 changed *RST Setting to -10.3 dB.

Lab Application Revision C.01 changed *RST Setting to -10.3 dB.

Programming Example

OUTPUT 714;"CALL:STATus:CCPChannel:SECondary?"

CALL:STATus:CCPChannel:SECondary[:CELL]:STATe?

Function

Queries the current state of the secondary common control physical channel. See Downlink Code Channel Information .

Query

Range: 0|1

*RST Setting

 1 (on)

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CCPChannel:SECondary:STATe?"

CALL:STATus:CELL[1]:POWer[:AMPLitude]?

Function

Queries the current cell power level. Cell power is set using the CALL:POWer commands.

See Cell Power and AWGN Power for more information about desired versus current power levels.

Query

Range:

  • -165 dBm/3.84 MHz to +37 dBm/3.84 MHz, NAN (this is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source)
  • 9.91 E+37 (NAN) is returned if CALL:STATus:CELL[1]:POWer:STATe? is OFF

Resolution: 0.01 dB

*RST Setting

 -75.00 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CELL:POWer:AMPLitude?"

CALL:STATus:CELL[1]:POWer:STATe?

Function

Queries the current state of the cell power setting. Cell power state is set using the CALL:POWer commands.

See Cell Power and AWGN Power for more information about desired versus current power levels.

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CELL:POWer:STATe?"

CALL:STATus:CELL:SYSTem[:TYPE]?

Function

Queries the current system type that the test set is currently emulating.

When the test set is in active cell operating mode (see CALL:OPERating ) the current system type is selected by the CALL:SYSTem command. (Active cell operating mode is not available in the initial W-CDMA test application release.)

When the test set is in any test mode operating mode (see CALL:OPERating ) or CW operating mode, this command will return the corresponding system type.

Query

Range: FDD|CW

*RST Setting

 FDD

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CELL:SYSTem?"

CALL:STATus:CELL2:POWer[:AMPLitude]?

Function

Queries the current cell 2 power level. (See Cell 2 Overview ).

Query

Range:

  • -165 dBm/3.84 MHz to +37dBm/3.84 MHz, 9.91 E+37
    (-115 dBm/3.84 MHz to -13 dBm/3.84 MHz actual hardware range with amplitude offset = 0)

    The actual power range is defined by adding the value of the associated amplitude offset to the range above. For example, if amplitude offset is -3.5 dB, then the power range will be -118.5 dBm/3.84 MHz to -16.5 dBm/3.84 MHz.

Resolution: 0.01 dBm/3.84 MHz

*RST Setting

 9.91E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CELL2:POWer?"

CALL:STATus:CELL2:POWer:STATe?

Function

Queries the current state of the cell 2 power setting. (See Cell 2 Overview ).

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CELL2:POWer:STATe?"

CALL:STATus:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum?

Function

Queries the current Maximum DL DPCH power. This is the actual upper limit of allowed adjustment to the DL DPCH Level currently in use by the test set if the Downlink Power Control State is set to On.

Query

Range: -30.0 to 20.0, 9.91 E+37

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:STATus:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum?"

CALL:STATus:CLPControl:DOWNlink:ECIor:RECord[:STATe]?

Function

Queries the current state of Real-time DPC Information statistic, which determines whether the test set is currently gathering real-time Downlink Power Control Information or not.

Query

Range: RECording|IDLE

*RST Setting

 IDLE

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:STATus:CLPControl:DOWNlink:ECIor:RECord?"

CALL:STATus:CLPControl:DOWNlink:ECIor:RECord:COUNt?

Function

Queries how many DPCH_Ec/Ior has been gathered.

Query

Range: 0 to 30000, 9.91 E+37

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:STATus:CLPControl:DOWNlink:ECIor:RECord:COUNt?"

CALL:STATus:CLPControl:DOWNlink:ECIor:RATio?

Function

Queries the Ratio of DPCH_Ec/Ior exceeded threshold.

Query

Range: 0.0 to 100.0, 9.91 E+37

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:STATus:CLPControl:DOWNlink:ECIor:RATio?"

CALL:STATus:CLPControl:DOWNlink:ECIor[:AVERage]?

Function

Queries the Average DPCH_Ec/Ior.

Query

Range: -30.0 to 0.0, 9.91 E+37

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:STATus:CLPControl:DOWNlink:ECIor?"

CALL:STATus:CLPControl:DOWNlink:ECIor:MAXimum?

Function

Queries the Maximum DPCH_Ec/Ior.

Query

Range: -30.0 to 0.0, 9.91 E+37

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:STATus:CLPControl:DOWNlink:ECIor:MAXimum?"

CALL:STATus:CLPControl:DOWNlink:ECIor:MINimum?

Function

Queries the Minimum DPCH_Ec/Ior.

Query

Range: -30.0 to 0.0, 9.91 E+37

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:STATus:CLPControl:DOWNlink:ECIor:MINimum?"

CALL:STATus:COMPressed:STATe?

Function

Queries Compressed Mode State/Overall CM (see Enabling/Disabling Compressed Mode ).

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:COMPressed:STATe?"

CALL:STATus:COMPressed:TGPSequence:ALL:STATe?

Function

Queries which TGPSs are currently active. The first num value corresponds to the First TGPS , the second num value corresponds to the Second TGPS , etc. See Enabling/Disabling Compressed Mode .

Query

Range: 1|0

*RST Setting

 0, 0, 0, 0

Requirements

Lab Application Revision: D.00.04 and above

Programming Example

OUTPUT 714;"CALL:STATus:COMPressed:TGPSequence:ALL:STATe?"

CALL:STATus:CPC:DRX:ACTivated?

Function

Queries the Current DRX Activated State.

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:DRX:ACTivated?"

CALL:STATus:CPC:DTX:ACTivated?

Function

Queries the current DTX Activated State.

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:DTX:ACTivated?"

CALL:STATus:CPC:DTX:TRANsition:C1Cycle2:COUNt?

Function

Queries the number of DTX Cycle 1 to Cycle 2 transitions.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:DTX:TRANsition:C1Cycle2:COUNt?"

CALL:STATus:CPC:HLESs:ACTivated?

Function

Queries the Current HS-SCCH-less Activated State.

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

 Lab Application Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:HLESs:ACTivated?"

CALL:STATus:CPC:HLESs:TBSize?

Function

Queries the TB size that is being used for HS-SCCH-less operation.

Query

Range: 137 to 1483 bits, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:HLESs:TBSize?"

CALL:STATus:CPC:MS:CQI:PREamble:INComplete:COUNt?

Function

Queries the Number of Incomplete preambles for CQI.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:CQI:PREamble:INComplete:COUNt?"

CALL:STATus:CPC:MS:CQI:MISSing:COUNt?

Function

Queries the Number of missing CQI transmission.

This result returns the number of missing CQI transmission since the result was last reset.

Query

Range: 0 to 150,000, 9.91 E+37

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:CQI:MISSing:COUNt?"

CALL:STATus:CPC:MS:CQI:POSTamble:INComplete:COUNt?

Function

Queries the Number of Incomplete Postamble for CQI.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:CQI:PREamble:INComplete:COUNt?"

CALL:STATus:CPC:MS:CQI:INCorrect:TRANsmission:COUNt?

Function

Queries the Number of incorrect CQI transmissions.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:CQI:INCorrect:TRANsmission:COUNt?"

CALL:STATus:CPC:MS:DPCChannel:BURSt[1]:COUNt?

Function

Queries the Number of DPCCH Burst 1 Transmissions.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:DPCChannel:BURSt:COUNt?"

CALL:STATus:CPC:MS:DPCChannel:BURSt2:COUNt?

Function

Queries the Number of DPCCH Burst 2 Transmissions.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:DPCChannel:BURSt2:COUNt?"

CALL:STATus:CPC:MS:DPCChannel:BURSt1:INComplete:POSTamble:COUNt?

Function

Queries the Number of Incomplete Postambles for DPCCH burst 1.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:DPCChannel:BURSt1:INComplete:POSTamble:COUNt?"

CALL:STATus:CPC:MS:DPCChannel:BURSt1:INComplete:PREamble:COUNt?

Function

Queries the Number of Incompleted preamble for DPCCH burst 1.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;!CALL:STATus:CPC:MS:DPCChannel:BURSt1:INComplete:PREamble:COUNt?"

CALL:STATus:CPC:MS:DPCChannel:BURSt2:INComplete:POSTamble:COUNt?

Function

Queries the Number of Incomplete Postambles for DPCCH burst 2.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:DPCChannel:BURSt2:INComplete:POSTamble:COUNt?"

CALL:STATus:CPC:MS:DPCChannel:BURSt2:INComplete:PREamble:COUNt?

Function

Queries the Number of Incompleted preamble for DPCCH burst 2.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:DPCChannel:BURSt2:INComplete:PREamble:COUNt?"

CALL:STATus:CPC:MS:DPCChannel:BURSt1:INComplete:COUNt?

Function

 Queries the Number of Incomplete DPCCH Burst 1 since the result was last reset.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:DPCChannel:BURSt1:INComplete:COUNt?"

CALL:STATus:CPC:MS:DPCChannel:BURSt2:INComplete:COUNt?

Function

 Queries the Number of Incomplete DPCCH Burst 2 since the result was last reset.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:DPCChannel:BURSt2:INComplete:COUNt?"

CALL:STATus:CPC:MS:DPCChannel:INCorrect:SLOT:COUNt?

Function

 Queries the Number of Incorrect DPCCH slots.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:DPCChannel:INCorrect:SLOT:COUNt?"

CALL:STATus:CPC:MS:DRX:CONFigured?

Function

Queries whether the DL DRX configuration has been successfully configured in the UE.

This result is only available in Active Cell mode.

Query

Range: 1|0

*RST Setting

 0 (false)

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:DRX:CONFigured?"

CALL:STATus:CPC:MS:DTX:CONFigured?

Function

Queries whether UL DTX configuration has been successfully configured in the UE.

Query

Range: 1|0

*RST Setting

 0 (false)

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:DTX:CONFigured?"

CALL:STATus:CPC:MS:EDCHannel:POSTamble:INComplete:COUNt?

Function

 Queries the Number of Incomplete postambles for the E-DCH.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:EDCHannel:POSTamble:INComplete:COUNt?"

CALL:STATus:CPC:MS:EDCHannel:PREamble:INComplete:COUNt?

Function

 Queries the Number of Incomplete preambles for the E-DCH.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:EDCHannel:PREamble:INComplete:COUNt?"

CALL:STATus:CPC:MS:EDCHannel:INCorrect:TRANsmission:COUNt?

Function

 Queries the Number of incorrect E-DCH transmissions.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:EDCHannel:INCorrect:TRANsmission:COUNt?"

CALL:STATus:CPC:MS:HLESs:CONFigured?

Function

Queries whether HS-SCCH-less configuration has been successfully configured in the UE.

Query

Range: 1|0

*RST Setting

 0 (false)

Requirements

 Lab Application Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:HLESs:CONFigured?"

CALL:STATus:CPC:MS:HSDPcchannel:POSTamble:INComplete:COUNt?

Function

Queries the Number of Incomplete postambles for the HS-DPCCH ACK/NACK.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:HSDPcchannel:POSTamble:INComplete:COUNt?"

CALL:STATus:CPC:MS:HSDPcchannel:DTX:EXPected:COUNt?

Function

Queries the Number of DTX received for HSDPA transmission in those TTI that UE won't monitor due to CPC DRX since the result last reset.

The "Expected DTX from HS-DPCCH " and "Unexpected ACK/NACK from HS-DPCCH" results are reset to NaN when any one of the following occurs:

  • "UE DRX Configured turns to "True" in Active Cell operating mode or "CPC Configured" turns to "True" for FDD Test mode;
  • Measurement Reset or Clear UE Info action is performed;
  • Operating change, or when a new call is established in Active Cell (i.e. when the Call Status changes from Idle to Setup).
  • In FDD Test mode, when "Channel Type" changes to/ from "HSPA Only" or when "Channel Type" is "HSPA Only" and "F-DPCH State" changes to/from "Off";
  • When any one of the DPCCH or CPC DRX Statistic results exceeds 150,000.

Query

Range: 0 to 150,000, 9.91 E+37 (Null)

*RST Setting

 9.91 E+37 (Null)

Requirements

 Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:HSDPcchannel:DTX:EXPected:COUNt?"

CALL:STATus:CPC:MS:HSDPcchannel:PREamble:INComplete:COUNt?

Function

Queries the Number of Incomplete preambles for the HS-DPCCH ACK/NACK.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:HSDPcchannel:PREamble:INComplete:COUNt?"

CALL:STATus:CPC:MS:HSDPcchannel:UNEXpected:COUNt?

Function

Queries the number of Unexpected ACK/NACK from HS-DPCCH.

The "Expected DTX from HS-DPCCH " and "Unexpected ACK/NACK from HS-DPCCH" results are reset to NaN when any one of the following occurs:

  • "UE DRX Configured turns to "True" in Active Cell operating mode or "CPC Configured" turns to "True" for FDD Test mode;
  • Measurement Reset or Clear UE Info action is performed;
  • Operating change, or when a new call is established in Active Cell (i.e. when the Call Status changes from Idle to Setup).
  • In FDD Test mode, when "Channel Type" changes to/ from "HSPA Only" or when "Channel Type" is "HSPA Only" and "F-DPCH State" changes to/from "Off";
  • When any one of the DPCCH or CPC DRX Statistic results exceeds 150,000.

Query

Range: 0 to 150,000, 9.91 E+37

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:HSDPcchannel:UNEXpected:COUNt?"

CALL:STATus:CPC:MS:INCorrect:CMFRame:COUNt?

Function

Queries the Number of incorrect compressed mode frames.

Query

Range: 0 to 150,000, 9.91 E+37

Resolution: 0.01

*RST Setting

 9.91 E+37

Requirements

 Lab Application Revision: G.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPC:MS:INCorrect:CMFRame:COUNt?"

CALL:STATus:CPIChannel[:CELL[1]][:LEVel]?

Function

Queries the current common pilot channel's power. See Downlink Code Channel Information .

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 -3.3 dB

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision A.06 changed *RST Setting to -3.3 dB.

Lab Application Revision C.01 changed *RST Setting to -3.3 dB.

Programming Example

OUTPUT 714;"CALL:STATus:CPIChannel?"

CALL:STATus:CPIChannel[:CELL[1]]:POWer[:AMPLitude]?

Function

Queries the current cell1 CPICH power level in dBm (current Cell Power + current CPICH level). See Downlink Code Channel Information .

Query

Range: -165.00 dBm to +37.00 dBm, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 -78.3 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPIChannel:POWer?"

CALL:STATus:CPIChannel[:CELL[1]]:STATe?

Function

Queries the current state of the common pilot channel. See Downlink Code Channel Information .

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPIChannel:STATe?"

CALL:STATus:CPIChannel:CELL2[:LEVel]?

Function

Queries the current cell 2 common pilot channel's power. See Cell 2 Overview and Downlink Code Channel Information .

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPIChannel:CELL2?"

CALL:STATus:CPIChannel:CELL2:POWer[:AMPLitude]?

Function

Queries the current cell2 CPICH power level in dBm (current Cell 2 Power + current Cell 2 CPICH level). See Cell 2 Overview and Downlink Code Channel Information .

Query

Range: -165.00 dBm to +37.00 dBm, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPIChannel:CELL2:POWer?"

CALL:STATus:CPIChannel:CELL2:STATe?

Function

Queries the current state of the cell 2 common pilot channel. See Cell 2 Overview and Downlink Code Channel Information .

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:CPIChannel:CELL2:STATe?"

CALL:STATus[:STATe]:DATA?

Function

Queries the status of the data connection. See Data Connection State .

Query

Range: ATTG|DET|IDLE|OFF|PDPAG|PDP|PDPD

*RST Setting

 OFF

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:DATA?"
! Returns the current data connection state.

CALL:STATus:DOWNlink:FREQuency?

Function

Queries the current downlink frequecny.

Query

Range (in MHz):

  • 2110 to 2170,
  • 1930 to 1990,
  • 1805 to 1880,
  • 869 to 894,
  • 2620 to 2690,
  • 925 to 960
  • 1475.9 to 1495.9
  • 728 to 746
  • 746 to 756
  • 758 to 768
  • 791 to 821
  • 1495.9 to 1510.9

*RST Setting

 2140.0

Requirements

Test Application Revision: A.18.00 and Lab Application Revision H.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:DOWNlink:FREQuency?"

CALL:STATus:DPCHannel[:LEVel]?

Function

Queries the current dedicated physical channel's power. See Downlink Code Channel Information .

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:DPCHannel?"

CALL:STATus:DPCHannel:STATe?

Function

Queries the current state of the dedicated physical channel. See Downlink Code Channel Information .

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:DPCHannel:STATe?"

CALL:STATus:DPCHannel:CELL2[:LEVel]?

Function

Queries the current cell 2 dedicated physical channel's power. See Cell 2 Overview and Downlink Code Channel Information .

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:DPCHannel:CELL2?"

CALL:STATus:DPCHannel:CELL2:STATe?

Function

Queries the current state of the cell 2 dedicated physical channel. See Cell 2 Overview and Downlink Code Channel Information .

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:DPCHannel:CELL2:STATe?"

CALL:STATus:DPCHannel[:CELL]:CURCbeta?

Function

Queries the current power gain of the dedicated physical control channel (DPCCH) see Uplink DPCH Bc/Bd Control .

Query

Range: 1 to 15

Resolution: 1

*RST Setting

 8

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, range is 1 to 15 (vs. 2 to 15)

Programming Example

OUTPUT 714;"CALL:STATus:DPCHannel:CURCbeta?"

CALL:STATus:DPCHannel[:CELL]:CURDbeta?

Function

Queries the current power gain of the dedicated physical data channel (DPDCH) see Uplink DPCH Bc/Bd Control .

Query

Range: 0 to 15

Resolution: 1

*RST Setting

 15

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:DPCHannel:CURDbeta?"

CALL:STATus:DPCHannel:OFFSet?

Function

 Queries the Current DPCH Offset .

Query

Range: 0 to 38400

Resolution: 256

*RST Setting

 0 chips

Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:DPCHannel:OFFSet?"

CALL:STATus:EAGChannel[:CELL][:LEVel]?

Function

 Queries the current level of the E-AGCH. See Downlink Code Channel Information .

Query

Range: -20.00 dB to 0.00 dB, 9.91E+37

Resolution: 0.01 dB

*RST Setting

 9.91E+37

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:EAGChannel?"

CALL:STATus:EAGChannel[:CELL]:STATe?

Function

 Queries the current state of the E-AGCH. See Downlink Code Channel Information .

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:EAGChannel:STATe?"

CALL:STATus:EDCHannel[:CELL]:BLOCk:SIZE[:LAST]?

Function

 Queries the Last Block Size .

Query

Range: 0 to 22996 bits, 9.91E+37

Resolution: 1 bit

*RST Setting

 9.91E+37

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:EDCHannel:BLOCk:SIZE?"

CALL:STATus:EDCHannel[:CELL]:BLOCk:SIZE:AVERage?

Function

 Queries the Avg Block Size .

Query

Range: 0 to 22996 bits, 9.91E+37

Resolution: 1 bit

*RST Setting

 9.91E+37

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:EDCHannel:BLOCk:SIZE:AVERage?"

CALL:STATus:EDCHannel[:CELL]:BLOCk:SIZE:MAXimum?

Function

 Queries the Max Block Size .

Query

Range: 0 to 22996 bits, 9.91E+37

Resolution: 1 bit

*RST Setting

 9.91E+37

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:EDCHannel:BLOCk:SIZE:MAXimum?"

CALL:STATus:EDCHannel[:CELL]:BLOCk:SIZE:MINimum?

Function

 Queries the Min Block Size .

Query

Range: 0 to 22996 bits, 9.91E+37

Resolution: 1 bit

*RST Setting

 9.91E+37

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:EDCHannel:BLOCk:SIZE:MINimum?"

CALL:STATus:EDCHannel[:CELL]:IBTHroughput?

Function

 Queries the Throughput .

Query

Range: 0 to 11500 kbps, 9.91E+37

Resolution: 1 kbps

*RST Setting

 9.91E+37

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:EDCHannel:IBTHroughput?"

CALL:STATus:EHIChannel[:CELL][:LEVel]?

Function

 Queries the current level of the E-HICH. See Downlink Code Channel Information .

Query

Range: -20.00 dB to 0.00 dB, 9.91E+37

Resolution: 0.01 dB

*RST Setting

 9.91E+37

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:EHIChannel?"

CALL:STATus:EHIChannel[:CELL]:STATe?

Function

 Queries the current state of the E-HICH. See Downlink Code Channel Information .

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:EHIChannel:STATe?"

CALL:STATus:EHIChannel[:CELL]:ACK[:COUNt]?

Function

 Queries the ACKs Transmitted .

Query

Range: 0 to 150000, 9.91E+37

Resolution: 1

*RST Setting

 9.91E+37

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:EHIChannel:ACK?"

CALL:STATus:EHIChannel[:CELL]:NACK[:COUNt]?

Function

 Queries the ACKs Transmitted .

Query

Range: 0 to 150000, 9.91E+37

Resolution: 1

*RST Setting

 9.91E+37

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:EHIChannel:NACK?"

CALL:STATus:ERGChannel[:CELL][:LEVel]?

Function

 Queries the current level of the E-RGCH. See Downlink Code Channel Information .

Query

Range: -20.00 dB to 0.00 dB, 9.91E+37

Resolution: 0.01 dB

*RST Setting

 9.91E+37

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:ERGChannel?"

CALL:STATus:ERGChannel[:CELL]:STATe?

Function

 Queries the current state of the E-RGCH. See Downlink Code Channel Information .

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:ERGChannel:STATe?"

CALL:STATus:ETFCi[:LAST]?

Function

 Queries the Last Received E-TFCI .

Query

Range: 0 to 127, 9.91E+37

Resolution: 1

*RST Setting

 9.91E+37

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:ETFCi?"

CALL:STATus:ETFCi:BOOSt?

Function

 Queries the Current E-TFCI Boost .

Query

Range: 0 to 127, 9.91E+37

Resolution: 1

*RST Setting

 9.91E+37

Requirements

Test Application Revision: A.17.00 and above, with the required feature license
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:ETFCi:BOOSt?"

CALL:STATus:ETFCi:RECord[:STATe]?

Function

 Queries the E-TFCI Recording State .

Query

Range: REC(recording)|IDLE

*RST Setting

 IDLE

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:ETFCi:RECord?"

CALL:STATus:ETFCi:RECord:ALL?

Function

Queries the Recorded E-TFCI Values . This result always returns 50 comma-separated numbers; Number of E-TFCI Results Recorded E-TFCI values, followed by NANs (9.91E+37).

Query

Range: 0 to 127, 9.91E+37

Resolution: 1

*RST Setting

 9.91E+37

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:ETFCi:RECord:ALL?"

CALL:STATus:ETFCi:RECord:COUNt?

Function

 Queries the Number of E-TFCI Results Recorded .

Query

Range: 0 to 50

Resolution: 1

*RST Setting

 0

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:ETFCi:RECord:COUNt?"

CALL:STATus:ETFCi:RECord:FRAMe:INDicator?

Function

 Queries the Recorded E-TFCI Integrity Indicators.

Query

Range: An array of 50 values, each element of the array has the following range:

- NONE (No value recorded)
- GCRC (Good CRC)
- BCRC (Bad CRC)
- DTX (EDPDCH subframe is DTX'd for an E-DCH TTI transmission)

*RST Setting

 NONE (No value recorded)

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:STATus:ETFCi:RECord:FRAMe:INDicator?"

CALL:STATus:FBINdicator?

Function

Queries the Current Info, Frequency Band .

Query

Range: BAND1|BAND2|BAND3|BAND4|BAND5|BAND6|BAND7|BAND8|BAND9|BAND10|
BAND11|BAND12|BAND13|BAND14|BAND19|BAND20|BAND21

*RST Setting

 BAND1

Requirements

Test Application Revision: A.08 and above.

Test Application Revision A.09, added BAND8 and BAND9.

Lab Application Revision: C.03 and above.

Lab Application Revision C.04 and D.00, added BAND8 and BAND9.

Test Application Revision A.10.01 and Lab Application Revision D.01.01 added BAND7

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, added BAND10

Test Application Revision A.13 and Lab Application Revision E.00.34, added BAND11

Test Application Revision A.14 and Lab Application Revision F.00, added BAND12, BAND13, BAND14

Test Application Revision A.18.00 and Lab Application Revision F.00, added BAND19, BAND20 and BAND21

Programming Example

OUTPUT 714;"CALL:STATus:FBINdicator?"

CALL:STATus:HSDSchannel:TBSize?

Function

 Queries the "Current Test Mode Transport Block Size".

Query

Range: 120 to 42192

Resolution: 1

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Test Application Revision A.14 and Lab Application Revision F.00 and above, range extended.

Programming Example

OUTPUT 714;"CALL:STATus:HSDSchannel:TBSize?"

CALL:STATus:HSDSchannel:TBSize:PSData?

Function

 Queries the "Current Test Mode Transport Block Size".

Query

Range: 137 to 27952

Resolution: 1

*RST Setting

 4664

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:HSDSchannel:TBSize:PSData?"

CALL:STATus:HSPDschannel[:CELL][:LEVel]?

Function

Queries the current sum of the powers in all of the active HS-PDSCH channels. See Downlink Code Channel Information .

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Test Application Revision A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:STATus:HSPDschannel?"

CALL:STATus:HSPDschannel[:CELL]:STATe?

Function

Queries the current state of the HS-PDSCH channels. See Downlink Code Channel Information .

Query

Range:

  • 1 (on) - power is present in one or more HS-PDSCHs
  • 0 (off) - no power is present in any HS-PDSCH

*RST Setting

 0 (off)

Requirements

Test Application Revision A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:STATus:HSPDschannel:STATe?"

CALL:STATus:HSSCchannel[1][:CELL][:LEVel]?

Function

Queries the current HS-SCCH 1 power level. See Downlink Code Channel Information .

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Test Application Revision A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:STATus:HSSCchannel?"

CALL:STATus:HSSCchannel[1][:CELL]:STATe?

Function

Queries the current state of the HS-SCCH 1 channel. See Downlink Code Channel Information .

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:STATus:HSSCchannel:STATe?"

CALL:STATus:HSSCchannel2[:CELL][:LEVel]?

Function

Queries the current HS-SCCH 2 power level. See Downlink Code Channel Information .

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Test Application Revision A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:STATus:HSSCchannel2?"

CALL:STATus:HSSCchannel2[:CELL]:STATe?

Function

Queries the current state of the HS-SCCH 2 channel. See Downlink Code Channel Information .

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:STATus:HSSCchannel2:STATe?"

CALL:STATus:HSSCchannel3[:CELL][:LEVel]?

Function

Queries the current HS-SCCH 3 power level. See Downlink Code Channel Information .

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Test Application Revision A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:STATus:HSSCchannel3?"

CALL:STATus:HSSCchannel3[:CELL]:STATe?

Function

Queries the current state of the HS-SCCH 3 channel. See Downlink Code Channel Information .

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:STATus:HSSCchannel3:STATe?"

CALL:STATus:HSSCchannel4[:CELL][:LEVel]?

Function

Queries the current HS-SCCH 4 power level. See Downlink Code Channel Information .

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Test Application Revision A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:STATus:HSSCchannel4?"

CALL:STATus:HSSCchannel4[:CELL]:STATe?

Function

Queries the current state of the HS-SCCH 4 channel. See Downlink Code Channel Information .

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Test Application Revision A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"CALL:STATus:HSSCchannel4:STATe?"

CALL:STATus:MAXimum:ALLowed:CQI:VALue?

Function

Queries the Maximum Allowed CQI Value.

Query

Range: 0 to 30, 9.91 E+37

Resolution: 1

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:MAXimum:ALLowed:CQI:VALue?"

CALL:STATus:MCELl?

Function

Queries Multi-Cell UTRAN Status.

Query

Range: NONE|MAIN|MLOC|MEXT|MSHO|AUX|AACT

*RST Setting

 NONE

Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:STATus:MCELl?"

CALL:STATus:MM?

Function

Queries MM Status .

Query

Range:

  • MMSTATUS1 (Updated (Normal))
  • MMSTATUS2 (Updated (Periodic))
  • MMSTATUS3 (IMSI Attached)
  • MMSTATUS4 (IMSI Detached)
  • MMSTATUS5 (None)

*RST Setting

 MMSTATUS5

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:STATus:MM?"

CALL:STATus:MPOWer:OFFSet:SIGNaled?

Function

Queries the "Last Signaled Measurement Power Offset".

Query

Range: -6.0 to +13.0 9.91E+37

*RST Setting

 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:MPOWer:OFFSet:SIGNaled?"

CALL:STATus:MS:HSDSchannel:CATegory?

Function

Queries Current UE HS-DSCH Category .

Query

Range: 1-14, 17, 18, 9.91E+37

*RST Setting

 9.91E+37

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Test Application Revision A.10 and Lab Application Revision D.01 added UE categories 7 and 8

Lab Application Revision F.00.07 expanded range from "1-8, 11, 12" to "1-14, 17, 18"

Programming Example

OUTPUT 714;"CALL:STATus:MS:HSDSchannel:CATegory?"

CALL:STATus:MS:IP:ADDRess:IP4?

Function

Queries the Current DUT IPv4 Address.

Query

Range: "" (Null) or 15 characters of standard IPv4 address formatted as: A.B.C.D, where A, B, C, and D are between 0 and 255

*RST Setting

 "" (Null)

Requirements

 Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:STATus:MS:IP:ADDRess:IP4?"

CALL:STATus:MS:IP:ADDRess:IP6:IID?

Function

Queries the Current DUT IPv6 IID. This is the IID part of the negotiated DUT IPv6 address. The DUT IPv6 address is formed by combining the DUT IPv6 IID with the link-local prefix or the IPv6 Prefix. The testset assigns DUT IPv6 IID either by accepting an UE proposed value or by generating a random number.

Query

Range: "" (Null) or 19 characters of standard IPv6 address formatted as: AAAA.BBBB.CCCC.DDDD, where A, B, C, and D are all hex numbers between 0 and F.

*RST Setting

 "" (Null)

Requirements

 Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:STATus:MS:IP:ADDRess:IP6:IID?"

CALL:STATus:MS:IP:ADDRess2:IP4?

Function

Queries the Current DUT IPv4 Address 2.

This setting returns the current negotiated DUT IPv4 address used by the second primary PDP context.

Query

Range: "" (Null) or 15 characters of standard IPv4 address formatted as: A.B.C.D, where A, B, C, and D are between 0 and 255

*RST Setting

 "" (Null)

Requirements

 Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:MS:IP:ADDRess2:IP4?"

CALL:STATus:MS:IP:ADDRess2:IP6:IID?

Function

Queries the Current DUT IPv6 IID 2 . This is the IID part of the negotiated DUT IPv6 address used by the second primary PDP context. The DUT IPv6 address is formed by combining the DUT IPv6 IID with the link-local prefix or the IPv6 Prefix. The testset assigns DUT IPv6 IID either by accepting an UE proposed value or by generating a random number.

Query

Range: "" (Null) or 19 characters of standard IPv6 address formatted as: AAAA.BBBB.CCCC.DDDD, where A, B, C, and D are all hex numbers between 0 and F.

*RST Setting

 "" (Null)

Requirements

 Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:STATus:MS:IP:ADDRess2:IP6:IID?"

CALL:STATus:MS:PDPContext:ACTivated:COUNt?

Function

Queries the Current Activated PDP Contexts Number .

This setting return the status of PDP contexts.

Query

Range: 0|1|2

*RST Setting

 0

Requirements

 Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:MS:PDPContext:ACTivated:COUNt?"

CALL:STATus:OCNSource[:CELL][:LEVel]([:SELected]|:FDD)?

Function

Queries the orthogonal channel noise source (OCNS) level for the selected system type. See Downlink Code Channel Information .

The OCNS level is set using the CALL:OCNSource commands.

The optional [:SELected] keyword in this command specifies that the OCNS channel level being queried applies to the current system type.

Query

Range: 0 to -20 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision A.06 changed *RST Setting to 9.91 E+37.

Lab Application Revision C.01 changed *RST Setting to 9.91 E+37.

Programming Example

OUTPUT 714;"CALL:STATus:OCNSource?"

CALL:STATus:OCNSource[:CELL]:STATe([:SELected]|:FDD)?

Function

Queries the current on/off state of the orthogonal channel noise simulator channel (OCNS). See Downlink Code Channel Information .

The OCNS channel on/off state is set using the CALL:OCNSource commands.

The optional [:SELected] keyword in this command specifies that the OCNS channel state being queried applies to the current system type.

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:OCNSource:STATe?"

CALL:STATus:OCNSource:CELL2[:LEVel]([:SELected]|:FDD)?

Function

Queries the cell 2 orthogonal channel noise source (OCNS) level for the selected system type. See Downlink Code Channel Information .

The OCNS level is set using the CALL:CELL2:OCNSource commands.

The optional [:SELected] keyword in this command specifies that the OCNS channel level being queried applies to the current system type.

(See Cell 2 Overview ).

Query

Range: 0 to -20 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:OCNSource:CELL2?"

CALL:STATus:OCNSource:CELL2:STATe([:SELected]|:FDD)?

Function

Queries the current cell 2 on/off state of the orthogonal channel noise simulator channel (OCNS). See Downlink Code Channel Information .

The OCNS channel on/off state is set using the CALL:CELL2:OCNSource commands.

The optional [:SELected] keyword in this command specifies that the OCNS channel state being queried applies to the current system type.

(See Cell 2 Overview ).

Query

Range: 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:OCNSource:CELL2:STATe?"

CALL:STATus:PICHannel[:CELL][:LEVel]?

Function

Queries the current downlink page indicator channel's power. See Downlink Code Channel Information .

Query

Range: -20.00 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 -8.3 dB

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision A.06 changed *RST Setting to -8.3 dB.

Lab Application Revision C.01 changed *RST Setting to -8.3 dB.

Programming Example

OUTPUT 714;"CALL:STATus:PICHannel?"

CALL:STATus:PICHannel[:CELL]:STATe?

Function

Queries the current state of the downlink page indicator channel. See Downlink Code Channel Information .

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:PICHannel:STATe?"

CALL:STATus:PRAChannel[:CELL]:CURCbeta?

Function

Queries the current power gain for the control data of the message portion of the uplink physical random access channel (PRACH) see PRACH Bc/Bd Control .

Query

Range: 2 to 15

Resolution: 1

*RST Setting

 15

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:PRAChannel:CURCbeta?"

CALL:STATus:PRAChannel[:CELL]:CURDbeta?

Function

Queries the current power gain for the message data of the message portion of the uplink physical random access channel (PRACH) see PRACH Bc/Bd Control .

Query

Range: 0 to 15

Resolution: 1

*RST Setting

 15

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:PRAChannel:CURDbeta?"

CALL:STATus:REPorted:CQI:LIMitation:COUNt?

Function

Queries the Count of Reported CQI Limitations. This result counts how many times the Maximum Allowed CQI Value is used instead of using reported CQI to avoid code collision.

Query

Range: 0 to 1,500,000, 9.91 E+37

Resolution: 1

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:REPorted:CQI:LIMitation:COUNt?"

CALL:STATus:REPorted:SCELl:CQI:LIMitation:COUNt?

Function

Queries how many times the Serving Cell Maximum Allowed CQI Value is used instead of using reported CQI to avoid code collision on the DC-HSDPA serving cell.

The result is only available in the LA.

Query

Range: 0 to 1,500,000, 9.91 E+37

*RST Setting

 9.91 E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:REPorted:SCELl:CQI:LIMitation:COUNt?"

CALL:STATus:REPorted:SSCell:CQI:LIMitation:COUNt?

Function

Queries the Count of Reported CQI Limitations. This result counts how many times the Maximum Allowed CQI Value is used instead of using reported CQI to avoid code collision on the DC-HSDPA secondary serving cell.

Query

Range: 0 to 1,500,000, 9.91 E+37

*RST Setting

 9.91 E+37

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:REPorted:SSCell:CQI:LIMitation:COUNt?"

CALL:STATus:DCARrier:TOTal:POWer[:AMPLitude]?

Function

Queries the UTRA FDD Dual Carrier Total RF Power.

Query

Range:

-162dBm/(3.84+3.84)MHz to +40dBm/(3.84+3.84)MHz, No Results Available

(-112dBm/(3.84+3.84)MHz to -13dBm/(3.84+3.84)MHz actual hardware range with amplitude offset = 0)

Resolution: 0.01 dBm/(3.84+3.84)MHz

Note: The actual power range is defined by adding the value of the associated Amplitude Offset to the range in the table. E.g. if Amplitude Offset is -3.5 dB, then the power range will be -115.5dBm/(3.84+3.84)MHz to -13.5dBm/(3.84+3.84)MHz.

*RST Setting

 No Results Available

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:DCARrier:TOTal:POWer?"

CALL:STATus:DCARrier:TOTal:STATe?

Function

Queries UTRA FDD Dual Carrier Total RF Power State.

Query

Range: 1|0

*RST Setting

 0 (Off)

Requirements

Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:DCARrier:TOTal:STATe?"
! Query the UTRA FDD Dual Carrier Total RF Power State.

CALL:STATus:ROHC:DOWNlink:CID:LARGe?

Function

Queries the Current Downlink ROHC Large CIDs.

This result is inferred from the "Current Downlink ROHC Max CID". If the "Current Downlink ROHC Max CID" is greater than 15, then this result is "True", otherwise this result is "False".

Query

Range: 1|0

*RST Setting

0

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:STATus:ROHC:DOWNlink:CID:LARGe?"

CALL:STATus:ROHC:DOWNlink:CID:MAXimum?

Function

Queries the Current Downlink ROHC Max CID.

Query

Range: 1 to 16383

Resolution: 1

*RST Setting

 15

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:STATus:ROHC:DOWNlink:CID:MAXimum?"

CALL:STATus:ROHC:DOWNlink:RDDepth?

Function

Queries the Current Downlink Reverse Decompression Depth.

Query

Range: 0 to 65535

Resolution: 1

*RST Setting

 0

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:STATus:ROHC:DOWNlink:RDDepth?"

CALL:STATus:ROHC:UPLink:CID:LARGe?

Function

Queries the Current Uplink ROHC Large CIDs.

This result is inferred from the "Current Uplink ROHC Max CID". If the "Current Uplink ROHC Max CID" is greater than 15, then this result is "True", otherwise this result is "False".

Query

Range: 1|0

*RST Setting

 0

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:STATus:ROHC:UPLink:CID:LARGe?"

CALL:STATus:ROHC:UPLink:CID:MAXimum?

Function

Queries the Current Uplink ROHC Max CID.

Query

Range: 1 to 16383

Resolution: 1

*RST Setting

 15

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:STATus:REPorted:CQI:LIMitation:COUNt?"

CALL:STATus:RRC:STATe?

Function

Queries RRC State .

Query

Range: DCH|FACH|IDLE

*RST Setting

 IDLE

Requirements

 Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"CALL:STATus:RRC:STATe?"

CALL:STATus:SERVice:TYPe?

Function

Queries the Current Service Type .

The current service type will be set to NONE when an event occurs that causes the service to be stopped. These events include:

  • End Call
  • A call processing error that results in a dropped call
  • UE initiated end of service
  • Full or Partial Preset

Query

Range:

  • AMR: AMR Voice
  • AHSP: AMR Voice + PS Data - HSPA (only applicable to the lab application)
  • APSD: AMR +PS Data (only applicable to the lab application)
  • CSDA: CS Data - Async ( only applicable to the lab application )
  • CSDV: CS Data - Video Call ( only applicable to the lab application and to a test application with the required feature license )
  • GPRS: UMTS/GPRS Packet Data ( only applicable to the lab application )
  • PHSP: UMTS/GPRS Packet Data - HSPA ( only applicable to the lab application )
  • PSDH: UMTS/GPRS Packet Data - HSDPA ( only applicable to the lab application )
  • RBT: RB Test Mode
  • RBTH: RB Test Mode - HSDPA ( only applicable to the lab application and to a test application with the required feature license )
  • RHSP: RB Test Mode - HSPA ( only applicable to the test application with the required feature license )
  • MMC: Mobile Management connection ( only applicable to the lab application )
  • NONE

*RST Setting

 NONE

Requirements

Test Application Revision: A.01 and above

Test Application Revision A.04 added AMR

Test Application Revision A.06 with the required feature license, added CSDV

Test Application Revision A.08.20 added RBTH

Test Application Revision A.12 with the required feature license and Lab Application Revision E.00.16, added RHSP

Lab Application Revision: A.01 and above

Lab Application Revision A.02 added AMR

Lab Application Revision C.01 added CSDV

Lab Application Revision C.03 added RBTH

Lab Application Revision D.00 added PSDH

Lab Application Revision E.00.16 added APSD

Lab Application Revision U.00.13 added PHSP

Lab Application Revision U.00.31 added AHSP

Lab Application Revision F.00 and above added MMC

Programming Example

OUTPUT 714;"CALL:STATus:SERVice:TYPe?"
! Returns the current service type.

CALL:STATus:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>UPLink[:CHANnel]?

Function

Queries PCR Info, UL: Channel and Frequency .

Query

Range: see CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CHANnel

*RST Setting

 see CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CHANnel

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Test Application Revision A.09 and Lab Application Revisions C.04 and D.00, added [:CHANnel]

All other changes match the CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink:CHANnel command.

Programming Example

OUTPUT 714;"CALL:STATus:SETup:CHANnel:UPLink?"

CALL:STATus:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>UPLink:SEParation?

Function

Queries the PCR Info, DL/UL Frequency Separation .

Query

Range: MHZ30|MHZ31|MHZ41|MHZ45|MHZ48|MHZ80|MHZ95|MHZ120|MHZ190|MHZ400|NSTD

*RST Setting

 MHZ190

Requirements

Test Application Revision: A.09 and above

Test Application Revision A.10.01, added MHZ120

Test Application Revision A.11, added [:PCReconfig]

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Lab Application Revision D.01.01, added MHZ120

Lab Application Revision D.02, added [:PCReconfig]

Lab Application Revision E.00.34, added MHZ48

Test Application Revision A.14 and Lab Application Revision F.00, added MHZ30 and MHZ31

Test Application Revision A.18.00 and Lab Application Revision H.00.00 and above, added MHZ41

Programming Example

OUTPUT 714;"CALL:STATus:SETup:CHANnel:UPLink:SEParation?"

CALL:STATus:SETup[:PCReconfig]:FBINdicator?

Function

Queries the PCR Info, Frequency Band .

Query

Range: BAND1|BAND2|BAND3|BAND4|BAND5|BAND6|BAND7|BAND8|BAND9|BAND10|
BAND11|BAND12|BAND13|BAND14|BAND19|BAND20|BAND21

*RST Setting

 BAND1

Requirements

Test Application Revision: A.09 and above

Lab Application Revisions: C.04 and D.00 and above

Test Application Revision A.10.01 and Lab Application Revision D.01.01, added BAND7

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, added BAND10

Test Application Revision A.11 and Lab Application Revision D.02, added [:PCReconfig]

Test Application Revision A.13 and Lab Application Revision E.00.34, added BAND11

Test Application Revision A.14 and Lab Application Revision F.00, added BAND12, BAND13, and BAND14

Test Application Revision A.18.00 and Lab Application Revision H.00.00 and above, added BAND19, BAND20 and BAND21.

Programming Example

OUTPUT 714;"CALL:STATus:SETup:FBINdicator?"

CALL:STATus:SETup:RBReconfig:CHANnel:UPLink[:CHANnel]?

Function

Queries RBR Info, UL: Channel and Frequency .

Query

Range: see CALL:SETup:RBReconfig:CHANnel:UPLink:CHANnel

*RST Setting

 see CALL:SETup:RBReconfig:CHANnel:UPLink:CHANnel

Requirements

Test Application Revision A.11 and Lab Application Revision D.02 and above

Lab Application Revision: E.00.34 and above, added 3487 - 3587.

Test Application Revision A.14 and Lab Application Revision F.00 and above, added 3612 - 3678, 3702, 3707, 3732, 3737, 3762, 3767, 3792 - 3818, 3842, 3867, 3892 - 3918, 3942, 3967

Test Application Revision: A.18.00 and Lab Application Revision H.00.00 and above, added 312 to 363, 387, 412, 437, 4287 to 4413 and 462 to 512

Programming Example

OUTPUT 714;"CALL:STATus:SETup:RBReconfig:CHANnel:UPLink?"

CALL:STATus:SETup:RBReconfig:CHANnel:UPLink:SEParation?

Function

Queries RBR Info, DL/UL Frequency Separation .

Query

Range: MHZ30|MHZ31|MHZ41|MHZ45|MHZ48|MHZ80|MHZ95|MHZ120|MHZ190|MHZ400|NSTD

*RST Setting

 MHZ190

Requirements

Test Application Revision A.11 and Lab Application Revision D.02 and above

Lab Application Revision E.00.34, added MHZ48

Test Application Revision A.14 and Lab Application Revision F.00, added MHZ30 and MHZ31

Test Application Revision A.18.00 and Lab Application Revision H.00.00 and above, added MHZ41

Programming Example

OUTPUT 714;"CALL:STATus:SETup:RBReconfig:CHANnel:UPLink:SEParation?"

CALL:STATus:SETup:RBReconfig:DPCHannel:CBETa?

Function

 Queries the beta c value that the test set will signal to the UE during the Radio Bearer Reconfiguration (see RBR Uplink DPCH Bc/Bd Control ).

Query

Range: 1 to 15

Resolution: 1

*RST Setting

 8

Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, range is 1 to 15 (vs. 2 to 15)

Programming Example

OUTPUT 714;"CALL:STATus:SETup:RBReconfig:DPCHannel:CBETa?"

CALL:STATus:SETup:RBReconfig:DPCHannel:DBETa?

Function

 Queries the beta d value that the test set will signal to the UE during the Radio Bearer Reconfiguration (see RBR Uplink DPCH Bc/Bd Control ).

Query

Range: 0 to 15

Resolution: 1

*RST Setting

 15

Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:SETup:RBReconfig:DPCHannel:DBETa?"

CALL:STATus:SETup:RBReconfig:FBINdicator?

Function

Queries RBR Info, Frequency Band .

Query

Range: BAND1|BAND2|BAND3|BAND4|BAND5|BAND6|BAND7|BAND8|BAND9|BAND10|
BAND11|BAND12|BAND13|BAND14|BAND19|BAND20|BAND21

*RST Setting

 BAND1

Requirements

Test Application Revision A.11 and Lab Application Revision D.02 and above

Lab Application Revision: E.00.34 and above, added BAND11

Test Application Revision A.14 and Lab Application Revision F.00, added BAND12, BAND13, and BAND14

Test Application Revision A.18.00 and Lab Application Revision H.00.00 and above, added BAND19, BAND20 and BAND21.

Programming Example

OUTPUT 714;"CALL:STATus:SETup:RBReconfig:FBINdicator?"

CALL:STATus:SETup:TCReconfig:CHANnel:UPLink[:CHANnel]?

Function

Queries TCR Info, UL: Channel and Frequency .

Query

Range: see CALL:SETup:TCReconfig:CHANnel:UPLink:CHANnel

*RST Setting

 see CALL:SETup:TCReconfig:CHANnel:UPLink:CHANnel

Requirements

Test Application Revision A.11 and Lab Application Revision D.02 and above

Lab Application Revision: E.00.34 and above, added 3487 - 3587.

Test Application Revision A.14 and Lab Application Revision F.00 and above, added 3612 - 3678, 3702, 3707, 3732, 3737, 3762, 3767, 3792 - 3818, 3842, 3867, 3892 - 3918, 3942, 3967

Test Application Revision: A.18.00 and Lab Application Revision H.00.00 and above, added 312 to 363, 387, 412, 437, 4287 to 4413 and 462 to 512

Programming Example

OUTPUT 714;"CALL:STATus:SETup:TCReconfig:CHANnel:UPLink?"

CALL:STATus:SETup:TCReconfig:CHANnel:UPLink:SEParation?

Function

Queries TCR Info, DL/UL Frequency Separation .

Query

Range: MHZ30|MHZ31|MHZ41|MHZ45|MHZ48|MHZ80|MHZ95|MHZ120|MHZ190|MHZ400|NSTD

*RST Setting

 MHZ190

Requirements

Test Application Revision A.11 and Lab Application Revision D.02 and above

Lab Application Revision E.00.34, added MHZ48

Test Application Revision A.14 and Lab Application Revision F.00, added MHZ30 and MHZ31

Test Application Revision A.18.00 and Lab Application Revision H.00.00 and above, added MHZ41

Programming Example

OUTPUT 714;"CALL:STATus:SETup:TCReconfig:CHANnel:UPLink:SEParation?"

CALL:STATus:SETup:TCReconfig:DPCHannel:CBETa?

Function

 Queries the beta c value that the test set will signal to the UE during the Transport Channel Reconfiguration (see TCR DPCH Bc/Bd Control ).

Query

Range: 1 to 15

Resolution: 1

*RST Setting

 8

Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, range is 1 to 15 (vs. 2 to 15)

Programming Example

OUTPUT 714;"CALL:STATus:SETup:TCReconfig:DPCHannel:CBETa?"

CALL:STATus:SETup:TCReconfig:DPCHannel:DBETa?

Function

 Queries the beta d value that the test set will signal to the UE during the Transport Channel Reconfiguration (see TCR DPCH Bc/Bd Control ).

Query

Range: 0 to 15

Resolution: 1

*RST Setting

 15

Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:SETup:TCReconfig:DPCHannel:DBETa?"

CALL:STATus:SETup:TCReconfig:FBINdicator?

Function

Queries TCR Info, Frequency Band .

Query

Range: BAND1|BAND2|BAND3|BAND4|BAND5|BAND6|BAND7|BAND8|BAND9|BAND10|
BAND11|BAND12|BAND13|BAND14|BAND19|BAND20|BAND21

*RST Setting

 BAND1

Requirements

Test Application Revision A.11 and Lab Application Revision D.02 and above

Test Application Revision A.13 and Lab Application Revision E.00.34 and above, added BAND11

Test Application Revision A.14 and Lab Application Revision F.00, added BAND12, BAND13, and BAND14

Test Application Revision A.18.00 and Lab Application Revision H.00.00 and above, added BAND19, BAND20 and BAND21.

Programming Example

OUTPUT 714;"CALL:STATus:SETup:TCReconfig:FBINdicator?"

CALL:STATus:SGRant:RELative:QUEued:COUNt?

Function

Queries Queued Relative Grants .

Query

Range: 0 to 1000

*RST Setting

 0

Requirements

Test Application Revision A.12 and above, with the required feature license

Lab Application Revision E.00.16 and above

Programming Example

OUTPUT 714;"CALL:STATus:SGRant:RELative:QUEued:COUNt?"

CALL:STATus:SHANdoff:EVENt?

Function

Queries the most recent Intra Frequency Event identifier. Events can be:

  • 1a
  • 1b
  • 1c
  • 1d
  • 1e
  • 1f
  • None

(See Event Reporting ).

Query

Range: 1A|1B|1C|1D|1E|1F|NONE

*RST Setting

 NONE

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:SHANdoff:EVENt?" !Returns the most recent event.

CALL:STATus:SHANdoff:EVENt:CELLid?

Function

 Queries the cell that triggered the most recent event. (See Event Reporting ).

Query

Range: CELL1|CELL2|NONE

*RST Setting

 NONE

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:SHANdoff:EVENt:CELLid?"

CALL:STATus:SHANdoff:STATe?

Function

 Queries Soft Handover State .

Query

Range: 1|0

*RST Setting

 0

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:SHANdoff:STATe?"

CALL:STATus:SSCell:POWer[:AMPLitude]?

Function

Queries the Current UTRA FDD Carrier 2 Cell Power.

Query

Range: -165dBm/3.84MHz to +37dBm/3.84MHz, 9.91 E+37 (NAN)

(-115dBm/3.84MHz to -13dBm/3.84MHz actual hardware range with amplitude offset=0)

Resolution:0.01dBm/3.84MHz

Note: The actual power range is defined by adding the value of the associated Amplitude Offset to the range above. E.g. if Amplitude Offset is -3.5dB, then the power range will be -118.5dBm/3.84MHz to -16.5dBm/3.84MHz.

*RST Setting

 9.91 E+37 (NAN)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SScell:Power?"
! Returns the Current UTRA FDD Carrier 2 Cell Power.

CALL:STATus:SSCell:POWer:STATe?

Function

Queries the Current UTRA FDD Carrier 2 Cell Power State.

Query

Range: 1|On|0|Off

*RST Setting

0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:POWer:STATe?"
! Returns the Current UTRA FDD Carrier 2 Cell Power State.

CALL:STATus:SSCell:TOTal:POWer[:AMPLitude]?

Function

Queries the desired total power on the carrier 2, which is equivalent to the Secondary Serving Cell Power .

Query

Range: -165dBm/3.84MHz to +37dBm/3.84MHz , 9.91 E+37 (NAN)

(-115dBm/3.84MHz to -13dBm/3.84MHz actual hardware range with amplitude offset=0)

Resolution:0.01dBm/3.84MHz

Note: The actual power range is defined by adding the value of the associated Amplitude Offset to the range above. E.g. if Amplitude Offset is -3.5 dB, then the power range will be -118.5dBm/3.84MHz to -16.5dBm/3.84MHz.

*RST Setting

 9.91 E+37 (NAN)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:TOTal:POWer?"
! Returns the UTRA FDD Carrier 2 Total RF Power.

CALL:STATus:SSCell:TOTal:POWer:STATe?

Function

Queries the desired power state of the carrier 2, which is equivalent to the "Secondary Serving Cell Power State".

Query

Range: 1|On|0|Off

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:TOTal:POWer:STATe?"
! Returns the UTRA FDD Carrier 2 Total RF Power State.

CALL:STATus:SSCell:UPLink:FREQuency?

Function

Queries the UL frequency that the test set is currently using.

Query

Range:

  • 1920 to 1980 MHz
  • 1850 to 1910 MHz
  • 1710 to 1785 MHz
  • 824 to 862 MHz
  • 2500 to 2570 MHz
  • 880 to 915 MHz
  • 1710 to 1784.9 MHz
  • 1427.9 to 1447.9 MHz
  • 698 to 716 MHz
  • 777 to 787 MHz
  • 788 to 798 MHz
  • 1447.9 to 1462.9 MHz

Increment: 0.1 MHz

*RST Setting

 1955.0 MHz

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:UPLink:FREQuency?"
!Returns the UTRA FDD Current Carrier 2 UL Frequency.

CALL:STATus:SSCell:DOWNlink:FREQuency?

Function

Queries the DL frequency that the test set is currently using.

Query

Range:

  • 2110 to 2170 MHz
  • 1930 to 1990 MHz
  • 1805 to 1880 MHz
  • 869 to 894 MHz
  • 2620 to 2690 MHz
  • 925 to 960 MHz
  • 1475.9 to 1495.9 MHz
  • 728 to 746 MHz
  • 746 to 756 MHz
  • 758 to 768 MHz
  • 791 to 821 MHz
  • 1495.9 to 1510.9 MHz

Increment: 0.1 MHz

*RST Setting

 2145.0 MHz

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:DOWNlink:FREQuency?"
!Returns the UTRA FDD Current Carrier 2 DL Frequency.

CALL:STATus:SSCell:CPIChannel:STATe?

Function

Queries the Current UTRA FDD Carrier 2 CPICH State

Query

Range: 1|On|0|Off

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:CPIChannel:STATe?"
! Returns the current UTRA FDD Carrier 2 CPICH State.

C ALL:STATus:SSCell:CPIChannel:[:LEVel]?

Function

Queries the Current UTRA FDD Carrier 2 CPICH Power Offset.

Query

Range: -20.00 to 0 dB, 9.91 E+37 (NAN)

Resolution: 0.01 dB

*RST Setting

 9.91 E+37 (NAN)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:CPIChannel?"
! Returns the Current UTRA FDD Carrier 2 CPICH Power Offset.

CALL:STATus:SSCell:CCPChannel:PRIMary:STATe?

Function

Queries the Current UTRA FDD Carrier 2 P-CCPCH/SCH State.

Query

Range: 1|On|0|Off

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:CCPChannel:PRIMary:STATe?"
! Returns the Current UTRA FDD Carrier 2 P-CCPCH/SCH State.

CALL:STATus:SSCell:CCPChannel:PRIMary[:LEVel]?

Function

Queries the Current UTRA FDD Carrier 2 P-CCPCH/SCH Power Offset.

Query

Range: -20.00 to 0 dB, 9.91 E+37 (NAN)

Resolution: 0.01 dB

*RST Setting

 9.91 E+37 (NAN)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:CCPChannel:PRIMary?"
! Returns the Current UTRA FDD Carrier 2 P-CCPCH/SCH Power Offset.

CALL:STATus:SSCell:PICHannel:STATe?

Function

Queries the Current UTRA FDD Carrier 2 PICH State.

Query

Range: 1|On|0|Off

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:PICHannel:STATe?"
! Returns the Current UTRA FDD Carrier 2 PICH Power Offset.

CALL:STATus:SSCell:PICHannel:[:LEVel]?

Function

Queries the Current UTRA FDD Carrier 2 PICH Power Offset.

Query

Range: -20.00 to 0 dB, 9.91 E+37 (NAN)

Resolution: 0.01 dB

*RST Setting

 9.91 E+37 (NAN)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:PICHannel?"
! Returns the Current UTRA FDD Carrier 2 PICH Power Offset.

CALL:STATus:SSCell:HSPDschannel:STATe?

Function

Queries the Current FDD Carrier 2 HS-PDSCH Power Offset.

Setting

Range: 1|On|0|Off

Query

Same as setting

*RST Setting

 1 (On)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:HSPDschannel:STATe?"

CALL:STATus:SSCell:HSPDschannel:[LEVel]?

Function

Queries the Current FDD Carrier 2 HS-PDSCH Power Offset.
Setting

Range: -35.00 to 0 dB, 9.91 E+37 (NAN)

Resolution: 0.01 dB

Increment: 0.1 dB

Query

 Same as setting

*RST Setting

 -3 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:HSPDschannel?"

CALL:STATus:SSCell:HSSCchannel1:STATe?

Function

Queries the Current UTRA FDD Carrier 2 HS-SCCH 1 State.

Query

Range: 1|On|0|Off

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:HSSCchannel1:STATe?"

CALL:STATus:SSCell:HSSCchannel1:[LEVel]?

Function

Queries the Current UTRA FDD Carrier 2 HS-SCCH 1 Power Offset.

Setting

Range: -20.00 to 0 dB, 9.91 E+37 (NAN)

Resolution: 0.01 dB

Increment: 0.1 dB

Query

 Same as setting

*RST Setting

 -10 dB

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:HSSCchannel1?"

CALL:STATus:SSCell:HSSCchannel2:STATe?

Function

Queries the Current UTRA FDD Carrier 2 HS-SCCH 2 State.

Query

Range: 1|On|0|Off

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:HSSCchannel2:STATe?"

CALL:STATus:SSCell:HSSCchannel2:[LEVel]?

Function

Queries the Current UTRA FDD Carrier 2 HS-SCCH 2 Power Offset.

Setting

Range: -20.00 to 0 dB, 9.91 E+37 (NAN)

Resolution: 0.01 dB

Increment: 0.1 dB

Query

 Same as setting

*RST Setting

 9.91 E+37 (NAN)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:HSSCchannel2?"

CALL:STATus:SSCell:HSSCchannel3:STATe?

Function

Queries the Current UTRA FDD Carrier 2 HS-SCCH 3 State.

Query

Range: 1|On|0|Off

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:HSSCchannel3:STATe?"

CALL:STATus:SSCell:HSSCchannel3:[LEVel]?

Function

Queries the Current UTRA FDD Carrier 2 HS-SCCH 3 Power Offset.

Setting

Range: -20.00 to 0 dB, 9.91 E+37 (NAN)

Resolution: 0.01 dB

Increment: 0.1 dB

Query

 Same as setting

*RST Setting

 9.91 E+37 (NAN)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:HSSCchannel3?"

CALL:STATus:SSCell:HSSCchannel4:STATe?

Function

Queries the Current UTRA FDD Carrier 2 HS-SCCH 3 State.

Query

Range: 1|On|0|Off

*RST Setting

 1 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:HSSCchannel4:STATe?"

CALL:STATus:SSCell:HSSCchannel4:[LEVel]?

Function

Queries the Current UTRA FDD Carrier 2 HS-SCCH 4 Power Offset.

Setting

Range: -20.00 to 0 dB, 9.91 E+37 (NAN)

Resolution: 0.01 dB

Increment: 0.1 dB

Query

 Same as setting

*RST Setting

 9.91 E+37 (NAN)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:HSSCchannel4?"

CALL:STATus:SSCell:OCNSource:LEVel?

Function

Returns the current composite relative power level in the OCNS channels for the carrier 2.

If there is no power being placed into the OCNS channels then the value of minus infinity is returned, which is -9.9E37.

Query

Range: -20.00 to 0 dB, 9.91 E+37 (NAN)

Resolution: 0.01 dB

*RST Setting

 9.91 E+37 (NAN)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:OCNSource:LEVel?"

CALL:STATus:SSCell:OCNSource:STATe?

Function

Queries the Current UTRA FDD Carrier 2 Actual Composite OCNS State.

Query

Range: 1|On|0|Off

*RST Setting

 0 (Off)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:OCNSource:STATe?"

CALL:STATus:SSCell:MPOWer:OFFSet:SIGNaled?

Function

Queries the last Measurement Power Offset value that was signaled to the UE during a call setup.

If a Measurement Power Offset value has not been signaled to the UE since the last preset or since the instrument was powered-up then NaN is returned.

This result is only available in the LA.

Query

Range: -6.0 to +13.0 dB, 9.91 E+37 (NAN)

*RST Setting

 9.91 E+37 (NAN)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:MPOWer:OFFSet:SIGNaled?"

CALL:STATus:SSCell:HSDSchannel:TBSize:PSData?

Function

Queries the current secondary serving cell HS-DSCH transport block size in use.

The result is calculated from the PS Data User Defined Active HS-PDSCHs, PS Data User Def Transport Block Size Index, PS Data User Defined Modulation Type, PS Data HS-DSCH 64QAM Configured State and PS Data HS-DSCH TB Size Tableparameters in accordance with 25.321 s9.2.3.1 and is updated whenever these parameters change while the Cell Operating Mode is Active Cell.

Query

Range: 137 to 42192

*RST Setting

 9.91 E+37 (NAN)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:HSDSchannel:TBSize:PSData?"

CALL:STATus:SSCell:HSDSchannel:TBSize?

Function

Queries the current secondary serving cell HS-DSCH transport block size in use.

Query

Range:120 to 42192

*RST Setting

 9.91 E+37 (NAN)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:HSDSchannel:TBSize?"

CALL:STATus:SSCell:MAXimum:ALLowed:CQI:VALue?

Function

Queries the upper limit of a CQI which will just not introduce code collision to the DC-HSDPA secondary serving cell.

Query

Range: 0 to 30, 9.91E+37 (NaN)

*RST Setting

 NaN

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell:MAXimum:ALLowed:CQI:VALue?"

CALL:STATus:SSCell?

Function

Queries the state of the DC-HSDPA secondary serving cell.

Query

Range: NCONfigured | CACTive|CINactive

*RST Setting

 NCONfigured

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license.
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"CALL:STATus:SSCell?"

CALL:STATus:TOTal:POWer[:AMPLitude]?

Function

Queries the current total RF power for the specified system type. The total RF power is equal to the sum of the cell power setting (see CALL:POWer ) and the AWGN setting (see CALL:AWGNoise ).

See Cell Power and AWGN Power for more information about desired versus current power levels.

Query

Range:

  • -165 dBm/3.84 MHz to +42 dBm/3.84 MHz, NAN (this is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source)
  • 9.91 E+37 (NAN) is returned if CALL:STATus:TOTal:POWer:STATe? is OFF

Resolution: 0.01 dB

*RST Setting

 -75.00 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:TOTal:POWer?"

CALL:STATus:TOTal:POWer:STATe?

Function

Queries the current total RF power measurement's state for the currently selected system type.

This query will return a 1 (on) if the current cell power ( CALL:POWer ) power state is on.

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:TOTal:POWer:STATe?"

CALL:STATus:UPLink:CHANnel?

Function

Queries the Current Info, UL: Channel and Frequency .

Query

Range: see CALL:UPLink:CHANnel:CHANnel

*RST Setting

 9750

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

All other changes match the CALL:UPLink:CHANnel:CHANnel command.

Programming Example

OUTPUT 714;"CALL:STATus:UPLink:CHANnel?"

CALL:STATus:UPLink:FREQuency?

Function

Queries the current uplink frequency.

Query

Range (in MHz):

  • 1920 to 1980,
  • 1850 to 1910,
  • 1710 to 1785,
  • 824 to 862
  • 2500 to 2570
  • 880 to 915
  • 1710 to 1784.9
  • 1427.9 to 1447.9
  • 698 to 716
  • 777 to 787
  • 788 to 798
  • 1447.9 to 1462.9

*RST Setting

 1950.0

Requirements

Test Application Revision: A.18.00 and Lab Application Revision H.00.00 and above

Programming Example

OUTPUT 714;"CALL:STATus:UPLink:FREQuency?"

CALL:STATus:UPLink:SEParation?

Function

Queries the Current Info, DL/UL Frequency Separation .

Query

Range: MHZ30|MHZ31|MHZ41|MHZ45|MHZ48|MHZ80|MHZ95|MHZ120|MHZ190|MHZ400|NSTD

*RST Setting

 MHZ190

Requirements

Test Application Revision: A.08 and above

Lab Application Revision: C.03 and above

Test Application Revision A.10.01 and Lab Application Revision D.01.01 added MHZ120

Lab Application Revision E.00.34, added MHZ48

Test Application Revision A.14 and Lab Application Revision F.00, added MHZ30 and MHZ31

Test Application Revision A.18.00 and Lab Application Revision H.00.00 and above, added MHZ41

Programming Example

OUTPUT 714;"CALL:STATus:UPLink:SEParation?"


CALL:SYSTem

CALL:SYSTem

Last updated: January 16, 2009

GPIB Command Conventions

  • CALL[:CELL]:SYSTem[:TYPE]?

CALL[:CELL]:SYSTem[:TYPE]?

Function

 Queries the type of cell the system is emulating when in active cell mode. This command is query only because only one active cell system type (UTRA FDD) is supported at this time.

Query

Range: FDD

*RST Setting

 FDD

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL:SYSTEM:TYPE?"


CALL:TIMing

CALL:TIMing

Last updated: September 2, 2009

GPIB Command Conventions

  • CALL[:CELL]:TIMing:EXTernal:OFFSet
  • CALL[:CELL]:TIMing:EXTernal:MEASurement?
  • CALL[:CELL]:TIMing:EXTernal:SYNChronize

CALL[:CELL]:TIMing:EXTernal:OFFSet

Function

Sets/queries the External 8960 Synchronization Offset.

This parameter is intended for use with the "Synchronize External 8960 Offset" action. This offset parameter will be provided to the external 8960 along with the SFN & chip of the reference trigger. The external 8960 will add the offset to the trigger time to determine the new starting SFN and chip for the timing chain. This starting time will take effect the moment the next trigger arrives.

Setting

Two integer values in the range: 0 to 4095, 0 to 38399

Query

 Same as setting

*RST Setting

 0, 0
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:TIMing:EXTernal:OFFSet 0,0"

CALL[:CELL]:TIMing:EXTernal:MEASurement?

Function

Queries the External 8960 Timing Measurement result.

This result is displayed on the Main node when Multi-Cell UTRAN mode is enabled successfully, or following the "Synchronize External 8960 Offset" event. It is defined as the number of frames and chips by which the external 8960s PCCPCH timing, leads the local 8960 and can be determined from the following equations.

Frames = ((((SFN_ext * 38400) + Chips_ext) - ((SFN_loc * 38400) + Chips_loc)) / 38400) % 4096Chips = ((((SFN_ext * 38400) + Chips_ext) - ((SFN_loc * 38400) + Chips_loc)) % 38400

Query

Two integer values in the range: 0 to 4095, 0 to 38399
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:TIMing:EXTernal:MEASurement?"

CALL[:CELL]:TIMing:EXTernal:SYNChronize

Function

Synchronizes the External 8960 Offset. This immediate action controls the relative time alignment of two test sets. It requires that an external connection be present between the two test sets.
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:TIMing:EXTernal:SYNChronize"


CALL:TMSI

CALL:TMSI

Last updated: September 2, 2009

GPIB Command Conventions

  • CALL[:CELL]:TMSI[:VALue]
  • CALL[:CELL]:TMSI:ASSignment

CALL[:CELL]:TMSI[:VALue]

Function

Sets/queries the TMSI .

This parameter can only be set when call status is Idle .

Setting

Range: 0 to 4294967294

Resolution: 1

Query

 Same as setting.

*RST Setting

0

Requirements

Test Application Revision: A.07 and above.

Lab Application Revision: C.02 and above.

Programming Example

OUTPUT 714;"CALL:TMSI 1348339801"
! Sets the TMSI to 1348339801.

CALL[:CELL]:TMSI:ASSignment

Function

Sets/queries the TMSI Assignment .

This parameter can only be set when call status is Idle .

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

O (off)

Requirements

Test Application Revision: A.07 and above.

Lab Application Revision: C.02 and above.

Programming Example

OUTPUT 714;"CALL:TMSI:ASSignment ON"
! Sets TMSI Assignment to On.


CALL:TOTal:POWer

CALL:TOTal:POWer

Last updated: January 16, 2009

GPIB Command Conventions

  • CALL:TOTal:POWer[:AMPLitude]?
  • CALL:TOTal:POWer:STATe?

CALL:TOTal:POWer[:AMPLitude]?

Function

Queries the desired total RF power for the current system type.

Total RF Power is a calculated value, that is the sum of cell power and AWGN power settings. (See Cell Power, AWGN Power and Total RF Power Ranges for more information about desired versus current power levels.)

Query

Range:

  • -165 dBm/3.84 MHz to +42 dBm/3.84 MHz
  • 9.91 E+37 (NAN) is returned if both Cell Power and AWGN power are set to OFF

Resolution: 0.01 dBm/3.84 MHz

*RST Setting

 -75 dBm/3.84 MHz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:TOTAL:POWER:AMPLITUDE?"

CALL:TOTal:POWer:STATe?

Function

Queries the total RF power state for the current system type.

The total RF power state is 1 (on) if either cell power or AWGN power is on.

The return value for this query is not necessarily the total power state at the moment this command is processed by the test set. To query the power state of the test set at the moment, use the CALL:STATus:TOTal:POWer:STATe? command.

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:TOTAL:POWER:STATE?"


CALL:TRIGger

CALL:TRIGger

Last updated: January 16, 2009

GPIB Command Conventions

  • CALL:TRIGger[:OUTPut]:SIGNal

CALL:TRIGger[:OUTPut]:SIGNal

Function

Sets/queries Trigger Output Setup .

Setting

Range: SFCLock|MGENerated

Query

 Range: SFCL|MGEN

*RST Setting

 SFCL

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:TRIGger:SIGNal MGENerated"
! Sets Trigger Output Setup to Measurement Generated.


CALL:UINTerferenc

CALL:UINTerferenc

Last updated: January 16, 2009

GPIB Command Conventions

  • CALL[:CELL[1]]:UINTerferenc

CALL[:CELL[1]]:UINTerferenc

Function

Sets/queries the Uplink Interference . See Initial PRACH TX Power .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: -110 dBm to -70 dBm

Resolution: 1 dBm

Query

Range: -110 dBm to -70 dBm

Resolution: 1 dBm

*RST Setting

 -110 dBm
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UINTerferenc -70"
! Sets the uplink interference power level to -70 dBm.


CALL:UPLink

CALL:UPLink

Last updated: January 7, 2012

GPIB Command Conventions

  • CALL:UPLink:CHANnel[:MCHannel]
  • CALL:UPLink:CHANnel:CHANnel
  • CALL:UPLink:CHANnel:CONTrol:AUTO
  • CALL:UPLink:CHANnel:SEParation

  • CALL:UPLink:DCCHannel:DDATa
  • CALL:UPLink:DPCChannel:DTX:DETection[:STATe]
  • CALL:UPLink:DPCChannel:POWer:INITial?
  • CALL:UPLink:DPCChannel:SLOT:FORMat
  • CALL:UPLink:DPCHannel:BETA:AUTo
  • CALL:UPLink:DPCHannel:MANual:CBETa
  • CALL:UPLink:DPCHannel:MANual:DBETa
  • CALL:UPLink:DPCHannel:SCODe

  • CALL:UPLink:PRAChannel:ASUBchannels
  • CALL:UPLink:PRAChannel:BETA:AUTo
  • CALL:UPLink:PRAChannel:MANual:CBETa
  • CALL:UPLink:PRAChannel:MANual:DBETa
  • CALL:UPLink:PRAChannel:POWer:INITial?
  • CALL:UPLink:PRAChannel:POWer[:RAMP]:STEP[:LEVel]
  • CALL:UPLink:PRAChannel:PREambles:NUMBer
  • CALL:UPLink:PRAChannel:PREambles:RCYCles[:MMAX]
  • CALL:UPLink:PRAChannel:SCODe
  • CALL:UPLink:PRAChannel:SIGNature
  • CALL:UPLink:PRAChannel:SMASk
  • CALL:UPLink:PRAChannel:TIMing[:OFFSet]

  • CALL:UPLink:TXPower:LEVel:MAXimum

CALL:UPLink:CHANnel[:MCHannel]

Function

The setting form of this command performs two functions: (1) sets Uplink Channel to a specific UARFCN (see CALL:UPLink:CHANnel:CHANnel ) and (2) sets uplink channel control to off (manual) (see CALL:UPLink:CHANnel:CONTrol:AUTO ).

The query form of this command returns the uplink UARFCN that is used by the test set when CALL:UPLink:CHANnel:CONTrol:AUTO is set to off (manual). Note, when CALL:UPLink:CHANnel:CONTrol:AUTO is set to on (auto), the uplink UARFCN used by the test set is determined by CALL:CHANnel .

The uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:UPLink:CHANnel? .

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

If the Uplink Channel and DL Channel settings have an uplink/downlink offset of less than 30 MHz, the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range: see CALL:UPLink:CHANnel:CHANnel

Query

 Same as setting

*RST Setting

Uplink UARFCN = 9750, uplink channel control = on (auto)

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision A.05.28 and Lab Application Revision B.01.29, added 812 - 837

Test Application Revision A.08 and Lab Application Revision C.03, changed channel ranges to match 3GPP TS 25.101 v6.7.0 (previously, channels supported were: 12-287, 812-837, 4095-4270, 4375-4600, 8525-8950 and 9225-9925, resolution = 1).

Test Application Revision A.09 and Lab Application Revisions C.04 and D.00, changed channel ranges to match 3GPP TS 25.101 v7.2.0 (previously channels supported were: 12, 37, 62, 87, 112, 137, 162, 187, 212, 237, 262, 287, 782, 787, 807, 812, 837, 862, 1162, 1187, 1212, 1237, 1262, 1287, 1312, 1337, 1362, 4132-4233 -- resolution = 1, 8562-8913 -- resolution = 1, 9262-9538 -- resolution = 1, 9612-9888 -- resolution = 1).

Test Application Revision A.10 and Lab Application Revision D.01, added 2012 - 2338, 2362, 2387, 2412, 2437, 2462, 2487, 2512, 2537, 2562, 2587, 2612, 2637, 2662, 2687

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, added 2887 to 3163, 3187, 3212, 3237, 3262, 3287, 3312, 3337, 3362, 3387, 3412, 3437, 3462

Lab Application Revision E.00.34 and above, added 3487 - 3587.

Test Application Revision A.14 and Lab Application Revision F.00 and above, added 3612 - 3678, 3702, 3707, 3732, 3737, 3762, 3767, 3792 - 3818, 3842, 3867, 3892 - 3918, 3942, 3967

Test Application Revision A.18.00 and Lab Application Revision H.00.00 and above, added 312 to 363, 387, 412, 437, 4287 to 4413 and 462 to 512

Programming Example

OUTPUT 714;"CALL:UPLink:CHANnel 9755"
! Sets the uplink channel UARFCN to 9755 and selects manual control mode for uplink channel.

CALL:UPLink:CHANnel:CHANnel

Function

The setting form of this command sets Uplink Channel to a specific UARFCN.

Note, this uplink UARFCN is only used by the test set when CALL:UPLink:CHANnel:CONTrol:AUTO is set to off (manual). When CALL:UPLink:CHANnel:CONTrol:AUTO is set to on (auto), the uplink UARFCN used by the test set is determined by CALL:CHANnel .

The query form of this command returns the uplink UARFCN that is used by the test set when CALL:UPLink:CHANnel:CONTrol:AUTO is set to off (manual).

The uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:UPLink:CHANnel? .

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

If the Uplink Channel and DL Channel settings have an uplink/downlink offset of less than 30 MHz, the warning message "+217, Performance not specified for UL/DL frequency offset < 30 MHz" will be issued. The setting will be used as entered if not changed by the user.

Setting

Range:

  • 12, 37, 62, 87, 112, 137, 162, 187, 212, 237, 262, 287
  • 312 to 363
  • 387, 412, 437
  • 462 to 512
  • 782, 787, 807, 812, 837, 862
  • 937 - 1288, resolution = 1
  • 1312 - 1513, resolution = 1
  • 1662, 1687, 1712, 1737, 1762, 1787, 1812, 1837, 1862
  • 2012 - 2338, resolution = 1
  • 2362, 2387, 2412, 2437, 2462, 2487, 2512, 2537, 2562, 2587, 2612, 2637, 2662, 2687
  • 2712 - 2863, resolution = 1
  • 2887 - 3163, resolution = 1
  • 3187, 3212, 3237, 3262, 3287, 3312, 3337, 3362, 3387, 3412, 3437, 3462
  • 3487 - 3587, resolution = 1
  • 3612 - 3678, resolution = 1
  • 3702, 3707, 3732, 3737, 3762, 3767
  • 3792 - 3818, resolution = 1
  • 3842, 3867
  • 3892 - 3918, resolution = 1
  • 3942, 3967
  • 4132 - 4233, resolution = 1
  • 4287 to 4413
  • 8762 - 8912, resolution = 1
  • 9262 - 9538, resolution = 1
  • 9612 - 9888, resolution = 1

Query

 Same as setting

*RST Setting

9750

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Test Application Revision A.08 and Lab Application Revision C.03, changed channel ranges to match 3GPP TS 25.101 v6.7.0 (previously, channels supported were: 12-287, 812-837, 4095-4270, 4375-4600, 8525-8950 and 9225-9925, resolution = 1).

Test Application Revision A.09 and Lab Application Revisions C.04 and D.00, changed channel ranges to match 3GPP TS 25.101 v7.2.0 (previously channels supported were: 12, 37, 62, 87, 112, 137, 162, 187, 212, 237, 262, 287, 782, 787, 807, 812, 837, 862, 1162, 1187, 1212, 1237, 1262, 1287, 1312, 1337, 1362, 4132-4233 -- resolution = 1, 8562-8913 -- resolution = 1, 9262-9538 -- resolution = 1, 9612-9888 -- resolution = 1).

Test Application Revision A.10 and Lab Application Revision D.01, added 2012 - 2338, 2362, 2387, 2412, 2437, 2462, 2487, 2512, 2537, 2562, 2587, 2612, 2637, 2662, 2687

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, added 2887 to 3163, 3187, 3212, 3237, 3262, 3287, 3312, 3337, 3362, 3387, 3412, 3437, 3462

Lab Application Revision: E.00.34 and above, added 3487 - 3587.

Test Application Revision A.14 and Lab Application Revision F.00 and above, added 3612 - 3678, 3702, 3707, 3732, 3737, 3762, 3767, 3792 - 3818, 3842, 3867, 3892 - 3918, 3942, 3967

Test Application Revision: A.18.00 and Lab Application Revision H.00.00 and above, added 312 to 363, 387, 412, 437, 4287 to 4413 and 462 to 512

Programming Example

OUTPUT 714;"CALL:UPLink:CHANnel:CHANnel 9755"
! Sets the uplink channel UARFCN to 9755.

CALL:UPLink:CHANnel:CONTrol:AUTO

Function

Sets/queries the Uplink Channel control mode.

  • Auto - uplink UARFCN is determined by CALL:CHANnel .
  • Manual - uplink UARFCN is determined by CALL:UPLink:CHANnel:CHANnel .

The uplink UARFCN being used by the test set at any given time can be determined by CALL:STATus:UPLink:CHANnel? .

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

Setting

Range:

  • 1|ON (auto)
  • 0|OFF (manual)

Query

 Range: 1|0

*RST Setting

1 (auto)

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:UPLink:CHANnel:CONTrol:AUTO OFF"
! Sets uplink channel control mode to manual.

CALL:UPLink:CHANnel:SEParation

Function

THIS COMMAND IS OBSOLETE. The Uplink Separation (Band) setting has been replaced by the Band Arbitrator setting ( CALL[:CELL]:BARBitrator ). Setting CALL:UPLink:CHANnel:SEParation to VMHZ45 sets Band Arbitrator to Band 5 . Setting CALL:UPLink:CHANnel:SEParation to any other value sets Band Arbitrator to Band 6 .

Sets/queries Uplink Separation (Band) .

When CALL:UPLink:CHANnel:CONTrol:AUTO is set to on (auto), the uplink UARFCN used by the test set is determined by this Uplink Separation setting and by CALL:CHANnel .

If CALL:UPLink:CHANnel:CONTrol:AUTO is set to on (auto) and you attempt to set Uplink Separation to a value that would result in an invalid uplink channel based on the current CALL:CHANnel setting, an error is posted. With CALL:UPLink:CHANnel:CONTrol:AUTO set to off (manual), set CALL:CHANnel and Uplink Separation to a valid combination, then set CALL:UPLink:CHANnel:CONTrol:AUTO to on.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

Setting

Range:

  • MHZ45 - 45 MHz (Band 6)
  • VMHZ45 - 45 MHz (Band 5)
  • MHZ80 - 80 MHz (Band 2)
  • MHZ95 - 95 MHz (Band 3)
  • MHZ190 - 190 MHz (Band 1)
  • MHZ400 - 400 MHz (Band 4)

Query

 Same as setting

*RST Setting

 MHZ190

Requirements

Test Application Revision: A.06 and above

Test Application Revision A.08 and Lab Application Revision C.03, added VMHZ45

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:UPLink:CHANnel:SEParation MHZ80"

CALL:UPLink:DCCHannel:DDATa

Function

Sets/queries the Uplink Dummy DCCH Data state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 0 (off)

Requirements

Test Application Revision: A.04 and above

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:UPLink:DCCHannel:DDATa OFF"

CALL:UPLink:DPCChannel:DTX:DETection[:STATe]

Function

Queries the UL DPCCH DTX Detection State.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 0 (off)

Requirements

 Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:UPLink:DPCChannel:DTX:DETection On"

CALL:UPLink:DPCChannel:POWer:INITial?

Function

Queries the expected initial power level for the uplink dedicated physical control channel (see Initial DPCCH TX Power ).

Query

Range: -50 to 24 dBm and 9.91E+37 (NAN)

Requirements

Test Application Revision: A.02.25 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:DPCChannel:POWer:INITial?"

CALL:UPLink:DPCChannel:SLOT:FORMat

Function

Sets/queries the the uplink DPCCH slot format to UE for UL DTX or UL DTX+DL DRX operation.

Setting

Range: 1|4

Query

Range: 1|4
*RST setting 1

Requirements

Lab Application Revision: F.00.19 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:DPCChannel:SLOT:FORMat 1"

CALL:UPLink:DPCHannel:BETA:AUTo

Function

Sets/queries the power gain control mode for the uplink dedicated physical channel (DPCH) which consists of the dedicated physical data channel (DPDCH) and the dedicated physical control channel (DPCCH). See Uplink DPCH Bc/Bd Control for details.

ON = automatic
OFF = manual

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off or FDD test operating mode when changing this value. See CALL:OPERating to select operating modes.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (on)

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.07 and above, this command applies to FDD test operating mode.

Lab Application Revision C.02 and above, this command applies to FDD test operating mode.

Programming Example

OUTPUT 714;"CALL:UPLink:DPCHannel:BETA:AUTo OFF"
! Enables manual control of the DPCH power gain.

CALL:UPLink:DPCHannel:MANual:CBETa

Function

Sets/queries the power gain of the dedicated physical control channel (DPCCH) when the DPCH power gain control mode is MANual (see CALL:UPLink:DPCHannel:BETA:AUTo ). See Manual Uplink DPCH Bc .

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the Cell Off or FDD Test operating mode when changing this value. See CALL:OPERating to select operating modes.

Setting

Range: 1 to 15

Resolution: 1

Query

 Same as setting
*RST setting 8

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.07 and Lab Application Revision C.02, this command applies to FDD test operating mode.

Lab Application Revision: D.00, range is 1 to 15 (but 1 is not recommended)

Lab Application Revision D.01, range is 2 to 15

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, range is 1 to 15 (vs. 2 to 15)

Programming Example

OUTPUT 714;"CALL:UPLink:DPCHannel:MANual:CBETa 10"
! Sets manual control of power gain for the DPCCH to 10.

CALL:UPLink:DPCHannel:MANual:DBETa

Function

Sets/queries the power gain of the dedicated physical data channel (DPDCH) when the DPCH power gain control mode is MANual (see CALL:UPLink:DPCHannel:BETA:AUTo ). See Manual Uplink DPCH Bd .

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the Cell Off or FDD Test operating mode when changing this value. See CALL:OPERating to select operating modes.

Setting

Range: 0 to 15

Resolution: 1

Query

Range: 0 to 15
*RST setting 15

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Test Application Revision A.07 and above, this command applies to FDD test operating mode.

Lab Application Revision C.02 and above, this command applies to FDD test operating mode.

Programming Example

OUTPUT 714;"CALL:UPLink:DPCHannel:MANual:DBETa 5"
! Sets manual control of power gain for the DPDCH to 5.

CALL:UPLink:DPCHannel:SCODe

Function

Sets/queries the uplink dedicated physical channel's scrambling code. See Uplink Parameters for details.

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

Setting

Range: 0 to 16777215

Query

 Same as setting

*RST Setting

0

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:DPCH:SCODe 10"
! Sets the uplink DPCH scrambling code to 10.

CALL:UPLink:DPCChannel:SLOT:FORMat

Function

Sets/queries the UL DPCCH Slot Format.

This setting configures the uplink DPCCH slot format for UL DTX or ULDTX+DL DRX operation in the UE. These two UL DPCCH slot formats are intended for use when the DPDCH is not configured in the uplink. The bit information for each uplink DPCCH slot format is decscribed in 3GPP 25.211 v760 Table 2.

Setting

Range: 1|4

Query

Range: 1|4

*RST Setting

1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:UPLink:DPCChannel:SLOT:FORMat 1"
! Sets the the UL DPCCH Slot Format to 1.

CALL:UPLink:PRAChannel:ASUBchannels

Function

Sets/queries the Available Subchannels (Bit Mask) .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 0 to 111111111111
(1 to 12 characters from the set 0 and 1).

Query

Range: "000000000000" to "111111111111"
(The returned string is always 12 characters from the set 0 and 1).

*RST Setting

"000000000001"

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:ASUBchannels '111111111111'"
! Sets all twelve PRACH access subchannels avai1able for use.

CALL:UPLink:PRAChannel:BETA:AUTo

Function

Sets/queries the power gain control mode for the message portion of the uplink physical random access channel (PRACH). See Uplink Parameters for details.

ON = automatic
OFF = manual

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (automatic)

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:BETA:AUTo OFF"
! Enables manual control of the PRACH power level.

CALL:UPLink:PRAChannel:MANual:CBETa

Function

Sets/queries the Manual PRACH Bc .

This command is only applicable when CALL:UPLink:PRAChannel:BETA:AUTo ) is set to auto.

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 2 to 15

Resolution: 1

Query

Range: 2 to 15
*RST setting 15

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:MANual:CBETa 10"
! Sets manual control of power gain for the control data
! of the message portion of the PRACH to 10.

CALL:UPLink:PRAChannel:MANual:DBETa

Function

Sets/queries the Manual PRACH Bd .

This command is only applicable when CALL:UPLink:PRAChannel:BETA:AUTo ) is set to auto.

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 0 to 15

Resolution: 1

Query

Range: 0 to 15
*RST setting 15

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:MANual:DBETa 5"
! Sets manual control of power gain for message data of
! the message portion of the PRACH to 5.

CALL:UPLink:PRAChannel:POWer:INITial?

Function

Queries the expected initial power level for the uplink physical random access channel (see Initial PRACH TX Power ).

Query

Range: -50 to 24 dBm and 9.91E+37 (NAN)

Requirements

Test Application Revision: A.02.25 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:POWer:INITial?"

CALL:UPLink:PRAChannel:POWer[:RAMP]:STEP[:LEVel]

Function

Sets/queries the PRACH Power Ramp Step .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 1 to 8

Resolution: 1

Query

Range: 1 to 8

*RST Setting

3

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:POWer:STEP:LEVel 5"

CALL:UPLink:PRAChannel:PREambles:NUMBer

Function

Sets/queries the PRACH Preambles .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 1 to 64

Resolution: 1

Query

Range: 1 to 64

*RST Setting

64

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:PREambles:NUMBer 15"
! Sets the maximum number of preambles per
! PRACH Ramping Cycle to 15.

CALL:UPLink:PRAChannel:PREambles:RCYCles[:MMAX]

Function

Sets/queries PRACH Ramping Cycles (MMAX) .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 1 to 32

Resolution: 1

Query

Range: 1 to 32

*RST Setting

2

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:PREambles:RCYCles 5"
! Sets the PRACH ramping cycles per PRACH access request to 5.

CALL:UPLink:PRAChannel:SCODe

Function

Sets/queries the PRACH Scrambling Codeword .

This parameter can not be set in active cell operating mode.

Setting

Range: 0 to 15

Resolution: 1

Query

Range: 0 to 15

*RST Setting

0

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:SCODe 5"

CALL:UPLink:PRAChannel:SIGNature

Function

This command is obsolete, please use the CALL:UPLink:PRAChannel:SMASk command instead.

Sets/queries the uplink physical random access channel's preamble signature. Changing this setting changes the CALL:UPLink:PRAChannel:SMASk setting as well.

While in the active cell operating mode, this setting can only be changed when the call status is Idle.

Setting

Range: 0 to 15

Resolution: 1

Query

 Same as setting

*RST Setting

0

Requirements

Test Application Revision: A.02 and above, obsolete as of A.05.

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:SIGNature 11"
! Set the PRACH signature to 11.

CALL:UPLink:PRAChannel:SMASk

Function

Sets/queries the PRACH Signature .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 0 to 1111111111111111

(1 to 16 characters from the set 0 and 1)

Query

Range: "0000000000000000" to "1111111111111111"

(The return string is always 16 characters from the set 0 and 1)

*RST Setting

 "0000000000000001"

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:UPLink:PRAChannel:SMASk '0000000000000001'"

CALL:UPLink:PRAChannel:TIMing[:OFFSet]

Function

Sets/queries Uplink Timing Offset .

This setting cannot be changed while in the active cell operating mode. Attempting to change this setting while in this mode results in an error issued and the test set will reject the change. Use the cell off operating mode when changing this value. See CALL:OPERating to select operating modes.

Setting

Range: -256 to +256

Query

 Same as setting

*RST Setting

0 chips

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:UPLink:TIMing 16"

CALL:UPLink:TXPower:LEVel:MAXimum

Function

Sets/queries Maximum Uplink Transmit Power Level .

This setting can only be changed when call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: -50 to +33 dBm

Query

 Same as setting

*RST Setting

 33 dBm

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:UPLink:TXPower:LEVel:MAXimum 24"
! Sets Maximum Uplink Transmit Power Level to +24 dBm.


CALL:VIDeo

CALL:VIDeo

Last updated: January 16, 2009

This section is only applicable to the lab application or feature-licensed test application.

GPIB Command Conventions

  • CALL:VIDeo:LAN:CONTrol:CSISend[:STATe]
  • CALL:VIDeo:LAN:CONTrol:RCORiginate[:STATe]
  • CALL:VIDeo:LAN:CONTrol:RCRelease[:STATe]
  • CALL:VIDeo:LAN:CONTrol:RECeive:UDP:PORT
  • CALL:VIDeo:LAN:CONTrol:SEND:IP:ADDRess
  • CALL:VIDeo:LAN:CONTrol:SEND:UDP:PORT

  • CALL:VIDeo:LAN:DATA:RECeive:UDP:PORT
  • CALL:VIDeo:LAN:DATA:SEND:IP:ADDRess
  • CALL:VIDeo:LAN:DATA:SEND:UDP:PORT

  • CALL:VIDeo:TYPE

CALL:VIDeo:LAN:CONTrol:CSISend[:STATe]

Function

 Sets/queries Sending of Call Status Indications State . This setting can only be changed when call status is idle.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 0 (off)

Requirements

 Lab Application Revision: D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:VIDeo:LAN:CONTrol:CSISend ON"
! Sets Sending of Call Status Indications State to on.

CALL:VIDeo:LAN:CONTrol:RCORiginate[:STATe]

Function

 Sets/queries Allow Remote Call Origination State . This setting can only be changed when call status is idle.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 0 (off)

Requirements

 Lab Application Revision: D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:VIDeo:LAN:CONTrol:RCORiginate ON"
! Sets Allow Remote Call Origination State to on.

CALL:VIDeo:LAN:CONTrol:RCRelease[:STATe]

Function

 Sets/queries Allow Remote Call Release State . This setting can only be changed when call status is idle.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 0 (off)

Requirements

 Lab Application Revision: D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:VIDeo:LAN:CONTrol:RCRelease ON"
! Sets Allow Remote Call Release State to on.

CALL:VIDeo:LAN:CONTrol:RECeive:UDP:PORT

Function

 Sets/queries Control Message Receiving UDP Port . This setting can only be changed when call status is idle.

Setting

Range: 6001 to 6010

Resolution: 1

Query

 Same as setting

Factory Setting

 6001 (this parameter is not affected by any reset operation and can only be changed by direct user access)

Requirements

 Lab Application Revision: D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:VIDeo:LAN:CONTrol:RECeive:UDP:PORT 6006"
! Sets Control Message Receiving UDP Port to 6006.

CALL:VIDeo:LAN:CONTrol:SEND:IP:ADDRess

Function

 Sets/queries Control Message Destination IP Address . This setting can only be changed when call status is idle.

Setting

Range: 15 characters formatted as follows: A.B.C.D where A= 0 to 126 and 128 to 223, B.C.D = 0 to 255 (no embedded spaces), blank field
Query Range: 15 characters formatted as follows: "A.B.C.D" where A= 0 to 126 and 128 to 223, B.C.D = 0 to 255 (no embedded spaces), "".

Factory Setting

 "" (this parameter is not affected by any reset operation and can only be changed by direct user access)

Requirements

 Lab Application Revision: D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:VIDeo:LAN:CONTrol:SEND:IP:ADDRess '10.10.10.16'"
! Sets Control Message Destination IP Address to 10.10.10.16.

CALL:VIDeo:LAN:CONTrol:SEND:UDP:PORT

Function

 Sets/queries Control Message Destination UDP Port . This setting can only be changed when call status is idle.

Setting

Range: 6001 to 6010

Resolution: 1

Query

 Same as setting

Factory Setting

 6001 (this parameter is not affected by any reset operation and can only be changed by direct user access)

Requirements

 Lab Application Revision: D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:VIDeo:LAN:CONTrol:SEND:UDP:PORT 6006"
! Sets Control Message Destination UDP Port to 6006.

CALL:VIDeo:LAN:DATA:RECeive:UDP:PORT

Function

 Sets/queries Data Message Receiving UDP Port . This setting can only be changed when call status is idle.

Setting

Range: 6011 to 6020

Resolution: 1

Query

 Same as setting

Factory Setting

 6011 (this parameter is not affected by any reset operation and can only be changed by direct user access)

Requirements

 Lab Application Revision: D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:VIDeo:LAN:DATA:RECeive:UDP:PORT 6016"
! Sets Control Message Destination UDP Port to 6016.

CALL:VIDeo:LAN:DATA:SEND:IP:ADDRess

Function

 Sets/queries Data Message Destination IP Address . This setting can only be changed when call status is idle.

Setting

Range: 15 characters formatted as follows: A.B.C.D where A= 0 to 126 and 128 to 223, B.C.D = 0 to 255 (no embedded spaces), blank field
Query Range: 15 characters formatted as follows: "A.B.C.D" where A= 0 to 126 and 128 to 223, B.C.D = 0 to 255 (no embedded spaces), "".

Factory Setting

 "" (this parameter is not affected by any reset operation and can only be changed by direct user access)

Requirements

 Lab Application Revision: D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:VIDeo:LAN:DATA:SEND:IP:ADDRess '10.10.10.06'"
! Sets Data Message Destination IP Address to 10.10.10.6.

CALL:VIDeo:LAN:DATA:SEND:UDP:PORT

Function

 Sets/queries Data Message Destination UDP Port . This setting can only be changed when call status is idle.

Setting

Range: 6011 to 6020

Resolution: 1

Query

 Same as setting

Factory Setting

 6011 (this parameter is not affected by any reset operation and can only be changed by direct user access)

Requirements

 Lab Application Revision: D.00.04 and above.

Programming Example

OUTPUT 714;"CALL:VIDeo:LAN:DATA:SEND:UDP:PORT 6016"
! Sets Data Message Destination UDP Port to 6016.

CALL:VIDeo:TYPE

Function

 Sets/queries Video Call Type . This setting can only be changed when call status is idle.

Setting

Range: UE|LAN8960|LOOPback

Query

Range: UE|LAN8960|LOOP

*RST Setting

 UE

Requirements

Lab Application Revision: D.00.04 and above.

Lab Application Revision E.00.16 added LOOPback

Programming Example

OUTPUT 714;"CALL:VIDeo:TYPE LAN8960"
! Sets Video Call Type to UE-to-8960LAN.


CALL:WAVeform

CALL:WAVeform

Last updated: January 16, 2009

GPIB Command Conventions

  • CALL[:CELL[1]]:WAVeform:TYPE:CW

CALL[:CELL[1]]:WAVeform:TYPE:CW

Function

Sets/queries the type of test signals to be output to the currently selected front-panel RF connector while in CW operating mode. See CW Operating Mode for details.

The test signals include:

  • CW generates an unmodulated continuous sine waveform signal.
  • AM generates an amplitude modulated signal with 56% depth and 20 kHz modulation rate.
  • DSB generates a dual side-band suppressed carrier signal with 20 kHz spacing between the two carriers.

When in CW operating mode, switching test signals requires a few seconds. A few seconds of delay is also encountered when changing operating modes if the current test signal is not CW.

Requirements

Test Application Revision: A.04 or above

Lab Application Revision: A.02 or above

Setting

Range: CW|AM|DSB

Query

Range: CW|AM|DSB

*RST Setting

CW

Programming Example

OUTPUT 714;"CALL:WAVeform:TYPE:CW AM"
! Sets the test signal to AM.


IEEE 488.2 Common Commands

IEEE 488.2 Common Commands

Last updated: January 16, 2009

Description

*CLS

The *CLS, clear status command, is defined in "IEEE Std 488.2-1992", 10.3. If an error message is currently posted on the test set's display, this command also closes the error message.

*ESE

The *ESE, standard event status enable command, is defined in "IEEE Std 488.2-1992", 10.10.

*ESE?

The *ESE?, standard event status enable query, is defined in "IEEE Std 488.2-1992", 10.11.

*ESR?

The *ESR?, standard event status register query, is defined in "IEEE Std 488.2-1992 ",10.12.

*IDN?

The *IDN?, identification query, is defined in "IEEE Std 488.2-1992", 10.14.*IDN? is used to retrieve information about the test set in ASCII format.

*IDN?, returns ASCII codes 32 through 126 excluding comma and semicolon in four comma separated fields. Field 1 returns the manufacturer, field 2 returns the instrument model number, field 3 returns the serial number, field 4 returns 0.

*OPC

The *OPC, operation complete command, is defined in "IEEE 488.2-1992", 10.18. *OPC causes the test set to continuously sense the No Operation Pending flag. When the No Operation Pending flag becomes TRUE, the OPC event bit in the standard event status register (ESR) is set to indicate that the state of all pending operations is completed. The *OPC common command is not recommended for use as an overlapped command.

*OPC?

The *OPC?, operation complete query, is defined in "IEEE Std 488.2-1992", 10.19. The *OPC? query allows synchronization between the controller and the test set using either the message available (MAV) bit in the status byte, or a read of the output OPC?. The *OPC? query does not effect the OPC event bit in the Standard Event Status Register (ESR). The *OPC? common command is not recommended for use as an overlapped command.

*OPT?

The *OPT?, option identification query, is defined in "IEEE Std 488.2-1992", 10.20. Each option will have a unique name, that name will be retuned with the query.

*RST

The *RST, full preset command, is defined in "IEEE Std 488.2-1992", 10.32. *RST is the recommended command when performing a full preset on the test set. A *RST restores the majority of settings to their default values.

  • *RST sets trigger arm to single
  • PRESet2 sets trigger arm to continuous

*SRE

The *SRE, service request enable command, is defined in "IEEE Std 488.2-1992", 10.34. The parameter range for this command is 0 through 255.

*SRE?

The *SRE?, service request enable query, is defined in "IEEE Std 488.2-1992", 10.35. Values returned by this query range from 0 through 255.

*STB?

The *STB?, read status byte query, is defined in "IEEE Std 488.2-1992", 10.36. Values returned by this query range from 0 through 255.

*TST?

The test set's implementation of *TST? does not follow the "IEEE Std 488.2-1992" section 10.38 definition. Rather, the test set's implementation is as described in the "Verifying the Test Set" (Self Test) topic in the Related Topics below. Values returned by this query are 0 (pass) and -330 (fail).

*WAI

The *WAI, wait-to-continue command, is defined in "IEEE Std 488.2-1992", 10.39. The *WAI command prevents the test set from executing any further commands or queries until all pending operation flags are false. The *WAI common command is not recommended for use as an overlapped command.

See also

Obtaining Identification Information (*IDN)

Preset Descriptions

Verifying the Test Set


DISPlay

DISPlay

Last updated: February 4, 2009

GPIB Command Conventions

  • DISPlay:BRIGhtness
  • DISPlay:MESSage:MASKable:STATe
  • DISPlay:MODE
  • DISPlay:WINDow:ERRor:CLEar
  • DISPlay:OPERator:MESSage

DISPlay:BRIGhtness

Function

Sets/queries the test set's display brightness.

A display backlight dimming feature lowers the display brightness after approximately 10 minutes without any manual user interaction with the test set. See Display Backlight Dimming .

Setting

Range: MEDium | HIGH | OFF
Query

Range: MED | HIGH | OFF
Factory setting

HIGH (this parameter is not affected by any reset operation and can only be changed by direct user access)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"DISPlay:BRIGhtness HIGH" !Sets display brightness to high.

DISPlay:MESSage:MASKable:STATe

Function

Blocks maskable messages from appearing on the test set display screen but not from the Message Log. Maskable messages are reported to the Message Log in either state. See Error Messages .

Setting

Range: 1|ON|0|OFF
Query Range: 1|0
Factory setting

On

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"DISPlay:MESSage:MASKable:STATe OFF"
!Prevents certain messages from appearing on the display.

DISPlay:MODE

Function

Sets/queries the test set's display mode.

See Display Mode (Track/Fast) for a description of fast and track display modes.

Setting

 Range: FAST | TRACK

Query

 Range: FAST | TRAC
*RST setting TRACK

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"DISPlay:MODE FAST" !Sets display mode to fast.

DISPlay:WINDow:ERRor:CLEar

Function

Clears the error message from the display screen but not from the Message Log.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"DISPlay:WINDow:ERRor:CLEar" !Clears an error message from the display.

DISPlay:OPERator:MESSage

Function

 Allows the operator to enter up to four messages, each up to 30 characters in length. These messages will be printed to the display when the command is sent and DISPlay:MODE is set to FAST.

Setting

1|2 |3|4

1=uppermost field, 4=lowermost field
Factory setting Each message is initialized to a null string. Nothing will be displayed until one or more of the four GPIB messages is sent to the test set.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"DISPlay:OPERator:MESSage1 'Press F6 to stop test'"
!Writes the message "Press F6 to stop test" to the uppermost display field.


DISPlay Subsystem

DISPlay Subsystem

Last updated: January 16, 2009

Description

The DISPlay subsystem is used to configure the test set's display mode or display brightness . Use of the DISPlay subsystem is not required to set or query any data or results.

Display Backlight Dimming

The test set's display brightness parameter has two settings at this time, high and medium. The life of the display's backlight will be maximized when brightness is set to medium. The test set has an auto dimming feature that will lower the display brightness automatically if approximately 10 minutes pass without a key being pressed on the test set's front panel. The display will return to the brightness level shown in the Display Brightness field when the test set is set to local and any front panel key is pressed. There is no other user control for this feature.

Syntax Diagram and Command Descriptions

DISPlay


FETCh:AFANalyzer

FETCh:AFANalyzer

Last updated: January 16, 2009

GPIB Command Conventions

  • FETCh:AFANalyzer[:ALL]?

  • FETCh:AFANalyzer:DISTortion[:AVERage]?
  • FETCh:AFANalyzer:DISTortion:ALL?
  • FETCh:AFANalyzer:DISTortion:MAXimum?
  • FETCh:AFANalyzer:DISTortion:MINimum?
  • FETCh:AFANalyzer:DISTortion:SDEViation?

  • FETCh:AFANalyzer:FREQuency[:AVERage]?
  • FETCh:AFANalyzer:FREQuency:ALL?
  • FETCh:AFANalyzer:FREQuency:MAXimum?
  • FETCh:AFANalyzer:FREQuency:MINimum?
  • FETCh:AFANalyzer:FREQuency:SDEViation?

  • FETCh:AFANalyzer:ICOunt?

  • FETCh:AFANalyzer:INTegrity?

  • FETCh:AFANalyzer:SINAD[:AVERage]?
  • FETCh:AFANalyzer:SINAD:ALL?
  • FETCh:AFANalyzer:SINAD:MAXimum?
  • FETCh:AFANalyzer:SINAD:MINimum?
  • FETCh:AFANalyzer:SINAD:SDEViation?

  • FETCh:AFANalyzer:VOLTage[:AVERage]?
  • FETCh:AFANalyzer:VOLTage:ALL?
  • FETCh:AFANalyzer:VOLTage:MAXimum?
  • FETCh:AFANalyzer:VOLTage:MINimum?
  • FETCh:AFANalyzer:VOLTage:SDEViation?

FETCh:AFANalyzer[:ALL]?

Function

Queries the AF analyzer measurements.

Measurement results are returned in the following order: integrity, average audio level, average SINAD, average distortion.

Query

Average analog audio level

  • Range: 0 to 20 volts, 9.91 E+37

  • Resolution: The lesser of 4 significant digits or 10 uV

Average SINAD

  • Range:-99 to 99 dB, 9.91 E+37

  • Resolution: 0.01 dB

Average audio distortion

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:ALL?"
!Returns integrity, average audio level, average SINAD,and average audio distortion.

FETCh:AFANalyzer:DISTortion[:AVERage]?

Function

Queries the average audio distortion measurement.

Query

Average audio distortion

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:AVERAGE?"

FETCh:AFANalyzer:DISTortion:ALL?

Function

Queries the audio distortion measurements.

The measurement results are returned in the following order: minimum distortion, maximum distortion, average distortion, standard deviation distortion.

Query

Minimum, maximum, and average audio distortion:

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Standard deviation audio distortion:

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.001%

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:ALL?"
!Returns mininum, maximum, average, and standard deviation audio distortion.

FETCh:AFANalyzer:DISTortion:MAXimum?

Function

Queries the maximum audio distortion.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.01%

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:MAXIMUM?"

FETCh:AFANalyzer:DISTortion:MINimum?

Function

Queries the minimum audio distortion.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.01%

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:MINIMUM?"

FETCh:AFANalyzer:DISTortion:SDEViation?

Function

Queries the standard deviation audio distortion.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.001%

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:SDEVIATION?"

FETCh:AFANalyzer:FREQuency[:AVERage]?

Function

Queries the average audio frequency measurement.

Query

Average audio frequency

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.1 Hz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:AVERAGE?"

FETCh:AFANalyzer:FREQuency:ALL?

Function

Queries the audio frequency measurements.

The measurement results are returned in the following order: minimum frequency, maximum frequency, average frequency, standard deviation frequency.

Query

Minimum, maximum, and average audio frequency:

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.1 Hz

Standard deviation audio frequency:

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.01 Hz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:ALL?"
!Returns mininum, maximum, average, and standard deviation audio frequency.

FETCh:AFANalyzer:FREQuency:MAXimum?

Function

Queries the maximum audio frequency.

Query

Range: 0 to 99999 Hz, 9.91 E+37

Resolution: 0.1 Hz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:MAXIMUM?"

FETCh:AFANalyzer:FREQuency:MINimum?

Function

Queries the minimum audio frequency.

Query

Range: 0 to 99999 Hz, 9.91 E+37

Resolution: 0.1 Hz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:MINIMUM?"

FETCh:AFANalyzer:FREQuency:SDEViation?

Function

Queries the standard deviation audio frequency.

Query

Range: 0 to 99999 Hz, 9.91 E+37

Resolution: 0.01 Hz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:SDEVIATION?"

FETCh:AFANalyzer:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

Query

Range: 0 to 999

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:ICOUNT?"

FETCh:AFANalyzer:INTegrity?

Function

Queries the measurement integrity indicator for the last AF analyzer measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 1 through 16

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANalyzer:INTegrity?"
!Query the inegrity indicator for the AF analyzer results.

FETCh:AFANalyzer:SINAD[:AVERage]?

Function

Queries the average SINAD measurement.

Query

Average SINAD

  • Range:-99 to 99 dB, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:AVERAGE?"

FETCh:AFANalyzer:SINAD:ALL?

Function

Queries the SINAD measurements.

Measurement results are returned in the following order: minimum SINAD, maximum SINAD, average SINAD, and standard deviation SINAD.

Query

Minimum, maximum, average SINAD:

  • Range: -99 to 99 dB, 9.91 E+37

  • Resolution: 0.01 dB

Standard deviation SINAD

  • Range: -99 to 99 dB, 9.91 E+37

  • Resolution: 0.001 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:ALL?"
!Returns mininum, maximum, average, and standard deviation SINAD.

FETCh:AFANalyzer:SINAD:MAXimum?

Function

Queries the maximum SINAD measurements.

Query

Range: -99 to 99 dB, 9.91 E+37

Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:MAXIMUM?"

FETCh:AFANalyzer:SINAD:MINimum?

Function

Queries the minimum SINAD measurements.

Query

Range: -99 to 99 dB, 9.91 E+37

Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:MINIMUM?"

FETCh:AFANalyzer:SINAD:SDEViation?

Function

Queries the standard deviation SINAD measurements.

Query

Range: 0 to 99 dB, 9.91 E+37

Resolution: 0.001 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:SDEVIATION?"

FETCh:AFANalyzer:VOLTage[:AVERage]?

Function

Queries the average audio level measurement.

Query

Range: 0 to 20 volts, 9.91 E+37

Resolution: the lesser of 4 significant digits or 10 uV

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:AVERAGE?"

FETCh:AFANalyzer:VOLTage:ALL?

Function

Queries the audio level measurements.

Measurement results are returned in the following order: minimum audio level, maximum audio level, average audio level, standard deviation audio level.

Query

Range: 0 to 20 V, 9.91 E+37

Resolution: 4 significant digits

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:ALL?"
!Returns minimum, maximum, average, and standard deviation audio level.

FETCh:AFANalyzer:VOLTage:MAXimum?

Function

Queries the maximum audio level measurement.

Query

Range: 0 to 20 V, 9.91 E+37

Resolution: 4 significant digits

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:MAXIMUM?"

FETCh:AFANalyzer:VOLTage:MINimum?

Function

Queries the minimum audio level measurement.

Query

Range: 0 to 20 V, 9.91 E+37

Resolution: 4 significant digits

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:MINIMUM?"

FETCh:AFANalyzer:VOLTage:SDEViation?

Function

Queries the standard deviation audio level measurement.

Query

Range: 0 to 20 V, 9.91 E+37

Resolution: 4 significant digits

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:SDEVIATION?"


FETCh:CFDTune

FETCh:CFDTune

Last updated: January 16, 2009

This section is only applicable to the lab application or feature-licensed test application.

GPIB Command Conventions

  • FETCh:CFDTune[:ALL]?
  • FETCh:CFDTune:INTegrity?

FETCh:CFDTune[:ALL]?

Function

Queries the fast device tune measurement results.

Results are returned in the following order:

  • Integrity
  • Number of Frequency Steps
  • Number of Power Steps
  • Number of MS TX power steps measured (in most cases, it equals Number of Frequency Steps multiplied by Number of Power Steps )
  • Comma-separated list of 400 MS Tx Power results. 400 results are always returned; if the test set measured fewer than 400 power steps from the mobile, the remaining values are NANs (9.91E+37). The power results for the first frequency in the MS TX Frequency Sequence are returned first, then the power results for the second frequency in the MS TX Frequency Sequence, etc., followed by NANs if fewer than 400 points were measured.

See Fast Device Tune Measurement Results .

Query

Integrity

  • Range: see Integrity Indicator

  • Resolution: 1

Number of Frequency Steps

  • Range: 1 to 20, 9.91 E+37

  • Resolution: 1.0

Number of Power Steps

  • Range: 1 to 20, 9.91 E+37

  • Resolution: 1.0

Number of MS Tx Power Steps Measured

  • Range: 1 to 400, 9.91 E+37

  • Resolution: 1.0

MS Tx Power Results Array

  • Range: -100.00 to +100.00 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Requirement

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 or D.00.04 and above

Programming Example

OUTPUT 714;"FETCh:CFDTune:ALL?"

!Returns integrity, number of frequency steps, number of power steps,
!Number of MS Tx Power steps measured, followed by a comma-separated list of
!400 MS Tx Power results.

FETCh:CFDTune:INTegrity?

Function

Queries the measurement integrity indicator for the fast device tune measurement.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: See Integrity Indicator

Requirement

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 or D.00.04 and above

Programming Example

OUTPUT 714;"FETCh:CFDTune:INTegrity?"
!Queries the inegrity indicator for the fast device tune results.


FETCh? Subsystem

FETCh? Subsystem

Last updated: January 5, 2010

Description

The FETCh? query is a function that allows users to query results from a measurement that was previously INITiated or READ. It does NOT begin a measurement. If no measurement is in progress it will return the integrity and measurement values from the last measurement made, or return an integrity of No Result Available and results of NAN. If a measurement is in process, the query will hang until the results are available, or the measurement fails or times out. The exact results returned with a FETCh? will depend on the specific measurement. A measurement may have a number of different results or combination of results for a FETCh?. The FETCh? queries are intended to be used to provide overlapped operation access to measurement results from the test set. When used along with SETup and INITiate commands , FETCh? is the primary way for the user to retrieve measurement results. In order to use the test set's concurrent test capabilities the overlapped commands of INITiate and FETCh? must be used. Overlapped commands allow the user to send commands and not wait for completion.

Syntax Diagrams and Command Descriptions

FETCh:AFANalyzer (AF Analyzer measurements)

FETCh:CFDTune (Fast Device Tune) lab application or feature-licensed test application only

FETCh:EVMQpsk (QPSK EVM measurement)

FETCh:FSTability (Frequency Stability measurement)

FETCh:HBLerror (HSDPA Block Error Ratio) lab application or feature-licensed test application only

FETCh:HRCQuality (HSDPA Reporting of Channel Quality Indicator Measurement) lab application only
FETCh:SAUDio (Swept Audio measurement)

FETCh:SMONitor (Spectrum Monitor measurements)

FETCh:WACLeakage (Adjacent Channel Leakage measurements)

FETCh:WBERror (Loopback Bit Error Ratio measurements)
FETCh:WBLerror (Loopback Block Error Ratio measurement)

FETCh:WCDomain (Code Domain measurements)

FETCh:WCPower (Channel Power measurements)

FETCh:WCTFormat (Change Of TFC) lab application only

FETCh:WDPAnalysis (Dynamic Power Analysis measurement)

FETCh:WEDPower (Extended Range Dynamic Power measurement)

FETCh:WILPower (Inner Loop Power measurements)

FETCh:WIQTuning (IQ Tuning measurements)

FETCh:WOBWidth (Occupied Bandwidth measurements)

FETCh:WOOPower (PRACH Transmit On/Off Power measurements)
FETCh:WPDiscon (Phase Discontinuity measurement)
FETCh:WPESquality (Perceptual Evaluation of Speech Quality measurement) lab application only
FETCh:WPPAnalysis (PRACH Preamble Analysis measurement) lab application only

FETCh:WSEMask (Spectrum Emission Mask measurements)
FETCh:WTDPower (TX Dynamic Power measurement)

FETCh:WTPower (Thermal Power measurements)

FETCh:WWQuality (Waveform Quality measurements)


FETCh:EVMQpsk

FETCh:EVMQpsk

Last updated: May 26, 2009

GPIB Command Conventions

  • FETCh:EVMQpsk[:ALL]?
  • FETCh:EVMQpsk:EVM[:MAXimum]?
  • FETCh:EVMQpsk:EVM:ALL?
  • FETCh:EVMQpsk:EVM:AVERage?
  • FETCh:EVMQpsk:EVM:MINimum?
  • FETCh:EVMQpsk:EVM:PEAK<[:MAXimum]|:ALL|:AVERage|:MINimum|:SDEViation>?
  • FETCh:EVMQpsk:EVM:SDEViation?

  • FETCh:EVMQpsk:FERRor[:WORSt]?
  • FETCh:EVMQpsk:FERRor:ALL?
  • FETCh:EVMQpsk:FERRor:AVERage?
  • FETCh:EVMQpsk:FERRor:MAXimum?
  • FETCh:EVMQpsk:FERRor:MINimum?
  • FETCh:EVMQpsk:FERRor:SDEViation?

  • FETCh:EVMQpsk:ICOunt?

  • FETCh:EVMQpsk:INTegrity?

  • FETCh:EVMQpsk:MERRor[:MAXimum]?
  • FETCh:EVMQpsk:MERRor:ALL?
  • FETCh:EVMQpsk:MERRor:AVERage?
  • FETCh:EVMQpsk:MERRor:MINimum?
  • FETCh:EVMQpsk:MERRor:SDEViation?

  • FETCh:EVMQpsk:OOFFset[:MAXimum]?
  • FETCh:EVMQpsk:OOFFset:ALL?
  • FETCh:EVMQpsk:OOFFset:AVERage?
  • FETCh:EVMQpsk:OOFFset:MINimum?
  • FETCh:EVMQpsk:OOFFset:SDEViation?

  • FETCh:EVMQpsk:PERRor[:MAXimum]?
  • FETCh:EVMQpsk:PERRor:ALL?
  • FETCh:EVMQpsk:PERRor:AVERage?
  • FETCh:EVMQpsk:PERRor:MINimum?
  • FETCh:EVMQpsk:PERRor:SDEViation?

FETCh:EVMQpsk[:ALL]?

Function

Queries the QPSK EVM measurements.

Measurement results are returned in the following order: integrity, EVM maximum, frequency error worst case, origin offset maximum, phase error maximum, magnitude error maximum, peak EVM maximum.

Query

Integrity

  • Range: 0 to 16

  • Resolution: 1

EVM Maximum

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Frequency Error worst case

  • Range-99.99 to 99.99 kHz, 9.91 E+37

  • Resolution: 0.1

Origin Offset Maximum

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error Maximum

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Magnitude Error Maximum

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Peak EVM Maximum

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk?"

FETCh:EVMQpsk:EVM[:MAXimum]?

Function

Queries the maximum EVM.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:EVM?"
! Returns maximum EVM.

FETCh:EVMQpsk:EVM:ALL?

Function

Queries the EVM measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation error vector magnitude.

Query

Minimum EVM

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Maximum EVM

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Average EVM

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Standard Deviation EVM

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:EVM:ALL?"
! Returns all EVM measurement results.

FETCh:EVMQpsk:EVM:AVERage?

Function

Queries the average EVM.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:EVM:AVERage?"
! Returns average EVM.

FETCh:EVMQpsk:EVM:MINimum?

Function

Queries the minimum EVM.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:EVM:MINimum?"
! Returns mininum EVM.

FETCh:EVMQpsk:EVM:PEAK<[:MAXimum]|:ALL|:AVERage|:MINimum|:SDEViation>?

Function

Queries the QPSK EVM measurement results and returns the following, depending upon which mnemonic is sent at the end of the command string:

  • [:MAXimum] - returns the maximum peak EVM result when Multi-Measurement Count is on or peak EVM when Multi-Measurement Count = Off .
  • :ALL - returns the minimum, maximum, average and standard deviation peak EVM results when Multi-Measurement Count is on (it returns peak EVM, peak EVM, peak EVM and zero when Multi-Measurement Count is off).
  • :AVERage - returns the average peak EVM result when Multi-Measurement Count is on (it returns peak EVM when Multi-Measurement Count is off).
  • :MINimum - returns the minimum peak EVM result when Multi-Measurement Count is on (it returns peak EVM when Multi-Measurement Count is off).
  • :SDEViation - returns the standard deviation of the peak EVM results when Multi-Measurement Count is on (it returns zero when Multi-Measurement Count is off).

Query

Range:

  • Peak EVM: 0 to 99.0%, 9.91E+37
  • Standard deviation: 0 to 99.00%, 9.91E+37

Resolution:

  • Peak EVM: 0.1%
  • Standard deviation: 0.01%

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:EVM:PEAK?"
! Returns peak EVM (or maximum peak EVM if multi-measurement count is on)

OUTPUT 714;"FETCh:EVMQpsk:EVM:PEAK:ALL?"
! Returns minimum, maximum, average and standard deviation peak EVM when multi-measurement
! count is on (it returns peak EVM, peak EVM, peak EVM and zero when multi-measurement
! count is off).

FETCh:EVMQpsk:EVM:SDEViation?

Function

Queries the standard deviation of results for EVM measurements.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.01

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:EVM:SDEViation?"
! Returns standard deviation EVM.

FETCh:EVMQpsk:FERRor[:WORSt]?

Function

Queries the worst case frequency error. (The test set returns either the Minimum or Maximum Frequency Error result, whichever is furthest from zero).

Query

Range: -99 to 99 kHz, 9.91 E+37

Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:FERRor?"
! Returns worst case frequency error.

FETCh:EVMQpsk:FERRor:ALL?

Function

Queries the frequency error measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation and worst case frequency error.

Query

Minimum Frequency Error

  • Range: -99 to 99 kHz, 9.91 E+37

  • Resolution: 0.1

Maximum Frequency Error

  • Range: -99 to 99 kHz, 9.91 E+37

  • Resolution: 0.1

Average Frequency Error

  • Range: -99 to 99 kHz, 9.91 E+37

  • Resolution: 0.1

Standard Deviation Frequency Error

  • Range: -99 to 99 kHz, 9.91 E+37

  • Resolution: 0.01

Worst Case Frequency Error

  • Range: -99 to 99 kHz, 9.91 E+37

  • Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:FERRor:ALL?"
! Returns mininum, maximum, average,
! standard deviation and worst case frequency error.

FETCh:EVMQpsk:FERRor:AVERage?

Function

Queries the average frequency error.

Query

Range: -99 to 99 kHz, 9.91 E+37

Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:FERRor:AVERage?"
! Returns average frequency error.

FETCh:EVMQpsk:FERRor:MAXimum?

Function

Queries the average frequency error.

Query

Range: -99 to 99 kHz, 9.91 E+37

Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:FERRor:MAXimum?"
! Returns maximum frequency error.

FETCh:EVMQpsk:FERRor:MINimum?

Function

Queries the minimum frequency error.

Query

Range: -99 to 99 kHz, 9.91 E+37

Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:FERRor:MINimum?"
! Returns minimum frequency error.

FETCh:EVMQpsk:FERRor:SDEViation?

Function

Queries the standard deviation of frequency error measurements.

Query

Range: 0 to 99 kHz, 9.91 E+37

Resolution: 0.01

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:FERRor:SDEViation?"
! Returns standard deviation frequency error.

FETCh:EVMQpsk:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

Query

Range: 0 to 999

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:ICOunt?"

FETCh:EVMQpsk:INTegrity?

Function

Queries the measurement integrity indicator for the last waveform quality measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:INTegrity?"
!Queries the integrity indicator for the channel channel power results.

FETCh:EVMQpsk:MERRor[:MAXimum]?

Function

Queries the average magnitude error.

Query

Range: 0 to 99%

Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:MERRor?"
! Returns maximum magnitude error.

FETCh:EVMQpsk:MERRor:ALL?

Function

Queries the magnitude error measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation magnitude error.

Query

Minimum Magnitude Error

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Maximum Magnitude Error

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Average Magnitude Error

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Standard Deviation Magnitude Error

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh::EVMQpsk:MERRor:ALL?"
! Returns mininum, maximum, average, and
! standard deviation magnitude error.

FETCh:EVMQpsk:MERRor:AVERage?

Function

Queries the average magnitude error.

Query

Range: 0 to 99%

Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:MERRor:AVERage?"
! Returns average magnitude error.

FETCh:EVMQpsk:MERRor:MINimum?

Function

Queries the minimum magnitude error.

Query

Range: 0 to 99%

Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:MERRor:MINimum?"
! Returns minimum magnitude error.

FETCh:EVMQpsk:MERRor:SDEViation?

Function

Queries the standard deviation of magnitude error measurements.

Query

Range: 0 to 99%

Resolution: 0.01

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:MERRor:SDEViation?"
! Returns standard deviation magnitude error.

FETCh:EVMQpsk:OOFFset[:MAXimum]?

Function

Queries the average origin offset.

Query

Range:-99 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:OOFFset?"
! Returns maximum origin offset.

FETCh:EVMQpsk:OOFFset:ALL?

Function

Queries the origin offset measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation origin offset.

Query

Minimum Origin Offset

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Maximum Origin Offset

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Average Origin Offset

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Standard Deviation Origin Offset

  • Range: 0 to 99 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:OOFFset:ALL?"
! Returns mininum, maximum, average, and
! standard deviation origin offset.

FETCh:EVMQpsk:OOFFset:AVERage?

Function

Queries the average origin offset.

Query

Range: -99 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:OOFFset:AVERage?"
! Returns average origin offset.

FETCh:EVMQpsk:OOFFset:MINimum?

Function

Queries the minimum origin offset.

Query

Range:-99 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:OOFFset:MINimum?"
! Returns minimum origin offset.

FETCh:EVMQpsk:OOFFset:SDEViation?

Function

Queries the standard deviation of results for origin offset measurements.

Query

Range: 0 to 99 dB, 9.91 E+37

Resolution: 0.01

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:OOFFset:SDEViation?"
! Returns standard deviation origin offset.

FETCh:EVMQpsk:PERRor[:MAXimum]?

Function

Queries the maximum phase error measurement.

Query

Range: 0 to 180 degrees, 9.91 E+37

Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:PERRor?"
! Returns maximum phase error.

FETCh:EVMQpsk:PERRor:ALL?

Function

Queries the phase error measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation phase error.

Query

Minimum Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Maximum Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Average Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Standard Deviation Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.01

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:PERRor:ALL?"
! Returns mininum, maximum, average, and
! standard deviation phase error.

FETCh:EVMQpsk:PERRor:AVERage?

Function

Queries the average phase error.

Query

Range: 0 to 180 degrees, 9.91 E+37

Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:PERRor:AVERage?"
! Returns average phase error.

FETCh:EVMQpsk:PERRor:MINimum?

Function

Queries the minimum phase error.

Query

Range: 0 to 180 degrees, 9.91 E+37

Resolution: 0.1

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:PERRor:MINimum?"
! Returns minimum phase error.

FETCh:EVMQpsk:PERRor:SDEViation?

Function

Queries the standard deviation of results for phase error measurements.

Query

Range: 0 to 180 degrees, 9.91 E+37

Resolution: 0.01

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"FETCh:EVMQpsk:PERRor:SDEViation?"
! Returns standard deviation phase error.


FETCh:FSTability

FETCh:FSTability

January 16, 2009

GPIB Command Conventions

  • FETCh:FSTability[:ALL]?
  • FETCh:FSTability:FERRor[:WORSt]?
  • FETCh:FSTability:FERRor:ALL?
  • FETCh:FSTability:FERRor:AVERage?
  • FETCh:FSTability:FERRor:MAXimum?
  • FETCh:FSTability:FERRor:MINimum?
  • FETCh:FSTability:FREQuency[:AVERage]?
  • FETCh:FSTability:FREQuency:ALL?
  • FETCh:FSTability:FREQuency:MAXimum?
  • FETCh:FSTability:FREQuency:MINimum?
  • FETCh:FSTability:FREQuency:SDEViation?
  • FETCh:FSTability:ICOunt?
  • FETCh:FSTability:INTegrity?

FETCh:FSTability[:ALL]?

Function

Queries the frequency stability measurement. Returns integrity, worst-case frequency error, and average frequency.

Query

Worst-case frequency error:

  • Range: -500 to 500 parts per million (ppm)

  • Resolution: 0.01 ppm

Average frequency:

  • Range: 100 E+6 to 3 E+9 Hz

  • Resolution: 0.01 ppm
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:ALL?"
!Returns integrity, worst-case frequency error, and average frequency.

FETCh:FSTability:FERRor[:WORSt]?

Function

Queries the frequency stability frequency error measurement.

Query

Range: -500 to 500 parts per million (ppm)

Resolution: 0.01 ppm
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:WORST?"

FETCh:FSTability:FERRor:ALL?

Function

Queries the frequency stability frequency error measurements.

Measurement results are returned in the following order: minimum frequency error, maximum frequency error, average frequency error, worst-case frequency error.

Query

Maximum, minimum frequency error:

  • Range: -500 E+3 to 500 E+3 Hz

  • Resolution: 1 Hz

Average frequency error:

  • Range: -500 E+3 to 500 E+3 Hz

  • Resolution: 1 Hz

Worst-case frequency error:

  • Range: -500 to 500 parts per million (ppm)

  • Resolution: 0.01
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:ALL?"
!Returns minimum, maximum, average, and worst-case frequency error.

FETCh:FSTability:FERRor:AVERage?

Function

Queries the average frequency error measurement.

Query

Range: -500 E+3 to 500 E+3 Hz

Resolution: 1 Hz
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:AVERAGE?"

FETCh:FSTability:FERRor:MAXimum?

Function

Queries the maximum frequency error measurement.

Query

Range: -500 E+3 to 500 E+3 Hz

Resolution: 1 Hz
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:MAXIMUM?"

FETCh:FSTability:FERRor:MINimum?

Function

Queries the minimum frequency error measurement.

Query

Range: -500 E+3 to 500 E+3 Hz

Resolution: 1 Hz
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"" !.

FETCh:FSTability:FREQuency[:AVERage]?

Function

Queries the frequency stability average frequency measurement.

Query

Range: 100 E+6 to 3 E+9 Hz

Resolution: 1 Hz
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:AVERAGE?"

FETCh:FSTability:FREQuency:ALL?

Function

Queries the frequency stability frequency measurement.

Measurement results are returned in the following order: minimum frequency, maximum frequency, average frequency, and standard deviation frequency.

Query

Minimum, maximum, average frequency:

  • Range: 100 E+6 to 3 E+9

  • Resolution: 1 Hz

Standard deviation frequency:

  • Range: 0 to 500 E+3 Hz

  • Resolution: 0.1 Hz
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:ALL?"
!Returns minimum, maximum, average, and standard deviation frequency.

FETCh:FSTability:FREQuency:MAXimum?

Function

Queries the maximum frequency stability frequency.

Query

Range: 100 E+6 to 3 E+9

Resolution: 1 Hz
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:MAXIMUM?"

FETCh:FSTability:FREQuency:MINimum?

Function

Queries the minimum frequency stability frequency.

Query

Range: 100 E+6 to 3 E+9

Resolution: 1 Hz
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:MINIMUM?"

FETCh:FSTability:FREQuency:SDEViation?

Function

Queries the standard deviation frequency stability frequency.

Query

Range: 0 to 500 E+3 Hz

Resolution: 0.1 Hz
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:SDEVIATION?"

FETCh:FSTability:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

Query

Range: 0 to 999
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:ICOUNT?"

FETCh:FSTability:INTegrity?

Function

Queries the measurement integrity indicator for the last frequency stability measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 1 through 16
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:INTEGRITY"
!Returns the integrity indicator for the frequency stability measurement.


FETCh:HBLerror

FETCh:HBLerror

Last updated: January 7, 2012

This section is only applicable to a test application with the required feature license.

GPIB Command Conventions

  • FETCh:HBLerror[:ALL]?
  • FETCh:HBLerror:ICOunt?
  • FETCh:HBLerror:INTegrity?
  • FETCh:HBLerror:RATio?
  • FETCh:HBLerror:IBTHroughput?
  • FETCh:HBLerror:ACK?
  • FETCh:HBLerror:NACK?
  • FETCh:HBLerror:SDTX?
  • FETCh:HBLerror:BLOCks?
  • FETCh:HBLerror:MCQindicator?
  • FETCh:HBLerror:SCELl[:ALL]?
  • FETCh:HBLerror:SCELl:RATio?
  • FETCh:HBLerror:SCELl:ACK?
  • FETCh:HBLerror:SCELl:NACK?
  • FETCh:HBLerror:SCELl:SDTX?
  • FETCh:HBLerror:SCELl:IBTHroughput?
  • FETCh:HBLerror:SCELl:MCQindicator?
  • FETCh:HBLerror:SCELl:BLOCks?
  • FETCh:HBLerror:SCELl:ICOunt?
  • FETCh:HBLerror:SSCell?
  • FETCh:HBLerror:SSCell:RATio?
  • FETCh:HBLerror:SSCell:ACK?
  • FETCh:HBLerror:SSCell:NACK?
  • FETCh:HBLerror:SSCell:SDTX?
  • FETCh:HBLerror:SSCell:IBTHroughput?
  • FETCh:HBLerror:SSCell:MCQindicator?
  • FETCh:HBLerror:SSCell:BLOCks?
  • FETCh:HBLerror:SSCell:ICOunt?

FETCh:HBLerror[:ALL]?

Function

Queries an HSDPA block error ratio measurement result and returns the following comma separated values: Integrity Indicator, Block Error Ratio in %, Information Bit Throughput in kbps, Positive Acknowledgments, Negative Acknowledgments, Statistical DTXs, Number of Blocks Tested, Median Channel Quality Indicator.

See HSDPA Block Error Ratio Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

Block Error Ratio

  • Range: 0.00 to 100.00%, 9.91E+37
  • Resolution: 0.01%

Information Bit Throughput

  • Range: 0.000 to 42000.000 kbps, 9.91E+37
  • Resolution: 0.001 kbps

Positive Acknowledgments

  • Range: 0 to 198000, 9.91E+37
  • Resolution: 1

Negative Acknowledgments

  • Range: 0 to 198000, 9.91E+37
  • Resolution: 1

Statistical DTXs

  • Range: 0 to 198000, 9.91E+37
  • Resolution: 1

Number of Blocks Tested

  • Range: 0 to 198000, 9.91E+37
  • Resolution: 1

Median Channel Quality Indicator

  • Range: 0 to 30, 9.91E+37
  • Resolution: 1

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Test Application Revision A.19.00 and above with the required feature license and Lab Application Revision H.00.00 and above expanded range of "Infomation Bit Throughput" from "1 to 14,000" to "1 to 42,000", ranges of "Positive Acknowledgments", "Negative Acknowledgments", "Statistical DTXs" and "Number of Blocks Tested" from "0 to 99000" to "0 to 198000".

Programming Example

OUTPUT 714;"FETCh:HBLerror?"
! Returns Integrity Indicator, Block Error Ratio, Information Bit Throughput,
! Positive Acknowledgements, Negative Acknowledgements, Statistical DTXs,
! Number of Blocks Tested, Median Channel Quality Indicator.

FETCh:HBLerror:ICOunt?

Function

Queries the intermediate count of blocks tested for the HSDPA block error ratio measurement (see HSDPA Block Error Ratio Measurement Description ).

To set up the total number of blocks to test, see SETup:HBLerror:COUNt .

Query

Range: 0 to 198,000 blocks

Resolution: 100 blocks

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Test Application Revision A.19.00 and above with the required feature license and Lab Application Revision H.00.00 and above expanded range from "0 to 99000" to "0 to 198000".

Programming Example

OUTPUT 714;"FETCh:HBLerror:ICOUnt?"
! Returns the intermediate count of blocks tested.

FETCh:HBLerror:INTegrity?

Function

Returns the Integrity Indicator for the HSDPA block error ratio measurement result (see HSDPA Block Error Ratio Measurement Description ).

Query

Range: 0 to the number of available integrity indicators.

Resolution: 1

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"FETCh:HBLerror:INTegrity?"
! Returns Integrity Indicator.

FETCh:HBLerror:RATio?

Function

Returns the Block Error Ratio in %.

Query

 Range/Resolution: see FETCh:HBLerror[:ALL]?

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"FETCh:HBLerror:RATio?"

FETCh:HBLerror:IBTHroughput?

Function

Returns the Information Bit Throughput (kbps) for the measurement interval (number of blocks tested).

Query

 Range/Resolution: see FETCh:HBLerror[:ALL]?

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Test Application Revision A.19.00 and above with the required feature license and Lab Application Revision H.00.00 and above expanded range from "1 to 14000" to "1 to 42000".

Programming Example

OUTPUT 714;"FETCh:HBLerror:IBTHroughput?"

FETCh:HBLerror:ACK?

Function

Returns the number of positive acknowledgments ( ACKs ) received during the measurement interval (number of blocks tested).

Query

 Range/Resolution: see FETCh:HBLerror[:ALL]?

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Test Application Revision A.19.00 and above with the required feature license and Lab Application Revision H.00.00 and above expanded range from "0 to 99000" to "0 to 198000".

Programming Example

OUTPUT 714;"FETCh:HBLerror:ACK?"

FETCh:HBLerror:NACK?

Function

Returns the number of negative acknowledgments ( NACKs ) received during the measurement interval (number of blocks tested).

Query

 Range/Resolution: see FETCh:HBLerror[:ALL]?

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Test Application Revision A.19.00 and above with the required feature license and Lab Application Revision H.00.00 and above expanded range from "0 to 99000" to "0 to 198000".

Programming Example

OUTPUT 714;"FETCh:HBLerror:NACK?"

FETCh:HBLerror:SDTX?

Function

Returns the number of statistical DTXs ( statDTXs ) during the measurement interval (number of blocks tested).

Query

 Range/Resolution: see FETCh:HBLerror[:ALL]?

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Test Application Revision A.19.00 and above with the required feature license and Lab Application Revision H.00.00 and above expanded range from "0 to 99000" to "0 to 198000".

Programming Example

OUTPUT 714;"FETCh:HBLerror:SDTX?"

FETCh:HBLerror:BLOCks?

Function

Returns the number of Blocks Tested .

Query

 Range/Resolution: see FETCh:HBLerror[:ALL]?

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Test Application Revision A.19.00 and above with the required feature license and Lab Application Revision H.00.00 and above expanded range from "0 to 99000" to "0 to 198000".

Programming Example

OUTPUT 714;"FETCh:HBLerror:BLOCks?"

FETCh:HBLerror:MCQindicator?

Function

Returns the median channel quality indicator ( Median CQI ) for the measurement interval (number of blocks tested).

Query

 Range/Resolution: see FETCh:HBLerror[:ALL]?

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"FETCh:HBLerror:MCQindicator?"

FETCh:HBLerror:SCELl[:ALL]?

Function

Queries an DC-HSDPA block error ratio measurement result for the downlink serving cells and returns the following comma separated values: Serving Cell Integrity Indicator, Serving Cell Block Error Ratio in %, Serving Cell Information Bit Throughput in kbps, Serving Cell ACKs, Serving Cell NACKs, Serving Cell Statistical DTXs, Serving Cell Number of Blocks Tested, Serving Cell Median CQI.

See Dual Cell HSDPA Considerations .

Query

Integrity Indicator - See Integrity Indicator .

Block Error Ratio

  • Range: 0.00 to 100.00%, 9.91E+37
  • Resolution: 0.01%

Information Bit Throughput

  • Range: 0.000 to 21000.000 kbps, 9.91E+37
  • Resolution: 0.001 kbps

Positive Acknowledgments

  • Range: 0 to 99000, 9.91E+37
  • Resolution: 1

Negative Acknowledgments

  • Range: 0 to 99000, 9.91E+37
  • Resolution: 1

Statistical DTXs

  • Range: 0 to 99000, 9.91E+37
  • Resolution: 1

Number of Blocks Tested

  • Range: 0 to 99000, 9.91E+37
  • Resolution: 1

Median Channel Quality Indicator

  • Range: 0 to 30, 9.91E+37
  • Resolution: 1

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SCELl?"
! Returns Serving Cell Integrity Indicator, Serving Cell Block Error Ratio,
! Serving Cell Information Bit Throughput, Serving Cell Positive Acknowledgements,
! Serving Cell Negative Acknowledgements, Serving Cell Statistical DTXs,
! Serving Cell Number of Blocks Tested, Serving Cell Median Channel Quality Indicator.

FETCh:HBLerror:SCELl:RATio?

Function

Returns the Serving Cell Block Error Ratio in %.

Query

 Range/Resolution: see FETCh:HBLerror:SCELl[:ALL]?

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SCELl:RATio?"

FETCh:HBLerror:SCELl:ACK?

Function

Returns the number of serving cell ACKs received during the measurement interval (number of blocks tested).

Query

 Range/Resolution: see FETCh:HBLerror:SCELl[:ALL]?

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SCELl:ACK?"

FETCh:HBLerror:SCELl:NACK?

Function

Returns the number of serving cell NACKs received during the measurement interval (number of blocks tested).

Query

 Range/Resolution: see FETCh:HBLerror:SCELl[:ALL]?

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SCELl:NACK?"

FETCh:HBLerror:SCELl:SDTX?

Function

Returns the number of serving cell statDTXs during the measurement interval (number of blocks tested).

Query

 Range/Resolution: see FETCh:HBLerror:SCELl[:ALL]?

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SCELl:SDTX?"

FETCh:HBLerror:SCELl:IBTHroughput?

Function

Returns the Serving Cell Information Bit Throughput for the measurement interval (number of blocks tested).

Query

 Range/Resolution: see FETCh:HBLerror:SCELl[:ALL]?

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SCELl:IBTHroughput?"

FETCh:HBLerror:SCELl:MCQindicator?

Function

Returns the Serving Cell Median CQI for the measurement interval (number of blocks tested).

Query

 Range/Resolution: see FETCh:HBLerror:SCELl[:ALL]?

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SCELl:MCQindicator?"

FETCh:HBLerror:SCELl:BLOCks?

Function

Returns the number of Serving Cell Blocks Tested.

Query

 Range/Resolution: see FETCh:HBLerror:SCELl[:ALL]?

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SCELl:BLOCks?"

FETCh:HBLerror:SCELl:ICOunt?

Function

Queries the intermediate count of blocks tested for the DC-HSDPA serving cell.

To set up the total number of blocks to test for serving cell , see SETup:HBLerror:COUNt:DCHSdpa:SERVing .

Query

Range: 0 to 99,000 blocks

Resolution: 100 blocks

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SCELl:ICOunt?"

FETCh:HBLerror:SSCell?

Function

Queries an DC-HSDPA block error ratio measurement result for the downlink secondary serving cells and returns the following comma separated values: Secondary Serving Cell Integrity Indicator, Secondary Serving Cell Block Error Ratio in %, Secondary Serving Cell Information Bit Throughput in kbps, Secondary Serving Cell ACKs, Secondary Serving Cell NACKs, Secondary Serving Cell Statistical DTXs, Secondary Serving Cell Number of Blocks Tested, Secondary Serving Cell Median CQI.

See Dual Cell HSDPA Considerations .

Query

Integrity Indicator - See Integrity Indicator .

Block Error Ratio

  • Range: 0.00 to 100.00%, 9.91E+37
  • Resolution: 0.01%

Information Bit Throughput

  • Range: 0.000 to 21000.000 kbps, 9.91E+37
  • Resolution: 0.001 kbps

Positive Acknowledgments

  • Range: 0 to 99000, 9.91E+37
  • Resolution: 1

Negative Acknowledgments

  • Range: 0 to 99000, 9.91E+37
  • Resolution: 1

Statistical DTXs

  • Range: 0 to 99000, 9.91E+37
  • Resolution: 1

Number of Blocks Tested

  • Range: 0 to 99000, 9.91E+37
  • Resolution: 1

Median Channel Quality Indicator

  • Range: 0 to 30, 9.91E+37
  • Resolution: 1

Requirements
Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SSCell?"
! Returns Secondary Serving Cell Integrity Indicator, Secondary Serving Cell Block Error Ratio,
! Secondary Serving Cell Information Bit Throughput,
! Secondary Serving Cell Positive Acknowledgements,
! Secondary Serving Cell Negative Acknowledgements, Secondary Serving Cell Statistical DTXs,
! Secondary Serving Cell Number of Blocks Tested,
! Secondary Serving Cell Median Channel Quality Indicator.

FETCh:HBLerror:SSCell:RATio?

Function

Returns the Secondary Serving Cell Block Error Ratio.

Query

 Range/Resolution: see FETCh:HBLerror:SSCell?

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SSCell:RATio?"

FETCh:HBLerror:SSCell:ACK?

Function

Returns the number of secondary serving cell ACKs received during the measurement interval (number of blocks tested).

Query

 Range/Resolution: see FETCh:HBLerror:SSCell?

Requirements
Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SSCell:ACK?"

FETCh:HBLerror:SSCell:NACK?

Function

Returns the number of secondary serving cell NACKs received during the measurement interval (number of blocks tested).

Query

 Range/Resolution: see FETCh:HBLerror:SSCell?

Requirements
Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SSCell:NACK?"

FETCh:HBLerror:SSCell:SDTX?

Function

Returns the number of scondary serving cell statistical DTXs (Secondary Serving Cell statDTXs) during the measurement interval (number of blocks tested).

Query

 Range/Resolution: see FETCh:HBLerror:SSCell?

Requirements
Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SSCell:SDTX?"

FETCh:HBLerror:SSCell:IBTHroughput?

Function

Returns the Secondary Serving Cell Information Bit Throughput for the measurement interval (number of blocks tested).

Query

 Range/Resolution: see FETCh:HBLerror:SSCell?

Requirements
Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SSCell:IBTHroughput?"

FETCh:HBLerror:SSCell:MCQindicator?

Function

Returns the secondary Secondary Serving Cell Median CQI for the measurement interval (number of blocks tested).

Query

 Range/Resolution: see FETCh:HBLerror:SSCell?

Requirements
Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SSCell:MCQindicator?"

FETCh:HBLerror:SSCell:BLOCks?

Function

Returns the number of Secondary Serving Cell Blocks Tested.

Query

 Range/Resolution: see FETCh:HBLerror:SSCell?

Requirements
Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SSCell:BLOCks?"

FETCh:HBLerror:SSCell:ICOunt?

Function

Queries the intermediate count of blocks tested for the DC-HSDPA secondary serving cell.

To set up the total number of blocks to test for serving cell , see SETup:HBLerror:COUNt:DCHSdpa:SECondary .

Query

Range: 0 to 99,000 blocks

Resolution: 100 blocks

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"FETCh:HBLerror:SSCell:ICOunt?"


FETCh:HRCQuality

FETCh:HRCQuality

Last updated: January 16, 2009

GPIB Command Conventions

This section is only applicable to the lab application.

  • FETCh:HRCQuality[:ALL]?
  • FETCh:HRCQuality:ICOunt?
  • FETCh:HRCQuality:INTegrity?
  • FETCh:HRCQuality:FAIL?

  • FETCh:HRCQuality:SENSe:BASE:ACKS:FILTered?
  • FETCh:HRCQuality:SENSe:BASE:ANResponses:FILTered?
  • FETCh:HRCQuality:SENSe:BASE:BLERatio:FILTered?
  • FETCh:HRCQuality:SENSe:BASE:CQINdicator[:DTFormat]?
  • FETCh:HRCQuality:SENSe:BASE:CQINdicator:MEDian?
  • FETCh:HRCQuality:SENSe:BASE:CQIReports:DISTribution?
  • FETCh:HRCQuality:SENSe:BASE:NACKs:FILTered?
  • FETCh:HRCQuality:SENSe:BASE:SDTX?

  • FETCh:HRCQuality:SENSe:BDETection:ACKS:FILTered?
  • FETCh:HRCQuality:SENSe:BDETection:ANResponses:FILTered?
  • FETCh:HRCQuality:SENSe:BDETection:BLERatio:FILTered?
  • FETCh:HRCQuality:SENSe:BDETection:CQINdicator[:DTFormat]?
  • FETCh:HRCQuality:SENSe:BDETection:CQINdicator:MEDian?
  • FETCh:HRCQuality:SENSe:BDETection:CQIReports:DISTribution?
  • FETCh:HRCQuality:SENSe:BDETection:DIRection?
  • FETCh:HRCQuality:SENSe:BDETection:NACKs:FILTered?
  • FETCh:HRCQuality:SENSe:BDETection:SDTX?

  • FETCh:HRCQuality:VARiance:CQINdicator[:DTFormat]?
  • FETCh:HRCQuality:VARiance:CQINdicator:MEDian?
  • FETCh:HRCQuality:VARiance:CQIReports[:COUNt]?
  • FETCh:HRCQuality:VARiance:CQIReports:CQIMinus1?
  • FETCh:HRCQuality:VARiance:CQIReports:CQIMinus2?
  • FETCh:HRCQuality:VARiance:CQIReports:CQIPlus0?
  • FETCh:HRCQuality:VARiance:CQIReports:CQIPlus1?
  • FETCh:HRCQuality:VARiance:CQIReports:CQIPlus2?
  • FETCh:HRCQuality:VARiance:CQIReports:DISTribution?
  • FETCh:HRCQuality:VARiance:CQIReports:WRANge?

  • FETCh:HRCQuality:VARiance:FAIL?

FETCh:HRCQuality[:ALL]?

Function

Queries the Reporting of Channel Quality Indicator measurement results and returns the following comma separated values: Integrity Indicator, Reporting of Channel Quality Indicator overall Pass/Fail.

See HSDPA Reporting of Channel Quality Indicator Measurement Description .

Query

Integrity Indicator - see Integrity Indicator

Reporting of Channel Quality Indicator overall Pass/Fail

Range: 0 (pass), 1 (fail), 9.91E+37

Requirements

 Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality?"
!Returns Integrity Indicator and Reporting of Channel Quality Indicator Pass/Fail
result.

FETCh:HRCQuality:ICOunt?

Function

Queries the intermediate count of the number of CQI reports collected during the CQI Variance test and also the number of ACK/NACK responses during the BLER versus CQI Sense test. Since the tests are run sequentially, you should notice the count restarting each time a test is started (see HSDPA Reporting of Channel Quality Indicator Measurement Description ).

To set the total number of CQI reports to test, see SETup:HRCQuality:VARiance:CQIReports[:COUNt] .

Query

Range: 1 to 99000

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:ICOunt?"
!Returns the intermediate count of the collected CQI reports.

FETCh:HRCQuality:INTegrity?

Function

Queries the Integrity Indicator for the HSDPA Reporting of Channel Quality Indicator measurement (see HSDPA Reporting of Channel Quality Indicator Measurement Description ).

Query

Range: 0 to the number of available integrity indicators.

Resolution: 1

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:INTegrity?"
!Returns Integrity Indicator for the Reporting of Channel Quality Indicator
measurement.

FETCh:HRCQuality:FAIL?

Function

Queries the Reporting of Channel Quality Indicator overall Pass/Fail result.

See HSDPA Reporting of Channel Quality Indicator Measurement Description .

Query

Range: 0 (pass), 1 (fail), 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:FAIL?"
!Returns the Reporting of Channel Quality Indicator Pass/Fail result.

FETCh:HRCQuality:SENSe:BASE:ACKS:FILTered?

Function

 Queries the number of Filtered ACKs for filtered HSDPA BLER measurement using the Median_CQI value.

Query

Range: 0 to 99000, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:SENSe:BASE:ACKS:FILTered?"
!Returns the number of filtered ACKs.

FETCh:HRCQuality:SENSe:BASE:ANResponses:FILTered?

Function

 Queries the number of Filtered ACKs+NACKs in the filtered HSDPA BLER measurement using the Median_CQI value.

Query

Range: 0 to 99000, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQualtiy:SENSe:BASE:ANResponses:FILTered?"
!Returns the number of filtered ACKs+NACKs.

FETCh:HRCQuality:SENSe:BASE:BLERatio:FILTered?

Function

 Queries the Filtered BLER (%) using the Median_CQI value.

Query

Range: 0.00 to 100.00, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQualtiy:SENSe:BASE:BLERatio:FILTered?"
!Returns the filtered HSDPA BLER using Median_CQI.

FETCh:HRCQuality:SENSe:BASE:CQINdicator[:DTFormat]?

Function

 Queries the Downlink TF CQI that is used in the BLER versus CQI Sense test for Median_CQI as a result of the Median_CQI result found in the CQI Variance test.

Query

Range: 1 to 30, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQualtiy:SENSe:BASE:CQINdicator?"
!Returns the Downlink TF CQI.

FETCh:HRCQuality:SENSe:BASE:CQINdicator:MEDian?

Function

 Queries the Median CQI used during the BLER versus CQI Sense test using the Median_CQI value.

Query

Range: 0 to 30, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQualtiy:SENSe:BASE:CQINdicator:MEDian?"
!Returns the Median CQI used for the BLER versus CQI Sense test.

FETCh:HRCQuality:SENSe:BASE:CQIReports:DISTribution?

Function

 Queries the frequency distribution of UE reported CQI values. See HSDPA Reporting of Channel Quality Indicator Measurement Description .

Query

An array of 31 values, each element of the array has a range of 0 to 30, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:SENSe:BASE:CQIReports:DISTribution?"
!Returns an array of the frequency distribtion of th UE reported CQI values.

FETCh:HRCQuality:SENSe:BASE:NACKs:FILTered?

Function

 Queries the number of Filtered NACKs for filtered HSDPA BLER measurement using the Median_CQI value.

Query

Range: 0 to 99000, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:SENSe:BASE:NACKs:FILTered?"
!Returns the number of Filtered NACKs received in the filtered
HSDPA BLER measurement using the Median_CQI value.

FETCh:HRCQuality:SENSe:BASE:SDTX?

Function

 Queries the number of statDTXs for BLER versus CQI Sense using the Median_CQI value.

Query

Range: 0 to 99000, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:SENSe:BASE:SDTX?"
!Returns the number of statistical DTXs.

FETCh:HRCQuality:SENSe:BDETection:ACKS:FILTered?

Function

 Queries the number of Filtered ACKs for the filtered HSDPA BLER measurement using either Median_CQI-1 or Median_CQI +2.

Query

Range: 0 to 99000, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:SENSe:BDETection:ACKS:FILTered?"
!Returns the number of Filtered ACKS received during the filtered
HSDPA BLER measurement using the Median_CQI-1 or Median CQI+2.

FETCh:HRCQuality:SENSe:BDETection:ANResponses:FILTered?

Function

 Queries the number of Filtered ACKs+NACKs for the filtered HSDPA BLER measurement using either Median_CQI-1 or Median_CQI +2.

Query

Range: 0 to 99000, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:SENSe:BDETection:ANResponses:FILTered?"
!Returns the number of Filtered ACKs+NACKs received during the
filtered HSDPA BLER measurement using the Median_CQI-1 or Median CQI+2.

FETCh:HRCQuality:SENSe:BDETection:BLERatio:FILTered?

Function

 Queries the Filtered BLER (%) using Median_CQI-1 or Median_CQI+2.

Query

Range: 0.00 to 100.00, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:SENSe:BDETection:BLERatio:FILTered?"
!Returns the Filtered BLER using Median_CQI-1 or Median_CQI+2.

FETCh:HRCQuality:SENSe:BDETection:CQINdicator[:DTFormat]?

Function

 Queries the Downlink TF CQI for the BLER versus CQI Sense that uses either Median_CQI-1 or Median_CQI+2 (based on the filtered HSDPA BLER result using Median_CQI), see HSDPA Reporting of Channel Quality Indicator Measurement Description .

Query

Range: 1 to 30, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:SENSe:BDETection:CQINdicator?"
!Returns the Downlink TF CQI for either Median_CQI-1 or Median_CQI+2.

FETCh:HRCQuality:SENSe:BDETection:CQINdicator:MEDian?

Function

 Queries the Median CQI for the BLER versus CQI Sense test.

Query

Range: 0 to 30, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:SENSe:BDETection:CQINdicator:MEDian?"
!Returns the Median CQI for the BLER versus CQI Sense test.

FETCh:HRCQuality:SENSe:BDETection:CQIReports:DISTribution?

Function

 Queries the frequency distribution of UE reported CQI values. See Median CQI

Query

Range: 1 to 99000, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:SENSe:BDETection:CQIReports:DISTribution?"
!Returns the frequency distribution of UE reported CQI values during the
BLER versus CQI Sense Part of the Reporting of Channel Quality Indicator
Measurement for either Median_CQI-1 or Median_CQI+2.

FETCh:HRCQuality:SENSe:BDETection:DIRection?

Function

Queries the direction (or sense) of the BLER. That is, if the filtered HSDPA BLER result is less than the Filtered BLER for initial CQI sense decision setting, the direction is Median_CQI+2. Similarly, if the filtered HSDPA BLER is greater than or equal to the Filtered BLER for initial CQI sense decision , the direction is Median_CQI-1.

To set the Filtered BLER for initial CQI sense decision , see SETup:HRCQuality:SENSe:BLERatio:FILTered:BASE:DECision .
Query

Range: 1 (Median_CQI+2), 2 (Median_CQI-1)

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:SENSe:BDETection:DIRection?"
!Returns the direction of BLER.

FETCh:HRCQuality:SENSe:BDETection:NACKs:FILTered?

Function

 Queries the number of received Filtered NACKs in the BLER versus CQI Sense test using either Median_CQI-1 or Median_CQI+2.

Query

Range: 0 to 99000, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:SENSe:BDETection:NACKs:FILTered?"
!Returns the number of received Filtered NACKs in the BLER versus CQI Sense test
!using either Median_CQI-1 or Median_CQI+2.

FETCh:HRCQuality:SENSe:BDETection:SDTX?

Function

Queries the number of received statDTXs in the BLER versus CQI Sense test using either Median_CQI-1 or Median_CQI+2.

Query

Range: 0 to 999, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:SENSe:BDETection:SDTX?"
!Returns the number of received statistical DTXs in the BLER versus CQI Sense test
!using either Median_CQI-1 or Median_CQI+2.

FETCh:HRCQuality:VARiance:CQINdicator[:DTFormat]?

Function

Queries the Downlink TF CQI for the CQI Variance test.

Query

Range: 1 to 30, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:VARiance:CQINdicator[:DTFormat]?"
!Returns the Downlink TF CQI for the CQI Variance test.

FETCh:HRCQuality:VARiance:CQINdicator:MEDian?

Function

 Queries the Median_CQI value that was measured during the CQI Variance test.

Query

Range: 0 to 30, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:VARiance:CQINdicator:MEDian?"
!Returns the Median_CQI value that was received during the CQI Variance test.

FETCh:HRCQuality:VARiance:CQIReports[:COUNt]?

Function

 Queries the Number of CQI Reports to test .

Query

Range: 1 to 99000, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:VARiance:CQIReports?"
!Returns the Number of CQI Reports to test.

FETCh:HRCQuality:VARiance:CQIReports:CQIMinus1?

Function

Queries the frequency of Median_CQI-1 occurrences during the CQI Variance tests.

See HSDPA Reporting of Channel Quality Indicator Measurement Description .

Query

Range: 0 to 99000, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:VARiance:CQIReports:CQIMinus1?"
!Returns the number of Median_CQI-1 occurrences.

FETCh:HRCQuality:VARiance:CQIReports:CQIMinus2?

Function

Queries the frequency of Median_CQI-2 occurrences during the CQI Variance tests.

See HSDPA Reporting of Channel Quality Indicator Measurement Description .

Query

Range: 0 to 99000, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:VARiance:CQIReports:CQIMinus2?"
!Returns the number of Median_CQI-2 occurrences.

FETCh:HRCQuality:VARiance:CQIReports:CQIPlus0?

Function

Queries the frequency of Median_CQI occurrences during the CQI Variance tests.

See HSDPA Reporting of Channel Quality Indicator Measurement Description .

Query

Range: 0 to 99000, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:VARiance:CQIReports:CQIPlus0?"
!Returns the number of Median_CQI occurrences.

FETCh:HRCQuality:VARiance:CQIReports:CQIPlus1?

Function

Queries the frequency of Median_CQI+1 occurrences during the CQI Variance tests.

See HSDPA Reporting of Channel Quality Indicator Measurement Description .

Query

Range: 0 to 99000, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:VARiance:CQIReports:CQIPlus1?"
!Returns the number of Median_CQI+1 occurrences.

FETCh:HRCQuality:VARiance:CQIReports:CQIPlus2?

Function

Queries the frequency of Median_CQI+2 occurrences during the CQI Variance tests.

See HSDPA Reporting of Channel Quality Indicator Measurement Description .

Query

Range: 0 to 99000, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:VARiance:CQIReports:CQIPlus2?"
!Returns the number of Median_CQI+2 occurrences.

FETCh:HRCQuality:VARiance:CQIReports:DISTribution?

Function

 Queries the frequency distribution of UE reported CQI values during the CQI Variance test. See HSDPA Reporting of Channel Quality Indicator Measurement Description .

Query

Range: 1 to 99000, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:VARiance:CQIReports:DISTribution?"
!Returns an array of the frequency distribution of UE reported CQI values
!during the CQI Variance test.

FETCh:HRCQuality:VARiance:CQIReports:WRANge?

Function

Queries the CQI in Range (%) during the CQI Variance test.

Query

Range: 0.00 to 100.00, 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:VARiance:CQIReports:WRANge?"
!Returns the percentage of CQI values within Median_CQI-2 to Median_CQI+2.

FETCh:HRCQuality:VARiance:FAIL?

Function

 Queries the Pass/Fail Result of the CQI Variance test. See HSDPA Reporting of Channel Quality Indicator Measurement Description .

Query

Range: 0 (pass), 1 (fail), 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:HRCQuality:VARiance:FAIL?"
!Returns the pass/fail result of the CQI Variance test.


FETCh:SAUDio

FETCh:SAUDio

January 16, 2009

GPIB Command Conventions

  • FETCh:SAUDio[:ALL]?

  • FETCh:SAUDio:DISTortion[:AVERage]?
  • FETCh:SAUDio:DISTortion:MAXimum?
  • FETCh:SAUDio:DISTortion:MINimum?
  • FETCh:SAUDio:DISTortion:SDEViation?

  • FETCh:SAUDio:ICOunt?

  • FETCh:SAUDio:INTegrity?

  • FETCh:SAUDio:SINAD[:AVERage]?
  • FETCh:SAUDio:SINAD:MAXimum?
  • FETCh:SAUDio:SINAD:MINimum?
  • FETCh:SAUDio:SINAD:SDEViation?

  • FETCh:SAUDio:VOLTage[:AVERage]?
  • FETCh:SAUDio:VOLTage:MAXimum?
  • FETCh:SAUDio:VOLTage:MINimum?
  • FETCh:SAUDio:VOLTage:SDEViation?

FETCh:SAUDio[:ALL]?

Function

This query returns the swept audio measurement results. This query returns results in the following order: integrity indicator, average swept audio level and average distortion for the first frequency point, average swept audio level and average distortion for the second frequency point, and so on. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.

For frequencies above 10 kHz, this measurement returns 9.91 E+37.

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Average audio level

  • Range: 1 mV to 20 V, 9.91 E+37
  • Resolution: the lesser of 4 significant digits or 10 uV

Average distortion

  • Range: 0 to 99.9%, 9.91 E+37
  • Resolution: 0.01%

FETCh:SAUDio:DISTortion[:AVERage]?

Function

This query returns a comma separated list of the audio distortion measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.

For frequencies above 10 kHz, this measurement returns 9.91 E+37.

Query

Average audio distortion

  • Range: 0 to 99.9%, 9.91 E+37

  • Resolution: 0.01%

FETCh:SAUDio:DISTortion:MAXimum?

Function | This query returns a comma separated list of the maximum audio distortion measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command. For frequencies above 10 kHz, this measurement returns 9.91 E+37.
Query | Range: 0 to 99.9%, 9.91 E+37 Resolution: 0.01%

FETCh:SAUDio:DISTortion:MINimum?

Function | This query returns a comma separated list of the minimum audio distortion measured at each frequency point in the sweep. For frequencies above 10 kHz, this measurement returns 9.91 E+37.
Query | Range: 0 to 99.9%, 9.91 E+37 Resolution: 0.01%

FETCh:SAUDio:DISTortion:SDEViation?

Function | This query returns a comma separated list of the standard deviation audio distortion measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command. For frequencies above 10 kHz, this measurement returns 9.91 E+37.
Query | Range: 0 to 99.9%, 9.91 E+37 Resolution: 0.001%

FETCh:SAUDio:ICOunt?

Function | This query returns the intermediate count of swept audio multi-measurements completed. The total measurement count is the number of measurements specified in with the multi-measurement count command, SETup:SAUDio:COUNt[:SNUMber] , times the number of frequency points specified with the SETup:SAUDio:FREQuency:POINts . Therefore, when completing a 5 point sweep with multi-measurements turned off, the measurement will return 5 not 1. See also SETup:SAUDio:ICOunt:MAXimum? .
Query | Range: 1 to 999 x 60 Resolution: 1

FETCh:SAUDio:INTegrity?

Function | This query returns the integrity indicator for the last swept audio measurement completed. Zero indicates a normal measurement. See Integrity Indicator for descriptions of non-zero integrity indicators.
Query | Range: See Integrity Indicator . Resolution: 1

FETCh:SAUDio:SINAD[:AVERage]?

Function

This query returns a comma separated list of the average SINAD measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.

Query

Average SINAD

  • Range: -99.99 to 99.99 dB, 9.91 E+37

  • Resolution: 0.01 dB

FETCh:SAUDio:SINAD:MAXimum?

Function | This query returns a comma separated list of the maximum SINAD measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: -99.99 to 99.99 dB, 9.91 E+37 Resolution: 0.01 dB

FETCh:SAUDio:SINAD:MINimum?

Function | This query returns a comma separated list of the minimum SINAD measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: -99.99 to 99.99 dB, 9.91 E+37 Resolution: 0.01 dB

FETCh:SAUDio:SINAD:SDEViation?

Function | This query returns a comma separated list of the standard deviation of SINAD measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: 0 to 99.99 dB, 9.91 E+37 Resolution: 0.001 dB

FETCh:SAUDio:VOLTage[:AVERage]?

Function | This query returns a comma separated list of the average swept audio level measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command. Value is returned in units of V.
Query | Range: 1 mV to 20, 9.91 E+37 Resolution: 4 significant digits

FETCh:SAUDio:VOLTage:MAXimum?

Function | This query returns a comma separated list of the maximum audio voltage measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: 1 mV to 20 V, 9.91 E+37 Resolution: 4 significant digits

FETCh:SAUDio:VOLTage:MINimum?

Function | This query returns a comma separated list of minimum audio voltage measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: 1 mV to 20 V, 9.91 E+37 Resolution: 4 significant digits

FETCh:SAUDio:VOLTage:SDEViation?

Function | This query returns a comma separated list of the standard deviation of audio voltage measured at each point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: 1 mV to 20 V, 9.91 E+37 Resolution: 4 significant digits


FETCh:SMONitor

FETCh:SMONitor

Last updated: January 16, 2009

GPIB Command Conventions

  • FETCh:SMONitor[:ALL]?
  • FETCh:SMONitor:INTegrity?
  • FETCh:SMONitor:TRACe?

FETCh:SMONitor[:ALL]?

Function

 Queries the spectrum monitor and returns Integrity Indicator followed by 401 points representing the amplitude results (in dBm) of the trace data.

Query

Range:

  • For spans of 125 kHz and 500 kHz

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: -50 to +55 dB

  • For all other spans

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: (reference level - 60 dB) to +55 dB

FETCh:SMONitor:INTegrity?

Function | Returns the integrity indicator value for the last spectrum monitor measurement performed. Zero indicates a normal result. See Integrity Indicator for descriptions of non-zero integrity indicators.
Query | Range: See Integrity Indicator . Resolution: 1

FETCh:SMONitor:TRACe?

Function

 Queries the spectrum monitor and returns Integrity Indicator followed by 401 points representing the amplitude results (in dBm) of the trace data.

Query

Range:

  • For spans of 125 kHz and 500 kHz

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: -50 to +55 dB

  • For all other spans

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: (reference level - 60 dB) to +55 dB


FETCh:WACLeakage

FETCh:WACLeakage

Last updated: January 16, 2009

GPIB Command Conventions

  • FETCh:WACLeakage[:ALL]?
  • FETCh:WACLeakage:AVERage[:ALL]?
  • FETCh:WACLeakage:ICOunt?

  • FETCh:WACLeakage:ICPower:[AVERage]?
  • FETCh:WACLeakage:ICPower:ALL?
  • FETCh:WACLeakage:ICPower:MAXimum?
  • FETCh:WACLeakage:ICPower:MINimum?
  • FETCh:WACLeakage:ICPower:SDEViation?

  • FETCh:WACLeakage:INTegrity?
  • FETCh:WACLeakage:SDEViation[:ALL]?

FETCh:WACLeakage[:ALL]?

Function

Queries an adjacent channel leakage ratio (ACLR) measurement result.

This query returns an integrity indicator followed by -5 MHz offset power ratio maximum, +5 MHz offset power ratio maximum, -10 MHz offset power ratio maximum, +10 MHz offset power ratio maximum.

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WACLEAKAGE:ALL?" !Returns integrity, ACLR measurements.

FETCh:WACLeakage:AVERage[:ALL]?

Function

Queries the average adjacent channel leakage ratio at the following offsets: -5 MHz, +5 MHz, -10 MHz, +10 MHz.

To set the number of measurement to average, use the command SETup:WACLeakage:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WACLEAKAGE:AVERAGE:ALL?"
!Queries the average adjacent channel leakage ratio.

FETCh:WACLeakage:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

To set up multi-measurements, see SETup:WACLeakage:COUNt[:SNUMber] .

Query

Range: 0 to 999

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WACLEAKAGE:ICOUNT?"
!Returns the intermediate count of adjacent channel leakage ratio multi-measurements.

FETCh:WACLeakage:ICPower:[AVERage]?

Function

Queries the average of several adjacent channel leakage measurement, in-channel power results. To set the number of measurements to average, use the command SETup:WACLeakage:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"FETCh:WACLeakage:ICPower?"
!Queries the average power for the in-channel power results.

FETCh:WACLeakage:ICPower:ALL?

Function

Queries the statistical measurement results for several adjacent channel leakage measurement, in-channel power results.

To set the number of measurements to gather statistics for, use the command SETup:WACLeakage:COUNt[:SNUMber] .

Results are returned in the following order: minimum, maximum, average, and standard deviation in-channel power.

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"FETCh:WACLeakage:ICPower:ALL?"
!Queries the statistical measurement results for the ACLR measurement, in-channel power results.

FETCh:WACLeakage:ICPower:MAXimum?

Function

Queries the maximum in-channel power of several adjacent channel leakage measurements. To set the number of measurement to average, use the command SETup:WACLeakage:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"FETCh:WACLeakage:ICPower:MAXimum?"
!Queries the maximum in-channel power of several ACLR measurements.

FETCh:WACLeakage:ICPower:MINimum?

Function

 Queries the minimum in-channel power of several adjacent channel leakage measurements. To set the number of measurements to compare, use the command SETup:WACLeakage:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"FFETCh:WACLeakage:ICPower:MINimum?"
!Queries the minimum in-channel power of several ACLR measurements.

FETCh:WACLeakage:ICPower:SDEViation?

Function

Queries the standard deviation of in-channel power for several adjacent channel leakage measurements. To set the number of measurement to compare, use the command SETup:WACLeakage:COUNt[:SNUMber] .

Query

  • Range: 0 to 99 dB, 9.91 E+37

  • Resolution: 0.001 dB

Requirements

Test Application Revision: A.14 and above

Programming Example

OUTPUT 714;"FETCh:WACLeakage:ICPower:SDEViation?"
!Queries the standard deviation of in-channel power for the ACLR measurements.

FETCh:WACLeakage:INTegrity?

Function

Queries the measurement integrity indicator for the last adjacent channel leakage measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WACLEAKAGE:INTegrity?"
!Queries the integrity indicator for the adjacent channel leakage ratio results.

FETCh:WACLeakage:SDEViation[:ALL]?

Function

Queries the standard deviation of several adjacent channel leakage ratio measurements at the following offsets: -5 MHz, +5 MHz, -10 MHz, +10 MHz.

To set the number of measurement to compare, use the command SETup:WACLeakage:COUNt[:SNUMber] .

Query

  • Range: 0 to 99 dB, 9.91 E+37

  • Resolution: 0.001 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WACLEAKAGE:SDEVIATION:ALL?"
!Queries the standard deviation of power for the adjacent channel leakage ratio !measurements.


FETCh:WBERror

FETCh:WBERror

Last updated: January 16, 2009

GPIB Command Conventions

  • FETCh:WBERror<[:ALL]|:INTegrity|:RATio|:COUNt|:BITS>?
  • FETCh:WBERror:RATio:FAIL?
  • FETCh:WBERror:CRCerrors?
  • FETCh:WBERror:ICOunt?
  • FETCh:WBERror:LDELay?
  • FETCh:WBERror:MBLocks?

FETCh:WBERror<[:ALL]|:INTegrity|:RATio|:COUNt|:BITS>?

Function

Queries the Loopback BER Measurement Results .

[:ALL] returns measurement results in the following order: integrity, bit error ratio, bit error count, bits tested.

Instead of querying [:ALL] results, you may query an individual result using the appropriate keyword (for example, FETCh:WBERror:RATio? returns the bit error ratio result only).
Query

Range

  • Integrity: see Integrity Indicator .
  • Bit Error Ratio: 0 to 99.0000%, 9.91 E+37
  • Bit Error Count: 0 to 999999999, 9.91 E+37
  • Bits Tested: 0 to 999999999, 9.91 E+37

Resolution

  • Integrity: 1
  • Bit Error Ratio: 0.0001%
  • Bit Error Count: 1
  • Bits Tested: 1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WBERROR:ALL?"

FETCh:WBERror:RATio:FAIL?

Function

Queries the Confidence Test Result .

Query

Range:

  • 0 (Pass)
  • 1 (Fail)
  • 2 (Max Bits)
  • 9.91 E+37

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WBERror:RATio:FAIL?"

FETCh:WBERror:CRCerrors?

Function

Queries the CRC Errors result. See CRC Errors .

Query

Range: 0 to 999999, 9.91 E+37

Resolution: 1

Requirements

Test Application Revision: A.04 and above

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCh:WBERror:CRCerrors?"

FETCh:WBERror:ICOunt?

Function

Queries the intermediate count of bits tested.

To set up the total number of bits to test, see SETup:WBERror:COUNt .

Query

Range: 0 to 999999999

Resolution: 1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WBERROR:ICOUNT?"

FETCh:WBERror:LDELay?

Function

Queries the Loopback Delay result.

Loopback Delay results can not be obtained when DL DTCH Data is set to All Zeros or All Ones (see CALL:DTCHannel:DATA ).

Query

Range: 0 to 50 frames, 9.91 E+37

Resolution: 1

Requirements

Test Application Revision: A.04 and above

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCh:WBERror:LDELay?"

FETCh:WBERror:MBLocks?

Function

Queries the Missing Blocks result.

Query

Range: 0 to 999999, 9.91 E+37

Resolution: 1

Requirements

Test Application Revision: A.04 and above

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCh:WBERror:MBLocks?"


FETCh:WBLerror

FETCh:WBLerror

Last updated: January 16, 2009

GPIB Command Conventions

  • FETCh:WBLerror<[:ALL]|:INTegrity|:RATio|:COUNt|:BLOCks|:MBLocks>?
  • FETCh:WBLerror:ICOunt?

FETCh:WBLerror<[:ALL]|:INTegrity|:RATio|:COUNt|:BLOCks|:MBLocks>?

Function

Queries a block error ratio measurement result.

Measurement results are returned in the following order: integrity, block error ratio, block error count, blocks tested, uplink missing blocks.

These results may also be queried individually using the appropriate command, as indicated in the diagram above. For example, to query the block error ratio result only, use the FETCh:WBLerror:RATio? command.

See Block Error Ratio Measurement Results .
Query

Range

  • Integrity: see Integrity Indicator .
  • Block Error Ratio: 0 to 99%, 9.91 E+37
  • Block Error Count: 0 to 99000, 9.91 E+37
  • Blocks Tested: 0 to 99000, 9.91 E+37
  • Uplink Missing Blocks: 0 to 99000, 9.91 E+37

Resolution

  • Integrity: 1
  • Block Error Ratio: 0.0001%
  • Block Error Count: 1
  • Blocks Tested: 1
  • Uplink Missing Blocks: 1

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"FETCh:WBLerror?"

FETCh:WBLerror:ICOunt?

Function

Queries the intermediate count of blocks tested.

To set up the total number of blocks to test, see SETup:WBLerror:COUNt .

Query

Range: 0 to 99000

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"FETCh:WBLerror:ICOunt?"


FETCh:WCDomain

FETCh:WCDomain

Last updated: January 16, 2009

GPIB Command Conventions

  • FETCh:WCDomain[:ALL]?

  • FETCh:WCDomain:BETas?
  • FETCh:WCDomain:BETas:HSPA?

  • FETCh:WCDomain:CERRor:ICHannel[:ALL]?
  • FETCh:WCDomain:CERRor:QCHannel[:ALL]?
  • FETCh:WCDomain:CERRor:RELative:ICHannel[:ALL]?
  • FETCh:WCDomain:CERRor:RELative:QCHannel[:ALL]?

  • FETCh:WCDomain:EVM?

  • FETCh:WCDomain:FERRor?

  • FETCh:WCDomain:INTegrity?

  • FETCh:WCDomain:MERRor?

  • FETCh:WCDomain:OOFFset?

  • FETCh:WCDomain:PCERror[:ALL]?
  • FETCh:WCDomain:PCERror:CHANnel?
  • FETCh:WCDomain:PCERror:ERRor?

  • FETCh:WCDomain:PERRor?

  • FETCh:WCDomain:POWer:EFFective:ICHannel[:ALL]?
  • FETCh:WCDomain:POWer:EFFective:QCHannel[:ALL]?
  • FETCh:WCDomain:POWer:ICHannel[:ALL]?
  • FETCh:WCDomain:POWer:NOMinal:ICHannel[:ALL]?
  • FETCh:WCDomain:POWer:NOMinal:QCHannel[:ALL]?
  • FETCh:WCDomain:POWer:QCHannel[:ALL]?
  • FETCh:WCDomain:POWer:RELative:ACCuracy:ICHannel[:ALL]?
  • FETCh:WCDomain:POWer:RELative:ACCuracy:QCHannel[:ALL]?

  • FETCh:WCDomain:TERRor?

FETCh:WCDomain[:ALL]?

Function

Queries the code domain measurements.

Measurement results are returned in the following order: integrity, EVM maximum, frequency error worst case, origin offset maximum, phase error maximum, worst case timing error, peak code domain error maximum.

Query

Integrity

  • Range: 0 to 23

  • Resolution: 1

EVM Maximum

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Frequency Error worst case

  • Range: -99.99 to 99.99 kHz, 9.91 E+37

  • Resolution: 0.1

Origin Offset Maximum

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error Maximum

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Timing Error Maximum

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Peak Code Domain Error Maximum

  • Range: -99.0 to 0.0 dB, 9.91 E+37

  • Resolution: 0.1

Requirements

Test Application Revision: A.02 and above

Test Application Revision: A.03, timing error is returned in chips instead of seconds

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:ALL?"

FETCh:WCDomain:BETas?

Function

Queries Beta c , Beta d1 , Beta d2 , Beta d3 , Beta d4 , Beta d5 , Beta d6 , Beta hsacknak , Beta hscqi . These beta results are the same as those returned by the waveform quality measurement (see Betac, Betad1, Betad2, Betad3, Betad4, Betad5, Betad6, Betahsacknak, Betahscqi ).

Query

Range: 0 to 1

Resolution: 0.001

Requirements

Test Application Revision: A.02 and above.

Test Application Revision A.09, with the required feature license, added Beta hsacknak and Beta hscqi .

Lab Application Revision: A.01 and above.

Lab Application Revision C.04 and D.00, added Beta hsacknak and Beta hscqi .

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:BETAS?"

FETCh:WCDomain:BETas:HSPA?

Function

Queries Beta c , Beta d1 , Beta d2 , Beta d3 , Beta d4 , Beta d5 , Beta d6 , Beta hsacknak , Beta hscqi , Beta ec , Beta ed1 , Beta ed2 . See Betaec, Betaed1, Betaed2 .

Query

Range: 0 to 1

Resolution: 0.001

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:WCDomain:BETas:HSPA?"

FETCh:WCDomain:CERRor:ICHannel[:ALL]?

Function

Queries the Code Domain Error (CDE) in each of the 256 "I" code channels (0 through 255).

Query

Range: -99.00 to 0.00 dB

Resolution: 0.01

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:CERROR:ICHANNEL:ALL?"

FETCh:WCDomain:CERRor:QCHannel[:ALL]?

Function

Queries the Code Domain Error (CDE) in each of the 256 "Q" code channels (0 through 255).

Query

Range: -99.00 to 0.00 dB

Resolution: 0.01

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:CERROR:QCHANNEL:ALL?"

FETCh:WCDomain:CERRor:RELative:ICHannel[:ALL]?

Function

Queries the Relative Code Domain Error (RCDE) in each of the 256 "I" code channels (0 through 255).

Query

Range: -99.00 to 0.00 dB, 9.91E+37

Resolution: 0.01

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:WCDomain:CERRor:RELative:ICHannel?"

FETCh:WCDomain:CERRor:RELative:QCHannel[:ALL]?

Function

Queries the Relative Code Domain Error (RCDE) in each of the 256 "Q" code channels (0 through 255).

Query

Range: -99.00 to 0.00 dB, 9.91E+37

Resolution: 0.01

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:WCDomain:CERRor:RELative:QCHannel?"

FETCh:WCDomain:EVM?

Function

Queries the maximum error vector magnitude (EVM).

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:EVM?" !Returns maximum EVM.

FETCh:WCDomain:FERRor?

Function

Queries the worst case frequency error.

Query

Range: -99 to 99 kHz, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:FERROR?" !Returns worst case frequency error.

FETCh:WCDomain:INTegrity?

Function

Queries the measurement integrity indicator for the last code domain measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:INTEGRITY?"
!Queries the integrity indicator for the code domain measurement results.

FETCh:WCDomain:MERRor?

Function

Queries the maximum magnitude error.

Query

Range: 0.0 to 99.0%

Resolution: 0.1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:MERRor?" !Returns maximum magnitude error.

FETCh:WCDomain:OOFFset?

Function

Queries the maximum origin offset.

Query

Range: -99 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:OOFFSET?" !Returns maximum origin offset.

FETCh:WCDomain:PCERror[:ALL]?

Function

Queries the peak code domain error measurement. There are four numbers returned for each measurement. The first three numbers describe channel at which the peak error result was measured (channelization code, spread factor, I/Q channel type), and the last number is the peak error.

Results are returned in the following order: channelization code, spread factor, I/Q channel type, and peak code domain error.

Query

Channelization Code

  • Range: 0 to 255, 9.91 E+37

Spread Factor

  • Range: 4 to 256, 9.91 E+37

I/Q Channel Type

  • Range: 0 = I, 1= Q, 9.91 E+37

Peak Code Domain Error

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:PCERROR:ALL?"
!Returns Channelization code, spread factor, I/Q channel type, and peak error.

FETCh:WCDomain:PCERror:CHANnel?

Function

Returns the orthogonal variable spreading factor (OVSF) code number (channelization code) at which the peak code domain error was detected.

Query

Range: 0 to 255

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:PCERROR:CHANNEL?" !Returns channel at which peak error was detected.

FETCh:WCDomain:PCERror:ERRor?

Function

Queries the maximum peak code domain error.

Query

Range: -99 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:PCERROR:ERRor?" !Returns maximum peak code domain error.

FETCh:WCDomain:PERRor?

Function

Queries the maximum peak code domain error.

Query

Range: 0 to 180 degrees, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:PERROR?" !Returns maximum phase error.

FETCh:WCDomain:POWer:EFFective:ICHannel[:ALL]?

Function

Queries the Effective Code Domain Power (ECDP) in each of the 256 "I" code channels (0 through 255).

Query

Range: -99.00 to 0.00 dB, 9.91E+37

Resolution: 0.01

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:WCDomain:POWer:EFFective:ICHannel?"

FETCh:WCDomain:POWer:EFFective:QCHannel[:ALL]?

Function

Queries the Effective Code Domain Power (ECDP) in each of the 256 "Q" code channels (0 through 255).

Query

Range: -99.00 to 0.00 dB, 9.91E+37

Resolution: 0.01

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:WCDomain:POWer:EFFective:QCHannel?"

FETCh:WCDomain:POWer:ICHannel[:ALL]?

Function

Queries the Code Domain Power (CDP) in each of the 256 "I" code channels (0 through 255).

Query

Range: -99 to 0 dB

Resolution: 0.01

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:POWER:ICHANNEL:ALL?"

FETCh:WCDomain:POWer:NOMinal:ICHannel[:ALL]?

Function

Queries the Nominal Code Domain Power (NCDP) in each of the 256 "I" code channels (0 through 255).

Query

Range: -99 to 0 dB, 9.91E+37

Resolution: 0.01

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:WCDomain:POWer:NOMinal:ICHannel?"

FETCh:WCDomain:POWer:NOMinal:QCHannel[:ALL]?

Function

Queries the Nominal Code Domain Power (NCDP) in each of the 256 "Q" code channels (0 through 255).

Query

Range: -99 to 0 dB, 9.91E+37

Resolution: 0.01

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:WCDomain:POWer:NOMinal:QCHannel?"

FETCh:WCDomain:POWer:QCHannel[:ALL]?

Function

Queries the Code Domain Power (CDP) in each of the 256 "Q" code channels (0 through 255).

Query

Range: -99 to 0 dB

Resolution: 0.01

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:POWER:QCHANNEL:ALL?"

FETCh:WCDomain:POWer:RELative:ACCuracy:ICHannel[:ALL]?

Function

Queries the Relative Code Domain Power Accuracy (RCDPA) in each of the 256 "I" code channels (0 through 255).

Query

Range: -99 to 0 dB, 9.91E+37

Resolution: 0.01

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:WCDomain:POWer:RELative:ACCuracy:ICHannel?"

FETCh:WCDomain:POWer:RELative:ACCuracy:QCHannel[:ALL]?

Function

Queries the Relative Code Domain Power Accuracy (RCDPA) in each of the 256 "Q" code channels (0 through 255).

Query

Range: -99 to 0 dB, 9.91E+37

Resolution: 0.01

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:WCDomain:POWer:RELative:ACCuracy:QCHannel?"

FETCh:WCDomain:TERRor?

Function

Queries the worst case timing error.

Query

Range: -99.99 to 99.99 chips, 9.91 E+37

Resolution: 0.01 chips

Requirements

Test Application Revision: A.02 and above

Test Application Revision: A.03, timing error is returned in chips instead of seconds

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCDOMAIN:TERROR?" !Returns worst case timing error.


FETCh:WCPower

FETCh:WCPower

Last updated: January 16, 2009

GPIB Command Conventions

  • FETCh:WCPower[:ALL]?

  • FETCh:WCPower:ICOunt?

  • FETCh:WCPower:INTegrity?

  • FETCh:WCPower:POWer[:AVERage]?
  • FETCh:WCPower:POWer:ALL?
  • FETCh:WCPower:POWer:MAXimum?
  • FETCh:WCPower:POWer:MINimum?
  • FETCh:WCPower:POWer:SDEViation?

  • FETCh:WCPower:RMSCubed:ALL?
  • FETCh:WCPower:RMSCubed[:AVERage]?
  • FETCh:WCPower:RMSCubed:MAXimum?
  • FETCh:WCPower:RMSCubed:MINimum?
  • FETCh:WCPower:RMSCubed:SDEViation?

FETCh:WCPower[:ALL]?

Function

Queries a channel power measurement result.

This query returns an integrity indicator followed by the average channel power measurement result.

If the multi-measurement state is on, the result represents the average of a number of channel power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WCPower:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCPOWER:ALL?" !Returns integrity, channel power measurement.

FETCh:WCPower:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

To set up multi-measurements, see SETup:WCPower:COUNt[:SNUMber] .

Query

Range: 0 to 999

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCPOWER:ICOUNT?"
!Returns the intermediate count of channel power multi-measurements.

FETCh:WCPower:INTegrity?

Function

Queries the measurement integrity indicator for the last channel power measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCPOWER:INTegrity?"
!Queries the integrity indicator for the channel channel power results.

FETCh:WCPower:POWer[:AVERage]?

Function

Queries the average of the results of several channel power measurements. To set the number of measurement to average, use the command SETup:WCPower:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCPOWER:POWER:AVERAGE?"
!Queries the average power for the channel power results.

FETCh:WCPower:POWer:ALL?

Function

Queries the statistical measurement results for several channel power measurements.

To set the number of measurements to gather statistics for, use the command SETup:WCPower:COUNt[:SNUMber] .

Results are returned in the following order: minimum, maximum, average, and standard deviation channel power.

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCPOWER:POWER:ALL?"
!Queries the statistical measurement results for channel power measurement.

FETCh:WCPower:POWer:MAXimum?

Function

Queries the maximum power of several channel power measurements. To set the number of measurement to average, use the command SETup:WCPower:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCPOWER:POWER:MAXIMUM?"
!Queries the inegrity indicator for the channel power results.

FETCh:WCPower:POWer:MINimum?

Function

 Queries the minimum power of several channel power measurements. To set the number of measurement to compare, use the command SETup:WCPower:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCPOWER:POWER:MINIMUM?"
!Queries the minimum channel power.

FETCh:WCPower:POWer:SDEViation?

Function

Queries the standard deviation of several channel power measurements. To set the number of measurement to compare, use the command SETup:WCPower:COUNt[:SNUMber] .

Query

  • Range: 0 to 99 dB, 9.91 E+37

  • Resolution: 0.001 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WCPOWER:POWER:SDEVIATION?"
!Queries the standard deviation of power for the channel power measurements.

FETCh:WCPower:RMSCubed:ALL?

Function

Queries the RMSCubed results, and returns the following comma separated values: Minimum, Maximum, Average, Standard Deviation RMSCubed.

These results are only available when RMSCubed State is set to on.

Query
  • Minimum, Maximum, Average RMSCubed

    Range: -99.00 to 99.00 dB, 9.91E+37

    Resolution: 0.01 dB

  • Standard Deviation RMSCubed

    Range: -99.000 to 99.000 dB, 9.91E+37

    Resolution: 0.001 dB

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:WCPower:RMSCubed:ALL?"

FETCh:WCPower:RMSCubed[:AVERage]?

Function

Queries the average RMSCubed result.

This result is only available when RMSCubed State is set to on.

Query

Range: -99.00 to 99.00 dB, 9.91E+37

Resolution: 0.01 dB

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:WCPower:RMSCubed?"

FETCh:WCPower:RMSCubed:MAXimum?

Function

Queries the maximum RMSCubed result.

This result is only available when RMSCubed State is set to on.

Query

Range: -99.00 to 99.00 dB, 9.91E+37

Resolution: 0.01 dB

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:WCPower:RMSCubed:MAXimum?"

FETCh:WCPower:RMSCubed:MINimum?

Function

Queries the minimum RMSCubed result.

This result is only available when RMSCubed State is set to on.

Query

Range: -99.00 to 99.00 dB, 9.91E+37

Resolution: 0.01 dB

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:WCPower:RMSCubed:MINimum?"

FETCh:WCPower:RMSCubed:SDEViation?

Function

Queries the standard deviation of the RMSCubed results.

This result is only available when RMSCubed State is set to on.

Query

Range: -99.000 to 99.000 dB, 9.91E+37

Resolution: 0.001 dB

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"FETCh:WCPower:RMSCubed:SDEViation?"


FETCh:WCTFormat

FETCh:WCTFormat

Last updated: January 16, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • FETCh:WCTFormat[:ALL]?
  • FETCh:WCTFormat:ICOunt?
  • FETCh:WCTFormat:INTegrity?
  • FETCh:WCTFormat:STEP:DOWN:RELative:POWer<[:AVERage]|:ALL|:MAXimum|:MINimum|:SDEViation>?
  • FETCh:WCTFormat:STEP:DOWN:ERRor?
  • FETCh:WCTFormat:STEP:DOWN:FAIL?
  • FETCh:WCTFormat:STEP:UP:RELative:POWer<[:AVERage]|:ALL|:MAXimum|:MINimum|:SDEViation>?
  • FETCh:WCTFormat:STEP:UP:ERRor?
  • FETCh:WCTFormat:STEP:UP:FAIL?

FETCh:WCTFormat[:ALL]?

Function

Queries a change of TFC measurement result and returns the following comma separated values: Integrity Indicator, Step Down Relative Power (average result if SETup:WCTFormat:COUNt[:SNUMber] is greater than 0), Step Down Error, Step Down Pass/Fail, Step Up Relative Power (average result if SETup:WCTFormat:COUNt[:SNUMber] is greater than 0), Step Up Error, Step Up Pass/Fail.

See Change of TFC Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

Step Down Relative Power

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Step Down Error

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Step Down Pass/Fail

  • Range: 0 (pass), 1 (fail), 9.91E+37

Step Up Relative Power

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Step Up Error

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Step Up Pass/Fail

  • Range: 0 (pass), 1 (fail), 9.91E+37

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat?"

FETCh:WCTFormat:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

To set up multi-measurements, see SETup:WCTFormat:COUNt[:SNUMber] .

Query

Range: 0 to 999

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat:ICOunt?"
! Returns the intermediate count of change of TFC multi-measurements.

FETCh:WCTFormat:INTegrity?

Function

Returns the Integrity Indicator for a change of TFC measurement result.

Query

Range: 0 to the number of available integrity indicators.

Resolution: 1

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat:INTegrity?"

FETCh:WCTFormat:STEP:DOWN:RELative:POWer<[:AVERage]|:ALL|:MAXimum|:MINimum|:SDEViation>?

Function

Queries a change of TFC measurement result and returns the following Step Down Relative Power (in dB) result(s):

  • [:AVERage] - average
  • :ALL - minimum, maximum, average, standard deviation
  • :MAXimum - maximum
  • :MINimum - minimum
  • :SDEViation - standard deviation

To set up multi-measurements, see SETup:WCTFormat:COUNt[:SNUMber] .

Query

Minimum, maximum, average

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Standard deviation

  • Range: 0.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat:STEP:DOWN:RELative:POWer?"
! Returns the Step Down Relative Power average result in dB.

OUTPUT 714;"FETCh:WCTFormat:STEP:DOWN:RELative:POWer:MAXimum?"
! Returns the Step Down Relative Power maximum result in dB.

FETCh:WCTFormat:STEP:DOWN:ERRor?

Function

Queries a change of TFC measurement result and returns the Step Down Error (in dB) result.

Query
  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat:STEP:DOWN:ERRor?"

FETCh:WCTFormat:STEP:DOWN:FAIL?

Function

Queries a change of TFC measurement result and returns the Step Down Pass/Fail result.

Query

 Range: 0 (pass), 1 (fail), 9.91E+37

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat:STEP:DOWN:FAIL?"

FETCh:WCTFormat:STEP:UP:RELative:POWer<[:AVERage]|:ALL|:MAXimum|:MINimum|:SDEViation>?

Function

Queries a change of TFC measurement result and returns the following Step Up Relative Power (in dB) result(s):

  • [:AVERage] - average
  • :ALL - minimum, maximum, average, standard deviation
  • :MAXimum - maximum
  • :MINimum - minimum
  • :SDEViation - standard deviation

To set up multi-measurements, see SETup:WCTFormat:COUNt[:SNUMber] .

Query

Minimum, maximum, average

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Standard deviation

  • Range: 0.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat:STEP:UP:RELative:POWer?"
! Returns the Step Up Relative Power average result in dB.

OUTPUT 714;"FETCh:WCTFormat:STEP:UP:RELative:POWer:MAXimum?"
! Returns the Step Up Relative Power maximum result in dB.

FETCh:WCTFormat:STEP:UP:ERRor?

Function

Queries a change of TFC measurement result and returns the Step Up Error (in dB) result.

Query
  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat:STEP:UP:ERRor?"

FETCh:WCTFormat:STEP:UP:FAIL?

Function

Queries a change of TFC measurement result and returns the Step Up Pass/Fail result.

Query

 Range: 0 (pass), 1 (fail), 9.91E+37

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"FETCh:WCTFormat:STEP:UP:FAIL?"


FETCh:WDPAnalysis

FETCh:WDPAnalysis

Last updated: January 16, 2009

GPIB Command Conventions

  • FETCh:WDPAnalysis<[:ALL]|:INTegrity|:STEPs>?

FETCh:WDPAnalysis<[:ALL]|:INTegrity|:STEPs>?

Function

Queries a dynamic power analysis measurement result.

The [:ALL] query returns an integrity indicator, the number of steps measured, and a comma-separated list of average power values for each step measured (in dBm).

You may also query the integrity indicator and number of steps measured using the INTegrity and STEPs mnemonics, respectively.

See Dynamic Power Analysis Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

Number of Steps

  • Range: 0 to 200
  • Resolution: 1

Average Power

  • Range: -99.99 to 99.99 dBm, 9.91E+37
  • Resolution: 0.01 dBm

Requirements

Test Application Revision: A.05 and above

Test Application Revision A.08 and Lab Application Revision C.03, increased Number of Steps range to 0 to 200 (previously it was 0 to 100)

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:WDPAnalysis?"
! Returns integrity, number of steps measured,
! average power for each step

OUTPUT 714;"FETCh:WDPAnalysis:STEPs?"
! Returns number of steps measured


FETCh:WEDPower

FETCh:WEDPower

Last updated: January 16, 2009

GPIB Command Conventions

  • FETCh:WEDPower<[:ALL]|:INTegrity|:STEPs>?

FETCh:WEDPower<[:ALL]|:INTegrity|:STEPs>?

Function

Queries an Extended Range Dynamic Power measurement result.

The [:ALL] query returns an integrity indicator, the number of steps measured, and a comma-separated list of average power values for each step measured (in dBm).

You may also query the integrity indicator and number of steps measured using the FETCh:WEDPower:INTegrity and FETCh:WEDPower:STEPs commands, respectively.

See Extended Range Dynamic Power Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

Number of Steps

  • Range: 1 to 85, 9.91E+37
  • Resolution: 1

Average Power

  • Range: -99 to 99 dBm, 9.91E+37
  • Resolution: 0.01 dBm

Requirements

Test Application Revision: A.10 and above

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"FETCh:WEDPower?"
! Returns integrity, number of steps measured,
! average power for each step

OUTPUT 714;"FETCh:WEDPower:STEPs?"
! Returns number of steps measured


FETCh:WILPower

FETCh:WILPower

Last updated: January 16, 2009

GPIB Command Conventions

  • FETCh:WILPower[:ALL]?
  • FETCh:WILPower:INTegrity?
  • FETCh:WILPower:NSLOts?
  • FETCh:WILPower:TRACe[:ABSolute]?
  • FETCh:WILPower:TRACe:RELative?
  • FETCh:WILPower:TRACe:REL10TPC?
  • FETCh:WILPower:TRACe:MASK?
  • FETCh:WILPower:SLOT?<sp><timeslot number>

FETCh:WILPower[:ALL]?

Function

Queries the Inner Loop Power measurements. Inner Loop Power Control consists of TPC (Transmit Power Control) commands that are sent to the UE on the downlink to control UE transmitter power on the uplink.

This measurement verifies that the UE derives the transmitter power control command (TPC_cmd) correctly and that the inner loop power control drives the UE to the correct level relative to the adjacent timeslot.

Inner Loop Power measurements are made over the period of time between 25 microsecond transient durations, which begin and end at the timeslot boundaries.

The test set returns absolute and relative-to-previous values for each timeslot and performs aggregate power control measurements over 10 TPC_cmd groups. See FETCh:WILPower:TRACe:REL10TPC?

Measurement results are returned in the following order (see Inner Loop Power Measurement Results ):

Query

Integrity (see Integrity Indicator )

Overall pass/fail

  • Range: 0 (pass), 1 (fail)

  • Resolution: 1

Worst case slot number (based on each adjacent timeslot measurements)

  • Range: 1 to 150, 9.91 E+37

  • Resolution: 1

Absolute power (based on worst case adjacent timeslot measurements)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Relative power (based on worst case adjacent timeslot measurements)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Worst case slot number (based on worst case Rel Pwr 10 TPC (dB) measurements)

  • Range: 1 to 150, 9.91 E+37

  • Resolution: 1

Absolute power (based on worst case Rel Pwr 10 TPC (dB) measurements)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Relative power (based on worst case Rel Pwr 10 TPC (dB) measurements)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower?"
! Returns all Inner Loop Power control measurement results.

FETCh:WILPower:INTegrity?

Function

Queries the measurement integrity indicator for the last measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower:INT?"
!Returns the Inner Loop Power control integrity indicator

FETCh:WILPower:NSLOts?

Function

 Returns the number of timeslots tested during the last Inner Loop Power control measurement. See Inner Loop Power Measurement Results .

Query

Resolution: 1

Range: 1 to 150, 9.91 E+37

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower:NSLOts?"
!Returns the number of slots tested.

FETCh:WILPower:TRACe[:ABSolute]?

Function

 Returns the absolute power levels of each timeslot measured during the last Inner Loop Power measurement. See Inner Loop Power Measurement Results .

Query

Absolute power (for up to 150 timeslots, see FETCh:WILPower:NSLOts? )

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower:TRACe?"
!Returns the absolute power levels of all timeslots.

FETCh:WILPower:TRACe:RELative?

Function

 Returns the power levels of each timeslot measured during the last Inner Loop Power measurement relative to the adjacent, previous timeslot. See Inner Loop Power Measurement Results .

Query

Relative power for up to 150 timeslots. See FETCh:WILPower:NSLOts? .

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower:TRACe:RELative?"
!Returns the relative power levels of all timeslots.

FETCh:WILPower:TRACe:REL10TPC?

Function

 For each timeslot measured during the last Inner Loop Power measurement, returns the aggregate power level of the previous 10 TPC_cmd groups, relative to the first timeslot in a set of 10 TPC_cmd groups. TPC_cmd groups can occur at a rate of one group per timeslot (Algorithm One) or one group per five-timeslots (Algorithm Two).

The first timeslot that has a 10 TPC measurement result will either be slot 10 (Algorithm One) or slot 50 (Algorithm Two). Timeslots are numbered beginning with zero.

Depending on which algorithm is used and the number of timeslots tested, the number of results returned by this command will vary. See Inner Loop Power Measurement Results .

Query

Relative power (for up to 150 timeslots). See FETCh:WILPower:NSLOts? .

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower:TRACe:REL10TPC?"
! returns the aggregate power level of 10 TPC_cmd groups for
! each timeslot relative to the first timeslot
! in a set of 10 TPC_cmd groups.

FETCh:WILPower:TRACe:MASK?

Function

Returns relative power measurement pass/fail indications for each timeslot based on previous, adjacent timeslot power. See Inner Loop Power Measurement Results .

Each pass/fail indication includes a result for both the adjacent and 10 TPC measurements. They are coded as follows:

  • 0 = Both measurements passed
  • 1 = Adjacent timeslot measurement failed
  • 2 = 10 TPC measurement failed
  • 3 = Both measurements failed

Query

Pass/Fail (for up to 150 timeslots). See FETCh:WILPower:NSLOts? .

  • Range: 0 to 3, 9.91 E+37

  • Resolution: 1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower:TRACe:MASK?"
!returns pass/fail indications for relative power measurements.

FETCh:WILPower:SLOT?<sp><timeslot number>

Function

 Returns the following measurement results in the following order for the timeslot number (timeslots are numbered beginning with 0) specified in the command (See Inner Loop Power Measurement Results ):

Query

Absolute power

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Relative power (based on the adjacent timeslot measurement)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Relative power (based on Rel Pwr 10 TPC (dB) measurements)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Pass/Fail

  • Range: 0 to 3 (see FETCh:WILPower:TRACe:MASK? for the return value definitions.)

  • Resolution: 1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WILPower:SLOT? 10"
!returns measurement results for timeslot 10.


FETCh:WIQTuning

FETCh:WIQTuning

Last updated: January 16, 2009

GPIB Command Conventions

  • FETCh:WIQTuning[:ALL]?
  • FETCh:WIQTuning:BETas?
  • FETCh:WIQTuning:BETas:HSPA?

  • FETCh:WIQTuning:EVM[:RMS]?
  • FETCh:WIQTuning:EVM:PEAK?

  • FETCh:WIQTuning:FERRor?
  • FETCh:WIQTuning:INTegrity?

  • FETCh:WIQTuning:IQGain?
  • FETCh:WIQTuning:IQPhase?

  • FETCh:WIQTuning:MERRor?
  • FETCh:WIQTuning:OOFFset?

  • FETCh:WIQTuning:PCERror[:ALL]?
  • FETCh:WIQTuning:PCERror:CHANnel?
  • FETCh:WIQTuning:PCERror:ERRor?

  • FETCh:WIQTuning:PERRor?
  • FETCh:WIQTuning:TERRor?
  • FETCh:WIQTuning:TRACe?

FETCh:WIQTuning[:ALL]?

Function

Queries the IQ tuning measurement.

Measurement results are returned in the following order: Integrity, EVM (RMS), EVM (peak), Frequency Error, Origin Offset, Phase Error, Magnitude Error, Time Error, Peak Code Domain Error, IQ Gain Imbalance, IQ Phase Imbalance.

Query

Integrity

  • Range: 0 to 23

  • Resolution: 1

EVM (RMS)

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.1

EVM (Peak)

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.1

Frequency Error

  • Range: -99.0 to 99.0 kHz, 9.91 E+37

  • Resolution: 0.1

Origin Offset

  • Range: -99.0 to 0.0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Magnitude Error

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.1

Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Peak Code Domain Error

  • Range: -99.0 to 0 dB, 9.91 E+37

  • Resolution: 0.1

IQ Gain Imbalance

  • Range: -99 to 99, 9.91 E+37

  • Resolution: 0.001 dB

IQ Phase Imbalance

  • Range: 0 to 180, 9.91 E+37

  • Resolution: 0.001 deg

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:ALL?"
! Queries the IQ tuning measurement results.

FETCh:WIQTuning:BETas?

Function

Queries Beta c , Beta d1 , Beta d2 , Beta d3 , Beta d4 , Beta d5 , Beta d6 , Beta hsacknak , Beta hscqi . These beta results are the same as those returned by the waveform quality measurement (see Betac, Betad1, Betad2, Betad3, Betad4, Betad5, Betad6, Betahsacknak, Betahscqi ).

Query

Range: 0 to 1

Resolution: 0.001

Requirements

Test Application Revision: A.03 and above.

Test Application Revision A.09, with the required feature license, added Beta hsacknak and Beta hscqi .

Lab Application Revision: A.01 and above.

Lab Application Revision C.04 and D.00, added Beta hsacknak and Beta hscqi .

Programming Example

OUTPUT 714;"FETCH:WIQTuning:BETas?"

FETCh:WIQTuning:BETas:HSPA?

Function

Queries Betac, Betad1, Betad2, Betad3, Betad4, Betad5, Betad6, Betahsacknak, Betahscqi, Betaec, Betaed1, Betaed2, Betaed3, Betaed4.

Query

Range: 0 to 1

Resolution: 0.001

Requirements

Lab Application Revision F.00 and above.

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"FETCh:WIQTuning:BETas:HSPA?"

FETCh:WIQTuning:EVM[:RMS]?

Function

Queries the rms IQ tuning measurement EVM.

Query

Range: 0 to 99.0%, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WIQTuning:EVM?" !Returns rms EVM.

FETCh:WIQTuning:EVM:PEAK?

Function

Queries the peak IQ tuning measurement EVM.

Query

Range: 0 to 99.0%, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WIQTuning:EVM:PEAK?" !Returns peak EVM.

FETCh:WIQTuning:FERRor?

Function

Queries the IQ tuning measurement frequency error.

Query

Range: -99.0 to 99.0 kHz, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:FERRor?" !Returns frequency error.

FETCh:WIQTuning:INTegrity?

Function

Queries the measurement integrity indicator for the last IQ tuning measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:INTegrity?"
!Queries the integrity indicator for the IQ tuning measurement results.

FETCh:WIQTuning:IQGain?

Function

Queries the IQ tuning measurement IQ modulator gain imbalance.

Query

Range: -99.0 to +99.0 dB

Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:IQGain?" !Queries the IQ tuning measurment IQ gain imbalance.

FETCh:WIQTuning:IQPhase?

Function

Queries the IQ tuning measurement IQ modulator phase imbalance.

Query

Range: -180.0 to +180.0 deg

Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:IQGain?" !Queries the IQ tuning measurment IQ gain imbalance.

FETCh:WIQTuning:MERRor?

Function

Queries the IQ tuning measurement magnitude error.

Query

Range: 0 to 99.0%

Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:MERRor?" !Queries magnitude error.

FETCh:WIQTuning:OOFFset?

Function

Queries the IQ tuning measurement origin offset.

Query

Range:-99.0 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:OOFFset?" !Returns origin offset.

FETCh:WIQTuning:PCERror[:ALL]?

Function

Queries the IQ tuning measurement peak code domain error. There are four numbers returned for each measurement. The first three numbers describe the channel where the peak error result was measured (OVSF channelization code, spreading factor, I/Q channel type), and the last number is the peak error.

Results are returned in the following order: OVFS channelization code, spreading factor, I/Q channel type, and peak code domain error.

Query

Channelization Code

  • Range: 0 to 255, 9.91 E+37

Spread Factor

  • Range: 4 to 256, 9.91 E+37

I/Q Channel Type

  • Range: 0 = I, 1= Q, 9.91 E+37

Peak Code Domain Error

  • Range: -99.0 to 0 dB, 9.91 E+37
  • Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:PCERror?"
!Returns Channelization code, spread factor, I/Q channel type, and peak error.

FETCh:WIQTuning:PCERror:CHANnel?

Function

Returns the orthogonal variable spreading factor (OVSF) code number (channelization code) where the peak code domain error was detected.

Query

Range: 0 to 255, 9.91 E+37

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:PCERror:CHANnel?" !Returns channel where peak error was detected.

FETCh:WIQTuning:PCERror:ERRor?

Function

Queries the IQ tuning measurement peak code domain error.

Query

  • Range: -99.0 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:PCERror:ERRor?"
!Returns peak code domain error.

FETCh:WIQTuning:PERRor?

Function

Queries the IQ tuning measurement phase error.

Query

  • Range: 0 to 180.0 degrees, 9.91 E+37

  • Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:PERRor?"
!Returns IQ tuning measurement phase error.

FETCh:WIQTuning:TERRor?

Function

Queries the IQ tuning measurement timing error.

Query

Range: -99.99 to 99.99 chips, 9.91 E+37

Resolution: 0.01 chips

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:TERRor?" !Returns IQ tuning measurement timing error.

FETCh:WIQTuning:TRACe?

Function

Queries the IQ tuning measurement EVM for each chip up to 2560 chips.

IQ constellation data can be derived from this measurement result.

Query

Range: 0 to 99.0%

Resolution: 0.1

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WIQTuning:TRACe?" !Queries the IQ tuning measurment EVM for 2560 chips.


FETCh:WOBWidth

FETCh:WOBWidth

Last updated: January 16, 2009

GPIB Command Conventions

  • FETCh:WOBWidth[:ALL]?

  • FETCh:WOBWidth:ICOunt?

  • FETCh:WOBWidth:INTegrity?

  • FETCh:WOBWidth:BANDwidth[:AVERage]?
  • FETCh:WOBWidth:BANDwidth:ALL?
  • FETCh:WOBWidth:BANDwidth:MAXimum?
  • FETCh:WOBWidth:BANDwidth:MINimum?
  • FETCh:WOBWidth:BANDwidth:SDEViation?

  • FETCh:WOBWidth:FREQuency:LOWer?
  • FETCh:WOBWidth:FREQuency:UPPer?

FETCh:WOBWidth[:ALL]?

Function

Queries an occupied bandwidth measurement result.

This query returns a comma-separated list of values in the following order: integrity indicator, average occupied bandwidth, lower frequency, upper frequency.

These results can also be queried individually using the FETCh:WOBWidth:INTegrity? , FETCh:WOBWidth:BANDwidth[:AVERage]? , FETCh:WOBWidth:FREQuency:LOWer? and FETCh:WOBWidth:FREQuency:UPPer? commands.

If the multi-measurement state is on, the result represents the average of a number of occupied bandwidth measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WOBWidth:COUNt[:SNUMber] .

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WOBWidth?"
! Returns integrity, occupied bandwidth, lower frequency, upper frequency.

FETCh:WOBWidth:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

To set up multi-measurements, see SETup:WOBWidth:COUNt[:SNUMber] .

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WOBWIDTH:ICOUNT?"
!Returns the intermediate count of occupied bandwidth multi-measurements.

FETCh:WOBWidth:INTegrity?

Function

Queries the measurement integrity indicator for the last occupied bandwidth measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WOBWIDTH:INTegrity?"
!Queries the integrity indicator for the channel occupied bandwidth results.

FETCh:WOBWidth:BANDwidth[:AVERage]?

Function

Queries the average of the results of several occupied bandwidth measurements. To set the number of measurement to average, use the command SETup:WOBWidth:COUNt[:SNUMber] .

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WOBWIDTH:BANDWIDTH:AVERAGE?"
!Queries the average power for the occupied bandwidth results.

FETCh:WOBWidth:BANDwidth:ALL?

Function

Queries the statistical measurement results for several occupied bandwidth measurements.

To set the number of measurements to gather statistics for, use the command SETup:WOBWidth:COUNt[:SNUMber] .

Results are returned in the following order: minimum, maximum, average, and standard deviation occupied bandwidth.

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WOBWIDTH:BANDWIDTH:ALL?"
!Queries the statistical measurement results for occupied bandwidth measurement.

FETCh:WOBWidth:BANDwidth:MAXimum?

Function

Queries the maximum bandwidth of several occupied bandwidth measurements. To set the number of measurement to average, use the command SETup:WOBWidth:COUNt[:SNUMber] .

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WOBWIDTH:BANDWIDTH:MAXIMUM?"
!Queries the maximum occupied bandwidth result for statistical measurements.

FETCh:WOBWidth:BANDwidth:MINimum?

Function

 Queries the minimum bandwidth of several occupied bandwidth measurements. To set the number of measurement to compare, use the command SETup:WOBWidth:COUNt[:SNUMber] .

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WOBWIDTH:BANDWIDTH:MINIMUM?"
!Queries the minimum occupied bandwidth result for statistical measurements.

FETCh:WOBWidth:BANDwidth:SDEViation?

Function

Queries the standard deviation of several occupied bandwidth measurements. To set the number of measurement to compare, use the command SETup:WOBWidth:COUNt[:SNUMber] .

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WOBWIDTH:BANDWIDTH:SDEVIATION?"
!Queries the standard deviation of power for the occupied bandwidth measurements.

FETCh:WOBWidth:FREQuency:LOWer?

Function

Queries the lower frequency result of the occupied bandwidth measurement.

This result can also be queried using the FETCh:WOBWidth[:ALL]? command.

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WOBWidth:FREQuency:LOWer?"
! Queries the lower frequency result.

FETCh:WOBWidth:FREQuency:UPPer?

Function

Queries the upper frequency result of the occupied bandwidth measurement.

This result can also be queried using the FETCh:WOBWidth[:ALL]? command.

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WOBWidth:FREQuency:UPPer?"
!Queries the upper frequency result.


FETCh:WOOPower

FETCh:WOOPower

Last updated: January 16, 2009

GPIB Command Conventions

  • FETCh:WOOPower[:ALL]?

FETCh:WOOPower[:ALL]?

Function

Queries the PRACH transmit on/off power measurement results. See PRACH Transmit On/Off Power Measurement Results .

[:ALL] returns measurement results in the following order: Integrity, Pre Burst Off Power level, Pre Burst Off Power pass/fail, Burst On Power, Open Loop Power Error value, Open Loop Power Error pass/fail, Post Burst Off Power level, Post Burst Off Power pass/fail.

Instead of returning [:ALL] results, you may query the result for any particular measurement result individually using the appropriate keywords (for example, FETCh:WOOPower:OFF:PRE[:BURSt]?).

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Query

Integrity: see Integrity Indicator

Pre Burst Off Power level

  • Range: -99.99 to 00.00 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Pre Burst Off Power pass/fail

  • Range: 0 (pass), 1 (fail), 9.91 E+37

Burst On Power

  • Range: -99.99 to 99.99 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Open Loop Power Error value

  • Range: -99.99 to +99.99 dB, 9.91E+37
  • Resolution: 0.01 dB

Open Loop Power Error pass/fail

  • Range: 0 (pass), 1 (fail), 9.91 E+37

Post Burst Off Power level

  • Range: -99.99 to 00.00 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Post Burst Off Power pass/fail

  • Range: 0 (pass), 1 (fail), 9.91 E+37

Programming Example

OUTPUT 714;"FETCh:WOOPower?"
! returns Integrity, Pre Burst Off Power level, Pre Burst Off Power pass/fail,
! Burst On Power, Open Loop Power Error value, Open Loop Power Error pass/fail,
! Post Burst Off Power level, Post Burst Off Power pass/fail

OUTPUT 714;"FETCh:WOOPower:INTegrity?"
! returns Integrity

OUTPUT 714;"FETCh:WOOPower:OFF:PRE?"
! returns Pre Burst Off Power level


FETCh:WPDiscon

FETCh:WPDiscon

Last updated: January 16, 2009

GPIB Command Conventions

  • FETCh:WPDiscon[:ALL]?
  • FETCh:WPDiscon:EVM:PEAK:SLOT?<sp><slot num>
  • FETCh:WPDiscon:EVM:PEAK:STEP?<sp><step num>
  • FETCh:WPDiscon:EVM:PEAK:WORSt?
  • FETCh:WPDiscon:INTegrity?
  • FETCh:WPDiscon:SLOT?<sp><slot num>
  • FETCh:WPDiscon:STEP?<sp><step num>
  • FETCh:WPDiscon:TRACe?<sp>DISC|PHASE|POW|EVM|PERR|FERR|MERR|TERR|OOFF|EVMPK

FETCh:WPDiscon[:ALL]?

Function

Queries a phase discontinuity measurement result and returns the following comma separated values: Integrity Indicator, Number of Steps Measured, Worst Case Phase Discontinuity Step Number, Worst Case Phase Discontinuity in degrees, Worst Case rms EVM Step Number, Worst Case rms EVM in % rms.

See Phase Discontinuity Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

Number of Steps Measured

  • Range: 2 to 91, 9.91E+37
  • Resolution: 1

Worst Case Phase Discontinuity Step Number

  • Range: 0 to 90, 9.91E+37
  • Resolution: 1

Worst Case Phase Discontinuity

  • Range: -180.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Worst Case rms EVM Step Number

  • Range: 0 to 90, 9.91E+37
  • Resolution: 1

Worst Case rms EVM

  • Range: 0.0 to 99.0% rms, 9.91E+37
  • Resolution: 0.1% rms

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:WPDiscon?"
! Returns Integrity Indicator, Number of Steps Measured,
! Worst Case Phase Discontinuity Step Number, Worst Case Phase Discontinuity in degrees,
! Worst Case rms EVM Step Number, Worst Case rms EVM in % rms

FETCh:WPDiscon:EVM:PEAK:SLOT?<sp><slot num>

Function

THIS COMMAND IS OBSOLETE. Please use FETCh:WPDiscon:EVM:PEAK:STEP?<sp><step num> .

Queries a phase discontinuity measurement result and returns the following comma separated values for the slot specified by <slot num>: Integrity Indicator, peak EVM in % peak.

<Slot num> range is 0 to 90.

See Phase Discontinuity Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

Peak EVM

  • Range: 0.0 to 99.0% peak, 9.91E+37
  • Resolution: 0.1% peak

Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"FETCh:WPDiscon:EVM:PEAK:SLOT? 3"
! Returns the following results for slot 3 (the fourth slot measured):
! Integrity Indicator, Peak EVM in % peak.

FETCh:WPDiscon:EVM:PEAK:STEP?<sp><step num>

Function

Queries a phase discontinuity measurement result and returns the following comma separated values for the step specified by <step num>: Integrity Indicator, peak EVM in % peak.

<step num> range is 0 to 90.

See Phase Discontinuity Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

Peak EVM

  • Range: 0.0 to 99.0% peak, 9.91E+37
  • Resolution: 0.1% peak

Requirements

Test Application Revision: A.10 and above

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"FETCh:WPDiscon:EVM:PEAK:STEP? 3"
! Returns the following results for step 3 (the fourth step measured):
! Integrity Indicator, Peak EVM in % peak.

FETCh:WPDiscon:EVM:PEAK:WORSt?

Function

Queries a phase discontinuity measurement result and returns the following comma separated values: Integrity Indicator, Worst Case Peak EVM Step Number, Worst Case Peak EVM in % peak.

See Phase Discontinuity Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

Worst Case Peak EVM Step Number

  • Range: 0 to 90, 9.91E+37
  • Resolution: 1

Worst Case Peak EVM

  • Range: 0.0 to 99.0% peak, 9.91E+37
  • Resolution: 0.1% peak

Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"FETCh:WPDiscon:EVM:PEAK:WORSt?"
! Returns Integrity Indicator,
! Worst Case Peak EVM Step Number, Worst Case Peak EVM in % peak.

FETCh:WPDiscon:INTegrity?

Function

Returns the Integrity Indicator for a phase discontinuity measurement result.

See Phase Discontinuity Measurement Description .

Query

 Range: See Integrity Indicator .

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:WPDiscon:INTegrity?"

FETCh:WPDiscon:SLOT?<sp><slot num>

Function

THIS COMMAND IS OBSOLETE. Please use the FETCh:WPDiscon:STEP?<sp><step num> command.

Queries a phase discontinuity measurement result and returns the following comma separated values for the slot specified by <slot num>: Integrity Indicator, Phase Discontinuity in degrees, Phase in degrees, Power in dBm, rms EVM in % rms, Phase Error in degrees, Frequency Error in Hz, Magnitude Error in %, Timing Error in chips, Origin Offset in dB.

<Slot num> range is 0 to 90.

See Phase Discontinuity Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

Phase Discontinuity

  • Range: -180.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Phase

  • Range: -180.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Power

  • Range: -99.0 to 99.0 dBm, 9.91E+37
  • Resolution: 0.1 dBm

rms EVM

  • Range: 0.0 to 99.0% rms, 9.91E+37
  • Resolution: 0.1% rms

Phase Error

  • Range: 0.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Frequency Error

  • Range: -99.0000 to +99.0000 kHz, 9.91E+37
  • Resolution: 0.1 Hz

Magnitude Error

  • Range: 0.0 to 99.0%, 9.91E+37
  • Resolution: 0.1%

Timing Error

  • Range: -99.00 to 99.00 chips, 9.91E+37
  • Resolution: 0.01 chips

Origin Offset

  • Range: -99.0 to 0.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:WPDiscon:SLOT? 3"
! Returns the following results for slot 3 (the fourth slot measured): Integrity Indicator,
Phase Discontinuity in degrees, Phase in degrees, Power in dBm, rms EVM in % rms,
Phase Error in degrees, Frequency Error in Hz, Magnitude Error in %,
Timing Error in chips, Origin Offset in dB

FETCh:WPDiscon:STEP?<sp><step num>

Function

Queries a phase discontinuity measurement result and returns the following comma separated values for the step specified by <step num>: Integrity Indicator, Phase Discontinuity in degrees, Phase in degrees, Power in dBm, rms EVM in % rms, Phase Error in degrees, Frequency Error in Hz, Magnitude Error in %, Timing Error in chips, Origin Offset in dB.

<step num> range is 0 to 90.

See Phase Discontinuity Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

Phase Discontinuity

  • Range: -180.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Phase

  • Range: -180.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Power

  • Range: -99.0 to 99.0 dBm, 9.91E+37
  • Resolution: 0.1 dBm

rms EVM

  • Range: 0.0 to 99.0% rms, 9.91E+37
  • Resolution: 0.1% rms

Phase Error

  • Range: 0.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Frequency Error

  • Range: -99.0000 to +99.0000 kHz, 9.91E+37
  • Resolution: 0.1 Hz

Magnitude Error

  • Range: 0.0 to 99.0%, 9.91E+37
  • Resolution: 0.1%

Timing Error

  • Range: -99.00 to 99.00 chips, 9.91E+37
  • Resolution: 0.01 chips

Origin Offset

  • Range: -99.0 to 0.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Requirements

Test Application Revision: A.10 and above

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"FETCh:WPDiscon:STEP? 3"
! Returns the following results for step 3 (the fourth step measured): Integrity Indicator,
Phase Discontinuity in degrees, Phase in degrees, Power in dBm, rms EVM in % rms,
Phase Error in degrees, Frequency Error in Hz, Magnitude Error in %,
Timing Error in chips, Origin Offset in dB

FETCh:WPDiscon:TRACe?<sp>DISC|PHASE|POW|EVM|PERR|FERR|MERR|TERR|OOFF|EVMPK

Function

Queries a phase discontinuity result and returns a comma separated list of values (one for each step measured) for the measurement result indicated by appending the following to the query:

  • DISC (phase discontinuity)
  • PHASE (phase)
  • POW (power)
  • EVM (rms EVM)
  • PERR (phase error)
  • FERR (frequency error)
  • MERR (magnitude error)
  • TERR (timing error)
  • OOFF (origin offset)
  • EVMPK (peak EVM)

See Phase Discontinuity Measurement Results .

The Number of Steps Measured can be determined by the FETCh:WPDiscon[:ALL]? command.

Query

 Range/Resolution: See FETCh:WPDiscon:STEP?<sp><step num> for the range and resolution of the various measurement results.

Requirements

Test Application Revision: A.05 and above

Test Application Revision A.09, added EVMPK

Lab Application Revision: B.01 and above

Lab Application Revision C.04 and D.00, added EVMPK

Programming Example

OUTPUT 714;"FETCh:WPDiscon:TRACe? DISC"
! Returns comma separated list of phase discontinuity results
! for each step measured.

OUTPUT 714; "FETCh:WPDiscon:TRACe? EVM"
! Returns comma separated list of rms EVM results for each step measured.


FETCh:WPESquality

FETCh:WPESquality

Last updated: October 26, 2010

GPIB Command Conventions

  • FETCh:WPESquality[:ALL]?
  • FETCh:WPESquality:AMR:RAB?
  • FETCh:WPESquality:HEADroom:DOWNlink?
  • FETCh:WPESquality:HEADroom:UPLink?
  • FETCh:WPESquality:INTegrity?
  • FETCh:WPESquality:SCORe:DOWNlink?
  • FETCh:WPESquality:SCORe:UPLink?

FETCh:WPESquality[:ALL]?

Function

 This query returns an integrity indicator followed by a comma separated list containing the following results: Uplink PESQ Score, Downlink PESQ Score, PESQ Uplink Headroom, PESQ Downlink Headroom. The query returns NAN (9.91E+37) for Perceptual Evaluation of Speech Quality measurement that is turned off. See Perceptual Evaluation of Speech Quality (PESQ) Measurement Description .

Query

Integrity

  • Range: 0 to 31

  • Resolution: 1

Uplink PESQ Score

  • Range: -0.5 to 4.5, 9.91 E+37

  • Resolution: 0.01

Downlink PESQ Score

  • Range: -0.5 to 4.5, 9.91 E+37

  • Resolution: 0.01

PESQ Uplink Headroom

  • Range: 0.0 to 100.0 dB, 9.91 E+37

  • Resolution: 0.1 dB

PESQ Downlink Headroom

  • Range: 0.0 to 100.0 dB, 9.91 E+37

  • Resolution: 0.1 dB

Requirements

Lab Application Revision: G.00 and above
Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"FETCh:WPESquality:ALL?"

FETCh:WPESquality:AMR:RAB?

Function

Queries the current AMR Radio Access Bearer .

Query

Range:

  • AMR1020 - 10.2k Voice
  • AMR1220 - 12.2k Voice
  • AMR12K - 12.2k Voice
  • AMR475 - 4.75k Voice
  • AMR515 - 5.15k Voice
  • AMR590 - 5.9k Voice
  • AMR670 - 6.7k Voice
  • AMR740 - 7.4k Voice
  • AMR795 - 7.95k Voice
  • AMRSelect - 12.2k Voice, 7.95k Voice, 5.9k Voice, 4.75k Voice
  • WAMR1 - WB 12.65k Voice, 8.85k Voice, 6.6k Voice
  • WAMR2 - WB 15.85k Voice, 2.65k Voice, 8.85k Voice, 6.6k Voice
  • WAMR3 - WB 23.85k Voice, 12.65k Voice, 8.85k Voice, 6.6k Voice
  • WAMR4 - WB AMR SRB5, 12.65k Voice, 8.85k Voice, 6.6k Voice
  • AMR1220P - SRB5 12.2k Voice, 7.95k Voice, 5.9k Voice, 4.75k Voice
Requirements

Lab Application Revision: G.00 and above
Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"FETCh:WPESquality:AMR:RAB?"
! Queries the AMR voice radio access bearer.

FETCh:WPESquality:HEADroom:DOWNlink?

Function

Queries the PESQ Downlink Headroom. See PESQ Measurement Results .

Query

Range: 0.0 to 100.0 dB, 9.91 E+37

Resolution: 0.1 dB

Requirements

Lab Application Revision: G.00 and above
Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"FETCh:WPESquality:HEADroom:DOWNlink?"

FETCh:WPESquality:HEADroom:UPLink?

Function

Queries the PESQ Uplink Headroom. See PESQ Measurement Results .

Query

Range: 0.0 to 100.0 dB, 9.91 E+37

Resolution: 0.1 dB

Requirements

Lab Application Revision: G.00 and above
Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"FETCh:WPESquality:HEADroom:UPLink?"

FETCh:WPESquality:INTegrity?

Function

Queries the measurement integrity indicator for the last Perceptual Evaluation of Speech Quality measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 to 31

Resolution: 1

Requirements

Lab Application Revision: G.00 and above
Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"FETCh:WPESquality:INTegrity?"

FETCh:WPESquality:SCORe:DOWNlink?

Function

Queries the Downlink PESQ Score. See PESQ Measurement Results .

Query

Range: -0.5 to 4.5, 9.91 E+37

Resolution: 0.01

Requirements

Lab Application Revision: G.00 and above
Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"FETCh:WPESquality:SCORe:DOWNlink?"

FETCh:WPESquality:SCORe:UPLink?

Function

Queries the Uplink PESQ Score. See PESQ Measurement Results .

Query

Range: -0.5 to 4.5, 9.91 E+37

Resolution: 0.01

Requirements

Lab Application Revision: G.00 and above
Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"FETCh:PESQuality:SCORe:UPLink?"


FETCh:WPPAnalysis

FETCh:WPPAnalysis

Last updated: January 16, 2009

This section is applicable to the lab application only.

GPIB Command Conventions

  • FETCh:WPPAnalysis<[:ALL]|:INTegrity|:EVM[:RMS]|:EVM:PEAK|:FERRor|:OOFFset|:PERRor|:MERRor|:TERRor|:IQGain|:IQPHase|:SIGNAture>?
  • FETCh:WWPAnalysis:SLOT:USED?
  • FETCh:WPPAnalysis:TRACe<:EVM|:PHASe|:IQ|:POWer>?

FETCh:WPPAnalysis<[:ALL]|:INTegrity|:EVM[:RMS]|:EVM:PEAK|:FERRor|:OOFFset|:PERRor|:MERRor|:TERRor|:IQGain|:IQPHase|:SIGNAture>?

Function

The [:ALL] mnemonic queries a PRACH preamble analysis measurement result and returns the following comma separated values: Integrity Indicator, EVM (rms) in % rms, EVM (peak) in %, Frequency Error in Hz, Origin Offset in dB, Phase Error (rms) in degrees, Magnitude Error in %, Timing Error in chips, IQ Gain Imbalance in dB, IQ Phase Imbalance in degrees, Signature.

You may also query the individual measurement results using the appropriate mnemonic.

See PRACH Preamble Analysis Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

EVM (rms)

  • Range: 0.0 to 100.0% rms, 9.91E+37
  • Resolution: 0.1% rms

EVM (peak)

  • Range: 0.0 to 100.0%, 9.91E+37
  • Resolution: 0.1%

Frequency Error

  • Range: -9.999 kHz to +9.999 kHz, 9.91E+37
  • Resolution: 0.1 Hz

Origin Offset

  • Range: -100.0 to 0.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Phase Error

  • Range: -180.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Magnitude Error

  • Range: 0.0 to 100.0%, 9.91E+37
  • Resolution: 0.1%

Timing Error

  • Range: -383.62 to +383.62 chips, 9.91E+37
  • Resolution: 0.01 chips

IQ Gain Imbalance

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

IQ Phase Imbalance

  • Range: -180.0 to 180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Signature

  • Range: 0 to 15, 9.91E+37
  • Resolution: 1

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:WPPAnalysis?"
! Returns Integrity Indicator, EVM (rms) in % rms, EVM (peak) in %,
! Frequency Error in Hz, Origin Offset in dB, Phase Error (rms) in degrees,
! Magnitude Error in %, Timing Error in chips, IQ Gain Imbalance in dB,
! IQ Phase Imbalance in degrees, Signature

OUTPUT 714;"FETCh:WPPAnalysis:EVM?"
! Returns EVM (rms) in % rms.

FETCh:WWPAnalysis:SLOT:USED?

Function

Queries the access slot used for the PRACH preamble analysis measurement. This result is only available when SETup:WPPAnalysis:TRIGger:SOURce is set to PROTocol.

Query

Range: 0 to 14

Requirements

Lab Application Revision F.00 and above.

Programming Example

OUTPUT 714;"FETCH:WWPAnalysis:SLOT:USED?"
!Returns the access slot used for the PRACH preamble analysis measurement.

FETCh:WPPAnalysis:TRACe<:EVM|:PHASe|:IQ|:POWer>?

Function

Queries a PRACH preamble analysis result and returns: number of chips measured, relative chip location of the first data point, and a variable length list of measured data for the measurement result indicated by appending:

  • EVM (EVM in %)
  • PHASe (Relative Phase in degrees)
  • IQ (IQ Constellation)
  • POWer (Relative Power in dB)
to the query.

For EVM, relative phase and relative power, one data point is returned for each chip measured (maximum is 4096 data points for EVM and relative phase, 4296 data points for relative power). For IQ constellation, two data points are returned for each chip measured (maximum is 2 x 4096 data points).

See PRACH Preamble Analysis Measurement Results .

Query

EVM

  • Range: 0.0 to 100.0% rms, 9.91E+37
  • Resolution: 0.1% rms

Relative Phase

  • Range: -180.0 to 180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

IQ Constellation

  • Range: -1.0000 to 1.0000, 9.91E+37
  • Resolution: 0.0001

Relative Power

  • Range: -100.0 to 0.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:WPPAnalysis:TRACe:EVM?"
! Returns number of chips measured, relative chip location of the first data point,
! and a maximum of 4096 EVM values (one for each chip measured).


FETCh:WSEMask

FETCh:WSEMask

Last updated: November 11, 2009

GPIB Command Conventions

  • FETCh:WSEMask:[:ALL]?
  • FETCh:WSEMask:ADDitional?
  • FETCh:WSEMask:BAND[:ALL]?
  • FETCh:WSEMask:BAND:ADDitional?
  • FETCh:WSEMask:BAND:ADDitional:LOWer[1]?
  • FETCh:WSEMask:BAND:ADDitional:UPPer[1]?
  • FETCh:WSEMask:BAND:LOWer[1]?
  • FETCh:WSEMask:BAND:UPPer[1]?
  • FETCh:WSEMask:FAIL?
  • FETCh:WSEMask:ICOunt?
  • FETCh:WSEMask:ICPower?
  • FETCh:WSEMask:INTegrity?
  • FETCh:WSEMask:RANGe[:ALL]?
  • FETCh:WSEMask:RANGe:ADDitional?
  • FETCh:WSEMask:RANGe:ADDitional:RANGe[1]?
  • FETCh:WSEMask:RANGe:RANGe[1]?

FETCh:WSEMask:[:ALL]?

Function

Returns the spectrum emissions mask measurement results.

Measurement results are returned in the following order: integrity, overall pass/fail (0 = pass, 1 = fail, 9.91 E+37 = no result available), in-channel power (in dBm/3.84 MHz), and pass/fail results for frequency ranges 1, 2, 3, and 4.

In-channel power is returned in dBm/3.84 MHz.

The four frequency ranges for this measurement are as follows:

  • Range 1: +/- 2.5 to 3.5 MHz
  • Range 2: +/- 3.5 to 7.5 MHz
  • Range 3: +/- 7.5 to 8.5 MHz
  • Range 4: +/- 8.5 to 12.5 MHz

If the multi-measurement state is on, the result represents the average of a number of spectrum emission measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WSEMask:COUNt[:SNUMber] .

Query

Range: -99.00 to +99.00 dBc

Resolution: 0.01

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:ALL?"

FETCh:WSEMask:ADDitional?

Function

Returns the spectrum emissions mask measurement results for the additional requirements.

Measurement results are returned in the following order: integrity, overall pass/fail (0 = pass, 1 = fail, 9.91 E+37 = no result available), in-channel power (in dBm/3.84 MHz), and pass/fail results for the two additional frequency ranges in the order of smallest frequency offset (nearest to the channel) to the greatest.

In-channel power is returned in dBm/3.84 MHz.

The two additional frequency ranges for this measurement are dependant on the band as follows:

  • Bands II, IV, X:
    • Range 1: +/- 2.5 to 3.5 MHz
    • Range 2: +/- 3.5 to 12.5 MHz
  • Band V:
    • Range 1: +/- 2.5 to 3.5 MHz
    • Range 2: +/- 3.5 to 12.5 MHz
  • Bands XII, XIII, XIV:
    • Range 1: +/- 2.5 to 2.6 MHz
    • Range 2: +/- 2.6 to 12.5 MHz

If the multi-measurement state is on, the result represents the average of a number of spectrum emission measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WSEMask:COUNt[:SNUMber] .

Query

Range: -99.00 to +99.00 dBc

Resolution: 0.01

Requirements

Test Application Revision: A.14 and above.

Programming Example

OUTPUT 714;"FETCh:WSEMask:ADDitional?"

FETCh:WSEMask:BAND[:ALL]?

Function

Returns the power level vectors relative to in-channel power for all of the bands. Results are in dBc. The total number of results returned is 266.

Query

Range: -99.00 to +99.00 dBc

Resolution: 0.01

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:BAND:ALL?"

FETCh:WSEMask:BAND:ADDitional?

Function

Returns the the absolute power level vectors for all of the addtional bands ( Lower2, Lower1,Upper1, Upper2). Results are in dBm. The total number of results returned is 590.

Query

Range: -99.00 to +99.00 dBm

Resolution: 0.01

Requirements

Test Application Revision: A.14 and above.

Programming Example

OUTPUT 714;"FETCh:WSEMask:BAND:ADDitional?"

FETCh:WSEMask:BAND:ADDitional:LOWer[1]?

Function

Returns the absolute power level vectors relative to in-channel power for the specified band. Results are in dBm. Result vector size is as follows:

  • LOWer2: -(12.5 MHz + 0.5 x measurement bandwidth for additional range 2) to -(2.6 or 3.5 MHz + 0.5 x measurement bandwidth for additional range 2) , (step size is 50 kHz when measurement bandwidth is set to 100 kHz and 250 KHz when measurement bandwidth is set to 1 MHz, BW 100 kHz or 1 MHz) 1:196
  • LOWer[1]: --(2.6 MHz or 3.5 MHz - 0.015MHz) to -2.515 MHz (step size 10 kHz, BW 30 kHz) 1:98

Query

Range: -99.00 to +99.00 dBm

Resolution: 0.01

Requirements

Test Application Revision: A.14 and above.

Programming Example

OUTPUT 714;"FETCh:WSEMask:BAND:ADDitional:LOWer2?"

FETCh:WSEMask:BAND:ADDitional:UPPer[1]?

Function

Returns the absolute power level vectors relative to in-channel power for the specified band. Results are in dBm. Result vector size is as follows:

  • UPPer[1]: 2.515 to (2.6MHz or 3.5MHz - 0.015MHz), (step size 10 kHz, BW 30 kHz) 1:98
  • UPPer2: (2.6 or 3.5 MHz + 0.5 x measurement bandwidth for additional range 2) to -(2.6 or 3.5MHz + 0.5 x measurement bandwidth for additional range 2), (step size is 50 kHz when measurement bandwidth is set to 100 kHz and 250 KHz when measurement bandwidth is set to 1 MHz, BW 100 kHz or 1 MHz) 1:196

Query

Range: -99.00 to +99.00 dBm

Resolution: 0.01

Requirements

Test Application Revision: A.14 and above.

Programming Example

OUTPUT 714;"FETCh:WSEMask:BAND:ADDitional:UPPer?"

FETCh:WSEMask:BAND:LOWer[1]?

Function

Returns the power level vectors relative to in-channel power for the specified band. Results are in dBc. Result vector size is as follows:

  • LOWer 4: -8.500 to -12.000 MHz (step size 250 kHz, BW 1 MHz) 1:15
  • LOWer 3: -7.500 to -8.500 MHz (step size 250 kHz, BW 1 MHz) 1:5
  • LOWer 2: -4.000 to -7.500 MHz (step size 250 kHz, BW 1 MHz) 1:15
  • LOWer[1]: -2.515 to -3.485 MHz (step size 10 kHz, BW 30 kHz) 1:98

Query

Range: -99.00 to +99.00 dBc

Resolution: 0.01

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:BAND:LOW2?"

FETCh:WSEMask:BAND:UPPer[1]?

Function

Returns the power level vectors relative to in-channel power for the specified band. Results are in dBc. Result vector size is as follows:

  • UPPer[1]: 2.515 to 3.485 MHz (step size 10 kHz, BW 30 kHz) 1:98
  • UPPer 2: 4.000 to 7.500 MHz (step size 250 kHz, BW 1 MHz) 1:15
  • UPPer 3: 7.500 to 8.500 MHz (step size 250 kHz, BW 1 MHz) 1:5
  • UPPer 4: 8.500 to 12.000 MHz (step size 250 kHz, BW 1 MHz) 1:15

Query

Range: -99.00 to +99.00 dBc

Resolution: 0.01

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:BAND:UPP?"
! Returns power level in the UPPer1 band.

FETCh:WSEMask:FAIL?

Function

Queries the measurement integrity and the overall pass/fail result for the spectrum emissions mask measurement.

Measurement results are returned in the following order: integrity, overall pass/fail (0 = Pass, 1 = Fail)

Query

Range: 0|1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:FAIL?"

FETCh:WSEMask:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

To set up multi-measurements, see SETup:WSEMask:COUNt[:SNUMber] .

Query

Range: 0 to 999

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:ICOUNT?"
!Returns the intermediate count of spectrum emissions mask multi-measurements.

FETCh:WSEMask:ICPower?

Function

Queries the in-channel absolute power. To set the number of measurement to average, use the command SETup:WSEMask:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:ICPOWER?"
!Queries the in-channel power for the spectrum emissions mask results.

FETCh:WSEMask:INTegrity?

Function

Queries the measurement integrity indicator for the last spectrum emissions mask measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:INTegrity?"
!Queries the integrity indicator for the channel spectrum emissions mask results.

FETCh:WSEMask:RANGe[:ALL]?

Function

Returns the following for each of the four measurement ranges: level (in dBc), frequency offset (in MHz), mask margin (in dB), pass fail result.

The level results are the relative power that is associated with the largest mask error in the range. Fail is indicated anytime the mask offset is negative.

Query

Level

  • Range: -99.00 to +99.00 dBc, 9.91 E+37
  • Resolution: 0.01

Frequency Offset

  • Range 1: +/- 2.515 to 3.485 MHz
  • Range 2: +/- 4.000 to 7.500 MHz
  • Range 3: +/- 7.500 to 8.500 MHz
  • Range 4: +/- 8.500 to 12.500 MHz
  • Resolution, all ranges: 0.001

Mask Margin

  • Range: -99.00 to +99.00 dB, 9.91 E+37
  • Resolution: 0.01 dB

Pass/Fail Result

  • Range: 0 = pass, 1 =f fail, 9.91 E+37 = undetermined

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WSEMASK:RANGE:ALL?"

FETCh:WSEMask:RANGe:ADDitional?

Function

Returns the following for each of the two additional measurement ranges: level (in dBc), frequency offset (in MHz), mask margin (in dB), pass fail result.

The level results are the relative power that is associated with the largest mask error in the range. Fail is indicated anytime the mask offset is negative.

Query

Level

  • Range: -99.00 to +99.00 dBc, 9.91 E+37
  • Resolution: 0.01

Frequency Offset (dependant on bands)

  • Bands II, IV, X:
    • Range 1: +/- 2.515 to 3.485 MHz
    • Range 2: +/- 4.000 to 12.000 MHz
  • Band V:
    • Range 1: +/- 2.515 to 3.485 MHz
    • Range 2: +/- 3.550 to 12.450 MHz
  • Bands XII, XIII, XIV:
    • Range 1: +/- 2.515 to 2.585 MHz
    • Range 2: +/- 2.650 to 12.450 MHz
  • Resolution, all ranges: 0.001

Mask Margin

  • Range: -99.00 to +99.00 dB, 9.91 E+37
  • Resolution: 0.01 dB

Pass/Fail Result

  • Range: 0 = pass, 1 =f fail, 9.91 E+37 = undetermined

Requirements

Test Application Revision: A.14 and above.

Programming Example

OUTPUT 714;"FETCh:WSEMask:RANGe:ADDitional?"

FETCh:WSEMask:RANGe:ADDitional:RANGe[1]?

Function

Returns the following results for the specified additional requirements range: level (in dBc), frequency offset (in MHz), mask margin (in dB), pass/fail result.

Query

Level

  • Range: -99.00 to +99.00 dBc, 9.91 E+37
  • Resolution: 0.01

Frequency Offset (dependant on bands)

  • Bands II, IV, X:
    • Range 1: +/- 2.515 to 3.485 MHz
    • Range 2: +/- 4.000 to 12.000 MHz
  • Band V:
    • Range 1: +/- 2.515 to 3.485 MHz
    • Range 2: +/- 3.550 to 12.450 MHz
  • Bands XII, XIII, XIV:
    • Range 1: +/- 2.515 to 2.585 MHz
    • Range 2: +/- 2.650 to 12.450 MHz
  • Resolution, all ranges: 0.001

Mask Margin

  • Range: -99.00 to +99.00 dB, 9.91 E+37
  • Resolution: 0.01 dB

Pass/Fail Result

  • Range: 0 = pass, 1 =fail, 9.91 E+37 = undetermined

Requirements

Test Application Revision: A.14 and above.

Programming Example

OUTPUT 714;"FETCh:WSEMask:RANGe:ADDitional:RANGe2?"
! Returns the power level results in additional range 2.

FETCh:WSEMask:RANGe:RANGe[1]?

Function

Returns the following results for the specified range: level (in dBc), frequency offset (in MHz), mask margin (in dB), pass/fail result.

Query

Level

  • Range: -99.00 to +99.00 dBc, 9.91 E+37
  • Resolution: 0.01

Frequency Offset

  • Range 1: +/- 2.515 to 3.485 MHz
  • Range 2: +/- 4.000 to 7.500 MHz
  • Range 3: +/- 7.500 to 8.500 MHz
  • Range 4: +/- 8.500 to 12.500 MHz
  • Resolution, all ranges: 0.001

Mask Margin

  • Range: -99.00 to +99.00 dB, 9.91 E+37
  • Resolution: 0.01 dB

Pass/Fail Result

  • Range: 0 = pass, 1 =fail, 9.91 E+37 = undetermined

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCh:WSEMask:RANGe:RANG3?"
! Returns power level in the range 3.


FETCh:WTDPower

FETCh:WTDPower

Last updated: January 16, 2009

GPIB Command Conventions

  • FETCh:WTDPower[:ALL]?
  • FETCh:WTDPower:COUNt[:STEP]?
  • FETCh:WTDPower:INTegrity?

FETCh:WTDPower[:ALL]?

Function

Queries the TX dynamic power measurement results.

This query returns 101 comma-separated values, in the order of an integrity value, followed by 100 power results.

The FETCh:WTDPower[:ALL] query always returns 101 power results, regardless of how many power measurements were performed by the test set when the measurement was executed. The number of power measurements performed by the test set is equal to the Number of Power Steps setting + 1, and can be queried using the FETCh:WTDPower:COUNt[:STEP]? command. If fewer than 100 power measurements were performed by the test set, the remaining power results are returned as 9.91 E+37.

Query

  • Integrity (see Integrity Indicator )

  • Power

    • Range: -100.00 to 100.00 dBm, 9.91 E+37
    • Resolution: 0.01 dB

Requirements

Test Application Revision: A.07 and above

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"FETCh:WTDPower?"
! Returns integrity, 100 power results.

FETCh:WTDPower:COUNt[:STEP]?

Function

Queries the number of Power measurements performed by the test set. The power measurement values can be queried using the FETCh:WTDPower[:ALL]? command.

The number of power measurements performed by the test set is equal to the Number of Power Steps setting + 1.

Query

Range: 0 to 100

Resolution: 1

Requirements

Test Application Revision: A.07 and above

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"FETCh:WTDPower:COUNt?"
! Returns the number of power measurements performed by the test set.

FETCh:WTDPower:INTegrity?

Function

Queries the Integrity Indicator . Zero indicates a normal measurement.

Query

Range: see Integrity Indicator

Resolution: 1

Requirements

Test Application Revision: A.07 and above

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"FETCh:WTDPower:INTegrity?"
! Queries the integrity indicator for the TX dynamic power measurement results.


FETCh:WTPower

FETCh:WTPower

Last updated: January 16, 2009

GPIB Command Conventions

  • FETCh:WTPower[:ALL]?
  • FETCh:WTPower:ICOunt?
  • FETCh:WTPower:INTegrity?
  • FETCh:WTPower:POWer[:AVERage]?
  • FETCh:WTPower:POWer:ALL?
  • FETCh:WTPower:POWer:MAXimum?
  • FETCh:WTPower:POWer:MINimum?
  • FETCh:WTPower:POWer:SDEViation?

FETCh:WTPower[:ALL]?

Function

Queries a thermal power measurement result.

This query returns an integrity indicator followed by a thermal power measurement result (if results are available).

If the multi-measurement state is on, the result represents the average of a number of thermal power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WTPower:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WTPOWER:ALL?" !Returns integrity, thermal power.

FETCh:WTPower:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

The multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WTPower:COUNt[:SNUMber]

Query

Range: 0 to 999

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WTPOWER:ICOUNT?"

FETCh:WTPower:INTegrity?

Function

Queries the measurement integrity indicator for the last thermal power measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 1 through 16

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WTPOWER:INTegrity?"
!Queries the inegrity indicator for the thermal power results.

FETCh:WTPower:POWer[:AVERage]?

Function

Queries the average of the results of several thermal power measurements. To set the number of measurement to average, use the command SETup:WTPower:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WTPOWER:POWER:AVERAGE?"
!Queries the thermal power for the thermal power results.

FETCh:WTPower:POWer:ALL?

Function

Queries the statistical measurement results for several thermal power measurements.

To set the number of measurements to gather statistics for, use the command SETup:WTPower:COUNt[:SNUMber] .

Results are returned in the following order: minimum, maximum, average, and standard deviation thermal power.

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WTPOWER:POWER:ALL?"
!Queries the statistical measurement results for thermal power measurement.

FETCh:WTPower:POWer:MAXimum?

Function

Queries the maximum power of several thermal power measurements. To set the number of measurement to average, use the command SETup:WTPower:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WTPOWER:POWER:MAXIMUM?"
!Queries the inegrity indicator for the thermal power results.

FETCh:WTPower:POWer:MINimum?

Function

 Queries the minimum power of several thermal power measurements. To set the number of measurement to compare, use the command SETup:WTPower:COUNt[:SNUMber] .

Query

  • Range: -99 to 99 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WTPOWER:POWER:MINIMUM?"
!Queries the minimum thermal power.

FETCh:WTPower:POWer:SDEViation?

Function

Queries the standard deviation of several thermal power measurements. To set the number of measurement to compare, use the command SETup:WTPower:COUNt[:SNUMber] .

Query

  • Range: 0 to 99 dB, 9.91 E+37

  • Resolution: 0.001 dB

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WTPOWER:POWER:SDEVIATION?"
!Queries the standard deviation of power for the thermal power measurements.


FETCh:WWQuality

FETCh:WWQuality

Last updated: March 15, 2010

GPIB Command Conventions

  • FETCh:WWQuality[:ALL]?

  • FETCh:WWQuality:BETas?
  • FETCh:WWQuality:BETas:HSPA?

  • FETCh:WWQuality:EVM[:MAXimum]?
  • FETCh:WWQuality:EVM:ALL?
  • FETCh:WWQuality:EVM:AVERage?
  • FETCh:WWQuality:EVM:MINimum?
  • FETCh:WWQuality:EVM:PEAK<[:MAXimum]|:ALL|:AVERage|:MINimum|:SDEViation>?
  • FETCh:WWQuality:EVM:SDEViation?

  • FETCh:WWQuality:FERRor[:WORSt]?
  • FETCh:WWQuality:FERRor:ALL?
  • FETCh:WWQuality:FERRor:AVERage?
  • FETCh:WWQuality:FERRor:MAXimum?
  • FETCh:WWQuality:FERRor:MINimum?
  • FETCh:WWQuality:FERRor:SDEViation?

  • FETCh:WWQuality:ICOunt?

  • FETCh:WWQuality:INTegrity?

  • FETCh:WWQuality:IQGain<[:WORSt]|:ALL|:AVERage|:MAXimum|:MINimum|:SDEViation>?

  • FETCh:WWQuality:IQPHase<[:WORSt]|:ALL|:AVERage|:MAXimum|:MINimum|:SDEViation>?

  • FETCh:WWQuality:MERRor[:MAXimum]?
  • FETCh:WWQuality:MERRor:ALL?
  • FETCh:WWQuality:MERRor:AVERage?
  • FETCh:WWQuality:MERRor:MINimum?
  • FETCh:WWQuality:MERRor:PEAK<[:MAXimum]|:ALL|:AVERage|:MINimum|:SDEViation>?
  • FETCh:WWQuality:MERRor:SDEViation?

  • FETCh:WWQuality:OOFFset[:MAXimum]?
  • FETCh:WWQuality:OOFFset:ALL?
  • FETCh:WWQuality:OOFFset:AVERage?
  • FETCh:WWQuality:OOFFset:MINimum?
  • FETCh:WWQuality:OOFFset:SDEViation?

  • FETCh:WWQuality:PCERror[:ALL]?
  • FETCh:WWQuality:PCERror:CHANnel?
  • FETCh:WWQuality:PCERror:MAXimum?

  • FETCh:WWQuality:PERRor[:MAXimum]?
  • FETCh:WWQuality:PERRor:ALL?
  • FETCh:WWQuality:PERRor:AVERage?
  • FETCh:WWQuality:PERRor:MINimum?
  • FETCh:WWQuality:PERRor:PEAK<[:MAXimum]|:ALL|:AVERage|:MINimum|:SDEViation>?
  • FETCh:WWQuality:PERRor:SDEViation?

  • FETCh:WWQuality:RHO[:MAXimum]
  • FETCh:WWQuality:RHO:ALL
  • FETCh:WWQuality:RHO:AVERage
  • FETCh:WWQuality:RHO:MINimum
  • FETCh:WWQuality:RHO:SDEViation

  • FETCh:WWQuality:TERRor[:WORSt]?
  • FETCh:WWQuality:TERRor:ALL?
  • FETCh:WWQuality:TERRor:AVERage?
  • FETCh:WWQuality:TERRor:MAXimum?
  • FETCh:WWQuality:TERRor:MINimum?
  • FETCh:WWQuality:TERRor:SDEViation?

FETCh:WWQuality[:ALL]?

Function

Queries the waveform quality measurements.

Measurement results are returned in the following order: integrity, EVM maximum, worst case frequency error, origin offset maximum, phase error maximum, magnitude error maximum, worst case timing error, and peak code domain error maximum.

Query

Integrity

  • Range: 0 to 23

  • Resolution: 1

EVM Maximum

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.1

Frequency Error worst case

  • Range: -99.0 to 99.0 kHz, 9.91 E+37

  • Resolution: 0.1

Origin Offset Maximum

  • Range: -99.0 to 0.0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error Maximum

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Magnitude Error Maximum

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.1

Timing Error Worst Case

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Peak Code Domain Error Maximum

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Requirements

Test Application Revision: A.01 and above

Test Application Revision: A.02 added peak code domain error and timing error

Test Application Revision: A.02.25, timing error is returned in chips instead of seconds.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:ALL?"

FETCh:WWQuality:BETas?

Function

Queries Betac, Betad1, Betad2, Betad3, Betad4, Betad5, Betad6, Betahsacknak, Betahscqi .

Query

Range: 0 to 1

Resolution: 0.001

Requirements

Test Application Revision: A.02 and above.

Test Application Revision A.09, with the required feature license, added Beta hsacknak and Beta hscqi .

Lab Application Revision: A.01 and above.

Lab Application Revision C.04 and D.00, added Beta hsacknak and Beta hscqi .

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:BETAS?"

FETCh:WWQuality:BETas:HSPA?

Function

Queries Betac, Betad1, Betad2, Betad3, Betad4, Betad5, Betad6, Betahsacknak, Betahscqi, Betaec, Betaed1, Betaed2, Betaed3, Betaed4.

Query

Range: 0 to 1

Resolution: 0.001

Requirements

Lab Application Revision F.00 and above.

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"FETCh:WWQuality:BETas:HSPA?"

FETCh:WWQuality:EVM[:MAXimum]?

Function

Queries the maximum EVM.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:EVM:MAXIMUM?"
! Returns maximum EVM.

FETCh:WWQuality:EVM:ALL?

Function

Queries the EVM measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation error vector magnitude.

Query

Minimum EVM

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Maximum EVM

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Average EVM

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Standard Deviation EVM

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:EVM:ALL?"
! Returns all EVM measurement results.

FETCh:WWQuality:EVM:AVERage?

Function

Queries the average EVM.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:EVM:AVERAGE?"
! Returns average EVM.

FETCh:WWQuality:EVM:MINimum?

Function

Queries the minimum EVM.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:EVM:MINIMUM?"
! Returns mininum EVM.

FETCh:WWQuality:EVM:PEAK<[:MAXimum]|:ALL|:AVERage|:MINimum|:SDEViation>?

Function

Queries the Waveform Quality measurement results and returns the following, depending upon which mnemonic is sent at the end of the command string:

  • [:MAXimum] - returns the maximum peak EVM result when Multi-Measurement Count is on or peak EVM when Multi-Measurement Count = Off .
  • :ALL - returns the minimum, maximum, average and standard deviation peak EVM results when Multi-Measurement Count is on (it returns peak EVM, peak EVM, peak EVM and zero when Multi-Measurement Count is off).
  • :AVERage - returns the average peak EVM result when Multi-Measurement Count is on (it returns peak EVM when Multi-Measurement Count is off).
  • :MINimum - returns the minimum peak EVM result when Multi-Measurement Count is on (it returns peak EVM when Multi-Measurement Count is off).
  • :SDEViation - returns the standard deviation of the peak EVM results when Multi-Measurement Count is on (it returns zero when Multi-Measurement Count is off).

See Waveform Quality Measurement Results .

Query

Range:

  • Peak EVM: 0 to 99.0%, 9.91E+37
  • Standard deviation: 0 to 99.00%, 9.91E+37

Resolution:

  • Peak EVM: 0.1%
  • Standard deviation: 0.01%

Requirements

Test Application Revision A.11, Lab Application D.02 and above

Programming Example

OUTPUT 714;"FETCh:WWQuality:EVM:PEAK?"
! Returns peak EVM (or maximum peak EVM if multi-measurement count is on)

OUTPUT 714;"FETCh:WWQuality:EVM:PEAK:ALL?"
! Returns minimum, maximum, average and standard deviation peak EVM when multi-measurement
! count is on (it returns peak EVM, peak EVM, peak EVM and zero when multi-measurement
! count is off).

FETCh:WWQuality:EVM:SDEViation?

Function

Queries the standard deviation of results for EVM measurements.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:EVM:SDEVIATION?"
! Returns standard deviation EVM.

FETCh:WWQuality:FERRor[:WORSt]?

Function

Queries the worst case frequency error. (The test set returns either the Minimum or Maximum Frequency Error result, whichever is furthest from zero).

Query

Range: -99 to 99 kHz, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:FERROR:WORSt?"
! Returns worst case frequency error.

FETCh:WWQuality:FERRor:ALL?

Function

Queries the frequency error measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation and worst case frequency error.

Query

Minimum Frequency Error

  • Range: -99 to 99 kHz, 9.91 E+37

  • Resolution: 0.1

Maximum Frequency Error

  • Range: -99 to 99 kHz, 9.91 E+37

  • Resolution: 0.1

Average Frequency Error

  • Range: -99 to 99 kHz, 9.91 E+37

  • Resolution: 0.1

Standard Deviation Frequency Error

  • Range: -99 to 99 kHz, 9.91 E+37

  • Resolution: 0.01

Worst Case Frequency Error

  • Range: -99 to 99 kHz, 9.91 E+37

  • Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:FERROR:ALL?"
! Returns mininum, maximum, average,
! standard deviation and worst case frequency error.

FETCh:WWQuality:FERRor:AVERage?

Function

Queries the average frequency error.

Query

Range: -99 to 99 kHz, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:FERROR:AVERAGE?"
! Returns average frequency error.

FETCh:WWQuality:FERRor:MAXimum?

Function

Queries the average frequency error.

Query

Range: -99 to 99 kHz, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:FERROR:MAXIMUM?"
! Returns maximum frequency error.

FETCh:WWQuality:FERRor:MINimum?

Function

Queries the minimum frequency error.

Query

Range: -99 to 99 kHz, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:FERROR:MINIMUM?"
! Returns minimum frequency error.

FETCh:WWQuality:FERRor:SDEViation?

Function

Queries the standard deviation of frequency error measurements.

Query

Range: 0 to 99 kHz, 9.91 E+37

Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:FERROR:SDEViation?"
! Returns standard deviation frequency error.

FETCh:WWQuality:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

Query

Range: 0 to 999

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:ICOUNT?"

FETCh:WWQuality:INTegrity?

Function

Queries the measurement integrity indicator for the last waveform quality measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:INTEGRITY?"
!Queries the integrity indicator for the channel channel power results.

FETCh:WWQuality:IQGain<[:WORSt]|:ALL|:AVERage|:MAXimum|:MINimum|:SDEViation>?

Function

Queries the Waveform Quality measurement results and returns the following, depending upon which mnemonic is sent at the end of the command string:

  • [:WORSt] - returns the worst case IQ gain imbalance result when Multi-Measurement Count is on (it returns IQ gain imbalance when Multi-Measurement Count is off). The worst case IQ gain imbalance result is either the maximum or minimum result, whichever is farthest from zero.
  • :ALL - returns the minimum, maximum, average, standard deviation and worst case IQ gain imbalance results when Multi-Measurement Count is on (it returns IQ gain imbalance when Multi-Measurement Count is off).
  • :AVERage - returns the average IQ gain imbalance result when Multi-Measurement Count is on (it returns IQ gain imbalance when Multi-Measurement Count is off).
  • :MAXimum - returns the maximum IQ gain imbalance result (positive number farthest from zero) when Multi-Measurement Count is on (it returns IQ gain imbalance when Multi-Measurement Count = Off .
  • :MINimum - returns the minimum IQ gain imbalance result (negative number farthest from zero) when Multi-Measurement Count is on (it returns IQ gain imbalance when Multi-Measurement Count is off).
  • :SDEViation - returns the standard deviation of the IQ gain imbalance results when Multi-Measurement Count is on (it returns zero when Multi-Measurement Count is off).

See Waveform Quality Measurement Results .

Query

Range:

  • IQ gain imbalance: -99.0 to 99.0 dB, 9.91E+37
  • Standard deviation: 0 to 99.00 dB, 9.91E+37

Resolution:

  • IQ gain imbalance: 0.1 dB
  • Standard deviation: 0.01 dB

Requirements

Test Application Revision A.11, Lab Application Revisions D.02 and E.00 and above

Programming Example

OUTPUT 714;"FETCh:WWQuality:IQGain?"
! Returns IQ gain imbalance (or worst case IQ gain imbalance if multi-measurement count is on)

OUTPUT 714;"FETCh:WWQuality:IQGain:ALL?"
! Returns minimum, maximum, average, standard deviation and worst case IQ gain imbalance
! when multi-measurement count is on.

FETCh:WWQuality:IQPHase<[:WORSt]|:ALL|:AVERage|:MAXimum|:MINimum|:SDEViation>?

Function

Queries the Waveform Quality measurement results and returns the following, depending upon which mnemonic is sent at the end of the command string:

  • [:WORSt] - returns the worst case IQ phase imbalance result when Multi-Measurement Count is on (it returns IQ phase imbalance when Multi-Measurement Count is off). The worst case IQ phase imbalance result is either the maximum or minimum result, whichever is farthest from zero.
  • :ALL - returns the minimum, maximum, average, standard deviation and worst case IQ phase imbalance results when Multi-Measurement Count is on (it returns IQ phase imbalance when Multi-Measurement Count is off).
  • :AVERage - returns the average IQ phase imbalance result when Multi-Measurement Count is on (it returns IQ phase imbalance when Multi-Measurement Count is off).
  • :MAXimum - returns the maximum IQ phase imbalance result (positive number farthest from zero) when Multi-Measurement Count is on (it returns IQ phase imbalance when Multi-Measurement Count = Off .
  • :MINimum - returns the minimum IQ phase imbalance result (negative number farthest from zero) when Multi-Measurement Count is on (it returns IQ phase imbalance when Multi-Measurement Count is off).
  • :SDEViation - returns the standard deviation of the IQ phase imbalance results when Multi-Measurement Count is on (it returns zero when Multi-Measurement Count is off).

See Waveform Quality Measurement Results .

Query

Range:

  • IQ phase imbalance: -180.0 to 180.0 degrees, 9.91E+37
  • Standard deviation: 0 to 180.00 degrees, 9.91E+37

Resolution:

  • IQ phase imbalance: 0.1 degrees
  • Standard deviation: 0.01 degrees

Requirements

Test Application Revision A.11, Lab Application Revisions D.02 and E.00 and above

Programming Example

OUTPUT 714;"FETCh:WWQuality:IQPHase?"
! Returns IQ phase imbalance (or worst case IQ phase imbalance if multi-measurement count is on)

OUTPUT 714;"FETCh:WWQuality:IQPHase:ALL?"
! Returns minimum, maximum, average, standard deviation and worst case IQ phase imbalance
! when multi-measurement count is on.

FETCh:WWQuality:MERRor[:MAXimum]?

Function

Queries the average magnitude error.

Query

Range: 0 to 99%

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:MERRor:MAXIMUM?"
! Returns maximum magnitude error.

FETCh:WWQuality:MERRor:ALL?

Function

Queries the magnitude error measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation magnitude error.

Query

Minimum Magnitude Error

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Maximum Magnitude Error

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Average Magnitude Error

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Standard Deviation Magnitude Error

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:MERRor:ALL?"
! Returns mininum, maximum, average, and
! standard deviation magnitude error.

FETCh:WWQuality:MERRor:AVERage?

Function

Queries the average magnitude error.

Query

Range: 0 to 99%

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:MERRor:AVERAGE?"
! Returns average magnitude error.

FETCh:WWQuality:MERRor:MINimum?

Function

Queries the minimum magnitude error.

Query

Range: 0 to 99%

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:MERRor:MINIMUM?"
! Returns minimum magnitude error.

FETCh:WWQuality:MERRor:PEAK<[:MAXimum]|:ALL|:AVERage|:MINimum|:SDEViation>?

Function

Queries the peak magnitude error results in the Waveform Quality measurement and returns the following, depending upon which mnemonic is sent at the end of the command string:

  • [:MAXimum] - returns the maximum peak magnitude error result when Multi-Measurement Count is on or peak magnitude error when Multi-Measurement Count is Off .
  • :ALL - returns the minimum, maximum, average and standard deviation peak magnitude error results when Multi-Measurement Count is on (it returns peak magnitude error, peak magnitude error, peak magnitude error and zero when Multi-Measurement Count is off).
  • :AVERage - returns the average peak magnitude error result when Multi-Measurement Count is on (it returns peak magnitude error when Multi-Measurement Count is off).
  • :MINimum - returns the minimum peak magnitude error result when Multi-Measurement Count is on (it returns peak magnitude error when Multi-Measurement Count is off).
  • :SDEViation - returns the standard deviation of the peak magnitude error results when Multi-Measurement Count is on (it returns zero when Multi-Measurement Count is off).

Query

Range:

  • Peak magnitude error: 0 to 99.0%, 9.91E+37
  • Standard deviation: 0 to 99.00%, 9.91E+37

Resolution:

  • Peak magnitude error: 0.1%
  • Standard deviation: 0.01%

Requirements

Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"FETCh:WWQuality:MERRor:PEAK?"
! Returns peak magnitude error (or maximum peak magnitude error if multi-measurement count is on)

OUTPUT 714;"FETCh:WWQuality:MERRor:PEAK:ALL?"
! Returns minimum, maximum, average and standard deviation peak magnitude error when
! multi-measurement count is on (it returns peak magnitude error, peak magnitude error,
! peak magnitude error and zero when multi-measurement count is off).

FETCh:WWQuality:MERRor:SDEViation?

Function

Queries the standard deviation of magnitude error measurements.

Query

Range: 0 to 99%

Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:MERRor:SDEVIATION?"
! Returns standard deviation magnitude error.

FETCh:WWQuality:OOFFset[:MAXimum]?

Function

Queries the average origin offset.

Query

Range:-99 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:OOFFSET:MAXIMUM?"
! Returns maximum origin offset.

FETCh:WWQuality:OOFFset:ALL?

Function

Queries the origin offset measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation origin offset.

Query

Minimum Origin Offset

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Maximum Origin Offset

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Average Origin Offset

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Standard Deviation Origin Offset

  • Range: 0 to 99 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:OOFFSET:ALL?"
! Returns mininum, maximum, average, and
! standard deviation origin offset.

FETCh:WWQuality:OOFFset:AVERage?

Function

Queries the average origin offset.

Query

Range: -99 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:OOFFSET:AVERAGE?"
! Returns average origin offset.

FETCh:WWQuality:OOFFset:MINimum?

Function

Queries the minimum origin offset.

Query

Range:-99 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:OOFFSET:MINIMUM?"
! Returns minimum origin offset.

FETCh:WWQuality:OOFFset:SDEViation?

Function

Queries the standard deviation of results for origin offset measurements.

Query

Range: 0 to 99 dB, 9.91 E+37

Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:OOFFSET:SDEVIATION?"
! Returns standard deviation origin offset.

FETCh:WWQuality:PCERror[:ALL]?

Function

Queries the peak code domain error measurement. There are four number returned for each measurement. The first three numbers describe channel at which the peak error result was measured (OVFS channelization code, spreading factor, I/Q channel type), and the last number is the peak error.

Results are returned in the following order: OVFS channelization code, spreading factor, I/Q channel type, and peak code domain error.

Query

Channelization Code

  • Range: 0 to 255, 9.91 E+37

Spread Factor

  • Range: 4 to 256, 9.91 E+37

I/Q Channel Type

  • Range: 0 = I, 1= Q, 9.91 E+37

Peak Code Domain Error

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Requirements

Test or Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:PCERROR:ALL?"
! Returns Channelization code, spread factor, I/Q channel type, and peak error.

FETCh:WWQuality:PCERror:CHANnel?

Function

Returns information about the channel at which the peak code domain error result occurred. The following three results are returned: OVFS channelization code, spreading factor and I/Q channel type.

Query

Channelization Code

  • Range: 0 to 255, 9.91 E+37

Spread Factor

  • Range: 4 to 256, 9.91 E+37

I/Q Channel Type

  • Range: 0 = I, 1= Q, 9.91 E+37

Requirements

Test or Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:PCERROR:CHANNEL?"
! Returns channel at which peak error was detected.

FETCh:WWQuality:PCERror:MAXimum?

Function

Queries the maximum peak code domain error.

Query

Range: -99 to 0 dB, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:PCERROR:MAXIMUM?"
! Returns maximum peak code domain error.

FETCh:WWQuality:PERRor[:MAXimum]?

Function

Queries the maximum phase error measurement.

Query

Range: 0 to 180 degrees, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:PERROR:MAXIMUM?"
! Returns maximum phase error.

FETCh:WWQuality:PERRor:ALL?

Function

Queries the phase error measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation phase error.

Query

Minimum Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Maximum Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Average Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Standard Deviation Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:PERROR:ALL?"
! Returns mininum, maximum, average, and
! standard deviation phase error.

FETCh:WWQuality:PERRor:AVERage?

Function

Queries the average phase error.

Query

Range: 0 to 180 degrees, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:PERROR:AVERAGE?"
! Returns average phase error.

FETCh:WWQuality:PERRor:MINimum?

Function

Queries the minimum phase error.

Query

Range: 0 to 180 degrees, 9.91 E+37

Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:PERROR:MINIMUM?"
! Returns minimum phase error.

FETCh:WWQuality:PERRor:PEAK<[:MAXimum]|:ALL|:AVERage|:MINimum|:SDEViation>?

Function

Queries the peak phase error results in the Waveform Quality measurement and returns the following, depending upon which mnemonic is sent at the end of the command string:

  • [:MAXimum] - returns the maximum peak phase error result when Multi-Measurement Count is on or peak phase error when Multi-Measurement Count is Off .
  • :ALL - returns the minimum, maximum, average and standard deviation peak phase error results when Multi-Measurement Count is on (it returns peak phase error, peak phase error, peak phase error and zero when Multi-Measurement Count is off).
  • :AVERage - returns the average peak phase error result when Multi-Measurement Count is on (it returns peak phase error when Multi-Measurement Count is off).
  • :MINimum - returns the minimum peak phase error result when Multi-Measurement Count is on (it returns peak phase error when Multi-Measurement Count is off).
  • :SDEViation - returns the standard deviation of the peak phase error results when Multi-Measurement Count is on (it returns zero when Multi-Measurement Count is off).

Query

Range:

  • Peak phase error: 0 to 180 degrees, 9.91E+37
  • Standard deviation: 0 to 180 degrees, 9.91E+37

Resolution:

  • Peak phase error: 0.1
  • Standard deviation: 0.01

Requirements

Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"FETCh:WWQuality:PERRor:PEAK?"
! Returns peak phase error(or maximum peak phase error if multi-measurement count is on)

OUTPUT 714;"FETCh:WWQuality:PERRor:PEAK:ALL?"
! Returns minimum, maximum, average and standard deviation peak phase error when
! multi-measurement count is on (it returns peak phase error, peak phase error, peak phase error
! and zero when multi-measurement count is off).

FETCh:WWQuality:PERRor:SDEViation?

Function

Queries the standard deviation of results for phase error measurements.

Query

Range: 0 to 180 degrees, 9.91 E+37

Resolution: 0.01

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:PERROR:SDEVIATION?"
! Returns standard deviation phase error.

FETCh:WWQuality:RHO[:MAXimum]

Function

Queries the maximum Rho in the waveform quality measurement.

Query

Range: 0.000 to 1.000, 9.91 E+37

Resolution: 0.001

Requirements

Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"FETCh:WWQuality:RHO?"
! Returns the maximum Rho result.

FETCh:WWQuality:RHO:ALL

Function

Queries all the Rho result with the following order: minimum, maximum, average and standard deviation Rho.

Query

Minimum, maximum, average or standard deviation Rho:

  • Range: 0.000 to 1.000, 9.91 E+37
  • Resolution: 0.001

Requirements

Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"FETCh:WWQuality:RHO:ALL?"
! Returns the minimum, maximum, average and standard deviation Rho results

FETCh:WWQuality:RHO:AVERage

Function

Queries the average Rho result.

Query

Range: 0.000 to 1.000, 9.91 E+37

Resolution: 0.001

Requirements

Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"FETCh:WWQuality:RHO:AVERage?"
! Returns the average Rho result

FETCh:WWQuality:RHO:MINimum

Function

Queries the minimum value of the Rho results

Query

Range: 0.000 to 1.000, 9.91 E+37

Resolution: 0.001

Requirements

Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"FETCh:WWQuality:RHO:MINimum?"
! Returns the minimum value of the Rho results.

FETCh:WWQuality:RHO:SDEViation

Function

Queries the standard deviation of the Rho results.

Query

Range: 0.000 to 1.000, 9.91 E+37

Resolution: 0.001

Requirements

Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"FETCh:WWQuality:RHO:SDEViation?"
! Returns the standard deviation of the Rho results.

FETCh:WWQuality:TERRor[:WORSt]?

Function

Queries the worst case timing error. (The test set returns either the Minimum or Maximum Timing Error result, whichever is furthest from zero).

Query

Range: -99.99 to 99.99 chips, 9.91 E+37

Resolution: 0.01 chips

Requirements

Test Application Revision: A.02 and above

Test Application Revision: A.02.25, timing error is returned in chips instead of seconds

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:TERROR:WORSt?"
! Returns worst case timing error.

FETCh:WWQuality:TERRor:ALL?

Function

Queries the timing error measurements.

Results are returned in the following order: minimum, maximum, average, standard deviation timing error.

Query

Minimum Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Maximum Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Average Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Standard Deviation Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Requirements

Test Application Revision: A.02 and above

Test Application Revision: A.02.25, timing error is returned in chips instead of seconds

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:TERROR:ALL?"
! Returns mininum, maximum, average, and
! standard deviation timing error.

FETCh:WWQuality:TERRor:AVERage?

Function

Queries the average timing error.

Query

Range: -99.99 to 99.99 chips, 9.91 E+37

Resolution: 0.01 chips

Requirements

Test Application Revision: A.02 and above

Test Application Revision: A.02.25, timing error is returned in chips instead of seconds

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:TERROR:AVERAGE?"
! Returns average timing error.

FETCh:WWQuality:TERRor:MAXimum?

Function

Queries the maximum timing error.

Query

Range: -99.99 to 99.99 chips, 9.91 E+37

Resolution: 0.01 chips

Requirements

Test Application Revision: A.02 and above

Test Application Revision: A.02.25, timing error is returned in chips instead of seconds

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:TERROR:MAXIMUM?"
! Returns maximum timing error.

FETCh:WWQuality:TERRor:MINimum?

Function

Queries the minimum timing error.

Query

Range: -99.99 to 99.99 chips, 9.91 E+37

Resolution: 0.01 chips

Requirements

Test Application Revision: A.02 and above

Test Application Revision: A.02.25, timing error is returned in chips instead of seconds

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:TERROR:MINIMUM?"
! Returns minimum timing error.

FETCh:WWQuality:TERRor:SDEViation?

Function

Queries the standard deviation of timing error measurements.

Query

Range: 0 to 99.99 chips, 9.91 E+37

Resolution: 0.01 chips

Requirements

Test Application Revision: A.02 and above

Test Application Revision: A.02.25, timing error is returned in chips instead of seconds

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCH:WWQUALITY:TERROR:SDEViation?"
! Returns standard deviation time error.


INITiate

INITiate

Last updated: December 29, 2009

GPIB Command Conventions

  • INITiate:<measurement mnemonic>[:ON]
  • INITiate:ON?
  • INITiate:CFDTune:ARMed?
  • INITiate:<measurement mnemonic>:OFF
  • INITiate:COUNt?
  • INITiate:DONE?
  • INITiate:DONE:CLEar
  • INITiate:DONE:FLAG[:ALL]
  • INITiate:DONE:FLAG:<measurement mnemonic>
  • INITiate:WEDPower:ARMed?

INITiate:<measurement mnemonic>[:ON]

Function

These commands initiate (start) the following measurements:

  • AFANalyzer - Audio Frequency Analyzer measurements
  • CFDTune - Fast Device Tune measurement ( lab application or feature-licensed test application only )
  • EVMQpsk - QPSK EVM measurement ( lab application only )
  • FSTability - Frequency Stability measurement
  • HBLerror - HSDPA Block Error Ratio ( lab application or feature-licensed test application only )
  • HRCQuality - HSDPA Reporting of Channel Quality Indicator measurement ( lab application only )
  • SAUDio - Swept Audio measurement
  • SMONitor - Spectrum Monitor measurement
  • WACLeakage - Adjacent Channel Leakage
  • WBERror - Loopback Bit Error Ratio measurement
  • WBLerror - Block Error Ratio measurement
  • WCDomain - Code Domain measurements
  • WCPower - Channel Power measurement
  • WCTFormat - Change of TFC ( lab application only )
  • WDPAnalysis - Dynamic Power Analysis
  • WEDPower - Extended Range Dynamic Power
  • WILPower - Inner Loop Power measurement
  • WIQTuning - IQ Tuning measurement
  • WOBWidth - Occupied Bandwidth measurement
  • WOOPower - PRACH Transmit On/Off Power measurement
  • WOOSynch - Out-of-Synch Handling of Output Power measurement
  • WPDiscon - Phase Discontinuity
  • WPESquality - Perceptual Evaluation of Speech Quality measurement
  • WPPAnalysis - PRACH Preamble Analysis ( lab application only )
  • WSEMask - Spectrum Emission Mask measurement
  • WTDPower - TX Dynamic Power measurement
  • WTPower - Thermal Power measurement
  • WWQuality - Waveform Quality measurement

This command also queries the active state using the ON? keyword in place of a measurement mnemonic.

The INITiate command is associated with the SETup SETup Subsystem and the FETCh? Subsystem .

One or more measurements can be initiated with the same program line (see Concurrent Measurements and the Programming Example below).

This command is also used to activate a measurement. See INITiate Programming Examples (how INIT commands are used) .

Requirements

Test Application Revision A.01 and above.

Test Application Revision A.02 added WCDomain, WSEMask, and WOBWidth.

Test Application Revision A.03 added WIQTuning, WILPower, WOOPower, and SMONitor.

Test Application Revision A.05 added WBLerror, WDPAnalysis and WPDiscon.

Test Application Revision A.06 added FSTability

Test Application Revision A.07 added WTDPower

Test Application Revision A.08 with the required feature license, added HBLerror

Test Application Revision A.09 with the required feature license, added CFDTune

Lab Application Revision: A.01 and above.

Lab Application Revision B.01 added WBLerror, WDPAnalysis, WPDiscon, and WPPAnalysis.

Lab Application Revision C.01 added FSTability, WCTFormat and WOOSynch

Lab Application Revision C.02 added WTDPower

Lab Application Revision C.03 added HBLerror

Lab Application Revision C.04 and D.00.04 added CFDTune

Test Application Revision A.10 and Lab Application Revision D.01 and above, added WEDPower

Lab Application Revision E.00.16 added HRCQuality

Lab Application Revision F.00.19 added EVMQpsk

Lab Application Revision G.00 added WPESquality

Programming Example

OUTPUT 714;"INITiate:WCPower;WWQuality:ON"
! Initiates a channel power and a waveform quality measurement.

INITiate:ON?

Function

Queries the measurements that are on. Returns a comma separated list of measurement mnemonics.

Query

Range: AFAN|CFDT#|EVMQ*|FST|HBL#|HRCQ*|SAUD|SMON|WACL|WBER|WBL|WCD|WCP
|WCTF*|WDPA|WEDP|WILP|WIQT|WOBW|WOOP|WOOS*|WPD|WPES*|WPPA*
|WSEM|WTDP|WTP|WWQ|NONE

# Only applicable to the lab application or feature-licensed test application.

* Only applicable to the lab application.

Requirements

Test Application Revision A.01 and above.

Test Application Revision A.02 added WCDomain, WSEMask, and WOBWidth.

Test Application Revision A.03 added WIQTuning, WILPower, WOOPower, and SMONitor.

Test Application Revision A.05 added WBLerror, WDPAnalysis and WPDiscon.

Test Application Revision A.06 added FSTability

Test Application Revision A.07 added WTDPower

Test Application Revision A.08 with the required feature license, added HBLerror

Test Application Revision A.09 with the required feature license, added CFDTune

Lab Application Revision: A.01 and above.

Lab Application Revision B.01 added WBLerror, WDPAnalysis, WPDiscon, and WPPAnalysis.

Lab Application Revision C.01 added FSTability, WCTFormat and WOOSynch

Lab Application Revision C.02 added WTDPower

Lab Application Revision C.03 added HBLerror

Lab Application Revision C.04 and D.00.04 added CFDTune

Test Application Revision A.10 and Lab Application Revision D.01, added WEDPower

Lab Application Revision E.00.16 added HRCQuality

Lab Application Revision F.00.19 added EVMQpsk

Lab Application Revision G.00 added WPESquality

Programming Example

OUTPUT 714;"INITiate:ON?"

INITiate:CFDTune:ARMed?

Function

Queries the arm state of the fast device tune measurement.

  • This command immediately returns a 1 if the fast device tune measurement has been initiated and is ready to be triggered.
  • This command hangs if the fast device tune measurement has been initiated but is not ready to be triggered (it will return a 1 once the measurement becomes ready to be triggered).
  • This command immediately returns a 0 if the fast device tune measurement is not in the process of preparing for a trigger (for example, if the fast device tune measurement has not been initiated, has been aborted, or has already been triggered).

Query

Range: 0 | 1

Requirement

Test Application Revision: A.09 and above, with the required feature license.
Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"INITiate:CFDTune:ARMed?"
!Queries whether the test set's hardware is successfully
!set up for the fast device tune measurement.

INITiate:<measurement mnemonic>:OFF

Function

Deactivates the selected measurement. See Measurement States .

Only one measurement can be deactivated at a time. To stop one or more measurements and leave them in the active state, use ABORt .

Requirements

Test Application Revision A.01 and above.

Test Application Revision A.02 added WCDomain, WSEMask, and WOBWidth.

Test Application Revision A.03 added WIQTuning, WILPower, WOOPower, and SMONitor.

Test Application Revision A.05 added WBLerror, WDPAnalysis and WPDiscon.

Test Application Revision A.06 added FSTability

Test Application Revision A.07 added WTDPower

Test Application Revision A.08 with the required feature license, added HBLerror

Test Application Revision A.09 with the required feature license, added CFDTune

Lab Application Revision: A.01 and above.

Lab Application Revision B.01 added WBLerror, WDPAnalysis, WPDiscon, and WPPAnalysis.

Lab Application Revision C.01 added FSTability, WCTFormat and WOOSynch

Lab Application Revision C.02 added WTDPower

Lab Application Revision C.03 added HBLerror

Lab Application Revision C.04 and D.00.04 added CFDTune

Test Application Revision A.10 and Lab Application Revision D.01, added WEDPower

Lab Application Revision E.00.16 added HRCQuality

Lab Application Revision F.00.19 added EVMQpsk

Lab Application Revision G.00 added WPESquality

Programming Example

OUTPUT 714;"INITiate:WCPower:OFF"
! Deactivates the channel power measurement.

INITiate:COUNt?

Function

Queries the number of measurements that have been initiated (are active). See Measurement States .

Query

Range: 0 to the number of measurements available in the application

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"INITiate:COUNt?"

INITiate:DONE?

Function

Queries (one at a time) which measurements, if any, are finished or have timed-out.

See Measurement Event Synchronization for how to use this command.

See Measurement States to understand the test set's measurement states.

See INITiate:DONE:FLAG:<measurement mnemonic> for include or exclude commands.
Query

Range: AFAN|CFDT#|EVMQ*|FST|HBL#|HRCQ*|SAUD|SMON|WACL|WBER|WBL|WCD|WCP
|WCTF*|WDPA|WEDP|WILP|WIQT|WOBW|WOOP|WOOS*|WPD|WPES*|WPPA*|WSEM
|WTDP|WTP|WWQ|NONE

# Only applicable to the lab application or feature-licensed test application.

* Only applicable to the lab application.

Requirements

Test Application Revision A.01 and above.

Test Application Revision A.02 added WCDomain, WSEMask, and WOBWidth.

Test Application Revision A.03 added WIQTuning, WILPower, WOOPower, and SMONitor.

Test Application Revision A.05 added WBLerror, WDPAnalysis and WPDiscon.

Test Application Revision A.06 added FSTability

Test Application Revision A.07 added WTDPower

Test Application Revision A.08 with the required feature license, added HBLerror

Test Application Revision A.09 with the required feature license, added CFDTune

Lab Application Revision: A.01 and above.

Lab Application Revision B.01 added WBLerror, WDPAnalysis, WPDiscon, and WPPAnalysis.

Lab Application Revision C.01 added FSTability, WCTFormat and WOOSynch

Lab Application Revision C.02 added WTDPower

Lab Application Revision C.03 added HBLerror

Lab Application Revision C.04 and D.00.04 added CFDTune

Test Application Revision A.10 and Lab Application Revision D.01, added WEDPower

Lab Application Revision E.00.16 added HRCQuality

Lab Application Revision F.00.19 added EVMQpsk

INITiate:DONE:CLEar

Function

Clears the done flag from all measurements.

Requirements

Test or Lab Application Revision A.01 and above.

Programming Example

OUTPUT 714;"INITiate:DONE:CLEar"
! Clears the done flag.

INITiate:DONE:FLAG[:ALL]

Function

Specifies that all measurements are either included or excluded when the INITitate:DONE? query is sent.

If a measurement trigger arm is left in continuous mode, the done flag for that measurement will toggle between DONE and WAIT. The INITiate:DONE? query will probably not be able to catch the measurement at the instant it is done; therefore, the measurement will never appear to be done. If a measurement's triggering must be continuously armed, you should exclude the measurement using INITiate:DONE:FLAG:<measurement mnemonic> .

Use INITitate:DONE:FLAG:ALL EXCLude to exclude all measurements.

Once INITiate:DONE:FLAG has been set to EXCLude for a measurement, the user must send the INCLude command for that measurement in order to query that measurement with the INITiate:DONE? query. The test set will not reset any excluded measurement with any type of preset.

Setting

Range: INCLude|EXCLude

Requirements

Test Application or Lab Application Revision A.01 and above.

Programming Example

OUTPUT 714;"INITiate:DONE:FLAG INCLude"
! Includes all measurements in the INITIATE:DONE? query.

INITiate:DONE:FLAG:<measurement mnemonic>

Function

Specifies if a measurement done flag is considered (using the INCLude or EXCLude settings) when the INITitate:DONE? query is sent.

If more than one measurement is active, and one or more measurement trigger arm states is continuous, the INITiate:DONE? query may not be effective. The best solution is to change the arm state of all measurements to single using the SETup:CONTinuous command. However, if a measurement must be continuously triggered, you should exclude the measurement using the EXCLude setting provided by this command if you want to use INITiate:DONE? to query measurement done status.

The test set will not reset any excluded measurement to included with any type of preset.

Setting

Range: INCLude|EXCLude

Requirements

Test Application Revision A.01 and above.

Test Application Revision A.02 added WCDomain, WSEMask, and WOBWidth.

Test Application Revision A.03 added WIQTuning, WILPower, WOOPower, and SMONitor.

Test Application Revision A.05 added WBLerror, WDPAnalysis and WPDiscon.

Test Application Revision A.06 added FSTability

Test Application Revision A.07 added WTDPower

Test Application Revision A.08 with the required feature license, added HBLerror

Test Application Revision A.09 with the required feature license, added CFDTune

Lab Application Revision: A.01 and above.

Lab Application Revision B.01 added WBLerror, WDPAnalysis, WPDiscon, and WPPAnalysis.

Lab Application Revision C.01 added FSTability, WCTFormat and WOOSynch

Lab Application Revision C.02 added WTDPower

Lab Application Revision C.03 added HBLerror

Lab Application Revision C.04 and D.00.04 added CFDTune

Test Application Revision A.10 and Lab Application Revision D.01, added WEDPower

Lab Application Revision E.00.16 added HRCQuality

Lab Application Revision F.00.19 added EVMQpsk

Lab Application Revision G.00 added WPESquality

Programming Example

OUTPUT 714;"INITiate:DONE:FLAG:WTP EXCLude"
! Excludes the thermal power measurement from responding
! to the INITiate:DONE? query.

INITiate:WEDPower:ARMed?

Function

Queries the arm state of the extended range dynamic power measurement.

  • This command immediately returns a 1 if the extended range dynamic power measurement has been initiated and is ready to be triggered.
  • This command hangs if the extended range dynamic power measurement has been initiated but is not ready to be triggered (it will return a 1 once the measurement becomes ready to be triggered).
  • This command immediately returns a 0 if the extended range dynamic power is not in the process of preparing for a trigger (for example, if the extended range dynamic power measurement has not been initiated, has been aborted, or has already been triggered).

Query

Range: 0 | 1

Requirement

Lab Application Revision: F.00 and above.

Programming Example

OUTPUT 714;"INITiate:WEDPower:ARMed?"
!Queries whether the test set's hardware is successfully
!set up for the extended range dynamic power measurement.


INITiate Subsystem

INITiate Subsystem

Last updated: January 16, 2009

Syntax Diagrams and Command Descriptions

INITiate

Description

INITiate Command Functions

The INITiate subsystem is used to:

  • Start (activate) individual or multiple (concurrent) measurements.

  • Turn individual measurements off.

  • Determine the number of measurements currently active (INIT:COUNT?).

  • Determine the names of the measurements currently active (INIT:ON?).

  • Determine which measurements are finished (INIT:DONE?).

What Happens When a Measurement is INITiated?

When a measurement is started using INITiate commands, a new measurement cycle is started. If the selected measurement is currently in a measurement cycle, it is aborted. If a timeout is specified, the timeout period begins when a measurement is initiated.

NOTE
The INITiate subsystem is derived from SCPI, but has some modifications to make it more compatible with the manual operation of the test set. Most notably, the choice of single or continuous measurement triggering is made using the SETup subsystem.

INITiate Programming Examples (how INIT commands are used)

The INITiate command is used to start measurements. INITiate commands allow multiple measurements to be started without waiting for other measurement processes to complete. For example, the following code starts the Digital Average Power and Waveform Quality measurements, and then uses the INITiate:DONE? command in a loop to query the status of these measurements, see Measurement Event Synchronization .

When the measurements are done, the FETCh command is used to acquire the results, and the results are entered into variables in the controlling application. The program ends when the INITiate:DONE? command returns the string "NONE" indicating that all initiated measurements have gone through the measuring state see Measurement States .

Trigger arming for each measurement is controlled in the SETup subsystem. The choices are single or continuous. The best practice (during remote operation) is to use single measurement mode. This simplifies the tasks of starting concurrent measurements, then using the INIT subsystem commands to determine which measurements are ready to be FETChed.

10 OUTPUT 714;"SETup:ALL:CONTinuous:OFF" ! selects single trigger  mode.
20 OUTPUT 714;"INITiate:WBERror;WCPower" ! starts loopback BER  and
30                                       !channel power  measurements.
40 LOOP
50 OUTPUT 714;"INITiate:DONE?" !query to find out if any measurements are done.
60 ENTER 714;Meas_complete$
70 SELECT Meas_complete$
80 CASE "WBER" !tests for the string "WBER", indicating loopback BER measurement is done.
90 OUTPUT 714;"FETCh:WBERror?" !Queries loopback BER results.
100 ENTER 714;Integrity,Ber,Ber_count,Bits_tested
110 CASE "WCP" !tests for the string "WCP", indicating channel power measuremenet is done.
120 OUTPUT 714;"FETCh:WCPow?" !Queries the channel power results.
130 ENTER 714;Integrity,Avg_chan_pow
140 END SELECT
150 EXIT IF Meas_complete$="NONE"
160 END LOOP
170 END


READ

Last updated: January 14, 2010

GPIB Command Conventions

  • READ:AFANalyzer[:ALL]?
  • READ:CFDTune[:ALL]?
  • READ:EVMQpsk[:ALL]?
  • READ:FSTability[:ALL]?
  • READ:HBLerror[:ALL]?
  • READ:HRCQuality[:ALL]?
  • READ:SAUDio[:ALL]?
  • READ:SMONitor:TRACe?
  • READ:WACLeakage[:ALL]?
  • READ:WBERror[:ALL]?
  • READ:WBLerror[:ALL]?
  • READ:WCDomain[:ALL]?
  • READ:WCPower[:ALL]?
  • READ:WCTFormat[:ALL]?
  • READ:WDPAnalysis[:ALL]?
  • READ:WEDPower[:ALL]?
  • READ:WILPower[:ALL]?
  • READ:WIQTuning[:ALL]?
  • READ:WOBWidth[:ALL]?
  • READ:WOOPower[:ALL]?
  • READ:WPDiscon[:ALL]?
  • READ:WPDiscon[:ALL]?
  • READ:WPPAnalysis[:ALL]?
  • READ:WSEMask[:ALL]?
  • READ:WSEMask:FAIL?
  • READ:WTDPower[:ALL]?
  • READ:WTPower[:ALL]?
  • READ:WWQuality[:ALL]?

READ:AFANalyzer[:ALL]?

Function

Initiates and fetches an audio frequency analyzer measurement as a sequential operation.

Measurement results are returned in the following order: integrity, average audio level, average SINAD, average audio distortion.

Query

Integrity: see Integrity Indicator

Average audio level

  • Range: 0 to 20 volts, 9.91 E+37
  • Resolution: the lesser of 4 significant digits or 10 uV.

Average SINAD

  • Range: -99.00 to 99.00 dB, 9.91 E+37
  • Resolution: 0.01 dB

Average audio distortion

  • Range: 0.00 to 99.00%, 9.91 E+37
  • Resolution: 0.01%

Requirements

Test or Lab Application Revision: A.01 and above

READ:CFDTune[:ALL]?

Function

Initiates and fetches the fast device tune measurement as a sequential operation.

Results are returned in the following order:

  • Integrity
  • Number of Frequency Steps
  • Number of Power Steps
  • Number of MS TX power steps measured (in most cases, it equals Number of Frequency Steps multiplied by Number of Power Steps )
  • Comma-separated list of 400 MS Tx Power results. 400 results are always returned; if the test set measured fewer than 400 power steps from the mobile, the remaining values are NANs (9.91E+37). The power results for the first frequency in the MS TX Frequency Sequence are returned first, then the power results for the second frequency in the MS TX Frequency Sequence, etc., followed by NANs if fewer than 400 points were measured.

See Fast Device Tune Measurement Results .

Query

Integrity

  • Range: see Integrity Indicator

  • Resolution: 1

Number of Frequency Steps

  • Range: 1 to 20, 9.91 E+37

  • Resolution: 1.0

Number of Power Steps

  • Range: 1 to 20, 9.91 E+37

  • Resolution: 1.0

Number of MS Tx Power Steps Measured

  • Range: 1 to 400, 9.91 E+37

  • Resolution: 1.0

MS Tx Power Results Array

  • Range: -100.00 to +100.00 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Requirement

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and D.00.04 and above

Programming Example

 OUTPUT 714;"READ:CFDTune:ALL?"

READ:EVMQpsk[:ALL]?

Function

Initiates and fetches a QPSK EVM measurement as a sequential operation.

Measurement results are returned in the following order: integrity, EVM maximum, frequency error worst case, origin offset maximum, phase error maximum, magnitude error maximum, peak EVM maximum.

If the multi-measurement state is on, each result represents the average of a number of QPSK EVM measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:EVMQpsk:COUNt[:SNUMber] .

Query

Integrity

  • Range: 0 to 16

  • Resolution: 1

EVM Maximum

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Frequency Error worst case

  • Range-99.99 to 99.99 kHz, 9.91 E+37

  • Resolution: 0.1

Origin Offset Maximum

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error Maximum

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Magnitude Error Maximum

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Peak EVM Maximum

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

READ:FSTability[:ALL]?

Function

Initiates and fetches a frequency stability measurement as a sequential operation.

Measurement results are returned in the following order: integrity, worst-case frequency error, average frequency.

Query

Worst-case frequency error

  • Range: -500 to 500 parts per million (ppm)
  • Resolution: 0.01

Average frequency

  • Range: 100 E+6 to 3 E+9 Hz
  • Resolution: 1 Hz

READ:HBLerror[:ALL]?

Function

Initiates and fetches an HSDPA block error ratio measurement as a sequential operation.

Measurement results are returned in the following order: Integrity Indicator, Block Error Ratio in %, Information Bit Throughput in kbps, Positive Acknowledgments, Negative Acknowledgments, Statistical DTXs, Number of Blocks Tested, Median Channel Quality Indicator.

Query

Integrity Indicator - See Integrity Indicator .

Block Error Ratio

  • Range: 0.00 to 100.00%, 9.91E+37
  • Resolution: 0.01%

Information Bit Throughput

  • Range: 0.000 to 14000.000 kbps, 9.91E+37
  • Resolution: 0.001 kbps

Positive Acknowledgments

  • Range: 0 to 99000, 9.91E+37
  • Resolution: 1

Negative Acknowledgments

  • Range: 0 to 99000, 9.91E+37
  • Resolution: 1

Statistical DTXs

  • Range: 0 to 99000, 9.91E+37
  • Resolution: 1

Number of Blocks Tested

  • Range: 0 to 99000, 9.91E+37
  • Resolution: 1

Median Channel Quality Indicator

  • Range: 0 to 30, 9.91E+37
  • Resolution: 1

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above

READ:HRCQuality[:ALL]?

Function

Initiates and fetches a Reporting of Channel Quality Indicator measurement as a sequential operation.

Measurement results are returned in the following order: Integrity Indicator, Reporting of Channel Quality Indicator Pass/Fail Result.

Query

Integrity Indicator - See Integrity Indicator .

Reporting of Channel Quality Indicator

  • Range: 0 (pass), 1 (fail), 9.91E+37

Requirements

Lab Application Revision: E.00.16 and above

READ:SAUDio[:ALL]?

Function

Initiates and fetches a swept audio measurement as a sequential operation.

Measurement results are returned in the following order: integrity indicator, average swept audio level and average distortion for the first frequency point, average swept audio level and average distortion for the second frequency point, and so on. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.

For frequencies above 10 kHz, this measurement returns 9.91 E+37.

Query

Integrity indicator: see Integrity Indicator

Average audio level

  • Range: 1 mV to 20 V, 9.91 E+37
  • Resolution: the lesser of 4 significant digits or 10 uV

Average distortion

  • Range: 0 to 99.9%, 9.91 E+37
  • Resolution: 0.01%

READ:SMONitor:TRACe?

Function

Queries (initiates and fetches) one spectrum monitor measurement as a sequential operation.

Returns a comma separated list of 401 points representing the amplitude results of the trace data.

Query

Range:

  • For spans of 125 kHz and 500 kHz

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: -50 to +55 dB

  • For all other spans

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: (reference level - 60 dB) to +55 dB

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above.

READ:WACLeakage[:ALL]?

Function

Initiates and fetches an adjacent channel leakage ratio measurement as a sequential operation.

Measurement results are returned in the following order: integrity, -5 MHz minimum offset power ratio, +5 MHz maximum offset power ratio, -10 MHz minimum offset power ratio,
+10 MHz maximum offset power ratio.

If the measurement state of any offset is set to OFF, the result for that offset will be 9.91 E+37.

Query
  • Range: -100 to 100 dBm
  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

READ:WBERror[:ALL]?

Function

Initiates and fetches a loopback bit error ratio measurement as a sequential operation.

Measurement results are returned in the following order: integrity, bit error ratio, bit error count, bits tested.

Query

Range

  • Integrity: 1 to 23
  • Bit Error Ratio: 0 to 99%, 9.91 E+37
  • Bit Error Count: 0 to 999999, 9.91 E+37
  • Bits Tested: 0 to 999999, 9.91 E+37

Resolution

  • Integrity: 1
  • Bit Error Ratio: 0.0001 dB
  • Bit Error Count: 1
  • Bits Tested: 1

Requirements

Test or Lab Application Revision: A.01 and above

READ:WBLerror[:ALL]?

Function

Initiates and fetches a loopback block error ratio measurement as a sequential operation.

Measurement results are returned in the following order: integrity, block error ratio, block error count, blocks tested, uplink missing blocks.

See Block Error Ratio Measurement Results .

Query

Range

  • Integrity: see Integrity Indicator .
  • Block Error Ratio: 0 to 99%, 9.91 E+37
  • Block Error Count: 0 to 99000, 9.91 E+37
  • Blocks Tested: 0 to 99000, 9.91 E+37
  • Uplink Missing Blocks: 0 to 99000, 9.91 E+37

Resolution

  • Integrity: 1
  • Block Error Ratio: 0.0001%
  • Block Error Count: 1
  • Blocks Tested: 1
  • Uplink Missing Blocks: 1

Requirements

Test Application Revision: A.05 and above.

Lab Application Revision: B.01 and above.

Programming Example

 OUTPUT 714;"READ:WBLerror?"

READ:WCDomain[:ALL]?

Function

Initiates and fetches a code domain measurement as a sequential operation.

Measurement results are returned in the following order: integrity, EVM, frequency error, origin offset, phase error, magnitude error, time error, peak code domain error.

Query

Integrity

  • Range: 0 to 23

  • Resolution: 1

EVM Maximum

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Frequency Error worst case

  • Range: -99.99 to 99.99 kHz, 9.91 E+37

  • Resolution: 0.1

Origin Offset Maximum

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error Maximum

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Magnitude Error Maximum

  • Range: 0.0 to 99.0%

  • Resolution: 0.1

Time Error Maximum

  • Range: -99 to 99 µ s, 9.91 E+37

  • Resolution: 1 ns

Peak Code Domain Error Maximum

  • Range: -99.0 to 0.0 dB, 9.91 E+37

  • Resolution: 0.1

Requirements

Test Application Revision:

Lab Application Revision: A.01 and above.

READ:WCPower[:ALL]?

Function

Initiates and fetches a channel power measurement as a sequential operation.

Measurement results are returned in the following order: integrity, average channel power.

If the multi-measurement state is on, the result represents the average of a number of channel power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WCPower:COUNt[:SNUMber] .

Query
  • Range: -99 to 99 dBm
  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

READ:WCTFormat[:ALL]?

Function

Initiates and fetches a change of TFC measurement as a sequential operation.

Measurement results are returned in the following order: Integrity Indicator, Step Down Relative Power (average result if SETup:WCTFormat:COUNt[:SNUMber] is greater than 0), Step Down Error, Step Down Pass/Fail, Step Up Relative Power (average result if SETup:WCTFormat:COUNt[:SNUMber] is greater than 0), Step Up Error, Step Up Pass/Fail.

See Change of TFC Measurement Results .

Query

Integrity Indicator - see Integrity Indicator .

Step Down Relative Power

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Step Down Error

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Step Down Pass/Fail

  • Range: 0 (pass), 1 (fail), 9.91E+37

Step Up Relative Power

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Step Up Error

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Step Up Pass/Fail

  • Range: 0 (pass), 1 (fail), 9.91E+37

Requirements

Lab Application Revision: C.01 and above

Programming Example

 OUTPUT 714;"READ:WCTFormat?"

READ:WDPAnalysis[:ALL]?

Function

Initiates and fetches a dynamic power analysis measurement as a sequential operation.

Measurement results are returned in the following order: integrity indicator, the number of steps measured, and a comma-separated list of average power values for each step measured (in dBm).

See Dynamic Power Analysis Measurement Results .

Query

Integrity Indicator - see Integrity Indicator .

Number of Steps

  • Range: 0 to 200
  • Resolution: 1

Average Power

  • Range: -99.99 to 99.99 dBm, 9.91E+37
  • Resolution: 0.01 dBm

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Test Application Revision A.08 and Lab Application C.03, increased Number of Steps range to 0 to 200 (previously it was 0 to 100)

Programming Example

 OUTPUT 714;"READ:WDPAnalysis?"
! Returns integrity, number of steps measured,
! average power for each step

READ:WEDPower[:ALL]?

Function

Initiates and fetches an extended range dynamic power measurement as a sequential operation.

Measurement results are returned in the following order: integrity indicator, the number of steps measured, and a comma-separated list of average power values for each step measured (in dBm).

See Extended Range Dynamic Power Measurement Results .

Query

Integrity Indicator - See Integrity Indicator .

Number of Steps

  • Range: 1 to 85, 9.91E+37
  • Resolution: 1

Average Power

  • Range: -99 to 99 dBm, 9.91E+37
  • Resolution: 0.01 dBm

Requirements

Test Application Revision: A.10 and above

Lab Application Revision: D.01 and above

Programming Example

 OUTPUT 714;"READ:WEDPower?"
! Returns integrity, number of steps measured,
! average power for each step

 OUTPUT 714;"READ:WEDPower:STEPs?"
! Returns number of steps measured

READ:WILPower[:ALL]?

Function

Initiates and fetches an Inner Loop Power control measurement as a sequential operation.

Measurement results are returned in the following order:

Query

Integrity

  • Range: 0 to 23

  • Resolution: 1

Overall pass/fail

  • Range: 0 to 1

  • Resolution: 1

Worst case slot number (based on each adjacent timeslot measurement)

  • Range: 1 to 150, 9.91 E+37

  • Resolution: 1

Absolute power (based on each adjacent timeslot measurement)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Relative power (based on each adjacent timeslot measurement)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Worst case slot number (based on Rel Pwr 10 TPC (dB) measurements)

  • Range: 1 to 150, 9.91 E+37

  • Resolution: 1

Absolute power (based on Rel Pwr 10 TPC (dB) measurements)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Relative power (based on Rel Pwr 10 TPC (dB) measurements)

  • Range: -99.0 to +99.0 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

 OUTPUT 714;"FETCh:WILPower:ALL?"

READ:WIQTuning[:ALL]?

Function

Initiates and fetches an IQ tuning measurement as a sequential operation.

Measurement results are returned in the following order: Integrity, RMS EVM, Peak EVM, Frequency Error, Origin Offset, Phase Error, Magnitude Error, Time Error, Peak Code Domain Error, IQ Gain Imbalance, IQ Phase Imbalance.

Query

Integrity

  • Range: 0 to 23

  • Resolution: 1

EVM (RMS)

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.1

EVM (Peak)

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.1

Frequency Error

  • Range: -99.0 to 99.0 kHz, 9.91 E+37

  • Resolution: 0.1

Origin Offset

  • Range: -99.0 to 0.0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Magnitude Error

  • Range: 0.0 to 99.0%, 9.91 E+37

  • Resolution: 0.1

Timing Error

  • Range: -99.99 to 99.99 chips, 9.91 E+37

  • Resolution: 0.01 chips

Peak Code Domain Error

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

IQ Gain Imbalance

  • Range:

  • Resolution:

IQ Phase Imbalance

  • Range:

  • Resolution:

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

 OUTPUT 714;"READ:WIQTuning:ALL?" !Queries the IQ tuning measurement results.

READ:WOBWidth[:ALL]?

Function

Initiates and fetches an occupied bandwidth measurement as a sequential operation.

Measurement results are returned in the following order: integrity, average occupied bandwidth.

If the multi-measurement state is on, the result represents the average of a number of channel power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WOBWidth:COUNt[:SNUMber] .

Query
  • Range: 0.0 to 10.0 MHz
  • Resolution:.0001

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

READ:WOOPower[:ALL]?

Function

Initiates and fetches a PRACH transmit on/off power measurement as a sequential operation.

Measurement results are returned in the following order: Integrity, Pre Burst Off Power level, Pre Burst Off Power pass/fail, Burst On Power, Open Loop Power Error value, Open Loop Power Error pass/fail, Post Burst Off Power level, Post Burst Off Power pass/fail (see PRACH Transmit On/Off Power Measurement Results ).

Query

Integrity

  • Range: 0 to 23

  • Resolution: 1

Pre Burst Off Power level

  • Range: -99.99 to 00.00 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Pre Burst Off Power pass/fail

  • Range: 0 (pass), 1 (fail), 9.91 E+37

Burst On Power

  • Range: -99.99 to 99.99 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Open Loop Power Error value

  • Range: -99.99 to +99.99 dB
  • Resolution: 0.01 dB

Open Loop Power Error pass/fail

  • Range: 0 (pass), 1 (fail), 9.91 E+37

Post Burst Off Power level

  • Range: -99.99 to 00.00 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Post Burst Off Power pass/fail

  • Range: 0 (pass), 1 (fail), 9.91 E+37

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

READ:WPDiscon[:ALL]?

Function

Initiates and fetches a phase discontinuity measurement as a sequential operation.

Measurement results are returned as a comma separated list of values: Integrity Indicator, Number of Steps Measured, Worst Case Phase Discontinuity Step Number, Worst Case Phase Discontinuity in degrees, Worst Case EVM Step Number, Worst Case EVM in % rms.

See Phase Discontinuity Measurement Results .

Query

Integrity Indicator - see Integrity Indicator .

Number of Steps Measured

  • Range: 2 to 91, 9.91E+37
  • Resolution: 1

Worst Case Phase Discontinuity Step Number

  • Range: 0 to 90, 9.91E+37
  • Resolution: 1

Worst Case Phase Discontinuity

  • Range: -180.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Worst Case EVM Step Number

  • Range: 0 to 90, 9.91E+37
  • Resolution: 1

Worst Case EVM

  • Range: 0.0 to 99.0% rms, 9.91E+37
  • Resolution: 0.1% rms

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

 OUTPUT 714;"READ:WPDiscon?"

READ:WPESquality[:ALL]?

Function

Initiates and fetches a perceptual evaluation of speech quality measurement as a sequential operation.

Measurement results are returned in the following order: Integrity, Uplink PESQ Score, Downlink PESQ Score,PESQ Uplink Headroom, PESQ Downlink Headroom.

Query

Integrity Indicator - see Integrity Indicator .

Uplink PESQ Score

  • Range: -0.5 to 4.5, 9.91 E+37
  • Resolution: 0.01

Downlink PESQ Score

  • Range: -0.5 to 4.5, 9.91 E+37
  • Resolution: 0.01

PESQ Uplink Headroom

  • Range: 0.0 to 100.0 dB, 9.91 E+37
  • Resolution: 0.1 dB

PESQ Downlink Headroom

  • Range: 0.0 to 100.0 dB, 9.91 E+37
  • Resolution: 0.1 dB

Requirements

Lab Application Revision: G.00 and above

Programming Example

 OUTPUT 714;"READ:WPESquality?"

READ:WPPAnalysis[:ALL]?

Function

Initiates and fetches a PRACH preamble analysis measurement as a sequential operation.

Measurement results are returned in the following order: Integrity Indicator, EVM (rms) in % rms, EVM (peak) in %, Frequency Error in Hz, Origin Offset in dB, Phase Error (rms) in degrees, Magnitude Error in %, Timing Error in chips, IQ Gain Imbalance in dB, IQ Phase Imbalance in degrees, Signature.

See PRACH Preamble Analysis Measurement Results .

Query

Integrity Indicator - see Integrity Indicator .

EVM (rms)

  • Range: 0.0 to 100.0% rms, 9.91E+37
  • Resolution: 0.1% rms

EVM (peak)

  • Range: 0.0 to 100.0%, 9.91E+37
  • Resolution: 0.1%

Frequency Error

  • Range: -9.999 kHz to +9.999 kHz, 9.91E+37
  • Resolution: 0.1 Hz

Origin Offset

  • Range: -100.0 to 0.0 dB, 9.91E+37
  • Resolution: 0.1 dB

Phase Error

  • Range: -180.0 to +180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Magnitude Error

  • Range: 0.0 to 100.0%, 9.91E+37
  • Resolution: 0.1%

Timing Error

  • Range: -383.62 to +383.62 chips, 9.91E+37
  • Resolution: 0.01 chips

IQ Gain Imbalance

  • Range: -100.0 to 100.0 dB, 9.91E+37
  • Resolution: 0.1 dB

IQ Phase Imbalance

  • Range: -180.0 to 180.0 degrees, 9.91E+37
  • Resolution: 0.1 degrees

Signature

  • Range: 0 to 15, 9.91E+37
  • Resolution: 1

Requirements

Lab Application Revision: B.01 and above

Programming Example

 OUTPUT 714;"READ:WPPAnalysis?"
! Returns Integrity Indicator, EVM (rms) in % rms, EVM (peak) in %,
! Frequency Error in Hz, Origin Offset in dB, Phase Error (rms) in degrees,
! Magnitude Error in %, Timing Error in chips, IQ Gain Imbalance in dB,
! IQ Phase Imbalance in degrees, Signature

READ:WSEMask[:ALL]?

Function

Initiates and fetches a spectrum emissions mask measurement as a sequential operation.

Measurement results are returned in the following order: integrity, overall pass/fail, in-channel power, and pass/fail results for each of the four frequency ranges.

In-channel power is returned in dBm/3.84 MHz.

The four frequency ranges for this measurement are as follows:

  • Range 1: +/- 2.515 to 3.485 MHz
  • Range 2: +/- 4.000 to 7.500 MHz
  • Range 3: +/- 7.500 to 8.500 MHz
  • Range 4: +/- 8.500 to 12.500 MHz

If the multi-measurement state is on, the result represents the average of a number of spectrum emissions measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WSEMask:COUNt[:SNUMber] .

Query

Integrity

  • Range: 0 to 23

Overall Pass/Fail

  • Range: 0|1

In-Channel Power (dBm/3.84 MHz)

  • Range: -99.00 to +99.00 dBm, 9.91 E+37
  • Resolution: 0.01

Range Pass/Fail

  • Range: 0|1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

READ:WSEMask:FAIL?

Function

Initiates and fetches a spectrum emissions mask measurement as a sequential operation.

Measurement results are returned in the following order: integrity, overall pass/fail (0 = Pass, 1 = Fail).

If the multi-measurement state is on, the result represents the average of a number of thermal power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WSEMask:COUNt[:SNUMber] .

Query
  • Range: 0|1

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

READ:WTDPower[:ALL]?

Function

Initiates and fetches a TX dynamic power measurement as a sequential operation.

This query returns 101 comma-separated values, in the order of an integrity value, followed by 100 power results.

This query always returns 101 power results, regardless of how many power measurements were performed by the test set when the measurement was executed. The number of power measurements performed by the test set is equal to the Number of Power Steps setting + 1, and can be queried using the FETCh:WTDPower:COUNt[:STEP]? command. If fewer than 100 power measurements were performed by the test set, the remaining power results are returned as 9.91 E+37.

Query

  • Integrity (see Integrity Indicator )

  • Power

    • Range: -100.00 to 100.00 dBm, 9.91 E+37
    • Resolution: 0.01 dB

Requirements

Test Application Revision: A.07 and above

Lab Application Revision: C.02 and above

READ:WTPower[:ALL]?

Function

Initiates and fetches a thermal power measurement as a sequential operation.

Measurement results are returned in the following order: integrity, thermal transmit power.

If the multi-measurement state is on, the result represents the average of a number of thermal power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WTPower:COUNt[:SNUMber] .

Query
  • Range: -99 to 99 dBm, 9.91 E+37
  • Resolution: 0.01 dB

Requirements

Test or Lab Application Revision: A.01 and above

READ:WWQuality[:ALL]?

Function

Initiates and fetches the waveform quality measurements as a sequential operation.

Measurement results are returned in the following order: integrity, EVM maximum, frequency error worst case, origin offset maximum, phase error maximum, magnitude error maximum.

If the multi-measurement state is on, each result represents the average of a number of waveform quality measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WWQuality:COUNt[:SNUMber] .

Query

Integrity

  • Range: 0 to 16

  • Resolution: 1

EVM Maximum

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Frequency Error worst case

  • Range-99.99 to 99.99 kHz, 9.91 E+37

  • Resolution: 0.1

Origin Offset Maximum

  • Range: -99 to 0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error Maximum

  • Range: 0 to 180 degrees, 9.91 E+37

  • Resolution: 0.1

Magnitude Error Maximum

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.1

Requirements

Test or Lab Application Revision: A.01 and above


READ? Subsystem

READ? Subsystem

Last updated: January 16, 2009

Syntax Diagram and Command Descriptions

READ

Description

The READ? command provides a sequential method to make measurements and retrieve the results. READ? will hang the GPIB bus until the measurement is completed, or until the timeout value has been exceeded. Associated SETup commands (for each measurement) are used with the READ? command to retrieve desired measurement results in a sequential manner.

Sending a READ? command is equivalent to an INITiate/FETCh cycle for a measurement. A READ? command executes an abort action on that measurement followed by an INITiate and a FETCH?.

READ? commands can be mixed with FETCH? queries in order to make combinations of sequential and overlapped operations. One measurement can be issued a READ? command (sequential), and the next measurement can be issued INITiate/FETCh? commands (overlapped), if necessary.

The advantage of using the READ? commands to obtain measurement results, as opposed to the INITiate/FETCh method is:

  • It is simpler. Fewer commands are required to obtain measurement results.

Some disadvantages of using READ? over INITiate and FETCh are:

  • The test set does not process any additional GPIB commands until the requested measurement results are available.
  • The sequential nature of the READ? command does not allow the user to make concurrent measurements. Concurrent measurements require the overlapped commands INITiate, DONE? and FETCh? .
  • The READ? command does not provide measurement results such as statistics that are available using the INITiate/FETCh method.
  • The READ? commands have pre-defined measurement results. If additional results are needed from a measurement they may be obtained with a FETCh? query.

NOTE
Trigger arming for each measurement is controlled in the SETup subsystem. Best practice during remote operation is to set trigger arm to single (Continuous Off).

Program Example - READ:WTPower?

OUTPUT 714;"READ:WTPower?" !Starts a thermal power measurement. As soon as the
                           !measurement cycle has completed, the test set
                           !provides the thermal power measurement results to the
                           !controlling application.
ENTER 714;Integrity, Thermal_power !Enters the integity indicator and the
                                      !thermal power measurement values into
                                      !the controlling application.


RFANalyzer

RFANalyzer

Last updated: January 16, 2009

GPIB Command Conventions

  • RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO
  • RFANalyzer:CONTrol:POWer:AUTO
  • RFANalyzer:CONTrol:UPLink:FREQuency:AUTO

  • RFANalyzer:CW:EXPected:POWer

  • RFANalyzer:MANual:POWer[:SELected]
  • RFANalyzer:MANual:POWer:FDD
  • RFANalyzer:MANual:MEASurement[:MFRequency]
  • RFANalyzer:MANual:MEASurement:FREQuency
  • RFANalyzer:MANual:UPLink[:MFRequency]
  • RFANalyzer:MANual:UPLink:FREQuency

RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO

Function

Turns on/off the auto Measurement Frequency feature which determines the measurement downconverter signal path frequency control mode. (See Block Diagram .)

ON = automatic

OFF = manual (see RFANalyzer:MANual:MEASurement[:MFRequency] and RFANalyzer:MANual:MEASurement:FREQuency )

Note, when you switch between operating modes, Measurement Frequency is returned to its default value of Auto .

Setting

 Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO OFF"
!Enables manual control of the measurement signal path tune frequency.

RFANalyzer:CONTrol:POWer:AUTO

Function

Sets/queries Power Control .

ON = automatic

OFF = manual (see RFANalyzer:MANual:POWer[:SELected] )

This command is available in Active Cell , FDD Test and Cell Off operating modes.

Note, when you switch between operating modes, Power Control is returned to its default value of Auto .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:CONTROL:POWER:AUTO OFF"

!Enables manual control of the expected input power level.

RFANalyzer:CONTrol:UPLink:FREQuency:AUTO

Function

Turns on/off the auto Uplink Frequency feature, which determines the test set's demodulation signal path tune frequency control mode.

ON = automatic

OFF = manual (see RFANalyzer:MANual:UPLink[:MFRequency] and RFANalyzer:MANual:UPLink:FREQuency .

This setting is available in FDD Test and CW operating modes.

Note, when you switch between operating modes, Uplink Frequency is returned to its default value of Auto .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:CONTROL:UPLINK:FREQUENCY:AUTO OFF" !Enables manual control of the demodulation signal path tune frequency.

RFANalyzer:CW:EXPected:POWer

Function

Sets/queries the expected CW receiver input power. This setting is only used when the Operating Mode is set to CW. (See CALL:OPERating .)

Setting

Range: -60 dBm to +53 dBm

Query

Range: -60 dBm to +53 dBm
*RST setting +13 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:CW:EXPECTED:POWER -20"

RFANalyzer:MANual:POWer[:SELected]

Function

Sets/queries Manual Power (the optional [:SELected] keyword in this command specifies that the manual power setting applies to the current system type). This command is only applicable when RFANalyzer:CONTrol:POWer:AUTO ( Power Control ) is set to Off (manual).

This command is available in Active Cell , FDD Test and Cell Off operating modes.

Note, when you switch between operating modes, Power Control is returned to its default value of Auto .

Setting

Range: Test application and system type dependent (approximately -25 to +43 dBm).

Resolution: 0.01 dBm

Query

 Range: Test application and system type dependent (approximately -25 to +43 dBm).
*RST setting -75 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:POWER:SELECTED 24 DBM" !Sets the manual power control mode expected input power level for the currently selected system type to 24 dBm.

RFANalyzer:MANual:POWer:FDD

Function

Sets/queries Manual Power when UTRA FDD is the current system type. This command is only applicable when RFANalyzer:CONTrol:POWer:AUTO ( Power Control ) is set to Off (manual).

This command is available in Active Cell , FDD Test and Cell Off operating modes.

Note, when you switch between operating modes, Power Control is returned to its default value of Auto .

Setting

Range: -129 to +80 dBm (-79 dBm to +30 dBm actual hardware range with amplitude offset = 0)

Resolution: 0.01 dBm

Query

 Range: -129 to +80 dBm (-79 dBm to +30 dBm actual hardware range with amplitude offset = 0)
*RST setting 0 dBm

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:POWER:FDD 24 DBM"
!Sets the manual power control mode expected input power level for the FDD system type to
!24 dBm.

RFANalyzer:MANual:MEASurement[:MFRequency]

Function

The setting form of this command performs two functions: (1) sets Measurement Frequency , the tune frequency of the test set's measurement signal path, and (2) selects manual (auto off) tune mode for the test set's measurement signal path.

The query form of this command returns the tune frequency of the test set's measurement signal path.

The tune mode for the test set's measurement signal path can be returned to auto using the RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO command.

Note, when you switch between operating modes, Measurement Frequency is returned to its default value of Auto .

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

 Range: 292.5 MHz to 2700 MHz
*RST setting 896 MHz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:MEASUREMENT:MFREQUENCY 942.6 MHZ"
!Enables manual control of the measurement signal path tune frequency and sets the tune frequency to 942.6 MHz.

RFANalyzer:MANual:MEASurement:FREQuency

Function

Sets/queries Measurement Frequency .

This setting is applied when manual mode is selected for Measurement Frequency (see RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO ).

Note, when you switch between operating modes, Measurement Frequency is returned to its default value of Auto .

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

 Range: 292.5 MHz to 2700 MHz
*RST setting 896 MHz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:MEASUREMENT:FREQUENCY 942.6 MHZ"
!Sets the measurement signal path tune frequency to 942.6 MHz when manual control mode is used.

RFANalyzer:MANual:UPLink[:MFRequency]

Function

The setting form of this command performs two functions: (1) sets Uplink Frequency , the tune frequency of the test set's demodulation signal path, and (2) selects manual (auto off) tune mode for the test set's demodulation signal path.

The query form of this command returns the tune frequency of the test set's demodulation signal path.

The tune mode for the test set's demodulation path can be returned to auto using the RFANalyzer:CONTrol:UPLink:FREQuency:AUTO command.

This setting is available in FDD Test and CW operating modes.

Note, when you switch between operating modes, Uplink Frequency is returned to its default value of Auto .

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

 Range: 292.5 MHz to 2700 MHz
*RST setting 896 MHz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:UPLINK:MFREQUENCY 1955.030 MHZ"

!Enables manual control of the demodulation signal path tune frequency and sets the tune frequency
!to 1955.030 MHz.

RFANalyzer:MANual:UPLink:FREQuency

Function

Sets/queries Uplink Frequency .

This setting is applied when manual mode is selected for Uplink Frequency (see RFANalyzer:CONTrol:UPLink:FREQuency:AUTO ).

This setting is available in FDD Test and CW operating modes.

Note, when you switch between operating modes, Uplink Frequency is returned to its default value of Auto .

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

Range: 292.5 MHz to 2700 MHz
*RST setting 896 MHz

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:UPLINK:FREQUENCY 942.6 MHZ"
!Sets the test set's demodulation signal path tune frequency to 942.6 MHz.


RFANalyzer Subsystem

RFANalyzer Subsystem

Last updated: January 16, 2009

Description

The RFANalyzer command subsystem performs "lower-level" functions that control the test set's measuring receiver. The measuring receiver includes three separate signal paths:

  • Power detector
  • Demodulation
  • Measurement

Refer to the Block Diagram for a description of the signal paths.

The RFANalyzer commands allow manual settings to the tune frequency or expected power level to each of these paths if it is necessary to override automatic settings.

Syntax Diagrams and Command Descriptions

RFANalyzer


RFGenerator: OUTPut

RFGenerator: OUTPut

Last updated: January 16, 2009

GPIB Command Conventions

  • RFGenerator:OUTPut[:DESTination]

RFGenerator:OUTPut[:DESTination]

Function

Sets/queries the RF output port destination: RF IN/OUT (IO) or RF OUT ONLY (OUT).

If the correct hardware is not installed when trying to change to the RF OUT ONLY port, the test set displays the following error: Hardware error; RFIO version does not support RF out only selection.

The query form will always return a value, regardless of the hardware version.

Setting

Range: IO | OUT

Query

Range: IO |OUT

*RST Setting

 IO

Requirements

Test or Lab Application Revision: A.01 and above

Hardware: RF Input/Output module with second RF output connector, modified front panel.

Programming Example

OUTPUT 714;"RFGenerator:OUTPut OUT"
!Sets the RF generator's output destination to the RF Out Only port.


RFGenerator Subsystem

RFGenerator Subsystem

Last updated: January 16, 2009

Description

The RFGenerator subsystem selects the RF generator output port on test sets equipped with both the RF IN/OUT port and the RF OUT ONLY port. If the test set does not have the RF OUT ONLY port, an error message is generated when attempting to switch output ports.

The RF OUT ONLY port may not be used with some test applications or lab applications. In that case, a message is displayed that tells you that the port could not be switched.

Syntax Diagrams and Command Descriptions

RFGenerator: OUTPut


SETup:AFANalyzer

SETup:AFANalyzer

Last updated: May 10, 2010

GPIB Command Conventions

  • SETup:AFANalyzer:CONTinuous

  • SETup:AFANalyzer:COUNt[:SNUMber]
  • SETup:AFANalyzer:COUNt:NUMBer
  • SETup:AFANalyzer:COUNt:STATe

  • SETup:AFANalyzer:DEMPhasis:STATe

  • SETup:AFANalyzer:DETector[:TYPE]

  • SETup:AFANalyzer:EXPandor[:SRLevel]
  • SETup:AFANalyzer:EXPandor:RLEVel
  • SETup:AFANalyzer:EXPandor:STATe

  • SETup:AFANalyzer:FILTer[:TYPE]
  • SETup:AFANalyzer:FILTer:TBPass[:FREQuency]

  • SETup:AFANalyzer:FREQuency:STATe

  • SETup:AFANalyzer:PEAK:VOLTage

  • SETup:AFANalyzer:SDIStortion:FREQuency
  • SETup:AFANalyzer:SDIStortion:STATe

  • SETup:AFANalyzer:TIMeout[:STIMe]
  • SETup:AFANalyzer:TIMeout:STATe
  • SETup:AFANalyzer:TIMeout:TIME

SETup:AFANalyzer:CONTinuous

Function

Sets/queries the trigger arm state for the AF analyzer measurement. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:AFANalyzer:COUNt[:SNUMber]

Function

Sets/queries the number of AF analyzer measurements to be made in a multi-measurement setup. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:AFANalyzer:COUNt:NUMBer

Function

Sets/queries the number of AF analyzer measurements to be made when multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:COUNT:NUMBER 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:AFANalyzer:COUNt:STATe

Function

Sets/queries the multi-measurement state of the AF analyzer measurement.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:COUNT:STATE ON" !Turns on multi-measurements.

SETup:AFANalyzer:DEMPhasis:STATe

Function

Sets/queries whether 750 us de-emphasis is enabled.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:DEMPHASIS:STATE ON"

SETup:AFANalyzer:DETector[:TYPE]

Function

Sets/queries the detector type for audio level measurements.

Setting

Range: RMS|PEAK

Query

Range: RMS|PEAK

*RST setting

RMS

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:DETECTOR:TYPE PEAK"

SETup:AFANalyzer:EXPandor[:SRLevel]

Function

Sets/queries the expandor's reference level and automatically sets the expandor's state to ON.

Setting

Range: 10 mV to 10 V

Resolution: 1 mV

Query

Range: 10 mV to 10 V

*RST setting

1 V

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:EXPANDOR:SRLEVEL 5V"
!Sets expandor state to on and level to 5 V.

SETup:AFANalyzer:EXPandor:RLEVel

Function

Sets/queries the expandor's reference level to be used when the expandor's state is set to ON.

Setting

Range: 10 mV to 10 V

Resolution: 1 mV

Query

Range: 10 mV to 10 V

*RST setting

1 V

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:EXPANDOR:RLEVEL 5V" !Sets expandor reference level to 5 V.

SETup:AFANalyzer:EXPandor:STATe

Function

Sets/queries whether the expandor is enabled.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:EXPANDOR:STATE ON"

SETup:AFANalyzer:FILTer[:TYPE]

Function

Sets/queries the filter type for audio measurements. Filter choices are as follows: 100 Hz tunable bandpass filter (TBP), C-message filter (CMES), 50 Hz to 15 kHz bandpass filter (BPAS50), 300 Hz to 15 kHz bandpass filter (BPAS300).

Setting

Range: NONE|TBPass|CMESsage|BPASs50|BPASs300

Query

Range: NONE|TBP|CMES|BPAS50|BPAS300

*RST setting

NONE

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:FILTER:TYPE BPASS50"
!Selects the 50 Hz to 15 kHz bandpass filter.

SETup:AFANalyzer:FILTer:TBPass[:FREQuency]

Function

Sets/queries the center frequency for the 100 Hz tunable bandpass filter (TBPass).

Setting

Range: 300.0 to 20000 Hz

Resolution: 0.1

Query

Range: 300.0 to 20000 Hz

*RST setting

1000

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

10 OUTPUT 714;"SETUP:AFANALYZER:FILTER:TBPASS:FREQUENCY 300HZ"

SETup:AFANalyzer:FREQuency:STATe

Function

Sets/queries whether the audio frequency measurement is enabled.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:FREQUENCY:STATE ON"

SETup:AFANalyzer:PEAK:VOLTage

Function

Sets/queries the expected peak voltage for audio measurements.

Setting

Range: 0.001 to 20 Vpk

Resolution: 0.001

Query

Range: 0.001 to 20 Vpk

*RST setting

20

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

10 OUTPUT 714;SETUP:AFANALYZER:PEAK:VOLTAGE 10V"

SETup:AFANalyzer:SDIStortion:FREQuency

Function

Sets/queries the fundamental frequency setting for the SINAD/distortion measurement.

Setting

Range: 100.0 to 10000 Hz

Resolution: 0.1

Query

Range: 100.0 to 10000 Hz

*RST setting

1000

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

10 OUTPUT 714;SETUP:AFANALYZER:SDISTORTION:FREQUENCY 300HZ"

SETup:AFANalyzer:SDIStortion:STATe

Function

Sets/queries whether the SINAD/distortion measurement is enabled.

Setting

Range: 1|0N|0|OFF

Query

Range: 1|0

*RST setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

10 OUTPUT 714;SETUP:AFANALYZER:SDISTORTION:STATE ON"

SETup:AFANalyzer:TIMeout[:STIMe]

Function

Sets/queries the AF analyzer measurement's timeout setting and automatically sets the timeout state to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, on

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:TIMEOUT:STIME 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:AFANalyzer:TIMeout:STATe

Function

Sets/queries the AF analyzer measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:TIMEOUT:STATE ON"

SETup:AFANalyzer:TIMeout:TIME

Function

Sets/queries the AF analyzer measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:TIMEOUT:TIME 5S"


SETup:CONTinuous

SETup:CONTinuous

Last updated: January 16, 2009

GPIB Command Conventions

  • SETup[:ALL]:CONTinuous

SETup[:ALL]:CONTinuous

Function

Sets/queries the trigger arm state for all measurements. Determines whether all measurements will make one measurement then stop (OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (ON (continuous)).

This setting overrides previously set trigger arm settings for individual measurements.

Setting

Range: ON, OFF

Programming Example

OUTPUT 714;"SETup:ALL:CONTinuous:OFF" !Sets all measurements to single trigger mode.


SETup:CFDTune

SETup:CFDTune

Last updated: January 7, 2012

This section is only applicable to the lab application or feature-licensed test application.

GPIB Command Conventions

  • SETup:CFDTune:FREQuency:STEP:COUNt

  • SETup:CFDTune:MS:RX:FREQuency:STEP[:VALues]
  • SETup:CFDTune:MS:RX:FREQuency:STEP:STARt:[INDex]
  • SETup:CFDTune:MS:RX:MODulation:STATe
  • SETup:CFDTune:MS:RX:POWer:STEP[:LEVels]
  • SETup:CFDTune:MS:RX:POWer:STEP:STARt:[INDex]

  • SETup:CFDTune:MS:TX:FREQuency:STEP[:VALues]
  • SETup:CFDTune:MS:TX:FREQuency:STEP:STARt:[INDex]
  • SETup:CFDTune:MS:TX:POWer:STEP[:LEVels]
  • SETup:CFDTune:MS:TX:POWer:STEP:STARt:[INDex]

  • SETup:CFDTune:POWer:STEP:COUNt
  • SETup:CFDTune:POWer:STEP:LENGth

  • SETup:CFDTune:TIMeout[:STIMe]
  • SETup:CFDTune:TIMeout:STATe
  • SETup:CFDTune:TIMeout:TIME

SETup:CFDTune:FREQuency:STEP:COUNt

Function

Sets/queries the Number of Frequency Steps .

Setting

Range: 1 to 20

Resolution: 1

Query

Range: 1 to 20

*RST Setting

5

Requirement

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"SETup:CFDTune:FREQuency:STEP:COUNt 10"
!Sets the number of frequency steps to 10.

SETup:CFDTune:MS:RX:FREQuency:STEP[:VALues]

Function

Sets/queries the MS RX Frequency Step Values .

If you set fewer than 40 values, the remaining values are set to NAN (9.91E+37).

Setting

Range:

Although you can enter any frequencies between 421 and 2170 MHz, when running the Fast Device Tune measurement in the W-CDMA/HSDPA application/format, you can only test frequencies within a single W-CDMA/HSDPA frequency band range:

  • 723 to 773 MHz (Bands XII, XIII, and XIV)
  • 864 to 899 MHz (Bands V and VI)
  • 920 to 965 MHz (Band VIII)
  • 1471 to 1506 MHz (Band XI)
  • 1800 to 1885 MHz (Bands III and IX)
  • 1925 to 1995 MHz (Band II)
  • 2105 to 2175 (Bands I, IV, and X)
  • 2615 to 2695 MHz (Band VII)

Resolution: 1 Hz

Query

 Same as setting

*RST Setting

1933.0MHz, 1933.2MHz, 1933.4MHz, 1933.6MHz, 1933.8MHz, 1934.0MHz, 1934.2MHz, 1934.4MHz, 1934.6MHz, 1934.8MHz, 1935.0MHz, 1935.2MHz, 1935.4MHz, 1935.6MHz, 1935.8MHz, 1936.0MHz, 1936.2MHz, 1936.4MHz, 1936.6MHz, 1936.8MHz, 872.0MHz, 872.2MHz, 872.4MHz, 872.6MHz, 872.8MHz, 873.0MHz, 873.2MHz, 873.4MHz, 873.6MHz, 873.8MHz, 874.0MHz, 874.2MHz, 874.4MHz, 874.6MHz, 874.8MHz, 875.0MHz, 875.2MHz, 875.4MHz, 875.4MHz, 875.6MHz, 875.8MHz

Requirement

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 or D.00.04 and above.

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, added 2622.4 to 2687.6 MHz (Band VII)

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:RX:FREQuency:STEP 1932.4 MHz, 1937.4 MHz, 1942.4 MHz, 1947.4 MHz,
1952.4 MHz"
! Sets MS RX Frequency Step Values to 1932.4 MHz, 1937.4 MHz, 1942.4 MHz, 1947.4 MHz,
! 1952.4 MHz, followed by 35 NANs (9.91E+37)

SETup:CFDTune:MS:RX:FREQuency:STEP:STARt:[INDex]

Function

 Sets/queries the MS RX Frequency Step Start Index .

Setting

Range: 0 to 39

Resolution: 1

Query

 Same as setting

*RST Setting

0

Requirement

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:RX:FREQuency:STEP:STARt 6"
!Sets the MS RX Frequency Step Start Index to 6.

SETup:CFDTune:MS:RX:MODulation:STATe

Function

Sets/queries the Fast Device Tune MS Rx Signal Modulation State.

This setting is used to determine the downlink signal modulation state. If this setting is 'ON', the downlink signal is generating the modulated signal. If this setting is 'OFF', the downlink signal generated without modulation that is CW signal.

This setting is applied only when the FDT measurement is initiated, and when the measurement is finished, the downlink modulation state will return back to ON.

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 1

Requirement

 Test Application Revision: A.19.00 and above

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:RX:MODulation:STATe"

SETup:CFDTune:MS:RX:POWer:STEP[:LEVels]

Function

Sets/queries the MS RX Power Step Levels .

If you set fewer than 40 values, the remaining values are set to NAN (9.91E+37).

Setting

Range:

Although you can enter any power levels between -165 and 37 dBm, when running the Fast Device Tune measurement in the W-CDMA/HSDPA application/format, the test set can only transmit test power levels in the range of -115 to -13 dBm ( RF IN/OUT ) or -115 to -5 dBm ( RF OUT ONLY ). These ranges assume an amplitude offset of 0; the allowable ranges change as you change amplitude offsets, see Cell Power, AWGN Power and Total RF Power Ranges .

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15.0dBm, -20.0dBm, -25.0dBm, -30.0dBm, -35.0dBm, -40.0dBm, -45.0dBm, -50.0dBm, -55.0dBm, -60.0dBm, -65.0dBm, -70.0dBm, -75.0dBm, -80.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm

Requirement

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 or D.00.04 and above.

Test Application Revision A.10 and Lab Application D.01, added support for RF OUT ONLY port.

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:RX:POWer:STEP -16, -20, -30, -40, -50,-60, -70, -80, -90, -100"
! Sets MS RX Power Step Levels to -16, -20, -30, -40, -50,-60, -70, -80, -90, -100 dBm,
! followed by 30 NANs (9.91E+37).

SETup:CFDTune:MS:RX:POWer:STEP:STARt:[INDex]

Function

 Sets/queries the MS RX Power Step Start Index .

Setting

Range: 0 to 39

Resolution: 1

Query

 Same as setting

*RST Setting

0

Requirement

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:RX:POWer:STEP:STARt 6"
!Sets the MS RX Power Step Start Index to 6.

SETup:CFDTune:MS:TX:FREQuency:STEP[:VALues]

Function

Sets/queries the MS TX Frequency Step Values .

If you set fewer than 40 values, the remaining values are set to NAN (9.91E+37).

Setting

Range:

Although you can enter any frequencies between 411 and 1980 MHz, when running the Fast Device Tune measurement in the W-CDMA/HSDPA application/format, you can only test frequencies within a single W-CDMA/HSDPA frequency band range:

  • 693 to 803 MHz (Bands XII, XIII, and XIV)
  • 819 to 854 MHz (Bands V and VI)
  • 875 to 920 MHz (Band VIII)
  • 1423 to 1458 MHz (Band XI)
  • 1705 to 1790 MHz (Bands III, IV, IX, and X)
  • 1845 to 1915 MHz (Band II)
  • 1915 to 1985 (Band I)
  • 2495 to 2575 MHz (Band VII)

Resolution: 1 Hz

Query

 Same as setting

*RST Setting

1853.0MHz, 1853.2MHz, 1853.4MHz, 1853.6MHz, 1853.8MHz, 1854.0MHz, 1854.2MHz, 1854.4MHz, 1854.6MHz, 1854.8MHz, 1855.0MHz, 1855.2MHz, 1855.4MHz, 1855.6MHz, 1855.8MHz, 1856.0MHz, 1856.2MHz, 1856.4MHz, 1856.6MHz, 1856.8MHz, 827.0MHz, 827.2MHz, 827.4MHz, 827.6MHz, 827.8MHz, 828.0MHz, 828.2MHz, 828.4MHz, 828.6MHz, 828.8MHz, 829.0MHz, 829.2MHz, 829.4MHz, 829.6MHz, 829.8MHz, 830.0MHz, 830.2MHz, 830.4MHz, 830.6MHz, 830.8MHz,
(the first 20 values default for US Cellular band and the last 20 values default for US PCS band)

Requirement

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 or D.00.04 and above.

Test Application Revision A.11 and Lab Application Revisions D.02 and E.00, added 2502.4 to 2567.6 MHz (Band VII)

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:TX:FREQuency:STEP 882.4 MHz, 893.4 MHz, 898.4 MHz, 903.4 MHz,
908.4 MHz"
! Sets MS TX Frequency Step Values to 882.4 MHz, 893.4 MHz, 898.4 MHz, 903.4 MHz,
908.4 MHz, followed by 35 NANs (9.91E+37)

SETup:CFDTune:MS:TX:FREQuency:STEP:STARt:[INDex]

Function

 Sets/queries the MS TX Frequency Step Start Index .

Setting

Range: 0 to 39

Resolution: 1

Query

 Same as setting

*RST Setting

0

Requirement

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:TX:FREQuency:STEP:STARt 6"
!Sets the MS TX Frequency Step Start Index to 6.

SETup:CFDTune:MS:TX:POWer:STEP[:LEVels]

Function

Sets/queries the MS TX Power Step Levels .

If you set fewer than 40 values, the remaining values are set to NAN (9.91E+37).

Setting

Range:

Although you can enter any power levels between -129 and +80 dBm (because this measurement is common to the W-CDMA/HSDPA, 1xEV-DO and cdma2000 formats), when running the Fast Device Tune measurement in the W-CDMA/HSDPA application/format, you can only measure power levels in the range of -70 to +30 dBm and the measurement is only specified for power levels in the range of -61 to +28 dBm (these ranges assume an amplitude offset of 0; the ranges change as you change amplitude offsets, see Amplitude Offset ).

Resolution: 0.01

Query

 Same as setting

*RST Setting

 12.0dBm, 7.0dBm, 2.0dBm, -8.0dBm, -13.0dBm, -18.0dBm, -23.0dBm, -28.0dBm, -33.0dBm, -38.0dBm, -43.0dBm, -48.0dBm, -53.0dBm, -58.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm

Requirement

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:TX:POWer:STEP 20, 16, 12, 8, 4, 0, -4, -8, -12, -16, -20, -30,
-40, -50"
! Sets Rx Power Step Levels to 20, 16, 12, 8, 4, 0, -4, -8, -12, -16, -20, -30, -40, -50,
! followed by 26 NANs (9.91E+37).

SETup:CFDTune:MS:TX:POWer:STEP:STARt:[INDex]

Function

 Sets/queries the MS TX Power Step Start Index .

Setting

Range: 0 to 39

Resolution: 1

Query

 Same as setting

*RST Setting

0

Requirement

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:TX:POWer:STEP:STARt 6"
!Sets the MS TX Power Step Start Index to 6.

SETup:CFDTune:POWer:STEP:COUNt

Function

Sets/queries the Number of Power Steps .

Setting

Range: 1 to 40

Resolution: 1

Query

Range: 1 to 40

*RST Setting

10

Requirement

Test Application Revision: A.09 and above, with the required feature license
Lab Application Revision: C.04 or D.00.04 and above.
Test Application Revision: A.13 and above, extended the range from 20 to 40
Lab Application Revision: E.01 and above, extend the range from 20 to 40

Programming Example

OUTPUT 714;"SETup:CFDTune:POWer:STEP:COUNt 15"
!Sets the number of power steps to 15.

SETup:CFDTune:POWer:STEP:LENGth

Function

Sets/queries the Power Step Length.

Setting

Range: MS20|MS10

Query

Range: MS20|MS10

*RST Setting

MS20

Requirement

Test Application Revision: A.13 and above, with the required feature license

Lab Application Revision: E.01 and above.

Programming Example

OUTPUT 714;"SETup:CFDTune:POWer:STEP:LENGth MS20"
!Sets the power step length to 20 ms.

SETup:CFDTune:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the Fast Device Tune measurement's timeout (see Measurement Timeouts ) value, and (2) sets the Fast Device Tune measurement's timeout state to 1 (on).

The query form returns the Fast Device Tune measurement's timeout value.

See Fast Device Tune Measurement Description .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirement

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"SETup:CFDTune:TIMeout 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:CFDTune:TIMeout:STATe

Function

 Sets/queries Fast Device Tune measurement's timeout state (see Measurement Timeouts ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirement

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"SETup:CFDTune:TIMeout:STATe ON"

SETup:CFDTune:TIMeout:TIME

Function

 Sets/queries Fast Device Tune measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirement

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 or D.00.04 and above.

Programming Example

OUTPUT 714;"SETup:CFDTune:TIMeout:TIME 5S"


SETup Subsystem

SETup Subsystem

Last updated: January 5, 2010

Description

The SETup subsystem is used to configure the test set for each measurement. Typical settings include:

  • Multi-Measurement Count, how many measurements will be made each time a measurement is initiated.
  • Trigger Arm, determines if a measurement will make one measurement then return to idle (single), or automatically rearm on completion of a measurement and repeat the process (continuous).
  • Trigger Source, how a measurement is triggered.
  • Trigger Delay, controls the delay time between the trigger and the start of sampling.
  • Measurement Timeout, length of time before a measurement times out.

NOTE
Trigger arming for each measurement is controlled in the SETup subsystem. The choices are single or continuous. In most cases, it is a best practice (during remote operation) to use "single" measurement mode. This simplifies the tasks of starting concurrent measurements, using the INIT subsystem commands to determine which measurements are ready to be fetched, then using the FETCh subsystem to obtain results. The command "SETup:CONTinuous:OFF sets all measurements to "single" trigger mode.

Syntax Diagrams and Command Descriptions

SETup:CONTinuous

SETup:AFANalyzer (AF Analyzer measurements)

SETup:CFDTune (Fast Device Tune measurement) lab application or feature-licensed test application only

SETup:EVMQpsk (QPSK EVM measurement)

SETup:FSTability (Frequency Stability measurement)

SETup:HBLerror (HSDPA Block Error Ratio) lab application or feature-licensed test application only

SETup:HRCQuality (HSDPA Reporting of Channel Quality Indicator measurement) lab application only
SETup:SAUDio (Swept Audio measurement)

SETup:SMONitor (Spectrum Monitor measurements)

SETup:WACLeakage (Adjacent Channel Leakage measurements)

SETup:WBERror (Loopback Bit Error Ratio measurements)
SETup:WBLerror (Loopback Block Error Ratio measurement)

SETup:WCDomain (Code Domain measurement)

SETup:WCPower (Channel Power measurement)

SETup:WCTFormat (Change Of TFC) lab application only

SETup:WDPAnalysis (Dynamic Power Analysis measurement)

SETup:WEDPower (Extended Range Dynamic Power measurement)

SETup:WILPower (Inner Loop Power measurement)

SETup:WIQTuning (IQ Tuning measurement)

SETup:WOBWidth (Occupied Bandwidth measurement)

SETup:WOOPower (PRACH Transmit On/Off Power measurements

SETup:WOOSynch (Out-of-Synch Handling of Output Power) lab application only

SETup:WPDiscon (Phase Discontinuity measurement)
SETup:WPESquality (Perceptual Evaluation of Speech Quality measurement)
SETup:WPPAnalysis (PRACH Preamble Analysis measurement) lab application only

SETup:WSEMask (Spectrum Emission Mask measurement)
SETup:WTDPower (TX Dynamic Power measurement)

SETup:WTPower (Thermal Power measurement)

SETup:WWQuality (Waveform Quality measurement)


SETup:EVMQpsk

SETup:EVMQpsk

Last updated: May 10, 2010

GPIB Command Conventions

  • SETup:EVMQpsk:CONTinuous

  • SETup:EVMQpsk:COUNt[:SNUMber]
  • SETup:EVMQpsk:COUNt:NUMBer
  • SETup:EVMQpsk:COUNt:STATe

  • SETup:EVMQpsk:INTerval

  • SETup:EVMQpsk:OOFFset

  • SETup:EVMQpsk:TIMeout[:STIMe]
  • SETup:EVMQpsk:TIMeout:STATe
  • SETup:EVMQpsk:TIMeout:TIME

  • SETup:EVMQpsk:TRIGger:DELay
  • SETup:EVMQpsk:TRIGger:SOURce

SETup:EVMQpsk:CONTinuous

Function

Sets/queries the trigger arm state for the QPSK EVM measurement. The trigger arm state determines whether the QPSK EVM measurement will be made once then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"SETup:EVMQpsk:CONTinuous OFF"
!Sets measurement to single trigger mode.

SETup:EVMQpsk:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of QPSK EVM measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of QPSK EVM multi-measurements to be made when multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"SETup:EVMQpsk:COUNt:SNUMber 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:EVMQpsk:COUNt:NUMBer

Function

Sets/queries the number of QPSK EVM measurements to be made when the multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"SETup:EVMQpsk:COUNt:NUMBer 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:EVMQpsk:COUNt:STATe

Function

Sets/queries the multi-measurement state of the QPSK EVM measurement.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"SETup:EVMQpsk:COUNt:STATe ON"
! Turns on multi-measurements.

SETup:EVMQpsk:INTerval

Function

Sets/queries the measurement interval.

Setting

Range: 333.333 us to 2 ms (corresponding range is half of WCDMA DPDCH slot to one subframe of HS-DPCCH channel)

Resolution: 1 ns

Query

 Same as setting

*RST Setting

 666.667 us (This value corresponds to one WCDMA DPDCH slot).

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"SETup:EVMQpsk:INTerval 666.667US"
! Sets Measurement Interval to 666.667 us.

SETup:EVMQpsk:OOFFset

Function

Sets/queries whether or not to include the original offset from the evaluated signal before calculating the EVM.

Setting

Range: INCLude|EXCLude

Query

Range: INCL|EXCL

*RST Setting

 INCL (include)

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"SETup:EVMQpsk:OOFFset INCLude"
! Sets to include the original offset before calculating EVM.

SETup:EVMQpsk:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the QPSK EVM measurement's timeout value, and (2) sets the QPSK EVM measurement's timeout STATe to 1 (on).

The query form returns the QPSK EVM measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"SETup:EVMQpsk:TIMeout 5S"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:EVMQpsk:TIMeout:STATe

Function

Sets/queries the QPSK EVM measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"SETup:EVMQpsk:TIMeout:STATe ON"

SETup:EVMQpsk:TIMeout:TIME

Function

Sets/queries the QPSK EVM measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"SETup:EVMQpsk:TIMeout:TIME 5S"

SETup:EVMQpsk:TRIGger:DELay

Function

 Sets/queries the trigger delay. This setting can be used to delay the measurement trigger in order to start a measurement during a specific timeslot in the frame. For example, a 1.333 ms delay would cause the trigger to wait until after the first two timeslots have elapsed.

Setting

Range: -10 to 10 milliseconds

Resolution: 1 nanosecond

Query

Same as setting

*RST Setting

 0 seconds

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"SETup:EVMQpsk:TRIGger:DELay 1MS"

SETup:EVMQpsk:TRIGger:SOURce

Function

Sets/queries the trigger source.

Setting

Range: IMMediate|EXTernal

Query

Range: IMM|EXT

*RST Setting

 IMMediate

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"SETup:EVMQpsk:TRIGger:SOURce IMMediate"


SETup:FSTability

SETup:FSTability

May 10, 2010

GPIB Command Conventions

  • SETup:FSTability:CONTinuous

  • SETup:FSTability:COUNt[:SNUMber]
  • SETup:FSTability:COUNt:NUMBer
  • SETup:FSTability:COUNt:STATe

  • SETup:FSTability:TIMeout[:STIMe]
  • SETup:FSTability:TIMeout:STATe
  • SETup:FSTability:TIMeout:TIME

SETup:FSTability:CONTinuous

Function

Sets/queries the trigger arm state for the frequency stability measurement. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:CONTINUOUS ON"
!Sets measurement to continuous trigger mode.

SETup:FSTability:COUNt[:SNUMber]

Function

Sets/queries the number of frequency stability measurements to be made in a multi-measurement setup. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

10, on
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:FSTability:COUNt:NUMBer

Function

Sets/queries the number of frequency stability measurements to be made when milt-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:COUNT:NUMBER 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:FSTability:COUNt:STATe

Function

Sets/queries the multi-measurement state of the frequency stability measurement.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:COUNT:STATE ON" !Turns on multi-measurements.

SETup:FSTability:TIMeout[:STIMe]

Function

Sets/queries the frequency stability measurement's timeout setting and automatically sets the timeout state to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, on
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:TIMEOUT:STIME 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:FSTability:TIMeout:STATe

Function

Sets/queries the frequency stability measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:TIMEOUT:STATE ON"

SETup:FSTability:TIMeout:TIME

Function

Sets/queries the frequency stability measurement's timeout setting.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

*RST Setting

10 seconds, on
Requirements

Test Application Revision A.06 and above.

Lab Application Revision C.01 and above.

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:TIMEOUT:TIME 5S"


SETup:HBLerror

SETup:HBLerror

Last updated: January 6, 2012

This section is only applicable to a test application with the required feature license.

GPIB Command Conventions

  • SETup:HBLerror:CONTinuous

  • SETup:HBLerror:COUNt
  • SETup:HBLerror:COUNt:DCHSdpa[:STATe]
  • SETup:HBLerror:COUNt:DCHSdpa:SERVing
  • SETup:HBLerror:COUNt:DCHSdpa:SECondary

  • SETup:HBLerror:TIMeout[:STIMe]
  • SETup:HBLerror:TIMeout:STATe
  • SETup:HBLerror:TIMeout:TIME

SETup:HBLerror:CONTinuous

Function

Sets/queries the trigger arm state for the measurement. The trigger arm state determines whether the measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

See HSDPA Block Error Ratio Measurement Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Test Application A.10 and Lab Application D.01, *RST setting changed to 0 (single).

Programming Example

OUTPUT 714;"SETup:HBLerror:CONTinuous OFF"
! Sets measurement to single trigger mode.

SETup:HBLerror:COUNt

Function

 Sets/queries the Number of blocks to test .

Setting

Range: 1 to 198,000 blocks

Resolution: 1 block

Query

 Same as setting

*RST Setting

 1000 blocks

Requirements

Test Application Revision: A.08 and above, with the required feature license
Lab Application Revision: C.03 and above.

Test Application Revision: A.19.00 and above, with the required feature license.Extended the range from 99000 to 198000
Lab Application Revision: H.01.00. Extended the range from 99000 to 198000

Programming Example

OUTPUT 714;"SETup:HBLerror:COUNt 2000"
! Sets the Number of blocks to test to 2000 blocks.

SETup:HBLerror:COUNt:DCHSdpa[:STATe]

Function

Sets/queries the Blocks to Test Specified Per Serving Cell .

When DC-HSDPA is configured and this setting is set to Off , then only the total number of blocks to test for the combined serving cells ( Number of blocks to test ) is used.

When DC-HSDPA is configured and this setting is set to On , then the number of blocks to test for the serving cell is determined by the DC-HSDPA Serving Cell Blocks to Test , and the number of blocks to test for the secondary serving cell is DC-HSDPA Secondary Serving Cell Blocks to Test .

If DC-HSDPA is not configured, this setting is not used.

Setting

Range: 1|ON|0|OFF

Query

 Same as setting

*RST Setting

 0 (OFF)

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"SETup:HBLerror:COUNt:DCHSdpa ON"

SETup:HBLerror:COUNt:DCHSdpa:SERVing

Function

 Sets/queries DC-HSDPA Serving Cell Blocks to Test when DC-HSDPA is configured and the Blocks to Test Specified Per Serving Cell is set to On .

Setting

Range: 1 to 99,000 blocks

Resolution: 1 block

Query

 Same as setting

*RST Setting

 1000 blocks

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"SETup:HBLerror:COUNt:DCHSdpa:SERVing 2000"
! Sets the Number of blocks to test for the serving cell to 2000 blocks.

SETup:HBLerror:COUNt:DCHSdpa:SECondary

Function

Sets/queries DC-HSDPA Secondary Serving Cell Blocks to Test when DC-HSDPA is configured and the Blocks to Test Specified Per Serving Cell is set to On .

If Current Secondary Serving Cell Status is Configured-Inactive , then the actual number of blocks to test for the secondary serving cell is 0, so all measure results for the secondary serving cell specific will return NAN.

Setting

Range: 1 to 99,000 blocks

Resolution: 1 block

Query

 Same as setting

*RST Setting

 1000 blocks

Requirements

 Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision: H.01.00 and above.

Programming Example

OUTPUT 714;"SETup:HBLerror:COUNt:DCHSdpa:SECondary 2000"
! Sets the Number of blocks to test for the secondary serving cell to 2000 blocks.

SETup:HBLerror:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the measurement's timeout value (see Measurement Timeouts ), and (2) sets the measurement's timeout state to 1 (on).

The query form returns the measurement's timeout value.

See HSDPA Block Error Ratio Measurement Description .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

Timeout value: 20 seconds

Timeout state: off

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"SETup:HBLerror:TIMeout 5"
! Sets measurement's timeout state to ON and sets the timeout time to 5 seconds.

SETup:HBLerror:TIMeout:STATe

Function

Sets/queries the measurement's timeout state (see Measurement Timeouts ).

See HSDPA Block Error Ratio Measurement Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"SETup:HBLerror:TIMeout:STATe ON"
! Sets the measurement's timeout state to ON.

SETup:HBLerror:TIMeout:TIME

Function

Sets/queries the measurement's timeout setting to be used when the timeout state is set to ON (see Measurement Timeouts ).

See HSDPA Block Error Ratio Measurement Description .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Same as setting

*RST Setting

20 seconds

Requirements

Test Application Revision: A.08 and above, with the required feature license

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"SETup:HBLerror:TIMeout:TIME 5"
! Sets the measurement's timeout to five seconds.


SETup:HRCQuality

SETup:HRCQuality

Last updated: January 16, 2009

GPIB Command Conventions

This section is only applicable to the lab application.

  • SETup:HRCQuality:SENSe:ANResponses:FILTered[:COUNt]
  • SETup:HRCQuality:SENSe:BLERatio:FILTered:BASE:DECision
  • SETup:HRCQuality:SENSe:BLERatio:FILTered:CQIMinus1[:LIMit]
  • SETup:HRCQuality:SENSe:BLERatio:FILTered:CQIPlus2[:LIMit]

  • SETup:HRCQuality:TIMeout[:STIMe]
  • SETup:HRCQuality:TIMeout:STATe
  • SETup:HRCQuality:TIMeout:TIME

  • SETup:HRCQuality:VARiance:CQIReports[:COUNt]
  • SETup:HRCQuality:VARiance:CQIValue:INITial
  • SETup:HRCQuality:VARiance:CQIValues:WRANge

SETup:HRCQuality:SENSe:ANResponses:FILTered[:COUNt]

Function

Sets/queries the Number filtered ACK/NACK responses to test .

Setting

Range: 1 to 99000

Query

Range: 1 to 99000

*RST Setting

 2000

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"SETup:HRCQuality:SENSe:ANResponses:FILTered 2000"
!Sets the Number of filtered ACK/NACK responses to test to 2000.

SETup:HRCQuality:SENSe:BLERatio:FILTered:BASE:DECision

Function

Sets/queries the Filtered BLER for initial CQI sense decision .

Setting

Range: 0.00 to 100.00

Query

Range: 0.00 to 100.00

*RST Setting

 10.00 (%)

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"SETup:HRCQuality:SENSe:BLERatio:FILTered:BASE:DECision 10"
!Sets the Filtered BLER for initial CQI sense decision to 10 %.

SETup:HRCQuality:SENSe:BLERatio:FILTered:CQIMinus1[:LIMit]

Function

Sets/queries the Filtered BLER for PASS/FAIL: Median_CQI-1 .

Setting

Range: 0.00 to 100.00

Query

Range: 0.00 to 100.00

*RST Setting

 10.00

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"SETup:HRCQuality:SENSe:BLERatio:FILTered:CQIMinus1 10"
!Sets the Filtered BLER for PASS/FAIL: Median_CQI-1 to 10%.

SETup:HRCQuality:SENSe:BLERatio:FILTered:CQIPlus2[:LIMit]

Function

Sets/queries the Filtered BLER for PASS/FAIL: Median_CQI+2 .

Setting

Range: 0.00 to 100.00

Query

Range: 0.00 to 100.00

*RST Setting

 10.00

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"SETup:HRCQuality:SENSe:BLERatio:FILTered:CQIPlus2 10"
!Sets the Filtered BLER for PASS/FAIL: Median_CQI+2 to 10%.

SETup:HRCQuality:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the measurement's timeout value (see Measurement Timeouts ), and (2) sets the measurement's timeout state to 1 (on).

The query form returns the measurement's timeout value.

See HSDPA Reporting of Channel Quality Indicator Measurement Description .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting.

*RST Setting

Timeout value: 20 seconds

Timeout state: off

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"SETup:HRCQuality:TIMeout 20"
! Sets measurement's timeout state to ON and sets the timeout time to 20 seconds.

SETup:HRCQuality:TIMeout:STATe

Function

Sets/queries the measurement's timeout state (see Measurement Timeouts ).

See HSDPA Reporting of Channel Quality Indicator Measurement Description .

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 0 (off)

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"SETup:HRCQuality:TIMeout:STATe 0"
! Sets measurement's timeout state to OFF.

SETup:HRCQuality:TIMeout:TIME

Function

Sets/queries the measurement's timeout setting to be used when the timeout state is set to ON (see Measurement Timeouts ).

See HSDPA Reporting of Channel Quality Indicator Measurement Description

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

 20 seconds

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"SETup:HRCQuality:TIMeout:TIME 20"
!Sets the measurement's timeout to 20 seconds.

SETup:HRCQuality:VARiance:CQIReports[:COUNt]

Function

Sets/queries the Number of CQI Reports to test .

Setting

Range: 1 to 99000

Query

Range: 1 to 99000

*RST Setting

 2000

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"SETup:HRCQuality:VARiance:CQIReports 2000"
!Sets the Number of CQI Reports to test to 2000.

SETup:HRCQuality:VARiance:CQIValue:INITial

Function

Sets/queries the Starting Downlink TF CQI .

Setting

Range: 1 to 30

Query

 Same as setting

*RST Setting

 16

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"SETup:HRCQuality:VARiance:CQIValue:INITial 16"
!Sets the Starting Downlink TF CQI to 16.

SETup:HRCQuality:VARiance:CQIValues:WRANge

Function

Sets/queries the Percentage of CQI values within range .

Setting

Range: 0.00 to 100.00

Query

Range: 0.00 to 100.00

*RST Setting

 90.00 %

Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"SETup:HRCQuality:VARiance:CQIValues:WRANge 90"
!Sets the Percentage of CQI values within range to 90%.


SETup:SAUDio

SETup:SAUDio

May 10, 2010

GPIB Command Conventions

  • SETup:SAUDio:CONTinuous

  • SETup:SAUDio:COUNt[:SNUMber]
  • SETup:SAUDio:COUNt:NUMBer
  • SETup:SAUDio:COUNt:STATe

  • SETup:SAUDio:COUPling

  • SETup:SAUDio:DETector[:TYPE]

  • SETup:SAUDio:FILTer[:TYPE]

  • SETup:SAUDio:FREQuency[:VALue]?
  • SETup:SAUDio:FREQuency:POINts
  • SETup:SAUDio:FREQuency:STARt
  • SETup:SAUDio:FREQuency:STOP

  • SETup:SAUDio:ICOunt:MAXimum?

  • SETup:SAUDio:PEAK:VOLTage

  • SETup:SAUDio:SETTling[:TIMe]

  • SETup:SAUDio:SDIStortion:STATe

  • SETup:SAUDio:TIMeout[:STIMe]
  • SETup:SAUDio:TIMeout:TIME
  • SETup:SAUDio:TIMeout:STATe

  • SETup:SAUDio:VOLTage:AMPLitude

SETup:SAUDio:CONTinuous

Function

Sets/queries the trigger arm state for the swept audio measurement. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:SAUDIO:CONTINUOUS ON" !Turns on continuous triggering.

SETup:SAUDio:COUNt[:SNUMber]

Function

Sets/queries the number of audio measurements to perform at each measurement point in a single multi-measurement sweep. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETUP:SAUDIO:COUNT:SNUMBER 5" !Turns on multi-measurements and makes 5 measurements at each frequency point in the sweep.

SETup:SAUDio:COUNt:NUMBer

Function

Sets/queries the number of audio measurements to perform at each measurement point in a single multi-measurement sweep when the SETup:SAUDio:COUNt:STATe is set to 1 (on).

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

10

Programming Example

OUTPUT 714;"SETUP:SAUDIO:COUNT:NUMBER 5" !Makes 5 measurements at each frequency point in the sweep.

SETup:SAUDio:COUNt:STATe

Function

Selects/queries the swept audio measurement's multi-measurement count state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:SAUDIO:COUNT:STATE ON" !Turns on multi-measurement for the swept audio measurement.

SETup:SAUDio:COUPling

Function

Sets/queries the audio generator's coupling to the AUDIO OUT port.

Setting

Range: AC|DC

Query

Range: AC|DC

*RST Setting

 DC

Programming Example

OUTPUT 714;"SETUP:SAUDIO:COUPLING AC" !Select AC coupling to the AUDIO OUT port.

SETup:SAUDio:DETector[:TYPE]

Function

Sets/queries the type of level detector used in swept audio measurements.

Setting

Range: RMS|PEAK

Query

Range: RMS|PEAK

*RST Setting

 RMS

Programming Example

OUTPUT 714;"SETUP:SAUDIO:DETECTOR:TYPE PEAK" !Select the peak detector for the AF analzyer.

SETup:SAUDio:FILTer[:TYPE]

Function

Sets/queries the type of filter on the sampled data, before any measurements are performed.

The filter choices are: none, TBPass (100 Hz bandwidth bandpass), CMESsage (C-Message), BPASs50 (50 Hz to 15 kHz bandpass), BPASs300 (300 Hz to 15 kHz bandpass)

Setting

Range: NONE|TBPass|CMESsage|BPASs50|BPASs300

Query

Range: NONE|TBP|CMES|BPAS50|BPAS300

*RST Setting

None

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FILTER:TYPE TBPASS" !Selects the 100 Hz bandpass filter.

SETup:SAUDio:FREQuency[:VALue]?

Function

Returns a comma-separated list of the generated frequency for each frequency point (see SETup:SAUDio:FREQuency:POINts ).

When you specify the start frequency, stop frequency, and the number of measurement points, the test set calculates the intermediate frequencies that are generated. You cannot directly set the intermediate frequencies using this command, you can only query them.

Query

Range: up to 60 comma separated values

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FREQUENCY:VALUE?" !Queries the list of generated frequencies.

SETup:SAUDio:FREQuency:POINts

Function

Sets/queries the number of evenly-spaced frequency points in the sweep. If this value is set to 1, only the start frequency is used in the sweep.

Setting

Range: 1 to 60

Query

Range: 1 to 60

*RST Setting

5

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FREQUENCY:POINTS 20" !Make audio measurements at 20 frequency points in the sweep.

SETup:SAUDio:FREQuency:STARt

Function

Sets/queries the frequency at which to begin the sweep. The default units are Hz.

It is possible to set the start frequency higher than the stop frequency. If this is done, the sweep starts at the higher frequency and stops at the lower frequency.

Setting

Range: 300.0 to 15000.0 Hz

Query

Range: 300.0 to 15000.0 Hz

*RST Setting

300 Hz

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FREQUENCY:START 450HZ" !Start the frequency sweep at 450 Hz.

SETup:SAUDio:FREQuency:STOP

Function

Sets/queries the frequency at which to end the sweep. The default units are Hz.

It is possible to set the stop frequency lower than the start frequency. If this is done, the sweep starts at the higher frequency and stops at the lower frequency.

Setting

Range: 300.0 to 15000.0 Hz

Query

Range: 300.0 to 15000.0 Hz

*RST Setting

 3000 Hz

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FREQUENCY:STOP 1500HZ" !Stop the frequency sweep at 1500 Hz.

SETup:SAUDio:ICOunt:MAXimum?

Function

Queries the total multi-measurement count. This is equal to the number of frequency points in the sweep multiplied by the multi-measurement count set for the swept audio measurement.

Query

Range: 1 to 59940 (60 measurement points multiplied by 999 multi-measurements)

*RST Setting

 5

Programming Example

OUTPUT 714;"SETUP:SAUDIO:ICOUNT:MAXIMUM?" !Queries the total number of measurements made.

SETup:SAUDio:PEAK:VOLTage

Function

Sets/queries the expected peak voltage of the swept audio measurement. This determines the range and resolution of the sampled voltage values.

Setting

Range: 1 mV to 20 V

Resolution: 1 mV

Query

Range: 1 mV to 20 V

*RST Setting

20 V peak

Programming Example

OUTPUT 714;"SETUP:SAUDIO:PEAK:VOLTAGE 5V"

SETup:SAUDio:SETTling[:TIMe]

Function

Sets/queries how long swept audio measurements wait to start an audio measurement after setting the audio source's frequency. A setting of 0.0 seconds let's swept audio measurements run at maximum speed.

Settling time may be needed when testing a device that has a time delay through the audio path. Path delays can cause the audio generator's signal to change frequencies before the output signal can be analyzed at that frequency. Specifying a settling time ensures that the audio generator stays at each frequency point long enough for the audio analyzer to correctly measure the device's audio output.

Setting

Range: 0.0 to 999 ms

Resolution: 1 ms

Query

Range: 0.0 to 999 ms

*RST Setting

0 ms

Programming Example

OUTPUT 714;"SETUP:SAUDIO:SETTLING:TIME 20MS"

SETup:SAUDio:SDIStortion:STATe

Function

Sets/queries whether SINAD and distortion measurements are enabled. Turning on SINAD/Distortion measurements will cause the swept audio measurement to run significantly slower because of added sampling and calculation times.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:SAUDIO:SDISTORTION:STATE ON"

SETup:SAUDio:TIMeout[:STIMe]

Function

 Selects/queries the timeout value in seconds that is used for swept audio measurements and sets the timeout state to ON. Units (S|MS) are optional, if no units are specified then units default to S (seconds).

Setting

Range: 0.1 to 999.9 seconds
Resolution: 0.1 seconds

Query

Range: 0.1 to 999.9 seconds

*RST Setting

 10 seconds

Programming Example

OUTPUT 714;"SETUP:SAUDIO:TIMEOUT:STIME 10" !Enables timeouts and sets the value to 10 seconds.

SETup:SAUDio:TIMeout:TIME

Function

 Selects/queries the timeout value in seconds that is used for swept audio measurements when the timeout state is set to ON. Units (S|MS) are optional, if no units are specified then units default to S (seconds).

Setting

Range: 0.1 to 999.9 seconds
Resolution: 0.1 seconds

Query

Range: 0.1 to 999.9 seconds

*RST Setting

 10 seconds

Programming Example

OUTPUT 714;"SETUP:SAUDIO:TIMEout:TIME 10" !Sets the timeout value to 10 seconds.

SETup:SAUDio:TIMeout:STATe

Function

 Selects/queries the swept audio measurement timeout state. Timeout is set using the SETup:SAUDio:TIMeout:TIME command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:SAUDIO:TIMEOUT:STATE ON" !Enables timeouts for swept audio measurements.

SETup:SAUDio:VOLTage:AMPLitude

Function

Sets/queries the output level (peak voltage) of the audio generator when it is turned on. This command does not turn on the audio generator.

Setting

Range: 0.0 to 9.0 V peak (R L > 600 ohms)

Resolution:

  • < 0.5 mV peak (less than or equal to 1 V peak output)
  • < 5 mV peak (greater than 1 V peak output)

Query

Range: 0.0 to 9.0 V peak (R L > 600 ohms)

*RST Setting

0.0 V peak

Programming Example

OUTPUT 714;"SETUP:SAUDIO:VOLTAGE:AMPLITUDE 1V" !Set the audio generator's output to 1Vpeak.


SETup:SMONitor

SETup:SMONitor

Last updated: May 10, 2010

GPIB Command Conventions

  • SETup:SMONitor:AMPLitude:PDIVision
  • SETup:SMONitor:AMPLitude:RLEVel:AUTO
  • SETup:SMONitor:AMPLitude:RLEVel:MANual

  • SETup:SMONitor:BANDwidth|BWIDth[:RESolution]?
  • SETup:SMONitor:BANDwidth|BWIDth:AUTO
  • SETup:SMONitor:BANDwidth|BWIDth:MANual
  • SETup:SMONitor:BANDwidth|BWIDth:ZSPan[:RESolution]

  • SETup:SMONitor:COUNt[:SNUMber]
  • SETup:SMONitor:COUNt:NUMber
  • SETup:SMONitor:COUNt:STATe

  • SETup:SMONitor:CONTinous

  • SETup:SMONitor:DETector[:TYPE]

  • SETup:SMONitor:FREQuency:SPAN

  • SETup:SMONitor:TIME:OFFSet
  • SETup:SMONitor:TIME:SPAN

  • SETup:SMONitor:TIMeout[:STIMe]
  • SETup:SMONitor:TIMeout:STATe
  • SETup:SMONitor:TIMeout:TIME

  • SETup:SMONitor:TRACe:MODE

  • SETup:SMONitor:TRiGger:DELay

  • SETup:SMONitor:TRiGger:SOURce

SETup:SMONitor:AMPLitude:PDIVision

Function

This command sets the scale of the spectrum monitor's display in dB per division (dB/div).
Setting

Range: 0.1 to 20 dB

Resolution: 0.1

Query

Range: 0.1 to 20 dBResolution: 0.1
*RST Setting

10 dB

Programming Example

OUTPUT 714;"SETup:SMONitor:AMPLitude:PDIVision 1DB"

!Sets scale of the spectrum monitor's display to 1 dB per division.

SETup:SMONitor:AMPLitude:RLEVel:AUTO

Function

This command allows you to set whether or not the spectrum monitor's reference level is selected automatically by the test set. This parameter must be set to OFF before the test set uses the manual setting for the reference level.

The command to manually set the reference level is SETup:SMONitor:AMPLitude:RLEVel:MANual .
Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting

OFF

Programming Example

OUTPUT 714;"SETup:SMONitor:AMPLitude:RLEVel:AUTO ON"

!Sets spectrum monitor's reference level to set automatically.

SETup:SMONitor:AMPLitude:RLEVel:MANual

Function

This command allows you to set the spectrum monitor's actual reference level in dBm. The range settings are coupled to the amplitude offset value for the current value of the expected frequency (set using SYSTem:CORRection[:SGAin] ). Changing the amplitude offset value does not change the reference value, unless the new value for the amplitude offset forces the current value of the reference level to exceed the range limits. If this happens the reference level is set to its limit.

The test set does not apply the manual setting until the command SETup:SMONitor:AMPLitude:RLEVel:AUTO is set to OFF.
Setting

Range: (-50 dBm + Amplitude Offset) to (+37 dBm - Amplitude Offset)

Resolution: 0.1 dB

Query

Range: (-50 dBm + Amplitude Offset) to (+37 dBm - Amplitude Offset)Resolution: 0.1 dB
*RST Setting

+37 dB

Programming Example

OUTPUT 714;"SETup:SMONitor:AMPLitude:RLEVel:MANual -20DBM"

!Sets spectrum monitor's reference level to -20 dBm.

SETup:SMONitor:BANDwidth|BWIDth[:RESolution]?

Function

This command queries the resolution bandwidth being used by the spectrum monitor measurement. This command returns the resolution bandwidth regardless of whether the bandwidth was set manually or automatically.

The command that configures the test set to automatically determine the resolution bandwidth based on the Frequency Span setting is SETup:SMONitor:BANDwidth|BWIDth:AUTO . When the resolution bandwidth is not set to Auto, you can manually configure the resolution bandwidth with the command SETup:SMONitor:BANDwidth|BWIDth:MANual .

Query

Range: 300 Hz to 5 MHz
*RST Setting 30000 Hz

Programming Example

OUTPUT 714;"SETup:SMONitor:BANDwidth?"

SETup:SMONitor:BANDwidth|BWIDth:AUTO

Function

This command sets/queries the Spectrum Monitor Resolution Bandwidth Coupling State. When the state of this parameter is ON the Resolution Bandwidth is determined by the Frequency Span setting ( SETup:SMONitor:FREQuency:SPAN ). When this parameter is set to OFF the Frequency Span and the Resolution Bandwidth parameters are decoupled and can be set separately to any valid Frequency Span and Resolution Bandwidth. See Frequency Span, Resolution Bandwidth and Dynamic Range for the complete list of valid settings for Frequency Span and Resolution Bandwidth.

The command to set the Frequency Span is SETup:SMONitor:FREQuency:SPAN

The command to set the resolution bandwidth is SETup:SMONitor:BANDwidth|BWIDth:MANual .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting 1

Requirements

Test Application Revision: A.07 and above

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:BAND:AUTO 0"

!Turns Spectrum Monitor Resolution Bandwidth Coupling parameter OFF.

SETup:SMONitor:BANDwidth|BWIDth:MANual

Function

This command sets/queries the value of the resolution bandwidth when SETup:SMONitor:BANDwidth|BWIDth:AUTO is set to OFF. When SETup:SMONitor:BANDwidth|BWIDth:AUTO is set to ON, the resolution bandwidth is determined by the Frequency Span setting ( SETup:SMONitor:FREQuency:SPAN ) and can be queried using the SETup:SMONitor:BANDwidth|BWIDth[:RESolution]? command.

When using this command the values in the Frequency Span and Resolution Bandwidth columns of Frequency Span, Resolution Bandwidth and Dynamic Range are no longer coupled. Therefore, the Frequency Span and the Resolution Bandwidth parameters can be set to any value in the Frequency Span and Resolution Bandwidth columns, respectively.

This command also sets the Spectrum Monitor Reference Level Coupling State to OFF (see SETup:SMONitor:AMPLitude:RLEVel:AUTO ).

The units (HZ|KHZ|MHZ) are optional, if no units are specified then the default is HZ.

Setting

Range: A value in the range 300 Hz to 5 MHz can be entered, however the value is rounded to a valid entry. The decision point for rounding up or down is the halfway point between the first valid entry below the setting and the first valid entry above the setting. The valid entries include: 300 Hz, 1 kHz, 3 kHz, 10 kHz, 30 kHz, 100 kHz, 300 kHz, 1 MHz, 5 MHz.

Query

300 Hz, 1 kHz, 3 kHz, 10 kHz, 30 kHz, 100 kHz, 300 kHz, 1 MHz, 5 MHz.
*RST Setting 30 kHz

Requirements

Test Application Revision: A.07 and above

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:BANDwidth:MANual 600 khz"

!Sets the Resolution Bandwidth to 300 kHz because the first valid entry below the setting is 300 kHz !and the first valid entry above the setting is 1 MHz. The middle point between the two valid values is !650 kHz and since 600 kHz is below 650 kHz, the test set rounds 600 kHz to 300 kHz.

SETup:SMONitor:BANDwidth|BWIDth:ZSPan[:RESolution]

Function

This command sets/queries the resolution bandwidth when the spectrum monitor is operating in zero span mode. To measure the total power of a signal you must select a resolution bandwidth greater than or equal to the signal bandwidth. To resolve two spectral components the resolution bandwidth must be less than the difference between them. The units (HZ|KHZ|MHZ) are optional, if no units are specified then the default is HZ.
To change the spectrum monitor to zero span mode, us the command SETup:SMONitor:FREQuency:SPAN , to set the frequency span to 0 Hz.

Any setting you enter is rounded to the nearest of the three settings.
Setting

Range: 100 kHz | 300 kHz | 1 MHz

Query

Range: 100 kHz | 300 kHz | 1 MHz

*RST Setting 300 kHz

Programming Example

OUTPUT 714;"SETup:SMONitor:BAND:ZSPan 100 KHZ"

!Sets spectrum monitor's zero span resolution bandwidth to 100 kHz.

SETup:SMONitor:COUNt[:SNUMber]

Function

This command sets/queries the averaging count and turns on averaging.

Setting

Range: 1 to 999

Query

Range: 1 to 999
*RST Setting

100

Programming Example

OUTPUT 714;"SETup:SMONitor:COUNt 200"

!Sets the averaging count to 200 and sets the averaging the state to on.

SETup:SMONitor:COUNt:NUMber

Function

This command sets/queries the averaging count used when the averaging is turned on.
Setting

Range: 1 to 999

Query

Range: 1 to 999
*RST Setting

100

Programming Example

OUTPUT 714;"SETup:SMONitor:COUNt:NUMBer 200" !Sets the averaging count to 200.

SETup:SMONitor:COUNt:STATe

Function

This command sets/queries the averaging state.
Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting

OFF

Programming Example

OUTPUT 714;"SETup:SMONitor:COUNt:STATe 1" !Turns on averaging.

SETup:SMONitor:CONTinous

Function

This command arms triggering for a measurement sweep. Trigger arming can be single (OFF) or continuous (ON). With single triggering, the measurement sweep starts when an INITiate or READ command is received. With continuous triggering, measurement sweeps initiate immediately and continuously.

The *RST (remote full preset) default setting is single triggering. At power-on or after a front-panel preset, the default setting is continuous triggering.
Setting

Range: ON|1|OFF|0

Query

Range: 1|0
*RST Setting OFF

Programming Example

OUTPUT 714;"SETup:SMONitor:CONTinuous ON" ! Sets the trigger mode to continuous.

SETup:SMONitor:DETector[:TYPE]

Function

 This command sets/queries the Spectrum Monitor Detection Method. There are three detection methods available in the test set's Spectrum Monitor: Peak Detection, Sample Detection, and RMS Detection. See Detection Method for more information.
Setting

Range: PEAK|SAMPle|RMS

Query

Range: PEAK|SAMP|RMS
*RST Setting PEAK

Requirements

Test Application Revision: A.07 and above

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:SMONitor:DETector RMS"
! Sets Detection Method to RMS.

SETup:SMONitor:FREQuency:SPAN

Function

This command sets/queries the spectrum monitor's frequency span. If the Spectrum Monitor Resolution Bandwidth Coupling State is ON (see SETup:SMONitor:AMPLitude:RLEVel:AUTO ) the Frequency Span setting will automatically determine the resolution bandwidth. The couplings between the frequency span and the resolution bandwidth are shown in Frequency Span, Resolution Bandwidth and Dynamic Range .

The units (HZ|KHZ|MHZ) are optional, if no units are specified then the default is HZ.

The command to set the resolution bandwidth is SETup:SMONitor:BANDwidth|BWIDth:MANual .
Setting

Range: A value in the range 125 kHz to 100 MHz can be entered, however the value is rounded to a valid entry. The decision point for rounding up or down is the halfway point between the first valid entry below the setting and the first valid entry above the setting.

  • 0 Hz, 125 kHz, 500 kHz, 1.25 MHz, 2.5 MHz, 4 MHz, 5 MHz, 10 MHz, 12 MHz, 20 MHz, 40 MHz, 80 MHz, 100 MHz
Query

Range: Same as setting range.
*RST Setting 5 MHz

Programming Example

OUTPUT 714;"SETup:SMONitor:FREQuency:SPAN 10MHZ" ! Sets the frequency span to 10 MHz.

SETup:SMONitor:TIME:OFFSet

Function

 This command sets/queries the time offset. You can specify the time window for viewing the signal using this command and the SETup:SMONitor:TIME:SPAN . The measurement is made for the duration of the time span, beginning at the time defined by the trigger event plus the trigger delay plus the time offset. The units (S|MS|US|NS) are optional, if no units are specified then the default is S.
Setting

Range: 0 us to 10 s

Resolution: 0.1 us
Query

Range: 0 us to 10 s

Resolution: 0.1 us
*RST Setting 0 us

Programming Example

OUTPUT 714;"SETup:SMONitor:TIME:OFFSet 25 MS"
! Sets the spectrum monitor's time offset to 25 millisecond.

SETup:SMONitor:TIME:SPAN

Function

 This command sets/queries the span of the time display. The units (S|MS|US) are optional, if no units are specified then the default is S.
Setting

Range: 50 us to 70 ms

Resolution: 0.250 us
Query

Range: 50 us to 70 ms

Resolution: 0.250 us
*RST Setting 10 ms

Programming Example

OUTPUT 714;"SETup:SMONitor:TIME:SPAN 30MS"
! Sets the spectrum monitor's time span to 30 millisecond.

SETup:SMONitor:TIMeout[:STIMe]

Function

This command sets/queries the spectrum monitor's timeout interval and turns on the timeout state. The units (S|MS|US) are optional, if no units are specified then the default is S.
Setting

Range: 1 to 999.9 seconds

Resolution: 0.1 second
Query

Range: 1 to 999.9 seconds

Resolution: 0.1 second
*RST Setting 10 s

Programming Example

OUTPUT 714;"SETup:SMONitor:TIMeout:STIMe 12S"
! Turns on the timeout timer and sets the timer to expire in 12 seconds.

SETup:SMONitor:TIMeout:STATe

Function

This command sets/queries the state of the spectrum monitor's timeout timer.
Setting

Range: 1|ON|0|OFF
Query

Range: 1|0
*RST Setting OFF

Programming Example

OUTPUT 714;"SETup:SMONitor:TIMeout:STATe 1" ! Turns on the timeout timer.

SETup:SMONitor:TIMeout:TIME

Function

This command sets/queries the spectrum monitor's timeout interval. The units (S|MS|US) are optional, if no units are specified then the default is S.
Setting

Range: 1 to 999.9 seconds

Resolution: 0.1 seconds
Query

Range: 1 to 999.9 seconds

Resolution: 0.1 seconds
*RST Setting 10 seconds

Programming Example

OUTPUT 714;"SETup:SMONitor:TIMeout:TIME 20S"
! Generates a timeout error if no results are reported within 20 seconds.

SETup:SMONitor:TRACe:MODE

Function

This command sets/queries the trace update parameter.

  • WRITe (Clear-write) erases any data previously stored in the selected trace.
  • MAXHold (maximum hold) maintains the maximum level for each trace point of the selected trace and updates each trace point if a new maximum level is detected in successive sweeps.
  • MINHold (minimum hold) maintains the minimum level for each trace point of the selected trace and updates each trace point if a new minimum level is detected in successive sweeps.

If you change the center, start, or the frequency span, or the resolution bandwidth, the MAXHold and MINHold traces are restarted. These traces are not restarted if you change only the reference level or the scale.
Setting

Range: WRITe|MAXHold|MINHold
Query

Range: WRIT|MAXH|MINH
*RST Setting WRITe

Programming Example

OUTPUT 714;"SETup:SMONitor:TRACe:MODE MAXH"
! Sets the update method to maximim hold.

SETup:SMONitor:TRiGger:DELay

Function

This command sets/queries the trigger delay. This command allows you to add a time delay following the trigger event before samples are taken. The delay can be positive or negative. The units (S|MS|US) are optional, if no units are specified then the default is S.
Setting

Range: -50 ms to +50 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
Query

Range: -50 ms to +50 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
*RST Setting 350 us

Programming Example

OUTPUT 714;"SETup:SMONitor:TRIGger:DELay 1MS" ! Sets the trigger delay to 1 millisecond.

SETup:SMONitor:TRiGger:SOURce

Function

This command sets the trigger source. Immediate triggering happens as soon as the measurement is armed. RF rise triggering is initiated by the rising edge of an RF burst. With protocol triggering, sampling is initiated by a signaling event such as the start of a burst. An external trigger is used when set to external.
Setting

Range: IMMediate|PROTocol|RISE|EXTernal
Query

Range: IMM|PROT|RISE|EXT
*RST Setting IMMediate

Programming Example

OUTPUT 714;"SETup:SMONitor:TRIGger:SOURce RISE"
! Sets the measurement to trigger on the rising edge of an RF burst.


SETup:WACLeakage

SETup:WACLeakage

Last updated: January 16, 2009

GPIB Command Conventions

  • SETup:WACLeakage:CONTinuous

  • SETup:WACLeakage:COUNt[:SNUMber]
  • SETup:WACLeakage:COUNt:NUMBer
  • SETup:WACLeakage:COUNt:STATe

  • SETup:WACLeakage:LOWer[1]:STATe
  • SETup:WACLeakage:LOWer2:STATe

  • SETup:WACLeakage:TIMeout[:STIMe]
  • SETup:WACLeakage:TIMeout:STATe
  • SETup:WACLeakage:TIMeout:TIME

  • SETup:WACLeakage:TRIGger:ALIGnment:HSDPcchannel:SUBFrame
  • SETup:WACLeakage:TRIGger:DELay
  • SETup:WACLeakage:TRIGger:SOURce

  • SETup:WACLeakage:UPPer[1]:STATe
  • SETup:WACLeakage:UPPer2:STATe

SETup:WACLeakage:CONTinuous

Function

Sets/queries the trigger arm state for the adjacent channel leakage measurement. The trigger arm state determines whether the adjacent channel leakage measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

See Adjacent Channel Leakage Ratio (ACLR) Measurement Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:WACLeakage:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of adjacent channel leakage measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of adjacent channel leakage multi-measurements to be made when multi-measurement state is ON.

See Adjacent Channel Leakage Ratio (ACLR) Measurement Description .

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:WACLeakage:COUNt:NUMBer

Function

Sets/queries the number of adjacent channel leakage measurements to be made when the multi-measurement state is ON.

See Adjacent Channel Leakage Ratio (ACLR) Measurement Description .

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:COUNT:NUMBER 5"
!Sets the number of adjacent channel leakage multi-measurements to 5.

SETup:WACLeakage:COUNt:STATe

Function

Sets/queries the adjacent channel leakage multi-measurement state.

See Adjacent Channel Leakage Ratio (ACLR) Measurement Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:COUNT:STATE ON" !Turns on adjacent channel leakage multi-measurements.

SETup:WACLeakage:LOWer[1]:STATe

Function

Sets/queries the 1st lower adjacent channel's state.

See Adjacent Channel Leakage Ratio (ACLR) Measurement Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:LOW1:STATE 0" !Turns off the lower 1st adjacent channel.

SETup:WACLeakage:LOWer2:STATe

Function

Sets/queries the 2nd lower adjacent channel's state.

See Adjacent Channel Leakage Ratio (ACLR) Measurement Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:LOW2:STATE 0" !Turns off the lower 2nd adjacent channel.

SETup:WACLeakage:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the adjacent channel leakage measurement's timeout (see Measurement Timeouts ) value, and (2) sets the adjacent channel leakage measurement's timeout STATe to 1 (on).

The query form returns the adjacent channel leakage measurement's timeout value.

See Adjacent Channel Leakage Ratio (ACLR) Measurement Description .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WACLeakage:TIMeout:STATe

Function

Sets/queries the adjacent channel leakage measurement's timeout (see Measurement Timeouts ) state.

See Adjacent Channel Leakage Ratio (ACLR) Measurement Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:TIMEOUT:STATE ON"

SETup:WACLeakage:TIMeout:TIME

Function

Sets/queries the adjacent channel leakage measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON.

See Adjacent Channel Leakage Ratio (ACLR) Measurement Description .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:TIMEOUT:TIME 5 S"

SETup:WACLeakage:TRIGger:ALIGnment:HSDPcchannel:SUBFrame

Function

Sets/queries the ACLR measurement's HS-DPCCH Trigger Subframe Alignment setting.

This command is only applicable when SETup:WACLeakage:TRIGger:SOURce is set to HSDPcchannel .

Setting

Range: 0 to 5

Resolution: 1

Query

 Same as setting

*RST Setting

 0 (subframe 0)

Requirements

Test Application Revision: A.08 and above with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SETup:WACLeakage:TRIGger:ALIGnment:HSDPcchannel:SUBFrame 1"
! Sets HS-DPCCH Trigger Subframe Alignment to subframe 1.

SETup:WACLeakage:TRIGger:DELay

Function

Sets/queries the adjacent channel leakage measurement's Trigger Delay setting.

This setting can be used to delay the measurement trigger in order to start a measurement during a specific timeslot in the frame. For example, a 1.333 ms delay would cause the trigger to wait until after the first two timeslots have elapsed.

Setting

Range: -12 to 12 ms

Resolution: 1 ns

Query

 Same as setting

*RST Setting

0 seconds

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision A.08 and Lab Application Revision A.03, increased range to -12 to 12 ms (previously it was -10 ms to 10 ms)

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:TRIGGER:DELAY 1MS"

SETup:WACLeakage:TRIGger:SOURce

Function

Sets/queries the adjacent channel leakage measurement's Trigger Source .

Setting

Range:

  • AUTO
  • EXTernal
  • HSDPcchannel (feature-licensed test application only)
  • IMMediate
  • PROTocol

Query

Range:

  • AUTO
  • EXT
  • HSDP (feature-licensed test application only)
  • IMM
  • PROT

*RST Setting

 AUTO

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision A.08 with the required feature license and Lab Application Revision A.03, added HSDPcchannel

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:TRIGGER:SOURCE IMMEDIATE"

SETup:WACLeakage:UPPer[1]:STATe

Function

Sets/queries the 1st upper adjacent channel's state.

See Adjacent Channel Leakage Ratio (ACLR) Measurement Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:UPP1:STATE 0" !Turns off the upper 1st adjacent channel.

SETup:WACLeakage:UPPer2:STATe

Function

Sets/queries the 2nd upper adjacent channel's state.

See Adjacent Channel Leakage Ratio (ACLR) Measurement Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WACLEAKAGE:UPP2:STATE 0" !Turns off the upper 2nd adjacent channel.


SETup:WBERror

SETup:WBERror

Last updated: January 16, 2009

GPIB Command Conventions

  • SETup:WBERror:CONFidence[:SLEVel]
  • SETup:WBERror:CONFidence:DUTFactor
  • SETup:WBERror:CONFidence:LEVel
  • SETup:WBERror:CONFidence:STATe

  • SETup:WBERror:CONTinuous

  • SETup:WBERror:COUNt

  • SETup:WBERror[:RATio]:REQuirement

  • SETup:WBERror:TIMeout[:STIMe]
  • SETup:WBERror:TIMeout:STATe
  • SETup:WBERror:TIMeout:TIME

SETup:WBERror:CONFidence[:SLEVel]

Function

Sets/queries Confidence Level . This command sets the Confidence Level and turns on Confidence State .

Setting

Range: 99.80%

Query

 Same as setting.

*RST Setting

 99.80% (Off)

Requirements

Test Application Revision: A.06 and above

Test Application Revision A.08.31 and Lab Application Revision C.03.11, fixed the range to 99.8% (previously it was 80.00% to 99.99% with a resolution of 0.01%)

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WBERror:CONFidence 99.8"
! Sets Confidence Level to 99.8% and turns Confidence State On.

SETup:WBERror:CONFidence:DUTFactor

Function

Sets/queries Bad DUT Factor .

This setting is only available when Confidence State is On .

Setting

Range: 1.5

Query

 Same as setting

*RST Setting

 1.5

Requirements

Test Application Revision: A.06 and above

Test Application Revision A.08.31 and Lab Application Revision C.03.11, fixed the range to 1.5 (previously it was 1.0 to 5.0, with a resolution of 0.1)

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WBERror:CONFidence:DUTFactor 1.5"
! Sets the DUT Factor to 1.5.

SETup:WBERror:CONFidence:LEVel

Function

Sets/queries Confidence Level .

Setting

Range: 99.80%

Query

 Same as setting.

*RST Setting

 99.80%

Requirements

Test Application Revision: A.06 and above

Test Application Revision A.08.31 and Lab Application Revision C.03.11, fixed the range to 99.8% (previously it was 80.00% to 99.99% with a resolution of 0.01%)

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WBERror:CONFidence:LEVel 99.8"
! Sets Confidence Level to 99.8%.

SETup:WBERror:CONFidence:STATe

Function

Sets/queries Confidence State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (Off)

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WBERror:CONFidence:STATe OFF"
! Sets Confidence State to Off.

SETup:WBERror:CONTinuous

Function

Sets/queries the trigger arm state for the loopback bit error ratio measurement. The trigger arm state determines whether the bit error measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)). See Trigger Arm (Single or Continuous) Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Test Application A.10 and Lab Application D.01, *RST setting changed to 0 (single).

Programming Example

OUTPUT 714;"SETUP:WBERROR:CONTINUOUS ON"
!Sets measurement to continuous trigger mode.

SETup:WBERror:COUNt

Function

 Sets/queries the Number of Bits to Test .

Setting

Range: 1000 to 999999999

Query

 Same as setting.

*RST Setting

 10000

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision A.06 and Lab Application Revision C.01 changed upper limit to 999999999.

Programming Example

OUTPUT 714;"SETUP:WBERROR:COUNT 5000"

SETup:WBERror[:RATio]:REQuirement

Function

Sets/queries the BER Requirement .

This setting is only available when Confidence State is On .

Setting

Range: 0.10 to 50.00%

Resolution: 0.01%

Query

 Same as setting.

*RST Setting

 0.10%

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WBERror:REQuirement 0.3"
! Sets BER Requirement to 0.3%.

SETup:WBERror:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the loopback bit error ratio measurement's timeout (see Measurement Timeouts ) value, and (2) sets the loopback bit error ratio measurement's timeout STATe to 1 (on).

The query form returns the loopback bit error rate measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

20 seconds, off

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WBERROR:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WBERror:TIMeout:STATe

Function

Sets/queries the loopback bit error ratio measurement's timeout state (see Measurement Timeouts ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WBERROR:TIMEOUT:STATE ON"

SETup:WBERror:TIMeout:TIME

Function

Sets/queries loopback bit error ratio measurement's timeout setting to be used when the timeout state is set to ON (see Measurement Timeouts ).

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

20 seconds

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WBERROR:TIMEOUT:TIME 5 S"


SETup:WBLerror

SETup:WBLerror

Last updated: January 16, 2009

GPIB Command Conventions

  • SETup:WBLerror:CONTinuous

  • SETup:WBLerror:COUNt

  • SETup:WBLerror:TIMeout[:STIMe]
  • SETup:WBLerror:TIMeout:STATe
  • SETup:WBLerror:TIMeout:TIME

SETup:WBLerror:CONTinuous

Function

Sets/queries the trigger arm state for the block error ratio measurement. The trigger arm state determines whether the block error ratio measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)). See Trigger Arm (Single or Continuous) Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Test Application A.10 and Lab Application D.01, *RST setting changed to 0 (single).

Programming Example

OUTPUT 714;"SETup:WBLerror:CONTinuous ON"
! Sets measurement to continuous trigger mode.

SETup:WBLerror:COUNt

Function

 Sets/queries the number of blocks to test in the block error ratio test. See Number of Blocks to Test .

Setting

Range: 1 to 99,000 blocks

Resolution: 1 block

Query

Same as setting

*RST Setting

 500 blocks

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WBLerror:COUNt 1000"

SETup:WBLerror:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the block error ratio measurement's timeout (see Measurement Timeouts ) value, and (2) sets the block error ratio measurement's timeout STATe to 1 (on).

The query form returns the block error ratio measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

20 seconds, off

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WBLerror:TIMeout 5"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WBLerror:TIMeout:STATe

Function

Sets/queries the block error ratio measurement's timeout state (see Measurement Timeouts ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WBLerror:TIMeout:STATe ON"

SETup:WBLerror:TIMeout:TIME

Function

Sets/queries block error ratio measurement's timeout setting to be used when the timeout state is set to ON (see Measurement Timeouts ).

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Same as setting

*RST Setting

20 seconds

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WBLerror:TIMeout:TIME 5"


SETup:WCDomain

SETup:WCDomain

Last updated: November 17, 2010

GPIB Command Conventions

  • SETup:WCDomain:CONTinuous

  • SETup:WCDomain:INTerval:HSDPcchannel

  • SETup:WCDomain:REFined:SDECoder:STATe
  • SETup:WCDomain:TIMeout[:STIMe]
  • SETup:WCDomain:TIMeout:STATe
  • SETup:WCDomain:TIMeout:TIME

  • SETup:WCDomain:TRANsient

  • SETup:WCDomain:TRIGger:ALIGnment:HSDPcchannel:SLOT
  • SETup:WCDomain:TRIGger:ALIGnment:HSDPcchannel:SUBFrame
  • SETup:WCDomain:TRIGger:ALIGnment:HSDPcchannel:SUBSlot
  • SETup:WCDomain:TRIGger:ALIGnment:SFNumber
  • SETup:WCDomain:TRIGger:SOURce

  • SETup:WCDomain:TSLot

SETup:WCDomain:CONTinuous

Function

Sets/queries the trigger arm state for the code domain measurement. The trigger arm state determines whether the bit error measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WCDOMAIN:CONTINUOUS ON"
!Sets measurement to continuous trigger mode.

SETup:WCDomain:INTerval:HSDPcchannel

Function

Sets/queries HS-DPCCH Measurement Interval .

This command is only applicable when SETup:WCDomain:TRIGger:SOURce = HSDPcchannel.

The sum of HS-DPCCH Trigger Subslot Alignment (see SETup:WCDomain:TRIGger:ALIGnment:HSDPcchannel:SUBSlot ) and HS-DPCCH Measurement Interval cannot exceed 1 slot.

Setting

Range: 0.5 to 1.0 slot

Resolution: 0.1 slot

Query

 Same as setting

*RST Setting

 1.0 slot

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"SETup:WCDomain:INTerval:HSDPcchannel 0.8"
! Sets HS-DPCCH Measurement Interval to 0.8 slot.

SETup:WCDomain:REFined:SDECoder:STATe

Function

Sets/queries the refined symbol decoder state for the code domain measurement.

When this setting is set to Off, the typical symbol decoder function will be used; when this setting is set to ON, the refined symbol decoder function will be used. The refined symbol decoder is expected to improve the symbol decoder performance when decoding the impairment signal but is slower. When the measured signal is of good quality, the typical symbol decoder function behaves the same as the refined symbol decoder. You are recommend to use the typical symbol decoder state when measuring a relative good quality signal to save the measurement time.

This setting is GPIB only.

Setting

 1|ON|0|OFF

Query

 1|0

*RST Setting

 0|OFF

Requirements

 Test Application Revision: A.17.00 and above
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"SETup:WCDomain:REFined:SDECoder:STATe 1"
!Sets the refined Symbol Decoder State to On.

SETup:WCDomain:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the code domain measurement's timeout (see Measurement Timeouts ) value, and (2) sets the adjacent channel leakage measurement's timeout STATe to 1 (on).

The query form returns the loopback bit error rate measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

20 seconds, off

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WCDOMAIN:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WCDomain:TIMeout:STATe

Function

Sets/queries the code domain measurement's timeout state (see Measurement Timeouts ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WCDOMAIN:TIMEOUT:STATE ON"

SETup:WCDomain:TIMeout:TIME

Function

Sets/queries code domain measurement's timeout setting to be used when the timeout state is set to ON (see Measurement Timeouts ).

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

20 seconds

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WCDOMAIN:TIMEOUT:TIME 5 S"

SETup:WCDomain:TRANsient

Function

Sets/queries Transient Period .

This command is only applicable when SETup:WCDomain:TRIGger:SOURce = HSDPcchannel.

Setting

Range: INCLude|EXCLude

Query

Range: INCL|EXCL

*RST Setting

 INCL (include)

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"SETup:WCDomain:TRANsient EXCLude"
! Sets Transient Period to Exclude.

SETup:WCDomain:TRIGger:ALIGnment:HSDPcchannel:SLOT

Function

Sets/queries HS-DPCCH Trigger Slot Alignment .

This command is only applicable when SETup:WCDomain:TRIGger:SOURce = HSDPcchannel.

Setting

Range: ACKNack|CQI1|CQI2

Query

Range: ACKN|CQI1|CQI2

*RST Setting

 ACKN

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"SETup:WCDomain:TRIGger:ALIGnment:HSDPcchannel:SLOT CQI1"
! Sets HS-DPCCH Trigger Slot Alignment to CQI1.

SETup:WCDomain:TRIGger:ALIGnment:HSDPcchannel:SUBFrame

Function

Sets/queries HS-DPCCH Trigger Subframe Alignment .

This command is only applicable when SETup:WCDomain:TRIGger:SOURce = HSDPcchannel.

Setting

Range: 0 to 5

Resolution: 1

Query

 Same as setting

*RST Setting

 0

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"SETup:WCDomain:TRIGger:ALIGnment:HSDPcchannel:SUBFrame 3"
! Sets HS-DPCCH Trigger Subframe Alignment to subframe 3.

SETup:WCDomain:TRIGger:ALIGnment:HSDPcchannel:SUBSlot

Function

Sets/queries HS-DPCCH Trigger Subslot Alignment .

This command is only applicable when SETup:WCDomain:TRIGger:SOURce = HSDPcchannel.

The sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval (see SETup:WCDomain:INTerval:HSDPcchannel ) cannot exceed 1 slot.

Setting

Range: 0 to 0.5 slot

Resolution: 0.1 slot

Query

 Same as setting.

*RST Setting

 0.0 slot

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"SETup:WCDomain:TRIGger:ALIGnment:HSDPcchannel:SUBSlot 0.3"
! Sets HS-DPCCH Trigger Subslot Alignment to 0.3 slot.

SETup:WCDomain:TRIGger:ALIGnment:SFNumber

Function

Sets/queries the code domain SFN Alignment setting.

This setting is only applicable when SETup:WCDomain:TRIGger:SOURce is set to EFRame.

Setting

Range: EVEN|ODD

Query

 Same as setting.

*RST Setting

 EVEN

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"SETup:WCDomain:TRIGger:ALIGnment:SFNumber EVEN"
! Sets SFN Alignment to Even

SETup:WCDomain:TRIGger:SOURce

Function

Sets/queries Trigger Source .

Setting

Range: IMMediate|PROTocol|EXTernal|AUTO|HSDPcchannel|EFRame

Query

Range: IMM|PROT|EXT|AUTO|HSDP|EFR

*RST Setting

 AUTO

Requirements

Test Application Revision: A.02 and above.

Test Application Revision A.09, with the required feature license, added HSDPcchannel.

Test Application Revision A.12 and above, with the required feature license, added EFRame.

Lab Application Revision: A.01 and above.

Lab Application Revision C.04 and D.00, added HSDPcchannel.

Lab Application Revision E.00.16 and above, added EFRame.

Programming Example

OUTPUT 714;"SETUP:WCDomain:TRIGGER:SOURCE AUTO"

SETup:WCDomain:TSLot

Function

Sets/queries Timeslot .

This command is only applicable when SETup:WCDomain:TRIGger:SOURce is NOT set to HSDPcchannel.

Setting

Range: 0 to 14

Resolution: 1

Query

 Same as setting

*RST Setting

 0

Requirements

Test Application Revision: A.02 and above

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WCDOMAIN:TSLot 10"


SETup:WCPower

SETup:WCPower

Last updated: June 9, 2009

GPIB Command Conventions

  • SETup:WCPower:CONTinuous

  • SETup:WCPower:COUNt[:SNUMber]
  • SETup:WCPower:COUNt:NUMBer
  • SETup:WCPower:COUNt:STATe

  • SETup:WCPower:FILTer[:RRC]

  • SETup:WCPower:INTerval:TIME

  • SETup:WCPower:POWer:RANGe:OFFSet:MANual

  • SETup:WCPower:RANGe:AUTO

  • SETup:WCPower:RMSCubed:STATe

  • SETup:WCPower:TIMeout[:STIMe]
  • SETup:WCPower:TIMeout:STATe
  • SETup:WCPower:TIMeout:TIME

  • SETup:WCPower:TRIGger:ALIGnment:HSDPcchannel:SUBFrame
  • SETup:WCPower:TRIGger:DELay
  • SETup:WCPower:TRIGger:SOURce

SETup:WCPower:CONTinuous

Function

Sets/queries the trigger arm state for the channel power measurement. The trigger arm state determines whether the channel power measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

See Channel Power Measurement Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:WCPower:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of channel power measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of channel power multi-measurements to be made when multi-measurement state is ON.

See Channel Power Measurement Description .

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:WCPower:COUNt:NUMBer

Function

Sets/queries the number of channel power measurements to be made when the multi-measurement state is ON.

See Channel Power Measurement Description .

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:COUNT:NUMBER 5"
!Sets the number of channel power multi-measurements to 5.

SETup:WCPower:COUNt:STATe

Function

Sets/queries the channel power multi-measurement state.

See Channel Power Measurement Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:COUNT:STATE ON" !Turns on channel power multi-measurements.

SETup:WCPower:FILTer[:RRC]

Function

Sets/queries the state of the root-raised cosine (RRC) filter ( RRC Filter ).

Setting

Range: ON|OFF

Query

Range: ON|OFF

*RST Setting

 OFF

Requirements

Test or Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:FILTER:RRC ON" !Turns on the RRC filter.

SETup:WCPower:INTerval:TIME

Function

Sets/queries the channel power Measurement Interval .

Setting

Range: 10 us to 12 ms

Resolution: 1 ns

Query

 Same as setting

*RST Setting

666.7 us (one slot interval)

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision A.08 and Lab Application Revision A.03, increased range to 10 us to 12 ms (previously it was 0.1 ms to 10 ms)

Programming Example

OUTPUT 714;"SETUP:WCPOWER:INTERVAL:TIME 10MS"
!Sets interval time to 10 milliseconds.

SETup:WCPower:POWer:RANGe:OFFSet:MANual

Function

Sets/queries the channel power Manual Power Range Offset setting.

This setting is only applicable when SETup:WCPower:RANGe:AUTO is set to off.

Setting

Range: 0.00 to 99.00 dB

Resolution: 0.01 dB

Query

 Same as setting.

*RST Setting

0 dB

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"SETup:WCPower:POWer:RANGe:OFFSet:MANual 0"
! Sets Manual Power Range Offset to 0 dB.

SETup:WCPower:RANGe:AUTO

Function

Sets/queries the channel power Auto Range setting.

Setting

Range: 1|ON|0|OFF

Query

 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.12 and above

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"SETup:WCPower:RANGe:AUTO OFF"
! Sets Auto Range to Off.

SETup:WCPower:RMSCubed:STATe

Function

Sets/queries the channel power RMSCubed State .

Setting

Range: 1|ON|0|OFF

Query

 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.12 and above, with the required feature license

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714;"SETup:WCPower:RMSCubed:STATe OFF"
! Sets RMSCubed State to Off.

SETup:WCPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the channel power measurement's timeout (see Measurement Timeouts ) value, and (2) sets the channel power measurement's timeout STATe to 1 (on).

The query form returns the channel power measurement's timeout value.

See Channel Power Measurement Description .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WCPower:TIMeout:STATe

Function

Sets/queries the channel power measurement's timeout (see Measurement Timeouts ) state.

See Channel Power Measurement Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:TIMEOUT:STATE ON"

SETup:WCPower:TIMeout:TIME

Function

Sets/queries the channel power measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON.

See Channel Power Measurement Description .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WCPOWER:TIMEOUT:TIME 5 S"

SETup:WCPower:TRIGger:ALIGnment:HSDPcchannel:SUBFrame

Function

Sets/queries the channel power measurement's HS-DPCCH Trigger Subframe Alignment setting.

This command is only applicable when SETup:WCPower:TRIGger:SOURce is set to HSDPcchannel .

Setting

Range: 0 to 5

Resolution: 1

Query

 Same as setting

*RST Setting

 0 (subframe 0)

Requirements

Test Application Revision: A.08 and above with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SETup:WCPower:TRIGger:ALIGnment:HSDPcchannel:SUBFrame 1"
! Sets HS-DPCCH Trigger Subframe Alignment to subframe 1.

SETup:WCPower:TRIGger:DELay

Function

Sets/queries the channel power measurement's Trigger Delay setting.

This setting can be used to delay the measurement trigger in order to start a measurement during a specific timeslot in the frame. For example, a 1.333 ms delay would cause the trigger to wait until after the first two timeslots have elapsed.

Setting

Range: -12 to 12 ms

Resolution: 1 ns

Query

 Same as setting

*RST Setting

0 seconds

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision A.08 and Lab Application Revision A.03, increased range to -12 to 12 ms (previously it was -10 ms to 10 ms)

Programming Example

OUTPUT 714;"SETUP:WCPOWER:TRIGGER:DELAY 1MS"

SETup:WCPower:TRIGger:SOURce

Function

Sets/queries the channel power measurement's Trigger Source .

Setting

Range:

  • AUTO
  • EXTernal
  • HSDPcchannel (feature-licensed test application only)
  • IMMediate
  • PROTocol
  • RISE

Query

Range:

  • AUTO
  • EXT
  • HSDP (feature-licensed test application only)
  • IMM
  • PROT
  • RISE

*RST Setting

 AUTO

Requirements

Test or Lab Application Revision: A.01 and above

Test Application Revision A.08 and Lab Application Revision A.03, added EXTernal

Test Application Revision A.08 with the required feature license and Lab Application Revision A.03, added HSDPcchannel

Programming Example

OUTPUT 714;"SETUP:WCPOWER:TRIGGER:SOURCE IMMEDIATE"


SETup:WCTFormat

SETup:WCTFormat

Last updated: January 16, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • SETup:WCTFormat:COUNt[:SNUMber]
  • SETup:WCTFormat:COUNt:NUMBer
  • SETup:WCTFormat:COUNt:STATe

  • SETup:WCTFormat:RMCHannel<12|33|64|144|384>:STEP:DOWN[:SIZE]
  • SETup:WCTFormat:RMCHannel<12|33|64|144|384>:STEP:UP[:SIZE]
  • SETup:WCTFormat:RMCHannel<12|33|64|144|384>:STEP:ERRor:LIMit:LOWer
  • SETup:WCTFormat:RMCHannel<12|33|64|144|384>:STEP:ERRor:LIMit:UPPer

  • SETup:WCTFormat:TIMeout[:STIMe]
  • SETup:WCTFormat:TIMeout:STATe
  • SETup:WCTFormat:TIMeout:TIME

SETup:WCTFormat:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of change of TFC measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of change of TFC multi-measurements to be made when multi-measurement state is ON.

See Multi-Measurement Count .

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:COUNt 5"
! Turns on multi-measurements and sets the number of measurements to 5.

SETup:WCTFormat:COUNt:NUMBer

Function

Sets/queries the number of change of TFC measurements to be made when the multi-measurement state is ON. See Multi-Measurement Count .

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:COUNt:NUMBer 5"
! Sets the number of change of TFC multi-measurements to 5.

SETup:WCTFormat:COUNt:STATe

Function

Sets/queries the change of TFC multi-measurement state. See Multi-Measurement Count .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:COUNt:STATe ON"
! Turns on change of TFC multi-measurements.

SETup:WCTFormat:RMCHannel<12|33|64|144|384>:STEP:DOWN[:SIZE]

Function

Sets/queries the Step Down Size .

Setting

Range: -15.0 to 0.0 dB

Resolution: 0.1 dB

Query

 Same as setting.

*RST Setting
  • RMCHannel12: -7.0 dB
  • RMCHannel33: -7.0 dB
  • RMCHannel64: -10.0 dB
  • RMCHannel144: -12.0 dB
  • RMCHannel384: -12.0 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:RMCHannel12:STEP:DOWN -8"
! Sets the 12.2k RMC Step Down Size to -8 dB.

OUTPUT 714;"SETup:WCTFormat:RMCHannel384:STEP:DOWN -13"
! Sets the 384k RMC Step Down Size to -13 dB.

SETup:WCTFormat:RMCHannel<12|33|64|144|384>:STEP:UP[:SIZE]

Function

Sets/queries the Step Up Size .

Setting

Range: 0.0 to 15.0 dB

Resolution: 0.1 dB

Query

 Same as setting.

*RST Setting
  • RMCHannel12: 7.0 dB
  • RMCHannel33: 7.0 dB
  • RMCHannel64: 10.0 dB
  • RMCHannel144: 12.0 dB
  • RMCHannel384: 12.0 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:RMCHannel12:STEP:UP 8"
! Sets the 12.2k RMC Step Up Size to 8 dB.

OUTPUT 714;"SETup:WCTFormat:RMCHannel384:STEP:UP 13"
! Sets the 384k RMC Step Up Size to 13 dB.

SETup:WCTFormat:RMCHannel<12|33|64|144|384>:STEP:ERRor:LIMit:LOWer

Function

Sets/queries the Step Error Limit: Lower .

Setting

Range: -15.0 to 0.0 dB

Resolution: 0.1 dB

Query

 Same as setting.

*RST Setting
  • RMCHannel12: -2.0 dB
  • RMCHannel33: -2.0 dB
  • RMCHannel64: -2.0 dB
  • RMCHannel144: -3.0 dB
  • RMCHannel384: -3.0 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:RMCHannel12:STEP:ERRor:LIMit:LOWer -3"
! Sets the 12.2k RMC Step Error Limit: Lower to -3 dB.

OUTPUT 714;"SETup:WCTFormat:RMCHannel384:STEP:ERRor:LIMit:LOWer -4"
! Sets the 384k RMC Step Error Limit: Lower to -4 dB.

SETup:WCTFormat:RMCHannel<12|33|64|144|384>:STEP:ERRor:LIMit:UPPer

Function

Sets/queries the Step Error Limit: Upper .

Setting

Range: 0.0 to 15.0 dB

Resolution: 0.1 dB

Query

 Same as setting.

*RST Setting
  • RMCHannel12: 2.0 dB
  • RMCHannel33: 2.0 dB
  • RMCHannel64: 2.0 dB
  • RMCHannel144: 3.0 dB
  • RMCHannel384: 3.0 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:RMCHannel12:STEP:ERRor:LIMit:UPPer 3"
! Sets the 12.2k RMC Step Error Limit: Upper to 3 dB.

OUTPUT 714;"SETup:WCTFormat:RMCHannel384:STEP:ERRor:LIMit:UPPer 4"
! Sets the 384k RMC Step Error Limit: Upper to 4 dB.

SETup:WCTFormat:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the change of TFC measurement's timeout value, and (2) sets the change of TFC measurement's timeout STATe to 1 (on).

The query form returns the change of TFC measurement's timeout value.

See Measurement Timeout .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

10 seconds, (off)

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:TIMeout 5"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WCTFormat:TIMeout:STATe

Function

Sets/queries the change of TFC measurement's timeout state. See Measurement Timeout .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:TIMeout:STATe ON"
! Sets the change of TFC measurement's timeout state to ON.

SETup:WCTFormat:TIMeout:TIME

Function

Sets/queries the change of TFC measurement's timeout setting to be used when the timeout state is set to ON. See Measurement Timeout .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Same as setting

*RST Setting

10 seconds

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WCTFormat:TIMeout:TIME 5"
! Sets the change of TFC measurement's timeout to five seconds.


SETup:WDPAnalysis

SETup:WDPAnalysis

Last updated: January 16, 2009

GPIB Command Conventions

  • SETup:WDPAnalysis:CONTinuous
  • SETup:WDPAnalysis:FOFFset
  • SETup:WDPAnalysis:INTerval
  • SETup:WDPAnalysis:LENGth
  • SETup:WDPAnalysis:RRCfilter
  • SETup:WDPAnalysis:STEPs

  • SETup:WDPAnalysis:TIMeout[:STIMe]
  • SETup:WDPAnalysis:TIMeout:STATe
  • SETup:WDPAnalysis:TIMeout:TIME

  • SETup:WDPAnalysis:TRIGger:ALIGnment:HSDPcchannel:SUBFrame
  • SETup:WDPAnalysis:TRIGger:DELay
  • SETup:WDPAnalysis:TRIGger:QUALify:STATe
  • SETup:WDPAnalysis:TRIGger:QUALify:TYPe
  • SETup:WDPAnalysis:TRIGger:QUALify:FALL
  • SETup:WDPAnalysis:TRIGger:QUALify:RISE
  • SETup:WDPAnalysis:TRIGger:SOURce
  • SETup:WDPAnalysis:TRIGger:THReshold

SETup:WDPAnalysis:CONTinuous

Function

Sets/queries the trigger arm state for the dynamic power analysis measurement. The trigger arm state determines whether the dynamic power analysis measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

See Trigger Arm (Single or Continuous) Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (on)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:CONTinuous OFF"
! Sets measurement to single trigger mode.

SETup:WDPAnalysis:FOFFset

Function

Sets/queries the dynamic power analysis Frequency Offset .

Setting

Range: -5 MHz to +5 MHz

Resolution: 1 Hz

Query

 Same as setting

*RST Setting

 0 Hz

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:FOFFset 960 KHZ"
! Sets the frequency offset to +960 kHz.

SETup:WDPAnalysis:INTerval

Function

Sets/queries the dynamic power analysis Measurement Interval .

Measurement Interval must be less than or equal to Step Length (see SETup:WDPAnalysis:LENGth ).

Setting

Range: 10 us to 12 ms

Resolution: 1 ns

Query

 Same as setting

*RST Setting

 +3E-4 s (300 us)

Requirements

Test Application Revision: A.05 and above

Test Application Revision A.08 and Lab Application Revision C.03, increased range to 10 us to 12 ms (previously it was 100 us to 10 ms)

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:INTerval 200 US"
! Sets the measurement interval to 200 microseconds.

SETup:WDPAnalysis:LENGth

Function

Sets/queries the dynamic power analysis step length. See Step Length .

The product of Steps and Step Length must not exceed 58.260 ms.

Setting

Range: 10 us to 12 ms

Resolution: 1 ns

Query

 Same as setting

*RST Setting

 +6.66667E-4 s (666.667 us)

Requirements

Test Application Revision: A.05 and above

Test Application Revision A.08 and Lab Application Revision C.03, increased range to 10 us to 12 ms (previously it was 100 us to 10 ms)

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:LENGth 700 US"
!Sets the step length to 700 microseconds.

SETup:WDPAnalysis:RRCfilter

Function

Sets/queries the state of the root-raised cosine (RRC) filter. See RRC Filter .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (On)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:RRCfilter OFF"
! Turns the RRC filter off.

SETup:WDPAnalysis:STEPs

Function

Sets/queries the number of steps in the UE's power sequence. See Steps .

The product of Steps and Step Length must not exceed 58.260 ms.

Setting

Range: 1 to 200

Resolution: 1

Query

 Same as setting

*RST Setting

 30

Requirements

Test Application Revision: A.05 and above

Test Application Revision A.08 and Lab Application Revision C.03, increased range to 200 steps (previously it was 100)

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:STEPs 20"
!Sets the number of steps to 20.

SETup:WDPAnalysis:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the dynamic power analysis measurement's timeout (see Measurement Timeouts ) value, and (2) sets the dynamic power analysis measurement's timeout STATe to 1 (on).

The query form returns the dynamic power analysis measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TIMEout 5"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WDPAnalysis:TIMeout:STATe

Function

Sets/queries the dynamic power analysis measurement's timeout (see Measurement Timeouts ) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TIMEout:STATe ON"

SETup:WDPAnalysis:TIMeout:TIME

Function

Sets/queries the dynamic power analysis measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TIMEout:TIME 5"

SETup:WDPAnalysis:TRIGger:ALIGnment:HSDPcchannel:SUBFrame

Function

Sets/queries the dynamic power analysis measurement's HS-DPCCH Trigger Subframe Alignment setting.

This command is only applicable when SETup:WDPAnalysis:TRIGger:SOURce is set to HSDPcchannel .

Setting

Range: 0 to 5

Resolution: 1

Query

 Same as setting

*RST Setting

 0 (subframe 0)

Requirements

Test Application Revision: A.08 and above with the required feature license

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TRIGger:ALIGnment:HSDPcchannel:SUBFrame 1"
! Sets HS-DPCCH Trigger Subframe Alignment to subframe 1.

SETup:WDPAnalysis:TRIGger:DELay

Function

Sets/queries the dynamic power analysis measurement's trigger delay setting. See Trigger Delay .

Setting

Range: -12 to 12 ms

Resolution: 1 ns

Query

 Same as setting

*RST Setting

 1.83333E-4 s (183.333 us)

Requirements

Test Application Revision: A.05 and above

Test Application Revision A.08 and Lab Application Revision C.03, increased range to -12 to 12 ms (previously it was -10 ms to 10 ms)

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TRIGger:DELay 200 US"
! Sets trigger delay to 200 microseconds.

SETup:WDPAnalysis:TRIGger:QUALify:STATe

Function

Sets/queries the trigger qualification state. See Trigger Qualification State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TRIGger:QUALify:STATe ON"
! Turns trigger qualification state on.

SETup:WDPAnalysis:TRIGger:QUALify:TYPe

Function

Sets/queries the trigger qualification type. See Trigger Qualification Type .

Setting

Range: FALL|RISE|RISEFALL

Query

 Same as setting

*RST Setting

 RISE

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TRIGger:QUALify:TYPe FALL"
! Sets the trigger qualification type to RF fall.

SETup:WDPAnalysis:TRIGger:QUALify:FALL

Function

Sets/queries the trigger qualification fall threshold. See Trigger Qualification Fall Threshold .

Setting

Range: 0 to 50 dB

Resolution: 0.01 dB

Query

 Same as setting

*RST Setting

 10 dB

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TRIGger:QUALify:FALL 15"
!Sets the trigger qualification fall threshold to 15 dB.

SETup:WDPAnalysis:TRIGger:QUALify:RISE

Function

Sets/queries the trigger qualification rise threshold. See Trigger Qualification Rise Threshold .

Setting

Range: 0 to 50 dB

Resolution: 0.01 dB

Query

 Same as setting

*RST Setting

 10 dB

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TRIGger:QUALify:RISE 15"
!Sets the trigger qualification rise threshold to 15 dB.

SETup:WDPAnalysis:TRIGger:SOURce

Function

Sets/queries the dynamic power analysis measurement's trigger source. See Trigger Source .

Setting

Range:

  • EXTernal
  • HSDPcchannel (only applicable to a test application with the required feature license)
  • RISE

Query

Range:

  • EXT
  • HSDP (only applicable to a test application with the required feature license)
  • RISE

*RST Setting

 RISE

Requirements

Test Application Revision: A.05 and above

Test Application A.08 and above with the required feature license and Lab Application Revision C.03, added HSDPcchannel

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TRIGger:SOURce EXTernal"
! Sets the trigger source to external

SETup:WDPAnalysis:TRIGger:THReshold

Function

Sets/queries the RF rise trigger threshold. See RF Rise Trigger Threshold .

Setting

Range: -61.0 dBm to +28 dBm

Resolution: 0.01 dBm

Query

 Same as setting

*RST Setting

 0 dBm

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TRIGger:THReshold 10"
! Sets the RF rise trigger threshold to 10 dBm.


SETup:WEDPower

SETup:WEDPower

Last updated: January 16, 2009

GPIB Command Conventions

  • SETup:WEDPower:SSEQuence:EXPected:POWer

  • SETup:WEDPower:STEPs:FSEQuence
  • SETup:WEDPower:STEPs:SSEQuence

  • SETup:WEDPower:TIMeout[:STIMe]
  • SETup:WEDPower:TIMeout:STATe
  • SETup:WEDPower:TIMeout:TIME

  • SETup:WEDPower:TRIGger:DELay
  • SETup:WEDPower:TRIGger:SOURce
  • SETup:WEDPower:TRIGger:THReshold

SETup:WEDPower:SSEQuence:EXPected:POWer

Function

Sets/queries the maximum power level expected from the UE's second power sequence in an Extended Range Dynamic Power measurement. See Second Sequence Expected Power for details.

Setting

Range: -61.0 dBm to +28.0 dBm

Resolution: 0.01 dBm

Query

 Same as setting

*RST Setting

 -14 dBm

Requirements

Test Application Revision: A.10 and above

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"SETup:WEDPower:SSEQuence:EXPected:POWer -5"
! Sets the second sequence expected power to -5 dBm.

SETup:WEDPower:STEPs:FSEQuence

Function

Sets/queries the number of steps to be measured in the first power sequence in an Extended Range Dynamic Power measurement. The sum of the first power sequence steps (specified by this command) and the second power sequence steps (specified by SETup:WEDPower:STEPs:SSEQuence ) can not be more than 85 steps. See First Sequence Steps for details.

Setting

Range: 1 to 84

Resolution: 1

Query

 Same as setting

*RST Setting

 38

Requirements

Test Application Revision: A.10 and above

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"SETup:WEDPower:STEPs:FSEQuence 5"
! Sets the number of power steps in the first sequence to 5.

SETup:WEDPower:STEPs:SSEQuence

Function

Sets/queries the number of steps to be measured in the second power sequence in an Extended Range Dynamic Power measurement. The sum of the first power sequence steps (specified by SETup:WEDPower:STEPs:FSEQuence ) and the second power sequence steps (specified by this command) can not be more than 85 steps. See Second Sequence Steps .

Setting

Range: 1 to 84

Resolution: 1

Query

 Same as setting

*RST Setting

 38

Requirements

Test Application Revision: A.10 and above

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"SETup:WEDPower:STEPs:SSEQuence 5"
! Sets the number of power steps in the second sequence to 5.

SETup:WEDPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the measurement timeout value (see SETup:WEDPower:TIMeout:TIME ), and (2) sets the measurement timeout state to on (see SETup:WEDPower:TIMeout:STATe ).

Ensure that you set the measurement timeout to a value great enough to allow you to command the UE to transmit its power sequences and for the test set to measure the power sequences.

The query form of this command returns the measurement timeout value.

See Measurement Timeouts .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

10 seconds

Requirements

Test Application Revision: A.10 and above

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"SETup:WEDPower:TIMeout 5"
! Sets timeout state to on and the timeout time to 5 seconds.

SETup:WEDPower:TIMeout:STATe

Function

Sets/queries the measurement timeout state for the Extended Range Dynamic Power measurement.

The measurement timeout state can also be set to on using the SETup:WEDPower:TIMeout[:STIMe] command.

See Measurement Timeouts .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.10 and above

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"SETup:WEDPower:TIMeout:STATe ON"

SETup:WEDPower:TIMeout:TIME

Function

Sets/queries the measurement timeout value for the Extended Range Dynamic Power measurement. It is used when the timeout state is set to on.

The measurement timeout value can also be set using the SETup:WEDPower:TIMeout[:STIMe] command.

Ensure that you set the measurement timeout to a value great enough to allow you to command the UE to transmit its power sequences and for the test set to measure the power sequences.

See Measurement Timeouts .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

10 seconds

Requirements

Test Application Revision: A.10 and above

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"SETup:WEDPower:TIMeout:TIME 5"

SETup:WEDPower:TRIGger:DELay

Function

Sets/queries the trigger delay for an Extended Range Dynamic Power measurement. It is applicable when SETup:WEDPower:TRIGger:SOURce is set to EXTernal. See Trigger Delay for details.

Setting

Range: -12.0 to 12.0 ms

Resolution: 1 ns

Query

 Same as setting

*RST Setting

 1.66667E-4 s (166.667 us)

Requirements

Test Application Revision: A.10 and above

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"SETup:WEDPower:TRIGger:DELay 200 US"
! Sets trigger delay to 200 microseconds.

SETup:WEDPower:TRIGger:SOURce

Function

Sets/queries the trigger source for an Extended Range Dynamic Power measurement. See Trigger Source for details.

Setting

Range: EXTernal|RISE

Query

Range: EXT|RISE

*RST Setting

 RISE

Requirements

Test Application Revision: A.10 and above

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"SETup:WDPAnalysis:TRIGger:SOURce EXTernal"
! Sets the trigger source to external

SETup:WEDPower:TRIGger:THReshold

Function

Sets/queries the RF rise trigger threshold for an Extended Range Dynamic Power measurement. It is applicable when SETup:WEDPower:TRIGger:SOURce is set to RISE. See RF Rise Trigger Threshold for details.

Setting

Range: -61.0 dBm to +28.0 dBm

Resolution: 0.01 dBm

Query

 Same as setting

*RST Setting

 0 dBm

Requirements

Test Application Revision: A.10 and above

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"SETup:WEDPower:TRIGger:THReshold 10"
! Sets the RF rise trigger threshold to 10 dBm.


SETup:WILPower

SETup:WILPower

Last updated: January 16, 2009

GPIB Command Conventions

  • SETup:WILPower:ALGorithm

  • SETup:WILPower:MAXimum:OUTPut:POWer:TEST:TOLerance
  • SETup:WILPower:MAXimum:POWer:THReshold:TEST:CONTrol:AUTO
  • SETup:WILPower:MAXimum:POWer:THReshold:TEST:MANual

  • SETup:WILPower:Minimum:OUTPut:POWer:TEST:TOLerance
  • SETup:WILPower:Minimum:POWer:THReshold:TEST:CONTrol:AUTO
  • SETup:WILPower:Minimum:POWer:THReshold:TEST:MANual

  • SETup:WILPower:MS:RANGe:TIME:CONTrol:AUTO
  • SETup:WILPower:MS:RANGe:TIME:MANual

  • SETup:WILPower:NSLOts
  • SETup:WILPower:SEGment
  • SETup:WILPower:STEP
  • SETup:WILPower:STARt
  • SETup:WILPower:STOP

  • SETup:WILPower:TIMeout[:STIMe]
  • SETup:WILPower:TIMeout:STATe
  • SETup:WILPower:TIMeout:TIME

  • SETup:WILPower:TPCRange
  • SETup:WILPower:TRIGger:DELay

SETup:WILPower:ALGorithm

Function

Sets/queries the power control algorithm for uplink channels. This setting is useful only when the test segment is set to Manual (see SETup:WILPower:SEGment ) and the start power is different from the stop power. See Inner Loop Power Measurement Description for more information.

Setting

Range: ALG1|ALG2

Query

Range: ALG1|ALG2

*RST Setting

ALG2

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:ALGorithm ALG1"
!Sets Power control algorithm to use algorithm 1.

SETup:WILPower:MAXimum:OUTPut:POWer:TEST:TOLerance

Function

Sets/queries Maximum Output Power Test Tolerance .

This setting is only applicable when Test Segment is set to E , F , G or H ( SETup:WILPower:SEGment ) and Maximum Power Threshold for Test Control is set to Auto ( SETup:WILPower:MAXimum:POWer:THReshold:TEST:CONTrol:AUTO ).

Setting

Range: 0.0 to +2.0 dB

Resolution: 0.1 dB

Query

 Same as setting

*RST Setting

 0.7 dB

Requirements

Test Application Revision: A.08 and above.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:MAXimum:OUTPut:POWer:TEST:TOLerance 0.8"
! Sets Maximum Output Power Test Tolerance to 0.8 dB.

SETup:WILPower:MAXimum:POWer:THReshold:TEST:CONTrol:AUTO

Function

Sets/queries the Maximum Power Threshold for Test Control .

This setting is only applicable when Test Segment is set to E , F , G or H ( SETup:WILPower:SEGment ).

When Maximum Power Threshold for Test Control is set to Manual , the Maximum Power Threshold for Test is determined by Maximum Power Threshold for Test Manual ( SETup:WILPower:MAXimum:POWer:THReshold:TEST:MANual ). When Maximum Power Threshold for Test Control is set to Auto , the maximum power threshold for test is determined as described in the Test Thresholds and Tolerances .

Setting

Range:

  • 1|ON (auto)
  • 0|OFF (manual)

Query

Range: 1|0

*RST Setting

 1 (auto)

Requirements

Test Application Revision: A.08 and above.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:MAXimum:POWer:THReshold:TEST:CONTrol:AUTO OFF"
! Sets Maximum Power Threshold for Test Control to Manual.

SETup:WILPower:MAXimum:POWer:THReshold:TEST:MANual

Function

Sets/queries Maximum Power Threshold for Test Manual .

This setting is only applicable when Test Segment is set to E , F , G or H ( SETup:WILPower:SEGment ) and Maximum Power Threshold for Test Control is set to Manual ( SETup:WILPower:MAXimum:POWer:THReshold:TEST:CONTrol:AUTO ).

Setting

Range: -61.00 to +33.00 dBm

Resolution: 0.01 dBm

Query

 Same as setting

*RST Setting

 +21.00 dBm

Requirements

Test Application Revision: A.08 and above.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:MAXimum:POWer:THReshold:TEST:MANual +19"
! Sets Maximum Power Threshold for Test Manual to +19 dBm.

SETup:WILPower:Minimum:OUTPut:POWer:TEST:TOLerance

Function

Sets/queries Minimum Output Power Test Tolerance .

This setting is only applicable when Test Segment is set to E , F , G or H ( SETup:WILPower:SEGment ) and Minimum Power Threshold for Test Control is set to Auto ( SETup:WILPower:Minimum:POWer:THReshold:TEST:CONTrol:AUTO ).

Setting

Range: 0.0 to +2.0 dB

Resolution: 0.1 dB

Query

 Same as setting

*RST Setting

 1.0 dB

Requirements

Test Application Revision: A.08 and above.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:Minimum:OUTPut:POWer:TEST:TOLerance 0.8"
! Sets Minimum Output Power Test Tolerance to 0.8 dB.

SETup:WILPower:Minimum:POWer:THReshold:TEST:CONTrol:AUTO

Function

Sets/queries the Minimum Power Threshold for Test Control .

This setting is only applicable when Test Segment is set to E , F , G or H ( SETup:WILPower:SEGment ).

When Minimum Power Threshold for Test Control is set to Manual , the Minimum Power Threshold for Test is determined by Minimum Power Threshold for Test Manual ( SETup:WILPower:Minimum:POWer:THReshold:TEST:MANual ). When Minimum Power Threshold for Test Control is set to Auto , the minimum power threshold for test is determined as described in the Test Thresholds and Tolerances .

Setting

Range:

  • 1|ON (auto)
  • 0|OFF (manual)

Query

Range: 1|0

*RST Setting

 0 (manual)

Requirements

Test Application Revision: A.08 and above.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:Minimum:POWer:THReshold:TEST:CONTrol:AUTO ON"
! Sets Minimum Power Threshold for Test Control to Auto.

SETup:WILPower:Minimum:POWer:THReshold:TEST:MANual

Function

Sets/queries Minimum Power Threshold for Test Manual .

This setting is only applicable when Test Segment is set to E , F , G or H ( SETup:WILPower:SEGment ) and Minimum Power Threshold for Test Control is set to Manual ( SETup:WILPower:Minimum:POWer:THReshold:TEST:CONTrol:AUTO ).

Setting

Range: -61.00 to +33.00 dBm

Resolution: 0.01 dBm

Query

 Same as setting

*RST Setting

 -49.00 dBm

Requirements

Test Application Revision: A.08 and above.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:Minimum:POWer:THReshold:TEST:MANual -50"
! Sets Minimum Power Threshold for Test Manual to -50 dBm.

SETup:WILPower:MS:RANGe:TIME:CONTrol:AUTO

Function

Sets/queries UE Range Time Control .

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

 1 (auto)

Requirements

Test Application Revision: A.11 and above.

Lab Application Revision: D.02 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:MS:RANGe:TIME:CONTrol:AUTO 1"
! Sets UE Range Time Control to Auto.

SETup:WILPower:MS:RANGe:TIME:MANual

Function

Sets/queries Manual UE Range Time .

This setting is only applicable when SETup:WILPower:MS:RANGe:TIME:CONTrol:AUTO is set to manual (0|OFF).

Setting

Range: 0 to 0.315 s

Resolution: 0.001 s

Query

 Same as setting

*RST Setting

 0 s

Requirements

Test Application Revision: A.11 and above.

Lab Application Revision: D.02 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:MS:RANGe:TIME:MANual 0"
! Sets Manual UE Range Time to 0 seconds.

SETup:WILPower:NSLOts

Function

Sets/queries the number of timeslots to be measured which equals to the total number of TPC commands sent for the chosen test segments. This setting is used only during two test configurations: when Test Segment A is selected and when Test Segment Manual is selected with Start Power and Stop Power set to the same values. See Inner Loop Power Measurement Description for more information.

The following sequence of TPC commands are sent in accordance with the selected number of timeslots:

  • 100000101010101 (Number of Slots = 15)
  • 100000101010101111101000001010 (Number of Slots = 30)
  • 100000101010101111101000001010101011111010000 (Number of Slots = 45)
  • 100000101010101111101000001010101011111010000010101010111110 (Num of Slots = 60)

Setting

Range: S15|S30|S45|S60

Query

Range: S15|S30|S45|S60

*RST Setting

 S45

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:NSLOts S60"
!Sets the number of timeslots to be measured to 60.

SETup:WILPower:SEGment

Function

Sets/queries the Inner Loop Power control measurement configuration. With Manual selected, you can build a custom test segment to run. If you select a test segment other than Manual, the test set will run a single test segment as specified in the standard (referred to as Test Steps in the standard). See Inner Loop Power Measurement Description for more information.

Setting

Range: MANual|A|B|C|E|F|G|H

Query

Range: MANual|A|B|C|E|F|G|H

*RST Setting

 A

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:SEGment MAN"
!Sets the segment to be measured to manual.

SETup:WILPower:STEP

Function

Sets/queries the power control step size for the UE transmitter which is the change in the UE transmitter output power in response to a single TPC_cmd derived at UE. ONE is the change of 1 dB and TWO is the change of 2 dB.

This setting is useful only when the test segment is set to Manual (see SETup:WILPower:SEGment ) and the power control algorithm is set to ALG1 (see SETup:WILPower:ALGorithm . See Inner Loop Power Measurement Description for more information.

Setting

Range: ONE|TWO

Query

Range: ONE|TWO

*RST Setting

TWO

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:STEP ONE"
!Sets Power control step size to 1 dB.

SETup:WILPower:STARt

Function

Sets/queries the start power for the measurement in manual mode (see SETup:WILPower:SEGment ). The UE will be instructed to the start power and make the measurements while ramping up/down the power to the specified stop power. See Inner Loop Power Measurement Description for more information.

Setting

Range: -61 dBm to +30 dBm (-50 dBm to +24 dBm for Class 1 UE)

Resolution: 1 dBm

Query

Range: -61 dBm to +30 dBm (-50 dBm to +24 dBm for Class 1 UE)

*RST Setting

+24 dBm

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:STARt 10"
!Sets Power control algorithm to use algorithm 1.

SETup:WILPower:STOP

Function

Sets/queries the stop power for the measurement in manual mode (see SETup:WILPower:SEGment ). The UE will be instructed to the start power and make the measurements while ramping up/down the power to the specified stop power. See Inner Loop Power Measurement Description for more information.

Setting

Range: -61 dBm to +30 dBm (-50 dBm to +24 dBm for Class 1 UE)

Resolution: 1 dBm

Query

Range: -61 dBm to +30 dBm (-50 dBm to +24 dBm for Class 1 UE)

*RST Setting

+24 dBm

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:STOP 0"

SETup:WILPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the Inner Loop Power control measurement's timeout (see Measurement Timeouts ) value, and (2) sets the Inner Loop Power control measurement's timeout STATe to 1 (on).

The query form returns the Inner Loop Power control measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WILPOWER:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WILPower:TIMeout:STATe

Function

Sets/queries the Inner Loop Power control measurement's timeout (see Measurement Timeouts ) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WILPOWER:TIMEOUT:STATE ON"

SETup:WILPower:TIMeout:TIME

Function

Sets/queries the Inner Loop Power control measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WILPOWER:TIMEOUT:TIME 5 S"

SETup:WILPower:TPCRange

Command

 Function Setting/Query Range
(Resolution = 0.01 dB) 		*RST Setting
See Transmitter Power Control Pass/Fail Ranges .
SETup:WILPower:TPCRange[:SINGle]:STEP:DOWN:DB1:LIMit:LOWer | TX Pwr Ctrl Rng Sngl Step Down 1dB: Lwr Lim | 0.00 to -1.00 dB | -0.40 dB
SETup:WILPower:TPCRange[:SINGle]:STEP:DOWN:DB1:LIMit:UPPer | TX Pwr Ctrl Rng Sngl Step Down 1dB: Upr Lim | -1.00 to -2.00 dB | -1.60 dB
SETup:WILPower:TPCRange[:SINGle]:STEP:DOWN:DB2:LIMit:LOWer | TX Pwr Ctrl Rng Sngl Step Down 2dB: Lwr Lim | 0.00 to -2.00 dB | -0.85 dB
SETup:WILPower:TPCRange[:SINGle]:STEP:DOWN:DB2:LIMit:UPPer | TX Pwr Ctrl Rng Sngl Step Down 2dB: Upr Lim | -2.00 to -4.00 dB | -3.15 dB
SETup:WILPower:TPCRange[:SINGle]:STEP:NONE:LIMit:LOWer | TX Pwr Ctrl Rng Sngl Step None: Lwr Lim | 0.00 to -1.00 dB | -0.60 dB
SETup:WILPower:TPCRange[:SINGle]:STEP:NONE:LIMit:UPPer | TX Pwr Ctrl Rng Sngl Step None: Upr Lim | 0.00 to +1.00 dB | +0.60 dB
SETup:WILPower:TPCRange[:SINGle]:STEP:UP:DB1:LIMit:LOWer | TX Pwr Ctrl Rng Sngl Step Up 1dB: Lwr Lim | 0.00 to +1.00 dB | +0.40 dB
SETup:WILPower:TPCRange[:SINGle]:STEP:UP:DB1:LIMit:UPPer | TX Pwr Ctrl Rng Sngl Step Up 1dB: Upr Lim | +1.00 to +2.00 dB | +1.60 dB
SETup:WILPower:TPCRange[:SINGle]:STEP:UP:DB2:LIMit:LOWer | TX Pwr Ctrl Rng Sngl Step Up 2dB: Lwr Lim | 0.00 to +2.00 dB | +0.85 dB
SETup:WILPower:TPCRange[:SINGle]:STEP:UP:DB2:LIMit:UPPer | TX Pwr Ctrl Rng Sngl Step Up 2dB: Upr Lim | +2.00 to +4.00 dB | +3.15 dB
SETup:WILPower:TPCRange:AGGRegate:ALGorithm1:STEP:DOWN:DB1:LIMit:LOWer | TX Pwr Ctrl Rng Agg Alg1 Step Down 1dB: Lwr Lim | -6.00 to -10.00 dB | -7.70 dB
SETup:WILPower:TPCRange:AGGRegate:ALGorithm1:STEP:DOWN:DB1:LIMit:UPPer | TX Pwr Ctrl Rng Agg Alg1 Step Down 1dB: Upr Lim | -10.00 to -14.00 dB | -12.30 dB
SETup:WILPower:TPCRange:AGGRegate:ALGorithm1:STEP:DOWN:DB2:LIMit:LOWer | TX Pwr Ctrl Rng Agg Alg1 Step Down 2dB: Lwr Lim | -12.00 to -20.00 dB | -15.70 dB
SETup:WILPower:TPCRange:AGGRegate:ALGorithm1:STEP:DOWN:DB2:LIMit:UPPer | TX Pwr Ctrl Rng Agg Alg1 Step Down 2dB: Upr Lim | -20.00 to -28.00 dB | -24.30 dB
SETup:WILPower:TPCRange:AGGRegate:ALGorithm1:STEP:UP:DB1:LIMit:LOWer | TX Pwr Ctrl Rng Agg Alg1 Step Up 1dB: Lwr Lim | +6.00 to +10.00 dB | +7.70 dB
SETup:WILPower:TPCRange:AGGRegate:ALGorithm1:STEP:UP:DB1:LIMit:UPPer | TX Pwr Ctrl Rng Agg Alg1 Step Up 1dB: Upr Lim | +10.00 to +14.00 dB | +12.30 dB
SETup:WILPower:TPCRange:AGGRegate:ALGorithm1:STEP:UP:DB2:LIMit:LOWer | TX Pwr Ctrl Rng Agg Alg1 Step Up 2dB: Lwr Lim | +12.00 to +20.00 dB | +15.70 dB
SETup:WILPower:TPCRange:AGGRegate:ALGorithm1:STEP:UP:DB2:LIMit:UPPer | TX Pwr Ctrl Rng Agg Alg1 Step Up 2dB: Upr Lim | +20.00 to +28.00 dB | +24.30 dB
SETup:WILPower:TPCRange:AGGRegate:ALGorithm2:STEP:DOWN:DB1:LIMit:LOWer TX Pwr Ctrl Rng Agg Alg2 Step Down 1dB: Lwr Lim

-2.00 to -10.00 dB

 -5.70 dB
SETup:WILPower:TPCRange:AGGRegate:ALGorithm2:STEP:DOWN:DB1:LIMit:UPPer | TX Pwr Ctrl Rng Agg Alg2 Step Down 1dB: Upr Lim | -10.00 to -18.00 dB | -14.30 dB
SETup:WILPower:TPCRange:AGGRegate:ALGorithm2:STEP:NONE:LIMit:LOWer | TX Pwr Ctrl Rng Agg Alg2 Step None: Lwr Lim | 0.00 to -2.00 dB | -1.10 dB
SETup:WILPower:TPCRange:AGGRegate:ALGorithm2:STEP:NONE:LIMit:UPPer | TX Pwr Ctrl Rng Agg Alg2 Step None: Upr Lim | 0.00 to +2.00 dB | +1.10 dB
SETup:WILPower:TPCRange:AGGRegate:ALGorithm2:STEP:UP:DB1:LIMit:LOWer | TX Pwr Ctrl Rng Agg Alg2 Step Up 1dB: Lwr Lim | +2.00 to +10.00 dB | +5.70 dB
SETup:WILPower:TPCRange:AGGRegate:ALGorithm2:STEP:UP:DB1:LIMit:UPPer | TX Pwr Ctrl Rng Agg Alg2 Step Up 1dB: Upr Lim | +10.00 to +18.00 dB | +14.30 dB

Requirements

Test Application Revision: A.08 and above.

Lab Application Revision: C.03 and above.

Programming Example

OUTPUT 714;"SETup:WILPower:TPCRange:STEP:DOWN:DB1:LIMit:LOWer -0.45"
! Sets TX Pwr Ctrl Rng Sngl Step Down 1dB: Lwr Lim to -0.45 dB.

SETup:WILPower:TRIGger:DELay

Function

Sets/queries the Inner Loop Power control measurement's Trigger Delay setting.

This setting can be used to delay the measurement trigger in order to start a measurement during a specific timeslot in the frame. For example, a 1.333 ms delay would cause the trigger to wait until after the first two timeslots have elapsed.

Setting

Range: -10 to 10 milliseconds

Resolution: 0.0001 millisecond

Query

Range: -10 to 10 milliseconds

*RST Setting

0 seconds

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WILPOWER:TRIGGER:DELAY 1MS"


SETup:WIQTuning

SETup:WIQTuning

Last updated: November 12, 2010

GPIB Command Conventions

  • SETup:WIQTuning:CONTinuous

  • SETup:WIQTuning:INTerval:HSDPcchannel

  • SETup:WIQTuning:REFined:SDECoder:STATe
  • SETup:WIQTuning:TIMeout[:STIMe]
  • SETup:WIQTuning:TIMeout:STATe
  • SETup:WIQTuning:TIMeout:TIME

  • SETup:WIQTuning:TRANsient

  • SETup:WIQTuning:TRIGger:ALIGnment:HSDPcchannel:SLOT
  • SETup:WIQTuning:TRIGger:ALIGnment:HSDPcchannel:SUBFrame
  • SETup:WIQTuning:TRIGger:ALIGnment:HSDPcchannel:SUBSlot
  • SETup:WIQTuning:TRIGger:ALIGnment:SFNumber
  • SETup:WIQTuning:TRIGger:SOURce

  • SETup:WIQTuning:TSLot

SETup:WIQTuning:CONTinuous

Function

Sets/queries the trigger arm state for the IQ tuning measurement. The trigger arm state determines whether the IQ tuning measurement will be made once then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WIQTuning:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:WIQTuning:INTerval:HSDPcchannel

Function

Sets/queries HS-DPCCH Measurement Interval .

This command is only applicable when SETup:WIQTuning:TRIGger:SOURce = HSDPcchannel.

The sum of HS-DPCCH Trigger Subslot Alignment (see SETup:WIQTuning:TRIGger:ALIGnment:HSDPcchannel:SUBSlot ) and HS-DPCCH Measurement Interval cannot exceed 1 slot.

Setting

Range: 0.5 to 1.0 slot

Resolution: 0.1 slot

Query

 Same as setting

*RST Setting

 1.0 slot

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"SETup:WIQTuning:INTerval:HSDPcchannel 0.8"
! Sets HS-DPCCH Measurement Interval to 0.8 slot.

SETup:WIQTuning:REFined:SDECoder:STATe

Function

 Sets/queries the refined symbol decoder state for the IQ Tuning measurement. When this setting is set to Off, the typical symbol decoder function will be used; when this setting is set to ON, the refined symbol decoder function will be used. The refined symbol decoder is expected to improve the symbol decoder performance when decoding the impairment signal but is slower. When the measured signal is of good quality, the typical symbol decoder function behaves the same as the refined symbol decoder. You are recommend to use the typical symbol decoder state when measuring a relative good quality signal to save the measurement time.This setting is GPIB only.

Setting

 1|ON|0|OFF

Query

 1|0

*RST Setting

 0|OFF

Requirements

 Test Application Revision: A.17.00 and above
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"SETup:WIQTuning:REFined:SDECoder:STATe 1"
! Sets the refined Symbol Decoder State to On.

SETup:WIQTuning:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the IQ tuning measurement's timeout value, and (2) sets the IQ tuning measurement's timeout STATe to 1 (on).

The query form returns the IQ tuning measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WIQTuning:TIMEout:STIMe 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WIQTuning:TIMeout:STATe

Function

Sets/queries the IQ tuning measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WIQTuning:TIMeout:STATe ON"

SETup:WIQTuning:TIMeout:TIME

Function

Sets/queries the IQ tuning measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WIQTuning:TIMeout:TIME 5S"

SETup:WIQTuning:TRANsient

Function

Sets/queries Transient Period .

This command is only applicable when SETup:WIQTuning:TRIGger:SOURce = HSDPcchannel.

Setting

Range: INCLude|EXCLude

Query

Range: INCL|EXCL

*RST Setting

 INCL (include)

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"SETup:WIQTuning:TRANsient EXCLude"
! Sets Transient Period to Exclude.

SETup:WIQTuning:TRIGger:ALIGnment:HSDPcchannel:SLOT

Function

Sets/queries HS-DPCCH Trigger Slot Alignment .

This command is only applicable when SETup:WIQTuning:TRIGger:SOURce = HSDPcchannel.

Setting

Range: ACKNack|CQI1|CQI2

Query

Range: ACKN|CQI1|CQI2

*RST Setting

 ACKN

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"SETup:WIQTuning:TRIGger:ALIGnment:HSDPcchannel:SLOT CQI1"
! Sets HS-DPCCH Trigger Slot Alignment to CQI1.

SETup:WIQTuning:TRIGger:ALIGnment:HSDPcchannel:SUBFrame

Function

Sets/queries HS-DPCCH Trigger Subframe Alignment .

This command is only applicable when SETup:WIQTuning:TRIGger:SOURce = HSDPcchannel.

Setting

Range: 0 to 5

Resolution: 1

Query

Range: 0 to 5

*RST Setting

 0

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"SETup:WIQTuning:TRIGger:ALIGnment:HSDPcchannel:SUBFrame 3"
! Sets HS-DPCCH Trigger Subframe Alignment to subframe 3.

SETup:WIQTuning:TRIGger:ALIGnment:HSDPcchannel:SUBSlot

Function

Sets/queries HS-DPCCH Trigger Subslot Alignment .

This command is only applicable when SETup:WIQTuning:TRIGger:SOURce = HSDPcchannel.

The sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval (see SETup:WIQTuning:INTerval:HSDPcchannel ) cannot exceed 1 slot.

Setting

Range: 0 to 0.5 slot

Resolution: 0.1 slot

Query

 Same as setting.

*RST Setting

 0.0 slot

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"SETup:WIQTuning:TRIGger:ALIGnment:HSDPcchannel:SUBSlot 0.3"
! Sets HS-DPCCH Trigger Subslot Alignment to 0.3 slot.

SETup:WIQTuning:TRIGger:ALIGnment:SFNumber

Function

Sets/queries which frame will be measured when the Even Frame trigger source is selected.

Setting

Range: ODD|EVEN

Query

Range: ODD|EVEN

*RST Setting

 EVEN

Requirements

Lab Application Revision F.00, and above.

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"SETup:WIQTuning:ALIGnment:SFNumber EVEN"

SETup:WIQTuning:TRIGger:SOURce

Function

Sets/queries Trigger Source .

Setting

Range: IMMediate|PROTocol|EXTernal|AUTO|HSDPcchannel|EFRame

Query

Range: IMM|PROT|EXT|AUTO|HSDP|EFR

*RST Setting

 AUTO

Requirements

Test Application Revision: A.02 and above.

Test Application Revision A.09, with the required feature license, added HSDPcchannel.

Lab Application Revision: A.01 and above.

Lab Application Revision C.04 and D.00, added HSDPcchannel.

Lab Application Revision F.00, added EFRame.

Test Application Revision A.14, with the required feature license, added EFRame.

Programming Example

OUTPUT 714;"SETUP:WIQTuning:TRIGGER:SOURCE AUTO"

SETup:WIQTuning:TSLot

Function

Sets/queries Timeslot .

This command is only applicable when SETup:WIQTuning:TRIGger:SOURce is NOT set to HSDPcchannel.

Setting

Range: 0 to 14

Resolution: 1

Query

Range: 0 to 14

*RST Setting

0

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WIQTuning:TSLot 10"


SETup:WOBWidth

SETup:WOBWidth

Last updated: January 16, 2009

GPIB Command Conventions

  • SETup:WOBWidth:CONTinuous

  • SETup:WOBWidth:PERcent:TOTal:POWer

  • SETup:WOBWidth:COUNt[:SNUMber]
  • SETup:WOBWidth:COUNt:NUMBer
  • SETup:WOBWidth:COUNt:STATe

  • SETup:WOBWidth:TIMeout[:STIMe]
  • SETup:WOBWidth:TIMeout:STATe
  • SETup:WOBWidth:TIMeout:TIME

  • SETup:WOBWidth:TRIGger:DELay
  • SETup:WOBWidth:TRIGger:SOURce

SETup:WOBWidth:CONTinuous

Function

Sets/queries the trigger arm state for the occupied bandwidth measurement. The trigger arm state determines whether the occupied bandwidth measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:WOBWidth:PERcent:TOTal:POWer

Function

Sets/queries the percentage of total power parameter used in the occupied bandwidth measurement.

Setting

Range: 70.0 to 99.0 percent

Query

Range: 70.0 to 99.0 percent

*RST Setting

99 percent

Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETup:WOBWidth:PERcent:TOTal:POWer 99"
!Sets percentage of total power to 99%.

SETup:WOBWidth:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of occupied bandwidth measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of occupied bandwidth multi-measurements to be made when multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:WOBWidth:COUNt:NUMBer

Function

Sets/queries the number of occupied bandwidth measurements to be made when the multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:COUNT:NUMBER 5"
!Sets the number of occupied bandwidth multi-measurements to 5.

SETup:WOBWidth:COUNt:STATe

Function

Sets/queries the occupied bandwidth multi-measurement state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:COUNT:STATE ON" !Turns on occupied bandwidth multi-measurements.

SETup:WOBWidth:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the occupied bandwidth measurement's timeout (see Measurement Timeouts ) value, and (2) sets the occupied bandwidth measurement's timeout STATe to 1 (on).

The query form returns the occupied bandwidth measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WOBWidth:TIMeout:STATe

Function

Sets/queries the occupied bandwidth measurement's timeout (see Measurement Timeouts ) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:TIMEOUT:STATE ON"

SETup:WOBWidth:TIMeout:TIME

Function

Sets/queries the occupied bandwidth measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:TIMEOUT:TIME 5 S"

SETup:WOBWidth:TRIGger:DELay

Function

Sets/queries the occupied bandwidth measurement's trigger delay setting.

This setting can be used to delay the measurement trigger in order to start a measurement during a specific timeslot in the frame. For example, a 1.333 ms delay would cause the trigger to wait until after the first two timeslots have elapsed.

Setting

Range: -10 to 10 milliseconds

Resolution: 1 nanosecond

Query

Range: -10 to 10 milliseconds

*RST Setting

0 seconds

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:TRIGGER:DELAY 1MS"

SETup:WOBWidth:TRIGger:SOURce

Function

Sets/queries the occupied bandwidth measurement's trigger source.

Setting

Range: IMMediate|PROTocol|AUTO

Query

Range: IMM|PROT|AUTO

*RST Setting

 AUTO

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WOBWIDTH:TRIGGER:SOURCE IMMEDIATE"


SETup:WOOPower

SETup:WOOPower

Last updated: January 16, 2009

GPIB Command Conventions

  • SETup:WOOPower:OFF:POWer:LIMit

  • SETup:WOOPower:OPEN:LOOP:POWer:LIMit
  • SETup:WOOPower:OPEN:LOOP:POWer:UPPer:LIMit
  • SETup:WOOPower:OPEN:LOOP:POWer:LOWer:LIMit

  • SETup:WOOPower:TIMeout[:STIMe]
  • SETup:WOOPower:TIMeout:STATe
  • SETup:WOOPower:TIMeout:TIME

SETup:WOOPower:OFF:POWer:LIMit

Function

Sets/queries the Off Power Limit (see Off Power Limit ).
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Setting

Range: -99.99 to 99.0

Resolution: 0.1

Query

Same as setting.

*RST Setting

-55 dBm

Programming Example

OUTPUT 714;"SETup:WOOPower:OFF:POWer:LIMit -54"
! Sets the Off Power Limit to -54 dBm.

SETup:WOOPower:OPEN:LOOP:POWer:LIMit

Function

This command sets symmetrical upper and lower pass/fail limits for the difference between the "on" power and the expected power.

NOTE
This command has been replaced by two separate commands which allow you to independently set the upper and lower pass/fail limits for this measurement result. This command is still available for backwards-compatibility, but we recommend that you use these two new commands instead: SETup:WOOPower:OPEN:LOOP:POWer:UPPer:LIMit SETup:WOOPower:OPEN:LOOP:POWer:LOWer:LIMit .
Requirements

Test Application Revision: A.03 and above

Lab Application Revision: A.01 and above

Setting

Range: 0.0 to 99.9

Resolution: 0.1

Query

Same as setting.

*RST Setting

 9.0 dB

Programming Example

OUTPUT 714;"SETup:WOOPower:OPEN:LOOP:POWer:LIMit 10"
! Sets the Open Loop Power Error Upper and Lower Limits to 10 dB.

SETup:WOOPower:OPEN:LOOP:POWer:UPPer:LIMit

Function

Sets/queries the Open Loop Power Error Upper Limit (see Open Loop Power Error Upper Limit ).
Requirements

Test Application Revision: A.04 and above

Lab Application Revision: A.02 and above

Setting

Range: 0.0 to 99.9

Resolution: 0.1

Query

Same as setting.

*RST Setting

 9.0 dB

Programming Example

OUTPUT 714;"SETup:WOOPower:OPEN:LOOP:POWer:UPPer:LIMit 10"
! Sets the Open Loop Power Error Upper Limit to 10 dB.

SETup:WOOPower:OPEN:LOOP:POWer:LOWer:LIMit

Function

Sets/queries the Open Loop Power Error Lower Limit (see Open Loop Power Error Lower Limit ).
Requirements

Test Application Revision: A.04 and above

Lab Application Revision: A.02 and above

Setting

Range: -99.9 to 0.0

Resolution: 0.1

Query

Same as setting.

*RST Setting

 -9.0 dB

Programming Example

OUTPUT 714;"SETup:WOOPower:OPEN:LOOP:POWer:LOWer:LIMit -10"
! Sets the Open Loop Power Error Lower Limit to -10 dB.

SETup:WOOPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the PRACH transmit on/off power measurement's timeout value (see Measurement Timeouts ), and (2) sets the timeout STATe to 1 (on).

The query form returns the PRACH transmit on/off power measurement's timeout value.
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

10 seconds, 0 (off)

Programming Example

OUTPUT 714;"SETup:WOOPower:TIMeout 5"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WOOPower:TIMeout:STATe

Function

Sets/queries the PRACH transmit on/off power measurement's timeout state (see Measurement Timeouts ).
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:WOOPower:TIMeout:STATe ON"

SETup:WOOPower:TIMeout:TIME

Function

Sets/queries the PRACH transmit on/off power measurement's timeout setting (see Measurement Timeouts ) to be used when the timeout state is set to ON.
Requirements

Test Application Revision: A.03 and above.

Lab Application Revision: A.01 and above.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETup:WOOPower:TIMeout:TIME 5"


SETup:WOOSynch

SETup:WOOSynch

This section is only applicable to the lab application.

Last updated: January 16, 2009

GPIB Command Conventions

  • SETup:WOOSynch:INTerval:AB
  • SETup:WOOSynch:INTerval:CD
  • SETup:WOOSynch:INTerval:DE

  • SETup:WOOSynch:RATio:AB
  • SETup:WOOSynch:RATio:BD
  • SETup:WOOSynch:RATio:DE
  • SETup:WOOSynch:RATio:E

  • SETup:WOOSynch:TIMeout[:STIMe]
  • SETup:WOOSynch:TIMeout:STATe
  • SETup:WOOSynch:TIMeout:TIME

SETup:WOOSynch:INTerval:AB

Function

 Sets/queries Segment Ta-b Interval .

Setting

Range: 0.04 to 5.00 seconds

Resolution: 0.04 seconds

Query

 Same as setting

*RST Setting

 5.00 seconds

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:INTerval:AB 3.5"
! Sets Segment Ta-b Interval to 3.52 s (because the resolution is 0.04 seconds).

SETup:WOOSynch:INTerval:CD

Function

 Sets/queries Segment Tc-d Interval .

Setting

Range: 0.04 to 5.00 seconds

Resolution: 0.04 seconds

Query

 Same as setting

*RST Setting

 5.00 seconds

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:INTerval:CD 3.5"
! Sets Segment Tc-d Interval to 3.52 s (because the resolution is 0.04 seconds).

SETup:WOOSynch:INTerval:DE

Function

 Sets/queries Segment Td-e Interval .

Setting

Range: 0.04 to 5.00 seconds

Resolution: 0.04 seconds

Query

 Same as setting

*RST Setting

 5.00 seconds

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:INTerval:DE 3.5"
! Sets Segment Td-e Interval to 3.52 s (because the resolution is 0.04 seconds).

SETup:WOOSynch:RATio:AB

Function

 Sets/queries DPCCH Quality Ratio Qa-b .

Setting

Range: -10.0 to -30.0 dB

Resolution: 0.1 dB

Query

 Same as setting

*RST Setting

 -21.6 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:RAT:AB -22.0"
! Sets DPCCH Quality Ratio Qa-b to -22.0 dB.

SETup:WOOSynch:RATio:BD

Function

 Sets/queries DPCCH Quality Ratio Qb-d .

Setting

Range: -10.0 to -30.0 dB

Resolution: 0.1 dB

Query

 Same as setting

*RST Setting

 -28.40 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:RATio:BD -28.0"
! Sets DPCCH Quality Ratio Qb-d to -28.0 dB.

SETup:WOOSynch:RATio:DE

Function

 Sets/queries DPCCH Quality Ratio Qd-e .

Setting

Range: -10.0 to -30.0 dB

Resolution: 0.1 dB

Query

 Same as setting

*RST Setting

 -24.40 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:RATio:DE -24.0"
! Sets DPCCH Quality Ratio Qd-e to -24.0 dB.

SETup:WOOSynch:RATio:E

Function

 Sets/queries DPCCH Quality Ratio Qe+ .

Setting

Range: -10.0 to -30.0 dB

Resolution: 0.1 dB

Query

 Same as setting

*RST Setting

 -17.60 dB

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:RATio:E -18.0"
! Sets DPCCH Quality Ratio Qe+ to -18.0 dB.

SETup:WOOSynch:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the measurement's timeout (see Measurement Timeouts ) value, and (2) sets the measurement's timeout STATe to 1 (on).

The query form returns the measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

20 seconds, (off)

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:TIMeout 5"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WOOSynch:TIMeout:STATe

Function

Sets/queries the measurement's timeout state (see Measurement Timeouts ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:TIMeout:STATe ON"
! Sets the measurement's timeout state to ON.

SETup:WOOSynch:TIMeout:TIME

Function

Sets/queries the measurement's timeout setting to be used when the timeout state is set to ON (see Measurement Timeouts ).

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Same as setting

*RST Setting

20 seconds

Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WOOSynch:TIMeout:TIME 5"
! Sets the measurement's timeout to five seconds.


SETup:WPDiscon

SETup:WPDiscon

Last updated: November 12, 2010

GPIB Command Conventions

  • SETup:WPDiscon:INTerval
  • SETup:WPDiscon:NPRepetition
  • SETup:WPDiscon:PCPattern
  • SETup:WPDiscon:REFined:SDECoder:STATe
  • SETup:WPDiscon:RTIMeslot

  • SETup:WPDiscon:STEP:COUNt
  • SETup:WPDiscon:STEP:INTerval

  • SETup:WPDiscon:TIMeout[:STIMe]
  • SETup:WPDiscon:TIMeout:STATe
  • SETup:WPDiscon:TIMeout:TIME

  • SETup:WPDiscon:TRIGger:ALIGnment:HSDPcchannel:SLOT
  • SETup:WPDiscon:TRIGger:ALIGnment:HSDPcchannel:SUBFrame
  • SETup:WPDiscon:TRIGger:ALIGnment:HSDPcchannel:SUBSlot
  • SETup:WPDiscon:TRIGger:SOURce

SETup:WPDiscon:INTerval

Function

Sets/queries the Measurement Interval .

This setting is only applicable when SETup:WPDiscon:TRIGger:SOURce is set to External or Protocol , and SETup:WPDiscon:PCPattern is set to NONE .

Setting

Range: 2 to 90 slots

Resolution: 1 slot

Query

 Same as setting.

*RST Setting

2 slots

Requirements

Test Application Revision: A.05 and above

Test Application Revision A.06 changed range upper limit from 75 to 90

Lab Application Revision: B.01 and above

Lab Application Revision C.01 changed range upper limit from 75 to 90

Programming Example

OUTPUT 714;"SETup:WPDiscon:INTerval 6"
! Sets the measurement interval to 6 slots.

SETup:WPDiscon:NPRepetition

Function

Sets/queries the Number of Pattern Repetitions .

This setting is only applicable when SETup:WPDiscon:TRIGger:SOURce is set to External or Protocol , and SETup:WPDiscon:PCPattern is set to DN5_4UP or UP5_4DN .

Setting

Range: 1 to 10

Resolution: 1

Query

 Same as setting.

*RST Setting

2

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:NPRepetition 10"
! Sets the Number of Pattern Repetitions to 10.

SETup:WPDiscon:PCPattern

Function

Sets/queries the Power Control Pattern .

This setting is only applicable when SETup:WPDiscon:TRIGger:SOURce is set to External or Protocol .

Setting

Range:

  • DN18
  • DN5_4UP
  • NONE
  • UP18
  • UP5_4DN

Query

 Same as setting.

*RST Setting

NONE

Requirements

Test Application Revision: A.06 and above

Test Application Revision A.09 added DN18 and UP18

Lab Application Revision: C.01 and above

Lab Application Revision C.04 and D.00 added DN18 and UP18

Programming Example

OUTPUT 714;"SETup:WPDiscon:PCPattern DN5_4UP"
! Sets the Power Control Pattern to 5DOWN/4UP.

SETup:WPDiscon:REFined:SDECoder:STATe

Function

Sets/queries the refined symbol decoder state for the Phase Discontinuity measurement.

When this setting is set to Off, the typical symbol decoder function will be used; when this setting is set to ON, the refined symbol decoder function will be used. The refined symbol decoder is expected to improve the symbol decoder performance when decoding the impairment signal but is slower. When the measured signal is of good quality, the typical symbol decoder function behaves the same as the refined symbol decoder. You are recommend to use the typical symbol decoder state when measuring a relative good quality signal to save the measurement time.

This setting is GPIB only.

Setting

 1|ON|0|OFF

Query

 1|0

*RST Setting

 0|OFF

Requirements

 Test Application Revision: A.17.00 and above
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:REFined:SDECoder:STATe 1"
! Sets the refined symbol decoder state to On.

SETup:WPDiscon:RTIMeslot

Function

Sets/queries the Reference Timeslot .

This setting is only applicable when SETup:WPDiscon:TRIGger:SOURce is set to External or Protocol , and SETup:WPDiscon:PCPattern is set to NONE .

Setting

Range: 0 to 14

Resolution: 1

Query

 Same as setting.

*RST Setting

 0

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:RTIMeslot 8"
! Sets the reference timeslot to the 9th slot of the first available frame.

SETup:WPDiscon:STEP:COUNt

Function

Sets/queries HS-DPCCH Measurement Step Count .

This command is only applicable when SETup:WPDiscon:TRIGger:SOURce is set to HSDPcchannel .

Setting

Range: 1 to 90

Resolution: 1

Query

 Same as setting.

*RST Setting

 21

Requirements

Test Application Revision: A.10 and above with the required feature license

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:STEP:COUNt 90"
! Sets HS-DPCCH Measurement Step Count to 90.

SETup:WPDiscon:STEP:INTerval

Function

Sets/queries HS-DPCCH Measurement Step Interval .

This command is only applicable when SETup:WPDiscon:TRIGger:SOURce is set to HSDPcchannel .

The sum of HS-DPCCH Trigger Subslot Alignment (see SETup:WPDiscon:TRIGger:ALIGnment:HSDPcchannel:SUBSlot ) and HS-DPCCH Measurement Step Interval cannot exceed 1 slot.

Setting

Range: 0.5 or 1.0 slot

Query

 Same as setting.

*RST Setting

 0.5 slot

Requirements

Test Application Revision: A.10 and above with the required feature license

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:STEP:INTerval 1.0"
! Sets HS-DPCCH Measurement Step Interval to 1.0 slot.

SETup:WPDiscon:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the phase discontinuity measurement's timeout (see Measurement Timeouts ) value, and (2) sets the phase discontinuity measurement's timeout STATe to 1 (on).

The query form returns the phase discontinuity measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

10 seconds, (off)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:TIMeout 5"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WPDiscon:TIMeout:STATe

Function

Sets/queries the phase discontinuity measurement's timeout state (see Measurement Timeouts ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:TIMeout:STATe ON"
! Sets the phase discontinuity measurement's timeout state to ON.

SETup:WPDiscon:TIMeout:TIME

Function

Sets/queries the phase discontinuity measurement's timeout setting to be used when the timeout state is set to ON (see Measurement Timeouts ).

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Same as setting

*RST Setting

10 seconds

Requirements

Test Application Revision: A.05 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:TIMeout:TIME 5"
! Sets the phase discontinuity measurement's timeout to five seconds.

SETup:WPDiscon:TRIGger:ALIGnment:HSDPcchannel:SLOT

Function

Sets/queries HS-DPCCH Trigger Slot Alignment .

This command is only applicable when SETup:WPDiscon:TRIGger:SOURce is set to HSDPcchannel .

Setting

Range: ACKNack|CQI1|CQI2

Query

 Range: ACKN|CQI1|CQI2

*RST Setting

 ACKN

Requirements

Test Application Revision: A.10 and above with the required feature license

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:TRIGger:ALIGnment:HSDPcchannel:SLOT CQI2"
! Sets HS-DPCCH Trigger Slot Alignment to CQI2.

SETup:WPDiscon:TRIGger:ALIGnment:HSDPcchannel:SUBFrame

Function

Sets/queries HS-DPCCH Trigger Subframe Alignment .

This command is only applicable when SETup:WPDiscon:TRIGger:SOURce is set to HSDPcchannel .

Setting

Range: 0 to 5

Resolution: 1

Query

 Same as setting.

*RST Setting

 0

Requirements

Test Application Revision: A.10 and above with the required feature license

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:TRIGger:ALIGnment:HSDPcchannel:SUBFrame 5"
! Sets HS-DPCCH Trigger Subframe Alignment to subframe 5.

SETup:WPDiscon:TRIGger:ALIGnment:HSDPcchannel:SUBSlot

Function

Sets/queries HS-DPCCH Trigger Subslot Alignment .

This command is only applicable when SETup:WPDiscon:TRIGger:SOURce is set to HSDPcchannel .

The sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Step Interval (see SETup:WPDiscon:STEP:INTerval ) cannot exceed 1 slot.

Setting

Range: 0.0 or 0.5 slot

Query

 Same as setting.

*RST Setting

 0.0 slot

Requirements

Test Application Revision: A.10 and above with the required feature license

Lab Application Revision: D.01 and above

Programming Example

OUTPUT 714;"SETup:WPDiscon:TRIGger:ALIGnment:HSDPcchannel:SUBSlot 0.5"
! Sets HS-DPCCH Trigger Subslot Alignment to 0.5 slot.

SETup:WPDiscon:TRIGger:SOURce

Function

Sets/queries the Trigger Source .

Setting

Range:

  • EXTernal
  • HSDPcchannel (lab application or feature-licensed test application only)
  • PROTocol

Query

Range:

  • EXT
  • HSDP (lab application or feature-licensed test application only)
  • PROT

*RST Setting

 PROT

Requirements

Test Application Revision: A.05 and above

Test Application Revision A.06 changed *RST setting from AUTO to PROT

Test Application Revision A.10 with required feature license, added HSDPcchannel

Lab Application Revision: B.01 and above

Lab Application Revision C.01 changed *RST setting from AUTO to PROT

Lab Application D.01, added HSDPcchannel

Programming Example

OUTPUT 714;"SETup:WPDiscon:TRIGger:SOURce PROTocol"
! Sets the phase discontinuity measurement trigger source to PROTocol.


SETup:WPESquality

SETup:WPESquality

Last updated: October 26, 2010

GPIB Command Conventions

  • SETup:WPESquality:CONTinuous
  • SETup:WPESquality:INPut:VOLTage[:EXPected]
  • SETup:WPESquality:MEASurement:MODE
  • SETup:WPESquality:OUTPut:VOLTage[:MAXimum]
  • SETup:WPESquality:SPEech
  • SETup:WPESquality:TIMeout[:STIMe]
  • SETup:WPESquality:TIMeout:STATe
  • SETup:WPESquality:TIMeout:TIME

SETup:WPESquality:CONTinuous

Function

Sets/queries the trigger arm state for the PESQ measurement. See PESQ Measurement Parameters .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: G.00 and above
Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"SETup:WPESquality:CONTinuous OFF"
!Sets measurement to single trigger mode.

SETup:WPESquality:INPut:VOLTage[:EXPected]

Function

Sets/queries the Expected Audio In Peak Voltage that is applied at the test set's AUDIO IN connector for the PESQ measurement. The units (V|mV|uV) are optional. If no units are specified, then units default to V. See PESQ Measurement Parameters .

Setting

Range: 0.001 to 2.0 V

Resolution: 1 mV

Query

Range: 0.001 to 2.0 V

*RST Setting

 2.0 V

Requirements

Lab Application Revision G.00 and above
Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"SETup:WPESquality:INPut:VOLTage 2"
!Sets the PESQ Expected Audio In Peak Voltage to 2 V.

SETup:WPESquality:MEASurement:MODE

Function

Sets/queries the measurement mode used by the PESQ measurements. See PESQ Measurement Parameters .

Setting

Range: UPLink | DOWNlink | BOTH

Query

Range: UPL| DOWN | BOTH

*RST Setting

 BOTH

Requirements

Lab Application Revision: G.00 and above
Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"SETup:WPESquality:MEASurement:MODE UPL"
!Sets the PESQ measurement mode to Uplink audio.

SETup:WPESquality:OUTPut:VOLTage[:MAXimum]

Function

Sets/queries the PESQ Maximum Audio Out Peak voltage. The units (V|mV|uV) are optional. If no units are specified, then units default to V. See PESQ Measurement Parameters .

Setting

Range: 0.0 to 5.0 V

Resolution: 0.1 mV

Query

Range: 0.0 to 5.0 V

Resolution: 0.1 mV

*RST Setting

 0.0 V

Requirements

Lab Application Revision: G.00 and above
Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"SETup:WPESquality:OUTPut:VOLTage 0.0"
! Sets the PESQ Maximum Audio Out Peak voltage.

SETup:WPESquality:SPEech

Function

Sets/queries the speech source of the PESQ measurement. See PESQ Measurement Parameters .

Setting

Range: MALE | FEMale

Query

Range: MALE | FEM

*RST Setting

 MALE

Requirements

Lab Application Revision: G.00 and above
Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"SETup:WPESquality:SPEech MALE"
!Sets the PESQ speech source to Male.

SETup:WPESquality:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the PESQ measurements' time-out STATe to 1 (ON) and, (2) sets the PESQ measurements' time-out value.

The query form returns the PESQ measurements' time-out value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, ON

Requirements

Lab Application Revision: G.00 and above
Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"SETup:WPESquality:TIMeout 5S"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WPESquality:TIMeout:STATe

Function

Sets/queries the PESQ measurements's time-out state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: G.00 and above
Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"SETup:WPESquality:TIMeout:STATe ON"

SETup:WPESquality:TIMeout:TIME

Function

Sets/queries the PESQ measurements' time-out setting to be used when the time-out state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 1 second

Query

Range: 0.1 second

*RST Setting

10 seconds

Requirements

Lab Application Revision: G.00 and above
Test Application Revision: A.16.00 and above

Programming Example

OUTPUT 714;"SETup:WPESquality:TIMeout:TIME 5S"


SETup:WPPAnalysis

SETup:WPPAnalysis

Last updated: January 16, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • SETup:WPPAnalysis:TRANsient

  • SETup:WPPAnalysis:TRIGger:DELay
  • SETup:WPPAnalysis:TRIGger:SOURce

  • SETup:WPPAnalysis:TIMeout[:STIMe]
  • SETup:WPPAnalysis:TIMeout:STATe
  • SETup:WPPAnalysis:TIMeout:TIME

SETup:WPPAnalysis:TRANsient

Function

Sets/queries the Transient Period setting.

Setting

Range: INCLude|EXCLude

Query

Range: INCL|EXCL

*RST Setting

EXCL

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPPAnalysis:TRANsient EXCLude"
! Excludes PRACH preamble transient periods from PRACH analysis.

SETup:WPPAnalysis:TRIGger:DELay

Function

 Sets/queries the Trigger Delay . This setting is applied only when SETup:WPPAnalysis:TRIGger:SOURce is set to RISE.

Setting

Range: -5120 to 5120 chips

Resolution: 1 chip

Query

Same as setting

*RST Setting

 0 chips

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPPAnalysis:Trigger:DELay 284"

SETup:WPPAnalysis:TRIGger:SOURce

Function

 Sets/queries the Trigger Source .

Setting

Range: PROTocol|EXTernal|RISE

Query

Range: PROT|EXT|RISE

*RST Setting

 PROT

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPPAnalysis:TRIGger:SOURce RISE"
! Sets the PRACH preamble analysis trigger to RF rise.

SETup:WPPAnalysis:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the PRACH preamble analysis timeout (see Measurement Timeouts ) value, and (2) sets the PRACH preamble analysis timeout STATe to 1 (on).

The query form returns the PRACH preamble analysis timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

10 seconds, off

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPPAnalysis:TIMeout 5"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WPPAnalysis:TIMeout:STATe

Function

Sets/queries the PRACH preamble analysis timeout state (see Measurement Timeouts ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPPAnalysis:TIMeout:STATe ON"
! Sets the timeout state to ON.

SETup:WPPAnalysis:TIMeout:TIME

Function

Sets/queries PRACH preamble analysis timeout setting to be used when the timeout state is set to ON (see Measurement Timeouts ).

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Same as setting

*RST Setting

10 seconds

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:WPPAnalysis:TIMeout:TIME 5"
! Sets the timeout to 5 seconds.


SETup:WSEMask

SETup:WSEMask

Last updated: January 16, 2009

GPIB Command Conventions

  • SETup:WSEMask:BOUNdary:ADDitional[1]
  • SETup:WSEMask:BWIDth:ADDitional2

  • SETup:WSEMask:CONTinuous

  • SETup:WSEMask:COUNt[:SNUMber]
  • SETup:WSEMask:COUNt:NUMBer
  • SETup:WSEMask:COUNt:STATe

  • SETup:WSEMask:LIMit:ADDitional[1]
  • SETup:WSEMask:LIMit:ADDitional2
  • SETup:WSEMask:LIMit:REQuirement

  • SETup:WSEMask:TIMeout[:STIMe]
  • SETup:WSEMask:TIMeout:STATe
  • SETup:WSEMask:TIMeout:TIME

  • SETup:WSEMask:TRIGger:ALIGnment:HSDPcchannel:SUBFrame
  • SETup:WSEMask:TRIGger:DELay
  • SETup:WSEMask:TRIGger:SOURce

  • SETup:WSEMask:LIMit:BWIDTH30
  • SETup:WSEMask:LIMit:BWIDTH1000

SETup:WSEMask:BOUNdary:ADDitional[1]

Function

Sets/queries the range boundary between range 1 and range 2 for additional SEM requirements.

Setting

Range:

  • KHZ2600 (2.6 MHz)
  • KHZ3500 (3.5 MHz)

Query

Range:

  • KHZ2600 (2.6 MHz)
  • KHZ3500 (3.5 MHz)

*RST Setting

KHZ3500

Requirements

Test Application Revision: A.14 and above.

Programming Example

OUTPUT 714;"SETup:WSEMask:BOUNdary:ADDitional KHZ3500"
!Sets the range boundary between range 1 and 2 for additional SEM requirements.

SETup:WSEMask:BWIDth:ADDitional2

Function

Sets/queries the measurement bandwidth of the second range of the additional SEM requirements, either 100 kHz or 1 MHz (as defined in TS 25.101 (v8.3.0, 2008-07)).

Setting

Range:

  • KHZ100
  • KHZ1000

Query

Range:

  • KHZ100
  • KHZ1000

*RST Setting

KHZ100

Requirements

Test Application Revision: A.14 and above.

Programming Example

OUTPUT 714;"SETup:WSEMask:BWIDth:ADDitional2 KHZ100"
!Sets the the measurement bandwidth of the second range of the
!additional SEM requirements to 100 kHz.

SETup:WSEMask:CONTinuous

Function

Sets/queries the trigger arm state for the spectrum emission mask measurement. The trigger arm state determines whether the spectrum emission mask measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

See Spectrum Emission Mask Measurement Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:WSEMask:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of spectrum emission mask measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of spectrum emission mask multi-measurements to be made when multi-measurement state is ON.

See Spectrum Emission Mask Measurement Description .

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:WSEMask:COUNt:NUMBer

Function

Sets/queries the number of spectrum emission mask measurements to be made when the multi-measurement state is ON.

See Spectrum Emission Mask Measurement Description .

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:COUNT:NUMBER 5"
!Sets the number of spectrum emission mask multi-measurements to 5.

SETup:WSEMask:COUNt:STATe

Function

Sets/queries the spectrum emission mask multi-measurement state.

See Spectrum Emission Mask Measurement Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:COUNT:STATE ON"
! Turns on spectrum emission mask multi-measurements.

SETup:WSEMask:LIMit:ADDitional[1]

Function

Sets/queries the first additional limit, which is applied to the first range for additional SEM requirements.

Setting

Range: -61.0 dBm to +28 dBm

Resolution: 0.01 dBm

Query

Same as setting

*RST Setting

-15 dBm

Requirements

Test Application Revision: A.14 and above.

Programming Example

OUTPUT 714;"SETup:WSEMask:LIMit:ADDitional -15DBM"
! Sets the first additional limit to -15 dBm.

SETup:WSEMask:LIMit:ADDitional2

Function

Sets/queries the second additional limit, which is applied to the second range for additional SEM requirements.

Setting

Range: -61.0 dBm to +28 dBm

Resolution: 0.01 dBm

Query

Same as setting

*RST Setting

-13 dBm

Requirements

Test Application Revision: A.14 and above.

Programming Example

OUTPUT 714;"SETup:WSEMask:LIMit:ADDitional2 -13DBM"
! Sets the first additional limit to -13 dBm.

SETup:WSEMask:LIMit:REQuirement

Function

Sets/queries the spectrum emission mask (SEM) fail limit mask.

When set to BASic (Basic Limit Only), SEM is tested for the basic SEM requirement only, and results are returned only for ranges 1 to 4 of the basic limit.

When set to BADDitional (Basic AND Additional Limit), SEM is tested for both basic and additional SEM requirements. Results are returned for range 1 to 4 and the additional range 1 to 2.

Setting

Range: BASic | BADDitional

Query

Range: BAS | BADD

*RST Setting

BASic

Requirements

Test Application Revision: A.14 and above.

Programming Example

OUTPUT 714;"SETup:WSEMask:LIMit:REQuirement BASic"
! Sets the spectrum emission mask (SEM) fail limit mask to basic limit only.

SETup:WSEMask:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the spectrum emission mask measurement's timeout (see Measurement Timeouts ) value, and (2) sets the spectrum emission mask measurement's timeout STATe to 1 (on).

The query form returns the spectrum emission mask measurement's timeout value.

See Spectrum Emission Mask Measurement Description .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:TIMEOUT:STIME 5 S"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WSEMask:TIMeout:STATe

Function

Sets/queries the spectrum emission mask measurement's timeout (see Measurement Timeouts ) state.

See Spectrum Emission Mask Measurement Description .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:TIMEOUT:STATE ON"

SETup:WSEMask:TIMeout:TIME

Function

Sets/queries the spectrum emission mask measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON.

See Spectrum Emission Mask Measurement Description .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:TIMEOUT:TIME 5 S"

SETup:WSEMask:TRIGger:ALIGnment:HSDPcchannel:SUBFrame

Function

Sets/queries the SEM measurement's HS-DPCCH Trigger Subframe Alignment setting.

This command is only applicable when SETup:WSEMask:TRIGger:SOURce is set to HSDPcchannel .

Setting

Range: 0 to 5

Resolution: 1

Query

 Same as setting

*RST Setting

 0 (subframe 0)

Requirements

Test Application Revision: A.08 and above with the required feature license

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"SETup:WSEMask:TRIGger:ALIGnment:HSDPcchannel:SUBFrame 1"
! Sets HS-DPCCH Trigger Subframe Alignment to subframe 1.

SETup:WSEMask:TRIGger:DELay

Function

Sets/queries the spectrum emission mask measurement's Trigger Delay setting.

This setting can be used to delay the measurement trigger in order to start a measurement during a specific timeslot in the frame. For example, a 1.333 ms delay would cause the trigger to wait until after the first two timeslots have elapsed.

Setting

Range: -12 to 12 ms

Resolution: 1 ns

Query

 Same as setting

*RST Setting

0 seconds

Requirements

Test Application Revision: A.02 and above

Test Application Revision A.08 and Lab Application C.03, increased range to -12 to 12 ms (previously it was -10 ms to 10 ms)

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WSEMASK:TRIGGER:DELAY 1MS"

SETup:WSEMask:TRIGger:SOURce

Function

Sets/queries the spectrum emission mask measurement's Trigger Source .

Setting

Range:

  • AUTO
  • EXTernal
  • HSDPcchannel (feature-licensed test application only)
  • IMMediate
  • PROTocol

Query

Range:

  • AUTO
  • EXT
  • HSDP (feature-licensed test application only)
  • IMM
  • PROT

*RST Setting

 AUTO

Requirements

Test Application Revision: A.02 and above

Test Application Revision A.08 with the required feature license and Lab Application C.03, added HSDPcchannel

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WSEMASK:TRIGGER:SOURCE IMMEDIATE"

SETup:WSEMask:LIMit:BWIDTH30

Function

Sets/queries the spectrum emission mask measurement's pass/fail limits for the 30 kHz bandwidth filter frequency offsets.

There are two 30 kHz bandwidth filter pass/fail settings, one for the +/-2.5 MHz offset and one for the +/-3.5 MHz offset.

See Spectrum Emission Mask Measurement Description .

Setting

Range: -90 to 0 dBc

Resolution: 0.01 dBc

Query

Range: -90 to 0

*RST Setting

 -35 dBc (+/-2.5 MHz offset), -50 dBc(+/-3.5 MHz offset)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:LIMit:BWIDTH30 -35,-34"
! Sets the +/-2.5 MHz frequency offset pass/fail limit to -35
! and sets the +/-3.5 MHz frequency offset to -34

SETup:WSEMask:LIMit:BWIDTH1000

Function

Sets/queries the spectrum emission mask measurement's pass/fail limits for the 1 MHz bandwidth filter frequency offsets.

There are four 1 MHz bandwidth filter pass/fail settings

  • +/-3.5 MHz offset
  • +/-7.5 MHz offset
  • +/-8.5 MHz offset
  • +/-12.5 MHz offset

See Spectrum Emission Mask Measurement Description .

Setting

Range: -90 to 0 dBc

Resolution: 0.01 dBc

Query

Range: -90 to 0

*RST Setting

 -35 dBc (+/-3.5 MHz offset), -39 dBc (+/-7.5 MHz offset), -49 dBc (+/-8.5 MHz offset), -49 dBc(+/-12.5 MHz offset)

Requirements

Test Application Revision: A.02 and above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SETUP:WSEMASK:LIMit:BWIDTH1000 -35,-34,-45,-45"
! Sets the pass/fail limits for the four SEM 1 MHz filter frequency offsets.


SETup:WTDPower

SETup:WTDPower

Last updated: January 16, 2009

GPIB Command Conventions

  • SETup:WTDPower:STEP[:LEVel]
  • SETup:WTDPower:STEP:COUNt
  • SETup:WTDPower:STEP:TIME

  • SETup:WTDPower:TIMeout[:STIMe]
  • SETup:WTDPower:TIMeout:STATe
  • SETup:WTDPower:TIMeout:TIME

SETup:WTDPower:STEP[:LEVel]

Function

Sets/queries Power Step Size .

Setting

Range: -90.00 to -0.01 dB

Resolution: 0.01 dB

Query

 Same as setting

*RST Setting

 -4.00 dB

Requirements

Test Application Revision: A.07 and above

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:WTDPower:STEP -5"
! Sets the power step size to -5 dB.

SETup:WTDPower:STEP:COUNt

Function

Sets/queries Number of Power Steps .

The total number of power results returned by the measurement is 1 + Number of Power Steps . The total number of power results available can be queried using the FETCh:WTDPower:COUNt[:STEP]? command.

Setting

Range: 0 to 99

Resolution: 1

Query

 Same as setting

*RST Setting

 19

Requirements

Test Application Revision: A.07 and above

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:WTDPower:STEP:COUNt 5"
! Sets the number of power steps to 5.

SETup:WTDPower:STEP:TIME

Function

Sets/queries the Power Step Time .

Setting

Range: MS20|MS40|MS80

Query

 Same as setting

*RST Setting

 MS20

Requirements

Test Application Revision: A.07 and above

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:WTDPower:STEP:TIME MS40"
! Sets power step time to 40 ms.

SETup:WTDPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the measurement timeout value (see SETup:WTDPower:TIMeout:TIME ), and (2) sets the measurement timeout state to on (see SETup:WTDPower:TIMeout:STATe ).

The query form of this command returns the measurement timeout value.

See Measurement Timeouts .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

10 seconds

Requirements

Test Application Revision: A.07 and above

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:WTDPower:TIMeout 5"
! Sets timeout state to on and sets the timeout time to 5 seconds.

SETup:WTDPower:TIMeout:STATe

Function

Sets/queries the measurement timeout state.

The measurement timeout state can also be set to on using the SETup:WTDPower:TIMeout[:STIMe] command.

See Measurement Timeouts .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: A.07 and above

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:WTDPower:TIMeout:STATe ON"

SETup:WTDPower:TIMeout:TIME

Function

Sets/queries the measurement timeout value to be used when the timeout state is set to on.

The measurement timeout value can also be set using the SETup:WTDPower:TIMeout[:STIMe] command.

See Measurement Timeouts .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

10 seconds

Requirements

Test Application Revision: A.07 and above

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"SETup:WTDPower:TIMeout:TIME 5"


SETup:WTPower

SETup:WTPower

Last updated: May 10, 2010

GPIB Command Conventions

  • SETup:WTPower:CONTinuous

  • SETup:WTPower:COUNt[:SNUMber]
  • SETup:WTPower:COUNt:NUMBer
  • SETup:WTPower:COUNt:STATe

  • SETup:WTPower:TIMeout[:STIMe]
  • SETup:WTPower:TIMeout:STATe
  • SETup:WTPower:TIMeout:TIME

SETup:WTPower:CONTinuous

Function

Sets/queries the trigger arm state for the thermal power measurement. The trigger arm state determines whether the thermal power measurement will be made once then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WTPOWER:CONTINUOUS ON"
!Sets measurement to single trigger mode.

SETup:WTPower:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of thermal power measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of thermal power multi-measurements to be made when multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WTPOWER:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:WTPower:COUNt:NUMBer

Function

Sets/queries the number of thermal power measurements to be made when the multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WTPOWER:COUNT:NUMBER 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:WTPower:COUNt:STATe

Function

Sets/queries the multi-measurement state of the thermal power measurement.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WTPOWER:COUNT:STATE ON" !Turns on multi-measurements.

SETup:WTPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the thermal power measurement's timeout value, and (2) sets the thermal power measurement's timeout STATe to 1 (on).

The query form returns the channel power measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WTPOWER:TIMEOUT:STIME 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WTPower:TIMeout:STATe

Function

Sets/queries the thermal power measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WTPOWER:TIMEOUT:STATE ON"

SETup:WTPower:TIMeout:TIME

Function

Sets/queries the thermal power measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WTPOWER:TIMEOUT:TIME 5S"


SETup:WWQuality

SETup:WWQuality

Last updated: November 17, 2010

GPIB Command Conventions

  • SETup:WWQuality:ALIGnment:SFNumber
  • SETup:WWQuality:CONTinuous

  • SETup:WWQuality:COUNt[:SNUMber]
  • SETup:WWQuality:COUNt:NUMBer
  • SETup:WWQuality:COUNt:STATe

  • SETup:WWQuality:INTerval:HSDPcchannel

  • SETup:WWQuality:REFined:SDECoder:STATe
  • SETup:WWQuality:TIMeout[:STIMe]
  • SETup:WWQuality:TIMeout:STATe
  • SETup:WWQuality:TIMeout:TIME

  • SETup:WWQuality:TRANsient

  • SETup:WWQuality:TRIGger:ALIGnment:HSDPcchannel:SLOT
  • SETup:WWQuality:TRIGger:ALIGnment:HSDPcchannel:SUBFrame
  • SETup:WWQuality:TRIGger:ALIGnment:HSDPcchannel:SUBSlot
  • SETup:WWQuality:TRIGger:SOURce

  • SETup:WWQuality:TSLot

SETup:WWQuality:ALIGnment:SFNumber

Function

Sets/queries which frame will be measured when the Even Frame trigger source is selected.

Setting

Range: ODD|EVEN

Query

Range: ODD|EVEN

*RST Setting

 EVEN

Requirements

Lab Application Revision F.00, and above.

Test Application Revision: A.14 and above, with the required feature license

Programming Example

OUTPUT 714;"SETup:WWQuality:ALIGnment:SFNumber EVEN"

SETup:WWQuality:CONTinuous

Function

Sets/queries the trigger arm state for the waveform quality measurement. The trigger arm state determines whether the waveform quality measurement will be made once then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:WWQuality:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of waveform quality measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of waveform quality multi-measurements to be made when multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:WWQuality:COUNt:NUMBer

Function

Sets/queries the number of waveform quality measurements to be made when the multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:COUNT:NUMBER 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:WWQuality:COUNt:STATe

Function

Sets/queries the multi-measurement state of the waveform quality measurement.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:COUNT:STATE ON"
! Turns on multi-measurements.

SETup:WWQuality:INTerval:HSDPcchannel

Function

Sets/queries HS-DPCCH Measurement Interval .

This command is only applicable when SETup:WWQuality:TRIGger:SOURce = HSDPcchannel.

The sum of HS-DPCCH Trigger Subslot Alignment (see SETup:WWQuality:TRIGger:ALIGnment:HSDPcchannel:SUBSlot ) and HS-DPCCH Measurement Interval cannot exceed 1 slot.

Setting

Range: 0.5 to 1.0 slot

Resolution: 0.1 slot

Query

 Same as setting

*RST Setting

 1.0 slot

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"SETup:WWQuality:INTerval:HSDPcchannel 0.8"
! Sets HS-DPCCH Measurement Interval to 0.8 slot.

SETup:WWQuality:REFined:SDECoder:STATe

Function

Sets/queries the refined symbol decoder state for the waveform quality measurement.

When this setting is set to Off, the typical symbol decoder function will be used; when this setting is set to ON, the refined symbol decoder function will be used. The refined symbol decoder is expected to improve the symbol decoder performance when decoding the impairment signal but is slower. When the measured signal is of good quality, the typical symbol decoder function behaves the same as the refined symbol decoder. You are recommend to use the typical symbol decoder state when measuring a relative good quality signal to save the measurement time.

This setting is GPIB only.

Setting

 1|ON|0|OFF

Query

 1|0

*RST Setting

 0|OFF

Requirements

 Test Application Revision: A.17.00 and above
Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"SETup:WWQuality:REFined:SDECoder:STATe 1"
! Sets the refined symbol decoder state to On.

SETup:WWQuality:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the waveform quality measurement's timeout value, and (2) sets the waveform quality measurement's timeout STATe to 1 (on).

The query form returns the waveform quality measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, off

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:TIMEOUT:STIME 5S"
! Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WWQuality:TIMeout:STATe

Function

Sets/queries the waveform quality measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:TIMEOUT:STATE ON"

SETup:WWQuality:TIMeout:TIME

Function

Sets/queries the waveform quality measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:TIMEOUT:TIME 5S"

SETup:WWQuality:TRANsient

Function

Sets/queries Transient Period .

Setting

Range: INCLude|EXCLude

Query

Range: INCL|EXCL

*RST Setting

 INCL (include)

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Test Application Revision A.10 and Lab Application D.01, this command is now applicable for all Trigger Source settings (non-HSDPA as well as HSDPA)

Programming Example

OUTPUT 714;"SETup:WWQuality:TRANsient EXCLude"
! Sets Transient Period to Exclude.

SETup:WWQuality:TRIGger:ALIGnment:HSDPcchannel:SLOT

Function

Sets/queries HS-DPCCH Trigger Slot Alignment .

This command is only applicable when SETup:WWQuality:TRIGger:SOURce = HSDPcchannel.

Setting

Range: ACKNack|CQI1|CQI2

Query

Range: ACKN|CQI1|CQI2

*RST Setting

 ACKN

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"SETup:WWQuality:TRIGger:ALIGnment:HSDPcchannel:SLOT CQI1"
! Sets HS-DPCCH Trigger Slot Alignment to CQI1.

SETup:WWQuality:TRIGger:ALIGnment:HSDPcchannel:SUBFrame

Function

Sets/queries HS-DPCCH Trigger Subframe Alignment .

This command is only applicable when SETup:WWQuality:TRIGger:SOURce = HSDPcchannel.

Setting

Range: 0 to 5

Resolution: 1

Query

 Same as setting.

*RST Setting

 0

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"SETup:WWQuality:TRIGger:ALIGnment:HSDPcchannel:SUBFrame 3"
! Sets HS-DPCCH Trigger Subframe Alignment to subframe 3.

SETup:WWQuality:TRIGger:ALIGnment:HSDPcchannel:SUBSlot

Function

Sets/queries HS-DPCCH Trigger Subslot Alignment .

This command is only applicable when SETup:WWQuality:TRIGger:SOURce = HSDPcchannel.

The sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval (see SETup:WWQuality:INTerval:HSDPcchannel ) cannot exceed 1 slot.

Setting

Range: 0 to 0.5 slot

Resolution: 0.1 slot

Query

 Same as setting.

*RST Setting

 0.0 slot

Requirements

Test Application Revision: A.09 and above, with the required feature license

Lab Application Revision: C.04 and above

Lab Application Revision: D.00 and above

Programming Example

OUTPUT 714;"SETup:WWQuality:TRIGger:ALIGnment:HSDPcchannel:SUBSlot 0.3"
! Sets HS-DPCCH Trigger Subslot Alignment to 0.3 slot.

SETup:WWQuality:TRIGger:SOURce

Function

Sets/queries Trigger Source .

Setting

Range: IMMediate|PROTocol|EXTernal|AUTO|HSDPcchannel|EFRame

Query

Range: IMM|PROT|EXT|AUTO|HSDP|EFR

*RST Setting

 AUTO

Requirements

Test Application Revision: A.02 and above.

Test Application Revision A.09, with the required feature license, added HSDPcchannel.

Lab Application Revision: A.01 and above.

Lab Application Revision C.04, D.00, added HSDPcchannel.

Lab Application Revision F.00, added EFRame.

Test Application Revision A.14, with the required feature license, added EFRame.

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:TRIGGER:SOURCE AUTO"

SETup:WWQuality:TSLot

Function

Sets/queries Timeslot .

This command is only applicable when SETup:WWQuality:TRIGger:SOURce is NOT set to HSDPcchannel.

Setting

Range: 0 to 14

Resolution: 1

Query

 Same as setting

*RST Setting

0

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:WWQUALITY:TSLOT 10"


CALL:SMService

CALL:SMService

Last updated: January 16, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:SMService:CBRoadcast:MESSage[<n>]:CDATa
  • CALL:SMService:CBRoadcast:MESSage[<n>]:CODE
  • CALL:SMService:CBRoadcast:MESSage[<n>]:CONTent
  • CALL:SMService:CBRoadcast:MESSage[<n>]:CTEXt
  • CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme[:SPECify]
  • CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:LANGuage
  • CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:VALue
  • CALL:SMService:CBRoadcast:MESSage[<n>]:GSCope
  • CALL:SMService:CBRoadcast:MESSage[<n>]:IDENtifier
  • CALL:SMService:CBRoadcast:MESSage[<n>]:LANGuage
  • CALL:SMService:CBRoadcast:MESSage[<n>]:STATe
  • CALL:SMService:CBRoadcast:MESSage[<n>]:TEXT
  • CALL:SMService:CBRoadcast:MESSage[<n>]:UPDate
  • CALL:SMService:CBRoadcast:REPetition[:SEConds]
  • CALL:SMService:CBRoadcast:STARt
  • CALL:SMService:CBRoadcast:STOP
  • CALL:SMService:CBRoadcast:TEXT:CUSTom
  • CALL:SMService:CBRoadcast:TXT1?
  • CALL:SMService:CBRoadcast:TXT2?

  • CALL:SMService:HTTProtocol:INPut
  • CALL:SMService:HTTProtocol:OUTPut

  • CALL:SMService:PTPoint:MORiginated:LOOPback

  • CALL:SMService:PTPoint:MORiginated[:MESSage]:CLEar[:ALL]
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:CONTents?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:COUNt?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:DCSCheme?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:DESTination?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:FORMat?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:LENGth?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:MREFerence?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:PIDentifier?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:SRRequest?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:TEXT?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:TRANsport?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHind?
  • CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHLength?

  • CALL:SMService:PTPoint:MORiginated:QUEue[:STATe]
  • CALL:SMService:PTPoint:MORiginated:QUEue:COUNt?
  • CALL:SMService:PTPoint:MORiginated:QUEue:NEXT

  • CALL:SMService:PTPoint:MORiginated:REPort:MODE:STATus
  • CALL:SMService:PTPoint:MORiginated:REPort:MODE:SUBMit

  • CALL:SMService:PTPoint[:MTERminated]:CONTents

  • CALL:SMService:PTPoint[:MTERminated]:DATA:CUSTom

  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:DCSCheme
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:FCAuse
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:MMTSend
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:MREFerence
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:PLAN
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:TYPE
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:PIDentifier
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:PINDicator
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:RPATh
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SREPort
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:PLAN
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:TYPE
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:STATus
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE:SUBReport:RPTYpe
  • CALL:SMService:PTPoint[:MTERminated][:MESSage]:UDHind

  • CALL:SMService:PTPoint[:MTERminated]:RCAuse?
  • CALL:SMService:PTPoint[:MTERminated]:SEND[:IMMediate]
  • CALL:SMService:PTPoint[:MTERminated]:SEND:STATe?
  • CALL:SMService:PTPoint[:MTERminated]:TEXT:CUSTom
  • CALL:SMService:PTPoint[:MTERminated]:TRANsport
  • CALL:SMService:PTPoint[:MTERminated]:TXT1?
  • CALL:SMService:PTPoint[:MTERminated]:TXT2?

CALL:SMService:CBRoadcast:MESSage[<n>]:CDATa

Function

This command sets/queries the User Defined Text Message (Custom Data) , which is the custom binary data string for message n, where n can be 1,2, or 3, that can be included in the cell broadcast message content.

An even number of characters must be used when setting the custom data string with this command.

Setting

 Range: 0 to 2460 hexadecimal characters.

Query

 Range: 0 to 2460 hexadecimal characters.

*RST setting

"" (null string)
Requirements

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:CDATa `a5fe'"
!Sets the custom binary data string.

CALL:SMService:CBRoadcast:MESSage[<n>]:CODE

Function

This sets the message code for Cell Broadcast Message n, where n can be 1, 2, or 3. See Message Code for more information.

Setting

 Range: 0 to 1023

Query

 Range: 0 to 1023

*RST setting

0
Requirements

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:CODE 1000"
! Sets the Cell Broadcast Message 1 to have 1000 as the code.

CALL:SMService:CBRoadcast:MESSage[<n>]:CONTent

Function

This command sets/queries the type of content that is to be included in each message (see Cell Broadcast Messages -Content ). The selected content can be one of two predefined text message strings, TXT1 or TXT2 (see CALL:SMService:CBRoadcast:TXT1? or CALL:SMService:CBRoadcast:TXT2? ), a custom text string (see CALL:SMService:CBRoadcast:MESSage[<n>]:CTEXt ), or a custom binary data (see CALL:SMService:CBRoadcast:MESSage[<n>]:CDATa ).

This parameter is automatically set to CTEXt if TEXT is included in the HTTP request URL. Similarly, this parameter is automatically set to CDATA if DATA is included in the HTTP request URL for message n, where n can be 1, 2, or 3. See Request URL Parameters .

Setting

 Range: TXT1|TXT2|CTEXt|CDATa

Query

 Range: TXT1|TXT2|CTEX|CDAT

*RST setting

 TXT1 (for message 1 and 3), TXT2 (for message 2)
Requirements

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:TXT1"
!Sets the Cell Broadcast Message 1 to use TXT1.

CALL:SMService:CBRoadcast:MESSage[<n>]:CTEXt

Function

This command sets/queries the User Defined Text Message (Custom Text) string that can be included in the cell broadcast message n, where n can be 1, 2, or 3.

Setting

 Range: 0 to 1395 ASCII characters

Query

 Range: 0 to 1395 ASCII characters

*RST setting

 "" (Empty String)
Requirements

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:CTEXt `Hello. How are you today?'"
!Sets the custom text string for message 1.

CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme[:SPECify]

Function

This command sets/queries the method used to set the 8-bit CBS Data Coding Scheme for message n, where n can be 1, 2, or 3. The two methods that can be used to specify the data coding scheme are:

  1. Language

    See CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:LANGuage .

  2. ValueSee CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:VALue .

This parameter is automatically set to Value if the following Request URL Parameters are included in the HTTP request URL: DCS or DCSHEX.

Setting

 Range: LANGuage|VALue

Query

 Range: LANG|VAL

*RST setting

 LANG
Requirements

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:DCSCheme LANG"
!Allows the test set to configure the data coding scheme for message 1 according to a specified
!language.

CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:LANGuage

Function

This command sets/queries the language for the cell broadcast text message for message n, where n can be 1, 2, or 3. The specified language is also used to set the 8-bit CBS Data Coding Scheme. This method is only appropriate for configuring text messages. See Data Coding Scheme Language for more information.

The 8-bit CBS Data Coding Scheme Specification must be set to LANGuage for this command to apply. The command to specify the method used to set the 8-bit CBS Data Coding Scheme is CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme[:SPECify] .

Setting

 Range: See Language values .

Query

 Range: See Language values .

*RST setting

 ENGLish
Requirements

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:DCSCheme:LANGuage ENGLish"
!Sets the language to English for the Cell Broadcast Message 1.

CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:VALue

Function

This command sets/queries the value used to set the 8-bit CBS Data Coding Scheme for message n, where n can be 1, 2, or 3. See Data Coding Scheme Value for more information.

The 8-bit CBS Data Coding Scheme Specification must be set to VALue for this command to apply. The command to specify the method used to set the 8-bit CBS Data Coding Scheme is CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme[:SPECify] .

Setting

Range: 0 to 255

Resolution: 1

Query

Range: 0 to 255

Resolution: 1

*RST setting

 1
Requirements

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:DCSCheme:VALue 1"
!Sets the value of the Data Coding Scheme to 1 for the Cell Broadcast Message 1.

CALL:SMService:CBRoadcast:MESSage[<n>]:GSCope

Function

This command sets/queries the Geographical Scope (GS) for message n, where n can be 1, 2, or 3.

Setting

 Range: CIMMediate|PNORmal|SNORmal|CNORmal

Query

 Range: CIMM|PNOR|SNOR|CNOR

*RST setting

CNOR
Requirements

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:GSCope CIMMediate"
!Sets the geographical scope for Cell Broadcast Message 1 regard similar messages in other cells as
!new and to continuously display the message.

CALL:SMService:CBRoadcast:MESSage[<n>]:IDENtifier

Function

This command sets/queries the Message Identifier for Cell Broadcast Message n (where n can be 1,2, or 3).

Setting

 Range: 0 to 65534

Query

 Range: 0 to 65534

*RST setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:IDENtifier 1500"
! Sets the message identifier for Cell Broadcast Message 1 to 1500.

CALL:SMService:CBRoadcast:MESSage[<n>]:LANGuage

Function

This command is obsolete. Please use the command CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:LANGuage instead.

This sets the language for Cell Broadcast Message n, where n can be 1, 2, or 3.

Setting

 Fixed string (see table below)

Query

 Fixed string

*RST setting

 ENGLish
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:LANGuage ENGLish"
! Sets the language to English for the Cell Broadcast Message 1.

Language values
Parameter Form | Query Value
GERMan | GERM
ENGLish | ENGL
ITALian | ITAL
FRENch | FREN
SPANish | SPAN
DUTCh | DUTC
SWEDish | SWED
DANish | DAN
PORTuguese | PORT
FINNish | FINN
NORWegian | NORW
GREek | GRE
TURKish | TURK
HUNGarian | HUNG
POLish | POL
UNSPecified | UNSP

CALL:SMService:CBRoadcast:MESSage[<n>]:STATe

Function

Enables Cell Broadcast Message n, where n is 1, 2 or 3. Cell Broadcast service must be started for a message to be sent. See CALL:SMService:CBRoadcast:STARt .

Setting

 0|OFF|1|ON

Query

 0||1

*RST setting

Message 1 is ON; Messages 2 and 3 are OFF
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage2:STATe ON"
! Sets the state for the Cell Broadcast Message 2 to ON,
! which is necessary to allow a message to be sent

CALL:SMService:CBRoadcast:MESSage[<n>]:TEXT

Function

THIS COMMAND IS OBSOLETE. Please use the command CALL:SMService:CBRoadcast:MESSage[<n>]:CONTent instead.

This command selects the text to be transmitted for Cell Broadcast Message n, where n is 1, 2 or 3.

Setting

 TXT1|TXT2|CUSTom

Query

 TXT1|TXT2|CUST

*RST setting

Message 2 is TXT2; Messages 1and 3 are TXT1
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:TEXT TXT2"
! Sets the Cell Broadcast Message 1 to contain the predefined TXT2 text.

CALL:SMService:CBRoadcast:MESSage[<n>]:UPDate

Function

This sets the Update Number for Cell Broadcast Message n, where n can be 1, 2, or 3.

Setting

 Range: 0 to 15

Query

 Range: 0 to 15

*RST setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:MESSage1:UPDate 10"
! Sets the Message Update number to 10 for the Cell Broadcast Message 1.

CALL:SMService:CBRoadcast:REPetition[:SEConds]

Function

This command sets/queries the Repetition Period for sending the cell broadcast message.

Setting

 Range: 1 to 1800

Query

 Range: 1 to 1800

*RST setting

30
Requirements

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:REPetition 30"
!Sets the Cell Broadcast Service repetiion period to 30 seconds.

CALL:SMService:CBRoadcast:STARt

Function

This command initiates the Cell Broadcast Service, which causes the periodic transmission of all messages enabled through the command CALL:SMService:CBRoadcast:MESSage[<n>]:STATe .

This command is ignored if Cell Broadcast Service has already been started.
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:STARt"
! Starts the Cell Broadcast Service.

CALL:SMService:CBRoadcast:STOP

Function

Stops the Cell Broadcast Service.

This command is ignored if Cell Broadcast Service has already been ended.
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:CBRoadcast:STOP"
! Stops the Cell Broadcast Service.

CALL:SMService:CBRoadcast:TEXT:CUSTom

Function

THIS COMMAND IS OBSOLETE. Please use CALL:SMService:CBRoadcast:MESSage[<n>]:CTEXt instead.

This sets the string of the custom text which can be sent with any of the Cell Broadcast Messages.

Setting

 String: 7 bit ACSII characters up to 1395 characters in length in quotes.

Query

 String: 7 bit ACSII characters up to 1395 characters in length.

*RST Setting

 "Enter your text here"
Requirements

Lab Application Revision: C.01 and above

Revision C.03 extends the range of accepted characters to 1395.

Programming Example

OUTPUT 714; "CALL:SMService:CBRoadcast:TEXT:CUSTom "Hello World" "
! Sets `Hello World' as a custom text which can be sent with
! any of the Cell Broadcast Messages.

CALL:SMService:CBRoadcast:TXT1?

Function

This queries the Predefined text message 1 (Text1) .

Query

 Returns a string.
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:CBRoadcast:TXT1?"
! Queries for the fixed Text Message 1.

CALL:SMService:CBRoadcast:TXT2?

Function | This queries the Predefined text message 2 (Text2) .
Query | Returns a string.
Requirements | Lab Application Revision: C.01 and above
Programming Example OUTPUT 714;"CALL:SMService:CBRoadcast:TXT2?" ! Queries for the fixed Text Message 2.

CALL:SMService:HTTProtocol:INPut

Function

Enables or disables the HTTP input interface for mobile terminated SMS.

Setting

 0|OFF|1|ON

Query

 0|1

*RST setting

OFF
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SMService:HTTProtocol:INPut ON"
! Enables the HTTP input interface for mobile terminated SMS

CALL:SMService:HTTProtocol:OUTPut

Function | Enables or disables the HTTP output interface for mobile originated SMS.
Setting | 0|OFF|1|ON
Query | 0|1
*RST setting | OFF
Requirements | Lab Application Revision: C.01 and above
Programming Example OUTPUT 714;"CALL:SMService:HTTProtocol:OUTPut 1" ! Enables the HTTP output interface for mobile originated SMS.

CALL:SMService:PTPoint:MORiginated:LOOPback

Function

Enables the loopback of a point-to-point message. The message is sent to the mobile station with the same parameters as the most recently received text message.

Setting

 0|OFF|1|ON

Query

 0|1

*RST setting

 0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:LOOPback ON"
! Enable loopback of a point to point message.

CALL:SMService:PTPoint:MORiginated[:MESSage]:CLEar[:ALL]

Function

Clears all Received Message data. This includes Transport, Length, Format, Contents, Text, Destination Address, Message Count, More Messages to Send Indication, Data Coding Scheme, User Data Header Indication, User Data Header Length, Status Report Request, and Message Reference.

Empties the message queue if it is enabled.

Clears the mobile terminated send state (See CALL:SMService:PTPoint[:MTERminated]:SEND:STATe? ).
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:CLEar"
! Clears all Received Message Data.

CALL:SMService:PTPoint:MORiginated[:MESSage]:CONTents?

Function

Queries the contents of the last mobile originated message and returns the raw message content.
Query Returns an ASCII formatted string of hexadecimal characters.
Range: 0 to 280 characters

*RST setting

 Empty string.
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:CONTents?"
! Returns the raw content of the last mobile originates message.

CALL:SMService:PTPoint:MORiginated[:MESSage]:COUNt?

Function

Queries the number of messages received by the test set.
Query Range: 0 to 255
Resolution: 1

*RST setting

 0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:COUNt?"
! Returns the number of messages received by the test set.

CALL:SMService:PTPoint:MORiginated[:MESSage]:DCSCheme?

Function

Queries the Data Coding Scheme (TP-DCS) of the last message received by the test set or the current message available in the message queue.
Query Range: 0 to 255 or 9.91E+37 (NAN)
Resolution: 1

*RST setting

 9.91E+37
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:DCSCheme?"
! Queries the Data Coding Scheme of the last message received
! by the test set or the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated[:MESSage]:DESTination?

Function

Queries the destination address of the last SMS message received by the test set.
Query Returns a string.

*RST setting

 "" (null string)
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:DESTination?"
! Queries the destination address of the last SMS message received by the test set.

CALL:SMService:PTPoint:MORiginated[:MESSage]:FORMat?

Function

Queries the Last Received Message Format.

Query

 ASC|BIN|UCS2|INV|UNKN

ASC: 7 bit ASCII string
BIN: Binary data
UCS2: Unicode Character Set 2
INV: Invalid (returned when no messages have been received
UNKN: Unknown message format

*RST setting

 INV
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:FORMat?"
! Queries the Last Received Message Format.

CALL:SMService:PTPoint:MORiginated[:MESSage]:LENGth?

Function

Queries the Last Received Message Length.
Query Returns a number value or 9.91E+37 (NAN).

ASCII - the number of characters in the ASCII text message
Binary/UCS2 - the number of octets of data in the message
No message received - NAN

*RST setting

 9.91E37
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:LENGth?"
! Queries the Last Received Message Length.

CALL:SMService:PTPoint:MORiginated[:MESSage]:MREFerence?

Function

Queries the Message Reference (TP-MR) of the last message received by the test set or the current message available in the message queue.
Query Range: 0 to 255 or 9.91E+37 (NAN)

*RST setting

 9.91E+37
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:MREFerence?"
! Queries the Message Reference (TP-MR) of the last message received
! by the test set or the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated[:MESSage]:PIDentifier?

Function

Queries the Protocol Identifier (TP-PID) of the last message received by the test set or the current message available in the message queue.
Query Range: 0 to 255 or 9.91E+37 (NAN)

*RST setting

 9.91E+37
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:PIDentifier?"
!Queries the Protocol Identifier (TP-PID) of the last message received
! by the test set or the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated[:MESSage]:SRRequest?

Function

Queries the Status Report Request (TP-SRR) of the last message received by the test set or the current message available in the message queue.
Query 0 | 1 | 9.91E+37 (NAN)

*RST setting

 9.91E+37
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:SRRequest?"
! Queries the Status Report Request (TP-SRR) of the last message received
! by the test set or the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated[:MESSage]:TEXT?

Function

Queries the text from the last SMS message received by the test set.
Query Returns a string.

*RST setting

 "" (null string)
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:TEXT?"
! Queries the text from the last SMS message received by the test set.

CALL:SMService:PTPoint:MORiginated[:MESSage]:TRANsport?

Function

Queries the reported transportation mechanism used by the mobile station when it originates a point-to-point SMS message.
Query Range: CSD|INV|PSD

CSD: CS Domain was used
INV: Invalid (returned when no messages have been received by the test set)
PSD: PS Domain was used
*RST Setting INV
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:TRANsport?"
! Queries the reported transportation mechanism used by the mobile station
! when it originates a point-to-point SMS message.

CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHind?

Function

Queries the User Data Header Indication (TP-UDHI) of the last message received by the test set or the current message available in the message queue.
Query 0 | 1 | 9.91E+37 (NAN)

*RST setting

 9.91E+37
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:UDHind?"
! Queries the User Data Header Indication (TP-UDHI) of the last message
! received by the test set or the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated[:MESSage]:UDHLength?

Function

Queries the User Data Header Length of the last message received by the test set or the current message available in the message queue.
Query Range: 0 to 140 bytes or 9.91E+37 (NAN)

*RST setting

 9.91E+37
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:UDHLength?"
! Queries the User Data Header Length of the last message received
! by the test set or the current message available in the message queue.

CALL:SMService:PTPoint:MORiginated:QUEue[:STATe]

Function

 Enables SMS message queuing. This causes the test set to put received SMS-SUBMIT messages into a queue instead of overwriting existing messages.

Setting

 0|OFF|1|ON
Query | Range: 0|1
*RST Setting | 0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:QUEue 1"
! Enables SMS message queuing. This causes the test set to put received
! SMS-SUBMIT messages into a queue instead of overwriting existing messages.

CALL:SMService:PTPoint:MORiginated:QUEue:COUNt?

Function

Queries the current number of SMS messages held in the message queue.
Query Range: 0 to 255
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:QUEue:COUNt?"
! Enables SMS message queuing. This causes the test set to put received
! SMS-SUBMIT messages into a queue instead of overwriting existing messages.

CALL:SMService:PTPoint:MORiginated:QUEue:NEXT

Function

Extracts the next message in the queue, making it available for query. Sending this command clears the previously available message results.
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:QUEue:NEXT"
! Enables SMS message queuing. This causes the test set to put received
! SMS-SUBMIT messages into a queue instead of overwriting existing messages.

CALL:SMService:PTPoint:MORiginated:REPort:MODE:STATus

Function

Sets/queries the method used to send Status Reports.
Setting | AUTO | MANual
Query | AUTO | MAN
*RST Setting | AUTO
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:REPort:MODE:STATus MANual"
! Sets/queries the method used to send Status Reports to Manual.

CALL:SMService:PTPoint:MORiginated:REPort:MODE:SUBMit

Function

Sets/queries the method used to send Submit Reports.
Setting | AUTO | MANual
Query | AUTO | MAN
*RST Setting | AUTO
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MORiginated:REPort:MODE:SUBMit AUTO" !Sets/queries the method used to send Submit Reports to Auto.

CALL:SMService:PTPoint[:MTERminated]:CONTents

Function | This selects the content to be sent in mobile terminated SMS messages.
Setting | Range: TXT1 | TXT2 | CTEXt | CDATa
Query | Range: TXT1 | TXT2 | CTEX | CDAT
*RST Setting | TXT1
Requirements | Lab Application Revision: C.01 and above
Programming Example OUTPUT 714;"CALL:SMService:PTPoint:CONTents TXT1" ! Selects TXT1 to be be sent in subsequent mobile terminated SMS messages.

CALL:SMService:PTPoint[:MTERminated]:DATA:CUSTom

Function

Sets/queries the data to be sent in mobile terminated SMS messages. SMS data is formatted in octets, therefore there must be an even number of characters in the string.

This data is only sent to the mobile station if the CALL:SMService:PTPoint[:MTERminated]:CONTents is set to CDATA.

Setting

Range: 0 to 280 2-bit ASCII hexidecimal characters

Query

Range: 0 to 280 2-bit ASCII hexadecimal characters, enclosed by double quotes

*RST Setting

"00"
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:DATA:CUSTom '4141'"
! This sets the hex data 4141 to be sent in subsequent mobile terminated SMS messages

CALL:SMService:PTPoint[:MTERminated][:MESSage]:DCSCheme

Function

Configures the TP-DCS (Data Coding Scheme) header element, used to identify the coding scheme used in the message contents.

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:DCSCheme 75"
! Configures the TP-DCS (Data Coding Scheme) header element, used to identify the coding scheme used in the message contents to 75.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:FCAuse

Function

Configures the TP-FCS (Failure Cause) header element, used to identify the reason for a previous SMS-SUBMIT failure. This setting is only relevant to the Submit Report message type. It is not relevant to either Deliver or Status Report message types.

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

255
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:FCAuse 20"
! Sets the TP-FCS (Failure Cause) header element, used to identify
! the reason for a previous SMS-SUBMIT failure.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:MMTSend

Function

Configures the TP-MMS (More Messages to Send) header element.

Setting

 0 | 1
0: More messages to send
1: No more messages

Query

 0 | 1

*RST Setting

1
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MMTSend 1"
! Sets the TP-MMS (More Messages to Send) header element to
! indicate that there are no more messages.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:MREFerence

Function

Configures the TP-MR (Message Reference) header element. This element is only included in mobile terminated SMS messages if their message type is SMS-STATUS REPORT. It is used to identify the previously submitted mobile originated SMS to which the status report message relates.

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MREFerence 100"
! Sets the TP-MR (Message Reference) header element for
! subsequent mobile terminated SMS messages.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress

Function

Configures the address value portion of the TP-OA (Originating Address) header element, used to identify the sender of the message.

Setting

 ASCII string of digits 0-9, the symbols * and #, and the lower case characters a, b, and c.
Range: 2 to 20 characters

Query

 ASCII string

*RST Setting

"8960"
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:OADDress "abc" "
! Changes the address value portion of the TP-OA (Originating Address) header
! element to abc, which is used to identify the sender of the message.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:PLAN

Function

Configures the number plan identification bits of the Type of Address field of the TP-OA (Originating Address) header element, used to identify the sender of the message.

Setting

 Range: UNKNown | ISDN | DATA | TELex | PRIVate | NATional

Query

 Range: UNKN | ISDN | DATA | TEL | PRIV | NAT

*RST Setting

UNKN
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:OADDress:PLAN NATional"
! Sets the number plan identification bits of the Type of Address field of the
! TP-OA (Originating Address) header element to National, which is used to
! identify the sender of the message.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:OADDress:TYPE

Function

Configures the Type of Number bits of the Type of Address field of the TP-OA (Originating Address) header element, used to identify the sender of the message.

Setting

 Range: UNKNown | INATional | NATional | NETWork | SUBScriber

Query

 Range: UNKN | INAT | NAT | NETW | SUBS

*RST Setting

 UNKN
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:OADDress:TYPE SUBScriber"
! Sets the Type of Number bits of the Type of Address field of the TP-OA (Originating Address)
! header element to `Suscriber', which is used to identify the sender of the message.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:PIDentifier

Function

Configures the TP-PID (Protocol Identifier) header element, used to identify the higher layer protocol used to send the SMS message.

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:MTERminated:MESSage:PIDentifier 100"
! Configures the TP-PID (Protocol Identifier) header element, used to identify the
! higher layer protocol used to send the SMS message.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:PINDicator

Function

Configures the TP-PI (Parameter Indicator) header element, used to identify the presence of optional elements within SMS-SUBMIT-REPORT and SMS-STATUS-REPORT messages.

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

7
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:PINDicator 5"
! Sets the TP-PI (Parameter Indicator) header element to `5', which is used to identify
! the presence of optional elements within SMS-SUBMIT-REPORT and
! SMS-STATUS-REPORT messages.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:RADDress

Function

Configures the TP-RA (Recipient Address) header element, used to identify the recipient of the previously submitted SMS message.

Setting

 ASCII string of digits 0-9, the symbols *, #, and +, and the letters a, b, and c.
Range: 2 to 20 characters

Query

 ASCII string

*RST Setting

"8960"
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:RADDress `abc'"
! Configures the TP-RA (Recipient Address) header element,
! used to identify the recipient of the previously submitted SMS messages.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:RPATh

Function

Configures the TP-RP (Reply Path) header element.

Setting

 0 | 1
0: A reply path does not exist
1: A reply path exists

Query

 0 | 1

*RST Setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:RPATh 1"
! Configures the TP-RP (Rely Path) header element to indicate the existence
! of a reply path.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress

Function

 Configures the RP Originating Address header element, used to identify the originating SMS Service Center address for MT transfer.

Setting

ASCII string of digits 0-9, the symbols * and #, and the lower case characters a, b, and c.

Range: 2-20 characters

Query

 ASCII string

*RST Setting

 "8960"
Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:SADDress "8960"

!Changes the SMSC Address to 8960.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:PLAN

Function

 Configures the RP Originating Address header element, which is used to identify the originating SMS Service Center address for MT transfer.

Setting

 Range: UNKNown | ISDN | DATA | TELex | PRIVate | NATional

Query

 Range: UNKN | ISDN | DATA | TEL | PRIV | NAT

*RST Setting

 UNKN
Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:SADDress:PLAN NATional"

!Sets the SMSC Address plan to National.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:SADDress:TYPE

Function

 Configures the RP Originating Address type header element, which is used to identify the type of the SMSC address setting.

Setting

 Range: NKNown | INATional | NATional | NETWork | SUBScriber

Query

 Range: UNKN | INAT | NAT | NETW | SUBS

*RST Setting

 UNKN
Requirements

Lab Application Revision: E.00.16 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:SADDress:TYPE SUBScriber"

!Sets the SMSC Address type to subscriber.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:SREPort

Function

Configures the TP-SRI (Status Report Indication) header element, used to indicate to the mobile station that a status report was requested for this message by the sender.

Setting

 0 | 1
0: Status report not requested
1: Status report requested

Query

 0 | 1

*RST Setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:SREPort 1"
! Sets the state of the TP-SRI (Status Report Indication) header element to 1,
! which is used to indicate that the mobile station should send a status report to the test set.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:STATus

Function

Configures the TP-ST (Status) header element, used to describe the status of the previously originated mobile SMS.

Setting

 Range: 0 to 255

Query

 Range: 0 to 255

*RST Setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:STATus 30"
! Sets the TP-ST (Status) header element to 30, which is used to describe
! the status of the previously originated mobile SMS.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE

Function

Sets the type of SMS message sent from the test set to the mobile station.

Setting

 DELiver | SUBReport | STATReport

Query

 DEL | SUBR |STATR

*RST Setting

 DELiver
Requirements

Lab Application Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TYPE"
! Sets the type of SMS message sent from the test set to the mobile station to DELiver.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:TYPE:SUBReport:RPTYpe

Function

Sets the RP type to use when sending an SMS-SUBMIT-REPORT message from the test set to the mobile station.

Setting

 ERRor | ACK

Query

 ERR | ACK

*RST Setting

 ACK
Requirements

Lab Application Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TYPE:SUBReport:RPTYpe ACK"
! Sets the RP type to `ACK' to use when sending an SMS-SUBMIT-REPORT
! message from the test set to the mobile station.

CALL:SMService:PTPoint[:MTERminated][:MESSage]:UDHind

Function

Configures the TP-UDHI (User Data Header Indication) header element. The TP-UDHI is used to indicate that the user data sent to the mobile station contains header information. This command is used when binary or concatenated messages are sent, but not with simple text messages.

Setting

 0 | 1
0: Content does not include header
1: Content includes header

Query

 0 | 1

*RST Setting

0
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:UDHind 1"
! Sets the TP-UDHI (User Data Header Indication) header element to 1,
! which is used to indicate that the user data sent to the mobile station does
! contain header information.

CALL:SMService:PTPoint[:MTERminated]:RCAuse?

Function

Queries the reject cause value when a mobile terminated message is rejected by the mobile station. If the last message sent to the mobile station was not rejected, NAN is returned for the reject cause value. If the last message sent to the mobile station was rejected, this query returns the decimal value of the reject cause.

Query

 Range: 0 to 255 (decimal) See Reject Cause
and 9.91 E+37 (NAN)

*RST Setting

9.91 E+37 (NAN)
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:RCAuse?"
! Queries the reject cause decimal value when a mobile terminated message is rejected by the
! mobile station. If the last message sent to the mobile was not rejected, the query returns NAN.

CALL:SMService:PTPoint[:MTERminated]:SEND[:IMMediate]

Function

 Sends a Point to Point SMS message.
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:SEND"
! Sends a Point to Point SMS message .

CALL:SMService:PTPoint[:MTERminated]:SEND:STATe?

Function

Queries the state of the last message sent to the mobile station.

Query

Range: IDLE | SEND | ACK | NACK | REJ | FAIL
IDLE: No message has been sent
SEND: Message send in progress
ACK: Message acknowledged by mobile station
NACK: Message was not acknowledged by mobile station and send timed out
REJ: Message was rejected by the mobile station
FAIL: Message could not be sent

*RST Setting

IDLE
Requirements

Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714; "CALL:SMService:PTPoint:SEND:STATe?"
! Queries the state of the last message sent to the mobile station. .

CALL:SMService:PTPoint[:MTERminated]:TEXT:CUSTom

Function

This sets the text of the custom message to be sent.

Setting

 String: 7 bit ASCII characters up to 160 characters in length

Query

 String: 7 bit ASCII characters up to 160 characters in length, enclosed by double quotes.

*RST Setting

 "Enter your text here"
Requirements

Lab Application Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TEXT:CUSTom `Hello World'"

CALL:SMService:PTPoint[:MTERminated]:TRANsport

Function

Selects the transportation mechanism to be used.

Setting

Range: CSDomain|PSDomain

Query

Range: CSD|PSD

*RST Setting

 PSD
Requirements

Lab Application Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TRANsport PSD"
! Selects PS Domain to be the transportation mechanism used.

CALL:SMService:PTPoint[:MTERminated]:TXT1?

Function

This queries the fixed Text Message 1.

Query

 Returns a string.

*RST Setting

 "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz"
Requirements

Lab Application Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TXT1"
! This queries the fixed Text Message 1.

CALL:SMService:PTPoint[:MTERminated]:TXT2?

Function

This queries the fixed Text Message 2.

Query

 Returns a string.

*RST Setting

 "Agilent Technologies, your partner in wireless solutions"
Requirements

Lab Application Revision: C.01 and above

Programming Example:

OUTPUT 714;"CALL:SMService:PTPoint:TXT2?"
! This queries the fixed Text Message 2.


STATus Subsystem Description

STATus Subsystem Description

Last updated: January 16, 2009

Description

The STATus subsystem is used to communicate current test set status information to the controlling application program.

Syntax Diagrams and Command Descriptions

STATus:OPERation

STATus:PRESet

STATus:QUEStionable

Status Byte Register
Standard Event Status Register

Related Topics

Status Subsystem Overview


STATus:OPERation

STATus:OPERation

Last updated: January 16, 2009

GPIB Command Conventions

  • STATus:OPERation Register Bit Assignments

  • STATus:OPERation:CALL Condition Register Bit Assignment
  • STATus:OPERation:CALL:COMMon Condition Register Bit Assignment
  • STATus:OPERation:CALL:COMMon:DATA Condition Register Bit Assignment

  • STATus:OPERation:FEATures Register Bit Assignments
  • STATus:OPERation:FEATures:COMMon Register Bit Assignments
  • STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments

  • STATus:OPERation:HARDware Condition Register Bit Assignments

  • STATus:OPERation:KEYPressed Register Bit Assignments

  • STATus:OPERation:NMRReady Register Bit Assignments
  • STATus:OPERation:NMRReady:AMPS Condition Register Bit Assignment
  • STATus:OPERation:NMRReady:CDMA Condition Register Bit Assignments
  • STATus:OPERation:NMRReady:COMMon Register Bit Assignments
  • STATus:OPERation:NMRReady:FDD Register Bit Assignments
  • STATus:OPERation:NMRReady:FDD2 Register Bit Assignments

STATus:OPERation Register Bit Assignments

The OPERation status register set contains bits which give an indication of conditions that are part of the test set's normal operation.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | KEYPressed Summary | This bit is the summary bit for the STATus:OPERation:KEYPressed register.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | SYSTem:SYNChronized | This condition bit is "pulsed" by the SYSTem:SYNChronized command. This will allow the status system to indicate that the input buffer is synchronized to the point where this command is parsed and that all prior sequential commands are completed and all prior overlapped commands have started.
11 | 2048 | HARDware Summary | This bit is the summary bit for the STATus:OPERation:HARDware register.
10 | 1024 | CALL Summary | This bit is the summary bit for the STATus:OPERation:CALL register.
9 | 512 | NMRReady (New Measurement Result Ready) Summary | This bit is the summary bit for the STATus:OPERation:NMRReady register.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation

OUTPUT 714;"STATUS:OPERATION:EVENT?" !Queries the Operation Event Register.
OUTPUT 714;"STATUS:OPERATION:CONDITION?" !Queries the Operation Condition Register.
OUTPUT 714;"STATUS:OPERATION:ENABLE 1024" !Sets the Operation Enable Register for bit 10.
OUTPUT 714;"STATUS:OPERATION:NTR 1024" !Sets the Operation Negative Transition
                                       !Register for bit 10.
OUTPUT 714;"STATUS:OPERATION:PTR 512" !Sets the Operation Event Positive Transition
                                      !Register for bit 9.

STATus:OPERation:CALL Condition Register Bit Assignment

The STATus:OPERation:CALL register bits will be used to indicate status of processes that occur during normal call processing operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | WCDMa Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:WCDMa register.
10 | 1024 | FDD Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:TA136 register.
4 | 16 | DIGital136 Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:DIGITAL136 register.
3 | 8 | AMPS Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:GSM register.
1 | 2 | COMMon Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:COMMon register.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:CALL

OUTPUT 714;"STATUS:OPERATION:CALL:EVENT?" !Queries the Operation Call Event !Register.
OUTPUT 714;"STATUS:OPERATION:CALL:CONDITION?" !Queries the Operation Call Condition Register.
OUTPUT 714;"STATUS:OPERATION:CALL:ENABLE 4"
    !Sets the Operation Call Enable Register for bit 2.
OUTPUT 714;"STATUS:OPERATION:CALL:NTR 4" !Sets the Negative Transition Register for bit 2.
OUTPUT 714;"STATUS:OPERATION:CALL:PTR 256" !Sets the Positive Transition Register for bit 8.

STATus:OPERation:CALL:COMMon Condition Register Bit Assignment

The STATus:OPERation:CALL:COMMon register bits will be used to indicate status of processes that occur during normal call processing operations.

Bit Number

Binary Weighting

Condition

Description

15

32768

Not Used. Defined by SCPI.

This bit is always 0.

14

16384

Data Summary

 This bit is the summary message bit for the STATus:QUEStionable:CALL:GSM:DATA register.

13

8192

 Call Control Status Access Probe

This bit is a 1 when the test set is in the call control status access probe state.

12

4096

Call Control Status Set Up Request

This bit is a 1 when the test set is in the call control status set up request state.

11

2048

Call Control Status Releasing

This bit is a 1 when the test set is in the call control status releasing state.

10

1024

Call Control Status Paging

This bit is a 1 when the test set is in the call control status paging state.

9

512

Registering (BS initiated)

This bit is set to a 1 when the Base Station initiates registration.

8

256

 Call Control Status Dormant

7

128

BS Originating

This bit is a 1 when:

  • Active Cell mode - the call processing state leaves the idle state

  • Test mode - the test set has noted a base station origination.

6

64

 Call Control Status Changing

This bit is a 1 when the test set is in the call control status changing state.

5

32

Call Control Status Handover/Handoff

This bit is a 1 when the test set is in the call control handover or handoff state.

4

16

Call Control Status Registering

This bit will be a 1 when the test set is in the call control status registering state.

3

8

Call Control Status is "Alerting"

This bit is a 1 when the test set is in the call alerting state (ringing).

2

4

Call Control Status is "Connected"

This bit is a 1 when the test set is in the call connected state.

1

2

Call Control Status is "Idle"

This bit is a 1 when the test set is in the call idle state.

0

1

Extension Bit

This bit is always 0.

Program Examples - STATus:OPERation:CALL:COMMon

OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:EVENT?" !Queries the Operation Call Common Event
                                          !Register.
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:CONDITION?" !Queries the Operation Call Common
                                              !Condition Register.
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:ENABLE 8" !Sets the Operation Call Common Enable
                                            !Register for bit 3.
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:NTR 8" !Sets the Negative Transition
                                         !Register for bit 3.
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:PTR 256" !Sets the Positive Transition
                                           !Register for bit 8.

STATus:OPERation:CALL:COMMon:DATA Condition Register Bit Assignment

The STATus:OPERation:CALL:COMMon:DATA register bits are used to indicate status of processes that occur during normal data connection processing operations.

Bit Number

Binary Weighting

Condition

Description

15

32768

Not Used. Defined by SCPI.

This bit is always 0.

14

16384

 Ping Active

13

8192

Reserved for future use.

This bit is always 0.

12

4096

Reserved for future use.

This bit is always 0.

11

2048

Reserved for future use.

This bit is always 0.

10

1024

Reserved for future use.

This bit is always 0.

9

512

 Data Connection Status Session Open

This bit is always 0.

8

256

 Data Connection Status PDP Active

This bit is always 0.

7

128

Starting Data Connection

This bit is a 1 when:

  • Active Cell mode - the data connection status leaves the idle state

  • Test mode - the test set has noted a base station origination.

6

64

Data Connection Status Changing

This bit is set to a 1 when the data connection status change detector has been armed.

5

32

 Data Connection Status Off This bit is set to 1 when the test set is in the call control status handover/handoff state.

4

16

 Data Connection Status Data Connected

This bit is set to 1 when data connection status data is in the connected state.

3

8

Data Connection Status Transferring

This bit is set to 1 when the data connection status is Transferring.

2

4

Data Connection Status Attached

This bit is set to 1 when the data connection status is Attached.

1

2

Data Connection Status Idle

This bit is set to 1 when the data connection status is Idle.

0

1

Extension Bit

This bit will always be 0.

Program Examples STATus:OPERation:CALL:COMMon:DATA

OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:EVENT?" !Queries and clears the Operation
                                                      !Call Common Data Event Register
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:CONDITION?" !Queries and clears the Operation
                                                          !Call Common Data Condition
                                                          !Register
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:ENABLE 128" !Sets the Operation Call Common
                                                          !Data Enable Register for bit 7
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:NTRANSITION 2" !Sets the Operation Call Common
                                                        !Data Negative Transition Filter
                                                        !Register for bit 1
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:PTRANSITION 2" !Set the Operation Call Common
                                                        !Data Positive Transition Filter
                                                        !Register for bit 1

STATus:OPERation:FEATures Register Bit Assignments

The STATus:OPERation:FEATures register bits are used to access miscellaneous Features Registers.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | COMMon Summary Bit | This bit is the summary bit for the STATus:OPERation:FEATures:COMMon register. (see STATus:OPERation:FEATures:COMMon Register Bit Assignments )
0 | 1 | Extension Bit | This bit is always 0.

STATus:OPERation:FEATures:COMMon Register Bit Assignments

The STATus:OPERation:FEATures:COMMon register bits indicate the status of processes that occur during various operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | SMService Summary bit | This bit is the summary message bit for the STATus:OPERation:FEATures:COMMon:SMService register. (see STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments )
0 | 1 | Extension Bit | This bit is always 0.

STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments

The STATus:OPERation:FEATures:COMMon:SMService register bits indicate the status of processes that occur during SMS operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Mobile-Originated SMS Message Queue Overflow | The CONDition bit moves from 0 to 1 and back to 0 when the event takes place.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Mobile-Originated Message Received/Ready to be Returned | If message queuing is "OFF", the CONDition bit moves from 0 to 1 and back to 0 when the event takes place. If message queuing is "ON", the CONDition bit is set to 1 and remains there until the test set is informed by the controller that all received messages have been read.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

STATus:OPERation:HARDware Condition Register Bit Assignments

The STATus:OPERation:HARDware register bits indicate when a softkey on the test set's front panel has been pressed while the test set is in remote operating mode.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | External Timebase in use | This bit is a 1 if a suitable external timebase is connected to the test set's 10 MHz REF IN connector on the rear panel of the test set.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:HARDware

OUTPUT 714;"STATUS:OPERATION:HARDware:EVENT?"
    !Queries the HARDware Event Register.
OUTPUT 714;"STATUS:OPERATION:HARDware:CONDITION?"
    !Queries the HARDware Condition Register.
OUTPUT 714;"STATUS:OPERATION:HARDware:ENABLE 16"
    !Sets HARDware Enable register for bit 4.
OUTPUT 714;"STATUS:OPERATION:HARDware:NTR 2"
    !Sets the HARDware Negative Transition Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:HARDware:PTR 4"
    !Sets the HARDware Positive Transition Register for bit 2

STATus:OPERation:KEYPressed Register Bit Assignments

The STATus:OPERation:KEYPressed register bits indicate when a softkey on the test set's front panel has been pressed while the test set is in remote operating mode.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | F12 softkey | This bit is a 1 when the test set's F12 softkey has been pressed.
10 | 1024 | F11 softkey | This bit is a 1 when the test set's F11 softkey has been pressed.
9 | 512 | F10 softkey | This bit is a 1 when the test set's F10 softkey has been pressed.
8 | 256 | F9 softkey | This bit is a 1 when the test set's F9 softkey has been pressed.
7 | 128 | F8 softkey | This bit is a 1 when the test set's F8 softkey has been pressed.
6 | 64 | F7 softkey | This bit is a 1 when the test set's F7 softkey has been pressed.
5 | 32 | F6 softkey | This bit is a 1 when the test set's F6 softkey has been pressed.
4 | 16 | F5 softkey | This bit is a 1 when the test set's F5 softkey has been pressed.
3 | 8 | F4 softkey | This bit is a 1 when the test set's F4 softkey has been pressed.
2 | 4 | F3 softkey | This bit is a 1 when the test set's F3 softkey has been pressed.
1 | 2 | F2 softkey | This bit is a 1 when the test set's F2 softkey has been pressed.
0 | 1 | F1 softkey | This bit is a 1 when the test set's F1 softkey has been pressed.

Program Examples - STATus:OPERation:KEYPressed

OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:EVENT?"
    !Queries the Keypressed Event Register.
OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:CONDITION?"
    !Queries the Keypressed Condition Register.
OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:ENABLE 16"
    !Sets Keypressed Enable register for bit 4.
OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:NTR 2"
    !Sets the Keypressed Negative Transition Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:PTR 4"
    !Sets the Keypressed Positive Transition Register for bit 2

STATus:OPERation:NMRReady Register Bit Assignments

The STATus:OPERation:NMRReady register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | WCDMa Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:WCDMa register.
10 | 1024 | FDD Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:TA136 register.
4 | 16 | DIGITAL136 Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:DIGITAL136 register.
3 | 8 | AMPS Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:GSM register.
1 | 2 | COMMON Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:COMMon register.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady

OUTPUT 714;"STATUS:OPERATION:NMRREADY:EVENT?" !Queries the New Measurement
                                              !Results Ready Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CONDITION?" !Queries the New Measurement
                                                  !Results Ready
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:ENABLE 16" !Sets New Measurement Results
                                                 !Ready Enable Regigter
                                                 !for bit 4.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:NTR 2" !Sets the New Measurement Results
                                             !Ready Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:PTR 4" !Sets the New Measurement
                                             !Results Ready Positive
                                             !Transition Register
                                             !for bit 2

STATus:OPERation:NMRReady:AMPS Condition Register Bit Assignment

The STATus:OPERation:NMRReady:AMPS register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Frequency Modulation New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
2 | 4 | Frequency Stability New Measurement Result Ready | This is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
1 | 2 | Analog Transmit Power New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:AMPS

OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:EVENT?" !Queries the New Measurement
                                              !Results Ready AMPS Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:CONDITION?" !Queries the New Measurement
                                                  !Results Ready AMPS
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:ENABLE 8" !Sets New Measurement Results
                                                 !Ready AMPS Enable Register
                                                 !for bit 3.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:NTR 2" !Sets the New Measurement Results
                                             !Ready AMPS Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:PTR 4" !Sets the New Measurement
                                             !Results Ready AMPS Positive
                                             !Transition Register
                                             !for bit 2.

STATus:OPERation:NMRReady:CDMA Condition Register Bit Assignments

The STATus:OPERation:NMRReady:CDMA register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | CFDTune New Measurement Result Ready. | This bit is a 1 if the Fast Device Tune measurement has completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | CTDPower New Measurement Result Ready | This bit is a 1 if the measurement has completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
9 | 512 | GAPPower New Measurement Result Ready | This bit is a 1 if the measurement has completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
8 | 256 | CTXSpurious New Measurement Result Ready | This bit is a 1 if the measurement has completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
7 | 128 | GPOWer New Measurement Result Ready | This bit is a 1 if the measurement has completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
6 | 64 | TROPower New Measurement Result Ready | This bit is a 1 if the measurement has completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
5 | 32 | CAPPower New Measurement Result Ready | This bit is a 1 if the measurement has completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
4 | 16 | CFERror New Measurement Result Ready | This bit is a 1 if the measurement has completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
3 | 8 | CPOWer New Measurement Result Ready | This bit is a 1 if the measurement has completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
2 | 4 | WQUality New Measurement Result Ready | This bit is a 1 if the measurement has completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
1 | 2 | DAPower New Measurement Result Ready | This bit is a 1 if the measurement has completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:CDMA

OUTPUT 714;"STATUS:OPERATION:NMRREADY:CDMA:EVENT?" !Queries the New Measurement
                                              !Results Ready CDMA Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CDMA:CONDITION?" !Queries the New Measurement
                                                  !Results Ready CDMA
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CDMA:ENABLE 8" !Sets New Measurement Results
                                                 !Ready CDMA Enable Regigter
                                                 !for bit 3.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CDMA:NTR 2" !Sets the New Measurement Results
                                             !Ready CDMA Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CDMA:PTR 4" !Sets the New Measurement
                                             !Results Ready CDMA Positive
                                             !Transition Register
                                             !for bit 2

STATus:OPERation:NMRReady:COMMon Register Bit Assignments

The STATus:OPERation:NMRReady:COMMon register bits indicate when a measurement has been completed and new measurement results are available. See Triggering of Measurements for related information.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Spectrum Monitor New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
2 | 4 | Swept Audio New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
1 | 2 | Audio Analyzer New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:COMMon

OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:EVENT?" !Queries the New Measurement
                                              !Results Ready Common Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:CONDITION?" !Queries the New Measurement
                                                  !Results Ready Common
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:ENABLE 2" !Sets New Measurement Results
                                                 !Ready Common Enable Register
                                                 !for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:NTR 2" !Sets the New Measurement Results
                                             !Ready Common Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:PTR 2" !Sets the New Measurement
                                             !Results Ready Common Positive
                                             !Transition Register
                                             !for bit 1

STATus:OPERation:NMRReady:FDD Register Bit Assignments

The STATus:OPERation:NMRReady:FDD register bits indicate when a measurement has been completed and new measurement results are available. See Triggering of Measurements for related information.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | WPDiscon New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
12 | 4096 | WPPAnalysis New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
11 | 2048 | WOOPower New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
10 | 1024 | WIQTuning New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
9 | 512 | WILPower New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
8 | 256 | WCDomain New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
7 | 128 | WOBWidth New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
6 | 64 | WSEMask New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
5 | 32 | WBERror New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
4 | 16 | WCPower New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
3 | 8 | WWQuality New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
2 | 4 | WACLeakage New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
1 | 2 | WTPower New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
0 | 1 | FDD2 Summary | This bit is the summary bit for the STATus:OPERation:NMRReady:FDD2 register.

Program Examples - STATus:OPERation:NMRReady:FDD

OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD:EVENT?" !Queries the New Measurement
                                              !Results Ready FDD Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD:CONDITION?" !Queries the New
                                                  !Measurement Results Ready FDD
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD:ENABLE 8" !Sets New Measurement Results
                                                 !Ready FDD Enable Register
                                                 !for bit 3.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD:NTR 2" !Sets the New Measurement Results
                                             !Ready FDD Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD:PTR 4" !Sets the New Measurement
                                             !Results Ready FDD Positive
                                             !Transition Register
                                             !for bit 2

STATus:OPERation:NMRReady:FDD2 Register Bit Assignments

The STATus:OPERation:NMRReady:FDD2 register bits indicate when a measurement has been completed and new measurement results are available. See Triggering of Measurements for related information.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | WEDPower New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
5 | 32 | HBLerror New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
4 | 16 | WTDPower New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
3 | 8 | WDPAnalysis New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
2 | 4 | WCTFormat New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
1 | 2 | WBLerror New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset, or while a measurement is in its measuring state.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:FDD2

OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD2:EVENT?" !Queries the New Measurement
                                              !Results Ready FDD Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD2:CONDITION?" !Queries the New
                                                  !Measurement Results Ready FDD
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD2:ENABLE 8" !Sets New Measurement Results
                                                 !Ready FDD Enable Register
                                                 !for bit 3.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD2:NTR 2" !Sets the New Measurement Results
                                             !Ready FDD Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:FDD2:PTR 4" !Sets the New Measurement
                                             !Results Ready FDD Positive
                                             !Transition Register
                                             !for bit 2


STATus:PRESet

STATus:PRESet

Last updated: January 16, 2009

GPIB Command Conventions

  • STATus:PRESet

STATus:PRESet

Function

Presets the status subsystem.

Presetting the status subsystem performs the following functions:

  • All enable registers are set to 0 (not enabled)
  • All Positive Transition Registers (PTR's) are set to 1 (positive transitions enabled).
  • All Negative Transition Registers (NTR's) are set to 0 (negative transitions disabled).

Requirements

Test Application Revision: A.01 and above


STATus:QUEStionable

STATus:QUEStionable

Last updated: January 16, 2009

GPIB Command Conventions

  • STATus:QUEStionable Condition Register Bit Assignment

  • STATus:QUEStionable:CALL Condition Register Bit Assignment

  • STATus:QUEStionable:ERRors Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors:COMMon Register Bit Assignments
  • STATus:QUEStionable:ERRors:FDD Register Bit Assignments
  • STATus:QUEStionable:ERRors:WCDMa Register Bit Assignments

  • STATus:QUEStionable:HARDware Condition Register Bit Assignment

STATus:QUEStionable Condition Register Bit Assignment

The STATus:QUEStionable register contains bits which give an indication that the data currently being acquired or generated is of questionable quality due to some condition affecting the functionality associated with that bit.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | QUEStionable:HARDware summary | This bit is the summary message bit for the STATus:QUEStionable:HARDware register.
10 | 1024 | QUEStionable:CALL summary | This bit is the summary message bit for the STATus:QUEStionable:CALL register.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | QUEStionable:ERRors summary | This bit is the summary message bit for the STATus:QUEStionable:ERRors register.
0 | 1 | Reserved for future use. | This bit is always 0.

Program Example - STATus:QUEStionable Register Bit Assignments

OUTPUT 714;"STATUS:QUESTIONABLE:EVENT?" !Queries and clears the Questionable Event
                                        !Register
OUTPUT 714;"STATUS:QUESTIONABLE:CONDITION?" !Queries and clears the Questionable Condition
                                            !Register
OUTPUT 714;"STATUS:QUESTIONABLE:ENABLE 1024" !Sets the Questionable Enable Register
                                             !for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:NTRANSITION 2" !Sets the Questionable Negative
                                               !Transition Filter Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:PTRANSITION 2" !Sets the Questionable Positive
                                               !Transition Filter Register for bit 1

STATus:QUEStionable:CALL Condition Register Bit Assignment

The STATus:QUEStionable:CALL registers will contain information about which event(s) occurred during call processing that indicate what call processing procedure failed

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | WCDMa Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:WCDMa register.
10 | 1024 | FDD Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:CALL:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:CALL:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:TA136 register.
4 | 16 | DIGital136 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:DIGital136 register.
3 | 8 | AMPS Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:GSM register.
1 | 2 | COMMon Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:COMMon register.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:CALL Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:CALL:EVENT?" !Queries and clears the Questionable
                                             !Call Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:CONDITION?" !Queries and clears the Questionable
                                                 !Call Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:ENABLE 1024" !Sets the Questionable
                                                  !Call Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:NTRANSITION 2" !Sets the Questionable Call
                                                    !Negative Transition Filter Register
                                                    !for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:PTRANSITION 2" !Sets the Questionable Call
                                                    !Positive Transition Filter Register
                                                    !for bit 1

STATus:QUEStionable:ERRors Condition Register Bit Assignment

The STATus:QUEStionable:ERRors register bits will be used to indicate information about test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | WCDMa Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:WCDMa register.
10 | 1024 | FDD Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:TA136 register.
4 | 16 | DIGital136 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:DIGital136 register.
3 | 8 | AMPS Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:GSM register.
1 | 2 | COMMon Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:ERRors register.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors Register Bit Assignments

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:EVENT?" !Queries and clears the Questionable
                                               !Errors Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:CONDITION?" !Queries and clears the Questionable
                                                   !Errors Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:ENABLE 1024" !Sets the Questionable
                                                    !Errors Enable
                                                    !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:NTRANSITION 2" !Sets the Questionable Errors
                                                      !Negative Transition Filter Register
                                                      !for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:PTRANSITION 2" !Sets the Questionable Errors
                                                      !Positive Transition Filter Register
                                                      !for bit 1

STATus:QUEStionable:ERRors:COMMon Register Bit Assignments

The STATus:QUEStionable:ERRors:COMMon register bits will be used to indicate information about the COMMon test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors:COMMon Register Bit Assignments

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:EVENT?" !Queries and clears the Questionable
                                                      !Errors Common Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:CONDITION?" !Queries the and clears the
                                                          !Questionable Errors
                                                          !Common Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:ENABLE 1024" !Sets the Questionable
                                                           !Errors Common Enable
                                                           !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:NTRANSITION 2" !Sets the Questionable Errors
                                                             !Common Negative Transition
                                                             !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:PTRANSITION 2" !Sets the Questionable Errors
                                                             !Common Positive Tranasition
                                                             !Register for bit 1

STATus:QUEStionable:ERRors:FDD Register Bit Assignments

The STATus:QUEStionable:ERRors:FDD register bits will be used to indicate information about FDD related test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | MUI Maskable Message. |
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. Query the Event Register to find out if one of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors:FDD Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:FDD:EVENT?" !Queries and clears the
                                                          !Questionable Errors
                                                          !FDD Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:FDD:CONDITION?" !Queries and clears the
                                                              !Qestionable Errors
                                                              !FDD Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:FDD:ENABLE 1024" !Sets the Questionable
                                                               !Errors FDD Enable
                                                               !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:FDD:NTRANSITION 2" !Sets the Questionable
                                                                 !Errors FDD Negative
                                                                 !Transition Filter
                                                                 !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:FDD:PTRANSITION 2" !Sets the Questionable
                                                                 !Errors FDD Positive
                                                                 !Transition Filter
                                                                 !Register for bit 1

STATus:QUEStionable:ERRors:WCDMa Register Bit Assignments

The STATus:QUEStionable:ERRors:WCDMa register bits will be used to indicate information about WCDMA related test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | MUI Maskable Message. |
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. Query the Event Register to find out if one of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors:WCDMA Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:WCDMA:EVENT?" !Queries and clears the
                                                          !Questionable Errors
                                                          !WCDMA Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:WCDMA:CONDITION?" !Queries and clears the
                                                              !Qestionable Errors
                                                              !WCDMA Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:WCDMA:ENABLE 1024" !Sets the Questionable
                                                               !Errors WCDMA Enable
                                                               !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:WCDMA:NTRANSITION 2" !Sets the Questionable
                                                                 !Errors WCDMA Negative
                                                                 !Transition Filter
                                                                 !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:WCDMA:PTRANSITION 2" !Sets the Questionable
                                                                 !Errors WCDMA Positive
                                                                 !Transition Filter
                                                                 !Register for bit 1

STATus:QUEStionable:HARDware Condition Register Bit Assignment

The STATus:QUEStionable:HARDware register bits give an indication that the data/signals currently being acquired or generated are of questionable quality.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit will always be 0.
11 | 2048 | Reserved for future use. | This bit will always be 0.
10 | 1024 | Reserved for future use. | This bit will always be 0.
9 | 512 | Reserved for future use. | This bit will always be 0.
8 | 256 | Reserved for future use. | This bit will always be 0.
7 | 128 | Reserved for future use. | This bit will always be 0.
6 | 64 | Reserved for future use. | This bit will always be 0.
5 | 32 | Reserved for future use. | This bit will always be 0.
4 | 16 | Power-up Self Test(s) Failed | This bit will be a 1 if the power-up self tests failed.
3 | 8 | Reserved for future use. | This bit will always be 0.
2 | 4 | Reserved for future use. | This bit will always be 0.
1 | 2 | Reserved for future use. | This bit will always be 0.
0 | 1 | Extension Bit. | This bit will always be 0.

Program Example - STATus:QUEStionable:HARDware Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:EVENT?" !Queries and clears the Questionable
                                                 !Hardware Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:CONDITION?" !Queries and clears the Questionable
                                                     !Hardware Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:ENABLE 1024" !Sets the Questionable
                                                      !Hardware Enable
                                                      !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:NTRANSITION 2" !Sets the Questionable
                                                        !Hardware Negative Transition Filter
                                                        !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:PTRANSITION 2" !Sets the Questionable
                                                        !Hardware Positive Transition Filter
                                                        !Register for bit 1


Status Byte Register

Status Byte Register

Last updated: January 16, 2009

  • *STB?

*STB?

NOTE
The Status Byte Register can also be read with a serial poll. For example, the command "Status_byte = SPOLL(714)" would perform a serial poll of the Status Byte Register, returning and releasing RQS (bit 6).

Status Byte Register Bit Assignments

Bit Number | Binary Weighting | Label | Description
7 | 128 | STATus: OPERation | Summarizes the STATus: OPERationStatus Register, which fans out to theNMRReady and CALL Status Registers.
6 | 64 | RQS (SRQ TRUE?)/Master Summary Status | RQS is read by a serial poll (SPOLL)Master Summary Status is read by a *STB? query - defined by IEEE 488.2
5 | 32 | Standard Event Status Register | Summarizes the Standard Event Status Register
4 | 16 | Message Available | SCPI - Defined
3 | 8 | STATus: QUEStionableStatus Register | Summary Message comes from theSTATus: QUEStionable Status Register,which fans out to the CALL andHARDware Status Registers
2 | 4 | Error/ Event Queue | SCPI - Defined
1 | 2 | Reserved |
0 | 1 | Reserved |

Program Example - Status Byte Register Bit Assignments

OUTPUT 714;"*STB?" !Queries the Status Byte.


Standard Event Status Register

Standard Event Status Register

Last updated: January 16, 2009

*ESR?

*ESE?

*ESE

GPIB Command Conventions

Standard Event Status Register Bit Assignment

Bit Number

Binary Weighting

Condition

Description

15

32768

Reserved by IEEE.

This bit will always be 0.

14

16384

Reserved by IEEE.

This bit will always be 0.

13

8192

Reserved by IEEE.

This bit will always be 0.

12

4096

Reserved by IEEE.

This bit will always be 0.

11

2048

Reserved by IEEE.

This bit will always be 0.

10

1024

Reserved by IEEE.

This bit will always be 0.

9

512

Reserved by IEEE.

This bit will always be 0.

8

256

Reserved by IEEE.

This bit will always be 0.

7

128

Power On

This bit is set to 1 if the power supply has been turned off and on since the last time this register was read or otherwise cleared. Defined in "IEEE Std. 488.2-1992",11.5.1.1.2

6

64

Reserved for future use.

This bit will always be 0.

5

32

Command Error

This bit is set to 1 if the test set detects an error while trying to process a command. The following events cause a command error:

  • An IEEE 488.2 syntax error. The test set received a message that did not follow the syntax defined by the standard.

  • A semantic error. For example the test set received an incorrectly spelled command.

  • The test set received a group execution trigger (GET) inside a program message

4

16

Execution Error

This bit is set to 1 if the test set detects an error while trying to execute a command. The following events cause a execution error:

  • A <PROGRAM DATA> element received in a command is outside the legal range for the test set, or it is inconsistent with the operation of the test set.

  • The test set could not execute a valid command due to some test set hardware/firmware condition.

3

8

Device Dependent Error

This bit is set to 1 if a test set operation does not execute properly due to an internal condition (such as, overrange). This bit indicates that the error was not a command, query, or execution error.

2

4

Query Error

This bit is set to 1 if an error has occurred while trying to read the test set's output queue. The following events cause a query error:

  • An attempt is made to read data from the output queue when no data is present or is pending.

  • Data in the output queue has been lost. An example of this would be an output queue overflow.

1

2

Reserved for future use.

This bit will always be 0.

0

1

Operation Complete

This bit is set to 1 when the test set has completed all pending operations and is ready to accept new commands. This bit is only generated in response to the *OPC IEEE 488.2 common command.

Program Example - Standard Event Status Register

OUTPUT 714;"*ESR?" !Queries (reads) the Standard Event Status Register.


GPIB Command Conventions

GPIB Command Conventions

Last updated: January 16, 2009

Description

Command Description

The uppercase letters of a mnemonic represent the short form of the mnemonic, whereas the long form of a mnemonic is the short form followed by the lowercase letters. The test set accepts either the long form or the short form of the mnemonic.

The mnemonics that are inside square brackets are optional. That is, a command operates the same whether or not the mnemonic in square brackets is used in the command.

A vertical bar, |, implies choices. When mnemonics are listed in parentheses separated by vertical bars ( | ), you must choose one of the mnemonics inside the parentheses.

Complex Command Description

Complex commands are valuable because they set the state of the parameter and a value for that parameter. For example, a command that contains the mnemonic [:SAMPlitude] is a complex command that sets the state to ON as well as the amplitude. You can use parameters such as amplitude, frequency, gain, number, time, and value as a complex command. Refer to the specific command for the parameter that applies.

Data Type Description

num value

Integer, float or scientific values.

For example,

CALL:POWer -55.5

CALL:POWer -5.55E+001

CALL:CHANnel 525

string

Characters. The string will often need to be enclosed in single or double quotes, depending upon your programming environment.

For example,

CALL:CIDentity "#0123456789*"

CALL:UPLink:PRAChannel:ASUBchannels '111111111111'

The string returned by the test set is enclosed by double quotes.
choice1|choice2|choice3

Specific character choices.

For example,

CALL:OPERating:MODE D2KTest

SYSTem:COMMunicate:GPIB:DEBug ON

Unit Type Description

Some commands have optional units of measurement. These are displayed in square brackets. If no units are specified in the command then the default unit in bold font below is used. The test set accepts the specified unit either with or without a space inserted between the <num value> and the unit (for example, both 10S and 10 S are valid). The following table summarizes the units available.

Description

Optional Units

Example

Amplitude (linear)

V |MV

To set the spectrum monitor's timeout interval to 20 seconds, use any of the following formats:

SETup:SMONitor:TIMeout:TIME 20
SETup:SMONitor:TIMeout:TIME 20S
SETup:SMONitor:TIMeout:TIME 20 S

Power (logarithmic)

DBM |DBW

Level (relative)

DB

Frequency

HZ |KHZ|MHZ|GHZ

Time

S |MS|US|NS

Percentage

PCT

[:SELected] Mnemonic

The [:SELected] Mnemonic is an optional mnemonic that implies a current selection on the test set. Often there are other mnemonics that can be used in place of the [:SELected] mnemonic to configure a setting that is not the currently selected configuration on the test set. The mnemonics that can replace the [:SELected] mnemonic are listed in parentheses separated by vertical bars ( | ) in the description table title. An example of a command that contains the [:SELected] mnemonic is shown in the following table.

Using quotes around strings

When the setting and query values of a GPIB command are strings, a single quote is needed around the strings when setting the command, while the test set returns the result in double quoted strings when querying.

For example:

OUTPUT 714;"SYSTem:APPLication:FORMat '1xEV-DO'"

OUTPUT 714;"SYSTem:APPLication:FORMat?"
!The test set returns "1xEV-DO". Note here the strings are enclosed in double quote.

An example of a command that contains strings in the setting and query values is shown in the following table.


SYSTem:APPLication

SYSTem:APPLication

Last updated: May 5, 2009

GPIB Command Conventions

  • SYSTem:APPLication[:CURRent][:NAME]?
  • SYSTem:APPLication[:CURRent]:REVision?

  • SYSTem:APPLication:CATalog[:NAME]?
  • SYSTem:APPLication:CATalog[:NAME]:COUNt?
  • SYSTem:APPLication:CATalog:FORMat?
  • SYSTem:APPLication:CATalog:FORMat:COUNt?
  • SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>'
  • SYSTem:APPLication:CATalog:LICense:APPLication:ALL?
  • SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?

  • SYSTem:APPLication:CATalog:R2Current:COVerage?
  • SYSTem:APPLication:CATalog:R2Current:STATus?

  • SYSTem:APPLication:CATalog:REVision?<sp>'<application name>'
  • SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>'

  • SYSTem:APPLication:FORMat[:NAME]
  • SYSTem:APPLication:FORMat:LICense?<sp>'<format name>'

  • SYSTem:APPLication:SELect[:NAME]
  • SYSTem:APPLication:SELect:REVision
  • SYSTem:APPLication:SELect:REVision?<sp>'<application name>'

SYSTem:APPLication[:CURRent][:NAME]?

Function

Queries the name of the currently running application.

To query the revision of the currently running application, see SYSTem:APPLication[:CURRent]:REVision? .

To switch applications, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication?"

SYSTem:APPLication[:CURRent]:REVision?

Function

Queries the revision of the currently running application.

To query the name of the currently running application, see SYSTem:APPLication[:CURRent][:NAME]? .

To switch to a different revision of an application, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:REVision?"

SYSTem:APPLication:CATalog[:NAME]?

Function

Queries the names of the applications stored on the test set (whether they are licensed or not).

This query returns a comma-separated list of double-quoted strings (one for each application stored on the test set).

To query the number of applications stored on the test set, see SYSTem:APPLication:CATalog[:NAME]:COUNt? .

To switch applications, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: One or more of the following strings, separated by commas -

  • "1xEV-DO FTM Terminal Test"
  • "1xEV-DO Lab App"
  • "1xEV-DO Lab App B"
  • "1xEV-DO Lab App T'
  • "1xEV-DO Lab App U"
  • "1xEV-DO Terminal Test"
  • "AMPS/136 Mobile Test"
  • "CDMA 2000 Lab App"
  • "CDMA 2000 Lab App B"
  • "CDMA 2000 Lab App T"
  • "CDMA 2000 Mobile Test"
  • "CDMA 2000_1xEV-DO"
  • "EGPRS Lab App"
  • "Fast Switch Test App"
Query (continued)
  • "GPRS Lab Application"
  • "GPRS Lab App B"
  • "GPRS Mobile Test"
  • "GSM Mobile Test"
  • "GSM/GPRS Lab App C"
  • "GSM/GPRS Lab App D"
  • "GSM/GPRS Lab App E"
  • "GSM/GPRS Lab App F"
  • "GSM/GPRS Lab App T"
  • "GSM/GPRS Lab App U"
  • "GSM/GPRS Mobile Test"
  • "GSM/GPRS RF Modem"
  • "GSM/GPRS_AMPS/136"
  • "GSM/GPRS_AMPS/136_WCDMA"
  • "GSM/GPRS_CDMA 2000"
  • "GSM/GPRS_WCDMA Lab App"
  • "GSM/GPRS_WCDMA Lab App B"
  • "GSM/GPRS_WCDMA Lab App C"
  • "GSM/GPRS_WCDMA Lab App D"
  • "GSM/GPRS_WCDMA Lab App E"
  • "GSM/GPRS_WCDMA Lab App T"
  • "GSM/GPRS_WCDMA Lab App U"
  • "WCDMA Lab App"
  • "WCDMA Lab App B"
  • "WCDMA Lab App C"
  • "WCDMA Lab App D"
  • "WCDMA Lab App E"
  • "WCDMA Lab App F"
  • "WCDMA Lab App T"
  • "WCDMA Lab App U"
  • "WCDMA Mobile Test"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog?"

SYSTem:APPLication:CATalog[:NAME]:COUNt?

Function

Queries the total number of applications stored on the test set.

To query the names of the applications stored on the test set, see SYSTem:APPLication:CATalog[:NAME]? .

Query

Range: 0 through 30

Resolution: 1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:COUNt?"

SYSTem:APPLication:CATalog:FORMat?

Function

Queries the names of the formats in the current application.

This query returns a comma-separated list of double-quoted strings (one for each format in the application).

To query the number of formats in the current application, see SYSTem:APPLication:CATalog:FORMat:COUNt? .

To switch formats in a fast switching application, see SYSTem:APPLication:FORMat[:NAME] .

Query

Range: One or more of the following strings separated by commas -

  • "1xEV-DO"
  • "AMPS/136"
  • "GSM/GPRS" (Note: this query return represents GSM, GPRS and EGPRS formats)
  • "IS-2000/IS-95/AMPS"
  • "IS-856"
  • "WCDMA"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:FORMat?"

SYSTem:APPLication:CATalog:FORMat:COUNt?

Function

Queries the number of formats in the current application.

To query the names of the formats in the current application, see SYSTem:APPLication:CATalog:FORMat? .

Query

Range: 0 to 30

Resolution: 1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:FORMat:COUNt?"

SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>'

Function

Queries the license status for the specified application/revision. The application/revision does not have to be installed in the test set.

The query must include a parameter for the application name and revision, enclosed by single quotes and separated by a comma. For application names and revisions, see SYSTem:APPLication:CATalog[:NAME]? and SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' . Note that the application name and revision parameters are not case-sensitive.

Query

Range: LIC|NLIC|PART|UNKN

  • "LIC" indicates this is a licensed application/revision.
  • "NLIC" indicates this is not a licensed application/revision.
  • "PART" indicates that not all of the formats in this application/revision are licensed. (To determine the license status of each format, see SYSTem:APPLication:FORMat:LICense?<sp>'<format name>' .)
  • "UNKN" indicates that license status is unknown.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense? 'CDMA 2000 Mobile Test','B.07.00'"

SYSTem:APPLication:CATalog:LICense:APPLication:ALL?

Function

Queries the names of the applications, formats and features that are licensed for the test set. The applications, formats and features do not have to be installed in the test set to be returned by this query.

This query returns a comma-separated list of double-quoted strings (two for each application, one for each format or feature).

To query the number of licensed applications, formats and features for the test set, see SYSTem:APPLication:CATalog:LICense:APPLication:COUNt? .

Query

Range: One or more of the following strings, separated by commas -

Applications -

  • "E1960A","GSM Mobile Test"
  • "E1961A","AMPS/136 TA"
  • "E1962B","CDMA2000 TA"
  • "E1963A","WCDMA TA"
  • "E1964A","GPRS Mobile Test"
  • "E1966A","1xEV-DO TA"
  • "E1968A","GSM/GPRS Mobile Test"
  • "E1976A","1xEV-DO FTM TA"
  • "E1985A","GSM/GPRS_AMPS/136"
  • "E1985B","GSM/GPRS_AMPS/136_WCDMA"
  • "E1985C","GSM/GPRS_CDMA 2000"
  • "E1985E","CDMA 2000_1xEV-DO"
  • "E1987A","Fast Switch Test App"
  • "E6590A","GSM/GPRS RF Modem"
  • "E6701A","GPRS LA"
  • "E6701B","GPRS LA rev B"
  • "E6701C","GSM/GPRS LA rev C"
  • "E6701D","GSM/GPRS LA rev D"
  • "E6701E","GSM/GPRS LA rev E"
  • "E6701F","GSM/GPRS LA rev F"
  • "E6701T","GSM/GPRS LA rev T"
  • "E6701U","GSM/GPRS LA rev U"
  • "E6702A","CDMA2000 LA"
  • "E6702B","CDMA2000 LA rev B"
  • "E6702T","CDMA2000 LA rev T"
  • "E6703A","WCDMA LA"
  • "E6703B","WCDMA LA rev B"
  • "E6703C","WCDMA LA rev C"
  • "E6703D","WCDMA LA rev D"
  • "E6703E","WCDMA LA rev E"
  • "E6703F","WCDMA LA rev F"
  • "E6703T","WCDMA LA rev T"
  • "E6703U","WCDMA LA rev U"
Query (continued)
  • "E6704A","EGPRS LA"
  • "E6706A","1xEV-DO Lab App"
  • "E6706T","1xEV-DO LA rev T"
  • "E6706U","1xEV-DO LA rev U"
  • "E6785A","GSM/GPRS_WCDMA Lab App"
  • "E6785B","GSM/GPRS_WCDMA LA rev B"
  • "E6785C","GSM/GPRS_WCDMA LA rev C"
  • "E6785D","GSM/GPRS_WCDMA LA rev D"
  • "E6785T","GSM/GPRS_WCDMA LA rev T"

Formats -

  • "E1968A-101","GSM TA"
  • "E1968A-102","GPRS TA"
  • "E1968A-103","EGPRS TA"
  • "E1968A-201","GSM/GPRS TA"
  • "E1968A-202","GSM/GPRS/EGPRS TA"
  • "E6590A-101","GSM/GPRS"
  • "E6590A-102","EGPRS"
  • "E6590A-103","RF Modem"

Features -

  • "E1962B-401","CDMA2000 Real"
  • "E1962B-402","AMPS Enhancement"
  • "E1962B-403","CDMA2000 Authenticate"
  • "E1963A-401","WCDMA Video Call"
  • "E1963A-403","HSDPA Test Modes"
  • "E1966A-102","1xEV-DO RelA"
  • "E1968A-410","Phase & Ampl vs Time"
  • "E1976A-102","1xEV-DO RelA FTM"
  • "E1999A-401","GSM Fast Device Tune"
  • "E6706A-102","1xEV-DO Rel A ETAP"
  • "E6706T-102","1xEV-DO Rel A ETAP"

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:ALL?"

SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?

Function

Queries the number of applications, formats and features that are licensed for the test set. The applications, formats and features do not have to be installed in the test set to be included in the query result.

To query the names of the licensed applications, formats and features for the test set, see SYSTem:APPLication:CATalog:LICense:APPLication:ALL? .

Query

Range: 0 to 300

Resolution: 1

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?"

SYSTem:APPLication:CATalog:R2Current:COVerage?

Function

Queries the coverage date of the installed R2C license. See Test Application Revision To Current (R2C) license .

Query

 Range: three comma-separated values with the format <year>, <month>, <day>.

Requirements

 Test Application Revision: A.14.16 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:R2Current:COVerage?"
! Queries the coverage date of the installed R2C license.

SYSTem:APPLication:CATalog:R2Current:STATus?

Function

Queries the R2C license status. See Test Application Revision To Current (R2C) license .

Query

 LIC | NLIC | PART

Requirements

 Test Application Revision: A.14.16 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:R2Current:STATus?"
! Queries the R2C license status.

SYSTem:APPLication:CATalog:REVision?<sp>'<application name>'

Function

Queries the revisions stored on the test set for the specified application.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

This query returns a comma-separated list of double-quoted strings (one for each revision of the application).

Note, if you have several revisions of the application stored on the test set, you may need to increase your GPIB controller's timeout time to avoid a timeout condition.

To query the number of revisions stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>' .

To switch to a different revision of an application, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

 Range: Comma-separated list of 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01","A.02.01"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:REVision? 'CDMA 2000 MOBILE TEST'"

SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>'

Function

Queries the number of revisions stored on the test set for the specified application.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

To query the revision numbers stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' .

Query

Range: 0 to 30

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:REVision:COUNt? 'CDMA 2000 MOBILE TEST'"

SYSTem:APPLication:FORMat[:NAME]

Function

Switches to the specified format (in the current application). Only fast switching applications include more than one format. To determine what formats are available in the current application, see SYSTem:APPLication:CATalog:FORMat? . To determine the license status of a format, see SYSTem:APPLication:FORMat:LICense?<sp>'<format name>' .

Queries the name of the currently active format in the current application.

Setting

Range:

  • 1xEV-DO
  • AMPS/136
  • GSM/GPRS (Note: this query return represents GSM, GPRS and EGPRS formats)
  • IS-2000/IS-95/AMPS
  • IS-856
  • WCDMA

Query

Same as setting.

Note: The query result is returned within a pair of double quotation marks. For example, if the current application is GSM/GPRS, the test set returns "GSM/GPRS" .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:FORMat 'IS-2000/IS-95/AMPS'"

OUTPUT 714;"SYSTem:APPLication:FORMat?"

SYSTem:APPLication:FORMat:LICense?<sp>'<format name>'

Function

Queries the license status of the specified format in the current application.

The query must include a parameter for the format name enclosed by single quotes. For format names, see SYSTem:APPLication:CATalog:FORMat? . Note that the format name parameter is not case-sensitive.

Query

Range: LIC|NLIC|UNKN

  • "LIC" indicates this is a licensed format.
  • "NLIC" indicates this is not a licensed format.
  • "UNKN" indicates that the license status is unknown.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:FORMat:LICense? 'IS-2000/IS-95/AMPS'"

SYSTem:APPLication:SELect[:NAME]

Function

Switches to the specified application (this includes a reboot of the test set). To determine what applications are stored on the test set, see SYSTem:APPLication:CATalog[:NAME]? . The revision that is switched to is determined by SYSTem:APPLication:SELect:REVision . To determine the license status of the application/revision, see SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>' .

Queries the name of the application that will be loaded after the next reboot of the test set.

Setting

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Query

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect 'CDMA 2000 MOBILE TEST'"

OUTPUT 714;"SYSTem:APPLication:SELect?"

SYSTem:APPLication:SELect:REVision

Function

Sets the revision that will be loaded when the application is switched to using the SYSTem:APPLication:SELect[:NAME] command.

To determine what application is to be switched to, see SYSTem:APPLication:SELect[:NAME] . To determine what revisions are stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' . To determine the license status of a revision, see SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>' .

To query the revision that will be loaded when an application is switched to, see SYSTem:APPLication:SELect:REVision?<sp>'<application name>' .

NOTE
GSM Mobile Test revisions prior to A.04.00 did not have application switching and provide no way to return to revisions that have switching. If you switch to a GSM Mobile Test application revision prior to A.04.00, the only way to return to a newer revision is by downloading it using the process for upgrading firmware.

Setting

Range: see SYSTem:APPLication:CATalog[:NAME]? and SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect:REVision 'CDMA 2000 Mobile Test','B.06.30'"

SYSTem:APPLication:SELect:REVision?<sp>'<application name>'

Function

Queries the revision that will be loaded when the specified application is switched to using the SYSTem:APPLication:SELect[:NAME] command.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

To set the revision that will be loaded when the specified application is switched to, see SYSTem:APPLication:SELect:REVision .

NOTE
GSM Mobile Test revisions prior to A.04.00 did not have application switching and provide no way to return to revisions that have switching. If you switch to a GSM Mobile Test application revision prior to A.04.00, the only way to return to a newer revision is by downloading it using the process for upgrading firmware.

Query

 Range: 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect:REVision? `CDMA 2000 MOBILE TEST'"

Related Topics

Application Switching


SYSTem:AUDio

SYSTem:AUDio

Last updated: January 16, 2009

GPIB Command Conventions

  • SYSTem:AUDio:OUTPut:SOURce
  • SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe
  • SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe
  • SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe

SYSTem:AUDio:OUTPut:SOURce

Function

Set/queries whether the audio generator signal or the FM demodulation signal is selected to be routed to the AUDIO OUT port of the test set's front panel.

When audio generator is selected for output at the front-panel AUDIO OUT port, use AFGenerator Subsystem to control the audio generator.

NOTE
The selection of FM Demod signal is useful only in AMPS system. A bandpass filter, expander circuit, and deemphasis circuit can be individually inserted or bypassed in the FM Demod signal path. Use the command SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe to insert the bandpass filter. Use the command SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe to insert the expandor circuit. Use the command SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe to insert the deemphasis filter.

NOTE
There will be no guaranteed performance for the signal present at the Audio Out port when FM Demod is selected for output.

Requirements

Test Application Revision: A.03 or above.

Lab Application Revision: A.01 or above.

Setting

AFGenerator|FMDemod

Query

AFG|FMD

*RST Setting

AFG

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:SOURce FMDemod"

!Selects FM Demod signal for output at the front panel AUDIO OUT port.

SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe

Function

Sets/queries whether the fixed bandpass filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port (see SYSTem:AUDio:OUTPut:SOURce ).

When the state is ON, a 300 Hz to 3 KHz bandpass filter is inserted in the audio signal path. When the state is OFF, the bandpass filter is bypassed in the audio signal path

Requirements

Test Application Revision: A.03 or above.

Lab Application Revision: A.01 or above.
Setting | Range: 0|OFF|1|ON

Query

Range: 0|1
*RST setting | 0 (OFF)

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe ON"

!Sets the bandpass filter state to ON.

SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe

Function

Sets/queries whether the expandor filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port (see SYSTem:AUDio:OUTPut:SOURce ).

When the state is ON, the expandor filter is inserted in the audio signal path. When the state is OFF, the expandor filter is bypassed in the audio signal path.

Requirements

Test Application Revision: A.03 or above.

Lab Application Revision: A.01 or above.
Setting | Range: 0|OFF|1|ON

Query

Range: 0|1
*RST setting | 0 (OFF)

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe ON" !Sets the expandor filter state to ON.

SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe

Function

Sets/queries whether the deemphasis filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port (see SYSTem:AUDio:OUTPut:SOURce ).

When the state is ON, the deemphasis filter is inserted in the audio signal path. When the state is OFF, the deemphasis filter is bypassed in the audio signal path.

Requirements

Test Application Revision: A.03 or above.

Lab Application Revision: A.01 or above.
Setting | Range: 0|OFF|1|ON

Query

Range: 0|1
*RST setting | 0 (OFF)

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe ON"

!Sets the deemphasis filter state to ON.


SYSTem:BEEPer

SYSTem:BEEPer

Last updated: January 16, 2009

GPIB Command Conventions

  • SYSTem:BEEPer:STATe

SYSTem:BEEPer:STATe

Function

Sets/queries the beeper state of the test set.

Setting

0|OFF | 1|ON

Query

0|1

*RST Setting

1 (on)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:BEEPER:STATE OFF" !Sets beeper state to off.


SYSTem:COMMunicate

SYSTem:COMMunicate

Last updated: May 11, 2011

GPIB Command Conventions

  • SYSTem:COMMunicate:GPIB[:SELF]:ADDRess
  • SYSTem:COMMunicate:GPIB:DEBug[:STATe]

  • SYSTem:COMMunicate:LAN[:SELF]:ADDRess[:IP4]
  • SYSTem:COMMunicate:LAN[:SELF]:ADDRess:IP6:IID?
  • SYSTem:COMMunicate:LAN[:SELF]:ADDRess:IP6:PREFix
  • SYSTem:COMMunicate:LAN[:SELF]:ADDRess2[:IP4]
  • SYSTem:COMMunicate:LAN[:SELF]:ADDRess2:IP6:IID?
  • SYSTem:COMMunicate:LAN[:SELF]:DGATeway[:IP4]
  • SYSTem:COMMunicate:LAN[:SELF]:DGATeway:IP6:IID
  • SYSTem:COMMunicate:LAN[:SELF]:ROUTer:STATe:IP6
  • SYSTem:COMMunicate:LAN[:SELF]:SMASk[:IP4]

  • SYSTem:COMMunicate:LAN:EPCore:ADDRess
  • SYSTem:COMMunicate:LAN:EPCore:CONNect
  • SYSTem:COMMunicate:LAN:EPCore:DCONnect
  • SYSTem:COMMunicate:LAN:EXTernal:ADDRess
  • SYSTem:COMMunicate:LAN:EXTernal:CONNect
  • SYSTem:COMMunicate:LAN:EXTernal:DCONnect

SYSTem:COMMunicate:GPIB[:SELF]:ADDRess

Function

 Sets/queries the test set's GPIB address. Configuring the Test Set's GPIB

Setting

Range: 0 to 30

Resolution: 1

Query

Range: 0 to 30

Resolution: 1

Factory setting

14 (this parameter is not affected by any reset operation and can only be changed by direct user access)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:GPIB:SELF:ADDRESS 14"
! Sets the GPIB address to 14.

SYSTem:COMMunicate:GPIB:DEBug[:STATe]

Function

Sets/queries the test set's SCPI debugger state.

When the state is on; enhanced error messages (generated from GPIB commands with syntax errors) are shown the test set display.

The error message is printed along with the syntax. <ERR> is displayed at the end of the incorrect node. Non-printable characters will be replaced with the $ symbol. See Error Messages for a list of the errors.

The debugger state should be set to on only during GPIB code development. Test times will increase if the debugger state is left on.

Setting

 Range: 0|OFF | 1|ON
Query 0|1

*RST setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:GPIB:DEBUG:STATE ON"
! Sets debugger to on.

SYSTem:COMMunicate:LAN[:SELF]:ADDRess[:IP4]

Function

Sets/queries the test set's LAN IPv4 address. The value of A is used to determine the subnet mask, see SYSTem:COMMunicate:LAN[:SELF]:SMASk[:IP4] .

If the LAN IP address is changed the subnet mask should be checked to insure that it is set to the proper class for that LAN address. (See Configuring the Test Set's LAN )

The LAN IP address cannot be changed when CALL[:CELL]:OPERating:MODE is set to CALL.

Setting

Range: 15 characters formatted as follows: A.B.C.D. The range of values for A= 0 to 126 and 128 to 223. The range of values for B,C, D = 0 to 255 (no embedded spaces).

Query

Range: 15 characters formatted as follows: A.B.C.D. The range of values for A= 0 to 126 and 128 to 223. The range of values for B,C, D = 0 to 255 (no embedded spaces).

Factory setting

0.0.0.0 (this parameter is not affected by any reset operation and can only be changed by direct user access)

Related Topics

 Configuring the Test Set's LAN

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:ADDRESS '130.015.156.255'"
!Sets the LAN IP address.

SYSTem:COMMunicate:LAN[:SELF]:ADDRess:IP6:IID?

Function

Queries the LAN IPv6 Address (IID) showed in the Instrument IP Addressing screen.

Query

 Range: 19 characters formatted as: AAAA:BBBB:CCCC:DDDD where A, B, C and D are all hex numbers ranging from 0 to F.
*RST Setting | Fixed value.
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"SYSTem:COMMunicate:LAN:ADDRess:IP6:IID?"
!Queries the LAN IPv6 Address (IID).

SYSTem:COMMunicate:LAN[:SELF]:ADDRess:IP6:PREFix

Function

Sets/queries the test set's IPv6 address prefix. See Instrument IP Info/Instrument IP Setup .

Setting

Range: 19 characters formatted as: AAAA:BBBB:CCCC:DDDD where A, B, C and D are all hex numbers.

  • "" (Null) or
  • 2000:0000:0000:0000 to 3FFF:FFFF:FFFF:FFFF or
  • FC00:0000:0000:0000 to FDFF:FFFF:FFFF:FFFF

Double-colon "::" can be used in the IPv6 address as valid. Moreover, "::" can be suffixed at the end of the 19 characters which is also a valid IPv6 address prefix. For example: 2009:1:2:3 and 2009:1:2:3:: are all valid IPv6 address prefixes for the GPIB parameter setting.

Query

 Range: 19 characters formatted as: AAAA:BBBB:CCCC:DDDD where A, B, C and D are all hex numbers ranging from 0 to F.
*RST Setting | "" (Null)
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"SYSTem:COMMunicate:LAN:ADDRess:IP6:PREFix '2009:8960:8960:8960'"
!Sets the IPv6 address prefix to 2009:8960:8960:8960.

OUTPUT 714;"SYSTem:COMMunicate:LAN:ADDRess:IP6:PREFix '2009:1:2:3'"
!Sets the IPv6 address prefix to 2009:1:2:3.

OUTPUT 714;"SYSTem:COMMunicate:LAN:ADDRess:IP6:PREFix '2009:1:2:3::'"
!Sets the IPv6 address prefix to 2009:1:2:3::.

SYSTem:COMMunicate:LAN[:SELF]:ADDRess2[:IP4]

Function

Sets/queries the test set's LAN 2 PORT IP address.

Setting

Range: 15 characters formatted as follows: A.B.C.D. The range of values for A= 0 to 126 and 128 to 223. The range of values for B.C. D = 0 to 255 (no embedded spaces).

Query

Range: 15 characters formatted as follows: A.B.C.D. The range of values for A= 0 to 126 and 128 to 223. The range of values for B,C, D = 0 to 255 (no embedded spaces).

Factory setting

0.0.0.0 (this parameter is not affected by any reset operation and can only be changed by direct user access)

Related Topics

 LAN 2 PORT

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:ADDRESS2 '130.015.156.255'"
! Sets the LAN 2 IP address.

SYSTem:COMMunicate:LAN[:SELF]:ADDRess2:IP6:IID?

Function

Queries the LAN 2 IPv6 Address (IID) showed in the Instrument IP Addressing screen.

Query

 Range: 19 characters formatted as: AAAA:BBBB:CCCC:DDDD where A, B, C and D are all hex numbers ranging from 0 to F.
*RST Setting | Fixed value.
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"SYSTem:COMMunicate:LAN:ADDRess2:IP6:IID?"
!Queries the LAN 2 IPv6 Address (IID).

SYSTem:COMMunicate:LAN[:SELF]:DGATeway[:IP4]

Function

Sets/queries the LAN IP router/gateway address for the test set.

Setting

Range: 15 characters formatted as follows: A.B.C.D where A= 0 to 223 B,C,D = 0 to 255 (no embedded spaces), blank field

Query

Range: 15 characters formatted as follows: A.B.C.D where A,B,C,D = 0 to 255 (no embedded spaces). blank field

Factory setting

blank field, (this parameter is not affected by any reset operation)

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:DGATEWAY '130.2.6.200'"

SYSTem:COMMunicate:LAN[:SELF]:DGATeway:IP6:IID

Function

Sets/queries the test set's IPv6 Default Router Interface ID. See Instrument IP Info/Instrument IP Setup for details.

Setting

Range: 19 characters formatted as: AAAA:BBBB:CCCC:DDDD where A, B, C and D are all hex numbers.

  • "" (Null) or
  • 0000:0000:0000:0001 to FFFF:FFFF:FFFF:FFFF

Double-colon "::" can be used in the IPv6 Default Router Interface ID as valid. Moreover, "::" can be prefixed at the beginning of the 19 characters which is also a valid IPv6 Default Router Interface ID. For example: 8960::1, ::1:2 and 8960:8960:146.208.232:220 are all valid IPv6 Default Router Interface IDs for the GPIB parameter setting.

The IPv6 Default Router Interface parameter is also IPv4 address-compatible with the format: ::W.X.Y.Z, where W.X.Y.Z is the dotted decimal representation of an IPv4 address. For example, ::8960:8960:146.208.232:220 and 8960:8960:146.208.232:220 are all valid IPv6 Default Router Interface IDs for the GPIB parameter setting.

Query

 Range: 19 characters formatted as: AAAA:BBBB:CCCC:DDDD where A, B, C and D are all hex numbers ranging from 0 to F.
*RST Setting | "" (Null)
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"
SYSTem:COMMunicate:LAN:DGATeway:IP6:IID '0000:0000:821D:B001'"
!Sets the test set's IPv6 Default Router Interface ID to 0000:0000:821D:B001.

SYSTem:COMMunicate:LAN[:SELF]:ROUTer:STATe:IP6

Function

 Sets/queries whether the test set acts as a IPv6 router. See IPv6 Router State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting Off

Requirements

Lab Application Revision: H.00.00 and above.

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:ROUTER:STATE:IP6 Off"
!Sets the IPv6 Router State to "off"

SYSTem:COMMunicate:LAN[:SELF]:SMASk[:IP4]

Function

Sets/queries the subnet mask of the test set based on the LAN IP address selected. The subnet mask changes according to the value of A used for the LAN IP address.

If A is less than 127, the default subnet mask is 255.0.0.0.

If A is greater than 127 and less or equal to 191, the default subnet mask is 222.255.0.0.

If A is grater than 191, the default subnet mask is 255.255.255.0.

If the LAN address is changed the default subnet mask should be checked to insure that it is set to the proper class for that LAN address.

Setting

Range: 15 characters formatted as follows: A.B.C.D where A,B,C,D are between = 0 to 255 (no embedded spaces)

Query

Range: 15 characters formatted as follows: A.B.C.D where A,B,C,D are between = 0 to 255 (no embedded spaces)

Factory setting

0.0.0.0 (this parameter is not affected by any reset operation and can only be changed by direct user access)

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:SMASK '255.2.6.200'"

SYSTem:COMMunicate:LAN:EPCore:ADDRess

Function

 Sets/queries the external Evolved Packet Core (EPC) simulator's IPv4 address. See Ext EPC IP Addr .

Setting

Range:

  • 0.0.0.0 to 126.255.255.255
  • 128.0.0.0 to 223.255.255.255

Query

 Same as setting
*RST Setting "0.0.0.0" (Null)

Requirements

Lab Application Revision: H.00.00 and above.

Programming Example

OUTPUT 714;"SYSTem:COMMunicate:LAN:EPCore:ADDRess '130.015.156.235'"
!Sets the external Evolved Packet Core (EPC) simulator's IPv4 address to '130.015.156.235'.

SYSTem:COMMunicate:LAN:EPCore:CONNect

Function

 Initiates the Connect to External EPC immediate action. See Connect To External EPC .

Requirements

Lab Application Revision: H.00.00 and above.

Programming Example

OUTPUT 714;"SYSTem:COMMunicate:LAN:EPCore:CONNect"
!Initiates a connection to the External EPC simulator.

SYSTem:COMMunicate:LAN:EPCore:DCONnect

Function

 Initiates the Disconnect From External EPC immediate action. See Disconnect From External EPC .

Requirements

Lab Application Revision: H.00.00 and above.

Programming Example

OUTPUT 714;"SYSTem:COMMunicate:LAN:EPCore:DCONnect"
!Disconnect the test set from the External EPC simulator.

SYSTem:COMMunicate:LAN:EXTernal:ADDRess

Function

Sets/queries the External 8960 IP Address .

Setting

Range: 15 characters formatted as follows: A.B.C.D where A= 0 to 126 and 128 to 223, B.C.D = 0 to 255 (no embedded spaces), blank field.

Query

Range: 15 characters formatted as follows: "A.B.C.D" where A= 0 to 126 and 128 to 223, B.C.D = 0 to 255 (no embedded spaces), "".

Factory setting

"" (this parameter is not affected by any reset operation and can only be changed by direct user access)

Requirements

Lab Application Revision: C.01 and above

Test Application Revision: A.06 and above, with the required feature license

Programming Example

OUTPUT 714;"SYSTem:COMMunicate:LAN:EXTernal:ADDRess '130.015.156.255'"
! Sets the External 8960 IP Address.

SYSTem:COMMunicate:LAN:EXTernal:CONNect

Function

 Initiates the Connect to External 8960 immediate action (see External Device Connection ).

Requirements

Lab Application Revision: C.01 and above

Test Application Revision: A.06 and above, with the required feature license

Programming Example

OUTPUT 714;"SYSTem:COMMunicate:LAN:EXTernal:CONNect"

SYSTem:COMMunicate:LAN:EXTernal:DCONnect

Function

 Initiates the Disconnect from External 8960 immediate action (see External Device Connection ).

Requirements

Lab Application Revision: C.01 and above

Test Application Revision: A.06 and above, with the required feature license

Programming Example

OUTPUT 714;"SYSTem:COMMunicate:LAN:EXTernal:DCONnect"


SYSTem:CONFigure

SYSTem:CONFigure

Last updated: January 16, 2009

GPIB Command Conventions

  • SYSTem:CONFigure:INFormation:HARDware:VERBose?

SYSTem:CONFigure:INFormation:HARDware:VERBose?

Function

Query the manufacturer, model number, model number of the test application running, serial number, revision, board ID, and cal file information. The information provided by the query represents the configuration that existed when the test set was powered up.

*RST Setting

Resets have no effect on this information. The information is gathered during the power up cycle.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:CONFIGURE:INFORMATION:HARDWARE:VERBOSE?" !Queries system hardware.

Related Topics

Hardware Configuration Report


SYSTem:CORRection

SYSTem:CORRection

Last updated: August 31, 2011

GPIB Command Conventions

  • SYSTem:CORRection[:SGAin]
  • SYSTem:CORRection:FREQuency
  • SYSTem:CORRection:GAIN
  • SYSTem:CORRection:POINts
  • SYSTem:CORRection:SFRequency
  • SYSTem:CORRection:STATe

SYSTem:CORRection[:SGAin]

Function

Sets/queries up to 60 comma-separated amplitude offset values in dB. This command sets the state to On.

See Amplitude Offset .

The units, dB, are optional. If no units are specified then units default to dB.

Sending a null list (no values) sets the state of all offsets to Off.

Setting

Range: 0 to 60 values between -100 to +100

Resolution: 0.01

Query

Range: 1 to 60 values between -100 to +100, and NAN (9.91E+37)

Resolution: 0.01

Factory Setting

Offsets 1 through 60, are set to 0.00 dB, state is set to Off

Requirements

Test or Lab Application Revision: A.01 and above
Lab Application Revision: G.00.00 and above, added amplitude offsets for frequency points 21 to 60

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:SGAIN -2.55,-3.12,-3.68,-4.23,-4.74,-5.3"
!A complex command that sets up to 60 comma separated offsets
!and sets the state to On for the frequencies, offsets and
!RF IN/OUT Amplitude Offset State

OUTPUT 714;"SYSTEM:CORRECTION:SGAIN"
!Sets the state for all frequencies and offsets to Off

SYSTem:CORRection:FREQuency

Function

Sets/queries up to 60 comma-separated frequency values. Each frequency value corresponds with a gain setting. See SYSTem:CORRection:GAIN .

The units, (GHz, MHz, kHz, Hz) are optional. If no units are specified, units default to Hz.

See Amplitude Offset .

Sending a null list (no values) sets the state of all frequencies to Off.

Setting

Range: 0 to 60 comma separated values ranging from 292.5 MHz to 2700 MHz

Resolution: 1 Hz

Query

Range: 1 to 60 comma separated values ranging from 292.5 MHz to 2700 MHz, and NAN (9.91E+37)

Resolution: 1 HZ

Factory Setting

Frequency values 1 to 10: 800.0MHz, 810.0MHz, 820.0MHz, 830.0MHz, 840.0MHz,850.0MHz, 860.0MHz, 870.0MHz, 880.0MHz, 890.0MHz;

Frequency values 11 to 20: 900.0MHz, 910.0MHz, 920.0MHz, 930.0MHz, 940.0MHz,950.0MHz, 960.0MHz, 970.0MHz, 980.0MHz, 990.0MHz;

Frequency values 21 to 30: 1700.0MHz, 1710.0MHz, 1720.0MHz, 1730.0MHz, 1740.0MHz,1750.0MHz, 1760.0MHz, 1770.0MHz, 1780.0MHz, 1790.0MHz;

Frequency values 31 to 40: 1800.0MHz, 1810.0MHz, 1820.0MHz, 1830.0MHz, 1840.0MHz,1850.0MHz, 1860.0MHz, 1870.0MHz, 1880.0MHz, 1890.0MHz;Frequency values 41 to 50: 1900.0MHz, 1910.0MHz, 1920.0MHz, 1930.0MHz, 1940.0MHz,1950.0MHz, 1960.0MHz, 1970.0MHz, 1980.0MHz, 1990.0MHz;Frequency values 51 to 60: 2000.0MHz, 2010.0MHz, 2020.0MHz, 2030.0MHz, 2040.0MHz,2050.0MHz, 2060.0MHz, 2070.0MHz, 2080.0MHz, 2090.0MHz.

Requirements

Test or Lab Application Revision: A.01 and above
Lab Application Revision: G.00.00 and above, added amplitude offsets for frequency points 21 to 60

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:FREQUENCY 1784.8 MHZ,1879.8 MHZ"
!Sets up to 60 comma separated frequencies

OUTPUT 714;"SYSTEM:CORRECTION:FREQUENCY"
!Sets the state for all frequencies and offsets to Off

SYSTem:CORRection:GAIN

Function

Sets/queries the up to 60 comma separated offset gain values in units of dB. Each gain value corresponds with a frequency setting. See SYSTem:CORRection:FREQuency .

See Amplitude Offset .

The units, dB, are optional. If no units are specified, units default to dB.

Sending a null list (no values) sets the state of all offsets to Off.

Setting

Range: 0 to 60 values between -100 to +100

Resolution: 0.01

Query

Range: 1 to 60 values between -100 to +100, and NAN (9.91E+37)

Resolution: 0.01

Factory Setting

Offsets 1 through 60, are set to 0.00 dB, state is set to off

Requirements

Test or Lab Application Revision: A.01 and above
Lab Application Revision: G.00.00 and above, added amplitude offsets for frequency points 21 to 60

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:GAIN -3.12,-3.68,-4.23"
!Sets up to 60 comma separated offset values.

OUTPUT 714;"SYSTEM:CORRECTION:GAIN"
!Sets the state for all frequencies and offsets to Off.

SYSTem:CORRection:POINts

Function

Query returns the number of offsets that are in their On state when the RF IN/OUT Amplitude Offset State is also set to On.

See Amplitude Offset .

Query

Range: 1 to 60, and NAN (9.91E+37)

Resolution: 1

Requirements

Test or Lab Application Revision: A.01 and above
Lab Application Revision: G.00.00 and above, added amplitude offsets for frequency points 21 to 60

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:POINTS?"

!Returns the number of frequencies and offsets with their state set to On.

SYSTem:CORRection:SFRequency

Function

Sets/queries up to 60 comma separated frequency values. This command sets the state to On.

The units (GHz, MHz, kHz, Hz) are optional. If no units are specified, units default to Hz.

See Amplitude Offset .

Sending a null list (no values) sets the state of all frequencies to Off.

Setting

Range: 0 to 60 comma separated values from 292.5 MHz to 2700 MHz

Resolution: 1 Hz

Query

Range: 1 to 60 comma separated values from 292.5 MHz to 2700 MHz, and NAN (9.91E+37)

Resolution: 1 HZ

Factory Setting

Frequency values 1 to 10: 800.0MHz, 810.0MHz, 820.0MHz, 830.0MHz, 840.0MHz,850.0MHz, 860.0MHz, 870.0MHz, 880.0MHz, 890.0MHz;

Frequency values 11 to 20: 900.0MHz, 910.0MHz, 920.0MHz, 930.0MHz, 940.0MHz,950.0MHz, 960.0MHz, 970.0MHz, 980.0MHz, 990.0MHz;

Frequency values 21 to 30: 1700.0MHz, 1710.0MHz, 1720.0MHz, 1730.0MHz, 1740.0MHz,1750.0MHz, 1760.0MHz, 1770.0MHz, 1780.0MHz, 1790.0MHz;

Frequency values 31 to 40: 1800.0MHz, 1810.0MHz, 1820.0MHz, 1830.0MHz, 1840.0MHz,1850.0MHz, 1860.0MHz, 1870.0MHz, 1880.0MHz, 1890.0MHz;Frequency values 41 to 50: 1900.0MHz, 1910.0MHz, 1920.0MHz, 1930.0MHz, 1940.0MHz,1950.0MHz, 1960.0MHz, 1970.0MHz, 1980.0MHz, 1990.0MHz;Frequency values 51 to 60: 2000.0MHz, 2010.0MHz, 2020.0MHz, 2030.0MHz, 2040.0MHz,2050.0MHz, 2060.0MHz, 2070.0MHz, 2080.0MHz, 2090.0MHz.

Each frequency state is Off.

Requirements

Test or Lab Application Revision: A.01 and above
Lab Application Revision: G.00.00 and above, added amplitude offsets for frequency points 21 to 60

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:SFREQUENCY 1710.2 MHZ,1805.2 MHZ,1784.8 MHZ,1879.8 MHZ"
!Sets up to 60 comma separated frequencies and sets the state to On for the frequency,
!offset, and RF IN/OUT Amplitude Offset State

OUTPUT 714;"SYSTEM:CORRECTION:SFREQUENCY"
!Sets the state for all frequencies and offsets to Off

SYSTem:CORRection:STATe

Function

Sets/queries the RF IN/OUT Amplitude Offset State. The state must be On before any of the offsets are active regardless of the state for any of the frequencies or offsets.

When the RF IN/OUT Amplitude Offset State is On, the Instrument Status Area will indicate "Offset" regardless of the state for any of the frequencies or offsets.

Setting any of the frequency or offset states to On will set the RF IN/OUT Amplitude Offset State to On.

See Amplitude Offset .

Setting

0|OFF | 1|ON

Query

0|1

Factory Setting

0 (off)

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:STATE ON" !Sets the RF IN/OUT
                                        !Amplitude Offset State to On


SYSTem:CURRent:TA

SYSTem:CURRent:TA

Last updated: January 16, 2009

GPIB Command Conventions

  • SYSTem:CURRent:TA:MODel?
  • SYSTem:CURRent:TA:NAME?
  • SYSTem:CURRent:TA:REVision?

SYSTem:CURRent:TA:MODel?

Function | Query the model number of the test application running. Printable ASCII characters up to a 15 character string.
Query | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting | non volatile, read from the test set's hard disk
Requirements | Test or Lab Application Revision: A.01 and above

SYSTem:CURRent:TA:NAME?

Function | Query the name of the test application running. Printable ASCII characters up to a 25 character string. This command is not recommended see SYSTem:APPLication .
Query | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting | non volatile, read from the test set's hard disk
Requirements | Test or Lab Application Revision: A.01 and above

SYSTem:CURRent:TA:REVision?

Function | Query the coordinated codeware revision for the test application running. Printable ASCII characters up to a 20 character string. This command is not recommended see SYSTem:APPLication .
Query | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting | non volatile, read from the test set's hard disk.
Requirements | Test or Lab Application Revision: A.01 and above


SYSTem:DATE

SYSTem:DATE

Last updated: January 16, 2009

GPIB Command Conventions

  • SYSTem:DATE

SYSTem:DATE

Function

Sets/queries the date.

Setting

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

Query

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

*RST Setting

 This feature is not affected by instrument preset

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:DATE 2001,9,27" !Sets the date to September 27,2001.

OUTPUT 714;"SYSTEM:DATE? !Returns "+2001,+9,+27" if the date has been set to September 27,2001.

Related Topics

SYSTem:UTC:DATE


SYSTem Subsystem

SYSTem Subsystem

Last updated: January 16, 2009

Description

The SYSTem subsystem collects the functions that are not related to test set performance. Examples include functions for performing general housekeeping and functions related to setting global configurations, such as TIME or CORRection (amplitude offset).

Syntax Diagrams and Command Descriptions

SYSTem:APPLication

SYSTem:AUDio

SYSTem:BEEPer
SYSTem:COMMunicate
SYSTem:CONFigure
SYSTem:CORRection
SYSTem:CURRent:TA
SYSTem:DATE
SYSTem:ERRor?
SYSTem:FATal

SYSTem:INSTrument

SYSTem:LOG

SYSTem:MEASurement:RESet
SYSTem:PRESet

SYSTem:REGister

SYSTem:ROSCillator
SYSTem:STATus (Lab Application only)
SYSTem:SYNChronized
SYSTem:TIME
SYSTem:TZONe
SYSTem:UTC


SYSTem:ERRor?

SYSTem:ERRor?

Last updated: January 16, 2009

GPIB Command Conventions

  • SYSTem:ERRor?

SYSTem:ERRor?

Function

Queries the contents of the Error/Event Queue. The Error/Event Queue may contain one or more messages with an error or event description. See Error Messages .

Manual users may view the Message Log from the SYSTEM CONFIG screen. See Error Message Log .

The contents of the Error/Event Queue and the Message Log may not match. For example, Manual User Error Messages are not returned by the SYSTem:ERRor? query, they are only viewable from the Error Message Log.
Query

Error/Event Queue

  • Range: 0 to 100 messages up to 255 characters in length

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:ERROR?" !Queries the contents of the Error/Event Queue


SYSTem:FATal

SYSTem:FATal

January 16, 2009

GPIB Command Conventions

  • SYSTem:FATal:ERRor:RESTart

SYSTem:FATal:ERRor:RESTart

Function

This command sets/queries the state of the Restart on Fatal Error parameter. See Restart on Fatal Error for more information.

Error messages that are created when a fatal error occurs are entered in the error/event queue that can be queried with the command SYSTem:ERRor? .

This is a nonvolatile setting, that is the instrument does not require a power supply to retain the setting its memory.

Setting

Range: ON|1|OFF|0

Query

Range: 1|0

*RST Setting

 0

Requirements

Test Application Revision: A.07 and above

Lab Application Revision: C.02 and above

Programming Example

OUTPUT 714;"SYSTem:FATal:ERRor:RESTart ON"
! Commands the instrument to restart if a fatal error occurs.


SYSTem:INSTrument

SYSTem:INSTrument

Last updated: January 16, 2009

GPIB Command Conventions

  • SYSTem:INSTrument:TEMPerature?
  • SYSTem:INSTrument:THERmal:POWer:NULL:ADJust?

SYSTem:INSTrument:TEMPerature?

Function

Queries the current internal operating temperature.

Query

Range: -60.0 to 100.0 (°C)

Requirements

Test Application Revision: A.13 and above

Lab Application Revision: E.01 and above

Programming Example

OUTPUT 714;"SYSTem:INSTrument:TEMPerature?"

SYSTem:INSTrument:THERmal:POWer:NULL:ADJust?

Function

Starts the Thermal Power Null Adjustment .

IMPORTANT
Ensure that your test set has warmed up at least 30 minutes and that no power is present at the front panel RF connectors before performing any calibrations.

When this adjustment has completed, a value is returned to indicate the success or failure of the adjustment. 0 indicates the adjustment completed successfully, 1 indicates that it failed.

Query

 Range: 0 (success), 1 (failure)

Requirements

Test Application Revision: A.09 and above

Lab Application Revision: C.04 and above

Programming Example

OUTPUT 714;"SYSTem:INSTrument:THERmal:POWer:NULL:ADJust?"
! Starts the Thermal Power Null Adjustment and returns a value indicating success or failure.


SYSTem:LOG

SYSTem:LOG

GPIB Command Conventions

  • SYSTem:LOG:UI:CLEAR


SYSTem:MEASurement:RESet

SYSTem:MEASurement:RESet

Last updated: January 16, 2009

GPIB Command Conventions

  • SYSTem:MEASurement:RESet

SYSTem:MEASurement:RESet

Function | Sets all measurements to abort. If continous triggering is enabled, measurements will begin a new measurement cycle.
Setting | These results are set to their default values when measurement reset occurs.
Requirements | Test or Lab Application Revision: A.01 and above


SYSTem:PRESet

SYSTem:PRESet

Last updated: January 16, 2009

GPIB Command Conventions

  • SYSTem:PRESet2
  • SYSTem:PRESet3

SYSTem:PRESet2

Function

Performs a full preset of the test set. This is the remote equivalent of pressing the SHIFT Preset keys on the front panel of the test set.

All parameters are set to their default values. All measurements are aborted the trigger arm is set to continuous. See Trigger Arm (Single or Continuous) Description .

The *RST command will set the trigger arm to single.
Related Topics See Full Preset for details about the *RST full preset.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:PRESET2" !Full preset, trigger arm set to continuous.

SYSTem:PRESet3

Function

Performs a partial preset. This is the recommended command for users when a partial preset is needed during remote operation of the test set.

Any call in process is disconnected and all measurements are aborted and inactivated. Measurement parameters are not changed.

A partial preset will not modify any measurement settings including trigger arm.

Related Topics

See Partial Preset for more details.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:PRESET3" !Partial preset when in remote operation.


SYSTem:REGister

SYSTem:REGister

Last updated: January 7, 2010

GPIB Command Conventions

  • SYSTem:REGister:SAVe
  • SYSTem:REGister:NAME
  • SYSTem:REGister:RECall
  • SYSTem:REGister:DELete

SYSTem:REGister:SAVe

Function

Saves the current test set settings to one of five available registers.

If this command is used to save to a register that is already full, the old contents of the register will be overwritten.

Setting

1|2|3|4|5

Query

No query

*RST Setting

 Not applicable

Requirements

Test Application Revision: A.03 or above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SYSTem:REGister:SAVe 1" !Saves the current test set configuration to save register 1.

SYSTem:REGister:NAME

Function

 Set/Queries the name of a specific register. The query form must include a parameter for the Register Number. The query format is as follow: SYSTem:REGister:NAME?<sp><Register Number>.

Setting

Range: two parameters separated with comma,

  • Register number: 1|2|3|4|5|6|7|8|9|10
  • Register name: any printable ASCII character, the maximum length is 20.

Query

 Register name: any printable ASCII character, the maximum length is 20.
Factory Setting "" (Null) for each register

Requirements

 Lab Application Revision: G.00.00 or above

Programming Example

OUTPUT 714;"SYSTem:REGister:NAME 1,'NOKIA TEST'" ! Set the register 1's name to "NOKIA TEST".

SYSTem:REGister:RECall

Function

Recalls a saved register from one of five registers.

If this command is used to recall a register that is empty, an error message will be displayed.

Setting

1|2|3|4|5

Query

No query

*RST Setting

 Not applicable

Requirements

Test Application Revision: A.03 or above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SYSTem:REGister:RECall 1" !Recalls register 1.

SYSTem:REGister:DELete

Function

Deletes any contents saved in the selected register.

Setting

1|2|3|4|5

Query

No query

*RST Setting

 Not applicable

Requirements

Test Application Revision: A.03 or above.

Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"SYSTem:REGister:DELete 1" !Deletes register 1.

Related Topics

Save and Recall Registers


SYSTem:ROSCillator

SYSTem:ROSCillator

Last updated: January 16, 2009

GPIB Command Conventions

  • SYSTem:ROSCillator[:TIMebase]?
  • SYSTem:ROSCillator:LOCKed?

SYSTem:ROSCillator[:TIMebase]?

Function

Queries the timebase source.

If an external timebase is used, it must have these characteristics:

  • an output level of 0 to +13 dBm

  • frequency of 10 MHz

Query

Range:

INT = internal source

EXT = external source

Requirements

Test or Lab Application Revision: A.01 and above

SYSTem:ROSCillator:LOCKed?

Function | Queries the timebase to find out if it is locked or unlocked. Returns 0 or 1.
Query | Range: 0 = unlocked 1 = locked
Requirements | Test or Lab Application Revision: A.01 and above


SYSTem:STATus

SYSTem:STATus

Last updated: February 13, 2012

This section is only applicable to the lab application and to a test application with the required feature license.

GPIB Command Conventions

  • SYSTem:STATus:COMMunicate:LAN:EPCore:CONNected[:STATe]?
  • SYSTem:STATus:COMMunicate:LAN:EPCore:CONNected:ADDRess?
  • SYSTem:STATus:COMMunicate:LAN:EXTernal[1]|2[:CONNected][:STATe]?
  • SYSTem:STATus:COMMunicate:LAN:EXTernal[1]|2[:CONNected]:ADDRess?

SYSTem:STATus:COMMunicate:LAN:EPCore:CONNected[:STATe]?

Function

 Queries the External EPC Conn Status .

Query

Range:

  • CONN - Connected
  • NCON - Not Connected

Requirements

Lab Application Revision: H.00.00 and above

Programming Example

OUTPUT 714;"SYSTem:STATus:COMMunicate:LAN:EPCore:CONNected?"
!Queries the External EPC Connection Status.

SYSTem:STATus:COMMunicate:LAN:EPCore:CONNected:ADDRess?

Function

 Queries the Connected EPC IPv4 address . See. Connected EPC IP Address .

Query

Range:

  • 0.0.0.0 to 126.255.255.255
  • 128.0.0.0 to 223.255.255.255
  • "" (Null)

Requirements

Lab Application Revision: H.00.00 and above

Programming Example

OUTPUT 714;"SYSTem:STATus:COMMunicate:LAN:EPCore:CONNected:ADDRess?"
!Queries the Connected EPC IPv4 address.

SYSTem:STATus:COMMunicate:LAN:EXTernal[1]|2[:CONNected][:STATe]?

Function

 Queries External Device Connection Status/External Device 2 Connection Status .

Query

Range:

  • CONG - Connecting
  • CONN - Connected
  • DISC - Disconnecting
  • NCON - Not Connected

Requirements

Lab Application Revision: C.01 and above

Lab Application Revision C.03, added [:CONNected] mnemonic.

Test Application Revision: A.06 and above, with the required feature license

Test Application Revision A.08.20, added [:CONNected] mnemonic.

Programming Example

OUTPUT 714;"SYSTem:STATus:COMMunicate:LAN:EXTernal?"

SYSTem:STATus:COMMunicate:LAN:EXTernal[1]|2[:CONNected]:ADDRess?

Function

 Queries the Connected Device IP Address/Connected Device 2 IP Address .

Query

Range: 15 characters formatted as follows: "A.B.C.D" where A= 0 to 126 and 128 to 223, B.C.D = 0 to 255 (no embedded spaces), "".

Requirements

Lab Application Revision: C.01 and above

Lab Application Revision C.03, :CONNected mnemonic is optional.

Test Application Revision: A.06 and above, with the required feature license

Test Application Revision A.08.20, :CONNected mnemonic is optional.

Programming Example

OUTPUT 714;"SYSTem:STATus:COMMunicate:LAN:EXTernal:ADDRess?"


SYSTem:SYNChronized

SYSTem:SYNChronized

Last updated: January 16, 2009

GPIB Command Conventions

  • SYSTem:SYNChronized

SYSTem:SYNChronized

Function | Sets/queries the test set to see that all prior sequential commands have completed or that all prior overlapped commands have started, indicating that the input buffer is synchronized.
Setting | Bit 12 of the status operation condition register is pulsed.
Query | Range: 1
Requirements | Test or Lab Application Revision: A.01 and above


SYSTem:TIME

SYSTem:TIME

Last updated: January 16, 2009

GPIB Command Conventions

  • SYSTem:TIME

SYSTem:TIME

Function

Sets/queries the local time of day.

UTC time will track changes made directly to local time settings. Also, if new settings are made to UTC time, local time will track UCT time.

Changes to time zone will cause changes to local time, but will not directly affect UTC time.

Setting

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

The resolution of local time setting is minutes. A number within the parameter range must be entered for <second> but it will not affect the minute setting.

Query

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

  • The resolution of the local time setting is minutes. The value returned for <second> will not provide useful information.

*RST Setting

 This feature is not affected by instrument preset

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:TIME 7,30,0" !Sets local time to 7:30

OUTPUT 714;"SYSTEM:TIME?" !Returns "+7,+30,+0" if local time has been set to 7:30.

Related Topics

SYSTem:UTC[:TIME]


SYSTem:TZONe

SYSTem:TZONe

Last updated: January 16, 2009

GPIB Command Conventions

  • SYSTem:TZONe

SYSTem:TZONe

Function

Sets/queries the time zone. The format of entry is hh,mm or -hh,-mm and the resolution is 15 minutes. Therefore, any entry that does not fall evenly on a 15 minute (quarter hour) boundary is rounded to the nearest 15 minutes. If -hh,mm is entered an error message is generated.

Changes to time zone will cause changes to local time, but will not directly affect UTC time.

Setting

Range: +17,+45 to -19,-45

  • <hour> -19 to 0
  • <minute> -59 to 0

or

  • <hour> 0 to 17
  • <minute> 0 to 59

Query

Range: +17,+45 to -19,-45

  • <hour> -19 to 0
  • <minute> -59 to 0

or

  • <hour> 0 to 17
  • <minute> 0 to 59

*RST Setting

 This feature is not affected by instrument preset

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:TZONe 8,0" !Sets time zone to 8 hours and 0 minutes.

OUTPUT 714;"SYSTEM:TZONe?" !Returns "+8,+0" if time zone has been set to 8 hours.

Related Topics

SYSTem:TIME


SYSTem:UTC

SYSTem:UTC

Last updated: January 16, 2009

GPIB Command Conventions

  • SYSTem:UTC[:TIME]
  • SYSTem:UTC:DATE

SYSTem:UTC[:TIME]

Function

Sets/queries the Universal Coordinated Time (UTC) time of day. (UTC is also known as UCT, Zulu, and Greenwich Mean Time.)

Local time will track UTC time settings. Also, if new settings are made to local time, UTC time will track local time.

Setting

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

The resolution of the UTC time setting is minutes. A number within the parameter range must be entered for <second> but it will not affect the minute setting.

Query

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

  • The resolution of the UTC time setting is minutes. The value returned for <second> will not provide useful information.

*RST Setting

 This feature is not affected by instrument preset

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:UTC:TIME 7,30,0" !Sets UCT time to 7:30

OUTPUT 714;"SYSTEM:UTC:TIME?" !Returns "+7,+30,+0" if UTC time has been set to 7:30.

SYSTem:UTC:DATE

Function

Sets/queries the Universal Coordinated Time (UTC) date. (UTC is also known as UCT, Zulu, and Greenwich Mean Time.)

Setting

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

Query

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

*RST Setting

 This feature is not affected by instrument preset

Requirements

 Test Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:UTC:DATE 2001,9,27" !Sets the UTC date to September 27,2001.

OUTPUT 714;"SYSTEM:UTC:DATE? !Returns "+2001,+9,+27" if the UTC date has been set to September 27,2001.

Related Topics

SYSTem:DATE


Performing Individual Measurements and 3GPP TS 34.121 Tests

Performing Individual Measurements and 3GPP TS 34.121 Tests

Last updated: September 14, 2011

NOTE
You can also download and print a pdf of this information at:

Manual Operation Guide: Making 3GPP TS 34.121 Tests Manually

(http://cp.literature.agilent.com/litweb/pdf/1000-1928.pdf)

Measurement Procedures
Measurement General Measurement Procedure 3GPP TS 34.121 Test Procedure

ACLR

How Do I Make an Adjacent Channel Leakage Ratio (ACLR) Measurement?

5.10

5.10A (lab application or feature-licensed test application only)

5.10B: Measuring 3GPP TS 34.121-1 (v8.10.0) 5.10B Adjacent Channel Leakage Ratio (ACLR) with E-DCH (lab application or feature-licensed test application only)

BLER

How Do I Make a Block Error Ratio (BLER) Measurement?

7.2.1

7.3.1: http://cp.literature.agilent.com/litweb/pdf/1000-1894.pdf

Change of TFC
(lab application only)

How Do I Make a Change of TFC (Transport Format Combination) Measurement?

5.6: Measuring 3GPP TS 34.121 5.6 Change Of TFC

Channel Power

How Do I Make a Channel Power Measurement?

5.2A (lab application or feature-licensed test application only) : Measuring 3GPP TS 34.121 5.2A Maximum Output Power with HS-DPCCH

5.2AA (lab application or feature-licensed test application only)

5.2B Measuring 3GPP TS 34.121-1 (v8.10.0) 5.2B Maximum Output Power with HS-DPCCH and E-DCH (lab application or feature-licensed test application only)

5.4.3: Measuring 3GPP TS 34.121 5.4.3 Minimum Output Power

Code Domain

How Do I Make a Code Domain Measurement?

5.2C

5.2D: Measuring 3GPP TS 34.121-1 (v8.10.0) 5.2D UE Relative Code Domain Power Accuracy for HS-DPCCH and E-DCH (lab application or feature-licensed test application only)

5.13.2A (lab application or feature-licensed test application only)

5.13.2B: Measuring 3GPP TS 34.121-1 (v8.10.0) 5.13.2B Relative Code Domain Error with HS-DPCCH and E-DCH (lab application or feature-licensed test application only)

Data Throughput Monitor
(lab application only)

How Do I Use the Data Throughput Monitor?

Dynamic Power Analysis

How Do I Make a Dynamic Power Analysis Measurement?

5.7A (lab application or feature-licensed test application only) : Measuring 3GPP TS 34.121 v7.5.0 s5.7A HS-DPCCH

Extended Range Dynamic Power

 How Do I Make an Extended Range Dynamic Power Measurement?

Fast Device Tune (lab application or feature-licensed test application only)

How Do I Make a Fast Device Tune Measurement?

HSDPA BLER (lab application or feature-licensed test application only)

How Do I Make an HSDPA Block Error Ratio Measurement?

6.3A: Measuring 3GPP TS 34.121-1 6.3A Maximum Input Level for HS-PDSCH Reception (16QAM)

6.3B: Measuring 3GPP TS 34.121-1 6.3B Maximum Input Level for HS-PDSCH Reception (64QAM)

Inner Loop Power

How Do I Make an Inner Loop Power Measurement?

5.4.2: Measuring 3GPP TS 34.121 5.4.2 Inner Loop Power Control in the Uplink

IQ Tuning

How Do I Make an IQ Tuning Measurement?

Loopback BER

How Do I Make a Loopback Bit Error Ratio (BER) Measurement?

6.2

6.3

Occupied Bandwidth

How Do I Make an Occupied Bandwidth (OBW) Measurement?

5.8

Out-of-Synch Handling of Output Power
(lab application only)

How Do I Make an Out-of-Synch Handling of Output Power Measurement?

5.4.4: Measuring 3GPP TS 34.121 5.4.4 Out-of-Synchronization Handling of Output Power

Phase Discontinuity

How Do I Make a Phase Discontinuity Measurement?

5.13.1AA (lab application or feature-licensed test application only) Measuring 3GPP TS 34.121 v7.5.0 5.13.1AA Error Vector Magnitude (EVM) and Phase Discontinuity with HS-DPCCH

5.13.3

PRACH Preamble Analysis
(lab application only)

How Do I Make a PRACH Preamble Analysis Measurement?

5.13.4

PRACH Transmit On/Off Power

How Do I Make a PRACH Transmit On/Off Power Measurement?

5.4.1: Measuring 3GPP TS 34.121 5.4.1 Open Loop Power Control in the Uplink

5.5.1: Measuring 3GPP TS 34.121 5.5.1 Transmit OFF Power

5.5.2: Measuring 3GPP TS 34.121 5.5.2 Transmit ON/OFF Time Mask

Spectrum Emission Mask

How Do I Make a Spectrum Emission Mask Measurement?

5.9

5.9A (lab application or feature-licensed test application only)

5.9B: Measuring 3GPP TS 34.121-1 (v8.10.0) 5.9B Spectrum Emission Mask with E-DCH (lab application or feature-licensed test application only)

Spectrum Monitor

How Do I Use the Spectrum Monitor?

(HSDPA) Reporting of Channel Quality Measurement

How Do I Make an HSDPA Reporting Channel Quality Indicator Measurement?

Thermal Power

How Do I Make a Thermal Power Measurement?

5.2: Measuring 3GPP TS 34.121 5.2 Maximum Output Power

TX Dynamic Power

How Do I Make a TX Dynamic Power Measurement?

9.3.1 Measuring 3GPP TS 34.121 9.3.1 Single Link Performance -AWGN Propagation Conditions

Waveform Quality

How Do I Make a Waveform Quality Measurement?

5.3: Measuring 3GPP TS 34.121 5.3 Frequency Error

5.13.1

5.13.1A (lab application or feature-licensed test application only) : Measuring 3GPP TS 34.121 v7.5.0 s5.13.1A Error Vector Magnitude (EVM) with HS-DPCCH

5.13.2

Related Topics

What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?


Audio Level Measurement Description

Audio Level Measurement Description

Last updated: January 16, 2009

How is an Audio Level measurement made?

Audio Level measures the AC voltage of the signal applied to the front-panel AUDIO IN connectors, and is one of the Audio Analyzer measurements. Audio Level can be measured for signals in the frequency range of
100 Hz to 20 kHz, at levels from 1 mV peak to 20V peak . The measurement is made after any filtering is applied, and can be made using an rms or peak detector. The type of detector being used for the measurement is displayed next to the measurement value.

When measuring very low voltages, it may be helpful to use the Audio Analyzer's adjustable bandpass filter and the rms detector to reduce noise components.

This measurement is not affected by the Amplitude Offset setting.

Related Topics

Programming an Audio Level Measurement


Adjacent Channel Leakage Ratio (ACLR) Measurement Description

Adjacent Channel Leakage Ratio (ACLR) Measurement Description

Last updated: January 16, 2009

  • How is an Adjacent Channel Leakage Ratio Measurement Made?
  • Adjacent Channel Leakage Ratio Measurement Parameters
  • Adjacent Channel Leakage Ratio Input Signal Requirements
  • Adjacent Channel Leakage Ratio Measurement Calibration

How is an Adjacent Channel Leakage Ratio Measurement Made?

Adjacent channel leakage ratio (ACLR) measures the relative power at ± 5 MHz and ± 10 MHz offsets from the uplink channel. Power is measured through a Root-Raised Cosine (RRC) filter with a rolloff of a=0.22, and a bandwidth equal to the chip rate (3.84 MHz). The ± 5 MHz measurements are referred to as the upper and lower first adjacent channels; the ± 10 MHz measurements are referred to as the upper and lower second adjacent channels. This measurement is defined in 3GPP TS 34.121, sections 5.10 and 5.10A, Adjacent Channel Power Leakage Ratio (ACLR).

Measurements for individual offsets can be turned off to increase measurement speed when these measurements are not needed.

Measurements can be displayed in either numeric or graphical form. When the graphical display is used (shown below), limits can be set for each offset to form a "limit line." When a limit is exceeded, the status changes from "Pass" to "Fail."

Adjacent Channel Leakage Ratio Measurement Parameters

  • Multi-Measurement Count: (see Statistical Measurement Results ).
  • -5 MHz Offset State
  • +5 MHz Offset State
  • -10 MHz Offset State
  • +10 MHz Offset State
  • Trigger Arm: (see Trigger Arm (Single or Continuous) Description ).
  • Trigger Source

    You must specify how you want to trigger the measurement using the Trigger Source setting.

    You may set Trigger Source to the following: (for more information on these trigger types, see Trigger Source Description ).

    • Auto: if the UE is synchronized to the test set, it uses protocol triggering; otherwise, it uses immediate triggering.

    • External

    • HS-DPCCH:

      This setting is only applicable to the lab application or a feature-licensed test application.

      When Trigger Source is set to HS-DPCCH , you can specify on which uplink subframe the measurement triggers using the HS-DPCCH Trigger Subframe Alignment setting.

      Trigger Source can only be set to HS-DPCCH when Channel Type = 12.2k RMC + HSDPA or 12.2k RMC + HSPA .

    • Immediate

    • Protocol: Derived from the 10 ms downlink DPCH frame clock.

  • Trigger Delay

    You can move the measurement interval (666.7 us = 1 timeslot) relative to the trigger using the Trigger Delay setting.

  • HS-DPCCH Trigger Subframe Alignment

    This setting is only applicable to the lab application or a feature-licensed test application.

    When Trigger Source is set to HS-DPCCH , you can specify on which uplink subframe the measurement triggers. You can then use the Trigger Delay setting to move the measurement interval (666.7 us = 1 timeslot) relative to that subframe boundary.

  • Measurement Timeout: (see Measurement Timeouts ).

Adjacent Channel Leakage Ratio Input Signal Requirements

  • For this measurement the test set's receiver uses autoranging to adjust for the level of the signal being measured; therefore, the expected signal level does not need to be specified during measurement setup.
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, 1700 MHz to 1990 MHz, or 2480 MHz to 2580 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of +5 dBm to +28 dBm, in a 3.84 MHz bandwidth.
  • The uplink must be of constant in-channel power for the duration of this measurement. This requirement has implications for correct power control configuration, and uplink dynamics in HSDPA and HSUPA.

Adjacent Channel Leakage Ratio Measurement Calibration

You must calibrate this measurement using the Calibrate Measurements procedure (see Calibrating the Test Set ).

Related Topics

  • Manual Operation: How Do I Make an Adjacent Channel Leakage Ratio (ACLR) Measurement?
  • Programming an Adjacent Channel Leakage Ratio Measurement
  • Adjacent Channel Leakage Ratio Troubleshooting
  • What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator


Audio Analyzer Block Diagram

Audio Analyzer Block Diagram

Last updated: January 16, 2009

Related Topics

Audio Analyzer Measurement Description


Audio Analyzer Measurement Description

Audio Analyzer Measurement Description

Last updated: January 16, 2009

How is an analog audio measurement made?

The Audio Analyzer can measure Audio Level (V), SINAD (dB), Distortion (%), and Audio Frequency. Measurements are made through the test set's front panel AUDIO IN connectors. When measuring a mobile's audio output, the audio signal may come from either an acoustic coupler or from a test interface connection to the mobile's audio circuitry.

See Audio Analyzer Block Diagram .

The AUDIO IN connectors feed the inputs to a floating-input differential amplifier, with each input having an impedance of about 100,000 ohms to chassis ground. For best noise immunity, connect the audio signal and its ground reference to the two input ports through shielded coaxial cables, or input the signal to the AUDIO IN HI connector and ground the AUDIO IN LO connector's center contact.

None of the analog audio measurement results are affected by the Amplitude Offset setting.

SINAD/Distortion State

Select On or Off to enable or disable the SINAD and Distortion measurements. When On, these measurement results are displayed below the Audio Level measurement and the SINAD/Distortion Fundamental Frequency must be entered to specify the audio frequency for the measurement (range: 100 Hz to 10 kHz). When Off, four dashes are displayed in place of the measurement results.

Audio Frequency State

Select On or Off to enable or disable the Audio Frequency measurement.

Filter Type

  • None - no filtering is provided (default).
  • 100 Hz BW Band Pass Filter (Tunable) - The 100 Hz BW BPF Center Frequency setting is available when this filter is selected, and can be set in the range of 300 Hz to 15 kHz.
  • C-Message
  • 50 Hz to 15 kHz
  • 300 Hz to 15 kHz

Detector Type

Select either Peak or RMS (default) for making and displaying an Audio Level measurement (does not affect other measurements). The type of detector selected is displayed next to the Audio Level measurement results. A 1-volt rms sinewave input signal would measure 1.414 V Peak when the Peak detector is used. A 1-volt peak input signal would measure 0.707 V RMS when the RMS detector is used.

Expected Peak Voltage

The Expected Amplitude sets the analog audio clipping level and must be set. This voltage is always the absolute peak audio input signal voltage expected at the AUDIO IN connectors, and must be in the range of 7.07 mV peak (5 mVrms) to 20 V peak . Remember, measuring a 1-volt rms sinewave input signal would require a 1.414 V peak expected voltage value to avoid clipping (over-driving) the input.

De-Emphasis State

Set to On or Off (default) to enable or disable 750 microsecond de-emphasis.

Expandor Reference Level

Set value from 10 mV/kHz to 10 V/kHz, or Off (default). Entering a numeric value automatically turns the state to On. Entering Off disables the expandor (state = off).

Trigger Source

Audio Analyzer measurements use immediate triggering and are continuously re-triggered by the analyzer any time the Trigger Arm parameter is set to Continuous. Trigger timing is independent of any mobile protocol signaling.

Related Topics

Audio Analyzer Block Diagram

AFANalyzer Troubleshooting

Audio Level Measurement Description

Audio Frequency Measurement Description

SINAD Measurement Description

Distortion Measurement Description

Programming an Audio Frequency Measurement

Programming an Audio Level Measurement

Programming a SINAD Measurement

Programming a Distortion Measurement

Statistical Measurement Results (Multi-measurements)


Audio Frequency Measurement Description

Audio Frequency Measurement Description

Last updated: January 16, 2009

How is an Audio Frequency measurement made?

Audio Frequency measures the frequency of the signal applied to the front-panel AUDIO IN connectors, and is one of the Audio Analyzer measurements. Audio frequency can be measured for signals in the frequency range of 100 Hz to 15 kHz, at levels from 7.1 mV peak to 20V peak, and with a signal-to-noise ratio of 30 dB or greater.

The audio frequency measurement is made after any filtering and processing are selected for the Audio Analyzer.

Related Topics

Programming an Audio Frequency Measurement


Calibrating the Test Set

Calibrating the Test Set

Last updated: January 16, 2009

Description

  • Calibration Process Requirements
  • Recommended Calibration Intervals
  • Calibration Descriptions
    • IQ Calibrations
    • Burst Mod Offset 1 Calibration
    • Thermal Power Null Adjustment
    • Digital Average Power Calibration
    • Spectrum Monitor Calibration
    • Channel Power Calibration
    • Calibrate Measurements

Various calibration routines must be run periodically to ensure measurement accuracy, source accuracy and allow the most robust demodulation of the device-under-test's signal. This document describes the various calibrations available in the test set and when they should be performed.

Calibration Process Requirements

IMPORTANT
Before performing any calibrations on your test set:

  • Ensure that the calibration is necessary - running calibrations more often than necessary wastes your time and effort, and if the calibration is performed incorrectly, could actually result in degraded test set performance.
  • Ensure that the test set is in its ambient operating environment - in other words, ensure that the test set has warmed up (at least 30 minutes) and is in a location similar to the one it will be used in. For example, if you are going to be using the test set in a racked test system, then you must calibrate the test set while it is in that test system, and all of the equipment has reached a stable operating temperature.
  • Ensure that no power is present at the front panel RF connectors - remove any cables or connectors from the RF IN/OUT and RF OUT ONLY connectors. If you are operating in a high RF environment, it is recommended that you also terminate the RF connectors with a 50 Ohm load.

Recommended Calibration Intervals

This section indicates when the test set calibrations should be performed. Procedures are given for test sets that include Option 003: Flexible Radio Link and test sets that do not. Refer to Calibration Descriptions for details about the calibrations and how to perform them.

  • Once every year you must perform a full calibration by following steps 1-7 of the Calibration Procedure for Test Sets with Option 003 (or steps 1-2 of the Calibration Procedure for Test Sets without Option 003 if your test set does not include option 003).
  • You must also perform steps 1-7 of the Calibration Procedure for Test Sets with Option 003 (or steps 1-2 of the Calibration Procedure for Test Sets without Option 003 if your test set does not include option 003) if any of the following events occur:
    • When you receive the test set, before using it for the first time (regardless of whether the test set is new, being returned from service, or on loan from a colleague).
    • After adding a new application or format to the test set.
      Note: Upgrading firmware already present in the test set does not typically require running the calibration procedures. However, when upgrading firmware, it is advisable to check the release notes for any major feature changes that require re-calibration of the test set.
    • After you perform any kind of repair or service on your test set.
  • It is recommended that once every month you perform steps 4-7 of the Calibration Procedure for Test Sets with Option 003 (or step 2 of the Calibration Procedure for Test Sets without Option 003 if your test set does not include option 003).
  • You must also perform steps 4-7 of the Calibration Procedure for Test Sets with Option 003 (or step 2 of the Calibration Procedure for Test Sets without Option 003 if your test set does not include option 003) if any of the following events occur:
    • The operating environment for your test set changes significantly (for example, the temperature changes by more than 10 degrees C or the test set is moved from a racked test system to a bench top).
    • A measurement returns integrity indicator 19 ( Uncalibrated Due to Temperature ).

IMPORTANT
Ensure that your test set has warmed up at least 30 minutes and that no power is present at the front panel RF connectors before performing any calibrations.

Calibration Procedure for Test Sets with Option 003

Calibration Procedure for Test Sets without Option 003

Calibration Descriptions

If any of the following calibrations fail, ensure that you have followed the Calibration Process Requirements and have performed the calibrations in the order prescribed by Recommended Calibration Intervals . If the calibration still fails, contact your local Agilent Sales Representative for assistance.

IQ Calibrations

When performed from a GSM/GPRS/EGPRS or AMPS/136 application or format, the First IQ Modulator calibration sends a signal from the Baseband Generator 1 module to the RF Source 1 module to optimize the phase accuracy of RF Source 1 as a function of frequency. The optimization data is then stored in the test set and accessed whenever the RF Source frequency is set. The Second IQ Modulator calibration performs a similar procedure for RF Source 2 (RF Source 2 is only present if the test set includes option 002: RF Source 2).

When performed from a W-CDMA/HSPA, cdma2000/IS-95/AMPS or 1xEV-DO application or format (which require option 003: Flexible Radio Link), the IQ calibrations perform the same phase optimizations explained above. Additionally, a signal is sent from the Flexible Radio Link Subsystem to the RF sources to calibrate phase accuracy for those alternative paths as well. This additional calibration data is written to the same calibration data file as above, but in a different area of the calibration table.

The IQ calibrations ensure that the test set accurately generates IQ-modulated signals. If the test set's IQ modulators have not been properly calibrated, the test set's output power (when producing an IQ-modulated signal) will be inaccurate, which may result in degraded receiver test results.

If you perform the IQ calibrations from a W-CDMA/HSPA, cdma2000/IS-95/AMPS or 1xEV-DO application or format, you do not need to perform them from any other application or format. However, note that if you perform the IQ calibrations from a GSM/GPRS/EGPRS or AMPS/136 application/format, you must still perform them once from a W-CDMA/HSPA, cdma2000/IS-95/AMPS or 1xEV-DO application or format.

The IQ calibrations do not need to be run frequently. See Recommended Calibration Intervals .

To initiate the IQ calibrations from the front panel, press SYSTEM CONFIG , press the right More ( 1 of 2 ) key, select Service ( F7 ), then select Cal. first IQ Modulator or Cal. second IQ Modulator . To initiate the IQ calibrations from a remote program, use the CALibration:IQ[1]|2? queries.

Each IQ calibration takes 5-6 minutes to execute.

Burst Mod Offset 1 Calibration

This calibration is only applicable to W-CDMA/HSPA, cdma2000/IS-95/AMPS, and 1xEV-DO applications and formats. This calibration is only required when using the test set to generate an AM or DSB-SC test signal (select ( F9 ) Test Signal when in CW Operating Mode ). These test signals are used for calibrating Zero Intermediate Frequency (Zero IF) devices which utilize Qualcomm's radioOne™ architecture.

You do not have to perform the Burst Mod Offset 1 calibration for each application/format in your test set; performing it from one application/format provides calibration data to all relevant applications and formats.

The Burst Mod Offset 1 calibration does not need to be run frequently. See Recommended Calibration Intervals .

The Burst Mod Offset 1 calibration calibrates the noise and signal level of RF Source 1 (as a function of frequency) to most accurately produce the AM and DSB-SC test signals required for Zero IF device calibration. The calibration is performed by generating the modulated test signals and adjusting RF Source 1 to optimize gain and minimize the noise floor. The optimization data is then stored in the test set and accessed whenever the RF Source frequency is set.

To initiate the Burst Mod Offset 1 calibration from the front panel, press SYSTEM CONFIG , press the right More ( 1 of 2 ) key, select Service ( F7 ), then select Cal. Burst Mod Offset 1 . To initiate the Burst Mod Offset 1 calibration from a remote program, use the CALibration:BMOFfset? query.

The Burst Mod Offset 1 calibration takes less than 1 minute to execute.

Thermal Power Null Adjustment

The Thermal Power Null Adjustment is only applicable to the cdma2000/IS-95/AMPS, 1xEV-DO and W-CDMA/HSPA applications/formats.

The Thermal Power Detector is calibrated at the factory and temperature controlled for stability. However, it is still possible for the auto-null circuit within the detector to drift over time. The Thermal Power Null Adjustment re-centers the auto-null circuit to provide optimum accuracy for the affected measurements.

You only need to perform the Thermal Power Null Adjustment once to re-center the auto-null circuit (you do not have to perform it from each application/format in your test set).

NOTE
Older application releases loaded on your test set may not include the Thermal Power Null Adjustment feature. Any applications that do not include the Thermal Power Null Adjustment feature (in the Utilities menu of the System Config screen) do not use the re-centering data and thus do not achieve the accuracy optimization that results from re-centering the auto-null circuit. You must upgrade those applications if you wish to achieve the accuracy optimization that results from running the Thermal Power Null Adjustment .

The Thermal Power Null Adjustment does not need to be run frequently. See Recommended Calibration Intervals .

This adjustment affects the Thermal Power (W-CDMA/HSPA) measurement, as well as all measurements that are calibrated by the Digital Average Power Calibration (cdma2000/IS-95/AMPS, 1xEV-DO) and Calibrate Measurements (W-CDMA/HSPA) routine.

To initiate the Thermal Power Null Adjustment from the front panel, press SYSTEM CONFIG , press the right More ( 1 of 2 ) key, and select Thermal Power Null Adjust ( F9 ). To initiate the Thermal Power Null Adjustment from a remote program, use the SYSTem:INSTrument:THERmal:POWer:NULL:ADJust? query.

The Thermal Power Null Adjustment takes between 30 seconds and 3 minutes.

The Thermal Power Null Adjustment can also be used to help verify your test set. See "Verifying the Test Set" in the Related Topics below.

Digital Average Power Calibration

The Digital Average Power calibration is only applicable to the cdma2000/IS-95/AMPS and 1xEV-DO applications/formats.

You do not have to perform the Digital Average Power calibration for each application/format in your test set; performing it from one application/format provides calibration data to all relevant applications and formats.

The Digital Average Power calibration does not need to be run frequently. See Recommended Calibration Intervals .

IMPORTANT
You must cycle the test set's power after the Digital Average Power calibration is complete in order to complete the calibration (the calibration data is not available to the test set until it has been restarted).

The Digital Average Power calibration generates calibration data for the Fast Power Detector for use by cdma2000/IS-95/AMPS and 1xEV-DO applications and formats. This calibration improves the accuracy of the Fast Power Detector when used to measure IS-95 and reverse RC-1 and RC-2 signals.

The calibration generates a CW signal at a given power level, measures it using the Fast Power Detector, generates a CDMA-modulated signal at the same power level, measures it using the Fast Power Detector and notes the difference. The calibration then generates a CW signal at a given power level, measures it using the Thermal Power Detector, generates a CDMA-modulated signal at the same power level, measures it using the Thermal Power Detector and notes the difference. Calibration data is then created by comparing these results. This is repeated for several power levels.

The Digital Average Power calibration provides calibration data for the following measurements:

  • Digital Average Power
  • Maximum/Minimum Power

To initiate the Digital Average Power calibration from the front panel, press Measurement selection , select Digital Average Power , then select Calibrate Digital Avg Pwr (F4) . To initiate the Digital Average Power calibration from a remote program, use the CALibration:DAPower? query.

The Digital Average Power calibration takes approximately 9 minutes to execute.

Spectrum Monitor Calibration

Performing the Spectrum Monitor calibration from one application/format does not provide calibration data to all relevant applications and formats. The calibration data files are shared as follows:

  • cdma2000/IS-95/AMPS and 1xEV-DO share the same Spectrum Monitor calibration data file.
  • W-CDMA/HSPA has its own Spectrum Monitor calibration data file.
  • GSM/GPRS/EGPRS and AMPS/136 share the same Spectrum Monitor calibration data file.

Thus, if you perform the Spectrum Monitor calibration from a 1xEV-DO application/format, you do not need to perform it from a cdma2000/IS-95/AMPS application/format. However you do still need to perform it from a W-CDMA/HSPA application/format and then again from either a GSM/GPRS/EGPRS or AMPS/136 application/format.

The Spectrum Monitor calibration should be run monthly, or whenever the test set's operating environment changes. See Recommended Calibration Intervals .

Performing the Spectrum Monitor calibration from a cdma2000/IS-95/AMPS or 1xEV-DO application/format executes the same routine as performing the Channel Power Calibration .

Performing the Spectrum Monitor calibration from a W-CDMA/HSPA application/format executes the same routine as performing the Calibrate Measurements routine.

Performing the Spectrum Monitor calibration from a GSM/GPRS/EGPRS or AMPS/136 application/format calibrates the IF signal path in the Measurement Downconverter, using a CW signal.

To initiate the Spectrum Monitor calibration from the front panel, press Instrument selection , select Spectrum Monitor , select Trigger Setup ( F4 ), then select Calibrate Measurement ( F11 ). To initiate the Spectrum Monitor calibration from a remote program, use the CALibration:SMONitor? query.

The Spectrum Monitor calibration takes between 45 seconds and 3 minutes to execute, depending upon which application/format it is executed from.

Channel Power Calibration

The Channel Power calibration is applicable to the cdma2000/IS-95/AMPS and 1xEV-DO applications/formats.

You do not have to perform the Channel Power calibration for each application/format in your test set; performing it from one application/format provides calibration data to all relevant applications and formats.

The Channel Power calibration should be run monthly, or whenever the test set's operating environment changes. See Recommended Calibration Intervals .

The Channel Power calibration calibrates the signal paths through the Measurement Downconverter and Demod Downconverter using both a CW signal and a modulated signal. The calibration is performed by comparing measured signals through the MDC and DDC to measurements made using the Fast Power Detector (which is calibrated at the factory and temperature controlled for stability). During the Calibrate Measurements calibration, the internal temperature of the test set is measured and stored with the calibration data. If the internal temperature of the test set drifts by more than +/- 10 C since the last calibration, measurements utilizing this calibration will return integrity indicator 19 ( Uncalibrated Due to Temperature ).

The Channel Power calibration provides calibration data for the following measurements:

  • Access Probe Power
  • Channel Power
  • Code Channel Time/Phase Error
  • Fast Device Tune ( lab application or feature-licensed test application only )
  • Gated Power
  • Graphical Access Probe Power ( lab application only )
  • Handoff Waveform Quality
  • Maximum/Minimum Power
  • Time Response of Open Loop Power Control
  • TX Dynamic Power
  • TX Spurious Emissions
  • Waveform Quality + Code Domain
  • Spectrum Monitor

Performing the Channel Power calibration executes the same routine as performing the Spectrum Monitor Calibration from a cdma2000/IS-95/AMPS or 1xEV-DO application/format.

To initiate the Channel Power calibration from the front panel, initiate any of the measurements listed above and select Calibrate Channel Power (F4) . To initiate the Channel Power calibration from a remote program, use the CALibration:CPOWer? query.

The Channel Power calibration takes approximately 2 minutes to execute.

Calibrate Measurements

The Calibrate Measurements routine is only applicable to W-CDMA/HSPA applications/formats.

The Calibrate Measurements routine should be run monthly, or whenever the test set's operating environment changes. See Recommended Calibration Intervals .

The Calibrate Measurements routine calibrates the signal paths through the Measurement Downconverter and Demod Downconverter using both a CW signal and a modulated signal. The calibration is performed by comparing measured signals through the MDC and DDC to measurements made using the Fast Power Detector (for CW signals) and the Thermal Power Detector (for modulated signals). Both of these detectors are calibrated at the factory and temperature controlled for stability. During the Calibrate Measurements calibration, the internal temperature of the test set is measured and stored with the calibration data. If the internal temperature of the test set drifts by more than +/- 10 C since the last calibration, measurements utilizing this calibration will return integrity indicator 19 ( Uncalibrated Due to Temperature ).

The Calibrate Measurements routine provides calibration data for the following measurements:

  • Adjacent Channel Leakage Ratio
  • Channel Power
  • Change of TFC ( lab application only )
  • Code Domain
  • Dynamic Power Analysis
  • Extended Range Dynamic Power
  • Fast Device Tune ( lab application or feature-licensed test application only )
  • Inner Loop Power
  • IQ Tuning
  • Occupied Bandwidth
  • Phase Discontinuity
  • PRACH Preamble Analysis ( lab application only )
  • PRACH Transmit On/Off Power
  • Spectrum Emission Mask
  • Spectrum Monitor
  • TX Dynamic Power
  • Waveform Quality

Performing the Calibrate Measurements routine executes the same routine as performing the Spectrum Monitor Calibration from a W-CDMA/HSPA application/format.

To initiate the Calibrate Measurements routine from the front panel, initiate any of the measurements listed above and select Calibrate Measurements (F4) . To initiate the Calibrate Measurements routine from a remote program, use the CALibration:MEASurements? query.

The Calibrate Measurements routine takes approximately 3 minutes to execute.

Related Topics

CALibration

SYSTem:INSTrument

Verifying the Test Set

Block Diagram

CW Operating Mode


Fast Device Tune Measurement Description

Fast Device Tune Measurement Description

This section is only applicable to the lab application or feature-licensed test application.

Last updated: January 16, 2009

  • How is a Fast Device Tune Measurement Made?
  • Fast Device Tune Measurement Parameters
    • Configuring the MS TX Frequency/Power Series
    • Configuring the MS RX Frequency/Power Series
    • Triggering the Fast Device Tune Measurement
    • Required Initial Conditions
  • Fast Device Tune Measurement Results
  • Fast Device Tune Input Signal Requirements
  • Calibrating the Fast Device Tune Measurement

How is a Fast Device Tune Measurement Made?

The Fast Device Tune measurement allows you to simultaneously calibrate your mobile station's transmitter (TX) output power and receiver (RX) input level across level and frequency in a single sweep (per frequency band range). The measurement is not performed with a call established between the test set and mobile station (MS). Rather, you must place your MS into a test mode which forces it to transmit a predefined series of power steps at various frequencies, and forces it to simultaneously tune its receiver to perform measurements of the test set's signal (to determine CPICH RSCP, for example) at various frequencies and power levels.

Example MS TX and MS RX Frequency/Power Series for Fast Device Tune Measurement

Before initiating the measurement, you must specify the power sequence that the MS will transmit (MS TX Power Sequence), and the frequencies at which the MS will transmit the power sequence (MS TX Frequency Sequence). You must also specify the power sequence you want the test set to transmit (MS RX Power Sequence), and the frequencies at which you want the test set to transmit the power sequence (MS RX Frequency Sequence).

Configuring the MS TX Frequency/Power Series

The MS TX Power Sequence may include up to 20 steps (of 10 ms or 20 ms duration) that span some or all of the measurement's input range (the levels can step up or down with varying magnitudes of change, as long as the first step in the sequence provides a 20 dB rise to trigger the measurement). The MS TX Frequency Sequence may include up to 20 frequencies (within one frequency band range).

The test set can measure a total of 400 power points in one measurement cycle (20 power values at 20 different frequencies). However, the measurement allows you to enter up to 40 MS TX Power Step Levels and 40 MS TX Frequency Step Values (indexed from 0 to 39). You must then use the MS TX Power Step Start Index and Number of Power Steps settings to specify which power steps comprise the MS TX Power Sequence, and the MS TX Frequency Step Start Index and Number of Frequency Steps settings to specify which frequency steps comprise the MS TX Frequency Sequence. See Frequency/Power Series Example for an example illustrating how to utilize this flexibility.

The test set uses the values in the MS TX Power Sequence and the MS TX Frequency Sequence to build the MS TX Frequency/Power Series, which drives how the test set's receiver is tuned throughout the measurement cycle. To build the MS TX Frequency/Power Series, the test set simply repeats the MS TX Power Sequence at each of the frequencies in the MS TX Frequency Sequence, and inserts a frequency re-tune step in between each repetition of the power sequence (to allow the test set and MS to re-tune to the new frequency; no measurements are performed by the test set during the frequency re-tune steps). During the frequency re-tune steps, the test set tunes its receiver to the power and frequency values required for the first step in the next power sequence. The frequency re-tune steps are the same step length as the power sequence steps (20 ms).

Before initiating the measurement, you must ensure that your MS is set to transmit the MS TX Frequency/Power Series you've set in the test set, including the frequency re-tune steps.

Configuring the MS RX Frequency/Power Series

While the test set is measuring the MS TX Power Sequence, it also transmits a MS RX Power Sequence for the MS to measure. This MS RX Power Sequence must include the same number of power steps as the MS TX Power Sequence (up to 20 steps of 10 ms or 20 ms duration). These steps can be at any power level in the test set's Cell Power output range.

The test set transmits its MS RX Power Sequence at each of the frequencies in the MS RX Frequency Sequence. The MS RX Frequency Sequence may include up to 20 frequencies within one frequency band range (which does not have to be the same frequency band range as the MS TX Frequency Sequence). The number of frequencies in the MS RX Frequency Sequence must match the number of frequency steps in the MS TX Frequency Sequence.

If you do not want the MS to measure test set power at as many power levels or frequencies as you want the test set to measure from the MS, simply place "dummy" power levels or frequencies at the end of the MS RX Power Sequence and MS RX Frequency Sequence (for example, simply repeat the final power level or frequency). You can then ignore the mobile station's measurement results for these "dummy" points. Likewise, if you need more measurement points in the MS RX Frequency/Power Series than in the MS TX Frequency/Power Series, you can place "dummy" power levels and frequencies in the MS TX Frequency/Power Series, but note that the test set will still measure and report power for these "dummy" points. You must simply ignore these results.

As with the MS TX Frequency/Power Series, the test set can transmit a total of 400 power points in one measurement cycle (20 power values at 20 different frequencies), but the measurement allows you to enter up to 40 MS RX Power Step Levels and 40 MS RX Frequency Step Values (indexed from 0 to 39). You must then use the MS RX Power Step Start Index and Number of Power Steps settings to specify which power steps comprise the MS RX Power Sequence, and the MS RX Frequency Step Start Index and Number of Frequency Steps settings to specify which frequency steps comprise the MS RX Frequency Sequence. See Frequency/Power Series Example for an example illustrating how to utilize this flexibility.

As with the MS TX Frequency/Power Series, the test set uses the values in the MS RX Power Sequence and the MS RX Frequency Sequence to build the MS RX Frequency/Power Series, which drives how the test set's generator is tuned throughout the measurement cycle. To build the MS RX Frequency/Power Series, the test set simply repeats the MS RX Power Sequence at each of the frequencies in the MS RX Frequency Sequence, and inserts a frequency re-tune step in between each repetition of the power sequence (to allow the test set and MS to re-tune to the new frequency; the MS should not perform any measurements on the test set's signal during this time, or if a measurement is performed, you should ignore the measurement results). During the frequency re-tune steps, the test set moves its generator to the power and frequency values required for the first step in the next power sequence. The frequency re-tune steps are the same step length as the power sequence steps (20 ms).

Before initiating the measurement, you must ensure that your MS is set to measure the MS RX Frequency/Power Series you've set in the test set, and that its tuning profile includes the frequency re-tune steps. Your mobile station should be configured to measure the test set's signal 5 ms after the start of each step, to allow the test set's source to settle.

To configure the downlink code channels transmitted by the test set during the MS RX Frequency/Power Series, see Downlink Channel Codes and Levels .

Frequency/Power Series Example

The test set can measure/transmit 400 power points in one measurement cycle (20 power values at 20 different frequencies). However, you can enter up to 40 power values and 40 frequencies for both the MS TX and MS RX sequences. This flexibility is present to make it more efficient for you to test different power sequences over different sets of frequencies or, more commonly, to test the same power sequence over different bands. You must load in the superset of power levels and frequency values once. Then for each measurement cycle, you simply change the start index and number of steps as needed and initiate the measurement.

For example, to measure a MS TX sequence of 14 power step levels in both the US Cellular and US PCS frequency bands:

  • MS transmit power levels (dBm): 20, 16, 12, 8, 4, 0,-4, -8, -12, -16, -20, -30, -40, -50
  • US Cellular band, frequencies (MHz): 826.4, 830.4, 834.4, 838.4, 842.4, 846.4
  • US PCS band, frequencies (MHz): 1852.4, 1856.4, 1860.4, 1864.4, 1870.4, 1874.4, 1878.4, 1882.4, 1886.4, 1890.4, 1894.4, 1898.4, 1902.4

and to transmit a MS RX sequence of 8 power step levels for the mobile station to measure:

  • Test set transmit power levels (dBm): -90, -80, -70, -60, -50, -40, -30, -20
  • US Cellular band, frequencies (MHz): 871.4, 875.4, 879.4, 883.4, 887.4, 891.4
  • US PCS band, frequencies (MHz): 1932.4, 1936.4, 1940.1, 1944.4, 1950.4, 1954.4, 1958.4, 1962.4, 1966.4, 1970.4, 1974.4, 1978.4, 1982.4

for multiple US Cellular/US PCS mobile stations, set the following:

  1. MS TX Power Step Levels = 20, 16, 12, 8, 4, 0,-4, -8, -12, -16, -20, -30, -40, -50
    MS RX Power Step Levels = -90, -80, -70, -60, -50, -40, -30, -20, -75, -75, -75, -75, -75, -75 (note that the last six values are "dummy" values required so that there are an equal number of power steps in the MS TX and MS RX sequences)
    MS TX Frequency Step Values = 826.4, 830.4, 834.4, 838.4, 842.4, 846.4, 1852.4, 1856.4, 1860.4, 1864.4, 1870.4, 1874.4, 1878.4, 1882.4, 1886.4, 1890.4, 1894.4, 1898.4, 1902.4
    MS RX Frequency Step Values = 871.4, 875.4, 879.4, 883.4, 887.4, 891.4, 1932.4, 1936.4, 1940.1, 1944.4, 1950.4, 1954.4, 1958.4, 1962.4, 1966.4, 1970.4, 1974.4, 1978.4, 1982.4
  2. MS TX Power Step Start Index = 0
    MS RX Power Step Start Index = 0
    Number of Power Steps = 14
  3. Mobile station #1:
    • MS TX Frequency Step Start Index = 0
      MS RX Frequency Step Start Index = 0
      Number of Frequency Steps = 6
      Initiate the measurement, query INITiate:CFDTune:ARMed?, fetch the results
    • MS TX Frequency Step Start Index = 6
      MS RX Frequency Step Start Index = 6
      Number of Frequency Steps = 13
      Initiate the measurement, query INITiate:CFDTune:ARMed?, fetch the results
  4. Mobile station #2: repeat step 3
  5. Mobile station #3: repeat step 3
  6. ...

Triggering the Fast Device Tune Measurement

The MS must trigger the measurement with a positive change in power of at least 20 dB (the mobile station's power must rise from 20 dB below the level of the first step in the MS TX Power Sequence to within 9 dB of the level of the first step).

To ensure successful triggering, it is recommended that you do the following:

  1. Order the MS to transmit continuously at >20 dB below the power level of the first step in the MS TX Power Sequence.
    Note: If your MS TX Power Sequence starts at a power level that is less than 20 dB above the minimum transmit power of your MS, then you must include a trigger pulse as the first step in the MS TX Power Sequence. The power level of this trigger pulse will be measured by the test set as one of the steps in the sequence.
  2. Initiate the Fast Device Tune measurement (this prepares the test set's hardware to execute the frequency/power series you've specified and arms the measurement's RF rise trigger).
  3. Send the INITiate:CFDTune:ARMed? query and wait for it to return a value of 1 , indicating that the measurement is armed and ready to be triggered (or wait ~2 seconds if running the measurement from the front panel).
  4. Order the MS to begin transmission of its MS TX Frequency/Power Series (the MS should then increase its output power by more than 20 dB to reach the first step in the series, which triggers the measurement with an RF rise).

Once triggered, the Fast Device Tune measurement performs a series of channel power measurements, one near the center of each step of the MS TX Power Sequence (while simultaneously transmitting the MS RX Power Sequence you've specified), then repeats the measurements at the next specified MS TX frequency (while simultaneously transmitting the MS RX Power Sequence at the next specified MS RX frequency). The test set tunes its receiver for each step according to the power levels you've specified for the MS TX Power Sequence. The MS must step its power according to the MS TX Power Sequence (and be within +/- 9 dB of the expected power level for each step) and hold its power constant for the duration of the measurement interval (666.7 us, 6.3 ms after the start of each 20 ms step, or 3.15 ms after the start of each 10 ms step.). After completing a measurement at each step of the MS TX Frequency/Power Series, the measurement returns power results for all of the measured steps.

Required Initial Conditions

  • Operating Mode must be set to FDD Test .
  • Channel Type must be set to one of the Symmetrical RMCs (Note, this measurement is not supported on HSDPA or HSPA connections.)
  • Power Control must be set to Manual .
  • Measurement Frequency must be set to manual control.
    To set Measurement Frequency to manual control from the front panel, press the OFF/MANUAL key. This sets Measurement Frequency to the last frequency value that this parameter was set to. The Fast Device Tune measurement ignores the specific value that Measurement Frequency is set to, so it can be set to any supported input frequency; the measurement simply requires that Measurement Frequency be in manual control mode.
  • RF Gen Freq Ctrl must be set to Manual .
  • AWGN Power must be Off .
  • This measurement is not supported on a faded channel ( lab application only , see Digital Bus Information ). ALC Mode must be set to Closed Loop before initiating the measurement.
  • You must configure the MS TX Frequency/Power Series to match the pattern of power levels to be transmitted by the MS and configure the MS RX Frequency/Power Series to match the pattern of power levels to be measured by the MS.

Operating Considerations

The Fast Device Tune measurement must re-range and re-trigger for every step in the MS TX Power Sequence. To ensure that this process is not interrupted by other operations, it is recommended that you not send any GPIB commands to the test set or press any front panel keys until the measurement has completed. If the measurement misses a trigger, it aborts and returns Integrity Indicator 30 : Missed Trigger .

No other measurements can be running when a Fast Device Tune measurement is performed. If any measurements are running when a Fast Device Tune measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while a Fast Device Tune measurement is running, the Fast Device Tune measurement is closed and a message is displayed.

Measurement results (and the RF generator output level) are affected by any RF IN/OUT Amplitude Offsets that are entered (see Amplitude Offset ).

Fast Device Tune Measurement Parameters

Fast Device Tune Setup

  • Measurement Timeout

    See Measurement Timeouts . Ensure that you set the Measurement Timeout to a value great enough to allow you to command the MS to transmit its MS TX Frequency/Power Series and for the test set to measure the MS TX Frequency/Power Series. For example, measuring the maximum allowable number of 400 power points can take more than 10 seconds (400 steps plus the 19 re-tune steps: 419 x 20 ms = 8.4 seconds, plus ~ 2 seconds required for the measurement to prepare for triggering).

    GPIB command: SETup:CFDTune:TIMeout[:STIMe]

  • MS TX Power Step Start Index

    Indicates which of the MS TX Power Step Levels is the first step in the MS TX Power Sequence.

    This parameter can be set to any integer value between 0 and 39. However, MS TX Power Step Start Index + Number of Power Steps must not exceed 40.

    Also, you must ensure that the range of values selected by MS TX Power Step Start Index and Number of Power Steps do not include any NANs (9.91E+37) or values that are outside of the input range for the current application format (considering the amplitude offset settings).

    GPIB command: SETup:CFDTune:MS:TX:POWer:STEP:STARt:[INDex]

  • MS TX Frequency Step Start Index

    Indicates which of the MS TX Frequency Step Values is the first frequency in the MS TX Frequency Sequence.

    This parameter can be set to any integer value between 0 and 39. However, MS TX Frequency Step Start Index + Number of Frequency Steps must not exceed 40.

    Also, the frequencies indicated by MS TX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range (and must not include any NANs (9.91E+37)).

    GPIB command: SETup:CFDTune:MS:TX:FREQuency:STEP:STARt:[INDex]

  • MS RX Power Step Start Index

    Indicates which of the MS RX Power Step Levels is the first step in the MS RX Power Sequence.

    This parameter can be set to any integer value between 0 and 39. However, MS RX Power Step Start Index + Number of Power Steps must not exceed 40.

    Also, you must ensure that the range of values selected by MS RX Power Step Start Index and Number of Power Steps do not include any NANs (9.91E+37) or values that are outside of the output range for the current application format (considering the amplitude offset settings).

    GPIB command: SETup:CFDTune:MS:RX:POWer:STEP:STARt:[INDex]

  • MS RX Frequency Step Start Index

    Indicates which of the MS RX Frequency Step Values is the first frequency in the MS RX Frequency Sequence.

    This parameter can be set to any integer value between 0 and 39. However, MS RX Frequency Step Start Index + Number of Frequency Steps must not exceed 40.

    Also, the frequencies indicated by MS RX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range (and must not include any NANs (9.91E+37)).

    GPIB command: SETup:CFDTune:MS:RX:FREQuency:STEP:STARt:[INDex]

  • Number of Power Steps

    Indicates how many (consecutive) MS TX Power Step Levels are used for the MS TX Power Sequence, and how many (consecutive) MS RX Power Step Levels are used for the MS RX Power Sequence.

    This parameter can be set to any integer value between 1 and 20, but MS TX Power Step Start Index + Number of Power Steps and MS RX Power Step Start Index + Number of Power Steps must not exceed 40.

    Also, you must ensure that the range of power values selected by MS TX Power Step Start Index, MS RX Power Step Start Index and Number of Power Steps do not include any NANs (9.91E+37) or values that are outside of the input or output ranges for the current application format (considering the amplitude offset settings).

    GPIB command: SETup:CFDTune:POWer:STEP:COUNt

  • Number of Frequency Steps

    Indicates how many (consecutive) MS TX Frequency Step Values are used for the MS TX Frequency Sequence, and how many (consecutive) MS RX Frequency Step Values are used for the MS RX Frequency Sequence.

    This parameter can be set to any integer value between 1 and 20, but MS TX Frequency Step Start Index + Number of Frequency Steps and MS RX Frequency Step Start Index + Number of Frequency Steps must not exceed 40.

    Note that the frequencies indicated by MS TX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range. Likewise, the frequencies indicated by MS RX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range, but do not have to be in the same frequency band range as the MS TX Frequency Sequence. Ensure that none of the frequency values you've selected are NANs (9.91E+37)).

    GPIB command: SETup:CFDTune:FREQuency:STEP:COUNt

Fast Device Tune MS TX/RX Parameters

  • MS TX Power Step Levels

    You can specify up to 40 mobile station output power levels (indexed from 0 up to 39). You must use the MS TX Power Step Start Index and Number of Power Steps settings to specify which of these (consecutive) power levels (up to 20) are used for the MS TX Power Sequence.

    Although you can enter any power levels between -129 and +80 dBm (because this measurement is common to the W-CDMA/HSDPA, 1xEV-DO and cdma2000 formats), when running the Fast Device Tune measurement in the W-CDMA/HSDPA application/format, you can only measure power levels in the range of -70 to +30 dBm and the measurement is only specified for power levels in the range of -61 to +28 dBm (these ranges assume an amplitude offset of 0; the ranges change as you change amplitude offsets, see Amplitude Offset ).

    GPIB command: SETup:CFDTune:MS:TX:POWer:STEP[:LEVels]

  • MS TX Frequency Step Values

    You can specify up to 40 mobile station uplink frequencies (indexed from 0 up to 39). You must use the MS TX Frequency Step Start Index and Number of Frequency Steps settings to specify which of these (consecutive) frequencies (up to 20) are used for the MS TX Frequency Sequence.

    Although you can enter any frequencies between 411 and 1980 MHz, when running the Fast Device Tune measurement in the W-CDMA/HSDPA application/format, you can only test frequencies within a single W-CDMA/HSDPA frequency band range:

    • 693 to 803 MHz (Bands XII, XIII, and XIV)
    • 819 to 854 MHz (Bands V and VI)
    • 875 to 920 MHz (Band VIII)
    • 1423 to 1458 MHz (Band XI)
    • 1705 to 1790 MHz (Bands III, IV, IX, and X)
    • 1845 to 1915 MHz (Band II)
    • 1915 to 1985 (Band I)
    • 2495 to 2575 MHz (Band VII)

    GPIB command: SETup:CFDTune:MS:TX:FREQuency:STEP[:VALues]

  • MS RX Power Step Levels

    You can specify up to 40 test set output power levels (indexed from 0 up to 39). You must use the MS RX Power Step Start Index and Number of Power Steps settings to specify which of these (consecutive) power levels (up to 20) are used for the MS RX Power Sequence.

    Although you can enter any power levels between -165 and 37 dBm, when running the Fast Device Tune measurement in the W-CDMA/HSDPA application/format, the test set can only transmit test power levels in the range of -109 to -15 dBm ( RF IN/OUT ) or -109 to -7 dBm ( RF OUT ONLY ). These ranges assume an amplitude offset of 0; the allowable ranges change as you change amplitude offsets, see Cell Power, AWGN Power and Total RF Power Ranges .

    GPIB command: SETup:CFDTune:MS:RX:POWer:STEP[:LEVels]

  • MS RX Frequency Step Values

    You can specify up to 40 test set downlink frequencies (indexed from 0 up to 39). You must use the MS RX Frequency Step Start Index and Number of Frequency Steps settings to specify which of these (consecutive) frequencies (up to 20) are used for the MS RX Frequency Sequence.

    Although you can enter any frequencies between 421 and 2170 MHz, when running the Fast Device Tune measurement in the W-CDMA/HSDPA application/format, you can only test frequencies within a single W-CDMA/HSDPA frequency band range:

    • 723 to 773 MHz (Bands XII, XIII, and XIV)
    • 864 to 899 MHz (Bands V and VI)
    • 920 to 965 MHz (Band VIII)
    • 1471 to 1506 MHz (Band XI)
    • 1800 to 1885 MHz (Bands III and IX)
    • 1925 to 1995 MHz (Band II)
    • 2105 to 2175 (Bands I, IV, and X)
    • 2615 to 2695 MHz (Band VII)

    GPIB command: SETup:CFDTune:MS:RX:FREQuency:STEP[:VALues]

Fast Device Tune Measurement Results

The Fast Device Tune measurement results are currently only available via GPIB command (see FETCh:CFDTune ). Measurement results are not available on the front panel screen.

  • Integrity Indicator
  • Power

    The test set performs a channel power measurement near the center of each step (7 ms after the start of the step), with a measurement interval of 666.7 us (1 timeslot) and the RRC Filter off. Power (dBm/5 MHz) is returned for each step in the MS TX Frequency/Power Series (except for the frequency re-tune steps). The total number of results returned by the measurement is always 400 ( Number of Power Steps x Number of Frequency Steps power result values are returned, followed by 9.91E+37 (NAN) for all remaining values up to 400). The power results for the first frequency in the MS TX Frequency Sequence are returned first, then the power results for the second frequency in the MS TX Frequency Sequence, etc., followed by NANs if fewer than 400 points were measured.

Note that the test set does not report the mobile station's measurement results (for example, CPICH RSCP). You must capture the mobile station's measurement results so that you can compare its measurements with the test set's actual transmission levels.

Fast Device Tune Input Signal Requirements

The Fast Device Tune measurement meets specifications when the following input signal requirements are met:

  • Frequency: 800 to 1000 MHz, 1400 to 1500 MHz, 1700 to 1990 MHz, and 2480 to 2580 MHz
  • Input level: -61 dBm to +28 dBm (the measurement can accept power within the range of -70 dBm to +30 dBm)

Calibrating the Fast Device Tune Measurement

You must calibrate this measurement using the Calibrate Measurements procedure (see Calibrating the Test Set ).

Related Topics

Programming a Fast Device Tune Measurement

How Do I Make a Fast Device Tune Measurement?

Fast Device Tune Troubleshooting

Channel Power Measurement Description

Receiver Control


Channel Power Measurement Description

Channel Power Measurement Description

Last updated: January 16, 2009

  • How is a Channel Power Measurement Made?
  • Channel Power Measurement Parameters
  • Channel Power Measurement Results
  • Channel Power Input Signal Requirements
  • Channel Power Measurement Calibration

How is a Channel Power Measurement Made?

The channel power measurement is made on the RF input signal after frequency downconversion and an analog to digital conversion (see Block Diagram ). The actual power measurement is performed by the test set's digital signal processor (DSP).

Differences between the Channel Power and Thermal Power Measurements

When the RRC Filter for the channel power measurement is turned on, the results are typically about 0.25 dB lower than the thermal power measurement results.

Thermal power performance is only specified for signals down to -10 dBm, while the channel power measurement is able to accurately measure signals down to -61 dBm.

Triggering the Channel Power Measurement

You must specify how you want to trigger the channel power measurement using the Trigger Source setting. You must also specify the Measurement Interval and may then choose to move the Measurement Interval relative to the trigger using the Trigger Delay setting.

For example ( for lab applications or feature-licensed test applications only ), given the following example power profile, to align the measurement trigger to measure the power level of the ACK portion of the HS-DPCCH signal (excluding the 25 us transient periods on either side of the slot boundaries), set Trigger Source to HS-DPCCH , set HS-DPCCH Trigger Subframe Alignment to 0 , set Measurement Interval to 616.7 us and set Trigger Delay to 25 us . To measure the power level of the statDTX, simply change HS-DPCCH Trigger Subframe Alignment to 3.

Channel Power Measurement Parameters

  • Multi-Measurement Count: (see Statistical Measurement Results ).

  • RRC Filter

    The signal can be filtered in the DSP with a root-raised cosine (RRC) filter with a rolloff of 0.22 and a bandwidth equal to the chip rate (3.84 MHz) to comply with 3GPP 34.121 conformance specifications that require RRC filtered power. The filter can also be turned off for conformance specifications requiring a mean power measurement. When the RRC filter is Off , the bandwidth of the channel power measurement is greater than (1+alpha) times the chiprate, where alpha=0.22.

  • Trigger Arm: (see Trigger Arm (Single or Continuous) Description ).

  • Trigger Source

    You may set Trigger Source to the following: (for more information on these trigger types, see Trigger Source Description ).

    • Auto: if the UE is synchronized to the test set, it uses protocol triggering; otherwise, it uses immediate triggering.

    • External

    • HS-DPCCH:

      This setting is only applicable to the lab application or a feature-licensed test application.

      When Trigger Source is set to HS-DPCCH , you can specify on which uplink subframe the measurement triggers using the HS-DPCCH Trigger Subframe Alignment setting.

      Trigger Source can only be set to HS-DPCCH when Channel Type = 12.2k RMC + HSDPA or 12.2k RMC + HSPA .

    • Immediate

    • Protocol: Derived from the 10 ms downlink DPCH frame clock.

    • RF Rise: RF Rise triggering can be used to measure power during PRACH bursts. The burst's on state level must be >-40 dBm and the off state level must be <-60 dBm for this trigger to work correctly.
  • Trigger Delay

    You can move the Measurement Interval relative to the measurement trigger using the Trigger Delay setting. See Triggering the Channel Power Measurement .

  • Measurement Interval

    This measurement can be made over a period of 10 us to 12 ms (the default is 1 timeslot or 666.7 us) by altering the Measurement Interval .

  • Auto Range

    When Auto Range is set to on, the test set automatically determines the expected power level from the UE before performing a channel power measurement. However, note that the measurement takes longer to execute when Auto Range is set to on. Also, the UE's output power must be stable in order for the autoranging algorithm to operate properly.

    When Auto Range is set to off, you must specify the expected power level from the UE as described in Manual Power Range Offset .

  • Manual Power Range Offset

    This setting is only applicable when Auto Range is off.

    When Auto Range is off, the test set uses the UE Target Power setting (for automatic receiver power control) or the Manual Power setting (for manual receiver power control; see Receiver Control ) to determine the expected power level from the UE. However, the UE Target Power setting (or Manual Power setting) only drives the DPCCH+DPDCH power level of the UE. When HS-DPCCH, E-DPCCH and/or E-DPDCH channels are present, the actual output power of the UE is greater than the UE Target Power setting. Thus when Auto Range is off, you must specify how much additional power is in the UE's signal due to the HSDPA and HSUPA channels (using the Manual Power Range Offset setting) to avoid an over range error.

    Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH = 10log 10 (Beta c ^2 + Beta d ^2 + Beta hs ^2 + Beta ec ^2 + Beta ed ^2) - 10log 10 (Beta d ^2 + Beta c ^2). For example, for 34.121 v7.5.0 Table C.11.1.3 sub-test 1, Power Change Due to HS-DPCCH, E-DPCCH and E-DPDCH = 14 dB. Thus, Manual Power Range Offset should be set to 14 dB for sub-test 1 when Auto Range is off. Manual Power Range Offset should be set as follows for the other sub-tests - sub-test 2: 5 dB, sub-test 3: 13 dB, sub-test 4: 2 dB, sub-test 5: 16 dB.

  • Measurement Timeout: (see Measurement Timeouts ).

  • HS-DPCCH Trigger Subframe Alignment

    This setting is only applicable to the lab application or a feature-licensed test application.

    When Trigger Source is set to HS-DPCCH , you can specify on which uplink subframe the measurement triggers. You can then use the Trigger Delay setting to move the Measurement Interval relative to that subframe boundary. See Triggering the Channel Power Measurement .

  • RMSCubed State

    This setting is only available via GPIB command ( SETup:WCPower:RMSCubed:STATe ). This setting determines whether the RMSCubed measurement result is available.

Channel Power Measurement Results

  • Integrity Indicator
  • Channel Power (in dBm)
  • RMSCubed

    This result is only available when RMSCubed State is set to on, and is only available via GPIB command. This result returns the root mean square of the cubic normalized voltage waveform (20log 10 ((v_norm 3 ) rms )), to aid in the calculation of CM (Cubic Metric) and MPR (Maximum Power Reduction) as defined in 3GPP TS 25.101 s6.2.2.

Channel Power Input Signal Requirements

  • If Auto Range is set to off, you must set the expected power level from the UE as described in Manual Power Range Offset .
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, 1700 MHz to 1990 MHz, or 2480 MHz to 2580 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of -61 dBm to +28 dBm, measured in a 3.84 MHz bandwidth.

Channel Power Measurement Calibration

You must calibrate this measurement using the Calibrate Measurements procedure (see Calibrating the Test Set ).

Related Topics

  • Manual Operation: How Do I Make a Channel Power Measurement?
  • Programming a Channel Power Measurement
  • Channel Power Troubleshooting
  • What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator


Code Domain Measurement Description

Code Domain Measurement Description

Last updated: January 16, 2009

  • How is a Code Domain Measurement Made?
    • Measurement Interval in Non-HSDPA Mode
    • Measurement Interval in HSDPA Mode ( lab application or feature-licensed test application only )
  • Code Domain Measurement Parameters
    • HSDPA Measurement Parameters ( lab application or feature-licensed test application only )
  • Code Domain Measurement Results
  • Code Domain Input Signal Requirements
  • Code Domain Measurement Calibration

How is a Code Domain Measurement Made?

Code domain power (CDP) is an analysis of the distribution of signal power projected on a code-space of a particular dimension, normalized to the total signal power. To analyze the composite waveform, each channel is decoded using a code-correlation algorithm. This algorithm determines the correlation coefficient for each code. Once the channels are decoded, the power in each code channel is determined.

Code domain error (CDE) measurements are made by sampling the down-converted input signal, then applying DSP (Digital Signal Processing) techniques to determine the original data input to the UE transmitter's OVSF code spreading function for each channel. The DSP uses the original data and coding to generate a representation of the original waveform. This is the reference waveform for the code domain error measurements.

CDE is determined by comparing the reference waveform with the waveform being measured to determine the error vector. The error vector is projected onto the code domain at the same spreading factor used to determine CDP. The error vector for each power code is defined as the ratio to the mean power of the reference waveform expressed in dB.

Measurement Interval in Non-HSDPA Mode

When on a non-HSDPA connection, you must set Trigger Source to any value other than HS-DPCCH . When operating in this mode, the measurement is made during one timeslot (666.7 us). You can choose in which timeslot of the W-CDMA frame the measurement is performed using the Timeslot setting.

Timeslot Setting

Measurement Interval in HSDPA Mode

This section is only applicable to the lab application or feature-licensed test application .

To measure code domain on an HSDPA connection, you must set Trigger Source to HS-DPCCH . When Trigger Source is set to HS-DPCCH, you can specify the measurement interval and its placement within any of the 6 HSDPA subframes.

  1. Use the HS-DPCCH Trigger Subframe Alignment setting to choose in which 2 ms subframe (0 to 5) you want to place the measurement interval.
  2. Use the HS-DPCCH Trigger Slot Alignment setting to specify in which slot within the subframe you want to place the measurement interval ( AckNack = the first slot of the subframe, CQI1 = the second slot of the subframe and CQI2 = the third slot of the subframe).
  3. Set the duration of the measurement interval using the HS-DPCCH Measurement Interval setting. Note that the sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval cannot exceed 1.0 slot.
  4. Use the HS-DPCCH Trigger Subslot Alignment setting to specify where you want to place the measurement interval within the slot. You can place the measurement interval at the slot boundary, 0.1 slot (66.7 us) after the slot boundary, 0.2 slot (133.3 us) after the slot boundary... up to 0.5 slot (333.3 us) after the slot boundary. Note, however, that the sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval cannot exceed 1.0 slot. If you wish to place the measurement interval after the slot boundary using the HS-DPCCH Trigger Subslot Alignment setting, you must first decrease the HS-DPCCH Measurement Interval setting appropriately.
  5. You can choose to shorten the measurement interval so as to exclude the 25 us (96 chip) transient periods at the start and end of the measurement interval using the Transient Period setting. For example, if you set HS-DPCCH Measurement Interval to 0.5 slot (333.3 us or 1280 chips) and set Transient Period to Exclude , the measurement is performed over 283.3 us (or 1088 chips).

Measurement Interval Duration and Placement for HSDPA

Code Domain Measurement Parameters

  • Timeslot

    When Trigger Source is set to any value other than HS-DPCCH , you can specify which timeslot of the W-CDMA frame (0 to 14) is evaluated by the code domain measurement. See Measurement Interval in Non-HSDPA Mode .

  • Trigger Arm: see Trigger Arm (Single or Continuous) Description .
  • Trigger Source

    Triggering choices are immediate, protocol, external, auto, HS-DPCCH and Even Frame.

    Auto triggering is the default choice. In most cases, auto triggering provides the optimum measurement triggering condition for the code domain measurement. For example, if the UE is synchronized to the test set, auto triggering causes protocol triggering to be used. Auto triggering causes immediate triggering is used if the UE is not synchronized. When immediate triggering is used, the measurement result returned for timing error is always NAN (Not a Number) because it is not possible to evaluate a timing error in this measurement situation. See Trigger Source Description for more information.

    HS-DPCCH ( lab application or feature-licensed test application only ): This Trigger Source is only available while on an HSDPA connection. See Trigger Source Description .

    Even Frame ( lab application or feature-licensed test application only ): This Trigger Source is only available while on an HSPA connection. When Trigger Source is set to Even Frame , the measurement triggers every 20 ms, in alignment with the 10 ms system frame clock. Whether the trigger occurs on odd-SFN or even-SFN frames is determined by the SFN Alignment setting.

  • Measurement Timeout: see Measurement Timeouts .
  • SFN Alignment

    When Trigger Source is set to Even Frame , this setting determines whether the trigger occurs on odd-SFN or even-SFN frames.

HSDPA Measurement Parameters

This section is only applicable to the lab application or feature-licensed test application .

These settings are only applicable when Trigger Source = HS-DPCCH .

See Measurement Interval in HSDPA Mode for more information about using these parameters to specify the duration and placement of the measurement interval.

  • Transient Period

    When Transient Period is set to Include , the measurement is performed over the interval specified by the HS-DPCCH Measurement Interval setting.

    When Transient Period is set to Exclude , the 25 us at the start of the measurement interval and the 25 us at the end of the measurement interval are excluded from the measurement. Thus, the measurement is performed over an interval equal to HS-DPCCH Measurement Interval minus 50 us. See Measurement Interval in HSDPA Mode .

  • HS-DPCCH Trigger Subframe Alignment

    Selects which 2 ms subframe (0 to 5) contains the measurement interval.

  • HS-DPCCH Trigger Slot Alignment

    Selects which slot in the 2 ms subframe contains the measurement interval ( AckNack = the first slot in the subframe, CQI1 = the second slot in the subframe and CQI2 = the third slot in the subframe).

  • HS-DPCCH Measurement Interval

    See Measurement Interval in HSDPA Mode .

    Note, the sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval cannot exceed 1.0 slot.

  • HS-DPCCH Trigger Subslot Alignment

    Selects where to place the measurement interval within the slot, in 0.1 slot (66.7 us) increments. This is useful because depending upon the Current DPCH Offset , the uplink DPCH and HS-DPCCH can be offset in time by increments of 0.1 slot (see HS-DPCCH/DPCCH Alignment vs. DPCH Frame Offset ).

    Note, the sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval cannot exceed 1.0 slot.

Code Domain Measurement Results

  • Graph of Code Domain Power and Code Domain Error results.
    • The x axis always has a resolution of 256 codes (SF=256).
    • The CDP and CDE are computed in the correct spreading factor for the DPCCH and DPDCH as defined for the channel type used. For example, in the graph below the 64k RMC is used. Therefore, the DPDCH occupies C ch,16,4 as defined in the 3GPP standards. (C ch,Spreading Factor,Code Number )
  • Code Domain Power (CDP)

    CDP is the ratio of the measured code domain power to the total power of the input signal.

  • Code Domain Error (CDE)

    CDE is the ratio of the mean power of the error vector projection onto the code to the mean power of the composite reference waveform. See 3GPP TS 25.101 s6.8.3.

  • Relative Code Domain Error (RCDE)

    RCDE is computed by projecting the error vector onto the code domain. The RCDE for every non-zero beta code in the domain is defined as the ratio of the mean power of the error vector projection onto the non-zero beta code, to the mean power of the non-zero beta code in the composite reference waveform. RCDE is available for the active code channels only (code channels with non-zero beta values in the composite reference waveform). See 3GPP TS 34.121 s5.13.2A.

  • Relative Code Domain Power Accuracy (RCDPA)

    RCDPA is a measure of the UE's ability to correctly set the level of individual code powers relative to the total power of all active codes. RCDPA is available for the active code channels only (code channels with non-zero beta values in the composite reference waveform). RCDPA is defined as the difference between the Measured CDP ratio and the NCDP ratio. Note that the Measured CDP ratio = 10*log 10 ((Measured code power)/(Measured total power of all active codes)), which is not the same as the Code Domain Power (CDP) result (which is relative to the total power of the input signal). See 3GPP TS 25.101 s6.2.3.

  • Nominal Code Domain Power (NCDP)

    NCDP is the ratio of nominal code domain power to the sum of all nominal code domain powers. NCDP is available for the active code channels only (code channels with non-zero beta values in the composite reference waveform). See 3GPP TS 25.101 s6.2.3.

  • Effective Code Domain Power (ECDP)

    ECDP k = (Measured CDP) k + 10*log 10 (SF k /256), where k represents the active code channel on which the ECDP is calculated. ECDP is available for the active code channels only (code channels with non-zero beta values in the composite reference waveform). See 3GPP TS 25.101 s6.8.3.

  • All of the measurement results of the Waveform Quality measurement. Waveform Quality Measurement Results
  • Beta ec , Beta ed1 , Beta ed2

    Beta ec , Beta ed1 , Beta ed2 provide results (other than NaN) when on an HSPA connection ( lab application or feature-licensed test application only ).

Code Domain Input Signal Requirements

  • For this measurement the test set's receiver uses auto-ranging to adjust for the level of the signal being measured; therefore the expected signal level does not need to be specified during measurement setup. However, it is recommended that Expected Power be configured to match the actual signal level expected to ensure the auto-ranging procedure executes as quickly as possible.
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, or from 1700 MHz to 1990 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of +5 dBm to +28 dBm, in a 3.84 MHz bandwidth.
  • Maximum measurable EVM = 35%
  • Maximum measurable frequency error = ± 1 kHz
  • Maximum measurable timing error = +/- 50 chips

Code Domain Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function ( CALibration:MEASurements? ) when the temperature has changed by ± 10° C or more since the last calibration. If this situation exists, the integrity indicator value becomes 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

  • Manual Operation: How Do I Make a Code Domain Measurement?
  • Programming a Code Domain Measurement
  • Code Domain Troubleshooting
  • What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator


Distortion Measurement Description

Distortion Measurement Description

Last updated: January 16, 2009

How is a Distortion measurement made?

Distortion is an audio quality measurement that compares the audio signal level from the mobile at a specified (desired) frequency to the level of signals present at other frequencies. The audio signals from the mobile are typically measured after digital demodulation of the traffic channel.

The test set makes two measurements to determine distortion. First, the test set measures the total audio signal level into the Audio Analyzer. Next, a precise notch filter is then used to remove the signal at the specified frequency. The remaining signal level indicates the level of unwanted signals (distortion). Distortion is expressed as a percentage of the total audio signal.

Distortion can be measured in the range of 100 Hz to 10 kHz. For information on using the Audio Analyzer, see Audio Analyzer Measurement Description .

The distortion measurement can be used to perform the audio harmonic distortion test. For example, in the AMPS system two audio signals are used: a 1004 Hz tone and the 6000 Hz SAT. The 1004 Hz tone is notched out to make the measurement.

Related Topics

Audio Analyzer Measurement Description


Data Throughput Monitor Description

Data Throughput Monitor Description

Last updated: January 6, 2012

This section is only applicable to the lab application.

Description

What is Data Throughput?

The Data Throughput Monitor can analyze data transfer rates under various RF and call processing conditions. You can initiate the Data Throughput Monitor by pressing the Instrument selection key. It is displayed on the Measurement/Instrument screen (accessible using the MEASUREMENT key).

Data throughput is the rate of data transfer to and from a wireless device.

NOTE

This feature does not attempt to monitor application layer data throughput (FTP, HTTP, TELNET, etc.).

Two sets of statistics are available from the Data Throughput Monitor:

  • OTA Rx and OTA Tx

    OTA (Over the Air) throughput counts the data transmitted and received by the test set's protocol stack. The location of the measurement point in the protocol stack is dependent upon system type; this data could be a byte stream from RLP (Radio Link Protocol) or RLC (Radio Link Control) or PPP (point to point protocol). OTA throughput does not count physical layer overhead such as mid-amble, guard, or tail bits, or bits added by the encoding process.

  • IP Rx and IP Tx

    IP (Internet Protocol) throughput counts the data transmitted and received by the test set. It measures the IP data transferred between the external LAN connector and the protocol stack. It provides a measure of the IP data packets being transferred to/from the wireless device.

How is Data Throughput Displayed?

When the Data Throughput Monitor is selected and a data call is connected, the test set accumulates data throughput statistics. If a data call is disconnected, data accumulation is suspended until another connection is made and data accumulation continues. Data accumulation can be cleared by performing a measurement reset or clearing the graph.

The test set provides two tools to analyze data throughput:

  • Graphical trace
  • Summary table

Graphical trace

The graphical trace presents up to the most recent 600 seconds (10 minutes) of data throughput statistics. Each of the following color-coded traces can be turned on or off:

  • OTA Tx - (Over The Air Transmitted bits-per-second). This is the rate of link-layer bit transfer sent from the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in W-CDMA and GPRS, or PPP in GSM. Tx refers to the reverse or uplink channel direction.
  • OTA Rx - (Over The Air Received bits-per-second). This is the rate of link-layer bit transfer received by the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in W-CDMA and GPRS, or PPP in GSM. Rx refers to the forward or downlink channel direction.
  • IP Tx - Internet Protocol Transmitted. This is the rate of network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.
  • IP Rx - Internet Protocol Received. This is the rate of network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.
  • Context 1 Tx - Internet Protocol Context 1 Transmitted. This is the rate of context 1 network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.
  • Context 1 Rx - Internet Protocol Context 1 Received. This is the rate of context 1 network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.

For WCDMA applications that have the required Dual Cell HSDPA license, there are three OTA Rx results available: OTA Rx (for the serving cell), OTA2 Rx (for the secondary serving cell) and OTA Rx Total (for the two cells combined). Accordingly you can enable any of the OTA Rx traces.

Four sets of Context <n> traces can be set: Context 1 Tx/Rx, Context 2 Tx/Rx, Context 3 Tx/Rx and Context 4 Tx/Rx. Totally there are 12 traces results are available form the Data Throughput Monitor, but six of them can be display on the screen at one time. The users can choose which traces are to be displayed by pressing Trace Display softkey.

Note that for an application that dose not support counters for multiple Contexts, the "Context<n>" counts will always be zero (a trace will still be available but every point will be "0").

A marker can be assigned to each trace to display instantaneous numeric data throughput values. Markers can be used in conjunction with the Freeze Graph feature to analyze points of interest on traces.

Summary table

The summary table provides the latest statistics for the four monitored measurements. Each measurement is displayed with the following statistics:

  • Marker

    The data rate at the measurement's marker position in bits-per-second.

  • Current

    The measurement's instantaneous data in bits-per-second.

  • Average

    The measurement's average data rate in bits-per-second over the length of the data connection or since the last time the measurement was cleared.

  • Peak

    The measurement's peak data rate in bits-per-second over the length of the data connection or since the last time the measurement was cleared.

  • Data Transfer

    The measurement's total data throughput count, in bytes, over the length of the data connection or since the last time the measurement was cleared

Related Topics

How Do I Use the Data Throughput Monitor?


QPSK EVM Measurement Description

QPSK EVM Measurement Description

Last updated: January 5, 2010

  • How is a QPSK EVM Measurement Made?
  • QPSK EVM Measurement Parameters
  • QPSK EVM Measurement Results
  • QPSK EVM Input Signal Requirements
  • QPSK EVM Measurement Calibration

How is a QPSK EVM Measurement Made?

The QPSK EVM measurement is to determine the error between the transmitted signal of a UE and the desired ideal signal. The measurement is very similar to the Waveform Quality measurement. The difference is that the expected input signal is a QPSK modulated signal, which is similar to the WCDMA uplink signal with only one code channel. The data carried by the QPSK symbols sequence can be any pattern.

This measurement is designed for the UE to calibrate its IQ modulator without a WCDMA format signal to meet the waveform quality requirements as defined in 3GPP TS 34.121.

Please note that the measurement results will only be valid if a pure QPSK modulated input signal is applied.

QPSK EVM Measurement Parameters

  • Multi-Measurement Count: see Statistical Measurement Results .
  • Trigger Arm: see Trigger Arm (Single or Continuous) Description .
  • Trigger Source

    Triggering choices are immediate, protocol, external, auto, and HS-DPCCH ( lab application or feature-licensed test application only ). See Trigger Source Description for more information.

    Auto triggering is the default choice. In most cases, auto triggering provides the optimum measurement triggering condition for the waveform quality measurement. For example, if the UE is synchronized to the test set, auto triggering causes protocol triggering to be used. Auto triggering causes immediate triggering is used if the UE is not synchronized. When immediate triggering is used, the measurement result returned for timing error is always NAN (Not a Number) because it is not possible to evaluate a timing error in this measurement situation.

  • Trigger Delay

    You can move the measurement interval (666.7 us = 1 timeslot) relative to the trigger using the Trigger Delay setting.

  • Measurement Timeout: see Measurement Timeouts .
  • Measurement Interval
  • Original Offset in EVM

    Selects whether or not to include the original offset from the evaluated signal before calculating the EVM.

QPSK EVM Measurement Results

  • Error Vector Magnitude (EVM)
  • Peak EVM - the maximum symbol EVM calculated at each QPSK symbol in the measurement interval.
  • Magnitude Error
  • Phase Error
  • Origin Offset
  • Frequency Error

QPSK EVM Input Signal Requirements

  • For this measurement the test set's receiver uses auto-ranging to adjust for the level of the signal being measured; therefore the expected signal level does not need to be specified during measurement setup. However, it is recommended that Expected Power be configured to match the actual signal level expected to ensure the auto-ranging procedure executes as quickly as possible.
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, 1700 MHz to 1990 MHz, or 2480 MHz to 2580 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of -25 dBm to +28 dBm, in a 3.84 MHz bandwidth.
  • Maximum measurable EVM = 35%
  • Maximum measurable frequency error = ± 1 kHz

QPSK EVM Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function ( CALibration:MEASurements? ) when the temperature has changed by ± 10° C or more since the last calibration. If this situation exists, the integrity indicator value becomes 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

  • QPSK EVM Troubleshooting
  • What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator


Frequency Stability Measurement Description

Frequency Stability Measurement Description

Last updated: January 16, 2009

Description

How is a Frequency Stability measurement made?

The Frequency Stability measurement displays the frequency of an RF signal applied to the test set's front panel RF IN/OUT input port. After each measurement the input signal's absolute RF freqency is displayed with 1000 Hz resolution on the test set's front panel and 1 Hz resolution when queried over the GPIB.

The absolute RF signal frequency obtained during each Frequency Stability measurement is compared to the expected (measurement downconverter) frequency of the test set's measuring receiver. The difference between the expected frequency and the measured frequency is displayed as frequency error with 1 Hz resolution.

Frequency Stability Measurement

If the device under test is a mobile station on a call, the expected frequency can be automatically set by the base station emulator (using the RF Channel setting).

If the device under test is not on a call, the expected frequency must be set by manually controlling the receiver (manual measurement frequency).

Operating Considerations

Front Panel Access

Frequency Stability measurements are accessed manually by pressing the front-panel Measurement selection key.

NOTE
In some test set applications it is necessary to select an analog System Type (for example, AMPS) or an analog Operating Mode (for example, AVC Test or CW) to access the Frequency Stability measurement.

Input Signal Requirements

The Frequency Stability measurement is designed to measure non-bursted analog signals. For example, this measurement can be made on an AMPS cellular mobile station while it is on an active AVC (analog voice channel) with or without SAT or other frequency modulation. It is not desiged to measure AM (amplitude modulated) signals.

When a mobile station is on a call, the test set has the ability to predict the power level and frequency that is present on the RF input and automatically adjust attenuator and measurement downconverter settings. However, for test operating modes or CW (continuous wave) the test set is not functioning as a base station emulator. In the absence of call control, it is likely that the test set's receiver will need to be manually tuned to the input signal.

To meet Frequency Stability measurement performance specifications, the input signal must be:

  • Within the frequency interval 293 MHz to 2.7 GHz.
  • Within 200 kHz of the expected frequency.
  • Greater than -30 dBm.
  • Within 3 dB of the expected power.
  • Within an FM index of three (if FM is applied).
  • Within 100 Hz and 15 kHz modulating frequency (if FM is applied).

Multi-measurement Use

When multi-measurement count is turned on during a Frequency Stability measurement, the test set returns statistical data acquired over a number of measurements, including the worst case frequency error, in ppm (parts per million).

Frequency Stability Measurement With Multi-measurements

Related Topics

Programming a Frequency Stability Measurement

Frequency Stability Troubleshooting

Receiver Control


HSDPA Block Error Ratio Measurement Description

HSDPA Block Error Ratio Measurement Description

Last updated: January 7, 2012

This section is only applicable to the lab application or a test application with the required feature license.

  • How is an HSDPA Block Error Ratio Measurement Made?
  • HSDPA Block Error Ratio Measurement Parameters
  • HSDPA Block Error Ratio Measurement Results
  • HSDPA Block Error Ratio Measurement Input Signal Requirements

How is an HSDPA Block Error Ratio Measurement Made?

The HSDPA block error ratio (BLER) measurement can only be performed on a Radio Bearer Test Mode connection with a Channel Type of 12.2k RMC + HSDPA or 12.2k RMC + HSPA. To perform the HSDPA BLER measurement, the test set sends blocks of data to the UE on the downlink HS-PDSCH(s). The data sent on the downlink HS-PDSCH(s) is determined by the HS-DSCH Data Pattern setting (or FDD Test "HS-DSCH Data Pattern" in FDD Test Operating Mode ). The test set then monitors the positive acknowledgments (ACKs) and negative acknowledgments (NACKs) sent by the UE on the uplink HS-DPCCH.

The UE is required to respond to every block of data directed to it with either an ACK or NACK. If it does not respond to a block in its assigned TTI, the test set logs the event as a statistical DTX (statDTX). Also, if the UE responds to a block with data other than all 1s (ACK) or all 0s (NACK), the TTI is treated as a statDTX. StatDTXs are considered block errors, and are included in the BLER calculation. You can specify how the test set responds to statDTXs using the statDTX Reception Behavior setting.

In addition to ACK/NACK information, the uplink HS-DPCCH also carries channel quality indicator (CQI) information. The test set analyzes the CQI values sent by the UE and reports the Median CQI .

Dual Cell HSDPA Considerations

When DC-HSDPA is active, there are three sets of the HSDPA block error ratio results: One for the serving cell, one for the secondary serving cell and one s for the combined serving cells.

FDD Test Mode Considerations

In FDD Test operating mode the test set does not provide radio bearer setup control of the UE. You must configure the UE to synchronize to the test set, demodulate the downlink HS-SCCH and HS-PDSCH channels and generate the appropriate uplink HS-DPCCH (see Synchronizing the UE to the Test Set's Downlink to Make Measurements ).

Once the UE begins transmitting its HS-DPCCH, the test set requires a finite amount of time to acquire and decode the UE's signal. If you initiate the HSDPA BLER measurement while the test set is still acquiring the UE's signal, the measurement will report statDTXs until it finishes its acquisition and begins demodulating the HS-DPCCH. To avoid an incorrect HBLER result, it is recommended that you wait approximately 2 seconds after the UE begins transmission of its HS-DPCCH before initiating the HBLER measurement (the amount of time required varies depending upon your test configuration).

HSDPA Block Error Ratio Measurement Parameters

  • Number of blocks to test

    Sets the number of blocks to test during the measurement.

    Note, the time for the measurement to complete increases linearly with the Number of blocks to test . The test time (in seconds) is determined by:

    (It takes six sub-frames (0.012 s) for a block sent to the UE by a HARQ process to be acknowledged at the test set).

    When DC-HSDPA is configured (the Current Secondary Serving Cell Status is Configured-Active or Configured-Inactive) , and the Blocks to Test Specified Per Serving Cell is set to On , then this setting is not used, and the actual number of blocks to test for the measurement is determined by the DC-HSDPA Serving Cell Blocks to Test and DC-HSDPA Secondary Serving Cell Blocks to Test .

    GPIB Command: SETup:HBLerror:COUNt

  • Blocks to Test Specified Per Serving Cell

    This setting is only applicable when DC-HSDPA is configured.

    • If it is set to On , then the number of blocks to test for the serving cell is determined by DC-HSDPA Serving Cell Blocks to Test and the number of blocks to test for the secondary serving cell is determined by DC-HSDPA Secondary Serving Cell Blocks to Test .
    • If it is set to Off , then the number of blocks to test for each serving cell is not predicted, but the total number of blocks to test for the serving cell and the secondary serving cell is determined by Number of blocks to test .

  • GPIB Command: SETup:HBLerror:COUNt:DCHSdpa[:STATe]

  • DC-HSDPA Serving Cell Blocks to Test

    GPIB Command: SETup:HBLerror:COUNt:DCHSdpa:SERVing

  • DC-HSDPA Secondary Serving Cell Blocks to Test

    GPIB Command: SETup:HBLerror:COUNt:DCHSdpa:SECondary

  • Trigger Arm: see Trigger Arm (Single or Continuous) Description .
  • Measurement Timeout

    See Measurement Timeouts . If you set Measurement Timeout to On , ensure that the Measurement Timeout value is greater than the time the measurement needs to measure the desired Number of blocks to test .

The trigger source for this measurement is always protocol-based (see Trigger Source Description ).

HSDPA Block Error Ratio Measurement Results

  • Block Error Ratio

    3GPP TS 34.121 F.6.3.2 defines the HSDPA block error ratio as:

  • Information Bit Throughput (kbps)

    This result reports the data throughput of the HSDPA connection. 3GPP TS 34.121 F.6.3.1 defines Information Bit Throughput R as "the sum (in kilobits) of the information bit payloads (excluding the 24-bit HS-DSCH CRC) successfully received during the test interval, divided by the duration of the test interval (in seconds)."

    Each time the test set receives an ACK from the UE, it increments a counter called "totalBits" by the size of the data block (in bits) that was positively acknowledged. Each time the test set transmits a data block on the HS-PDSCHs, it increments a counter called "blocksTransferred" (a transmission of a new block of data or retransmission of an old block of data both count as a block transmission). Each time the test set does not transmit a block in a TTI it increments a counter called regDTX.

    Throughput (in kbps) is then calculated as follows:

  • ACKs

    Number of positive acknowledgments received.

  • NACKs

    Number of negative acknowledgments received.

  • statDTXs

    Number of statistical DTXs received .

  • Blocks Tested

    Blocks tested is the number of blocks that were tested in determining the Block Error Ratio , Information Bit Throughput , ACKs , NACKs , statDTXs and Median CQI .

  • Median CQI

    The test set monitors the CQI values reported by the UE, then:

    1. Generates a CQI frequency distribution (number of occurrences of each CQI value)
    2. Generates a cumulative CQI frequency distribution (total number of occurrences at or below each CQI value)
    3. Determines the median value of the cumulative CQI frequency distribution (determines which CQI value is above the (n-1)/2 occurrence point, where n is the total number of CQI occurrences).

    This value is the Median CQI , as specified by 3GPP TS 34.121 9.3.1.4.2 step 4.

    For example:
    CQI frequency distribution (frequency/CQI): 1/10, 3/11, 5/12, 4/13, 2/14
    Cumulative CQI frequency distribution (cumulative freq/CQI): 1/10, 4/11, 9/12, 13/13, 15/14
    The Median CQI value occurs at (15-1)/2 = 7 occurrences, which lies between a CQI value of 11 and 12. The Median CQI value in this example is thus 12.

  • Integrity Indicator

HSDPA Block Error Ratio Measurement Input Signal Requirements

  • The expected power into the test set must be set in order to maintain the link with the UE. This is done using the UE Target Power setting or by using manual receiver power control and specifying the expected power level. See Receiver Control .

  • Frequency: 800 to 1000 MHz, 1700 to 1990 MHz
  • Input level: -61 dBm to +28 dBm

Related Topics

Manual Operation: How Do I Make an HSDPA Block Error Ratio Measurement?

Programming an HSDPA Block Error Ratio Measurement

HSDPA Block Error Ratio Troubleshooting

HSDPA Counters

Block Error Ratio (BLER) Measurement Description

What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?


HSDPA Reporting of Channel Quality Indicator Measurement Description

HSDPA Reporting of Channel Quality Indicator Measurement Description

Last updated: January 16, 2009

This section is only applicable to the lab application.

  • How is a Reporting of Channel Quality Indicator Measurement Made?
  • Reporting of Channel Quality Indicator Measurement Parameters
  • Reporting of Channel Quality Indicator Measurement Results
  • Key 3GPP Tests Performed Using the Reporting of Channel Quality Indicator Measurement
  • Reporting of Channel Quality Indicator Input Signal Requirements
  • Other Things to Consider

How is a Reporting of Channel Quality Indicator Measurement Made?

NOTE
The test set allows you to collect up to 99000 UE reported CQI values and 99000 filtered ACK/NACK responses in Reporting of Channel Quality Indicator measurement. If both parameters are set to their maximum value of 99000, this measurement can take over 24 minutes to complete.

3GPP TS 34.121 9.3.1 states "The reporting accuracy of channel quality indicator (CQI) under AWGN environments is determined by the reporting variance and the BLER performance using the transport format indicated by the reported CQI median."

The Reporting of Channel Quality Indicator measurement consists of two main parts, which run in sequential order:

Part 1: CQI Variance test

Part 2: Block Error Ratio (BLER) versus CQI Sense

For the CQI Variance test (Part1), the downlink signal is configured according to the transport format that corresponds to the CQI value set in the Starting Downlink TF CQI (default value is 16). This is regardless of any CQI values reported by the UE. The test set collects the CQI reports every 2 ms and then, once it collects the Number of CQI Reports to test , it calculates the Median_CQI based on the collected data. If the CQI Variance test it is not within ۬ of the median CQI value then the entire Reporting of Channel Quality Indicator measurement fails and the measurement does not perform the BLER versus CQI Sense test (Part 2).

For the BLER versus CQI Sense test, the downlink signal is sent using the transport format that corresponds to the Median_CQI calculated from the CQI Variance test. The test set continues to collect the associated ACK, NACK, and statDTX responses to any transmitted HSDPA blocks. The responses are filtered as described in 3GPP TS 34.121 9.3.1.4.2 step 6.

The test set collects the responses until the number of filtered responses reaches the Number filtered ACK/NACK responses to test parameter, and then calculates the filtered HSDPA BLER from the filtered responses ( Filtered BLER (%) ). Note, this is the completion of the first half of the BLER versus CQI Sense test. The second half is dependent on the Filtered BLER (%) result that was obtained using the Median_CQI. The second half of the BLER versus CQI Sense testis performed as follows:

  • If the Filtered BLER (%) based on the Median_CQI is less than the Filtered BLER for initial CQI sense decision parameter (default is 10%), the test uses the transport format according to the Median _CQI+2 to gather filtered responses (until the number of filtered responses reaches the Number filtered ACK/NACK responses to test ) and then recalculates the filtered HSDPA BLER. If the filtered HSDPA BLER based on the Median _CQI+2 is greater than or equal to the Filtered BLER for PASS/FAIL: Median_CQI+2 parameter, then the UE passes the BLER versus CQI Sense test, and the BLER versus CQI Sense test is complete. Otherwise,
  • If the Filtered BLER (%) based on the Median_CQI is greater than or equal to the Filtered BLER for initial CQI sense decision parameter (default is 10%), the test uses the transport format according to the Median _CQI-1 to gather filtered responses (until the number of filtered responses reaches the Number filtered ACK/NACK responses to test ) and then recalculates the filtered HSDPA BLER. If the filtered HSDPA BLER based on the Median _CQI+1 is less than the Filtered BLER for PASS/FAIL: Median_CQI-1 parameter, then the UE passes the BLER versus CQI Sense test, and the BLER versus CQI Sense test is complete.

Reporting of Channel Quality Indicator Measurement Parameters

  • Starting Downlink TF CQI

    Sets the transport format of the downlink signal used during the CQI Variance test (Part 1 of the Reporting of Channel Quality Indicator measurement).

  • Number of CQI Reports to test

    Sets the number of CQI reports to be gathered in the CQI Variance test (Part 1 of the Reporting of Channel Quality Indicator measurement).

  • Percentage of CQI values within range

    Sets the percentage of values that must be in the range Median_CQI-2 to Median_CQI+2 used during CQI Variance test (Part 1 of the Reporting of Channel Quality Indicator measurement).

  • Number filtered ACK/NACK responses to test

    Sets the number of filtered ACK/NACK responses to be gathered in the BLER versus CQI Sense test (Part 2 of the Reporting of Channel Quality Indicator measurement).

  • Filtered BLER for initial CQI sense decision

    Sets the filtered HSDPA BLER ratio to use to make the CQI sense decision. That is, this parameter sets the filtered HSDPA BLER ratio that controls whether to use Median_CQI+2 or Median_CQI-1 is used for the second half of the BLER versus CQI Sense test.

  • Filtered BLER for PASS/FAIL: Median_CQI-1

    Sets the filtered HSDPA BLER ratio used to determine the pass/fail result for the Median_CQI-1 sense direction during the BLER versus CQI Sense test (Part 2 of the Reporting of Channel Quality Indicator measurement).

  • Filtered BLER for PASS/FAIL: Median_CQI+2

    Sets the filtered HSDPA BLER ratio used to determine the pass/fail result for the Median_CQI+2 sense direction during the BLER versus CQI Sense test (Part 2 of the Reporting of Channel Quality Indicator measurement).

  • Measurement Timeout

    See Measurement Timeouts . If you set Measurement Timeout to On , ensure that the Measurement Timeout value is greater than the time the measurement needs to measure the desired Number of CQI Reports to test .

Reporting of Channel Quality Indicator Measurement Results

Since the Reporting of Channel Quality Indicator measurement consists of two parts, there are separate results reported for each part, including a Pass/Fail result for each part and then an overall Pass/Fail result for the entire measurement.

The CQI Variance test is performed first which provides the Part 1: CQI Variance test results. Then the BLER versus CQI Sense test is performed which provides the two sets of results that are at Median_CQI and either Median_CQI+2 or Median_CQI-1 (depending on the filtered HSDPA BLER result).

Part 1: CQI Variance Results.

  • Downlink TF CQI

    This result indicates which transport format was used on the downlink by displaying the corresponding CQI value. The CQI value is an index into the CQI tables specified in 3GPP TS 25.214, which are separated based on the UE category and is characterized by the Number of Active HS-PDSCHs, Transport Block Size, Modulation Type, UE IR Buffer Size (see HSDPA RB Test Mode Setup for more information on these parameters)

  • CQI Reports

    This result is the total number of CQI reports gathered during the CQI Variance test (Part 1 of the Reporting of Channel Quality Indicator measurement).

  • Median_CQI

    This value is the Median CQI , as specified by 3GPP TS 34.121 9.3.1.4.2 step 4. The CQI report distribution generated by the test set during the CQI Variance test can be obtained using the GPIB query: "FETCh:HRCQuality:VARiance:CQIReports:DISTribution?" .

  • CQI in Range (%)

    This result is the percentage of CQI values reported from the UE that are in the range of Median_CQI-2 to Median_CQI+2 .

  • Pass/Fail

Part 2: BLER versus CQI Sense

  • Downlink TF CQI

    This result indicates which transport format was used on the downlink by displaying the corresponding CQI value. The CQI value is an index into the CQI tables specified in 3GPP TS 25.214, which are separated based on the UE category and is characterized by the Number of Active HS-PDSCHs, Transport Block Size, Modulation Type, UE IR Buffer Size (see HSDPA RB Test Mode Setup for more information on these parameters)

  • Median CQI

    This is determined the same way as that the Median_CQI is found in the CQI Variance test.

  • statDTXs

    The number of statistical DTXs received.

  • Filtered ACKs

    Number of filtered positive acknowledgments. (The responses are filtered as described in 3GPP TS 34.121 9.3.1.4.2 step 6.)

  • Filtered NACKs

    Number of filtered negative acknowledgments. (The responses are filtered as described in 3GPP TS 34.121 9.3.1.4.2 step 6.)

  • Filtered ACKs+NACKs

    The sum of the number of filtered positive acknowledgments and filtered negative acknowledgments. (The responses are filtered as described in 3GPP TS 34.121 9.3.1.4.2 step 6.)

  • Filtered BLER (%)

    Filtered HSDPA BLER result.

Key 3GPP Tests Performed Using the Reporting of Channel Quality Indicator Measurement

3GPP TS 34.121 9.3 Reported Channel Quality Indicator

Reporting of Channel Quality Indicator Input Signal Requirements

  • The expected power into the test set must be set in order to maintain a link with the UE. This is done using the UE Target Power setting or by using manual receiver control and specifying the expected power level. See Receiver Control .
  • Frequency: 800 to 1000 MHZ, 1700 to 1990 MHz
  • Input level: -61 dBm to +28 dBm

Other Things to Consider

The Reporting of Channel Quality Indicator measurement is aborted and restarted when the following test set parameters are changed while the measurement is active: Operating Mode , Measurement Frequency , Channel Type , RB Test HS-DSCH Configuration Type , or any changes to the System Configuration screen.

This measurement is triggered via the HS-DPCCH, and therefore you must have an RB Test Mode - HSDPA connection established (Channel Type 12.2K +HSDPA) in order for the test set to perform this measurement. Active Cell is the only Operating Mode currently supported.

Error messages are displayed when the following parameters are not set up correctly: CQI Repetition Factor, Measurement Power Offset, and UE IR Buffer Size. There are also several settings that must be set in order to comply with 3GPP TS 9.3.1.

During this measurement, the test set has ACK/NACK handling set such that new data is sent from the UE regardless of the previous response from the UE (ACK, NACK or DTX).

Since the CQI Variance and both parts of the BLER versus CQI Sense run sequentially, the intermediate count only applies to the part of the measurement that is currently running.

There are several parameters that are not specific to this measurement that must be set in order to comply with 3GPP TS 34.121 9.3.1. See Parameters that Affect the HSDPA Reporting of Channel Quality Indicator Measurement .

Related Topics

Manual Operation: How Do I Make an HSDPA Reporting Channel Quality Indicator Measurement?


Parameters that Affect the HSDPA Reporting of Channel Quality Indicator Measurement

Parameters that Affect the HSDPA Reporting of Channel Quality Indicator Measurement

Last updated: January 16, 2009

This section is only applicable to the lab applications.

The following table lists the parameters that affect the Reporting of Channel Quality Indicator measurement, but are not specific to the measurement. These parameters may or may not be a user settable parameter in the test set. If they are user settable, the table indicates whether you need to set these parameters. If the parameter is not user settable the test set automatically sets it during the Reporting of Channel Quality measurement.This is indicated by the User Settable, Set by the User and Set by the HRCQ Measurement columns, respectively.

The Warning Message column indicates whether or not the test set displays a warning message if a particular parameter is not set correctly when the Reporting of Channel Quality Indicator measurement is initiated. If no warning is displayed by the test set for a specific parameter that is not set correctly, you must ensure the settings are correct.

The Settable When Call Status is Connected column indicates whether the parameter can be set when the call status is in the Connected state. If it can not, you must ensure the parameter is set correctly before a call is established.

Parameter | 3GPP Reference | UE Category 1 to 6 | UE Category 7 to 8 | UE Category 11 to 12 | User Settable | Set by the User | Set by the HRCQ Measurement | Warning Message | Settable when Call Status is Connected | Notes
HSDPA Cell 1 Connected CPICH Level | 34.121 Table E.5.1 | -10 dB |  |  | Y | Y | N | N | Y |
HSDPA Cell 1 Connected P-CCPCH/SCH Level |  | -12 dB |  |  | Y | Y | N | N | Y |
HSDPA Cell 1 Connected PICH Level |  | -15 dB |  |  | Y | Y | N | N | Y |
HSDPA Cell 1 Connected HS-SCCH 2 Level |  | DTX'd |  |  | Y | Y | N | N | Y |
HSDPA Cell 1 Connected HS-SCCH 3 Level |  | DTX'd |  |  | Y | Y | N | N | Y |
HSDPA Cell 1 Connected HS-SCCH 4 Level |  | DTX'd |  |  | Y | Y | N | N | Y |
OCNS level |  | As required |  |  | N | N | N | N | N | Value is set automatically. No user-settable functionality.
Cell Power | 34.121 Table 9.3.1.1 | -60, -55 or -50 dBm / 3.84 MHz |  |  | Y | Y | N | N | Y |
AWGN Power |  | -60 dBm / 3.84 MHz |  |  | Y | Y | N | N | Y |
HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) |  | - 3 dB |  |  | Y | Y | Y | N | Y |
RB Test Mode First HS-PDSCH Channel Code |  | 5 |  |  | Y | Y | N | N | N | Default is 7
HSDPA Cell 1 Connected HS-SCCH 1 Level |  | -10 dB |  |  | Y | Y | N | N | Y |
HSPA Cell 1 Connected DPCH Level |  | -10 dB |  |  | Y | Y | N | N | Y |
Number of Transmissions |  | 1 |  |  | Y | N | Y | N | Y |
Number of HS-SCCHs to be monitored |  | 1 |  |  | N | N | N | N | N | Value is set automatically. No user-settable functionality.
CQI Feedback Cycle (k) |  | 2 ms |  |  | Y | Y | N | N | Y | When call is in connected state can only set using Transport Channel Reconfiguration message.
CQI Repetition Factor |  | 1 |  |  | Y | Y | N | Y | Y | When call is in connected state can only set using Transport Channel Reconfiguration message.
User Defined Inter-TTI Interval |  | 3 |  |  | Y | Y | N | N | Y |
statDTX Reception Behavior | 34.121 table 9.2.1.2 | Handle as ACK |  |  | Y | Y | N | N | Y | Default is to handle as statDTXs
Meas Pow Offset | 25.214 section 6A.2 | 7 dB | 7 dB | 7 dB | Y | Y | N | Y | Y | When call is in connected state can only set using Transport Channel Reconfiguration message. A warning message is displayed if the value signaled to the UE on call setup does not equal HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) - HSDPA Cell 1 Connected CPICH Level .
Transport block size | 25.214 Tables 7A, 7B, 7E | 3565 bits | 3565 bits | 3319 bits | N | N | Y | N | Y | Not user settable. Measurement sets indirectly by using the Transport Block Size Index and other variables.
User Defined Transport Block Size Index | 25.321 Table 9.2.3.1, Annex A | 8 | 8 | 43 | Y | N | Y | N | Y | "RB Test HS-DSCH Configuration Type" on page 1 must be set to User Defined in order to change this parameter while a call is connected.
User Defined Number of Active HS-PDSCHs | 25.214 Tables 7A, 7B, 7E | 5 | 5 | 5 | Y | N | Y | N | Y | "RB Test HS-DSCH Configuration Type" on page 1 must be set to User Defined in order to change this parameter while a call is connected.
User Defined Modulation Type |  | 16 QAM | 16 QAM | QPSK | Y | N | Y | N | Y | "RB Test HS-DSCH Configuration Type" on page 1 must be set to User Defined in order to change this parameter while a call is connected.
Reference power adjustment |  | 0 dB | 0 dB | -1 dB | Y | N | Y | N | Y | Changes the current power level of the HS-PDSCH. This parameter is affected by HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) .
User Defined Explicit UE IR Buffer Size |  | 9600 bits | 19200 bits | 4800 bits | Y | Y | N | Y | N |
RV Sequence |  | 0 | 0 | 0 | Y | N | Y | N | Y |
HS-SCCH 1 Channelization Code | 34.121 Table 9.3.1.2 | 2 |  |  | Y | Y | N | N | N |
User Defined Number of HARQ Processes |  | 2 |  |  | Y | Y | N | N | N | "RB Test HS-DSCH Configuration Type" on page 1 must be set to User Defined in order to change this parameter while a call is connected.
FRC MAC-d PDU Size |  | 112 bits | TBD | 112 bits | N | N | N | N | N | Not settable when "RB Test HS-DSCH Configuration Type" on page 1 is set to User Defined. Value for UE Cat 7, 8 not yet specified in standards.

Related Topics

HSDPA Reporting of Channel Quality Indicator Measurement Description

Manual Operation: How Do I Make an HSDPA Reporting Channel Quality Indicator Measurement?


Inner Loop Power Measurement Description

Inner Loop Power Measurement Description

Last updated: January 16, 2009

  • How is an Inner Loop Power Measurement Made?
  • Inner Loop Power Measurement Parameters
  • Inner Loop Power Measurement Results
  • Inner Loop Power Input Signal Requirements
  • Inner Loop Power Measurement Calibration

How is an Inner Loop Power Measurement Made?

Inner loop power control in the uplink is the ability of the UE to adjust its output power in accordance with one or more TPC (transmit power control) commands received in the downlink. When the UE is not in soft handover, only one TPC command is received in each timeslot. The UE's output power changes in response to a single TPC command, TPC_cmd, derived at the UE based on the power control algorithm. TPC_cmd, along with the power control step size, determines the UE transmit output power. The power change is applied in the timeslot adjacent to the timeslot in which the TPC command is received. For example, the power change derived from a TPC command in the 10th timeslot is applied to the 11th timeslot.

The inner loop power measurement is made through a root-raised cosine (RRC) filter with a roll off of alpha=0.22 and a bandwidth equal to the chip rate (3.84 MHz). The test set measures the mean power in each timeslot, excluding the transient duration. The transient duration is from 25 microseconds before the slot boundary to 25 microseconds after the slot boundary. The relative power difference is calculated for adjacent TPC_cmds and also for 10 TPC_cmd groups (10 timeslots if using algorithm 1 and 50 slots if using algorithm 2).

You can run the inner loop power measurement in Auto Mode or Manual Mode .

The inner loop power test process specified in 3GPP TS 34.121 5.4.2 consists of a series of test segments (referred to as Test Steps in the standard, see Inner Loop Power Control Test Steps ). The test set allows you to run one Test Segment at a time.

Inner Loop Power Control Test Steps

Auto Mode

Auto mode is used to run a single test segment as specified by 3GPP TS 34.121 5.4.2. This is achieved by selecting any one of the test segments (referred to as Test Steps in the standard) from the Test Segment menu and then initiating the measurement. You can perform the entire "Inner Loop Power Control in the Uplink" test by piecing the test segments together.

The test set behavior for each Test Segment is described in the table below. When you initiate the measurement with one of these test segments selected, the test set drives the UE to the proper start power for the test segment (if it is not already at the proper power) and performs a Physical Channel Reconfiguration to the proper power control algorithm and step size values for the test segment (if needed) before beginning the test.

Note that if the test segment requires a Physical Channel Reconfiguration to change to the required power control algorithm and/or step size, when the test segment completes the test set performs another Physical Channel Reconfiguration to return the connection to its pre-measurement configuration. Thus, it will save measurement execution time if you perform a Physical Channel Reconfiguration to the required power control algorithm and/or step size before beginning test of segments E and F or G and H (test segments A, B and C already match the default power control algorithm and step size in the test set).

Test Segment Descriptions
Test Segment | Power Control Algorithm | Step Size | Start Power | TPC Command Sequence Sent by Test Set
A | Two | 1 dB | -10 dBm (+/- 1 dB) | The TPC commands sent depend upon the Number of Slots setting.
B | Two | 1 dB | -10 dBm (+/- 1 dB) | 50 TPC commands with value 1
C | Two | 1 dB | 0 dBm (+/- 1 dB) | 50 TPC commands with value 0
Note: Test Segment can not be set to D. Step D in 3GPP TS 34.121 5.4.2 is automatically performed when you initiate Test Segment E. In other words, when Test Segment E is initiated, the test set sets Power Control Algorithm to One , Step Size to 1 dB , and sends TPC commands with a value of 1 until the UE stops increasing its output power. The test set then sends the TPC command sequence for Step E.
E | One | 1 dB | UE's maximum power + | Up to 300 TPC commands with value 0 #, *
F | One | 1 dB | UE's minimum power # | Up to 300 TPC commands with value 1 +, *
G | One | 2 dB | UE's maximum power + | Up to 150 TPC commands with value 0 #, *
H | One | 2 dB | UE's minimum power # | Up to 150 TPC commands with value 1 +, *
# The test set sends all down bits to the UE until the UE stops decreasing its output power (is stable within +/- 0.5 dB for E, within +/- 1 dB for G). + The test set sends all up bits to the UE until the UE stops increasing its output power (is stable within +/- 0.5 dB for F, within +/- 1 dB for H). * Note: to maintain accuracy, the test set re-ranges its receiver during these sequences. During this re-ranging time, the test set sends a series of alternating power control bits to the UE to hold its output power level.

Manual Mode

Manual mode allows you to build a custom test segment. This is achieved by selecting Manual from the Test Segment menu. In manual mode, the UE is instructed to go to Start Power before starting the test. The test set then measures the UE's response by sending the TPC commands with the Step Size and Power Control Algorithm you've specified until the expected target power is equal to Stop Power . If necessary, the test set performs a Physical Channel Reconfiguration to the proper power control algorithm and step size values before beginning the test.

UE (Mobile Station) Control During FDD Test Operation Mode

When the measurement is made in FDD test mode, the UE should be capable of deriving TPC_cmd commands in test mode. You need to configure the UE to use the proper power control algorithm and the step size before initiating a measurement, as these settings are not signalled to the UE by the test set.

Operating Considerations

No other measurements can be running during the inner loop power measurement. If any measurements are running when an inner loop power measurement is initiated, they are closed and a message is displayed to indicate that they have been closed.

To use this measurement in active cell mode, the UE must be on a call.

The test set does not support testing the UE in compressed mode with this measurement, therefore 3 dB power control step size is not allowed.

The total power of the UE on the uplink consists of the standard W-CDMA channels (UL DPCCH and DPDCH), the HSDPA control channel (HS-DPCCH) and the HSUPA channels (E-DPCCH and E-DPDCH). The target power for active power control sets the DPCCH and DPDCH power levels, so the total UE power when using HSPA is always higher than the target power. The actual offset in power depends on the ?c and ?d values, Delta CQI and Delta Ack/Nack values, and the E-TFCI of the enhanced channel. The mathematical relationship is expressed in the following formula:

For example, if HS-DPCCH is present in addition to DPCCH and 1 DPDCH, the UE Tx RF power will be:

higher than the UE's target power in dB.

Inner Loop Power Measurement Parameters

  • Test Segment

    See Auto Mode .

  • Power Control Algorithm

    This setting is only applicable when Test Segment = Manual (see Manual Mode ). Note, if Start Power is equal to Stop Power , the Power Control Algorithm and Step Size settings can not be changed and are set to Algorithm 2 and 1 dB . The number of slots measured is then determined by the Number of Slots setting.

    For a description of power control algorithms one and two, see UL CL Power Ctrl Algorithm .

  • Step Size

    This setting is only applicable when Test Segment = Manual and Power Control Algorithm = One .

    Step Size is the change in the UE's transmit power in response to a single TPC command.

  • Start Power

    This setting is only applicable when Test Segment = Manual (see Manual Mode ). Note, if Start Power is equal to Stop Power , the Power Control Algorithm and Step Size settings can not be changed and are set to Algorithm 2 and 1 dB . The number of slots measured is then determined by the Number of Slots setting.

  • Stop Power

    This setting is only applicable when Test Segment = Manual (see Manual Mode ). Note, if Start Power is equal to Stop Power , the Power Control Algorithm and Step Size settings can not be changed and are set to Algorithm 2 and 1 dB . The number of slots measured is then determined by the Number of Slots setting.

  • Number of Slots

    This setting is only applicable when Test Segment = Manual and Start Power = Stop Power or when Test Segment = A .

    The following TPC commands are sent, depending upon the Number of Slots setting:

    • 15: 100000101010101
    • 30: 100000101010101111101000001010
    • 45: 100000101010101111101000001010101011111010000
    • 60: 100000101010101111101000001010101011111010000010101010111110

  • Test Thresholds and Tolerances

    For test segments E-H, pass/fail limit checking (as specified by the Transmitter Power Control Pass/Fail Ranges ) and worst case results are determined for the range of measured results bounded by the Minimum Power Threshold for Test (MinPTT) and the Maximum Power Threshold for Test (MaxPTT). You can set MinPTT and MaxPTT manually, or let the test set automatically determine these values.

    To follow the test method specified by 3GPP TS 34.121 5.4.2, set Maximum Power Threshold for Test Control to Auto , set Maximum Output Power Test Tolerance to 0.7 dB , set Minimum Power Threshold for Test Control to Manual , and Minimum Power Threshold for Test Manual to -49 dBm .

    • Maximum Power Threshold for Test Control

      • Manual : MaxPTT is determined by the Maximum Power Threshold for Test Manual setting.
      • Auto : MaxPTT is determined automatically by the test set as follows -
        • Test segments E and G: Prior to starting the test segment, the test set sends all up bits to the UE (to drive the UE to transmit at the highest power possible), then makes a channel power measurement of the UE's output power once it has stabilized. MaxPTT is then set to this measured power level minus the Maximum Output Power Test Tolerance .
        • Test segment F and H: At the end of the test segment (when the UE's output power has stabilized at the highest power it is capable of transmitting), MaxPTT is set to the measured power level minus the Maximum Output Power Test Tolerance .

    • Maximum Power Threshold for Test Manual

      When Maximum Power Threshold for Test Control is set to Manual , this setting specifies the MaxPTT.

    • Maximum Output Power Test Tolerance

      When Maximum Power Threshold for Test Control is set to Auto , this setting allows you to modify the MaxPTT value used by the test set.

    • Minimum Power Threshold for Test Control

      • Manual : MinPTT is determined by the Minimum Power Threshold for Test Manual setting.
      • Auto : MinPTT is determined automatically by the test set as follows -
        • Test segments F and H: Prior to starting the test segment, the test set sends all down bits to the UE (to drive the UE to transmit at the lowest power possible), then makes a channel power measurement of the UE's output power once it has stabilized. MinPTT is then set to this measured power level plus the Minimum Output Power Test Tolerance .
        • Test segment E and G: At the end of the test segment (when the UE's output power has stabilized at the lowest power it is capable of transmitting), MinPTT is set to the measured power level plus the Minimum Output Power Test Tolerance .

    • Minimum Power Threshold for Test Manual

      When Minimum Power Threshold for Test Control is set to Manual , this setting specifies the MinPTT.

    • Minimum Output Power Test Tolerance

      When Minimum Power Threshold for Test Control is set to Auto , this setting allows you to modify the MinPTT value used by the test set.

  • UE Range Time

    Before the test set can measure the UE's response to power control bits, it must drive the UE to the proper starting power as determined by the Test Segment 's start power (see Test Segment Descriptions ) or by the Start Power setting (when Test Segment = Manual ). When the measurement is initiated, the test set sends power control bits to drive the UE to the required start power. The amount of time needed to drive the UE to the proper starting power depends upon the UE's current output power level and the power control algorithm used to drive the UE's output power. The amount of time the test set waits for this initial ranging to complete is determined by the following settings:

    • UE Range Time Control

      When UE Range Time Control is set to Auto , the test set automatically determines a sufficient UE range time and does not begin measuring UE output power until that time has elapsed.

      When UE Range Time Control is set to Manual , when the measurement is initiated, the test set waits a time equal to Manual UE Range Time before beginning measurement of the UE's output power (during this wait time the test set sends power control bits to drive the UE to the required start power). Manual UE range time control is especially useful if you know that the UE's output power is already at the required starting power. In this case, you can set Manual UE Range Time to zero and start the measurement immediately, and thus minimize the measurement execution time.

      GPIB command: SETup:WILPower:MS:RANGe:TIME:CONTrol:AUTO

    • Manual UE Range Time

      This setting determines the UE range time when UE Range Time Control is set to Manual .

      GPIB command: SETup:WILPower:MS:RANGe:TIME:CONTrol:AUTO

  • Transmitter Power Control Pass/Fail Ranges

    You can set the pass/fail ranges applied for each Test Segment (when in Auto Mode ) or in Manual Mode (based on power control algorithm, power step size and direction).

    Auto Mode : The following tables indicate how the pass/fail range settings map to the 3GPP TS 34.121 5.4.2.5 test requirements and the test segments to which they apply:

    3GPP TS 34.121 Table 5.4.2.5.1 Transmitter Power Control Range (with Applicable Test Segments and Pass/Fail Range Settings)
    TPC_cmd | Transmitter power control range (all units are in dB)
    1 dB step size | 2 dB step size
    Lower | Upper | Test Segment | Lower | Upper | Test Segment
    +1 | +0.4 | +1.6 | B, F | +0.85 | +3.15 | H
    TX Pwr Ctrl Rng Sngl Step Up 1dB:
    Lwr Lim     and Upr Lim     		TX Pwr Ctrl Rng Sngl Step Up 2dB:
    Lwr Lim     and Upr Lim
    0 | -0.6 | +0.6 | A, B, C | -0.6 | +0.6 | N/A
    TX Pwr Ctrl Rng Sngl Step None:
    Lwr Lim     and Upr Lim     		N/A
    -1 | -0.4 | -1.6 | C, E | -0.85 | -3.15 | G
    TX Pwr Ctrl Rng Sngl Step Dn 1dB:
    Lwr Lim     and Upr Lim     		TX Pwr Ctrl Rng Sngl Step Dn 2dB:
    Lwr Lim     and Upr Lim

    3GPP TS 34.121 Table 5.4.2.5.2 Transmitter Aggregate Power Control Tolerance (with Applicable Test Segments and Pass/Fail Range Settings)
    TPC_cmd group | Transmitter power control range after 10 equal TPC_cmd group (all units are in dB)
    1 dB step size | 2 dB step size
    Lower | Upper | Test Segment | Lower | Upper | Test Segment
    +1 | +7.7 | +12.3 | F | +15.7 | +24.3 | H
    TX Pwr Ctrl Rng Agg Alg1 Step Up
    1dB: Lwr Lim     and Upr Lim     		TX Pwr Ctrl Rng Agg Alg1 Step Up
    2dB: Lwr Lim     and Upr Lim
    0 | -1.1 | +1.1 | A | -1.1 | +1.1 | N/A
    TX Pwr Ctrl Rng Agg Alg2 Step None:
    Lwr Lim     and Upr Lim     		N/A
    -1 | -7.7 | -12.3 | E | -15.7 | -24.3 | G
    TX Pwr Ctrl Rng Agg Alg1 Step Dn
    1dB: Lwr Lim     and Upr Lim     		TX Pwr Ctrl Rng Agg Alg1 Step Dn
    2dB: Lwr Lim     and Upr Lim
    0,0,0,0,+1 | +5.7 | +14.3 | B | N/A | N/A | N/A
    TX Pwr Ctrl Rng Agg Alg2 Step Up
    1dB: Lwr Lim     and Upr Lim     		N/A
    0,0,0,0,-1 | -5.7 | -14.3 | C | N/A | N/A | N/A
    TX Pwr Ctrl Rng Agg Alg2 Step Dn
    1dB: Lwr Lim     and Upr Lim     		N/A

    Manual Mode : The following table indicates for which manual test scenarios the pass/fail range settings are applied.

    Manual Mode Pass/Fail Range Settings
    Pass/Fail Range Setting Applicable Manual Test Scenarios
    TX Pwr Ctrl Rng Sngl Step Up
    1dB: Upr Lim     and Lwr Lim     		Stop Power > Start Power
    and Power Control Algorithm = Two or One with Step Size = 1 dB .
    TX Pwr Ctrl Rng Sngl Step Up
    2dB: Upr Lim     and Lwr Lim     		Stop Power > Start Power
    and Power Control Algorithm = One with Step Size = 2 dB .
    TX Pwr Ctrl Rng Sngl Step None:
    Upr Lim     and Lwr Lim

    Start Power = Stop Power
    or Power Control Algorithm = Two .
    TX Pwr Ctrl Rng Sngl Step Dn
    1dB: Upr Lim     and Lwr Lim     		Stop Power < Start Power
    and Power Control Algorithm = Two or One with Step Size = 1 dB .
    TX Pwr Ctrl Rng Sngl Step Dn
    2dB: Upr Lim     and Lwr Lim     		Stop Power < Start Power
    and Power Control Algorithm = One with Step Size = 2 dB .
    TX Pwr Ctrl Rng Agg Alg1 Step Up
    1dB: Upr Lim     and Lwr Lim     		Stop Power > Start Power
    and Power Control Algorithm = One with Step Size = 1 dB .
    TX Pwr Ctrl Rng Agg Alg1 Step Up
    2dB: Upr Lim     and Lwr Lim     		Stop Power > Start Power
    and Power Control Algorithm = One with Step Size = 2 dB .
    TX Pwr Ctrl Rng Agg Alg1 Step Dn
    1dB: Upr Lim     and Lwr Lim     		Stop Power < Start Power
    and Power Control Algorithm = One with Step Size = 1 dB .
    TX Pwr Ctrl Rng Agg Alg1 Step Dn
    2dB: Upr Lim     and Lwr Lim     		Stop Power < Start Power
    and Power Control Algorithm = One with Step Size = 2 dB .
    TX Pwr Ctrl Rng Agg Alg2 Step None:
    Upr Lim     and Lwr Lim

    Start Power = Stop Power
    or Power Control Algorithm = Two .
    TX Pwr Ctrl Rng Agg Alg2 Step Up
    1dB: Upr Lim     and Lwr Lim     		Stop Power > Start Power
    and Power Control Algorithm = Two .
    TX Pwr Ctrl Rng Agg Alg2 Step Dn
    1dB: Upr Lim     and Lwr Lim     		Stop Power < Start Power
    and Power Control Algorithm = Two .

  • Trigger Delay

    You can adjust the beginning of the measurement interval for each slot measured using the Trigger Delay setting. This is useful if your UE's output power change in response to TPC commands is delayed. You can then shift the measurement interval to match the delay in the UE's response.

    Note, Trigger Delay should only be set to a non-zero value if your UE's output power response to TPC commands is delayed (i.e. if your UE is not operating properly). If your UE is behaving correctly in the timing of power changes in response to TPC commands, non-zero values of the Trigger Delay setting can cause unspecified results.

  • Measurement Timeout : (see Measurement Timeouts ).

Inner Loop Power Measurement Results

The test set can run a single one of the test segments at a time resulting in pass/fail and trace data that can be accessed via the MUI or RUI.

Pass/Fail and Worst Case Result Boundaries

Which timeslots are evaluated for pass/fail criteria (as specified by Transmitter Power Control Pass/Fail Ranges ) and worst case results are determined as follows:

  • Auto Mode , test segments A, B and C: Pass/fail limit checking and worst case results are determined for the entire range of measured results.
  • Auto Mode , test segments E, F, G and H: Pass/fail limit checking and worst case results are determined for the range of measured results bounded by the Minimum Power Threshold for Test and the Maximum Power Threshold for Test (see Test Thresholds and Tolerances ).
  • Manual Mode : Pass/fail limit checking and worst case results are determined for the range of measured results bounded by Start Power and Stop Power .

Inner Loop Power Measurement Results

  • Overall pass/fail result for the specified test segment: if any timeslot in the test segment does not meet the pass/fail criteria (see Transmitter Power Control Pass/Fail Ranges ), the entire segment test fails.
  • Number of slots: indicates the number of timeslots measured. For test segments E-H, this is not necessarily the same as the number of timeslots used for determining pass/fail and worst case results (see Test Thresholds and Tolerances ).
  • Results associated with each timeslot in which a TPC command was sent by the test set:
    • Slot number: Used as an index to the results reported in each timeslot. Slot 0 is the reference timeslot. Response to the TPC command sequence are from Slot 1.
    • Absolute Pwr (dBm): Indicates mean output power level for the current slot excluding the transient time (25 us from either side of the slot boundary).
    • Relative Pwr (dB): The difference between the mean power in the current slot and the mean power in the previous slot.
    • Rel Pwr 10 TPC (dB): The change in mean power over 10 TPC_cmd groups. (NAN for the first 9 results when in Algorithm 1 mode and NAN for the first 49 results when in Algorithm 2 mode.)
    • P/F: Indicates whether the change in the UE transmit power level is within the range specified by the Transmitter Power Control Pass/Fail Ranges . (Pass/Fail result: 0 = pass, 1 = fail adj TPC_cmds, 2 = fail 10 TPC_cmd groups result, 3 = fail in both adj TPC_cmds and 10 TPC_cmd groups test)
  • Worst case results (closest to failing or farthest from the pass/fail range if it failed).
    • Timeslot number of the worst case adjacent TPC_cmds result in which the worst case relative power for adjacent TPC_cmds is returned.
    • Absolute power level associated with the worst case TPC_cmds timeslot
    • Relative power level for adjacent TPC_cmds associated with the worst case TPC_cmds timeslot
    • Relative power level for 10 TPC_cmd groups associated with the worst case TPC_cmds timeslot
    • Timeslot number of the worst case 10 TPC_cmd groups result in which the worst case relative power for 10 TPC_cmd groups is returned.
    • Absolute power level associated with the worst case 10 TPC_cmd groups timeslot
    • Relative power level for adjacent TPC_cmds associated with the worst case 10 TPC_cmd groups timeslot
    • Relative power level for 10 TPC_cmd groups associated with the worst case 10 TPC_cmd groups timeslot

Inner Loop Power Input Signal Requirements

  • For this measurement the test set's receiver uses autoranging to adjust for the level of the signal being measured; therefore, the expected signal level does not need to be specified during measurement setup.
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, 1700 MHz to 1990 MHz, or 2480 MHz to 2580 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of -61 dBm to +28 dBm, in a 3.84 MHz bandwidth.

Inner Loop Power Measurement Calibration

You must calibrate this measurement using the Calibrate Measurements procedure (see Calibrating the Test Set ).

Related Topics

Manual Operation: How Do I Make an Inner Loop Power Measurement?


IQ Tuning Measurement Description

IQ Tuning Measurement Description

Last updated: January 16, 2009

  • How is an IQ Tuning Measurement Made?
    • Measurement Interval in Non-HSDPA Mode
    • Measurement Interval in HSDPA Mode ( lab application or feature-licensed test application only )
  • IQ Tuning Measurement Parameters
    • HSDPA Measurement Parameters ( lab application or feature-licensed test application only )
  • IQ Tuning Measurement Results
  • IQ Tuning Input Signal Requirements
  • IQ Tuning Measurement Calibration

How is an IQ Tuning Measurement Made?

The IQ tuning measurement includes all of the measurements available in the Waveform Quality measurement (see Waveform Quality Measurement Results ), along with the following measurement results:

  • Chip EVM

    Chip EVM is the calculated EVM at each chip in the measured timeslot. Chip EVM is measured as a 2560 element array of 32-bit floating point numbers. The first element in the array corresponds to the measured EVM for the first chip in the measured time slot, the second element to the EVM for the second chip in the measured time slot, and so on. These results are available graphically on the front panel display and numerically via the GPIB commands.

  • IQ constellation diagram

    The IQ constellation is the measured IQ signal with origin offset included. IQ constellation is measured as a 2560 element array of ordered pairs. Each ordered pair consists of two 32-bit floating point numbers corresponding to one point in the IQ constellation. The first member in the ordered pair is the I coordinate, the second is the Q coordinate. The array is scaled so all points fall within a unit circle. The first ordered pair in the IQ constellation array corresponds to the first chip in the measured time slot, the second ordered pair in the array corresponds to the second chip in the measured time slot, and so on. The IQ constellation result is only available graphically on the front panel display. It is not be accessible via the GPIB commands.

Measurement Interval in Non-HSDPA Mode

When on a non-HSDPA connection, you must set Trigger Source to any value other than HS-DPCCH . When operating in this mode, the measurement is made during one timeslot (666.7 us). You can choose in which timeslot of the W-CDMA frame the measurement is performed using the Timeslot setting.

Timeslot Setting

Measurement Interval in HSDPA Mode

This section is only applicable to the lab application or feature-licensed test application .

To measure IQ tuning on an HSDPA connection, you must set Trigger Source to HS-DPCCH . When Trigger Source is set to HS-DPCCH, you can specify the measurement interval and its placement within any of the 6 HSDPA subframes.

  1. Use the HS-DPCCH Trigger Subframe Alignment setting to choose in which 2 ms subframe (0 to 5) you want to place the measurement interval.
  2. Use the HS-DPCCH Trigger Slot Alignment setting to specify in which slot within the subframe you want to place the measurement interval ( AckNack = the first slot of the subframe, CQI1 = the second slot of the subframe and CQI2 = the third slot of the subframe).
  3. Set the duration of the measurement interval using the HS-DPCCH Measurement Interval setting. Note that the sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval cannot exceed 1.0 slot.
  4. Use the HS-DPCCH Trigger Subslot Alignment setting to specify where you want to place the measurement interval within the slot. You can place the measurement interval at the slot boundary, 0.1 slot (66.7 us) after the slot boundary, 0.2 slot (133.3 us) after the slot boundary... up to 0.5 slot (333.3 us) after the slot boundary. Note, however, that the sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval cannot exceed 1.0 slot. If you wish to place the measurement interval after the slot boundary using the HS-DPCCH Trigger Subslot Alignment setting, you must first decrease the HS-DPCCH Measurement Interval setting appropriately.
  5. You can choose to shorten the measurement interval so as to exclude the 25 us (96 chip) transient periods at the start and end of the measurement interval using the Transient Period setting. For example, if you set HS-DPCCH Measurement Interval to 0.5 slot (333.3 us or 1280 chips) and set Transient Period to Exclude , the measurement is performed over 283.3 us (or 1088 chips).

Measurement Interval Duration and Placement for HSDPA

IQ Tuning Measurement Parameters

  • Timeslot

    When Trigger Source is set to any value other than HS-DPCCH , you can specify which timeslot of the W-CDMA frame (0 to 14) is evaluated by the IQ tuning measurement. See Measurement Interval in Non-HSDPA Mode .

  • Trigger Arm: see Trigger Arm (Single or Continuous) Description .
  • Trigger Source

    Triggering choices are immediate, protocol, external, auto and HS-DPCCH ( lab application or feature-licensed test application only ). See Trigger Source Description for more information.

    Auto triggering is the default choice. In most cases, auto triggering provides the optimum measurement triggering condition for the IQ tuning measurement. For example, if the UE is synchronized to the test set, auto triggering causes protocol triggering to be used. Auto triggering causes immediate triggering is used if the UE is not synchronized. When immediate triggering is used, the measurement result returned for timing error is always NAN (Not a Number) because it is not possible to evaluate a timing error in this measurement situation.

  • Measurement Timeout: see Measurement Timeouts .

HSDPA Measurement Parameters

This section is only applicable to the lab application or feature-licensed test application .

These settings are only applicable when Trigger Source = HS-DPCCH .

See Measurement Interval in HSDPA Mode for more information about using these parameters to specify the duration and placement of the measurement interval.

  • Transient Period

    When Transient Period is set to Include , the measurement is performed over the interval specified by the HS-DPCCH Measurement Interval setting.

    When Transient Period is set to Exclude , the 25 us at the start of the measurement interval and the 25 us at the end of the measurement interval are excluded from the measurement. Thus, the measurement is performed over an interval equal to HS-DPCCH Measurement Interval minus 50 us. See Measurement Interval in HSDPA Mode .

  • HS-DPCCH Trigger Subframe Alignment

    Selects which 2 ms subframe (0 to 5) contains the measurement interval.

  • HS-DPCCH Trigger Slot Alignment

    Selects which slot in the 2 ms subframe contains the measurement interval ( AckNack = the first slot in the subframe, CQI1 = the second slot in the subframe and CQI2 = the third slot in the subframe).

  • HS-DPCCH Measurement Interval

    See Measurement Interval in HSDPA Mode .

    Note, the sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval cannot exceed 1.0 slot.

  • HS-DPCCH Trigger Subslot Alignment

    Selects where to place the measurement interval within the slot, in 0.1 slot (66.7 us) increments. This is useful because depending upon the Current DPCH Offset , the uplink DPCH and HS-DPCCH can be offset in time by increments of 0.1 slot (see HS-DPCCH/DPCCH Alignment vs. DPCH Frame Offset ).

    Note, the sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval cannot exceed 1.0 slot.

IQ Tuning Measurement Results

Chip EVM and the IQ constellation are graphed together on the same screen. See figure IQ Tuning Graph Display for an example display. You can use the Axis Control ( F2 ) and the Marker ( F3 ) settings to control the Chip EVM trace graph and the IQ constellation diagram. The IQ constellation diagram is always redrawn to reflect the latest Chip EVM settings. For example, if the chip EVM for chips 512 through 1023 are plotted, then the IQ constellation is shown for just chips 512 through 1023. The I and Q values for the IQ constellation all range between -1.0 and +1.0.

IQ Tuning Graph Display

The IQ tuning measurement also returns all of the measurement results of the Waveform Quality measurement. Waveform Quality Measurement Results

IQ Tuning Input Signal Requirements

  • For this measurement the test set's receiver uses auto-ranging to adjust for the level of the signal being measured; therefore the expected signal level does not need to be specified during measurement setup. However, it is recommended that Expected Power be configured to match the actual signal level expected to ensure the auto-ranging procedure executes as quickly as possible.
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, 1700 MHz to 1990 MHz, or 2480 MHz to 2580 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of -25 dBm to +28 dBm, in a 3.84 MHz bandwidth.
  • Maximum measurable EVM = 35%
  • Maximum measurable timing error = +/- 50 chips

IQ Tuning Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function ( CALibration:MEASurements? ) when the temperature has changed by ± 10° C or more since the last calibration. If this situation exists, the integrity indicator value becomes 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

  • Manual Operation: How Do I Make an IQ Tuning Measurement?
  • Programming an IQ Tuning Measurement
  • IQ Tuning Measurement Troubleshooting
  • What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator


Loopback Bit Error Ratio (BER) Measurement Description

Loopback Bit Error Ratio (BER) Measurement Description

Last updated: January 16, 2009

  • How Is a Loopback Bit Error Ratio Measurement Made?
  • Loopback BER Measurement Parameters
  • Loopback BER Measurement Results
  • Input Signal Requirements

How Is a Loopback Bit Error Ratio Measurement Made?

3GPP TS 34.121, F.6.1.1 defines bit error ratio (BER) as follows: "The Bit Error Ratio is defined as the ratio of the bits wrongly received to all data bits sent. The bits are the information bits above the convolutional/turbo decoder."

When the test set measures loopback bit error ratio, it sends a known data pattern (see DL DTCH Data ) on the downlink dedicated traffic channel (DTCH) to a UE that is configured in loopback mode 1 or 2. (Although the measurement will operate with UE Loopback Type set to 2 , all TS 34.121 tests utilizing the BER measurement require loopback mode 1). The UE decodes the data and re-transmits it on the uplink DTCH. The test set analyzes the uplink data to see how closely it matches the data bits originally sent on the downlink. The test set compares the downlink and uplink data one transport block at a time and reports the Bit Error Ratio .

To decrease test time, you may set Confidence State to On and specify the BER Requirement , which allows the test set to stop testing when an early pass or early fail event occurs, and to report a Confidence Test Result (see 3GPP TS 34.121 F.6 and 3GPP TS 34.901).

3GPP TS 34.121 Figure F.6.1.9

Because the test set must compare the UE's uplink data with the corresponding downlink data, the measurement must be able to synchronize to the UE's signal (align received uplink transport blocks with their corresponding downlink transport blocks. In doing so, the test set determines the UE's Loopback Delay ). See Input Signal Requirements .

When testing the UE's receiver performance, it is assumed that the uplink is error free. Any errors occurring on the uplink invalidate the receiver test. The loopback BER measurement returns information about uplink CRC Errors to assist in ensuring that the uplink is error free (to perform the loopback BER measurement, you must set Uplink DTCH RMC CRC Presence to Present so that an uplink CRC is generated).

To perform the loopback BER measurement while in Active Cell Operating Mode , you must be on an RB test mode call, with Channel Type set to a symmetrical RMC. Loopback BER can not be measured for Asymmetrical RMCs .

The trigger source for this measurement is always protocol-based (see Trigger Source Description ).

UE Control During FDD Test Mode Operation

The FDD Test Operating Mode does not provide radio bearer setup control of the UE for test mode operation. You must configure the UE in loopback mode 1 or 2 and synchronize it to the test set's downlink signal in order to make this measurement in FDD test operating mode.

The uplink transport format must include both the DTCH and the DCCH; however, only the DTCH information is used for the loopback bit error ratio measurement.

Loopback BER Measurement Parameters

  • Number of Bits to Test

    When Confidence State is Off , you may set the number of data bits to test during the measurement using the Number of Bits to Test setting. However, the actual number of bits tested is always the largest multiple of the number of bits needed to fill a DTCH transport block for the transmitted format. For example, for the 12.2 kbps reference measurement channel (RMC) the transport block is 244 bits. If you set the number of bits to test to 1000, the actual number of bits tested will be 1220 (1000 bits/244 bits per block = 4.1 blocks, so 5 blocks are required to test at least 1000 bits. 5 blocks x 244 bits per block = 1220 bits).

    When Confidence State is On , you may set the maximum number of bits to test during the measurement using the Number of Bits to Test setting. However, the actual number of bits tested will be less than this number if an early pass or early fail event occurs (see Confidence Test Result ). If a Confidence Test Result of Max Bits Tested is returned, then the actual number of bits tested is the largest multiple of the number of bits needed to fill a DTCH transport block for the transmitted format, as explained above.

    GPIB command: SETup:WBERror:COUNt

  • Trigger Arm - see Trigger Arm (Single or Continuous) Description .

  • Measurement Timeout - see Measurement Timeouts .

  • Confidence State

    To decrease test time, you may set Confidence State to On and specify BER Requirement , which allows the test set to stop testing when an early pass or early fail event occurs, and to report a Confidence Test Result (see 3GPP TS 34.121 F.6 and 3GPP TS 34.901).

    From the front panel, Confidence State can be set by pressing the ON or OFF key while Confidence Level is selected.

    GPIB commands: SETup:WBERror:CONFidence[:SLEVel] , SETup:WBERror:CONFidence:STATe

  • Confidence Level

    3GPP TS 34.121 F.6 defines:
    F = probability of a wrong decision
    (1 - F) = probability of a correct decision
    The probability (risk) to fail a good DUT shall be </= F according to the following definition: A DUT is failed, accepting a probability of </= F that the DUT is still better than the specified error ratio (Test requirement (see BER Requirement )).
    The probability to pass a bad DUT shall be </= F according to the following definition: A DUT is passed, accepting a probability of </= F that the DUT is still worse than M times the specified error ratio (see BER Requirement ). (M>1 is the Bad DUT Factor ).

    The Confidence Level parameter is equivalent to (1 - F). 3GPP TS 34.121 table F.6.1.8 specifies an F of 0.2% ( Confidence Level of 99.8% ) for all Receiver and Performance Characteristics tests in 3GPP TS 34.121 sections 6 and 7 (except for the fail limit for 6.5 Blocking Characteristics).

    Confidence Level is thus fixed to 99.8%. Similarly, Bad DUT Factor is fixed to 1.5.

    GPIB commands: SETup:WBERror:CONFidence[:SLEVel] , SETup:WBERror:CONFidence:LEVel

  • BER Requirement

    3GPP TS 34.121 F.6 defines TR = Test Requirement. As testing progresses, the bit error ratio trajectory converges to a value (see 3GPP TS 34.121 Figure F.6.1.9 ). The BER value that the UE is converging to shall not exceed the Test Requirement. The BER Requirement parameter is equivalent to Test Requirement expressed as a percentage. 3GPP TS 34.121 table F.6.1.8 specifies a Test Requirement of between 0.001 and 0.1 (0.1% and 10% BER Requirement ) for the Receiver and Performance Characteristics tests in 3GPP TS 34.121 sections 6 and 7.

    This setting is only available when Confidence State is On .

    GPIB command: SETup:WBERror[:RATio]:REQuirement

  • Bad DUT Factor

    3GPP TS 34.121 F.6 defines M = bad DUT factor. A Bad DUT Factor of greater than 1 shifts the early pass limit curve up (the early pass limit curve is defined by 3GPP TS 34.121 F.6.1.5 equation (2). See also 3GPP TS 34.121 Figure F.6.1.9 .) This allows an early pass event to occur after fewer bits have been tested for a given number of errors, which results in a higher bit error ratio (see the early pass equation for NL( ne ) in 3GPP TS 34.121 F.6.1.9). As M is increased, a greater number of bad DUTs are passed.

    3GPP TS 34.121 table F.6.1.8 specifies a Bad DUT Factor of 1.5 for all Receiver and Performance Characteristics tests in 3GPP TS 34.121 sections 6 and 7. Thus, Bad DUT Factor is fixed to 1.5.

    This setting is only available when Confidence State is On .

    GPIB command: SETup:WBERror:CONFidence:DUTFactor

  • Uplink DTCH RMC CRC Presence
  • UE Loopback Type

Loopback BER Measurement Results

  • Integrity Indicator
  • Bit Error Ratio

    The ratio of incorrectly received bits to the Bits Tested , expressed as a percentage (%).

    GPIB command: FETCh:WBERror<[:ALL]|:INTegrity|:RATio|:COUNt|:BITS>?

  • Confidence Test Result

    The Confidence Test Result is only available when Confidence State is On .

    • Pass : Few enough bit errors were detected for a large enough number of Bits Tested that the test set is able to predict (with the specified Confidence Level ) that the bit error ratio trajectory is converging to a value below the BER Requirement . An early pass event is determined according to 3GPP TS 34.121 5.6.1.5 equation (2).
    • Fail : Enough bit errors were detected for the number of Bits Tested that the test set is able to predict (with the specified Confidence Level ) that the bit error ratio trajectory is converging to a value above the BER Requirement . An early fail event is determined according to 3GPP TS 34.121 5.6.1.5 equation (1).
    • Max Bits Tested : After testing the number of bits specified by Number of Bits to Test , the test set is unable to predict (with the specified Confidence Level ) whether the bit error ratio trajectory is converging to a value above or below the BER Requirement .

    GPIB command: FETCh:WBERror:RATio:FAIL?

  • Bit Error Count

    The number of incorrectly received bits.

    GPIB command: FETCh:WBERror<[:ALL]|:INTegrity|:RATio|:COUNt|:BITS>?

  • Bits Tested

    Number of bits tested to determine the Bit Error Count and Bit Error Ratio results.

    GPIB command: FETCh:WBERror<[:ALL]|:INTegrity|:RATio|:COUNt|:BITS>?

  • Missing Blocks

    The UE sends a TFCI for each uplink DTCH transport block. When operating in Active Cell Operating Mode , the test set monitors the uplink TFCI, and can report uplink missing blocks. If the TFCI indicates that there is no data block sent for that TTI, the test set reports a missing block. When a missing block occurs, Bit Error Count and the number of Bits Tested are not incremented. The test set returns a Questionable MS-to-Cell Data Integrity Indicator .

    When in FDD Test Operating Mode , the test set does not monitor the uplink TFCI; rather, it assumes that a data block is sent in every TTI. However, when a missing block occurs, the test set detects a CRC error. Thus, the data within the block is not analyzed, and the number of Bits Tested is not incremented.

    GPIB command: FETCh:WBERror:MBLocks?

  • CRC Errors

    To determine if an uplink CRC error has occurred, the test set calculates the CRC for the data sent in the uplink DTCH transport block, and compares the result to the CRC sent by the UE for that transport block. When a CRC error occurs, the data within the block is not analyzed, and the number of Bits Tested is not incremented. If a CRC error occurs, the test set returns a Questionable MS-to-Cell Data Integrity Indicator .

    GPIB command: FETCh:WBERror:CRCerrors?

  • Loopback Delay

    3GPP TS 25.211 section 7.6.3 specifies that the uplink frame transmission take place 1024 chips after reception of the corresponding downlink frame. In reality, there is often a larger delay before the UE is able to transmit the uplink frame. 3GPP TS 34.109, 5.3.2.9 specifies this delay between received downlink radio frames and their corresponding uplink radio frames (produced from the received data) as the loopback delay. Loopback delay is measured at the UE antenna connector and is specified in units of radio frames. While the UE test loop is closed and the radio bearer configuration is not changed, the UE is required to maintain a fixed loopback delay, which must not exceed the number of radio frames corresponding to 10 times the TTI (Transmission Timing Interval) of the actual transport channel configuration. For example, if TTI is 10 ms, the UE is required to maintain a fixed loopback delay not to exceed 10 radio frames (the test set can actually tolerate a loopback delay of up to 50 TTI).

    To calculate loopback delay, the test set correlates the data in the uplink radio frame to the data sent in the downlink radio frame. Thus, the data sent by the test set must be different for each radio frame ( DL DTCH Data must not be set to All Zeros or All Ones ).

    GPIB command: FETCh:WBERror:LDELay?

Input Signal Requirements

  • The expected power into the test set must be set in order to maintain the link with the UE. This is done using the UE Target Power setting or by using manual receiver power control and specifying the expected power level. See Receiver Control .

  • Frequency: 800 to 1000 MHz, 1700 to 1990 MHz
  • Input level: -61 dBm to +28 dBm
  • The test set can synchronize to the UE's signal only if the bit error ratio is less than 10% on a block-by-block basis for three consecutive blocks, and the loopback delay is less than 50 transmission time intervals of the DTCH. See Synchronization requirements .

Related Topics

Manual Operation: How Do I Make a Loopback Bit Error Ratio (BER) Measurement?

Programming a Loopback Bit Error Ratio Measurement

Loopback Bit Error Ratio Troubleshooting

Radio Bearer Test Mode and Channel Type

Block Error Ratio (BLER) Measurement Description

What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?


Occupied Bandwidth (OBW) Measurement Description

Occupied Bandwidth (OBW) Measurement Description

Last updated: January 16, 2009

How is the occupied bandwidth measurement made?

As defined by 3GPP TS 34.121 section 5.8 Occupied Bandwidth (OBW) is the bandwidth containing 99% of the total integrated power of the transmitted spectrum, centered on the assigned channel frequency. The test set allows the percentage of total integrated power to be adjusted from 70.0 to 99.0%.

During this measurement, a Gaussian filter with a bandwidth greater than 10MHz and a resolution bandwidth (RBW) of 30 kHz or less is used to measure the distribution of the power spectrum.

First, the total power found in the measured frequency range is calculated. Then, starting at the lowest frequency in the range and moving upward, the power distributed in each frequency is summed until this sum is 0.5% of the total power. This gives the lower frequency value. Next, starting at the highest frequency in the range and moving downward, the power distributed in each frequency is summed until 0.5% of the total power is reached. This gives the upper frequency value. The bandwidth between the 0.5% power frequency points is the occupied bandwidth.

Input Signal Requirements

  • For this measurement the test set's receiver uses autoranging to adjust for the level of the signal being measured; therefore the expected signal level does not need to be specified during measurement setup.
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, or from 1700 MHz to 1990 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of +5 dBm to +28 dBm, in a 3.84 MHz bandwidth.
  • The uplink must be of constant in-channel power for the duration of this measurement. This requirement has implications for correct power control configuration, and uplink dynamics in HSDPA and HSUPA.

Trigger Source

The trigger source defaults to Auto and tries to use protocol triggering if the UE is synchronized to the test set. Immediate triggering is used if the UE is not synchronized.

If you want to measure the occupied bandwidth for a specific timeslot, use the trigger delay parameter.

Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function (see CALibration:MEASurements? ) when the temperature has changed by ± 10° C or more since the last calibration. If this situation exists, the integrity indicator value is changed to 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

  • Manual Operation: How Do I Make an Occupied Bandwidth (OBW) Measurement?
  • Programming an Occupied Bandwidth Measurement
  • Occupied Bandwidth Troubleshooting
  • What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator


PRACH Transmit On/Off Power Measurement Description

PRACH Transmit On/Off Power Measurement Description

Last updated: January 16, 2009

  • How is a PRACH Transmit On/Off Power Measurement Made?
  • PRACH Transmit On/Off Power Measurement Parameters
  • PRACH Transmit On/Off Power Measurement Results
  • Key 3GPP Tests Performed Using the PRACH Transmit On/Off Power Measurement
  • Input Signal Requirements
  • Measurement Calibration

How is a PRACH Transmit On/Off Power Measurement Made?

Before initiating a PRACH transmit on/off measurement, turn the UE on and wait for it to camp to the test set's signal. When the PRACH transmit on/off power measurement is initiated, the test set sets Call Limit State to On to prevent successful call connection, then pages the UE. This forces the UE to transmit PRACH preamble bursts.

The test set then measures the "on" power of the first PRACH preamble burst from the UE. The test set measures the average power (without an RRC filter present) from 25 µs after the start of the PRACH access slot, to 25 µs before the end of the PRACH preamble burst (see Burst On Power Measurement Interval ).

Burst On Power Measurement Interval

The test set then measures the "off" power before and after a subsequent PRACH preamble burst ("Pre Burst Off Power" and "Post Burst Off Power," respectively). The test set measures the average power with an RRC filter in place (Root-Raised Cosine filter response with a roll off of alpha = 0.22 and a bandwidth equal to the chip rate). The Pre Burst Off Power is measured from 642 µs before the start of the PRACH access slot to 25 µs before the start of the PRACH access slot. Depending upon your test set's hardware configuration (see www.agilent.com/find/8960upgrades), the Post Burst Off Power is measured from either 25 µs or 100 µs after the end of the PRACH preamble burst to 642 µs after the end of the PRACH preamble burst. See Burst Off Power Measurement Intervals .

Burst Off Power Measurement Intervals

The PRACH transmit on/off power measurement is triggered by a combination of RF rise and protocol. The test set must first receive an RF rise which is at least -45 dBm, and which is no more than 9 dB below the expected power ( Initial PRACH TX Power if Power Control is set to Auto, or Manual Power if Power Control is set to Manual; see Receiver Control ). The test set then uses this RF rise to determine in which PRACH access slot the PRACH preamble burst is contained. The protocol trigger then triggers the measurement on that access slot.

Measurement Behavior

The UE must be camped to the test set and in idle mode before performing the PRACH Transmit On/Off Power measurement.

To perform the PRACH transmit on/off power measurement, you must set Available Subchannels (Bit Mask) to only allow one available subchannel.

You must also set PRACH Preambles to at least 3 before initiating this measurement. It is recommended that you set PRACH Preambles to 4 , PRACH Ramping Cycles (MMAX) to 1 , and Call Limit State to Off before initiating this measurement to minimize issues after the measurement has completed. See the following:

  • Recommended PRACH Preambles and PRACH Ramping Cycles (MMAX) settings
  • Importance of Setting Call Limit State to Off before Initiating a PRACH Measurement
  • Test set may lock up if operations are attempted before the UE completes its PRACH sequence

No other measurements can be running when a PRACH transmit on/off power measurement is performed. If any measurements are running when a PRACH transmit on/off power measurement is initiated, they are closed and a message is displayed to indicate that they were closed.

Other Considerations

To change the UE's Initial PRACH TX Power level (which is reported by the Burst On Power result), you can change Primary CPICH TX Power , Uplink Interference , Constant Value , Cell Power and/or CPICH RSCP (Received Signal Code Power) . If you change Primary CPICH TX Power , Uplink Interference , or Constant Value , you must force the UE to re-read the BCCH before initiating the measurement (so that it will use the same values for these settings as the test set when calculating the power of its initial PRACH preamble). If your UE supports the Broadcast Channel (BCCH) Update Procedure (SIB Contents) , set BCCH Update Page to Auto to force the UE to re-read the BCCH. If your UE does not support the BCCH Update procedure, see BCCH Update Page for suggestions on forcing the UE to re-read the BCCH.

PRACH Transmit On/Off Power Measurement Parameters

  • Measurement Timeout: (see Measurement Timeouts )
  • Off Power Limit

    Sets the requirement (in dBm) for the measured "off" power ( Pre Burst Off Power and Post Burst Off Power ).

  • Open Loop Power Error Upper Limit

    Sets the upper limit (in dB) for the difference between the measured "on" power ( Burst On Power ) and the expected power ( Initial PRACH TX Power if Power Control is set to Auto, or Manual Power if Power Control is set to Manual, see Receiver Control ).

  • Open Loop Power Error Lower Limit

    Sets the lower limit (in dB) for the difference between the measured "on" power ( Burst On Power ) and the expected power ( Initial PRACH TX Power if Power Control is set to Auto, or Manual Power if Power Control is set to Manual, see Receiver Control ).

PRACH Transmit On/Off Power Measurement Results

  • Pre Burst Off Power

    This result returns the RRC filtered average "off" power (in dBm) before the PRACH preamble burst (see How is a PRACH Transmit On/Off Power Measurement Made? ); as well as pass or fail which indicates whether the power is below the requirement set by Off Power Limit .

  • Burst On Power

    This result returns the average "on" power (in dBm) (see How is a PRACH Transmit On/Off Power Measurement Made? ).

  • Open Loop Power Error

    This result returns the difference between the Burst On Power and the expected power based on open loop power control, as well as pass or fail which indicates whether the error is within the limits set by Open Loop Power Error Upper Limit and Open Loop Power Error Lower Limit .

  • Post Burst Off Power

    This result returns the RRC filtered average "off" power (in dBm) after the PRACH preamble burst (see How is a PRACH Transmit On/Off Power Measurement Made? ), as well as pass/fail, indicating whether the power is below the requirement set by Off Power Limit (see PRACH Transmit On/Off Power Measurement Parameters ).

Key 3GPP Tests Performed Using the PRACH Transmit On/Off Power Measurement

The "on" power measurement tests the open loop power control of the UE (3GPP TS 34.121, 5.4.1), while the "off" power measurement tests for unnecessary system signal leakage power (3GPP TS 34.121, 5.5). This measurement measures both the "on" power of the first PRACH preamble burst and the "off" power immediately prior to and just following any given PRACH preamble. It meets the requirements defined in 3GPP TS 34.121, section 5.5, Transmit ON/OFF Power and section 5.4.1, Open Loop Power Control in the Uplink . In order to prevent false "off" power measurements in the case where a compliant UE transmits power up to the limit of the +25 µs transient period, the start of the "off" power measurement period is delayed slightly to allow for recovery from receiver re-ranging.

Input Signal Requirements

  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, 1700 MHz to 1990 MHz, or 2480 MHz to 2580 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of -45 dBm to +28 dBm for "on" power, and in the range of -61 dBm to -50 dBm for "off" power.

Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function ( CALibration:MEASurements? ) when the temperature has changed by more than ± 10° C since the last calibration. If this situation exists, the integrity indicator value becomes 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

  • Manual Operation: How Do I Make a PRACH Transmit On/Off Power Measurement?
  • Programming a PRACH Transmit On/Off Power Measurement
  • PRACH Transmit On/Off Power Troubleshooting
  • What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Integrity Indicator


Perceptual Evaluation of Speech Quality (PESQ) Measurement Description

Perceptual Evaluation of Speech Quality (PESQ) Measurement Description

Last updated: October 26, 2010

This section is only applicable to the feature-licensed lab application or test application

  • How is a PESQ measurement made?
  • PESQ Measurement Parameters
  • PESQ Measurement Results
  • Related Topics

NOTE
The Perceptual Evaluation of Speech Quality measurement can not be concurrent with the Audio Analyzer instrument or the Real Time vocoder, nor can it be concurrent with the Swept Audio or the Multi-tone audio measurement. Hence starting the PESQ measurement will turn off any other measurement that is active, and vice versa.

How is a PESQ measurement made?

Perceptual Evaluation of Speech Quality (PESQ), as defined in the ITU-T P.862 standard, is a objective method to test the speech quality of the mobile station. The objectivity is based on the comparison to the traditional MOS (Mean Opinion Score) method in which a group of listeners are used to rate the voice quality to a value ranging from 1(bad) to 5 (excellent).

When AMR Voice is selected as the paging service (see Paging Service ), the AMR Source is set to PESQ and the AMR Radio Access Bearer is set to a desired vocoder (see AMR Setup ), the test set supports the PESQ measurement by comparing the original signal with the received signal passed through a communication system. After the PESQ analysis, a score is given ranging from -0.5 to 4.5. A higher score means a better speech quality.

There are three modes provided for this measurement: Uplink Audio, Downlink Audio and Both.

  • Uplink Audio: The test set acts as an audio generator, generates the original signal and sends it to the front-panel AUDIO OUT port which is connected to the mobile station's audio in port. The mobile station encodes the signals into speech frames of the uplink traffic channel. The test set then decodes the received speech frames, compares the original signal with the received signal and makes the PESQ measurement. See Typical Signal Flow with Uplink Audio Mode .
    Typical Signal Flow with Uplink Audio Mode
  • Downlink Audio: The test set acts as an audio generator, generates the original signal and encodes it into speech frames of the downlink traffic channel. The mobile decodes the received speech frames and outputs it to its audio out port which is connected to test set' s AUDIO IN port. The test set then compares the original signal with the received signal and makes the PESQ measurement. See Typical Signal Flow with Downlink Audio Mode .
    Typical Signal Flow with Downlink Audio Mode
  • Both: The test set performs the Uplink Audio measurement and Downlink Audio measurement simultaneously.

PESQ Measurement Parameters

The parameters shown in the PESQ Setup menu include:

  • Measurement Mode - specifies the measurement mode to perform the PESQ measurement. When Uplink Audio is selected, the test set generates the original signal and analyzes the received uplink signal from the mobile to perform the PESQ measurement. When Downlink Audio is selected, the test set generates the original signal and analyzes the signal at its AUDIO IN port. If the Measurement Mode is set to Both, the test set performs the uplink and the downlink PESQ measurement simultaneously.

    GPIB Command: SETup:WPESquality:MEASurement:MODE

    NOTE
    It is suggested to do the uplink and downlink PESQ measurement respectively although the test set supports the "Both" measurement mode. This is because some mobile phones have bad isolation between their audio in and audio out path. If performing the downlink and uplink measurement simultaneously, the uplink measurement will be affected a lot by the Downlink measurement.

  • Speech Source - specifies the speech source for use to perform the PESQ measurement. The test set supports two speech sources in accordance with the ITU-T P.862 standard: Male and Female .

    GPIB Command: SETup:WPESquality:SPEech

  • Expected Audio In Peak Voltage - Specifies the absolute peak voltage of the audio signal expected at the AUDIO IN port of the test set.

    GPIB Command: SETup:WPESquality:INPut:VOLTage[:EXPected]

  • Maximum Audio Out Peak voltage - Specifies the maximum peak voltage of the audio signal that can be output at the AUDIO OUT port of the test set.

    GPIB Command: SETup:WPESquality:OUTPut:VOLTage[:MAXimum]

  • Trigger Arm - (see Trigger Arm (Single or Continuous) Description ).

    GPIB Command: SETup:WPESquality:CONTinuous

  • Measurement Timeout - (see Measurement Timeouts ).

    GPIB Command: SETup:WPESquality:TIMeout[:STIMe]

PESQ Measurement Results

  • Integrity Indicator - (see Integrity Indicator ).
  • Uplink PESQ Score - indicates the uplink PESQ score, with the range from -0.5 to 4.5.
  • Downlink PESQ Score - indicates the downlink PESQ score, with the range from -0.5 to 4.5.
  • PESQ Uplink Headroom - indicates the signal headroom value before PESQ analysis when doing uplink PESQ measurement. This value can help you to adjust the signal level at the audio in port of the mobile so that the uplink signal level is not too large or too small to affect the PESQ score.
  • PESQ Downlink Headroom - indicates the signal headroom value before PESQ analysis when doing downlink PESQ measurement. This value can help you to adjust the downlink signal level so that the signal at the AUDIO IN port of the test set is not too large or too small to affect the PESQ score.
  • AMR RAB - indicates the current AMR Radio Access Bearer.
  • PESQ Measurement Status - indicates the whether the PESQ measurement is In Progress or Completed .

Related Topics

GPIB Commands: SETup:WPESquality , FETCh:WPESquality .


Swept Audio Measurement Description

Swept Audio Measurement Description

Last updated: January 16, 2009

Description

How are swept audio measurements made?

Swept audio measurements synchronize the frequencies of the test set's audio generator and audio analyzer instruments to automatically make measurements at up to 60 frequency points. Audio level, SINAD, and distortion measurements can be performed at each measurement point in the sweep.

This measurement only generates and analyzes audio signals; no modulation of the RF generator, or demodulation by the receiver, is performed. A representation of this operation is shown below.

Swept Audio Measurements Block Diagram

To perform the swept audio measurements, you must route audio generator signal to the AUDIO OUT port (not the FM Demod signal). See Interactions with the Audio Analyzer and Audio Generator Instruments . The audio signal from the device under test is sent to the audio analyzer through the AUDIO IN ports.

The start and stop frequencies for the sweep define the frequency range. The user specifies the number of measurement points, which are evenly spaced through the specified frequency range.

Measurement settling time can be set to specify how long the audio signal is generated at each frequency before a measurement is made by the audio analyzer. This is used to account for settling time in the device being tested and any signal delay through the device. Increasing the settling time increases the sweep time.

If the 100 Hz BW bandpass filter is selected, the center frequency of the filter is synchronized to the audio generator and audio analyzer frequencies.

Typical applications include measuring the audio distortion of a mobile station across several frequencies and measuring the frequency response of an audio filter or amplifier.

This is not a measurement procedure specified in the EIA/TIA standards.

Operating Considerations

Front Panel Access

Swept Audio measurements are accessed manually by pressing the front-panel Instrument selection key.

Multi-measurement Use

When multi-measurements are used with the swept audio measurement, the AF analyzer makes the number of measurements specified at each point in the sweep. For example, if five measurement points are specified, and the multi-measurement count is set to 20, a total of 100 measurements are performed during the sweep.

Interactions with the Audio Analyzer and Audio Generator Instruments

To route Audio Generator signal to the front panel AUDIO OUT port, use the "SYSTem:AUDio:OUTPut:SOURce" command or press the System Config hardkey, then select Audio Out Port ( F1 ) on the System Config Screen (2 of 2).

The Swept Audio measurement and the Audio Analyzer instrument cannot be used at the same time to make audio measurements. If you enable either function while the other function is already enabled, the first function is turned off and a message is displayed that informs you of this situation.

Selecting the Swept Audio measurement will automatically adjust Audio Generator instrument settings. These settings will not be restored to their original values when the Swept Audio measurement is closed.

The amplitude of the Audio Generator instrument can be changed while the Swept Audio measurement is enabled. However, trying to change the Audio Generator instrument's frequency while using swept audio measurements is not allowed, and causes an error message to be displayed.

Specifying a Specific Measurement Frequency Point Within a Sweep

If you need to make sure that a measurement is performed at a specific frequency within the sweep, you can use the following algorithms to calculate the values to enter:

For example if you wanted to make a measurement at 1004 Hz (F) during a sweep of 15 points (P) that begins at 300 Hz (S) and ends after 3 kHz (Emin), the first algorithm tells you that 1004 Hz occurs at the fourth point in the sweep (n). Use the second algorithm to calculate the actual stop frequency (E) you would enter for that sweep (3585.333 Hz).

Related Topics

Programming a Swept Audio Measurement

Swept Audio Measurement Troubleshooting

Audio Analyzer Measurement Description

Audio Level Measurement Description

Distortion Measurement Description

SINAD Measurement Description


SINAD Measurement Description

SINAD Measurement Description

Last updated: January 16, 2009

How is a SINAD measurement made?

SINAD is a receiver audio quality measurement that is typically used for mobile stations operating on an analog system, such as AMPS. It is the ratio of Signal+Noise+Distortion divided by Noise+Distortion, expressed in dB. SINAD is measured using the test set's Audio Analyzer. SINAD can be measured in the range of 100 Hz to 10 kHz. For information on using the Audio Analyzer, see Audio Analyzer Measurement Description .

The SINAD measurement is used to determine receiver RF sensitivity. SINAD is usually measured either of two ways:

  • Reduce the Cell Power from the test set until 12 dB SINAD is displayed (re-triggering for each measurement), or
  • Set the Cell Power from the test set to a specified low level and verify a 12 dB SINAD reading.

Difference in Agilent 8960 Series 10 and 8920B Test Set SINAD Measurements

If you have previously used the Agilent 8920B RF Communications Test Set to measure SINAD, you may notice that the Agilent 8960 Series 10 test set's SINAD value may be lower by up to 0.8 dB when measuring 12 dB SINAD. This is due to the more precise digital notch filter used by the 8960, causing a more accurate noise measurement to be made. The 8920B uses an analog filter that does not have as tight a filter notch as the 8960.

Related Topics

Programming a SINAD Measurement


Spectrum Monitor Description

Spectrum Monitor Description

Last updated: January 16, 2009

How is the spectrum monitor (SMON) used?

The Spectrum Monitor (SMON) can be used to locate, identify and measure transmitted signals from a device under test. The Spectrum Monitor can be used while a call is in progress.

The Spectrum Monitor is intended to be used for indication only. The Spectrum Monitor does not have the same level accuracy specifications as other measurements provided by the test set, and should therefore not be used when parametric accuracy is required (for example, calibration of a mobile). It is recommended that you use the other wireless format-specific measurements when you require accurate parametric measurements.

From the test set's front panel, the Spectrum Monitor can be accessed by pressing the Instrument Selection key, then selecting Spectrum Monitor . If you require more details on manual operation of the Spectrum Monitor, see How Do I Use the Spectrum Monitor? .

The Spectrum Monitor has the following two modes of operation:

  • Swept mode, in which the X axis represents frequency , and the Y axis represents absolute amplitude.
  • Zero span mode, in which the X axis represents time and the Y axis represents absolute amplitude.

You can use the markers on the Spectrum Monitor's graphical display to set the expected frequency and power levels that are used by the test or lab application for parametric measurements.

The center frequency used by the Spectrum Monitor is initially set at the expected frequency maintained by the test set's base station emulator. The expected frequency range is 292.5 MHz to 2700 MHz.

The range of frequencies which the spectrum monitor is calibrated to measure is determined by the range of traffic band frequencies supported by the specific test or lab application that is currently running. For example, if you are using the GSM Test Application, any of the frequencies used by the GSM traffic bands are available for you to monitor accurately. You can view signals which fall outside of any of the frequencies used by GSM, but the Spectrum Monitor will not be calibrated.

Detection Method

Frequency binning is used when the Spectrum Monitor divides the frequency span by the number of display points such that each bin contains a segment of the frequency span. Within each frequency bin, a single value representing each frequency bin is displayed on the test set's screen. The algorithm used to find the value that represents each frequency bin is determined by the detection method. There are three detection methods available in the test set's Spectrum Monitor:

  • Peak Detection

    The largest spectral component in the frequency bin is used to represent each bin.

  • Sample Detection

    The last spectral component in the frequency bin is used to represent each bin.

  • RMS Detection

    The sum of the power across the frequency bin is used to represent each bin.

The command to change the detection method is SETup:SMONitor:DETector[:TYPE] .

Resolution Bandwidth and Frequency Span

The resolution bandwidth can be used to resolve two or more closely spaced signals as long as the resolution bandwidth is less than the difference between the spectral components. A resolution bandwidth greater than or equal to the signal bandwidth can be used to measure the total power of a signal.

Refer to Frequency Span, Resolution Bandwidth and Dynamic Range below. When the Resolution Bandwidth Coupling State is OFF, the Frequency Span and the Resolution Bandwidth can be set to any value in their respective columns, and Resolution Bandwidth setting determines the Displayed Dynamic Range. When the Resolution Bandwidth Coupling State is On, the Resolution Bandwidth and Displayed Dynamic Range settings are coupled with the Frequency Span setting. For example, if the Frequency Span is 100 MHz, the test set automatically sets the Resolution Bandwidth to 5 MHz and the Displayed Dynamic Range to 55 dB.

Frequency Span, Resolution Bandwidth and Dynamic Range
Frequency Span | Resolution Bandwidth | Displayed Dynamic Range
100 MHz | 5 MHz | 50 dB
80 MHz | 1 MHz | 55 dB
40 MHz | 300 kHz | 60 dB
20 MHz | 100 kHz | 65 dB
12 MHz | 100 kHz | 65 dB
10 MHz | 100 kHz | 65 dB
5 MHz | 30 kHz | 70 dB
4 MHz | 30 kHz | 70 dB
2.5 MHz | 10 kHz | 75 dB
1.25 MHz | 3 kHz | 80 dB
500 kHz | 1 kHz | 80 dB
125 kHz | 300 Hz | 80 dB
0 Hz (zero span mode) | 100 kHz | 65 dB
 | 300 kHz | 60 dB
 | 1 MHz | 55 dB

The command to set the Resolution Bandwidth Coupling State is SETup:SMONitor:BANDwidth|BWIDth:AUTO .

The command to set the Resolution Bandwidth is SETup:SMONitor:BANDwidth|BWIDth:MANual , and the command to set the Frequency Span is SETup:SMONitor:FREQuency:SPAN .

Single or Multi-Measurements

The Spectrum Monitor can return either single or averaged results.

  • If you set the averaging state OFF then the trace represents a single measurement sweep.

  • If you set the averaging state ON, and the averaging count number to a value greater than one, then the trace represents the rolling average of the specified number of sweeps.

Input Signal Requirements

The Spectrum Monitor will complete and meet its accuracy specifications under the following input signal conditions.

  • The signal is within 40 dB of the reference level.
  • The measurement frequency is within the traffic band frequencies supported by the specific lab or test application that is currently running, and the expected frequency is tuned to the carrier.

Trigger Source

Triggering choices available for the Spectrum Monitor are Immediate, Protocol, RF Rise, and External.

For more information on measurement triggering, refer to Triggering of Measurements .

Calibrating the Spectrum Monitor

See Spectrum Monitor Calibration .

Related Topics

How Do I Use the Spectrum Monitor?


Spectrum Emission Mask Measurement Description

Spectrum Emission Mask Measurement Description

Last updated: January 19, 2009

  • How is the Spectrum Emission Mask Measurement Made?
  • Additional Spectrum Emission Mask Requirements
  • Spectrum Emission Mask Measurement Parameters
  • Spectrum Emission Mask Measurement Results
  • Spectrum Emission Mask Input Signal Requirements
  • Spectrum Emission Mask Measurement Calibration

How is the Spectrum Emission Mask Measurement Made?

What is the Spectrum Emission Mask?

The UE conformance specifications in 3GPP TS 34.121, Section 5.9 and 5.9A define a mask for out of channel emissions. This mask is defined relative to the in-channel power. The graphic below is an example of out-of-channel measurement results you might see on the test set. The spectrum emission mask for each of the four frequency bands is visible in green.

In-channel power

The in-channel power is measured on the RF input signal which is filtered with a 3.84 MHz bandwidth Root-Raised Cosine (RRC) filter with a rolloff of alpha = 0.22. The measurement interval for the in-channel power is 1 timeslot (666.7 us).

Out-of-channel emissions

The out-of-channel emissions found in frequencies between 2.5 and 12.5 MHz away from the center channel frequency are determined in four symmetrical bands on each side of the carrier.

The emissions are measured with either a 30 kHz or 1 MHz bandwidth Gaussian measurement filter. The spectrum emission mask measurement's pass/fail limits for the 30 kHz bandwidth filter and 1 MHz bandwidth filter are settable. See Spectrum Emission Mask in the Test Set for details of the spectrum emission mask measurement in the test set.

Spectrum Emission Mask in the Test Set
 | Frequency Offset from carrier | Measurement Bandwidth | Resolution Bandwidth (RBW)
Range 1 | 2.5 - 3.5 MHz | 30 kHz | 10 kHz
Range 2 | 3.5 - 7.5 MHz | 1 MHz | 250 kHz
Range 3 | 7.5 - 8.5 MHz | 1 MHz | 250 kHz
Range 4 | 8.5 - 12.5 MHz | 1 MHz | 250 kHz

NOTE
The resolution bandwidth (RBW) may also be referred to as the measurement step size.

The compliance of Range 1 with the specified mask is determined using the following measurement procedure. A 30 kHz Gaussian measurement filter is centered 2.515 MHz away from the carrier frequency on both sides. The filter is shifted by 10 kHz for each measurement until the 30 kHz filter is centered at a 3.485 MHz offset from the carrier. This provides 98 measurement points on each side of the carrier for evaluating mask compliance.

The remaining frequency ranges are evaluated in the same manner. However, a 1 MHz Gaussian measurement filter is used and the resolution bandwidth is 250 kHz instead of 10 kHz. The measurements begin with the filter centered at 4 MHz and end with it centered at 12 MHz. This provides 33 unique measurement points on each side of the carrier for evaluating mask compliance. However, there are redundant points at 7.5 MHz and 8.5 MHz. Therefore, 35 measurement points are available when measurement results are queried via GPIB, while 33 points are visible on the test set's spectrum emission mask measurement graphic.

Additional Spectrum Emission Mask Requirements

According to 3GPP TS 25.101 (v8.3.0, 2008-07), for operation in Band II, IV, V, X, XII, XIII and XIV, the out-of-channel UE emissions should satisfy both the basic requirements and the additional requirements, which are specified by the absolute power within the measurement bandwidth. For additional SEM requirements, there are 2 symmetrical ranges on each side of the carrier. These ranges are measured in a 30 kHz, 100kHz or 1 MHz bandwidth. The different bands have different range definitions (see Additional Spectrum Emission Limits for Band II, IV, X , Additional Spectrum Emission Limits for Band V , and Additional Spectrum Emission Limits for Band XII, XIII, XIV

To use the additional Spectrum Emission Mask requirements results, you must calibrate this measurement using the Calibrate Measurements procedure (see Calibrating the Test Set ).

Additional Spectrum Emission Limits for Band II, IV, X
 | Frequency Offset from carrier | Measurement Bandwidth | Minimum Requirement
Additional Range 1 | 2.5 - 3.5 MHz | 30 kHz | -15 dBm
Additional Range 2 | 3.5 - 12.5 MHz | 1 MHz | -13 dBm
Additional Spectrum Emission Limits for Band V
 | Frequency Offset from carrier | Measurement Bandwidth | Minimum Requirement
Additional Range 1 | 2.5 - 3.5 MHz | 30 kHz | -15 dBm
Additional Range 2 | 3.5 - 12.5 MHz | 100 kHz | -13 dBm
Additional Spectrum Emission Limits for Band XII, XIII, XIV
 | Frequency Offset from carrier | Measurement Bandwidth | Minimum Requirement
Additional Range 1 | 2.5 - 2.6 MHz | 30 kHz | -13 dBm
Additional Range 2 | 2.6 - 12.5 MHz | 100 kHz | -13 dBm

Spectrum Emission Mask Measurement Parameters

  • Multi-Measurement Count: (see Statistical Measurement Results ).
  • Trigger Arm: (see Trigger Arm (Single or Continuous) Description ).
  • Trigger Source

    You must specify how you want to trigger the measurement using the Trigger Source setting.

    You may set Trigger Source to the following: (for more information on these trigger types, see Trigger Source Description ).

    • Auto: if the UE is synchronized to the test set, it uses protocol triggering; otherwise, it uses immediate triggering.

    • External

    • HS-DPCCH:

      This setting is only applicable to the lab application or a feature-licensed test application.

      When Trigger Source is set to HS-DPCCH , you can specify on which uplink subframe the measurement triggers using the HS-DPCCH Trigger Subframe Alignment setting.

      Trigger Source can only be set to HS-DPCCH when Channel Type = 12.2k RMC + HSDPA or 12.2k RMC + HSPA .

    • Immediate

    • Protocol: Derived from the 10 ms downlink DPCH frame clock.

  • Trigger Delay

    You can move the start point of the in-channel and out-of-channel measurement intervals relative to the trigger using the Trigger Delay setting.

  • HS-DPCCH Trigger Subframe Alignment

    This setting is only applicable to the lab application or a feature-licensed test application.

    When Trigger Source is set to HS-DPCCH , you can specify on which uplink subframe the measurement triggers. You can then use the Trigger Delay setting to move the measurement interval relative to that subframe boundary.

  • Fail Limit Mask

    You can select whether SEM is tested for the Basic Limit Only or Basic and Additional Limits:

    • Basic: Results are returned only for ranges 1 to 4 of the basic limit
    • Basic and Additional Limit: Results are returned for range 1 to 4 and the additional range 1 to 2.

  • Measurement Timeout: (see Measurement Timeouts ).
  • Limit 30 kHz Bandwidth: +-2.5 MHz
  • Limit 30 kHz Bandwidth: +-3.5 MHz
  • Limit 1 MHz Bandwidth: +-3.5 MHz
  • Limit 1 MHz Bandwidth: +-7.5 MHz
  • Limit 1 MHz Bandwidth: +-8.5 MHz
  • Limit 1 MHz Bandwidth: +-12.5 MHz

Spectrum Emission Mask Measurement Results

  • Pass/Fail for the overall spectrum emission mask. If any out-of-channel frequency range does not comply with the standard, the entire mask fails.
  • In-channel power
  • Pass/Fail for each of the four individual frequency ranges (plus pass/fail for the two additional frequency ranges if testing for the additional requirements).
  • Power level vectors relative to in-channel power for each frequency range. These vectors contain the power measured at each frequency offset in the individual ranges. The value of each frequency offset is determined by the starting measurement position and the resolution bandwidth. For example, range 3 (7.5 MHz to 8.5 MHz) starts at 7.5 MHz and has a resolution bandwidth of 250 kHz. Therefore, relative power measurements are returned for offsets 7.5, 7.75, 8, 8.25, and 8.5 MHz from the carrier frequency.
  • Results for each frequency range. The relative power level and the frequency offset of the largest mask error, the margin of that error, and whether or not the range passed or failed the spectrum emission mask specifications are the available results.

Spectrum Emission Mask Input Signal Requirements

  • For this measurement the test set's receiver uses autoranging to adjust for the level of the signal being measured; therefore the expected signal level does not need to be specified during measurement setup.
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, 1700 MHz to 1990 MHz, or 2480 to 2580 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of +5 dBm to +28 dBm, in a 3.84 MHz bandwidth.
  • The uplink must be of constant in-channel power for the duration of this measurement. This requirement has implications for correct power control configuration, and uplink dynamics in HSDPA and HSUPA.

Spectrum Emission Mask Measurement Calibration

You must calibrate this measurement using the Calibrate Measurements procedure (see Calibrating the Test Set ).

Related Topics

  • Manual Operation: How Do I Make a Spectrum Emission Mask Measurement?
  • Programming a Spectrum Emission Mask Measurement
  • Spectrum Emission Mask Troubleshooting
  • What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator


What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?

What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?

Last updated: December 22, 2011

These tables list the tests specified in 3GPP TS 34.121, whether the tests are supported by the test set, and the recommended measurement to perform the tests.

  • 3GPP TS 34.121 Section 5 Transmitter Characteristics
  • 3GPP TS 34.121 Section 6 Receiver Characteristics
  • 3GPP TS 34.121 Section 7 Performance Requirements
  • 3GPP TS 34.121 Section 9 Performance Requirements for HSDPA
  • 3GPP TS 34.121 Section 10 Performance Requirement (E-DCH)
3GPP TS 34.121 Section 5 Transmitter Characteristics
3GPP TS 34.121 | Test Description | Supported in Test Set? | Measurement Procedure
5.2 | Maximum Output Power | Yes | How Do I Make a Thermal Power Measurement?
5.2A | Maximum Output Power with HS-DPCCH (Release 5 only) | Yes # | How Do I Make a Channel Power Measurement?
5.2AA | Maximum Output Power with HS-DPCCH (Release 6 and later) | Yes # | How Do I Make a Channel Power Measurement?
5.2B | Maximum Output Power with HS-DPCCH and E-DCH | Yes # | How Do I Make a Channel Power Measurement?
5.2C | UE Relative Code Domain Power Accuracy | Yes # | How Do I Make a Code Domain Measurement?
5.2D | UE Relative Code Domain Power Accuracy for HS-DPCCH and E-DCH | Yes # | Measuring 3GPP TS 34.121-1 (v8.10.0) 5.2D UE Relative Code Domain Power Accuracy for HS-DPCCH and E-DCH
5.2E | UE Relative Code Domain Power Accuracy for HS-DPCCH and E-DCH with 16QAM | Yes # | Measuring 3GPP TS 34.121-1 (v8.10.0) s5.2E UE Relative Code Domain Power Accuracy for HS-DPCCH and E-DCH with 16QAM
5.3 | Frequency Error | Yes | How Do I Make a Waveform Quality Measurement?
5.4.1 | Open Loop Power Control in the Uplink | Yes | How Do I Make a PRACH Transmit On/Off Power Measurement?
5.4.2 | Inner Loop Power Control in the Uplink | Partially | How Do I Make an Inner Loop Power Measurement? (does not support 3 dB step size)
5.4.3 | Minimum Output Power | Yes | How Do I Make a Channel Power Measurement? (with RRC filter OFF)
5.4.4 | Out-of-synchronization handling of output power | Yes +, ** | How Do I Make an Out-of-Synch Handling of Output Power Measurement? (Establish a connection between the test set and UE, initiate the measurement from the test set, measure the UE's output power using the spectrum analyzer)
5.5.1 | Transmit OFF Power | Yes | How Do I Make a PRACH Transmit On/Off Power Measurement?
5.5.2 | Transmit ON/OFF Time mask | Yes | How Do I Make a PRACH Transmit On/Off Power Measurement?
5.6 | Change of TFC | Yes + | How Do I Make a Change of TFC (Transport Format Combination) Measurement?
5.7 | Power setting in uplink compressed mode | No |
5.7A | HS-DPCCH | Yes # | How Do I Make a Dynamic Power Analysis Measurement?
5.8 | Occupied Bandwidth (OBW) | Yes | How Do I Make an Occupied Bandwidth (OBW) Measurement?
5.9 | Spectrum Emission Mask | Yes | How Do I Make a Spectrum Emission Mask Measurement?
5.9A | Spectrum Emission Mask with HS-DPCCH | Yes # | How Do I Make a Spectrum Emission Mask Measurement?
5.9B | Spectrum Emission Mask with E-DCH | Yes # | How Do I Make a Spectrum Emission Mask Measurement?
5.10 | Adjacent Channel Leakage Power Ratio (ACLR) | Yes | How Do I Make an Adjacent Channel Leakage Ratio (ACLR) Measurement?
5.10A | Adjacent Channel Leakage Power Ratio (ACLR) with HS-DPCCH | Yes # | How Do I Make an Adjacent Channel Leakage Ratio (ACLR) Measurement?
5.10B | Adjacent Channel Leakage Power Ratio (ACLR) with E-DCH | Yes # | How Do I Make an Adjacent Channel Leakage Ratio (ACLR) Measurement?
5.11 | Spurious Emissions | Yes** | Camp to test set, measure spurious emissions using external spectrum analyzer
5.12 | Transmit Intermodulation | Yes* , ** | Camp to the test set, inject tones using external signal generator, measure transmit intermodulation using external spectrum analyzer
5.13.1 | Error Vector Magnitude (EVM) | Yes | How Do I Make a Waveform Quality Measurement?
5.13.1A | Error Vector Magnitude (EVM) with HS-DPCCH | Yes # | How Do I Make a Waveform Quality Measurement?
5.13.1AA | Error Vector Magnitude (EVM) and Phase Discontinuity with HS-DPCCH | Yes # | How Do I Make a Phase Discontinuity Measurement?
5.13.1AAA | EVM and IQ origin offset for HS-DPCCH and E-DCH with 16 QAM | Yes # | Measuring 3GPP TS 34.121-1 (v8.10.0) s5.13.1AAA EVM and IQ origin offset for HS-DPCCH and E-DCH with 16 QAM
5.13.2 | Peak code domain error | Partially | How Do I Make a Waveform Quality Measurement? (only for a single DPCH)
5.13.2A | Relative Code Domain Error with HS-DPCCH | Yes # | How Do I Make a Code Domain Measurement?
5.13.2B | Relative Code Domain Error with HS-DPCCH and E-DCH | Yes # | How Do I Make a Code Domain Measurement?
5.13.2C | Relative Code Domain Error for HS-DPCCH and E-DCH with 16QAM | Yes # | Measuring 3GPP TS 34.121-1 (v8.10.0) s5.13.2C Relative Code Domain Error for HS-DPCCH and E-DCH with 16QAM
5.13.3 | UE Phase Discontinuity | Yes | How Do I Make a Phase Discontinuity Measurement?
5.13.4 | PRACH Preamble Quality | Partially + | How Do I Make a PRACH Preamble Analysis Measurement? (measurement is not performed on first preamble, AICH transmission timing is fixed to 0, measurement does not determine if correct access slot was used)
3GPP TS 34.121 Section 6 Receiver Characteristics
3GPP TS 34.121 | Test Description | Supported in Test Set? | Measurement Procedure
6.2 | Reference Sensitivity Level | Yes | How Do I Make a Loopback Bit Error Ratio (BER) Measurement?
6.2A | Reference Sensitivity Level for DC-HSDPA | Yes # |
6.3 | Maximum Input Level | Yes | How Do I Make a Loopback Bit Error Ratio (BER) Measurement?
6.3A | Maximum Input Level for HS-PDSCH Reception (16QAM) | Yes # | Measuring 3GPP TS 34.121-1 6.3A Maximum Input Level for HS-PDSCH Reception (16QAM)
6.3B | Maximum Input Level for HS-PDSCH Reception (64QAM) | Yes # | Measuring 3GPP TS 34.121-1 6.3B Maximum Input Level for HS-PDSCH Reception (64QAM)
6.3C | Maximum Input Level for DC-HSDPA Reception (16QAM) | Yes # | Measuring 3GPP TS 34.121-1 6.3C Maximum Input Level for DC-HSDPA Reception (16QAM)
6.3D | Maximum Input Level for DC-HSDPA Reception (64QAM) | Yes # | Measuring 3GPP TS 34.121-1 6.3D Maximum Input Level for DC-HSDPA Reception (64QAM)
6.4 | Adjacent Channel Selectivity (ACS) (Rel-99 and Rel-4) | Yes* | How Do I Make a Loopback Bit Error Ratio (BER) Measurement? (plus W-CDMA signal from a signal generator)
6.4A | Adjacent Channel Selectivity (ACS) (Rel-5 and later releases) | Yes* | How Do I Make a Loopback Bit Error Ratio (BER) Measurement? (plus W-CDMA signal from a signal generator)
6.4B | Adjacent channel selectivity (ACS) for DC-HSDPA | Yes* |
6.5 | Blocking Characteristics | Yes* | How Do I Make a Loopback Bit Error Ratio (BER) Measurement? (plus W-CDMA signal from a signal generator)
6.5A | Blocking characteristics for DC-HSDPA | Yes* |
6.6 | Spurious Response | Yes* | How Do I Make a Loopback Bit Error Ratio (BER) Measurement? (plus a CW signal from a signal generator)
6.6A | Spurious response for DC+HSDPA | Yes* |
6.7 | Intermodulation Characteristics | Yes* | How Do I Make a Loopback Bit Error Ratio (BER) Measurement? (plus 2 CW signals from signal generators)
6.7A | Intermodulation characteristics for DC-HSDPA | Yes* |
6.8 | Spurious Emissions | Yes** | Camp to test set, measure spurious emissions using external spectrum analyzer
3GPP TS 34.121 Section 7 Performance Requirements
3GPP TS 34.121 | Test Description | Supported in Test Set? | Measurement Procedure
7.2.1 | Demodulation in Static Propagation Conditions: Demodulation of Dedicated Channel (DCH) | Yes | How Do I Make a Block Error Ratio (BLER) Measurement?
7.3.1 | Demodulation of DCH in Multi-Path Fading Propagation Conditions: Single Link Performance | Partially +, *** | How Do I Make a Block Error Ratio (BLER) Measurement? (plus multi-path fading simulator and external AWGN noise source) (only for tests with phase reference = P-CPICH)
7.4.1 | Demodulation of DCH in Moving Propagation Conditions: Single Link Performance | Yes +, *** | How Do I Make a Block Error Ratio (BLER) Measurement? (plus multi-path fading simulator and external AWGN noise source)
7.5.1 | Demodulation of DCH in Birth-Death Propagation Conditions: Single Link Performance | Yes +, *** | How Do I Make a Block Error Ratio (BLER) Measurement? (plus multi-path fading simulator and external AWGN noise source)
7.5.1A | Demodulation of DCH in high speed train condition | Yes +, *** | How Do I Make a Block Error Ratio (BLER) Measurement? (plus multi-path fading simulator and external AWGN noise source)
7.6.1 | Demodulation of DCH in Open-Loop Transmit Diversity Mode | No |
7.6.2 | Demodulation of DCH in Closed Loop Transmit Diversity Mode | No |
7.6.3 | Demodulation of DCH in Site Selection Diversity Transmission Power Control Mode | No |
7.7.1 | Demodulation of DCH in Inter-Cell Soft Handover | Yes +, *** |
7.7.1A | Demodulation of DCH in Inter-Cell Soft Handover (Release 6 and later) | Yes +, *** |
7.7.2 | Combining of TPC Commands from Radio Links of Different Radio Link Sets | No |
7.7.3 | Combining of Reliable TPC Commands from Radio Links of Different Radio Link Sets | No |
7.8.1 | Power Control in the Downlink, Constant BLER Target | No |
7.8.1A | Power control in the downlink, constant BLER target (Release 6 and later) | Yes |
7.8.2 | Power Control in the Downlink, Initial Convergence | No |
7.8.3 | Power Control in the Downlink, Wind Up Effects | No |
7.8.3A | Power control in the downlink, wind up effects (Release 6 and later) | Yes |
7.8.4 | Power Control in the Downlink, Different Transport Formats | Yes |
7.8.5 | Power control in the downlink for F-DPCH | No |
7.9.1 | Downlink Compressed Mode: Single Link Performance | No |
7.9.1A | Single link performance (Release 6 and later) | Yes |
7.10 | Blind Transport Format Detection | No |
7.11 | Demodulation of Paging Channel (PCH) | No |
7.12 | Detection of Acquisition Indicator (AI) | No |
7.13 | UE UL power control operation with discontinuous UL DPCCH transmission operation | No |
3GPP TS 34.121 Section 9 Performance Requirements for HSDPA
3GPP TS 34.121 | Test Description | Supported in the Test Set? | Measurement Procedure
9.2.1A | Demodulation of HS-DSCH (Fixed Reference Channel): Single Link Performance - QPSK/16QAM, FRC H-Set 1/2/3 | Yes +, *** | How Do I Make an HSDPA Block Error Ratio Measurement? (plus multi-path fading simulator and external AWGN noise source)
9.2.1B | Demodulation of HS-DSCH (Fixed Reference Channel): Single Link Performance - QPSK, FRC H-Set 4/5 | Yes +, *** | How Do I Make an HSDPA Block Error Ratio Measurement? (plus multi-path fading simulator and external AWGN noise source)
9.2.1C | Demodulation of HS-DSCH (Fixed Reference Channel): Single Link Performance - QPSK/16QAM, FRC H-Set 6/3 | Yes +, *** | How Do I Make an HSDPA Block Error Ratio Measurement? (plus multi-path fading simulator and external AWGN noise source)
9.2.1D | Demodulation of HS-DSCH (Fixed Reference Channel): Single Link Performance - Enhanced Performance Requirements Type 1 - QPSK/16QAM, FRC H-Set 1/2/3 | Yes +, *** | How Do I Make an HSDPA Block Error Ratio Measurement? (plus multi-path fading simulator and external AWGN noise source)
9.2.1E | Demodulation of HS-DSCH (Fixed Reference Channel): Single Link Performance - Enhanced Performance Requirements Type 1 - QPSK/16QAM, FRC H-Set 6/3 | Yes +, *** | How Do I Make an HSDPA Block Error Ratio Measurement? (plus multi-path fading simulator and external AWGN noise source)
9.2.1F | Demodulation of HS-DSCH (Fixed Reference Channel): Single Link Performance - Enhanced Performance Requirements Type 2 - QPSK/16QAM, FRC H-Set 6/3 | Yes +, *** | How Do I Make an HSDPA Block Error Ratio Measurement? (plus multi-path fading simulator and external AWGN noise source)
9.2.1FA | Single Link Performance - Enhanced Performance Requirements Type 2 - QPSK/16QAM, Fixed Reference Channel (FRC) H-Set 6A/3A | Yes +, *** |
9.2.1G | Single Link Performance - Enhanced Performance Requirements Type 3 - QPSK/16QAM, Fixed Reference Channel (FRC) H-Set 6/3 | Yes +, *** | How Do I Make an HSDPA Block Error Ratio Measurement? (plus multi-path fading simulator and external AWGN noise source)
9.2.1GA | Single Link Performance - Enhanced Performance Requirements Type 3 - QPSK/16QAM, Fixed Reference Channel (FRC) H-Set 6A/3A | Yes +, *** |
9.2.1H | Single Link Performance - Enhanced Performance Requirements Type 2 - 64QAM, Fixed Reference Channel (FRC) H-Set 8 | Yes +, *** | How Do I Make an HSDPA Block Error Ratio Measurement? (plus multi-path fading simulator and external AWGN noise source)
9.2.1HA | Single Link Performance - Enhanced Performance Requirements Type 2 - 64QAM, Fixed Reference Channel (FRC) H-Set 8A | Yes +, *** |
9.2.1I | Single Link Performance - Enhanced Performance Requirements Type 3 - 64QAM, Fixed Reference Channel (FRC) H-Set 8 | Yes +, *** | How Do I Make an HSDPA Block Error Ratio Measurement? (plus multi-path fading simulator and external AWGN noise source)
9.2.1IA | Single Link Performance - Enhanced Performance Requirements Type 3 - 64QAM, Fixed Reference Channel (FRC) H-Set 8A | Yes +, *** |
9.2.1J | Single Link Performance - Enhanced Performance Requirements Type 2 - QPSK/16QAM, Fixed Reference Channel (FRC) H-Set 10 | Yes +, *** | How Do I Make an HSDPA Block Error Ratio Measurement? (plus multi-path fading simulator and external AWGN noise source)
9.2.1JA | Single Link Performance - Enhanced Performance Requirements Type 2 - QPSK/16QAM, Fixed Reference Channel (FRC) H-Set 10A | Yes +, *** |
9.2.1K | Single Link Performance - Enhanced Performance Requirements Type 3 - QPSK/16QAM, Fixed Reference Channel (FRC) H-Set 10 | Yes +, *** | How Do I Make an HSDPA Block Error Ratio Measurement? (plus multi-path fading simulator and external AWGN noise source)
9.2.1KA | Single Link Performance - Enhanced Performance Requirements Type 3 - QPSK/16QAM, Fixed Reference Channel (FRC) H-Set 10A | Yes +, *** |
9.2.1LA | Enhanced Performance Requirements Type 3i - QPSK, Fixed Reference Channel (FRC) H-Set 6A | Yes +, *** |
9.2.2 | Open Loop Diversity Performance | No |
9.2.3 | Closed Loop Diversity Performance | No |
9.3.1 | Reporting of CQI: Single Link Performance - AWGN Propagation Conditions | Yes+ | HSDPA Reporting of Channel Quality Indicator Measurement Description
9.3.1A | Reporting of CQI: Single Link Performance - AWGN Propagation Conditions, 64QAM | Yes+ | HSDPA Reporting of Channel Quality Indicator Measurement Description
9.3.1B | Single Link Performance - AWGN Propagation Conditions, DC-HSDPA requirements | No |
9.3.2 | Reporting of CQI: Single Link Performance - Fading Propagation Conditions | No |
9.3.2A | Single Link Performance - Fading Propagation Conditions, DC-HSDPA requirements | No |
9.3.3 | Reporting of CQI: Open Loop Diversity Performance - AWGN Propagation Conditions | No |
9.3.4 | Reporting of CQI: Open Loop Diversity Performance - Fading Propagation Conditions | No |
9.3.5 | Reporting of CQI: Closed Loop Diversity Performance - AWGN Propagation Conditions | No |
9.3.6 | Reporting of CQI: Closed Loop Diversity Performance - Fading Propagation Conditions | No |
9.3.7 | MIMO Performance - Reporting of Channel Quality Indicator | No |
9.4.1 | HS-SCCH Detection Performance: Single Link Performance | Yes +, *** | How Do I Make an HSDPA Block Error Ratio Measurement? (plus multi-path fading simulator and external AWGN noise source) (HS-SCCH 2-4 all use the same Alternate H-RNTI )
9.4.1A | HS-SCCH Detection Performance: Single Link Performance - Enhanced Performance Requirements Type 1 | Partially +, *** | How Do I Make an HSDPA Block Error Ratio Measurement? (plus multi-path fading simulator and external AWGN noise source) (HS-SCCH 2-4 all use the same Alternate H-RNTI )
9.4.2 | HS-SCCH Detection Performance: Open Loop Diversity Performance | No |
9.4.2A | HS-SCCH Detection Performance: Open Loop Diversity Performance - Enhanced Performance Requirements Type 1 | No |
9.4.3 | HS SCCH Detection Performance: HS-SCCH Type 3 Performance | No |
9.5 | HS-SCCH-less demodulation of HS-DSCH (Fixed Reference Channel) | No |
3GPP TS 34.121 Section 10 Performance Requirement (E-DCH)
3GPP TS 34.121 | Test Description | Supported in the Test Set? | Measurement Procedure
10.2.1.1 | Detection of E-DCH HARQ ACK Indicator Channel (E-HICH): Single Link Performance (10 ms TTI) | Yes+ |
10.2.1.2 | Detection of E-DCH HARQ ACK Indicator Channel (E-HICH): Single Link Performance (2 ms TTI) | Yes+ |
10.3.1.1 | Detection of E-DCH Relative Grant Channel (E-RGCH): Single Link Performance (10 ms TTI) | Yes+ |
10.3.1.2 | Detection of E-DCH Relative Grant Channel (E-RGCH): Single Link Performance (2 ms TTI) | Yes+ |
10.4.1 | Demodulation of E-DCH Absolute Grant Channel (E-AGCH): Single Link Performance | Yes+ |

+ This test is supported in the lab application only.

# This test is supported in the lab application or feature-licensed test application only.

* Requires also an external signal generator, such as the E4438C ESG Vector Signal Generator.

** Requires also an external spectrum analyzer, such as the E4445A PSA Spectrum Analyzer.

*** Requires also a multi-path fading simulator and external AWGN source, such as the N5115B Fading Solution.

Related Topics

3GPP Compliance


Thermal Power Measurement Description

Thermal Power Measurement Description

Last updated: January 16, 2009

How is a thermal power measurement made?

Thermal power is a broadband, unfiltered measurement that measures all power present at the test set's RF IN/OUT connector using a thermal detector. Because of its high accuracy when measuring power up to +28 dBm, this is the preferred measurement to use for higher power measurements, such as the Maximum Output Power test (3GPP TS 34.121, section 5.2, v3.2.0).

The 3GPP standard specifies that this measurement be made over at least 1 timeslot (667 µs). The implementation of this measurement in the test set measures over 10 ms with the UE in power control algorithm 2.

The thermal power measurement automatically zeroes itself for each measurement; no other calibration is required. To meet specified performance, the test set must be operated in the temperature range of 20° C to 55° C.

The thermal power measurement is not as fast as the channel power measurement, and is not intended to measure signal levels below -10 dBm. Use the channel power measurement to measure power levels from -11 dBm to -61 dBm, or when maximum measurement speed is required. See Channel Power Measurement Description .

Trigger Source

No synchronization between the test set and the mobile station (UE) is needed, so immediate triggering is always used for this measurement. No trigger delay is available.

Differences in Thermal Power and Channel Power Measurement Results

Because the thermal power measurement is an unfiltered measurement, its results are typically about 0.25 dB higher than the filtered channel power measurement results.

Input Signal Requirements

  • For this measurement the test set's receiver uses auto-ranging to adjust for the level of the signal being measured; therefore the expected signal level does not need to be specified during measurement setup.
  • For specified accuracy, the frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, 1700 MHz to 1990 MHz, or 2480 MHz to 2580 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of -10 dBm to +28 dBm for greatest accuracy (although signals can be measured down to -20 dBm with degraded accuracy).
  • This measurement is unfiltered, so all signals present at the RF IN/OUT connector affect the measurement results.

Related Topics

Manual Operation: How Do I Make a Thermal Power Measurement?

Programming a Thermal Power Measurement

Thermal Power Troubleshooting

Statistical Measurement Results

Triggering of Measurements

What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?


Verifying the Test Set

Verifying the Test Set

Last updated: January 16, 2009

Description

  • Self Test
  • Thermal Power Null Adjustment

If you are experiencing problems with your test set, first ensure that you have performed the recommended calibrations (see the "Calibrating the Test Set" topic in the Related Topics below). If you are still experiencing problems, run the following verifications to determine if a hardware failure has occurred in your test set.

Self Test

The Self Test verification checks the integrity of the test set's RF Interface module.

You do not have to perform the Self Test verification from each application/format in your test set; performing it from one application/format verifies the test set's RF Interface module.

To initiate the Self Test verification from the front panel, press the SYSTEM CONFIG key, press the right More ( 1 of 2 ) key, and select Self Test ( F8 ). To initiate the Self Test verification from a remote program, use the *TST? query (see the "IEEE 488.2 Common Commands" topic in the Related Topics below).

The Self Test verification takes approximately 30 seconds to execute, and returns 0 (pass) or -330 (fail).

Thermal Power Null Adjustment

The Thermal Power Null Adjustment is described in detail in the "Calibrating the Test Set" topic in the Related Topics below. The Thermal Power Null Adjustment is a periodic calibration that you must perform on your test set. However, if you are experiencing problems with your test set, you can also use the Thermal Power Null Adjustment to ensure that your test set's Thermal Power Detector auto-null circuit has not drifted such that it is no longer able to null the power detector. If this occurs, the Thermal Power Null Adjustment returns a 1 (fail).

Related Topics

Calibrating the Test Set


Block Error Ratio (BLER) Measurement Description

Block Error Ratio (BLER) Measurement Description

Last updated: January 16, 2009

  • How is a Block Error Ratio Measurement Made?
  • Block Error Ratio Measurement Parameters
  • Block Error Ratio Measurement Results
  • Block Error Ratio Input Signal Requirements

How is a Block Error Ratio Measurement Made?

3GPP TS 34.121, F.6.1.1 defines block error ratio (BLER) as follows: "A Block Error Ratio is defined as the ratio of the number of erroneous blocks received to the total number of blocks sent. An erroneous block is defined as a Transport Block, the cyclic redundancy check (CRC) of which is wrong."

To perform a block error ratio measurement, you must be on a Radio Bearer Test Mode call. The block error ratio measurement can be performed for both Symmetrical RMCs and Asymmetrical RMCs . For RMCs with a downlink rate of 12.2, 64 or 144 kbps, the test set sends a block every 20 ms. For RMCs with a downlink rate of 384 kbps, the test set sends a block every 10 ms.

The data sent on the downlink is determined by the DL DTCH Data setting.

Symmetrical RMCs

For Symmetrical RMCs (which use Transparent Mode (TM) RLC entities on the DTCH), the test set measures block error ratio by sending data and CRC bits in the downlink transport blocks to a UE that is configured in loopback mode 2 ( UE Loopback Type must be set to Type 2 ). The UE then loops the data bits and CRC bits from the downlink transport blocks into the uplink transport blocks and transmits them in the uplink. The test set then generates a CRC from the data bits received in the uplink transport block and compares this calculated CRC against the CRC received in the uplink transport block (this CRC is the downlink CRC for the downlink transport block, looped back up by the UE). If the CRCs do not match, the transport block is defined to be a "block error."

To perform the block error ratio measurement for symmetrical RMCs, Uplink DTCH RMC CRC Presence must be set to Used for Data . This disables the uplink CRC, to allow room for the UE to loop back the downlink CRC for each block (there are an equal number of available bits in the uplink and downlink, if the UE were to transmit an uplink CRC, it would not be able to loop back the downlink CRC).

Asymmetrical RMCs

For Asymmetrical RMCs (which use Acknowledged Mode (AM) RLC entities on the DTCH), the test set increments the Block Error Count when it receives a retransmission request from the UE. (The UE generates a CRC from the data bits received in the downlink transport block, and compares this calculated CRC against the CRC received in the downlink transport block. If the CRCs do not match, the UE sends a retransmission request to the test set.)

UE Control During FDD Test Mode Operation

The FDD Test Operating Mode does not provide radio bearer setup control of the UE for test mode operation. You must configure the UE in loopback mode 2 and synchronize it to the test set's downlink signal in order to make this measurement in FDD test operating mode.

The uplink transport format must include both the DTCH and the DCCH; however, only the DTCH information is used for the block error ratio measurement.

Note that Asymmetrical RMCs are not available in FDD test operating mode.

Block Error Ratio Measurement Parameters

  • Number of Blocks to Test

    Sets the number of blocks to test during the measurement.

    Note, the time for the measurement to complete increases linearly with the Number of Blocks to Test . For example, to test 500 blocks while on a 12.2k RMC takes approximately 10 seconds (500 blocks x 20 ms/block = 10 seconds).

  • Trigger Arm - see Trigger Arm (Single or Continuous) Description .
  • Measurement Timeout

    See Measurement Timeouts . Ensure that the Measurement Timeout is greater than the time the measurement needs to measure the desired Number of Blocks to Test .

  • Uplink DTCH RMC CRC Presence
  • UE Loopback Type

The trigger source for this measurement is always protocol-based (see Trigger Source Description ).

Block Error Ratio Measurement Results

  • Integrity Indicator
  • Block Error Ratio

    The ratio of incorrectly received blocks to the total blocks sent to the UE, expressed as a percentage (%).

  • Block Error Count

    The number of incorrectly received blocks, or "block errors".

  • Blocks Tested

    Number of blocks tested to determine the Block Error Ratio and Block Error Count results.

    Note, you set the number of blocks to test during the measurement using the Number of Blocks to Test setting. However, for Asymmetrical RMCs , the actual number of Blocks Tested may be greater than the Number of Blocks to Test . For asymmetrical RMCs, every 200 ms the UE indicates to the test set whether the blocks received in the last 200 ms period were received correctly or if any retransmissions are required. Depending upon the alignment of this 200 ms measurement period with the TTI boundary, and depending upon how many blocks are sent every 200 ms (based on data rate), it is quite likely that the UE will provide acknowledgment/retransmission information for more blocks than requested by the Number of Blocks to Test setting. These extra blocks are included in the Blocks Tested , Block Error Ratio and Block Error Count results.

  • Uplink Missing Blocks

    The UE sends a TFCI for each uplink DTCH transport block. When operating in Active Cell Operating Mode , the test set monitors the uplink TFCI, and can report uplink missing blocks. For Symmetrical RMCs , if the TFCI indicates that there is no data block sent for that TTI, the test set reports a missing block. When an uplink missing block occurs, no block comparison is done on the block, and the number of Blocks Tested is not incremented. The test set returns a Questionable MS-to-Cell Data Integrity Indicator .

    The Uplink Missing Blocks result does not apply to Asymmetrical RMCs , because data is not returned on the uplink, only periodic status reports.

    When in FDD Test Operating Mode , the test set does not monitor the uplink TFCI; rather, it assumes that a data block is sent in every TTI. Thus, errors resulting from uplink missing blocks are included in the Block Error Count result when in FDD test operating mode.

Block Error Ratio Input Signal Requirements

  • The expected power into the test set must be set in order to maintain the link with the UE. This is done using the UE Target Power setting or by using manual receiver power control and specifying the expected power level. See Receiver Control .

  • Frequency: 800 to 1000 MHz, 1700 to 1990 MHz
  • Input level: -61 dBm to +28 dBm

Related Topics

Manual Operation: How Do I Make a Block Error Ratio (BLER) Measurement?

Programming a Block Error Ratio Measurement

Block Error Ratio Troubleshooting

HSDPA Block Error Ratio Measurement Description

Loopback Bit Error Ratio (BER) Measurement Description

What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?


Change of TFC (Transport Format Combination) Measurement Description

Change of TFC (Transport Format Combination) Measurement Description

Last updated: January 16, 2009

This section is only applicable to the lab application.

  • How is a Change of TFC Measurement Made?
  • Change of TFC Measurement Parameters
  • Change of TFC Measurement Results
  • Change of TFC Measurement Input Signal Requirements
  • Change of TFC Measurement Calibration

How is a Change of TFC Measurement Made?

When a UE changes its TFC, it must change its output power in accordance with any resulting change in data rate. The 3GPP TS 34.121 5.6 Change of TFC test addresses the case of an uplink 12.2k RMC operating in DTX (Discontinuous Transmission) mode, wherein the DPDCH is periodically turned off. The test confirms that the UE's output power level changes properly when its DPDCH is turned off.

The change of TFC measurement requires an RB Test Mode connection between the test set and UE, in either loopback mode 1 or 2. When the measurement is initiated, the test set stops sending a constant stream of data (to be looped back by the UE), and instead sends a block of data, then a block of no data, repeatedly. This causes the UE to turn its DPDCH on and off on a block-by-block basis. The test set monitors the uplink TFCI and the change of TFC measurement is triggered when the TFCI indicates no data is present on the DPDCH (the DPDCH is thus off for that block). The test set then measures the mean power in the timeslot before and after the transition from DPDCH on to DPDCH off, and before and after the transition from DPDCH off to DPDCH on. The power measurements do not include the transient periods of 25 us on either side of the timeslot boundaries. Thus, the measurement interval is 2368 chips, or 617 us. The measurement then reports the step change in power ( [image] P as described in 3GPP TS 34.121 5.6) for both transitions (see Step Down Relative Power (in dB) and Step Up Relative Power (in dB) ).

3GPP TS 34.121 5.6.2 Transmit template during DTX

Required Initial Conditions

Before performing the change of TFC measurement, you must:

  • Set Operating Mode to Active Cell Operating Mode .
  • Establish a Radio Bearer Test Mode connection. Note, this measurement is not supported on HSDPA or HSPA connections.
  • Set Uplink Dummy DCCH Data to Off .
  • Ensure that the initial output level of your UE is such that its output power level with DPDCH on and off falls within the measurement's required input level (see Change of TFC Measurement Input Signal Requirements ).

Recommended Initial Conditions

The following settings are recommended based on the 3GPP TS 34.121 5.6 requirements:

  • UE Target Power = 0 dBm .
  • UL CL Power Control Mode = Alternating bits .
  • UL CL Power Ctrl Algorithm = Two .
  • Uplink DPCH Bc/Bd Control = Auto . This ensures that [image] and [image] are (automatically) set to the values specified by the standards (for example, 0.5333 and 1.0 for 12.2k RMC).

No other measurements can be running when a change of TFC measurement is performed. If any measurements are running when a change of TFC measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while a change of TFC measurement is running, the change of TFC measurement is closed and a message is displayed.

Change of TFC Measurement Parameters

  • Multi-Measurement Count

    See Statistical Measurement Results . When multi-measurement count is on, the test set measures the mean power in the timeslot before and after the transition from DPDCH on to DPDCH off, and before and after the transition from DPDCH off to DPDCH on, and then repeats for the next available DPDCH on/off/on transition until the requested number of samples has been taken.

  • Measurement Timeout

    See Measurement Timeouts .

The following four parameters can be independently set for the 12.2k RMC, 33k No Coding RMC, 64k RMC, 144k RMC and 384k RMCs:

  • Step Down Size

    You can specify the expected step down change in power for each RMC. Step Down Pass/Fail is determined using this Step Down Size setting and the Step Error Limit: Upper and Step Error Limit: Lower settings.

  • Step Up Size

    You can specify the expected step up change in power for each RMC. Step Up Pass/Fail is determined using this Step Up Size setting and the Step Error Limit: Upper and Step Error Limit: Lower settings.

  • Step Error Limit: Upper

    You can specify the upper limit for the difference between the expected Step Down Size or Step Up Size and the measured step change in power for each RMC. Step Down Pass/Fail and Step Up Pass/Fail are determined using this Step Error Limit: Upper setting and the Step Error Limit: Lower setting.

  • Step Error Limit: Lower

    You can specify the lower limit for the difference between the expected Step Down Size or Step Up Size and the measured step change in power for each RMC. Step Down Pass/Fail and Step Up Pass/Fail are determined using the Step Error Limit: Upper setting and this Step Error Limit: Lower setting.

Change of TFC Measurement Results

  • Step Down Relative Power (in dB)

    The Step Down Relative Power is the mean power while the DPDCH is off minus the mean power while the DPDCH is on, for an on-to-off transition.

  • Step Down Error (in dB)

    The Step Down Error is the difference between the measured Step Down Relative Power (in dB) and the Step Down Size setting. If Multi-Measurement Count is on, the error of the greatest magnitude is reported.

  • Step Down Pass/Fail

    Fail is returned if Step Down Error (in dB) is greater than Step Error Limit: Upper or less than Step Error Limit: Lower .

    Pass is returned if Step Down Error (in dB) is less than or equal to Step Error Limit: Upper and greater than or equal to Step Error Limit: Lower .

  • Step Up Relative Power (in dB)

    The Step Up Relative Power is the mean power while the DPDCH is on minus the mean power while the DPDCH is off, for an off-to-on transition.

  • Step Up Error (in dB)

    The Step Up Error is the difference between the measured Step Up Relative Power (in dB) and the Step Up Size setting. If Multi-Measurement Count is on, the error of the greatest magnitude is reported.

  • Step Up Pass/Fail

    Fail is returned if Step Up Error (in dB) is greater than Step Error Limit: Upper or less than Step Error Limit: Lower .

    Pass is returned if Step Up Error (in dB) is less than or equal to Step Error Limit: Upper and greater than or equal to Step Error Limit: Lower .

Change of TFC Measurement Input Signal Requirements

  • Frequency: 800 to 1000 MHz, 1700 to 1990 MHz, or 2480 MHz to 2580 MHz.
  • Input level: -61 dBm to +28 dBm.
  • Step change in power when transitioning between DPDCH off and on states must not exceed 15 dB.

Change of TFC Measurement Calibration

You must calibrate this measurement using the measurement calibration procedure (see Calibrating the Test Set ).

Related Topics

Manual Operation: How Do I Make a Change of TFC (Transport Format Combination) Measurement?

Programming a Change of TFC (Transport Format Combination) Measurement

Change of TFC (Transport Format Combination) Troubleshooting

What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?

Triggering of Measurements

Integrity Indicator


Dynamic Power Analysis Measurement Description

Dynamic Power Analysis Measurement Description

Last updated: January 16, 2009

  • How is a Dynamic Power Analysis Measurement Made?
    • UE Power Calibration
    • HSDPA/HSPA Power versus Time (lab application or feature-licensed test application only)
  • Dynamic Power Analysis Measurement Parameters
  • Dynamic Power Analysis Measurement Results
  • Dynamic Power Analysis Measurement Input Signal Requirements
  • Dynamic Power Analysis Measurement Calibration

How is a Dynamic Power Analysis Measurement Made?

The dynamic power analysis measurement is a flexible tool that allows you to measure the output power of your UE versus time. This section describes two main uses of the measurement:

  • UE Power Calibration
  • HSDPA/HSPA Power versus Time (lab application or feature-licensed test application only)

UE Power Calibration

The dynamic power analysis measurement is not performed with a call established between the test set and UE. Rather, you must place your UE into a test mode which forces it to continuously transmit the power sequence you desire to test, and then analyze the resulting UE output power using the test set.

The dynamic power analysis measurement can measure UE output power sequences that step up and/or down with varying or fixed power step sizes. The power step length, which must be fixed for the sequence, can be between 10 us and 12 ms (the measurement is specified for step lengths of 67 us to 12 ms). A total of 58.26 ms of power sequence can be analyzed (for example, up to 87 steps can be measured when Step Length is set to one timeslot (666.7 us)).

NOTE
The test set can measure power between -61 dBm and +28 dBm, but the power sequence must not span more than 35 dB when RRC Filter = Off or 40 dB when RRC Filter = On . To measure a power range greater than 40 dB, you must break the power range up into individual power sequences that do not exceed 40 dB, and perform the measurement for each power sequence.

To use the measurement, you must first set Measurement Frequency to the expected UE transmitter frequency and set Manual Power to the maximum expected power for the sequence. You can perform the dynamic power analysis measurement in Active Cell Operating Mode or FDD Test Operating Mode . However, since this measurement does not utilize any overhead signalling to control the UE's power or frequency, you must manually set the test set's Expected Power and Measurement Frequency in either operating mode.

You must specify the length and number of steps in the sequence (including trigger pulses), configure the RF rise trigger, initiate the measurement, then order the UE to send its sequence continuously .

The measurement executes most efficiently if the UE transmits its power sequence continuously, until the measurement has completed. The measurement can be triggered externally or by an RF rise in the power sequence. Once triggered, the measurement captures the first power sequence, auto-ranges to the maximum power of the sequence, then triggers on and measures the next available power sequence. The time for the auto-ranging to complete varies depending upon the power sequence.

NOTE
It is important that the UE continuously transmit its power sequence so that a power sequence is available for the test set to measure as soon as it has completed its auto-ranging.

You can vary the Measurement Interval and its placement within each step (using the Trigger Delay setting), and insert or remove the RRC Filter . The measurement can analyze CW signals and uplink DPCH signals (when measuring CW signals, you must adjust the RF Rise Trigger Threshold setting accordingly and use the Frequency Offset setting to set the proper offset from the Measurement Frequency setting.)

Triggering the Dynamic Power Analysis Measurement for UE Power Calibration

You can trigger the dynamic power analysis measurement using an RF rise within the power sequence by setting Trigger Source to RF Rise and specifying the appropriate RF Rise Trigger Threshold . If your power sequence starts with an abrupt rise in power, no separate trigger pulse is needed. However, for the most robust triggering, it is recommended that you include a trigger pulse in every power sequence. The trigger pulse should rise in power by at least 20 dB, reach the maximum power of the sequence, then fall in power by at least 20 dB. Before initiating the measurement, you must set Power Control to Manual and set Manual Power to the highest power expected in the sequence. It is then recommended that RF Rise Trigger Threshold be set to approximately 10 dB below the expected maximum power.

It is recommended that you also use trigger qualification, which allows you to further define the measurement trigger. Instead of the measurement triggering when the UE's signal simply rises above the RF Rise Trigger Threshold value, you can specify that the signal must meet some additional criteria before the measurement is triggered. To use trigger qualification, set Trigger Qualification State to On and set Trigger Qualification Type to RF Rise , RF Fall or RF Rise and Fall as appropriate for your power sequence. You must then set Trigger Qualification Rise Threshold and/or Trigger Qualification Fall Threshold accordingly. It is recommended that these rise/fall criteria be at least 10 dB.

Trigger Recommendations for UE Power Calibration

Auto-ranging in the Dynamic Power Analysis Measurement for UE Power Calibration

To ensure successful auto-ranging, you must set the Steps setting equal or greater than the number of steps in the power sequence (including trigger pulses). When the measurement is triggered, the test set captures data for the time period specified by the Steps and Step Length setting to determine the power range of the sequence. It then ranges its receivers to accommodate the highest power in the sequence. The time for this auto-ranging to complete varies depending upon the number of steps in the sequence; a typical duration is approximately 500 ms (note that this is much greater than the duration of one power sequence). Once it has completed this auto-ranging, the test set re-arms and then is triggered by the next available power sequence. It then analyzes and reports the power of each step in that power sequence.

The measurement is most accurate over a 40 dB range (when RRC Filter = On ). If the UE's power sequence spans more than 40 dB, the test set will measure and report the power of the entire sequence, but accuracy is degraded for steps that are more than 40 dB below the highest power in the sequence. To measure a power range greater than 40 dB, you must break the power range up into individual power sequences that do not exceed 40 dB.

To ensure that the measurement executes as quickly as possible, the UE should transmit its power sequence continuously until the measurement completes. This ensures that as soon as the measurement is done auto-ranging, another power sequence is immediately available for measurement.

Measurement Auto-ranging

NOTE
If the power range of the subsequent power sequence does not closely match that of the power sequence used to auto-range, instead of reporting measurement results, the measurement attempts to auto-range again. This could occur if the "Steps" setting is less than the number of steps in the sequence, the UE's signal was noisy, or if a false trigger occurred.

Optimizing the Dynamic Power Analysis Measurement for UE Power Calibration

To help ensure your measurement routine executes as fast as possible, consider the following:

  • Ensure that the UE is continuously repeating its power sequence.
  • Use RF rise triggering, include a trigger pulse in the power sequence, and use trigger qualification to avoid false triggering.
  • Make the trigger pulse equal to the maximum power in the sequence, to best utilize the 40 dB dynamic range of the measurement.
  • Minimize the space between consecutive sequences (one step of space is sufficient).
  • Note that a noisy UE signal may force the measurement to auto-range repeatedly.

HSDPA/HSPA Power versus Time ( lab application or feature-licensed test application only )

To perform power versus time measurements on an HSDPA or HSPA uplink signal, you must be on a Radio Bearer Test Mode connection with a Channel Type of 12.2k RMC + HSDPA or 12.2k RMC + HSPA.

Dynamic Power Analysis Measurement Parameters

The dynamic power analysis measurement can capture up to 58.26 ms of power signal. Thus, the product of Steps and Step Length must not exceed 58.26 ms.

Specifying the Measurement Duration

  • Steps

    You must specify the total number of steps to be measured.

    The time duration of each step is determined by Step Length . If Step Length is set to 666.666... us, then the number of Steps to measure is equivalent to the number of timeslots to measure.

    For UE power calibration: the number of steps to measure must include any trigger pulses or separation steps included in the UE's power sequence. It is important that you set Steps equal or greater than the number of steps in your UE's power sequence so that the entire power sequence is evaluated during auto-ranging of the measurement (see Auto-ranging in the Dynamic Power Analysis Measurement for UE Power Calibration ).

  • Step Length

    For UE power calibration: this setting specifies the time duration of one step in the UE's power sequence (in seconds). Each step in the power sequence must be identical in length.

    For HSDPA/HSPA power versus time ( lab application or feature-licensed test application only ): this setting specifies the time duration of one step, which determines how often a power measurement is made.

    Step Length must be greater than or equal to Measurement Interval .

Specifying the Measurement Characteristics for Each Step

  • Measurement Interval

    When measuring the average power of each step, you can specify how long a period of time over which to average the power for each step using the Measurement Interval setting. This setting is applied to the measurement of every step.

    Measurement Interval must be less than or equal to Step Length .

  • Trigger Delay

    When measuring the average power of each step, you can specify how long a period of time over which to average the power for each step using the Measurement Interval setting, and then place the measurement interval at the desired position within the step's duration in time using the Trigger Delay setting. In other words, the Trigger Delay setting specifies how long after the start of the step the power measurement should begin. This setting is applied to the measurement of every step.

    For example, for UE power calibration, the default settings of Step Length = 666.7 us , Measurement Interval = 300 us and Trigger Delay = 183.3 us causes the test set to measure power for 300 us centered in the middle of the step:

    Example Step Length, Measurement Interval and Trigger Delay Settings for UE Power Calibration

    For example, for HSDPA power versus time ( lab application or feature-licensed test application only ), setting Step Length = 666.7 us , Measurement Interval = 616.7 us and Trigger Delay = 25 us causes the test set to measure power over the entire timeslot excluding the 25 us transient periods on either side of the slot boundaries:

    Example Step Length, Measurement Interval and Trigger Delay Settings for HS-DPCCH Power versus Time
  • RRC Filter

    You may choose to measure the average power of each step with or without the RRC (Root Raised Cosine) filter in place. The RRC filter has an alpha of 0.22 and a bandwidth equal to the chip rate of 3.84 MHz.

  • Frequency Offset

    For UE power calibration: the UE's signal may or may not be modulated with an uplink DPCH signal. If the signal is not modulated with an uplink DPCH signal and is offset in frequency from the expected measurement frequency, you must set the Frequency Offset setting accordingly, to allow for the most accurate power measurements possible.

Specifying the Measurement Triggering

  • Trigger Source

    You may set Trigger Source to RF Rise , External or HS-DPCCH ( lab application or feature-licensed test application only ). For more information on these trigger types, see Trigger Source Description .

    For UE power calibration, Trigger Source must be set to RF Rise or External . If Trigger Source is set to RF Rise , you must characterize the trigger using the RF Rise Trigger Threshold . For the most robust triggering, it is also recommended that you further qualify the trigger using the Trigger Qualification State setting.

    For HSDPA or HSPA power versus time, it is recommended that you use a Trigger Source of HS-DPCCH . When Trigger Source is set to HS-DPCCH , you can specify on which uplink subframe the measurement triggers using the HS-DPCCH Trigger Subframe Alignment setting. You can also measure HSDPA/HSPA power versus time using a Trigger Source of External , but you must ensure that your external trigger is properly aligned to the portion of the HSDPA/HSPA signal that you wish to measure.

  • HS-DPCCH Trigger Subframe Alignment

    This setting is only applicable to the lab application or a feature-licensed test application.

    When Trigger Source is set to HS-DPCCH , you can specify on which uplink subframe the measurement triggers. You can then use the Trigger Delay setting to move the Measurement Interval relative to that subframe boundary.

  • RF Rise Trigger Threshold

    This setting is only applicable when Trigger Source is set to RF Rise . When Trigger Source is set to RF Rise , you must set the RF Rise Trigger Threshold to the power level (in dBm) at which you want the measurement to trigger. When the power of the UE's signal rises above the RF Rise Trigger Threshold level, the measurement is triggered.

    The test set assumes a crest factor of 3.1 dB for the signal (as is typical for an uplink DPCH signal relative to a CW signal) and thus actually triggers when the input signal reaches the RF Rise Trigger Threshold level plus 3.1 dB. If the UE's signal has a crest factor other than 3.1 dB, you must set the RF Rise Trigger Threshold level accordingly.

    RF Rise Trigger Threshold must be set to within 0 dB to -25 dB of the Expected Power .

    This setting is only available when Trigger Source is set to RF Rise .

  • Trigger Qualification State

    This setting is only applicable when Trigger Source is set to RF Rise .

    For complex UE power sequences, you may choose to further define the measurement trigger using trigger qualification. Instead of the measurement triggering when the UE's signal simply rises above the RF Rise Trigger Threshold value, you can specify that the UE's signal must meet some additional criteria as well before the measurement is triggered, using the Trigger Qualification Type setting.

  • Trigger Qualification Type

    This setting is only applicable when Trigger Source is set to RF Rise .

    • RF Rise : If you choose a Trigger Qualification Type of RF Rise , then the measurement will not trigger unless the UE's signal rises above the RF Rise Trigger Threshold value AND crosses this level with a positive change in power equal to or greater than the Trigger Qualification Rise Threshold . For example, if RF Rise Trigger Threshold is set to 0 dBm and Trigger Qualification Rise Threshold is set to 10 dB , then the measurement will not trigger until the UE's signal rises above 0 dBm AND increases in power by at least 10 dB within the qualification interval. The qualification interval is one Step Length before the transition across the RF Rise Trigger Threshold and one Step Length after the transition. (The power measurements performed in the qualification interval are performed according to the Measurement Interval , Trigger Delay , and RRC Filter settings, see Specifying the Measurement Characteristics for Each Step ).
      Example Trigger Scenarios with Trigger Qualification Type Set to RF Rise
    • RF Fall : If you choose a Trigger Qualification Type of RF Fall , then the measurement will not trigger unless the UE's signal rises above the RF Rise Trigger Threshold value AND then exhibits a negative change in power equal to or greater than the Trigger Qualification Fall Threshold during the qualification interval. The qualification interval is the two Step Lengths immediately after the transition across the RF Rise Trigger Threshold .
    • RF Rise and Fall : If you choose a Trigger Qualification Type of RF Rise and Fall , then the measurement will not trigger unless the UE's signal rises above the RF Rise Trigger Threshold value AND crosses this level with a positive change in power equal to or greater than the Trigger Qualification Rise Threshold AND then exhibits a negative change in power equal to or greater than the Trigger Qualification Fall Threshold . In other words, both requirements of a Trigger Qualification Type of RF Rise and RF Fall as explained above must be met

    No matter which type is chosen for the Trigger Qualification Type , if the requirements are met, then the measurement will trigger at the point at which the RF Rise Trigger Threshold was crossed.

    This setting is only available when Trigger Qualification State is set to On .

  • Trigger Qualification Rise Threshold

    This setting is only applicable when Trigger Source is set to RF Rise .

    This setting specifies the positive change in power that must occur for the measurement to trigger when the RF Rise Trigger Threshold is crossed, when Trigger Qualification Type is set to RF Rise or RF Rise and Fall .

  • Trigger Qualification Fall Threshold

    This setting is only applicable when Trigger Source is set to RF Rise .

    This setting specifies the negative change in power that must occur for the measurement to trigger when the RF Rise Trigger Threshold is crossed, when Trigger Qualification Type is set to RF Fall or RF Rise and Fall .

Other Measurement Parameters

  • 34.121 5.7A Measurement Configuration

    This setting should be used in conjunction with the 34.121 Preset Call Configurations . The 34.121 5.7A Measurement Configuration setting sets the following: Trigger Arm = Single , Steps = 37 , Step Length = 333.3 us , Measurement Interval = 283.3 us , Trigger Source = HS-DPCCH , HS-DPCCH Trigger Subframe Alignment = subframe 0 , Trigger Delay = -308.3 us , and RRC Filter = Off . You can then use the marker to measure the power step changes and ensure that your UE conforms to 5.7A (see Measuring 3GPP TS 34.121 v7.5.0 s5.7A HS-DPCCH ).

  • Trigger Arm (see Trigger Arm (Single or Continuous) Description )
  • Measurement Timeout (see Measurement Timeouts )

Dynamic Power Analysis Measurement Results

  • Integrity Indicator (see Integrity Indicator )
  • Number of Steps Measured

    You can query the number of steps measured using the FETCh:WDPAnalysis commands. The number of steps measured is also displayed on the front panel graphical display (see How Do I Make a Dynamic Power Analysis Measurement? ).

    The number of steps measured is determined by the Steps setting.

  • Average Power for Each Step (in dBm)

    Once the dynamic power analysis measurement has autoranged and triggered on the UE's power sequence, the test set then measures the average power for each step in the sequence as specified by the Measurement Interval , Trigger Delay , and RRC Filter settings. (See Specifying the Measurement Characteristics for Each Step .)

    You can retrieve the average power measured for each step using the FETCh:WDPAnalysis commands or from the front panel (see How Do I Make a Dynamic Power Analysis Measurement? ).

A typical UE power calibration measurement result is shown below:

Dynamic Power Analysis Measurement Input Signal Requirements

The dynamic power analysis measurement can measure power between -61 dBm and +28 dBm.

The dynamic range for any one measurement is 40 dB when RRC Filter = On (the UE's power may not vary by more than 40 dB in a single power sequence).

Dynamic Power Analysis Measurement Calibration

You must calibrate the dynamic power analysis measurement using the Calibrate Measurements procedure (see Calibrating the Test Set ).

Related Topics

Manual Operation: How Do I Make a Dynamic Power Analysis Measurement?

Programming the Dynamic Power Analysis Measurement

Dynamic Power Analysis Troubleshooting

What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?

Triggering of Measurements

Integrity Indicator

Product Note: W-CDMA Dynamic Power Analysis Using the Agilent 8960 Wireless Communications Test Set

TX Dynamic Power Measurement Description


Extended Range Dynamic Power Measurement Description

Extended Range Dynamic Power Measurement Description

Last updated: January 16, 2009

  • How is an Extended Range Dynamic Power Measurement Made?
  • Extended Range Dynamic Power Measurement Parameters
  • Extended Range Dynamic Power Measurement Results
  • Extended Range Dynamic Power Input Signal Requirements
  • Calibrating the Extended Range Dynamic Power Measurement

How is an Extended Range Dynamic Power Measurement Made?

The Extended Range Dynamic Power measurement allows you to measure the UE's transmitter output power across its entire dynamic power (up to 90 dB) in one measurement cycle. This measurement does not require a call established between the test set and UE since it does not utilize any overhead signalling to control the UE's power or frequency. Rather, you must place your UE into a test mode which forces it to transmit two power sequences you desire to test, and then analyze the resulting UE output power using the test set.

The Extended Range Dynamic Power measurement can measure power between -61 dBm and +28 dBm. Two power sequences output from the UE can be measured in one measurement cycle and the power range of each power sequence must not span more than 45 dB. Therefore, to measure a power range greater than 45 dB, you must break the power range up into two power sequences that do not exceed 45 dB. Each power sequence can contain up to 84 power steps (the levels can step up and/or down with varying magnitudes of change and the length of each step is fixed to one timeslot (666.7 us)). The sum of the steps in the two power sequences can not exceed 85 power steps. Moreover, you must command your UE to transmit for 15 power steps (timeslots) with constant or varied power levels between the two power sequences you desire to measure because the measurement must re-range its receiver in the middle of the two power sequences. The test set does not make any power measurements during the 15 timeslots re-range period. For example, to measure a UE's output power ranging from +24 dBm to -51 dBm, it is recommended that you command your UE to output the first power sequence stepping through the range of +24 dBm to -13 dBm in 1 dB step size, then hold its power constant for 15 timeslots, and then output the second power sequence stepping through the power range of -14 dBm to -51 dBm in 1 dB step size. The test set measures a total of 76 steps (timeslots) in one measurement and returns 76 power results for each step.

The figure below shows a typical example of UE output power sequence for the Extended Range Dynamic Power measurement.

Example of UE Test Mode Output Power Sequence

The Extended Range Dynamic Power measurement can be made in Active Cell Operating Mode or FDD Test Operating Mode . Before starting the measurement, you must first set Measurement Frequency to the expected UE transmitter frequency and set Manual Power to the maximum expected power. To best utilize the 45 dB dynamic range of the test set's receiver, Manual Power should be set to the highest power expected in the first power sequence and Second Sequence Expected Power should be set to the highest power expected in the second power sequence. You must specify the number of steps in both sequences ( First Sequence Steps and Second Sequence Steps ), configure the trigger ( Trigger Source , RF Rise Trigger Threshold or Trigger Delay ), initiate the measurement, then order the UE to send its power sequences.

When the Extended Range Dynamic Power measurement is initiated, it waits for an RF rise trigger from the UE or an external trigger (see Triggering the Extended Range Dynamic Power Measurement ). Once triggered, the test set starts to measure the UE output power sequences. It first samples the signals for the number of steps (timeslots) specified by the First Sequence Steps , then re-ranges its receiver according to the setting of Second Sequence Expected Power during the next 15 timeslots re-range period (the test set does not make any measurement during the re-range period), and after that, samples the signal for the number of timeslots specified by the Second Sequence Steps . When all of the power steps in both power sequences are sampled (with RRC filter off), the test set analyzes the power of each step and then returns the power results for all measured steps. The power result of each step is determined by averaging over a half timeslot measurement interval (0.5 timeslot = 333.3 us). When the Trigger Source is RF Rise , the measurement interval is centered in the middle of each step (666.7 us). That is, the measurement interval shall be at 166.7 us relative to the start of each step. When the Trigger Source is External , you can use the Trigger Delay to specify when the measurement interval should begin.

Triggering the Extended Range Dynamic Power Measurement

The measurement can be triggered externally or by an RF rise trigger in the power sequence.

  • You can trigger the Extended Range Dynamic Power measurement using an RF rise within the power sequence by setting the Trigger Source to RF Rise and specifying the appropriate RF Rise Trigger Threshold . To ensure a successful RF rise triggering, it is recommended that you do the following:
    1. Set Power Control to Manual and set Manual Power to the highest power expected in the first power sequence. It is also recommended that the RF Rise Trigger Threshold be set to approximately 10 dB below the highest power expected in the first power sequence.
    2. Order the UE to transmit continuously at a low power level to ensure that the first power step in the power sequences meets the requirements of the RF rise trigger. The trigger pulse should rise in power by at least 20 dB and above the RF Rise Trigger Threshold level. If the first power step you desire to measure meets the trigger pulse requirements, no separate trigger pulse is needed. Otherwise, you should include a separate power step as a trigger pulse in the first power sequence that you desire to measure.
    3. Initiate the Extended Range Dynamic Power measurement by sending the INITiate:WEDPower command or by pressing the START SINGLE hardkey if running the measurement from the front panel (this is to arm the measurement).
    4. Send the INITiate:WEDPower:ARMed? query and wait for it to return a value of 1, indicating that the measurement is armed and ready to be triggered.
    5. Order the UE to begin transmission of its power sequences to be measured. Since the power level of the first step in the first power sequence is above the RF Rise Trigger Threshold level, this causes the measurement to be triggered on an RF rise signal.
  • You can also use an external trigger source by setting the Trigger Source to External as needed for your test cases. When External is selected as your trigger source, you are allowed to adjust the Trigger Delay .

Operating Considerations

  • You must command your UE to transmit for 15 power steps (timeslots) with constant or varied power levels between the two power sequences you desire to measure because the measurement requires re-ranging its receiver after completing the first power sequence and before measuring the second power sequence. The test set does not make any power measurements during the 15 timeslots re-range period.
  • To obtain the optimum measurement accuracy, it is recommended that the power range of each power sequence not exceed 45 dB. Also, to best utilize the 45 dB dynamic range of the receiver, Manual Power should be set to the highest power expected in the first power sequence and Second Sequence Expected Power should be set to the highest power expected in the second power sequence.
  • You must set the First Sequence Steps and Second Sequence Steps to match the power sequences to be transmitted by the UE. Also, the sum of the two settings can not be more than 85 steps.
  • No other measurements can be running when a Extended Range Dynamic Power measurement is performed. If any measurements are running when a Extended Range Dynamic Power measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while an Extended Range Dynamic Power measurement is running, the Extended Range Dynamic Power measurement is closed and a message is displayed.
  • During front panel operation of this measurement, you must press the START SINGLE key to start the measurement.
  • Do not send any GPIB commands to the test set or press any front panel keys until the measurement has completed.

Extended Range Dynamic Power Measurement Parameters

  • First Sequence Steps

    Sets the number of steps (1 to 84) the UE will transmit during the first power sequence. The length of each step is fixed to one timeslot (666.7us). The UE's output power steps up or down through the first power sequence, which must not exceed 45 dB power range.

    Note: The sum of First Sequence Steps and Second Sequence Steps can not be more than 85 steps.

    GPIB command: SETup:WEDPower:STEPs:FSEQuence

  • Second Sequence Steps

    Sets the number of steps (1 to 84) the UE will transmit during the second power sequence. The length of each step is fixed to one timeslot (666.7us). The UE's output power steps up or down through the second power sequence, which must not exceed 45 dB power range.

    Note: The sum of the First Sequence Steps and Second Sequence Steps can not be more than 85 steps.

    GPIB command: SETup:WEDPower:STEPs:SSEQuence

  • Second Sequence Expected Power

    Sets the maximum expected power that the UE will transmit during the second power sequence. It should be set to the highest power in the second power sequence to best utilize the 45 dB dynamic range of the receiver.

    The test set ranges its receiver based on the Manual Power setting for the first power sequence measurement (it is recommended you set the Manual Power to the highese power in the first power sequence) and then re-ranges it receiver based on the Second Sequence Expected Power setting for the second power sequence.

    GPIB command: SETup:WEDPower:SSEQuence:EXPected:POWer

  • RF Rise Trigger Threshold

    This setting is only applicable when the Trigger Source is set to RF Rise . When the Trigger Source is set to RF Rise , you must set the RF Rise Trigger Threshold to the power level (in dBm) at which you want the measurement to trigger. When the power of the UE's signal rises above the RF Rise Trigger Threshold level, the measurement is triggered.

    The RF Rise Trigger Threshold must be set to within 0 dB to -25 dB of Manual Power (it is suggested that you set Manual Power to the highest power level of the first power sequence to best utilize the 45 dB dynamic range of the receiver). Also, it is recommended that the RF Rise Trigger Threshold be set to approximately 10 dB below the Manual Power .

    The test set assumes a crest factor of 3.1 dB for the signal (as is typical for an uplink DPCH signal relative to a CW signal) and thus actually triggers when the input signal reaches the RF Rise Trigger Threshold level plus 3.1 dB. If the UE's signal has a crest factor other than 3.1 dB, you must set the RF Rise Trigger Threshold level accordingly.

    GPIB command: SETup:WEDPower:TRIGger:THReshold

  • Trigger Source

    You may set Trigger Source to RF Rise or External . If Trigger Source is set to RF Rise , you must characterize the trigger using the RF Rise Trigger Threshold .

    For more information on these trigger types, see Trigger Source Description .

    GPIB command: SETup:WEDPower:TRIGger:SOURce

  • Trigger Delay

    The power level of each step is measured by averaging over a half timeslot measurement interval (0.5 timeslot = 333.3 us). When the Trigger Source is External , you can move the measurement interval of the first power step relative to the external trigger using the Trigger Delay setting. The measurement intervals for all subsequent steps are then spaced by one timeslot. To make the power measurement of each step always be centered in the middle of the step, you should set the Trigger Delay to the time offset between the external trigger and the start of the first power step plus 166.7 us.

    When the Trigger Source is RF Rise , the power measurement is averaged over 0.5 timeslot measurement interval (333.3 us) that is always centered in the middle of each step. Therefore, the measurement interval starts at 166.7us relative to the start of each step.

    For example, if the UE began to output its power sequences at 200 us delay after the external trigger, you should set Trigger Source to External and Trigger Delay to 366.7 us . Thus, the power of each step is averaged for a half timeslot (333.3 us) that is centered in the middle of the step (since the length of each step is fixed to one timeslot (666.7 us) and the measurement interval is fixed to half timeslot (333.3 us)).

    GPIB command: SETup:WEDPower:TRIGger:DELay

    Example of Trigger Delay setting for External Trigger Source
  • Measurement Timeout - see Measurement Timeouts . Ensure that you set the Measurement Timeout to a value great enough to allow you to command the UE to transmit its power sequences and for the test set to measure the power sequences.

    GPIB command: SETup:WEDPower:TIMeout[:STIMe]

Extended Range Dynamic Power Measurement Results

  • Integrity Indicator (see Integrity Indicator )
  • Number of Steps Measured

    The number of steps measured should be the sum of the First Sequence Steps and Second Sequence Steps settings. It can be queried using the FETCh:WEDPower or FETCh:WEDPower:STEPs command (see FETCh:WEDPower ). It is also displayed on the front panel graphical display (see the figure below).

  • Average Power for Each Step (in dBm)

    The test set measures the average power for each step by performing a channel power measurement (with RRC filter off) over a measurement interval of 333.3 us (one half timeslot). The measurement interval is centered in the middle of the 666.7 us (timeslot) step when Trigger Source is RF Rise , or is offset from the start of the step according to the Trigger Delay setting when Trigger Source is set to External .

    You can retrieve the average power measured for each step using the FETCh:WEDPower command or from the front panel (see the figure below).

Extended Range Dynamic Power Input Signal Requirements

The Extended Range Dynamic Power measurement can measure power between -61 dBm and +28 dBm.

The dynamic range for each power sequence is 45 dB. That is, the UE's power can not vary by more than 45 dB in any of the two power sequences.

Calibrating the Extended Range Dynamic Power Measurement

You must calibrate this measurement using the measurement calibration procedure (see Calibrating the Test Set ).

Related Topics

Manual Operation: How Do I Make an Extended Range Dynamic Power Measurement?

Programming an Extended Range Dynamic Power Measurement

Extended Range Dynamic Power Measurement Troubleshooting

Channel Power Measurement Description

Receiver Control

Dynamic Power Analysis Measurement Description


Waveform Quality Measurement Description

Waveform Quality Measurement Description

Last updated: January 16, 2009

  • How is a Waveform Quality Measurement Made?
    • Measurement Interval in Non-HSDPA Mode
    • Measurement Interval in HSDPA Mode ( lab application or feature-licensed test application only )
  • Waveform Quality Measurement Parameters
    • HSDPA Measurement Parameters ( lab application or feature-licensed test application only )
  • Waveform Quality Measurement Results
  • Waveform Quality Input Signal Requirements
  • Waveform Quality Measurement Calibration

How is a Waveform Quality Measurement Made?

3GPP TS 34.121 s5.13 states "The Error Vector Magnitude is a measure of the difference between the reference waveform and the measured waveform. This difference is called the error vector. Both waveforms pass through a matched Root Raised Cosine filter with bandwidth 3,84 MHz and roll-off a = 0,22. Both waveforms are then further modified by selecting the frequency, absolute phase, absolute amplitude and chip clock timing so as to minimise the error vector. The EVM result is defined as the square root of the ratio of the mean error vector power to the mean reference power expressed as a %."

The waveform quality measurement in the test set compares the received signal's IQ modulation characteristics to an ideal signal, as defined in 3GPP TS 34.121 s5.13 and annex B.

Measurement Interval in Non-HSDPA Mode

When on a non-HSDPA connection, you must set Trigger Source to any value other than HS-DPCCH . When operating in this mode, the measurement is made during one timeslot (666.7 us). You can choose in which timeslot of the W-CDMA frame the measurement is performed using the Timeslot setting. You can also choose whether to include or exclude the 25 us transient periods on the slot boundaries using the Transient Period setting.

Measurement Interval Duration and Placement for Non-HSDPA

Measurement Interval in HSDPA Mode

This section is only applicable to the lab application or feature-licensed test application .

To measure waveform quality on an HSDPA connection, you must set Trigger Source to HS-DPCCH . When Trigger Source is set to HS-DPCCH, you can specify the measurement interval and its placement within any of the 6 HSDPA subframes.

  1. Use the HS-DPCCH Trigger Subframe Alignment setting to choose in which 2 ms subframe (0 to 5) you want to place the measurement interval.
  2. Use the HS-DPCCH Trigger Slot Alignment setting to specify in which slot within the subframe you want to place the measurement interval ( AckNack = the first slot of the subframe, CQI1 = the second slot of the subframe and CQI2 = the third slot of the subframe).
  3. Set the duration of the measurement interval using the HS-DPCCH Measurement Interval setting. Note that the sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval cannot exceed 1.0 slot.
  4. Use the HS-DPCCH Trigger Subslot Alignment setting to specify where you want to place the measurement interval within the slot. You can place the measurement interval at the slot boundary, 0.1 slot (66.7 us) after the slot boundary, 0.2 slot (133.3 us) after the slot boundary... up to 0.5 slot (333.3 us) after the slot boundary. Note, however, that the sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval cannot exceed 1.0 slot. If you wish to place the measurement interval after the slot boundary using the HS-DPCCH Trigger Subslot Alignment setting, you must first decrease the HS-DPCCH Measurement Interval setting appropriately.
  5. You can choose to shorten the measurement interval so as to exclude the 25 us (96 chip) transient periods at the start and end of the measurement interval using the Transient Period setting. For example, if you set HS-DPCCH Measurement Interval to 0.5 slot (333.3 us or 1280 chips) and set Transient Period to Exclude , the measurement is performed over 283.3 us (or 1088 chips).

Measurement Interval Duration and Placement for HSDPA

Waveform Quality Measurement Parameters

  • Multi-Measurement Count: see Statistical Measurement Results .
  • Timeslot

    When Trigger Source is set to any value other than HS-DPCCH , you can specify which timeslot of the W-CDMA frame (0 to 14) is evaluated by the waveform quality measurement. See Measurement Interval in Non-HSDPA Mode .

  • Transient Period

    When Transient Period is set to Include and Trigger Source is set to any value other than HS-DPCCH , the measurement is performed over one timeslot. When Transient Period is set to Include and Trigger Source is set to HS-DPCCH , the measurement is performed over the interval specified by the HS-DPCCH Measurement Interval setting.

    When Transient Period is set to Exclude , the 25 us at the start of the measurement interval and the 25 us at the end of the measurement interval are excluded from the measurement. Thus, when Trigger Source is set to any value other than HS-DPCCH , the measurement is performed over 666.7 us - 50 us = 616.7 us. When Trigger Source is set to HS-DPCCH , the measurement is performed over an interval equal to HS-DPCCH Measurement Interval less 25 us from each end (see Measurement Interval in HSDPA Mode ).

  • Trigger Arm: see Trigger Arm (Single or Continuous) Description .
  • Trigger Source

    Triggering choices are immediate, protocol, external, auto, and HS-DPCCH ( lab application or feature-licensed test application only ). See Trigger Source Description for more information.

    Auto triggering is the default choice. In most cases, auto triggering provides the optimum measurement triggering condition for the waveform quality measurement. For example, if the UE is synchronized to the test set, auto triggering causes protocol triggering to be used. Auto triggering causes immediate triggering is used if the UE is not synchronized. When immediate triggering is used, the measurement result returned for timing error is always NAN (Not a Number) because it is not possible to evaluate a timing error in this measurement situation.

  • Measurement Timeout: see Measurement Timeouts .

HSDPA Measurement Parameters

This section is only applicable to the lab application or feature-licensed test application .

These settings are only applicable when Trigger Source = HS-DPCCH .

See Measurement Interval in HSDPA Mode for more information about using these parameters to specify the duration and placement of the measurement interval.

  • HS-DPCCH Trigger Subframe Alignment

    Selects which 2 ms subframe (0 to 5) contains the measurement interval.

  • HS-DPCCH Trigger Slot Alignment

    Selects which slot in the 2 ms subframe contains the measurement interval ( AckNack = the first slot in the subframe, CQI1 = the second slot in the subframe and CQI2 = the third slot in the subframe).

  • HS-DPCCH Measurement Interval

    See Measurement Interval in HSDPA Mode .

    Note, the sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval cannot exceed 1.0 slot.

  • HS-DPCCH Trigger Subslot Alignment

    Selects where to place the measurement interval within the slot, in 0.1 slot (66.7 us) increments. This is useful because depending upon the Current DPCH Offset , the uplink DPCH and HS-DPCCH can be offset in time by increments of 0.1 slot (see HS-DPCCH/DPCCH Alignment vs. DPCH Frame Offset ).

    Note, the sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval cannot exceed 1.0 slot.

  • 34.121 5.13.1A Measurement Configurations

    These settings should be used in conjunction with the 34.121 Preset Call Configurations . All four of the 5.13.1A measurement configurations set the following: Transient Period = Exclude , HS-DPCCH Measurement Interval = 0.5 slot and Trigger Source = HS-DPCCH . They also set the trigger alignment settings so as to capture the regions indicated in the diagram below.

             Measurement Point HS-DPCCH Trigger Subframe Alignment HS-DPCCH Trigger Slot Alignment HS-DPCCH Trigger Subslot Alignment
    34.121 5.13.1A Low of Low-High Transition | 1 | subframe 5 | CQI2 | 0.5 slot
    34.121 5.13.1A High of Low-High Transition | 2 | subframe 0 | AckNack | 0.0 slot
    34.121 5.13.1A High of High-Low Transition | 3 | subframe 3 | AckNack | 0.5 slot
    34.121 5.13.1A Low of High-Low Transition | 4 | subframe 3 | CQI1 | 0.0 slot

    You can then ensure that your UE conforms to 5.13.1A (see Measuring 3GPP TS 34.121 v7.5.0 s5.13.1A Error Vector Magnitude (EVM) with HS-DPCCH ).

Waveform Quality Measurement Results

  • EVM: Error Vector Magnitude (in %)
  • Peak EVM (maximum chip EVM, in %) - available through GPIB query only.
  • Frequency Error (in Hz)
  • Origin Offset (in dB)
  • Phase Error (in degrees)
  • Magnitude Error (in %)
  • Time Error (in chips)

    The time error is determined as a result of minimizing the error vector between the measured and ideal signals. It is a measure of the timing error of the UE's transmission relative to the frame clock. The requirements for UE timing are defined in 3GPP TS 25.133 s7.1, which states "The uplink DPCCH/DPDCH frame transmission takes place approximately T 0 chips after the reception of the first detected path (in time) of the corresponding downlink DPCCH/DPDCH or F-DPCH frame, from the reference cell". The time error reported by the test set does not include T 0 (defined to be 1024 chips by 3GPP TS 25.211 s7.6.3). The time error is the error beyond 1024 chips.

  • PCDE

    Peak Code Domain Error (in dB) and the code channel at which it occurs (C ch,Spreading Factor,Code Number ).

  • Beta c , Beta d1 , Beta d2 , Beta d3 , Beta d4 , Beta d5 , Beta d6 , Beta hsacknak , Beta hscqi

    Only Beta c (DPCCH) and Beta d1 (DPDCH 1) provide results (other than NaN) while on a non-HSDPA connection. Beta d2-6 are reserved for future use. See Uplink DPCH Bc/Bd Control for more information on Beta c and Beta d .

    Beta hsacknak and Beta hscqi only provide results (other than NaN) when on an HSDPA connection ( lab application or feature-licensed test application only ). Beta hsacknak represents the value of Beta hs when measuring the Ack/Nack portion of the subframe. Beta hscqi represents the value of Beta hs when measuring the CQI portion of the subframe. Thus, when HS-DPCCH Trigger Slot Alignment is set to AckNack , a valid result is returned for Beta hsacknak , NaN is returned for Beta hscqi . Likewise, when HS-DPCCH Trigger Slot Alignment is set to CQI1 or CQI2 , a valid result is returned for Beta hscqi , NaN is returned for Beta hsacknak . See HS-DPCCH Gain Settings for more information on Beta hs .

    The beta results are available through GPIB query only.

  • IQ Gain Imbalance and IQ Phase Imbalance (in dB) - available through GPIB query only.

    IQ gain imbalance and IQ phase imbalance measurements are determined by comparing the received signal's IQ modulation characteristics with an ideal signal (IQ gain imbalance, IQ phase imbalance and Origin Offset are solved for using the parameter estimator described in Estimation of Amplitude Imbalance, Phase Imbalance, and Origin Offset of a Complex Signal Relative to an Ideal Reference by R. A. Birgenheier, Jan. 4, 2000).

Waveform Quality Input Signal Requirements

  • For this measurement the test set's receiver uses auto-ranging to adjust for the level of the signal being measured; therefore the expected signal level does not need to be specified during measurement setup. However, it is recommended that Expected Power be configured to match the actual signal level expected to ensure the auto-ranging procedure executes as quickly as possible.
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, 1700 MHz to 1990 MHz, or 2480 MHz to 2580 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of -25 dBm to +28 dBm, in a 3.84 MHz bandwidth.
  • Maximum measurable EVM = 35%
  • Maximum measurable frequency error = ± 1 kHz
  • Maximum measurable timing error = +/- 50 chips

Waveform Quality Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function ( CALibration:MEASurements? ) when the temperature has changed by ± 10° C or more since the last calibration. If this situation exists, the integrity indicator value becomes 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

  • Manual Operation: How Do I Make a Waveform Quality Measurement?
  • Programming a Waveform Quality Measurement
  • Waveform Quality Troubleshooting
  • What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator


Out-of-Synch Handling of Output Power Measurement Description

Out-of-Synch Handling of Output Power Measurement Description

Last updated: January 16, 2009

This section is only applicable to the lab application.

  • How is an Out-of-Synch Handling of Output Power Measurement Made?
  • Out-of-Synch Handling of Output Power Measurement Parameters
  • Out-of-Synch Handling of Output Power Measurement Results
  • Key 3GPP Tests Performed Using the Out-of-Synch Handling of Output Power Measurement

How is an Out-of-Synch Handling of Output Power Measurement Made?

Out-of-synchronization handling of output power measures the UE's ability to monitor the downlink DPCCH quality and turn its transmitter on or off based on the quality level.

3GPP TS 34.121 5.4.4.2 states: "When the UE estimates the DPCCH quality over the last 160 ms period to be worse than a threshold Qout, the UE shall shut its transmitter off within 40 ms. The UE shall not turn its transmitter on again until the DPCCH quality exceeds an acceptable level Qin. When the UE estimates the DPCCH quality over the last 160 ms period to be better than a threshold Qin, the UE shall again turn its transmitter on within 40 ms."

"The UE shall not shut its transmitter off before point B. The UE shall shut its transmitter off before point C, which is Toff = 200 ms after point B. The UE shall not turn its transmitter on between points C and E. The UE shall turn its transmitter on before point F, which is Ton = 200 ms after point E."

The UE's transmitter is considered to be "off" if the transmitted power is below -55 dBm and "on" if the transmitted power is above -49 dBm.

3GPP TS 34.121 Figure 5.4.4.1 Test case for out-of-synch handling in the UE

The Out-of-Synch Handling of Output Power measurement allows you to specify the time intervals and DPCCH_Ec/Ior levels between points A and F (see Out-of-Synch Handling of Output Power Measurement Parameters ). When the measurement is initiated, the test set varies its DPCCH level according to these settings. You must then measure the UE's power response using an external spectrum analyzer to determine if the UE turned its power off and on as required (see Out-of-Synch Handling of Output Power Measurement Results ).

Required Initial Conditions

Before performing the out-of-synch measurement, you must:

  • Connect the test set's rear panel TRIG OUT port to the TRIGGER IN port of an external spectrum analyzer (the external spectrum analyzer is required to measure the UE's output power and obtain measurement results, see Out-of-Synch Handling of Output Power Measurement Results ).
  • Connect the UE to the test set's RF IN/OUT port and to the spectrum analyzer's RF INPUT port via an RF splitter, and specify the loss due to the RF splitter in both the test set and the spectrum analyzer.
  • Set Trigger Output Setup to Measurement Generated .
  • Establish a Radio Bearer Test Mode connection (3GPP TS 34.121 5.4.4 specifies a 12.2k RMC connection). Note, this measurement is not supported on HSDPA or HSPA connections.

Recommended Initial Conditions

The following settings are recommended based on the 3GPP TS 34.121 5.4.4 requirements. Note that some of these parameters must be set before establishing a connection.

  • Set Connected DL Channel Levels as specified by 3GPP TS 34.121 Table E.3.3 and Table 5.4.4.3:
    • Cell 1 Connected CPICH Level = -10.00 dB .
    • Cell 1 Connected P-CCPCH/SCH Level = -12.00 dB .
    • Cell 1 Connected S-CCPCH Level = Off .
    • Cell 1 Connected PICH Level = -15.00 dB .
    • Cell 1 Connected DPCH Level = -16.60 dB . (This sets DPCCH_Ec/Ior before point A to -16.6 dB, because PO1 = PO2 = PO3 = 0, which makes DPCH_Ec/Ior = DPCCH_Ec/Ior).

    See Downlink Channel Levels .

  • Set (T313 + N313*10 ms) > (Ta-b + 200 ms + Tc-d + Td-e + N315*10 ms) to ensure that the UE will not drop the call when the measurement in initiated (see UE Timer and Constant Parameters and Out-of-Synch Handling of Output Power Measurement Parameters for more information on these settings). The UE may drop the call if the UE timers specify a drop time that is less than the time that the test set's DPCCH_Ec/Ior value is low, plus the time required for the UE to receive N315 "in sync" indicators. 3GPP TS 34.121 Table 5.4.4.2A specifies a value of 15 s for T313 and a value of 200 for N313.
  • Leave the Out-of-Synch Handling of Output Power Measurement Parameters set to their default values, (which correspond to 3GPP TS 34.121 section 5.4.4.2, 5.4.4.4.2 and Table 5.4.4.3):
    • Segment Ta-b Interval = 5.000 s
    • Segment Tc-d Interval = 5.000 s
    • Segment Td-e Interval = 5.000 s
    • DPCCH Quality Ratio Qa-b = -21.60
    • DPCCH Quality Ratio Qb-d = -28.40
    • DPCCH Quality Ratio Qd-e = -24.40
    • DPCCH Quality Ratio Qe+ = -17.60
  • Set UE Target Power to the maximum output power for your UE and set UL CL Power Control Mode to All Up bits .
  • Set Cell Power ( F7 on the Call Parms 1 of 3 menu) to -61 dBm .
  • Select Generator Info ( F3 on the Call Control 2 of 4 menu) and set AWGN Power ( F5 ) to -60 dBm.

No other measurements can be running when an out-of-synch handling of output power measurement is performed. If any measurements are running when an out-of-synch handling of output power measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while an out-of-synch handling of output power measurement is running, the out-of-synch handling of output power measurement is closed and a message is displayed.

FDD Test Mode Operating Considerations

The out-of-synch handling of output power measurement can be performed while in FDD Test Operating Mode , however you must configure the UE such that its output power will respond appropriately to the changes in the test set's DPCCH_Ec/Ior.

Out-of-Synch Handling of Output Power Measurement Parameters

See 3GPP TS 34.121 Figure 5.4.4.1 Test case for out-of-synch handling in the UE for a definition of points A - F.

  • Segment Ta-b Interval

    Time between points A and B. The test set's DPCCH_Ec/Ior is set to DPCCH Quality Ratio Qa-b for the time Segment Ta-b Interval .

  • Segment Tc-d Interval

    Time between points C and D. The test set's DPCCH_Ec/Ior is set to DPCCH Quality Ratio Qb-d for 200 ms plus Segment Tc-d Interval (because Tb-c = Toff = 200 ms).

  • Segment Td-e Interval

    Time between points D and E. The test set's DPCCH_Ec/Ior is set to DPCCH Quality Ratio Qd-e for the time Segment Td-e Interval .

  • DPCCH Quality Ratio Qa-b

    DPCCH_Ec/Ior between points A and B. (Note: the DPCCH quality ratio before point A is determined by the value that Cell 1 Connected DPCH Level is set to before the measurement is initiated, see Downlink Channel Levels .)

  • DPCCH Quality Ratio Qb-d

    DPCCH_Ec/Ior between points B and D.

  • DPCCH Quality Ratio Qd-e

    DPCCH_Ec/Ior between points D and E.

  • DPCCH Quality Ratio Qe+

    DPCCH_Ec/Ior after point E.

  • Measurement Timeout: see Measurement Timeouts .

Out-of-Synch Handling of Output Power Measurement Results

The Out-of-Synch Handling of Output Power measurement does not return any measurement results at this time. Initiating the measurement only causes the test set to change its DPCCH_Ec/Ior as specified by the Out-of-Synch Handling of Output Power Measurement Parameters . You must use an external spectrum analyzer to measure the UE's resulting output power. When the Out-of-Synch Handling of Output Power measurement is initiated from the test set, the test set generates a trigger at point A that you can route to the test set's rear panel TRIG OUT connector using the Trigger Output Setup setting, to trigger the spectrum analyzer. See How Do I Make an Out-of-Synch Handling of Output Power Measurement? .

Key 3GPP Tests Performed Using the Out-of-Synch Handling of Output Power Measurement

3GPP TS 34.121 5.4.4 Out-of-synchronisation handling of output power.

Related Topics

Manual Operation: How Do I Make an Out-of-Synch Handling of Output Power Measurement?


Phase Discontinuity Measurement Description

Phase Discontinuity Measurement Description

Last updated: January 16, 2009

  • How is a Phase Discontinuity Measurement Made?
    • Non-HSDPA Phase Discontinuity
    • HSDPA Phase Discontinuity ( lab application or feature-licensed test application only )
  • Phase Discontinuity Measurement Parameters
    • Non-HSDPA Phase Discontinuity Measurement Parameters
    • HSDPA Phase Discontinuity Measurement Parameters ( lab application or feature-licensed test application only )
  • Phase Discontinuity Measurement Results
  • Key 3GPP Tests Performed Using the Phase Discontinuity Measurement
  • Phase Discontinuity Measurement Input Signal Requirements
  • Phase Discontinuity Measurement Calibration

How is a Phase Discontinuity Measurement Made?

The Phase Discontinuity measurement can be used to measure a non-HSDPA signal (DPCH only) or an HSDPA signal (DPCH + HS-DPCCH).

To perform measurements on a non-HSDPA signal, set Trigger Source to Protocol or External . See Non-HSDPA Phase Discontinuity for additional information.

To perform measurements on an HSDPA signal ( lab application or feature-licensed test application only ), set Trigger Source to HS-DPCCH. See HSDPA Phase Discontinuity .

Non-HSDPA Phase Discontinuity

To measure phase discontinuity on a non-HSDPA signal (DPCH only), you must set Trigger Source to Protocol or External .

3GPP TS 34.121 s5.13.3.1 states: " Phase discontinuity is the change in phase between any two adjacent timeslots. The EVM for each timeslot (excluding the transient periods of 25 us on either side of the nominal timeslot boundaries), shall be measured according to subclause 5.13.2. The frequency, absolute phase, absolute amplitude and chip clock timing used to minimise the error vector are chosen independently for each timeslot. The phase discontinuity result is defined as the difference between the absolute phase used to calculate EVM for the preceding timeslot, and the absolute phase used to calculate EVM for the succeeding timeslot. "

Graphical Description of Phase Discontinuity (3GPP TS 34.121 5.13.3.1)

" The best-fit rate of change of phase for each timeslot is calculated using the same process as used to minimize the EVM. This best-fit rate of change of phase is by definition the frequency error result for the timeslot. Due to the presence of power steps in the test, the data used for the best-fit calculation shall exclude the 25 us transition period at the beginning and end of each timeslot. The best-fit rate of change of phase for each timeslot is then extrapolated in both directions onto the timeslot boundaries. The phase discontinuity result at any one slot boundary is the difference between the extrapolated phase at the end of the timeslot preceding the slot boundary and the extrapolated phase at the start of the timeslot following the slot boundary. "

The non-HSDPA phase discontinuity measurement in the test set measures the change in phase between adjacent slots as prescribed in the test standard. Therefore the phase discontinuity reported for any given slot is the extrapolated starting phase of that slot minus the extrapolated ending phase of the previous slot (the 25 us transient periods on either side of the slot boundaries are excluded during the best-fit calculation of the rate of change of phase, such that only 617 us of each slot is used in the best-fit calculation).

The non-HSDPA phase discontinuity measurement also returns the extrapolated starting phase of each slot (normalized to the extrapolated starting phase of the Reference Timeslot ), the power of each slot, and several waveform quality results for each slot (see Phase Discontinuity Measurement Results ).

The total number of slots measured when the non-HSDPA phase discontinuity measurement is initiated is determined by Number of Pattern Repetitions or by Measurement Interval , depending upon the Power Control Pattern setting.

HSDPA Phase Discontinuity

This section is only applicable to the lab application or feature-licensed test application.

To measure phase discontinuity on an HSDPA signal (DPCH + HS-DPCCH), you must set Trigger Source to HS-DPCCH .

3GPP 34.121 s5.13.1AA states: " Phase discontinuity for HS-DPCCH is the change in phase due to the transmission of the HS-DPCCH. In the case where the HS-DPCCH timeslot is offset from the DPCCH timeslot, the period of evaluation of the phase discontinuity shall be the DPCCH timeslot that contains the HS-DPCCH slot boundary. The phase discontinuity for HS-DPCCH result is defined as the difference between the absolute phase used to calculate the EVM for that part of the DPCCH timeslot prior to the HS-DPCCH slot boundary, and the absolute phase used to calculate the EVM for remaining part of the DPCCH timeslot following the HS-DPCCH slot boundary. In all cases the subslot EVM is measured excluding the transient periods of 25 us. Since subslot EVM is only defined for intervals of at least one half timeslot, the phase discontinuity for HS-DPCCH is only defined for non-aligned timeslots when the offset is 0.5 slots. "

The HSDPA phase discontinuity measurement in the test set can be used to measure the change in phase across HS-DPCCH boundaries as prescribed in the test standard.

You can specify whether 0.5 slot or 1.0 slot steps are evaluated by the measurement using the HS-DPCCH Measurement Step Interval setting. You can change the placement of the measurement trigger (which coincides with step 1) using the HS-DPCCH Trigger Subframe Alignment , HS-DPCCH Trigger Slot Alignment and HS-DPCCH Trigger Subslot Alignment settings.

Measurement Step Interval and Trigger Placement for HSDPA

The phase discontinuity reported for any given step is the extrapolated starting phase of that step minus the extrapolated ending phase of the previous step (the 25 us transient periods on either side of the step are excluded during the best-fit calculation of the rate of change of phase, such that only 283 us or 617 us is used in the best-fit calculation depending upon whether HS-DPCCH Measurement Step Interval is set to 0.5 slot or 1.0 slot , respectively).

The HSDPA phase discontinuity measurement also returns the extrapolated starting phase of each step (normalized to the extrapolated starting phase of step 0), the power of each step, and several waveform quality results for each step (see Phase Discontinuity Measurement Results ).

The total number of steps measured when the measurement is initiated is determined by HS-DPCCH Measurement Step Count setting.

When Trigger Source is set to HS-DPCCH , when the measurement is initiated the test set checks to see that UL CL Power Ctrl Algorithm is set to Two and UL CL Power Ctrl Stepsize is set to 1 dB . If not, the test set sends the UE a Physical Channel Reconfiguration message with these values. (When the measurement completes, the values are returned to their pre-measurement states.) The test set then transmits alternating power control bits throughout the duration of the measurement.

Operating Mode Considerations

The phase discontinuity measurement is supported in Active Cell Operating Mode and FDD Test Operating Mode .

In Active Cell Operating Mode , you must be on a call before running the phase discontinuity measurement. You must set the UE to the proper power level before running the measurement by setting UL CL Power Control Mode to Active Bits and UE Target Power to the desired level.

In FDD Test Operating Mode , you must ensure that the UE is synchronized to the downlink frame clock before running the measurement. You must properly range the test set's receiver before running the measurement by setting the Expected Power and the UE's output power level accordingly. It is recommended that you set Power Control to Auto and use the UE Target Power setting to set the expected power (rather than setting Power Control to Manual and using the Manual Power setting). Auto power control is recommended because after completion of the measurement, the test set sets UE Target Power to the power level of the last measured step to aid in maintaining the connection between the test set and UE. The test set does not change the Manual Power setting to match the power level of the last measured step.

Phase Discontinuity Measurement Parameters

  • Trigger Source

    Trigger Source can be set to Protocol , External or HS-DPCCH ( lab application or feature-licensed test application only ). See Trigger Source Description .

    When Trigger Source is set to Protocol :

    • When Power Control Pattern is set to NONE , the test set uses the 10 ms frame clock to trigger the measurement on the first available frame.
    • When Power Control Pattern is set to 5UP/4DOWN , 5DOWN/4UP , 18 UP or 18 DOWN and Trigger Source is set to Protocol , the measurement triggers on the frame in which the pattern transmission starts.

    When Trigger Source is set to HS-DPCCH , the measurement triggers at the location specified by the HS-DPCCH Trigger Subframe Alignment , HS-DPCCH Trigger Slot Alignment and HS-DPCCH Trigger Subslot Alignment settings (see Measurement Step Interval and Trigger Placement for HSDPA ).

  • Measurement Timeout (see Measurement Timeouts ).

Non-HSDPA Phase Discontinuity Measurement Parameters

The following settings are only applicable when Trigger Source is set to Protocol or External .

  • Power Control Pattern

    When Power Control Pattern is set to 5UP/4DOWN or 5DOWN/4UP :

    • When the measurement is initiated, the test set checks to see that UL CL Power Ctrl Algorithm is set to One and UL CL Power Ctrl Stepsize is set to 1 dB . If not, the test set sends the UE a Physical Channel Reconfiguration message with these values. (When the measurement completes, the values are returned to their pre-measurement states.)
    • The test set then sends a repeating pattern of 5 up bits then 4 down bits or 5 down bits then 4 up bits, until the Number of Pattern Repetitions is reached. Thus the total number of slots measured by the test set is determined by the Number or Pattern Repetitions setting.
    • The Reference Timeslot (first timeslot measured) is always slot 14 of the frame prior to the start of the power control pattern.
    • When the measurement completes, in an attempt to maintain the connection with the UE the test set sets UE Target Power to the UE's output power in the final measured slot and sets UL CL Power Control Mode to Active Bits when in Active Cell Operating Mode or to Alternating Bits when in FDD Test Operating Mode .

    When Power Control Pattern is set to NONE :

    • The power control pattern sent to the UE when the measurement is initiated is determined by the UL CL Power Control Mode setting (for example, 10 Up/Down bits ).
    • The total number of slots measured by the test set is determined by the Measurement Interval setting.
    • The Reference Timeslot (first timeslot measured) is determined by the Reference Timeslot setting.

    When Power Control Pattern is set to 18 UP or 18 DOWN :

    • When the measurement is initiated, the test set checks to see that UL CL Power Ctrl Algorithm is set to One and UL CL Power Ctrl Stepsize is set to 1 dB . If not, the test set sends the UE a Physical Channel Reconfiguration message with these values. (When the measurement completes, the values are returned to their pre-measurement states.)
    • The test set then sends 18 up bits or 18 down bits. When Power Control Pattern is set to 18 UP or 18 DOWN , the Number of Pattern Repetitions is fixed to 1. Thus, the total number of slots measured by the test set for one measurement execution is 19 (the Reference Timeslot plus 18 slots).
    • To measure phase discontinuity across the entire dynamic range of your UE, repeatedly execute the phase discontinuity measurement until the desired range has been tested. Each time the measurement completes, the test set sets UE Target Power to the UE's output power in the final measured slot. Thus, there is no need to change the UE Target Power between measurements that are intended to span the dynamic range of the UE, unless you choose to include some overlap between the consecutive measurements.
    • The Reference Timeslot (first timeslot measured) is always slot 14 of the frame prior to the start of the power control pattern.

  • Number of Pattern Repetitions

    When Power Control Pattern is set to 5UP/4DOWN or 5DOWN/4UP , the Number of Pattern Repetitions setting determines the number of times the chosen pattern is sent to the UE. The measurement ends once the specified number of pattern repetitions has been sent, so this setting determines the total number of slots measured by the test set. The total number of timeslots measured is equal to the Reference Timeslot plus 9*( Number of Pattern Repetitions ). The maximum number of timeslots that can be measured is thus 91.

    When Power Control Pattern is set to NONE , this setting is ignored.

    When Power Control Pattern is set to 18 UP or 18 DOWN , this setting is fixed to 1 .

  • Reference Timeslot

    When Power Control Pattern is set to NONE , the Reference Timeslot setting determines the first timeslot to be measured (within the first available frame after the measurement is initiated). For example, if you set Reference Timeslot to 4 , then the first slot measured will be the 5th slot of the frame (because the slots are numbered 0 to 14 in a frame).

    When Power Control Pattern is set to 5UP/4DOWN , 5DOWN/4UP , 18 UP or 18 DOWN , the Reference Timeslot is always slot 14 of the frame prior to the start of the power control pattern. Thus, this setting is ignored.

    The test set compares all other slots to the Reference Timeslot when determining the Phase (in degrees) result.

  • Measurement Interval

    When Power Control Pattern is set to NONE the Measurement Interval setting determines the number of adjacent slots for the test set to measure. The test set measures the number of slots specified by the Measurement Interval setting, starting with the timeslot specified by Reference Timeslot .

    When Power Control Pattern is set to 5UP/4DOWN , 5DOWN/4UP , 18 UP or 18 DOWN , this setting is ignored.

HSDPA Phase Discontinuity Measurement Parameters

This section is only applicable to the lab application or feature-licensed test application.

The following settings are only applicable when Trigger Source is set to HS-DPCCH .

  • HS-DPCCH Trigger Subframe Alignment

    Selects which 2 ms subframe (0 to 5) contains the measurement trigger (see Measurement Step Interval and Trigger Placement for HSDPA ). When the measurement is initiated, the test set triggers the measurement on the next available subframe specified by this setting.

    GPIB command: SETup:WPDiscon:TRIGger:ALIGnment:HSDPcchannel:SUBFrame

  • HS-DPCCH Trigger Slot Alignment

    Selects which slot in the 2 ms subframe contains the measurement trigger (AckNack = the first slot in the subframe, CQI1 = the second slot in the subframe and CQI2 = the third slot in the subframe). See Measurement Step Interval and Trigger Placement for HSDPA .

    GPIB command: SETup:WPDiscon:TRIGger:ALIGnment:HSDPcchannel:SLOT

  • HS-DPCCH Trigger Subslot Alignment

    Selects where to place the measurement trigger within the slot selected by the HS-DPCCH Trigger Slot Alignment setting (at the slot boundary or at the slot half-way point). See Measurement Step Interval and Trigger Placement for HSDPA .
    Note, the sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Step Interval cannot exceed 1.0 slot.

    GPIB command: SETup:WPDiscon:TRIGger:ALIGnment:HSDPcchannel:SUBSlot

  • HS-DPCCH Measurement Step Interval

    Sets the measurement step size (one slot or one half slot). See Measurement Step Interval and Trigger Placement for HSDPA .
    Note, the sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Step Interval cannot exceed 1.0 slot.

    GPIB command: SETup:WPDiscon:STEP:INTerval

  • HS-DPCCH Measurement Step Count

    Sets the number of steps for which to measure phase discontinuity. The number of steps evaluated by the test set is equal to HS-DPCCH Measurement Step Count + 1, because step 0 must be evaluated in order to provide a phase discontinuity result for step 1. No phase discontinuity result is returned for step 0, although all other measurement results are returned for step 0 (phase, power, EVM, etc.).

    GPIB command: SETup:WPDiscon:STEP:COUNt

Phase Discontinuity Measurement Results

The following results are available via the FETCh:WPDiscon[:ALL]? command, or from the front panel (see How Do I Make a Phase Discontinuity Measurement? ).

  • Number of Steps Measured

    The test set reports the number of steps measured. The number of steps measured depends upon the Measurement Interval or Number of Pattern Repetitions setting (non-HSDPA phase discontinuity), or the HS-DPCCH Measurement Step Count setting (HSDPA phase discontinuity).

  • Worst Case Phase Discontinuity Step Number: Indicates which of the measured steps had the worst phase discontinuity. The first measured step is numbered 0. Thus, for example, if the reported Worst Case Phase Discontinuity Step Number is 5 , the 6th step measured had the worst phase discontinuity result.
  • Worst Case Phase Discontinuity (in degrees): Provides the phase discontinuity result for the measured step with the worst phase discontinuity.
  • Worst Case rms EVM Step Number: Indicates which of the measured steps had the worst rms EVM. The first measured step is numbered 0. Thus, for example, if the reported Worst Case rms EVM Step Number is 90 , the 91st step measured had the worst rms EVM result.
  • Worst Case rms EVM (in % rms): Provides the rms EVM result for the measured step with the worst rms EVM.

The following results are only available via the FETCh:WPDiscon:EVM:PEAK:WORSt? GPIB command (not from the front panel).

  • Worst Case Peak EVM Step Number:

    Indicates which of the measured steps had the worst peak EVM. The first measured step is numbered 0. Thus, for example, if the reported Worst Case Peak EVM Step Number is 90 , the 91st step measured had the worst peak EVM result.

  • Worst Case Peak EVM (in % peak):

    Provides the peak EVM result for the measured step with the worst peak EVM.

Results Returned for Each Step Measured:

As mentioned above, the measurement indicates which step(s) had the worst measurement results. The measurement also returns all measurement results for all measured steps.

The measurement results for all steps are available from the front panel (except peak EVM; peak EVM is only available via GPIB). See How Do I Make a Phase Discontinuity Measurement? .

You can also query all of the measurement results (except peak EVM) for a particular step using the FETCh:WPDiscon:STEP?<sp><step num> command. To query the peak EVM for a particular step, use the FETCh:WPDiscon:EVM:PEAK:STEP?<sp><step num> command.

You can also query a particular measurement result for all steps using the FETCh:WPDiscon:TRACe?<sp>DISC|PHASE|POW|EVM|PERR|FERR|MERR|TERR|OOFF|EVMPK command. Simply append the command with the specific measurement result you are interested in, and the results for all measured steps are returned.

  • Phase Discontinuity (in degrees)

    The phase discontinuity reported for any given step is the extrapolated starting phase of that step minus the extrapolated ending phase of the previous step. Thus, no phase discontinuity is reported for the first step (the Reference Timeslot for non-HSDPA phase discontinuity).

  • Phase (in degrees)

    The phase reported for any given step is the extrapolated starting phase of that step normalized to the extrapolated starting phase of the first step (the Reference Timeslot for non-HSDPA phase discontinuity). Thus, the phase of the first step is always zero.

  • Power (in dBm)

    The average power is reported for each step (this is a channel power measurement over the step, excluding the transient periods of 25 us on either side of the nominal step boundaries, with the RRC filter off).

  • rms EVM (in % rms)
  • Phase Error (in degrees)
  • Frequency Error (in Hz)
  • Magnitude Error (in %)
  • Time Error (in chips)
  • Origin Offset (in dB)
  • Peak EVM (in % peak)

Key 3GPP Tests Performed Using the Phase Discontinuity Measurement

The phase discontinuity measurement can be used to test 3GPP TS 34.121 5.13.1AA, 5.13.3, as well as the 3GPP TS 25.101 6.8.4.1 minimum requirement:

Phase Discontinuity Minimum Requirement
Phase Discontinuity (in degrees) | Maximum Allowed Rate of Occurrence (in Hz)
Phase Discontinuity </= 30 | 1500
30 < Phase Discontinuity </= 60 | 300
Phase Discontinuity > 60 | 0

Regarding 3GPP TS 34.121 test 5.13.3: section 5.13.3.4.2 specifies "NOTE: In order to make it practical to measure the entire power control dynamic range (between min power threshold and max power threshold with suitable margins), it is permissible to segment the power control sequences into smaller subsequences. Except when within 5 dB of the upper or lower thresholds, segmentation will require sufficient overlap such that every power step in one direction is followed by four steps in the other direction." This overlap ensures that the full dynamic range of the UE is tested, as there is some uncertainty in the actual UE output power based on Active Bits closed loop power control. Without overlapping the subsequence ending and starting powers, some portion of the UE's output power range may not be tested. To implement the specified overlap, after running the Phase Discontinuity measurement with Power Control Pattern set to 5UP/4DOWN ( or 5DOWN/4UP ), instead of immediately running the measurement again to test the next subsequence, first set UE Target Power to 4 dB below (or above) the ending power of the prior test subsequence. A faster method of ensuring that the full dynamic range of the UE is tested is as follows: after testing two subsequences, compare the Power (in dBm) of the first slot in the current subsequence with the power of the last slot in the prior subsequence to ensure that they are equal or have some overlap. If not, set UE Target Power accordingly and retest the subsequence.

Phase Discontinuity Measurement Input Signal Requirements

  • This measurement does not autorange, therefore the expected power level from the mobile station (UE) is set using the current UE Target Power setting, or by using manual receiver power control and specifying the expected power level. See Receiver Control .
  • Frequency: 800 to 1000 MHz, 1700 to 1990 MHz
  • Input level:
    • -25 dBm to +28 dBm (other measurements returned with Phase Discontinuity)
    • -61 dBm to +28 dBm (Phase Discontinuity measurement only)
  • Maximum measurable EVM: 35% (measurement is only specified for EVM <17.5%)
  • Maximum measurable frequency error: +/- 1 kHz
  • Maximum measurable timing error: +/- 10 us

Phase Discontinuity Measurement Calibration

You must calibrate the phase discontinuity measurement using the measurement calibration procedure (see Calibrating the Test Set ).

Related Topics

Manual Operation: How Do I Make a Phase Discontinuity Measurement?


PRACH Preamble Analysis Measurement Description

PRACH Preamble Analysis Measurement Description

Last updated: January 16, 2009

This section is only applicable to the lab application.

  • How is a PRACH Preamble Analysis Measurement Made?
  • PRACH Preamble Analysis Measurement Parameters
  • PRACH Preamble Analysis Measurement Results
  • Key 3GPP Tests Performed Using the PRACH Preamble Analysis Measurement
  • PRACH Preamble Analysis Measurement Input Signal Requirements
  • PRACH Preamble Analysis Measurement Calibration

How is a PRACH Preamble Analysis Measurement Made?

3GPP TS 25.101, 6.8 states "Transmit modulation defines the modulation quality for expected in-channel RF transmissions from the UE. The requirements apply to all transmissions including the PRACH/PCPCH pre-amble and message parts and all other expected transmissions. In cases where the mean power of the RF signal is allowed to change versus time e.g. PRACH, DPCH in compressed mode, change of TFC and inner loop power control, the EVM and Peak Code Domain Error requirements do not apply during the 25 us period before and after the nominal time when the power is expected to change."

The PRACH preamble analysis measurement determines the modulation and timing errors between the transmitted signal of the UE and the ideal signal. The measurement algorithm is similar to that used in the waveform quality and IQ tuning measurements (see Waveform Quality Measurement Description and IQ Tuning Measurement Description ), except that the measurement is performed on a PRACH preamble burst, rather than over a timeslot of the DPCH transmission.

You can choose whether to include the "transient periods" of 96 chips (25 us) on either side of the PRACH preamble in the measurement using the Transient Period setting (for all measurement results except Relative Power (in dB) ). The measurement can thus be performed over the entire PRACH preamble burst, (4096 chips, or 1066.7 us), or only over 3904 chips (1016.7 us).

Before initiating a PRACH preamble analysis measurement, turn the UE on and wait for it to camp to the test set's signal. When you initiate the PRACH preamble measurement by pressing START SINGLE or sending the INITiate command, the test set sets Call Limit State to On to prevent successful call connection, then pages the UE (the test set returns Call Limit State to its prior setting after completion of the measurement). This forces the UE to transmit PRACH preamble bursts.

After the measurement is triggered by a burst (see Trigger Source ) it must determine which signature the UE used to transmit the PRACH preamble so that it can decode the burst data. To do this, it attempts to correlate the data to each of the signatures specified by the PRACH Signature setting. The measurement will execute fastest if you only specify one available signature.

When operating in FDD Test Operating Mode , you do not have access to the PRACH Signature setting, as the test set does not send this type of signalling to the UE in FDD test operating mode. However, when you initiate the measurement in FDD test operating mode, the measurement uses the value last set in the PRACH signature setting to determine which signatures to try to correlate to the PRACH preamble burst. Thus, before running this measurement in FDD test operating mode, you must switch to Active Cell Operating Mode and ensure that the PRACH Signature setting includes the signature that your UE will transmit.

To perform the PRACH preamble analysis measurement, you must set Available Subchannels (Bit Mask) to only allow one available subchannel.

You must also set PRACH Preambles to at least 3 before initiating this measurement. It is recommended that you set PRACH Preambles to 3 , PRACH Ramping Cycles (MMAX) to 1 , and Call Limit State to Off before initiating this measurement to minimize issues after the measurement has completed. See the following:

  • Recommended PRACH Preambles and PRACH Ramping Cycles (MMAX) settings
  • Importance of Setting Call Limit State to Off before Initiating a PRACH Measurement
  • Test set may lock up if operations are attempted before the UE completes its PRACH sequence

No other measurements can be running when a PRACH preamble analysis measurement is performed. If any measurements are running when a PRACH preamble analysis measurement is initiated, they are closed and a message is displayed to indicate that they were closed.

PRACH Preamble Analysis Measurement Parameters

  • Trigger Source

    You can set Trigger Source as follows:

    • Protocol : If trigger source is set to protocol, the test set monitors every available access slot (as determined by the Available Subchannels (Bit Mask) setting) to see if a significant change in power occurs (which would indicate a PRACH preamble burst is present in that access slot). If a burst is present, the measurement is triggered on the access slot boundary.
    • External : see Trigger Source Description .
    • RF Rise : If trigger source is set to RF rise, the measurement is triggered when the UE's power rises to within 9 dB of the expected power (the expected power is equal to Initial PRACH TX Power if Power Control is set to Auto , or Manual Power if Power Control is set to Manual ; see Receiver Control ). When Trigger Source is set to RF Rise, you may specify a Trigger Delay . When trigger source is set to RF rise, the Timing Error (in chips) result is not available.

  • Trigger Delay

    Trigger delay is only available when Trigger Source is set to RF Rise. The trigger delay setting specifies when to begin the measurement relative to the trigger event. If trigger delay is set to 0 chips, the measurement will begin immediately after the trigger event. See Trigger Delay Description for additional information about trigger delays.

  • Measurement Timeout: (see Measurement Timeouts )
  • Transient Period

    The transient period setting determines whether to include the "transient periods" of 96 chips (25 us) on either side of the PRACH preamble in the measurement. If Transient Period is set to Include , the measurement is performed over the entire PRACH preamble, 4096 chips (1066.7 us). If Transient Period is set to Exclude , the measurement is performed over only 3904 chips (1016.7 us).

    NOTE
    The transient period affects the measurement interval for all measurement results except Relative Power (in dB) . Relative Power is always measured over 4096 chips.

PRACH Preamble Analysis Measurement Results

  • EVM (rms) (in %)

    This result is the rms EVM for the entire PRACH preamble burst (either 4096 or 3904 chips, depending upon the Transient Period setting).

    The EVM for each chip measured in the burst is also available (see EVM (in %) ).

  • EVM (peak) (in %)

    This result is the worst EVM reported for any chip in the burst (either 3904 or 4096 chips are compared, depending upon the Transient Period setting). See EVM (in %) .

  • Frequency Error (in Hz)
  • Origin Offset (in dB)
  • Phase Error (rms) (in degrees)
  • Magnitude Error (in %)
  • Timing Error (in chips)

    This result is the difference in time of the PRACH data relative to the expected timing for the given subchannel setting (see Available Subchannels (Bit Mask) ). See 3GPP TS 25.211, 5.2.2 and 7.3 and 3GPP TS 25.214, 6.1.

    Timing error is not available when Trigger Source is set to RF Rise .

  • IQ Gain Imbalance (in dB)
  • IQ Phase Imbalance (in degrees)
  • Signature: The test set reports the PRACH signature used by the UE for the preamble burst being analyzed. This result may differ from the Detected PRACH Signature result if more than one signature is specified as available by the PRACH Signature setting.

Results Returned for Each Chip Measured

  • Relative Power (in dB)

    The measurement always measures the power in all 4096 chips of the PRACH preamble (regardless of the Transient Period setting), and also measures the power in up to 100 chips before and after the PRACH preamble (if there is a substantial amount of timing error, then fewer than 100 chips before or after the PRACH preamble will be measured and reported). The measurement reports the power in each chip relative to the greatest power measured in any of the chips.

  • EVM (in %)

    This result is the EVM for each measured chip (either 3904 or 4096 chips, depending upon the Transient Period setting).

    The rms EVM (see EVM (rms) (in %) ) and the peak EVM (see EVM (peak) (in %) ) for the entire PRACH preamble burst is also available.

  • Phase Error (in degrees): The measurement calculates the phase difference between each measured chip (either 3904 or 4096 chips, depending upon the Transient Period setting) and its corresponding chip in the ideal signal.
  • IQ Constellation: The measurement plots the I-Q coordinates for each measured chip (either 3904 or 4096 chips, depending upon the Transient Period setting).

A typical measurement result is shown below:

Key 3GPP Tests Performed Using the PRACH Preamble Analysis Measurement

3GPP TS 34.121 5.13.4 PRACH Preamble Quality.

PRACH Preamble Analysis Measurement Input Signal Requirements

  • This measurement does not autorange, therefore the expected power level from the mobile station (UE) is set using the current MS Target Power setting, or by using manual receiver power control and specifying the manual power level. See Receiver Control .
  • The frequency of the signal being measured must be in the range of 800 MHz to 1000 MHz, 1700 MHz to 1990 MHz, or 2480 MHz to 2580 MHz.
  • The level into the test set's RF IN/OUT connector must be in the range of -25 dBm to +28 dBm, in a 3.84 MHz bandwidth.
  • Maximum measurable EVM = 35%.
  • Maximum measurable frequency error = +/- 1 kHz.
  • Maximum measurable timing error = +/- 96 chips (25 us).

PRACH Preamble Analysis Measurement Calibration

This measurement should be calibrated using the Calibrate Measurements function ( CALibration:MEASurements? ) when the temperature has changed by more than ± 10° C since the last calibration. If this situation exists, the integrity indicator value becomes 19 and a message is displayed indicating "Uncalibrated Due to Temperature".

Related Topics

Manual Operation: How Do I Make a PRACH Preamble Analysis Measurement?

Programming the PRACH Preamble Analysis Measurement

PRACH Preamble Analysis Troubleshooting

What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?

Triggering of Measurements

Integrity Indicator


TX Dynamic Power Measurement Description

TX Dynamic Power Measurement Description

Last updated: January 16, 2009

  • How is a TX Dynamic Power Measurement Made?
  • TX Dynamic Power Measurement Parameters
  • TX Dynamic Power Measurement Results
  • TX Dynamic Power Input Signal Requirements
  • Calibrating the TX Dynamic Power Measurement

How is a TX Dynamic Power Measurement Made?

The TX dynamic power measurement aids in power calibration of your UE. The measurement is not performed with a call established between the test set and UE. Rather, you must place your UE into a test mode which forces it to transmit a power sequence of successive down steps of fixed size and duration.

The UE's output power sequence may span some or all of the measurement's input range of -61 dBm to +28 dBm, in up to 99 steps. The steps may be 20, 40 or 80 ms in duration.

Before starting the TX dynamic power measurement, you must use Manual Receiver Control to specify the initial transmit power of the UE's power sequence to properly range the test set's receiver. You must also specify the UE's transmit frequency (see Measurement Frequency ).

Example UE Output Power Profile for TX Dynamic Power Measurement

The UE must trigger the measurement with a positive change in power from 20 dB below the initial transmit power. To ensure successful triggering, it is recommended that you first order the UE to transmit continuously at the initial transmit power level, initiate the measurement, then order the UE to drop and then raise its output power by more than 20 dB to create the RF rise trigger.

Once triggered, the TX dynamic power measurement performs a series of channel power measurements, one at each step of the power sequence. Before measuring the power level of step 0, the test set tunes its receiver according to the Manual Power setting. The test set then tunes its receiver to the proper level before performing each subsequent channel power measurement based on the Power Step Size setting and the measured power of the prior step (this allows the measurement to track UEs that do not correctly decrease power according to the Power Step Size setting). The UE must step its power down and then hold its power constant for each step in the test sequence (the step duration is determined by Power Step Time ). After completing a measurement at each of the requested power steps (based on the Number of Power Steps setting), the test set returns power results for the initial UE transmit power (step 0), and for each of the steps.

Required Initial Conditions

While in FDD Test , Active Cell and Cell Off operating modes, Power Control must be set to Manual . You must then set Manual Power (or Expected CW Power if in CW operating mode) to the initial transmit power of the sequence.

You must set Measurement Frequency to the UE's transmit frequency.

You must set Power Step Size , Power Step Time and Number of Power Steps to match the power sequence to be transmitted by the UE.

Operating Considerations

The TX dynamic power measurement must re-range and re-trigger for every step in the UE's power sequence. To ensure that this process is not interrupted by other operations, it is recommended that you not send any GPIB commands to the test set or press any front panel keys until the measurement has completed. If the measurement misses a trigger, it aborts and returns Integrity Indicator 30 : Missed Trigger .

The TX dynamic power measurement is available in all operating modes. However, it is assumed that the call status is idle as the UE must be operating in a test mode to transmit the required power sequence.

No other measurements can be running when a TX dynamic power measurement is performed. If any measurements are running when a TX dynamic power measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while a TX dynamic power measurement is running, the TX dynamic power measurement is closed and a message is displayed.

TX Dynamic Power Measurement Parameters

  • Power Step Size

    Sets the size (in dB) of each step down in the UE's power sequence. The test set re-ranges its receiver for each channel power measurement based on this setting.

    GPIB command: SETup:WTDPower:STEP[:LEVel]

  • Number of Power Steps

    Sets the number of power steps (down from its initial transmit power) the UE will transmit during its power sequence. The total number of Power results returned by the measurement is 1 + Number of Power Steps .

    GPIB command: SETup:WTDPower:STEP:COUNt

  • Power Step Time

    Sets the duration of each step in the UE's power sequence (20, 40 or 80 ms). The test set triggers each channel power measurement relative to the first RF rise trigger based on this setting. The UE must hold its power constant for this time at each power level in the sequence.

    GPIB command: SETup:WTDPower:STEP:TIME

  • Measurement Timeout - see Measurement Timeouts . Ensure that you set the Measurement Timeout to a value great enough to allow you to command the UE to transmit its power sequence and for the test set to measure the power sequence.

TX Dynamic Power Measurement Results

  • Integrity Indicator
  • Power

    The test set performs a channel power measurement near the center of each power step (nominally 6, 16, or 36 ms after the start of the step when Power Step Time = 20, 40, or 80 ms, respectively), with a measurement interval of 666.7 us and the RRC Filter Off . Power (dBm/5 MHz) is returned for each step in the UE's power sequence. The initial transmit power of the sequence (the power in slot 0, before the first step down in power) is also returned. Thus, the total number of power results returned by the measurement is 1 + Number of Power Steps . The total number of power results can be queried using the FETCh:WTDPower:COUNt[:STEP]? command.

    GPIB command: FETCh:WTDPower[:ALL]?

TX Dynamic Power Input Signal Requirements

The TX dynamic power measurement meets specifications when the following input signal requirements are met:

  • Frequency: 800 to 1000 MHz, 1700 to 1990 MHz, or 2480 MHz to 2580 MHz
  • Input level: -61 dBm to +28 dBm

Calibrating the TX Dynamic Power Measurement

You must calibrate this measurement using the measurement calibration procedure (see Calibrating the Test Set ).

Related Topics

Manual Operation: How Do I Make a TX Dynamic Power Measurement?

Programming a TX Dynamic Power Measurement

TX Dynamic Power Measurement Troubleshooting

Channel Power Measurement Description

Receiver Control

Product Note: Performing W-CDMA Tx Dynamic Power Measurements Using the Agilent 8960 Wireless Communications Test Set

Dynamic Power Analysis Measurement Description


wcdma_muiguide_ch_appendix

Appendix

This Appendix includes some general setup procedures that are required to perform the tests and other helpful information.

The contents are:

  • What 3GPP W-CDMA/HSPA Conformance Tests Are Supported?
  • How Do I Set Up a Call and Make a Connection?
  • How Do I Perform a Handover?
  • Calibrating the Test Set
  • Amplitude Offset


Introduction

Introduction

Last updated: January 16, 2009

The intent of this guide is to help you quickly learn how to use the E1963A and E6703C/D W-CDMA/HSDPA Test and Lab Applications to manually make UE receiver and transmitter tests as specified in the 3GPP TS 34.121 standard.

  • See Making 3GPP TS 34.121 Tests .

The Appendix includes additional information to help you perform the 3GPP TS 34.121 tests:

  • What 3GPP W-CDMA/HSPA Conformance Tests Are Supported? table that shows which tests are supported by the test set.
  • General procedures that are required to set up the measurements.
  • Calibration procedures that must be performed periodically when testing UEs with the test set.
  • Amplitude Offset information to help you properly account for losses in your system.

The scope of this guide does not cover the numerous features and capabilities of the test set. For details, refer to the E1963A, E6703C/D/T Online User's Guide which is available at:

  • http://wireless.agilent.com/rfcomms/refdocs/wcdma/default.php, or
  • User Documentation CD-ROM shipped with your application.


wcdma_muiguide_ch_make_meas

Making 3GPP TS 34.121 Tests

This chapter demonstrates the step-by-step procedures for making many of the tests specified in the 3GPP TS 34.121 standard. The procedures for each test are based on one set of settings as specified for the test. However, the general setup procedures are the same for other sets of settings. To learn more about which tests are supported by the test set, see What 3GPP W-CDMA/HSPA Conformance Tests Are Supported? .

Measurement Procedures
Measurement | General Measurement Procedure | 3GPP TS 34.121 Test Procedure
ACLR | How Do I Make an Adjacent Channel Leakage Ratio (ACLR) Measurement? | 5.10 5.10A (lab application or feature-licensed test application only)
BLER | How Do I Make a Block Error Ratio (BLER) Measurement? | 7.2.1 7.3.1: http://cp.literature.agilent.com/litweb/pdf/1000-1894.pdf
Change of TFC (lab application only) | How Do I Make a Change of TFC (Transport Format Combination) Measurement? | 5.6: Measuring 3GPP TS 34.121 5.6 Change Of TFC
Channel Power | How Do I Make a Channel Power Measurement? | 5.2A (lab application or feature-licensed test application only) : Measuring 3GPP TS 34.121 5.2A Maximum Output Power with HS-DPCCH 5.4.3: Measuring 3GPP TS 34.121 5.4.3 Minimum Output Power
Code Domain | How Do I Make a Code Domain Measurement? |
Data Throughput Monitor (lab application only) | How Do I Use the Data Throughput Monitor? |
Dynamic Power Analysis | How Do I Make a Dynamic Power Analysis Measurement? | 5.7A (lab application or feature-licensed test application only) : Measuring 3GPP TS 34.121 v7.5.0 s5.7A HS-DPCCH
HSDPA BLER (lab application or feature-licensed test application only) | How Do I Make an HSDPA Block Error Ratio Measurement? | 6.3A: Measuring 3GPP TS 34.121 6.3A Maximum Input Level for HS-PDSCH Reception (16QAM)
Inner Loop Power | How Do I Make an Inner Loop Power Measurement? | 5.4.2: Measuring 3GPP TS 34.121 5.4.2 Inner Loop Power Control in the Uplink
IQ Tuning | How Do I Make an IQ Tuning Measurement? |
Loopback BER | How Do I Make a Loopback Bit Error Ratio (BER) Measurement? | 6.2 6.3
Occupied Bandwidth | How Do I Make an Occupied Bandwidth (OBW) Measurement? | 5.8
Out-of-Synch Handling of Output Power (lab application only) | How Do I Make an Out-of-Synch Handling of Output Power Measurement? | 5.4.4: Measuring 3GPP TS 34.121 5.4.4 Out-of-Synchronization Handling of Output Power
Phase Discontinuity | How Do I Make a Phase Discontinuity Measurement? | 5.13.3
PRACH Preamble Analysis (lab application only) | How Do I Make a PRACH Preamble Analysis Measurement? | 5.13.4
PRACH Transmit On/Off Power | How Do I Make a PRACH Transmit On/Off Power Measurement? | 5.4.1: Measuring 3GPP TS 34.121 5.4.1 Open Loop Power Control in the Uplink 5.5.1: Measuring 3GPP TS 34.121 5.5.1 Transmit OFF Power 5.5.2: Measuring 3GPP TS 34.121 5.5.2 Transmit ON/OFF Time Mask
SEM | How Do I Make a Spectrum Emission Mask Measurement? | 5.9 5.9A (lab application or feature-licensed test application only)
Spectrum Monitor | How Do I Use the Spectrum Monitor? |
Thermal Power | How Do I Make a Thermal Power Measurement? | 5.2: Measuring 3GPP TS 34.121 5.2 Maximum Output Power
TX Dynamic Power | How Do I Make a TX Dynamic Power Measurement? |
Waveform Quality | How Do I Make a Waveform Quality Measurement? | 5.3: Measuring 3GPP TS 34.121 5.3 Frequency Error 5.13.1 5.13.1A ( (lab application or feature-licensed test application only) : Measuring 3GPP TS 34.121 v7.5.0 s5.13.1A Error Vector Magnitude (EVM) with HS-DPCCH 5.13.2


Programming an Audio Level Measurement

Programming an Audio Level Measurement

Last updated: January 16, 2009

This section provides an example of how to make an audio level measurement with the Audio Analyzer (AFANalyzer) via GPIB.

The following procedure assumes that an audio source is connected to the AUDIO IN connectors. See Audio Analyzer Measurement Description .

  1. Configure audio analyzer measurement parameters using the SETup subsystem. Even though default settings exist for each parameter, it is a good idea to deliberately set each parameter to make sure the setting is correct for the specific audio analyzer measurement you are making.
  2. Start the audio analyzer measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain audio analyzer measurement results.

Programming Example

10  OUTPUT 714;"SETup:AFANalyzer:CONTinuous OFF" !Set the audio analyzer
20                                           !measurements to single trigger mode.
30  OUTPUT 714;"SETup:AFANalyzer:PEAK:VOLTage 3V" !Set the Expected Amplitude level for
40                                                !audio input voltage in Vpeak.
50  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:STATe OFF" !Turn off the SINAD and
60                                                  !distortion measurements since
70                                                  !they are not being used.
80  OUTPUT 714;"SETup:AFANalyzer:FILTer NONE" !Bypass all audio filters.
90  OUTPUT 714;"SETup:AFANalyzer:DEMPhasis:STATe OFF" !Turn off de-emphasis.
100 OUTPUT 714;"SETup:AFANalyzer:EXPandor:STATe OFF" !Turn off the expandor.
110 OUTPUT 714;"SETup:AFANalyzer:DETector RMS" !Specify the RMS detector for the
120                                            !audio measurement.
130 OUTPUT 714;"SETup:AFANalyzer:TIMeout 3S" !Set a timeout value of 3 seconds
140                                      !in case the measurement cannot be made.
150 OUTPUT 714;"INITiate:AFANalyzer" !Start the AF Analyzer measurement.
160 OUTPUT 714;"FETCh:AFANalyzer:VOLTage?" !Fetch the Audio Level result.
170 ENTER 714;Audio_level  !Enter the returned value into a variable.
180 END

Returned Values

The results returned by this program are:

  • Integrity returns the measurement integrity indicator (0 means a successful measurement with no errors). See Integrity Indicator .
  • Audio_level returns the analog audio level in volts rms.

Related Topics

Audio Analyzer Measurement Description

AFANalyzer Troubleshooting

INITiate

SETup:AFANalyzer

FETCh:AFANalyzer

Control Program Example


Programming an Adjacent Channel Leakage Ratio Measurement

Programming an Adjacent Channel Leakage Ratio Measurement

Last updated: January 16, 2009

This section provides an example of how to make an adjacent channel leakage ratio measurement via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is transmitting an uplink signal.

The program example demonstrates how individual offsets, such as the ± 10 MHz measurements, can be turned off to increase measurement speed, but would normally be left on when making the 3GPP TS 34.121, 5.10 measurement.

The basic procedure to test adjacent channel leakage ratio is as follows:

  1. Set the adjacent channel leakage ratio setup parameters as desired using the SETup:WACLeakage commands.
  2. Use the INITiate:WACLeakage command to start the measurement.
  3. Use the FETCh:WACLeakage? query to obtain the measurement results.

Programming Example

10    OUTPUT 714;"SETup:WACLeakage:CONTinuous OFF"   !Set the adjacent
20                 !channel leakage ratio measurement to single trigger mode.
30    OUTPUT 714;"SETup:WACLeakage:TIMeout 1S"!Set a timeout value of 1 second
40                                  !in case the measurement cannot be made.
50    OUTPUT 714;"SETup:WACLeakage:COUNt 5"!Set multi-measurements to 5 and
60                                     !enable multi-measurements.
70    OUTPUT 714;"SETup:WACLeakage:TRIGger:SOURce AUTO" !Set the trigger source
80                                                   !to use automatic triggering.
90    OUTPUT 714;"SETup:WACLeakage:LOWer2:STATe OFF"  !Turn off the lower
100                              !second alternate (-10 MHz) measurement.
110   OUTPUT 714;"SETup:WACLeakage:UPPer2:STATe OFF"  !Turn off the upper
120                              !second alternate (+10 MHz) measurement.
130   OUTPUT 714;"INITiate:WACLeakage"!Start the adjacent channel leakage
140                                   !ratio measurement.
150   OUTPUT 714;"FETCh:WACLeakage?"!Query the returned integrity indicator, and the
160                                             !measurement values for each offset.
170   ENTER 714;Integrity,Low_1st_alt,Hi_1st_alt,Low_2nd_alt,Hi_2nd_alt  !Enter the
180                                             !returned values into variables.
190   IF Integrity<>0 THEN !Integrity <> 0 indicates  an invalid measurement.
200     PRINT "Measurement problem; check for signal level over/under range condition."
210   ELSE
220   END IF
230   END

Returned Values

  • Integrity stores the returned integrity indicator value (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Because multi-measurements are being used, Low_1st_alt and Hi_1st_alt (± 5 MHz) measurements return the average adjacent channel leakage ratio measurement values for those offsets, in dB. If multi-measurements were not being used, the returned values would be a single measurement value for each frequency offset.
  • Because the Low_2nd_alt and Hi_2nd_alt (± 10 MHz) measurements are turned off in this example, the returned values are always 9.91E+37 (NAN).

Related Topics

  • Adjacent Channel Leakage Ratio Troubleshooting
  • Adjacent Channel Leakage Ratio (ACLR) Measurement Description
  • SETup:WACLeakage
  • INITiate
  • FETCh:WACLeakage
  • Amplitude Offset
  • Integrity Indicator


Programming an Audio Frequency Measurement

Programming an Audio Frequency Measurement

Last updated: January 16, 2009

This section provides an example of how to make an audio frequency measurement with the Audio Analyzer (AFANalyzer) via GPIB.

The following procedure assumes that an audio source is connected to the AUDIO IN connectors. See Audio Analyzer Measurement Description .

  1. Configure audio analyzer measurement parameters using the SETup subsystem. When more than one audio frequency signal may be present, use the 100 Hz bandpass filter to isolate the desired signal for measurement (see the Programming Example below).
  2. Start the audio analyzer measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain audio analyzer measurement results.

Programming Example

10  OUTPUT 714;"SETup:AFANalyzer:CONTinuous OFF" !Set the audio analyzer
20                                           !measurements to single trigger mode.
30 ! OUTPUT 714;"SETup:AFANalyzer:PEAK:VOLTage 3V" !Set the Expected peak voltage
40                                                !for the audio input level in Vpeak.
50  OUTPUT 714;"SETup:AFANalyzer:FREQuency:STATe ON" !Enable audio frequency meausurement.
60  OUTPUT 714;"SETup:AFANalyzer:FILTer TBPass" !Select the 100 Hz bandpass filter.
70  OUTPUT 714;"SETup:AFANalyzer:FILTer:TBPass 6000 Hz" !Set the 100 Hz bandpass
80     !filter's center frequency to 6 kHz (example; to measure SAT frequency).
90  OUTPUT 714;"SETup:AFANalyzer:TIMeout 3S" !Set a timeout value of 3 seconds
100                                      !in case the measurement cannot be made.
110 OUTPUT 714;"INITiate:AFANalyzer" !Start the AF Analyzer measurement.
120 OUTPUT 714;"FETCh:AFANalyzer:FREQuency?" !Fetch the Audio Frequency  result.
130 ENTER 714;Audio_frequency !Enter the returned value into a variable.
140 END

Related Topics

Audio Frequency Measurement Description

AFANalyzer Troubleshooting

Audio Analyzer Measurement Description

INITiate

SETup:AFANalyzer

FETCh:AFANalyzer

Control Program Example


Programming a Fast Device Tune Measurement

Programming a Fast Device Tune Measurement

Last updated: January 16, 2009

This section is only applicable to the lab application or feature-licensed test application.

The basic procedure to make a Fast Device Tune measurement is as follows:

  1. Set the test set's initial conditions (refer to the Set_init_cond subroutine): set operating mode to FDD test, measurement frequency to manual mode, power control to manual mode, and RF generator frequency control to manual mode.
  2. Set up the MS RX Frequency/Power series (3 power step levels plus 7 dummy power levels at 4 frequency points) on the test set to match your MS's configuration (refer to the Set_msrx_series subroutine). See SETup:CFDTune for details on the commands.
  3. Set the MS TX Frequency/Power series (10 power step levels at 4 frequency points) on the test set to match your MS's configuration (refer to the Set_mstx_series subroutine). See SETup:CFDTune for details on the commands.
  4. Verify that your MS is in the proper test mode and is configured to match the MS TX/RX Frequency Power series you've specified in the test set.
  5. Order your MS to transmit continuously at >20 dB below the power level of the first step in MS TX Power Series.
  6. Initiate (arm) the measurement using the INITiate:<measurement mnemonic>[:ON] command, then use the INITiate:CFDTune:ARMed? command to verify that the test set's hardware is successfully set up and ready to receive an RF rise trigger from the MS.
  7. Order your MS to start its MS TX Frequency/Power series (which must generate an RF rise (> 20 dB) to trigger the measurement).
  8. When the measurement is finished, use the FETCh:CFDTune commands to obtain the measurement results.

Programming Example

10    ! ====================================================================
20    !
30    ! Fast Device Tune Programming Example for W-CDMA/HSDPA
40    !
50    ! ====================================================================
60    !
70    ! *** Initialize Program Variables ***
80    !
90       OPTION BASE 0
100       Testset=714
110       CLEAR SCREEN
120       CLEAR 7
130       CLEAR Testset
140       PRINT "*** Fast Device Tune Programming Example for W-CDMA/HSDPA***"
150       PRINT
160     !
170     !
180     !***Set up GPIB timeout***
190       ON TIMEOUT 7,32 CALL Timeout
200     ! Call "Timeout" routine after 32 seconds of GP-IB hang-up
210     !
220     !
230     ! *** Variable declarations ***
240       DIM Mstx_pow$[8000]
250       ALLOCATE REAL Mstx_pow_res(0:399)
260       Sz=16*(20+19) !ASCII Arrays = 16*(20+19) elements
270       ALLOCATE Freq_rx$[Sz],Pow_rx$[Sz],Freq_tx$[Sz],Pow_tx$[Sz]
280     !
290       Op_mode$="FDDTest" !Operating mode.
300       Meas_timeout=15 !Measurement timeout.
310     !
320       Num_freq_steps=4 !Number of Rx and Tx Frequency Steps
330       Num_pow_steps=10 !Number of Rx and Tx Power Steps
340     !
350       Str_ind_freq_rx=0 !Start Index of Rx Frequency
360       Str_ind_pow_rx=0 !Start Index of Rx Power
370     !
380       Freq_rx$="1932.4E6, 1950.4E6, 1966.4E6, 1982.4E6"
390     ! MS RX Frequencies
400       Pow_rx$="-80, -60, -40, -60, -60, -60, -60, -60, -60, -60"
410     ! MS RX Powers (last 7 values are "dummy" values)
420     !
430       Str_ind_freq_tx=0 !Start Index of Tx Frequency
440       Str_ind_pow_tx=0 !Start Index of Tx Power
450     !
460       Freq_tx$="1852.4E6, 1870.4E6, 1886.4E6, 1902.4E6"
470     ! MS TX Frequencies
480       Pow_tx$="16, 12, 8, 4, 0, -4, -8, -12, -16, -20"
490     ! MS TX Powers
500     !
510       Loss_frequency$="800E6"!Set frequencies for path loss
520       Expected_loss$="-1.5"!Set path loss at frequencies specified
530     !
540     !************************************
550     !***Simple Test Executive
560     !************************************
570     !
580       GOSUB Preset_test_set
590     !End any current connection and preset test set
600       GOSUB Set_path_loss
610     !Set the pass loss required for your test.
620       GOSUB Set_init_cond
630     !Set initial conditions required for the FDT test
640       GOSUB Set_msrx_series
650     !Set up the MS Rx Freq/Power Series
660       GOSUB Set_mstx_series
670     !Set up the MS Tx Freq/Power Series
680       GOSUB Check_ms_config
690     !Check UE settings match what you've set on the test set
700       GOSUB Fdt_meas
710     !Make the Fast Device Tune measurement.
720       GOTO End_program
730       !
740     !
750     !**************************************************************************
760     ! BEGINNING OF SUBROUTINES
770     !**************************************************************************
780     !
790     !
800  Preset_test_set:         !
810         !*******************************************************************
820         ! Subroutine: Preset the test set (Step 1: Set Up the Test Set)
830         !*******************************************************************
840           !
850       OUTPUT Testset;"*RST"
860         ! Full preset test set
870       RETURN
880          !
890  Set_path_loss:     !
900      !*******************************************************************
910      ! Subroutine: Set path loss values
920      !*******************************************************************
930           !
940       OUTPUT Testset;"SYST:CORR:FREQ ";Loss_frequency$
950         ! Set the frequencies for amplitude offset
960       OUTPUT Testset;"SYST:CORR ";Expected_loss$
970         ! Set the amplitude offsets for above frequencies
980       RETURN
990           !
1000  Set_init_cond:    !
1010      !*******************************************************************
1020      ! Subroutine: Set initial conditions required for the FDT Test
1030      !*******************************************************************
1040            !
1050       OUTPUT Testset;"CALL:OPER:MODE ";Op_mode$
1060          !Set Operating Mode
1070       OUTPUT Testset;"SET:CFDT:TIM "&VAL$(Meas_timeout)
1080          !Set measurement timeout.
1090       OUTPUT Testset;"CALL:CONT:DOWN:FREQ:AUTO OFF"
1100          !Set RF generator frequency control to manual mode.
1110       OUTPUT Testset;"RFAN:CONT:MEAS:FREQ:AUTO OFF"
1120          !Set receiver measurement frequency control to manual mode.
1130       OUTPUT Testset;"RFAN:CONT:POW:AUTO OFF"
1140          !Set receiver power control to manual mode.
1150       RETURN
1160      !
1170  Set_msrx_series:      !
1180           !*******************************************************************
1190           ! Subroutine: Set up the MS Rx Freq/Power Series
1200           !*******************************************************************
1210          !
1220       PRINT "*** Set the number of Tx/Rx Frequency and Power Steps ***"
1230       OUTPUT Testset;"SET:CFDT:FREQ:STEP:COUN ";Num_freq_steps
1240       OUTPUT Testset;"SET:CFDT:POW:STEP:COUN ";Num_pow_steps
1250       PRINT "Number of Tx/Rx Frequency Steps = ";Num_freq_steps
1260       PRINT "Number of Tx/Rx Power Steps = ";Num_pow_steps
1270       PRINT
1280       PRINT "*** Set MS Rx Freq/Power Series ***"
1290       Stp_ind_freq_rx=Str_ind_freq_rx+Num_freq_steps
1300          ! Compute Stop Index of Frequency steps
1310       Stp_ind_pow_rx=Str_ind_pow_rx+Num_pow_steps
1320          ! Compute Stop Index of Power steps
1330          !
1340          ! Check for Mx Rx Test Freq/Power Indicies Out of Range
1350       IF (Stp_ind_freq_rx<40 AND Stp_ind_pow_rx<40) THEN
1360           ! Set MS Rx Frequency and Power Start Indicies
1370           OUTPUT Testset;"SET:CFDT:MS:RX:FREQ:STEP:STAR:IND ";Str_ind_freq_rx
1380           OUTPUT Testset;"SET:CFDT:MS:RX:POW:STEP:STAR:IND ";Str_ind_pow_rx
1390           PRINT "MS Rx Test Start Freq Index = ";Str_ind_freq_rx
1400           PRINT "MS Rx Test Start Power Index = ";Str_ind_pow_rx
1410       ELSE
1420           PRINT
1430           PRINT "Error-The number of freq steps or power steps Out of Range (>40)"
1440           PRINT
1450           PRINT "Program Stopped"
1460           STOP
1470       END IF
1480            !
1490          !*** Set MS Rx Freq/Power Values ***
1500       OUTPUT Testset;"SET:CFDT:MS:RX:FREQ:STEP ";Freq_rx$
1510       PRINT "MS Rx Test Freq Series = ";Freq_rx$
1520       OUTPUT Testset;"SET:CFDT:MS:RX:POW:STEP ";Pow_rx$
1530       PRINT "MS Rx Test Power Series = ";Pow_rx$
1540       PRINT
1550          !
1560       RETURN
1570          !
1580  Set_mstx_series:       !
1590        !*******************************************************************
1600        ! Subroutine: Set up the MS Tx Freq/Power Series
1610        !*******************************************************************
1620       PRINT "*** Set MS Tx Freq/Power Series ***"
1630       Stp_ind_freq_tx=Str_ind_freq_tx+Num_freq_steps
1640          ! Compute Stop Index of Frequency steps
1650       Stp_ind_pow_tx=Str_ind_pow_tx+Num_pow_steps
1660          ! Compute Stop Index of Power steps
1670          !
1680          ! Check for MS Tx Test Freq/Power Indicies Out of Range
1690       IF (Stp_ind_freq_tx<40 AND Stp_ind_pow_tx<40) THEN
1700           ! Set MS Tx Frequency and Power Start Indicies
1710           OUTPUT Testset;"SET:CFDT:MS:TX:FREQ:STEP:STAR:IND ";Str_ind_freq_tx
1720           OUTPUT Testset;"SET:CFDT:MS:TX:POW:STEP:STAR:IND ";Str_ind_pow_tx
1730           PRINT "MS Tx Test Start Freq Index =";Str_ind_freq_tx
1740           PRINT "MS Tx Test Start Power Index =";Str_ind_pow_tx
1750       ELSE
1760           PRINT
1770           PRINT "Error-The number of freq steps or power steps Out of Range (>40)"
1780           PRINT
1790           PRINT "Program Stopped"
1800           STOP
1810       END IF
1820            !
1830           !*** Set MS Tx Freq/Power Values ***
1840           !
1850       OUTPUT Testset;"SET:CFDT:MS:TX:FREQ:STEP ";Freq_tx$
1860       PRINT "MS Tx Test Freq Series = ";Freq_tx$
1870       OUTPUT Testset;"SET:CFDT:MS:TX:POW:STEP ";Pow_tx$
1880       PRINT "MS Tx Test Power Series = ";Pow_tx$
1890       PRINT
1900          !
1910       RETURN
1920      !
1930  Check_ms_config:          !
1940          !*******************************************************************
1950          ! Subroutine: Check UE's Configuration Matches Test Set's
1960          !*******************************************************************
1970       PRINT "************** NOTE *****************************************"
1980       PRINT "Make sure that your UE is placed into a test mode, and is properly"
1990       PRINT "configured to measure the MS RX Freq/Power series and transmit"
2000       PRINT "the MS TX Freq/Power series you've set in the test set."
2010       PRINT
2020       PRINT "Order your UE to transmit continuously at >20 dB below the power level"
2030       PRINT "of the first step in MS Tx Power Series"
2040       PRINT "*************************************************************"
2050       PRINT
2060       LINPUT "Press ENTER when finished",Keyboard$
2070       RETURN
2080            !
2090  Fdt_meas:     !
2100        !*******************************************************************
2110        ! Subroutine: Perform FDT Measurement
2120       !*******************************************************************
2130      !
2140       OUTPUT Testset;"INIT:CFDT"
2150      !Arm the FDT measurement and start to build the MS Tx and Rx Freq/Power Series.
2160       OUTPUT Testset;"INIT:CFDT:ARMed?"
2170      !Queries that the MS Tx and Rx Freq/Power Series is successfully built
2180      !and the test set is ready for test.
2190       ENTER Testset;Meas_arm
2200       IF Meas_arm THEN
2210           PRINT "Command the UE to trigger the measurement (20 dB RF rise)..."
2220           PRINT
2230           !
2240           !***Obtain measurement results***
2250           OUTPUT Testset;"FETC:CFDT?"
2260           ENTER Testset;Integrity,Freq_step_cnt,Pow_step_cnt,Num_meas,Mstx_pow$
2270           !
2280       ELSE
2290           PRINT "The test set is not properly armed. Please check the MS Tx and"
2300           PRINT "Rx Freq/Power Series Setups."
2310           GOTO End_program
2320       END IF
2330           !
2340       PRINT "*** Print MS Tx Measurement Results ***"
2350       PRINT
2360       PRINT "Integrity = ";Integrity
2370       PRINT "Number of Freq Steps = ";Freq_step_cnt
2380       PRINT "Number of Power Steps = ";Pow_step_cnt
2390       PRINT "Total Number of Meas Results = ";Num_meas
2400       PRINT
2410          !
2420          !Convert ASCII Array to Real Array
2430       FOR N=1 TO Num_meas
2440           Dynamic_mkr=((N-1)*17)
2450        !Set up a marker that will jump to each comma in the ascii string
2460           Mstx_pow_res(N)=VAL(Mstx_pow$[Dynamic_mkr+1,Dynamic_mkr+16])
2470        !Convert ascii to a numeric value
2480       NEXT N
2490            !
2500          ! PRINT "MS Tx Power Results:"
2510       PRINT "Freq Step #   Power Step #  Meas Power[dBm/5 MHz]"
2520       PRINT
2530       FOR N_freq=0 TO Freq_step_cnt-1
2540           FOR N_pow=0 TO Pow_step_cnt-1
2550               PRINT N_freq+1," ",N_pow+1," ",Mstx_pow_res(N_freq*Pow_step_cnt+N_pow+1)
2560           NEXT N_pow
2570           PRINT
2580       NEXT N_freq
2590        !
2600       RETURN
2610       !
2620  End_program:     !
2630          !*******************************************************************
2640          ! Subroutine: End of all testing clean up
2650          !*******************************************************************
2660            !
2670       OUTPUT Testset;"*RST"
2680      !Full preset test set
2690       DEALLOCATE Mstx_pow_res(*),Freq_rx$,Pow_rx$,Freq_tx$,Pow_tx$
2700       PRINT
2710       PRINT "End of Program"
2720       END
2730      !
2740      !**************************************************************************
2750      ! SUB-PROGRAM SECTION
2760      !**************************************************************************
2770            !
2780  Timeout: SUB Timeout            ! Global timeout handler
2790           PRINT
2800           PRINT "Program timed out, check setup"
2810           CLEAR 7
2820           CLEAR Testset
2830           STOP
2840       SUBEND
2850      !
2860 !

The measurement results include an integrity indicator, the number of frequency steps (Freq_step_cnt), the number of power steps at each frequency (Pow_step_cnt), number of MS TX power steps measured (Num_meas should equal Freq_step_cnt * Pow_step_cnt), followed by Num_meas power results.

A sample output from this program example is shown below:

Related Topics

  • Fast Device Tune Troubleshooting
  • Fast Device Tune Measurement Description
  • Receiver Control
  • Amplitude Offset
  • Integrity Indicator


Programming a Channel Power Measurement

Programming a Channel Power Measurement

Last updated: February 5, 2009

This section provides examples of how to make channel power measurements via GPIB.

  • General Channel Power Programming Example
  • Program Example: 5.2B Maximum Output Power with HS-DPCCH and E-DCH (lab application or feature-licensed test application only)

The basic procedure to test channel power is as follows:

  1. Set the channel power Setup parameters as desired using the SETup:WCPower commands.
  2. Use the INITiate:WCPower command to start the measurement.
  3. Use the FETCh:WCPower? query to obtain the measurement results.

General Channel Power Programming Example

The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is transmitting an uplink signal.

10    OUTPUT 714;"SETup:WCPower:CONTinuous OFF"!Set the channel power
20                                     !measurement to single trigger mode.
30    OUTPUT 714;"SETup:WCPower:TIMeout 1S"!Set a timeout value of 1 second
40                                  !in case the measurement cannot be made.
50    OUTPUT 714;"SETup:WCPower:COUNt 5"!Set multi-measurements to 5 and
60                                     !enable multi-measurements.
70    OUTPUT 714;"SETup:WCPower:INTerval:TIME 666.7US"!Set the measurement interval
80                                                   !for 1 timeslot (666.7 us).
90    OUTPUT 714;"SETup:WCPower:TRIGger:SOURce AUTO" !Set the trigger source
100                                                  !to use automatic triggering.
110   OUTPUT 714;"INITiate:WCPower"!Start the channel power measurement.
120   OUTPUT 714;"FETCh:WCPower?"!Query the returned integrity indicator and the
130                              !average channel power measurement.
140   ENTER 714;Integrity,Wcpower!Enter the returned values into variables.
150   IF Integrity<>0 THEN !Integrity <> 0 indicates an invalid measurement.
170     PRINT "Measurement problem; check for signal level over/under range condition."
171   ELSE
180   END IF
190   END
  • Integrity stores the returned integrity indicator value (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Wcpower returns the average channel power measurement value in dBm.

Program Example: 5.2B Maximum Output Power with HS-DPCCH and E-DCH

This section is only applicable to the lab application or feature-licensed test application.

This procedure conforms to 34.121 v7.5.0 plus CR R5-072417.

10 ! Channel Power Programming Example
20 ! 3GPP TS 34.121 5.2B Maximum Output Power with HS-DPCCH and E-DCH
30 !
40   Testset=714
50   OUTPUT Testset;"*RST"! Full preset the test set
60   CLEAR SCREEN
70   PRINT "3GPP TS 34.121 5.2B Max Output Power with HS-DPCCH and E-DCH"
80   PRINT
90 !
100 ! *** Set Up Connection Parameters ***
110 !
120   OUTPUT Testset;"CALL:OPERating:MODE OFF"! Operating Mode = Cell Off
130   OUTPUT Testset;"CALL:CELL:RLC:REEStablish OFF"! RLC Reestablish
140   OUTPUT Testset;"CALL:PSDomain PRESent"! PS Domain Information
150   OUTPUT Testset;"CALL:CHANnel 10563"! DL Chan low range freq (Band I IMT-2000)
160 !
170 ! *** Set Up Test Parameters ***
180 !
190   OUTPUT Testset;"CALL:UPLink:DPCHannel:BETA:AUTO 0"! Manual beta control
200   OUTPUT Testset;"CALL:UPLink:DPCHannel:MANual:CBETa 11"! Betac=11/15 (sub-test 1)
210   OUTPUT Testset;"CALL:UPLink:DPCHannel:MANual:DBETa 15"! Betad=15/15 (sub-test 1)
220   OUTPUT Testset;"CALL:UPLink:TXPower:LEVel:MAXimum 21"! Max UL Transmit Power Lvl
230   OUTPUT Testset;"CALL:POWer -86"                            ! Cell Power
240   OUTPUT Testset;"CALL:SERVice:RBTest:RAB HSParmc12"         ! Channel Type
250   OUTPUT Testset;"CALL:CONNected:CPIChannel:HSPA -10"        ! CPICH Level
260   OUTPUT Testset;"CALL:CONNected:CCPChannel:PRIMary:HSPA -12"! P-CCPCH/SCH Level
270   OUTPUT Testset;"CALL:CONNected:PICHannel:HSPA -15"         ! PICH Level
280   OUTPUT Testset;"CALL:CONNected:DPCHannel:HSPA -10"         ! DPCH Level
290   OUTPUT Testset;"CALL:CONNected:EAGChannel -20"             ! E-AGCH Level
300   OUTPUT Testset;"CALL:CONNected:EHIChannel -20"             ! E-HICH Level
310   OUTPUT Testset;"CALL:CONNected:ERGChannel:STATe OFF"       ! E-RGCH State
320   OUTPUT Testset;"CALL:CONNected:HSPDschannel:HSPA -3"       ! HS-PDSCHs Level
330   OUTPUT Testset;"CALL:CONNected:HSSCchannel:HSPA -8"        ! HS-SCCH 1 Level
340   OUTPUT Testset;"CALL:HSUPa:SERVice:RBTest:RLCSdu:SIZE BITS2936"! E-DCH RLC SDU Size
350   OUTPUT Testset;"CALL:HSUPa:EDPCchannel:POFFset 6"! E-DPCCH/DPCH PO (sub-test 1)
360   OUTPUT Testset;"CALL:HSUPa:ETFCi:POFFsets:REFerence DEF3412101"! Ref E-TFCI POs
370   OUTPUT Testset;"CALL:HSUPa:SGRant:ABSolute:RBSetup INDex26"! RB Setup AG (sub-test 1)
380   OUTPUT Testset;"CALL:HSDPa:SERVice:RBTest:HSDSchannel:CONFig FRC"! HS-DSCH Config
390   OUTPUT Testset;"CALL:HSDPa:SERVice:RBTest:FRC:TYPE QPSK1"  ! FRC Type
400   OUTPUT Testset;"CALL:HSDPa:MACHs:NTRans 4"                 ! Number of Trans
410   OUTPUT Testset;"CALL:HSDPa:MACHs:RVSequence '0,2,5,6,0,0,0,0'"! RV Sequence
420   OUTPUT Testset;"CALL:HSDPa:UPLink:DACK 8"                  ! DeltaACK=30/15
430   OUTPUT Testset;"CALL:HSDPa:UPLink:DNACK 8"                 ! DeltaNACK=30/15
440   OUTPUT Testset;"CALL:HSDPa:UPLink:DCQI 8"                  ! DeltaCQI=30/15
450   OUTPUT Testset;"CALL:HSDPa:UPLink:ANACk:RFACtor 3"! Ack-Nack Repetition Factor
460   OUTPUT Testset;"CALL:HSDPa:UPLink:CQI:FCYCle 4 MS"         ! CQI Feedback Cycle
470   OUTPUT Testset;"CALL:HSDPa:UPLink:CQI:RFACtor 2"           ! CQI Repetition Factor
480   OUTPUT Testset;"CALL:CELL:CLPControl:UPLink:ALGorithm ALG2"! UL CL Power Ctrl Alg
490   OUTPUT Testset;"CALL:OPERating:MODE CALL"! Operating Mode = Active Cell
500 !
510 ! *** Make a Connection ***
520 !
530   BEEP
540   PRINT "Power on the UE, wait for it to register/attach, then Originate a call"
550   PRINT "If HSUPA Throughput = 0 kbps, send the appropriate Single Shot AG for"
560   PRINT "your sub-test (20: (119/15)^2 for sub-test 1)"
570   PRINT
580   PRINT "Press F2 to continue"
590   PRINT
600   PAUSE
610 !
620 ! *** Drive the UE to Max Power ***
630 !
640 ! Set UE Target Power to drive UE power to 6 dB below max power, wait 150 ms
650   OUTPUT Testset;"CALL:CLPControl:UPLink:MODE ACTive"! Active bits power control
660   OUTPUT Testset;"CALL:MS:POwer:TARGet 4"! UE Target Pow (sub-test 1, power class 3)
670   WAIT .15
680   OUTPUT Testset;"CALL:CLPControl:UPLink:MODE UDOW"! Alternating bits power control
690 !
700 ! Use Channel Power to confirm proper starting power
710   OUTPUT Testset;"SETup:WCPower:POWer:RANGe:OFFSet:MANual 14"
720   ! Manual Power Range Offset = 14 dB for sub-test 1
730   OUTPUT Testset;"READ:WCPower?"! INITiate and FETCh Channel Power
740   ENTER Testset;Integrity,Chanpow
750   BEEP
760   PRINT USING " ""Starting Channel Power (dBm) = "",2D.1D ";Chanpow
770   PRINT "If starting Channel Power is greater than 18 dBm (power class 3),"
780   PRINT "send down power control bit(s) as needed."
790   PRINT
800   PRINT "Press F2 to continue."
810   PRINT
820   PAUSE
830 !
840 ! Determine starting E-TFCI
850   OUTPUT Testset;"CALL:STATus:ETFCi?"! Last Received E-TFCI
860   ENTER Testset;Lastetfci
870   PRINT "Initial E-TFCI = ";Lastetfci
880   PRINT "(Target E-TFCI is 75 for sub-test 1)"
890   PRINT
900 !
910 ! Dimension array for E-TFCI results and set record number to 15
920   DIM Etfci(49)
930   OUTPUT Testset;"CALL:HSUPa:ETFCi:RECord:COUNt 15"! E-TFCI Rec Count
940 !
950 ! Send step up TPC bit and record 150 ms of E-TFCI results
960   PRINT "E-TFCI values after step up bit(s): "
970   LOOP
980       OUTPUT Testset;"CALL:CLPControl:UPLink:UP"! Send step up TPC bit
990       GOSUB Recordetfci
1000   !
1010 ! Determine if UE sent a decreased E-TFCI
1020       GOSUB Decreasedetfci
1030   EXIT IF Etfcicheck=1! Exit loop once UE reports a decreased E-TFCI
1040   END LOOP
1050 !
1060 ! Send step down TPC bit and record 150 ms of E-TFCI results
1070   PRINT "E-TFCI values after first step down bit: "
1080   OUTPUT Testset;"CALL:CLPControl:UPLink:DOWN"! Send step down TPC bit
1085   WAIT .15 ! Additional wait time may be required here depending on the UE model.
1090   GOSUB Recordetfci
1100 !
1110 ! Determine if UE sent a decreased E-TFCI
1120   GOSUB Decreasedetfci
1130   IF Etfcicheck=1 THEN ! If a decrease E-TFCI occurred, send another down TPC bit
1140       OUTPUT Testset;"CALL:CLPControl:UPLink:DOWN"! Send step down TPC bit
1145       WAIT .15 ! Additional wait time may be required here depending on the UE model.
1150       GOSUB Recordetfci
1160       PRINT
1170       PRINT "E-TFCI values after second step down bit: "
1180       FOR N=0 TO 14
1190           PRINT Etfci(N);
1200       NEXT N
1210       PRINT
1220       PRINT
1230   END IF
1240 !
1250 ! Determine if E-TFCI matches target E-TFCI
1260   Targetetfci=75! (sub-test 1)
1270   PRINT "Target E-TFCI =";Targetetfci
1280   Etfcipass=1! UE will pass unless array values don't match target E-TFCI
1290   FOR N=0 TO 14
1300       IF Etfci(N)<>Targetetfci THEN Etfcipass=0
1310   NEXT N
1320   IF Etfcipass=0 THEN ! If any E-TFCI doesn't match target E-TFCI, UE fails
1330       PRINT "Recorded E-TFCI does not match the Target E-TFCI of 75 for sub-test 1"
1340       STOP
1350   END IF
1360   PRINT "E-TFCI matches Target E-TFCI"
1370   PRINT
1380 !
1390 ! *** INITiate and FETCh Measurements ***
1400   OUTPUT Testset;"READ:WCPower?"! INITiate and FETCh Channel Power
1410   ENTER Testset;Integrity,Chanpow
1420 !
1430 ! *** Print Measurement Results ***
1440   PRINT "Integrity (0 = normal) =";Integrity
1450   PRINT USING " ""Channel Power (dBm)    = "",2D.1D ";Chanpow
1460   PRINT
1470   PRINT "Requirement for sub-test 1 power class 3 UE: 24 dBm +1.7/-5.2 dB"
1480 !
1490   GOSUB Endprogram
1500 !
1510 !========================================
1520 ! *** Subroutines ***
1530 !========================================
1540 !
1550  Recordetfci:! Records E-TFCIs and enters them into the Etfci() array
1560   OUTPUT Testset;"CALL:HSUPa:ETFCi:RECord:STARt"! Start Recording E-TFCI
1570   LOOP
1580       OUTPUT Testset;"CALL:STATus:ETFCi:RECord?"! E-TFCI Recording State
1590       ENTER Testset;Recordstate$
1600   EXIT IF Recordstate$="IDLE"! Exit loop when recording is complete
1610   END LOOP
1620   OUTPUT Testset;"CALL:STATus:ETFCi:RECord:ALL?"! Query E-TFCI results
1630   ENTER Testset;Etfci(*)! Enter E-TFCI results into array
1640   RETURN
1650   !
1660  Decreasedetfci:! Prints 15 E-TFCI results and returns Eftcicheck = 1 if any
1670                 ! Decreased E-TFCIs occurred
1680   Etfcicheck=0
1690   FOR N=0 TO 14
1700       PRINT Etfci(N);
1710       IF Etfci(N)<Lastetfci OR Etfci(N)=9.91E+37 THEN Etfcicheck=1
1720       ! Is any E-TFCI value decreased from starting E-TFCI? If so, set Etfcicheck = 1
1730       ! Also allows program to continue if no E-TFCIs from UE
1740   NEXT N
1750   PRINT
1760   PRINT
1770   RETURN
1780 !
1790  Endprogram:!
1800   END

An example output from this program is as follows:

Related Topics

  • Channel Power Troubleshooting
  • Channel Power Measurement Description
  • SETup:WCPower
  • INITiate
  • FETCh:WCPower
  • Amplitude Offset
  • Integrity Indicator


Programming a Code Domain Measurement

Programming a Code Domain Measurement

Last updated: January 16, 2009

This section provides examples of how to make code domain measurements via GPIB.

  • General Code Domain Programming Example
  • Program Example: 5.2D UE Relative Code Domain Power Accuracy for HS-DPCCH and E-DCH (lab application or feature-licensed test application only)
  • Program Example: 5.13.2B Relative Code Domain Error with HS-DPCCH and E-DCH (lab application or feature-licensed test application only)

The basic procedure is as follows:

  1. Set the code domain setup parameters as desired using the SETup:WCDomain commands.
  2. Use the INITiate:WCDomain command to start the measurement.
  3. Use FETCh:WCDomain? queries to obtain the measurement results.

General Code Domain Programming Example

The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is synchronized to the test set and is transmitting an uplink signal.

10    ! Set trigger mode to single for the Code Domain measurement
20    OUTPUT 714;"SETup:WCDomain:CONTinuous OFF"
30    ! Set a timout value of 5 seconds and enable the timeout state
40    OUTPUT 714;"SETup:WCDomain:TIMeout 5"
50    ! Set the trigger source to automatically select the appropriate
60    !  trigger
70    OUTPUT 714;"SETup:WCDomain:TRIGger:SOURce AUTO"
80    ! Set the timeslot to be measured
90    OUTPUT 714;"SETup:WCDomain:TSLot 7"
100   ! Initiate the Code Domain measurement
110   OUTPUT 714;"INITiate:WCDomain"
120   ! Fetch the integrity indicator and the results of the measurement
130   OUTPUT 714;"FETCh:WCDomain:INTegrity?;BETas?"
140   ENTER 714;Integrity,Bc1,Bd1,Bd2,Bd3,Bd4,Bd4,Bd5
150   ! Check the integrity indicator to ensure the results are valid
160   IF Integrity<>0 THEN
170     PRINT "Measurement failed."
180   ELSE
190   ! Process the measurement results.
200   END IF
210   END
  • Integrity stores the returned integrity indicator value (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Bc1 returns the relative amplitude level for the DPCCH (bc).
  • Bd1 returns the relative amplitude level for the DPDCH (bd1).
  • Bd2 - Bd6 returns "NAN" (Not A Number). These are reserved for use in the future.

Program Example: 5.2D UE Relative Code Domain Power Accuracy for HS-DPCCH and E-DCH

This section is only applicable to the lab application or feature-licensed test application.

This procedure conforms to 34.121 v7.5.0 plus CR R5-072417.

10 ! Code Domain Power Programming Example
20 ! 3GPP TS 34.121 5.2D UE RCDPA for HS-DPCCH and E-DCH
30 !
40   Testset=714
50   OUTPUT Testset;"*RST"! Full preset the test set
60   CLEAR SCREEN
70   PRINT "3GPP TS 34.121 5.2D UE RCDPA for HS-DPCCH and E-DCH"
80   PRINT
90 !
100 ! *** Set Up Connection Parameters ***
110 !
120   OUTPUT Testset;"CALL:OPERating:MODE OFF"! Operating Mode = Cell Off
130   OUTPUT Testset;"CALL:CELL:RLC:REEStablish OFF"! RLC Reestablish
140   OUTPUT Testset;"CALL:PSDomain PRESent"! PS Domain Information
150   OUTPUT Testset;"CALL:CHANnel 10700"! DL Chan mid range freq (Band I IMT-2000)
160 !
170 ! *** Set Up Test Parameters ***
180 !
190   OUTPUT Testset;"CALL:UPLink:DPCHannel:BETA:AUTO 0"! Manual beta control
200   OUTPUT Testset;"CALL:UPLink:DPCHannel:MANual:CBETa 11"! Betac=11/15 (sub-test 1)
210   OUTPUT Testset;"CALL:UPLink:DPCHannel:MANual:DBETa 15"! Betad=15/15 (sub-test 1)
220   OUTPUT Testset;"CALL:UPLink:TXPower:LEVel:MAXimum 21"! Max UL Transmit Power Lvl
230   OUTPUT Testset;"CALL:POWer -86"                            ! Cell Power
240   OUTPUT Testset;"CALL:SERVice:RBTest:RAB HSParmc12"         ! Channel Type
250   OUTPUT Testset;"CALL:CONNected:CPIChannel:HSPA -10"        ! CPICH Level
260   OUTPUT Testset;"CALL:CONNected:CCPChannel:PRIMary:HSPA -12"! P-CCPCH/SCH Level
270   OUTPUT Testset;"CALL:CONNected:PICHannel:HSPA -15"         ! PICH Level
280   OUTPUT Testset;"CALL:CONNected:DPCHannel:HSPA -10"         ! DPCH Level
290   OUTPUT Testset;"CALL:CONNected:EAGChannel -20"             ! E-AGCH Level
300   OUTPUT Testset;"CALL:CONNected:EHIChannel -20"             ! E-HICH Level
310   OUTPUT Testset;"CALL:CONNected:ERGChannel:STATe OFF"       ! E-RGCH State
320   OUTPUT Testset;"CALL:CONNected:HSPDschannel:HSPA -3"       ! HS-PDSCHs Level
330   OUTPUT Testset;"CALL:CONNected:HSSCchannel:HSPA -8"        ! HS-SCCH 1 Level
340   OUTPUT Testset;"CALL:HSUPa:SERVice:RBTest:RLCSdu:SIZE BITS2936"! E-DCH RLC SDU Size
350   OUTPUT Testset;"CALL:HSUPa:EDPCchannel:POFFset 6"! E-DPCCH/DPCH PO (sub-test 1)
360   OUTPUT Testset;"CALL:HSUPa:ETFCi:POFFsets:REFerence DEF3412101"! Ref E-TFCI POs
370   OUTPUT Testset;"CALL:HSUPa:SGRant:ABSolute:RBSetup INDex26"! RB Setup AG (sub-test 1)
380   OUTPUT Testset;"CALL:HSUPa:SGRant:ABSolute:PATTern:VALue INDex20"! (sub-test 1)
390   OUTPUT Testset;"CALL:HSUPa:SGRant:ABSolute:PATTern:VALue2 ZGRant"! Zero Grant
400   OUTPUT Testset;"CALL:HSUPa:SGRant:ABSolute:MODE SSHot"! Single Shot AG Mode
410   OUTPUT Testset;"CALL:HSDPa:SERVice:RBTest:HSDSchannel:CONFig FRC"! HS-DSCH Config
420   OUTPUT Testset;"CALL:HSDPa:SERVice:RBTest:FRC:TYPE QPSK1"  ! FRC Type
430   OUTPUT Testset;"CALL:HSDPa:MACHs:NTRans 4"                 ! Number of Trans
440   OUTPUT Testset;"CALL:HSDPa:MACHs:RVSequence `0,2,5,6,0,0,0,0'"! RV Sequence
450   OUTPUT Testset;"CALL:HSDPa:UPLink:DACK 8"                  ! DeltaACK=30/15
460   OUTPUT Testset;"CALL:HSDPa:UPLink:DNACK 8"                 ! DeltaNACK=30/15
470   OUTPUT Testset;"CALL:HSDPa:UPLink:DCQI 8"                  ! DeltaCQI=30/15
480   OUTPUT Testset;"CALL:HSDPa:UPLink:ANACk:RFACtor 3"! Ack-Nack Repetition Factor
490   OUTPUT Testset;"CALL:HSDPa:UPLink:CQI:FCYCle 4 MS"         ! CQI Feedback Cycle
500   OUTPUT Testset;"CALL:HSDPa:UPLink:CQI:RFACtor 2"           ! CQI Repetition Factor
510   OUTPUT Testset;"CALL:CELL:CLPControl:UPLink:ALGorithm ALG2"! UL CL Power Ctrl Alg
520   OUTPUT Testset;"CALL:OPERating:MODE CALL"! Operating Mode = Active Cell
530 !
540 ! *** Make a Connection ***
550 !
560   BEEP
570   PRINT "Power on the UE, wait for it to register/attach, then Originate a call"
580   PRINT "If HSUPA Throughput = 0 kbps, send the appropriate Single Shot AG for"
590   PRINT "your sub-test (20: (119/15)^2 for sub-test 1)"
600   PRINT
610   PRINT "Press F2 to continue"
620   PRINT
630   PAUSE
640 !
650 ! *** Drive the UE to Max Power ***
660 !
670 ! Set UE Target Power to drive UE power to 6 dB below max power, wait 150 ms
680   OUTPUT Testset;"CALL:CLPControl:UPLink:MODE ACTive"! Active bits power control
690   OUTPUT Testset;"CALL:MS:POwer:TARGet 4"! UE Target Pow (sub-test 1, power class 3)
700   WAIT .15
710   OUTPUT Testset;"CALL:CLPControl:UPLink:MODE UDOW"! Alternating bits power control
720 !
730 ! Use Channel Power to confirm proper starting power
740   OUTPUT Testset;"SETup:WCPower:POWer:RANGe:OFFSet:MANual 14"
750   ! Manual Power Range Offset = 14 dB for sub-test 1
760   OUTPUT Testset;"READ:WCPower?"! INITiate and FETCh Channel Power
770   ENTER Testset;Integrity,Chanpow
780   BEEP
790   PRINT USING " ""Starting Channel Power (dBm) = "",2D.1D ";Chanpow
800   PRINT "If starting Channel Power is greater than 18 dBm (power class 3),"
810   PRINT "send down power control bit(s) as needed."
820   PRINT
830   PRINT "Press F2 to continue."
840   PRINT
850   PAUSE
860 !
870 ! Determine starting E-TFCI
880   OUTPUT Testset;"CALL:STATus:ETFCi?"! Last Received E-TFCI
890   ENTER Testset;Lastetfci
900   PRINT "Initial E-TFCI = ";Lastetfci
910   PRINT "(Target E-TFCI is 75 for sub-test 1)"
920   PRINT
930 !
940 ! Dimension array for E-TFCI results and set record number to 15
950   DIM Etfci(49)
960   OUTPUT Testset;"CALL:HSUPa:ETFCi:RECord:COUNt 15"! E-TFCI Rec Count
970 !
980 ! Send step up TPC bit and record 150 ms of E-TFCI results
990   PRINT "E-TFCI values after step up bit(s): "
1000   LOOP
1010       OUTPUT Testset;"CALL:CLPControl:UPLink:UP"! Send step up TPC bit
1020       GOSUB Recordetfci
1030   !
1040 ! Determine if UE sent a decreased E-TFCI
1050       GOSUB Decreasedetfci
1060   EXIT IF Etfcicheck=1! Exit loop once UE reports a decreased E-TFCI
1070   END LOOP
1080 !
1090 ! Send step down TPC bit and record 150 ms of E-TFCI results
1100   PRINT "E-TFCI values after first step down bit: "
1110   OUTPUT Testset;"CALL:CLPControl:UPLink:DOWN"! Send step down TPC bit
1120   GOSUB Recordetfci
1130 !
1140 ! Determine if UE sent a decreased E-TFCI
1150   GOSUB Decreasedetfci
1160   IF Etfcicheck=1 THEN ! If a decrease E-TFCI occurred, send another down TPC bit
1170       OUTPUT Testset;"CALL:CLPControl:UPLink:DOWN"! Send step down TPC bit
1180       GOSUB Recordetfci
1190       PRINT
1200       PRINT "E-TFCI values after second step down bit: "
1210       FOR N=0 TO 14
1220           PRINT Etfci(N);
1230       NEXT N
1240       PRINT
1250       PRINT
1260   END IF
1270 !
1280 ! Determine if E-TFCI matches target E-TFCI
1290   Targetetfci=75! (sub-test 1)
1300   PRINT "Target E-TFCI =";Targetetfci
1310   Etfcipass=1! UE will pass unless array values don't match target E-TFCI
1320   FOR N=0 TO 14
1330       IF Etfci(N)<>Targetetfci THEN Etfcipass=0
1340   NEXT N
1350   IF Etfcipass=0 THEN ! If any E-TFCI doesn't match target E-TFCI, UE fails
1360       PRINT "Recorded E-TFCI does not match the Target E-TFCI of 75 for sub-test 1"
1370       STOP
1380   END IF
1390   PRINT "E-TFCI matches Target E-TFCI"
1400   PRINT
1410 !
1420 ! *** INITiate and FETCh Measurements ***
1430   DIM Rcdpai(255)
1440   DIM Rcdpaq(255)
1450   DIM Ncdpi(255)
1460   DIM Ncdpq(255)
1470   OUTPUT Testset;"CALL:HSUPa:SGRant:ABSolute:MODE PATTern"
1480   ! Start Absolute Grant pattern
1490   OUTPUT Testset;"SETup:WCDomain:TRIGger:SOURce EFRame"! Even Frame Trigger Source
1500   OUTPUT Testset;"SETup:WCDomain:TSLot 14"! (Measurement point 1)
1510   OUTPUT Testset;"SETup:WCDomain:TRIGger:ALIGnment:SFNumber ODD"! (Meas point 1)
1520   OUTPUT Testset;"INITiate:WCDomain"! INITiate Code Domain Power
1530   OUTPUT Testset;"FETCh:WCDomain:INTegrity?"! Integrity Indicator
1540   ENTER Testset;Integrity
1550   OUTPUT Testset;"FETCh:WCDomain:POWer:NOMinal:ICHannel?"!NCDP I chan
1560   ENTER Testset;Ncdpi(*)
1570   OUTPUT Testset;"FETCh:WCDomain:POWer:NOMinal:QCHannel?"!NCDP Q chan
1580   ENTER Testset;Ncdpq(*)
1590   OUTPUT Testset;"FETCh:WCDomain:POWer:RELative:ACCuracy:ICHannel?"!RCDPA I chan
1600   ENTER Testset;Rcdpai(*)
1610   OUTPUT Testset;"FETCh:WCDomain:POWer:RELative:ACCuracy:QCHannel?"!RCDPA Q chan
1620   ENTER Testset;Rcdpaq(*)
1630 !
1640 ! *** Print Measurement Results ***
1650   PRINT "Integrity (0 = normal) =";Integrity
1651   PRINT
1660   PRINT "NCDP (dB) results:"
1670   PRINT USING " ""DPCCH    = "",4D.2D ";Ncdpq(0)
1680   PRINT USING " ""DPDCH    = "",4D.2D ";Ncdpi(64)
1690   PRINT USING " ""HS-DPCCH = "",4D.2D ";Ncdpq(64)
1700   PRINT USING " ""E-DPCCH  = "",4D.2D ";Ncdpi(1)
1710   PRINT USING " ""E-DPDCH1 = "",4D.2D ";Ncdpi(128)
1720   PRINT
1730   PRINT "RCDPA (dB) results:"
1740   PRINT USING " ""DPCCH      = "",2D.2D ";Rcdpaq(0)
1750   PRINT USING " ""DPDCH      = "",2D.2D ";Rcdpai(64)
1760   PRINT USING " ""HS-DPCCH   = "",2D.2D ";Rcdpaq(64)
1770   PRINT USING " ""E-DPCCH    = "",2D.2D ";Rcdpai(1)
1780   PRINT USING " ""E-DPDCH1   = "",2D.2D ";Rcdpai(128)
1790 !
1800   GOSUB Endprogram
1810 !
1820 !========================================
1830 ! *** Subroutines ***
1840 !========================================
1850 !
1860  Recordetfci:! Records E-TFCIs and enters them into the Etfci() array
1870   OUTPUT Testset;"CALL:HSUPa:ETFCi:RECord:STARt"! Start Recording E-TFCI
1880   LOOP
1890       OUTPUT Testset;"CALL:STATus:ETFCi:RECord?"! E-TFCI Recording State
1900       ENTER Testset;Recordstate$
1910   EXIT IF Recordstate$="IDLE"! Exit loop when recording is complete
1920   END LOOP
1930   OUTPUT Testset;"CALL:STATus:ETFCi:RECord:ALL?"! Query E-TFCI results
1940   ENTER Testset;Etfci(*)! Enter E-TFCI results into array
1950   RETURN
1960   !
1970  Decreasedetfci:! Prints 15 E-TFCI results and returns Eftcicheck = 1 if any
1980                 ! Decreased E-TFCIs occurred
1990   Etfcicheck=0
2000   FOR N=0 TO 14
2010       PRINT Etfci(N);
2020       IF Etfci(N)<Lastetfci OR Etfci(N)=9.91E+37 THEN Etfcicheck=1
2030       ! Is any E-TFCI value decreased from starting E-TFCI? If so, set Etfcicheck = 1
2040       ! Also allows program to continue if no E-TFCIs from UE
2050   NEXT N
2060   PRINT
2070   PRINT
2080   RETURN
2090 !
2100  Endprogram:!
2110   END

An example output from this program is as follows:

Program Example: 5.13.2B Relative Code Domain Error with HS-DPCCH and E-DCH

This section is only applicable to the lab application or feature-licensed test application.

This procedure conforms to 34.121 v7.5.0 plus CR R5-072417.

10 ! Code Domain Programming Example
20 ! 3GPP TS 34.121 5.13.2.B RCDE with HS-DPCCH and E-DCH
30 !
40   Testset=714
50   OUTPUT Testset;"*RST"! Full preset the test set
60   CLEAR SCREEN
70   PRINT "3GPP TS 34.121 5.13.2.B RCDE with HS-DPCCH and E-DCH"
80   PRINT
90 !
100 ! *** Set Up Connection Parameters ***
110 !
120   OUTPUT Testset;"CALL:OPERating:MODE OFF"! Operating Mode = Cell Off
130   OUTPUT Testset;"CALL:CELL:RLC:REEStablish OFF"! RLC Reestablish
140   OUTPUT Testset;"CALL:PSDomain PRESent"! PS Domain Information
150   OUTPUT Testset;"CALL:CHANnel 10563"! DL Chan low range freq (Band I IMT-2000)
160 !
170 ! *** Set Up Test Parameters ***
180 !
190   OUTPUT Testset;"CALL:UPLink:DPCHannel:BETA:AUTO 0"! Manual beta control
200   OUTPUT Testset;"CALL:UPLink:DPCHannel:MANual:CBETa 11"! Betac=11/15 (sub-test 1)
210   OUTPUT Testset;"CALL:UPLink:DPCHannel:MANual:DBETa 15"! Betad=15/15 (sub-test 1)
220   OUTPUT Testset;"CALL:UPLink:TXPower:LEVel:MAXimum 21"! Max UL Transmit Power Lvl
230   OUTPUT Testset;"CALL:POWer -86"                            ! Cell Power
240   OUTPUT Testset;"CALL:SERVice:RBTest:RAB HSParmc12"         ! Channel Type
250   OUTPUT Testset;"CALL:CONNected:CPIChannel:HSPA -10"        ! CPICH Level
260   OUTPUT Testset;"CALL:CONNected:CCPChannel:PRIMary:HSPA -12"! P-CCPCH/SCH Level
270   OUTPUT Testset;"CALL:CONNected:PICHannel:HSPA -15"         ! PICH Level
280   OUTPUT Testset;"CALL:CONNected:DPCHannel:HSPA -10"         ! DPCH Level
290   OUTPUT Testset;"CALL:CONNected:EAGChannel -20"             ! E-AGCH Level
300   OUTPUT Testset;"CALL:CONNected:EHIChannel -20"             ! E-HICH Level
310   OUTPUT Testset;"CALL:CONNected:ERGChannel:STATe OFF"       ! E-RGCH State
320   OUTPUT Testset;"CALL:CONNected:HSPDschannel:HSPA -3"       ! HS-PDSCHs Level
330   OUTPUT Testset;"CALL:CONNected:HSSCchannel:HSPA -8"        ! HS-SCCH 1 Level
340   OUTPUT Testset;"CALL:HSUPa:SERVice:RBTest:RLCSdu:SIZE BITS2936"! E-DCH RLC SDU Size
350   OUTPUT Testset;"CALL:HSUPa:EDPCchannel:POFFset 6"! E-DPCCH/DPCH PO (sub-test 1)
360   OUTPUT Testset;"CALL:HSUPa:ETFCi:POFFsets:REFerence DEF3412101"! Ref E-TFCI POs
370   OUTPUT Testset;"CALL:HSUPa:SGRant:ABSolute:RBSetup INDex26"! RB Setup AG (sub-test 1)
380   OUTPUT Testset;"CALL:HSDPa:SERVice:RBTest:HSDSchannel:CONFig FRC"! HS-DSCH Config
390   OUTPUT Testset;"CALL:HSDPa:SERVice:RBTest:FRC:TYPE QPSK1"  ! FRC Type
400   OUTPUT Testset;"CALL:HSDPa:MACHs:NTRans 4"                 ! Number of Trans
410   OUTPUT Testset;"CALL:HSDPa:MACHs:RVSequence `0,2,5,6,0,0,0,0'"! RV Sequence
420   OUTPUT Testset;"CALL:HSDPa:UPLink:DACK 8"                  ! DeltaACK=30/15
430   OUTPUT Testset;"CALL:HSDPa:UPLink:DNACK 8"                 ! DeltaNACK=30/15
440   OUTPUT Testset;"CALL:HSDPa:UPLink:DCQI 8"                  ! DeltaCQI=30/15
450   OUTPUT Testset;"CALL:HSDPa:UPLink:ANACk:RFACtor 3"! Ack-Nack Repetition Factor
460   OUTPUT Testset;"CALL:HSDPa:UPLink:CQI:FCYCle 4 MS"         ! CQI Feedback Cycle
470   OUTPUT Testset;"CALL:HSDPa:UPLink:CQI:RFACtor 2"           ! CQI Repetition Factor
480   OUTPUT Testset;"CALL:CELL:CLPControl:UPLink:ALGorithm ALG2"! UL CL Power Ctrl Alg
490   OUTPUT Testset;"CALL:OPERating:MODE CALL"! Operating Mode = Active Cell
500 !
510 ! *** Make a Connection ***
520 !
530   BEEP
540   PRINT "Power on the UE, wait for it to register/attach, then Originate a call"
550   PRINT "If HSUPA Throughput = 0 kbps, send the appropriate Single Shot AG for"
560   PRINT "your sub-test (20: (119/15)^2 for sub-test 1)"
570   PRINT
580   PRINT "Press F2 to continue"
590   PRINT
600   PAUSE
610 !
620 ! *** Drive the UE to Max Power ***
630 !
640 ! Set UE Target Power to drive UE power to 6 dB below max power, wait 150 ms
650   OUTPUT Testset;"CALL:CLPControl:UPLink:MODE ACTive"! Active bits power control
660   OUTPUT Testset;"CALL:MS:POwer:TARGet 4"! UE Target Pow (sub-test 1, power class 3)
670   WAIT .15
680   OUTPUT Testset;"CALL:CLPControl:UPLink:MODE UDOW"! Alternating bits power control
690 !
700 ! Use Channel Power to confirm proper starting power
710   OUTPUT Testset;"SETup:WCPower:POWer:RANGe:OFFSet:MANual 14"
720   ! Manual Power Range Offset = 14 dB for sub-test 1
730   OUTPUT Testset;"READ:WCPower?"! INITiate and FETCh Channel Power
740   ENTER Testset;Integrity,Chanpow
750   BEEP
760   PRINT USING " ""Starting Channel Power (dBm) = "",2D.1D ";Chanpow
770   PRINT "If starting Channel Power is greater than 18 dBm (power class 3),"
780   PRINT "send down power control bit(s) as needed."
790   PRINT
800   PRINT "Press F2 to continue."
810   PRINT
820   PAUSE
830 !
840 ! Determine starting E-TFCI
850   OUTPUT Testset;"CALL:STATus:ETFCi?"! Last Received E-TFCI
860   ENTER Testset;Lastetfci
870   PRINT "Initial E-TFCI = ";Lastetfci
880   PRINT "(Target E-TFCI is 75 for sub-test 1)"
890   PRINT
900 !
910 ! Dimension array for E-TFCI results and set record number to 15
920   DIM Etfci(49)
930   OUTPUT Testset;"CALL:HSUPa:ETFCi:RECord:COUNt 15"! E-TFCI Rec Count
940 !
950 ! Send step up TPC bit and record 150 ms of E-TFCI results
960   PRINT "E-TFCI values after step up bit(s): "
970   LOOP
980       OUTPUT Testset;"CALL:CLPControl:UPLink:UP"! Send step up TPC bit
990       GOSUB Recordetfci
1000   !
1010 ! Determine if UE sent a decreased E-TFCI
1020       GOSUB Decreasedetfci
1030   EXIT IF Etfcicheck=1! Exit loop once UE reports a decreased E-TFCI
1040   END LOOP
1050 !
1060 ! Send step down TPC bit and record 150 ms of E-TFCI results
1070   PRINT "E-TFCI values after first step down bit: "
1080   OUTPUT Testset;"CALL:CLPControl:UPLink:DOWN"! Send step down TPC bit
1090   GOSUB Recordetfci
1100 !
1110 ! Determine if UE sent a decreased E-TFCI
1120   GOSUB Decreasedetfci
1130   IF Etfcicheck=1 THEN ! If a decrease E-TFCI occurred, send another down TPC bit
1140       OUTPUT Testset;"CALL:CLPControl:UPLink:DOWN"! Send step down TPC bit
1150       GOSUB Recordetfci
1160       PRINT
1170       PRINT "E-TFCI values after second step down bit: "
1180       FOR N=0 TO 14
1190           PRINT Etfci(N);
1200       NEXT N
1210       PRINT
1220       PRINT
1230   END IF
1240 !
1250 ! Determine if E-TFCI matches target E-TFCI
1260   Targetetfci=75! (sub-test 1)
1270   PRINT "Target E-TFCI =";Targetetfci
1280   Etfcipass=1! UE will pass unless array values don't match target E-TFCI
1290   FOR N=0 TO 14
1300       IF Etfci(N)<>Targetetfci THEN Etfcipass=0
1310   NEXT N
1320   IF Etfcipass=0 THEN ! If any E-TFCI doesn't match target E-TFCI, UE fails
1330       PRINT "Recorded E-TFCI does not match the Target E-TFCI of 75 for sub-test 1"
1340       STOP
1350   END IF
1360   PRINT "E-TFCI matches Target E-TFCI"
1370   PRINT
1380 !
1390 ! *** INITiate and FETCh Measurements ***
1400   DIM Ncdpi(255)
1410   DIM Ncdpq(255)
1420   DIM Ecdpi(255)
1430   DIM Ecdpq(255)
1440   DIM Rcdei(255)
1450   DIM Rcdeq(255)
1460 !
1470   OUTPUT Testset;"INITiate:WCDomain"     ! INITiate Code Domain Power
1480   OUTPUT Testset;"FETCh:WCDomain:INTegrity?"     ! Integrity Indicator
1490   ENTER Testset;Integrity
1500   OUTPUT Testset;"FETCh:WCDomain:POWer:NOMinal:ICHannel?"!NCDP I chan
1510   ENTER Testset;Ncdpi(*)
1520   OUTPUT Testset;"FETCh:WCDomain:POWer:NOMinal:QCHannel?"!NCDP Q chan
1530   ENTER Testset;Ncdpq(*)
1540   OUTPUT Testset;"FETCh:WCDomain:POWer:EFFective:ICHannel?"!ECDP I chan
1550   ENTER Testset;Ecdpi(*)
1560   OUTPUT Testset;"FETCh:WCDomain:POWer:EFFective:QCHannel?"!ECDP Q chan
1570   ENTER Testset;Ecdpq(*)
1580   OUTPUT Testset;"FETCh:WCDomain:CERRor:RELative:ICHannel?"!RCDE I chan
1590   ENTER Testset;Rcdei(*)
1600   OUTPUT Testset;"FETCh:WCDomain:CERRor:RELative:QCHannel?"!RCDE Q chan
1610   ENTER Testset;Rcdeq(*)
1620 !
1630 ! *** Print Measurement Results ***
1640   PRINT "Integrity (0 = normal) =";Integrity
1650   PRINT
1660   PRINT "NCDP (dB) results:"
1670   PRINT USING " ""DPCCH    = "",4D.2D ";Ncdpq(0)
1680   PRINT USING " ""DPDCH    = "",4D.2D ";Ncdpi(64)
1690   PRINT USING " ""HS-DPCCH = "",4D.2D ";Ncdpq(64)
1700   PRINT USING " ""E-DPCCH  = "",4D.2D ";Ncdpi(1)
1710   PRINT USING " ""E-DPDCH1 = "",4D.2D ";Ncdpi(128)
1720   PRINT
1730   PRINT "ECDP (dB) results:"
1740   PRINT USING " ""DPCCH    = "",4D.2D ";Ecdpq(0)
1750   PRINT USING " ""DPDCH    = "",4D.2D ";Ecdpi(64)
1760   PRINT USING " ""HS-DPCCH = "",4D.2D ";Ecdpq(64)
1770   PRINT USING " ""E-DPCCH  = "",4D.2D ";Ecdpi(1)
1780   PRINT USING " ""E-DPDCH1 = "",4D.2D ";Ecdpi(128)
1790   PRINT
1800   PRINT "RCDE (dB) results:"
1810   PRINT USING " ""DPCCH    = "",4D.2D ";Rcdeq(0)
1820   PRINT USING " ""DPDCH    = "",4D.2D ";Rcdei(64)
1830   PRINT USING " ""HS-DPCCH = "",4D.2D ";Rcdeq(64)
1840   PRINT USING " ""E-DPCCH  = "",4D.2D ";Rcdei(1)
1850   PRINT USING " ""E-DPDCH1 = "",4D.2D ";Rcdei(128)
1860 !
1870   GOSUB Endprogram
1880 !
1890 !========================================
1900 ! *** Subroutines ***
1910 !========================================
1920 !
1930  Recordetfci:! Records E-TFCIs and enters them into the Etfci() array
1940   OUTPUT Testset;"CALL:HSUPa:ETFCi:RECord:STARt"! Start Recording E-TFCI
1950   LOOP
1960       OUTPUT Testset;"CALL:STATus:ETFCi:RECord?"! E-TFCI Recording State
1970       ENTER Testset;Recordstate$
1980   EXIT IF Recordstate$="IDLE"! Exit loop when recording is complete
1990   END LOOP
2000   OUTPUT Testset;"CALL:STATus:ETFCi:RECord:ALL?"! Query E-TFCI results
2010   ENTER Testset;Etfci(*)! Enter E-TFCI results into array
2020   RETURN
2030   !
2040  Decreasedetfci:! Prints 15 E-TFCI results and returns Eftcicheck = 1 if any
2050                 ! Decreased E-TFCIs occurred
2060   Etfcicheck=0
2070   FOR N=0 TO 14
2080       PRINT Etfci(N);
2090       IF Etfci(N)<Lastetfci OR Etfci(N)=9.91E+37 THEN Etfcicheck=1
2100       ! Is any E-TFCI value decreased from starting E-TFCI? If so, set Etfcicheck = 1
2110       ! Also allows program to continue if no E-TFCIs from UE
2120   NEXT N
2130   PRINT
2140   PRINT
2150   RETURN
2160 !
2170  Endprogram:!
2180   END

An example output from this program is as follows:

Related Topics

  • Code Domain Troubleshooting
  • Code Domain Measurement Description
  • SETup:WCDomain
  • INITiate
  • FETCh:WCDomain
  • Amplitude Offset
  • Integrity Indicator


Programming a Digital Audio Interface (DAI) Test

Programming a Digital Audio Interface (DAI) Test

Last updated: January 16, 2009

This section is only applicable to the GGE lab application. It is included in this manual to provide an example of how to approach automating a DAI test in the W-CDMA/HSPA lab application.

  • Programming a Downlink DAI Test
  • Programming a Uplink DAI Test

Programming a Downlink DAI Test

The following example program demonstrates use of the Downlink DAI Test. See Programming a Downlink DAI Test for procedure on how to set up a Downlink DAI Test.

11 Testset=714
12 CLEAR SCREEN
13 CLEAR 7
14 CLEAR Testset
15 PRINT "*** Digital Audio Interface (DAI) Downlink Test Program for GSM/GPRS/EGPRS***"
16 PRINT
17 PRINT
18     !
19     !****************************************************************
21     ! TS Uploads the COD/DEC reference file to the Test set via HTTP interface,
22     ! Indicate which codec the COD/DEC reference file applies to,
23     ! Press Enter when finished.
24     !****************************************************************
25 Codec_type$="AFS"     !Set the Type of the Codec file to "Adaptive Full Rate".
26     !
27 BEEP
28     !
30 PRINT "Upload the COD/DEC reference file to the Test set,"
31 PRINT "Indicate which codec the COD/DEC reference file applies to,"
32 PRINT "Press Enter when finished."
33 PRINT
34 PRINT
35 !
36 LINPUT "Press ENTER when finished",Keyboard$
37         !
38 !
39 OUTPUT 714;"CALL:CELL:OPERating:MODE CALL"     !Set the operating mode to Active Cell.
40 OUTPUT 714;"CALL:CELL:POWer -50dBm"     !Set the Cell Power.
41 !
42 !If necessary, configure the traffic channel parameters for the call assignment.
43 !See "CALL:TCHannel".
44 !If necessary, set the Paging Identity. See "CALL:PAGing:IDENtity[:TYPE]".
50 !If necessary, set the IMSI state. See "CALL:PAGing:IMSI".
60 !If necessary, set the repeat paging state. See "CALL:PAGing:REPeat[:STATe][:SELected".
61 !
70 OUTPUT 714;"CALL:ORIGINATE"     ! Begin the BS originated call.
80 OUTPUT 714;"CALL:CONNECTED:STATE?"     ! The connect/idle query.
90 ENTER 714;Call_connected     ! Program will hang here until state
100                              ! change or protocol timer expires.
110     !************************************************************
120     ! If mobile is not set to auto-answer, answer the call.
130     !************************************************************
140 IF NOT Call_connected THEN
150 DISP "CALL NOT CONNECTED."
160 ELSE
170 OUTPUT 714;"CALL:TCHannel:CMODe:LSPeech:CHANnel ";Codec_type$
171        !Set the Logical Speech Channel to be tested.
172 OUTPUT 714;"CALL:TCHannel:DAINterface:TINTerface SDECoder"
173        ! Enable the DAI Speech Decoder.
174 !
175         !*********************************************************************
176         ! Command the Customer Test Station (TS) to apply reset pulse to DUT.
177         ! Command the Customer Test Station (TS) to start recording the
178         ! COD file output from the Mobile Station via the DAI.
179         ! Press Enter when finished.
180         !*********************************************************************
181 !
182 BEEP
183 !
184 PRINT "Command the Customer Test Station (TS) to apply reset pulse to DUT."
185 PRINT "Command the Customer Test Station (TS) to start recording the"
186 PRINT "COD file output from the Mobile Station via the DAI."
187 PRINT "Press Enter when finished."
188 PRINT
189 PRINT
190         !
191 LINPUT "Press ENTER when finished",Keyboard$
192 !
193 OUTPUT 714;"CALL:DAINterface:PLAY:STATus?"         !Query the play status
194 ENTER 714;Play_status$
195 !
196 IF NOT (Play_status$="IDLE") THEN
197         !
198   OUTPUT 714;"CALL:DAINterface:PLAY:STARt"
199 !
200   LOOP
201   OUTPUT 714;"CALL:DAINterface:PLAY:STATus?"           !Query the play status.
202   ENTER 714;Play_status$
203   EXIT IF NOT (Play_status$="PLAY")
204   END LOOP
205 !
206   PRINT "DAI Downlink Test Finished."
207 !
208 ELSE
209   PRINT "Operation rejected; Digital audio file is not available."
210 END IF
211 !
212 OUTPUT 714;"CALL:TCHannel:DAINterface:TINTerface OFF"
213        !Set the DAI Test Interface to Off.
214 OUTPUT 714;"CALL:END"         !End the Call connection.
215 !
216 END IF
217 END

Programming a Uplink DAI Test

The following example program demonstrates use of the Uplink DAI Test. See Programming a Uplink DAI Test for procedure on how to set up a Uplink DAI Test.

11 Testset=714
12 CLEAR SCREEN
13 CLEAR 7
14 CLEAR Testset
15 PRINT "*** Digital Audio Interface (DAI) Uplink Test Program for GSM/GPRS/EGPRS***"
16 PRINT
17 PRINT
35 !
36 Codec_type$="AFS"     !Set the Type of the Codec file to "Adaptive Full Rate".
37 OUTPUT 714;"CALL:CELL:OPERating:MODE CALL"     !Set the operating mode to Active Cell.
38 OUTPUT 714;"CALL:CELL:POWer -50dBm"     !Set the Cell Power.
39 !
40 !If necessary, configure the traffic channel parameters for the call assignment.
41 	 !See "CALL:TCHannel".
42 !If necessary, set the Paging Identity. See "CALL:PAGing:IDENtity[:TYPE]".
50 !If necessary, set the IMSI state. See "CALL:PAGing:IMSI".
60 !If necessary, set the repeat paging state. See "CALL:PAGing:REPeat[:STATe][:SELected]".
61 !
70 OUTPUT 714;"CALL:ORIGINATE"     ! Begin the BS originated call.
80 OUTPUT 714;"CALL:CONNECTED:STATE?"     ! The connect/idle query.
90 ENTER 714;Call_connected     ! Program will hang here until state
100                              ! change or protocol timer expires.
110     !************************************************************
120     ! If mobile is not set to auto-answer, answer the call.
130     !************************************************************
140 IF NOT Call_connected THEN
150 DISP "CALL NOT CONNECTED."
160 ELSE
170 OUTPUT 714;"CALL:TCHannel:CMODe:LSPeech:CHANnel ";Codec_type$
171        !Set the Logical Speech Channel to be tested.
172 OUTPUT 714;"CALL:TCHannel:DAINterface:TINTerface SENCoder"
173        ! Enable the DAI Speech Encoder.
174 !
175         !*********************************************************************
176         ! Command the Customer Test Station (TS) to apply reset pulse to DUT.
178         !*********************************************************************
179 !
180 BEEP
181 !
182 PRINT "Command the Customer Test Station (TS) to apply reset pulse to DUT."
185 PRINT "Press Enter when finished."
186 PRINT
188                 !
190 LINPUT "Press ENTER when finished",Keyboard$
191 !
193       !
194 OUTPUT 714;"CALL:DAINterface:RECord:STARt"
195 !
196         !*********************************************************************
197         ! Command the Customer Test Station (TS) to start transfering the
198         ! digital audio file to the Mobile Station.
201         !*********************************************************************
202 !
203 BEEP
204 !
205 PRINT "Command the Customer Test Station (TS) to start transfering the"
206 PRINT "digital audio file to the Mobile Station."
209 PRINT "Press Enter when finished."
210 PRINT
213         !
214 LINPUT "Press ENTER when finished",Keyboard$
215 !
216         !**********************************************************************
217         ! Command the Test Set to stop recording after the transmission of the
218         ! digital audio file is finished.
219         !**********************************************************************
220 !
221 BEEP
222 PRINT "Press ENTER When the Customer Test Station has finished the transmission of the digital audio file"
223 PRINT
224 !
225 LINPUT "Press ENTER when finished",Keyboard$
226 !
227 OUTPUT 714;"CALL:DAINterface:RECord:STOP"
228 !
229 PRINT "DAI Uplink Test Finished."
230 !
232 OUTPUT 714;"CALL:TCHannel:DAINterface:TINTerface OFF"
233        !Set the DAI Test Interface to Off.
234 OUTPUT 714;"CALL:END"
235        !End the Call connection.
236 !
237 END IF
238 END

Related Topics

Digital Audio Interface (DAI) Description

How to use the Digital Audio Interface Features

CALL:DAINterface


Programming a Distortion Measurement

Programming a Distortion Measurement

Last updated: January 16, 2009

This section provides an example of how to make distortion measurements via GPIB. Distortion measurements are not typically made when testing W-CDMA mobiles, but are more common when testing AMPS or other analog mobiles. The programming example below is typical for an AMPS mobile.

SINAD and Distortion measurements are affected by the same STATe and INITiate commands, so both measurements are enabled and triggered at the same time. However, measurement results are queried separately. See Audio Analyzer Measurement Description .

The following procedure assumes that the mobile's audio output is connected to the AUDIO IN connectors and the mobile is on an analog voice channel (AVC). The AVC is being modulated with a 1004 Hz tone at ± 8 kHz peak deviation, and a 6000 Hz SAT at ± 2 kHz peak deviation. It is also assumed that the Cell Power from the test set is set to -50 dBm (IS-137 standard).

  1. Configure audio analyzer measurement parameters using the SETup subsystem.
  2. Start the audio analyzer measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain audio analyzer measurement results.

Programming Example

10  OUTPUT 714;"SETup:AFANalyzer:CONTinuous OFF" !Set the audio analyzer
20                                           !measurements to single trigger mode.
30  OUTPUT 714;"SETup:AFANalyzer:PEAK:VOLTage 3V" !Set the Expected Amplitude level for
40                                                !audio input voltage in Vpeak.
50  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:STATe ON" !Turn on the SINAD and
60                                                  !distortion measurements.
70  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:FREQuency 1004 HZ" !Specify the audio
80                                      !frequency to use for the measurements.
90  OUTPUT 714;"SETup:AFANalyzer:FILTer CMessage" !Select the c-message filter.
100 OUTPUT 714;"SETup:AFANalyzer:DEMPhasis:STATe OFF" !Turn off de-emphasis.
110 OUTPUT 714;"SETup:AFANalyzer:EXPandor:STATe OFF" !Turn off the expandor.
120 OUTPUT 714;"SETup:AFANalyzer:TIMeout 3S" !Set a timeout value of 3 seconds
130                                      !in case the measurement cannot be made.
140 OUTPUT 714;"INITiate:AFANalyzer" !Start the AF Analyzer measurement.
150 OUTPUT 714;"FETCh:AFANalyzer:INTegrity?" !Query the integrity indicator to
160                           !verify that a reliable measurement was made.
170 ENTER 714;Integrity  !Enter the returned value into a variable for comparison
180                      !with possible integrity indicator values (not shown here).
190 IF Integrity=0 THEN  !Only fetch measurement result if integrity indicator is 0.
200 OUTPUT 714;"FETCh:AFANalyzer:DISTortion?" ! Fetch the Distortion result.
210 ENTER 714;Distortion !Enter the returned value into a variable.
220 END IF
230 END

Returned Values

The results returned by this program are:

  • Integrity returns the measurement integrity indicator; 0 means a successful measurement with no errors. See Integrity Indicator .
  • Distortion returns the Distortion measurement value in percent (%).

Related Topics

Audio Analyzer Measurement Description

AFANalyzer Troubleshooting

Distortion Measurement Description

INITiate

SETup:AFANalyzer

FETCh:AFANalyzer

Control Program Example


Programming a Frequency Stability Measurement

Programming a Frequency Stability Measurement

January 16, 2009

This section provides an example of how to make Frequency Stability measurements via GPIB.

The following program example assumes that a signal within the measurement range in connected to the RF IN/OUT connector (see Input Signal Requirements ).

The basic procedure to test Frequency Stability is as follows:

  1. Set the expected frequency and power.
  2. Define the Frequency Stability Setup parameters as desired for measurement timeout and multi-measurements.
  3. Use the INITiate:FSTability command to start the measurement.
  4. Use the FETCh? command to obtain the measurement results.

Programming Example

10  !Set the expected frequency and power.
20  OUTPUT 714;"SETup:FSTability:CONTinuous OFF" !Set the frequency stability
30                                           !measurement to single trigger mode.
40  OUTPUT 714;"SETup:FSTability:TIMeout 1 S" !Set a timeout value of 1 second
50                                       !in case the measurement cannot be made.
60  OUTPUT 714;"SETup:FSTability:COUNt 5" !Set multi-measurements to 5.
70  OUTPUT 714;"INITiate:FSTability" !Start the measurement.
80  OUTPUT 714;"FETCh:FSTability?" !Query the returned integrity indicator and the
90         !Worst Case Frequency Error and average Frequency measurements.
100 ENTER 714;Integrity,Freq_error,Frequency  !Enter the returned values into variables.
110 IF Integrity=0 THEN  !See if the integrity value = 0 (valid measurement).
120 ELSE
130 PRINT "Measurement problem; check for signal level over/under range condition."
140 END IF
150 END

Returned Values

The measurements returned by this program are:

  • Integrity returns the measurement integrity indicator (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Freq_error returns the worst case frequency error in parts per million (PPM). Frequency returns the average frequency.

Related Topics

Frequency Stability Measurement Description

Frequency Stability Troubleshooting

INITiate

SETup:FSTability

FETCh:FSTability

Receiver Control


Dealing With Semicolon Separated Response Data Lists

Dealing With Semicolon Separated Response Data Lists

Last updated: January 16, 2009

Description

In accordance with IEEE 488.2-1992 Section 8.4.1 the test set uses the semicolon (;) as the response message unit separator (RMUS). The RMUS separates sequential response message unit elements from one another when multiple response message unit elements are sent in a response message. This condition would occur when combining multiple queries into a single GPIB transaction.

Query Response Data Types Used By Test Set

The test set can return the following data types in response to queries:

  • character data (char): ASCII characters A-Z (65-90 decimal), underscore (95 decimal), digits (48-57 decimal).

  • string data: ASCII characters enclosed in quotes (for example, "5551212" or "PGSM")

  • numeric response data (nr1): numeric data in the form +/- dddddddd

  • numeric response data (nr3): numeric data in the form +/- ddd.ddd E +/- dddd

Semicolon Separated Response Data Lists Containing Mixed Data Types

Problems can occur when trying to enter semicolon separated response data lists containing mixed data types.

For example: If the following command string is sent to the test set, the test set will respond by constructing a response message which contains multiple response message unit elements (that is, one response message unit element for each query item contained in the command string). Some response message unit elements are string data type, some are character data type and some are nr3 data type.

OUTPUT 714;"CALL:MS:REP:IMSI?;PCL?;REV?;SBAN?;ONUM?;MCC?;MNC?;LAC?"

An example response message generated by the test set in response to the above OUTPUT statement would be:

"001012345678901";+4.00000000E+000;PHAS1;"PGSM";"5551212";9.91E37;9.91E37;9.91E37

Constructing the following data entry statement will account for multiple responses from the query:

ENTER 714;Imsi$,Pcl,Rev$,Sban$,Onum$,Mcc,Mnc,Lac

In the Basic programming environment the above ENTER statement will fail with an `Insufficient data for ENTER' error. Some programming languages, Basic for example, cannot use the semicolon character as a data item terminator for string variables. In this example Basic will attempt to enter data into Imsi$ until it sees a LF (line feed) data item terminator. The test set does not send the LF until all the data has been sent. Consequently when Basic sees the LF it terminates entry of data into Imsi$ and starts to look for data to enter into Pcl. Since the test set is no longer sending any data the error message `Insufficient data for ENTER' is generated.

One possible workaround is to enter all the data into a single string variable, replace all semicolons with line feeds and then enter the data from the string into the individual data items. For example:

DIM Response$[500]
!
!
OUTPUT 714;"CALL:MS:REP:IMSI?;PCL?;REV?;SBAN?;ONUM?;MCC?;MNC?;LAC?"
ENTER 714;Response$
Semicolon=POS(Response$,";")
WHILE Semicolon
Response$[Semicolon,Semicolon]=CHR$(10)
Semicolon=POS(Response$,";")
END WHILE
ENTER Response$;Imsi$,Pcl,Rev$,Sban$,Onum$,Mcc,Mnc,La

Semicolon Separated Response Data Lists Containing Only Numeric Data Types

Semicolon separated response data lists containing only numeric data types do not present the types of problem associated with semicolon separated response data lists containing mixed data types. The number building routines in most languages will use any non-numeric character (that is, anything other than +/- 0123456789 E .) as the data item terminator. Consequently when the number building routines encounter the semicolon the data item is terminated. The following example illustrates this:

OUTPUT 714;"FETCH:TXP:INT?;POW:MIN?;MAX?"
ENTER 714;Integrity,Min_power,Max_power


Concurrent Measurements

Concurrent Measurements

Last updated: January 16, 2009

Description

A number of measurements can be initiated (with the INITiate command) while other measurements are being made, and the test set will perform as many operations simultaneously as its architecture allows. This technique is referred to as concurrency. Performing measurements concurrently can greatly improve test throughput.

Operating Considerations

The test set has three parallel signal paths to improve measurement throughput.

  • Demodulation downconverter path.
  • Measurement downconverter path.
  • Power detector path.

Since measurements are DSP (digital signal processor) based, and there are four A/D converters available to digitize or "sample" the input signal for analysis by the DSP, the test set will always have the capability to perform one transmitter measurement, one receiver measurement, and maintain the radio link concurrently. The test set's ability to perform multiple transmitter, or multiple receiver tests concurrently will depend on the availability of resources within the test set and availability of the signal to be tested.

Concurrent Measurements for the W-CDMA Applications

This table shows the concurrency considerations for the W-CDMA applications.

W-CDMA Concurrency Considerations
 | W W Q | W T P | W T D P | W S E M | W P P A | W P D | W O O S | W O O P | W O B W | W I Q T | W I L P | W E D P | W D P A | W C T F | W C P | W C D | W B L | W B E R | W A C L | S M O N | S A U D | HRCQ | H B L | F S T | D T M | C F D T | A F G | A F A N
AFAN (Audio Analyzer) | B | Y | D | B | D | D | D | D | B | B | D | D | B | D | B | B | Y | Y | B | B | A | D | Y | B | Y | D | Y | ...
AFG (Audio Generator) | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | E | Y | Y | Y | Y | Y | ... | ...
CFDTune (Fast Device Tune) | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | Y | ... | ... | ...
DTM (Data Throughput Monitor) | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | ... | ... | ... | ...
FST (Frequency Stability) | B | Y | D | B | D | D | D | D | B | B | D | D | B | D | B | B | Y | Y | B | B | B | D | Y | ... | ... | ... | ... | ...
HBL (HSDPA BLER) | Y | Y | D | Y | D | D | D | D | Y | Y | D | D | Y | D | Y | Y | B | B | Y | Y | Y | D | ... | ... | ... | ... | ... | ...
HRCQ (Reporting of Channel Quality Indicator) | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | D | ... | ... | ... | ... | ... | ... | ...
SAUD (Swept Audio) | B | Y | D | B | D | D | D | D | B | B | D | D | B | D | B | B | Y | Y | B | B | ... | ... | ... | ... | ... | ... | ... | ...
SMON (Spectrum Monitor) | B | Y | D | B | D | D | D | D | B | B | D | D | B | D | B | B | Y | Y | B | ... | ... | ... | ... | ... | ... | ... | ... | ...
WACL (Adjacent Channel Leakage Ratio) | B | Y | D | B | D | D | D | D | B | B | D | D | B | D | B | B | Y | Y | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WBER (Loopback BER) | Y | Y | D | Y | D | D | D | D | Y | Y | D | D | Y | D | Y | Y | A | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WBL (BLER) | Y | Y | D | Y | D | D | D | D | Y | Y | D | D | Y | D | Y | Y | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WCD (Code Domain) | B | Y | D | B | D | D | D | D | B | B | D | D | B | D | B | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WCP (Channel Power) | B | Y | D | B | D | D | D | D | B | B | D | D | B | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WCTF (Change of TFC) | D | D | D | D | D | D | D | D | D | D | D | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WDPA (Dynamic Power Analysis) | B | B | D | B | D | D | D | D | B | B | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WEDP (Extended Range Dynamic Power) | D | D | D | D | D | D | D | D | D | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WILP (Inner Loop Power) | D | D | D | D | D | D | D | D | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WIQT (IQ Tuning) | B | Y | D | B | D | D | D | D | B | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WOBW (Occupied Bandwidth) | B | Y | D | B | D | D | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WOOP (PRACH Transmit On/Off Power) | D | D | D | D | D | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WOOS (Out-of-Synch Handling of Output Power) | D | D | D | D | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WPD (Phase Discontinuity) | D | D | D | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WPPA (PRACH Preamble Analysis) | D | D | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WSEM (Spectrum Emission Mask) | B | Y | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WTDPower (TX Dynamic Power) | D | D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WTP (Thermal Power) | Y | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WWQ (Waveform Quality) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...

Table Key

Y: These measurements can operate concurrently with no conflicts.

A: Cannot operate concurrently. The measurement which is initiated most recently will cause all other conflicting measurements to be closed.

B: These measurements share a sampler path. If multiple measurements are initiated at the same time, they will execute sequentially. However, if multiple measurements are configured to operate off the same trigger event and only a single occurrence of that event happens, only the first initiated measurement will complete .

D: When this measurement is initiated, all other measurements are closed.

E: Swept audio automatically adjusts the audio generator, therefore adjusting the audio generator's frequency while using swept audio will generate an error message. Also, once the swept audio measurement has completed, it does not reset the audio generator values back to what they were before it adjusted them.

Related Topics

Block Diagram


Integrity Indicator

Integrity Indicator

Last updated: January 16, 2009

Description

The test set can evaluate its own performance and make a determination as to the validity of a measurement result. The test set evaluates the conditions surrounding a measurement and reports to the user its evaluation of these conditions in a parameter called the measurement integrity indicator. A measurement integrity indicator value is returned for every completed measurement. It is recommended that the user take advantage of this feature in every measurement.

The returned value defines whether or not a problem was encountered by the measurement process. It is not, however, guaranteed to be the only or root cause of the measurement problem. This is because some of the conditions surrounding a measurement may interact, and the test set may have insufficient information to determine the root cause of the measurement problem. However, in most cases, the value returned is the most likely cause of the problem.

Not all of the integrity indicator values are available for each measurement or test application, if a value doesn't apply it will not be available.

Integrity Indicator Values

NOTE
GSM, GPRS and EGPRS measurements return integrity indicators (8, 9, 11) when the measurement synchronization is set to midamble.

Integrity Indicator Number

Integrity Indicator Message

0

Normal: Indicates the measurement completed successfully without error and the result is accurate.

1

No Result Available: Indicates that there is no measurement result and returns NAN (not a number).

2

Measurement Timeout: Indicates that a measurement has timed out. The measurement timeout state must be set to ON.

3

Hardware Not Installed: Indicates that a piece of hardware is not installed in the test set, or the hardware has failed in a way which leads the instrument controller to believe it isn't installed.

4

Hardware Error: Indicates that a hardware failure has occurred. These include failures such as a phase lock loop out-of-lock, defective DSP samplers, or power detectors that can not be calibrated.

5

Over Range: Indicates that the input signal is over range. This can occur because your device's power is above the maximum input level for the measurement, or because your device's power is too far above the expected power. Refer to the measurement's `Input Signal Requirements' to determine if your device's power is higher than the maximum input level for the measurement. Otherwise, verify that your device's power is less than 3dB above the expected power level for GSM/GPRS/EGPRS, or less than 9dB above the expected power level for W-CDMA, cdma2000 and 1xEV-DO.

6

Under Range: Indicates that the input signal is under range. This can occur because your device's power is below the minimum input level for the measurement, or because your device's power is too far below the expected power. Refer to the measurement's `Input Signal Requirements' to determine if your device's power is lower than the minimum input level for the measurement. Otherwise, verify that your device's power is less than 10dB below the expected power level for GSM/GPRS/EGPRS, or less than 9dB below the expected power level for W-CDMA, cdma2000 and 1xEV-DO.

7

Burst Short: Indicates that the burst duration is too short, or part of the burst was not sampled due to improper triggering.

8

Trigger Early or Fall Early: Indicates that the DUT's burst amplitude fell prematurely or, due to an early trigger (early relative to a transmitted burst) the measurement sampling operation terminated before the falling edge of the burst.

9

Trigger Late or Rise Late: Indicates that either the rising edge of the DUT's burst was late or, due to a late trigger (late relative to a transmitted burst) the measurement sampling operation didn't start until after the rising edge of the transmitted burst.

10

Signal Too Noisy: Indicates that the measurement algorithm has found the signal measured to be too noisy to provide accurate results.

11

Sync Not Found: For the GSM/GPRS/EGPRS power versus time measurement, indicates that the midamble was not found therefore the measurement was not synchronized. For the W-CDMA BER and BLER measurements, indicates that the test set has lost synchronization with the UE.

12

Oven Out of Range: Indicates that a temperature controlled oven (other than the internal timebase oven) is outside of its operating range. The power meter's oven is checked and its condition reported with this value. (The internal timebase generates a temporary error message (out of lock) that is sent to the system error queue and the display. This is not an integrity indicator value, it is an error message.)

13

Unidentified Error: Indicates errors which are not covered by the other integrity values. Examples include: parameter errors, algorithm memory errors (too many measurements), measurements unavailable (unable to control), autorange unable to converge, default calibration data used.
14

PCM Full Scale Warning: Indicates that the PCM signal has reached plus or minus full scale. The measurement made will be accurate on the PCM signal but would typically indicate an overdriven or oscillating element in the DUT.
15

Questionable Result for Phase 1 Mobile: Indicates that the user attempted to make an FBER measurement in a phase 1 system. FBER is only possible in a phase 2 GSM system. This indicator is available only when the selected broadcast band is PGSM.

16

Questionable Result:
1. Indicates that the channel mode was NOT set to Full Rate Speech while a Decoded Audio measurement was active. Decoded Audio is only supported for FS Speech.
2. For the cdma2000 lab application, this integrity indicator is used to indicate that the Digital Average Power measurement result is questionable if the reverse channel is in 1/8 rate gated transmission in radio configuration 3 and above or the test set can not determine whether the reverse channel is in gated transmission (for example, while in a voice call).
3. For the GPRS Bit Error and GPRS Block Error measurements, this integrity indicator is returned when the Connection Type is set to an invalid parameter, i.e. SRB Loopback.

17

Can not Correlate: Indicates that the test sets internally generated reference signal does not correlate with the received signal.

Some conditions that could cause this integrity indicator result include the following:

  • an input signal that is corrupted
  • the input signal is extremely distorted
  • the input signal is off by more than 10 ms.
  • the frequency of the input signal deviates more than allowed
  • something is wrong with the long-code mask coming from the mobile ID

18

Frequency Out Of Range: Indicates that a Channel Power Measurement was attempted at a frequency for which there is no calibration data. The test set display will indicate 4 dashes.

19

Uncalibrated Due To Temperature: Indicates that the ambient temperature changes more than 10 degrees C since latest calibration, when attempting a Channel Power Measurement.

20

 Potential Receiver Saturation: Indicates that an input signal immediately prior to the measured input was high enough to potentially saturate the receiver hardware.

21

Parameter Error: Indicates that a measurement setup parameter has been set in a way that gives invalid measurement results.

22

Unsupported Configuration: Indicates that some parameter, other than a measurement setup parameter has been set so that it causes an invalid measurement result. Typically this would be a base station emulator parameter.

23

Call Processing Operation Failed: Indicates that a call processing operation, (base station emulator) needed in the course of making the measurement could not complete.

24

Calibration Error

25

 Burst Not Found
26 | Missing Loopback Packets or AT Buffer Overflow: Indicates that Loopback Packets are missing, or the Access Terminal had an overflow. This integrity indicator was added for the 1xEV-DO Packet Error Rate measurement.

27

No AT Loopback Packets: Indicates that no Loopback Packets from the Access Terminal were detected for a period of several seconds. This integrity indicator was added to provide an early termination criteria for the 1xEV-DO Packet Error Rate measurement.

28

 Questionable MS-to-Cell Data: Indicates that a condition exists on the uplink or reverse channel that has caused the measurement results to be in question. In the case of the WCDMA Loopback BER measurement, an example condition that could cause this integrity indicator would be detection of a CRC error in an uplink transport block.
30 | Trigger Missed: Indicates one or more triggers were missed during the measurement. In the case of the CDMA TX dynamic power measurement, an example condition that may cause this integrity indicator would be GPIB or LAN activities occur during the measurement. This integrity indicator was added to prevent the CDMA TX dynamic power measurement from hanging forever and provide an early termination criteria for the measurement.

31

Dual Measurement Request: Indicates that a request has been received for a measurement type that is already running.

32

Measurement Not Licensed: Indicates that the required feature license for the measurement is not present. See

http://www.agilent.com/find/8960upgrades

for details on hardware and software requirements to run a specific feature.

Related Topics

Error Messages


Measurement Timeouts

Measurement Timeouts

Last updated: January 16, 2009

Description

The primary use of measurement timeouts is to regain control of the test set's GPIB in cases where the bus could potentially "hang."

The time normally required for a measurement to complete may vary greatly depending on the individual measurement, its settings, it's multiple measurement count value, and so forth. Because of this, you may need to set the timeout longer than the default for measurements where a large number of multiple measurements are requested or where measurement triggers may be infrequent.

Be careful when setting a timeout that is shorter than the default. It is possible to specify a timeout that is so short the measurement does not even have a chance to begin. Measurement timeouts should always be at least several seconds long.

Timeout units default to S (seconds). The seconds suffix is an optional part of the command. If you want MS (milliseconds), US (microseconds) or NS (nanoseconds), you must specify these units in the suffix.

Timeout Values

All measurements in the W-CDMA Mobile Test application default to a timeout value of 10 seconds, except Loopback BER, Block Error Ratio and Out-of-Synch Handling of Output Power. For these measurements the timeout default is 20 seconds.

Related Topics

Integrity Indicator


Step 1: Set Up the Test Set

Step 1: Set Up the Test Set

Last updated: January 16, 2009

The following information provides additional details on Step 1 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you initialize the test set and set up the general operating conditions.

Contents

  • Initialize the Test Set
  • Set Up General Operating Conditions

Initialize the Test Set

  • Fully Preset the Test Set

    It is important to get the test set to a known state before each production session.

    Sending the *RST command fully presets the test set, which ends all call processing and measurement processes and restores all values to defaults.

  • Clear the Error Queue

    Before each production session, it is useful to clear the error queue of any old messages. That way, you know that any messages logged are relevant to the current production session.

    Sending the *CLS command clears the error queue.

Set Up General Operating Conditions

  • Turn Debugger On

    While developing your code, it is very useful to enable the GPIB debugger using the
    SYST:COMM:GPIB:DEB ON command. When the debugger is on, the test set alerts you when you send an incorrect command, and it also tells you which symbol or letter in the command is incorrect.

NOTE
You should turn the debugger off once you have finished development and your code is stable.

  • Set Operating Mode

    The test set contains a base station emulator (BSE), whose primary purpose is to provide enough call processing to allow parametric measurements of a mobile station's RF signal.

    An important characteristic of the test set's base station emulator is its operating mode. The operating mode sets the way in which the base station emulator interacts with the mobile station.

    Active cell mode is used when emulating a normal cell. Active cell mode allows active signaling between the mobile station and BSE. The mobile station camps to the BSE signal, and an actual call is established.

    In test mode, the mobile station synchronizes to the BSE signal and transmits an appropriate signal which the test set analyzes.

    The test set's operating mode is set using the following command:

    Command to Set the Test Set's Operating Mode

    Command

             Example

    CALL:OPER:MODE <operating mode>

    CALL:OPER:MODE CELL

  • Set Amplitude Offsets

    To achieve accurate measurement results, it is important to account for losses in the cabling and fixturing between the mobile station and test set. You must determine what the losses are for your test setup and then specify the appropriate frequency-dependent amplitude offset values.

    You can specify amplitude offsets for up to 20 frequencies using the following commands:

    Commands to Set Amplitude Offsets

    Command

             Example

    SYST:CORR:FREQ <freq1>, <freq2>, <freq3>

    SYST:CORR:FREQ 800MHz, 1800MHz,
    1900MHz

    SYST:CORR[:SGAin] <offset1>,
    <offset2>, <offset3>

             SYST:CORR -0.7, -1.0, -1.2

  • Set Display Mode

    To achieve a slightly faster test execution speed, you can disable the front panel display on the test set using the DISP:MODE FAST command.


Step 2: Configure Test Set and Mobile Station Parameters

Step 2: Configure Test Set and Mobile Station Parameters

Last updated: January 16, 2009

The following information provides additional details on Step 2 of the Programming Flowchart. This information is applicable to all test and lab applications.

Description

In this step you configure the parameters that allow a connection to be made between the test set and mobile station. This mainly involves setting up channels and power levels.

Contents

  • Set Up Channels
  • Set Cell Power
  • Set Mobile Station Transmit Power
  • Set Up Additional Connection Parameters

Set Up Channels

For many technologies, setting up channels involves specifying the channel associated with every band and channel type (for example, analog or digital), and then setting the active band and channel type. For some technologies, such as W-CDMA, you simply specify the downlink and uplink UARFCNs (channels).

  • Specify Channel Numbers

    All of the test set's test applications can test in more than one frequency band (for example, US Cellular, US PCS, or Korean PCS). To produce the most efficient code, you should configure the channel information for each band in advance. Then, to move to a new band during testing, you only need to send the command to change bands. You do not need to also specify the channel of the new band. This reduces test time.

    To set up the channel number for the various bands, use one of the following commands (depending upon which test application you are using):

    Commands to Set the Channel for a Band

    Command

             Example Technology

    CALL:<channel mnemonic>:<band mnemonic>
    <num value>

    CALL:TCH:EGSM 124

             GSM/GPRS/EGPRS

    CALL:SET:<channel type mnemonic>:<band
    mnemonic> <num value>

    CALL:SET:DTC:PCS 777

             AMPS/136

    CALL:CHAN:<channel type mnemonic>:<band
    mnemonic> <num value>

    CALL:CHAN:DIG2000:K
    PCS 384

             cdma2000/IS-95/AMPS

    This practice also applies to test applications which test both analog and digital channel types. In this case you should specify the channel for the analog and digital channel types in advance. Then, switching between them requires only one command to initiate the change, and not an additional change to specify the channel of the new channel type.

    If you specify channels in advance as described, the only time you need to specify a channel during testing is if you move to a new channel within the same band and channel type.

  • Set Active Band and Mode

    Once you have specified the channel information for each band and channel type, you must set the active band using one of the following commands (depending upon which test application you are using):

    Commands to Set the Active Band

    Command

             Example Technology

    CALL:<channel mnemonic>:BAND <band mnemonic>

    CALL:TCH:BAND
    EGSM

             GSM/GPRS/EGPRS

    CALL:SET:<channel type mnemonic>:BAND <band
    mnemonic>

             CALL:SET:DTC:BAND
    PCS     		AMPS/136
    CALL:BAND:<channel mnemonic> <band mnemonic>

    CALL:BAND:DIG2000
    KPCS

             cdma2000/IS-95/AMPS

    If the test application you are using supports testing of both analog and digital channel types, then you must also set the channel type using the following command:

    Command to Set the Active Channel Type

    Command

             Example

    CALL:<channel mnemonic>:TYPE <channel type
    mnemonic>

    CALL:TCH:TYPE
    DTC

  • Active Cell and Test Mode Considerations

    The function of the CALL commands differ depending upon whether you are in active cell or test mode.

    In active cell mode, when you use the CALL commands to set the channel numbers, the test set's output frequency and receiver frequency are set. A message is also sent to the mobile station to set its frequency.

    However, in test mode, since the BSE does not send call processing information to the mobile station, the CALL commands only configure the test set's output frequency and receiver frequency. You need to also send the appropriate test mode commands to the mobile station to set it to the correct frequency.

    In test mode, instead of using the CALL commands to configure the test set's frequencies, you may prefer to manually control the RF generator and RF analyzer using the CALL:RFG and RFAN commands, respectively. In either case, you must still send the appropriate test mode commands to the mobile station to move it to the proper frequency.

Set Cell Power

To set the output power of the test set, use the following command:

Command to Set Cell Power
Command | Example
CALL:POW <num value> | CALL:POW -75

  • Active Cell and Test Mode Considerations

    You can use the CALL:POW command to set the cell power in both active cell and test mode. However, in test mode you may prefer to manually control the output power of the test set using the CALL:RFG commands.

Set Mobile Station Transmit Power

In active cell mode, use one of the following commands to set the mobile station transmit power level (depending upon which test application you are using):

Commands to Set Mobile Station Transmit Power
Command | Example | Technology
CALL:MS:TXL:<band mnemonic> <num value> | CALL:MS:TXL:DCS <num value> | GSM
CALL:SET:MS:<channel type mnemonic>:TXL:<band mnemonic> <num value> | CALL:SET:MS:DIG:TXL:PCS <num value> | AMPS/136
CALL:<channel mnemonic>:MS:TXL:<band mnemonic>:BURS <num value> | CALL:PDTCH:MS:TXL:DCS: BURS <num value> | GPRS/EGPRS

In addition to setting the mobile station transmit level, these commands also automatically configure the test set's receiver at the expected input level, whether in active cell or test mode. However, in test mode, you must also send the appropriate test mode commands to the mobile station to command it to output at the correct level. This is due to the fact that the BSE is not transmitting call processing commands to the mobile station.

  • Manually Setting Expected Power

    Sending the CALL commands in Commands to Set Mobile Station Transmit Power automatically sets the expected input level of the test set's receiver. However, there is another option for setting the receiver's input level in both active cell and test mode. It is often beneficial to manually set the expected input power level using the RFAN commands, rather than using the CALL commands.

    When you set the expected power manually, you tell the test set exactly what power level to expect. Whereas the CALL commands simply tell the test set the range of input level to expect, based on the definition of the mobile station power level (for example, an AMPS/136 mobile station transmitting at power level 3 has an output level in the range of +20 dBm to +26 dBm).

Set Up Additional Connection Parameters

Depending upon the test application you are using, there may be other connection parameters to specify, such as timeslot, timing advance, vocoder, or data rates and types.

In active cell mode, you may also choose to set up network parameters, such as base station identifier numbers (for example, SID) and color codes.

All of these parameters are configured using the CALL subsystem.


Step 3: Set Measurement Parameters

Step 3: Set Measurement Parameters

Last updated: January 16, 2009

The following information provides additional details on Step 3 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you set up the conditions under which the measurements operate. You do this by configuring measurement parameters.

Contents

  • Measurement Parameters Overview
  • Generic Measurement Parameters
  • Measurement-Specific Measurement Parameters

Measurement Parameters Overview

There are two different types of measurement parameters:

  • Generic Measurement Parameters
  • Measurement-Specific Measurement Parameters

The SETup subsystem is used to configure measurement parameters. Each individual measurement parameter can be set and queried using the associated SETup subsystem command. The general hierarchy of the SETup subsystem command structure is as follows:

SETup:<measurement mnemonic>:<measurement parameter> <parameter setting/value>

NOTE
Not all measurements use all measurement parameters. Refer to the GPIB syntax listing for the detailed list of measurement parameters for individual measurements.

Generic Measurement Parameters

There are three types of generic measurement parameters:

  • Measurement Count (used by most measurements)
    Measurement Count State
    Measurement Count Number

  • Measurement Timeout (used by all measurements)
    Measurement Timeout State
    Measurement Timeout Time

  • Measurement Trigger (used by most measurements)
    Trigger Arm (used by all measurements)
    Trigger Source (not applicable to analog measurements)
    Trigger Delay (not applicable to analog measurements)

Measurement Count Parameters

The measurement count parameters control measurement averaging. The STATe command turns averaging on or off, and the NUMBer command determines the number of averages. The SNUMber command is a complex command which allows you to turn averaging on and set the number of averages in one command.

Statistical Measurement Results Parameters
Parameter | Command Syntax
Measurement Count State | SETup:<meas-mnemonic>:COUNt:STATe <ON|1|OFF|0>
Measurement Count Number | SETup:<meas-mnemonic>:COUNt:NUMBer <numeric value>
Measurement Count Number and State | SETup:<meas-mnemonic>:COUNt[:SNUMber] <numeric value>
Programming Example:

OUTPUT Test_set;"SET:DTXP:COUN 10"

sets the multi-measurement count state to ON and set the number of averages to 10 for the digital transmit power measurement.

Measurement Timeout Parameters

Measurement timeout parameters control the maximum time that a measurement executes. TIMe sets the amount of time and STATe determines if the timeout is in use. The STIMe command is a complex command which enables you to set both parameters in one command.

Measurement Timeout Parameters
Parameters | Command Syntax
Measurement Timeout Time and State | SETup:<meas-mnemonic>:TIMeout[:STIMe] <numeric value>[<suffix>]
Measurement Timeout State | SETup:<meas-mnemonic>:TIMeout:STATe <ON|1|OFF|0>
Measurement Timeout Time | SETup:<meas-mnemonic>:TIMeout:TIME <numeric value>[<suffix>]
Programming Example:

OUTPUT Test_set;"SET:DTXP:TIM 10"

sets the measurement timeout state to ON and set the measurement timeout time to 10 seconds for the digital transmit power measurement.

Measurement Trigger Parameters

There are three measurement trigger parameters. They control the arming of a measurement, the source of the trigger, and the trigger's delay.

  • The trigger arm parameter determines whether the test set makes one measurement and then stops (single), or automatically re-arms upon completion of one measurement and repeats the process (continuous). The recommended setting when writing a control program is single (CONTinuous OFF).

  • The trigger source parameter selects the source of the measurement trigger signal. The recommended Trigger Source setting when writing a control program is AUTO.

NOTE
Trigger source is always IMMediate for analog measurements and cannot be changed by the user.

  • The trigger delay parameter controls the delay between the trigger event (the point in time at which the trigger signal is received) and the start of sampling. Negative values indicate that the sampling should occur prior to the trigger event.

NOTE
Trigger delay is not applicable to analog measurements.

Measurement Trigger Parameters
Parameter | Command Syntax
Trigger Arm | SETup:<meas-mnemonic>:CONTinuous <ON|1|OFF|0>
Trigger Source | SETup:<meas-mnemonic>:TRIGger:SOURce <AUTO|IMMediate|PROTocol|RISE>
Trigger Delay | SETup:<meas-mnemonic>:TRIGger:DELay <numeric value>[<suffix>]

NOTE
You can set the Trigger Arm for all measurements to single (CONTinuous OFF) using the following command syntax:

SETup[:ALL]:CONTinuous:OFF

Programming Example:

OUTPUT Test_set;"SET:CONT:OFF"

sets the trigger arm to single for all measurements.

Programming Example:

OUTPUT Test_set;"SET:DTXP:TRIG:SOUR AUTO"

sets the trigger source to AUTO for the digital transmit power measurement.

Programming Example:

OUTPUT Test_set;"SET:DTXP:TRIG:DEL 10 US"

sets the trigger delay to 10 microseconds for the digital transmit power measurement.

Measurement-Specific Measurement Parameters

Measurement-specific measurement parameters set up operating conditions for a specific measurement. For example:

  • Setting the channel power measurement speed in IS-2000
  • Setting ORFS frequency offsets in GPRS
  • Setting number of bits for the FBER measurement in GSM

Refer to the GPIB syntax listing for the detailed list of measurement parameters for individual measurements.

Programming Example:

OUTPUT Test_set;"SET:CPOW:MSP FAST"

sets the IS-2000 channel power measurement speed to fast.

Programming Example:

OUTPUT Test_set;"SET:ORFS:SWIT:FREQ 400 KHZ"

sets the first ORFS offset to 400 kHz.

Programming Example:

OUTPUT Test_set;"SET:FBER:COUN 10000"

sets the number of fast BER bits to test to 10,000 bits.

Program Example Setting Both Generic and Measurement-Specific Measurement Parameters

! Set trigger arm to single for all measurements:
!
OUTPUT Test_set;"SET:CONT:OFF"
!
! *****************************************************
! Configure Modulation Accuracy Measurement:
!
OUTPUT Test_set;"SET:MACC:COUN 5"
! Example of using a complex command to set both the
! measurement count state and number at the same time.
!
OUTPUT Test_set;"SET:MACC:TRIG:SOUR AUTO"
! Sets trigger source to auto.
!
OUTPUT Test_set;"SET:MACC:TIM 15"
! Sets timeout state to ON and time to 15 sec.
!
OUTPUT Test_set;"SET:MACC:EVM10:STAT ON"
! Turns the EVM10 State ON
!
! ******************************************************
! Configure Digital TX Power Measurement:
!
OUTPUT Test_set;"SET:DTXP:COUN 5"
OUTPUT Test_set;"SET:DTXP:TRIG:SOUR AUTO"
OUTPUT Test_set;"SET:DTXP:TIM 5"
!
! ******************************************************
! Configure Frequency Stability Measurement:
!
OUTPUT Test_set;"SET:FST:COUN 3"
OUTPUT Test_set;"SET:FST:TIM 10"
!
! ******************************************************
! Configure Analog TX Power Measurement:
!
OUTPUT Test_set;"SET:ATXP:COUN 5"
OUTPUT Test_set;"SET:ATXP:TRIG:SOUR AUTO"
OUTPUT Test_set;"SET:ATXP:TIM 15"


Step 4: Make Connection

Step 4: Make Connection

Last updated: January 16, 2009

The following information provides additional details on Step 4 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you make a connection between the mobile station and test set. How you do this depends upon whether you are in active cell or test mode. In active cell mode you establish a phone call between the test set and mobile station. In test mode, you command the mobile station to synchronize to the test set's signal and begin transmitting back an appropriate signal.

Contents

  • Establish a Call in Active Cell Mode
  • Make a Test Mode Connection

Establish a Call in Active Cell Mode

To test a mobile station in active cell mode, you must first establish a call between the test set and mobile station. Your control program must issue the commands necessary to initiate the call connection process, either to the test set (for a base station originated call) or to the mobile station (for a mobile station originated call). Your control program must then determine when the call has successfully connected so that it can proceed to testing. The control program must also determine if the call has not been successfully connected so that it can take appropriate action.

Call States

At any instant in time a call can be in a stable state such as the idle or the connected state, or in one of many transitory states such as alerting, handoff, registering, releasing or paging. These are referred to as transitory states because the amount of time which the call can spend in any of these states is limited by the mobile station's protocol. The call is not allowed to stay in a transitory state indefinitely.

NOTE
If repeat paging or repeat registration are on, it is possible for the call process to stay in one of the transitory states beyond the time specified by the mobile station's protocol timers.

Call Connection Synchronization Commands

The test set has a set of commands designed specifically for call connection and release synchronization.

Call Connection Synchronization Commands
Synchronization Command | Command Syntax
Call-Connected-State Query | CALL:CONNected[:STATe]?
Call-State-Change Detector Arm | CALL:CONNected:ARM[:IMMediate]
Call-State-Change Detector Timeout | CALL:CONNected:TIMeout

  • Call-Connected-State Query

    The CALL:CONN? query allows the control program to determine if a call is in the connected state or in the idle state.

    Responses Returned by the CALL:CONN? Query
    Response | Meaning
    1 | The call is in the connected state.
    0 | The call is in the idle state.

    If the call is in one of the transitory states, the query waits until the call reaches the idle state or connected state before returning a value.

  • Call-State-Change Detector Arm Command

    The test set has a call-state-change detector which can be used to temporarily hold the response to a CALL:CONN? query until the call state has moved from idle to connected or vice versa.

    Without the call-state-change detector, the CALL:CONN? query only hangs if the call is in a transitory state. Otherwise, it immediately returns a 1 or 0. Therefore, if a call connection process is started and the CALL:CONN? query is sent before the call state has transitioned from idle to one of the transitory states, the query immediately returns a 0. This indicates that the call is in the idle state (and therefore that the connection attempt failed). In reality, the call likely connected, but not until after the CALL:CONN? query immediately returned a 0.

    When the call-state-change detector is armed during a connection attempt, if the CALL:CONN? query is sent while the call state is still idle, the query waits until the state changes to connected, and then returns a 1.

    The CALL:CONNected:ARM[:IMMediate] command is used to arm this call-state-change detector.

  • Call-State-Change Detector Timeout Command

    If the call-state-change detector is armed and a call connection is attempted but the call state never changes from the idle state, the CALL:CONN? query hangs the bus. This easily happens if the mobile is badly broken, the mobile is not connected to the test set, or no one pushes the send button on the mobile.

    The CALL:CONNected:TIMeout command is used to set the timeout value for the call-state-change detector.

    The timeout timer is started whenever the call-state-change detector is armed, and should be set to the maximum amount of time the control program should wait between arming the detector and the beginning of the connection process (when the call state moves from the idle state). If the timer expires before the call state has moved from the idle or connected state, the call-state-change detector is disarmed, which releases the CALL:CONN? query if it is currently hanging.

Process for Making a Base Station Originated Call

Process for Making a Base Station Originated Call

NOTE
It is not necessary for you to send the CALL:CONN:TIM and CALL:CONN:ARM commands as they are automatically sent by the test set during a base station originated call or base station release.

Programming Example

OUTPUT Test_set;"CALL:PAG:PNUM `0000574016'"! Set paging number
OUTPUT Test_set;"CALL:PAG:REP ON" ! Set paging repeat state
OUTPUT Test_set;"CALL:ORIG" ! Start a base station originated call
OUTPUT Test_set;"CALL:CONN?"  ! Hanging GPIB query
ENTER Test_set;Call_connected      ! Program hangs here until
                                   ! origination passes or fails
IF NOT Call_connected THEN
   OUTPUT Test_set;"CALL:END"
! <put error handler here>
END IF
! Call is connected so proceed with control program

Process for Making a Mobile Station Originated Call

Process for Making a Mobile Station Originated Call

NOTE
The test set cannot originate a call from the mobile station. You must physically dial a number on the mobile station and press send, or send commands to a test bus built into the mobile station. For mobile station originated calls where the call is originated by physically dialing a number (as opposed to using a test bus) ensure that the call-state-change detector timeout time is long enough to allow the number to be dialed.

Programming Example

OUTPUT Test_set;"CALL:CONN:TIM 10"         ! Set timeout time to 10 seconds
OUTPUT Test_set;"CALL:CONN:ARM"            ! Arm the change detector
DISP "Initiate a call from the mobile"
OUTPUT Test_set;"CALL:CONN?"          ! Initiate a call connected state query
ENTER Test_set;Call_connected              ! Program hangs here until
                                           ! origination passes or fails
IF NOT Call_connected THEN
   OUTPUT Test_set;"CALL:END"
! <put error handler here>
END IF
! Call is connected.  Proceed with the control program.

Make a Test Mode Connection

To make a connection between the test set and mobile station in test mode, you must send the appropriate test mode commands to the mobile station to command it to synchronize to the test set's signal and begin transmitting.

You may also want to make a quick power measurement to ensure that the connection has been made.


Step 5: INITiate and FETCh Measurements

Step 5: INITiate and FETCh Measurements

Last updated: January 16, 2009

The following information provides additional details on Step 5 of the Programming Flowchart. This information is applicable to all test applications.

Description

This step involves making measurements on the mobile station.

The test set has multiple signal paths and processors, which means you can make measurements concurrently and reduce test time. Making concurrent measurements involves starting a group of measurements, fetching the results of the measurements as they complete, and then verifying that the results are valid.

In this step you may also choose to make measurements in a more sequential way.

Contents

  • Concurrent Measurement Process
  • Alternative Measurement Process

Concurrent Measurement Process

Process for Making Concurrent Measurements

Start a Set of Concurrent Measurements

The INITiate command is used to start measurements. Each individual measurement can be started using the INITiate command. For starting measurements, the syntax of the INITiate command is as follows:

INITiate:<measurement mnemonic>[:ON]

More than one measurement can be started using a single INITiate command. For example:

OUTPUT Test_set;"INIT:TXP;PFER"

starts the transmit power measurement and the phase and frequency error measurement. These measurements then run concurrently.

Determine if a Measurement Is Done

Use the INITiate:DONE? query command to determine which measurement has completed.

This command is a query only and returns only one response per query. The responses returned and their meanings are shown in the following table:

Responses Returned from INITiate:DONE? Query
Response String | Meaning
<MEASUREMENT1 mnemonic> | MEASUREMENT1 is done.
<MEASUREMENT2 mnemonic> | MEASUREMENT2 is done.
WAIT | There are one or more measurements that are in progress, but none of those measurements are done yet.
NONE | No measurements are in progress.

Once a measurement is reported as being complete via the INITiate:DONE? query it is removed from the done list (it is not reported again). To use the INITiate:DONE? query properly, your control program should immediately fetch a measurement's results once it is reported as being complete.

Obtain a Set of Measurement Results

In order to minimize bus traffic and reduce test time, the test set's measurements are designed to return multiple measured values in response to a single measurement request.

For example, if a transmit power measurement with averaging is initiated there are five measurement results available. These are:

  1. Measurement integrity value
  2. Average value
  3. Minimum value
  4. Maximum value
  5. Standard deviation value

The test set can return the measurement results in a variety of formats to suit your needs using the FETCh? subsystem. The general structure of the FETCh? command is as follows:

FETCh:<measurement mnemonic>:<result format>?

For example, the transmitter power measurement results can be returned as:

Example FETCh? Result Formats
Command | Results Returned
FETC:TXP? | Measurement integrity and average value
FETC:TXP:POW:ALL? | Minimum, maximum, average and standard deviation values
FETC:TXP:POW:AVER? | Average value only
FETC:TXP:POW:MIN? | Minimum value only
FETC:TXP:POW:MAX? | Maximum value only
FETC:TXP:POW:SDEV? | Standard deviation value only
FETC:TXP:INT? | Measurement integrity value only
Concurrent Measurement Process Programming Example

! Start a Set of Concurrent Measurements:
!
OUTPUT Test_set;"INIT:TXP;PFER"
!
! Determine if a Measurement Is Done:
!
LOOP
  OUTPUT Test_set;"INIT:DONE?"
  ENTER Test_set;Meas_done$
!
! Obtain a Set of Measurement Results:
!
  SELECT Meas_done$
    CASE "TXP"
      OUTPUT Test_set;"FETC:TXP:POW?"
      ENTER Test_set;Avg_tx_power
    CASE "PFER"
      OUTPUT Test_set;"FETC:PFER:RMS?"
      ENTER Test_set;Max_rms_phas_er
  END SELECT
EXIT IF Meas_done$="NONE"
END LOOP

Validate Measurement Results

Validating measurement results is extremely important. The test set returns a result if it is capable of making a measurement, even if this result is obtained under adverse conditions.

The measurement integrity indicator is a measurement result and therefore is queried using the FETCh subsystem. A value of 0 indicates that the measurement is valid. A value other than 0 indicates that an error occurred during the measurement process.

Example Integrity Indicators
Value Returned | Description (message also appears on test set)
0 | Normal
1 | No Result Available
2 | Measurement Timeout
5 | Over Range
6 | Under Range
Programming Example

OUTPUT Test_set;"FETC:DTXP?"
ENTER Test_set;Integrity,Avg_dig_pow
IF Integrity=0 THEN
   PRINT "AVG DIG POW= ";Avg_dig_pow
ELSE
   PRINT "DTXP Measurement Error"
   PRINT "DTXP Measurement Integrity is ";Integrity
END IF

Alternative Measurement Process

You may choose to test in a sequential way rather than use the concurrent measurement process.

For instance, instead of using the INIT:DONE? query to determine when a measurement is complete, you may choose to initiate a set of measurements and then simply fetch them sequentially.

Programming Example

OUTPUT Test_set; "INIT:DTXP;MACC"
OUTPUT Test_set; "FETC:DTXP:POW?"
ENTER Test_set;Avg_dig_pow
OUTPUT Test_set; "FETC:MACC:EVM[1]?"
ENTER Test_set;Max_EVM1

In this example, the test set starts both measurements at the same time. However, if the MACC measurement finishes first, the results are not fetched until the DTXP measurement finishes. Therefore, this process requires that you understand the order in which measurements will complete in order to optimize your testing speed.


Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Last updated: January 16, 2009

The following information provides additional details on Step 6 of the Programming Flowchart. This information is applicable to all test applications.

Description

After performing a set of measurements on the mobile station using the configuration established in step 2, you may want to change this configuration and test the mobile station again. This step involves changing testing conditions such as channel, mobile station transmit power level, or cell power.

Contents

  • Change Channels
  • Change Other Connection Parameters

Change Channels

In a manufacturing environment it is common to test a mobile station on more than one channel. Some or all of the tests may be performed on multiple channels, to verify the mobile station's performance in a range of operating frequencies.

Perform a Handoff (Handover) in Active Cell Mode

If you are operating in active cell mode, to change channels you perform a handoff (handover) to the new channel. The control program sends the commands to initiate the handoff (handover), and then determines whether the transition was successfully completed. This is accomplished using the CALL:STATus? query.

The CALL:STATus? query immediately returns the state of the call at the time the query is received.

Example Responses Returned from the CALL:STAT? Query
Response | Meaning
IDLE | The call is in the Idle state
ALER | The call is in the Alerting transitory state.
HAND | The call is in the Handoff transitory state.
PAG | The call is in the Paging transitory state.
CONN | The call is in the Connected state.

After issuing the commands to perform a handoff (handover), you should send the CALL:STAT? query to verify that the call is still connected before resuming testing.

Process for Performing a Handoff (Handover)

Test Mode Considerations

In test mode, you can either change the test set's frequencies by using the handoff (handover) commands, or directly control the RF generator and RF analyzer.

In either case, you must also send the appropriate test mode commands to the mobile station to move it to the new channel.

Change Other Connection Parameters

You may also choose to change the mobile station transmit power level or cell power, or other connection parameters such as timeslot or timing advance.


Step 7: End Connection

Step 7: End Connection

Last updated: January 16, 2009

The following information provides additional details on Step 7 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you release the call (in active cell mode) or end the mobile station transmission (in test mode).

Contents

  • Release the Call in Active Cell Mode
  • End the Mobile Station Test Mode Transmission
  • Partially Preset the Test Set

Release the Call in Active Cell Mode

In active cell mode, you can release the call with the mobile station in one of two ways:

  • Release from the Base Station

  • Release from the Mobile Station

Releasing an Active Call from the Base Station

Process for Releasing an Active Call from the Base Station
Programming Example

OUTPUT Test_set;"CALL:END"        ! Initiate a base station release.
OUTPUT Test_set;"CALL:CONN?" 	 	! Send call connected state query.
ENTER Test_set;Call_connected     ! Program hangs here until state
                                  ! change or timer expires.
IF Call_connected THEN            ! Check if disconnection successful
! <put error handler here>
END IF
! Call is disconnected so proceed with control program

Releasing an Active Call from the Mobile Station

Process for Terminating an Active Call from the Mobile Station

NOTE
The test set cannot initiate a call disconnection from the mobile station. You must manually push the end button on the mobile station or send commands to a test bus built into the mobile station. For a mobile station release where the call is terminated by physically pushing a button on the phone (as opposed to using a test bus) ensure that the call-state-change-detector timeout time is long enough to allow the end button to be pushed.

Programming Example

OUTPUT Test_set;"CALL:CONN:TIM 5" !Set timeout time to 5 seconds.
OUTPUT Test_set;"CALL:CONN:ARM"   !Arm the change detector.
DISP "Terminate the call from the mobile station."
OUTPUT Test_set;"CALL:CONN?" !Initiate call connected state query.
ENTER Test_set;Call_connected     !Program hangs here until state
                                  !change or timer expires.
IF Call_connected THEN            !Check if disconnection successful.
! <put error handler here>
END IF
! Call is disconnected so proceed with control program

End the Mobile Station Test Mode Transmission

In test mode, you must send the necessary test mode commands to end the mobile station transmission.

Partially Preset the Test Set

At this point, it is good practice to partially preset the test set by sending the SYST:PRES3 command. This command stops all measurement and call processing processes, but does not reset all values to default.


wcdma_prog_getting_started_flowchart

Programming: Getting Started Guide for
W-CDMA Mobile Test

Introduction

Last updated: January 16, 2009

The Getting Started Guide is organized around the basic set of tasks a control program normally performs when testing a mobile station in a manufacturing environment.

Click on any step in the flowchart below to learn more about how to program the Agilent Technologies 8960 to perform these tasks.

Programming Flowchart

  • Step 1: Set Up the Test Set
  • Step 2: Configure Test Set and UE Parameters
  • Step 3: Set Measurement Parameters
  • Step 4: Make a Connection
  • Step 5: INITiate and FETCh Measurements
  • Step 6: Reconfigure Test Set and UE Connection Parameters
  • Step 7: End the Connection

You can also use the buttons on each page to navigate between steps, return to the flowchart, or to find more detailed information about each step.

Conventions used in this Getting Started Guide

Throughout this Getting Started Guide the term "test set" refers to an Agilent Technologies 8960 Series 10 wireless communications test set with the E1963A W-CDMA mobile test application installed.

UE refers to W-CDMA user equipment like a mobile station, for example.

The variable Testset used in the steps of the Getting Started Guide refers to the test set's GPIB address.

About the Programming Examples Presented in this Guide

Programming Language:

Programming examples presented in this guide are written in the HP BASIC programming language, also known as RMB or Rocky Mountain BASIC. The use of HP BASIC is not an endorsement of the HP BASIC product.

Line Numbers

All of the programming examples in the guide with line numbers are sections from a control program example available on-line for you to download.

Code that is not part of the download control program example does not have line numbers. This code may represent an alternate method of performing the task or may illustrate a feature not used by the control program example.

Syntax used in Programming Examples:

  • The programming examples use the shortened form of the command syntax to minimize GPIB bus transactions. The shortened form of a command is defined by use of capital letters in the command syntax. For the command syntax:

 RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO?

    the shortened form would be:

 RFAN:CONT:MEAS:FREQ:AUTO?
  • The programming examples do not include optional nodes. Optional nodes in the command syntax are defined by enclosing the node inside the [ ] brackets. For example, the command syntax:

 CALL[:CELL]:POWer[:SAMPlitude] -80dBm

    appears in the programming examples as:

 CALL:POW -80dBm

  • Programming examples make extensive use of compound commands using the ; and the ;: separators. Refer to the on-line information for the definition and use of these command separators.

Complex Commands

Complex commands are used to configure the state and assign values to parameters simultaneously. Complex commands can be used to save programming steps and minimize GPIB bus transactions.

  • The syntax below turns the state of the parameter on.

    OUTPUT Test_set;"SET:DTXP:TIM:STAT ON"

  • The syntax below is used to assign a value to the parameter.

    OUTPUT Test_set;"SET:DTXP:TIM:STAT 10 S"

  • Both of the above actions can be accomplished with one syntax command:

    OUTPUT Test_set;"SET:DTXP:TIM:STAT 10 S"

    The command above sets the parameter state to ON and the value of the parameter to 10 seconds. Note that in this example the optional command mnemonic :STIMe has been included to clarify that this complex command was used to set both the state and the value.

  • This command can be shortened further by removing the optional command mnemonic :STIMe, as shown below.

    OUTPUT Test_set;"SET:DTXP:TIM 10 S"

    This is the format that will be used throughout this guide.


Step 1: Set Up the Test Set

Step 1: Set Up the Test Set

Last updated: January 16, 2009

In this step you initialize the test set and set up general operating conditions.

  • Initialize the Test Set
  • Set Up General Operating Conditions

Initialize the Test Set

Fully Preset the Test Set

It is important to start each production session with the test set in a known state. Sending the *RST command resets all parameters to their default values, ends all measurement processes, and sets all measurement triggers to single.

Clear the Error Queue

At the start of each production session it is useful to clear the error queue so that you know any messages logged are relevant to the current production session.

Programming Example

210   OUTPUT Testset;"*RST"
220   OUTPUT Testset;"*CLS"

Set Up General Operating Conditions

Turn Debugger On

The debugger is useful while you are developing code. When it is on, the test set alerts you when you send an incorrect command. You should turn it off once your code is complete.

Set Operating Mode

There are four operating modes available: Active Cell, FDD Test Mode, CW Mode, or Cell Off Mode.

Some cell and connection parameters can not be set unless the operating mode is set to Cell Off.

Set Amplitude Offsets

You can account for path loss in your system by setting amplitude offsets. You can specify up to 20 frequency/amplitude pairs.

Programming Example

230   OUTPUT Testset;"SYST:COMM:GPIB:DEB ON"
240   OUTPUT Testset;"CALL:OPER:MODE OFF"
250   OUTPUT Testset;"SYST:CORR:FREQ 2000MHZ"
260   OUTPUT Testset;"SYST:CORR -1"


Step 2: Configure Test Set and UE Parameters

Step 2: Configure Test Set and UE Parameters

Last updated: January 16, 2009

In this step you configure the parameters that allow a connection to be made between the test set and UE.

  • Set up the Cell Parameters
  • Set Generator Info Parameters
  • Set Uplink Parameters
  • Set up Call Parameters
  • Set Uplink Channel Levels
  • Set up Call Control

Set up the Cell Parameters

The example below illustrates how to set up the cell parameters. You can set cell parameters like the MCC, MNC, and LAC as well as specify whether single or repeat paging should be used when paging the UE.

The operating mode must be Cell Off to set up the cell parameters. See Set Operating Mode . If you do not set the operating mode to Cell Off, the test set generates the following error:

Command Rejected. Change Not Allowed in Active Cell Mode.

320   ! Cell Parameters
330   OUTPUT Testset;"CALL:LAC 30865" !Correct LAC avoids Location Update
340   OUTPUT Testset;"CALL:MCC 234"
350   OUTPUT Testset;"CALL:MNC 56"
360   OUTPUT Testset;"CALL:PAG:REP:STAT:WCDMA ON

Set Generator Info Parameters

There are several downlink physical channels and an AWGN (Additive White Gaussian Noise) source which you can configure. You can set the power level of each physical channel (relative to cell power) and the absolute power level of the AWGN source. You can also specify that these channels use different power levels once an Active Cell connection has been established. For some of the physical channels you can also specify the channelization code. The downlink channel codes and levels required the operating mode be set to Cell Off for configuring.

370   ! Generator Info
380   !   -Downlink Channel Codes
390   OUTPUT Testset;"CALL:SCOD:PRIM 0"
400   OUTPUT Testset;"CALL:SRB:CCH:DED:BPS3400:CCOD CODE12"
410   OUTPUT Testset;"CALL:CCPC:SEC:CCOD CODE7"
420   OUTPUT Testset;"CALL:PICH:CCOD CODE16"
430   OUTPUT Testset;"CALL:AICH:CCOD CODE10"
440   OUTPUT Testset;"CALL:DPCH:RMC12:CCOD CODE9"
450   !   -Downlink Channel Levels
460   OUTPUT Testset;"CALL:CPIC -4.8"
470   OUTPUT Testset;"CALL:CCPC:PRIM -7.1"
480   OUTPUT Testset;"CALL:CCPC:SEC -6.9"
490   OUTPUT Testset;"CALL:PICH -9.9"
500   OUTPUT Testset;"CALL:AICH -9.9"
510   OUTPUT Testset;"CALL:DPCH -12"
520   !   -Connected DL Channel Levels
530   OUTPUT Testset;"CALL:CONN:CPIC -3.3"
540   OUTPUT Testset;"CALL:CONN:CCPC:PRIM -5.35"
550   OUTPUT Testset;"CALL:CONN:PICH -20" !Change PICH to give OCNS
560   OUTPUT Testset;"CALL:CONN:DPCH -10.3"
570   !   -AWGN Power
580   OUTPUT Testset;"CALL:AWGN:POW:STAT OFF"

Set Uplink Parameters

The example below illustrates how to configure the PRACH and how to indicate what primary scrambling code the UE is using. The operating mode must be Cell Off to set these parameters.

590   ! Uplink Parameters
600   OUTPUT Testset;"CALL:UPL:PRAC:POW:STEP 3"
610   OUTPUT Testset;"CALL:UPL:PRAC:SIGN 0"
620   OUTPUT Testset;"CALL:UPL:PRAC:SCOD 0"
630   OUTPUT Testset;"CALL:UPL:DPCH:SCOD 0"

Set up Call Parameters

You must set the frequency at which the downlink will transmit, by specifying either the UARFCN or the frequency.

You must indicate to the 8960 at what frequency the UE will transmit. (Unlike other technologies, in W-CDMA the uplink channel is not automatically determined based on the downlink channel. The offset between the uplink and downlink may vary based upon which band class you are operating in. So, you must specify the uplink frequency.) You can specify the expected uplink frequency by UARFCN or by frequency.

You can specify the downlink DPCH type (such as 12.2k RMC) and data type (such as PRBS15).

650   ! Call Parameters
660   OUTPUT Testset;"CALL:POW ";Rf_level
670   OUTPUT Testset;"CALL:DPCH:TYP RMC12"
680   OUTPUT Testset;"CALL:CHAN 10563"
690   OUTPUT Testset;"CALL:UPL:CHAN 9613"
700   OUTPUT Testset;"CALL:DTCH:DATA PRBS15"
710   OUTPUT Testset;"CALL:SRB:CCH:DED:DRAT BPS3400"

Set Uplink Channel Levels

As the example below illustrates, you can specify which closed loop power control bit sequence is sent on the downlink DPCCH.

It is important for you to specify what uplink power level the test set should expect by setting the MS Target Power. (In Active Cell mode, this command forces the UE to the specified output power. In FDD Test Mode, since the 8960 is not performing active closed loop power control of the uplink, this command does not change the UE's output power.) Setting the MS Target Power automatically sets the receiver's expected power accordingly.

720   ! Uplink Channel Levels
730   OUTPUT Testset;"CALL:CLPC:UPL:MODE ACT"
740   OUTPUT Testset;"CALL:MS:POW:TARG 0 DBM"

Set up Call Control

Finally, for performing the test set originated connection in Step 4: Make a Connection , you specify the UE's IMSI and change the operating mode back to Active Cell.

750   ! Call Control
760   OUTPUT Testset;"CALL:PAG:IMSI `1234567890'"
770   OUTPUT Testset;"CALL:OPER:MODE CALL"


Step 3: Set Measurement Parameters

Step 3: Set Measurement Parameters

Last updated: January 16, 2009

In this step you set up measurement parameters. This configures the measurements so that they are ready to execute in Step 5: INITiate and FETCh Measurements .

Many of the measurements have only generic measurement parameters available, such as measurement count, timeout, trigger arm and trigger source.

There is a command available to set all measurement triggers to single ( SET:CONT:OFF ), which is the recommended trigger arm configuration for remote use of the test set. However, if you sent the *RST command in Step 1: Set Up the Test Set , all measurement triggers will already be set to single.

Some measurements have measurement-specific parameters available. Consult the programming reference material available on the Internet to find out more about measurement-specific parameters.

Programming Example

830   ! Set all measurement triggers to single
840   OUTPUT Testset;"SET:CONT:OFF"
850   ! Set up the Thermal Power measurement
860   OUTPUT Testset;"SET:WTP:TIM 7;COUN 1"
870   ! Set up the Channel Power measurement
880   OUTPUT Testset;"SET:WCP:TIM 7;COUN 1"
890   OUTPUT Testset;"SET:WCP:INT:TIME .667 MS"
900   OUTPUT Testset;"SET:WCP:FILT ON" ! Turn the RRC filter on
910   ! Set up the Waveform Quality measurement
920   OUTPUT Testset;"SET:WWQ:TIM 7;COUN 1;TSL 1"
930   ! Set up the ACLR measurement
940   OUTPUT Testset;"SET:WACL:TIM 7;COUN 1"
950   ! Set up the Loopback BER measurement
960   OUTPUT Testset;"SET:WBER:TIM 7;COUN 10000"
970   ! Set up the Occupied Bandwidth measurement
980   OUTPUT Testset;"SET:WOBW:TIM 7;COUN 1"
990   ! Set up the Spectrum Emission Mask measurement
1000  OUTPUT Testset;"SET:WSEM:TIM 7;COUN 1"


Step 4: Make a Connection

Step 4: Make a Connection

Last updated: January 16, 2009

In this step you establish communication between the test set and user equipment such that measurements can be made. There are two possible ways to make a connection with the UE.

  • Originating a Connection from the Test Set
  • Make a Connection using Test Mode Commands

Originating a Connection from the Test Set

The code below illustrates how to make a connection by originating a call from the test set and taking advantage of the repeat paging feature to decrease connection speed.

Origination is performed in a subroutine to allow the use of a timeout separate from the control program's GPIB timeout. This is necessary because the use of repeat paging prevents the use of the state change detector and it's associated timeout (activated by the CALL:CONN? hanging query). Therefore, to prevent GPIB bus from hanging indefinitely, which could occur if the UE is not turned on or badly broken, a timeout is implemented in the subroutine on line 2790. The :SEQ sequential command is appended to the CALL:ORIG command to prevent subsequent commands from being accepted by the test set before repeated pages can be used to originate a connection.

1060  PRINT "Turn the UE on now."
1070  Originate ! Subroutine to originate a connection

2810  SUB Originate
2820    COM /Address/ INTEGER Testset
2830    ON TIMEOUT 7,10 CALL Orig_failed
2840    OUTPUT Testset;"CALL:ORIG:SEQ"
2850    OUTPUT Testset;"CALL:CONN?"
2860    ENTER Testset;Connected
2870    IF NOT Connected THEN
2880      PRINT "Call origination not successful."
2890      STOP
2900    END IF
2910  SUBEND

If the origination fails

By using repeat paging, a situation has been introduced in which the test set will not respond to subsequent GPIB commands until the origination is successful. Once the origination attempt has timed out, it becomes necessary to send the test set a Device Clear remote command (IEEE 488.2 Section 6.1.4.2.6) to free up the remote user interface. In HP BASIC this is the CLEAR command, see line 1900. Subsequently, you can send the CALL:END command to stop paging the UE and proceed with the control program.

1920  SUB Orig_failed
1930    COM /Address/ INTEGER Testset
1940    CLEAR Testset
1950    OUTPUT Testset;"CALL:END"
1960    PRINT "Origination failed. Check conditions and run again."
1970    STOP
1980  SUBEND

Make a Connection using Test Mode Commands

When the test set is operating in FDD Test Mode, you do not send any commands to the test set for this step. The test set should already be properly configured and transmitting its downlink signal so that the UE can detect and synchronize to it. In this step you either implement a pause in your program and wait for the UE to be manually configured and begin transmitting, or send appropriate test mode commands to configure the UE and begin its transmission.

The method used to synchronize the UE with the test set is proprietary to the UE manufacturer. The test set has no direct control of synchronization when the UE is operating in test mode.


Step 5: INITiate and FETCh Measurements

Step 5: INITiate and FETCh Measurements

Last updated: January 16, 2009

In this step you INITiate measurements, FETCh the results, and verify the results are valid.

  • INITiate a Set of Concurrent Measurements
  • FETCh Measurement Results

INITiate a Set of Concurrent Measurements

The test set is capable of performing concurrent measurements. To start the measurement process you INITiate a set of concurrent measurements.

1190    OUTPUT Testset;"INIT:WBER;WTP;WWQ;WACL;WOBW;WSEM"
1200    Fetch_results! Go to a subroutine to handle the results

FETCh Measurement Results

To retrieve measurement results as they complete, you must set up a loop using the INIT:DONE? query. Depending upon the output of the query, the program will either wait for a measurement to complete, FETCh the result of a completed measurement, or continue the program once all measurements are complete. Once a measurement result is FETChed, you should check its integrity indicator to verify that the result is valid.

1990  SUB Fetch_results
2000    COM /Address/ INTEGER Testset
2010    REPEAT
2020      OUTPUT Testset;"INIT:DONE?"
2030      ENTER Testset;Measdone$
2040      SELECT Measdone$
2050      CASE "WTP"
2060        OUTPUT Testset;"FETC:WTP:INT?;POW?"
2070        ENTER Testset;Integrity,Power
2080        IF Integrity=0 THEN
2090          Print_results(Measdone$,Power)
2100        ELSE
2110          Meas_error(Measdone$,Integrity)
2120        END IF
2130      CASE "WCP"
2140        OUTPUT Testset;"FETC:WCP:INT?;POW?"
2150        ENTER Testset;Integrity,Power
2160        IF Integrity=0 THEN
2170          Print_results(Measdone$,Power)
2180        ELSE
2190          Meas_error(Measdone$,Integrity)
2200        END IF
2210      CASE "WWQ"
2220        OUTPUT Testset;"FETC:WWQ?"
2230        ENTER Testset;Integrity,Evm,Ferr,Ooff,Perr,Merr
2240        IF Integrity=0 THEN
2250          Print_results(Measdone$,Evm,Ferr,Ooff,Perr,Merr)
2260        ELSE
2270          Meas_error(Measdone$,Integrity)
2280        END IF
2290      CASE "WACL"
2300        OUTPUT Testset;"FETC:WACL:INT?;AVER?"
2310        ENTER Testset;Integrity,Negfive,Posfive,Negten,Posten
2320        IF Integrity=0 THEN
2330          Print_results(Measdone$,Negfive,Posfive,Negten,Posten)
2340        ELSE
2350          Meas_error(Measdone$,Integrity)
2360        END IF
2370      CASE "WBER"
2380        OUTPUT Testset;"FETC:WBER?"
2390        ENTER Testset;Integrity,Ber
2400        IF Integrity=0 THEN
2410          Print_results(Measdone$,Ber)
2420        ELSE
2430          Meas_error(Measdone$,Integrity)
2440        END IF
2450      CASE "WOBW"
2460        OUTPUT Testset;"FETC:WOBW?"
2470        ENTER Testset;Integrity,Obw
2480        IF Integrity=0 THEN
2490          Print_results(Measdone$,Obw)
2500        ELSE
2510          Meas_error(Measdone$,Integrity)
2520        END IF
2530      CASE "WSEM"
2540        OUTPUT Testset;"FETC:WSEM?"
2550        ENTER Testset;Integrity,Overall,Pow,Range1,Range2,Range3,Range4
2560        IF Integrity=0 THEN
2570          Print_results(Measdone$,Overall)
2580        ELSE
2590          Meas_error(Measdone$,Integrity)
2600        END IF
2610      END SELECT
2620    UNTIL Measdone$="NONE"
2630  SUBEND


Step 6: Reconfigure Test Set and UE Connection Parameters

Step 6: Reconfigure Test Set and UE Connection Parameters

Last updated: January 16, 2009

In this step you change characteristics of the link between the test set and UE differently depending on your test set operating mode.

  • Reconfigure the Connection when using Active Cell
  • Reconfigure the Connection when using Test Mode

Reconfigure the Connection when using Active Cell

The example below illustrates how to change the downlink and uplink channels. The process used to reconfigure the connection is to first change the parameter settings with CALL:SET commands. These new parameters are activated when the CALL:HAND command is sent. The CALL:STAT? query is used to ensure the call is still connected. If the connection is compromised, the subroutine Dropped_call is called.

1260  !Use deferred commands to set up new channels
1270    OUTPUT Testset;"CALL:SET:CHAN:DOWN 10526"
1280    OUTPUT Testset;"CALL:SET:CHAN:UPL 9626"
1290    OUTPUT Testset;"CALL:HAND:PCR" ! Executes the handoff
1300    OUTPUT Testset;"CALL:STAT?" ! Verify the handoff success
1310    ENTER Testset;Call_state$
1320    IF Call_stat$<>"CONN" THEN Dropped_call

Reconfigure the Connection when using Test Mode

If you change the test set configuration, such as downlink frequency or primary scrambling code, you must configure the test set and then allow the user equipment to find the new configuration and synchronize to it before proceeding with measurements. It is not necessary to use the CALL:HAND command used when the UE is on an active call.


Step 7: End the Connection

Step 7: End the Connection

Last updated: January 16, 2009

You can end the connection in one of two ways:

  • Ending the Connection from the Test Set
  • Ending the Connection from the UE

Ending the Connection from the Test Set

The CALL:END command is used to end the connection. Here you use the CALL:CONN? query for call synchronization. This query returns a 0 if the call ended successfully and a 1 if the call is not ended.

1390  OUTPUT Testset;"CALL:END"
1400  OUTPUT Testset;"CALL:CONN?"
1410  ENTER Testset;Callstate
1420  IF Callstate=1 THEN
1430    PRINT "Make sure the phone has released the call."
1440    OUTPUT Testset;"SYST:PRES3"
1450  END IF

Ending the Connection from the UE

Because the connection is being ended from the UE, it is important to set a timeout value and arm the change detector. More information about using these commands to achieve call synchronization is available in the additional details about this step available on the Internet.

OUTPUT Testset;"CALL:CONN:TIM 5" !Set timeout time to 5 seconds.
OUTPUT Testset;"CALL:CONN:ARM"   !Arm the change detector.
DISP "Terminate the call from the mobile station."
OUTPUT Testset;"CALL:CONN?" !Initiate call connect state query.
ENTER Testset;Call_connected     !Program will hang here until state
                                  !change or timer expires.
!Check if disconnect successful.
IF Call_connected THEN OUTPUT Testset;"SYST:PRES3"


Programming an HSDPA Block Error Ratio Measurement

Programming an HSDPA Block Error Ratio Measurement

Last updated: January 16, 2009

This section is only applicable to the lab application or a test application with the required feature license.

This example is for FDD Test Operating Mode . The measurement is also available in Active Cell Operating Mode .

This section provides an example of how to make HSDPA BLER measurements via remote program. The following program example assumes that the UE is connected to the RF IN/OUT connector.

The basic procedure to test HSDPA BLER is as follows:

  1. Set the HSDPA BLER setup parameters as desired using the SETup:HBLerror commands.
  2. Use the INITiate:HBLerror command to start the measurement.
  3. Use the FETCh:HBLerror query to obtain the measurement results (or use the READ:HBLerror? command to both initiate and fetch the measurement as a sequential operation).

Programming Example

10 ! HSDPA Block Error Ratio Measurement Programming Example
20 ! 3GPP TS 34.121 6.3A Maximum Input Level for HS-PDSCH
30 ! Reception (16QAM)
40 !
50       Testset=714
60 !
70 !***Set up test parameters***
80 !
90       OUTPUT Testset;"CALL:OPERating:MODE FDDTest"
100 ! Set Operating Mode to FDD Test
110       OUTPUT Testset;"CALL:POWer -25.7"
120 ! Set Cell Power to -25.7 dB
130       OUTPUT Testset;"CALL:SERVice:RBTest:RAB HSDParmc12"
140 ! Set Channel Type to 12.2k RMC + HSDPA
150       OUTPUT Testset;"CALL:FDDTest:FRC:TYPE QAM1"
160 ! Set FRC Type to H-Set 1 16QAM
170       OUTPUT Testset;"CALL:FDDTest:MACHs:NTRans 1"
180 ! Set FDD Test Number of Tranmissions to 1
190       OUTPUT Testset;"CALL:FDDTest:MACHs:RVSequence `6'"
200 ! Set FDD Test RV Sequence to 6,0,0,0,0,0,0,0
210       OUTPUT Testset;"CALL:FDDTest:HRNTi `32'"
220 ! Set FDD Test Primary H-RNTI (Hex) as needed
230       OUTPUT Testset;"CALL:MS:POWer:TARGet 20"
240 ! Set UE Target Power to 20 or 18 dBm
250       OUTPUT Testset;"CALL:FDDTest:DPCHannel:HSDPa -13"
260 ! Set HSDPA FDD Test DPCH Level to -13 dB
270       OUTPUT Testset;"CALL:FDDTest:HSSCchannel -13"
280 ! Set FDD Test HS-SCCH 1 Level to -13 dB
290 !
300 !***Set up measurement parameters***
310 !
320       OUTPUT Testset;"SETup:HBLerror:COUNt 500"
330 ! Set Number of blocks to test to 500
340       OUTPUT Testset;"SETup:HBLerror:CONTinuous OFF"
350 ! Set Trigger Arm to Single
360 !
370       CLEAR SCREEN
380       PRINT "Configure the UE to synchronize to the test "
390       PRINT "set, demodulate the HS-SCCH and HS-PDSCH "
400       PRINT "channels and generate an HS-DPCCH."
410       PRINT
420       PRINT "Press CONTINUE"
430       PRINT
440 !
450       PAUSE
460 !
470 !***INITiate and FETCh measurements***
480 !
490       OUTPUT Testset;"INITiate:HBLerror"
500 ! Initiate an HBLER measurement
510       OUTPUT Testset;"FETCh:HBLerror?"
520       ENTER Testset;Int,Ratio,R,Ack,Nack,Sdtx,Num,Mcqi
530 !
540 !***Print measurement results***
550 !
560       PRINT "HSDPA Block Error Ratio Results:"
570       PRINT
580       PRINT "Integrity Indicator                     = ",Int
590       PRINT "Block Error Ratio (%)                   = ",Ratio
600       PRINT "Information Bit Throughput (kbps)       = ",R
610       PRINT "Positive Acknowledgments                = ",Ack
620       PRINT "Negative Acknowledgments                = ",Nack
630       PRINT "Statistical DTXs                        = ",Sdtx
640       PRINT "Number of Blocks Tested                 = ",Num
650       PRINT "Median Channel Quality Indicator        = ",Mcqi
660 !
670       END
680 !

Related Topics

  • HSDPA Block Error Ratio Troubleshooting
  • HSDPA Block Error Ratio Measurement Description
  • Manual Operation: How Do I Make an HSDPA Block Error Ratio Measurement?


Programming an HSDPA Reporting of Channel Quality Indicator Measurement

Programming an HSDPA Reporting of Channel Quality Indicator Measurement

Last updated: January 16, 2009

This section is only applicable to the lab application.

This example is for Active Cell Operating Mode .

This section provides an example of how to make Reporting of Channel Quality Indicator measurements via a remote program. The following program example assumes that the UE is connected to the RF IN/OUT connector, the appropriate Amplitude Offsets are set and the UE has attached to the test set.

The basic procedure to perform the Reporting of Channel Quality Indicator measurement is as follows:

  1. Set the Reporting of Channel Quality Indicator setup parameters as desired using the SETup:HRCQuality commands as well as non-measurement specific test set parameters that are called out in the 3GPP standards (see Parameters that Affect the HSDPA Reporting of Channel Quality Indicator Measurement ).
  2. Use the INITiate:HRCQuality command to start the measurement.
  3. Use the FETCh:HRCQuality query to obtain the measurement results (or use the READ:HRCQuality? command to both initiate and fetch the measurement as a sequential operation).

Programming Example

10  ! Reporting of Channel Quality Indicator Measurement Programming Example
20    ! 3GPP TS 34.121 9.3.1 Single Link Performance - AWGN Propagation Conditions
30    ! Category 8 UE
40    !
50          Testset=714
60    !
70    !***Set up test parameters***
80    !
90         OUTPUT Testset;"CALL:OPERating:MODE OFF"
100     ! Set Operating Mode to OFF
110         OUTPUT Testset;"CALL:HSDPa:SERVice:RBTest:HSPDschannel:CCODe CODE5"
120     ! Set RB Test Mode First HS-PDSCH Channel Code to 5
130  !
140         OUTPUT Testset;"CALL:HSDPa:SERVice:RBTest:UDEFined:HARQ:PROCess:COUNt 2"
150     ! Set User Defined Number of HARQ Processes 2
160        !
170         OUTPUT Testset;"CALL:SERVice:RBTest:RAB HSDParmc12"
180     ! Set Channel Type to 12.2k RMC + HSDPA
190     !
200         OUTPUT Testset;"CALL:HSDPa:MACHs:SDTX:RBEHavior ACK"
210     ! Set statDTX Reception Behavior to Handle as NACK
220      !
230      !
240 !***Settings per 34.121 table 9.3.1.1***
250 !
260         OUTPUT Testset;"CALL:POWer -50"
270     ! Set Cell Power to -50 dBm
280         OUTPUT Testset;"CALL:AWGNoise:POWer -60"
290     ! Set AWGN Power to -60 dBM/3.84 MHz
300     !
310     !HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) is set by the measurement to -3 dB
320     !
330         OUTPUT Testset;"CALL:CONNected:HSSCchannel -10"
340     ! Set SDPA Cell 1 Connected HS-SCCH 1 Level to -10 dB
350     !
360         OUTPUT Testset;"CALL:HSDPa:UPLink:CQI:FCYCle 2 MS"
370     ! Set CQI Feedback Cycle (k) to 2 ms
380         OUTPUT Testset;"CALL:HSDPa:UPLink:CQI:RFACtor 1"
390     ! Set CQI Repetition Factor to 1
400         OUTPUT Testset;"CALL:HSDPa:SERVice:RBTest:UDEFined:ITTI 3"
410     ! Set User Defined Inter-TTI Interval to 3
420     !
430 !***Settings per 34.121 table E.5.1***
440 !
450         OUTPUT Testset;"CALL:CONNected:CPIChannel:HSDPa -10"
460     ! Set HSDPA Cell 1 Connected CPICH Level to -10 dB
470         OUTPUT Testset;"CALL:CONNected:CCPChannel:PRIMary:HSDPa -12"
480     ! Set HSDPA Cell 1 Connected P-CCPCH/SCH Level to -12 dB
490         OUTPUT Testset;"CALL:CONNected:PICHannel:HSDPa -15"
500     ! Set HSDPA Cell 1 Connected PICH Level to -15
510         OUTPUT Testset;"CALL:CONNected:HSSCchannel2 -15"
520     ! Set HSDPA Cell 1 Connected HS-SCCH 2 Level to OFF (-15dB)
530         OUTPUT Testset;"CALL:CONNected:HSSCchannel3 -15"
540     ! Set HSDPA Cell 1 Connected HS-SCCH 3 Level to OFF (-15dB)
550         OUTPUT Testset;"CALL:CONNected:HSSCchannel4 -15"
560     ! Set HSDPA Cell 1 Connected HS-SCCH 4 Level to OFF (-15dB)
570     !
580 !***Settings per 25.214 section 6A.2***
590 !
600         OUTPUT Testset;"CALL:HSDPa:MPOWer 7"
610     !Set the Measurement Power Offset to dB
620     !
630     !
640 !***Settings per 25.214 tables 7A,7B,7E***
650 !
660     ! User Defined Number of Active HS-PDSCHs is set by the measurement to 5
670 !
680     ! User Defined Transport Block Size Index is set by the measurement to 8.
690     !
700     ! User Defined Modulation Type is set by the measurement to 16QAM
710            !
720         OUTPUT Testset;"CALL:HSDPa:MACHs:RVSequence `0'"
730     !Set RV Sequence to 0
740         OUTPUT Testset;"CALL:HSDPa:SERVice:RBTest:UDEFined:MS:IREDundancy:BUFFer:ALLocation EXPLicit"
750     ! Set User Defined UE IR Buffer Allocation to Explicit
760         OUTPUT Testset;"CALL:HSDPa:SERVice:RBTest:UDEFined:MS:IREDundancy:BUFFer:SIZE 19200"
770     ! Set User Defined Explicit UE IR Buffer Size to 19200 bits
780         OUTPUT Testset;"CALL:OPERating:MODE CALL"
790     ! Set Operating Mode to CALL
800  !
810     !***Set up measurement parameters***
820     !
830         OUTPUT Testset;"SETup:HRCQuality:VARiance:CQIValue:INITial 16"
840     ! Set Starting Downlink TF CQI to 16
850         OUTPUT Testset;"SETup:HRCQuality:VARiance:CQIReports 2000"
860     ! Set Number of CQI Reports to test to 2000
870         OUTPUT Testset;"SETup:HRCQuality:VARiance:CQIValue:WRANge 90"
880     ! Set Percentage of CQI values within range to 90 %
890         OUTPUT Testset;"SETup:HRCQuality:SENSe:ANResponses:FILTered 1000"
900     ! Set Number filtered ACK/NACK responses to test to 1000
910         OUTPUT Testset;"SETup:HRCQuality:SENSe:BLERatio:FILTered:BASE:DECision 10"
920     ! Set Filtered BLER for initial CQI sense decision to 10%
930         OUTPUT Testset;"SETup:HRCQuality:SENSe:BLERatio:FILTered:CQIMinus1 10"
940     ! Set Filtered BLER for PASS/FAIL: Median_CQI-1 to 10%
950         OUTPUT Testset;"SETup:HRCQuality:SENSe:BLERatio:FILTered:CQIPlus2 10"
960     ! Set Filtered BLER for PASS/FAIL: Median_CQI+2 to 10%
970         OUTPUT Testset;"SETup:HRCQuality:TIMeout:STATe OFF"
980     ! Set Measurement Timeout to off
990 !
1000    !
1010      !
1020          CLEAR SCREEN
1030          PRINT "Establish an RB Test Mode - HSDPA connection "
1040          PRINT "by pressing Originate Call from the call setup screen"
1050          PRINT
1060          PRINT "Press CONTINUE when the Call Status shows `Connected'"
1070          PRINT
1080     !
1090          PAUSE
1100     !
1110     !***INITiate and FETCh measurements***
1120     !
1130          OUTPUT Testset;"INITiate:HRCQuality"
1140 !
1150     !
1160          OUTPUT Testset;"FETCh:HRCQuality?"
1170          ENTER Testset;Int,Pass_fail
1180           !
1190 !
1200     !***FETCh the CQI Variance results***
1210          !
1220          OUTPUT Testset;"FETCh:HRCQuality:VARiance:CQINdicator?"
1230          ENTER Testset;Tf_cqi
1240          OUTPUT Testset;"FETCh:HRCQuality:VARiance:CQIReports?"
1250          ENTER Testset;Num_reports
1260          OUTPUT Testset;"FETCh:HRCQuality:VARiance:CQINdicator:MEDian?"
1270          ENTER Testset;Med_cqi
1280          OUTPUT Testset;"FETCh:HRCQuality:VARiance:CQIReports:WRANge?"
1290          ENTER Testset;Cqi_in_range
1300          OUTPUT Testset;"FETCh:HRCQuality:VARiance:FAIL?"
1310          ENTER Testset;Cvar_pf
1320  !
1330           !*Fetch the CQI Variance Frequency Distribution*
1340         REAL Int,Cvar_dis(30)
1350         OUTPUT Testset;"FETCh:HRCQuality:VARiance:CQIReports:DISTribution?"
1360         ENTER Testset;Int,Cvar_dis(*)
1370 !
1380     !***FETCh the BLER vs. CQI Sense base results***
1390        !
1400         OUTPUT Testset;"FETCh:HRCQuality:SENSe:BASE:CQINdicator?"
1410         ENTER Testset;Base_tf_cqi
1420         OUTPUT Testset;"FETCh:HRCQuality:SENSe:BASE:CQINdicator:MEDian?"
1430         ENTER Testset;Base_med_cqi
1440         OUTPUT Testset;"FETCh:HRCQuality:SENSe:BASE:SDTX?"
1450         ENTER Testset;Base_statdtxs
1460         OUTPUT Testset;"FETCh:HRCQuality:SENSe:BASE:ACKS:FILTered?"
1470         ENTER Testset;Base_filt_a
1480         OUTPUT Testset;"FETCh:HRCQuality:SENSe:BASE:NACKs:FILTered?"
1490         ENTER Testset;Base_filt_n
1500         OUTPUT Testset;"FETCh:HRCQuality:SENSe:BASE:ANResponses:FILTered?"
1510         ENTER Testset;Base_filt_an
1520         OUTPUT Testset;"FETCh:HRCQuality:SENSe:BASE:BLERatio:FILTered?"
1530         ENTER Testset;Base_bler
1540         !
1550       !
1560     !***FETCh the BLER vs. CQI Sense boundary detection results***
1570    !
1580         OUTPUT Testset;"FETCh:HRCQuality:SENSe:BDETection:DIRection?"
1590         ENTER Testset;Sense
1600         OUTPUT Testset;"FETCh:HRCQuality:SENSe:BDETection:CQINdicator?"
1610         ENTER Testset;Bdet_tf_cqi
1620         OUTPUT Testset;"FETCh:HRCQuality:SENSe:BDETection:CQINdicator:MEDian?"
1630         ENTER Testset;Bdet_med_cqi
1640         OUTPUT Testset;"FETCh:HRCQuality:SENSe:BDETection:SDTX?"
1650         ENTER Testset;Bdet_statdtxs
1660         OUTPUT Testset;"FETCh:HRCQuality:SENSe:BDETection:ACKS:FILTered?"
1670         ENTER Testset;Bdet_filt_a
1680         OUTPUT Testset;"FETCh:HRCQuality:SENSe:BDETection:NACKs:FILTered?"
1690         ENTER Testset;Bdet_filt_n
1700         OUTPUT Testset;"FETCh:HRCQuality:SENSe:BDETection:ANResponses:FILTered?"
1710         ENTER Testset;Bdet_filt_an
1720         OUTPUT Testset;"FETCh:HRCQuality:SENSe:BDETection:BLERatio:FILTered?"
1730         ENTER Testset;Bdet_bler
1740 !
1750     !
1760    !***Print measurement results***
1770    !
1780         PRINT "Reporting of Channel Quality Indicator Measurement Results:"
1790         PRINT
1800         !
1810         PRINT "Part 1:CQI Variance Results:"
1820         PRINT "----------------------------"
1830         PRINT "Downlink TF CQI: ",Tf_cqi
1840         PRINT "CQI Reports    : ",Num_reports
1850         PRINT "Median_CQI: ",Med_cqi
1860         PRINT "CQI in Range (%): ",Cqi_in_range
1870         PRINT "CQI Variance Pass(0)/Fail (1):",Cvar_pf
1880         PRINT
1890         PRINT "The frequency distribution of the CQI Reports"
1900         PRINT "gathered during the CQI Variance test is:"
1910         PRINT Cvar_dis(*)
1920         PRINT
1930         PRINT "Part 2:BLER versus CQI Sense:"
1940         PRINT "       Median_CQI                ";Sense
1950         PRINT "                             1=Median_CQI+2; 2=Median CQI-1"
1960         PRINT "--------------------------------------------"
1970         PRINT "Downlink TF CQI:     ",Base_tf_cqi;Bdet_tf_cqi
1980         PRINT "Median_CQI:          ",Base_med_cqi;Bdet_med_cqi
1990         PRINT "statDTXs:            ",Base_statdtxs;Bdet_statdtxs
2000         PRINT "Filtered ACKs:       ",Base_filt_a;Bdet_filt_a
2010         PRINT "Filtered NACKs:      ",Base_filt_n;Bdet_filt_n
2020         PRINT "Filtered ACKs_NACKs: ",Base_filt_an;Bdet_filt_an
2030         PRINT "BLER:                ",Base_bler;Bdet_bler
2040         PRINT
2050         PRINT "Integrity Indicator                     = ",Int
2060         PRINT "Overall Pass (0) / Fail (1)             = ",Pass_fail
2070         !
2080     !
2090         END
2100     !

A sample output from this programming example is shown below:

Related Topics

  • HSDPA Reporting of Channel Quality Indicator Measurement Description
  • HSDPA Reporting of Channel Quality Indicator Troubleshooting
  • Manual Operation: How Do I Make an HSDPA Reporting Channel Quality Indicator Measurement?
  • Amplitude Offset
  • Integrity Indicator
  • SETup:HRCQuality
  • INITiate
  • FETCh:HRCQuality


Programming an Inner Loop Power Measurement

Programming an Inner Loop Power Measurement

Last updated: January 16, 2009

This section provides an example of how to make inner loop power measurements via GPIB.

The basic procedure to test inner loop power is as follows:

  1. Establish an RB test mode connection between the UE and test set (see Step 4: Make a Connection ).
  2. Set up the measurement using the SETup:WILPower commands.
  3. INITiate the measurement using the INITiate command.
  4. FETCh the measurement results using the FETCh:WILPower commands (or use the READ:WILPower[:ALL]? command to both initiate and fetch the measurement as a sequential operation).

Programming Example

10 ! Inner Loop Power Programming Example
20 ! 3GPP TS 34.121 5.4.2 Inner Loop Power Control
30 ! in the Uplink
40 !
50 ! This programming example assumes that there is an
60 ! RB Test Mode connection between the test set and UE.
70 !
80       Testset=714
90 !
100 ! *** Set Up Test Parameters ***
110 !
120       OUTPUT Testset;"CALL:POWer -93"
130 ! Set Cell Power to -93 dBm
140 !
150 ! *** Set Up Measurement Parameters ***
160 !
170       OUTPUT Testset;"SETup:WILPower:NSLOts S45"
180 ! (For test segment A) set Number of Slots as desired
190       OUTPUT Testset;"SETup:WILPower:MAXimum:POWer:THReshold:TEST:CONTrol:AUTO ON"
200 ! (For test segments E-H) set Maximum Power Threshold for Test Control to Auto
210       OUTPUT Testset;"SETup:WILPower:MAXimum:OUTPut:POWer:TEST:TOLerance 0.7"
220 ! (For test segments E-H) set Maximum Output Power Test Tolerance to 0.70 dB
230       OUTPUT Testset;"SETup:WILPower:Minimum:POWer:THReshold:TEST:CONTrol:AUTO OFF"
240 ! (For test segments E-H) set Minimum Power Threshold for Test Control to Manual
250       OUTPUT Testset;"SETup:WILPower:Minimum:POWer:THReshold:TEST:MANual -49"
260 ! (For test segments E-H) set Minimum Power Threshold for Test Manual to -49 dBm
270 !
280       CLEAR SCREEN
290 !
300       FOR I=1 TO 7
310           SELECT I
320           CASE 1
330               Test_segment$="A"
340           CASE 2
350               Test_segment$="B"
360           CASE 3
370               Test_segment$="C"
380           CASE 4
390               Test_segment$="E"
400           CASE 5
410               Test_segment$="F"
420           CASE 6
430               Test_segment$="G"
440           CASE 7
450               Test_segment$="H"
460           END SELECT
470 !
480           OUTPUT Testset;"SETup:WILPower:SEGment ";Test_segment$
490 ! Set Test Segment
500 !
510 ! *** INITiate and FETCh Measurements ***
520 !
530           OUTPUT Testset;"INITiate:WILPower"
540 ! Initiate an Inner Loop Power measurement.
550           OUTPUT Testset;"FETCh:WILPower:NSLOts?"
560 ! Fetch number of slots measured
570           ENTER Testset;Numslots
580           OUTPUT Testset;"FETCh:WILPower?"
590 ! Fetch Inner Loop Power measurement results.
600           ENTER Testset;Integrity,Pass_fail
610 ! Retrieve the results.
620 !
630 ! *** Print Measurement Results ***
640 !
650           PRINT
660           PRINT "Test Segment ",Test_segment$
670           PRINT "Number of slots measured         = ",Numslots
680           PRINT "Integrity Indicator (0 = Normal) = ",Integrity
690           PRINT "Pass/Fail (0 = Pass, 1 = Fail)   = ",Pass_fail
700       NEXT I
710 !
720       END

A sample output from this programming example is shown below:

Related Topics

  • Inner Loop Power Troubleshooting
  • Inner Loop Power Measurement Description
  • Manual Operation: How Do I Make an Inner Loop Power Measurement?
  • SETup:WILPower
  • INITiate
  • FETCh:WILPower
  • Amplitude Offset
  • Integrity Indicator


Invalid Measurement Results

Invalid Measurement Results

Last updated: January 16, 2009

Description

Invalid measurement results are returned by the test set when conditions such as signal level are not within the present measurement range. Three different invalid measurement results are provided in order to help you understand the condition that caused the invalid result.

  • 9.9E+37 = INFinity (Infinity)
  • -9.9E+37 = NINF (Negative Infinity)
  • 9.91E+37 = NAN (Not A Number)

9.9E+37 (INFinity)

9.9E+37 is returned by the test set when the measurement is out of range and results are far above the present measurement range.

-9.9E+37 (NINFinity)

-9.91E+37 is returned by the test set when the measurement is out of range and results are far below the present measurement range.

9.91E+37 (NAN)

9.91E+37 is returned by the test set when the measurement is out of range but it can not be determined if measurement results are far above, or far below the measurement range.

If a measurement exceeds its measurement timeout value before a valid result is determined, 9.91E+37 is returned.

FETCH? and READ? Invalid Results

When a FETCH? or READ? query is performed on a measurement with invalid results, the integrity indicator returns a value of 1, indicating No Result Available.

Manual Users Invalid Results

Manual users will generally see four dashes , "----" on the test set display. When the measurement timeout value has been exceeded, "Measurement Timeout" is displayed as well as the four dashes.


Programming an IQ Tuning Measurement

Programming an IQ Tuning Measurement

Last updated: January 16, 2009

This section provides an example of how to make IQ tuning measurements via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is transmitting an uplink signal.

The basic procedure to test IQ tuning is as follows:

  1. Set up the IQ tuning measurement parameters as desired using the SETup:WIQTuning commands.
  2. Use the INITiate:WIQTuning command to start the measurement.
  3. Use the FETCh:WIQTuning? query to obtain the measurement results.

Programming Example

10    RE-SAVE "c:\temp\programs\iqt_example"
20    CLEAR SCREEN
30    !Select which timeslot will be measured
40    OUTPUT 714;"SETup:WIQTuning:TSLot 14"
50    !Initiate the IQ tuning measurement
60    OUTPUT 714;"INITiate:WIQTuning"
70    !Query all IQ tuning measurement results.
80    OUTPUT 714;"FETCh:WIQTuning?"
90    !Read back all IQ tuning measurement results.
100   ENTER 714;Int,Rms_evm,Pk_evm,F_err,O_ofs,P_err,M_err,T_err,Pk_cd_err,Iq_gn_im,Iq_ph_im
110   PRINT "Integrity indicator = ";Int
120   PRINT "RMS error vector magnitude = ";Rms_evm
130   PRINT "Peak error vector magnitude = ";Pk_evm
140   PRINT "Frequency error = ";F_err
150   PRINT "Origin offset = ";O_ofs
160   PRINT "Phase error = ";P_err
170   PRINT "Magnitude error = ";M_err
180   PRINT "Timing error = ";T_err
190   PRINT "Peak code domain error = ";Pk_cd_err
200   PRINT "IQ gain imbalance = ";Iq_gn_im
210   PRINT "IQ phase imbalance = ";Iq_ph_im
220   END

Returned Values

See FETCh:WIQTuning .

Related Topics

  • IQ Tuning Measurement Troubleshooting
  • IQ Tuning Measurement Description
  • Manual Operation: How Do I Make an IQ Tuning Measurement?
  • SETup:WIQTuning
  • INITiate
  • FETCh:WIQTuning
  • Amplitude Offset
  • Integrity Indicator


Programming a Loopback Bit Error Ratio Measurement

Programming a Loopback Bit Error Ratio Measurement

Last updated: January 16, 2009

This section provides an example of how to make loopback bit error ratio (BER) measurements via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector.

The basic procedure to test loopback BER is as follows:

  1. Set Uplink DTCH RMC CRC Presence to Present (see CALL:SERVice:RBTest:DTCHannel:CRC[:PRESence] ).
  2. Set UE Loopback Type to Type 1 (see CALL:MS:LOOPback:TYPE ).
  3. Set the loopback BER setup parameters as desired using the SETup:WBERror commands.
  4. Prompt the user to establish an RB Test Mode connection.
  5. Set UE Target Power and Cell Power as needed.
  6. Use the INITiate:WBERror command to start the measurement (see INITiate ).
  7. Use the FETCh:WBERror ? query to obtain the measurement results (or use the READ:WBERror[:ALL]? command to both initiate the measurement and fetch key measurement results as a sequential operation).

Programming Example

10     ! Loopback Bit Error Ratio Measurement Programming Example
20     !
30       Testset=714
40     !
50     !***Set up test parameters***
60     !
70       OUTPUT Testset;"CALL:SERVice:RBTest:DTCHannel:CRC:PRESence PRESent"
80          ! Set Uplink DTCH RMC CRC Presence to Present.
90       OUTPUT Testset;"CALL:MS:LOOPback:TYPE TYPE1"
100         ! Set UE Loopback Type to Type 1.
110     !
120     !***Set up measurement parameters***
130     !
140       OUTPUT Testset;"SETup:WBERror:COUNt 10000"
150         ! Set Number of Bits to Test to 10000.
160       OUTPUT Testset;"SETup:WBERror:CONTinuous OFF"
170         ! Set Trigger Arm to Single.
180       OUTPUT Testset;"SETup:WBERror:CONFidence 99.80"
190         ! Turn Confidence State On and set Confidence Level to 99.80%.
200       OUTPUT Testset;"SETup:WBERror:REQuirement 0.10"
210         ! Set BER Requirement to 0.10%.
220       OUTPUT Testset;"SETup:WBERror:CONFidence:DUTFactor 1.5"
230         ! Set Bad DUT Factor to 1.5.
240     !
250     !***Establish a connection***
260       PRINT "Establish an RB Test Mode connection between the UE and test set."
270       PRINT "Press F2 to continue."
280       PAUSE
290     !
300     !***Set up test parameters***
310     !
320       OUTPUT Testset;"CALL:MS:POWer:TARGet 21"
330         ! Set UE Target Power to +21 dBm.
340       OUTPUT Testset;"CALL:POWer -106"
350         ! Set Cell Power to -106 dBm.
360     !
370     !***INITiate and FETCh measurements***
380     !
390       OUTPUT Testset;"INITiate:WBERror"
400         ! INITiate the measurement
410       OUTPUT Testset;"FETCh:WBERror?"
420       ENTER Testset;Integ,Ber,Error_count,Bits_tested
430       OUTPUT Testset;"FETCh:WBERror:RATio:FAIL?"
440       ENTER Testset;Conf_test
450         ! FETCh and READ Loopback BER measurement results
460     !
470     !***Print measurement results***
480     !
490       CLEAR SCREEN
500       PRINT "Loopback BER Measurement Results:"
510       PRINT
520       PRINT "Integrity Indicator                   = ",Integ
530       PRINT "Bit Error Ratio (%)                   = ",Ber
540       PRINT "Bit Error Count                       = ",Error_count
550       PRINT "Bits Tested                           = ",Bits_tested
560       PRINT "Confidence Test Result                = ",Conf_test
570       PRINT "(0=Pass, 1=Fail, 2=Max Bits Tested)"
580     !
590       END

Related Topics

  • Loopback Bit Error Ratio Troubleshooting
  • Loopback Bit Error Ratio (BER) Measurement Description
  • How Do I Make a Loopback Bit Error Ratio (BER) Measurement?
  • Amplitude Offset
  • Integrity Indicator


Measurement Progress Report

Measurement Progress Report

Last updated: January 16, 2009

Description

The measurement progress report is a query of how far along a multi-measurement cycle has progressed. When the multi-measurement count is greater than one, the measurement progress report will indicate the number of measurements that have completed. The returned value will be the last update and not the actual number, because the value is updated periodically and not for each multi-measurement cycle. Every measurement has the measurement progress report available.

Programming Example

OUTPUT 714;"FETCh:WACLeakage:ICOunt?" !Returns the approximate number of
    !Adjacent Leakage Ratio (ACLR) measurements completed while using
    !multi-measurements.

Related Topics

Statistical Measurement Results


Measurement Event Synchronization

Measurement Event Synchronization

Last updated: January 16, 2009

Description

Measurement event synchronization saves time by controlling the communication between the controller, the test set, and the mobile station, so that no device does something before it is supposed to (which can cause errors or do something well after it could have). Because some measurements can run concurrently, it is necessary that the control program know when individual measurement results are available.

Measurement event synchronization is accomplished using the INITiate subsystem's command INITiate:DONE? or the STATus:OPERation:NMRReady status registers.

INITiate:DONE?

The INITiate:DONE? query returns a string that indicates what, if any, measurements are ready to be fetched. This query should be used inside a loop, checking each measurement that was initiated. See INITiate for more details about this query.

The INITiate:DONE? query returns at least one of the following indicators for each pass through the loop:

  • "AFAN" - The audio frequency analyzer measurement results are available.
  • "SMON" - The spectrum monitor measurement results are available.
  • "WACL" - The adjacent channel leakage measurement results are available.
  • "WBER" - The loopback bit error ratio measurement results are available.
  • "WCD" - The code domain measurement results are available
  • "WCP" - The channel power measurement results are available.
  • "WILP" - The inner loop power measurement results are available.
  • "WIQT" - The IQ tuning measurement results are available.
  • "WOBW" - The occupied bandwidth measurement results are available.
  • "WOOP" - The PRACH transmit On/Off power measurement results are available.
  • "WSEM" - The spectrum emission mask measurement results are available.
  • "WTP" - The thermal power measurement results are available.
  • "WWQ" - The waveform quality measurement results are available
  • "WAIT" - There are one or more measurements which are in the measuring state which are not excluded from the query. See INITiate:DONE:FLAG:<measurement mnemonic> . When WAIT is returned at least one measurement is not ready to be fetched yet.
  • "NONE" - There are no measurements currently in the measuring state. This assumes no measurements have been excluded. See INITiate:DONE:FLAG:<measurement mnemonic> . This would indicate that all measurements results are available or none have been initiated.

Programming Example

The following example assumes that the UE is transmitting and no measurements other than channel power (WCP) and waveform quality (WWQ) are being triggered. See Transition Filters .

10  OUTPUT 714;"SETup:WCPower:CONTinuous OFF" !Sets channel power
20                                            !trigger mode to single.
30  OUTPUT 714;"SETUP:WWQuality:CONTinuous OFF" !Sets waveform quality
40                                       !trigger mode to single.
50  OUTPUT 714;"INITiate:WCPower;WWQuality" !Begin channel power and
60                                      !waveform quality measurements.
70  REPEAT
80    OUTPUT 714;"INITiate:DONE?" !Queries the test set for
90                                !measurements that have completed
100   ENTER 714;Meas_done$ !String value representing DONE measurements,
110                      ! NONE if no measurements are done.
120   SELECT Meas_done$ !This variable will have a value of  WAIT until
130                   !a measurement is DONE.
140   CASE "WCP" !Characters must be upper case.
150     OUTPUT 714;"FETCH:WCPower?" !If this case is selected,
160             !channel power results are FETCHed.
170     ENTER 714;Integrity,Wcpower_meas
180     PRINT "Average Channel Power is ";Wcpower_meas
190   CASE "WWQ" !Characters must be uppercase.
200     OUTPUT 714;"FETCH:WWQuality:EVM?" !If this case is selected,
210             !the Max EVM measurement is FETCHed.
220     ENTER 714;Evm_meas
230     PRINT "Maximum Error Vector Magnitude is ";Evm_meas
240   END SELECT
250 UNTIL Meas_done$="NONE"   !When all triggered measurements have completed,
260                           !the INITiate:DONE? query returns NONE.
270 END

STATus:OPERation:NMRReady:FDD

The STATus:OPERation:NMRReady:FDD command allows the program to immediately branch to the next operation or command without continuing through a loop as in INITiate:DONE? See STATus:OPERation:NMRReady:FDD Register Bit Assignments for more details about this command.

You must enable the following so that as soon as the enabled NMRReady bit is true the program moves on.

  • Positive or negative transition filter. See Transition Filters .
  • STATus:OPERation:NMRReady:FDD bit for the measurement desired.
  • STATus:OPERation:NMRReady bit (1024 for FDD) for the required system. See STATus Subsystem Description or Description .
  • STATus:OPERation bit (512 for NMRReady).
  • Service Request Enabling (*SRE 128 for NMRReady).

The STATus:OPERation:NMRReady:FDD Register Bit Assignments status register provides status reporting on the following measurement completions:

  • Adjacent Channel Leakage Ratio
  • Channel Power
  • Code Domain
  • Loopback Bit Error Ratio
  • Occupied Bandwidth
  • Spectrum Emission Mask
  • Thermal Power
  • Waveform Quality

Operating Considerations

Only one indicator is returned per query.

All active measurements must be set to single trigger mode. This ensures that when a measurement completes it remains in the "DONE" state rather than restarting. Sending the "*RST" command at the beginning of the test code or using the "SETup:CONTinous:OFF" command during measurement setups are ways to set the trigger to single for all measurements.

Related Topics

INITiate Command Functions


Control Program Example

Last updated: January 16, 2009

HP BASIC

For your convenience we have combined the programming examples shown in the Getting Started Guide into one program. This program, written using HP BASIC, is a fully functional W-CDMA control program. You can use this as a starting point for developing your own program. Click on the link below entitled "Getting Started Guide Control Program Example" to view this program. The other programming example uses FDD Test Mode in the test set and requires test mode control of the UE.

  • Getting Started Guide Control Program Example


Test System Synchronization

Test System Synchronization

Last updated: January 16, 2009

  • Measurement Event Synchronization


Obtaining Measurement Results

Obtaining Measurement Results

Last updated: January 16, 2009

  • Concurrent Measurements
  • Measurement Timeouts
  • Measurement Progress Report
  • Triggering of Measurements
  • Statistical Measurement Results
  • Integrity Indicator
  • Invalid Measurement Results
  • Dealing With Semicolon Separated Response Data Lists


Programming an Occupied Bandwidth Measurement

Programming an Occupied Bandwidth Measurement

Last updated: January 16, 2009

This section provides an example of how to make occupied bandwidth measurements via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is synchronized to the test set and is transmitting an uplink signal.

The basic procedure is as follows:

  1. Set the occupied bandwidth setup parameters as desired using the SETup:WOBWidth commands.
  2. Use the INITiate:WOBWidth command to start the measurement.
  3. Use the FETCh:WOBWidth? query to obtain the measurement results.

Programming Example

10    ! Set trigger mode to single for the Occupied Bandwidth meas
20    OUTPUT 714;"SETup:WOBWidth:CONTinuous OFF"
30    ! Set a timout value of 5 seconds and enable the timeout state
40    OUTPUT 714;"SETup:WOBWidth:TIMeout 5"
50    ! Set the trigger source to automatically select the appropriate
60    !  trigger
70    OUTPUT 714;"SETup:WOBWidth:TRIGger:SOURce AUTO"
80    ! Turn on multi-measurements and set the count number
90    OUTPUT 714;"SETup:WOBWidth:COUNt 5"
100   ! Initiate the Occupied Bandwidth measurement
110   OUTPUT 714;"INITiate:WOBWidth"
120   ! Fetch the integrity indicator and the statistical results of
130   !  the measurement
140   OUTPUT 714;"FETCh:WOBWidth:INTegrity?;BANDwidth:ALL?"
150   ENTER 714;Integrity,Min,Max,Avg,Sdev
160   ! Check the integrity indicator to ensure the results are valid
170   IF Integrity<>0 THEN
180     PRINT "Measurement failed."
190   ELSE
200   ! Process the measurement results.
210   END IF
220   END

Returned Values

  • Integrity stores the returned integrity indicator value (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Min returns the minimum occupied bandwidth result in MHz.
  • Max returns the maximum occupied bandwidth result in MHz.
  • Avg returns the average occupied bandwidth result in MHz.
  • Sdev returns the standard deviation of the occupied bandwidth results in MHz.

Related Topics

  • Occupied Bandwidth Troubleshooting
  • Occupied Bandwidth (OBW) Measurement Description
  • SETup:WOBWidth
  • INITiate
  • FETCh:WOBWidth
  • Amplitude Offset
  • Integrity Indicator


Programming a PRACH Transmit On/Off Power Measurement

Programming a PRACH Transmit On/Off Power Measurement

Last updated: January 16, 2009

This section provides an example of how to make PRACH transmit on/off power measurements via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector.

The basic procedure to test PRACH transmit on/off power is as follows:

  1. Set the PRACH transmit on/off power setup parameters as desired using the SETup:WOOPower commands.
  2. Use the INITiate :WOOPower commands to start the measurement.
  3. Use the FETCh:WOOPower query to obtain the measurement results.

Programming Example

10 ! PRACH Transmit On/Off Power Measurement Programming Example:
20 ! 5.4.1 Open Loop Power Control in the Uplink
30 !
40 ! This example assumes that the UE is camped to the test set, and in idle mode.
50 ! (The test set must first be configured to allow the UE to camp to the
60 ! test set - sufficient cell power level, proper cell parameters etc.)
70 !
80 ! Ensure that you have properly accounted for the path loss in your system
90 ! using the Amplitude Offset setting.
100 !
110       Testset=714
120 !
130 !***Set up test parameters***
140 !
150       OUTPUT Testset;"CALL:UPLink:PRAChannel:PREambles:NUMBer 4"
160 ! Set number of PRACH Preambles to 4
170       OUTPUT Testset;"CALL:UPLink:PRAChannel:PREambles:RCYCles 1"
180 ! Set number of PRACH Ramping Cycles to 1
190       OUTPUT Testset;"CALL:UPLink:PRAChannel:ASUBchannels `000000000001'"
200 ! Set Available Subchannels to 1
210       OUTPUT Testset;"CALL:UPLink:TXPower:LEVel:MAXimum 21"
220 ! Set Maximum Uplink Transmit Power Level to the max power for your UE
230       OUTPUT Testset;"CALL:CONNected:LIMit OFF"
240 ! Set Call Limit State to Off
250       OUTPUT Testset;"CALL:BCCHannel:UPDAtepage AUTO"
260 ! Set BCCH Update Page to Auto so the test set will notify the UE of
270 ! the changes to Cell Parameters.
280 !
290 !***"RX Upper dynamic end" test***
300 !***Set up test parameters for "RX Upper dynamic end" test***
310 !
320       OUTPUT Testset;"CALL:PCTPower 19"
330 ! Set Primary CPICH TX Power to 19 dBm
340       OUTPUT Testset;"CALL:UINTerferenc -75"
350 ! Set Uplink Interference to -75 dBm
360       OUTPUT Testset;"CALL:CVALue -10"
370 ! Set Constant Value to -10 dB
380       OUTPUT Testset;"CALL:POWer -25"
390 ! Set Cell Power to -25 dBm"
400 !
410 !***Set up measurement parameters***
420 !
430       OUTPUT Testset;"SETup:WOOPower:TIMeout 5"
440 ! Set timeout to 5 seconds
450       OUTPUT Testset;"SETup:WOOPower:OPEN:LOOP:POWer:UPPer:LIMit 9"
460 ! Set the Open Loop Power Error Upper Limit to 9 dB
470       OUTPUT Testset;"SETup:WOOPower:OPEN:LOOP:POWer:LOWer:LIMit -9"
480 ! Set the Open Loop Power Error Lower Limit to -9 dB
490 !
500 !***INITiate and FETCh measurements for "RX Upper dynamic end" test***
510 !
520       OUTPUT Testset;"INITiate:WOOPower"
530 ! Initiate a PRACH transmit on/off power measurement
540       OUTPUT Testset;"FETCh:WOOPower?"
550 ! Fetch PRACH transmit power measurement results
560       ENTER Testset;Integrity,Pre_off_pow,Pre_off_pf,On_pow,Ol_pow_err,Ol_pf,Post_off_pow,Post_off_pf
570 ! Read results
580 !
590 !***Print measurement results for "RX Upper dynamic end" test***
600 !
610       CLEAR SCREEN
620       PRINT "PRACH Transmit On/Off Power Measurement Results:"
630       PRINT
640       PRINT "RX Upper dynamic end --"
650       PRINT "Integrity Indicator (0 = normal)        = ",Integrity
660       PRINT "Expected UE Power                       =         -37.7 dBm"
670       PRINT "Measured UE Power (dBm)                 = ",On_pow
680       PRINT "Open Loop Power Error (dB)              = ",Ol_pow_err
690       PRINT "Open Loop Power Error Pass (0)/Fail (1) = ",Ol_pf
700 !
710 ! Before inititating the measurement again, ensure that the UE
720 ! has finished PRACHing from the prior measurement.
730 ! (Wait 250 ms, then query to see if the call status is idle.)
740       WAIT .25
750       LOOP
760           OUTPUT Testset;"CALL:STATus?"
770           ENTER Testset;Call_status$
780       EXIT IF Call_status$="IDLE"
790       END LOOP
800 !
810 !***"RX-middle" test***
820 !***Set up test parameters for "RX-middle" test***
830 !
840       OUTPUT Testset;"CALL:PCTPower 28"
850 ! Set Primary CPICH TX Power to 28 dBm
860       OUTPUT Testset;"CALL:UINTerferenc -101"
870 ! Set Uplink Interference to -101 dBm
880       OUTPUT Testset;"CALL:CVALue -10"
890 ! Set Constant Value to -10 dB
900       OUTPUT Testset;"CALL:POWer -65.7"
910 ! Set Cell Power to -65.7 dBm"
920 !
930 !***INITiate and FETCh measurements for "RX-middle" test***
940 !
950       OUTPUT Testset;"INITiate:WOOPower"
960 ! Initiate a PRACH transmit on/off power measurement
970       OUTPUT Testset;"FETCh:WOOPower?"
980 ! Fetch PRACH transmit power measurement results
990       ENTER Testset;Integrity,Pre_off_pow,Pre_off_pf,On_pow,Ol_pow_err,Ol_pf,Post_off_pow,Post_off_pf
1000 ! Read results
1010 !
1020 !***Print measurement results for "RX-middle" test***
1030 !
1040       PRINT
1050       PRINT "RX-middle --"
1060       PRINT "Integrity Indicator (0 = normal)        = ",Integrity
1070       PRINT "Expected UE Power                       =         -14 dBm"
1080       PRINT "Measured UE Power (dBm)                 = ",On_pow
1090       PRINT "Open Loop Power Error (dB)              = ",Ol_pow_err
1100       PRINT "Open Loop Power Error Pass (0)/Fail (1) = ",Ol_pf
1110 !
1120 ! Before inititating the measurement again, ensure that the UE
1130 ! has finished PRACHing from the prior measurement.
1140 ! (Wait 250 ms, then query to see if the call status is idle.)
1150       WAIT .25
1160       LOOP
1170           OUTPUT Testset;"CALL:STATus?"
1180           ENTER Testset;Call_status$
1190       EXIT IF Call_status$="IDLE"
1200       END LOOP
1210 !
1220 !***"RX-Sensitivity" test***
1230 !***Set up test parameters for "RX-Sensitivity" test***
1240 !
1250       OUTPUT Testset;"CALL:PCTPower 19"
1260 ! Set Primary CPICH TX Power to 19 dBm
1270       OUTPUT Testset;"CALL:UINTerferenc -110"
1280 ! Set Uplink Interference to -110 dBm
1290       OUTPUT Testset;"CALL:CVALue -10"
1300 ! Set Constant Value to -10 dB
1310       OUTPUT Testset;"CALL:POWer -106.7"
1320 ! Set Cell Power to -106.7 dBm"
1330 !
1340 !***INITiate and FETCh measurements for "RX-Sensitivity" test***
1350 !
1360       OUTPUT Testset;"INITiate:WOOPower"
1370 ! Initiate a PRACH transmit on/off power measurement
1380       OUTPUT Testset;"FETCh:WOOPower?"
1390 ! Fetch PRACH transmit power measurement results
1400       ENTER Testset;Integrity,Pre_off_pow,Pre_off_pf,On_pow,Ol_pow_err,Ol_pf,Post_off_pow,Post_off_pf
1410 ! Read results
1420 !
1430 !***Print measurement results for "RX-Sensitivity" test***
1440 !
1450       PRINT
1460       PRINT "RX-Sensitivity --"
1470       PRINT "Integrity Indicator (0 = normal)        = ",Integrity
1480       PRINT "Expected UE Power                       =          9 dBm"
1490       PRINT "Measured UE Power (dBm)                 = ",On_pow
1500       PRINT "Open Loop Power Error (dB)              = ",Ol_pow_err
1510       PRINT "Open Loop Power Error Pass (0)/Fail (1) = ",Ol_pf
1520       PRINT
1530 !
1540       END

Related Topics

  • PRACH Transmit On/Off Power Troubleshooting
  • PRACH Transmit On/Off Power Measurement Description
  • SETup:WOOPower
  • INITiate
  • FETCh:WOOPower
  • Amplitude Offset
  • Integrity Indicator


Programming a Swept Audio Measurement

Programming a Swept Audio Measurement

January 16, 2009

This section provides an example of how to make swept audio measurements via the GPIB.

The following example assumes that some device under test is connected between the test set's AUDIO OUT and AUDIO IN ports. The default audio level measurement, and the optional SINAD and distortion measurements, are performed at each frequency point in the sweep.

  1. Configure the swept audio measurement using the SETup subsystem.
  2. Start the measurement using the INITiate subsystem.
  3. Use the FETCh subsystem to obtain the audio analyzer's results for all points in the sweep.

Programming Example

10    OUTPUT 714;"SETup:SAUDio:FREQuency:STARt 300 Hz" !Start the frequency
20                                         !sweep at 300 Hz.
30    OUTPUT 714;"SETup:SAUDio:FREQuency:STOP 4 kHz" !Stop the frequency
40                                         !sweep at 4 kHz.
50    OUTPUT 714;"SETup:SAUDio:FREQuency:POINts 5"  !Make measurements at 5 frequencies
60                       !spaced evenly between the start and stop frequencies.
70    OUTPUT 714;"SETup:SAUDio:SETTling 1.5 ms" !Set a settling time of
80                                          !1.5 milliseconds.
90    OUTPUT 714;"SETup:SAUDio:VOLTage:AMPLitude 1 V" !SET the audio generator
100                                         !voltage to 1 volt peak.
110   OUTPUT 714;"SETup:SAUDio:DETector PEAK" !Select the peak detector for
120                                         !the audio analyzer.
130   OUTPUT 714;"SETup:SAUDio:FILTer TBPass" !Select the AF analyzer's 100 Hz bandwidth
140    !band pass filter for making the measurements. The center frequency for the filter
150                                !automatically tracks the AF generator's frequency.
160   OUTPUT 714;"SETup:SAUDio:PEAK:VOLTage 1 V" !Set the expected peak voltage
170                                         !at the AUDIO IN port.
180   OUTPUT 714;"SETup:SAUDio:SDIStortion:STATe ON" !Turn on the SINAD
190                                         !and distortion measurements.
200   OUTPUT 714;"SETup:SAUDio:CONTinuous OFF" !Set the swept audio
210                                         !measurement to single trigger mode.
220   OUTPUT 714;"SETup:SAUDio:TIMeout 5 S" !Set a measurement timeout of
230                                      !5 seconds in case the measurement cannot be made.
240   OUTPUT 714;"INITiate:SAUDio"          !Start the swept audio measurements.
250   OUTPUT 714;"FETCh:SAUDio?"            !Query the audio level and distortion results.
260   ENTER 714;Integrity,Lev1,Dist1,Lev2,Dist2,Lev3,Dist3,Lev4,Dist4,Lev5,Dist5 !Enter the
270                        !returned integrity value, and the level and distortion values
280                        !for each of the five measurement points, into variables.
290   OUTPUT 714;"FETCh:SAUDio:SINAD?"       !Query the SINAD results.
300   ENTER 714;Sinad1,Sinad2,Sinad3,Sinad4,Sinad5 !Enter the 5 returned SINAD values
310                                          !into variables.
320   END

Returned Values

The results returned by this program are:

  • Integrity returns the measurement integrity indicator (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Lev1 through Lev5 return the audio level (voltage) at each of the five measurement points. In this example, the value is returned in volts peak because the peak detector was specified.
  • Dist1 through Dist5 return the distortion value at each of the five measurement points.
  • Sinad1 through Sinad5 return the SINAD value at each of the five measurement points.

The example program uses the single FETCh:SAUDio[:ALL]? query to return the integrity value, the audio level (voltage) values, and the distortion values, at one time. These values can also be queried separately if required. The SINAD value is always queried separately.

Related Topics

Swept Audio Measurement Description

Swept Audio Measurement Troubleshooting

INITiate

SETup:SAUDio

FETCh:SAUDio


Programming a SINAD Measurement

Programming a SINAD Measurement

Last updated: January 16, 2009

This section provides an example of how to make SINAD measurement via GPIB. SINAD measurements are not typically made when testing W-CDMA mobiles but, are more common when testing AMPS or other analog mobiles. The programming example below is typical for an AMPS mobile.

SINAD and Distortion measurements are affected by the same STATe and INITiate commands, so both measurements are enabled and triggered at the same time. However, measurement results are queried separately. See Audio Analyzer Measurement Description .

The following procedure assumes that the mobile's audio output is connected to the AUDIO IN connectors and the mobile is on an analog voice channel (AVC) that is being modulated with a 1004 Hz tone at +/-8 kHz peak deviation. It is also assumed that the Cell Power from the test set is set to a minimum usable level (typically about -116 dBm).

  1. Configure audio analyzer measurement parameters using the SETup subsystem.
  2. Start the audio analyzer measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain audio analyzer measurement results.

Programming Example

10  OUTPUT 714;"SETup:AFANalyzer:CONTinuous OFF" !Set the audio analyzer
20                                           !measurements to single trigger mode.
30  OUTPUT 714;"SETup:AFANalyzer:PEAK:VOLTage 3V" !Set the Expected Amplitude level for
40                                                !audio input voltage in Vpeak.
50  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:STATe ON" !Turn on the SINAD and
60                                                  !distortion measurements.
70  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:FREQuency 1004 HZ" !Specify the audio
80                                      !frequency to use for the measurements.
90  OUTPUT 714;"SETup:AFANalyzer:FILTer CMESsage" !Select the c-message filter.
100 OUTPUT 714;"SETup:AFANalyzer:DEMPhasis:STATe OFF" !Turn off de-emphasis.
110 OUTPUT 714;"SETup:AFANalyzer:EXPandor:STATe OFF" !Turn off the expandor.
120 OUTPUT 714;"SETup:AFANalyzer:TIMeout 3S" !Set a timeout value of 3 seconds
130                                      !in case the measurement cannot be made.
140 OUTPUT 714;"INITiate:AFANalyzer" !Start the AF Analyzer measurement.
150 OUTPUT 714;"FETCh:AFANalyzer:INTegrity?" !Query the integrity indicator to
160                           !verify that a reliable measurement was made.
170 ENTER 714;Integrity  !Enter the returned value into a variable for comparison
180                      !with possible integrity indicator values (not shown here).
190 IF Integrity=0 THEN !Only fetch measurement result if integrity indicator is 0.
200 OUTPUT 714;"FETCh:AFANalyzer:SINAD?" !Fetch the SINAD result.
210 ENTER 714;Sinad  !Enter the returned value into a variable.
220 END IF
230 END

Returned Values

The results returned by this program are:

  • Integrity returns the integrity indicator (0 means a successful measurement with no errors). See Integrity Indicator .
  • SINAD returns the SINAD value in dB.

Related Topics

Audio Analyzer Measurement Description

AFANalyzer Troubleshooting

INITiate

SETup:AFANalyzer

FETCh:AFANalyzer

Control Program Example


Programming the Spectrum Monitor

Programming the Spectrum Monitor

Last updated: January 16, 2009

This section provides an example of how to use the Spectrum Monitor via the GPIB.

The following procedure assumes that the mobile station's antenna output is connected to the RF IN/OUT connector, and that the mobile station is transmitting a forward channel signal.

  1. Configure the Spectrum Monitor parameters using the SETup subsystem.
  2. Start the Spectrum Monitor using the INITiate subsystem.
  3. Use the INITiate:DONE? command to determine if Spectrum Monitor results are available.
  4. Use the FETCh? commands to obtain Spectrum Monitor results.
  5. Use the CALCulate commands to set and query the Spectrum Monitor markers.

Programming Example

10       REAL Amplitudes(400)       ! Set up array to hold 401 amplitude results (trace data)
20       OUTPUT 714;"SETUP:SMONITOR:CONTINUOUS OFF"!Configures the Spectrum Monitor to
30                                                !single trigger mode.
40       OUTPUT 714;"SETUP:SMONITOR:COUNT:NUMBER 20"!Configures a multi-measurement
50                                                  !of 20.
60       OUTPUT 714;"SETUP:SMONITOR:TRIGGER:SOURCE IMMEDIATE"!Configure trigger source
70                                                     !to immediate.
80       OUTPUT 714;"SETUP:SMONITOR:FREQUENCY:SPAN 20 MHz"!Set frequency span
90       OUTPUT 714;"SETUP:SMONITOR:BWIDth:MANUAL 300 KHZ" !Decouples the frequency span
100                           ! and the resolution bandwidth, and sets the resolution bandwidth.
110       OUTPUT 714;"INITIATE:SMONITOR"!Start the Spectrum Monitor
120     !
130       OUTPUT 714;"FETCH:SMONITOR:INTEGRITY?"!Fetch SMON Integrity
140       ENTER 714;Integrity
150       PRINT "Spectrum Monitor Integrity: ";Integrity
160       IF Integrity=0 THEN                  !Fetch results if SMON
170           OUTPUT 714;"FETCH:SMONITOR:TRACE?"!has valid integrity.
180           ENTER 714;Integrity,Amplitudes(*)!Load valid results into array
190           PRINT "Trace Data Amplitude Results (dB):"
200           PRINT "--------------------------------------------------"
210           PRINT Amplitudes(*) !Prints the 401 stored data points.
220           PRINT "--------------------------------------------------"
230       ELSE
240           PRINT "Bad Integrity value =";Integrity
250           STOP
260       END IF
270     ! Move the marker to the signal peak and query the frequency and level
280       OUTPUT 714;"CALCULATE:SMONITOR:MARKER1:PEAK:MAXIMUM"
290       OUTPUT 714;"CALCULATE:SMONITOR:MARKER1:FREQUENCY?"
300       ENTER 714;Peak_frequency
310       PRINT "Maximum Peak Frequency (MHz): ";Peak_frequency
320       OUTPUT 714;"CALCULATE:SMONITOR:MARKER1:AMPLITUDE?"
330       ENTER 714;Peak_amplitude
340       PRINT "Maximum Peak Amplitude (dBm): ";Peak_amplitude
350       END

Returned Values

The results returned by this program are:

  • Integrity returns the Spectrum Monitor Integrity Indicator (0 means that the Spectrum Monitor completed with no errors).
  • Amplitudes() returns 401 points representing the amplitude results (in dBm) of the trace data.
  • Peak_frequency returns the frequency in MHz at marker 1. In this case, marker 1 is positioned at the highest peak value.
  • Peak_amplitude returns the amplitude in dBm at marker 1. In this case, marker 1 is positioned at the highest peak value.

Related Topics

Spectrum Monitor Description

SETup:SMONitor

INITiate

FETCh:SMONitor

CALCulate:SMONitor


Programming a Spectrum Emission Mask Measurement

Programming a Spectrum Emission Mask Measurement

Last updated: January 16, 2009

This section provides an example of how to make a spectrum emission mask measurement via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is transmitting an uplink signal.

The basic procedure is as follows:

  1. Set the spectrum emission mask setup parameters as desired using the SETup:WSEMask commands.
  2. Use the INITiate:WSEMask command to start the measurement.
  3. Use the FETCh:WSEMask? query to obtain the measurement results.

Programming Example

10    ! Set trigger mode to single for the Spectrum Emission Mask meas.
20    OUTPUT 714;"SETup:WSEMask:CONTiuous OFF"
30    ! Set the multi-measurement count to 10
40    OUTPUT 714;"SETup:WSEMask:COUNt 10"
50    ! Set a timout value of 5 seconds and enable the timeout state
60    OUTPUT 714;"SETup:WSEMask:TIMeout 5"
70    ! Set the trigger source to automatically select the appropriate
80    !  trigger
90    OUTPUT 714;"SETup:WSEMask:TRIGger:SOURce AUTO"
100   ! Initiate the Spectrum Emission Mask measurement
110   OUTPUT 714;"INITiate:WSEMask"
120   ! Fetch the integrity indicator and the results of the measurement
130   OUTPUT 714;"FETCh:WSEMask?"
140   ENTER 714;Integrity,Wsemask,Chan_power,R1,R2,R3,R4
150   ! Check the integrity indicator to ensure the results are valid
160   IF Integrity<>0 THEN
170     PRINT "Measurement failed."
180   ELSE
190   ! Process the measurement results.
200   END IF
210   END

Returned Values

  • Integrity stores the returned integrity indicator value (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Because multi-measurements are being used, R1, R2, R3, and R4 indicate a mask pass or fail for each frequency range based on the average of the power levels associated with the largest mask error for each measurement. Mask pass or fail for each frequency range is determined from the average of the measurement results. The average of the relative power level results for the number of measurements specified is taken. This average is used to determine if that frequency range passed or failed the mask. If multi-measurements were not being used, the mask result would be based on a single measurement value for each frequency range.

Related Topics

  • Spectrum Emission Mask Troubleshooting
  • Spectrum Emission Mask Measurement Description
  • SETup:WSEMask
  • INITiate
  • FETCh:WSEMask
  • Amplitude Offset
  • Integrity Indicator


Statistical Measurement Results

Statistical Measurement Results

Last updated: January 16, 2009

Description

Most measurements have a setup window that provides for the entry of a multi-measurement count value. This specifies how many measurements the test set will perform to obtain a set of values from which to calculate the following statistical measurement results:

  • Average (arithmetic mean) of measurement set
  • Minimum value from measurement set
  • Maximum value from measurement set
  • Standard Deviation of measurement set

Operating Considerations

The advantages of using the multi-measurement feature to obtain statistical measurement data include: reduced time associated with GPIB bus traffic, and reduced time configuring hardware. This is because the number of measurements specified in the multi-measurement count value are performed during one measurement cycle.

Programming Example

OUTPUT 714;"SETUP:WACLeakage:COUNt 10" !Enters an Adjacent Channel
!Leakage Ratio (ACLR) count of 10, and turns the multi-measurement
!count state on.

Related Topics

Measurement Progress Report


Status Subsystem Overview

Status Subsystem Overview

Last updated: January 16, 2009

The following pages present an overview of the entire status subsystem, including applications which may or may not be loaded in your test set.

Description

Overview of STATus Reporting Structure

Status Reporting Structure For STATus QUEStionable Registers

Status Reporting Structure For STATus OPERation Registers

Status Reporting Structures for the COMMon Registers

Status Reporting Structure for the SMService Register

Status Reporting Structure for the GSM Registers

Status Reporting Structure For the GPRS Registers

Status Reporting Structure for the AMPS Registers

Status Reporting Structure for the DIGital136 Registers

Status Reporting Structures for the TA136 Registers

Status Reporting Structure for the DIGital95 Registers

Status Reporting Structure for the DIGital 2000 Registers

Status Reporting Structure for the CDMA Registers

Status Reporting Structure for the TA 2000 Registers

Status Reporting Structure for the FDD Registers

Status Reporting Structure for the WCDMA Registers

Status Reporting Structure For the TA856 Registers

Status Reporting Structure for the DIGital856 Registers

Status Data Structure - Register Model

The generalized status register model consists of a Condition Register, Transition Filters, an Event Register, an Enable Register, and a Summary Message Bit.

Condition Register

A condition is a test set state that is either TRUE or FALSE (a GPIB command error has occurred or a GPIB command error has not occurred). Each bit in a Condition Register is assigned to a particular test set state. A Condition Register continuously monitors the hardware and firmware states assigned to it. There is no latching or buffering of any bits in a Condition Register; it is updated in real time. Condition Registers are read-only. Condition Registers in the test set are 16 bits long and may contain unused bits. All unused bits return a zero value when read.

Transition Filters

In the test set, the Transition Filters are implemented as two registers: a 16-bit positive transition (PTR) register and a 16-bit negative transition (NTR) register.

For each bit in the Condition Register, a Transition Filter bit determines the state transitions which will set a corresponding bit in the Event Register. Transition Filters may be set to pass positive transitions (PTR), negative transitions (NTR) or either (PTR or NTR). A positive transition refers to a condition bit which has changed from 0 to 1. A negative transition refers to a condition bit which has changed from 1 to 0.

A positive transition of a bit in the Condition register will be latched in the Event Register if the corresponding bit in the positive transition filter is set to 1. A positive transition of a bit in the Condition register will not be latched in the Event Register if the corresponding bit in the positive transition filter is set to 0.

A negative transition of a bit in the Condition register will be latched in the Event Register if the corresponding bit in the negative transition filter is set to 1. A negative transition of a bit in the Condition register will not be latched in the Event Register if the corresponding bit in the negative transition filter is set to 0. Either transition (PTR or NTR) of a bit in the Condition Register will be latched in the Event Register if the corresponding bit in both transition filters is set to 1. No transitions (PTR or NTR) of a bit in the Condition Register will be latched in the Event Register if the corresponding bit in both transition filters is set to 0.

Transition Filters are read-write.

Transition Filters are unaffected by a *CLS (clear status) command.

Transitions Filters are set to pass positive transitions (all 16 bits of the PTR register are set to 1 and all 16 bits of the NTR register are set to 0) at power on or after receiving the *RST (reset) command.

Event Register

The Event Register captures bit-state transitions in the Condition Register as defined by the Transition Filters. Each bit in the Event Register corresponds to a bit in the Condition Register. Bits in the Event Register are latched, and, once set, they remain set until cleared by a query of the Event Register or a *CLS (clear status) command. This guarantees that the application can't miss a bit-state transition in the Condition Register. There is no buffering; so while an event bit is set, subsequent transitions in the Condition Register corresponding to that bit are ignored. Event Registers are read-only. Event Registers in the test set are 16 bits long and may contain unused bits. All unused bits return a zero value when read.

Event Enable Register

The Event Enable Register defines which bits in the Event Register will be used to generate the Summary Message. Each bit in the Enable Register has a corresponding bit in the Event Register. The test set logically ANDs corresponding bits in the Event and Enable registers and then performs an inclusive OR on all the resulting bits to generate the Summary Message. By using the enable bits the application program can direct the test set to set the Summary Message to the 1 or TRUE state for a single event or an inclusive OR of any group of events. Enable Registers are read-write. Enable Registers in the test set are 16 bits long and may contain unused bits which correspond to unused bits in the associated Event Register. All unused bits return a zero value when read and are ignored when written to. Enable Registers are unaffected by a *CLS (clear status) command or queries.

Standard Event Status Register Model

Summary Message Bit

The Summary Message is a single-bit message which indicates whether or not one or more of the enabled events have occurred since the last reading or clearing of the Event Register. The test set logically ANDs corresponding bits in the Event and Enable registers and then performs an inclusive OR on all the resulting bits to generate the Summary Message. By use of the enable bits, the application program can direct the test set to set the Summary Message to the 1, or TRUE, state for a single event or an inclusive OR of any group of events.

The Summary Message is TRUE, logic 1, if the register contains some information and an enabled event in the Event Register is set TRUE.

The Summary Message is FALSE, logic 0, if the queue is empty and no enabled events are TRUE. Registers can be cleared by reading all the information from the queue. Registers can also be cleared using the *CLS (clear status) command.

Service Request Enabling Register Model

Status Byte Register

The Status Byte Register is an 8 bit register that provides single bit summary messages, each summary message summarizes and overlaying status data structure. Summary messages always track the current status of the associated status data structure. Service request enabling determines if one or more of the summary messages will generate a message. Device status reporting is defined in IEEE 488.2-1992, 11.1.

The Status Byte Register contains the STB and RQS (or MSS) messages from the test set. The Status Byte Register can be read with either a serial poll or the *STB? common query. The value for bit 6 is dependent on which method used.

When reading with a serial poll the status byte and the RQS message are returned as a single data byte. The RQS message indicates if the SRQ is TRUE. The Status Byte Register is not affected by a serial poll, the RQS is set to FALSE when polled.

The *STB? query allows you to read the status byte and the MSS. The response represents the sum of the binary weighted values of the Status Byte Register from bit 0-5 and 7.

The Master Summary Status (MSS) message from bit 6 indicates when there is at least one reason for requesting service.

The Message Available (MAV) summary message from bit 4 is TRUE when there is a message is in the output queue.

The Status Byte Register is cleared with the *CLS common command. The output queue and the MAV are not affected by the *CLS command.

Service Request Enable Register

The Service Request Enable Register is an 8 bit register that enables corresponding summary messages in the Status Byte Register. Enabling the service request with the *SRE command allows you to choose which bits in the Status Byte Register will trigger a service request.

The Service Request Enable Register is read with the *SRE? query. The returned value is the sum of the binary weighted values of the Service Request Enable Register, with a range of 0 through 63 or 128 through 191.

The value of the unused bit 6 will always be zero.

System Synchronization Bit

Bit 12 of the status operation condition register is "pulsed" when the SYSTem:SYNChronized command is sent. This allows the status system to indicate that:

  • the input buffer is synchronized to the point where this command is parsed
  • all prior sequential commands are completed
  • all prior overlapped commands have started

Related Topics

STATus Subsystem Description


Call Processing Event Synchronization

Call Processing Event Synchronization

Last updated: January 16, 2009

Description

Using the call processing subsystem overlapped command synchronization commands, you can query the test set to find out when an overlapped command operation is done (:DONE?, :OPC?), force the test set to not execute any more commands until an overlapped command operation has completed (:WAIT), or simply force an overlapped command to behave as a sequential command (:SEQ).

Pending Operation Flags

Associated with each overlapped command, the test set maintains a binary indicator known as a pending operation flag. A pending operation flag is set true when the operation started by the overlapped command is executing, and is set false when the operation is no longer executing.

NOTE
In addition to the call processing subsystem overlapped commands, the test set also provides the measurement-related INITiate <measurement> overlapped commands.

Call Processing Subsystem Overlapped Command Synchronization Commands

Overlapped Commands
Command Purpose Of Command

Example

:DONE?

Returns a 0 if the associated command's pending operation flag is true, or a 1 if it is false.

10 OUTPUT 714;"CALL:TCH 65"
20 OUTPUT 714;"SETUP:TXP:CONT OFF"
30 OUTPUT 714;"SETUP:PFER:CONT OFF"
40 REPEAT
50 OUTPUT 714;"CALL:TCH:DONE?"
60 ENTER 714;Process_done
70 UNTIL Process_done
80 OUTPUT 714;INIT:TXP;PFER"
90 END

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and execute two setup commands. After the two setup commands have finished, the :DONE? command is used to find out if the handover is finished

:SEQuential

Forces an overlapped command to execute in a sequential manner. No subsequent commands will be executed until the pending operation flag for this operation is false.

OUTPUT 714;"CALL:TCH:SEQ 65"

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and to not execute any more commands until the pending operation flag associated with the CALL:TCH command is false.

:WAIT

Forces the test set to wait until the associated command's pending operation flag is false before executing any more commands.

10 OUTPUT 714;"CALL:TCH 65"
20 OUTPUT 714;"SETUP:TXP:CONT OFF"
30 OUTPUT 714;"SETUP:PFER:CONT OFF"
40 OUTPUT 714;"CALL:TCH:WAIT"
50 OUTPUT 714;"INIT:TXP;PFER"
60 END

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and execute two setup commands. After the two setup commands have finished, the :WAIT command is sent to prevent the test set from executing the INITiate command until the handover is finished.

:OPComplete?

Places a 1 in the test set's output queue when the associated command's pending operation flag goes false. Controlling program hangs on this query until the 1 is retrieved.

10 OUTPUT 714;"CALL:TCH 65"
20 OUTPUT 714;"SETUP:TXP:CONT OFF"
30 OUTPUT 714;"SETUP:PFER:CONT OFF"
40 OUTPUT 714;"CALL:TCH:OPC?"
50 ENTER 714;Op_complete
60 OUTPUT 714;"INIT:TXP;PFER"
70 END

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and execute two setup commands. After the two setup commands have finished, the :OPC? command is sent to hang program execution until a 1 is put in the test set's output queue, satisfying the ENTER statement and allowing program execution to continue with the INITiate command.

Operating Considerations

When using the call processing subsystem overlapped command synchronization commands, check the conditions that set the operation's pending operation flag (POF) false to avoid unexpected results.

Call Processing Subsystem Overlapped Commands

Overlapped Commands
Call Processing Command | Purpose Of Command | Pending Operation Flag (POF) is false when
CALL:ORIGinate See CALL:ORIGinate . | Performs a base station call origination. | The call processing state leaves the Idle state (when the operating mode is active cell), or The test set has noted this parameter change (when the operating mode is test mode).
CALL:CONNected:ARM[:IMMediate] See CALL:CONNected:ARM[:IMMediate] . | Arms the call control status change detector. | The call control status change detector has been disarmed. See Connected/Idle Query .

Related Topics

Call Processing State Synchronization


Call Processing State Synchronization

Call Processing State Synchronization

Last updated: January 16, 2009

Call Processing State Query

The CALL:STATus[:STATe][:VOICe]? query returns the current call processing state (see Call Connection State ).

For the lab application only, the CALL:STATus[:STATe]:DATA? query returns the current data connection state (see Data Connection State ).

Description

Connected/Idle Query

This query will determine if a call is connected or disconnected by returning an integer value. The value indicates if the call state is idle or connected, not if any call state change has occurred.

Query returns one of the following:

  • 0 = idle
  • 1 = connected

If the call is in the setup request, proceeding, alerting, or disconnecting state, this command will not return a value until the call status proceeds to either connected or idle.

OUTPUT 714;"CALL:CONNECTED:STATE?"

Base Station Originated Call - Using the Connected/Idle Query

The following example illustrates the use of the connected/idle query for a base station originated call. This code originates a call, then waits for the connected/idle query to return a result.

Note that this code does not include the CALL:CONNECTED:TIME (timeout timer) or the CALL:CONNECTED:ARM (change detector arm) commands. These commands are unnecessary since the change detector is armed automatically by the CALL:ORIGINATE command, and the timeout timer value is never applicable since a base station originated call guarantees a state change.

10    OUTPUT 714;"CALL:ORIGINATE" ! Begin the BS originated call.
20    OUTPUT 714;"CALL:CONNECTED:STATE?" ! The connect/idle query.
30    ENTER 714;Call_connected ! Program will hang here until state
40                             ! change or protocol timer expires.
50    !************************************************************
60    ! If mobile is not set to auto-answer, answer the call.
70    !************************************************************
80    IF NOT Call_connected THEN
90      DISP "CALL NOT CONNECTED."
100   ELSE
110     DISP "CALL IS CONNECTED."
120   END IF
130   END

Call State Change Detector

This feature provides a method for holding off the Connected/Idle Query results until a change in call processing states is detected. Arming the call state change detector is useful only for mobile station originated calls or disconnects only. It is armed automatically when call processing functions originating from the test set are requested.

The call state change detector becomes disarmed when any of the following conditions have been met:

  • the call processing state has changed to either connected or idle

    or...

  • the attempt to connect or disconnect a call has failed, and one of the test set's Fixed Timers has timed out

    or...

  • no call processing state changes occurred within the time period specified by the Call State Change Detector Timeout .

The following command arms the call state change detector:

OUTPUT 714;"CALL:CONNECTED:ARM[:IMMEDIATE]"

Mobile Station Originated Call - Arming the Change Detector

The following example illustrates the use of the call state change detector along with the connected/idle query to synchronize a controlling application with a call processing state change during a mobile station originated call.

When the CALL:CONNECTED:ARM command is received by the test set, the detector becomes armed and configures the test set to hold off on returning a result for the CALL:CONNECTED:STATE? query until the detector is disarmed by one of the three events described above.

10    OUTPUT 714;"CALL:CONNECTED:TIMEOUT 10S" ! Sets the time out
20                                            ! time to 10 seconds.
30    OUTPUT 714;"CALL:CONNECTED:ARM" ! Arm the change detector.
40    DISP "Make a mobile station orginated call. Continue when done."
50    PAUSE
60    OUTPUT 714;"CALL:CONNECTED:STATE?" ! The connected/idle query.
70    ENTER 714;Call_connected
80    IF Call_connected=1 THEN
90      DISP "Call is connected."
100     WAIT 2
110   ELSE
120     DISP "Call is not connected."
130     WAIT 2
140   END IF
150   END

Call State Change Detector Timeout

If a state change does not occur, the user needs a way to control how long to wait for the change detector. The change detector is disarmed by the timeout timer. After a timeout, the connected/idle query will return a 1 for connected or a 0 for idle. The timeout timer is user settable, but the user setting is only applied during mobile station originated call processing operations. For base station originated call processing operations, the timeout timer is automatically set to 60 seconds by the test set.

Related Topics

CALL:CONNected:TIMeout


Test System Synchronization Overview

Test System Synchronization Overview

Last updated: January 16, 2009

Description

Typical test systems include an external controller with a GPIB connection to the test set, an RF (and possible AF) connection between the test set and a mobile station under test, and a serial connection between the mobile station and the external controller.

Synchronizing an external controller with the test set and a mobile station under test ensures that no device does something before it is supposed to, which can cause errors, or does something well after it could have, which wastes time.

Test System

Sequential versus overlapped commands

The test set uses both sequential and overlapped commands:

  • Sequential commands must finish executing before the next command starts to execute.
  • Overlapped commands do not finish executing before the next command starts to execute.

Overlapped commands are more difficult to synchronize because an overlapped operation that started several commands earlier may still be executing as subsequent commands are being parsed out from the input buffer and executed. This can present a problem unless the external controller is properly synchronized to the test set's execution of commands. Overlapped commands allow the test set to use its internal resources as efficiently as possible.

Methods for synchronization

The test set's GPIB command set supports the following methods to achieve synchronization for overlapped commands. In some cases, combinations of these methods will provide the best results:

Methods one and two do not require the external controller to query the test set, nor to perform any branching or decision-making associated with information acquired from the test set.

Methods three through six rely on responses from the test set to an external controller, indicating that some event has occurred. The external controller can then make decisions based on these responses to control the flow of commands to the test set and other devices in the test system.

  1. Force the test set to execute overlapped commands sequentially.
  2. Force the test set to wait until an overlapped command is done executing before executing any more commands.
  3. Query the test set to determine when a command has finished executing.
  4. Query the test set to determine when all commands sent to it have at least begun executing.
  5. Query the test set to determine the current call or data connection processing state.
  6. Program the test set to generate a service request when an operation has completed or the test set is in a certain state.

Commands used for synchronization:

  • CALL:STATus
    This command queries the test set's current call processing state. This command supports synchronization method five. See Call Processing State Synchronization .

  • CALL:STATus
    This command determines the connected/idle state of a call. A feature called the change detector provides the user with a way to hold off the response to this query until a call processing state transition has taken place. See Connected/Idle Query . This command supports synchronization method five.

  • :DONE? and :OPC?
    These specialized commands can be appended to call processing overlapped commands to support synchronization method three. See Call Processing Subsystem Overlapped Command Synchronization Commands .

  • :WAIT
    This specialized command can be appended to call processing overlapped commands to support synchronization method two.
    See Call Processing Subsystem Overlapped Command Synchronization Commands .

  • :SEQ
    This specialized command can be appended to call processing overlapped commands to support synchronization method one.
    See Call Processing Subsystem Overlapped Command Synchronization Commands .

  • INITiate:DONE?
    This specialized command causes the test set to return a mnemonic indicating if a measurement is done. If not, the returned mnemonic will indicate if the measurement is still executing. This command supports synchronization method three.
    See INITiate:DONE? .

  • STATUS:<register>
    Status bits in the register are provided to indicate the test set's call processing state. These bits support synchronization methods five and six.
    Status bits in the STATus:OPERation:NMRReady Register Bit Assignments are provided to indicate when a measurement is ready to be fetched. These bits support synchronization method three and six.
    Many other status bits are provided in the GPIB status subsystem that are useful for synchronization. See STATus Subsystem Description .

  • SYSTem:SYNChronized
    This specialized command puts a 1 in the test set's output queue, the test set responds to the query by sending a 1 to the external controller indicating that all prior sequential commands have completed, and all prior overlapped commands have at least begun execution. The condition bit is set then cleared. See STATus:OPERation Register Bit Assignments . This command supports synchronization four and six.

  • *OPC and *OPC? , and *WAI (not recommended)
    Note: These commands look at all of the test set's operations collectively. Because multiple processes are likely to be executing at the same time, it is recommended that the other commands above be used instead.

Related Topics

Call Processing State Synchronization


Programming a Thermal Power Measurement

Programming a Thermal Power Measurement

Last updated: January 16, 2009

This section provides an example of how to make thermal power measurements via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is transmitting an uplink signal.

The basic procedure to test thermal power is as follows:

  1. Set the thermal power setup parameters as desired for triggering, measurement timeout, and multi-measurements using the SETup:WTPower commands.
  2. Use the INITiate:WTPower command to start the measurement.
  3. Use the FETCh:WTPower? query to obtain the measurement results.

Programming Example

10    OUTPUT 714;"SETup:WTPower:CONTinuous Off"!Set the thermal power
20                                     !measurement to single trigger mode.
30    OUTPUT 714;"SETup:WTPower:TIMeout 2S"!Set a timeout value of 2 secondS
40                  !and enable timeouts in case the measurement cannot be made.
50    OUTPUT 714;"SETup:WTPower:COUNt 5"!Set multi-measurements to 5 and
60                                     !enable multi-measurements.
70    OUTPUT 714;"INITiate:WTPower"!Start the measurement.
80    OUTPUT 714;"FETCh:WTPower?"!Query the returned integrity indicator and the
90                               !average thermal power measurement.
100   ENTER 714;Integrity,Wtpower!Enter the returned values into variables.
110   IF Integrity<>0 THEN !Integrity <> 0 indicates an  invalid measurement.
120     PRINT "Measurement problem; check for signal level over/under range condition."
130   ELSE
140   END IF
150   END

Returned Values

  • Integrity stores the returned integrity indicator value (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Because multi-measurements are being used in this example, Wtpower stores the returned average thermal power measurement value in dBm. If multi-measurements were not being used, the returned value would be a single thermal power measurement value.

Related Topics

  • Thermal Power Troubleshooting
  • Thermal Power Measurement Description
  • SETup:WTPower
  • INITiate
  • FETCh:WTPower
  • Amplitude Offset
  • Integrity Indicator


Triggering of Measurements

Triggering of Measurements

Last updated: January 16, 2009

Description

  • Trigger Source Description
  • Triggering Process Description
  • Trigger Arm (Single or Continuous) Description
  • Trigger Delay Description
  • Trigger Qualification Description

Trigger Source Description

A measurement trigger causes hardware (for example, a sampler) to capture data which is used by a measurement algorithm to produce a measurement result. Not all of the trigger source choices are available in every measurement, or every test application.

RF Rise Trigger Source:

When RF rise triggering is selected, a measurement dependent threshold is used to define the trigger point on the envelope of the signal being measured. The envelope amplitude must fall below this threshold and remain there for a measurement-dependent period of time before the trigger is armed. After the trigger is armed, a trigger will occur as the envelope amplitude increases and passes through the threshold.

Protocol Trigger Source:

When protocol triggering is selected, a data capture is triggered by a protocol generated signal. The test set's protocol engine knows when the DUT's signal should be present and generates a trigger signal for use by the measurement to trigger the data capture.

External Trigger Source:

When external triggering is selected, the user supplies an external trigger signal via the rear panel TRIG IN connector in order to trigger data capture. The trigger will occur on the rising edge of this signal.

Immediate Trigger Source:

When immediate triggering selected, the trigger occurs as soon as any pre-trigger samples required by the measurement algorithm are taken. Data capture is triggered when the measurement is initiated.

HS-DPCCH Trigger Source:

When Trigger Source is set to HS-DPCCH and HS-DPCCH Trigger Subframe Alignment is set to subframe 0 , the trigger occurs at the start of every uplink HARQ0 subframe for which the downlink HARQ0 subframe was aligned with the 10 ms system frame clock. For an FRC, the trigger thus occurs every 60 ms. The HS-DPCCH Trigger Subframe Alignment setting can be used to move the trigger (in subframe increments) relative to the uplink HARQ0 subframe.

Auto Trigger Source:

When auto triggering is selected, the test set automatically chooses the best trigger source for that measurement. This trigger source setting is convenient because the measurement trigger doesn't need to be changed when switching parameters. Auto trigger source is the best choice for most users.

Triggering Process Description

The triggering process controls the present and future states of the test set during the measurement cycle. Triggers are set up using the SETup commands and can be set up when a measurement is in the inactive state. A measurement is activated (selected) with an INITiate command. If a measurement is initiated while in its measurement cycle, it will terminate that measurement and restart it. The active state is not a single state but a collection of any state other than the inactive state. Deactivating (de-selecting) the measurement is accomplished through an INITiate:<MEAS>:OFF command.

Manually, a measurement is activated by selecting it from the Measurement Selection menu. A measurement is deactivated by pressing the Measurement Selection key, scrolling to measurement in the Measurement Selection menu, and then pressing F4 (Close Measurement) .

The Test Set's Measurement States

Measurement States

The following examples describe states of the test set under various conditions. Refer to The Test Set's Measurement States .

Inactive State

If the test set has just been powered on, or any form of preset has been performed, then the measurement state is inactive.

Wait for Trigger State

If a measurement has been initiated with the INITiate command but has not been triggered, or a measurement has been selected from the Measurement Selection menu but has not been triggered, then the measurement state is wait for trigger.

Measuring and Idle States (Trigger Arm Single)

If the trigger arm is set to single, the trigger source is available, and the trigger qualifier (optional) is satisfied, the measurement state transitions to measuring and measurement results are now available to the user. The state then transitions to idle (awaiting another INITiate).

Measuring State (Trigger Arm Continuous)

If the trigger arm is set to continuous, the trigger source is available, and the trigger qualifier (optional) is satisfied, the measurement state transitions to measuring and measurement results are now available to the user. The measurement is continually triggered until the measurement is deactivated. Measurement results are only available after the measurement completes and before it rearms. The measurement is deactivated using the INITiate:<MEAS>:OFF. or Close Measurement .

Trigger Arm (Single or Continuous) Description

Trigger arm determines if a measurement will make one measurement then return to idle (single), or automatically rearm on completion of a measurement and repeat the process (continuous).

NOTE
When operating the test set remotely, the recommended setting for the trigger arm parameter is single. This ensures proper operation of the INIT:DONE? query which is used to control the retrieval of measurement results when measurements are initiated concurrently.

When a continuously armed measurement gets a result, it is available to any currently pending (waiting, hanging) FETCh? query. Then another measurement cycle is started immediately. At this point the results are no longer valid. The INIT:DONE? query is used to determine when there is a completed measurement with valid results that can be fetched. If you look for a continuously armed measurement with valid results that can be fetched using INIT:DONE? then you are unlikely to get anything but WAIT. Each time the Test Set is queried, it is 99% likely to be making another measurement. Even if it did return a measurement name, by the time the control program determines which FETCh? query to send, it is too late to fetch the results and the FETCh? query just hangs until the next measurement cycle is done, nullifying the efficiency provided by the INIT:DONE? query.

Pressing the Start Single key on the front panel will cause all currently active measurements with trigger arm set to single to arm and make the measurement.

Pressing Shift, Start Single (Stop) causes all measurements with trigger arm set to single to abort the measurement.

It is unnecessary for you to arm a measurement if the trigger arm is set to continuous. When in continuous mode, the measurement is automatically rearmed after completing a measurement.

Trigger Arm Default Settings
Action | Trigger Arm Default Setting
Power up of test set | Continuous
Manual Full Preset | Continuous
*RST (Remote) Full Preset | Single
Partial Preset | No change

Trigger Delay Description

Trigger delay controls the delay time between the trigger and the start of sampling. Resolution is 1 nanosecond per measurement and the units are in seconds. A negative value indicates the sampling should occur prior to the trigger. The default is zero seconds which is preferred for most measurements.

Trigger Qualification Description

When Trigger Qualification is on, the test set samples the input signal when a trigger is received. It then determines if the input signal was valid by looking at its power level. If the power level during sampling did not meet the requirements of a valid signal, the state returns to wait for trigger without processing the samples. If a valid signal is present, then it is qualified, and the samples are processed.

Related Topics

Integrity Indicator


Programming a Block Error Ratio Measurement

Programming a Block Error Ratio Measurement

Last updated: January 16, 2009

  1. Set MS Loopback Type to Type 2 using the CALL:MS:LOOPback:TYPE command.
  2. Set Uplink DTCH RMC CRC Presence to Used for Data using the CALL:SERVice:RBTest:DTCHannel:CRC[:PRESence] command.
  3. Prompt the user to power the UE on and wait for it to camp to the test set, then continue the program.
  4. Set Paging Service to RB Test Mode using the CALL:PAGing:SERVice[:TYPE] command.
  5. Set Channel Type to 12.2k RMC using the CALL:SERVice:RBTest:RAB command.
  6. Originate a call using the CALL:ORIGinate[:AUTO] command.
  7. Set Cell Power as needed using the CALL[:CELL]:POWer[:SAMPLitude][:SELected] command.
  8. Set up the measurement using the SETup:WBLerror commands.
  9. INITiate the measurement using the INITiate command.
  10. FETCh the measurement results using the FETCh:WBLerror commands.

Related Topics

Block Error Ratio (BLER) Measurement Description


Programming a Change of TFC (Transport Format Combination) Measurement

Programming a Change of TFC (Transport Format Combination) Measurement

Last updated: January 16, 2009

This section is only applicable to the lab application.

This section provides an example of how to make change of TFC measurements via GPIB.

The basic procedure to perform change of TFC measurements is as follows:

  1. Ensure that Uplink Dummy DCCH Data is set to Off ( CALL:UPLink:DCCHannel:DDATa ).
  2. Establish an RB test mode connection between the UE and test set (see Step 4: Make a Connection ).
  3. Configure the change of TFC measurement parameters as desired using the SETup:WCTFormat commands.
  4. Use the INITiate :WCTFormat command to start the measurement.
  5. Use the FETCh:WCTFormat query to obtain the measurement results (or use the READ:WCTFormat[:ALL]? command to both initiate and fetch the measurement as a sequential operation).

Programming Example

10 ! Change of TFC Measurement Programming Example
20 ! This programming example assumes that Uplink Dummy DCCH Data is
30 ! set to Off, Uplink DPCH Bc/Bd Control is set to Auto, UL CL Power
40 ! Ctrl Algorithm is set to Two, and that there is an RB Test Mode
50 ! connection between the test set and UE.
60 !
70 Testset=714
80 !
90 ! *** Set Up Test Parameters ***
100 !
110 OUTPUT Testset;"CALL:MS:POWer:TARGet 0"
120 ! Set MS Target Power to 0 dBm.
130 OUTPUT Testset;"CALL:CLPControl:UPLink:MODE UDOWn"
140 ! Set UL CL Power Ctrl Mode to Alternating.
150 !
160 ! *** Set Up Measurement Parameters ***
170 !
180 OUTPUT Testset;"SETup:WCTFormat:COUNt 5"
190 ! Set Multi-Measurement Count to 5.
200 !
210 ! *** INITiate and FETCh Measurements ***
220 !
230 OUTPUT Testset;"INITiate:WCTFormat"
240 ! Initiate a Change of TFC measurement.
250 OUTPUT Testset;"FETCh:WCTFormat?"
260 ! Fetch Change of TFC measurement results.
270 ENTER Testset;Int,Down_pwr,Down_err,Down_pf,Up_pwr,Up_err,Up_pf
280 ! Retrieve the results.
290 !
300 ! *** Print Measurement Results ***
310 !
320 CLEAR SCREEN
330 PRINT "Change of TFC Measurement Results:"
340 PRINT
350 PRINT "Integrity Indicator                      = ",Int
360 PRINT "Step Down Relative Power (in dB)         = ",Down_pwr
370 PRINT "Step Down Error (in dB)                  = ",Down_err
380 PRINT "Step Down Pass/Fail (0 = pass, 1 = fail) = ",Down_pf
390 PRINT "Step Up Relative Power (in dB)           = ",Up_pwr
400 PRINT "Step Up Error (in dB)                    = ",Up_err
410 PRINT "Step Up Pass/Fail (0 = pass, 1 = fail)   = ",Up_pf
420 !
430 END

Related Topics

  • Change of TFC (Transport Format Combination) Troubleshooting
  • Change of TFC (Transport Format Combination) Measurement Description
  • Manual Operation: How Do I Make a Change of TFC (Transport Format Combination) Measurement?


Programming the Dynamic Power Analysis Measurement

Programming the Dynamic Power Analysis Measurement

Last updated: January 16, 2009

The following program example assumes that the UE is connected to the RF IN/OUT connector.

The basic procedure to perform a Dynamic Power Analysis measurement (for UE power calibration) is as follows:

  1. Set the test set's receiver to the proper power and frequency using the RFANalyzer:CONTrol:POWer:AUTO , RFANalyzer:MANual:POWer[:SELected] and RFANalyzer:MANual:MEASurement[:MFRequency] commands.
  2. Set the Dynamic Power Analysis setup parameters to match your UE's power sequence using the SETup:WDPAnalysis commands.
  3. Arm the measurement using the INITiate:<measurement mnemonic>[:ON] command.
  4. Prompt the user to place the UE into a test mode which will force it to continuously transmit the power sequence you desire to test.
  5. FETCh the measurement results using the FETCh:WDPAnalysis commands.

The example below assumes a power sequence as follows:

Programming Example

10 ! *** WDPAnalysis Programming Example ***
20 !
30 ! This programming example assumes the UE is connected to the test set
40 ! and prepared to send a power sequence that consists of a trigger pulse
50 ! that moves from -20 dBm to 0 dBm to -20 dBm, then steps in 1 dB
60 ! increments from -20 dBm to 0 dBm.  Each step is 1 timeslot in length.
70 ! The UE must continuously repeat this power sequence.
80 !
90       CLEAR SCREEN
100       DIM Wdpa_res$[3400]
110       DIM Wdpa_val(200)
120       Testset=714
130 !
140 ! *** Set up the test set ***
150 !
160       OUTPUT Testset;"RFANalyzer:MANual:MEASurement 1950 MHZ"
170         ! Sets Measurement Frequency to 1950 MHz
180       OUTPUT Testset;"RFANalyzer:CONTrol:POWer:AUTO OFF"
190         ! Sets Power Control to Manual
200       OUTPUT Testset;"RFANalyzer:MANual:POWer 0 DBM"
210         ! Sets Manual Power to 0 dBm
220 !
230 ! *** Set up measurement parameters ***
240 !
250       OUTPUT Testset;"SETup:WDPAnalysis:STEPs 23"
260         ! Sets Steps to 23
270       OUTPUT Testset;"SETup:WDPAnalysis:LENGth 666.7 US"
280         ! Sets Step Length to 666.7 us (1 timeslot)
290       OUTPUT Testset;"SETup:WDPAnalysis:INTerval 300 US"
300         ! Sets Measurement Interval to 300 us
310       OUTPUT Testset;"SETup:WDPAnalysis:TRIGger:THReshold -10 DBM"
320         ! Sets RF Rise Trigger Threshold to -10 dBm
330       OUTPUT Testset;"SETup:WDPAnalysis:RRCfilter ON"
340         ! Sets RRC Filter to On
350       OUTPUT Testset;"SETup:WDPAnalysis:FOFFset 0 HZ"
360         ! Sets Frequency Offset to 0 Hz
370       OUTPUT Testset;"SETup:WDPAnalysis:TRIGger:QUALify:STATe ON"
380         ! Sets Trigger Qualification State to On
390       OUTPUT Testset;"SETup:WDPAnalysis:TRIGger:QUALify:TYPE RISEFALL"
400         ! Sets Trigger Qualification Type to RF Rise and Fall
410       OUTPUT Testset;"SETup:WDPAnalysis:TRIGger:QUALify:RISE 10 DB"
420         ! Sets Trigger Qualification Rise Threshold to 10 dB
430       OUTPUT Testset;"SETup:WDPAnalysis:TRIGger:QUALify:FALL 10 DB"
440         ! Sets Trigger Qualification Fall Threshold to 10 dB
450       OUTPUT Testset;"SETup:WDPAnalysis:CONTinuous OFF"
460         ! Sets Trigger Arm to Single
470       OUTPUT Testset;"SETup:WDPAnalysis:TRIGger:SOURce RISE"
480         ! Sets Trigger Source to RF Rise
490       OUTPUT Testset;"SETup:WDPAnalysis:TRIGger:DELay 183.3 US"
500         ! Sets Trigger Delay to 183.3 us
510         ! (to place the Measurement Interval in the center of the timeslot)
520       OUTPUT Testset;"SETup:WDPAnalysis:TIMeout 10 S"
530         ! Sets Measurement Timeout to 10 s
540 !
550 ! *** Initiate the measurement ***
560 !
570       OUTPUT Testset;"INITiate:WDPAnalysis"
580       PRINT "Order UE to transmit its power sequence continuously"
590 !
600 ! *** Obtain measurement results ***
610 !
620       OUTPUT Testset;"FETCh:WDPAnalysis?"
630       ENTER Testset;Integrity,Numsteps,Wdpa_res$
640 !        ! FETChes the Integrity Indicator, number of power measurement
650 !        ! results available, and the power results
660 !
670 ! *** Print measurement results ***
680 !
690       PRINT
700       PRINT "Integrity Indicator = ";Integrity
710       PRINT "The number of power meas results available = ";Numsteps
720       PRINT
730       FOR I=1 TO Numsteps
740           Wdpa_mkr=((I-1)*17)
750             ! Sets up a marker that jumps to each comma in the ascii string
760           Wdpa_val(I)=VAL(Wdpa_res$[Wdpa_mkr+1;Wdpa_mkr+16])
770             ! Convert ascii to a numeric value
780           PRINT "Power of step";I;"= ";Wdpa_val(I);"dBm"
790       NEXT I
800 !
810       END

A sample output from this program example is shown below:

Related Topics

Dynamic Power Analysis Measurement Description


Programming an Extended Range Dynamic Power Measurement

Programming an Extended Range Dynamic Power Measurement

Last updated: January 16, 2009

This section provides an example of how to make an Extended Range Dynamic Power measurement via remote program.

The following program example assumes that the test set is in Active Cell Operating mode and the UE is connected to the RF IN/OUT connector.

The basic procedure to make the Extended Range Dynamic Power measurement is as follows:

  1. Set the test set's receiver to the proper power and frequency using the RFANalyzer:CONTrol:POWer:AUTO , RFANalyzer:MANual:POWer[:SELected] and RFANalyzer:MANual:MEASurement[:MFRequency] commands.
  2. Set the parameters (see Extended Range Dynamic Power Measurement Parameters for details) to match your UE's output power sequences and trigger source requirement using the SETup:WEDPower commands. In this example, an RF rise trigger is used.
  3. Place your UE into the test mode and verify that it is ready for measurement.
  4. Order your UE to transmit so that the first power step in the power sequences meets the requirements of the RF rise trigger. The trigger pulse should rise in power by at least 20 dB and above the RF Rise Trigger Threshold level. See Triggering the Extended Range Dynamic Power Measurement for details.
  5. Initiate (arm) the Extended Range Dynamic Power measurement using the INITiate:WEDPower command.
  6. Send the INITiate:WEDPower:ARMed? query and wait for it to return a value of 1, indicating that the measurement is armed and ready to be triggered
  7. Order your UE to begin transmission of its power sequences (two power sequences for measurement and 15 timeslots of constant power in the middle of the two power sequences for test set re-ranging. The test set does not make any measurement during the receiver re-ranging period).
  8. When the measurement completes, use the FETCh:WEDPower commands to obtain the measurement results for each step.

Programming Example

10 CLEAR SCREEN
20 OPTION BASE 0
30 Testset=718
40 !
50 ! *** Variable declarations for the measurements ***
60 DIM Edpow_res$[5000]
70 DIM Dynamic_val(200)
80 !
90 Fst_seq_steps=45      ! Number of steps in 1st sequence
100 Sec_seq_steps=40     ! Number of steps in 2nd sequence
110 Meas_freq=1000000000 ! Frequency = 1GHz
120 Man_pwr=13           ! Manual Power = 13 dBm
130 Sec_seq_exp_pwr=-32  ! Second sequence expected power = -32 dBm.
140 Trig_source$="Rise"  ! Trigger Source is RF Rise.
150 Trig_thresh=3        ! RF rise trigger threshold = 3dBm
160                       ! (10 dB below the manual power)
170 !
180 !***Set up measurement parameters***
190 !
200 OUTPUT Testset;"SETup:WEDPower:TIMeout 10"
210 ! Sets Measurement Timeout to 10 seconds
220 OUTPUT Testset;"RFANalyzer:MANual:MEASurement ";Meas_freq
230 ! Sets Measurement Frequency to 1 GHz (output from UE)
240 OUTPUT Testset;"RFANalyzer:CONTrol:POWer:AUTO OFF"
250 ! Sets Power Control to manual mode
260 OUTPUT Testset;"RFANalyzer:MANual:POWer ";Man_pwr
270 ! Sets the maximum expected power output from the UE. It is used by
280 ! test set to range its receiver for initial test. It is recommended
290 ! that you set it to the first step in the first power sequence of UE output.
300 OUTPUT Testset;"SETup:WEDPower:SSEQuence:EXPected:POWer ";Sec_seq_exp_pwr
310 ! Sets second sequence expected power. Test set requires re-ranging its
320 ! receiver based on this setting for the second sequence test.
330 !
340 OUTPUT Testset;"SETup:WEDPower:STEPs:FSEQuence ";Fst_seq_steps
350 ! Sets number of power steps in first sequence.
360 OUTPUT Testset;"SETup:WEDPower:STEPs:SSEQuence ";Sec_seq_steps
370 ! Sets number of power steps in second sequence.
380 !
390 OUTPUT Testset;"SETup:WEDPower:TRIGger:SOURce ";Trig_source$
400 ! Sets trigger source.
410 OUTPUT Testset;"SETup:WEDPower:TRIGger:THReshold ";Trig_thresh
420 ! Sets RF rise trigger threshold.
430 !
440               !
450 !***Initiate the measurement***
460 !
470 OUTPUT Testset;"INITiate:WEDPower"
480 ! Initiates the measurement
490 OUTPUT Testset;"INIT:WEDPower:ARMed?"
500 !Queries whether the measurement is ready for trigger.
510 ENTER Testset;Meas_arm
520 IF Meas_arm THEN
530   PRINT "Command the UE to trigger the measurement and begin its step down"
540   PRINT "power sequences (two power sequences for measurement and 15 timeslots"
550   PRINT "of constant power in the middle of the two power sequences"
560   PRINT "for test set re-ranging its receiver.  Test set does not make"
570   PRINT "any measurement during the receiver re-ranging period.)"
580   PRINT
590  LINPUT "Press ENTER when finished",Keyboard$
670  !***Obtain measurement results***
680  OUTPUT Testset;"FETCh:WEDPower?"
690  ENTER Testset;Integrity,Numpowmeas,Edpow_res$
700  ! Fetches the integrity indicator, the number of power
710  ! steps measured and power results for each step.
770 ELSE
780   PRINT "The test set is not properly armed. Please check the setups."
790   GOTO End_program
800 END IF
810 !
820 !***Print measurement results***
830 PRINT
840 PRINT "Integrity Indicator = ";Integrity
850 PRINT "The number of power meas results available = ";Numpowmeas
860 FOR I=1 TO Numpowmeas
870   Dynamic_mkr=((I-1)*17)
880   ! Sets up a marker that will jump to each comma in the ascii string
890   Dynamic_val(I)=VAL(Edpow_res$[Dynamic_mkr+1;Dynamic_mkr+16])
900   ! Convert ascii to a numeric value
910   PRINT
920   PRINT "Power of step";I;"= ";Dynamic_val(I);"dBm/5 MHz"
930 NEXT I
940 !
950 !*******************************************************************
960 ! Subroutine: End of all testing clean up
970 !*******************************************************************
980 !
990  End_program:!
1000 !
1010 OUTPUT Testset;"*RST"
1020 !Full preset test set
1050 PRINT "End of Program"
1060 END

Part of the results from this example program is shown below:

Related Topics

Extended Range Dynamic Power Measurement Description

Manual Operation: How Do I Make an Extended Range Dynamic Power Measurement?


Programming the Phase Discontinuity Measurement

Programming the Phase Discontinuity Measurement

Last updated: January 16, 2009

This section provides an example of how to make phase discontinuity measurements via GPIB.

The basic procedure to perform phase discontinuity measurements is as follows:

  1. Establish an RB test mode connection between the UE and test set (see Step 4: Make a Connection ).
  2. Set UL CL Power Control Mode to Active Bits ( CALL[:CELL]:CLPControl:UPLink:MODE ).
  3. Set UE Target Power to the appropriate level ( CALL:MS:POWer:TARGet[: AMPLitude]? ).
  4. Set up the measurement using the SETup:WPDiscon commands.
  5. INITiate the measurement using the INITiate command.
  6. FETCh the measurement results using the FETCh:WPDiscon commands (or use the READ:WPDiscon[:ALL]? command to both initiate and fetch the measurement as a sequential operation).

Programming Example

10 ! Phase Discontinuity Measurement Programming Example
20 ! This programming example assumes that there is an RB
30 ! Test Mode connection between the test set and UE.
40 !
50 Testset=714
60 !
70 ! *** Set Up Test Parameters ***
80  !
90 OUTPUT Testset;"CALL:CLPControl:UPLink:MODE ACTive"
100 ! Set UL CL Power Ctrl Mode to Active Bits.
110 OUTPUT Testset;"CALL:MS:POWer:TARGet 21"
120 ! Set MS Target Power to +21 dBm.
130 !
140 ! *** Set Up Measurement Parameters ***
150 !
160 OUTPUT Testset;"SETup:WPDiscon:PCPattern DN5_4UP"
170 ! Set Power Control Pattern to 5DOWN/4UP.
180 OUTPUT Testset;"SETup:WPDiscon:NPRepetition 10"
190 ! Set the Number of Pattern Repetitions to 10.
200 !
210 ! *** INITiate and FETCh Measurements ***
220 !
230 OUTPUT Testset;"INITiate:WPDiscon"
240 ! Initiate a Phase Discontinuity measurement.
250 OUTPUT Testset;"FETCh:WPDiscon?"
260 ! Fetch Phase Discontinuity measurement results.
270 ENTER Testset;Int,Num_slts,Wc_pd_slt,Wc_pd,Wc_evm_slt,Wc_evm
280 ! Retrieve the results.
290 !
300 ! *** Print Measurement Results ***
310 !
320 CLEAR SCREEN
330 PRINT "Phase Discontinuity Measurement Results:"
340 PRINT
350 PRINT "Integrity Indicator                         = ",Int
360 PRINT "Number of Slots Measured                    = ",Num_slts
370 PRINT "Worst Case Phase Discontinuity Slot Number  = ",Wc_pd_slt
380 PRINT "Worst Case Phase Discontinuity (in degrees) = ",Wc_pd
390 PRINT "Worst Case EVM Slot Number                  = ",Wc_evm_slt
400 PRINT "Worst Case EVM (in % rms)                   = ",Wc_evm
410 !
420 END

Related Topics

Phase Discontinuity Troubleshooting

Phase Discontinuity Measurement Description

Manual Operation: How Do I Make a Phase Discontinuity Measurement?


Programming the PRACH Preamble Analysis Measurement

Programming the PRACH Preamble Analysis Measurement

Last updated: January 16, 2009

This section is only applicable to the lab application.

  1. Set Call Limit State to Off using the CALL:CONNected:LIMit[:STATe][:SELected] command.
  2. Set PRACH Signature as needed using the CALL:UPLink:PRAChannel:SMASk command.
  3. Set PRACH Preambles to at least 3 using the CALL:UPLink:PRAChannel:PREambles:NUMBer command.
  4. Set Available Subchannels (Bit Mask) to specify only one available subchannel using the CALL:UPLink:PRAChannel:ASUBchannels command.
  5. Prompt the user to power the UE on and wait for it to camp to the test set, then continue the program.
  6. Set Cell Power as needed using the CALL[:CELL]:POWer[:SAMPLitude][:SELected] command.
  7. Set up the measurement using the SETup:WPPAnalysis commands.
  8. INITiate the measurement using the INITiate command.
  9. FETCh the measurement results using the FETCh:WPPAnalysis commands.

Related Topics

PRACH Preamble Analysis Measurement Description


Programming a TX Dynamic Power Measurement

Programming a TX Dynamic Power Measurement

Last updated: January 16, 2009

This section provides an example of how to make a TX dynamic power measurement via remote program.

The following program example assumes that the test set is in Active Cell Operating mode and the UE is connected to the RF IN/OUT connector.

The basic procedure to measure TX dynamic power is as follows:

  1. Set the test set's receiver to the proper power and frequency using the RFANalyzer:CONTrol:POWer:AUTO , RFANalyzer:MANual:POWer[:SELected] and RFANalyzer:MANual:MEASurement[:MFRequency] commands.
  2. Set the TX dynamic power setup parameters to match your UE's power sequence using the SETup:WTDPower commands.
  3. Place your UE into the test mode required for performing TX dynamic power and order it to transmit continuously at the initial transmit power level.
  4. Initiate (arm) the TX dynamic power measurement using the INITiate:<measurement mnemonic>[:ON] command.
  5. Using the UE's test mode interface, command your UE to generate the RF rise needed to trigger the measurement.
  6. When the measurement is finished, use the FETCh:WTDPower commands to obtain the measurement results.

Programming Example

10       CLEAR SCREEN
20       DIM Dypow_res$[3400]
30       DIM Dynamic_val(200)
40       Testset=714
50            !
60            !***Set up measurement parameters***
70            !
80       OUTPUT Testset;"SETup:WTDPower:TIMeout 10"
90            ! Sets Measurement Timeout to 10 seconds
100       OUTPUT Testset;"RFANalyzer:CONTrol:POWer:AUTO OFF"
110           ! Sets Power Control to manual mode
120       OUTPUT Testset;"RFANalyzer:MANual:POWer 20"
130           ! Sets Manual Power to 20 dBm
140       OUTPUT Testset;"RFANalyzer:MANual:MEASurement 1900 MHZ"
150           ! Sets Measurement Frequency to 1900 MHz
160       OUTPUT Testset;"SETup:WTDPower:STEP -3"
170           ! Sets Power Step Size to -3 dB
180       OUTPUT Testset;"SETup:WTDPower:STEP:COUNt 9"
190           ! Sets Number of Power Steps to 9
200       OUTPUT Testset;"SETup:WTDPower:STEP:TIME MS20"
210           ! Sets Power Step Time to 20 ms
220           !
230           !***Initiate the measurement***
240           !
250       OUTPUT Testset;"INITiate:WTDPower"
260           ! Initiates the measurement
270           !
280       PRINT "Command the UE to trigger the measurement"
290       PRINT "and begin its step down power sequence"
300           !
310           !***Obtain measurement results***
320           !
330       OUTPUT Testset;"FETCh:WTDPower:COUNt?"
340       ENTER Testset;Numpowmeas
350           ! Determines the number of power results available
360       OUTPUT Testset;"FETCh:WTDPower?"
370       ENTER Testset;Integrity,Dypow_res$
380           ! Fetches the integrity indicator and power results
390           !
400           !***Print measurement results***
410           !
420       PRINT
430       PRINT "Integrity Indicator = ";Integrity
440       PRINT "The number of power meas results available = ";Numpowmeas
450       FOR I=1 TO Numpowmeas
460           Dynamic_mkr=((I-1)*17)
470             ! Sets up a marker that will jump to each comma in the ascii string
480           Dynamic_val(I)=VAL(Dypow_res$[Dynamic_mkr+1;Dynamic_mkr+16])
490             ! Convert ascii to a numeric value
500           PRINT
510           PRINT "Power of step";I-1;"= ";Dynamic_val(I);"dBm/5 MHz"
520       NEXT I
530           !
540       END

A sample output from this program example is shown below:

Related Topics

TX Dynamic Power Measurement Description

Manual Operation: How Do I Make a TX Dynamic Power Measurement?


Programming a Waveform Quality Measurement

Programming a Waveform Quality Measurement

Last updated: January 16, 2009

This section provides an example of how to make waveform quality measurements via GPIB. The following program example assumes that the mobile station's (UE's) antenna output is connected to the RF IN/OUT connector, and that the mobile station is synchronized to the test set and is transmitting an uplink signal.

The basic procedure to test waveform quality is as follows:

  1. Set the waveform quality setup parameters as desired using the SETup:WWQuality commands.
  2. Use the INITiate:WWQuality command to start the measurement.
  3. Use the FETCh:WWQuality? query to obtain the measurement results.

Programming Example

10    OUTPUT 714;"SETup:WWQuality:CONTinuous Off"   !Set the waveform quality
20                                       !measurement to single trigger mode.
30    OUTPUT 714;"SETup:WWQuality:TIMeout 1S"!Set a timeout value of 1 second
40                                  !in case the measurement cannot be made.
50    OUTPUT 714;"SETup:WWQuality:COUNt 5"  !Set multi-measurements to 5 and
60                                          !enable multi-measurements.
70    OUTPUT 714;"SETup:WWQuality:TSLot 11" !Set the measurement to
80                                !measure waveform quality during timeslot 11.
90    OUTPUT 714;"INITiate:WWQuality" !Start the waveform quality measurement.
100   OUTPUT 714;"FETCh:WWQuality?"  !Query the integrity indicator and all
110                               !results for the waveform quality measurement.
120   ENTER 714;Integrity,Evm,Ferr,Ooff,Perr,Merr,Terr,Pcde !Enter the
130          !returned integrity indicator and measurement values into variables.
140   IF Integrity<>0 THEN !Check the integrity value.
150   PRINT "Measurement problem; check for signal level over/under range condition."
160   ELSE
170   ! Process measurement results
180   END IF
190   END

Returned Values

  • Integrity stores the returned integrity indicator value (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Evm returns the maximum error vector magnitude result.
  • Ferr returns the worst case frequency error result.
  • Ooff returns the maximum origin offset result.
  • Perr returns the maximum phase error result.
  • Merr returns the maximum magnitude error result.
  • Terr returns the worst case timing error in chips.
  • Pcde returns the maximum peak code domain error.

Related Topics

  • Waveform Quality Troubleshooting
  • Waveform Quality Measurement Description
  • SETup:WWQuality
  • INITiate
  • FETCh:WWQuality
  • Amplitude Offset
  • Integrity Indicator


E1963A and E6703B W-CDMA Applications: GPIB Command Revision Information

Last updated: January 16, 2009

The tables below indicate new and revised GPIB commands for the W-CDMA test and lab applications at each release.

  • GPIB Changes for E1963A A.05.20, E6703B B.01.20 - April 2004
  • GPIB Changes for E1963A A.05, E6703B B.01 - December 2003
GPIB Changes for E1963A A.05.20, E6703B B.01.20 - April 2004
GPIB Command | New | Revised | Test Application | Lab Application
CALL[:CELL]:BCCHannel:ITRFrequency:DOWNlink:CHANnel |  | X | X | X
CALL:CHANnel |  | X | X | X
CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:DOWNlink |  | X | X | X
CALL:SETup[:PCReconfig]:CHANnel<[:SELected]|:FDD>:UPLink[:MCHannel] |  | X | X | X
CALL:UPLink:CHANnel[:MCHannel] |  | X | X | X
GPIB Changes for E1963A A.05, E6703B B.01 - December 2003
GPIB Command | New | Revised | Test Application | Lab Application
ABORt:<measurement mnemonic> |  | X | X | X
CALL[:CELL]:BCCHannel:GSMSystem:BAND | X |  | X | X
CALL[:CELL]:BCCHannel:GSMSystem:BCC | X |  | X | X
CALL[:CELL]:BCCHannel:GSMSystem:NCC | X |  | X | X
CALL[:CELL]:BCCHannel:GSMSystem:STATe | X |  | X | X
CALL[:CELL]:BCCHannel:INTRAFREQ:CELL2:SCODe . This command is now obsolete. |  | X | X | X
CALL[:CELL]:BCCHannel:INTRAFREQ:CELL3:SCODe . This command is now obsolete. |  | X | X | X
CALL[:CELL]:BCCHannel:INTERFREQ:DOWNlink:CHANnel . This command is now obsolete. |  | X | X | X
CALL[:CELL]:BCCHannel:INTERFREQ:SCODe . This command is now obsolete. |  | X | X | X
CALL[:CELL[1]]:BCCHannel:INTERFREQ:UPLink:CHANnel. This command is now obsolete. |  | X | X | X
CALL[:CELL]:BCCHannel:ITAFrequency:SCODe | X |  | X | X
CALL[:CELL]:BCCHannel:ITAFrequency:STATe | X |  | X | X
CALL[:CELL]:BCCHannel:ITRFrequency:DOWNlink:CHANnel | X |  | X | X
CALL[:CELL]:BCCHannel:ITRFrequency:SCODe | X |  | X | X
CALL[:CELL]:BCCHannel:ITRFrequency:STATe | X |  | X | X
CALL:COMPressed:ENABle | X |  |  | X
CALL:COMPressed:MEASurement:GSMSystem:RSSI:RINTerval | X |  |  | X
CALL:COMPressed:MEASurement:GSMSystem:RSSI:RQUantity | X |  |  | X
CALL:COMPressed:MEASurement:ITRFrequency:RQUantity | X |  |  | X
CALL:COMPressed:MEASurement:ITRFrequency:RINTerval | X |  |  | X
CALL:COMPressed:MEASurement:STATe | X |  |  | X
CALL:COMPressed:MEASurement:TYPe | X |  |  | X
CALL:COMPressed:TGPSequence:DEFinition | X |  |  | X
CALL:COMPressed:TGPSequence([1]|2|3|4):TGLength[1] | X |  |  | X
CALL:COMPressed:TGPSequence([1]|2|3|4):TGPLength | X |  |  | X
CALL:COMPressed:TGPSequence([1]|2|3|4):TGSNumber | X |  |  | X
CALL:DPCHannel:RMC144:CCODe | X |  | X |
CALL:DPCHannel:KSPS240[:CCODe] | X |  |  | X
CALL:COUNt:DTMonitor | X |  |  | X
CALL:DPCHannel:TYPe . This command is now obsolete. | X |  | X | X
CALL:FDDTest:COMPressed:DACTivation:TYPe | X |  |  | X
CALL:FDDTest:COMPressed:ECFNumber | X |  |  | X
CALL:FDDTest:COMPressed:SCFNumber | X |  |  | X
CALL:HANDoff[:IMMediate] . This command is now obsolete. |  | X | X | X
CALL:HANDoff:PCReconfig[:IMMediate] | X |  | X | X
CALL:HANDoff:SYSTem[:GSM][:IMMediate] | X |  | X | X
CALL:HANDoff:TCReconfig[:IMMediate] | X |  | X | X
CALL:MS:LOOPback:TYPE | X |  | X | X
CALL:MS:REPorted:MEASurement:TYPe | X |  | X | X
CALL:MS:REPorted:GSMSystem:BCHannel? | X |  |  | X
CALL:MS:REPorted:GSMSystem:CELLs? | X |  |  | X
CALL:MS:REPorted:GSMSystem:RSSI? | X |  |  | X
CALL:MS:REPorted:ITRFrequency:CELLs? | X |  |  | X
CALL:MS:REPorted:ITRFrequency:DOWNlink:CHANnel? | X |  |  | X
CALL:MS:REPorted:ITRFrequency:ECNO? | X |  |  | X
CALL:MS:REPorted:ITRFrequency:PATHloss? | X |  |  | X
CALL:MS:REPorted:ITRFrequency:RSCP? | X |  |  | X
CALL:MS:REPorted:ITRFrequency:RSSI? | X |  |  | X
CALL:MS:REPorted:ITRFrequency:SCODe? | X |  |  | X
CALL:SERVice:CSData:MODE:ASYNchronous:OUTput | X |  |  | X
CALL:SERVice:CSData:PPPMode. This command is now obsolete. |  | X |  | X
CALL:SERVice:CSData:RAB. This command is now obsolete. |  | X |  | X
CALL:SERVice:GPRS:RAB |  | X |  | X
CALL:SERVice:RBTest:DTCHannel:CRC[:PRESence] | X |  | X | X
CALL:SERVice:RBTest:RAB | X |  | X | X
CALL:SERVice:RBTest:RRC:STATe | X |  |  | X
CALL:SETup[:HANDoff]:SYSTem[:TYPE] . This command is now obsolete. |  | X | X | X
CALL:SETup:TCReconfig:RBTest:RAB | X |  | X | X
CALL:STATus[:GMM]:ATTached:STATe? |  | X |  | X
CALL:STATus:COMPressed:STATe? | X |  |  | X
CALL:STATus:MM? | X |  | X | X
CALL:STATus:RRC:STATe? | X |  |  | X
CALL:STATus:SERVice:TYPe? |  | X | X | X
CALL:STATus:SHANdoff:STATe? | X |  |  | X
CALL:UPLink:TXPower:LEVel:MAXimum | X |  | X | X
FETCh:WBLerror | X |  | X | X
FETCh:WDPAnalysis | X |  | X | X
FETCh:WPDiscon | X |  | X | X
FETCh:WPPAnalysis | X |  |  | X
INITiate:DONE? |  | X | X | X
INITiate:DONE:FLAG:<measurement mnemonic> |  | X | X | X
INITiate:<measurement mnemonic>[:ON] |  | X | X | X
INITiate:ON? |  | X | X | X
INITiate:<measurement mnemonic>:OFF |  | X | X | X
READ:WBLerror[:ALL]? | X |  | X | X
READ:WDPAnalysis[:ALL]? | X |  | X | X
READ:WPDiscon[:ALL]? | X |  | X | X
READ:WPPAnalysis[:ALL]? | X |  |  | X
SETup:WBLerror | X |  | X | X
SETup:WDPAnalysis | X |  | X | X
SETup:WPDiscon | X |  | X | X
SETup:WPPAnalysis | X |  |  | X


E1963A W-CDMA/HSPA Test Application Revision Information

E1963A W-CDMA/HSPA Test Application Revision Information

Last updated: March 30, 2012

This document describes the features in the Agilent Technologies E1963A W-CDMA Mobile Test Application releases. This document contains the original features, as well as enhancements that have been added over time.

If you are interested in comparing the key feature differences between the latest releases of each of the W-CDMA/HSPA Test and Lab Applications, see:

W-CDMA/HSPA Applications Feature Comparison

CAUTION
You may need to upgrade the hardware in your test set before installing the application firmware described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up (see Test Set Lockup During Power Up Sequence ).
  • The application may not run.
  • Some features in the application may be inaccessible, or may not perform to specifications.

To determine if a hardware upgrade is required for your testing needs, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Select the appropriate link below to view the required release.

  • A.19.12 Release - March 2012
  • A.18.07 Release - March 2011
  • A.17.10 Release - December 2010
  • A.16.08 Release - July 2010
  • A.15.12 Release - October 2009
  • A.14.18 Release - May 2009
  • A.13.13 Release - September 2008
  • A.12.11 Release - November 2007
  • A.11.08 Release - July 2007
  • A.10.19 Release - April 2007
  • A.10.17 Release - March 2007
  • A.10.12 Release - December 2006
  • A.09.06 Release - July 2006
  • A.08.31 Release - January 2006
  • A.08.09 Release - August 2005
  • A.07.25 Release - May 2005
  • A.06.17 Release - January 2005
  • A.05.33 Release - July 2004
  • A.05.28 Release - April 2004
  • A.05.16 Release - January 2004
  • A.05.14 Release - January 2004
  • A.04.10 Release - July 2003
  • A.03.20 Release - February 2003
  • A.02.35 Release - August 2002
  • A.02.20 Release - May 2002
  • A.01.08 Release - November 2001 (Initial Test Application Release)

A.19.12 Release - March 2012

The most current documentation for the WCDMA/HSPA applications is the on-line User's Guide located at:

.http://wireless.agilent.com/rfcomms/refdocs/wcdma/default.htm

Hardware Requirements

This release has specific hardware requirements. Test sets with serial number<MY5210 require a HW upgrade to run this release.

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Call Processing

  • Dual Cell HSDPA. (An additional feature license is required to enable this functionality in a licensed lab application or test application.)

    Dual carrier HSDPA, also referred as dual cell HSDPA or DC-HSDPA in the test standard, is a WCDMA release 8 feature that allows the network to transmit HSDPA data from two cells simultaneously. The peak rate is doubled from 21Mbps to 42Mbps without the use of MIMO. See Dual Cell HSDPA Concepts and How Does the Test Set Supports DC-HSDPA .

    Please be noted that specific hardware is required to enable this feature.

  • New Radio Bearer Setup Message RLC Configuration. See CALL[:CELL]:RBSetup:RLC:CONFigure .

Measurements

  • Enhanced the Fast Device Tune Measurement to allow the downlink modulation being turned off to generate CW singal. See SETup:CFDTune:MS:RX:MODulation:STATe .

_____________________________________________________________________________________________________

A.18.07 Release - March 2011

The most current documentation for the WCDMA/HSPA applications is the on-line User's Guide located at:

.http://wireless.agilent.com/rfcomms/refdocs/wcdma/default.htm

Hardware Requirements

Please be aware that this release has specific hardware requirements to be able to run correctly.

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Call Processing

  • Support for two box voice handover. See Handovers Available in the Two-Cell Test System . (An additional feature license is required to enable this functionality in a licensed test application)
  • Support for Band XIX, XX, and XXI. (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application.)
    • New channel and frequencies. See Downlink Channel (UARFCN) ( CALL:CHANnel ), Uplink Channel (UARFCN) ( CALL:UPLink:CHANnel[:MCHannel] , CALL:STATus:UPLink:SEParation? ).
    • New Physical Channel Reconfiguration channels, Transport Channel Reconfiguration channels and Radio Bearer Reconfiguration channels. See CALL:SETup , and CALL:STATus .

    In addition, the current downlink and uplink frequency can be queried by CALL:STATus:DOWNlink:FREQuency? and CALL:STATus:UPLink:FREQuency? .

  • New parametes for Transport Channel Reconfiguration ( RB TCR E-DPDCH Max Channelisation Codes and RB TCR E-DPDCH Max Channelisation Codes (HSPA Only) ). See CALL:SETup:TCReconfig:RBTest:EDPDchannel:CCODes:MAX[:HSPARMC12] and CALL:SETup:TCReconfig:RBTest:EDPDchannel:CCODes:MAX:HSPA .

_____________________________________________________________________________________________________

A.17.10 Release - December 2010

The most current documentation for the WCDMA/HSPA applications is the on-line User's Guide located at:

.http://wireless.agilent.com/rfcomms/refdocs/wcdma/default.htm

Hardware Requirements

Please be aware that this release has specific hardware requirements to be able to run correctly.

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Call Processing

  • Support for uplink 16QAM (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application.)
    • The test set can demodulate E-DCH with 16QAM and 2 ms TTI by setting E-DCH 16QAM State to On . See also CALL:HSUPa:EDCHannel:QAM16[:STATe] .
    • Add the following 34.121 preset call configurations: 5.2E:HSPA+:UL 16QAM and 5.13.1AAA,5.13.2C:HSPA+:UL 16QAM . See HSPA+ 34.121 Preset Call Configurations .
    • When HSUPA TTI mode is 2ms TTI and UL 16QAM state is on, alternate absolute grant values are available. See Serving Grant Parameters .
    • New 16QAM settings for Transport Channel Reconfiguration .
    • Extend the range of reference E-TFCI power offset. See Common HSUPA Parameters .
    • Extend the range of following HSUPA real time results: last Block Size , Average Block Size , Minimum Block Size and Maximum Block Size .
  • UE Reported E-DCH Category Extension, see Rep EDCH Cat/Ext .

Measurements

  • Enhanced the Tx measurements to support uplink 16 QAM.
  • (For HSDPA, by GPIB only) Refined symbol decoder for Code Domain (see SETup:WCDomain:REFined:SDECoder:STATe ), Waveform Quality (see SETup:WWQuality:REFined:SDECoder:STATe )., IQ Tuning (see SETup:WIQTuning:REFined:SDECoder:STATe ), and Phase Discontinuity (see SETup:WPDiscon:REFined:SDECoder:STATe ).

_____________________________________________________________________________________________________

A.16.08 Release - July 2010

The most current documentation for the WCDMA/HSPA applications is the downloadable User's Guide located at:

http://www.agilent.com/find/e1963a (from the Technical Support tab choose Manuals, then "Repository of E1963A, E6703A/B/C/D/E/T/U CHM Help Files") .

Hardware Requirements

Please be aware that this release has specific hardware requirements to be able to run correctly.

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Call Processing

  • Update the preset configurations for 3GPP TS 34.121 5.2B, 5.9B, 5.10B and 5.13.2B sub test 5 to comply with the newer version standard. See HSPA 34.121 Preset Call Configurations .

Measurements

  • Added a new measurement: Perceptual Evaluation of Speech Quality (PESQ). (An additional feature license is required to enable this functionality in a licensed lab application or test application)

    PESQ is a objective method to test the speech quality of the mobile station. With a voice service and the AMR Source set to PESQ , the test set supports the PESQ measurement with three measurement modes: Uplink Audio, Downlink Audio and Both. When a single measurement is done, a PESQ score ranging from -0.5 (bad) to 4.5 (Excellent) is given to rate the speech quality. The related headroom is also displayed.

    • For the measurement description, see Perceptual Evaluation of Speech Quality (PESQ) Measurement Description .
    • For the manual operation, see Measuring Perceptual Evaluation of Speech Quality (PESQ) .
    • For the GPIB commands, see SETup:WPESquality or FETCh:WPESquality .
    • For trouble shooting, see Perceptual Evaluation of Speech Quality Measurement Troubleshooting

  • The waveform quality measurement is extended to report the following results: Peak Magnitude Error, Peak Phase Error and Rho, by GPIB command only. See FETCh:WWQuality . (An additional Revision to Current (R2C) license is required to enable this functionality in a licensed test application.)

_____________________________________________________________________________________________________

A.15.12 Release - October 2009

For the most up-to-date information about this release, please visit www.agilent.com/find/8960manuals.

Hardware Requirements

Please be aware that this release has specific hardware requirements to be able to run correctly.

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Call Processing

  • Enhanced F-DPCH (see CALL:FDDTest:FDPChannel:SLOT:FORMat , CALL:HSDPa:FDPChannel:SLOT:FORMat )
  • FDD Test Mode FRC H-Set 8 UE IR Buffer Size (see CALL:FDDTest:FRC:HSET8:MS:IREDundancy:BUFFer:SIZE )
  • FRC H-Set 8 UE IR Buffer Size (see CALL:HSDPa:SERVice:RBTest:FRC:HSET8:MS:IREDundancy:BUFFer:SIZE )

Measurements

  • The E1963A now includes the QPSK EVM measurement. This measurement can be used to determine the error between the transmitted signal of a UE and the desired ideal signal, like the Waveform Quality measurement. The difference is that the QPSK EVM measurement expects a QPSK modulated input signal, which is similar to the WCDMA uplink signal with only one code channel. The data carried by the QPSK symbols sequence can be any pattern. There are several results reported with this measurement. These include the following:

    • Error Vector Magnitude (EVM)
    • Peak EVM - the maximum symbol EVM which is the calculated EVM at each QPSK symbol in the measurement interval
    • Phase Error
    • Origin Offset
    • Frequency Error

    See SETup:EVMQpsk , INITiate , READ , and FETCh:EVMQpsk .

_____________________________________________________________________________________________________

A.14.18 Release - May 2009

For the most up-to-date information about this release, please visit www.agilent.com/find/8960manuals.

Hardware Requirements

Please be aware that this release has specific hardware requirements to be able to run correctly.

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Call Processing

  • The E1963A includes HSPA+ 64QAM DL test modes with signaling, HSPA+ MAC_ehs and Layer 2 enhancements. Layer 2 enhancements involve dynamically controlling the RLC PDU and SDU sizes instead of them being fixed. H-Set 8 is the one FRC that is now defined with 64QAM specifically for testing HSPA+ devices. An additional feature license is required to enable this functionality in a licensed test application. Refer to the following items:
    • Changes on the HS-SCCH coding scheme to accommodate 64QAM: To be able to support signaling of three modulation formats (QPSK, 16QAM and 64QAM), the coding of HS-SCCHs changes if the UE is configured to be able to use 64QAM modulation type by higher layer signaling and the modulation format on the HS-PDSCHs is 16QAM or 64QAM.
    • New HS-DSCH Transport Block table defined for 64QAM: To support the 64QAM modulation format, a new table of HS-DSCH Transport Block Size and a corresponding table of K0,I of different numbers of channelization codes and modulation schemes are defined in 25.321 v7.8.0. To differentiate the additional K0,I table in release 7 from the existing K0,I table defined in release 5, the former is named octet aligned table, the latter is named bit aligned table. The selection between the two tables in UE depends on 3 Information Elements transmitted from the network which are defined in 25.331 v7.8.0:
      • DL MAC header type
      • Downlink 64QAM configured
      • HS-DSCH TB size table
    • H-SET 8 (64QAM modulation): Each 3GPP FRC H-Set defines a static configuration at the transport channel and physical channel level (for example, block size, number of HS-PDSCHs, inter-TTI distance, number of HARQ processes). The end result is a fixed data rate for the purposes of easier more consistent testing. Each FRC H-Set is associated with a particular UE category. FRC H-Sets 1, 2, 3, 6 and 10 have both QPSK and 16QAM variants, H-Set 4 and 5 only have QPSK variants. This is because UE categories 11 and 12, which are associated with H-Set 4 and 5 respectively, are only capable of QPSK modulation. H-Set 8 only has 64QAM variants. The FRC does not define the MAC-hs and MAC-ehs parameters such as the number of transmissions of a block and the RV sequence, so you must still manually configure these items. H-Set 8 implies that MAC-ehs be applied instead of MAC-hs, octet-aligned HS-DSCH Transport Block Size table be applied. H-Set 8 does not specify the MAC-d PDU size. However, you still need to specify the MAC-ehs SDU size. This can be done using the MAC-d PDU size.

      New RB test mode parameters to support testing UE categories greater than 12.
      • MAC-hs or MAC-ehs (see CALL:HSDPa:SERVice:RBTest:UDEFined:HSDSchannel:MAC )
      • Whether 64QAM could be configured (see CALL:HSDPa:SERVice:RBTest:UDEFined:QAM64:STATe )
      • Flexible RLC SDU size: Flexible RLC SDU size provides a way to configure the RLC SDU size from 1 byte to 1503 bytes when MAC-ehs is configured in RB Test Mode. When MAC-ehs is configured in user defined configuration, no segmentation is done at RLC layer. This setting sequentially determines the RLC PDU size of the DTCH mapped on HS-DSCH, and the MAC-ehs SDU size (see CALL:HSDPa:SERVice:RBTest:UDEFined:MACEHS:RLC:SDU[:SIZE] ).
    • MAC-ehs: The use of an octet-aligned table requires MAC-ehs (see CALL:FDDTest:HSDSchannel:UDEFined:MACEHS:TBSTable:ALIGnment ). MAC-ehs is introduced to support the 64QAM modulation type and MIMO to achieve higher data rate at the MAC layer.
  • HSDPA 14.4Mbps RB Test and FDD Test modes and arbitrary configuration of downlink code allocation: Downlink throughput with HSDPA test modes in increased to a maximum of 14.4Mbps (Category 10). An additional feature license is required to enable this functionality in a licensed test application.

    Also the ability is provided to flexibly configure channel codes to set up to 15 HS-PDSCHs needed for maximum HSDPA throughput. H-Set 10 allows up to 15 HS-DSCH code channels.
    • Arbitrary DL code configuration (collision detection): You can freely set channelization codes in the allowable integer ranges, and the test set will apply a code collision detection procedure on all active channels and report a warning when a collision is detected.
  • Support for Band XII channels (UL/DL); Band XIII channels (UL/DL); Band XIV channels (UL/DL). See CALL:CHANnel , CALL:UPLink:CHANnel[:MCHannel] , CALL:SETup , CALL:STATus:FBINdicator? , CALL:STATus:SETup:RBReconfig:FBINdicator? , CALL:STATus:SETup:TCReconfig:FBINdicator? , and CALL:STATus:SETup[:PCReconfig]:FBINdicator? . An additional current Revision to Current (R2C) license is required to enable this functionality in a licensed test application.
  • 3GPP TS 34.121 related enhancements:
    • Independent H-RNTI: The UE identity values sent on the four HS-SCCHs (H-RNTIs) are extended so that all four can be set independently. This provides support for 3GPP TS 34.121 s9.4.1. In this release, you can configure the state of any HS-SCCH to be off, i.e. neither allocating the HS-SCCH in the test set nor configuring the UE to allocate that HS-SCCH through RRC messages when a HSDPA or HSPA connection is established (see CALL:FDDTest:HSSCchannel[1]:CONFig:STATe ).
    • Existing preset call configurations have been expanded to add configurability for the HSDPA and HSUPA sub-tests defined in the 3GPP TS 34.121 Annex C tables. This has added 26 new preset call configurations. Previously there were (5) HSDPA and (2) HSPA preset call configuration settings. These are retained as the "generic" setups but additional sub-set setups are added.
    • Support for two new data types (PRBS20 and PRBS23) is provided for use with W-CDMA or HSDPA channels. This adds compliance for 3GPP TS 34.121 s9.2.1A, C, D, E, F, and G. Sections 9.2.1H and I are also supported when 64QAM is the selected modulation type (see ) CALL:FDDTest:HSDSchannel:DATA , CALL:DTCHannel:DATA , and CALL:HSDPa:SERVice:RBTest:HSDSchannel:DATA ).
    • The ranges of the relative levels for the E-HICH, E-AGCH, and ERGCH are extended to support 3GPP TS 34.121 sections 10.2.1.1, 10.3.1.1, 10.3.1.2, and 10.4.1.
    • The AG Pattern has been extended to 8 values, adding support for 34.121 section 10.4.1 test.When the Absolute Grant mode parameter is set to "Pattern" then the application will transmit a continuous sequence of values to the UE over the E-AGCH (see CALL:HSUPa ).
  • A new parameter has been added to set the activation time of WCDMA to GSM handovers. See .
  • SMS TP-OA, TP-RA, RP-OA extension - allows you to configure parameters TP-OA, TP-RA, RP-OA. An additional current Revision to Current (R2C) license is required to enable this functionality in a licensed test application.

Measurements

  • HSUPA IQ tuning, phase discontinuity measurement, waveform quality. EVM measurements are enhanced to support use with HSUPA. An additional current Revision to Current (R2C) license is required to enable this functionality in a licensed test application.
  • SEM enhancement: This 34.121 measurement has been modified for certain frequency bands that have small frequency separation. Also, an absolute measurement result has been added to the standard and this has been incorporated. See SETup:WSEMask and FETCh:WSEMask . An additional current Revision to Current (R2C) license is required to enable this functionality in a licensed test application.
  • An in-channel power result has been added to the Adjacent Channel Leakage Ratio (ACLR) measurement. An additional current Revision to Current (R2C) license is required to enable this functionality in a licensed test application. See FETCh:WACLeakage .
  • The Inner Loop Power measurement now supports use with the 12.2k RMC + HSDPA channel type. An additional current Revision to Current (R2C) license is required to enable this functionality in a licensed test application.
  • The frequency range of the Fast Device Tune measurement has been extended.

_____________________________________________________________________________________________________

A.13.13 Release - September 2008

For the most up-to-date information about this release, please visit www.agilent.com/find/8960manuals.

Hardware Requirements

Please be aware that this release has specific hardware requirements to be able to run correctly.

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Call Processing

  • 5.74 Mbps HSUPA (2ms TTI) in RB test mode and FDD test mode - The test set now supports 5.74 Mbps HSUPA (2ms TTI) in addition to the previously supported 2 Mbps HSUPA (10ms TTI), allowing full support of the E-DCH Category 6 HSUPA device verification and manufacturing. An additional feature license is required to enable this functionality in a licensed test application.
    • HSUPA TTI Mode: CALL:HSUPa:EDCHannel:TTI
    • E-TFCI Table Index (2ms TTI): CALL:HSUPa:ETFCi:TINDex:MS2
    • UTRA FDD RB Test Mode Channel Type: CALL:SERVice:RBTest:RAB
    • E-DCH Minimum Set E-TFCI Information State: CALL:HSUPa:EDCHannel:ETFCi:MSET:STATe
    • E-DCH Minimum Set E-TFCI (2ms TTI): CALL:HSUPa:EDCHannel:ETFCi:MSET:MS2
    • RB Test Mode E-DPDCH Max Channelisation Codes (HSPA Only): CALL:HSUPa:SERVice:RBTest:EDPDchannel:CCODes:MAX:HSPA
    • FDD Test Mode E-DPDCH Max Channelisation Codes (HSPA Only): CALL:FDDTest:EDPDchannel:CCODes:MAX:HSPA
  • One-box video loopback - Allows a video call using just one test set and one UE by looping the voice and video data sent by the UE back to the UE. An additional feature license is required to enable this functionality in a licensed test application.
  • AMR/WB-AMR real-time vocoder and digital audio interface - This release includes an AMR/WB-AMR vocoder, which is supported in both voice loopback and with the digital audio interface (playing and recording of pre-defined audio files). This allows for the audio codec verification and real-time end-to-end audio testing. An additional feature license is required to enable this functionality in a licensed test application. See CALL:SERVice:AMR:RAB .
  • Short message service (SMS) - Allows you to test both the cell broadcast and point-to-point (mobile terminated and mobile originated messages) SMS capability of your UE (previously SMS was only supported in the lab application). An additional feature license is required to enable this functionality in a licensed test application. See Short Message Service (SMS) .
  • FM source - The test set, with an external adapter (E5520A) connecting to the RF IN/OUT port, can generate FM mono signals from 10-110 MHz, allowing for calibration of FM receiver of your UE. See FM Broadcast .
  • Equipment Identity Request can now be configured to request from the UE either the IMEI, IMEISV, or both. See CALL:EIDentity , CALL:MS:REPorted:EISV? and CALL:MS:REPorted:EISV:SVN? .
  • Support for Band XI. See CALL:STATus:FBINdicator? , CALL:STATus:SETup:RBReconfig:FBINdicator? , CALL:STATus:SETup:TCReconfig:FBINdicator? , and CALL:STATus:SETup[:PCReconfig]:FBINdicator? .
  • The UTRA FDD Speech Echo Loopback Delay value was previously fixed at 0.5 seconds. This setting determines the amount of time that speech frames received on the uplink are delayed before being retransmitted on the downlink. A new parameter has been added with a default value of 0.5 seconds to maintain backwards compatibility. See CALL:SERVice:AMR:SPEech:ECHO:LOOPback:DELay .
  • E-TFCI recording has been enhanced allowing you to control whether all E-DPDCH subframes are recorded, or only those that pass CRC checks. An additional feature license is required to enable this functionality in a licensed test application. See CALL:HSUPa:ETFCi:RECord:BEHavior .

Measurements

  • Enhanced fast device tune (FDT) - Supports 10ms measurement step size in addition to the 20ms step size previously available in the E1999A-201 feature option (see SETup:CFDTune:POWer:STEP:LENGth ). (An additional feature license is required to enable this functionality in a licensed test application). Besides, the range of Number of Power Steps is extended up to 40.
  • Enhancements to the UE reported measurements - Previously, the CPICH Ec/No and CPICH RSCP UE reported values were displayed in the index value. With this release you can get more intuitive values in dB or dBm.

Other Features

  • The test set now provides summary information for the user calibrations that have been performed, along with a readout of the test set's current operating temperature. See User Calibration Summary .

_____________________________________________________________________________________________________

A.12.11 Release - November 2007

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Support for HSUPA in RB Test Mode and FDD Test Mode. The test set supports 10 ms TTI HSUPA in conjunction with HSDPA (HSUPA + HSDPA = HSPA). See HSPA in Active Cell Operating Mode , HSPA Radio Bearer Test Mode and HSPA in FDD Test Operating Mode . An additional feature license is required to enable this functionality in a licensed test application.
    • New 12.2k RMC + HSPA Channel Type .
    • New HSUPA RB Test Mode Setup settings.
    • New Common HSUPA Parameters settings.
    • New Serving Grant settings/actions allow you to send relative grant up/down commands on the E-RGCH, single shot absolute grants or an absolute grant pattern on the E-AGCH.
    • New HSDPA/HSPA DL Channel Codes , HSPA Connected DL Channel Levels .
    • New E-RNTI Parameters .
    • E-TFCI Recording: New E-TFCI Recording Information screen and E-TFCI Recording settings/actions allow you to record and view up to 50 E-TFCI values from the UE.
    • New HSPA Information screen displays HSDPA Information as well as HSUPA counters (such as block size, throughput, ACKs/NACKs transmitted) and information (such as queued relative grants, last received E-TFCI). HSUPA Information and HSUPA Happy Bit Information is also available on the main Call Setup Screen .
    • New Transport Channel Reconfiguration settings allow you to change E-DPCCH/DPCCH power offset and reference E-TFCI power offsets while on a connection (and change absolute grant as well).
    • Radio Bearer Reconfiguration now supports HSPA RB test mode connections.
    • Also, see HSUPA Concepts .
  • New E-DCH Cell Indicator and HSDPA Cell Indicator settings allow UEs to display a visual cue that HSUPA or HSDPA functionality is available in the current cell. An additional feature license is required to enable this functionality in a licensed test application.
  • New HSPA 34.121 Preset Call Configurations ( 5.2B, 5.9B, 5.10B, 5.13.2B with QPSK and 5.2D with QPSK ) simplify configuring the test set for 3GPP TS 34.121 HSPA tests from the front panel. An additional feature license is required to enable this functionality in a licensed test application.
  • DeltaACK , DeltaNACK and DeltaCQI are now applicable to FDD test mode (previously these settings were only used by the test set while in active cell operating mode). This allows you to indicate the DeltaACK, DeltaNACK and DeltaCQI values being used by the UE while in FDD Test Operating Mode , for use by the code domain measurement. An additional feature license is required to enable this functionality in a licensed test application.

Transmitter Measurements

  • Channel Power measurement now supports HSPA. An additional feature license is required to enable this functionality in a licensed test application. See:
    • Measuring 3GPP TS 34.121-1 (v8.10.0) 5.2B Maximum Output Power with HS-DPCCH and E-DCH
    • Program Example: 5.2B Maximum Output Power with HS-DPCCH and E-DCH
  • Channel Power measurement now returns RMSCubed results, see Channel Power Measurement Results .
  • Code Domain measurement now supports HSPA. An additional feature license is required to enable this functionality in a licensed test application. See:
    • Measuring 3GPP TS 34.121-1 (v8.10.0) 5.2D UE Relative Code Domain Power Accuracy for HS-DPCCH and E-DCH
    • Program Example: 5.2D UE Relative Code Domain Power Accuracy for HS-DPCCH and E-DCH
    • Measuring 3GPP TS 34.121-1 (v8.10.0) 5.13.2B Relative Code Domain Error with HS-DPCCH and E-DCH
    • Program Example: 5.13.2B Relative Code Domain Error with HS-DPCCH and E-DCH
  • Spectrum Emission Mask measurement now supports HSPA. An additional feature license is required to enable this functionality in a licensed test application. See: Measuring 3GPP TS 34.121-1 (v8.10.0) 5.9B Spectrum Emission Mask with E-DCH .
  • Adjacent Channel Leakage Ratio measurement now supports HSPA. An additional feature license is required to enable this functionality in a licensed test application. See Measuring 3GPP TS 34.121-1 (v8.10.0) 5.10B Adjacent Channel Leakage Ratio (ACLR) with E-DCH .
  • If ALC Mode is not set to Closed Loop and you try to initiate the Fast Device Tune measurement, an error is posted (because the Fast Device Tune measurement is not supported on a faded channel). See Fast Device Tune Measurement Description .

Known Issues

  • The Block Error Ratio (BLER) measurement does not operate correctly when the Channel Type is set to 12.2k RMC + HSPA. The measurement always reports an error ratio of 100% with this channel type. With 12.2k RMC + HSPA, the BLER measurement uses RLC Transparent Mode (TM) and would require the UE Loopback Type to be set to Type 2 in order to loop back data and CRC bits. However, UE Loopback Type is fixed to Type 1 for this configuration, as required by TS 34.109 (refer to section 5.3.1 in TS 34.109, rev 7.2.0). This means that the BLER measurement cannot work correctly. In a subsequent release of the E1963A, the BLER measurement will not be supported for the 12.2k RMC + HSPA Channel Type.

_____________________________________________________________________________________________________

A.11.08 Release - July 2007

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963_A11_E6703_D02_T03_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Support for Band X (see Channel (UARFCN) Parameters ).
    • The range of the Transmit SIB5bis setting has been expanded to include Band X ( BAND10 ) and Standard Bands ( SBANds ). The default has changed from Bands IV & IX to Standard Bands (and the default value for the CALL[:CELL]:BCCHannel:SIB5:BIS command has changed from BAND49 to SBANds ).
  • If your test set includes the required hardware (see Hardware Requirements ) uplink Betac can now be set to 1 via the following settings:
    • Manual Uplink DPCH Bc
    • TCR Manual Uplink DPCH Bc
    • RBR Manual Uplink DPCH Bc
  • AWGN Power and External AWGN Power can now be 10 dB above or 20 dB below Cell Power or Cell 2 Power , and can be within 20 dB of each other (previously the limit was +/- 10 dB).
  • Changes have been made to accommodate 3GPP TS 25.331 v5.17.0 s8.6.6.28, which now specifies that the UE's behavior is undefined if the network sets the Timing Indication information element to Initialise on a non-hard handover (i.e. where the UARFCNs and one or more Primary Scrambling Codes remain unchanged as part of the reconfiguration).
    • New Auto setting is now the default value for the following parameters:
      • PCR Timing Indication (CFN Handling)
      • TCR Timing Indication (CFN Handling)
      • RBR Timing Indication (CFN Handling)

      Note, the default has thus also changed to AUTO for the following GPIB commands: , and .

    • Maintain is now the default value for the CM PCR Timing Indication (CFN Handling) setting (and thus also for the CALL:COMPressed:PCReconfig:CFNHandling command).
    • Downlink and uplink channels can now be changed while on a connection using a Transport Channel Reconfiguration or Radio Bearer Reconfiguration (previously channels could only be changed on a connection using a Physical Channel Reconfiguration). This allows you to perform a legal timing re-initialized Transport Channel Reconfiguration or Radio Bearer Reconfiguration, which allows you to change the DPCH Frame Offset to 0, 1, 2, 3, 4, or 5 x 512 chips while on a connection. For more information, see RB setup Timing Indication (CFN Handling): and Current DPCH Offset .
      • New TCR Channel (UARFCN) State , TCR Downlink Channel (UARFCN) , TCR Uplink Channel (UARFCN) and TCR Band Arbitrator settings.
      • New RBR Channel (UARFCN) State , RBR Downlink Channel (UARFCN) , RBR Uplink Channel (UARFCN) and RBR Band Arbitrator settings.
      • Channel (UARFCN) Information screen now includes TCR Info and RBR Info .
    • 34.121 Preset Call Configurations setting names have been updated to include 5.2AA, 5.2C and 5.13.2A. An additional feature license is required to enable this functionality in a licensed test application.

Transmitter Measurements

  • Inner Loop Power measurement enhancements:
    • Improved UE range time and new UE Range Time settings allow the Inner Loop Power measurement to execute more quickly.
    • The Inner Loop Power measurement can now measure power across a 30 dB dynamic range before needing to re-range (previously re-ranging was required every 13 dB). This allows the measurement to execute more quickly. Note, this improvement has specific Hardware Requirements .
  • Peak EVM, IQ Gain Imbalance and IQ Phase Imbalance results are now available from the Waveform Quality measurement, via GPIB command only (see Waveform Quality Measurement Description ).
  • New Dynamic Power Analysis 34.121 5.7A Measurement Configuration setting helps you quickly configure the measurement to perform 3GPP TS 34.121 5.7A from the front panel. This setting should be used in conjunction with the existing 34.121 Preset Call Configurations .

  • New Waveform Quality 34.121 5.13.1A Measurement Configurations help you quickly configure the measurement to perform 3GPP TS 34.121 5.13.1A from the front panel. These settings should be used in conjunction with the existing 34.121 Preset Call Configurations .

  • The Fast Device Tune measurement now supports Band VII (the range of the MS TX Frequency Step Values now includes 2502.4 to 2567.6 MHz, and the range of the MS RX Frequency Step Values now includes 2622.4 to 2687.6 MHz). See Fast Device Tune Measurement Description . Note, the band VII functionality has specific Hardware Requirements . An additional feature license is required to enable this functionality in a licensed test application.
  • The PRACH Transmit On/Off Power measurement's "Post Burst Off Power" range has been improved for test sets with the required hardware (see Hardware Requirements ). Previously the Post Burst Off Power was measured starting 100 µs after the end of the PRACH preamble burst. With the required hardware, the Post Burst Off Power is measured starting 25 µs after the end of the PRACH preamble burst. See PRACH Transmit On/Off Power Measurement Description .
  • New Extended Range Dynamic Power measurement (see Extended Range Dynamic Power Measurement Description ).

_____________________________________________________________________________________________________

A.10.19 Release - April 2007

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the A.10.17 Release - March 2007 .

A.10.17 Release - March 2007

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963_A10_E6703_D01_T01_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Support for HSDPA UE categories 7 and 8 (7.2 Mbps) in RB Test Mode. See HSDPA Information .
    • FRC Type can be set to H-Set 6 QPSK and H-Set 6 16QAM.
    • User Defined Number of Active HS-PDSCHs can be set up to 10.
    • Expanded range of RB Test Mode First HS-PDSCH Channel Code parameter to allow for 10 HS-PDSCHs.
    • Manual UE HS-DSCH Category can be set to 7 and 8.
  • Support for Band VII (see Channel (UARFCN) Parameters ). This functionality has specific Hardware Requirements .
  • New Transmit SIB5bis setting.
  • New SRB Configuration Control setting allows automatic configuration of the SRB for RMCs.
  • New CS/PS Domain setting for CN Domain allows establishing an HSDPA RB Test Mode connection with the RMC placed on the CS domain and the FRC placed on the PS Domain.
  • New Uplink 0k DTCH for HSDPA Loopback State parameter.
  • Uplink closed loop power control algorithm and step size can now be changed while on a connection, using a Physical Channel Reconfiguration. See Handover UL CL Power Ctrl Algorithm and Handover UL CL Power Ctrl Step Size .
  • New Uplink TFCI Control and Manual Uplink TFCI settings in FDD test operating mode.
  • All seven of the 34.121 Preset Call Configurations now include setting Maximum Uplink Transmit Power Level to +21 dBm.
  • Radio Bearer Reconfiguration supports handovers from CS/PS Domain HSDPA connections (see CN Domain ).
  • Changed all occurrences of "Handoff" to "Handover" on all screens (no changes to the associated GPIB commands).

Transmitter Measurements

  • Phase Discontinuity measurement now supports HSDPA. New HS-DPCCH Trigger Source and associated settings: HS-DPCCH Trigger Subframe Alignment , HS-DPCCH Trigger Slot Alignment , HS-DPCCH Trigger Subslot Alignment , HS-DPCCH Measurement Step Interval and HS-DPCCH Measurement Step Count .
  • The Fast Device Tune measurement is now supported on the RF OUT ONLY port, and includes a complete front panel user interface. See How Do I Make a Fast Device Tune Measurement? .
  • Waveform quality measurement now supports excluding transient periods on non-HSDPA connections. See Measurement Interval in Non-HSDPA Mode .
  • Inner Loop Power measurement now terminates as soon as an Unable to Cal: Power unstable condition is detected. See Inner Loop Power Troubleshooting . Also, the re-ranging algorithm has been improved to allow greater robustness in detecting UE failures around test set re-ranging periods.

Receiver Measurements

  • *RST setting for Trigger Arm changed to 0 (single) for Loopback BER , Block Error Ratio and HSDPA Block Error Ratio measurements. See SETup:WBERror:CONTinuous , SETup:WBLerror:CONTinuous and SETup:HBLerror:CONTinuous . Behavior of full preset from the front panel is unchanged (a front panel full preset still sets Trigger Arm to Continuous for these three measurements).

Other Features

  • The downlink HARQ0 trigger is transmitted every time data is transmitted by HARQ process 0 (which is every 12 ms when on an FRC). See Trigger Output Setup .

_____________________________________________________________________________________________________

A.10.12 Release - December 2006

Release has been delayed.

_____________________________________________________________________________________________________

A.09.06 Release - July 2006

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963A_A09_E6703C_C04_D00_T00.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

NOTE
The settable ranges for CALL:CHANnel and CALL:UPLink:CHANnel have changed due to changes in 3GPP TS 25.101. Some channels are no longer available. See the Requirements information at CALL:CHANnel and CALL:UPLink:CHANnel:CHANnel for more information.

  • New Current UE HS-DSCH Category .
  • New UE Category Parameters .
  • Support for 3GPP TS 25.101 v7.2.0 channel changes: addition of Band VIII and Band IX, renumbering of Band III and Band IV.
    • New DL Channel and Uplink Channel ranges.

      NOTE
      The settable ranges for CALL:CHANnel and CALL:UPLink:CHANnel have changed due to changes in 3GPP TS 25.101. Some channels are no longer available. See the Requirements information at CALL:CHANnel and CALL:UPLink:CHANnel:CHANnel for more information.

    • New Band Arbitrator setting (replaces Uplink Separation (Band) setting).
    • New Handover Band Arbitrator setting (replaces Handoff Uplink Separation (Band) setting)
  • New 34.121 Preset Call Configurations make it much simpler to configure the test set for 3GPP TS 34.121 HSDPA tests from the front panel.
  • New user defined downlink channel for HSDPA RB Test Mode (see User Defined Configuration of the HS-DSCH ) and HSDPA FDD Test Mode (see HS-DSCH Parameters ).
  • New FRC MAC-d PDU Size setting.
  • New Radio Bearer Reconfiguration allows handovers from a CS Domain HSDPA RB Test Mode connection to a (non-HSDPA) symmetrical RMC.
  • Physical Channel Reconfiguration now supported on HSDPA RB Test Mode connections.
  • System Handover now supported on CS domain HSDPA RB Test Mode connections.
  • Transport Channel Reconfiguration enhanced to include the following new parameters: TCR DPCH Bc/Bd Control , TCR Manual Uplink DPCH Bc , TCR Manual Uplink DPCH Bd , TCR Default DPCH Offset (DOFF) and TCR Relative DPCH Frame Offset .
  • Transport Channel Reconfiguration is now supported on an HSDPA RB Test Mode connection. New parameters added for HSDPA Transport Channel Reconfiguration: TCR DeltaACK , TCR DeltaNACK , TCR DeltaCQI , TCR Ack-Nack Repetition Factor , TCR CQI Feedback Cycle (k) , TCR CQI Repetition Factor , TCR Number of HARQ Processes , TCR UE IR Buffer Allocation and TCR Explicit UE IR Buffer Size .
  • New Current DPCH Offset .
  • New DPCH Frame Offset setting (FDD test operating mode only).
    This setting replaces the use of Default DPCH Offset (DOFF) in FDD Test operating mode (previously, you could use the Default DPCH Offset (DOFF) setting to control the DPCH Frame Offset in FDD Test mode; Default DPCH Offset (DOFF) is now only available in active cell operating mode).
  • New Network Mode of Operation setting. Previously Network Mode of Operation was signalled by the test set with a fixed value of 2. You may now set the value of this Information Element to either 1 or 2. Note, the default setting for Network Mode of Operation is 1, which is different from the fixed value previously sent by the test set.
  • New Paging Parameters menu replaces Paging IMSI on front panel Call Control 1 of 4 ( F4 ). The Paging Parameters menu includes Paging IMSI and the following settings which were moved from the Cell Parameters menu: CS Paging Identity Type , TMSI Assignment , TMSI and Repeat Paging .

Transmitter Measurements

  • New Fast Device Tune measurement (see Fast Device Tune Measurement Description ). An additional feature license is required to enable this functionality in a licensed test application. This feature does not require a feature license in the lab application. See www.agilent.com/find/8960upgrades for more information.
  • Waveform quality, code domain and IQ tuning measurements now support HSDPA (see Waveform Quality Measurement Description , Code Domain Measurement Description and IQ Tuning Measurement Description ). When Trigger Source is set to HS-DPCCH , many new settings and results are available.
    • Trigger Source range now includes HS-DPCCH .
    • New Transient Period setting.
    • New HS-DPCCH Trigger Subframe Alignment setting.
    • New HS-DPCCH Trigger Slot Alignment setting.
    • New HS-DPCCH Trigger Subslot Alignment setting.
    • New HS-DPCCH Measurement Interval setting.
    • New Beta hs-acknack and Beta hs-cqi results.
  • Phase discontinuity measurement enhancements (see Phase Discontinuity Measurement Description ).
    • New 18 up and 18 down settings for Power Control Pattern .
    • New peak EVM results (via remote access only). Previously only rms EVM results were available.

Other Features

  • Previously, the downlink HARQ0 trigger occurred every time data was transmitted by HARQ process 0 (which is every 12 ms when on an FRC). The downlink HARQ0 trigger is now only transmitted when the HARQ0 process is aligned with the 10 ms system frame clock (which is every 60 ms when on an FRC). See Trigger Output Setup .
  • New Thermal Power Null Adjustment .

_____________________________________________________________________________________________________

A.08.31 Release - January 2006

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963A_A0820_E6703C_C03_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

NOTE
The settable ranges for CALL:CHANnel and CALL:UPLink:CHANnel have changed. Some channels are no longer available. See the Requirements information at CALL:CHANnel and CALL:UPLink:CHANnel:CHANnel for more information.

  • Support for HSDPA in Active Cell Operating Mode (HSDPA RB Test Mode ). (An additional feature license is required to enable this functionality in a licensed test application. See www.agilent.com/find/8960upgrades for more information.)
  • GMM State is now available in the test application (previously it was only available in the lab application).
  • New Default DPCH Offset (DOFF) parameter.
  • New AMR RABs: 4.75k, 5.15k, 5.9k, 6.7k, 7.4k, 7.95k, and 10.2k (see AMR Setup ).
  • New PCR Activation Time parameter.
  • New RB Test Mode PCR Loopback Messaging State parameter.
  • New Asymmetric RMC Loopback Messaging parameter.
  • New Wait for RLC Ack of Handover From UTRAN parameter.
  • The underlying architecture of the External Device Connection feature (used to establish a Video Call ) has changed at this release. This implementation is not compatible with prior revisions of the External Device Connection . To establish an External Device Connection between two test sets, the test sets must have compatible firmware (see www.agilent.com/find/8960upgrades for more information). Note, an additional feature license is required to enable this functionality in a licensed test application.
  • Changed the formula used for calculating Initial DPCCH TX Power .

Transmitter Measurements

  • Dynamic Power Analysis: Dynamic range has been expanded to 35 dB (40 dB when RRC Filter = On ).

Receiver Measurements

  • Loopback BER: Confidence Level (1-F) is now fixed to 99.8% and Bad DUT Factor (M) is fixed to 1.5. These parameters are being fixed because 3GPP TS 34.121 Table F.6.1.8 specifies an F of 0.2% and Bad DUT Factor of 1.5 for all Receiver and Performance Characteristics tests in 34.121 sections 6 and 7 (except for the fail limit for 6.5, Blocking Characteristics). Also, the 34.121 early pass/early fail formulas are based on the parameter D, which is mapped to F in 3GPP TS 34.901 Table 6-1 for only a small set of values of F and M (including F=0.2% and M=1.5).

_____________________________________________________________________________________________________

A.08.09 Release - August 2005

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963A_A08_E6703C_C02_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Support for HSDPA in FDD test operating mode (see HSDPA in FDD Test Operating Mode ). (An additional feature license is required to enable this functionality in a licensed test application. See www.agilent.com/find/8960upgrades for more information.)
  • Support for Bands IV and V:
    • New DL Channel and Uplink Channel ranges.
      NOTE

      The settable ranges for CALL:CHANnel and CALL:UPLink:CHANnel have changed. Some channels are no longer available. See the Requirements information at CALL:CHANnel and CALL:UPLink:CHANnel:CHANnel for more information.

    • New Frequency Band Indicator State setting.
  • New Channel (UARFCN) Information screen.

Transmitter Measurements

  • Inner loop power measurement enhancements:
    • User-settable pass/fail limits (see Transmitter Power Control Pass/Fail Ranges ).
    • User-settable MaxPTT and MinPTT (see Test Thresholds and Tolerances ).
  • Dynamic power analysis measurement enhancements:
    • Support for HSDPA: new HS-DPCCH Trigger Source selection and HS-DPCCH Trigger Subframe Alignment setting, expanded Steps , Step Length , Measurement Interval , and Trigger Delay settings. (An additional feature license is required to enable this functionality in a licensed test application. See www.agilent.com/find/8960upgrades for more information.)
  • Channel power measurement enhancements:
    • Support for HSDPA: new HS-DPCCH Trigger Source selection and HS-DPCCH Trigger Subframe Alignment setting, expanded Trigger Delay and Measurement Interval settings. (An additional feature license is required to enable this functionality in a licensed test application. See www.agilent.com/find/8960upgrades for more information.)
    • New External Trigger Source selection.
  • Adjacent channel leakage ratio measurement enhancements:
    • Support for HSDPA: new HS-DPCCH Trigger Source selection and HS-DPCCH Trigger Subframe Alignment setting, expanded Trigger Delay setting. (An additional feature license is required to enable this functionality in a licensed test application. See www.agilent.com/find/8960upgrades for more information.)
  • Spectrum emission mask measurement enhancements:
    • Support for HSDPA: new HS-DPCCH Trigger Source selection and HS-DPCCH Trigger Subframe Alignment setting, expanded Trigger Delay setting. (An additional feature license is required to enable this functionality in a licensed test application. See www.agilent.com/find/8960upgrades for more information.)

Receiver Measurements

  • New HSDPA Block Error Ratio measurement - see HSDPA Block Error Ratio Measurement Description . (An additional feature license is required to enable this functionality in a licensed test application. See www.agilent.com/find/8960upgrades for more information.)

Other Features

  • Downlink subframe 0 (HARQ 0) trigger available at rear panel (see Trigger Output Setup ). (An additional feature license is required to enable this functionality in a licensed test application. See www.agilent.com/find/8960upgrades for more information.)

_____________________________________________________________________________________________________

A.07.25 Release - May 2005

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963A_A07_E6703C_C02_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Ability to page the UE using a TMSI - see CS Paging Identity Type , TMSI Assignment and TMSI .
  • BS release from RB Test Mode procedure now uses Open UE Test Loop message instead of Deactivate RB Test Mode message (see BS Release from Radio Bearer Test Mode in CELL_DCH ).
  • UL CL Power Control Mode can be set to Active in FDD Test Operating Mode . New FDD Test UL CL Power Ctrl Algorithm and FDD Test UL CL Power Ctrl Stepsize settings.
  • Uplink DPCH Bc/Bd Control , Manual Uplink DPCH Bc and Manual Uplink DPCH Bd are available in FDD Test Operating Mode .
  • New settings:
    • PCR Timing Indication (CFN Handling)
    • TCR Timing Indication (CFN Handling)
    • RB Setup Timing Indication (CFN Handling)

Transmitter Measurements

  • New TX Dynamic Power measurement. See TX Dynamic Power Measurement Description .
  • Spectrum Monitor enhancements: span and resolution bandwidth can now be set independently, new Detection Method . See Spectrum Monitor Description .

Other Features

  • New Restart on Fatal Error setting.

_____________________________________________________________________________________________________

A.06.17 Release - January 2005

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963A_A06_E6703C_C01_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Video Call (An additional feature license is required to enable this functionality in a licensed test application. This feature does not require a feature license in the lab application. See www.agilent.com/find/8960upgrades for more information.)
  • Asymmetrical RMCs .
  • New Uplink Separation (Band) setting.
  • RB Test Mode to GSM Handover Alerting State .
  • DRX Cycle Length (CN Domain) .
  • Cell Identity .
  • PS Domain Information .
  • UE timers: N313 Successive Out-Of-Sync Reception Max , T313 Out-Of-Sync Reception Timer , and N315 Successive In-Sync Reception Counter .
  • Trigger Output Setup .

Transmitter Measurements

  • Frequency Stability measurement (see Frequency Stability Measurement Description ).
  • Phase Discontinuity measurement enhancements (see Phase Discontinuity Measurement Description ):
    • New Power Control Pattern and Number of Pattern Repetitions settings.
    • Phase due to frequency errors of previous slots no longer removed when determining Phase (in degrees) result. Previously, each phase result was adjusted to remove the accumulated phase due to the frequency error of the previous timeslot. The phase result was, in effect, the accumulation of the phase discontinuity results. The Phase result is now equal to the phase estimate that results from the minimization of the EVM result for each slot.

Receiver Measurements

  • Loopback Bit Error Ratio measurement now supports confidence testing (see Loopback Bit Error Ratio (BER) Measurement Description ).
  • Block Error Ratio measurement now supports Asymmetrical RMCs (see Block Error Ratio (BLER) Measurement Description ).

Other Features

  • New Burst Mod Offset 1 Calibration . (This calibration is only needed if you are performing zero IF calibration of Qualcomm radioOne™ devices.)

_____________________________________________________________________________________________________

A.05.33 Release - July 2004

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Resolved Known Issues

  • Assert if partial preset is initiated while call status is Releasing .
  • Assert if UE initiates a release while the call status is Setup during a UE-initiated AMR voice call.
  • Test set-originated AMR voice call is dropped by UE if user does not answer the alert quickly enough.
  • Incorrect downlink CRC and DTCH block size configuration when Uplink DTCH RMC CRC Presence is set to Used for Data .
  • Test set does not send Open UE Test Loop message during release of RB test mode call.
  • Hard handover fails due to missing IE (related to Timing Indication) in Phys Chan Reconfig message.
  • AMR voice call origination fails due to incorrect extraction of security algorithm capability parameters.

_____________________________________________________________________________________________________

A.05.28 Release - April 2004

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963A_A0528_E6703B_B0129_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Summary of GPIB command changes for this release: GPIB Changes for E1963A A.05.20, E6703B B.01.20 - April 2004

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Support for 800 MHz channels (Band VI). See DL Channel , Uplink Channel and Physical Channel Reconfiguration .

Resolved Known Issues

  • Handoff and current UARFCNs not updated on failed handoff.

_____________________________________________________________________________________________________

A.05.16 Release - January 2004

The functionality present in the A.05.16 release is identical to that in the A.05.14 release (see A.05.14 Release - January 2004 and GPIB Changes for E1963A A.05, E6703B B.01 - December 2003 ).

_____________________________________________________________________________________________________

A.05.14 Release - January 2004

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963A_A05_E6703B_B01_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Summary of GPIB command changes for this release: GPIB Changes for E1963A A.05, E6703B B.01 - December 2003

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • New RB test mode Channel Types (see Radio Bearer Test Mode ):
    • 144k RMC
    • 33k No Coding RMC
  • Support for Loopback Type 2 (see UE Loopback Type ) and Uplink DTCH RMC CRC Presence .
  • Handoff changes:
    • New Transport Channel Reconfiguration capability (handoff to new RMC).
    • Ability to configure GSM cell from front panel of W-CDMA format for System Handover . System handoffs now accessible via new Handoffs menu.
    • New Physical Channel Reconfiguration menu for hard handoffs, accessible via new Handoffs menu.
  • GSM and inter frequency neighbor cell configuration (see SIB11 Cell Info List ).
  • UE reported measurements:
    • New UE Reported Measurements screen (see UE Reported Measurements and How Do I Order and Retrieve UE Reported Measurement Results? ).
    • New Report Measurement Type setting (see Cell 1/Cell 2 UE Reported Measurements ).
  • New Call Setup Screen layout:
    • Call Processing Status area includes new MM Status .
    • UE reported measurement results moved to new UE Reported Measurements screen.
  • New Maximum Uplink Transmit Power Level setting.
  • PRACH Signature mask functionality added to test application.
  • Uplink Interference default setting changed from -75 dBm to -110 dBm.

Transmitter Measurements

  • Phase Discontinuity. See Phase Discontinuity Measurement Description .
  • Dynamic Power Analysis. See Dynamic Power Analysis Measurement Description .
  • Autoranging for Waveform Quality, IQ Tuning and Code Domain Power. See Waveform Quality Measurement Description , IQ Tuning Measurement Description and Code Domain Measurement Description ).

Receiver Measurements

  • Loopback Block Error Ratio. See Block Error Ratio (BLER) Measurement Description .

_____________________________________________________________________________________________________

A.04.10 Release - July 2003

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963A_A04_E6703A_A02_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • AMR Voice service support. See AMR Setup and CALL:PAGing:SERVice[:TYPE] .
  • Support for 384k RMC in active cell operating mode. See Radio Bearer Test Mode and Channel Type .
  • BCCH Update Page field - If BCCH Update Page is set to Inhibit, when you change a parameter that causes a BCCH Update, the test set updates its BCCH information but does NOT send a Paging Type I message to the UE. See BCCH Update Page .
  • Downlink DTCH Data type "Incrementing." See DL DTCH Data .
  • Clear MS Info. See Clear UE Info .
  • Uplink Dummy DCCH Data support. See Uplink Dummy DCCH Data .

Transmitter Measurements

  • Loopback BER enhancements:
    • Loopback Delay result.
      See Loopback Delay and FETCh:WBERror:LDELay? .
    • CRC Errors result.
      See CRC Errors and FETCh:WBERror:CRCerrors? .
    • Missing Blocks result.
      See Missing Blocks and FETCh:WBERror:MBLocks? .
  • PRACH Transmit On/Off Power enhancements:
    • Open Loop Power Error Upper Limit.
      See Open Loop Power Error Upper Limit and SETup:WOOPower:OPEN:LOOP:POWer:UPPer:LIMit .
    • Open Loop Power Error Lower Limit.
      See Open Loop Power Error Lower Limit and SETup:WOOPower:OPEN:LOOP:POWer:LOWer:LIMit .

Other Features

  • Support for calibration of wireless devices that use Qualcomm's radioOne Zero Intermediate Frequency (Zero IF) architecture. See CW Operating Mode , How Do I Configure Test Signals in CW Operating Mode? , and CALL[:CELL[1]]:WAVeform:TYPE:CW .

_____________________________________________________________________________________________________

A.03.20 Release - February 2003

The reference guide for this release is available at the following web location. Note, this is a 12.9 MB .pdf file.

http://cp.literature.agilent.com/litweb/pdf/1000-1864.pdf

This firmware release provides you with improved call processing from the previous release, three new measurements (Inner Loop Power, PRACH Transmit On/Off Power, and IQ Tuning), and enhancements to the Spectrum Emission Mask and Occupied Bandwidth measurements. The newly added Spectrum Monitor instrument provides additional transmitter measurement functionality. Also, save/recall function is available in this release. By working with the E1968A test application, this revision allows to make an inter-system handoff from W-CDMA to GSM.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Support for inter-system hard handoff from W-CDMA to GSM. See Handovers for more information.
  • Support for user selectable "Registration" or "IMSI Attach". See Performing a Location Update (CS Domain Registration) .
  • Support for security operation control (security procedure with authentication and integrity protection). See Security Information .
  • Support for UE (mobile station) reported measurement results for current cell: DPCH BLER, CPICH RSCP, CPICH Ec/No, and Pathloss. See CALL:MS:REPorted:MEASurement:REQuest .
  • Support for user settable open loop power control parameters used to determine the initial transmit power of the first PRACH preamble. See Initial PRACH TX Power for more information.
  • Added 2.2k DCCH Signalling Radio Bear configuration for no RLC Reset during Radio Bear Setup. See Signalling Radio Bearer (SRB) Parameters for more information.
  • User settable power gain controls (beta-c and beta-d) for uplink channels (PRACH and DPCH). See Uplink Parameters .

Transmitter Measurements

  • Inner Loop PowerFor more information about this measurement, refer to Inner Loop Power Measurement Description .
  • PRACH Transmit On/Off PowerFor more information about this measurement, refer to PRACH Transmit On/Off Power Measurement Description .
  • IQ TuningFor more information about this measurement, refer to IQ Tuning Measurement Description .
  • Spectrum Emission MaskSupport for adjustable mask limits for each range. For more information, refer to Spectrum Emission Mask Measurement Description .
  • Occupied BandwidthSupport for adjustable percentage of total integrated power from 70.0 to 99.0%. For more information, refer to Occupied Bandwidth (OBW) Measurement Description .
  • Spectrum Monitor MeasurementThe Spectrum Monitor measurement feature has been added. This allows you to find, identify and measure transmitted signals from your UE (mobile phone). It can also be used for spur measurements in the transmit band. See Spectrum Monitor Description .

Other Features

  • Save/Recall

    This function allows you to store the test set's current settings to a register and retrieve them later, eliminating the task of reconfiguring the test set. See Save and Recall Registers .

_____________________________________________________________________________________________________

A.02.35 Release - August 2002

This firmware release provides you with improved call processing from the previous release.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • 64k RMC capability has been improved in both active cell and test mode.
  • Call limit state

    This allows you to make power measurements on PRACH preambles by not permitting the test set to respond. See Call Limit State for more information.

  • Expected values for open loop power control are now available on the display and via GPIB. See:
    • CALL:UPLink:DPCChannel:POWer:INITial?
    • CALL:UPLink:PRAChannel:POWer:INITial?
  • PRACH signature capability has been improved.

Measurements

  • Timing error is now returned in chips instead of seconds for the Waveform Quality and Code Domain measurements.

_____________________________________________________________________________________________________

A.02.20 Release - May 2002

The reference guide for this release is available at the following web location. Note, this is an 8.8 MB .pdf file.

http://cp.literature.agilent.com/litweb/pdf/1000-1844.pdf

This firmware release provides you with call processing, including base station originate, base station release, and closed loop power control, an additional reference measurement channel, 64k RMC, three new measurements, Spectrum Emission Mask, Occupied Bandwidth, and Code Domain Power, and enhancements to the Waveform Quality and Channel Power measurements. Also, a GPIB help mode exists in this firmware. This revision works with the E1985A fast switching test application.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Network initiated origination

    This allows you to originate a call from the test set. See CALL:ORIGinate .

  • Network initiated release.

    This allows you to end a call from the test set. See CALL:END .

  • Closed loop power control

    For more information, refer to Uplink Closed Loop Power Control Parameters and UE Target Power .

  • Support for a 64k Reference Measurement Channel (RMC) has been added in this release. Refer to CALL:DPCHannel:TYPe for more information.
  • Hard handoff capability is available in this release. Only handoffs to new downlink and uplink channels are supported. It is not possible to switch between the 12.2k and 64k RMC while on a call. A new command has been added to initiate the handoff. (See .)
  • UE reported information

    This command allows you to query the test set for information the UE has sent about its identification, power class, etc. For more information, refer to CALL:MS:REPorted .

  • Cell parameters that can be configured include the following:
    • Local Area Code (See CALL:LACode )
    • Mobile Country Code (See CALL:MCCode )
    • Mobile Network Code (See CALL:MNCode )
    • Repeat Paging (See CALL:PAGing:REPeat[:STATe][:SELected] )
  • New downlink signal parameters that can be configured:
    • AICH Channelizaton Code, Initial Channel Level (See CALL:AICHannel )
    • DPCH Initial Channel Level (See CALL:DPCHannel:LEVel )
    • P-CCPCH Initial Channel Level (See CALL:CCPChannel:PRIMary:LEVel )
    • S-CCPCH Channelization Code, Initial Channel Level (See CALL:CCPChannel )
    • CPICH Initial Channel Level (See CALL:CPIChannel )
    • PICH Channelization Code, Initial Channel Level (See CALL:PICHannel )
    • Connected Channel Level for P-CCPCH, S-CCPCH, CPICH, PICH, and DPCH (See CALL:CONNected )
    • Signaling Radio Bearer Channelization Code, Data Rate (See CALL:SRBearer )
  • Uplink signal parameters that can be configured:
    • Uplink Channel (See CALL:UPLink:CHANnel[:MCHannel] )
    • Uplink DPCH Scrambling Code (See CALL:UPLink:DPCHannel:SCODe )
    • PRACH Power Step (See CALL:UPLink:PRAChannel:POWer[:RAMP]:STEP[:LEVel]
    • PRACH Signature (See CALL:UPLink:PRAChannel:SIGNature )
    • PRACH Scrambling Code (See CALL:UPLink:PRAChannel:SCODe )
    • PRACH Timing Offset (See CALL:UPLink:PRAChannel:TIMing[:OFFSet]

Measurements

  • Spectrum Emission Mask

    For more information about this measurement, refer to Spectrum Emission Mask Measurement Description .

  • Occupied Bandwidth

    For more information about this measurement, refer to Occupied Bandwidth (OBW) Measurement Description .

  • Code Domain

    For more information about this measurement, refer to Code Domain Measurement Description .

  • The Waveform Quality measurement now makes timing error and peak code domain error available as measurement results. Support for immediate triggering for making asynchronous EVM measurements has been added. For more information, refer to the Waveform Quality Measurement Description .
  • The Channel Power measurement has been enhanced to allow you to turn the RRC filter on and off. For more information refer to SETup:WCPower:FILTer[:RRC] .

Other

  • Help Mode

    This release enables the HELP key on the test set's front panel. When in help mode, the test set provides GPIB syntax assistance. For more information, refer to Help Mode .

  • This release gives you the first revision of the W-CDMA Test Application that can be used with the E1985A GSM_136/AMPS_GPRS fast switching test application. This release when used with the E1985A GSM_AMPS/136_GPRS_WCDMA fast switching test application allows you to switch quickly between GSM, AMPS/136, GPRS, and W-CDMA formats.

    When writing program code for use with the E1985A, there are several parameters which require the format identifier, :WCDMA, to be appended. For details on these commands, refer to the user documentation for the GSM_AMPS/136_GPRS_WCDMA fast switching test application.

  • Measurements have to be recalibrated when you switch to the E1963A W-CDMA Test Application from the E1962B CDMA2000 Test Application of release revisions B.05 or lower.

_____________________________________________________________________________________________________

A.01.08 Release - November 2001 (Initial Test Application Release)

The reference guide for this release is available at the following web location. Note, this is a 6.5 MB .pdf file.

http://cp.literature.agilent.com/litweb/pdf/1000-1802.pdf

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

This release of the W-CDMA test application does not provide call processing. Therefore, call processing operations, such as base station origination (paging) and registration, are not available to establish a connection between the test set and the user equipment (UE).

A frequency division duplex (FDD) test mode is available to provide a downlink signal that a properly configured UE can synchronize to in order to transmit a corresponding uplink signal. The test set can then demodulate the uplink signal and make waveform quality and loopback bit error ratio measurements. See FDD Test Operating Mode for a description of this feature.

Transmitter Measurements

  • Thermal Power. This is an unfiltered, broad-banded power measurement that uses a thermal detector to measure the total power of all signals present at the test set's RF IN/OUT connector down to -10 dBm. Because of its high accuracy, this is the preferred power measurement for the Maximum Output Power test (3GPP TS 34.121, section 5.2, v3.2.0) to verify that the UE is transmitting at the correct level when transmitting at its highest output level. See Thermal Power Measurement Description .
  • Channel Power. This is a filtered power measurement that can be used to measure high level and low level signals within a 3.84 MHz bandwidth. This measurement is used in the Transmit Off Power test (3GPP TS 34.121, section 5.5.1, v3.2.0). It can also be used for calibrating mobile TX power. These tests require specific power levels to be measured within the 3.84 MHz channel bandwidth. See Channel Power Measurement Description .
  • Adjacent Channel Leakage Ratio. Power is measured within a 3.84 MHz bandwidth at +/-5 MHz and +/-10 MHz offsets from the center frequency. The measurement results can be displayed in either numeric and graphical formats. This measurement is defined in 3GPP TS 34.121, section 5.10, v3.2.0, Adjacent Channel Leakage Power Ratio (ACLR) , which verifies that the mobile station is not transmitting too much power outside of its 3.84 MHz channel bandwidth, which could interfere with other frequency channels. See Adjacent Channel Leakage Ratio (ACLR) Measurement Description .
  • Waveform Quality. This measurement returns the composite error vector magnitude (EVM), frequency error, origin offset, phase error, and magnitude error of the received signal. This measurement is used for the Error Vector Magnitude (EVM) test in 3GPP TS 34.121, section 5.13.1, and for the Frequency Error test in 3GPP TS 34.121, section 5.3, v3.2.0. These measurements verify the accuracy of the transmitter's modulation circuitry and RF source. For this FDD test mode release, this measurement can only be performed on a 12.2 kbps reference measurement channel (RMC) that is synchronized to the downlink signal from the test set. See Waveform Quality Measurement Description .

Receiver Measurements

  • Loopback bit error ratio (BER). This measurement uses the UE in loopback mode 1 to test the sensitivity of its receiver. The receiver sensitivity test is described in 3GPP TS 34.121, section 6.2, v3.2.0, Reference Sensitivity Level . When using the test set's FDD Test operating mode, the user must configure the UE in the loopback mode 1 to perform this measurement; no provision is made to send messages over the downlink signal to the UE to configure it. See Loopback Bit Error Ratio (BER) Measurement Description .

Other Features

Base Station Emulation in FDD Test Operating Mode

Base station emulation for this release is limited to sending a configurable downlink signal that the UE can synchronize to in order to transmit a corresponding uplink signal. The downlink does not send any commands to the UE to configure it for testing. All control of the UE must be provided by the user.

Downlink signal parameters that can be configured include the following settings:

  • Downlink channel codes:
    • Primary Scrambling Code
    • PICH Channelization Code
    • DPCH 12.2 RMC Channelization Code
  • Downlink channel levels:
    • FDD Test CPICH Level
    • FDD Test P-CCPCH/SCH Level
    • FDD Test PICH Level
    • FDD Test DPCH Level
  • Orthogonal Channel Noise Simulator - OCNS is automatically turned on and off, and the level set, as the downlink channel levels are changed.
  • Additive White Gaussian Noise (AWGN)
  • Downlink Transport Format Combination Indicator (TFCI)
  • Downlink channel
  • Downlink DTCH data type
  • Downlink PICH data pattern

Power control bit patterns can also be configured on the downlink. This allows you to vary the value being sent for the uplink closed loop power control data, and to send step up and step down power control sequences.

CW Operating Mode

CW operating mode provides an unmodulated RF generator signal with an adjustable level from -10 dBm to -127 dBm.


Adjacent Channel Leakage Ratio Troubleshooting

Adjacent Channel Leakage Ratio Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

  • During remote operation of the adjacent channel leakage ratio measurement, it is recommended that you configure the trigger arm to single. See SETup:WACLeakage . If the trigger arm is not set to single, you may not be able to retrieve measurement results during remote use if you are using the INIT:DONE? query. When the trigger arm is continuous, the measurement rearms itself and starts another measurement cycle, causing the INIT:DONE? query to always return "WAIT". See Trigger Arm (Single or Continuous) Description for more explanation.
  • The trigger source defaults to Auto for the adjacent channel leakage ratio measurement, and tries to use protocol triggering if the mobile station (UE) is synchronized to the test set. Immediate triggering is used if the mobile station is not synchronized. While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to Immediate or External .
  • Trigger Source can only be set to HS-DPCCH when Channel Type = 12.2k RMC + HSDPA or 12.2k RMC + HSPA .
  • The measurement results are the calculated ratios between the in-channel power and adjacent channels and are therefore not adjusted by any amplitude offsets that are entered.
  • Ensure that the measurement has been properly calibrated (see Adjacent Channel Leakage Ratio Measurement Calibration ).
  • Ensure that you are meeting the Adjacent Channel Leakage Ratio Input Signal Requirements .

Interpreting Integrity Indicator Values

This measurement uses auto-ranging to automatically set the expected level into the test set.

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. See Calibrating the Test Set .

See Integrity Indicator .

Related Topics

Adjacent Channel Leakage Ratio (ACLR) Measurement Description


AFANalyzer Troubleshooting

AFANalyzer Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

During remote operation of the Audio Analyzer, you should always set the Trigger Arm to Single. The length of time required to return a measurement over GPIB using continuous triggering varies, but is always longer than when using single triggering. Continuous triggering can also cause problems when the INITiate:DONE? query is used.

The Detector Type selected (peak or rms) also sets how Audio Level measurements are displayed; as a peak value or an rms value. When comparing returned values over GPIB to your specifications, be sure to take into account the type of detector being used.

The Expected Peak Voltage is always set in V peak , regardless of the Detector Type selected, and cannot exceed 20 V peak (14.1 V rms ).

For accurate measurements, always set all Audio Analyzer setup parameters to their proper settings for the measurement being made. The SINAD and Distortion measurements typically use different settings than the Audio Level measurement. See Audio Analyzer Measurement Description and Audio Analyzer Block Diagram .

For very low level audio signals, use the 100 Hz BW BPF filter to reduce the affects of noise (see Audio Level Measurement Description ).

For accurate Audio Frequency measurements where more than one signal may be present, use the 100 Hz BW BPF filter to isolate the desired signal (see Audio Level Measurement Description ).

Interpreting Integrity Indicator Values

See Integrity Indicator .

If over range (5) is returned, the input level is greater than 4.9 dB above the Expected Peak Amplitude value or the maximum input level of 20 volts peak.

If under range (6) is returned, the input level is lower than 8 dB below the Expected Peak Amplitude value.

If the signal has both over range and under range conditions, only the over range condition (5) is indicated.


Error Message Log

Error Message Log

Last updated: January 16, 2009

Description

When an error message is displayed, it is also logged in the error message log. This log is only accessible manually; it is not available through GPIB. The error message log can be displayed by pressing the F7 menu key from the SYSTEM CONFIG screen. Next Page and Previous Page controls are provided.

All errors and events that are generated are displayed in the error message log. When the log is full a new message is sent to the log and the oldest message is removed from the log. The log is cleared when the test set powers up or when you press F10 (Clear Error Message Log).

Related Topics

Error Messages


Troubleshooting Call Processing Operations

Troubleshooting Call Processing Operations

Last updated: January 16, 2009

  • Camping and Registration Troubleshooting
  • Call Establishment Troubleshooting
  • Other Call Processing Problems

Camping and Registration Troubleshooting

  • Call Limit must be OFF for any random access procedure such as Location Update or BS Origination (paging) to be successful. See Call Limit State .

  • UE Does Not Register with Test Set

    If your UE does not register with the test set, you may need to:

    • Set ATT (IMSI Attach) Flag State to Set , and then turn the UE's power off and on.
    • Increase the Cell Power level.
    • Change the Signalling Radio Bearer (SRB) Parameters to one that is supported by your UE.
    • Consider using the Agilent USIM, which is configured to match the test set's default configuration. See www.agilent.com/find/usim.
    • Ensure that DL Channel is set to a UARFCN that the UE supports, and that the proper Frequency Band Indicator is being transmitted by the test set (see Frequency Band Indicator State ).

  • UE Does Not Camp to Test Set at Low Cell Power Levels

    To determine whether to camp to a cell, the UE measures the CPICH RSCP for the cell, and then compares it to the minimum CPICH RSCP required to camp to the cell (the test set specifies a minimum CPICH RSCP of -115 dBm). If the UE's maximum transmit power is less than the Maximum Uplink Transmit Power Level specified by the test set, then the UE must subtract this difference from it's CPICH RSCP value before comparing it to the minimum requirement of -115 dBm. For example, if Maximum Uplink Transmit Power Level is set to +33 dBm, the UE's maximum transmit power is +24 dBm, and the UE measures a CPICH RSCP of -111 dBm, then it will not camp to the test set (-111 dBm - (33 dBm - 24 dBm) = -120 dBm, which is less than the minimum required level of -115 dBm). If Maximum Uplink Transmit Power Level were set to +24 dBm, then the UE would camp to the test set (-111 dBm is greater than the minimum required level of -115 dBm). To ensure that your UE will camp to the test set at low cell power levels, set Maximum Uplink Transmit Power Level to the maximum transmit power for your UE.

  • Test Set in Cell Barred List

    If Call Limit State is set to On and you page the UE, the test set will not respond to the UE's PRACH sequence. If the UE reaches the end of its sequence without an acknowledgment from the test set, it may place the test set into its cell barred list. (This may need to occur several times before the UE places the test set into its cell barred list). This means the UE will not look for the test set on its next attempt to camp to a base station. (After a certain amount of time, the UE will resume its consideration of the test set when trying to camp to a base station). If the test set has been added to the UE's cell barred list, you may need to:

    • Change the Local Area Code (LAC) of the test set.
    • Turn the UE off, then back on.
    • With the UE powered on, wait until the UE's cell barred timer expires (this can be as much as 20 minutes), such that it will then search for the test set when trying to camp.

  • UE Registers Continuously Due to Integrity Protection Expectation

    If the UE expects integrity protection to be enabled then it will continually attempt to register (as often as every 30 seconds) until the location update procedure successfully starts integrity protection. For integrity protection to be successfully started, the Security Operations setting must be 'Auth+Int' and the rest of the parameters on the Security Settings menu (excluding 'RAND') must match those in the uSIM. See Security Information .

Call Establishment Troubleshooting

  • Call Limit must be OFF for any random access procedure such as Location Update or BS Origination (paging) to be successful. See Call Limit State .

  • UE Does Not Connect to Test Set

    To successfully establish a call, you may need to:

    • Set RLC Reestablish to Off .
    • Set Uplink Timing Offset to match your UE PRACH signal's offset from the access slot.
    • Set RB Setup Timing Indication (CFN Handling) to Initialise . Note, most UEs do not require that this parameter be changed from its default value of Maintain . Some UEs may not connect to the test set if this parameter is set to Initialise . Also note that call establishment times will increase when RB Setup Timing Indication (CFN Handling) is set to Initialise .
    • Change the Signalling Radio Bearer (SRB) Parameters to one that is supported by your UE.
    • Consider using the Agilent USIM, which is configured to match the test set's default configuration. See www.agilent.com/find/usim.

  • UE Does Not Connect to Test Set (HSDPA)

    This section is only applicable to the lab application or feature-licensed test application.

    To successfully establish an HSDPA connection, you may need to:

    • Set RLC Reestablish to Off .
    • Set Uplink 64k DTCH for HSDPA Loopback State to On .
    • Ensure that the CN Domain and PS Domain Information settings are set properly. Before you can establish a connection in the PS domain (i.e. CN Domain set to PS Domain or CS/PS Domain ), the UE must have attached to the test set. To enable this, the PS Domain Information parameter must have been set to Present when the UE registered with the test set. Note that PS Domain Information is set to Absent by default in the Test Application (it is set to Present by default in the Lab Application).

    You must:

    • Set Channel Type to 12.2k RMC + HSDPA .

  • UE Does Not Connect to Test Set (HSPA)

    This section is only applicable to the lab application or feature-licensed test application.

    To successfully establish an HSPA connection, you may need to:

    • Set RLC Reestablish to Off .

    You must:

    • Ensure that PS Domain Information is set to Present before the UE registers with the test set ( PS Domain Information is set to Absent by default in the Test Application and to Present by default in the Lab Application).
    • Set Channel Type to 12.2k RMC + HSPA .

  • UE Does Not Respond to Test Set's Page

    • If your UE registers with the test set, but does not respond to the test set's page, try this alternate (and usually faster) test set-originated connection procedure:

      1. Connect the UE to the test set, but do not power it on.
      2. Set Operating Mode to Cell Off .
      3. Set Repeat Paging to On .
      4. Set ATT (IMSI Attach) Flag State to Set .
      5. Set Operating Mode to Active Cell .
      6. Select Originate Call and power on the UE.

      After the UE registers with the test set (performs a Location Update), rather than releasing the RRC connection, it will immediately move to connecting the RB test mode call as there is a page request outstanding.

    • If CS Paging Identity Type is set to TMSI , the UE must have a TMSI assigned to it before it will respond to the test set's page. The test set assigns a TMSI to the UE during the Location Update Procedure if TMSI Assignment is set to On before the Location Update Procedure is performed. The TMSI being used to page the UE must be the same as the TMSI assigned to it during registration (the TMSI setting must not have been changed between registration and paging).
    • You may need to change the Signalling Radio Bearer (SRB) Parameters to one that is supported by your UE.
    • Consider using the Agilent USIM, which is configured to match the test set's default configuration. See www.agilent.com/find/usim.

  • To establish an RB Test Mode call, you must set Paging Service to RB Test Mode and originate the call from the test set. You can not originate an RB Test Mode call from the UE.

  • Some UEs will automatically perform a PDP Context Activation if PS Domain Information is set to Present . If so, before establishing an RB Test Mode or AMR Voice call, you must first select End Call .

  • Call Setup Fails Due to Transmission of Single PRACH Preamble

    To aid in successful call completion, ensure that your UE does not begin its PRACH preamble sequence at the Maximum Uplink Transmit Power Level or its maximum transmit power (the maximum power it is physically able to transmit). If the UE supports early termination of the PRACH procedure, it will terminate the PRACH preamble sequence once it reaches the maximum transmit level for the cell (as specified by Maximum Uplink Transmit Power Level ) or is maximum transmit power. If a UE supporting early termination begins its PRACH transmission at either of these maximum levels, it will only transmit one PRACH preamble, causing the call setup procedure to fail (the test set requires two consecutive preambles before it will issue a positive indication on the AICH). See Initial PRACH TX Power .

Other Call Processing Problems

  • HSPA: To achieve 2 Mbps in the uplink with the downlink configured to H-Set 1 QPSK (534 kbps), set E-DCH RLC SDU Size to at least 4 x 2936 bits = 11744 bits. Note that you must also set RB Test Mode E-DPDCH Max Channel Codes = 2SF2 , grant the UE a large enough serving grant to allow this data rate, and ensure that the UE's transmit power is low enough that the HSUPA channels do not get scaled down.
  • HSPA: Once the HSPA connection is established if HSUPA Throughput = 0 kbps, initiate the Single Shot AG action and observe if throughput then becomes non-zero. There is a known issue in some UEs wherein they ignore the RB Setup AG value and use a zero grant upon call establishment.
  • HSPA: In order for the UE to receives commands from the test set on the E-RGCH, you must set RB Test Mode E-RGCH Information State and HSPA Cell 1 Connected E-RGCH Level to On (they are both set to off by default).
  • HSDPA: If you experience unexpectedly high HSDPA Block Error Ratio results ( lab application or feature-licensed test application only ), ensure that FRC Type is set to a configuration supported by your UE.
  • If you set a code channel state to Off (see Downlink Channel Levels Overview ), the test set will not automatically turn it back on if it is needed to perform a call processing operation you've requested (for example, if you set PICH Level to Off , the Originate Call procedure will fail).

Related Topics

Performing a Location Update (CS Domain Registration)


Cell Broadcast Service (CBS) Troubleshooting

Cell Broadcast Service (CBS) Troubleshooting

Last updated: September 14, 2011

Description

The Wireless Protocol Advisor (WPA) attempts to decode any messages as text when the Data Coding Scheme value is set to a value that corresponds to text. If the content of the CBS message being transmitted is data (not text), the WPA still attempts to decode the message as text which will not be accurate. You must ensure that Data Coding Scheme is set to an appropriate value.

In case CBS is not received by the UE due to certain broadcast messages confliction with the UE specific paging occasions (see detailed descriptions in 3GPP TS 25.304 section 6.2), use the following steps to ensure a successful reception:

  1. Configure the UE to receive CBS messages on channel 0
  2. Turn off the UE and remove the battery. This step is to help the UE out of an unknown and no-response state.
  3. Full preset the test set, and configure the cell parameters as below ( CALL SETUP -> Call Control 2 of 6 -> Cell info ( F2 )\ Cell Parameters ( F2 )). This is to ensure that the UE's paging occasions do not conflict with the CTCH allocation used for CBS message transfer.
    • DRX Cycle Length (CN Domain) to 512 frames
    • DRX Cycle Length (UTRAN) to 512 frames
    • CTCH Allocation Period to 20 frames
  4. Set the cell broadcast Repetition Period to 5 s ( CALL SETUP -> Call Control 4 of 6 -> Short Message Service ( F6 )-> Cell Broadcast ( F2 )-> Cell Broadcast Setup ( F5 ))
  5. Start the Cell Broadcast by pressing the Start Cell Broadcast button
  6. Turn on the UE and wait
  7. The UE should receive the first CBS message within 30 seconds

Related Topics

Cell Broadcast Service (CBS)


Fast Device Tune Troubleshooting

Fast Device Tune Troubleshooting

Last updated: January 16, 2009

This section is only applicable to the lab application or feature-licensed test application.

Possible Setup Issues

  • The measurement is not performed with a call established between the test set and mobile station (MS). Rather, you must place your MS into a test mode which forces it to transmit a predefined series of power steps at various frequencies, and forces it to simultaneously tune its receiver to perform measurements of the test set's signal (to determine CPICH RSCP, for example) at various frequencies and power levels. Note that the test set does not report the mobile station's measurement results (for example, CPICH RSCP). You must capture the mobile station's measurement results so that you can compare its measurements with the test set's actual transmission levels.
  • During front panel operation of this measurement, you must press the START SINGLE key to initiate the measurement.
  • Ensure that you have met the Fast Device Tune Input Signal Requirements .
  • This measurement is not supported on HSDPA or HSPA connections.
  • Before performing a fast device tune measurement, ensure that the measurement has been properly calibrated (see Calibrating the Test Set ).
  • The MS RX Power Sequence must include the same number of power steps as the MS TX Power Sequence, and the number of frequencies in the MS RX Frequency Sequence must match the number of frequency steps in the MS TX Frequency Sequence. If you do not want the MS to measure test set power at as many power levels or frequencies as you want the test set to measure from the MS, simply place "dummy" power levels or frequencies at the end of the MS RX Power Sequence and MS RX Frequency Sequence (for example, simply repeat the final power level or frequency). You can then ignore the mobile station's measurement results for these "dummy" points. Likewise, if you need more measurement points in the MS RX Frequency/Power Series than in the MS TX Frequency/Power Series, you can place "dummy" power levels and frequencies in the MS TX Frequency/Power Series, but note that the test set will still measure and report power for these "dummy" points. You must simply ignore these results.
  • To ensure successful triggering of the measurement, follow the instructions at Triggering the Fast Device Tune Measurement .
  • If you are running the measurement from the front panel, you must wait 2 seconds after initiating the measurement before instructing your mobile station to trigger the test set (if using the measurement remotely, you can use the INITiate:CFDTune:ARMed? query to determine that the measurement is ready; a separate wait statement is not required). To ensure that the test set triggered on the first transmission from the mobile, verify that the "Number of MS TX Power Steps Measured" returned by the FETCh:CFDTune[:ALL]? commands is equal to Number of Frequency Steps multiplied by Number of Power Steps .
  • Required initial conditions:
    • Operating Mode must be set to FDD Test .
    • Channel Type must be set to one of the Symmetrical RMCs (note, the measurement is not supported on the 12.2k RMC + HSDPA channel).
    • Power Control must be set to Manual .
    • Measurement Frequency must be set to manual control.
      To set Measurement Frequency to manual control from the front panel, press the OFF/MANUAL key. This sets Measurement Frequency to the last frequency value that this parameter was set to. The Fast Device Tune measurement ignores the specific value that Measurement Frequency is set to, so it can be set to any supported input frequency; the measurement simply requires that Measurement Frequency be in manual control mode.
    • RF Gen Freq Ctrl must be set to Manual .
    • AWGN Power must be Off .
    • This measurement is not supported on a faded channel ( lab application only , see Digital Bus Information ). ALC Mode must be set to Closed Loop before initiating the measurement.
    • You must configure the MS TX Frequency/Power Series to match the pattern of power levels to be transmitted by the MS and configure the MS RX Frequency/Power Series to match the pattern of power levels to be measured by the MS (and at the appropriate frequencies). Ensure that you have included the frequency retune steps in your mobile station's transmit/receive sequences (for example, the number of power steps you've configured your mobile to transmit should be equal to the Number of Power Steps setting + 1).
    • Your mobile station should be configured to measure the test set's signal 5 ms after the start of each step, to allow the test set's source to settle.
  • Ensure that you set the Measurement Timeout to a value great enough to allow you to command the MS to transmit its MS TX Frequency/Power Series and for the test set to measure the MS TX Frequency/Power Series. For example, measuring the maximum allowable number of 400 power points can take more than 10 seconds (400 steps plus the 19 re-tune steps: 419 x 20 ms = 8.4 seconds, plus ~ 2 seconds required for the measurement to prepare for triggering).
  • MS TX Power Step Start Index + Number of Power Steps and MS RX Power Step Start Index + Number of Power Steps must not exceed 40.
  • You must ensure that the range of power values selected by MS TX Power Step Start Index, MS RX Power Step Start Index and Number of Power Steps do not include any NANs (9.91E+37) or values that are outside of the input or output ranges for the current application format (considering the amplitude offset settings).
  • MS TX Frequency Step Start Index + Number of Frequency Steps and MS RX Frequency Step Start Index + Number of Frequency Steps must not exceed 40.
  • The frequencies indicated by MS TX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range. Likewise, the frequencies indicated by MS RX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range, but do not have to be in the same frequency band range as the MS TX Frequency Sequence. Ensure that none of the frequency values you've selected are NANs (9.91E+37)).
  • Note that if you specify fewer than 40 values for the following commands: SETup:CFDTune:MS:RX:FREQuency:STEP[:VALues] , SETup:CFDTune:MS:RX:POWer:STEP[:LEVels] , SETup:CFDTune:MS:TX:FREQuency:STEP[:VALues] and SETup:CFDTune:MS:TX:POWer:STEP[:LEVels] , the remaining values are set to NAN (9.91E+37).
  • Although you can enter any power levels for MS TX Power Step Levels between -129 and +80 dBm (because this measurement is common to the W-CDMA/HSDPA, 1xEV-DO and cdma2000 formats), when running the Fast Device Tune measurement in the W-CDMA/HSDPA application/format, you can only measure power levels in the range of -70 to +30 dBm and the measurement is only specified for power levels in the range of -61 to +28 dBm (these ranges assume an amplitude offset of 0; the ranges change as you change amplitude offsets, see Amplitude Offset ).
  • Although you can enter any frequencies for MS TX Frequency Step Values between 411 and 1980 MHz, when running the Fast Device Tune measurement in the W-CDMA/HSDPA application/format, you can only test frequencies within a single W-CDMA/HSDPA frequency band range:
    • 824 to 849 MHz (Bands V and VI)
    • 882.4 to 912.6 MHz (Band VIII)
    • 1712.4 to 1782.6 MHz (Bands III, IV and IX)
    • 1852.4 to 1907.6 MHz (Band II)
    • 1922.4 to 1977.6 (Band I)
  • Although you can enter any power levels for MS RX Power Step Levels between -165 and 37 dBm, when running the Fast Device Tune measurement in the W-CDMA/HSDPA application/format, the test set can only transmit test power levels in the range of -115 to -13 dBm ( RF IN/OUT ) or -115 to -5 dBm ( RF OUT ONLY ). These ranges assume an amplitude offset of 0; the allowable ranges change as you change amplitude offsets, see Cell Power, AWGN Power and Total RF Power Ranges .
  • Although you can enter any frequencies for MS RX Frequency Step Values between 421 and 2170 MHz, when running the Fast Device Tune measurement in the W-CDMA/HSDPA application/format, you can only test frequencies within a single W-CDMA/HSDPA frequency band range:
    • 871.4 to 891.6 MHz (Bands V and VI)
    • 925 to 960 MHz (Band VIII)
    • 1807.4 to 1877.6 MHz (Bands III and IX)
    • 1932.4 to 1987.6 MHz (Band II)
    • 2112.4 to 2167.6 (Bands I and IV)

Other Considerations

  • The Fast Device Tune measurement must re-range and re-trigger for every step in the MS TX Power Sequence. To ensure that this process is not interrupted by other operations, it is recommended that you not send any GPIB commands to the test set or press any front panel keys until the measurement has completed. If the measurement misses a trigger, it aborts and returns Integrity Indicator 30 : Missed Trigger .
  • No other measurements can be running when a Fast Device Tune measurement is performed. If any measurements are running when a Fast Device Tune measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while a Fast Device Tune measurement is running, the Fast Device Tune measurement is closed and a message is displayed.
  • Measurement results (and the RF generator output level) are affected by any RF IN/OUT Amplitude Offsets that are entered (see Amplitude Offset ).
  • The Fast Device Tune measurement results are currently only available via GPIB command (see FETCh:CFDTune ). Measurement results are not available on the front panel screen.

Related Topics

  • Fast Device Tune Measurement Description


Channel Power Troubleshooting

Channel Power Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

  • During remote operation of the channel power measurement it is recommended that you configure the trigger arm to single (see SETup:WCPower:CONTinuous ). If the trigger arm is not set to single, you may not be able to retrieve measurement results during remote use if you are using the INIT:DONE? query. When the trigger arm is continuous, the measurement rearms itself and starts another measurement cycle, causing the INIT:DONE? query to always return "WAIT". See Trigger Arm (Single or Continuous) Description for more explanation.
  • The trigger source defaults to Auto for the channel power measurement, and tries to use protocol triggering if the mobile station (UE) is synchronized to the test set. Immediate triggering is used if the mobile station is not synchronized. While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to Immediate or RF Rise .
  • RF Rise triggering should only be used when a burst is sent, such as a PRACH burst.
  • Trigger Source can only be set to HS-DPCCH when Channel Type = 12.2k RMC + HSDPA or 12.2k RMC + HSPA .
  • Measurement results are affected by any amplitude offsets that are entered. See Amplitude Offset .
  • The channel power measurement value may be slightly lower than the thermal power measurement's value (typically about 0.25 dB). This is because the channel power measurement is band-limited, rejecting the additional power that may be in the uplink signal's sidebands.
  • Ensure that the measurement has been properly calibrated (see Channel Power Measurement Calibration ).
  • Ensure that you are meeting the Channel Power Input Signal Requirements . If Auto Range is set to off, you must set the expected power level from the UE as described in Manual Power Range Offset . If Auto Range is on, the UE's output power must be stable in order for the autoranging algorithm to operate properly.
  • The RMSCubed results are only available when RMSCubed State is set to on.

Interpreting Integrity Indicator Values

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set. See Auto Range and Manual Power Range Offset .

If Under Range (6) is returned, the measured signal is below the expected input level.

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. See Calibrating the Test Set .

See Integrity Indicator .

Related Topics

Channel Power Measurement Description


Code Domain Troubleshooting

Code Domain Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

  • When on a non-HSDPA connection, you must set Trigger Source to any value other than HS-DPCCH .
  • Trigger Source can only be set to Even Frame when on an HSPA connection ( lab application or feature-licensed test application only ).
  • To measure code domain on an HSDPA connection, you must set Trigger Source to HS-DPCCH .
  • The sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval cannot exceed 1.0 slot. If you wish to place the measurement interval after the slot boundary using the HS-DPCCH Trigger Subslot Alignment setting, you must first decrease the HS-DPCCH Measurement Interval setting appropriately.
  • During remote operation of the code domain measurement, it is recommended that you configure the trigger arm to single. See SETup:WCDomain . If the trigger arm is not set to single, you may not be able to retrieve measurement results during remote use if you are using the INIT:DONE? query. When the trigger arm is continuous, the measurement rearms itself and starts another measurement cycle, causing the INIT:DONE? query to always return "WAIT". See Trigger Arm (Single or Continuous) Description for more explanation.
  • Your UE must be synchronized to the test set for this measurement to operate correctly.
  • RF In/Out Amplitude offsets entered do not affect these measurement results unless the received signal level becomes too low to accurately detect relative I/Q modulation vector transitions.
  • While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to Immediate or External .
  • Timing Error results are not available when Trigger Source is set to Immediate .

Other Considerations

  • Only Beta c (DPCCH) and Beta d1 (DPDCH 1) provide results (other than NaN) while on a non-HSDPA connection. Beta d2-6 are reserved for future use.
  • Beta hsacknak and Beta hscqi only provide results (other than NaN) when on an HSDPA connection ( lab application or feature-licensed test application only ).
  • When HS-DPCCH Trigger Slot Alignment is set to AckNack , a valid result is returned for Beta hsacknak , NaN is returned for Beta hscqi . Likewise, when HS-DPCCH Trigger Slot Alignment is set to CQI1 or CQI2 , a valid result is returned for Beta hscqi , NaN is returned for Beta hsacknak .
  • Beta ec , Beta ed1 , Beta ed2 provide results (other than NaN) when on an HSPA connection ( lab application or feature-licensed test application only ).

Interpreting Integrity Indicator Values

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Cannot Correlate (17) is returned, the test set cannot demodulate the signal from the mobile station (UE). Make sure the uplink scrambling code from the mobile station matches the UL Scrambling setting on the test set (see CALL:UPLink ).

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. See Calibrating the Test Set .

See Integrity Indicator .

Related Topics

Code Domain Measurement Description


Troubleshooting Compressed Mode Operation

Troubleshooting Compressed Mode Operation

Last updated: March 3, 2009

This section is only applicable to the lab application .

Possible Setup Issues

  • The test set supports compressed mode on the following connection types and channel configurations: RB Test Mode, HSDPA RB Test Mode, AMR voice, CS Data/Video Call, PS Data, and HSDPA PS Data. The 384k RMC is not supported as it is not compressible by spread factor reduction because the uplink 384k DPCH already uses the minimum DPCH spreading factor of 4. At this time, due to processor limitations, compressed mode is not supported on any 384k downlink channels.
  • The test set does not support compressed mode for the HSUPA RB Test Mode and HSUPA PS Data channel configurations.
  • The downlink DPCH channelization codes available during compressed mode are limited to those that would not cause collisions with other downlink channels during compressed frames. See Channel Types Supported in Compressed Mode and Valid Channelization Codes .
  • When you enable compressed mode with UE measurements, the test set sends a Measurement Control message to the UE which includes a list of cells to measure (the SIB11 cell info list for inter-frequency cells or for GSM cells, depending upon the Measurement Configuration setting). Thus, before enabling compressed mode with UE measurements, ensure that the cells in the SIB11 cell info lists are in a frequency band that is supported by your UE (some UEs will drop the connection if ordered to measure a cell in a frequency band they don't support).
  • 3GPP TS 25.331 v5.17.0 s8.6.6.28 states that the UE's behavior is undefined if the network sets the Timing Indication IE to Initialise on a non-hard handover (i.e. where the UARFCNs and one or more Primary Scrambling Codes remain unchanged as part of the reconfiguration). Thus, if you perform a Physical Channel Reconfiguration to enable/disable comprised mode with CM PCR Timing Indication (CFN Handling) set to Initialise , the UE may drop the call, ignore or reject the reconfiguration request, or report a reconfiguration failure. See Timing Indication (CFN Handling) for additional details.

Configuring the TGPSs (Transmission Gap Pattern Sequences)

  • See Key Considerations when Specifying the Transmission Gap Pattern Sequences
  • You must set at least one TGPS state to On before enabling compressed mode.
  • Some UEs do not support activating more than one TGPS with the same TG Measurement Purpose (TGMP) .

Retrieving UE Reported Measurement Results

  • To receive UE reported measurement results when compressed mode is enabled, ensure that UE Measurements in Compressed Mode is set to On , and that the Measurement Configuration setting matches the TG Measurement Purpose for at least one active TGPS.
  • The Measurement Control message sent to activate compressed mode can only contain one value for the MeasurementType information element, either interRATMeasurement (GSM cells) or interFrequencyMeasurement (W-CDMA cells). Thus, for a given compressed mode activation, the test set can only order the UE to measure either W-CDMA or GSM cells. For a given compressed mode activation you can include multiple TGPSs with FDD (W-CDMA) and GSM measurement purposes, but to change which type of cells are being measured by the UE you must disable compressed mode, change Measurement Configuration , then enable compressed mode.
  • Per 3GPP TS 25.331 s8.6.7.5, if GSM Meas BSIC Verification is set to verifiedBSIC , the UE will only report measurement results for cells for which it was able to decode the BSIC and match it to the NCC and BCC specified in the SIB11 GSM cell info list. If your UE does not support BSIC verification and you set GSM Meas BSIC Verification to verifiedBSIC , your UE will likely return empty Measurement Reports. If your UE supports BSIC verification you may still receive empty Measurement Reports when GSM BSIC Verification is set to verifiedBSIC if you do not include an active TGPS with a TG Measurement Purpose of GSM Initial BSIC ID or GSM BSIC Reconfirmation (see 3GPP TS 25.331 s8.6.7.6).
  • Depending upon your UE's compressed mode implementation, you may need to set GSM Meas BSIC Verification to verifiedBSIC before your UE will perform the Initial BSIC Identification or BSIC Reconfirmation procedures.
  • The GSM RSSI Measurement Reporting Quantity and Interfreq Measurement Reporting Quantity parameters determine how many Measurement Reports the UE returns. After the UE has returned the number of reports specified by these parameters, it stops reporting measurement results.

Operating Considerations

  • See Additional Considerations While in Compressed Mode Operation .
  • The test set supports compressed mode by spreading factor reduction in both the downlink and uplink. Note, however, that the test set does not transmit downlink compressed frames at an increased power level; compressed frames are transmitted at the same power level as non-compressed frames - the power level determined by the Cell Power setting.
  • Changing the Downlink Frame Structure Type setting does not change the structure of the downlink signal from the test set. Regardless of the Downlink Frame Structure Type setting, during compressed mode frames the test set sends the TPC field and pilot field in every slot (even the slots that occur during the transmission gap). Changing the Downlink Frame Structure Type setting only changes the frame structure signaled to the UE (which changes what the UE looks for during the downlink transmission gaps).
  • If TGPRC is non-zero, when the specified number of transmission gap pattern repetitions have occurred, the state of that TGPS changes from On to Off .
  • See Compressed Mode Operation While in FDD Test Operating Mode .

Related Topics

Compressed Mode


Troubleshooting External Device Connection

Troubleshooting External Device Connection

Last updated: March 20, 2009

This section is only applicable to the lab application and to a test application with the required feature license.

Description

  • When connecting two 8960s, it is recommended that you connect them via a hub (using the LAN 1 PORT and LAN 2 PORT on both 8960s), rather than through a gateway or WAN link, or connect them directly using a LAN crossover cable. This helps minimize the risk of lost data due to delayed packets.
  • Before initiating an external device connection between two 8960s, you can verify that the two test sets are able to communicate by pinging one test set from the other. To do so, on 8960 #1:
    • Press the Call Setup key, then the left More key until the Ping menu is available.
    • Select Ping , then Ping Setup ( F1 ).
    • Set Device to Ping to Alternate ( CALL:DATA:PING:SETup:DEVice ).
    • Set the Alternate Ping Address to the IP address of 8960 #2 ( CALL:DATA:PING:SETup:ALTernate:IP:ADDRess ).
    • Select Start Ping ( F3 ) ( CALL:DATA:PING:STARt ).
  • When you select Connect to External 8960 , if the External Device Conn Status moves from Not Connected through several other states ( Connecting/ Connected /Disconnecting ) and then immediately back to Not Connected , check both 8960s for an error condition. The 8960 to which you are attempting to connect may not have the hardware or license required for the External Device Connection feature, or may have incompatible firmware. (The underlying architecture of the External Device Connection feature has changed over time. The implementations are not compatible. To establish an External Device Connection between two test sets, the test sets must have compatible firmware (see www.agilent.com/find/8960upgrades for more information)).
  • Ensure that Ext 8960 IP Addr on the 8960 originating the connection is equal to the LAN IP Address of the 8960 you wish to connect to (the LAN IP Address of each 8960 is shown in the LAN Connection Information window of the External Device Connection Setup screen as LAN (Self) IP Address , and also viewable/settable from the Instrument Setup ( F1 ) menu of the System Config screen).
  • Ensure that Subnet Mask and Default Gateway are configured properly for each test set.
  • Ext 8960 IP Addr and Connected Device IP Address will always be equal on the display of the test set that initiated the external device connection. However, Ext 8960 IP Addr and Connected Device IP Address can be different on the test set that was connected to, as Ext 8960 IP Addr is only used when initiating an external device connection.
  • Ext 8960 IP Addr can not be set to the same value as LAN IP Address or DUT IP Address . If LAN IP Address is set to the value of Ext 8960 IP Addr , Ext 8960 IP Addr is reset to a blank field.
  • The external device connection is not affected by a partial preset. However, the external device connection is disconnected as a result of a full preset.

Related Topics

External Device Connection


Fixed Timer Messages

Fixed Timer Messages

Last updated: May 3, 2011

Description

This is the list of fixed timers with a brief explanation and their values. A timer expiry message appears in its own window, on the test set display. You have no access to these values and can not change them. None of the fixed timers are active when operating mode is FDD Test.

Fixed Timer Messages
Timer Name | Description | Value
T302 CELL UPDATE or URA UPDATE timer | Time the UE waits for reception of CELL UPDATE CONFIRM or URA UPDATE CONFIRM after CELL UPDATE or URA UPDATE is transmitted. | 400 ms
N302 CELL UPDATE or URA UPDATE retransmission counter | Maximum number of retransmissions of the CELL UPDATE or URA UPDATE message. | 1
T304 UE CAPABILITY INFORMATION timer | Time the UE waits for reception of UE CAPABILITY INFORMATION CONFIRM after UE CAPABILITY INFORMATION is transmitted. | 400 ms
N304 UE CAPABILITY INFORMATION retransmission counter | Maximum number of retransmissions of the UE CAPABILITY INFORMATION message. | 1
T307 Transition to Idle mode timer | Time the UE waits to detect "in service area" during an RRC state transition to Idle mode. | 50 seconds
T310 PUSCH capacity request repetition timer | Time the UE waits for reception of PHYSICAL SHARED CHANNEL ALLOCATION after PUSCH CAPACITY REQUEST is transmitted. | 320 ms
N310 PUSCH CAPACITY REQUEST retransmission counter | Maximum number of retransmissions of the PUSCH CAPACITY REQUEST message. | 5
T311 "PUSCH allocation assignment" timer | Time the UE waits for reception of a PHYSICAL SHARED CHANNEL ALLOCATION message with CHOICE "PUSCH allocation" set to "PUSCH allocation assignment" after A PHYSICAL SHARED CHANNEL ALLOCATION message with CHOICE "PUSCH allocation" set to "PUSCH allocation pending" is received. | 500 ms
T314 CS domain re-establishment timer | Time the UE waits for the Cell Update procedure to be complete after the criteria for CS domain radio link failure are fulfilled. | 0 seconds
T315 PS domain re-establishment timer | Time the UE waits for the Cell Update procedure to be complete after the criteria for PS domain radio link failure are fulfilled. | 0 seconds
T316 CELL UPDATE timer when "out of service" in URA_PCH or CELL_PCH | Time the UE waits for detection of "in service area" after "out of service area" is detected while in URA_PCH or CELL_PCH. | 50 seconds
T317 CELL UPDATE when re-entering "in service" timer | Time the UE waits for detection of "in service area" after "out of service area" is detected while in CELL_FACH or after expiry of T316. | Infinity


Error Messages

Error Messages

Last updated: January 16, 2009

Error Message Descriptions

Fixed Timer Messages

Manual User Error Messages

-400 through -499 Error Message Descriptions

-300 through -399 Error Message Descriptions

-200 through -299 Error Message Descriptions

-100 through -199 Error Message Descriptions

+100 through +199 Error Message Descriptions

+200 through +299 Error Message Descriptions

+300 through +399 Link Control Device-Specific Error

+400 through +499 Error Message Descriptions

+500 through +599 Test Application Hardware Device-Specific Error

+600 through +699 Error Message Descriptions

+700 through +799 Error Message Descriptions

+800 through +899 Error Message Descriptions

Description

Reading Error Messages

When an error occurs, an error message is shown in a message window at the center of the test set's display. When an error message is displayed, an audio beep occurs; the beeper state of the test set can be set to on or off. Error messages can be cleared from the test set's display using the DISPlay:WINDow:ERRor:CLEar command, or *CLS. Pressing any functional front panel key, i.e. the LOCAL key, will also clear an error message from the test set's display.

Each error message that is generated is recorded in either the error/event queue or the message log or both.

The error/event queue is read remotely using the SYSTem:ERRor? query. The error/event queue is able to hold 100 messages. The SYSTem:ERRor? query returns one error message at a time. As an error message is queried, it is removed from the error queue. To read the entire error/event queue (and thus also clear the error queue) use the following program.

10 DIM Err_msg$[255]
20 REPEAT
30 OUTPUT 714;"SYSTEM:ERROR?"
40 ENTER 714; Err_num,Err_msg$
50 PRINT Err_num,Err_msg$
60 UNTIL Err_num = 0

You can also clear the error queue by sending *CLS or *RST or by cycling the test set's power.

The message log may be viewed on the test set's display by pressing the SYSTEM CONFIG screen's Message Log key. The message log can display up to 24 entries over two pages. To clear the message log, select Clear Message Log ( F10 ), or cycle the test set's power.

Because the error queue and Message Log can be cleared independently, their contents may differ.

Classes of Errors

Error messages are divided into classes, each class of error is handled differently by the test set. The message log is cleared when the test set is power cycled.

Measurement Integrity Indicators

These messages occur as a result of a measurement, they indicate the validity of the measurement. Measurement integrity indicators are read with the FETCh command.

Non-Persistent Errors

These messages are generated when a condition occurs that is incorrect, but has no serious or long lasting effect on the test set's operation. Examples could include an out of range value to a parameter, or an invalid GPIB mnemonic. The message window is cleared when any front panel key is pressed.

Persistent Errors

These errors are generated when a non-transitory error condition exists. Persistent errors occur when a hardware failure is found, or when damage or injury to a person or the test set may occur.

The test set displays these errors in the error message window and as a prompt at the bottom of the display screen where it remains until the error condition no longer exists.

Fatal Errors

When these errors occur no further operation of the test set is possible without cycling the power switch. Fatal errors are not saved in the error message log. The test set display will provide the user with information about what to do next and some details about what the test set was doing when the fatal error occurred.

Maskable Messages

These messages are intended to inform the user of a condition within the test set. They are generally meant to provide information to the user. The user will need to decide if this condition is undesirable and if they want the message to appear.

Maskable Message Display State

The Maskable Messages Display State found in the Instrument Setup menu gives users a way to block these messages and the associated beep from ever happening. When the state is Off these messages and their associated beep will be blocked. The Maskable Message Display State can be set manually or with the following GPIB command:

OUTPUT 714;"DISPLAY:MESSAGE:MASKABLE:STATE OFF"
! Prevents certain messages from appearing on the display.

Instrument Maskable Messages

  • Instrument warning: Audio Generator instrument has been closed.
  • Instrument warning: Audio Analyzer instrument has been closed.
  • Instrument warning: Analog Audio instrument has been closed.

Related Topics

SYSTem:ERRor?


Manual User Error Messages

Manual User Error Messages

Last updated: January 16, 2009

Description

These messages are intended to be displayed on the manual user interface only, and are not entered into the Error/Event Queue.

Error Message | Description
The function you requested is not yet available. | The test set does not have this capability.
IQ Calibration completed successfully for modulator <N> | <N> is the IQ modulator number that you are attempting to calibrate, <N> is 1 or 2.
IQ Calibration failed for modulator <N> | <N> is the IQ modulator number that you are attempting to calibrate, <N> is 1 or 2.
The function you requested is not available in this TA. | This function is used in another Test Application.
IQ Calibration for modulator 1 in progress (10 minutes). Call processing disabled. | This error is cleared by either the; IQ Calibration completed successfully for modulator <N>, or IQ Calibration failed for modulator <N>.
IQ Calibration for modulator 2 in progress (6 minutes). Call processing disabled. | This error is cleared by either the; IQ Calibration completed successfully for modulator <N>, or IQ Calibration failed for modulator <N>.
Instrument warning: Audio generator instrument has been closed. | The audio generator instrument was closed automatically by the test set.
Measurement warning: Audio Analyzer instrument has been closed. | The audio analyzer instrument was closed automatically by the test set.
Measurement warning: Analog audio measurement has been closed. | Analog audio measurements have been closed by the test set.
Protocol warning: Setting change has terminated the link with the DUT | Some setting change has caused the call to disconnect.
Warning; Call processing disabled | The call processing functions are not active because the test set is performing calibration operations.
IQ first modulator calibration X% | IQ modulator calibration in progress, X represents the percent complete.
IQ second modulator calibration X% | IQ modulator calibration in progress, X represents the percent complete.

WCDMA and FDD Manual User Messages

Error Message | Description
WCDMA common measurements calibration completed successfully. | The calibration procedure for WCDMA measurements completed without problems.
WCDMA common measurements calibration failed due to temperature drift. Wait for temperature to stabilize. | The temperature in the test set was changing during calibration, causing the calibration to fail.
WCDMA common measurements calibration failed due to oven out of range. | Indicates an internal problem during measurement calibration.
WCDMA common measurements calibration failed due to loopback switch problem. | Indicates an internal problem during measurement calibration.
WCDMA common measurements calibration failed due to under range condition. | Indicates an internal problem during measurement calibration.
WCDMA common measurements calibration failed due to over range condition. | Indicates an internal problem during measurement calibration.
WCDMA common measurements calibration failed due to correlation problem. | Indicates an internal problem during measurement calibration.
WCDMA common measurements calibration failed. | The measurement calibration procedure failed for an unspecified reason.
WCDMA common measurements calibration in progress. Do not apply RF power during calibration | Tells you to not apply power during measurement calibration.
WCDMA common measurements calibration <x>%. | Progress indicator for the measurement calibration routine.
FDD measurement warning; Thermal Power measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict. This message is typically generated when thermal power measurements are initiated.
FDD measurement warning; Adjacent Channel Leakage Ratio measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict. This message is typically generated when adjacent channel leakage ratio measurements are initiated.
FDD measurement warning; Waveform Quality measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict. This message is typically generated when waveform quality measurements are initiated.
FDD measurement warning; Channel Power measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict. This message is typically generated when channel power measurements are initiated.
FDD measurement warning; Loopback Bit Error Ratio measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict. This message is typically generated when loopback bit error ratio measurements are initiated.
FDD measurement warning; Spectrum Emission Mask measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict. This message is typically generated when spectrum emission mask measurements are initiated.
FDD measurement warning; Code Domain measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict. This message is typically generated when code domain measurements are initiated.
FDD measurement warning; Occupied Bandwidth measurement has been closed. | Indicates that a measurement has been inactivated because of a resource conflict. This message is typically generated when occupied bandwidth measurements are initiated.


-100 through -199 Error Message Descriptions

-100 through -199 Error Message Descriptions

Last updated: January 16, 2009

Description

A command error indicates that the test set's GPIB parser has detected an IEEE 488.2 syntax error.

When one of these errors is generated, the command error bit in the event status register is set.

Error Message

Description

-100 Command error

This event bit (Bit 5) indicates a syntax error, or a semantic error, or a GET command was entered, see IEEE 488.2, 11.5.1.1.4.

-101 Invalid character

Indicates a syntactic elements contains a character which is invalid for that type.

-102 Syntax error

Indicates that an unrecognized command or data type was encountered. For example, a string was received when the device does not accept strings.

-103 Invalid separator

The parser was expecting a separator and encountered an illegal character. For example, the semicolon was omitted after a program message unit.

-104 Data type error

The parser recognized a data element different than one allowed. For example, numeric or string data was expected but block data was encountered.

-105 Get not allowed

Indicates a Group Execute Trigger was received within a program message. Correct the program so that the GET does not occur within the program code.

-108 Parameter not allowed

Indicates that more parameters were received than expected for the header. For example, *ESE common command only accepts one parameter, so *ESE 0,1 is not allowed.

-109 Missing parameter

Indicates that less parameters were received than required for the header. For example, *ESE requires one parameter, *ESE is not allowed.

-110 Command header error

Indicates an error was detected in the header. This error is used when the device cannot detect the more specific errors -111 through -119.

-111 Header separator error

Indicates that a character that is not a legal header separator was encountered while parsing the header.

-112 Program mnemonic too long

Indicates that the header contains more that twelve characters, see IEEE 488.2, 7.6.1.4.1.

  • - 113 Undefined header
  • - 113 Undefined header

  • Indicates the header is syntactically correct, but it is undefined for this specific device. For example, `XYZ' is not defined for any device.
  • Attempt to set value of the GPS RF Generator Frequency or Frequency 2 will result in this error

-114 Header suffix out of range

Indicates the value of a header suffix attached to a program mnemonic makes the header invalid.

-120 Numeric data error

This error, as well as errors -121 through -129, are generated when parsing a data element which appears to be numeric, including non-decimal numeric types. This particular error is used if the device cannot detect a more specific error.

-121 Invalid character in number

Indicates an invalid character for the data type being parsed was encountered. For example, an alpha in a decimal numeric or a "9" in octal data.

-123 Exponent too large

Indicates the magnitude of an exponent was greater than 32000, see IEEE 488.2, 7.7.2.4.1.

-124 Too many digits

Indicates the mantissa of a decimal numeric data element contained more than 255 digits excluding leading zeros, see IEEE 488.2, 7.7.2.4.1.

-128 Numeric data not allowed

Indicates that a legal numeric data element was received, but the device does not accept one in this position for the header.

-130 Suffix error

This error, as well as errors -131 through -139, are generated when parsing a suffix. This particular error message is used if the device cannot detect a more specific error.

-131 Invalid suffix

Indicates the suffix does not follow the syntax described in IEEE 488.2, 7.7.3.2, or the suffix is inappropriate for this device.

-134 Suffix too long

Indicates the suffix contain more than 12 characters, see IEEE 488.2, 7.7.3.4.

-138 Suffix not allowed

Indicates that a suffix was encountered after a numeric element that does not allow suffixes.

-140 Character data error

This error, as well as errors -141 through -149, are generated when parsing a character data element. This particular error message is used if the device cannot detect a more specific error.

-141 Invalid character data

Indicates that the character data element contains an invalid character or the particular element received is not valid for the header.

-144 Character data too long

Indicates the character data element contains more than twelve characters, see IEEE 488.2, 7.7.1.4.

-148 Character not allowed

Indicates a legal character data element was encountered where prohibited by the device.

-150 String data error

This error, as well as errors -151 through -159, are generated when parsing a string data element. This particular error message is used if the device cannot detect a more specific error.

-151 Invalid string data

Indicates that a string data element was expected, but was invalid, see IEEE 488.2, 7.7.5.2. For example, an END message was received before the terminal quote character.

-158 String data not allowed

Indicates that a string data element was encountered but was not allowed by the device at this point in parsing.

-160 Block data error

This error, as well as errors -161 through -169, are generated when parsing a block data element. This particular error message is used if the device cannot detect a more specific error.

-161 Invalid block data

Indicates a block data element was expected, but was invalid, see IEEE 488.2, 7.7.6.2. For example, and END message was received before the end length was satisfied.

-168 Block data not allowed

Indicates a legal block data element was encountered, but not allowed by the device at this point in parsing.

-170 Expression error

This error, as well as errors -171 through -179, are generated when parsing an expression data element. This particular error message is used if the device cannot detect a more specific error.

-171 Invalid expression

Indicates the expression data element was invalid, see IEEE 488.2, 7.7.7.2. For example, unmatched parentheses or an illegal character.

-178 Expression data not allowed

Indicates a legal expression data was encountered, but was not allowed by the device at this point in parsing.

-180 Macro error

This error, as well as error -181 through -189, are generated when defining a macro or execution a macro. This particular error message is used if the device cannot detect a more specific error.

-181 Invalid output macro definition

Indicates that a macro parameter place holder was encountered outside of a macro definition.

-183 Invalid inside macro definition

Indicates that the program message unit sequence, sent with a *DDT or a *DMC command, is syntactically invalid, see IEEE 488.2, 10.7.6.3.

-184 Macro parameter error

Indicates that a command inside the macro definition had the wrong number or type of parameters.


-200 through -299 Error Message Descriptions

-200 through -299 Error Message Descriptions

Last updated: January 16, 2009

Description

These errors are generated when something occurs that is incorrect in the current state of the instrument. These errors may be generated by a user action from either the remote or the manual user interface.

Error Message | Description
-200 Execution error | This event bit (Bit 4) indicates a PROGRAM DATA element following a header was outside the legal input range or otherwise inconsistent with the device's capabilities, see IEEE 488.2, 11.5.1.1.5.
-203 Command protected | Indicates that a legal password-protected program command or query could not be executed because the command was disabled.
-220 Parameter error | Indicates that a program data element related error occurred.
-221 Setting conflict | Indicates that a legal program data element was parsed but could not be executed due to the current device state.
-222 Data out of range | Indicates that a legal program data element was parsed but could not be executed because the interpreted value was outside the legal range defined by the devices
-223 Too much data | Indicates that a legal program data element of block, expression, or string type was received that contained more data than the device could handle due to memory or related device-specific requirements.
-224 Illegal parameter value | Indicates that the value selected was not part of the list of values given.
-225 Out of memory | The device has insufficient memory to perform the requested operation.
-226 Lists not the same length | Attempted to use LIST structure having individual LIST's of unequal lengths.
-230 Data corrupt or stale | Indicates invalid data, a new reading started but not completed since the last access.
-231 Data questionable | Indicates that measurement accuracy is suspect.
-233 Invalid version | Indicates that a legal program data element was parsed but could not be executed because the version of the data is incorrect to the device. For example, a not supported file version, a not supported instrument version.
-240 Hardware error | Indicates that a legal program command or query could not be executed because of a hardware problem in the device.
-241 Hardware missing | Indicates that a legal program command or query could not be executed because of missing device hardware. For example, an option was not installed.
-250 Mass storage error | Indicates that a mass storage error occurred. The device cannot detect the more specific errors described for errors -251 through -259.
-251 Missing mass storage | Indicates that a legal program command or query could not be executed because of missing mass storage.
-252 Missing media | Indicates that a legal program command or query could not be executed because of missing media. For example, no disk.
-253 Corrupt media | Indicates that a legal program command or query could not be executed because of corrupt media. For example, bad disk or wrong format.
-254 Media full | Indicates that a legal program command or query could not be executed because the media is full. For example, there is no room left on the disk.
-255 Directory full | Indicates that a legal program command or query could not be executed because the media directory was full.
-256 File name not found | Indicates that a legal program command or query could not be executed because the file name was not found on the media.
-257 File name error | Indicates that a legal program command or query could not be executed because the file name on the device media was in error. For example, an attempt was made to read or copy a nonexistent file.
-258 Media protected | Indicates that a legal program command or query could not be executed because the media was protected. For example, the write-protect switch on a memory card was set.
-270 Macro error | Indicates that a macro related execution error occurred.
-271 Macro syntax error | Indicates that a syntactically legal macro program data sequence, according to IEEE 488.2, 10.7.2, could not be executed due to a syntax error within the macro definition.
-272 Macro execution error | Indicates that a syntactically legal macro program data sequence could not be executed due to some error in the macro definition, see IEEE 488.2, 10.7.6.3.
-273 Illegal macro label | Indicates that the macro label was not accepted, it did not agree with the definition in IEEE 488.2, 10.7.3
-274 Macro parameter error | Indicates that the macro definition improperly used a macro parameter placeholder, see IEEE 4882, 10.7.3.
-275 Macro definition too long | Indicates that a syntactically legal macro program data sequence could not be executed because the string of block contents were too long for the device to handle, IEEE 488.2, 10.7.6.1.
-276 Macro recursion error | Indicates that a syntactically legal macro program data sequence count not be executed because it would be recursive, see IEEE 488.2, 10.7.6.6.
-277 Macro redefinition not allowed | Indicates that redefining an existing macro label, see IEEE 488.2, 10.7.6.4.
-278 Macro header not found | Indicates that a legal macro label in the *GMS?, see IEEE 488.2, 10.13, could not be executed because the header was not previously defined.


-300 through -399 Error Message Descriptions

-300 through -399 Error Message Descriptions

Last updated: January 16, 2009

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error. When one of these errors is generated, the device specific error bit in the event status register is set.

Error Message | Description
-300 Device specific error | This event bit (Bit 3) indicates that a device operation did not properly complete due to some condition, such as overrange see IEEE 488.2, 11.5.1.1.6.
-311 Memory error | Indicates some physical fault in the devices memory, such as a parity error.
-312 PUD memory lost | Indicates protected user data saved by the *PUD command has been lost, see IEEE 488.2, 10.27.
-313 Calibration memory lost | Indicates that nonvolatile calibration data used by the *CAL? command has been lost, see IEEE 488.2, 10.2.
-314 Save/recall memory lost | Indicates that the nonvolatile data saved by the *SAV command has been lost, see IEEE 488.2, 10.33.
-315 Configuration memory lost | Indicates that nonvolatile configuration data saved by the device has been lost.
-320 Storage fault | Indicates that the firmware detected a fault when using data storage. This is not an indication of physical damage or failure of any mass storage element.
-321 Out of memory | An internal operation needed more memory than was available
-330 Self test failed | Indicates a problem with the device that is not covered by a specific error message. The device may require service.
-340 Calibration failed | Indicates a problem during calibration of the device that is not covered by a specific error.
-350 Queue overflow | Indicates that there is no room in the queue and an error occurred but was not recorded. This code is entered into the queue in lieu of the code that caused the error.
-360 Communication error | This is the generic communication error for devices that cannot detect the more specific errors described for error -361 through -363.
-361 Parity error in program message | Parity bit not correct when data received for example, on a serial port.
-362 Framing error in program message | A stop bit was not detected when data was received for example, on a serial port (for example, a baud rate mismatch).
-363 Input buffer overrun | Software or hardware input buffer on serial port overflows with data caused by improper or nonexistent pacing.


-400 through -499 Error Message Descriptions

-400 through -499 Error Message Descriptions

Last updated: January 16, 2009

Description

A Query error is generated either when data in the instrument's GPIB output queue has been lost, or when an attempt is being made to read data from the output queue when no output is present or pending.

Error Message | Description
-400 Query error | This event bit (Bit 2) indicates that an attempt to read data from the Output Queues when no output is present or pending, to data in the Output Queue has been lost see IEEE488.2, 11.5.1.1.7.
-410 Query INTERRUPTED | Indicates the test set has been interrupted by a new program message before it finishes sending a RESPONSE MESSAGE see IEEE 488.2, 6.3.2.3.
-420 Query UNTERMINATED | Indicates an incomplete Query in the program see IEEE 488.2, 6.3.2.2.
-430 Query DEADLOCKED | Indicates that the Input Buffer and Output Queue are full see IEEE 488.2, 6.3.1.7.
-440 Query UNTERMINATED after indefinite response | Indicates that a query was received in the same program message after a query requesting an indefinite response was executed see IEEE 488.2, 6.5.7.5.


+100 through +199 Error Message Descriptions

+100 through +199 Error Message Descriptions

Last updated: January 16, 2009

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error.

These are general errors generated by the core instrument. When one of these errors is generated, the `+100 errors' bit in the questionable error status register is set.

Error Message

Description

+101 Assert; Cycle power. Assert message<message1>

<message1> will appear as:

;P:DSP T:<task ID> E:<error code> C:<error classif.> F1:<flag 1> F2:<flag 2> if the DSP generated the assert.

;P:Protocol T:<task ID> L:<line number> F:<file name> if the Protocol processor generated the assert.

;P:Host T:<task ID> L:<line number> F:<file name> if the Host processor generated the assert.

+102 Exception; Cycle power. Exception message<message2>

<message2> will appear as: T:<task ID> or V:<vector number> or PC:<program counter> or DA:<data adrs reg value>.

Vector number, program counter and data address register values are hexadecimal format.

+103 Failure; No measurements or settings can be made

Indicates none of the VI's are operational because a serious problem exists.

+104 Failure; No settling operations will take place

Indicates none of the VI's are operational because a serious problem exists.

+105 Failure; No measurements or setting can be made for the function selected

Indicates none of the VI's are operational because a serious problem exists.

+110 Input pacing; Internal communication queue overflow likely

Indicates that GPIB commands are too fast for the device input queue and should be slowed.

+111 Input pacing; Internal communication queue overflow imminent. Pacing increased

Indicates that GPIB commands were too fast and the device input queue has not kept pace.

+112 Internal error; Protocol error <message3>

<message3> is an eight digit hexadecimal number that is the error code reported by protocol.

+113 Internal error; <VI NAME> forced inactive

Indicates that a VI is inactivated when not executed.

<VI NAME> includes: "IntVmVI","GprsBsEmulVI", "GsmComBsEmulVI","GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI", "TdmaTaBsEmulVI".

+114 Internal error; <VI NAME> not responding

Indicates that a VI has not been instantiated or the state is not available.

<VI NAME> includes: "IntVmVI","GprsBsEmulVI", "GsmComBsEmulVI", "GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI", "TdmaTaBsEmulVI", "RfHwAccessVI".

+115 Internal error; <VI NAME> inactive

Indicates that a VI has been made inactive.

<VI NAME> includes: "IntVmVI", "GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI".

+120 Warning; Receiver over range due to requested settings

Indicates the total received power (a combination of received power and amplitude offset) is above the range of the test set.

+121 Warning; Receiver under range due to requested settings

Indicates the total received power (a combination of received power and amplitude offset) is below the range of the test set.
+122 Warning; Reference out of lock

Indicates the test set's internal reference is out of lock.

+123 Warning; Duplicate RF IN/OUT Amplitude Offset Frequency entry. First frequency entry in RF IN/OUT Amplitude Offset table will be used.

Indicates that an amplitude offset value for that frequency has already been entered. The test set will use the amplitude offset value entered first.

+124 Warning; Source over range due to requested settings

The setting selected for total transmit power (a combination of cell power, AWGN power, amplitude offset) is above the test set's range.

+125 Warning; Source under range due to requested settings

The setting selected for total transmit power (a combination of cell power, AWGN power, amplitude offset) is below the test set's range.

+126 Warning; Data out of range error for system time, system date, time zone, UTC time or UTC date due to user input error or couplings between these settings

  • +236 Call operation rejected; Called MS is not responding
  • +236 GSM/GPRS operation rejected, Attempting to set NMO while generating a BCH

+127 Warning; Impairments backoff (IBO) over range due to settings made under external software control

+129 Configuration warning: License will expire soon

The temporary license is about to expire. This message will give the license number and the number of days before it is scheduled to expire.

+130 Configuration error; Unable to switch to indicated Test Application

The test application selected is not available for this test set.

+131 Configuration error; Current Test Application is not licensed (License = N). Select another Test Application

The test application selected is not licensed. Select another revision or test application that is licensed (License = L).

+132 Configuration error; Selected Test Application Format is not available.

Indicates that the fast switching operation will not activate a particular radio format. Check the revision number of the test application associated with the radio format, does the revision correspond with what the fast switching test application needs?
+133 Configuration error; Selected Test Application Format is not licensed, (License = N).

The radio format selected is not licensed. Select another revision or obtain a licensed revision of the test application test application that is licensed (License = L).

+134 Configuration error; Unable to switch to selected Test Application Format

The Test Application Format name used is correct but for some reason the test set can not switch to that format.

+137 Configuration error; The license has expired for the selected format

When a license expires you must switch applications by pressing the SYSTEM CONFIG key and then selecting Format Switch (F2) or Application Selection (F3).

+138 Configuration error; Selected format is not licensed due to unexpected system time change

 This message is displayed when a temporary license expires due to a change occurring to system time.

+139 Configuration error; Functionality is not available

+140 Operation rejected; Command is not supported in this operating mode

+141 Operation Rejected; A Measurement Is Currently Controlling This Setting. | An attempt has been made to access a setting that is being controlled by a measurement.

  • +142 Configuration error; Functionality not available
  • +142 Operation rejected; Functionality is not available in the selected partition; GPS

  • An attempt has been made to access lab application functions from a test application.
  • Selecting `GPS' when in format other than GGE, C2K, 1xev-DO and WCDMA, e.g. AMPS/IS136, shall result in this error message.

+143 Operation Rejected; Selected measurement is not available in the current measurement selection list

An attempt has been made to access a measurement that is not available in the current application.

+144 Operation rejected; PC connection not established

+145 Operation rejected; Feature is not licensed. See www.agilent.com/find/8960upgrades for additional information

The feature you are attempting to access is not licensed in your test set. Visit www.agilent.com/find/8960upgrades to find out how to acquire the required license.

+146 Operation rejected; External 8960 connection feature is not licensed. See www.agilent.com/find/8960upgrades for additional information

The external 8960 connection feature requires a license in a test application. Visit www.agilent.com/find/8960upgrades to find out how to acquire the required license.
+146 FDD operation rejected; HSDPA is not licensed. See www.agilent.com/find/8960upgrades for additional information | The HSDPA feature requires a license in a test application. Visit www.agilent.com/find/8960upgrades to find out how to acquire the required license.
+147 Help is enabled. Select a field to display the GPIB syntax. For additional help refer to www.agilent.com/find/8960 and select "8960 Online User's Guides".

+147 FDD operation rejected; HSPA feature is not licensed. See www.agilent.com/find/8960upgrades for additional information

+148 Operation rejected; Setting is currently under external control

+149 Warning; Running a partially qualified version of the application

+150 Operation rejected; LAN IP address 2 cannot be the same as the instrument LAN address

+151 Operation rejected; LAN IP address 2 must be on the same subnet as the instrument

+152 Warning; LAN IP address 2 cleared to 0.0.0.0 due to an instrument LAN address or subnet mask change

+153 Operation rejected; Even number of hexadecimal digits is required

+ 154 Operation rejected; An application is currently controlling this setting; <application>

 <application> could be <1xEV-DO Multicarrier>

+160 Save/Recall error; File operation error

 Occurs if there is any disk read or write problems when trying to save, recall or delete a register.

+161 Save/Recall error; Recalling available (empty) register

 Occurs if an attempt is made to recall any register that has not been saved.
+162 Save/Recall error; Functionality is not yet available for current application. | Occurs when an attempt to save a save/recall register while using an application that has not implemented this feature.

+163 Save/Recall error; Functionality is not yet available for current application

+170 Warning; RF source 1 ALC mode set to closed due to requested setting

+171 Warning; 8960 has been restarted after a non-recoverable error occurred.

Occurs when the instrument has completed its power up sequence after restarting due to a fatal error.


+200 through +299 Error Message Descriptions

+200 through +299 Error Message Descriptions

Last updated: November 9, 2010

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error.

When one of these errors is generated, the +200 errors bit in the questionable error status register is set.

+200 through +299 Error Messages

Error Message

Description

+201 WCDMA call processing error; No Response to RRC Connection Setup

No "RRC Connection Complete" message was received from the UE. However, the BS Origination process is allowed to proceed.
+202 WCDMA call disconnected; No Response to RRC Connection Release

No "RRC Connection Release Complete" message was received from the UE. However, the BS Release process is allowed to proceed.
+203 WCDMA call processing error; No Response to Activate RB Test Mode

No "Activate Radio Bearer Test Mode Complete" message was received from the UE. However, the BS Origination process is allowed to proceed.
+204 WCDMA call processing error; No Response to De-Activate RB Test Mode

No "De-Activate Radio Bearer Test Mode Complete" message was received from the UE. However, the BS Release process is allowed to proceed.
+205 WCDMA call processing error; No Response to Close UE Test Loop

No "Close UE Test Loop Complete" message was received from the UE. However, the BS Origination process is allowed to proceed.

If this error occurs during a Transport Channel Reconfiguration , the UE did not send the Close UE Test Loop Complete message to the test set within 6 seconds. The test set will terminate the procedure.
+206 WCDMA call processing error; No Response to Radio Bearer Setup

No "Radio Bearer Setup Complete" message was received from the UE. However, the BS Origination process is allowed to proceed.

If this error occurred during a reconfiguration, see Troubleshooting Handovers .
+207 WCDMA call processing error; No response to Radio Bearer Release

+208 WCDMA call processing error; No response to Identity Request

The test set did not receive an identity response message from the UE. However, the Location Update process is allowed to proceed.
+209 WCDMA Call Disconnected. No Signal Found on Uplink DPCH

The test set could not find a valid DPCH signal within 2 seconds of sending the "RRC Connection Setup" message during a BS Origination procedure.

If this errors occurs during a Physical Channel Reconfiguration , the test set could not find a valid DPCH signal within 5 seconds of sending the Physical Channel Reconfiguration message. The call status is returned to idle.

If this error occurs during an External 8960 Handover , the destination test set (configured as a W-CDMA/HSPA cell) could not find a valid DPCH signal within 5 seconds of being notified of an incoming external handover. The call status is returned to idle.
+210 WCDMA Call Disconnected; Signal Lost on Uplink DPCH

The test set determined that a link failure occurred due to loss of synchronization with the embedded pilot in the uplink DPCH.

If this error occurred during a handover, see Troubleshooting Handovers . If it occurred during enabling/disabling compressed mode, see Troubleshooting Compressed Mode Operation .
+211 Call Disconnected; No Response to registration request. | The call is dropped by the test set as a result of the UE not responding to a registration request message.
+212 WCDMA Call Disconnected. Max No. RLC Retransmissions Exceeded. Starting RLC Reset Proc | The single RLC retransmission attempted by the test set is not acknowledged by the UE.
+213 WCDMA Call Disconnected; RLC Reset Procedure failed

The single RLC retransmission request from the test set resulted in a second incorrectly received PDU.
+214 FDD call operation rejected; Change not allowed in Active Cell Mode

+214 WCDMA call operation rejected; Change Not Allowed in Active Cell Mode | This setting can not be changed by the user while the Cell Operating Mode is "Active Cell".

+215 Call Disconnected; No Response to Page

The test set did not receive either a valid PRACH preamble or the "RRC Connection Request" message within 2 seconds.
+216 Call disconnected; Called MS did not answer

+216 WCDMA call operation rejected; UL power control is active

+217 Call Disconnected; Unexpected Call Release By the External Device

This error is posted on the 8960 connected to the UE that originated the Video Call if the call between the receiving UE and its 8960 is unexpectedly released (for example, if the RF cable is disconnected).

+217 FDD warning; Performance not specified for UL/DL frequency offset < 30 MHz

Performance is not specified when the difference in the uplink and downlink frequencies is less than
30 MHz.

The following known issue exists in some revisions of the W-CDMA/HSDPA applications: this warning is erroneously returned for some uplink/downlink separations greater than 30 MHz; please ignore this warning unless the uplink/downlink separation is less than 30 MHz.
+218 Call Disconnected; Signal With The External Device Has Been Lost | This error is returned if during a Video Call , a message from one UE to the other is not received even though there is a valid External Device Connection between the two 8960s.

+218 FDD Settings Deferred: AWGN power > +10 or < -20 dB relative to cell power

+220 FDD call operation rejected; UL Power Control is active

Step up or step down TPC bit patterns can not be sent when uplink closed loop power control is active.

+221 FDD Settings Deferred: Test mode channel power levels sum to > +0.03 dB

The sum of the code channels cannot exceed +0.03 dB. Reduce one or more channel levels.
+222 WCDMA call processing error; No Physical Channel Reconfiguration Complete

The uplink DPCH is found but the appropriate "Reconfiguration Complete" message is not received from the UE after a sending a physical channel reconfiguration. However, the test set assumes the reconfiguration was successful and attempts to maintain the connection. If this error occurred during a handover, see Troubleshooting Handovers . If it occurred during enabling/disabling compressed mode, see Troubleshooting Compressed Mode Operation .

+223 FDD settings deferred; Initial Active Cell code channel power levels sum to > +0.03 dB

The sum of the code channels cannot exceed +0.03 dB. Reduce one or more channel levels.

+224 FDD Settings Deferred: One or more code channel power levels > 30 dB below total RF power

The power of at least one code channel is more than 30 dB below the total RF power, exceeding the test set's limits.

+225 FDD settings deferred; One or more Initial Active Cell code channel power levels > 30 dB below total RF power

The power of at least one code channel is more than 30 dB below the total RF power, exceeding the test set's limits.

+226 FDD settings deferred; Connected Active Cell code channel power levels sum to > +0.03 dB

The sum of the code channels cannot exceed +0.03 dB. Reduce one or more channel levels.

+227 FDD settings deferred; One or more Connected Active Cell code channel power levels > 30 dB below total RF power

The power of at least one code channel is more than 30 dB below the total RF power, exceeding the test set's limits.
+229 WCDMA call disconnected; Setup aborted

+230 FDD settings deferred; External AWGN power > +10 or < -20 dB relative to cell power

+230 Call operation rejected; Action not possible

+231 FDD settings deferred; AWGN power and External AWGN power > 20 dB apart

+231 Call operation rejected; Call processing in progress

+232 Call operation rejected; Protocol request ignored

+232 FDD settings deferred; Test Mode HSDPA code channel power levels sum to > +0.03 dB

The sum of the code channels cannot exceed +0.03 dB. Reduce one or more channel levels. See HSDPA in FDD Test Operating Mode and Downlink Channel Levels .
+233 Call operation rejected; External 8960 has an invalid configuration for the requested end-to-end service | This error is returned when attempting to establish a Video Call with an 8960 that is not properly configured to receive the video call (the 8960 must be in active cell operating mode, and in the idle state). The call with the originating UE is disconnected.
+233 WCDMA call processing error; No response to Authentication Request

+234 Call operation rejected; Called MS is not responding | This error is returned when attempting to establish a Video Call if the 8960 receiving the page request sends a page message to its UE and the UE does not respond. The connection to the originating UE is released.
+234 WCDMA call processing error; Security Mode not completed

+235 WCDMA call processing error; No CC Call Confirmed received from the UE

+235 Call operation rejected; The external device has an invalid configuration for the requested service

+236 WCDMA Call processing error; No CC ALerting received from the UE
+236 Call Disconnected; Called MS Did Not Answer | This error is returned while attempting to set up a Video Call , if during the alerting phase of the call setup procedure the called UE does not answer. The connections to both UEs will release.
+237 WCDMA call processing error; No CC Connect received from the UE

+238 WCDMA call processing error; No CC Release received from the UE

+239 Operation rejected; Starting ping not allowed with current configuration

+239 FDD call operation rejected; Requested change would cause the channelization code of the last HS-PDSCH to be greater than 14. Decrease the first HS-PDSCH channelization code before changing the FRC Type

To set the channelization codes for the HS-PDSCHs, you must specify the FDD Test First HS-PDSCH Channelization Code . The second HS-PDSCH is then assigned the FDD Test First HS-PDSCH Channelization Code + 1, etc. An HS-PDSCH may not be assigned to channelization code 15. This error occurs if you select an FRC Type that, paired with the current FDD Test First HS-PDSCH Channelization Code setting, would cause an HS-PDSCH to be assigned to a channelization code of 15. See HSDPA in FDD Test Operating Mode .

+240 Operation rejected; Attempting to send SMS submit report after timer TR2N expired

There are network (TR2N) and mobile station (TR2M) timers associated with the return of a SMS-SUBMIT-REPORT message. You should ensure that the time taken to respond to a SMS-SUBMIT message when using MANUAL mode is well within the limits of these timers (by at least a couple of seconds). If a request to send an SMS-SUBMIT-REPORT is received at the test set outside these time constraints, the message will not be sent to the mobile station.

+240 FDD call operation rejected; Channelization code is already in use on another HS-SCCH

Each HS-SCCH must be assigned to a different channelization code. See HSDPA in FDD Test Operating Mode and Downlink Channel Codes .

+241 Operation rejected; Attempting to send SMS submit report while mode set to Auto

+241 FDD call operation rejected; The first HS-PDSCH channelization code and FRC type would yield a value greater than 14 for the last HS-PDSCH channelization code

To set the channelization codes for the HS-PDSCHs, you must specify the FDD Test First HS-PDSCH Channelization Code . The second HS-PDSCH is then assigned the FDD Test First HS-PDSCH Channelization Code + 1, etc. An HS-PDSCH may not be assigned to channelization code 15. This error occurs if you select an FDD Test First HS-PDSCH Channelization Code that, paired with the current FRC Type setting, would cause an HS-PDSCH to be assigned to a channelization code of 15. See HSDPA in FDD Test Operating Mode .

+242 Operation rejected; Attempting to send SMS status report while mode set to Auto

+242 FDD settings deferred; One or more Test Mode HSDPA code channel power levels > 30 dB below total RF power

The power of at least one code channel is more than 30 dB below the total RF power, exceeding the test set's limits. See HSDPA in FDD Test Operating Mode and Downlink Channel Levels .

+243 Operation rejected; Too many outstanding requests, could not send SMS message

+243 WCDMA Call Operation Rejected; Handover To GSM Requires A Multi-Format Application With Both GSM And WCDMA.

+244 FDD call processing error; No response to Active Set Update

+245 FDD call processing error; Active Set Update Failure occurred

+246 FDD settings deferred; Connected Active Cell HSDPA code channel power levels sum to > +0.03 dB | See Downlink Channel Levels .
+247 FDD settings deferred; One or more Connected Active Cell HSDPA code channel power levels > 30 dB below total RF power | See Downlink Channel Levels .
+248 WCDMA call processing error; No response to Activate PDP Context request

+249 WCDMA protocol failure; UE reported protocol error occurred

+250 Protocol failure; Unknown error

+250 WCDMA call processing error; UE Event Measurement Control Failure Occurred | The UE returned a Measurement Control Failure. If this occurs during activation of compressed mode, then compressed mode is still activated, but UE measurements have not been properly enabled.
+251 WCDMA call processing error; PDP Context rejected

+251 Warning; DUT's request for the primary DNS server address has been ignored because the setting does not currently contain a valid IP address

See DUT IP Setup .
+252 FDD settings deferred; Cell 1 power and Cell 2 power > 10 dB apart

+252 Warning; DUT's request for the secondary DNS server address has been ignored because the setting does not currently contain a valid IP address

See DUT IP Setup .
+253 FDD settings deferred; AWGN power > +10 or < -20 dB relative to cell 2 power

+253 Warning; DUT's request for primary and secondary DNS server addresses has been ignored because both of the settings do not contain valid IP addresses

See DUT IP Setup .
+254 FDD settings deferred; Cell 2 Active Cell code channel power levels sum to > +0.03 dB

+255 FDD settings deferred; One or more Cell 2 Active Cell code channel power levels > 30 dB below total RF power

+256 WCDMA call processing error; Authentication failed

+256 FDD settings deferred; External AWGN power > +10 or < -20 dB relative to cell 2 power

+258 FDD warning; RLC behavior not compliant to 3GPP specifications if 3.4k or 13.6k SRB is used

+259 WCDMA call operation rejected; Invalid DUT IP address

+260 WCDMA call processing error; No response to CC connect

+261 WCDMA call disconnected; Bearer Capability Not Supported | If this error occurs during CS Data operation, the UE has requested an unsupported rate or configuration. See Circuit Switched Data Service .
+262 WCDMA call processing error; No response to CC Release

+263 WCDMA call processing error; No response to CC Reject

+264 WCDMA call processing error; No response to CC Disconnect

+265 WCDMA call processing error; UE periodic Measurement Control Failure occurred

+266 FDD call operation rejected; Change Allowed Only When Call Status Is Idle

+267 FDD call operation rejected; Step size 2 is not allowed when in Algorithm 2 mode

+268 WCDMA call processing error; No response to CM Service Accept

+270 WCDMA call processing error; No response to Deactivate PDP Context request

+271 WCDMA call operation rejected; Inter-System Handover only allowed while in RB Test Mode service

+272 WCDMA call operation rejected; Inter-System Handover only allowed with RMC Channel Types

+273 WCDMA call processing error; Attach not completed

+274 WCDMA call processing error; Security Mode failed

+275 WCDMA warning; Measurement Not Available in This Configuration | If this error occurs when trying to run the loopback BER or loopback BLER measurement, ensure that you have properly set Uplink DTCH RMC CRC Presence and UE Loopback Type .
+276 WCDMA call disconnected; No Response To Open UE Test Loop Message

This error occurs during a Transport Channel Reconfiguration if the UE does not send the Open UE Test Loop Complete message to the test set within 3 seconds. The test set will continue with the procedure.

This error occurs during a BS release if the UE does not send the Open UE Test Loop Complete message to the test set within 3 seconds. The BS release proceeds. See BS Release from Radio Bearer Test Mode in CELL_DCH .
+277 WCDMA call processing error; Transport Channel Reconfiguration Message Not Received From The UE. | This error occurs during a Transport Channel Reconfiguration if the UE does not send the Transport Channel Reconfiguration Complete message to the test set within 6 seconds. The test set will drop the connection. See Troubleshooting Handovers: Transport Channel Reconfiguration .
+278 FDD call operation rejected. Functionality Not Yet Supported In Current Service Type.

You must be on an RB test mode call to perform a Transport Channel Reconfiguration . You must be on an RB test mode or AMR Radio Access Bearer call to perform a GSM handover (see System Handover ).
+279 WCDMA call processing error; No response to RLC Poll

+280 FDD call operation rejected; Compressed Mode Can Only Be Activated When in Connected Mode | You can not enable compressed mode until the test set and UE are on a 12.2k RMC call in RB test mode.
+281 FDD call operation rejected; Compressed Mode Not Supported In This Service Type or RAB | You can not enable compressed mode until the test set and UE are on a 12.2k RMC call in RB test mode.
+282 FDD call operation rejected; Compressed Mode Not Supported In This Channel Type | You can not enable compressed mode until the test set and UE are on a 12.2k RMC call in RB test mode.
+283 FDD call operation rejected; Compressed Mode Not Active | This is returned if you try to disable compressed mode when it is not active.
+284 FDD call operation rejected; Parameter Cannot Be Changed While Compressed Mode Is Active | If TGPS Definition During Call Setup is set to Off , then the TGPS Parameters can only be configured if Compressed Mode State is Off (so that the transmission gap definition can then be provided to the UE when compressed mode is subsequently activated).
+285 FDD call operation rejected; When TGPS Is Defined Via Call Setup This Parameter Can Only Be Changed When Call Status Is Idle | If TGPS Definition During Call Setup is set to RB Setup , then you can only configure the TGPS Parameters when the call status is Idle (so that the transmission gap definition can then be provided to the UE when the call is subsequently established).
+286 FDD call operation rejected; Invalid Compressed Mode Parameter (Gap In First Frame Is Too Long) | A single frame must not have more than one gap, and a gap in any one frame must not exceed 7 slots. (14 - TGSN) > 7 and TGL1 > 1 not allowed.
+287 FDD call operation rejected; Invalid Compressed Mode Parameter (Gap In Second Frame Is Too Long) | A single frame must not have more than one gap, and a gap in any one frame must not exceed 7 slots. TGL1 - (14 - TGSN) > 7 not allowed.
+288 FDD call operation rejected; Invalid Compressed Mode Parameter (Two Gaps In Same Frame) | A single frame must not have more than one gap, and a gap in any one frame must not exceed 7 slots. TGPL1 < 2 and TGL1 > (14 - TGSN) not allowed.

+289 FDD call operation rejected; Operation not supported in CELL_FACH state

+290 FDD call processing error; Physical Channel Reconfiguration Failure Message Received From UE

The UE returned a Physical Channel Reconfiguration Failure message instead of a Physical Channel Reconfiguration Complete message. If this occurs during activation of compressed mode, then compressed mode is not activated. If this occurs when compressed mode is already enabled, then compressed mode is deactivated. If this occurs during deactivation of compressed mode, then compressed mode is left activated.

If this error occurred during a handover, see Troubleshooting Handovers . If it occurred during enabling/disabling compressed mode, see Troubleshooting Compressed Mode Operation .
+291 FDD call processing error; No Response To Physical Channel Reconfiguration

The UE did not respond to the Physical Channel Reconfiguration message. If this occurs during activation of compressed mode, then compressed mode is still activated in the test set at the signaled CFN, and the Measurement Control message is still sent to the UE (if you have set Compressed Mode Meas - UE Setup to On).

If this error occurred during a handover, see Troubleshooting Handovers . If it occurred during enabling/disabling compressed mode, see Troubleshooting Compressed Mode Operation .
+292 FDD call processing error; Layer 1 reported Compressed Mode Failure

+293 FDD call processing error; Received Compressed Mode Measurement Control failure

+294 FDD Call Operation Rejected; CFN Must Be Aligned To A 40 ms Boundary | The starting CFN mod 4 must be 0.
+295 FDD call operation rejected; Compressed Mode Not Supported on This Channel Code (Only Supported on 20, 29, 37, 45, 60, 70, 76, 87 & 93) | Compressed mode can only be activated when the DPCH channelization code is 20, 29, 37, 45, 60, 70, 76, 87 or 93. Any other channelization codes could potentially cause compressed frames to collide with other downlink channels.
+296 FDD call operation rejected; Calculated UL Channel is invalid. With UL Channel not set to Auto, set DL Channel and UL Separation to a valid combination, then set UL Channel to Auto

+297 FDD call operation rejected; Calculated Handover UL Channel is invalid. With Handover UL Channel not set to Auto, set Handover DL Channel and Handover UL Separation to a valid combination, then set Handover UL Channel to Auto

+297 Operation rejected; Attempting to send SMS message while operating mode is not active cell

+298 FDD call operation rejected; Functionality not yet supported on an asymmetric RMC

+299 WCDMA call processing error; No response to Location Updating Accept | This error is returned if the UE has been assigned a TMSI in the Location Updating Accept message (see Location Update (Registration) Procedure ) and it does not transmit a TMSI Reallocation Complete message within 6 seconds.


+300 through +399 Link Control Device-Specific Error

+300 through +399 Link Control Device-Specific Error

Last updated: November 1, 2010

These errors are generated when a problem occurs in maintaining the link between the test set and a DUT. These errors generally occur when a message is received from the DUT that is unexpected.

When one of these errors is generated, the `+300 errors' bit in the questionable error status register is set. Refer to Standard Event Status Register for information on this register.

+300 through +399 Error Messages
Error Message | Description
+320 WCDMA call processing error; Point-to-Point SMS is not supported over a CS domain while connected on a PS service

See Short Message Service (SMS) .
+321 WCDMA call processing error; Point-to-Point SMS is not supported over a PS domain while connected on a CS service

See Short Message Service (SMS) .
+322 FDD warning; A value of less than 0 dB for Sintrasearch will be interpreted by the UE as 0 dB | Sintrasearch can be set to any even number value between -32 dB and +20 dB, but any negative value will be interpreted by the UE as 0 dB.
+323 FDD warning; A value of less than 0 dB for Sintersearch will be interpreted by the UE as 0 dB | Sintersearch can be set to any even number value between -32 dB and +20 dB, but any negative value will be interpreted by the UE as 0 dB.

+324 FDD call operation rejected; Primary H-RNTI cannot be the same as the Alternate H-RNTI

See Primary H-RNTI (Hex) and Alternate H-RNTI (Hex) .

+324 Warning; SMS message queue overflow, last received message has been discarded

See Short Message Service (SMS) .
+325 WCDMA warning; UE did not report an HS-DSCH category. Configuring the channel based on the value of the manual UE HS-DSCH category

See UE Reported HS-DSCH Category .

+326 WCDMA warning; UE reported an unsupported HS-DSCH category. Configuring the channel based on the value of the manual UE HS-DSCH category

See UE Reported HS-DSCH Category .

+327 WCDMA warning; UE's request for the primary DNS server address has been ignored since the setting does not currently contain a valid IP address

See DNS Server IP Addresses .

+328 WCDMA warning; UE's request for the secondary DNS server address has been ignored since the setting does not currently contain a valid IP address

See DNS Server IP Addresses .

+329 WCDMA warning; UE's request for primary and secondary DNS server addresses has been ignored since both of the settings do not contain valid IP addresses

See DNS Server IP Addresses .

+333 FDD call operation rejected; Soft handover is not available while HSDPA is active

See HSDPA in Active Cell Operating Mode .

+334 FDD warning; Soft handover is not available while HSDPA is active

See HSDPA in Active Cell Operating Mode .

+335 FDD call operation rejected; UE reported measurements are not available while HSDPA is active

See HSDPA in Active Cell Operating Mode .

+336 FDD warning; UE reported measurements are not available while HSDPA is active

See HSDPA in Active Cell Operating Mode .

+337 FDD call operation rejected; Transport channel reconfiguration not available while HSDPA is active

See HSDPA in Active Cell Operating Mode .
+338 FDD call operation rejected; CTCH allocation period cannot be greater than 4096 - CBS frame offset

See CTCH Allocation Period .

+339 FDD call operation rejected; CTCH allocation period must be greater than CBS frame offset

See CTCH Allocation Period .

+340 FDD call operation rejected; CQI feedback cycle must be greater than or equal to CQI repetition factor * 2 ms

See CQI Transmission Settings .

+341 WCDMA warning; Power reduction specified in the CQI table will not be applied

See PS Data Configuration Type .

+342 WCDMA call operation rejected; WCDMA to GSM handoff is not available while HSDPA is active

See HSDPA in Active Cell Operating Mode .

+343 WCDMA call operation rejected; Physical channel reconfiguration is not available while HSDPA is active

See HSDPA in Active Cell Operating Mode .

+344 FDD call operation rejected; Requested operation will push the DPCH offset outside of its 0 to 38400 chip range

See Current DPCH Offset .

+344 WCDMA warning; PCT External Controller Connected

See CALL:PPRocedure:PCTest:EXTernal:CTRL:STATe

+345 FDD call operation rejected; Cannot reconfigure to the selected TCR RAB while on an HSDPA call

See Transport Channel Reconfiguration .

+346 FDD call operation rejected; An HSDPA call must be active in order to reconfigure to the selected TCR RAB

See Transport Channel Reconfiguration .

+347 FDD warning; The UE HS-DSCH category is not capable of receiving 16QAM modulation

See User Defined Configuration of the HS-DSCH .

+348 FDD warning; The UE HS-DSCH category is not capable of inter-TTI values less than 3

See User Defined Configuration of the HS-DSCH .

+349 FDD warning; The UE HS-DSCH category is not capable of inter-TTI values less than 2

See User Defined Configuration of the HS-DSCH .

+350 FDD warning; The total IR buffer size required for explicit configuration exceeds the available IR buffer size for UE category

See User Defined Configuration of the HS-DSCH .

+351 FDD warning; The current transport block size exceeds the maximum capability for UE category

See User Defined Configuration of the HS-DSCH .

+352 FDD call operation rejected; Functionality not supported on PS domain

+353 FDD call operation rejected; Functionality is available only when the call status is connected

+354 FDD call processing error; UE rejected Cell Change Order From UTRAN message

This error is generated if the UE rejects a Cell Change Order from W-CDMA/HSPA to GSM/GPRS/EGPRS when PDP Context Active. See Two-Cell Test System .

+355 FDD call processing error; UE reported Cell Change Order From UTRAN failure

This error is generated if during a Cell Change Order from W-CDMA/HSPA to GSM/GPRS/EGPRS when PDP Context Active, the UE reports a Cell Change Order from UTRAN Failure. The originating test set attempts to maintain the connection. See Two-Cell Test System .

+356 FDD operation rejected; Functionality is not available while a connection between 2 UEs is active

This error is generated if a UE-to-UE Video Call is active when the Execute Ext 8960 Handover immediate action is attempted. See Two-Cell Test System .

+357 FDD call processing error; UE rejected Handover from UTRAN message

This error is generated if the UE rejects a handover from W-CDMA/HSPA to GSM/GPRS/EGPRS when the call status is connected. See Two-Cell Test System .

+358 FDD call processing error; UE reported Handover from UTRAN failure

This error is generated if during a handover from W-CDMA/HSPA to GSM/GPRS/EGPRS when the call status is connected, the UE reports a Handover from UTRAN Failure. The originating test set attempts to maintain the connection. See Two-Cell Test System .

+359 FDD warning; Did not receive the Handover to UTRAN Complete message

This error is generated if a two-cell GSM/GPRS/EGPRS to W-CDMA/HSPA CS handover is attempted, the uplink DCCH is detected by the destination test set, but the Handover to UTRAN Complete message is not received by the destination test set within 6 seconds. The destination test set assumes that the handover was nonetheless successful and attempts to maintain the connection. See Two-Cell Test System .

+360 FDD call processing error; External handoff failure

See Two-Cell Test System .

+361 FDD call processing error; External 8960 is incompatible for the requested operation

See Two-Cell Test System .

+362 FDD call operation rejected; The 0k and 64k uplink DTCHs cannot be simultaneously active

See HSDPA RB Test Mode Settings .

+363 FDD call disconnected; UE HS-DSCH categories 7 and 8 not supported on a PDP context

+364 FDD call operation rejected; Cannot process requested operation while Compressed Mode is active and the TCR timing indication is set to maintain

See Compressed Mode .

+365 FDD call operation rejected; Compressed Mode not supported on this channel code (only supported on 24, 25, 26, 27)

See Compressed Mode .

+366 FDD call processing error; Invalid parameters caused a compressed mode real time error due to overlapping gaps

See Compressed Mode .

+367 FDD call operation rejected; Compressed Mode cannot be activated when all of the TGPS states are set to off

See Compressed Mode .

+368 FDD call processing error; UE rejected the Physical Channel Reconfiguration message

 If this error occurred during a handover, see Troubleshooting Handovers . If it occurred during enabling/disabling compressed mode, see Troubleshooting Compressed Mode Operation .

+369 FDD warning; A valid TGD must be specified when TGL2 is not 0

See Compressed Mode .

+370 FDD Warning; Band VII value is not supported without the proper hardware so setting will be set to the next logical value. See www.agilent.com/find/8960upgrades for additional information

See Channel (UARFCN) Parameters .

+371 FDD call processing error; A remote video call origination request was rejected because the 8960 cannot handle the request

See Video Call .

+372 FDD call processing error; A remote video call release request was rejected because the 8960 cannot handle the request

See Video Call .

+374 FDD warning; The current UE HS-DSCH category is not capable of receiving more than 5 HS-PDSCHs

See HSDPA RB Test Mode Settings .

+375 FDD call operation rejected; The requested operation will cause the number of HS-PDSCHs to be too large for the first HS-PDSCH channelization code

See HSDPA RB Test Mode Settings .

+376 FDD call operation rejected; Requested operation would cause a channel code collision with the listed channels;

See Downlink Channel Codes .

+377 FDD call processing error; UE rejected the Transport Channel Reconfiguration message

See Troubleshooting Handovers: Transport Channel Reconfiguration .

+378 FDD call processing error; Transport Channel Reconfiguration Failure message received from the UE

See Troubleshooting Handovers: Transport Channel Reconfiguration .

+379 FDD call disconnected; Cannot allocate the required number of HS-PDSCHs for the current CQI value and PS Data first HS-PDSCH channel code

 This error is returned during an HSPA PDP Context setup procedure if the combination of Current UE HS-DSCH Category , PS Data Configuration Type and PS Data First HS-PDSCH Channel Code would cause the number of HS-PDSCHs specified by the CQI Value, when added to the PS Data First HS-PDSCH Channel Code , to exceed 15 (because then the HS-PDSCHs would collide with the downlink OCNS channels). The Activate PDP Context Request is rejected.

+380 FDD call operation rejected; The requested operation will cause the MAC-hs block size to be too small to carry the MAC-d PDU size

This error is returned if you attempt to set PS Data Configuration Type to 7 or less while PS Data User Defined Active HS-PDSCHs is set to 656 bits, or vice versa (because doing so would cause the MAC-hs transport block size to be too small to carry even a single MAC-d PDU).

+381 FDD call operation rejected; Compressed Mode not supported on this RAB when the S-CCPCH channel code is 57

See Compressed Mode .
+382 FDD warning: The E-RGCH channel currently has no power allocated to it | See RB Test Mode E-RGCH Information State .

+383, FDD call operation rejected, 64QAM must be configured with MAC-ehs

This error is returned if any of the following setting combinations occurs:

  • FDD Test Mode Modulation Type is 64QAM and FDD Test Mode HS-DSCH MAC entity is MAC-hs ;
  • Modulation Type is 64QAM and RB Test Mode HS-DSCH MAC entity is MAC-hs ;
  • PS Data Modulation Type is 64QAM , PS Data HS-DSCH MAC Entity is MAC-hs and PS Data HS-DSCH Configuration Type is User Defined ;
  • PS Data HS-DSCH MAC Entity is MAC-ehs , PS Data Modulation Type is 64QAM , PS Data HS-DSCH 64QAM Configured State is Off and PS Data HS-DSCH Configuration Type is User Defined .
+384 FDD call operation rejected; The primary E-RNTI cannot be the same as the alternate E-RN | See E-RNTI Parameters .
+387 FDD call operation rejected; The E-RGCH command queue is full | See Relative Grant Transmission .
+388 FDD call operation rejected; Change not allowed while E-TFCI recording is active | See E-TFCI Recording .
+389 FDD settings deferred; Connected Active Cell HSPA code channel power levels sum to > +0.03 dB | See Downlink Code Channel Information .
+390 FDD settings deferred; One or more Connected Active Cell HSPA code channel power levels > 30 dB below total RF power | See Downlink Code Channel Information .
+391 FDD settings deferred; Test Mode HSPA code channel power levels sum to> +0.03 dB | See Downlink Code Channel Information .
+392 FDD settings deferred; One or more Test Mode HSPA code channel power levels > 30 dB below total RF power | See Downlink Code Channel Information .
+393 FDD call operation rejected; The E-RGCH is not active in the UE | See RB Test Mode E-RGCH Information State .
+394 FDD call processing error; Radio Bearer Setup Failure message received from UE
+395 FDD call operation rejected; Absolute grant mode is not single shot | See Serving Grant .
+396 FDD call processing error; Absolute grant pattern values cannot be changed while the absolute grant mode is set to pattern | See Serving Grant .

+397 FDD call operation rejected; Simultaneous services is not supported on the desired service configuration

See Simultaneous Services .


+400 through +499 Error Message Descriptions

+400 through +499 Error Message Descriptions

Last updated: January 16, 2009

Description

These errors are generated when a problem occurs in one of the test set's hardware modules that is part of the test set's core instrument.

When one of these errors is generated, the `+400 errors' bit in the questionable error status register is set.

Error Message | Description
+400 Hardware failure; Hardware is not available |
+401 Hardware failure; Protocol processor hardware is not responding |
+402 Hardware failure; Demod receiver hardware is not responding |
+403 Hardware failure; Measurement receiver hardware is not responding |
+404 Hardware failure; RF source 1 hardware is not responding |
+405 Hardware failure; RF source 1 digital modulation hardware is not responding |
+406 Hardware failure; RF source 1 level hardware is not responding |
+407 Hardware failure; DSP demod control hardware is not responding |
+408 Hardware failure; 2nd demod receiver hardware is not responding |
+409 Hardware failure; Base station emulator trigger hardware is not responding |
+410 Hardware failure; Audio source hardware is not responding |
+411 Hardware failure; RF source 2 hardware is not responding |
+412 Hardware failure; Internal voltmeter hardware is not responding |
+413 Hardware failure; Fixed timebase input is not responding |
+414 Hardware failure; Fixed external reference output is not responding |
+415 Hardware failure; Instrument reference is not responding |
+416 Hardware failure; Bit clock A is not responding |
+417 Hardware failure; RF source 2 frequency hardware is not responding |
+418 Hardware failure; RF source 2 digital modulation hardware is not responding |
+419 Hardware failure; RF source 2 level hardware is not responding |
+420 Hardware failure; RF source hopping hardware is not responding |
+421 Hardware failure; Digital demod hopping hardware is not responding |
+422 Hardware failure; Misc VI hardware is not responding |
+423 Hardware failure; Unable to access networking information |
+424 Hardware failure; Bit clock B is not responding |
+425 Hardware failure; Invalid EEPROM checksum <EEPROM board ID> | See the list of EEPROM board ID names below.
+426 Hardware failure; Unable to write to EEPROM <EEPROM board ID> | See the list of EEPROM board ID names below.
+427 Hardware failure; Unable to read from EEPROM <EEPROM board ID> | See the list of EEPROM board ID names below.
+428 Hardware failure; Board not identified <board ID> | See the list of board ID names below.
+429 Hardware failure; Could not create board identification <board ID> | See the list of board ID names below.
+430 Hardware failure; Control version not compatible with FW <board ID> | See the list of board ID names below.
+431 Hardware failure; RF IO DAC cannot be calibrated due to present temperature |
+432 Hardware failure; RF hardware is not responding |
+433 Hardware failure; RF source FM hardware is not responding |
+434 Hardware failure; Audio source FM hardware is not responding |
+435 Hardware failure; Miscellaneous state hardware is not responding |
+436 Hardware failure; BSP access error |
+437 Hardware failure; LSS hardware is not responding |
+438 Hardware failure; RFIO hardware is not responding |
+460 Hardware failure; Hardware doesn't support requested operation. See www.agilent.com/find/8960upgrades for additional information | This error occurs when an action is attempted that is not possible with the test set's hardware. Visit www.agilent.com/find/8960upgrades to find out how to acquire the necessary hardware.
+461 Hardware failure; Link subsystem hardware is not responding. Call processing functionality not operational. | This error occurs any time the link subsystem is not operating correctly. The message is persistent to warn the user that any call processing operations will not work.
+462 Hardware error; Hardware not supported; <board ID><part_number> | This error appears when an operation was attempted that requires hardware that is not installed in the test set.
+463 Hardware error: RFIO version does not support loopback switching. |
+464 Hardware error: RFIO version does not support RF out only selection. | This error occurs when trying to select the RF OUT ONLY port when the test set has the RF I/O module that only has the RF IN/OUT port.
+465 Hardware error; RfSplitters version does not support RF out only selection |
+466 Hardware error; Missing or unsupported hardware. Module |
+467 Optional hardware error; Missing or unsupported optional hardware. Option |
+469 Hardware failure; Bbio VI hardware is not responding |
+470 Hardware error; Hardware doesn't support requested operation. Feature is not licensed. See www.agilent.com/find/8960upgrades for additional information | This error occurs you attempt to access a feature which is not licensed in the test set and is not possible with the test set's hardware. Visit www.agilent.com/find/8960upgrades to find out how to acquire the necessary hardware and license.

<board ID> names

3 GHZ ATTENUATOR 1| ;3GHZ ATTENUATOR 2| ;AUDIO BD| ;ROM BASEBAND GENERATOR 1| ;ROM BASEBAND GENERATOR 2| ;DEMOD DOWNCONVERTER| ;VECTOR OUTPUT BOARD 1| ;VECTOR OUTPUT BOARD 2| ;IVF MEASUREMENT| ;MEASUREMENT DOWCONVERTER| ;RF POWER DETECTORS| ;REFERENCE MODULE| ;SYNTH DOUBLER 1| ;SYNTH DOUBLER 2| ;TIMING REF| ;MOMENTUM INSTRUMENT| ;RF MOTHER BOARD| ;JUMPER BOARD| ;DIGITAL MOTHER BOARD| ;FLAT PANEL ADAPTER| ;REAR PANEL BOARD

<EEPROM board ID> names

Instrument Eeprom ID State| ;Atten 1 Eeprom ID State| ;Atten 2 Eeprom ID State| ;Audio Eeprom ID State| ;BaseBandGen 1 Eeprom ID State| ;BaseBandGen 2 Eeprom ID State| ;Demod DC Eeprom ID State| ;Digital Mother Board Eeprom ID State| ;IQ Output 1 Eeprom ID State| ;IQ Output 2 Eeprom ID State| ;IVF Meas Eeprom ID State| ; Jumper Board Eeprom ID State| ; Meas DC Eeprom ID State| ;RF Mother Board Eeprom ID State| ;RF Interface Eeprom ID State| ; Ref Mod Eeprom ID State| ;Sig Gen 1 Eeprom ID State| ; Sig Gen 2 Eeprom ID State| ;Time Ref Eeprom ID State| ;Display Interface Eeprom ID State| ;Rear Panel Eeprom ID State


+500 through +599 Test Application Hardware Device-Specific Error

+500 through +599 Test Application Hardware Device-Specific Error

Last updated: November 25, 2010

Description

These errors are generated when a problem occurs with a hardware module that is required for a particular application.When one of these errors is generated, the `+500 errors' bit in the questionable error status register is set.

+500 through +599 Error Messages
Error Message | Description
+501 Protocol logging failure; No observation points enabled | This error message is displayed for information purposes only.
+519 Configuration error; DUT IP addresses must be unique |
+520 Configuration error; DUT IP address must be on same subnet as instrument | This error message is generated if the DUT IP address is not on the same subnet as the instrument. This situation may arise because the instrument IP address was set after the DUT IP address, or the instrument subnet mask changed.
+521 Configuration error; DUT IP address cannot be the same as the instrument LAN address | This error message is generated if the DUT IP address and the instrument IP address are the same. This situation may arise because the instrument IP address was set after the DUT IP address.
+522 Configuration Error; Operation Rejected Due To Invalid IP Address | This error is returned when attempting to Connect to External 8960 if the Ext 8960 IP Addr is invalid.
+524 Operation rejected; External PDSN state can not be changed while data connection is dormant | This error message is displayed for information purposes only.
+525 Configuration error; External PDSN IP address must be on same subnet as instrument |
+526 Configuration error; External PDSN IP address cannot be the same as instrument LAN address | This error message is generated if the External PDSN IP address and the instrument IP address are the same.
+527 Operation rejected; External PDSN state change to on not allowed if external PDSN IP address is undefined | This error message is displayed for information purposes only.
+528 Operation rejected; External PDSN service not available; external PDSN state set to off | This error message is displayed for information purposes only
+529 Warning; External PDSN control connection dropped; external PDSN state set to off. | This error message is associated with a lost control connection between test set and MOB-IP-SIM.
+530 Operation rejected; External PDSN settings cannot be changed when external PDSN state is on. | This error message is displayed for information purposes only.
+531 Operation rejected; External PDSN state cannot be changed while a data connection is established. | This error message is displayed for information purposes only.
+532 Warning; External PDSN data connection dropped | This error message is associated with a lost data connection between MOB-IP-SIM and MS.
+533 Operation rejected; ping DUT functionality is not available while external PDSN state is on. | This error message is displayed for information purposes only.
+534 Operation Rejected; No Response From The External Device | This error is returned when attempting to Connect to External 8960 if the external 8960 does not respond to the connection request.
+535 External 8960 LAN connection request rejected[; Because <reason>] | <reason> could be one of these two strings: a. external 8960 connection is not allowed; b. call processing is in progress.
+536 Warning; Connection Is Already Established With The External Device | This error is returned when attempting to Connect to External 8960 if your test set is already connected to the external 8960.
+537 Operation Rejected; Change Allowed Only When A Connection To An External Device Does Not Exist | This error is returned when attempting to set the Ext 8960 IP Addr while External Device Conn Status is not Disconnected .
+538 Operation Rejected; External 8960 Test Set IP Address Cannot Be The Same As Instrument LAN IP Address | This error is returned when attempting to set the Ext 8960 IP Addr to the same value as LAN IP Address .
+539 Warning; Connection To The External Device Has Been Lost; check call status to determine if any active calls have been disconnected | This error occurs if the External Device Connection is broken (for example, if you disconnect the LAN cable from the test set).
+540 Operation Rejected; Cannot Process Request While Attempting To Connect To Or Disconnect From The External Device | This error is returned when attempting to Connect to External 8960 or Disconnect from External 8960 if the External Device Conn Status is Connecting or Disconnecting .
+541 Operation Rejected; External 8960 Test Set IP Address Cannot Be The Same As The DUT IP Address | This error is returned when attempting to set the Ext 8960 IP Addr to the same value as DUT IP Address .
+542 Operation Rejected; Service Not Available Without A Connection To An External Device | This error is returned when attempting to originate an end-to-end service without an External Device Connection in place.
+543 HTTP Client Error; failed to create socket |
+544 HTTP Client Error; failed to connect to the socket |
+545 HTTP Client Error; invalid IP address specified |
+546 HTTP Client Error; timeout |
+547 HTTP Client Error; could not access socket |
+548 HTTP Client Error; bad request URL |
+549 Operation rejected; External 8960 test set IP address cannot be the same as the other external 8960 IP address | This error message is displayed for information purposes only.
+550 HTTP SMS request ignored; Request parameter out of range | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface containing a parameter value out of the supported range.
+551 HTTP SMS request ignored; Incompatible parameters in request | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface containing parameters that can not be used together in the same request URL.
+552 HTTP SMS request ignored; Missing mandatory parameter in request | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface that does not contain parameters required by the test set.
+553 HTTP SMS warning; Output message URL exceeded maximum length and has been truncated | This error is generated when the constructed URL received by the test set's HTTP interface for a mobile originated SMS message exceeds the maximum size of 1500 characters. This generally occurs if one or more tags have been duplicated in the output URL format string, causing the length restriction to be exceeded.
+560 Data out of range; Total Baseband Studio multi-path relative levels' sum invalid; no change |
+561 Operation failed; The external device connection request failed likely because there is a firmware incompatibility between the two connecting devices. See www.agilent.com/find/8960upgrades for additional information | The underlying architecture of the External Device Connection feature has changed over time. The two implementations are not compatible. To establish an External Device Connection between two test sets, the test sets must have compatible firmware (see www.agilent.com/find/8960upgrades for more information)
+562 Operation failed; The incoming request for an external device connection request failed likely because there is a firmware incompatibility between the two connecting devices. See www.agilent.com/find/8960upgrades for additional information | The underlying architecture of the External Device Connection feature has changed over time. The two implementations are not compatible. To establish an External Device Connection between two test sets, the test sets must have compatible firmware (see www.agilent.com/find/8960upgrades for more information)
+563 Operation rejected; Calling party number 1 and calling party number 2 can not be set to the same number. | This error is generated when calling party1 number is set to the same value as calling party 2 number.
+564 Operation rejected; Requested DUT IP address is currently in use | This error is generated if the DUT address is currently assigned to a mobile device for an active data session. The device may be directly connected to the local 8960, or may be connected to a remote 8960, with an external connection to the local 8960. Specifically this can occur if the data connection was first established on the local 8960, but a cell transition occurred (handover) while the two 8960s were externally connected.
+565 Operation aborted; Signal was lost between 8960s | This error is generated if, after the Execute Ext 8960 Handover immediate action is initiated, a signaling problem occurs with the external 8960 before the appropriate handover message is sent to the UE.
+566 Warning; Signal was lost between 8960s but the operation will still try to continue | This error is generated if, after the Execute Ext 8960 Handover immediate action is initiated, a signaling problem occurs with the external 8960 after the appropriate handover message is sent to the UE.
+567 Operation rejected; Instrument LAN address can not be on same subnet as any DUT routing subnets (192.168.104.0/22) when DUT routing state is on. | This error is generated if any of the IP address or LAN subnet mask are set to an address that brings out any conflict with any of the fixed network routes the operation is rejected when turn on DUT routing.
+568 Operation failed; The external device connection request failed; <<reason> on <unit>> | <reason> could be: 1.CDMA system time synchronization failed 2. Call processing in progress 3. Incorrect state <unit>; Refer to your document CD or go to www.agilent.com/find/8960 for correct configuration 4. External connection not allowed 5. LAN communication error 6. IP address conflict 7. Due to data connection status 8. Due to external device connection status 9. Unkown error 10. Missing feature license 11. Missing hardware 12. Missing feature license and hardware 13. Incompatible firmware revisions14. CDMA system time not synchronized; <unit> could be: 1. on Aux 1 Unit 2. on Aux 2 Unit
+569 Operation rejected; External device connection is not allowed due to External Device Connection Allowed off | This error message is displayed for information purposes only.
+570 Warning; Disconnecting from the external device due to unexpected LAN message received | This error message is displayed for information purposes only.
+571 Configuration error; IPv6 prefix is empty. | This error is displayed if IPv6 Prefix is blank at the start of PPP negotiation
+572 Operation rejected; No response from the external evolved packet core | This error message is displayed for information purposes only.
+573 Warning; Connection to the external evolved packet core has been lost | This error message is displayed for information purposes only.
+574 Operation rejected; External EPC IP address cannot be the same as instrument LAN IP address | This error message is displayed for information purposes only.
+576 Operation rejected: IPv6 prefix change not allowed when IPv6 router state is on | This error message is reported if the testset's IPv6 Prefix is changed when IPv6 Router State is on, this will cause unexpected behavior.


+600 through +699 Error Message Descriptions

+600 through +699 Error Message Descriptions

Last updated: January 16, 2009

Description

These errors are generated when a problem occurs that is specific to one of the test set's instruments. These errors are part of the test set's core. Note that these measurements may not be present in every test application and therefore, these errors may not be present in every test application. There is no plan at present to support test application specific instruments.

An instrument in this context refers to the measurement-like functionality such as the audio generator and not to the test set as a whole.

When one of these errors is generated, the `+600 errors' bit in the questionable error status register is set.

Error Message | Description
+601 Instrument failure; Audio generator hardware is not responding | Indicates a problem occurs when attempting to control the test set's audio generator.
+602 Data out of range; Spectrum Monitor; No peaks left |
+603 Data out of range; Spectrum Monitor; No peaks right |
+604 Data out of range; Spectrum Monitor; No peaks found |
+605 Operation rejected; Spectrum Monitor; Receiver power currently set to Auto |
+606 Operation rejected; Spectrum Monitor; Meas frequency currently set to Auto |
+607 Operation rejected; Spectrum Monitor; Marker Frequency out of Meas Frequency tune range |
+608 Operation rejected; Spectrum Monitor instrument is inactive |
+620 Data out of range; Total multi-tone audio downlink level upper limit exceeded; no change |
+621 Data out of range; Total multi-tone audio uplink level upper limit exceeded; no change |
+622 Warning; Multi-tone audio downlink level over range due to requested setting |
+623 Operation rejected; Multi-tone audio downlink levels cannot be set when total level state is on |
+624 Operation rejected; Multi-tone audio uplink levels cannot be set when total level state is on |
+625 Operation rejected; Multi-tone audio analyzer frequencies cannot be set when use generator frequencies state is on |


+700 through +799 Error Message Descriptions

+700 through +799 Error Message Descriptions

Last updated: January 16, 2009

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error.

When one of these errors is generated, the +700 errors bit in the questionable error status register is set.

FDD System Measurement Errors
Error Message | Description
+701 FDD measurement failure; Thermal Power hardware is not responding | A hardware failure associated with this measurement is suspected. Rerun the measurement to verify this error.
+702 FDD measurement failure; Adjacent Channel Leakage Ratio hardware is not responding | A hardware failure associated with this measurement is suspected. Rerun the measurement to verify this error.
+703 FDD measurement failure; Waveform Quality hardware is not responding | A hardware failure associated with this measurement is suspected. Rerun the measurement to verify this error.
+704 FDD measurement failure; Channel Power hardware is not responding | A hardware failure associated with this measurement is suspected. Rerun the measurement to verify this error.
+705 FDD measurement failure; Loopback Bit Error Ratio hardware is not responding | A hardware failure associated with this measurement is suspected. Rerun the measurement to verify this error.
+706 FDD measurement failure; Spectrum Emission Mask hardware is not responding | A hardware failure associated with this measurement is suspected. Rerun the measurement to verify this error.
+707 FDD measurement failure; Occupied Bandwidth hardware is not responding | A hardware failure associated with this measurement is suspected. Rerun the measurement to verify this error.
+708 FDD measurement failure; Code Domain hardware is not responding | A hardware failure associated with this measurement is suspected. Rerun the measurement to verify this error.
+709 FDD measurement failure; IQ Tuning hardware is not responding |
+710 FDD measurement failure; Inner Loop Power hardware is not responding |
+711 FDD measurement failure; Transmit ON/OFF Power hardware is not responding |
+712 FDD measurement failure; PRACH Preamble Analysis hardware is not responding |
+713 CDMA measurement failure; Fast Device Tune measurement is not responding. |
+715 FDD measurement failure; Phase Discontinuity hardware is not responding |
+716 FDD measurement failure; Block Error Ratio hardware is not responding |
+717 FDD measurement failure; Dynamic Power Analysis hardware is not responding |
+718 FDD measurement failure; Change of Transport Format hardware is not responding |
+719 FDD measurement failure; TX Dynamic Power hardware is not responding |
+720 FDD measurement failure; HSDPA Block Error Ratio hardware is not responding |
+721 FDD measurement failure; Extended Range Dynamic Power hardware is not responding |
+750 FDD Measurement failure; Incorrect PRACH Preambles setting. Valid range: >= 3 |
+751 FDD Measurement failure; Incorrect Available Subchannels setting. Valid range: any single subchannel. |
+752 FDD Measurement failure; Measurement only available in Idle call state. |
+753 FDD Measurement failure; Measurement only available in Active Cell Operating Mode |
+754 FDD Measurement failure; Measurement only available when the receiver control measurement frequency is: 1) set to the uplink channel frequency OR 2) set to AUTO mode |
+755 FDD Measurement failure; Call not connected |
+756 FDD Measurement failure; Sync not found |
+757 FDD measurement failure; Measurement not available in the current channel type |
+758 FDD Measurement failure; Receiver power control changed to AUTO |
+759 FDD measurement failure; Measurement only available in Service Type RB Test Mode |
+760 FDD measurement failure; Measurement only available when Uplink Dummy DCCH Data set to Off |
+761 FDD measurement failure; Loopback BER measurement is not available in current configuration |
+762 FDD measurement failure; Loopback BER measurement, run from within WCTF, failed to complete successfully |
+763 FDD measurement failure; Trigger Source must be set to External when in FDD Test Operating Mode |
+764 FDD measurement failure; Measurement not available using Channel Type: 33K No Coding RMC |
+765 FDD Measurement Failure; Measurement Only Available When Call Is In Connected State | A measurement which requires a connection in active cell operating mode has been requested to run without a connection in place.
+766 FDD Measurement Failure; Measurement not available in CW or Cell Off Operating Modes | A measurement has been requested to run in an operating mode in which it is not available.
+767 FDD measurement failure; Measurement only available in 12.2k, 64k, 144k, 384k and 33k No Coding RMCs |
+768 FDD measurement warning; UL CL Power Control is not set to ALL_UP |
+769 FDD measurement warning; Channel Type is not 12.2k |
+770 FDD measurement warning; UE Call Drop Timer setting too short |
+771 FDD measurement failure; Measurement only available in FDD Test Operating Mode | See FDD Test Operating Mode .
+772 FDD measurement failure; Measurement only available using Channel Type: 12.2k RMC + HSDPA | See HSDPA in FDD Test Operating Mode and Channel Type .
+773 FDD measurement failure; Measurement not available in the current service type |
+774 FDD measurement failure; Measurement not available using Channel Type: 12.2k RMC + HSDPA | See HSDPA in FDD Test Operating Mode and Channel Type .
+775 FDD measurement failure; Trigger Source selection only available with Channel Type = 12.2k RMC + HSDPA and Operating Mode = FDD Test or Active Cell | See HSDPA in FDD Test Operating Mode and HSDPA in Active Cell Operating Mode .
+776 FDD measurement failure; Measurement only available with Channel Type = 12.2k RMC + HSDPA and Operating Mode = FDD Test or Active Cell | See HSDPA in FDD Test Operating Mode and HSDPA in Active Cell Operating Mode .
+777 FDD measurement warning; Measurement timeout time is smaller than the time required to test the user specified number-of-blocks-to-test | See Measurement Timeout and Number of blocks to test .
+777 FDD measurement failure; In Active Cell operating mode, when Trigger Source = HS-DPCCH, measurement only available when call is in Connected state |
+778 FDD measurement failure; In Active Cell operating mode, the HS-DPCCH measurement trigger only active when HSDPA is active | See HSDPA in FDD Test Operating Mode and HSDPA in Active Cell Operating Mode .
+779 FDD measurement failure; Measurement only available when receiver power control set to MANUAL | See Receiver Control .
+780 CDMA measurement failure; Fast Device Tune measurement setup is not correct. Refer to your documentation CD or go to www.agilent.com/find/8960 for correct setup steps | See Fast Device Tune Measurement Description .
+780 FDD measurement failure; Extended range dynamic power measurement first sequence steps + second sequence steps must be less than or equal to 85 |
+781 CDMA operation rejected; Fast Device Tune feature is not licensed. See www.agilent.com/find/8960upgrades for additional information | See Fast Device Tune Measurement Description .
+781 FDD measurement failure; Measurement is not available for RB Test Mode channel types with HSUPA channels or GPRS radio access bearers with HSUPA configurations |
+782 CDMA measurement failure; Fast Device Tune measurement MS Tx/Rx frequency step sequence table start index + frequency step count must be less than or equal to 40 | See Fast Device Tune Measurement Description .
+782 FDD measurement failure; Measurement is not available for RB Test Mode channel types without HSUPA channels or GPRS radio access bearers without HSUPA configurations |
+783 CDMA measurement failure; Fast Device Tune measurement MS Tx/Rx power step sequence table start index + power step count must be less than or equal to 40 | See Fast Device Tune Measurement Description .
+783 FDD measurement failure; In Active Cell operating mode, the Even Frame measurement trigger only available when HSUPA is active | See Code Domain Measurement Description .
+784 CDMA measurement failure; Fast Device Tune measurement MS Tx/Rx frequency values in use must not be NAN | See Fast Device Tune Measurement Description .
+784 FDD measurement failure; Measurement only available in User Defined HS-DSCH configuration type | See HSDPA Reporting of Channel Quality Indicator Measurement Description .
+785 CDMA measurement failure; Fast Device Tune measurement MS Tx/Rx power levels in use must not be NAN | See Fast Device Tune Measurement Description .
+785 FDD measurement failure; The Manual Power Range Offset is set incorrectly | This error is returned if the sum of the Manual Power Range Offset and expected input power level (UE Target Power or Manual Power) exceeds 30 dBm. See Channel Power Measurement Description .
+786 CDMA measurement failure; Fast Device Tune measurement MS Tx frequency values in use are not in the same band | See Fast Device Tune Measurement Description .
+787 CDMA measurement failure; Fast Device Tune measurement MS Rx frequency values in use are not in the same band | See Fast Device Tune Measurement Description .
+788 CDMA measurement failure; Fast Device Tune measurement MS Tx power levels in use are out of range | See Fast Device Tune Measurement Description .
+788 FDD measurement warning; CQI repetition factor is not set to 1 | See HSDPA Reporting of Channel Quality Indicator Measurement Description .
+789 CDMA measurement failure; Fast Device Tune measurement MS Rx power levels in use are out of range | See Fast Device Tune Measurement Description .
+789 FDD measurement warning; Measurement power offset last signaled to UE not equal to current HSDPA Cell 1 Connected HS-PDSCHs Level (Sum) - current HSDPA Cell 1 Connected HS-CPICH Level | See HSDPA Reporting of Channel Quality Indicator Measurement Description .
+790 CDMA measurement failure; Fast Device Tune measurement unable to build frequency and power sequence tables. Measurement is unavailable. Check the Message Log for error details | See Fast Device Tune Measurement Description .
+790 FDD measurement warning; UE IR buffer size not correct for UE category | See HSDPA Reporting of Channel Quality Indicator Measurement Description .
+791 FDD measurement warning; UE HS-DSCH Category Control set to Manual. Manual UE HS-DSCH Category setting not equal to MS reported UE Category | See HSDPA Reporting of Channel Quality Indicator Measurement Description .
+792 CDMA measurement failure; Fast Device Tune measurement first frequency in frequency sequence not in recognized frequency band | See Fast Device Tune Measurement Description .
+792 FDD measurement failure; Total number of HS-PDSCHs required by 3GPP TS 25.214 CQI mapping table for the most recent Median_CQI is too large based on current RB Test Mode First HS-PDSCH Channel Code setting | See HSDPA Reporting of Channel Quality Indicator Measurement Description .


+800 through +899 Error Message Descriptions

+800 through +899 Error Message Descriptions

Last updated: January 16, 2009

Description

These errors are generated when a problem occurs that is specific to one of the test set's core measurements (such as analog audio).

When one of these errors is generated, the `+800 errors' bit in the questionable error status register is set.

Error Message | Description
+801 Measurement failure; Analog audio hardware is not responding | Indicates that a problem occurs when attempting to control the measurement's hardware.
+802 Measurement failure; Audio analyzer hardware is not responding | Indicates that a problem occurs when attempting to control the measurement's hardware.
+803 Measurement failure; Signal Finder hardware is not responding |
+805 Measurement failure; Multi-tone audio hardware is not responding |


QPSK EVM Troubleshooting

QPSK EVM Troubleshooting

Last updated: January 14, 2010

Possible Setup Issues

  • During remote operation of the QPSK EVM measurement, it is recommended that you configure the trigger arm to single. See SETup:EVMQpsk . If the trigger arm is not set to single, you may not be able to retrieve measurement results during remote use if you are using the INIT:DONE? query. When the trigger arm is continuous, the measurement rearms itself and starts another measurement cycle, causing the INIT:DONE? query to always return "WAIT". See Trigger Arm (Single or Continuous) Description for more explanation.
  • Your UE must be synchronized to the test set for this measurement to operate correctly.
  • RF In/Out Amplitude offsets entered do not affect these measurement results unless the received signal level becomes too low to accurately detect relative I/Q modulation vector transitions.

Interpreting Integrity Indicator Values

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Cannot Correlate (17) is returned, the test set cannot demodulate the signal from the mobile station (UE). Make sure the uplink scrambling code from the mobile station matches the UL Scrambling setting on the test set (see CALL:UPLink ).

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. See Calibrating the Test Set .

See Integrity Indicator .

Related Topics

QPSK EVM Measurement Description


Frequency Stability Troubleshooting

Frequency Stability Troubleshooting

January 16, 2009

Possible Setup Issues

The Trigger Arm should always be set to Single for GPIB operation (not Continuous ).

If Trigger Arm is set to single, you must press START SINGLE to start the measurement from the front panel.

This measurement can only be used for analog signals.

The expected signal frequency and input level must be specified for accurate measurements (see Receiver Control ).

Ensure that the input signal meets the Input Signal Requirements .

Related Topics

Frequency Stability Measurement Description


Troubleshooting Handovers

Troubleshooting Handovers

Last updated: January 16, 2009

  • Physical Channel Reconfiguration
  • Transport Channel Reconfiguration
  • System Handovers
  • Radio Bearer Reconfiguration

Physical Channel Reconfiguration

  • See Physical Channel Reconfiguration Operating Considerations .
  • You must be on a call to perform a physical channel reconfiguration.
  • 3GPP TS 25.331 v5.17.0 s8.6.6.28 states that the UE's behavior is undefined if the network sets the Timing Indication IE to Initialise on a non-hard handover (i.e. where the UARFCNs and one or more Primary Scrambling Codes remain unchanged as part of the reconfiguration). Thus, if you perform a Physical Channel Reconfiguration with PCR Timing Indication (CFN Handling) set to Initialise, and the handover downlink and uplink channels are the same as the current downlink and uplink channels, the UE may drop the call, ignore or reject the reconfiguration request, or report a reconfiguration failure.

  • When the test set orders a Physical Channel Reconfiguration, it takes a finite amount of time for the test set to move to and settle at the new frequency. When the Physical Channel Reconfiguration is ordered, most UEs wait a time of T312 at the new frequency before determining that the handover has failed (T312 is signalled by the test set in SIB1 with a value of 5 seconds). If your UE does not wait once moving to the new frequency, the handover may fail. If it does, set PCR Activation Time as needed to cause the UE to wait until the test set has moved to the new frequency (a setting of 100 (100 x 10 ms = 1 s) is usually sufficient). Do not set PCR Activation Time to a value other than 0 unless necessary, as it slows down the handover procedure.

  • Ensure that the handover downlink and handover uplink channels are set to proper values for your UE. Note that the default DL Channel of 10700 and default handover downlink channel of 10730 are 6 MHz apart (the default uplink channels are also 6 MHz apart). If you wish to handover to channels that are 5 MHz from the default channels, set the handover downlink channel to 10725 and handover uplink channel to 9775 .
  • If the test set recognizes the physical channel reconfiguration as illegal for any reason, an error is posted, the reconfiguration is rejected and the test set remains in its state prior to the initiation of the reconfiguration. Conversely, if the UE simply does not respond as expected during a reconfiguration, an error is posted and the test set proceeds with the procedure as if the expected response was received.

Transport Channel Reconfiguration

  • See Transport Channel Reconfiguration Operating Considerations .

  • The Transport Channel Reconfiguration provides three main functions:

    • Switching Between Symmetrical RMCs while on an RB Test Mode Connection . You must be on a (non-HSDPA/non-HSPA) RB test mode symmetrical RMC call to perform a transport channel reconfiguration between RMCs.
    • Changing Parameters that Require Cell Off Operating Mode or Idle Connection Status while on a Connection . You must be on an RB test mode symmetrical RMC connection (non-HSDPA, HSDPA or HSPA) to change these settings.
    • Changing HSPA Parameters that Require Idle Connection Status while on a Connection ( lab application or feature-licensed test application only ). You must be on an HSDPA or HSPA RB test mode connection to change these settings.
  • 3GPP TS 25.331 v5.17.0 s8.6.6.28 states that the UE's behavior is undefined if the network sets the Timing Indication IE to Initialise on a non-hard handover (i.e. where the UARFCNs and one or more Primary Scrambling Codes remain unchanged as part of the reconfiguration). Thus, if you perform a Transport Channel Reconfiguration with TCR Timing Indication (CFN Handling) set to Initialise (or set to Auto and TCR Default DPCH Offset (DOFF) is set to a value other than the Current DPCH Offset ), and the handover downlink and uplink channels are the same as the current downlink and uplink channels, the UE may drop the call, ignore or reject the reconfiguration request, or report a reconfiguration failure.
  • Ensure that the handover downlink and handover uplink channels are set to proper values for your UE. Note that the default DL Channel of 10700 and default handover downlink channel of 10730 are 6 MHz apart (the default uplink channels are also 6 MHz apart). If you wish to handover to channels that are 5 MHz from the default channels, set the handover downlink channel to 10725 and handover uplink channel to 9775 .

System Handovers

This functionality is only available in GSM/GPRS_W-CDMA fast switching test and lab applications.

  • The system handover functionality allows you to handover to a GSM voice call from any of the following connection types:

    • AMR Setup
    • (non-HSDPA/non-HSPA) Radio Bearer Test Mode
    • HSDPA Radio Bearer Test Mode with CN Domain set to CS Domain ( lab application or feature licensed test application only )
    • HSPA Radio Bearer Test Mode ( lab application or feature licensed test application only )

    You must be on one of these types of connections to perform a system handover.

  • Before performing the handover, you must ensure that the GSM/GPRS format is set to Active Cell operating mode.
  • When performing a handover from W-CDMA RB test mode to a GSM voice call with RB Test Mode to GSM Handover Alerting State set to On , the UE will ring. You must answer the ring for the connection to be completed and testing to progress.
  • When performing a handover from W-CDMA RB test mode to a GSM voice call with RB Test Mode to GSM Handover Alerting State set to Off , when the handover is completed, the connection is left in the RR Connected state. Data loopback (for BER testing) is available in this state, but voice echo is not.
  • If your UE does not send a W-CDMA layer 2 acknowledgment for the Handover From UTRAN command, you must set Wait for RLC Ack of Handover From UTRAN to Off . Otherwise, the test set will not continue with the handover until it receives the expected acknowledgment, and the handover will fail.
  • Presetting the test set while operating in the W-CDMA format will not reset the System Handover parameters to their default settings. Presetting the test set while operating in the GSM/GPRS format will reset these parameters to their default values.
  • When operating in the W-CDMA format, the System Handover parameter settings are not saved when using the SAVE REGISTERS utility.

Radio Bearer Reconfiguration

  • See Radio Bearer Reconfiguration Operating Considerations .
  • The Radio Bearer Reconfiguration allows you to handover from a CS Domain or CS/PS Domain HSDPA RB Test Mode connection or HSPA RB Test Mode connection to a (non-HSDPA/non-HSPA) symmetrical RMC.
  • 3GPP TS 25.331 v5.17.0 s8.6.6.28 states that the UE's behavior is undefined if the network sets the Timing Indication IE to Initialise on a non-hard handover (i.e. where the UARFCNs and one or more Primary Scrambling Codes remain unchanged as part of the reconfiguration). Thus, if you perform a Radio Bearer Reconfiguration with RBR Timing Indication (CFN Handling) set to Initialise (or set to Auto and RBR Default DPCH Offset (DOFF) is set to a value other than the Current DPCH Offset ), and the handover downlink and uplink channels are the same as the current downlink and uplink channels, the UE may drop the call, ignore or reject the reconfiguration request, or report a reconfiguration failure.
  • Ensure that the handover downlink and handover uplink channels are set to proper values for your UE. Note that the default DL Channel of 10700 and default handover downlink channel of 10730 are 6 MHz apart (the default uplink channels are also 6 MHz apart). If you wish to handover to channels that are 5 MHz from the default channels, set the handover downlink channel to 10725 and handover uplink channel to 9775 .

Related Topics

Handovers


HSDPA Block Error Ratio Troubleshooting

HSDPA Block Error Ratio Troubleshooting

Last updated: January 16, 2009

This section is only applicable to the lab application or a test application with the required feature license.

Possible Setup Issues

  • The HSDPA block error ratio (BLER) measurement can only be performed on a Radio Bearer Test Mode connection with a Channel Type of 12.2k RMC + HSDPA or 12.2k RMC + HSPA.
  • See FDD Test Mode Considerations .
  • If you experience unexpectedly high HSDPA BLER results, ensure that FRC Type is set to a configuration supported by your UE.
  • If you set Measurement Timeout to On , ensure that the Measurement Timeout value is greater than the time the measurement needs to measure the desired Number of blocks to test .
  • During front panel operation of this measurement, if Trigger Arm is set to Single , you must press the START SINGLE key to initiate the measurement.
  • During remote operation of the HSDPA BLER measurement, you should configure the Trigger Arm to Single .
  • Ensure that you have met the HSDPA Block Error Ratio Measurement Input Signal Requirements .
  • Measurement results are influenced by any amplitude offsets that are entered, since the level into the UE is altered.
  • In FDD Test operating mode, the test set does not signal the CQI Feedback Cycle (k) or CQI Repetition Factor to the UE, you must set the values manually in the UE. To ensure a valid Median CQI result, you must ensure that CQI Feedback Cycle (k) is greater than or equal to CQI Repetition Factor * 2ms (so that there are no collisions between new and repeated CQI information). See CQI Transmission Settings for more information about this requirement.

Troubleshooting Techniques

Check to see if an integrity indicator other than 0 (normal) was returned with the measurement result (see Integrity Indicator ).

  • If Questionable MS-to-Cell Data (28) is returned, the setting you've chosen for Ack-Nack Repetition Factor is causing collisions between data being sent to the UE by the test set, and the repeated ACKs/NACKs being sent by the UE. You must ensure that the minimum inter-TTI of the active HSDPA channel is greater than or equal to Ack-Nack Repetition Factor * 2 ms (so that there are sufficient unused subframes on the uplink for the ACK/NACK repeats to be transmitted without colliding with new ACK/NACK information). Otherwise, the repeated ACK/NACK information will be sent by the UE when the test set expects ACK/NACK information for the block it just transmitted to the UE (a block that the UE ignored because it was sending an ACK or NACK repeat for a prior block). The test set would then treat the ACK/NACK repeat like ACK/NACK information for the current block, resulting in incorrect HSDPA BLER results.
  • If Measurement Timeout (2) is returned, the value you entered for the measurement may be too small for the Number of blocks to test . In this case, either reduce the number of blocks to test or increase the timeout value.
  • If Unsupported Configuration (22) is returned, you must set Channel Type to 12.2k RMC + HSDPA .

Related Topics

  • HSDPA Block Error Ratio Measurement Description


Using GPIB Command Debug Mode

Using GPIB Command Debug Mode

Last updated: January 16, 2009

Description

It is recommended that you set the test set's operating environment to debug during GPIB code development. Test times may be longer than necessary if the debugger state is left on. When debug mode is on, the error message displayed on the test set's front panel when incorrect GPIB syntax is sent to the test set is enhanced with additional information to help you correct the syntax error.

To set the test set debug mode to "ON" use the following syntax:

SYSTem:COMMunicate:GPIB:DEBug ON

Related Topics

SYSTem:COMMunicate:GPIB:DEBug[:STATe]


HSDPA Reporting of Channel Quality Indicator Troubleshooting

HSDPA Reporting of Channel Quality Indicator Troubleshooting

Last updated: January 16, 2009

This section is only applicable to the lab application.

Possible Setup Issues

  • The Reporting of Channel Quality Indicator measurement can only be performed on a Radio Bearer Test Mode connection with a Channel Type of 12.2k RMC + HSDPA .
  • If you experience unexpectedly high BLER results in the BLER versus CQI Sense part of the measurement, ensure that FRC Type is set to a configuration supported by your UE.
  • If you set Measurement Timeout to On , ensure that the Measurement Timeout value is greater than the time the measurement needs to measure the desired Number of CQI Reports to test and the desired Number filtered ACK/NACK responses to test .
  • During front panel operation of this measurement, you must press the START SINGLE key to initiate the measurement.
  • Ensure that you have met the Reporting of Channel Quality Indicator Input Signal Requirements .
  • Measurement results are influenced by any amplitude offsets that are entered, since the level into the UE is altered.

  • There are several parameters that are not specific to this measurement that must be set in order for this measurement to complete without error messages and in order to comply with 3GPP TS 34.121 9.3.1. See Parameters that Affect the HSDPA Reporting of Channel Quality Indicator Measurement .

Troubleshooting Techniques

Check to see if an integrity indicator other than 0 (normal) was returned with the measurement result (see Integrity Indicator ).

  • If Measurement Timeout (2) is returned, the value you entered for the measurement may be too small for the Number of CQI Reports to test and the Number filtered ACK/NACK responses to test . In this case, either reduce the number of reports to test or increase the timeout value.
  • If Unsupported Configuration (22) is returned, you must set Channel Type to 12.2k RMC + HSDPA .

Related Topics

  • HSDPA Reporting of Channel Quality Indicator Measurement Description


Inner Loop Power Troubleshooting

Inner Loop Power Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

  • This measurement is not supported on HSDPA or HSPA connections.
  • No other measurements can be running when an inner loop power measurement is performed. If any measurements are running when an inner loop power measurement is initiated, they are closed and a message is displayed to indicate that they were closed.
  • To use this measurement in Active Cell mode, the UE (mobile station) needs to be up on a call. To use the measurement in FDD Test Mode, UE should be capable of deriving TPC commands in FDD test mode. You needs to configure the UE to use the proper power control algorithm and the step size before initiating a measurement.
  • The Inner Loop Power measurement attempts to reconfigure the UE to the desired algorithm mode and power step size (if it is required) before running the measurement. If the UE does not receive or acknowledge this request, the test set issues an error "No physical channel reconfig complete received".
  • For test segments E-H, if Maximum Power Threshold for Test Control and Minimum Power Threshold for Test Control are set to Manual , ensure that Maximum Power Threshold for Test Manual is greater than Minimum Power Threshold for Test Manual . Otherwise, the measurement will return a result of "fail", as you've specified that none of the measured timeslots be considered for pass/fail.
  • The test set does not support testing the UE in compressed mode with this measurement, therefore 3 dB power control step size is not allowed.
  • Trigger Delay should only be set to a non-zero value if your UE's output power response to TPC commands is delayed (i.e. if your UE is not operating properly). If your UE is behaving correctly in the timing of power changes in response to TPC commands, non-zero values of the Trigger Delay setting can cause unspecified results.
  • Absolute measurement results are affected by any amplitude offsets that are entered (relative measurement results are not). See Amplitude Offset .
  • This measurement does not provide valid results while on a faded channel (see Digital Bus Information ).

Interpreting Integrity Indicator Values

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. Calibrating the Test Set .

Unable to Cal; Power unstable (24) is returned if, during test segments E-H, the UE does not properly respond to power control during the re-range periods.

See Integrity Indicator .

Related Topics

  • Inner Loop Power Measurement Description


IQ Tuning Measurement Troubleshooting

IQ Tuning Measurement Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

  • This measurement is not supported on HSPA connections.
  • When on a non-HSDPA connection, you must set Trigger Source to any value other than HS-DPCCH .
  • To measure IQ tuning on an HSDPA connection, you must set Trigger Source to HS-DPCCH .
  • The sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval cannot exceed 1.0 slot. If you wish to place the measurement interval after the slot boundary using the HS-DPCCH Trigger Subslot Alignment setting, you must first decrease the HS-DPCCH Measurement Interval setting appropriately.
  • During remote operation of the IQ tuning measurement, it is recommended that you configure the trigger arm to single. See SETup:WIQTuning . If the trigger arm is not set to single, you may not be able to retrieve measurement results during remote use if you are using the INIT:DONE? query. When the trigger arm is continuous, the measurement rearms itself and starts another measurement cycle, causing the INIT:DONE? query to always return "WAIT". See Trigger Arm (Single or Continuous) Description for more explanation.
  • Your UE must be synchronized to the test set for this measurement to operate correctly.
  • RF In/Out Amplitude offsets entered do not affect these measurement results unless the received signal level becomes too low to accurately detect relative I/Q modulation vector transitions.
  • While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to Immediate or External .
  • Timing Error results are not available when Trigger Source is set to Immediate .

Other Considerations

  • Only Beta c (DPCCH) and Beta d1 (DPDCH 1) provide results (other than NaN) while on a non-HSDPA connection. Beta d2-6 are reserved for future use.
  • Beta hsacknak and Beta hscqi only provide results (other than NaN) when on an HSDPA connection ( lab application or feature-licensed test application only ).
  • When HS-DPCCH Trigger Slot Alignment is set to AckNack , a valid result is returned for Beta hsacknak , NaN is returned for Beta hscqi . Likewise, when HS-DPCCH Trigger Slot Alignment is set to CQI1 or CQI2 , a valid result is returned for Beta hscqi , NaN is returned for Beta hsacknak .

Interpreting Integrity Indicator Values

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Cannot Correlate (17) is returned, the test set cannot demodulate the signal from the mobile station (UE). Make sure the uplink scrambling code from the mobile station matches the UL Scrambling setting on the test set (see CALL:UPLink ).

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. See Calibrating the Test Set .

See Integrity Indicator .

Related Topics

  • IQ Tuning Measurement Description


Loopback Bit Error Ratio Troubleshooting

Loopback Bit Error Ratio Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

  • To perform the Loopback BER measurement while in Active Cell Operating Mode , you must be on an RB test mode call, with Channel Type set to a symmetrical RMC. Loopback BER can not be measured for Asymmetrical RMCs .
  • The UE must be configured in loopback mode 1 or 2 (see UE Loopback Type ). When using FDD Test Operating Mode , you must manually configure the UE during testing; no overhead messaging or signaling is provided to set up the mobile station in this operating mode. See UE Control During FDD Test Mode Operation .
  • If the Confidence Test Result is Max Bits Tested , you may need to increase the Number of Bits to Test to enable a Pass or Fail result.
  • Uplink DTCH RMC CRC Presence must be set to Present .
  • Loopback Delay results can not be obtained when DL DTCH Data is set to All Zeros or All Ones .
  • During remote operation of the loopback bit error ratio measurement, you should configure the trigger arm to single. See SETup:WBERror and Triggering of Measurements .
  • This measurement always uses protocol triggering. A measurement cannot be made unless the UE is synchronized to the test set's downlink signal and is transmitting a corresponding uplink signal.
  • Synchronization requirements

    In order for the test set to synchronize to the UE's signal and perform the BER measurement, the following must occur:

    • The loopback delay must be less than 50 transmission time intervals of the DTCH.
      Note, some UEs buffer data during a Physical Channel Reconfiguration (handover), then increase the loopback delay to compensate. As a result, after several handovers, the loopback delay may be too great for the test set to synchronize to the UE's signal. To correct the problem, set RB Test Mode PCR Loopback Messaging State to On before performing the Physical Channel Reconfiguration (this clears the UE's buffer and resets its loopback delay as part of every Physical Channel Reconfiguration), or perform a Transport Channel Reconfiguration to the same RMC after the Physical Channel Reconfiguration to reset the loopback delay in the UE.
    • The bit error ratio must be less than 10% on a block-by-block basis for three consecutive blocks.
      If necessary, increase Cell Power or decrease AWGN Power to decrease BER and allow the test set to synchronize to the uplink signal.

  • Measurement results are affected by any amplitude offsets that are entered, since the level into the UE is altered.

Other Considerations

  • During front panel operation of the loopback BER measurement, intermediate results are always displayed (i.e. as bit errors are detected the current bit error ratio for the test is updated). This may cause the bit error ratio to vary throughout execution of the measurement. You should use the final bit error ratio reported to determine the BER result for the measurement, not the intermediate results.

    NOTE
    If trigger arm is set to continuous, it may be difficult to determine the final bit error ratio result. Watching the bits tested increment will help you determine when the measurement is reporting the final result. (The test set will then immediately begin the next measurement.)

  • The test set may return a Confidence Test Result of Max Bits Tested even when the Bit Error Ratio result is above the specified BER Requirement . This is because as testing progresses, the bit error ratio trajectory converges to a value (see 3GPP TS 34.121 Figure F.6.1.9 ). The test set attempts to predict if the BER value the UE is converging to will be above or below the BER Requirement . The BER trajectory may temporarily exceed the BER Requirement yet still converge to a value below the BER Requirement . A result of Max Bits Tested is returned by the test set if it can not accurately predict whether the trajectory is converging to a value above or below the BER Requirement .

  • When Confidence State is Off , you may set the number of data bits to test during the measurement using the Number of Bits to Test setting. However, the actual number of bits tested is always the largest multiple of the number of bits needed to fill a DTCH transport block for the transmitted format. For example, for the 12.2 kbps reference measurement channel (RMC) the transport block is 244 bits. So if you set the number of bits to test to 1000, the actual number of bits tested will be 1220 (1000 bits/244 bits per block = 4.1 blocks, so 5 blocks are required to test at least 1000 bits. 5 blocks x 244 bits per block = 1220 bits).

    When Confidence State is On , you may set the maximum number of bits to test during the measurement using the Number of Bits to Test setting. However, the actual number of bits tested will be less than this number if an early pass or early fail event occurs (see Confidence Test Result ). If a Confidence Test Result of Max Bits Tested is returned, then the actual number of bits tested is the largest multiple of the number of bits needed to fill a DTCH transport block for the transmitted format.

  • The loopback block error ratio and loopback bit error ratio measurements can not be run concurrently. If a BLER measurement is initiated while a BER measurement is active, the BER measurement will be aborted and the measurement will be closed (and vice versa).

Interpreting Integrity Indicator Values

  • If Measurement Timeout (2) is returned:
    • The measurement timeout value you entered for the measurement may be too small for the number of bits being used. In this case, either reduce the number of bits to test or increase the timeout value.
    • The measurement may not have started because it could not align the received data with the transmitted data. This happens if any of the following conditions occur:
      • The test set is unable to synchronize to the uplink signal. See Synchronization requirements .
      • The UE is not configured for the proper loopback mode.
      • The UE is not configured for the proper uplink transport format.
  • Questionable MS-to-Cell Data (28) is returned if a CRC Error or Missing Block is detected (see CRC Errors and Missing Blocks ).

Related Topics

Integrity Indicator


Occupied Bandwidth Troubleshooting

Occupied Bandwidth Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

During remote operation of the occupied bandwidth measurement, you should configure the trigger arm to single. See SETup:WOBWidth .

If the trigger arm is not set to single, you may not be able to retrieve measurement results during remote use if you are using the INIT:DONE? query. When the trigger arm is continuous, the measurement rearms itself and starts another measurement cycle, causing the INIT:DONE? query to always return "WAIT". See Trigger Arm (Single or Continuous) Description for more explanation.

The trigger source defaults to Auto for the occupied bandwidth measurement, and tries to use protocol triggering if the mobile station (UE) is synchronized to the test set. Immediate triggering is used if the mobile station is not synchronized. While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to Immediate or External .

Interpreting Integrity Indicator Values

This measurement uses auto-ranging to automatically set the expected level into the test set.

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. CALibration Subsystem

See Integrity Indicator .

Related Topics

  • Occupied Bandwidth (OBW) Measurement Description


PRACH Transmit On/Off Power Troubleshooting

PRACH Transmit On/Off Power Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

  • Before performing a PRACH transmit on/off measurement, turn the UE on and wait for it to camp to the test set's signal. When the PRACH transmit on/off power measurement is initiated, the test set pages the UE. The UE must be camped to the test set and in idle mode before performing the PRACH Transmit On/Off Power measurement.
  • Recommended PRACH Preambles and PRACH Ramping Cycles (MMAX) settings

    The measurement requires a minimum of 3 PRACH preambles, but it is recommended that you set PRACH Preambles to 4 to ensure that the test set is able to capture two PRACH bursts for analysis. It is also recommended that you set PRACH Preambles to no greater than 4 and set PRACH Ramping Cycles (MMAX) to 1 to allow the UE's PRACH sequence to end as soon as possible. This helps avoid the following issue: Test set may lock up if operations are attempted before the UE completes its PRACH sequence .

  • Importance of Setting Call Limit State to Off before Initiating a PRACH Measurement

    It is recommended that you set Call Limit State to Off before initiating this measurement. Then, when the measurement completes, if the UE is still sending PRACH preambles to the test set, the test set will acknowledge the UE. Note, when the test set acknowledges the UE, the call is not completed because the UE is attempting to establish a test set-originated call, whereas the test set acknowledges the UE expecting a UE-originated call. Acknowledging the UE helps prevent the UE from placing the test set into its cell barred list (see Test Set in Cell Barred List ). When the test set acknowledges the UE, you will see the call status move from Paging to Idle , to Setup , to Releasing and then back to Idle . Do not attempt to stop or re-initiate the measurement, or to start any new measurements until the test set has reached Idle state (see Test set may lock up if operations are attempted before the UE completes its PRACH sequence ).

    Setting call limit mode to off before initiating the measurement also avoids another issue: When the measurement completes, if you try to send signalling to the UE while it is still sending PRACH preambles to the test set, the UE will ignore the incoming messages and the signalling will fail. If call limit mode is set to off, the test set will acknowledge the UE and cause it to stop sending PRACH preambles, and then send the signalling you have requested to the UE.

  • Available Subchannels (Bit Mask) must be set to only one available subchannel.
  • During front panel operation of this measurement, you must press the START SINGLE key to initiate the measurement.
  • No other measurements can be running when a PRACH transmit on/off power measurement is performed. If any measurements are running when a PRACH transmit On/Off power measurement is initiated, they are closed and a message is displayed to indicate that they were closed.
  • An RF rise to a level within 9 dB of the expected power ( Initial PRACH TX Power if Power Control is set to Auto, or Manual Power if Power Control is set to Manual, see Receiver Control ) is required to allow the measurement to then trigger based on protocol. If your UE is not transmitting at the expected Initial PRACH Tx Power level, you may need to set expected power manually.
  • Absolute measurement results are affected by any amplitude offsets that are entered (relative measurement results are not). See Amplitude Offset .

Other Considerations

  • Test set may lock up if operations are attempted before the UE completes its PRACH sequence

    When the measurement completes, you must wait until the UE has finished its PRACH sequence before turning off or re-initiating the measurement, or before starting any new measurements. Otherwise, the test set may lock up. If you are controlling the test set via remote program, you must include a wait period after the measurement completes (see Programming a PRACH Transmit On/Off Power Measurement ).

    If you set Call Limit Mode to Off before initiating the measurement, you will know that the UE's PRACH sequence is complete when you see the call status move from Paging to Idle , to Setup , to Releasing and then back to Idle (see Importance of Setting Call Limit State to Off before Initiating a PRACH Measurement ). Do not attempt any of the above listed operations until the test set has reached Idle state.

    To allow the UE to complete its PRACH sequence as quickly as possible, it is recommended that you set PRACH Preambles to 4 and PRACH Ramping Cycles (MMAX) to 1 (see Recommended PRACH Preambles and PRACH Ramping Cycles (MMAX) settings ).

  • To change the UE's Initial PRACH TX Power level (which is reported by the Burst On Power result), you can change Primary CPICH TX Power , Uplink Interference , Constant Value , Cell Power and/or CPICH RSCP (Received Signal Code Power) . If you change Primary CPICH TX Power , Uplink Interference , or Constant Value , you must force the UE to re-read the BCCH before initiating the measurement (so that it will use the same values for these settings as the test set when calculating the power of its initial PRACH preamble). If your UE supports the Broadcast Channel (BCCH) Update Procedure (SIB Contents) , set BCCH Update Page to Auto to force the UE to re-read the BCCH. If your UE does not support the BCCH Update procedure, see BCCH Update Page for suggestions on forcing the UE to re-read the BCCH.
  • If the UE registers after the measurement has completed, the measurement results will no longer be viewable from the front panel or accessible via the FETCh:WOOPower commands. This will occur if the UE expects integrity protection to be enabled. See UE Registers Continuously Due to Integrity Protection Expectation .
  • If the PRACH transmit on/off power measurement timeout is not on, the PRACH transmit on/off measurement will hang until it is triggered by a PRACH burst. You can reset the measurement by pressing the MEASUREMENT RESET key.
  • This measurement does not provide valid results while on a faded channel (see Digital Bus Information ).

Interpreting Integrity Indicator Values

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. Calibrating the Test Set

See Integrity Indicator .

Related Topics

  • PRACH Transmit On/Off Power Measurement Description


Perceptual Evaluation of Speech Quality Measurement Troubleshooting

Perceptual Evaluation of Speech Quality Measurement Troubleshooting

Last updated: October 26, 2010

NOTE
The Perceptual Evaluation of Speech Quality measurement can not be concurrent with the Audio Analyzer instrument or the Real Time vocoder, nor can it be concurrent with the Swept Audio or the Multi-tone audio measurement. Hence starting the PESQ measurement will turn off any other measurement that is active, and vice versa.

NOTE
All of the measurements except for the Perceptual Evaluation of Speech Quality measurement become unavailable when the AMR Source is set to PESQ .

Possible Setup Issues

During remote operation of this measurement, you should always set the Trigger Arm to Single. See SETup:WPESquality:CONTinuous . If single triggering is used during manual operation, press the START SINGLE key to trigger each measurement.

For accurate measurement results, always set all the Perceptual Evaluation of Speech Quality measurement setup parameters to their proper settings for the measurement being made.

  • You should select the AMR Radio Access Bearer to one of the voice option and set the AMR Source to PESQ (see AMR Setup ) to perform the PESQ measurement.
  • It is recommended that you perform the uplink or the downlink PESQ measurement separately if your mobile phone has not a good isolation between the audio in and audio out path. Performing the uplink and downlink PESQ measurement separately helps to ensure the measurement results to be more accurate.
  • The PESQ may cost more than 10 seconds to be completed. You should make sure the Measurement Timeout is set to a time long enough to complete the measurement, or you can simply turn this setting to Off to avoid a un-expected timeout.
  • During downlink PESQ measurement, if "Over Range" is displayed, it indicates that the measured audio signal at AUDIO IN port is far above the Expected Audio In Peak Voltage setting. You should increase the Expected Audio In Peak Voltage setting. If "Under Range" is displayed, it indicates that the measured audio signal at AUDIO IN port is far below the Expected Audio In Peak Voltage setting. You should decrease the Expected Audio In Peak Voltage setting. You can adjust the Expected Audio In Peak Voltage setting based on the value of PESQ downlink headroom value.

Other Techniques

Check to see if an integrity indicator other than 0 (normal) was returned with a measurement result (see Integrity Indicator ).

Related Topics

Perceptual Evaluation of Speech Quality (PESQ) Measurement Description


Swept Audio Measurement Troubleshooting

Swept Audio Measurement Troubleshooting

January 16, 2009

Possible Setup Issues

During remote operation of the Swept Audio measurement, you should always set the Trigger Arm setting to Single. The length of time required to return a measurement over GPIB using continuous triggering varies, but is always longer than when using single triggering. Continuous triggering can also cause problems when the INITiate:DONE? query is used.

If digital measurements are active, turn them off or set their trigger source to Immediate. See Triggering of Measurements .

The Detector Type selected (peak or rms) also sets how Audio Level measurements are displayed; as a peak value or an rms value. When comparing returned values over GPIB to your specifications, be sure to take into account the type of detector being used.

The Expected Peak Voltage is always set in V peak , regardless of the Detector Type selected, and cannot exceed 20 V peak (14.1 V rms ).

For accurate measurements, always set the Detector Type, Filter Type, and other audio analyzer settings for the type of measurement being made. The SINAD and Distortion measurements typically use different settings than the Audio Level measurement. See Audio Analyzer Measurement Description and Audio Analyzer Block Diagram .

For very low level audio signals, or for measurements made in a noisy environment, use the 100 Hz BW BPF filter to reduce the affects of noise (see Audio Analyzer Measurement Description ).

Interpreting Integrity Indicator Values

See Integrity Indicator .

If over range (5) is returned, the input level is greater than 4.9 dB above the Expected Peak Amplitude value or the maximum input level of 20 volts peak.

If under range (6) is returned, the input level is lower than 8 dB below the Expected Peak Amplitude value.

If the signal has both over range and under range conditions, only the over range condition (5) is indicated.


Troubleshooting Simultaneous Services

Troubleshooting Simultaneous Services

Last updated: March 20, 2009

This section only applies to the lab application.

  • Ensure that GPRS Radio Access Bearer is set to one of the following settings:
    • 64k PS Data RAB
    • 64k UL/384k DL PS Data RAB
    • HSUPA UL / HSDPA DL PS
  • Ensure that Compressed Mode is disabled. This setting can be enabled or disabled while simultaneous services is active.
  • Ensure that Soft Handover State is Off. This setting can be enabled or disabled while simultaneous services is active.

Related Topics

Simultaneous Services


Spectrum Monitor Troubleshooting

Spectrum Monitor Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

During remote operation of the Spectrum Monitor you should configure the trigger arm to single, see SETup:SMONitor .

If the trigger arm is not set to single, the Spectrum Monitor may not return a result. When trigger arm is continuous the Spectrum Monitor rearms itself and starts another measurement cycle, during remote operation the fetch query may not be synchronized to the measurement cycle, see Measurement States .

If trigger source immediate is used for burst modulated signals the results returned will be unreliable. Burst modulated signals should be measured with Trigger Source set to RF Rise or Auto. For RF Rise triggering to work correctly, the signal should be no less than 20 dB below the reference and greater than -20 dBm.

While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to Immediate , External or RF Rise .

Interpreting Integrity Indicator values

See Integrity Indicator .

Related Topics

Spectrum Monitor Description


Spectrum Emission Mask Troubleshooting

Spectrum Emission Mask Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

  • During remote operation of the spectrum emission mask measurement, it is recommended that you configure the trigger arm to single. See SETup:WSEMask . If the trigger arm is not set to single, you may not be able to retrieve measurement results during remote use if you are using the INIT:DONE? query. When the trigger arm is continuous, the measurement rearms itself and starts another measurement cycle, causing the INIT:DONE? query to always return "WAIT". See Trigger Arm (Single or Continuous) Description for more explanation.
  • The trigger source defaults to Auto for the spectrum emission mask measurement, and tries to use protocol triggering if the mobile station (UE) is synchronized to the test set. Immediate triggering is used if the mobile station is not synchronized. While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to Immediate or External .
  • Trigger Source can only be set to HS-DPCCH when Channel Type = 12.2k RMC + HSDPA or 12.2k RMC + HSPA .
  • Measurement results for the mask are not affected by any amplitude offsets that are entered because they are all relative to the in-channel power. The absolute in-channel power returned by the measurement will reflect any amplitude offset settings for the appropriate frequency range.
  • Ensure that the measurement has been properly calibrated (see Spectrum Emission Mask Measurement Calibration ).
  • Ensure that you are meeting the Spectrum Emission Mask Input Signal Requirements .

Interpreting Integrity Indicator Values

This measurement uses auto-ranging to automatically set the expected level into the test set.

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. See Calibration Strategy

See Integrity Indicator .

Related Topics

Spectrum Emission Mask Measurement Description


Test Set Lockup During Power Up Sequence

Test Set Lockup During Power Up Sequence

Last updated: January 16, 2009

Description

Loading application firmware onto your test set that is not compatible with your test set's hardware configuration will cause your test set to lock up when restarted.

For information on application firmware and test set hardware compatibility, see:

http://www.agilent.com/find/E5515

(select either E5515B or E5515C Release Notes).

Test sets shipped after February, 2004 include a lockup recovery utility in the event that a test set lockup occurs. If your test set has locked up during its power up sequence, turn the test set off. Turn the test set back on, and when the following text is displayed:

"Press `SYSTEM CONFIG' key to enter application selection utility."

press the SYSTEM CONFIG key.

If you press the SYSTEM CONFIG key within five seconds from the time this message is first displayed, a menu of installed applications is displayed that allows you to select an application to load.

Select an application that is compatible with your test set's hardware by entering the appropriate number listed on the display using the DATA ENTRY keys.


Thermal Power Troubleshooting

Thermal Power Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

During remote operation of the thermal power measurement you should configure the trigger arm to single. See SETup:WTPower .

If the trigger arm is not set to single, the measurement may not return a result. When trigger arm is continuous, the measurement rearms itself and starts another measurement cycle; possibly interrupting the FETCh operation during remote use. See Measurement States .

The trigger source is always immediate for the thermal power measurement. No synchronization or external signals are required.

Measurement results are affected by any RF In/Out amplitude offsets that are entered. See Amplitude Offset .

The thermal power measurement value may be slightly higher than the channel power measurement's value (typically about 0.25 dB). This is because the channel power measurement is band-limited, rejecting the additional power that may be in the uplink signal's sidebands.

This is a broadband, unfiltered power measurement. Therefore, virtually any signal present at the RF IN/OUT connector will affect this measurement. If the measured level exceeds the channel power measurement by more than 0.25 dBm, verify that the only signal present is the mobile station's (UE) uplink signal.

Interpreting Integrity Indicator Values

This measurement uses autoranging to automatically set the expected level into the test set.

If Over Range (5) is returned, the signal exceeds the maximum allowable level for the test set.

If Under Range (6) is returned, the measured signal is below -21 dBm. The thermal power measurement is specified to operate accurately down to -10 dBm, and will operate with degraded accuracy down to -20 dBm. Use the channel power measurement for measuring lower level signals.

See Integrity Indicator .

Related Topics

Thermal Power Measurement Description


Troubleshooting the Two-Cell Test System

Troubleshooting the Two-Cell Test System

Last updated: January 16, 2009

This section is only applicable to the lab application.

Description

Possible Setup Issues

  • Important : DUT IP Address must be set to a different value in each test set in the two-cell test system.
  • The operating mode in both test sets must be set to Active Cell in order to perform cell transitions, as this is the only operating mode that provides signaling to the mobile.
  • While operating in the GSM/GPRS/EGPRS application/format, the connection type must be set to Auto in both test sets of the two-cell test system in order to maintain IP-based data connections during cell reselection. Any other connection type setting terminates the active data connection during cell reselection and does not restart the data connection once cell reselection is complete.
  • It is recommended that you configure the neighbor cell list in each test set to contain the other test set's information (using the SIB 11 Cell Info List in W-CDMA/HSPA or the Cell Lists in GSM/GPRS/EGPRS). This enables the mobile to measure the other test set before transitioning to it (some mobiles will not perform a "blind" handover) and allows you to view the mobile's measurement reports for the test set. Ensure that you have properly configured the mobile measurement reports for measuring the destination test set's current configuration by using the Compressed Mode settings in W-CDMA/HSPA (the HSUPA packet data service in the test set does not currently support compressed mode) or the Measurement Reports settings in GSM/GPRS/EGPRS.
  • Network Control Order in the GSM/GPRS/EGPRS application determines how the mobile should perform cell reselections. If Network Control Order is set to NC0 or NC1 in the test set to which the mobile is currently attached, it may not respond to network-initiated attempts at cell reselection. Also, if the test set to which the mobile is attached has Network Control Order set to NC2 , the mobile may not perform autonomous cell reselection.

Operating Considerations

  • Mobile initiated cell reselections made during GSM/GPRS/EGPRS PS data transfer mode may result in a TBF aborted by the mobile with no indication provided to the test set as to why the abort is occurring. In this circumstance, a warning appears at the test set from which the mobile is moving.
  • When performing a cell reselection from GSM/GPRS/EGPRS while actively transferring data, data may arrive for the mobile at the originating test set after the mobile has moved from the originating test set, but before it has arrived at the destination test set. In this case, the originating test set posts an error, but the reselection is not impacted. Once the mobile is established at the destination test set, all subsequent data is tunneled to the mobile at the destination test set.
  • Since the two-cell test system allows you to control when handovers and cell reselections occur, the measurement reports that are returned periodically by the mobile are not used by the test sets. you must order network-initiated cell transitions; it is not possible for the test sets to automatically order the transitions based on measurement reports from the mobile
  • The DUT IP Address setting is inaccessible if the mobile is connected to the current test set but using an IP address originally assigned by the other test set. When a mobile has an active PDP context with one test set and transitions to another, a tunnel is created to route data to and from the mobile via the originating test set. During tunneling, the mobile uses the DUT IP Address provided by the originating test set, not the DUT IP Address of the serving test set. In this case, the IP data trace is shown on the Data Throughput Monitor of the originating test set; only the OTA data trace is shown on the destination test set's Data Throughput Monitor. Refer to the External Device Connection documentation for additional information.
  • The External Device Connection is disconnected as a result of a full preset. You must re-establish the External Device Connection before continuing two-cell testing.

Related Topics

Two-Cell Test System


Troubleshooting UE Reported Measurements

Troubleshooting UE Reported Measurements

Last updated: January 16, 2009

  • When you issue the Send Meas Request command (see Cell 1/Cell 2 UE Reported Measurements ), if no measurement results are displayed for cell 1 (or cell 2 when using the lab application), consider the following:

    When you issue the Send Meas Request command, the UE is directed to perform measurements on the neighbor cells specified in SIB 11 (see SIB11 Cell Info List ). It should also report measurement results for any other detected cells not on the neighbor list. However some UEs may require that the cell be in the neighbor list in order to perform measurements on it. Thus, ensure that you have entered cell 1's Primary Scrambling Code in the Intra-frequency Cells list (and/or cell 2's primary scrambling code, see "Cell 2 Overview" on page 1 ).

    For cell 2, see also Cell 2 Power is on, but no Mobile Station Reported Pilot Level Information is being displayed for Cell 2 .

  • UE Reported Measurements are not available on an HSDPA connection.

Related Topics

UE Reported Measurements


Troubleshooting Video Call

Troubleshooting Video Call

Last updated: January 16, 2009

UE-to-UE Video Call

This section is only applicable to the lab application and to a test application with the required feature license.

  • Ensure that Video Call Type is set to UE-to-UE .
  • The 8960 receiving the UE-to-UE video call origination must be in Active Cell Operating Mode , in Idle state.
  • If one of the 8960s is partially preset while up on a UE-to-UE video call, the call to its UE is dropped with no over-the-air signaling. If the other UE does not recognize that the call has dropped (and thus ends the call), you should manually end the call or partially preset its 8960 as well.
  • If one of the 8960s is fully preset while up on a UE-to-UE video call, the external device connection is disconnected, which causes both 8960s to end the call with their respective UEs.
  • Originating a UE-to-UE video call on your UE may require different key presses than originating a voice call.
  • The underlying architecture of the External Device Connection feature (used to establish a UE-to-UE Video Call ) has changed over time. The implementations are not compatible (see Troubleshooting External Device Connection ). To establish an External Device Connection between two test sets, the test sets must have compatible firmware (see www.agilent.com/find/8960upgrades for more information).

UE-to-8960LAN Video Call

This section is only applicable to the lab application.

  • Ensure that Video Call Type is set to UE-to-8960LAN .
  • To originate a UE-to-8960LAN video call from your external device, Allow Remote Call Origination State must be set to On .
  • To release the UE-to-8960LAN video call from your external device, Allow Remote Call Release State must be set to On .
  • The timing between the "Video Call Established Indication" from the test set and the arrival of the first data message on the data interface is not specified; either message can arrive at the external device first.
  • The timing between the "Video Call Terminated Indication" from the test set and the arrival of the last data message on the data interface is not specified; either message can arrive at the external device last.
  • Ensure that your external device is set to send control messages to the UDP port and IP address specified by the Control Message Receiving UDP Port and LAN IP Address settings.
  • Ensure that your external device is set to receive control messages at the UDP port and IP address specified by the Control Message Destination UDP Port and Control Message Destination IP Address settings.
  • Ensure that your external device is set to send data messages to the UDP port and IP address specified by the Data Message Receiving UDP Port and LAN IP Address settings.
  • Ensure that your external device is set to receive data messages at the UDP port and IP address specified by the Data Message Destination UDP Port and Data Message Destination IP Address settings.

Loopback Video Call

This section is only applicable to the lab application.

  • Ensure that Video Call Type is set to Loopback .
  • The 8960 receiving the Loopback video call origination must be in Active Cell Operating Mode , in Idle state.
  • Originating a loopback video call on your UE may require different key presses than originating a voice call.

Related Topics

Video Call


Block Error Ratio Troubleshooting

Block Error Ratio Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

  • When performing the block error ratio measurement for Symmetrical RMCs :
    • The UE must be configured in loopback mode 2 (see UE Loopback Type ).
    • Uplink DTCH RMC CRC Presence must be set to Used for Data .
  • When using FDD Test Operating Mode , you must manually configure the UE during testing; no overhead messaging or signaling is provided to set up the mobile station in this operating mode. See UE Control During FDD Test Mode Operation .
  • For Asymmetrical RMCs , the test set will stop sending downlink transport blocks to the UE if it does not receive an acknowledgment or retransmission request from the UE for a significant period of time. If the UE does not then drop the call, the measurement will hang. You must increase the downlink signal-to-noise ratio (e.g. increase Cell Power or decrease AWGN Power so that the UE can detect the downlink transport blocks and send acknowledgments or retransmission requests to the test set). You must also disconnect and then reconnect the call, then re-initiate the measurement. To prevent the measurement from hanging again in the future, enable the Measurement Timeout . Note, however, that before re-initiating the measurement you will still need to increase the downlink signal-to-noise ratio, then disconnect and reconnect the call.
  • During remote operation of the block error ratio measurement, you should configure the trigger arm to single. See SETup:WBLerror and Triggering of Measurements .
  • During front panel operation of this measurement, if Trigger Arm is set to Single (see Trigger Arm (Single or Continuous) Description ), you must press the START SINGLE key to initiate the measurement.
  • Measurement results are influenced by any amplitude offsets that are entered, since the level into the UE is altered.

Interpreting Integrity Indicator Values

  • If Measurement Timeout (2) is returned:
    • The Measurement Timeout value you entered for the measurement may be too small for the Number of Blocks to Test . In this case, either reduce the number of blocks to test or increase the timeout value.
  • Questionable MS-to-Cell Data (28) is returned if a missing block is detected (see Uplink Missing Blocks ).

Other Considerations

  • The block error ratio and loopback bit error ratio measurements can not be run concurrently. If a BLER measurement is initiated while a BER measurement is active, the BER measurement is aborted and the measurement is closed (and vice versa).

  • It is not necessary to synchronize the test set and UE when performing the block error ratio measurement (it is not necessary to align received uplink transport blocks with their corresponding downlink transport blocks), whereas the test set must align the uplink and downlink blocks before performing the loopback BER measurement. Thus, the measurement does not determine the UE's Loopback Delay , whereas the loopback BER measurement does.
  • To perform the block error ratio measurement for symmetrical RMCs, Uplink DTCH RMC CRC Presence must be set to Used for Data . This disables the uplink CRC. Thus, the block error ratio measurement does not report any uplink CRC Errors , whereas the loopback BER measurement does. Thus, it is very important that you ensure the uplink is robust (error free).
  • The Uplink Missing Blocks result does not apply to Asymmetrical RMCs .

Related Topics

Integrity Indicator


Change of TFC (Transport Format Combination) Troubleshooting

Change of TFC (Transport Format Combination) Troubleshooting

Last updated: January 16, 2009

This section is only applicable to the lab application.

Possible Setup Issues

  • Before performing the change of TFC measurement, you must ensure the following:

    • Operating Mode = Active Cell Operating Mode .
    • Current Service Type = Radio Bearer Test Mode (you must be on an RB Test Mode connection).
    • This measurement is not supported on HSDPA or HSPA connections.
    • Uplink Dummy DCCH Data = Off .
    • Initial output level of your UE is such that its output power level with DPDCH on and off falls within the measurement's required input level (see Change of TFC Measurement Input Signal Requirements ).

  • The following settings are recommended based on the 3GPP TS 34.121 5.6 requirements:

    • UE Target Power = 0 dBm .
    • UL CL Power Control Mode = Alternating bits .
    • UL CL Power Ctrl Algorithm = Two .
    • Uplink DPCH Bc/Bd Control = Auto . This ensures that [image] and [image] are (automatically) set to the values specified by the standards (for example, 0.5333 and 1.0 for 12.2k RMC).
  • During front panel operation of this measurement, you must press the START SINGLE key to initiate the measurement.
  • The change of TFC measurement is triggered when the TFCI indicates no data is present on the DPDCH. If the UE does not properly set the TFCI bit to indicate when data is present on the DPDCH, the measurement will hang. To prevent the measurement from hanging indefinitely, set the Measurement Timeout . You can reset the measurement, if needed, by pressing the MEASUREMENT RESET key.
  • This measurement does not provide valid results while on a faded channel (see Digital Bus Information ).

Other Considerations

  • No other measurements can run while a change of TFC measurement is being performed. If any measurements are running when a change of TFC measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while a change of TFC measurement is running, the change of TFC measurement is closed and a message is displayed.
  • Ensure that the UE is meeting the Change of TFC Measurement Input Signal Requirements .
  • The change of TFC measurement must be properly calibrated (see Change of TFC Measurement Calibration )

Related Topics

  • Change of TFC (Transport Format Combination) Measurement Description


Dynamic Power Analysis Troubleshooting

Dynamic Power Analysis Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

  • The product of Steps and Step Length must not exceed 58.260 ms (a total of 58.26 ms of power sequence can be analyzed at a time).
  • Measurement Interval must be less than or equal to Step Length .
  • During remote operation of the dynamic power analysis measurement, it is recommended that you configure the Trigger Arm to Single .
  • During front panel operation of this measurement, if Trigger Arm is set to Single (see Trigger Arm (Single or Continuous) Description ), you must press the START SINGLE key to initiate the measurement.

UE Power Calibration:

  • To ensure that the measurement executes as quickly as possible, the UE should transmit its power sequence continuously until the measurement completes. This ensures that as soon as the measurement is done auto-ranging, another power sequence is immediately available for measurement. See Auto-ranging in the Dynamic Power Analysis Measurement for UE Power Calibration .
  • The measurement is most accurate over a 25 dB range. If the UE's power sequence spans more than 25 dB, the test set will measure and report the power of the entire sequence, but accuracy is degraded for steps that are more than 25 dB below the highest power in the sequence. To measure a power range greater than 25 dB, you must break the power range up into individual power sequences that do not exceed 25 dB.
  • To ensure proper autoranging, you must specify the number of steps in your sequence and their duration using the Steps and Step Length settings. It is important that you set Steps equal or greater than the number of steps in your UE's power sequence so that the entire power sequence is evaluated during the autoranging.
  • To ensure proper triggering when Trigger Source is set to RF Rise , it is highly recommended that you use trigger qualification for robust triggering (see Trigger Qualification State ).
  • Each step in the power sequence must be identical in length.
  • RF Rise Trigger Threshold must be set to within 0 dB to -25 dB of the Expected Power .
  • To use the measurement, you must first set Measurement Frequency to the expected UE transmitter frequency and set Manual Power to the maximum expected power for the sequence. You can perform the dynamic power analysis measurement in Active Cell Operating Mode or FDD Test Operating Mode . However, since this measurement does not utilize any overhead signalling to control the UE's power or frequency, you must manually set the test set's Expected Power and Measurement Frequency in either operating mode.
  • The UE's signal may or may not be modulated with an uplink DPCH signal. If the signal is not modulated with an uplink DPCH signal and is offset in frequency from the expected measurement frequency, you may need to use the Frequency Offset setting to ensure the most accurate power measurements possible.
  • The test set assumes a crest factor of 3.1 dB for the signal (as is typical for an uplink DPCH signal relative to a CW signal) and thus actually triggers when the input signal reaches the RF Rise Trigger Threshold level plus 3.1 dB. If the UE's signal has a crest factor other than 3.1 dB, you must set the RF Rise Trigger Threshold level accordingly.

HSDPA or HSPA Power versus Time ( lab application or feature-licensed test application only )

  • To perform HSDPA or HSPA power versus time measurements, you must be on a Radio Bearer Test Mode connection with a Channel Type of 12.2k RMC + HSDPA or 12.2k RMC + HSPA. Note: in FDD Test operating mode the test set does not provide radio bearer setup control of the UE. You must configure the UE to synchronize to the test set, demodulate the downlink HS-SCCH and HS-PDSCH channels and generate the appropriate uplink HS-DPCCH (see Synchronizing the UE to the Test Set's Downlink to Make Measurements ).
  • For HSDPA or HSPA power versus time, it is recommended that you use a Trigger Source of HS-DPCCH or External .

Other Considerations

  • Absolute measurement results are affected by any amplitude offsets that are entered (relative measurement results are not). See Amplitude Offset .
  • Ensure that the measurement has been properly calibrated (see Dynamic Power Analysis Measurement Calibration ).
  • Ensure that you are meeting the Dynamic Power Analysis Measurement Input Signal Requirements .

Related Topics

Dynamic Power Analysis Measurement Description

Manual Operation: How Do I Make a Dynamic Power Analysis Measurement?


Extended Range Dynamic Power Measurement Troubleshooting

Extended Range Dynamic Power Measurement Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

  • The Extended Range Dynamic Power measurement can be made in Active Cell Operating Mode or FDD Test Operating Mode . It is not performed with a call established between the test set and UE. Rather, you must place your UE into a test mode which forces it to transmit two power sequences you desire to measure and 15 power steps (timeslots) in the middle of the two power sequences to allow the test set to re-range its receiver.
  • Before initiating the measurement, you must first set Measurement Frequency to the UE's transmit frequency and set Manual Power to the maximum power expected from the UE's first power sequence. (To best utilize the 45 dB dynamic range of the test set's receiver, the Manual Power should be set the highest power level of the first power sequence.)
  • The measurement must be properly triggered once it has been initiated. See Triggering the Extended Range Dynamic Power Measurement for details.
  • Ensure that the measurement setup parameters meet their respective requirements. See Extended Range Dynamic Power Measurement Parameters for details.
  • See Operating Considerations for more possible setup issues you should pay attention to.

Other Considerations

  • Ensure that you have entered the proper Amplitude Offset values for your test setup. Absolute measurement results are affected by any amplitude offsets that are entered (relative measurement results are not).
  • Ensure that the power sequence to be measured meet the Extended Range Dynamic Power Input Signal Requirements .
  • Before performing an Extended Range Dynamic Power measurement, ensure that the measurement has been properly calibrated (see Calibrating the Test Set ).
  • To ensure that the measurement is not interrupted by other operations, it is recommended that you not send any GPIB commands to the test set or press any front panel keys until the measurement has completed.
  • Check to see if an integrity indicator other than 0 (normal) was returned with the measurement result (see Integrity Indicator ).

Related Topics

Extended Range Dynamic Power Measurement Description

Manual Operation: How Do I Make an Extended Range Dynamic Power Measurement?


Out-of-Synch Handling of Output Power Troubleshooting

Out-of-Synch Handling of Output Power Troubleshooting

Last updated: January 16, 2009

This section is only applicable to the lab application.

Possible Setup Issues

  • The Out-of-Synch Handling of Output Power measurement does not return any measurement results at this time. Initiating the measurement only causes the test set to change its DPCCH_Ec/Ior as specified by the Out-of-Synch Handling of Output Power Measurement Parameters . You must use an external spectrum analyzer to measure the UE's resulting output power. When the Out-of-Synch Handling of Output Power measurement is initiated from the test set, the test set generates a trigger at point A that you can route to the test set's rear panel TRIG OUT connector using the Trigger Output Setup setting, to trigger the spectrum analyzer. See How Do I Make an Out-of-Synch Handling of Output Power Measurement? .
  • Before performing the out-of-synch measurement, you must:
    • Connect the test set's rear panel TRIG OUT port to the rear panel TRIGGER IN port of an external spectrum analyzer (the external spectrum analyzer is required to measure the UE's output power and obtain measurement results, see Out-of-Synch Handling of Output Power Measurement Results ).
    • Connect the UE to the test set's RF IN/OUT port and to the spectrum analyzer's RF INPUT port via an RF splitter, and specify the loss due to the RF splitter in both the test set and the spectrum analyzer.
    • Set Trigger Output Setup to Measurement Generated .
    • Establish a Radio Bearer Test Mode connection (3GPP TS 34.121 5.4.4 specifies a 12.2k RMC connection). This measurement is not supported on HSDPA or HSPA connections.
  • The following settings are recommended based on the 3GPP TS 34.121 5.4.4 requirements. Note that some of these parameters must be set before establishing a connection.
    • Set Connected DL Channel Levels as specified by 3GPP TS 34.121 Table E.3.3 and Table 5.4.4.3:
      • Cell 1 Connected CPICH Level = -10.00 dB .
      • Cell 1 Connected P-CCPCH/SCH Level = -12.00 dB .
      • Cell 1 Connected S-CCPCH Level = Off .
      • Cell 1 Connected PICH Level = -15.00 dB .
      • Cell 1 Connected DPCH Level = -16.60 dB . (This sets DPCCH_Ec/Ior before point A to -16.6 dB, because PO1 = PO2 = PO3 = 0, which makes DPCH_Ec/Ior = DPCCH_Ec/Ior).

      See Downlink Channel Levels .

    • Set (T313 + N313*10 ms) > (Ta-b + 200 ms + Tc-d + Td-e + N315*10 ms) to ensure that the UE will not drop the call when the measurement in initiated (see UE Timer and Constant Parameters and Out-of-Synch Handling of Output Power Measurement Parameters ). The UE may drop the call if the UE timers specify a drop time that is less than the time that the test set's DPCCH_Ec/Ior value is low, plus the time required for the UE to receive N315 "in sync" indicators. 3GPP TS 34.121 Table 5.4.4.2A specifies a value of 15 s for T313 and a value of 200 for N313.
    • Leave the Out-of-Synch Handling of Output Power Measurement Parameters set to their default values, (which correspond to 3GPP TS 34.121 section 5.4.4.2, 5.4.4.4.2 and Table 5.4.4.3):
      • Segment Ta-b Interval = 5.000 s
      • Segment Tc-d Interval = 5.000 s
      • Segment Td-e Interval = 5.000 s
      • DPCCH Quality Ratio Qa-b = -21.60
      • DPCCH Quality Ratio Qb-d = -28.40
      • DPCCH Quality Ratio Qd-e = -24.40
      • DPCCH Quality Ratio Qe+ = -17.60
    • Set UE Target Power to the maximum output power for your UE and set UL CL Power Control Mode to All Up bits .
    • Set Cell Power ( F7 on the Call Parms 1 of 3 menu) to -61 dBm .
    • Select Generator Info ( F3 on the Call Control 2 of 5 menu) and set AWGN Power ( F5 ) to -60 dBm.
  • During front panel operation of this measurement, you must press the START SINGLE key to initiate the measurement.

Other Considerations

  • The out-of-synch handling of output power measurement can be performed while in FDD Test Operating Mode , however you must configure the UE such that its output power will respond appropriately to the changes in the test set's DPCCH_Ec/Ior.

  • No other measurements can be running when an out-of-synch handling of output power measurement is performed. If any measurements are running when an out-of-synch handling of output power measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while an out-of-synch handling of output power measurement is running, the out-of-synch handling of output power measurement is closed and a message is displayed.
  • If the measurement is aborted, the UE could be left in an off state if the pre-measurement value of Cell 1 Connected DPCH Level is less than Qin.
  • The measurement will timeout unless Measurement Timeout > Segment Ta-b Interval + 200 ms + Segment Tc-d Interval + Segment Td-e Interval + 200 ms.
  • This measurement does not provide valid results while on a faded channel (see Digital Bus Information ).

Related Topics

  • Out-of-Synch Handling of Output Power Measurement Description


Phase Discontinuity Troubleshooting

Phase Discontinuity Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

  • In Active Cell Operating Mode , you must be on a call before initiating the measurement.
  • This measurement is not supported on HSPA connections.
  • When on a non-HSDPA call, Trigger Source must be set to Protocol or External . When on an HSDPA call ( lab application or feature-licensed test application only ), Trigger Source must be set to HS-DPCCH .
  • In FDD Test Operating Mode , you must ensure that the UE is synchronized to the downlink frame clock before running the measurement.
  • During front panel operation of this measurement, you must press the START SINGLE key to initiate the measurement.
  • Ensure that you have met the Phase Discontinuity Measurement Input Signal Requirements .
  • Before performing a phase discontinuity measurement, ensure that the measurement has been properly calibrated (see Calibrating the Test Set ).

Other Considerations

  • No other measurements can be running when a phase discontinuity measurement is performed. If any measurements are running when a phase discontinuity measurement is initiated, they are closed and a message is displayed to indicate that they were closed.
  • When Trigger Source is set to HS-DPCCH ( lab application or feature-licensed test application only ), when the measurement is initiated the test set checks to see that UL CL Power Ctrl Algorithm is set to Two and UL CL Power Ctrl Stepsize is set to 1 dB . If not, the test set sends the UE a Physical Channel Reconfiguration message with these values.
  • When Power Control Pattern is set to 5UP/4DOWN , 5DOWN/4UP , 18 UP or 18 DOWN , when the measurement is initiated the test set checks to see that UL CL Power Ctrl Algorithm is set to One and UL CL Power Ctrl Stepsize is set to 1 dB . If not, the test set sends the UE a Physical Channel Reconfiguration message with these values.
  • Absolute measurement results are affected by any amplitude offsets that are entered (relative measurement results are not). See Amplitude Offset .
  • The sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Step Interval cannot exceed 1.0 slot ( lab application or feature-licensed test application only ).
  • The Phase (in degrees) result is always zero for step 0, the first step measured (the Reference Timeslot for non-HSDPA phase discontinuity).
  • No Phase Discontinuity (in degrees) result is reported for step 0, the first step measured (the Reference Timeslot for non-HSDPA phase discontinuity).
  • When Power Control Pattern is set to 5UP/4DOWN , 5DOWN/4UP , 18 UP or 18 DOWN , when the measurement completes, in an attempt to maintain the connection with the UE, the test set sets UE Target Power to the UE's output power in the final measured slot and sets UL CL Power Control Mode to Active Bits when in Active Cell Operating Mode or to Alternating Bits when in FDD Test Operating Mode .
  • While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to External .

Related Topics

  • Phase Discontinuity Measurement Description


PRACH Preamble Analysis Troubleshooting

PRACH Preamble Analysis Troubleshooting

Last updated: January 16, 2009

This section is only applicable to the lab application.

Possible Setup Issues

  • Before performing a PRACH preamble analysis measurement, turn the UE on and wait for it to camp to the test set's signal. When the PRACH preamble analysis measurement is initiated, the test set pages the UE. The UE must be camped to the test set and in idle mode before performing the PRACH preamble analysis measurement.
  • Recommended PRACH Preambles and PRACH Ramping Cycles (MMAX) settings

    The measurement requires a minimum of 3 PRACH preambles, so PRACH Preambles must be no less than 3. It is also recommended that you set PRACH Preambles to no greater than 3 and set PRACH Ramping Cycles (MMAX) to 1 to allow the UE's PRACH sequence to end as soon as possible. This helps avoid the following issue: Test set may lock up if operations are attempted before the UE completes its PRACH sequence .

  • Importance of Setting Call Limit State to Off before Initiating a PRACH Measurement

    It is recommended that you set Call Limit State to Off before initiating this measurement. Then, when the measurement completes, if the UE is still sending PRACH preambles to the test set, the test set will acknowledge the UE. Note, when the test set acknowledges the UE, the call is not completed because the UE is attempting to establish a test set-originated call, whereas the test set acknowledges the UE expecting a UE-originated call. Acknowledging the UE helps prevent the UE from placing the test set into its cell barred list (see Test Set in Cell Barred List ). When the test set acknowledges the UE, you will see the call status move from Paging to Idle , to Setup , to Releasing and then back to Idle . Do not attempt to stop or re-initiate the measurement, or to start any new measurements until the test set has reached Idle state (see Test set may lock up if operations are attempted before the UE completes its PRACH sequence ).

    Setting call limit mode to off before initiating the measurement also avoids another issue: When the measurement completes, if you try to send signalling to the UE while it is still sending PRACH preambles to the test set, the UE will ignore the incoming messages and the signalling will fail. If call limit mode is set to off, the test set will acknowledge the UE and cause it to stop sending PRACH preambles, and then send the signalling you have requested to the UE.

  • Available Subchannels (Bit Mask) must be set to only one available subchannel.
  • During front panel operation of this measurement, you must press the START SINGLE key to initiate the measurement.
  • No other measurements can be running when a PRACH preamble analysis measurement is performed. If any measurements are running when a PRACH preamble analysis measurement is initiated, they are closed and a message is displayed to indicate that they were closed.

Other Considerations

  • Test set may lock up if operations are attempted before the UE completes its PRACH sequence

    When the measurement completes, you must wait until the UE has finished its PRACH sequence before turning off or re-initiating the measurement, or before starting any new measurements. Otherwise, the test set may lock up. If you are controlling the test set via remote program, you must include a wait period after the measurement completes.

    If you set Call Limit Mode to Off before initiating the measurement, you will know that the UE's PRACH sequence is complete when you see the call status move from Paging to Idle , to Setup , to Releasing and then back to Idle (see Importance of Setting Call Limit State to Off before Initiating a PRACH Measurement ). Do not attempt any of the above listed operations until the test set has reached Idle state.

    To allow the UE to complete its PRACH sequence as quickly as possible, it is recommended that you set PRACH Preambles to 4 and PRACH Ramping Cycles (MMAX) to 1 (see Recommended PRACH Preambles and PRACH Ramping Cycles (MMAX) settings ).

  • The measurement will execute fastest if you only specify one available signature using the PRACH Signature setting.
  • The PRACH preamble analysis measurement reports the PRACH signature used by the UE for the preamble burst being analyzed. This result may differ from the Detected PRACH Signature result if more than one signature is specified as available by the PRACH Signature setting.
  • While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to RF Rise or External .
  • Timing error is not reported when Trigger Source is set to RF Rise .
  • FDD Test Operating Mode Considerations
    • When operating in FDD Test Operating Mode , you do not have access to the PRACH Signature setting, as the test set does not send this type of signalling to the UE in FDD test operating mode. However, when you initiate the measurement in FDD test operating mode, the measurement uses the value last set in the PRACH signature setting to determine which signatures to try to correlate to the PRACH preamble burst. Thus, you must switch to Active Cell Operating Mode and ensure that the PRACH Signature setting includes the signature that your UE will transmit before running this measurement in FDD test operating mode.
  • If the PRACH preamble analysis measurement timeout is not on, the PRACH preamble analysis measurement will hang until it is triggered by a PRACH burst. You can reset the measurement by pressing the MEASUREMENT RESET key.

Interpreting Integrity Indicator Values

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. Calibrating the Test Set

See Integrity Indicator .

Related Topics

  • PRACH Preamble Analysis Measurement Description


TX Dynamic Power Measurement Troubleshooting

TX Dynamic Power Measurement Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

  • The TX dynamic power measurement is not performed with a call established between the test set and UE. Rather, you must place your UE into a test mode which forces it to transmit a power sequence of successive down steps of fixed size and duration.
  • Before starting the TX dynamic power measurement, you must use Manual Receiver Control to specify the initial transmit power of the UE's power sequence (the expected power of step 0) to properly range the test set's receiver. You must also specify the UE's transmit frequency (see Measurement Frequency ).
  • You must set Power Step Size , Power Step Time and Number of Power Steps to match the power sequence to be transmitted by the UE.
  • During front panel operation of this measurement, you must press the START SINGLE key to initiate the measurement.
  • Once the measurement has been initiated, the UE must trigger the measurement with a positive change in power from 20 dB below the initial transmit power up to the initial transmit power. To ensure successful triggering, it is recommended that you first order the UE to transmit continuously at the initial transmit power level, initiate the measurement, then order the UE to drop and then raise its output power by more than 20 dB to create the RF rise trigger.
  • Ensure that you have met the TX Dynamic Power Input Signal Requirements .
  • Before performing a TX dynamic power measurement, ensure that the measurement has been properly calibrated (see Calibrating the Test Set ).
  • Ensure that you have entered the proper Amplitude Offset values for your test setup.
  • Ensure that you set the Measurement Timeout to a value great enough to allow you to command the UE to transmit its power sequence and for the test set to measure the power sequence.

Other Considerations

  • The TX dynamic power measurement must re-range and re-trigger for every step in the UE's power sequence. To ensure that this process is not interrupted by other operations, it is recommended that you not send any GPIB commands to the test set or press any front panel keys until the measurement has completed.
  • No other measurements can be running when a TX dynamic power measurement is performed. If any measurements are running when a TX dynamic power measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while a TX dynamic power measurement is running, the TX dynamic power measurement is closed and a message is displayed.
  • The total number of power results returned by the measurement is always 1 + Number of Power Steps .
  • This measurement does not provide valid results while on a faded channel (see Digital Bus Information ).

Troubleshooting Techniques

Check to see if an integrity indicator other than 0 (normal) was returned with the measurement result (see Integrity Indicator ).

  • If Trigger Missed (30) is returned, one or more triggers was missed during the measurement. This may occur if you send GPIB commands to the test set or press any front panel keys while the measurement is executing. This may also occur if the measurement is executed while the test set is warming up after power up, due to calibration operations that occur within the test set during the warm-up period.
  • If Over Range (5) is returned; the input power exceeded +28 dBm or was greater than +9 dB above the expected power level for one or more steps.
  • If Under Range (6) is returned; the input power is below -61 dBm or is less than -9 dB below the expected power level for one or more steps.

Related Topics

TX Dynamic Power Measurement Description

Manual Operation: How Do I Make a TX Dynamic Power Measurement?


Waveform Quality Troubleshooting

Waveform Quality Troubleshooting

Last updated: January 16, 2009

Possible Setup Issues

  • This measurement is not supported on HSPA connections.
  • When on a non-HSDPA connection, you must set Trigger Source to any value other than HS-DPCCH .
  • To measure waveform quality on an HSDPA connection, you must set Trigger Source to HS-DPCCH .
  • The sum of HS-DPCCH Trigger Subslot Alignment and HS-DPCCH Measurement Interval cannot exceed 1.0 slot. If you wish to place the measurement interval after the slot boundary using the HS-DPCCH Trigger Subslot Alignment setting, you must first decrease the HS-DPCCH Measurement Interval setting appropriately.
  • During remote operation of the waveform quality measurement, it is recommended that you configure the trigger arm to single. See SETup:WWQuality . If the trigger arm is not set to single, you may not be able to retrieve measurement results during remote use if you are using the INIT:DONE? query. When the trigger arm is continuous, the measurement rearms itself and starts another measurement cycle, causing the INIT:DONE? query to always return "WAIT". See Trigger Arm (Single or Continuous) Description for more explanation.
  • Your UE must be synchronized to the test set for this measurement to operate correctly.
  • RF In/Out Amplitude offsets entered do not affect these measurement results unless the received signal level becomes too low to accurately detect relative I/Q modulation vector transitions.
  • While on a faded channel (see Digital Bus Information ), the measurement will only return valid results if Trigger Source is set to Immediate or External .
  • Timing Error results are not available when Trigger Source is set to Immediate .

Other Considerations

  • Only Beta c (DPCCH) and Beta d1 (DPDCH 1) provide results (other than NaN) while on a non-HSDPA connection. Beta d2-6 are reserved for future use.
  • Beta hsacknak and Beta hscqi only provide results (other than NaN) when on an HSDPA connection ( lab application or feature-licensed test application only ).
  • When HS-DPCCH Trigger Slot Alignment is set to AckNack , a valid result is returned for Beta hsacknak , NaN is returned for Beta hscqi . Likewise, when HS-DPCCH Trigger Slot Alignment is set to CQI1 or CQI2 , a valid result is returned for Beta hscqi , NaN is returned for Beta hsacknak .

Interpreting Integrity Indicator Values

If Over Range (5) is returned, the measured signal exceeds the expected input level or exceeds the maximum allowed input power for the test set.

If Under Range (6) is returned, the measured signal is below the expected input level.

If Cannot Correlate (17) is returned, the test set cannot demodulate the signal from the mobile station (UE). Make sure the uplink scrambling code from the mobile station matches the UL Scrambling setting on the test set (see CALL:UPLink ).

If Uncalibrated Due to Temperature (19) is returned, the temperature in the test set has changed by ± 10° C or more since the last calibration and should be calibrated again. See Calibrating the Test Set .

See Integrity Indicator .

Related Topics

Waveform Quality Measurement Description


User Interface (UI) Log

User Interface (UI) Log

Last updated: January 16, 2009

Description

To help you troubleshoot or optimize your GPIB control programs, you can configure the test set to capture GPIB interface traffic and store it in the UI (User Interface) Log. To enable GPIB logging, see Step 2: Turn On UI Log GPIB State .

The UI log buffer can store up to 153600 bytes of information with 255 bytes displayed in a row. If the buffer is full, the oldest entry is removed from the top of the log and the newest entry is added to the end.

You can reset and access the UI Log through either the GPIB interface or a Web Browser.

The following procedures demonstrate how to reset and access the UI Log.

  • Step 1: Clear UI Log Data
  • Step 2: Turn On UI Log GPIB State
  • Step 3-1: Get UI Log Data
  • Step 3 - 2: Get Other UI Log Information (Optional)
  • Step 4: Save UI Log Data

Step 1: Clear UI Log Data

Before capturing new GPIB traffic, you can clear the residual information in UI Log storage. Two methods are valid to clear UI Log data storage in the test set:

  • Clear the UI Log via Local Area Network (LAN)

    • Connect your computer to the test set via LAN or directly via a LAN crossover cable.
    • Go to the URL of the test set using a web browser such as Internet Explorer.
      URL in Web Browser to Clear UI Log Data
      Command | Example
      http:// <test_set_ip_address> /uilogclear | http://111.222.333.444/uilogclear

    Clear UI Log Data

  • Clear the UI log via GPIB

    • Connect your computer to the test set via a GPIB interface.
    • Send the GPIB command in the following table to the test set and the log is cleared.

    SYSTem:LOG:UI:CLEAR

    GPIB Command to Clear the UI Log
    Command | Example
    SYSTem:LOG:UI:CLEAR | SYST:LOG:UI:CLEAR

Step 2: Turn On UI Log GPIB State

  • Send the GPIB command in the following table to the test set before you run your test program or send it from the point in your program where it is desired to start GPIB logging.

    NOTE
    The Log GPIB state is reset to OFF after cycling power. It is not reset by a full preset.

    SYSTem:LOG:UI:GPIB[:STATe]

    UI Log GPIB State Command
    Command Example

    SYSTem:LOG:UI:GPIB[:STATe] ON|OFF

    SYST:LOG:UI:GPIB:STAT ON

Step 3-1: Get UI Log Data

  • Go to the URL of the test set using your web browser to retrieve the GPIB log. The GPIB log is displayed in the browser window.

    NOTE
    You must ensure the computer is connected to the test set either via Ethernet LAN or a direct connection using a LAN crossover cable.

    URL in Web Browser to get the UI Log Data
    Command | Example
    http:// <test_set_LAN_IP_Address> /uilog | http://111.222.333.444/uilog
    Display UI Log Data in Web Browser

    NOTE
    In addition to GPIB traffic information, the UI Log also includes data regarding the key presses, knob turns and error messages that occur as you operate your test set from the front panel. Only the lines with the prefix "rem:" indicate the GPIB commands.

The UI Log display is not real time, therefore the latest UI log does not display automatically in the web browser. To capture multiple logs, click Refresh in the View menu.

Step 3 - 2: Get Other UI Log Information (Optional)

You can get more information about UI log data by sending the GPIB queries.

  • Query the number of lines containing GPIB commands in the UI Log

    The GPIB query in the following table returns the number of lines in the log since the last time the log was cleared.

    SYSTem:LOG:UI:COUNt?

    Query the number of lines in the UI Log
    Command Example

    SYSTem:LOG:UI:COUNt?

    SYST:LOG:UI:COUN?
  • Query the string at the specified line in the UI Log

    The GPIB query in the following table returns the string located at the line in the log that you specify. Note that issuing this command turns off GPIB logging. You must turn it back on using the SYSTem:LOG:UI:GPIB[:STATe] command to continue GPIB logging.

    SYSTem:LOG:UI:REPort?

    Query the string in the UI Log
    Command Example

    SYSTem:LOG:UI:REPort? <sp><number value>

    SYST:LOG:UI:REP? 11

Step 4: Save UI Log Data

To save the log in the Web Browser to a file:

  1. In the File menu, click Save As....
  2. In the Save as type: box, select Text File (*.txt).
  3. In the File name: box, type the file name.
  4. Click the Save button.


Activate PDP Context Control

Activate PDP Context Control

Last updated: November 11, 2010

This section is only applicable to the lab application.

You may configure the test set to ignore or reject an Activate PDP Context Request from the UE. You can choose what value is sent in the SM Cause information element of the Activate PDP Context Reject message using the Activate PDP Context Reject SM Cause setting. Use this function in parallel with Protocol Logging to verify that the UE behaves in a manner conforming to the standards for this situation and for each associated SM Cause value.

Activate PDP Context Reject SM Cause

When Activate PDP Context Reject State is On , you may specify what value is sent in the SM Cause information element using the Activate PDP Context Reject SM Cause setting. From the front panel, you may choose from the valid causes specified in 3GPP TS 24.008 10.5.6.6.

Activate PDP Context Reject SM Cause
Cause Value (decimal) | Cause Value (bits) | Cause
25 | 00011001 | LLC or SNDCP Failure
26 | 00011010 | Insufficient Resources
27 | 00011011 | Missing or Unknown APN
28 | 00011100 | Unknown PDP Address or PDP Type
29 | 00011101 | User Authentication Failed
30 | 00011110 | Activation Rejected By GGSN
31 | 00011111 | Activation Rejected, Unspecified
32 | 00100000 | Service Option Not Supported
33 | 00100001 | Requested Service Opt Not Subscribed
34 | 00100010 | Service Opt Temporarily Out of Order
35 | 00100011 | NSAPI Already Used
36 | 00100100 | Regular Deactivation
37 | 00100101 | QoS Not Accepted
38 | 00100110 | Network Failure
39 | 00100111 | Reactivation Required
40 | 00101000 | Feature Not Supported
41 | 00101001 | Semantic Error in TFT Operation
42 | 00101010 | Syntactical Error in TFT Operation
43 | 00101011 | Unknown PDP Context
44 | 00101100 | Semantic Error in Packet Filter(s)
45 | 00101101 | Syntactical Errors in Packet Filters(s)
46 | 00101110 | PDP Context Without TFT Already Activated
50 | 00110010 | PDP Type IPv4 Only Allowed
51 | 00110011 | PDP Type IPv6 Only Allowed
52 | 00110100 | Single Address Bearers Only Allowed
56 | 00111000 | Collision With Network Initiated Request
81 | 01010001 | Invalid Transaction Identifier Value
95 | 01011111 | Semantically Incorrect Message
96 | 01100000 | Invalid Mandatory Information
97 | 01100001 | Msg Type Non-existent/Not Implemented
98 | 01100010 | Msg Type Not Compatible With Protocol State
99 | 01100011 | IE Non-existent or Not Implemented
100 | 01100100 | Conditional IE Error
101 | 01100101 | Msg Not Compatible With Protocol State
111 | 01101111 | Protocol Error, Unspecified

If you select Custom Value from the front panel, a value of 0 is sent to the UE.

The CALL:SERVice:GPRS:REJect:CAUSe command allows you to send any value between 0 and 255 to the UE, even those not mapped to a cause in the standard. If you send a value other than those listed in the above table via the GPIB command, the front panel setting displays CUSTOM .

Related Topics

Ladder Diagram: UE Initiated GPRS Service, Activate PDP Context Reject

How Do I Configure the Data Channel?

Packet Switched Data

CALL:SERVice

Call Processing Status


Data Channel Applications

Data Channel Applications

Last updated: March 16, 2009

This section is only applicable to the lab application.

WAP Functional Test

The WCDMA Data Channel facilitates the functional test of a Wireless Application Protocol (WAP) device such as a WAP-enabled mobile station.

Logging data during this process provides protocol data at useful points in the stack, which may help in debugging a WCDMA device.

Before you use the data channel for WAP functional test, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network (not the same as the WAP gateway)
  • a valid IP address for the DUT
  • the default WAP gateway address (this may be required by the WCDMA device)

Modem Functional Test

The data channel feature enables testing of wireless modems or WCDMA devices with built-in modems.This test typically involves using a dial-up connection. If the modem is not built-in, it is usually controlled from another device such as a PC.

Before you use the Data channel for modem testing, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network
  • a valid IP address for the modem or its controlling PC (even though the modem is the Device Under Test (DUT), typically a PC will be assigned the IP address)

Base Station Emulation

You can use the Data Channel and the test set to emulate a base station. This is particularly useful when you want to have a base station available, for example when demonstrating a wireless application, or when functionally testing wireless devices on a workbench. You may also want to vary key parameters of the cell, such as transmit power, and observe how the DUT performs.

Before you use the Data Channel for Base Station Emulation, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network
  • a valid IP address for the DUT

FTP Functional Test

The Data Channel facilitates File Transfer Protocol (FTP) via the device. Typically this is done with a dial-up connection to an external PC using a GPRS PCMCIA modem or an external GPRS modem.

With appropriate evaluation tools on the Control PC, you can measure the throughput of the modem. Many commercial FTP programs provide detailed information on transfer speed.

To empirically measure the throughput, the performance of the network must be known. For this reason, it is not recommended to perform this evaluation while connected to the Internet. A direct connection or Intranet connection should be used instead.

Related Topics

Packet Switched Data

Circuit Switched Data Service

TCP Data Flood


Circuit Switched Data Service

Circuit Switched Data Service

Last updated: January 16, 2009

The test set supports two types of circuit switched (CS) data service:

  • Asynchronous/Non-Transparent CS Data Service
  • Synchronous/Transparent CS Data Service

The synchronous/transparent service is used by 3G-324M multi-media applications (for example, video phones), whereas the asynchronous/non-transparent service is used by more bursty data, such as IP traffic. The primary difference between the two services is that they use different radio bearer configurations, and the asynchronous/non-transparent configuration includes the RLP layer above the RLC entities (the RLC entities connect directly to the application in the synchronous/transparent configuration).

Asynchronous/Non-Transparent CS Data Service

The test set only supports UE-originated asynchronous/non-transparent CS data service, but both test set and UE-initiated release from the CS data service are supported.

Two radio bearers are supported: 57.6k UL/57.6k DL CS Data RAB (see 3GPP TS 34.108, 6.10.2.4.1.17) and 14.4k UL/14.4k DL CS Data RAB (see 3GPP TS 34.108, 6.10.2.4.1.15). You may specify the downlink DPCH channel codes for these two RABs using the DPCH 120 ksps Channelization Code and DPCH 30 ksps Channelization Code settings (see Downlink Channel Codes and Levels ).

Async CS Data Source

You may choose what application protocol uses the CS data service using the Async CS Data Source setting. This setting can only be changed when the call status is idle. This setting allows you to specify the access point to the traffic plane data stream as follows:

  • Serial Port - connects the top of the L2R/RLP layer directly to the rear panel SERIAL 3 port of the test set. When Async CS Data Source is set to Serial Port , debug access to the serial port is shut off, and the serial port is configured for CS data operation (data rate of 115,000 bps, 8 bits, no parity, 1 stop bit).
    Software flow control (i.e. XON/XOFF characters) is used across the serial port to control the data flow. The L2R/RLP entity obeys the flow control commands from the UE and will similarly command the UE to stop sending data if its internal buffers begin to fill up.
  • IP - connects the top of the L2R/RLP layer to a PPP/IP layer that is fed to the test set's LAN PORT . The PPP layer operates in asynchronous framing mode.

GPIB command: CALL:SERVice:CSData:MODE:ASYNchronous:OUTput .

CS Data Asynchronous Bearer User Plane Protocol Configuration

Synchronous/Transparent CS Data Service

The synchronous/transparent CS data service allows you to make two types of 3G-324M video calls: UE-to-UE Video Call (lab application or feature-licensed test application) and UE-to-8960LAN Video Call (lab application only).

At this time, a video call connection is the only type of synchronous/transparent CS data service supported in the test set.

One radio bearer is supported: 64k UL/DL CS Data RAB (see 3GPP TS 34.108, 6.10.2.4.1.13). You may specify the downlink DPCH channel code for this RAB using the DPCH 120 ksps Channelization Code setting (see Downlink Channel Codes and Levels ).

Related Topics

Manual Operation: How Do I Configure the Data Channel?

Circuit Switched Data Service Ladder Diagrams

Video Call

Downlink Channel Codes and Levels

CALL:SERVice

DUT IP Setup

Rear Panel Connectors


Circuit Switched Data Service Ladder Diagrams

Circuit Switched Data Service Ladder Diagrams

Last updated: January 16, 2009

UE Initiated CS Data Service Start Procedure

Related Topics

Circuit Switched Data Service


DUT IP Setup

DUT IP Setup

Last updated: January 13, 2012

This section is only applicable to the lab application.

Description

The test set supports three types of IP connection with the access terminal (AT, or also the Device Under Test): IPv4, IPv6 and IPv4+IPv6. Before the AT initiates an IP connection (either IPv4 or IPv6 or both) with the test set, the DUT IP parameters must be correctly set. A typical DUT IP Setup parameters menu is shown as below.

DUT IP Setup Menu

  • DUT IP Version

    This parameter specifies the DUT IP version to be used. If multiple PDP contexts are to be setup, this parameter sets the DUT IP version of the first PDP context.

    • If it is set to IPv4 , only an IPv4 connection is allowed to be set up between the test set and the DUT.
    • If it is set to IPv6 , only an IPv6 connection is allowed to be set up between the test set and the DUT. A DUT IPv6 address (IID) will be allocated randomly to the DUT by the test set if the DUT does not promote one (see CALL:STATus:MS:IP:ADDRess:IP6:IID? ).
    • If it is set to IPv4 + IPv6 (Dual) , both IPv4 and IPv6 connections are allowed to be set up between the test set and the DUT. It is also allowed to set up a single IP connection (either IPv4 or IPv6) if the DUT only supports one IP version.

    NOTE
    DUT IP Version only affects OTA (over the air) negotiation between the test set and the DUT. The test set always supports both IPv4 and IPv6 via LAN connections.

    GPIB Command: CALL:MS:IP:VERSion

  • DUT IP Address
  • DUT IPv6 Prefix

    The DUT IPv6 Prefix is a 16-char string that specifies the IPv6 Prefix of the DUT when the DUT IP Version is IPv4+IPv6 or IPv6 .

    The current IPv6 Prefix that the DUT is using depends on the following situations:

    • If DUT IPv6 Prefix is left blank, set to an invalid value or set to the same value as IPv6 Prefix, Upper/Lower (Hex) , the DUT will use the same IPv6 prefix as the test set.
    • If DUT IPv6 Prefix is set to a valid value which is other than the IPv6 Prefix, Upper/Lower (Hex) , then the test set serves as a router between the UE and the LAN segment, which means:
      • The test set will forward all the IPv6 packets directing to that DUT IPv6 Prefix (no matter what the IID is) from the network to the UE.
      • The test set will not forward any link-local prefixed (i.e. FE80::) IPv6 packet to the UE.
      • In order to ensure the forward IPv6 packets firstly reach the test set, the network node should use the test set as the gateway for the IPv6 packets directing to that UE IPv6 Prefixes. In order to achieve this, you may need to manually edit the IPv6 routing table of the network node (for example, by adding a routing entry in the routing table).

    DUT IPv6 Prefix 2 is only used when setting up multiple PDP contexts. If more than one PDP contexts is to be set up, meanwhile if any of these PDN connections is via IPv6, you must also set the associated DUT IPv6 Prefix for that PDP contexts. See Multiple PDP Contexts Information . Note that if you set the DUT IPv6 prefixes to be different from the IPv6 prefix of the test set, you must also ensure the two DUT IPv6 prefixes are not the same with each other.

    When operating from the front panel, you must set both the DUT IPv6 Prefix Upper part and the DUT IPv6 Prefix Lower part to form a full DUT IPv6 Prefix.

    The DUT IPv6 Prefix can only be changed when the call status is Idle .

    These settings are non-volatile (they persist across partial and full presets and power-cycling the test set).

    GPIB Command: CALL:MS:IP:ADDRess[1]|2:IP6:PREFix

  • DUT IP 2 Version

    If multiple PDP contexts are to be setup, this parameter sets the DUT IP version of the second PDP context.

    • If it is set to IPv4 , only an IPv4 connection is allowed to be set up between the test set and the DUT.
    • If it is set to IPv6 , only an IPv6 connection is allowed to be set up between the test set and the DUT. A DUT IPv6 address (IID) will be allocated randomly to the DUT by the test set if the DUT does not promote one (see CALL:STATus:MS:IP:ADDRess:IP6:IID? ).
    • If it is set to IPv4 + IPv6 (Dual) , both IPv4 and IPv6 connections are allowed to be set up between the test set and the DUT. It is also allowed to set up a single IP connection (either IPv4 or IPv6) if the DUT only supports one IP version.

    GPIB Command: CALL:MS:IP:VERSion2

  • DUT IP Address 2

    If multiple PDP contexts are to be setup, this parameter sets the DUT IP address of the second PDP context.

    GPIB Command: CALL:MS:IP:ADDRess2

  • DUT IPv6 Prefix 2

    See DUT IPv6 Prefix .

  • DNS Server IP Addresses

    As part of the PS data call setup procedures, the UE can include PPP/IPCP messages that ask the network for the IP addresses of the DNS servers that it should use to resolve domain names. These PPP/IPCP messages are carried as part of the PDP Context Activation message and in them the UE can request either the Primary DNS Server address or the Secondary DNS Server address or both. If the UE requests either one or both of the DNS server addresses and they are set to 0.0.0.0, the test set does not respond to the UE, returns an error, and then proceeds with the PDP Context Activation. If the UE requests both of the DNS server addresses and either one contains a value other than 0.0.0.0, that address is sent to the UE.

    These settings are non-volatile (they persist across partial and full presets and power-cycling the test set).

    • DUT Primary DNS Server IP Address

      GPIB command: CALL:MS:DNSServer:PRIMary:IP:ADDRess

    • DUT Secondary DNS Server IP Address

      GPIB command: CALL:MS:DNSServer:SECondary:IP:ADDRess

  • Route 192.168.104.0/24 Traffic to DUT

    Set this parameter to On when you need to test the routing function of the UE. See DUT Routing State .

    GPIB Command: CALL:MS:IP:ADDRess:ROUTing:STATe .

  • DUT IPv6 DNS Server Address

    During the PS data call setup procedure, the UE can also ask the network for the IPv6 address of the DNS server via PDP Context Activation message.

    The DUT IPv6 DNS Server address is an typical IPv6 address and is comprised of two portion accordingly: IPv6 Prefix and IPv6 Interface ID (IID). Each portion is further divided into two parts (the upper part and the lower part) separately to simplify the input, see DUT IP Setup Menu .The DUT IPv6 DNS Server address setting is stored in non-volatile RAM and will NOT be changed by a reset, power cycle operations.

    GPIB Command: CALL:MS:DNSServer:PRIMary:IP:ADDRess:IP6

Related Topics

Packet Switched Data


DUT Routing State

DUT Routing State

Last updated: January 16, 2009

Description

The test set allows you to test the router function of a device. The test set acts as a router and it enables the routing of packets to the DUT.

DUT Routing

How does the DUT work as a router

As in the above figure, if the test set is set as follows:

1. 8960 Ext IP = 130.129.183.15

2. DUT IP = 130.29.179.201

3. Host IP = 192.168.104.0

4. 8960 Routing table

Dest Mask Gateway Interface
130.29.179.201 0xFFFFFFFF 192.168.200.1 fap0
192.168.104.0 0xFFFFFF00 192.168.200.1 fap0

The IP packets that are addressed to the DUT are sent via the over-the-air interface to the DUT. When the DUT Routing State is enabled, any packet that has an address that matches the subnet mask (any address in the range 192.168.104.0 to 192.168.104.255) is sent over the air to the DUT. The DUT forwards the packet to its controller (typically a router). The router then takes care of forwarding the packet to the intended host.

How to Configure the DUT Routing State

This test set allows you to enter a maximum of four DUT IP addresses. For GSM/GPRS/EDGE LA application, you may use all four DUT IP Addresses. For all other LA applications, you are allowed to use only one DUT IP Address. For each DUT IP address, there is one associated subnet route. These subnet routes are hardcoded as follows:

Hardcoded Subnets
DUT | Network Route | Network Route Mask
1 | 192.168.104.0 | 255.255.255.0
2 | 192.168.105.0 | 255.255.255.0
3 | 192.168.106.0 | 255.255.255.0
4 | 192.168.107.0 | 255.255.255.0

Configuring the CDMA2000 DUT Routing State

If the test set's DUT IP Address is set to 146.208.232.214, the Route 192.168.1.4.0/24 Traffic to DUT is set to On, as shown below. This is done by performing that the address in the range 192.168.104.0 to 192.168.104.255 forward to the DUT which IP address is 146.208.232.214.

Route Choosing Requirements

There are two requirements for choosing routes:

  • Allows ease of reference: the set of all four subnets can be denoted by 192.168.104.0/22.
  • The subnets are chosen in an attempt to minimize the chances that you might already be using the same address for other nodes on the network. For example, it is assumed typical private networks tend to use IP address in the 192.168.1.x and 192.168.100.x ranges.

The routes can not be set over MUI and not be available over RUI.

The LAN IP Address, LAN IP Address 2 and the DUT IP Address are all required on the same subnet. If you turn on DUT routing, any attempt to enter a LAN IP Address, LAN IP Address 2 or DUT IP Address within the range of any of the fixed network routes is rejected and an error message generated.

Operating Consideration

For CDMA2000, the DUT Routing State can not be changed when operating mode is set to Active Cell and the call or data status is other than IDLE.

For 1xEV-DO, the DUT Routing State can not be changed when operating mode is set to Active Cell and the data status is other than IDLE .

For WCDMA and GGE, the DUT Routing State can be changed when the operating mode is Cell Off

The 8960 can not be proxy ARPing for any of the new routed packets or advertising these new routes via RIP (Routing Information Protocol) or OSPF (Open Shortest Path First) or similar traffic management protocols.

The targeting of the IP address ranges to the 8960 for forwarding OTA (Over-The-Air technology) is the responsibility of the external LAN configuration.

If the Secondary PDP context is being used and the Primary PDP context clears off, no DUT routing subnet packets is forwarded to the DUT. Similarly, if the Secondary PDP context is at a higher priority than the Primary PDP context and the traffic on the Secondary PDP context takes up all the available bandwidth, DUT routing subnet packets is not forwarded to the DUT.

Related Topics

Data Channel


GPRS Packet Data Service Ladder Diagrams

GPRS Packet Data Service Ladder Diagrams

Last updated: January 16, 2009

This section is only applicable to the lab application.

  • GPRS Attach
  • Test Set Initiated GPRS Detach
  • UE Initiated GPRS Detach
  • Test Set Initiated GPRS Service
  • UE Initiated GPRS Service
  • UE Initiated GPRS Service, Activate PDP Context Reject

GPRS Attach

Test Set Initiated GPRS Detach

UE Initiated GPRS Detach

Test Set Initiated GPRS Service

UE Initiated GPRS Service

UE Initiated GPRS Service, Activate PDP Context Reject

Related Topics

Packet Switched Data


Multiple PDP Contexts Information

Multiple PDP Contexts Information

Last updated: November 25, 2010

This section is only applicable to the lab application.

The topics discussed in this section are:

  • Multiple PDP Contexts Overview
  • Operating Considerations
  • Multiple PDP Contexts Setup
    • Multiple PDP Contexts Parameters
    • QoS Profile1/2 Setup

Multiple PDP Contexts Overview

The Multiple PDP Contexts functionality allows you to test the UEs running simultaneous PS services, for example, to test the UE that is sending/receiving emails while performing video stream. There are two categories for multiple PDP contexts:

  • multiple primary PDP contexts: provides connections to different target networks (PDNs, Packet Data Network). Two or more PDP contexts are independent from one another, each of them uses a unique PDP address. Each PDP context has its own QoS (Quality Of Service) and NSAPI (Network Layer Service Access Point Identifier). Besides, each individual PDP context has a separate RAB (Radio Access Bearer).
  • secondary PDP contexts: provides connections to the same PDN but with different QoS. (Not supported yet)

The test set supports to setup multiple (up to two) primary PDP contexts simultaneously with the UE. You can enable/disable the primary PDP contexts independently from one another, with each PDP context using its own IP address (either IPv4 or IPv6) and QOS profile, see Multiple PDP Contexts Parameters .

Operating Considerations

  • The test set establishes the requested PDP context based on GPRS Radio Access Bearer , rather than the QOS. You must set the GPRS Radio Access Bearer to 64K PS or HSUPA UL/HSDPA DL PS , and set the PS Data SRB Mapping Mode to UL E-DCH/DL DCH in order to set up multiple PDP contexts.
  • Setting the QOS profile for each PDP context does not mean that the test set will actually adjust its transmission and reception based on the configured QoS profile. The test set only signals these parameters to the UE via the Active PDP Context Accept message.
  • Multiple primary PDP contexts can only be setup one after another. After the first primary PDP context is setup, the second context must be initiated from the UE by sending an Activate PDP Context Request message to the test set. Once two primary PDP contexts are setup, the test set will ignore any additional PDP context requests from the UE.
  • For multiple PDP contexts, you can also configure the test set to ignore/reject any PDP Activation request from UE by setting the Activate PDP Context Ignore State ( CALL:SERVice:GPRS:IGNore[:STATe] ) or the Activate PDP Context Reject State ( CALL:SERVice:GPRS:REJect[:STATe] ). Besides, you can set the rejectable APNs by Access Point Name Settings .
  • The following functionalities are not compatible with multiple PDP contexts: External 8960 Handover , CELL_FACH, Downlink Power Control Information , Ciphering, Compressed Mode , Continuous Packet Connectivity and Simultaneous Services .
  • You should set the following settings to their permitted value, or the test set will automatically change it to an appropriate one based on the standard: Maximum Bitrate for Uplink , Maximum Bitrate for Downlink , Guaranteed Bitrate for Uplink , Guaranteed Bitrate for Downlink , Maximum SDU Size . For example, setting the Maximum Bitrate for Uplink to 70 will cause the the test set to change it to 64 automatically. See their GPIB commands for the permitted value range.

Multiple PDP Contexts Setup

You can set two DUT IP addresses to support at most two primary PDP contexts, see DUT IP Setup . The actual DUT IP address used (can be an IPv4 address or an IPv6 address) for each PDP connection is according to the UE's requests and your DUT IP settings.

Multiple PDP Contexts Parameters

  • First primary PDP Context QoS profile

    This setting allows the you to configure the QoS parameters for the first primary PDP context if the first DUT IP is configured. If it is configured to QoS Profile 1 or QoS Profile 2 , the requested QoS from UE will be ignored and the QoS will be configured based on the associated QoS Profile1/2 Setup . If it is configured to None and the UE requested QOS parameters are valid, the test set will use the requested QoS, otherwise the test set will use the default value(s) in the accept message.

    GPIB Command: CALL:MS:IP:ADDRess[1]:CONText:PRIMary:QOService

  • Second primary PDP Context QoS profile

    This setting allows the user to configure the QoS parameters for the second primary PDP context if the second DUT IP is configured. If it is configured to QoS Profile 1 or QoS Profile 2 , the requested QoS from UE will be ignored and the QoS will be configured based on the associated QoS Profile1/2 Setup . If it is configured to None and the UE requested QOS parameters are valid, the test set will use the requested QoS, otherwise the test set will use the default value(s) in the accept message.

    GPIB Command: CALL:MS:IP:ADDRess2:CONText:PRIMary:QOService

You are not allowed to change these settings while in Active Cell operating mode and the data status is other than Idle .

QoS Profile1/2 Setup

For either the first or the second primary PDP context, if its QOS profile is set to QoS Profile 1 or QoS Profile 2 (see Multiple PDP Contexts Parameters ), the requested QoS from UE will be ignored and the IE Negotiated QoS fields of ACTIVATE PDP CONTEXT ACCEPT message for this PDP connection will be configured based on the following settings:

  • Traffic Class

    GPIB Command: CALL:SERVice:PSData[:QOSProfile[1]]:TCLass or CALL:SERVice:PSData:QOSProfile2:TCLass .

  • Maximum Bitrate for Uplink

    This setting should be larger than the Guaranteed Bitrate for Uplink .

    GPIB Command: CALL:SERVice:PSData[:QOSProfile[1]]:UPLink:BRAte[:MAXimum] or CALL:SERVice:PSData:QOSProfile2:UPLink:BRAte[:MAXimum] for the setting range.

  • Maximum Bitrate for Downlink

    This setting should be larger than the Guaranteed Bitrate for Downlink .

    GPIB Command: CALL:SERVice:PSData[:QOSProfile[1]]:DOWNlink:BRAte[:MAXimum] or CALL:SERVice:PSData:QOSProfile2:DOWNlink:BRAte[:MAXimum]

  • Guaranteed Bitrate for Uplink

    This setting should be smaller than the Maximum Bitrate for Downlink .

    GPIB Command: CALL:SERVice:PSData[:QOSProfile[1]]:UPLink:BRAte:GUARanteed or CALL:SERVice:PSData:QOSProfile2:UPLink:BRAte:GUARanteed

  • Guaranteed Bitrate for Downlink

    This setting should be smaller than the Maximum Bitrate for Downlink .

    GPIB Command: CALL:SERVice:PSData[:QOSProfile[1]]:DOWNlink:BRAte:GUARanteed or CALL:SERVice:PSData:QOSProfile2:DOWNlink:BRAte:GUARanteed

  • Delivery Order

    Setting this parameter to On indicates "With delivery order" while setting it to Off indicates "Without delivery order".

    GPIB Command: CALL:SERVice:PSData[:QOSProfile[1]]:DORDer or CALL:SERVice:PSData:QOSProfile2:DORDer

  • Maximum SDU Size

    GPIB Command: CALL:SERVice:PSData[:QOSProfile[1]]:SDU:SIZE[:MAXImum] or CALL:SERVice:PSData:QOSProfile2:SDU:SIZE[:MAXImum]

  • SDU error ratio

    GPIB Command: CALL:SERVice:PSData[:QOSProfile[1]]:SDU:ERATio or CALL:SERVice:PSData:QOSProfile2:SDU:ERATio

  • Residual bit error ratio

    GPIB Command: CALL:SERVice:PSData[:QOSProfile[1]]:RBERatio or CALL:SERVice:PSData:QOSProfile2:RBERatio

  • Delivery of Erroneous SDUs

    GPIB Command: CALL:SERVice:PSData[:QOSProfile[1]]:SDU:EDELivery or CALL:SERVice:PSData:QOSProfile2:SDU:EDELivery

  • Transfer Delay

    GPIB Command: CALL:SERVice:PSData[:QOSProfile[1]]:TDELay or CALL:SERVice:PSData:QOSProfile2:TDELay

  • Traffic Handling Priority

    GPIB Command: CALL:SERVice:PSData[:QOSProfile[1]]:THPRiority or CALL:SERVice:PSData:QOSProfile2:THPRiority

  • Signaling Indication

    GPIB Command: CALL:SERVice:PSData[:QOSProfile[1]]:SINDication or CALL:SERVice:PSData:QOSProfile2:SINDication

These settings can only be changed while the data status is Idle .

Related Topics

CALL:MS:IP:ADDRess


Packet Switched Data

Packet Switched Data

Last updated: November 9, 2010

This section is only applicable to the lab application.

The test set's packet switched (PS) data service is a complete end-to-end service conforming to the GPRS Packet Data Service described in 3GPP TS 23.060. For example, you can connect the test set's LAN port to your network and make a complete connection from the UE through the test set to that network. The lab application does not provide any applications support or network services above TCP/IP packet handling.

PS Domain Information must be set to Present before a UE will initiate PS services with the test set.

For an example of establishing a packet data connection, see Establishing a Packet Data Connection .

The topics discussed in this section are:

  • HSDPA Packet Switched Data
  • HSPA Packet Switched Data
  • Packet Data Setup
    • GPRS Radio Access Bearer
    • Activate PDP Context Reject
    • Access Point Name Settings
    • Initial PS Data RRC State

HSDPA Packet Switched Data

The test set supports an HSDPA packet data connection as defined by 3GPP TS 34.108 6.10.2.4.5.1 (see GPRS Radio Access Bearer ). You must specify some aspects of the channel configuration by providing the UE category to the test set (see Current UE HS-DSCH Category , but note that the HSDPA packet data service in the test set only supports UE categories 1-6, 11 and 12) and by specifying a PS Data Configuration Type .

Based on the Current UE HS-DSCH Category , the test set sets the number of HARQ processes to the value in 3GPP TS 34.108 s6.10.2.4.5.1.2.2.2 (for example, number of HARQ processes is set to 6 for a category 12 UE).

Based on the Current UE HS-DSCH Category , the test set sets the inter-TTI interval to the "Minimum inter-TTI interval" value in 3GPP TS 25.306 Table 5.1a (for example, inter-TTI interval is set to 1 for a category 12 UE).

Based on the PS Data Configuration Type setting, the test set sets the transport block size, number of HS-PDSCHs, modulation type and IR buffer size (N IR ) to the values in 3GPP TS 25.214 s6A.2 Tables 7A-E (depending upon the Current UE HS-DSCH Category ).

HSPA Packet Switched Data

This section is only applicable to the lab application.

The test set supports an HSPA channel configuration for packet data connections that is combined with HSDPA as defined by 3GPP TS 34.108 6.10.2.4.6.1 (see GPRS Radio Access Bearer ). The HSUPA packet data service in the test set supports a 10 ms E-DCH TTI or 2 ms E-DCH TTI (see E-DCH TTI ). The test set also requires that the UE use no more than two E-DPDCHs with a minimum spreading factor of SF2. The actual number of E-DPDCHs and the spreading factor the UE uses are dependent on the PS Data E-DPDCH Max Channel Codes setting, the amount of data waiting to be transmitted, the UE's serving grant, the UE's E-DCH capability and the power the UE has available.

The following table lists the maximum block size and corresponding uplink data rate for each E-DCH UE category.

E-DCH UE Category | Max Block Size | Uplink Data Rate (for 10 ms TTI)
Category 1 | 7110 | 7.11 kbps
Category 2 and 3 | 14484 | 14.484 kbps
Category 4, 5, and 6 | 20000 | 2 Mbps

The HSUPA packet data service in the test set only fully supports data rates on the HSDPA channel up to 3.6 Mbps (category 7 and 8 UE's can still establish a PDP context, however data rates above 3.6 Mbps are not guaranteed).

The HSUPA packet data service in the test set only supports scheduled grants. During call setup the UE is given an absolute grant. Once on the call the UE's Serving Grant can be modified either by transmitting a new absolute grant or by sending up or down relative grant command. If the test set does not send a specific Up/Down command request, it sends a hold on the E-RGCH. Note that the HSPA Cell 1 Connected E-RGCH Level must be set to On (by default it is set to Off) in order for the UE to hear the relative grant commands.

During call setup, the UE is given a minimum E-TFCI set. This setting is effectively a minimum serving grant that is available even if the actual serving grant is reduce below the value by commands sent on the E-AGCH or the E-RGCH. Also during call setup, the UE is instructed to use a HARQ RV Configuration = rv0 (that is, chase combining), however the test set only perform demodulation and decoding on the most recently received E-DPDCH frame (and therefore it does not actual perform chase combining).

If the E-HICH Behavior is set to Active, the test set transmits Ack/Nack responses on the E-HICH based on whether the E-DPDCH passed its CRC check or not. If the UE did not transmit on the E-DPDCH then the Alternate E-HICH Signature is used on the E-HICH to simulate a DTX.

Scheduling information sent by the UE in the MAC-e PDUs can be viewed in the contents of the MAC-e/es layer messages which can be captured by using the Wireless Protocol Advisor (WPA). By default the scheduling information is off. To turn scheduling information on, see Scheduling Information Periodicity (No Grant) and Scheduling Information Periodicity (Grant) .

The MAC-e/es PDUs are logged as a single PDU that has both MAC-e and MAC-es fields decoded. In addition to the MAC-e/es PDU contents, WPA logs all the information contained in the header of the MAC0e/es PDU. All E-DCH data is logged including blocks that fail their CRC check. Note that if a MAC-e/es block is marked as failing its CRC check, it could either be due to a bit error in the information itself, or because of a bit error on the E-DPCCH and thus the L1 header information (number of HARQ processes, E-DCH block size, RSN, Happy Bit, number of channels and spreading factor, E-AGCH and E-RGCH) logged for each MAC-e/es frame might not match what the UE attempted to transmit.

Packet Data Setup

GPRS Radio Access Bearer

The GPRS RABs available in the test set include:

  • 64k PS Data RAB (3GPP TS 34.108 6.10.2.4.1.26)
  • 64k UL / 384k DL RMC (3GPP TS 25.101 A.2.2 and A.3.4)
  • 64k UL / 384k DL PS Data RAB (3GPP TS 34.108 6.10.2.4.1.32)
  • 128k UL / 384k DL PS Data RAB (3GPP TS 34.108 6.10.3.4.1.33)
  • 384k UL / 384k DL PS Data RAB (3GPP TS 34.108 6.10.3.4.1.34).
  • 64k UL / HSDPA DL PS (3GPP TS 34.108 6.10.2.4.5.1) - downlink rate is dependent upon the Current UE HS-DSCH Category and the PS Data Configuration Type setting.
  • 128k UL / HSDPA DL PS (3GPP TS 34.108 6.10.2.4.5.1a) - downlink rate is dependent upon the Current UE HS-DSCH Category and the PS Data Configuration Type setting.
  • 384k UL / HSDPA DL PS (3GPP TS 34.108 6.10.2.4.5.2) - downlink rate is dependent upon the Current UE HS-DSCH Category and the PS Data Configuration Type setting.
  • HSUPA UL / HSDPA DL PS (+ 3.4k SRB on DCH PS Data RAB) (3GPP TS 34.108 6.10.2.4.5.1) -
    Streaming or interactive or background / UL: maximum bit rate dependent upon the Current UE HS-DSCH Category and TTI. DL: maximum bit rate dependent on the Current UE HS-DSCH Category. PS RAB + UL : 3.4 DL: 3.4 kbps SRBs for DCCH on DCH.

GPIB command: CALL:SERVice:GPRS:RAB

Activate PDP Context Reject

You may configure the test set to reject your UE's request to start a packet data session using the Activate PDP Context Control settings.

Access Point Name Settings

The Access Point Name State setting allows you to choose whether the test set includes an Access Point Name (APN) in the Request PDP Context Activation message that is used to begin network initiated PS connections (see 3GPP TS 34.108 s7.2.4.1.3 and Test Set Initiated GPRS Service ). You can choose an APN using the Access Point Name setting, or set Access Point Name to Custom and then use the CALL:SERVice:PSData:APName:CUSTom command to set a custom value.

  • Access Point Name State

    Determines whether the test set includes an Access Point Name (APN) in the Request PDP Context Activation message. The APN value is set using the Access Point Name parameter.

    GPIB command: CALL:SERVice:PSData:APName:STATe

  • Access Point Name

    If Access Point Name State is set to On , you can specify one of the following APNs be sent in the Request PDP Context Activation message:

    • general.t-mobile.uk
    • i-mode.docomo.ne.jp
    • live.vodafone.com
    • mobile.bt.uk
    • Orangeinternet
    • wap.cingular
    • wap.o2.co.uk
    • Custom - to set the custom APN value to be sent, use the CALL:SERVice:PSData:APName:CUSTom command.

    GPIB command: CALL:SERVice:PSData:APName[:VALue]

Initial PS Data RRC State

This setting controls whether the UE is assigned to CELL_DCH or CELL_FACH when a PDP Context is initiated or when an incoming 2-box PS data cell change order occurs. SCCPCH/PRACH Configuration must be set to Signaling + Traffic to use the CELL_FACH mode.

Related Topics

HSDPA PS Data Setup

HSUPA PS Data Setup

GPRS Packet Data Service Ladder Diagrams

How Do I Configure the Data Channel?


Establishing a Packet Data Connection

Establishing a Packet Data Connection

Last updated: January 16, 2009

This section is only applicable to the lab application.

  • A. PC Setup
  • B. Hardware Connections
  • C. Test Set Setup
  • D. Establishing the Packet Data Connection

The following procedure is an example of how to use the test set for IP packet data transfer. The following steps outline the requirements for data service using a WCDMA UE as a wireless modem (see Modem Functional Test ). The UE is connected to the USB port on a laptop computer (PC) running USB port driver software developed by the manufacturer of the UE.

All test sets capable of running the WCDMA Lab Application have an internal server with an 8960 web site. This web site provides screen capture images and supports printouts. This procedure will demonstrate how to access this web site via the RF interface using packet data service.

The purpose of this procedure is to serve as an overview of the tasks required for a typical data channel application. If your particular application involves accessing internet or intranet sites via the test set's LAN interface, additional requirements such as getting through corporate firewalls may complicate setup procedures.

A. PC Setup

Install and Configure the Device Driver

The laptop has to be configured to include the wireless modem (UE) in its list of networks. In this application, the wireless modem manufacturer produced software that runs on the PC. When run for the first time, the software prompts the user for setup information. When properly configured, the PC will recognize the wireless modem on the USB (or other) port.

Configure the PC for a Dial-up Connection to the Internet via the Wireless Modem (UE)

The laptop has to be configured to include the wireless modem (UE) in its list of networks. The network dial-up connection properties must be configured according to the requirements of the wireless modem and the data port driver. When the PC is properly configured, the "Network and Dial-up Connections menu" should include the wireless modem in its list of connections.

B. Hardware Connections

There are many different configurations for testing a wireless modem's (or other device such as a WAP-enabled UE) data handling performance. See Modem Functional Test for a diagram of the configuration used for this example.

RF (Wireless Modem to Test Set)

  1. Connect the wireless modem (UE) RF cable to the test set's RF IN/OUT port.

PC to Wireless Modem

  1. For this example, the USB port provides the connection. Connect the USB port from the wireless modem (UE) to the PC.

C. Test Set Setup

  1. Press the Call Setup key to go to the Call Setup screen on the test set.
  2. Press the left More key to go to the 3 of 4 screen of the Control menu.

  3. Select DUT IP Setup .

    Set the DUT IP Address in the DUT IP Setup menu on the test set. For this procedure, The DUT IP Address must be unique in that no other host on the network is using that same address. In this example the network consists of only two IP addresses, the PC and the Test Set. The DUT IP Address must be different than the LAN IP Address found in the Instrument Setup menu. See DUT IP Address .

    In this application, the DUT IP Address will be sent to the laptop computer if you set the Internet Protocol (TCP/IP) Properties to "Obtain an IP address automatically" menu.

  4. Select Data Channels ( F4 ), Packet Data Setup ( F1 ), and select the GPRS Radio Access Bearer you wish to use.

    Set the other Packet Data Settings as desired.

  5. Set the test set's cell parameters, uplink parameters and call parameters as needed to allow your UE to attach to the test set (see How Do I Set Up a Call and Make a Connection? ).

D. Establishing the Packet Data Connection

  1. Turn the wireless modem (UE) on and wait for GMM State to read "Attached" on the test set's front panel display. Note, some wireless modems may need to attempt data transfer before attaching to the test set. If that is the case with your UE, proceed to steps 2 and 3.

  2. You can now establish the packet data connection from the wireless modem or from the test set (if your UE supports test set-initiated packet data connections).
    • To establish the connection from the wireless modem: Use the laptop computer's "Network and Dial-up Connections" menu to make a dial up connection (dial *99#). The wireless modem will request an activation and the PDP Context will become active. This can be observed by looking for "PDP Active" in the Active Cell field. See UE Initiated GPRS Service .
    • To establish the connection from the test set (if supported by your UE): Set Paging Service to UMTS/GPRS Packet Data and select Originate Call . See Test Set Initiated GPRS Service .

  3. Open the web browser on the PC. Enter the IP address of the test set in the web browser's address window. The web browser should display the following screen:

As data is transferred, the Data Channels Counters window keeps a running count of data in both the uplink and downlink:

You can also use the Data Throughput Monitor to monitor the transfer of data (see Data Throughput Monitor Description ).

Additionally, for HSDPA or HSPA Packet Data connections, the windows in the HSPA Information screen display counters to help you monitor the connection.

Related Topics

Packet Switched Data

GPRS Packet Data Service Ladder Diagrams

How Do I Configure the Data Channel?


Ping

Ping

Last updated: May 30, 2011

This section is only applicable to the lab application.

Ping Description

Ping is a tool to help check system interconnects. The test set has a Ping feature that allows you to ping either the DUT IP Address or an alternate address specified by you (see How Do I Ping a Device From the Test Set? ). An IP datagram (technically an Internet Control Message Protocol (ICMP) Echo Request message) is sent from the test set to the ping target, and expects a response from the target. You can define the size of the IP datagram and the Internet Protocol to use (whether IPv4 or IPv6) when using this feature. The default packet size is 64 bytes for both IPv4 and IPv6. If a response is received it is recorded on the test set's display.

Ping is the simplest implementation of the Data Channel feature. If you are trying to debug a system that is not responding to a full network setup (for example a WAP setup), try pinging the DUT from a computer attached to the network. Experiment with very large packets, very long timeouts and continuous pings.

How to Read the Ping Results

If the connection is good, then the device returns a packet to the test set and the packet transfer information is displayed on the test set's screen (see Ping Data Display ). The figure below shows the kind of information that is displayed on the Ping screen. In this example, the Ping Count has been set to ping 10 times. Note that on average it took 1248 ms to complete a ping.

Ping Data Display

Operating Considerations

  • When pinging the DUT, the DUT must either accept a network initiated PDP Context activation or have requested a PDP Context.
  • There are restrictions regarding IP Addresses that are valid for use. See DUT IP Address for more information.
  • Ping is only available in Active Cell operating mode.
  • When the Ping originates from the test set and the target is the DUT, the Downlink Source address is always the IP address of the test set, and Uplink Destination Address is the same value.
  • Your mobile station must support ping for you to be able to successfully ping the DUT IP Address.
  • If the test set supports the LAN 2 PORT (see the Tip in LAN 2 PORT for how to identify the support of LAN 2 PORT), both the LAN PORT and the LAN 2 PORT are required to be physically connected to the same subnet to ping a DUT. Undoubtedly the LAN IP Address and the LAN IP Address 2 (Data+) must also be set correctly.
  • If the test set does not support the LAN 2 PORT , you only need to set the LAN IP Address correctly to ping a DUT from the test set, no physical connection to a subnet is required.
  • If the test set does not support the LAN 2 PORT due to hardware restriction and the Ping Protocol is set to IPv6 ,then ping to a DUT (the Device to Ping is set to DUT ) will cause an error indicating that the requested operation is not supported.
  • When the Ping Protocol is set to IPv6 , the Ping6 Setup middle menu is displayed after Ping Setup ( F1 ), and the Alternate Ping6 Address is divided into four parts to simplify the manual input: Alternate Ping6 Address Prefix, Upper (Hex) , Alternate Ping6 Address Prefix, Lower (Hex) , Alternate Ping6 Address IID, Upper (Hex) , Alternate Ping6 Address IID, Lower (Hex) .
  • When the Ping Protocol is set to IPv6 , the parameter of Ping Timeout is grayed out with a fixed value of 5 seconds.

Related Topics

Manual Operation: How Do I Ping a Device From the Test Set?


Automatic RRC State Transitions

Automatic RRC State Transitions

Last updated: January 7, 2012

This section is only applicable to the lab application.

The automatic RRC state transitions are driven by a set of triggers as below:

  1. Inactivity timer based. These triggers fire after a certain amount of time has elapsed since the network received or transmitted to/from the UE. You can set the amount of time as in RRC State Trans Setup .
  2. UE reported measurement report. This trigger fires when a measurement report indicating a particular event-based measurement has occurred in the UE.
    • E4A fires when the network receives a Measurement Report indicating that Event 4A ("Transport Channel Traffic Volume becomes larger than an absolute threshold") has occurred in the UE. When the network receives the E4A Measurement Report, the UE will be transit to CELL_DCH if it is in CELL_FACH'
    • E4B trigger fires when the network receives a Measurement Report indicating that Event 4B ("Transport Channel Traffic Volume becomes larger than an absolute threshold") has occurred in the UE. When the network receives the E4B Measurement Report, the UE will be transit to CELL_FACH if it is in CELL_DCH.
  3. Network buffer threshold. This trigger fires when an RLC buffer in the test set associated with a traffic plane radio bearer is above or below a threshold for a period of time. You can set the threshold and period of time as in RRC State Trans Setup .
  4. Downlink IP data arrival.

    The downlink data trigger fires when an IP packet arrives at the 8960 for the UE and it is in CELL_PCH, URA_PCH or Idle if both the top level Automatic RRC State Transitions setting is On and the Automatic Transition Upon Downlink IP Data setting is On .When this trigger fires the UE will be transit to CELL_FACH if it is in CELL_PCH or URA_PCH or the RRC state indicated in the Initial PS Data RRC State setting if it is in Idle.

  5. UE-reported Signalling Connection Release Indication (SCRI).

    This trigger fires when an SCRI is received and allows transition from CELL_DCH or CELL_FACH to an efficient battery consumption RRC state IDLE, CELL_PCH, URA_PCH, or CELL_FACH State, or drops the PDP context directly.

    • RRC Idle with SCRI

      If UE is on a PDP Context in CELL_DCH or CELL_FACH and an SCRI with "psdomain" identity is received from the UE, and if SCRI With Fast Dormancy State is set to Off , you have two choices: 1), If you want to maintain the active PDP Context when the SCRI is received and only drop the RRC Connection ( RRC Idle With SCRI is set to On ), then the test set will initiate the RRC Connection Release procedure and the UE will be transit to RRC Idle; 2), If you want to drop the active PDP Context when the SCRI is received ( RRC Idle With SCRI is set to Off ), then the test set will transit the UE to Idle.

    • SCRI with Fast Dormancy

      If UE is on a PDP Context in CELL_DCH or CELL_FACH and an SCRI is received from the UE, if the IE "Signalling Connection Release Indication Cause" indicates "UE requested PS Data session end", you have two choices: 1), if you want to maintain the activate PDP Context and move the UE to an efficient battery consumption RRC State (set the SCRI With Fast Dormancy State to On , then the test set will initiate a state transition to efficient battery consumption RRC State (called Fast Dormancy); 2), if you do not want to initiate the Fast Dormancy procedure when the SCRI is received ( SCRI With Fast Dormancy State is set to Off ), then test set will behave the same as in RRC Idle with SCRI .

RRC State Trans Setup

  • Automatic RRC State Transitions

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:AUTO

  • CELL_DCH Inactivity Timer State

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:ITIMer:DCH:STATe

  • CELL_DCH Inactivity Timer Length

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:ITIMer:DCH:VALue

  • CELL_DCH Inactivity Timer Dest RRC State

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:ITIMer:DCH:DESTination

  • CELL_FACH Inactivity Timer State

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:ITIMer:FACH:STATe

  • CELL_FACH Inactivity Timer Length

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:ITIMer:FACH:VALue

  • CELL_FACH Inactivity Timer Dest RRC State

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:ITIMer:FACH:DESTination

  • UE Event 4A Trigger State

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:TVOLume:TRIGger[:STATe]:EVent4A

  • UE Event 4A Reporting Threshold

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:TVOLume:RTHReshold:EVent4A

  • UE Event 4A Time to Trigger (ms)

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:TVOLume:TTTRigger:EVent4A

  • UE Event 4B Trigger State

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:TVOLume:TRIGger[:STATe]:EVent4B

  • UE Event 4B Reporting Threshold

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:TVOLume:RTHReshold:EVent4B

  • UE Event 4B Time to Trigger (ms)

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:TVOLume:TTTRigger:EVent4B

  • RRC Idle With SCRI

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:SCRI:RRCIdle[:STATe]

  • SCRI With Fast Dormancy State

    See SCRI with Fast Dormancy

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:SCRI:FDORmancy[:STATe]

  • Fast Dormancy Dest RRC State for CELL_DCH

    See SCRI with Fast Dormancy

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:SCRI:FDORmancy:DCH:DESTination

  • Fast Dormancy Dest RRC State for CELL_FACH

    See SCRI with Fast Dormancy

    GPIB Command: CALL:SERVice:PSData:RRC:TRANsition:SCRI:FDORmancy:FACH:DESTination


TCP Data Flood

TCP Data Flood

Last updated: January 16, 2009

This section is only applicable to the lab application.

This topic details the following:

  • 8960 TCP Data Flood Overview
  • 8960 TCP Data Flood Generator
  • Using the Character Generator and Discard Functions
  • Operating Considerations

8960 TCP Data Flood Overview

Testing the throughput of an IP-based packet switched data connection typically requires both a data source and a data sink. The requirements on the data source are usually straightforward and can often be summarized as "send data as fast as the air interface will allow". Most test environments use a generic PC or Linux server connected to the test set's LAN. This PC is colloquially referred to as the "server", because it is often running an FTP server. Sometimes the data sink will be the phone itself or another PC, often referred to as the "client" PC connected to the DUT and using the DUT as a modem.

The internal Data Generator functionality in the 8960 lab applications can be used to simplify your test environment by removing the need for an external "server" PC for simple throughput testing. As well as shortening test environment setup time this simplification typically results in more repeatable results as the configuration of Windows PCs, and their data throughput capabilities, can vary widely from one PC to another.

The two standard use-cases for throughput testing involve sending either UDP or TCP data as fast as the air interface will allow.

UDP does not impose any throughput restrictions of its own. UDP is a protocol which does not require any acknowledgements of the received data from the recipient of the transmission for retransmission of missed / bad blocks. It is therefore a good mechanism for testing the data throughput capable to almost theoretical limits but may not be completely representative of the end user experience.

TCP is used by common protocols like HTTP and FTP so is a good choice for measuring throughput that an actual user will experience, however end-to-end throughput can be restricted by TCP mechanisms in the server PC (such as receive window size and congestion control) that are not related to over-the-air capacity.

8960 TCP Data Flood Generator

The TCP data generator is an implementation of the RFC 864 CHARGEN service that runs on port 19 on the test set's protocol processor. Please note that a Special High Data Rate hardware test set is required (or a test set with the equivalent hardware upgrades). To use this feature, you simply establish a TCP connection with the test set on port 19 and the generator will start streaming data over the link as fast as possible for as long as the connection exists. The format of the transmitted data is the example described on page 3 of RFC 864 (http://www.ietf.org/rfc/rfc0864.txt). Any user data received over the TCP connection is discarded by the test set.

There are no user-settable configuration parameters associated with this feature.

Using the Character Generator and Discard Functions

  • To start the character generation function while on a PS data connection, use a command line telnet program on the client PC to connect to port 19 of the test set's protocol IP address.:

    C:\> telnet <lan 2 address> 19

    When successful, a large amount of scrolling text can be seen on the screen. The telnet program is making a TCP connection to port 19 on the test set's protocol processor. The chargen service is listening on port 19 and upon connection establishment, the service streams data as fast as it can over that connection. To stop, type "Ctrl+]" to get the command prompt back and then type "quit". Note that the data rate is usually limited by how fast the telnet program can draw the data to the screen. Alternatively, you can create your own socket application to establish the chargen connection. This would be likely to increase the throughput since there would be no drawing of data to the display. A socket application could be created quickly in Perl or Python.

  • To demonstrate the Discard function, where the source of the TCP data is on the client PC, use a command line telnet program on the client PC to connect to port 9 of the test set's protocol IP address:

    C:> telnet <lan 2 address> 9

    This makes a TCP connection to the discard server running on port 9. Discard is the opposite of chargen in that the test set simply sits there and discards anything that arrives on the connection. You can send characters simply by typing in the telnet window (although it is unlikely that you will see characters on the screen because they are not being echoed by the Discard server).

Operating Considerations

Data Throughput Monitor and WPA

All traffic transmitted or received by the TCP data generator will be recorded as part of the IP and OTA lines on the Data Throughput Monitor and all IP traffic will also be logged to WPA under the IP logging point.

LAN and Internal Ping Functionality Interactions

Although the intention of the TCP generator is to keep the air interface link fully loaded with data the LAN port and internal ping functionality that is normally used to send data to the DUT are not disabled while either generator is active. This means that you can activate a data generator and still send packets to the DUT through either the external LAN port or internal ping functionality. However those packets have to compete with the active data generator for buffer space in the transmit queue so will likely experience high packet loss rates and possibly higher than normal latencies.

2-box Environment Interactions

In a two-box environment any traffic going to/from the data generators will follow the phone as it moves between boxes. This means that if you establish a connection to the TCP traffic generator on a particular box and then hand the phone over to the other box the TCP traffic generator will remain active.


Data Channel Troubleshooting

Data Channel Troubleshooting

Last updated: January 16, 2009

This section is only applicable to the lab application.

  • PS Domain Information must be set to Present before a UE will initiate PS services with the test set.

GPRS Attach

GPRS attach is a UE initiated procedure. There are three errors conditions during GPRS attach that will generate error messages. These error conditions will not stop the GPRS attach procedure:

  • The test set does not receive the RRC Connection Complete message from the UE within 6 seconds from the time of sending the RRC Connection Setup message. This will generate error +201, No Response to RRC Connection Setup.
  • The test set does not receive the Identity Response message from the UE within 6 seconds from the time of sending the Identity Request message. This will generate error +208, No Response to Identity Request.
  • The test set does not receive the RRC Connection Release Complete message from the UE within 6 seconds from the time of sending the RRC Connection Release message. This will generate error +208, No Response to RRC Connection Release.

Ping

  • If your data channel application does not seem to be working, try pinging the device. The test set has a ping feature, and so do most computer operating systems. See Ping for more information.
  • Ping log has an unknown IP address: If you log a Ping that originated from the test set, the Ping Downlink Source Address and the Uplink Destination Address have a fixed value of 0x821DB5CB. This is because the test set uses an internal address to originate IP data from the test set to the mobile station.
  • Ping does not work although the mobile station is attached: The device must be PDP activated. This may require that you initiate a data transfer from the mobile station. Also, Ping and Data Channel are only available in when the connection type is set to Auto .

Frequently Asked Questions

  • Can't find where to set the mobile station address: Switch the Conn Type to Auto first.
  • BER measurements wrong when using the data channel: The BER measurement is not supported during data connections.
  • What is the APN (Access Point Name) that I need to include with the dial string when using dial-up? No APN is needed.

Related Topics

Packet Switched Data

Circuit Switched Data Service


Downlink Power Control Information

Last updated: May 25, 2010

This section is only applicable to the lab application.

  • Downlink Power Control Parameters
  • DPCH Ec/Ior Parameters
  • Start/Stop Recording DPCH Ec/Ior
  • Operating Considerations

The test set supports downlink closed power control if a RB test mode call connection is set up. In response to the TPC (transmit power control) bits from the UE, the test set adjusts the downlink DPCCH/DPDCH/F-DPCH power accordingly. Downlink power control helps to test the ability of the UE receiver to converge to required link quality set by the network while using as low power as possible in downlink.

For an ordinary transmit power control procedure, the UE generates TPC commands, and sends a unique TPC command in each slot to control the network transmit power (referred to as downlink power control mode 0 (DPC_MODE = 0) in the 3GPP standard). The DPC_MODE parameter is a UE specific parameter and fixed to "0" in the test set, see Operating Considerations .

Another situation of downlink power control is power control in compressed mode, see Compressed Mode .

Downlink Power Control Parameters

When Downlink Power Control Parms ( F1 ) is pressed, the following parameters are displayed in the Downlink Power Control Parameters middle menu:

  • Downlink Power Control State

    This parameter allows you to enable or disable downlink power control when a RB test mode call is established.

    This parameter can only be set when the call status is idle.

    GPIB Command: CALL[:CELL]:CLPControl:DOWNlink[:STATe] .

  • WCDMA Maximum DPCH Level

    This parameter sets the relative power level to the Cell 1 Connected CPICH Level .

    GPIB Command: CALL[:CELL]:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum[:WCDMa]

  • HSDPA Maximum (F-)DPCH Level

    HSDPA Maximum (F-)DPCH Level sets the relative power level to the HSDPA Cell 1 Connected CPICH Level .

    GPIB Command: CALL[:CELL]:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum:HSDPa

  • HSPA Maximum (F-)DPCH Level

    HSPA Maximum (F-)DPCH Level sets the relative power level to the HSPA Cell 1 Connected CPICH Level .

    GPIB Command: CALL[:CELL]:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum:HSPA

  • Minimum (F-)DPCH Level

    The average power of transmitted DPCH symbols over one time slot should not exceed Maximum DPCH Level, nor should it be below the Minimum (F-)DPCH Level .

    GPIB Command: CALL[:CELL]:CLPControl:DOWNlink:DPCHannel:LEVel:MINimum

  • Target Quality on DTCH

    This parameter specifies the quality target (BLER target) on DTCH. When Downlink Power Control State is set to On, this information is sent to the UE via the RadioBearerSetup message.

    This parameter can only be set when the call status is idle.

    GPIB Command: CALL[:CELL]:CLPControl:DOWNlink:DTCHannel:TARGet[:QUALity]

  • Target Quality on DCCH State

    This parameter specifies whether the BLER target is to be assigned to a DCCH. If it is set to On, the BLER target is to be assigned to a DCCH and the outer loop is based on DTCH rather than DCCH. If it is set to Off, the outer loop is based on DCCH.

    This parameter can only be set when the call status is idle.

    GPIB Command: CALL[:CELL]:CLPControl:DOWNlink:DCCHannel[:STATe]

  • Target Quality on DCCH

    When the Target Quality on DCCH State is set to On , Target Quality on DCCH specifies the BLER target on DCCH.

    This parameter can only be set when the call status is idle.

    GPIB Command: CALL[:CELL]:CLPControl:DOWNlink:DCCHannel:TARGet[:QUALity]

The Downlink Power Control Parameters window displays the Downlink Power Control State and the Current Maximum (F-)DPCH Level that is being used by the test set. You can also query these results by:

Current Downlink Power Control Results
Result | GPIB Command
Downlink Power Control State | CALL[:CELL]:CLPControl:DOWNlink[:STATe]
Current Maximum (F-)DPCH Level | CALL:STATus:CLPControl:DOWNlink:DPCHannel:LEVel:MAXimum?

DPCH Ec/Ior Parameters

When DPCH Ec/Ior Parameters ( F2 ) is pressed, the following parameters are displayed in the DPCH Ec/Ior Parameters middle menu:

  • DPCH Ec/Ior Count

    This setting allows you to specify how many realtime downlink power control information to be recorded each time the Start Recording DPCH Ec/Ior action is performed.

    GPIB Command: CALL[:CELL]:CLPControl:DOWNlink:ECIor:RECord:COUNt

  • DPCH Ec/Ior Threshold

    By setting this parameter, the test set can calculate and display how many DPCH_Ec/Ior is below the threshold (Ratio of DPCH Ec/Ior Bellow Threshold) during the realtime recording period.

    GPIB Command: CALL[:CELL]:CLPControl:DOWNlink:ECIor:THReshold

See the table below on how to query the DPCH Ec/Ior results:

Current DPCH Ec/Ior Results
Result | GPIB Command
Recording State | CALL:STATus:CLPControl:DOWNlink:ECIor:RECord[:STATe]?
Count of DPCH Ec/Ior Gathered | CALL:STATus:CLPControl:DOWNlink:ECIor:RECord:COUNt?
Threshold of DPCH_Ec/Ior | CALL[:CELL]:CLPControl:DOWNlink:ECIor:THReshold
Ratio of DPCH Ec/Ior Below Threshold | CALL:STATus:CLPControl:DOWNlink:ECIor:RATio?
Average DPCH_Ec/Ior | CALL:STATus:CLPControl:DOWNlink:ECIor[:AVERage]?
Maximum DPCH Ec/Ior | CALL:STATus:CLPControl:DOWNlink:ECIor:MAXimum?
Minimum DPCH Ec/Ior | CALL:STATus:CLPControl:DOWNlink:ECIor:MINimum?

Start/Stop Recording DPCH Ec/Ior

By pressing the Start Recording DPCH Ec/Ior , the test set keeps a realtime track of the following DPCH Ec/Ior information during the downlink power control: Count of DPCH_Ec/Ior Gathered , Ratio of DPCH_Ec/Ior Bellow Threshold and Average/Maximum/Minimum DPCH_Ec/Ior . The number of the downlink power control information to record is specified by DPCH Ec/Ior Count . Stop Recording DPCH Ec/Ior action will abort the recording. Recording State on the Recorded DPCH Ec/Ior Statistic Info screen shows whether the recording is in process or Idle.

Any of the following operations will reset the realtime DPCH Ec/Ior statistic information:

  • Start Recording DPCH Ec/Ior
  • Measurement Reset
  • A new call is established
  • Operating Mode change

GPIB Command: CALL[:CELL]:CLPControl:DOWNlink:ECIor:RECord:STARt and CALL[:CELL]:CLPControl:DOWNlink:ECIor:RECord:STOP

Operating Considerations

  • The following downlink power control parameters are fixed in the test set as below:
    • Downlink Power Control Mode (DPC_MODE): fixed to DPC_MODE0
    • Downlink Power Control Step Size: fixed to 1 dB
    • Limited Power Increase: fixed to Not Used
    • DeltaSIR2: fixed to 0
    • DeltaSIRafter2: fixed to 0
  • The standard specifies that the average power of transmitted DPCH symbols over one time slot should not exceed the maximum DPCH level. Therefore, when the Downlink Power Control State is On , the Maximum DPCH Level must not be less than the Connected DPCH Level (Note: the Maximum DPCH Level setting for WCDMA/HSDPA/HSPA only specifies the relative value to Connected CPICH Level, remember to add them together before comparing to the Connected DPCH Level. See also Cell 1 Connected DPCH Level , HSDPA Cell 1 Connected DPCH Level or HSPA Cell 1 Connected DPCH Level ). Likewise, when the Downlink Power Control State is Off , if the Maximum DPCH Level is not configured correctly, the Downlink Power Control State is not allowed to be set back to On.
  • If you want to test the UE outer loop power control with different transport formats (specified in the 3GPP standard TS34.121 7.8.4), you can set the 0k and 12.2k RMC state to On (GPIB Command only, see CALL[:CELL]:CLPControl:DOWNlink:RMC012:STATe ) when the Channel Type is 12.2k RMC, so that when you set up a RB test mode, the test set will set up the 12.2k and 0k RMC instead of the 12.2k RMC. Besides, you must also set the 0k and 12.2k RMC date rate (GPIB Command only, see CALL[:CELL]:CLPControl:DOWNlink:RMC012:DRATe ) to the correct value during different test stages.
  • You can not perform handover operations (for example, physical channel reconfiguration or transport channel reconfiguration) when the current service type is RB test Mode , the Channel Type is set to 12.2k RMC and the 0k and 12.2k RMC state ( CALL[:CELL]:CLPControl:DOWNlink:RMC012:STATe ) is On.

Related Topics

Generator Information

How Do I Change Generator Information?

Cell Power and AWGN Power

Signalling Radio Bearer (SRB) Parameters

Active Cell Operating Mode

Cell Off Operating Mode


E-UTRAN / WCDMA Interworking

E-UTRAN / WCDMA Interworking

Last updated: May 11, 2011

This section is only applicable to the lab application.

  • E-UTRAN / WCDMA Interworking Overview
  • E-UTRAN / WCDMA Interworking Parameters
  • E-UTRAN / WCDMA Interworking Physical Connection
  • Operating Considerations

E-UTRAN / WCDMA Interworking Overview

E-UTRAN/WCDMA interworking relates to the test set working together with the Agilent E6621A PXT (See note below) to perform inter-Radio Access Technologies operations. This allow you to test the multi-mode wireless devices for LTE-WCDMA inter-RAT performance while using the test set as the WCDMA network simulator. In particular, the test set supports the following test scenarios:

  • Cell reselection between WCDMA and LTE (bi-directional, UE-initiated only).
  • PS Handover between WCDMA and LTE (bi-directional, network-initiated only). See External PS Handover .
  • RRC Redirection from LTE to WCDMA.
  • Circuit Switched Fallback (CSFB) from LTE. See Unexpected Page Response .

For the hardware connection for these tests, see E-UTRAN / WCDMA Interworking Physical Connection .

For the inter-RAT frequency and priority information, see SIB19 Information .

NOTE
E-UTRAN / WCDMA interworking is restricted to using the Agilent E6621A PXT Wireless Communications Test Set as the LTE simulator. You must set up the PXT environment (cell configuration, RRC scenario, EPC, etc.) correctly so that the PXT emulates both the E-UTRAN and EPC functionalities for inter-RAT tests.

For detailed guidance on how to use the E6621A PXT, please refer to the E6621A user's guide at

http://cp.literature.agilent.com/litweb/pdf/E6621-90002.pdf

Before any LTE-WCDMA inter-RAT test, you must first set up a connection between the two simulators, for signaling and packet data transferring. Namely, you must set up the E-UTRAN / WCDMA Interworking Parameters and connect to the external LTE simulator successfully before performing any inter-RAT operation.

E-UTRAN / WCDMA Interworking Parameters

Manual Operation: You can access the following menu from the CALL SETUP hardkey, go to the left side Call Control 6 of 6 , then press the E-UTRAN/WCDMA Interworking Info ( F2 ).

E-UTRAN /WCDMA Interworking Information Screen

  • Ext EPC IP Addr

    Specifies the external EPC's IPv4 address, i.e. the IPv4 address of the LTE simulator for the test set to set up a connection via LAN.

    This setting is non-volatile (it persists across partial and full presets and power-cycling the test set).

    GPIB Command: SYSTem:COMMunicate:LAN:EPCore:ADDRess

  • Connect To External EPC

    This action establishes a connection between the test set and the LTE simulator specified by Ext EPC IP Addr . When a connection is successfully set up, check the External EPC Conn Status for Connected and check the Connected EPC IP Address for the IPv4 address of the connected LTE simulator.

    GPIB Command: SYSTem:COMMunicate:LAN:EPCore:CONNect

  • Disconnect From External EPC

    When a connection is established between the test set and the LTE simulator, this action disconnects the test set from the LTE simulator specified by Ext EPC IP Addr . The External EPC Conn Status shows Not Connected if there is no connection present.

    GPIB Command: SYSTem:COMMunicate:LAN:EPCore:DCONnect

Evolved Packet Core (EPC) Connection Information

  • External EPC Conn Status

    Indicates the external EPC connection status, whether there is a connection present between the test set and the LTE simulator.

    GPIB Command: SYSTem:STATus:COMMunicate:LAN:EPCore:CONNected[:STATe]?

  • Connected EPC IP Address

    Indicates the IP address of the connected LTE simulator.

    GPIB Command: SYSTem:STATus:COMMunicate:LAN:EPCore:CONNected:ADDRess?

E-UTRAN / WCDMA Interworking Physical Connection

The figure below shows a typical Physical connection for E-UTRAN /WCDMA interworking.

  • Agilent PXT Test Set: working as the LTE system simulator whose functionalities and interfaces are in accordance with the standard.
  • Agilent 8960 Test Set: when running the E6703H lab application or above, the test set can work as a WCDMA network simulator.
  • Ethernet (LAN) Connection: interworking between the two systems relies on an ethernet connection to exchange signaling message or packet data.

    Note that there are two LAN Ports on the rear panel of the test set (See Rear Panel Connectors ). For E-UTRAN /WCDMA interworking, LAN 2 PORT is required to exchange signaling message or packet data. LAN 1 PORT is optional, but it is still useful for other LAN operations such as protocol logging, firmware downloads or screen captures.

  • RF Interface: The DUT must be able to communicate with both simulators. To accomplish this, it is common to use an RF splitter to connect the mobile to both test sets simultaneously.
  • GPIB Connection: GPIB connection between both test sets and a controlling PC are necessary if remote control of the instruments in the system is required.
  • Ethernet Switch or Hub: An ethernet switch or hub is needed in order for the Device Under Test to connect to external servers as well as for connecting the PC running WPA to the test sets.

Operating Considerations

  • Connecting to EPC requires the LAN 2 PORT to be configured and connected correctly. To set up the LAN 2 port on the front panel, press SYSTEM CONFIG hardkey and go to Control 1 of 2 , LAN IP Address 2 (Data+) setting is at the bottom of Instrument Setup (F1) menu.
  • Connecting/Disconnecting to the external EPC will cause any active PDP contexts to be deactivated.
  • The connection can be initiated from either the test set or the EPC simulator.
  • Ext EPC IP Addr must not be identical to the LAN IP Address setting. When the connection is successfully set up, Ext EPC IP Addr can not be changed.
  • On a full preset or format switch, the connection between the test set and the external EPC simulator will be interrupted.

Related Topics

GPIB Command: SYSTem:COMMunicate , SYSTem:STATus


E-UTRAN / WCDMA Interworking

E-UTRAN / WCDMA Interworking

Last updated: February 26, 2012

This section is only applicable to the lab application.

  • E-UTRAN / WCDMA Interworking Overview
  • E-UTRAN / WCDMA Interworking Parameters
  • E-UTRAN / WCDMA Interworking Physical Connection
  • Operating Considerations

E-UTRAN / WCDMA Interworking Overview

E-UTRAN/WCDMA interworking relates to the test set working together with the Agilent E6621A PXT (See note below) to perform inter-Radio Access Technologies operations. This allow you to test the multi-mode wireless devices for LTE-WCDMA inter-RAT performance while using the test set as the WCDMA network simulator. In particular, the test set supports the following test scenarios:

  • Cell reselection between WCDMA and LTE (bi-directional, UE-initiated only).
  • PS Handover between WCDMA and LTE (bi-directional, network-initiated only). See External PS Handover .
  • RRC Redirection from LTE to WCDMA.
  • Circuit Switched Fallback (CSFB) from LTE. See Unexpected Page Response .

For the hardware connection for these tests, see E-UTRAN / WCDMA Interworking Physical Connection .

For the inter-RAT frequency and priority information, see SIB19 Information .

NOTE
E-UTRAN / WCDMA interworking is restricted to using the Agilent E6621A PXT Wireless Communications Test Set as the LTE simulator. You must set up the PXT environment (cell configuration, RRC scenario, EPC, etc.) correctly so that the PXT emulates both the E-UTRAN and EPC functionalities for inter-RAT tests.

For detailed guidance on how to use the E6621A PXT, please refer to the E6621A user's guide at

http://cp.literature.agilent.com/litweb/pdf/E6621-90002.pdf

Before any LTE-WCDMA inter-RAT test, you must first set up a connection between the two simulators, for signaling and packet data transferring. Namely, you must set up the E-UTRAN / WCDMA Interworking Parameters and connect to the external LTE simulator successfully before performing any inter-RAT operation.

E-UTRAN / WCDMA Interworking Parameters

Manual Operation: You can access the following menu from the CALL SETUP hardkey, go to the left side Call Control 6 of 6 , then press the E-UTRAN/WCDMA Interworking Info ( F2 ).

E-UTRAN /WCDMA Interworking Information Screen

  • Ext EPC IP Addr

    Specifies the external EPC's IPv4 address, i.e. the IPv4 address of the LTE simulator for the test set to set up a connection via LAN.

    This setting is non-volatile (it persists across partial and full presets and power-cycling the test set).

    GPIB Command: SYSTem:COMMunicate:LAN:EPCore:ADDRess

  • Connect To External EPC

    This action establishes a connection between the test set and the LTE simulator specified by Ext EPC IP Addr . When a connection is successfully set up, check the External EPC Conn Status for Connected and check the Connected EPC IP Address for the IPv4 address of the connected LTE simulator.

    GPIB Command: SYSTem:COMMunicate:LAN:EPCore:CONNect

  • Disconnect From External EPC

    When a connection is established between the test set and the LTE simulator, this action disconnects the test set from the LTE simulator specified by Ext EPC IP Addr . The External EPC Conn Status shows Not Connected if there is no connection present.

    GPIB Command: SYSTem:COMMunicate:LAN:EPCore:DCONnect

Evolved Packet Core (EPC) Connection Information

  • External EPC Conn Status

    Indicates the external EPC connection status, whether there is a connection present between the test set and the LTE simulator.

    GPIB Command: SYSTem:STATus:COMMunicate:LAN:EPCore:CONNected[:STATe]?

  • Connected EPC IP Address

    Indicates the IP address of the connected LTE simulator.

    GPIB Command: SYSTem:STATus:COMMunicate:LAN:EPCore:CONNected:ADDRess?

E-UTRAN / WCDMA Interworking Physical Connection

The figure below shows a typical Physical connection for E-UTRAN /WCDMA interworking.

  • Agilent PXT Test Set: working as the LTE system simulator whose functionalities and interfaces are in accordance with the standard.
  • Agilent 8960 Test Set: when running the E6703H lab application or above, the test set can work as a WCDMA network simulator.
  • Ethernet (LAN) Connection: interworking between the two systems relies on an ethernet connection to exchange signaling message or packet data.

    Note that there are two LAN Ports on the rear panel of the test set (See Rear Panel Connectors ). For E-UTRAN /WCDMA interworking, LAN 2 PORT is required to exchange signaling message or packet data. LAN 1 PORT is optional, but it is still useful for other LAN operations such as protocol logging, firmware downloads or screen captures.

  • RF Interface: The DUT must be able to communicate with both simulators. To accomplish this, it is common to use an RF splitter to connect the mobile to both test sets simultaneously.
  • GPIB Connection: GPIB connection between both test sets and a controlling PC are necessary if remote control of the instruments in the system is required.
  • Ethernet Switch or Hub: An ethernet switch or hub is needed in order for the Device Under Test to connect to external servers as well as for connecting the PC running WPA to the test sets.

Operating Considerations

  • Connecting to EPC requires the LAN 2 PORT to be configured and connected correctly. To set up the LAN 2 port on the front panel, press SYSTEM CONFIG hardkey and go to Control 1 of 2 , LAN IP Address 2 (Data+) setting is at the bottom of Instrument Setup (F1) menu.
  • Connecting/Disconnecting to the external EPC will cause any active PDP contexts to be deactivated.
  • The connection can be initiated from either the test set or the EPC simulator.
  • Ext EPC IP Addr must not be identical to the LAN IP Address setting. When the connection is successfully set up, Ext EPC IP Addr can not be changed.
  • On a full preset or format switch, the connection between the test set and the external EPC simulator will be interrupted.

Related Topics

GPIB Command: SYSTem:COMMunicate , SYSTem:STATus


SIB11 FACH Measurement Occasion Information

SIB11 FACH Measurement Occasion Information

Last updated: November 25, 2010

This section is only applicable to the lab application.

FACH measurement occasions (FMO) are used to control UE measurement activities on inter-frequency and inter-RAT cells while the UE is in CELL_FACH RRC state. FMO are configured to allow for measurement of some parameters that cannot be measured while simultaneously receiving the S-CCPCH of the serving cell in CELL_FACH. When configured, FMO create transmission gaps in the S-CCPCH sent from the network when the UE is in CELL_FACH.

How Does the Test Set Support FACH Measurement Occasion?

The UE decides when to perform measurements in CELL_FACH that can be made while simultaneously receiving the S-CCPCH of the serving cell. For other requested measurements in CELL_FACH, FMO are required. In order to perform measurements using FMO, FACH Meas Occasion Cycle Len Coeff Control must be set to Present and FACH Meas Occasion Cycle Len Coeff and C-RNTI (Hex) set to desired values.

The 3GPP standards allow FMO to be configured using SIB11 or SIB12. The test set uses only SIB11 for configuration of FMO.

The SIB11 FMO settings are configured separately from the existing SIB11 measurement settings. You must configure SIB11 FMO, SIB11 inter-frequency and inter-RAT measurements so that no conflicts occur at the UE. The test set does not perform error checking to validate these settings.

The TTI of the S-CCPCH is fixed to 10 ms.

CELL_FACH state is supported when using W-CDMA RABs.

Measurement of TDD neighbor cells cannot be configured. Because of this, the UE is not asked to make TDD measurements when using FMO. In other words, the IE "Inter-RAT Measurement Indicators" is fixed to `1.'

Measurement of IS2000 neighbor cells cannot be configured. Because of this, only `GSM' is supported as the "RAT Type" IE in "FACH Measurement Occasion Info."

FACH Measurement Occasion User Settings

The following sections summarize the settings provided for configuring FMO. With the exception of Inter-frequency FDD measurement indicator and Inter-RAT measurement indicators Control , all of the settings must be set when the Operating Mode is set to Off . Then when the Operating Mode is switched back to Active Cell , SIB11 will transmit the correct FMO parameters.See How Do I Change the SIB11 FACH Measurement Occasion Information? on how to set the FMO settings from the front panel. See How Do I Change Cell Parameters? on how to set the C-RNTI.

  • FACH Measurement Occasion Info Control

    If Present is selected, SIB11 includes the IE "FACH Measurement Occasion Info", and all other FMO settings are available for selection. If Absent is selected, SIB11 does not include this IE.

    GPIB Command: CALL[:CELL]:BCCHannel:FMOCcasion:CONTrol

  • FACH Meas Occasion Cycle Len Coeff Control

    If Present is selected, the IE "FACH Measurement Occasion Cycle Length Coefficient" is included in the "FACH Measurement Occasion Info." If Absent is selected, the IE is not included.

    GPIB Command: CALL[:CELL]:BCCHannel:FMOCcasion:CLCoeff:CONTrol

  • FACH Measurement Occasion Cycle Length Coefficient

    This setting is used by the UE to calculate M_REP, the FACH measurement occasion cycle length, using the equation provided in 3GPP TS 25.331. The test set does not transmit anything to the UE with the identified C-RNTI value via FACH during FACH measurement occasions in CELL_FACH state.

    GPIB Command: CALL[:CELL]:BCCHannel:FMOCcasion:CLCoeff

  • Inter-Frequency FDD Measurement Indicator

    If the value 1 or On is selected, the UE performs measurements and evaluates cell re-selection criteria on the inter-frequency FDD cells listed in SIB11 in CELL_FACH state.This setting can only be modified when the Call or Data Status is Idle .

    GPIB Command: CALL[:CELL]:BCCHannel:FMOCcasion:FDDIndicator

  • Inter-RAT Measurement Indicators Control

    If Present is selected, "Inter-RAT Measurement Indicators" and "RAT Type" are included in "FACH Measurement Occasion Info."This setting can only be modified when the Call or Data Status is Idle .

    GPIB Command: CALL[:CELL]:BCCHannel:FMOCcasion:RATIndicator:CONTrol

Related Topics

Manual Operation: How Do I Change the SIB11 FACH Measurement Occasion Information?

GPIB Commands: CALL:BCCHannel


SIB19 Information

SIB19 Information

Last updated: November 25, 2010

This section is only application to the lab application.

As specified in the 3GPP standard, the system information block type 19 contains Inter-RAT frequency and priority information to be used in the cell. The test set support SIB 19 by the following parameters:

  • SIB19 Info
  • SIB 19 UTRA Info List
  • SIB19 E-UTRA Info List

SIB19 Info

This setting determines whether or not SIB19 shall be transmitted via the BCCH.

GPIB command: CALL[:CELL]:BCCHannel:SIB19[:INFormation]

SIB 19 UTRA Info List

  • SIB19 UTRA Serving Cell Priority

    This setting determines the reselection priority associated with the UTRA Serving Cell.

    GPIB command: CALL[:CELL]:BCCHannel:SIB19:UTRA:SCEL1:PRIority

  • SIB19 UTRA Serving Cell Sprioritysearch1

    This setting affects the rate of inter-frequency and inter-RAT measurements when absolute priorities are used. See more details in 3GPP TS 25.304.

    GPIB command: CALL[:CELL]:BCCHannel:SIB19:UTRA:SCEL1:SPSearch1

  • SIB19 UTRA Serving Cell Sprioritysearch2

    You can specify whether to broadcast the S prioritysearch2 value in SIB 19 as part of the UTRA Serving Cell Info, by setting the SIB19 UTRA Serving Cell Sprioritysearch2 to On or Off . When it is set to On and set to a value, this setting affects the rate of inter-frequency and inter-RAT measurements when absolute priorities are used. See more details in 3GPP TS 25.304.GPIB command: CALL[:CELL]:BCCHannel:SIB19:UTRA:SCEL1:SPSearch2[:SVALue]

  • SIB19 UTRA Serving Cell Low Threshold

    This threshold is used in the rules for cell reselection when absolute priorities are used. It specifies the limit for serving cell Rx level below which the UE may perform cell reselection to a cell on a lower absolute priority layer.

    GPIB command: CALL[:CELL]:BCCHannel:SIB19:UTRA:SCEL1:THReshold:LOW

SIB19 E-UTRA Info List

The SIB19 E-UTRA Info List provides eight different E-UTRA Frequency and Priority Information entries, indexing from 1 to 8. Each entry allows you to configure the following fields: Measurement Bandwidth, priority, QrxlevminEUTRA, Threshx, high, Threshx, low and E-UTRA detection.

  • SIB19 E-UTRA EARFCN (1 to 8): E-UTRA State

    This setting determines whether the corresponding SIB19 E-UTRA EARFCN information is present in SIB19. If all the eight E-UTRA State are set to Off , the optional 'E-UTRA frequency and priority' IE will not be included in SIB19.

    GPIB command: CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8[:STATe]

  • SIB19 E-UTRA EARFCN (1 to 8): EARFCN

    This setting specifies the Downlink EARFCN of the neighbouring E-UTRA cell(s) for the corresponding SIB19 E-UTRA EARFCN (1 to 8).

    GPIB command: CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:EARFcn

  • SIB19 E-UTRA EARFCN (1 to 8): Measurement Bandwidth

    This setting determines the measurement bandwidth for the corresponding SIB19 E-UTRA EARFCN (1 to 8). The measurement bandwidth indicates the number of resource blocks over which the UE could measure.

    The default value for this setting is 50, specifying a channel bandwidth of 10MHz to match the specification of the default EARFCN values as in the 3GPP TS 36.508 v8.5.0.

    GPIB command: CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:MBWidth

  • SIB19 E-UTRA EARFCN (1 to 8): Priority

    This setting determines the reselection priority for the corresponding SIB19 E-UTRA EARFCN (1 to 8).

    GPIB command: CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:PRIority

  • SIB19 E-UTRA EARFCN (1 to 8): QrxlevminEUTRA

    This setting determines the QrxlevminEUTRA, which allows specification of the minimum required Rx level in the cell(s) associated with the corresponding SIB19 E-UTRA EARFCN (1 to 8).

    GPIB command: CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:RLMinimum

  • SIB19 E-UTRA EARFCN (1 to 8): Threshx,high

    This setting determines the Thresh x,high value for the corresponding SIB19 E-UTRA EARFCN (1 to 8). Thresh x,high , as defined in 3GPP TS 36.304 v8.8.0, specifies the threshold used by the UE when reselecting towards the higher priority frequency X than current serving frequency.

    GPIB command: CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:THReshold:HIGH

  • SIB19 E-UTRA EARFCN (1 to 8): Threshx,low

    This setting determines the Thresh x,low value for the corresponding SIB19 E-UTRA EARFCN (1 to 8). Thresh x,low , as defined in 3GPP TS 36.304 v8.8.0, specifies the threshold used in reselection towards frequency X priority from a higher priority frequency.

    GPIB command: CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:THReshold:LOW

  • SIB19 E-UTRA EARFCN (1 to 8): Detection

    This settings determines the content of the detection field for the corresponding SIB19 E-UTRA EARFCN (1 to 8).

    GPIB command: CALL[:CELL]:BCCHannel:SIB19:EUTRa[1]|2|3|4|5|6|7|8:DETection


How Do I Configure the AMR Radio Access Bearer?

How Do I Configure the AMR Radio Access Bearer?

Last updated: January 16, 2009

This section is applicable to the lab application only.

  1. Press the CALL SETUP key.
  2. Press the More key under Call Control to move to the 3 of 5 menu.
  3. Select AMR Setup ( F5 ).
  4. In the AMR Setup menu, set the AMR Source to Echo and the AMR Radio Access Bearer to the desired setting.

Related Topics

AMR Setup


How Do I Configure Cell 2?

How Do I Configure Cell 2?

Last updated: January 16, 2009

This section is only applicable to the lab application.

  • Set Cell 2 Power, Cell 2 Primary Scrambling Code, and Cell 2 Time Offset
  • Set Cell 2 Downlink Channel Levels
  • Set Cell 2 Closed Loop Power Control Mode

Set Cell 2 Power, Cell 2 Primary Scrambling Code, and Cell 2 Time Offset

  1. Press the CALL SETUP key.
  2. Select Handovers ( F5 ) on the Call Control menu, then Soft Handover Info ( F4 ).
  3. Set Cell 2 Power ( F1 ) to the desired value.
  4. Select SHO / Event Parameters ( F2 ).
    • Set Cell 2 Primary Scrambling Code to the desired value.
    • Set Cell 2 Time Offset to the desired value.

    Select Close Menu ( F6 ).

Set Cell 2 Downlink Channel Levels

  1. Press the CALL SETUP key.
  2. Press the left More key until you reach the Call Control ( 2 of 4 ) menu.
  3. Press Generator Info ( F3 ).
  4. Press the Connected DL Channel Levels ( F4 ) key, and change the power levels for the downlink channels, as needed.
  5. Select Close Menu ( F6 ).

Set Cell 2 Closed Loop Power Control Mode

  1. Press the CALL SETUP key.
  2. Press the right More key until you reach the Call Parms ( 3 of 3 ) menu.
  3. Select UL CL Power Ctrl Parameters ( F8 ).
  4. Set Cell 2 Power Ctrl to the desired setting.
  5. Select Close Menu ( F6 ).

Related Topics

Soft Handover

How Do I Perform a Soft Handover?

How Do I Configure and Enable (Start) Event Reporting?

Configuring Cell 1: How Do I Change Generator Information?


How Do I Configure the Data Channel?

How Do I Configure the Data Channel?

Last updated: January 16, 2009

This section is only applicable to the lab application.

  • GPRS Packet Data Service
  • CS (Circuit Switched) Data Service

GPRS Packet Data Service

  1. Press the CALL SETUP key.
  2. Press the More key on the left until you reach the Call Parms ( 3 of 4 ) menu.
  3. Press Data Channels ( F4 ).

  4. Press Packet Data Setup ( F1 ).

  5. Set GPRS Radio Access Bearer to the desired value.
  6. If you would like to simulate a network rejection of an Activate PDP Context Request from a UE, set Activate PDP Context Reject State to On , and set Activate PDP Context Reject SM Cause to the desired value.
  7. Select Close Menu ( F6 ).

CS (Circuit Switched) Data Service

  1. Press the CALL SETUP key.
  2. Press the More key on the left until you reach the Call Parms ( 3 of 4 ) menu.
  3. Press Data Channels ( F4 ).
  4. Press CS Data Setup ( F2 ).

  5. Set the CS data settings as needed.

  6. Select Close Menu ( F6 ).

Related Topics

Packet Switched Data


How Do I Configure and Enable (Start) Event Reporting?

How Do I Configure and Enable (Start) Event Reporting?

Last updated: January 16, 2009

This section is only applicable to the lab application.

  • A. Configure Event Parameters
  • B. Enable Event Reporting
  • C. Change Event Parameters

A. Configure Event Parameters

  1. Go to the Soft Handover Information Screen

  2. Select SHO / Event Parameters ( F2 ).

  3. Set event parameters as needed.

B. Enable Event Reporting

  1. Go to the Soft Handover Information Screen
  2. Set Event State ( F4 ) to On . The test set sends a Measurement Control message to the UE with the event parameter configuration specified in step A. Configure Event Parameters .

The UE reports events for cell 1 and cell 2 as they occur, as well as MS reported measurement results for each cell.

C. Change Event Parameters

  1. A. Configure Event Parameters .
  2. Select Send Event Config ( F5 if Event State is On ), to send a new Measurement Control message to the UE, specifying the changes to the event parameters.

NOTE
You can also send a new Measurement Control message to the UE by toggling Event State off and on.

Related Topics

Soft Handover


How Do I Ping a Device From the Test Set?

How Do I Ping a Device From the Test Set?

Last updated: May 30, 2011

This section is only applicable to the lab application.

How To Ping the DUT From the Test Set

  1. Set up a packet data connection as in the Establishing a Packet Data Connection procedure. Check for "PDP Active" in the Active Cell field.
  2. Press the Call Setup key.
  3. Press the left More key until 3 of 3 is displayed.
  4. Select Ping.
  5. Set up the desired Ping Protocol ( F2 ).
  6. Select Ping Setup ( F1 ).
  7. In the Ping Setup menu, select the Device to Ping. If you select DUT, the IP Address entered in the DUT IP Address field will be pinged. If you select Alternate, the IP Address entered in the Alternate Ping Address field will be pinged.
  8. Set the Ping Count, Timeout, and Packet Size.
  9. Select Start Ping .

Related Topics

Ping


How Do I Perform a Soft Handover?

How Do I Perform a Soft Handover?

Last updated: January 16, 2009

This section is only applicable to the lab application.

  • Make a Call
  • Go to the Soft Handover Information Screen
  • Configure Cell 2 and Turn Cell 2 Power On
  • Enable Soft Handover
  • (Optional) Perform Loopback BER or BLER Testing

Make a Call

See How Do I Set Up a Call and Make a Connection?

Go to the Soft Handover Information Screen

  1. Press the CALL SETUP key.
  2. Select Handovers ( F5 ) on the Call Control menu, then Soft Handover Info ( F4 ).

Configure Cell 2 and Turn Cell 2 Power On

See How Do I Configure Cell 2?

Enable Soft Handover

  1. Go to the Soft Handover Information Screen
  2. Set Soft Handover ( F3 ) to On .

(Optional) Perform Loopback BER or BLER Testing

  1. Configure and initialize the loopback BER (or BLER) measurement (see How Do I Make a Loopback Bit Error Ratio (BER) Measurement? and How Do I Make a Block Error Ratio (BLER) Measurement? ).
  2. Set Soft Handover ( F3 ) to Off .
  3. Set Cell Power ( F7 ) to -110 dBm/3.84 MHz .
  4. Set Cell2 Power ( F2 ) to -103.5 dBm/3.84 MHz . Note as you increase cell 2 power or decrease cell 1 power, BER increases.
  5. Set Soft Handover ( F3 ) to On . BER should decrease significantly, as the cell 2 signal is now combined with the cell 1 signal, rather than acting as interference. (If cell 2 level is too high, the messaging to order a soft handover may not be properly received by the UE and an error will be posted. If this is the case, simply decrease cell 2 power, enable soft handover, then return cell 2 its previous level)

Related Topics

Soft Handover

How Do I Configure Cell 2?

How Do I Configure and Enable (Start) Event Reporting?

How Do I Make a Loopback Bit Error Ratio (BER) Measurement?

How Do I Make a Block Error Ratio (BLER) Measurement?


Soft Handover

Soft Handover

Last updated: January 16, 2009

This section is only applicable to the lab application.

  • Cell 2 Overview
  • Soft Handover Overview
  • Mobile Station Reported Pilot Information
  • Enabling Soft Handover
  • Soft Handover State
  • Loopback BER and BLER Testing in Soft Handover
  • Event Reporting

Cell 2 Overview

The lab application includes two sectors, cell 1 and cell 2. Cell 1 is a full sector, supporting all call processing functionality available in the test set. Cell 2 is provided to allow the test set to perform a soft handover. Cell 2 alone can not be used for call processing events, such as establishing a call or handing off to a new frequency. Cell 2 can only be used in conjunction with cell 1 to test the UE's soft handover capability. The table below summarizes the features of cell 1 and cell 2, and indicates if the features are user-settable.

Cell 1 and Cell 2 Features
Feature |  | Cell 1 | Cell 2
DL Channel |  | User-settable (see Downlink Channel (UARFCN) ) | Equals cell 1 setting
CPICH | Level | User-settable | User-settable (see CALL:CELL2:CPIChannel ).
P-CCPCH/SCH | Level | User-settable | User-settable (see CALL:CELL2:CCPChannel ).
S-CCPCH | Channelization Code | User-settable | No S-CCPCH
 | Level | User-settable | No S-CCPCH
PICH | Channelization Code | User-settable | No PICH
 | Level | User-settable | No PICH
AICH | Channelization Code | User-settable | No AICH
 | Level | User-settable | No AICH
DPCH | Channelization Code | User-settable | Equals cell 1 setting
 | Level | User-settable | User-settable (see CALL:CELL2:DPCHannel ).
Composite OCNS |  | 16 channels (see Orthogonal Channel Noise Simulator (OCNS) ) | 1 channel at OVSF [128,2] (see CALL:CELL2:OCNSource )
Primary Scrambling Code |  | User-settable | User-settable (see CALL:CELL2:SCODe ).
Cell Power |  | User-settable | User-settable. Cell 2 power must be within 10 dB of cell 1 power. Cell 2 is turned off if cell 1 is turned off. (see CALL:CELL2:POWer )
Closed Loop Power Control |  | User-settable: All Up, All Down, Alternating, 10 Up/10 Down, Active, Single Up, Single Down (see Uplink Closed Loop Power Control Parameters and UE Target Power ). | User-settable: All Up, All Down, Alternating, 10 Up/10 Down, Active. When set to "Active," the TPC bits transmitted are the same as those transmitted by cell 1 (see Cell 2 UL CL Power Ctrl Mode and CALL:CELL2:CLPControl ).
Cell 2 Time Offset |  | You can specify a time offset which offsets the cell 2 signal in time relative to the cell 1 signal (see How Do I Configure Cell 2? and CALL:CELL2:TOFFset ). The test set can then order the UE to measure and report the SFN-SFN Observed Time Difference (OTD) .

See How Do I Configure Cell 2? for more information about configuring cell 2 from the front panel. See Downlink Channel Codes and Levels for more information about cell 1 channelization codes and levels.

The test set's total RF output power is a combination of the power of cell 1, cell 2 and AWGN power:
Total RF Power (dBm/3.84 MHz) = [Cell 1 Power + Cell 2 Power + AWGN Power] (dBm/3.84 MHz)
(see Cell Power and AWGN Power for more information about cell power and AWGN power).

Soft Handover Overview

The soft handover functionality is accessible through the Soft Handover Information screen (select Handovers ( F5 ) on the Call Control menu, then Soft Handover Info ( F4 ).)

Generated Pilot Information

The Generated Pilot Information window reports:

  • Total RF Power
  • Cell 1 CPICH Power (Cell Power + CPICH Level (or Cell 1 Connected CPICH Level))
  • Cell 2 CPICH Power (Cell 2 Power + Cell 2 CPICH Level)
  • Delta Power (the difference between the CPICH and Total RF Power)
  • Primary Scrambling Code

See Cell Power and AWGN Power , Downlink Channel Codes and Levels and CALL:STATus .

Mobile Station Reported Pilot Information

When a non-HSDPA connection is established between the test set and UE, you may request measurement results from the UE, including CPICH RSCP , CPICH Ec/No , Pathloss , OTD , OTD Type and DTCH BLER (see Cell 1/Cell 2 UE Reported Measurements ). When you request UE reported measurement results, results for CPICH RSCP, CPICH Ec/No and Pathloss are returned for both cell 1 and cell 2 (if cell 2 is set to a non-zero power level). If you have enabled soft handover (see Enabling Soft Handover ), the DTCH BLER Report result includes both cell 1 and cell 2 (there is only one DTCH in soft handover because soft combining of the two radio links in the UE occurs before the point where the DTCH is extracted and BLER is calculated).

Enabling Soft Handover

After establishing a non-HSDPA call between the test set's cell 1 and the UE, and configuring cell 2 (power, primary scrambling code, time offset, etc., see Cell 2 Overview ), you may turn soft handover on (see How Do I Perform a Soft Handover? and CALL:SHANdoff:ENABle ). This orders the UE to try to demodulate the signal from cell 2. Soft handover is not supported while on a CELL_FACH connection (see RB Test Mode RRC State Setting ) or while on an HSDPA connection.

Soft handover is supported for HSUPA connections but only to simulate a network scenario for when a UE performs a soft handover with cell 2 but the HSUPA channels remain confined to the cell 1 (serving cell). When an HSUPA call is established between the test set's cell 1 and the UE and you turn soft handover on, the DPCH is instructed to soft handover to cell 2 while the HSUPA channels remain confined to cell 1.

Soft Handover State

If the soft handover was successful (the UE responded correctly to the Active Set Update procedure), then a status of On is displayed for Soft Handover State (see CALL:STATus:SHANdoff:STATe? ).

Loopback BER and BLER Testing in Soft Handover

You can test Loopback BER and BLER while in soft handover (see How Do I Perform a Soft Handover? , Loopback Bit Error Ratio (BER) Measurement Description and Block Error Ratio (BLER) Measurement Description ). When soft handover is not enabled, as you increase cell 2 power, you will see an increase in BER/BLER (because cell 2 acts as an interferer). When you enable soft handover, the BER/BLER result should improve, as the UE is then able to soft combine the signals from both cells. (If cell 2 level is too high, the messaging to order a soft handover may not be properly received by the UE and an error will be posted. If this is the case, simply decrease cell 2 power, enable soft handover, then return cell 2 to its previous level).

Event Reporting

The soft handover functionality present in the test set also allows you to enable/disable event reporting (by turning Event State on and off), and to configure event parameters (such as Event 1a State , R 1a etc.).

When event reporting is enabled (non-HSDPA connections only), the UE reports to the test set when an event occurs (if you have enabled that event by turning its state on. For example: if you have set Event 1a State to On , then the UE will report when a 1a event occurs). You can query the most recent event reported by the UE using the CALL:STATus:SHANdoff:EVENt? query, and which cell caused the event using the CALL:STATus:SHANdoff:EVENt:CELLid? query.

When you turn Event State on (enable event reporting), the test set sends a Measurement Control message to the UE with the following user-settable event information:

  • 1a (A Primary CPICH enters the Reporting Range): Event 1a State, W, R 1a , H 1a
  • 1b (A Primary CPICH leaves the Reporting Range): Event 1b State, W, R 1b , H 1b
  • 1c (A Non-active Primary CPICH becomes better than an active Primary CPICH): Event 1c State, H 1c
  • 1d (Change of best cell): Event 1d State, H 1d
  • 1e (A Primary CPICH becomes better than an absolute threshold): Event 1e State, T 1e , H 1e
  • 1f (A Primary CPICH becomes worse than an absolute threshold): Event 1f State, T 1f , H 1f

(see How Do I Configure and Enable (Start) Event Reporting? and CALL:SHANdoff )

NOTE
After changing event parameters, you must send a new Measurement Control message to the UE by selecting Send Event Config ( F5 when viewing the SHO/Event Parameters menu with Event State on) or by toggling Event State off and on.

The Measurement Control message sent by the test set orders the UE to use the RSCP measurement result to determine whether an event has occurred. When an event occurs, the UE reports the requested MS reported measurement results - CPICH Ec/No, CPICH RSCP, Pathloss and/or DTCH BLER Report (see Mobile Station Reported Pilot Information ).

Related Topics

Manual Operation: How Do I Configure Cell 2?

Manual Operation: How Do I Configure and Enable (Start) Event Reporting?

Manual Operation: How Do I Perform a Soft Handover?

CALL:SHANdoff

CALL:STATus

Soft Handover Ladder Diagrams

UE Reported Measurements

Troubleshooting Soft Handover

Loopback Bit Error Ratio (BER) Measurement Description


Soft Handover Ladder Diagrams

Soft Handover Ladder Diagrams

Last updated: January 16, 2009

Enable Event Reporting

Related Topics

Soft Handover


CALL:CELL2:CCPChannel

CALL:CELL2:CCPChannel

January 16, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:CELL2:CCPChannel:PRIMary[:SLEVel]
  • CALL:CELL2:CCPChannel:PRIMary:LEVel
  • CALL:CELL2:CCPChannel:PRIMary:STATe

CALL:CELL2:CCPChannel:PRIMary[:SLEVel]

Function

Sets/queries the initial power offset of the cell 2 primary common control physical channel. This command sets the power offset level and turns on the power offset.

See Cell 2 Overview .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -5.35 dB
Requirements

Lab Application Revision: A.01 and above.

Lab Application Revision C.01 and above, changed default value to -5.35 dB.

Programming Example

OUTPUT 714;"CALL:CELL2:CCPCHANNEL:PRIMARY:SLEVEL -15DB" !Enables and sets the initial P-CCPCH power offset to -15 dB.

CALL:CELL2:CCPChannel:PRIMary:LEVel

Function

Sets/queries the cell 2 primary common control physical channel's initial power offset.

See Cell 2 Overview .

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -5.35 dB
Requirements

Lab Application Revision: A.01 and above.

Lab Application Revision C.01 and above, changed default value to -5.35 dB.

Programming Example

OUTPUT 714;"CALL:CELL2:CCPCHANNEL:PRIMARY:LEVEL -15DB" !Sets the initial P-CCPCH power offset to -15 dB.

CALL:CELL2:CCPChannel:PRIMary:STATe

Function

Sets/queries the cell 2 primary common control physical channel's state.

See Cell 2 Overview .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL2:CCPCHANNEL:PRIMARY:STATE ON"


CALL:CELL2:CLPControl

CALL:CELL2:CLPControl

January 16, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:CELL2:CLPControl:UPLink:MODE

CALL:CELL2:CLPControl:UPLink:MODE

Function

Sets/queries the cell 2 uplink power control setting when using the Active Cell operating mode. See Cell 2 Overview .

Setting

Range:

  • ACTive (activates closed loop power control)
  • UDOWn (alternating bits)
  • UP (all up bits)
  • DOWN (all down bits)
  • UDOWn10 (ten up/ten down bits)

Query

Range: Same as setting range.

*RST Setting

ACTive

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:CLPControl:UPLink:MODE ACTive"
!Sets the uplink closed loop power control to active.


CALL:CELL2:CPIChannel

CALL:CELL2:CPIChannel

Last updated: January 16, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:CELL2:CPIChannel[:SLEVel]
  • CALL:CELL2:CPIChannel:LEVel
  • CALL:CELL2:CPIChannel:STATe

CALL:CELL2:CPIChannel[:SLEVel]

Function

Sets/queries the cell 2 common pilot channel's initial power offset. This command sets the power offset level and turns on the power offset.

(See Cell 2 Overview ).

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -3.3 dB
Requirements

Lab Application Revision: A.01 and above.

Lab Application Revision C.01 and above, changed default value to -3.3 dB.

Programming Example

OUTPUT 714;"CALL:CELL2:CPICHANNEL:SLEVEL -10"

CALL:CELL2:CPIChannel:LEVel

Function

Sets/queries the common pilot channel's initial power offset. This command sets the power offset level and turns on the power offset.

(See Cell 2 Overview ).

Setting

Range: -20.00 dB to 0 dB

Resolution: 0.01

Query

Range: -20.00 dB to 0 dB

Resolution: 0.01

*RST Setting

 -3.3 dB
Requirements

Lab Application Revision: A.01 and above.

Lab Application Revision C.01 and above, changed default value to -3.3 dB.

Programming Example

OUTPUT 714;"CALL:CELL2:CPICHANNEL:LEVEL -5"

CALL:CELL2:CPIChannel:STATe

Function

Sets/queries the common pilot channel's state.

(See Cell 2 Overview ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)
Requirements Lab Application Revision: A.01 and above.

Programming Example

OUTPUT 714;"CALL:CELL2:CPICHANNEL:STATE ON"


CALL:CELL2:DPCHannel

CALL:CELL2:DPCHannel

Last updated: January 16, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:CELL2:DPCHannel[:SLEVel]
  • CALL:CELL2:DPCHannel:LEVel
  • CALL:CELL2:DPCHannel:STATe

CALL:CELL2:DPCHannel[:SLEVel]

Function

 Sets/queries the cell 2 dedicated physical channel's (DPCH) initial downlink offset, and sets its state to ON. (See Cell 2 Overview ).

Setting

Range: -30.00 dB to 0 dB

Resolution: 0.01
Query Same as setting

*RST Setting

 -10.30 dB

Requirements

Lab Application Revision: A.01 and above.

Lab Application Revision C.01 and above, changed default value to -10.30 dB.

Programming Example

OUTPUT 714;"CALL:CELL2:DPCHANNEL:SLEVEL -12"

CALL:CELL2:DPCHannel:LEVel

Function

 Sets/queries the cell 2 dedicated physical channel's (DPCH) initial downlink offset. (See Cell 2 Overview ).

Setting

Range: -30.00 dB to 0 dB

Resolution: 0.01
Query Same as setting

*RST Setting

 -10.30 dB

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:DPCHANNEL:LEVEL -12"

CALL:CELL2:DPCHannel:STATe

Function

Sets/queries the dedicated physical control channel's state.

This setting cannot be changed while in active cell operating mode. Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

(See Cell 2 Overview ).

Setting

Range: 1|ON | 0|OFF

Query

Range: 1| 0

*RST Setting

 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:DPCHANNEL:STAT 1"


CALL:CELL2:OCNSource

CALL:CELL2:OCNSource

Last updated: January 16, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:CELL2:OCNSource:CCODe:CODE
  • CALL:CELL2:OCNSource:LEVel([:SELected]|:FDD)?
  • CALL:CELL2:OCNSource:STATe([:SELected]|:FDD)?

CALL:CELL2:OCNSource:CCODe:CODE

Function

Sets/queries the channelization code of the single Cell 2 OCNS channel. This channel has a spreading factor of 128.

This setting cannot be changed while in active cell operating mode (when available). Attempting to change this setting while in this mode results in the following error message: "Command Rejected. Change Not Allowed in Active Cell Mode." Use the cell off operating mode when changing this value.

Setting

Range: 1 to 127

Query

Range: 1 to 127

*RST Setting

 2

Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:CELL2:OCNSource:CCODe:CODE 2"

CALL:CELL2:OCNSource:LEVel([:SELected]|:FDD)?

Function

Queries the cell 2 calculated ( Desired ) level of the UTRA FDD composite orthogonal channel noise simulator (OCNS).

The optional [:SELected] keyword in this command specifies that the OCNS channel level being queried applies to the current system type.

The OCNS level is a calculated value used to balance the relative power levels of the following channels to sum to 100%:

  • OCNS
  • Common Pilot Channel (CPICH)
  • Primary Common Control Physical Channel (P-CCPCH)
  • Synchronization Channel (SCH)
  • Dedicated Physical Channel (DPCH)

If the contribution of OCNS is calculated to be -30 dB or less, the OCNS state is turned off.

(See Cell 2 Overview ).

Query

Range: 0 to -29 dB, 9.91 E+37, -9.9E+37 (returned if no power is being placed into the OCNS channels)

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:OCNSOURCE:LEVEL?" !Queries the cell 2 calculated OCNS level.

CALL:CELL2:OCNSource:STATe([:SELected]|:FDD)?

Function

Queries the cell 2 on/off state of the calculated UTRA FDD composite orthogonal channel noise simulator (OCNS).

The optional [:SELected] keyword in this command specifies that the OCNS state being queried applies to the current system type.

The OCNS level is a calculated value used to balance the relative power levels of the following channels to sum to 100%:

  • OCNS
  • Common Pilot Channel (CPICH)
  • Primary Common Control Physical Channel (P-CCPCH)
  • Synchronization Channel (SCH)
  • Dedicated Physical Channel (DPCH)

If the contribution of OCNS is calculated to be -30 dB or less, the OCNS state is turned off.

(See Cell 2 Overview ).

Setting

Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:OCNSOURCE:STATE?"


CALL:CELL2:POWer

CALL:CELL2:POWer

January 16, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:CELL2:POWer[:SAMPLitude]
  • CALL:CELL2:POWer:AMPLitude[:SELected]
  • CALL:CELL2:POWer:STATe[:SELected]

CALL:CELL2:POWer[:SAMPLitude]

Function

Sets/queries the cell 2 power level (including compensation for amplitude offset), and sets its state to ON. (See Cell 2 Overview ).

Setting

Range:

  • -165 dBm/3.84MHz to +37dBm/3.84MHz, 9.91 E+37

    (-115 dBm/3.84MHz to -13 dBm/3.84MHz actual hardware range with amplitude offset = 0)

    The actual power range is defined by adding the value of the associated Amplitude Offset to the range in the table. For example, if amplitude offset is -3.5 dB, then the power range will be -118.5 dBm/3.84 MHz to -16.5 dBm/3.84MHz.

Resolution: 0.01 dBm/3.84 MHz

Query

Range: Same as setting range.

Resolution: Same as setting range.

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:POWER:SAMPLITUDE -30"
! Sets the cell 2 power level -30 dBm and turns it on.

CALL:CELL2:POWer:AMPLitude[:SELected]

Function

Sets/queries the cell 2 power level (including compensation for amplitude offset).

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type. The current system type can be changed using the CALL[:CELL]:SYSTem[:TYPE]? command.

(See Cell 2 Overview ).

Setting

Range:

  • -165 dBm/3.84MHz to +37dBm/3.84MHz, 9.91 E+37

    (-115 dBm/3.84MHz to -13 dBm/3.84MHz actual hardware range with amplitude offset = 0)

    The actual power range is defined by adding the value of the associated Amplitude Offset to the range in the table. For example, if amplitude offset is -3.5 dB, then the power range will be -118.5 dBm/3.84 MHz to -16.5 dBm/3.84MHz.

Resolution: 0.01 dBm/3.84 MHz

Query

Range: Same as setting range.

Resolution: Same as setting range.

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:POWER:AMPLITUDE -30"
!Sets the cell 2 power level -30 dBm.

CALL:CELL2:POWer:STATe[:SELected]

Function

Sets/queries the cell 2 power state.

The optional [:SELected] keyword in this command specifies that the cell 2 power state being set or queried applies to the current system type. The current system type can be changed using the CALL[:CELL]:SYSTem[:TYPE]? command.

(See Cell 2 Overview ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

OFF

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:POWER:STATE ON"
! Turns on cell 2 power.


CALL:CELL2:SCODe

CALL:CELL2:SCODe

January 16, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:CELL2:SCODe[:PRIMary]

CALL:CELL2:SCODe[:PRIMary]

Function

Sets/queries the cell 2 primary scrambling code.

The actual code number for the primary scrambling code is 16 times the value of this setting. See 3GPP TS 25.213, "Spreading and Modulation (FDD)" for a complete description of the relationship between this index and the actual spreading code number.

This setting can only be changed in idle mode.

(See Cell 2 Overview ).

Setting

Range: 0 to 511

Query

Range: 0 to 511

*RST Setting

127

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:SCODe 10"
! Sets the cell 2 primary scrambling code to 10.


CALL:CELL2:TOFFset

CALL:CELL2:TOFFset

January 16, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:CELL2:TOFFset

CALL:CELL2:TOFFset

Function

Sets/queries the cell 2 time offset. (See Cell 2 Overview ).

Setting

Range: 0 to +16 chips

Query

 Same as setting

*RST Setting

0 chips

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:TOFFset 10" !Sets the cell 2 time offset to 10.


CALL:COUNt

CALL:COUNt

Last updated:January 6, 2012

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:COUNt:CLEar:MS:IP
  • CALL:COUNt:MS:IP[:ALL]?
  • CALL:COUNt:MS:IP:RX?
  • CALL:COUNt:MS:IP:RX:IP6?
  • CALL:COUNt:MS:IP:TX?
  • CALL:COUNt:MS:IP:TX:IP6?
  • CALL:COUNt:MS:ROHC:RX:COMPressed[:OCTets]?
  • CALL:COUNt:MS:ROHC:RX:COMPressed:PACKets?
  • CALL:COUNt:MS:ROHC:TX:COMPressed[:OCTets]?
  • CALL:COUNt:MS:ROHC:TX:COMPressed:PACKets?

CALL:COUNt:CLEar:MS:IP

Function

 Clears the data counters.

Programming Example

OUTPUT 714;"CALL:COUNt:CLEar:MS:IP" !Clears the IP counters.

CALL:COUNt:MS:IP[:ALL]?

Function

Queries the number of IP (Internet Protocol) packets and bytes transferred between the test set and the wireless device on both the uplink and downlink. Results are returned in the following order:

1. Downlink packets
2. Downlink bytes
3. Uplink packets
4. Uplink bytes

Power up, full preset, or the clear counters command will clear the counters.

When IP counters reach their maximum value, they remain at that value until cleared.

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP:ALL?" !Queries the packet and byte count on the downlink and uplink.

CALL:COUNt:MS:IP:RX?

Function

Queries the number of IP (Internet Protocol) packets and bytes (both IPv4 and IPv6) transferred between the wireless device and the test set on the uplink channel. Results are returned in the following order:

1. Packets
2. Bytes

Power up, full preset, or the clear counters command will clear the counters.

When IP counters reach their maximum value, they remain at that value until cleared.

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP:RX?" !Queries the packet and byte count on the downlink.

CALL:COUNt:MS:IP:RX:IP6?

Function

Queries the number of IPv6 (Internet Protocol) packets and bytes transferred between the wireless device and the test set on the uplink channel. Results are returned in the following order:

1. Packets
2. Bytes

Power up, full preset, or the clear counters command will clear the counters.

When the counters reach their maximum value, they remain at that value until cleared.

Query

Range: 0 to 9,999,999,999, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP:RX:IP6?".

CALL:COUNt:MS:IP:TX?

Function

Queries the number of IP (Internet Protocol) packets and bytes (both IPv4 and IPv6) transferred between the wireless device and the test set on the downlink channel. Results are returned in the following order:

1. Packets
2. Bytes

Power up, full preset, or the clear counters command will clear the counters.

When IP counters reach their maximum value, they remain at that value until cleared.

Query

Range: 0 to 9,999,999,999, 9.91 E+37

Resolution: 1

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP:TX?" !Queries the packet and byte count on the downlink.

CALL:COUNt:MS:IP:TX:IP6?

Function

Queries the number of IPv6 (Internet Protocol) packets and bytes transferred between the wireless device and the test set on the downlink channel. Results are returned in the following order:

1. Packets
2. Bytes

Power up, full preset, or the clear counters command will clear the counters.

When the counters reach their maximum value, they remain at that value until cleared.

Query

Range: 0 to 9,999,999,999, 9.91 E+37

Resolution: 1

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP:TX:IP6?" !Queries the IPv6 packet and byte count on the downlink.

CALL:COUNt:MS:ROHC:RX:COMPressed[:OCTets]?

Function

Queries the number of octets for the downlink compressed packets.

Query

Range: 0 to 9999999999, 9.91E +37

*RST Setting

9.91E +37
Requirements Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:ROHC:RX:COMPressed?"
!Queries the umber of octets for the downlink compressed packets.

CALL:COUNt:MS:ROHC:RX:COMPressed:PACKets?

Function

Queries the number of downlink compressed packets (packets compressed by the test set compressor).

Query

Range: 0 to 9999999999, 9.91E +37

*RST Setting

9.91E +37
Requirements Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:ROHC:RX:COMPressed:PACKets?"
!Queries the number of downlink compressed packets.

CALL:COUNt:MS:ROHC:TX:COMPressed[:OCTets]?

Function

Queries the number of octets for uplink compressed packets.

Query

Range: 0 to 9999999999, 9.91E +37

*RST Setting

9.91E +37
Requirements Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:ROHC:TX:COMPressed?"
!Queries the number of octets for uplink compressed packets.

CALL:COUNt:MS:ROHC:TX:COMPressed:PACKets?

Function

Queries the number of uplink compressed packets (packets compressed by the UE compressor).

Query

Range: 0 to 9999999999, 9.91E +37

*RST Setting

9.91E +37
Requirements Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:ROHC:TX:COMPressed:PACKets?"
!Queries the number of uplink compressed packets.


CALL:DATA:PING

CALL:DATA:PING

Last updated: May 25, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:DATA:PING[:ALL]?

  • CALL:DATA:PING:ICOunt?

  • CALL:DATA:PING:PACKets:RX?
  • CALL:DATA:PING:PACKets:TX?

  • CALL:DATA:PING:PLOSs?

  • CALL:DATA:PING:SETup:ALTernate:IP:ADDRess[:IP4]
  • CALL:DATA:PING:SETup:ALTernate:IP:ADDRess:IP6
  • CALL:DATA:PING:SETup:COUNt
  • CALL:DATA:PING:SETup:DEVice
  • CALL:DATA:PING:SETup:PACKet[:SIZE][:IP4]
  • CALL:DATA:PING:SETup:PACKet[:SIZE]:IP6
  • CALL:DATA:PING:SETup:PROTocol
  • CALL:DATA:PING:SETup:TIMeout

  • CALL:DATA:PING:STARt

  • CALL:DATA:PING:STOP

  • CALL:DATA:PING:TIME[:AVERage]?
  • CALL:DATA:PING:TIME:MAXimum?
  • CALL:DATA:PING:TIME:MINimum?

CALL:DATA:PING[:ALL]?

Function

This command returns the following results: packets transmitted, packets received, percent packets lost, minimum round trip time (in seconds), average round trip time (in seconds), maximum round trip time (in seconds).

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:ALL?"

ENTER 714;Pxmit,Prcvd,Plost,Min_time,Avg_time,Max_time

CALL:DATA:PING:ICOunt?

Function

This command queries the value that is available when the query is received.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:ICOUNT?"

ENTER 714;variable_name

CALL:DATA:PING:PACKets:RX?

Function

This command queries the number of packets received from the device being tested or from the alternate device if CALL:DATA:PING:SETup:DEVice is set to ALTernate.

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:PACKETS:RX?"

ENTER 714;variable_name

!Queries the number of packets received from the device being tested.

CALL:DATA:PING:PACKets:TX?

Function

This queries the number of packets transmitted from the test set.

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:PACKETS:TX?"

ENTER 714;variable_name

!Queries the number of packets transmitted from the test set.

CALL:DATA:PING:PLOSs?

Function

This command queries the percentage of packets lost during the ping session.

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:PLOSS?" !Queries the percentage of lost packets.

ENTER 714;variable_name

CALL:DATA:PING:SETup:ALTernate:IP:ADDRess[:IP4]

Function

This sets/queries the alternate internet protocol (IP) address. This address will be used as the address to ping instead of the device under test if the CALL:DATA:PING:SETup:DEVice command is set to ALT and the CALL:DATA:PING:SETup:PROTocol is set to IP4.

Setting

Range: IPv4 address in dotted decimal format.

Query

Same as setting.
Requirements

Lab Application Revision: A.01 and above

Lab Application Revision: F.00.19 and above, added [:IP4]

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:ALTERNATE:IP:ADDRESS '192.168.16.57'"

CALL:DATA:PING:SETup:ALTernate:IP:ADDRess:IP6

Function

This sets/queries the Alternate internet protocol version 6(IPv6) pinging address. This address will be used as the alternate address to ping instead of the device under test if the CALL:DATA:PING:SETup:DEVice command is set to ALT and the CALL:DATA:PING:SETup:PROTocol command is set to IP6.

Setting

Range: 0 to 45 characters of an valid IPv6 address, this can be a normal 39- character IPv6 address, a zero compression IPv6 address or a up to 45-character IPv4 address-compatible address (see IPv6 Address Requirements ). Ranges are from

  • "" (blank field) or
  • 2000:0000:0000:0000:0000:0000:0000:0000 to 3FFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF or
  • FC00:0000:0000:0000:0000:0000:0000:0000 to FDFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF or
  • FE80:0000:0000:0000:0000:0000:0000:0000 to FEBF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF

Query

 Range: "" (blank field) or 39 characters of IPv6 address with the format: AAAA:BBBB:CCCC:DDDD:EEEE:FFFF:GGGG:HHHH. Each of the A, B, ... H is an hex number ranging from 0 to F.

*RST Setting

 FE80:0000:0000:0000:0000:0000:0000:0001
Requirements Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:ALTERNATE:IP:ADDRESS:IP6 '2009::146.208.232.220'"
Sets the alternate Ping6 Address to 2009::146.208.232.220.

OUTPUT 714;"CALL:DATA:PING:SETUP:ALTERNATE:IP:ADDRESS:IP6 'FE80::1'"
Sets the alternate Ping6 Address to FE80::1.

CALL:DATA:PING:SETup:COUNt

Function

This command set/queries the number of ping IP messages sent for each uninterrupted invocation of the CALL:DATA:PING:STARt command.

Setting

Range: 1 to 2147483647

Query

 Same as setting
Requirements

Lab Application Revision: A.01 and above

Lab Application Revision D.01, extended the upper limit of the range from 1000 to 2147483647

*RST Setting

 10

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:COUNT 20"

CALL:DATA:PING:SETup:DEVice

Function

This command sets/queries which device address is used in the ping IP packets, the address of the device under test, or the address of an alternate device.

Setting

Range: DUT|ALTernate

Query

Range: DUT|ALT
Requirements Lab Application Revision: A.01 and above

*RST Setting

 DUT

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:DEVice ALT"

CALL:DATA:PING:SETup:PACKet[:SIZE][:IP4]

Function

This command sets/queries the number of bytes sent by the test set in each ping packet when the CALL:DATA:PING:SETup:PROTocol command is set to IP4.

Setting

Range: 8 to 4076

Resolution: 1

Query

 Same as setting
Requirements

Lab Application Revision: A.01 and above

Lab Application Revision: F.00.19 and above, added [:IP4]

*RST Setting

 64 bytes

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETup:PACKet 10"

CALL:DATA:PING:SETup:PACKet[:SIZE]:IP6

Function

This command sets/queries the number of bytes sent by the test set in each ping packet with the CALL:DATA:PING:SETup:PROTocol command set to IP6.

Setting

Range: 9 to 8192

Resolution: 1

Query

 Same as setting
Requirements Lab Application Revision: F.00.19 and above

*RST Setting

 64 bytes

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETup:PACKet:IP6 10"

CALL:DATA:PING:SETup:PROTocol

Function

This command sets/queries the ping protocol to use when pinging the external device.

Setting

 IP4 | IP6

Query

 Same as setting
Requirements Lab Application Revision: F.00.19 and above

*RST Setting

 IP4

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETup:PROTocol IP4"

CALL:DATA:PING:SETup:TIMeout

Function

This command sets or queries how long the test set will wait before ending a ping session.

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.

Setting

Range: 1 to 100 seconds

Query

Range: 1 to 100 seconds
Requirements Lab Application Revision: A.01 and above

*RST Setting

 5 seconds

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:TIMEOUT 10"

CALL:DATA:PING:STARt

Function

This command starts a ping session.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:START"

CALL:DATA:PING:STOP

Function

This command immediately stops a ping session. The ping results will not include counts for any ping message that has not yet received a response.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:STOP"

CALL:DATA:PING:TIME[:AVERage]?

Function

This command queries the average round trip time (in seconds) for a series of pings.

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:TIME:AVERAGE?"

ENTER 714;variable_name

CALL:DATA:PING:TIME:MAXimum?

Function

This command queries the maximum round trip time (in seconds) for a series of pings.

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:TIME:MAXIMUM?"

ENTER 714;variable_name

CALL:DATA:PING:TIME:MINimum?

Function

This command queries the minimum round trip time (in seconds).

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:TIME:MINIMUM?"

ENTER 714;variable_name


CALL:MS:IP:ADDRess

CALL:MS:IP:ADDRess

Last updated: May 11, 2011

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:MS:IP:ADDRess:ROUTing:STATe
  • CALL:MS:IP:ADDRess[1]
  • CALL:MS:IP:ADDRess[1]|2:IP6:PREFix
  • CALL:MS:IP:ADDRess2
  • CALL:MS:IP:ADDRess[1]:CONText:PRIMary:QOService
  • CALL:MS:IP:ADDRess2:CONText:PRIMary:QOService
  • CALL:MS:IP:VERSion
  • CALL:MS:IP:VERSion2

CALL:MS:IP:ADDRess:ROUTing:STATe

Function

This command enables or disables forwarding of subnet traffic to the DUT IP Address. See DUT Routing State for more information.

Setting

Range:1 | ON | 0 | OFF

Query

Range: 0 | 1

*RST Setting

0 | OFF

Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:MS:IP:ADDRess:ROUTing:STATe OFF"
! Turns off the DUT routing state.

CALL:MS:IP:ADDRess[1]

Function

Sets/queries the DUT (Device Under Test) IP address.

This command is used to set up a wireless device's IP address.

Setting

Range: 15 characters formatted as follows: A.B.C.D

The range of values for A= 0 to 126 and 128 to 223. The range of values for B,C,D = 0 to 255

Query

Range: 15 characters formatted as follows: A.B.C.D

The range of values for A= 0 to 166 and 168 to 223. The range of values for B,C,D = 0 to 255

*RST Setting

 Non-volatile

Programming Example

OUTPUT 714;"CALL:MS:IP:ADDRess1 `130.29.179.219'"
!Sets the DUT IP Address1 to 130.29.179.219.

CALL:MS:IP:ADDRess[1]|2:IP6:PREFix

Function

Sets/queries the DUT IPv6 Prefix .

Setting

Range: 19 characters formatted as: AAAA:BBBB:CCCC:DDDD where A, B, C and D are all hex numbers.

  • "" (Null) or
  • 2000:0000:0000:0000 to 3FFF:FFFF:FFFF:FFFF or
  • FC00:0000:0000:0000 to FDFF:FFFF:FFFF:FFFF

Double-colon "::" can be used in the IPv6 address as valid. Moreover, "::" can be suffixed at the end of the 19 characters which is also a valid IPv6 address prefix. For example: 2009:1:2:3 and 2009:1:2:3:: are all valid IPv6 address prefixes for the GPIB parameter setting.

Query

 Range: 19 characters formatted as: AAAA:BBBB:CCCC:DDDD where A, B, C and D are all hex numbers ranging from 0 to F.

*RST Setting

 "" (Null)

Requirements

Lab Application Revision: H.00.00 and above

Programming Example

OUTPUT 714;"CALL:MS:IP:ADDRess:IP6:PREFix '2009:1:2:3::'"
!Sets the DUT IPv6 prefix to 2009:1:2:3::.

CALL:MS:IP:ADDRess2

Function

Sets/queries the IPv4 address of the second primary PDP Context.

Setting

Range: "" OR

0.0.0.0 to 225.255.255.255

Query

Range: "" OR

0.0.0.0 to 225.255.255.255

*RST Setting

 ""

Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:MS:IP:ADDRess2 `130.29.179.219'"
!Sets the address of second primay PDP Context to 130.29.179.219.

CALL:MS:IP:ADDRess[1]:CONText:PRIMary:QOService

Function

Sets/queries the DUT IP QOS Profile.

This parameter specifies the QOS parameters for the first primary PDP context.

Setting

Range: NONE | QOSProfile1 | QOSProfile2

Query

 Range: NONE | QOSP1 | QOSP2

*RST Setting

 NONE

Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:MS:IP:ADDRess1:CONText:PRIMary:QOService QOSProfile1"
!Sets the QOS parameters to QOSProfile1.

CALL:MS:IP:ADDRess2:CONText:PRIMary:QOService

Function

Sets/queries the DUT IP 2 QOS Profile, the QOS parameters for the second primary PDP context.

Setting

Range: NONE | QOSProfile1 | QOSProfile2

Query

 Range: NONE | QOSP1 | QOSP2

*RST Setting

 NONE

Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:MS:IP:ADDRess2:CONText:PRIMary:QOService QOSProfile1"
!Sets the QOS parameters to QOSProfile1.

CALL:MS:IP:VERSion

Function

 Sets/queries the type of the communication the test set will use when setting up a connection with the DUT, See DUT IP Version .

Setting

Range: IP4 | IP6 | DUAL

Query

Range: same as setting

*RST Setting

 IP4

Requirements

 Lab Application Revision: G.00.09 and above

Programming Example

OUTPUT 714;"CALL:MS:IP:VERSion IP4"
! Sets the DUT IP Version to IPv4.

CALL:MS:IP:VERSion2

Function

 Sets/queries the DUT IP 2 Version, the type of the communication the test set will use when setting up a connection with the DUT, See DUT IP 2 Version .

Setting

Range: IP4 | IP6 | DUAL

Query

Range: same as setting

*RST Setting

 IP4

Requirements

 Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:MS:IP:VERSion 2 IP4"
! Sets the DUT IP 2 Version to IPv4.


CALL:PLOGging

CALL:PLOGging

Last updated: January 16, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:PLOGging:ACTive?
  • CALL:PLOGging:CONNected?
  • CALL:PLOGging:DONE?
  • CALL:PLOGging:STARt
  • CALL:PLOGging<:STATus|:STATe>?
  • CALL:PLOGging:STOP

CALL:PLOGging:ACTive?

Function

This query returns an integer value of 1 if the status of the test set's protocol logging data source is:

  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.

See CALL:PLOGging<:STATus|:STATe>? .

If the state of the test set's protocol logging data source is not Active, this query will "hang" until a transition to the Active state occurs, or a bus timeout or device clear terminates the query attempt.
Requirements Lab Application Revision: A.01.20 and above

Query

 Range: 1

Programming Example

 OUTPUT 714;"CALL:PLOGGING:ACT?"!Queries the Active state.

CALL:PLOGging:CONNected?

Function

This query returns an integer value of 1 if the status of the test set's protocol logging data source is either:

  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.
  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.

See CALL:PLOGging<:STATus|:STATe>? .

If the state of the test set's protocol logging data source is not one of the above, this query will "hang" until a transition to one of these states occurs, or a bus timeout or device clear terminates the query attempt.
Requirements Lab Application Revision: A.01.20 and above

Query

 Range: 1

Programming Example

 OUTPUT 714;"CALL:PLOGGING:CONN?"!Queries the connected state.

CALL:PLOGging:DONE?

Function

This query returns an integer value of 1 if the status of the test set's protocol logging data source is either:

  • DISC (Disconnected) - There is no real-time protocol logging session established between the test set and the protocol logging software.
  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.

See CALL:PLOGging<:STATus|:STATe>? .

If the state of the test set's protocol logging data source is not one of the above, this query will "hang" until a transition to one of these states occurs, or a bus timeout or device clear terminates the query attempt.
Requirements Lab Application Revision: A.01.20 and above

Query

 Range: 1

Programming Example

 OUTPUT 714;"CALL:PLOGGING:DONE?"!Queries the done (logging) state.

CALL:PLOGging:STARt

Function

This command will cause the test set to transition to the Active logging state. Once in the Active Logging state the test set can begin forwarding messages to the protocol logging software.

The protocol logging software must be in real-time mode (not post-capture mode) and a real-time logging session must be connected before transition to the Active logging state is possible.

A real-time logging session is connected by entering the IP Address of the test set in the Tools, Configuration window found in the protocol logging software. When a real-time logging session is connected, the test set's front panel logging annunciator will display Logging:Idle (see the Idle description in CALL:PLOGging<:STATus|:STATe>? .)

After the transition from the Idle to Active logging state has occurred, the test set's front paned logging annunciator will appear as follows:

Logging:Active

Note

The test set can also be transitioned to the Active logging state by clicking on the REC (record) button located in the protocol logging software

Note

Requirements Lab Application Revision: A.01.20 and above

Programming Example

 OUTPUT 714;"CALL:PLOGGING:START" !Starts protocol logging.

CALL:PLOGging<:STATus|:STATe>?

Function

This command queries the status of the test set's protocol logging data source. The logging status can be viewed on the test set front panel's logging annunciator.

Possible query results are:DISC

  • (Disconnected) - There is no real-time protocol logging session established between the test set and the protocol logging software.
  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.
  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.
  • STRTG (Starting) - This is a transitional state while the protocol logging software attempts to start logging test set protocol messages.
  • STPG (Stopping) - This is a transitional state while the protocol logging software attempts to stop logging test set protocol messages.

Requirements Lab Application Revision: A.01.20 and above

Query

 Range: DISC|IDLE|ACT|STRTG|STPG

Programming Example

 OUTPUT 714;"CALL:PLOGGING:STATe?"!Queries the protocol logging state.

CALL:PLOGging:STOP

Function

This command will cause the test set to transition to the Idle logging state.

The test set must be in the Active state before transition to the Idle logging state is possible.

After the transition from the Active to the Idle logging state, the test set's front panel logging annunciator will appear as follows

Logging:Idle

Note

The test set can also be transitioned to the Idle logging state by clicking on the STOP button located in the protocol logging software

Note

Requirements Lab Application Revision: A.01.20 and above

Programming Example

 OUTPUT 714;"CALL:PLOGGING:STOP"!Stops protocol logging.


CALL:RACode

CALL:RACode

Last updated: January 16, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL[:CELL]:RACode<[:SELected]|:WCDMa>

CALL[:CELL]:RACode<[:SELected]|:WCDMa>

Function

Sets/queries the Routing Area Code (RAC) .

This parameter can only be set when PS Domain Information is set to Present and call status is Idle . If BCCH Update Page is set to Auto and you change this setting while your UE is camped to the test set, the test set performs a Broadcast Channel (BCCH) Update Procedure (SIB Contents) . If BCCH Update Page is set to Inhibit (the default value) and you change this setting while your UE is camped to the test set, you must force your UE to re-read the BCCH to observe the change (see BCCH Update Page for more details).

Setting

Range: 0 to 255

Query

 Same as setting.

*RST Setting

 1
Requirements Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:RACODE 2"
! Sets the routing area code to 2.


CALL:SERVice

CALL:SERVice

Last updated: January 7, 2012

GPIB Command Conventions

  • CALL:SERVice:AMR:RAB
  • CALL:SERVice:AMR:RAB:DLRate:AMR1220P
  • CALL:SERVice:AMR:RAB:DLRate:AMRSelect
  • CALL:SERVice:AMR:RAB:DLRate:WAMR1
  • CALL:SERVice:AMR:RAB:DLRate:WAMR2
  • CALL:SERVice:AMR:RAB:DLRate:WAMR3
  • CALL:SERVice:AMR:RAB:DLRate:WAMR4
  • CALL:SERVice:AMR:RAB:ULSubset:AMR1220P
  • CALL:SERVice:AMR:RAB:ULSubset:SEND
  • CALL:SERVice:AMR:RAB:ULSubset:WAMR4
  • CALL:SERVice:AMR:SOURce
  • CALL:SERVice:AMR:SPEech:ECHO:LOOPback:DELay

  • CALL:SERVice:CSData:MODE:ASYNchronous:OUTput

  • CALL:SERVice:GPRS:AAReject[:STATe]
  • CALL:SERVice:GPRS:AAReject:CAUSe
  • CALL:SERVice:GPRS:AREJect[:STATe]
  • CALL:SERVice:GPRS:AREJect:CAUSe
  • CALL:SERVice:GPRS:AIGNore[:STATe]
  • CALL:SERVice:GPRS:IGNore[:STATe]
  • CALL:SERVice:GPRS:RAB
  • CALL:SERVice:GPRS:RAUPdate:IGNore[:STATe]
  • CALL:SERVice:GPRS:RAUReject[:STATe]
  • CALL:SERVice:GPRS:RAUReject:CAUSe
  • CALL:SERVice:GPRS:REJect[:STATe]
  • CALL:SERVice:GPRS:REJect:CAUSe

  • CALL:SERVice:PSData:APName[:VALue]
  • CALL:SERVice:PSData:APName:CUSTom
  • CALL:SERVice:PSData:APName:STATe

  • CALL:SERVice:PSData:HEADer:COMPression[:STATe]

  • CALL:SERVice:PSData[:QOSProfile[1]]:DORDer
  • CALL:SERVice:PSData:QOSProfile2:DORDer
  • CALL:SERVice:PSData[:QOSProfile[1]]:DOWNlink:BRAte:GUARanteed
  • CALL:SERVice:PSData:QOSProfile2:DOWNlink:BRAte:GUARanteed
  • CALL:SERVice:PSData[:QOSProfile[1]]:DOWNlink:BRAte[:MAXimum]
  • CALL:SERVice:PSData:QOSProfile2:DOWNlink:BRAte[:MAXimum]
  • CALL:SERVice:PSData[:QOSProfile[1]]:RBERatio
  • CALL:SERVice:PSData:QOSProfile2:RBERatio
  • CALL:SERVice:PSData[:QOSProfile[1]]:SDU:EDELivery
  • CALL:SERVice:PSData:QOSProfile2:SDU:EDELivery
  • CALL:SERVice:PSData[:QOSProfile[1]]:SDU:ERATio
  • CALL:SERVice:PSData:QOSProfile2:SDU:ERATio
  • CALL:SERVice:PSData[:QOSProfile[1]]:SDU:SIZE[:MAXImum]
  • CALL:SERVice:PSData:QOSProfile2:SDU:SIZE[:MAXImum]
  • CALL:SERVice:PSData[:QOSProfile[1]]:SINDication
  • CALL:SERVice:PSData:QOSProfile2:SINDication
  • CALL:SERVice:PSData[:QOSProfile[1]]:TCLass
  • CALL:SERVice:PSData:QOSProfile2:TCLass
  • CALL:SERVice:PSData[:QOSProfile[1]]:TDELay
  • CALL:SERVice:PSData:QOSProfile2:TDELay
  • CALL:SERVice:PSData[:QOSProfile[1]]:THPRiority
  • CALL:SERVice:PSData:QOSProfile2:THPRiority
  • CALL:SERVice:PSData[:QOSProfile[1]]:UPLink:BRAte:GUARanteed
  • CALL:SERVice:PSData:QOSProfile2:UPLink:BRAte:GUARanteed
  • CALL:SERVice:PSData[:QOSProfile[1]]:UPLink:BRAte[:MAXimum]
  • CALL:SERVice:PSData:QOSProfile2:UPLink:BRAte[:MAXimum]

  • CALL:SERVice:PSData:RAPName[1]|2|3|4|5|6[:VAlue]
  • CALL:SERVice:PSData:RAPName[1]|2|3|4|5|6:CUSTom
  • CALL:SERVice:PSData:RAPName:REJect:CAUSe
  • CALL:SERVice:PSData:RAPName:STATe

  • CALL:SERVice:PSData:ROHC:DOWNlink:CID:MAXimum
  • CALL:SERVice:PSData:ROHC:DOWNlink:PROFile:ESP[:STATe]
  • CALL:SERVice:PSData:ROHC:DOWNlink:PROFile:RTP[:STATe]
  • CALL:SERVice:PSData:ROHC:DOWNlink:PROFile:UDP[:STATe]
  • CALL:SERVice:PSData:ROHC:DOWNlink:RDDepth

  • CALL:SERVice:PSData:ROHC:TARGet:MODe
  • CALL:SERVice:PSData:ROHC:UPLink:CID:MAXimum
  • CALL:SERVice:PSData:ROHC:UPLink:MODE
  • CALL:SERVice:PSData:ROHC:UPLink:PROFile:ESP[:STATe]
  • CALL:SERVice:PSData:ROHC:UPLink:PROFile:RTP[:STATe]
  • CALL:SERVice:PSData:ROHC:UPLink:PROFile:UDP[:STATe]

  • CALL:SERVice:PSData:RLC:DOWNlink:TRAFfic:TSPRohibit[:VALue]
  • CALL:SERVice:PSData:RLC:DOWNlink:TRAFfic:TSPRohibit:CONTrol:AUTO
  • CALL:SERVice:PSData:RLC:DOWNlink:TRAFfic:WSIZe:CONTrol:AUTO
  • CALL:SERVice:PSData:RLC:DOWNlink:TRAFfic:WSIZe[VALue]
  • CALL:SERVice:PSData:RLC:UPLink:TRAFfic:WSIZe:CONTrol:AUTO
  • CALL:SERVice:PSData:RLC:UPLink:TRAFfic:WSIZe[VALue]

  • CALL:SERVice:PSData:RRC:INITial:STATe

  • CALL:SERVice:PSData:RRC:TRANsition:AUTO
  • CALL:SERVice:PSData:RRC:TRANsition:DCH
  • CALL:SERVice:PSData:RRC:TRANsition:DLData:STATe
  • CALL:SERVice:PSData:RRC:TRANsition:FACH
  • CALL:SERVice:PSData:RRC:TRANsition:IDLE
  • CALL:SERVice:PSData:RRC:TRANsition:ITIMer:DCH[:SVALue]
  • CALL:SERVice:PSData:RRC:TRANsition:ITIMer:DCH:DESTination
  • CALL:SERVice:PSData:RRC:TRANsition:ITIMer:DCH:STATe
  • CALL:SERVice:PSData:RRC:TRANsition:ITIMer:DCH:VALue
  • CALL:SERVice:PSData:RRC:TRANsition:ITIMer:FACH[:SVALue]
  • CALL:SERVice:PSData:RRC:TRANsition:ITIMer:FACH:DESTination
  • CALL:SERVice:PSData:RRC:TRANsition:ITIMer:FACH:STATe
  • CALL:SERVice:PSData:RRC:TRANsition:ITIMer:FACH:VALue
  • CALL:SERVice:PSData:RRC:TRANsition:PCH
  • CALL:SERVice:PSData:RRC:TRANsition:SCRI:FDORmancy[:STATe]
  • CALL:SERVice:PSData:RRC:TRANsition:SCRI:FDORmancy:DCH:DESTination
  • CALL:SERVice:PSData:RRC:TRANsition:SCRI:FDORmancy:FACH:DESTination
  • CALL:SERVice:PSData:RRC:TRANsition:SCRI:RRCIdle[:STATe]
  • CALL:SERVice:PSData:RRC:TRANsition:UPCH
  • CALL:SERVice:PSData:RRC:TRANsition:TVOLume:TRIGger[:STATe]:EVent4A
  • CALL:SERVice:PSData:RRC:TRANsition:TVOLume:TRIGger[:STATe]:EVent4B
  • CALL:SERVice:PSData:RRC:TRANsition:TVOLume:RTHReshold:EVent4A
  • CALL:SERVice:PSData:RRC:TRANsition:TVOLume:RTHReshold:EVent4B
  • CALL:SERVice:PSData:RRC:TRANsition:TVOLume:TTTRigger:EVent4A
  • CALL:SERVice:PSData:RRC:TRANsition:TVOLume:TTTRigger:EVent4B

  • CALL:SERVice:PSData:SRBearer:MAPPing
  • CALL:SERVice:PSData:SRBearer:MAPPing:MODE

  • CALL:SERVice:RBTest:ARMC:CNDomain
  • CALL:SERVice:RBTest:ARMC:LMESsaging
  • CALL:SERVice:RBTest:DTCHannel:CRC[:PRESence]
  • CALL:SERVice:RBTest:RAB
  • CALL:SERVice:RBTest:RRC:STATe

CALL:SERVice:AMR:RAB

Function

Sets/queries the AMR Radio Access Bearer .

This parameter can only be set when call/data status is idle.

Setting

Range:

  • AMR1020 - 10.2k Voice
  • AMR1220 - 12.2k Voice
  • AMR12K - 12.2k Voice
  • AMR475 - 4.75k Voice
  • AMR515 - 5.15k Voice
  • AMR590 - 5.9k Voice
  • AMR670 - 6.7k Voice
  • AMR740 - 7.4k Voice
  • AMR795 - 7.95k Voice
  • AMRSelect - 12.2k Voice, 7.95k Voice, 5.9k Voice, 4.75k Voice
  • WAMR1 - WB 12.65k Voice, 8.85k Voice, 6.6k Voice
  • WAMR2 - WB 15.85k Voice, 2.65k Voice, 8.85k Voice, 6.6k Voice
  • WAMR3 - WB 23.85k Voice, 12.65k Voice, 8.85k Voice, 6.6k Voice
  • WAMR4 - WB AMR SRB5, 12.65k Voice, 8.85k Voice, 6.6k Voice
  • AMR1220P - SRB5 12.2k Voice, 7.95k Voice, 5.9k Voice, 4.75k Voice

Query

 Same as setting
*RST Setting AMR12K
Requirements

Test Application Revision: A.08.20 and above

Lab Application Revision: A.02 and above

Lab Application Revision C.03, added AMR1020|AMR1220|AMR475|AMR515
|AMR590|AMR670|AMR740|AMR795

Lab Application Revision E.00.34, added AMRSelect|WAMR1|WAMR2|WAMR3

Lab Application Revision F.00, added WAMR4|AMR1220P

Programming Example

OUTPUT 714;"CALL:SERVice:AMR:RAB AMR740"
! Sets the AMR voice radio access bearer to 7.4k Voice.

CALL:SERVice:AMR:RAB:DLRate:AMR1220P

Function

Sets/queries the AMR Rate for SRB5 12.2k to 4.75k RAB.

Setting

Range: AMR475|AMR590|AMR795|AMR1220

Query

 Same as setting
*RST Setting AMR1220
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:AMR:RAB:DLRate:AMR1220P AMR1220"

CALL:SERVice:AMR:RAB:DLRate:AMRSelect

Function

Sets/queries the AMR Rate for SRB5 12.2k to 4.75k RAB.

Setting

Range: AMR475|AMR590|AMR795|AMR1220

Query

 Same as setting
*RST Setting AMR1220
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:AMR:RAB:DLRate:AMRSelect AMR1220"

CALL:SERVice:AMR:RAB:DLRate:WAMR1

Function

Sets/queries the AMR Rate for Wideband 12.65k to 6.6k RAB.

Setting

Range: AMR660|AMR885|AMR1265

Query

 Same as setting
*RST Setting AMR1265
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:AMR:RAB:DLRate:WAMR1 AMR1265"

CALL:SERVice:AMR:RAB:DLRate:WAMR2

Function

Sets/queries the AMR Rate for Wideband 15.85k to 6.6k RAB.

Setting

Range: AMR660|AMR885|AMR1265|AMR1220|AMR1585

Query

 Same as setting
*RST Setting AMR1585
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:AMR:RAB:DLRate:WAMR2 AMR1585"

CALL:SERVice:AMR:RAB:DLRate:WAMR3

Function

Sets/queries the AMR Rate for Wideband 23.85k to 6.6k RAB.

Setting

Range: AMR660|AMR885|AMR1265|AMR2385

Query

 Same as setting
*RST Setting AMR2385
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:AMR:RAB:DLRate:WAMR3 AMR2385"

CALL:SERVice:AMR:RAB:DLRate:WAMR4

Function

Sets/queries the AMR Rate for Wideband SRB5 12.65k to 6.6k RAB.

Setting

Range: AMR660|AMR885|AMR1265

Query

 Same as setting
*RST Setting AMR1265
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:AMR:RAB:DLRate:WAMR4 AMR1265"

CALL:SERVice:AMR:RAB:ULSubset:AMR1220P

Function

Sets/queries the pre-defined subset for SRB5 12.2k Voice, 7.95k Voice, 5.9k Voice, 4.75k Voice.

This setting allows you to restrict the uplink rate to a particular Transport Format Combination (TFC) defined for a channel.

Setting

Range: SUB1|SUB2|SUB3|SUB4

Query

 Same as setting
*RST Setting SUB1
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:AMR:RAB:ULSubset:AMR1220P SUB1"
! Sets the subset to SUB1 which contains all rates for the channel.

CALL:SERVice:AMR:RAB:ULSubset:SEND

Function

Sends the Uplink Transport Format Combination (TFC) Subset for the active AMR RAB.

Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:AMR:RAB:ULSubset:SEND"

CALL:SERVice:AMR:RAB:ULSubset:WAMR4

Function

Sets/queries the pre-defined subset for WB AMR SRB5, 12.65k Voice, 8.85k Voice, 6.6k Voice.

This setting allows you to restrict the uplink rate to a particular Transport Format Combination (TFC) defined for a channel.

Setting

Range: SUB1|SUB2|SUB3

Query

 Same as setting
*RST Setting SUB1
Requirements

Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:AMR:RAB:ULSubset:AMR1220P SUB1"
! Sets the subset to SUB1 which contains all rates for the channel.

CALL:SERVice:AMR:SOURce

Function

Sets/queries the AMR Source .

This parameter can only be set when call/data status is idle.

Setting

Range: ECHO|RTVocoder|EXTernal8960|PESQ

Query

 Same as setting
*RST Setting ECHO
Requirements

Lab Application Revision: E.00.13 and above

Lab Application Revision: E.00.34, added EXTernal8960

Lab Application Revision: G.00.00, added PESQ

Programming Example

OUTPUT 714;"CALL:SERVice:AMR:SOURce ECHO"
! Sets the AMR Source to ECHO.

CALL:SERVice:AMR:SPEech:ECHO:LOOPback:DELay

Function

Sets/queries the UTRA FDD Speech Echo Loopback Delay. This parameter determines the amount of time that speech frames received on the uplink are delayed before being retransmitted on the downlink.

This setting is only applicable when CALL:SERVice:AMR:SOURce is set to ECHO.

This setting cannot be changed when the cell operating mode is Active Cell and the call/data status is any state other than IDLE. If you attempt to change this setting when the cell operating mode is Active Cell and the call/data status is not IDLE, the test set will reject the change and an error will be reported.

Setting

Range: 0.1 to 4 seconds

Resolution: 0.02 seconds

Query

 Same as setting
*RST Setting 0.5 seconds
Requirements

Lab Application Revision: E.00.34 and above

Test Application Revision: A.13 and above.

Programming Example

OUTPUT 714;"CALL:SERVice:AMR:SPEech:ECHO:LOOPback:DELay 0.5"
! Sets the UTRA FDD Speech Echo Loopback Delay to 0.5 seconds.

CALL:SERVice:CSData:MODE:ASYNchronous:OUTput

Function

Sets/queries the Async CS Data Source .

Setting

Range: IP|SERIAL

Query

 Same as setting.
*RST Setting | IP
Requirements | Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:SERVice:CSData:MODE:ASYNchronous:OUTput SERIAL"

CALL:SERVice:GPRS:AAReject[:STATe]

Function

Sets/queries the Combined GPRS Attach Forced IMSI Attach Reject State. While the GPRS Attach Forced Reject State is Off and this setting is On, the test set will reject IMSI attach for non-GPRS service of any combined GPRS attach that arrives from the UE.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:SERVice:GPRS:AAReject 0"

CALL:SERVice:GPRS:AAReject:CAUSe

Function

Sets/queries the Combined GPRS Attach Forced IMSI Attach Reject Cause.

This setting will be used to populate the GMM cause field in the GPRS ATTACH ACCEPT message sent from the test set to the UE if the Combined GPRS Attach Forced IMSI Attach Reject State is set to On. The default value is selected to prevent the UE from considering the combined attach procedure as failed for both GPRS and non-GPRS services.

Setting

Range: 0 to 255

Query

Range: 0 to 255

*RST Setting

 17 (Network Failure)
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:SERVice:GPRS:AAReject:CAUSe 17"

CALL:SERVice:GPRS:AREJect[:STATe]

Function

Sets/queries the GPRS Attach Forced Reject State.

While it is On, the test set will reject any GPRS attach request from the UE. A GPRS ATTACH REJECT message will be sent to the UE.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting

0 (Off)
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:SERVice:GPRS:AREJect OFF"

CALL:SERVice:GPRS:AREJect:CAUSe

Function

Sets/queries the GPRS Attach Forced Reject Cause.

This setting will be used to populate the GMM cause field in the GPRS ATTACH ACCEPT message sent from the test set to the UE if GPRS Attach Forced Reject State is set to On.

Setting

Range: 0 to 255

Query

Range: 0 to 255

*RST Setting

 111 (Protocol error, unspecified)
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:SERVice:GPRS:AREJect:CAUSe 111"

CALL:SERVice:GPRS:AIGNore[:STATe]

Function

Sets/queries the Attach Ignore State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (Off)
Requirements

Lab Application Revision: G.00.09 and above.

Programming Example

OUTPUT 714;"CALL:SERVice:GPRS:AIGNore 0"

CALL:SERVice:GPRS:IGNore[:STATe]

Function

Sets/queries the Activate PDP Context Ignore State. When set to On, the test set will ignore any PDP Context Activation Requests that arrive from the UE, and will not send any message back to the UE.

This command and CALL:SERVice:GPRS:REJect[:STATe] can not be set to ON simultaneously.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (Off)
Requirements

Lab Application Revision: G.00.09 and above.

Programming Example

OUTPUT 714;"CALL:SERVice:GPRS:IGNore 0"

CALL:SERVice:GPRS:RAB

Function

Set/queries the GPRS Radio Access Bearer .

Setting

Range:

  • GPRSRAB1: 64k PS
  • GPRSRAB2: 64k UL/384k DL RMC
  • GPRSRAB3: 64k UL/384k DL PS
  • GPRSRAB4: 128k UL/384k DL PS
  • GPRSRAB5: 384k UL/384k DL PS.
  • PSDHsdpa64: 64k UL/HSDPA DL PS
  • PSDHsdpa128: 128k UL/HSDPA DL PS.
  • PSDHsdpa384: 384k UL/HSDPA DL PS.
  • PHSPa: HSUPA UL / HSDPA DL PS + 3.4k SRB on DCH PS Data RAB.

Query

 Same as setting
*RST Setting GPRSRAB1
Requirements

Lab Application Revision: A.01 and above.

Lab Application Revision A.02 added GPRSRAB2.

Lab Application Revision B.01 added GPRSRAB3.

Lab Application Revision D.00 added PSDHsdpa64.

Lab Application Revision D.00.04 added PSDHsdpa128, PSDHsdpa384

Lab Application Revision D.01 added GPRSRAB4 and GPRSRAB5

Lab Application Revisions U.00.13 and E.01.13, added PHSPa

Programming Example

OUTPUT 714;"CALL:SERVice:GPRS:RAB GPRSRAB2"
! Sets the GPRS Radio Access Bearer to 64k RMC UL/384k RMC DL on DPCH.

CALL:SERVice:GPRS:RAUPdate:IGNore[:STATe]

Function

Sets/queries the Routing Area Update Ignore State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0
Requirements

Lab Application Revision: G.00.09 and above.

Programming Example

OUTPUT 714;"CALL:SERVice:GPRS:RAUPdate:IGNore 0"

CALL:SERVice:GPRS:RAUReject[:STATe]

Function

Sets/queries the Routing Area Updating (RAU) Forced Reject State.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:SERVice:GPRS:RAUReject 0"

CALL:SERVice:GPRS:RAUReject:CAUSe

Function

Routing Area Updating (RAU) Forced Reject Cause.

This setting will be used to populate the GMM cause field in the ROUTING AREA UPDATE REJECT message sent from the test set to the UE if the Routing Area Updating (RAU) Forced Reject State is set to On.

Setting

Range: 0 to 255

Query

Range: 0 to 255

*RST Setting

 111 (Protocol error, unspecified)
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:SERVice:GPRS:RAUReject:CAUSe 111"

CALL:SERVice:GPRS:REJect[:STATe]

Function

Sets/queries the Activate PDP Context Reject State. If it is set to On, the test set will reject any PDP Activation Requests that arrive from the UE.

This command and the CALL:SERVice:GPRS:IGNore[:STATe] can not be set to On simultaneously.

Setting

Range: 1|ON|0|OFF

Query

 1|0
*RST Setting | 0 (Off)
Requirements | Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SERVice:GPRS:REJect 0"
! Sets Activate PDP Context Reject State to Off.

CALL:SERVice:GPRS:REJect:CAUSe

Function

Sets/queries the Activate PDP Context Reject SM Cause .

This command is only applicable when CALL:SERVice:GPRS:AREJect:CAUSe is ON.

Setting

Range: 0 to 255.

Query

 Same as setting
*RST Setting | 111
Requirements | Lab Application Revision: C.01 and above

Programming Example

OUTPUT 714;"CALL:SERVice:GPRS:REJect:CAUSe 40"
! Sets Activate PDP Context Reject SM Cause to 40.

CALL:SERVice:PSData:APName[:VALue]

Function

Sets/queries the Access Point Name .

This command is only applicable if Access Point Name State is set to On (see CALL:SERVice:PSData:APName:STATe ).

Setting

Range:

  • O2 - wap.o2.co.uk
  • BT - mobile.bt.uk
  • CINGular - wap.cingular
  • CUSTom - Custom
  • DOComo - i-mode.docomo.ne.jp
  • ORANge - Orangeinternet
  • TMOBile - general.t-mobile.uk
  • VODafone - live.vodafone.com

Query

 Range: O2|BT|CING|CUST|DOC|ORAN|TMOB|VOD
*RST Setting | TMOB
Requirements | Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:APName ORANge"
! Sets Access Point Name to Orangeinternet

CALL:SERVice:PSData:APName:CUSTom

Function

Sets/queries the custom Access Point Name (APN). See Access Point Name Settings .

This command is only applicable if Access Point Name State is set to On (see CALL:SERVice:PSData:APName:STATe ) and Access Point Name State is set to Custom (see CALL:SERVice:PSData:APName[:VALue] ).

Setting

Range: 0 to 99 characters from the set
.-0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz

Query

 Same as setting, but enclosed in double quotes.
*RST Setting | "" (null string)
Requirements | Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:APName:CUSTom 'mobileAnywhere'"
! Sets the custom APN to mobileAnywhere.

CALL:SERVice:PSData:APName:STATe

Function

Sets/queries the Access Point Name State .

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0
*RST Setting | 0 (off)
Requirements | Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:APName:STATe ON"
! Sets Access Point Name State to On.

CALL:SERVice:PSData:HEADer:COMPression[:STATe]

Function

Sets/queries the Header Compression State.

This setting controls whether PDCP Header compression is enabled or not when establish a Packet Switched Data Call.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0
*RST Setting 0 (Off)
Requirements

Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:HEADer:COMPression OFF"

CALL:SERVice:PSData[:QOSProfile[1]]:DORDer

Function

Sets/queries the state of "Delivery order" of IE Negotiated QoS.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0
*RST Setting On
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile1:DORDer Off"
! Sets the "Delivery order" to Off.

CALL:SERVice:PSData:QOSProfile2:DORDer

Function

Sets/queries the state of "Delivery order" of IE Negotiated QoS.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0
*RST Setting | 1 (On)
Requirements | Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile2:DORDer Off"
! Sets the "Delivery order" to Off.

CALL:SERVice:PSData[:QOSProfile[1]]:DOWNlink:BRAte:GUARanteed

Function

Sets/queries the "Guaranteed bit rate for downlink" and "Guaranteed bit rate for downlink (extend)" of IE Negotiated QoS.

Setting
  • 1kbps to 63kbps (Resolution:1kbps)
  • 64kbps to 568kbps (Resolution: 8kbps)
  • 576kbps to 8640kbps (Resolution: 64kbps)
  • 8700kbps to 16000kbps (Resolution: 100kbps)
  • 17Mbps to 128Mbps (Resolution: 1Mbps)
  • 130Mbps to 256Mbps (Resolution: 2Mbps)

Query

 Range: Same as setting
*RST Setting 1kbps
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile1:DOWNLink:BRAte:GUARanteed 8700"
! Sets the "Guaranteed bit rate for downlink" to 8700kbps.

CALL:SERVice:PSData:QOSProfile2:DOWNlink:BRAte:GUARanteed

Function

Sets/queries the "Guaranteed bit rate for downlink" and "Guaranteed bit rate for downlink (extend)" of IE Negotiated QoS.

Setting
  • 1kbps to 63kbps (Resolution:1kbps)
  • 64kbps to 568kbps (Resolution: 8kbps)
  • 576kbps to 8640kbps (Resolution: 64kbps)
  • 8700kbps to 16000kbps (Resolution: 100kbps)
  • 17Mbps to 128Mbps (Resolution: 1Mbps)
  • 130Mbps to 256Mbps (Resolution: 2Mbps)

Query

 Range: Same as setting
*RST Setting | 1 kbps
Requirements | Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile2:DOWNLink:BRAte:GUARanteed 8700"
! Sets the "Guaranteed bit rate for downlink" to 8700kbps.

CALL:SERVice:PSData[:QOSProfile[1]]:DOWNlink:BRAte[:MAXimum]

Function

Sets/queries the "Maximum bit rate for downlink" and "Maximum bit rate for downlink (extend)" of IE Negotiated QoS.

Setting
  • 1kbps to 63kbps (Resolution:1kbps)
  • 64kbps to 568kbps (Resolution: 8kbps)
  • 576kbps to 8640kbps (Resolution: 64kbps)
  • 8700kbps to 16000kbps (Resolution: 100kbps)
  • 17Mbps to 128Mbps (Resolution: 1Mbps)
  • 130Mbps to 256Mbps (Resolution: 2Mbps)

Query

 Range: Same an setting
*RST Setting 64 kbps
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile1:DOWNLink:BRAte:MAXimum 8700"
! Sets the "Maximum bit rate for downlink" to 8700kbps.

CALL:SERVice:PSData:QOSProfile2:DOWNlink:BRAte[:MAXimum]

Function

Sets/queries the "Maximum bit rate for downlink" and "Maximum bit rate for downlink (extend)" of IE Negotiated QoS.

Setting
  • 1kbps to 63kbps (Resolution:1kbps)
  • 64kbps to 568kbps (Resolution: 8kbps)
  • 576kbps to 8640kbps (Resolution: 64kbps)
  • 8700kbps to 16000kbps (Resolution: 100kbps)
  • 17Mbps to 128Mbps (Resolution: 1Mbps)
  • 130Mbps to 256Mbps (Resolution: 2Mbps)

Query

 Range: Same an setting
*RST Setting | 64 kbps
Requirements | Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile2:DOWNLink:BRAte:MAXimum 8700"
! Sets the "Maximum bit rate for downlink" to 8700kbps.

CALL:SERVice:PSData[:QOSProfile[1]]:RBERatio

Function

Sets/queries the "Residual Bit Error Rate" of IE Negotiated QoS.

Setting

Range: R5ENegative2 | R1ENegative2 | R5ENegative3 | R4ENegative3 | R1ENegative3 | R1ENegative4 | R1ENegative5 | R1ENegative6 | R6ENegative8

Query

 Range: Same as setting
*RST Setting R1ENegative4
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile1:RBERatio 5E-2"

CALL:SERVice:PSData:QOSProfile2:RBERatio

Function

Sets/queries the "Residual Bit Error Rate" of IE Negotiated QoS.

Setting

Range: R5ENegative2 | R1ENegative2 | R5ENegative3 | R4ENegative3 | R1ENegative3 | R1ENegative4 | R1ENegative5 | R1ENegative6 | R6ENegative8

Query

 Range: Same as setting
*RST Setting | R1EN4
Requirements | Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile2:RBERatio 5E-2"

CALL:SERVice:PSData[:QOSProfile[1]]:SDU:EDELivery

Function

Sets/queries the "Delivery of erroneous SDUs" of IE Negotiated QoS.

Setting

Range: NDETect| DELivered| NDELivered

NDETect: no detect

DELivered: delivered

NDELivered: not delivered

Query

 Range: Same as setting
*RST Setting NDELivered
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile1:SDU:EDELivery"

CALL:SERVice:PSData:QOSProfile2:SDU:EDELivery

Function

Sets/queries the "Delivery of erroneous SDUs" of IE Negotiated QoS.

Setting

Range: NDETect| DELivered| NDELivered

NDETect: no detect

DELivered: delivered

NDELivered: not delivered

Query

 Range: Same as setting
*RST Setting | NDELivered
Requirements | Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile2:SDU:EDELivery"

CALL:SERVice:PSData[:QOSProfile[1]]:SDU:ERATio

Function

Sets/queries the "SDU error ratio" of IE Negotiated QoS.

Setting

Range: R1ENegative2 | R7ENegative3 | R1ENegative3 | R1ENegative4 | R1ENegative5 | R1ENegative6 | R1ENegative1

Query

 Range: Same as setting
*RST Setting R1ENegative4
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile2:SDU:ERATio 1E-1"

CALL:SERVice:PSData:QOSProfile2:SDU:ERATio

Function

Sets/queries the "SDU error ratio" of IE Negotiated QoS.

Setting

Range: R1ENegative2 | R7ENegative3 | R1ENegative3 | R1ENegative4 | R1ENegative5 | R1ENegative6 | R1ENegative1

Query

 Range: Same as setting
*RST Setting | R1ENegative4
Requirements | Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile2:SDU:ERATio R1ENegative4"

CALL:SERVice:PSData[:QOSProfile[1]]:SDU:SIZE[:MAXImum]

Function

Sets/queries the "Maximum SDU size" of IE Negotiated QoS.

Setting

Range: 10 to 1500 Resolution: 10|

1502| 1510| 1520

Query

 Range: Same as setting
*RST Setting 1500
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile1:SDU:SIZE:MAXImum 1502"
! Sets the "Maximum SDU size" to 1502.

CALL:SERVice:PSData:QOSProfile2:SDU:SIZE[:MAXImum]

Function

Sets/queries the "Maximum SDU size" of IE Negotiated QoS.

Setting

Range: 10 to 1500 (Resolution: 10)| 1502| 1510| 1520

Query

 Range: Same as setting
*RST Setting | 1500
Requirements | Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile2:SDU:SIZE:MAXImum 1502"
! Sets the "Maximum SDU size" to 1502.

CALL:SERVice:PSData[:QOSProfile[1]]:SINDication

Function

Sets the "Signalling Indication" of IE Negotiated QoS.

Setting

Range: OPTimised| NOPTimised
*RST Setting NOPTimised
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile1:SINDication OPTimised"
! Sets the "Signalling Indication" to OPTimised.

CALL:SERVice:PSData:QOSProfile2:SINDication

Function

Sets the "Signalling Indication" of IE Negotiated QoS.

Setting

Range: OPTimised| NOPTimised
*RST Setting | NOPTimised
Requirements | Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile2:SINDication OPTimised"
! Sets the "Signalling Indication" to OPTimised.

CALL:SERVice:PSData[:QOSProfile[1]]:TCLass

Function

Sets/queries the "Traffic Class" of IE Negotiated QoS.

Setting

Range: CONVersation| STReaming| INTeractive| BACKground

Query

 Range: Same as setting
*RST Setting INTeractive
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile1:TCLass CONVersation"
! Sets the "Traffic Class" to CONVersation.

CALL:SERVice:PSData:QOSProfile2:TCLass

Function

Sets/queries the "Traffic Class" of IE Negotiated QoS.

Setting

Range: CONVersation| STReaming| INTeractive| BACKground

Query

 Range: Same as setting
*RST Setting INTeractive
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile2:TCLass CONVersation"
! Sets the "Traffic Class" to CONVersation.

CALL:SERVice:PSData[:QOSProfile[1]]:TDELay

Function

Sets the "Transfer delay" of IE Negotiated QoS.

Setting

Range: 10ms to 150ms (Resolution: 10ms)

200ms to 950ms (Resolution: 50ms)

1000ms to 4000ms (Resolution: 100ms)
*RST Setting | 100ms
Requirements | NDELivered

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile1:TDELay 200
! Sets the "Transfer delay" to 200ms.

CALL:SERVice:PSData:QOSProfile2:TDELay

Function

Sets the "Transfer delay" of IE Negotiated QoS.

Setting

Range: 10ms to 150ms (Resolution: 10ms)

200ms to 950ms (Resolution: 50ms)

1000ms to 4000ms (Resolution: 100ms)
*RST Setting 100 ms
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile2:TDELay 200 ms
! Sets the "Transfer delay" to 200ms.

CALL:SERVice:PSData[:QOSProfile[1]]:THPRiority

Function

Sets the "Traffic handling priority" of IE Negotiated QoS.

Setting

Range: 1| 2| 3
*RST Setting 2
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile1:THPRiority 1
! Sets the "Traffic handling priority" to 1.

CALL:SERVice:PSData:QOSProfile2:THPRiority

Function

Sets the "Traffic handling priority" of IE Negotiated QoS.

Setting

Range: 1| 2| 3
*RST Setting 2
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile2:THPRiority 1"
! Sets the "Traffic handling priority" to 1.

CALL:SERVice:PSData[:QOSProfile[1]]:UPLink:BRAte:GUARanteed

Function

Sets/queries the "Guaranteed bit rate for uplink" and "Guaranteed bit rate for uplink (extend)" of IE Negotiated QoS.

Setting
  • 1kbps to 63kbps (Resolution:1kbps)
  • 64kbps to 568kbps (Resolution: 8kbps)
  • 576kbps to 8640kbps (Resolution: 64kbps)
  • 8700kbps to 16000kbps (Resolution: 100kbps)
  • 17Mbps to 128Mbps (Resolution: 1Mbps)
  • 130Mbps to 256Mbps (Resolution: 2Mbps)

Query

 Range: Same as setting
*RST Setting 1kbps
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile1:UPLink:BRAte:GUARanteed 8700"
! Sets the "Guaranteed bit rate for uplink" to 8700kbps.

CALL:SERVice:PSData:QOSProfile2:UPLink:BRAte:GUARanteed

Function

Sets/queries the "Guaranteed bit rate for uplink" and "Guaranteed bit rate for uplink (extend)" of IE Negotiated QoS.

Setting
  • 1kbps to 63kbps (Resolution:1kbps)
  • 64kbps to 568kbps (Resolution: 8kbps)
  • 576kbps to 8640kbps (Resolution: 64kbps)
  • 8700kbps to 16000kbps (Resolution: 100kbps)
  • 17Mbps to 128Mbps (Resolution: 1Mbps)
  • 130Mbps to 256Mbps (Resolution: 2Mbps)

Query

 Range: Same as setting
*RST Setting 1 kbps
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile2:UPLink:BRAte:GUARanteed 8700"
! Sets the "Guaranteed bit rate for uplink" to 8700kbps.

CALL:SERVice:PSData[:QOSProfile[1]]:UPLink:BRAte[:MAXimum]

Function

Sets/queries the "Maximum bit rate for uplink" and "Maximum bit rate for uplink (extend)" of IE Negotiated QoS.

Setting
  • 1 to 63kbps (Resolution:1kbps)
  • 64kbps to 568kbps (Resolution: 8kbps)
  • 576kbps to 8640kbps (Resolution: 64kbps)
  • 8700kbps to 16000kbps (Resolution: 100kbps)
  • 17Mbps to 128Mbps (Resolution: 1Mbps)
  • 130Mbps to 256Mbps (Resolution: 2Mbps)

Query

 Range: Same as setting
*RST Setting 64
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile1:UPlink:BRAte:MAXimum 8700"
! Sets the "Maximum bit rate for uplink" to 8700kbps.

CALL:SERVice:PSData:QOSProfile2:UPLink:BRAte[:MAXimum]

Function

Sets/queries the "Maximum bit rate for uplink" and "Maximum bit rate for uplink (extend)" of IE Negotiated QoS.

Setting
  • 1kbps to 63kbps (Resolution:1kbps)
  • 64kbps to 568kbps (Resolution: 8kbps)
  • 576kbps to 8640kbps (Resolution: 64kbps)
  • 8700kbps to 16000kbps (Resolution: 100kbps)
  • 17Mbps to 128Mbps (Resolution: 1Mbps)
  • 130Mbps to 256Mbps (Resolution: 2Mbps)

Query

 Range: Same as setting
*RST Setting 64kbps
Requirements

Lab Application Revision: G.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:QOSProfile2:UPlink:BRAte:MAXimum 8700"
! Sets the "Maximum bit rate for uplink" to 8700kbps.

CALL:SERVice:PSData:RAPName[1]|2|3|4|5|6[:VAlue]

Function

Sets/queries the specified (First through Sixth) Rejectable GPRS Access Point Name (APN).

Setting

Range:

  • O2 - wap.o2.co.uk
  • BT - mobile.bt.uk
  • CINGular - wap.cingular
  • CUSTom - Custom
  • DOComo - i-mode.docomo.ne.jp
  • ORANge - Orangeinternet
  • TMOBile - general.t-mobile.uk
  • VODafone - live.vodafone.com

Query

 Range: O2|BT|CING|CUST|DOC|ORAN|TMOB|VOD
*RST Setting | TMOB
Requirements | Lab Application Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RAPName TMOBile"

CALL:SERVice:PSData:RAPName[1]|2|3|4|5|6:CUSTom

Function

Sets/queries the specified (First through Sixth) Rejectable custom Access Point Name (APN).

Setting

Range: 0 to 99 characters from the set
.-0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz

Query

 Same as setting, but enclosed in double quotes.
*RST Setting | "" (null string)
Requirements | Lab Application Revision: F.01 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RAPName:CUSTom 'mobileAnywhere'"
! Sets the first rejectable custom APN to mobileAnywhere.

CALL:SERVice:PSData:RAPName:REJect:CAUSe

Function

Sets/queries the First through Sixth GPRS Service Reject SM Cause.

Setting

A comma separated list of 6 <nr1> values in the range: 0 to 255

Query

A comma separated list of 6 <nr1> values in the range: 0 to 255

*RST Setting

 111 (Protocol error, unspecified), 111 (Protocol error, unspecified), 111 (Protocol error, unspecified), 111 (Protocol error, unspecified), 111 (Protocol error, unspecified), 111 (Protocol error, unspecified)
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RAPName:REJect:CAUSe 111, 111, 111, 111, 111, 111"

CALL:SERVice:PSData:RAPName:STATe

Function

Sets/queries the First through Sixth Rejectable Access Point Name (APN) States.

Setting

A comma separated list of 6 values in the range: 1|ON|0|OFF

Query

 A comma separated list of 6 values in the range: 1|0
*RST Setting 0 (off), 0 (off), 0 (off), 0 (off), 0 (off), 0 (off)
Requirements

Lab Application Revision: F.01 and above.

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RAPName:STATe OFF, OFF, OFF, OFF, OFF, OFF"

CALL:SERVice:PSData:ROHC:DOWNlink:CID:MAXimum

Function

 Sets/queries the Downlink ROHC Max CID. This setting is used to configure the UE during a PS Data call when CALL:SERVice:PSData:HEADer:COMPression[:STATe] is On.

Setting

Range: 1 to 16383

Query

 Same as setting
*RST Setting 15
Requirements

Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:ROHC:DOWNlink:CID:MAXimum 15"
! Sets Downlink ROHC Max CID to 15.

CALL:SERVice:PSData:ROHC:DOWNlink:PROFile:ESP[:STATe]

Function

Sets/queries the Downlink ROHC ESP Profile State. This setting controls whether the ESP profile is used in the downlink by the test set when CALL:SERVice:PSData:HEADer:COMPression[:STATe] is On.

  • When set to "On", the test set includes the ESP profile (0x0003) to compress the downlink data.
  • When set to "Off", the test set does not include the ESP profile for downlink data compression.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0
*RST Setting | 0 (off)
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:ROHC:DOWNlink:PROFile:ESP OFF"
! Sets Downlink ROHC ESP Profile State to Off.

CALL:SERVice:PSData:ROHC:DOWNlink:PROFile:RTP[:STATe]

Function

Sets/queries the Downlink ROHC RTP Profile State. This setting controls whether the RTP profile is used in the downlink by the test set when CALL:SERVice:PSData:HEADer:COMPression[:STATe] is On.

  • When set to "On", the test set includes the RTP profile (0x0001) to compress the downlink data.
  • When set to "Off", the test set does not include the RTP profile for downlink data compression.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0
*RST Setting | 1 (on)
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:ROHC:DOWNlink:PROFile:RTP ON"
! Sets Downlink ROHC RTP Profile State to On.

CALL:SERVice:PSData:ROHC:DOWNlink:PROFile:UDP[:STATe]

Function

Sets/queries the Downlink ROHC UDP Profile State. This setting controls whether the UDP profile is used in the downlink by the test set when CALL:SERVice:PSData:HEADer:COMPression[:STATe] is On.

  • When set to "On", the test set includes the UDP profile (0x0002) to compress the downlink data.
  • When set to "Off", the test set does not include the UDP profile for the downlink data compression.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0
*RST Setting | 0 (off)
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:ROHC:DOWNlink:PROFile:UDP OFF"
! Sets Downlink ROHC UDP Profile State to On.

CALL:SERVice:PSData:ROHC:DOWNlink:RDDepth

Function

 Sets/queries the Downlink Reverse Decompression Depth. This setting is used to configure the UE during a PS Data call when CALL:SERVice:PSData:HEADer:COMPression[:STATe] is On. A setting of 0 means that the reverse decompression function is disabled.

Setting

Range: 0 to 65535

Query

 Same as setting
*RST Setting 0
Requirements

Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:ROHC:DOWNlink:RDDepth 0"
! Disables the reverse decompression function.

CALL:SERVice:PSData:ROHC:TARGet:MODe

Function

Sets/queries the PDCP ROHC Target Mode. This setting is used to determine if the "PDCP ROHC Target Mode" IE will be included in the L3 signalling message.

Setting

Range:

ABSent: The test set does not include "PDCP ROHC Target Mode" IE in L3 signalling message and there is no restriction of the UE's decompressor mode transition.

OMODe: The UE's decompressor is only allowed to transition to O-mode.

RMODe: The UE's decompressor is only allowed to transition to O-mode.

Query

Range: ABS|OMOD|RMOD
*RST Setting | ABSent
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:ROHC:TARGet:MODe ABSent"
! Sets test set to include PDCP ROHC Target Mode IE in L3 signalling message.

CALL:SERVice:PSData:ROHC:UPLink:CID:MAXimum

Function

 Sets/queries the Uplink ROHC Max CID. This setting is used to configure the UE during a PS Data call when CALL:SERVice:PSData:HEADer:COMPression[:STATe] is On.

Setting

Range: 1 to 16383

Query

 Same as setting
*RST Setting | 15
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:ROHC:UPLink:CID:MAXimum 15"
! Sets Uplink ROHC Max CID to 15.

CALL:SERVice:PSData:ROHC:UPLink:MODE

Function

Sets/queries the Uplink ROHC Mode. This setting controls the preferred ROHC mode that is to be used in the test set decompressor (and UE compressor). The test set decompressor will try to switch to this mode after ROHC context is established between test set and UE.

Setting

 Range: UMODe|OMODe|RMODe

Query

 Range: UMOD|OMOD|RMOD
*RST Setting | OMODe
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:ROHC:UPLink:MODE OMODe"
! Sets HSPA PS Data SRB Mapping Mode to UL/DL DCH.

CALL:SERVice:PSData:ROHC:UPLink:PROFile:ESP[:STATe]

Function

Sets/queries the Uplink ROHC ESP Profile State. This setting controls whether the UDP/IP profile is configured to allow the UE to use the uplink when CALL:SERVice:PSData:HEADer:COMPression[:STATe] is On.

  • When set to "On", the test set includes the UDP profile (0x0002) in the "PDCP Info" IE for theL3 signalling message. This allows the UE to use the UDP profile to compress data in the uplink.

  • When set to "Off", the test set does not include the UDP profile in the "PDCP Info"IE for the L3 signalling message and the UDP profile is not allowed to be used by the UE.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0
*RST Setting | 0 (off)
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:ROHC:UPLink:PROFile:ESP OFF"
! Sets Uplink ROHC ESP Profile State to Off.

CALL:SERVice:PSData:ROHC:UPLink:PROFile:RTP[:STATe]

Function

Sets/queries the Uplink ROHC RTP Profile State. This setting controls whether the RTP/UDP/IP profile is configured for the UE to use in the uplink when CALL:SERVice:PSData:HEADer:COMPression[:STATe] is On.

  • When set to "On", the test set includes the RTP profile (0x0001) in the "PDCP Info" IE for the L3 signalling message. This allows the UE to use the RTP profile to compress data in the uplink.
  • When set to "Off", the test set does not include the RTP profile in the "PDCP Info" IE in the L3 signalling message and the UE is not allowed to use the RTP profile in the uplink.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0
*RST Setting | 1 (on)
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:ROHC:UPLink:PROFile:RTP ON"
! Sets Uplink ROHC RTP Profile State to On.

CALL:SERVice:PSData:ROHC:UPLink:PROFile:UDP[:STATe]

Function

Sets/queries the Uplink ROHC UDP Profile State. This setting controls whether the UDP/IP profile is configured for the UE to use in the uplink when CALL:SERVice:PSData:HEADer:COMPression[:STATe] is On.

  • When set to On, the test set includes the UDP profile (0x0002) in the "PDCP Info" IE for the L3 signalling message. This allows the UE to use the UDP profile to compress data in the uplink.
  • When set to Off, the test set does not include the UDP profile in the "PDCP Info" IE for the L3 signalling message and the UDP profile is not allowed to be used by the UE.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0
*RST Setting | 0 (off)
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:ROHC:UPLink:PROFile:UDP OFF"
! Sets Uplink ROHC UDP Profile State to Off.

CALL:SERVice:PSData:RLC:DOWNlink:TRAFfic:TSPRohibit[:VALue]

Function

Sets/queries the Downlink RLC Status Prohibit Timer value. This setting is used when the Status Prohibit timer control is set to Manual.

Setting

Range:

  • 10 to 550 in increments of 10
  • 600 to 1000 in increments of 50

Query

Range: Same as setting
*RST Setting | 40
Requirements | Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RLC:DOWNlink:TRAFfic:TSPRohibit 40"
! Sets the Downlink RLC Status Prohibit Timer value to 40.

CALL:SERVice:PSData:RLC:DOWNlink:TRAFfic:TSPRohibit:CONTrol:AUTO

Function

Sets/queries the Downlink RLC Status Prohibit Timer State.

Setting

Range: 1|0

Query

 Range: 1|0
*RST Setting | 1 (auto)
Requirements | Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RLC:DOWNlink:TRAFfic:TSPRohibit:CONTrol:AUTO 1"
! Sets the Downlink RLC Status Prohibit Timer State to Auto.

CALL:SERVice:PSData:RLC:DOWNlink:TRAFfic:WSIZe:CONTrol:AUTO

Function

Sets/queries the Downlink RLC Window Size State.

Setting

Range: 1|0

Query

Range: 1|0

*RST Setting

1 (auto)

Requirements

Lab Application Revision F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RLC:DOWNlink:TRAFfic:WSIZe:CONTrol:AUTO ON"
! Sets the Downlink RLC Window Size State to Auto.

CALL:SERVice:PSData:RLC:DOWNlink:TRAFfic:WSIZe[VALue]

Function

Sets/queries the Downlink RLC Window Size.

Setting

Range: SIZE1|SIZE8|SIZE16|SIZE32|SIZE64|SIZE128|SIZE256|SIZE512|SIZE1024|SIZE1536
|SIZE2047|SIZE2560|SIZE3072|SIZE3584|SIZE4095

Query

Range: Same as setting
*RST Setting | SIZE2047
Requirements | Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RLC:DOWNlink:TRAFfic:WSIZe SIZE2047"
! Sets the Downlink RLC Window Size to 2047.

CALL:SERVice:PSData:RLC:UPLink:TRAFfic:WSIZe:CONTrol:AUTO

Function

Sets/queries the Uplink RLC Window Size State.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (auto)

Requirements

Lab Application Revision F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RLC:UPLink:TRAFfic:WSIZe:CONTrol:AUTO ON"
! Sets the Uplink RLC Window Size State to Auto.

CALL:SERVice:PSData:RLC:UPLink:TRAFfic:WSIZe[VALue]

Function

Sets/queries the Uplink RLC Window Size.

Setting

Range: SIZE1|SIZE8|SIZE16|SIZE32|SIZE64|SIZE128|SIZE256|SIZE512|SIZE1024|SIZE1536
|SIZE2047|SIZE2560|SIZE3072|SIZE3584|SIZE4095

Query

Range: Same as setting
*RST Setting | SIZE2047
Requirements | Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RLC:UPLink:TRAFfic:WSIZe SIZE2047"
! Sets the Uplink RLC Window Size to 2047.

CALL:SERVice:PSData:RRC:INITial:STATe

Function

Sets/queries Initial PS Data RRC State .

Setting

Range: DCH |FACH

Query

Range: DCH |FACH
*RST Setting | DCH
Requirements | Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:INITial:STATe DCH"
! Sets the UE to be assigned to CELL_DCH.

CALL:SERVice:PSData:RRC:TRANsition:AUTO

Function

Sets/queries Automatic RRC State Transition Control State.

This setting controls whether the automatic RRC state transitions are enabled or not (including the transition based on downlink IP data). This setting cannot be changed while a PDP Context is Active.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:AUTO ON"
! Sets the Automatic RRC State Transition Control State to On.

CALL:SERVice:PSData:RRC:TRANsition:DCH

Function

If the UE is on a PDP Context in CELL_DCH state then this causes the test set to transition the UE to CELL_FACH.
Requirements Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:DCH"

CALL:SERVice:PSData:RRC:TRANsition:DLData:STATe

Function

Sets/queries the Automatic Transitions On DL IP Data State.

This setting controls if IP data arriving for the UE while it is in Idle will cause a transition to CELL_FACH/ CELL_DCH. if automatic transitions are On.When triggered, the UE will be transitioned to the RRC state indicated in the "Initial PS Data RRC State" setting if it is in Idle.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:DLData:STATe OFF"
! Sets the Automatic Transitions On DL IP Data State to off.

CALL:SERVice:PSData:RRC:TRANsition:FACH

Function

If the UE is on a PDP Context in CELL_DCH state then this causes the test set to transition the UE to CELL_FACH.
Requirements Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:FACH"

CALL:SERVice:PSData:RRC:TRANsition:IDLE

Function

If the UE is on a PDP Context in CELL_DCH or CELL_FACH state then this causes the application to transition the UE to RRC_Idle.
Requirements Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:IDLE"

CALL:SERVice:PSData:RRC:TRANsition:ITIMer:DCH[:SVALue]

Function

Sets/queries the CELL_DCH Inactivity Timer Length, and sets its state to ON.

This setting controls the transactions that are triggered from the CELL_DCH state to RRC state selected in the "CELL_DCH Inactivity Timer Destination RRC State" setting where no RLC PDUs have been received or transmitted for the specified amount of time.

Setting

Range: 0.1 increments (num seconds)

Query

Range: 0.1 increments (num seconds)

*RST Setting

5 s

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:ITIMer:DCH 5s"
!Sets the CELL_DCH Inactivity Timer Length to 5 seconds and turns it on.

CALL:SERVice:PSData:RRC:TRANsition:ITIMer:DCH:DESTination

Function

Sets/queries the CELL_DCH Inactivity Timer Destination RRC State.

This setting controls the destination state when the transaction is triggered from CELL_DCH state where no RLC PDUs have been received or transmitted for the specified amount of time. This setting can be changed while a PDP context is active.

Setting

Range: FACH|IDLE

Query

Range: FACH|IDLE

*RST Setting

FACH

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:ITIMer:DCH:DESTination FACH"
! Sets the CELL_DCH Inactivity Timer Destination RRC State to CELL_FACH.

CALL:SERVice:PSData:RRC:TRANsition:ITIMer:DCH:STATe

Function

Sets/queries the CELL_DCH Inactivity Timer State.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:ITIMer:DCH:STATe OFF"
! Sets the CELL_DCH Inactivity Timer State to Off.

CALL:SERVice:PSData:RRC:TRANsition:ITIMer:DCH:VALue

Function

Sets/queries the CELL_DCH Inactivity Timer Length.

This setting controls the transactions that are triggered from the CELL_DCH state to RRC state selected in the "CELL_DCH Inactivity Timer Destination RRC State" setting where no RLC PDUs have been received or transmitted for the specified amount of time.

Setting

Range: 0.1 increments (num seconds)

Query

Range: 0.1 increments (num seconds)

*RST Setting

 5 s

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:NITZone:DSTIme:VALue 0"
!Sets the Daylight Saving Time value to 0 hours.

CALL:SERVice:PSData:RRC:TRANsition:ITIMer:FACH[:SVALue]

Function

Sets/queries the CELL_FACH Inactivity Timer Length, and sets its state to ON.

This setting controls the transaction that is triggered from the CELL_FACH state to the RRC state selected in the "CELL_FACH Inactivity Timer Destination RRC State" setting where no RLC PDUs have been received or transmitted for the specified amount of time.

This setting can be changed while a PDP context is active.

Setting

Range: 0.1 increments (num seconds)

Query

Range: 0.1 increments (num seconds)

*RST Setting

15 s

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:ITIMer:FACH 15s"
!Sets the CELL_FACH Inactivity Timer Length to 15 seconds and turns it on.

CALL:SERVice:PSData:RRC:TRANsition:ITIMer:FACH:DESTination

Function

Sets/queries the CELL_FACH Inactivity Timer Destination RRC State.

This setting controls the destination state when the transaction is triggered from CELL_FACH state where no RLC PDUs have been received or transmitted for the specified amount of time.

This setting can be changed while a PDP context is active.

Setting

Range: DCH|PCH|UPCH|IDLE

Query

Range: DCH|PCH|UPCH|IDLE

*RST Setting

IDLE

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:ITIMer:FACH:DESTination IDLE"
! Sets the CELL_FACH Inactivity Timer Destination RRC State to Idle.

CALL:SERVice:PSData:RRC:TRANsition:ITIMer:FACH:STATe

Function

 Sets/queries the CELL_FACH Inactivity Timer Length State.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:ITIMer:FACH:STATe OFF"
! Sets the CELL_FACH Inactivity Timer Length State to off.

CALL:SERVice:PSData:RRC:TRANsition:ITIMer:FACH:VALue

Function

Sets/queries .the CELL_FACH Inactivity Timer Length.

This setting controls the transaction that is triggered from the CELL_FACH state to the RRC state selected in the "CELL_FACH Inactivity Timer Destination RRC State" setting where no RLC PDUs have been received or transmitted for the specified amount of time.

This setting can be changed while a PDP context is active.

Setting

Range: 0.1 increments (num seconds)

Query

Range: 0.1 increments (num seconds)

*RST Setting

15 s

Requirements

 Lab Application Revision: F.00.19 and above

Programming Example

OUTPUT 714;"CCALL:SERVice:PSData:RRC:TRANsition:ITIMer:FACH:VALue 15s"
!Sets the CELL_FACH Inactivity Timer Length to 15 seconds.

CALL:SERVice:PSData:RRC:TRANsition:PCH

Function

If the UE is on a PDP Context in CELL_FACH state then this causes the test set to transition the UE to CELL_PCH.
Requirements Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:PCH"

CALL:SERVice:PSData:RRC:TRANsition:SCRI:FDORmancy[:STATe]

Function

Sets/queries the SCRI With Fast Dormancy State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

 Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:SCRI:FDORmancy OFF"

CALL:SERVice:PSData:RRC:TRANsition:SCRI:FDORmancy:DCH:DESTination

Function

Sets/queries the Fast Dormancy Dest RRC State for CELL_DCH .

Setting

Range: FACH| IDLE

Query

Range: FACH| IDLE

*RST Setting

 FACH

Requirements

 Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:SCRI:FDORmancy:DCH:DESTination FACH"

CALL:SERVice:PSData:RRC:TRANsition:SCRI:FDORmancy:FACH:DESTination

Function

Sets/queries the Fast Dormancy Dest RRC State for CELL_FACH .

Setting

Range: PCH| UPCH| IDLE

Query

Range: PCH| UPCH| IDLE

*RST Setting

 PCH

Requirements

 Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:SCRI:FDORmancy:FACH:DESTination PCH"

CALL:SERVice:PSData:RRC:TRANsition:SCRI:RRCIdle[:STATe]

Function

Sets/queries the RRC Idle With SCRI State.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

 Lab Application Revision: G.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:SCRI:RRCIdle OFF"
! Sets the RRC Idle With SCRI State.

CALL:SERVice:PSData:RRC:TRANsition:UPCH

Function

If the UE is on a PDP Context in CELL_FACH state then this causes the test set to transition the UE to URA_PCH.
Requirements Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:UPCH"

CALL:SERVice:PSData:RRC:TRANsition:TVOLume:TRIGger[:STATe]:EVent4A

Function

Sets/queries the UE Event 4A Trigger State. This setting controls the configuration of the Event 4A measurements in the UE that are enabled at PDP Context establishment if automatic transitions are On.

If both Automatic RRC State Transitions and this setting is set to On , then Event 4A measurements are configured in the UE at call setup.

When the test set receives the Measurement Report that Event 4A has occurred, the UE will be transitioned to CELL_DCH if it is in CELL_FACH. If UE is in any other state other than CELL_FACH, the report will be ignored.

Setting

Range:

1|ON|0|OFF

Query

Range: 1|0
*RST Setting 1|ON
Requirements Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:TVOLume:TRIGger:EVent4A On"

CALL:SERVice:PSData:RRC:TRANsition:TVOLume:TRIGger[:STATe]:EVent4B

Function

Sets/queries the UE Event 4B Trigger State.

This setting controls the configuration of the Event 4A measurements in the UE that are enabled at PDP Context establishment if automatic transitions are On .

If both Automatic RRC State Transitions and this setting is set to On , then Event 4B measurements are configured in the UE at call setup.

When the network receives the Measurement Report that Event 4B has occurred, the UE will be transitioned to CELL_FACH if it is in CELL_DCH. If UE is in any other state other than CELL_DCH, the report will be ignored.

Setting

Range:

1|ON|0|OFF

Query

Range: 1|0
*RST Setting 1|ON
Requirements Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:TVOLume:TRIGger:EVent4B On"

CALL:SERVice:PSData:RRC:TRANsition:TVOLume:RTHReshold:EVent4A

Function

Sets/queries the UE Event 4A Buffer Data Threshold.

This setting controls the configuration of the Event 4A measurements in the UE that are enabled at PDP Context establishment if automatic transitions are On and UE Event 4A State is On.

Setting

Range: BYTes8 | BYTes16 | BYTes32 | BYTes64 | BYTes128 | BYTes256 | BYTes512 | BYTes1024 | KBYTes2 | KBYTes3 | KBYTes4 | KBYTes6 | KBYTes8 | KBYTes12 | KBYTes16 | KBYTes24 | KBYTes32 | KBYTes48 | KBYTes96 | KBYTes128 | KBYTes192 | KBYTes256 | KBYTes384 | KBYTes512 | KBYTes768

Query

Same as setting
*RST Setting BYTes1024
Requirements Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:TVOLume:RTHReshold:EVent4A BYTes1024"

CALL:SERVice:PSData:RRC:TRANsition:TVOLume:RTHReshold:EVent4B

Function

Sets/queries the UE Event 4B Buffer Data Threshold.

This setting controls the configuration of the Event 4B measurements in the UE that are enabled at PDP Context establishment if automatic transitions are On and UE Event 4B State is On.

Setting

Range: BYTes8 | BYTes16 | BYTes32 | BYTes64 | BYTes128 | BYTes256 | BYTes512 | BYTes1024 | KBYTes2 | KBYTes3 | KBYTes4 | KBYTes6 | KBYTes8 | KBYTes12 | KBYTes16 | KBYTes24 | KBYTes32 | KBYTes48 | KBYTes96 | KBYTes128 | KBYTes192 | KBYTes256 | KBYTes384 | KBYTes512 | KBYTes768

Query

Same as setting
*RST Setting BYTes64
Requirements Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:TVOLume:RTHReshold:EVent4B BYTes64"

CALL:SERVice:PSData:RRC:TRANsition:TVOLume:TTTRigger:EVent4A

Function

Sets/queries the UE Event 4A Time to Trigger.

This setting controls the configuration of the Event 4A measurements in the UE that are enabled at PDP Context establishment if automatic transitions are On and UE Event 4A State is On.

Setting

Range: MS0 | MS10 | MS20 | MS40 | MS60 | MS80 | MS100 | MS120 | MS160 | MS200 |MS240 | MS320 | MS640 | MS1280 | MS2560 | MS5000

Query

Same as setting
*RST Setting MS1280
Requirements Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:TVOLume:TTTRigger:EVent4A MS1280"

CALL:SERVice:PSData:RRC:TRANsition:TVOLume:TTTRigger:EVent4B

Function

Sets/queries the UE Event 4B Time to Trigger.

This setting controls the configuration of the Event 4B measurements in the UE that are enabled at PDP Context establishment if automatic transitions are On and UE Event 4B State is On.

Setting

Range: MS0 | MS10 | MS20 | MS40 | MS60 | MS80 | MS100 | MS120 | MS160 | MS200 |MS240 | MS320 | MS640 | MS1280 | MS2560 | MS5000

Query

Same as setting
*RST Setting MS5000
Requirements Test Application Revision: A.19.00 and above, with the required feature license
Lab Application Revision H.01.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:RRC:TRANsition:TVOLume:TTTRigger:EVent4B MS5000"

CALL:SERVice:PSData:SRBearer:MAPPing

Function

Sets/queries the HSPA PS Data SRB Mapping Mode when CALL:SERVice:GPRS:RAB is set to PHSPa (HSUPA UL/HSDPA DL PS).

Setting

Range:

UDDDch: SRB is mapped onto UL/DL DCH (DPDCH/DPDCH in physical layer over air interface)

UEDDch: SRB is mapped onto UL E-DCH/DL DCH (EDPDCH/DPDCH in physical layer over air interface)

UEDHsdsch: SRB is mapped onto UL E-DCH/DL HSDSCH with DL FDPCH configured (EDPDCH/HSPDSCH in physical layer over air interface)

Query

Range: UDDD|UEDD|UEDH
*RST Setting | UDDDch
Requirements | Lab Application Revision: F.00 and above

Programming Example

OUTPUT 714;"CALL:SERVice:PSData:SRBearer:MAPPing UDDDch"
! Sets HSPA PS Data SRB Mapping Mode to UL/DL DCH.

CALL:SERVice:PSData:SRBearer:MAPPing:MODE

Function

THIS COMMAND IS OBSOLETE. Please use the command CALL:SERVice:PSData:SRBearer:MAPPing instead.Sets/queries the HSPA PS Data SRB Mapping Mode when CALL:SERVice:GPRS:RAB is set to PHSPa (HSUPA UL/HSDPA DL PS).

Setting

Range:

DCHDch: SRB is mapped onto UL/DL DCH (DPDCH/DPDCH in physical layer over air interface)

EDCHDch: SRB is mapped onto UL E-DCH/DL DCH (EDPDCH/DPDCH in physical layer over air interface)

Query

Range: DCHD|EDCHD
*RST Setting DCHDch
Requirements

Lab Application Revision: E.00.34 and above

Lab Application Revision: F.00 and above, command Obsolete

Programming Example

OUTPUT 714;"CCALL:SERVice:PSData:SRBearer:MAPPing:MODE DCHDch"
! Sets HSPA PS Data SRB Mapping Mode to UL/DL DCH.

CALL:SERVice:RBTest:ARMC:CNDomain

Function

Sets/queries the Asymmetric RMC CN Domain. This parameter controls whether the domain used is Circuit Switched (CS) or Packet Switched (PS) during an asymmetric reference measurement channels (RMC) call setup.This parameter does not affect the call setup procedure of symmetric RMCs.

This setting can only be changed while call status is idle.

Setting

Range: CSDomain|PSDomain

Query

Range: CSD|PSD
*RST Setting CSD
Requirements

Lab Application Revision: E.00.34 and above

Programming Example

OUTPUT 714;"CALL:SERVice:RBTest:ARMC:CNDomain CSDomain"
! Sets the Asymmetric RMC CN Domain to circuit switched.

CALL:SERVice:RBTest:ARMC:LMESsaging

Function

Sets/queries the Asymmetric RMC Loopback Messaging .

This setting can only be changed while call status is idle.

Setting

Range:

  • COPen - Close/Open
  • NONE

Query

 Range: COP|NONE
*RST Setting COP
Requirements

Test Application Revision: A.08.20 and above

Lab Application Revision: C.03 and above

Programming Example

OUTPUT 714;"CALL:SERVice:RBTest:ARMC:LMESsaging NONE"
! Sets Asymmetric RMC Loopback Messaging to None.

CALL:SERVice:RBTest:DTCHannel:CRC[:PRESence]

Function

Sets/queries the Uplink DTCH RMC CRC Presence .

Setting

Range:

  • PRESent
  • DATa: (Used for Data)

Query

 Range: PRES|DAT
*RST Setting PRES
Requirements

Test Application Revision: A.05 and above

Test Application Revision: A.06 and above, :PRESence is optional

Lab Application Revision: B.01 and above

Lab Application Revision: C.01 and above, :PRESence is optional

Programming Example

OUTPUT 714;"CALL:SERVice:RBTest:DTCHannel:CRC DATa"
! Sets the Uplink DTCH RMC CRC Presence to Used for Data.

CALL:SERVice:RBTest:RAB

Function

Sets/queries the Channel Type .

Setting

Range:

  • HSDParmc12 (12.2k RMC + HSDPA) ( only applicable to the lab application or feature-licensed test application )
  • HSParmc12 (12.2k RMC + HSPA ( only applicable to the feature-licensed test application )
  • HSPA ( only applicable to the feature-licensed test application )
  • RMC12 (12.2k RMC)
  • RMC64 (64k RMC)
  • RMC144 (144k RMC)
  • RMC384 (384k RMC)
  • RMC33NC (33k No Coding RMC)
  • RMCAM1264 (12.2k UL/64k DL AM RMC) (active cell operating mode only)
  • RMCAM12144 (12.2k UL/144k DL AM RMC) (active cell operating mode only)
  • RMCAM12384 (12.2k UL/384k DL AM RMC) (active cell operating mode only)
  • RMCAM64384 (64k UL/384k DL AM RMC) (active cell operating mode only)

Query

Range:

  • HSDP12 (12.2k RMC + HSDPA) ( only applicable to the lab application or feature-licensed test application )
  • HSP12 (12.2k RMC + HSPA) ( only applicable to the feature-licensed test application )
  • HSPA ( only applicable to the feature-licensed test application )
  • RMC12 (12.2k RMC)
  • RMC64 (64k RMC)
  • RMC144 (144k RMC)
  • RMC384 (384k RMC)
  • RMC33NC (33k No Coding RMC)
  • RMCAM1264 (12.2k UL/64k DL AM RMC) (active cell operating mode only)
  • RMCAM12144 (12.2k UL/144k DL AM RMC) (active cell operating mode only)
  • RMCAM12384 (12.2k UL/384k DL AM RMC) (active cell operating mode only)
  • RMCAM64384 (64k UL/384k DL AM RMC) (active cell operating mode only)
*RST Setting RMC12
Requirements

Test Application Revision: A.05 and above

Test Application Revision A.06 added
RMCAM1264|RMCAM12144|RMCAM12384|RMCAM64384.

Test Application Revision A.08 with the required feature license

Test Application Revision A.08.20 with the required feature license, HSDParmc12 is available in active cell operating mode (previously it was only available in FDD test operating mode)

Test Application Revision A.12 with the required feature license and Lab Application Revision E.00.16, added HSParmc12.

Lab Application Revision: B.01 and above

Lab Application Revision C.01 added RMCAM1264|RMCAM12144|RMCAM12384|RMCAM64384

Lab Application Revision C.03, added HSDParmc12

Programming Example

OUTPUT 714;"CALL:SERVice:RBTest:RAB RMC64"
! Sets channel type to 64k RMC.

CALL:SERVice:RBTest:RRC:STATe

Function

Sets/queries the RB Test Mode RRC State Setting .

Setting

Range: DCH|FACH

Query

 Same as setting
*RST Setting DCH
Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:SERVice:RBTest:RRC:STATe FACH"


CALL:SHANdoff

CALL:SHANdoff

Last updated: January 16, 2009

This section is only applicable to the lab application.

GPIB Command Conventions

  • CALL:SHANdoff:ENABle

  • CALL:SHANdoff:EVENt:ENABle
  • CALL:SHANdoff:EVENt:SEND:CONFig

  • CALL:SHANdoff:EVent1A:STATe
  • CALL:SHANdoff:EVent1A:REPorting:RANGe
  • CALL:SHANdoff:EVent1A:HYSTeresis
  • CALL:SHANdoff:EVent1A:WVALue
  • CALL:SHANdoff:EVent1B:STATe
  • CALL:SHANdoff:EVent1B:REPorting:RANGe
  • CALL:SHANdoff:EVent1B:HYSTeresis
  • CALL:SHANdoff:EVent1B:WVALue
  • CALL:SHANdoff:EVent1C:STATe
  • CALL:SHANdoff:EVent1C:HYSTeresis
  • CALL:SHANdoff:EVent1D:STATe
  • CALL:SHANdoff:EVent1D:HYSTeresis
  • CALL:SHANdoff:EVent1E:STATe
  • CALL:SHANdoff:EVent1E:HYSTeresis
  • CALL:SHANdoff:EVent1E:THREshold
  • CALL:SHANdoff:EVent1F:STATe
  • CALL:SHANdoff:EVent1F:HYSTeresis
  • CALL:SHANdoff:EVent1F:THREshold

CALL:SHANdoff:ENABle

Function

Turns Soft Handover On or Off. (See Enabling Soft Handover )

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

 OFF

Programming Example

OUTPUT 714;"CALL:SHANdoff:ENABle ON"
!Turns Soft Handover ON.

CALL:SHANdoff:EVENt:ENABle

Function

Turns Event State On or Off (enables/disables event reporting). (See Event Reporting )

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

 OFF

Programming Example

OUTPUT 714;"CALL:SHANdoff:EVENt:ENABle ON"
!Turns Event State ON.

CALL:SHANdoff:EVENt:SEND:CONFig

Function

Sends a Measurement Control message. You must send this command after configuring an event parameter (CALL:SHANdoff:EVent1A - 1F commands) for the new event parameter value to be implemented by the UE. (See Event Reporting ).

Programming Example

OUTPUT 714;"CALL:SHANdoff:EVENt:SEND:CONFig"
!Sends a Measurement Control message.

CALL:SHANdoff:EVent1A:STATe

Function

Controls the UTRA FDD Event 1a ON/OFF State. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

It is recommended that you set CALL:SHANdoff:EVENt:ENABle to OFF before changing this setting. You must then turn CALL:SHANdoff:EVENt:ENABle back ON to enable event reporting.

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

 ON

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1A:STATe ON"
!Turns the Event 1a State ON.

CALL:SHANdoff:EVent1A:REPorting:RANGe

Function

Controls the UTRA FDD Event 1a Reporting Range Constant. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

Setting

Range: 0.0 to 14.5 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 0.0 dB
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 14.5 dB

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1A:REPorting:RANGe 3"
!Sets the UTRA FDD Event 1a Reporting Range Constant to 3 dB.

CALL:SHANdoff:EVent1A:HYSTeresis

Function

Controls the UTRA FDD Event 1a Hysteresis. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

Setting

Range: 0.0 dB to 7.5 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 1.5 dB
Requirements Lab Application Revision: C.01 and above, new range 0 to 7.5 dB

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1A:HYSTeresis 4"
!Sets the UTRA FDD Event 1a Hysteresis to 4 dB.

CALL:SHANdoff:EVent1A:WVALue

Function

Controls the UTRA FDD Event 1a "W" Value. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

Setting

Range: 0.0 to 2.0

Resolution: 0.1

Query

 Same as setting

*RST Setting

 0.0
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 2.0

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1A:WVALue 0.5"
!Sets the UTRA FDD Event 1a "W" Value to 0.5.

CALL:SHANdoff:EVent1B:STATe

Function

Controls the UTRA FDD Event 1b ON/OFF State. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

It is recommended that you set CALL:SHANdoff:EVENt:ENABle to OFF before changing this setting. You must then turn CALL:SHANdoff:EVENt:ENABle back ON to enable event reporting.

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

 ON

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1B:STATe ON"
!Turns the Event 1b State ON.

CALL:SHANdoff:EVent1B:REPorting:RANGe

Function

Controls the UTRA FDD Event 1b Reporting Range Constant. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

Setting

Range: 0.0 to 14.5 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 0.0 dB
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 14.5 dB

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1B:REPorting:RANGe 3"
!Sets the UTRA FDD Event 1b Reporting Range Constant to 3 dB.

CALL:SHANdoff:EVent1B:HYSTeresis

Function

Controls the UTRA FDD Event 1b Hysteresis. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

Setting

Range: 0.0 dB to 7.5 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 1.5 dB
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 7.5 dB

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1B:HYSTeresis 4"
!Sets the UTRA FDD Event 1b Hysteresis to 4.0 dB.

CALL:SHANdoff:EVent1B:WVALue

Function

Controls the UTRA FDD Event 1b "W" Value. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

Setting

Range: 0.0 to 2.0

Resolution: 0.1

Query

 Same as setting
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 2.0

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1B:WVALue 5"
!Sets the UTRA FDD Event 1b "W" Value to 0.5 dB.

CALL:SHANdoff:EVent1C:STATe

Function

Controls the UTRA FDD Event 1c ON/OFF State. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

It is recommended that you set CALL:SHANdoff:EVENt:ENABle to OFF before changing this setting. You must then turn CALL:SHANdoff:EVENt:ENABle back ON to enable event reporting.

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

 ON

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1C:STATe ON"
!Turns the Event 1c State ON.

CALL:SHANdoff:EVent1C:HYSTeresis

Function

Controls the UTRA FDD Event 1c Hysteresis. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

Setting

Range: 0.0 dB to 7.5 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 1.5 dB
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 7.5 dB

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1C:HYSTeresis 4"
!Sets the UTRA FDD Event 1c Hysteresis to 4.0 dB.

CALL:SHANdoff:EVent1D:STATe

Function

Controls the UTRA FDD Event 1d ON/OFF State. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

It is recommended that you set CALL:SHANdoff:EVENt:ENABle to OFF before changing this setting. You must then turn CALL:SHANdoff:EVENt:ENABle back ON to enable event reporting.

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

 ON

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1D:STATe ON"
!Turns the Event 1d State ON.

CALL:SHANdoff:EVent1D:HYSTeresis

Function

Controls the UTRA FDD Event 1c Hysteresis. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

Setting

Range: 0.0 dB to 7.5 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 1.5 dB
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 7.5 dB

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1D:HYSTeresis 4"
!Sets the UTRA FDD Event 1d Hysteresis to 4.0 dB.

CALL:SHANdoff:EVent1E:STATe

Function

Controls the UTRA FDD Event 1e ON/OFF State. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

It is recommended that you set CALL:SHANdoff:EVENt:ENABle to OFF before changing this setting. You must then turn CALL:SHANdoff:EVENt:ENABle back ON to enable event reporting.

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

 ON

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1E:STATe ON"
!Turns the Event 1e State ON.

CALL:SHANdoff:EVent1E:HYSTeresis

Function

Controls the UTRA FDD Event 1e Hysteresis. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

Setting

Range: 0.0 dB to 7.5 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 1.5 dB
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 7.5 dB

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1E:HYSTeresis 4"
!Sets the UTRA FDD Event 1e Hysteresis to 4.0 dB.

CALL:SHANdoff:EVent1E:THREshold

Function

Controls the UTRA FDD Event 1e Threshold. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

Setting

Range: -115 to -25 dBm

Resolution: 1

Query

 Same as setting

*RST Setting

 -60 dBm
Requirements Lab Application Revision: C.01 and above, new range -115 to -25 dBm

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1E:THREshold -70"
!Sets the UTRA FDD Event 1e Threshold to -70 dBm.

CALL:SHANdoff:EVent1F:STATe

Function

Controls the UTRA FDD Event 1f ON/OFF State. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

It is recommended that you set CALL:SHANdoff:EVENt:ENABle to OFF before changing this setting. You must then turn CALL:SHANdoff:EVENt:ENABle back ON to enable event reporting.

Setting

Range: 0|OFF|1|ON

Query

Range: 0|1

*RST Setting

 ON

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1F:STATe ON"
!Turns the Event 1f State ON.

CALL:SHANdoff:EVent1F:HYSTeresis

Function

Controls the UTRA FDD Event 1f Hysteresis. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

Setting

Range: 0.0 dB to 7.5 dB

Resolution: 0.5

Query

 Same as setting

*RST Setting

 1.5 dB
Requirements Lab Application Revision: C.01 and above, new range 0.0 to 7.5 dB

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1F:HYSTeresis 4"
!Sets the UTRA FDD Event 1f Hysteresis to 4.0 dB.

CALL:SHANdoff:EVent1F:THREshold

Function

Controls the UTRA FDD Event 1f Threshold. In order for changes to this event parameter to be seen by the UE, you must send the CALL:SHANdoff:EVENt:SEND:CONFig command. (See Event Reporting ).

Setting

Range: -115 to -25 dBm

Resolution: 1

Query

 Same as setting

*RST Setting

 -80 dBm
Requirements Lab Application Revision: C.01 and above, new range -115 to -25 dBm

Programming Example

OUTPUT 714;"CALL:SHANdoff:EV1F:THREshold -70"
!Sets the UTRA FDD Event 1f Threshold to -70 dBm.


Protocol Logging Requirements

Protocol Logging Requirements

Last updated: January 16, 2009

This section is only applicable to the lab application.

The lab application enables the test set to log protocol messages. Protocol messages are forwarded to the Wireless Protocol Advisor (WPA) software, which is required for message display and analysis. This software is included with the lab application and will run on PCs that meet the following system requirements:

Summary of Requirements for the Wireless Protocol Advisor

NOTE
These requirements are subject to change or addition without notice. Always refer to the product web page for the latest information.

  • PC Operating System:
    • US version of Microsoft , Windows , 2000, NT or XP
    • Chinese version of Microsoft , Windows , 2000, NT or XP
  • 300 MHz Pentium or equivalent recommended
  • 256 MB RAM or greater recommended
  • 250 MB available disk space required for installation
  • 100 MB available disk space recommended for storing logged information
  • Video resolution minimum 800 by 600 pixels with at least 256 colors
  • LAN or WAN connectivity required to connect to the test set


Activating Protocol Logging From the Test Set

Activating Protocol Logging From the Test Set

Last updated: January 16, 2009

This section is only applicable to the lab application.

Once a connection is established between the PC running the WPA (Wireless Protocol Advisor) and the test set, a logging session can be activated (or deactivated) by selecting the start (or stop) softkey from the test set's front panel or by sending GPIB commands that perform the same functions:

NOTE
The WPA software performs the same start/stop functions when the REC (RECord) button is selected. Refer to the WPA on-line Help for details.

Test Set Control of Protocol Logging

If a PC with the WPA software has not yet connected with the test set, an error message will be generated if an attempt is made to start protocol logging. Exactly one PC/WPA can be connected to a test set at one time.

Front Panel Control of Protocol Logging

  1. Press the CALL SETUP key to go to the Call Setup screen.
  2. Press the More key on the left hand Call Control menu to go to menu 3.
  3. Select Protocol Logging ( F1 ).
  4. Select Start Protocol Logging ( F1 ) to begin logging.

Remote Control of Protocol Logging

The GPIB command to control Protocol Logging is CALL:PLOGging .


E6703A/B/C/D/E/F/G/H/T/U W-CDMA/HSPA Lab Application Revision Information

E6703A/B/C/D/E/F/G/H/T/U W-CDMA/HSPA Lab Application Revision Information

Last updated: March 30, 2012

This document describes features and functionality that are part of the Agilent Technologies W-CDMA Lab Application releases. This document contains the original features, as well as enhancements that have been added over time.

If you are interested in comparing the key feature differences between the latest releases of each of the W-CDMA/HSPA Test and Lab Applications, see:

W-CDMA/HSPA Applications Feature Comparison

CAUTION
You may need to upgrade the hardware in your test set before installing the application firmware described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up (see Test Set Lockup During Power Up Sequence ).
  • The application may not run.
  • Some features in the application may be inaccessible, or may not perform to specifications.

To determine if a hardware upgrade is required for your testing needs, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Select the appropriate link below to view the required release.

  • H.01.12 Release (E6703H) - March 2012
  • H.00.06 Release (E6703H) - May 2011
  • G.01.10 Release (E6703G) - December 2010
  • G.00.14 Release (E6703G) - June 2010
  • G.00.08 Release (E6703G) - January 2010
  • F.01.12 Release (E6703F) - October 2009
  • F.00.19 Subscription Release (E6703F) - May 2009
  • F.00.07 Subscription Release (E6703F) - December 2008
  • U.01.04 Special Release (E6703U) - October 2008
  • E.01.16 Release (E6703E) - October 2008
  • E.01.13 Release (E6703E) - September 2008
  • U.00.33 Special Release (E6703U) - May 2008
  • E.00.36 Subscription Release (E6703E) - May 2008
  • U.00.31 Special Release (E6703U) - May 2008
  • E.00.34 Subscription Release (E6703E) - May 2008
  • U.00.20 Special Release (E6703U) - November 2007
  • E.00.23 Subscription Release (E6703E) - November 2007
  • T.03.08 Special Release (E6703T) - July 2007
  • D.02.08 Release (E6703D) - July 2007
  • E.00.15 Subscription Release (E6703E) - May 2007
  • U.00.12 Special Release (E6703U) - April 2007
  • E.00.12 Subscription Release (E6703E) - April 2007
  • T.01.17 Special Release (E6703T) - March 2007
  • D.01.17 Release (E6703D) - March 2007
  • T.01.12 Special Release (E6703T) - December 2006
  • D.01.12 Release (E6703D) - December 2006
  • D.00.09 Subscription Release (E6703D) - September 2006
  • T.00.08 Special Release (E6703T) - August 2006
  • D.00.08 Subscription Release (E6703D) - August 2006
  • C.04.06 Release (E6703C) - July 2006
  • T.00.04 Special Release (E6703T) - May 2006
  • T.00.02 Special Release (E6703T) - April 2006
  • D.00.03 Subscription Release (E6703D) - April 2006
  • C.03.11 Release (E6703C) - January 2006
  • C.02.25 Release (E6703C) - May 2005
  • C.01.17 Release (E6703C) - January 2005
  • B.01.34 Release (E6703B) - July 2004
  • B.01.29 Release (E6703B) - April 2004
  • B.01.16 Release (E6703B) - January 2004
  • B.01.14 Release (E6703B) - January 2004
  • A.02.10 Release (E6703A) - July 2003
  • A.01.20 Release (E6703A) - February 2003 (Initial Lab Application Release)

H.01.12 Release (E6703H) - March 2012

The E6703H Release H.01.12 includes all of the features and functionality present in the prior E6703H Subscription Releases which were made available early to Annual Contract owners.

This release also includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.18 (see A.19.12 Release - March 2012 ), and the features described below.

Hardware Requirements

This release has specific hardware requirements. Test sets with serial number<MY5210 require a HW upgrade to run this release.

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Call Processing

  • Dual Cell HSDPA.

    Dual carrier HSDPA, also referred to as dual cell HSDPA or DC-HSDPA in the test standard, is introduced in 3GPP Release 8 to allow the network to transmit HSDPA data from two cells simultaneously. The peak rate is doubled from 21Mbps to 42Mbps without the use of MIMO. See Dual Cell HSDPA Concepts and How Does the Test Set Supports DC-HSDPA . Please be noted that specific hardware is required to enable this feature.

  • Fast Domancy.

    Fast Dormancy is a special signaling function added to WCDMA and HSPA technologies in Release 8 of the 3GPP standards. It is defined to improve UE battery life while also minimizing network signaling. Fast Dormancy builds upon the existing defined RRC state transitions by more clearly defining the frequency of these transitions and the signaling procedures for requesting and granting certain transitions. See SCRI with Fast Dormancy .

  • E-UTRAN Inter-RAT measurement report.

    When compressed mode is activated, you can choose to have E-UTRA measurements activated in the UE. See Compressed Mode and E-UTRA Measurement Results .

  • UE Reported Release Indicator. See CALL:MS:REPorted:RINDicator? .
  • Enable/Disable DTX detection. See CALL:UPLink:DPCChannel:DTX:DETection[:STATe] .
  • RG Pattern enhancement. See CALL:HSUPa:SGRant:RELative:PATTern .

H.00.06 Release (E6703H) - May 2011

The E6703H Release H.00.06 includes all of the features and functionality present in the prior E6703G Subscription Releases which were made available early to Annual Contract owners.

This release also includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.18 (see A.18.07 Release - March 2011 ), and the features described below.

Please be aware that this release has specific hardware requirements to be able to run correctly.

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Call Processing

  • Inter-RAT operation with LTE.

    By setting up a connection with an external LTE simulator, the test set supports the following test scenarios:

    • Cell reselection between WCDMA and LTE (bi-directional, UE-initiated only).
    • PS Handover between WCDMA and LTE (bi-directional, network-initiated only). See External PS Handover .
    • RRC Redirection from LTE to WCDMA.
    • Circuit Switched Fallback (CSFB) from LTE. See Unexpected Page Response .
    See also E-UTRAN / WCDMA Interworking on how to set up the connection between the test set and the LTE simulator.

  • IPv6 Router and DUT IPv6 Prefix

    Added a new setting " IPv6 Router State " to control whether the test set acts as an IPv6 router or not. See IPv6 Router State .

    You are also allowed to set the DUT IPv6 prefix (and DUT IPv6 prefix 2 for multiple PDP contexts) when IPv6 is used. If the DUT IPv6 Prefix is set to a valid value other than the IPv6 prefix of the test set, the test set can act as a router to forward all the IPv6 packets directing to that DUT IPv6 Prefix to the UE.

G.01.10 Release (E6703G) - December 2010

The E6703G Release G.01 includes all of the features and functionality present in the prior E6703F Subscription Releases which were made available early to Annual Contract owners.

This release also includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.17 (see A.17.10 Release - December 2010 ), and the features described below.

Please be aware that this release has specific hardware requirements to be able to run correctly.

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Call Processing

  • Support for Multiple PDP Contexts.

    Multiple PDP Contexts functionality allows you to test the UEs running simultaneous PS services. The test set supports to setup multiple (up to two) primary PDP contexts simultaneously with the UE. You can enable/disable the primary PDP contexts independently from one another, with each PDP context using its own IP address (either IPv4 or IPv6) and QOS profile. See more detail in Multiple PDP Contexts Information .

  • Support for SIB19 (the system information block type 19), which contains Inter-RAT frequency and priority information to be used in the cell. See SIB19 Information .
  • Support HSDPA pattern setup by HSDPA Pattern Parameters .
  • Enhanced CPC:
    • CPC UE DRX Statistics available, including Expected DTX from HS-DPCCH ( CALL:STATus:CPC:MS:HSDPcchannel:DTX:EXPected:COUNt? ) and Unexpected ACK/NACK from HS-DPCCH ( CALL:STATus:CPC:MS:HSDPcchannel:UNEXpected:COUNt? ).
    • Extend the range of Default DPCH Offset (DOFF) , as well as the relavant parameters for Transport Channel Reconfiguration and Radio Bearer Reconfiguration. See CALL:DPCHannel:DOFFset , CALL:SETup:TCReconfig:DPCHannel:DOFFset and CALL:SETup:RBReconfig:DPCHannel:DOFFset .
  • Add a new RG pattern: 12 Downs+8 Holds to facilitate the 3GPP TS 34.121 test case 10.3.2
  • Add Integrity Key and Ciphering Key report for security procedure. These two results are available both on the screen and by GPIB remote control, see CALL:SECurity:RESult:INTegrity:KEY? and CALL:SECurity:RESult:CIPHering:KEY? .
  • Add the MM/SS connection timeout setting, by GPIB only, see CALL:SSERvice:PIPE:DATA:TIMeout .

G.00.14 Release (E6703G) - June 2010

The E6703G Release G.00 includes all of the features and functionality present in the prior E6703F Subscription Releases which were made available early to Annual Contract owners.

This release also includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.15 (see A.15.12 Release - October 2009 ), and the features described below.

Please be aware that this release has specific hardware requirements to be able to run correctly.

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Call Processing

  • Support downlink power control if a RB test mode call connection is set up. In response to the TPC (transmit power control) bits from the UE, the test set adjusts the downlink DPCCH/DPDCH/F-DPCH power accordingly. Downlink power control helps to test the ability of the UE receiver to converge to required link quality set by the network while using as low power as possible in downlink. The following parameters are added in support of this feature:
    • For ordinary transmit power control, see Downlink Power Control Information and CALL:CLPControl
    • For power control in compressed mode, see <num> TG Delta SIR 1 and <num> TG Delta SIR After 1
    • Target Quality On F-DPCH
  • IPv6 support
    • Support to select the DUT IP Version and DUT IPv6 DNS Server Address .
    • Display and query IPv6 bytes and packets. See CALL:COUNt:MS:IP:RX:IP6? and CALL:COUNt:MS:IP:TX:IP6? .
  • Support to ignore the following request messages from the UE:
    • GPRS Attach ( CALL:SERVice:GPRS:AIGNore[:STATe] )
    • Location Updating ( CALL[:CELL]:LAUPdate:IGNore[:STATe] )
    • Routing Area Update ( CALL:SERVice:GPRS:RAUPdate:IGNore[:STATe] )
    • PDP Activation ( CALL:SERVice:GPRS:IGNore[:STATe] )

    See Message Reply Control and Activate PDP Context Control .

  • Update the preset configurations for 3GPP TS 34.121 5.2B, 5.9B, 5.10B and 5.13.2B sub test 5 to comply with the newer version standard. See HSPA 34.121 Preset Call Configurations .
  • Add a new predefined reference E-TFCI power offset, shown as "Definition 34121-03: 34.121 v8.8.0 Table 5.2B.3A" to comply with the 3GPP standard. See Predefined Reference E-TFCI Power Offsets and CALL:HSUPa:ETFCi:POFFsets:REFerence .

G.00.08 Release (E6703G) - January 2010

The E6703G Release G.00 includes all of the features and functionality present in the prior E6703F Subscription Releases which were made available early to Annual Contract owners.

This release also includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.15 (see A.15.12 Release - October 2009 ), and the features described below.

Please be aware that this release has specific hardware requirements to be able to run correctly.

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Call Processing

  • Support HSUPA channel configuration for soft handover. Following immediate actions are added:
    • Add HSUPA Main to Active Set: This action will create both DPCH and E-DCH on the main node and signal to the UE to add it to the active set. See CALL[:CELL]:DPEDchannel:ASET:ADD:MAIN .
    • Add HSUPA Aux to Active Set: This action will create both DPCH and E-DCH on the Aux node and signal to the UE to add it to the active set. See CALL[:CELL]:DPEDchannel:ASET:ADD:AUXiliary
    • Remove HSUPA Main from Active: This action will release both DPCH and E-DCH on the main node and signal to the UE to remove it from the active set. See CALL[:CELL]:DPEDchannel:ASET:REMove:MAIN
    • Remove HSUPA Aux from Active: This action will release both DPCH and E-DCH on the Aux node and signal to the UE to remove it from the active set. See CALL[:CELL]:DPEDchannel:ASET:REMove:AUXiliary .
  • Add additional CPC results which shows the UL DTX erroneous statistical information. These results are available by both front panel and GPIB command. See CALL:STATus .

    Add a new CPC setting " HS-SCCH Less Order Info ". This setting is used to configure which order will be sent on HS-SCCH to control the HS-SCCH less operation on the air after HS-SCCH less operation has been configured to UE. See CALL:CPC:HLESs:ORDer .

  • DL Max PDU Payload Size: This setting determines the downlink maximum flexible AM RLC PDU payload size. DL Max PDU Payload Size is only available when the PS Data HS-DSCH MAC Entity is set to MAC-ehs and the Downlink AM RLC Mode is Flexible . See CALL:HSDPa:SERVice:PSData:RLC:DOWNlink:MAXimum:PDU:PSIZe .
  • Support to get UE Positioning Capability via RRC pipe, by GPIB command only. See CALL:PPRocedure:RRC:PIPE:UEPosition:CAPability? . You can also retrieve the message CM Service Request via SS Pipe by CALL:SSERvice:PIPE:DATA:CMService:REQuest? .
  • Add a new setting "RRC Idle With SCRI" in Auto RRC State Transitions Setup menu. This setting determines whether the test set will initiate the RRC state transitions procedure upon receiving the Signalling Connection Release Indication (SCRI) message from the UE. See CALL:SERVice:PSData:RRC:TRANsition:SCRI:RRCIdle[:STATe] .
  • Add the following HSUPA settings:
    • HSUPA PS Data MAC-d PDU Size: This setting controls the size of the E-DCH MAC-d PDU that is to be used to configure the UE in signalling message during HSUPA PS Data call setup procedure. See CALL:HSUPa:SERVice:PSData:MACD:PDUSize .
    • RG Mode: The Relative Grant Mode (RG Mode) determines the behavior of the E-RGCH channel, whether the test set will enable the Send Up/Down Relative Grant (Serving RLS) action or transmit a continuous sequence of values to the UE over E-RGCH. The values that are transmitted to the UE are defined by Section E-RGCH Pattern . See CALL:HSUPa:SGRant:RELative:MODE .
    • RG Pattern: see CALL:HSUPa:SGRant:RELative:PATTern .
  • Add the following HSDPA settings:
    • PS Data HS-DSCH MAC-d PDU Size Control: This setting determines whether PS Data HS-DSCH MAC-d PDU Size or PS Data HS-DSCH MAC-d PDU Size Manual is to be used on HS-DSCH channel. See CALL:HSDPa:SERVice:PSData:MACD:PDUSize:CONTrol
    • PS Data HS-DSCH MAC-d PDU Size Manual: When PS Data HS-DSCH MAC-d PDU Size Control is set to Manual , this setting determines the size of the MAC-d PDU that is used on the DTCH that is mapped to the HS-DSCH for a HSDPA PS data connection. See CALL:HSDPa:SERVice:PSData:MACD:PDUSize:MANual .
  • Add a new option for E-HICH Behavior: All DTXs. See CALL[:CELL]:EHIChannel:BEHavior .
  • Extend the frequency numbers to set the amplitude offset from 20 to 60. See Amplitude Offset and SYSTem:CORRection .
  • Support for setting register names. You can set a name for each register to easily identify your saved configuration. See Setting register names and SYSTem:REGister:NAME

Measurements

  • Added a new measurement: Perceptual Evaluation of Speech Quality (PESQ). (An additional feature license is required to enable this functionality in a licensed lab application or test application)

    PESQ is a objective method to test the speech quality of the mobile station. With a voice service and the AMR Source set to PESQ , the test set supports the PESQ measurement with three measurement modes: Uplink Audio, Downlink Audio and Both. When a single measurement is done, a PESQ score ranging from -0.5 (bad) to 4.5 (Excellent) is given to rate the speech quality. The related headroom is also displayed.

    • For the measurement description, see Perceptual Evaluation of Speech Quality (PESQ) Measurement Description .
    • For the manual operation, see Measuring Perceptual Evaluation of Speech Quality (PESQ) .
    • For the GPIB commands, see SETup:WPESquality or FETCh:WPESquality .
    • For trouble shooting, see Perceptual Evaluation of Speech Quality Measurement Troubleshooting

F.01.12 Release (E6703F) - October 2009

The E6703F Release F.01 includes all of the features and functionality present in the prior E6703F Subscription Releases which were made available early to Annual Contract owners.

This release also includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.15 (see A.15.12 Release - October 2009 ), and the features described below.

Please be aware that this release has specific hardware requirements to be able to run correctly.

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Call Processing

  • Location Updating Forced Reject State (see CALL:LAUPdate )
  • Combined GPRS Attach Forced IMSI Attach Reject State (see CALL:SERVice:GPRS:AAReject[:STATe] , CALL:SERVice:GPRS:AAReject:CAUSe , CALL:SERVice:GPRS:AREJect[:STATe] , CALL:SERVice:GPRS:AREJect:CAUSe , CALL:SERVice:GPRS:RAUReject[:STATe] , CALL:SERVice:GPRS:RAUReject:CAUSe )
  • GPRS Service Reject by APN Settings (see CALL:SERVice:PSData:RAPName[1]|2|3|4|5|6[:VAlue] , CALL:SERVice:PSData:RAPName[1]|2|3|4|5|6:CUSTom , CALL:SERVice:PSData:RAPName:REJect:CAUSe , CALL:SERVice:PSData:RAPName:STATe )
  • CPC Operation Control (see CALL:CPC:MODE )
  • HS-SCCH-less operation (see CALL:CPC:HLESs:HSPDschannel:CODE[:SECond] , CALL:CPC:HLESs:NTRans , CALL:CPC:HLESs:TBSize:INDex , CALL:CPC:HSDSchannel:TTYPe , CALL:STATus:CPC:HLESs:ACTivated? , CALL:STATus:CPC:HLESs:TBSize? )
  • RRC Pipe enhancements (see CALL:PPRocedure:RRC:PIPE:ADDMessage:FINE[:DATA] , CALL:PPRocedure:RRC:PIPE:MCMessage:FINE[:DATA] )
  • Enable Multi-Cell UTRAN Mode (see CALL[:CELL]:MCELl:DISable , CALL[:CELL]:MCELl:ENABle , CALL:STATus:MCELl? )
  • Active Set UI Control (see CALL[:CELL]:DPCHannel:ASET:ADD:AUX , CALL[:CELL]:DPCHannel:ASET:ADD:MAIN , CALL[:CELL]:DPCHannel:ASET:REMove:AUX , CALL[:CELL]:DPCHannel:ASET:REMove:MAIN )
  • External 8960 Timing measurement (see CALL[:CELL]:TIMing:EXTernal:OFFSet , CALL[:CELL]:TIMing:EXTernal:MEASurement? , CALL[:CELL]:TIMing:EXTernal:SYNChronize )

F.00.19 Subscription Release (E6703F) - May 2009

This is a Subscription Release of the E6703F application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have a current W-CDMA/HSDPA Lab Application Annual Contract to obtain this Subscription Release. Contact your Agilent Sales Representative for more information.

Call Processing

  • The RRC Pipe functions have been enhanced to provide timestamp information. This is useful for making Time To First Fix calculations where only the time between the UE fully receiving the MCM message and starting to transmit the MCM Response is considered. See CALL:PPRocedure .
  • Support for Robust Header Compression (ROHC) protocol as defined in RFC3095. The purpose of ROHC protocol is to provide a means to compress the protocol headers (for different IP/UDP/RTP combinations) in order to support services such as VoIP. See CALL:SERVice , CALL:COUNt , and CALL:STATus
  • Added partial support for Continuous Packet Connectivity: UL DTX, DL DRX and new uplink DPCCH slot formats are implemented for PS data call and RB Test Mode in Active Cell Mode and FDD Test Mode. see the following topics:
    • CALL:CPC
    • CALL:STATus
    • CALL:FDDTest
  • Support for the 64QAM PS Data Modulation Type. See CALL:HSDPa .
  • Additional PS data state transition settings. including Inactivity Timer configuration. See CALL:SERVice
  • Added FACH Measurement Occasion information settings. See CALL:BCCHannel .
  • Addition of UTRA FDD UE Transmitted Power Report and other UE reported values. See CALL:MS:REPorted .
  • Added settable SsearchRAT parameters. See CALL:RESelection .
  • Added RB Test Mode Uplink E-DCH RLC PDU Size parameter (see CALL:HSUPa:SERVice:RBTest:RLCPdu:SIZE ).
  • Added UL DPCCH Slot Format Setting (see CALL:UPLink:DPCChannel:SLOT:FORMat ).
  • Support for Supplementary Services (SS) Pipe. The SS Pipe along with the RRC Pipe, allows you to implement a Location Service (LCS) system. See CALL:SSERvice .
  • Added UEA1/UIA1 encryption (see CALL:SECurity:OPERation ).

Measurements

  • The E6703F now includes a QPSK EVM measurement. This measurement can be used to determine the error between the transmitted signal of a UE and the desired ideal signal, like the Waveform Quality measurement. The difference is that the QPSK EVM measurement expects a QPSK modulated input signal, which is similar to the WCDMA uplink signal with only one code channel. The data carried by the QPSK symbols sequence can be any pattern. There are several results reported with this measurement. These include the following:

    • Error Vector Magnitude (EVM)
    • Peak EVM - the maximum symbol EVM which is the calculated EVM at each QPSK symbol in the measurement interval
    • Phase Error
    • Origin Offset
    • Frequency Error

    See SETup:EVMQpsk , INITiate , READ , and FETCh:EVMQpsk .

Other Features

  • The test set now supports both IPv4 and IPv6 for IP connections. See Instrument IP Info/Instrument IP Setup and IPv6 Address Requirements .

F.00.07 Subscription Release (E6703F) - December 2008

This is a Subscription Release of the E6703F application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have a current W-CDMA/HSDPA Lab Application Annual Contract to obtain this Subscription Release. Contact your Agilent Sales Representative for more information.

Call Processing

  • The E6703F includes HSPA+ 64QAM DL test modes with signaling, HSPA+ MAC_ehs and Layer 2 enhancements. Layer 2 enhancements involve dynamically controlling the RLC PDU and SDU sizes instead of them being fixed. H-Set 8 is the one FRC that is now defined with 64QAM specifically for testing HSPA+ devices. Refer to the following items::
    • Changes on the HS-SCCH coding scheme to accommodate 64QAM: To be able to support signaling of three modulation formats (QPSK, 16QAM and 64QAM), the coding of HS-SCCHs changes if the UE is configured to be able to use 64QAM modulation type by higher layer signaling and the modulation format on the HS-PDSCHs is 16QAM or 64QAM.
    • New HS-DSCH Transport Block table defined for 64QAM: To support the 64QAM modulation format, a new table of HS-DSCH Transport Block Size and a corresponding table of K0,I of different numbers of channelization codes and modulation schemes are defined in 25.321 v7.8.0. To differentiate the additional K0,I table in release 7 from the existing K0,I table defined in release 5, the former is named octet aligned table, the latter is named bit aligned table. The selection between the two tables in UE depends on 3 Information Elements transmitted from the network which are defined in 25.331 v7.8.0:
      • DL MAC header type
      • Downlink 64QAM configured
      • HS-DSCH TB size table
    • H-SET 8 (64QAM modulation): Each 3GPP FRC H-Set defines a static configuration at the transport channel and physical channel level (for example, block size, number of HS-PDSCHs, inter-TTI distance, number of HARQ processes). The end result is a fixed data rate for the purposes of easier more consistent testing. Each FRC H-Set is associated with a particular UE category. FRC H-Sets 1, 2, 3, 6 and 10 have both QPSK and 16QAM variants, H-Set 4 and 5 only have QPSK variants. This is because UE categories 11 and 12, which are associated with H-Set 4 and 5 respectively, are only capable of QPSK modulation. H-Set 8 only has 64QAM variants. The FRC does not define the MAC-hs and MAC-ehs parameters such as the number of transmissions of a block and the RV sequence, so you must still manually configure these items. H-Set 8 implies that MAC-ehs be applied instead of MAC-hs, octet-aligned HS-DSCH Transport Block Size table be applied. H-Set 8 does not specify the MAC-d PDU size. However, you still need to specify the MAC-ehs SDU size. This can be done using the MAC-d PDU size.

      New RB test mode parameters to support testing UE categories greater than 12:
      • MAC-hs or MAC-ehs (see CALL:HSDPa:SERVice:RBTest:UDEFined:HSDSchannel:MAC )
      • Whether 64QAM could be configured (see CALL:HSDPa:SERVice:RBTest:UDEFined:QAM64:STATe )
      • Flexible RLC SDU size: Flexible RLC SDU size provides a way to configure the RLC SDU size from 1 byte to 1503 bytes when MAC-ehs is configured in RB Test Mode. When MAC-ehs is configured in user defined configuration, no segmentation is done at RLC layer. This setting sequentially determines the RLC PDU size of the DTCH mapped on HS-DSCH, and the MAC-ehs SDU size (see CALL:HSDPa:SERVice:RBTest:UDEFined:MACEHS:RLC:SDU[:SIZE] ).
    • MAC-ehs: The use of an octet-aligned table requires MAC-ehs (see CALL:FDDTest:HSDSchannel:UDEFined:MACEHS:TBSTable:ALIGnment ). MAC-ehs is introduced to support the 64QAM modulation type and MIMO to achieve higher data rate at the MAC layer.
  • Compressed mode is enhanced to support use with HSUPA (see CALL:COMPressed ).
  • HSDPA Features:
    • HSDPA >10Mbps IP data: Downlink throughput with HSDPA using an IP connection is increased to support at least Category 9 devices (10.2Mbps).
    • HSDPA 14.4Mbps RB Test and FDD Test modes and arbitrary configuration of downlink code allocation: Downlink throughput with HSDPA test modes in increased to a maximum of 14.4Mbps (Category 10). Also the ability is provided to flexibly configure channel codes to set up to 15 HS-PDSCHs needed for maximum HSDPA throughput. H-Set 10 allows up to 15 HS-DSCH code channels.
      • Arbitray DL code configuration (collision detection): You can freely set channelization codes in the allowable integer ranges, and the test set will apply a code collision detection procedure on all active channels and report a warning when collision is detected.
      • Implications of Arbitrary DL code configuration on OCNS code selection: You cannot directly activate 384k compressed mode with default code allocation like you could previously. A set of applicable codes must be setup beforehand for 384k compressed mode to avoid code collision between OCNS codes and compressed 384k DPCH code when compressed mode is activated. In order to support this scenario, the test provides one set of code preset functionality to help you quickly allocate one set of applicable code allocation for compressed mode with the 384k downlink channel configuration.
    • Enhanced HSDPA compressed mode allowing it to operate more like a real network:
      • For HSDPA, the standard specifies the compression is performed on an associated 12.2K RMC channel. In addition, according to standard, the UE is not required to listen to the HSDPA downlink channels during transmission gap. The test set provides two modes for HSDPA compressed mode support, either to transmit on HSDPA downlink channels regardless of transmission gap, or to DTX on transmision gap. The test set now provides functionality to either continue to transmit HSDPA data regardless of compressed mode, relying on a re-transmission mechanism for eventual loss of HSDPA data due to compressed mode or DTX on HSDPA channels when they overlap with a transmission gap.
  • Support for Band XII channels (UL/DL); Band XIII channels (UL/DL); Band XIV channels (UL/DL). See CALL:CHANnel , CALL:UPLink:CHANnel[:MCHannel] , CALL:SETup , CALL:STATus:FBINdicator? , CALL:STATus:SETup:RBReconfig:FBINdicator? , CALL:STATus:SETup:TCReconfig:FBINdicator? , and CALL:STATus:SETup[:PCReconfig]:FBINdicator? .
  • UMA/GAN Enhancements: The E6703F, when used along with the E6962B GANC software supports:
    • 3G UMA PS data handovers (requires E6708A Enhanced GAN feature license).
    • 2G/GAN/3G one-box handovers Voice and PS data handovers between 2G, 3G, and UMA/GAN are supported (requires E6708A Enhanced GAN feature license).

    • PLMN support

      Refer to the E6962B embedded online help for further details.

  • IP Data enhancements:
    • CELL_FACH for PS data (also URA_PCH and CELL_PCH): Transitional states of CELL_FACH, CELL_PCH, and URA_PCH are supported with W-CDMA PS data. Used to optimize battery life and PS data user experience.
    • CELL_FACH enhancements: Support for HSDPA with CELL_FACH, CELL_PCH, and URA_PCH is added along with event triggering for transitions between these states.

      See CALL:SERVice .

  • Audio enhancements:
    • AMR/AMR-WB multi-rate control (dynamic AMR/AMR-WB) both uplink and downlink) . Several configurations are now added to allow for testing of a a UEs adaptive multi-rate capability.
    • RFC 4867 (.amr) file format with DAI Addition of this file format allows longer audio files in a more compressed file to be played back and recorded using the digital audio interface (DAI) with 2G and 3G.
    • Audio routing with GAN : All of the test set's audio functionality works with GAN including audio in/out ports, DAI, and real-time vocoders. Refer to the E6962B online help for details.

      See CALL:SERVice .

  • A-GPS Reset MS Positioning Stored Info message: The Reset UE Positioning Stored Information message can be sent to the UE to clear the UE of the last positioning information it received. This is useful for receiver sensitivity testing. This feature is only available on an active RB test mode or PS data connection. See CALL:PPRocedure:GPSystem:MS:RESet .
  • 3GPP TS 34.121 related enhancements:
    • Independent H-RNTI: The UE identity values sent on the four HS-SCCHs (H-RNTIs) are extended so that all four can be set independently. This provides support for 3GPP TS 34.121 s9.4.1. In this release, you can configure the state of any HS-SCCH to be off, i.e. neither allocating the HS-SCCH in the test set nor configuring the UE to allocate that HS-SCCH through RRC messages when a HSDPA or HSPA connection is established (see CALL:FDDTest:HSSCchannel[1]:CONFig:STATe ).
    • Existing preset call configurations have been expanded to add configurability for the HSDPA and HSUPA sub-tests defined in the 3GPP TS 34.121 Annex C tables. This has added 26 new preset call configurations. Previously there were (5) HSDPA and (2) HSPA preset call configuration settings. These are retained as the "generic" setups but additional sub-set setups are added.
    • Support for two new data types (PRBS20 and PRBS23) is provided for use with W-CDMA or HSDPA channels. This adds compliance for 3GPP TS 34.121 s9.2.1A, C, D, E, F, and G. Sections 9.2.1H and I are also supported when 64QAM is the selected modulation type (see CALL:FDDTest:HSDSchannel:DATA , CALL:DTCHannel:DATA , and CALL:HSDPa:SERVice:RBTest:HSDSchannel:DATA ).
    • The ranges of the relative levels for the E-HICH, E-AGCH, and ERGCH are extended to support 3GPP TS 34.121 sections 10.2.1.1, 10.3.1.1, 10.3.1.2, and 10.4.1.
    • The AG Pattern has been extended to 8 values, adding support for 34.121 section 10.4.1 test.When the Absolute Grant mode parameter is set to "Pattern" then the application will transmit a continuous sequence of values to the UE over the E-AGCH (see CALL:HSUPa ).
  • Equivalent PLMN List - allows you to set a list of equivalent PLMN identities that is sent to the UE. See Equivalent PLMN List for more information.

Measurements

  • HSUPA IQ tuning, phase discontinuity measurement, waveform quality. EVM measurements are enhanced to support use with HSUPA.
  • SEM enhancement: This 34.121 measurement has been modified for certain frequency bands that have small frequency separation. Also added an absolute measurement result to the standard and this has been incorporated.

Other Features

  • The Global Position System (GPS) feature allows you to generate GPS signals to calibrate the GPS receiver of the mobile. See Single Channel GPS Source .
  • In this release the 2nd RF Source (Option 002) is required to allow you to set the RF Gen Configure parameter to GPS, however future releases will not require this option.

U.01.04 Special Release (E6703U) - October 2008

The E6703U can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6703U onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

You must have a current W-CDMA/HSPA Lab Application Annual Contract to obtain this Special Release. Contact your Agilent Sales Representative for more information.

Note, the Special High Data Rate Hardware required to support the E6703U meets the E6703D measurement parametric specifications in a temperature range of 25 °C +/- 5 °C, and has an operating temperature range of 0 to 35 °C.

The features and functionality offered in this release are otherwise identical to those offered in the E.01.16 Release (E6703E) - October 2008 .

For information on how to use these E6703U features, see the "E6703U User Documentation" topic in the following CHM Help File (this CHM Help File also includes information on how to use the features that are common to the E6703E and E6703U):

http://www.home.agilent.com/upload/cmc_upload/All/E1963_A13_E6703_E01_16_U01_04_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

E.01.16 Release (E6703E) - October 2008

This is a maintenance release to resolve the known issues detailed in the previous release. The features offered in this release are otherwise identical to those offered in the E.01.13 Release (E6703E) - September 2008 with the following key exceptions:

  • The value for RLC SDU window size has been increased when on a 5.7Mbps HSUPA IP data to increase IP data throughput for some devices (from 1024 to UE reported max AM RLC Window size).
  • The frequency band ranges have been extended for the Fast Device Tune measurement. See Fast Device Tune MS TX/RX Parameters .

E.01.13 Release (E6703E) - September 2008

The E6703E Release E.01.13 includes all of the features and functionality present in the prior E6703E Subscription Releases which were made available early to Annual Contract owners.

This release also includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.13 (see A.13.13 Release - September 2008 ), and the features described below.

Please be aware that this release has specific hardware requirements to be able to run correctly.

To determine if a hardware upgrade is required for this release, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Call Processing

  • 5.7 Mbps HSUPA IP data: Uplink rates up to 5.7 Mbps (E-DCH category 6 devices) are now supported.

Known Issues

  • Using save/recall causes HSUPA 2ms settings to un-synchronize between host and protocol.
  • The SYSTem:APPLication:CATalog:LICense:APPLication:ALL? command does not function.
  • Cannot camp to band IX.
  • Web pages are sometimes not properly displayed on the mobile when Web browsing.
  • An assert occurs when attempting a PCR handoff between bands (for example, 1 to 2, 2 to 5, 5 to 1) with a PDP context established using "Reported CQI" during an FTP.
  • If your test set has 2 LAN ports (LAN 1 PORT and LAN 2 PORT) on the test set's rear panel but you are running an application other than the E6703U, then ignore any set up references to the LAN 2 PORT and use the LAN 1 PORT instead.

    You can confirm whether or not the LAN 2 PORT is functional by pressing the Instrument Setup ( F1 ) key on the test set's front panel. If you do not see a menu item titled LAN IP Address 2 (Data+) , a LAN 2 connection is not present and you must use the LAN 1 PORT instead.

    The LAN 2 PORT will be functional in a future E6703E release.

U.00.33 Special Release (E6703U) - May 2008

This is a maintenance release to resolve the known issue detailed in the previous release. The features offered in this release are otherwise identical to those offered in the U.00.31 Special Release (E6703U) - May 2008 .

E.00.36 Subscription Release (E6703E) - May 2008

This is a maintenance release to resolve the known issue detailed in the previous release. The features offered in this release are otherwise identical to those offered in the E.00.34 Subscription Release (E6703E) - May 2008 .

U.00.31 Special Release (E6703U) - May 2008

NOTE
This release is unavailable due to a critical defect related to test set IP address assignment. Please refer to the top of Known Issues for further details on this issue.

The E6703U can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6703U onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

You must have a current W-CDMA/HSPA Lab Application Annual Contract to obtain this Subscription Release. Contact your Agilent Sales Representative for more information.

Note, the Special High Data Rate Hardware required to support the E6703U meets the E6703D measurement parametric specifications in a temperature range of 25 °C +/- 5 °C, and has an operating temperature range of 0 to 35 °C.

The features and functionality offered in this release are identical to those offered in the E.00.34 Subscription Release (E6703E) - May 2008 with the following key exceptions:

  • The E6703U Special High Data Rate W-CDMA/HSPA Lab Application (along with the appropriate hardware option) now supports Simultaneous Services for 12.2k AMR + 64k/64k and 12.2k AMR + HSPA configurations. This allows transitions between states of voice only, data only, and voice + data running simultaneously. This capability helps device developers functionally test new devices under real-world conditions.
  • Two-Cell Test System support for handovers between a GSM DTM (Dual Transfer Mode) call and a W-CDMA voice + data connection ( Simultaneous Services ).
  • TCP data flood, providing a means of sending and receiving TCP data between the test set and a cellular device with the minimum influence of external PCs on device throughput since no server PC is required. See TCP Data Flood .
  • DUT Routing State - allows you to use the test set as a router when exchanging IP datagrams between the UE and remote servers. See DUT Routing State .

Known Issues

  • The test set incorrectly assigns itself two IP addresses based on the "LAN IP Address" setting in the test set - the IP address specified by the "LAN IP Address" setting and "LAN IP Address" + 1. Thus, the test set will respond to IP traffic directed to "LAN IP Address" and "LAN IP Address + 1". This may result in unexpected network behavior if another device on the network is also assigned to "LAN IP Address" + 1.

    Example:

    If you set LAN IP Address = 192.168.1.22, the Test Set will also respond to LAN IP Address = 192.168.1.23. This will result in unexpected network behavior if there is another device on your network set to LAN IP Address = 192.168.1.23.

    Workaround:

    Reserve both "LAN IP Address" and "LAN IP Address" + 1 for use by your test set:

    • Ensure that no other device on the network is assigned "LAN IP Address" + 1, including other test sets.

    • Ensure that the test set's other IP addresses, such as "DUT IP Address" and "LAN IP Address 2" are not set to "LAN IP Address" + 1.

  • The 384k downlink compressed mode feature does not operate correctly in this release of the E6703U. Attempting to use the feature in this release will result in dropped calls. This issue will be fixed in a subsequent release of the E6703U.

_____________________________________________________________________________________________________

E.00.34 Subscription Release (E6703E) - May 2008

NOTE
This release is unavailable due to a critical defect related to test set IP address assignment. Please refer to the top of Known Issues for further details on this issue.

This is a Subscription Release of the E6703E application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have a current W-CDMA/HSDPA Lab Application Annual Contract to obtain this Subscription Release. Contact your Agilent Sales Representative for more information.

Call Processing

  • The E6703E now supports end-to-end two-box voice connection. A voice call between two UEs can be set up between two 8960 test sets.
  • Support for Idle Periods in the Downlink (IPDL), both Continuous Mode and Burst Mode. See Idle Periods in the Downlink (IPDL) .
  • Support for additional multi-rate and multi-rate wideband AMR channel types. See CALL:SERVice:AMR:RAB .
  • Support for Control Plane Assisted GPS (A-GPS) by means of RRC Pipe functions. The RRC Pipe is used to transport externally coded messages to and from the UE. See CALL:PPRocedure .
  • The E6703E now supports Network Identity and Time Zone (NITZ). The following information can be transferred from a serving PLMN to a UE for storage and/or use; universal time (UT), daylight saving time (DST), and local timezone(LTZ). See Network Identity and Time Zone .
  • Equipment Identity Request can now be configured to request from the UE either the IMEI, IMEISV, or both. See CALL:EIDentity , CALL:MS:REPorted:EISV? and CALL:MS:REPorted:EISV:SVN? .
  • Support for Band XI. See CALL:STATus:FBINdicator? , CALL:STATus:SETup:RBReconfig:FBINdicator? , CALL:STATus:SETup:TCReconfig:FBINdicator? , and CALL:STATus:SETup[:PCReconfig]:FBINdicator? .
  • The UTRA FDD Speech Echo Loopback Delay value was previously fixed at 0.5 seconds. This setting determines the amount of time that speech frames received on the uplink are delayed before being retransmitted on the downlink. A new parameter has been added with a default value of 0.5 seconds to maintain backwards compatibility. See CALL:SERVice:AMR:SPEech:ECHO:LOOPback:DELay .
  • E-TFCI recording has been enhanced allowing you to control whether all E-DPDCH subframes are recorded, or only those that pass CRC checks. See CALL:HSUPa:ETFCi:RECord:BEHavior .

Measurements

  • The E6703E now includes three additional 34.121 Preset Call Configurations for reporting of Channel Quality Indicator measurements; 9.3.1 with 16QAM (Cat 1 to 6), 9.3.1 with 16QAM (Cat 7 to 8), and 9.3.1 with QPSK (Cat 11 to 12).
  • A Histogram graphical display has been added for representation of Channel Quality Indicator measurement results.
  • The E6703E now includes CPICH RSCP reporting, displaying UE reported measurement of signal strength (Received Signal Code Power).

Known Issues

  • The test set incorrectly assigns itself two IP addresses based on the "LAN IP Address" setting in the test set - the IP address specified by the "LAN IP Address" setting and "LAN IP Address" + 1. Thus, the test set will respond to IP traffic directed to "LAN IP Address" and "LAN IP Address + 1". This may result in unexpected network behavior if another device on the network is also assigned to "LAN IP Address" + 1.

    Example:

    If you set LAN IP Address = 192.168.1.22, the Test Set will also respond to LAN IP Address = 192.168.1.23. This will result in unexpected network behavior if there is another device on your network set to LAN IP Address = 192.168.1.23.

    Workaround:

    Reserve both "LAN IP Address" and "LAN IP Address" + 1 for use by your test set:

    • Ensure that no other device on the network is assigned "LAN IP Address" + 1, including other test sets.

    • Ensure that the test set's other IP addresses, such as "DUT IP Address" and "LAN IP Address 2" are not set to "LAN IP Address" + 1.

  • In this release of the E6703E, a performance issue exists with HSUPA (10 ms) RB Test Mode. This configuration works as intended when logging is switched off or when logging basic signaling messages. However, when high data rate logging (for example, MAC) is enabled, performance is degraded (for example, messages will be missed). Full HSUPA RB Test Mode capability with logging enabled, requires special high data rate hardware (E5515C test set with E5515C-H08 or E5515CU-589 HW upgrade) and the special high data rate W-CDMA/HSPA Lab Application (E6703U).
  • When performing a downlink UDP flood on an HSDPA packet data connection, if the over-the-air (OTA) rate is much lower than the UDP rate (due to the CQI Value setting or User-Defined settings, etc.) and you rapidly increase the OTA rate, the test set may assert. Note, this issue does not exist in the E6703U.
  • If your test set does not include the hardware required to enable the Real-Time Vocoder and Digital Audio Interface features, the following warning is posted upon power up "Warning:; Hardware does not support a currently licensed feature. See www.agilent.com/find/8960upgrades for additional information; WCDMA Enhanced Audio." If you would like to enable this enhanced audio functionality in your test set, see www.agilent.com/find/8960upgrades for hardware upgrade information. Otherwise, please disregard this warning.
  • If you attempt to use the real-time vocoder with an incorrect hardware configuration, the following error message appears in the message log: "Operation rejected; feature is not licensed. See www.agilent.com/find/8960upgrades for more information." The wording of this error message is misleading as the error is in fact being caused by an incorrect hardware configuration, not an unlicensed feature. The following warning posted once at start up reports the problem correctly "Warning:; Hardware does not support a currently licensed feature. See www.agilent.com/find/8960upgrades for additional information; WCDMA Enhanced Audio." This issue will be fixed in a subsequent release of the E6703E.
  • The Block Error Ratio (BLER) measurement does not operate correctly when the Channel Type is set to 12.2k RMC + HSPA. The measurement always reports an error ratio of 100% with this channel type. With 12.2k RMC + HSPA, the BLER measurement uses RLC Transparent Mode (TM) and would require the UE Loopback Type to be set to Type 2 in order to loop back data and CRC bits. However, UE Loopback Type is fixed to Type 1 for this configuration, as required by TS 34.109 (refer to section 5.3.1 in TS 34.109, rev 7.2.0). This means that the BLER measurement cannot work correctly. In a subsequent release of the E6703E, the BLER measurement will not be supported for the 12.2k RMC + HSPA Channel Type.
  • The 34.121 presets for HRCQI do not configure several settings correctly. CAT 11,12 phones may fail if the preset configuration is used without changes.

    Workaround: Select the 34.121 Preset Call Config for the category phone in use. Change the following settings as shown:

    • HSDPA Cell 1 Connected CPICH Level to -10.0 (is erroneously set to -15.0)
    • HSDPA Cell 1 Connected PICH Level to -15.0 (is not being set at all, existing value left intact)
    • Number of Transmissions to 1 (is not being set at all, existing value left intact)
    • DeltaCqi to 5 (is erroneously set to 3)
    • Ack-Nack Repetition Factor to 1 (is erroneously set to 3)

U.00.20 Special Release (E6703U) - November 2007

The E6703U can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6703U onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

You must have a current W-CDMA/HSPA Lab Application Annual Contract to obtain this Subscription Release. Contact your Agilent Sales Representative for more information.

Note, the Special High Data Rate Hardware required to support the E6703U meets the E6703D measurement parametric specifications in a temperature range of 25 °C +/- 5 °C, and has an operating temperature range of 0 to 35 °C.

The features and functionality offered in this release are identical to those offered in the E.00.23 Subscription Release (E6703E) - November 2007 , with the following key exceptions:

  • The E6703U Special High Data Rate W-CDMA/HSPA Lab Application (along with the appropriate hardware option) supports the HSUPA Data Channel and therefore supports an HSPA UL/HSDPA DL PS GPRS Radio Access Bearer and a Packet Switched Data - HSPA service (see Current Service Type ). See HSUPA PS Data Setup for a list of parameters available to setup the HSUPA Data Channel.
  • The E6703U Special High Data Rate W-CDMA/HSPA Lab Application (along with the appropriate hardware option) supports circuit switched AMR voice and packet switched data connections or IP data simultaneously, referred to by 3GPP as Simultaneous Services .
_____________________________________________________________________________________________________

E.00.23 Subscription Release (E6703E) - November 2007

This is a Subscription Release of the E6703E application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have a current W-CDMA/HSDPA Lab Application Annual Contract to obtain this Subscription Release. Contact your Agilent Sales Representative for more information.

The features offered in this release are:

  • all the features offered in the A.12.11 Release - November 2007 .
  • The E6703E supports Loopback Video Call .
  • The E6703E supports an AMR Real-Time Vocoder to allow you to perform live end-to-end testing of the UE's entire audio path.
  • The E6703E supports the ability to perform the bit exact test of the AMR speech coder/decoder via the UE's Digital Audio Interface (see Digital Audio Interface (DAI) Description ).
  • The E6703E supports setting the SMSC Address .
  • The E6703E, when used along with the E6962A GAN Controller (GANC) emulation software, can create a UMA/GAN (Unlicensed Mobile Access / Generic Access Network) test system. This allows you to perform lab based functional, application, and pre-conformance testing of dual mode enabled UMA/GAN handsets. See UMA/GAN Test System for more information.

    The UMA/GAN test system is built around the test set's existing capabilities to provide GERAN cell and core network emulation. To aid in simulation of the GAN cell in the system, Agilent provides the E6962A GANC emulation software. This software is capable of communicating with a connected UE using the standardized GAN Up interface protocols, namely GA-RC, GA-CSR, and GA-PSR. The Agilent GANC emulation software also connects to the test set in the UMA/GAN test system to make use of the test set's core network capabilities via modified BSSAP & BSSGP protocols. The combination of these interfaces (Up interface protocols and BSSAP & BSSGP protocols) at the GANC allows a connected UE to fully make use of the GANC for accessing the test set's core network to perform GAN based speech, data and signaling procedures. You must have the E6962A GAN Controller to build the UMA/GAN test system. Contact your Agilent Sales Representative for more information.
  • The E6703E contains limited support (voice calls may unexpectedly drop) of circuit switched AMR voice and packet switched data connections or IP data simultaneously, or Simultaneous Services . Note: Full support of this feature is provided in the U.00.20 Special Release (E6703U) - November 2007 .
  • The E6703E supports using the UE reported CQI value or User Defined values for configuring the HSDPA PS Data downlink channel (HS-DSCH). This is in addition to directly setting the CQI value, which was previously the only method for configuring the HS-DSCH. The new parameters added for this feature are as follows (see HSDPA PS Data Setup for details):
    • PS Data Configuration Type
    • PS Data User Defined Active HS-PDSCHs
    • PS Data User Def Transport Block Size Index
    • PS Data User Defined Modulation Type
    • PS Data Minimum Inter-TTI Interval
    • PS Data Number of HARQ Processes
    • PS Data UE IR Buffer Allocation
    • PS Data Explicit UE IR Buffer Size
  • The following additional HSDPA PS data parameters have been added to the E6703E to allow you greater flexibility in configuring the HSDPA PS data channel, instead of automatically setting these based on the UE's HS-DSCH category and are all used to configure the user defined HS-DSCH:
    • PS Data Minimum Inter-TTI Interval
    • PS Data Number of HARQ Processes
    • PS Data UE IR Buffer Allocation
    • PS Data Explicit UE IR Buffer Size
  • Several HSUPA parameters have been added to the E6703E.

    New Common HSUPA Parameters include:

    • Happy Bit Delay Condition
    • Happy Bit Averaging Period
    • Scheduling Information Periodicity (No Grant)
    • Scheduling Information Periodicity (Grant)
    • HARQ Maximum Number of Retransmissions

    Also, HSUPA Happy Bit Information has been added to the HSPA Information screen.

  • The Measurement Power Offset setting is supported in the E6703E (in idle mode and while on a call).
  • Support of several UE timers and constants has been added to the E6703E. These include: T300, N300, T308, N308, RRC Connection Release Complete Wait Count, T309, T312, N312, and T3312. See UE Timer and Constant Parameters for more information.
  • AWGN Power and External AWGN Power can now be 10 dB above or 20 dB below Cell Power or Cell 2 Power , and can be within 20 dB of each other (previously the limit was +/- 10 dB).
  • Changes have been made to accommodate 3GPP TS 25.331 v5.17.0 s8.6.6.28, which now specifies that the UE's behavior is undefined if the network sets the Timing Indication information element to Initialise on a non-hard handover (i.e. where the UARFCNs and one or more Primary Scrambling Codes remain unchanged as part of the reconfiguration).
    • New Auto setting is now the default value for the following parameters:
      • PCR Timing Indication (CFN Handling)
      • TCR Timing Indication (CFN Handling)
      • RBR Timing Indication (CFN Handling)

      Note, the default has thus also changed to AUTO for the following GPIB commands: , and .

    • Maintain is now the default value for the CM PCR Timing Indication (CFN Handling) setting (and thus also for the CALL:COMPressed:PCReconfig:CFNHandling command).
    • Downlink and uplink channels can now be changed while on a connection using a Transport Channel Reconfiguration or Radio Bearer Reconfiguration (previously channels could only be changed on a connection using a Physical Channel Reconfiguration). This allows you to perform a legal timing re-initialized Transport Channel Reconfiguration or Radio Bearer Reconfiguration, which allows you to change the DPCH Frame Offset to 0, 1, 2, 3, 4, or 5 x 512 chips while on a connection. For more information, see RB setup Timing Indication (CFN Handling): and Current DPCH Offset .
      • New TCR Channel (UARFCN) State , TCR Downlink Channel (UARFCN) , TCR Uplink Channel (UARFCN) and TCR Band Arbitrator settings.
      • New RBR Channel (UARFCN) State , RBR Downlink Channel (UARFCN) , RBR Uplink Channel (UARFCN) and RBR Band Arbitrator settings.
      • Channel (UARFCN) Information screen now includes TCR Info and RBR Info .
    • 34.121 Preset Call Configurations setting names have been updated to include 5.2AA, 5.2C and 5.13.2A.

Transmitter Measurements

  • The E6703E supports the Reporting of Channel Quality Indicator measurement as defined by 3GPP TS 34.121 9.3.1. See HSDPA Reporting of Channel Quality Indicator Measurement Description
    for more information.
  • Inner Loop Power measurement enhancements:
    • Improved UE range time and new UE Range Time settings allow the Inner Loop Power measurement to execute more quickly.
    • The Inner Loop Power measurement can now measure power across a 30 dB dynamic range before needing to re-range (previously re-ranging was required every 13 dB). This allows the measurement to execute more quickly. Note, this improvement has specific Hardware Requirements .
  • The PRACH Transmit On/Off Power measurement's "Post Burst Off Power" range has been improved for test sets with the required hardware (see Hardware Requirements ). Previously the Post Burst Off Power was measured starting 100 µs after the end of the PRACH preamble burst. With the required hardware, the Post Burst Off Power is measured starting 25 µs after the end of the PRACH preamble burst. See PRACH Transmit On/Off Power Measurement Description .
  • New Extended Range Dynamic Power measurement (see Extended Range Dynamic Power Measurement Description ).

_____________________________________________________________________________________________________

T.03.08 Special Release (E6703T) - July 2007

The E6703T can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6703T onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6703T meets the E6703D measurement parametric specifications in a temperature range of 25 °C +/- 5 °C, and has an operating temperature range of 0 to 35 °C.

The features and functionality offered in this release are identical to those offered in the D.02.08 Release (E6703D) - July 2007 , with the following key exceptions:

  • The E6703T Special High Data Rate W-CDMA/HSDPA Lab Application (along with the appropriate hardware option) supports the maximum IP data throughput of HSDPA UE categories 1-6, 11 and 12. This allows you to test 3.6 Mbps HSDPA IP data throughput for category 5 and 6 UEs. Note that to achieve 7.2 Mbps HSDPA IP data throughput you must have a current W-CDMA/HSDPA Lab Application Annual Contract, which allows you to download the E6703U Subscription Releases.
  • The E6703T supports the following GPRS Radio Access Bearers. If you attempt to select these RABs in the E6703D, an error is posted. See GPRS Radio Access Bearer .
    • 384k UL/384k DL PS
    • 128k UL/HSDPA DL PS
    • 384k UL/HSDPA DL PS
  • The E6703T (along with the appropriate hardware option) supports enabling compressed mode for 384k downlink channels (if you try to enable compressed mode while on a 384k downlink channel in the E6703D, an error is posted).
  • You must use the LAN 2 PORT for transferring data to the test set.

Note that only the E6703U supports 7.2 Mbps HSDPA IP data throughput. The E6703T supports 3.6 Mbps HSDPA IP data throughput.

_____________________________________________________________________________________________________

D.02.08 Release (E6703D) - July 2007

The E6703D Release D.02 includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.11.08 (see A.11.08 Release - July 2007 ).

Note that this Online User's Guide includes documentation for the following feature that is only available in the E6703E (which is available to W-CDMA/HSDPA Lab Application Annual Contract owners): Two-Cell Test System inter-RAT voice handovers.

_____________________________________________________________________________________________________

E.00.15 Subscription Release (E6703E) - May 2007

This is a Subscription Release of the E6703E application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have a current W-CDMA/HSDPA Lab Application Annual Contract to obtain this Subscription Release. Contact your Agilent Sales Representative for more information.

The features offered in this release are identical to those offered in the E.00.12 Subscription Release (E6703E) - April 2007 . However, this release does not require the new hardware that was necessary for the E.00.12 release. Contact your local Agilent Sales Representative for more information.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

U.00.12 Special Release (E6703U) - April 2007

The E6703U can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6703U onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

You must have a current W-CDMA/HSDPA Lab Application Annual Contract to obtain this Subscription Release. Contact your Agilent Sales Representative for more information.

Note, the Special High Data Rate Hardware required to support the E6703U meets the E6703D measurement parametric specifications in a temperature range of 25 °C +/- 5 °C, and has an operating temperature range of 0 to 35 °C.

The features and functionality offered in this release are identical to those offered in the E.00.12 Subscription Release (E6703E) - April 2007 , with the following key exceptions:

  • The E6703U Special High Data Rate W-CDMA/HSDPA Lab Application (along with the appropriate hardware option) supports the maximum IP data throughput of HSDPA UE categories 1-8, 11 and 12. This allows you to test 3.6 Mbps HSDPA IP data throughput for category 5 and 6 UEs, and 7.2 Mbps HSDPA IP data throughput for category 7 and 8 UEs.
  • The E6703U supports the following GPRS Radio Access Bearers. If you attempt to select these RABs in the E6703E, an error is posted. See GPRS Radio Access Bearer .
    • 384k UL/384k DL PS
    • 128k UL/HSDPA DL PS
    • 384k UL/HSDPA DL PS
  • The E6703U (along with the appropriate hardware option) supports enabling compressed mode for 384k downlink channels (if you try to enable compressed mode while on a 384k downlink channel in the E6703E, an error is posted).
  • You must use the LAN 2 PORT for transferring data to the test set.

_____________________________________________________________________________________________________

E.00.12 Subscription Release (E6703E) - April 2007

This is a Subscription Release of the E6703E application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have a current W-CDMA/HSDPA Lab Application Annual Contract to obtain this Subscription Release. Contact your Agilent Sales Representative for more information.

Hardware Requirements

E6703E E.00.12 has specific hardware requirements. You may need to upgrade the hardware in your test set before installing this release. Contact your local Agilent Sales Representative for more information, or visit:

http://www.agilent.com/find/8960upgrades

Known Issues

  • Connection may drop if Physical Channel Reconfiguration is performed while transferring data on an HSDPA PS Data connection.
  • System Handover from the W-CDMA/HSDPA format to the GSM/GPRS/EGPRS format fails if any of the following GSM/GPRS/EGPRS format parameters are set as follows:
    • Frequency Hopping set to On .
    • Logical Speech Channel set to WFS (Wideband Full) .
  • If the Transport Channel Reconfiguration fails and the connection drops while TCR Timing Indication (CFN Handling) is set to Maintain and TCR Relative DPCH Frame Offset is set to 256 chips (because, for example, your UE does not support this functionality), subsequent attempts to reestablish the connection may then fail. You must change Default DPCH Offset (DOFF) (under Cell Info ( F2 )>> Cell Parameters ) to a value other than the current setting, then set it to the desired setting, then reestablish the connection.
  • Two-Cell Test System: If you establish a voice call with the GSM/GPRS/EGPRS test set, then perform an External 8960 Handover to the W-CDMA/HSDPA test set, when you attempt to hand back to the GSM/GPRS/EGPRS test set, an error is posted. If you establish the voice call with the W-CDMA/HSDPA test set initially, then you can successfully hand the call back and forth between the two test sets without error.

Call Processing

  • The Two-Cell Test System now supports inter-RAT voice handovers (W-CDMA/HSDPA <--> GSM/GPRS/EGPRS).
    • New Activation Time setting.
  • The following settings have been changed/added in support of 7.2 Mbps HSDPA IP data throughput. Although these changes are present in both the E6703E and E6703U, you must have the E6703U (and the appropriate hardware option) to achieve 7.2 Mbps HSDPA IP data throughput.
    • The PS Data First HS-PDSCH Channelization Code can now be set to 5 and 6 (the new range is 5-10), and the default has been changed to 5 (from 7).
      Note, the default value for the CALL:HSDPa:SERVice:PSData:HSPDschannel:CCODe command has changed from CODE7 to CODE5 .
    • New PS Data User Defined Active HS-PDSCHs setting.
  • If your test set includes the required hardware (see Hardware Requirements ) uplink Betac can now be set to 1 via the following settings:
    • Manual Uplink DPCH Bc
    • TCR Manual Uplink DPCH Bc
    • RBR Manual Uplink DPCH Bc
  • Support for Band X (see Channel (UARFCN) Parameters ).
    • The range of the Transmit SIB5bis setting has been expanded to include Band X ( BAND10 ) and Standard Bands ( SBANds ). The default has changed from Bands IV & IX to Standard Bands (and the default value for the CALL[:CELL]:BCCHannel:SIB5:BIS command has changed from BAND49 to SBANds ).

Transmitter Measurements

  • The Fast Device Tune measurement now supports Band VII (the range of the MS TX Frequency Step Values now includes 2502.4 to 2567.6 MHz, and the range of the MS RX Frequency Step Values now includes 2622.4 to 2687.6 MHz). See Fast Device Tune Measurement Description . Note, the band VII functionality has specific Hardware Requirements .
  • New Dynamic Power Analysis 34.121 5.7A Measurement Configuration setting helps you quickly configure the measurement to perform 3GPP TS 34.121 5.7A from the front panel. This setting should be used in conjunction with the existing 34.121 Preset Call Configurations .
  • New Waveform Quality 34.121 5.13.1A Measurement Configurations help you quickly configure the measurement to perform 3GPP TS 34.121 5.13.1A from the front panel. These settings should be used in conjunction with the existing 34.121 Preset Call Configurations .
  • IQ Gain Imbalance and IQ Phase Imbalance results are now available from the Waveform Quality measurement, via GPIB command only (see Waveform Quality Measurement Description ). Previously, IQ Gain/Phase Imbalance results were only available via the IQ Tuning measurement.

_____________________________________________________________________________________________________

T.01.17 Special Release (E6703T) - March 2007

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the T.01.12 Special Release (E6703T) - December 2006 .

_____________________________________________________________________________________________________

D.01.17 Release (E6703D) - March 2007

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the D.01.12 Release (E6703D) - December 2006 .

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

T.01.12 Special Release (E6703T) - December 2006

The E6703T can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6703T onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6703T meets the E6703D measurement parametric specifications in a temperature range of 25 °C +/- 5 °C, and has an operating temperature range of 0 to 35 °C.

The features and functionality offered in this release are identical to those offered in the D.01.12 Release (E6703D) - December 2006 , with the following key exceptions:

  • The E6703T Special High Data Rate W-CDMA/HSDPA Lab Application (along with the appropriate hardware option) supports the maximum IP data throughput of HSDPA UE categories 1-6, 11 and 12. This allows you to test 3.6 Mbps HSDPA IP data throughput for category 5 and 6 UEs.
  • The E6703T supports the following GPRS Radio Access Bearers. If you attempt to select these RABs in the E6703D, an error is posted. See GPRS Radio Access Bearer .
    • 384k UL/384k DL PS
    • 128k UL/HSDPA DL PS
    • 384k UL/HSDPA DL PS
  • The E6703T (along with the appropriate hardware option) supports enabling compressed mode for 384k downlink channels (if you try to enable compressed mode while on a 384k downlink channel in the E6703D, an error is posted).
  • You must use the LAN 2 PORT for transferring data to the test set.

For information on how to use these E6703T features, see the "E6703T User Documentation" topic in the following CHM Help File (this CHM Help File also includes information on how to use the features that are common to the E6703D and E6703T):

http://www.home.agilent.com/upload/cmc_upload/All/E1963_A10_E6703_D01_T01_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

_____________________________________________________________________________________________________

D.01.12 Release (E6703D) - December 2006

Note that the E6703D Release D.01 includes all of the features and functionality present in the E6703D Subscription Releases which were made available early to Annual Contract owners: D.00.08 Subscription Release (E6703D) - August 2006 and D.00.03 Subscription Release (E6703D) - April 2006 .

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963_A10_E6703_D01_T01_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Two new GPRS Radio Access Bearers are present in the GPRS Radio Access Bearer menu of the E6703D: 128k UL/384k DL PS and 384k UL/384k DL PS . However, the 384k UL/384k DL PS RAB is only accessible in the E6703T with the appropriate hardware option. Attempting to select this RAB in the E6703D causes an error.
  • Range of all Manual Uplink DPCH Bc settings has been returned to 2 to 15.
  • Continuous Ping - The number of pings the test set sends the UE before terminating has been extended from 1000 pings to 217483647 to allow much more time to pass before it needs to be restarted.
  • Support for HSDPA UE categories 7 and 8 (7.2 Mbps) in RB Test Mode. See HSDPA Information .
    • FRC Type can be set to H-Set 6 QPSK and H-Set 6 16QAM.
    • User Defined Number of Active HS-PDSCHs can be set up to 10.
    • Expanded range of RB Test Mode First HS-PDSCH Channel Code parameter to allow for 10 HS-PDSCHs.
    • Manual UE HS-DSCH Category can be set to 7 and 8.
  • Support for Band VII (see Channel (UARFCN) Parameters ). This functionality has specific Hardware Requirements .
  • New Transmit SIB5bis setting.
  • New SRB Configuration Control setting allows automatic configuration of the SRB for RMCs.
  • New CS/PS Domain setting for CN Domain allows establishing an HSDPA RB Test Mode connection with the RMC placed on the CS domain and the FRC placed on the PS Domain.
  • New Uplink 0k DTCH for HSDPA Loopback State parameter.
  • Uplink closed loop power control algorithm and step size can now be changed while on a connection, using a Physical Channel Reconfiguration. See Handover UL CL Power Ctrl Algorithm and Handover UL CL Power Ctrl Step Size .
  • New Uplink TFCI Control and Manual Uplink TFCI settings in FDD test operating mode.
  • All seven of the 34.121 Preset Call Configurations now include setting Maximum Uplink Transmit Power Level to +21 dBm.
  • Radio Bearer Reconfiguration supports handovers from CS/PS Domain HSDPA connections (see CN Domain ).
  • Changed all occurrences of "Handoff" to "Handover" on all screens (no changes to the associated GPIB commands).

Transmitter Measurements

  • Phase Discontinuity measurement now supports HSDPA. New HS-DPCCH Trigger Source and associated settings: HS-DPCCH Trigger Subframe Alignment , HS-DPCCH Trigger Slot Alignment , HS-DPCCH Trigger Subslot Alignment , HS-DPCCH Measurement Step Interval and HS-DPCCH Measurement Step Count .
  • The Fast Device Tune measurement is now supported on the RF OUT ONLY port, and includes a complete front panel user interface. See How Do I Make a Fast Device Tune Measurement? .
  • Waveform quality measurement now supports excluding transient periods on non-HSDPA connections. See Measurement Interval in Non-HSDPA Mode .
  • Inner Loop Power measurement now terminates as soon as an Unable to Cal: Power unstable condition is detected. See Inner Loop Power Troubleshooting . Also, the re-ranging algorithm has been improved to allow greater robustness in detecting UE failures around test set re-ranging periods.

Receiver Measurements

  • *RST setting for Trigger Arm changed to 0 (single) for Loopback BER , Block Error Ratio and HSDPA Block Error Ratio measurements. See SETup:WBERror:CONTinuous , SETup:WBLerror:CONTinuous and SETup:HBLerror:CONTinuous . Behavior of full preset from the front panel is unchanged (a front panel full preset still sets Trigger Arm to Continuous for these three measurements).

Other Features

  • The downlink HARQ0 trigger is transmitted every time data is transmitted by HARQ process 0 (which is every 12 ms when on an FRC). See Trigger Output Setup .

_____________________________________________________________________________________________________

D.00.09 Subscription Release (E6703D) - September 2006

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the D.00.08 Subscription Release (E6703D) - August 2006 .

_____________________________________________________________________________________________________

T.00.08 Special Release (E6703T) - August 2006

The E6703T can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6703T onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6703T meets the E6703D measurement parametric specifications in a temperature range of 25 °C +/- 5 °C, and has an operating temperature range of 0 to 35 °C.

The features and functionality offered in this release are identical to those offered in the D.00.08 Subscription Release (E6703D) - August 2006 , with the following key exceptions:

  • The E6703T Special High Data Rate W-CDMA/HSDPA Lab Application (along with the appropriate hardware option) supports the maximum IP data throughput of HSDPA UE categories 1-6, 11 and 12. This allows you to test 3.6 Mbps HSDPA IP data throughput for category 5 and 6 UEs.
  • Two GPRS Radio Access Bearer s, 128k UL/HSDPA DL PS and 384k UL/HSDPA DL PS , are only accessible in the E6703T with the appropriate hardware option. Attempting to select these RABs in the E6703D causes an error.
  • The E6703T (along with the appropriate hardware option) supports enabling compressed mode for 384k downlink channels (if you try to enable compressed mode while on a 384k downlink channel in the E6703D, an error is posted).
  • You must use the LAN 2 PORT for transferring data to the test set.

For information on how to use these E6703T features, see the "E6703T User Documentation" topic in the following CHM Help File (this CHM Help File also includes information on how to use the features that are common to the E6703D and E6703T):

http://www.home.agilent.com/upload/cmc_upload/All/E6703D_D0008.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Known Issues

  • When using the two-cell test system with one or more E6703T applications, note the following:
    Before establishing an External Device Connection with a remote test set, you must enter the LAN IP Address of the remote test set into the Ext 8960 IP Addr field of the originating test set. If you originate the connection from an E703D application, the LAN IP Address of the originating test set is then displayed in the Connected Device IP Address field of the remote test set.
    However, if you originate the connection from an E6703T application, the Connected Device IP Address displayed on the remote test set is the E703T test set's LAN IP Address 2 (rather than LAN IP Address ). Regardless, do not enter LAN IP Address 2 into the Ext 8960 IP Addr field when connecting to an E6703T test set; the External Device Connection attempt will fail. You must always enter the LAN IP Address into the Ext 8960 IP Addr field.

_____________________________________________________________________________________________________

D.00.08 Subscription Release (E6703D) - August 2006

This is a Subscription Release of the E6703D application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have a current W-CDMA/HSDPA Lab Application Annual Contract to obtain this Subscription Release. Contact your Agilent Sales Representative for more information.

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E6703D_D0008.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Resolved Known Issues

The following known issues have been resolved in this release:

  • When on an HSDPA Packet Data connection:
    • The Current Service Type is reported as PS Data rather than PS Data - HSDPA (and the CALL:STATus:SERVice:TYPe? query returns GPRS rather than PSDH ).
    • The Data Throughput Monitor's OTA graph results contain the MAC-hs throughput (only acknowledged bits are counted, so an increase in NACKs decreases the OTA throughput; this is the same result returned by the HSDPA counters). The OTA graph is intended to display L1 throughput (all bits passed to L1 from MAC-hs are counted).
  • If Current UE HS-DSCH Category is NAN (9.91E+37 or "----") and you try to originate an HSDPA connection when RB Test HS-DSCH Configuration Type is set to User Defined , the test set will assert. If your UE does not report a UE category upon registering with the test set, set UE HS-DSCH Category Control to Manual and set Manual UE HS-DSCH Category to your UE's category before originating an HSDPA connection.

Call Processing

  • Added support for two-cell inter-RAT data cell reselection and Cell Change Order (W-CDMA/HSDPA <--> GSM/GPRS/EGPRS). See Two-Cell Test System .
  • New External 8960 Handover .
  • New Cell Information menu replaces Cell Parameters menu on front panel Call Control 2 of 5 ( F2 ). The Cell Information menu includes the Cell Parameters menu, the new Reselection Parameters menu and the new Access Restriction Parameters menu. Note that the Cell Reselection Parameters menu includes Sintersearch and Sintrasearch , which were moved from the Cell Parameters menu.
  • New SIB11 Cell Info List settings:
    • GSM <num> Cell Cell Reselection Min Rx Level
    • Intra-freq <num> Cell Cell Reselection Offset1
    • Intra-freq <num> Cell Cell Reselection Offset2
    • Inter-freq <num> Cell Cell Reselection Offset1
    • Inter-freq <num> Cell Cell Reselection Offset2
  • Active Cell Compressed Mode enhancements

    The compressed mode feature now allows you to specify up to 4 TGPSs (Transmission Gap Pattern Sequences), versus just one. Each TGPS can have a different measurement purpose, and can include one or two transmission gap lengths. Compressed mode is also now available on all connection types and channel configurations (RMC, AMR, CS Data, PS Data) except 384k RMC and any 384k downlink channel (previously compressed mode was only available on a 12.2k RMC connection). Six compressed mode preset configurations have been added to help you easily configure compressed mode from the front panel. Three new GSM UE measurement results are now available.

    Compressed Mode Parameters: Shared Compressed Mode Parameters

    • New Downlink Frame Structure Type setting.

    Compressed Mode Parameters: TGPS Parameters

    • New <num> TGPS State settings (for First TGPS through Fourth TGPS ).
    • New GPIB command to query the state of the 4 TGPSs: CALL:STATus:COMPressed:TGPSequence:ALL:STATe? .
    • New <num> TG Measurement Purpose (TGMP) settings (for First TGPS through Fourth TGPS ). These settings replace the previous Compressed Mode Measurement Purpose setting (however for backwards-compatibility the CALL:COMPressed:MEASurement:TYPe command is still available, now includes GIBI and GBR , and can be used to set the First TG Measurement Purpose (TGMP) ).
    • New <num> TG Starting Slot Number (TGSN) settings (for First TGPS through Fourth TGPS ).
      Existing command to set Transmission Gap Starting Slot Number (TGSN) , CALL:COMPressed:TGPSequence:TGSNumber , has been expanded to: CALL:COMPressed:TGPSequence([1]|2|3|4):TGSNumber .
      New GPIB command to set the TGSN for all of the TGPSs: CALL:COMPressed:TGPSequence:ALL:TGSNumber <num value>, <num value>, <num value>, <num value> .
    • New <num> TG Pattern Length (TGPL) settings (for First TGPS through Fourth TGPS ).
      Existing command to set Transmission Gap Pattern Length (TGPL) , CALL:COMPressed:TGPSequence:TGPLength , has been expanded to: CALL:COMPressed:TGPSequence([1]|2|3|4):TGPLength .
      New GPIB command to set the TGPL for all of the TGPSs: CALL:COMPressed:TGPSequence:ALL:TGPLength <num value>, <num value>, <num value>, <num value> .
    • New <num> Transmission Gap Length 1 (TGL1) settings (for First TGPS through Fourth TGPS ).
      Existing command to set Transmission Gap Length (TGL), CALL:COMPressed:TGPSequence:TGLength , has been expanded to: CALL:COMPressed:TGPSequence([1]|2|3|4):TGLength[1] .
      New GPIB command to set the TG Length 1 (TGL1) for all of the TGPSs: CALL:COMPressed:TGPSequence:ALL:TGLength[1] <num value>, <num value>, <num value>, <num value> .
    • New <num> Transmission Gap Length 2 (TGL2) settings (for First TGPS through Fourth TGPS ).
    • New <num> TG Start Distance (TGD) settings (for First TGPS through Fourth TGPS ).
    • New <num> TG Relative CFN (TGCFN) settings (for First TGPS through Fourth TGPS ).
    • New <num> TG Pattern Repetition Count (TGPRC) settings (for First TGPS through Fourth TGPS ).

    UE Measurements Setup

    • New Measurement Configuration setting.
    • New GSM Meas BSIC Verification setting.
    • New GSM Meas N_Identify_Abort setting.
    • New GSM Meas T_Re_Confirm_Abort (x0.5 seconds) setting.

    New Compressed Mode Measurement Results:

    • Inter-RAT Cell ID .
    • BSIC Verification .
    • BSIC Value .
  • FDD Test Mode Compressed Mode enhancements
    • New <num> TG Starting CFN settings (for First TGPS through Fourth TGPS ).
      New GPIB command to set Starting CFN for an individual TGPS: CALL:FDDTest:COMPressed:TGPSequence([1]|2|3|4):SCFNumber .
      New GPIB command to set the Starting CFN for all of the TGPSs: CALL:FDDTest:COMPressed:TGPSequence:ALL:SCFNumber <num value>, <num value>, <num value>, <num value> .
      For backwards-compatibility, the existing command to set Starting CFN , CALL:FDDTest:COMPressed:SCFNumber , is still available and can be used to set the First TG Starting CFN .
  • New UE-to-8960LAN Video Call feature. The Synchronous/Transparent CS Data Service in the test set now supports UE-to-8960LAN video calls (previously it only supported UE-to-UE video calls using two test sets and two UEs). The UE-to-8960LAN video call feature is used to establish a 3G-324M video call between a UE and an external device using a single test set (the test set is used to establish a call with the UE and then route the data on the bearer to/from an external device via its LAN Port ). The UE-to-8960LAN video call can be originated by the UE or by the external device.
  • New Video Call Type parameter.
  • New Transmit SIB5bis setting.
  • Two GPRS Radio Access Bearer s previously only present in the E6703T, 128k UL/HSDPA DL PS and 384k UL/HSDPA DL PS , are now present in the GPRS Radio Access Bearer menu of the E6703D. However, they are still only accessible in the E6703T with the appropriate hardware option. Attempting to select these RABs in the E6703D causes an error.
  • New Uplink TFCI Control and Manual Uplink TFCI settings in FDD test operating mode.
  • New 34.121 Preset Call Configurations make it much simpler to configure the test set for 3GPP TS 34.121 HSDPA tests from the front panel.
  • New Radio Bearer Reconfiguration allows handovers from a CS Domain HSDPA RB Test Mode connection to a (non-HSDPA) symmetrical RMC.
  • System Handover now supported on CS domain HSDPA RB Test Mode connections.
  • New parameters added for HSDPA Transport Channel Reconfiguration: TCR Number of HARQ Processes , TCR UE IR Buffer Allocation and TCR Explicit UE IR Buffer Size .
  • New Paging Parameters menu replaces Paging IMSI on front panel Call Control 1 of 4 ( F4 ). The Paging Parameters menu includes Paging IMSI and the following settings which were moved from the Cell Parameters menu: CS Paging Identity Type , TMSI Assignment , TMSI and Repeat Paging .

Transmitter Measurements

  • Fast Device Tune measurement (see Fast Device Tune Measurement Description ). This feature was also previously available in the E6703C C.04.06 release. An additional feature license is required to enable this functionality in a licensed test application. This feature does not require a feature license in the lab application. See www.agilent.com/find/8960upgrades for more information.

_____________________________________________________________________________________________________

C.04.06 Release (E6703C) - July 2006

The E6703C Release C.04 includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.09.06 (see A.09.06 Release - July 2006 ). The unique features of the E6703C Lab Application are indicated below.

A downloadable version of the Online User's Guide (CHM Help File) is available that is specific to this release, (however, the CHM Help File also includes documentation for the following HSDPA Packet Switched Data parameters that are only available in the E6703D: GPRS Radio Access Bearer of 64k UL/HSDPA DL PS , Current Service Type of PS Data - HSDPA , PS Data First HS-PDSCH Channel Code , HSDPA DPCH 15 ksps (OVSF 256) Channelization Code and PS Data Configuration Type settings):

http://www.home.agilent.com/upload/cmc_upload/All/E1963A_A09_E6703C_C04_D00_T00.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

NOTE
The settable ranges for CALL:CHANnel and CALL:UPLink:CHANnel have changed due to changes in 3GPP TS 25.101. Some channels are no longer available. See the Requirements information at CALL:CHANnel and CALL:UPLink:CHANnel:CHANnel for more information.

  • Protocol Logging is now available while on an HSDPA connection.
  • New Cell Information menu replaces Cell Parameters menu on front panel Call Control 2 of 4 ( F2 ). The Cell Information menu includes the Cell Parameters menu and the new Reselection Parameters menu. The Reselection Parameters menu includes the following settings which were moved from the Cell Parameters menu: Sintersearch and Sintrasearch .

_____________________________________________________________________________________________________

T.00.04 Special Release (E6703T) - May 2006

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the T.00.02 Special Release (E6703T) - April 2006 .

_____________________________________________________________________________________________________

T.00.02 Special Release (E6703T) - April 2006

The E6703T can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6703T onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6703T meets the E6703D measurement parametric specifications in a temperature range of 25 °C +/- 5 °C, and has an operating temperature range of 0 to 35 °C.

The features and functionality offered in this release are identical to those offered in the D.00.03 Subscription Release (E6703D) - April 2006 , with the following key exceptions:

  • The E6703T Special High Data Rate W-CDMA/HSDPA Lab Application (along with the appropriate hardware option) supports the maximum IP data throughput of HSDPA UE categories 1-6, 11 and 12. This allows you to test 3.6 Mbps HSDPA IP data throughput for category 5 and 6 UEs.
  • New GPRS Radio Access Bearers: 128k UL/HSDPA DL PS or 384k UL/HSDPA DL PS .
  • You must use the new LAN 2 PORT for transferring data to the test set.

For information on how to use these E6703T features, see the "E6703T User Documentation" topic in the following CHM Help File (this CHM Help File also includes information on how to use the features that are common to the E6703D and E6703T):

http://www.home.agilent.com/upload/cmc_upload/All/E6703D_D0003.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Resolved Known Issues

The following E6703D known issues have been resolved in the E6703T:

  • When on an HSDPA Packet Data connection, the Data Throughput Monitor's OTA graph results contain the MAC-hs throughput.
  • If Current UE HS-DSCH Category is NAN (9.91E+37 or "----") and you try to originate an HSDPA connection when RB Test HS-DSCH Configuration Type is set to User Defined , the test set will assert.

_____________________________________________________________________________________________________

D.00.03 Subscription Release (E6703D) - April 2006

This is a Subscription Release of the E6703D application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have a current W-CDMA/HSDPA Lab Application Annual Contract to obtain this Subscription Release. Contact your Agilent Sales Representative for more information.

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E6703D_D0003.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Known Issues

  • Manual Uplink DPCH Bc and RB Test Mode TCR Manual Uplink DPCH Bc parameters can be set to 1, and a value of 1 is signalled to the UE. However, the underlying functionality to support this configuration is not fully implemented in the test set. As a result, connections made in this configuration are unstable.
  • When on an HSDPA Packet Data connection:
    • The Current Service Type is reported as PS Data rather than PS Data - HSDPA (and the CALL:STATus:SERVice:TYPe? query returns GPRS rather than PSDH ).
    • If the PS Data Configuration Type you've entered requires a "Reference Power Adjustment" as per 3GPP TS 25.214, the test set adjusts the power in the HS-PDSCHs accordingly. However, the Current Sum of Active HS-PDSCHs value present on the Generator Information screen is not updated.
    • The HS-SCCH and HS-PDSCH Conn Desired values on the Generator Information screen always show a value of Off , regardless of the HSDPA Connected DL Channel Levels .
    • The Data Throughput Monitor's OTA graph results contain the MAC-hs throughput (only acknowledged bits are counted, so an increase in NACKs decreases the OTA throughput; this is the same result returned by the HSDPA counters). The OTA graph is intended to display L1 throughput (all bits passed to L1 from MAC-hs are counted).
    • If your test configuration causes a high HSDPA BLER (for example, due to a high level of AWGN or a high CQI Value ), throughput may drop to zero. If ending and re-establishing the connection does not solve the problem, you must change your configuration so as to lower HSDPA BLER.
    • The E6703D's HSDPA packet data service allows packet data connections to be established with HSDPA UEs of category 1-6, 11 and 12. However, it does not support the maximum throughput of all of these UE categories. Actual throughput achieved depends on many variables such as the number of sessions established and the type of PS application used. However, the E6703T Special High Data Rate W-CDMA/HSDPA Lab Application (along with the appropriate hardware option) does support the maximum throughput of categories 1-6, 11 and 12 (3.6 Mbps for UE categories 5 and 6). Contact your local Agilent sales representative for more information regarding the E6703T.
  • If Current UE HS-DSCH Category is NAN (9.91E+37 or "----") and you try to originate an HSDPA connection when RB Test HS-DSCH Configuration Type is set to User Defined , the test set will assert. If your UE does not report a UE category upon registering with the test set, set UE HS-DSCH Category Control to Manual and set Manual UE HS-DSCH Category to your UE's category before originating an HSDPA connection.

Call Processing

NOTE
The settable ranges for CALL:CHANnel and CALL:UPLink:CHANnel have changed due to changes in 3GPP TS 25.101. Some channels are no longer available. See the Requirements information at CALL:CHANnel and CALL:UPLink:CHANnel:CHANnel for more information.

  • Support for HSDPA Packet Switched Data . See also HSDPA in Active Cell Operating Mode .
    • New GPRS Radio Access Bearer of 64k UL/HSDPA DL PS .
    • New Current Service Type of PS Data - HSDPA .
    • New PS Data First HS-PDSCH Channel Code setting.
    • New HSDPA DPCH 15 ksps (OVSF 256) Channelization Code setting (see HSDPA/HSPA DL Channel Codes ).
    • New PS Data Configuration Type setting.
  • New Current UE HS-DSCH Category .
  • New UE Category Parameters .
  • Protocol Logging is now available while on an HSDPA connection. While the WPA supports protocol logging while on an HSDPA data channel connection, logging is not supported at full data rates. It is not guaranteed that all protocol messages between the DUT and the test set will be captured for high data throughput rates and therefore recommended that you do not use the WPA for CQI values greater than 5. The `CQI Value' setting can be accessed on the test set by pressing `HSDPA Parameters' (F10) from the Call Setup screen, then `HSDPA PS Data Setup' (F7).
  • Support for 3GPP TS 25.101 v7.2.0 channel changes: addition of Band VIII and Band IX, renumbering of Band III and Band IV.
    • New DL Channel and Uplink Channel ranges.

      NOTE
      The settable ranges for CALL:CHANnel and CALL:UPLink:CHANnel have changed due to changes in 3GPP TS 25.101. Some channels are no longer available. See the Requirements information at CALL:CHANnel and CALL:UPLink:CHANnel:CHANnel for more information.

    • New Band Arbitrator setting (replaces Uplink Separation (Band) setting).
    • New Handover Band Arbitrator setting (replaces Handoff Uplink Separation (Band) setting)
  • New user defined downlink channel for HSDPA RB Test Mode (see User Defined Configuration of the HS-DSCH ) and HSDPA FDD Test Mode (see HS-DSCH Parameters ).
  • New FRC MAC-d PDU Size setting.
  • Physical Channel Reconfiguration now supported on HSDPA RB Test Mode and HSDPA Packet Data connections.
  • Transport Channel Reconfiguration enhanced to include the following new parameters: TCR DPCH Bc/Bd Control , TCR Manual Uplink DPCH Bc , TCR Manual Uplink DPCH Bd , TCR Default DPCH Offset (DOFF) and TCR Relative DPCH Frame Offset .
  • Manual Uplink DPCH Bc parameter can be set to 1 (previously the range was 2 to 15). However, the underlying functionality to support this configuration is not fully implemented in the test set. As a result, connections made in this configuration are unstable.
  • Transport Channel Reconfiguration is now supported on an HSDPA RB Test Mode connection. New parameters added for HSDPA Transport Channel Reconfiguration: TCR DeltaACK , TCR DeltaNACK , TCR DeltaCQI , TCR Ack-Nack Repetition Factor , TCR CQI Feedback Cycle (k) , and TCR CQI Repetition Factor .
  • New Current DPCH Offset .
  • New DPCH Frame Offset setting (FDD test operating mode only).
    This setting replaces the use of Default DPCH Offset (DOFF) in FDD Test operating mode (previously, you could use the Default DPCH Offset (DOFF) setting to control the DPCH Frame Offset in FDD Test mode; Default DPCH Offset (DOFF) is now only available in active cell operating mode).
  • New Network Mode of Operation setting. Previously Network Mode of Operation was signalled by the test set with a fixed value of 2. You may now set the value of this Information Element to either 1 or 2. Note, the default setting for Network Mode of Operation is 1, which is different from the fixed value previously sent by the test set.

Transmitter Measurements

  • Waveform quality, code domain and IQ tuning measurements now support HSDPA (see Waveform Quality Measurement Description , Code Domain Measurement Description and IQ Tuning Measurement Description ). When Trigger Source is set to HS-DPCCH , many new settings and results are available.
    • Trigger Source range now includes HS-DPCCH .
    • New Transient Period setting.
    • New HS-DPCCH Trigger Subframe Alignment setting.
    • New HS-DPCCH Trigger Slot Alignment setting.
    • New HS-DPCCH Trigger Subslot Alignment setting.
    • New HS-DPCCH Measurement Interval setting.
    • New Beta hs-acknack and Beta hs-cqi results.
  • Phase discontinuity measurement enhancements (see Phase Discontinuity Measurement Description ).
    • New 18 up and 18 down settings for Power Control Pattern .
    • New peak EVM results (via remote access only). Previously only rms EVM results were available.

Other Features

  • Previously, the downlink HARQ0 trigger occurred every time data was transmitted by HARQ process 0 (which is every 12 ms when on an FRC). The downlink HARQ0 trigger is now only transmitted when the HARQ0 process is aligned with the 10 ms system frame clock (which is every 60 ms when on an FRC). See Trigger Output Setup .
  • New Thermal Power Null Adjust user calibration. This calibration only affects the Thermal Power measurement. Perform this calibration once a month if you are using the Thermal Power measurement.
    GPIB command: SYSTem:INSTrument:THERmal:POWer:NULL:ADJust? (0 = success, 1 = failure).

_____________________________________________________________________________________________________

C.03.11 Release (E6703C) - January 2006

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963A_A0820_E6703C_C03_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

The E6703C Release C.03.11 includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.08.09 and A.08.31 (see A.08.09 Release - August 2005 and A.08.31 Release - January 2006 ). The unique features of the E6703C Lab Application are indicated below.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

NOTE
The settable ranges for CALL:CHANnel and CALL:UPLink:CHANnel have changed. Some channels are no longer available. See the Requirements information at CALL:CHANnel and CALL:UPLink:CHANnel:CHANnel for more information.

  • New HTTP interface for cell broadcast SMS (see HTTP Interface for Cell Broadcast Service - Introduction )
  • Multi-page and binary cell broadcast SMS - cell broadcast functionality has been enhanced to allow messages up to 15 pages in length to be transmitted. Support has also been added for messages that contain binary data. For more information, see Cell Broadcast Service (CBS) .
    • New parameters: CTCH Allocation Period , CBS Frame Offset , Message Code , Data Coding Scheme Specification , Data Coding Scheme Value , Geographical Scope (GS) , Repetition Period .
    • New RUI-only parameters accessible through the following GPIB commands: CALL:SMService:CBRoadcast:MESSage[<n>]:CDATa , CALL:SMService:CBRoadcast:MESSage[<n>]:CTEXt .
    • New GPIB commands to replace obsoleted commands: CALL:SMService:CBRoadcast:MESSage[<n>]:DCSCheme:LANGuage , CALL:SMService:CBRoadcast:MESSage[<n>]:CONTent .
  • New T3212 Periodic Location Update Timer parameter.
  • New DNS Server IP Addresses .
  • New Access Point Name Settings .
  • Support for HSDPA fading (see Digital Bus Information ).

_____________________________________________________________________________________________________

C.02.25 Release (E6703C) - May 2005

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963A_A07_E6703C_C02_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

The E6703C Release C.02.25 includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.07.25 (see A.07.25 Release - May 2005 ). The unique features of the E6703C Lab Application are indicated below.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • New CM PCR Timing Indication (CFN Handling) setting.
  • New Sintersearch and Sintrasearch settings.

_____________________________________________________________________________________________________

C.01.17 Release (E6703C) - January 2005

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963A_A06_E6703C_C01_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

The E6703C Release C.01.17 includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.06.17 (see A.06.17 Release - January 2005 ). The unique features of the E6703C Lab Application are indicated below.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Short Message Service (SMS)
  • Calling Party Number (see Calling Party Number Parameters ).
  • UE-reported SFN-SFN Observed Time Difference (OTD) ).
  • Activate PDP Context Reject SM Cause .

Transmitter Measurements

  • Change Of TFC measurement (see Change of TFC (Transport Format Combination) Measurement Description ).
  • Out-of-Synch Handling of Output Power measurement (see Out-of-Synch Handling of Output Power Measurement Description ).

Other Features

  • Supports signal fading. For details, download the:

    E5515C Fading Solution Application Guide

    (available at http://cp.literature.agilent.com/litweb/pdf/1000-1894.pdf ).

_____________________________________________________________________________________________________

B.01.34 Release (E6703B) - July 2004

The E6703B Release B.01.34 includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.05.33 (see A.05.33 Release - July 2004 ). The unique features of the E6703B Lab Application are indicated below.

Resolved Known Issues

  • Assert if UE attempts to register while RB Test Mode RRC State Setting is CELL_FACH .
  • Cell 1 output power level affected by state of Cell 2 Power setting.

_____________________________________________________________________________________________________

B.01.29 Release (E6703B) - April 2004

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963A_A0528_E6703B_B0129_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

The E6703B Release B.01.29 includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.05.28 (see A.05.28 Release - April 2004 ). The unique features of the E6703B Lab Application are indicated below.

Summary of GPIB command changes for this release: GPIB Changes for E1963A A.05.20, E6703B B.01.20 - April 2004

Resolved Known Issues

  • No uplink power control on packet data connection.

_____________________________________________________________________________________________________

B.01.16 Release (E6703B) - January 2004

The functionality present in the B.01.16 release is identical to that in the B.01.14 release (see B.01.14 Release (E6703B) - January 2004 and GPIB Changes for E1963A A.05, E6703B B.01 - December 2003 ).

_____________________________________________________________________________________________________

B.01.14 Release (E6703B) - January 2004

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963A_A05_E6703B_B01_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

The E6703B Release B.01.14 includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.05.14 (see A.05.14 Release - January 2004 ). The unique features of the E6703B Lab Application are indicated below.

Summary of GPIB command changes for this release: GPIB Changes for E1963A A.05, E6703B B.01 - December 2003

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Call origination to CELL_FACH state via new RB Test Mode RRC State Setting .
  • Data channel:
    • New 64k PS UL/384k PS DL GPRS DPCH RAB (see Packet Switched Data ).
    • New asynchronous/non-transparent CS data service (see Circuit Switched Data Service ).
  • Compressed mode operation including GSM and inter frequency neighbor cell measurement reporting (see Compressed Mode ).
  • New Call Setup Screen layout:
    • Call Processing Status area includes new Soft Handover State , Compressed Mode State , and RRC State .
    • UE reported measurement results available from Soft Handoff Information screen only (no longer available from main Call Setup Screen ). See UE Reported Measurements and How Do I Order and Retrieve UE Reported Measurement Results? .
  • Soft Handover functionality now accessible via new Handoffs menu.

Transmitter Measurements

  • PRACH Preamble Analysis. See PRACH Preamble Analysis Measurement Description .

Instruments

  • Data Throughput Monitor. See Data Throughput Monitor Description .

_____________________________________________________________________________________________________

A.02.10 Release (E6703A) - July 2003

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1963A_A04_E6703A_A02_Ref_Guide.chm

NOTE: To properly view the CHM Help File, you must save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties>>Unblock.

The E6703A Release A.02.10 includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.04.10 (see A.04.10 Release - July 2003 ). The unique features of the E6703A Lab Application are indicated below.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • AMR Voice service RAB configuration. See AMR Setup , CALL:PAGing:SERVice[:TYPE] and CALL:SERVice:AMR:RAB .
  • Supports Data Channel GPRS Radio Access Bearer 64k UL/384k DL DPCH. See CALL:SERVice:GPRS:RAB .
  • Detected PRACH Signature - The test set detects which PRACH signature is used by the UE and returns an integer representing that signature. See Detected PRACH Signature .
  • PRACH Signature Mask - a 16-bit mask to specify which of the 16 PRACH preamble signatures are available to the UE. See PRACH Signature and CALL:UPLink:PRAChannel:SMASk .
  • Attached State reported. See GMM State and CALL:STATus[:GMM]:ATTached:STATe? .

_____________________________________________________________________________________________________

A.01.20 Release (E6703A) - February 2003 (Initial Lab Application Release)

The reference guide for this release is available at the following web location. Note, this is a 12.9 MB .pdf file.

http://cp.literature.agilent.com/litweb/pdf/1000-1864.pdf

These are the original features of the Agilent E6703A.

The E6703A Release A.01.20 includes all of the features and functionality present in the E1963A W-CDMA Test Application Release A.03.20 (see A.03.20 Release - February 2003 ). The unique features of the E6703A Lab Application are indicated below.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Call Processing

  • Protocol Logging: (see Protocol Logging )

    The E6703A Lab Application enables the test set to capture the exchange of control and data information between the test set and a UE (user equipment). Captured information is forwarded to a software application that runs on a personal computer under the Windows operating system.

    The software application is referred to as the WPA (Wireless Protocol Advisor). It is tailored for the capture, display, and analysis of message exchange protocols between the test set (emulating a base station), and a UE.

  • Data Channel: (see Data Channel )

    The data channel feature allows you to use the test set as a router while you exchange data between the UE and remote servers.

  • Soft Handoff: (see Soft Handover )

    The E6703A Lab Application includes two sectors which allow you to perform a soft handoff. The lab application also supports event reporting.


Troubleshooting Soft Handover

Troubleshooting Soft Handover

Last updated: January 16, 2009

This section is only applicable to the lab application.

Possible Setup Issues

  • Some UEs require Cell 2 Primary Scrambling Code = Intra Freq 2nd Cell Scrambling Code

    When ordered to perform a soft handover with a cell, some UEs require that they have previously measured the cell before handing off to it. When the UE is directed to perform measurements on the neighbor cells specified in SIB 11 (see SIB11 Cell Info List ), it should also report measurement results for any other detected cells not on the neighbor list. However some UEs may require that the cell be in the neighbor list in order to perform measurements on it. Thus, some UES require that cell 2 be in the neighbor list for soft handover to be successful.

  • Cell 2 Power is on, but no Mobile Station Reported Pilot Level Information is being displayed for Cell 2

    To aid in the UE's detection of cell 2, ensure that cell 2's primary scrambling code is included in the intra frequency neighbor cell list (see Cell 2 Overview and SIB11 Cell Info List ), and that cell 2's power is high enough to be detected (you may need to set it to a value higher than cell 1).

  • Soft handover is not supported on a CELL_FACH call (see RB Test Mode RRC State Setting ).
  • Soft handover and Event Reporting are not supported on HSDPA connections. However, you can turn Cell 2 on while on an HSDPA connection.
  • Soft handover is supported for HSUPA connections but only to simulate a network scenario for when a UE performs a soft handover with cell 2 but the HSUPA channels remain confined to the cell 1 (serving cell). When an HSUPA call is established between the test set's cell 1 and the UE and you turn soft handover on, the DPCH is instructed to soft handover to cell 2 while the HSUPA channels remain confined to cell 1.

Related Topics

Soft Handover