What's New in the User's Guide?

  • This manual supports the E1985x fast switching test applications and the E6785x fast switching lab applications.
  • Added new E1985E cdma2000_1xEV-DO fast switching test application Revision E.01.
  • Updated for E1985B Revision A.04, E1985C Revision C.02, and E6785B Revision B.01

Take Advantage of your Fast Switching Applications

Use the Contents and Search tabs to find specific information about your test and lab applications. For a description of the fast switching applications, click on the Fast Switching Description on the Contents.

The User's Guide is updated frequently. Check the web monthly to verify that you have the latest version of this guide:

http://www.agilent.com/find/e1985d

(choose "Manuals, Guides & Notifications" under "In the Library")

© Agilent Technologies, Inc. 2002


Legal Information

Acknowledgements

Microsoft ® is a U.S. registered trademark of Microsoft Corporation

Windows ® and MS Windows ® are U.S. registered trademarks of Microsoft Corporation.

Adobe ® Acrobat ® are trademarks of Adobe Systems Incorporated.

Notice

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as "Commercial computer software" as defined in DFAR 252.227-7014 (June 1995), or as a "commercial item" as defined in FAR 2.101(a) or as "Restricted computer software" as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

© Agilent Technologies, Inc. 2001


Release Notes

Release Notes

Last updated: November 5, 2003


Programming

Programming

Last updated: November 5, 2003

Getting Started

  • Programming: Getting Started Guide


GPIB Commands

GPIB Commands

Last updated: November 13, 2003

GPIB command syntax for the E1985B GSM/GPRS_AMPS/136_W-CDMA, E1985C GSM/GPRS_cdma2000/IS-95/AMPS, E1985E cdma2000/IS-95/AMPS_1xEV-DO and E6785B GSM/GPRS_W-CDMA fast switching applications is identical to the syntax for the E1968A GSM/GPRS, E1961A AMPS/136, E1962B cdma2000/IS-95/AMPS, E1963A W-CDMA, and E1966A 1xEV-DO Mobile Test Applications, as well as the E6701C GSM/GPRS and the E6703A W-CDMA Lab Applications. For details on the specific format's syntax, click:

  • GSM/GPRS GPIB commands
  • AMPS/136 GPIB commands
  • W-CDMA commands
  • cdma2000/IS-95/AMPS GPIB commands
  • 1xEV-DO GPIB commands

Some of the GPIB commands are shared between formats in the fast switching applications. Therefore to identify which format the command is to be implemented on the test set requires a format mnemonic at the end of the command (:SELected, :GSM, :GPRS, :TA136, :DIGital136, :DIGital95, :DIGital2000, :TA2000, :DIGital856, :TA856, :FDD and :WCDMa). If you do not add a format mnemonic to a shared command, the command is sent to the active format. If you want to change a command in the inactive format you must use a mnemonic.

The following GPIB subsystems are shared between formats. For details, click:

  • ABORt Commands with Format Mnemonics
  • CALL Commands with Format Mnemonics
  • FETCh Commands with Format Mnemonics
  • INITiate Commands with Format Mnemonics
  • READ Commands with Format Mnemonics
  • RFANalyzer Commands with Format Mnemonics
  • SETup Commands with Format Mnemonics
  • SYSTem:FTRigger Commands with Format Mnemonics

For details of the format switching commands, click:

  • SYSTem:APPLication:FORMat[:NAME]


Fast Switching Application Description

Fast Switching Application Description

Last updated: November 13, 2003

Click on the link below for a description of the fast switching applications, or click on the links to the left to find specific information.

  • E1985B GSM/GPRS_AMPS/136_W-CDMA Fast Switching Mobile Test Application


How Do I Switch Formats?

How Do I Switch Formats?

Last updated: November 5, 2003

A. Choose a format.

  1. Press the SYSTEM CONFIG key.
  2. Press the Format Switch ( F2 ) key.

B. Switch formats.

  1. Turn the knob to highlight the desired format.

  2. Press the knob to switch formats.

Related Topics

SYSTem:APPLication


E1985E cdma2000/IS-95/AMPS_1xEV-DO Fast Switching Mobile Test Application

E1985E cdma2000/IS-95/AMPS_1xEV-DO Fast Switching Mobile Test Application

Last updated: November 13, 2003

This section contains details on the following:

  • Overview
  • Differences between Format Switching and Application Switching
  • Application Revision and Licensing Requirements
  • Power Up Format
  • GPIB Commands for Switching Formats GPIB Commands for Switching Formats
  • Test Set States When Switching Format
  • Error Message Log When Switching Format
  • Distinguishing between Formats with Common Command Syntax

Overview

The Agilent Technologies E1985E cdma2000/IS-95/AMPS_1xEV-DO Fast Switching Mobile Test Application combines the measurements and features from the E1962B cdma2000/IS-95/AMPS and the E1966A 1xEV-DO Mobile Test Applications into a single fast switching application. The E1985E application allows you to switch between IS-2000/IS-95/AMPS and IS-856 formats very quickly (see How Do I Switch Formats? ).

The E1985E application significantly reduces test times to meet your demands for testing IS-2000/IS-95/AMPS and IS-856 multi-format wireless appliances. You can send programming commands to an idle format while testing an active format to further minimize setup and test times. A format selected in a fast switching application becomes the active format. All other formats at this time are inactive.

If you need operating details about a particular format, refer to the appropriate reference information:

  • E1962B cdma2000 Online User's Guide
  • E1966A 1xEV-DO Online User's Guide

Differences between Format Switching and Application Switching

Format Switching allows you to fast switch between formats that are bundled in one fast switching application. The E1985E cdma2000/IS-95/AMPS_1xEV-DO application contains versions of IS-2000/IS-95/AMPS and IS-856 formats and allows you to rapidly switch between them. However, you must hold a license for the desired format to be able to switch to that format. Select the SYSTEM CONFIG , then the Format Switch ( F2 ) for viewing and switching formats within the E1985E. See How Do I Switch Formats? .

Application Switching (which is significantly slower than format switching) does not require the E1985E application. However, to perform Application Switching, you must have more than one application installed in your test set to switch between these applications (for example, E1962B cdma2000/IS-95/AMPS and the E1966A 1xEV-DO application). Application switching is simply switching between individual applications. The applications that are currently installed in your test set can be viewed and switched by pressing the SYSTEM CONFIG . Select the Application Selection ( F3 ), then the Application Switch ( F1 ) for viewing and switching applications.

Application Revision and Licensing Requirements

You must have application licenses installed in your test set for each application you want to switch between. Refer to the following diagrams for details on the licenses you require to switch between formats.

Once you install the E1985E application, there is no need to upgrade the individual applications. You only need to upgrade the E1985E application as this contains the latest revisions of the individual applications that you have licensed. Note that if you want to revert back to your earlier revision of an individual application, you have to perform a slower application switch to do this. The E1985E application is not using your previously installed earlier revision individual applications. The E1985E is a self-contained application which combines the latest revision of the available formats into one application.

If you are not able to switch formats, check the test set to see that the formats you are trying to switch between are licensed. License information for each format within the E1985E can be viewed from the SYSTEM CONFIG screen, by selecting the Format Switch ( F2 ). The letter indicating the license status of each format is shown in the License column on the right side of the screen. The license status is either; Licensed "L", Not Licensed "N", or Unknown "U":

  • "L"- A Licensed revision of this application is present. This means that you can switch to this format.
  • "N" - You do not have a licensed revision of this application. This means that you will not be able to switch to this format. If you select a revision which is Not Licensed, the following error message will be displayed: +133 Configuration error; Selected Partition is not licensed (License = N).
  • "U" - This application revision has Unknown license status.

Power Up Format

The format the E1985E application powers up in depends on the licenses that are present on the test set. The E1985E will boot up into the first available licensed Test Application Partition that is present according to the following order: IS-2000/IS-95/AMPS, IS-856. When the E1962B cdma2000/IS-95/AMPS format license is present, the test set selects the IS-2000/IS-95/AMPS format at power up as the active format.

GPIB Commands for Switching Formats

To perform a format switch or query the name of the currently active format, use the command SYSTem:APPLication:FORMat[:NAME] .

To query the license status of any of the formats, use the command SYSTem:APPLication:FORMat:LICense? '<format name>' .

To query the names of all the formats which are available, use the command SYSTem:APPLication:CATalog:FORMat? .

To query the total number of formats which are available, use the command SYSTem:APPLication:CATalog:FORMat:COUNt? .

For further details on these commands and other SYSTem:APPLication commands, see SYSTem:APPLication .

Test Set States When Switching Format

Switching formats affects the test set in the same way that a partial preset does.

Full and partial presets affect all formats included in the fast switching application whether or not the format is active.

For more details on what happens to the test set during a partial preset, see Preset Descriptions .

The following key functions are affected by a format switch:

  • The current call/connection is terminated
  • Measurements are deactivated

The following key functions are not affected by a format switch:

  • Most Call/data connection setup parameters
  • Most measurement parameters
  • Test set setup parameters

Error Message Log When Switching Format

The error message log is not cleared when you switch formats with the fast switching application. All error messages are shown in the error message log, they are not separated by format.

Distinguishing between Formats with Common Command Syntax

Some of the GPIB commands in the CALL, RFANalyzer and SETup subsystems are shared between formats in the E1985E fast switching application. You use additional nodes known as Format Mnemonics (:SELected, :TA2000, :DIGital2000, :DIGital95, :TA856 and :DIGital856) to clarify the format that you want the command to apply to. If you don't add a format mnemonic to a shared command, the command is sent to the active format. You must use a format mnemonic to send a command to an inactive format.

  • For more details on the shared CALL commands, see CALL Commands with Format Mnemonics .
  • For more details on the shared RFANalyzer commands, see RFANalyzer Commands with Format Mnemonics .
  • For more details on the shared SETup commands, see SETup Commands with Format Mnemonics .


E6785x GSM/GPRS_W-CDMA Fast Switching Lab Application Revision Information

E6785x GSM/GPRS_W-CDMA Fast Switching Lab Application Revision Information

Last updated: November 13, 2003

This document lists revision information about the Agilent Technologies E6785x GSM/GPRS_W-CDMA fast switching lab applications. For more information about the E6785x application, see E6785B GSM/GPRS_W-CDMA Lab Application (Fast Switching) .

This document contains the original features, as well as enhancements that have been added over time. Select the appropriate link below to view the required release.

  • B.01 Release - December 2003
  • A.02 Release - June 2003
  • A.01 Release - February 2003

B.01 Release - December 2003

This release updates the GSM/GPRS_W-CDMA fast switching lab application with the equivalent features of the following lab applications.

Revision B.01 Equivalent Functionality
E6701C GSM/GPRS Lab Application | E6703B W-CDMA Lab Application
C.03 | B.01

A.02 Release - June 2003

This release updates the GSM/GPRS_W-CDMA fast switching lab application with the equivalent features of the following lab applications.

Revision A.02 Equivalent Functionality
E6701C GSM/GPRS Lab Application | E6703A W-CDMA Lab Application
C.02 | A.04

A.01 Release - February 2003

This is the initial release of the GSM/GPRS_W-CDMA fast switching lab application. You must have licensed revisions of E6701C GSM/GPRS Lab Application and E6703A W-CDMA Lab Application before fast switching will work.

The A.01 revision of the GSM/GPRS_W-CDMA fast switching lab application has the equivalent capabilities of revision C.01 E6701C GSM/GPRS Lab Application and revision A.03 E6703A W-CDMA Lab Application.

Revision A.01 Equivalent Functionality
E6701C GSM/GPRS Lab Application | E6703A W-CDMA Lab Application
C.01 | A.03


ABORt Commands with Format Mnemonics

ABORt Commands with Format Mnemonics

Last updated: November 5, 2003

Some of the ABORt commands are common between the formats in the fast switching applications. Therefore to identify which format the command is to be implemented on the test set requires a format mnemonic at the end of the command. This format mnemonic is simply an extension to the command

It is possible not to use a format mnemonic. This is the same as using the optional [:SELected] format mnemonic. This would mean that the command is sent to the active format. The advantage of using a format mnemonic with these common commands, is that it makes it easier for you to read and maintain your test code. The disadvantage is that the extended command string causes your test code to run slightly slower. If you want to change a command in the inactive format you must use a mnemonic.

The following sections list the format mnemonics used by the different fast switching applications and the ABORt commands which use the format mnemonics, and which mnemonics are applicable to them.

  • GSM/GPRS_AMPS/136_W-CDMA format mnemonics

GSM/GPRS_AMPS/136_W-CDMA format mnemonics

  • [:SELected], this selects the format that is currently active.
  • :GSM, this selects the GSM format, whether the format is active or not.
  • :DIGital136, this selects the digital system in the AMPS/136 format, whether the format is active or not.
ABORt Commands using Format Mnemonics
Command | [:SELected] 1 | :GSM | :DIGital136
ABORt:DPOWer | Yes | Yes | Yes
ABORt:IQTuning | Yes | Yes | Yes

1.

If you use the [:SELected] node in a format that does not support that particular command then you will receive an undefined header message.


CALL Commands with Format Mnemonics

CALL Commands with Format Mnemonics

Last updated: November 18, 2003

Some of the CALL commands are common between the formats in the fast switching applications. Therefore to identify which format the command is to be implemented on the test set requires a format mnemonic at the end of the command. This format mnemonic is simply an extension to the command.

It is possible not to use a format mnemonic. This is the same as using the optional [:SELected] format mnemonic. This would mean that the command is sent to the active format. The advantage of using a format mnemonic with these common commands, is that it makes it easier for you to read and maintain your test code. The disadvantage is that the extended command string causes your test code to run slightly slower. If you want to change a command in the inactive format you must use a mnemonic.

The following sections list the format mnemonics used by the different fast switching applications and the CALL commands which use the format mnemonics, and which mnemonics are applicable to them.

  • GSM/GPRS_AMPS/136_W-CDMA format mnemonics
  • GSM/GPRS_cdma2000/IS-95/AMPS format mnemonics
  • cdma2000/IS-95/AMPS_1xEV-DO format mnemonics
  • GSM/GPRS_W-CDMA format mnemonics

GSM/GPRS_AMPS/136_W-CDMA format mnemonics

  • [:SELected], this selects the format that is currently active.
  • :GSM, this selects the GSM format, whether the format is active or not.
  • :GPRS, this selects the GPRS format, whether the format is active or not.
  • :TA136, this selects the AMPS/136 format, whether the format is active or not.
  • :DIGital136, this selects the digital system in the AMPS/136 format, whether the format is active or not.
  • :WCDMa, this selects the W-CDMA format, whether the format is active or not.
  • :FDD, this selects the frequency division duplex system in the W-CDMA format, whether the format is active or not.
CALL Commands using Format Mnemonics
Command | [:SELected] 1 | :GSM | :GPRS | :TA136 | :DIGital136 | :WCDMa | :FDD
CALL:BURSt:TYPE | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BA:TABLe:DCS | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BA:TABLe:EGSM | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BA:TABLe:GSM450 | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BA:TABLe:GSM480 | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BA:TABLe:GSM750 | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BA:TABLe:GSM850 | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BA:TABLe:PCS | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BA:TABLe:PGSM | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BA:TABLe:RGSM | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BA:TABLe[:SELected] | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BA:TABLe:POINts:DCS | Yes | Yes | No | No | No | No | No
CALL[:CELL]:BA:TABLe:POINts:EGSM | Yes | Yes | No | No | No | No | No
CALL[:CELL]:BA:TABLe:POINts:GSM450 | Yes | Yes | No | No | No | No | No
CALL[:CELL]:BA:TABLe:POINts:GSM480 | Yes | Yes | No | No | No | No | No
CALL[:CELL]:BA:TABLe:POINts:GSM750 | Yes | Yes | No | No | No | No | No
CALL[:CELL]:BA:TABLe:POINts:GSM850 | Yes | Yes | No | No | No | No | No
CALL[:CELL]:BA:TABLe:POINts:PCS | Yes | Yes | No | No | No | No | No
CALL[:CELL]:BA:TABLe:POINts:PGSM | Yes | Yes | No | No | No | No | No
CALL[:CELL]:BA:TABLe:POINts:RGSM | Yes | Yes | No | No | No | No | No
CALL[:CELL]:BA:TABLe:POINts[:SELected] | Yes | Yes | No | No | No | No | No
CALL:BAND | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BCH:ARFCn:DCS | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BCH:ARFCn:EGSM | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BCH:ARFCn:GSM850 | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BCH:ARFCn:GSM450 | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BCH:ARFCn:GSM480 | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BCH:ARFCn:GSM750 | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BCH:ARFCn:PCS | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BCH:ARFCn:PGSM | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BCH:ARFCn:RGSM | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:BCH:ARFCn[:SELected] | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:MCCode | Yes | Yes | No | No | Yes | Yes | No
CALL[:CELL]:PMNCode:STATe | Yes | Yes | Yes | No | No | No | No
CALL[:CELL]:POWer:AMPLitude | Yes | Yes | Yes | Yes | No | No | Yes
CALL[:CELL]:POWer[:SAMPlitude] | Yes | Yes | Yes | Yes | No | No | Yes
CALL[:CELL]:POWer:STATe | Yes | Yes | Yes | Yes | No | No | Yes
CALL[:CELL]:RFGenerator:FREQuency | Yes | Yes | No | Yes | No | No | No
CALL:COUNT:RACH | Yes | Yes | Yes | No | No | No | No
CALL:MS:REPorted:IMEI | Yes | Yes | Yes | No | No | Yes | No
CALL:MS:REPorted:IMSI | Yes | Yes | Yes | No | No | Yes | No
CALL:MS:REPorted:ONUMber | Yes | Yes | No | Yes | No | No | No
CALL:MS:REPorted:PCLass | Yes | Yes | No | Yes | No | Yes | No
CALL:MS:REPorted:REVision[:DIGital] | Yes | Yes | No | Yes | No | No | No
CALL:PAGing:IMSI[:SELected] | Yes | Yes | Yes | No | No | Yes | No
CALL:PAGing:REPeat[:STATe] | Yes | Yes | No | Yes | No | Yes | No

GSM/GPRS_cdma2000/IS-95/AMPS format mnemonics

  • [:SELected], this selects the format that is currently active.
  • :GSM, this selects the GSM format, whether the format is active or not.
  • :GPRS, this selects the GPRS format, whether the format is active or not.
  • :DIGital2000, this selects the cdma2000 system in the cdma2000/IS-95/AMPS format, whether the format is active or not.
  • :DIGital95, this selects the IS-95 system in the cdma2000/IS-95/AMPS format, whether the format is active or not.
  • :AMPS, this selects the AMPS system in the cdma2000/IS-95/AMPS format, whether the format is active or not.
  • :CW, this selects the CW system in the cdma2000/IS-95/AMPS format, whether the format is active or not.
  • :TA2000, this selects the cdma2000/IS-95/AMPS format, whether the format is active or not.
CALL Commands using Format Mnemonics
Command | [:SELected] 2 | :GSM | :GPRS | :DIGital2000 | :DIGital95 | :AMPS | :CW | :TA2000
CALL[:CELL]:BAND | Yes | Yes | Yes | Yes | Yes | No | No | No
CALL[:CELL]:MCCode | Yes | Yes | Yes | No | No | No | No | Yes
CALL[:CELL]:MNCode | Yes | Yes | Yes | No | No | No | No | Yes
CALL[:CELL]:POWer:AMPLitude | Yes | Yes | Yes | Yes | Yes | Yes | Yes | No
CALL[:CELL]:POWer[:SAMPlitude] | Yes | Yes | Yes | Yes | Yes | Yes | Yes | No
CALL[:CELL]:POWer:STATe | Yes | Yes | Yes | Yes | Yes | Yes | Yes | No
CALL:MS:REPorted:MCCode | Yes | Yes | No | No | No | No | No | Yes
CALL:MS:REPorted:MNCode | Yes | Yes | No | No | No | No | No | Yes
CALL:MS:REPorted:PCLass | Yes | Yes | No | No | No | No | No | Yes

cdma2000/IS-95/AMPS_1xEV-DO format mnemonics

  • [:SELected], this selects the format or system that is currently active.
  • :TA2000, this selects the IS-2000/IS-95/AMPS format, whether the format is active or not.
  • :DIGital2000, this selects the IS-2000 system in the IS-2000/IS-95/AMPS format, whether the format is active or not.
  • :DIGital95, this selects the IS-95 system in the IS-2000/IS-95/AMPS format, whether the format is active or not.
  • :TA856, this selects the IS-856 format, whether the format is active or not.
  • :DIGital856, this selects the IS-856 system in the IS-856 format, whether the format is active or not.
CALL Commands using Format Mnemonics
Command | [:SELected] 3 | :TA2000 | :DIGital2000 | :DIGital95 | :AMPS | :CW | :TA856 | :DIGital856
CALL[:CELL]:BAND | Yes | No | Yes | Yes | No | No | No | Yes
CALL[:CELL]:CLPControl:REVerse:MODE | Yes | Yes | No | No | No | No | Yes | No
CALL[:CELL]:MCCode | Yes | Yes | No | No | No | No | Yes | No
CALL[:CELL]:POWer[:SAMPlitude] | Yes | No | Yes | Yes | Yes | Yes | No | Yes
CALL[:CELL]:POWer:AMPLitude | Yes | No | Yes | Yes | Yes | Yes | No | Yes
CALL[:CELL]:POWer:STATe | Yes | No | Yes | Yes | Yes | Yes | No | Yes
CALL:AWGNoise:POWer[:SAMPlitude] | Yes | No | Yes | Yes | No | No | No | Yes
CALL:AWGNoise:POWer:AMPLitude | Yes | No | Yes | Yes | No | No | No | Yes
CALL:AWGNoise:POWer:STATe | Yes | No | Yes | Yes | No | No | No | Yes
CALL:CHANnel | Yes | No | Yes | Yes | No | No | No | Yes
CALL:CONNected:DROP:TIMer[:STATe] | Yes | Yes | No | No | No | No | Yes | No
CALL:CONNected:LIMit[:STATe] | Yes | Yes | No | No | No | No | Yes | No
CALL:SETup:BAND | Yes | No | Yes | Yes | No | No | No | Yes
CALL:SETup:CHANnel | Yes | No | Yes | Yes | No | No | No | Yes
CALL:STATus:AWGNoise:POWer[:AMPLitude] | Yes | No | Yes | Yes | No | No | No | Yes
CALL:STATus:AWGNoise:POWer:STATe | Yes | No | Yes | Yes | No | No | No | Yes
CALL:STATus:CELL:POWer[:AMPLitude] | Yes | No | Yes | Yes | No | No | No | Yes
CALL:STATus:CELL:POWer:STATe | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes
CALL:STATus:TOTal:POWer[:AMPLitude] | Yes | No | Yes | Yes | No | No | No | Yes
CALL:STATus:TOTal:POWer:STATe | Yes | No | Yes | Yes | No | No | No | Yes
CALL:TOTal:POWer[:AMPLitude | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes
CALL:TOTal:POWer:STATe | Yes | Yes | Yes | Yes | Yes | Yes | Yes | Yes
CALL:TRIGger[:OUTPut]:TYPE | Yes | Yes | No | No | No | No | Yes | No

GSM/GPRS_W-CDMA format mnemonics

  • [:SELected], this selects the format that is currently active.
  • :GSM, this selects the GSM format, whether the format is active or not.
  • :GPRS, this selects the GPRS format, whether the format is active or not.
  • :WCDMa, this selects the W-CDMA format, whether the format is active or not.
  • :FDD, this selects the frequency division duplex system in the W-CDMA format, whether the format is active or not.
CALL Commands using Format Mnemonics
Command | [:SELected] 4 | :GSM | :GPRS | :WCDMa | :FDD
CALL[:CELL]:LACode | Yes | Yes | Yes | Yes | No
CALL[:CELL]:MCCode | Yes | Yes | Yes | Yes | No
CALL[:CELL]:MNCode | Yes | Yes | Yes | Yes | No
CALL[:CELL]:POWer:AMPLitude | Yes | Yes | Yes | No | Yes
CALL[:CELL]:POWer:AMPLitude:CW | Yes | No | No | No | No
CALL[:CELL]:POWer[:SAMPlitude] | Yes | Yes | Yes | Yes | Yes
CALL[:CELL]:POWer[:SAMPlitude]:CW | Yes | No | No | No | No
CALL[:CELL]:POWer:STATe | Yes | Yes | Yes | Yes | Yes
CALL[:CELL]:POWer:STATe:CW | Yes | No | No | Yes | No
CALL[:CELL]:RFGenerator:FREQuency | Yes | Yes | Yes | Yes | No
CALL:CONNected:DROP:TIMer[:STATE] | Yes | Yes | Yes | Yes | No
CALL:MS:REPorted:IMEI | Yes | Yes | Yes | Yes | No
CALL:MS:REPorted:IMSI | Yes | Yes | Yes | Yes | No
CALL:PAGing:IMSI[:SELected] | Yes | Yes | Yes | Yes | No
CALL:PAGing:REPeat[:STATe] | Yes | Yes | No | Yes | No

1.

If you use the [:SELected] node in a format that does not support that particular command then you will receive an undefined header message.

2.

If you use the [:SELected] node in a format that does not support that particular command then you will receive an undefined header message.

3.

If you use the [:SELected] node in a format that does not support that particular command then you will receive an undefined header message.

4.

If you use the [:SELected] node in a format that does not support that particular command then you will receive an undefined header message.


FETCh Commands with Format Mnemonics

FETCh Commands with Format Mnemonics

Last updated: November 5, 2003

Some of the FETCh commands are common between the formats in the fast switching applications. Therefore to identify which format the command is to be implemented on the test set requires a format mnemonic at the end of the command. This format mnemonic is simply an extension to the command

It is possible not to use a format mnemonic. This is the same as using the optional [:SELected] format mnemonic. This would mean that the command is sent to the active format. The advantage of using a format mnemonic with these common commands, is that it makes it easier for you to read and maintain your test code. The disadvantage is that the extended command string causes your test code to run slightly slower. If you want to change a command in the inactive format you must use a mnemonic.

The following sections list the format mnemonics used by the different fast switching applications and the FETCh commands which use the format mnemonics, and which mnemonics are applicable to them.

  • GSM/GPRS_AMPS/136_W-CDMA format mnemonics

GSM/GPRS_AMPS/136_W-CDMA format mnemonics

  • [:SELected], this selects the format that is currently active.
  • :GSM, this selects the GSM format, whether the format is active or not.
  • :DIGital136, this selects the digital system in the AMPS/136 format, whether the format is active or not.
FETCh Commands using Format Mnemonics
Command | [:SELected] 1 | :GSM | :DIGital136
FETCh:DPOWer:ICOunt | Yes | Yes | Yes
FETCh:DPOWer:INTegrity[:RANGE1] | Yes | Yes | Yes
FETCh:DPOWer:NUMBer[:RANGE1] | Yes | Yes | Yes
FETCh:DPOWer:POWer[:RANGE1] | Yes | Yes | Yes
FETCh:DPOWer[:ALL][:RANGE1] | Yes | Yes | Yes
FETCh:IQTuning:ICOunt | Yes | Yes | Yes
FETCh:IQTuning:INTegrity | Yes | Yes | Yes
FETCh:IQTuning:POWer[:ALL] | Yes | Yes | Yes
FETCh:IQTuning:SPUR:POWer | Yes | Yes | Yes
FETCh:IQTuning[:ALL] | Yes | Yes | Yes

1.

If you use the [:SELected] node in a format that does not support that particular command then you will receive an undefined header message.


INITiate Commands with Format Mnemonics

INITiate Commands with Format Mnemonics

Last updated: November 5, 2003

Some of the INITiate commands are common between the formats in the fast switching applications. Therefore to identify which format the command is to be implemented on the test set requires a format mnemonic at the end of the command. This format mnemonic is simply an extension to the command

It is possible not to use a format mnemonic. This is the same as using the optional [:SELected] format mnemonic. This would mean that the command is sent to the active format. The advantage of using a format mnemonic with these common commands, is that it makes it easier for you to read and maintain your test code. The disadvantage is that the extended command string causes your test code to run slightly slower. If you want to change a command in the inactive format you must use a mnemonic.

The following sections list the format mnemonics used by the different fast switching applications and the INITiate commands which use the format mnemonics, and which mnemonics are applicable to them.

  • GSM/GPRS_AMPS/136_W-CDMA format mnemonics

GSM/GPRS_AMPS/136_W-CDMA format mnemonics

  • [:SELected], this selects the format that is currently active.
  • :GSM, this selects the GSM format, whether the format is active or not.
  • :DIGital136, this selects the digital system in the AMPS/136 format, whether the format is active or not.
INITiate Commands using Format Mnemonics
Command | [:SELected] 1 | :GSM | :DIGital136
INITiate:DONE:FLAG:DPOWer | Yes | Yes | Yes
INITiate:DONE:FLAG:IQTuning | Yes | Yes | Yes
INITiate:DPOWer:OFF | Yes | Yes | Yes
INITiate:DPOWer[:ON] | Yes | Yes | Yes
INITiate:IQTuning:OFF | Yes | Yes | Yes
INITiate:IQTuning[:ON] | Yes | Yes | Yes

1.

If you use the [:SELected] node in a format that does not support that particular command then you will receive an undefined header message.


READ Commands with Format Mnemonics

READ Commands with Format Mnemonics

Last updated: November 5, 2003

Some of the READ commands are common between the formats in the fast switching applications. Therefore to identify which format the command is to be implemented on the test set requires a format mnemonic at the end of the command. This format mnemonic is simply an extension to the command

It is possible not to use a format mnemonic. This is the same as using the optional [:SELected] format mnemonic. This would mean that the command is sent to the active format. The advantage of using a format mnemonic with these common commands, is that it makes it easier for you to read and maintain your test code. The disadvantage is that the extended command string causes your test code to run slightly slower. If you want to change a command in the inactive format you must use a mnemonic.

The following sections list the format mnemonics used by the different fast switching applications and the READ commands which use the format mnemonics, and which mnemonics are applicable to them.

  • GSM/GPRS_AMPS/136_W-CDMA format mnemonics

GSM/GPRS_AMPS/136_W-CDMA format mnemonics

  • [:SELected], this selects the format that is currently active.
  • :GSM, this selects the GSM format, whether the format is active or not.
  • :DIGital136, this selects the digital system in the AMPS/136 format, whether the format is active or not.
READ Commands using Format Mnemonics
Command | [:SELected] 1 | :GSM | :DIGital136
READ:DPOWer[:ALL] | Yes | Yes | Yes
READ:IQTuning[:ALL] | Yes | Yes | Yes

1.

If you use the [:SELected] node in a format that does not support that particular command then you will receive an undefined header message.


RFANalyzer Commands with Format Mnemonics

RFANalyzer Commands with Format Mnemonics

Last updated: November 18, 2003

Some of the RFANalyzer commands are common between the formats in the fast switching applications. Therefore to identify which format the command is to be implemented on the test set requires a format mnemonic at the end of the command. This format mnemonic is simply an extension to the command

It is possible not to use a format mnemonic. This is the same as using the optional [:SELected] format mnemonic. This would mean that the command is sent to the active format. The advantage of using a format mnemonic with these common commands, is that it makes it easier for you to read and maintain your test code. The disadvantage is that the extended command string causes your test code to run slightly slower. If you want to change a command in the inactive format you must use a mnemonic.

The following sections list the format mnemonics used by the different fast switching applications and the RFANalyzer commands which use the format mnemonics, and which mnemonics are applicable to them.

  • GSM/GPRS_AMPS/136_W-CDMA format mnemonics
  • GSM/GPRS_cdma2000/IS-95/AMPS format mnemonics
  • cdma2000/IS-95/AMPS_1xEV-DO format mnemonics
  • GSM/GPRS_W-CDMA format mnemonics

GSM/GPRS_AMPS/136_W-CDMA format mnemonics

  • [:SELected], this selects the format that is currently active.
  • :GPRS, this selects the GPRS format, whether the format is active or not.
  • :FDD, this selects the frequency division duplex system in the W-CDMA format, whether the format is active or not.
RFANalyzer Commands using Format Mnemonics
Command | [:SELected] 1 | :GPRS | :FDD
RFANalyzer:MANual:POWer | Yes | Yes | Yes

GSM/GPRS_cdma2000/IS-95/AMPS format mnemonics

  • [:SELected], this selects the format that is currently active.
  • :GPRS, this selects the GPRS format, whether the format is active or not.
  • :DIGital2000, this selects the cdma2000 system in the cdma2000/IS-95/AMPS format, whether the format is active or not.
  • :DIGital95, this selects the IS-95 system in the cdma2000/IS-95/AMPS format, whether the format is active or not.
RFANalyzer Commands using Format Mnemonics
Command | [:SELected] 2 | :GPRS | :DIGital95 | :DIGital2000
RFANalyzer:MANual:POWer | Yes | Yes | Yes | Yes

cdma2000/IS-95/AMPS_1xEV-DO format mnemonics

  • [:SELected], this selects the format that is currently active.
  • :DIGital2000, this selects the IS-2000 system in the IS-2000/IS-95/AMPS format, whether the format is active or not.
  • :DIGital95, this selects the IS-95 system in the IS-2000/IS-95/AMPS format, whether the format is active or not.
  • :DIGital856, this selects the IS-856 system in the IS-856 format, whether the format is active or not.
RFANalyzer Commands using Format Mnemonics
Command | [:SELected] 3 | :DIGital2000 | :DIGital95 | :DIGital856
RFANalyzer:AUTO:POWer | Yes | Yes | Yes | Yes
RFANalyzer:MANual:POWer | Yes | Yes | Yes | Yes

GSM/GPRS_W-CDMA format mnemonics

  • [:SELected], this selects the format that is currently active.
  • :GPRS, this selects the GPRS format, whether the format is active or not.
  • :FDD, this selects the frequency division duplex system in the W-CDMA format, whether the format is active or not.
RFANalyzer Commands using Format Mnemonics
Command | [:SELected] 4 | :GPRS | :FDD
RFANalyzer:MANual:POWer | Yes | Yes | Yes

1.

If you use the [:SELected] node in a format that does not support that particular command then you will receive an undefined header message.

2.

If you use the [:SELected] node in a format that does not support that particular command then you will receive an undefined header message.

3.

If you use the [:SELected] node in a format that does not support that particular command then you will receive an undefined header message.

4.

If you use the [:SELected] node in a format that does not support that particular command then you will receive an undefined header message.


SETup Commands with Format Mnemonics

SETup Commands with Format Mnemonics

Last updated: November 18, 2003

Some of the SETup commands are common between the formats in the fast switching applications. Therefore to identify which format the command is to be implemented on the test set requires a format mnemonic at the end of the command. This format mnemonic is simply an extension to the command

It is possible not to use a format mnemonic. This is the same as using the optional [:SELected] format mnemonic. This would mean that the command is sent to the active format. The advantage of using a format mnemonic with these common commands, is that it makes it easier for you to read and maintain your test code. The disadvantage is that the extended command string causes your test code to run slightly slower. If you want to change a command in the inactive format you must use a mnemonic.

The following sections list the format mnemonics used by the different fast switching applications and the SETup commands which use the format mnemonics, and which mnemonics are applicable to them.

  • GSM/GPRS_AMPS/136_W-CDMA format mnemonics
  • cdma2000/IS-95/AMPS_1xEV-DO format mnemonics

GSM/GPRS_AMPS/136_W-CDMA format mnemonics

  • [:SELected], this selects the format that is currently active.
  • :GSM, this selects the GSM format, whether the format is active or not.
  • :DIGital136, this selects the digital system in the AMPS/136 format, whether the format is active or not.
SETup Commands using Format Mnemonics
Command | [:SELected] 1 | :GSM | :DIGital136
SETup:DPOWer:CONTinuous | Yes | Yes | Yes
SETup:DPOWer:COUNt:NUMBer | Yes | Yes | Yes
SETup:DPOWer:EMDifference | Yes | Yes | Yes
SETup:DPOWer:TIMeout[:STIMe] | Yes | Yes | Yes
SETup:DPOWer:TIMeout:STATe | Yes | Yes | Yes
SETup:DPOWer:TIMeout:TIME | Yes | Yes | Yes
SETup:IQTuning:CONTinuous | Yes | Yes | Yes
SETup:IQTuning:COUNt[:SNUMber] | Yes | Yes | Yes
SETup:IQTuning:COUNt:NUMBer | Yes | Yes | Yes
SETup:IQTuning:COUNt:STATe | Yes | Yes | Yes
SETup:IQTuning:REFerence[:MANual][:FREQuency] | Yes | Yes | Yes
SETup:IQTuning:SPUR[:SFREQuency] | Yes | Yes | Yes
SETup:IQTuning:SPUR:FREQuency | Yes | Yes | Yes
SETup:IQTuning:SPUR:STATe | Yes | Yes | Yes
SETup:IQTuning:TIMeout[:STime] | Yes | Yes | Yes
SETup:IQTuning:TIMeout:STATe | Yes | Yes | Yes
SETup:IQTuning:TIMeout:TIME | Yes | Yes | Yes
SETup:IQTuning:TRIGger:DELay | Yes | Yes | Yes
SETup:IQTuning:TRIGger:SOURce | Yes | Yes | Yes

cdma2000/IS-95/AMPS_1xEV-DO format mnemonics

  • [:SELected], this selects the format that is currently active.
  • :TA2000, this selects the IS-2000/IS-95/AMPS format, whether the format is active or not.
  • :TA856, this selects the IS-856 format, whether the format is active or not.
  • :DIGital2000, this selects the IS-2000 system in the IS-2000/IS-95/AMPS format, whether the format is active or not.
  • :DIGital95, this selects the IS-95 system in the IS-2000/IS-95/AMPS format, whether the format is active or not.
  • :DIGital856, this selects the IS-856 system in the IS-856 format, whether the format is active or not.
SETup Commands using Format Mnemonics
Command | [:SELected] 2 | :TA2000 | :TA856 | :DIGital2000 | :DIGital95 | :DIGital856

1.

If you use the [:SELected] node in a format that does not support that particular command then you will receive an undefined header message.

2.

If you use the [:SELected] node in a format that does not support that particular command then you will receive an undefined header message.


SYSTem:APPLication

SYSTem:APPLication

Last updated: November 5, 2003

Diagram Conventions

SYSTem:APPLication[:CURRent][:NAME]?

Function

Queries the test set for the name of the currently running application.

Query

Range: A string up to 25 characters including null. See SYSTem:APPLication:CATalog[:NAME]? .

Programming Example

OUTPUT 714;"SYSTEM:APPLICATION:NAME?"

SYSTem:APPLication[:CURRent]:REVision?

Function

Queries the test set for the currently running application revision number.

Query

Range: Any string up to 20 characters including null. A typical example would be A.01.01 for a licensed version.

Programming Example

OUTPUT 714;"SYSTEM:APPLICATION:CURRENT:REVISION?"

SYSTem:APPLication:CATalog[:NAME]?

Function

Queries the test set for all of the names of the applications stored on the hard drive.

This query returns one or more strings, each string is separated by a comma.

Query

Range:

  • 1xEV-DO Terminal Test
  • AMPS/136 Mobile Test
  • CDMA 2000 Lab App
  • CDMA 2000 Lab App B
  • CDMA 2000 Mobile Test
  • CDMA 2000_1xEV-DO
  • GPRS Lab App B
  • GPRS Mobile Test
  • GSM Mobile Test
  • GSM/GPRS Lab App C
  • GSM/GPRS Mobile Test
  • GSM/GPRS_AMPS/136_WCDMA
  • GSM_AMPS/136_GPRS_WCDMA
  • GSM/GPRS_CDMA 2000
  • GSM/GPRS_WCDMA Lab App
  • WCDMA Lab App
  • WCDMA Mobile Test

Programming Example

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME?"

SYSTem:APPLication:CATalog[:NAME]:COUNt?

Function

Queries the test set for the total number application names stored on the hard drive. Up to 30 applications can be stored.

Query

Range: 0 through 30

Programming Example

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME:COUNT?"

SYSTem:APPLication:CATalog:FORMat?

Function

Queries the test set for the names of all formats that are available in a fast switching application. A licensed fast switching application must be selected to use this command.

This query returns one or more strings, each string is separated by a comma.

Query

Range: One or more comma separated strings or a null string, each string up to 25 characters.

  • AMPS/136
  • GSM/GPRS
  • IS-2000/IS-95/AMPS
  • IS-856
  • WCDMA

Programming Example

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:FORMAT?"

SYSTem:APPLication:CATalog:FORMat:COUNt?

Function

Queries the test set for the total number of formats available in a fast switching application. A licensed fast switching application must be selected to use this command.

Query

Range: 0 to 3

Programming Example

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:FORMAT:COUNT?"

SYSTem:APPLication:CATalog:LICense? '<application name>','<revision>'

Function

Queries the license status for a selected revision.

The query must include two strings separated by a comma. The application name and revision must be entered as they appear in the Application Setup menu, with the exception that the string is not case sensitive and can be entered in any combination of upper and lower case letters. You can also use SYSTem:APPLication:CATalog[:NAME]? to determine the application name, and use SYSTem:APPLication:CATalog:REVision? '<application name>' to determine the revisions for the specified application.

Query

Range: LIC|NLIC|PART|UNKN

  • "LIC" indicates this is a licensed application.
  • "NLIC" indicates this is not a licensed application.
  • "PART" only part of the application with multiple radio formats is licensed
  • "UNKN" indicates that license status is unknown.

Programming Example

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:LICENSE? 'CDMA 2000 Mobile Test','B.07.00'"

SYSTem:APPLication:CATalog:REVision? '<application name>'

Function

Queries the test set for all of the revision numbers for a specified application stored on the test set's hard drive.

The application name must be entered as it appears in the Application Setup menu, with the exception that the string is not case sensitive and can be entered in any combination of upper and lower case letters. You can also use SYSTem:APPLication:CATalog[:NAME]? to determine the application name.

Query

Range: One or more comma separated strings or a null string

Programming Example

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION? 'CDMA 2000 MOBILE TEST'"

SYSTem:APPLication:CATalog:REVision:COUNt? '<application name>'

Function

Queries the test set for the number of revisions present on the test set's hard drive for a specified application. Up to 30 revisions can be stored for a application.

The application name must be entered as it appears in the Application Setup menu, with the exception that the string is not case sensitive and can be entered in any combination of upper and lower case letters. You can also use SYSTem:APPLication:CATalog[:NAME]? to determine the application name.

Query

Range: 0 through 30

Programming Example

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION:COUNT? `AMPS/136 MOBILE TEST'"

SYSTem:APPLication:FORMat[:NAME]

Function

Switches formats in a fast switching application. A licensed fast switching application must be selected to use this command. You can use SYSTem:APPLication:CATalog:FORMat? to determine the format name included in the fast switching application.

Queries the test set for the name of the currently active format. This string is not case sensitive.

Setting

Range:

  • "AMPS/136"
  • "GSM/GPRS"
  • "IS-2000/IS-95/AMPS"
  • "IS-856"
  • "WCDMA"

Query

Range: A string up to 25 characters, or the null string.

  • AMPS/136
  • GSM/GPRS
  • IS-2000/IS-95/AMPS
  • IS-856
  • WCDMA

Programming Example

OUTPUT 714;"SYSTEM:APPLICATION:FORMAT:NAME 'IS-2000/IS-95/AMPS'"

OUTPUT 714;"SYSTEM:APPLICATION:FORMAT:NAME?"

SYSTem:APPLication:FORMat:LICense? '<format name>'

Function

Queries the test set for the license status of the specified format in the fast switching application. You can use SYSTem:APPLication:CATalog:FORMat? to determine the format name included in the fast switching application.

Query

Range: LIC|NLIC|PART|UNKN

  • LIC indicates this is a licensed application.
  • NLIC indicates this is not a licensed application.
  • PART indicates that only part of the application with multiple formats is licensed.
  • UNKN indicates that license status is unknown.

Programming Example

OUTPUT 714;"SYSTEM:APPLICATION:FORMAT:LICENSE? 'IS-2000/IS-95/AMPS'"

SYSTem:APPLication:SELect[:NAME] '<application name>'

Function

Selects a application and reboots the test set. This will switch the application to the revision already selected. There is no need to re-select the revision before switching. The reboot process takes about 1 minute.

Queries the test set for the application that is selected and will run after the next reboot of the test set.

The application name must be entered as it appears in the Application Setup menu, with the exception that the string is not case sensitive and can be entered in any combination of upper and lower case letters. You can also use SYSTem:APPLication:CATalog[:NAME]? to determine the application name.

NOTE
Selecting the correct name and the desired revision of a application is important. This information should be reviewed before proceeding.

Setting

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Query

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Programming Example

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME 'CDMA 2000 MOBILE TEST'"

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME?"

SYSTem:APPLication:SELect:REVision '<application name>','<revision>'

Function

Selects an application and a revision for the application.

The revision does not need to be set in order to switch applications. The only time you select revisions is to change revisions.

Queries the test set for the revision of a specified application.

The application name and revision must be entered as they appear in the Application Setup menu, with the exception that the string is not case sensitive and can be entered in any combination of upper and lower case letters. You can also use SYSTem:APPLication:CATalog[:NAME]? to determine the application name, and use SYSTem:APPLication:CATalog:REVision? '<application name>' to determine the revisions for the specified application.

Setting

Range: A valid application name and revision number for any licensed application.

Query

Range: A string up to 20 characters, or the null string.

Programming Example

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION 'GSM/GPRS MOBILE TEST','A.01.00'"

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION? 'GSM/GPRS MOBILE TEST'"


SYSTem:FTRigger Commands with Format Mnemonics

SYSTem:FTRigger Commands with Format Mnemonics

Last updated: November 5, 2003

Some of the SYSTem:FTRigger commands are common between the formats in the fast switching applications. Therefore to identify which format the command is to be implemented on the test set requires a format mnemonic at the end of the command. This format mnemonic is simply an extension to the command

It is possible not to use a format mnemonic. This is the same as using the optional [:SELected] format mnemonic. This would mean that the command is sent to the active format. The advantage of using a format mnemonic with these common commands, is that it makes it easier for you to read and maintain your test code. The disadvantage is that the extended command string causes your test code to run slightly slower. If you want to change a command in the inactive format you must use a mnemonic.

The following sections list the format mnemonics used by the different fast switching applications and the SYSTem:FTRigger commands which use the format mnemonics, and which mnemonics are applicable to them.

  • GSM/GPRS_AMPS/136_W-CDMA format mnemonics

GSM/GPRS_AMPS/136_W-CDMA format mnemonics

  • [:SELected], this selects the format that is currently active.
  • :GSM, this selects the GSM format, whether the format is active or not.
  • :GPRS, this selects the GPRS format, whether the format is active or not.
  • :DIGital136, this selects the digital system in the AMPS/136 format, whether the format is active or not.
SYSTem:FTRigger Commands using Format Mnemonics
Command | [:SELected] 1 | :GSM | :GPRS | :DIGital136
SYSTem:FTRigger:STATe | Yes | Yes | Yes | Yes
SYSTem:FTRigger:TSLot | Yes | Yes | Yes | Yes

1.

If you use the [:SELected] node in a format that does not support that particular command then you will receive an undefined header message.


Manual Operation

Manual Operation

Last updated: November 5, 2003

Manual operation for the E1985B GSM/GPRS_AMPS/136_W-CDMA Mobile Test Application, the E1985C GSM/GPRS_cdma2000/IS-95/AMPS Mobile Test Application, the E1985E cdma2000/IS-95/AMPS_1xEV-DO Mobile Test Application and the E6785B GSM/GPRS_W-CDMA Lab Application fast switching applications are identical to the procedures described for the E1968A GSM/GPRS, E1961A AMPS/136, E1962B cdma2000/IS-95/AMPS, E1963A W-CDMA and E1966A 1xEV-DO Mobile Test Applications, as well as the E6701C GSM/GPRS and the E6703B W-CDMA Lab Applications when you have switched to the format you want. To switch the formats in the fast switching application, see How Do I Switch Formats? . For details

For details on the specific format manual operation, refer to:

  • GSM/GPRS Manual Operation
  • AMPS/136 Manual Operation
  • W-CDMA Manual Operation
  • cdma2000/IS-95/AMPS Manual Operation
  • 1xEV-DO Manual Operation


E1985x Fast Switching Test Applications Revision Information

E1985x Fast Switching Test Applications Revision Information

Last updated: November 13, 2003

This document lists revision information about the Agilent Technologies E1985x fast switching applications. All individual fast switching applications such as the E1985B, E1985C and E1985E are ordered using the E1985D model number. Select the appropriate link below to view the required releases.

E1985D fast switching application suite revision history:

  • D.02 Release - December 2003
  • D.01 Release - July 2003

E1985E cdma2000/IS-95/AMPS_1xEV-DO fast switching mobile test application revision history:

  • E.01 Release - December 2003

E1985C GSM/GPRS_cdma2000/IS-95/AMPS fast switching mobile test application revision history:

  • C.02 Release - December 2003
  • C.01 Release - July 2003

E1985B GSM/GPRS_AMPS/136_W-CDMA fast switching mobile test application revision history:

  • B.04 Release - December 2003
  • B.03 Release - July 2003
  • B.02 Release - January 2003
  • B.01 Release - June 2002

E1985A GSM/GPRS_AMPS/136 fast switching mobile test application revision history:

  • A.03 Release - March 2002
  • A.02 Release - July 2001
  • A.01 Release - February 2001

D.02 Release - December 2003

This release adds the E1985E cdma2000/IS-95/AMPS_1xEV-DO fast switching application to the E1985D for your ordering and updates the fast switching test application with the equivalent features of the following test applications:

  • E1985E cdma2000/IS-95/AMPS_1xEV-DO Mobile Test Application Revision E.01
  • E1985C GSM/GPRS_cdma2000/IS-95/AMPS Mobile Test Application Revision C.02
  • E1985B GSM/GPRS_AMPS/136_W-CDMA Mobile Test Application Revision B.04

D.01 Release - July 2003

This release creates the E1985D GSM/GPRS_AMPS/136_W-CDMA and GSM/GPRS_cdma2000/IS-95/AMPS Mobile Test applications which has the equivalent features of the following fast switching test applications:

  • E1985C GSM/GPRS_cdma2000/IS-95/AMPS Mobile Test Application Revision C.01
  • E1985B GSM/GPRS_AMPS/136_W-CDMA Mobile Test Application Revision B.03

E.01 Release - December 2003

This release creates the E1985E cdma2000/IS-95/AMPS_1xEV-DO fast switching mobile test application which has the equivalent features of the following test applications:

  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.07
  • E1966A 1xEV-DO Terminal Test Application Revision A.02

For details of the chassis requirements to run each of these technologies, please refer to the release notes for the individual technologies test application.

C.02 Release - December 2003

This release updates the E1985C GSM/GPRS_cdma2000/IS-95/AMPS fast switching test application with the equivalent features of the following test applications:

  • E1968A GSM/GPRS/EGPRS Mobile Test Application Revision A.03
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.07

For details of the chassis requirements to run each of these technologies, please refer to the release notes for the individual technologies test application.

C.01 Release - July 2003

This release creates the E1985C GSM/GPRS_cdma2000/IS-95/AMPS fast switching test application which has the equivalent features of the following test applications:

  • E1968A GSM/GPRS Mobile Test Application Revision A.02
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.06

For details of the chassis requirements to run each of these technologies, please refer to the release notes for the individual technologies test application.

B.04 Release - December 2003

This release updates the E1985B GSM/GPRS_AMPS/136_W-CDMA fast switching test application with the equivalent features of the following test applications:

  • E1961A AMPS/136 Mobile Test Application Revision A.08
  • E1963A W-CDMA Mobile Test Application Revision A.05
  • E1968A GSM/GPRS/EGPRS Mobile Test Application Revision A.03

For details of the chassis requirements to run each of these technologies, please refer to the release notes for the individual technologies test application.

B.03 Release - July 2003

This release updates the E1985B GSM/GPRS_AMPS/136_W-CDMA fast switching test application with the equivalent features of the following test applications:

  • E1961A AMPS/136 Mobile Test Application Revision A.07
  • E1963A W-CDMA Mobile Test Application Revision A.03
  • E1968A GSM/GPRS Mobile Test Application Revision A.02

For details of the chassis requirements to run each of these technologies, please refer to the release notes for the individual technologies test application.

B.02 Release - January 2003

This release adds the E1968A GSM/GPRS Mobile Test Application to the fast switching test application replacing the E1960A GSM Mobile Test Application and the E1964A Mobile Test Application. The E1960A and E1964A mobile test applications are obsolete and replaced by the E1968A. This release updates the fast switching test application with the equivalent features of the following test applications:

  • E1961A AMPS/136 Mobile Test Application Revision A.07
  • E1963A W-CDMA Mobile Test Application Revision A.02
  • E1968A GSM/GPRS Mobile Test Application Revision A.01

For details of the chassis requirements to run each of these technologies, please refer to the release notes for the individual technologies test application.

B.01 Release - June 2002

This release adds W-CDMA to the fast switching test application and updates the fast switching test application with the equivalent features of the following test applications:

  • E1960A GSM Mobile Test Application Revision A.10
  • E1961A AMPS/136 Mobile Test Application Revision A.07
  • E1963A W-CDMA Mobile Test Application Revision A.02
  • E1964A GPRS Mobile Test Application Revision A.04

For details of the chassis requirements to run each of these technologies please refer to the release notes for the individual technologies test application.

A.03 Release - March 2002

This release updates the fast switching test application with the equivalent features of the following test applications:

  • E1960A GSM Mobile Test Application Revision A.09
  • E1961A AMPS/136 Mobile Test Application Revision A.06
  • E1964A GPRS Mobile Test Application Revision A.03

A.02 Release - July 2001

This release adds GPRS to the fast switching test application and has the equivalent features of the following test applications:

  • E1960A GSM Mobile Test Application Revision A.08
  • E1961A AMPS/136 Mobile Test Application Revision A.05
  • E1964A GPRS Mobile Test Application Revision A.02

To allow the GPRS test application to operate in the fast switching environment with GSM and AMPS/136 a number of the existing GPRS commands had to be changed. If you previously used any of these commands you must change them to the new commands to allow your code to run as you would expect. You will not receive an error message if you do not change these commands as the commands are still valid commands for setting the inactive GSM format.

Note, these commands only need changed in your GPRS code, not your GSM code.

GPRS Command Changes

Previous Commands

New Commands

CALL[:CELL]:POWer[:SAMPlitude]:GSM

CALL[:CELL]:POWer[:SAMPlitude]:GPRS

CALL[:CELL]:POWer:AMPLitude:GSM

CALL[:CELL]:POWer:AMPLitude:GPRS

CALL[:CELL]:POWer:STATe:GSM

CALL[:CELL]:POWer:STATe:GPRS

RFANalyzer:MANual:POWer:GSM[:SELected]
:BURSt[1|2]

RFANalyzer:MANual:POWer:GPRS[:SELected]
:BURSt[1|2]

STATus:OPERation:NMRReady:GSM:CONDition

STATus:OPERation:NMRReady:GSM:ENABle

STATus:OPERation:NMRReady:GSM:NTRansition

STATus:OPERation:NMRReady:GSM:PTRansition

STATus:OPERation:NMRReady:GSM[:EVENt]

STATus:OPERation:NMRReady:GPRS:CONDition

STATus:OPERation:NMRReady:GPRS:ENABle

STATus:OPERation:NMRReady:GPRS:NTRansition

STATus:OPERation:NMRReady:GPRS:PTRansition

STATus:OPERation:NMRReady:GPRS[:EVENt]

STATus:QUEStionable:CALL:GSM:DATA:CONDition

STATus:QUEStionable:CALL:GSM:DATA:ENABle

STATus:QUEStionable:CALL:GSM:DATA:NTRansition

STATus:QUEStionable:CALL:GSM:DATA:PTRansition

STATus:QUEStionable:CALL:GSM:DATA[:EVENt]

STATus:QUEStionable:CALL:GPRS:CONDition

STATus:QUEStionable:CALL:GPRS:ENABle

STATus:QUEStionable:CALL:GPRS:NTRansition

STATus:QUEStionable:CALL:GPRS:PTRansition

STATus:QUEStionable:CALL:GPRS[:EVENt]

STATus:QUEStionable:ERRors:GSM:CONDition

STATus:QUEStionable:ERRors:GSM:ENABle

STATus:QUEStionable:ERRors:GSM:NTRansition

STATus:QUEStionable:ERRors:GSM:PTRansition

STATus:QUEStionable:ERRors:GSM[:EVENt]

STATus:QUEStionable:ERRors:GPRS:CONDition

STATus:QUEStionable:ERRors:GPRS:ENABle

STATus:QUEStionable:ERRors:GPRS:NTRansition

STATus:QUEStionable:ERRors:GPRS:PTRansition

STATus:QUEStionable:ERRors:GPRS[:EVENt]

A.01 Release - February 2001

This is the initial release of the GSM_AMPS/136 fast switching test application. You must have licensed revisions of E1960A GSM Mobile Test and E1961A AMPS/136 Mobile Test before fast switching will work.

The A.01 revision of the GSM_AMPS/136 fast switching test application has the equivalent capabilities of revision A.07 E1960A GSM Mobile Test and revision A.04 E1961A AMPS/136 Mobile Test.

Revision A.01 Equivalent Functionality
E1960A GSM Mobile Test | E1961A AMPS/136 Mobile Test
A.07 | A.04

GSM Syntax Changes

Most of your existing test code will work for this release however, some CALL and SETup commands are shared for both formats. These shared commands and queries will default to the active format selected. You can specify a format for the commands or queries by including a format mnemonic. See CALL Commands with Format Mnemonics or SETup Commands with Format Mnemonics for more information.

Existing GSM test code needs to be changed as follows for this revision to work.

  1. GSM command/query:

OUTPUT 714;"SETUP:IQTUNING:REFERENCE:FREQUENCY POS67KHZ"
!Sets reference frequency for IQ Tuning measurement (old command).

    must change to:

OUTPUT 714;"SETUP:IQTUNING:REFERENCE:MANUAL:FREQUENCY:CHARACTER:GSM POS67KHZ"
!Sets reference frequency for IQ Tuning measurement returns character data.

    or:

OUTPUT 714;"SETUP:IQTUNING:REFERENCE:MANUAL:FREQUENCY:GSM +67000"
!Sets reference frequency for IQ Tuning measurement.

    or to auto tune the reference use:

OUTPUT 714;"SETUP:IQTUNING:REFERENCE:AUTO ON"
!Turns on the auto reference selection.

  2. This GSM query now returns float 32 values of 1, 2 and 9.91E+37 (NAN). This query previously returned enumerated values of PHASe 1, PHASe 2 and UNKNown.

OUTPUT 714;"CALL:MS:REPORTED:REVISION?" !Returns the MS reported protocol revision.

    If you want to receive the enumerated values of UNKNown, PHASe1 and PHASe2, you must use this query.

OUTPUT 714;"CALL:MS:REPORTED:REVISION:CHARACTER:GSM?" !Returns the MS reported
                                                      ! protocol version.

    or:

OUTPUT 714;"CALL:MS:REPORTED:REVISION:DIGITAL:GSM?" !Returns the MS reported
                                                    !protocol version.

AMPS/136 Syntax Changes

All of your existing test code will work for this release however, some CALL and SETup commands are shared for both formats. These shared commands and queries will default to the active format. You can specify the format for the commands or queries by including a format mnemonic. See CALL Commands with Format Mnemonics or SETup Commands with Format Mnemonics for more information.


E1985B GSM/GPRS_AMPS/136_W-CDMA Fast Switching Mobile Test Application

E1985B GSM/GPRS_AMPS/136_W-CDMA Fast Switching Mobile Test Application

Last updated: November 13, 2003

The Agilent Technologies E1985B GSM/GPRS_AMPS/136_W-CDMA Fast Switching Mobile Test Application allows you to switch between GSM/GPRS, AMPS/136, and W-CDMA formats very quickly. The E1985B application combines the measurements and features from the E1968A GSM/GPRS, E1961A AMPS/136, and the E1963A W-CDMA Mobile Test Applications into a single fast switching test application.

The E1968A GSM/GPRS Mobile Test Application is the parent test shell for the option 101 GSM mobile test functionality and the option 102 GPRS mobile test functionality. A GSM and GPRS functionality suite is provided by E1968A option 201.

Different Switching Methods

Format Switching allows you to fast switch between formats that are bundled in one fast switching application. The E1985B application contains versions of GSM/GPRS, AMPS/136 and W-CDMA formats and allows you to rapidly switch between them. However, you must hold a license for the desired format to be able to switch to that format. Select SYSTEM CONFIG > Format Switch for viewing and switching formats within the E1985B.

Test Application Switching (which is significantly slower than Format Switching) does not require the E1985B application. However, to perform Test Application Switching, you must have more than one test application installed in your test set to switch between these test applications (for example, E1968A GSM/GPRS and the E1963A W-CDMA test application). Application switching is simply switching between individual test applications. The test applications that are currently installed in your test set can be viewed and switched from the SYSTEM CONFIG screen. Select Application Selection > Application Switch for viewing and switching test applications.

Refer to the individual appliation Online User's Manual when you need operating details about a particular format (GSM/GPRS, AMPS/136, or W-CDMA).

Format Switching

This section contains details on the following:

  • Overview
  • Test Application Revision and Licensing
  • Power Up
  • GPIB Commands GPIB Commands
  • Format Switching Behavior
  • Error Messages
  • Distinguishing between Formats with Common Command Syntax

Overview

A format selected in a fast switching test application becomes the active format. All other formats at this time are inactive.

Test Application Revision and Licensing

You must have test application licenses installed in your test set for each test application you want to switch between. Refer to the following diagrams for details on the licenses you require to switch between formats.

Once you install the E1985B application, there is no need to upgrade the individual test applications. You only need to upgrade the E1985B application as this contains the latest revisions of the individual test applications that you have licensed. Note that if you want to revert back to your earlier revision of an individual test application, you have to perform a slower test application switch to do this. The E1985B application is not using your previously installed earlier revision individual test applications. The E1985B is a self-contained test application which combines the latest revision of all three formats into one test application.

If you are not able to switch formats, check the test set to see that the formats you are trying to switch between are licensed. License information for each format within the E1985B can be viewed from the SYSTEM CONFIG screen, by selecting the Format Switch menu (F2). The letter indicating the license status of each format is shown in the License column on the right side of the screen. The license status is either; Licensed "L", Not Licensed "N", or Unknown "U":

  • "L"- A Licensed revision of this test application is present. This means that you can switch to this format.
  • "N" - You do not have a licensed revision of this test application. This means that you will not be able to switch to this format. If you select a revision which is Not Licensed, the following error message will be displayed: +133 Configuration error; Selected Partition is not licensed (License = N).
  • "U" - This test application revision has Unknown license status.

Power Up

The format the E1985B GSM/GPRS_AMPS/136_W-CDMA mobile test application powers up in depends on the licenses that are present on the test set. The E1985B will boot up into the first available licensed Test Application Partition that is present according to the following order: GSM/GPRS, AMPS/136, W-CDMA. When the E1968A GSM/GPRS format license is present, the test set selects the GSM/GPRS format at power up as the active format. The GSM/GPRS format must also have optional licenses corresponding to GSM functionality and/or GPRS functionality. Check this functionality by pressing the SYSTEM CONFIG button which will list GSM TA in the "License Status" area if GSM functionality is licensed. GPRS TA will be listed if GPRS functionality is licensed.

The Connection Type will default to AUTO, ready to make GSM voice calls, when the E1985B powers up into the GSM/GPRS format and the E1968A is licensed for GSM functionality. If the E1968A is only licensed for GPRS functionality, the Connection Type setting will default to BLER, ready to perform GPRS data connections.

If you do not have a license for the E1968A GSM/GPRS TA but do have a licensed revision of the E1961A AMPS/136 TA, the test set selects the AMPS/136 format as the active format. See Test Application Revision and Licensing for information on licenses required.

GPIB Commands

To perform a format switch or query the name of the currently active format, use the command SYSTem:APPLication:FORMat[:NAME] .

To query the license status of any of the formats, use the command SYSTem:APPLication:FORMat:LICense? '<format name>' .

To query the names of all the formats which are available, use the command SYSTem:APPLication:CATalog:FORMat? .

To query the total number of formats which are available, use the command SYSTem:APPLication:CATalog:FORMat:COUNt? .

For further details on these commands and other SYSTem:APPLication commands, see SYSTem:APPLication .

Format Switching Behavior

Switching formats affects the test set in the same way that a partial preset does.

Full and partial presets affect all formats in the GSM/GPRS_AMPS/136_W-CDMA Mobile Test Application whether or not the format is active.

For more details on what happens to the test set during a partial preset, see Partial Preset .

The following key functions are affected by a format switch:

  • The current call/connection is terminated
  • Measurements are deactivated

The following key functions are not affected by a format switch:

  • Most Call/data connection setup parameters
  • Most measurement parameters
  • Test set setup parameters

Error Messages

The error message log is not cleared when you switch formats with the GSM/GPRS_AMPS/136_W-CDMA Mobile Test Application. All error messages are shown in the error message log, they are not separated by format.

Distinguishing between Formats with Common Command Syntax

Some of the GPIB commands in the following subsystems are shared between formats in the GSM/GPRS_AMPS/136_W-CDMA Mobile Test Application. You use additional nodes known as Format Mnemonics (:SELected, :GSM, :GPRS, :TA136, :DIGital136, :WCDMa, and FDD) to clarify the format that you want the command to apply to. If you don't add a format mnemonic to a shared command, the command is sent to the active format. You must use a format mnemonic to send a command to an inactive format.

  • For more details on the shared ABORt commands, see ABORt Commands with Format Mnemonics .
  • For more details on the shared CALL commands, see CALL Commands with Format Mnemonics .
  • For more details on the shared FETCh commands, see FETCh Commands with Format Mnemonics .
  • For more details on the shared FETCh commands, see FETCh Commands with Format Mnemonics .
  • For more details on the shared INITiate commands, see INITiate Commands with Format Mnemonics .
  • For more details on the shared READ commands, see READ Commands with Format Mnemonics .
  • For more details on the shared RFANalyzer commands, see RFANalyzer Commands with Format Mnemonics .
  • For more details on the shared SETup commands, see SETup Commands with Format Mnemonics .
  • For more details on the shared SYSTem:FTRigger commands, see SYSTem:FTRigger Commands with Format Mnemonics .


Preset Descriptions

Preset Descriptions

Last updated: November 5, 2003

Description

The test set is capable of accepting several different preset commands.

At no time during a preset operation, does transmit power exceed the last user setting of the transmit power. The input power is not set to any value lower than the last user setting of the input power. This is to avoid power spikes on the output and possible receiver damage on the input during transitions associated with preset operations.

Partial Preset

Partial preset saves setup time because measurement setup parameters remain unchanged. This is the recommended way to place the test set in a known condition.

When you fast switch between formats in a fast switching test application the test set behaves as if a partial preset has occurred. The table below lists some key partial preset results.

Example

OUTPUT 714;"SYSTEM:PRESET3" !Command for a partial preset when user in
                            !remote operation.

SYSTEM:PRESET3 is the recommended command for a partial preset operation. The SYSTEM:PRESET[1] command is not recommended for use at this time.

Press the green Preset key on the front panel to perform a partial preset.

Partial Preset Behavior
Function | Partial Preset Result
Trigger Arm | no change
Measurement parameters | no change
Calibration data | no change
Enable registers | no change
Positive Transition Filter registers | no change
Negative Transition Filter registers | no change
Contents of RAM | no change
Contents of output queue | no change
Contents of error queue | no change
Maskable Message Display State | no change
Operating Mode | Active Cell
Measurements | aborted and inactivated
Measurement results | NAN
Measurement integrity indicator | 1 = no result available
Transmit Power State | ON
Cell Activated State | ON
Call in progress | aborted
Call Control Status | Idle
Call Counters | cleared
Call Error Counters | cleared
SACCH | cleared
Pending Service request | not cleared

Full Preset

A full preset requires you to select new measurements and configure their parameters. If measurement parameters do not need to be changed, use a partial preset to save time.

Example

OUTPUT 714;"*RST" !Recommended command for a full preset, sets trigger arm to single.

OUTPUT 714;"SYSTEM:PRESET2" !Command for a full preset, sets trigger arm to continuous.

The *RST common command is the recommended command for a full preset operation.

NOTE
Transmit power is not set to OFF during a full preset, transmit power is set to the default value.

Full Preset Behavior
Function | Full Preset Result
Trigger Arm | Continuous (manual operation full preset or SYSTEM:PRESET2 command)
Trigger Arm | Single (remote operation full preset, *RST command)
Measurement Parameters | all set to defaults
Maskable Message Display State | On (manual operation full preset)
Maskable Message Display State | Off (remote operation full preset)

Status Preset

The STATUS:PRESET command sets the status system as defined in "SCPI 1995 Volume 2: Command Reference" section 20.7. All of the enable registers are set to 0, all PTR registers are set to 1, and all NTR registers are set to 0.

Example

OUTPUT 714;"STATUS:PRESET" !Presets the STATus subsystem.

Related Topics

E1985B GSM/GPRS_AMPS/136_W-CDMA Mobile Test Fast Switching


Diagram Conventions

Diagram Conventions

Last updated: November 5, 2003

Description

Diagram Description

Mnemonics are connected by lines. Each line can be followed in only one direction, as indicated by the arrow at the end of the line. Any combination of mnemonics that can be generated by starting at the root mnemonic and following the line in the direction of the arrow is syntactically correct.

The drawings show the proper use of spaces. Where spaces are required they are indicated by <sp>, otherwise no spaces are allowed between mnemonics.

Complex Command Description

A complex command sets the state of the parameter to ON, and is used to set a value for that parameter. These parameters; amplitude, frequency, gain, number, time, and value can be used as a complex command. Refer to the specific command for the parameter that applies.

Developing Code

It is recommended that you set the test set's operating environment to debug. When debug mode is on, the error message displayed on the test set's front panel when incorrect GPIB syntax is sent to the test set is enhanced with additional information to help you correct the syntax error. To set the test set debug mode to "ON" use the following syntax:

SYSTem:COMMunicate:GPIB:DEBug ON

Data Type Description

num value

Integer, float or scientific values.

For example,

CALL:POWer -55.5

CALL:POWer -5.55E+001

CALL:CHANnel 525

string

Characters. The string will often need to be enclosed in single or double quotes, depending upon your programming environment.

For example,

CALL:CIDentity "#0123456789*"

CALL:UPLink:PRAChannel:ASUBchannels '111111111111'

The string returned by the test set is enclosed by double quotes.
choice1|choice2|choice3

Specific character choices.

For example,

CALL:OPERating:MODE D2KTest

SYSTem:COMMunicate:GPIB:DEBug ON


Step 1: Set Up the Test Set

Step 1: Set Up the Test Set

Last updated: November 5, 2003

The following information provides additional details on Step 1 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you initialize the test set and set up the general operating conditions.

Contents

  • Initialize the Test Set
  • Set Up General Operating Conditions

Initialize the Test Set

  • Fully Preset the Test Set

    It is important to get the test set to a known state before each production session.

    Sending the *RST command fully presets the test set, which ends all call processing and measurement processes and restores all values to defaults.

  • Clear the Error Queue

    Before each production session, it is useful to clear the error queue of any old messages. That way, you know that any messages logged are relevant to the current production session.

    Sending the *CLS command clears the error queue.

Set Up General Operating Conditions

  • Turn Debugger On

    While developing your code, it is very useful to enable the GPIB debugger using the
    SYST:COMM:GPIB:DEB ON command. When the debugger is on, the test set alerts you when you send an incorrect command, and it also tells you which symbol or letter in the command is incorrect.

NOTE
You should turn the debugger off once you have finished development and your code is stable.

  • Set Operating Mode

    The test set contains a base station emulator (BSE), whose primary purpose is to provide enough call processing to allow parametric measurements of a mobile station's RF signal.

    An important characteristic of the test set's base station emulator is its operating mode. The operating mode sets the way in which the base station emulator interacts with the mobile station.

    Active cell mode is used when emulating a normal cell. Active cell mode allows active signaling between the mobile station and BSE. The mobile station camps to the BSE signal, and an actual call is established.

    In test mode, the mobile station synchronizes to the BSE signal and transmits an appropriate signal which the test set analyzes.

    The test set's operating mode is set using the following command:

    Command to Set the Test Set's Operating Mode

    Command

             Example

    CALL:OPER:MODE <operating mode>

    CALL:OPER:MODE CALL

  • Set Amplitude Offsets

    To achieve accurate measurement results, it is important to account for losses in the cabling and fixturing between the mobile station and test set. You must determine what the losses are for your test setup and then specify the appropriate frequency-dependent amplitude offset values.

    You can specify amplitude offsets for up to 20 frequencies using the following commands:

    Commands to Set Amplitude Offsets

    Command

             Example

    SYST:CORR:FREQ <freq1>, <freq2>, <freq3>

    SYST:CORR:FREQ 800MHz, 1800MHz,
    1900MHz

    SYST:CORR[:SGAin] <offset1>,
    <offset2>, <offset3>

             SYST:CORR -0.7, -1.0, -1.2

  • Set Display Mode

    To achieve a slightly faster test execution speed, you can disable the front panel display on the test set using the DISP:MODE FAST command.


Step 2: Configure Test Set and Mobile Station Parameters

Step 2: Configure Test Set and Mobile Station Parameters

Last updated: June 10, 2003

The following information provides additional details on Step 2 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you configure the parameters that allow a connection to be made between the test set and mobile station. This mainly involves setting up channels and power levels.

Contents

  • Set Up Channels
  • Set Cell Power
  • Set Mobile Station Transmit Power
  • Set Up Additional Connection Parameters

Set Up Channels

Setting up channels involves specifying the channel associated with every band and channel type (for example, analog or digital), and then setting the active band and channel type.

  • Specify Channel Numbers

    All of the test set's test applications can test in more than one frequency band (for example, US Cellular, US PCS, or Korean PCS). To produce the most efficient code, you should configure the channel information for each band in advance. Then, to move to a new band during testing, you only need to send the command to change bands. You do not need to also specify the channel of the new band. This reduces test time.

    To set up the channel number for the various bands, use one of the following commands (depending upon which test application you are using):

    Commands to Set the Channel for a Band

    Command

             Example

    CALL:<channel mnemonic>:<band mnemonic>
    <num value>

    CALL:TCH:EGSM 124

    CALL:SET:<channel type mnemonic>:<band
    mnemonic> <num value>

    CALL:SET:DTC:PCS 777

    CALL:CHAN:<channel type mnemonic>:<band
    mnemonic> <num value>

    CALL:CHAN:DIG2000:K
    PCS 384

    This practice also applies to test applications which test both analog and digital channel types. In this case you should specify the channel for the analog and digital channel types in advance. Then, switching between them requires only one command to initiate the change, and not an additional change to specify the channel of the new channel type.

    If you specify channels in advance as described, the only time you need to specify a channel during testing is if you move to a new channel within the same band and channel type.

  • Set Active Band and Mode

    Once you have specified the channel information for each band and channel type, you must set the active band using one of the following commands (depending upon which test application you are using):

    Commands to Set the Active Band

    Command

             Example

    CALL:<channel mnemonic>:BAND <band mnemonic>

    CALL:TCH:BAND
    EGSM

    CALL:SET:<channel type mnemonic>:BAND <band
    mnemonic>

             CALL:SET:DTC:BAND
    PCS
    CALL:BAND:<channel mnemonic> <band mnemonic>

    CALL:BAND:DIG2000
    KPCS

    If the test application you are using supports testing of both analog and digital channel types, then you must also set the channel type using the following command:

    Command to Set the Active Channel Type

    Command

             Example

    CALL:<channel mnemonic>:TYPE <channel type
    mnemonic>

    CALL:TCH:TYPE
    DTC

  • Active Cell and Test Mode Considerations

    The function of the CALL commands differ depending upon whether you are in active cell or test mode.

    In active cell mode, when you use the CALL commands to set the channel numbers, the test set's output frequency and receiver frequency are set. A message is also sent to the mobile station to set its frequency.

    However, in test mode, since the BSE does not send call processing information to the mobile station, the CALL commands only configure the test set's output frequency and receiver frequency. You need to also send the appropriate test mode commands to the mobile station to set it to the correct frequency.

    In test mode, instead of using the CALL commands to configure the test set's frequencies, you may prefer to manually control the RF generator and RF analyzer using the CALL:RFG and RFAN commands, respectively. In either case, you must still send the appropriate test mode commands to the mobile station to move it to the proper frequency.

Set Cell Power

To set the output power of the test set, use the following command:

Command to Set Cell Power
Command | Example
CALL:POW <num value> | CALL:POW -75

  • Active Cell and Test Mode Considerations

    You can use the CALL:POW command to set the cell power in both active cell and test mode. However, in test mode you may prefer to manually control the output power of the test set using the CALL:RFG commands.

Set Mobile Station Transmit Power

In active cell mode, use one of the following commands to set the mobile station transmit power level (depending upon which test application you are using):

Commands to Set Mobile Station Transmit Power
Command | Example
CALL:MS:TXL:<band mnemonic> <num value> | CALL:MS:TXL:DCS <num value>
CALL:SET:MS:<channel type mnemonic>:TXL:<band mnemonic> <num value> | CALL:SET:MS:DIG:TXL:PCS <num value>
CALL:<channel mnemonic>:MS:TXL:<band mnemonic>:BURS <num value> | CALL:PDTCH:MS:TXL:DCS: BURS <num value>

In addition to setting the mobile station transmit level, these commands also automatically configure the test set's receiver at the expected input level, whether in active cell or test mode. However, in test mode, you must also send the appropriate test mode commands to the mobile station to command it to output at the correct level. This is due to the fact that the BSE is not transmitting call processing commands to the mobile station.

  • Manually Setting Expected Power

    Sending the CALL commands in Commands to Set Mobile Station Transmit Power automatically sets the expected input level of the test set's receiver. However, there is another option for setting the receiver's input level in both active cell and test mode. It is often beneficial to manually set the expected input power level using the RFAN commands, rather than using the CALL commands.

    When you set the expected power manually, you tell the test set exactly what power level to expect. Whereas the CALL commands simply tell the test set the range of input level to expect, based on the definition of the mobile station power level (for example, an AMPS/136 mobile station transmitting at power level 3 has an output level in the range of +20 dBm to +26 dBm).

Set Up Additional Connection Parameters

Depending upon the test application you are using, there may be other connection parameters to specify, such as timeslot, timing advance, vocoder, or data rates and types.

In active cell mode, you may also choose to set up network parameters, such as base station identifier numbers (for example, SID) and color codes.

All of these parameters are configured using the CALL subsystem.


Step 3: Set Measurement Parameters

Step 3: Set Measurement Parameters

Last updated: June 10, 2003

The following information provides additional details on Step 3 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you set up the conditions under which the measurements operate. You do this by configuring measurement parameters.

Contents

  • Measurement Parameters Overview
  • Generic Measurement Parameters
  • Measurement-Specific Measurement Parameters

Measurement Parameters Overview

There are two different types of measurement parameters:

  • Generic Measurement Parameters
  • Measurement-Specific Measurement Parameters

The SETup subsystem is used to configure measurement parameters. Each individual measurement parameter can be set and queried using the associated SETup subsystem command. The general hierarchy of the SETup subsystem command structure is as follows:

SETup:<measurement mnemonic>:<measurement parameter> <parameter setting/value>

NOTE
Not all measurements use all measurement parameters. Refer to the GPIB syntax listing for the detailed list of measurement parameters for individual measurements.

Generic Measurement Parameters

There are three types of generic measurement parameters:

  • Measurement Count (used by most measurements)
    Measurement Count State
    Measurement Count Number

  • Measurement Timeout (used by all measurements)
    Measurement Timeout State
    Measurement Timeout Time

  • Measurement Trigger (used by most measurements)
    Trigger Arm (used by all measurements)
    Trigger Source (not applicable to analog measurements)
    Trigger Delay (not applicable to analog measurements)

Measurement Count Parameters

The measurement count parameters control measurement averaging. The STATe command turns averaging on or off, and the NUMBer command determines the number of averages. The SNUMber command is a complex command which allows you to turn averaging on and set the number of averages in one command.

Statistical Measurement Results Parameters
Parameter | Command Syntax
Measurement Count State | SETup:<meas-mnemonic>:COUNt:STATe <ON|1|OFF|0>
Measurement Count Number | SETup:<meas-mnemonic>:COUNt:NUMBer <numeric value>
Measurement Count Number and State | SETup:<meas-mnemonic>:COUNt[:SNUMber] <numeric value>
Programming Example:

OUTPUT Test_set;"SET:DTXP:COUN 10"

sets the multi-measurement count state to ON and set the number of averages to 10 for the digital transmit power measurement.

Measurement Timeout Parameters

Measurement timeout parameters control the maximum time that a measurement executes. TIMe sets the amount of time and STATe determines if the timeout is in use. The STIMe command is a complex command which enables you to set both parameters in one command.

Measurement Timeout Parameters
Parameters | Command Syntax
Measurement Timeout Time and State | SETup:<meas-mnemonic>:TIMeout[:STIMe] <numeric value>[<suffix>]
Measurement Timeout State | SETup:<meas-mnemonic>:TIMeout:STATe <ON|1|OFF|0>
Measurement Timeout Time | SETup:<meas-mnemonic>:TIMeout:TIME <numeric value>[<suffix>]
Programming Example:

OUTPUT Test_set;"SET:DTXP:TIM 10"

sets the measurement timeout state to ON and set the measurement timeout time to 10 seconds for the digital transmit power measurement.

Measurement Trigger Parameters

There are three measurement trigger parameters. They control the arming of a measurement, the source of the trigger, and the trigger's delay.

  • The trigger arm parameter determines whether the test set makes one measurement and then stops (single), or automatically re-arms upon completion of one measurement and repeats the process (continuous). The recommended setting when writing a control program is single (CONTinuous OFF).

  • The trigger source parameter selects the source of the measurement trigger signal. The recommended Trigger Source setting when writing a control program is AUTO.

NOTE
Trigger source is always IMMediate for analog measurements and cannot be changed by the user.

  • The trigger delay parameter controls the delay between the trigger event (the point in time at which the trigger signal is received) and the start of sampling. Negative values indicate that the sampling should occur prior to the trigger event.

NOTE
Trigger delay is not applicable to analog measurements.

Measurement Trigger Parameters
Parameter | Command Syntax
Trigger Arm | SETup:<meas-mnemonic>:CONTinuous <ON|1|OFF|0>
Trigger Source | SETup:<meas-mnemonic>:TRIGger:SOURce <AUTO|IMMediate|PROTocol|RISE>
Trigger Delay | SETup:<meas-mnemonic>:TRIGger:DELay <numeric value>[<suffix>]

NOTE
You can set the Trigger Arm for all measurements to single (CONTinuous OFF) using the following command syntax:

SETup[:ALL]:CONTinuous:OFF

Programming Example:

OUTPUT Test_set;"SET:CONT:OFF"

sets the trigger arm to single for all measurements.

Programming Example:

OUTPUT Test_set;"SET:DTXP:TRIG:SOUR AUTO"

sets the trigger source to AUTO for the digital transmit power measurement.

Programming Example:

OUTPUT Test_set;"SET:DTXP:TRIG:DEL 10 US"

sets the trigger delay to 10 microseconds for the digital transmit power measurement.

Measurement-Specific Measurement Parameters

Measurement-specific measurement parameters set up operating conditions for a specific measurement. For example:

  • Setting the channel power measurement speed in IS-2000
  • Setting ORFS frequency offsets in GPRS
  • Setting number of bits for the FBER measurement in GSM

Refer to the GPIB syntax listing for the detailed list of measurement parameters for individual measurements.

Programming Example:

OUTPUT Test_set;"SET:CPOW:MSP FAST"

sets the IS-2000 channel power measurement speed to fast.

Programming Example:

OUTPUT Test_set;"SET:ORFS:SWIT:FREQ 400 KHZ"

sets the first ORFS offset to 400 kHz.

Programming Example:

OUTPUT Test_set;"SET:FBER:COUN 10000"

sets the number of fast BER bits to test to 10,000 bits.

Program Example Setting Both Generic and Measurement-Specific Measurement Parameters

! Set trigger arm to single for all measurements:
!
OUTPUT Test_set;"SET:CONT:OFF"
!
! *****************************************************
! Configure Modulation Accuracy Measurement:
!
OUTPUT Test_set;"SET:MACC:COUN 5"
! Example of using a complex command to set both the
! measurement count state and number at the same time.
!
OUTPUT Test_set;"SET:MACC:TRIG:SOUR AUTO"
! Sets trigger source to auto.
!
OUTPUT Test_set;"SET:MACC:TIM 15"
! Sets timeout state to ON and time to 15 sec.
!
OUTPUT Test_set;"SET:MACC:EVM10:STAT ON"
! Turns the EVM10 State ON
!
! ******************************************************
! Configure Digital TX Power Measurement:
!
OUTPUT Test_set;"SET:DTXP:COUN 5"
OUTPUT Test_set;"SET:DTXP:TRIG:SOUR AUTO"
OUTPUT Test_set;"SET:DTXP:TIM 5"
!
! ******************************************************
! Configure Frequency Stability Measurement:
!
OUTPUT Test_set;"SET:FST:COUN 3"
OUTPUT Test_set;"SET:FST:TIM 10"
!
! ******************************************************
! Configure Analog TX Power Measurement:
!
OUTPUT Test_set;"SET:ATXP:COUN 5"
OUTPUT Test_set;"SET:ATXP:TRIG:SOUR AUTO"
OUTPUT Test_set;"SET:ATXP:TIM 15"


Step 4: Make Connection

Step 4: Make Connection

Last updated: June 10, 2003

The following information provides additional details on Step 4 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you make a connection between the mobile station and test set. How you do this depends upon whether you are in active cell or test mode. In active cell mode you establish a phone call between the test set and mobile station. In test mode, you command the mobile station to synchronize to the test set's signal and begin transmitting back an appropriate signal.

Contents

  • Establish a Call in Active Cell Mode
  • Make a Test Mode Connection

Establish a Call in Active Cell Mode

To test a mobile station in active cell mode, you must first establish a call between the test set and mobile station. Your control program must issue the commands necessary to initiate the call connection process, either to the test set (for a base station originated call) or to the mobile station (for a mobile station originated call). Your control program must then determine when the call has successfully connected so that it can proceed to testing. The control program must also determine if the call has not been successfully connected so that it can take appropriate action.

Call States

At any instant in time a call can be in a stable state such as the idle or the connected state, or in one of many transitory states such as alerting, handoff, registering, releasing or paging. These are referred to as transitory states because the amount of time which the call can spend in any of these states is limited by the mobile station's protocol. The call is not allowed to stay in a transitory state indefinitely.

NOTE
If repeat paging or repeat registration are on, it is possible for the call process to stay in one of the transitory states beyond the time specified by the mobile station's protocol timers.

Call Connection Synchronization Commands

The test set has a set of commands designed specifically for call connection and release synchronization.

Call Connection Synchronization Commands
Synchronization Command | Command Syntax
Call-Connected-State Query | CALL:CONNected[:STATe]?
Call-State-Change Detector Arm | CALL:CONNected:ARM[:IMMediate]
Call-State-Change Detector Timeout | CALL:CONNected:TIMeout

  • Call-Connected-State Query

    The CALL:CONN? query allows the control program to determine if a call is in the connected state or in the idle state.

    Responses Returned by the CALL:CONN? Query
    Response | Meaning
    1 | The call is in the connected state.
    0 | The call is in the idle state.

    If the call is in one of the transitory states, the query waits until the call reaches the idle state or connected state before returning a value.

  • Call-State-Change Detector Arm Command

    The test set has a call-state-change detector which can be used to temporarily hold the response to a CALL:CONN? query until the call state has moved from idle to connected or vice versa.

    Without the call-state-change detector, the CALL:CONN? query only hangs if the call is in a transitory state. Otherwise, it immediately returns a 1 or 0. Therefore, if a call connection process is started and the CALL:CONN? query is sent before the call state has transitioned from idle to one of the transitory states, the query immediately returns a 0. This indicates that the call is in the idle state (and therefore that the connection attempt failed). In reality, the call likely connected, but not until after the CALL:CONN? query immediately returned a 0.

    When the call-state-change detector is armed during a connection attempt, if the CALL:CONN? query is sent while the call state is still idle, the query waits until the state changes to connected, and then returns a 1.

    The CALL:CONNected:ARM[:IMMediate] command is used to arm this call-state-change detector.

  • Call-State-Change Detector Timeout Command

    If the call-state-change detector is armed and a call connection is attempted but the call state never changes from the idle state, the CALL:CONN? query hangs the bus. This easily happens if the mobile is badly broken, the mobile is not connected to the test set, or no one pushes the send button on the mobile.

    The CALL:CONNected:TIMeout command is used to set the timeout value for the call-state-change detector.

    The timeout timer is started whenever the call-state-change detector is armed, and should be set to the maximum amount of time the control program should wait between arming the detector and the beginning of the connection process (when the call state moves from the idle state). If the timer expires before the call state has moved from the idle or connected state, the call-state-change detector is disarmed, which releases the CALL:CONN? query if it is currently hanging.

Process for Making a Base Station Originated Call

Process for Making a Base Station Originated Call

NOTE
It is not necessary for you to send the CALL:CONN:TIM and CALL:CONN:ARM commands as they are automatically sent by the test set during a base station originated call or base station release.

Programming Example

OUTPUT Test_set;"CALL:PAG:PNUM `0000574016'"! Set paging number
OUTPUT Test_set;"CALL:PAG:REP ON" ! Set paging repeat state
OUTPUT Test_set;"CALL:ORIG" ! Start a base station originated call
OUTPUT Test_set;"CALL:CONN?"  ! Hanging GPIB query
ENTER Test_set;Call_connected      ! Program hangs here until
                                   ! origination passes or fails
IF NOT Call_connected THEN
   OUTPUT Test_set;"CALL:END"
! <put error handler here>
END IF
! Call is connected so proceed with control program

Process for Making a Mobile Station Originated Call

Process for Making a Mobile Station Originated Call

NOTE
The test set cannot originate a call from the mobile station. You must physically dial a number on the mobile station and press send, or send commands to a test bus built into the mobile station. For mobile station originated calls where the call is originated by physically dialing a number (as opposed to using a test bus) ensure that the call-state-change detector timeout time is long enough to allow the number to be dialed.

Programming Example

OUTPUT Test_set;"CALL:CONN:TIM 10"         ! Set timeout time to 10 seconds
OUTPUT Test_set;"CALL:CONN:ARM"            ! Arm the change detector
DISP "Initiate a call from the mobile"
OUTPUT Test_set;"CALL:CONN?"          ! Initiate a call connected state query
ENTER Test_set;Call_connected              ! Program hangs here until
                                           ! origination passes or fails
IF NOT Call_connected THEN
   OUTPUT Test_set;"CALL:END"
! <put error handler here>
END IF
! Call is connected.  Proceed with the control program.

Make a Test Mode Connection

To make a connection between the test set and mobile station in test mode, you must send the appropriate test mode commands to the mobile station to command it to synchronize to the test set's signal and begin transmitting.

You may also want to make a quick power measurement to ensure that the connection has been made.


Step 5: INITiate and FETCh Measurements

Step 5: INITiate and FETCh Measurements

Last updated: June 10, 2003

The following information provides additional details on Step 5 of the Programming Flowchart. This information is applicable to all test applications.

Description

This step involves making measurements on the mobile station.

The test set has multiple signal paths and processors, which means you can make measurements concurrently and reduce test time. Making concurrent measurements involves starting a group of measurements, fetching the results of the measurements as they complete, and then verifying that the results are valid.

In this step you may also choose to make measurements in a more sequential way.

Contents

  • Concurrent Measurement Process
  • Alternative Measurement Process

Concurrent Measurement Process

Process for Making Concurrent Measurements

Start a Set of Concurrent Measurements

The INITiate command is used to start measurements. Each individual measurement can be started using the INITiate command. For starting measurements, the syntax of the INITiate command is as follows:

INITiate:<measurement mnemonic>[:ON]

More than one measurement can be started using a single INITiate command. For example:

OUTPUT Test_set;"INIT:TXP;PFER"

starts the transmit power measurement and the phase and frequency error measurement. These measurements then run concurrently.

Determine if a Measurement Is Done

Use the INITiate:DONE? query command to determine which measurement has completed.

This command is a query only and returns only one response per query. The responses returned and their meanings are shown in the following table:

Responses Returned from INITiate:DONE? Query
Response String | Meaning
<MEASUREMENT1 mnemonic> | MEASUREMENT1 is done.
<MEASUREMENT2 mnemonic> | MEASUREMENT2 is done.
WAIT | There are one or more measurements that are in progress, but none of those measurements are done yet.
NONE | No measurements are in progress.
Responses Returned from INITiate:DONE? Query
Response String | Meaning
<MEASUREMENT1 mnemonic> | MEASUREMENT1 is done.
<MEASUREMENT2 mnemonic> | MEASUREMENT2 is done.
WAIT | There are one or more measurements that are in progress, but none of those measurements are done yet.
NONE | No measurements are in progress.

Once a measurement is reported as being complete via the INITiate:DONE? query it is removed from the done list (it is not reported again). To use the INITiate:DONE? query properly, your control program should immediately fetch a measurement's results once it is reported as being complete.

Obtain a Set of Measurement Results

In order to minimize bus traffic and reduce test time, the test set's measurements are designed to return multiple measured values in response to a single measurement request.

For example, if a transmit power measurement with averaging is initiated there are five measurement results available. These are:

  1. Measurement integrity value
  2. Average value
  3. Minimum value
  4. Maximum value
  5. Standard deviation value

The test set can return the measurement results in a variety of formats to suit your needs using the FETCh? subsystem. The general structure of the FETCh? command is as follows:

FETCh:<measurement mnemonic>:<result format>?

For example, the transmitter power measurement results can be returned as:

Example FETCh? Result Formats
Command | Results Returned
FETC:TXP? | Measurement integrity and average value
FETC:TXP:POW:ALL? | Minimum, maximum, average and standard deviation values
FETC:TXP:POW:AVER? | Average value only
FETC:TXP:POW:MIN? | Minimum value only
FETC:TXP:POW:MAX? | Maximum value only
FETC:TXP:POW:SDEV? | Standard deviation value only
FETC:TXP:INT? | Measurement integrity value only
Concurrent Measurement Process Programming Example

! Start a Set of Concurrent Measurements:
!
OUTPUT Test_set;"INIT:TXP;PFER"
!
! Determine if a Measurement Is Done:
!
LOOP
  OUTPUT Test_set;"INIT:DONE?"
  ENTER Test_set;Meas_done$
!
! Obtain a Set of Measurement Results:
!
  SELECT Meas_done$
    CASE "TXP"
      OUTPUT Test_set;"FETC:TXP:POW?"
      ENTER Test_set;Avg_tx_power
    CASE "PFER"
      OUTPUT Test_set;"FETC:PFER:RMS?"
      ENTER Test_set;Max_rms_phas_er
  END SELECT
EXIT IF Meas_done$="NONE"
END LOOP

Validate Measurement Results

Validating measurement results is extremely important. The test set returns a result if it is capable of making a measurement, even if this result is obtained under adverse conditions.

The measurement integrity indicator is a measurement result and therefore is queried using the FETCh subsystem. A value of 0 indicates that the measurement is valid. A value other than 0 indicates that an error occurred during the measurement process.

Example Integrity Indicators
Value Returned | Description (message also appears on test set)
0 | Normal
1 | No Result Available
2 | Measurement Timeout
5 | Over Range
6 | Under Range
Programming Example

OUTPUT Test_set;"FETC:DTXP?"
ENTER Test_set;Integrity,Avg_dig_pow
IF Integrity=0 THEN
   PRINT "AVG DIG POW= ";Avg_dig_pow
ELSE
   PRINT "DTXP Measurement Error"
   PRINT "DTXP Measurement Integrity is ";Integrity
END IF

Alternative Measurement Process

You may choose to test in a sequential way rather than use the concurrent measurement process.

For instance, instead of using the INIT:DONE? query to determine when a measurement is complete, you may choose to initiate a set of measurements and then simply fetch them sequentially.

Programming Example

OUTPUT Test_set; "INIT:DTXP;MACC"
OUTPUT Test_set; "FETC:DTXP:POW?"
ENTER Test_set;Avg_dig_pow
OUTPUT Test_set; "FETC:MACC:EVM[1]?"
ENTER Test_set;Max_EVM1

In this example, the test set starts both measurements at the same time. However, if the MACC measurement finishes first, the results are not fetched until the DTXP measurement finishes. Therefore, this process requires that you understand the order in which measurements will complete in order to optimize your testing speed.


Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Last updated: June 10, 2003

The following information provides additional details on Step 6 of the Programming Flowchart. This information is applicable to all test applications.

Description

After performing a set of measurements on the mobile station using the configuration established in step 2, you may want to change this configuration and test the mobile station again. This step involves changing testing conditions such as channel, mobile station transmit power level, or cell power.

Contents

  • Change Channels
  • Change Other Connection Parameters

Change Channels

In a manufacturing environment it is common to test a mobile station on more than one channel. Some or all of the tests may be performed on multiple channels, to verify the mobile station's performance in a range of operating frequencies.

Perform a Handoff (Handover) in Active Cell Mode

If you are operating in active cell mode, to change channels you perform a handoff (handover) to the new channel. The control program sends the commands to initiate the handoff (handover), and then determines whether the transition was successfully completed. This is accomplished using the CALL:STATus? query.

The CALL:STATus? query immediately returns the state of the call at the time the query is received.

Example Responses Returned from the CALL:STAT? Query
Response | Meaning
IDLE | The call is in the Idle state
ALER | The call is in the Alerting transitory state.
HAND | The call is in the Handoff transitory state.
PAG | The call is in the Paging transitory state.
CONN | The call is in the Connected state.

After issuing the commands to perform a handoff (handover), you should send the CALL:STAT? query to verify that the call is still connected before resuming testing.

Process for Performing a Handoff (Handover)

Test Mode Considerations

In test mode, you can either change the test set's frequencies by using the handoff (handover) commands, or directly control the RF generator and RF analyzer.

In either case, you must also send the appropriate test mode commands to the mobile station to move it to the new channel.

Change Other Connection Parameters

You may also choose to change the mobile station transmit power level or cell power, or other connection parameters such as timeslot or timing advance.


Step 7: End Connection

Step 7: End Connection

Last updated: June 10, 2003

The following information provides additional details on Step 7 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you release the call (in active cell mode) or end the mobile station transmission (in test mode).

Contents

  • Release the Call in Active Cell Mode
  • End the Mobile Station Test Mode Transmission
  • Partially Preset the Test Set

Release the Call in Active Cell Mode

In active cell mode, you can release the call with the mobile station in one of two ways:

  • Release from the Base Station

  • Release from the Mobile Station

Releasing an Active Call from the Base Station

Process for Releasing an Active Call from the Base Station
Programming Example

OUTPUT Test_set;"CALL:END"        ! Initiate a base station release.
OUTPUT Test_set;"CALL:CONN?" 	 	! Send call connected state query.
ENTER Test_set;Call_connected     ! Program hangs here until state
                                  ! change or timer expires.
IF Call_connected THEN            ! Check if disconnection successful
! <put error handler here>
END IF
! Call is disconnected so proceed with control program

Releasing an Active Call from the Mobile Station

Process for Terminating an Active Call from the Mobile Station

NOTE
The test set cannot initiate a call disconnection from the mobile station. You must manually push the end button on the mobile station or send commands to a test bus built into the mobile station. For a mobile station release where the call is terminated by physically pushing a button on the phone (as opposed to using a test bus) ensure that the call-state-change-detector timeout time is long enough to allow the end button to be pushed.

Programming Example

OUTPUT Test_set;"CALL:CONN:TIM 5" !Set timeout time to 5 seconds.
OUTPUT Test_set;"CALL:CONN:ARM"   !Arm the change detector.
DISP "Terminate the call from the mobile station."
OUTPUT Test_set;"CALL:CONN?" !Initiate call connected state query.
ENTER Test_set;Call_connected     !Program hangs here until state
                                  !change or timer expires.
IF Call_connected THEN            !Check if disconnection successful.
! <put error handler here>
END IF
! Call is disconnected so proceed with control program

End the Mobile Station Test Mode Transmission

In test mode, you must send the necessary test mode commands to end the mobile station transmission.

Partially Preset the Test Set

At this point, it is good practice to partially preset the test set by sending the SYST:PRES3 command. This command stops all measurement and call processing processes, but does not reset all values to default.


Programming: Getting Started Guide for GSM/GPRS_AMPS/136_W-CDMA

Programming: Getting Started Guide for GSM/GPRS_AMPS/136_WCDMA Mobile Test

Introduction

Last updated: June 10, 2003

The Getting Started Guide is organized around the basic set of tasks a control program normally performs when testing a mobile station in a manufacturing environment.

Click on any step in the flowchart below to learn more about how to program the Agilent Technologies 8960 to perform these tasks.

Programming Flowchart

  • Step 1: Set up the Test Set
  • Step 2: Configure Test Set and Mobile Station Parameters
  • Step 3: Set Measurement Parameters
  • Step 4: Make a Connection
  • Step 5: INITiate and FETCh Measurements
  • Step 6: Reconfigure Test Set and Mobile Station Connection Parameters
  • Step 7: End the Connection

You can also use the buttons on each page to navigate between steps, return to the flowchart, or to find more detailed information about each step.

How to use the programming flowchart for switching between formats

It is important for you to understand how to utilize the programming flowchart when designing a control program to switch between multiple formats. In steps 1,2, and 3 of the programming flowchart, you set up the test set and configure parameters for each applicable format all at once. In contrast, you implement steps 4-7 for only one format at a time. Flowchart for the fast switching test application illustrates in greater detail how to perform these steps for each format. Example code for multiple formats is contained in steps 4-7 of this guide.

Flowchart for the fast switching test application

Conventions used in this Getting Started Guide

Throughout this Getting Started Guide the term "test set" refers to an Agilent Technologies 8960 Series 10 Wireless Communications Test Set with the E1985B GSM/GPRS_AMPS/136_WCDMA mobile test application installed.

The variable Testset used in the steps of the Getting Started Guide refers to the test set's GPIB address.

How to use this Getting Started Guide

The most effective way to use this Getting Started Guide is with the Programming Flowchart included inside this guide and the 8960 User Documentation. This documentation is found in two locations:

  • the 8960 Series 10 Support Site (updated frequently) on the Internet, or
  • the User Documentation CD-ROM shipped with your test application.

Each step on the Programming Flowchart is illustrated with example program code in this guide. Using this Getting Started Guide, the Programming Flowchart, and the on-line information about 8960 programming, you will be able to generate a control program to perform fundamental mobile station manufacturing tests.

Useful on-line links

Go to the 8960 Series 10 Support Site on either the CD-ROM or the Internet. The CD-ROM should self-launch to its home page. The URL for the website is:

http://www.agilent.com/find/8960support/

Navigate to the Programming page for this test application. The illustrations on the back of the Programming Flowchart show you how to navigate to this page.

The following links are under the heading Getting Started on the Programming page:

  • Programming: Getting Started Guide
    • This on-line version of this guide contains links to more detailed information about each step which may be useful as you develop your control program.
  • Control Program Examples
    • These examples are for you to download. You may want to use these as templates for your own control program or to execute.
    • The control program explained in the Getting Started Guide is also available here for you to download. It is a fully functional control program.

About the Programming Examples Presented in this Guide

Programming Language:

Programming examples presented in this guide are written in the HP BASIC programming language, also known as RMB or Rocky Mountain BASIC. The use of HP BASIC is not an endorsement of the HP BASIC product.

Line Numbers

All of the programming examples in the guide with line numbers are sections from a control program example available on-line for you to download.

Code that is not part of the download control program example does not have line numbers. This code may represent an alternate method of performing the task or may illustrate a feature not used by the control program example.

Syntax used in Programming Examples:

  • The programming examples use the shortened form of the command syntax to minimize GPIB bus transactions. The shortened form of a command is defined by use of capital letters in the command syntax. For the command syntax:

 RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO?

    the shortened form would be:

 RFAN:CONT:MEAS:FREQ:AUTO?
  • The programming examples do not include optional nodes. Optional nodes in the command syntax are defined by enclosing the node inside the [ ] brackets. For example, the command syntax:

 CALL[:CELL]:POWer[:SAMPlitude] -80dBm

    appears in the programming examples as:

 CALL:POW -80dBm

  • Programming examples make extensive use of compound commands using the ; and the ;: separators. Refer to the on-line information for the definition and use of these command separators.

Complex Commands

Complex commands are used to configure the state and assign values to parameters simultaneously. Complex commands can be used to save programming steps and minimize GPIB bus transactions.

  • The syntax below turns the state of the parameter on.

    OUTPUT Test_set;"SET:DTXP:TIM:STAT ON"

  • The syntax below is used to assign a value to the parameter.

    OUTPUT Test_set;"SET:DTXP:TIM:TIME 10 S"

  • Both of the above actions can be accomplished with one syntax command:

    OUTPUT Test_set;"SET:DTXP:TIM:STIM 10 S"

    The command above sets the parameter state to ON and the value of the parameter to 10 seconds. Note that in this example the optional command mnemonic :STIMe has been included to clarify that this complex command was used to set both the state and the value.

  • This command can be shortened further by removing the optional command mnemonic :STIMe, as shown below.

    OUTPUT Test_set;"SET:DTXP:TIM 10 S"

    This is the format that will be used throughout this guide.


Step 1: Set up the Test Set

Step 1: Set up the Test Set

Last updated: June 10, 2003

This step explains how to:

  • Fully Preset the Test Set
  • Turn on the GPIB Debugger
  • Select the Active Format

Fully Preset the Test Set

To set up the test set, you begin by sending the *RST command. *RST is used to perform a full preset of the test set, returning it to a known state. *RST also sets all measurements to single trigger.

All measurement triggers are set to single in all the test formats supported by the test application when the *RST command is sent.

Turn on the GPIB Debugger

A useful tool that you may want to turn on at this time is the GPIB command debugger. While turned on, error messages containing debugging information appear on the test set's screen when the test set receives an unknown GPIB command. The information indicates what type of error was caused and where in the syntax the error occurred. Troubleshooting, like locating and fixing typing errors for example, becomes easier using the GPIB command debugger.

This command should be taken out of your code once development is completed. It does increase your test time. The SYST:COMM:GPIB:DEB:STAT ON command only assists you when debugging code.

Select the Active Format

The SYST:APPL:FORM command used in the diagram switches the test set to the correct format. This is a very fast switch because it occurs within the test application. Switches to other test applications use a different command and take much longer. Refer to user documentation on your CD-ROM or the Internet for more information about fast switching.


Step 2: Configure Test Set and Mobile Station Parameters

Step 2: Configure Test Set and Mobile Station Parameters

Last updated: June 10, 2003

Many of the parameters configured in this step are being set to their default values. In a manufacturing environment it may be desirable to explicitly configure these parameters to ensure that the required settings have not been changed by someone setting a parameter's value through the test set's front panel. However, greater code efficiency can be achieved by not configuring them.

Configure test set and mobile station parameters

It is possible for you to configure the test set and mobile station parameters for all test formats supported by the test application at the beginning of your program. The following examples illustrate how to set up parameters for all available formats after having selected the GSM format as the active format in Step 1: Set up the Test Set .

  • Set up parameters for GSM
  • Set up parameters for AMPS/136
  • Set up parameters for GPRS

Set up parameters for GSM

Notice the use of the :GSM identifier appended to the CALL:POW:AMPL command. Identifiers are used with commands or queries that are shared by test formats. They enable you to send commands to an inactive test format. Therefore, it is not necessary to use the :GSM format identifier below because GSM is the active test format. It is included here to demonstrate the use of format identifiers.

670   OUTPUT Testset;"CALL:POW:AMPL:GSM ";Gsm_level
680   OUTPUT Testset;"CALL:BAND EGSM"
690   OUTPUT Testset;"CALL:TCH 5;BCH 32;:CALL:MS:TXL 0;TADV 0"

Set up parameters for AMPS/136

Notice the use of the format identifier appended to the CALL:POW:AMPL command. The format identifier for the AMPS/136 Mobile Test format is :TA136 . The format identifier for the digital system in AMPS/136 format is

:DIG136
. None of the other commands sent below require this format identifier because they are unique to the AMPS/136 test format.

720   OUTPUT Testset;"CALL:OPER:MODE CALL"
730   OUTPUT Testset;"CALL:POW:AMPL:TA136 ";Tdma_level
740   OUTPUT Testset;"CALL:DCCH 1013"
750   OUTPUT Testset;"CALL:SET:AVC 387"
760   OUTPUT Testset;"CALL:SET:DTC:BAND CELL"
770   OUTPUT Testset;"CALL:SET:DTC:CHAN:CELL 542"
780   OUTPUT Testset;"CALL:SET:DTC:CHAN:PCS 1000"
790   OUTPUT Testset;"CALL:TCH:TYPE DTC"
800   OUTPUT Testset;"CALL:SET:MS:ANAL:TXL 2"
810   OUTPUT Testset;"CALL:SET:MS:DIG:TXL:CELL 2"
820   OUTPUT Testset;"CALL:SET:MS:DIG:TXL:PCS 2"
830   ! Set up the AVC for the SINAD measurement.
840   ! Turn off the internal FM until connection is on an AVC.
850   OUTPUT Testset;"CALL:FM:INT:STAT OFF;DEV 8KHZ;FREQ 1004HZ"

Set up parameters for GPRS

GSM and GPRS share many parameters. You will see this again in Step 3: Set Measurement Parameters where many identifiers are used to set up GPRS measurement parameters while also setting up measurement parameters for GSM while GSM is the active format.

You can see the use of the format identifier for the GPRS Mobile Test format, :GPRS , in the following example code.

!  Configure GPRS parameters
OUTPUT Test_set;"CALL:BAND:GPRS PGSM"! Set broadcast band
OUTPUT Test_set;"CALL:POW:GPRS -80"! Set cell power to -80 dBm.
OUTPUT Test_set;"CALL:PDTCH 45"! Set packet data traffic channel
OUTPUT Test_set;"CALL:FUNC:DATA:TYPE BLER"! Data connection type
!
! Set Multi-slot Configuration to two downlinks and one uplink.
OUTPUT Test_set;"CALL:PDTCH:MSL:CONF D2U1"
OUTPUT Test_set;"CALL:PDTCH:CSCH CS4"! Set Coding Scheme to CS4
! Assign values to the power reduction levels
OUTPUT Test_set;"CALL:PDTCH:PZER:LEV 16" ! Assign a value to P0
OUTPUT Test_set;"CALL:PDTCH:PRED:LEV2 6" ! Set PRL2 to 6dB
! Assign power levels to the downlink bursts
OUTPUT Test_set;"CALL:PDTCH:PRED:BURS2 PRL2"
!
! Assign a power level to the uplink burst
OUTPUT Test_set;"CALL:PDTCH:MS:TXL:BURS 5"


Step 3: Set Measurement Parameters

Step 3: Set Measurement Parameters

Last updated: June 10, 2003

  • Set trigger to single for all measurements
  • Set measurement parameters

Set trigger to single for all measurements

You can send either the *RST command, as discussed in Fully Preset the Test Set , or the following command to set the trigger to single for all measurements in all the test formats supported by the test application. In the example below, the command is commented out (by preceding it with an !) because in the control program example utilized throughout this guide, the *RST command is used, making the SET:CONT:OFF command unnecessary. If you choose to not send the *RST command, make sure to uncomment this line.

950   ! OUTPUT Testset;"SET:CONT:OFF"

Set measurement parameters

The most efficient use of a test application supporting multiple test formats is to complete measurement setups at times when the test system is doing something else. This example illustrates setting up measurement parameters for the test formats at the beginning of the program, presumably while a phone is being prepared for RF test.

For more information about the measurement parameters, refer to the additional details about this step available on your CD-ROM or the Internet.

  • Set GSM measurement parameters
  • Set AMPS/136 measurement parameters
  • Set GPRS measurement parameters

Set GSM measurement parameters

For more details about specific GSM measurement parameters, refer to the 8960 User Documentation for the GSM Mobile Test Application available on your CD-ROM or the Internet.

980   OUTPUT Testset;"SET:PFER:TIM 5;COUN 1"
990   OUTPUT Testset;"SET:PVT:TIM 5;COUN 10"
1000  OUTPUT Testset;"SET:PVT:TIME -28us,-10us,321.2us,552.8us,570.8us"
1010  OUTPUT Testset;"SET:ORFS:TIM 7;COUN:STAT OFF"
1020  !
1030  ! This example puts the switching and modulation offsets to be
1040  ! tested into string variables.  Mod$ contains the modulation
1050  ! offsets while Swit$ contains the switching offsets.
1060  Mod$="200KHZ,-200KHZ,400KHZ,-400KHZ"
1070  Swit$="400KHZ,-400KHZ,600KHZ,-600KHZ"
1080  OUTPUT Testset;"SET:ORFS:MOD:COUN 10;FREQ "&Mod$
1090  OUTPUT Testset;"SET:ORFS:SWIT:COUN 20;FREQ "&Swit$
1100  OUTPUT Testset;"SET:FBER:COUN 10000"

Set AMPS/136 measurement parameters

For more details about specific AMPS/136 measurement parameters, refer to the 8960 User Documentation for the AMPS/136 Mobile Test Application available on your CD-ROM or the Internet.

1140  ! Digital Measurement Parameters
1150  OUTPUT Testset;"SET:DTXP:TIM 3;COUN 10"
1160  OUTPUT Testset;"SET:MACC:TIM 3;COUN 1"
1170  OUTPUT Testset;"SET:MACC:EVM10:STAT ON"
1180  OUTPUT Testset;"SET:ACP:TIM 3;COUN 1"
1190  !
1200  ! Analog Measurement Parameters
1210  OUTPUT Testset;"SET:FST:TIM 3;COUN 1"
1220  OUTPUT Testset;"SET:ATXP:TIM 3;COUN 10"
1230  OUTPUT Testset;"SET:FM:TIM 3;COUN 1"
1240  OUTPUT Testset;"SET:FM:FREQ:STAT ON"
1250  OUTPUT Testset;"SET:FM:DIST:STAT ON;FREQ 6000"
1260  OUTPUT Testset;"SET:FM:DET PPE"
1270  OUTPUT Testset;"SET:FM:FILT:TBP 6000"
1280  OUTPUT Testset;"SET:FM:FILT TBP"
1290  !
1300  ! Audio Measurement Parameters
1310  OUTPUT Testset;"SET:AFAN:FREQ:STAT ON"
1320  OUTPUT Testset;"SET:AFAN:FILT CMES;TIM 3;COUN 5;PEAK:VOLT 1"
1330  OUTPUT Testset;"SET:AFAN:SDIS:STAT ON;FREQ 1004"

Set GPRS measurement parameters

For more details about specific GPRS measurement parameters, refer to the 8960 User Documentation for the GPRS Mobile Test Application available on your CD-ROM or the Internet.

! Configure ORFS Measurement
!
OUTPUT Test_set;"SET:ORFS:TIM:GPRS 20"! Set timeout time.
Swit$=".4MHZ,-.4MHZ,.6MHZ,-.6MHZ,1.2MHZ,-1.2MHZ,1.8MHZ,-1.8MHZ"
OUTPUT Test_set;"SET:ORFS:SWIT:COUN:GPRS 20"
OUTPUT Test_set;"SET:ORFS:SWIT:FREQ:GPRS "&Swit$
!
! Configure Power vs. Time Measurement for GSM and GPRS:
!
Pvt$="-28us,-10us,321.2us,552.8us,570.8us"
OUTPUT Test_set;"SET:PVT:TIM:GPRS 10"
OUTPUT Test_set;"SET:PVT:COUN:GPRS 5"
OUTPUT Test_set;"SET:PVT:TIME:GPRS "&Pvt$
!
! Configure Phase & Frequency Error Measurement for GSM and GPRS:
!
OUTPUT Test_set;"SET:PFER:COUN 10;TIM 5"
OUTPUT Test_set;"SET:PFER:TIM:GPRS 5"
OUTPUT Test_set;"SET:PFER:COUN:GPRS 10"
OUTPUT Test_set;"SET:PFER:SYNC MID;SYNC:GPRS MID"


Step 4: Make a Connection

Step 4: Make a Connection

Last updated: June 10, 2003

For more information about various ways to make a connection with the mobile station, refer to the Programming: Getting Started Guide for the specific mobile test technologies.

In this control program example, a GSM call is established first. After you switch formats at the end of Step 7: End the Connection , it will again be necessary to establish a call. (See the fast switching test application flowchart, Flowchart for the fast switching test application to see the process for using multiple formats.) Following are code examples for making a connection in different formats.

  • Subroutine for making GSM and AMPS/136 connections
  • Make a GSM connection
  • Make an AMPS/136 connection

Subroutine for making GSM and AMPS/136 connections

A subroutine for making connections is used because this same code is used more than once. This provides greater code efficiency.

The code for the subroutine is below:

3870  SUB Orig_call(Format$)
3880    COM INTEGER Testset
3890    PRINT "Turn the ";Format$;" phone on now."
3900    PRINT "When the phone camps, press `F2' to continue."
3910    PAUSE
3920    CLEAR SCREEN
3930    PRINT "Originate a call on the ";Format$;" Mobile now."
3940    OUTPUT Testset;"CALL:CONN:TIM 10"
3950    OUTPUT Testset;"CALL:CONN:ARM"!Arm the Call-State-Change
3960                                  ! Detector
3970    OUTPUT Testset;"CALL:CONN?"!Query State
3980    ENTER Testset;Callstate
3990    IF NOT Callstate THEN
4000      Orig_failed
4010    END IF
4020  SUBEND

Make a GSM connection

The subroutine to establish the GSM connection is called using the code below.

1390  Orig_call("GSM") ! Subroutine for originating a call from the MS

Make an AMPS/136 connection

After performing all GSM measurements, ending the GSM connection, and switching the test set to the AMPS/136 format, you can establish an AMPS/136 connection by calling the subroutine again. See Flowchart for the fast switching test application illustrates this process for making use of the multiformat capability.

2020  Orig_call("AMPS/136")


Step 5: INITiate and FETCh Measurements

Step 5: INITiate and FETCh Measurements

Last updated: June 10, 2003

This step explains how to:

  • INITiate a set of measurements
  • FETCh measurement results using a subroutine
  • Measurement Integrity Indicators

INITiate a set of measurements

The current active format is GSM. Therefore, GSM measurements are INITiated and FETChed first. Flowchart for the fast switching test application diagrams the process for using multiple formats.

  • INITiating GSM measurements
  • INITiating AMPS/136 measurements

INITiating GSM measurements

The example below illustrates how to start four GSM measurements running concurrently. The FBER (Fast Bit Error Rate) measurement is a receiver measurement. This makes use of the test set's ability to make transmitter and receiver measurements at the same time.

1510    OUTPUT Testset;"INIT:FBER;PFER;PVT;ORFS"

INITiating AMPS/136 measurements

The sections below contain examples illustrating how to start AMPS/136 digital and analog measurements.

Digital

2110    OUTPUT Testset;"CALL:MS:REP:MAHO ON"
2120    OUTPUT Testset;"CALL:POW:TA136 ";Maho_level
2130    OUTPUT Testset;"INIT:DTXP;MACC;ACP"

Analog

2410  OUTPUT Testset;"CALL:FM:INT:STATE ON"
2420  OUTPUT Testset;"CALL:POW ";Sinad_level
2430  OUTPUT Testset;"INIT:ATXP;FST;AFAN;FM"

FETCh measurement results using a subroutine

In a typical control program, measurements are repeated on various frequencies and power levels. Therefore, it is desirable to have a subroutine capable of fetching multiple measurement results. The example code below demonstrates how you might create a subroutine for fetching the measurement results. Refer to the additional details available on your CD-ROM or the Internet for more information about the different measurement results that are available and how to fetch them.

4100  SUB Fetch_results
4110    COM INTEGER Testset
4120    REPEAT
4130      OUTPUT Testset;"INIT:DONE?"
4140      ENTER Testset;Measdone$
4150      SELECT Measdone$
4160      CASE "DTXP"
4170        OUTPUT Testset;"FETC:DTXP?"
4180        ENTER Testset;Integrity,Power
4190        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4200        Print_results(Measdone$,Power)
4210      CASE "MACC"
4220        OUTPUT Testset;"FETC:MACC?"
4230        ENTER Testset;Integrity,Evm,Ferr,Ooff,Perr,Mag,Evm10
4240        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4250        Print_results(Measdone$,Evm,Ferr,Ooff,Perr,Mag,Evm10)
4260      CASE "ACP"
4270        OUTPUT Testset;"FETC:ACP?"
4280        ENTER Testset;Integrity,Adjl,Adjh,Alt1l,Alt1h,Alt2l,Alt2h
4290        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4300        Print_results(Measdone$,Adjl,Adjh,Alt1l,Alt1h,Alt2l,Alt2h)
4310      CASE "ATXP"
4320        OUTPUT Testset;"FETC:ATXP?"
4330        ENTER Testset;Integrity,Power
4340        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4350        Print_results(Measdone$,Power)
4360      CASE "FST"
4370        OUTPUT Testset;"FETC:FST?"
4380        ENTER Testset;Integrity,Ferr,Freq
4390        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4400        Print_results(Measdone$,Ferr,Freq)
4410      CASE "AFAN"
4420        OUTPUT Testset;"FETC:AFAN?"
4430        ENTER Testset;Integrity,Level,Sinad,Dist
4440        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4450        OUTPUT Testset;"FETC:AFAN:FREQ?"
4460        ENTER Testset;Freq
4470        Print_results(Measdone$,Level,Dist,Sinad,Freq)
4480      CASE "FM"
4490        OUTPUT Testset;"FETC:FM?"
4500        ENTER Testset;Integrity,Dev,Dist,Freq
4510        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4520        Print_results(Measdone$,Dev,Dist,Freq)
4530      CASE "PVT"
4540        OUTPUT Testset;"FETC:PVT?"
4550        ENTER Testset;Integrity,Mask,Power,Pvt1,Pvt2,Pvt3,Pvt4,Pvt5
4560        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4570        Print_results(Measdone$,Mask,Power,Pvt1,Pvt2,Pvt3,Pvt4,Pvt5)
4580      CASE "PFER"
4590        OUTPUT Testset;"FETC:PFER?"
4600        ENTER Testset;Integrity,Rmsperr,Peakperr,Ferr
4610        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4620        Print_results(Measdone$,Rmsperr,Peakperr,Ferr)
4630      CASE "ORFS"
4640        OUTPUT Testset;"FETC:ORFS:INT?"
4650        ENTER Testset;Integrity
4660        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4670        OUTPUT Testset;"FETC:ORFS:SWIT?"
4680        ENTER Testset;S1,S2,S3,S4
4690        OUTPUT Testset;"FETC:ORFS:MOD?"
4700        ENTER Testset;Pow_30khz,M1,M2,M3,M4
4710        Print_results(Measdone$,S1,S2,S3,S4,M1,M2,M3,M4,Pow_30khz)
4720      CASE "FBER"
4730        OUTPUT Testset;"FETC:FBER:INT?;RAT?"
4740        ENTER Testset;Integrity,Fber
4750        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4760        Print_results(Measdone$,Fber)
4770      END SELECT
4780    UNTIL Measdone$="NONE"
4790  SUBEND

Measurement Integrity Indicators

When the test set performs a measurement, it always returns a measurement result even when the measurement was made under adverse conditions. Therefore, you should check the measurement integrity indicator value to ensure it is zero. If the value is something other than zero, the returned measurement result is not valid. Refer to the user documentation on your CD-ROM or the Internet for more information about integrity indicators.

3380  SUB Bad_integrity(Integrity,Meas_name$)
3390    IF Integrity<>0 THEN
3400       PRINT "Warning: ";Meas_name$;" Integrity =";Integrity
3410    END IF
3420  SUBEND


Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Last updated: June 10, 2003

There are several ways you may want to reconfigure the connection parameters. For more information refer to the Programming: Getting Started Guide for the specific mobile test technologies.

The first active format in the control program example is GSM. Flowchart for the fast switching test application diagrams the process for using multiple formats.

Below are examples of reconfiguring parameters from the control program example for:

  • GSM
  • AMPS/136

GSM

Here, the GSM call is reconfigured to a new channel, a new mobile station transmit level, and a new band. The state of the call is checked after the reconfiguration to ensure the call is maintained.

1640      OUTPUT Testset;"CALL:TCH 25;:CALL:MS:TXL 0"
1650      OUTPUT Testset;"CALL:TCH:BAND DCS"
1660      OUTPUT Testset;"CALL:STAT?"
1670      ENTER Testset;Callstat$
1680      IF Callstat$<>"CONN" THEN Dropped_call

AMPS/136

The code below illustrates using a loop to reconfigure the connection first to a different band and then to an analog voice channel.

2220    IF I=1 THEN ! Just did TDMA 800, get ready for TDMA 1900
2230      OUTPUT Testset;"CALL:SET:DTC:BAND PCS"
2240      PRINT ""
2250      PRINT "TDMA PCS Results:"
2260    ELSE   ! Done doing TDMA 1900, get ready for Analog
2270      OUTPUT Testset;"CALL:TCH:TYPE AVC"
2280      PRINT ""
2290      PRINT "Analog Results:"
2300    END IF
2310    OUTPUT Testset;"CALL:HAND"
2320    OUTPUT Testset;"CALL:STAT?"
2330    ENTER Testset;Callstat$
2340    IF Callstat$<>"CONN" THEN Dropped_call
2350  NEXT I


Step 7: End the Connection

Step 7: End the Connection

Last updated: June 10, 2003

  • End the connection for GSM and AMPS/136
  • Switch formats
  • Make a new connection

End the connection for GSM and AMPS/136

For more information about ways to end the connection with the mobile station, refer to the Programming: Getting Started Guide for the specific mobile technologies.

The example below illustrates how to end the connection from the test set. The commands needed to perform this function are the same for both GSM and AMPS/136 formats. They are different for other formats supported by the test application.

1780  OUTPUT Testset;"CALL:END"
1790  OUTPUT Testset;"CALL:CONN?"
1800  ENTER Testset;Callstate
1810  IF Callstate=1 THEN
1820    PRINT "Make sure the GSM phone has released the call."
1830    OUTPUT Testset;"SYST:PRES3"
1840  END IF

Switch formats

At this point in your control program, you can switch to a new format. The process for using multiple formats of the test application is diagramed in Flowchart for the fast switching test application . The example code below illustrates activating the AMPS/136 format.

1960  OUTPUT Testset;"SYST:APPL:FORM `AMPS/136'"

Similarly, to activate the GPRS format, use the following example code.

OUTPUT Test_set;"SYST:APPL:FORM `GPRS'"

Make a new connection

It is possible for you to begin testing in a new format immediately. All the set up has already been done. Testing can begin by repeating steps 4, 5, and 6 as illustrated in Flowchart for the fast switching test application . To establish the new connection, see Step 4: Make a Connection .


Control Program Examples

Control Program Examples

Last updated: November 5, 2003

HP BASIC

For your convenience we have combined the programming examples shown in the Getting Started Guide into one program. This program, written using HP BASIC, is a fully functional control program using the fast switching test application to test the GSM and AMPS/136 features of a mobile station. You can use this control program as a starting point for developing your own programs. Click on the link below to view the program:

  • Control Program Example for GSM and AMPS/136 Multi-format Test


E1985C GSM/GPRS_cdma2000/IS-95/AMPS Fast Switching Mobile Test Application

E1985C GSM/GPRS_cdma2000/IS-95/AMPS Fast Switching Mobile Test Application

Last updated: November 13, 2003

The Agilent Technologies E1985C GSM/GPRS_cdma2000/IS-95/AMPS Fast Switching Mobile Test Application allows you to switch between GSM/GPRS and cdma2000/IS-95/AMPS formats very quickly. The E1985C GSM/GPRS_cdma2000/IS-95/AMPS mobile test application combines the measurements and features from the E1968A GSM/GPRS and the E1962B cdma2000/IS-95/AMPS Mobile Test Applications into a single fast switching test application.

The E1968A GSM/GPRS Mobile Test Application is the parent test shell for the option 101 GSM mobile test functionality and the option 102 GPRS mobile test functionality. A GSM and GPRS functionality suite is provided by E1968A option 201.

Different Switching Methods

Format Switching allows you to fast switch between formats that are bundled in one fast switching application. The E1985C GSM/GPRS_cdma2000/IS-95/AMPS application contains versions of GSM/GPRS and cdma2000/IS-95/AMPS formats and allows you to rapidly switch between them. However, you must hold a license for the desired format to be able to switch to that format. Select SYSTEM CONFIG > Format Switch for viewing and switching formats within the E1985C.

Application Switching (which is significantly slower than Format Switching) does not require the E1985C application. However, to perform Application Switching, you must have more than one test application installed in your test set to switch between these test applications (for example, E1968A GSM/GPRS and the E1962B cdma2000/IS-95/AMPS test application). Application switching is simply switching between individual applications. The applications that are currently installed in your test set can be viewed and switched from the SYSTEM CONFIG screen. Select Application Selection > Application Switch for viewing and switching test applications.

Refer to the individual application Online User's Manual when you need operating details about a particular format (GSM/GPRS or cdma2000/IS-95/AMPS).

Format Switching

This section contains details on the following:

  • Overview
  • Application Revision and Licensing
  • Power Up
  • GPIB Commands GPIB Commands
  • Format Switching Behavior
  • Error Messages
  • Distinguishing between Formats with Common Command Syntax

Overview

A format selected in a fast switching test application becomes the active format. All other formats at this time are inactive.

Application Revision and Licensing

You must have application licenses installed in your test set for each application you want to switch between. Refer to the following diagrams for details on the licenses you require to switch between formats.

Once you install the E1985C GSM/GPRS_cdma2000/IS-95/AMPS application, there is no need to upgrade the individual applications. You only need to upgrade the E1985C application as this contains the latest revisions of the individual applications that you have licensed. Note that if you want to revert back to your earlier revision of an individual application, you have to perform a slower application switch to do this. The E1985C GSM/GPRS_cdma2000/IS-95/AMPS application is not using your previously installed earlier revision individual test applications. The E1985C is a self-contained application which combines the latest revision of the two formats into one test application.

If you are not able to switch formats, check the test set to see that the formats you are trying to switch between are licensed. License information for each format within the E1985C can be viewed from the SYSTEM CONFIG screen, by selecting the Format Switch menu (F2). The letter indicating the license status of each format is shown in the License column on the right side of the screen. The license status is either; Licensed "L", Not Licensed "N", or Unknown "U":

  • "L"- A Licensed revision of this test application is present. This means that you can switch to this format.
  • "N" - You do not have a licensed revision of this test application. This means that you will not be able to switch to this format. If you select a revision which is Not Licensed, the following error message will be displayed: +133 Configuration error; Selected Partition is not licensed (License = N).
  • "U" - This test application revision has Unknown license status.

Power Up

The format the E1985C GSM/GPRS_cdma2000/IS-95/AMPS application powers up in depends on the licenses that are present on the test set. The E1985C will boot up into the first available licensed Test Application Partition that is present according to the following order: GSM/GPRS, cdma2000/IS-95/AMPS. When the E1968A GSM/GPRS format license is present, the test set selects the GSM/GPRS format at power up as the active format. The GSM/GPRS format must also have optional licenses corresponding to GSM functionality and/or GPRS functionality. Check this functionality by pressing the SYSTEM CONFIG button which will list GSM TA in the "License Status" area if GSM functionality is licensed. GPRS TA will be listed if GPRS functionality is licensed.

The Connection Type will default to AUTO, ready to make GSM voice calls, when the E1985C powers up into the GSM/GPRS format and the E1968A is licensed for GSM functionality. If the E1968A is only licensed for GPRS functionality, the Connection Type setting will default to BLER, ready to perform GPRS data connections.

GPIB Commands

To perform a format switch or query the name of the currently active format, use the command SYSTem:APPLication:FORMat[:NAME] .

To query the license status of any of the formats, use the command SYSTem:APPLication:FORMat:LICense? '<format name>' .

To query the names of all the formats which are available, use the command SYSTem:APPLication:CATalog:FORMat? .

To query the total number of formats which are available, use the command SYSTem:APPLication:CATalog:FORMat:COUNt? .

For further details on these commands and other SYSTem:APPLication commands, see SYSTem:APPLication .

Format Switching Behavior

Switching formats affects the test set in the same way that a partial preset does.

Full and partial presets affect all formats in the GSM/GPRS_cdma2000/IS-95/AMPS Mobile Test Application whether or not the format is active.

For more details on what happens to the test set during a partial preset, see Partial Preset .

The following key functions are affected by a format switch:

  • The current call/connection is terminated
  • Measurements are deactivated

The following key functions are not affected by a format switch:

  • Most Call/data connection setup parameters
  • Most measurement parameters
  • Test set setup parameters

Error Messages

The error message log is not cleared when you switch formats with the GSM/GPRS_cdma2000/IS-95/AMPS Mobile Test Application. All error messages are shown in the error message log, they are not separated by format.

Distinguishing between Formats with Common Command Syntax

Some of the GPIB commands in the CALL and RFANalyzer subsystems are shared between formats in the GSM/GPRS_cdma2000/IS-95/AMPS Mobile Test Application. You use additional nodes known as Format Mnemonics (:SELected, :GSM, :GPRS, :DIG2000, :DIG95, :AMPS, :TA2000) to clarify the format that you want the command to apply to. If you don't add a format mnemonic to a shared command, the command is sent to the active format. You must use a format mnemonic to send a command to an inactive format.

  • For more details on the shared CALL commands, see CALL Commands with Format Mnemonics .
  • For more details on the shared RFANalyzer commands, see RFANalyzer Commands with Format Mnemonics .


E6785B GSM/GPRS_W-CDMA Lab Application (Fast Switching)

E6785B GSM/GPRS_W-CDMA Lab Application (Fast Switching)

Last updated: November 13, 2003

The Agilent Technologies E6785B GSM/GPRS_W-CDMA Lab Application (Fast Switching) allows you to switch between GSM/GPRS and W-CDMA formats very quickly. The E6785B fast switching application combines the measurements and features from the E6701C GSM/GPRS and the E6703B W-CDMA lab applications into a single fast switching application. The E6785A is the predecessor of the E6785B, see E6785x GSM/GPRS_W-CDMA Fast Switching Lab Application Revision Information .

Different Switching Methods

Format Switching allows you to fast switch between formats that are bundled in one fast switching application. The E6785B GSM/GPRS_W-CDMA lab application contains versions of GSM/GPRS and W-CDMA formats and allows you to rapidly switch between them. However, you must hold a license for the desired format to be able to switch to that format. Select SYSTEM CONFIG > Format Switch for viewing and switching formats within the E6785B.

Application Switching (which is significantly slower than Format Switching) does not require the E6785B GSM/GPRS_W-CDMA application. However, to perform Application Switching, you must have more than one application installed in your test set to switch between these applications (for example, E6701C GSM/GPRS and the E6703B W-CDMA lab application). Application switching is simply switching between individual applications. The applications that are currently installed in your test set can be viewed and switched from the SYSTEM CONFIG screen. Select Application Selection > Application Switch for viewing and switching applications.

Refer to the individual application Online User's Guide when you need operating details about a particular format (GSM/GPRS or W-CDMA).

Format Switching

This section contains details on the following:

  • Overview
  • Application Revision and Licensing
  • Power Up
  • GPIB Commands GPIB Commands
  • Format Switching Behavior
  • Error Messages
  • Distinguishing between Formats with Common Command Syntax

Overview

A format selected in a fast switching application becomes the active format. All other formats at this time are inactive.

Application Revision and Licensing

You must have application licenses installed in your test set for each application you want to switch between. Refer to the following diagrams for details on the licenses you require to switch between formats.

NOTE
The E6701C GSM/GPRS application includes all the E6704A EGPRS firmware code. You will get access to all the EGPRS LA features if you have an E6704A license. The E6704A by itself is of no use and can only be added to the E6701C. There will be no specific W-CDMA to EGPRS handoff.

Once you install the E6785B GSM/GPRS_W-CDMA lab application, there is no need to upgrade the individual applications. You only need to upgrade the E6785B fast switching application as this contains the latest revisions of the individual applications that you have licensed. Note that if you want to revert back to your earlier revision of an individual application, you have to perform a slower application switch to do this. The E6785B application is not using your previously installed earlier revision individual applications. The E6785B is a self-contained application which combines the latest revision of the two formats into one application.

If you are not able to switch formats, check the test set to see that the formats you are trying to switch between are licensed. License information for each format within the E6785B can be viewed from the SYSTEM CONFIG screen, by selecting the Format Switch menu (F2). The letter indicating the license status of each format is shown in the License column on the right side of the screen. The license status is either; Licensed "L", Not Licensed "N", or Unknown "U":

  • "L"- A Licensed revision of this application is present. This means that you can switch to this format.
  • "N" - You do not have a licensed revision of this application. This means that you will not be able to switch to this format. If you select a revision which is Not Licensed, the following error message will be displayed: +133 Configuration error; Selected Partition is not licensed (License = N).
  • "U" - This application revision has Unknown license status.

Power Up

The format the E6785B GSM/GPRS_W-CDMA lab application powers up in depends on the licenses that are present on the test set. The E6785B will boot up into the first available licensed Lab Application Partition that is present according to the following order: GSM/GPRS, W-CDMA. When the E6701C GSM/GPRS format license is present, the test set selects the GSM/GPRS format at power up as the active format.

GPIB Commands

To perform a format switch or query the name of the currently active format, use the command SYSTem:APPLication:FORMat[:NAME] .

To query the license status of any of the formats, use the command SYSTem:APPLication:FORMat:LICense? '<format name>' .

To query the names of all the formats which are available, use the command SYSTem:APPLication:CATalog:FORMat? .

To query the total number of formats which are available, use the command SYSTem:APPLication:CATalog:FORMat:COUNt? .

For further details on these commands and other SYSTem:APPLication commands, see SYSTem:APPLication .

Format Switching Behavior

Switching formats affects the test set in the same way that a partial preset does.

Full and partial presets affect all formats in the GSM/GPRS_W-CDMA Lab Application whether or not the format is active.

For more details on what happens to the test set during a partial preset, see Partial Preset .

The following key functions are affected by a format switch:

  • The current call/connection is terminated
  • Measurements are deactivated

The following key functions are not affected by a format switch:

  • Most Call/data connection setup parameters
  • Most measurement parameters
  • Test set setup parameters

Error Messages

The error message log is not cleared when you switch formats with the GSM/GPRS_W-CDMA Lab Application. All error messages are shown in the error message log, they are not separated by format.

Distinguishing between Formats with Common Command Syntax

Some of the GPIB commands in the CALL and RFANalyzer subsystems are shared between formats in the GSM/GPRS_W-CDMA Lab Application. You use additional nodes known as Format Mnemonics (:SELected, :GSM, :GPRS, :WCDMa and :FDD) to clarify the format that you want the command to apply to. If you don't add a format mnemonic to a shared command, the command is sent to the active format. You must use a format mnemonic to send a command to an inactive format.

  • For more details on the shared CALL commands, see CALL Commands with Format Mnemonics .
  • For more details on the shared RFANalyzer commands, see RFANalyzer Commands with Format Mnemonics .