What's New in the User's Guide?

  • The contents have been updated and now include documentation for the E1987A Fast Switching Test Application revision A.11. The E6785G is available as a subscription release to any one with current GSM/GPRS/EGPRS, W-CDMA/HSPA, CDMA2000/IS-95/AMPS and 1xEV-DO Lab Application Annual Contracts.

  • If you have a Fast Switching application or revision other than those referenced above, see the Release Notes to download the guide that is specific to your application.

Take Advantage of Your Fast Switching Mobile Test and Lab Applications

  • Use the Contents and Search tabs to find specific information about your test and lab applications.

  • The online version of this guide is available at:

http://wireless.agilent.com/rfcomms/refdocs/gsm136fsta/default.php

© Agilent Technologies, Inc. 2010


Legal Information

Acknowledgements

Microsoft ® is a U.S. registered trademark of Microsoft Corporation

Windows ® and MS Windows ® are U.S. registered trademarks of Microsoft Corporation.

Adobe ® Acrobat ® are trademarks of Adobe Systems Incorporated.

Notice

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as "Commercial computer software" as defined in DFAR 252.227-7014 (June 1995), or as a "commercial item" as defined in FAR 2.101(a) or as "Restricted computer software" as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

© Agilent Technologies, Inc. 2001


Fast Switching Description

Fast Switching Description

Last updated: September 2, 2009

The Agilent Technologies fast switching test applications and fast switching lab applications allow you to switch between radio formats such as GSM/GPRS/EGPRS, cdma2000, 1xEV-DO and W-CDMA very quickly.

What is Fast Switching?

Newer Fast Switching Applications

Licensing Requirements

Hardware Requirements

FAQ's

What is Fast Switching?

Fast Switching applications allow you to switch quickly between radio formats within a single licensed fast switching application.

Select SYSTEM CONFIG and then the Format Switch for viewing and switching formats. See How Do I Switch Formats? for details.

Newer Fast Switching Applications

Fast switching applications have been refined since their introduction. The following sections provide a description for each application. For details, see Release Notes .

Fast Switching Test Applications

E1987A

The E1987A application combines all of the 8960 test application radio formats into one fast switching application. In this application, fast switching is supported between all test application radio formats listed below:

  • E1961A AMPS/136 mobile test application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/is136/default.php

  • E1962B cdma2000/IS-95/AMPS mobile test application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/cdma2k/default.php

  • E1963A W-CDMA mobile test application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/wcdma/default.php

  • E1968A-Option 202 GSM/GPRS/EGPRS mobile test application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/gsmgprs/default.php

  • E1966A 1xEV-DO mobile test application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/1xevdo/default.php

E1985B

This product was discontinued as of January 2006.

The E1985B supports fast switching between all test application radio formats listed below:

  • E1961A AMPS/136 mobile test application
  • E1963A W-CDMA mobile test application
  • E1968A-Option 202 GSM/GPRS/EGPRS mobile test application

E1985C

This product was discontinued as of January 2006.

The E1985C supports fast switching between all test application radio formats listed below:

  • E1962B cdma2000/IS-95/AMPS mobile test application
  • E1968A-Option 202 GSM/GPRS/EGPRS mobile test application

E1985E

This product was discontinued as of January 2006.

The E1985E supports fast switching between all test application radio formats listed below:

  • E1962B cdma2000/IS-95/AMPS mobile test application
  • E1966A-1xEV-DO mobile test application

E1985D

The E1985D application combines, as an ordering convenience, the E1985B, E1985C, and E1985E fast switching applications into one part number.

With multiple fast switching applications installed in your test set you have the capability to fast switch between formats within the limits of each fast switching model. For example, the E1985B allows you to fast switch between GSM and W-CDMA. If you also have the E1985C you can switch between GSM and cdma2000. However, this combination of fast switching applications does not allow you to switch between W-CDMA and cdma2000. The way to gain this capability is to install the E1987A , which fast switches between all formats.

Fast Switching Lab Applications

E6785U

The E6785U supports fast switching between the lab application radio formats listed below since U.00.xx release:

  • E6701U GSM/GPRS mobile lab application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/gsmgprs/default.php

  • E6703U W-CDMA mobile lab application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/wcdma/default.php

  • E6704A EGPRS mobile lab application (licensing for EGPRS in the E6701U)
  • E6702T cdma2000/IS-95/AMPS mobile lab application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/cdma2k/default.php

  • E6706U 1xEV-DO mobile lab application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/1xevdo/default.php

Note, the E6785U supports fast switching only between the lab application radio formats E6701U and E6703U before U.00.37 release:

E6785E

The E6785E supports fast switching between the lab application radio formats listed below since E.01.xx release:

  • E6701F GSM/GPRS mobile lab application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/gsmgprs/default.php

  • E6703E W-CDMA mobile lab application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/wcdma/default.php

  • E6704A EGPRS mobile lab application (licensing for EGPRS in the E6701E)
  • E6702B cdma2000/IS-95/AMPS mobile lab application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/cdma2k/default.php

  • E6706B 1xEV-DO mobile lab application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/1xevdo/default.php

Note, the E6785E supports fast switching only between the lab application radio formats E6701F and E6703E before E.01.39 release:

E6785T

The E6785T supports fast switching between the lab application radio formats listed below:

  • E6701T GSM/GPRS mobile lab application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/gsmgprs/default.php

  • E6703T W-CDMA mobile lab application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/wcdma/default.php

  • E6704A EGPRS mobile lab application (licensing for EGPRS in the E6701E)

E6785D

The E6785D supports fast switching between the lab application radio formats listed below:

  • E6701E GSM/GPRS mobile lab application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/gsmgprs/default.php

  • E6703D W-CDMA mobile lab application. For feature details, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/wcdma/default.php

  • E6704A EGPRS mobile lab application (licensing for EGPRS in the E6701E)

E6785C

The E6785C supports fast switching between the lab application radio formats listed below:

  • E6701D GSM/GPRS mobile lab application
  • E6703C W-CDMA mobile lab application
  • E6704A EGPRS mobile lab application (licensing for EGPRS in the E6701D)

E6785B

This product was discontinued as of January 2006.

The E6785B supports fast switching between the lab application radio formats listed below:

  • E6701C GSM/GPRS mobile lab application
  • E6703B W-CDMA mobile lab application
  • E6704A EGPRS mobile lab application (licensing for EGPRS in the E6701C)

Licensing Requirements

Fast switching is limited to formats that are individually licensed within test or lab applications. Besides the license you receive with your fast switching test application or your fast switching lab application, you must also have the individual license(s) for the test or lab applications you plan to fast switch between. The individual licenses are redeemed and automatically loaded onto the test set when a purchased application is downloaded.

To determine which of your currently loaded test or lab applications are licensed, press the SYSTEM CONFIG key and press F2 to select the Application Setup menu. This list will also include the licensed fast switching applications. To see all of your licenses, go to

.

A listing of all test, lab, and fast switching applications and the formats they support can be found at:

http://www.agilent.com/find/8960upgrades

Revision Control

When running a fast switching application, the revision of each format you fast switch to will depend on the fast switching application revision. Non-fast-switching test and lab applications, although required for their licenses, will not be accessed when fast switching between formats.

For revision information about the formats included with a fast switching application, see Release Notes .

Hardware Requirements

CAUTION
You may need to upgrade the hardware in your test set before installing the application firmware described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up.
  • The application may not run.
  • Some features in the application may be inaccessible, or may not perform to specifications.

To determine if a hardware upgrade is required for your testing needs, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

If you are not able to switch formats, see Troubleshooting .

Frequently Asked Questions (FAQ's)

See FAQ's .

Downloads

To download the latest version of the fast switching application, see:


Manual Operation

Manual Operation

Last updated: July 25, 2008

Fast Switching Between Formats from the Front Panel

To perform fast switching between radio formats that are part of a fast switching test or lab applications from the front panel, see How Do I Switch Formats? .

Manual Operation of Fast Switching Formats

Manual operation for fast switching applications is identical to standard applications.

For details on a specific format's manual operation, refer to the applicable radio technology's Manual Operation section in the Online User's Guide.

For example, to locate the Manual Operation section for the 1xEV-DO test application included with the E1987A fast switching application:

  1. Select the 1xEV-DO (E1966A) technology.
  2. Select Manual Operation from the Contents menu.


Programming

Programming

Getting Started

  • Programming: Getting Started Guide


Fast Switching GPIB Commands

Fast Switching GPIB Commands

  • GPIB Commands for Switching Formats
  • GPIB Commands for the Formats in a Fast Switching Application
  • GPIB Commands with Format Mnemonics

GPIB Commands for Switching Formats

For a detailed description of GPIB commands that are used for format switching, see:

SYSTem:APPLication:FORMat[:NAME]

GPIB Commands for the Formats in a Fast Switching Application

For fast switching application GPIB commands, refer to the applicable radio technology's GPIB Commands section in the Online User's Guide. The individual technologies' Online User's Guide is available at:

  • AMPS/136 format, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/is136/default.php

  • cdma2000/IS-95/AMPS format, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/cdma2k/default.php

  • W-CDMA (including HSDPA) format, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/wcdma/default.php

  • GSM/GPRS (including EDGE) format, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/gsmgprs/default.php

  • IS-856 (1xEV-DO) format, please visit:

    http://wireless.agilent.com/rfcomms/refdocs/1xevdo/default.php

For example, to locate the GPIB commands for the 1xEV-DO test application included with the E1987A fast switching application:

  1. Select the 1xEV-DO (E1966A) technology.
  2. Select GPIB Commands from the Contents menu.

GPIB Commands with Format Mnemonics

Some GPIB commands are common to more than one technology in a fast switching application. To specify a technology when using these commands the test set accepts a format mnemonic at the end of the command (:SELected, :GSM, :GPRS, :TA136, :DIGital136, :DIGital95, :DIGital2000, :TA2000, :DIGital856, :TA856, :FDD and :WCDMa).

For a listing of the GPIB commands that are common to multiple technologies, see:

GPIB Commands with Format Mnemonics

If you do not add a format mnemonic to a common command, the command is applied to the currently active technology.


Release Notes

Last updated: April 30, 2009

E1987A Fast Switching Test Application Revision Information

E1985A Fast Switching Test Applications Revision Information (Discontinued as of December 2005)

E1985B Fast Switching Test Applications Revision Information (Discontinued as of December 2005)

E1985C Fast Switching Test Applications Revision Information (Discontinued as of December 2005)

E1985D Fast Switching Test Applications Revision Information (Discontinued as of December 2005)

(Discontinued as of December 2005)


Troubleshooting

Troubleshooting

Some features may be inaccessible or may not perform to specifications without a hardware upgrade to your test set or a proper license. For more details, please see:

http://www.agilent.com/find/8960upgrades

Contact Information

  • Contact Us

Licensing Requirements

Fast switching is limited to formats that are individually licensed within test or lab applications. Besides the license you receive with your fast switching test application or your fast switching lab application, you must also have the individual license(s) for the test or lab applications you plan to fast switch between. See Licensing Requirements

FAQ's

When I load a fast switching application, what happens to the old test applications?

The old test applications remain in the test set's list of applications. However, the fast switching application will not use your previously installed test applications. The fast switching application is a self-contained test application which combines the latest revision of radio formats into one test application.

Note that if you want to revert back to your earlier revision of an individual test application, you have to perform an application switch.

When I power up my test set, which fast switching format will come up?

The radio format that a fast switching application powers up in depends on the licenses that are present on the test set. For example, if the test set running the E1985B GSM/GPRS_AMPS/136_WCDMA fast switching application is power cycled and all of the test applications are licensed, the fast switching application will boot up to the first available licensed test application format that is present according to the following order: GSM/GPRS, AMPS/136, W-CDMA.

The Connection Type will default to AUTO, ready to make GSM voice calls, when the E1985B powers up into the GSM/GPRS format and the E1968A is licensed for GSM functionality. If the E1968A is only licensed for GPRS functionality, the Connection Type setting will default to BLER, ready to perform GPRS data connections.

If you do not have a license for the E1968A GSM/GPRS TA but do have a licensed revision of the E1961A AMPS/136 TA, the test set selects the AMPS/136 format as the active format. See Licensing Requirements for information on licenses required.

Do I need to upgrade every test or lab application on my test set after I have installed a fast switching application?

Once you install a fast switching application, there is no need to upgrade the individual test applications. You only need to upgrade the fast switching application as this contains the latest revisions of the individual test or lab applications that you have licensed.

Where is the User's Guide for my fast switching application?

Refer to the individual application Online User's Guide's when you need operating details about a particular format.

What happens to my settings when I fast switch to another format?

Switching formats affects the test set in the same way that a partial preset does.

Full and partial presets affect all formats in the GSM/GPRS_AMPS/136_W-CDMA Mobile Test Application whether or not the format is active.


E1985A Fast Switching Test Applications Revision Information

E1985A Fast Switching Test Applications Revision Information

This product was discontinued on December 1, 2005 and replaced by the E1987A. For information on migrating from the E1985 to the E1987A fast switching application, refer to the link below:

http://wireless.agilent.com/rfcomms/promo/products/misc/Transition_E1985_to_E1987A.pdf

In some cases, older E5515s will require a hardware upgrade to run the E1987A. For the release notes of the E1987A, see E1987A Fast Switching Test Application Revision Information .

This document lists revision information about the Agilent Technologies E1985A GSM_AMPS/136_GPRS_W-CDMA fast switching test application. The E1985A is a discontinued product. The E1985A is not compatible with the EGPRS hardware in E5515B and E5515C. The E1985A has been replaced by the E1985B (see E1985B Fast Switching Test Applications Revision Information ).

CAUTION
Loading an application onto your E5515 Test Set that is not compatible with your E5515's hardware revision can cause your E5515 to lock-up. For information on application/E5515 compatibility refer to:

http://www.agilent.com/find/E5515

and select the relevant link, either E5515B Release Notes or E5515C Release Notes. Always refer to this information before loading an application.

E1985A GSM/GPRS_AMPS/136 fast switching application suite revision history:

  • B.01.70 Release - February 2003
  • B.01.55 Release - September 2002
  • B.01.35 Release - August 2002
  • B.01.20 Release - May 2002
  • A.03.20 Release - March 2002
  • A.02 Release - July 2001
  • A.01.07 Release - February 2001

B.01.70 Release - February 2003

This release adds the W-CDMA and updates the E1985A with the equivalent features of the following test applications and application revisions:

  • E1960A GSM Mobile Test Application Revision A.10.70
  • E1961A AMPS/136 Mobile Test Application Revision A.07.70
  • E1963A W-CDMA Mobile Test Application Revision A.03.20
  • E1964A GPRS Mobile Test Application Revision A.04.70

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

B.01.55 Release - September 2002

This release adds the W-CDMA and updates the E1985A with the equivalent features of the following test applications and application revisions:

  • E1960A GSM Mobile Test Application Revision A.10.55
  • E1961A AMPS/136 Mobile Test Application Revision A.07.55
  • E1963A W-CDMA Mobile Test Application Revision A.02.55
  • E1964A GPRS Mobile Test Application Revision A.04.55

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

B.01.35 Release - August 2002

This release adds the W-CDMA and updates the E1985A with the equivalent features of the following test applications and application revisions:

  • E1960A GSM Mobile Test Application Revision A.10.35
  • E1961A AMPS/136 Mobile Test Application Revision A.07.35
  • E1963A W-CDMA Mobile Test Application Revision A.02.35
  • E1964A GPRS Mobile Test Application Revision A.04.35

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

B.01.20 Release - May 2002

This release adds the W-CDMA and updates the E1985A with the equivalent features of the following test applications and application revisions:

  • E1960A GSM Mobile Test Application Revision A.10.20
  • E1961A AMPS/136 Mobile Test Application Revision A.07.20
  • E1963A W-CDMA Mobile Test Application Revision A.02.20
  • E1964A GPRS Mobile Test Application Revision A.04.20

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

A.03.20 Release - March 2002

This release updates the fast switching test application with the equivalent features of the following test applications and application revisions:

  • E1960A GSM Mobile Test Application Revision A.09.20
  • E1961A AMPS/136 Mobile Test Application Revision A.06.20
  • E1964A GPRS Mobile Test Application Revision A.03.20

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

A.02 Release - July 2001

This release adds the GPRS and updates the E1985A with the equivalent features of the following test applications and application revisions:

  • E1960A GSM Mobile Test Application Revision A.08.08
  • E1961A AMPS/136 Mobile Test Application Revision A.05.05
  • E1964A GPRS Mobile Test Application Revision A.02.06

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

To allow the GPRS test application to operate in the fast switching environment with GSM and AMPS/136 a number of the existing GPRS commands had to be changed. If you previously used any of these commands you must change them to the new commands to allow your code to run as you would expect. You will not receive an error message if you do not change these commands as the commands are still valid commands for setting the inactive GSM format.

Note that these commands only need changed in your GPRS code, not your GSM code.

GPRS Command Changes

Previous Commands

New Commands

CALL[:CELL]:POWer[:SAMPlitude]:GSM

CALL[:CELL]:POWer[:SAMPlitude]:GPRS

CALL[:CELL]:POWer:AMPLitude:GSM

CALL[:CELL]:POWer:AMPLitude:GPRS

CALL[:CELL]:POWer:STATe:GSM

CALL[:CELL]:POWer:STATe:GPRS

RFANalyzer:MANual:POWer:GSM[:SELected]
:BURSt[1|2]

RFANalyzer:MANual:POWer:GPRS[:SELected]
:BURSt[1|2]

STATus:OPERation:NMRReady:GSM:CONDition

STATus:OPERation:NMRReady:GSM:ENABle

STATus:OPERation:NMRReady:GSM:NTRansition

STATus:OPERation:NMRReady:GSM:PTRansition

STATus:OPERation:NMRReady:GSM[:EVENt]

STATus:OPERation:NMRReady:GPRS:CONDition

STATus:OPERation:NMRReady:GPRS:ENABle

STATus:OPERation:NMRReady:GPRS:NTRansition

STATus:OPERation:NMRReady:GPRS:PTRansition

STATus:OPERation:NMRReady:GPRS[:EVENt]

STATus:QUEStionable:CALL:GSM:DATA:CONDition

STATus:QUEStionable:CALL:GSM:DATA:ENABle

STATus:QUEStionable:CALL:GSM:DATA:NTRansition

STATus:QUEStionable:CALL:GSM:DATA:PTRansition

STATus:QUEStionable:CALL:GSM:DATA[:EVENt]

STATus:QUEStionable:CALL:GPRS:CONDition

STATus:QUEStionable:CALL:GPRS:ENABle

STATus:QUEStionable:CALL:GPRS:NTRansition

STATus:QUEStionable:CALL:GPRS:PTRansition

STATus:QUEStionable:CALL:GPRS[:EVENt]

STATus:QUEStionable:ERRors:GSM:CONDition

STATus:QUEStionable:ERRors:GSM:ENABle

STATus:QUEStionable:ERRors:GSM:NTRansition

STATus:QUEStionable:ERRors:GSM:PTRansition

STATus:QUEStionable:ERRors:GSM[:EVENt]

STATus:QUEStionable:ERRors:GPRS:CONDition

STATus:QUEStionable:ERRors:GPRS:ENABle

STATus:QUEStionable:ERRors:GPRS:NTRansition

STATus:QUEStionable:ERRors:GPRS:PTRansition

STATus:QUEStionable:ERRors:GPRS[:EVENt]

A.01.09 Release - February 2001

This is the initial release of the GSM_AMPS/136 fast switching test application. You must have licensed revisions of E1960A GSM Mobile Test and E1961A AMPS/136 Mobile Test before fast switching will work.

This release has the equivalent features of the following test applications and application revisions:

  • E1960A GSM Mobile Test Application Revision A.07.06
  • E1961A AMPS/136 Mobile Test Application Revision A.04.09

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

A.01.07 Release - February 2001

This is the initial release of the GSM_AMPS/136 fast switching test application. You must have licensed revisions of E1960A GSM Mobile Test and E1961A AMPS/136 Mobile Test before fast switching will work.

This release has the equivalent features of the following test applications and application revisions:

  • E1960A GSM Mobile Test Application Revision A.07.06
  • E1961A AMPS/136 Mobile Test Application Revision A.04.07

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

GSM Syntax Changes

Most of your existing test code will work for this release however, some CALL and SETup commands are shared for both formats. These shared commands and queries will default to the active format selected. You can specify a format for the commands or queries by including a format mnemonic. See Format Mnemonics for more information.

Existing GSM test code needs to be changed as follows for this revision to work.

  1. GSM command/query:

OUTPUT 714;"SETUP:IQTUNING:REFERENCE:FREQUENCY POS67KHZ"
!Sets reference frequency for IQ Tuning measurement (old command).

    must change to:

OUTPUT 714;"SETUP:IQTUNING:REFERENCE:MANUAL:FREQUENCY:CHARACTER:GSM POS67KHZ"
!Sets reference frequency for IQ Tuning measurement returns character data.

    or:

OUTPUT 714;"SETUP:IQTUNING:REFERENCE:MANUAL:FREQUENCY:GSM +67000"
!Sets reference frequency for IQ Tuning measurement.

    or to auto tune the reference use:

OUTPUT 714;"SETUP:IQTUNING:REFERENCE:AUTO ON"
!Turns on the auto reference selection.

  2. This GSM query now returns float 32 values of 1, 2 and 9.91E+37 (NAN). This query previously returned enumerated values of PHASe 1, PHASe 2 and UNKNown.

OUTPUT 714;"CALL:MS:REPORTED:REVISION?" !Returns the MS reported protocol revision.

    If you want to receive the enumerated values of UNKNown, PHASe1 and PHASe2, you must use this query.

OUTPUT 714;"CALL:MS:REPORTED:REVISION:CHARACTER:GSM?" !Returns the MS reported
                                                      ! protocol version.

    or:

OUTPUT 714;"CALL:MS:REPORTED:REVISION:DIGITAL:GSM?" !Returns the MS reported
                                                    !protocol version.

AMPS/136 Syntax Changes

All of your existing test code will work for this release however, some CALL and SETup commands are shared for both formats. These shared commands and queries will default to the active format. You can specify the format for the commands or queries by including a format mnemonic. See Format Mnemonics for more information.


E1985B Fast Switching Test Applications Revision Information

E1985B Fast Switching Test Applications Revision Information

Last updated: February 27, 2009

This product was discontinued on December 1, 2005 and replaced by the E1987A. For information on migrating from the E1985 to the E1987A fast switching application, refer to the link below:

http://wireless.agilent.com/rfcomms/promo/products/misc/Transition_E1985_to_E1987A.pdf

In some cases, older E5515s will require a hardware upgrade to run the E1987A. For the release notes of the E1987A, see E1987A Fast Switching Test Application Revision Information .

This page lists revision information about the Agilent Technologies E1985B GSM/GPRS_AMPS/136_W-CDMA fast switching test application. The E1987A allows fast switching across all TA formats. E1985 applications switch across specified formats. For a description of the E1985B application (such as license information, etc.), see Fast Switching Description .

CAUTION
Loading an application onto your E5515 Test Set that is not compatible with your E5515's hardware revision can cause your E5515 to lock-up. For information on application/E5515 compatibility refer to:

http://www.agilent.com/find/E5515

and select the relevant link, either E5515B Release Notes or E5515C Release Notes. Always refer to this information before loading an application.

E1985B GSM/GPRS_AMPS/136_W-CDMA fast switching application suite revision history:

  • B.06.25 Release - April 2005
  • B.05.18 Release - January 2005
  • B.04.35 Release - July 2004
  • B.04.30 Release - April 2004
  • B.04.16 Release - December 2003
  • B.03.10 Release - July 2003
  • B.02.27 Release - March 2003
  • B.02.20 Release - January 2003

B.06.25 Release - April 2005

This release updates the E1985B GSM/GPRS_AMPS/136_W-CDMA fast switching test application with the equivalent features of the following test applications and application revisions:

  • E1961A AMPS/136 Mobile Test Application Revision A.10.08
  • E1963A W-CDMA Mobile Test Application Revision A.07.25
  • E1968A GSM/GPRS/EGPRS Mobile Test Application Revision A.05.11

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

B.05.18 Release - January 2005

This release updates the E1985B GSM/GPRS_AMPS/136_W-CDMA fast switching test application with the equivalent features of the following test applications and application revisions:

  • E1961A AMPS/136 Mobile Test Application Revision A.09.16
  • E1963A W-CDMA Mobile Test Application Revision A.06.17
  • E1968A GSM/GPRS/EGPRS Mobile Test Application Revision A.04.18

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

B.04.35 Release - July 2004

This release updates the E1985B GSM/GPRS_AMPS/136_W-CDMA fast switching test application with the equivalent features of the following test applications and application revisions:

  • E1961A AMPS/136 Mobile Test Application Revision A.08.27
  • E1963A W-CDMA Mobile Test Application Revision A.05.33
  • E1968A GSM/GPRS/EGPRS Mobile Test Application Revision A.03.54

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

B.04.30 Release - April 2004

This release updates the E1985B GSM/GPRS_AMPS/136_W-CDMA fast switching test application with the equivalent features of the following test applications and application revisions:

  • E1961A AMPS/136 Mobile Test Application Revision A.08.27
  • E1963A W-CDMA Mobile Test Application Revision A.05.28
  • E1968A GSM/GPRS/EGPRS Mobile Test Application Revision A.03.48

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

B.04.16 Release - December 2003

This release adds the EGPRS (E1968A Option 103 or Option 202 provides a license for enabling EGPRS) and updates the E1985B GSM/GPRS_AMPS/136_W-CDMA fast switching test application with the equivalent features of the following test applications and application revisions:

  • E1961A AMPS/136 Mobile Test Application Revision A.08.12
  • E1963A W-CDMA Mobile Test Application Revision A.05.14
  • E1968A GSM/GPRS/EGPRS Mobile Test Application Revision A.03.32

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

B.03.10 Release - July 2003

This release updates the E1985B GSM/GPRS_AMPS/136_W-CDMA fast switching test application with the equivalent features of the following test applications and application revisions:

  • E1961A AMPS/136 Mobile Test Application Revision A.07.70
  • E1963A W-CDMA Mobile Test Application Revision A.04.10
  • E1968A GSM/GPRS Mobile Test Application Revision A.02.10

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

B.02.27 Release - March 2003

This release updates the E1985B GSM/GPRS_AMPS/136_W-CDMA fast switching test application with the equivalent features of the following test applications and application revisions:

  • E1961A AMPS/136 Mobile Test Application Revision A.07.70
  • E1963A W-CDMA Mobile Test Application Revision A.3.23
  • E1968A GSM/GPRS/EGPRS Mobile Test Application Revision A.01.25

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

B.02.20 Release - January 2003

This is the initial release of E1985B GSM/GPRS_AMPS/136_W-CDMA fast switching test application. Compared with the E1985A B.01 revision (see B.01.20 Release - May 2002 ), the E1985B adds the E1968A GSM/GPRS Mobile Test Application to replace the E1960A GSM Mobile Test Application and the E1964A Mobile Test Application. The E1960A and E1964A mobile test applications are obsolete and replaced by the E1968A.

This release updates the E1985B with the equivalent features of the following test applications and application revisions:

  • E1961A AMPS/136 Mobile Test Application Revision A.07.70
  • E1963A W-CDMA Mobile Test Application Revision A.03.20
  • E1968A GSM/GPRS Mobile Test Application Revision A.01.20

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.


E1985C Fast Switching Test Applications Revision Information

E1985C Fast Switching Test Applications Revision Information

This product was discontinued on December 1, 2005 and replaced by the E1987A. For information on migrating from the E1985 to the E1987A fast switching application, refer to the link below:

http://wireless.agilent.com/rfcomms/promo/products/misc/Transition_E1985_to_E1987A.pdf

In some cases, older E5515s will require a hardware upgrade to run the E1987A. For the release notes of the E1987A, see E1987A Fast Switching Test Application Revision Information .

This document lists revision information about the Agilent Technologies E1985C GSM/GPRS_cdma2000/IS-95/AMPS fast switching test application. For a description of the E1985C application (such as license information, etc.), see Fast Switching Description .

CAUTION
Loading an application onto your E5515 Test Set that is not compatible with your E5515's hardware revision can cause your E5515 to lock-up. For information on application/E5515 compatibility refer to:

http://www.agilent.com/find/E5515

and select the relevant link, either E5515B Release Notes or E5515C Release Notes. Always refer to this information before loading an application.

The E1987A allows fast switching across all TA formats. E1985 applications switch across specified formats.

E1985C GSM/GPRS_cdma2000/IS-95/AMPS fast switching application suite revision history:

  • C.04.25 Release - September 2005
  • C.04.04 Release - April 2005
  • C.03.18 Release - January 2005
  • C.02.33 Release - July 2004
  • C.02.28 Release - December 2003
  • C.02.18 Release - December 2003
  • C.01.14 Release - July 2003
  • C.01.12 Release - July 2003

C.04.25 Release - September 2005

This release adds GSM Digital ORFS and defect fixes. It is a special fast switching release. There are no equivalent TA releases.

This release has the equivalent features of the following test application revisions:

  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.09.19
  • E1968A GSM/GPRS(/EGPRS Mobile) Test Application Revision A.05.11 (Plus Digital ORFS and defect fixes. Does not support PAvT E1968A-410)

Please contact your Agilent Sales Representative to obtain this revision. For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test applications listed above.

C.04.04 Release - April 2005

This release updates the E1985C fast switching application with the equivalent features of the following test applications and application revisions:

  • E1968A GSM/GPRS/EGPRS Mobile Test Application Revision A.05.11
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.09.14

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

C.03.18 Release - January 2005

This release updates the E1985C fast switching application with the equivalent features of the following test applications and application revisions:

  • E1968A GSM/GPRS/EGPRS Mobile Test Application Revision A.04.18
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.08.20

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

C.02.33 Release - July 2004

This release updates the E1985C fast switching application with the equivalent features of the following test applications and application revisions:

  • E1968A GSM/GPRS/EGPRS Mobile Test Application Revision A.03.54
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.07.28

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

C.02.28 Release - December 2003

This release updates the E1985C fast switching application with the equivalent features of the following test applications and application revisions:

  • E1968A GSM/GPRS/EGPRS Mobile Test Application Revision A.03.48
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.07.28

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

C.02.18 Release - December 2003

This release adds the EGPRS (E1968A Option 103 or Option 202 provides a license for enabling EGPRS) and updates the E1985C fast switching application with the equivalent features of the following test applications and application revisions:

  • E1968A GSM/GPRS/EGPRS Mobile Test Application Revision A.03.32
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.07.15

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

C.01.14 Release - July 2003

This is the initial release of the E1985C GSM/GPRS_cdma2000/IS-95/AMPS fast switching test application. This release has the equivalent features of the following test applications and application revisions:

  • E1968A GSM/GPRS Mobile Test Application Revision A.02.10
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.06.44

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

C.01.12 Release - July 2003

This is the initial release of the E1985C GSM/GPRS_cdma2000/IS-95/AMPS fast switching test application. This release has the equivalent features of the following test applications and application revisions:

  • E1968A GSM/GPRS Mobile Test Application Revision A.02.10
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.06.42

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.


E1985D Fast Switching Test Applications Revision Information

E1985D Fast Switching Test Applications Revision Information

This product was discontinued on December 1, 2005 and replaced by the E1987A. For information on migrating from the E1985 to the E1987A fast switching application, refer to the link below:

http://wireless.agilent.com/rfcomms/promo/products/misc/Transition_E1985_to_E1987A.pdf

In some cases, older E5515s will require a hardware upgrade to run the E1987A. For the release notes of the E1987A, see E1987A Fast Switching Test Application Revision Information .

This page lists revision information about the Agilent Technologies E1985D fast switching test applications. The E1985D includes the E1985B, E1985C and E1985E applications each of which are ordered in the E1985D. They cannot be ordered individually.

CAUTION
Loading an application onto your E5515 Test Set that is not compatible with your E5515's hardware revision can cause your E5515 to lock-up. For information on application/E5515 compatibility refer to:

http://www.agilent.com/find/E5515

and select the relevant link, either E5515B Release Notes or E5515C Release Notes. Always refer to this information before loading an application.

E1985D fast switching application suite revision history:

  • D.03 Release - January 2005
  • D.02 Release - December 2003
  • D.01 Release - July 2003

D.03 Release - January 2005

This release adds the E1985E and updates the E1985B and E1985C fast switching test applications with the following application revisions. For the specific revision information of the individual fast switching test application, select the links in the "Reference" column of the following table.

Applications and Application Revisions in E1985D D.02
Application | Fast Switching TA Description | Revision | Reference
E1985B | GSM/GPRS_AMPS/136_W-CDMA | B.05 | E1985B Fast Switching Test Applications Revision Information
E1985C | GSM/GPRS_cdma2000/IS-95/AMPS | C.03 | E1985C Fast Switching Test Applications Revision Information
E1985E | cdma2000/IS-95/AMPS_1xEV-DO | E.02 | E1985E Fast Switching Test Applications Revision Information

D.02 Release - December 2003

This release adds the E1985E and updates the E1985B and E1985C fast switching test applications with the following application revisions. For the specific revision information of the individual fast switching test application, select the links in the "Reference" column of the following table.

Applications and Application Revisions in E1985D D.02
Application | Fast Switching TA Description | Revision | Reference
E1985B | GSM/GPRS_AMPS/136_W-CDMA | B.04 | E1985B Fast Switching Test Applications Revision Information
E1985C | GSM/GPRS_cdma2000/IS-95/AMPS | C.02 | E1985C Fast Switching Test Applications Revision Information
E1985E | cdma2000/IS-95/AMPS_1xEV-DO | E.01 | E1985E Fast Switching Test Applications Revision Information

D.01 Release - July 2003

The E1985D is a suite of fast switching test applications. This release is the initial release of the E1985D. It includes the following fast switching test applications and application revisions. For the specific revision information of the individual fast switching test applications, select the links in the "Reference" column of the following table.

Applications and Application Revisions in E1985D D.01
Application | Fast Switching TA Description | Revision | Reference
E1985B | GSM/GPRS_AMPS/136_W-CDMA | B.03 | E1985B Fast Switching Test Applications Revision Information
E1985C | GSM/GPRS_cdma2000/IS-95/AMPS | C.01 |


E1985E Fast Switching Test Applications Revision Information

E1985E Fast Switching Test Applications Revision Information

This product was discontinued on December 1, 2005 and replaced by the E1987A. For information on migrating from the E1985 to the E1987A fast switching application, refer to the link below:

http://wireless.agilent.com/rfcomms/promo/products/misc/Transition_E1985_to_E1987A.pdf

In some cases, older E5515s will require a hardware upgrade to run the E1987A. For the release notes of the E1987A, see E1987A Fast Switching Test Application Revision Information .

This page lists revision information about the Agilent Technologies E1985E cdma2000/IS-95/AMPS_1xEV-DO fast switching test application. For a description of the E1985E application (such as license information, etc.), see Fast Switching Description .

CAUTION
Loading an application onto your E5515 Test Set that is not compatible with your E5515's hardware revision can cause your E5515 to lock-up. For information on application/E5515 compatibility refer to:

http://www.agilent.com/find/E5515

and select the relevant link, either E5515B Release Notes or E5515C Release Notes. Always refer to this information before loading an application.

The E1987A allows fast switching across all TA formats. E1985 applications switch across specified formats.

E1985E cdma2000/IS-95/AMPS_1xEV-DO fast switching application suite revision history:

  • E.03.13 Release - May 2005
  • E.02.19 Release - January 2005
  • E.01.35 Release - August 2004
  • E.01.29 Release - April 2004
  • E.01.15 Release - January 2004

E.03.13 Release - May 2005

This release updates the E1985E fast switching application with the equivalent features of the following test applications and application revisions:

  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.09.14
  • E1966A 1xEV-DO Terminal Test Application Revision A.04.09

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

E.02.19 Release - January 2005

This release updates the E1985E fast switching application with the equivalent features of the following test applications and application revisions:

  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.08.20
  • E1966A 1xEV-DO Terminal Test Application Revision A.03.17

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

E.01.35 Release - August 2004

This release updates the E1985E fast switching application with the equivalent features of the following test applications and application revisions:

  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.07.28
  • E1966A 1xEV-DO Terminal Test Application Revision A.02.32

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

E.01.29 Release - April 2004

This release updates the E1985E fast switching application with the equivalent features of the following test applications and application revisions:

  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.07.28
  • E1966A 1xEV-DO Terminal Test Application Revision A.02.28

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.

E.01.15 Release - January 2004

This is the initial release of the cdma2000/IS-95/AMPS_1xEV-DO fast switching test application. This release has the equivalent features of the following test applications and application revisions:

  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.07.15
  • E1966A 1xEV-DO Terminal Test Application Revision A.02.15

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test application listed above.


E1987A Fast Switching Test Application Revision Information

Last updated: May 25, 2010

This page lists revision information about the Agilent Technologies E1987A fast switching test application. The E1987A application combines all of the 8960 test applications into one fast switching application. For a description of the E1987A application (such as license information, etc.), see Fast Switching Description .

CAUTION
You may need to upgrade the hardware in your test set before installing the application firmware described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up.
  • The application may not run.
  • Some features in the application may be inaccessible, or may not perform to specifications.

To determine if a hardware upgrade is required for your testing needs, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

E1987A fast switching application suite revision history:

  • A.11.xx Release - July 2010
  • A.10.12 Release - October 2009
  • A.09.21 Release - May 2009
  • A.08.17 Release - October 2008
  • A.08.14 Release - September 2008
  • A.07.11 Release - November 2007
  • A.06.19 Release - July 2007
  • A.05.28 Release - April 2007
  • A.05.24 Release - March 2007
  • A.05.15 Release - December 2006
  • A.04.27 Release - July 2006
  • A.03.31 Release - December 2005
  • A.03.09 Release - July 2005
  • A.02.45 Release -September 2005
  • A.02.10 Release - April 2005
  • A.01.21 Release - January 2005

A.11.xx Release - July 2010

This is a maintenance release to resolve the known issues detailed in the previous release. The features offered in this release are otherwise identical to those offered in the A.09.21 Release - May 2009 .

This release has the equivalent features of the following test applications:

  • E1961A AMPS/136 Mobile Test Application Revision A.15
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.17
  • E1963A W-CDMA Mobile Test Application Revision A.16
  • E1968A GSM/GPRS(/EGPRS) Mobile Test Application Revision Mobile Test Application Revision A.12
  • E1966A 1xEV-DO Mobile Test Application Revision A.12

A.10.12 Release - October 2009

This is a maintenance release to resolve the known issues detailed in the previous release. The features offered in this release are otherwise identical to those offered in the A.09.21 Release - May 2009 .

This release has the equivalent features of the following test applications:

  • E1961A AMPS/136 Mobile Test Application Revision A.14.12
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.16.12
  • E1963A W-CDMA Mobile Test Application Revision A.15.12
  • E1968A GSM/GPRS(/EGPRS) Mobile Test Application Revision Mobile Test Application Revision A.11.12
  • E1966A 1xEV-DO Mobile Test Application Revision A.11.12

A.09.21 Release - May 2009

This is a maintenance release to resolve the known issues detailed in the previous release. The features offered in this release are otherwise identical to those offered in the A.08.17 Release - October 2008 .

This release has the equivalent features of the following test applications:

  • E1961A AMPS/136 Mobile Test Application Revision A.13.18
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.15.18
  • E1963A W-CDMA Mobile Test Application Revision A.14.18
  • E1968A GSM/GPRS(/EGPRS) Mobile Test Application Revision Mobile Test Application Revision A.10.21
  • E1966A 1xEV-DO Mobile Test Application Revision A.10.18

A.08.17 Release - October 2008

This is a maintenance release to resolve the known issues detailed in the previous release. The features offered in this release are otherwise identical to those offered in the A.08.14 Release - September 2008 .

This release has the equivalent features of the following test applications:

  • E1961A AMPS/136 Mobile Test Application Revision A.12.13
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.14.14
  • E1963A W-CDMA Mobile Test Application Revision A.13.13
  • E1968A GSM/GPRS(/EGPRS) Mobile Test Application Revision Mobile Test Application Revision A.09.15
  • E1966A 1xEV-DO Mobile Test Application Revision A.09.13

A.08.14 Release - September 2008

This release updates the E1987A fast switching test application. It includes new features and defect fixes. For more information on measurements and features, please refer to the specifications for the equivalent model of the test application listed below. This release has the equivalent features of the following test applications:

  • E1961A AMPS/136 Mobile Test Application Revision A.12
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.14
  • E1963A W-CDMA Mobile Test Application Revision A.13
  • E1968A GSM/GPRS(/EGPRS) Mobile Test Application Revision Mobile Test Application Revision A.09
  • E1966A 1xEV-DO Mobile Test Application Revision A.09

Known Issues

  • The real time vocoder's Voice Activity Detection State parameter (CALL:RTVocoder:VADetection[:STATe]) is not functioning. It remains in the OFF state.
  • The SYStem:APPLication:CATalog:LICense:APPLication:ALL? command does not function.
  • Using save/recall causes HSUPA 2ms settings to un-synchronize between host and protocol.

A.07.11 Release - November 2007

The E1987A A.07.11 is a special release which adds early E1963A-413 W-CDMA HSUPA capability. The A.07.11 release has fast switching capability between GSM/GPRS/EGPRS and W-CDMA formats. It does not include fast switching capability for cdma2000/IS-95/AMPS, 1xEV-DO or AMPS/136 formats. Use E1987A A.07.11 release only if you need HSUPA capability. For more information on measurements and features, please refer to the specifications for the equivalent model release of the test application listed below. This release has the equivalent features of the following test applications:

  • E1963A W-CDMA Mobile Test Application Revision A.12.11
  • E1968A GSM/GPRS(/EGPRS) Mobile Test Application Revision Mobile Test Application Revision A.08.08

A.06.19 Release - July 2007

This release updates the E1987A fast switching test application. It includes new features and defect fixes. For more information on measurements and features, please refer to the specifications for the equivalent model of the test application listed below. This release has the equivalent features of the following test applications:

  • E1961A AMPS/136 Mobile Test Application Revision A.11.68
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.13.08
  • E1963A W-CDMA Mobile Test Application Revision A.11.08
  • E1968A GSM/GPRS(/EGPRS) Mobile Test Application Revision Mobile Test Application Revision A.08.08
  • E1966A 1xEV-DO Mobile Test Application Revision A.08.09

A.05.28 Release - April 2007

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the A.05.24 Release - March 2007 .

A.05.24 Release - March 2007

This release updates the E1987A fast switching test application. It includes new features and defect fixes. For more information on measurements and features, please refer to the specifications for the equivalent model of the test application listed below. This release has the equivalent features of the following test applications:

  • E1961A AMPS/136 Mobile Test Application Revision A.11.46
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.12
  • E1963A W-CDMA Mobile Test Application Revision A.10
  • E1968A GSM/GPRS(/EGPRS) Mobile Test Application Revision Mobile Test Application Revision A.07
  • E1966A 1xEV-DO Mobile Test Application Revision A.07

A.05.15 Release - December 2006

Release has been delayed.

A.04.27 Release - July 2006

This release updates the E1987A fast switching test application. It includes new features and defect fixes. For more information on measurements and features, please refer to the specifications for the equivalent model of the test application listed below. This release has the equivalent features of the following test applications:

  • E1961A AMPS/136 Mobile Test Application Revision A.11.26
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.11
  • E1963A W-CDMA Mobile Test Application Revision A.09
  • E1968A GSM/GPRS(/EGPRS) Mobile Test Application Revision Mobile Test Application Revision A.06.40
  • E1966A 1xEV-DO Mobile Test Application Revision A.06

A.03.31 Release - December 2005

This release updates the E1987A fast switching test application. It includes new features and defect fixes. For more information on measurements and features, please refer to the specifications for the equivalent model of the test application listed below. This release has the equivalent features of the following test applications:

  • E1961A AMPS/136 Mobile Test Application Revision A.11.11
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.10.11
  • E1963A W-CDMA Mobile Test Application Revision A.08.31
  • E1968A GSM/GPRS(/EGPRS) Mobile Test Application Revision Mobile Test Application Revision A.06.31
  • E1966A 1xEV-DO Mobile Test Application Revision A.05.11

A.03.09 Release - July 2005

This release enables the special W-CDMA HSDPA hardware capability. This release has the equivalent features of the following test application revisions:

  • E1963A W-CDMA mobile test application (A.08.09)
  • E1968A-Option 202 GSM/GPRS/EGPRS mobile test application (A.06.09)

The following formats are not supported in this special HSDPA release. To fast switch these formats, use a previous E1987A revision. Support for these formats will be included when HSDPA capability becomes standard in E5515C-003 in Q1 2006.

  • E1961A AMPS/136 mobile test application - not supported
  • E1962B cdma2000/IS-95/AMPS mobile test application - not supported
  • E1966A-1xEV-DO mobile test application - not supported

Please contact your Agilent Sales Representative to get this revision. For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test applications listed above.

A.02.45 Release -September 2005

This release has the equivalent features of the following test application revisions:

  • E1961A AMPS/136 Mobile Test Application Revision A.10.08
  • E1962B cdma2000/IS-95/AMPS Mobile Test Application Revision B.09.19
  • E1963A W-CDMA Mobile Test Application Revision A.07.25
  • E1968A GSM/GPRS(/EGPRS) Mobile Test Application Revision A.05.11 (Plus Digital ORFS and defect fixes. Does not support PAvT, E1968A-410.)
  • E1966A 1xEV-DO Mobile Test Application Revision A.04.11

This release adds GSM Digital ORFS and defect fixes. This is a special fast switching release. There are no equivalent TA releases.

Please contact your Agilent Sales Representative to obtain this revision. For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test applications listed above.

A.02.10 Release - April 2005

Please contact your Agilent Sales Representative to get this revision. For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test applications listed below.

This release includes defect fixes and new features in some formats. Please refer to the TA release notes for added features. This release has the equivalent features of the following test applications:

  • E1961A AMPS/136 mobile test application (A.10.08)
  • E1962B cdma2000/IS-95/AMPS mobile test application (B.09.14)
  • E1963A W-CDMA mobile test application (A.07.25)
  • E1968A-Option 202 GSM/GPRS/EGPRS mobile test application (A.05.11)
  • E1966A-1xEV-DO mobile test application (A.04.09)

The E1987A application combines all of the 8960 test application radio formats into one fast switching application.

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test applications listed above.

A.01.21 Release - January 2005

This is the initial release of the E1987A fast switching test application. This release has the equivalent features of the following test applications:

  • E1961A AMPS/136 mobile test application (A.09)
  • E1962B cdma2000/IS-95/AMPS mobile test application (B.08)
  • E1963A W-CDMA mobile test application (A.06)
  • E1968A-Option 202 GSM/GPRS/EGPRS mobile test application (A.04)
  • E1966A-1xEV-DO mobile test application (A.03)

The E1987A application combines all of the 8960 test application radio formats into one fast switching application.

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the test applications listed above.


Control Program Example for GSM and AMPS/136 Multi-format Test

10 !*****************************************************************

20 ! Program Name: Comp_ex.txt Rev. A.0.0 Date: 18 December 2002

30 ! Comprehensive Example Program

40 ! 8960 GSM TA and AMPS/136 TA Fast Switching

50 !

60 ! This is a program to demonstrate the use of Momentum

70 ! with E1985A GSM/GPRS_AMPS/136_WCDMA Fast Switching TA

80 ! testing a dual-mode TDMA phone and a GSM phone.

90 !*****************************************************************

100 !

110 ! Configure the BASIC environment, dimension and initialize

120 ! variables. These actions are unrelated to programming the

130 ! Agilent Technologies 8960.

140 COM INTEGER Testset

150 DIM Swit$[255],Mod$[255]

160 Testset=714

170 Tdma_level=-75

180 Gsm_level=-85

190 Maho_level=-110

200 Sinad_level=-116

210 Fber_level=-105

220 !

230 ON TIMEOUT 7,20 GOSUB Timeout

240 CLEAR SCREEN

250 !

260 !*****************************************************************

270 ! Step 1: Set up the Test Set

280 !*****************************************************************

290 ! Fully Preset the test set to start from a known state. Not

300 ! always necessary to do a full preset in a manufacturing

310 ! environment, but desirable in a programming example.

320 !

330 ! *NOTE* Sending this command sets trigger to single for measurements

340 ! in each format.

350 !

360 OUTPUT Testset;"*RST"

370 !

380 ! Turn on the GPIB debugger. This is optional but very helpful

390 ! for debugging GPIB commands when developing new code. Remove

400 ! this line of code after completing program development.

410 !

420 OUTPUT Testset;"SYST:COMM:GPIB:DEB:STAT ON"

430 !

440 ! Set the test set to the correct test format. In this example,

450 ! the command below sets the test format to GSM. Later the test

460 ! set is switched to the AMPS/136 test format.

470 !

480 OUTPUT Testset;"SYST:APPL:FORM 'GSM'" !Gsm

490 !

500 ! Set amplitude offsets

510 !

520 ! Set RF IN/OUT port's amplitude offset to compensate for fixture

530 ! loss of MS. After setting offset, cell power settings reflect

540 ! RF power at the MS antenna input.

550 !

560 OUTPUT Testset;"SYST:CORR:FREQ 800MHZ,1000MHZ,1900MHZ"

570 OUTPUT Testset;"SYST:CORR:SGA -0.7,-0.8,-1.0"

580 !*****************************************************************

590 ! Step 2: Configure the Test Set and MS Parameters

600 !*****************************************************************

610 !

620 ! Set up the parameters for GSM Mobile Test

630 OUTPUT Testset;"CALL:POW:AMPL:GSM ";Gsm_level !Gsm

640 OUTPUT Testset;"CALL:BAND EGSM" !Gsm

650 OUTPUT Testset;"CALL:TCH 5;BCH 32;:CALL:MS:TXL 0;TADV 0" !Gsm

660 !

670 ! Set up the parameters for AMPS/136 Mobile Test

680 OUTPUT Testset;"CALL:OPER:MODE CALL"

690 OUTPUT Testset;"CALL:POW:AMPL:TA136 ";Tdma_level

700 OUTPUT Testset;"CALL:DCCH 1013"

710 OUTPUT Testset;"CALL:SET:AVC 387"

720 OUTPUT Testset;"CALL:SET:DTC:BAND CELL"

730 OUTPUT Testset;"CALL:SET:DTC:CHAN:CELL 542"

740 OUTPUT Testset;"CALL:SET:DTC:CHAN:PCS 1000"

750 OUTPUT Testset;"CALL:TCH:TYPE DTC"

760 OUTPUT Testset;"CALL:SET:MS:ANAL:TXL 2"

770 OUTPUT Testset;"CALL:SET:MS:DIG:TXL:CELL 2"

780 OUTPUT Testset;"CALL:SET:MS:DIG:TXL:PCS 2"

790 ! Set up the AVC for the Audio Harmonic Distortion measurement.

800 ! Turn off the internal FM until connection is on an AVC.

810 OUTPUT Testset;"CALL:FM:INT:STAT OFF;DEV 8KHZ;FREQ 1004HZ"

820 !

830 !*****************************************************************

840 ! Step 3: Set the Measurement Parameters

850 !*****************************************************************

860 !

870 ! *NOTE* If you choose to not perform a *RST before initiating

880 ! measurements, uncomment the following command. This sets the

890 ! trigger to single for all measurements.

900 !

910 ! OUTPUT Testset;"SET:CONT:OFF"

920 !

930 ! Set the parameters for the GSM measurements

940 OUTPUT Testset;"SET:PFER:TIM 5;COUN 1" !Gsm

950 OUTPUT Testset;"SET:PVT:TIM 5;COUN 10" !Gsm

960 OUTPUT Testset;"SET:PVT:TIME -28us,-10us,321.2us,552.8us,570.8us"

970 OUTPUT Testset;"SET:ORFS:TIM 7;COUN:STAT OFF" !Gsm

980 !

990 ! This example puts the switching and modulation offsets to be

1000 ! tested into string variables. Mod$ contains the modulation

1010 ! offsets while Swit$ contains the switching offsets.

1020 Mod$="200KHZ,-200KHZ,400KHZ,-400KHZ"

1030 Swit$="400KHZ,-400KHZ,600KHZ,-600KHZ"

1040 OUTPUT Testset;"SET:ORFS:MOD:COUN 10;FREQ "&Mod$ !Gsm

1050 OUTPUT Testset;"SET:ORFS:SWIT:COUN 20;FREQ "&Swit$ !Gsm

1060 OUTPUT Testset;"SET:FBER:COUN 10000" !Gsm

1070 !

1080 ! Set the parameters for the AMPS/136 measurements

1090 !

1100 ! Digital Measurement Parameters

1110 OUTPUT Testset;"SET:DTXP:TIM 3;COUN 10"

1120 OUTPUT Testset;"SET:MACC:TIM 3;COUN 1"

1130 OUTPUT Testset;"SET:MACC:EVM10:STAT ON"

1140 OUTPUT Testset;"SET:ACP:TIM 3;COUN 1"

1150 !

1160 ! Analog Measurement Parameters

1170 OUTPUT Testset;"SET:FST:TIM 3;COUN 1"

1180 OUTPUT Testset;"SET:ATXP:TIM 3;COUN 10"

1190 OUTPUT Testset;"SET:FM:TIM 3;COUN 1"

1200 OUTPUT Testset;"SET:FM:FREQ:STAT ON"

1210 OUTPUT Testset;"SET:FM:DIST:STAT ON;FREQ 6000"

1220 OUTPUT Testset;"SET:FM:DET PPE"

1230 OUTPUT Testset;"SET:FM:FILT:TBP 6000"

1240 OUTPUT Testset;"SET:FM:FILT TBP"

1250 !

1260 ! Audio Measurement Parameters

1270 OUTPUT Testset;"SET:AFAN:FREQ:STAT ON"

1280 OUTPUT Testset;"SET:AFAN:FILT CMES;TIM 3;COUN 5;PEAK:VOLT 1"

1290 OUTPUT Testset;"SET:AFAN:SDIS:STAT ON;FREQ 1004"

1300 !

1310 !*****************************************************************

1320 ! Step 4: Make a Connection (GSM)

1330 !*****************************************************************

1340 !

1350 Orig_call("GSM") ! Subroutine for originating a call from the MS

1360 CLEAR SCREEN

1370 PRINT "GSM 900 Results: "

1380 Time2=TIMEDATE ! Stores the current time to be used for

1390 ! calculating the total test time.

1400 !

1410 !*****************************************************************

1420 ! Step 5: INITiate and FETCh Measurements (GSM)

1430 !*****************************************************************

1440 !

1450 FOR I=1 TO 2

1460 OUTPUT Testset;"CALL:POW:GSM ";Fber_level

1470 OUTPUT Testset;"INIT:FBER;PFER;PVT;ORFS"

1480 Read_sacch

1490 Burst_timing

1500 Fetch_results

1510 OUTPUT Testset;"INIT:FBER:OFF"

1520 OUTPUT Testset;"CALL:POW:GSM ";Gsm_level

1530 !

1540 !*****************************************************************

1550 ! Step 6: Reconfigure Test Set and MS Connection Parameters

1560 ! (Change to DCS)

1570 !*****************************************************************

1580 !

1590 IF I=1 THEN

1600 OUTPUT Testset;"CALL:TCH 25;:CALL:MS:TXL 0"

1610 OUTPUT Testset;"CALL:TCH:BAND DCS"

1620 OUTPUT Testset;"CALL:STAT?"

1630 ENTER Testset;Callstat$

1640 IF Callstat$<>"CONN" THEN Dropped_call

1650 PRINT ""

1660 PRINT "Channel 25 Results: "

1670 END IF

1680 NEXT I

1690 !

1700 !*****************************************************************

1710 ! Step 7: End Connection (GSM)

1720 !*****************************************************************

1730 !

1740 OUTPUT Testset;"CALL:END"

1750 OUTPUT Testset;"CALL:CONN?"

1760 ENTER Testset;Callstate

1770 IF Callstate=1 THEN

1780 PRINT "Make sure the GSM phone has released the call."

1790 OUTPUT Testset;"SYST:PRES3"

1800 END IF

1810 PRINT ""

1820 PRINT "GSM Testing is finished. Turn off the GSM phone now."

1830 PRINT ""

1840 !

1850 !*****************************************************************

1860 ! Step 6: Reconfigure Test Set and MS Connection Parameters

1870 ! Fast-Switch Formats (GSM to AMPS/136)

1880 !*****************************************************************

1890 !

1900 ! Switch the test format to AMPS/136.

1910 !

1920 OUTPUT Testset;"SYST:APPL:FORM 'AMPS/136'"

1930 !

1940 !*****************************************************************

1950 ! Step 4: Make a Connection (AMPS/136)

1960 !*****************************************************************

1970 !

1980 Orig_call("AMPS/136")

1990 !

2000 !*****************************************************************

2010 ! Step 5: INITiate and FETCh Measurements (TDMA)

2020 !*****************************************************************

2030 !

2040 PRINT ""

2050 PRINT "TDMA Cellular Results:"

2060 FOR I=1 TO 2

2070 OUTPUT Testset;"CALL:MS:REP:MAHO ON"

2080 OUTPUT Testset;"CALL:POW:TA136 ";Maho_level

2090 OUTPUT Testset;"INIT:DTXP;MACC;ACP"

2100 Fetch_results

2110 Read_maho(Maho_level,Tdma_level)

2120 !

2130 !*****************************************************************

2140 ! Step 6: Reconfigure Test Set and MS Connection Parameters

2150 ! (Change to PCS, then Analog)

2160 !*****************************************************************

2170 !

2180 IF I=1 THEN ! Just did TDMA 800, get ready for TDMA 1900

2190 OUTPUT Testset;"CALL:SET:DTC:BAND PCS"

2200 PRINT ""

2210 PRINT "TDMA PCS Results:"

2220 ELSE ! Done doing TDMA 1900, get ready for Analog

2230 OUTPUT Testset;"CALL:TCH:TYPE AVC"

2240 PRINT ""

2250 PRINT "Analog Results:"

2260 END IF

2270 OUTPUT Testset;"CALL:HAND"

2280 OUTPUT Testset;"CALL:STAT?"

2290 ENTER Testset;Callstat$

2300 IF Callstat$<>"CONN" THEN Dropped_call

2310 NEXT I

2320 !

2330 !*****************************************************************

2340 ! Step 5(REPEATED): INITiate and FETCh Measurements (Analog)

2350 !*****************************************************************

2360 !

2370 OUTPUT Testset;"CALL:FM:INT:STATE ON"

2380 OUTPUT Testset;"CALL:POW ";Sinad_level

2390 OUTPUT Testset;"INIT:ATXP;FST;AFAN;FM"

2400 Fetch_results

2410 OUTPUT Testset;"CALL:POW ";Tdma_level

2420 !

2430 !*****************************************************************

2440 ! Step 7: End Connection

2450 !*****************************************************************

2460 !

2470 OUTPUT Testset;"CALL:END"

2480 OUTPUT Testset;"CALL:CONN?"

2490 ENTER Testset;Callstate

2500 IF Callstate=1 THEN

2510 PRINT "Make sure the AMPS/136 phone has released the call."

2520 OUTPUT Testset;"SYST:PRES3"

2530 END IF

2540 PRINT ""

2550 PRINT "AMPS/136 Testing Complete."

2560 Testtime=PROUND(TIMEDATE-Time2,-2)

2570 PRINT ""

2580 PRINT "Test time was ";Testtime;" seconds."

2590 STOP

2600 Timeout: !Comes here only when program times out

2610 PRINT "Program time out."

2620 END

2630 !

2640 !*****************************************************************

2650 ! Subroutine Section

2660 !*****************************************************************

2670 !

2680 ! Subroutine to format the printing of the measurement results.

2690 !

2700 SUB Print_results(Meas_name$,R1,OPTIONAL R2,R3,R4,R5,R6,R7,R8,R9)

2710 SELECT Meas_name$

2720 CASE "DTXP"

2730 PRINT USING "5X,""Ave Digital Power:"",5X,M2D.2D,"" dBm""";R1

2740 CASE "MACC"

2750 PRINT USING "5X,""Max EVM1:"",14X,M2D.2D,"" %""";R1

2760 PRINT USING "5X,""Max EVM10:"",13X,M2D.2D,"" %""";R6

2770 PRINT USING "5X,""Worst Freq Error:"",5X,M3D.2D,"" Hz""";R2

2780 PRINT USING "5X,""Max Mag. Error:"",8X,M2D.2D,"" %""";R5

2790 PRINT USING "5X,""Max Origin Offset:"",5X,M2D.2D,"" dB""";R3

2800 PRINT USING "5X,""Max Phase Error:"",7X,M2D.2D,"" Deg""";R4

2810 CASE "ACP"

2820 PRINT USING "5X,""ACP Adj Lo:"",12X,M2D.2D,"" dBc""";R1

2830 PRINT USING "5X,""ACP Adj Hi:"",12X,M2D.2D,"" dBc""";R2

2840 PRINT USING "5X,""ACP Alt1 Lo:"",11X,M2D.2D,"" dBc""";R3

2850 PRINT USING "5X,""ACP Alt1 Hi:"",11X,M2D.2D,"" dBc""";R4

2860 PRINT USING "5X,""ACP Alt2 Lo:"",11X,M2D.2D,"" dBc""";R5

2870 PRINT USING "5X,""ACP Alt2 Hi:"",11X,M2D.2D,"" dBc""";R6

2880 CASE "ATXP"

2890 PRINT USING "5X,""Ave Analog Power:"",6X,M2D.2D,"" dBm""";R1

2900 CASE "FST"

2910 PRINT USING "5X,""Worst Freq Error:"",5X,M3D.2D,"" ppm""";R1

2920 PRINT USING "5X,""Average Freq:"",6X,M3D.2DESZ,"" Hz""";R2

2930 CASE "FM"

2940 PRINT USING "5X,""SAT Frequency:"",10X,M4D,"" Hz""";R3

2950 PRINT USING "5X,""SAT Deviation:"",9X,M5D,"" Hz""";R1

2960 PRINT USING "5X,""Distortion:"",11X,M3D.2D,"" %""";R2

2970 CASE "AFAN"

2980 PRINT USING "5X,""Audio Level:"",10X,M3D.2D,"" V""";R1

2990 PRINT USING "5X,""Audio Distortion:"",5X,M3D.2D,"" %""";R2

3000 PRINT USING "5X,""SINAD:"",16X,M3D.2D,"" dB""";R3

3010 PRINT USING "5X,""Audio Frequency:"",8X,M4D,"" Hz""";R4

3020 CASE "PFER"

3030 PRINT "Max RMS Phase Error: ";R1;" Deg"

3040 PRINT "Max Peak Phase Error: ";R2;" Deg"

3050 PRINT "Worst Freq Error: ";R3;" Hz"

3060 CASE "ORFS"

3070 PRINT "ORFS 30KHZ Ref. Pow: ";R9;" dBm"

3080 PRINT "ORFS (Switch) 400KHZ: ";R1;" dBm"

3090 PRINT "ORFS (Switch)-400KHZ: ";R2;" dBm"

3100 PRINT "ORFS (Switch) 600KHZ: ";R2;" dBm"

3110 PRINT "ORFS (Switch)-600KHZ: ";R4;" dBm"

3120 PRINT "ORFS (Mod) 200KHZ: ";R5;" dBc"

3130 PRINT "ORFS (Mod)-200KHZ: ";R6;" dBc"

3140 PRINT "ORFS (Mod) 400KHZ: ";R7;" dBc"

3150 PRINT "ORFS (Mod)-400KHZ: ";R8;" dBc"

3160 CASE "PVT"

3170 IF R1=1 THEN Pvt$="PASS"

3180 IF R1=0 THEN Pvt$="FAIL"

3190 PRINT "Average Power: ";R2;" dBm"

3200 PRINT "Power vs Time Mask: ";Pvt$

3210 PRINT "Power @-28us Offset: ";R3;" dBm"

3220 PRINT "Power @-10us Offset: ";R4;" dBm"

3230 PRINT "Power @321.2us Offset: ";R5;" dBm"

3240 PRINT "Power @552.8us Offset: ";R6;" dBm"

3250 PRINT "Power @570.8us Offset: ";R7;" dBm"

3260 CASE "FBER"

3270 PRINT USING "5X,""Fast BER:"",14X,M2D.2D,"" %""";R1

3280 END SELECT

3290 SUBEND

3300 !

3310 ! Subroutine to print information about measurements with

3320 ! integrity indicators other than zero.

3330 !

3340 SUB Bad_integrity(Integrity,Meas_name$)

3350 IF Integrity<>0 THEN

3360 PRINT "Warning: ";Meas_name$;" Integrity =";Integrity

3370 END IF

3380 SUBEND

3390 !

3400 ! Subroutine to terminate the program and print a warning if the

3410 ! call is dropped.

3420 !

3430 SUB Dropped_call

3440 PRINT " "

3450 PRINT "Call was dropped. Program aborted."

3460 STOP

3470 SUBEND

3480 !

3490 ! Subroutine to parse and print Mobile Assisted Handoff results

3500 !

3510 SUB Print_maho(Ber$,Rssi,Maho_level)

3520 SELECT Ber$

3530 CASE "BERI0"

3540 PRINT " MAHO BER at ";Maho_level;" dBm is: <0.01 %"

3550 CASE "BERI1"

3560 PRINT " MAHO BER at ";Maho_level;" dBm is: 0.01 < 0.1 %"

3570 CASE "BERI2"

3580 PRINT " MAHO BER at ";Maho_level;" dBm is: 0.1 < 0.5 %"

3590 CASE "BERI3"

3600 PRINT " MAHO BER at ";Maho_level;" dBm is: 0.5 < 1.0 %"

3610 CASE "BERI4"

3620 PRINT " MAHO BER at ";Maho_level;" dBm is: 1.0 < 2.0 %"

3630 CASE "BERI5"

3640 PRINT " MAHO BER at ";Maho_level;" dBm is: 2.0 < 4.0 %"

3650 CASE "BERI6"

3660 PRINT " MAHO BER at ";Maho_level;" dBm is: 4.0 < 8.0 %"

3670 CASE "BERI7"

3680 PRINT " MAHO BER at ";Maho_level;" dBm is: > 8.0 %"

3690 CASE ELSE

3700 PRINT " MAHO Results not available."

3710 SUBEXIT

3720 END SELECT

3730 PRINT " MAHO RSSI at ";Maho_level;" dBm is: ";Rssi;" dBm"

3740 SUBEND

3750 !

3760 ! Subroutine to terminate the program and print a warning if an

3770 ! origination fails.

3780 !

3790 SUB Orig_failed

3800 PRINT "Origination failed. Check conditions and run again."

3810 STOP

3820 SUBEND

3830 !

3840 ! Subroutine to prompt the user to originate a call from the

3850 ! mobile station and to also maintain call synchronization.

3860 !

3870 SUB Orig_call(Format$)

3880 COM INTEGER Testset

3890 PRINT "Turn the ";Format$;" phone on now."

3900 PRINT "When the phone camps, press 'F2' to continue."

3910 PAUSE

3920 CLEAR SCREEN

3930 PRINT "Originate a call on the ";Format$;" Mobile now."

3940 OUTPUT Testset;"CALL:CONN:TIM 10"

3950 OUTPUT Testset;"CALL:CONN:ARM"!Arm the Call-State-Change

3960 ! Detector

3970 OUTPUT Testset;"CALL:CONN?"!Query State

3980 ENTER Testset;Callstate

3990 IF NOT Callstate THEN

4000 Orig_failed

4010 END IF

4020 SUBEND

4030 !

4040 ! Subroutine to fetch measurement results from the test set and

4050 ! check measurement integrity values.

4060 !

4070 SUB Fetch_results

4080 COM INTEGER Testset

4090 REPEAT

4100 OUTPUT Testset;"INIT:DONE?"

4110 ENTER Testset;Measdone$

4120 SELECT Measdone$

4130 CASE "DTXP"

4140 OUTPUT Testset;"FETC:DTXP?"

4150 ENTER Testset;Integrity,Power

4160 IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)

4170 Print_results(Measdone$,Power)

4180 CASE "MACC"

4190 OUTPUT Testset;"FETC:MACC?"

4200 ENTER Testset;Integrity,Evm,Ferr,Ooff,Perr,Mag,Evm10

4210 IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)

4220 Print_results(Measdone$,Evm,Ferr,Ooff,Perr,Mag,Evm10)

4230 CASE "ACP"

4240 OUTPUT Testset;"FETC:ACP?"

4250 ENTER Testset;Integrity,Adjl,Adjh,Alt1l,Alt1h,Alt2l,Alt2h

4260 IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)

4270 Print_results(Measdone$,Adjl,Adjh,Alt1l,Alt1h,Alt2l,Alt2h)

4280 CASE "ATXP"

4290 OUTPUT Testset;"FETC:ATXP?"

4300 ENTER Testset;Integrity,Power

4310 IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)

4320 Print_results(Measdone$,Power)

4330 CASE "FST"

4340 OUTPUT Testset;"FETC:FST?"

4350 ENTER Testset;Integrity,Ferr,Freq

4360 IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)

4370 Print_results(Measdone$,Ferr,Freq)

4380 CASE "AFAN"

4390 OUTPUT Testset;"FETC:AFAN?"

4400 ENTER Testset;Integrity,Level,Sinad,Dist

4410 IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)

4420 OUTPUT Testset;"FETC:AFAN:FREQ?"

4430 ENTER Testset;Freq

4440 Print_results(Measdone$,Level,Dist,Sinad,Freq)

4450 CASE "FM"

4460 OUTPUT Testset;"FETC:FM?"

4470 ENTER Testset;Integrity,Dev,Dist,Freq

4480 IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)

4490 Print_results(Measdone$,Dev,Dist,Freq)

4500 CASE "PVT"

4510 OUTPUT Testset;"FETC:PVT?"

4520 ENTER Testset;Integrity,Mask,Power,Pvt1,Pvt2,Pvt3,Pvt4,Pvt5

4530 IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)

4540 Print_results(Measdone$,Mask,Power,Pvt1,Pvt2,Pvt3,Pvt4,Pvt5)

4550 CASE "PFER"

4560 OUTPUT Testset;"FETC:PFER?"

4570 ENTER Testset;Integrity,Rmsperr,Peakperr,Ferr

4580 IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)

4590 Print_results(Measdone$,Rmsperr,Peakperr,Ferr)

4600 CASE "ORFS"

4610 OUTPUT Testset;"FETC:ORFS:INT?"

4620 ENTER Testset;Integrity

4630 IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)

4640 OUTPUT Testset;"FETC:ORFS:SWIT?"

4650 ENTER Testset;S1,S2,S3,S4

4660 OUTPUT Testset;"FETC:ORFS:MOD?"

4670 ENTER Testset;Pow_30khz,M1,M2,M3,M4

4680 Print_results(Measdone$,S1,S2,S3,S4,M1,M2,M3,M4,Pow_30khz)

4690 CASE "FBER"

4700 OUTPUT Testset;"FETC:FBER:INT?;RAT?"

4710 ENTER Testset;Integrity,Fber

4720 IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)

4730 Print_results(Measdone$,Fber)

4740 END SELECT

4750 UNTIL Measdone$="NONE"

4760 SUBEND

4770 !

4780 ! Subroutine to retrieve MAHO results reported by the mobile

4790 ! station.

4800 !

4810 SUB Read_maho(Maho_level,Tdma_level)

4820 COM INTEGER Testset

4830 OUTPUT Testset;"CALL:MS:REP:MAHO:BERR:NEW?"

4840 ENTER Testset;Ber$

4850 OUTPUT Testset;"CALL:MS:REP:MAHO:BERR:NEW?"

4860 ENTER Testset;Ber$

4870 OUTPUT Testset;"CALL:MS:REP:MAHO:RSSI?"

4880 ENTER Testset;Rssi

4890 Print_maho(Ber$,Rssi,Maho_level)

4900 OUTPUT Testset;"CALL:POW:TA136 ";Tdma_level

4910 OUTPUT Testset;"CALL:MS:REP:MAHO OFF"

4920 SUBEND

4930 !

4940 ! Subroutine to retrieve RX quality and level results

4950 ! reported by the mobile station.

4960 !

4970 SUB Read_sacch

4980 COM INTEGER Testset

4990 Sacch: !

5000 OUTPUT Testset;"CALL:MS:REP:RXQ:NEW?;NEW?;NEW?"

5010 ENTER Testset;Ignore,Ignore,Rx_qual

5020 IF Rx_qual=9.91E+37 THEN GOTO Sacch

5030 OUTPUT Testset;"CALL:MS:REP:RXL?"

5040 ENTER Testset;Rx_lev

5050 PRINT " MS Reported RX Qual :";Rx_qual

5060 PRINT " MS Reported RX Level :";Rx_lev

5070 SUBEND

5080 !

5090 ! Subroutine to retrieve burst timing error information.

5100 !

5110 SUB Burst_timing

5120 COM INTEGER Testset

5130 OUTPUT Testset;"CALL:STAT:TCH:TERR?"

5140 ENTER Testset;Time_error

5150 PRINT " Burst Timing Error:";Time_error

5160 SUBEND


E6785A/B/C/D/E/F/T/U Fast Switching Lab Application Revision Information

E6785A/B/C/D/E/F/G/T/U Fast Switching Lab Application Revision Information

Last updated: January 14, 2010

This document describes features and functionality that are part of the Agilent Technologies GSM/GPRS_W-CDMA fast switching lab applications. This document contains the original features, as well as enhancements that have been added over time. For a description of the fast switching application (such as license information, etc.), see Fast Switching Description .

CAUTION
You may need to upgrade the hardware in your test set before installing the application firmware described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up.
  • The application may not run.
  • Some features in the application may be inaccessible, or may not perform to specifications.

To determine if a hardware upgrade is required for your testing needs, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Select the appropriate link below to view the required release:

  • G.00 Subscription Release - January 2009
  • F.01.12 Subscription Release - September 2009
  • F.00.21 Subscription Release - May 2009
  • F.00.07 Subscription Release - December 2008
  • U.01.04 Special Release (E6785U) - October 2008
  • E.01.17 Release (E6785E) - October 2008
  • E.01.14 Release - September 2008
  • U.00.39 Special Release - May 2008
  • E.00.41 Subscription Release - May 2008
  • U.00.37 Special Release - May 2008
  • E.00.39 Subscription Release - May 2008
  • U.00.23 Special Release - November 2007
  • E.00.25 Subscription Release - November 2007
  • T.03.08 Special Release - July 2007
  • D.02.08 Release - July 2007
  • E.00.16 Subscription Release - May 2007
  • U.00.13 Special Release - April 2007
  • E.00.13 Subscription Release - April 2007
  • T.01.19 Special Release - March 2007
  • D.01.20 Release - March 2007
  • T.01.12 Special Release - December 2006
  • D.01.13 Release - December 2006
  • T.00.03 Special Release - August 2006
  • D.00.03 Pre-Release (E6785D)- August 2006
  • C.04.06 Release - July 2006
  • C.03.12 Release - December 2005
  • C.02.25 Release - May 2005
  • C.01.18 Release - January 2005
  • B.02.14 Release - January 2005
  • B.01.33 Release - July 2004
  • B.01.28 Release - April 2004
  • B.01.16 Release - January 2004
  • A.02.10 Release - July 2003
  • A.01.25 Release - March 2003
  • A.01.20 Release - February 2003

G.00 Subscription Release - January 2009

This is a subscription release of the E6785G application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have current GSM/GPRS/EGPRS, W-CDMA/HSPA, CDMA2000/IS-95/AMPS and 1xEV-DO Lab Application Annual Contracts to obtain this subscription release. Contact your Agilent Sales Representative for more information.

This release has the equivalent features of the following lab applications:

  • E6701H GSM/GPRS Lab Application Revision H.00 (E6704A provides a license for enabling EGPRS in the E6701G)
  • E6702D CDMA2000 Lab Application Revision D.00
  • E6703G W-CDMA Lab Application Revision G.00
  • E6706D 1xEV-DO Lab Application Revision D.00

This release of the fast switching lab application requires release A.07.50 or newer of the Wireless Protocol Advisor. This is available at:

http://www.agilent.com/find/wlcontract

Hardware Requirement

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

F.01.12 Subscription Release - September 2009

This is a subscription release of the E6785F application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have current GSM/GPRS/EGPRS, W-CDMA/HSPA, CDMA2000/IS-95/AMPS and 1xEV-DO Lab Application Annual Contracts to obtain this subscription release. Contact your Agilent Sales Representative for more information.

This release has the equivalent features of the following lab applications:

  • E6701G GSM/GPRS Lab Application Revision G.01.12 (E6704A provides a license for enabling EGPRS in the E6701G)
  • E6702C CDMA2000 Lab Application Revision C.01.12
  • E6703F W-CDMA Lab Application Revision F.01.12
  • E6706C 1xEV-DO Lab Application Revision C.01.12

This release of the fast switching lab application requires release A.07.50 or newer of the Wireless Protocol Advisor. This is available at:

http://www.agilent.com/find/wlcontract

Hardware Requirement

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

F.00.21 Subscription Release - May 2009

This is a subscription release of the E6785F application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have current GSM/GPRS/EGPRS, W-CDMA/HSPA, CDMA2000/IS-95/AMPS and 1xEV-DO Lab Application Annual Contracts to obtain this subscription release. Contact your Agilent Sales Representative for more information.

This release has the equivalent features of the following lab applications:

  • E6701G GSM/GPRS Lab Application Revision G.00.18 (E6704A provides a license for enabling EGPRS in the E6701G)
  • E6702C CDMA2000 Lab Application Revision C.00.18
  • E6703F W-CDMA Lab Application Revision F.00.19
  • E6706C 1xEV-DO Lab Application Revision C.00.17

This release of the fast switching lab application requires release A.07.50 or newer of the Wireless Protocol Advisor. This is available at:

http://www.agilent.com/find/wlcontract

Hardware Requirement

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

F.00.07 Subscription Release - December 2008

This is a subscription release of the E6785F application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have current GSM/GPRS/EGPRS, W-CDMA/HSPA, CDMA2000/IS-95/AMPS and 1xEV-DO Lab Application Annual Contracts to obtain this subscription release. Contact your Agilent Sales Representative for more information.

This release has the equivalent features of the following lab applications:

  • E6701G GSM/GPRS Lab Application Revision G.00.07 (E6704A provides a license for enabling EGPRS in the E6701G)
  • E6702C CDMA2000 Lab Application Revision C.00.07
  • E6703F W-CDMA Lab Application Revision F.00.07
  • E6706C 1xEV-DO Lab Application Revision C.00.07

This release of the fast switching lab application requires release A.07.50 or newer of the Wireless Protocol Advisor. This is available at:

http://www.agilent.com/find/wlcontract

Hardware Requirement

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

U.01.04 Special Release (E6785U) - October 2008

This is a subscription release of the E6785U application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have current GSM/GPRS/EGPRS, W-CDMA/HSPA, cdma2000/IS-95/AMPS and 1xEV-DO Lab Application Annual Contracts to obtain this subscription release. Contact your Agilent Sales Representative for more information.

The E6785U can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6785U onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6785U meets the E6785D measurement parametric specifications in a temperature range of 25 +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

This release has the equivalent features of the following lab applications:

  • E6701U GSM/GPRS Lab Application Revision U.01.04 (E6704A provides a license for enabling EGPRS in the E6701T)
  • E6702T CDMA2000 Lab Application Revision T.04.04
  • E6703U W-CDMA Lab Application Revision U.01.04
  • E6706U 1xEV-DO Lab Application Revision U.01.04

_____________________________________________________________________________________________________

E.01.17 Release (E6785E) - October 2008

This is a maintenance release to resolve the known issues detailed in the previous release. The features offered in this release are otherwise identical to those offered in the E.01.14 Release - September 2008 , with the following exception:

  • The value for RLC SDU window size has been increased when on a 5.7Mbps HSUPA IP data to increase IP data throughput for some devices (from 1024 to UE reported max AM RLC Window size).

This release is available for download at the Lab Application Annual Contract site: www.agilent.com/find/wlcontract.

This release has the equivalent features of the following lab applications:

  • E6701F GSM/GPRS Lab Application Revision F.01.15
  • E6702B CDMA2000 Lab Application Revision B.07.14
  • E6703U W-CDMA Lab Application Revision E.01.16
  • E6706B 1xEV-DO Lab Application Revision B.01.13

_____________________________________________________________________________________________________

E.01.14 Release - September 2008

This release updates the E6785E fast switching lab application. It includes new features and defect fixes. For more information on measurements and features, please refer to the specifications for the equivalent model of the lab application listed below.

This release has the equivalent features of the following lab applications:

  • E6701F GSM/GPRS Lab Application Revision F.01 (E6704A provides a license for enabling EGPRS in the E6701E)
  • E6702B CDMA2000 Lab Application Revision B.07
  • E6703E W-CDMA Lab Application Revision E.01
  • E6706B 1xEV-DO Lab Application Revision B.01

Known Issues

  • A protocol processor timeout occurs during repeated packet switched data handover procedures between two test sets in E6701F.
  • The real time vocoder's Voice Activity Detection State parameter (CALL:RTVocoder:VADetection[:STATe) is not functioning in E6701F. It remains in the OFF state.
  • Results are erroneously high for USF BLER (Unassigned) when three or more uplinks are in use in E6701F (that is, when using extended dynamic allocation).
  • Cannot camp to band IX in E6703E.
  • An assert occurs when attempting a PCR handoff between bands (for example, 1 to 2, 2 to 5, 5 to 1) with a PDP context established using "Reported CQI" during an FTP in E6703E.
  • Using save/recall causes HSUPA 2ms settings to un-synchronize between host and protocol in E6703E.
  • Web pages are sometimes not properly displayed on the mobile when Web browsing with E6701F and E6703E.
  • The SYSTem:APPLication:CATalog:LICense:APPLication:ALL? command does not function in E6701F and E6703E.

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

Hardware Requirement

http://www.agilent.com/find/8960upgrades

U.00.39 Special Release - May 2008

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the U.00.37 Special Release - May 2008 Release.

This release has the equivalent features of the following lab applications:

  • E6701U GSM/GPRS Lab Application Revision U.00.34 (E6704A provides a license for enabling EGPRS in the E6701U)
  • E6702T CDMA2000 Lab Application Revision T.03.08
  • E6703U W-CDMA Lab Application Revision U.00.33
  • E6706U 1xEV-DO Lab Application Revision U.00.46

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

E.00.41 Subscription Release - May 2008

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the E.00.39 Subscription Release - May 2008 Release.

This release has the equivalent features of the following lab applications:

  • E6701F GSM/GPRS Lab Application Revision F.00.39 (E6704A provides a license for enabling EGPRS in the E6701T)
  • E6702B CDMA2000 Lab Application Revision B.06.08
  • E6703E W-CDMA Lab Application Revision E.00.36
  • E6706B 1xEV-DO Lab Application Revision B.00.46

Hardware Requirements

http://www.agilent.com/find/8960upgrades

_____________________________________________________________________________________________________

U.00.37 Special Release - May 2008

This is a subscription release of the E6785U application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have current GSM/GPRS/EGPRS, W-CDMA/HSPA, cdma2000/IS-95/AMPS and 1xEV-DO Lab Application Annual Contracts to obtain this subscription release. Contact your Agilent Sales Representative for more information.

The E6785U can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6785U onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6785U meets the E6785D measurement parametric specifications in a temperature range of 25 +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

This release has the equivalent features of the following lab applications:

  • E6701U GSM/GPRS Lab Application Revision U.00.32 (E6704A provides a license for enabling EGPRS in the E6701U)
  • E6702T CDMA2000 Lab Application Revision T.03.08
  • E6703U W-CDMA Lab Application Revision U.00.31
  • E6706U 1xEV-DO Lab Application Revision U.00.44

This release of the fast switching lab application requires release A.07.50 or newer of the Wireless Protocol Advisor. This is available at:

http://www.agilent.com/find/wlcontract

Hardware Requirements

http://www.agilent.com/find/8960upgrades

E.00.39 Subscription Release - May 2008

This is a subscription release of the E6785E application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have current GSM/GPRS/EGPRS, W-CDMA/HSPA, cdma2000/IS-95/AMPS and 1xEV-DO Lab Application Annual Contracts to obtain this subscription release. Contact your Agilent Sales Representative for more information.

This release has the equivalent features of the following lab applications:

  • E6701F GSM/GPRS Lab Application Revision F.00.37 (E6704A provides a license for enabling EGPRS in the E6701F)
  • E6702B CDMA2000 Lab Application Revision B.06.08
  • E6703E W-CDMA Lab Application Revision E.00.34
  • E6706B 1xEV-DO Lab Application Revision B.00.44

This release of the fast switching lab application requires release A.07.50 or newer of the Wireless Protocol Advisor. This is available at:

http://www.agilent.com/find/wlcontract

Hardware Requirement

http://www.agilent.com/find/8960upgrades

U.00.23 Special Release - November 2007

This is a subscription release of the E6785U application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have current GSM/GPRS/EGPRS and W-CDMA/HSPA Lab Application Annual Contracts to obtain this subscription release. Contact your Agilent Sales Representative for more information.

The E6785U can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6785U onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6785U meets the E6785D measurement parametric specifications in a temperature range of 25 +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

This release has the equivalent features of the following lab applications:

  • E6701U GSM/GPRS Lab Application Revision U.00.22 (E6704A provides a license for enabling EGPRS in the E6701U)
  • E6703U W-CDMA Lab Application Revision U.00.20

Hardware Requirements

http://www.agilent.com/find/8960upgrades

E.00.25 Subscription Release - November 2007

This is a subscription release of the E6785E application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have current GSM/GPRS/EGPRS and W-CDMA/HSPA Lab Application Annual Contracts to obtain this subscription release. Contact your Agilent Sales Representative for more information.

This release has the equivalent features of the following lab applications:

  • E6701F GSM/GPRS Lab Application Revision F.00.27 (E6704A provides a license for enabling EGPRS in the E6701E)
  • E6703E W-CDMA Lab Application Revision E.00.23

Hardware Requirements

http://www.agilent.com/find/8960upgrades

T.03.08 Special Release - July 2007

The E6785T can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6785T onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6785T meets the E6785D measurement parametric specifications in a temperature range of 25 +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

This release has the equivalent features of the following lab applications:

  • E6701T GSM/GPRS Lab Application Revision T.03 (E6704A provides a license for enabling EGPRS in the E6701T)
  • E6703T W-CDMA Lab Application Revision T.03

Hardware Requirements

http://www.agilent.com/find/8960upgrades

D.02.08 Release - July 2007

This release updates the E6785D GSM/GPRS_W-CDMA fast switching lab application. It includes new features and defect fixes. For more information on measurements and features, please refer to the specifications for the equivalent model of the lab application listed below. This release has the equivalent features of the following lab applications:

  • E6701E GSM/GPRS Lab Application Revision E.02 (E6704A provides a license for enabling EGPRS in the E6701E)
  • E6703D W-CDMA Lab Application Revision D.02

Hardware Requirements

http://www.agilent.com/find/8960upgrades

E.00.16 Subscription Release - May 2007

This is a subscription release of the E6785E application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have current GSM/GPRS/EGPRS and W-CDMA/HSDPA Lab Application Annual Contracts to obtain this subscription release. Contact your Agilent Sales Representative for more information.

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the E.00.13 Subscription Release - April 2007 Release.

_____________________________________________________________________________________________________

U.00.13 Special Release - April 2007

This is a subscription release of the E6785U application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have current GSM/GPRS/EGPRS and W-CDMA/HSDPA Lab Application Annual Contracts to obtain this subscription release. Contact your Agilent Sales Representative for more information.

The E6785U can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6785U onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6785U meets the E6785D measurement parametric specifications in a temperature range of 25 +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

This release has the equivalent features of the following lab applications:

  • E6701U GSM/GPRS Lab Application Revision U.00.13 (E6704A provides a license for enabling EGPRS in the E6701T)
  • E6703U W-CDMA Lab Application Revision U.00.12

Hardware Requirements

http://www.agilent.com/find/8960upgrades

E.00.13 Subscription Release - April 2007

This is a subscription release of the E6785E application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have current GSM/GPRS/EGPRS and W-CDMA/HSDPA Lab Application Annual Contracts to obtain this subscription release. Contact your Agilent Sales Representative for more information.

This release has the equivalent features of the following labapplications:

  • E6701F GSM/GPRS Lab Application Revision F.00.13 (E6704A provides a license for enabling EGPRS in the E6701E)
  • E6703E W-CDMA Lab Application Revision E.00.12

Hardware Requirements

http://www.agilent.com/find/8960upgrades

T.01.19 Special Release - March 2007

The E6785T can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6785T onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6785T meets the E6785D measurement parametric specifications in a temperature range of 25 +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the T.01.12 Special Release - December 2006 .

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Resolved Known Issues

  • GSM/GPRS Tx Power Measurement problem

D.01.20 Release - March 2007

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the D.01.13 Release - December 2006 .

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Resolved Known Issues

  • GSM/GPRS Tx Power Measurement problem

T.01.12 Special Release - December 2006

The E6785T can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6785T onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6785T meets the E6785D measurement parametric specifications in a temperature range of 25 +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

This release has the equivalent features of the following lab applications:

  • E6701T GSM/GPRS Lab Application Revision T.01 (E6704A provides a license for enabling EGPRS in the E6701T)
  • E6703T W-CDMA Lab Application Revision T.01

Hardware Requirements

http://www.agilent.com/find/8960upgrades

D.01.13 Release - December 2006

This release updates the E6785D GSM/GPRS_W-CDMA fast switching lab application. It includes new features and defect fixes. For more information on measurements and features, please refer to the specifications for the equivalent model of the lab application listed below. This release has the equivalent features of the following lab applications:

  • E6701E GSM/GPRS Lab Application Revision E.01 (E6704A provides a license for enabling EGPRS in the E6701E)
  • E6703D W-CDMA Lab Application Revision D.01

Hardware Requirements

http://www.agilent.com/find/8960upgrades

T.00.03 Special Release - August 2006

The E6785T can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6785T onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6785T meets the E6785D measurement parametric specifications in a temperature range of 25 +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

This release has the equivalent features of the following lab applications:

  • E6701T GSM/GPRS Lab Application Revision T.00.08 (E6704A provides a license for enabling EGPRS in the E6701T)
  • E6703T W-CDMA Lab Application Revision T.00.08

D.00.03 Pre-Release (E6785D)- August 2006

This is a pre-release of the E6785D application. In order to provide early access to new features, this pre-release has not been fully qualified.

You must have current E6720A Option 001 and 003 Lab Application Annual Upgrade Contracts to obtain this pre-release. Contact your Agilent Sales Representative for more information.This release has the equivalent features of the following lab applications:

  • E6701E GSM/GPRS Lab Application Revision E.00.12 (E6704A provides a license for enabling EGPRS in the E6701E)
  • E6703D W-CDMA Lab Application Revision D.00.08

C.04.06 Release - July 2006

This release updates the E6785C GSM/GPRS_W-CDMA fast switching lab application. It includes new features and defect fixes. For more information on measurements and features, please refer to the specifications for the equivalent model of the lab application listed below. This release has the equivalent features of the following lab applications:

  • E6701D GSM/GPRS Lab Application Revision D.03.40 (E6704A provides a license for enabling EGPRS in the E6701D)
  • E6703C W-CDMA Lab Application Revision C.04

C.03.12 Release - December 2005

This release updates the E6785C GSM/GPRS_W-CDMA fast switching lab application. It includes new features and defect fixes. For more information on measurements and features, please refer to the specifications for the equivalent model of the lab application listed below. This release has the equivalent features of the following lab applications:

  • E6701D GSM/GPRS Lab Application Revision D.03.32 (E6704A provides a license for enabling EGPRS in the E6701D)
  • E6703C W-CDMA Lab Application Revision C.03.11

C.02.25 Release - May 2005

This release introduces the E6785C GSM/GPRS_W-CDMA fast switching lab application with the equivalent features of the following lab applications and application revisions:

  • E6701D GSM/GPRS Lab Application Revision D.02.10 (E6704A provides a license for enabling EGPRS in the E6701D)
  • E6703C W-CDMA Lab Application Revision C.02.25

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the lab application listed above.

C.01.18 Release - January 2005

This release introduces the E6785C GSM/GPRS_W-CDMA fast switching lab application with the equivalent features of the following lab applications and application revisions:

  • E6701D GSM/GPRS Lab Application Revision D.01.18 (E6704A provides a license for enabling EGPRS in the E6701D)
  • E6703C W-CDMA Lab Application Revision C.01.17

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the lab application listed above.

B.02.14 Release - January 2005

This release introduces the E6785C GSM/GPRS_W-CDMA fast switching lab application with the equivalent features of the following lab applications and application revisions:

  • E6701D GSM/GPRS Lab Application Revision C.04.14 (E6704A provides a license for enabling EGPRS in the E6701D)
  • E6703C W-CDMA Lab Application Revision B.02.14

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the lab application listed above.

B.01.33 Release - July 2004

This release updates the E6785B GSM/GPRS_W-CDMA fast switching lab application with the equivalent features of the following lab applications and application revisions:

  • E6701C GSM/GPRS Lab Application Revision C.03.54 (E6704A provides a license for enabling EGPRS in the E6701C)
  • E6703B W-CDMA Lab Application Revision B.01.34

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the lab application listed above.

B.01.28 Release - April 2004

This release updates the E6785B GSM/GPRS_W-CDMA fast switching lab application with the equivalent features of the following lab applications and application revisions:

  • E6701C GSM/GPRS Lab Application Revision C.03.48 (E6704A provides a license for enabling EGPRS in the E6701C)
  • E6703B W-CDMA Lab Application Revision B.01.29

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the lab application listed above.

B.01.16 Release - January 2004

This release updates the E6785B GSM/GPRS_W-CDMA fast switching lab application with the equivalent features of the following lab applications and application revisions:

  • E6701C GSM/GPRS Lab Application Revision C.03.32 (E6704A provides a license for enabling EGPRS in the E6701C)
  • E6703B W-CDMA Lab Application Revision B.01.16

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the lab application listed above.

A.02.10 Release - July 2003

This release updates the E6785A GSM/GPRS_W-CDMA fast switching lab application with the equivalent features of the following lab applications and application revisions:

  • E6701C GSM/GPRS Lab Application Revision C.02.10 (E6704A provides a license for enabling EGPRS in the E6701C)
  • E6703A W-CDMA Lab Application Revision A.02.10

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the lab application listed above.

A.01.25 Release - March 2003

This is the initial release of the E6785A GSM/GPRS_W-CDMA fast switching lab application. This release has the equivalent features of the following lab applications and application revisions:

  • E6701C GSM/GPRS Lab Application Revision C.01.24 (E6704A provides a license for enabling EGPRS in the E6701C)
  • E6703A W-CDMA Lab Application Revision A.01.23

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the lab application listed above.

A.01.20 Release - February 2003

This is the initial release of the E6785A GSM/GPRS_W-CDMA fast switching lab application. This release has the equivalent features of the following lab applications and application revisions:

  • E6701C GSM/GPRS Lab Application Revision C.01.20 (E6704A provides a license for enabling EGPRS in the E6701C)
  • E6703A W-CDMA Lab Application Revision A.01.20

For more information on measurements, specifications, and E5515 mainframe requirements, please refer to the specifications for the equivalent model of the lab application listed above.


How Do I Switch Formats?

How Do I Switch Formats?

Last updated: July 25, 2008

A. Choose a format.

  1. Press the SYSTEM CONFIG key.
  2. Press the Format Switch ( F2 ) key.

B. Switch formats.

  1. Turn the knob to highlight the desired format.

  2. Press the knob to switch formats.

Related Topics

SYSTem:APPLication


GPIB Commands with Format Mnemonics

GPIB Commands with Format Mnemonics

Some of the GPIB commands are common to multiple technologies in a fast switching application. To send a command that specifies a particular technology an extension is added to the command. It is called a format mnemonic.

Using format mnemonics is optional unless you want to send a command that is directed to a technology that is not currently active.

If you do not use a format mnemonic, or if you append the optional [:SELected] format mnemonic, the command is applied to the technology that is currently active.

The following format mnemonics can be appended to the commands listed in the table below.

  • [:SELected] (the format that is currently active).
  • :GSM, this selects the GSM/GPRS/EGPRS format.
  • :TA136, this selects the AMPS/136 format.
  • :DIGital136 (AMPS/136), this selects the IS-136 system in the cdma2000/IS-95/AMPS format, whether the format is active or not.
  • :WCDMa, this selects the W-CDMA format.
  • :FDD, this selects the Frequency Division Duplex system in the W-CDMA format, whether the format is active or not.
  • :CW, this selects the CW system within the active format.
  • :DIGital856, this selects the IS-856 system in the IS-856 1xEV-DO format, whether the format is active or not.
  • :TA856, this selects the IS-856 1xEV-DO format.
  • :AMPS, this selects the AMPS system in the cdma2000/IS-95/AMPS format, whether the format is active or not.
  • :TA2000, this selects the cdma2000/IS-95/AMPS format.
  • :DIGital95, this selects the IS-95 system in the cdma2000/IS-95/AMPS format, whether the format is active or not.
  • :DIGital2000, this selects the cdma2000 system in the cdma2000/IS-95/AMPS format.

NOTE
If you use the [:SELected] mnemonics in a format that does not support that particular command then you will receive an undefined header message.

Format Mnemonics

The table shown below, GPIB Commands using Format Mnemonics , lists the GPIB commands with format mnemonics. If you are running the 1987A, which includes all technologies, any of these commands could apply to your needs. If you are running any of the other fast switching applications, use the following key to determine which commands apply to your application:

  • B = E1985B GSM/GPRS_AMPS/136_W-CDMA Mobile Test Fast Switching
  • C = E1985C GSM/GPRS_cdma2000/IS-95/AMPS Mobile Test Fast Switching
  • E = E1985E cdma2000/IS-95/AMPS_1xEV-DO Mobile Test Fast Switching
  • L = E6785B/C/D GSM/GPRS_W-CDMA Lab Application Fast Switching

GPIB Commands using Format Mnemonics
Command | [: S E L e c t e d] | : G S M | : T A 1 3 6 | : D I G i t a l 1 3 6 | : W C D M a | : F D D | : C W | : A M P S | : T A 8 5 6 | : D I G i t a l 8 5 6 | : T A 2 0 0 0 | : D I G i t a l 2 0 0 0 | : D I G i t a l 9 5
ABORt:DPOWer | B | B |  | B |  |  |  |  |  |  |  |  |
ABORt:IQTuning | B | B |  | B |  |  |  |  |  |  |  |  |
CALL:AWGNoise:POWer:AMPLitude | E |  |  |  |  |  |  |  |  | E |  | E | E
CALL:AWGNoise:POWer[:SAMPlitude] | E |  |  |  |  |  |  |  |  | E |  | E | E
CALL:AWGNoise:POWer:STATe | E |  |  |  |  |  |  |  |  | E |  | E | E
CALL[:CELL]:BAND | C,E | C |  |  |  |  |  |  |  | E |  | C,E | C,E
CALL[:CELL]:CLPControl:REVerse:MODE (See Note 1) | E |  |  |  |  |  |  |  | E |  | E |  |
CALL[:CELL]:LACode | B,L | B,L |  |  | B,L |  |  |  |  |  |  |  |
CALL[:CELL]:MCCode | B,C,E,L | B,C,L |  | B | B,L |  |  |  | E |  | C,E |  |
CALL[:CELL]:MNCode | C | C |  |  |  |  |  |  |  |  | C |  |
CALL[:CELL]:POWer:AMPLitude | B,C,E,L | B,C,L | B |  |  | B,L | B,C,E,L | C,E |  | E |  | C,E | C,E
CALL[:CELL]:POWer[:SAMPlitude] | B,C,E,L | B,C,L | B |  | L | B,L | B,C,E,L | C,E |  | E |  | C,E | C,E
CALL[:CELL]:POWer:STATe | B,C,E,L | B,C,L | B |  | L | B,L | B,C,E,L | C,E |  | E |  | C,E | C,E
CALL[:CELL]:RACode | B,L | B,L |  |  | B,L |  |  |  |  |  |  |  |
CALL[:CELL]:RFGenerator:FREQuency | B | B | B |  |  |  |  |  |  |  |  |  |
CALL:CHANnel | E |  |  | E |  |  |  |  |  |  |  | E | E
CALL:CONNected:DROP:TIMer[:STATe] | E |  |  |  |  |  |  |  | E |  | E |  |
CALL:CONNected:LIMit[:STATe] (See Note 2) | E |  |  |  | B,L |  |  |  | E |  | E |  |
CALL:MS:REPorted:IMEI | B,L | B,L |  |  | B,L |  |  |  |  |  |  |  |
CALL:MS:REPorted:IMSI | B,L | B,L |  |  | B,L |  |  |  |  |  |  |  |
CALL:MS:REPorted:ONUMber | B | B | B |  |  |  |  |  |  |  |  |  |
CALL:MS:REPorted:PCLass | B,L | B,L | B |  | B,L |  |  |  |  |  |  |  |
CALL:MS:REPorted:REVision[:DIGital] | B | B | B |  |  |  |  |  |  |  |  |  |
CALL:MS:REPorted:MCCode | C | C |  |  |  |  |  |  |  |  | C |  |
CALL:MS:REPorted:MNCode | C | C |  |  |  |  |  |  |  |  | C |  |
CALL:MS:REPorted:PCLass | C | C |  |  |  |  |  |  |  |  | C |  |
CALL:PAGing:IMSI | B,L | B,L | B |  | B,L |  |  |  |  |  |  |  |
CALL:PAGing:REPeat[:STATe] | B,L | B,L | B |  | B,L |  |  |  |  |  |  |  |
CALL:RTVocoder:DECoder:HEADroom? | B,C,E,L | B,C,L |  |  | B,L |  |  |  |  |  | C,E |  |
CALL:RTVocoder:ENCoder:DRATe | B,C,E,L | B,C,L |  |  | B,L |  |  |  |  |  | C,E |  |
CALL:RTVocoder:ENCoder:DRATe:MODE | B,C,E,L | B,C,L |  |  | B,L |  |  |  |  |  | C,E |  |
CALL:RTVocoder:ENCoder:HEADroom? | B,C,E,L | B,C,L |  |  | B,L |  |  |  |  |  | C,E |  |
CALL:RTVocoder:INPut:VOLTage[:EXPected] | B,C,E,L | B,C,L |  |  | B,L |  |  |  |  |  | C,E |  |
CALL:RTVocoder:OUTPut:VOLTage[:MAXimum] | B,C,E,L | B,C,L |  |  | B,L |  |  |  |  |  | C,E |  |
CALL:RTVocoder:AMRate[:STATe] | B,C,E,L | B,C,L |  |  | B,L |  |  |  |  |  | C,E |  |
CALL:RTVocoder:AMRate:ALGorithm | B,C,E,L | B,C,L |  |  | B,L |  |  |  |  |  | C,E |  |
CALL:SETup:BAND | E |  |  |  |  |  |  |  |  | E |  | E | E
CALL:SETup:CHANnel | E |  |  |  |  |  |  |  |  | E |  | E | E
CALL:STATus:AWGNoise:POWer[:AMPLitude] | E |  |  |  |  |  |  |  |  | E |  | E | E
CALL:STATus:AWGNoise:POWer:STATe | E |  |  |  |  |  |  |  |  | E |  | E | E
CALL:STATus:CELL:POWer[:AMPLitude] | E |  |  |  |  |  |  |  |  | E |  | E | E
CALL:STATus:CELL:POWer:STATe | E |  |  |  |  |  | E | E | E | E | E | E | E
CALL:STATus:TOTal:POWer[:AMPLitude] | E |  |  |  |  |  |  |  |  | E |  | E | E
CALL:STATus:TOTal:POWer:STATe | E |  |  |  |  |  |  |  |  | E |  | E | E
CALL:TOTal:POWer[:AMPLitude | E |  |  |  |  |  | E | E | E | E | E | E | E
CALL:TOTal:POWer:STATe | E |  |  |  |  |  | E | E | E | E | E | E | E
CALL:TRIGger[:OUTPut]:TYPE | E |  | E |  |  |  |  |  |  |  | E |  |
FETCh:DPOWer:ICOunt? | B | B |  | B |  |  |  |  |  |  |  |  |
FETCh:DPOWer:INTegrity[:RANGE1]? | B | B |  | B |  |  |  |  |  |  |  |  |
FETCh:DPOWer:NUMBer[:RANGE1]? | B | B |  | B |  |  |  |  |  |  |  |  |
FETCh:DPOWer:POWer[:RANGE1]? | B | B |  | B |  |  |  |  |  |  |  |  |
FETCh:DPOWer[:ALL][:RANGE1]? | B | B |  | B |  |  |  |  |  |  |  |  |
FETCh:IQTuning:ICOunt? | B | B |  | B |  |  |  |  |  |  |  |  |
FETCh:IQTuning:INTegrity? | B | B |  | B |  |  |  |  |  |  |  |  |
FETCh:IQTuning:POWer[:ALL]? | B | B |  | B |  |  |  |  |  |  |  |  |
FETCh:IQTuning:REFerence:FREQuency? |  |  |  |  |  |  |  |  |  |  |  |  |
FETCh:IQTuning:SPUR:POWer? | B | B |  | B |  |  |  |  |  |  |  |  |
FETCh:IQTuning[:ALL]? | B | B |  | B |  |  |  |  |  |  |  |  |
INITiate:DONE:FLAG:DPOWer | B | B |  | B |  |  |  |  |  |  |  |  |
INITiate:DONE:FLAG:IQTuning | B | B |  | B |  |  |  |  |  |  |  |  |
INITiate:DPOWer:OFF | B | B |  | B |  |  |  |  |  |  |  |  |
INITiate:DPOWer[:ON] | B | B |  | B |  |  |  |  |  |  |  |  |
INITiate:IQTuning:OFF | B | B |  | B |  |  |  |  |  |  |  |  |
INITiate:IQTuning[:ON] | B | B |  | B |  |  |  |  |  |  |  |  |
READ:DPOWer[:ALL] | B | B |  | B |  |  |  |  |  |  |  |  |
READ:IQTuning[:ALL] | B | B |  | B |  |  |  |  |  |  |  |  |
RFANalyzer:AUTO:POWer | E |  |  |  |  |  |  |  |  | E |  | E | E
RFANalyzer:MANual:POWer | B,C,E,L |  |  |  |  | B,L |  |  |  | E |  | E,C | E,C
SETup:DPOWer:CONTinuous | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:DPOWer:COUNt:NUMBer | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:DPOWer:EMDifference | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:DPOWer:TIMeout[:STIMe] | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:DPOWer:TIMeout:STATe | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:DPOWer:TIMeout:TIME | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:IQTuning:CONTinuous | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:IQTuning:COUNt[:SNUMber] | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:IQTuning:COUNt:NUMBer | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:IQTuning:COUNt:STATe | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:IQTuning:OFFSet:FREQuency | B |  |  | B |  |  |  |  |  |  |  |  |
SETup:IQTuning:OFFSet:POINts | B |  |  | B |  |  |  |  |  |  |  |  |
SETup:IQTuning:REFerence[:MANual][:FREQuency] | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:IQTuning:SPUR[:SFREQuency] | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:IQTuning:SPUR:FREQuency | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:IQTuning:SPUR:STATe | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:IQTuning:TIMeout[:STime] | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:IQTuning:TIMeout:STATe | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:IQTuning:TIMeout:TIME | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:IQTuning:TRIGger:DELay | B | B |  | B |  |  |  |  |  |  |  |  |
SETup:IQTuning:TRIGger:SOURce | B | B |  | B |  |  |  |  |  |  |  |  |
SYSTem:FTRigger:STATe | B | B |  | B |  |  |  |  |  |  |  |  |
SYSTem:FTRigger:TSLot | B | B |  | B |  |  |  |  |  |  |  |  |

NOTE:

  1. The :SELect, :TA856 and :TA2000 format mnemonics access the same shared setting value. It is recommended that you use the command CALL:CLPControl:REVerse:MODE (without any format mnemonic) to set the reverse closed loop power control mode.
  2. The :TA856 and :TA2000 format mnemonics access the same shared setting value while the :WCDMA format mnemonic accesses a separate setting value. If you do not add a format mnemonic to the CALL:CONNected:LIMit command, the command is sent to the active format.


SYSTem:APPLication

SYSTem:APPLication

GPIB Command Conventions

  • SYSTem:APPLication[:CURRent][:NAME]?
  • SYSTem:APPLication[:CURRent]:REVision?
  • SYSTem:APPLication:CATalog[:NAME]?
  • SYSTem:APPLication:CATalog[:NAME]:COUNt?
  • SYSTem:APPLication:CATalog:FORMat?
  • SYSTem:APPLication:CATalog:FORMat:COUNt?
  • SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>'
  • SYSTem:APPLication:CATalog:LICense:APPLication:ALL?
  • SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?
  • SYSTem:APPLication:CATalog:REVision?<sp>'<application name>'
  • SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>'
  • SYSTem:APPLication:FORMat[:NAME]
  • SYSTem:APPLication:FORMat:LICense?<sp>'<format name>'
  • SYSTem:APPLication:SELect[:NAME]
  • SYSTem:APPLication:SELect:REVision
  • SYSTem:APPLication:SELect:REVision?<sp>'<application name>'

SYSTem:APPLication[:CURRent][:NAME]?

Function

Queries the name of the currently running application.

To query the revision of the currently running application, see SYSTem:APPLication[:CURRent]:REVision? .

To switch applications, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication?"

SYSTem:APPLication[:CURRent]:REVision?

Function

Queries the revision of the currently running application.

To query the name of the currently running application, see SYSTem:APPLication[:CURRent][:NAME]? .

To switch to a different revision of an application, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01"

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:REVision?"

SYSTem:APPLication:CATalog[:NAME]?

Function

Queries the names of the applications stored on the test set.

This query returns a comma-separated list of double-quoted strings (one for each application stored on the test set).

To query the number of applications stored on the test set, see SYSTem:APPLication:CATalog[:NAME]:COUNt? .

To switch applications, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: One or more of the following strings, separated by commas -

  • "1xEV-DO FTM Terminal Test"
  • "1xEV-DO Lab App"
  • "1xEV-DO Lab App T'
  • "1xEV-DO Terminal Test"
  • "AMPS/136 Mobile Test"
  • "CDMA 2000 Lab App"
  • "CDMA 2000 Lab App B"
  • "CDMA 2000 Lab App T"
  • "CDMA 2000 Mobile Test"
  • "CDMA 2000_1xEV-DO"
  • "EGPRS Lab App"
  • "Fast Switch Test App"
  • "GPRS Lab Application"
  • "GPRS Lab App B"
  • "GPRS Mobile Test"
  • "GSM Mobile Test"
  • "GSM/GPRS Lab App C"
  • "GSM/GPRS Lab App D"
  • "GSM/GPRS Lab App E"
  • "GSM/GPRS Lab App T"
  • "GSM/GPRS Mobile Test"
  • "GSM/GPRS RF Modem"
  • "GSM/GPRS_AMPS/136"
  • "GSM/GPRS_AMPS/136_WCDMA"
  • "GSM/GPRS_CDMA 2000"
  • "GSM/GPRS_WCDMA Lab App"
  • "GSM/GPRS_WCDMA Lab App B"
  • "GSM/GPRS_WCDMA Lab App C"
  • "GSM/GPRS_WCDMA Lab App D"
  • "GSM/GPRS_WCDMA Lab App T"
  • "WCDMA Lab App"
  • "WCDMA Lab App B"
  • "WCDMA Lab App C"
  • "WCDMA Lab App D"
Query (continued)
  • "WCDMA Lab App T"
  • "WCDMA Mobile Test"

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog?"

SYSTem:APPLication:CATalog[:NAME]:COUNt?

Function

Queries the total number of applications stored on the test set.

To query the names of the applications stored on the test set, see SYSTem:APPLication:CATalog[:NAME]? .

Query

Range: 0 through 30

Resolution: 1

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:COUNt?"

SYSTem:APPLication:CATalog:FORMat?

Function

Queries the names of the formats in the current application.

This query returns a comma-separated list of double-quoted strings (one for each format in the application).

To query the number of formats in the current application, see SYSTem:APPLication:CATalog:FORMat:COUNt? .

To switch formats in a fast switching application, see SYSTem:APPLication:FORMat[:NAME] .

Query

Range: One or more of the following strings separated by commas -

  • "1xEV-DO"
  • "AMPS/136"
  • "GSM/GPRS" (Note: this query return represents GSM, GPRS and EGPRS formats)
  • "IS-2000/IS-95/AMPS"
  • "IS-856"
  • "WCDMA"

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:FORMat?"

SYSTem:APPLication:CATalog:FORMat:COUNt?

Function

Queries the number of formats in the current application.

To query the names of the formats in the current application, see SYSTem:APPLication:CATalog:FORMat? .

Query

Range: 0 to 30

Resolution: 1

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:FORMat:COUNt?"

SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>'

Function

Queries the license status for the specified application/revision. The application/revision does not have to be installed in the test set.

The query must include a parameter for the application name and revision, enclosed by single quotes and separated by a comma. For application names and revisions, see SYSTem:APPLication:CATalog[:NAME]? and SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' . Note that the application name and revision parameters are not case-sensitive.

Query

Range: LIC|NLIC|PART|UNKN

  • "LIC" indicates this is a licensed application/revision.
  • "NLIC" indicates this is not a licensed application/revision.
  • "PART" indicates that not all of the formats in this application/revision are licensed. (To determine the license status of each format, see SYSTem:APPLication:FORMat:LICense?<sp>'<format name>' .)
  • "UNKN" indicates that license status is unknown.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense? 'CDMA 2000 Mobile Test','B.07.00'"

SYSTem:APPLication:CATalog:LICense:APPLication:ALL?

Function

Queries the names of the applications, formats and features that are licensed for the test set. The applications, formats and features do not have to be installed in the test set to be returned by this query.

This query returns a comma-separated list of double-quoted strings (two for each application, one for each format or feature).

To query the number of licensed applications, formats and features for the test set, see SYSTem:APPLication:CATalog:LICense:APPLication:COUNt? .

Query

Range: One or more of the following strings, separated by commas.

Applications -

  • "E1960A","GSM Mobile Test"
  • "E1961A","AMPS/136 TA"
  • "E1962B","CDMA2000 TA"
  • "E1963A","WCDMA TA"
  • "E1964A","GPRS Mobile Test"
  • "E1966A","1xEV-DO TA"
  • "E1968A","GSM/GPRS Mobile Test"
  • "E1976A","1xEV-DO FTM TA"
  • "E1985A","GSM/GPRS_AMPS/136"
  • "E1985B","GSM/GPRS_AMPS/136_WCDMA"
  • "E1985C","GSM/GPRS_CDMA 2000"
  • "E1985E","CDMA 2000_1xEV-DO"
  • "E1987A","Fast Switch Test App"
  • "E6590A","GSM/GPRS RF Modem"
  • "E6701A","GPRS LA"
  • "E6701B","GPRS LA rev B"
  • "E6701C","GSM/GPRS LA rev C"
  • "E6701D","GSM/GPRS LA rev D"
  • "E6701E","GSM/GPRS LA rev E"
  • "E6701T","GSM/GPRS LA rev T"
  • "E6702A","CDMA2000 LA"
  • "E6702B","CDMA2000 LA rev B"
  • "E6702T","CDMA2000 LA rev T"
  • "E6703A","WCDMA LA"
  • "E6703B","WCDMA LA rev B"
  • "E6703C","WCDMA LA rev C"
  • "E6703D","WCDMA LA rev D"
  • "E6703T","WCDMA LA rev T"
  • "E6704A","EGPRS LA"
  • "E6706A","1xEV-DO Lab App"
  • "E6706T","1xEV-DO LA rev T"
  • "E6785A","GSM/GPRS_WCDMA Lab App"
  • "E6785B","GSM/GPRS_WCDMA LA rev B"
Query (continued)
  • "E6785C","GSM/GPRS_WCDMA LA rev C"
  • "E6785D","GSM/GPRS_WCDMA LA rev D"
  • "E6785T","GSM/GPRS_WCDMA LA rev T"

Formats -

  • "E1968A-101","GSM TA"
  • "E1968A-102","GPRS TA"
  • "E1968A-103","EGPRS TA"
  • "E1968A-201","GSM/GPRS TA"
  • "E1968A-202","GSM/GPRS/EGPRS TA"
  • "E6590A-101","GSM/GPRS"
  • "E6590A-102","EGPRS"
  • "E6590A-103","RF Modem"

Features -

  • "E1962B-401","CDMA2000 RelA"
  • "E1962B-402","AMPS Enhancement"
  • "E1962B-403","CDMA2000 Authenticat"
  • "E1963A-401","WCDMA Video Call"
  • "E1963A-403","HSDPA Test Modes"
  • "E1966A-102","1xEV-DO RelA"
  • "E1968A-410","Phase & Ampl vs Time"
  • "E1976A-102","1xEV-DO RelA FTM"
  • "E1999A-201","Fast Device Tune"
  • "E1999A-401","GSM Fast Device Tune"
  • "E6706A-102","1xEV-DO Rel A ETAP"
  • "E6706T-102","1xEV-DO Rel A ETAP"

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:ALL?"

SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?

Function

Queries the number of applications, formats and features that are licensed for the test set. The applications, formats and features do not have to be installed in the test set to be included in the query result.

To query the names of the licensed applications, formats and features for the test set, see SYSTem:APPLication:CATalog:LICense:APPLication:ALL? .

Query

Range: 0 to 300

Resolution: 1

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?"

SYSTem:APPLication:CATalog:REVision?<sp>'<application name>'

Function

Queries the revisions stored on the test set for the specified application.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

This query returns a comma-separated list of double-quoted strings (one for each revision of the application).

Note, if you have several revisions of the application stored on the test set, you may need to increase your GPIB controller's timeout time to avoid a timeout condition.

To query the number of revisions stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>' .

To switch to a different revision of an application, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

 Range: Comma-separated list of 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01","A.02.01"

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:REVision? 'CDMA 2000 MOBILE TEST'"

SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>'

Function

Queries the number of revisions stored on the test set for the specified application.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

To query the revision numbers stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' .

Query

Range: 0 to 30

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:REVision:COUNt? 'CDMA 2000 MOBILE TEST'"

SYSTem:APPLication:FORMat[:NAME]

Function

Switches to the specified format (in the current application). Only fast switching applications include more than one format. To determine what formats are available in the current application, see SYSTem:APPLication:CATalog:FORMat? . To determine the license status of a format, see SYSTem:APPLication:FORMat:LICense?<sp>'<format name>' .

Queries the name of the currently active format in the current application.

Setting

Range: See SYSTem:APPLication:CATalog:FORMat?

Query

Range: same as setting

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:FORMat 'IS-2000/IS-95/AMPS'"

OUTPUT 714;"SYSTem:APPLication:FORMat?"

SYSTem:APPLication:FORMat:LICense?<sp>'<format name>'

Function

Queries the license status of the specified format in the current application.

The query must include a parameter for the format name enclosed by single quotes. For format names, see SYSTem:APPLication:CATalog:FORMat? . Note that the format name parameter is not case-sensitive.

Query

Range: LIC|NLIC|UNKN

  • "LIC" indicates this is a licensed format.
  • "NLIC" indicates this is not a licensed format.
  • "UNKN" indicates that the license status is unknown.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:FORMat:LICense? 'IS-2000/IS-95/AMPS'"

SYSTem:APPLication:SELect[:NAME]

Function

Switches to the specified application (this includes a reboot of the test set). To determine what applications are stored on the test set, see SYSTem:APPLication:CATalog[:NAME]? . The revision that is switched to is determined by SYSTem:APPLication:SELect:REVision . To determine the license status of the application/revision, see SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>' .

Queries the name of the application that will be loaded after the next reboot of the test set.

Setting

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Query

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect 'CDMA 2000 MOBILE TEST'"

OUTPUT 714;"SYSTem:APPLication:SELect?"

SYSTem:APPLication:SELect:REVision

Function

Sets the revision that will be loaded when the application is switched to using the SYSTem:APPLication:SELect[:NAME] command.

To determine what application is to be switched to, see SYSTem:APPLication:SELect[:NAME] . To determine what revisions are stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' . To determine the license status of a revision, see SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>' .

To query the revision that will be loaded when an application is switched to, see SYSTem:APPLication:SELect:REVision?<sp>'<application name>' .

NOTE
GSM Mobile Test revisions prior to A.04.00 did not have application switching and provide no way to return to revisions that have switching. If you switch to a GSM Mobile Test application revision prior to A.04.00, the only way to return to a newer revision is by downloading it using the process for upgrading firmware.

Setting

Range: see SYSTem:APPLication:CATalog[:NAME]? and SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect:REVision 'CDMA 2000 Mobile Test','B.06.30'"

SYSTem:APPLication:SELect:REVision?<sp>'<application name>'

Function

Queries the revision that will be loaded when the specified application is switched to using the SYSTem:APPLication:SELect[:NAME] command.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

To set the revision that will be loaded when the specified application is switched to, see SYSTem:APPLication:SELect:REVision .

NOTE
GSM Mobile Test revisions prior to A.04.00 did not have application switching and provide no way to return to revisions that have switching. If you switch to a GSM Mobile Test application revision prior to A.04.00, the only way to return to a newer revision is by downloading it using the process for upgrading firmware.

Query

 Range: 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01"

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect:REVision? `CDMA 2000 MOBILE TEST'"


GPIB Syntax for Fast Switching

GPIB Syntax for Fast Switching

GPIB Commands that Switch Formats

For a detailed description of GPIB commands that are used for format switching, see:

SYSTem:APPLication:FORMat[:NAME]

GPIB Commands for the Formats in Fast Switching Applications

GPIB command syntax for the fast switching applications is identical to the syntax for the test and lab applications. For details on a specific format's syntax, tab to the GPIB commands section for that format.

For example, to locate the GPIB commands for the 1xEV-DO test application that is included in the E1987A fast switching application, tab to the 1xEV-DO (E1966A) technology.

GPIB Commands with Format Mnemonics

Some GPIB commands are common to more than one technology in a fast switching application. To specify a technology when using these commands the test set accepts a format mnemonic at the end of the command (:SELected, :GSM, :GPRS, :TA136, :DIGital136, :DIGital95, :DIGital2000, :TA2000, :DIGital856, :TA856, :FDD and :WCDMa).

For a listing of the GPIB commands that are common to multiple technologies, see:

GPIB Commands with Format Mnemonics

If you do not add a format mnemonic to a common command, the command is applied to the currently active technology.


GPIB Command Conventions

GPIB Command Conventions

Description

Command Description

The uppercase letters of a mnemonic represent the short form of the mnemonic, whereas the long form of a mnemonic is the short form followed by the lowercase letters. The test set accepts either the long form or the short form of the mnemonic.

The mnemonics that are inside square brackets are optional. That is, a command operates the same whether or not the mnemonic in square brackets is used in the command.

A vertical bar, |, implies choices. When mnemonics are listed in parentheses separated by vertical bars ( | ), you must choose one of the mnemonics inside the parentheses.

Complex Command Description

Complex commands are valuable because they set the state of the parameter and a value for that parameter. For example, a command that contains the mnemonic [:SAMPlitude] is a complex command that sets the state to ON as well as the amplitude. You can use parameters such as amplitude, frequency, gain, number, time, and value as a complex command. Refer to the specific command for the parameter that applies.

Data Type Description

num value

Integer, float or scientific values.

For example,

CALL:POWer -55.5

CALL:POWer -5.55E+001

CALL:CHANnel 525

string

Characters. The string will often need to be enclosed in single or double quotes, depending upon your programming environment.

For example,

CALL:CIDentity "#0123456789*"

CALL:UPLink:PRAChannel:ASUBchannels '111111111111'

The string returned by the test set is enclosed by double quotes.
choice1|choice2|choice3

Specific character choices.

For example,

CALL:OPERating:MODE D2KTest

SYSTem:COMMunicate:GPIB:DEBug ON

Unit Type Description

Some commands have optional units of measurement. These are displayed in square brackets. If no units are specified in the command then the default unit in bold font below is used. The test set accepts the specified unit either with or without a space inserted between the <num value> and the unit (for example, both 10S and 10 S are valid). The following table summarizes the units available.

Description

Optional Units

Example

Amplitude (linear)

V |MV

To set the spectrum monitor's timeout interval to 20 seconds, use any of the following formats:

SETup:SMONitor:TIMeout:TIME 20
SETup:SMONitor:TIMeout:TIME 20S
SETup:SMONitor:TIMeout:TIME 20 S

Power (logarithmic)

DBM |DBW

Level (relative)

DB

Frequency

HZ |KHZ|MHZ|GHZ

Time

S |MS|US|NS

Percentage

PCT

[:SELected] Mnemonic

The [:SELected] Mnemonic is an optional mnemonic that implies a current selection on the test set. Often there are other mnemonics that can be used in place of the [:SELected] mnemonic to configure a setting that is not the currently selected configuration on the test set. The mnemonics that can replace the [:SELected] mnemonic are listed in parentheses separated by vertical bars ( | ) in the description table title. An example of a command that contains the [:SELected] mnemonic is shown in the following table.

Using quotes around strings

When the setting and query values of a GPIB command are strings, a single quote is needed around the strings when setting the command, while the test set returns the result in double quoted strings when querying.

For example:

OUTPUT 714;"SYSTem:APPLication:FORMat '1xEV-DO'"

OUTPUT 714;"SYSTem:APPLication:FORMat?"
!The test set returns "1xEV-DO". Note here the strings are enclosed in double quote.

An example of a command that contains strings in the setting and query values is shown in the following table.


Step 1: Set Up the Test Set

Step 1: Set Up the Test Set

The following information provides additional details on Step 1 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you initialize the test set and set up the general operating conditions.

Contents

  • Initialize the Test Set
  • Set Up General Operating Conditions

Initialize the Test Set

  • Fully Preset the Test Set

    It is important to get the test set to a known state before each production session.

    Sending the *RST command fully presets the test set, which ends all call processing and measurement processes and restores all values to defaults.

  • Clear the Error Queue

    Before each production session, it is useful to clear the error queue of any old messages. That way, you know that any messages logged are relevant to the current production session.

    Sending the *CLS command clears the error queue.

Set Up General Operating Conditions

  • Turn Debugger On

    While developing your code, it is very useful to enable the GPIB debugger using the
    SYST:COMM:GPIB:DEB ON command. When the debugger is on, the test set alerts you when you send an incorrect command, and it also tells you which symbol or letter in the command is incorrect.

NOTE
You should turn the debugger off once you have finished development and your code is stable.

  • Set Operating Mode

    The test set contains a base station emulator (BSE), whose primary purpose is to provide enough call processing to allow parametric measurements of a mobile station's RF signal.

    An important characteristic of the test set's base station emulator is its operating mode. The operating mode sets the way in which the base station emulator interacts with the mobile station.

    Active cell mode is used when emulating a normal cell. Active cell mode allows active signaling between the mobile station and BSE. The mobile station camps to the BSE signal, and an actual call is established.

    In test mode, the mobile station synchronizes to the BSE signal and transmits an appropriate signal which the test set analyzes.

    The test set's operating mode is set using the following command:

    Command to Set the Test Set's Operating Mode

    Command

             Example

    CALL:OPER:MODE <operating mode>

    CALL:OPER:MODE CALL

  • Set Amplitude Offsets

    To achieve accurate measurement results, it is important to account for losses in the cabling and fixturing between the mobile station and test set. You must determine what the losses are for your test setup and then specify the appropriate frequency-dependent amplitude offset values.

    You can specify amplitude offsets for up to 20 frequencies using the following commands:

    Commands to Set Amplitude Offsets

    Command

             Example

    SYST:CORR:FREQ <freq1>, <freq2>, <freq3>

    SYST:CORR:FREQ 800MHz, 1800MHz,
    1900MHz

    SYST:CORR[:SGAin] <offset1>,
    <offset2>, <offset3>

             SYST:CORR -0.7, -1.0, -1.2

  • Set Display Mode

    To achieve a slightly faster test execution speed, you can disable the front panel display on the test set using the DISP:MODE FAST command.


Step 2: Configure Test Set and Mobile Station Parameters

Step 2: Configure Test Set and Mobile Station Parameters

The following information provides additional details on Step 2 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you configure the parameters that allow a connection to be made between the test set and mobile station. This mainly involves setting up channels and power levels.

Contents

  • Set Up Channels
  • Set Cell Power
  • Set Mobile Station Transmit Power
  • Set Up Additional Connection Parameters

Set Up Channels

For many technologies, setting up channels involves specifying the channel associated with every band and channel type (for example, analog or digital), and then setting the active band and channel type. For some technologies, such as W-CDMA, you simply specify the downlink and uplink UARFCNs (channels).

  • Specify Channel Numbers

    All of the test set's test applications can test in more than one frequency band (for example, US Cellular, US PCS, or Korean PCS). To produce the most efficient code, you should configure the channel information for each band in advance. Then, to move to a new band during testing, you only need to send the command to change bands. You do not need to also specify the channel of the new band. This reduces test time.

    To set up the channel number for the various bands, use one of the following commands (depending upon which test application you are using):

    Commands to Set the Channel for a Band

    Command

             Example Technology

    CALL:<channel mnemonic>:<band mnemonic>
    <num value>

    CALL:TCH:EGSM 124

             GSM/GPRS/EGPRS

    CALL:SET:<channel type mnemonic>:<band
    mnemonic> <num value>

    CALL:SET:DTC:PCS 777

             AMPS/136

    CALL:CHAN:<channel type mnemonic>:<band
    mnemonic> <num value>

    CALL:CHAN:DIG2000:K
    PCS 384

             cdma2000/IS-95/AMPS

    This practice also applies to test applications which test both analog and digital channel types. In this case you should specify the channel for the analog and digital channel types in advance. Then, switching between them requires only one command to initiate the change, and not an additional change to specify the channel of the new channel type.

    If you specify channels in advance as described, the only time you need to specify a channel during testing is if you move to a new channel within the same band and channel type.

  • Set Active Band and Mode

    Once you have specified the channel information for each band and channel type, you must set the active band using one of the following commands (depending upon which test application you are using):

    Commands to Set the Active Band

    Command

             Example Technology

    CALL:<channel mnemonic>:BAND <band mnemonic>

    CALL:TCH:BAND
    EGSM

             GSM/GPRS/EGPRS

    CALL:SET:<channel type mnemonic>:BAND <band
    mnemonic>

             CALL:SET:DTC:BAND
    PCS     		AMPS/136
    CALL:BAND:<channel mnemonic> <band mnemonic>

    CALL:BAND:DIG2000
    KPCS

             cdma2000/IS-95/AMPS

    If the test application you are using supports testing of both analog and digital channel types, then you must also set the channel type using the following command:

    Command to Set the Active Channel Type

    Command

             Example

    CALL:<channel mnemonic>:TYPE <channel type
    mnemonic>

    CALL:TCH:TYPE
    DTC

  • Active Cell and Test Mode Considerations

    The function of the CALL commands differ depending upon whether you are in active cell or test mode.

    In active cell mode, when you use the CALL commands to set the channel numbers, the test set's output frequency and receiver frequency are set. A message is also sent to the mobile station to set its frequency.

    However, in test mode, since the BSE does not send call processing information to the mobile station, the CALL commands only configure the test set's output frequency and receiver frequency. You need to also send the appropriate test mode commands to the mobile station to set it to the correct frequency.

    In test mode, instead of using the CALL commands to configure the test set's frequencies, you may prefer to manually control the RF generator and RF analyzer using the CALL:RFG and RFAN commands, respectively. In either case, you must still send the appropriate test mode commands to the mobile station to move it to the proper frequency.

Set Cell Power

To set the output power of the test set, use the following command:

Command to Set Cell Power
Command | Example
CALL:POW <num value> | CALL:POW -75

  • Active Cell and Test Mode Considerations

    You can use the CALL:POW command to set the cell power in both active cell and test mode. However, in test mode you may prefer to manually control the output power of the test set using the CALL:RFG commands.

Set Mobile Station Transmit Power

In active cell mode, use one of the following commands to set the mobile station transmit power level (depending upon which test application you are using):

Commands to Set Mobile Station Transmit Power
Command | Example | Technology
CALL:MS:TXL:<band mnemonic> <num value> | CALL:MS:TXL:DCS <num value> | GSM
CALL:SET:MS:<channel type mnemonic>:TXL:<band mnemonic> <num value> | CALL:SET:MS:DIG:TXL:PCS <num value> | AMPS/136
CALL:<channel mnemonic>:MS:TXL:<band mnemonic>:BURS <num value> | CALL:PDTCH:MS:TXL:DCS: BURS <num value> | GPRS/EGPRS

In addition to setting the mobile station transmit level, these commands also automatically configure the test set's receiver at the expected input level, whether in active cell or test mode. However, in test mode, you must also send the appropriate test mode commands to the mobile station to command it to output at the correct level. This is due to the fact that the BSE is not transmitting call processing commands to the mobile station.

  • Manually Setting Expected Power

    Sending the CALL commands in Commands to Set Mobile Station Transmit Power automatically sets the expected input level of the test set's receiver. However, there is another option for setting the receiver's input level in both active cell and test mode. It is often beneficial to manually set the expected input power level using the RFAN commands, rather than using the CALL commands.

    When you set the expected power manually, you tell the test set exactly what power level to expect. Whereas the CALL commands simply tell the test set the range of input level to expect, based on the definition of the mobile station power level (for example, an AMPS/136 mobile station transmitting at power level 3 has an output level in the range of +20 dBm to +26 dBm).

Set Up Additional Connection Parameters

Depending upon the test application you are using, there may be other connection parameters to specify, such as timeslot, timing advance, vocoder, or data rates and types.

In active cell mode, you may also choose to set up network parameters, such as base station identifier numbers (for example, SID) and color codes.

All of these parameters are configured using the CALL subsystem.


Step 3: Set Measurement Parameters

Step 3: Set Measurement Parameters

The following information provides additional details on Step 3 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you set up the conditions under which the measurements operate. You do this by configuring measurement parameters.

Contents

  • Measurement Parameters Overview
  • Generic Measurement Parameters
  • Measurement-Specific Measurement Parameters

Measurement Parameters Overview

There are two different types of measurement parameters:

  • Generic Measurement Parameters
  • Measurement-Specific Measurement Parameters

The SETup subsystem is used to configure measurement parameters. Each individual measurement parameter can be set and queried using the associated SETup subsystem command. The general hierarchy of the SETup subsystem command structure is as follows:

SETup:<measurement mnemonic>:<measurement parameter> <parameter setting/value>

NOTE
Not all measurements use all measurement parameters. Refer to the GPIB syntax listing for the detailed list of measurement parameters for individual measurements.

Generic Measurement Parameters

There are three types of generic measurement parameters:

  • Measurement Count (used by most measurements)
    Measurement Count State
    Measurement Count Number

  • Measurement Timeout (used by all measurements)
    Measurement Timeout State
    Measurement Timeout Time

  • Measurement Trigger (used by most measurements)
    Trigger Arm (used by all measurements)
    Trigger Source (not applicable to analog measurements)
    Trigger Delay (not applicable to analog measurements)

Measurement Count Parameters

The measurement count parameters control measurement averaging. The STATe command turns averaging on or off, and the NUMBer command determines the number of averages. The SNUMber command is a complex command which allows you to turn averaging on and set the number of averages in one command.

Statistical Measurement Results Parameters
Parameter | Command Syntax
Measurement Count State | SETup:<meas-mnemonic>:COUNt:STATe <ON|1|OFF|0>
Measurement Count Number | SETup:<meas-mnemonic>:COUNt:NUMBer <numeric value>
Measurement Count Number and State | SETup:<meas-mnemonic>:COUNt[:SNUMber] <numeric value>
Programming Example:

OUTPUT Test_set;"SET:DTXP:COUN 10"

sets the multi-measurement count state to ON and set the number of averages to 10 for the digital transmit power measurement.

Measurement Timeout Parameters

Measurement timeout parameters control the maximum time that a measurement executes. TIMe sets the amount of time and STATe determines if the timeout is in use. The STIMe command is a complex command which enables you to set both parameters in one command.

Measurement Timeout Parameters
Parameters | Command Syntax
Measurement Timeout Time and State | SETup:<meas-mnemonic>:TIMeout[:STIMe] <numeric value>[<suffix>]
Measurement Timeout State | SETup:<meas-mnemonic>:TIMeout:STATe <ON|1|OFF|0>
Measurement Timeout Time | SETup:<meas-mnemonic>:TIMeout:TIME <numeric value>[<suffix>]
Programming Example:

OUTPUT Test_set;"SET:DTXP:TIM 10"

sets the measurement timeout state to ON and set the measurement timeout time to 10 seconds for the digital transmit power measurement.

Measurement Trigger Parameters

There are three measurement trigger parameters. They control the arming of a measurement, the source of the trigger, and the trigger's delay.

  • The trigger arm parameter determines whether the test set makes one measurement and then stops (single), or automatically re-arms upon completion of one measurement and repeats the process (continuous). The recommended setting when writing a control program is single (CONTinuous OFF).

  • The trigger source parameter selects the source of the measurement trigger signal. The recommended Trigger Source setting when writing a control program is AUTO.

NOTE
Trigger source is always IMMediate for analog measurements and cannot be changed by the user.

  • The trigger delay parameter controls the delay between the trigger event (the point in time at which the trigger signal is received) and the start of sampling. Negative values indicate that the sampling should occur prior to the trigger event.

NOTE
Trigger delay is not applicable to analog measurements.

Measurement Trigger Parameters
Parameter | Command Syntax
Trigger Arm | SETup:<meas-mnemonic>:CONTinuous <ON|1|OFF|0>
Trigger Source | SETup:<meas-mnemonic>:TRIGger:SOURce <AUTO|IMMediate|PROTocol|RISE>
Trigger Delay | SETup:<meas-mnemonic>:TRIGger:DELay <numeric value>[<suffix>]

NOTE
You can set the Trigger Arm for all measurements to single (CONTinuous OFF) using the following command syntax:

SETup[:ALL]:CONTinuous:OFF

Programming Example:

OUTPUT Test_set;"SET:CONT:OFF"

sets the trigger arm to single for all measurements.

Programming Example:

OUTPUT Test_set;"SET:DTXP:TRIG:SOUR AUTO"

sets the trigger source to AUTO for the digital transmit power measurement.

Programming Example:

OUTPUT Test_set;"SET:DTXP:TRIG:DEL 10 US"

sets the trigger delay to 10 microseconds for the digital transmit power measurement.

Measurement-Specific Measurement Parameters

Measurement-specific measurement parameters set up operating conditions for a specific measurement. For example:

  • Setting the channel power measurement speed in IS-2000
  • Setting ORFS frequency offsets in GPRS
  • Setting number of bits for the FBER measurement in GSM

Refer to the GPIB syntax listing for the detailed list of measurement parameters for individual measurements.

Programming Example:

OUTPUT Test_set;"SET:CPOW:MSP FAST"

sets the IS-2000 channel power measurement speed to fast.

Programming Example:

OUTPUT Test_set;"SET:ORFS:SWIT:FREQ 400 KHZ"

sets the first ORFS offset to 400 kHz.

Programming Example:

OUTPUT Test_set;"SET:FBER:COUN 10000"

sets the number of fast BER bits to test to 10,000 bits.

Program Example Setting Both Generic and Measurement-Specific Measurement Parameters

! Set trigger arm to single for all measurements:
!
OUTPUT Test_set;"SET:CONT:OFF"
!
! *****************************************************
! Configure Modulation Accuracy Measurement:
!
OUTPUT Test_set;"SET:MACC:COUN 5"
! Example of using a complex command to set both the
! measurement count state and number at the same time.
!
OUTPUT Test_set;"SET:MACC:TRIG:SOUR AUTO"
! Sets trigger source to auto.
!
OUTPUT Test_set;"SET:MACC:TIM 15"
! Sets timeout state to ON and time to 15 sec.
!
OUTPUT Test_set;"SET:MACC:EVM10:STAT ON"
! Turns the EVM10 State ON
!
! ******************************************************
! Configure Digital TX Power Measurement:
!
OUTPUT Test_set;"SET:DTXP:COUN 5"
OUTPUT Test_set;"SET:DTXP:TRIG:SOUR AUTO"
OUTPUT Test_set;"SET:DTXP:TIM 5"
!
! ******************************************************
! Configure Frequency Stability Measurement:
!
OUTPUT Test_set;"SET:FST:COUN 3"
OUTPUT Test_set;"SET:FST:TIM 10"
!
! ******************************************************
! Configure Analog TX Power Measurement:
!
OUTPUT Test_set;"SET:ATXP:COUN 5"
OUTPUT Test_set;"SET:ATXP:TRIG:SOUR AUTO"
OUTPUT Test_set;"SET:ATXP:TIM 15"


Step 4: Make Connection

Step 4: Make Connection

The following information provides additional details on Step 4 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you make a connection between the mobile station and test set. How you do this depends upon whether you are in active cell or test mode. In active cell mode you establish a phone call between the test set and mobile station. In test mode, you command the mobile station to synchronize to the test set's signal and begin transmitting back an appropriate signal.

Contents

  • Establish a Call in Active Cell Mode
  • Make a Test Mode Connection

Establish a Call in Active Cell Mode

To test a mobile station in active cell mode, you must first establish a call between the test set and mobile station. Your control program must issue the commands necessary to initiate the call connection process, either to the test set (for a base station originated call) or to the mobile station (for a mobile station originated call). Your control program must then determine when the call has successfully connected so that it can proceed to testing. The control program must also determine if the call has not been successfully connected so that it can take appropriate action.

Call States

At any instant in time a call can be in a stable state such as the idle or the connected state, or in one of many transitory states such as alerting, handoff, registering, releasing or paging. These are referred to as transitory states because the amount of time which the call can spend in any of these states is limited by the mobile station's protocol. The call is not allowed to stay in a transitory state indefinitely.

NOTE
If repeat paging or repeat registration are on, it is possible for the call process to stay in one of the transitory states beyond the time specified by the mobile station's protocol timers.

Call Connection Synchronization Commands

The test set has a set of commands designed specifically for call connection and release synchronization.

Call Connection Synchronization Commands
Synchronization Command | Command Syntax
Call-Connected-State Query | CALL:CONNected[:STATe]?
Call-State-Change Detector Arm | CALL:CONNected:ARM[:IMMediate]
Call-State-Change Detector Timeout | CALL:CONNected:TIMeout

  • Call-Connected-State Query

    The CALL:CONN? query allows the control program to determine if a call is in the connected state or in the idle state.

    Responses Returned by the CALL:CONN? Query
    Response | Meaning
    1 | The call is in the connected state.
    0 | The call is in the idle state.

    If the call is in one of the transitory states, the query waits until the call reaches the idle state or connected state before returning a value.

  • Call-State-Change Detector Arm Command

    The test set has a call-state-change detector which can be used to temporarily hold the response to a CALL:CONN? query until the call state has moved from idle to connected or vice versa.

    Without the call-state-change detector, the CALL:CONN? query only hangs if the call is in a transitory state. Otherwise, it immediately returns a 1 or 0. Therefore, if a call connection process is started and the CALL:CONN? query is sent before the call state has transitioned from idle to one of the transitory states, the query immediately returns a 0. This indicates that the call is in the idle state (and therefore that the connection attempt failed). In reality, the call likely connected, but not until after the CALL:CONN? query immediately returned a 0.

    When the call-state-change detector is armed during a connection attempt, if the CALL:CONN? query is sent while the call state is still idle, the query waits until the state changes to connected, and then returns a 1.

    The CALL:CONNected:ARM[:IMMediate] command is used to arm this call-state-change detector.

  • Call-State-Change Detector Timeout Command

    If the call-state-change detector is armed and a call connection is attempted but the call state never changes from the idle state, the CALL:CONN? query hangs the bus. This easily happens if the mobile is badly broken, the mobile is not connected to the test set, or no one pushes the send button on the mobile.

    The CALL:CONNected:TIMeout command is used to set the timeout value for the call-state-change detector.

    The timeout timer is started whenever the call-state-change detector is armed, and should be set to the maximum amount of time the control program should wait between arming the detector and the beginning of the connection process (when the call state moves from the idle state). If the timer expires before the call state has moved from the idle or connected state, the call-state-change detector is disarmed, which releases the CALL:CONN? query if it is currently hanging.

Process for Making a Base Station Originated Call

Process for Making a Base Station Originated Call

NOTE
It is not necessary for you to send the CALL:CONN:TIM and CALL:CONN:ARM commands as they are automatically sent by the test set during a base station originated call or base station release.

Programming Example

OUTPUT Test_set;"CALL:PAG:PNUM `0000574016'"! Set paging number
OUTPUT Test_set;"CALL:PAG:REP ON" ! Set paging repeat state
OUTPUT Test_set;"CALL:ORIG" ! Start a base station originated call
OUTPUT Test_set;"CALL:CONN?"  ! Hanging GPIB query
ENTER Test_set;Call_connected      ! Program hangs here until
                                   ! origination passes or fails
IF NOT Call_connected THEN
   OUTPUT Test_set;"CALL:END"
! <put error handler here>
END IF
! Call is connected so proceed with control program

Process for Making a Mobile Station Originated Call

Process for Making a Mobile Station Originated Call

NOTE
The test set cannot originate a call from the mobile station. You must physically dial a number on the mobile station and press send, or send commands to a test bus built into the mobile station. For mobile station originated calls where the call is originated by physically dialing a number (as opposed to using a test bus) ensure that the call-state-change detector timeout time is long enough to allow the number to be dialed.

Programming Example

OUTPUT Test_set;"CALL:CONN:TIM 10"         ! Set timeout time to 10 seconds
OUTPUT Test_set;"CALL:CONN:ARM"            ! Arm the change detector
DISP "Initiate a call from the mobile"
OUTPUT Test_set;"CALL:CONN?"          ! Initiate a call connected state query
ENTER Test_set;Call_connected              ! Program hangs here until
                                           ! origination passes or fails
IF NOT Call_connected THEN
   OUTPUT Test_set;"CALL:END"
! <put error handler here>
END IF
! Call is connected.  Proceed with the control program.

Make a Test Mode Connection

To make a connection between the test set and mobile station in test mode, you must send the appropriate test mode commands to the mobile station to command it to synchronize to the test set's signal and begin transmitting.

You may also want to make a quick power measurement to ensure that the connection has been made.


Step 5: INITiate and FETCh Measurements

Step 5: INITiate and FETCh Measurements

The following information provides additional details on Step 5 of the Programming Flowchart. This information is applicable to all test applications.

Description

This step involves making measurements on the mobile station.

The test set has multiple signal paths and processors, which means you can make measurements concurrently and reduce test time. Making concurrent measurements involves starting a group of measurements, fetching the results of the measurements as they complete, and then verifying that the results are valid.

In this step you may also choose to make measurements in a more sequential way.

Contents

  • Concurrent Measurement Process
  • Alternative Measurement Process

Concurrent Measurement Process

Process for Making Concurrent Measurements

Start a Set of Concurrent Measurements

The INITiate command is used to start measurements. Each individual measurement can be started using the INITiate command. For starting measurements, the syntax of the INITiate command is as follows:

INITiate:<measurement mnemonic>[:ON]

More than one measurement can be started using a single INITiate command. For example:

OUTPUT Test_set;"INIT:TXP;PFER"

starts the transmit power measurement and the phase and frequency error measurement. These measurements then run concurrently.

Determine if a Measurement Is Done

Use the INITiate:DONE? query command to determine which measurement has completed.

This command is a query only and returns only one response per query. The responses returned and their meanings are shown in the following table:

Responses Returned from INITiate:DONE? Query
Response String | Meaning
<MEASUREMENT1 mnemonic> | MEASUREMENT1 is done.
<MEASUREMENT2 mnemonic> | MEASUREMENT2 is done.
WAIT | There are one or more measurements that are in progress, but none of those measurements are done yet.
NONE | No measurements are in progress.
Responses Returned from INITiate:DONE? Query
Response String | Meaning
<MEASUREMENT1 mnemonic> | MEASUREMENT1 is done.
<MEASUREMENT2 mnemonic> | MEASUREMENT2 is done.
WAIT | There are one or more measurements that are in progress, but none of those measurements are done yet.
NONE | No measurements are in progress.

Once a measurement is reported as being complete via the INITiate:DONE? query it is removed from the done list (it is not reported again). To use the INITiate:DONE? query properly, your control program should immediately fetch a measurement's results once it is reported as being complete.

Obtain a Set of Measurement Results

In order to minimize bus traffic and reduce test time, the test set's measurements are designed to return multiple measured values in response to a single measurement request.

For example, if a transmit power measurement with averaging is initiated there are five measurement results available. These are:

  1. Measurement integrity value
  2. Average value
  3. Minimum value
  4. Maximum value
  5. Standard deviation value

The test set can return the measurement results in a variety of formats to suit your needs using the FETCh? subsystem. The general structure of the FETCh? command is as follows:

FETCh:<measurement mnemonic>:<result format>?

For example, the transmitter power measurement results can be returned as:

Example FETCh? Result Formats
Command | Results Returned
FETC:TXP? | Measurement integrity and average value
FETC:TXP:POW:ALL? | Minimum, maximum, average and standard deviation values
FETC:TXP:POW:AVER? | Average value only
FETC:TXP:POW:MIN? | Minimum value only
FETC:TXP:POW:MAX? | Maximum value only
FETC:TXP:POW:SDEV? | Standard deviation value only
FETC:TXP:INT? | Measurement integrity value only
Concurrent Measurement Process Programming Example

! Start a Set of Concurrent Measurements:
!
OUTPUT Test_set;"INIT:TXP;PFER"
!
! Determine if a Measurement Is Done:
!
LOOP
  OUTPUT Test_set;"INIT:DONE?"
  ENTER Test_set;Meas_done$
!
! Obtain a Set of Measurement Results:
!
  SELECT Meas_done$
    CASE "TXP"
      OUTPUT Test_set;"FETC:TXP:POW?"
      ENTER Test_set;Avg_tx_power
    CASE "PFER"
      OUTPUT Test_set;"FETC:PFER:RMS?"
      ENTER Test_set;Max_rms_phas_er
  END SELECT
EXIT IF Meas_done$="NONE"
END LOOP

Validate Measurement Results

Validating measurement results is extremely important. The test set returns a result if it is capable of making a measurement, even if this result is obtained under adverse conditions.

The measurement integrity indicator is a measurement result and therefore is queried using the FETCh subsystem. A value of 0 indicates that the measurement is valid. A value other than 0 indicates that an error occurred during the measurement process.

Example Integrity Indicators
Value Returned | Description (message also appears on test set)
0 | Normal
1 | No Result Available
2 | Measurement Timeout
5 | Over Range
6 | Under Range
Programming Example

OUTPUT Test_set;"FETC:DTXP?"
ENTER Test_set;Integrity,Avg_dig_pow
IF Integrity=0 THEN
   PRINT "AVG DIG POW= ";Avg_dig_pow
ELSE
   PRINT "DTXP Measurement Error"
   PRINT "DTXP Measurement Integrity is ";Integrity
END IF

Alternative Measurement Process

You may choose to test in a sequential way rather than use the concurrent measurement process.

For instance, instead of using the INIT:DONE? query to determine when a measurement is complete, you may choose to initiate a set of measurements and then simply fetch them sequentially.

Programming Example

OUTPUT Test_set; "INIT:DTXP;MACC"
OUTPUT Test_set; "FETC:DTXP:POW?"
ENTER Test_set;Avg_dig_pow
OUTPUT Test_set; "FETC:MACC:EVM[1]?"
ENTER Test_set;Max_EVM1

In this example, the test set starts both measurements at the same time. However, if the MACC measurement finishes first, the results are not fetched until the DTXP measurement finishes. Therefore, this process requires that you understand the order in which measurements will complete in order to optimize your testing speed.


Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Last updated: July 25, 2008

The following information provides additional details on Step 6 of the Programming Flowchart. This information is applicable to all test applications.

Description

After performing a set of measurements on the mobile station using the configuration established in step 2, you may want to change this configuration and test the mobile station again. This step involves changing testing conditions such as channel, mobile station transmit power level, or cell power.

Contents

  • Change Channels
  • Change Other Connection Parameters

Change Channels

In a manufacturing environment it is common to test a mobile station on more than one channel. Some or all of the tests may be performed on multiple channels, to verify the mobile station's performance in a range of operating frequencies.

Perform a Handoff (Handover) in Active Cell Mode

If you are operating in active cell mode, to change channels you perform a handoff (handover) to the new channel. The control program sends the commands to initiate the handoff (handover), and then determines whether the transition was successfully completed. This is accomplished using the CALL:STATus? query.

The CALL:STATus? query immediately returns the state of the call at the time the query is received.

Example Responses Returned from the CALL:STAT? Query
Response | Meaning
IDLE | The call is in the Idle state
ALER | The call is in the Alerting transitory state.
HAND | The call is in the Handoff transitory state.
PAG | The call is in the Paging transitory state.
CONN | The call is in the Connected state.

After issuing the commands to perform a handoff (handover), you should send the CALL:STAT? query to verify that the call is still connected before resuming testing.

Process for Performing a Handoff (Handover)

Test Mode Considerations

In test mode, you can either change the test set's frequencies by using the handoff (handover) commands, or directly control the RF generator and RF analyzer.

In either case, you must also send the appropriate test mode commands to the mobile station to move it to the new channel.

Change Other Connection Parameters

You may also choose to change the mobile station transmit power level or cell power, or other connection parameters such as timeslot or timing advance.


Step 7: End Connection

Step 7: End Connection

The following information provides additional details on Step 7 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you release the call (in active cell mode) or end the mobile station transmission (in test mode).

Contents

  • Release the Call in Active Cell Mode
  • End the Mobile Station Test Mode Transmission
  • Partially Preset the Test Set

Release the Call in Active Cell Mode

In active cell mode, you can release the call with the mobile station in one of two ways:

  • Release from the Base Station

  • Release from the Mobile Station

Releasing an Active Call from the Base Station

Process for Releasing an Active Call from the Base Station
Programming Example

OUTPUT Test_set;"CALL:END"        ! Initiate a base station release.
OUTPUT Test_set;"CALL:CONN?" 	 	! Send call connected state query.
ENTER Test_set;Call_connected     ! Program hangs here until state
                                  ! change or timer expires.
IF Call_connected THEN            ! Check if disconnection successful
! <put error handler here>
END IF
! Call is disconnected so proceed with control program

Releasing an Active Call from the Mobile Station

Process for Terminating an Active Call from the Mobile Station

NOTE
The test set cannot initiate a call disconnection from the mobile station. You must manually push the end button on the mobile station or send commands to a test bus built into the mobile station. For a mobile station release where the call is terminated by physically pushing a button on the phone (as opposed to using a test bus) ensure that the call-state-change-detector timeout time is long enough to allow the end button to be pushed.

Programming Example

OUTPUT Test_set;"CALL:CONN:TIM 5" !Set timeout time to 5 seconds.
OUTPUT Test_set;"CALL:CONN:ARM"   !Arm the change detector.
DISP "Terminate the call from the mobile station."
OUTPUT Test_set;"CALL:CONN?" !Initiate call connected state query.
ENTER Test_set;Call_connected     !Program hangs here until state
                                  !change or timer expires.
IF Call_connected THEN            !Check if disconnection successful.
! <put error handler here>
END IF
! Call is disconnected so proceed with control program

End the Mobile Station Test Mode Transmission

In test mode, you must send the necessary test mode commands to end the mobile station transmission.

Partially Preset the Test Set

At this point, it is good practice to partially preset the test set by sending the SYST:PRES3 command. This command stops all measurement and call processing processes, but does not reset all values to default.


gsm_136_fsta_prog_getting_started_flowchart

Programming: Getting Started Guide

Introduction

Last updated: July 25, 2008

The Getting Started Guide is organized around the basic set of tasks a control program normally performs when testing a mobile station in a manufacturing environment.

Click on any step in the flowchart below to learn more about how to program the Agilent Technologies 8960 to perform these tasks.

Programming Flowchart

  • Step 1: Set up the Test Set
  • Step 2: Configure Test Set and Mobile Station Parameters
  • Step 3: Set Measurement Parameters
  • Step 4: Make a Connection
  • Step 5: INITiate and FETCh Measurements
  • Step 6: Reconfigure Test Set and Mobile Station Connection Parameters
  • Step 7: End the Connection

You can also use the buttons on each page to navigate between steps, return to the flowchart, or to find more detailed information about each step.

How to use the programming flowchart for switching between formats

It is important for you to understand how to utilize the programming flowchart when designing a control program to switch between multiple formats. In steps 1, 2, and 3 of the programming flowchart, you set up the test set and configure parameters for each applicable format all at once. In contrast, you implement steps 4-7 for only one format at a time. Flowchart for the fast switching test application illustrates in greater detail how to perform these steps for each format. Example code for multiple formats is contained in steps 4-7 of this guide.

Flowchart for the fast switching test application

Conventions used in this Getting Started Guide

Throughout this Getting Started Guide the term "test set" refers to an Agilent Technologies 8960 Series 10 Wireless Communications Test Set with the E1985B GSM/GPRS_AMPS/136_WCDMA mobile test application installed.

The variable Testset used in the steps of the Getting Started Guide refers to the test set's GPIB address.

About the Programming Examples Presented in this Guide

Programming Language:

Programming examples presented in this guide are written in the HP BASIC programming language, also known as RMB or Rocky Mountain BASIC. The use of HP BASIC is not an endorsement of the HP BASIC product.

Line Numbers

All of the programming examples in the guide with line numbers are sections from a control program example available on-line for you to download.

Code that is not part of the download control program example does not have line numbers. This code may represent an alternate method of performing the task or may illustrate a feature not used by the control program example.

Syntax used in Programming Examples:

  • The programming examples use the shortened form of the command syntax to minimize GPIB bus transactions. The shortened form of a command is defined by use of capital letters in the command syntax. For the command syntax:

 RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO?

    the shortened form would be:

 RFAN:CONT:MEAS:FREQ:AUTO?
  • The programming examples do not include optional nodes. Optional nodes in the command syntax are defined by enclosing the node inside the [ ] brackets. For example, the command syntax:

 CALL[:CELL]:POWer[:SAMPlitude] -80dBm

    appears in the programming examples as:

 CALL:POW -80dBm

  • Programming examples make extensive use of compound commands using the ; and the ;: separators. Refer to the on-line information for the definition and use of these command separators.

Complex Commands

Complex commands are used to configure the state and assign values to parameters simultaneously. Complex commands can be used to save programming steps and minimize GPIB bus transactions.

  • The syntax below turns the state of the parameter on.

    OUTPUT Test_set;"SET:DTXP:TIM:STAT ON"

  • The syntax below is used to assign a value to the parameter.

    OUTPUT Test_set;"SET:DTXP:TIM:TIME 10 S"

  • Both of the above actions can be accomplished with one syntax command:

    OUTPUT Test_set;"SET:DTXP:TIM:STIM 10 S"

    The command above sets the parameter state to ON and the value of the parameter to 10 seconds. Note that in this example the optional command mnemonic :STIMe has been included to clarify that this complex command was used to set both the state and the value.

  • This command can be shortened further by removing the optional command mnemonic :STIMe, as shown below.

    OUTPUT Test_set;"SET:DTXP:TIM 10 S"

    This is the format that will be used throughout this guide.


Step 1: Set up the Test Set

Step 1: Set up the Test Set

This step explains how to:

  • Fully Preset the Test Set
  • Turn on the GPIB Debugger
  • Select the Active Format

Fully Preset the Test Set

To set up the test set, you begin by sending the *RST command. *RST is used to perform a full preset of the test set, returning it to a known state. *RST also sets all measurements to single trigger.

All measurement triggers are set to single in all the test formats supported by the test application when the *RST command is sent.

Turn on the GPIB Debugger

A useful tool that you may want to turn on at this time is the GPIB command debugger. While turned on, error messages containing debugging information appear on the test set's screen when the test set receives an unknown GPIB command. The information indicates what type of error was caused and where in the syntax the error occurred. Troubleshooting, like locating and fixing typing errors for example, becomes easier using the GPIB command debugger.

This command should be taken out of your code once development is completed. It does increase your test time. The SYST:COMM:GPIB:DEB:STAT ON command only assists you when debugging code.

Select the Active Format

The SYST:APPL:FORM command used in the diagram switches the test set to the correct format. This is a very fast switch because it occurs within the test application. Switches to other test applications use a different command and take much longer. Refer to user documentation on your CD-ROM or the Internet for more information about fast switching.


Step 2: Configure Test Set and Mobile Station Parameters

Step 2: Configure Test Set and Mobile Station Parameters

Many of the parameters configured in this step are being set to their default values. In a manufacturing environment it may be desirable to explicitly configure these parameters to ensure that the required settings have not been changed by someone setting a parameter's value through the test set's front panel. However, greater code efficiency can be achieved by not configuring them.

Configure test set and mobile station parameters

It is possible for you to configure the test set and mobile station parameters for all test formats supported by the test application at the beginning of your program. The following examples illustrate how to set up parameters for all available formats after having selected the GSM format as the active format in Step 1: Set up the Test Set .

  • Set up parameters for GSM
  • Set up parameters for AMPS/136
  • Set up parameters for GPRS

Set up parameters for GSM

Notice the use of the :GSM identifier appended to the CALL:POW:AMPL command. Identifiers are used with commands or queries that are shared by test formats. They enable you to send commands to an inactive test format. Therefore, it is not necessary to use the :GSM format identifier below because GSM is the active test format. It is included here to demonstrate the use of format identifiers.

670   OUTPUT Testset;"CALL:POW:AMPL:GSM ";Gsm_level
680   OUTPUT Testset;"CALL:BAND EGSM"
690   OUTPUT Testset;"CALL:TCH 5;BCH 32;:CALL:MS:TXL 0;TADV 0"

Set up parameters for AMPS/136

Notice the use of the format identifier appended to the CALL:POW:AMPL command. The format identifier for the AMPS/136 Mobile Test format is :TA136 . The format identifier for the digital system in AMPS/136 format is

:DIG136
. None of the other commands sent below require this format identifier because they are unique to the AMPS/136 test format.

720   OUTPUT Testset;"CALL:OPER:MODE CALL"
730   OUTPUT Testset;"CALL:POW:AMPL:TA136 ";Tdma_level
740   OUTPUT Testset;"CALL:DCCH 1013"
750   OUTPUT Testset;"CALL:SET:AVC 387"
760   OUTPUT Testset;"CALL:SET:DTC:BAND CELL"
770   OUTPUT Testset;"CALL:SET:DTC:CHAN:CELL 542"
780   OUTPUT Testset;"CALL:SET:DTC:CHAN:PCS 1000"
790   OUTPUT Testset;"CALL:TCH:TYPE DTC"
800   OUTPUT Testset;"CALL:SET:MS:ANAL:TXL 2"
810   OUTPUT Testset;"CALL:SET:MS:DIG:TXL:CELL 2"
820   OUTPUT Testset;"CALL:SET:MS:DIG:TXL:PCS 2"
830   ! Set up the AVC for the SINAD measurement.
840   ! Turn off the internal FM until connection is on an AVC.
850   OUTPUT Testset;"CALL:FM:INT:STAT OFF;DEV 8KHZ;FREQ 1004HZ"

Set up parameters for GPRS

GSM and GPRS share many parameters. You will see this again in Step 3: Set Measurement Parameters where many identifiers are used to set up GPRS measurement parameters while also setting up measurement parameters for GSM while GSM is the active format.

You can see the use of the format identifier for the GPRS Mobile Test format, :GPRS , in the following example code.

!  Configure GPRS parameters
OUTPUT Test_set;"CALL:BAND:GPRS PGSM"! Set broadcast band
OUTPUT Test_set;"CALL:POW:GPRS -80"! Set cell power to -80 dBm.
OUTPUT Test_set;"CALL:PDTCH 45"! Set packet data traffic channel
OUTPUT Test_set;"CALL:FUNC:DATA:TYPE BLER"! Data connection type
!
! Set Multi-slot Configuration to two downlinks and one uplink.
OUTPUT Test_set;"CALL:PDTCH:MSL:CONF D2U1"
OUTPUT Test_set;"CALL:PDTCH:CSCH CS4"! Set Coding Scheme to CS4
! Assign values to the power reduction levels
OUTPUT Test_set;"CALL:PDTCH:PZER:LEV 16" ! Assign a value to P0
OUTPUT Test_set;"CALL:PDTCH:PRED:LEV2 6" ! Set PRL2 to 6dB
! Assign power levels to the downlink bursts
OUTPUT Test_set;"CALL:PDTCH:PRED:BURS2 PRL2"
!
! Assign a power level to the uplink burst
OUTPUT Test_set;"CALL:PDTCH:MS:TXL:BURS 5"


Step 3: Set Measurement Parameters

Step 3: Set Measurement Parameters

  • Set trigger to single for all measurements
  • Set measurement parameters

Set trigger to single for all measurements

You can send either the *RST command, as discussed in Fully Preset the Test Set , or the following command to set the trigger to single for all measurements in all the test formats supported by the test application. In the example below, the command is commented out (by preceding it with an !) because in the control program example utilized throughout this guide, the *RST command is used, making the SET:CONT:OFF command unnecessary. If you choose to not send the *RST command, make sure to uncomment this line.

950   ! OUTPUT Testset;"SET:CONT:OFF"

Set measurement parameters

The most efficient use of a test application supporting multiple test formats is to complete measurement setups at times when the test system is doing something else. This example illustrates setting up measurement parameters for the test formats at the beginning of the program, presumably while a phone is being prepared for RF test.

For more information about the measurement parameters, refer to the additional details about this step available on your CD-ROM or the Internet.

  • Set GSM measurement parameters
  • Set AMPS/136 measurement parameters
  • Set GPRS measurement parameters

Set GSM measurement parameters

For more details about specific GSM measurement parameters, refer to the 8960 User Documentation for the GSM Mobile Test Application available on your CD-ROM or the Internet.

980   OUTPUT Testset;"SET:PFER:TIM 5;COUN 1"
990   OUTPUT Testset;"SET:PVT:TIM 5;COUN 10"
1000  OUTPUT Testset;"SET:PVT:TIME -28us,-10us,321.2us,552.8us,570.8us"
1010  OUTPUT Testset;"SET:ORFS:TIM 7;COUN:STAT OFF"
1020  !
1030  ! This example puts the switching and modulation offsets to be
1040  ! tested into string variables.  Mod$ contains the modulation
1050  ! offsets while Swit$ contains the switching offsets.
1060  Mod$="200KHZ,-200KHZ,400KHZ,-400KHZ"
1070  Swit$="400KHZ,-400KHZ,600KHZ,-600KHZ"
1080  OUTPUT Testset;"SET:ORFS:MOD:COUN 10;FREQ "&Mod$
1090  OUTPUT Testset;"SET:ORFS:SWIT:COUN 20;FREQ "&Swit$
1100  OUTPUT Testset;"SET:FBER:COUN 10000"

Set AMPS/136 measurement parameters

For more details about specific AMPS/136 measurement parameters, refer to the 8960 User Documentation for the AMPS/136 Mobile Test Application available on your CD-ROM or the Internet.

1140  ! Digital Measurement Parameters
1150  OUTPUT Testset;"SET:DTXP:TIM 3;COUN 10"
1160  OUTPUT Testset;"SET:MACC:TIM 3;COUN 1"
1170  OUTPUT Testset;"SET:MACC:EVM10:STAT ON"
1180  OUTPUT Testset;"SET:ACP:TIM 3;COUN 1"
1190  !
1200  ! Analog Measurement Parameters
1210  OUTPUT Testset;"SET:FST:TIM 3;COUN 1"
1220  OUTPUT Testset;"SET:ATXP:TIM 3;COUN 10"
1230  OUTPUT Testset;"SET:FM:TIM 3;COUN 1"
1240  OUTPUT Testset;"SET:FM:FREQ:STAT ON"
1250  OUTPUT Testset;"SET:FM:DIST:STAT ON;FREQ 6000"
1260  OUTPUT Testset;"SET:FM:DET PPE"
1270  OUTPUT Testset;"SET:FM:FILT:TBP 6000"
1280  OUTPUT Testset;"SET:FM:FILT TBP"
1290  !
1300  ! Audio Measurement Parameters
1310  OUTPUT Testset;"SET:AFAN:FREQ:STAT ON"
1320  OUTPUT Testset;"SET:AFAN:FILT CMES;TIM 3;COUN 5;PEAK:VOLT 1"
1330  OUTPUT Testset;"SET:AFAN:SDIS:STAT ON;FREQ 1004"

Set GPRS measurement parameters

For more details about specific GPRS measurement parameters, refer to the 8960 User Documentation for the GPRS Mobile Test Application available on your CD-ROM or the Internet.

! Configure ORFS Measurement
!
OUTPUT Test_set;"SET:ORFS:TIM:GPRS 20"! Set timeout time.
Swit$=".4MHZ,-.4MHZ,.6MHZ,-.6MHZ,1.2MHZ,-1.2MHZ,1.8MHZ,-1.8MHZ"
OUTPUT Test_set;"SET:ORFS:SWIT:COUN:GPRS 20"
OUTPUT Test_set;"SET:ORFS:SWIT:FREQ:GPRS "&Swit$
!
! Configure Power vs. Time Measurement for GSM and GPRS:
!
Pvt$="-28us,-10us,321.2us,552.8us,570.8us"
OUTPUT Test_set;"SET:PVT:TIM:GPRS 10"
OUTPUT Test_set;"SET:PVT:COUN:GPRS 5"
OUTPUT Test_set;"SET:PVT:TIME:GPRS "&Pvt$
!
! Configure Phase & Frequency Error Measurement for GSM and GPRS:
!
OUTPUT Test_set;"SET:PFER:COUN 10;TIM 5"
OUTPUT Test_set;"SET:PFER:TIM:GPRS 5"
OUTPUT Test_set;"SET:PFER:COUN:GPRS 10"
OUTPUT Test_set;"SET:PFER:SYNC MID;SYNC:GPRS MID"


Step 4: Make a Connection

Step 4: Make a Connection

For more information about various ways to make a connection with the mobile station, refer to the Programming: Getting Started Guide for the specific mobile test technologies.

In this control program example, a GSM call is established first. After you switch formats at the end of Step 7: End the Connection , it will again be necessary to establish a call. (See the fast switching test application flowchart, Flowchart for the fast switching test application to see the process for using multiple formats.) Following are code examples for making a connection in different formats.

  • Subroutine for making GSM and AMPS/136 connections
  • Make a GSM connection
  • Make an AMPS/136 connection

Subroutine for making GSM and AMPS/136 connections

A subroutine for making connections is used because this same code is used more than once. This provides greater code efficiency.

The code for the subroutine is below:

3870  SUB Orig_call(Format$)
3880    COM INTEGER Testset
3890    PRINT "Turn the ";Format$;" phone on now."
3900    PRINT "When the phone camps, press `F2' to continue."
3910    PAUSE
3920    CLEAR SCREEN
3930    PRINT "Originate a call on the ";Format$;" Mobile now."
3940    OUTPUT Testset;"CALL:CONN:TIM 10"
3950    OUTPUT Testset;"CALL:CONN:ARM"!Arm the Call-State-Change
3960                                  ! Detector
3970    OUTPUT Testset;"CALL:CONN?"!Query State
3980    ENTER Testset;Callstate
3990    IF NOT Callstate THEN
4000      Orig_failed
4010    END IF
4020  SUBEND

Make a GSM connection

The subroutine to establish the GSM connection is called using the code below.

1390  Orig_call("GSM") ! Subroutine for originating a call from the MS

Make an AMPS/136 connection

After performing all GSM measurements, ending the GSM connection, and switching the test set to the AMPS/136 format, you can establish an AMPS/136 connection by calling the subroutine again. See Flowchart for the fast switching test application illustrates this process for making use of the multiformat capability.

2020  Orig_call("AMPS/136")


Step 5: INITiate and FETCh Measurements

Step 5: INITiate and FETCh Measurements

This step explains how to:

  • INITiate a set of measurements
  • FETCh measurement results using a subroutine
  • Measurement Integrity Indicators

INITiate a set of measurements

The current active format is GSM. Therefore, GSM measurements are INITiated and FETChed first. Flowchart for the fast switching test application diagrams the process for using multiple formats.

  • INITiating GSM measurements
  • INITiating AMPS/136 measurements

INITiating GSM measurements

The example below illustrates how to start four GSM measurements running concurrently. The FBER (Fast Bit Error Rate) measurement is a receiver measurement. This makes use of the test set's ability to make transmitter and receiver measurements at the same time.

1510    OUTPUT Testset;"INIT:FBER;PFER;PVT;ORFS"

INITiating AMPS/136 measurements

The sections below contain examples illustrating how to start AMPS/136 digital and analog measurements.

Digital

2110    OUTPUT Testset;"CALL:MS:REP:MAHO ON"
2120    OUTPUT Testset;"CALL:POW:TA136 ";Maho_level
2130    OUTPUT Testset;"INIT:DTXP;MACC;ACP"

Analog

2410  OUTPUT Testset;"CALL:FM:INT:STATE ON"
2420  OUTPUT Testset;"CALL:POW ";Sinad_level
2430  OUTPUT Testset;"INIT:ATXP;FST;AFAN;FM"

FETCh measurement results using a subroutine

In a typical control program, measurements are repeated on various frequencies and power levels. Therefore, it is desirable to have a subroutine capable of fetching multiple measurement results. The example code below demonstrates how you might create a subroutine for fetching the measurement results. Refer to the additional details available on your CD-ROM or the Internet for more information about the different measurement results that are available and how to fetch them.

4100  SUB Fetch_results
4110    COM INTEGER Testset
4120    REPEAT
4130      OUTPUT Testset;"INIT:DONE?"
4140      ENTER Testset;Measdone$
4150      SELECT Measdone$
4160      CASE "DTXP"
4170        OUTPUT Testset;"FETC:DTXP?"
4180        ENTER Testset;Integrity,Power
4190        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4200        Print_results(Measdone$,Power)
4210      CASE "MACC"
4220        OUTPUT Testset;"FETC:MACC?"
4230        ENTER Testset;Integrity,Evm,Ferr,Ooff,Perr,Mag,Evm10
4240        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4250        Print_results(Measdone$,Evm,Ferr,Ooff,Perr,Mag,Evm10)
4260      CASE "ACP"
4270        OUTPUT Testset;"FETC:ACP?"
4280        ENTER Testset;Integrity,Adjl,Adjh,Alt1l,Alt1h,Alt2l,Alt2h
4290        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4300        Print_results(Measdone$,Adjl,Adjh,Alt1l,Alt1h,Alt2l,Alt2h)
4310      CASE "ATXP"
4320        OUTPUT Testset;"FETC:ATXP?"
4330        ENTER Testset;Integrity,Power
4340        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4350        Print_results(Measdone$,Power)
4360      CASE "FST"
4370        OUTPUT Testset;"FETC:FST?"
4380        ENTER Testset;Integrity,Ferr,Freq
4390        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4400        Print_results(Measdone$,Ferr,Freq)
4410      CASE "AFAN"
4420        OUTPUT Testset;"FETC:AFAN?"
4430        ENTER Testset;Integrity,Level,Sinad,Dist
4440        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4450        OUTPUT Testset;"FETC:AFAN:FREQ?"
4460        ENTER Testset;Freq
4470        Print_results(Measdone$,Level,Dist,Sinad,Freq)
4480      CASE "FM"
4490        OUTPUT Testset;"FETC:FM?"
4500        ENTER Testset;Integrity,Dev,Dist,Freq
4510        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4520        Print_results(Measdone$,Dev,Dist,Freq)
4530      CASE "PVT"
4540        OUTPUT Testset;"FETC:PVT?"
4550        ENTER Testset;Integrity,Mask,Power,Pvt1,Pvt2,Pvt3,Pvt4,Pvt5
4560        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4570        Print_results(Measdone$,Mask,Power,Pvt1,Pvt2,Pvt3,Pvt4,Pvt5)
4580      CASE "PFER"
4590        OUTPUT Testset;"FETC:PFER?"
4600        ENTER Testset;Integrity,Rmsperr,Peakperr,Ferr
4610        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4620        Print_results(Measdone$,Rmsperr,Peakperr,Ferr)
4630      CASE "ORFS"
4640        OUTPUT Testset;"FETC:ORFS:INT?"
4650        ENTER Testset;Integrity
4660        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4670        OUTPUT Testset;"FETC:ORFS:SWIT?"
4680        ENTER Testset;S1,S2,S3,S4
4690        OUTPUT Testset;"FETC:ORFS:MOD?"
4700        ENTER Testset;Pow_30khz,M1,M2,M3,M4
4710        Print_results(Measdone$,S1,S2,S3,S4,M1,M2,M3,M4,Pow_30khz)
4720      CASE "FBER"
4730        OUTPUT Testset;"FETC:FBER:INT?;RAT?"
4740        ENTER Testset;Integrity,Fber
4750        IF Integrity<>0 THEN CALL Bad_integrity(Integrity,Measdone$)
4760        Print_results(Measdone$,Fber)
4770      END SELECT
4780    UNTIL Measdone$="NONE"
4790  SUBEND

Measurement Integrity Indicators

When the test set performs a measurement, it always returns a measurement result even when the measurement was made under adverse conditions. Therefore, you should check the measurement integrity indicator value to ensure it is zero. If the value is something other than zero, the returned measurement result is not valid. Refer to the user documentation on your CD-ROM or the Internet for more information about integrity indicators.

3380  SUB Bad_integrity(Integrity,Meas_name$)
3390    IF Integrity<>0 THEN
3400       PRINT "Warning: ";Meas_name$;" Integrity =";Integrity
3410    END IF
3420  SUBEND


Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Last updated: July 25, 2008

There are several ways you may want to reconfigure the connection parameters. For more information refer to the Programming: Getting Started Guide for the specific mobile test technologies.

The first active format in the control program example is GSM. Flowchart for the fast switching test application diagrams the process for using multiple formats.

Below are examples of reconfiguring parameters from the control program example for:

  • GSM
  • AMPS/136

GSM

Here, the GSM call is reconfigured to a new channel, a new mobile station transmit level, and a new band. The state of the call is checked after the reconfiguration to ensure the call is maintained.

1640      OUTPUT Testset;"CALL:TCH 25;:CALL:MS:TXL 0"
1650      OUTPUT Testset;"CALL:TCH:BAND DCS"
1660      OUTPUT Testset;"CALL:STAT?"
1670      ENTER Testset;Callstat$
1680      IF Callstat$<>"CONN" THEN Dropped_call

AMPS/136

The code below illustrates using a loop to reconfigure the connection first to a different band and then to an analog voice channel.

2220    IF I=1 THEN ! Just did TDMA 800, get ready for TDMA 1900
2230      OUTPUT Testset;"CALL:SET:DTC:BAND PCS"
2240      PRINT ""
2250      PRINT "TDMA PCS Results:"
2260    ELSE   ! Done doing TDMA 1900, get ready for Analog
2270      OUTPUT Testset;"CALL:TCH:TYPE AVC"
2280      PRINT ""
2290      PRINT "Analog Results:"
2300    END IF
2310    OUTPUT Testset;"CALL:HAND"
2320    OUTPUT Testset;"CALL:STAT?"
2330    ENTER Testset;Callstat$
2340    IF Callstat$<>"CONN" THEN Dropped_call
2350  NEXT I


Step 7: End the Connection

Step 7: End the Connection

  • End the connection for GSM and AMPS/136
  • Switch formats
  • Make a new connection

End the connection for GSM and AMPS/136

For more information about ways to end the connection with the mobile station, refer to the Programming: Getting Started Guide for the specific mobile technologies.

The example below illustrates how to end the connection from the test set. The commands needed to perform this function are the same for both GSM and AMPS/136 formats. They are different for other formats supported by the test application.

1780  OUTPUT Testset;"CALL:END"
1790  OUTPUT Testset;"CALL:CONN?"
1800  ENTER Testset;Callstate
1810  IF Callstate=1 THEN
1820    PRINT "Make sure the GSM phone has released the call."
1830    OUTPUT Testset;"SYST:PRES3"
1840  END IF

Switch formats

At this point in your control program, you can switch to a new format. The process for using multiple formats of the test application is diagramed in Flowchart for the fast switching test application . The example code below illustrates activating the AMPS/136 format.

1960  OUTPUT Testset;"SYST:APPL:FORM `AMPS/136'"

Similarly, to activate the GPRS format, use the following example code.

OUTPUT Test_set;"SYST:APPL:FORM `GPRS'"

Make a new connection

It is possible for you to begin testing in a new format immediately. All the set up has already been done. Testing can begin by repeating steps 4, 5, and 6 as illustrated in Flowchart for the fast switching test application . To establish the new connection, see Step 4: Make a Connection .


Control Program Examples

HP BASIC

For your convenience we have combined the programming examples shown in the Getting Started Guide into one program. This program, written using HP BASIC, is a fully functional control program using the fast switching test application to test the GSM and AMPS/136 features of a mobile station. You can use this control program as a starting point for developing your own programs. Click on the link below to view the program:

  • Control Program Example for GSM and AMPS/136 Multi-format Test


E6785A/B/C/D/E/T/U Fast Switching Lab Application Revision Information

E6785A/B/C/D/E/F/G/T/U Fast Switching Lab Application Revision Information

Last updated: May 21, 2008

This document describes features and functionality that are part of the Agilent Technologies GSM/GPRS_W-CDMA fast switching lab applications. This document contains the original features, as well as enhancements that have been added over time. For a description of the fast switching application (such as license information, etc.), see Fast Switching Description .

CAUTION
You may need to upgrade the hardware in your test set before installing the application firmware described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up.
  • The application may not run.
  • Some features in the application may be inaccessible, or may not perform to specifications.

To determine if a hardware upgrade is required for your testing needs, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Select the appropriate link below to view the required release:

  • U.00.37 Special Release - May 2008
  • E.00.39 Subscription Release - May 2008

U.00.37 Special Release - May 2008

This is a subscription release of the E6785U application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have current GSM/GPRS/EGPRS, W-CDMA/HSPA, cdma2000/IS-95/AMPS and 1xEV-DO Lab Application Annual Contracts to obtain this subscription release. Contact your Agilent Sales Representative for more information.

The E6785U can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Loading the E6785U onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6785U meets the E6785D measurement parametric specifications in a temperature range of 25 +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

This release has the equivalent features of the following lab applications:

  • E6701U GSM/GPRS Lab Application Revision U.00.32 (E6704A provides a license for enabling EGPRS in the E6701T)
  • E6703U W-CDMA Lab Application Revision U.00.31
  • E6706U 1xEV-DO Lab Application Revision U.00.44

This release of the fast switching lab application requires release A.07.50 or newer of the Wireless Protocol Advisor. This is available at:

http://www.agilent.com/find/wlcontract

Hardware Requirements

http://www.agilent.com/find/8960upgrades

E.00.39 Subscription Release - May 2008

This is a subscription release of the E6785E application. In order to provide early access to new features, this subscription release has been partially qualified. The new features present in this release have been bench-tested to verify their performance. The previously existing features in this release have undergone a shortened software qualification cycle to verify that they have not been negatively affected by the new features.

You must have current GSM/GPRS/EGPRS, W-CDMA/HSPA, cdma2000/IS-95/AMPS and 1xEV-DO Lab Application Annual Contracts to obtain this subscription release. Contact your Agilent Sales Representative for more information.

This release has the equivalent features of the following lab applications:

  • E6701F GSM/GPRS Lab Application Revision F.00.37 (E6704A provides a license for enabling EGPRS in the E6701E)
  • E6703E W-CDMA Lab Application Revision E.00.34
  • E6706B 1xEV-DO Lab Application Revision B.00.44

This release of the fast switching lab application requires release A.07.50 or newer of the Wireless Protocol Advisor. This is available at:

http://www.agilent.com/find/wlcontract

Hardware Requirement

http://www.agilent.com/find/8960upgrades

Known Issues

  • The test set incorrectly assigns itself two IP addresses based on the "LAN IP Address" setting in the test set - the IP address specified by the "LAN IP Address" setting and "LAN IP Address" + 1. Thus, the test set will respond to IP traffic directed to "LAN IP Address" and "LAN IP Address + 1". This may result in unexpected network behavior if another device on the network is also assigned to "LAN IP Address" + 1.

    Example:

    If you set LAN IP Address = 192.168.1.22, the Test Set will also respond to LAN IP Address = 192.168.1.23. This will result in unexpected network behavior if there is another device on your network set to LAN IP Address = 192.168.1.23.

    Workaround:

    Reserve both "LAN IP Address" and "LAN IP Address" + 1 for use by your test set:

    • Ensure that no other device on the network is assigned "LAN IP Address" + 1, including other test sets.
    • Ensure that the test set's other IP addresses, such as "DUT IP Address" and "LAN IP Address 2" are not set to "LAN IP Address" + 1.

_____________________________________________________________________________________________________