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SATAGG Electrical Compliance Test Application—At a Glance

The Agilent N5411B SATA6G automated compliance test application for
SATA (Serial ATA) provides a framework for using Agilent Infiniium
90000 Series oscilloscopes to perform compliance testing. The automated
test application guides you through the process of identifying the test
environment, selecting and configuring tests, making oscilloscope
connections, running tests, and evaluating the test results.

To use the automated test application, see:

e Chapter 1, “Installing the SATA6G Electrical Compliance Test
Application,” starting on page 7

¢ Chapter 2, “Preparing to Take Measurements,” starting on page 11

e Chapter 3, “Using the Electrical Compliance Test Application,” starting
on page 15

For advanced features, see:

e Chapter 4, “User Defined Add-Ins,” starting on page 57

e Chapter 5, “Controlling the Application via a Remote PC,” starting on
page 63

See Also For more information on performing SATA6G compliance tests, see:
e SATA-IO 6G PHY Specification.

* @ "Serial ATA International Organization web site".

For a printable version of this help file, see: ~ "Agilent N5411B SATA6G
Electrical Compliance Test Application Online Help".
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Installing the Software 8
Installing the License Key 9

If you purchased the N5411B SATAG6G Electrical Compliance Test
application separately from your oscilloscope, you need to install the
software and license key.
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1 Installing the SATAGG Electrical Compliance Test Application

Installing the Software

1 Make sure you have the required version of Infiniium oscilloscope
software:

a See the compliance test application release notes for the required
minimum version of software.

b To check the software version on the oscilloscope, choose Help>Ahout
Infiniium... from the main menu

2 Download the N5411B SATA6G Electrical Compliance Test application
from the Agilent website:

a Go to "http://www.agilent.com/find/scope-apps-sw", and navigate to
the N5411B SATAG6G Electrical Compliance Test application software
download.

b Then, follow the instructions to download and install the application
software.

8 Agilent N5411B SATAGG Electrical Compliance Test Application Online Help
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Installing the SATAGG Electrical Compliance Test Application 1

Installing the License Key

1 Request a license code from Agilent by following the instructions on the
Entitlement Certificate.

You will need the oscillocope's "Option ID Number", which you can find
in the Help>About Infiniium... dialog.

2 After you receive your license code from Agilent, choose Utilities>Install
Option License....

3 In the Install Option License dialog, enter your license code and click
Install License.

4 Click OK in the dialog that tells you to restart the Infiniium oscilloscope
application software to complete the license installation.

b Click Close to close the Install Option License dialog.
6 Choose File>Exit.

7 Restart the Infiniium oscilloscope application software to complete the
license installation.

Agilent N5411B SATAGG Electrical Compliance Test Application Online Help 9
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. Agilent N5411B SATAG6G Electrical Compliance Test Application
[ ) Online Help

.... ‘...2

.‘0‘. Preparing to Take Measurements
[
o Required Equipment and Software 12

Calibrating the Oscilloscope 13
Running the Automated Test Application on a Second Monitor 75

Before running the automated tests, you need to acquire the required
equipment and software, and you should calibrate the oscilloscope. After
the oscilloscope has been calibrated, you are ready to start the SATA6G
Electrical Compliance Test application and perform measurements.
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2

Preparing to Take Measurements

Required Equipment and Software

12

In order to run the SATA6G Electrical Compliance Test application, you
need the following equipment and software:

e The minimum version of Infiniium oscilloscope software described in
the compliance test application's release notes.

¢ The equipment and software listed in the data sheet's "Ordering
Information" section (see @ *~ "N5411B SATA 6 Gb/s Compliance Test
Software Data Sheet").

Licenses are also required for these software options:
N5400A EZJIT Plus Jitter Analysis Software Option.

E2688A Serial Data Analysis/Mask Testing with Clock Recovery
Software Option.

e Agilent also recommends using a second monitor (see page 75) to view
the automated test application.

* Before performing tests, calibrate the oscilloscope (see page 13).
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Preparing to Take Measurements 2

Calibrating the Oscilloscope

If you have not already calibrated the oscilloscope, see Appendix A,
“Calibrating the Oscilloscope,” starting on page 69.

If the ambient temperature changes more than 5 degrees Celsius from the calibration
temperature, internal calibration should be performed again. The delta between the
calibration temperature and the present operating temperature is shown in the
Utilities>Calibration menu.

If you switch cables between channels or other oscilloscopes, it is necessary to perform
cable and probe calibration again. Agilent recommends that, once calibration is performed,
you label the cables with the channel for which they were calibrated.

Agilent N5411B SATAGG Electrical Compliance Test Application Online Help 13



2  Preparing to Take Measurements
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This chapter shows how to use the SATA6G Electrical Compliance Test

application.
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Using the Electrical Compliance Test
Application

Starting the SATAGG Electrical Compliance Test Application 16
Creating or Opening a Test Project 19

Setting Up the Test Environment 20

Selecting Tests 25

Configuring Tests 28

Connecting the Oscilloscope to the DUT 30

Running Tests 31

Viewing Results 40

Viewing/Exporting/Printing the Report 50

Saving Test Projects 54
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Using the Electrical Compliance Test Application

Starting the SATAGG Electrical Compliance Test Application

16

1 From the Infiniium oscilloscope's main menu, choose Analyze>Automated
Test Apps>SATAGG Test.

Utilities Help
Math (FFT and more)...
Histogram...

Mask Test...

M1 Oscilloscope Tools...

Jitter...
Serial Data...

Automated Test Apps 4 SATAGG Test

The SATAG6G Electrical Compliance Test application window appears.

SATA6G Test -- SATA6G Device 1 EEX
File View Help
0=
Task Flow :I Set Up lSeIect Tests ] Configure ] Connect ] Run Tests ] Results ] Htrnl Repart: ]
Set Up SATABG Test Environment Setup
Device Under Test (DUT)
¢ Device Type: Generation: Interface:
* Drive (" Host @ Genl Genll O oGenIl &0 Om O ox
Select Tests
Device Identifier: User Description:
|(SELECT OR: TYPE) v | |isELECT OR TYPE) v | s

Comments:

Automation

Using Pulse Generator 511344

" ¥es % No

10

0 Tests  Follow instructions to describe your test environment Connection: UMKROWH

If SATAGG Test does not appear in the Automated Test Apps menu, the SATAG6G Electrical
Compliance Test application has not been installed (see Chapter 1, “Installing the SATA6G
Electrical Compliance Test Application,” starting on page 7).

The task flow pane and the tabs in the main pane, show the steps you
take when running the automated tests:

Agilent N5411B SATAGG Electrical Compliance Test Application Online Help



Using the Electrical Compliance Test Application

3

Set Up

Lets you identify the test environment.

Select Tests

Lets you select the tests you want to run. The tests are organized
hierarchically so you can select all tests in a group. After tests are run,
status indicators show which tests have passed, failed, or not been run,
and there are indicators for the test groups.

Configure

Lets you configure the test parameters (for example, test pattern
source).

Connect

Shows you how to connect the oscilloscope to the device under test for
the tests that are to be run.

Run Tests

Starts the automated tests. If the connections to the device under test
need to be changed while multiple tests are running, the tests pause,
show you how to change the connection, and wait for you to confirm
that the connections have been changed before continuing.

Results

Contains more detailed information about the tests that have been run.
You can change the thresholds at which marginal or critical warnings
appear.

Html Report

Shows a compliance test report that can be printed.

See Also * "To view/minimize the task flow pane" on page 17

* "To view/hide the toolbar" on page 18

Next < "Creating or Opening a Test Project" on page 19

To view/minimize the task flow pane

* To toggle between a minimized and restored task flow pane, choose
View>Task Flow from the menu.

* To minimize the task flow pane, click the minimize button in the pane.

Task Flow : I

e To restore a minimized task flow pane, click the Task Flow button in the

pane.

MO ysEL

Agilent N5411B SATAG6G Electrical Compliance Test Application Online Help
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3 Using the Electrical Compliance Test Application

To view/hide the toolbar

e To toggle between a hidden and visible toolbar, choose View>Toolbar
from the menu.

18 Agilent N5411B SATAGG Electrical Compliance Test Application Online Help



Using the Electrical Compliance Test Application 3

Creating or Opening a Test Project

To create a new test project:

1 Choose File>New Project... from the menu.

A new, empty project, with all the default settings is created.
To open an existing test project:
1 Choose File>0pen Project... from the menu.

2 In the Open dialog, browse to a test project directory and select the
desired ".proj" file.

3 Click Open.
See Also

"To set load preferences" on page 19

Next < "Setting Up the Test Environment" on page 20

To set load preferences

1 From the SATA6G Electrical Compliance Test application's menu, choose
View>Preferences....

2 In the Preferences dialog, select the Save/Load tab.

Preferences

Display] Remote] Report] Run  Save/Load l

‘when Loading a Project
¥ Restore saved test selection

Auto Recovery
Save AutoRecovery data:

{+ After each trial or permutation (increases runtime)

" Only at the end of a run

ok | cancel | |

3 In the Save/Load tab, you can choose to restore saved test selections
when loading a project.

4 Click Apply to save the changes and click OK to close the Preferences
dialog.

Agilent N5411B SATAGG Electrical Compliance Test Application Online Help 19



3 Using the Electrical Compliance Test Application

Setting Up the Test Environment

The environment setup affects the tests that can be selected later. Only tests that apply to
the specified setup will appear. Also, changing the environment setup when there are
existing test results will create a new test project.

b Click the SetUp tab, or click the SetUp box in the Task Flow pane.

SATA6G Test -- SATA6G Device 1 * EEX
File View Help
R " R
Task Flow _ l Select Tests ] Configure ] Conneck ] Run Tests ] Results ] Htrnl Repart: ]
Set Up SATABG Test Environment Setup
Device Under Test (DUT)
¢ Device Type: Generation: Interface:
@ Drive " Host T @enl O GenIl & GenIm i O -
Select Tests
Device Identifier: User Description:
|(SELECT OR: TYPE) v | |isELECT OR TYPE) v | s

Configure Caomments:

Connect

Automation

| Configure Devices. ..

Run Tests

E

Using Pulse Generator 511344
* ¥es " Mo

15 Tests

Follow instructions to describe your kest environment

Connection: UMKNCWH

6 Select the appropriate Device Typewhich identifies a drive or host device.

10

1"

Select the appropriate Generation:
Gen | — identifies a 1.5 Gbps rate.
Gen Il — identifies a 3.0 Gbps rate.
Gen lll — identifies a 6.0 Gbps rate.
Select the appropriate Interface:
i — PC motherboard to device applications.
m — Short backplane and external desktop applications.
x — Long backplane and system-to-system applications.

If the device uses spread spectrum clocking, check SSC.

Select or type the appropriateDevice Identifier andUser Description, and

enter any desiredComments.

If an 81134A pulse pattern generator is required (for example, when

performing OOB tests or when it will be used as the test pattern source
with the device in Far End Retimed Loopback mode):

20
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Using the Electrical Compliance Test Application 3

These steps assume the oscilloscope and pulse pattern generator are already networked so
that the oscilloscope can remotely control the pulse pattern generator (over LAN, GPIB,
etc.). For more information, see the instruments' documentation.

a Select Yes under "Using Pulse Generator 81134A".

You must select Yes before the 00B tests can be selected.

b To enter the pulse pattern generator's network address, click
Configure Devices....

¢ In the Configure Devices dialog, enter the pulse pattern generator's
IP Address or SICL Address.

Configure Devices E]|§|E]

811344 Pulse Generatar l
Fulse Generator Address
* |P Address |141.183.191.234 ™ SICL Address |
Get [DN...
Fulse Generator Calibration
s
QOSCILLOSCOFPE
211344 Trigzer
CH1 CH2 CH4 CH2 CH1 O
9 PP PO
Calibrate Elapzed: 00:02:13
Saved Calibration Status: Success
Cloze

d Click GetIDN... to verify the pulse pattern generator's network
address.

e Click OK to close the verification message dialog.

f If running OOB Signal Detection Threshold is intended, click
Calibrate to calibrate the 81134A voltage values for this test group.

g Click Close to close the Configure Devices dialog.

h If the pulse pattern generator has not already been set up in the
Agilent 10 Libraries configuration, follow the instructions in "To add
the pulse generator to the 10 Libraries configuration" on page 22.

Agilent N5411B SATAGG Electrical Compliance Test Application Online Help 21
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22

Using the Electrical Compliance Test Application

The automated test application will set up and control the pulse pattern

generator over the network.

Next < "Selecting Tests" on page 25

To add the pulse generator to the 10 Libraries configuration

The pulse pattern generator must be added to the 10 Libraries

configuration. For example, the following steps show how to do this when

both instruments are on a Local Area Network (LAN).

1 If the Agilent IO Libraries Control "IO"

choosing Start>All Programs>Agilent 10 Libraries>10 Control.

2 Right-click on the IO Libraries Control icon, and choose Run 10 Config.

Run YI5A Assistant
Run YiFind32 {debug utility)

Run I2 Config

Wigw Documentation »
Run Event Yiewer

Agilent YISA Options 3

Hide Agilent IO Libraries Control
Exit

About Agilent IO Libraries Controlm
L

3 In the Agilent 10 Libraries Configuration window, select the TCPIPO lan

configured interface; then, click Edit....

Agilent 10 Libraries Configuration - 10 Config

File Options Help

10 Config configures and edits Agilent 10 interfaces.
- To configure a new interface, select the interface in ‘Available Interface Types' and click 'Configure’
- To edit a configured interface, select the interface in 'Configured Interfaces' and click 'Edit'
- Ta automatically configure the interfaces identified with ™, click 'Auta Config!

Available Interface Types Configured Interfaces

WVISA Type  Interface Description WVISA Mame  SICL Mame

ASRAL “R%-232 COM Parts ~ ASRLT Cam1 * futo Config
ASRL IS4 LAN Client (e.g. E5S GFIB0 hpib?

GPIB *82350 PCI GFIB Card

GPIE 82341 154 GPIE Card Y LAN. Server 0K
GFIB 82357 UUSE to GFIB

GFIB Y154 LN Client [e.g. E58

GPIBYX  GPIBAXI Command Madu Help
TCRIP “LaM Client [LAM Instrume

UsSE “USE Instruments

LUSB 4154 LAN Client for USE

4 “E8431 IEEE-1394 to Wil

Intermal Instrument

nia LAM Server [PC as Server ¥

[ |

*MOTE: Auto Config will configure interfaces identified with an

Bemove

4 In the LAN Client dialog, click Edit VISA Config....

Agilent N5411B SATAGG Electrical Compliance Test Application Online Help
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Using the Electrical Compliance Test Application 3

LAN Client X

Guestions? Press the Help button below.
Recommended default values are shown.

SICL Interface Mame: [|ar,
WS4 Interface Mame: [TCPIPOD il
Cancel

Logical Unit: |30 il
Help
LAN Infinite Timeout: 120 Seconds

Clignt Timeout Delta: 25 Seconds Defaults

Connect Timeout: | 5000 Miliseconds

¥ LogEmors Edit ¥I54 Canfig...

Default Protocol
+ AUTO [automatically detect protocal)
" 111 [TCPAP Instrument Protocal]
" SICL-LAN

b In the "TCPIP devices" dialog, click Add device.

TCPIP devices 53

Manually configured devices on the TCRIPO interface:

Alias WISA Resource String e

[ o |
Cancel

Add device
T
[[Aonsrsseves |

[

6 In the "Add a TCPIP resource" dialog, enter the IP address of the
81134A pulse pattern generator, and enter a device name of "lan0";
then, click OK.

Add a TCPIP resource

Optional Aliaz Name: |TcpipDevice1 oK.

Machine Mame/IP Device Mame/Port # Cancel

TCPRIPO: |130.29.89.28 = lan0

Fiesulting %154 Resource Sting

<L

TCPIPO:130.29.69.28::1an0:INSTR Test

Agilent N5411B SATAGG Electrical Compliance Test Application Online Help 23
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Using the Electrical Compliance Test Application

7 Keep clicking 0K to close all the dialogs and the Agilent 10 Libraries
Configuration window.

8 To verify that the pulse pattern generator has been added to the 10
Libraries configuration, right-click on the IO Libraries Control icon, and

choose Run VISA Assistant.

Run YISA Assistant
Run YiFind32 {debug utility)
Fun IO Config

Wigw Documentation »
Run Event Yiewer
Agilent YISA Options 3

Hide Agilent IO Libraries Control
Exit
About Agilent IO Libraries Control

9 In the VISA Assistant window:
a Select the "TCPIPO:: ... ::lan0" device.

b Select the Formatted 1/0 tab.
Select the SCPI instrument language.

d Click the *IDN? query button.

The response should read "<Agilent Technologies, 81134A,

DEXXXXXXXX, Ver X.X.X" if the pulse pattern generator is connected.

U7 VISA Assistant -
File Edit WYiew Configure Help

?
=1~ TCPIPO
I TCPIPO:1130,29.60.28 | Instument Driver Farmatted 140 | Wermany 140 Attributes]
Tepiphevicel Clear Histoy | [~ Show C Cade
=1~ GPIBO e
GPIBD: 7 INSTR. »IDN? _ Device Clear_|
<Agilent Technologies, 811344, DE4280051 3, Ver 2.81 s
=} ASRLL Set Timeout
ASRL1GINSTR
Read STE
*RST
*TST?
SYST:ERR?
Enter String ta Print or Query: Instr. Lang,
j ™ Custam
" |EEE 488.2
wiPrintf | viScanf | willueryf | * SCPI
< | =
For Help, press F1 09:32:43

10 Choose File>Exit to close the VISA Assistant window.

Agilent N5411B SATAGG Electrical Compliance Test Application Online Help



Using the Electrical Compliance Test Application 3

Selecting Tests

1 Click the Select Tests tab, or click the Select Tests box in the Task Flow
pane.

2 Check the tests you want to run.

SATAGG Test -- SATA6G Device 1 *
File View Help

D | "»¥rE w |0
Task Flow _| SetUp #| Configure ] Conneck ] Run Tests ] Results ] Htrnl Repart:

( Tests

- © General Specifications

O Channel Speed, FBaud & Unit Interval
) Frequency Long-Term Stability

) Transmitted Signal Requirements
) T Differential Output Yoltage

O
a
O © 1% RisefFal Time
a
a
|

Set Up

Select Tests

O kskewTs, T Differential Skew
) Wem,acTy, T¥ AC Common Mode Voltage
0 Jitter

v

Configure

Connect

Test: {(None Selected)

Description: (Select a Single Test)
Run Tests

0

1 Tests  (Check the testis) vou would like to run Connection: UMKROWH

Some things to note:

Checking a parent node/group will check all available
sub- groups/tests.

Unchecking a parent node/group will uncheck all sub-groups/tests.
A parent node is checked if all subgroups are checked.

A parent node is unchecked if ANY subgroup is unchecked.

If a test has a non-range limit of 0, that is, value < 0, then the test application will provide a
nominal value. This nominal value produces a non-infinite margin and is used to declare the
100% margin point. The assigned nominal value can be viewed at the description pane.

Using the When you right-click in the test pane, it produces a pop-up menu
Right-Click containing some shortcuts for selecting and deselecting tests.
Pop-Up Menu

Agilent N5411B SATAGG Electrical Compliance Test Application Online Help 25



3 Using the Electrical Compliance Test Application

When Tests Have
Already Been Run

26

Uncheck All

Check All

Check This Branch Only
Run 4
Results 4

If tests have already been run, you see their status in the Select Tests tab.

SATAGG Test -- SATA6G Device 1 *
File View Help
0= DERE T | B

Task Flow _| Setip Select Tests lConFigure ] Connect ] Run Tests ] Results ] Htrnl Repart:

=] SATAGG Tests
- General Specifications
O channel Speed, FEaud & Unit Interval
] @ Spread Spectrum Clocking
/" Spread Spectrum Madulation Frequency
/" Spread Spectrum Madulation Deviation (Min)
/" Spread Spectrum Madulation Deviation (Max)
¢ Transmitted Signal Requirements
) T Differential Output Yoltage
) T¥ Rise/Fall Time
) tskewT, TX Differential Skew
) Wem,acTy, Tx AC Common Mode Yolkage
) Jitker

Set Up

Select Tests

Configure

i
ESRE e e N I |

Doooo

Connect

Test: {(None Selected)

Description: (Select a Single Test)
Run Tests

0

3 Tests  Check the test{s) you would like to run Connection: UMKROWH

The marks have the following meanings:

The test passed.

x The test failed.

The test has not been run, or no tests in the group have been run.

The test is currently running.

Some tests in the group have run and passed.

Some tests in the group have run and failed.

1 Some tests in the group have passed and some have failed; not all of the tests have
been run.

¢ Some tests in the group have passed and some have failed; all of the tests have run.

° All tests in the group have run and passed.

o All tests in the group have run and failed.
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Using the Electrical Compliance Test Application 3

Next < "Configuring Tests" on page 28
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3 Using the Electrical Compliance Test Application

Configuring Tests

1 Click the Configure tab, or click the Configure box in the Task Flow pane.
2 Select either Compliance Mode or Debug Mode.

Compliance Mode — chooses the configuration options necessary to
meet compliance.

Debug Mode — lets you modify configuration options. This can be
useful, for example, when investigating a test failure.

3 Select the bulleted item for the settings you want to configure; then,
select or enter your settings.

A description of the selected configuration item appears in the lower,
right part of the application window.

Note that you can also enter values in some of the drop-down selection
fields. Entered values are checked for validity.

SATA6G Test -- SATA6G Device 1 * EEX
File View Help
D | "W

TaskFlow | setUp ] Select Tests

» Compliance Mode ¢ Debug Mode

onnect ] Run Tests ] Resuls ] Heml Report ]

Set Up

=l SATARG Tests ~ | |Settings For: {(Nothing Selected)
@ Test Pattern Source Selection {vendaor £
@ Pause In Between Test (Do not pause b
Select Tests =+ O General Specifications
@ Channel Speed : Sample Size {100,(
=+ Transmitted Signal Requirements
=~ O T Differential Output Yoltage
@ Sample Size (5007}
=+ T¥ Rise/Fall Time
¢ @ Test Pattern Used for Risetime,
@ Sample Size (10,000}
=+ O tskewTy, T¥ Differential Skew
@ Sample Size (10,000}
= O Mem,acTy, T AC Common Mode Yo
@ Memory Depth (65536)

Run Tests =0 der
@ Target Data Lenath Used for 7.

Configure

Connect

< >
1 Tests  Configure options For the tests you checked Connection: UMKROWH
TIP A quick way to see the Debug Mode configuration option values that are used in the

Compliance Mode is to switch from Compliance Mode to Debug Mode.

TIP A quick way to reset all configuration options is to switch from Debug Mode to Compliance
Mode.

28 Agilent N5411B SATAGG Electrical Compliance Test Application Online Help



Using the Electrical Compliance Test Application 3

TIP A quick way to reset all configuration options and delete all test results is to create a new
project (see page 19). The new project will have default configuration options.

Next < "Connecting the Oscilloscope to the DUT" on page 30
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Connecting the Oscilloscope to the DUT

1 Click the Connect tab, or click the Connect box in the Task Flow pane.

2 Follow the displayed instructions for connecting the oscilloscope to the
device under test.

SATAGG Test -- SATA6G Device 1 *
File View Help
0= DEOE I

Set Up ] Select Tests ] Configure  “onnect ]Run Tests ] Resuls ] Heml Report
Instructions for Connection: SATAGG Test Connection

3 kests will -

Bo R Step 1of 1.

1 phyysical
sekup will be OSCILLOSCOFRE

used,

MO ysEL

_Follow t_hese CH1 CH3
instructions

to start
testing SATA TEST FIXTURE

00

Terminators DC Blockers

Run Tests

3 Tests  Follow instructions to connect the DUT, then press [Run] Connection: SATAGE Test Connectio

3 When connections to the device under test have been made, check the |
have completed these instructions box.

Next ¢ "Running Tests" on page 31
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Running Tests

You should allow the oscilloscope to warm-up at least 30 minutes before running any
measurement tests.

TIP It is a good idea to calibrate the oscilloscope at least once a year or when the Calibration
ATemp is greater than +5 °C. The Calibration ATemp is found in the Help>About Infiniium...
menu on the Infiniium oscilloscope.

The Run Tests tab's settings let you run the selected tests once or multiple
times. When you run tests multiple times, there are options for selecting
which trials are stored and how long tests are run.

To run the selected tests once:

1 Start the test run.

There are several ways to run selected tests:
Click RunTests in the Task Flow pane.
Click *“) in the toolbar.
Select a branch in the Select Tests tab; then, click | in the toolbar.

Select the Run Tests tab, make sure the Once "run until" option is
selected, and click the big Run button.

SATA6G Test -- SATA6G Device 1 *
File View Help
D | "W

Task Flow _| setup ] Select Tests | Configure | Connect Run Tests lResuIis ] Html Report]
3 tests selected to run.

SetUp

3 tests will be Store Mode

run.
During run, store details for|Worst | trials (up to 25)
1 physical setup

Select Tests vill be used. Run Until
Current Run tests m
Connection:
SATAGG Test [ Send email ™ Onevent

Connection
Configure

Connect

- Store: details for up to 25 worst trials {margin)
- Run tests: once
Run Tests

Hi080

3Tests |[Follow instructions to connect the DUT, then press [Run] Connection: SATAGG Test Connection
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For more information on additional run options, see:
"To select the "store mode™ on page 33
"To run multiple times" on page 34
"To send email on pauses or stops" on page 35
"To pause or stop on events" on page 35
"To specify the event" on page 36

2 If there are existing test results, you are asked if you would like to keep
them or re-test (delete) them.

If you would like to keep the existing test results to compare against
new results, select Append New "Trial" Results.

Select Replace the Existing Results if you would like to delete the existing
test results.

Existing Results for Selected Tests
Test Results already exist for the following tests:

Existing Results for Selected Tests

Test Mame

/ Spread Spectum Modulation Frequency
/ Spread Spectum Modulation D eviation [Min)
/ Spread Spectum Modulation D eviation [Max)]

" Replace the Existing Results
+ Append New "Trial" Results %

3 While the tests are running, status dialogs appear to inform you about
the test progress.

Verifying Scope Configuration...

Itern Result
¢ Connected To Scope ok
+¢ Can Communicate with Scope ok
+ Corect Response from Scope QK
+ Good Model Mumber ok
+ Infiniiumn 5 oftware Fevizion »= 560 ok
¢ Walid Option Licenses ok
¢ Good MCR Yersion ok
< | >
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Running Test 1 of 3, 1 Trials Remain
Current Test: Spread Spectrum Modulation Frequency

0of 3 Tests
Completed

Status: Performing Automated Step...

Progress:

4 When the tests are complete, click 0K.

SATA6G Test Information

1 ) All Tests Complete

See Also + "To set the display preferences" on page 37

* "To set the run preferences" on page 38

Next < "Viewing Results" on page 40

To select the "store mode"

When running tests multiple times, you can select which trials are stored.
1 Select the Run Tests tab.

2 In the Store Mode area, select:

SetUp ] Select Tests ] Configure ] Connect Run Tests lResuIis ] Hitml Report]
3 tests selected to run.

3 tests will be
run.

Store Mode

During run, store details for|Worst | trials (up to 25)
1 physical setup

will be used. Run Until

Current Run tests

Connection: Waorst

SATAGG Test [ Send email k ™ Onevent

Connection

Best — stores the results of the best N trials.

Event — stores the results of N trials in which the event is detected.
The event is determined in the Event area. See "To specify the event"
on page 36.
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Last — stores the results of the last N trials.

Worst — stores the results of the worst N trials.

Up to 25 trials can be stored.

If you change the Store Mode when test results exist, the existing results
will be deleted.

The Store Mode selection affects the trial display options in the Report tab
of the Preference dialog. See "To set trial display preferences" on page 48.

To run multiple times
The "run until" option lets you specify whether tests are run once or
multiple times.
1 Select the Run Tests tab.

2 In the Run Until area, select:

SetUp ] Select Tests ] Configure ] Connect Run Tests lResuIis ] Hitml Report]
3 tests selected to run.

3 tests will be Store Mode
run.
During run, store details for|Worst _« | trials (up to 25)
1 physical setup
will be used. Run Until

Current Run tests Once 4

Connection:

. |Forever
SATAGG Test [ Send email ™ Onevent

Connection Once

Forever — runs the tests repeatedly until you click the Cancel button.

N Times — runs the tests N times. When this option is selected, you

can specify the number of runs and whether pauses occur between
each run.

SetUp ] Select Tests ] Configure | Connect Run Tests lResuIis ] Hitml Report]
3 tests selected to run.

3 tests will be Store Mode

run.
During run, store details for|Worst _« | trials (up to 25)
1 physical setup

will be used. Run Until

Current Run tests > | Number of runs:|2 = ™ Pause
Connection:

SATAGG Test [ Send email ™ Onevent

Connection

Once — runs the tests only once. This is the default setting.

When multiple runs are selected, you can use the trial display options in
the Report tab of the Preference dialog to specify how many trials are
displayed in the test report. See "To set trial display preferences" on
page 48.
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To send email on pauses or stops

You can configure the test application to send email whenever a run
pauses or ends.

1
2
3

5

Select the Run Tests tab.
In the Run Until area, check Send email.
Click Configure.
In the Configure Email dialog, enter your To and From email addresses
and the hostname of the SMTP Server.
SetUp ] Select Tests ] Configure ] Connect Run Tests lResuIis ] Hitml Report]
3 tests selected to run.
3 tests will be Store Mode
run During run, store details for|Worst | trials (up to 25)
1 physical setup
will be used. Run Until
Current Run tests m
Connection:
SATAGG Test ¥ Send email ™ Onevent
Connection
Configure Email
‘when run is paused or ends, send notification email:
To: |me@MyCompany.com
From: |me@MyCompany.com
SMTP Server: |mai|server.MyCompany.com|
0K | Cancel |
Click OK.

Pauses can occur between runs when running a specific number of times
(see "To run multiple times" on page 34) or when pausing on an event (see
"To pause or stop on events" on page 35).

To pause or stop on events

You can set up test runs to pause or stop on events which are checked at
the end of each test.

Select the Run Tests tab.

1

2 In the Run Until area, check On event.

3 In the drop-down selection field that appears, select either:
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SetUp | Select Tests | Configure | Connect Run Tests lResuIis ] Hitml Report]
3 tests selected to run.

3 tests will be Store Mode

run.
During run, store details for|Worst _« | trials (up to 25)
1 physical setup

will be used. Run Until
Current Run tests Once 4
Connection:

SATAGG Test [ Send email ¥ Onevent |Jod -
Connection
Event Stop

|Fail e X

Pause — causes the run to pause when the event is detected.
Stop — cause the run to stop when the event is detected.
4 In the Event area, specify the type of event. See "To specify the event"
on page 36.

Pauses or stops can be set up to automatically send email (see "To send
email on pauses or stops" on page 35).

To specify the event

In the Store Mode area when you have selected Event (see "To select the
"store mode"" on page 33) or in the Run Until area when you have selected
to pause or stop on an event (see "To pause or stop on events" on
page 35), the Event area appears so that you can specify the event.

1 In the Event area, select the type of event:

SetUp ] Select Tests ] Configure ] Connect Run Tests lResuIis ] Hitml Report]
3 tests selected to run.

3 tests will be Store Mode

run.
During run, store details for|Worst _« | trials (up to 25)
1 physical setup

will be used. Run Until
Current Run tests Once 4
Connection:
SATAGG Test [~ send email ¥ Onevent |Stop -
Connection
Event
|Fail hd

Fail
~Pass

Fail — causes the event to fire when a prerequisite test or selected
test fails.

Margin <N — causes the event to fire when a test generates a
margin < specified. When this option is selected, enter the minimum
required margin percentage.

Pass — causes the event to fire when a test passes (excluding
prerequisite tests).
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A tilde "7" character in the event selection drop-down shows that the
event is unavailable. If you select an event type that is not available, a
dialog tells you why. For example, the Pass condition is only available
when the Store Mode is set to Best, Event, or Last. As such, the
condition appears as ~“Pass when the Store Mode is set to Worst.

To set the display preferences

Information, warning, and error conditions can occur while running tests.
The display preferences let you choose whether message dialogs are
shown. And, there are other display preferences that affect what happens
as tests are run.

1 From the SATA6G Electrical Compliance Test application's menu, choose
View>Preferences....

2 In the Preferences dialog, select the Display tab.

Preferences

Display l Remate ] Report ] Run ] Save/Load ]

Message Dizlogs

¥ Show information dialogs
¥ Show warning dialogs
Iv¥ Show error dialogs

™ Invert scope display for screen shots
(Won't invert if scope’s ColorGrade is enabled)
Iv¥ Keep application on top (Mid-run dialogs are always on top)

™ Log events (When directed by the Agilent support organization)

V¥ Show tooltips

3 In the Display tab, you can choose to show the following types of
message dialogs:

Information dialogs.
Warning dialogs.

Error dialogs.
Messages that require you to make a choice, such as "0K/Cancel" and "Yes/No" are

always enabled.

4 Also, you can choose to:
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Invert scope display — (white background) when the application
captures the screen shots. Note that no inversion takes place is the
oscilloscope's ColorGrade is enabled.

Keep application on top — Always keep the application's main dialog on
the top of the Infiniium application. Note that the mid-run dialogs
are always displayed on the top.

Log events — Use this option only when directed to by Agilent Support
(Note that this option degrades the runtime performance).

Show tooltips — By enabling this option, the tooltips appear as you
move the pointer over various controls in the application.

b Click Apply to save the changes and click OK to close the Preferences
dialog.

To set the run preferences

Information, warning, and error conditions can occur while running tests.
The display preferences let you choose whether message dialogs are
shown. And, there are other display preferences that affect what happens
as tests are run.

1 From the SATAG6G Electrical Compliance Test application's menu, choose
View>Preferences....

2 In the Preferences dialog, select the Run tab.

Preferences

Display] Remote] Repot Run ]Save;"Load]
Prompts
[v¥ Beep when user prompted
[v¥ Beep only during run

Test Abort Action

If 2 test aborts:
* Continue the run (problem descriptions may be viewed after the run ends)
" Stop the run and report the problem immediately

(Mote: The "Stop’ button is not affected by these settings )

Misc

Iv¥ Display Results tab at end of run

ok | cancel | |

3 In the Run tab, specify Prompts settings:

Beep when user prompted — causes the oscilloscope to beep when there
is prompt for user input.

Beep only during run — specifies that beeps only occur during runs.
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4 Specify Test Abort Action settings:

Continue the run — causes tests to continue running after a test
aborts. When this option is selected, you can view problem
descriptions after the run ends.

Stop the run — causes the run to stop after a test aborts, and the
problem is reported immediately.

Note that these settings do not affect the Stop button.

b Click Apply to save the changes and click OK to close the Preferences
dialog.
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Viewing Results

1 Click B in the toolbar, or click the Results tab.

40

SATAGG Test -- SATA6G Device 1 *
File View Help
O | '»2)E

* %

Task Flow _| SetUp ] Select Tests ] Configure ] Conneck ] Run Tests  Results lHtmI Repart: ]

Set Up Test Mame | ‘Warst Ackual | ‘warst Margin | Spec Range
/ Spread Spectrum Modulation Frequency 30,98kHz 32.8% 30.00kHz <= va
/ Spread Spectrum Modulation Deviation (Min) -2.528kpp...  49.5% -5.350kppm of F
/ Spread Spectrum Modulation Deviation {Max) 16ppmof ... 5.9% -5,350kppm of F
Select Tests
Configure ¢ S
¢ Details: Spread Spectrum Modulation Frequency
Surmmary /" Trial 1 (Worst) ] / Trial 4 ] / Trial 3 ] / Trials ] b L4
Connect ;riTlﬁ 50 | actual ... | margn [ sscoy... | ~
ailed:
Passed: 5 Mean  308%Hr 3311% 129
= Stgev  BdhdHr 281 7m¥ 447 2m
Worst Tria Bange 2120Mz  F0G7m¥ 1000
R e Traly M 3098kHr 3276% 1000
Max 3. 00kHz  3347% 1107
Sum 1R kHr  16EEE STO0
/Trial .. 30.98kHz  32.8% 10
Shawy trials JTrial4  30.99kHz  33.0% 10
Up to worst 25 /Trals  30.9%kHz  330% 1t
Modify. .. /Trial 5 31.00kHz 33.3% 10 w
v 1m PR - — s

3 Tests 3 results shown, [Himl Report] tab shows details Connection: UMKROWH

The Results tab contains three resizable panes for test results
information. If you select one of the tests in the top pane, details and
reference images (if any) are shown in the lower panes.

The summary of the test trial is displayed in the bottom left pane. It
also shows the Worst Trial (depending on your settings in the Store
Mode of the Run Tests tab).

The bottom right pane may have several tabs, depending on the selected
Report Preferences. If more than one trial is selected, then the first tab
will be the Summary tab. It shows the summary of all the test trials. A
maximum of 25 trials can be displayed at any one time.

If the worst first is selected as the trial display option, the Worst Trial
will be the next tab after the Summary tab, followed by other trials in
the order of trial performance.

The reference images will appear in the bottom right pane for the
selected trials. See "To show reference images and flash mask hits" on
page 46 for more details on reference images.
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SATAGG Test -- SATA6G Device 1 *
File View Help
O@ | '»2:r | X

Task Flow _| SetUp ] Select Tests ] Configure ] Conneck ] Run Tests  Results lHtmI Repart: ]

‘ Set Up Test Mame | ‘Warst Ackual | ‘warst Margin | Spec Range
/ Spread Spectrum Modulation Frequency 30,98kHz 32.8% 30.00kHz <=
/ Spread Spectrum Modulation Deviation (Min) -2.528kpp...  49.5% -5,350kppm o
/ Spread Spectrum Modulation Deviation {Max) 17ppmof ...  5.8% -5.350kppm o
Select Tests
< I »

Details: Spread Spectrum Modulati

Garllaue S.ummary /' Summary H / Trial 7 ] / Trial & ] / Trial 4
Tr'}?'ﬁ 7 Parameter | value F ce I
E:'s':e"jlo? Test Limits [30.00kHz to 33.0 |3P
' Parameter Tested Spread Spectrum o Clock Frequency
Connect Worsk Trial Vu . 30,98kHz
Trial 1 LErErenCec I
55C Cycles 10
Show trials
Fun Tests Up to warsk 25
Modify. .. < >
3 Tests 3 results shown, [Himl Report] tab shows details Connection: SATAGE Test Connectio

A quick way to reset all configuration options and delete all test results is to create a new

TIP . . . . ) .
project (see page 19). The new project will have default configuration options.
If a test has a non-range limit of 0, that is, value < 0, then the test application will provide a
nominal value. This nominal value produces a non-infinite margin and is used to declare the
100% margin point. The assigned nominal value can be viewed at the description pane.
SeeAlso * "To delete trials from the results" on page 41

Next

* "To show reference images and flash mask hits" on page 46
* "To change margin thresholds" on page 47
* "To change the test display order" on page 48

* "To set trial display preferences" on page 48

"Viewing/Exporting/Printing the Report" on page 50

To delete trials from the results

1 In the Results tab, choose one of these ways to delete a trial:

While a test result entry (at upper pane) or trial tab (at lower pane)
has input focus, either click on the toolbar 'delete' button or press
the delete key on the keyboard OR:
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SATA6G Test -- Project Samples

File View Help
0w H | '»'2»_5!‘|Xrﬂ96|
Task Flow _ Results
setwp | sekctDelate Selected Result(s)[® | i Report |
SetUp Test Mame | Worst Actual | Worst Mar A |
/ Channel Speed, FBaud & Unit Interval 166.5693ps 64% |
/ Frequency Long-Term Stahility -17ppm 47.6%
X ydiffTX, Minimum TX Differential Output Voltage 82mvy
Select Tests / VdiffTX, Maximum T¥ Differential Output Voltage 250mV 72.2%
/ TX Risetime 61.85ps 17.6%
X T¥ Falltime 71.74ps
X T Differential Skew HFTP 35.7ps el
Configure < 1 |
Details: Channel Speed, FBaud Unit Interval
—summary —— -/ Summary -/ Trial 1{(Warst) |
Connect T"i_3||5d: 3 Parameter | value |
E:;:eé-us Test Limits [166.5083ps to 157.5583ps]
: Parameter Tested Period of Unit Interval
Worst trial Actual Value 166.6693ps
Trial 1 Referenced Values:
HEVREES I;l Channel Speed -16ppm
o . |fBaud -16ppm
EraizEs f Baud in bps 5.999905000Gbps
Up to 1 trials
Worst first
| Modify...|
2 Tests |34 results shown, [Html Report] tab shows details |Connecﬁon: SATAGG Test Connection | él

° Another option is to right-click at a test result (at upper pane) and

select a trial or test to delete OR:

SATA6G Test -- Project Samples
File View Help
Do W &5 [ %K

Task Flow _| setUp I Select Tests I Configure I Connectl Run Tests Results |Hh11| Reportl

SetUp Test Mame | Worst Actual | Worst Mar A |
/ Channel Speed, FBaud & Unit Interval 166.6693ps 6.4% :l
/ Frequency Long-Term Stahility -17ppm 47.6%
X ydiffTX, Minimum TX Differential Output Voltage 82mvy

Select Tests / VdiffTX, Maximum T¥ Differential Output Voltage
vy time
XTxFaltime )} Delete One Trial...
X Txpifferenti palate Selected Test... | 3
|

250mY 72.2%

Configure <
[Details: TX Ris Delete All Tests...
frait]  yiew HTML Results. .
Parameter IRELE T
Test Limits [33.00ps to 68.00ps] TX Risetime Mode
Parameter Tested T¥ Risetime Mode
Actual Value 61.85ps

Referenced Values:

Test Pattern LFTP

Run Tests

2 Tests |34 results shown, [Html Report] tab shows details |Connecﬁon: SATAGG Test Connection | él

* Right-click inside the display area of trial summary tab (at the lower

pane):
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SATA6G Test -- Project Samples

File View Help
D@ M| &y [ % 0|
Task Flow | setUp I Select Tests I Configure I Connectl Run Tests Results |Hh11| Reportl
SetUp Test Mame | Worst Actual | Worst Mar A
/ Channel Speed, FBaud & Unit Interval 166.5693ps 6.4% |
/ Frequency Long-Term Stahility -17ppm 47.6%
X ydiffTX, Minimum TX Differential Output Voltage 82mvy
Select Tests / VdiffTX, Maximum T¥ Differential Output Voltage 250mV 72.2%
/ TX Risetime 61.85ps 17.6%
X T¥ Falltime 71.74ps
X T Differential Skew HFTP 35.7ps e |
Details: Channel Speed, FBaud Unit Interval
—Summary —— / Summary | / Trial 1 (Worst) |
Trials: 3 Trial Actual Value | Margin Channel Speed | f Baut A
Failed: 0 = = —
Passed: 3 = e o
— Delete One Trial
Worsttria Range G o =
=i Hin 166 7bs 6421%  -17.00pom .
Up to 1trials s == : -14 2
Worst first £ Trial 1 (Worst)  166.669305  6.4% -1600m -16p0r -~
Modify..| | # ]| S
2Tests |34 results shown. [Html Report] tab shows details Connection: SATAGG Test Connection él

2 Select the trial to delete:

f# Select Trial To Delete

EIBX

Flease select a single trial to delete:
Test Name | Trial # | Actual Value Margin | Channel Speed
[ Channel Speed, FBaud & Unit Interval 1 1666693E-10 64 Channel Speed =-16
Channel Speed, FBaud & Unit Interval 2 1666694E-10 64 Channel Speed =-16
[ Channel Speed, FBaud & Unit Interval 3 1.666695E-10 64 Channel Speed =-17
< 1]
ok | Cancel |

f_Baud

f_Baud =-16
f_Baud =-16
f_Baud =-17

Z|

3 If other tests have results that were generated during the same trial run
as the trial you are deleting, you will be asked if you wish to delete

these tests at the same time.

f# Select Trial To Delete

EIBX

The following results were generated during the same trial as the result you selected.
Check additional results to delete:
Test Name | Trial # | Actual Value | Margin | |
[ Channel Speed. FBaud & Unit Interval 2 1.666694E... 64 Channel Speed ... f_Baud =
[ Frequency Long-Term Stability 2 -16 477
£ 1l >
0K Cancel Select All
A
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The trial numbers of the affected results may not match. The application presents you with
those results that were generated during the same run. You can decide to delete those
other trials as well.

4 Once you have selected the trials to delete and clicked 0K, you get a
confirmation dialog:

SATA6G Test: Confirm result deletion

» | Delete the following results:
g
Channel Speed, FBaud & Unit Interval, Trial 2

Confirm?

5 The remaining trials are renumbered downwards to fill in the hole left
by the deleted trial:

SATA6G Test Information

For each test that lost a trial, any 'holes' created were filled by renumbering higher trials
down by 1.

For example, you start with these 3 trials:

Trial #1 (Actual Value = 100}

Trial #2 (Actual Value = 200}

Trial #3 (Actual Value = 300)

Then affter deleting Trial #2, Trial #3 gets renumbered:

Trial #1 (Actual Value = 100}
Trial #2 (Actual Value = 300)

6 If you delete the last remaining trial of a test, the entire test results are
removed:
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SATA6G Test -- Project Samples *
File View Help

D@ E| o | Xk

Task Flow _| setUp I Select Tests I Configure I Connectl Run Tests Results |Hh11| Reportl

Run Tests

-17ppm

SetUp Test Mame | Worst Actual | Worst Mar A |
/ Channel Speed, FBaud & Unit Interval 166.6695ps 6.4% :l
/ Frequency Long-Term Stahility -17ppm 47.6%
X ydiffTX, Minimum TX Differential Output Voltage 82mvy
Select Tests / VdiffTX, Maximum T¥ Differential Output Voltage 250mV 72.2%
/ TX Risetime 61.85ps 17.6%
X T¥ Falltime 71.74ps
X T Differential Skew HFTP 35.70s &)
Configure < 1 |
Details: Channel Speed, FBaud Unit Interval
/ Trial 1 |
Connect Parameter | Value |
Test Limits [166.56083ps to 167.5583ps]
Parameter Tested Period of Unit Interval
Actual Value 166.6695ps

£ Baud in bps 5.099358000Ghps | Delete This Trial...

)

2Tests 34 results shown. [Himl Report] tab shows details Connection: SATAGG Test Connection

Project Samples *

File View Help
D@ | &y [ % 0|
Task Flow | SetUp | Select Tests | Configure | Connect | RunTests Reslts | Heml Report |
SetUp Test Mame | Worst Actual | Worst Mar A |
/ Frequency Long-Term Stahility -17ppm 47.6% ;|
X ydiffT, Minimum TX Differential Output Voltage 32my
/ VdiffTX, Maximum T¥ Differential Output Voltage 250mV 72.2%
Select Tests /Tx Risetime 51.85ps 17.6%
X TX Falltime 71.74ps
X Tx Differential Skew HFTP 35.7ps
X Tx Differential Skew MFTP 31.0ps &)
Configure < 1 |
Details: (Select an individual result)
Run Tests
2Tests 33 results shown. [Himl Report] tab shows details Connection: SATAGG Test Connection él

NOTE: There are two situations in which you are not allowed to delete a trial:
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e (Case 1: The trial you attempt to delete is the last remaining extreme
trial but not the last remaining trial. In the SATA6G Electrical
Compliance Test application, the maximum number of trials displayed is
25. For example:

a Let's assume N is 25 (the maximum number of trials displayed).
b You have run more than N trials of a test.

¢ Now, you can delete up to N-1, where all these tests are displayed in
the individual result tabs. You will not be able to delete the last
remaining test displayed in the individual result tab or other
non-displayed tests; however, you can delete the entire test.

e (Case 2: The trial you attempt to delete is associated with a trial defined
in Case 1.

RefApp Test Error

This trial can not be deleted.

Reaszon: You cannot delete the last exdreme trial of a testwhen its statistics hold results for
maore than 1 trial.

To show reference images and flash mask hits

1 In the Results tab, click on an image in the Reference Images pane.

Reference Images:

smit Gap L.,

1ection: UNKMOWN

This opens the reference image dialog.
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In the reference image dialog, you can:
Click the J flash red pixels button to highlight the points of failure.
Click the @l z00m in or & zoom out buttons to resize the dialog.
2 Click the & close button to close the # Mask Failures dialog.

To change margin thresholds

1 From the SATAG6G Electrical Compliance Test application's menu, choose
View>Preferences....

Or, when viewing the Results tab, click Bl in the toolbar.
2 In the Preferences dialog, select the Report tab.

Preferences

Display] Remote Report lRun ] Save,-"Load]

Margin Reporting
[v¥ Enable Margin Highlighting

warnat (%) |G

20 = oo =
Test Display
Order tests: + Chronologically

" Same as 'Select Tests' tab
Trial Display

Show details for upto |1 Tl worst trial(s)

Order trial details:© Chronologically
(+ \norst first

[V Show images for up to 25 worst trial(s)

ok | cancel | |

3 In the Margin Reporting area, you can:

Enable or disable margin highlighting.
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Change the percent of margin at which to give warnings or critical
failures.

4 Click 0K to save your changes and close the Preferences dialog.

To change the test display order

1 From the SATA6G Electrical Compliance Test application's menu, choose
View>Preferences....

Or, when viewing the Results tab, click 1 in the toolbar.
2 In the Preferences dialog, select the Report tab.

Preferences

Display] Remote Report lRun ] Save,-"Load]

Margin Reporting
[v¥ Enable Margin Highlighting

vt ) | NN

20 = oo =
Test Display
Order tests: + Chronologically

" Same as 'Select Tests' tab

Trial Display
Show details for upto |1 Tl worst trial(s)

Order trial details:© Chronologically
(+ \norst first

[V Show images for up to 25 worst trial(s)

ok | cancel | |

3 In the TestDisplay area, you can:

Order tests chronologically or use the same ordering as in the Select
Tests tab.

4 Click OK to save your changes and close the Preferences dialog.

To set trial display preferences

1 From the SATAG6G Electrical Compliance Test application's menu, choose
View>Preferences....

Or, when viewing the Results tab, click | in the toolbar.
2 In the Preferences dialog, select the Report tab.
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Preferences

Display] Remote Report lRun ] Sa\re,-"Load]

Margin Reporting
[v¥ Enable Margin Highlighting

O
Test Display
Order tests: + Chronologically

" Same as 'Select Tests' tab

Trial Display
Show details for up to |1 =1 worst trial(s)

Order trial details: ¢ Chronologically
(+ \norst first

[V Show images for up to 25 worst trial(s)

ok | cancel | |

3 In the Trial Display area, you can:

Select the maximum number of trials, up to 25, whose details are
displayed at one time.

Order trial details chronologically or by "best", "worst", or "last" trial
first.

Specify whether screens captured during the run are displayed in the
Results tab.

Note that the "worst", "best", or "last" trials depends on the "store mode"
setting in the Run Tests tab. See "To select the "store mode™ on
page 33.

4 Click Apply to save the changes and click OK to close the Preferences
dialog.

These settings only affect the viewing of results and not their capture. Therefore, a change
can be made to either before or after running the tests.
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Viewing/Exporting/Printing the Report

e To view the HTML test report, click the Html Report tab.

SeeAlso -

Next

SATAGG Test -- SATA6G Device 1 *
File View Help
0= DEOE I

& &

Set Up ] Select Tests ] Configure ] Connect ] Run Tests ] Results Html Report l

MO ysEL

Agilent Technologies

SATA 6G Test Report
Overall Results:0 of 27 Tests Failed

Test Configuration Details
Device Description
Generation Gen ll
Interface i
Device Type
Test Session Details

01.40.0000P
Infiniium Model Humber DS0591204.2
Infiniium Serial Humber | hyv'47330004
Application SW Yersion 24599121
Last Test Date 15472008 2:35:45 AM

Drive

Infiniium SW Version

4 »

1 Tests  ViewSave/Print detailed HTML results, Connection: UMKROWH

"To export the report" on page 50
"To print the report" on page 53

e "Saving Test Projects" on page 54

To export the report

1

To export results
in CSV
(comma-separate
d values) format

50

From the SATAG6G Electrical Compliance Test application's menu, choose

File>Export Results> from the menu.

There are two options for exporting the HTML test report: CSV or

HTML.

Select the CSV option to export the results as a comma- separated list of
values.
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SATA6G Test -- Project Samples

File View Help
New Project...
Open Project...

ke
qure ] Connev:t] Run Tests ] Results Html Report l
mum TX Differential OQutput Voltage

Save Project
Save Project As...

Export Results I8
»

User Defined

inimum differential voltage [[TX+) - (TX-)] mes:

of section 7.2. This is measured at mated 5

HTML
‘mmrx Differential Output Voltage 22mv

Print...

Page Setup...

Print Preview...
Recent Projects 4

Exit
| ’— .mm TEyeTop

TopStdDev| 18m | [EyeTopMarker 37m| [EyeTop (S

[Ev StdDev 16m | [Ey Marker| -45m |

Save File As...

File name: |test

Location: |C:"-.D0c:uments and Settings"All Users'\Documents®Irfinium*Apps\SATAEGTe Browse...

File will be saved at C:\D and Al Users'D \nfiniiumiApps|SATABG Testitest cav
oK Cancel |

Z|

The data format is shown in the first line of the exported

*.csv file.

frest ID, Test Name, Measured Item, Trial 1 value,

Trial 2 Va1ue, Tr1a1 3 value

10131, "Channel Speed, FBaud & unit Interval”, channel Speed -1e","-16", " 17"
10131, "Channel Speed, FBaud & unit Interval"”,f_Baud,"-16","-16","-17"

10131, "Channel Speed, FBaud & unit Interval”,Actual value, “l 666693 10", "1.666694E-1
10131, "Channel Speed, FBaud & unit Interval"”,f_Baud in bps, '5999905000", "5999902000"
10131, "channel Speed, FBaud & unit Interval”, Marg1n 6.4 "Lre.4"

10231, "Freguency Long-Term Stability”,Aactual value,"-16", i 16“ 17"

10231, "Freguency Long-Term Stabi1ity“,Margin,“4?.?“,“4?.?“ "47.86"

20115, "vdiffTx, Minimum TX Differential output V01tage“,EyeT0pMean,“0.091“
20115, "vdiffTx, Minimum TX Differential output voltage",EyeTopstdDev, "0.018"
20115, "vdiffTx, Minimum TX Differential output voltage",actual value, "0.082"
20115, "vdiffTx, Minimum TX Differential output voltage",EyeTopMarker,"0.037"
20115, "vdiffT>, Minimum TX Differential output voltage",Margin, "-65.8"

20115, "vdiffTx, Minimum TX Differential output voltage",EyeTop, "(See image)”
20115, "vdiffTx, Minimum TX Differential output voltage",EyeBottomMean, "-0.094"
20115, "vdiffT>, Minimum TX Differential output voltage",EyeBottomstdDev, "0.016"
20115, "vdiffT, Minimum TX Differential output voltage",EyeBottomMarker, "-0.045"
20115, "vdiffT>, Minimum TX Differential output voltage",EyeBottom,”(See image)”
20125, "vdiffTx, Maximum TX Differential output voltage",Histogram Max, "0.122"
20125, "vdiffTx, Maximum TX Differential output voltage",Histogram Min,"-0.128"
20125, "vdiffTx, Maximum TX Differential output voltage",actual wvalue, "0.25"
20125, "vdiffTx, Maximum TX Differential output voltage",™margin,"72.2"

20214, "TX Risetime"”,Test Pattern, "LFTP"

20214, "TX Risetime"”, Actual value,"6.185e-11"
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To export the
report in HTML
format File View Help

New Project...
Open Project...

ke
qure ] Connect] Run Tests ] Results Html Report l
mum TX Differential OQutput Voltage

Save Project
Save Project As...

Export Results 4 C.S;u'r

User Defined s HTML » gle-File
Print TTVEfTEME — Multi-File

Page Setup... TopStdDev| 18m | [EyeTopMarker 37m| [EyeTop (S
Print Preview...

Recent Projects 4
Exit
| ]— TrarTEyeTop

There are two options for exporting HTML format test reports:

[iiin’l.n’ | voltage [(TX+]

-3

[Ev StdDev 16m | [Ey Marker| -45m |

» Single-File — To save a single-file report, use the "save as" type "Web
Archive, single file (.mht)".

SATA6G Test Information

i To create a single-file report that can be displayed on ancther computer,
select 'Save as type = Web Archive, single file (mht)' in the next Internet Explorer dialog.

Mote: Due to a .mht format limitation, single-file reports will not contain hyperlinks in the

summary table. To get hyperlinks, press cancel in the next dialog and choose option:
File->Export Results->HTML->Multi-File.

Single-file reports will not contain hyperlinks in the summary table (due to a .mht format
limitation). If you want these hyperlinks, use the multi-file format.

e Multi-File — If your report is large and you would like to use links
within the report, select the HTML>Multi-File option. Selecting the
multi-file option exports the results as a set of separate image and
HTML files. It creates a folder with the specified name that may be
copied to any computer.
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Save Report As IZIIEIFZI

Location: | \Documents and Settings"All Users'\Documents'Infinium"Apps \SATAGG Test Browse...

Report will be saved at C:\Documents and Settings'\All
Users\Documents!Infiniium\Apps'\SATABG Test\Project Samples
To view on ancther computer, copy the entire folder.

ok | cancel |

2|

To view the exported report, open the HTML file stored in the folder.

To print the report

e To preview the HTML test report printout, click R or choose File>Print
Preview... from the menu.

¢ To print the HTML test report, click 8l or choose File>Print... from the
menu.
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Saving Test Projects

To save test settings and results to the current project directory:

1 Choose File>Save Project from the menu.

To save test settings and results to a new project directory:

1 Choose File>Save Project As... from the menu.

Save Project As

Mame:  |SATABG_1
Location: |EI:\scope\apps\SATABGTest Browse... |
Project will be saved at C:hscopehappsh\SATABG T esthSATABG_1
(] 8 | Cancel |
A

2 In the Save Project As... dialog, enter the device name and location.

Project files will be saved in a directory whose name is the device
name.

3 Click OK.

See Also * "To set AutoRecovery preferences" on page 54

To set AutoRecovery preferences

1 From the SATAG6G Electrical Compliance Test application's menu, choose
View>Preferences....

2 In the Preferences dialog, select the Save/Load tab.
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Preferences

Display] Remote] Report] Run  Save/Load l

‘when Loading a Project
¥ Restore saved test selection

Auto Recovery
Save MutoRecovery data:
{+ After each trial or permutation (increases runtime)

" Only at the end of a run

ok | cancel | |

3 In the AutoRecovery area, you can choose:
To auto-save results after each trial or permutation even if the entire
multi- trial is not completed. This option enables full recovery.
To auto-save results only upon the completion of the entire
multi- trial.
4 Click Apply to save the changes and click OK to close the Preferences
dialog.
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To install an add-in 58
To remove an add-in 61

If there are measurements you would like the compliance test application
to make that are not currently included in its test list, you can use
Agilent's N56467A User Defined Application (UDA) tool to design and
deploy an "add-in", or package of tests that can be imported into existing

compliance applications. Please see the UDA documentation for how to
create an add-in.
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To install an add-in

To install an add-in:

1 Use the File menu:

FIEN View Tools Help

Mew Project, ..
Open Project.,.,

p lSeIect Tests ] Co

Save Project
Save Project As...

User Defined Install Add-In

Recent Projects 3

Exit

You will be prompted for the location of the add-in's installer (created
by the N5467A UDA tool):

Look, jn: |L'f)AddIns j = EB-
e Marme Size  Type
L\b' EfsetUpUda_addin My Add-In_v0.01.0001b.exe | 432KEB  Application
My Recent
Documents
?‘[‘:
Desktop

My Computer -
JCEE7EM

% < | >

My Nebwork File name: |SetUpUda_AddIn_My Add-n_v0.07.0001b.exe j Open |
Flaces
Filez of type: |User Defined Add-In Installers [Setupllda_sddin_" exe] j Cancel

and then reminded that the application will need to restart to complete
the installation:
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RefApp Test: Delete AllResults, Install Add-In And Exit?

P, The following actions will now occur:
3 1. ALL existing results for ALL tests will be deleted.
2. Thiz uzer defined add-in will be installed: SetUplda_Addin_ky Add-ln_+0.01.0001 b.exe
3. The application will exit without offering to restore the scope to itz last setup.
Proceed?

Mote: Chooze 'Cancel’ if you need to save existing test results.

Ok | Lancel |

If your project has unsaved test results, choose Cancel and save the project before
retrying.

RefApp Test Information

i User Defined Add-In installed successfully. The application will now close.

The Add-In will be loaded the next time you launch the application.

Restart the application, and you will receive a notice that there is an
active add-in:

RefApp Test Information

i Loaded User Defined Add-In:
hy Add-In, version 0.1.2

'Debug Mode' is now active.

Add-in tests are only visible in Debug Mode, so when there is an active
add-in installed, the compliance application will start up in this mode.

Add-in tests are displayed in their own test group on the Select Tests tab:
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(BETA VERSION 0.00.3892) RefApp Test -- Reference Device 1 *

File Wiew Tools Help
Ded|l Y2 |2 Ble @
SetUp  Select Tests |C0nfigure I Connect I Run Tests I Results I Htrnl Repart:

—
= Al Reference App Tests
i age Tests

Set Up

Select Tests

Test: {(None Selected)

Description: (Select a Single Test)
Limit: Set: Specification 1,00

A

&80 Connection: UNKNOWH

1 Tests |Check the testis) you would like to run
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To remove an add-in

To remove an add-in:

1 Use the File menu:

View Tools  Help

Mew Project, .. E ﬁ,l;;_ B o

Open Praject... y - =
Select Tests i

Save Project P l Configu

Save Project As... 1 AllReference App T

- [ O_Connection Pag

User Defined Uninstall Add-In...

Recent Projects 3

Exit

You will be reminded that the application will need to restart to
complete the installation:

RefApp Test: Delete All Results, Uninstall Add-In And Exit?

P, The following actions will now occur:
\--f/ 1. ALL existing results for ALL tests will be deleted.
2. The uzer defined add-in will be rermaoved.
3. The application will exit without offering to restore the scope to itz last setup.

Proceed?

Mote: Chooze 'Cancel’ if you need to save existing test results.

Ok | Lancel |

If your project has unsaved test results, choose Cancel and save the project before
retrying.
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'.‘. Controlling the Application via a

°. Remote PC

To check for the App Remote license 64
To identify the remote interface version 65
To enable the remote interface 66

To enable remote interface hints 67

If the oscilloscope has the App Remote license option installed (for the
Nb5452A remote interface), the SATA6G Electrical Compliance Test
application's Preference dialog will have a Remote tab for enabling the
remote interface and setting remote options.

The N5452A remote interface lets you control Infiniium compliance
applications from a remote PC. It comes with ready to run executables,
but it also lets you create custom programs using a .NET 2.0 programming
language or the National Instruments' LabVIEW 8.5 graphical programming
environment.

With the remote interface, you can:

e Launch and close applications.

e Configure options.

* Run tests.

* Obtain results.

e Control when and where dialogs are displayed.

e Save and load projects.

For more information on the remote interface, see the "N5452A Remote
Interface for Infiniium Compliance Applications" on the Agilent web site.
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b Controlling the Application via a Remote PC

To check for the App Remote license

1 From the Infiniium oscilloscope's main menu, choose Help>About
Infiniium.

2 In the license list, check for the App Remote license as shown below.

About Infiniium (UNRELEASED SOFTWARE) X

Model Number:  DSC90804A Close
J_I- Serial Number:  No Serial
‘ Copy To H Change Serial ‘

Clipboard Number...
SYSTEM CONFIGURATION
Software Revision: 02.96.8998
Firmware Revision: Main 208
Front Panel Revision: FPGA 2 PIC 4.59
Hard Disk Free Space: 40.93 GB
System Memory: 2.139 GB
Operating System: Microsoft Windows® XP
Option ID Number: 804ALAB
InfiniiScan ~
User Def Fn
’

PCT Express 2.0 Compliance
Gigabit Ethernet Compliance
10G Ethernet Compliance

CURRENT STATUS

5.2

Current Date: 14 SEP 2010 15:43:01
Internal Temp: 50 °C

Calibration Status: Calibrated

Calibration Date: 7 APR 2009 10:23:35
Self Test Status: Passed

Self Test Date: 10 NOV 2008 13:13:53

For product assistance and support see Technical
Support in the Help Contents Page.

Copyright © 2010 Agilent Technologies
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To identify the remote interface version

1 From the SATAG6G Electrical Compliance Test application's menu, choose
Help>About....

2 In the About dialog, the remote interface version is listed above other
version information.

r X

( Agilent Technologies

o

I L L T T 1, =y

JAltenatecNieSHENGine:

Agilent NS4TIB SATASG Test
(BETA) Version 1.29.9036

=

Remote Interface:  1.60 Add-In Interface:  1.00
Assemblies Loaded

mscorib 2.00.0000

Automated TestEngine 3.35.5045

(Swstem 2 (0 TWWM

< | [*
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To enable the remote interface

1 From the SATAG6G Electrical Compliance Test application's menu, choose
View>Preferences....

2 In the Preferences dialog, select the Remote tab.

Preferences

Display Remote l Report ] Run ] Save/Load ]

[v¥ Enable remote interface  (Version 1.60)
Remote Options

I~ Show remote interface hints:

Toolbar: Left-click to see hint.
Controls: Right-click to see hint.
Description panes: Hint appended to text.

Network Port Status
Primary port (9544):  Active
Alternate port (45544): Untried

ok | cancel | |

3 Check the Enable remote interface option if you need to access the
application remotely.

If you are performing the tests with the application's user interface and
want to ensure no remote users accidentally interfere with you, disable
the remote interface by un-checking this option.

4 Click Apply to save the changes and click OK to close the Preferences
dialog.
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To enable remote interface hints

1 From the SATAG6G Electrical Compliance Test application's menu, choose
View>Preferences....

2 In the Preferences dialog, select the Remote tab.

Preferences

Display Remote lReport] Run ] Save,-"Load]

¥ Enable remote interface  (Version 1.60)
Remote Options

¥ Show remote interface hints: | Arsl -
Toolbar: Left-click to see hinjllil
Controls: Right-click to see HCSharp k
Description panes: Hint appended to text.

Network Port Status

Primary port (9544):  Active

Alternate port (45544): Untried

oK | Cancel | apply |

3 In the remote options area, check Show remote interface hints.

When this option is checked:

You can select the remote programming language described in the
tips.

Tooltips related to the remote interface commands appear when you
click the toolbar.

Various controls in the tabs will have a context menu item added as
"Remote interface hint...".

The Select Tests and Configure tabs will display a remote hint in their
description panes at the bottom of the screen, when an item is
selected.

4 Click Apply to save the changes and click OK to close the Preferences
dialog.
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: Channel-to-Channel De-skew 70

This section describes oscilloscope calibration procedures.
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Calibrating the Oscilloscope

Channel-to-Channel De-skew

70

This procedure ensures that the timing skew errors between channel 1 and
channel 3 are minimized. In addition to the required equipment, you need:

e SMA T-adapter.

e Additional BNC to SMA male adapter (two precision 3.5 mm BNC to
SMA male adapters are provided with the oscilloscope).

To perform the channel-to-channel de-skew:

1 Connect the Channel 1 and Channel 3 SMA cables to the oscilloscope's
Aux Out:

Leave the RG-316 cables and SMA adapters on Channel 1 and
Channel 3.

Install a BNC to SMA male adapter on the oscilloscope Aux Out.

Connect the middle branch of the SMA T-adapter to the SMA
adapter on the Aux Out BNC.

Connect the far end of the cable from the Channel 1 SMA adapter, to
one branch of the SMA T-adapter on the Aux Out.

Connect the far end of the cable from the Channel 3 SMA adapter, to
the other branch of the SMA T-adapter on the Aux Out.

X BNC to SMA Male Adapter
Oscilloscope

SMA T-adapter
A

SMA Cable

Aux Ot
vy

SMA Cable

2 Set up the oscilloscope:

b

From the oscilloscope's main menu, choose File>Load>Setup....

In the Load Setup dialog, select the "INF_SMA_Deskew.set" setup file,
and click Load.
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File  Control Setup  Measure Analyze Ukilities Help Z:01 PM

Look in: | 9 setups

INF_SM#_Deskew.set
5 sebupl, set
My Recent setupl.set
Documents setup2 set
Frs sebupd.set
- setup4.set
Desktap setupS. set
sebupt, set
sebup?.set
MyD sebups.set
[y Documents sebupd.set

Flaces

2
My Network — File rame: [INF_5MA_Deskew | Load

Cancel

Filez of type: |Setup Files [*.zet]

Kepboard... |

If the setup file is not available, it can be created by following the
instructions in "INF_SMA_Deskew.set Setup File Details" on page 73.

3 Observe the channel-to-channel skew.

The oscilloscope display should look similar to the picture below. A
falling edge of the square wave is shown in a 200 ps/div horizontal
scale. The upper portion of the screen shows channel 1 (yellow trace)
and channel 3 (purple trace) superimposed on one another. The lower
portion of the screen is the differential signal (green trace) of channel 1
minus channel 3. The top two traces provide for visual inspection of
relative time skew between the two channels. The bottom trace provides
for visual presentation of unwanted differential mode signal resulted
from relative channel skew (and to a much lesser extent from other
inevitable channel mismatch parameters like gain and non-linearity).
The picture below is an example of exaggerated skew between channel 1
and channel 3, measured to be about 50 ps with the cursor.
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File  Control Setup  Measure Analyze Ukilities Help 2:07 PM

1] iGHz Standard BH @J
O N 0"

F ee=g

The following picture shows the desired effect of no skew between the
cables. Note that the channel 1 (yellow trace), channel 3 (purple trace)
traces overlap, and the differential signal (green trace) is flat. If this is
not the case, then perform the following steps to reduce the skew
between channels 1 and 3.

File  Control Setup  Measure Analyze Ukilities Help 205 PM

More
[1af2)

Delete
All
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4 De-skew the channels:
a Choose Setup>Channel 1....
b Move the Channel Setup dialog to the left so you can see the traces.

¢ Adjust the Skew (by clicking on the < or > arrows) to achieve the
flattest response on the differential signal (green trace).

File  Control Setup  Measure Analyze Ukilities Help 2:08 PM
1] fGHz Standard BM EJ
On 50 On
O N 0"

d Click Close to close the Channel Setup dialog.

5 Disconnect the cables from the T-adapter on the Aux Out BNC. Leave
the cables connected to the Channel 1 and Channel 3 inputs.

Each cable is now calibrated for the oscilloscope channel it is connected to. Do not switch
cables between channels or other oscilloscopes, or it will be necessary to calibrate them
again. It is recommended that the cables be labeled with the channel they were calibrated
for.

INF_SMA Deskew.set Setup File Details

If the INF_SMA_Deskew.set file is not available, you can create it by
following these instructions.

1 Start from a default setup by pressing the Default Setup key on the
front panel. Then, configure the following settings:

Acquisition: Averaging on, number of averages 16, Interpolation on.

Channel 1: Scale 100.0 mV/, Offset &#8722;350 mV, Coupling DC, Impedance 50 Ohms.
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Channel 3: Turn Channel On; Scale 100.0 mV/, Offset &#8722;350 mV, Coupling DC,
Impedance 50 Ohms.

Time base: Scale 200 ps/div.

Trigger: Trigger level &#8722;173 mV, Slope falling.

Function 2: Turn on and configure for channel 1 subtract channel 3, Vertical scale 50 mV/,
Offset 100.000 mV.

2 From the oscilloscope's main menu, choose File>Save>Setup..., enter the
file name "INF_SMA_Deskew.set", and click Save.
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® Running the Automated Test

. Application on a Second Monitor

A second monitor can be used to display the automated test application,
allowing you to view the oscilloscope while using the application. You need
to connect a second monitor to the video port labeled Second Monitor on
the rear panel of the oscilloscope and not to the port labeled VGA. (The
VGA output is only used to display the screen of the oscilloscope on the
external monitor.)

Before starting the automated test application, you should be sure that the
second monitor is properly configured:

1

Exit the oscilloscope application, and click on the Windows Start menu
button.

Select the Control Panel menu item.

Select Appearance and Themes.

© Fle Edt Vew Favorites Toos Help a*
Qe - © - ¥ Pserch [ roders | [T
: address | @ Control Panel v: EY co

- controt panc > Pick a category

B Switch to Classic View

= -
@ W’Lﬂmﬂ]ﬂ g Printers and Other Hardware
- o

L=

e
-
o

-
? - Date, Time, Language, and Regional
Add or Remove Programs. ' Options

-
(]
¥

MKetwork and Internet Connections - User Accounts

- I{‘j Sounds, Speech, and Audio Devices Accessibility Options
- S

e |
' Performance and Maintenance -.\y Security Center

Select Display.
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Running the Automated Test Application on a Second Monitor

© Fle Edt View Favorites Toos Hep &
Q- © ¥ Psear [roees [T
 address | B Appearance and Themes v|Gn

Wi, Appearance and Themes
-

Pick a task...

(9] Change the computer’s theme
[3] change the desktop background
| Choose a screen saver
Change the screen resolution

or pick a Control Panel icon

:‘ Qﬁnﬁv n Falder Options

Taskbar and Start Menu

5 Select the Settings tab.

| Themes || Desktop || Screen Saver || Appearance | Settings ]

Drag the monitor icons to match the physical amangement %ynur monitors.

21

Display:
| 1. (Muttiple Monitors) on ATl MOBILITY RADEON X300 w |
Screen resolution Color quality
L= {J Mo [Highest (32bi) v
1024 by 768 pixels I .

Use this device as the primary monitor.
BExtend my Windows desktop onto this monitor.

[ identty ][ Troubleshoot... | [ Advanced |

[ ok ][ cancel | oy

6 Select monitor two and set the Screen resolution and Color quality for
your monitor.

7 Enable the Extend my Windows desktop onto this monitor control.

8 Click OK to apply these changes and close the Display Properties dialog
box.

Once the second monitor is configured, moving the mouse off the
oscilloscope screen will cause the mouse to be displayed on the second
monitor. If you want to stop using the second monitor, you should disable
the Extend my Windows desktop onto this monitor control.
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Numerics

81134A pulse pattern generator, 20

A

abort (test) actions, 39

ambient temperature change, 13
App Remote license, 64
AutoRecovery preferences, 54

beep only during run, 38
beep when user prompted, 38
best trials, store mode, 33

c

cable change, 13

calibrating the oscilloscope, 13, 69

channel-to-channel de-skew, 70

clock speed, 20

comma-separated value (CSV) format, export
results, 50

comments, 20

configuring tests, 28

connecting oscilloscope to DUT, 30

continue run when test aborts, 39

creating test project, 19

critical at percent of margin, 47, 48

CSV (comma-separated value) format, export
results, 50

CTC commands, 20

D

deleting trials, 41

de-skew, channel-to-channel, 70
device identifier, 20

device type, 20

display preferences, 37

dual monitor configuration, 75
DUT, connecting to oscilloscope, 30

E

email on pause or stop, 35
enable margin reporting, 47, 48
enable remote interface, 66
Entitlement Certificate, 9

equipment required, 12
error dialogs, 37

event log, 38

event specification, 36
event trials, store mode, 33
events, pause or stop on, 35
exporting the report, 50

F

fail event, 36
flash red pixels in reference images, 46
forever, run until setting, 34

G

Genl, 20
Genll, 20
GENIII, 20

generation, 20

H

hints, remote interface, 67

HTML format, export results, 52

HTML test report,
viewing/exporting/printing, 50

i interface, 20
INF_SMA_Deskew.set file details, 73
information dialogs, 37

installation, 7

interface, 20

invert scope display, 38

K

keep application on top, 38
L

last trials, store mode, 34
license key, 9

license, App Remote, 64
load preferences, 19
log events, 38
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M

m interface, 20

margin < N event, 36

margin thresholds, changing, 47, 48

mask hits, flash red pixels in reference
images, 46

monitor, second for automated test
application, 75

multi-file HTML, export results, 52

multiple runs, 34

N

N times, run until setting, 34

N5411B SATAGG (Serial ATA) electrical
compliance test application, 3

Nb5452A remote interface, 63

notices, 2

0

once, run until setting, 34
opening test project, 19
oscilloscope, connecting to DUT, 30

P

pass event, 36

pause on event, 35

pause, email on, 35
preferences, display, 37
preferences, remote, 66
preferences, report, 47, 48
preferences, run, 38
preferences, save/load, 19, b4
preview print, 53

printing HTML test report, 53
project, creating or opening, 19
project, saving, 54

reference images, showing, 46

remote control, 63

remote interface hints, 67

remote interface version, 65

remote interface, enable, 66

remote preferences, 66

report (HTML), viewing/exporting/printing, 50
report preferences, 47, 48

report, exporting, 50
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report, printing, 53 w

required equipment and software, 12

results, viewing test, 40 warn at percent of margin, 47, 48
run multiple times, 34 warning dialogs, 37

run preferences, 38 worst trials, store mode, 34

run until, 34

running tests, 31 X

S x interface, 20

SATAGG (Serial ATA) automated testing, 3 7

save/load preferences, 19, 54

saving test project, 54

second monitor for automated test
application, 75

selecting tests, 25

setup, 20

show tooltips, 38

showing reference images, 46

single-file HTML, export results, 52

software installation, 8

software required, 12

starting SATABG (Serial ATA) Electrical
Compliance Test application, 16

stop on event, 35

stop run when test aborts, 39

stop, email on, 35

store mode, 33

zoom in/out in reference images, 46

T

task flow pane, viewing/minimizing, 17

test abort actions, 39

test display order, 48

test order, 48

test project, creating or opening, 19

test project, saving, 54

test report (HTML),
viewing/exporting/printing, 50

tests, configuring, 28

tests, running, 31

tests, selecting, 25

tests, viewing results, 40

toolbar, viewing/hiding, 18

tooltips, show, 38

trademarks, 2

trial display preferences, 48

trials, best/worst/last, 33, 48

trials, deleting, 41

U

unavailable tests, 25
user description, 20

v

version, remote interface, 65
viewing HTML test report, 50
viewing test results, 40
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