DI030SATC Serial ATA (SATA)

Compliance Test Application
Keysight D9030SATC Software Version 1.92.0.0

Release Date: March 20, 2024
Operating System: Microsoft Windows 10
Minimum Instrument Software Version: 11.50.00601 (UXR/UXR-B Series)

6.74.01101 (90000 Series, 90000 X-Series, 90000 Q-
Series, V-Series, and Z-Series)

Minimum J-BERT Firmware Version: 7.10
File Name: SetupInfSATA6GO1920000.exe
License: Please see the product data sheet on Keysight.com.

Modifications / Changes

- Removed super-frame feature.

Known Issues

- The app will not launch in demo mode in the absence of InfiniiSim license.

ANV KEYSIGHT



AV KEYSIGHT

Keysight D9030SATC Software Version 1.91.3.0

Release Date:

March 27, 2023

Requirements Category (e.g., operating system):

Microsoft Windows 10

Requirements Category (e.g., minimum instrument software
version):

11.50.00601 (UXR/UXR-B Series)

6.74.00402 (90000 Series, 90000 X-Series, 90000 Q-
Series, V-Series, and Z-Series)

Requirements Category (e.g., minimum J-BERT firmware 7.10

version):

File Name: SetupInfSATA6GO1910003.exe

License: Please see the product data sheet on Keysight.com.

New Features

- Supports UXR-B Series oscilloscope.

Modification

- Update Keysight License Manager b.
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Keysight D9030SATC Software Version 1.91.0.0

Release Date: September 30, 2021

Requirements Category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7

Requirements Category (e.g., minimum instrument software ~ 11.30.00406 (UXR Series)

version):
£6.73.00102 (90000 Series, 90000 X-Series, 30000 Q-
Series, V-Series, and Z-Series)

Requirements Category (e.g., minimum J-BERT firmware 7.10

version):

File Name: SetupInfSATA6GO1910000.exe

License: Please see the product data sheet on Keysight.com.

New Features

Supports Infinilum Oscilloscope Software version 6.60 for non-UXR-Series oscilloscope.
Supports Infinilum Oscilloscope Software version 11.10 for UXR-Series oscilloscope.

Included Peak-Mode Tx Emphasis, LFTP as an alternate test methodology into TSG-17
test.

Included new UTD 1.6 version.

Modifications

Increased the gap of COMINIT and COMWAKE mask to 200 mVppd to cater to signal
glitch.

Created a set of new test IDs to correct Host Gen 3u’s Transmit Total Jitter test names
from “after CIC” to “without CIC” according to specification.

GUI "Interface" value will remain the same. It will not switch back to "Interface" "I
whenever user flips "Device Type" or "Generation" selections unless the selected
"Interface" value is not supported.

Issues Fixed

3/59

Fixed the behavior to retrieve M8020A option correctly.

Created an exception handling to handle the issue wherein the app was unable to launch.
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Known Issues
- Infinilum may occasionally encounter crash while running jitter tests.

- Gen 1’s Jitter tests (LFTP) may not be able to generate results if the pattern is very
periodic.

- Gen 3’s Jitter tests may plot broken Bathtub.
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Keysight D9030SATC Software Version 1.90.1.0

Release Date: January 10, 2020

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 10.25.00902 (UXR Series)

version):
6.40.071007 (90000 Series, 90000 X-Series, 90000 Q-
Series, V-Series, Z-Series)
Requirements category (e.g., minimum J-BERT firmware 7.10
version):
File Name: SetupInfSATA6GO1900001.exe
Modification

- Compliance application versioning format is changed to 1.90.1.0. This format will be used
for all future releases.

Bug Fixes
- Update new Framework version to fix SuperFrame Infiniisim license checking.

- Fix TSG-15 (TX Minimum Differential Voltage Amplitude) test in Gen Ill to run without
Infiniisim license.

Known Issue

- In UXR series oscilloscope, Jitter Tests unable to generate results for Gen | and Gen Il for
all interfaces in HFTP signals. Infiniium Oscilloscope Software version 10.11.04711 is
recommended to use and run the mentioned tests.
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Keysight D9030SATC Software Version 1.90.0000

Release Date: December 06, 2019

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 10.12.05108 (UXR Series)

version):
6.50.00904 (90000 Series, 90000 X-Series, 90000 Q-
Series, V-Series, Z-Series)

Requirements category (e.g., minimum J-BERT firmware 7.10

version):

File Name: SetupInfSATA6GO1900000.exe

New Features
- Supports Infiniium Oscilloscope Software version 6.50 for non UXR-Series oscilloscope.

- Supports Infinilum Oscilloscope Software version 10.12 for UXR-Series oscilloscope.

Modification

- Supports both M8070A and M8070B system software for M800O series of BER test
solutions.

- Includes Test Time Analysis Logger for debugging purposes.

Known Issue

- In UXR series oscilloscope, Jitter Tests unable to generate results for Gen | and Gen Il for
all interfaces in HFTP signals. Infiniium Oscilloscope Software version 10.11.04711 is
recommended to use and run the mentioned tests.

- Infiniisim license is required in order to run on test TSG-15 (TX Minimum Differential
Voltage Amplitude) in Gen IIl.
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Keysight D90O30SATC Software Version 1.89.0002

Release Date: August 23,2019

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 10.11.04711 (UXR Series)

version):
6.40.01001 (90000 Series, 90000 X-Series, 90000 Q-
Series, V-Series, Z-Series)

Requirements category (e.g., minimum J-BERT firmware 7.10

version):

File Name: SetupInfSATA6GO1890002.exe

New Features

Supports Infinilum Oscilloscope Software version 6.40.

Supports Infinilum Oscilloscope Software version 10.11 for UXR-Series oscilloscope.

Implements PPKS feature.

Compliance application GUI changes in QuickSilver.

Modification
- Re-enables COM trigger for non-Gmax scope and remains Infiniiscan trigger for Gmax
SCope.
Bug Fixes

- Enhance the histogram measurement on Differential Output Voltage tests.

Known Issue

- Compliance application supports only M8070A system software for M800O series of BER
test solutions.

- There is no license found message when user clicks on Tools->Infiniium->InfiniiSim or
Precision Prob if InfiniiSim & Precision Prob licenses are not available in the scope.
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Keysight N5411B Software Version 1.88

Release Date: February 27,2019

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 10.00.04104 (UXR Series)

version):
6.30.01102 (90000 Series, 90000 X-Series, 90000 Q-
Series, V-Series, Z-Series)

Requirements category (e.g., minimum J-BERT firmware 7.10

version):

File Name: SetupInfSATA6GO1880000.exe

New Features

- Supports Infinilum Oscilloscope Software version 10.00 for UXR-Series oscilloscope.

Modification

- Updated the OOB Tx+ and Tx- single-ended signal mismatch based on amplitude voltage
(Vamplitude) instead of peak to peak voltage (Vpp) using histogram method.

- Enhanced Trigger Channel vertical range in Gap Detection Windows OOB tests.
- Changed triggering method from COMM Trigger to Infiniscan Trigger.

- Implemented HiSLIP protocol from VXI-11.

Known Issue

- Slowness in test time on Differential Output Voltage Tests are noticeable. This is because
hardware trigger is no longer supported hence software trigger Infiniiscan is implemented
which will bring the slowness in test time.
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Keysight N5411B Software Version 1.87

Release Date: October 17,2018

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 6.30.00609 (30000 Series, 90000 X-Series, 90000 Q-

version): Series, V-Series, Z-Series)
Requirements category (e.g., minimum J-BERT firmware 7.0

version):

File Name: SetupInfSATA6G01870000.exe

New Features
- Supports Infiniium Oscilloscope Software version 6.30.

- Supports user configurable sampling rate for OOB Gap Detection Windows & Signal
Detection Threshold Tests remotely via “SampRate_OOBDetectionTest” configuration
variable. Please refer to Programmer’s Reference for more details (see Help > Remote
Interface).

Modification

- Updated the OOB Tx+ and Tx- single-ended signal mismatch based on amplitude voltage
(Vamplitude) instead of peak to peak voltage (Vpp).
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Keysight N5411B Software Version 1.86

Release Date: April 13, 2018

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 6.20.00620 (30000 Series, 90000 X-Series, 90000 Q-

version): Series, V-Series, Z-Series)
Requirements category (e.g., minimum J-BERT firmware 7.0

version):

File Name: SetupInfSATA6G01860000.exe

New Features
- Supports Infiniium Oscilloscope Software version 6.20.

- Supports M8020A BIST mode automation by loading the sequence file and pattern file to
M8020A JBERT.

o Note: Only N4903B sequence file and pattern file supported (Generated using
JBIST-GUI)

- Supports user configurable edge detection threshold voltage mode for OOB response or
rejects tests via “EdgeDetectionVThreshMode” configuration variable. Please refer to
Programmer’s Reference for more details (see Help > Remote Interface).

Modification

- Updated the “Pattern Length (Pattern Check)” configuration variable from Debug mode to
Compliance mode.

- Updated the PHY-04[c]: Spread-Spectrum Modulation DFDT (Min) and PHY-04[d]:
Spread-Spectrum Modulation DFDT (Max) tests to informative tests.

- Updated the “Edge Detection Voltage Threshold (%)” to calculate the edge threshold level
based on the amplitude of the filtered OOB signal (mode) rather than based on the peak-
to-peak of the filtered OOB signal.

Bug Fixes

- Fixed the issue of incorrect result for O0B-06[a], 00B-06[b] Drive Response to COMWAKE.
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Note

- Keysight recommends running the SATA application with Infiniilum user interface disabled.
Please refer to Online Help for more details (see Help > Contents... > Running Tests > To
Set the Run Preferences).

- Keysight recommends the user to remains active for the same session of Remote Desktop
on the same machine if Remote Desktop is required.

- Keysight recommends viewing the SATA application’s html report with Internet Explorer.
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Keysight N5411B Software Version 1.85

Release Date: March 21, 2017

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 6.00.00624 (30000 Series, 90000 X-Series, 90000 Q-

version): Series, V-Series, Z-Series)
Requirements category (e.g., minimum J-BERT firmware 7.0

version):

File Name: SetupInfSATA6G01850000.exe

New Features
- Supports Infinilum Oscilloscope Software version 6.00.

- Supports user configurable stimulus’s Spread Spectrum Clocking (SSC) if SSC is checked
for N4903B and M8020A JBERT remotely via “PulsegenStimulusSSC” configuration
variable under debug mode. Please refer to Programmer’s Reference for more details (see
Help > Remote Interface).

Modification

- Support both disparity for the LBP test pattern for pattern check.

Bug Fixes

- Fixed the OutOfMemoryException error issue during the run of the test or export the HTML
results.

- Fixed the issue of the “InfiniiScan trigger not found” error.
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Keysight N5411B Software Version 1.84

Release Date: September 19, 2016

Requirements category (e.g., operating system): Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 5.70.00707 (30000 Series, 90000 X-Series, 90000 Q-

version): Series, V-Series, Z-Series)
Requirements category (e.g., minimum J-BERT firmware 7.0

version):

File Name: SetupInfSATA6G01840000.exe

New Features

- Supports Infiniium Oscilloscope Software version 5.70.

Modification

- Removed TSG-17[a]: Gen3 (6 Gb/s) Tx Emphasis test with HFTP and LFTP test pattern.
Please refer to Serial ATA Technical Proposal TPR_059 and TPR_069 for more details.

- Updated the TSG-17[b]: Gen3 (6Gb/s) Tx Emphasis test to include CIC by default for
Gen3i.

- Updated the following test name:

o 0O0B-01[a] : Host Rejects Min Vthresh COMINIT to OOB-01[c] : Host Rejects Min
Vthresh COMINIT for Gen | and Gen Il.

o 0O0B-01[a]: Drive Rejects Min Vthresh COMRESET to OOB-01[c] : Drive Rejects
Min Vthresh COMRESET for Gen | and Gen |I.

o 0O0B-01[b] : Host Responds to Max Vthresh COMINIT to OOB-01[b/d] : Host
Responds to Max Vthresh COMINIT.

o 0OB-01[b]: Drive Responds to Max Vthresh COMRESET to O0B-01[b/d] : Drive
Responds to Max Vthresh COMRESET.

- Updated the OOB transmit burst and gap analysis run once instead of twice for the same
OOB signal.
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Bug Fixes

- Fixed the SICL error issue in PHY-04: Spread-Spectrum Modulation DFDT with Infiniium
version 5.70.

- Fixed the issue of unit interval measurement trend is out of the display grid in PHY-01:
Channel Speed, FBaud & Unit Interval and PHY-03: Spread-Spectrum Modulation
Frequency tests if the SSC profile is not consistent.

- Fixed the issue of incorrect screenshot for the OOB-03: COMRESET/COMINIT and
COMWAKE Transmit Burst Length tests.

- Fixed the issue of inconsistence test result for OOB-06: COMWAKE Gap Detection
Windows tests for Host with ASR.
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Keysight N5411B Software Version 1.83

Release Date: April 05, 2016

Requirements category (e.g., operating system): Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 5.60.0000 (90000 Series, 90000 X-Series, 90000 Q-Series,

version): V-Series, Z-Series)
Requirements category (e.g., minimum J-BERT firmware 7.0

version):

File Name: SetupInfSATA6G01830000.exe

New Features
- Supports Infiniium Oscilloscope Software version 5.60.
- Supports Infiniium Oscilloscope Software version 5.60 for V-Series oscilloscope.

- Supports user configurable to enable BIST mode automation for N4903B remotely via
“BISTModeAutomationN4903B” configuration variable. Please refer to Programmer’s
Reference for more details (see Help > Remote Interface).

Modification

- Updated “O0B Sequence” user configurable to support host DUT that required long idle
time for DUT response after ASR COMINIT. Please refer to Programmer’s Reference for
more details (see Help > Remote Interface).

Bug Fixes

- Fixed the issue of pattern sequence are not loaded into the N4903B J-BERT for multiple
trial run when the user the enable BIST mode automation.

- Fixed the issue of unable to detect COMRESET/COMINIT response from the DUT after
10us from the stimulus generated COMRESET/COMINIT.

- Fixed the issue of O0OB-02 to OOB-05 tests unable to run with Infinilum version 5.60 and
above.
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Keysight Nb5411B Software Version 1.82

Release Date: November 9, 2015

Requirements category (e.g., operating system): Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 5.50.0035 (90000 Series, 90000 X-Series, 90000 Q-Series,

version): Z-Series)

Requirements category (e.g., minimum J-BERT firmware 7.0

version):

File Name: SetupInfSATA6G01820000.exe

New Features

- Supports TSG-17[b]: Gen3 (6 Gb/s) Tx Emphasis test with MFTP test pattern. Please refer
to Serial ATA Technical Proposal TPR_069 for more details.

- Supports user configurable sleep time before the screenshot of the jitter related graph
plot. Please refer to Programmer’s Reference for more details (see Help > Remote
Interface).

- Supports Infinilum user interface disabled feature during the run of the test. Please refer to
Online Help for more details (see Help > Contents... > Running Tests > To Set the Run
Preferences).

Modification

- Updated the test name label for “PHY-02: Frequency Long-Term Stability” to “PHY-02:
Frequency Long-Term Stability / Accuracy”.

- Updated the test name label for “TSG-17: Gen3 (6 Gb/s) Tx Emphasis” test with HFTP and
LFTP test pattern to “TSG-17[a]: Gen3 (6 Gb/s) Tx Emphasis”.
Bug Fixes
- Fixed the display SICL command error when running in Infinilum 4.60 or below.

- Fixed the InfiniiSim and the InfiniiScan SICL command error when running the SATA
application without the InfiniiSim or InfiniiScan licenses installed in the Infiniium.

- Fixed the issue of the selected stimulus tab for Configure Device dialog do not update base
on the Stimulus selected in the Set Up tab of the SATA Compliance Application.
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- Fixed the issue of Configure Devices dialog does not always stay at the top of the
application.

- Fixed the issue stimulus calibration status reset after the Configure Devices dialog reopen.

- Fixed the issue of elapsed time do not update during the calibration of the N4903N JBERT
and M8020A JBERT for OOB Signal Detection Threshold Tests.

- Fixed the issue of M8020A J-BERT trigger configuration warning when the SATA
Compliance Application controls the M8020A J-BERT stimulus.

- Fixed the issue of inconsistency font for the html report that included OOB tests.
- Fixed the issue of missing screenshot in TSG-03: Differential Skew test for x-interface.
- Fixed the issue of additional display window for TSG-06 [a]: Amplitude Imbalance tests.

- Fixed the issue of incorrect horizontal display for LBP bit display in TSG-01: Differential
Output Voltage (Min) test.

- Fixed the issue of missing line in BER bathtub plot.
- Fixed the issue of 0OOB COMWAKE response inconsistent result as the COMWAKE signal is
out of the display screen.

Note

- Keysight recommends running the SATA application with Infiniium user interface disabled.
Please refer to Online Help for more details (see Help > Contents... > Running Tests > To
Set the Run Preferences).
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Keysight Nb5411B Software Version 1.8

Release Date: April 10, 2015

Requirements category (e.g., operating system): Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 4.60.0005 (90000 Series, 90000 X-Series, 90000 Q-Series,

version): Z-Series)

Requirements category (e.g., minimum J-BERT firmware 7.0

version):

File Name: SetupInfSATA6G01810000.exe

New Features
- Supports Infiniium Oscilloscope Software version 5.50.
- Supports M8020A J-BERT (High Performance Serial BERT) as stimulus source.

- Supports TSG-17: Gen3 (6 Gb/s) Tx Emphasis test. Please refer to Serial ATA Technical
Proposal TPR_059 for more details.

Modification
- Update the u interface SATA tests available for host device only.
- Update the test name label for TSG-13 Gen3 (6Gb/s) Transmitter Jitter tests.

- Update the OOB sequence with D10.2 for 00B-06 COMWAKE Gap Detection Windows
tests for devices.

- Remote Interface updated to version 3.40. For more information, see Keysight’s N5452A

Remote Programming Toolkit (www.keysight.com/find/scope-apps).

Bug Fixes

- Fixed the issue of wrong histogram placement in TSG-01: Differential Output Voltage tests
in Infiniium 5.00 and above.

- Fixed the issue of unhandled error in TSG-15: Gen3 (6Gb/s) TX Minimum Differential
Voltage Amplitude (UI=5E6) in Infiniium 5.50 and above.

- Fixed the issue of error when perform the calibration for OOB-01: OOB Signal Detection
Threshold tests.
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- Fixed the issue of no full screen jitter plot displayed in the Transmit Jitter tests in Infiniium
5.00 and above.
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Agilent N5411B Software Version 1.80

Release Date: June 02, 2014

Requirements category (e.g., operating system): Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 4.60.0005 (90000 Series, 90000 X-Series, 90000 Q-Series,

version): Z-Series)

Requirements category (e.g., minimum J-BERT firmware 6.80

version):

File Name: SetupInfSATA6G01800000.exe

New Features
- Supports Infiniium Oscilloscope Software version 5.00.

- Supports Infinilum Oscilloscope Software version 4.60.0005 for 90000 Z-Series
oscilloscope.

- New Help > Support > Collect Files menu item simplifies collecting files needed by Agilent
support engineers

Modification

- Minimum Infiniium Oscilloscope Software updated to version 4.60.0005.
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Agilent N5411B Software Version 1.71

Release Date: May 23, 2014
Requirements category (e.g., operating system): Microsoft Windows XP
Microsoft Windows 7

Requirements category (e.g., minimum instrument software  4.20.0000 (Microsoft Windows XP for 90000 Series, 90000
version): X-Series, 90000 Q-Series),

4.60.0005 (Microsoft Windows 7 for 90000 Series, 90000
X-Series, 90000 Q-Series)

Requirements category (e.g., minimum J-BERT firmware 6.80
version):
File Name: SetupInfSATA6GO1710000.exe

New Features

- Supports for Serial ATA Interoperability Program Revision 1.5.0 Unified Test Document
Version 0.99Db.

- Supports user configurable OOB sequence with/without D10.2 (Device) or ALIGN (Host) via
“O0B Sequence” configuration variable under debug mode. Please refer to Programmer’s
Reference for more details (see Help > Remote Interface).

- Supports user configurable ISI Filter Leading Bit and Lagging Bit for Transmit Jitter test via
“ISI Filter Leading Bit” and “ISI Filter Lagging Bit” configuration variables under debug
mode. Please refer to Programmer’s Reference for more details (see Help > Remote
Interface).

Modification

- InfiniiSim now includes new Normalize Gain option.

- When using BitifEye BIT2100 instrument for switch matrix, now requires minimum firmware
version: 3.4-1.10.

- Remote Interface updated to version 2.50. For more information, see Agilent’s N5452A

Remote Programming Toolkit (www.agilent.com/find/scope-apps).
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Bug Fixes
- Fixed the issue of the progress window appear in the screenshot of the report.
- Fixed the issue of unhandled error when running the application in MSO oscilloscope.

- Fixed the issue of error when performing the calibration for OOB-01: OOB Signal Detection
Threshold tests.

- Fixed the issue of missing SSC profile in PHY-03 Spread-Spectrum Modulation Frequency
tests and PHY-04 Spread-Spectrum Modulation Deviation tests.

- Fixed the issue of wrong histogram placement in TSG-01: Differential Output Voltage tests
for Infiniium Oscilloscope Software Version 5.00 and above.

- Fixed the issue of run error in TSG-03 Differential Skew tests.
- Fixed the issue of signal clipping in TSG-04 AC Common Mode Voltage tests.

- Fixed the issue of invalid total jitter limit in TSG-13 Gen3 (6Gb/s) Transmitter Jitter used
RJ tests.

- Fixed Connection tab "Suppress" checkbox.

Miscellaneous Notes

- This will be the last version to support Infiniium Oscilloscope Software Version 4.20.
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Agilent N5411B Software Version 1.70

Release Date: December 13, 2013
Requirements category (e.g., operating system): Microsoft Windows XP
Microsoft Windows 7

Requirements category (e.g., minimum instrument software  4.20.0000 (Microsoft Windows XP for 90000 Series, 90000
version): X-Series, 90000 Q-Series),

4.60.0005 (Microsoft Windows 7 for 90000 Series, 90000
X-Series, 90000 Q-Series)

Requirements category (e.g., minimum J-BERT firmware 6.80
version):
File Name: SetupInfSATA6GO1700000.exe

New Features

- Supports Infinilum Oscilloscope Software version 4.60.0005 for 90000 Q-Series
oscilloscope.

- Supports for Serial ATA Interoperability Program Revision 1.5.0 Unified Test Document
draft version.

- Supports u interface SATA tests.

- Supports N4903B BIST mode automation by loading the sequence file and pattern file to
N4903B JBERT.

- Supports pattern checking for the input signal via “Pattern Check” configuration variable.
Please refer to Programmer’s Reference for more details (see Help > Remote Interface).

- Supports user configurable CDR setting in jitter tests via “Override Default”, “Clock
Recovery Loop Bandwidth” and “Clock Recovery Damping Factor” configuration variables.
Please refer to Programmer’s Reference for more details (see Help > Remote Interface).

- Supports user configurable low pass filter's bandwidth in OOB tests via “O0B Low Pass
Filter Bandwidth” configuration variable. Please refer to Programmer’s Reference for more
details (see Help > Remote Interface).

- Supports debug feature for OOB-07/08 OOB Gap Detection Windows tests under debug
mode. Please refer to Programmer’s Reference for more details (see Help > Remote
Interface).

- User can now suppress connection prompts from the user interface (see Connect tab).

23/59 Keysight DIO30SATC Serial ATA (SATA) Compliance Test Application Release Notes



ANV KEYSIGHT

- Ifa project opens as Read-Only and there are no settings conflicts with the current version
of the app, user may use File > Save Project (Settings-Only) As... menu item to extract the
configuration (and no results) from that project.

- If user creates the folder:
o (Win7) C:\ProgramData\ Agilent\Infiniium\Apps\<app_name>\app\scripts

o (WinXP) C:\Documents and Settings\All Users\Application
Data\Agilent\Infiniium\Apps\<app_name>\app\scripts

- Then menu item File > Execute Script... becomes visible and enables user to pick a file to
execute (e.g. Python or Visual Basic script). Scripts in this folder may also be executed via
the Automation tab or remote interface.

- HTML reports include probe info.

Modification

- Minimum Infiniium Oscilloscope Software updated to version 4.20.0000 for Window XP
oscilloscope.

- Minimum Infiniium Oscilloscope Software updated to version 4.60.0005 for Window 7
oscilloscope.

- Application’s project file saved for version 1.65 and below will be opened as read-only.
- Update the SATA CIC embedding by using InfiniiSim instead of user defined function.

- Update the test limit for PHY-04 Spread-Spectrum Modulation DFDT tests to +/-1250
ppm/us range limit.

- Update the OOB sequence by adding the D10.2 in the sequence for 00B-06 COMWAKE
Gap Detection Windows tests devices.

- Last location when saving/opening/exporting project/ files/etc. will be saved.
- ARSL scripts supports for .txt file extension.

- Last Test Date reported using international format.

- Preserves line breaks for “User Comments” field in HTML report.

- Includes new Delay option in InfiniiSim.

- New option to control jump behavior when user double-click a test name on the Select
Tests tab. See View > Preferences > Report.
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- Remote Interface updated to version 2.40. For more information, see Agilent’s N5452A

Remote Programming Toolkit (www.agilent.com/find/scape-apps).

Bug Fixes
- Fixed launch on Win7 for non-admin user.

- Fixed statistics display for items in the Referenced Values section.
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Agilent N5411B Software Version 1.65

Release Date: July 16, 2013
Requirements category (e.g., operating system): Microsoft Windows XP
Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 3.21 (90000 Series, 90000 X-Series)

version):

Requirements category (e.g., minimum J-BERT firmware 6.80

version):

File Name: SetupInfSATA6GO1650000.exe

New Features

- Supports Infinilum Oscilloscope Software version 3.21 for 90000 MSOX -Series
oscilloscope.
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Agilent N5411B Software Version 1.64

Release Date: July 27,2012
Requirements category (e.g., operating system): Microsoft Windows XP
Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 3.21 (90000 Series, 90000 X-Series)

version):

Requirements category (e.g., minimum J-BERT firmware 6.80

version):

File Name: SetupInfSATA6GO1640000.exe

New Features

- Supports for Serial ATA Interoperability Program Revision 1.5.0 Unified Test Document
Version 0.99b.

- Supports InfiniiSim feature for all PHY tests and TSG tests. InfiniiSim feature can be access
through the main menu (see Tools > Infiniium > InfiniiSim).

Modification

- Update the response detection window in OOB-07 COMINIT /COMRESET Gap Detection
Windows tests from 10.0us to 20.0ps.

Bug Fixes

- Fixed the issue of slow measurement in O0OB-2/3/4/5 COMINIT/COMRESET/COMWAKE
Transmit Burst and Gap Length tests for Infinilum Oscilloscope Software Version 3.50.0001
and above.

- Fixed the issue of wrong judgment in OOB-06 COMWAKE Gap Detection Windows tests
(for non-continuous ALIGN response from the device).
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Agilent N5411B Software Version 1.63

Release Date: April 17,2012
Requirements category (e.g., operating system): Microsoft Windows XP
Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 3.21 (90000 Series, 90000 X-Series)

version):

Requirements category (e.g., minimum J-BERT firmware 6.80

version):

File Name: SetupInfSATA6GO1630000.exe

New Features

- Supports for Serial ATA Interoperability Program Revision 1.4.3 Unified Test Document
Version 1.00. Please refer to the Table 1.63.1 for more details.

- Supports user configurable enable or disable of the use of SATA CIC via “Use SATA CIC”
configuration variable. Please refer to Programmer’s Reference for more details (see Help >
Remote Interface).

- Supports user configurable frequency window for the TSG-16 Gen3 (6Gb/s) Tx AC
Common Mode Voltage tests via “FFT Frequency Window, Min” and “FFT Frequency
Window, Max” configuration variables. Please refer to Programmer’s Reference for more
details (see Help > Remote Interface).

Modification

- Update several tests from mandatory tests to informative tests base on Serial ATA
Interoperability Program Revision 1.4.3 Unified Test Document Version 1.00. Please refer
to the Table 1.63.1 for more detalils.

- Update the Bandwidth Limit feature for acquisition setup to be available for both
Compliance Mode and Debug Mode. Bandwidth Limit feature can be access through the
main menu (see Tools > Infiniium > Acquisition Setup).

- Update the default sample size for PHY-01 Channel Speed, FBaud and Unit Interval test
and PHY-02 Frequency Long-Term Stability from 100,000UI to 200,000 Ul (covers at least
one SSC profile).

- Update the stimulus differential voltage output of compliance mode in all PHY tests and
TSG tests to 600mV.
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- Update the test limit for TSG-02 Rise/Fall Time tests base on Serial ATA Interoperability
Program Revision 1.4.3 Unified Test Document Version 1.00.

- Remove the “Memory Depth” configuration variable for TSG-16 Gen3 (6Gb/s) Tx AC
Common Mode Voltage tests.

Bug Fixes

- Fixed the issue of incorrect number of histogram hits in TSG-01[b] Differential Output

Voltage (Max) test.

- Fixed the issue of ALIGN field detection in OOB-06 COMWAKE Gap Detection Windows

tests.
Table 1.63.1
Before UTD 1.4.3 UTD 1.4.3
Test Name Tlegt Test Name Tle[ft Comments
TSG-01[b] : TSG-01[b] :
Differential Output 20121 Differential Output 20121 Change to Informative
Voltage (Max) Voltage (Max) Testin all UTD
(Informative) (Informative)
20211 20231
R 20212 | TSG-02[a] : Rise Time | 20232 Change to Informative
TSG-02[a} - Rise Time =557 3 (Informative) 20233 Testin UTD 1.4.3.
20214 20234
20221 20241
. : 20222 | TSG-02[a] : Fall Time | 20242 Change to Informative
TSG-02[a] : Fall Time 20223 (Informative) 20243 Test in UTD 1.4.3
20224 20244
TSG-03[a] : 20311 TSG-03[a] : 20331 .
Differential Skew Differential Skew Change to Informative
HETP 20312 HETP (Informative) 20332 Testin UTD 1.4.3
. TSG-13[a] : RJ before
TSG-13la) - RJ before CIC, MFTP, Clock To Change to Informative
CIC, MFTP, Clock To 20311 . 21312 .
. Data, JTF Defined Testin UTD 1.4.3
Data, JTF Defined .
(Informative)
TSG-13[f] : TJ after TSG-13If] - T4 after
CIC, HFTP, Clock To .
CIC, HFTP, Clock To . Change to Informative
. 21511 Data, JTF Defined 21517 .
Data, JTF Defined Testin UTD 1.4.3
(BER=1E-12)
(BER=1E-12) .
(Informative)
TSG-13[g] : TJ after TSG-13lg}: TJ after
CIC, HFTP, Clock To .
CIC, HFTP, Clock To 21513 Data. JTF Defined 21517 Change to Informative
Data, JTF Defined ‘ Testin UTD 1.4.3
(BER=1E-6)
(BER=1E-6) .
(Informative)
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TSG-04 : AC :
~ - Common Mode 20412 Ne\qv ZegtfgfgegGlg/gTD
Voltage, HFTP - '
TSG-04 : AC :
i} - Common Mode | 20423 NeV1V Zegtfg(rjgeodelg/gm
Voltage, MFTP - '
TSG-04 : AC :
. - Common Mode | 20424 NeV1V Zegtfg(rjge(?Glg/LsJTD
Voltage, HFTP - '
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Agilent N5411B Software Version 1.62

Release Date: February 2, 2012
Requirements category (e.g., operating system): Microsoft Windows XP
Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 3.21 (90000 Series, 90000 X-Series)

version):

Requirements category (e.g., minimum J-BERT firmware 6.80

version):

File Name: SetupInfSATA6G01620000.exe

New Features

- Supports user selectable Serial ATA Interoperability Program Unified Test Document, e.g.
UTD 1.1, UTD 1.2. UTD 1.3, UTD 1.4, UTD 1.4.1, UTD 1.4.2 and UTD 1.4.3. Please refer to
each of the Serial ATA Interoperability Program Unified Test Document for more tests
details.

- Supports User-Defined Compliance Limits feature for user to select, edit and create tests
limit. User-Defined Compliance Limits feature can be access through the main menu (see
Tools > Compliance limits).

- Supports Bandwidth Limit feature for acquisition setup for all PHY tests and TSG tests
under Debug Mode. Bandwidth Limit feature can be access through the main menu (see
Tools > Infiniium > Acquisition Setup).

- Supports Precision Probe and Precision Cable feature. Precision Probe and Precision Cable
feature configuration setup can be accessed through the main menu (see Tools > Infiniium
> PrecisionProbe/PrecisionCable).

- Remote interface help and PDF files can be accessed through the main menu (see Help >
Remote Interface).

- New ‘Automation’ tab enables you to create command scripts that modify settings and
execute tests.

- New user preference to set default project location (Menu: View > Preferences >
Save/Load: Default Location).
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Modification

- Minimum Infiniium Oscilloscope Software updated to version 3.21.

- Update the test name base on the naming in Serial ATA Interoperability Program Unified
Test Document. Please refer to each of the Serial ATA Interoperability Program Unified
Test Document for more tests details.

- Update the test limit for PHY-04 Spread-Spectrum Modulation DFDT tests from +/- 1200
ppm/us range limit to +/-1250 ppm/us range limit.

- Update the maximum test limit for TSG-02 Rise/Fall Time tests for 6Gb/s from 68ps to
80ps. Please refer to ECNO53 for more details.

- Update the analysis bandwidth for TSG-04 AC Common Mode Voltage to low end at
200MHz and high end at 4.5GHz for UTD 1.4.2.

- Update the eye height measurement location for TSG-15 Gen3 (6Gb/s) TX Minimum
Differential Voltage Amplitude tests from [0.45, 0.55] Ul location to 0.50 Ul location.

- Update the test limit for OOB-03 COMINIT/COMRESET and COMWAKE Transmit Burst
Length from [Min = 103.5ns, Max = 109.9ns] to [Min = 103.5ns, Max = 110.9ns] for UTD
1.4.1 and above.

- Update the test limit for OOB-05 COMWAKE Transmit Gap Length from [Min = 103.5ns,
Max = 109.9ns] to [Min = 102.4ns, Max = 109.9ns] for UTD 1.4.7 and above.

- PrecisionProbe dialog screens now have tooltips and remote hints.
- A calibration creation wizard is added to the PrecisionProbe dialog box.
- Remote Interface updated to version 2.00. For more information, see Agilent's N5452A
Remote Programming Toolkit (www.agilent.com/find/scape-apps).
Bug Fixes

- Fixed the issue of error in TSG-15 Gen3 (6Gb/s) TX Minimum Differential Voltage
Amplitude tests.

- Fixed the issue of triggering alogorithm in O0B-2/3/4/5 COMINIT/COMRESET/COMWAKE
Transmit Burst and Gap Length tests.

- Fixed the issue of file not found in OOB-01 OOB Signal Detection Threshold tests.

- Fixed app startup under Windows Standard User login.
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Agilent N5411B Software Version 1.61

Release Date: September 30, 2011
Requirements category (e.g., operating system): Microsoft Windows XP
Microsoft Windows 7

Requirements category (e.g., minimum instrument software ~ 3.10 (90000 Series, 90000 X-Series)

version):

Requirements category (e.g., minimum J-BERT firmware 6.80

version):

File Name: SetupInfSATA6GO1610000.exe

New Features

- Supports for Window 7 Infiniium oscilloscope.
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Agilent N5411B Software Version 1.60

Release Date: August 12, 2011

Requirements category (e.g., operating system): Microsoft Windows XP

Requirements category (e.g., minimum instrument software  3.10 (90000 Series, 90000 X-Series)

version):

Requirements category (e.g., minimum J-BERT firmware 6.80

version):

File Name: SetupInfSATA6G01600000.exe
Modification

- Minimum Infiniium Oscilloscope Software updated to version 3.10.

- Update the test methodology for TSG-15 Gen3 (6Gb/s) TX Minimum Differential Voltage
Amplitude tests. Please refer to ECNO50 for more details.

- Update the test ID for several tests. Please refer to the Table 1.60.1 for more details.

o Merge test ID: Old tests ID are auto substitute by the application to ensure
backward compatible.

= 20112,20113, 20114 -> 20111
= 20122,20123, 20124 -> 20121
o Splittest ID: Old tests ID are split into several test ID.

= 20115 -> 20115 for drive DUT and 20116 for host DUT

Bug Fixes

- Fixed the issue of incorrect termination mode from 50 ohm termination to 25 ohm
termination in TSG-16 Gen3 (6Gb/s) Tx AC Common Mode Voltage at 3GHz tests.

o FFT_dBmV_3GHz = FFT_dBm_3GHz + 43.9794

- Fixed the issue of incomplete number of acquisition hits for histogram in TSG-01
Differential Output Voltage tests for Gen1 and GenZ2.

Table 1.60.1

Old Test ID New Test ID Notes
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20112 20111 Merge to test ID 20111
20113 20111 Merge to test ID 20111
20114 20111 Merge to test ID 20111
20122 20121 Merge to test ID 20121
20123 20127 Merge to test ID 20121
20124 20121 Merge to test ID 20121
20115 Split from test ID 20115
20115 20115 for drive DUT
20116 20115 for host DUT
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Agilent N5411B Software Version 1.50

Release Date: February 11, 2011

Requirements category (e.g., operating system): Microsoft Windows XP

Requirements category (e.g., minimum instrument software ~ 3.03 (90000 Series, 90000 X-Series)

version):

Requirements category (e.g., minimum J-BERT firmware 6.80

version):

File Name: SetupInfSATA6G01500000.exe

New Features
- Supports N4903B J-BERT (High Performance Serial BERT) as stimulus source.

o The calibration procedure for J-BERT does not require the use of attenuator. The
calibration might not work well if attenuators are added to the connections.

- Supports jitter measurement at 1E-12 and T1E-6 for Gen1, Gen2 and Geng3.

Modification
- Minimum Infinilum Oscilloscope Software updated to version 3.03.
- Update the stimulus calibration routine GUI to improve the calibration.

- Update the Set Up tab GUI to improve the use model. “SSC”, “ASR” and “BIST Mode”
options are group under “Capabilities” of the DUT.

- Update the configuration variable. Please refer to Programmer’s Reference for more details
(see Help > Remote Interface).

o “HostASR” configuration variable supports “1.0” (checked) and “0.0” (unchecked)
options.

o “BISTMode” configuration variable supports “BIST-L” and “BIST-T” options. (This
configuration variable replaced “TPSource” configuration variable )

o “OptConnection” configuration variable supports “none”, “PPG_IP”, “PPG_Sicl”,
“JBERT_IP” and “UBERT_Sicl” options.

- Update the application to not uncheck the selected tests in Select Test tab when select
Debug mode.
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- Update the stimulus single-ended voltage output of compliance mode in all PHY tests and
TSG tests to 600mV.

- Update the test methodology to disable averaging for in TSG-16 Gen3 (6Gb/s) Tx AC
Common Mode Voltage tests.

- Update the OOB test verification to accommodate changes in the Infinilum Oscilloscope
Software.

- Update the COMWAKE response gap length from 155 Ul and 165 Ul to 153 Ul and 167 Ul
in OOB-06 COMWAKE Gap Detection Windows tests for UTD 1.4.1 and above.

Bug Fixes

- COMWAKE minimum and maximum response test for host with ASR enabled: Previously
there is an issue of some hosts treating the COMINIT from the stimulus instrument to be an
unsolicited COMINIT sometimes with a certain probability, which results in an initial
COMRESET reply from host instead. In this version, the app will now retry 10 times to re-
fire the stimulus instrument (81134A or N4903B) to get an initial COMWAKE, whereby from
the host’s perspective, is supposed to be an in reply to a solicited COMINIT from the
stimulus instrument.

Miscellaneous Notes

- Please ensure the memory depth for the Infiniium oscilloscope is at least 25.0Mpts to
ensure proper run of the compliance tests.

37 /59 Keysight DIO30SATC Serial ATA (SATA) Compliance Test Application Release Notes



ANV KEYSIGHT

Agilent N5411B Software Version 1.30

Release Date: September 20, 2010

Requirements category (e.g., operating system): Microsoft Windows XP

Requirements category (e.g., minimum instrument software ~ 2.57 (90000 Series),

version):
2.95 (90000 X-Series)

File Name: SetupInfSATA6GO1300000.exe

New Features
- Supports Infiniium Oscilloscope Software version 2.95 for 90000 X-Series oscilloscope.

- Supports user configurable RJ bandwidth of either Wide (White) or Narrow (Pink) for the
jitter tests. Please refer to Programmer’s Reference for more details (see Help > Remote
Interface).

- Supports jitter measurement at 1E-12 (default) and 1E-6 (informative) for Gen1, Gen2 and

Gen3.

Modification

- Minimum Infiniium Oscilloscope Software updated to version 2.51 for 90000 Series
oscilloscope.

- Default the response for BIST-T and BIST-L dialog when the message box suppression is
enabled.

- Update the TSG-13 Gen3 (6Gb/s) Transmitter Jitter tests. TSG-13 Gen3 (6Gb/s)
Transmitter Jitter tests consists of the following tests:

o RJ Before CIC

o TJ Before CIC HFTP, using RJ
o TJ Before CIC LBP, using RJ
o TJafter CIC HFTP, using RJ
o TJ after CIC LBP, using RJ

o TJ1E12 after CIC HFTP

o TJ 1E6 after CIC HFTP
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o TJ1E12 after CIC LBP

o TJ 1E6 after CIC LBP

Bug Fixes
- Fixed the issue of slow loading for Far End Retimed connection diagram.
- Fixed the issue of missing Periodic/Arbitrary selection in Configure tab for jitter tests.
- Fixed the issue of missing MFTP test when Pulsegen Usage = “No” and SSC = “Yes”

- Fixed the issue of incorrect termination mode from 50 ohm termination to 25 ohm
termination in TSG-16 Gen3 (6Gb/s) Tx AC Common Mode Voltage tests at 6GHz.

o FFT_dBmV_6GHz = FFT_dBm_6GHz + 43.9794
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Agilent Nb5411B Software Version 1.20

Release Date: January 22, 2010

Requirements category (e.g., operating system): Microsoft Windows XP

Requirements category (e.g., minimum instrument software 5.7 (80000 Series),

version):
2.10 (90000 Series)

File Name: SetupInfSATA6G01200000.exe

New Features

- Supports user configurable jitter BER level for the jitter tests. Please refer to Programmer’s
Reference for more details (see Help > Remote Interface).

- Supports jitter measurement at 1E-12 (default) and 1E-6 (informative) for Gen1, Gen2 and
Gen3.

Modification

- Minimum Infiniium Oscilloscope Software updated to version 2.10 for 90000 Series
oscilloscope.

- Update the report fields for jitter tests to include DCD value (informative). The DCD value

does not affect overall jitter tests results.

Miscellaneous Notes

- This will be the last version to support 80000 Series oscilloscope.
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Agilent Nb411B Software Version 1.11

Release Date: December 21, 2009

Requirements category (e.g., operating system): Microsoft Windows XP

Requirements category (e.g., minimum instrument software 5.7 (80000 Series),

version):
2.01 (90000 Series)
File Name: SetupInfSATA6GO1110000.exe
Bug Fixes

- Fixed the issue of unable to run OOB-01 OOB Signal Detection Threshold tests with non-
debug mode calibration.
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Agilent N5411B Software Version 1.10

Release Date: November 23, 2009

Requirements category (e.g., operating system): Microsoft Windows XP

Requirements category (e.g., minimum instrument software 5.7 (80000 Series),

version):
2.01 (90000 Series)

File Name: SetupInfSATA6GO1100000.exe

New Features
- Supports BIST-L loopback mode for Gen3i DUT.

- Supports TSG-15 Gen3 (6Gb/s) TX Minimum Differential Voltage Amplitude tests for Gen3i
DUT.

- Supports debug mode for OOB-01 OOB Signal Detection Threshold tests by sweeping
down the differential voltage level of the stimulus from a defined voltage level to the
voltage level where the first rejection or no response encountered.

Modification

- Minimum Infiniium Oscilloscope Software updated to version 5.71 for 80000 Series
oscilloscope.

- Minimum Infinilum Oscilloscope Software updated to version 2.01 for 90000 Series
oscilloscope.

- Update the CIC S parameter file from SATA_Gen3i CIC.txt or SATA_Gen3m_CIC.txt files to
standardized SATA_CIC_Spec.s4p file.

- Update the configuration variable. Please refer to Programmer’s Reference for more details
(see Help > Remote Interface).

o “Jitter_Datalength” and “Jitter_PatternMode” configuration variables are asserted
when “OverrideditterDefault” configuration variable is “ENABLED” in debug mode.

o “Jitter_Datalength” configuration variable moved to debug mode.
o ‘“DifferentialSkew_RetrialGlitch” configuration variable is added.
o Redefinition and addition configuration variables:

= “VthreshDebugResponsetolnconsistent”
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= “VthreshDebugResponsetolnconsistentStartVdiff”
= “VthreshDebuglInconsistentToReject”
= “VthreshDebuglnconsistentToRejectStartVdiff”

- Update the threshold level for all PHY tests and TSG tests to use threshold at OV with
hysteresis +/- 10mV, except TSG-02 Rise/Fall Time tests.

- Update the algorithm for the jitter tests.

o Infinilum Oscilloscope Software update algorithm for the jitter separation to
improve the measurement accuracy.

o Infinilum Oscilloscope Software increases the memory depth of 2.048Mpts for
arbitrary mode jitter separation.

o Update the configuration variables for the jitter test with details descriptions.

- Update the test methodology in TSG-16 Gen3 (6Gb/s) Tx AC Common Mode Voltage tests
at 3GHz and 6GHz to allow peak to peak measurement from -5350 ppm to 350 ppm.

- Update the vertical markers measurement boundary to +/-2 Ul centered at the trigger in
TSG-14 Gen3 (6Gb/s) TX Maximum Differential Voltage Amplitude tests.

- Update the measurement details for TSG-15 TX Minimum Differential Voltage Amplitude
tests.

o Eye Height = (Vtop_mean - 3 Vtop_stddev) - (Vbase_mean - 3 Vbase_stddev)

- Update the sampling rate for OOB-01/06/07 OOB Signal Detection Threshold and OOB
Gap Detection Threshold tests to 10GSa/s to preserve better signal integrity prior the low
pass filter. This will also enhance OOB signal response detection accuracy and precision.
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Agilent N5411B Software Version 1.02

Release Date: April- 24, 2009

Requirements category (e.g., operating system): Microsoft Windows XP

Requirements category (e.g., minimum instrument software ~ 5.60 (80000 Series),

version):
1.40 (90000 Series)
File Name: SetupInfSATA6G01020000.exe
Modification
- Update the test methodology for TSG-14 Gen3 (6Gb/s) TX Maximum Differential Voltage
Amplitude tests to use acquisition averaging instead of histogram peak to peak (worst case
amplitude).
Bug Fixes

- Fixed the issue of conversion in TSG-16 Gen3 (6Gb/s) Tx AC Common Mode Voltage tests
by reporting the value in unit of “dBmV” instead of “dBm” in HTML report.

- Fixed the issue of total jitter value in TSG-13 Gen3 (6Gb/s) Transmitter Jitter tests by
reporting the total jitter value extracted directly from the EZJIT jitter result panel.
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Agilent Nb5411B Software Version 1.071

Release Date: March 16, 2009

Requirements category (e.g., operating system): Microsoft Windows XP

Requirements category (e.g., minimum instrument software ~ 5.60 (80000 Series),

45/ 59

version):
1.40 (90000 Series)
File Name: SetupInfSATABG01010000.exe
Bug Fixes

- Fixed the issue of loop bandwidth error in jitter tests for Gen1 and Gen2.

Agilent Nb411B Software Version 1.00

Release Date: February 09, 2009

Requirements category (e.g., operating system): Microsoft Windows XP

Requirements category (e.g., minimum instrument software  5.60 (80000 Series),

version):
1.40 (90000 Series)

File Name: SetupInfSATA6GO1000000.exe

New Features

- Supports user configurable RJ bandwidth of either Wide (White) or Narrow (Pink) for the
jitter tests. Please refer to Programmer’s Reference for more details (see Help > Remote
Interface).

- Supports Gena3i tests for BIST-T mode:
o Channel Speed, FBaud & Unit Interval

Frequency Long Term Stability

O

o TX Differential Voltage Test ( Maximum)
o TXRise/Fall Time
o TX Differential Skew

= HFTP
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= MFTP
o TXAC Common Mode Voltage
o TJ &DJ at Connector, Clk-Data

= RJ before CIC

= TJ before CIC, HFTP

= TJ before CIC, LBP

» TJafter CIC, HFTP

= TJafter CIC, LBP

- Supports user configurable threshold level for OOB-01/06/07 OOB Signal Detection
Threshold and OOB Gap Detection Threshold tests to allow manual adjustment when
default threshold level touches the low passed filter ripples. Please refer to Programmer’s
Reference for more details (see Help > Remote Interface).

Modification

- Minimum Infiniium Oscilloscope Software updated to version 5.60 for 80000 Series
oscilloscope.

- Minimum Infiniium Oscilloscope Software updated to version 1.40 for 90000 Series
oscilloscope.

- Application’s project file saved for N5411A SATA Il application will not be able to open
using N5411B SATAGG application. Please use the internet browser to load the old report
file.

- Update the Matlab MCR to Matlab 7.5.
- Expanded UTD required patterns on the Select Test tab:
o Test pattern options are removed for these tests.
- Added cancel button to abandon the calibration request on the calibration dialog box.
- Update the message box for BIST-T mode to display once for the same test pattern.

- Update the sampling rate for spread-spectrum clocking tests sampling rate for 90000
Series oscilloscope to 40GSa/s and 80000 Series oscilloscope to 20GSa/s.

- Update the limit for memory depth rate for spread-spectrum clocking tests for 90000
Series oscilloscope to T0Mpts to provide safety margin to match the with the memory
analysis limitation in Infinilum software.
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- Update the test pattern for TSG-02 Rise/Fall Time to LFTP with 8 Ul on screen.

- Update the reporting variables in TSG-03 Differential Skew tests to non-absolute values
for debugging purpose (“Tx+ Rising to Tx- Falling” and “Tx+ Falling to Tx- Rising”).
However the final compliance result formula still remains the same as intended by SATA-
10:

o Differential Skew = average(abs[(mean(TX+ rising)) — (mean(TX- falling))] +
abs[(mean(TX+falling)) - (mean(TX- rising))])

- Update the methodology and test point for x interface DUT in jitter tests from “at
connector” algorithm to “after CIC” algorithm.

- Update the Differential Output Voltage tests:
o Update the reporting statistics redundancy
o Update the histogram location from 0.5 Ul to 0.45 Ul - 0.55 Ul for Gen1.
o Fix the issue of inaccurate timebase for LBP waveform

- Remove the DC Coupled Common Mode Voltage test.

Bug Fixes

- Fixed the issue of timebase accuracy for x interface DUT in TSG-06 Amplitude Imbalance
tests.

- Fixed the issue of smearing in OOB OOB tests with 2GSa/s sampling rate limitation when
interpolation is turned off.

Known Issues

- In some very rare cases of OOB Transmit Burst and Gap Length tests, the desired COMINIT
and COMWAKE bursts are not easily captured (the probability of capturing is low) by using
automation due to OOB response inconsistencies. In such cases, the user should opt for
manual testing or retry manually.
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Agilent N5411A Software Version 2.60

Release Date: November 07, 2008

Requirements category (e.g., operating system): Microsoft Windows XP

Requirements category (e.g., minimum instrument software ~ 5.50 (80000 Series),

version):
1.30 (90000 Series)

File Name: SetupInfSATAII02600000.exe

New Features
- Supports SSC Optimization Memory Buffer for the last SSC acquisition (if required)

- Supports the Asynchronous Signal Recovery (ASR) for host DUT response
COMRESET/COMINIT/COMWAKE Gap Detection Windows tests and OOB Signal Detection
Threshold tests.

- Supports debug mode for OOB Signal Detection Threshold tests by sweeping down the
differential voltage level of the stimulus from a upper voltage level (Vthresh = 210mV) to
the voltage level where the first rejection or no response encountered.

Modification

- Minimum Infiniium Oscilloscope Software updated to version 5.50 for 80000 Series
oscilloscope.

- Minimum Infiniium Oscilloscope Software updated to version 1.30 for 90000 Series
oscilloscope.

- Update the configuration variable. Please refer to Programmer’s Reference for more details
(see Help > Remote Interface).

o “VthreshDebugResponsetolnconsistent” configuration variable is added.
o “HostASR” configuration variable is added.
o “DebugAmplitudelmbalance” configuration variable is added.

- Enhanced the OOB signal calibration acquisition to 100 acquisitions average for every
calibration target pair in 90000 Series oscilloscope.

- Split the Spread Spectrum Modulation Deviation into two tests:

o Spread Spectrum Modulation Deviation (Max)
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o Spread Spectrum Modulation Deviation (Min)
Split the Amplitude Imbalance test into two tests:

o Amplitude Imbalance HFTP

o Amplitude Imbalance MFTP

Update the test methodology for Amplitude Imbalance tests to Real Time Eye
implementation test for better match with SATA-I0 measurement definition and faster
execution speed.

Enhanced the comments field information for COMRESET/COMINIT/COMWAKE Gap
Detection Windows tests and OOB Signal Detection Threshold tests in the HTML report.

Bug Fixes

Fixed the issue of dialog box mismatch with the windows resolution of 640x480 for 80000
Series oscilloscope during calibration.

Fixed the issue of Advanced Communication Trigger not found error for the single ended
signals which is approximately below 200Vpp during the setup for any PHY tests or TSG
tests.

Fixed the issue of change connection dialog box hidden behind the SATAII application
during OOB-01 OOB Signal Detection Threshold tests.

Fixed the low pass filter smearing issue for COMRESET/COMINIT/COMWAKE Gap
Detection Windows tests and OOB Signal Detection Threshold tests by adding tolerance
for burst, gap and align length as a workaround.

Known Issues

Supports the 54855 and 80000A Series oscilloscope with limitation for the
COMRESET/COMINIT/COMWAKE Gap Detection Windows tests and OOB Signal Detection
Threshold tests due to the graphics limitation of older oscilloscope hardware. It is
recommended to use the 80000B Series or 90000 Series oscilloscopes with 12GHz and
above bandwidth.

In some very rare cases of OOB Transmit Burst and Gap Length tests, the desired COMINIT
and COMWAKE bursts are not easily captured (the probability of capturing is low) by using
automation due to OOB response inconsistencies. In such cases, the tester should opt for
manual testing.

In some very rare cases of COMRESET/COMINIT/COMWAKE Gap Detection Windows tests
and OOB Signal Detection Threshold tests, especially ‘Responds to in-spec COMWAKE’
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measurement, it is difficult to determine a valid response by using automation due to the
differences in SATA product behavior. In such cases, the tester should opt for manual
visual verification. This control is located in the N5411A application Configure tab, and is
called “O0OB Gap and Vthresh Detection Mode”. Select ‘Manual’. This will allow the tester
to determine either PASS or FAIL per the specification’s requirement and mark the
measurement correctly. This is not the default mode.
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Agilent N5411A Software Version 2.52

Release Date: May 30, 2008

Requirements category (e.g., operating system): Microsoft Windows XP

Requirements category (e.g., minimum instrument software ~ 5.40 (80000 Series),

version):
1.20 (90000 Series)

File Name: SetupInfSATAII02520000.exe

Modification

- Minimum Infiniium Oscilloscope Software updated to version 1.20 for 90000 Series
oscilloscope.

- Removed the long/short patterns configuration variable option in the Configure tab.
- Removed the additional COMRESET options in Configure tab.
- Moved the ‘#aligns’ option from compliance mode to debug mode in the Configure tab.

- Update the application to allow the use of either 2*10dB attenuators or 2*20dB
attenuators in the OOB signal calibration.

- Added retries to the Tx Differential Voltage tests in the event when the trigger fails in the
BIST-T mode.

- Added filtering to the glitches in Differential Skew tests at certain parallel edges which
results to double Ul reporting (e.g. 666ps).

- Enhanced the AC Common Mode Voltage test to be more robust in handling high AC
common mode spikes.

- Update the reset DUT message box for the OOB tests of host DUT.

- Increased the number of images that can be reported to the maximum of 25 images.

Bug Fixes
- Fixed the issue of missing MWArray.dll for Differential Skew tests.

- Fixed the issue of pulse pattern generator SICL address unable to close during certain
sequences.

- Fixed the issue of incorrect trigger for OOB tests by increasing the default OOB trigger
level to avoid triggering during power-up glitches.
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- Fixed the issue of display inconsistency for “Set DUT to OOB Mode” message box.

- Fixed the issue of missing calibration information for OOB Signal Detection Threshold tests.
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Agilent N94TTA Software Version 2.51

Release Date: February 29, 2008

Requirements category (e.g., operating system): Microsoft Windows XP

Requirements category (e.g., minimum instrument software ~ 5.40 (80000 Series),

version):
1.00 (90000 Series)

File Name: SetupInfSATAII02510000.exe

Modification

- Modified the connection diagram display logic to match the new attenuator configuration
requirements.

- Modified from previous implementation of: two 10dBs or four 10dBs attenuator (as
illustrated in the calibration diagram) to two 20dBs attenuator for Gen1 host/drive OOB
Signal Detection Threshold tests using attenuators checkbox is removed.

- Modified the drive OOB Signal Detection Threshold tests calibration procedure to use
amplitude voltage (VAmpt) measurement on one OOB Burst instead of peak to peak (Vpp)
measurement to take the corresponding voltages between the oscilloscope and pulse
pattern generator.

- Modified the Long Term Frequency Accuracy tests to acquire the maximum SSC cycles in
maximum memory available. The algorithm is generic to 80000 Series and 90000 Series
oscilloscope.

- Modified the Differential Skew test to Matlab implementation, where InfiniiScan is no
longer required. The previous implementation uses the InfiniiScan whenever available.

- Provided workaround on the DUTs that show trigger error messages and report unfound
signal when the histogram is turned on for 90000 Series oscilloscope.

Bug Fixes

- Fixed the issue of inconsistent results in Differential Skew tests.
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Agilent N5411TA Software Version 2.50

Release Date: January 11, 2008

Requirements category (e.g., operating system): Microsoft Windows XP

Requirements category (e.g., minimum instrument software ~ 5.40 (80000 Series),

version):
1.00 (90000 Series)

File Name: SetupInfSATAII02500000.exe

New Features

- Supports Infinilum Oscilloscope Software version 1.00 for 90000 Series oscilloscope.

- Supports for Serial ATA Interoperability Program Revision 1.2 Unified Test Document
Version 1.00.

- General Specifications and Transmitted Signal Requirements:
o Added periodic mode option for the Jitter Tests in the debug mode.
o Added Long Term Frequency Stability Test for the Non-SSC Tests

o Dynamic Test Pattern Generation with alignment to improve the Loopback
functionality

o Implemented Fbaud/500 or JTF Loop Bandwidth selection for the Clock to Data
Jitter Test. This selection is only available for i and m interfaces. Removed the
Data-Data Jitter Tests.

- Compliance Test Framework and miscellaneous:
o ECN 006 - FB10removal
o ECN 008 - fbaud/500 Jitter Parameter Clarification
o ECNOT6 - Long Term Frequency Accuracy and SSC Profile Tests for Transmitters
o ECN Q017 - OOB Burst/Gap Duration Clarification
o Supports the Remote Interface Control
o Calibration and attenuators usage options:
= With attenuators, all tests are available. Calibration factors which are

generated by performing the calibration will be required.
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= Without attenuators, the OOB Signal Detection Threshold tests will be
hidden.

Modification

Minimum Infiniium Oscilloscope Software updated to version 5.40 for 80000 Series
oscilloscope.

OOB Specifications:

o Amended the UTD1.2: OOBT1 Signal Detection Threshold boundary limits at 40mV,
210mV for Gen1, and 60mV, 210mV for Gen2

o Amended the UTD1.2: O0B6, OOBY:

= Implemented a new algorithm for the COMINIT/COMRESET/COMWAKE
Gap Detection Windows tests.

o Amended the OOB Burst Length Test Information and Specification to comply with
UTD1.2

o Amended OOB Gap Length Test Information and Specification to comply with
UTD1.2

o For Host COMRESET tests, an additional COMINIT is sent to the host after user
resets the DUT.

General Specifications and Transmitted Signal Requirements:

o Amended the specification range for the TX Differential Skew for Gen2x from 20ps
to 15ps.

o Reduced the SSC Measurement test time by
»= Disable interpolation
=  Sampling Rate = 10GSa/s
= Memory Depth = 1.03Mpts

o Amended the Amplitude Imbalance Test for the HFTP and MFTP patterns’
measurement algorithm.

= Forthe HFTP, it is required that the measurement points be taken at 0.5UlI
of the bit within the pattern. All amplitude values for this measurement
shall be the mode value measured at 0.5 Ul nominal over a minimum of
10,000 Ul
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= For the MFTP, it is required that the measurement points be taken at 0.5UlI
of the 2nd bit within the pattern. All amplitude values for this measurement
shall be the mode value measured at 0.5 Ul nominal over a minimum of
10,000 Ul

o Enhanced the “Sample Size” Configuration Variable to reflect the approximated
sample size values corresponding to the measured edges.

o Enhanced the Data Rate and Unit Interval Variables in the Unit Interval Test to be
able to correlate with each other.

o Decreased the sampling rate and memory depth for the SSC Tests to reduce the
test time and also prevent the waveforms from being discarded due to edges not
found during the SSC Frequency Measurement.

o Amended the Skew Test Algorithm by using the measured mid point value instead
of zero value reference to measure the skew. The new algorithm uses Infiniiscan,
effectively reject the Aligns whenever the Infiniiscan license exists.

o Amended the Rise/Fall Time measurement to use the mean value instead of the
mode value.

o Improved the Amplitude Imbalance Test reporting. The test reports both HFTP and
MFTP values instead of just the worst case value.

- Compliance Test Framework and miscellaneous:
o Improved the overall connectivity experience of the pulse generator dialog box.
o Added MultiTrials feature.

o Amended the pattern files to comply with the latest 81134 pulse generator
commands.

o Updated test references to SATA 2.60 Gold.
o Connection Diagram Updated

o Differential probe is not needed anymore for OOB Signal Threshold Detection Tests
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Agilent N54T1TA Software Version 2.0

Release

Date: December 18, 2006

Requirements category (e.g., operating system): Microsoft Windows XP

Requirements category (e.g., minimum instrument software ~ 5.00 (80000 Series)

version):

File Name: SetupInfSATAII02010000.exe

New Features

Supports user configurable output voltage for the 81134A pulse pattern generator under
debug mode. Please refer to Programmer’s Reference for more details (see Help > Remote
Interface).

Supports user configurable SSC smoothing point for the spread-spectrum clocking tests
under debug mode. Please refer to Programmer’s Reference for more details (see Help >
Remote Interface).

Supports signal checking and verification before test run.
Supports trigger verification for basic trigger integrity checking before the test run.
Supports Amplitude Imbalance tests.

Supports dynamic vertical scaling for OOB tests when using the mask for COM Response
tests.

Modification

Updated the connection pages to include the DC blockers into the illustration.

Enhanced SSC measurement algorithm to work with DUTs with heavily distorted SSC
waveform. The algorithm is also enhanced to test and measure multiple SSC if no edges
are found during the acquisitions.

Update the timing for OOB tests.
Added boundary limits to the number of Ul for OOB tests.
Rise/Fall Imbalance with results swapped for Tx- Rise and Tx- Fall.

Changed skew measurement technique due to MOI changes.
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- TJ/ DJ measurement will report OUI if the measured TJ / DJ is in the Femto Second
Range.

- Gen1 Jitter Description Data-Data was changed to Clock-Data.

- SSC smoothing point for Gen1 and Gen 2 SSC measurement was updated to 335 and 670
respectively.

- Added break for OOB measurement. The previous implementation was using a cancellation
message box which will prompt for 6 times before the test is canceled.

- Connection page changed to include COMAX connector labeling.

- Added checking to allow the usage of Periodic Jitter measurement if the pattern selected
is short ( 80 bits pattern ) whereas longer patterns will use Arbitrary.

- The entire host connection page had descriptions mismatched with the illustration. The
descriptions were updated.

Bug Fixes

- Fixed the issue of timeout for Gen 2 Host TJ & DJ tests.
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Agilent Nb5411A Software Version 2.00

Release Date: December 18, 2006

Requirements category (e.g., operating system): Microsoft Windows XP

Requirements category (e.g., minimum instrument software ~ 5.00 (80000 Series)
version):

File Name: SetupInfSATAII02000000.exe

Initial Release
© Keysight Technologies 2000-2023
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