
 

 

RELEASE NOTES 

 

 

D9040SASC 

Serial Attached SCSI - 4 

Compliance Test Application 
Keysight D9040SASC Software Version 4.21.0.0 

Release Date: February 2024 

Operating system: Microsoft Windows 10 

Minimum instrument software version: 11.50.00601 (UXR-Series) 

6.74.00402 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Minimum J-BERT firmware version: 7.10 

SAS3_EYEOPENING script version: 2.4.1 

File Name: SetupInfSAS404210000.exe 

License:  Please see the product data sheet on Keysight.com. 

Modifications 

- Enhanced vertical scaling in clipped signal condition. 

- Updated InstallShield prerequisite settings. 
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Keysight D9040SASC Software Version 4.20.4.0 

Release Date: April 2023 

Requirements Category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7 

Requirements Category (e.g., minimum instrument software 

version): 

11.25.00202 (UXR-Series) 

6.74.00402 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements Category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.4.1 

File Name: SetupInfSAS404200004.exe 

License:  Please see the product data sheet on Keysight.com. 

Modification 

- Update Keysight License Manager 5. 
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Keysight D9040SASC Software Version 4.20.0.0 

Release Date: March 2022 

Requirements Category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7 

Requirements Category (e.g., minimum instrument software 

version): 

11.25.00202 (UXR-Series) 

6.73.00102 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements Category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.4.1 

File Name: SetupInfSAS404200000.exe 

License:  Please see the product data sheet on Keysight.com. 

New Features 

- Supports UXR 2-Channels scope. 

Bug Fixes 

- Fixed the incorrect Vpp value measured in scope that happens intermittently in TX 

Maximum Noise During OOB Idle test. 

- Fixed the behavior to retrieve M8020A option correctly. 
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Keysight D9040SASC Software Version 4.11.0.0 

Released Date: January 2021 

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

10.25.00902 (UXR-Series) 

6.55.00504 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.4.1 

File Name: SetupInfSAS404110000.exe 

License:  Please see the product data sheet on Keysight.com. 

New Features 

- New version formatting. 

- Auto detect WDP pattern length. 

Bug Fixes 

- Fix the pattern string generated by M8040 with data rate 1.5Gbps in Waveform Distortion 

Penalty test. 

- Fix the issue to run with Channel 2&4 connection without Infiniisim license.  
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Keysight D9040SASC Software Version 4.10.0000 

Released Date: 18 October 2019 

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

10.11.04711 (UXR-Series) 

6.55.00504 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.4.1 

File Name: SetupInfSAS404100000.exe 

License:  Please see the product data sheet on Keysight.com. 

New Features 

- Supports test automation using M8040A stimulus. 
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Keysight D9040SASC Software Version 4.03.0001 

Released Date: 23 August 2019 

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

10.11.04711 (UXR-Series) 

6.40.01001 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.4.1 

File Name: SetupInfSAS404030001.exe 

License:  Please see the product data sheet on Keysight.com. 

New Features 

- Implementation of PPKS licensing feature. 

- Supports combination of channel 2 and channel 4 in OOB test. 

Modification 

- Decrease the default InfiniiScan pattern length check to improve triggering. 

Bug Fixes 

- Support Infiniisim (using channel) in the absence of Infiniisim license (DEA/DEB). 

Known Issue 

- There is no license found message when user clicks on Tools->Infiniium->InfiniiSim or 

Precision Prob if InfiniiSim & Precision Prob licenses are not available in the scope. 
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Keysight N5412E Software Version 4.02 

Released Date: 02 January 2019 

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

6.30.00701 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.4.1 

File Name: SetupInfSAS404020000.exe 

License:  Please see the product data sheet on Keysight.com. 

New Features 

- Supports user configurable InfiniiScan trigger for TX NRZ Data Signaling Requirements, TX 

Coefficient Requests and Circuit Response Requirements and TX Device End-to-End 

Simulation Characteristics Requirements tests via “Trigger Mode (TX NRZ Data Signaling 

Requirements)”, “Trigger Mode (TX Coefficient Requests and Circuit Response 

Requirements)” and “Trigger Mode (TX Device End-to-End Simulation Characteristics 

Requirements)” configuration variable respectively. Please refer to Programmer’s 

Reference for more details (see Help > Remote Interface). 

- Support RealEdge feature in scope Q-Series & Z-Series. 

Modification 

- Clear Display before starting Mask Test on OOB signal so that reacquisition is carried out. 

- Updated JTF parameters in 22.5Gbps for both SSC and non-SSC support. 

Bug Fixes 

- Fixed the issue of N4903B license checking. 
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Keysight N5412E Software Version 4.01 

Released Date: 30 October 2018 

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

6.30.00609 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.4.1 

File Name: SetupInfSAS404010000.exe 

License:  Please see the product data sheet on Keysight.com. 

New Features 

- Supports Infiniium Oscilloscope Software version 6.30. 

- Supports user configurable measurement threshold hysteresis level used in all SAS tests 

except TX OOB Signaling tests via “Measurement Threshold Hysteresis” configuration 

variable. Please refer to Programmer’s Reference for more details (see Help > Remote 

Interface). 

Modification 

- Updated the TX Peak-to-Peak Voltage, IT and TX Peak-to-Peak Voltage, ET (with .tf4 file) 

tests to use averaging when acquiring the waveform for 22.5 Gbps. 

- Added the TX Common Mode Spectrum tests for 22.5 Gbps. 

Bug Fixes 

- Fixed the “The path is not of a legal form” error in some of the oscilloscope. 

- Fixed the issue of long launching time and slow GUI response time when changing the bit 

rate. 

- Fixed the issue of pattern length check fail for PRBS15 with SSC enabled. 

- Fixed the issue of incorrect result for TX SSC DFDT tests due to the spikes exists in the UI 

measurement trend after the Low Pass Filter. 
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- Fixed the issue of the SICL error for TX Common Mode Spectrum tests if the common 

mode signal is large. 

Keysight N5412E Software Version 4.00 

Released Date: 4 September 2017 

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

6.00.01101 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.4.1 

File Name: SetupInfSAS404000000.exe 

License:  Please see the product data sheet on Keysight.com. 

New Features 

- Supports Serial Attached SCSI-4 (SAS-4) Specification Revision 09. 

- Supports Infiniium Offline.  

Modification 

- Renamed the test name of TX OOB Burst Amplitude Minimum to TX OOB Burst Amplitude 

Minimum (Zero-Length Test Load). 

- Added the Tx OOB Burst Amplitude Minimum (TCTF Test Load). 

Bug Fixes 

- Fixed the issue of incorrect pass limit and unit for Tx Common Mode Spectrum test. 

- Fixed the issue of unhandled exception while running the SAS3_EYEOPENING script. 

Note 

- Application’s project file saved for Keysight N5412D software version 3.15 and below will 

not be compatible with Keysight N5412E software. 
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- User-Defined Add-Ins must be recompiled with Keysight N5467A User Defined Application 

(UDA) tool version 3.10 and above to compatible with Keysight N5412E software version 

4.00. 

Keysight N5412D Software Version 3.15 

Released Date: 14 March 2017 

Requirements category (e.g., operating system): Microsoft Windows 10, Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

6.00.00537 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.4 

File Name: SetupInfSAS303150000.exe 

New Features 

- Supports Infiniium Oscilloscope Software version 6.00.  

- Supports for SAS3_EYEOPENING script and End-to-End simulation transfer function files 

Version 2.4 from Version 2.3. 

- Support waveform averaging for the TX Coefficient Requests and Circuit Response 

Requirements and TX Device End-to-End Simulation Characteristics Requirements. 

Modification 

- Updated the TX SSC DFDT (Min) test to include the screenshot. 

Bug Fixes 

- Fixed the OutOfMemoryException error issue during the run of the test or export the HTML 

results. 

- Fixed the issue of application terminate when deleting trial result. 

- Fixed the issue of the “InfiniiScan trigger not found” error. 

- Fixed the issue of “Index was outside the bounds of the array” when the user cancel the 

signal acquisition for long random test pattern  
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- Fixed the issue of Infiniium crashes when running the TX OOB Signaling tests with more 

than 6 bursts OOB signal.  

Keysight N5412D Software Version 3.14 

Released Date: 19 September 2016 

Requirements category (e.g., operating system): Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

5.70.00627 (90000 Series, 90000 X-Series, 90000 Q-

Series, V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.3 

File Name: SetupInfSAS303140000.exe 

New Features 

- Supports Infiniium Oscilloscope Software version 5.70. 

- Supports M8020A J-BERT (High Performance Serial BERT) as test pattern source. 

- Supports Infiniium user interface disabled feature during the run of the test. Please refer to 

Online Help for more details (see Help > Contents… > Running Tests > To Set the Run 

Preferences). 

Modification 

- Updated the acquisition sampling rate for TX NRZ Data Signaling Requirements from 40 

GSa/s to maximum sampling rate supported by the oscilloscope. 

o For 1.5 Gbps, 3.0 Gbps, 6.0 Gbps bit rate, the acquisition bandwidth will be default to 

16.8 GHz or the next higher allowed bandwidth if 80 GSa/s acquisition sampling rate 

is used. 

- Updated the 16 waveform average for TX Peak-to-Peak Voltage test for all bit rate. In 

previous version, the 16 waveform average for TX Peak-to-Peak Voltage test only apply for 

12.0 Gbps tests. The number of waveform average is configurable via “Average Count” 

(Averaging_TX_NRZData_VPP) configuration variable. Please refer to Programmer’s 

Reference for more details (see Help > Remote Interface). 

- Supports OOB signal with more than 6 bursts (6 bursts to 10 bursts). 
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Bug Fixes 

- Fixed the issue of incorrect result for TX Maximum Noise During OOB Idle if the OOB signal 

has fast transition time. Updated the zoom window to cover 98% (from 99%) of the OOB 

idle time for maximum noise measurement to prevent the OOB burst rise/fall edge 

included in the measurement. 

Note 

- Keysight recommends running the SAS application with Infiniium user interface disabled. 

Please refer to Online Help for more details (see Help > Contents… > Running Tests > To 

Set the Run Preferences). 
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Keysight N5412D Software Version 3.13.0001 

Released Date: 25 April 2016 

Requirements category (e.g., operating system): Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

5.60.0000 (90000 Series, 90000 X-Series, 90000 Q-Series, 

V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.3 

File Name: SetupInfSAS303130001.exe 

Bug Fixes 

- Fixed the issue of SAS3_EYEOPENING script unable to run. 
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Keysight N5412D Software Version 3.13 

Released Date: 5 April 2016 

Requirements category (e.g., operating system): Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

5.60.0000 (90000 Series, 90000 X-Series, 90000 Q-Series, 

V-Series, Z-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.3 

File Name: SetupInfSAS303130000.exe 

New Features 

- Supports Infiniium Oscilloscope Software version 5.60. 

- Supports Infiniium Oscilloscope Software version 5.60 for V-Series oscilloscope. 

- Supports user configurable default vertical range of the single-ended signal in all SAS 

tests except TX OOB Signaling tests via “Default Vertical Range” configuration variable 

under debug mode. Please refer to Programmer’s Reference for more details (see Help > 

Remote Interface). 

Modification 

- Updated the minimum Vpp of the single-ended signal during signal check from 100 mV to 

50 mV. 

Bug Fixes 

- Fixed the InfiniiSim and the InfiniiScan SICL command error when running the SAS 

application without the InfiniiSim or InfiniiScan licenses installed in the Infiniium. 

- Fixed the issue of InfiniiScan unable to trigger the signal when running the SAS application 

without InfiniiScan license. 

- Fixed the issue of SAS application unable to run the test with low amplitude signal. 

- Fixed the issue of FFT spectrum out of display screen for TX Common Mode Spectrum Test 

in Infiniium 5.60 and above due to the change in the FFT reference level. 
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- Fixed the issue of TX OOB Signaling tests unable to run with Infiniium version 5.60 and 

above. 
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Keysight N5412D Software Version 3.12 

Released Date: 10 April 2015 

Requirements category (e.g., operating system): Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

4.60 (90000 Series, 90000 X-Series, 90000 Q-Series, Z-

Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.3 

File Name: SetupInfSAS303120000.exe 

New Features 

- Supports Infiniium Oscilloscope Software version 5.50. 

- Supports Channel 2 and Channel 4 as the input channel connection for all Non-OOB 

Signaling tests. 

Modification 

- Updated the default sampling rate for TX Rise/Fall Time test to maximum sampling rate 

supported by the oscilloscope. 

- Remote Interface updated to version 3.40. For more information, see Keysight’s N5452A 

Remote Programming Toolkit (www.keysight.com/find/scope-apps). 

Bug Fixes 

- Fixed the issue of unable to set the “Tx Vpp, ET Test Method” in the Set Up tab using 

remote programming by rename the option “De-embedding File” to “De_embedding File”. 

- Fixed the issue of reference amplitude in TX Rise/Fall Time test base on the test 

methodology in UNH IOL document. 

- Fixed the issue of signal clipping in TX Common Mode RMS Voltage Limit test.  

- Fixed the SICL error issue of TX Waveform Distortion Penalty (WDP) test in Infiniium 5.00 

and above. 

- Fixed the issue of incorrect transfer function files loaded in TX Device End-to-End 

Simulation Characteristics Requirements tests. 

http://www.keysight.com/find/scope-apps
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- Fixed the issue of no waveform or measurement in the screenshot image of TX Spread 

Spectrum Clocking Requirement Test. 

- Fixed the issue of Infiniium application crashes while running the OOB signal validation 

using mask. 
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Agilent N5412D Software Version 3.11 

Released Date: 17 June 2014 

Requirements category (e.g., operating system): Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

4.60 (90000 Series, 90000 X-Series, 90000 Q-Series, Z-

Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.3 

File Name: SetupInfSAS303110000.exe 

New Features 

- Supports for Infiniium Oscilloscope Software version 4.60 for 90000 Z-Series oscilloscope. 

Bug Fixes 

- Fixed the issue in Infiniium Z- Series oscilloscopes. 
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Agilent N5412D Software Version 3.10 

Released Date: 2 June 2014 

Requirements category (e.g., operating system): Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

4.60 (90000 Series, 90000 X-Series, 90000 Q-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.3 

File Name: SetupInfSAS303100000.exe 

New Features 

- Supports Infiniium Oscilloscope Software version 5.00. 

- New Help > Support > Collect Files menu item simplifies collecting files needed by Agilent 

support engineers. 

Modification 

- Minimum Infiniium Oscilloscope Software updated to version 4.60. 
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Agilent N5412C Software Version 3.02 

Released Date: 9 May 2014 

Requirements category (e.g., operating system): Microsoft Windows XP 

Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

4.10.0008 (90000 Series, 90000 X-Series, 90000 Q-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.3 

File Name: SetupInfSAS303020000.exe 

New Features 

- Supports for Infiniium Oscilloscope Software version 4.10.0008 for 90000 Q-Series 

oscilloscope. 

- Supports for Serial Attached SCSI-3 (SAS-3) Specification Revision 06. 

- Supports for SAS3_EYEOPENING script and End-to-End simulation transfer function files 

Version 2.3. 

- Supports remote programming for the TX Coefficient Requests and Circuit Response test’s 

coefficient request selection using GenericMessageEvent.  

o Establish two-way channel using Agilent.Infiniium.AppFW.Remote.dll AteEventSink 

class by remote client. 

o Add the Even Handler for the GenericMessageEvent of the AteEventSink class: 

mAteEventSink.GenericMessageEvent += OnGenericMessage 

o Remote client will be called when the N5412C SAS Compliance Application required 

coefficient request. The OnGenericMessage handler will received an array: 

object[] { "Coefficient 1 Request", "Coefficient 2 Request", "Coefficient 3 Request" }  

o Remote client need to response to the N5412C SAS Compliance Application with the 

coefficient request needed. For example: 

private object[] OnGenericMessage(object[] data) 

{ 

if (data.Length == 3) 
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{ 

if ((data[0].ToString() == "Coefficient 1 Request") && (data[1].ToString() == 

"Coefficient 2 Request") && (data[2].ToString() == "Coefficient 3 Request")) 

{ 

return new object[] { "dec", "dec", "hold" }; 

} 

} 

return new object[0]; 

} 

- Added TX Peak-to-Peak Voltage, ET (with *.tf4 file) test to measure the peak-to-peak 

voltage at ET test point by de-embedding the transfer function file.  

- Added feature to export TX Coefficient Requests and Circuit Response test result into CSV 

file in the project folder. 

Modification 

- Updated the second order low pass filter’s frequency’s bandwidth for TX SSC Modulation 

Deviation test and TX SSC DFDT test. 

- Supports user configurable first order low pass filter’s bandwidth for TX Physical Link Rate 

Long Term Stability test. Please refer to Programmer’s Reference for more details (see 

Help > Remote Interface). 

- Supports user configurable acquisition averaging for TX Peak-to-Peak Voltage, IT test and 

TX Peak-to-Peak Voltage, ET (with *.tf4 file) test. Please refer to Programmer’s Reference 

for more details (see Help > Remote Interface). 

- Supports user selectable TX Peak-to-Peak Voltage, ET test method on Set Up tab. 

- Report K0 value for TX Coefficient Requests and Circuit Response test, Tx Pre-cursor 

Equalization Ratio (Rpre) test and Tx Post-cursor Equalization Ratio (Rpost) test. 

- Included the screenshot of waveform for TX Pre-cursor Equalization Ratio (Rpre) test, TX 

Post-cursor Equalization Ratio (Rpost) test, TX No Equalization Coefficient Preset test, TX 

Reference 1 Coefficient Preset test and TX Reference 2 Coefficient Preset test. 

- InfiniiSim now includes new Normalize Gain option. 

- When using BitifEye BIT2100 instrument for switch matrix, now requires minimum firmware 

version: 3.4-1.10. 

- Remote Interface updated to version 2.50. For more information, see Agilent’s N5452A 

Remote Programming Toolkit (www.agilent.com/find/scope-apps). 

http://www.agilent.com/find/scope-apps
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Bug Fixes 

- Fixed the issue of no result display for the TX Waveform Distortion Penalty (WDP) test. 

- Fixed the position of the dialog for TX Coefficient Requests and Circuit Response test.  

- Fixed Connection tab "Suppress" checkbox. 

Miscellaneous Notes 

- This will be the last version to support Infiniium Oscilloscope Software Version 4.20. 
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Agilent N5412C Software Version 3.01 

Released Date: 2 September 2013 

Requirements category (e.g., operating system): Microsoft Windows XP 

Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

4.10.0008 (90000 Series, 90000 X-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

SAS3_EYEOPENING script version 2.2 

File Name: SetupInfSAS303010000.exe 

New Features 

- Supports for Infiniium Oscilloscope Software version 4.10.0008 for 90000 MSOX-Series 

oscilloscope. 

- Supports for SAS3_EYEOPENING script and End-to-End simulation transfer function files 

Version 2.2. 

- Added the TX Peak-to-Peak Voltage, ET test to measure the peak-to-peak voltage at ET 

test point for minimum limit value. 

Modification 

- Supports 81134A test pattern source for 12.0Gbps bit rate DUT.  

- Change the low pass filter for Tx Physical Link Rate Long Term Stability from smoothing to 

Butterworth filter with configurable bandwidth. Please refer to Programmer’s Reference for 

more details (see Help > Remote Interface). 

- Remove the TX Pre-cursor Equalization Ratio (Rpre), Min and TX Post-cursor Equalization 

Ratio (Rpost), Min tests.  

- Remove the TX No Equalization Peak-to-peak Voltage (VHL), TX Reference 1 Peak-to-peak 

Voltage (VHL) and TX Reference 2 Peak-to-peak Voltage (VHL) tests. 

- Change the COMSAS OOB trigger mask to take into consideration of the negation time in 

the specification.  

- Preserves line breaks for “User Comments” field in HTML Report.  
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- Includes new Delay option in InfiniiSim. 

- New option to control jump behavior when user double-click a test name on the Select 

Tests tab. See View > Preferences > Report. 

- Remote Interface updated to version 2.40. For more information, see Agilent’s N5452A 

Remote Programming Toolkit (www.agilent.com/find/scope-apps). 

Bug Fixes 

- Fix the issue of SAS3_EYEOPENING script’s result by setting the auto correct error to true 

by default. 

  

http://www.agilent.com/find/scope-apps
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Agilent N5412C Software Version 3.00 

Released Date: 15 April 2013 

Requirements category (e.g., operating system): Microsoft Windows XP 

Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

4.10.0008 (90000 Series, 90000 X-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

File Name: SetupInfSAS303000000.exe 

New Features 

- Supports Serial Attached SCSI-3 (SAS-3) Specification Revision 05a. 

- New configuration variables (RJ Method, Jitter Pattern Length and etc.) added for the Tx 

Jitter test. Please refer to Programmer’s Reference for more details (see Help > Remote 

Interface). 

- User can now suppress connection prompts from the user interface (see Connect tab). 

- If a project opens as Read-Only and there are no settings conflicts with the current version 

of the app, user may use File > Save Project (Settings-Only) As…  menu item to extract the 

configuration (and no results) from that project. 

- If user creates the folder: 

o (Win7) C:\ProgramData\ Agilent\Infiniium\Apps\<app_name>\app\scripts 

o (WinXP) C:\Documents and Settings\All Users\Application 

Data\Agilent\Infiniium\Apps\<app_name>\app\scripts 

Then menu item File > Execute Script… becomes visible and enables user to pick a file to 

execute (e.g. Python or Visual Basic script). Scripts in this folder may also be executed via 

the Automation tab or remote interface. 

- HTML reports include probe info. 
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Modification 

- Minimum Infiniium Oscilloscope Software updated to version 4.10.0008. 

- Application’s project file saved for version 1.32 and below will be opened as read-only. 

- Supports for multiple SSC Modulation Type tests selections in single trial run. 

- Last location when saving/opening/exporting project/ files/etc. will be saved. 

- ARSL scripts supports for .txt file extension. 

- Last Test Date reported using international format. 

Bug Fixes 

- Fixed the issue of the histogram window in Tx Maximum Noise During OOB Idle test.  

o The histogram window’s top and bottom limit should be changed base on the Min and 

Max of the idle time instead of fixed value. 

- Fixed the issue of the histogram window in Tx OOB Offset Delta test. 

o The histogram window’s top and bottom limit should cover whole OOB burst instead 

of fixed value. 

- Fixed launch on Win7 for non-admin user. 

- Fixed statistics display for items in the Referenced Values section. 
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Agilent N5412B Software Version 1.32 

Released Date: 27 April 2012 

Requirements category (e.g., operating system): Microsoft Windows XP 

Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

3.21 (90000 Series, 90000 X-Series) 

Requirements category (e.g., minimum J-BERT firmware 

version): 

7.10 

File Name: SetupInfSAS201320000.exe 

New Features 

- Supports for N4903B J-BERT (High Performance Serial BERT) as stimulus source. 

Modification 

- Application’s project file saved for version 1.31 and below will be opened as read-only. 

- Remove the InfiniiSim button on Set Up tab. User may access Infiniium’s InfiniiSim feature 

through the main menu (see Tools > Infiniium > InfiniiSim). 

- Configuration variable for stimulus device has changed according to Table 1.32.1. Please 

refer to Programmer’s Reference for more details (see Help > Remote Interface). 

Table 1.32.1 

GUI 

Location 
Location 

Old 

Configuration 

Variable 

Old 

Configuration 

Values 

New 

Configuration 

Variable 

New 

Configuration 

Values 

Setup 
Stimulus 

Device 
Withpulsegen Yes,No StimulusDevice 

81134A, N4903B, 

None 

Setup cmbIPaddr cmbIPaddr 

(Accepts  

user-defined 

text) 

IP_Address 

(Accepts  

user-defined 

text) 

Setup cmbSicladdr cmbSicl 

(Accepts  

user-defined 

text) 

Sicl_Address 

(Accepts  

user-defined 

text) 

Setup optConnection optConnection 
none, pulsegen, 

pulsegenSicl 
optConnection 

None, PPG_IP, 

PPG_Sicl, 

JBERT_IP, 

JBERT_Sicl 
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Agilent N5412B Software Version 1.31 

Released Date: 20 January 2012 

Requirements category (e.g., operating system): Microsoft Windows XP 

Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

3.21 (90000 Series, 90000 X-Series) 

File Name: SetupInfSAS201310000.exe 

New Features 

- Supports Precision Probe and Precision Cable feature. Precision Probe and Precision Cable 

feature configuration setup can be accessed through the main menu (see Tools > Infiniium 

> PrecisionProbe/PrecisionCable). 

- Supports Bandwidth Limit feature for acquisition setup for all tests under Debug Mode. 

Bandwidth Limit feature can be access through the main menu (see Tools > Infiniium > 

Acquisition Setup).  

- Remote interface help and PDF files can be accessed through the main menu (see Help > 

Remote Interface).  

- New ‘Automation’ tab enables you to create command scripts that modify settings and 

execute tests.  

- New user preference to set default project location (Menu: View > Preferences > 

Save/Load: Default Location). 

Modification 

- Minimum Infiniium Oscilloscope Software updated to version 3.21. 

- TX WDP Test support for variable pattern length. 

- Optional way of access Infiniium’s InfiniiSim feature through the main menu (see Tools > 

Infiniium > InfiniiSim). 

- InfiniiSim and PrecisionProbe dialog screens now have tooltips and remote hints.  

- A calibration creation wizard is added to the PrecisionProbe dialog box.  

- Remote Interface updated to version 2.11. For more information, see Agilent’s N5452A 

Remote Programming Toolkit (www.agilent.com/find/scope-apps).  

http://www.agilent.com/find/scope-apps
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Bug Fixes 

- Fixed issue of unable to load saved waveform.  

- Fixed issue of no display of DFDT UDF in TX SSC DFDT test. 

- Fixed app startup under Windows Standard User login. 
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Agilent N5412B Software Version 1.30 

Released Date: 30 September 2011 

Requirements category (e.g., operating system): Microsoft Windows XP 

Microsoft Windows 7 

Requirements category (e.g., minimum instrument software 

version): 

3.10 (90000 Series, 90000 X-Series) 

File Name: SetupInfSAS201300000.exe 

New Features 

- Supports for Window 7 Infiniium oscilloscope. 

- Supports pattern verification for HFTP, MFTP, D30.3 (LFTP), CJTPAT test pattern. 

- Supports pattern verification (optionally) for Scramble 0 test pattern. Please refer to 

Programmer’s Reference for more details (see Help > Remote Interface). 

- Supports TX WDP test (This test required SASWDP.m script file and Matlab installed in 

oscilloscope). 

Modification 

- Minimum Infiniium Oscilloscope Software updated to version 3.10. 

- Removed the TX Physical Link Rate Long Term Frequency minimum test and maximum 

test. The TX Physical Link Rate Long Term Frequency mean test is maintained. 

- Included oscilloscope result panel as part of screen shot for test reported images. 

Bug Fixes 

– Fixed the BIST-L 6.0Gbps outputting 3.0Gbps signal issue. 

– Fixed the TX Rise/Fall Time measurement issue.  
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Agilent N5412B Software Version 1.10 

Released Date: 23 September 2010 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument software 

version): 

2.51 (90000 Series), 

2.95 (90000 X-Series) 

File Name: SetupInfSAS201100000.exe 

New Features 

- Supports Infiniium Oscilloscope Software version 2.95 for 90000 X-Series oscilloscope. 

- Supports notification splash screen when oscilloscope setup for non-OOB tests. 

Modification 

- Minimum Infiniium Oscilloscope Software updated to version 2.51 for 90000 Series 

oscilloscope. 

- Changed TX Rise/Fall Time specification from dynamic specification to static specification 

in accordance to SAS2.1r5. 

Bug Fixes 

- Fixed the clock data recovery settings for TX Spread Spectrum Clocking (SSC) 

Requirements tests. 

- Fixed the connection diagram prompt sequence logic issue. 

- Fixed the RJ result to be 14 times of RJ1sigma at 1E-12. 
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Agilent N5412B Software Version 1.00 

Released Date: 13 August 2010 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument software 

version): 

2.50.0003 (90000 Series) 

File Name: SetupInfSAS201000000.exe 

New Features 

- Supports SAS-2 6Gbps Physical Layer Test Suite Version 1.01 Clause 5. 

o TX OOB Signaling 

o TX Spread Spectrum Clocking (SSC) Requirements 

o TX NRZ Data Signaling Requirements 

- Supports InfiniiSim. 

- Supports different test pattern source mode: 

o BIST-Transmit Mode 

o BIST-Loopback Mode (Experimental) 

o Saved WFM Mode (Please refer to Help CHM for more details on the usage criteria) 

Modification 

- Minimum Infiniium Oscilloscope Software updated to version 2.50.0003 for 90000 Series 

oscilloscope. 

Miscellaneous Notes 

- Supports only 6 OOB bursts for TX OOB Signaling tests. 
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Agilent N5412A Software Version 1.60 

Released Date: 14 May 2010 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument software 

version): 

5.71 (80000 Series), 

2.10.0008 (90000 Series) 

File Name: SetupInfSAS01600000.exe 

Modification 

- Minimum Infiniium Oscilloscope Software updated to version 5.71 for 80000 Series 

oscilloscope. 

- Minimum Infiniium Oscilloscope Software updated to version 2.10.0008 for 90000 Series 

oscilloscope. 

- Changed device name selection: 

o “Drive”:  Equivalent to “Target” in SAS terminology 

o “Host”:  Equivalent to “Initiator” in SAS terminology 

- Removed OOB configure variables in configure tab that are no longer relevant after major 

OOB trigger change. 

- Changed Maximum Noise during OOB Idle Time Test in “IR & CR Device Test Point” to use 

the same algorithm as Maximum Transmitter Device Off Voltage Test. 

Bug Fixes 

- Fixed the OOB trigger issue with new behavior:  

o OOB response simulated on 81134A pulse pattern generator single channel amplitude 

sweep from 100mV to 2V.  

o Supports OOB response timing specification up to 1000ns gap between subsequent 

OOB signals. (Current implementation does not guarantee accurate trigger if OOB 

detection if OOB Burst response are less than 1000ns after each other. The 

implementation is tested on DUT with 500ms gap between subsequent OOB signal).  

o Display message box error if signal’s amplitude imbalance of more than 20% detected 

to avoid subsequent errors. 
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o Supports 2 different trigger method attempt for extracting COMINIT signal: 

▪ Pulse Pattern Generator YES: 

• Turning off the pulse pattern generator to acquire COMINIT from 

DUT (same as Pulse Pattern Generator NO) 

• If trigger method 1 cannot work, switch to method 2 by using pulse 

pattern generator to send stimulus to SAS DUT for response by 

outputting 320ns idle time COMINIT signals with 3200ns negation 

time between subsequent COMINIT(s) pattern. 

▪ Pulse Pattern Generator NO: 

• Does not use pulse pattern generator 

o Supports only 1 trigger method attempt for extracting COMSAS signal: 

▪ Pulse Pattern Generator YES: 

• Stimulate the DUT for response by outputting 320ns idle time 

COMINIT signals with 3200ns negation time between subsequent 

COMINIT(s) pattern. 

o Supports only 1 trigger method attempt for extracting COMWAKE signal:  

▪ Pulse Pattern Generator YES: 

• Simulate the DUT for response by outputting 320ns idle time 

COMINIT signals with 3200ns negation time between subsequent 

COMINIT(s) pattern. 

o Supports variable OOB output amplitude from DUT. 

o Does not support OOB single ended signal phenomena below as the advanced trigger 

mode might mistake the sharp spike as part of the OOB signal: 
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- There is a chance that the application detecting the OOB signal if some OOB stream 

portion does not have the spike shown above. If this is the case, the tester should try to re-

run the test again.  

- Fixed HTML report header by removing the PulseGen header field. 

Miscellaneous Notes 

- This will be the last version to support 80000 Series oscilloscope. 
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Agilent N5412A Software Version 1.51 

Released Date: 17 March 2008 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument software 

version): 

5.40 (80000 Series), 

1.00 (90000 Series) 

File Name: SetupInfSAS01510000.exe 

Bug Fixes 

- Fixed the issue of application hangs when restoring the oscilloscope settings upon exiting 

the application. 
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Agilent N5412A Software Version 1.50 

Released Date: 11 January 2008 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument software 

version): 

5.40 (80000 Series) 

1.00 (90000 Series) 

File Name: SetupInfSAS01500000.exe 

New Features 

- Supports Infiniium Oscilloscope Software version 1.00 for 90000 Series oscilloscope. 

- Added the OOB signals idle time tests. 

Modification 

- Minimum Infiniium Oscilloscope Software updated to version 5.40 for 80000 Series 

oscilloscope. 

Bug Fixes 

- Fixed the connection diagrams for the OOB and signaling tests. 
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Agilent N5412A Software Version 1.01 

Released Date: 19 January 2006 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument software 

version): 

4.21 (80000 Series) 

File Name: SetupInfSAS01010000.exe 

New Features 

- Supports Infiniium Oscilloscope Software version 5.02 for 80000 Series oscilloscope. 

Bug Fixes 

- Fixed the timeout issue for the rise/fall/skew group of test. 

- Fixed the test description error for the rise/fall/skew group of test. 

  



 

 

 

39 / 39 Keysight D9040SASC Serial Attached SCSI - 4 Compliance Test Application Release Notes 

Agilent N5412A Software Version 1.00 

Released Date: 19 January 2006 

Requirements category (e.g., operating system): Microsoft Windows XP 

Requirements category (e.g., minimum instrument software 

version): 

4.21 (80000 Series) 

File Name: SetupInfSAS01000000.exe 

Initial Release 
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