Installation

How to Install Code Conversion Assistant

Note: This download includes Zipped files. You must have the necessary software to Unzip these files.

Install Code Conversion Assistant

  1. On the download page, click Agilent NA Code Conversion Assistant

  2. Click Save this Program to disk, then click OK

  3. Save the file to your PC desktop

  4. On your desktop, double-click NACCA.exe to Unzip this file.

  5. Extract the zipped files to your PC desktop.

  6. On your desktop, double-click AgtCCA.msi to start the installation.

  7. Click Next to accept the default settings.

  8. On your desktop, double-click EME328e.exe

  9. Follow the prompts to install EMEditor v3.

  10. On your desktop, double-click 8753_PNAro10.zip or the 8510_PNAro10.zip.

  11. Unzip the 4 .esy files to C:\Program Files\ EMEditor3

  12. You can delete the 4 files (NACCA.exe, AgtCCA.msi, 8753_PNAro96.zip, 8510_PNAro1.00.zip) from your desktop.

Configure EmEditor v3 with Code Conversion Assistant

Note EmEditor is third-party shareware. If you continue using EmEditor v3 more than 30 days, you must register your copy.

  1. On your Windows Taskbar, click Start, point to Programs, then click EmEditor v3

  2. In EmEditor, click Tools then Properties for Current Configuration

  3. Select Highlight (1) tab.

  4. Click Import

  5. Click Browse and navigate to C:\Program files\EmEditor.

  6. Select the .esy file that corresponds with the programming environment of your test program to be converted.

Code Converter Assistant will ignore 87xx / 8510 commands within commented lines of code. This selection remains the next time you run the conversion assistant. To change this setting:

  • Click Reset

  • Select Reset to default, then click OK

For more information see Using Code Conversion Assistant

See Also:

  • 8753 Cross-Reference

  • PNA SCPI Commands


Using Code Conversion Assistant

Using Network Analyzer Code Conversion Assistant

Network Analyzer Code Conversion Assistant is a software tool that helps you convert your 875x, 872x, and 8510 test programs into PNA programs. After you load your test program into Code Conversion Assistant, it recognizes the 87xx/8510 commands and color-codes the level of 'convertablilty'. Blue commands are easily replaced for you. Yellow command replacements are more complicated - Code Conversion Assistant will help you in the conversion. Red commands have no PNA equivalent.

  • Configure Code Conversion Assistant

  • Load the 87xx/8510 File

  • How to Replace Commands

  • Conversion Settings

Note: For more help, see the PNA Help files: SCPI Command Tree and 8753 Command Finder.

Configure Code Conversion Assistant

  1. Run EmEditor.

  2. In EmEditor, click Tools, then Properties for Current Configuration

  3. Select Highlight (1) tab.

  4. Click Import.

  5. Code Converter Assistant will ignore 87xx/8510 commands within commented lines of code. Select one of the following data files that corresponds to your 87xx/8510 program language. This selection remains the next time you run the conversion assistant.

    • PNA_8753_c++_ro10.esy or PNA_8510_c++_ro10.esy - C++

    • PNA_8753_rmb_ro10.esy or PNA_8510_c++_ro10.esy - HP BASIC

    • PNA_8753_vb_ro10.esy or PNA_8510_c++_ro10.esy - Visual Basic

    • PNA_8753_ro10.esy or PNA_8510_ro10.esy - Generic

To change this setting, first reset the current selection.

    • Click Reset

    • Select Reset to default, then click OK

Load the Program File

Load the 87xx / 8510 program file to be converted to PNA code. This file must be in Text format.

  1. Under the File menu click Open

  2. Navigate to, and select, the 87xx / 8510 file.

  3. Click Open

The Code Converter highlights the 87xx / 8510 GPIB commands using the following colors:

  • Blue Easy conversion

  • Yellow Some consideration is required for conversion.

  • Red The PNA does NOT have an equivalent function.

  • Green After code is replaced, these user-selected parameters must be entered manually.

How to Replace Commands

To replace code, click the NA icon

If the NA icon is not displayed, right-click any toolbar. Then click Plug-ins bar

Agilent NWA Code Conversion Assistant dialog box help

87xx / 8510 Command to be converted.

Highlight Check to highlight all of the 87xx / 8510 commands in your test program.

Function Overview Description of the 87xx / 8510 command.

PNA Description of the PNA command(s) to replace the 87xx / 8510 command.

87xx / 8510 Channel Shows available channels for replacement. To make more channels available, click Setup.

Convert Option 'Yellow' 87xx / 8510 commands can have more than one potential PNA replacement as shown in the dialog box above. Select the option you would like to use in the conversion.

Setup Invokes the following Setup dialog box

Find Next Does not convert the current command but moves to the next 87xx / 8510 command to be converted.

Convert Converts the current command and moves to the next 87xx / 8510 command to be converted.

Convert All ClassA Code You can select a range of commands to convert. When a range is selected, click to convert all the ClassA ( Blue ) commands; 'Yellow' commands are ignored.

Conversion Settings

To access these settings, click Setup on the previous dialog box.

Conversion Settings (Setup) dialog box help

The 8753ES and PNA use channels differently. The following settings determine how Code Converter will convert 87xx / 8510 channel usage into the PNA code. The field to the right of the checkboxes indicates the results of your selections.

Coupled Chan Check if the 87xx / 8510 stimulus between channel 1 and 2 is coupled. Both channel 1 and channel 2 settings will convert to channel 1 in the PNA code.

Aux Chan1 Check if channel 3 (the auxiliary channel of the channel 1) is enabled. Default is NOT checked.

Aux Chan2 Check if channel 4 (the auxiliary channel of the channel 2) is enabled. Default is NOT checked.

Conversion Symbol Adds text to the end of lines that have been converted. Include the comment symbol for your programming language. For example, type the following in the text box to add to it to the end of all lines to be converted: !< PNA >

Default Reverts all settings to their defaults.

Conversion Table Select the Network Analyzer code to convert your test program to: ENA or PNA.

See Also:

  • 8753 Cross-Reference

  • PNA SCPI Commands


SCPI Command Tree

IEEE- 488.2 Common Commands

ABORt

Stops all sweeps

CALCulate __Click to hide CALC commands

:CORRection

Sets Electrical Delay and Phase Offset

:DATA

Sends and queries data.

:FILTer

Sets time domain gating

:FORMat

Sets the display format

:FUNCtion

Controls Trace Statistics

:LIMit

Controls limit lines for pass / fail testing

:MARKer

Controls the marker settings

:MATH

Performs math on the memory trace

:NORMalize

Specifies the normalization features used for a receiver power calibration

:PARameter

Creates and deletes measurements

:RDATa?

Queries receiver data

:SMOothing

Controls point-to-point smoothing

:TRANsform

Controls time domain transform settings

CONTrol

Controls the rear-panel connectors

DISPlay

Controls the display settings

FORMat

Sets the format for data transfer

HCOPy

Controls hardcopy printing

INITiate

Sets continuous or manual triggering

MMEMory

Saves and recalls instrument states

OUTPut

Turns RF power ON and OFF

SENSe __Click to hide SENSe commands

:AVErage

Sets sweep averaging parameters

:BANDwidth

Specifies the IF filter bandwidth

:CORRection

Provides non-guided calibration capability

:CORR:COLL:CKIT

Defines calibration standards

:CORR:CSET

Manages Cal Sets

:CORR:GUIDed

Provides Guided calibration capability

:COUPle

Sets sweep as Chopped or Alternate

:FREQuency

Controls frequency sweep functions

:POWer

Sets receiver attenuation and overpower protection

:ROSCillator

Returns the source of the reference oscillator.

:SEGMent

Defines the segment sweep settings.

:SWEep

Specifies the sweep modes of the analyzer.

SOURce

Controls the power to the DUT

SOURce:POWer

Provides for Source Power Correction

STATus

Reads the analyzer status registers

SYSTem

Controls the analyzer defaults

TRIGger

Starts or ends a measurement


SCPI List

List of PNA SCPI Commands

Click on a command for details

COMMON COMMANDS

*CLS - Clear Status

*ESE - Event Status Enable

*ESE? - Event Status Enable Query

*ESR - Event Status Enable Register

*IDN? - Identify

*OPC - Operation complete command

*OPC? - Operation complete query

*OPT? - Identify Options Query

*RST - Reset

*SRE - Service Request Enable

*SRE? - Service Request Enable Query

*STB? - Status Byte Query

*TST? - Result of Self-test Query

*WAI - Wait

ABORT Command

ABORt

CALC:CORRECTION Commands

CALCulate<cnum>:CORRection:EDELay:TIME <num>

CALCulate<cnum>:CORRection:OFFSet[:MAGNitude] <num>

CALCulate<cnum>:CORRection:OFFSet:PHASe <num>[<char>]

CALC:DATA Commands

CALCulate<cnum>:DATA <char>

CALCulate<cnum>:DATA:CUSTom <name>,<data>

CALCulate<cnum>:DATA:CUSTom:CATalog?

CALC:FILTER Commands

CALCulate<cnum>:FILTer[:GATE]:TIME:CENTer <num>

CALCulate<cnum>:FILTer[:GATE]:TIME:SHAPe <char>

CALCulate<cnum>:FILTer[:GATE]:TIME:SPAN <num>

CALCulate<cnum>:FILTer[:GATE]:TIME:STATe <boolean>

CALCulate<cnum>:FILTer[:GATE]:TIME:STARt <num>

CALCulate<cnum>:FILTer[:GATE]:TIME:STOP <num>

CALCulate<cnum>:FILTer[:GATE]:TIME[:TYPE] <char>

CALC:FORMAT Command

CALCulate<cnum>:FORMat <char>

CALC:FUNCTION Commands

CALCulate<cnum>:FUNCtion:DATA?

CALCulate<cnum>:FUNCtion:DOMain:USER[:RANGe] <range>

CALCulate<cnum>:FUNCtion:DOMain:USER:STARt <range>, <start>

CALCulate<cnum>:FUNCtion:DOMain:USER:STOP <range>, <stop>

CALCulate<cnum>:FUNCtion:STATistics[:STATe] <ON|OFF>

CALCulate<cnum>:FUNCtion:TYPE <char>

CALC:LIMIT Commands

CALCulate<cnum>:LIMit:DATA <block>

CALCulate<cnum>:LIMit:DISPlay[:STATe] <ON | OFF>

CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STARt <num>

CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STOP <num>

CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STARt <num>

CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STOP <num>

CALCulate<cnum>:LIMit:SEGMent<snum>:TYPE <char>

CALCulate<cnum>:LIMit:SOUNd[:STATe] <ON | OFF>

CALCulate<cnum>:LIMit:STATe <ON | OFF>

CALC:MARKER Commands

CALCulate<cnum>:MARKer:AOFF

CALCulate<cnum>:MARKer:BWIDth <num>

CALCulate<cnum>:MARKer<mkr>:COUPling[:STATe]<ON|OFF>

CALCulate<cnum>:MARKer<mkr>:DELTa <ON|OFF>

CALCulate<cnum>:MARKer<mkr>:DISCrete <ON|OFF>

CALCulate<cnum>:MARKer<mkr>:FORMat <char>

CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:EXCursion <num>

CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:THReshold <num>

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER <range>

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STARt <start>

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STOP <stop>

CALCulate<cnum>:MARKer<mkr>:FUNCtion:EXECute [<func>]

CALCulate<cnum>:MARKer<mkr>:FUNCtion[:SELect] <char>

CALCulate<cnum>:MARKer<mkr>:TARGet <num>

CALCulate<cnum>:MARKer<mkr>:FUNCtion:TRACking <ON | OFF>

CALCulate<cnum>:MARKer:REFerence[:STATe] <ON | OFF>

CALCulate<cnum>:MARKer:REFerence:X <num>

CALCulate<cnum>:MARKer:REFerence:Y?

CALCulate<cnum>:MARKer<mkr>:TYPE <char>

CALCulate<cnum>:MARKer<mkr>:SET <char>

CALCulate<cnum>:MARKer<mkr>[:STATe] <ON|OFF>

CALCulate<cnum>:MARKer<mkr>:X <num>

CALCulate<cnum>:MARKer<mkr>:Y?

CALC:MATH Commands

CALCulate<cnum>:MATH:FUNCtion <char>

CALCulate<cnum>:MATH:MEMorize

CALC:NORMALIZE Commands

CALCulate<cnum>:NORMalize[:IMMediate]

CALCulate<cnum>:NORMalize:STATe <ON | OFF>

CALCulate<cnum>:NORMalize:INTerpolation[:STATe] <ON | OFF>

CALC:PARAMETER Commands

CALCulate<cnum>:PARameter:CATalog?

CALCulate<cnum>:PARameter:DEFine <Mname>,<param>[,load]

CALCulate<cnum>:PARameter:DELete <Mname>

CALCulate<cnum>:PARameter:DELete:ALL

CALCulate<cnum>:PARameter:SELect <Mname>

CALC:RDATA Commands

CALCulate<cnum>:RDATA? <char>

CALC:SMOOTHING Commands

CALCulate<cnum>:SMOothing:APERture <num>

CALCulate<cnum>:SMOothing:POINts <num>

CALCulate<cnum>:SMOothing[:STATe] <ON | OFF>

CALC:TRANSFORM Commands

CALCulate<cnum>:TRANsform:TIME:CENTer <num>

CALCulate<cnum>:TRANsform:TIME:IMPulse:WIDTh <num>

CALCulate<cnum>:TRANsform:TIME:KBESsel <num>

CALCulate<cnum>:TRANsform:TIME:LPFREQuency

CALCulate<cnum>:TRANsform:TIME:SPAN <num>

CALCulate<cnum>:TRANsform:TIME:STARt <num>

CALCulate<cnum>:TRANsform:TIME:STATe <ON | OFF>

CALCulate<cnum>:TRANsform:TIME:STOP <num>

CALCulate<cnum>:TRANsform:TIME:STEP:RTIMe <num>

CALCulate<cnum>:TRANsform:TIME:STIMulus <char>

CALCulate<cnum>:TRANsform:TIME[:TYPE] <char>

CONTROL Commands

CONTrol:AUXiliary:C[:DATA] <num>

CONTrol:AUXiliary:C:LOGic <char>

CONTrol:AUXiliary:C:MODE <char>

CONTrol:AUXiliary:FOOTswitch?

CONTrol:AUXiliary:FOOTswitch:MODE <char>

CONTrol:AUXiliary:INPut:VOLTage?

CONTrol:AUXiliary:OUTPut<out>:MODE <char>

CONTrol:AUXiliary:OUTPut<out>:Voltage <num>

CONTrol:AUXiliary:PASSfail:LOGic <char>

CONTrol:AUXiliary:PASSfail:MODe <char>

CONTrol:AUXiliary:PASSfail:SCOPe <char>

CONTrol:AUXiliary:SWEepend <char>

CONTrol:EXTernal:TESTset:DATa <addr>,<data>

CONTrol:EXTernal:TESTset:INTerrupt?

CONTrol:EXTernal:TESTset:RAWData <data>

CONTrol:EXTernal:TESTset:SWEepholdoff?

CONTrol:HANDler:C:MODE <char>

CONTrol:HANDler:D:MODE <char>

CONTrol:HANDler:<port>[:DATa] <num>

CONTrol:HANDler:INPut?

CONTrol:HANDler:LOGic <char>

CONTrol:HANDler:OUTPut<num>[:DATa] <num2>

CONTrol:HANDler:OUTPut<num>:USER[:DATa] <num2>

CONTrol:HANDler:PASSfail:LOGic <char>

CONTrol:HANDler:PASSfail:MODe <char>

CONTrol:HANDler:PASSfail:SCOPe <char>

CONTrol:HANDler:SWEepend <char>

CONTrol:SIGNal <conn>,<char>

DISPLAY Commands

DISPlay:ANNotation:FREQuency[:STATe] <ON | OFF>

DISPlay:ANNotation:MESSage:STATe <ON | OFF>

DISPlay:ANNotation:STATus <ON|OFF>

DISPlay:CATalog?

DISPlay:ENABLE <ON | OFF>

DISPlay[:TILE]

DISPlay:WINDow<wnum>:ANNotation:MARKer:SINGle[:STATe] <bool>

DISPlay:WINDow<wnum>:ANNotation:MARKer:SIZE <char>

DISPlay:WINDow<wnum>:ANNotation:MARKer:STATe <ON|OFF>

DISPlay:WINDow<wnum>:ANNotation:TRACe:STATe <ON|OFF>

DISPlay:WINDow<wnum>:CATalog?

DISPlay:WINDow<wnum>:ENABle <ON | OFF>

DISPlay:WINDow<wnum>[:STATe] <ON | OFF>

DISPlay:WINDow<wnum>:TABLe <char>

DISPlay:WINDow<wnum>:TITLe:DATA <string>

DISPlay:WINDow<wnum>:TITLe[:STATe] <ON | OFF>

DISPlay:WINDow<wnum>:TRACe<tnum>:DELete

DISPlay:WINDow<wnum>:TRACe<tnum>:FEED <name>

DISPlay:WINDow<wnum>:TRACe<tnum>MEMory[:STATe] <ON | OFF>

DISPlay:WINDow<wnum>:TRACe<tnum>:SELect

DISPlay:WINDow<wnum>:TRACe<tnum>[:STATe] <ON | OFF>

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:AUTO

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:PDIVision <num>

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RLEVel <num>

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RPOSition <num>

FORMAT Commands

FORMat:BORDer <char>

FORMat[:DATA] <char>

HARDCOPY Command

HCOPy[:IMMediate]

INITIATE Commands

INITiate:CONTinuous <boolean>

INITiate<cnum>[:IMMediate]

MMEMORY Commands

MMEMory:CATalog[:<char>]? [<folder>]

MMEMory:CDIRectory <folder>

MMEMory:COPY <file1>,<file2>

MMEMory:DELete <file>

MMEMory:LOAD[:<char>] <file>

MMEMory:MDIRectory <folder>

MMEMory:MOVE <file1>,<file2>

MMEMory:RDIRectory <folder>

MMEMory:STORe[:<char>] <file>

OUTPUT Command

OUTPut[:STATe] <ON | OFF>

SENS:AVERAGE Commands

SENSe<cnum>:AVERage:CLEar

SENSe<cnum>:AVERage:COUNt <num>

SENSe<cnum>:AVERage[:STATe] <ON | OFF>

SENSE:BANDWIDTH Command

SENSe<cnum>:BANDwidth | BWIDth[:RESolution] <num>

SENSE:CORRECTION Commands

SENSe<cnum>:CORRection:CCHeck[:ACQuire] <char>

SENSe<cnum>:CORRection:CCHeck:DONE

SENSe<cnum>:CORRection:CCHeck:PARameter <Mname>

SENSe<cnum>:CORRection:COEFficient <term>[,port]

SENSe<cnum>:CORRection:COLLect[:ACQuire] <char>[,char]

SENSe<cnum>:CORRection:COLLect:APPLy

SENSe<cnum>:CORRection:COLLect:METHod <char>

SENSe<cnum>:CORRection:COLLect:SAVE

SENSe<cnum>:CORRection:EXTension:PORT<pnum>[:TIME] <num>

SENSe<cnum>:CORRection:EXTension:RECeiver<Rnum>[:TIME] <num>

SENSe<cnum>:CORRection:EXTension[:STATe] <ON | OFF>

SENSe:CORRection:IMPedance:INPut:MAGNitude <num>

SENSe<cnum>:CORRection:INTerpolation[:STATe] <ON | OFF>

SENSe<cnum>:CORRection:ISOLation[:STATe] <ON | OFF>

SENSe<cnum>:CORRection:RVELocity:COAX <num>

SENSe:CORRection:SFORward[:STATe] <boolean>

SENSe<cnum>:CORRection[:STATe] <ON | OFF>

SENSe:CORRection:TSTandards[:STATe] <boolean>

SENSE:CORRECTION:COLLECT:CKIT Commands

SENSe:CORRection:COLLect:CKIT:NAME <name>

SENSe:CORRection:COLLect:CKIT:OLIST[class]?

SENSe:CORRection:COLLect:CKIT:ORDer<class> <std> [,<std>] [,<std>] [,<std>] [,<std>] [,<std>] [,<std>]

SENSe:CORRection:COLLect:CKIT:RESet <num>

SENSe:CORRection:COLLect:CKIT[:SELect] <num>

SENSe:CORRection:COLLect:CKIT:STANdard:C0 <num>

SENSe:CORRection:COLLect:CKIT:STANdard:C1 <num>

SENSe:CORRection:COLLect:CKIT:STANdard:C2 <num>

SENSe:CORRection:COLLect:CKIT:STANdard:C3 <num>

SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter <char>

SENSe:CORRection:COLLect:CKIT:STANdard:DELay <num>

SENSe:CORRection:COLLect:CKIT:STANdard:FMAX <num>

SENSe:CORRection:COLLect:CKIT:STANdard:FMIN <num>

SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance <num>

SENSe:CORRection:COLLect:CKIT:STANdard:L0 <num>

SENSe:CORRection:COLLect:CKIT:STANdard:L1 <num>

SENSe:CORRection:COLLect:CKIT:STANdard:L2 <num>

SENSe:CORRection:COLLect:CKIT:STANdard:L3 <num>

SENSe:CORRection:COLLect:CKIT:STANdard:LABel <name>

SENSe:CORRection:COLLect:CKIT:STANdard:LOSS <num>

SENSe:CORRection:COLLect:CKIT:STANdard[:SELECT] <num>

SENSe:CORRection:COLLect:CKIT:STANdard:TYPE <char>

SENSE:CORRECTION:CSET Commands

SENSe<cnum>:CORRection:CSET:CATalog?

SENSe<cnum>:CORRection:CSET:DELete <string>

SENSe<cnum>:CORRection:CSET:DESCription <string>

SENSe<cnum>:CORRection:CSET:GUID <string>

SENSe<cnum>:CORRection:CSET[:SELect] <char>

SENSe<cnum>:CORRection:CSET:SAVE <char>

SENSE:CORRECTION:COLLECT:GUIDED Commands

SENSe<cnum>:CORRection:COLLect:GUIDed:ACQuire <std>

SENSe<cnum>:CORRection:COLLect:GUIDed:CKIT:PORT<pnum>:CATalog?

SENSe<cnum>:CORRection:COLLect:GUIDed:CKIT:PORT<pnum>[:SELect] <kit>

SENSe<cnum>:CORRection:COLLect:GUIDed:CONNector:CATalog?

SENSe<cnum>:CORRection:COLLect:GUIDed:CONNector:PORT<pnum>[:SELect] <conn>

SENSe<cnum>:CORRection:COLLect:GUIDed:DESCription? <step>

SENSe<cnum>:CORRection:COLLect:GUIDed:INITiate

SENSe<cnum>:CORRection:COLLect:GUIDed:METHod

SENSe<cnum>:CORRection:COLLect:GUIDed:SAVE

SENSe<cnum>:CORRection:COLLect:GUIDed:STEPs?

SENSE:COUPLE Command

SENSe<cnum>:COUPle <ALL | NONE>

SENSE:FREQUENCY Commands

SENSe<cnum>:FREQuency:CENTer <num>

SENSe<cnum>:FREQuency[:CW |:FIXed] <num>

SENSe<cnum>:FREQuency:SPAN <num>

SENSe<cnum>:FREQuency:STARt <num>

SENSe<cnum>:FREQuency:STOP <num>

SENSE:POWER Command

SENSe<cnum>:POWer:ATTenuation <recvr>,<num>

SENSE:ROSCILLATOR Command

SENSe:ROSCillator:SOURce?

SENSE:SEGMENT Commands

SENSe<cnum>:SEGMent<snum>:ADD

SENSe<cnum>:SEGMent<snum>:BWIDth[:RESolution] <num>

SENSe<cnum>:SEGMent:BWIDth[:RESolution]:CONTrol <ON | OFF>

SENSe<cnum>:SEGMent:COUNt?

SENSe<cnum>:SEGMent<snum>:DELete

SENSe<cnum>:SEGMent:DELete:ALL

SENSe<cnum>:SEGMent<snum>:FREQuency:CENTer <num>

SENSe<cnum>:SEGMent<snum>:FREQuency:SPAN <num>

SENSe<cnum>:SEGMent<snum>:FREQuency:START <num>

SENSe<cnum>:SEGMent<snum>:FREQuency:STOP <num>

SENSe<cnum>:SEGMent<snum>:POWer[<port>][:LEVel] <num>

SENSe<cnum>:SEGMent:POWer[:LEVel]:CONTrol <ON | OFF>

SENSe<cnum>:SEGMent<snum>[:STATe] <ON | OFF>

SENSe<cnum>:SEGMent<snum>:SWEep:POINts <num>

SENSe<cnum>:SEGMent<snum>:SWEep:TIME <num>

SENSe<cnum>:SEGMent:SWEep:TIME:CONTrol <ON | OFF>

SENSE:SWEEP Commands

SENSe<cnum>:SWEep:DWELl <num>

SENSe<cnum>:SWEep:DWELl:AUTO <ON | OFF>

SENSe<cnum>:SWEep:GENeration <char>

SENSe<cnum>:SWEep:GROups:COUNt <num>

SENSe<cnum>:SWEep:MODE <char>

SENSe<cnum>:SWEep:POINts <num>

SENSe<cnum>:SWEep:SRCPort <1 | 2>

SENSe<cnum>:SWEep:TIME <num>

SENSe<cnum>:SWEep:TIME:AUTO <ON | OFF>

SENSe<cnum>:SWEep:TRIGger:POINt <ON | OFF>

SENSe<cnum>:SWEep:TYPE <char>

SOURCE Commands

SOURce<cnum>:POWer<port>:ATTenuation <num>

SOURce<cnum>:POWer<port>:ATTenuation:AUTO <ON | OFF>

SOURce<cnum>:POWer:CENTer <num>

SOURce<cnum>:POWer:COUPle <ON | OFF>

SOURce<cnum>:POWer:DETector <INTernal | EXTernal>

SOURce<cnum>:POWer<port>[:LEVel][:IMMediate] [:AMPLitude] <num>

SOURce<cnum>:POWer[:LEVel]:SLOPe <int>

SOURce<cnum>:POWer[:LEVel]:SLOPe:STATe <ON|OFF>

SOURce<cnum>:POWer:SPAN <num>

SOURce<cnum>:POWer:STARt <num>

SOURce<cnum>:POWer:STOP <num>

SOURCE:POWER:CORRECTION Commands

SOURce<cnum>:POWer<port>:CORRection:COLLect:ABORt

SOURce<cnum>:POWer<port>:CORRection:COLLect[:ACQuire] <char>

SOURce<cnum>:POWer<port>:CORRection:COLLect:AVERage[:COUNt] <num>

SOURce<cnum>:POWer:CORRection:COLLect:FCHeck[:STATe] <ON | OFF>

SOURce<cnum>:POWer<port>:CORRection:COLLect:METHod <char>

SOURce<cnum>:POWer<port>:CORRection:COLLect:SAVE

SOURce<cnum>:POWer:CORRection:COLLect:<pmChan>SENsor[:FRANge] <num1>,<num2>

SOURce<cnum>:POWer:CORRection:COLLect:<pmChan>SENsor:RCFactor <num>

SOURce<cnum>:POWer:CORRection:COLLect:TABLe:DATA <data>

SOURce<cnum>:POWer:CORRection:COLLect:TABLe:FREQuency <data>

SOURce<cnum>:POWer:CORRection:COLLect:TABLe:LOSS[:STATe] <ON | OFF>

SOURce<cnum>:POWer:CORRection:COLLect:TABLe:POINts?

SOURce<cnum>:POWer:CORRection:COLLect:TABLe[:SELect] <char>

SOURce<cnum>:POWer<port>:CORRection:DATA <data>

SOURce<cnum>:POWer<port>:CORRection:LEVel <num>

SOURce<cnum>:POWer<port>:CORRection[:STATe] <ON|OFF>

STATUS REGISTER Commands

Status Byte Register Commandsr

STATus:QUEStionable:<keyword>

STATus:QUEStionable:INTegrity <keyword>

STATus:QUEStionable:INTegrity:HARDware<keyword>

STATus:QUEStionable:INTegrity:MEASurement<keyword>

STATus:QUEStionable:LIMit1<keyword>

STATus:QUEStionable:LIMit2<keyword>

STATus:QUEStionable:DEFine<keyword>

STATus:QUEStionable:DEFine:USER<1|2|3><keyword>

Standard Event Status Register Commands

STATus:OPERation<keyword>

STATus:OPERation:AVERaging1<keyword>

STATus:OPERation:AVERaging2<keyword>

STATus:OPERation:DEFine<keyword>

STATus:OPERation:DEFine:USER<1|2|3><keyword>

SYSTEM Commands

SYSTem:COMMunicate:GPIB:PMETer:ADDRess <num>

SYSTem:CORRection:WIZard <char>

SYSTem:ERRor?

SYSTem:ERRor:COUNt?

SYSTem:PRESet

TRIGGER Commands

TRIGger[:SEQuence]:DELay <num>

TRIGger[:SEQuence]:LEVel <char>

TRIGger[:SEQuence]:SCOPe <char>

TRIGger[:SEQuence]:SOURce <char>


Abort SCPI

About Triggering

Abort Command

ABORt

(Write-only) Stops all sweeps - then resume per current trigger settings. This command is the same as INITtiate:IMMediate (restart) except if a channel is performing a single sweep, ABORt will stop the sweep, but not initiate another sweep.
Examples | ABOR abort
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable


Correction SCPI

Calc:Correction Commands

Controls Electrical Delay and Offset

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. To select the measurement use CALC<ChanNum>:PAR:SEL <MeasName>.

CALCulate<cnum>:CORRection:EDELay:TIME <num>

(Read-Write) Sets the electrical delay for the selected measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Electrical delay in seconds. Choose any number between: -10.00 and 10.00 Use SENS:CORR:RVEL:COAX <num> to set Velocity factor.
Examples | CALC1:CORR:EDEL:TIME 1NS calculate2:correction:time 0.5e-12
Query Syntax | CALCulate:CORRection:EDELay:TIME?
Return Type | Character
Overlapped? | No
Default | 0 seconds

CALCulate<cnum>:CORRection:OFFSet[:MAGNitude] <num>

(Read-Write) Specifies the power level to which the selected (unratioed) measurement’s data is to be adjusted by a Receiver Power Calibration. This command applies only when the selected measurement is of unratioed power. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Cal power level in dBm. No limits are enforced on this value, but the PNA receivers themselves have maximum and minimum power specifications (that may differ between PNA models) which this value must comply with for a valid receiver power cal.
Examples | CALC:CORR:OFFS –10DBM calculate1:correction:offset:magnitude maximum
Query Syntax | CALCulate<cnum>:CORRection:OFFSet[:MAGNitude]?
Return Type | Character
Overlapped? | No
Default | 0dBm

CALCulate<cnum>:CORRection:OFFSet:PHASe <num>[<char>]

(Read-Write) Sets the phase offset for the selected measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Offset phase value. Choose any number between: -360 and 360
<char> | Units for phase. OPTIONAL. Choose either: DEG - Degrees (default) RAD - Radians
Examples | CALC:CORR:OFFS:PHAS 10 calculate:correction:offset:phase 20rad
Query Syntax | CALCulate:CORRection:OFFSet:PHASe?
Return Type | Character, returned value always in degrees
Overlapped? | No
Default | 0 degrees


Data SCPI

Calc:Data Commands

Controls sending and receiving data with the PNA

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See Data Access Map

CALCulate<cnum>:DATA <char>,<data>

Writes Measurement data, Memory data, Normalization Divisor data, or Error terms.

CALCulate<cnum>:DATA? <char>
Reads Measurement data, Memory data, Normalization Divisor data, or Error terms.
Format of returned Measurement and Memory Data:

REAL or ASCii (see Transferring Measurement Data)

FDATA - one number per trace point
SDATA - two numbers per trace point
FMEM - one number per trace point
SMEM - two numbers per trace point
SDIV - two numbers per trace point

Format of all returned Error Terms: - two numbers per trace point

(see below for specifying <char> for error terms)

Parameters

<cnum> - Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char> - To write or read Measurement (DATA), Memory (MEM) or Normalization Divisor (DIV) choose from:

FDATA - formatted trace data from measResult location
SDATA - corrected complex trace data from rawMeas location
FMEM - formatted memory data from memResult location
SMEM - corrected complex data from rawMemory location
SDIV - complex data from Normalization Divisor location

Note: Normalization Divisor data is that obtained from a Receiver Power Calibration, for example.

<char> - To write or read Error Terms...

For Response Open calibrations:

Specify this <char>... | to get this Term...
SCORR3 | Reflection Tracking

For Response Short calibrations:

Specify this <char>... | to get this Term...
SCORR3 | Reflection Tracking

For Response Thru calibrations:

Specify this <char>... | to get this Term...
SCORR6 | Transmission Tracking

For Response Thru and Isolation calibrations:

Specify this <char>... | to get this Term...
SCORR4 | Isolation
SCORR6 | Transmission Tracking

For 1-Port calibrations:

Specify this <char>... | to get this Term...
SCORR1 | Directivity
SCORR2 | Source Match
SCORR3 | Reflection Tracking

For 2-Port SOLT and TRL calibrations

Specify this <char>... | to get this Term...
SCORR1 | Forward Directivity
SCORR2 | Forward Source Match
SCORR3 | Forward Reflection Tracking
SCORR4 | Forward Isolation
SCORR5 | Forward Load Match
SCORR6 | Forward Transmission Tracking
SCORR7 | Reverse Directivity
SCORR8 | Reverse Source Match
SCORR9 | Reverse Reflection Tracking
SCORR10 | Reverse Isolation
SCORR11 | Reverse Load Match
SCORR12 | Reverse Transmission Tracking

For FULL 3-Port SOLT calibrations

Specify this <char>... | to get this Term... | for this Receiver Port .
SCORR13 | Directivity | 3 (S33)
SCORR14 | Source Match | 3 (S33)
SCORR15 | Reflection Tracking | 3 (S33)
SCORR16 | Isolation | 3 (S31)
SCORR17 | Load Match | 3 (S31)
SCORR18 | Trans Tracking | 3 (S31)
SCORR19 | Isolation | 1 (S13)
SCORR20 | Load Match | 1 (S13)
SCORR21 | Trans Tracking | 1 (S13)
SCORR22 | Isolation | 3 (S32)
SCORR23 | Load Match | 3 (S32)
SCORR24 | Trans Tracking | 3 (S32)
SCORR25 | Isolation | 2 (S23)
SCORR26 | Load Match | 2 (S23)
SCORR27 | Trans Tracking | 2 (S23)

EXAMPLE

CALC:DATA FDATA,Data(x)
calculate2:data sdata,data(r,i)

See another example using this command.

Overlapped? - No

Default - Not Applicable

Notes:

  • When querying memory, you must first store a trace into memory using CALC:MATH:MEMorize.

  • When querying the normalization divisor, you must first store a divisor trace using CALC:NORMalize[:IMMediate].

  • If normalization interpolation is ON and the number of points changes after the initial normalization, the divisor data will then be interpolated.

  • When querying error terms, there must be error terms in the analyzer.

  • If interpolation is ON and the number of points changes after the initial calibration, the error terms will then be the interpolated results.

  • To get and put receiver data, see CALC:RDATA?

  • To get uncorrected ratioed data, turn correction OFF and use Calc:Data SDATA.

  • CALCulate commands act on the selected measurement. You can select one measurement in each channel. Therefore, you can have up to four measurements selected at the same time. Select the measurement for each channel using CALC:PAR:SEL.

Learn more about Error Terms

CALCulate<cnum>:DATA:CUSTom <name>,<data>

(Read-Write) Reads or writes data from a custom-named measurement buffer. Specify the measurement using CALCulate:PARameter:SELect. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<name> | Name of the buffer to be read or written
<data> | Data to be read or written to the custom buffer. Format as one number per data point.
Examples | CALC:DATA:CUST 'VectorResult0',0,1,2,3,4,5 'Write CALC:DATA:CUST? 'VectorResult0' 'Read
Query Syntax | CALCulate:DATA:CUSTom? <name>
Return Type | REAL or ASCii (see Getting Data from the Analyzer)
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:DATA:CUSTom:CATalog?

(Read-only) Reads the list of buffer names (comma separated list of string values) available from the selected parameter. Specify the measurement using CALCulate:PARameter:SELect. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:DATA:CUST:CAT? calculate:data:custom:catalog?
Return Type | REAL or ASCii (see Getting Data from the Analyzer)
Overlapped? | No
Default | Not Applicable


Filter SCPI

Calc:Filter Commands

Controls the gating function used in time domain measurements. The gated range is specified with either (start / stop) or (center / span) commands.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Gating

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:FILTer[:GATE]:TIME:CENTer <num>

(R ead-Write) Sets the gate filter center time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Center time in seconds; Choose any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:GATE:TIME:CENT -5 ns calculate2:filter:time:center maximum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:CENTer?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:FILTer[:GATE]:TIME:SHAPe <char>

(R ead-Write) Sets the gating filter shape when in time domain. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from MAXimum - the widest gate filter available WIDE - NORMal - MINimum - the narrowest gate filter available
Examples | CALC:FILT:GATE:TIME:SHAP MAX calculate2:filter:time:shape normal
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:SHAPe?
Return Type | Character
Overlapped? | No
Default | NORMal

CALCulate<cnum>:FILTer[:GATE]:TIME:SPAN <num>

(R ead-Write) Sets the gate filter span time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Time span in seconds; Choose any number between: 0 and 2* [(number of points-1) / frequency span] Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:GATE:TIME:SPAN 5 ns calculate2:filter:time:span maximum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:SPAN?
Return Type | Character
Overlapped? | No
Default | 20 ns

CALCulate<cnum>:FILTer[:GATE]:TIME:STATe <boolean>

(R ead-Write) Turns gating state ON or OFF. Critical Note: Note: Sweep type must be set to LInear Frequency in order to use Transform Gating.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<boolean> | ON (or 1) - turns gating ON. OFF (or 0) - turns gating OFF.
Examples | CALC:FILT:TIME:STAT ON calculate2:filter:gate:time:state off
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:FILTer[:GATE]:TIME:STARt <num>

(R ead-Write) Sets the gate filter start time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Start time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:TIME:STAR 1e-8 calculate2:filter:gate:time:start minimum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:STARt?
Return Type | Character
Overlapped? | No
Default | 10 ns

CALCulate<cnum>:FILTer[:GATE]:TIME:STOP <num>

(R ead-Write) Sets the gate filter stop time. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Stop time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:FILT:TIME:STOP -1 ns calculate2:filter:gate:time:stop maximum
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME:STOP?
Return Type | Character
Overlapped? | No
Default | 10 ns

CALCulate<cnum>:FILTer[:GATE]:TIME[:TYPE] <char>

(R ead-Write) Sets the type of gate filter used. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from: BPASs - Includes (passes) the range between the start and stop times. NOTCh - Excludes (attenuates) the range between the start and stop times.
Examples | CALC:FILT:TIME BPAS calculate2:filter:gate:time:type notch
Query Syntax | CALCulate<cnum>:FILTer[:GATE]:TIME[:TYPE]?
Return Type | Character
Overlapped? | No
Default | BPAS


Format SCPI

Calc:Format Command

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

  • See an example using this command.

  • See a List of all commands in this block.

  • Learn About Data Format

CALCulate<cnum>:FORMat <char>

(Read-Write) Sets the display format for the measurement. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

Choose from:

  • MLINear

  • MLOGarithmic

  • PHASe

  • IMAGinary

  • REAL

  • POLar

  • SMITh

  • SWR

  • GDELay

Examples

CALC:FORM MLIN
calculate2:format polar

Query Syntax

CALCulate<cnum>:FORMat?

Return Type

Character

Overlapped?

No

Default

MLINear

List of all commands in this block:
(Parameters in bold italics)

:CALCulate1:FORMat MLIN
:CALCulate1:FORMat?


Function SCPI

Calc:Function Commands

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn a bout Trace Statistics

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:FUNCtion:DATA?

(Read-only) Returns the trace statistic data for the selected statistic type for the specified channel. Select the type of statistic with CALC:FUNC:TYPE. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

Return Type

Character

Example

CALCulate2:FUNCtion:DATA?

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:FUNCtion:DOMain:USER[:RANGe] <range>

(Read-Write) Sets the range used to calculate trace statistics. Each channel shares 10 domain ranges. The x-axis range is specified with the CALC:FUNC:DOM:USER:START and STOP commands. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<range> | Range number. Choose from: 0 to 9 0 is Full Span of the current x-axis range 1 to 9 are user-specified ranges
Examples | CALC:FUNC:DOM:USER 4 calculate2:function:domain:user:range 0
Query Syntax | CALCulate<cnum>:FUNCtion:DOMain:USER[:RANGe]?
Return Type | Character
Overlapped? | No
Default | 0 - Full Span

CALCulate<cnum>:FUNCtion:DOMain:USER:STARt <range>, <start>

(Read-Write) Sets the start of the specified user-domain range. To apply this range, use CALC:FUNC:DOM:USER To set the stop of the range, use CALC:FUNC:DOM:USER:STOP. Critical Note: Note: This command does the same as CALC:MARK:FUNC:DOM:USER:STAR
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<range> | Range number that will receive the start value. Choose an integer between 1 and 9
<start> | Start value of the specified range. Choose a real number between: the analyzer's Minimum and Maximum x-axis value.
Examples | CALC:FUNC:DOM:USER:STAR 1,1e9 calculate2:function:domain:user:start 2,2e9
Query Syntax | CALCulate<cnum>:FUNCtion:DOMain:USER:STARt? <range>
Return Type | Character
Overlapped? | No
Default | The analyzer's Minimum x-axis value

CALCulate<cnum>:FUNCtion:DOMain:USER:STOP <range>, <stop>

(Read-Write) Sets the stop of the specified user-domain range. To apply this range, use CALC:FUNC:DOM:USER To set the start of the range, use CALC:FUNC:DOM:USER:START Critical Note: Note: This command does the same as CALC:MARK:FUNC:DOM:USER:STOP
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<range> | Range number that will receive the stop value. Choose an integer between 1 and 9
<stop> | Stop value of the specified range. Choose a real number between: the analyzer's Minimum and Maximum x-axis value.
Examples | CALC:FUNC:DOM:USER:STOP 4,5e9 calculate2:function:domain:user:stop 3,8e9
Query Syntax | CALCulate<cnum>:FUNCtion:DOMain:USER:STOP? <range>
Return Type | Character
Overlapped? | No
Default | The analyzer's Maximum x-axis value

CALCulate<cnum>:FUNCtion:STATistics[:STATe] <ON|OFF>

(Read-Write) Displays and hides the measurement (Trace) statistics (peak-to-peak, mean, standard deviation) on the screen.

The analyzer will display either measurement statistics or Filter Bandwidth statistics; not both. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<ON|OFF>

ON - Displays trace statistics

OFF - Hides trace statistics

Examples

CALC:FUNC:STAT ON
calculate2:function:statistics:state off

Query Syntax

CALCulate<cnum>:FUNCtion:STATistics[:STATe]?

Return Type

Boolean (1 = ON, 0 = OFF)

Overlapped?

No

Default

OFF (0)

CALCulate<cnum>:FUNCtion:TYPE <char>

(Read-Write) Sets statistic TYPE that you can then query using CALC:FUNCtion:DATA?. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from: PTPeak - the difference between the max and min data points on the trace. STDEV - standard deviation of all data points on the trace MEAN - mean (average) of all data points on the trace
Examples | CALC:FUNC:TYPE PTP calculate2:function:type stdev
Query Syntax | CALCulate<cnum>:FUNCtion:TYPE?
Return Type | Character
Overlapped? | No
Default | PTPeak


Limit SCPI

Calc:Limit Command

Controls the limit segments used for pass / fail testing.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Limit Lines

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:LIMit:DATA <block>

(Read-Write) Sets data for limit segments. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<block>

Data for all limit segments in REAL,64 format. The following is the data format for 1 segment:
Type,BegStim, EndStim, BegResp,EndResp

Type | Type of limit segment. Choose from 0 - Off 1 - Max 2 - Min
BegStim | Start of X-axis value (freq, power, time)
EndStim | End of X-axis value
BegResp | Y-axis value that corresponds with Start of X-axis value
EndResp | Y-axis value that corresponds with End of X-axis value

Examples

The following writes three max limit segments for a bandpass filter.

"CALC:LIM:DATA 1,3e5,4e9,-60,0,1,4e9,7.5e9,0,0,1,7.5e9,9e9,0,-30"

Query Syntax

CALCulate<cnum>:LIMit:DATA?

Return Type

Definite length block - All 100 predefined limit segments are returned.

Overlapped?

No

Default

100 limit segments - all values set to 0

CALCulate<cnum>:LIMit:DISPlay[:STATe] <ON | OFF>

(Read-Write) Turns the display of limit segments ON or OFF (if the data trace is turned ON). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns the display of limit segments ON. OFF (or 0) - turns the display of limit segments OFF.
Examples | CALC:LIM:DISP:STAT ON calculate2:limit:display:state off
Query Syntax | CALCulate<cnum>:LIMit:DISPlay[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STARt <num>

(Read-Write) Sets the start (beginning) of the Y-axis amplitude (response) value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number between: -500 and 500 Display value is limited to the Maximum and Minimum displayed Y-axis values.
Examples | CALC:LIM:SEGM1:AMPL:STAR 10 calculate2:limit:segment2:amplitude:start 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STARt?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STOP <num>

(Read-Write) Sets the stop (end) of the Y-axis amplitude (response) value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number between: -500 and 500 Display value is limited to the Maximum and Minimum displayed Y-axis values.
Examples | CALC:LIM:SEGM1:AMPL:STOP 10 calculate2:limit:segment2:amplitude:stop 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>AMPLitude:STOP?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STARt <num>

(Read-Write) Sets the start (beginning) of the X-axis stimulus value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number within the X-axis span of the analyzer.
Examples | CALC:LIM:SEGM1:STIM:STAR 10 calculate2:limit:segment2:stimulus:start 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STARt?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STOP <num>

(Read-Write) Sets the stop (end) of the X-axis stimulus value. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number; if unspecified, value is set to 1.
<num> | Choose any number within the X-axis span of the analyzer.
Examples | CALC:LIM:SEGM1:AMPL:STOP 10 calculate2:limit:segment2:stimulus:stop 10
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>STIMulus:STOP?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:LIMit:SEGMent<snum>:TYPE <char>

(Read-Write) Sets the type of limit segment. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<snum> | Segment number. Choose any number between: 1 and 100 If unspecified, value is set to 1.
<char> | Choose from: LMAX - a MAX limit segment. Any response data exceeding the MAX value will fail. LMIN - a MIN limit segment. Any response data below the MIN value will fail. OFF - the limit segment (display and testing) is turned OFF.
Examples | CALC:LIM:SEGM:TYPE LMIN calculate2:limit:segment3:type lmax
Query Syntax | CALCulate<cnum>:LIMit:SEGMent<snum>:TYPE?
Return Type | Character
Overlapped? | No
Default | OFF

CALCulate<cnum>:LIMit:SOUNd[:STATe] <ON | OFF>

(Read-Write) Turns limit testing fail sound ON or OFF. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns sound ON. OFF (or 0) - turns sound OFF.
Examples | CALC:LIM:SOUN ON calculate2:limit:sound:state off
Query Syntax | CALCulate<cnum>:LIMit:SOUNd[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:LIMit:STATe <ON | OFF>

(Read-Write) Turns limit segment testing ON or OFF. Use CALC:LIM:DISP to turn ON and OFF the display of limit segments. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns limit testing ON. OFF (or 0) - turns limit testing OFF.
Examples | CALC:LIM:STAT ON calculate2:limit:state off
Query Syntax | CALCulate<cnum>:LIMit:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF


Marker SCPI

Calc:Marker Commands

Controls the marker settings used to remotely output specific data to the computer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See commands for controlling the marker readout number and size

  • Learn about Markers

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

Note: The Reference Marker is Marker Number 10

CALCulate<cnum>:MARKer:AOFF

(Write-only) Turns all markers off for selected measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:MARK:AOFF calculate2:marker:aoff
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

CALCulate<cnum>:MARKer:BWIDth <num>

(Read-Write) Turns on and sets markers 1 through 4 to calculate filter bandwidth. The <num> parameter sets the value below the maximum bandwidth peak that establishes the bandwidth of a filter. For example, if you want to determine the filter bandwidth 3 db below the bandpass peak value, set <num> to -3.

This feature activates markers 1 through 4. To turn off these markers, either turn them off individually or turn them All Off.

The analyzer screen will show either Bandwidth statistics OR Trace statistics; not both.

To search a User Range with the bandwidth search, first activate marker 1 and set the desired User Range. Then send the CALC:MARK:BWID command. The user range used with bandwidth search only applies to marker 1 searching for the max value. The other markers may fall outside the user range.
Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<num>

Target value below filter peak. Choose any number between:
-500 and 500

Examples

CALC:MARK:BWID -3
calculate2:marker:bwidth -2.513

Query Syntax

CALCulate<cnum>:MARKer:BWIDth?
Returns the results of bandwith search:

Return Type

Four Character values separated by commas: bandwidth, center Frequency, Q, loss.

Overlapped?

No

Default

-3

CALCulate<cnum>:MARKer<mkr>:COUPling[:STATe]<ON|OFF>

(Read-Write) Sets and Reads the state of Coupled Markers (ON and OFF) Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | False (0) - Turns Coupled Markers OFF True (1) - Turns Coupled Markers ON
Examples | CALC:MARK:COUP ON calculate2:marker8:coupling off
Query Syntax | CALCulate<cnum>:MARKer<mkr>:COUPling:[STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer<mkr>:DELTa <ON|OFF>

(Read-Write) Specifies whether marker is relative to the Reference marker or absolute. Note: The reference marker must already be turned ON with CALC:MARK:REF:STATE. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | ON (or 1) - Specified marker is a Delta marker OFF (or 0) - Specified marker is an ABSOLUTE marker
Examples | CALC:MARK:DELT ON calculate2:marker8:delta off
Query Syntax | CALCulate<cnum>:MARKer<mkr>:DELTa?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer<mkr>:DISCrete <ON|OFF>

(Read-Write) Makes the specified marker display either a calculated value between data points (interpolated data) or the actual data points (discrete data). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | ON (or 1) - Specified marker displays the actual data points OFF (or 0) - Specified marker displays calculated data between the actual data points.
Examples | CALC:MARK:DISC ON calculate2:marker8:discrete off
Query Syntax | CALCulate<cnum>:MARKer<mkr>:DISCrete?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer<mkr>:FORMat <char>

(Read-Write) Sets the format of the data that will be returned in a marker data query CALC:MARK:Y? and the displayed value of the marker readout. The selection does not have to be the same as the measurement's display format. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1
<char> | Choose from: DEFault - The format of the selected measurement MLINear - Linear magnitude MLOGarithmic - Logarithmic magnitude IMPedance - (R+jX) ADMittance - (G+jB) PHASe - Phase IMAGinary - Imaginary part (Im) REAL - Real part (Re)l POLar - (Re, Im) GDELay - Group Delay LINPhase - Linear Magnitude and Phase LOGPhase - Log Magnitude and Phase
Examples | CALC:MARK:FORMat MLIN calculate2:marker8:format Character
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FORMat?
Return Type | Character
Overlapped? | No
Default | DEFault

CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:EXCursion <num>

(Read-Write) Sets amplitude peak excursion for the specified marker. The Excursion value determines what is considered a "peak". This command applies to marker peak searches (Next peak, Peak Right, Peak Left). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any existing marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Excursion value. Choose any number between -500 and 500. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:FUNC:APE:EXC 10 calculate2:marker8:function:apeak:excursion maximum
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:EXCursion?
Return Type | Character
Overlapped? | No
Default | 3

CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:THReshold <num>

(Read-Write) Sets peak threshold for the specified marker. If a peak (using the criteria set with :EXCursion) is below this reference value, it will not be considered when searching for peaks. This command applies to marker peak searches (Next peak, Peak Right, Peak Left). Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1
<num> | Threshold value.Choose any number betwe en -500 and 500. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:FUNC:APE:THR -40 calculate2:marker8:function:apeak:threshold -55
Query Syntax | CALCulate<cnum>:MARKer<mkr>:FUNCtion:APEak:THReshold?
Return Type | Character
Overlapped? | No
Default | -100

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER <range>

(Read-Write) Assigns the specified marker to a range number. The x-axis travel of the marker is constrained to the range's span. The span is specified with the CALC:MARK:FUNC:DOM:USER:START and STOP commands, unless range 0 is specified which is the full span of the analyzer.

Each channel shares 10 domain ranges. (Trace statistics use the same ranges.) More than one marker can use a domain range. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<span>

User span. Choose any Integer from 0 to 9.

0 is Full Span of the analyzer
1 to 9 are available for user-defined x-axis span

Examples

CALC:MARK:FUNC:DOM:USER 1
calculate2:marker8:function:domain:user 1

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER?
Returns the user span number that the specified marker is assigned to.

Return Type

Character

Overlapped?

No

Default

0 - Full Span

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STARt <start>

(Read-Write) Sets the start of the span that the specified marker's x-axis span will be constrained to.
Use CALC:MARK:FUNC:DOM:USER<range> to set range number
Use CALC:MARK:FUNC:DOM:USER:STOP to set the stop value.

Note: If the marker is assigned to range 0 (full span), the USER:STARt and STOP commands generate an error. You cannot set the STARt and STOP values for "Full Span".

Note: This command does the same as CALC:FUNC:DOM:USER:STAR

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<start>

The analyzer's Minimum x-axis value

Examples

CALC:MARK:FUNC:DOM:USER:START 500E6
calculate2:marker8:function:domain:user:start 1e12

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STARt?

Return Type

Character

Overlapped?

No

Default

The analyzer's Minimum x-axis value

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STOP <stop>

(Read-Write) Sets the stop of the span that the marker's x-axis travel will be constrained to. Use CALC:MARK:FUNC:DOM:USER<range> to set range number
Use CALC:MARK:FUNC:DOM:USER:STARt to set the stop value.

Note: If the marker is assigned to range 0 (full span), the USER:STARt and STOP commands generate an error. You cannot set the STARt and STOP values for "Full Span".

Note: This command does the same as CALC:FUNC:DOM:USER:STOP

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<stop>

Stop value of x-axis span; Choose any number between the analyzer's MINimum and MAXimum x-axis value.

Examples

CALC:MARK:FUNC:DOM:USER:STOP 500e6
calculate2:marker8:function:domain1:user:stop 1e12

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:DOMain:USER:STOP?

Return Type

Character

Overlapped?

No

Default

The analyzer's MAXimum x-axis value.

CALCulate<cnum>:MARKer<mkr>:FUNCtion:EXECute [<func>]

(Write-only) Immediately executes (performs) the specified search function. If no function is specified, executes the selected function. Select the function with CALC:MARK:FUNCtion:SEL. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<func>

Optional argument. The function that is to be performed. Choose from:

MAXimum - finds the highest value
MINimum - finds the lowest value
RPEak - finds the next valid peak to the right
LPEak - finds the next valid peak to the left
NPEak - finds the next highest value among the valid peaks
TARGet - finds the target value to the right, wraps around to the left
LTARget - finds the next target value to the left of the marker
RTARget - finds the next target value to the right of the marker

Examples

CALC:MARK:FUNC:EXEC
calculate2:marker2:function:execute maximum

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:MARKer<mkr>:FUNCtion[:SELect] <char>

(Read-Write) Sets the search function that the specified marker will perform when executed. To execute (or perform) the function, use:
CALC:MARK:FUNC:EXEC or
CALC:MARK:FUNC:TRAC ON to automatically execute the search every sweep. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<char>

Marker function. Choose from:

MAXimum - finds the highest value
MINimum - finds the lowest value
RPEak - finds the next valid peak to the right
LPEak - finds the next valid peak to the left
NPEak - finds the next highest value among the valid peaks
TARGet - finds the target value to the right; wraps around to the left
LTARget - finds the next target value to the left of the marker
RTARget - finds the next target value to the right of the marker

Examples

CALC:MARK:FUNC MAX
calculate2:marker8:function:select ltarget

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion[:SELect]?

Overlapped?

No

Default

MAX

CALCulate<cnum>:MARKer<mkr>:TARGet <num>

(Read-Write) Sets the target value for the specified marker when doing Target Searches (CALC:MARK:FUNC:SEL <TARGet | RTARget | LTARget> Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Target value to search for; Units are NOT allowed.
Examples | CALC:MARK:TARG 2.5 calculate2:marker8:target -10.3
Query Syntax | CALCulate<cnum>:MARKer<mkr>:TARGet?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:MARKer<mkr>:FUNCtion:TRACking <ON | OFF>

(Read-Write) Sets the tracking capability for the specified marker. The tracking function finds the selected search function every sweep. In effect, turning Tracking ON is the same as doing a CALC:MARK:FUNC:EXECute command every sweep. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

<ON | OFF>

ON (or 1) - The specified marker will "Track" (find) the selected function every sweep.

OFF (or 0) - The specified marker will find the selected function only when the CALC:MARK:FUNC:EXECute command is sent.

Examples

CALC:MARK:FUNC:TRAC ON
calculate2:marker8:function:tracking off

Query Syntax

CALCulate<cnum>:MARKer<mkr>:FUNCtion:TRACking?

Return Type

Boolean (1 = ON, 0 = OFF)

Overlapped?

No

Default

OFF

CALCulate<cnum>:MARKer:REFerence[:STATe] <ON | OFF>

(Read-Write) Turns the reference marker (marker 10) ON or OFF. When turned OFF, existing Delta markers revert to absolute markers. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns reference marker ON OFF (or 0) - turns reference marker ON
Examples | CALC:MARK:REF ON calculate2:marker:reference:state OFF
Query Syntax | CALCulate<cnum>:MARKer:REFerence[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:MARKer:REFerence:X <num>

(Read-Write) Sets and returns the absolute x-axis value of the reference marker (marker 10). Critical Note:

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<num>

X-axis value. Choose any number within the operating domain of the reference marker.

Examples

CALC:MARK:REF:X 1e9

calculate2:marker:reference:x 1e6

Query Syntax

CALCulate<cnum>:MARKer:REFerence:X?

Return Type

Character

Overlapped?

No

Default

If the first Marker, turns ON in the middle of the X-axis span. If not, turns ON at the position of the active marker.

CALCulate<cnum>:MARKer:REFerence:Y?

(Read-only) Returns the absolute Y-axis value of the reference marker. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

Examples

CALC:MARK:REF:Y?

calculate2:marker:reference:y?

Return Type

Character

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:MARKer<mkr>:TYPE <char>

(Read-Write) Sets the type of the specified marker. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<char>

Choose from:
NORMal - a marker that stays on the assigned X-axis position unless moved or searching.
FIXed - a marker that will not leave the assigned X or current Y-axis position.

Examples

CALC:MARK:TYPE NORM
calculate2:marker2:type fixed

Query Syntax

CALCulate<cnum>:MARKer<mkr>:TYPE?

Return Type

Character

Overlapped?

No

Default

NORMal

CALCulate<cnum>:MARKer<mkr>:SET <char>

(Read-Write) Sets the selected instrument setting to assume the value of the specified marker. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1

<char>

Choose from:
CENTer - changes center frequency to the value of the marker
SPAN - changes the frequency span to the value of the marker's domain
STARt - changes the start frequency to the value of the marker
STOP - changes the stop frequency to the value of the marker
RLEVel - changes the reference level to the value of the marker
DELay - changes the xxx delay to the value of the marker

Examples

CALC:MARK:SET CENT
calculate2:marker8:set span

Query Syntax

CALCulate<cnum>:MARKer<mkr>:SET?

Return Type

Character

Overlapped?

No

Default

Not applicable

CALCulate<cnum>:MARKer<mkr>[:STATe] <ON|OFF>

(Read-Write) Turns the specified marker ON or OFF. Marker 10 is the Reference Marker. To turn all markers off, use CALC:MARK:AOFF. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1.
<ON|OFF> | ON (or 1) - turns marker ON. OFF (or 0) - turns marker OFF.
Examples | CALC:MARK ON calculate2:marker8 on
Query Syntax | CALCulate<cnum>:MARKer<mkr>:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Off

CALCulate<cnum>:MARKer<mkr>:X <num>

(Read-Write) Sets the marker's X-axis value (frequency, power, or time). If the marker is set as delta, the SET and QUERY data is relative to the reference marker. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<mkr> | Any marker number from 1 to 10; if unspecified, value is set to 1.
<num> | Any X-axis position within the measurement span of the marker. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:MARK:X 100Mhz calculate2:marker8:x maximum
Query Syntax | CALCulate<cnum>:MARKer<mkr>:X?
Return Type | Character
Overlapped? | No
Default | First Marker turns ON in the middle of the X-axis span. Subsequent markers turn ON at the position of the active marker.

CALCulate<cnum>:MARKer<mkr>:Y?

(Read-only) Reads the marker's Y-axis value. The format of the value depends on the current CALC:MARKER:FORMAT setting. If the marker is set as delta, the data is relative to the reference marker. The query always returns two numbers:

  • Smith and Polar formats - (Real, Imaginary)

  • LINPhase and LOGPhase - (Real, Imaginary)

  • All other formats - (Value,0)

Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<mkr>

Any marker number from 1 to 10; if unspecified, value is set to 1.

Examples

CALC:MARK:Y?
calculate2:marker3:y?

Query Syntax | CALCulate<cnum>:MARKer<mkr>:Y?
Return Type | Character
Overlapped? | No
Default | Not applicable


Math SCPI

Calc:Math Command

Controls math operations on the currently selected measurement and memory.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Math Operations

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:MATH:FUNCtion <char>

(Read-Write) Sets math operations on the currently selected measurement and the trace stored in memory. (There MUST be a trace stored in Memory. See CALC:MATH MEM) Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | The math operation to be applied. Choose from the following:
NORMal | Trace data only
ADD | Data + Memory
SUBTract | Data - Memory
MULTiply | Data * Memory
DIVide | Data / Memory
Examples | CALC:MATH:FUNC NORM calculate2:math:function subtract
Query Syntax | CALCulate<cnum>:MATH:FUNCtion?
Return Type | Character
Overlapped? | No
Default | NORMal

CALCulate<cnum>:MATH:MEMorize

(Write-only) Puts the currently selected measurement trace into memory. (Data-> Memory) Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:MATH:MEM calculate2:math:memorize
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable


Normalize SCPI

Calc:Normalize Commands

Specifies the normalization features used for a receiver power calibration.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Receiver Cal

Save and recall your receiver power calibration (which use .CST file commands):

  • SENS:CORR:CSET:SAVE

  • SENS:CORR:CSET[:SEL]

Or use these two commands and specify either .STA or .CST file extensions:

  • MMEM:LOAD

  • MMEM:STOR

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:NORMalize[:IMMediate]

(Read-Write) Stores the selected measurement’s data to that measurement’s “divisor” buffer for use by the Normalization data processing algorithm. This command is not compatible with ratioed measurements such as S-parameters. It is intended for receiver power calibration when the selected measurement is of an unratioed power type. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:NORM calculate1:normalize:immediate
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:NORMalize:STATe <ON | OFF>

(Read-Write) Specifies whether or not normalization is applied to the measurement. Normalization is enabled only for measurements of unratioed power where it serves as a receiver power calibration. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - normalization is applied to the measurement. OFF (or 0) – normalization is NOT applied to the measurement.
Examples | CALC:NORM:STAT ON calculate2:normalize:state off
Query Syntax | CALCulate<cnum>:NORMalize:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:NORMalize:INTerpolation[:STATe] <ON | OFF>

(Read-Write) Turns normalization interpolation ON or OFF. Normalization is enabled only for measurements of unratioed power, where it serves as a receiver power calibration. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) – turns interpolation ON. OFF (or 0) – turns interpolation OFF.
Examples | CALC:NORM:INT ON calculate2:normalize:interpolation:state off
Query Syntax | CALCulate<cnum>:NORMalize:INTerpolation[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON


Parameter SCPI

Calc:Parameter Commands

Lists, creates, selects and deletes measurements

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Measurement Parameters

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:PARameter:CATalog?

(Read-only) Returns the names and parameters of existing measurements for the specified channel. Critical Note:
Parameters |
<cnum> | Channel number of the measurements to be listed. If unspecified, <cnum> is set to 1.
Examples | CALC:PAR:CAT? calculate2:parameter:catalog?
Query Syntax | CALCulate<cnum>:PARameter:CATalog?
Return Type | String - "<measurement name>,<parameter>,[<measurement name>,<parameter>...]"
Overlapped? | No
Default | "CH1_S11_1,S11"

CALCulate<cnum>:PARameter:DEFine <Mname>,<param>[,load]

(Write-only) Creates a measurement but does NOT display it.

  • Use DISP:WIND:STATe to create a window if it doesn't already exist.

  • Use DISP:WIND<wnum>:TRAC<tnum>:FEED <Mname> to display the measurement.

You must select the measurement (CALC<cnum>:PAR:SEL <mname>) before making additional settings. Critical Note:

Parameters

<cnum>

Channel number of the new measurement. Choose any number between:
1 and 4
If unspecified, value is set to 1.

<Mname>

Name of the measurement. Any non-empty, unique string, enclosed in quotes.

<param>

Parameter

Choose from the following for S-Parameter measurements

S11 | S22 | S12 | S21

For 3-port analyzers only:

S33 | S13 | S31 | S23 | S32

For the following non S-Parameter measurements, Specify the source port with: SENSe:SWEep:SRCPort <1|2>)

Choose from the following for non-ratioed measurements:
A | B | C | R1 | R2

Choose from the following for ratioed measurements:

<param> | Description
AB | A/B
AC | A/C - 3 port analyzers only
BA | B/A
BC | B/C - 3 port analyzers only
CA | C/A - 3 port analyzers only
CB | C/B - 3 port analyzers only
AR1 | A/R1
BR1 | B/R1
CR1 | C/R1 - 3 port analyzers only
AR2 | A/R2
BR2 | B/R2
R1A | R1/A
R2A | R2/A
R1B | R1/B
R2B | R2/B
R1C | R1/C - 3 port analyzers only
R2R1 | R2/R1
R1R2 | R1/R2

[load] | Optional argument; specifies the device port which will provide the load for the measurement (Multi-port reflection measurements only). This argument is ignored if a transmission S-parameter is specified.)
Examples | CALC:PAR:DEF 'Test',S12 calculate2:parameter:define 'test',s22 CALC4:PAR:DEF 'ch4_S33',S33,2 'Defines an S33 measurement with a load on port2 of the analyzer.
Query Syntax | Not Applicable; see Calc:Par:Cat?
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:PARameter:DELete [:NAME]<Mname>

(Write-only) Deletes the specified measurement. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<Mname> | String - Name of the measurement
Examples | CALC:PAR:DEL 'TEST' calculate2:parameter:delete 'test'
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:PARameter:DELete:ALL

(Write-only) Deletes all specified measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:PAR:DEL:ALL calculate2:parameter:delete:all
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

CALCulate<cnum>:PARameter:SELect <Mname>

(Read-Write) Sets the selected measurement. Most CALC: commands require that this command be sent before a setting change is made. One measurement on each channel can be selected at the same time. To obtain a list of currently named measurements, use CALC:PAR:CAT? Critical Note:
Parameters |
<cnum> | Channel number of the measurement to be selected. If unspecified, <cnum> is set to 1.
<Mname> | String - Name of the measurement. (Do NOT include the parameter name.)
Examples | CALC:PAR:SEL 'TEST' calculate2:parameter:select 'test'
Query Syntax | CALCulate:PARameter:SELect?
Return Type | String
Overlapped? | No
Default | No Selection


RData SCPI

Calc:RData Command

Generally when you query the analyzer for data, you expect that the number of data values returned will be consistent with the number of points in the sweep.

However, if you query receiver data while the instrument is sweeping, the returned values may contain zeros. For example, if your request for receiver data is handled on the 45th point of a 201 point sweep, the first 45 values will be valid data, and the remainder will contain complex zero.

This can be avoided by synchronizing this request with the end of a sweep or putting the channel in hold mode.

Learn about Unratioed Measurements

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:RDATA? <char>

(Read-only) Returns receiver data for the selected measurement. To query measurement data, see CALC:DATA? Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from receivers: A B R1 R2 REF - returns either R1 or R2 data depending on the source port of the CALC-selected measurement.
Example | GPIB.Write "INITiate:CONTinuous OFF" GPIB.Write "INITiate:IMMediate;*wai" GPIB.Write "CALCulate:RDATA? A"
Return Type | Character - Two numbers per data point
Overlapped? | No
Default | Not Applicable

List of all commands in this block:
(Parameters in bold italics)

:CALCulate1:RDATA? A


Smoothing SCPI

Calc:Smoothing Commands

Controls point-to-point smoothing. Smoothing is a noise reduction technique that averages adjacent data points in a measurement trace. Choose the amount of smoothing by specifying either the number of points or the aperture. Smoothing is not the same as CALC:AVERage which averages each data point over a number of sweeps.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example us ing some of these commands.

  • Learn about Smoothing

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:SMOothing:APERture <num>

(Read-Write) Sets the amount of smoothing as a percentage of the number of data points in the channel. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Percentage value. Choose any number between: 1 and 25
Examples | CALC:SMO:APER 2 calculate2:smoothing:aperture 20.7
Query Syntax | CALCulate<cnum>:SMOothing:APERture?
Return Type | Character
Overlapped? | No
Default | 1.5

CALCulate<cnum>:SMOothing:POINts <num>

(Read-Write) Sets the number of adjacent data points to average. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Number of points from 1 point to maximum of 25% of data points in the channel. For example: if number of points in a data trace = 401, the maximum value for points = 100. The points value is always rounded to the closest odd number.
Examples | CALC:SMO:POIN 50 calculate2:smoothing:points 21
Query Syntax | CALCulate<cnum>:SMOothing:POINts?
Return Type | Character
Overlapped? | No
Default | 3

CALCulate<cnum>:SMOothing[:STATe] <ON | OFF>

(Read-Write) Turns data smoothing ON or OFF. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON | OFF> | ON (or 1) - turns smoothing ON. OFF (or 0) - turns smoothing OFF.
Examples | CALC:SMO ON calculate2:smoothing:state off
Query Syntax | CALCulate<cnum>:SMOothing[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF


Transform SCPI

Calc:Transform Commands

Specifies the settings for time domain transform.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Time Domain

Note: CALCulate commands act on the selected measurement. You can select one measurement in each channel. Select the measurement for each channel using CALC:PAR:SEL.

CALCulate<cnum>:TRANsform:TIME:CENTer <num>

(Read-Write) Sets the center time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Center time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:CENT 1e-8 calculate2:transform:time:center 15 ps
Query Syntax | CALCulate<cnum>:TRANsform:TIME:CENTer?
Return Type | Character
Overlapped? | No
Default | 0

CALCulate<cnum>:TRANsform:TIME:IMPulse:WIDTh <num>

(Read-Write) Sets the impulse width for the transform window. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Impulse width in seconds; Choose any number between: .6 / frequency span and 1.39 / frequency span
Examples | CALC:TRAN:TIME:IMP:WIDTh 10 calculate2:transform:time:impulse:width 13
Query Syntax | CALCulate<cnum>:TRANsform:TIME:IMPulse:WIDTh?
Return Type | Character
Overlapped? | No
Default | .98 / Default Span

CALCulate<cnum>:TRANsform:TIME:KBESsel <num>

(Read-Write) Sets the parametric window for the Kaiser Bessel window. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Window width for Kaiser Bessel in seconds; Choose any number between: 0.0 and 13.0
Examples | CALC:TRAN:TIME:KBES 10 calculate2:transform:time:kbessel 13
Query Syntax | CALCulate<cnum>:TRANsform:TIME:KBESsel?
Return Type | Character
Overlapped? | No
Default | 6

CALCulate<cnum>:TRANsform:TIME:LPFREQuency

(Write-only) Sets the start frequencies in LowPass Mode. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
Examples | CALC:TRAN:TIME:LPFR calculate2:transform:time:lpfrequency
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

CALCulate<cnum>:TRANsform:TIME:SPAN <num>

(Read-Write) Sets the span time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Span time in seconds; any number between: 0 and 2* [(number of points-1) / frequency span] Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:SPAN 1e-8 calculate2:transform:time:span maximum
Query Syntax | CALCulate<cnum>:TRANsform:TIME:SPAN?
Return Type | Character
Overlapped? | No
Default | 20 ns

CALCulate<cnum>:TRANsform:TIME:STARt <num>

(Read-Write) Sets the start time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Start time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:STAR 1e-8 calculate2:transform:time:start minimum
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STARt?
Return Type | Character
Overlapped? | No
Default | -10 ns

CALCulate<cnum>:TRANsform:TIME:STATe <ON | OFF>

(Read-Write) Turns the time domain transform capability ON or OFF. Critical Note: Note: Sweep type must be set to Linear Frequency in order to use Time Domain Transform.
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<ON|OFF> | ON (or 1) - turns time domain ON. OFF (or 0) - turns time domain OFF.
Examples | CALC:TRAN:TIME:STAT ON calculate2:transform:time:state off
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

CALCulate<cnum>:TRANsform:TIME:STOP <num>

(Read-Write) Sets the stop time for time domain measurements. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Stop time in seconds; any number between: ± (number of points-1) / frequency span Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | CALC:TRAN:TIME:STOP 1e-8 calculate2:transform:time:stop maximum
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STOP?
Return Type | Character
Overlapped? | No
Default | 10 ns

CALCulate<cnum>:TRANsform:TIME:STEP:RTIMe <num>

(Read-Write) Sets the step rise time for the transform window. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<num> | Rise time in seconds; Choose any number between: .45 / frequency span and 1.48 / frequency span
Examples | CALC:TRAN:TIME:STEP:RTIM 1e-8 calculate2:transform:time:step:rtime 15 ps
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STEP:RTIMe?
Return Type | Character
Overlapped? | No
Default | .99 / Default Span

CALCulate<cnum>:TRANsform:TIME:STIMulus <char>

(Read-Write) Sets the type of simulated stimulus that will be incident on the DUT. Critical Note:
Parameters |
<cnum> | Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.
<char> | Choose from: STEP - simulates a step DUT stimulus IMPulse - simulates a pulse DUT stimulus STEP can ONLY be used when CALC:TRAN:TIME:TYPE is set to LPASs (Lowpass). (STEP cannot be used with TYPE = BPASs.) :STIM STEP will set :TYPE to LPASs :TYPE BPASs will set :STIM to IMPulse
Examples | CALC:TRAN:TIME:STIM STEP calculate2:transform:time:stimulus impulse
Query Syntax | CALCulate<cnum>:TRANsform:TIME:STIMulus?
Return Type | Character
Overlapped? | No
Default | IMPulse

CALCulate<cnum>:TRANsform:TIME[:TYPE] <char>

(Read-Write) Sets the type of time domain measurement. Critical Note:

Parameters

<cnum>

Channel number of the measurement. There must be a selected measurement on that channel. If unspecified, <cnum> is set to 1.

<char>

Type of measurement. Choose from:
LPASs - Lowpass; Must also send CALC:TRAN:TIME:LPFRequency before calibrating.
BPASs - Bandpass;

BPASs can only be used when CALC:TRAN:TIME:STIM is set to IMPulse. (BPASs cannot be used with :STIM = STEP)

:STIM STEP will set :TYPE to LPASs

:TYPE BPASs will set :STIM to IMPulse

Examples

CALC:TRAN:TIME LPAS
calculate2:transform:time:type bpas

Query Syntax

CALCulate<cnum>:TRANsform:TIME[:TYPE]?

Return Type

Character

Overlapped?

No

Default

BPAS


Common Commands SCPI

IEEE 488.2 Common Commands

*CLS - Clear Status

*ESE - Event Status Enable

*ESE? - Event Status Enable Query

*ESR? - Event Status Enable Register

*IDN? - Identify

*OPC - Operation complete command

*OPC? - Operation complete query

*OPT? - Identify Options Query

*RST - Reset

*SRE - Service Request Enable

*SRE? - Service Request Enable Query

*STB? - Status Byte Query

*TST? - Result of Self-test Query

*WAI - Wait

*CLS - Clear Status

Clears the instrument status byte by emptying the error queue and clearing all event registers. Also cancels any preceding *OPC command or query. See Status Commands and Reading the Analyzer's Status Registers.

*ESE - Event Status Enable

Sets bits in the standard event status enable register. See Status Commands and Reading the Analyzer's Status Registers.

*ESE? - Event Status Enable Query

Returns the results of the standard event enable register. The register is cleared after reading it. See Status Commands and Reading the Analyzer's Status Registers.

*ESR - Event Status Enable Register

Reads and clears event status enable register. See Status Commands and Reading the Analyzer's Status Registers.

*IDN? - Identify

Returns a string that uniquely identifies the analyzer. The string is of the form "Agilent Technologies",<model number>,<serial "number>,<software revision>" .

*OPC - Operation complete command

Generates the OPC message in the standard event status register when all pending overlapped operations have been completed (for example, a sweep, or a Default). See Understanding Command Synchronization.

*OPC? - Operation complete query

Returns an ASCII "1" when all pending overlapped operations have been completed. See Understanding Command Synchronization

*OPT? - Identify Options Query

Returns a string identifying the analyzer option configuration.

*RST - Reset

Executes a device reset and cancels any pending *OPC command or query, exactly the same as a SYSTem:PRESet. The contents of the analyzer's non-volatile memory are not affected by this command.

*SRE - Service Request Enable

Before reading a status register, bits must be enabled. This command enables bits in the service request register. The current setting is saved in non-volatile memory. See Status Commands and Reading the Analyzer's Status Registers.

*SRE? - Service Request Enable Query

Reads the current state of the service request enable register. The register is cleared after reading it. The return value can be decoded using the table in Status Commands. See also Reading the Analyzer's Status Registers.

*STB? - Status Byte Query

Reads the value of the instrument status byte. The register is cleared only when the registers feeding it are cleared. See Status Commands and Reading the Analyzer's Status Registers.

*TST? - Result of Self-test Query

Returns the result of a query of the analyzer hardward status. An 0 indicates no failures found. Any other value indicates one or more of the following conditions exist. The value returned is the Weight (or sum of the Weights) of the existing conditions. For example:

  • If 4 is returned from *TST?, an Overpower condition exists.

  • If 6 is returned, both Unleveled and Overpower conditions exists.
Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Phase Unlock | the source has lost phaselock. This could be caused by a reference channel open or a hardware failure.
1 | 2 | Unleveled | the source power is unleveled. This could be a source is set for more power than it can deliver at the tuned frequency. Or it could be caused by a hardware failure.
2 | 4 | Overpower | too much power is detected at the input. This is from either using an amplifier, or a hardware failure.
3 | 8 | EE Write Failed | an attempted write to the EEPROM has failed. This is possibly caused by a hardware failure.
4 | 16 | YIG Cal Failed | the analyzer was unable to calibrate the YIG. Either the phaselock has been lost or there has been a hardware failure.
5 | 32 | Ramp Cal Failed | the analyzer was unable to calibrate the analog ramp generator due to a possible hardware failure.
6 | 64 | OverTemp | the source temperature sensor exceeds the limit. It could result from restricted airflow or a broken fan

*WAI - Wait

Prohibits the instrument from executing any new commands until all pending overlapped commands have been completed. See Understanding Command Synchronization


Control SCPI

Control Commands

Specifies the settings to remotely control the rear panel connectors.

  • Click on a blue keyword to view the command details.

  • See a List of all SCPI commands.

  • See a pinout and detailed description of the rear panel connectors:

    • Auxilliary IO connector

    • External Test Set IO connector

    • Material Handler IO connector

CONTrol:AUXiliary:C[:DATA] <num>

(Read-Write) Reads and writes a 4-bit value to Port C on the Aux I/O connector. This port is connected internally to the Handler IO connector. Therefore this command will also affect the state of Port C on the Handler IO
Parameters |
<num> | Data value. Choose any number 0 to 15.
Examples | CONTrol:AUXiliary:C:DATA 15 For Positive Logic Port C lines C0, C1, C2, C3 go High or if in Negative Logic they go Low. CONTrol:AUXiliary:C:DATA? A returned value of 15 when in Positive Logic indicates Port C lines C0, C1, C2, C3 are High, or if in Negative Logic they are Low.
Query Syntax | CONTrol:AUXiliary:C:DATA?
Return Type | Integer
Overlapped? | No
Default | 0

CONTrol:AUXiliary:C:LOGic <char>

(Read-Write) Reads and writes the logic mode of Port C on the AUX IO. This port is connected to Port C of the Handler IO connector. Therefore, it will have the same logic setting.

Parameters

<char>

Logic of Port C. Choose from:

POSitive - when a value of one is written the associate line goes High

NEGative - when a value of one is written the associate line goes Low

When Port C is in Output/Write mode, a change in logic causes the output lines to change state immediately. For example, Low levels change to High levels.

When Port C is in Input/Read mode, a change in logic does NOT cause the lines to change, but data read from Port C will reflect the change in logic.

Examples

CONT:AUX:C:LOG POS 'Positive logic is applied to Port C data.

Query Syntax

CONTrol:AUXiliary:C:LOGic?

Return Type

Character

Overlapped?

No

Default

NEGative

CONTrol:AUXiliary:C:MODE <char>

(Read-Write) Sets Port C to read or write mode. This port is connected to Port C of the Handler IO connector. Therefore, it will have the same mode setting.

NOTE: When Port C is set to INPut mode, data writes are NOT applied to the lines. MODE must be set to OUTPut mode before writing.

Parameters

<char>

INPut - set the port for reading

OUTPut - set the port for writing

Examples

CONT:AUX:C:MOD INP 'set Port C to Input Mode for reading.

CONTrol:AUXiliary:C:MODE? 'queries the input/output mode that the port set to.

Query Syntax

CONTrol:AUXiliary:C:MODE?

Return Type

Character

Overlapped?

No

Default

INPut

CONTrol:AUXiliary:FOOTswitch?

(Read) Reads the Auxiliary connector Footswitch Input (pin 20 of the AUX IO connector).
Examples | CONT:AUX:FOOT? control:auxiliary:footswitch?
Return Type | Boolean True (or 1) = pressed False (or 0) = released
Overlapped? | No
Default | False (0) - Released

CONTrol:AUXiliary:FOOTswitch:MODE <char>

(Read-Write) Determines what occurs when the footswitch is pressed. For more information see the FootSwitch In pin description in the Auxiliary IO connector.

Parameters

<char>

IGNore - Footswitch presses are ignored.

SWEep - Footswitch presses trigger a sweep. The PNA must be in Manual Trigger Mode.

RECall - Footswitch presses recall an instrument state. When more than one state is available, then each footswitch press recalls the next state, then starts over from the beginning. It is possible for a recalled state to override the current mode. If the recalled state is IGNore, then mode changes and additional footswitch presses are ignored.

MACRo - Footswitch presses load and run a macro. When more than one macro is available, then each footswitch press loads and runs the next macro, then starts over from the beginning. It is possible for a Macro to override the current mode. If the macro contains a Preset, then the mode changes to the default setting IGNore and additional footswitch presses are ignored.

Examples

CONT:AUX:FOOT:MODe MACRo 'sets the footswitch mode to MACRo causing a macro to be loaded and run with a footswitch press.

CONTrol:AUXiliary:Footswitch:MODE? 'queries the footswitch mode setting

Query Syntax

CONTrol:AUXiliary:FOOTswitch:MODE?

Return Type

Character

Overlapped?

No

Default

IGNore

CONTrol:AUXiliary:INPut:VOLTage?

(Read-Only) Reads the ADC input voltage from pin 14 of the AUX IO connector.
Examples | CONT:AUX:INPut:VOLT? control:auxiliary:input:voltage?
Return Type | REAL
Overlapped? | No
Default | Not Applicable

CONTrol:AUXiliary:OUTPut<out>:MODE <char>

(Read-Write) Sets and reads whether the voltage sent to the specified Analog Out line on the Auxiliary IO is applied immediately or after the sweep is completed. See the Analog Out 1, 2 pin description.
Parameters |
<out> | DAC output number. Choose from: 1 - DAC Output 1 (pin 2) 2 - DAC Output 2 (pin 3)
<char> | WAIT - Voltage changes sent to the selected analog out are applied between sweeps. NOWait - Voltage changes sent to the selected analog out are applied immediately, without waiting until the end of a sweep.
Examples | CONT:AUX:OUTP1:MODE NOW control:auxiliary:output2:mode nowait
Query Syntax | CONTrol:AUXiliary:OUTPut<out>:MODE? 'Reads the output mode
Return Type | Character
Overlapped? | No
Default | WAIT

CONTrol:AUXiliary:OUTPut<out>:VOLTage <num>

(Read-Write) Sets and reads voltages on the DAC/Analog Output 1 and Output 2 (pins 2 and 3) of the Auxiliary IO connector.
Parameters |
<out> | DAC output number. Choose from: 1 - DAC Output 1 (pin 2) 2 - DAC Output 2 (pin 3)
<num> | Output Voltage. Choose a voltage value between -10 and +10 volts
Examples | CONT:AUX:OUTP1:VOLT 5 control:auxiliary:output2:voltage 5
Query Syntax | CONTrol:AUXiliary:OUTPut<out>:VOLTage? 'Reads the output DAC voltage
Return Type | REAL
Overlapped? | No
Default | 0

CONTrol:AUXiliary:PASSfail:LOGic <char>

(Read-Write) Sets the logic of the PassFail line (pin 12) on the AUX IO connector. This line is connected internally to the PassFail line of the Material Handler IO (pin 33).
Parameters |
<char> | Choose from: POSitive - Causes the PassFail line to have positive logic (high = pass, low = fail). NEGative - Causes the PassFail line to have negative logic (high = fail, low = pass).
Examples | CONT:AUX:PASS:LOG POS control:auxiliary:passfail:logic negative
Query Syntax | CONTrol:AUXiliary:PASSfail:LOGic?
Return Type | Character
Overlapped? | No
Default | POSitive

CONTrol:AUXiliary:PASSfail:MODe <char>

(Read-Write) Sets and reads the mode for the PassFail line (pin 12) on the AUX IO connector. This line is hardwired to the PassFail line (pin 33) of the Material Handler IO connector.

Parameters

<char>

Choose from:
PASS - the line stays in PASS state. When a device fails, then the line goes to FAIL state after the SweepEnd line is asserted.

FAIL - the line stays in FAIL state. When a device passes, then the line goes to PASS state after the SweepEnd line is asserted.

NOWait - the line stays in PASS state. When a device fails, then the line goes to FAIL state IMMEDIATELY.

Examples

CONT:AUX:PASS:MODE NOW
control:auxiliary:passfail:mode fail

Query Syntax

CONTrol:AUXiliary:PASSfail:MODE?

Return Type

Character

Overlapped?

No

Default

NOWait

CONTrol:AUXiliary:PASSfail:SCOPe <char>

(Read-Write) Sets and reads the scope of the PassFail line on the AUX IO connector. This line is connected to the PassFail line of the Handler IO connector. Therefore, it will have the same scope.

Parameters

<char>

Choose from:
Channel - The PassFail line returns to its default state before sweeps on the next channel start. (A channel measurement may require several sweeps.)

Global - The PassFail line returns to its default state before the sweeps for the next triggerable channel start.

The default state of the passFail line (before a measurement occurs and after a failure occurs) is set by CONTrol:AUXiliary:PASSfail:MODe

Examples

CONT:AUX:PASS:SCOP CHAN
control:auxiliary:passfail:scope sweep

Query Syntax

CONTrol:AUXiliary:PASSfail:SCOPe?

Return Type

Character

Overlapped?

No

Default

CYCLe

CONTrol:AUXiliary:SWEepend <char>

(Read-Write) Specifies the event that will cause the AUX IO Sweep End line (pin 11) to go to a low (false) state. The line will return to a high state after the appropriate calculations are complete. This line is connected internally to the Sweep End line of the Material Handler IO.
Parameters |
<char> | Choose from: Sweep - the line goes low when each sweep is complete. Channel - The line goes low when all of the sweeps for each channel is complete. Global - The line goes low when all the sweeps for all channels are complete. The default state of the passFail line (before a measurement occurs and after a failure occurs) is set by CONTrol:AUXiliary:PASSfail:MODe.
Examples | CONT:AUX:SWE SWE control:auxiliary:sweepend channel
Query Syntax | CONTrol:AUXiliary:SWEepend?
Return Type | Character
Overlapped? | No
Default | SWEep

CONTrol:EXTernal:TESTset:DATa <addr>,<data>

(Read-Write) Reads and writes 13 bits of data to the specified address using the AD0 through AD12 lines of the external test set connector. The instrument generates the appropriate timing signals (strobes the address, then the data) to control an external test set.
Parameters |
<addr> | Decimal equivalent of the 13 bit binary address.
<data> | Decimal equivalent of the 13 bit binary data
Examples | CONT:EXT:TEST:DATA 12,3 CONTrol:external:testset:data 12,3
Query Syntax | CONTrol:EXTernal:TESTset:DATA? <addr> 'Reads the decimal equivalent of the binary data from the specified address
Return Type | Integer
Overlapped? | No
Default | Not Applicable

CONTrol:EXTernal:TESTset:INTerrupt?

(Read-Only) Reads the boolean state of the Interrupt In line (pin 13) on the external test set connector.
Examples | CONT:EXT:TEST:INT? control:external:testset:interrupt?
Return Type | Boolean False (0) - the line is being held at a TTL High. True (1) - the line is being held at a TTL Low.
Overlapped? | No
Default | Not Applicable

CONTrol:EXTernal:TESTset:RAWData <data>

(Read-Write) Reads and writes 16 bits of data through the AD0 through AD12 and three timing lines of the external test set connector. Does NOT generate appropriate timing signals.

Use of this command requires detailed knowledge of all 16 bits. Refer to the Data format table.

Note: During a WRITE, Bit 13 must always be low. Otherwise Bit 0-12 will tristate

Parameters

<data>

Decimal equivalent of the binary data.

Format of data WRITTEN with RAWData:

Pin | Bit | Signal name
22 | 0 | AD0*
23 | 1 | AD1*
11 | 2 | AD2*
10 | 3 | AD3*
9 | 4 | AD4*
21 | 5 | AD5*
20 | 6 | AD6*
19 | 7 | AD7*
6 | 8 | AD8*
5 | 9 | AD9*
4 | 10 | AD10*
17 | 11 | AD11*
3 | 12 | AD12*
25 | 13 | RLW
24 | 14 | LDS
8 | 15 | LAS

* This Output will float if RLW (bit-13) is set high

Examples | CONT:EXT:TEST:RAWD 8001 CONTrol:external:testset:rawdata 1234
Query Syntax | CONTrol:EXTernal:TESTset:RAWData?
Return Format | Format of data READ with RAWData?
Pin | Bit | Signal name
22 | 0 | AD0*
23 | 1 | AD1*
11 | 2 | AD2*
10 | 3 | AD3*
9 | 4 | AD4*
21 | 5 | AD5*
20 | 6 | AD6*
19 | 7 | AD7*
6 | 8 | AD8*
5 | 9 | AD9*
4 | 10 | AD10*
17 | 11 | AD11*
3 | 12 | AD12*
2 | 13 | Sweep Holdoff In
13 | 14 | Interrupt In (inverted internally)
na | 15 | Always Zero, grounded internally
 | *These lines are dependent on the state of RLW (pin25). Writing a 0(low) to RLW will set lines AD0-AD12 to write mode. Writing a 1(high) to RLW will set lines AD0-AD12 to read mode.
Return Type | Integer
Overlapped? | No
Default | Not Applicable

CONTrol:EXTernal:TESTset:SWEepholdoff?

(Read-Only) Reads the Sweep Holdoff Iine (pin 2) on the external test set connector.
Examples | CONT:EXT:TEST:SWE? control:external:testset:sweepholdoff?
Return Type | Boolean TRUE (1) - the pin is set to a TTL High FALSE (0) - the pin is set to TTL Low
Overlapped? | No
Default | Not Applicable

CONTrol:HANDler:C:MODE <char>

(Read-Write) Sets and reads the direction of data flow for Port C.
Parameters |
<char> | Direction of flow. Choose from: INPut - Port C is used to input data OUTPut - Port C is used to output data
Examples | CONT:HAND:C:MODE INP control:handler:c:mode output
Query Syntax | CONTrol:HANDler:C:MODE?
Return Type | Character
Overlapped? | No
Default | INPut

CONTrol:HANDler:D:MODE <char>

(Read-Write) Sets and reads the direction of data flow for Port D
Parameters |
<char> | Direction of flow. Choose from: INPut - Port D is used to input data OUTPut - Port D is used to output data
Examples | CONT:HAND:D:MODE INP control:handler:d:mode output
Query Syntax | CONTrol:HANDler:D:MODE?
Return Type | Character
Overlapped? | No
Default | Input

CONTrol:HANDler:<port>[:DATa] <num>

(Read-Write) Writes and reads data on the specified port.
Parameters |
<port> | Port identifier to set bits for. Choose from: A,B,C,D,E,F,G,H
<num> | The number of the data bits to set. Refer to the following table for the maximum number for each port. The minimum number for each port is 0.
Port | Max allowable <num> | MSB...........................................LSB 23...................................................0 |
A | 255 | A7...A0 | Write-only
B | 255 | B7...B0 | Write-only
C | 15 | C3...C0 | Read-Write
D | 15 | D3...D0 | Read-Write
E | 255 | D3...D0 + C3...C0 | Read-Write
F | 65535 | B7...B0 + A7...A0 | Write-only
G | 1048575 | C3...C0 + B7...B0 + A7...A0 | Write-only
H | 16777215 | D3...D0 + C3...C0 + B7...B0 + A7...A0 | Write-only

 | Note: When writing to port G, port C must be set to output mode When writing to port H, both port C and port D must be set to output mode. Use CONT:HAND:C:MODE OUTP and CONT:HAND:D:MODE OUTP
Examples | CONT:HAND:A 254 control:handler:c:data 12
Query Syntax | CONTrol:HANDler:<port>:DATA?
Return Type | Integer
Overlapped? | No
Default | Not Applicable

CONTrol:HANDler:INPut?

(Read-Only) Reads a hardware latch that captures low to high transition on Input1 of the Material Handler IO. Reading the latch causes it to reset and is ready for the next transition. The hardware latch is only capable of capturing one transition per query. Additional transitions are ignored until after the next query.

Examples

CONT:HAND:INP?
control:handler:input?

Return Type

Integer - Returns a value of zero or one.

One - A low to high transition occurred at Input1 since the last time it was queried.

Zero - No low to high transition occurred. After the query the latch is reset and is ready for the next input. If no low to high transitions occur additional queries will return zero.

Momentarily grounding or driving Input1 low, then high, will cause a transition to be detected and latched.

Overlapped?

No

Default

0

CONTrol:HANDler:LOGic <char>

(Read-Write) Sets the logic of the Data ports A-H on the Handler connector. Some of these lines are connected internally to the AuxIO.

Parameters

<char>

Choose from:
POSitive- Causes the Port lines to have positive logic (high = 1, low = 0).

NEGative- Causes the Port lines to have negative logic (high = 0, low = 1).

For ports that are in output (write) mode, a change in logic causes the output lines to change state immediately. For example, Low levels change immediately to High levels.

For ports that are in input (read) mode (C,D,E only), a change in logic will be reflected when data is read from that port. For example, if a line read 0, the next read after a logic change will read 1.

Examples

CONT:HAND:LOG POS
control:handler:logic negative

Query Syntax

CONTrol:HANDler:LOGic?

Return Type

Character

Overlapped?

No

Default

POSitive

CONTrol:HANDler:OUTPut<num>[:DATa] <num2>

(Read-Write) Sets or reads whether the specified output line is High or Low.
Parameters |
<num> | Output port. Choose from: 1 - output 1(default) 2 - output 2
<num2> | 0 - Low 1 - High
Examples | CONT:HAND:OUTPut1 1 control:handler:output2:data 0
Query Syntax | CONTrol:HANDler:OUTPut<num>:DATA?
Return Type | Integer (0 or 1)
Overlapped? | No
Default | 0 - Low

CONTrol:HANDler:OUTPut<num>:USER[:DATa] <num2>

(Read-Write) Sets or reads whether the specified USER output line is High or Low.
Parameters |
<num> | USER Output port. Choose from: 1 - User output 1(default) 2 - User output port.
<num2> | 0 - Low 1 - High
Examples | CONT:HAND:OUTPut1:USER 1 control:handler:output2:user:data 0
Query Syntax | CONTrol:HANDler:OUTPut<num>:USER:DATA?
Return Type | Integer (0 or 1)
Overlapped? | No
Default | 0 - Low

CONTrol:HANDler:PASSfail:LOGic <char>

(Read-Write) Sets the logic of the PassFail line of the Material Handler IO (pin 33). This line is connected internally to the PassFail line (pin 12) on the AUX IO connector.
Parameters |
<char> | Choose from: POSitive- Causes the PassFail line to have positive logic (high = pass, low = fail). NEGative- Causes the PassFail line to have negative logic (high = fail, low = pass).
Examples | CONT:HAND:PASS:LOG POS control:handler:passfail:logic negative
Query Syntax | CONTrol:HANDler:PASSfail:LOGic?
Return Type | Character
Overlapped? | No
Default | POSitive

CONTrol:HANDler:PASSfail:MODe <char>

(Read-Write) Sets the mode for the PassFail line (pin 33) of the Material Handler IO connector. This line is hardwired to the PassFail line (pin 12) on the AUX IO connector.

Parameters

<char>

Choose from:
PASS- the line stays in PASS state. When a device fails, then the line goes to fail after the Sweep End line is asserted.

FAIL- the line stays in FAIL state. When a device passes, then the line goes to PASS state after the Sweep End line is asserted.

NOWait- the line stays in PASS state. When a device fails, then the line goes to fail IMMEDIATELY.

Examples

CONT:HAND:PASS:MODE NOW
control:handler:passfail:mode fail

Query Syntax

CONTrol:HANDler:PASSfail:MODE?

Return Type

Character

Overlapped?

No

Default

NOWait

CONTrol:HANDler:PASSfail:SCOPe <char>

(Read-Write) Sets and reads scope mode of the PassFail line on the HANDLER IO. This line is connected to the PassFail line of the Handler IO connector. Therefore, it will have the same scope.

Parameters

<char>

Choose from:

CHANnel- The PassFail line returns to its default state before sweeps on the next channel start. (A channel measurement may require several sweeps.)

GLOBal - The PassFail line returns to its default state before the sweeps for the next triggerable channel start.

The default state of the passFail line (before a measurement occurs) and after a failure occurs is set by CONTrol:HANDler:PASSfail:MODe

Examples

CONT:HAND:PASS:SCOP CHAN
control:handler:passfail:scope sweep

Query Syntax

CONTrol:HANDler:PASSfail:SCOPe?

Return Type

Character

Overlapped?

No

Default

GLOBal

CONTrol:HANDler:SWEepend <char>

(Read-Write) Specifies the event that will cause the Handler Sweep End line to go to a low (false) state. The line will return to a high state after the appropriate calculations are complete. This line is connected internally to the Sweep End line of the AUX IO connector.
Parameters |
<char> | Choose from: SWEep - the line goes low when each sweep is complete CHANnel - the line goes low when all the sweeps for each channel is complete. GLOBal - the line goes low when all sweeps for all channels are complete. The default state of the passFail line (before a measurement occurs) and after a failure occurs is set by CONTrol:HANDler:PASSfail:MODe
Examples | CONT:HAND:SWE SWE control:handler:sweepend channel
Query Syntax | CONTrol:HANDler:SWEepend?
Return Type | Character
Overlapped? | No
Default | SWEep

CONTrol:SIGNal <conn>,<char>

(Read-Write) Enables external edge triggering in the PNA. To receive trigger signals from an external source, the PNA must be in External trigger mode. For synchronized measurements, when sending or receiving trigger signals, both the source and PNA must have the same number of data points per sweep and be in point sweep mode, or equivalent source setting. Edge triggering is only available on PNA models E8361A, E8362B, E8363B, and E8364B. For more information, see Edge Triggering.

Parameters

<conn>

Rear Panel connector to send or receive trigger signals. Choose from:

BNC1 Trigger IN from external source (Trigger IN BNC connector)

AUXT Trigger IN from external source (AUX IO connector Pin 19)

Note: Only one of the input connectors is active at a time. When a command is sent to one, the PNA automatically makes the other INACTIVE.

BNC2 Trigger OUT to external source (Trigger OUT BNC connector)

<char>

When <conn> is set to either BNC1 or AUXT choose from:

TIENEGATIVE - (Trigger In Edge Negative) - Triggers the PNA when receiving a negative going signal

TIEPOSITIVE - (Trigger In Edge Positive) - Triggers the PNA when receiving a positive going signal

TILLOW - (Trigger In Level Low) - Triggers the PNA when receiving a low level signal

TILHIGH - (Trigger In Level High) - Triggers the PNA when receiving a High-level signal

INACTIVE - Disables the specified connector.

Note: The channel to be triggered must be in point sweep mode

When <conn> is set to BNC2 choose from:

TOPPAFTER - (Trigger Out Pulse Positive After) - Sends a POSITIVE going TTL pulse at the END of each point during the sweep.

TOPBEFORE - (Trigger Out Pulse Positive Before) - Sends a POSITIVE going TTL pulse at the START of each point during the sweep.

TOPNAFTER - (Trigger Out Pulse Negative After) - Sends a NEGATIVE going TTL pulse at the END of each point during the sweep.

TOPNBEFORE - (Trigger Out Pulse Negative Before) - Sends a NEGATIVE going TTL pulse at the START of each point during the sweep.

INACTIVE - Disables the specified connector.

Examples

CONT:SIGN BNC1,TIENEGATIVE
control:signal bnc2,topbefore

Query Syntax

CONTrol:SIGNal <conn>?

In addition to the arguments listed above, the following is also a possible returned value:

NAVAILABLE - This feature is not available on this PNA

Return Type

Character

Overlapped?

No

Default

BNC1 = INACTIVE
BNC2 = INACTIVE
AUXT = TILHIGH


Display SCPI

Display Commands

Controls the settings of the front panel screen.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example using some of these commands

  • Learn a bout Screen Setup

DISPlay:ANNotation:FREQuency[:STATe] <ON | OFF>

(Read-Write) Turns frequency information on the display title bar ON or OFF for all windows.
Parameters |
<ON | OFF> | ON (or 1) - turns frequency annotation ON. OFF (or 0) - turns frequency annotation OFF.
Examples | DISP:ANN:FREQ ON display:annotation:frequency:state off
Query Syntax | DISPlay:ANNotation:FREQuency[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON (1)

DISPlay:ANNotation:MESSage:STATe <ON | OFF>

(Read-Write) Enables and disables error pop-up messages on the display.
Parameters |
<ON | OFF> | ON (or 1) - enables error pop-up messages OFF (or 0) - disables error pop-up messages
Examples | DISP:ANN:MESS:STAT ON display:annotation:message:state off
Query Syntax | DISPlay:ANNotation:MESSage:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON (1)

DISPlay:ANNotation:STATus <ON|OFF>

(Read-Write) Turns the status bar at the bottom of the screen ON or OFF. The status bar displays information for the active window.
Parameters |
<ON | OFF> | ON (or 1) - turns status bar ON. OFF (or 0) - turns status bar OFF.
Examples | DISP:ANN:STAT ON display:annotation:status off
Query Syntax | DISPlay:ANNotation:STATus?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Last state that was set

DISPlay:CATalog?

(Read-only) Returns the existing Window numbers.
Return Type | String of Character values, separated by commas
Example | Two windows with numbers 1 and 2 returns: "1,2"
Overlapped? | No
Default | Not applicable

DISPlay:ENABLE <ON | OFF>

(Read-Write) Specifies whether to disable or enable all analyzer display information in all windows in the analyzer application. Marker data is not updated. More CPU time is spent making measurements instead of updating the display.
Parameters |
<ON | OFF> | ON (or 1) - turns the display ON. OFF (or 0) - turns the display OFF.
Examples | DISP:ENAB ON display:enable off
Query Syntax | DISPlay:ENABle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay[:TILE]

(Write-only) Tiles the windows on the screen.
Examples | DISP display:tile
Overlapped? | No
Default | Not Applicable

DISPlay:WINDow<wnum>:ANNotation:MARKer:SINGle[:STATe] <bool>

(Read-Write) Either shows marker readout of only the active trace or all of the traces simultaneously. See other SCPI Marker commands
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<bool> | ON (or 1) - show a single marker per trace OFF (or 0) - show up to 4 markers per active trace
Examples | DISP:WIND:ANN:MARK:SING ON display:window:annotation:marker:single off
Query Syntax | DISPlay:WINDow:ANNotation:MARKer:SINGle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

DISPlay:WINDow<wnum>:ANNotation:MARKer:SIZE <char>

(Read-Write) Specifies the size of the marker readout text. See other SCPI Marker commands
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<char> | Readout text size. Choose from:NORMal | LARGe
Examples | DISP:WIND:ANN:MARK:SIZE LARG display:window:annotation:marker:size normal
Query Syntax | DISPlay:WINDow:ANNotation:MARKer:SIZE?
Return Type | Character
Overlapped? | No
Default | NORMal

DISPlay:WINDow<wnum>:ANNotation:MARKer:STATe <ON|OFF>

(Read-Write) Specifies whether to show or hide the Marker data (when markers are ON) on the selected window. See other SCPI Marker commands
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns marker data ON. OFF (or 0) - turns marker data OFF.
Examples | DISP:WIND:ANN:MARK:STAT ON display:window:annotation:marker:state off
Query Syntax | DISPlay:WINDow:ANNotation:MARKer:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:ANNotation:TRACe:STATe <ON|OFF>

(Read-Write) Specifies whether to show or hide the Trace Status buttons on the left of the display.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns the buttons ON. OFF (or 0) - turns the buttons OFF.
Examples | DISP:WIND:ANN:TRAC:STAT ON display:window:annotation:trace:state off
Query Syntax | DISPlay:WINDow:ANNotation:TRACe:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:CATalog?

(Read-only) Returns the trace numbers for the specified window.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
Return Type | String of Character values, separated by commas
Example | Window 1 with four traces: DISPlay:WINDow1:CATalog? Returns: "1,2,3,4"
Overlapped? | No
Default | Not applicable

DISPlay:WINDow<wnum>:ENABle <ON | OFF>

(Read-Write) Specifies whether to disable or enable all analyzer display information in the specified window. Marker data is not updated. More CPU time is spent making measurements instead of updating the display.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns the display ON. OFF (or 0) - turns the display OFF.
Examples | DISP:WIND:ENABle ON display:window1:enable off
Query Syntax | DISPlay:WINDow<wnum>:ENABle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>[:STATe] <ON | OFF>

Write to create or delete a window on the screen or Read whether a window is present.
Parameters |
<wnum> | Window number to create; choose any integer between: 1 and 4
<ON | OFF> | ON (or 1) - The window <wnum> is created. OFF (or 0) - The window <wnum> is deleted.
Examples | DISP:WIND ON display:window2:state off
Query Syntax | DISPlay:WINDow<wnum>[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Window number "1" ON

DISPlay:WINDow<wnum>:TABLe <char>

Write to show the specified table at the bottom of the analyzer screen or Read to determine what table is visible.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1
<char> | Table to show. Choose from: OFF | MARKer | LIMit | SEGMent
Examples | DISP:WIND:TABLe SEGM display:window:table off
Query Syntax | DISPlay:WINDow:TABLe?
Overlapped? | No
Default | OFF

DISPlay:WINDow<wnum>:TITLe:DATA <string>

(Read-Write) Sets data in the window title area. The title is turned ON and OFF with DISP:WIND:TITL:STAT OFF.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<string> | Title to be displayed. Any characters, enclosed with quotes. If the title string exceeds 50 characters, an error will be generated and the title not accepted. Newer entries replace (not append) older entries.
Examples | DISP:WIND:TITL:DATA 'hello' display:window2:title:data 'hello'
Query Syntax | DISPlay:WINDow<wnum>:TITLe:DATA?
Return Type | String
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TITLe[:STATe] <ON | OFF>

(Read-Write) Turns display of the title string ON or OFF. When OFF, the string remains, ready to be redisplayed when turned back ON.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the title string ON. OFF (or 0) - turns the title string OFF.
Examples | DISP:WIND:TITL ON Display:window1:title:state off
Query Syntax | DISPlay:WINDow<wnum>:TITLe[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:TRACe<tnum>:DELete

(Write-only) Deletes the specified trace from the specified window. The measurement parameter associated with the trace is not deleted.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | The number of the trace to be deleted; if unspecified, value is set to 1
Examples | DISP:WIND:TRAC:DEL display:window2:trace2:delete
Query Syntax | Not applicable
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TRACe<tnum>:FEED <name>

(Write-only) Creates a new trace <tnum> and associates (feeds) a measurement <name> to the specified window<wnum>. This command should be executed immediately after creating a new measurement with CALC:PAR:DEF<name>,<parameter>.

To feed the same measurement to multiple traces, create another measurement with the same <name>,<parameter> using the CALC:PAR:DEF command. The analyzer will collect the data only once.

Parameters

<wnum>

Any existing window number (1 to 4); if unspecified, value is set to 1.

<tnum>

Trace number to be created. Choose any Integer between:
1 and 4

<name>

Name of the measurement that was defined with CALC:PAR:DEF<name>,<parameter>

Examples

DISP:WIND:TRAC:FEED 'test'
display:window2:trace2:feed 'test'

Query Syntax

Not applicable

Overlapped?

No

Default

"CH1_S11"

DISPlay:WINDow<wnum>:TRACe<tnum>MEMory[:STATe] <ON | OFF>

(Read-Write) Turns the memory trace ON or OFF.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the memory trace ON. OFF (or 0) - turns the memory trace OFF.
Examples | DISP:WIND:TRAC:MEM ON display:window2:trace2:memory:state off
Query Syntax | DISPlay:WIND<wnum>:TRACe<tnum>:MEMory[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

DISPlay:WINDow<wnum>:TRACe<tnum>:SELect

(Write-only) Activates the specified trace in the specified window for front panel use.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
Examples | DISP:WIND:TRAC:SEL display:window2:trace2:select
Query Syntax | Not applicable
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TRACe<tnum>[:STATe] <ON | OFF>

(Read-Write) Turns the display of the specified trace in the specified window ON or OFF. When OFF, the measurement behind the trace is still active.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the trace ON. OFF (or 0) - turns the trace OFF.
Examples | DISP:WIND:TRAC ON display:window2:trace2:state off
Query Syntax | DISPlay:WIND<wnum>:TRACe<tnum>[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:AUTO

(Write-only) Performs an Autoscale on the specified trace in the specified window, providing the best fit display. Autoscale is performed only when the command is sent; it does NOT keep the trace autoscaled indefinitely.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
Examples | DISP:WIND:TRAC:Y:AUTO display:window2:trace2:y:scale:auto
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:PDIVision <num>

(Read-Write) Sets the Y axis Per Division value of the specified trace in the specified window.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<num> | Units / division value. The range of acceptable values is dependent on format and domain. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | DISP:WIND:TRAC:Y:PDIV 1 display:window2:trace2:y:scale:pdivision maximum
Query Syntax | DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:PDIVision?
Return Type | Character
Overlapped? | No
Default | 10

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RLEVel <num>

(Read-Write) Sets the Y axis Reference Level of the specified trace in the specified window.
Parameters |
<wnum> | Any existing window number (1 to 4); if unspecified, value is set to 1.
<tnum> | Any existing trace number; if unspecified, value is set to 1
<num> | Reference level value. The range of acceptable values is dependent on format and domain. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | DISP:WIND:TRAC:Y:RLEV 0 display:window2:trace2:y:scale:rlevel minimum
Query Syntax | DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RLEVel?
Return Type | Character
Overlapped? | No
Default | NA

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RPOSition <num>

(Read-Write) Sets the Reference Position of the specified trace in the specified window

Parameters

<wnum>

Any existing window number (1 to 4); if unspecified, value is set to 1.

<tnum>

Any existing trace number; if unspecified, value is set to 1

<num>

Reference position on the screen measured in horizontal graticules from the bottom. The range of acceptable values is dependent on format and domain.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

DISP:WIND:TRAC:Y:RPOS 0
display:window2:trace2:y:rposition maximum

Query Syntax

DISPlay:WINDow<wnum>:TRACe<tnum>:Y[:SCALe]:RPOSition?

Return Type

Character

Overlapped?

No

Default

5


Format SCPI

Format Commands

Specifies the way that data will be transferred when moving large amounts of data. These commands will affect data that is transferred with the CALC:DATA and CALC:RDATA commands.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

FORMat:BORDer <char>

(Read-Write) Set the byte order used for GPIB data transfer. Some computers read data from the analyzer in the reverse order. This command is only implemented if FORMAT:DATA is set to :REAL. If FORMAT:DATA is set to :ASCII, the swapped command is ignored.

Parameters

<char>

Choose from:
NORMal - Use when your controller is anything other than an IBM compatible computers
SWAPped - for IBM compatible computers

Examples

FORM:BORD SWAP
format:border normal

Query Syntax

FORMat:BORDer?

Overlapped?

No

Default

Normal

FORMat[:DATA] <char>

(Read-Write) Sets the data format for data transfers. To transfer measurement data, use the CALC:DATA command.

To transfer Source Power correction data, use SOURce:POWer:CORRection:COLLect:TABLe:DATA
SOURce:POWer:CORRection:COLLect:TABLe:FREQuency
SOURce:POWer:CORRection:DATA

Parameters

<char>

Choose from:
REAL,32 - (default value for REAL) Best for transferring large amounts of measurement data.
REAL,64 - Slower but has more significant digits than REAL,32. Use REAL,64 if you have a computer that doesn't support REAL,32.
ASCii,0 - The easiest to implement, but very slow. Use if small amounts of data to transfer.

For more information, see Transferring Measurement Data

Examples

FORM REAL,64
format:data ascii

Query Syntax

FORMat:DATA?

Return Type

Character,Character

Overlapped?

No

Default

REAL,32


Hardcopy SCPI

Hardcopy Command

Learn about Printing

HCOPy[:IMMediate]

(Write-only) Prints the screen to the default printer.
Examples | HCOP hcopy:immediate
Query Syntax | Not applicable
Overlapped? | No
Default | Not Applicable


Initiate SCPI

Initiate Commands

Controls triggering signals

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn a bout Triggering

INITiate:CONTinuous <boolean>

(Read-Write) Specifies whether the analyzer sends Continuous sweep triggers to triggerable channels or enables Manual triggering.
Parameters |
<boolean> | ON (or 1) - Continuous sweep mode. OFF (or 0) - Manual sweep mode.
Examples | INIT:CONT ON initiate:continuous off
Query Syntax | INITiate:CONTinuous?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

INITiate<cnum>[:IMMediate]

(Write-only) Stops the current sweeps and immediately sends a trigger to the specified channel. ( Same as Sweep \ Trigger \ Trigger! )

  • If the specified channel is in HOLD, it will sweep one time and return to HOLD when complete.

  • If Trigger:Scope = Global, all channels will receive a trigger.

  • If Trigger:Scope = Channel (only the active channel receives a trigger) and the specified channel is not the active channel, the specified channel will NOT receive a trigger signal.

  • If the specified channel is NOT in Manual trigger (INIT:CONT OFF), the analyzer will return an error.

  • If channel <cnum> does not exist, the analyzer will return an error.

Parameters

<c num>

Any existing channel number. If unspecified, value is set to 1

Examples

INIT
initiate2:immediate

Query Syntax

Not applicable

Overlapped?

Yes

Default

Not applicable


Memory SCPI

Memory Commands

The memory commands control saving and loading instrument states to the hard drive.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Save / Recall

All MMEM files have an extension according to their type.

  1. Binary filetype:

  • .sta - Instrument State

  • .cal - Calibration file

  • .cst - Both Instrument State and Calibration file

  2. ASCII filetype (MDIF or Touchstone formats):

  • .s1p

  • .s2p

  • .s3p

The default folder is "C:\Program Files\Agilent\Network Analyzer\Documents"

You can change the active directory using MMEMory:CDIRectory, or you can use an absolute path name to specify all MMEM files and folders.

MMEMory:CATalog[:<char>]? [<folder>]

(Read-only) Returns a comma-separated string of file names that are in the specified folder. If there are no files of the specified type, "NO CATALOG" is returned.
Parameters |
<char> | The type of files to list. Choose from: STATe - Instrument states (.sta) CORRection - Calibration Data (.cal) CSTate - Instrument state and Calibration data (.cst) If unspecified then ALL file types (even unknown types) are listed.
<folder> | String - Any existing folder name. If unspecified 'C:\Program Files\Agilent\Network Analyzer\Documents' is used.
Examples | MMEM:CAT? 'lists all files from the current folder mmemory:catalog:correction? 'C:\Program Files\Agilent\Network Analyzer\Documents' 'lists .cal files from the specified folder
Overlapped? | No
Default | Not applicable

MMEMory:CDIRectory <folder>

(Read-Write) Changes the folder name.

Parameters

<folder>

Any drive and folder name that already exists.
If the same level as "C:\Program Files\Agilent\Network Analyzer\Documents", then no punctuation is required

MMEM:CDIR Service

If the new folder is at a different level than "C:\Program Files\Agilent\Network Analyzer\Documents", use a slash (\) before the folder name and enclose in quotes.

mmemory:cdirectory '\automation' 'changes default directory up one level.

You can use an absolute path to specify the new folder.

mmemory:cdirectory 'c:\automation\service'

Query Syntax

MMEMory:CDIRectory? 'Returns the current folder name

Return Type

String

Overlapped?

No

Default

'C:\Program Files\Agilent\Network Analyzer\Documents'

MMEMory:COPY <file1>,<file2>

(Write-only) Copies file1 to file2. Extensions must be specified.
Parameters |
<file1> | String - Name of the file to be copied.
<file2> | String - Name of the file to be created from file1.
Examples | MMEM:COPY 'MyFile.cst','YourFile.cst'
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:DELete <file>

(Write-only) Deletes file. Extensions must be specified.
Parameters |
<file> | String - Name of the file to be deleted.
Examples | MMEM:DEL 'MyFile.cst'
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:LOAD[:<char>] <file>

(Write-only) Loads the specified file.
Parameters |
<char> | The type of file to load. Choose from: STATe - Instrument states (.sta) CORRection - Calibration Data (.cal) CSTate - Instrument state and Calibration data (.cst) If <char> is unspecified, the extension must be included in the filename. If an extension is specified in <file> that does not agree with <char> then no action is taken.
<file> | String - Name of the file to be loaded. The default folder is used if unspecified in the filename.
Examples | MMEM:LOAD 'MyFile.cst' mmemory:load:state 'MyInstState'
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:MDIRectory <folder>

(Write-only) Makes a folder.
Parameters |
<folder> | String - Name of the folder to make.
Examples | MMEM:MDIR 'MyFolder' mmemory:mdirectory 'c:\NewFolder'
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:MOVE <file1>,<file2>

(Write-only) Renames <file1> to <file2>. File extensions must be specified.
Parameters |
<file1> | String - Name of the file to be renamed.
<file2> | String - Name of the new file.
Examples | MMEM:MOVE 'MyFile.cst','YourFile.cst'
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:RDIRectory <folder>

(Write-only) Removes the specified folder.
Parameters |
<folder> | String - Name of the folder to remove.
Examples | MMEM:RDIR 'MyFolder'
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

MMEMory:STORe[:<char>] <file>

(Write-only) Stores the specified file (.sta, .cal, .cst, .s1p, .s2p, and .s3p.). The ASCII file types (.s1p, .s2p, and .s3p.) may be valid only if the proper calibration is enabled for the current active measurement. Example: MMEM:STOR "myfile.s2p" stores an s2p file successfully if 2-Port calibration is enabled. For more information on filetypes (see: Save recall a file)
Parameters |
<char> | The type of file to store. Choose from: STATe - Instrument states (.sta) CORRection - Calibration Data (.cal) CSTate - Instrument state and Calibration data (.cst) No <char> is specified for s1p, s2p and s3p If unspecified, then the extension must be included in the filename. If an extension is specified in <file> that does not agree with <char> then no action is taken.
<file> | String - Name of any valid file that is not already in existence.
Examples | MMEM:STOR:STAT 'myState' mmemory:store 'c:\bin\myState.sta'
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable


Output SCPI

Output Command

Learn about Power

OUTPut[:STATe] <ON | OFF>

(Read-Write) Turns RF power from the source ON or OFF.
Parameters |
<ON | OFF> | ON (or 1) - turns RF power ON. OFF (or 0) - turns RF power OFF.
Examples | OUTP ON output:state off
Query Syntax | OUTPut[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON


Average SCPI

Sens:Average Commands

Sets sweep-to-sweep averaging parameters. Averaging is a noise reduction technique that averages each data point over a user-specified number of sweeps. Averaging affects all of the measurements in the channel.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example using some of these commands.

  • Learn about Averaging

SENSe<cnum>:AVERage:CLEar

(Write-only) Clears and restarts averaging of the measurement data. Must also set SENS:AVER[:STATe] ON
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
Examples | SENS:AVER:CLE sense2:average:clear
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

SENSe<cnum>:AVERage:COUNt <num>

(Read-Write) Sets the number of measurement sweeps to combine for an average. Must also set SENS:AVER[:STATe] ON
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<num> | Number of measurement sweeps to average. Choose any number between: 1 and 1024
Examples | SENS:AVER:COUN 999 sense2:average:count 73
Query Syntax | SENSe<cnum>:AVERage:COUNt?
Return Type | Character
Overlapped? | No
Default | 1

SENSe<cnum>:AVERage[:STATe] <ON | OFF>

(Read-Write) Turns trace averaging ON or OFF.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns averaging ON. OFF (or 0) - turns averaging OFF.
Examples | SENS:AVER ON sense2:average:state off
Query Syntax | SENSe<cnum>:AVERage[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | Off


CorrCollCKIT SCPI

Sense:Correction:Collect:CKit Commands

Use to change the definitions of calibration kit standards.

Most of these commands act on the currently selected standard from the currently selected calibration kit.

  • To select a Calibration kit, use SENS:CORR:COLL:CKIT:SEL.

  • To select a Calibration standard, use SENS:CORR:COLL:CKIT:STAN:SEL

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Modifying Cal Kits

Note: You should provide data for every definition field - for every standard in your calibration kit. If a field is not set, the default value may not be what you expect.

SENSe:CORRection:COLLect:CKIT:NAME <name>

(Read-Write) Sets a name for the selected calibration kit.
Parameters |
<name> | Calibration Kit name. Any string name, can include numerics, period, and spaces; any length (although the dialog box display is limited to about 30 characters).
Examples | SENS:CORR:COLL:CKIT:NAME 'MYAPC35' sense:correction:collect:ckit:name 'mytypen'
Query Syntax | SENSe:CORRection:COLLect:CKIT:NAME?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:OLABel<class> <name>

(Read-Write) Sets the label for the calibration class designed by <class>. The label is used in the prompts for connecting the calibration standards associated with that <class>.
Parameters |
<class> | Number of the calibration class. Choose a number between: 1 and 15. The <class> numbers are associated with the following calibration Classes:
<class> | Class | Description
1 | S11A | Reflection standard
2 | S11B | Reflection standard
3 | S11C | Reflection standard
4 | S21T | Thru standard
5 | S22A | Reflection standard
6 | S22B | Reflection standard
7 | S22C | Reflection standard
8 | S12T | Thru standard
3-port analyzers only
9 | S33A | Reflection standard
10 | S33B | Reflection standard
11 | S33C | Reflection standard
12 | S32T | Thru standard
13 | S23T | Thru standard
14 | S31T | Thru standard
15 | S13T | Thru standard

<name> | Label for the calibration class. Must be enclosed in quotes. Any string between 1 and 12 characters long. Cannot begin with a numeric.
Examples | SENS:CORR:COLL:CKIT:OLAB3 'LOADS' sense:correction:collect:ckit:olabel4 'Thru'
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:OLIST[class]?

(Read-only) Returns seven values of standards that are assigned to the specified class.
Parameters |
<class> | Number of the calibration class to be queried. The <class> numbers are associated with the following calibration Classes:
<class> | Class | Description
1 | S11A | Reflection standard
2 | S11B | Reflection standard
3 | S11C | Reflection standard
4 | S21T | Thru standard
5 | S22A | Reflection standard
6 | S22B | Reflection standard
7 | S22C | Reflection standard
8 | S12T | Thru standard
3-port analyzers only
9 | S33A | Reflection standard
10 | S33B | Reflection standard
11 | S33C | Reflection standard
12 | S32T | Thru standard
13 | S23T | Thru standard
14 | S31T | Thru standard
15 | S13T | Thru standard
<class> | Number of the calibration class to be queried. The <class> numbers are associated with the following calibration Classes:
Examples | SENS:CORR:COLL:CKIT:OLIST8? Always returns 7 standard numbers. Unassigned standards return 0
Return Type | Character; returns the <class> number of the selected standard.
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:ORDer<class> <std> [,<std>] [,<std>] [,<std>] [,<std>] [,<std>] [,<std>]

(Read-Write) Sets a standard number to a calibration class. Does NOT set or dictate the order for measuring the standards. For more information, see Assigning Standards to a Calibration Class
Parameters |
<class> | Number of the calibration class that is assigned to <standard>. Choose a number between: 1 and 15 The <class> numbers are associated with the following calibration Classes:

<class> | Class | Description
1 | S11A | Reflection standard
2 | S11B | Reflection standard
3 | S11C | Reflection standard
4 | S21T | Thru standard
5 | S22A | Reflection standard
6 | S22B | Reflection standard
7 | S22C | Reflection standard
8 | S12T | Thru standard
3-port analyzers only
9 | S33A | Reflection standard
10 | S33B | Reflection standard
11 | S33C | Reflection standard
12 | S32T | Thru standard
13 | S23T | Thru standard
14 | S31T | Thru standard
15 | S13T | Thru standard
<std> | Standard number to be assigned to the class; Choose a standard between 1 and 8. One standard is mandatory; up to six additional standards are optional.
Examples | Assigns standard 3 to S11A class: SENS:CORR:COLL:CKIT:ORD1 3 Assigns standard 2 and 5 to S21T class class: sense:correction:collect:ckit:order4 2,5
Query Syntax | SENSe:CORRection:COLLect:CKIT:ORDer<class>? 'Returns only the first standard assigned to the specified class. To query the remaining standards, use SENSe:CORRection:COLLect:CKIT:OLIST[1-15]?
Return Type | Character.
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:RESet <num>

(Write-only) Resets the selected calibration kit to factory default definition values.
Parameters |
<num> | The number of the calibration kit to be reset. Choose any integer between: 1 and 8
Examples | SENS:CORR:COLL:CKIT:RESet 1 sense:correction:collect:ckit:reset 4
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT[:SELect] <num>

(Read-Write) Selects (makes active) a calibration kit for performing a calibration or for modifying standards. All subsequent "CKIT" commands that are sent apply to this selected calibration kit. Select a calibration standard using SENS:CORR:COLL:CKIT:STAN <num>
Parameters |
<num> | The number of the calibration kit. Choose from: Use SENSe:CORRection:COLLect:CKIT:RESet to restore Cal Kits to default values.
<num> | Name
1 | User Defined 1
2 | User Defined 2
3 | User Defined 3
4 | User Defined 4
5 | User Defined 5
6 | User Defined 6
7 | User Defined 7
8 | User Defined 8
9 | User Defined 9
10 | User Defined 10
99 | ECAL module
Examples | SENS:CORR:COLL:CKIT 2 sense2:correction:collect:ckit:select 7
Query Syntax | SENSe:CORRection:COLLect:CKIT?
Return Type | Charact er
Overlapped? | No
Default | 1

SENSe:CORRection:COLLect:CKIT:STANdard:C0 <num>

(Read-Write) Sets the C0 value (the first capacitance value) for the selected standard.
Parameters |
<num> | Value for C0 in picofarads
Examples | The following commands set C0=15 picofarads: SENS:CORR:COLL:CKIT:STAN:C0 15 sense:correction:collect:ckit:standard:c0 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C0?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C1 <num>

(Read-Write) Sets the C1 value (the second capacitance value) for the selected standard.
Parameters |
<num> | Value for C1 in picofarads
Examples | The following two commands set C1=15 picofarads: SENS:CORR:COLL:CKIT:STAN:C1 15 sense:correction:collect:ckit:standard:c1 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C1?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C2 <num>

(Read-Write) Sets the C2 value (the third capacitance value) for the selected standard.
Parameters |
<num> | Value for C2 in picofarads
Examples | The following two commands set C2=(-15) picofarads: SENS:CORR:COLL:CKIT:STAN:C2 -15 sense:correction:collect:ckit:standard:c2 -15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C2?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:C3 <num>

(Read-Write) Sets the C3 value (the fourth capacitance value) for the selected standard.
Parameters |
<num> | Value for C3 in picofarads
Examples | The following two commands set C3=15 picofarads: SENS:CORR:COLL:CKIT:STAN:C3 15 sense:correction:collect:ckit:standard:c3 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:C3?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter <char>

Note: Character is sometimes referred to as Medium

(Read-Write) Sets the media type of the selected calibration standard.
Parameters |
<char> | Media type of the standard. Choose from: Coax - Coaxial Cable Wave - Waveguide
Examples | SENS:CORR:COLL:CKIT:STAN:CHAR COAX sense:correction:collect:ckit:standard:character wave
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:CHARacter?
Return Type | Character
Overlapped? | No
Default | Coax

SENSe:CORRection:COLLect:CKIT:STANdard:DELay <num>

(Read-Write) Sets the electrical delay value for the selected standard.
Parameters |
<num> | Electrical delay in seconds
Examples | SENS:CORR:COLL:CKIT:STAN:DEL 50e-12 sense2:correction:collect:ckit:standard:delay 50ps
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:DELay?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:FMAX <num>

(Read-Write) Sets the maximum frequency for the selected standard.
Parameters |
<num> | Maximum frequency in Hertz.
Examples | SENS:CORR:COLL:CKIT:STAN:FMAX 9e9 sense:correction:collect:ckit:standard:fmax 9Ghz
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:FMAX?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:FMIN <num>

(Read-Write) Sets the minumum frequency for the selected standard.
Parameters |
<num> | Minimum frequency in Hertz.
Examples | SENS:CORR:COLL:CKIT:STAN:FMIN 1e3 sense:correction:collect:ckit:standard:fmin 1khz
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:FMIN?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance <num>

Note: Impedance is sometimes referred to as Z0

(Read-Write) Sets the characteristic impedance for the selected standard.
Parameters |
<num> | Impedance in Ohms
Examples | SENS:CORR:COLL:CKIT:STAN:IMP 75 sense:correction:collect:ckit:standard:impedance 50.3
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:IMPedance?
Return Type | Character
Overlapped? | No
Default | 50

SENSe:CORRection:COLLect:CKIT:STANdard:L0 <num>

(Read-Write) Sets the L0 value (the first inductance value) for the selected standard.
Parameters |
<num> | Value for L0 in picohenries
Examples | The following two commands set L0=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L0 15 sense:correction:collect:ckit:standard:l0 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L0?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L1 <num>

(Read-Write) Sets the L1 value (the second inductance value) for the selected standard.
Parameters |
<num> | Value for L1 in picohenries
Examples | The following two commands set L1=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L1 15 sense:correction:collect:ckit:standard:l1 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L1?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L2 <num>

(Read-Write) Sets the L2 value (the third inductance value) for the selected standard.
Parameters |
<num> | Value for L2 in picohenries
Examples | The following two commands set L2=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L2 15 sense:correction:collect:ckit:standard:l2 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L2?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:L3 <num>

(Read-Write) Sets the L3 value (the fourth inductance value) for the selected standard.
Parameters |
<num> | Value for L3 in picohenries
Examples | The following two commands set L3=15 picohenries: SENS:CORR:COLL:CKIT:STAN:L3 15 sense:correction:collect:ckit:standard:l3 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:L3?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:LABel <name>

(Read-Write) Sets the label for the selected standard. The label is used to prompt the user to connect the specified standard.
Parameters |
<name> | Label for the standard; Must be enclosed in quotes. Any string between 1 and 12 characters long. Cannot begin with a numeric.
Examples | SENS:CORR:COLL:CKIT:STAN:LAB 'OPEN' sense:correction:collect:ckit:standard:label 'Short2'
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:LABel?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:LOSS <num>

(Read-Write) Sets the insertion loss for the selected standard.
Parameters |
<num> | Insertion loss in Mohms / sec. (MegaOhms per second of electrical delay)
Examples | SENS:CORR:COLL:CKIT:STAN:LOSS 3.5e9 sense:correction:collect:ckit:standard:loss 3
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:LOSS?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard[:SELECT] <num>

(Read-Write) Selects the calibration standard. All subsequent "CKIT" commands to modify a standard will apply to the selected standard. Select a calibration kit using SENS:CORR:COLL:CKIT:SEL
Parameters |
<num> | Number of the standard. Choose any number between: 1 and 8
Examples | SENS:CORR:COLL:CKIT:STAN 3 sense:correction:collect:ckit:standard:select 8
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard[:SELect]?
Return Type | Character
Overlapped? | No
Default | 1

SENSe:CORRection:COLLect:CKIT:STANdard:TYPE <char>

(Read-Write) Sets the type for the selected standard.
Parameters |
<char> | Choose from: OPEN SHORT LOAD SLOAD (sliding load) THRU (through) ARBI(arbitrary)
Examples | SENS:CORR:COLL:CKIT:STAN:TYPE LOAD sense:correction:collect:ckit:standard:type short
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:TYPE?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:TZReal <num>

(Read-Write) Sets the TZReal component value of the Terminal Impedance for the selected standard. Note: Only applicable when the Standard Type is set to ARBI
Parameters |
<num> | Value for TZReal in Ohms
Examples | The following commands set TZReal=15 Ohms: SENS:CORR:COLL:CKIT:STAN:TZReal 15 sense:correction:collect:ckit:standard:TZReal 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:TZReal?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe:CORRection:COLLect:CKIT:STANdard:TZImag <num>

(Read-Write) Sets the TZImag component value of the Terminal Impedance for the selected standard. Note: Only applicable when the Standard Type is set to ARBI
Parameters |
<num> | Value for TZImag in Ohms
Examples | The following two commands set TZImag=15 Ohms: SENS:CORR:COLL:CKIT:STAN:TZImag 15 sense:correction:collect:ckit:standard:TZImag 15
Query Syntax | SENSe:CORRection:COLLect:CKIT:STANdard:TZImag?
Return Type | Character
Overlapped? | No
Default | Not Applicable


CorrCset SCPI

Sense:Correction:CSET Commands

Performs actions on calibration sets.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Measurement Calibration

SENSe<cnum>:CORRection:CSET:CATalog?

(Read-only) Returns a string containing a list of comma-separated GUIDs for Cal Sets in the following format: {FD6F863E-9719-11d5-8D6C-00108334AE96}, {1B03B2CE-971A-11d5-8D6C-00108334AE96}, {2B893E7A-971A-11d5-8D6C-00108334AE96}
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:CORR:CSET:CAT? sense2:correction:cset:catalog?
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:CORRection:CSET:DELete <string>

(Write-only) Deletes a Cal Set from the set of available Cal Sets. This command immediately updates the Cal Set file on the hard drive. Using the Cal Sets collection is a convenient way to manage Cal Sets.

If the Cal Set identified by the GUID is currently in use, the Cal Set will not be deleted. If you still want to delete a Cal Set that is in use, either turn off correction on the subscribing measurement, turn off subscribed channels, or select a different Cal Set for the subscribed channel.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<string>

The GUID of the Cal Set to be deleted. The curly brackets and hyphens must be included. Not case sensitive.

Examples

SENS:CORR:CSET:DEL '{2B893E7A-971A-11d5-8D6C-00108334AE96}'
sense2:correction:cset:delete '{2B893E7A-971A-11d5-8D6C-00108334AE96}'

Query Syntax

Not Applicable

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:CSET:DESCription <string>

(Read-Write) Sets or returns the descriptive string assigned to the selected Cal Set. Change this string so that you can easily identify each Cal Set. Select the Cal Set using SENSe:CORRection:CSET:GUID
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<string> | The descriptive string associated with the currently-selected Cal Set
Examples | SENS:CORR:CSET:DESC 'MyCalSet' sense2:correction:cset:description 'thisCalSet'
Query Syntax | SENSe<cnum>:CORRection:CSET:DESCription?
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:CORRection:CSET:GUID <string>

(Read-Write) Selects the Cal Set identified by the string parameter (GUID) and applies it to the specified channel.

A Cal Set cannot be selected for a channel which is not On.

If the stimulus settings of the selected Cal Set differ from those of the selected channel, the instrument will automatically change the channel's settings to match the Cal Set.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<string>

GUID of the desired Cal Set. The curly brackets and hyphens must be included.

Examples

SENS:CORR:CSET:GUID '{2B893E7A-971A-11d5-8D6C-00108334AE96}'
sense2:correction:cset:guid '{2B893E7A-971A-11d5-8D6C-00108334AE96}'

Query Syntax

SENSe<cnum>:CORRection:CSET:GUID?

Returns the GUID of the currently-selected Cal Set for the specified channel.

Return Type

String

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:CSET[:SELect] <char>

(Read-Write) Restores a correction data set from memory. The file name is "CSETx.cst" where x is the user number assigned to <char>, and .cst specifies a cal set and instrument state. This is not the same syntax as a file saved through the default choices from the front panel, which is "at00x.cst". For more information on the file naming syntax, see the MMEMory subsystem.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: DEF - Presets the analyzer USER01- Restores User01 calibration data USER02 - Restores User02 calibration data through... USER10 - Restores User10 calibration data
Examples | SENS:CORR:CSET DEF sense2:correction:cset:select user02
Query Syntax | SENSe<cnum>:CORRection:CSET[:SELect]?
Return Type | Charact er
Overlapped? | No
Default | DEF

SENSe<cnum>:CORRection:CSET:SAVE <char>

Write a correction data set to memory or Read the last correction set saved. The file name is saved as "CSETx.cst" where x is the user number assigned to <char>, and .cst specifies a cal set and instrument state. This is not the same syntax as a file saved through the default choices from the front panel, which is "at00 x.cst". For more information on the filenaming syntax, see the MMEMory subsystem.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: USER01 USER02... USER10
Examples | SENS:CORR:CSET:SAVE USER03 sense2:correction:cset:save user09
Query Syntax | SENSe<cnum>:CORRection:CSET:SAVE? Queries the last correction set saved.
Return Type | Charact er
Overlapped? | No
Default | Not applicable


CorrGuided SCPI

Sense:Correction:Collect:Guided Commands

Performs and applies a GUIDED measurement calibration and other error correction features.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example using some of these commands.

  • Learn about Measurement Calibration

SENSe<cnum>:CORRection:COLLect:GUIDed:ACQuire <std>

(Write-only) Initiates the measurement of the specified calibration standard
Executing this command with an unnecessary standard has no affect.

The measured data is stored and used for subsequent calculations of error correction coefficients. All standards must be measured before a calibration can be completed. Any measurement can be repeated until the SENS:CORR:COLL:GUID:SAVE command is executed.

Query the user prompt description using SENS:CORR:COLL:GUID:DESC?
Query the required calibration steps using SENS:CORR:COLL:GUID:STEP?

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<std>

Choose from:STAN1, STAN2, STAN3, through STAN40

Examples

SENS:CORR:COLL:GUID:ACQ STAN1
sense2:correction:collect:guided:acquire stan1

Query Syntax

Not Applicable

Return Type

Character

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:CKIT:PORT<pnum>:CATalog?

(Read-only) Returns a comma-separated list of valid kits for each port. Use items in the list to select the kit to be used with the SENS:CORR:COLL:GUID:CKIT:PORT command.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<pnum> | Any existing port number: 1,2 or 3 (for 3-port analyzers). If unspecified, value is set to 1
Examples | SENS:CORR:COLL:GUID:CKIT:PORT1:CAT? 'When "Type N (50) male" is specified for connector type, returns: "85054D, 85032F"
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:CKIT:PORT<pnum>[:SELect] <kit>

(Read-Write) Specifies the calibration kit for each port to be used during a guided calibration. An unused port does NOT need to have a specified Cal Kit.

Note:
1. Specify the connector type for the port with SENS:CORR:COLL:GUID:CONN:PORT.
2. Query the valid available kits for each port with SENS:CORR:COLL:GUID:CKIT:PORT:CAT?
3. Specify the kit using this command.
4. Perform a query of this command. If the <kit> parameter was incorrectly entered, an error will be returned.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<pnum>

Any existing port number: 1,2 or 3 (for 3-port analyzers). If unspecified, value is set to 1

<kit>

Calibration kit to be used for the specified port.

Examples

SENS:CORR:COLL:GUID:CKIT:PORT1 '85055A'
sense2:correction:collect:ckit:port2:select '85055A'

Query Syntax

SENSe:CORRection:COLLect:GUIDed:CKIT:PORT<pnum>[:SELect]?

Return Type

String - If the <kit> parameter was incorrectly entered while writing, an error will be returned.

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:CONNector:CATalog?

(Read-only) Returns a comma-separated list of valid connectors. Use an item from the returned list to specify a connector for the SENS:CORR:COLL:GUID:CONN:PORT:SEL command.
Examples | SENS:CORR:COLL:GUID:CONN:CAT? Returns: Type N (50) female, Type N (50) male, APC 7 (50), 3.5 mm (50) male, 3.5 mm (50) female, User Connector A
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:CONNector:PORT<pnum>[:SELect] <conn>

(Read-Write) Specifies a connector type for every port during the Guided Calibration procedure. Valid connector names are stored within calibration kits. Some cal kits may include both male and female connectors. Therefore, specifying connector gender may be required.

Unused ports must be defined as or Not used. If all ports are defined as "Not used", a guided calibration cannot be performed.

  • A single port with a valid <conn> name indicates a 1-Port calibration will be performed.

  • Two ports with valid <conn> names indicate either a 2-Port or TRL calibration will be performed depending on the standards definition found within the cal kit and the capability of the analyzer. (The analyzer must have 4 receivers for TRL calibrations.).

  • Three ports with valid <conn> names indicate a 3-Port calibration will be performed.

Note:
1. Use SENS:CORR:COLL:GUID:CONN:CAT? to query available connectors before specifying the port connector.
2. Select a connector type using this command.
3. Perform a query of this command. If the <conn> parameter was incorrectly entered, an error will be returned.
4. Specify the cal kit to use for each port with SENS:CORR:COLL:GUID:CKIT:PORT

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<pnum>

Any existing port number: 1,2 or 3 (for 3-port analyzers). If unspecified, value is set to 1

<conn>

DUT connector type to connect with analyzer port <pnum>

Some kits may include both male and female connectors so specifying gender may be required.

Valid connector names are stored within calibration kits. Query available connectors using SENSe:CORRection:COLLect:GUIDed:CONNector:CATalog?

Examples

SENS:CORR:COLL:GUID:CONN:PORT1 'Type N (50) female'

'Indicates the DUT port that connects with the analyzer's Port1 is a TypeN 50 ohm Female connector.

Query Syntax

SENSe<cnum>:CORRection:COLLect:GUIDed:CONNector:PORT<pnum>[:SELect]?

Return Type

String

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:DESCription? <step>

(Read-only) Returns the connection description for the specified calibration step.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<step> | A number from 1 to the number of steps required to complete the calibration (Use SENS:CORR:COLL:GUID:STEP? to query the number of steps )
Examples | SENS:CORR:COLL:GUID:DESC ? 10 'Returns: Connect APC 7 Open to port3
Return Type | String
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:INITiate

(Write-only) Initiates a guided calibration by creating a new Cal Set.

The analyzer determines the measurements needed to perform the calibration using the settings specified from the SENS:CORR:COLL:GUID:CONN:PORT and SENS:CORR:COLL:GUID:CKIT:PORT commands.

After this command is executed, subsequent commands can be used to query the number of measurement steps, issue the acquisition commands, query the connection description strings, and subsequently complete a guided calibration.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

Examples

SENS:CORR:COLL:GUID:INIT
sense2:correction:collect:guided:initiate

Query Syntax

Not Applicable

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:METHod <char>

(Read-Write) Selects from one of several algorithms available for performing a guided calibration.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Note: to avoid errors, type the following <char> in the format shown in boldface, example use UNKN and not UNKNown.

DEFAULT - Informs guided calibrations to use the default algorithm when computing the number of needed standards acquisition steps. (In this release, the default algorithm is ADAPTER REMOVAL).

ADAPremove - Use the adapter removal algorithm

FLUSH - When ECal calkits are specified, use the FLUSH THRU algorithm. This selection has no affect if ECal calkits are not used or if the ECal module selected is not insertable.

UNKNown - Use the Unknown THRU algorithm for 2-Port calibrations for non-insertable devices. This selection is not available on instruments which do not have 4 receivers.

Examples

SENS:CORR:COLL:GUID:METH
sense2:correction:collect:guided:method unkn

Query Syntax

Not Applicable

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:SAVE

(Write-only) Completes the guided cal by computing the error correction terms, turning Correction ON, and saving the calibration to a cal set.

If all of the required standards have not been measured, the calibration will not complete properly.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

Examples

SENS:CORR:COLL:GUID:SAVE
sense2:correction:collect:guided:save

Query Syntax

Not Applicable

Overlapped?

No

Default

Not Applicable

SENSe<cnum>:CORRection:COLLect:GUIDed:STEPs?

(Read-only) Returns the number of measurement steps required to complete the current guided calibration. This command is sent after the SENS:CORR:COLL:GUID:INIT, SENS:CORR:COLL:GUID:CONN:PORT and SENS:CORR:COLL:GUID:CKIT:PORT commands.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:CORR:COLL:GUID:STEP? sense2:correction:collect:guided:steps?
Return Type | Integer
Overlapped? | No
Default | Not Applicable


Couple SCPI

Sense:Couple Command

Learn about Alternate Sweep

SENSe<cnum>:COUPle <ALL | NONE>

(Read-Write) Sets the sweep mode as Chopped or Alternate.
Parameters |
<cnum> | Any existing channel number; if unspecified, value is set to 1.
<ALL | NONE> | ALL - Sweep mode set to Chopped - reflection and transmission measured on the same sweep. NONE - Sweep mode set to Alternate - reflection and transmission measured on separate sweeps. Improves Mixer bounce and Isolation measurements. Increases sweep time
Examples | SENS:COUP ALL sense2:couple none
Query Syntax | SENSe<cnum>:COUPle?
Return Type | Character
Overlapped? | No
Default | ALL


Frequency SCPI

Sense:Frequency Commands

Sets the frequency sweep functions of the analyzer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example using some of these commands.

  • Learn about Frequency Sweep

SENSe<cnum>:FREQuency:CENTer <num>

(Read-Write) Sets the center frequency of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Center frequency. Choose any number between the minimum and maximum frequency limits of the anal yzer. Units are Hz

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:CENT 1000000
sense2:frequency:center 1mhz

Query Syntax

SENSe<cnum>:FREQuency:CENTer?

Return Type

Character

Overlapped?

No

Default

Center of the analyzer's frequency span

SENSe<cnum>:FREQuency[:CW |:FIXed] <num>

(Read-Write) Sets the Continuous Wave (or Fixed) frequency. Must also send SENS:SWEEP:TYPE CW to put the analyzer into CW sweep mode.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

CW frequency. Choose any number between the minimum and maximum frequency limits of the anal yzer. Units are Hz.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ 1000000
SENS:FREQ:CW MIN
sense2:frequency:fixed 1mhz

Query Syntax

SENSe<cnum>:FREQuency[:CW | :FIXed]?

Return Type

Character

Overlapped?

No

Default

1 GHz

SENSe<cnum>:FREQuency:SPAN <num>

(Read-Write) Sets the frequency span of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Frequency span. Choose any number between:
0 (minimum) and the maximum frequency span of the anal yzer.
Units are Hz

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:SPAN 1000000
sense2:frequency:span max

Query Syntax

SENSe<cnum>:FREQuency:SPAN?

Return Type

Character

Overlapped?

No

Default

Maximum frequency span of the analyzer

SENSe<cnum>:FREQuency:STARt <num>

(Read-Write) Sets the start frequency of the analyzer.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Start frequency. Choose any number between the MIN and MAX frequency limits of the anal yzer. Units are Hz Note: If FREQ:START is set greater than FREQ:STOP, then STOP is set equal to START. Note: This command will accept MIN or M AX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:FREQ:STAR 1000000 sense2:frequency:start MIN
Query Syntax | SENSe<cnum>:FREQuency:STARt?
Return Type | Character
Overlapped? | No
Default | Minimum frequency of the analyzer

SENSe<cnum>:FREQuency:STOP <num>

(Read-Write) Sets the stop frequency of the analyzer.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Stop frequency. Choose any number between:
the minimum and maximum frequency limits of the anal yzer. Units are Hz

If FREQ:STOP is set less than FREQ:START, then START will be set equal to STOP.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:FREQ:STOP 1000000
sense2:frequency:stop max

Query Syntax

SENSe<cnum>:FREQuency:STOP?

Return Type

Character

Overlapped?

No

Default

Maximum frequency of the analyzer


Power SCPI

Sense:Power Command

Learn a bout Receiver Attenuation

SENSe<cnum>:POWer:ATTenuation <recvr>,<num>

(Read-Write) Sets the attenuation level for the specified receiver. Note: Attenuation cannot be set with Sweep Type set to Power
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<recvr> | Receiver to get attenuation. Choose from: ARECeiver - receiver A BRECeiver - receiver B
<num> | Choose from: 0 to 35 dB - in 5 dB steps If a number other than these is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered for <num> the analyzer will switch in 15 dB attenuation.
Examples | SENS:POW:ATT AREC,10 sense2:power: attentuation breceiver,30
Query Syntax | SENSe<cnum>:POWer :ATTenuation? <rec>
Return Type | Character
Overlapped? | No
Default | 0


Roscillator SCPI

Sense:Roscillator Command

Learn about the Reference Osc.

SENSe:ROSCillator:SOURce?

(Read-only) Applying a signal to the Reference Oscillator connector automatically sets the Reference Oscillator to EXTernal. This command allows you to check that it worked. EXT is returned when a signal is present at the Reference Oscillator connector. INT is returned when NO signal is present at the Reference Oscillator connector.
Examples | SENS:ROSC:SOUR? sense:roscillator:source?
Return Type | Character
Overlapped? | No
Default | Not applicable


Segment SCPI

Sense:Segment Commands

Defines the segment sweep settings. Enable segment sweep with SENS:SWE:TYPE SEGMent.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn a bout Segment Sweep

SENSe<cnum>:SEGMent<snum>:ADD

(Write-only) Adds a segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to add. If unspecified, value is set to 1. Segment numbers must be sequential. If a new number is added where one currently exists, the existing segment and those following are incremented by one.
Examples | Two Segments exist (1 and 2). The following command will add a new segment (1). The existing (1 and 2) will become (2 and 3) respectively. SENS:SEGM1:ADD sense2:segment1:add
Query Syntax | Not applicable. Use Sense:Segment:Count to determine the number of segments in a trace.
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent<snum>:BWIDth[:RESolution] <num>

(Read-Write) Sets the IFBandwidth for the specified segment. First set SENS:SEGM:BWIDth:CONTrol ON. All subsequent segments that are added assume the new IF Bandwidth value.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

IF Bandwidth. Choose from:
1 | 2 | 3 | 5 | 7 | 10 | 15 | 20 | 30 | 50 | 70 | 100 | 150 | 200 | 300 | 500 | 700 | 1k | 1.5k | 2k | 3k | 5k | 7k | 10k | 15k | 20k | 30k | 35k | 40k |
If a number other than these is entered, the analyzer will round up to the closest valid number (unless a number higher than the maximum in entered.)

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:BWID 1KHZ
sense2:segment2:bwidth:resolution max

Query Syntax

SENSe<cnum>:SEGMent<snum>:BWIDth[:RESolution]?

Return Type

Character

Overlapped?

No

Default

35k

SENSe<cnum>:SEGMent:BWIDth[:RESolution]:CONTrol <ON | OFF>

(Read-Write) Specifies whether the IF Bandwidth resolution can be set independently for each segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns Bandwidth control ON. Bandwidth can be set for each segment OFF (or 0) - turns Bandwidth control OFF. Use channel bandwidth setting
Examples | SENS:SEGM:BWID:CONT ON sense2:segment:bwidth:control off
Query Syntax | SENSe<cnum>:SEGMent:BWIDth[:RESolution]:CONTrol?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent:COUNt?

(Read-only) Queries the number of segments that exist in the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:SEGM:COUNt? sense2:segment:count?
Return Type | Character
Overlapped? | No
Default | 1 segment

SENSe<cnum>:SEGMent<snum>:DELete

(Write-only) Deletes the specified sweep segment.
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Number of the segment to delete. If unspecified, value is set to 1
Examples | SENS:SEGM:DEL sense2:segment2:delete
Query Syntax | Not applicable
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent:DELete:ALL

(Write-only) Deletes all sweep segments.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:SEGM:DEL:ALL sense2:segment:delete:all
Query Syntax | Not applicable
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent<snum>:FREQuency:CENTer <num>

(Read-Write) Sets the Center Frequency for the specified segment. The Frequency Span of the segment remains the same. The Start and Stop Frequencies change accordingly.

Note: All previous segment's Start and Stop Frequencies that are larger than the new Start Frequency are changed to the new Start Frequency. All following segment's start and stop frequencies that are smaller than the new Stop Frequency are changed to the new Stop Frequency.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

Center Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:FREQ:CENT 1MHZ
sense2:segment2:frequency:center 1e9

Query Syntax

SENSe<cnum>:SEGMent<snum>:FREQuency:CENTer?

Return Type

Character

Overlapped?

No

Default

Stop Frequency of the previous segment. If first segment, start frequency of the analyzer.

SENSe<cnum>:SEGMent<snum>:FREQuency:SPAN <num>

(Read-Write) Sets the Frequency Span for the specified segment. The center frequency of the segment remains the same. The start and stop frequencies change accordingly.

Note: All previous segment's Start and Stop Frequencies that are larger than the new Start Frequency are changed to the new Start Frequency. All following segment's start and stop frequencies that are smaller than the new Stop Frequency are changed to the new Stop Frequency.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Segment number to modify. Choose any existing segment number.

<num>

Frequency Span in Hz. Choose any number between the minimum and maximum frequency of the analyzer.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:FREQ:SPAN 1MHZ
sense2:segment2:frequency:span max

Query Syntax

SENSe<cnum>:SEGMent<snum>:FREQuency:SPAN?

Return Type

Character

Overlapped?

No

Default

If first segment, frequency span of the analyzer. Otherwise 0.

SENSe<cnum>:SEGMent<snum>:FREQuency:START <num>

(Read-Write) Sets the Start Frequency for the specified sweep segment. Note: All other segment Start and Stop Frequency values that are larger than this frequency are changed to this frequency.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to modify. Choose any existing segment number.
<num> | Start Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:FREQ:STAR 1MHZ sense2:segment2:frequency:start minimum
Query Syntax | SENSe<cnum>:SEGMent<snum>:FREQuency:STARt?
Return Type | Character
Overlapped? | No
Default | Stop Frequency of the previous segment. If first segment, start frequency of the analyzer.

SENSe<cnum>:SEGMent<snum>:FREQuency:STOP <num>

(Read-Write) Sets the Stop Frequency for the specified sweep segment. Note: All other segment's Start and Stop Frequency values that are larger than this frequency are changed to this frequency.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to modify. Choose any existing segment number.
<num> | Stop Frequency in Hz. Choose any number between the minimum and maximum frequency of the analyzer. Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:FREQ:STOP 1MHZ sense2:segment2:frequency:stop maximum
Query Syntax | SENSe<cnum>:SEGMent<snum>:FREQuency:STOP?
Return Type | Character
Overlapped? | No
Default | If first segment, stop frequency of the analyzer. Otherwise, start frequency of the segment.

SENSe<cnum>:SEGMent<snum>:POWer[<port>][:LEVel] <num>

(Read-Write) Sets the Port Power level for the specified sweep segment. First set SENS:SEGM:POW:CONTrol ON. All subsequent segments that are added assume the new Power Level value.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to modify. Choose any existing segment number.
<port> | Port number of the source. Choose from 1 or 2. If unspecified, value is set to 1.
<num> | Power level. Choose from any number between: -90 and 20
Examples | SENS:SEGM:POW 0 sense2:segment2:power1:level -10
Query Syntax | SENSe<cnum>:SEGMent<snum>:POWer[<port>][:LEVel]?
Return Type | Character
Overlapped? | No
Default | 0

SENSe<cnum>:SEGMent:POWer[:LEVel]:CONTrol <ON | OFF>

(Read-Write) Specifies whether Power Level can be set independently for each segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns Power Level control ON. Power level can be set for each segment. OFF (or 0) - turns Power Level control OFF. Use the channel power level setting.
Examples | SENS:SEGM:POW:CONT ON sense2:segment:power:level:control off
Query Syntax | SENSe<cnum>:SEGMent:POWer[:LEVel]:CONTrol?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent<snum>[:STATe] <ON | OFF>

(Read-Write) Turns the specified sweep segment ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Segment number to be turned ON or OFF
<ON | OFF> | ON (or 1) - turns segment ON. OFF (or 0) - turns segment OFF.
Examples | SENS:SEGM ON sense2:segment2:state off
Query Syntax | SENSe<cnum>:SEGMent[:STATe]? <snum>
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe<cnum>:SEGMent<snum>:SWEep:POINts <num>

(Read-Write) Sets the number of data points for the specified sweep segment.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<snum>

Any existing segment number. If unspecified, value is set to 1

<num>

Number of points in the segment. The total number of points in all segments cannot exceed 16001. A segment can have as few as 1 point.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SEGM:SWE:POIN 51
sense2:segment2:sweep:points maximum

Query Syntax

SENSe<cnum>:SEGMent<snum>:S WEep:POINts?

Return Type

Character

Overlapped?

No

Default

201

SENSe<cnum>:SEGMent<snum>:SWEep:TIME <num>

(Read-Write) Sets the time the analyzer takes to sweep the specified sweep segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<snum> | Any existing segment number.
<num> | Sweep time in seconds. Choose a number between 0 and 100 Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SEGM:SWE:TIME 1ms sense2:segment2:sweep:time .001
Query Syntax | SENSe<cnum>:SEGMent<snum>:S WEep:TIME?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:SEGMent:SWEep:TIME:CONTrol <ON | OFF>

(Read-Write) Specifies whether Sweep Time can be set independently for each sweep segment.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns Sweep Time control ON. Sweep Time can be set for each segment. OFF (or 0) - turns Sweep Time control OFF. Uses the channel Sweep Time setting.
Examples | SENS:SEGM:SWE:TIM:CONT ON sense2:segment:sweep:time:control off
Query Syntax | SENSe<cnum>:SEGMent:SWEep:TIME:CONTrol?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF


Sense Bandwidth SCPI

Sense:Bandwidth Command

Learn about IF Bandwidth

SENSe<cnum>:BANDwidth | BWIDth[:RESolution] <num>

(Read-Write) Sets the bandwidth of the digital IF filter to be used in the measurement. The keywords BAND or BWID are interchangeable.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

IF Bandwidth in Hz. Choose from:
1 | 2 | 3 | 5 | 7 | 10 | 15 | 20 | 30 | 50 | 70 | 100 | 150 | 200 | 300 | 500 | 700 | 1k | 1.5k | 2k | 3k | 5k | 7k | 10k | 15k | 20k | 30k | 35k | 40k |

If a number other than these is entered, the analyzer will round up to the closest valid number (unless a number higher than the maximum in entered.)

Examples

SENS:BWID 1KHZ
sense2:bandwidth:resolution 1000

Query Syntax

SENSe<cnum>:BANDwidth | BWIDth[:RESolution]?

Return Type

Character

Overlapped?

No

Default

35k


Sense Correction SCPI

Sense:Correction Commands

Performs and applies measurement calibration and other error correction features.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example using some of these commands.

  • Learn about Measurement Calibration

SENSe<cnum>:CORRection:CCHeck[:ACQuire] <char>[,char]

(Write-only) Reads the 'confidence data' associated with the specified ECal module and puts it into memory. The measurement is selected using SENS:CORR:CCH:PAR. This command is compatible with *OPC.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1.

<char>

ECAL Module that contains the confidence data. Choose from:

  • ECALA

  • ECALB

[char]

Optional argument. Specifies which characterization within the ECal module that the confidence data will be read from. If this argument is not used, the default is CHAR0.

<char>

CHAR0 Factory characterization (data that was stored in the ECal module by Agilent)

CHAR1 User characterization (data that was written to the module by the User Characterization feature on the PNA)

Examples

SENS:CORR:CCHeck ECALA

sense2:correction:ccheck:acquire ecalb,char1

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

SENSe<cnum>:CORRection:CCHeck:DONE

(Write-only) Concludes the Confidence Check and sets the ECal module back into the idle state.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SENS:CORR:CCH:DONE sense2:correction:ccheck:done
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

SENSe<cnum>:CORRection:CCHeck:PARameter <Mname>

(Read-Write) Specifies an existing measurement to be used for the Confidence Check.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<Mname> | Name of the measurement you are selecting for the confidence check. The measurement must already exist.
Examples | SENS:CORR:CCH:PAR 'TEST' 'selects the measurement "test" on channel 1 for the confidence check sense2:correction:ccheck:parameter 'test' 'selects the measurement "test" on channel 2 for the confidence check
Query Syntax | SENSe<cnum>:CORRection:CCHeck:PARameter? Returns the name of the selected measurement on channel <cnum>.
Overlapped? | No
Default | Not applicable

SENSe<cnum>:CORRection:COEFficient <term>[,port]

(Write-only) Displays the selected error term as trace data. Correction must be turned on. Note: This command displays error terms for only Channel 1 measurements
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<term> | Error term to be displayed:
Specify this: | to get this Term...
1 | Directivity
2 | Source Match
3 | ReflectionTracking
4 | Isolation
5 | Load Match
6 | Transmission Tracking
[port] | Optional Parameter - Port number of the source drive. If unspecified, value is set to 1.
Examples | SENS:CORR:COEF 1 'Displays the directivity term for port 1 source SENS:CORR:COEF 2,2 'Displays the source match for port 2 source
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

SENSe<cnum>:CORRection:COLLect[:ACQuire] <char>[,char]

(Write-only) Measures the specified standards from the selected calibration kit. The calibration kit is selected using the Sense:Correction:Collect:CKIT command.

Note: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

 | <char> | Measures the standards associated with these class labels:
 | STAN1 | S11A and S22A
 | STAN2 | S11B and S22B
 | STAN3 | S11C and S22C
 | STAN4 | S21T and S12T - usually the THRU standard
 | STAN5 | Generic Isolation; not associated with calibration kit definition
 | ECALA | ECAL module A
 | ECALB | ECAL module B
 | SLSET | Sets 'sliding load type', and increments the "number of slides" count. The total number of slides is critical to the correct calculation of the sliding load algorithm. See a sliding load cal example.
 | SLDONE | Computes the sliding load using a circle fit algorithm.
[char] |  | Optional argument.
 |  | For mechanical calibration kits, this argument is for specifying the standard identified in the SENS:CORR:COLL:CKIT:ORDer list to be acquired. If this argument is not used, the default is SST1.
<char> | Measures the standards associated with these class labels:
SST1 | First standard in the order list
SST2 | Second standard in the order list
SST3 | Third standard in the order list
SST4 | Fourth standard in the order list
SST5 | Fifth standard in the order list
SST6 | Sixth standard in the order list
SST7 | Seventh standard in the order list
 | For ECal, this argument is for specifying which characterization within the ECal module will be used for the acquire. If this argument is not used, the default is CHAR0.
<char> | Measures the standards associated with these class labels:
CHAR0 | Factory characterization (data that was stored in the ECal module by Agilent)
CHAR1 | User characterization (data that was written to the module by the User Characterization feature on the PNA)
Examples | SENS:CORR:COLL STAN1 'if SENS:CORR:COLL:CKIT:ORDer2 5,3,7 was specified, the following command measures standard 3 (the second in the order list) sense1:correction:collect:acquire stan3,sst2 SENS:CORR:COLL ECALA sense2:correction:collect:acquire ecalb,char1
Query Syntax | Not applicable
Overlapped? | No
Default | Not applicable

SENSe<cnum>:CORRection:COLLect:APPLy

(Write-only) Applies error terms to the measurement that is selected using Calc:Par:Select.

Note: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.

Note: This command is only necessary if you need to modify error terms. If you do not need to modify error terms, SENSe<cnum>:CORRection:COLLect:SAVE calculates and then automatically applies error terms after you use SENS:CORR:COLL:ACQuire to measure cal standards.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

Example

  1. CALCulate2:PARameter:SELect S21_2 'select the measurement to apply terms to

  2. SENSe2:CORRection:COLLect:METHod SPARSOLT 'set type of cal method.

  3. CALCulate2:DATA? SCORR1 'download the error term of interest

  4. 'Modify the error term here

  5. CALCulate2:DATA SCORR1 'upload the error term of interest

  6. SENSe2:CORRection:COLLect:APPLy 'applies the error terms to the measurement

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

SENSe<cnum>:CORRection:COLLect:METHod <char>

(Read-Write) Sets the calibration method. (also known as 'Calibration Type' on calibration dialog box.)

Note: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

Method | Description
NONE | No Cal method
GUIDED | Guided calibration
REFL1OPEN | Response Open
REFL1SHORT or REFL1 | Response Short
REFL3 | Full 1 port
TRAN1 | Response Thru
TRAN2 | Response Thru and Isolation
SPARSOLT | Full SOLT 2 port
Examples | SENS:CORR:COLL:METH REFL1 sense2:correction:collect:method sparsolt
Query Syntax | SENSe<cnum>:CORRection:COLLect:METHod?
Return Type | Character
Overlapped? | No
Default | Not Applicable

SENSe<cnum>:CORRection:COLLect:SAVE

(Write-only) Calculates the error terms using the selected :METHod and applies the error terms to the selected measurement (turns error correction ON.) Does NOT save the calibration error-terms.

Note: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

Examples

SENS:CORR:COLL:SAVE
sense2:correction:collect:save

Query Syntax

Not applicable

Overlapped?

No

Default

Not applicable

SENSe<cnum>:CORRection:EXTension:PORT<pnum>[:TIME] <num>

(Read-Write) Sets the extension value at the specified port. Must also set SENS:CORR:EXT ON. Note: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<pnum> | Number of the port that will receive the extension. If unspecified, value is set to 1. Choose from: 1 for Port 1 2 for Port 2
<num> | The port extension in seconds; may include suffix. Choose a number between: -10 and 10
Examples | SENS:CORR:EXT:PORT 2MS sense2:correction:extension:port2 .00025
Query Syntax | SENSe<cnum>:CORRection:EXTension:PORT<pnum> [:TIME]?
Return Type | Character
Overlapped? | No
Default | 0

SENSe<cnum>:CORRection:EXTension:RECeiver<Rnum>[:TIME] <num>

(Read-Write) Sets the extension value at the specified receiver. Must also set SENS:CORR:EXT ON . Note: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<Rnum> | Number of the receiver that will receive the extension. If unspecified, value is set to 1 Choose from: 1 for Receiver A 2 for Receiver B
<num> | The electrical length in seconds; may include suffix. Choose a number between: -10 and 10
Examples | SENS:CORR:EXT:REC 2MS sense2:correction:extension:receiver2:time .00025
Query Syntax | SENSe<cnum>:CORRection:EXTension:RECeiver<Rnum> [:TIME]?
Return Type | Character
Overlapped? | No
Default | 0

SENSe<cnum>:CORRection:EXTension[:STATe] <ON | OFF>

(Read-Write) Turns port extensions ON or OFF. Note: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns port entensions ON. OFF (or 0) - turns port extensions is OFF.
Examples | SENS:CORR:EXT ON sense2:correction:extension:state off
Query Syntax | SENSe<cnum>:CORRection:EXTension[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe:CORRection:IMPedance:INPut:MAGNitude <num>

(Read-Write) Sets and returns the system impedance value for the analyzer.
Parameters |
<num> | System Impedance value in ohms. Choose any number between 0 and 1000 ohms.
Examples | SENS:CORR:IMP:INP:MAGN 75 sense:correction:impedance:input:magnitude 50.5
Query Syntax | SENSe:CORRection:IMPedance: INPut:MAGNitude?
Return Type | Character
Overlapped? | No
Default | 50

SENSe<cnum>:CORRection:INTerpolation[:STATe] <ON | OFF>

(Read-Write) Turns correction interpolation ON or OFF. Note: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns interpolation ON. OFF (or 0) - turns interpolation OFF.
Examples | SENS:CORR:INT ON sense2:correction:interpolation:state off
Query Syntax | SENSe<cnum>:CORRection:INTerpolation[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SENSe<cnum>:CORRection:ISOLation[:STATe] <ON | OFF>

(Read-Write) Turns isolation cal ON or OFF during Full 2-port calibration. If this comand is not sent, the default state is to disable Isolation.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns isolation ON. OFF (or 0) - turns isolation OFF.
Examples | SENS:CORR:ISOL ON sense2:correction:isolation:state off
Query Syntax | SENSe<cnum>:CORRection:ISOLation[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF - (Isolation disabled)

SENSe<cnum>:CORRection:RVELocity:COAX <num>

(Read-Write) Sets the velocity factor to be used with Electrical Delay and Port Extensions.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Velocity factor. Choose a number between: 0 and 10 (.66 polyethylene dielectric; .7 teflon dielectric) Note: to specify the electrical delay for reflection measurements (in both directions), double the velocity factor.
Examples | SENS:CORR:RVEL:COAX .66 sense2:correction:rvelocity:coax .70
Query Syntax | SENSe<cnum>:CORRection:RVELocity:COAX?
Return Type | Character
Overlapped? | No
Default | 1

SENSe:CORRection:SFORward[:STATe] <boolean>

(Read-Write) Sets the direction a calibration will be performed when only one set of standards is used. Use SENSe:CORRection:TSTandards[:STATe] OFF to specify that only one set of standards will be used.
Parameters |
<boolean> | ON (1) - FORWARD direction of a 2-port calibration will be performed OFF (0) - REVERSE direction of a 2-port calibration will be performed
Examples | SENS:CORR:SFOR 1 sense:correction:sforward:state 0 See an example using this command
Query Syntax | Not applicable
Overlapped? | No
Default | ON

SENSe<cnum>:CORRection[:STATe] <ON | OFF>

(Read-Write) Specifies whether or not correction data is applied to the measurement. Note: Before using this command you must select a measurement using CALC:PAR:SEL. You can select one measurement for each channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - correction is applied to the measurement. OFF (or 0) - correction is NOT applied to the measurement.
Examples | SENS:CORR ON sense2:correction:state off
Query Syntax | SENSe<cnum>:CORRection[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SENSe:CORRection:TSTandards[:STATe] <boolean>

(Read / Write) Specifies the acquisition of calibration data using TWO set of standards or ONE.

Parameters

<boolean>

ON (1) - TWO sets of standards will be used for full 2-port calibration for both Forward and Reverse parameters.

OFF (2) - ONE set of standards will be used for full 2-port calibration.

Set SENSe:CORRection:COLLect:SFORward[:STATe] to ON for the forward acquisitions and OFF for the reverse acquisitions.

Examples

SENS:CORR:TST 1
sense:correction:tstandard:state 0

See an example using this command

Query Syntax

SENSe:CORRection:TSTandards[:STATe]?

Overlapped?

No

Default

ON


Sweep SCPI

Sense:Sweep Commands

Specifies the sweep functions of the analyzer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn a bout Sweeping

SENSe<cnum>:SWEep:DWELl <num>

(Read-Write) Sets the dwell time between each sweep point.

  • Dwell time is ONLY available with SENSe:SWEep:GENeration set to STEPped; It is Not available in ANALOG.

  • Sending dwell = 0 is the same as setting SENS:SWE:DWEL:AUTO ON. Sending a dwell time > 0 sets SENS:SWE:DWEL:AUTO OFF.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Dwell time in seconds.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SENS:SWE:DWEL .1
sense2:sweep:dwell min

Query Syntax

SENSe<cnum>:SWEep:DWELl?

Return Type

Character

Overlapped?

No

Default

0 - (Note: dwell time set to 0 is the same as dwell:auto ON)

SENSe<cnum>:SWEep:DWELl:AUTO <ON | OFF>

(Read-Write) Specifies whether or not to automatically calculate and set the minimum possible dwell time. Setting Auto ON has the same effect as setting dwell time to 0.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns dwell ON. OFF (or 0) - turns dwell OFF.
Examples | SENS:SWE:DWEL:AUTO ON sense2:sweep:dwell:auto off
Query Syntax | SENSe<cnum>:S WEep:DWELl:AUTO?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SENSe<cnum>:SWEep:GENeration <char>

(Read-Write) Sets sweep as Stepped or Analog.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<char>

Choose from:

STEPped - source frequency is CONSTANT during measurement of eah displayed point. More accurate than ANALog. Dwell time can be set in this mode.

ANALog - source frequency is continuously RAMPING during measurement of each displayed point. Faster than STEPped. Sweep time (not dwell time) can be set in this mode.

Examples

SENS:SWE:GEN STEP
sense2:sweep:generation analog

Query Syntax

SENSe<cnum>:S WEep:GENeration?

Return Type

Character

Overlapped?

No

Default

Analog

SENSe<cnum>:SWEep:GROups:COUNt <num>

(Read-Write) Sets the trigger count (groups) for the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Count (groups) number. Choose any number between: 1 and 2e6 (1 is the same as single trigger)
Examples | SENS:SWE:GRO:COUN 10 sense2:sweep:groups:count 50
Query Syntax | SENSe<cnum>:SWEep:GROups:COUNt?
Return Type | Character
Overlapped? | No
Default | 1

SENSe<cnum>:SWEep:MODE <char>

(Read-Write) Sets the trigger mode for the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Trigger mode. Choose from: HOLD - channel will not trigger CONTinuous - channel triggers indefinitely GROups - channel accepts the number of triggers specified with the last SENS:SWE:GRO:COUN <num>
Examples | SENS:SWE:MODE CONT sense2:sweep:mode hold
Query Syntax | SENSe<cnum>:SWEep:MODE?
Return Type | Character
Overlapped? | YES - SENS:SWE:MODE GROUPS (when INIT:CONT is ON) NO - HOLD and CONTinuous
Default | CONTinuous

SENSe<cnum>:SWEep:POINts <num>

(Read-Write) Sets the number of data points for the measurement.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Choose any number between 1 and 16001 Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SWE:POIN 51 sense2:sweep:points max
Query Syntax | SENSe<cnum>:S WEep:POINts?
Return Type | Character
Overlapped? | No
Default | 201

SENSe<cnum>:SWEep:SRCPort <1 | 2>

(Read-Write) Sets the source port when making non S-parameter measurements. Has no effect on S-parameter measurements.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<1 | 2> | 1 - Source power comes out Port 1 2 - Source power comes out Port 2
Examples | SENS:SWE:SRCP 1 sense2:sweep:srcport 2
Query Syntax | SENSe<cnum>:S WEep:SRCPort?
Return Type | Character
Overlapped? | No
Default | 1

SENSe<cnum>:SWEep:TIME <num>

(Read-Write) Sets the time the analyzer takes to complete one sweep.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Sweep time in seconds. Choose a number between 0 and 86,400 (24hrs) Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.
Examples | SENS:SWE:TIME 1ms sense2:sweep:time .001
Query Syntax | SENSe<cnum>:S WEep:TIME?
Return Type | Character
Overlapped? | No
Default | NA

SENSe<cnum>:SWEep:TIME:AUTO <ON | OFF>

(Read-Write) Turns the automatic sweep time function ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns the automatic sweep time ON. OFF (or 0) - turns the automatic sweep time OFF.
Examples | SENS:SWE:TIME:AUTO sense2:sweep:time:auto off
Query Syntax | SENSe<cnum>:S WEep:TIME:AUTO?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SENSe<cnum>:SWEep:TRIGger:POINt <ON | OFF>

(Read-Write) Specifies whether the specified channel will measure one point for each trigger or all of the measurements in the channel. Setting any channel to POINt mode will automatically set the TRIGger:SCOPe = CURRent.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - Channel measures one data point per trigger. OFF (or 0) - All measurements in the channel made per trigger.
Examples | SENS:SWE:TRIG:POIN ON sense2:sweep:trigger:point off
Query Syntax | SENSe<cnum>:SWEep:TRIGger:POINt?
Return Type | Boolean (1 = Point, 0 = Measurement)
Overlapped? | No
Default | 0 - Measurement

SENSe<cnum>:SWEep:TYPE <char>

(Read-Write) Sets the type of analyzer sweep mode.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: LINear | LOGarithmic | POWer | CW | SEGMent Note: SWEep TYPE cannot be set to SEGMent if there are no segments turned ON. A segment is automatically turned ON when the analyzer is started.
Examples | SENS:SWE:TYPE LIN sense2:sweep:type segment
Query Syntax | SENSe<cnum>:S WEep:TYPE?
Return Type | Character
Overlapped? | No
Default | LINear

List of all commands in this block:
(Parameters in bold italics)

:SENSe1:SWEep:DWELL 2ms
:SENSe1:SWEep:DWELL?
:SENSe1:SWEep:DWELL:AUTO ON
:SENSe1:SWEep:DWELL:AUTO?
:SENSe1:SWEep:GENeration STEP
:SENSe1:SWEep:GENeration?
:SENSe1:SWEep:GROups:COUNt 50
:SENSe1:SWEep:GROups:COUNt?
:SENSe1:SWEep:MODE CONT
:SENSe1:SWEep:MODE?
:SENSe1:SWEep:POINts 201
:SENSe1:SWEep:POINts?
:SENSe1:SWEep:SRCPort 1
:SENSe1:SWEep:SRCPort?
:SENSe1:SWEep:TIME 2ms
:SENSe1:SWEep:TIME?
:SENSe1:SWEep:TIME:AUTO ON
:SENSe1:SWEep:TIME:AUTO?
:SENSe1:SWEep:TRIGger:POINt ON
:SENSe1:SWEep:TRIGger:POINt?
:SENSe1:SWEep:TYPE LINear
:SENSe1:SWEep:TYPE?


Source SCPI

Source Commands

Controls the power delivered to the DUT.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Power Settings

SOURce<cnum>:POWer<port>:ATTenuation <num>

(Read-Write) Sets the attenuation level for the selected channel. Sending this command turns automatic attenuation control (SOUR:POW:ATT:AUTO) to OFF. If the ports are coupled, changing the attenuation on one port will also change the attenuation on the other port. To turn port coupling OFF use SOURce:POWer:COUPle OFF.

Note: Attenuation cannot be set with Sweep Type set to Power

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Port number of the attenuator being set. Choose 1 or 2; If unspecified, value is set to 1.

<num>

Choose a number between 0 and 70 dB, in 10 dB steps.
If a number other than these is entered, the analyzer will select the next lower valid value. For example, if 19.9 is entered for <num> the analyzer will switch in 10 dB attenuation.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SOUR:POW:ATT 10
source2:power:attentuation maximum

Query Syntax

SOURce<cnum>:POWer<port>:ATTenuation?

Return Type

Character

Overlapped?

No

Default

0

SOURce<cnum>:POWer<port>:ATTenuation:AUTO <ON | OFF>

(Read-Write) Turns automatic attenuation control ON or OFF. Setting an attenuation value (using SOURce:POWer:ATTenuation <num>) sets AUTO OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1.
<port> | Port number of the attenuator being set. Choose 1 or 2; If unspecified, value is set to 1.
<ON | OFF> | ON (or 1) - turns coupling ON. The analyzer automatically selects the appropriate attenuation level to meet the specified power level. OFF (or 0) - turns coupling OFF. Attenuation level must be set using SOURce:POWer:ATTenuation <num>.
Examples | SOUR:POW2:ATT:Auto On source2:power: attentuation:auto off
Query Syntax | SOURce<cnum>:POWer:ATTenuation:Auto?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SOURce<cnum>:POWer:CENTer <num>

(Read-Write) Sets the power sweep center power. Must also set: SENS:SWE:TYPE POWer and SOURce:POWer:SPAN <num>.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Center power. Choose a number between -90 and 20 dBm (actual achievable leveled power depends on frequency)
Examples | SOUR:POW:CENT -15 source2:power:center -7
Query Syntax | SOURce<cnum>:POWer:CENTer?
Return Type | Character
Overlapped? | No
Default | 0 dBm

SOURce<cnum>:POWer:COUPle <ON | OFF>

(Read-Write) Turns Port Power Coupling ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON | OFF> | ON (or 1) - turns coupling ON. Power level can be set individually for each source port. OFF (or 0) - turns coupling OFF. The same power level is used for both source ports.
Examples | SOUR:POW:COUP ON source2:power:couple off
Query Syntax | SOURce<cnum>:POWer:COUPle?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | ON

SOURce<cnum>:POWer:DETector <INTernal | EXTernal>

(Read-Write) Sets the source leveling loop as Internal or External.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<INTernal | EXTernal> | INTernal - Internal leveling is applied to the source EXTernal - External leveling is applied to the source through a rear-panel jack.
Examples | SOUR:POW:DET INT source2:power:detector external
Query Syntax | SOURce<cnum>:POWer:DETector?
Return Type | Character
Overlapped? | No
Default | INTernal

SOURce<cnum>:POWer<port>[:LEVel][:IMMediate]
[:AMPLitude] <num>

(Read-Write) Sets the RF power output level.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Port number of the attenuator being set. Choose 1 or 2; If unspecified, value is set to 1.

<num>

Source power in dBm. Choose any value between -90 and +20 dBm
Actual achievable leveled power depends on frequency.

Note: This command will accept MIN or MAX instead of a numeric parameter. See SCPI Syntax for more information.

Examples

SOUR:POW1 5DB
source2:power:level
:immediate:amplitude maximum

Query Syntax

SOURce<cnum>:POWer[:LEVel][:IMMediate][:AMPLitude]?

Return Type

Character

Overlapped?

No

Default

0 dBm

SOURce<cnum>:POWer[:LEVel]:SLOPe <int>

(Read-Write) Sets the RF power slope value.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<int> | Slope value in db/GHz. Choose any integer between -2 and 2 (0 is no slope).
Examples | SOUR:POW:SLOP 2 source2:power:slope -2
Query Syntax | SOURce<cnum>:POWer[:LEVel]:SLOPe?
Return Type | Character
Overlapped? | No
Default | 0

SOURce<cnum>:POWer[:LEVel]:SLOPe:STATe <ON|OFF>

(Read-Write) Turns Power Slope ON or OFF.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON|OFF> | ON (or 1) - turns slope ON. OFF (or 0) - turns slope OFF.
Examples | SOUR:POW:SLOP:STAT ON source2:power:slope:state off
Query Syntax | SOURce<cnum>:POWer[:LEVel]:SLOPe:STATe?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF

SOURce<cnum>:POWer:SPAN <num>

(Read-Write) Sets the power sweep span power. Must also set:

SENS:SWE:TYPE POWer and SOURce:POWer:CENTer <num> .

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<num>

Span power. Choose a number between:
-90 and 20 dBm
(actual achievable leveled power depends on frequency)

Examples

SOUR:POW:SPAN -15
source2:power:span -7

Query Syntax

SOURce<cnum>:POWer:SPAN?

Return Type

Character

Overlapped?

No

Default

0 dBm

SOURce<cnum>:POWer:STARt <num>

(Read-Write) Sets the power sweep start power. Must also set SENS:SWE:TYPE POWer and SOURce:POWer:STOP <num>.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Start power. Choose a number between -90 and +20 dBm (actual achievable leveled power depends on frequency)
Examples | SOUR:POW:STAR -15 source2:power:start -7
Query Syntax | SOURce<cnum>:POWer:STARt?
Return Type | Character
Overlapped? | No
Default | 0 dBm

SOURce<cnum>:POWer:STOP <num>

(Read-Write) Sets the power sweep stop power. Must also set: SENS:SWE:TYPE POWer and SOURce:POWer:START <num>.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<num> | Stop power. Choose a number between -90 and +20 dBm (actual achievable leveled power depends on frequency)
Examples | SOUR:POW:STOP -15 source2:power:stop -7
Query Syntax | SOURce<cnum>:POWer:STOP?
Return Type | Character
Overlapped? | No
Default | 0 dBm


SourceCorrection SCPI

Source:Power:Correction Commands

Controls the source power correction features of the analyzer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • See an example program using these commands.

  • See a template for creating your own Power Meter Driver

  • Learn about Source Cal

Note: the SOURce:POWer:CORRection:COLLect:ACQuire command, used to step the PNA and read a power meter, cannot be sent over the GPIB. Use one of the alternative methods described in the command details.

SOURce<cnum>:POWer<port>:CORRection:COLLect:ABORt

(Write-only) Aborts a source power calibration sweep that is in progress.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<port> | Port number to correct for source power. If unspecified, value is set to 1.
Examples | SOUR:POW:CORR:COLL:ABOR source1:power2:correction:collect:abort
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SOURce<cnum>:POWer<port>:CORRection:COLLect[:ACQuire] <char>

(Write-only) Initiates a source power cal acquisition sweep using the power sensor attached to the specified channel (A or B) on the power meter.

Note: Never use GPIB to send this SCPI command to the PNA. This command requires the PNA to take GPIB control. The PNA currently does not support pass control a technique whereby GPIB control can be passed back and forth between two controllers.

Use one of the following methods to perform this command or its equivalent:

  • SCPI programming of the PNA using a LAN Client interface (see example)

  • Send SCPI commands through the COM interface using the SCPI String Parser object.

  • Directly control the Power Meter and PNA to step frequency; then acquire and store the Power reading. (see example)

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Port number to correct for source power. If unspecified, value is set to 1.

<char>

Choose from:

ASENsor - Sensor on power meter channel A

BSENsor - Sensor on power meter channel B

Examples

SOUR:POW:CORR:COLL ASEN
source1:power2:correction:collect:acquire bsensor

Query Syntax

Not Applicable

Overlapped?

No

Default

Not Applicable

SOURce<cnum>:POWer<port>:CORRection:COLLect:AVERage[:COUNt] <num>

(Read-Write) Specifies how many power readings are taken at each frequency point (averaging factor) during a source power cal acquisition sweep.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<port> | Port number to correct for source power. If unspecified, value is set to 1.
<num> | Number of readings per point. Choose any number between 1 and 100.
Examples | SOUR:POW:CORR:COLL:AVER 2 source1:power2:correction:collect:average:count 3
Query Syntax | SOURce:POWer:CORRection:COLLect:AVERage[:COUNt]?
Return Type | Character
Overlapped? | No
Default | 1

SOURce<cnum>:POWer:CORRection:COLLect:FCHeck[:STATe] <ON | OFF>

(Read-Write) Enables and disables frequency checking of source power cal acquisition sweeps.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<ON|OFF>

ON (1) turns source power cal frequency checking ON. A requested acquisition will only succeed for those frequency points which fall within a frequency range specified for the power sensor being used. An acquisition will pause in mid-sweep if the frequency is about to exceed the maximum frequency limit specified for that sensor. When the sweep is paused in this manner, a sensor connected to the other channel input of the power meter can be connected to the measurement port in place of the previous sensor, and used to complete the sweep. However, the maximum frequency specified for the second sensor would need to be sufficient for the sweep to complete. Frequency limits are specified using the commands SOURce<cnum>:POWer:CORRection:COLLect:ASENsor[:FRANge] and

SOURce<cnum>:POWer:CORRection:COLLect:BSENsor[:FRANge].

OFF (0) - turns source power cal frequency checking OFF. An acquisition will use just one power sensor for the entire sweep, regardless of frequency.

Examples

SOUR:POW:CORR:COLL:FCH ON
source1:power2:correction:collect:fcheck:state off

Query Syntax

SOURce:POWer:CORRection:COLLect:FCHeck[:STATe]?

Return Type

Boolean (1 = ON, 0 = OFF)

Overlapped?

No

Default

OFF (0)

SOURce<cnum>:POWer<port>:CORRection:COLLect:METHod <char>

(Read-Write) Selects the source power calibration method. Currently, PMETer is the only supported method. In general, test software should not omit use of this command as it may eventually be required if other source power cal methods become supported.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<port> | Port number to correct for source power. If unspecified, value is set to 1.
<char> | Choose from: NONE - No Cal method PMETer - Power Meter
Examples | SOUR:POW:CORR:COLL:METH PMET source1:power2:correction:collect:method pmeter
Query Syntax | SOURce:POWer:CORRection:COLLect:METHod?
Return Type | Character
Overlapped? | No
Default | NONE

SOURce<cnum>:POWer<port>:CORRection:COLLect:SAVE

(Write-only) Applies the array of correction values after a source power calibration sweep has completed. The source power correction will then be active on the specified source port for channel <cnum>. This command does NOT save the correction values.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<port> | Port number to correct for source power. If unspecified, value is set to 1.
Examples | SOUR:POW:CORR:COLL:SAVE source1:power2:correction:collect:save
Query Syntax | Not Applicable
Overlapped? | No
Default | Not Applicable

SOURce<cnum>:POWer:CORRection:COLLect:<pmChan>SENsor[:FRANge] <num1>,<num2>

(Read-Write) Specifies the frequency range over which the power sensors connected to the specified channels (A and B) of the power meter can be used (minimum frequency, maximum frequency). If the power meter has only a single channel, that channel is considered channel A.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<pmChan> | Power Meter channel. Choose from: A - Channel A B - Channel B
<num1> | Minimum frequency for the sensor. If a frequency unit is not specified, Hz is assumed. No limits are placed on this value.
<num2> | Maximum frequency for the sensor. If a frequency unit is not specified, Hz is assumed. No limits are placed on this value.
Examples | SOUR:POW:CORR:COLL:ASEN 100E3, 3E9 source1:power2:correction:collect:bsensor:frange 10 MHz, 18 GHz
Query Syntax | SOURce:POWer:CORRection:COLLect:ASENsor[:FRANge]? SOURce:POWer:CORRection:COLLect:BSENsor[:FRANge]?
Return Type | Character
Overlapped? | No
Default | 0,0

SOURce<cnum>:POWer:CORRection:COLLect:<pmChan>SENsor:RCFactor <num>

(Read-Write) ) Specifies the reference cal factor for the power sensor connected to channel A or B of the power meter. If the power meter has only a single channel, that channel is considered channel A.

Note: If the sensor connected to the specified channel of the power meter contains cal factors in EPROM (such as the Agilent E-series power sensors), those will be the cal factors used during the calibration sweep. The reference cal factor value associated with this command, and any cal factors entered into the PNA for that sensor channel, will not be used.

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<pmChan>

Power Meter channel. Choose from:

A - Channel A

B - Channel B

<num>

Reference cal factor in percent. Choose any number between 1 and 150.

Examples

SOUR:POW:CORR:COLL:ASEN:RCF 98.7
source1:power2:correction:collect:bsensor:rcfactor 105

Query Syntax

SOURce:POWer:CORRection:COLLect:ASENsor:RCFactor?

SOURce:POWer:CORRection:COLLect:BSENsor:RCFactor?

Return Type

Character

Overlapped?

No

Default

100

SOURce<cnum>:POWer:CORRection:COLLect:TABLe:DATA <data>

(Read-Write) Read or write data into the selected table. If the selected table is a power sensor table, the data is interpreted as cal factors in units of percent. If the loss table is selected, the data is interpreted as loss in units of dB.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<data> | Data to write into the selected table.
Examples | SOURce:POWer:CORRection:COLLect:TABLe:DATA 0.12, 0.34, 0.56
Query Syntax | SOURce<cnum>:POWer:CORRection:COLLect:TABLe:DATA? If the selected table is currently empty, no data is returned.
Return Type | Character - one number per table segment
Overlapped? | No
Default | Not Applicable

SOURce<cnum>:POWer:CORRection:COLLect:TABLe:FREQuency <data>

(Read-Write) Read or write frequency values for the selected table (cal factor table for a power sensor, or the loss compensation table).
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<data> | Frequency data to write into the selected table.
Examples | SOURce:POWer:CORRection:COLLect:TABLe:FREQuency 10E6, 1.5E9, 9E9
Query Syntax | SOURce<cnum>:POWer:CORRection:COLLect:TABLe:FREQuency? If the selected table is currently empty, no data is returned.
Return Type | Character - one number per table segment
Overlapped? | No
Default | Not Applicable

SOURce<cnum>:POWer:CORRection:COLLect:TABLe:LOSS[:STATe] <ON | OFF>

(Read-Write) Indicates whether or not to adjust the power readings using the values in the loss table during a source power cal sweep.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<ON|OFF> | ON (or 1) - turns use of the loss table ON. OFF (or 0) - turns use of the loss table OFF.
Examples | SOUR:POW:CORR:COLL:TABL:LOSS ON source1:power2:correction:collect:table:loss:state off
Query Syntax | SOURce:POWer:CORRection:COLLect:TABLe:LOSS[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF (0)

SOURce<cnum>:POWer:CORRection:COLLect:TABLe:POINts?

(Read-only) Returns the number of segments that are currently in the selected table.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
Examples | SOUR:POW:CORR:COLL:TABL:POIN? source1:power2:correction:collect:table:points?
Return Type | Character
Overlapped? | No
Default | 0

SOURce<cnum>:POWer:CORRection:COLLect:TABLe[:SELect] <char>

(Read-Write) Selects which table (cal factor table for a power sensor, or the loss compensation table) you want to write to or read from. Read or write using SOURce:POWer:CORRection:COLLect:TABLe:FREQuency and SOURce:POWer:CORRection:COLLect:TABLe:DATA
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<char> | Choose from: NONE - No table selected ASENsor - Cal Factor table for Power Sensor A BSENsor - Cal Factor table for Power Sensor B LOSS - Loss compensation table
Examples | SOUR:POW:CORR:COLL:TABL ASEN source1:power2:correction:collect:table:select bsensor
Query Syntax | SOURce:POWer:CORRection:COLLect:TABLe[:SELect]?
Return Type | Character
Overlapped? | No
Default | NONE

SOURce<cnum>:POWer<port>:CORRection:DATA <data>

(Read-Write) Writes and reads source power calibration data.

When querying source power calibration data, if no source power cal data exists for the specified channel and source port, no data is returned.

If a change in the instrument state causes interpolation and/or extrapolation of the source power cal, the correction data associated with this command correspond to the new instrument state (interpolated and/or extrapolated data).

Parameters

<cnum>

Any existing channel number. If unspecified, value is set to 1

<port>

Port number to correct for source power. If unspecified, value is set to 1.

<data>

Correction Data

Examples

SOURce1:POWer2:CORRection:DATA 0.12, -0.34, 0.56

Query Syntax

SOURce<cnum>:POWer<port>:CORRection:DATA?

Return Type

Character - One number per trace point

Overlapped?

No

Default

Not Applicable

SOURce<cnum>:POWer<port>:CORRection:LEVel <num>

(Read-Write) Specifies the power level that is expected at the desired reference plane (DUT input or output).
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<port> | Port number to correct for source power. If unspecified, value is set to 1.
<num> | Cal power level in dBm. Because this could potentially be at the output of a device-under-test, no limits are placed on this value here. It is realistically limited by the specifications of the device (power sensor) that will be used for measuring the power. The power delivered to the PNA receiver must never exceed PNA specifications for the receiver!
Examples | SOUR:POW:CORR:LEV 10 source1:power2:correction:level 0 dbm
Query Syntax | SOURce:POWer:CORRection:LEVel?
Return Type | Character
Overlapped? | No
Default | 0 dBm

SOURce<cnum>:POWer<port>:CORRection[:STATe] <ON|OFF>

(Read-Write) Enables and disables source power correction for the specified port on the specified channel.
Parameters |
<cnum> | Any existing channel number. If unspecified, value is set to 1
<port> | Port number to correct for source power. If unspecified, value is set to 1.
<ON|OFF> | ON (or 1) turns source power correction ON. OFF (or 0) - turns source power correction OFF.
Examples | SOUR:POW:CORR ON source1:power2:correction:state off
Query Syntax | SOURce:POWer:CORRection[:STATe]?
Return Type | Boolean (1 = ON, 0 = OFF)
Overlapped? | No
Default | OFF (0)


Status SCPI

Status Register Commands

The status registers enable you to query the state of selected events that occur in the analyzer.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Status Registers

Note: Any bit not shown in the registers is not used but may be reserved for future use.

Status Byte Register

Summarizes the states of the other registers and monitors the analyzer's output queue. It also generates service requests. The Enable register is called the Service Request Enable Register.

Commands

Description

*CLS

Clears ALL "event" registers and the SCPI Error / Event queue. The corresponding ENABLE registers are unaffected.

*STB?

Reads the value of the analyzer's status byte. The byte remains after being read.

*SRE?

Reads the current state of the Service Request Enable Register.

*SRE <num>

Sets bits in the Service Request Enable register. The current setting of the SRE register is stored in non-volatile memory. Use *SRE 0 to clear the enable.

<num> Combined value of the weights for bits to be set.

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
2 | 4 | Error / Event queue Summary (EAV) | the Error / Event queue is not empty. To read the the error message, use SYST:ERR?
3 | 8 | Questionable Register Summary | any enabled bit in the questionable event status register is set to 1
4 | 16 | Message Available | the output queue is not empty
5 | 32 | Standard Event Register Summary | any enabled bit in the standard event status register is set to 1
6 | 64 | Request Service | any of the other bits in the status byte register is set to 1 (used to alert the controller of a service request within the analyzer). This bit cannot be disabled.
7 | 128 | Operation Register Summary | any enabled bit in the standard operation event status register is set to 1

STATus:QUEStionable:<keyword>

Summarizes conditions that monitor the quality of measurement data.

< keyword >

Example

:CONDition?

STAT:QUES:COND?

:ENABle <bits>

STAT:QUES:ENAB 1024

[:EVENt]?

STAT:QUES?

:NTRansition <bits>

STAT:QUES:NTR 1024

:PTRansition <bits>

STAT:QUES:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
9 | 512 | Integrity Reg summary | any enabled bit in the Integrity event register is set to 1
10 | 1024 | Limit Registers summary | any enabled bit in the Limit event registers is set to 1
11 | 2048 | Define Registers summary | any enabled bit in the Define event registers is set to 1

STATus:QUEStionable:INTegrity <keyword>

Summarizes conditions in the Measurement Integrity register.

<keyword>

Example

:CONDition?

STAT:QUES:INT:COND?

:ENABle <bits>

STAT:QUES:INT:ENAB 1024

[:EVENt]?

STAT:QUES:INT?

:NTRansition <bits>

STAT:QUES:INT:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Measurement Summary | any bit in the Measurement Integrity event register is set to 1
2 | 2 | Hardware Summary | any bit in the Hardware event register is set to 1

STATus:QUEStionable:INTegrity:HARDware<keyword>

Monitors the status of hardware failures.

<keyword>

Example

:CONDition?

STAT:QUES:INT:HARD:COND?

:ENABle <bits>

STAT:QUES:INT:HARD:ENAB 1024

[:EVENt]?

STAT:QUES:INT:HARD?

:NTRansition <bits>

STAT:QUES:INT:HARD:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:HARD:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | Phase Unlock | the source has lost phaselock, possibly caused by a reference channel open or a hardware failure.
2 | 4 | Unleveled | the source power is unleveled. This could be caused by a source set for more power than it can deliver at the tuned frequency. Or it could be caused by a hardware failure.
3 | 8 | Overpower | too much power is detected at the input. This is from either using an amplifier, or a hardware failure.
4 | 16 | EE Write Failed | an attempted write to the EEPROM has failed, possibly caused by a hardware failure.
5 | 32 | YIG Cal Failed | the analyzer was unable to calibrate the YIG. Either the phaselock has been lost or there has been a hardware failure.
6 | 64 | Ramp Cal Failed | the analyzer was unable to calibrate the analog ramp generator due to a possible hardware failure.
7 | 128 | OverTemp | the source temperature sensor exceeds the limit. It could result from restricted airflow or a broken fan

STATus:QUEStionable:INTegrity:MEASurement<keyword>

Monitors the lag between changing a channel settings and when the data is ready to query out.

When you change the channel state (start/stop freq, bandwidth, and so on), then the questionable bit for that channel gets set. This indicates that your desired channel state does not yet match the data you would get if querying a data trace. When the next complete sweep has been taken (without aborting in the middle), and the data trace matches the channel state that produced it, the bit is cleared for that channel.

<keyword>

Example

:CONDition?

STAT:QUES:INT:MEAS:COND?

:ENABle <bits>

STAT:QUES:INT:MEAS:ENAB 1024

[:EVENt]?

STAT:QUES:INT:MEAS?

:NTRansition <bits>

STAT:QUES:INT:MEAS:NTR 1024

:PTRansition <bits>

STAT:QUES:INT:MEAS:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Channel1 | a channel1 setting change has occurred and the data does not yet reflect that change.
1 | 2 | Channel2 | a channel2 setting change has occurred and the data does not yet reflect that change.
2 | 4 | Channel3 | a channel3 setting change has occurred and the data does not yet reflect that change.
3 | 8 | Channel4 | a channel4 setting change has occurred and the data does not yet reflect that change.

STATus:QUEStionable:LIMit1<keyword>

Monitors the status of limit line failures and summarizes the Limit2 event register. When a trace fails, or any bit in the Limit2 event register fails, the representative bit is set to 1. These enable bits are set to 1 by default.

Note:The '1' on 'LIMit1 is a parameter. If unspecified, the value is set to 1.

<keyword>

Example

:CONDition?

STAT:QUES:LIM1:COND?

:ENABle <bits>

STAT:QUES:LIM1:ENAB 1024

[:EVENt]?

STAT:QUES:LIM1?

:NTRansition <bits>

STAT:QUES:LIM1:NTR 1024

:NTRansition?

STAT:QUES:LIM1:NTR?

:PTRansition <bits>

STAT:QUES:LIM1:PTR 0

:PTRansition?

STAT:QUES:LIM1:PTR?

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Limit 2 Reg summary | any point from limit2 event register fails
1 | 2 | Trace 1 | any point on trace fails the limit test
2 | 4 | Trace 2 | any point on trace fails the limit test
3 | 8 | Trace 3 | any point on trace fails the limit test
4 | 16 | Trace 4 | any point on trace fails the limit test
5 | 32 | Trace 5 | any point on trace fails the limit test
6 | 64 | Trace 6 | any point on trace fails the limit test
7 | 128 | Trace 7 | any point on trace fails the limit test
8 | 256 | Trace 8 | any point on trace fails the limit test
9 | 512 | Trace 9 | any point on trace fails the limit test
10 | 1024 | Trace 10 | any point on trace fails the limit test
11 | 2048 | Trace 11 | any point on trace fails the limit test
12 | 4096 | Trace 12 | any point on trace fails the limit test
13 | 8192 | Trace 13 | any point on trace fails the limit test
14 | 16384 | Trace 14 | any point on trace fails the limit test

STATus:QUEStionable:LIMit2<keyword>

Monitors the status of limit line failures. When trace 15 or 16 fails, the representative bit is set to 1. These enable bits are set to 1 by default.

Note: The '2' on 'LIMit2 is a parameter. If unspecified, the value is set to 1.

<keyword>

Example

:CONDition?

STAT:QUES:LIM2:COND?

:ENABle <bits>

STAT:QUES:LIM2:ENAB 1024

[:EVENt]?

STAT:QUES:LIM2?

:NTRansition <bits>

STAT:QUES:LIM2:NTR 1024

:PTRansition <bits>

STAT:QUES:LIM2:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | Trace15 | any point on trace fails the limit test
2 | 4 | Trace16 | any point on trace fails the limit test

STATus:QUEStionable:DEFine<keyword>

Summarizes conditions in the Questionable:Define:User<1|2|3> event registers.

<keyword>

Example

:CONDition?

STAT:QUES:DEF:COND?

:ENABle <bits>

STAT:QUES:DEF:ENAB 1024

[:EVENt]?

STAT:QUES:DEF?

:NTRansition <bits>

STAT:QUES:DEF:NTR 1024

:PTRansition <bits>

STAT:QUES:DEF:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | USER1 | any bit in the USER1 event register is set to 1
2 | 4 | USER2 | any bit in the USER2 event register is set to 1
3 | 8 | USER3 | any bit in the USER3 event register is set to 1

STATus:QUEStionable:DEFine:USER<1|2|3><keyword>

Monitors conditions that you define and map in any of the three QUES:DEF:USER event registers.

<keyword>

Example

:ENABle <bits>

STAT:QUES:DEF:USER1:ENABle 1024

[:EVENt]?

STAT:QUES:DEF:USER1?

:MAP <bit>,<error>

STAT:QUES:DEF:USER1:MAP 0,-113 'when error -113 occurs, bit 0 in USER1 will set to 1.

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | for user | user defined
1 | 2 | for user | user defined
2 | 4 | for user | user defined
3 | 8 | for user | user defined
4 | 16 | for user | user defined
5 | 32 | for user | user defined
6 | 64 | for user | user defined
7 | 128 | for user | user defined
8 | 256 | for user | user defined
9 | 512 | for user | user defined
10 | 1024 | for user | user defined
11 | 2048 | for user | user defined
12 | 4096 | for user | user defined
13 | 8192 | for user | user defined
14 | 16384 | for user | user defined

Standard Event Status Register

Monitors "standard" events that occur in the analyzer. This register can only be cleared by:

  • a Clear Command (*CLS).

  • reading the Standard Enable Status Register (*ESE?).

  • a power-on transition. The analyzer clears the register and then records any transitions that occur, including setting the Power On bit (7).

Commands

Description

*ESE?

Reads the settings of the standard event ENABLE register.

*ESE <bits>

Sets bits in the standard event ENABLE register. The current setting is saved in non-volatile memory.

<bits> The sum of weighted bits in the register. Use *ESE 0 to clear the enable register.

*ESR?

Reads and clears the EVENT settings in the Standard Event Status register.

*OPC

Sets bit 0 when the overlapped command is complete. (see Understanding Command Synchronization / OPC).

*OPC?

Operation complete query - read the Operation Complete bit (0).

Bit

Weight

Description

Bit is set to 1 when the following conditions exist:

0

1

Operation Complete

the two following events occur in order:

  1. the *OPC command is sent to the analyzer

  2. the analyzer completes all pending overlapped commands

1

NA

Request Control

Not Supported - the analyzer application is not configured to control GPIB operation

2

4

Query Error

a query error is detected indicating:
- an attempt to read data from the output queue when no data was present OR
- data in the output queue was lost, as in an overflow

4

16

Execution Error

an execution error is detected indicating:
- a <PROGRAM DATA> element was outside the legal range or inconsistent with the operation of the analyzer OR
- the analyzer could not execute a valid command due to some internal condition

5

32

Command Error

a command error is detected indicating that the analyzer received a command that:

  • did not follow proper syntax

  • was misspelled

  • was an optional command it does not implement

7

128

Power ON

Power to the analyzer has been turned OFF and then ON since the last time this register was read.

STATus:OPERation<keyword>

Summarizes conditions in the Averaging and Operation:Define:User<1|2|3> event registers.

<keyword>

Example

:CONDition?

STAT:OPER:COND?

:ENABle <bits>

STAT:OPER:ENAB 1024

[:EVENt]?

STAT:OPER?

:NTRansition <bits>

STAT:OPER:NTR 1024

:PTRansition <bits>

STAT:OPER:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
8 | 256 | Averaging summary | either enabled bit in the Averaging summary event register is set to 1
9 | 512 | User Defined summary |
10 | 1024 | Device summary | either enabled bit in the Device summary event register is set to 1

STATus:OPERation:AVERaging1<keyword>

Monitors Averaging of Traces 1 to 14 and summarizes Traces 15 and 16.

Note:The '1' on 'AVERaging1 is a parameter. If unspecified, the value is set to 1.

<keyword>

Example

:CONDition?

STAT:OPER:AVER1:COND?

:ENABle <bits>

STAT:OPER:AVER1:ENAB 1024

[:EVENt]?

STAT:OPER:AVER1?

:NTRansition <bits>

STAT:OPER:AVER1:NTR 1024

:PTRansition <bits>

STAT:OPER:AVER1:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | AVER2 summary | any enabled bit in AVERaging2 event register is set to 1
1 | 2 | Trace 1 | Averaging is complete
2 | 4 | Trace 2 | Averaging is complete
3 | 8 | Trace 3 | Averaging is complete
4 | 16 | Trace 4 | Averaging is complete
5 | 32 | Trace 5 | Averaging is complete
6 | 64 | Trace 6 | Averaging is complete
7 | 128 | Trace 7 | Averaging is complete
8 | 256 | Trace 8 | Averaging is complete
9 | 512 | Trace 9 | Averaging is complete
10 | 1024 | Trace 10 | Averaging is complete
11 | 2048 | Trace 11 | Averaging is complete
12 | 4096 | Trace 12 | Averaging is complete
13 | 8192 | Trace 13 | Averaging is complete
14 | 16384 | Trace 14 | Averaging is complete

STATus:OPERation:AVERaging2<keyword>

Monitors Averaging of Traces 15 and 16.

Note:The '2' on 'AVERaging2 is a parameter. If unspecified, the value is set to 1.

<keyword>

Example

:CONDition?

STAT:OPER:AVER2:COND?

:ENABle <bits>

STAT:OPER:AVER2:ENAB 1024

[:EVENt]?

STAT:OPER:AVER2?

:NTRansition <bits>

STAT:OPER:AVER2:NTR 1024

:PTRansition <bits>

STAT:OPER:AVER2:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | Trace 15 | Averaging is complete
2 | 4 | Trace 16 | Averaging is complete

STATus:OPERation:DEFine<keyword>

Summarizes conditions in the OPERation:Define:User<1|2|3> event registers.

<keyword>

Example

:CONDition?

STAT:OPER:DEF:COND?

:ENABle <bits>

STAT:OPER:DEF:ENAB 12

[:EVENt]?

STAT:OPER:DEF?

:NTRansition <bits>

STAT:OPER:DEF:NTR 12

:PTRansition <bits>

STAT:OPER:DEF:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
1 | 2 | USER1 | any bit in the USER1 event register is set to 1
2 | 4 | USER2 | any bit in the USER2 event register is set to 1
3 | 8 | USER3 | any bit in the USER3 event register is set to 1

STATus:OPERation:DEFine:USER<1|2|3><keyword>

Monitors conditions that you define and map in any of the three OPER:DEF:USER event registers.

<keyword>

Example

:ENABle <bits>

STAT:OPER:DEF:USER1:ENAB 1024

[:EVENt]?

STAT:OPER:DEF:USER1?

:MAP <bit>,<error>

STAT:OPER:DEF:USER1:MAP 0,-113 'when error -113 occurs, bit 0 in USER1 will set to 1.

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | for user | user defined
1 | 2 | for user | user defined
2 | 4 | for user | user defined
3 | 8 | for user | user defined
4 | 16 | for user | user defined
5 | 32 | for user | user defined
6 | 64 | for user | user defined
7 | 128 | for user | user defined
8 | 256 | for user | user defined
9 | 512 | for user | user defined
10 | 1024 | for user | user defined
11 | 2048 | for user | user defined
12 | 4096 | for user | user defined
13 | 8192 | for user | user defined
14 | 16384 | for user | user defined

STATus:OPERation:DEVice<keyword>

Summarizes conditions in the OPERation:DEVice event registers.

<keyword>

Example

:CONDition?

STAT:OPER:DEV:COND?

:ENABle <bits>

STAT:OPER:DEV:ENAB 16

[:EVENt]?

STAT:OPER:DEV?

:NTRansition <bits>

STAT:OPER:DEV:NTR 16

:PTRansition <bits>

STAT:OPER:DEV:PTR 0

Bit | Weight | Description | Bit is set to 1 when the following conditions exist:
0 | 1 | Unused |
1 | 2 | Unused |
2 | 4 | Unused |
3 | 8 | Unused |
4 | 16 | Sweep Completed | When sweep is complete
5 | 32 | Unused |
6 | 64 | Unused |
7 | 128 | Unused |
8 | 256 | Unused |
9 | 512 | Unused |
10 | 1024 | Unused |
11 | 2048 | Unused |
12 | 4096 | Unused |
13 | 8192 | Unused |
14 | 16384 | Unused |


Status Keywords SCPI

Status Command Keywords

The following keywords can be appended to the node or nodes that represent the Status register you want to control.

  • :CONDition?

  • :ENABle

  • :ENABle?

  • :EVENt?

  • :MAP

  • :NTRansition

  • :PTRansition

Learn about Status Registers

:CONDition?

Monitors the conditions as they occur REAL TIME. That is, a condition may occur, and then clear before the condition is read. Reading this register returns a 16-bit decimal weighted number.

:ENABle <bit>

Enables register bits that will monitored using the service request (SRQ) method. (To use the direct read method, you do not have to enable the bit.)

Default value for STATus:QUEStionable:ENABle and STATus:OPERation:ENABle is 0: No bits enabled.

Default value for all other registers :ENABle <bits> is 32767; ALL BITS ENABLED.

Therefore it is ONLY necessary to send the ENABle keyword if you want to DISABLE some conditions. For example, to enable ONLY Trace1 (bit 2) of the LIMIT1 register (disable all other traces) , send: STATus:QUEStionable:LIMit1:ENABle 4

:ENABle?

Read the enable register to verify the bits that you enabled. Returns a 16 bit weighted sum of the bits that are enabled.

[:EVENt]?

Query only - This is the Default keyword for most registers. Use it to determine if a condition has occured. These bits remain set until they are read or otherwise cleared.

:MAP <bit>,<error>

Associates a bit is the User register with an error number. For example

STATus:QUEStionable:DEFine:USER2:MAP 0,-113

0 is the bit that will be set

-113 is the error

When error -113 "Undefined Header" occurs, bit 0 in the USER2 register will be set to 1.

:NTRansition <bits>

Write-Read - Negative Transition register bits set the condition to be set on the Negative going (True to False) transition. Use this register if you are only interested in a condition changing from True to False.

:NTRansition?

queries the register to verify that you set a negative transition.

:PTRansition <bits>

Write-Read - Positive Transition register bits set the condition to be set on the False to True transition. Use this register if you are only interested in the change of a condition from False to True.

:PTRansition?

Queries the register to verify that you set a positive transition.


System SCPI

System Commands

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Preset

SYSTem:COMMunicate:GPIB:PMETer:ADDRess <num>

(Read-Write) Specifies the GPIB address of the power meter to be used in a source power calibration.
Parameters |
<num> | GPIB address of the power meter. Choose any integer between 0 and 30.
Examples | SYST:COMM:GPIB:PMET:ADDR 13 system:communicate:gpib:pmeter:address 14
Query Syntax | SYSTem:COMMunicate:GPIB:PMETer:ADDRess?
Return Type | Character
Overlapped? | No
Default | 13

SYSTem:CORRection:WIZard <char>

(Write-only) Launches either the Calibration Wizard or the Version 2 Calibration Kit File Manager dialog box.
Parameters |
<char> | Choose from: MAIN - Launches the Calibration Wizard CKIT - Launches the Version 2 Calibration Kit File Manager dialog box. Both display on the PNA screen.
Examples | SYST:CORR:WIZ MAIN system:correction:wizard ckit
Query Syntax | Not Applicable?
Overlapped? | No
Default | Not Applicable

SYSTem:ERRor?

(Read-only) Returns the next error in the error queue. Each time the analyzer detects an error, it places a message in the error queue. When the SYSTEM:ERROR? query is sent, one message is moved from the error queue to the output queue so it can be read by the controller. Error messages are delivered to the output queue in the order they were received. The error queue is cleared when any of the following conditions occur:

  • When the analyzer is switched ON.

  • When the *CLS command is sent to the analyzer.

  • When all of the errors are read.

If the error queue overflows, the last error is replaced with a "Queue Overflow" error. The oldest errors remain in the queue and the most recent error is discarded.

Examples

SYST:ERR?
system:error?

Overlapped?

No

Default

Not applicable

SYSTem:ERRor:COUNt?

(Read-only) Returns the number of errors in the error queue.Use SYST:ERR? to read an error.
Examples | SYST:ERR:COUN? system:error:count?
Overlapped? | No
Default | Not applicable

SYSTem:PRESet

(Write-only) Deletes all traces, measurements, and windows. In addition, resets the analyzer to factory defined default settings and creates a S11 measurement named "CH1_S11_1". For a list of default settings, see Default. If the PNA display is disabled with DISP:ENAB OFF then SYST:PRES will NOT enable the display.
Examples | SYST:PRES system:preset
Overlapped? | No
Default | Not applicable

SYSTem:FPReset

(Write-only) Deletes all traces, measurements, and windows. The screen goes blank. This command is used in the factory during instrument programming.
Examples | SYST:FPR system:fpreset
Overlapped? | No
Default | Not applicable


Trigger SCPI

Trigger Commands

Starts or ends a measurement sequence. These commands are an important part of synchronizing measurements.

  • Click on a blue keyword to view the command details.

  • See a List of all commands in this block.

  • Learn about Triggering

TRIGger[:SEQuence]:DELay <num>

(Read-Write) Sets and reads the trigger delay. This delay is only applied while in External Trigger mode. After an external trigger is applied, the start of the sweep is delayed for the specified delay value plus any inherent latency.
Parameters |
<num> | Delay value in seconds. Range from 0 to 1 second.
Examples | TRIG:DEL 1e-3 trigger:sequence:delay .003
Query Syntax | TRIGger[:SEQuence]:DELay?
Return Type | Character
Overlapped? | No
Default | 0

TRIGger[:SEQuence]:LEVel <char>

(Read-Write) Triggers either on a High or Low level trigger signal. (There is currently no positive or negative edge triggering.) This setting only has an effect when TRIG:SOURce EXTernal is selected.
Parameters |
<char> | Choose from: HIGH - analyzer triggers on TTL High LOW - analyzer triggers on TTL Low
Examples | TRIG:LEV HIGH trigger:sequence:level low
Query Syntax | TRIGger[:SEQuence]:LEVel?
Return Type | Character
Overlapped? | No
Default | LOW

TRIGger[:SEQuence]:SCOPe <char>

(Read-Write) Specifies whether triggers are applied to all channels or the current channel.
Parameters |
<char> | Choose from: ALL - triggers all channels. Also sets SENS:SWEep:TRIG:POINt OFF on ALL channels. CURRent - trigger only one channel at a time. With each trigger signal, the channel is incremented to the next triggerable channel.
Examples | TRIG:SCOP ALL trigger:sequence:scope current
Query Syntax | TRIGger[:SEQuence]:SCOPe?
Return Type | Character
Overlapped? | No
Default | ALL

TRIGger[:SEQuence]:SOURce <char>

(Read-Write) Sets the source of the sweep trigger signal. This command is a super-set of INITiate:CONTinuous, which can NOT set the source to External.
Parameters |
<char> | Choose from: EXTernal - external (rear panel) source IMMediate - internal source sends continuous trigger signals MANual - sends one trigger signal when manually triggered from the front panel or INIT:IMM is sent.
Examples | TRIG:SOUR EXT trigger:sequence:source immediate
Query Syntax | TRIGger[:SEQuence]:SOURce?
Return Type | Character
Overlapped? | No
Default | IMMediate


53 Finder

Indicates the most common of the network analyzer commands that have been mapped to a corresponding command in PNA. Since the commands listed on this page are base commands, commands that are derived from these base commands may not have a corresponding command in PNA.

Indicates a command that has not been mapped to a corresponding command in PNA, but may be in future revisions. However, this does not always indicate that the required functionality does not exist in PNA. See the 8753 Programming Guide for a description of the command functionality.

Description of Symbol Conventions

Legend

AB

ADAP1

ADDR

ADPT

ALC

ALTAB

ANAB

ANAI

AR

ASEG

ASSS

ATT

AUTO

AUXC

AVER

BACI

BANDPASS

BEEP

BLAD

BR

CAL1

CALF

CALI

CALK

CALN

CALSPORT

CALZ

CBRI

CENT

CHAN

CHOPAB

CLAD

CLASS

CLEA

CLEAL

CLEABIT

CLEASEQ

CLEL

CLES

CLS

COAD

COAX

COLO

COLOR

CONS

CONT

CONV

COPY

CORI

CORR

COU

CSWI

CWFREQ

CWTIME

D1DIVI2

D2XUPCH

D4XUPCH

DATI

DCONV

DEBU

DECRLOOC

DEFC

DEFLPRINT

DEFLTCPIO

DEFS

DEL

DELA

DEMO

DFLT

DIRS

DISC

DISM

DISP

DIVI

DONE

DONM

DOSEQ

DOWN

DUAC

DUPLSEQ

ECALAB?

ECALCONT

ECALDONE

ECALERC

ECALFREQS

ECALFUL2

ECALISOAVG

ECALMANTHRU

ECALMODID

ECALMODINF

ECALMODSELA

ECALMODSELB

ECALNFREQS

ECALOMII

ECALPAUSED

ECALRERC

ECALS11

ECALS22

EDIT

ELED

EMIB

ENTO

ERCDONE

ESB?

ESE

ESNB

ESR?

EXTD

EXTM

EXTRCHAN

EXTT

FIXE

FORM

FORMAT

FREQ

FREQOFFS

FRER

FLUP

FWD

GATE

GATS

GOSUB

HARM

HOLD

IDN?

IF

IFBW

IMAG

INCRLOOC

INI

INPU

INSM

INT

INTE

ISO

KEY

KITD

KOR?

LAB

LABE

LEF

LIM

LIMI

LIMT

LINFREQ

LINM

LINT

LIS

LISTTYPE

LISV

LO

LOA

LOAD

LOADSEQ

LOGFREQ

LOGM

LOOC

LOWP

LRN

MANTRIG

MARK

MAXF

MEAS

MEASTAT

MENU

MINF

MINMAX

MINU

MODI1

MODS

NEWSEQ

NEXP

NOOP

NUMG

NUMR

OF

OFS

OMII

OPC

OPEP

OUTP

PARA

PARAL

PAUS

PCB

PCOL

PENN

PHAO

PHAS

PLOS

PLOT

PLT

PMTRTTIT

POIN

POL

PORE

PORT

PORTP

POWE

POWL

POWM

POWR

POWS

POWT

PRAN

PREP

PRES

PRI

PRIN

PRINTALL

PRN

PTOS

PURG

PWMC

PWRLOSS

PWRMCAL

PWRR

RAI

RAWOFFS

READ

REAL

RECA

RECO

REF

REFT

REIC

RERCDONE

RESC

RESD

RESPDONE

REST

RETP

REV

RF

RFLP

RIG

RSCO

RST

S

SADD

SAMC

SAV

SAVE

SAVEUSEK

SAVU

SCAL

SCAP

SDEL

SDON

SEA

SEDI

SEG

SEL

SELL

SEQ

SEQWAIT

SET

SHOM

SING

SLI

SLOP

SM8

SMI

SMOO

SOFR

SOFT

SOUP

SPAN

SPEC

SPEG

SPLD

SPLID

SRE

SSEG

STAN

STAR

STB?

STDD

STDT

STEPSWP

STOP

STOR

STORSEQ

STPSIZE

SVCO

SWE

SWPSTART

SWR

TAK

TAKE4

TALKLIST

TESS?

TIMDTRAN

TIMESTAM

TINT

TIT

TITT

TRA

TRACK

TRAP

TRL

TSSWI

TST?

TSTIO

TSTP

TTL

UCONV

UP

USEPASC

USESENS

VELOFACT

VIEM

VOFF

WAIT

WAVD

WAVE

WID

WIND

WRSK


53Banner

A

B

C

D

E

F

G

H

I

J

K

L

M

N

O

P

R

S

T

U

V

W

8753 Cross-Reference


53 Symbol Conventions

8753 Command Cross Reference

Symbol Conventions

Symbol

Description

<num>

Required numerical data.

<a1| a2>

An appendage that is part of the command. For example, FORMAT<DOS|LIF> indicates that the actual commands are FORMATDOS and FORMATLIF.

<$>

Indicates a character string operand which must be enclosed by double quotes.

|

An either/or choice in appendages or optional data.

[ ]

Optional data.

<LF>

Line feed.


A

AB

8753 Command

Description

Range

Query Response

AB

Measures and displays A/B on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Step 1 CALC:PAR:DEFINE

Create the measurement.

Step 2 DISP:WIND ON

If a new window will be used to display the measurement, then create a window.

Step 3 DISP:WIND:TRAC:FEED

Display the measurement in the window.

PNA COM Equivalent - Notes

CreateMeasurement Method

Create and display the measurement.

ADDR

8753 Command

Description

Range

Query Response

ADDRPOWM

Power Meter GPIB address

Integers 0-30

<num>><LF>

PNA SCPI Equivalent - Notes

SYST:COMM:GPIB:PMET:ADDR

Specifies the GPIB address of the power meter to be used in a source power calibration.

PNA COM Equivalent - Notes

PowerMeterGPIBAddress Property

Specifies the GPIB address of the power meter that will be referenced by the SourcePowerCalibrator object

ALTAB

8753 Command

Description

Range

Query Response

ALTAB

Places the analyzer in the alternate inputs measurement mode, where A and B measurements are made on alternate sweeps. See also "CHOPAB."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

SENS:COUP ALL

Sets sweeps to either alternate or chopped.

PNA COM Equivalent - Notes

AlternateSweep Property

Sets sweeps to either alternate or chopped.

ANAI

8753 Command

Description

Range

Query Response

ANAI

Measures and displays the data at the Auxiliary Input (Analog IN

Integers 1-31

<0|1>><LF

PNA SCPI Equivalent - Notes

CONT:AUX:INP

Reads the ADC input voltage from pin 14 of the AUX IO connector.

PNA COM Equivalent - Notes

get InputVoltage Method

Reads the ADC input voltage from pin 14 of the AUX IO connector.

AR

8753 Command

Description

Range

Query Response

AR

Measures and displays A/R on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Step 1 CALC:PAR:DEFINE

Create the measurement.

Step 2 DISP:WIND

If a new window will be used to display the measurement, then create a window.

Step 3 DISP:WIND:TRAC:FEED

Display the measurement in the window.

PNA COM Equivalent - Notes

CreateMeasurement Method

Create and display the measurement.

ASEG

8753 Command

Description

Range

Query Response

ASEG

Uses all segments for list frequency sweep. See also "SSEG".

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

SENS:SEGM

Turn on each segment to be used with list frequency sweep.

PNA COM Equivalent - Notes

LimitSegment Object

LimitSegment object.

ATT

8753 Command

Description

Range

Query Response

ATTP1><num>[DB]

Selects the amount of attenuation at PORT 1.

0–70 dB

<num><LF

ATTP2><num>[DB]

Selects the amount of attenuation at PORT 2.

0–70 dB

<num><LF

Note: These commands only apply to 8753ES Option 011 analyzers.

PNA SCPI Equivalent - Notes

Step 1 SOUR:POW:COUP

Set Port Power Coupling OFF.

Step 2 SOUR:POW:ATT

Set the attenuation level for the selected port.

PNA COM Equivalent - Notes

Step 1 Couple Ports Property

Set Port Power Coupling OFF.

Step 2 Attenuator Property

Set the attenuation level for the selected port.

AUTO

8753 Command

Description

Range

Query Response

AUTO

Auto scale the active channel.

N/A

N/A

PNA SCPI Equivalent - Notes

DISP:WIND:TRAC:Y:AUTO

Auto scale on the specified trace in the specified window.

PNA COM Equivalent - Notes

Autoscale Method

Auto scales the trace or all of the traces in the selected window.

AVER

8753 Command

Description

Range

Query Response

AVERREST

Restarts the averaging on the active channel.

N/A

N/A

AVERFACT<num>

Sets the averaging factor on the active channel.

integers 0–999

<num><LF

AVERO<ON|OFF>

Turns averaging on and off on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

SENS:AVER:CLE

Restart averaging.

SENS:AVER:COUN

Read-Write the averaging factor.

SENS:AVER

Read-Write averaging ON or OFF.

PNA COM Equivalent - Notes

Averaging Restart Method

Restart averaging.

Averaging Factor Property

Read-Write the averaging factor.

Averaging Property

Read-Write averaging ON or OFF.


B

BLAD

8753 Command

Description

Range

Query Response

BLAD<ON|OFF>

Blanks the display.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

DISP:ENAB

Blanks the display information in all windows.

DISP:WIND:ENABle

Blanks the display information in a specified window.

PNA COM Equivalent - Notes

Visible Property

Makes the Network Analyzer application visible or not visible.

BR

8753 Command

Description

Range

Query Response

BR

Measures and displays B/R on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1 CALC:PAR:DEF

Create the measurement.

Step 2 DISP:WIND

If a new window will be used to display the measurement, then create a window.

Step 3 DISP:WIND:TRAC:FEED

Display the measurement in the window.

PNA COM Equivalent - Notes

CreateMeasurementMethod

Create and display the measurement.


C

CALF

8753 Command

Description

Range

Query Response

CALFCALF

Sets the power meter sensor calibration factor.

0200%

<num><L F >

CALFSEN<A|B>

Edits a apecified power sensor calibration table

<N/A>

<N/A>

PNA SCPI Equivalent - Notes

SOUR:POW:CORR:COLL:TABL:DATA

(Read-Write) Read or write data into the selected table. If the selected table is a power sensor table, the data is interpreted as cal factors in units of percent. If the loss table is selected, the data is interpreted as loss in units of dB.

SOUR:POW:CORR:COLL:TABL

Selects which table (cal factor table for a power sensor, or the loss compensation table) you want to write to or read from.

PNA COM Equivalent - Notes

CalFactor Property

Sets or returns the cal factor value associated with a power sensor cal factor segment.

CalFactorSegments Collection

PowerLossSegments Collection

Access the appropriate table in either collection.

CALI

CALIERC

CALIRERC

CALIFUL2

CALIRAI

CALIRESP

CALIS111

CALIS221

CALITRL2

8753 Command

Description

Range

Query Response

CALIFUL2

Begins the sequence for a short, load, open, thru (SLOT) 2-port calibration.

N/A

<0|1><LF>

CALIRAI

Begins the sequence for a response and isolation calibration.

N/A

<0|1><LF>

CALIRESP

Begins the sequence for a response calibration.

N/A

<0|1><LF>

CALIS111

Begins the sequence for an S11 1-port calibration (ES models), or a reflection 1-port calibration (ET models).

N/A

<0|1><LF>

CALIS221

Begins the sequence for an S22 1-port calibration.

N/A

<0|1><LF>

CALITRL2

Begins the sequence for a thru, reflect, line or line, reflect, match (TRL*/LRM*) 2-port calibration.

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

SENS:CORR:COLL:CKIT

If a calibration kit is not selected, select a calibration kit.

SENS:CORR:COLL

Measure the specified standard from the selected calibration kit.

PNA COM Equivalent - Notes

CalKitType Property

If a calibration kit is not selected, select a calibration kit.

AcquireCalStandard2 Method

Measure the specified standard from the selected calibration kit.

8753 Command

Description

Range

Query Response

CALIERC

Begins the sequence for a forward enhanced response calibration.

N/A

<0|1><LF>

CALIRERC

Begins the sequence for a reverse enhanced response calibration.

N/A

<0|1><LF>

Notes

These commands currently are not available.

CALK

8753 Command

Description

Range

Query Response

CALK24MM

Selects a 2.4-mm calibration kit (85056A/D) as the default cal kit.

N/A

<0|1>><LF

CALK292MM

Selects a 2.92-mm calibration kit as the default cal kit.

N/A

<0|1>><LF

CALK292S

Selects a 2.92* calibration kit (85056K) as the default cal kit.

N/A

<0|1>><LF

CALK35MD

Selects a 3.5-mm calibration kit (85052B/D for 8720E series analyzers, and 85033D for 8753ET/ES analyzers) as the default cal kit.

N/A

<0|1>><LF

CALK35MC

Selects a 3.5-mm calibration kit (85033C) as the default cal kit. CALK35MM selects the 85033C cal kit for the 8752C and 8753D analyzers.

N/A

<0|1>><LF

CALK716

Selects a 7-16 calibration kit (85038) as the default cal kit.

N/A

<0|1>><LF

CALK7MM

Selects a 7-mm calibration kit (85050 series for 8720E series analyzers, and 85031B for 8753ET/ES analyzers) as the default cal kit.

N/A

<0|1>><LF

CALKN50

Selects a type-N 50 ohm calibration kit (85054 for 8720E series analyzers, and 85032B/E for 8753ET/ES analyzers) as the default cal kit.

N/A

<0|1>><LF

CALKN75

Selects a type-N 75 ohm calibration kit (85036B/E) as the default cal kit.

N/A

<0|1>><LF

CALKTRLK

Selects a TRL 3.5-mm calibration kit (85052C) as the default cal kit.

N/A

<0|1>><LF

CALKUSED

Selects a user-defined calibration kit.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

SENS:CORR:COLL:CKIT

Select the appropriate calibration kit. If the specific calibration kit is not listed, one can be created and stored in the User Defined section.

3 = CALKN50

4 = CALK35MD

5 = CALK716

6 = CALKTRLK

PNA COM Equivalent - Notes

CalKitType Property

Specifies the type of calibration kit to use in the calibration process.

CALN

8753 Command

Description

Range

Query Response

CALN

Turns calibration type to "off." See also "CORR."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

SENS:CORR:COLL:METH REFL1

Read-Write the calibration method. Set to "NONE" to turn calibration off.

PNA COM Equivalent - Notes

CalibrationType_Property

Specifies and returns the type of calibration to be applied to the measurement. Set to "NONE" to turn calibration off.

CENT

8753 Command

Description

Range

Query Response

CENT<num>[HZ|DB]

Sets the center stimulus value. If a list frequency segment is being edited, sets the center of the list segment.

For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ± 1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

SENS:FREQ:CENT

To set the center frequency value.

SENS:SEGM:FREQ:CENT

To set the center frequency value for a segment.

PNA COM Equivalent - Notes

CenterFreq_Property

Read-Write the center frequency of all measurements in a channel or for a specified sweep segment.

CHAN

8753 Command

Description

Range

Query Response

CHAN1

Makes channel 1 the active channel. OPC-compatible.

N/A

N/A

CHAN2

Makes channel 2 the active channel. OPC-compatible.

N/A

N/A

CHAN3

Makes channel 3 the active channel. OPC-compatible.

N/A

N/A

CHAN4

Makes channel 4 the active channel. OPC-compatible.

N/A

N/A

Notes

Unlike the 8753 network analyzer, the PNA Series Network Analyzers do not need a separate channel to display each parameter. While the PNA Series has four independent measurement channels, only one channel is needed to display all four measurement parameters. In addition, up to four windows are available to view four active and four memory traces per window.

CHOPAB

8753 Command

Description

Range

Query Response

CHOPAB

Places the analyzer in the chop measurement mode. See also "ALTAB."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

SENS:COUP ALL

Read-Write the sweep mode as Chopped or Alternate.

PNA COM Equivalent - Notes

Alternate_Sweep_Property

Read-Write the sweep mode as Chopped or Alternate.

CLASS

8753 Command

Description

Range

Query Response

CLASS11A

S11A: S11 (forward reflection) 1-port, open

N/A

N/A

CLASS11B

S11B: S11 (forward reflection) 1-port, short

N/A

N/A

CLASS11C

S11C: S11 (forward reflection) 1-port, load

N/A

N/A

CLASS22A

S22A: S22 (reverse reflection) 1-port, open

N/A

N/A

CLASS22B

S22B: S22 (reverse reflection) 1-port, short

N/A

N/A

CLASS22C

S22C: S22 (reverse reflection) 1-port, load

N/A

N/A

PNA SCPI Equivalent - Notes

SENS:CORR:COLL

Measure the specified standard from the selected calibration kit.

PNA COM Equivalent - Notes

AcquireCalStandard2_Method

Measure the specified standard from the selected calibration kit.

CLEAL

8753 Command

Description

Range

Query Response

CLEAL

Clears the limit line list. Should be preceded by EDITLIML.

N/A

N/A

PNA SCPI Equivalent - Notes

CALC:LIM:DATA

Limit lines always remain in memory. Use this SCPI command to set limit segment OFF or make a new limit line.

PNA COM Equivalent - Notes

Delete_Method

Delete the limit test collection.

CLEL

8753 Command

Description

Range

Query Response

CLEL

Clears the currently selected list. This could be a frequency list, power loss list, or limit test list. Must be preceded by an "EDIT" command.

N/A

N/A

PNA SCPI Equivalent - Notes

SENS:SEGM:DEL

Clear a single sweep segment.

SENS:SEGM:DEL:ALL

Clear all sweep segments.

PNA COM Equivalent - Notes

Remove_Method

Removes an item from a collection of objects.

CLES

8753 Command

Description

Range

Query Response

CLES

Clears the status byte register, the event-status registers, and the enable registers. Same as CLS.

N/A

N/A

PNA SCPI Equivalent - Notes

*CLS - Clear Status

Clears the instrument status byte by emptying the error queue and clearing all event registers.

PNA COM Equivalent - Notes

No equivalent command at present.

CLS

8753 Command

Description

Range

Query Response

CLS

Clears the status byte register, the event-status registers, and the enable registers. Same as CLES.

N/A

N/A

PNA SCPI Equivalent - Notes

*CLS - Clear Status

Clears the instrument status byte by emptying the error queue and clearing all event registers. Replace "CLS" with "*CLS".

PNA COM Equivalent - Notes

No equivalent command at present.

CONT

8753 Command

Description

Range

Query Response

CONT

Places the analyzer in continuous sweep trigger mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

INIT:CONT

Read-Write the sweep triggering mode.

PNA COM Equivalent - Notes

Continuous_Method

Read-Write the sweep triggering mode.

CORI

8753 Command

Description

Range

Query Response

CORI<ON|OFF>

Turns interpolative error correction on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

SENS:CORR:INT

Read-Write correction interpolation ON or OFF.

PNA COM Equivalent - Notes

No equivalent command at present.

CORR

8753 Command

Description

Range

Query Response

CORR<ON|OFF>

Turns error correction on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

SENS:CORR

Read-Write whether or not correction data is applied to the measurement.

PNA COM Equivalent - Notes

Error_Correction_Property

Sets (or returns) error correction ON or OFF

CWFREQ

8753 Command

Description

Range

Query Response

CWFREQ<num>[HZ|DB]

Sets the CW frequency for power sweep and CW frequency modes. While the list frequency table segment is being edited, it sets the center frequency of the current segment. See also "MARKCENT."

For frequency or power sweeps, refer to "Preset State and Memory Allocation," in the analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ±1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

SENS:FREQ

Read-Write the Continuous Wave (or Fixed) frequency.

PNA COM Equivalent - Notes

CW_Frequency_Property

CW Frequency property.

CWTIME

8753 Command

Description

Range

Query Response

CWTIME

Selects CW time as the sweep type.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

SENS:SWE:TYPE

Read-Write the type of analyzer sweep mode.

PNA COM Equivalent - Notes

Sweep_Type_Property

Sets the type of X-axis sweep that is performed on a channel.


D-E

DATI

8753 Command

Description

Range

Query Response

DATI

Stores the data trace in channel memory. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

CALC:MATH MEM

Write-only the currently selected measurement trace into memory.

PNA COM Equivalent - Notes

DataToMemory_Method

Stores the active measurement into memory.

DEL

8753 Command

Description

Range

Query Response

DELO

Turns delta marker mode off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:MARK:DELT

Read-Write whether marker is relative to the reference or not.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

DELR<num>

Makes the indicated marker the delta reference.

Integers 15

<0|1>><LF

DELRFIXM

Makes the fixed marker the delta reference.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Step 1 CALC:MARK:REF

If the reference marker is not turned ON, use this command to set the reference marker to ON.

Step 2 CALC:MARK:REF:X

Set the reference marker to the correct position.

Step 3 CALC:MARK:DELT

Turn marker delta mode ON for the marker that will report the delta value measured from the reference marker.

PNA COM Equivalent - Notes

No equivalent command at present.

DELA

8753 Command

Description

Range

Query Response

DELA

Displays the data formatted as group delay.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:FORM MLIN

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Format_Property

Sets (or returns) the display format of the measurement.

DISP

8753 Command

Description

Range

Query Response

DISPDATA

Data only.

N/A

<0|1>><LF

DISPDATM

Data and memory.

N/A

<0|1>><LF

DISPDDM

Data divided by memory (linear division, log subtraction). See also "DIVI."

N/A

<0|1>><LF

DISPDMM

Data minus memory (linear subtraction). See also "MINU."

N/A

<0|1>><LF

DISPMEMO

Memory only.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:MATH:FUNC

Read-Write math operations on the currently selected measurement and the trace stored in memory.

PNA COM Equivalent - Notes

Trace_Math_Property

Performs math operations on the measurement object and the trace stored in memory.

DIVI

8753 Command

Description

Range

Query Response

DIVI

Data divided by memory (linear division, log subtraction). See also "DISPDDM."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:MATH:FUNC

Read-Write math operations on the currently selected measurement and the trace stored in memory.

PNA COM Equivalent - Notes

Trace_Math_Property

Performs math operations on the measurement object and the trace stored in memory.

DONE

8753 Command

Description

Range

Query Response

DONE

Done with a class of standards, during a calibration. Only needed when multiple standards are measured to complete the class.

N/A

N/A

Notes

Since this action is performed automatically in PNA, this command is no longer necessary.

ECALAB?

8753 Command

Description

Range

Query Response

ECALAB

Queries the analyzer for the currently selected module

N/A

<0|1><LF

PNA SCPI Equivalent - Notes

No equivalent command at this time

PNA COM Equivalent - Notes

IsECALModuleFound Property

Tests communication between the PNA and the specified ECal module.

ECALDONE

8753 Command

Description

Range

Query Response

ECALDONE

Designed to be used in a polling loop to determine if the ECAL operation is finished.

N/A

N/A

PNA SCPI Equivalent - Notes

1. SENS:CORR:COLL:ACQ ECAL<A|B>

Measures the ECAL A module

2. *OPC?

Operation Complete query

PNA COM Equivalent - Notes

COM methods do not return until the cal is complete

ECALFUL2

8753 Command

Description

Range

Query Response

ECALFUL2

Performs an full 2-port ECAL

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

1. SENS:CORR:COLL:METH SPARSOLT

Sets the calibration method to SOLT

2. SENS:CORR:COLL:ACQ ECAL<A|B>

Measures the ECAL module

PNA COM Equivalent - Notes

DoECAL2Port Method

Does a 2-Port calibration using an ECAL module.

ECALISOAVG

8753 Command

Description

Range

Query Response

ECALISOAVG

Sets the number of averages in the ECAL isolation averages function

1-999

<num><LF>

PNA SCPI Equivalent - Notes

SENS:AVER:COUN

Sets the number of measurement sweeps to combine for an average.

PNA COM Equivalent - Notes

Averaging Factor Property

Specifies the number of measurement sweeps to combine for an average

ECALMODINF

8753 Command

Description

Range

Query Response

ECALMODINF

Returns string information on the selected ECAL module.

N/A

<array><LF>

PNA SCPI Equivalent - Notes

No equivalent command at this time

PNA COM Equivalent - Notes

Get ECAL Module Info Method

Returns the following information about the connected ECAL module: model number, serial number, connector type, calibration date, min and max frequency.

ECALOMII

8753 Command

Description

Range

Query Response

ECALOMII

Set omit isolation ON or OFF

N/A

<0|1><LF

PNA SCPI Equivalent - Notes

SENS:CORR:ISOL

Turns isolation cal ON or OFF during Full 2-port (or ECAL) calibration.

PNA COM Equivalent - Notes

ECALIsolation Property

Specifies whether the acquisition of the ECal calibration should include isolation or not.

ECALS11

8753 Command

Description

Range

Query Response

ECALS11

Performs a S11 ECAL

N/A

N/A

PNA SCPI Equivalent - Notes

1. SENS:CORR:COLL:METH REFL3

Sets the calibration method to 1-port

2. SENS:CORR:COLL:ACQ ECAL<A|B>

Measures the ECAL module

PNA COM Equivalent - Notes

DoECAL1Port Method

Does a 1-Port calibration using an ECAL module.

ECALS22

8753 Command

Description

Range

Query Response

ECALS22

Performs a S22 ECAL

N/A

N/A

PNA SCPI Equivalent - Notes

1. SENS:CORR:COLL:METH REFL3

Sets the calibration method to 1-port

2. SENS:CORR:COLL:ACQ ECAL<A|B>

Measures the ECAL module

PNA COM Equivalent - Notes

DoECAL1Port Method

Does a 1-Port calibration using an ECAL module.

EDIT

8753 Command

Description

Range

Query Response

EDITDONE

Done editing list frequency, limit table, cal sensor table, or power loss list.

N/A

N/A

EDITLIML

Begins editing limit table.

N/A

N/A

EDITLIST

Begins editing list frequency table.

N/A

N/A

Notes

Since these actions are performed automatically in PNA when working with a limit table, these commands are no longer necessary.

ELED

8753 Command

Description

Range

Query Response

ELED<num>[S]

Sets the electrical delay offset.

±10 seconds

<num><LF

PNA SCPI Equivalent - Notes

CALC1:CORR:EDEL:TIME

Read-Write the electrical delay for the selected measurement.

PNA COM Equivalent - Notes

Electrical_Delay_Property

Sets the Electrical Delay

ESE

8753 Command

Description

Range

Query Response

ESE<num>

Enables the selected event-status register bits to be summarized by bit 5 in the status byte. An event-status register bit is enabled when the corresponding bit in the operand <num> is set.

integers 0255

<num><LF

PNA SCPI Equivalent - Notes

*ESE

Sets bits in the standard event status enable register. Replace "ESE" with "*ESE".

PNA COM Equivalent - Notes

No equivalent command at present.

ESR?

8753 Command

Description

Range

Query Response

ESR?

Query only. Outputs event-status register.

N/A

<num><LF

PNA SCPI Equivalent - Notes

*ESR

Returns the results of the standard event enable register. The register is cleared after reading it. Replace "ESR?" with "*ESR?".

PNA COM Equivalent - Notes

No equivalent command at present.

EXTM

8753 Command

Description

Range

Query Response

EXTMDATA

Adds error corrected data (real and imaginary pairs) along with the other files.

N/A

<0|1>><LF

EXTMDATO

Selected data arrays only (real and imaginary pairs), without instrument states or calibrations. Always saves the data array, even if it hasnt been selected.

N/A

<0|1>><LF

EXTMFORM

Formatted trace data. Uses currently selected format for data.

N/A

<0|1>><LF

EXTMRAW

Raw data arrays (real and imaginary pairs).

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:DATA:CUST

Read-Write either measurement data or memory data.

PNA COM Equivalent - Notes

Get_Data_Method

Retrieves data.

8753 Command

Description

Range

Query Response

EXTMGRAP

User graphics.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

PrintToFile_Method

Saves the screen data to bitmap (.bmp) file of the screen.

EXTT

8753 Command

Description

Range

Query Response

EXTT

Activates or deactivates the external trigger mode. OPC-compatible.

N/A

<0|1>><LF

EXTTPOIN

Sets the external trigger to auto-trigger on point. OPC-compatible.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

TRIG:SOUR

Read-Write the source of the sweep trigger signal.

SENS:SWE:TRIG:POIN

Read-Write whether the specified channel will measure one point when triggered or all of the measurements in the channel.

PNA COM Equivalent - Notes

Trigger_Signal_Property

Sets or returns the trigger source.

Trigger_Mode_Property

Determines the measurement that occurs when a trigger signal is sent to the channel.

8753 Command

Description

Range

Query Response

EXTTHIGH

Sets the external trigger line high.

N/A

N/A

EXTTLOW

Sets the external trigger line low.

N/A

N/A

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

No equivalent command at present.


F-G-H

FORM

8753 Command

Description

Range

Query Response

FORM1

The analyzer's internal binary format, 6 bytes-per-data point. The array is preceded by a four-byte header. The first two bytes represent the string "#A", the standard block header. The second two bytes are an integer representing the number of bytes in the block to follow. FORM1 is best applied when rapid data transfers, not to be modified by the computer nor interpreted by the user, are required.

N/A

N/A

FORM2

IEEE 32-bit floating-point format, 4 bytes-per-number, 8 bytes-per-data point. The data is preceded by the same header as in FORM1. Each number consists of a 1-bit sign, an 8-bit biased exponent, and a 23-bit mantissa. FORM2 is the format of choice if your computer is not a PC, but supports single-precision floating-point numbers.

N/A

N/A

FORM3

IEEE 64-bit floating-point format, 8 bytes-per-number, 16 bytes-per-data point. The data is preceded by the same header as in FORM1. Each number consists of a 1-bit sign, an 11-bit biased exponent, and a 52-bit mantissa. This format may be used with double-precision floating-point numbers. No additional precision is available in the analyzer data, but FORM3 may be a convenient form for transferring data to your computer.

N/A

N/A

FORM4

ASCII floating-point format. The data is transmitted as ASCII numbers. There is no header. The analyzer always uses FORM4 to transfer data that is not related to array transfers (i.e. marker responses and instrument settings). Data is comma delimited.

N/A

N/A

FORM5

PC-DOS 32-bit floating-point format with 4 bytes-per-number, 8 bytes-per-data point. The data is preceded by the same header as in FORM1. The byte order is reversed with respect to FORM2 to comply with PC-DOS formats. If you are using a PC-based controller, FORM5 is the most effective format to use.

N/A

N/A

PNA SCPI Equivalent - Notes

FORM1, the 8753 analyzer's internal binary format, is not compatible with PNA.

format:data

For FORM2, FORM3, and FORM4, use this SCPI command.

Step 1 format:data

For FORM5, format the data to 32-bit with the SCPI command in Step 1. Then, swap the bits with the SCPI command in Step 2.

Step 2 format:border

PNA COM Equivalent - Notes

No equivalent command at present.

FRER

8753 Command

Description

Range

Query Response

FRER

Places the analyzer in GPIB free run mode. (Same as continuous sweep trigger mode.) See "CONT."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

initiate:continuous

Read-Write the sweep triggering mode.

PNA COM Equivalent - Notes

Continuous_Method

Read-Write the sweep triggering mode.

FWD

8753 Command

Description

Range

Query Response

FWDI

Selects the forward isolation calibration class during a 2-port calibration sequence.

N/A

N/A

PNA SCPI Equivalent - Notes

SENS:CORR:COLL

Measure the specified standard from the selected calibration kit. See "STAN5".

PNA COM Equivalent - Notes

AcquireCalStandard2_Method

Measure the specified standard from the selected calibration kit.

8753 Command

Description

Range

Query Response

FWDM

Selects the forward match calibration class during a 2-port calibration sequence.

N/A

N/A

FWDT

Selects the forward transmission calibration class during a 2-port calibration sequence.

N/A

N/A

Notes

Both the forward match and the forward transmission are measured automatically during a 2-port calibration on the PNA Series Network Analyzers.

HOLD

8753 Command

Description

Range

Query Response

HOLD

Puts the sweep trigger into hold mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

initiate:continuous

Read-Write the sweep triggering mode. Set the sweep trigger mode to "OFF".

PNA COM Equivalent - Notes

Hold_Method

Put the sweep trigger into hold mode.


I

IDN?

8753 Command

Description

Range

Query Response

IDN?

Query only. Outputs the identification string: AGILENT TECHNOLOGIES ,87NNEX,xxxxxxxxxx,X.XX where 87NNEX is the model number of the instrument, xxxxxxxxxx is the serial number of the instrument, and X.XX is the firmware revision of the instrument.

N/A

See command description.

PNA SCPI Equivalent - Notes

*IDN?

Returns a string that uniquely identifies the analyzer. Replace "IDN?" with "*IDN?".

PNA COM Equivalent - Notes

Application_Property

Returns the name of the Analyzer making measurements on the channel.

IF

8753 Command

Description

Range

Query Response

IFBIHIGH

IFBILOW

Tests the specified GPIO bit. If HIGH / LOW invokes the sequence which follows.

N/A

N/A

PNA SCPI Equivalent - Notes

CONT:AUX:PASS:LOG

Sets the logic of the PassFail line (pin 12) on the AUX IO connector. This line is connected internally to the PassFail line of the Material Handler IO (pin 33).

PNA COM Equivalent - Notes

PassFailLogic Property

Sets the logic of the PassFail line (pin 12) on the AUX IO connector. This line is connected internally to the PassFail line of the Material Handler IO (pin 33).

IFBW

8753 Command

Description

Range

Query Response

IFBW<num>[HZ]

Sets the IF bandwidth.

Choose from 10, 30, 100, 300, 1000, 3000, 3700, 6000

<num><LF

PNA SCPI Equivalent - Notes

SENS:BWID

Read-Write the bandwidth of the digital IF filter to be used in the measurement.

PNA COM Equivalent - Notes

IF_Bandwidth_Property

Sets or returns the IF Bandwidth of all measurements in a channel.

IMAG

8753 Command

Description

Range

Query Response

IMAG

Selects the imaginary display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:FORM

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Format_Property

Sets (or returns) the display format of the measurement.

INPU

INPUCALC

INPUCALK

INPUDATA

INPUFORM

INPULEAS

INPUPMCAL1

INPUPMCAL2

INPURAW1

INPURAW2

INPURAW3

INPURAW4

INPUCALC

8753 Command

Description

Range

Query Response

INPUCALC<num><array>

Inputs an error coefficient array <num>

N/A

N/A

PNA SCPI Equivalent - Notes

CALC:DATA:

Writes Measurement data, Memory data, or Error terms

PNA COM Equivalent - Notes

Put_Error_Term_Method

Puts variant error term data into the error-correction buffer.

Put_Error_Term_Complex_Method

Puts typed error term data into the error-correction buffer

8753 Command

Description

Range

Query Response

INPUDATA

Inputs an error corrected data array, using the current setting of the FORM command.

N/A

N/A

INPUFORM

Inputs a formatted data array, using the current setting of the FORM command.

N/A

N/A

INPURAW1

Inputs raw data array 1 (S11 data). After the data is received, the analyzer stops sweeping, error-corrects the data, then formats and displays the data.

N/A

N/A

INPURAW2

Inputs raw data array 2 (S21 data). After the data is received, the analyzer stops sweeping, error-corrects the data, then formats and displays the data.

N/A

N/A

INPURAW3

Inputs raw data array 3 (S12 data). After the data is received, the analyzer stops sweeping, error-corrects the data, then formats and displays the data.

N/A

N/A

INPURAW4

Inputs raw data array 4 (S22 data). After the data is received, the analyzer stops sweeping, error-corrects the data, then formats and displays the data.

N/A

N/A

PNA SCPI Equivalent - Notes

Step 1 CALC:DATA:

Input the data array.

Step 2 SENS:CORR

If the downloaded data array is error corrected, then error corrections need to be turned OFF. If not, an additional set of corrections will be applied to the downloaded data.

PNA COM Equivalent - Notes

Step 1aPut_Data_Complex_Method

Input raw data.

Step 1bPut_Data_Complex_Method

Input formatted data

Step 2 Put_Data_Complex_Method

If the downloaded data array is error corrected, then error corrections need to be turned OFF. If not, an additional set of corrections will be applied to the downloaded data.

INPUPMCAL

8753 Command

Description

Range

Query Response

INPUPMCAL<array>

Inputs an power meter calibration arrays for channels 1 and 2 in FORM4 only

N/A

N/A

PNA SCPI Equivalent - Notes

SOUR1:POW:CORR:DATA

Writes and reads source power calibration data

PNA COM Equivalent - Notes

putSourcePowerCalData Method

Inputs source power calibration data (as variant data type) to this channel for a specific source port.

putSourcePowerCalDataScalar

Inputs source power calibration data (as scalar values) to this channel for a specific source port.

The following commands are not currently available.

8753 Command

Description

Range

Query Response

INPUCALK<array>

Inputs a cal kit array in FORM1 only. Can be read out with the OUTCALK command. After the transfer, the data should be saved into the user cal kit area with the SAVEUSEK command.

N/A

N/A

INPULEAS<learnstring>

Inputs a learn string in FORM1 only. Can be read out with the OUTPLEAS command, or with INPULEAS?.

N/A

<data><LF >


L

LIM

8753 Command

Description

Range

Query Response

LIMS

Sets the limit stimulus break point.

Stimulus range.

Currently this command can be queried by sending the command by the OUTPACTI command.

PNA SCPI Equivalent - Notes

CALC:LIM:SEGM1:STIM:STAR

Read-Write the start (beginning) of the X-axis stimulus value.

CALC:LIM:SEGM1:AMPL:STOP

Read-Write the stop (end) of the X-axis stimulus value.

PNA COM Equivalent - Notes

Begin_Stimulus_Property

Specifies the beginning X-axis value of the Limit Line.

End_Stimulus_Value

Specifies the end X-axis value of the Limit Line.

8753 Command

Description

Range

Query Response

LIMD

Sets the limit delta value while editing a limit line segment.

Amplitude range.

Currently this command can be queried by sending the command by the OUTPACTI command.

LIML

Sets the lower limit value.

Amplitude range.

Same as above.

LIMM

Sets the middle limit value.

Amplitude range.

Same as above.

LIMU

Sets the upper limit value.

Amplitude range.

Same as above.

PNA SCPI Equivalent - Notes

CALC:LIM:DATA

Read-Write data for limit lines.

PNA COM Equivalent - Notes

LimitSegment_Object

Make a limit line object.

LIMI

LIMIAMPO

LIMILINE

LIMIMAOF

LIMISTIO

LIMITEST

8753 Command

Description

Range

Query Response

LIMILINE<ON|OFF>

Turns the display of the limit lines on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:LIM:DISP:STAT

Read-Write the display of limit lines ON or OFF.

PNA COM Equivalent - Notes

LineDisplay_Property

Turns the display of limit lines ON or OFF.

8753 Command

Description

Range

Query Response

LIMITEST<ON|OFF>

Turns limit testing on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:LIM:STAT

Read-Write limit line testing ON or OFF.

PNA COM Equivalent - Notes

State_Property

Turns an object ON and OFF.

8753 Command

Description

Range

Query Response

LIMIAMPO<num>[HZ|DB]

Enters the limit line amplitude offset.

Amplitude range.

<num>><LF

LIMIMAOF

Marker to limit offset. Centers the limit lines about the current marker position using the limit amplitude offset function.

N/A

N/A

LIMISTIO<num>[HZ|DB]

Enters the stimulus offset of the limit lines.

Stimulus range.

<num>><LF

Notes

These commands currently are not available.

LIMT

8753 Command

Description

Range

Query Response

LIMTFL

Makes the segment a flat line.

N/A

<0|1>><LF

LIMTSL

Makes the segment a sloping line.

N/A

<0|1>><LF

LIMTSP

Makes the segment a single point.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:LIM:DATA

Read-Write data for limit lines.

PNA COM Equivalent - Notes

LimitSegment_Object

Make a limit line object.

LINFREQ

8753 Command

Description

Range

Query Response

LINFREQ

Selects a linear frequency sweep.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

SENS:SWE:TYPE

Read-Write the type of analyzer sweep mode.

PNA COM Equivalent - Notes

Sweep_Type_Property

Sets the type of X-axis sweep that is performed on a channel.

LINM

8753 Command

Description

Range

Query Response

LINM

Selects the linear magnitude display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:FORM

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Format_Property

Sets (or returns) the display format of the measurement.

LIS

LISFREQ

LISIFBWM

LISPWRM

8753 Command

Description

Range

Query Response

LISFREQ

Selects the list frequency sweep mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

SENS:SWE:TYPE

Selects the sweep type.

PNA COM Equivalent - Notes

Sweep_Type_Property

Selects the sweep type.

8753 Command

Description

Range

Query Response

LISIFBWM<ON|OFF>

Enables/disables the IFBW setting for a list-frequency table in swept list mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

SENS:SEGM:BWID:CONT

Read-Write whether the IF Bandwidth resolution can be set independently for each segment.

SENS:SEGM:BWID

Read-Write the IFBandwidth for the specified segment.

PNA COM Equivalent - Notes

IF_Bandwidth_Option_Property

Enables the IFBandwidth to be set on individual sweep segments.

IF_Bandwidth_Property

Sets or returns the IF Bandwidth of the segment.

8753 Command

Description

Range

Query Response

LISPWRM<ON|OFF>

Enables/disables the power setting for a list-frequency table in swept list mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

SENS:SEGM:POW:CONT

Read-Write whether Power Level can be set independently for each segment.

SENS:SEGM:POW

Read-Write the Port Power level for the specified segment.

PNA COM Equivalent - Notes

Source_Power_Option_Property

Enables the source power to be set on individual sweep segments.

Test_Port_Power_Property

Sets or returns the RF power level of the segment.

LISTTYPE

8753 Command

Description

Range

Query Response

LISTTYPELSTP

Selects the stepped list mode for use with a list-frequency table.

N/A

<0|1><LF>

LISTTYPELSWP

Selects the swept list mode for use with a list-frequency table.

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

SENS:SWE:GEN

Read-Write sweep as Stepped or Analog.

PNA COM Equivalent - Notes

Sweep_Generation_Mode_Property

Sets the method used to generate a sweep: continuous ramp (analog) or discrete steps (stepped).

LOAD

8753 Command

Description

Range

Query Response

LOAD<num>

Loads the file from disk using the file name provided by the preceding TITF<num>; command. The actual file loaded depends on the file title in the file position specified by the TITF<num> command. Requires pass control mode when using the GPIB port.

integers 15

N/A

PNA SCPI Equivalent - Notes

MMEM:LOAD

Write-only to load the specified file.

PNA COM Equivalent - Notes

Recall_Method

Recalls a measurement state, calibration state, or both.

LOGM

8753 Command

Description

Range

Query Response

LOGM

Selects the log magnitude display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:FORM

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Format_Property

Sets (or returns) the display format of the measurement.


M

MANTRIG

8753 Command

Description

Range

Query Response

MANTRIG

Sets the trigger mode to manual trigger on point. OPC-compatible.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Step 1 TRIG:SOUR

Set the trigger source to manual.

Step 2 SENS:SWE:TRIG:POIN

Set the trigger mode to point.

PNA COM Equivalent - Notes

Step 1 Trigger_Signal_Property

Set the trigger source to manual.

Step 2 Trigger_Mode_Property

Set the trigger mode to point.

MARK

MARK<1|2|3|4|5> | MARKMAXI
MARKBUCK | MARKMIDD
MARKCENT | MARKMINI
MARKCONT | MARKOFF
MARKCOUP | MARKREF
MARKCW | MARKSPAN
MARKDELA | MARKSTAR
MARKDISC | MARKSTIM
MARKFAUV | MARKSTOP
MARKFSTI | MARKUNCO
MARKFVAL | MARKZERO

8753 Command

Description

Range

Query Response

MARK<1|2|3|4|5><num>

Makes the selected marker active and sets its stimulus value.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ±1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Step 1 CALC:MARK

Set the specified marker ON. Note: CALCulate commands act on the selected measurement. You must have a measurement defined and selected before a marker can be turned on. To define a measurement use CALCulate<cnum>:PARameter:DEFine <Mname>,<param>. Select the measurement for each channel using CALCulate<cnum>:PARameter:SELect <Mname>.

Step 2 CALC:MARK:X

Set the marker's X-axis value (frequency, power, or time).

PNA COM Equivalent - Notes

Stimulus_Property

Sets and reads the X-Axis value of the marker.

8753 Command

Description

Range

Query Response

MARKBUCK<num>

Places the active marker on a specific sweep point (bucket). <num> is the bucket number.

0 to (number-of-points - 1). For example, on a 201 point sweep, <num> can range from 0 to 200.

<num><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Bucket_Number_Property

Sets or returns the bucket number (data point) for the active marker.

8753 Command

Description

Range

Query Response

MARKCENT

Sets the center stimulus value to that of the active marker's stimulus value.

N/A

N/A

MARKSTAR

Sets the start stimulus to that of the active marker's.

N/A

N/A

MARKSTOP

Sets the stop stimulus to that of the active marker's.

N/A

N/A

MARKREF

Sets the reference value to that of the active marker's amplitude.

N/A

N/A

PNA SCPI Equivalent - Notes

CALC:MARK:SET

Read-Write the selected instrument setting to assume the value of the specified marker.

PNA COM Equivalent - Notes

Set_Center_Method

Changes the analyzer's center frequency to the X-axis position of the marker. The start frequency stays the same and the stop frequency adjusts.

Set_Start_Method

Changes the analyzer's start frequency to the X-axis position of the marker. The stop frequency stays the same and the frequency span adjusts.

Set_Stop_Method

Changes the analyzer's stop frequency to the X-axis position of the marker. The start frequency stays the same and the frequency span adjusts.

SetReferenceLevel_Method

Changes the measurement's reference level to the marker's Y-axis value.

8753 Command

Description

Range

Query Response

MARKDELA

Sets electrical length so group delay is zero at the active marker's stimulus.

N/A

N/A

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

SetElectricalDelay_Method

Changes the measurement's electrical delay value to the marker's delay value.

8753 Command

Description

Range

Query Response

MARKMAXI

Search for trace maximum on the current channel. Same as SEAMAX.

N/A

<0|1>><LF

MARKMINI

Search for trace minimum on the current channel. Same as SEAMIN.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Step 1 CALC:MARK

If a marker is not currently turned ON, set marker to ON with this command.

Step 2 CALC:MARK:FUNC:EXEC

Write-only to immediately execute (perform) the specified search function.

PNA COM Equivalent - Notes

Search_Max_Method

Searches the marker domain for the maximum value.

Search_Min_Method

Searches the marker domain for the minimum value.

8753 Command

Description

Range

Query Response

MARKCONT

Places the markers continuously on the trace, not on discrete points (interpolates the marker values between discrete points).

N/A

<0|1>><LF

MARKDISC

Places the markers on the discrete measurement points.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:MARK:DISC

Read-Write the specified marker as either interpolate data or not.

PNA COM Equivalent - Notes

Interpolate_Markers_Method

Turns All Marker Interpolation ON and OFF for the measurement.

8753 Command

Description

Range

Query Response

MARKOFF

Turns all markers and marker functions off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:MARK:AOFF

Write-only all markers off for selected measurement.

PNA COM Equivalent - Notes

DeleteAllMarkers_Method

Turn markers OFF by deleting all of the markers from the measurement.

8753 Command

Description

Range

Query Response

MARKCW

Sets the CW frequency to the active marker's frequency.

N/A

N/A

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Set_CW_Method

Changes the analyzer to sweep type CW mode and makes the CW frequency the marker's frequency.

8753 Command

Description

Range

Query Response

MARKFSTI<num>

Sets the stimulus position of the fixed marker.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ±1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

Step 1 CALC:MARK

If the marker is not turned ON, set the marker ON.

Step 2 CALC:MARK:TYPE

Set the marker type to "Fixed".

Step 3 CALC:MARK:X

Set the position of the marker.

PNA COM Equivalent - Notes

Step 1 Type_Marker_Property

Sets and reads the marker type.

Step 2 Stimulus_Property

Sets and reads the X-Axis value of the marker.

8753 Command

Description

Range

Query Response

MARKMIDD

Makes the marker amplitude the limit segment middle value during a limit segment edit.

N/A

N/A

MARKSPAN

Sets the span for the entire trace to that of the span between the active marker and the delta reference marker.

N/A

N/A

MARKSTIM

During a limit segment edit, sets the limit stimulus break point to that of the active marker's.

N/A

N/A

MARKZERO

Places the fixed marker at the active marker position and makes it the delta reference.

N/A

N/A

Notes

These functions require multiple SCPI or COM commands along with appropriate math calculations.

8753 Command

Description

Range

Query Response

MARKCOUP

Couples the markers between the channels, as opposed to MARKUNCO.

N/A

<0|1>><LF

MARKUNCO

Uncouples the markers between channels, as opposed to MARKCOUP.

N/A

<0|1>><LF

MARKFAUV

Sets the auxiliary value of the fixed marker position. Works in coordination with MARKFVAL and MARKFSTI.

Amplitude range. Same as MARKFVAL.

<num><LF

MARKFVAL

Sets the value of the fixed marker position.

Amplitude range. For log mag: ± 500 dB. For phase: ± 500 degrees. For Smith chart and Polar: ± 500 units. For linear magnitude: ± 500 units. For SWR: ± 500 units. The scale is always positive, and has minimum values of 0.001dB, 10e-12 degrees, 10e-15 seconds, and 10 picounits.

<num><LF

Notes

These commands are currently not supported.

MEAS

8753 Command

Description

Range

Query Response

MEASA

Measures and displays input A on the active channel.

N/A

<0|1>><LF

MEASB

Measures and displays input B on the active channel.

N/A

<0|1>><LF

MEASR

Measures and displays input R on the active channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Step 1 CALC:PAR:DEF

Create the measurement.

Step 2 DISP:WIND

If a new window will be used to display the measurement, then create a window.

Step 3 DISP:WIND:TRAC:FEED

Display the measurement in the window.

PNA COM Equivalent - Notes

CreateMeasurement_Method

Create and display the measurement.

MEASTAT

8753 Command

Description

Range

Query Response

MEASTAT<ON|OFF>

Turns trace statistics on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Show_Statistics_Property

Displays and hides the measurement statistics (peak-to-peak, mean, standard deviation) on the screen.

MINMAX

8753 Command

Description

Range

Query Response

MINMAX<ON|OFF>

Enables/disables min/max recording per segment. Min and max values are recorded per limit segment. Limit testing need not be active.

N/A

<0|1>><LF

Notes

This command is not available on PNA.

MINU

8753 Command

Description

Range

Query Response

MINU

Data minus memory (linear subtraction). See also "DISPDMM."

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:MATH:FUNC

Read-Write math operations on the currently selected measurement and the trace stored in memory.

PNA COM Equivalent - Notes

Trace_Math_Property

Performs math operations on the measurement object and the trace stored in memory.


N-O

NUMG

8753 Command

Description

Range

Query Response

NUMG<num>

Activates the indicated number of groups of sweeps. A group is whatever is needed to update the current parameter once. This function restarts averaging if it is enabled. OPC-compatible.

Integers 1999.

N/A

PNA SCPI Equivalent - Notes

Step 1 SENS:SWE:GRO:COUN

Set the number of groups.

Step 2 SENS:SWE:MODE

Set the trigger mode to groups.

PNA COM Equivalent - Notes

Number Of Groups Method

Sets the Number of trigger signals the channel will receive. After the channels has received that number of trigger signals, the channel switches to Hold mode.

NUMR

8753 Command

Description

Range

Query Response

NUMR

Sets the number of power meter readings per point in a power calibration

integers 1 to 100

<num><LF

PNA SCPI Equivalent - Notes

SOUR:POW:CORR:COLL:AVER

Specifies how many power readings are taken at each frequency point (averaging factor) during a source power cal acquisition sweep.

PNA COM Equivalent - Notes

ReadingsPerPoint Property

For purpose of averaging during source power cal, specifies how many power readings are taken at each frequency point (Averaging factor).

OMII

8753 Command

Description

Range

Query Response

OMII

Omits the isolation step of a calibration sequence.

N/A

N/A

PNA SCPI Equivalent - Notes

SENS:CORR:ISOL

Read-Write isolation cal ON or OFF during Full 2-port calibration.

PNA COM Equivalent - Notes

Acquire Cal Standard2 Method

To omit Isolation from a 2-port calibration, do not Acquire a cal standard for naSOLT_Isolation

OPC

8753 Command

Description

Range

Query Response

OPC

Operation complete. Reports the completion of the next command received by setting bit 0 in the event-status register, or by replying to an interrogation if OPC? is issued.

N/A

<0|1>><LF>

PNA SCPI Equivalent - Notes

*OPC

Operation complete command. Replace "OPC" with "*OPC".

*OPC?

Operation complete query. Replace "OPC?" with "*OPC?".

PNA COM Equivalent - Notes

No equivalent command at present.

OUTP

OUTPACTI | OUTPFAIP | OUTPMARK | OUTPRAF
OUTPAMAX | OUTPFORE | OUTPMEMF | OUTPRAW
OUTPAMIN | OUTPFORM | OUTPMEMO | OUTPRFFR
OUTPAPER | OUTPICAL | OUTPMSTA | OUTPSEGAF
OUTPCALC | OUTPIDEN | OUTPMWID | OUTPSEGAM
OUTPCALK | OUTPIPMCL | OUTPMWIL | OUTPSEGF
OUTPCHAN | OUTPKEY | OUTPOPTS | OUTPSEGM
OUTPDATA | OUTPLEAS | OUTPPLOT | OUTPSEQ
OUTPDATF | OUTPLIM | OUTPPMCAL | OUTPSERN
OUTPDATP | OUTPLIMF | OUTPPRE | OUTPSTAT
OUTPDATR | OUTPLIML | OUTPPRIN | OUTPTITL
OUTPERRO | OUTPLIMM | OUTPPRNALL |

8753 Command

Description

Range

Query Response

OUTPAPER

Outputs the smoothing aperture in stimulus units, rather than as a percentage.

N/A

<num><LF

PNA SCPI Equivalent - Notes

Step 1 CALC:SMO:APER

Output the smoothing aperture.

Step 2 SENS:FREQ:SPAN

Output the span.

Step 3

Multiply the smoothing aperture as a decimal number with the span to produce the smoothing aperture in stimulus units.

PNA COM Equivalent - Notes

Step 1 Smoothing Aperture Property

Output the smoothing aperture.

Step 2 Frequency Span Property

Output the span.

Step 3

Multiply the smoothing aperture as a decimal number with the span to produce the smoothing aperture in stimulus units.

8753 Command

Description

Range

Query Response

OUTPCALC

Outputs the selected error coefficient array for the active cal on the active channel.

Two-digit integers 0112

<array><LF

PNA SCPI Equivalent - Notes

CALC:DATA

Output the error coefficient array.

PNA COM Equivalent - Notes

GetErrorTerm Method

Retrieves error term data for the active calibration.

GetErrorTerm Complex Method

Retrieves error term data in complex pairs from the error correction buffer.

8753 Command

Description

Range

Query Response

OUTPCALK

Outputs the currently active calibration kit, as a string of less than 1000 bytes. The data is in FORM1.

N/A

<$><LF >

PNA SCPI Equivalent - Notes

SENS:CORR:COLL:CKIT:NAME

Read-Write a name for the selected calibration kit.

PNA COM Equivalent - Notes

Name CalKit Property

Sets and Returns a name for the selected calibration kit.

8753 Command

Description

Range

Query Response

OUTPDATA

Outputs the error-corrected data from the active channel in real/imaginary pairs.

N/A

<array><LF

PNA SCPI Equivalent - Notes

CALC:DATA

Output the error-corrected data array.

PNA COM Equivalent - Notes

GetNAComplex Method

Output the error-corrected data array.

8753 Command

Description

Range

Query Response

OUTPFORM

Outputs the formatted display data array from the active channel, in current display units.

N/A

<array><LF

PNA SCPI Equivalent - Notes

CALC:DATA

Output the data array.

PNA COM Equivalent - Notes

GetData Method

Output the data array.

8753 Command

Description

Range

Query Response

OUTPIDEN

Outputs the identification string for the analyzer in the form: AGILENT TECHNOLOGIES ,87NNEX,xxxxxxxxxx,X.XX where 87NNEX is the model number of the instrument, xxxxxxxxxx is the serial number of the instrument, and X.XX is the firmware revision of the instrument. (Same as the "IDN?" command.)

N/A

<$><LF >

PNA SCPI Equivalent - Notes

*IDN?

Returns a string that uniquely identifies the analyzer.

PNA COM Equivalent - Notes

Application Property

Returns the name of the Analyzer making measurements on the channel.

8753 Command

Description

Range

Query Response

OUTPIPMCL

Outputs the interpolated power meter calibration array for channel 1 or channel 2. Values are returned as 100 times the interpolated power meter reading in dB. This is an ASCII transfer (FORM4).

Integers 1 or 2.

<array><LF

PNA SCPI Equivalent - Notes

SOUR:POW:CORR:DATA

Writes and reads source power calibration data.

PNA COM Equivalent - Notes

get SourcePowerCalData Method

get SourcePowerCalDataScalar Method

Retrieves requested source power calibration data, if it exists, from this channel.

8753 Command

Description

Range

Query Response

OUTPLIM

Outputs the status of the limit test for the channel selected with <num>.

Integers 14

<0|1|-1><LF

PNA SCPI Equivalent - Notes

STAT:QUES:LIM1:COND?

Check status bit to determine status of the limit test.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPLIML

Outputs the limit test results for each point in the sweep. This is an ASCII transfer.

N/A

<array><LF

OUTPLIMM

Outputs the limit test results at the active marker.

N/A

<num,num,num,num><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Get Test Result Method

Returns the result of limit line testing.

8753 Command

Description

Range

Query Response

OUTPMARK

Outputs the active marker values. The first two numbers are the marker response values, and the last is the stimulus value.

N/A

<num,num,num><LF >

PNA SCPI Equivalent - Notes

CALC:MARK:X

Read-Write the marker's X-axis value (frequency, power, or time).

CALC:MARK:Y?

Read-only the marker's Y-axis value.

PNA COM Equivalent - Notes

Stimulus Property

Sets and reads the X-Axis value of the marker.

Value Property

Reads the Y-Axis value of the marker.

8753 Command

Description

Range

Query Response

OUTPMEMO

Outputs the memory trace from the active channel. The data is in real/imaginary pairs, and can be treated the same as data read with the OUTPDATA command.

N/A

<array><LF

PNA SCPI Equivalent - Notes

CALC:DATA

Read-Write either measurement data or memory data. When querying memory, you must first store a trace into memory using CALCuate<cnum>:MATH:MEMorize

PNA COM Equivalent - Notes

DataToMemory Method

If the data is not in memory, store data into memory.

GetData Method

Output memory data.

8753 Command

Description

Range

Query Response

OUTPMSTA

Outputs the marker statistics in ASCII format: mean, standard deviation, and peak-to-peak variation in that order. If statistics is not on, it is turned on to generate current values and turned off again.

N/A

<num,num,num><LF

PNA SCPI Equivalent - Notes

Step 1 CALC:FUNC:TYPE

Select the statistic TYPE that you can then query.

Step 2 CALC:FUNC:DATA?

Read the selected trace statistic.

PNA COM Equivalent - Notes

Get Trace Statistics Method

Returns the Trace Statistics.

8753 Command

Description

Range

Query Response

OUTPMWID

Outputs the marker bandwidths search results in ASCII format: bandwidth, center, and Q in that order. If widths is not on, it is turned on to generate current values and then turned off again.

N/A

<num,num,num><LF>

OUTPMWIL

Outputs the marker bandwidths search results in ASCII format: bandwidth, center, Q, and loss in that order. If widths is not on, it is turned on to generate current values and turned off again.

N/A

<num,num,num,num><LF>

PNA SCPI Equivalent - Notes

CALC:MARK:BWID

Use command to set and return filter statistics.

PNA COM Equivalent - Notes

Get Filter Statistics Method

Returns the Filter Statistics resulting from a SearchFilterBandwidth method.

8753 Command

Description

Range

Query Response

OUTPOPTS

Outputs an ASCII string of the options installed in the analyzer.

N/A

<$><LF

PNA SCPI Equivalent - Notes

*OPT?

Returns a string identifying the analyzer option configuration.

PNA COM Equivalent - Notes

Options Property

Returns a string identifying the analyzer option configuration.

8753 Command

Description

Range

Query Response

OUTPPRIN

Outputs a PCL raster dump of the display, intended for a graphics printer.

N/A

<$><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

DoPrint Method

Prints the screen to the active printer.

PrintToFile Method

Saves the screen data to a bitmap (.bmp) file.

8753 Command

Description

Range

Query Response

OUTPRAW

Outputs the selected raw data array.

Integers 14:  1=S11data
 2=S21 data
 3=S12 data
 4=S22 data

<array><LF

PNA SCPI Equivalent - Notes

CALC:DATA

Output the data array.

PNA COM Equivalent - Notes

GetData Method

Output the data array.

8753 Command

Description

Range

Query Response

OUTPSERN

Outputs a string that contains the serial number of the analyzer.

N/A

<$><LF

PNA SCPI Equivalent - Notes

*IDN?

Output the serial number.

PNA COM Equivalent - Notes

IDString Property

Returns the ID of the analyzer, including the Model number, Serial Number, and the Software revision number.

8753 Command

Description

Range

Query Response

OUTPSTAT

Returns the status byte as an ASCII integer (0255) that can be interpreted as the 8-bit status byte. This command is the same as "STB?."

N/A

<num><LF

PNA SCPI Equivalent - Notes

*STB?

Reads the value of the instrument status byte.

PNA COM Equivalent - Notes

No equivalent command at present.

8753 Command

Description

Range

Query Response

OUTPTITL

Outputs the display title in ASCII format.

N/A

<$><LF

PNA SCPI Equivalent - Notes

DISP:WIND:TITL:DATA

Read-Write data in the window title area.

PNA COM Equivalent - Notes

Title Property

Writes or reads a custom title for the window.

8753 Command

Description

Range

Query Response

OUTPDATF

Fast data transfer command for OUTPDATA.

N/A

<array><LF

OUTPFORE

Fast data transfer command for OUTPFORM.

N/A

<array><LF

OUTPMEMF

Fast data transfer command for OUTPMEMO.

N/A

<array><LF

OUTPRAF<num>

Fast data transfer of the selected raw data array.

Integers 14:  1=S11data
 2=S21 data
 3=S12 data
 4=S22 data

<array><LF

Notes

The PNA Series Network Analyzer outputs data at the fastest possible data rate at all times. Therefore, there are not any commands in the PNA Series that correspond to the above commands.

8753 Command

Description

Range

Query Response

OUTPACTI

Outputs the value of the active function, or the last active function if the active entry area is off. The value is returned in ASCII format.

N/A

<$><LF>

OUTPCHAN

Outputs the active channel number: 1, 2, 3, or 4.

N/A

<num><LF

OUTPDATP

Outputs the trace data indexed by point (see "SELPT").

N/A

<num,num><LF

OUTPDATR

Outputs the trace data for a range of points (see "SELMINPT," "SELMAXPT"). This is an ASCII (FORM4) transfer.

N/A

<array><LF

Notes

The PNA Series Network Analyzer has features to output data and state information much different than earlier network analyzers. Therefore, there are not any commands in the PNA Series that directly correspond to the above commands.

8753 Command

Description

Range

Query Response

OUTPAMAX

Outputs the max values for all limit line segments. This is an ASCII transfer (FORM4).

N/A

<array><LF

OUTPAMIN

Outputs the min values for all limit line segments. This is an ASCII transfer (FORM4).

N/A

<array><LF

OUTPLIMF

Outputs the limit test results for each failed point, followed by the number of failed points. This is an ASCII transfer.

N/A

<array><LF

OUTPSEGAF

Outputs the segment number and its limit test status for all active segments. This is an ASCII transfer.

N/A

<array><LF

OUTPSEGAM

Outputs the limit test min/max for all segments. Outputs the segment number, max stimulus, max value, min stimulus, min value for all active segments. This is an ASCII transfer.

N/A

<array><LF

OUTPSEGF

Outputs the limit test status for a specified segment. See also "SELSEG."

N/A

<0|1|-1><L F> Values returned for limit test status are: 0 (fail), 1 (pass), or -1 (no limit).

OUTPSEGM

Outputs limit test min/max for a specified segment. See also "SELSEG."

N/A

<num,num><LF

Notes

These limit and segment commands currently are not available.

8753 Command

Description

Range

Query Response

OUTPERRO

Outputs the oldest error message in the error queue. Sends the error number first, and then the error message itself, as an ASCII (FORM4) string no longer than 50 characters.

N/A

<num,$><LF

OUTPFAIP

This command is similar to OUTPLIMF except that it reports the number of failures first, followed by the stimulus and trace values for each failed point in the test. ASCII format.

N/A

<array><LF

OUTPICAL

Outputs the selected interpolated error coefficient array for the active cal on the active channel.

Two-digit integers 0112.

<array><LF

OUTPKEY

Outputs the key code of the last key pressed in ASCII format. An invalid key is reported with a 63, a knob turn with a -1. See programming manual for additional information.

N/A

<num><LF

OUTPLEAS

Outputs the learn string, which contains the entire front panel state, the limit table, and the list frequency table. It is always in binary format not intended for decoding.

N/A

<learnstring><LF

OUTPPLOT

Outputs the HP-GL plot string in ASCII format to the GPIB port. Can be directed to a plotter, or read into the computer.

N/A

<$><LF>

OUTPPMCAL

Outputs the power meter calibration array for channel 1 or channel 2. See programming manual for additional information.

Integers 1 or 2.

<array><LF

OUTPPRE

Outputs pre-raw data array <num>. See programming manual for additional information.

integers 14:  1=S11data
 2=S21 data
 3=S12 data
 4=S22 data

<array><LF

OUTPPRNALL

Outputs all of the list values or the current page of operating parameters in ASCII format. See programming manual for additional information.

N/A

Rows of data separated by a <LF>. Ends with <LF><LF>.

OUTPRFFR

Outputs the external source RF frequency. The instrument must be in external source mode, using either INSMEXSA or INSMEXSM.

N/A

<num><LF

OUTPSEQ

Outputs the specified sequence listing to the GPIB port.

Integers 16.

<$><LF>

Notes

These commands currently are not available.


P

PARA

8753 Command

Description

Range

Query Response

PARAOUT

Programs all GPIO output bits at once.

integers 0255

<num><LF

PNA SCPI Equivalent - Notes

CONTrol:AUXiliary:C:DATA

Reads and writes a 4-bit value to Port C on the Aux I/O connector.

PNA COM Equivalent - Notes

Put PortCData Method

Writes a 4-bit value to Port C on the Aux I/O connector (pins 22-25)

PHAO

8753 Command

Description

Range

Query Response

PHAO<num>

Sets the phase offset.

0360 degrees

<num><LF

PNA SCPI Equivalent - Notes

CALC:CORR:OFFS:PHAS

Read-Write the phase offset for the selected measurement.

PNA COM Equivalent - Notes

Phase Offset Property

Sets the Phase Offset.

PHAS

8753 Command

Description

Range

Query Response

PHAS

Selects the phase display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:FORM

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Format Property

Sets (or returns) the display format of the measurement.

POIN

8753 Command

Description

Range

Query Response

POIN<num>

Sets the number of points in the sweep, or in a sweep segment.

Choose from: 3, 11, 21, 26, 51, 101, 201, 401, 801, 1601

<num><LF

PNA SCPI Equivalent - Notes

SENS:SWE:POIN

Read-Write the number of data points for the measurement. (2 - 16001)

PNA COM Equivalent - Notes

Number of Points Property

Sets or returns the Number of Points. (2 - 16001)

POL

8753 Command

Description

Range

Query Response

POLA

Selects the polar display format.

N/A

<0|1>><LF

POLMLIN

Selects linear as the marker readout format for polar display.

N/A

<0|1>><LF

POLMLOG

Selects log as the marker readout format for polar display.

N/A

<0|1>><LF

POLMRI

Selects real/imaginary as the marker readout format for polar display.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:FORM

Selects the polar display format.

CALC:MARK

Use this command to turn on a marker.

CALC:MARK:FORM

Selects the appropriate marker readout format.

PNA COM Equivalent - Notes

Format Property

Selects the polar display format.

Marker Format Property

Selects the appropriate marker readout format.

PORE

8753 Command

Description

Range

Query Response

PORE<ON|OFF>

Turns port extensions on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

SENS:CORR:EXT

Read-Write port extensions ON or OFF.

PNA COM Equivalent - Notes

State Property

Turns port extensions ON or OFF.

PORT

8753 Command

Description

Range

Query Response

PORT1<num>[S]

Set the port extension length for Port 1

±10 seconds

<0|1>><LF

PORT2<num>[S]

Set the port extension length for Port 2

±10 seconds

<0|1>><LF

PORTA<num>[S]

Set the port extension length for Input A

±10 seconds

<0|1>><LF

PORTB<num>[S]

Set the port extension length for Input B

±10 seconds

<0|1>><LF

PNA SCPI Equivalent - Notes

SENS:CORR:EXT:PORT

Read-Write the extension value at the specified port.

SENS:CORR:EXT:REC

Read-Write the extension value at the specified receiver.

PNA COM Equivalent - Notes

Port1 Property

Sets the port extension value for Port 1.

Port2 Property

Sets the port extension value for Port 2.

InputA Property

Sets the port extension value for Receiver A.

InputB Property

Sets the port extension value for Receiver B.

PORTP

8753 Command

Description

Range

Query Response

PORTP<CPLD|UNCPLD>

Selects either coupled or uncoupled for the port powers of a given channel.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

SOUR:POW:COUP

Read-Write Port Power Coupling ON or OFF.

PNA COM Equivalent - Notes

CouplePorts Property

Turns ON and OFF source power coupling.

POWE

8753 Command

Description

Range

Query Response

POWE<num>[DB]

Sets the output power level.

output power range of your analyzer. The output power range of your analyzer depends upon the model and installed options. Refer to your analyzers users guide to determine the power range of your analyzer.

<num><LF

PNA SCPI Equivalent - Notes

SOUR:POW

Read-Write the RF power output level.

PNA COM Equivalent - Notes

Test Port Power Property

Read-Write the RF power output level.

POWL

8753 Command

Description

Range

Query Response

POWLFREQ

Selects the frequency for which a power loss correction is entered. This must be followed by a POWLLOSS<num>; command,which sets the value.

stimulus range

<num><L F >

POWLLOSS

Sets the loss value for a particular frequency, set by POWLFREQ, in the power loss list.

-9900 to 9900 dB

<num><L F >

PNA SCPI Equivalent - Notes

SOUR:POW:CORR:COLL:TABL:FREQ

(Read-Write) Read or write frequency values for the selected table (cal factor table for a power sensor, or the loss compensation table).

SOUR:POW:CORR:COLL:TABL:DATA

(Read-Write) Read or write data into the selected table. If the selected table is a power sensor table, the data is interpreted as cal factors in units of percent. If the loss table is selected, the data is interpreted as loss in units of dB.

PNA COM Equivalent - Notes

Frequency Property

Sets or returns the frequency associated with a PowerLossSegment.

CalFactor Property

Sets or returns the cal factor value associated with a power sensor cal factor segment.

POWR

8753 Command

Description

Range

Query Response

POWR<num>

Sets the source power range. See also "PRAN."

Use two-digit integers 0007.

N/A

PNA SCPI Equivalent - Notes

SOUR:POW:ATT

Setting the attenuation is equivalent to setting the source power range.

PNA COM Equivalent - Notes

Attenuator Property

Setting the attenuation is equivalent to setting the source power range.

POWS

8753 Command

Description

Range

Query Response

POWS

Selects power sweep from the sweep type menu.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

SENS:SWE:TYPE

Read-Write the type of analyzer sweep mode.

PNA COM Equivalent - Notes

Sweep Type Property

Sets the type of X-axis sweep that is performed on a channel.

POWT

8753 Command

Description

Range

Query Response

POWT<ON|OFF>

Sets source power on or off. Works the opposite of the SOUP command. Sending POWTON turns source power off. Sending POWTOFF turns source power on.

N/A

<0|1>><LF>

PNA SCPI Equivalent - Notes

OUTP

Turns ON and OFF Source Power.

PNA COM Equivalent - Notes

Source Power State Property

Turns ON and OFF Source Power.

PRAN

8753 Command

Description

Range

Query Response

PRAN<num>

Sets the source power range. See also "POWR."

integers 07.

N/A

PNA SCPI Equivalent - Notes

SOUR:POW:ATT

Setting the attenuation is equivalent to setting the source power range.

PNA COM Equivalent - Notes

Attenuator Property

Setting the attenuation is equivalent to setting the source power range.

PRES

8753 Command

Description

Range

Query Response

PRES

Presets the analyzer to the factory preset state. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

SYST:PRES

Preset.

PNA COM Equivalent - Notes

Preset Method

Preset

PRIN

8753 Command

Description

Range

Query Response

PRINALL

Copies the display, in raster graphics mode, to a printer. Requires pass control when using the GPIB port. (Use PRINTALL to send ASCII data to the printer.)

N/A

N/A

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

Do Print Method

Prints the screen to the active printer.

PrintToFile Method

Saves the screen data to a bitmap (.bmp) file.

PWMC

8753 Command

Description

Range

Query Response

PWMCONES

Power Meter Cal done on one sweep. A calibration sweep should be taken. a calibration sweep should be taken (TAK) to ensure a valid power calibration.

-100dB to 100dB

<0|1>><LF>

PNA SCPI Equivalent - Notes

Selects the source power calibration method.

PNA COM Equivalent - Notes

PWRR

8753 Command

Description

Range

Query Response

PWRR<PMAN|PAUTO>

Selects whether the power range is in auto or manual mode.

N/A

<0|1>><LF 0 = manual mode; 1 = auto mode

PNA SCPI Equivalent - Notes

SOUR:POW:ATT:AUTO

Read-Write automatic attenuation control ON or OFF. Setting the automatic attenuation control is equivalent to setting the source power range mode.

PNA COM Equivalent - Notes

Attenuator Mode Property

Sets or returns the mode of operation of the attenuator control. Setting the automatic attenuation control is equivalent to setting the source power range mode.

PWRLOSS

8753 Command

Description

Range

Query Response

PWRLOSS

Selects whether or not to use the power loss table for a power meter calibration

N/A

<0|1>><LF>

PNA SCPI Equivalent - Notes

SOUR:POW:CORR:COLL:TABL:LOSS

(Read-Write) Indicates whether or not to adjust the power readings using the values in the loss table during a source power cal sweep.

PNA COM Equivalent - Notes

UsePowerLossSegments Property

Specifies if subsequent calls to the AcquirePowerReadings method will make use of the loss table (PowerLossSegments).


R

RAI

8753 Command

Description

Range

Query Response

RAID

Completes the response and isolation cal sequence. OPC-compatible.

N/A

N/A

RAIISOL

Calls the isolation class for the response and isolation calibration.

N/A

N/A

RAIRESP

Calls the response class for the response and isolation calibration.

N/A

N/A

PNA SCPI Equivalent - Notes

SENS:CORR:COLL:SAVE

Write-only to calculate the correction data using the selected :METHod and turn error correction ON.

SENS:CORR:COLL

Write-only to measure the specified standard from the selected calibration kit.

SENS:CORR:COLL:METH

Read-Write the calibration method.

PNA COM Equivalent - Notes

Calculate Error Coefficients Method

Calculates the correction data using the selected Cal Type and turns error correction ON.

AcquireCalStandard2 Method

Measures the specified standard from the selected calibration kit.

SetCalInfo Method

Specifies the type of calibration to perform.

REAL

8753 Command

Description

Range

Query Response

REAL

Sets the display format to real.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:FORM

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Format Property

Sets (or returns) the display format of the measurement.

REF

8753 Command

Description

Range

Query Response

REFP<num>

Enters the reference position. 0 is the bottom, 10 is the top of the graticule.

Integers 0–10

<num><LF

REFV<num>

Enters the reference line value.

Amplitude range. For log mag: ± 500 dB. For phase: ± 500 degrees. For Smith chart and Polar: ± 500 units. For linear magnitude: ± 500 units. For SWR: ± 500 units. The scale is always positive, and has minimum values of 0.001dB, 10e-12 degrees, 10e-15 seconds, and 10 picounits.

<num><LF

PNA SCPI Equivalent - Notes

DISP:WIND:TRAC:Y:RPOS

Read-Write the Reference Position of the specified trace in the specified window.

DISP:WIND:TRAC:Y:RLEV

Read-Write the Y axis Reference Level of the specified trace in the specified window.

PNA COM Equivalent - Notes

Reference Position Property

Sets or returns the Reference Position of the active trace.

Reference Value Property

Sets or returns the value of the Y-axis Reference Level of the active trace.

REIC

8753 Command

Description

Range

Query Response

REIC

Sets the power level reference value for a power calibration

Amplitude Range

N/A

PNA SCPI Equivalent - Notes

CALC:CORR:OFFS

(Read-Write) Specifies the power level to which the selected (unratioed) measurement’s data is to be adjusted by a Receiver Power Calibration. This command applies only when the selected measurement is of unratioed power.

PNA COM Equivalent - Notes

LogMagnitudeOffset Property

Sets or returns the power offset value in dBm that the normalized unratioed power measurement data will be shifted by. The unratioed power measurement is effectively calibrated to the power level specified by the value of LogMagnitudeOffset as soon as the Normalization property is set to ON after the DataToDivisor method has been called.

RESPDONE

8753 Command

Description

Range

Query Response

RESPDONE

Completes the response calibration sequence. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

SENS:CORR:COLL:SAVE

Write-only to calculate the correction data.

PNA COM Equivalent - Notes

Calculate Error Coefficients Method

Calculates the correction data.

REST

8753 Command

Description

Range

Query Response

REST

Measurement restart.

N/A

N/A

PNA SCPI Equivalent - Notes

Step 1 ABOR

Abort the current sweep with the command in Step 1.

Step 2 INIT

Initiate a new sweep with the command in Step 2.

PNA COM Equivalent - Notes

No equivalent command at present.

REV

8753 Command

Description

Range

Query Response

REVI

Calls the reverse isolation calibration class during a full 2-port calibration.

N/A

N/A

REVM

Calls the reverse match calibration class during a full 2-port calibration.

N/A

N/A

REVT

Calls the reverse transmission calibration class during a full 2-port calibration.

N/A

N/A

PNA SCPI Equivalent - Notes

SENS:CORR:COLL:SAVE

Write-only to calculate the correction data using the selected :METHod and turn error correction ON.

SENS:CORR:COLL

Write-only to measure the specified standard from the selected calibration kit.

SENS:CORR:COLL:METH

Read-Write the calibration method.

PNA COM Equivalent - Notes

Calculate Error Coefficients Method

Calculates the correction data using the selected Cal Type and turns error correction ON.

AcquireCalStandard2 Method

Measures the specified standard from the selected calibration kit.

SetCalInfo Method

Specifies the type of calibration to perform.

RST

8753 Command

Description

Range

Query Response

RST

Presets the analyzer to the factory preset state. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

*RST

Executes a device reset and cancels any pending *OPC command or query. Replace "RST" with "*RST".

PNA COM Equivalent - Notes

Reset Method

Resets instrument. Clears all existing windows and measurements.


S

8753 Command

Description

Range

Query Response

S11

Forward reflection measurement.

N/A

<0|1>><LF

S12

Reverse transmission measurement.

N/A

<0|1>><LF

S21

Forward transmission measurement.

N/A

<0|1>><LF

S22

Reverse reflection measurement.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

Follow the steps below to create and display a measurement.

Step 1 CALC:PAR:DEF

Create the measurement.

Step 2 DISP:WIND

If a new window will be used to display the measurement, then create a window.

Step 3 DISP:WIND:TRAC:FEED

Display the measurement in the window.

PNA COM Equivalent - Notes

CreateMeasurement Method

Create and display the measurement.

SADD

8753 Command

Description

Range

Query Response

SADD

Adds a new segment to the table during a list-frequency, limit-table, cal sensor table, or power loss table edit.

N/A

N/A

PNA SCPI Equivalent - Notes

SENS:SEGM:ADD

Write-only to add a segment. A segment must be added prior to setting data in the segment.

PNA COM Equivalent - Notes

Add segments Method

Add a segment.

SCAL

8753 Command

Description

Range

Query Response

SCAL<num>

Sets the trace scale factor.

Amplitude range. For log mag: ± 500 dB. For phase: ± 500 degrees. For Smith chart and Polar: ± 500 units. For linear magnitude: ± 500 units. For SWR: ± 500 units. The scale is always positive, and has minimum values of 0.001dB, 10e-12 degrees, 10e-15 seconds, and 10 picounits.

<num><LF

PNA SCPI Equivalent - Notes

DISP:WIND:TRAC:Y:PDIV

Read-Write the Y axis Per Division value of the specified trace in the specified window.

PNA COM Equivalent - Notes

YScale Property

Sets or returns the Y-axis Per Division value of the active trace.

SDEL

8753 Command

Description

Range

Query Response

SDEL

Deletes the current segment while editing a list frequency, a limit table, or a power loss list.

N/A

N/A

PNA SCPI Equivalent - Notes

SENS:SEGM:DEL

Write-only to delete the specified segment number.

SENS:SEGM:DEL:ALL

Write-only to delete all segments.

CALC:LIM:DATA

Limit lines always remain in memory. Use this SCPI command to set limit segment OFF.

PNA COM Equivalent - Notes

Remove Method

Removes an item from a collection of objects.

SEA

SEAL

SEAMAX

SEAMIN

SEAOFF

SEAR

SEATARG

8753 Command

Description

Range

Query Response

SEAL

Search left for next occurrence of the target value.

N/A

N/A

SEAR

Search right for next occurrence of the target value.

N/A

N/A

PNA SCPI Equivalent - Notes

Step 1 CALC:MARK:TARG

Read-Write the target value for the specified marker when doing Target Searches.

Step 2 CALC:MARK:FUNC:EXEC

Write-only to immediately execute (perform) the specified search function.

PNA COM Equivalent - Notes

Step 1 TargetValue Property

Sets the target value for the marker when doing Target Searches.

Step 2a Search Target Left Method

Moving to the left of the marker position, searches the marker's domain for the target value.

Step 2b Search Target Right Method

Moving to the right of the marker position, searches the marker's domain for the target value.

8753 Command

Description

Range

Query Response

SEAMAX

Search for trace maximum on the current channel.

N/A

<0|1><LF>

SEAMIN

Search for trace minimum on the current channel.

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

CALC:MARK:FUNC:EXEC

Write-only to immediately execute (perform) the specified search function.

PNA COM Equivalent - Notes

Search Max Method

Searches the marker domain for the maximum value.

Search Min Method

Searches the marker domain for the minimum value.

8753 Command

Description

Range

Query Response

SEAOFF

Turns the marker search off.

N/A

<0|1><LF>

PNA SCPI Equivalent - Notes

CALC:MARK

Turn marker search off by turning OFF the marker.

PNA COM Equivalent - Notes

Delete Marker Method

Turn marker search off by turning OFF the marker.

8753 Command

Description

Range

Query Response

SEATARG<num>

Set the search target amplitude.

Amplitude range.

<num><LF>

PNA SCPI Equivalent - Notes

CALC:MARK:TARG

Sets the target value for the marker when doing Target Searches.

PNA COM Equivalent - Notes

TargetValue Property

Sets the target value for the marker when doing Target Searches.

SEDI

8753 Command

Description

Range

Query Response

SEDI<num>

During either a frequency, limit, or power loss table edit, selects segment <num> for editing.

State dependent. Range for frequency segment = 1 to 30; Range for limit test segment = 1 to 18; Range for power loss table segment = 1 to 12

<num><LF>

PNA SCPI Equivalent - Notes

PNA Network Analyzers allow one to directly edit a segment or limit line. To edit a segment or limit line, see the following commands:

Sense:Segment

Commands to edit a segment.

Calc:Limit

Commands to edit a limit line.

PNA COM Equivalent - Notes

PNA Network Analyzers allow one to directly edit a segment or limit line. See the appropriate methods and properties for segments and limit lines.

SEG

8753 Command

Description

Range

Query Response

SEGIFBW<num>

Sets the IFBW for the active segment of a list-frequency table in swept list mode.

Choose from 10, 30, 100, 300, 1000, 3000, 3700, 6000.

see "Note" below

SEGPOWER<num>

Sets the power for the active segment of a list-frequency table in swept list mode.

Output power range of your analyzer. The output power range is dependent upon the model and option configuration of your analyzer. Refer to your analyzers users guide to determine the output power range of your analyzer.

see "Note" below

Note: Currently these commands can be queried by sending the command followed by the OUTPACTI command.

PNA SCPI Equivalent - Notes

SENS:SEGM:BWID

Read-Write the IFBandwidth for the specified segment.

SENS:SEGM:POW

Read-Write the Port Power level for the specified segment.

PNA COM Equivalent - Notes

IF Bandwidth Property

Sets or returns the IF Bandwidth of all measurements in a channel.
OR
Sets or returns the IF Bandwidth of a specified sweep segment.

Test Port Power Property

Sets or returns the RF power level of all measurements in a channel
or
Sets or returns the RF power level of a specified sweep segment.

SING

8753 Command

Description

Range

Query Response

SING

Single sweep. OPC-compatible.

N/A

N/A

PNA SCPI Equivalent - Notes

INIT:CONT

If sweep is not is single sweep mode, put the analyzer in single sweep mode by setting continuous OFF.

INIT

Trigger one sweep.

PNA COM Equivalent - Notes

Single_Method

Single sweep.

SMI

8753 Command

Description

Range

Query Response

SMIC

Selects Smith chart display format.

N/A

<0|1>><LF

SMIMGB

Selects G+jB (conductance and susceptance) marker readout on a Smith chart.

N/A

<0|1>><LF

SMIMLIN

Selects linear magnitude marker readout on a Smith chart.

N/A

<0|1>><LF

SMIMLOG

Selects log magnitude marker readout on a Smith chart.

N/A

<0|1>><LF

SMIMRI

Selects real/imaginary pairs (resistance and reactance) marker readout on a Smith chart.

N/A

<0|1>><LF

SMIMRX

Selects R + jX marker readout on a Smith chart.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:FORM

Selects the Smith chart display format.

CALC:MARK

Use this command to turn on a marker.

CALC:MARK:FORM

Selects the appropriate marker readout format.

PNA COM Equivalent - Notes

Format Property

Selects the Smith chart display format.

Marker Format Property

Selects the appropriate marker readout format.

SMOO

8753 Command

Description

Range

Query Response

SMOOAPER<num>

Sets the smoothing aperture as a percent of the trace.

0.05 to 20%

<num><LF

SMOOO<ON|OFF>

Selects whether smoothing is on or off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:SMO:APER

Read-Write the amount of smoothing.

CALC:SMO

Read-Write data smoothing ON or OFF.

PNA COM Equivalent - Notes

Smoothing Aperture Property

Specifies or returns the amount of smoothing.

Smoothing Property

Turns data smoothing ON and OFF.

SOUP

8753 Command

Description

Range

Query Response

SOUP<ON|OFF>

Selects whether the source power is on or off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

OUTP

Read-Write RF power from the source ON or OFF.

PNA COM Equivalent - Notes

Source Power State Property

Turns source power ON and OFF.

SPAN

8753 Command

Description

Range

Query Response

SPAN<num>[HZ|DB]

Sets the stimulus span value. If a list frequency segment is being edited, sets the span of the list segment.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ± 1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

SENS:FREQ:SPAN

Read-Write the frequency span of the analyzer.

SENS:SEGM:FREQ:SPAN

Read-Write the frequency span for the specified segment.

PNA COM Equivalent - Notes

Frequency Span Property

Sets or returns the frequency span of all measurements in a channel
or
Sets or returns the frequency span of a specified sweep segment.

SRE

8753 Command

Description

Range

Query Response

SRE<num>

Service request enable. A bit set in <num> enables the corresponding bit in the status byte to generate an SRQ.

integers 0255

<num><LF

PNA SCPI Equivalent - Notes

*SRE

Enables bits in the service request register. Replace "SRE" with "*SRE".

PNA COM Equivalent - Notes

No equivalent command at present.

SSEG

8753 Command

Description

Range

Query Response

SSEG<num>

Selects the desired segment of the frequency list for a list frequency sweep. See also "ASEG".

Integers 130

<num><LF

PNA SCPI Equivalent - Notes

SENS:SEGM

Read-Write the specified segment ON or OFF.

SENS:SWE:TYPE

The segment will not be turned on until the sweep type is set to "SEGMent" sweep with this command.

PNA COM Equivalent - Notes

Segments Collection

Segment collection object.

STAR

8753 Command

Description

Range

Query Response

STAR<num>[HZ|DB]

Sets the start stimulus value. If a list frequency segment is being edited, sets the start of the list segment.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ± 1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

SENS:SWE:TYPE

Read-Write the start frequency of the analyzer.

SENS:SEGM:FREQ:STAR

Read-Write the start frequency for the specified segment.

PNA COM Equivalent - Notes

Start Frequency Property

Sets or returns the start frequency of all measurements in a channel
or
Sets or returns the start frequency of a specified sweep segment.

STB?

8753 Command

Description

Range

Query Response

STB?

Query only. Outputs the status byte in ASCII format (FORM4). Same as OUTPSTAT.

N/A

<num><LF

PNA SCPI Equivalent - Notes

*STB?

Enables bits in the service request register. Replace "STB?" with "*STB?".

PNA COM Equivalent - Notes

No equivalent command at present.

STOP

8753 Command

Description

Range

Query Response

STOP<num>[HZ|DB]

Sets the stop stimulus value. If a list frequency segment is being edited, sets the stop of the list segment.

Stimulus range. For frequency or power sweeps, refer to "Preset State and Memory Allocation," in your analyzers users guide. For CW time: 0 to 24 hours. For frequency sweep, transform on: ± 1/frequency step. For CW time sweep, transform on: ±1/time step.

<num><LF

PNA SCPI Equivalent - Notes

SENS:FREQ:STOP

To Read-Write the stop frequency of the analyzer.

SENS:SEGM:FREQ:STOP

To Read-Write the stop frequency for the specified segment.

PNA COM Equivalent - Notes

Stop Frequency Property

Sets or returns the stop frequency of all measurements in a channel
or
Sets or returns the stop frequency of a specified sweep segment.

STOR

8753 Command

Description

Range

Query Response

STOR<num>

Stores the current instrument state to disk using the file name provided by the preceding TITF<num> command.

Integers 15

N/A

PNA SCPI Equivalent - Notes

MMEM:STOR:STAT

Write-only to store the specified file.

PNA COM Equivalent - Notes

Save Method

Saves a measurement state, calibration state, or both.

SWE

8753 Command

Description

Range

Query Response

SWEA

Automatically selects the fastest sweep time based on the current analyzer settings for number of points, IF bandwidth, sweep mode, averaging condition and frequency span.

N/A

N/A

SWET<num>[S]

Sets the sweep time. (Setting SWET0 is equivalent to sending the SWEA command.)

086,400 s

<num><LF

PNA SCPI Equivalent - Notes

SENS:SWE:TIME:AUTO

Read-Write the automatic sweep time function ON or OFF.

SENS:SWE:TIME

Read-Write the time the analyzer takes to complete one sweep.

PNA COM Equivalent - Notes

Sweep Time Property

Sets the Sweep time of the analyzer. Setting sweep time to 0 will result in the fastest possible sweep time with the current settings.

SWR

8753 Command

Description

Range

Query Response

SWR

Selects the SWR display format.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:FORM

Read-Write the display format for the measurement.

PNA COM Equivalent - Notes

Format Property

Sets (or returns) the display format of the measurement.


T-Z

TALKLIST

8753 Command

Description

Range

Query Response

TALKLIST

Selects the talker listener mode.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

No equivalent command at present.

PNA COM Equivalent - Notes

GPIBMode Property

Selects the talker listener mode.

TAK

8753 Command

Description

Range

Query Response

TAKRS

Begins a receiver calibration sweep

N/A

N/A

PNA SCPI Equivalent - Notes

CALC:NORM:IMM

Stores the selected measurements data to that measurements divisor buffer for use by the Normalization data processing algorithm. This command is not compatible with ratioed measurements such as S-parameters. It is intended for receiver power calibration when the selected measurement is of an unratioed power type.

PNA COM Equivalent - Notes

DataToDivisor Method

Stores the measurements data to the measurements divisor buffer for use by the Normalization data processing algorithm. Normalization is currently supported only on measurements of unratioed power, for purpose of receiver power calibration.

TIT

8753 Command

Description

Range

Query Response

TITL<$>

Enters a new display title.

48 characters max

N/A

PNA SCPI Equivalent - Notes

DISP:WIND:TITL:DATA

Read-Write data in the window title area.

PNA COM Equivalent - Notes

Title Property

Writes or reads a custom title for the window.

8753 Command

Description

Range

Query Response

TITF

Titles the indicated file numbers.

<num>: 15 <$>: 10 char. max.

N/A

TITP

Titles the plot to disk file.

10 characters max

N/A

TITR

Titles the indicated internal register.

<num>: 15 <$>: 10 char. max.

N/A

TITREG

Titles save/recall registers 01 through 31. TITREG01 through TITREG05 are the same as TITR1 through TITR5.

<num>: 0131 <$>: 10 char. max.

N/A

TITSEQ

Selects the sequence to be titled.

<num>: 16 <$>: 10 char. max.

N/A

TITSQ

Provides access to the sequence title functions.

N/A

N/A

Notes

These commands currently are not available on PNA

TRACK

8753 Command

Description

Range

Query Response

TRACK<ON|OFF>

Turns marker search tracking on and off.

N/A

<0|1>><LF

PNA SCPI Equivalent - Notes

CALC:MARK:FUNC:TRAC

Read-Write tracking capability for the specified marker.

PNA COM Equivalent - Notes

Tracking Property

Turns marker search tracking on and off.

TRL

8753 Command

Description

Range

Query Response

TRLL1

Measures TRL Line/match for Port 1 during a TRL/LRM 2-port calibration.

N/A

N/A

TRLL2

Measures TRL Line/match for Port 2 during a TRL/LRM 2-port calibration.

N/A

N/A

TRLR1

Measures TRL S11 reflect during a TRL/LRM 2-port calibration.

N/A

N/A

TRLR2

Measures TRL S22 reflect during a TRL/LRM 2-port calibration.

N/A

N/A

TRLT

Measures TRL thru during a TRL/LRM 2-port calibration.

N/A

N/A

PNA SCPI Equivalent - Notes

SENS:CORR:COLL:METH

Read-Write the calibration method.

SENS:CORR:COLL

Write-only to measure the specified standard from the selected calibration kit.

PNA COM Equivalent - Notes

SetCalInfo_Method

Specifies the type of calibration to perform.

AcquireCalStandard2 Method

Measures the specified standard from the selected calibration kit.

TST?

8753 Command

Description

Range

Query Response

TST?

Query only. Causes a self test and returns a zero if the test is passed.

N/A

<num><LF>

PNA SCPI Equivalent - Notes

*TST?

Returns the result of a complete self-test. An ASCII 0 indicates no failures found.

PNA COM Equivalent - Notes

No equivalent command at present.

TSTP

8753 Command

Description

Range

Query Response

TSTP<P1|P2>

Selects test port 1 or 2 for non-S-parameter measurements.

N/A

N/A

PNA SCPI Equivalent - Notes

SENS:SWE:SRCP

Read-Write the source port when making non S-parameter measurements. Has no effect on S-parameter measurements.

PNA COM Equivalent - Notes

CreateMeasurement Method

Create and display the measurement. Method parameter allows one to select the specific port.

TTL

8753 Command

Description

Range

Query Response

TTLLPULS

TTL normally high, low pulse at end of

sweep.

N/A

<0|1><L F >

TTLHPULS

TTL normally low, high pulse at end of

sweep.

N/A

<0|1><L F >

PNA SCPI Equivalent - Notes

CONT:AUX:SWE

(Read-Write) Specifies the event that will cause the AUX IO Sweep End line (pin 11) to go to a low (false) state. The line will return to a high state after the appropriate calculations are complete. This line is connected internally to the Sweep End line of the Material Handler IO.

PNA COM Equivalent - Notes

SweepEndMode Property

(Read-Write) Specifies the event that will cause the AUX IO Sweep End line (pin 11) to go to a low (false) state. The line will return to a high state after the appropriate calculations are complete. This line is connected internally to the Sweep End line of the Material Handler IO.

USESENS

8753 Command

Description

Range

Query Response

USESENSA

USESENSB

Selects the power meter input being used for a power calibration

N/A

N/A

PNA SCPI Equivalent - Notes

SOUR:POW:CORR:COLL

Initiates a source power cal acquisition sweep using the power sensor attached to the specified channel (A or B) on the power meter.

PNA COM Equivalent - Notes

AcquirePowerReadings Method

Initiates a source power cal acquisition

VELOFACT

8753 Command

Description

Range

Query Response

VELOFACT<num>

Enters the velocity factor of the transmission medium.

0 to 10

<num><LF

PNA SCPI Equivalent - Notes

SENS:CORR:RVEL:COAX

Read-Write the velocity factor to be used with Electrical Delay and Port Extensions.

PNA COM Equivalent - Notes

Velocity Factor Property

Sets the velocity factor to be used with Electrical Delay and Port Extensions.

WAIT

8753 Command

Description

Range

Query Response

WAIT

Waits for a clean sweep when used with the OPC command.

N/A

N/A

PNA SCPI Equivalent - Notes

*WAI

Prohibits the instrument from executing any new commands until all pending overlapped commands have been completed.

PNA COM Equivalent - Notes

No equivalent command at present.

WID

8753 Command

Description

Range

Query Response

WIDT<ON|OFF>

Turns the bandwidth search on and off.

N/A

<0|1><LF

WIDV<num>

Enters the widths search parameter.

Amplitude range.

<num><LF

PNA SCPI Equivalent - Notes

Step 1 CALC:MARK:BWID

Turn ON bandwidth search. Also, can return statistics.

Step 2 CALC:MARK:FUNC:TRAC

Turn marker tracking ON.

Step 3 CALC:MARK:AOFF

Turn OFF bandwidth search. This is accomplished by turning all markers OFF. Markers can also be turned OFF one at a time with CALCulate<cnum>:MARKer<mkr>[:STATe] <ON|OFF>

PNA COM Equivalent - Notes

Step 1 Bandwidth Target Property

Enter the bandwidth target value.

Step 2 Search Filter Bandwidth Method

Turn ON bandwidth search.

Step 3 Tracking Property

Turn marker tracking ON.

Get Filter Statistics Method

The filter statistics can be returned with this method.

DeleteAllMarkers Method

Turn OFF bandwidth search. This is accomplished by turning all markers OFF. Markers can also be turned OFF one at a time with DeleteMarker method.