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Agilent N5411B Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411B Software Version 1.71 
Released Date: 23 May 2014 
File Name: SetupInfSATA6G01710000.exe 
Minimum Infiniium Oscilloscope Baseline Version:  

Window XP : 4.20.0000 (90000 and 90000X) 
Window 7 : 4.60.0005 (90000 and 90000X) 

Minimum JBERT-B Firmware Version: 6.80 
 
Additions: 
 

 Support for Serial ATA Interoperability Program Revision 1.5.0 Unified 
Test Document. 

 Support user configurable OOB sequence with/without D10.2 (Device) or 
ALIGN (Host). Please refer to Programmer’s Reference for more details 
(see Help > Remote Interface). 

 Support user configurable ISI Filter Leading Bit and Lagging Bit for 
Transmit Jitter test. Please refer to Programmer’s Reference for more 
details (see Help > Remote Interface). 

 InfiniiSim now includes new Normalize Gain option. 
 

Modifications: 
 

 Fixed the issue of missing SSC profile in PHY-03 Spread-Spectrum 
Modulation Frequency test and PHY-04 Spread-Spectrum Modulation 
Deviation test. 

 Fixed the issue of TSG-03 Differential Skew test. 

 Fixed the issue of signal clipping in TSG-04 AC Common Mode Voltage test. 

 Fixed the issue of TSG-13 Gen3 (6Gb/s) Transmitter Jitter used RJ test of 
invalid total jitter limit. 

 Fixed the issue of the progress window appear in the screenshot of the report. 

 Fixed the issue of unhandled error when running in MSO oscilloscope. 

 Remote Interface updated to version 2.50. 

 Fixed Connection tab "Suppress" checkbox. 

 When using BitifEye BIT2100 instrument for switch matrix, now requires 
minimum firmware version: 3.4-1.10. 

 

Note: 
 

 This will be the last version to support Infiniium Oscilloscope Baseline Version 
4.20. 
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Agilent N5411B Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 

 
 
Agilent N5411B Software Version 1.70 
Released Date: 13 December 2013 
Minimum Infiniium Oscilloscope Baseline Version:  

Window XP : 4.20.0000 (90000 and 90000X) 
Window 7 : 4.60.0005 (90000 and 90000X) 

Minimum JBERT-B Firmware Version: 6.80 
File Name: SetupInfSATA6G01700000.exe 
 
Additions: 
 

 Update tests to support UTD 1.5. 

 Update and add tests to support u interface.  

 Support for BIST mode automation by loading the JBERT sequence file 
and pattern file. 

 Support for pattern checking. Please refer to Programmer’s Reference for 
more details (see Help > Remote Interface). 

 Support for user configurable jitter test’s CDR setting under debug mode. 
Please refer to Programmer’s Reference for more details (see Help > 
Remote Interface). 

 Support for user configurable low pass filter’s bandwidth for OOB signal 
detector. Please refer to Programmer’s Reference for more details (see 
Help > Remote Interface). 

 Support for OOB Gap Detection Windows debug under debug mode. 
Please refer to Programmer’s Reference for more details (see Help > 
Remote Interface). 

 User can now suppress connection prompts from the user interface (see 
Connect tab). 

 If a project opens as Read-Only and there are no settings conflicts with the 
current version of the app, user may use File > Save Project (Settings-Only) 
As…  menu item to extract the configuration (and no results) from that project. 

 If user creates the folder: 
(Win7)       C:\ProgramData\ Agilent\Infiniium\Apps\<app_name>\app\scripts 
(WinXP)    C:\Documents and Settings\All Users\Application     

      Data\Agilent\Infiniium\Apps\<app_name>\app\scripts 
Then menu item File > Execute Script… becomes visible and enables user to 
pick a file to execute (e.g a.Python or Visual Basic script). Scripts in this 
folder may also be executed via the Automation tab or remote interface. 

 HTML reports include probe info. 
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Modifications: 
 

 Projects saved by previous versions of this application will open in read-
only mode. 

 Update the test limit for Spread-Spectrum Modulation DFDT to range of 
+/-1250ppm/us for both minimum and maximum measurement. 

 Update the OOB signal sequence for device DUT by adding the D10.2 
pattern in the sequence for COMWAKE response.  

 Update the SATA CIC embedding by using InfiniiSim. 

 Last location when saving/opening/exporting project/ files/etc. will be 
saved. 

 ARSL scripts supports for .txt file extension. 

 Last Test Date reported using international format. 

 Fixed launch on Win7 for non-admin user. 

 Fixed statistics display for items in the Referenced Values section. 

 Preserves line breaks for “User Comments” field in HTML Report. 

 Includes new Delay option in InfiniiSim. 

 New option to control jump behavior when user double-click a test name on 
the Select Tests tab. See View > Preferences > Report. 

 Remote Interface updated to version 2.40. 
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Agilent N5411B Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 

 
 
Agilent N5411B Software Version 1.65 
Released Date: 16 July 2013 
Minimum Infiniium Oscilloscope Baseline Version: 3.21 (90000 and 90000X) 
Minimum JBERT-B Firmware Version: 6.80 
File Name: SetupInfSATA6G01650000.exe 
 
Additions: 
 

 Support for MSOX Infiniium oscilloscope. 
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Agilent N5411B Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411B Software Version 1.64 
Released Date: 27 July 2012 
Minimum Infiniium Oscilloscope Baseline Version: 3.21 (90000 and 90000X) 
Minimum JBERT-B Firmware Version: 6.80 
File Name: SetupInfSATA6G01640000.exe 
 
Additions: 
 

 InfiniiSim feature is now available during the run for all PHY tests and TSG 
tests. InfiniiSim feature can be access through the main menu (see 
Tools > Infiniium > InfiniiSim).  
 

Modifications: 
 

 The COMRESET/COMINIT response detection window increased from 
10.0us to 20.0us. 

 Fixed the issue of slow measurement of OOB-2/3/4/5 OOB signal 
Burst/Gap Length test using Infiniium 3.50.0001. 

 Fixed the issue of wrong judgment for the COMWAKE response (non-
continuous ALIGN response from the device DUT).  
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Agilent N5411B Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411B Software Version 1.63 
Released Date: 17 April 2012 
Minimum Infiniium Oscilloscope Baseline Version: 3.21 (90000 and 90000X) 
Minimum JBERT-B Firmware Version: 6.80 
File Name: SetupInfSATA6G01630000.exe 
 
Additions: 
 

 Support latest baseline 3.21. 

 Additional test added for UTD 1.4.3. Please refer to the Table 1.63.1. 

 Project file of SATA application version 1.62 and below is treated as read-
only. 

 User may disable the use of SATA CIC via “Use SATA CIC” in Configure 
tab. Please refer to Programmer’s Reference for more details (see Help > 
Remote Interface). 

 User may select the frequency window for the TSG-16 Gen3 (6Gb/s) Tx 
AC Common Mode Voltage measurement via “FFT Frequency Window, 
Min” and “FFT Frequency Window, Max”. Please refer to Programmer’s 
Reference for more details (see Help > Remote Interface). 
 

Modifications: 
 

 Several tests changed to informative test for UTD 1.4.3. Please refer to 
the Table 1.63.1. 

 Change of the TSG-02 Rise/Fall Time test limit for UTD 1.4.3.  

 Change of the PHY-01: Unit Interval and PHY-02: Frequency Long-Term 
Stability default Sample Size from 100,000 to 200,000 UI to covers at least 
one SSC profile. 

 Change of the stimulus differential voltage output to 600mV for 
Compliance mode of non-OOB test. 

 Bandwidth Limit feature for acquisition setup is available for both 
Compliance and Debug Mode. To access the Bandwidth Limit feature see 
menu: Tools > Infiniium > Acquisition Setup.  

 Fixed ALIGN field detection issue for OOB COMWAKE test.  

 Remove the config “Memory Depth” for TSG-16 Gen3 (6Gb/s) Tx AC 
Common Mode Voltage measurement. 
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Before UTD 1.4.3 UTD 1.4.3 

Comments 
Test Name 

Test 
ID 

Test Name 
Test 
ID 

TSG-01[b] : Differential 
Output Voltage (Max) 

(Informative) 
20121 

TSG-01[b] : Differential 
Output Voltage (Max) 

(Informative) 
20121 

Change to Informative Test in all 
UTD 

TSG-02[a] : Rise Time 

20211 

TSG-02[a] : Rise Time 
(Informative) 

20231 

Change to Informative Test in 
UTD 1.4.3. 

20212 20232 

20213 20233 

20214 20234 

TSG-02[a] : Fall Time 

20221 

TSG-02[a] : Fall Time 
(Informative) 

20241 

Change to Informative Test in 
UTD 1.4.3 

20222 20242 

20223 20243 

20224 20244 

TSG-03[a] : Differential 
Skew, HFTP 

20311 TSG-03[a] : Differential 
Skew, HFTP (Informative) 

20331 Change to Informative Test in 
UTD 1.4.3 20312 20332 

TSG-13[a] : RJ before CIC, 
MFTP, Clock To Data, JTF 

Defined 
20311 

TSG-13[a] : RJ before CIC, 
MFTP, Clock To Data, JTF 

Defined (Informative) 
21312 

Change to Informative Test in 
UTD 1.4.3 

TSG-13[f] : TJ after CIC, 
HFTP, Clock To Data, JTF 

Defined (BER=1E-12) 
21511 

TSG-13[f] : TJ after CIC, 
HFTP, Clock To Data, JTF 

Defined (BER=1E-12) 
(Informative) 

21517 
Change to Informative Test in 

UTD 1.4.3 

TSG-13[g] : TJ after CIC, 
HFTP, Clock To Data, JTF 

Defined (BER=1E-6) 
21513 

TSG-13[g] : TJ after CIC, 
HFTP, Clock To Data, JTF 

Defined (BER=1E-6) 
(Informative) 

21517 
Change to Informative Test in 

UTD 1.4.3 

- - 
TSG-04 : AC Common 
Mode Voltage, HFTP  

20412 
New test added in UTD 1.4.3 for 

3.0Gb/s 

- - 
TSG-04 : AC Common 
Mode Voltage, MFTP  20423 

New test added in UTD 1.4.3 for 
6.0Gb/s 

- - 
TSG-04 : AC Common 
Mode Voltage, HFTP  

20424 
New test added in UTD 1.4.3 for 

6.0Gb/s 

Table 1.63.1 
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Agilent N5411B Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411B Software Version 1.62 
Released Date: 2 February 2012 
Minimum Infiniium Oscilloscope Baseline Version: 3.21 (90000 and 90000X) 
Minimum JBERT-B Firmware Version: 6.80 
File Name: SetupInfSATA6G01620000.exe 
 
Additions: 
 

 Support latest baseline 3.21. 

 Support for various Unified Test Document version. UTD 1.1, UTD 1.2, 
UTD 1.3, UTD 1.4, UTD 1.4.1, UTD 1.4.2, UTD 1.4.3. Please refer to each 
Unified Test Document for tests details. 

 Addition Transmit Jitter informative tests for SSOP, MFTP and LFTP test 
pattern. “Hide Informative Tests” check box to hide all the informative tests.  

 User-defined compliance limits feature for user to select, edit and create 
tests limit. This feature can be access through the main menu (see 
Tools > Compliance limits). 

 Bandwidth Limit feature for acquisition setup set the frequency limit to be 
used during a run for all PHY tests and TSG tests ONLY (Debug Mode 
only). To access the Bandwidth Limit feature see menu: Tools > 
Infiniium > Acquisition Setup.  

 Infiniium’s Precision Probe and Precision Cable feature configuration 
setup can be accessed through the main menu (see Tools > Infiniium > 
PrecisionProbe/PrecisionCable).  

 Remote interface help and PDF files can be accessed through the main 
menu (see Help > Remote Interface).  

 New ‘Automation’ tab enables you to create command scripts that modify 
settings and execute tests.  

 New user preference to set default project location (Menu: View > 
Preferences > Save/Load : Default Location). 

  
Modifications: 
 

 Change of the test display name according to UTD. 

 Change of the Rise/Fall Time test limit based on ECN053 for 6Gb/s 
Rise/Fall Time max limit from 68ps to 80ps. 

 Change of the Spread-Spectrum Modulation DFDT limit from +/- 1200pp 
to +/-1250ppm. 

 Change of the TSG-04 AC Common Mode Voltage measurement 
bandwidth to 200MHz to 4.5GHz for UTD 1.4.2. 
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 Change of the TSG-15 Minimum Differential Voltage Amplitude eye height 
measurement location at 0.50 UI from [0.45UI, 0.55UI]. 

 Change of the OOB-03 COMINIT/COMRESET and COMWAKE Transmit 
Burst Length limit to [103.5ns, 110.9ns] from [103.5ns, 109.9ns] for UTD 
1.4.1 and above. 

 Change of the OOB-05 COMWAKE Transmit Gap Length limit to [102.4ns, 
109.9ns] from [103.5ns, 109.9ns] for UTD 1.4.1 and above. 

 Fixed issue for the OOB trigger algorithm. 

 Fixed issue for the OOB Signal Detection Threshold of file is not found. 

 Fixed issue for the 6.0Gb/s Tx Differential Output Voltage (Minimum) error.  

 PrecisionProbe dialog screens now have tooltips and remote hints.  

 A calibration creation wizard is added to the PrecisionProbe dialog box.  

 Now supports Remote Interface version 2.00. For more information, see 
Agilent’s N5452A Remote Programming Toolkit 
(www.agilent.com/find/scope-apps).  

 Fixed app startup under Windows Standard User login. 
 

 

 
 

http://www.agilent.com/find/scope-apps
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Agilent N5411B Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411B Software Version 1.61 
Released Date: 30 September 2011 
Minimum Infiniium Oscilloscope Baseline Version: 3.10 (90000 and 90000X) 
Minimum JBERT-B Firmware Version: 6.80 
File Name: SetupInfSATA6G01610000.exe 
 
Additions: 
 

 Supports Win 7. 
 
Modifications: 
 

 No Modification 
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Agilent N5411B Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411B Software Version 1.60 
Released Date: 12 August 2011 
Minimum Infiniium Oscilloscope Baseline Version: 3.10 (90000 and 90000X) 
Minimum JBERT-B Firmware Version: 6.80 
File Name: SetupInfSATA6G01600000.exe 
 
Additions: 
 

 Supports latest baseline 3.10. 
 
Modifications: 
 

 Vdiff Test for Gen3i modified for ECN50. 

 Remote TestIDs Changes (see Remote User Changes Table below): 
1. TestID Merge: Auto substitution by app, this ensures backward 

interoperability: 
 20112, 20113, 20114 -> 20111 
 20122, 20123, 20124 -> 20121 

2. TestID Split:  
 Original 20115 

 20115 for Drive Tests only 

 20116 for Host Tests only 

 Fixed Gen3i TX AC Common Mode Voltage Test FFT 3G Conversion 
Factor to 25Ohm Common Mode Type Termination (FFTdBmV3G = 
FFTdBm3G + 43.9794), previously incorrectly referenced  to 50Ohm 
Termination 

 Fixed Gen1 & 2 Vdiff MAX Test(Informative Test) histogram hits issue. 
Each section of the test does not complete the required number of 
acquisition before proceeding to the next section. 
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Remote User Changes: 
 

Old TestIDs New TestIDs Action 

20112 20111 Merge to 20111 

20113 20111 Merge to 20111 

20114 20111 Merge to 20111 

20122 20121 Merge to 20121 

20123 20121 Merge to 20121 

20124 20121 Merge to 20121 

20115 20115 Split: For Drive Test 

20116 Split: For Host Test 
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Agilent N5411B Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411B Software Version 1.50 
Released Date: 11 Feb 2011 
Minimum Infiniium Oscilloscope Baseline Version: 3.03 (90000 and 90000X) 
Minimum JBERT-B Firmware Version: 6.80 
File Name: SetupInfSATA6G01500000.exe 
 
Additions: 
 

 Supports latest baseline 3.03. 

 Supports N4903B J-BERT as stimulus in addition to 81134A Pulse Pattern 
Generator. 

1. The calibration procedure for J-BERT does not require the use of 
attenuator. It might not work well if attenuators are added to the 
connections. 

 Adds Jitter measurement 1E-12 and 1E-6 for Gen1,2,3. 
  
Modifications: 
 

 Improved Calibration Routine GUI. 

 Improved GUI user model logics. SSC, ASR, BIST Mode Options now 
grouped under “Capabilities” Group. 

 Modified COMWAKE Response tests lower and upper boundary to 153UI 
and 167UI respectively according to ECN. 

 Remote Programming Variable Changes, notably  
1. [OptConnection] now provides 5 options “none”, “PPG_IP”, 

“PPG_Sicl”, “JBERT_IP”, “JBERT_Sicl”. 
2. [HostASR] provides “1.0” as checked option, and “0.0” as 

unchecked option. 
3. [BISTMode] provides “BIST-L” and “BIST-T” options (replaced older 

config variable [TPSource]) 

 Connection Diagram now includes JBERT’s instruction 

 Miscellaneous changes on the OOB tests verification due to 
accommodate changes in the baseline system. 

 Default 81134A and N4903B voltage to 600mV single channel setting on 
the pattern generator 

 Selecting debug mode in configure tab will not uncheck the selected tests 
in select test tab 

 Averaging is now disabled in Gen3i AC Common Mode Test Group 

 Host ASR enabled: COMWAKE min & max Response Test: Previously 
there is an issue of some hosts treating the COMINIT from the stimulus 
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instrument to be an unsolicited COMINIT sometimes with a certain 
probability, which results in an initial COMRESET reply from host instead. 
In this version, the app will now retry 10 times to re-fire the stimulus 
instrument (81134A or N4903B) to get an initial COMWAKE, whereby 
from the host’s perspective, is supposed to be an in reply to a solicited 
COMINIT from the stimulus instrument.     

 
Additional Note: 
 

 Please ensure the Infiniium Scope has at least 25Mpts installed for 
compliance test. The tests could still be run, however the tests may not 
run correctly.  
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Agilent N5411B Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411B Software Version 1.30 
Released Date: 20 Sep 2010 
Minimum Infiniium Oscilloscope Baseline Version: 2.51 (90000) and 
2.95(90000X)  
File Name: SetupInfSATA6G01300000.exe 
 
Additions: 
 

 Supports White/Pink noise selection for Jitter test. 

 Adds Jitter measurement selection at BER 1E12(default) and 
1E6(informative).  

 
Modifications: 
 

 Fixed Far End Retimed Connection Diagram loading too slow issue 

 Fixed missing Jitter Tests Periodic/Arbitrary selection in configure tab 

 Fixed missing MFTP test when Pulsegen Usage = “No” and SSC = “Yes” 

 Fixed AC Common Mode Test for Gen3 dbm to dbmV conversion factor to 
43.9794. => FFTdBmV6G = FFTdBm6G + 43.9794 

 Remote Test: Configured a default response for BIST-T/BIST-L dialog 
during “messagebox suppression” 

 Modified Jitter Test Gen3i Criteria, now consists of tests below: 
1. RJ Before CIC 
2. TJ Before CIC HFTP, using RJ  
3. TJ Before CIC LBP, using RJ 
4. TJ after CIC HFTP, using RJ 
5. TJ after CIC LBP, using RJ 
6. TJ 1E12 after CIC HFTP 
7. TJ 1E6 after CIC HFTP 
8. TJ 1E12 after CIC LBP 
9. TJ 1E6 after CIC LBP 
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Agilent N5411B Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411B Software Version 1.20 
Released Date: 22 January 2010 
Minimum Infiniium Oscilloscope Baseline Version: 5.71 (80000B), 2.10 
(90000 series)  
File Name: SetupInfSATA6G01200000.exe 
 
Additions: 
 

 Supports Baseline 2.10 for 90000 Series 

 Adds Jitter measurement selection at BER 1E12(default) and 
1E6(informative) 

 Jitter test reports additional DCD Jitter value(informative), this value does 
not affect overall Jitter results calculation. 

 Remote Interface Variable Changes: 
1. Added [JitterAtBER] 

 
Miscellaneous Notes: 
 

 This will be the last version to support the 80000 series oscilloscope. 
Following releases will only support 90000 series oscilloscope.  
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Agilent N5411B Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411B Software Version 1.11 
Released Date: 21 December 2009 
Minimum Infiniium Oscilloscope Baseline Version: 5.71 (80000B), 2.01 
(90000 series)  
File Name: SetupInfSATA6G01110000.exe 
 
Modifications: 
 

 Fixed OOB detection threshold test not able to run if non-debug mode 
calibration is selected issue. 
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Agilent N5411B Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411B Software Version 1.10 
Released Date: 23 November 2009 
Minimum Infiniium Oscilloscope Baseline Version: 5.71 (80000B), 2.01 
(90000 series)  
File Name: SetupInfSATA6G01100000.exe 
 
Additions: 
 

 Added Loopback mode for Gen3i 

 Added Debug capability for OOB Vthresh Test to downsweep from defined 
voltage level voltage to a threshold level that has 1st encountered rejected 
response. 

 Added Gen3i Minimum TX Differential Voltage 

 Support for baseline 5.71 (80000B) and 2.01(90000A) 
 
Modifications: 
 

 Replaced SATA_Gen3i.txt S parameter file for CIC with standardized 
SATA-IO s4p file. 

 Gen3i AC Common Mode Test: 
o Allow peak to peak measurement from -5350ppm to 350ppm at 

both 3Ghz and 6Ghz 

 Jitter Tests: 
o Baseline modified Jitter Algorithm to improve measurement 

accuracy 
o 90000A scopes increased target memory data length to 2.048Mpts 

using default arbitrary mode 
o Restructured jitter test configure options with enhanced 

descriptions 

 Thresholds Definitions: 
o Uses Hysteresis centered 0 +/- 10mV for all TSG tests except for 

rise/fall time related tests.  

 Gen3i Maximum TX Differential Voltage 
o Vertical markers measurement boundary redefined to +/- 2UI 

centered about the trigger.  

 Gen3i Minimum TX Differential Voltage 
o Explicitly show out measurement details: Eye Height = (Vtop_mean 

– 3 Vtop_stddev) – (Vbase_mean – 3 Vbase_stddev).  

 Remote Interface Variable Changes: 
o [Jitter_DataLength] moved to debug mode 
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o [Jitter_DataLength] and [Jitter_PatternMode] are only asserted 
when [OverrideJitterDefault] setting is “ENABLED”  in debug mode. 

o Added [DifferentialSkew_RetrialGlitch] 
o Redefinition and addition:  

 [VthreshDebugResponsetoInconsistent] 
 [VthreshDebugResponsetoInconsistentStartVdiff] 
 [VthreshDebugInconsistentToReject] 
 [VthreshDebugInconsistentToRejectStartVdiff]  

 OOB testing for Gap/Vthresh Response Verification Testgroup: increased 
Sampling rate to 10GSa/s to preserve better signal integrity prior to low 
passed filtering. This will also enhance OOB response detection precision. 
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Agilent N5411B Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411B Software Version 1.02 
Released Date: 24 April 2009 
Minimum Infiniium Oscilloscope Baseline Version: 5.60 (80000B), 1.40 
(90000 series)  
File Name: SetupInfSATA6G01020000.exe 
 
Modifications: 
 

 Fixed the conversion error in the AC Common Mode Test where the 
HTML Compliance report now uses the correct reporting unit of “dbmV” 
instead of “dbm”.  

 Modified the Max TX Vdiff test for Gen3i, to use acquisition averaging 
instead of histogram peak to peak (worst case amplitude).  

 Fixed the Jitter Gen3i specification interpretation issue, whereby the “Total 
Jitter(TJ)” is now extracted directly from the Jitter Results Panel.  
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Agilent N5411B Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411B Software Version 1.01 
Released Date: 16 March 2009 
Minimum Infiniium Oscilloscope Baseline Version: 5.60 (80000B), 1.40 
(90000 series)  
File Name: SetupInfSATA6G01010000.exe 
 
Modifications: 
 

 Fixed the Gen1im and Gen2im Jitter Tests loop bandwidth error.  
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Agilent N5411B Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411B Software Version 1.00 
Released Date: 9 Feb 2009 
Minimum Infiniium Oscilloscope Baseline Version: 5.60 (80000B), 1.40 
(90000 series)  
File Name: SetupInfSATA6G01000000.exe 
 
Additions: 
 

 Added Gen3i group of tests for BIST-T mode which include: 
o Channel Speed, FBaud & Unit Interval 
o Frequency Long Term Stability 
o TX Differential Voltage Test ( Maximum) 
o TX Rise/Fall Time 
o TX Skew 

 HFTP 
 MFTP 

o TX AC Common Mode Voltage 
o TJ & DJ at Connector, Clk-Data 

 RJ before CIC 
 TJ before CIC, HFTP 
 TJ before CIC, LBP 
 TJ after CIC, HFTP 
 TJ after CIC, LBP 

 Obsolete the DC Coupled Common Mode Voltage Test. 

 Matlab MCR Checking to force Matlab 7.5 only. 

 Added OOB Gap/Vthresh % Thresholds for manual adjustment in case the 
default threshold touches the low passed filter ripples. 

 
Modifications: 
 

 Amend the Vdiff Test: 
o Reporting Statistics Redundancy 
o 0.5 UI to 0.45-0.55 in Gen1 
o LBP waveform inaccurate timebase 

 Fixed OOB Low Pass Filter Smearing Issue on 2GSa/s sampling rate 
limitation by turning off the interpolation. 

 Expanded UTD required patterns on the Select Test tab:  
o Test pattern option were removed for these tests 

 To prompt message box only once for the same test pattern in the BIST-T 
mode. 
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 Changed x Interface Jitter Tests from “at connector” algorithm to “after 
CIC” algorithm. 

 Fixed x Interface Amplitude Imbalance timebase inaccurate problem. 

 Changed SSC Tests Sampling Rate from 10GSa/s to 20GSa/s. 

 Changed Rise/Fall Time to LFTP Test Pattern with 8UI on screen. 

 Added cancel button to abandon the calibration request on the calibration 
pop up dialog box. 

 Changed the Skew reporting variables to non-absolute values (“Tx+ Rising 
to Tx- Falling” & “Tx+ Falling to Tx- Rising”) for debugging purpose, 
however the final compliance result formula still remains the same as 
intended by SATA-IO:  

o Diff Skew = average( abs[ (mean (TX+ rising)) – (mean(TX- falling))] 
+  abs[ (mean(TX+falling)) – (mean(TX- rising))] ) 

 Changed SSC sampling rate for 90000A scopes to 40GSa/s and 80000B 
scopes to 20GSa/s. 

 Limited the SSC maximum memory depth to 10Mpts in 90000A scope to 
provide safety margin to match the baseline analysis memory limitation. 

 
Known Issues: 
 

 In some very rare cases of OOB Burst and Gap Width measurement, the 
desired COMINIT and COMWAKE bursts are not easily captured (the 
probability of capturing is low) by using automation due to OOB response 
inconsistencies. In such cases, the user should opt for manual testing or 
retry manually.  

 
Miscellaneous Notes: 
 

 Project files from the old N5411A SATAII application would not be able to 
be loaded into N5411B SATA6G application. The user should view the old 
project files in an Internet Browser or by using the previous N5411A 
application.  
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Agilent N5411A Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411A Software Version 2.60 
Released Date: 7 Nov 2008  
Minimum Infiniium Oscilloscope Baseline Version: 5.50 (80000 series), 1.30 
(90000 series)  
File Name: SetupInfSATAII0260.exe 
 
Additions: 
 

 Supports the Asynchronous Signal Recovery Host DUT Response in OOB 
COMRESET/COMINIT/COMWAKE Gap Detection Windows and Vthresh 
Tests 

 Added the Vthresh Debug mode that sweeps from upper boundary 
Vthresh = 210mV stimulus (expected to give consistent response) to a 
Vthresh level that gives the first Inconsistent Response from the DUT 

 In SATA_App_Remote_Prog_Ref.chm  
o Added Remote Interface variables:  

 VthreshDebugResponsetoInconsistent 
 HostASR 

o Removed Remote Interface variables: 
 DebugAmplitudeImbalance 

 
Modifications: 
 

 Changed the minimum baseline requirements to 5.50 (for 80000 Series) 
and 1.30 (for 90000 Series) 

 Added the SSC Optimization Memory Buffer for the last SSC Acquisition 
(if required) 

 Fixed the Advanced Communication Trigger not found error for the single 
ended signals which is approximately below 200Vpp during the setup for 
non-00B tests. 

 Added the Burst/Gap/Align tolerance as a workaround to OOB 
Gap/Vthresh Detection due to the Low Pass Filter smearing issue.  

 Split the Spread Spectrum Modulation Deviation into two tests: 
o Spread Spectrum Modulation Deviation (Max) 
o Spread Spectrum Modulation Deviation (Min) 

 Split the Amplitude Imbalance test into two tests: 
o TX Amplitude Imbalance HFTP 
o TX Amplitude Imbalance MFTP 

 Enhanced the 90000 Scope Calibration Acquisition to 100 Acquisitions 
Average for every calibration target pair.  
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 Fixed the 80000A Series scope calibration dialog box mismatch with the 
windows resolution of 640X480. 

 Fixed the issue of Vthresh Change Connection dialog box hidden behind 
the SATA application. 

 Enhanced the OOB Gap/Vthresh Detection comments field information in 
the HTML Report 

 Changed the Amplitude Imbalance test to Real Time Eye Implementation 
test to better match SATA-IO measurement definition and for faster 
execution speed. 

 
Known Issues: 
 

 In some very rare cases of OOB Gap and Vthresh tests, especially 
‘Responds to in-spec COMWAKE’ measurement, it is difficult to determine 
a valid response by using automation due to the differences in SATA 
product behavior. In such cases, the tester should opt for manual visual 
verification. This control is located in the N5411A product’s Configure tab, 
and is called ‘OOB Gap and Vthresh Detection mode.  Select ‘Manual’.  
This will allow the tester to determine either PASS or FAIL per the 
specification’s requirement and mark the measurement correctly.  This is 
not the default mode. 

 

 In some very rare cases of OOB Burst and Gap Width measurement, the 
desired COMINIT and COMWAKE bursts are not easily captured (the 
probability of capturing is low) by using automation due to OOB response 
inconsistencies. In such cases, the tester should opt for manual testing. 

 

 Supports the 54855 and 80000A Series scopes with limitation for the OOB 
Gap/Vthresh Detection test due to the older scopes’ hardware graphics 
limitation.  It is recommended to use the Agilent 80000B or 90000A Series 
Infiniium oscilloscopes with 12GHz or greater bandwidth with Agilent 
N5411A Software version 2.60. 
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Agilent N5411A Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411A Software Version 2.52 
Released Date: 30 May 2008  
Minimum Infiniium Oscilloscope Baseline Version: 5.40 (80000 series), 1.20 
(90000 series)  
File Name: SetupInfSATAII0252.exe 
 
Modifications: 
 

 Fixed the missing calibration information issue for the Vthresh Detection 
Tests 

 Fixed the missing MWArray.dll issue for the Skew Test 

 Increased the OOB Trigger level to avoid triggering at power-up glitches 
when acquiring the COMRESET 

 Removed the long/short patterns option in the user configure tab 

 Enhanced the AC Common Mode to be more robust in handling high AC 
Common Mode Spikes 

 Modified the RESETDUT Message Box of the Host OOB Tests 

 Added filtering to the glitches in the skew measurement at certain parallel 
edges which results to double UI reporting (e.g. 666ps) 

 Increased the number of images that can be reported to the maximum of 
25 images 

 Fixed the issue of pulse generator SICL address unable to close during 
certain sequences. 

 Increased timeout for the channel speed sample with the size of 500k 

 Added retries to the Tx Differential Voltage Test in the event the trigger 
fails in the BIST-TAS mode 

 Fixed the popup consistency of the “Set DUT To OOB Mode” Message 
Box 

 Moved the ‘#aligns’ option from compliance mode to debug mode in the 
configure tab 

 Removed the additional COMRESET options in user configure tab 

 Either 2*10dB attenuators or 2*20dB attenuators can now be used in the 
calibration procedure 
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Agilent N5411A Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411A Software Version 2.51 
Released Date: 29 Feb 2008  
Minimum Infiniium Oscilloscope Baseline Version: 5.40 (80000 series), 1.00 
(90000 series)  
File Name: SetupInfSATAII0251.exe 
 
Modifications: 
 

 Modified from previous implementation of: two 10dBs or four 10dBs 
attenuator (as illustrated in the calibration diagram) to two  20dBs 
attenuator for Gen1 Host/Drive OOB Vthresh Rejection Test only. “using 
attenuators” checkbox is removed. 

 Modified the Long Term Frequency Accuracy Test to acquire the 
maximum SSC cycles in Maximum Memory Available. The algorithm is 
generic to 80000 and 90000 series scopes. 

 Modified the OOB Vthresh Signal Detection Test Calibration procedure to 
use Vampt measurement on 1 OOB Burst instead of using Vpp 
measurement to take the corresponding voltages between the scope and 
pulse generator.  

 Modified the Skew Test to Matlab implementation, where Infiniiscan is no 
longer required. The previous implementation uses the Infiniiscan 
whenever available. 

 Modified the connection diagram display logic to match the new attenuator 
configuration requirements. 

 Fixed the phenomena of inconsistent results issue in skew test. 

 Provided workaround on the DUTs that trigger error messages, reporting 
unfound signal when the histogram is turned on. This occurs on 90000 
series scopes only. 
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Agilent N5411A Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411A Software Version 2.50 
Released Date: 11 Jan 2008  
Minimum Infiniium Oscilloscope Baseline Version: 5.40 (80000 series), 1.00 
(90000 series)  
File Name: SetupInfSATAII0250.exe 
 
Additions: 
 

 General Specifications and Transmitted Signal Requirements: 
o Added periodic mode option for the Jitter Tests in the debug mode.  
o Added Long Term Frequency Stability Test for the Non-SSC Tests 
o Dynamic Test Pattern Generation with alignment to improve the 

Loopback functionality 
o Implemented Fbaud/500 or JTF Loop Bandwidth selection for the 

Clock to Data Jitter Test. This selection is only available for i and m 
interfaces. Removed the Data-Data Jitter Tests. 

 

 Compliance Test Framework and miscellaneous: 
o Supports baseline 5.40(80000 series) and baseline 1.00 (90000 

series) 
o Supports the Unified Test Document 1.2 and  

o ECN 006 - FB10removal 
o ECN 008 - fbaud/500 Jitter Parameter Clarification 
o ECN 016 - Long Term Frequency Accuracy and SSC Profile 

Tests for Transmitters 
o ECN 017 - OOB Burst/Gap Duration Clarification 

o Supports the Remote Interface Control 
o Calibration and attenuators usage options: 

 With attenuators, all tests are available. Calibration factors 
which are generated by performing the calibration will be 
required. 

 Without attenuators, the OOB Signal Detection Threshold 
tests will be hidden.  

 
Modifications: 
 

 OOB Specifications:  
o Amended the UTD1.2: OOB1 Signal Detection Threshold boundary 

limits at 40mV, 210mV for Gen1, and 60mV, 210mV for Gen2 
o Amended the UTD1.2: OOB6, OOB7: 
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 Implemented a new algorithm for the 
COMINIT/COMRESET/COMWAKE Gap Detection Windows 
tests. 

o Amended the OOB Burst Length Test Information and Specification 
to comply with UTD1.2 
 

o Amended OOB Gap Length Test Information and Specification to 
comply with UTD1.2 

o For Host COMRESET tests, an additional COMINIT is sent to the 
host after user resets the DUT. 

 

 General Specifications and Transmitted Signal Requirements: 
o Amended the specification range for the TX Differential Skew for 

Gen2x from 20ps to 15ps. 
o Reduced the SSC Measurement test time by  

o disabling interpolation 
o sampling at 10GSa/s 
o Memory Depth 1.03Mpts 

o Amended the Amplitude Imbalance Test for the HFTP and MFTP 
patterns’ measurement algorithm.  
o For the HFTP, it is required that the measurement points be 

taken at 0.5UI of the bit within the pattern.  All amplitude values 
for this measurement shall be the mode value measured at 0.5 
UI nominal over a minimum of 10,000 UI 

o For the MFTP, it is required that the measurement points be 
taken at 0.5UI of the 2nd bit within the pattern.  All amplitude 
values for this measurement shall be the mode value measured 
at 0.5 UI nominal over a minimum of 10,000 UI 

o Enhanced the “Sample Size” Configuration Variable to reflect the 
approximated sample size values corresponding to the measured 
edges. 

o Enhanced the Data Rate and Unit Interval Variables in the Unit 
Interval Test to be able to correlate with each other. 

o Decreased the sampling rate and memory depth for the SSC Tests 
to reduce the test time and also prevent the waveforms from being 
discarded due to edges not found during the SSC Frequency 
Measurement. 

o Amended the Skew Test Algorithm by using the measured mid 
point value instead of zero value reference to measure the skew. 
The new algorithm uses Infiniiscan, effectively reject the Aligns 
whenever the Infiniiscan license exists. 

o Amended the Rise/Fall Time measurement to use the mean value 
instead of the mode value. 

o Improved the Amplitude Imbalance Test reporting. The test reports 
both HFTP and MFTP values instead of just the worst case value. 
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 Compliance Test Framework and miscellaneous: 
o Improved the overall connectivity experience of the pulse generator 

dialog box. 
o Added MultiTrials feature. 
o Amended the pattern files to comply with the latest 81134 pulse 

generator commands. 
o Updated test references to SATA 2.60 Gold. 
o Connection Diagram Updated 

 Differential probe is not needed anymore for OOB Signal 
Threshold Detection Tests 
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Agilent N5411A Serial ATA Electrical Performance 
Validation and Compliance Software Release Notes 
 
 
Agilent N5411A Software Version 02.01 
Released Date: 18 Dec 2006 
Minimum Infiniium Oscilloscope Baseline Version: 05.00.00 
File Name: SetupInfSATAIITest0201.exe 
 
Additions: 
 

 Selectable SSC Smoothing Point range in the DEBUG mode. 

 User can change the 81134A’s amplitude in the DEBUG mode. 

 Added dynamic vertical scaling for OOB related test when using the Mask 
for COM Response tests. 

 Added signal checking and verification before test run. 

 SSC measurement algorithm is enhanced to work with DUTs with heavily 
distorted SSC waveform. The algorithm is also enhanced to test and 
measure multiple SSC if no edges are found during the acquisitions.  

 Added Trigger Verify for Basic Trigger Integrity checking before the test 
run. 

 
Modifications: 
 

 Fixed illegal timeout for Gen 2 Host TJ & DJ Measurement. 

 Updated Connection pages to include the DC Blockers into the illustration 

 Change timing for OOB related tests. 

 Added boundary limits to the number of UI during OOB. 

 Rise / Fall Imbalance with results swapped for Tx- Rise and Tx- Fall. 

 Changed skew measurement technique due to MOI changes. 

 Added Amplitude Imbalance Test. 

 TJ / DJ measurement will report 0UI if the measured TJ / DJ is in the 
Femto Second Range. 

 Gen1 Jitter Description Data-Data was changed to Clock-Data. 

 SSC smoothing point for Gen1 and Gen 2 SSC measurement was 
updated to 335 and 670 respectively. 

 Added break for OOB measurement. The previous implementation was 
using a cancellation message box which will prompt for 6 times before the 
test is canceled. 

 Connection page changed to include COMAX connector labeling. 

 Added checking to allow the usage of Periodic Jitter measurement if the 
pattern selected is short ( 80 bits pattern ) whereas longer patterns will 
use Arbitrary. 
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 The entire host connection page had descriptions mismatched with the 
illustration. The descriptions were updated. 

 


