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KS8400B PathWave Test Automation 
Overview

Welcome to the Keysight 8400B PathWave Test Automation Getting Started 
Guide. In this chapter, you learn how to use the simple graphical user interface 
for PathWave Test Automation, called the Editor. Let's get started. 

Objectives 
In this guide you will learn how to: 

– Obtain and install KS8400B PathWave Test Automation Platform license

– Obtain and install SL1220A and SL1221A Plugins and licenses

– Navigate the PathWave Test Automation Platform (TAP) Editor 

– Create a simple test plan and configure test steps 

– Add and configure resources: Instruments, Devices Under Test (DUTs), and 
Result Listeners 

PathWave Test Automation Software 

For information about Keysight PathWave Test Automation, go to:
www.keysight.com/find/tap 

Download the latest KS8400B PathWave Test Automation software at:
https://www.keysight.com/us/en/product/KS8400B/pathwave-test-automation.html

Download the latest SL1200A Grid Integration and Compliance Test Automation 
Suite package from: 
https://www.keysight.com/us/en/lib/software-detail/computer-software/sl1220a-ac---
grid-test-sequencing-plugin.html

http://www.keysight.com/find/tap
http://www.keysight.com/find/tap
https://www.keysight.com/us/en/product/KS8400B/pathwave-test-automation.html
https://www.keysight.com/us/en/product/KS8400B/pathwave-test-automation.html
https://www.keysight.com/us/en/lib/software-detail/computer-software/sl1220a-ac---grid-test-sequencing-plugin.html
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Additional Keysight Test Automation Platform (TAP) Resources

– Help with licenses: call 1-800-829-4444 for Keysightcare
or email at: usa_orders@keysight.com

– http://www.youtube.com/@opentap158) 

– https://www.keysight.com/us/en/support/KS8400B/pathwave-test-automa
tion.html

– https://www.keysight.com/us/en/assets/3122-1326/application-notes/Pat
hWave-Test-Automation-Training-Editor-Introduction.pdf 

IMPORTANT licensing information: The SL1200A Grid Integration and 
Compliance Test Automation Suite package includes both the 
SL1220A and SL1221A Plugins. Plugin licenses are exclusive. Test 
Steps for plugins not licensed are visible but not usable.

You must license the SL1220A plugin to use the SL1220A AC/Grid 
Test Sequencing Plugin test steps and you can use them without 
using any of the SL1221A PHIL-based Anti-Islanding Compliance 
Test Automation Plugin test steps.

Similarly, you must license the SL1221A PHIL-based 
Anti-Islanding Compliance Test Automation Plugin to use the 
IEEE 1547.1-2020 Compliance Test Automation Software Test 
Steps and you can use them without using the SL1220A AC/Grid 
Test Sequencing Plugin test steps.

http://www.youtube.com/@opentap158)
https://www.keysight.com/us/en/support/KS8400B/pathwave-test-automation.html
https://www.keysight.com/us/en/assets/3122-1326/application-notes/PathWave-Test-Automation-Training-Editor-Introduction.pdf
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Definition of Terms

Bench Settings: Configure an instrument's address and other settings.

Log Panel: The Session Log is a text (.txt) file generated each time you start the 
Editor. It contains messages generated when the program runs.

Macro Step: One Test Step involves multiple Test Steps.

Package: Packages contain one or more Plugins and other related files (such as 
data files or README files), custom test steps, instruments, DUTs, result listeners 
and test plans. Packages are installed/removed with the Package Manager.

Package Manager: The Package Manager allows you easy access to packages. It 
can be configured to point to any server where packages are hosted. The 
Package Manager lets you download and install preexisting packages.

Plugin: Plugins provide additional TAP functionality. They are distributed in 
Packages that contain DLLs and other required files. 

Resources: Resources are called before the Test Plan execution starts and are 
closed when the Test Plan execution ends.

Resource Bar: The Resource Bar at the bottom of the Editor shows the currently 
configured DUTs, Instruments, and Results Listeners. For example, the following 
graphic shows one DUT (TimeDut), two Instruments (PSU, TEMP), and three 
Results Listeners (Log, SQLite, CSV).

In the Resource Bar, you can: add additional resources, select a listed resource to 
open its settings to modify or remove it, etc.

Results Viewer: View results from executing the Test Plan. Lets you plot results, 
track trends, and find errors. Results may be stored as either a text log file, a CSV 
file, or an SQLite Database file.

Run Explorer: This window displays basic information about the history of the test 
plan runs stored in the SQLite database, including a Run ID, Test Plan Name and 
Verdict (Pass, Fail, or Error). 

Test Plan: A Test Plan contains a sequence Test Steps and associated data. They 
are stored as XML files with the .TapPlan file extension.

Test Step: Individual steps in the Test Plan. Some Test Steps can have children. A 
Child Test Step is an ordinary step that is inserted as a child of another step. 
Child Test Steps are indented from the list of regular test steps.

Test Step Settings: Test Step Settings panel lets you edit the settings for the step 
selected in the test plan. Settings are properties that are automatically reflected 
in the TAP Editor. They are loaded and saved when the Test Plan is loaded/saved.

Timing Analyzer: Timing Analyzer results are based on log files.
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Install KS8400B Test Automation

1 Install KS8400B Test Automation

This section describes installation and how to begin using the KS8400B 
Pathwave Test Automation software.

In this chapter:
Installation page 12
Start the Test Automation Editor page 13
Introduction to the Test Automation Editor page 14

Editor Panels page 15
Menu and Resource Bars page 15
Dockable Panels page 15
Create a Simple Test Plan page 16

Congratulations! You have just run your first test plan! page 18
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Installation

1 Uninstall any previous versions of KS8400B Pathwave Test Automation. On 
the machine you want to run Keysight Test Automation: 

– Select Windows Start > Control Panel.

– Select Programs and Features.

– Find Keysight Test Automation.

– Click Uninstall.

2 Download the latest KS8400B Pathwave Test Automation software at: 
https://www.keysight.com/us/en/product/KS8400B/pathwave-test-automation.html

3 Scroll down. Under Software, click: Drivers, Firmware & Software.

4 Click: PathWave Test Automation Software Download.

5 Click  to download the current version. 

6 Select: Full Installer (PathWave Test Automation 9.23.x). 

7 Fill out the form then click . 

8 After the software downloads: 

– Launch (Run as Administrator) TestAutomation.Developer.version.exe.

– Follow the prompts to completely install PathWave Test Automation.

9 Select and purchase a Keysight KS8400B license.

-- You will receive an Entitlement Certificate when you purchase a license.

-- Follow instructions in the Entitlement Certificate to redeem the license. 

-- Save the license file (.lic) to a temporary location on the C: drive of the 
computer where you have installed the KS8400B software.

-- If you did not receive or cannot find your entitlement certificate, 
contact: https://www.keysight.com/us/en/contact.html

10 Install the license: 

– Start Keysight PathWave License Manager.

– Click the +Add a License File button.

– Browse to your .lic file and click Open to install your trial license. 

Congratulations! You are now ready to use KS8400B Pathwave Test Automation. 

https://www.keysight.com/us/en/contact.html
https://www.keysight.com/us/en/product/KS8400B/pathwave-test-automation.html
https://www.keysight.com/us/en/product/KS8400B/pathwave-test-automation.html
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Start the Test Automation Editor

1 Select Start > Keysight Test Automation to start the Editor. 

2 The Editor displays a welcome screen with an introduction of what is included 
in the Test Automation and useful links to help you get started. 

– Uncheck the Show welcome screen at startup checkbox to hide the 
welcome screen on startup. 

– Close the Welcome screen. 
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Introduction to the Test Automation Editor

The main Editor contains six components or panels: 

– Menu Bar 

– Test Plan Control Bar

– Test Plan Panel

– Test Step Settings Panel

– Log Panel

– Resource Bar

There is also a Macro Test Steps panel that is not shown above. It is used only with 
Macros and is not used in this tutorial.

Menu Bar

Test Plan Panel -

Test Step Settings Panel -
Configure the selected

step

View the sequence of test steps
that comprise the test plan

Test Plan Settings

Test Plan Control Bar -
Add, remove, run, and stop 

the test plan

 Resource Bar -
Configure instruments, DUTs (EUTs), 

and Result Listeners

Log Panel - View messages related to the Test Plan execution
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Editor Panels

The Test Plan Panel displays the test steps that have been added to the current 
test plan. If you click on a test step, you can see the related configuration in the 
Test Step Settings Panel. A test step's configuration settings can include, but are 
not limited to, input and output settings, and resources such as DUTs and 
instruments. Test Plan Settings Panel lets you edit the settings of the entire test 
plan.

The Log panel displays log messages from PathWave Test Automation during 
startup and during test plan execution. Log messages are classified as Error, 
Warning, Information, and Debug level events. The content displayed in the log 
panel is also saved in the Session log, which can be found at 
*%TAP_PATH%/SessionLogs*. 

Menu and Resource Bars

The Menu Bar provides the following: 

– File - lets you open and save test plans among other options. 

– Settings - let you configure the Editor, the Engine, and the Results settings 
and gives you the option to configure resources (connections, instruments, 
and DUTs) via Bench Settings. 

– Tools - let you open the Package Manager, Results Viewer, Run Explorer, 
and Timing Analyzer. 

– View - allows for panels to be shown/hidden or for custom panels to be 
displayed and docked. 

– Help - provides links to OpenTAP documentation. 

The Resource Bar shows what is currently configured for PathWave Test 
Automation. Resource is the general term for a Device Under Test (DUT), 
instrument, or result listener used by a test plan. Status indicators next to the 
resource indicate its state: 

– Green light = in use 

– Grey light = not currently in use 

Dockable Panels

The Test Plan, Test Plan Settings, Test Step Settings, Log, and Step panels are 
dockable. This allows you to:

– Float the panels. They can be resized. They also minimize and close with 
the main window.

– Preset the desired layout. Select View > Presets to return hidden, floating, 
or docked panels to their default locations.
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Create a Simple Test Plan

Let's take a closer look at creating a test plan formed by some test steps. 

1 Click the icon in the Test Plan panel or press Ctrl+T: 

2  The Test Steps window opens, displaying a list of available test steps 
organized in expandable groups: 

PathWave Test Automation comes preinstalled with the Basic Steps and Flow 
Control Plugins. Custom test steps are also displayed here. As your list of test 
steps grows, the search bar at the top becomes increasingly useful. 

Search Bar

Available Test Steps

Brief Description of
Selected Step
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3  In the Test Steps dialog box, select Flow Control and scroll down. Add a 
Repeat step. Either: 

– Select Repeat and click Add, or 
– Double-click the Repeat step. 

The description of the step appears at the bottom of the window. 

4 Select Basic Steps and scroll down if necessary. Add a Delay child step: 

– Select Delay 
– Click Add Child 

5 Add a Log Output step, using either the Add button, or by double-clicking. A 
Step is added based on the scope of the previous step. In this case Delay was 
a child step of Repeat, so Log Output will be a child step of Repeat as well. 

Your test plan should now look similar to this: 

– Child steps are indented in the Editor. 
– Reorder Test Steps by manually dragging them to a new location. 

6 Close the Test Steps window. 

7 Select the Repeat step by clicking on it. The Test Step Settings panel now 
shows these settings:

This means that the Delay and Log Output steps will execute three times. 
If the Step Settings panel does not appear, click View > Panels > 
Test Step Settings.
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Install KS8400B Test Automation Congratulations! You have just run your first test plan!

8 Select the Delay and Log Output steps respectively and inspect their Step 
Settings. Click on Log Output and enter your own Log Message in the text box: 

9 Run the test plan by clicking  or by pressing F5. 

10 After the run completes, scroll through the Log Panel to find your log 
message: 

11 If you don't see your log message: 

– Make sure that the Information tab in the Log panel is checked. This is 
needed because the Log Output step’s Log Severity setting is set to 
Information. 

– The Search button on the right of the Log Panel can also be used: 

Congratulations! You have just run your first test plan!
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2 Demonstration Example

In this chapter:
Install the Demonstration Package page 20

Construct the Test Plan page 21
Use the Results Viewer and Run Explorer page 25
Timing Analyzer page 31

Saving Test Plans page 33
Optional: Add a Title to Your Test Plan page 33
This Completes the Exercises on the Editor page 33
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Install the Demonstration Package

This chapter shows how to install a package containing demonstration test steps 
and instruments. We will use the Demonstration Plugin for simulating charging 
and discharging batteries that involves a power analyzer. You do not need access 
to instruments or other plugins for this example. 

1 Click Tools > Package Manager. 

2  The Package Manager opens. It can be configured to point to any server 
where packages are hosted. The Package Manager allows you easy access to 
packages. Packages typically contain one or more Plugins and other related 
files (such as data files or README files): 
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In the Package Manager: 

– Selecting a package in the left panel displays information about that 
package. Packages can contain custom test steps, instruments, DUTs, 
result listeners and test plans. 

– The Description tab gives a general overview of the package. 

– The Plugins tab shows all the custom test steps, instruments, DUTs, result 
listeners and other components contained in the package. 

– The Files tab shows all the files included in the package. 

– The Dependencies tab shows if the package is dependent on any other 
packages.

3 Scroll down and select the Demonstration Plugin (which is included with the 
PathWave Test Automation installation) and click Install. After installation the 
Demonstration Plugin displays a check mark in front, indicating that it is 
installed. 

4 Close the Package Manager window.

Construct the Test Plan

1 Remove any test steps left over from the previous example. Select the Test 
Step, then either: 

– Click the  button, or 

– Press Delete on the keyboard. 

2 Clear the Log panel. Right click on the Log panel then select Clear Log Panel.

3 Click the  button (or press Ctrl+T) to open the Test Steps window. Notice 
that there is now a new group called Demo. 

4  From the Demo group’s Battery Test subgroup, add a: 

– Charge step

and a 

– Discharge step 

If you have trouble installing a Package, close the Test Automation 
Editor and re-install the package. You can run the Package 
Manager from the Windows list of applications.
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5  Close the Test Steps window. Your test plan should now look like this: 

6 In the Test Plan panel, select either of the two test steps. You will notice that 
both steps reference an instrument resource — Power Analyzer in the Test 
Step Settings pane on the right side of the display. 
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7 We need to add a Power Analyzer instrument as a resource. 

– In the Resource Bar at the bottom of the panel, select Add New next to 
Instruments. 

– In the Bench Settings window (which also can be opened via Settings > 
Bench > Instruments), select the  in the lower-left corner. 

– The Add New Instrument window opens. Select Power Analyzer, then Add.

– Close the Add New Instrument window. 
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8 Next you would typically configure the instrument's address and other 
settings. Because this is a simulated instrument, click OK to close the Bench 
Settings window. 

9 In the Test Plan panel, the Resource Bar now shows one Instrument: PSU.

10 In the Step Settings for both the Charge and Discharge steps select the PSU 
as the Power Analyzer resource from the drop down menu. Make certain that 
you do this for both Charge and Discharge steps.
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Use the Results Viewer and Run Explorer

In PathWave Test Automation, a result listener is also a Resource, just like an 
instrument or DUT. Result listeners store data created by the test steps. 

You can add database-style result listeners that allow for a more in-depth view of 
the data. This lets you plot results, track trends, and find errors. This can all be 
done in the Results Viewer. 

To use the Results Viewer and the Run Explorer, a database Result Listener is 
needed. Let’s add an SQLite result listener. SQLite is a lightweight database that 
consists of a single file that encapsulates the full data set. You can use other 
types of databases too. 

Let's add the Log result listener as well. Multiple result listeners can be 
configured at the same time and will process the data from PathWave Test 
Automation in parallel. This happens in a separate thread, so it doesn't impact 
the execution speed of the test plan. 

1 Select Results > Add New from the Menu Bar. This opens the Settings dialog 
box: 

– Click the in the bottom left corner of the dialog box. This opens the Add 
New Results Listener dialog box.

– Under the Text group, select Text Log, then Add. 

2 In the Add New Result Listener window 

– Expand the Database group.

– Add the SQLite Result Listener, then Add.
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3 Close the Add New Result Listener window, then close the Add New Results 
Listener window. 

4 Execute the test plan by clicking in the Test Plan panel or by pressing F5. 

5 Let's make the results a little more interesting. Select the Charge Test Step and 
change the Charge Current from 10 A to 15 A. 

This creates a separate run result when you run the test plan again. 

6 Run the test plan again so you can look at the data that was captured. 

7 Select Tools > Run Explorer. The Results Viewer and Timing Analyzer also can 
be opened directly from the Tools menu. 

The Test Plan Run Explorer opens. This window displays some basic 
information about the history of your test plan runs stored in the SQLite 
database, including a Run ID, Test Plan Name and Verdict (Pass, Fail, or 
Error). In our case, neither of the last two have been set: 
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8 Now we will view the results of those test runs: 

– Hold Shift and select both Test Plan Runs at the top of the Test Plan Run 
Explorer list (your Run IDs may be different). 

– Open the Results Viewer by either: 

-- Clicking the View results from test plan button — , or 

-- Right clicking the test plan runs and selecting Plot Selected. 
– The Results Viewer shows two different plots one under the other (one for 

Charge and one for Discharge), as well as some Chart Settings to the right: 
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– Select the Charge plot, a blue box appears around the chart. 

– Locate the Series setting in the Charge Settings menu. Select Add a 
Modifier and click Split: 
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9 Click on the Split > Run ID drop-down arrow, navigate to Step > Power Supply, 
and select Charge Current2: 

Charge Current is here because it is a setting in the Power Supply group of the 
Charge test step. The number “2” next to Charge Current indicates that there are 
two unique values in the data set. 

10 The chart automatically updates: 
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11 Play around with the other Chart Settings. PathWave Test Automation 
provides powerful plotting capabilities that make evaluating data fast and 
easy. Some of the most commonly used are: 

– Chart Types, such as XY Scatter, XY Line, Histogram, etc. 

– Series Modifiers, particularly Split and Filter.

– Chart Data, which is based on what is passed in to the Result Listener by 
the test step.

The Chart Settings only apply to the selected chart, which is highlighted in 
blue. This allows you to configure the charts individually. 

12 Close the Results Viewer. 

Timing Analyzer

The Timing Analyzer is another powerful tool built into PathWave Test 
Automation. It can optimize test plans, locate bottlenecks in execution, and 
identify areas for parallel execution. 

1 Navigate back to the Test Plan Run Explorer. 

2 Click the Compare logs selection mode icon, that adds check boxes in front of 
each run: 

3  Select the top test plan as Left and the other as Right: 

4  Click the Compare logs for selected runs icon (the magnifying glass icon on the 
right) to open the Timing Analyzer: 
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5 The Timing Analyzer displays each element of the test plan on the left. The 
Time View window on the right shows time sequentially, with a visual break 
down of how long each action took and when the action occurred: 

6 The Time View window supports the standard zooming functionality with 
either a mouse wheel or by using Ctrl+ or Ctrl-, as well as left and right 
scrolling. 

7 The Log messages are also linked to the Time View graphs. Select one of the 
messages and notice that the associated bar becomes highlighted with a thin 
red box around it. 

8 Zoom in on the Charge completed time bar: 

1 2
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9 The times for the Charge steps (your times may be slightly different): 

– The top test run took 2.36 seconds 

– The bottom test run took 3.58 seconds

This is because we changed the Charge Current between runs. A 5 A increase in 
charge current resulted in a 1.17 second decrease in charge time. This is an 
example of the type of timing analysis that can be done easily with the Timing 
Analyzer. 

Saving Test Plans

Select File > Save, enter a file name for the test plan, and click OK.

Test Plans are saved with a TapPlan file extension. The default location is at the 
root folder of the installation folder, typically either”

– C:\Program Files\Keysight\Test Automation (for 64-bit)

– C:\Program Files (x86)\Keysight\Test Automation (for 32-bit)

Optional: Add a Title to Your Test Plan

To assign a name to your test plan you must save it. Click: File > Save As.... This 
opens a Windows Explorer dialog box where you can navigate to a folder and 
specify a file name for your test. This file name becomes the title for your Test 
Plan.

This Completes the Exercises on the Editor

We hope you found it interesting and are keen on learning more in the following 
labs and using PathWave Test Automation on your own! 

If the Editor closes improperly, it will try to restore the Test Plan 
that was last open.
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3 SL1220A /SL1221A Plugin 
Installation

This chapter describes installation SL1200A Grid Integration and Compliance 
Test Automation Suite (the Package). This package contains both the SL1220A 
AC/Grid Test Sequencing Plugin and the SL1221A PHIL-based Anti-Islanding 
Compliance Test Automation Plugin.

In this chapter:
SL1200A Package Installation page 36

SL1200A Package Installation Requirements page 36
Install SL1200A Grid Integration and Compliance Test Automation 

Suite page 39
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SL1200A Package Installation

SL1200A Package Installation Requirements

Install the Python Run-Time Environment

No license is required for the Python Run-Time Environment.

1 Install Python Run-Time Environment from: www.python.org.

2 Select: Downloads > All releases. Keysight recommends installing version 3.12. 

IMPORTANT licensing information: The SL1200A Grid Integration and 
Compliance Test Automation Suite package includes both the 
SL1220A and SL1221A Plugins. Plugin licenses are exclusive. Test 
Steps for plugins not licensed are visible but not usable.

You must license the SL1220A plugin to use the SL1220A AC/Grid 
Test Sequencing Plugin test steps and you can use them without 
using any of the SL1221A PHIL-based Anti-Islanding Compliance 
Test Automation Plugin test steps.

Similarly, you must license the SL1221A PHIL-based 
Anti-Islanding Compliance Test Automation Plugin to use the 
IEEE 1547.1-2020 Compliance Test Automation Software Test 
Steps and you can use them without using the SL1220A AC/Grid 
Test Sequencing Plugin test steps.

IMPORTANT: Install the Python Run Time Environment version 3.12 
(recommended) before installing the SL1200A Grid Integration and 
Compliance Test Automation Suite package (version 3.0 or later). 
You should also install the latest version of Keysight IO Libraries 
Suite, which is shown in the next section.
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– Be sure to install the 64-bit python
– Be sure to install for "all users"
– Be sure to install pip

3 Check the box for Add Python.exe to PATH. You may need to check the box for 
Use admin privileges.... 

4 Click Customize Installation. This opens the following dialog:

Make certain that PIP is selected.

5 Click Next to install. 
PIP packages should install automatically. However, if that process fails, you 
can use the following locations and method of updating the packages that are 
required

Note: PIP Packages can also be installed manually as follows:

– C:\Program Files\Keysight\Test Automation\Packages\SL1220A AC Grid 
Test Sequencer\opensvp\ requirements.txt

– C:\Program Files\Keysight\Test Automation\Packages\SL1220A AC Grid 
Test Sequencer\PostProcessing\requirements.txt

– pip install -r requirements.txt 

– ...use the specific directories above or navigate to those locations and 
execute the command as shown.
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Install Keysight's IO Libraries Suite

Keysight IO Libraries Suite is required.

1 Install the latest version of Keysight IO Libraries Suite from: IO Libraries Suite.

2 Scroll down to the How to Download section.

3 Click the Download IOLS 2024 button. 

4 Locate the IOLibSuite xxxxxxx.exe file in your Downloads folder.

5 Run the downloaded installer with Admin Privilege.

6 Follow all on-screen instructions.

7 Use Keysight Connection Expert to locate and identify test instruments in your 
test system.

Use Keysight Connection Expert to determine the IP Address or VISA address of 
instruments connected for IEEE 1547.1 Conformance Tests. Also, refer to the 
instrument's documentation. This would typically involve connection the DC 
Sources. The SL1200A Grid Emulator has its own discovery mechanism 
associated with the SL1200A Soft Front Panel.

https://www.keysight.com/us/en/lib/software-detail/computer-software/io-libraries-suite-downloads-2175637.html
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Install SL1200A Grid Integration and Compliance Test Automation 
Suite

The following procedure provides instructions to install Version 3.0 (or later) of 
the SL1200A Grid Integration and Compliance Test Automation Suite. Follow 
these instructions whether you are installing the plugin for the first time or are 
upgrading from an earlier version.

1 If it is open, close the KS8400B Test Automation Editor. 

2 If you had a previous version of the SL1220A package (prior to 3.0), it must be 
uninstalled before proceeding. If you did not have a previous version installed, 
skip to Step  below.

– Navigate to C:\Program Files\Keysight\Test Automation\.

– Click PackageManager.exe to open the KS8400 Package Manager directly.

– Select (highlight) the old SL1220A package.

– Click the Uninstall to uninstall the old SL1220A package.

Download the latest SL1200A Grid Integration and Compliance Test Automation 
Suite package from: 
https://www.keysight.com/us/en/lib/software-detail/computer-software/sl1220a-ac---
grid-test-sequencing-plugin.html

– Select the current release of SL1200A Grid Integration and Compliance 
Test Automation Suite package (version 3.0 or later).

– Click the  button.

You wont be able to install a plug-in without the base license 
installed and active. That is: install KS8400B > Install KS8400B 
License > Install SL1221A > Install SL1221A License. 

https://www.keysight.com/us/en/lib/software-detail/computer-software/sl1220a-ac---grid-test-sequencing-plugin.html
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3 Install the new version (3.0 or later) of the SL1200A Package: 

– After it downloads, double-click:
SL1220A_AC_Grid_Test_Sequencer-version.TapPackage. A new Package 
Manager window opens.

– Follow the prompts to install the package.
4 After the SL1200 package installs successfully, close the Package Manager 

window. 

5 Reopen the Test Automation Editor.

6 Select and purchase an SL1220A AC/Grid Test Sequencing Plugin and/or the 
SL1221A PHIL-based Anti-Islanding Compliance Test Automation Plugin 
license.

-- You will receive an Entitlement Certificate when you purchase a license.

-- Follow instructions in the Entitlement Certificate to redeem the license. 

-- Save the license file (*.lic) to the computer where you have installed the 
SL1200A package.

-- If you did not receive or cannot find your entitlement certificate, 
contact: https://www.keysight.com/us/en/contact.html

7 Install the plugin license(s): 

– Start Keysight PathWave License Manager.
– Click the +Add a License File button.
– Browse to your .lic file and click Open to install your trial license.

IMPORTANT: if you created test plans using versions 2.x or earlier of 
the SL1220A plug-in and ex

perience Namespace errors, use the following conversion 
process and utility to migrate the test plan file(s) to version 3.0:

Navigate to: C:\Program Files\Keysight\Test Automation\
Packages/SL1200A Grid Integration and Compliance Test 
Automation Suite/Tools/testplan_migration.py

Run the script with a single argument (which is the .TestPlan 
file you want to migrate to 3.x namespaces). For example:

python testplan_migration.py C:\TEMP\Old_TestPlan.TestPlan.

There may still be some residual errors related to the old plugin 
when loading the Test Plan, but those issues will be resolved 
when you re-save the plan from the new plugin.

https://www.keysight.com/us/en/contact.html
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4 Using the SL1220A AC/Grid Test 
Sequencing Plugin

In this chapter, we will learn how to control the output voltage of the SL1200A 
SL1200A Regenerative AC Emulator and set up measurement logging with live 
plotting panels by creating a simple test plan. This example test plan can 
become a template or starting point for a larger Test Plan. 

In this chapter:
Equipment and Software Requirements page 42

Hardware Requirements  page 42
Software Requirements  page 43

SL1220A Programming Overview page 44
Add SL1200A System Instruments  page 45
Create the Example Test Plan  page 47
Additional SL1220A Example TAP Programs  page 53

IMPORTANT licensing information: The SL1200A Grid Integration and 
Compliance Test Automation Suite package includes both the 
SL1220A and SL1221A Plugins. Plugin licenses are mutually 
exclusive. Test Steps for plugins not licensed are visible but not 
usable.

You must license the SL1220A plugin to use the SL1220A AC/Grid 
Test Sequencing Plugin test steps and you can use them without 
using any of the SL1221A SL1221A PHIL-based Anti-Islanding 
Compliance Test Automation Plugin test steps.

Similarly, you must license the SL1221A PHIL-based 
Anti-Islanding Compliance Test Automation Plugin to use the 
IEEE 1547.1-2020 Compliance Test Automation Software Test 
Steps and you can use them without using the SL1220A AC/Grid 
Test Sequencing Plugin test steps.
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Equipment and Software Requirements

Hardware Requirements

– One SL1200A Regenerative AC/Grid Emulator such as the SL1212A 

– KS8400B TAP Software and license

– SL1200A Integrated Grid Test Automation Suite package and license for 
the SL1220A AC/Grid Test Sequencing Plugin

Refer to the SL1200A Grid Integration and Compliance Test Automation Suite 
Help File for more detailed information.

The example discussed in this section should first be run with an open output as shown in 
the hardware configuration figure on the next page. This ensures that proper operation 
of the plug-in can be verified without risking damage to equipment from 
improper programming. Once the test plan has been run, it can be used as a 
template for subsequent operation with a DUT.

RISK OF PROPERTY DAMAGE AND/OR DEATH: The 
following example training lab will program the SL1200 to 
output high voltages capable of injuring or killing a person. 
Any load or DUT connected to the SL1200 may be damaged 
if it is not properly rated. The L1, L2, L3, N, G, DC+ and DC- 
terminals should all be fully disconnected during the 
example training lab. Please take all proper precautions 
before proceeding with this exercise
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Soft Front Panel

Keysight’s SL1200A Series Regenerative AC/Grid Emulator Soft Front Panel 
(SFP) provides a tool for discovering and configuring your SL1200A Systems on 
your local LAN. Use this tool to update the firmware and gate ware of all 
components within the SL1215A rack. For detailed information, refer to the 
SL1220A SFP and help file. 

Software Requirements

– Keysight KS8400B Pathwave Test Automation Platform (TAP) software and 
license

– SL1200A Integrated Grid Test Automation Suite package and license for 
the SL1220A AC/Grid Test Sequencing Plugin

See “PathWave Test Automation Software” on page 7 for detailed software 
installation information.
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SL1220A Programming Overview

Keysight’s SL1220A AC Emulator section in the SL1220A Help File details all the 
TAP Steps available in the SL1220A Plugin. There are five major groups or 
sub-sections of TAP Steps:

– Common - provides general purpose Step that can be used in multiple 
Emulation Modes

– Configure - provides a single configuration Step for each Emulation Mode, 
which configures the SL1220A system

– Measure - provides a wide variety of measurements from the built-in Power 
Analyzer of the SL1220A system

– Static - provides Steps for changing set-points, slew rates, etc. which 
control the system over the LAN connection and execute at the 
performance level of the TAP and Windows environment

– Transient - provides Steps that run inside the controller of the SL1220A and 
has time-precision and 50 s time resolution for real-time operations

Programming always starts with Configure steps. These are described in the 
Configuring the Emulation Model section of the SL1220A Help File. Configure 
steps completely set up the SL1200A for a particular Emulation mode, where 
initial Set-points, Slew Rates, Control Limits, and Protection Limits are set. With 
a single Configure Step, the system is fully operational at that point. 
Understanding Set Points, Slew Rates, Limits, and Trip Times gives you an 
overview of the control parameters involved. Protection and Control Limits 
explains in greater detail the available Limits for monitoring and controlling the 
system, so you can avoid over-voltage or over-current, or you can cause the 
SL1200A system to open its output relay contactors to disconnect from the DUT 
if the Power Analyzer detects over-voltage or over-current.

Measurements and Data Logging explains the access to the built-in Power 
Analyzer of the SL1200A system. The Data Logger allows you to create .csv files 
with selected measurements for a particular test, and measurements are 
collected in background while other steps can be executed to stimulate the test 
environment. The Measure Steps provide a means of measuring results against 
limits, so your Test Plan can indicate success or failure.

The External Triggering section of the Help file explains how to synchronize the 
SL1200A with your test environment.
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Add SL1200A System Instruments

TAP software allows you to add an Instrument that gives you access to the 
Keysight SL1220A AC Emulator Plugin. Add an instrument by clicking the 
Add New button at the bottom of the Test Automation window:

This opens the Bench Settings dialog box. Click the  button in the lower left to 
Add New Instrument.

Expand the Keysight AC Emulator menu. Select the Keysight SL1220A AC 
Emulator. Click Add. Close the Add New Instrument box.

You will be presented with a dialog for setting the IP Address and choosing the 
model number of the system you want to program. The following screen capture 
shows entering the IP Address. If the system is connected to your computer via 
LAN, click the Retrieve Device Number button to determine which model number 
it is at that IP Address.
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If desired, you can alter the default name of the instrument by double-clicking 
the name and changing it. Once you are done, click the OK button to return to the 
main Test Automation window.
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Create the Example Test Plan

This example can become a template or starting point for a Test Plan. 

1 Got to File > New or press CTRL+ N on your keyboard to start a new test plan.

2 Clear the log panel. Right click on the log file panel then select Clear Log 
Panel.

3  Click the  button (or press CTRL+ T) to open the Add New Steps window. 
You will notice that there is now a new group called Keysight SL1220A AC 
Emulator.

4  Expand the Keysight SL1220A AC Emulator group’s Common subgroup. Add 
a Check ACE Errors step1.

1 ACE refers to AC Emulator

Insert this step at the beginning of your Test Plan. This allows it to 
send any messages into the Log Viewer and clear any previous 
error conditions that may have occurred.
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5 Expand the Configure > Emulation subsection. Add the Configure Three Phase 
AC Voltage step. 

6 Close the Test Steps box.

7 In the Test Plan panel, click on the newly added Configure Three Phase AC 
Voltage step — the step should be highlighted in light blue. The Test Step 
Settings panel at the right of the screen has several fields to configure. If you 
cannot see the Test Step Settings panel, go to View > Panels > Test Step 
Settings at the top of your screen. If you still can’t see the panel, go to View > 
Presets > Default to reset the Test Automation GUI.

8 Use the SL1220A AC Emulator drop-down to select the instrument you want 
to control in this test. If you have configured just one SL1200, then it will be 
automatically selected. 

a Leave Enable Harmonic Control de-selected (we will not be injecting 
harmonics during this example).

b Check the Neutral Pass Through (grounds the neutral). 

c Set the Frequency to either 50 or 60Hz. 

d Check Set Voltage/Slew Rate same for all phases to make programming 
easier. 

e Scroll down to the Phase 1 Settings, and set the Voltage to 231 or 277 
VRMS. 

f Leave the rest of the settings alone. By default the phases are programmed 
to operate balanced with a 120 degree phase difference.

If your system is not connected to actual SL12xx hardware, most of 
these items are grayed-out and not configurable.
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9 In the Test Plan window, look to the left of the Configure Three Phase AC 
Voltage step. You should see a  icon. Click this icon to expand the test 
step. The main test step, Configure Three Phase AC Voltage, is considered the 
“parent” step, which executes first before the two tab-delineated steps 
underneath it which are its “child” steps1. 

10 Click on the child step Set Three Phase AC Protection Parameters step. We do 
not need to edit any of the default values for the example, but note that this is 
where you can set AC protection trip limits and delays.

11 Click on the Test Plan  icon again to open the Test Steps box. 

a Navigate to and expand the Measure subsection. 

b Add a Start Measurement Log test step to your test plan. 

c Now, select it in the Test Plan panel to adjust its programmable 
parameters. 

d In the Test Step Settings panel, make sure the output mode is set to 
Independent Three Phase Mode. 

e You may change the log file name and location if you desire, otherwise the 
log will be written to the root of the test automation install directory
(C:\Program Files\Keysight\Test Automation). 

f Select the Choose CSV Log File Parameters button to open the parameter 
selection menu. 

g You can alter the measurements taken, otherwise leave these settings 
alone for the example. Close the parameters box.

h Check the Add System Info box to add a header with firmware and serial 
number information of the SL1200A to the measurement log file. 

i Keep the Sample Rate at 50 ms. 

j Click the Choose View 1 Parameter button to open the View 1 Parameter 
selection menu. This allows you to select one parameter to graph in a 
live-viewable panel. 

k Choose V1 RMS L-N [V]. Close the parameter box.

l Click on the Choose View 2 Parameter button and select another 
parameter you would like to view such as frequency. Close the parameter 
box.

m Finally, click on the Choose Data Table Parameters button to select which 
parameters should be shown continuously as a table.

1 More information on parent and child steps can be found in the Keysight Test Automation Help file under 
Help > Getting Started.

If your system is not connected to actual SL12xx hardware, most of 
these items are grayed-out and not configurable.
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12 Go to View > Panels > Keysight SL1220A and enable all three panels - View 1, 
View 2, and Data Table. You should see three floating panels at the middle of 
the screen. You can keep them floating and move them around to another 
monitor or part of your screen, or you may “dock” the panels into the UI as 
you’d like. Make sure to keep these panels visible later when the test plan is 
running.

13 Click on the  button once more. Add the Delay step. Delay is not part of the 
SL1220A Plugin and is under the Basic Steps drop-down in the test steps 
menu. Program the delay to 5 seconds.

14 Add the Set AC Voltage Output step from the Static > AC subsection of the 
SL1220A Plugin test step list.

15 Set all phases to 277.2 or 332.4 VRMS (20% OV from 231V L-N/400VL-L or 
277VL-N/480VL-L).

16 Check the Change Existing Slew Rate box. Set the slew rate to 20 VRMS/s.

17 Add another 5 second delay step.

18 Add another Set AC Voltage Output step. You can add these steps from the Test 
Steps menu, or you can copy-paste existing steps from your test plan and 
change their values. In the new Set AC Voltage Output step, program the 
output to return to 231 or 277 VRMS with a slew rate of 
20 VRMS/s once more.

19 Add one more 5 second delay.
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20 Under the Measure subsection of the test steps menu, add a Stop Measurement 
Log step. The example test plan is now complete, and should look like the 
following: 

RISK OF PROPERTY DAMAGE AND/OR DEATH: The 
following example training lab will program the SL1200 to 
output high voltages capable of injuring or killing a person. 
Any load or DUT connected to the SL1200 may be damaged 
if it is not properly rated. The L1, L2, L3, N, G, DC+ and DC- 
terminals should all be fully disconnected during the 
example training lab. Please take all proper precautions 
before proceeding with this exercise
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21 Run the test plan. During the runtime, the panels you added earlier should 
display real-time data from the system. At the end of the test, your view 
panels should look something like the below.  
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Additional SL1220A Example TAP Programs

Additional, complete example Test Plans are located at the default installation 
location: C:\Program Files\Keysight\Test Automation\SL1220A Sample Plans. They will 
be prefixed with SL1220A and with underscore characters instead of spaces in 
the name (e.g. SL1220A_Example_2_AC_Three_Phase_Voltage_Priority.

Step Names, as shown in the screen capture, are modified in the 
Test Step Settings panel in the Editor. For example, the name “Set 
All Phases AC Voltage 330 V at 20 Vrms/s” is actually the “Set AC 
Voltage Output” Test Step from the SL1220A Static subgroup. The 
Step Name changes according to the settings. 

Similarly, the “Wait 500 ms” step is actually another Wait test step 
but with the Step Name changed according to the specified time.
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5 Using the SL1221A PHIL-based 
Anti-Islanding Compliance Test 
Automation Plugin

In this chapter:
Equipment and Software Requirements page 56

Hardware Requirements  page 56
Software Requirements  page 56

Keysight Unintentional Islanding Overview page 57
An Example Test System for Unintentional Island Tests page 58

Recommended LAN Configuration  page 59
Steps to Creating an Unintentional Island Test Plan: page 60
Add and Configure EUT and Test Instruments page 61

Add a Power Inverter (EUT)  page 61
Add a Power Inverter (EUT)  page 61
Add an AC Grid Emulator and DC Source  page 62
Optional: Add EUT Nameplate Information  page 66

IEEE 1547.1-2020 Conformance Step page 67
Grid Emulator, EUT, and DC Source  page 68
Create the Test Plan  page 69
Nameplate Test Step  page 70
Section 5.10 Unintentional Island Test Steps  page 71
Section 5.10 Measure Sustained Island Test Step  page 72
Section 5.10 Measure Clearing Time Test Step  page 73
Status Panel  page 74

Running a Test Plan page 75
Running a Measure Sustained Island Step  page 75
Running a Measure Clearing Time Step  page 78

Measurements and Post Processing Directories page 82
CSV Measurement Files  page 83
PNG Waveform Files  page 85

Important: This chapter provides a brief overview of the SL1221A PHIL-based 
Anti-Islanding Compliance Test Automation Plugin used to run unintentional 
islanding tests according to IEEE 1547.1-2020. It does not provide complete and 
detailed instructions. For detailed information, refer to the SL1200A Grid 
Integration and Compliance Test Automation Suite Help File.
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Equipment and Software Requirements

Hardware Requirements

To fully use the SL1221A PHIL-based Anti-Islanding Compliance Test 
Automation Plugin you need the following hardware:

– One SL1200A Regenerative AC Emulator such as the SL1212A. Multiple 
units can be connected in parallel to achieve higher power.

– A DC source such as the Keysight RP7900A or SL1200A Gridf Emulator in 
DC Emulation Mode (fixed DC only)

– A Power Inverter for the Device Under Test (DUT, also known as an EUT1)

Refer to the SL1200A Grid Integration and Compliance Test Automation Suite 
Help File for more detailed information.

Software Requirements

– Keysight KS8400B Pathwave Test Automation Platform (TAP) software and 
license

– SL1200A Integrated Grid Test Automation Suite package and license for 
the SL1221A PHIL-based Anti-Islanding Compliance Test Automation 
Plugin

See “Install SL1200A Grid Integration and Compliance Test Automation Suite” on 
page 39 for detailed SL1200A package installation information.

1 "EUT" and "DUT" refer to the same device. EUT is used by IEEE, the SL1221A Plugin, and others to specify the 
device being tested. DUT is a common term and is used in Keysight's KS8400B.

IMPORTANT licensing information: The SL1200A Grid Integration and 
Compliance Test Automation Suite package includes both the 
SL1220A and SL1221A Plugins. Plugin licenses are mutually 
exclusive. Test Steps for plugins not licensed are visible but not 
usable.

You must license the SL1220A plugin to use the SL1220A AC/Grid 
Test Sequencing Plugin test steps, and you can use them without 
using any of the SL1221A PHIL-based Anti-Islanding Compliance 
Test Automation Plugin test steps.

Similarly, you must license the SL1221A PHIL-based 
Anti-Islanding Compliance Test Automation Plugin to use the 
IEEE 1547.1-2020 Compliance Test Automation Software Test 
Steps and you can use them without using the SL1220A AC/Grid 
Test Sequencing Plugin test steps.
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Keysight Unintentional Islanding Overview

The following graphic describes the Keysight solution for unintentional islanding. 
This graphic represents the translation of the unintentional island test 
procedures, setups, etc., found in the IEEE-1547.1-2020 into the Keysight 
KS8400B Test Automation Platform (TAP). This TAP environment running the 
SL1221A TAP Plugin addresses the Section 5.10.2 test requirements. The 
software runs in the Windows environment and interfaces to the various 
hardware components via LAN. 
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An Example Test System for Unintentional Island Tests

We will use the SL1221A PHIL-based Anti-Islanding Compliance Test 
Automation Software plugin to create a sample Unintentional Islanding test plan 
based on the following system diagram. Your actual test plan may use a different 
DC Source, AC Grid configuration, or EUT (power inverter) and be different than 
this example.

The test environment consists of the Grid Emulator (a Keysight SL1200 series 
AC/Grid Emulator), the Power Inverter (EUT - Equipment Under Test, or DUT - 
Device Under Test), and the DC Source to power the inverter. Each of these 
devices must be properly configured (referred to as a “profile”) in the SL1221A 
plugin before testing can take place. The following illustration shows a 
Three-Phase (3) inverter configuration. However, the SL1221A can also test 
Single-Phase and Split-Phase inverters as well. For detailed information, refer to 
the SL1200A Grid Integration and Compliance Test Automation Suite Help File.
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To achieve best performance, the SL1221A Plugin configures the SL1200A 
AC/Grid Emulation system to always operate in the Three-Phase mode where the 
user selects the Single, Split, or Three-Phase mode of operation and then wires 
the Power Inverter to the active L1, L2, L3, and Neutral lines. This allows a single 
SL1200A AC/Grid Emulator rack system to handle low power Single and Split 
Phase micro inverters up to relatively high-power Single, Split, and Three-Phase 
Power Inverters while maintaining its highest output impedance for RLC 
Autotuning.

The SL1221A plugin controls the SL1200A AC/Grid Emulator and sets up the 
Power Inverter using either SunSpec ModBus or allows manual control of the 
inverter.

The DC Source can be virtually any DC Source that works best to power the EUT.

Recommended LAN Configuration

The SL1200A Grid Emulators make use of UDP Broadcasting for 20kSa/s 
measurement data during testing. This broadcast data only works if the 
computer and the SL1200A are on the same subnet. Keysight recommends using 
a computer with a single LAN interface connected to a LAN Switch and to all the 
other LAN Devices, as shown below.
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Steps to Creating an Unintentional Island Test Plan:

1 Add and configure the EUT in the TAP Editor

2 Add an AC Emulator and DC Source in the TAP Editor

– Add and configure the AC Emulator

– Add and configure the DC Source

– Optionally, add EUT Nameplate Information step

3 Add the IEEE 1547.1-2020 Conformance Test Step (known as the 
Grandparent Test Step)

4 Complete Test Step Settings

– Optional: Add a Title to Your Test Plan. See “Optional: Add a Title to Your 
Test Plan” on page 33

5 Run the Test Plan

6 Analyze the Test Data

Keysight’s SL1200A Grid Integration and Compliance Test Automation Suite 
Help File describes each of these steps in detail.

Important: Create the EUT Profile, Grid Emulator Profile, and DC 
Source Profile before you add the IEEE 1547.1-2020 Conformance 
Test Step into the Test Plan. Otherwise, Test Plan errors may occur.
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Add and Configure EUT and Test Instruments

Creating the EUT Profile, Grid Emulator, and DC Source are necessary before you 
add the IEEE 1547.1-2020 Conformance Test Step into the Test Plan. Otherwise, 
you will see red-circle errors ( ) in the Test Plan. 

Add a Power Inverter (EUT)

EUT configuration is essential to properly operate the Grid Emulator and the DC 
Source. The TAP environment creates a resource called a DUT (or EUT1). The EUT 
Device Profile provides the configuration information. A detailed description of 
creating profiles for the EUT, Grid Emulator, and DC Source can be found in the 
SL1200A Help File.

You must specify the EUT (power inverter) you are testing. Multiple EUTs may be 
created and populated with the correct information. The one to be tested can be 
selected and used in a Test Plan. The EUT Profile is the starting point for all 
information and represents the most important source of information to drive the 
Test Steps.

1 Add an EUT by clicking the DUTs Add New button in the Resources panel at 
the bottom of the Test Automation window. Alternately, select Settings > 
Bench > DUTs to open the DUTs tab in the Bench Settings panel. 

2 Select the DUTs tab in the Bench Settings panel. Then click the  icon. This 
opens the Add New DUT panel.

3 If necessary, expand the IEEE 1547.1-2020 Conformance Test Equipment. 

4 Select Power Inverter, then click the Add button.

This adds a Power Inverter as a DUT device in the KS8400B Resources panel and 
automatically opens the DUT Bench Settings panel. 

1  IEEE and other industries use EUT to specify the device being tested. Keysight's KS8400B uses "DUT", this is 
the same as an "EUT". 
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5 After adding a DUT, complete the Bench Settings panel with all necessary 
information about the power inverter to ensure proper communication. For 
detailed information, refer to the DUT Bench Settings panel in the SL1220A Help 
File.

6 It is possible to have multiple DUT devices specified in the SL1221A Plugin. 
Once added with the default name as power inverter, you can double-click 
the named device on the left side to rename it.

Add an AC Grid Emulator and DC Source 

For the Test Plan to be functional, resource configuration is necessary. You must 
add both an AC Emulator and a DC Source that powers the power inverter. You 
have several choices for each of these. 

For this example, select a Keysight SL1200A Series Regenerative AC/Grid 
Emulator and a Keysight RP7900 DC Source. Note that these are configured in 
the Add New Instrument panel. 

1 Add an instrument by clicking the Instruments Add New button at the bottom 
of the Test Automation window. Alternately, you can select Settings > Bench 
> Instruments to open the Instruments tab in the Bench Settings panel. 

2 Select the Instruments tab in the Bench Settings panel then click the  icon. 
This opens the Add New Instruments panel in front of the Bench Settings panel.

3 Expand the IEEE 1547.1-2020 Conformance Test Equipment > DC Sources to 
show possible DC Sources. 
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4 Expand the Keysight AC Emulator to show the Keysight SL1200A Series 
Regenerative AC/Grid Emulator.

Add an AC Grid Emulator

The SL1221A TAP Plugin supports the SL1200A Series of Grid Emulators:

SL1201A 600 VL-L, 63 A, 30 kW / 42 kVA 

SL1202A 600 VL-L, 63 A, 45 kW / 66 kVA 

SL1203A 600 VL-L, 125 A, 90 kW / 130 kVA 

SL1212A 1200 VL-L, 32.5 A, 45 kW / 68 kVA 

SL1213A 1200 VL-L, 65 A, 90 kW / 135 kVA 

SL1214A 600 / 1200 VL-L, 65 / 32.5 A, 45 kW / 68 kVA 

SL1215A 600 / 1200 VL-L, 130 / 65 A, 90 kW / 135 kVA

The two models in Blue have Dual Range operation, where they can represent 
the other five models’ voltage range programmatically.

Models come with three or six Power Stages and up to nine voltage-range AND 
same-power systems can be paralleled together. Power Stages are paralleled 
together per AC phase.

Refer to SL1200A Series Scienlab Regenerative AC Emulator for detailed 
information. Also, refer to the SL1200A Grid Integration and Compliance Test 
Automation Suite Help File for more detailed information.

https://www.keysight.com/us/en/products/hev-ev-grid-emulators-and-test-systems/sl1200a-series-scienlab-regenerative-3-phase-ac-emulator.html
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1 For this example, select the Keysight SL1200A AC Emulator then click the ADD 
button. This opens the Bench Settings panel. 

2 Complete the Bench Settings panel with Director IP Address, etc. to ensure 
proper communication with the SL1200A. For detailed information, refer to 
the AC Emulator Bench Settings panel in the SL1220A Help File.

3 Click the Retrieve Device Number button to select or specify exactly which 
model of the SL1200A series is used for the test. The SL1200A AC Emulators 
come with a Soft Front Panel that can be used to discover any SL1200A 
Systems on the LAN your PC is connected. If installed on your PC, it can be 
found typing SL1200A into your Windows Search box, which should bring up 
the following and then selecting its Help File for assistance

Add a DC Source

This document describes ways of changing the AC Output Power of the EUT by 
manually controlling the DC Power Supply. This gives maximum flexibility in 
choosing a DC Power Supply for powering the EUT. 
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You can add one or more DC Sources.

1 For this example, select the Keysight RP79Xx89Xx DC Source. Click the ADD 
button. 

2 Fill in the Bench Settings panel with all necessary information about your DC 
source to ensure proper communication. For detailed information, refer to the 
DC Source Bench Settings panel in the SL1220A Help File. 

3 Parameters shown are compared when trying use the DC Source during 
testing. If the DC Power is insufficient for the needs of testing the EUT, this is 
flagged in the Equipment Screening step. Equipment Screening is enabled in 
Test Steps Settings panel of the 5.10.2 Unintentional Island Test Step.
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Optional: Add EUT Nameplate Information

After adding the EUT to the Resources, you can include a test step to 
automatically add the EUT Nameplate information. This information is used to 
verify connectivity and assist troubleshooting.

This Test Step must go before the IEEE 1547.1 Conformance Test Step (the 
Grandparent step). 

1 In the Test Automation editor, click the  button (or press Ctrl+T) to open the 
Test Steps panel. 

2 Expand EUT Control > Common. 

3 Select Nameplate Information then click the Add button to insert the 
Nameplate Information panel. 

Note that the Nameplate Test Step can specify which EUT it is query, but you 
MUST provide your own power to the EUT for the command to work. That is, the 
Step does NOT provide power to the EUT as it does with the IEEE 1547.1-2020 
Conformance Test Grandparent Step.

This can be easily done by using the SL1200A Soft Front Panel and executing the 
Nameplate Test Step by itself in the TAP Test Plan.

For detailed information about the Nameplate Panel, see “Nameplate Test Step” 
on page 70.

Keysight’s SL1200A Grid Emulator can be configured as a DC 
Source too. However, the SL1200A cannot provide PhotoVoltaic 
(PV) Simulation. Therefore, if you must operate the EUT in MPP 
mode, you need to provide a DC Source that has PhotoVoltaic 
(PV) Simulation, such as Keysight’s RP79xx/RP89xx series power 
supplies or any other DC Source that is controlled manually.
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IEEE 1547.1-2020 Conformance Step

Only a single step - called the IEEE 1547.1-2020 Conformance Test or 
Grandparent Step -- represents the complete IEEE 1547.1-2020 test. This step is 
called the “Grandparent” step1, because there are multiple sub-steps involved:

- IEEE 1547.1-2020 Conformance Step. This is the top-level Step from which all 
Test Type Steps are run.

– Section 5.10 Unintentional Island Test, known as the ‘Parent’ step

-- Section 5.10.2 Measure Sustained Island Tests, known as ‘Child’ steps

-- Section 5.10.2 Measure Clearing Time Tests, known as ‘Child’ steps

1 It is also called a “Macro” step because there are multiple steps involved in this one step.
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Grid Emulator, EUT, and DC Source

This IEEE 1547.1-2020 Conformance or Grandparent Test Step is the step where 
you select which Resources are used in the test and you can view the name of 
the Results directory: IEEE-1547.1 Results Directory (the name is not editable). 

When this Test Step or any step under this one is run, the following directory 
path is either selected or created:

C:\TEMP\My_Power_Inverter_Results\IEEE 1547.1-2020

Steps (Parent or Child steps) below this have additional unchangeable directory 
names.

The C:\TEMP\My_Power_Inverter_Results\ comes from the EUT Profile page and 
called the Data Logging Directory.

Select resources from 
the Grandparent Test 
Step Settings panel

Results Directory
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The Grid Emulator, EUT, and DC Source are selected from the top level 
Grandparent Step Test Step Settings Panel: 

Having selected the EUT Three-Phase, all of the Measure Steps configure the 
Grid Emulator for Three-Phase operation.

Create the Test Plan

With the DUT, Grid Emulator, and DC Source profiles created, a Test Plan can be 
created. The Test Plan comes from adding Test Steps into the Test Plan Area. 

This Step is used to specify the Normal and Abnormal Categories 
of the Power Inverter. These settings affect almost every Child 
Step setting in configuring the EUT for proper operation.
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Nameplate Test Step

Under the EUT Control/Common folder, there is a Test Step called Nameplate 
Information. This Step is useful to make sure you can communicate with the EUT 
over SunSpec ModBus. Add this step as follows:

1 In the Test Automation editor, click the  button (or press Ctrl+T) to open 
the Test Steps panel. 

2 Expand EUT Control > Common. 

3 Select Nameplate Information then click the Add button to insert the Nameplate 
Information Test Step.

If your EUT is powered ON, you can press the green arrow key  or right-click 
the Nameplate Information step and select Run Select Test Steps.

Once executed, the results display in the Test Step Settings.

EUT Control  > Common > Nameplate Information Test Step should only 
be added BEFORE the Grandparent step or AFTER the last Child 
step beneath the Grandparent step. You can run the Nameplate 
Information Test Step by itself by right-clicking on it and selecting 
Run Selected Test Steps or pressing F10. You MUST power the 
EUT separately, since this Step does NOT configure the AC or DC 
Source to power the EUT. Some EUTs can power from either AC or 
DC. f you have an SL1200A Grid Emulator or DC Source, you can 
use the SL1200A Soft Front Panel to power the EUT.
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Section 5.10 Unintentional Island Test Steps

This step, called the “Parent Step” specifies parameters that affect all the child 
Steps that follow. Also, the initial settings of this Step are affected by its Parent 
Step - which specifies the Normal and Abnormal Categories. The following 
shows the Test Step Settings for this Parent Step: 

The default settings are according to the IEEE 1547.1-2020 Standard. You are 
allowed to change many of them, and the changes will be reflected in the Test 
Plan and in the Report. For example, if you wanted to see how well the EUT is 
operating, you could lower the Operating Tolerances from 5% to 3% to see if the 
EUT passes that stricter requirement. However, a Red circle ( ) will appear next 
the parameter changed, and the Test Report will reflect the change to the 
Standard. It would be up to the auditor of the test results to determine if any 
changes invalidate the test results.
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Section 5.10 Measure Sustained Island Test Step

When running one of these five Steps for the first time, the software prompts you 
to turn the Anti-Island Algorithm OFF in the Power Inverter. You don’t want the 
Power Inverter to shut down within the specified two second time period. You 
want the Island to persist when the SL1221A RLC emulation matches the 
impedance of the Power Inverter.

If running in the EUT Manual mode (under the EUT profile), the software prompts 
you to configure the EUT to default Test Case . Otherwise, with EUT SunSpec 
ModBus operation, the EUT is automatically configured to these settings.

This Sustained Island Step specifies parameters that affect its operation. There 
are five Sustained Island Test Steps, and many of the parameters are changed 
dependent upon the type of test to be conducted. The first Step defaults to the 
Test Case 1 configuration. The remainder of the Sustained Island steps push out 
the limits of voltage and frequency, so you can test the four corners of Voltage 
and Frequency. Only parameters you should be concerned with are as follows:

– Waveform Capture Period: For Sustained Island, the PHIL controlled 
environment must create an island that lasts at least 10s. The test fails if 
island does not sustain itself for at least 10 seconds.

– Pause While In Island: Normally, the test only lasts for the about 14s. If you 
want the Grid Emulator to pause after the island event is triggered, check 
this box, and the island condition lasts as long as possible for external 
measurement evaluation of Voltage and Frequency, which should be very 
close to the Grid Voltage and Frequency initially applied. However, now 
the Voltage and Frequency are the result of the matched RLC impedances, 
which will be slightly different than the original Grid signals.
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The Step Status panel in the Test Step Settings for each Step shows the progress 
of the particular Step when it is executing. Selecting this Step while Running 
permits you to visualize the Step Status information in detail. Key information is 
also represented in the Test Step Status Panel along with the real measurements 
being made during the test sequence. 

Section 5.10 Measure Clearing Time Test Step

When running one of these ten Steps for the first time, the software prompts you 
to turn the Anti-Island Algorithm ON in the Power Inverter. That is, you want the 
Power Inverter to shut down within the specified 2 second time period if the Grid 
goes away. 

When running in the EUT Manual mode, the system prompts to configure the 
EUT to the appropriate setting for the particular test case, category, and 
operating modes, as specified in the EUT Profile. Otherwise, with EUT SunSpec 
ModBus operation, the EUT is automatically configured for you..

The Measure Clearing Time Step specifies parameters that affect its operation. 
There are ten Measure Clearing Time Test Steps, and many of the parameters are 
changed dependent upon the type of test to be conducted. Only parameters you 
should be concerned with are the Exploration Methods:

– Exploration Method: Default is Automated Trend Analysis, where the 
percentage points list (specified in the Parent Step) is implemented, and 
any additional points are automatically added to meet the other 
requirements in the Parent Step. For example, the Trend Analysis in the 
Parent Step specifies there must be at least 4 Exploration Points to the 
Right and Left of the highest clearing time point. If there are only 3 on the 
Right side of the “Bell Curve” after running through percentage points 
95-105%, then point 106% is added. This continues until the criteria is 
met.
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The other option is Manual Search, where a prompt will be given after 
traversing the Percentage List found in the Parent Step. You can then add 
your own percentage points.

– Waveform Capture Period: For Clearing Time, the Power Inverter must shut 
down within 2s. The test fails if the island does not cause a trip in less than 
2 seconds for any specified percentage point.

The Step Status in the Test Step Settings shows the progress of this particular 
Step when it is executing. Selecting this Step while Running permits you to 
visualize this information.

This information is also represented in the Test Step Status Panel along with the 
real measurements being made at each sub-step. 

Status Panel

The Status Panel is constantly updated as each test runs. You can watch and 
monitor test progress by watching the Status Panel.

Shows the measured values of the AC 
Emulator during the tests. For Split-Phase 
configuration, only Phase 1 and Phase 2 
should show active results.

DC Source measurements show the Power 
Inverter is in regulation and that it requires 
12.24 kW of DC power to produce the 4 kW 
AC power per phase.

At this power level, these would be the RLC 
components necessary to cause a proper 
island condition after auto tunning.

At the time this panel was captured, the 
RLC values had not been calculated and 
the island event had not taken place.

These are the expected steady-state Real 
power and Reactive power settings per 
phase for this test.
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Running a Test Plan

It is recommended that you run all five Measure Sustained Island Steps 
individually or as a group. It is also recommended that you run each Measure 
Clearing Time Step individually. Although the 10 Clearing Time Steps can be run 
automatically, you are likely to see issues with proper operation if this is the first 
time you have run the Step. Running them individually will give you confidence 
they are working properly, so you don’t have to abort the Test Plan to stop all 
testing when one Step is not working properly. Therefore, right-click on any of 
the 10 lower-level Steps and select Run Selected Test Steps.

Running a Measure Sustained Island Step

You will be prompted to turn OFF the Anti-Island and any other mode that might 
cause the Power Inverter to shut OFF automatically. If you are running multiple 
Sustained Island Step in sequence, you will only see the following Dialog once.
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In Manuel EUT Mode (from the EUT profile), you will also be asked to configure 
the Power Inverter for either the specified test case or to turn off all voltage and 
frequency limits. For example, here is the Dialog for the remaining four Sustained 
Island Steps.

When the Measure Sustained Island Test Step is running, the Test Step Status 
panel shows the settings, measurements, and progress
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When this Step finishes, it Passed with a Green banner, and the Measure 
Sustained Island Panel shows the results – that the Sustained Island lasted for at 
least 10 seconds:
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Running a Measure Clearing Time Step

You will be prompted to turn ON the Anti-Island and any other mode that might 
cause the Power Inverter to shut OFF automatically. If you are running multiple 
Measure Clearing Time Steps in sequence, you will only see the following Dialog 
once.

You will also be asked to configure the Power Inverter for the specified test case 
when in Manual EUT Mode (from the EUT profile).

When the Measure Clearing Time Test Step is running, the Test Step Status panel 
shows the settings, measurements, and progress for each test iteration. Default 
is running iterations 95-105%. Note that the Parent Step holds this default List of 
Percentages for all Clearing Time Steps. Also note that the sequence of the 
percentages follows an alternating pattern, so you can see each side of the 
clearing time response being exercised during the test. This alternating on either 
side of 100% can allow you to abort the test quicker if you see one side or the 
other misbehaving.
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As another example, here are the results of the 95-105% iterations:
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You can also use ranges. For example, if you had entered: 90:94,106:110, the 
following response occurs. Those 10 points will be tested and added to 
the Exploration points. The Verification Points are established by 
making two more Clearing Time measurements of the highest three 
Exploration Points including any points in between. In the image below, 
the three highest Exploration Points include points 101 and 102 since 
they are in between the highest points of 99,100, and 103. The IEEE 
1547.1-2020 Standard specifies all the points from 99 to 103 be 
measured two more times. 
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Measurements and Post Processing Directories

All the measurements and post processed results can be found at the following 
locations for either Clearing Time or Sustained Island Steps:

Walking down the directory hierarchy into the Clearing Time Test, we find Test 
Case 1:

Notice that this directory is time stamped, so that each time you run this 
Measure Clearing Time Step, you do not interfere with any of the previous 
measurements.
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CSV Measurement Files

The Measurements directory contains the measurements from all the percentage 
iterations. The files with just “log” contain the 20 kSa/s measurements of Voltage 
and Current. The “Systemlog” files contain the 1kSa/s RMS, Frequency, and 
Marker measurements. The following is just a short list of this directory, where 
test percentages were from 95 - 105%. Each percentage creates a file name 
based upon that percent. During the Reinforcement or Verification period where 
points are repeated, plus signs (+) are added for each repeated test point.
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The Post Processed Results / Processed Runs directory would have all the results 
of the Exploration percentages and the final analysis .csv files showing the 
performance of the EUT for this test case..
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PNG Waveform Files

Most of the PNG files found in the Processed Runs directory show waveforms 
created from the Measurements directory files, where the log and Systemlog 
contain the 20 kSa/s and 1 kSa/s measurements, respectively. Here is an 
example of the Clearing Time response at 95% change to the Capacitor:

This is the 20 kSa/s data. There is always 200 ms of measurements prior to the 
Island Event. The time from that event to where the voltage is below the 
expected threshold is the Clearing Time.

All PNG files are viewable from the Clearing Time and Sustained Island panels in 
the TAP Editor using a drop-down selection menu.
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A Additional TAP Functions

In this Appendix:
Color Theme page 87
Locking a Test Plan page 88

Unlocking a Test Plan page 89
Run Time Estimation page 90

Overview page 90
Usage page 90
Run Your Test Plan. page 92

Additional Notes page 93
Run Explorer page 93
Editor Settings page 94
Test Plan Estimation Capturing page 94

Color Theme

Select a color theme for the Test Editor by selecting Settings > Editor. Then select 
either Light, Dark, or Automatic (default). Almost all of the screen captures in this 
manual use the Light theme.

Color Theme (Light) — Light is black text on white background. Dark is white text 
on black background. 
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Locking a Test Plan

Keysight’s KS8400 provides a Test plan locking mechanism. Its primary use is to 
prevent accidental editing by test plan developers. This lock can easily be 
bypassed by clicking Unlock Test Plan.

There are two ways to lock a test plan:

- First Method: in the Menu bar, select File > Lock Test Plan.

- Second Method: In the Menu bar, select View > Panels > Test Plan Settings. In this 
panel, there is a checkbox to Lock/Unlock the test plan labeled Locked.

Alternatively, you can reach this panel by clicking the settings icon  
that is located next to the main test plan progress bar. This icon also 
provides a keyboard shortcut (Alt + E) to reach this same Test Plan Settings 
panel.
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A locked Test Plan shows a closed lock next to the Test Plan name:

Unlocking a Test Plan

To unlock the Test plan, either select File > Unlock Test Plan or select the settings icon 
and uncheck the Locked checkbox.,
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Run Time Estimation

Keysight's KS8400B Developer's GUI (the Editor) has built-in functionality to 
estimate Test Plan running time.

Overview

To access this functionality, add a Result Listener to your configuration that 
implements IResultStore (interface that defines result listener plugins with the 
capability of storing result data). There are currently two result listener plugins 
that implement this: SQLite and PostgreSQL. PostgreSQL requires having the 
database type preconfigured to establish a connection; SQLite works without 
preconfiguration. The following example uses the SQLite result listener plugin.

Usage

1 To add the SQLite and PostgreSQL Database Result Listener plugins, go to 
Tools > Package Manager and install this plugin.
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2 Add an SQLite Result Listener plugin to your configuration. This can be done 
in one of two ways:

a On the Menu bar on the top of the GUI, select Settings > Results.

b On the Resource Bar at the bottom of the GUI, click on Results Add New.

3 In the Settings window, within the Results tab, click the  icon to add a new 
Result Listener. Go to Database > SQLite and click Add.

4 Click OK in the Settings window to save your changes and add SQLite as a 
Result Listener.
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Run Your Test Plan.

On the first test run, there is no predicted test time. The second test run, and any 
following test runs of that same test plan, show an estimation of test run 
duration. This shows up as a tooltip when you hover your mouse over the 
progress bar above the Test Plan. The progress bar also adds an additional 
comment about running x% faster/slower than the average. 

Additionally, individual test steps also provide a tooltip showing the expected 
duration for that test step.

During the test plan run, the progress bar changes to show remaining time after 
the first run and shows the amount of time over the expected test duration.
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Additional Notes

Run Explorer

The SQLite database result listener stores TAP metadata related to the test run. 
View this data in KS8400B's Run Explorer. To view this, you can go to Tools > Run 
Explorer in the Menu bar.

This view shows every test run stored within this SQLite database. Add additional 
column headers to view by right clicking the header bar and adding a new item. 
The image below shows the Duration column to get a quick view of the test times 
of all the Test Plan runs the SQLite database stored. The run data persists 
outside of the current session, so reopening the editor and running the same 
saved test plan will still give an test time estimation. Use the Run Explorer to 
delete test runs that are considered outliers in test time. 
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Editor Settings

You can control how many test runs are used to calculate the average test run 
time. This is configurable in Settings > Editor under Duration Estimation Avg. Count. 
The default value for this setting is the last 10 runs.

Test Plan Estimation Capturing

The Editor calculates test run time averages for test plans that are exactly the 
same. If you change a test step setting value in the test plan and run the updated 
plan, it counts as the first run of that test plan, therefore not calculating an 
average test duration (on its first run). Reverting the test plan back to its original 
state causes the estimation to use its previous duration values again.
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