Agilent Technologies

Agi'lent N5411B Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411B Software Version 1.71

Released Date: 23 May 2014

File Name: SetupInfSATA6G01710000.exe
Minimum Infiniium Oscilloscope Baseline Version:

Window XP : 4.20.0000 (90000 and 90000X)
Window 7  : 4.60.0005 (90000 and 90000X)

Minimum JBERT-B Firmware Version: 6.80

Additions:

Support for Serial ATA Interoperability Program Revision 1.5.0 Unified
Test Document.

Support user configurable OOB sequence with/without D10.2 (Device) or
ALIGN (Host). Please refer to Programmer’s Reference for more details
(see Help > Remote Interface).

Support user configurable ISI Filter Leading Bit and Lagging Bit for
Transmit Jitter test. Please refer to Programmer’s Reference for more
details (see Help > Remote Interface).

InfiniiSim now includes new Normalize Gain option.

Modifications:

Note:

Fixed the issue of missing SSC profile in PHY-03 Spread-Spectrum
Modulation Frequency test and PHY-04 Spread-Spectrum Modulation
Deviation test.

Fixed the issue of TSG-03 Differential Skew test.

Fixed the issue of signal clipping in TSG-04 AC Common Mode Voltage test.
Fixed the issue of TSG-13 Gen3 (6Gb/s) Transmitter Jitter used RJ test of
invalid total jitter limit.

Fixed the issue of the progress window appear in the screenshot of the report.
Fixed the issue of unhandled error when running in MSO oscilloscope.
Remote Interface updated to version 2.50.

Fixed Connection tab "Suppress" checkbox.

When using BitifEye BIT2100 instrument for switch matrix, now requires
minimum firmware version: 3.4-1.10.

This will be the last version to support Infiniium Oscilloscope Baseline Version
4.20.
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Agilent Technologies

Agi'lent N5411B Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411B Software Version 1.70

Released Date: 13 December 2013

Minimum Infiniium Oscilloscope Baseline Version:
Window XP : 4.20.0000 (90000 and 90000X)
Window 7  : 4.60.0005 (90000 and 90000X)

Minimum JBERT-B Firmware Version: 6.80

File Name: SetupInfSATA6G01700000.exe

Additions:

e Update tests to support UTD 1.5.

e Update and add tests to support u interface.

e Support for BIST mode automation by loading the JBERT sequence file
and pattern file.

e Support for pattern checking. Please refer to Programmer’s Reference for
more details (see Help > Remote Interface).

e Support for user configurable jitter test's CDR setting under debug mode.
Please refer to Programmer’s Reference for more details (see Help >
Remote Interface).

e Support for user configurable low pass filter's bandwidth for OOB signal
detector. Please refer to Programmer’s Reference for more details (see
Help > Remote Interface).

e Support for OOB Gap Detection Windows debug under debug mode.
Please refer to Programmer’s Reference for more details (see Help >
Remote Interface).

e User can now suppress connection prompts from the user interface (see
Connect tab).

e If a project opens as Read-Only and there are no settings conflicts with the
current version of the app, user may use File > Save Project (Settings-Only)
As... menu item to extract the configuration (and no results) from that project.

e If user creates the folder:

(Win7) C:\ProgramData\ Agilent\Infinium\Apps\<app_name>\app\scripts

(WinXP) C:\Documents and Settings\All Users\Application
Data\Agilent\Infiniium\Apps\<app_name>\app\scripts

Then menu item File > Execute Script... becomes visible and enables user to

pick a file to execute (e.g a.Python or Visual Basic script). Scripts in this

folder may also be executed via the Automation tab or remote interface.

e HTML reports include probe info.
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Agilent Technologies

Modifications:

Projects saved by previous versions of this application will open in read-
only mode.

Update the test limit for Spread-Spectrum Modulation DFDT to range of
+/-1250ppm/us for both minimum and maximum measurement.

Update the OOB signal sequence for device DUT by adding the D10.2
pattern in the sequence for COMWAKE response.

Update the SATA CIC embedding by using InfiniiSim.

Last location when saving/opening/exporting project/ files/etc. will be
saved.

ARSL scripts supports for .txt file extension.

Last Test Date reported using international format.

Fixed launch on Win7 for non-admin user.

Fixed statistics display for items in the Referenced Values section.
Preserves line breaks for “User Comments” field in HTML Report.

Includes new Delay option in InfiniiSim.

New option to control jump behavior when user double-click a test name on
the Select Tests tab. See View > Preferences > Report.

Remote Interface updated to version 2.40.
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Agilent Technologies

Agi'lent N5411B Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411B Software Version 1.65
Released Date: 16 July 2013

Minimum Infiniium Oscilloscope Baseline Version: 3.21 (90000 and 90000X)
Minimum JBERT-B Firmware Version: 6.80
File Name: SetupInfSATA6G01650000.exe

Additions:

e Support for MSOX Infinilum oscilloscope.
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Agilent Technologies
Agi'lent N5411B Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411B Software Version 1.64
Released Date: 27 July 2012

Minimum Infiniium Oscilloscope Baseline Version: 3.21 (90000 and 90000X)
Minimum JBERT-B Firmware Version: 6.80

File Name: SetupInfSATA6G01640000.exe

Additions:

e InfiniiSim feature is now available during the run for all PHY tests and TSG
tests. InfiniiSim feature can be access through the main menu (see
Tools > Infiniium > InfiniiSim).

Modifications:

e The COMRESET/COMINIT response detection window increased from
10.0us to 20.0us.

e Fixed the issue of slow measurement of OOB-2/3/4/5 OOB signal
Burst/Gap Length test using Infiniium 3.50.0001.

e Fixed the issue of wrong judgment for the COMWAKE response (non-
continuous ALIGN response from the device DUT).
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Agilent Technologies
Agi'lent N5411B Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411B Software Version 1.63

Released Date: 17 April 2012

Minimum Infiniium Oscilloscope Baseline Version: 3.21 (90000 and 90000X)
Minimum JBERT-B Firmware Version: 6.80

File Name: SetupInfSATA6G01630000.exe

Additions:

e Support latest baseline 3.21.

e Additional test added for UTD 1.4.3. Please refer to the Table 1.63.1.

e Project file of SATA application version 1.62 and below is treated as read-
only.

e User may disable the use of SATA CIC via “Use SATA CIC” in Configure
tab. Please refer to Programmer’s Reference for more details (see Help >
Remote Interface).

e User may select the frequency window for the TSG-16 Gen3 (6Gb/s) Tx
AC Common Mode Voltage measurement via “FFT Frequency Window,
Min” and “FFT Frequency Window, Max”. Please refer to Programmer’s
Reference for more details (see Help > Remote Interface).

Modifications:

e Several tests changed to informative test for UTD 1.4.3. Please refer to
the Table 1.63.1.

e Change of the TSG-02 Rise/Fall Time test limit for UTD 1.4.3.

e Change of the PHY-01: Unit Interval and PHY-02: Frequency Long-Term
Stability default Sample Size from 100,000 to 200,000 Ul to covers at least
one SSC profile.

e Change of the stimulus differential voltage output to 600mV for
Compliance mode of non-OOB test.

e Bandwidth Limit feature for acquisition setup is available for both
Compliance and Debug Mode. To access the Bandwidth Limit feature see
menu: Tools > Infinilum > Acquisition Setup.

e Fixed ALIGN field detection issue for OOB COMWAKE test.

e Remove the config “Memory Depth” for TSG-16 Gen3 (6Gb/s) Tx AC
Common Mode Voltage measurement.
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“Before UTD 1.4.3

UTD 1.4.3
Test Test Comments
Test Name D Test Name D
TSG-01[b] : Differential TSG-01[b] : Differential Chande to Informative Test in all
Output Voltage (Max) 20121 Output Voltage (Max) 20121 9 UTD
(Informative) (Informative)
20211 20231
R 20212 TSG-02[4] : Rise Time 20232 Change to Informative Test in
TSG-02[a : Rise Time 20213 (Informative) 20233 UTD 1.4.3.
20214 20234
20221 20241
_ , 20222 TSG-02[a] : Fall Time 20242 Change to Informative Test in
TSG-02[a] : Fall Time 20223 (Informative) 20243 UTD 1.4.3
20224 20244
TSG-03[a] : Differential 20311 TSG-03[4] : Differential 20331 Change to Informative Test in
Skew, HFTP 20312 | Skew, HFTP (Informative) | 20332 UTD 1.4.3
TSG-13[a] : RJ before CIC, TSG-13[a] : RJ before CIC, . .
MFTP, Clock To Data, JTF | 20311 | MFTP, Clock To Data, JTF | 21312 | Change to Informative Test in
! ! . UTD 1.4.3
Defined Defined (Informative)
. TSG-13[f] : TJ after CIC,
TSG-13[f] : TJ after CIC, HFTP, Clock To Data, JTF Change to Informative Test in
HFTP, Clock To Data, JTF | 21511 : - 21517
. - Defined (BER=1E-12) UTD 1.4.3
Defined (BER=1E-12) (Informative)
) . TSG-13[qg] : TJ after CIC,
I-|rFST?3 1C3:I[g] - TJ after CIC, HFTP, Clock To Data, JTF Change to Informative Test in
, Clock To Data, JTF | 21513 , Z 21517
) - Defined (BER=1E-6) UTD 1.4.3
Defined (BER=1E-6) (Informative)
) ) TSG-04 : AC Common 20412 New test added in UTD 1.4.3 for
Mode Voltage, HFTP 3.0Gb/s
) TSG-04 : AC Common 20423 New test added in UTD 1.4.3 for
j Mode Voltage, MFTP 6.0Gb/s
) _ TSG-04 : AC Common 20424 New test added in UTD 1.4.3 for
Mode Voltage, HFTP 6.0Gb/s

Table 1.63.1
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Agilent Technologies

Agi'lent N5411B Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411B Software Version 1.62

Released Date: 2 February 2012

Minimum Infiniium Oscilloscope Baseline Version: 3.21 (90000 and 90000X)
Minimum JBERT-B Firmware Version: 6.80

File Name: SetupInfSATA6G01620000.exe

Additions:

e Support latest baseline 3.21.

e Support for various Unified Test Document version. UTD 1.1, UTD 1.2,
UTD 1.3, UTD 1.4, UTD 1.4.1, UTD 1.4.2, UTD 1.4.3. Please refer to each
Unified Test Document for tests details.

e Addition Transmit Jitter informative tests for SSOP, MFTP and LFTP test
pattern. “Hide Informative Tests” check box to hide all the informative tests.

e User-defined compliance limits feature for user to select, edit and create
tests limit. This feature can be access through the main menu (see
Tools > Compliance limits).

e Bandwidth Limit feature for acquisition setup set the frequency limit to be
used during a run for all PHY tests and TSG tests ONLY (Debug Mode
only). To access the Bandwidth Limit feature see menu: Tools >
Infinilum > Acquisition Setup.

e Infiniium’s Precision Probe and Precision Cable feature configuration
setup can be accessed through the main menu (see Tools > Infiniium >
PrecisionProbe/PrecisionCable).

e Remote interface help and PDF files can be accessed through the main
menu (see Help > Remote Interface).

e New ‘Automation’ tab enables you to create command scripts that modify
settings and execute tests.

e New user preference to set default project location (Menu: View >
Preferences > Save/Load : Default Location).

Modifications:

¢ Change of the test display name according to UTD.

e Change of the Rise/Fall Time test limit based on ECNO053 for 6Gb/s
Rise/Fall Time max limit from 68ps to 80ps.

e Change of the Spread-Spectrum Modulation DFDT limit from +/- 1200pp
to +/-1250ppm.

e Change of the TSG-04 AC Common Mode Voltage measurement
bandwidth to 200MHz to 4.5GHz for UTD 1.4.2.
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Change of the TSG-15 Minimum Differential Voltage Amplitude eye height
measurement location at 0.50 Ul from [0.45Ul, 0.55Ul].

Change of the OOB-03 COMINIT/COMRESET and COMWAKE Transmit
Burst Length limit to [103.5ns, 110.9ns] from [103.5ns, 109.9ns] for UTD
1.4.1 and above.

Change of the OOB-05 COMWAKE Transmit Gap Length limit to [102.4ns,
109.9ns] from [103.5ns, 109.9ns] for UTD 1.4.1 and above.

Fixed issue for the OOB trigger algorithm.

Fixed issue for the OOB Signal Detection Threshold of file is not found.
Fixed issue for the 6.0Gb/s Tx Differential Output Voltage (Minimum) error.
PrecisionProbe dialog screens now have tooltips and remote hints.

A calibration creation wizard is added to the PrecisionProbe dialog box.
Now supports Remote Interface version 2.00. For more information, see
Agilent’s N5452A Remote Programming Toolkit
(www.agilent.com/find/scope-apps).

Fixed app startup under Windows Standard User login.
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Agilent Technologies

Agi'lent N5411B Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411B Software Version 1.61
Released Date: 30 September 2011

Minimum Infiniium Oscilloscope Baseline Version: 3.10 (90000 and 90000X)
Minimum JBERT-B Firmware Version: 6.80
File Name: SetupInfSATA6G01610000.exe

Additions:

e Supports Win 7.

Modifications:

e No Modification
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Agilent Technologies
Agi'lent N5411B Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411B Software Version 1.60

Released Date: 12 August 2011

Minimum Infiniium Oscilloscope Baseline Version: 3.10 (90000 and 90000X)
Minimum JBERT-B Firmware Version: 6.80

File Name: SetupInfSATA6G01600000.exe

Additions:
e Supports latest baseline 3.10.

Modifications:

e Vdiff Test for Gen3i modified for ECN50.
e Remote TestIDs Changes (see Remote User Changes Table below):
1. TestID Merge: Auto substitution by app, this ensures backward
interoperability:
= 20112,20113, 20114 -> 20111
= 20122,20123, 20124 -> 20121
2. TestID Split:
= Original 20115
e 20115 for Drive Tests only
e 20116 for Host Tests only
e Fixed Gen3i TX AC Common Mode Voltage Test FFT 3G Conversion
Factor to 250hm Common Mode Type Termination (FFTdBmV3G =
FFTdBmM3G + 43.9794), previously incorrectly referenced to 500hm
Termination
e Fixed Genl & 2 Vdiff MAX Test(Informative Test) histogram hits issue.
Each section of the test does not complete the required number of
acquisition before proceeding to the next section.
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Remote User Changes:

Old TestIDs New TestIDs Action
20112 20111 Merge to 20111
20113 20111 Merge to 20111
20114 20111 Merge to 20111
20122 20121 Merge to 20121
20123 20121 Merge to 20121
20124 20121 Merge to 20121
20115 20115 Split: For Drive Test
20116 Split: For Host Test
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Agilent Technologies

Agi'lent N5411B Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411B Software Version 1.50

Released Date: 11 Feb 2011

Minimum Infiniium Oscilloscope Baseline Version: 3.03 (90000 and 90000X)
Minimum JBERT-B Firmware Version: 6.80

File Name: SetupInfSATA6G01500000.exe

Additions:

e Supports latest baseline 3.03.
e Supports N4903B J-BERT as stimulus in addition to 81134A Pulse Pattern
Generator.

1. The calibration procedure for J-BERT does not require the use of
attenuator. It might not work well if attenuators are added to the
connections.

e Adds Jitter measurement 1E-12 and 1E-6 for Genl,2,3.

Modifications:

e Improved Calibration Routine GUI.
e Improved GUI user model logics. SSC, ASR, BIST Mode Options now
grouped under “Capabilities” Group.
e Modified COMWAKE Response tests lower and upper boundary to 153Ul
and 167Ul respectively according to ECN.
e Remote Programming Variable Changes, notably
1. [OptConnection] now provides 5 options “none”, “PPG_IP",
“‘PPG_Sicl”, “JBERT_IP”, “UBERT_Sicl”.
2. [HostASR] provides “1.0” as checked option, and “0.0" as
unchecked option.
3. [BISTMode] provides “BIST-L” and “BIST-T” options (replaced older
config variable [TPSource])
e Connection Diagram now includes JBERT’s instruction
e Miscellaneous changes on the OOB tests verification due to
accommodate changes in the baseline system.
e Default 81134A and N4903B voltage to 600mV single channel setting on
the pattern generator
e Selecting debug mode in configure tab will not uncheck the selected tests
in select test tab
e Averaging is now disabled in Gen3i AC Common Mode Test Group
e Host ASR enabled: COMWAKE min & max Response Test: Previously
there is an issue of some hosts treating the COMINIT from the stimulus
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instrument to be an unsolicited COMINIT sometimes with a certain
probability, which results in an initial COMRESET reply from host instead.
In this version, the app will now retry 10 times to re-fire the stimulus
instrument (81134A or N4903B) to get an initial COMWAKE, whereby
from the host’s perspective, is supposed to be an in reply to a solicited
COMINIT from the stimulus instrument.

Additional Note:

e Please ensure the Infiniium Scope has at least 25Mpts installed for
compliance test. The tests could still be run, however the tests may not
run correctly.
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Agi'lent N5411B Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411B Software Version 1.30

Released Date: 20 Sep 2010

Minimum Infiniium Oscilloscope Baseline Version: 2.51 (90000) and
2.95(90000X)

File Name: SetupInfSATA6G01300000.exe

Additions:
e Supports White/Pink noise selection for Jitter test.
e Adds Jitter measurement selection at BER 1E12(default) and
1E6(informative).

Modifications:

Fixed Far End Retimed Connection Diagram loading too slow issue

Fixed missing Jitter Tests Periodic/Arbitrary selection in configure tab

Fixed missing MFTP test when Pulsegen Usage = “No” and SSC = “Yes”

Fixed AC Common Mode Test for Gen3 dbm to dbmV conversion factor to

43.9794. => FFTdBmV6G = FFTdBmM6G + 43.9794

e Remote Test: Configured a default response for BIST-T/BIST-L dialog
during “messagebox suppression”

e Modified Jitter Test Gen3i Criteria, now consists of tests below:

RJ Before CIC

TJ Before CIC HFTP, using RJ

TJ Before CIC LBP, using RJ

TJ after CIC HFTP, using RJ

TJ after CIC LBP, using RJ

TJ 1E12 after CIC HFTP

TJ 1E6 after CIC HFTP

TJ 1E12 after CIC LBP

TJ 1E6 after CIC LBP

©CoNoh,rwhE
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Agi'lent N5411B Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411B Software Version 1.20

Released Date: 22 January 2010

Minimum Infiniium Oscilloscope Baseline Version: 5.71 (80000B), 2.10
(90000 series)

File Name: SetupInfSATA6G01200000.exe

Additions:

e Supports Baseline 2.10 for 90000 Series
e Adds Jitter measurement selection at BER 1E12(default) and
1E6(informative)
e Jitter test reports additional DCD Jitter value(informative), this value does
not affect overall Jitter results calculation.
e Remote Interface Variable Changes:
1. Added [JitterAtBER]

Miscellaneous Notes:

e This will be the last version to support the 80000 series oscilloscope.
Following releases will only support 90000 series oscilloscope.
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Agi'lent N5411B Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411B Software Version 1.11
Released Date: 21 December 2009

Minimum Infiniium Oscilloscope Baseline Version: 5.71 (80000B), 2.01
(90000 series)

File Name: SetupInfSATA6G01110000.exe

Modifications:

e Fixed OOB detection threshold test not able to run if non-debug mode
calibration is selected issue.
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Agi'lent N5411B Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411B Software Version 1.10

Released Date: 23 November 2009

Minimum Infiniium Oscilloscope Baseline Version: 5.71 (80000B), 2.01
(90000 series)

File Name: SetupInfSATA6G01100000.exe

Additions:

e Added Loopback mode for Gen3i

e Added Debug capability for OOB Vthresh Test to downsweep from defined
voltage level voltage to a threshold level that has 1st encountered rejected
response.

e Added Gen3i Minimum TX Differential Voltage
e Support for baseline 5.71 (80000B) and 2.01(90000A)

Modifications:

e Replaced SATA Gen3i.txt S parameter file for CIC with standardized
SATA-10 s4p file.
e Gen3i AC Common Mode Test:
o Allow peak to peak measurement from -5350ppm to 350ppm at
both 3Ghz and 6Ghz
e Jitter Tests:
o Baseline modified Jitter Algorithm to improve measurement
accuracy
o 90000A scopes increased target memory data length to 2.048Mpts
using default arbitrary mode
o Restructured jitter test configure options with enhanced
descriptions
e Thresholds Definitions:
o Uses Hysteresis centered 0 +/- 10mV for all TSG tests except for
rise/fall time related tests.
e Gen3i Maximum TX Differential Voltage
o Vertical markers measurement boundary redefined to +/- 2UI
centered about the trigger.
¢ Gen3i Minimum TX Differential Voltage
o Explicitly show out measurement details: Eye Height = (Vtop_mean
— 3 Vtop_stddev) — (Vbase_mean — 3 Vbase_stddev).
¢ Remote Interface Variable Changes:
o [Jitter_DatalLength] moved to debug mode
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o [Jitter_DatalLength] and [Jitter_PatternMode] are only asserted
when [OverridelitterDefault] setting is “ENABLED” in debug mode.
o Added [DifferentialSkew_RetrialGlitch]
o Redefinition and addition:
= [VthreshDebugResponsetolnconsistent]
= [VthreshDebugResponsetolnconsistentStartVdiff]
= [VthreshDebuglnconsistentToReject]
= [VthreshDebuglnconsistentToRejectStartVdiff]
e OOB testing for Gap/Vthresh Response Verification Testgroup: increased
Sampling rate to 10GSa/s to preserve better signal integrity prior to low
passed filtering. This will also enhance OOB response detection precision.
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Agi'lent N5411B Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411B Software Version 1.02

Released Date: 24 April 2009

Minimum Infiniium Oscilloscope Baseline Version: 5.60 (80000B), 1.40
(90000 series)

File Name: SetupInfSATA6G01020000.exe

Modifications:

e Fixed the conversion error in the AC Common Mode Test where the
HTML Compliance report now uses the correct reporting unit of “domV”
instead of “dbm”.

e Modified the Max TX Vdiff test for Gen3i, to use acquisition averaging
instead of histogram peak to peak (worst case amplitude).

e Fixed the Jitter Gen3i specification interpretation issue, whereby the “Total
Jitter(TJ)” is now extracted directly from the Jitter Results Panel.
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Agi'lent N5411B Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411B Software Version 1.01
Released Date: 16 March 2009

Minimum Infiniium Oscilloscope Baseline Version: 5.60 (80000B), 1.40
(90000 series)

File Name: SetupInfSATA6G01010000.exe

Modifications:

e Fixed the Genlim and Gen2im Jitter Tests loop bandwidth error.
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Agi'lent N5411B Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411B Software Version 1.00

Released Date: 9 Feb 2009

Minimum Infiniium Oscilloscope Baseline Version: 5.60 (80000B), 1.40
(90000 series)

File Name: SetupInfSATA6G01000000.exe

Additions:

e Added Gena3i group of tests for BIST-T mode which include:

O O O O O

(@]

Channel Speed, FBaud & Unit Interval
Frequency Long Term Stability
TX Differential Voltage Test ( Maximum)
TX Rise/Fall Time
TX Skew
= HFTP
= MFTP
TX AC Common Mode Voltage
TJ & DJ at Connector, Clk-Data
= RJ before CIC
= TJ before CIC, HFTP
= TJ before CIC, LBP
= TJafter CIC, HFTP
= TJafter CIC, LBP

e Obsolete the DC Coupled Common Mode Voltage Test.

e Matlab MCR Checking to force Matlab 7.5 only.

e Added OOB Gap/Vthresh % Thresholds for manual adjustment in case the
default threshold touches the low passed filter ripples.

Modifications:

e Amend the Vdiff Test:

@)
©)
©)

Reporting Statistics Redundancy
0.5 Ul to 0.45-0.55 in Genl
LBP waveform inaccurate timebase

e Fixed OOB Low Pass Filter Smearing Issue on 2GSa/s sampling rate
limitation by turning off the interpolation.
e Expanded UTD required patterns on the Select Test tab:

o

Test pattern option were removed for these tests

e To prompt message box only once for the same test pattern in the BIST-T

mode.
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Changed x Interface Jitter Tests from “at connector” algorithm to “after
CIC” algorithm.
Fixed x Interface Amplitude Imbalance timebase inaccurate problem.
Changed SSC Tests Sampling Rate from 10GSa/s to 20GSal/s.
Changed Rise/Fall Time to LFTP Test Pattern with 8Ul on screen.
Added cancel button to abandon the calibration request on the calibration
pop up dialog box.
Changed the Skew reporting variables to non-absolute values (“Tx+ Rising
to Tx- Falling” & “Tx+ Falling to Tx- Rising”) for debugging purpose,
however the final compliance result formula still remains the same as
intended by SATA-IO:

o Diff Skew = average( abs[ (mean (TX+ rising)) — (mean(TX- falling))]

+ abs[ (mean(TX+falling)) — (mean(TX- rising))] )

Changed SSC sampling rate for 90000A scopes to 40GSa/s and 80000B
scopes to 20GSa/s.
Limited the SSC maximum memory depth to 10Mpts in 90000A scope to
provide safety margin to match the baseline analysis memory limitation.

Known Issues:

In some very rare cases of OOB Burst and Gap Width measurement, the
desired COMINIT and COMWAKE bursts are not easily captured (the
probability of capturing is low) by using automation due to OOB response
inconsistencies. In such cases, the user should opt for manual testing or
retry manually.

Miscellaneous Notes:

Project files from the old N5411A SATAII application would not be able to
be loaded into N5411B SATAG6G application. The user should view the old
project files in an Internet Browser or by using the previous N5411A
application.
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Agi'lent N5411A Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411A Software Version 2.60

Released Date: 7 Nov 2008

Minimum Infiniium Oscilloscope Baseline Version: 5.50 (80000 series), 1.30
(90000 series)

File Name: SetupInfSATAII0260.exe

Additions:

Supports the Asynchronous Signal Recovery Host DUT Response in OOB
COMRESET/COMINIT/COMWAKE Gap Detection Windows and Vthresh
Tests
Added the Vthresh Debug mode that sweeps from upper boundary
Vthresh = 210mV stimulus (expected to give consistent response) to a
Vthresh level that gives the first Inconsistent Response from the DUT
In SATA_App_Remote_Prog_Ref.chm
o Added Remote Interface variables:
= VthreshDebugResponsetolnconsistent
= HostASR
o Removed Remote Interface variables:
= DebugAmplitudelmbalance

Modifications:

Changed the minimum baseline requirements to 5.50 (for 80000 Series)
and 1.30 (for 90000 Series)
Added the SSC Optimization Memory Buffer for the last SSC Acquisition
(if required)
Fixed the Advanced Communication Trigger not found error for the single
ended signals which is approximately below 200Vpp during the setup for
non-00B tests.
Added the Burst/Gap/Align tolerance as a workaround to OOB
Gap/Vthresh Detection due to the Low Pass Filter smearing issue.
Split the Spread Spectrum Modulation Deviation into two tests:

o Spread Spectrum Modulation Deviation (Max)

o Spread Spectrum Modulation Deviation (Min)
Split the Amplitude Imbalance test into two tests:

o TX Amplitude Imbalance HFTP

o TX Amplitude Imbalance MFTP
Enhanced the 90000 Scope Calibration Acquisition to 100 Acquisitions
Average for every calibration target pair.
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Fixed the 80000A Series scope calibration dialog box mismatch with the
windows resolution of 640X480.

Fixed the issue of Vthresh Change Connection dialog box hidden behind
the SATA application.

Enhanced the OOB Gap/Vthresh Detection comments field information in
the HTML Report

Changed the Amplitude Imbalance test to Real Time Eye Implementation
test to better match SATA-IO measurement definition and for faster
execution speed.

Known Issues:

In some very rare cases of OOB Gap and Vthresh tests, especially
‘Responds to in-spec COMWAKE' measurement, it is difficult to determine
a valid response by using automation due to the differences in SATA
product behavior. In such cases, the tester should opt for manual visual
verification. This control is located in the N5411A product’s Configure tab,
and is called ‘OOB Gap and Vthresh Detection mode. Select ‘Manual’.
This will allow the tester to determine either PASS or FAIL per the
specification’s requirement and mark the measurement correctly. This is
not the default mode.

In some very rare cases of OOB Burst and Gap Width measurement, the
desired COMINIT and COMWAKE bursts are not easily captured (the
probability of capturing is low) by using automation due to OOB response
inconsistencies. In such cases, the tester should opt for manual testing.

Supports the 54855 and 80000A Series scopes with limitation for the OOB
Gap/Vthresh Detection test due to the older scopes’ hardware graphics
limitation. It is recommended to use the Agilent 80000B or 90000A Series
Infiniium oscilloscopes with 12GHz or greater bandwidth with Agilent
N5411A Software version 2.60.
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Agilent N5411A Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411A Software Version 2.52

Released Date: 30 May 2008

Minimum Infiniium Oscilloscope Baseline Version: 5.40 (80000 series), 1.20
(90000 series)

File Name: SetupInfSATAII0252.exe

Modifications:

e Fixed the missing calibration information issue for the Vthresh Detection
Tests

e Fixed the missing MWArray.dll issue for the Skew Test

e Increased the OOB Trigger level to avoid triggering at power-up glitches
when acquiring the COMRESET

e Removed the long/short patterns option in the user configure tab

e Enhanced the AC Common Mode to be more robust in handling high AC
Common Mode Spikes

e Modified the RESETDUT Message Box of the Host OOB Tests

e Added filtering to the glitches in the skew measurement at certain parallel
edges which results to double Ul reporting (e.g. 666ps)

e Increased the number of images that can be reported to the maximum of
25 images

e Fixed the issue of pulse generator SICL address unable to close during
certain sequences.

e Increased timeout for the channel speed sample with the size of 500k

e Added retries to the Tx Differential Voltage Test in the event the trigger
fails in the BIST-TAS mode

e Fixed the popup consistency of the “Set DUT To OOB Mode” Message
Box

e Moved the ‘#aligns’ option from compliance mode to debug mode in the
configure tab

e Removed the additional COMRESET options in user configure tab

e Either 2*10dB attenuators or 2*20dB attenuators can now be used in the
calibration procedure

Page 26 of 32



Agilent Technologies
Agi'lent N5411A Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411A Software Version 2.51

Released Date: 29 Feb 2008

Minimum Infiniium Oscilloscope Baseline Version: 5.40 (80000 series), 1.00
(90000 series)

File Name: SetupInfSATAII0251.exe

Modifications:

e Modified from previous implementation of: two 10dBs or four 10dBs
attenuator (as illustrated in the calibration diagram) to two 20dBs
attenuator for Genl Host/Drive OOB Vthresh Rejection Test only. “using
attenuators” checkbox is removed.

e Modified the Long Term Frequency Accuracy Test to acquire the
maximum SSC cycles in Maximum Memory Available. The algorithm is
generic to 80000 and 90000 series scopes.

e Modified the OOB Vthresh Signal Detection Test Calibration procedure to
use Vampt measurement on 1 OOB Burst instead of using Vpp
measurement to take the corresponding voltages between the scope and
pulse generator.

e Modified the Skew Test to Matlab implementation, where Infiniiscan is no
longer required. The previous implementation uses the Infiniiscan
whenever available.

e Modified the connection diagram display logic to match the new attenuator
configuration requirements.

e Fixed the phenomena of inconsistent results issue in skew test.

e Provided workaround on the DUTSs that trigger error messages, reporting
unfound signal when the histogram is turned on. This occurs on 90000
series scopes only.
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Agi'lent N5411A Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411A Software Version 2.50

Released Date: 11 Jan 2008

Minimum Infiniium Oscilloscope Baseline Version: 5.40 (80000 series), 1.00
(90000 series)

File Name: SetupInfSATAII0250.exe

Additions:

e General Specifications and Transmitted Signal Requirements:

o Added periodic mode option for the Jitter Tests in the debug mode.

o Added Long Term Frequency Stability Test for the Non-SSC Tests

o Dynamic Test Pattern Generation with alignment to improve the
Loopback functionality

o Implemented Fbaud/500 or JTF Loop Bandwidth selection for the
Clock to Data Jitter Test. This selection is only available for i and m
interfaces. Removed the Data-Data Jitter Tests.

e Compliance Test Framework and miscellaneous:
o Supports baseline 5.40(80000 series) and baseline 1.00 (90000
series)
o Supports the Unified Test Document 1.2 and
o ECN 006 - FB10removal
o ECN 008 - fbaud/500 Jitter Parameter Clarification
o ECN 016 - Long Term Frequency Accuracy and SSC Profile
Tests for Transmitters
o ECN 017 - OOB Burst/Gap Duration Clarification
o Supports the Remote Interface Control
o Calibration and attenuators usage options:
= With attenuators, all tests are available. Calibration factors
which are generated by performing the calibration will be
required.
= Without attenuators, the OOB Signal Detection Threshold
tests will be hidden.

Modifications:

e OOB Specifications:
o Amended the UTD1.2: OOB1 Signal Detection Threshold boundary
limits at 40mV, 210mV for Genl, and 60mV, 210mV for Gen2
o Amended the UTD1.2: OOB6, OOBY:
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= Implemented a new algorithm for the
COMINIT/COMRESET/COMWAKE Gap Detection Windows
tests.
Amended the OOB Burst Length Test Information and Specification
to comply with UTD1.2

Amended OOB Gap Length Test Information and Specification to
comply with UTD1.2

For Host COMRESET tests, an additional COMINIT is sent to the
host after user resets the DUT.

e General Specifications and Transmitted Signal Requirements:

©)

o

Amended the specification range for the TX Differential Skew for

Gen2x from 20ps to 15ps.

Reduced the SSC Measurement test time by
o disabling interpolation
o sampling at 10GSa/s
o Memory Depth 1.03Mpts

Amended the Amplitude Imbalance Test for the HFTP and MFTP

patterns’ measurement algorithm.

o For the HFTP, it is required that the measurement points be
taken at 0.5UI of the bit within the pattern. All amplitude values
for this measurement shall be the mode value measured at 0.5
Ul nominal over a minimum of 10,000 Ul

o For the MFTP, it is required that the measurement points be
taken at 0.5Ul of the 2nd bit within the pattern. All amplitude
values for this measurement shall be the mode value measured
at 0.5 Ul nominal over a minimum of 10,000 Ul

Enhanced the “Sample Size” Configuration Variable to reflect the

approximated sample size values corresponding to the measured

edges.

Enhanced the Data Rate and Unit Interval Variables in the Unit

Interval Test to be able to correlate with each other.

Decreased the sampling rate and memory depth for the SSC Tests

to reduce the test time and also prevent the waveforms from being

discarded due to edges not found during the SSC Frequency

Measurement.

Amended the Skew Test Algorithm by using the measured mid

point value instead of zero value reference to measure the skew.

The new algorithm uses Infiniiscan, effectively reject the Aligns

whenever the Infiniiscan license exists.

Amended the Rise/Fall Time measurement to use the mean value

instead of the mode value.

Improved the Amplitude Imbalance Test reporting. The test reports

both HFTP and MFTP values instead of just the worst case value.
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e Compliance Test Framework and miscellaneous:

(@]

@)
©)

Improved the overall connectivity experience of the pulse generator
dialog box.
Added MultiTrials feature.
Amended the pattern files to comply with the latest 81134 pulse
generator commands.
Updated test references to SATA 2.60 Gold.
Connection Diagram Updated
= Differential probe is not needed anymore for OOB Signal
Threshold Detection Tests
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Agi'lent N5411A Serial ATA Electrical Performance
Validation and Compliance Software Release Notes

Agilent N5411A Software Version 02.01

Released Date: 18 Dec 2006

Minimum Infiniium Oscilloscope Baseline Version: 05.00.00
File Name: SetupInfSATAIITest0201.exe

Additions:

Selectable SSC Smoothing Point range in the DEBUG mode.

User can change the 81134A’s amplitude in the DEBUG mode.

Added dynamic vertical scaling for OOB related test when using the Mask
for COM Response tests.

Added signal checking and verification before test run.

SSC measurement algorithm is enhanced to work with DUTs with heavily
distorted SSC waveform. The algorithm is also enhanced to test and
measure multiple SSC if no edges are found during the acquisitions.
Added Trigger Verify for Basic Trigger Integrity checking before the test
run.

Modifications:

Fixed illegal timeout for Gen 2 Host TJ & DJ Measurement.

Updated Connection pages to include the DC Blockers into the illustration
Change timing for OOB related tests.

Added boundary limits to the number of Ul during OOB.

Rise / Fall Imbalance with results swapped for Tx- Rise and Tx- Fall.
Changed skew measurement technique due to MOI changes.

Added Amplitude Imbalance Test.

TJ / DJ measurement will report QUI if the measured TJ / DJ is in the
Femto Second Range.

Genl Jitter Description Data-Data was changed to Clock-Data.

SSC smoothing point for Genl and Gen 2 SSC measurement was
updated to 335 and 670 respectively.

Added break for OOB measurement. The previous implementation was
using a cancellation message box which will prompt for 6 times before the
test is canceled.

Connection page changed to include COMAX connector labeling.

Added checking to allow the usage of Periodic Jitter measurement if the
pattern selected is short ( 80 bits pattern ) whereas longer patterns will
use Arbitrary.
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e The entire host connection page had descriptions mismatched with the
illustration. The descriptions were updated.
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