Revision 2006-07-12

What's New in the User's Guide?

  • The contents have been updated and now include documentation for the E1966A 1xEV-DO Terminal Test Application, revision A.06 and E6706A 1xEV-DO Lab Application, revision A.03.

    • One of the most important updates is that the test set supports for 1xEV-DO Release A ETAP (Enhanced Test Application Protocol) which provides the standards compliant measurements required to test the TX quality of the access terminal at 1.8 Mbps while testing the receiver quality of the access terminal at 3.1 Mbps.

      NOTICE
      THE DELIVERY OF THE AGILENT PRODUCT DOES NOT CONVEY A LICENSE NOR IMPLY ANY RIGHTS TO USE THE "1xEV-DO REVISION A" CAPABILITY CONTAINED IN THE AGILENT PRODUCT. SUCH USE REQUIRES THE EXPRESS CONSENT OF OR A SEPARATE LICENSE FROM QUALCOMM INCORPORATED. CUSTOMERS AND PRODUCT USERS SHALL BE SOLELY RESPONSIBLE TO OBTAIN SUCH CONSENT OR LICENSE FROM QUALCOMM INCORPORATED IN CONJUNCTION WITH THE USE OF THE "1XEVDO REVISION A" CAPABILITY.

      See the Release Notes for more information.

  • If you have the E6703T Special 1xEV-DO Lab Application, click here to learn how this guide applies to you: E6706T User Documentation .

Note: If you have a 1xEV-DO application or revision other than those referenced above, see the Release Notes to download the guide that is specific to your application.

Take Advantage of Your 1xEV-DO Mobile Test and Lab Applications

  • Click on the links in the Contents box to find specific information about your test and lab applications.

  • To download a portable version of this online user's guide, click on the Downloadable Manual link and select the latest CHM Help File.
  • If you are unfamiliar with this product, or don't know where to find the information you need, see Getting Started with the 1xEV-DO Terminal Test and Lab Applications .


Legal Information

Acknowledgements

Microsoft ® is a U.S. registered trademark of Microsoft Corporation

Windows ® and MS Windows ® are U.S. registered trademarks of Microsoft Corporation.

Adobe ® Acrobat ® are trademarks of Adobe Systems Incorporated.

Notice

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as "Commercial computer software" as defined in DFAR 252.227-7014 (June 1995), or as a "commercial item" as defined in FAR 2.101(a) or as "Restricted computer software" as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

© Agilent Technologies, Inc. 2001


Data Connection Processing

Data Connection Processing

Last updated: June 19, 2006

This page provides links to descriptions of the numerous settings and operations available in the test set for base station emulation and data connection processing including: Access Network Emulator Configuration , Access Terminal Information , Data Connection Processing Overview , Test Set Operating Modes and General Information .

If you have trouble finding the information you need below, use the "Search" functionality to search the contents of this guide. If you are new to using the test set, it may be helpful to review the Getting Started with Data Connection Processing section, which further describes where to find key data connection processing content.

Data Connection Processing Overview

  • TAP/ETAP Data Connection Processing States Lifecycle
  • TAP/ETAP Data Connection Call Flow
  • C.S0029 Test Application Specification Description (TAP/ETAP)
  • Summary of Data Connection Processing States Description
  • Data Channel ( Lab Application Only ) (DPA based data connection, Mobile IP, Data Throughout Monitor, Hybrid Mode, etc.)

Access Network Emulator Configuration

Parameters Under Call Control Menus

Parameters Under Call Parms Menus
Operating Mode , System Type

Cell Power

Handoff Setup

Cell Band

AT Max Power

Channel

Access Network Info:

  • Configurable Attribute Parms: Preferred Control Channel Cycle Control , Rate 1M8 Supported Control ( only for subtype 2 physical layer )
  • Cell Parameters: Sector ID , Country Code , Color Code , Subnet Mask , Control Channel Data Rate , Preferred Control Channel Cycle , Pilot Drop
  • Channel Gain Info ( for subtype 0 physical layer ) or Channel Gain/Traffic Info ( for subtype 2 physical layer ):
    • Channel Gain Parameters: ACK Channel Gain , DRC Channel Gain , Data Offset 9k6|19k2|38k4|76k8|153k6 , Data Offset Nom , Auxiliary Pilot Channel Gain ( only for subtype 2 physical layer ), DSC Channel Gain ( only for subtype 2 physical layer )
    • Power Parameters Info ( only for subtype 2 physical layer ) including: T2P Transition Settings , Termination Target Settings , TxT2P Gain Settings , Power Parameters Screen
    • Enhanced Traffic Parameters ( only for subtype 2 physical layer ) including: Auxiliary Pilot Channel Min Payload , DSC Length , Short Packet Enabled Threshold
    • RRI Gain Parameters ( only for subtype 2 physical layer )
  • Access Parameters ( for subtype 0 physical layer ) or Enhanced Parameters ( for subtype 2 physical layer ): Open Loop Adjust , Preamble Length , Probe Initial Adjust , Probe Num Step , Probe Power Step , Probe Sequence Max
  • CDMA System Time / Sync Info: CDMA System Time Parameters , Multi-unit Synchronization ( Lab Application Only )

Application Config:

  • Session Application Type ( Lab Application Only )
  • Test Application Protocol ( only for subtype 0 physical layer )
  • Enhanced Test Application Protocol ( only for subtype 2 physical layer )
  • Limited TAP ( only for subtype 0 physical layer )
  • AT Directed Packets
  • DRC Value Fixed Mode Attribute
  • ACK Channel Bit Fixed Mode Attribute
  • ACK Channel Modulation Type ( only for subtype 2 physical layer )
  • Reverse Data Transmission Mode ( only for subtype 2 physical layer )
  • Enhanced Access Rate ( only for subtype 2 physical layer )

Generator Info:

  • Code Channel Parameters ( only for subtype 2 physical layer ) including: H-ARQ Modulation , H-ARQ/L-ARQ Channel Level , P-ARQ Channel Level , RPC Channel Level
  • AWGN Power
  • PN Offset
  • External Trigger Type
  • Termination Parameters ( only for subtype 2 physical layer ) including: Max Forward Packet Duration , ACK R-Data After

FTAP Rate ( only for subtype 0 physical layer )

F-Traffic Format ( only for subtype 2 physical layer )

F-Traffic Config ( only for subtype 2 physical layer )

Data Channel (Lab Application Only )

RTAP Rate ( only for subtype 0 physical layer )

R-Data Pkt Size ( only for subtype 2 physical layer )

Ping (Lab Application Only )

Reverse Closed Loop Power Control

Protocol Logging (Lab Application Only )

Power Control Step

Digital Bus Information ( Lab Application with rear panel digital bus only )

Call Drop Timer

Call Limit Mode

Protocol Rel

Protocol Subtype Config: ( only for protocol release A )

  • Release A Physical Layer Subtype
  • PL Subtype 2 Access Channel MAC Subtype

Session Close

Receiver Control

  • Other Parameters: Fixed Settings

Access Terminal Information

  • AT Reported: Hardware ID , Hardware ID Type , Session Seed
  • AN Assigned: UATI 024 , UATI Color Code , MAC Index
  • User Specified: AT Max Power

Test Set Operating Modes

  • Operating Mode
  • Active Cell Operating Mode
  • IS-856 Test Operating Mode
  • CW Operating Mode

General Information

  • Forward Channel Overview


Measurements

Measurements

Last updated: June 30, 2006

The test set includes many measurements and instruments for testing your wireless device. This page provides links to measurement information including: 3GPP2 C.S0033 Tests Supported by the Test Set , Measurement Descriptions and Key C.S0033 Test Descriptions (how the measurement is performed by the test set, setup parameters, the measurement results available, as well as the related C.S0033 tests that can be made with the measurement), Measurement Calibration and Measurement Calibration (pass loss setting, input signal requirements for the measurement, etc.).

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

3GPP2 C.S0033 Tests Supported by the Test Set

  • Test Adherence to Standards

Measurement Descriptions and Key C.S0033 Test Descriptions

  • Access Probe Power Measurement Description
    • 4.3.1 Range of Open Loop Output Power

  • Audio Analyzer Measurement Description

    • Audio Analyzer Block Diagram
    • Audio Frequency Measurement Description
    • Audio Level Measurement Description
    • Distortion Measurement Description
    • SINAD Measurement Description

  • Channel Power Measurement Description
    • 4.3.5 Minimum Controlled Output Power
  • Digital Average Power Measurement Description
    • 4.3.4 Maximum RF Output Power
  • Fast Device Tune Measurement Description ( Only applicable to the lab application or feature-licensed test application )
  • Graphical Access Probe Power Measurement Description ( Only applicable to the lab application )
    • 4.3.1 Range of Open Loop Output Power
  • Packet Error Rate (PER) Measurement Description
    • 3.2.1 Demodulation of Forward Traffic Channel in AWGN
    • 3.2.2 Demodulation of Forward Traffic Channel in Multipath Fading Channel ( Lab Application Only )
    • 3.3.1 Receiver Sensitivity and Dynamic Range
  • Spectrum Monitor Description
  • Swept Audio Measurement Description
  • Time Response of Open Loop Power Control (TROLPC) Measurement Description
    • 4.3.2 Time Response of Open Loop Power Control
  • TX Dynamic Power Measurement Description
  • TX Spurious Emissions Measurement Description
    • 4.4.1 Conducted Spurious Emissions
  • Waveform Quality + Code Domain Measurement Description
    • 4.2.2 Waveform Quality and Frequency Accuracy
    • 4.3.7 RRI Channel Output Power
    • 4.3.8 Code Domain Power

Measurement Calibration

  • Calibrating the Test Set

General Measurement Information

  • Amplitude Offset


Manual Operation

Manual Operation

Last updated: May 24, 2006

This page provides links to information on using the test set from the front panel including: Data Connection Operations (procedures for opening/closing a session/test data connection and performing handoffs), Access Network Emulator Configuration (procedures to configure the specific parameters for the test set's base station emulator), Multi-unit Synchronization Operations (how to synchronize multiple test sets for particular test case such as hybrid mode), Making Measurements (general procedures to use the measurements, and step by step procedures for performing Individual 3GPP C.S0033 tests), Data Channel (Lab Application Only) (DPA based packet data operations), Protocol Logging (Lab Application Only) , Test Set Configuration (such as amplitude offsets, GPIB and LAN ports), General Manual Operation (such as Help Mode, which provides context-sensitive GPIB command syntax assistance, and Save and Recall Registers, which provide a way to return to frequently used setups).

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide

Data Connection Operations

  • How Do I Open a Session and Test Data Connection?
  • How Do I Perform a Handoff?
  • How Do I Close the Session?
  • How Do I Close the Connection?

Access Network Emulator Configuration

  • How Do I Change Call Parameters? (including Protocol Release, Physical Layer Subtype, Session Application Type, ACK Channel Bit Fixed Mode Attribute, DRC Value Fixed Mode Attribute, Application, AT Directed Packets, Cell Band, Channel, FTAP rate, limited TAP...)
  • How Do I Change Configurable Attribute Control Mode? (PCCC Control, Rate 1M8 Supported Control)
  • How Do I Change Cell Parameters? (Color Code, Control Channel Data Rate, Sector ID, Pilot Drop...)
  • How Do I Change Channel Gain/Traffic Info Parameters? (T2P Power Parameters, Enhanced Traffic Parameters, ACK Channel Gain, Data Offset Nom, RRI Gain Parameters...)
  • How Do I Change Access Parameters? (Open Loop Adjust, Probe Initial Adjust, Probe Num Step...)
  • How Do I Change CDMA System Time Parameters?
  • How Do I Change Generator Information? (AWGN power, PN offset, H-ARQ/L-ARQ Channel Level, RPC Channel Level, ACK R-Data After...)
  • How Do I Change Parameters in IS-856 Test Operating Mode?

Multi-unit Synchronization Operations

  • How Do I Perform Multi-unit Synchronization? ( Lab Application Only )

Making Measurements

  • Performing Specific Measurements and C.S0033 Tests Manually [image] Click here for step-by-step instructions for performing individual C.S0033 tests.

  • How Do I Make Measurements?
  • How Do I Change the Measurement Setup?
  • How Do I Turn Off a Measurement?
  • How Do I Use the Spectrum Monitor?

Data Channel ( Lab Application Only )

  • How Do I Make a Packet Data Connection?
  • How Do I Set Up Data Channel Parameters?
  • How Do I Access the Data Counters?
  • How Do I Use the Data Throughput Monitor?
  • How Do I Ping a Device From the Test Set?
  • Packet Data Service Example Procedure (via Simple IP)
  • Packet Data Service Example Procedure (via Mobile IP)
  • How Do I Make Hybrid Mode AT/MS Tests?

Protocol Logging ( Lab Application Only )

  • Activating Protocol Logging From the Test Set

Test Set Configuration

  • How Do I Configure the Test Set for My Test System? (GPIB address, amplitude offsets...)
  • How Do I Configure the AUDIO OUT Port?
  • How Do I Configure Test Signals in CW Operating Mode?

General Manual Operation

  • Help Mode
  • Save and Recall Registers
  • Front Panel Connectors
  • Rear Panel Connectors
  • Remote/Local Mode
  • Printing Screens
  • Instrument Status Area
  • Preset Descriptions
  • Manual Operation: Manual Receiver Control


Programming

Programming

Last updated: June 30, 2006

The test set is programmable through the GPIB (General Purpose Interface Bus) located on the rear panel. This page is to help you program the test set including: Getting Started with Programming (generic programming procedure and comprehensive program example), Programming Examples for Individual Measurements and General Programming (including test system synchronization).

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

Getting Started with Programming

  • Programming: Getting Started Guide for 1xEV-DO Terminal Test - It provides a general approach to configuring the test set's base station emulator, setting up a test data connection and performing measurements programmatically. It is developed based on a TAP test data connection, but the general procedure also applies to the tests in an ETAP test data connection.
  • Control Program Examples - It provides two comprehensive programming examples, one for testing an AT based on TAP test data connection and another for testing an AT based on ETAP test data connection.

Programming Examples for Individual Measurements

  • Programming an Access Probe Power Measurement
  • Programming an Audio Frequency Measurement
  • Programming an Audio Level Measurement
  • Programming a Distortion Measurement
  • Programming a SINAD Measurement
  • Programming a Channel Power Measurement
  • Programming a Digital Average Power Measurement
  • Programming a Fast Device Tune Measurement ( Only applicable to the lab application or feature-licensed test application )
  • Programming a Graphical Access Probe Power Measurement ( Only applicable to the lab application )
  • Programming a Packet Error Rate (PER) Measurement
  • Programming the Spectrum Monitor
  • Programming a Swept Audio Measurement
  • Programming a Time Response of Open Loop Power Control (TROLPC) Measurement
  • Programming a Tx Spurious Emissions Measurement
  • Programming a TX Dynamic Power Measurement
  • Programming a Waveform Quality/Code Domain Measurement

General Programming

The following section provides links to the general programming topics including:

Programming for Data Connection Processing

  • Establishing a connection: Step 4: Make a connection
  • Performing a handoff: Step 6: Reconfigure Test Set and Mobile Station Connection Parameters
  • Closing the session/connection: Step 7: End the Connection

Programming for Making Measurements

  •

Step 3: Set Measurement Parameters

    •

  •

Step 5: INITiate and FETCh Measurements

    •

  •

INITiate Programming Examples (how INIT commands are used)

    •

  •

Concurrent Measurements

    •

  •

Obtaining Measurement Results

    •

Test System Synchronization

  •

Test System Synchronization

    •

General Information

  •

Preset Descriptions

    •

  •

Receiver Control

    •

  •

Status Subsystem Overview

    •

  •

Dealing With Semicolon Separated Response Data Lists

    •

  •

Using GPIB Command Debug Mode

    •

  •

User Interface (UI) Log

    •


GPIB Commands

GPIB Commands

This page provides links to all of the test set's GPIB subsystems. Select a subsystem link below for a description of the subsystem and links to all of the GPIB commands within that subsystem.

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

GPIB Diagram Conventions

  • Diagram Conventions to understand how GPIB commands are represented in the diagrams.

Data Connection Processing

  • CALL Subsystem to control the access terminal and set up and control the cell.

Measurement Control

  • SETup Subsystem to configure a measurement.
  • INITiate Subsystem or READ? Subsystem to start a measurement.
  • FETCh? Subsystem or READ? Subsystem to get measurement results.
  • CALCulate Subsystem to perform data processing on measurement results.
  • ABORt Subsystem to stop a measurement.

Status

  • STATus Subsystem to communicate test set status.

IEEE 488.2 Common Commands

  • IEEE 488.2 Common Commands

Instrument Selection

  • AFGenerator Subsystem
  • RFANalyzer Subsystem (not controlled as an instrument)
  • RFGenerator Subsystem (not controlled as an instrument)

Test Set Configuration

  • CALibration Subsystem
  • DISPlay Subsystem
  • SYSTem Subsystem

Help Mode

Help Mode


Protocol Logging

Protocol Logging

This section is only applicable to the lab application.

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

With a lab application, the test set can capture the protocol messages exchanged between the test set and a wireless device. The protocol messages are forwarded via the test set's LAN port to the Wireless Protocol Advisor (WPA) software (which is included with your lab application), so that they can be displayed and analyzed. If you're using the data channel feature of the test set as an IP router to exchange data between the wireless device and a network server, then the WPA can also monitor these communications.

The Wireless Protocol Advisor software runs on a personal computer under the Windows operating system. It is tailored for the capture, display, and analysis of message exchange protocols between the test set (emulating a base station), and a wireless device. The software connects with the test set through the LAN port, to capture messages and data used to set up and maintain links and transfer data. Messages and data can be filtered to include specific protocol layers and message fields.

IMPORTANT
Most of the information necessary to establish a connection and to display, filter, store, print, and analyze the message exchange between the test set and an AT is accessible through the Help feature available on-line when the WPA application is running.

This on-line help is also available for download at:

http://www.agilent.com/find/e6584a/

To help you get started using the WPA, the Agilent E6584A Wireless Protocol Advisor Operating Guide is available at:

http://cp.literature.agilent.com/litweb/pdf/1000-1868.pdf

Additional information, including PC operating system requirements and additional protocol logging reference information is listed below.

PC Operating System Requirements

Logging protocol messages requires an external PC with the following system requirements:

  • Protocol Logging Requirements

Starting and Stopping Protocol Logging

There are several ways to control the logging of signaling messages.

The primary method for starting and stopping is through features found in the WPA software.

The following information describes features available through the test set's remote and manual user interface for performing these functions:

  • Activating Protocol Logging From the Test Set

Protocols Decoded by WPA

The test set can log all protocol messages exchanged between the test set and an access terminal (AT), but only the following protocol messages can be decoded by the WPA:

  • Signal Link Protocol (SLP) messages
  • Radio Link Protocol (RLP) messages
  • Point-to-Point Protocol (PPP) messages
  • Forward/Reverse Internet Protocol (IP) messages
  • Test Application Protocol (TAP) messages

Example Usages of Protocol Logging

  • Protocol Logging During Ping


Data Channel

Data Channel

This section is only applicable to the lab application.

The data channel function allows you to use the test set as an IP router, exchanging packet data between a 1XEV-DO wireless device and a packet switched network (such as an IP network) via a packet data connection. The performance of data applications such as music download, interactive and multimedia applications can then be tested.

The Session Application Type must be set to Default Packet Application before an AT initiates a packet data connection with the test set.

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

Data Channel Overview

  • Packet Data Network Emulation in the Test Set
  • Packet Data Connection Call Flow
  • Packet Data Connection Processing States Lifecycle
  • Summary of Data Connection Processing States Description
  • Summary of Data Channel Operations in the Test Set

Data Channel Configuration

  • Data Channel Parameters

Data Channel Capabilities

  • Hybrid Mode
  • Simple IP and Mobile IP
  • Packet Data Service Example Procedure (via Simple IP)
  • Packet Data Service Example Procedure (via Mobile IP)
  • Data Counters (RLP/IP counters, Forward/Reverse Traffic Channel Packet counters)
  • Data Throughput Monitor
  • Ping
  • Data Channel Applications

Troubleshooting Information

  • Data Channel Troubleshooting

General Information

  • IP Address Requirements


Troubleshooting

Troubleshooting

Last updated: July 28, 2006

This page provides links to troubleshooting information including: Contact Information , Measurement Troubleshooting , Data Connection Troubleshooting , Error Indicators and Other Troubleshooting Information (such as block diagrams and known issues).

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

IMPORTANT
If you install application firmware on a test set with incompatible hardware, the test set may lock up. See Test Set Lockup Due to Power Up Sequence .

Some features may be inaccessible or may not perform to specifications without a hardware upgrade to your test set or a proper license. For more details, please see:

http://www.agilent.com/find/8960upgrades

Contact Information

  • Contact Us

Measurement Troubleshooting

  • Access Probe Power Troubleshooting
  • Audio Analyzer Troubleshooting
  • Channel Power Measurement Troubleshooting
  • Digital Average Power Troubleshooting
  • Fast Device Tune Troubleshooting ( Only applicable to the lab application or feature-licensed test application )
  • Graphical Access Probe Power Troubleshooting ( Only applicable to the lab application )
  • Packet Error Rate Measurement Troubleshooting
  • Spectrum Monitor Troubleshooting
  • Swept Audio Measurement Troubleshooting
  • Time Response of Open Loop Power Control Troubleshooting
  • TX Dynamic Power Measurement Troubleshooting
  • Tx Spurious Emissions Measurement Troubleshooting
  • Waveform Quality Measurement Troubleshooting

Data Connection Troubleshooting

  • Troubleshooting Data Connection Processing
  • Data Channel Troubleshooting ( Lab Application Only )

Error Indicators

  • Error Messages
  • Error Message Log
  • Integrity Indicator

Other Troubleshooting Information

  • Troubleshooting Setting Power Levels
  • Test Set Lockup Due to Power Up Sequence
  • Using GPIB Command Debug Mode
  • User Interface (UI) Log
  • Block Diagram
  • Calibrating the Test Set
  • 8960 Known Issues


Configuration

Configuration

Last updated: July 28, 2006

This page provides links to configuration information including: Configuration Information (identification, hardware configuration), Configuring the Test Set (such as setting amplitude offsets, GPIB address and LAN ports) and Selecting an Application .

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

Configuration Information

  • Obtaining Identification Information (*IDN)
  • Hardware Configuration Report

Configuring the Test Set

  • Configuring the Test Set's AUDIO OUT port
  • Display Brightness
  • Display Mode (Track/Fast)
  • Test Set Beeper
  • Timebase Description/Configuration
  • Configuring the Test Set's LAN
  • Configuring the Test Set's GPIB
  • Amplitude Offset
  • Restart on Fatal Error
  • Calibrating the Test Set

Selecting an Application

  • Test Application Switching


Release Notes

Release Notes

Last updated: June 30, 2006

The links below list the features and functionality of the applications for each release of the firmware.

Features and Functionality

  • E1966A 1xEV-DO Terminal Test Application Revision Information
  • E6706A/T 1xEV-DO Terminal Lab Application Revision Information

GPIB Commands

  • E1966A and E6706A Applications: GPIB Command Revision Information


Getting Started with Data Connection Processing

Getting Started with Data Connection Processing

Most of the information in the Data Connection Processing section describes the features and functionality available in the Active Cell and IS-856 Test operating modes. While in these modes, the test set includes a base station emulator which allows you to establish a data connection between the test set and your wireless device (with signalling when in Active Cell Operating Mode or by the device synchronizing to the forward link when in IS-856 Test Operating Mode ). You can then perform many data connection operations and measurements.

The 1x EV-DO system supports a number of different applications. Each application defines a unique set of procedures and capabilities. The E1966A supports test application protocols (TAP/ETAP) that are defined by the C.S0029 standard and mainly used for access terminal minimum performance tests in a factory/laboratory environment. For details, see C.S0029 Test Application Specification Description (TAP/ETAP) .

To learn more about the parameters for configuring the base station emulator, see Access Network Emulator Configuration .

To learn more about the various data connection processing states that the test set and access terminal can reside in as you perform data connection operations, see Summary of Data Connection Processing States Description .

To learn more about the messages and parameter values that are exchanged as you establish a test application connection between the test set and access terminal, see TAP/ETAP Data Connection Call Flow .

To learn more about the information reported to the test set by the access terminal (such as UATI, etc.), see Access Terminal Information .

In addition to the test application protocols, the E6706A lab application also supports Default Packet application protocol that is used in actual 1xEV-DO network and provides Internet connectivity to access terminals for transporting real user packet data. All of the real network operation (based on Default Packet connection) are described in Data Channel section including simple IP/mobile IP packet data connection, hybrid mode, etc.


Summary of Data Connection Processing States Description

Summary of Data Connection Processing States Description

TAP/ETAP Data Connection Processing States Lifecycle

Packet Data Connection Processing States Lifecycle ( Lab Application Only )

  • Idle State
  • UATI Request State
  • Session Negotiate State
  • Session Open State
  • Paging State
  • Connection Request State
  • Connection Negotiate State
  • Connected State
  • Dormant State ( Lab Application Only )


Configuring the Test Set's AUDIO OUT port

Configuring the Test Set's AUDIO OUT port

Description

The AUDIO OUT connector on the test set's front panel can be configured to carry one of two signals:

  • Audio Generator
  • FM Demod

By default, the AUDIO OUT connector is configured to carry the output from the built in audio generator. This signal is typically used to stimulate a system to measure its audio performance. When the audio generator's signal is selected for output at the front panel AUDIO OUT connector, use the AFGenerator commands to control the signal.

When testing AMPS systems, it may be useful to configure the AUDIO OUT connector to carry the analog FM Demod signal. This provides the demodulated FM signal for external analysis and baseband processing. Fixed bandwidth bandpass, expandor, and de-emphasis filters can be selected to control the FM Demod signal. When the FM Demod signal is selected for output at the front panel AUDIO OUT connector, use the SYSTem:AUDio:OUTPut commands to control the signal.

For front panel operation, to select the signal source for output to the AUDIO OUT connector, press System Config hardkey, then select Audio Out Port ( F1 ) on the System Config Screen (2 of 2).

Programmatically, to select the signal source for output to the AUDIO OUT connector, use the SYSTem:AUDio:OUTPut:SOURce commands.

Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:SOURce AFGenerator" !Selects Audio Generator signal for output
                                                    !at the front panel AUDIO OUT port.

NOTE
Refer to the Technical Specifications in the Application Datasheet for specifications of the AUDIO OUT connector. There will be no guaranteed performance for the signal present at the AUDIO OUT connector when FM Demod signal is selected for output.

Related Topics

How Do I Configure the AUDIO OUT Port?


Restart on Fatal Error

Restart on Fatal Error

Description

The Restart on Fatal Error feature provides the ability to configure the test set to automatically restart when a fatal error occurs. Restart on Fatal Error does not apply when a fatal error occurs during the test set's power up sequence.

The Restart on Fatal Error State is retained regardless of whether the test set is restarted manually or through the Restart on Fatal Error feature. The test set's default setting for the Restart on Fatal Error State is Off. If the Restart on Fatal Error State is set to On and a fatal error occurs, the test set prints the fatal error condition on the test set's front panel. The test set then waits 25 seconds before restarting.

The following error message is then displayed on the test set's front panel once the test set completes its power up sequence: " Warning; 8960 has been restarted after a non-recoverable error occurred. " All errors in the error/event queue can be queried using the command SYSTem:ERRor? .

Configurable Parameters

Restart on Fatal Error State is the only parameter that needs to be configured to allow the test set to restart if a fatal error is encountered. The command to set this parameter is SYSTem:FATal:ERRor:RESTart .

How Do I Configure the Test Set to Restart State?

The following procedure details how to configure the test set to automatically restart if a fatal error is encountered during operation.

  1. Press SYSTEM CONFIG .
  2. Press Instrument Setup ( F1 ).
  3. Scroll down and highlight the Restart on Fatal Error State parameter.
  4. Press the knob to change the state to On as shown in the figure below.

Related Topics

SYSTem:FATal:ERRor:RESTart


Test Set Beeper

Test Set Beeper

Description

This parameter allows you to change the beeper state to on or off. A beep will indicate error conditions caused during manual or remote operation of the test set.

A 100 ms, 1.24 kHz audible tone (beep) is generated when an error message is logged and the beeper state is set to on. If two errors are generated in quick succession, two beeps are generated to indicate that more than one error has been logged.

The beeper state can be manually set in the Instrument Setup window found in the SYSTEM CONFIG screen.

Example

OUTPUT 714;"SYSTEM:BEEPER:STATE OFF"

Related Topics

SYSTem:BEEPer


Display Brightness

Display Brightness

Description

This parameter allows you to adjust the brightness of the test set's display. The test set's display screen has two brightness settings:

  • medium brightness
  • high brightness

Example

OUTPUT 714;"DISPLAY:BRIGHTNESS MEDIUM" ! sets screen brightness to medium.

Related Topics

DISPlay


Display Mode (Track/Fast)

Display Mode (Track/Fast)

May 24, 2006

Description

There are two display modes to select from when operating the test set remotely.

  • Display mode fast
  • Display mode track

Fast Mode

When operating remotely, there is often no need for the display to be updated as measurements are made. Using the fast display mode will increase the speed of the test set when it is operated remotely.

Fast mode is designed for remote use only. The test set returns to track mode if you change to manual operation.

  • No screen or menu items are visible (except error messages).
  • Error messages will be displayed in their normal location.
  • "This instrument is being operated remotely" will be displayed at the bottom of the screen.

Example

OUTPUT 714;"DISPLAY:MODE FAST" !Selects fast mode

Track Mode

The track display mode is used to allow users to see what the test set is doing while it is being controlled remotely. Track mode is the default mode of the test set.

  • Any changes made remotely will be updated on the screen if that screen is displayed.
  • The error message window will be displayed as required when an error occurs.

Example

OUTPUT 714;"DISPLAY:MODE TRACK"!Selects track mode

Writing Messages to the Display

The capability to write up to four 30-character lines of text to the front panel display for operator messages is available when the display is in Fast Mode . This feature can be used to control the flow of software running on an external controller by pressing softkeys on the test set's front panel.

For example, by displaying a message that prompts the operator to press a front panel softkey and then monitoring that softkey through status register bits, the programmer can design code that starts measurements, stops measurements, or branches to a selected routine or function without the need for access to the external computer's keyboard.

The GPIB commands for writing messages to the display are found in the DISPlay:OPERator:MESSage table.

The status bit register GPIB commands and bit definitions for monitoring the test set's softkeys are found in the STATus:OPERation:KEYPressed Condition Register Bit Assignments table.

Related Topics

DISPlay


Configuring the Test Set's GPIB

Configuring the Test Set's GPIB

Description

The GPIB address is an integer between 0 and 30. The test set comes with a default address of 14 and may be set/queried using the SYSTem subsystem or manually through the system configuration screen by selecting the parameter and changing the number with the knob or the keypad.

The GPIB address is a non-volatile parameter. The GPIB address is not affected by any reset operation and can only be changed by direct access to the parameter itself.

Related Topics

SYSTem:COMMunicate


Hardware Configuration Report

Hardware Configuration Report

Description

You can generate a list of the test set's hardware configuration over the LAN or GPIB.

The LAN query is the easiest and most direct way to query the test set's hardware configuration. This method uses your web browser to display a formatted report.

The GPIB query returns an unformatted character string that must be buffered and saved to an HTML file to provide formatted text.

LAN Query

  1. Refer to the SYSTEM CONFIG screen to determine the LAN address.
  2. Open a web browser and enter <LAN address>/iconfig. For example, if your LAN address is 130.2.2.147, you would enter:

    130.2.2.147/iconfig

  3. The web browser will then display formatted text. A partial list of the hardware configuration information is shown below:

GPIB Query

Use the following Basic example as a model to store the test set's configuration as an HTML file.

GPIB Example:

10    DIM Buf1$[20000],Buf2$[20000] ! This is the minimum space for the arrays
20    OUTPUT 714;"SYSTEM:CONFIGURE:INFORMATION:HARDWARE:VERBOSE?"
30    ENTER 714;Buf1$,Buf2$
40    CREATE "HW.htm",1              ! Create an HTML file
50    ASSIGN @File TO "HW.htm"
60    OUTPUT @File;Buf1$,Buf2$
70    END

In the future, the hardware configuration report may increase in length. More space would then need to be allocated for the arrays.

Display the HTML file using a web browser or HTML text editor.

Related Topics

SYSTem:CONFigure


Obtaining Identification Information (*IDN)

Obtaining Identification Information (*IDN)

Last updated: May 24, 2006

Description

Test set information is returned from a *IDN? query. The *IDN? query provides information about the Manufacturer, Model Number, Serial Number, and Firmware Revision. *IDN? is defined in IEEE Std. 488.2-1992, 10.14.

Test Set Information

*IDN? query returns identification information as a comma separated string.

DIM A$[100]
OUTPUT 714;"*IDN?" !returns manufacturer,model number, serial number and "0"
                   !separated by commas
ENTER 714;A$
PRINT A$           !prints, for example "Agilent Technologies, 8960 Series 10 E5515B,
                   !US38020105,0
  • Agilent Technologies is the manufacturer.
  • Printable ASCII characters excluding comma and semicolon up to a 25-character string.
    Model number example: 8960 Series 10 E5515B
  • Printable ASCII characters excluding comma and semicolon up to a 10-character string.
    Serial number example: US00000123
  • Printable ASCII characters excluding comma and semicolon up to a 20-character string.
    Firmware revision example: 0

NOTE
The *IDN? query will always indicate that the firmware revision is zero. SYSTem:APPLication[:CURRent]:REVision? is the recommended way to query the firmware revision.

Related Topics

Hardware Configuration Report


Configuring the Test Set's LAN

Configuring the Test Set's LAN

Description

LAN IP Address

CAUTION
Always verify that the test set is responding to a new LAN IP Address by pinging the test set. If the test set does not respond to the ping, cycle power. This will ensure that the test set will respond to the new LAN IP Address.

The LAN address is a character string with a maximum of 15 characters and a format of A.B.C. D where A is between 0 and 223 (excluding 127, which is assigned for use as the Internet host loopback address), and B, C, and D are between 0 and 255. No embedded spaces are allowed. The address may be manually set/viewed in the system configuration screen. The LAN address can be set/queried using the SYSTem subsystem.

The LAN address is a non-volatile parameter. The LAN address is not affected by any reset operation and can only be changed by direct access to the parameter itself.

NOTE
If the LAN address is set to a different network class, the subnet mask will change to the default net mask for the new network class.

For convenience the DATA port on the front panel may be configured as a LAN port. When an RJ45 jumper cable, (part number E5515-61160) is connected from the LAN PORT on the rear panel, to the ETHERNET TO FRONT PANEL port also on the rear panel, the user has LAN access from the front panel of the test set. Without the RJ45 jumper cable, the test set connection to a LAN is the rear-panel, LAN PORT connector.

LAN Default Gateway

The LAN router, (default gateway), is a character string with a maximum of 15 characters and a format of A, B, C, D, where A is between 0 and 223 , and B, C, and D are between 0 and 255, no embedded spaces are allowed. If the default gateway is set to a format not allowed with the LAN address or the subnet mask that have been selected, the default gateway will be set to a null string, indicated by a blank field on the test set display. The address may be manually set/viewed in the system configuration screen. The LAN default gateway can be set/queried using the SYSTem subsystem.

The LAN default gateway is the address of a router that routes messages between networks and or subnets. If this value is not specified, LAN communications will be limited to the network and subnet specified by the LAN IP address and the subnet mask. Your network administrator will know if a default gateway is needed and if so, the address of the router. If the default gateway address is not needed by your network, it may be disabled by entering any of the following values: "0" (zero), "" (null string), "0.0.0.0"

The LAN default gateway is a non-volatile parameter. The LAN default gateway is not affected by any reset operation and can only be changed by direct access to the parameter itself.

LAN Subnet Mask

The LAN subnet mask address is a character string with a maximum of 15 characters and a format of A, B, C, D, where A , B, C, and D are between 0 and 255. No embedded spaces are allowed. The address may be manually set/viewed in the system configuration screen. The LAN subnet mask address can be set/queried using the SYSTem subsystem.

The subnet mask number combined with the IP address identifies which network and subnet your computer is on. Contact your system administrator for the correct subnet mask for your network.

The subnet mask determines the boundaries between the subnet ID and the host ID.

The LAN subnet mask is a non-volatile parameter. The LAN subnet mask is not affected by any reset operation and can only be changed by direct access to the parameter itself or by changes to the LAN IP Address.

NOTE
If the LAN address is set to a different network class, the subnet mask will change to the default net mask for the new network class.

The subnet mask number is obtained from your network administrator.

Related Topics

IP Address Requirements


Amplitude Offset

Amplitude Offset

Description

Amplitude offsets compensate for loss or gain between the test set's RF IN/OUT front panel connector and the mobile station's RF connector.

To access the amplitude offset feature, press the SYSTEM CONFIG key, followed by the RF IN/OUT Amptd Offset ( F5 ) key.

Amplitude offset settings are preserved during power cycles or instrument preset.

Setting Up Amplitude Offsets and Frequency Points

Up to 20 frequency points can be assigned an amplitude offset. Negative amplitude offset values should be entered when there is a loss through the RF cabling and test fixtures and positive values should be entered when there is a gain.

The RF IN/OUT Amplitude Offset table displays the current (on/off) state of the amplitude offset feature. There are also 20 rows for entering frequencies and 20 rows for entering corresponding offset values. To enter values in the table use the RF IN/OUT Amplitude Offset Setup menu.

To set up amplitude offsets remotely, one comma-separated string is sent to set up frequency points and another comma-separated string assigns the corresponding amplitudes.

GPIB Commands

OUTPUT 714;"SYSTEM:CORRECTION:SFREQUENCY 1710.2 MHZ,1805.2 MHZ,1784.8 MHZ,1879.8 MHZ"
!sets the first 4 frequencies in the amplitude offset table.

OUTPUT 714;"SYSTEM:CORRECTION:SGAIN -2.55,-3.12,-3.68,-4.23"
!sets the first 4 amplitude offsets in the amplitude offset table.

Turning amplitude offsets on/off

When the RF IN/OUT Amplitude Offset State is on, all offsets that are not individually turned off are applied and the word "Offset" appears in the Instrument Status Area of the test set's display.

If the RF IN/OUT Amplitude Offset State is off, none of the amplitude offsets are applied.

GPIB Command

OUTPUT 714;"SYSTEM:CORRECTION:STATE ON"
!Sets the RF IN/OUT Amplitude Offset State to On

NOTE
If the RF IN/OUT Amplitude Offset State is turned off , none of the amplitude offsets are on, even if values are entered for the individual offsets.

Examples of Amplitude Offset Behavior

When the amplitude offset table entries accurately represent the loss in all components (cabling, connectors, and test fixturing) in the signal path between the test set and the mobile station, the test set will make the necessary adjustments in both receiver and transmitter measurements.

Mobile Station Receiver Example

When you set a transmit power level, the test set uses the amplitude offset value to adjust the power so that the test set's transmit power level refers to the power level received at the mobile station.

As shown in Amplitude Offset Mobile Station Receiver Example , with the test set's transmit power set to -85 dBm and a -3 dB amplitude offset the actual power level transmitted from the test set will be automatically offset to -82 dBm. With a 3 dB loss in the signal path the mobile station will receive -85 dBm, the actual setting.

Amplitude Offset Mobile Station Receiver Example

Mobile Station Transmitter Example

When you measure power from the mobile station, the displayed and queried values are offset to show the level at the mobile station.

As shown in Amplitude Offset Mobile Station Transmitter Example , with the mobile station transmitting 12 dBm and a -3 dB amplitude offset is entered, the measured power at the test set would be 9 dBm. The displayed power level is automatically adjusted to 12 dBm to show the level at the mobile station.

If the expected power, which can be set manually or automatically is 12 dBm, the test set's internal hardware adjusts itself to receive 9 dBm which is the actual power from the mobile station after 3 dB loss in the network.

Amplitude Offset Mobile Station Transmitter Example

Amplitude Offsets Between Frequency Settings

If mobile station testing is performed at frequencies that do not have amplitude offsets assigned to them, the test set will estimate an amplitude offset based on the nearest settings. For example, the following screen shows five amplitude offsets for frequencies ranging from 890.2 MHz to 1710.2 MHz.

RF IN/OUT Amplitude Offset Setup

For test frequencies between the lowest (890.2 MHz) and highest (1710.2 MHz) frequency points that are not entered in the table, the test set will calculate offsets using piece-wise linear interpolation.

The graph shown in Amplitude Offset Interpolation is a conceptual representation of the test set's amplitude offset configuration using the settings from the RF IN/OUT Amplitude Offset table in RF IN/OUT Amplitude Offset Setup . Each of the five points are shown on a non-scaled frequency versus amplitude offset graph. At a test frequency of 890.4 MHz, which is midway between point number one (-1 dB) and point number two (-2 dB) the test set applies an offset of -1.5 dB. Be aware that since amplitude offsets are in units of dB, this piece-wise linear interpolation does not produce a linear transition from point to point.

Amplitude Offset Interpolation

If testing is done outside the range of frequencies bounded by the lowest and highest frequency entries, the test set simply uses the amplitude offset that is paired with the nearest frequency point.

IMPORTANT
It is highly recommended that amplitude offsets are set up for each test frequency. This eliminates inaccuracies due to the mismatch between the test set's linear interpolation and the actual frequency response of the RF path between the test set and mobile station.

Related Topics

SYSTem:CORRection


Test Application Name

Test Application Name

Description

The following queries give you details about the application name. To query or switch applications you must use the application's name as it appears in the catalog (without regard to case).

  • To query the name of the all applications installed in the test set use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME?"

  • To query the name of the selected application (running or not) use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME?"
  • To query the name of the currently running application use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:CURRENT:NAME?"

  • To query the number of applications installed in the test set use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME:COUNT?"

The application names can also be displayed in the Application Setup menu on the test set's display.

Related Topics

SYSTem:APPLication


Test Application Revisions and Licenses

Test Application Revisions and Licenses

Last Updated: May 24, 2006

Description

Different revisions of the applications in your test set provide different capabilities. The selected application revision is loaded after the next application switch or power cycle of the test set. Once you select a revision the revision does not change unless you select another revision.

You can query the selected revision, all available revisions, and the total count of available revisions for a selected application. These queries are helpful when selecting revisions but are not usually necessary when switching applications.

NOTE
The Agilent E1960A GSM Mobile Test Application revisions prior to A.04.00 do not support application switching. If you select a revision prior to A.04.00 you will not have a path to switch back to later revisions.

If you accidentally switch to a non-supported revision, use the firmware upgrade process to load firmware with the correct revision.

Application Revision Queries and Commands

These are commands to query revision information or select a revision.

  • To query a selected application revision (running or not) use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION? `AMPS/136 MOBILE TEST'"
  • To query the revision of the application currently running use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:CURRENT:REVISION?"
  • To query all of the revisions available for a application use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION? `AMPS/136 MOBILE TEST'"
  • To select a revision of an application use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION `GSM mobile test','A.04.01'"

    After switching to a different revision of your application, you may need to calibrate the test set. See the on-line reference guide for your application for more information.

  • To query the number of revisions for a specified application:

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION:COUNT? `GSM MOBILE TEST'"

Application License Status Query

The application license status can be queried for a particular application and revision using the following GPIB query:

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:LICENSE? `GSM mobile test','A.04.01'"

This query returns one of the following:

  • "LIC" - This revision of application appears to have a LICense. The application may have been developed before licensing and therefore needs no license.
  • "NLIC" - This application does not appear to have a license. Selecting a Not LICensed revision will result in an error +130.
  • "PART" - Some PART of the application does not appear to have a license.
  • "UNKN" - This application has UNKNown license status.

You can also query a list of all licensed applications, formats and features using the following GPIB query:

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:ALL?"

NOTE
If you switch to a not licensed revision the test set will reboot to the SYSTEM CONFIG screen. You will be unable to select any other screen or make any measurements. Query or view the Application Setup menu to determine the licensed versions of applications available.

Revision and license information can be viewed and selected from the SYSTEM CONFIG screen, by selecting the Application Setup menu. Revisions are shown with their license status. After the revision number is a letter. That letter indicates the revision license status; Licensed "L", Not Licensed "N", or Unknown "U".

  • "L"- This revision of application appears to have a License. The application may have been developed before licensing and therefore needs no license.
  • "N" - This application does not appear to have a license. Selecting a Not licensed revision will result in an error +130.
  • "P" - Some Part of the application does not appear to have a license.
  • "U" - This application has Unknown license status.

Related Topics

Test Application Switching


Test Application Switching

Test Application Switching

Description

Different radio formats (such as GSM, AMPS, CDMA 2000 or TIA/EIA 136) can be tested when additional applications are purchased from Agilent Technologies. The test set allows you to switch between different applications. A reboot is necessary to make a newly selected application functional. The reboot happens automatically when the you tell the test set to switch applications. Switching to another application takes about one minute.

Some radio formats are combined as fast switching applications. Switching formats in a fast switching application takes less than 2 seconds.

Application Switching GPIB Command

In order to switch to another application use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME `GSM MOBILE TEST'"

Sending this command causes the test set to reboot.

Application Revision and Licensing

Each application must have a valid license and revision to function. Licensed revisions of applications are available from Agilent Technologies.

It may take several seconds before revision, model, and name information is returned.

Application Switching Programming Example

This program example shows you how to switch to the GSM Mobile Test Application.

  1. Query the list of application names to get exact spelling of the GSM Mobile Test Application. This is not necessary if you already know the exact name.
  2. Query the test set to get a list of all revisions for "GSM Mobile Test." This is not necessary if you are not changing revisions.
  3. Select a revision of "GSM Mobile Test." This is required if you are changing revisions.
  4. Select the GSM test application. This will switch applications and cause the test set to reboot.

10    OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME?"
20    !Queries all of the application names
30    ENTER 714;N$
40    PRINT "The CATALOG names that are loaded are ";N$
50    OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION? `GSM MOBILE TEST'"
60    !Queries all revisions of GSM MOBILE TEST
70    ENTER 714;Cat_rev$
80    PRINT "The revisions for the GSM Mobile Test Application are ";Cat_rev$
90    OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION `GSM MOBILE TEST','A.04.01'"
100   !Selects a revision
110   OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME `GSM MOBILE TEST'"
120   !Switches the application to GSM MOBILE TEST
130   END

Related Topics

Test Application Revisions and Licenses


Timebase Description/Configuration

Timebase Description/Configuration

Description

The time base source is selected by the test set, either an internal time base or an external source (if a suitable signal is detected) is used as the reference oscillator. If a 10 MHz +/- 100 ppm signal, that has an input level from 0 to +13 dBm is connected to the 10 MHz REF IN connector on the rear panel, the test set will automatically select the external timebase.

You can read the status window at the bottom of the test set display for the EXT REF indicator, or query the test set to verify if it is using an external time base or an internal time base. You may also query the test set to verify if the time base is locked. The reference oscillator functionality is controlled through the SYSTEM subsystem.

Example:

OUTPUT 714;"SYSTEM:ROSCILLATOR[:TIMEBASE]?" !returns INT or EXT
                                            !(internal or external) timebase.
OUTPUT 714;"SYSTEM:ROSCILLATOR:LOCKED?" !returns 1 or 0 (locked or unlocked)
                                        !condition for timebase

Related Topics

SYSTem:ROSCillator


PL Subtype 2 Access Channel MAC Subtype

PL Subtype 2 Access Channel MAC Subtype

Last updated: July 10, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

In Active Cell operating mode, the PL Subtype 2 Access Channel MAC Subtype allows you to select either the Default or the Enhanced Access Channel MAC protocol subtype when the Protocol Rel is set to release A (1xEV-DO-A) and the Release A Physical Layer Subtype is set to Subtype 2 . What you set is negotiated with the AT during Session Negotiate State . When the test set is configured to protocol release 0 or protocol release A with subtype 0 physical layer, only the Default Access Channel MAC protocol is negotiated.

The Default (Subtype 0) indicates that the protocol subtype assigned to the Access Channel MAC protocol is Default Access Channel MAC and its Subtype ID number is 0x0000. The Enhanced (Subtype 1) indicates that the protocol subtype assigned to the Access Channel MAC protocol is Enhanced Access Channel MAC and its Subtype ID number is 0x0001.

As defined by the C.S0024-A standard, when a session is not open, the test set is internally configured to the Default Access Channel MAC protocol. When a session is successfully open, the specified Access Channel MAC Subtype is configured for the session.

As shown in the table below, the current Access Channel MAC Subtype indicates the Access Channel MAC protocol that the test set is emulating. It is displayed on the Configurable Attribute In Use window on the Access Network Information screen or can be queried with CALL:STATus:PROTocol:ACMac? .

Determination of Current Access Channel MAC Subtype
Protocol Release | Physical Layer Subtype | Connection State | Current Access Channel MAC Subtype
A (1xEV-DO-A) | Subtype 2 | Idle State (session not open) | Default Access Channel MAC protocol
 |  | Session Open or Connected | Default or Enhanced Access Channel MAC protocol (depending on the setting of PL Subtype 2 Access Channel MAC Subtype )
 | Subtype 0 | Does not matter | Default Access Channel MAC protocol
0 (1xEV-DO) | Does not matter | Does not matter | Default Access Channel MAC protocol

When the Protocol Rel is set to release A (1xEV-DO-A) and the Release A Physical Layer Subtype is set to Subtype 2 , changing the PL Subtype 2 Access Channel MAC Subtype results in a session re-negotiation once a session is open. If a connection is open, changing the PL Subtype 2 Access Channel MAC Subtype results in the connection dropped with signaling. You will have to re-open the connection. For details, see Session Negotiate State .

NOTE
The PL Subtype 2 Access Channel MAC Subtype defaults to the Enhanced setting. Negotiating a session when the Protocol Rel set to release A (1xEV-DO-A) and the Release A Physical Layer Subtype set to Subtype 2 will fail if the AT does not support Enhanced Access Channel MAC protocol. When using an AT that does not support Enhanced Access Channel MAC Protocol, the PL Subtype 2 Access Channel MAC Subtype should be changed from Enhanced to Default.

Related Topics

GPIB Command: CALL[:CELL]:PROTocol:ACMac

Manual Operation:

  • To Configure the Test Set to Default Access Channel MAC Subtype
  • To Configure the Test Set to Enhanced Access Channel MAC Subtype

Enhanced Access Rate

Release A Physical Layer Subtype

Protocol Rel

Test Application Protocol

Enhanced Test Application Protocol


ACK Channel Bit Fixed Mode Attribute

ACK Channel Bit Fixed Mode Attribute

The ACK Channel Bit Fixed Mode Attribute controls whether the AckChannelBitFixedMode attribute is included in the FTAP Parameter Assignment Message or FETAP Parameter Assignment Message sent to the AT. The FTAP Parameter Assignment Message is sent when the test set is configured to TAP (see Test Application Protocol ). The FETAP Parameter Assignment Message is sent when the test set is configured to ETAP (see Enhanced Test Application Protocol ). If the FETAP Parameter Assignment Message is sent, the ACK Channel Bit Fixed Mode Attribute is also used to control whether the ACKChannelModulationTypeFixedMode attribute (see ACK Channel Modulation Type ) is included in the FETAP Parameter Assignment Message .

ACK Channel Bit Fixed Mode Attribute can be set to:

  • On (ACK Channel Bit Fixed mode enabled)

    In this mode, the ACKChannelBitFixedMode attribute is included in the FTAP Parameter Assignment Message or FETAP Parameter Assignment Message sent to the AT. This means the access terminal must transmit the R-ACK channel in every slot and set the transmitted ACK Channel bit to the value specified by the ACKChannelBit field in the ACKChannelBitFixedMode attribute (ACKChannelBit field is fixed to 1 (Nak) by the test set. See Fixed Settings ). If the FETAP Parameter Assignment Message is sent, the ACKChannelModulationTypeFixedMode attribute is also included (see ACK Channel Modulation Type ).

  • Off (ACK Channel Bit Fixed mode not enabled)

    In this mode, the ACKChannelBitFixedMode attribute is NOT sent in the FTAP Parameter Assignment Message or FETAP Parameter Assignment Message . This means the access terminal acknowledges forward test packets addressed to it as in normal system operation. That is, the access terminal transmits a positive acknowledgment (Ack) on the R-ACK channel if it successfully receives a packet addressed to it on the Forward Traffic Channel. Otherwise, the access terminal transmits a negative acknowledgment (Nak) on the ACK channel. A Forward Traffic Channel physical layer packet is considered successfully received if it has a valid FCS (frame check sequence). The forward test packets addressed to the AT is controlled by the AT Directed Packets . If no forward test packet is addressed to it, the AT does not transmit the R-ACK.

In order for the R-ACK Channel to be active in all slots, you must set ACK Channel Bit Fixed Mode Attribute to on.

To force the AT not to transmit the R-ACK Channel in any slots, you must set the ACK Channel Bit Fixed Mode Attribute to off and AT Directed Packets to 0% so that the AT does not receive any forward test packets to acknowledge. (It is not necessary to set AT Directed Packets to 0% if Test Application Protocol is set to RTAP and Limited TAP is on. In this state, the test set does not transmit any forward test packets. See Transmit Forward Test Packets? .) The TROLPC measurement requires the AT not to transmit the R-ACK channel (see Time Response of Open Loop Power Control (TROLPC) Measurement Description ).

ACK Channel Bit Fixed Mode Attribute can be changed at any time, and an FTAP Parameter Assignment Message or FETAP Parameter Assignment Message will immediately be sent by the test set, reflecting the setting.

The ACK Channel Bit Fixed Mode Attribute is displayed on the Call Setup screen in the Application Configuration window when the Session Application Type is set to Test Application in the Active Cell operating mode.

The test set ranges its receiver as if the R-ACK Channel is always present in every slot (even if no R-ACK channel is transmitting). See Expected Power .

Related Topics

Manual Operation: How Do I Change Call Parameters?

GPIB Command: CALL[:CELL]:APPLication:ACKChannel:BFMAttribute[:STATe]

C.S0029 Test Application Specification Description (TAP/ETAP)

Test Application Protocol

Enhanced Test Application Protocol

ACK Channel Modulation Type


ACK Channel Gain

ACK Channel Gain

ACK Channel Gain sets the power of the R-ACK Channel relative to the power of the R-Pilot Channel.

The ACK Channel Gain parameter is sent in the Traffic Channel Assignment message (see TAP/ETAP Data Connection Call Flow ).

ACK Channel Gain can be changed at any time.

Related Topics

GPIB Command: CALL:MS:ACKGain[:RTPilot]

Manual Operation: How Do I Change Channel Gain/Traffic Info Parameters?


ACK Channel Modulation Type

ACK Channel Modulation Type

Last updated: June 30, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

ACK Channel Modulation Type sets the type of the modulation used to transmit the reverse ACK (R-ACK) channel for subtype 2 physical layer. It is sent to the access terminal in the ACKChannelModulationTypeFixedMode attribute in the FETAP Parameter Assignment Message when the test set is configured to ETAP (see Test Application Configuration ) and the ACK Channel Bit Fixed Mode Attribute is set to On.

ACK Channel Modulation Type
ACK Channel Modulation Type | ACK Channel Modulation Type Fixed Mode attribute value (C.S0029-A) | Description
Bi-Polar Keying | 0 | Indicates the R-ACK channel using BPSK (Bi-Polar keying) modulation where a +1 implies an ACK (positive acknowledgment) and -1 implies a NAK (negative acknowledgment).
On-Off Keying | 1 | Indicates the R-ACK channel using OOK (On-Off keying) modulation where a 1 implies an ACK (positive acknowledgment) and 0 implies a NAK (negative acknowledgment).

ACK Channel Modulation Type can be changed at any time.

The ACK Channel Modulation Type is displayed on the Call Setup screen in the Application Configuration window when the Session Application Type is set to Test Application , the Release A Physical Layer Subtype is set to Subtype 2 and the ACK Channel Bit Fixed Mode Attribute is set to On in the Active Cell operating mode.

When ACK Channel Bit Fixed Mode Attribute is Off, the AT uses the modulation for the R-ACK channel based on the type of the received packet (Single User or Multi-User). The C.S0024-A air interface standard specifies that the ACK channel modulation is fixed to the BPSK mode when acknowledging a Single User packet and fixed to the OOK mode when acknowledging a Multi-User packet. The test set only supports Single User packets in Test Application configuration, so the AT will always use the BPSK modulation for the R-ACK channel when ACK Channel Bit Fixed Mode Attribute is Off.

Related Topics

GPIB Command: CALL[:CELL]:APPLication:ACKChannel:MODulation

Manual Operation: How Do I Change Call Parameters? (Application Configuration menu)


Test Application Protocol

Test Application Protocol

Last updated: June 16, 2006

When the test set is configured to the Test Application Protocol (TAP) (see Test Application Configuration ) and a data connection is established ( Connected State ) in the Active Cell operating mode, the Test Application Protocol setting determines if RTAP (Reverse Test Application Protocol) or FTAP (Forward Test Application Protocol) is enabled for controlling the test.

The RTAP configures the TAP (0x0003) for testing of the AT's transmitter while the FTAP configures the TAP (0x0003) for testing of the AT's receiver. See C.S0029 Test Application Specification Description (TAP/ETAP) .

The FTAP Parameter Assignment message and RTAP Parameter Assignment message are both sent to the access terminal to configure the TAP (0x0003) when a TAP data connection is established. The FTAP Parameter Assignment message is always sent first. What attributes are included in these messages and the test set behavior depend on the current Test Application Protocol and Limited TAP settings.

FTAP/RTAP Parameter Assignment Messages versus Limited TAP and TAP Settings
Test Application Protocol =FTAP | Test Application Protocol =RTAP
Limited TAP = Off | Limited TAP = On | Limited TAP = Off | Limited TAP = On

FTAP Parameter Assignment Message
DRC Value Fixed mode

If DRC Value Fixed Mode Attribute is set to on, then the DRC Value Fixed Mode attribute is sent (DRC Value Fixed Mode is enabled). The DRC Value field is set to FTAP Rate .

If DRC Value Fixed Mode Attribute is set to off, then the DRC Value Fixed Mode attribute is NOT sent (DRC Value Fixed mode is NOT enabled).

 The DRC Value Fixed Mode attribute is NOT sent (DRC Value Fixed mode is NOT enabled).
DRC Cover Fixed mode | DRC Cover Fixed Mode attribute is NOT sent (DRC Cover Fixed mode is NOT enabled). Since there is only one sector in the test set, there is no need to fix the DRC Cover. The DRC Cover for the test set is sent in the Traffic Channel Assignment message.
ACK Channel Bit Fixed mode

If ACK Channel Bit Fixed Mode Attribute is set to on, then the ACK Channel Bit Fixed Mode attribute is sent (ACK Channel Bit Fixed mode is enabled). The ACK Channel Bit is set to 1 (see Fixed Settings ).

If ACK Channel Bit Fixed Mode Attribute is set to off, then the ACK Channel Bit Fixed Mode attribute is NOT sent (ACK Channel Bit Fixed mode is NOT enabled).
Loop Back mode | Loop Back Mode attribute is sent (Loop Back mode is enabled). | Loop Back Mode attribute is NOT sent (Loop Back mode is NOT enabled).

RTAP Parameter Assignment Message
RTAP Test Packet mode | RTAP Test Pkt Enable attribute is NOT sent (RTAP Test Packet mode is NOT enabled). | RTAP Test Pkt Enable attribute is sent (RTAP Test Packet mode is enabled). This indicates that AT is to start sending RTAP Test Packets on the reverse traffic channel.
Packet Rate Mode | Packet Rate Mode attribute is NOT sent (Configured Packet Rate mode is NOT enabled). | Packet Rate Mode attribute is sent (Configured Packet Rate mode is enabled). MinRateIndex and MaxRateIndex fields are both set according to the RTAP Rate .
Test Set Configuration

Transmit Forward Test Packets?

 Yes No
Maintain Connection if TAP or Limited TAP setting Changed? | Yes

The Test Application Protocol setting can be set at any time. Changing this setting when a TAP data connection is established will cause the TAP to re-negotiate FTAP or RTAP on the existing traffic channel.

The Test Application Protocol is displayed on the Call Setup screen in the Application Configuration window when the test set is configured to TAP (see Test Application Configuration ) in the Active Cell operating mode.

Related Topics

GPIB Command: CALL[:CELL]:APPLication[:TAPPlication][:TYPE]

Manual Operation: How Do I Change Call Parameters?

C.S0029 Test Application Specification Description (TAP/ETAP)

TAP/ETAP Data Connection Call Flow

TAP/ETAP Data Connection Processing States Lifecycle

Enhanced Test Application Protocol


AT Directed Packets

AT Directed Packets

3GPP2 C.S0033-A section 8.4.3.5 specifies :

When the access terminal under test is in the Connected State and a 100% packet activity is required (see Fixed Settings , Forward Packet Activity), the access network equipment shall conform to the following rules for the generation of packets:

  • All the slots during the test will contain Forward Traffic Channel packets or Control Channel packets (100% packet activity).
  • Unless otherwise explicitly stated, the serving rate of the access terminal under test shall be 50%. Therefore, at every slot that a new Forward Traffic Channel packet is to be generated, the access network equipment shall generate a uniformly distributed random number "x" between 0 and 1.
    • If x > 0.5, the Forward Traffic Channel packet shall be directed to the access terminal under test.
    • Otherwise, the Forward Traffic Channel packet shall be a filling packet emulating other users' activity.
  • The packets emulating other users must be of the same length as the length of the packets generated for the access terminal under test. The Preamble MAC index used for the filling packets shall be any valid MAC index number different from the one used for the access terminal under test.

The test set implements this requirement but allows for the percentage of packets directed to the AT under test to be varied. The AT Directed Packets specifies what percentage of the packets are directed to the AT under test. This parameter can be set between 0 and 100%, in 1% increments. The default value is 50%. The AT Directed Packets is displayed on the Call Setup screen in the Application Configuration window.

If the AT under test has enough processing power to receive more than 50% of the valid FTAP or FETAP test packets, you can increase the AT Directed Packets parameter and speed up PER testing, optimizing throughput. For more description on the FTAP or FETAP, see C.S0029 Test Application Specification Description (TAP/ETAP) .

NOTE
If Limited TAP is on while Test Application Protocol is set to FTAP, AT Directed Packets must not be greater than 50%, and RTAP Rate must be set to 9.6 kbps.

In order for the R-ACK Channel to be active, you must set ACK Channel Bit Fixed Mode Attribute to on, and set AT Directed Packets to a non-zero value.

Operating Considerations ( Lab Application Only )

In the Lab Application , when the Session Application Type is set to the Default Packet Application , the AT Directed Packets will determine the maximum percentage of Forward Traffic Channel packets that will be directed to the AT.

  • You should always set the AT Directed Packets to 100% for maximum throughout. This allows the test set to send data to the AT under test in all possible slots. Note that achieving maximum throughout also depends on other parameters of your test setup such as Window Size, TCP or UDP protocol, etc.
  • When there is no data or not sufficient amounts of data to send to the AT, the actual percentage directed to the AT will be lower that the AT Directed Packets setting.

Related Topics

Programming: Programming a Packet Error Rate (PER) Measurement

GPIB Command: CALL[:CELL]:APPLication:ATDPackets

Manual Operation: How Do I Change Call Parameters?


AT Max Power

AT Max Power

Last updated: June 16, 2006

Expected Power is used to range the test set's receiver. If the output power of the access terminal is more than 9 dB below the expected power, an under range integrity indicator is returned by the test set. If your settings for cell power, amplitude offset, open loop adjust and other parameters determining the expected power of the access terminal require the AT to output a power above its rated maximum power, then its power will likely be below the expected power. To prevent this from happening, you can specify AT Max Power, which defines an upper limit for the expected power. Expected power tracks the expected power from the access terminal based on the open loop equation, until it reaches AT Max Power. Expected power is then clipped to the AT Max Power value.

AT Max Power can be changed at any time.

Manual Operation: AT max power can be set by selecting F6 on the Call Control 1 of 2 menu from the Call Setup screen. AT max power is reported on the Call Setup screen in the Access Terminal Information (User Entered) window.

The possible settings for AT Max Power are based on the lower limit of the 4.3.4 Maximum RF Output Power minimum standard for each cell band and AT power class.

AT Max Power
Cell Band | AT Power Class | Max Power Specification, Lower Limit (dBm)
US Cellular, Japan Cellular | I | +31
 | II | +27
 | III | +23
US PCS, Korean PCS, US PCS 1900 | I | +28
 | II | +23
 | III | +18
 | IV | +13
 | V | +8
NMT-450 | I | +33
 | II | +28
 | III | +23
 | IV | +18
IMT-2000 (outside Japan) | I | +28
 | II | +23
 | III | +18
 | IV | +13
 | V | +8
IMT-2000 (inside Japan) | I and II | +20
 | III | +18
 | IV | +13
 | V | +8
Secondary 800 | I | +27
 | II | +23

Related Topics

GPIB Command: CALL:MS:POWer:MAXimum <[:SELected]|:IMT2000|:JCDMa|:KPCS|:NMT450|:SECondary800|:USCellular|:USPCs|:USPCs1900>


Auxiliary Pilot Channel Gain

Auxiliary Pilot Channel Gain

Last updated: June 16, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

When the test set is in the Active Cell operating mode with Protocol Rel set to the A (1xEV-DO-A) and Release A Physical Layer Subtype set to the Subtype 2, the Auxiliary Pilot Channel Gain sets the power of the R-Auxiliary Pilot channel relative to the power of the R-Data channel (-15 to 0 dB, in 1 dB step). It is used by the AT to compute the transmit power of the R-Aux Pilot channel if transmitted. To determine when the R-Aux Pilot channel is transmitted, see Auxiliary Pilot Channel Min Payload .

The Auxiliary Pilot Channel Gain is a "Configurable Attribute" that is used to set part of the AuxiliaryPilotChannelParameters attribute for the Subtype 3 Reverse Traffic Channel MAC Protocol. It is negotiated with the AT during session negotiation. When a session is open, changing the Auxiliary Pilot Channel Gain results in a session re-negotiation. See Session Negotiate State for details.

Related Topics

GPIB Command: CALL:MS:APGain[:RTTRaffic]

Manual Operation: How Do I Change Channel Gain/Traffic Info Parameters? (under Channel Gain Parameters menu)


Block Diagram

Block Diagram

Last updated: July 28, 2006

Description

RF Interface Module

Input and output signals are routed through the RF Interface module. The RF Interface module consists of:

  • A directional bridge for sampling incoming power.
  • Hybrid power splitters which create 4 bidirectional ports (two receiver ports and two source ports). The directional bridge couples power to the Power Detector.
  • RF amplifiers.
  • Video gain circuits.
  • Fast and thermal power detectors.

The RF Interface module provides two identical RF Source path connections to the In/Out port of the instrument. There is about 25 dB of isolation between the two source paths. There is about 35 dB of isolation between the source paths and either receiver path. The RFIO module has nominally 23 dB of insertion loss in the source path. A temperature sensing circuit facilitates compensation for path loss variation with temperature.

The source signals can be looped back through the input signal path to cross-calibrate the Measurement Downconverter and the Power Detector.

The sampled input power from the directional bridge can be amplified by as many as two 18 dB range amplifiers and then can be directed to the fast detector or the thermal detector. The input power to the fast detector is detected by a diode detector that is part of a feedback loop. The input to the thermal detector is measured in a bridge using a pair of RMS thermal detectors in a feedback loop.

Signal Downconversion

The test set's downconversion receiver section has two downconversion modules; a Measurement Downconversion Module for making measurements, and a Demodulation Downconversion Module for maintaining the radio link.

Demodulation Downconverter Module

The Demodulation Downconverter module is used as part of the demodulation receiver that maintains the radio link.

Measurement Downconverter Module

The Measurement Downconverter module provides high quality (wide dynamic range, spurious free) signals to the Analog To Digital Converter module's measurement sampler input.

The Measurement Downconverter module is designed for very high performance operation to ensure accurate and repeatable measurement results. The Measurement Downconverter module contains two downconversion stages, two local oscillators, and a logarithmic IF envelope detector . Both first and second LO synthesizers are tunable. The first LO is used when tuning to the RF input frequency, and the second LO is used when setting second IF frequency, which is fed to the measurement sampler on the Analog To Digital Converter module.

Link Subsystem

The Link Subsystem maintains the radio link for all CDMA formats. The Link Subsystem has two parts:

  • Protocol Processor
  • Optional Link Subsystem hardware

The Protocol Processor module is responsible for maintaining the radio link between the test set and the mobile station under test. The primary tasks of the Protocol Processor module are:

  • Generating the protocol messaging necessary for the forward channel and sending that protocol stream to the test set's RF source for transmission to the mobile station.
  • Decoding the protocol messaging received from the mobile station under test on the reverse channel.
  • Computing measurement results which are associated with data bits contained within the mobile stations messaging, such as bit error ratio and frame error rate.

The optional Link Subsystem hardware provides additional signaling link control for CDMA signaling formats. These include:

  • Layer 1 digital signal processing.
  • Providing I/Q baseband signals which are sent to the I/Q modulator in the RF Source

Analog To Digital Converter Module

Following the Measurement Downconverter and Demodulation Downconverter IF 1 is the Analog to Digital Converter module. The purpose of the Analog to Digital Converter module is to convert the downconverted analog signals into digital data streams which can be processed by the Digital Signal Processing module.

In order to maintain the radio link of non-CDMA formats, the downconversion path through the Demodulation Downconverter module has a dedicated A/D conversion path.

To optimize measurement throughput, the fast RF power detector also has a single dedicated A/D path. This allows power measurements, in many cases, to be made concurrently with other measurements. The two outputs from the Measurement Downconverter module and the Audio In signal share a single multiplexed A/D path.

The outputs of the various analog to digital converters on the Analog to Digital Converter module share a common data bus with the Digital Signal Processing module.

Digital Signal Processing Module

The Digital Signal Processing (DSP) module is responsible for a variety of tasks within the overall test set architecture. These tasks are:

  • Demodulate data from the radio under test (data received from the Demodulation Downconverter module) and sending the demodulated data bits to the Protocol Processor module.
  • For some systems, perform audio measurements using audio information sent to the DSP module from the Protocol Processor module.
  • Execute a variety of signal processing algorithms to perform measurements on the radio system of the currently loaded TA (data received from the power detector ADC, the measurement ADC and, in some cases, data received from the Demodulation Downconverter ADC).

The DSP processor communicates with the Host Processor and the Protocol Processor, as well as controlling the configuration and synchronization of the Analog To Digital Converter module.

Host Processor Module

The Host Processor module is responsible for a variety of tasks within the overall test set architecture. These tasks include:

  • Control of the manual user interface (MUI).
  • Executing commands and processing data received from the LAN interface.
  • Executing commands and processing data received from the GPIB interface.
  • Controlling hard disk access.
  • Control of all RF and audio hardware modules.
  • Routing measurement results received form the Digital Signal Processing and Protocol Processor modules to the appropriate output device (display, GPIB, LAN, serial, etc.).

Voltmeter/Counter

Voltmeter

The voltmeter is used to measure internal voltages for instrument self-diagnostics.

Frequency Counter

The Frequency Counter is used to measure external frequencies from the front panel Audio IN, High or Low BNC connectors, and to measure internal signals for diagnostics. The external input can receive a signal between 20 Hz and 50 MHz, with a level from 25 mV to 8 V rms.

Audio Section

Audio Analysis Path

Externally applied audio signals can be analyzed through the test set's DSP module for such characteristics as AC level, SINAD, or distortion.

The audio signal to be analyzed is input to the test set using the front panel Audio IN High/Low connectors. The signal is then routed to the Analog To Digital Converter module's measurement sampler for analysis by the DSP module.

The Audio In connector accepts signals from 20 Hz to 15 KHz, at input levels from 10 mV to 20 V peak.

Audio 1 Path

The Audio 1 path provides analog baseband signals used for frequency modulation of the test set's RF sources. Up to four separate audio sources may be summed together in any combination to provide the composite Audio 1 output. These include the external FM input, internal direct digital synthesis (DDS,) regenerated SAT, and audio echo input.

The external FM input accepts an externally supplied audio signal with a peak voltage between 0.25 and 2 V peak.

The internal DDS generates low distortion audio signals from DC to 20 KHz with 0.1 Hz resolution. One to four signals may be generated and internally summed, with independent level control of each waveform.

The SAT regeneration circuit outputs a signal which is phase-locked to a received SAT signal. This is useful for testing situations where the test set needs to emulate a mobile station.

The audio echo input is used for retransmitting the received audio after a selectable time delay, to check both radio transmit and receive paths simultaneously.

For most applications, only one or two of these Audio 1 path sources are enabled at any given time.

Audio 2 Path

The Audio 2 path provides a secondary means for sending analog baseband signals to the FM modulator. Audio 2 contains only one source, a DDS similar to that used for Audio 1.

Typically, the Audio 2 path DDS is used for cases where multiple signals must be summed together with the lowest possible distortion. Another potential use of Audio 2 would be to obtain higher output levels than Audio 1 is capable of (up to twice as much), assuming the two outputs are set to the same frequency and phase, and then summed together at the Baseband Generator module.

Audio 2 is rarely used in practice because the DDS used for Audio 2 is the same DDS that is used for the front panel audio output.

Audio Out Path

Any one of four inputs may be coupled to the front panel audio output connector. These include a 4 channel DDS (shared with Audio 2), receiver discriminator audio from the Demodulation Downconverter module, audio echo from the Analog To Digital Converter module, and audio vocoder.

The front panel output is capable of providing signal levels up to 9 V peak into > 600 ohm loads, and up to 0.8 V peak into an 8 ohm load (e.g. speaker). The output level is calibrated for all modes except discriminator audio,
The discriminator audio has an uncalibrated volume control provided due to the high tolerances involved.

Typically the DDS mode is used to feed the MIC input of a radio, or it may simply be used as a general purpose low distortion function generator.

Audio echo can be selected to route the received audio to the front panel audio output connector.

RF Sources

The test set has up to two identical RF sources. The RF sources are used to provide analog or digitally modulated RF carriers for use in parametric testing of mobile stations encompassing a variety of cellular radio formats. In general, the sources have a frequency range of 292 MHz to 2.7 GHz and an amplitude range of -10 dBm to -127 dBm.

The RF sources consist of a Synthesized Signal Generator module followed by a Vector Output module and an RF Attenuator module. Baseband modulation information is supplied to the RF sources from a Baseband Generator module preceded by an Audio Section module.

Baseband Generators

The purpose of the Baseband Generator module is to provide, for the modulation type currently in effect, properly formatted baseband signals to the modulation circuits on the RF Source modules.

The Baseband Generator performs several functions related to the generation and processing of these base-band modulation signals. These are:

  • Transform data and clock signals from the Protocol Processor module into base-band analog I/Q modulation signals for the I/Q modulator in the Vector Output module
  • Transform data from the Protocol Processor module into baseband FSK modulation for the FM modulator in the Signal Generator module
  • Provide baseband FM path source selection, gain adjustment and summing node for analog FM signals from the Audio module and internally generated baseband FSK signals which are output to the FM modulator in the Signal Generator module
  • Transform burst and adjacent timeslot signals from the Protocol Processor module into baseband burst modulation signals for the burst modulator in the Vector Output module

Related Topics

Calibrating the Test Set


Active Cell Operating Mode

Active Cell Operating Mode

Active Cell mode is the test set's default operating mode, and is used to emulate a 1xEV-DO access network cell interacting with the access terminal (AT).

The Active Cell Operating Mode allows you to make a signalling connection between the test set and an AT. When connected, the AT's performance can be measured using the suite of measurements shown when the Measurement selection key is pressed.

The basic features provided by active cell operating mode are:

  • Data Connection Processing

    • Start Data Connection
    • End Data Connection
    • Close Session
    • Hard Handoff (Cell Band and Channel)
    • Hybrid Mode operations ( Lab Application Only ) (see Hybrid Mode )
  • Access Network Emulation
    • Protocol Releases: both release 0 and release A (see Protocol Rel )
    • Cell Power and AWGN
    • Code Channels: Pilot, Traffic, Control, and MAC Channels

    • Cell Bands (see Cell Band )

  • Application Support (see Session Application Type )

    • Test Application Protocols (see C.S0029 Test Application Specification Description (TAP/ETAP) )
      • Forward Test Application Protocol (FTAP)
      • Reverse Test Application Protocol (RTAP)
      • Forward Enhanced Test Application Protocol (FETAP)
      • Reverse Enhanced Test Application Protocol (RETAP)

    • ( Lab Application Only ) Default Packet Application (DPA) (see Session Application Type )

      • Data Channel

  • ( Lab Application Only ) Protocol Logging (see Protocol Logging )

Related Topics

Operating Mode

IS-856 Test Operating Mode ( Lab Application Only )


Cell Band

Cell Band

The test set's access network emulator provides a selection of cell bands.

Cell Bands
Cell Band | Programming Mnemonic | C.S0024 Band Class | Forward Link Frequency Range (MHz) | Reverse Link Frequency Range (MHz)
US Cellular | USCellular | 0 | 860 - 894 | 815 - 849
US PCS | USPCs | 1 | 1930 - 1990 | 1850 - 1910
Japan CDMA | JCDMa | 3 | 832 - 870 | 887 - 925
Korean PCS | KPCS | 4 | 1840 - 1870 | 1750 - 1780
NMT-450 | NMT450 | 5 | 421 - 494 | 411 - 484
IMT-2000 | IMT2000 | 6 | 2110 - 2170 | 1920 - 1980
Secondary 800 | SECondary800 | 10 | 851 - 869, 935 - 940 | 806 - 824, 896 - 901
US PCS 1900 | USPCs1900 | 14 | 1930 - 1995 | 1850 - 1915

Cell band can be changed at any time. Changing cell band initiates an implicit handoff (see Handoff ).

Related Topics

GPIB Command: CALL:BAND

Manual Operation: How Do I Change Call Parameters?


Channel

Channel

The range of RF channels available varies by band class.

CDMA Channel Number to CDMA Frequency Assignment
Cell Band | Channel Number | Preferred Channel Number | Center Frequency for Forward Channel N (MHz) | Center Frequency for Reverse Channel N (MHz)
US Cellular | 1-799 | 384 | 0.03*N+870.000 | 0.03*N+825.000
 | 991-1023 |  | 0.03*(N-1023)+870.000 | 0.03*(N-1023)+825.000
 | 1024 - 1323 |  | 0.030*(N-1024) + 860.040 | 0.030*(N-1024) + 815.040
US PCS | 0-1199 | 525 | 1930.000+0.05*N | 1850.000+0.05*N
Japan Cellular | 1-799 | 76 | 0.0125*N+860.000 | 0.0125*N+915.000
 | 801-1039 |  | 0.0125*(N-800)+843.000 | 0.0125*(N-800)+898.000
 | 1041-1199 |  | 0.0125*(N-1040)+832.000 | 0.0125*(N-1040)+887.000
 | 1201-1600 |  | 0.0125*(N-1200)+838.000 | 0.0125*(N-1200)+893.000
Korean PCS | 0-599 | 325 | 1840.000+0.05*N | 1750.000+0.05*N
NMT-450 | 1-300 | 210 | 0.025*(N-1)+460.000 | 0.025*(N-1)+450.000
 | 539-871 |  | 0.025*(N-512)+421.000 | 0.025*(N-512)+411.000
 | 1039-1473 |  | 0.025*(N-1024)+461.000 | 0.025*(N-1024)+451.000
 | 1792-2016 |  | 0.025*(N-1792)+489.000 | 0.025*(N-1792)+479.000
IMT-2000 | 0-1199 | 525 | 2110.000+0.05*N | 1920.000+0.05*N
Secondary 800 | 0-719 | 820 | 0.025*N+851.000 | 0.025*N+806.000
 | 720-919 |  | 0.025*(N-720)+935.000 | 0.025*(N-720)+896.000
US PCS 1900 | 0-1299 | 525 | 1930.000+0.05*N | 1850.000+0.05*N

Channel can be changed at any time. Changing channel initiates an implicit handoff (see Handoff ).

Related Topics

GPIB Command: CALL:CHANnel

Manual Operation: How Do I Change Call Parameters?


CDMA System Time Parameters

CDMA System Time Parameters

  • Overview
  • CDMA System Time Parameters and Information
  • Operating Consideration

Overview

The CDMA system time is the time reference used by all IS-95/IS-2000 and IS-856 systems. It is synchronous to UTC time (Universal Coordinated Time) except for leap seconds and uses the same time origin as GPS (Global Positioning System) time. Access terminals (ATs) use the same system time, offset by the propagation delay from the AN to the AT.

The test set emulating an AN allows you to set the CDMA System Time , Leap Seconds and IS856 Local Time Offset (hh.mm) which are sent to the AT in the overhead messages ( Sync Message and SectorParameters Message ). The AT determines its local time based on these parameters. When the AT successfully synchronize its system time to the test set, the local time that is displayed on the AT's screen should be same as the CDMA Local Time displayed on the test set's CDMA System Time Information window.

The settable CDMA system time provides convenience to verify AT's time-based applications such as alarms, calendar, meeting scheduler, etc.

( Lab Application Only ) The settable CDMA system time is required by multiple test sets synchronization. For details, see Multi-unit Synchronization .

CDMA System Time Parameters and Information

  • CDMA System Time

    The CDMA System Time consists of two portions: CDMA System Time (Date) and CDMA System Time (Time) which are set from the CDMA System Time Parameters menu when the test set is in idle state. The CDMA system time in the test set starts at what you set (or internal RTC time when shipped from the factory) and keeps going as the UTC time (Universal Coordinated Time) without leap seconds. It is shown on the CDMA System Time Information window and updated every two seconds. To get a more accurate CDMA system time running in the test set, use CALL[:CELL]:CSTime:TIME ? query command which has one second resolution.

    The CDMA System Time (Date) can be set to any date from January 6, 1980 to January 5, 2080. The CDMA System Time (Time) can be set to any time of the day. You can change the CDMA system time while the test set is in idle state. When setting the CDMA system time from the front panel, you can use a simple way. For example, to set the CDMA System Time to January 1, 2000 2:00 PM, you can simply enter 2000.1.1 in the CDMA System Time (Date) field and enter 14 in the CDMA System Time (Time) field. Moreover, <second> you enter in odd number will be automatically rounded up to an even number.

    The CDMA system time is stored in the test set's non-volatile RAM. Power-cycle, full preset and save/recall operations do not affect the ongoing CDMA system time but power cycle may cause minor uncertainty on CDMA system time. (see Operating Consideration ).

    GPIB Command: CALL[:CELL]:CSTime:DATE and CALL[:CELL]:CSTime:TIME

  • Leap Seconds

    Specifies the leap seconds since the start of CDMA system time. It is ranged from 0 to 255 seconds. It is used by CDMA Local Time calculation.

    It is stored in the test set's non-volatile RAM and is not affected by power cycle, full preset or save/recall operations.

    GPIB Command: CALL[:CELL]:CSTime:LOCal:LEAP

  • IS856 Local Time Offset (hh.mm)

    Specifies the local time offset from CDMA system time. It is ranged from -17.00 to +17.00 hours. It is used by CDMA Local Time calculation.

    It is stored in the test set's non-volatile RAM and is not affected by power cycle, full preset or save/recall operations.

    GPIB Command: CALL[:CELL]:CSTime:LOCal:OFFSet[:SELected] or CALL[:CELL]:CSTime:LOCal:OFFSet:TA856

  • CDMA Local Time

    Like the CDMA system time, the CDMA local time consists of two portions: CDMA Local Time (Date) and CDMA Local Time (Time) which are shown on the CDMA System Time Information window and updated every two seconds. The CDMA local time is a calculated value which is based on the formula:

    CDMA Local Time = CDMA System Time (Date) + CDMA System Time (Time) - Leap Seconds + Local Time Offset

    The CDMA local time is primarily used to verify the correctness of the time displayed on the AT's screen. When the AT successfully acquires and synchronizes with the test set, the time displayed on the AT's screen should be same as the CDMA Local Time (Date) and CDMA Local Time (Time) that are shown on the test set.

    GPIB Command: CALL:STATus:CSTime:LOCal:DATE? and CALL:STATus:CSTime:LOCal:TIME?

NOTE
Changing the Local Time Offset or Leap Seconds results in the CDMA local time immediately updated on the test set's CDMA System Time Information window. However, since these parameters are sent to the AT in the overhead message ( SectorParameters Message ), the local time displayed on the AT's screen may not be same as that on the test set until the updates in the overhead message is received by the AT.

Operating Consideration

  • The CDMA System Time (Date) and the CDMA System Time (Time) are available only in Active Cell or IS-856 Test Mode operating mode.
  • The CDMA System Time (Date) and the CDMA System Time (Time) can only be set when the test set is in idle state.

    NOTE
    Most ATs will immediately open a session with the test set once they reach the idle state upon power-up. You can close the session at any time (see Session Closing State ) and the data connection will be taken to the idle state. However, most ATs will try to immediately re-establish a session. You can prevent the AT from re-establishing a session by turning Call Limit Mode on.

  • There is about +/- 1 second uncertainty on CDMA system time when any of the following actions is performed.
    • Cycle power the test set.
    • Perform the Channel Power Calibration, Open Loop ALC Calibration or Average Power Calibration (See Calibrating the Test Set ).
    • Change the Digital Bus Path setting on the test set (See Digital Bus Information ).
    • Switch the application format (for example switch between cdma2000 and 1xEV-DO applications) (see Test Application Switching ).
    • Switch the Operating Mode from CW (with Test Signal set to AM or DSB-SC ) to Active Cell or IS-2000 Test Mode .

Related Topics

Manual Operation: How Do I Change CDMA System Time Parameters?


CW Operating Mode

CW Operating Mode

Last updated: June 16, 2006

Description

When in CW operating mode, the test set operates like a signal generator. The basic features provided by CW operating mode are:

  • No over the air signaling is used. Therefore there is no synchronization between the mobile station and test set.
  • No demodulation or channel decoding is available.
  • No automatic receiver control is provided. Expected CW power, measurement receiver frequency, and uplink receiver frequency are available as manual settings only.

    Manual receiver control settings made while using the CW operating mode can affect manual receiver settings made in other operating modes. When changing operating modes and using manual receiver settings, always verify that the manual receiver settings are correct for the new operating mode.

  • Any one of three test signals can be generated while analyzing another signal (at the same frequency or at a different frequency). No interaction exists between these controls.
  • All test set measurements are available while in CW operating mode. However, measurements requiring protocol triggering cannot be made. Immediate triggering should be used for most measurements because no overhead signaling is occurring. Protocol triggering will timeout or report an integrity indicator other than zero.

Test Signals Description

The test set in CW operating mode provides any one of three test signals: CW (no modulation), AM (fixed 56% amplitude modulation), and DSB-SC (dual side-band suppressed carrier). An example usage of the test signals is for calibrating mobile stations that use Qualcomm's radioOne™ Zero Intermediate Frequency (Zero IF) architecture.

You can select any one of three signals with adjustable power level and frequency for output to the currently selected front panel RF connector.

  • With CW test signal selected (the default setting), the test set provides an unmodulated carrier. With either AM or DSB-SC test signal selected, the test set will modulate the signal as shown in the following figure.
  • For any of the test signals selected, the output power level is controlled by the Cell Power ( F7 ). The Cell Power refers to the power found in the entire signal including sidebands if applicable.
  • For any of the test signals selected, the frequency is adjusted by changing the RF Gen Freq ( F8 ).
    • With the CW or AM signal selected, the RF Gen Freq setting represents the center frequency of the signal (fc).
    • With the DSB-SC signal selected, the RF Gen Freq setting represents the frequency of the lower sideband signal (fL). The upper sideband (fh) is 20 kHz above the RF Gen Freq setting, that is fh = fL+20 kHz.

Programming Usage

Use the following commands to control each function for CW operating mode:

  • Select CW operating mode: CALL[:CELL]:OPERating:MODE
  • Set the cell power output level to be transmitted by the test set: CALL:POWer
  • Set the RF generator frequency: CALL[:CELL]:RFGenerator:FREQuency
  • Set the expected CW power level to be received by the test set: RFANalyzer:CW:EXPected:POWer
  • Set the measurement receiver frequency: RFANalyzer:MANual:MEASurement[:MFRequency]

Operating Considerations

  • When in CW operating mode, switching the test signals requires a few seconds. This delay is also encountered when changing operating modes if the current test signal is not CW.
  • Changing the operating mode affects manual receiver control parameters. See Effects on Receiver Control When Changing Operating Mode .
  • See Calibrating the Test Set .

Related Topics

Operating Mode


Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power

Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power

Last updated: June 29, 2006

The test set's access network emulator provides control over the following RF power levels:

Cell Power

Î or is defined in C.S0033 as the received power spectral density of the Forward Channel as measured at the access terminal antenna connector. The Forward Channel is defined as a CDMA Channel from an access network to access terminals. The Forward Channel is transmitted on a CDMA frequency assignment using a particular pilot PN offset. If you have accounted for path loss (see Amplitude Offset ) between the test set output port and the access terminal antenna connector, then cell power is equivalent to Î or .

AWGN Power

I oc is defined in C.S0033 as the power spectral density of a band-limited white noise source (simulating interference from other cells) as measured at the access terminal antenna connector. If you have accounted for path loss, then AWGN power is equivalent to I oc .

The test set also reports:

Total RF Power

Total RF Power is the sum of cell power and AWGN power. I 0 is defined in C.S0033 as the total received power spectral density, including signal and interference, as measured at the access terminal antenna connector. If you have accounted for path loss, then total RF power is equivalent to I 0 .

E b /N t

E b /N t is the ratio (in dB) of the combined received energy per bit to the effective noise power spectral density for the Control Channel or Forward Traffic Channel at the access terminal antenna connector (assuming you have accounted for path loss). It is calculated as follows:
Traffic E b /N t = Traffic_Chip_Bit + Î or /I oc (all in dB). (Traffic_Chip_Bit is the number of PN chips per Forward Traffic Channel bit.)

Cell Power, AWGN Power and Total RF Power Ranges

The range of values that you can set these power levels to differs from the actual hardware range of the source. This is due to compensation for path loss between the test set output and the access terminal antenna connector (see Amplitude Offset ).

For example, if you enter a value of -30 dBm for desired CW cell power, this indicates that you want -30 dBm of power at the access terminal antenna connector. So, if you have indicated an amplitude offset of -3.5 dB exists between the test set's RF In/Out port and the access terminal's antenna connector, the source will actually have to output -26.5 dB in order to deliver -30 dB to the access terminal antenna connector. Thus, with an amplitude offset of -3.5 dB, the settable range of CW cell power is -130.5 dB to -13.5 dB. The actual power range at a given time is defined by adding the value of the associated amplitude offset to the actual hardware range. If you select an invalid combination of power levels and amplitude offsets, an error message will appear.

Range of Power Levels
Parameter | Actual Hardware Range with Amplitude Offset = 0 (RF In/Out Port) | Actual Hardware Range with Amplitude Offset = 0 (RF Out Only Port) | Setting (or Query) Range
Cell Power (CW) | -127 dBm to -10 dBm | -119 dBm to -2 dBm | -177 dBm to +40 dBm
Cell Power (DIGital856) | -120 dBm/1.23 MHz to -13 dBm/1.23 MHz | -115 dBm/1.23 MHz to -5 dBm/1.23 MHz | -170 dBm/1.23 MHz to +37 dBm/1.23 MHz
AWGN Power (DIGital856) | -120 dBm/1.23 MHz to -15 dBm/1.23 MHz | -115 dBm/1.23 MHz to -7 dBm/1.23 MHz | -170 dBm/1.23 MHz to +35 dBm/1.23 MHz
Total RF Power | -120 dBm/1.23 MHz to -10.88 dBm/1.23 MHz | -115 dBm/1.23 MHz to -2.88 dBm/1.23 MHz | -170 dBm/1.23 MHz to +42 dBm/1.23 MHz
Eb/Nt |  |  | -24.26 dB to +33.80 dB

For the lab application , an external AWGN value is available when the test set is configured to generate faded forward channel signals with AWGN. This setup requires a rear panel digital bus connection to an external PC running Baseband Studio software. See Digital Bus Information for details.

Programming Usage

The test set includes commands to set the desired cell power and AWGN power levels. You may also query what you've set these desired power levels to, as well as query what the total RF power will be based on your desired cell power and AWGN power levels. See "Command to Set/Query Desired Level" in RF Power Levels and Noise Ratio Commands .

The test set also includes commands to query the current level of cell power, AWGN power, total RF power and E b /N t . See "Command to Query Current Level" in RF Power Levels and Noise Ratio Commands . These CALL:STATus commands are query only. They return values that indicate the test set's actual hardware settings and hardware status. Actual hardware settings can differ from the desired level you've set if you've broken one of the rules above for setting power levels. If this happens, there will be a persistent error reported by the test set indicating the problem. When no error conditions exist, the commands used to set the desired level will return the same results as the commands used to query current level. For example, "CALL:AWGNoise:POWer?" will return the same value as "CALL:STATus:AWGNoise:POWer?" when no error conditions exist. Although the CALL:STATus commands are available for your use, it is a best practice to query the desired power levels instead and include error trapping in your control program to look for errors indicating the desired and current power levels are not equal (see Error Messages ).

RF Power Levels and Noise Ratio Commands
Parameter | Command to Set/Query Desired Level | Command to Query Current Level
Cell Power | CALL[:CELL]:POWer[:SAMPlitude]<[:SELected]|:CW|:DIGital856> | CALL:STATus:CELL[1]:POWer:[AMPLitude]<[:SELected]|:DIGital856>?
AWGN Power | CALL:AWGNoise[:INTernal]:POWer[:SAMPlitude]<[:SELected]|:DIGital856> | CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude]<[:SELected]|:DIGital856>?
Total RF Power | CALL:TOTal:POWer[:AMPLitude]<[:SELected]|:DIGital856>? (query only) | CALL:STATus:TOTal:POWer[:AMPLitude]<[:SELected]|:DIGital856>?
E b /N t | none | CALL:STATus:TRAFfic[:CELL[1]]:EBNTotal?

Rules for Setting Power Levels and Amplitude Offsets

  • The difference between cell power and AWGN power must not be more than 35 dB when both powers are ON.
  • The total RF power and amplitude offset must not set the source outside its valid hardware range.
  • When the test set is configured to physical layer subtype 2 and both Cell power and AWGN power are On, the power level of any MAC code channel generated must not be greater than 30dB below the current Total RF Power. When any cell or AWGN power level is changed such that any code channel is more than 30dB below the Total RF Power, an error message is posted to indicate the error condition. When this happens, the cell or AWGN setting is pended (not applied to the hardware) and the current power setting is not updated (left at previous value). See Code Channel Parameters for setting the power levels of the MAC code channels.

Related Topics

Manual Operation: How Do I Change Generator Information?


Receiver Control

Receiver Control

  • Automatic Receiver Control
  • Manual Receiver Control in Active Cell Operating Mode
  • Manual Receiver Control in IS-856 Test Operating Mode
  • Manual Receiver Control in CW Operating Mode
  • Under Range/Over Range Errors
  • Effects on Receiver Control When Changing Operating Mode

The test set's receiver includes two frequency downconverters:

  • Measurement downconverter
  • Demodulation downconverter

The Demodulation downconverter is used to establish and maintain the connection (RF link) between the access terminal and test set, while the Measurement downconverter is optimized for measurements.

Refer to the Block Diagram for a description of the Signal Downconversion paths.

Automatic Receiver Control

Automatic receiver control is the default for all operating modes except CW (see CW Operating Mode ). With automatic receiver control, the test set automatically tunes to the correct frequencies for making measurements and maintaining a connection. Also, the test set automatically adjusts attenuation settings according to the power level that should be present at the RF IN/OUT port given the current settings. This power level is referred to as the expected power, and the current value for expected power is displayed on many of the transmitter power measurement screens.

When operating in active cell operating mode with automatic receiver power control, expected power is derived essentially from the cell power setting according to open loop power control behavior, but expected power is also offset by other settings (see Expected Power ). Tune frequencies are derived from the channel field setting (see Channel ).

In some instances, you may want to control the test set's receiver settings manually rather than allowing the test set to automatically control them. This ability is referred to as manual receiver control.

In CW operating mode, you must always specify what frequencies and power the receiver should tune to, there is no automatic receiver control.

Manual Receiver Control in Active Cell Operating Mode

For front panel operation, see Manual Receiver Control in Active Cell or Cell Off Operating Mode .

Manual receiver power

When the Rcvr Power Ctrl field is set to manual (manual receiver power control is selected), an additional field is displayed below Rcvr Power Ctrl. That field is labeled Receiver Power, and when it is displayed automatic receiver power control is disabled. The test set will adjust its attenuation to receive a signal at the level indicated by the Receiver Power field.

Use the following commands for manual receiver power control:

  • RFANalyzer:CONTrol:POWer:AUTO (to set receiver power control to manual)
  • RFANalyzer:MANual:POWer<[:SELected]|:DIGital856> (to set the Receiver Power)

When reverse power control (Rvs Power Ctrl) is set to Active bits, closed loop power control will drive the access terminal's transmitted power to the power level set in the Receiver Power field. To effectively disable closed loop power control and inhibit the test set's ability to drive the access terminal's power level to the manually set Receiver Power, select alternating bits in the Rvs Power Ctrl field. With alternating bits is selected in the Rvs Power Ctrl field, cell power level changes will control the access terminal's power level according to open loop power control behavior.

Measurement downconverter frequency

When a frequency is entered in the Meas Frequency field, the selection labeled Auto is replaced by a manual receiver control tune frequency. The receiver will no longer be tuned according to the channel number entered in the Channel field.

The commands used to manually tune the test set's measurement downconverter input signal path are:

  • RFANalyzer:MANual:MEASurement[:MFRequency] (to specify a receiver measurement frequency and turn manual mode on)

  • RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO (to turn manual receiver measurement frequency mode on/off)

  • RFANalyzer:MANual:MEASurement:FREQuency (to specify a receiver measurement frequency)

Demodulation downconverter frequency

In Active Cell operating mode, there is no access to manual control of the receiver demodulation frequency. (Refer to the Block Diagram for a description of the Signal Downconversion paths.)

Manual Receiver Control in IS-856 Test Operating Mode

For front panel operation, see Manual Receiver Control in IS-856 Test Operating Mode .

Manual receiver power

When the Rcvr Power Ctrl field is set to manual (manual receiver power control is selected), an additional field is displayed below Rcvr Power Ctrl. That field is labeled Receiver Power, and when it is displayed automatic receiver power control is disabled. The test set will adjust its attenuation to receive a signal at the level indicated by the Receiver Power field.

Use the following commands for manual receiver power control:

  • RFANalyzer:CONTrol:POWer:AUTO (to set receiver power control to manual)
  • RFANalyzer:MANual:POWer<[:SELected]|:DIGital856> (to set the receiver power)

In IS-856 test mode the access terminal can be programmed to respond to closed loop power control bits. If the access terminal is responding to power control bits, and with alternating bits selected in the Rvs Power Ctrl field, cell power level changes will control the access terminal's power level according to open loop power control behavior.

Measurement downconverter frequency

When a frequency is entered in the Meas Frequency field, the selection labeled Auto is replaced by a manual receiver control tune frequency. The receiver will no longer be tuned according to the channel number entered in the Channel field.

The measurement receiver frequency commands used to manually tune the test set's measurement downconverter input signal path are:

  • RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO (to turn manual mode on/off)

  • RFANalyzer:MANual:MEASurement[:MFRequency] (to specify a receiver measurement frequency and turn manual mode on)

  • RFANalyzer:MANual:MEASurement:FREQuency (to specify a receiver measurement frequency)

Demodulation downconverter frequency

When a frequency is entered in the Rvs Link Freq field, the selection labeled Auto is replaced by a manual receiver control tune frequency. In manual mode, the receiver's demodulation downconverter will no longer be tuned according to the channel number entered in the Channel field.

The commands used to manually tune the test set's demodulation downconverter input signal path are:

  • RFANalyzer:CONTrol:UPLink:FREQuency:AUTO (to turn manual mode on/off)

  • RFANalyzer:MANual:UPLink[:MFRequency] (to specify a receiver demodulation frequency and turn manual mode on)

  • RFANalyzer:MANual:UPLink:FREQuency (to specify a receiver demodulation frequency)

NOTE
Manual control of the demodulation receiver frequency is rarely needed. If you require control of the receiver's measurement frequency, see Measurement downconverter frequency
.

Manual Receiver Control in CW Operating Mode

For front panel operation, see Manual Receiver Control in CW Operating Mode .

Manual receiver power

When the Receiver Control softkey is selected, a menu drops down that includes a setting for Expected CW Power. The test set will adjust its attenuation to receive a signal at the level indicated by the Expected CW Power.

For CW operating mode, the Expected CW Power from the access terminal is set manually using the RFANalyzer:CW:EXPected:POWer command.

Measurement downconverter frequency

When the Receiver Control softkey is selected, a menu drops down that includes a setting for Measurement Frequency.

The command used to manually tune the test set's measurement downconverter input signal path is:

  • RFANalyzer:MANual:MEASurement:FREQuency (to specify a receiver measurement frequency)

Demodulation downconverter frequency

When the Receiver Control softkey is selected, a menu drops down that includes a setting for Uplink Frequency.

The command used to manually tune the test set's demodulation downconverter input signal path is:

  • RFANalyzer:MANual:UPLink:FREQuency (to specify a receiver demodulation frequency)

NOTE
Manual control of the receiver demodulation frequency is rarely needed. If you require control of the receiver's measurement frequency, see Measurement downconverter frequency .

Under Range/Over Range Errors

The test set uses the expected power level to establish a range of acceptable input levels into its receivers. If the received signal is above or below the acceptable range, an Over Range or an Under Range message is displayed and the integrity value for the measurement is set to 5 or 6 (respectively). Refer to Integrity Indicator for details about the integrity values.

You can set the expected power level beyond the capability of the test set's hardware because expected power is intended to reflect the potential range of RF power at the access terminal . This range of RF power is meant to accommodate the use of a gain or loss network between the access terminal and the test set. See Amplitude Offset for details about amplitude offset.

The upper and lower limits of expected power provide boundaries for the combination of amplitude offset and expected power. If you set expected power to +52 dBm and the amplitude offset to -3 dB, the calculated receiver power will be 49 dBm, but the test set shall be set to +43 dBm, the upper limit of the hardware. If the calculated value of receiver power goes below -25 dB, the lower limit of the hardware, the test set shall be set to -25 dB.

Effects on Receiver Control When Changing Operating Mode

After selecting the operating mode and setting one or more receiver controls to manual, the receiver control settings remain as you set them until you change operating mode. Changing operating mode (except for CW which defaults to manual) causes some or all receiver parameters to return to automatic control.

Related Topics

Manual Operation: Manual Receiver Control

Expected Power

RFANalyzer

CW Operating Mode

Active Cell Operating Mode

IS-856 Test Operating Mode ( Lab Application Only )


IS-856 Test Operating Mode

IS-856 Test Operating Mode

  • Overview
  • Parameters for IS-856 Test Operating Mode

NOTE
The test set currently does not support protocol release A (see Protocol Rel ) in IS-856 Test operating mode. When the test set is configure to the protocol release A, switching to the IS-856 Test operating mode is rejected with an error message.

The following section is only applicable to the IS-856 Test mode operations in protocol release 0.

Overview

The test set's IS-856 Test operating mode is used when it is not possible, or not desired, to communicate via over-the-air signaling with the access terminal (AT), but forward link stimulus and reverse link measurements are still needed.

In IS-856 Test operating mode, the test set does not send any signalling information on the forward link. Any changes to the access terminal (AT) configuration, such as channel, MAC index, forward traffic data rate, etc., must be accomplished by directly sending commands to the AT from a system controller (usually a personal computer) through a proprietary digital interface.

Upon entry into IS-856 Test operating mode, the test set begins continuously transmitting a forward link signal which consists of forward channels such as pilot, MAC, and traffic channels. The PC controller is required to initiate the test mode in the AT, step the AT through the call setup process (such as acquire pilot, acquire sync, and demodulate forward traffic channel). When the AT synchronizes to the forward channels and successfully demodulates the forward link signal, the AT starts transmitting a corresponding reverse link signal. The AT's transmitter performance can then be measured using the suite of measurements shown when the Measurement selection key is pressed. A typical test setup is shown in the figure below.

Typical Measurement Setup in IS-856 Test Mode

Parameters for IS-856 Test Operating Mode

Most of the call processing parameters used in the Active Cell operating mode are also available in the IS-856 Test mode (see How Do I Change Parameters in IS-856 Test Operating Mode? for details).

The table below only shows the key parameters that are set differently while in the IS-856 Test mode and in the Active Cell mode.

Key Different Parameters Used in Active Cell and in IS-856 Test operating mode
Settings | IS-856 Test Operating Mode | Active Cell Operating Mode
MAC Index | 5 - 63 (see MAC Index in IS-856 Test Operating Mode ) | 5 (see MAC Index in Active Cell Operating Mode )
Fwd Traffic Rate | See Forward Traffic Rate in IS-856 Test Operating Mode . | See FTAP Rate .
Exp R-Data Rate | See Expected Reverse Data Rate in IS-856 Test Operating Mode . | See RTAP Rate .
Manual Receiver Control | See Manual Receiver Control in IS-856 Test Operating Mode . | See Manual Receiver Control in Active Cell Operating Mode .
RF Generator Frequency | To set a forward link frequency that does not correspond to a defined channel number, you can set the test set's RF generator frequency control to manual and enter a RF generator frequency manually. See CALL[:CELL]:CONTrol:DOWNlink:FREQuency:AUTO and CALL[:CELL]:RFGenerator:FREQuency . | The test set's RF generator frequency can only be determined from the Band and Channel number corresponding to the standard definition.
Closed Loop Power Control | Three modes are available, Alternating bits, All Up bits, All Down bits. See Reverse Closed Loop Power Control for description. | Four modes are available, Active bits, Alternating bits, All Up bits, All Down bits. See Reverse Closed Loop Power Control for description.

Related Topics

Manual Operation: How Do I Change Parameters in IS-856 Test Operating Mode?


Call Drop Timer

Call Drop Timer

The call drop timer can be enabled (turned on) or disabled (turned off).

Once a data connection is established, if the call drop timer is enabled, the call drop timer is started.

When the call drop timer is turned on, if the test set is unable to correctly decode the reverse link for a period of 5 seconds, the call drop timer expires and the test set drops the data connection without signaling (and transitions to the Session Open State ).

If the test set is able to decode the reverse signal, the call drop timer is reset.

Related Topics

GPIB Command: CALL:CONNected:DROP:TIMer[:STATe]<[:SELected]|:TA856>

Manual Operation: How Do I Change Call Parameters?


Call Limit Mode

Call Limit Mode

Call limit mode can be enabled (turned on) or disabled (turned off).

When call limit mode is on, the test set will not respond to any access probes from the access terminal (during events such as opening a session or connection, keep alive mechanisms etc.). This forces the access terminal to repeatedly send access probes.

IMPORTANT
You can not open a session when call limit mode is on.

IMPORTANT
You can not change a parameter which is configured during the Session Negotiate State when a session is open and call limit mode is on.

Related Topics

GPIB Command: CALL:CONNected:LIMit[:STATe]<[:SELected]|:TA856>

Manual Operation: How Do I Change Call Parameters?


Color Code

Color Code

The color code identifies the test set's sector.

Color code is sent in the Quick Config message (see TAP/ETAP Data Connection Call Flow ).

Color code can be changed at any time.

Related Topics

GPIB Command: CALL[:CELL]:CCODe

Manual Operation: How Do I Change Cell Parameters?


Connected State

Connected State

In the connected state, the test set has established a physical link connection (traffic channel) with the access terminal (AT). The AT can use the Reverse Traffic Channel and the test set can use the Forward Traffic Channel and Control Channel to communicate with each other.

( only for lab application ) When the test set is configured to use the Default Packet Application (see Session Application Type ), the connected state only indicates a physical link connection and does not mean that a PPP connection is open. Only if the AT is assigned an IP address during PPP connection establishment procedure, the connected state indicates both a PPP connection and a physical connection are established between the AT and the test set (see AT Initiated Packet Data Connection from Idle State ).

The connected state is a non-transitory state (see TAP/ETAP Data Connection Processing Lifecycle and Packet Data Connection Processing States Lifecycle ).

To query the state of the data connection, see Data Connection State Synchronization .

Related Topics

TAP/ETAP Data Connection Processing States Lifecycle

TAP/ETAP Data Connection Call Flow

Packet Data Connection Processing States Lifecycle ( Lab Application Only )

Packet Data Connection Call Flow ( Lab Application Only )


Connection Closing State

Connection Closing State

In the connection closing state, the test set is in the process of closing the data connection.

To close a TAP/ETAP data connection, send the CALL:FUNCtion:DATA:STOP command or select End Data Connection . ( F3 on Call Control). You can close the connection at any time, and the data connection will be taken to the session open state.

( only for lab application ) The connection closing may result in the data connection going to Dormant State or Session Open State (depending upon whether the PPP connection is maintained or not). See Packet Data Connection Call Flow .

The connection closing state is a transitory state (see TAP/ETAP Data Connection Processing Lifecycle and Packet Data Connection Processing States Lifecycle ).

To query the state of the data connection, see Data Connection State Synchronization .

Related Topics

GPIB Command: CALL:FUNCtion:DATA:STOP

Programming: Step 7: End the Connection

Manual Operation: How Do I Close the Connection?

TAP/ETAP Data Connection Processing States Lifecycle

TAP/ETAP Data Connection Call Flow

Packet Data Connection Processing States Lifecycle ( Lab Application Only )

Packet Data Connection Call Flow ( Lab Application Only )


Connection Negotiate State

Connection Negotiate State

In the connection negotiate state, the test set is in the process of negotiating a data connection such as traffic channel configuration and TAP/ETAP configuration. See Connection Negotiate Procedure for details.

The connection negotiate state is a transitory state (see TAP/ETAP Data Connection Processing Lifecycle ).

To query the state of the data connection, see Data Connection State Synchronization .

Related Topics

TAP/ETAP Data Connection Processing States Lifecycle


Connection Request State

Connection Request State

In the connection request state, the test set has received a Connection Request message from the access terminal.

If the test set is initiating a test data connection (TAP/ETAP), it will page the access terminal (AT) and direct the AT to send a Connection Request message (see Paging Procedure ). If the AT is initiating a connection (for example, to establish a temporary connection for session negotiation. See Session Negotiate State .), it simply sends a Connection Request message.

( only for lab application ) When the Session Application Type is set to Default Packet Application , the data connection can be re-activated from the Dormant State to the Connected State by a Connection Request message from the AT (or in response to a page from the test set) (see AT Initiated Packet Data Connection Re-activation from Dormant State and AN Initiated Packet Data Connection Re-activation from Dormant State ).

The connection request state is a transitory state (see TAP/ETAP Data Connection Processing Lifecycle and Packet Data Connection Processing States Lifecycle ).

To query the state of the data connection, see Data Connection State Synchronization .

Related Topics

TAP/ETAP Data Connection Processing States Lifecycle

TAP/ETAP Data Connection Call Flow

Packet Data Connection Processing States Lifecycle ( Lab Application Only )

Packet Data Connection Call Flow ( Lab Application Only )

Data Connection State Synchronization

Fixed Settings , Connection Request Timeout


Control Channel Data Rate

Control Channel Data Rate

Last updated: June 16, 2006

Control channel data rate determines the rate used on the Control Channel.

The access terminal determines the control channel data rate based on MAC Index of the Control Channel packet preamble (see MAC Index for more information).

Control Channel Configuration
Rate (kbps) | Configuration Format (packet size, slots, preamble length) | MAC Index
38.4 | (1024, 16, 1024) | 3
76.8 | (1024, 8, 512) | 2

Control channel data rate can be changed at any time.

Operating Considerations

The test set does not support Enhanced Control Channel MAC Protocol and only supports Default Control Channel MAC Protocol for physical layer subtype 2. See Current Physical Layer Subtype and Associated Protocols .

Related Topics

GPIB Command: CALL:CCHannel:DRATe

Manual Operation: How Do I Change Cell Parameters?


Country Code

Country Code

Country code sets the 3-digit BCD encoded representation of the cell country code of the sector, which specifies the country that the sector resides in.

Country code is sent in the Sector Parameters message (see TAP/ETAP Data Connection Call Flow ).

Country code can be changed at any time and will be sent out in the next overhead message.

Related Topics

GPIB Command: CALL[:CELL]:MCCode<[:SELected]|:TA856>

Manual Operation: How Do I Change Cell Parameters?


TAP/ETAP Data Connection Processing States Lifecycle

TAP/ETAP Data Connection Processing States Lifecycle

As shown in the figure below, there are several key state transitions in the data connection processing lifecycle when the test set is configured to use the Test Application protocols (TAP/ETAP) (see Test Application Configuration ). For the key steps and messaging to establish a test data connection (TAP/ETAP), see TAP/ETAP Data Connection Call Flow .

TAP/ETAP Data Connection Processing Lifecycle

  1. Once the access terminal (AT) is powered on, it acquires the system and then moves into Idle state (see Idle State ).
  2. Before the AT can send or receive any test data packet, it must first open a session with the test set. The test set can then open a test data connection with the AT. The test set can't send data to the AT unless the AT has established a session. Only the AT can initiate a session. The AT initiates a session by sending a UATI Request (see UATI Request State ).
  3. The session is then configured through the negotiation of configurable attributes (see Session Negotiate State ). A temporary traffic channel connection is established for the session negotiation because the session negotiation is performed on a traffic channel connection. This temporary connection is closed after the session negotiation is complete. The temporary connection is initiated by the AT by simply sends a connection request (see Connection Request State ).
  4. Once the session negotiation is complete, the session is open (see Session Open State ). To change any of the configurable attributes for the session, the session must be renegotiated. The test set must be configured to TAP or ETAP (see Session Application Type for how to configure) prior to establishing a test data connection for AT's performance tests.
  5. Once this is complete, you can then start a TAP or ETAP data connection from the test set. Page the AT by pressing the F3 (Start Data Connection ) which directs the AT to send a Connection Request message (see Paging Procedure ).
  6. The connection configuration is then negotiated during the Connection Negotiate State , such as TAP/ETAP parameters used for a test environment (see C.S0029 Test Application Specification Description (TAP/ETAP) ).
  7. Once this is complete, the data connection is open (see Connected State ). Now, the AT and the test set can use the assigned traffic channel to send application traffic to each other.
  8. The AT may handoff to a new frequency because it is moving out of the current frequency coverage area, or perhaps the current frequency is heavily loaded and the network wants to balance the load (see Handoff State ).
  9. The connection may be closed by either the test set or AT (see Connection Closing State ).
  10. The session may be closed by either the test set or AT (see Session Closing State ).

NOTE
Access Network (AN): The network equipment providing data connectivity between a packet switched data network (typically the Internet) and the access terminals. An access network is equivalent to a base station in a cdma2000 system.

The test set can emulate an AN so that the term of the test set and the AN are interchangeable throughout this User's Guide.

Access Terminal (AT): A device providing data connectivity to a user. An access terminal may be connected to a computing device such as a laptop personal computer or it may be a self-contained data device such as a personal digital assistant. An access terminal is equivalent to a mobile station in a cdma2000 system.

Related Topics

TAP/ETAP Data Connection Call Flow

C.S0029 Test Application Specification Description (TAP/ETAP)

Data Connection State Synchronization

Idle State

UATI Request State

Session Negotiate State

Session Open State

Paging State

Connection Request State

Connection Negotiate State

Connected State

Handoff

Connection Closing State

Session Closing State


Data Offset 9k6|19k2|38k4|76k8|153k6

Data Offset 9k6|19k2|38k4|76k8|153k6

The data offset <rate> parameters include: data offset 9k6, data offset 19k2, data offset 38k4, data offset 76k8, and data offset 153k6, corresponding to the five RTAP Rate s of 9.6, 19.2, 38.4, 76.8 and 153.6 kbps, respectively.

The data offset <rate> parameters allow you to specify a rate-specific offset for the R-Data and R-Access Data Channels to their nominal power (see Data Offset Nom ). The power level of the R-Data and R-Access channels is determined by the specific data offset <rate> and other parameters (see Expected Power ). Note that for the subtype 2 physical layer R-Data, the TxT2P Gain Settings are used to specify the power offset of the R-Data channel.

Depending upon current physical layer subtype, these parameters are used in different protocols (as shown in the table below). To determine when each protocol is active, see Current Physical Layer Subtype and Associated Protocols .

Data Offset Parameters and Protocols Association
Protocols | Data Offset Parameters
Default Access Channel MAC | Data Offset Nom , Data Offset 9k6
Default Reverse Traffic Channel MAC | Data Offset Nom , Data Offset 9k6, Data Offset 19k2, Data Offset 38k4, Data Offset 76k8, And Data Offset 153k6
Enhanced Access Channel MAC | Data Offset Nom , Data Offset 9k6, Data Offset 19k2, Data Offset 38k4

The data offset <rate> parameters are "Configurable Attributes" negotiated with the AT for the protocol during the Session Negotiate State . When a session is open, changing a data offset <rate> parameter results in a session re-negotiation. If a data offset <rate> parameter is changed when a connection is open, the connection will be closed. You will have to re-open the connection. See Session Negotiate State for details.

Related Topics

GPIB Command: CALL:MS:DOFFset<:BPS9600|:BPS19200|:BPS38400|:BPS76800|:BPS153600>

Manual Operation: How Do I Change Channel Gain/Traffic Info Parameters?


Data Offset Nom

Data Offset Nom

Data Offset Nom allows you to specify the nominal offset of the R-Data and R-Access Data Channels to the R-Pilot Channel. It is used by the test set to range its receiver (see Expected Power ).

Data Offset Nom is a "Configurable Attribute" for the Default Access Channel MAC, Default Reverse Traffic Channel MAC and Enhanced Access Channel MAC protocols. To determine when each protocol is active, see Current Physical Layer Subtype and Associated Protocols . It is sent to the AT in the Configuration Request message during session negotiation. When a session is open, changing this setting results in a session re-negotiation. If Data Offset Nom is changed when a connection is open, the connection will be closed. You will have to re-open the connection. See Session Negotiate State for details.

Related Topics

GPIB Command: CALL:MS:DOFFset:NOMinal

Manual Operation: How Do I Change Channel Gain/Traffic Info Parameters?


DRC Channel Gain

DRC Channel Gain

DRC Channel Gain sets the power of the R-DRC Channel relative to the power of the R-Pilot Channel.

The DRC Channel Gain parameter is sent in the Traffic Channel Assignment message (see TAP/ETAP Data Connection Call Flow ).

DRC Channel Gain can be changed at any time.

Related Topics

GPIB Command: CALL:MS:DRCGain[:RTPilot]

Manual Operation: How Do I Change Channel Gain/Traffic Info Parameters? (under Channel Gain Parameters menu)


DRC Value Fixed Mode Attribute

DRC Value Fixed Mode Attribute

Last updated: June 16, 2006

The DRC Value Fixed Mode Attribute controls whether the DRCValueFixedMode Attribute is included in the FTAP Parameter Assignment Message or FETAP Parameter Assignment Message sent to the AT. The FTAP Parameter Assignment Message is sent when the test set is configured to TAP (see Test Application Protocol ). The FETAP Parameter Assignment Message is sent when the test set is configured to ETAP (see Enhanced Test Application Protocol ).

DRC Value Fixed Mode Attribute can be set to:

  • On (DRC Value Fixed Mode enabled)

    In this mode, the DRCValueFixedMode attribute is sent in the FTAP Parameter Assignment Message or FETAP Parameter Assignment Message . The test set dictates the DRC value of the Forward Traffic Channel by sending the DRCValue in the DRCValueFixedMode attribute. The AT is required to use the indicated DRC value. This means that the AT must set its transmitted DRC to the value specified by the DRCValueFixedMode attribute.

    The DRCValue in the DRCValueFixedMode attribute is set according to the FTAP Rate if sent in the FTAP Parameter Assignment Message or set according to the F-Traffic Format if sent in the FETAP Parameter Assignment Message .

  • Off (DRC Value Fixed Mode not enabled)

    In this mode, the DRCValueFixedMode attribute is not sent in the FTAP Parameter Assignment Message or FETAP Parameter Assignment Message . This means that the AT requests the DRC value based on the current link conditions as in real system operation.

    Unlike the subtype 0 physical layer, the subtype 2 physical layer supports multiple transmission formats in response to a DRC value requested by the AT. The F-Traffic Config determines which transmission format is used for each requested DRC value. To determine which physical layer subtype is configured, see Release A Physical Layer Subtype .

The DRC Value Fixed Mode Attribute is displayed on the Call Setup screen in the Application Configuration window when the Session Application Type is set to Test Application in the Active Cell operating mode.

Operating Considerations

  • DRC Value Fixed Mode Attribute can be changed at any time. However, in some cases, changing this setting may result in an error message posted (see Short Packet Enabled Threshold for details).
  • When the DRC Value Fixed Mode Attribute is on, the DRC value sent by the AT will match the DRC value that the test set directs the AT to send in all properly operating ATs. However, if the AT does not send the DRC value indicated by the test set, the test set will follow the DRC value sent by the AT. When this happens, there is no error or indication.

Related Topics

Manual Operation: How Do I Change Call Parameters? : Application Config menu

GPIB Command: CALL[:CELL]:APPLication:DRCChannel:VFMAttribute[:STATe]


DSC Channel Gain

DSC Channel Gain

Last updated: June 16, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

DSC Channel Gain sets the power of the R-DSC Channel relative to the power of the R-Pilot Channel (-15.5 to 0 dB, in 0.5 dB step). It is sent to the AT via the DSCChannelGain or DSCChannelGainBase parameter in the Traffic Channel Assignment message (see TAP/ETAP Data Connection Call Flow ) when the test set is in the Active Cell operating mode with Protocol Rel set to the A (1xEV-DO-A) and Release A Physical Layer Subtype set to the Subtype 2.

The DSC value carried on the R-DSC Channel is used by the AT to indicate to the AN the selected serving cell on the forward channel. The DSC value takes effect one slot after the end of its transmission and stays in effect for DSC Length slots.

DSC Channel Gain can be changed at any time.

Related Topics

GPIB Command: CALL:MS:DSCGain[:RTPilot]

Manual Operation: How Do I Change Channel Gain/Traffic Info Parameters? (under Channel Gain Parameters menu)


Termination Parameters

Termination Parameters

Last updated: June 16, 2006

  • Max Forward Packet Duration
  • ACK R-Data After

Max Forward Packet Duration

When the Forward Link Early Termination is disabled (see Fixed Settings ), the Max Forward Packet Duration is used with the DRC value requested by the access terminal to determine how many slots are transmitted for the current forward link data packet. It can be thought as a fake emulation for the forward link early termination.

For each physical layer packet, the test set transmits N slots, where the N is defined as the minimum of the number of slots per DRC and the Max Forward Packet Duration . For the number of slots per DRC, see FTAP Rate for the subtype 0 physical layer and DRC Value and Forward Transmission Formats for the subtype 2 physical layer.

If you set the Max Forward Packet Duration to a value less than the actual slots required for the physical layer packet per the DRC value, the effective data rate will be higher than the nominal data rate per the DRC. For example, the nominal date rate for the DRC value 1 with packet format (physical layer packet size = 512 bits, nominal transmit duration =16 slots, preamble length =1024 chips) is 19.2kbps. If you set the to Max Forward Packet Duration to 4 slots, the effective data rate will be 76.8 kbps.

The Max Forward Packet Duration is applicable to both the Active Cell or IS-856 Test operating mode for all supported application types (see Session Application Type ).

ACK R-Data After

This section is only applicable to the lab application and to a test application with the required feature license.

ACK R-Data After setting is used to emulate early termination on the reverse data channel (R-Data). It determines when the test set starts to send ACK bit on the forward ARQ channel upon reception of the R-Data subpackets.

ACK R-Data After setting is applicable when the test set is in the Active Cell operating mode with current physical layer subtype set to Subtype 2 (see Release A Physical Layer Subtype ) and the Active ARQ disabled (see Fixed Settings ).

In Subtype 2 physical layer operation, the AT can transmit up to four subpackets for each transmitted physical layer packet (see Background Information (Subpacket) ). The test set transmits a positive acknowledgment (ACK) or a negative acknowledgment (NAK) on the ARQ Channel in response to each received subpacket.

  • The H-ARQ bit (Hybrid ARQ bit) is sent after the first (subpacket 0), second (subpacket 1) or third subpacket (subpacket 2) for a physical layer packet is received by the test set.
  • The L-ARQ bit (Last ARQ bit) is sent after the reception of the fourth subpacket (subpacket 3).
  • The P-ARQ bit (Packet ARQ bit) is sent after a physical layer packet has been successfully received (H-ARQ or L-ARQ sends ACK) or has failed to be received (L-ARQ sends NAK) after all four subpackets have been sent.

The following table shows the ACK/NAK bit patterns that are transmitted by the test set on the forward ARQ channel according to the ACK R-Data After setting and the actual received reverse data subpackets.

Bit pattern sent on the forward ARQ channels
ACK R-Data After | ARQ Bits Sent after Reverse Traffic Subpacket N Is Received |  |  |  | Overall Packets (P-ARQ)
 | Subpacket 0 | Subpacket 1 | Subpacket 2 | Subpacket 3
 | H-ARQ | H-ARQ | H-ARQ | L-ARQ
Subpacket 0 (All ACK) | ACK | ACK * | ACK * | ACK * | ACK
Subpacket 1 | NAK | ACK | ACK * | ACK * | ACK
Subpacket 2 | NAK | NAK | ACK | ACK * | ACK
Subpacket 3 | NAK | NAK | NAK | ACK | ACK
Never (All NAK) | NAK | NAK | NAK | NAK | NAK
Note: * ACK is sent only if the subpacket is received. The AT is not expected to send the subpacket if it correctly demodulates and processes the previously received ACK for that physical layer subpacket.

When Subpacket 0 (All ACK) is selected, an ACK bit will be sent on the ARQ channels for every subpacket received. When Never (All NAK) is selected, an NAK bit will be sent on the ARQ channels for every subpacket received.

ACK R-Data After setting defaults to Never (All NAK) which is to force the AT listening to the ARQ channel to send all four subpackets for each physical layer packet.

Different modulation schemes are used on the ARQ channel. The L-ARQ bit and the P-ARQ bit are modulated using NAK-oriented ON-OFF Keying (0 implies ACK, -1 implies NAK) while the H-ARQ modulation depends upon the setting of H-ARQ Modulation .

Related Topics

GPIB Command:

  • Max Forward Packet Duration: CALL[:CELL]:APPLication:TRAFfic:PDURation:MAXimum
  • ACK R-Data After: CALL:MACChannel:ARQ:ACK:DATA[:REVerse][:AFTer]

Manual Operation: How Do I Change Generator Information? (Termination Parameters menu)

R-Data Pkt Size

Release A Physical Layer Subtype

Fixed Settings : Active ARQ, Forward Link Early Termination


Enhanced Access Rate

Enhanced Access Rate

Last updated: July 10, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

Enhanced Access Rate allows you to control the rate that the access terminal (AT) will use to transmit the Enhance Access Channel MAC packets when the Session Application Type is set to the Test Application and the Current Access Channel MAC Subtype is Enhanced Access Channel MAC. When the Current Access Channel MAC Subtype is Default Access Channel MAC, the access rate is always fixed to 9.6 kbps.

Enhanced Access Channel Rate
Rate Index | Enhanced Access Channel Rate (kbps)
0 | 9.6
1 | 19.2
2 | 38.4

In the Active Cell operating mode, when the Session Application Type is Test Application and the Current Access Channel MAC Subtype is Enhanced Access Channel MAC, the Enhanced Access Rate is included in the EnhancedAccessChannelRateMode attribute of the RETAP Parameter Assignment Message sent to the AT. For details on the RETAP Parameter Assignment Message , see Enhanced Test Application Protocol .

When the Enhanced Access Rate is configured for an ETAP connection, the AT is required to select the access channel rate based on the minimum of Enhanced Access Rate and Sector Access Max Rate. (Sector Access Max Rate is fixed to 38.4 kbps by the test set (see Fixed Settings ), so the enhanced access channel rate is always determined by the Enhanced Access Rate setting).

The Enhanced Access Rate can be changed at any time but only affects the access rate of the AT after an RETAP Parameter Assignment Message has been successfully sent and until a session is re-negotiated for the next access. The access rate that the test set expects the AT to use for the current or next access is displayed on the Expected Enhanced Access Rate field on the Call Setup screen in the Application Configuration window when the Protocol Rel is set to A (1xEV-DO-A ), the Session Application Type is set to Test Application , and the Release A Physical Layer Subtype is set to Subtype 2 ..

Related Topics

GPIB Command: CALL[:CELL]:APPLication:EACCess:DRATe

Manual Operation: How Do I Change Call Parameters?


Enhanced Traffic Parameters

Enhanced Traffic Parameters

Last updated: June 30, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

The Enhanced Traffic Parameters menu provides access to the configurable attributes for the Enhanced Forward Traffic Channel MAC and Subtype 3 Reverse Traffic Channel MAC protocols that are used with the subtype 2 physical layer protocol. To determine when the test set supports these protocols, see Current Physical Layer Subtype and Associated Protocols .

  • Auxiliary Pilot Channel Min Payload
  • DSC Length
  • Short Packet Enabled Threshold

Auxiliary Pilot Channel Min Payload

The Auxiliary Pilot channel (R-Aux Pilot) is transmitted by the AT when operating at high data rate to aid AN for reverse signal demodulation. When the test set is in the Active Cell operating mode with Protocol Rel set to A (1xEV-DO-A) and Release A Physical Layer Subtype set to Subtype 2, the Auxiliary Pilot Channel Min Payload specifies the minimum R-Data payload size (roughly corresponding to the data rate) at which point the AT is required to transmit the R-Aux Pilot channel. That is, when the AT is transmitting at a data rate (determined by R-Data Pkt Size ) no less than the Auxiliary Pilot Channel Min Payload , the AT is expected to transmit the R-Aux Pilot channel.

The Auxiliary Pilot Channel Min Payload is a "Configurable Attribute" that is used to set part of the AuxiliaryPilotChannelParameters attribute for the Subtype 3 Reverse Traffic Channel MAC Protocol. It is negotiated with the AT during session negotiation. When a session is open, changing the Auxiliary Pilot Channel Min Payload results in a session re-negotiation. See Session Negotiate State for details.

If the R-Aux Pilot channel is transmitted, the Auxiliary Pilot Channel Gain is used to control the power of the R-Aux Pilot Channel.

Operating Considerations

  • The test set can demodulate the reverse signal when R-Pilot takes up certain amount of the total received power. If you set the current TxT2P gain (see TxT2P Gain Settings ) very high but keep the AT from transmitting the R-Aux Pilot channel, the test set may not be able to demodulate the reverse signal. For example. when you set the AT to transmit 8192 bits packet at high TxT2P gain, no R-Aux Pilot is transmitted if the Auxiliary Pilot Channel Min Payload is set to 12288 bits. In this case, the test set may not be able to demodulate the reverse signal.

DSC Length

DSC Length determines the length of a single DSC transmission (in units of 8 slots). It is a "Configurable Attribute" that is used to set DSCLength attribute for the Enhanced Forward Traffic Channel MAC protocol. It is negotiated with the AT during session negotiation. When a session is open, changing the DSC Length results in a session re-negotiation. See Session Negotiate State for details.

The R-DSC channel is expected to be transmitted from the AT when Release A Physical Layer Subtype is set to subtype 2. The R-DSC channel is used by the AT to indicate to the AN the selected serving cell on the Forward Channel. The serving cell is indicated by the DSC value for that cell. The DSC value takes effect one slot after the end of its transmission and stays in effect for DSC Length slots. When the DSC channel is transmitted, its power is controlled by the DSC Channel Gain .

Short Packet Enabled Threshold

Short Packet Enabled Threshold determines the threshold that allows for use of the non-canonical transmission formats for the forward traffic channel (for subtype 2 physical layer) per the DRC value requested by the AT. It is applicable when the test set is in the Active Cell operating mode with Protocol Rel set to A (1xEV-DO-A) and the Release A Physical Layer Subtype set to Subtype 2.

  • If the canonical packet size for the received DRC value is less than the specified Short Packet Enabled Threshold value, the non-canonical (short packet) formats for the DRC value can be used. For details on the canonical and non-canonical forward transmission formats for a DRC value, see DRC Value and Forward Transmission Formats .

  • If any of the following conditions happen, an error message "Digital856 call processing settings deferred: Short Packets Enabled Threshold incompatible with forward traffic configuration" is posted. When the error is present, the test set uses the canonical transmission format for the received DRC value regardless of the user settings ( F-Traffic Config or F-Traffic Format ).

    • Short Packet Enabled Threshold is set to less than 4096 bits when the Session Application Type is Test Application , DRC Value Fixed Mode Attribute is Off and F-Traffic Config is not Canonical.
    • DRC Value Fixed Mode Attribute is On when the Session Application Type is Test Application and F-Traffic Format is set to a non-canonical value where the associated DRC value's canonical packet size is equal to or more than the Short Packet Enabled Threshold .

Short Packet Enabled Threshold is a "Configurable Attribute" for the Enhanced Forward Traffic Channel MAC protocol. It is negotiated with AT via the ShortPacketsEnabledThresh attribute during session negotiation. When a session is open, changing this setting results in a session re-negotiation. See Session Negotiate State for details.

Operating Considerations

  • The test set defaults the Short Packet Enabled Threshold to 4096 bits. This allows for all non-canonical (short packet) formats. It is not expected to be changed unless some ATs failed to open a session with this value. The default value set in the test set is not the protocol default value (2048 bits) as defined in the C.S0024-A. This opens the possibility of session failure for some ATs that only support the protocol default value. In this case, you may need to change the Short Packet Enabled Threshold to the value supported by your AT.
  • Signaling messages are always sent in the canonical format. This is to avoid the Signaling Link Protocol (SLP) from having to make very small fragments for the signaling messages that would be required with some non-canonical formats and forced single encapsulation (required for Test Applications).

Related Topics

GPIB Command:

  • Auxiliary Pilot Channel Min Payload: CALL:MS:APPayload[:MINimum]
  • DSC Length: CALL:MS:DSCLength[:SLOTs]
  • Short Packet Enabled Threshold: CALL[:CELL]:APPLication:TRAFfic:SPACket:THReshold

Manual Operation: How Do I Change Channel Gain/Traffic Info Parameters? (Enhanced Traffic Parameters menu)


TAP/ETAP Data Connection Call Flow

TAP/ETAP Data Connection Call Flow

The following diagrams illustrate the key steps and messaging to establish a test data connection (TAP/ETAP) between the access terminal (AT) and the test set. It is assumed that the test set has properly configured to the TAP or ETAP (see Test Application Configuration ).

( Lab Application Only ) For the key steps and messaging to establish a packet data connection (DPA), see Packet Data Connection Call Flow .

Initialization Procedure

UATI Request procedure

Session Negotiation Procedure

Paging Procedure

Connection Request Procedure

Connection Negotiate Procedure

Related Topics

TAP/ETAP Data Connection Processing States Lifecycle


Enhanced Test Application Protocol

Enhanced Test Application Protocol

Last updated: June 16, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

When the test set is configured to the Enhanced Test Application Protocol (ETAP) (see Test Application Configuration ) and a data connection is established ( Connected State ) in the Active Cell operating mode, the Enhanced Test Application Protocol setting determines if RETAP (Reverse Enhanced Test Application Protocol) or FETAP (Forward Enhanced Test Application Protocol) is enabled for controlling the test.

The RETAP configures the ETAP (0x000A) for testing of the AT's transmitter while the FETAP configures the ETAP (0x000A) for testing of the AT's receiver. See TAP/ETAP Data Connection Processing States Lifecycle .

The FETAP Parameter Assignment message and RETAP Parameter Assignment message are both sent to the access terminal to configure the ETAP (0x000A) as a data connection is established. The FETAP Parameter Assignment message is always sent first. What attributes are included in these messages and the test set behavior depend on the current Enhanced Test Application Protocol setting.

FETAP/RETAP Parameter Assignment Messages Versus ETAP Setting
Enhanced Test Application Protocol =FETAP | Enhanced Test Application Protocol =RETAP
FETAP Parameter Assignment Message
DRC Value Fixed Mode

If DRC Value Fixed Mode Attribute is set to on, then the DRC Value Fixed Mode attribute is sent (DRC Value Fixed Mode is enabled). The DRC Value field is set according to F-Traffic Format .

If DRC Value Fixed Mode Attribute is set to off, then the DRC Value Fixed Mode attribute is NOT sent (DRC Value Fixed mode is NOT enabled).
DRC Cover Fixed Mode | DRC Cover Fixed Mode attribute is NOT sent (DRC Cover Fixed mode is NOT enabled). Since there is only one sector in the test set, there is no need to fix the DRC Cover. The DRC Cover for the test set is sent in the Traffic Channel Assignment message.

ACK Channel Bit Fixed Mode

If ACK Channel Bit Fixed Mode Attribute is set to on, then the ACKChannelBitFixedMode attribute is sent (ACK Channel Bit Fixed mode is enabled). Also, the ACK Channel Bit value is fixed to 1 by the test set (see Fixed Settings ). If the ACKChannelBitFixedMode attribute is sent, the ACK Channel Modulation Type Fixed Mode attribute must also be sent.

If ACK Channel Bit Fixed Mode Attribute is set to off, then the ACK Channel Bit Fixed Mode attribute is NOT sent (ACK Channel Bit Fixed mode is NOT enabled).
Loop Back Mode | Loop Back Mode attribute is sent (Loop Back mode is enabled). This means the AT requires to transmit FETAP Loop Back Packets on the Reverse Traffic Channel. | Loop Back Mode attribute is NOT sent (Loop Back mode is NOT enabled).

ACK Channel Modulation Type Fixed Mode

If ACK Channel Bit Fixed Mode Attribute is set to on, then the ACKChannelModulationTypeFixedMode attribute is sent (ACK Channel Modulation Type Fixed mode is enabled). The ACKChannelModulationType field is set according to ACK Channel Modulation Type . Valid only for Subtype 2 physical layer protocol. If the ACKChannelModulationTypeFixedMode attribute is sent, the ACK Channel Bit Fixed Mode attribute must also be sent.

If ACK Channel Bit Fixed Mode Attribute is set to off, then the ACKChannelModulationTypeFixedMode attribute is NOT sent (ACK Channel Modulation Type Fixed mode is NOT enabled).
RETAP Parameter Assignment Message
RETAP Test Packet Mode

RETAP Test Pkt Enable attribute is NOT sent (RETAP Test Packet mode is NOT enabled).

 RETAP Test Pkt Enable attribute is sent (RETAP Test Packet mode is enabled). This indicates that AT is to start sending RETAP Test Packets on the reverse traffic channel.
Packet Rate Mode

Packet Rate Mode attribute is NOT sent (Packet Rate mode is NOT enabled) because it is only valid for Subtype 0 physical layer protocol sent in the RTAP Parameter Assignment Message .

For Subtype 2 physical layer protocol, Packet Payload Size Mode is used if the Reverse Traffic Channel payload size is to be configured.

Packet Payload Size Mode

Packet Payload Size Mode attribute is NOT sent (Packet Payload Size mode is NOT enabled). Valid only for Subtype 2 physical layer protocol.

Packet Payload Size Mode attribute is sent (Packet Payload Size mode is enabled). MinPayloadSizeIndex and MaxPayloadSizeIndex fields are set according to the R-Data Pkt Size . Valid only for Subtype 2 physical layer protocol.
Enhanced Access Channel Rate Mode

Enhanced Access Channel Rate Mode attribute is sent (Enhanced Access Channel Rate Mode is enabled). EnhancedAccessChannelRateIndex field is set according to the Enhanced Access Rate . Valid only for Enhanced Access Channel MAC protocol (see Release A Access Channel MAC Subtype ).

Burst Period Mode

Burst Period Mode attribute is NOT sent (Burst Period Mode is NOT enabled). Valid only for Subtype 2 physical layer protocol.

Burst Period Mode attribute is sent (the Configured Burst Period mode is enabled). The LinkFlowID field is set according to the Reverse Data Transmission Mode and the BurstSize field is set to 0xFFFF (see Fixed Settings ).

If the Burst Period Mode is sent, then the Burst Size Mode must also be sent. Valid only for Subtype 2 physical layer protocol.

Burst Size Mode

Burst Size Mode attribute is NOT sent (Burst Size Mode is NOT enabled). Valid only for Subtype 2 physical layer protocol.

Burst Size Mode attribute is sent (the Configured Burst Size mode is enabled). The LinkFlowID field is set according to the Reverse Data Transmission Mode and the BurstSize field is set to 0xFFFF (see Fixed Settings ). If the Burst Size Mode is sent, then the Burst Period Mode must also be sent. Valid only for Subtype 2 physical layer protocol.
Test Set Configuration
Transmit FETAP Test Packets? | Yes
Maintain Connection if ETAP setting Changed? | Yes

The Enhanced Test Application Protocol setting can be set at any time. Changing this setting when an ETAP data connection is established will cause the ETAP to re-negotiate FETAP or RETAP on the existing traffic channel.

The Enhanced Test Application Protocol is displayed on the Call Setup screen in the Application Configuration window when the test set is configured to ETAP (see Test Application Configuration ) in the Active Cell operating mode.

Related Topics

GPIB Command: CALL[:CELL]:APPLication:ETAPlication[:TYPE]

Manual Operation: How Do I Change Call Parameters?

Release A Physical Layer Subtype

C.S0029 Test Application Specification Description (TAP/ETAP)

TAP/ETAP Data Connection Call Flow

TAP/ETAP Data Connection Processing States Lifecycle

Test Application Protocol


Expected Power

Expected Power

Last updated: June 16, 2006

  • In Active Cell Operating Mode
  • In IS-856 Test Operating Mode
  • In CW Operating Mode
  • Range of Expected power

In Active Cell Operating Mode

In active cell mode, by default, receiver power control is set to auto (see Receiver Control ). In this mode, expected power is used to set the measurement and demodulation receiver powers. Expected power is calculated by the test set based on the power contained in one slot, and is displayed on the measurement screen for digital average power, channel power, and access probe power when the test set is configured to RTAP (see Test Application Protocol ) and RETAP (see Enhanced Test Application Protocol ). Expected power is determined by adding the power of all of the reverse channels in the access terminal's signal (the power in each of the reverse channels is determined by the open loop power control equation). Which reverse channels contain power varies according to the current Release A Physical Layer Subtype and the state of the data connection, as shown in the following figures.

Expected Power Ranging Diagram for Subtype 0 Physical Layer

Expected Power Ranging Diagram for Subtype 2 Physical Layer

The expected power for each of these three states of the data connection is as follows:

Expected Power for Subtype 0 and Subtype 2 Physical Layer

Connection State

Subtype 0 Physical Layer

Subtype 2 Physical Layer

NOTE: In the following equations, the definition or interpretation of '+' (add) depends on what units are being added. This short hand notation is used to simplify the equations' notation.

  • AA (dBm) = XX (dBm) + YY (dB)
    In this notation, straight mathematical addition is used. The YY value is directly added to XX value to get the AA value with no conversions. dB units can be directly added to dBm units resulting in a dBm value.
  • AA (dBm) = XX (dBm) + YY (dBm)
    In this notation, the equations is showing a logical addition, not straight mathematical addition. Conversion of units is required to perform the logical addition. The YY value and XX value are converted to linear units (W), the added mathematically, the resulting value in linear units (W) is then converted back to dBm. dBm units cannot be directly added together.

Idle/Access

Expected Power (dBm) = R-Pilot (dBm) + R-Access Data (dBm)

Traffic Assignment

Expected Power (dBm) = R-Pilot (dBm) + R-DRC (dBm)

Traffic Channel Connected

Expected Power (dBm) = R-Pilot (dBm) + R-DRC (dBm) + R-Data (dBm) + [R-ACK (dBm) - 3.01 dB]

Note: The test set sets its expected power as if the R-ACK Channel is always present.

Depending on the Pre-Transition or Post-Transition gain used for the R-RRI and R-Data channels, the Expected Power is calculated as:

Expected Power [Pre] (dBm) = R-Pilot (dBm) + R-DRC (dBm) + R-Data(dBm) [Pre] + R-RRI (dBm) [Pre]+ [R-ACK (dBm) + R-DSC (dBm)] / 2 + R-Aux Pilot (dBm)

Expected Power [Post] (dBm) = R-Pilot (dBm) + R-DRC (dBm) + R-Data(dBm) [Post] + R-RRI (dBm) [Post] + [R-ACK (dBm) + R-DSC (dBm)] / 2 + R-Aux Pilot (dBm)

Note:

  • Only the Expected Power [Pre] is used to range the test set's measurement and demodulation receivers.
  • Expected Power [Post] is calculated only when the test set is configured to RETAP with ACK Channel Bit Fixed Mode Attribute set to On. In all other cases, this value is not available.
  • Both the Expected Power [Pre] and Expected Power [Post] are displayed on some measurements screen (such as channel power and digital average power).
  • The Expected Power values are calculated as if the R-ACK Channel is always present.
  • R-Aux Pilot is added only when the R-Aux Pilot channel is transmitted (see Auxiliary Pilot Channel Min Payload for when the R-Aux Pilot channel is transmitted).

The power of each of the reverse channels is calculated as follows:

  • R-Pilot

    R-Pilot (dBm) = - [ Total RF Power (dBm) + AT Noise Floor (dBm)] + [- Open Loop Adjust (dB)] + Probe Initial Adjust (dB)

    • Subtype 0: Probe Initial Adjust (dB) = Probe Initial Adjust
    • Subtype 2: Probe Initial Adjust (dB) = Probe Initial Adjust + Pilot Strength Correction, where
      Pilot Strength Correction = min (Pilot Strength Correction Max, max (Pilot Strength Nominal - Pilot Strength, Pilot Strength Correction Min))
      Because the Pilot Strength Correction Max, Pilot Strength Nominal, Pilot Strength and Pilot Strength Correction Min are fixed to 0 dB in the test set (see Fixed Settings ), so Pilot Strength Correction = 0 dB. So, Probe Initial Adjust (dB) = Probe Initial Adjust

  • R-Access Data

    • Subtype 0 and Subtype 2 Preamble: R-Access Data (dBm) = R-Pilot (dBm) + Data Offset 9k6 + 3.75
      (because the R-Access Data is fixed at 9.6 kbps)
    • Subtype 2 Non-Preamble: R-Access Data (dBm) = R-Pilot (dBm) + Data Offset 9k6|19k2|38k4 + Gain Correction
      (R-Access data rate depends on the Enhanced Access Rate . See Data Offset Rate and Gain Correction Values for each Data Rate )

  • R-DRC

    • Subtype 0: R-DRC (dBm) = R-Pilot (dBm) + DRC Channel Gain (dB)
    • Subtype 2: R-DRC (dBm) = R-Pilot (dBm) + DRC Channel Gain (dB) + DRC Channel Gain Boost (dB)
      (DRC Channel Gain Boost is fixed to 0 dB in the test set, see Fixed Settings )

  • R-ACK

    R-ACK (dBm) = R-Pilot (dBm) + ACK Channel Gain (dB)

  • R-DSC

    • Subtype 0: R-DRC (dBm) = R-Pilot (dBm) + DSC Channel Gain (dB)
    • Subtype 2: R-DRC (dBm) = R-Pilot (dBm) + DSC Channel Gain (dB) + DSC Channel Gain Boost (dB)
      (DSC Channel Gain Boost is fixed to 0 dB in the test set, see Fixed Settings )

  • R-Data

    • Subtype 0: R-Data (dBm) = R-Pilot (dBm) + Data Offset Nom (dB) + Data Offset 9k6|19k2|38k4|76k8|153k6 (dB) + Gain Correction
      (see Data Offset Rate and Gain Correction Values for each Data Rate )
    • Subtype 2: R-Data (dBm) [Pre] = R-Pilot (dBm) + Current TxT2P Pre Gain (dB)
      R-Data (dBm) [Post] = R-Data (dBm) [Pre] (if Current T2P Transition = 3 and RETAP is configured), otherwise, R-Data (dBm) [Post] = R-Pilot (dBm) + Current TxT2P Post Gain (dB)
      (see Power Parameters Info for current TxT2P Pre-Transition and Post-Transition gain values)

  • R-RRI

    • Subtype 0: R-RRI (dBm) = R-Pilot (dBm)
    • Subtype 2: R-RRI (dBm) [Pre] = R-Pilot (dBm) + Current RRI Channel Gain Pre-Transition (dB)
      R-RRI (dBm) [Post] = R-RRI (dBm) [Pre] (if Current T2P Transition = 3 and RETAP is configured), otherwise, R-RRI (dBm) [Post] = R-Pilot (dBm) + Current RRI Channel Gain Post-Transition (dB)
      (see RRI Gain Parameters for current RRI Channel Gain Pre-Transition and Post-Transition values)

  • R-Aux Pilot

    Subtype 2 only: R-Aux Pilot (dBm) = R-Data (dBm) (for subtype 2) + Auxiliary Pilot Channel Gain (dB)

Data Offset Rate and Gain Correction Values for each Data Rate
Data Rate (kbps) | Data Offset 9k6|19k2|38k4|76k8|153k6 (dB) | Gain Correction (dB)
9.6 | Data Offset 9k6 | 3.75
19.2 | Data Offset 19k2 | 6.75
38.4 | Data Offset 38k4 | 9.75
76.8 | Data Offset 76k8 | 13.25
153.6 | Data Offset 153k6 | 18.50

The valid range for expected power is -69 dBm (see Input Signal Requirements ) to AT Max Power

In IS-856 Test Operating Mode

The test set currently does not support protocol release A (1xEV-DO-A) in IS-856 test operating mode. The following section applies to the protocol release 0 (1xEV-DO) which only supports subtype 0 physical layer.

In IS-856 test operating mode, when the Receiver Control is auto, expected power is used to set the measurement and demodulation receiver powers. Expected power is calculated by the test set, and is displayed on the measurement screen such as digital average power, channel power and access probe power.

The expected power for access channel and reverse traffic channel is as follows:

Access Channel: Expected Power (dBm) = R-Pilot (dBm) + R-Access Data (dBm)

Reverse Traffic Channel: Expected Power (dBm) = R-Pilot (dBm) + R-Data (dBm)

  • R-Pilot (dBm) = - [ Total RF Power (dBm) + AT Noise Floor (dBm)] - Open Loop Adjust (dB) + Probe Initial Adjust (dB)
    See Fixed Settings for more information on AT Noise Floor.
  • R-Access Data (dBm) = R-Pilot (dBm) + Data Offset 9k6 + 3.75
    (because the R-Access Data is fixed at 9.6 kbps)
  • R-Data (dBm) = R-Pilot (dBm) + Data Offset Nom (dB) + Data Offset 9k6|19k2|38k4|76k8|153k6 (dB) + Gain Correction)
    (To set the Exp R-Data Rate , see Expected Reverse Data Rate in IS-856 Test Operating Mode .)
Data Offset Rate and Gain Correction Values for each Data Rate
Exp R-Data Rate (kbps) | Data Offset 9k6|19k2|38k4|76k8|153k6 (dB) | Gain Correction (dB)
9.6 | Data Offset 9k6 | 3.75
19.2 | Data Offset 19k2 | 6.75
38.4 | Data Offset 38k4 | 9.75
76.8 | Data Offset 76k8 | 13.25
153.6 | Data Offset 153k6 | 18.50

In CW Operating Mode

In CW operating mode, you must specify the CW expected power that the test set should range its receiver to (see Receiver Control ).

Range of Expected power

The valid range for expected power is -69 dBm (see Input Signal Requirements ) to AT Max Power

Related Topics

GPIB Commands:

  • Active Cell/IS-856 Test mode - RFANalyzer:AUTO:POWer<[:SELected]|:DIGital856>? , CALL:STATus:MS:AUTO:POWer:POST? (only for subtype 2 physical layer)
  • CW mode - RFANalyzer:CW:EXPected:POWer


External Trigger Type

External Trigger Type

External trigger type selects the trigger that is routed to the rear panel TRIG OUT port (see Rear Panel Connectors ). The triggers are based off of the internal clocks/references of the test set and are the same signals that are used to trigger the measurements and data connection processing functionality.

External Trigger Type
Trigger | Description
1.67 ms (1 slot) | Slot clock
26.67 ms (1 frame) | Frame clock (short sequence rollover)
426.67 ms (16 frames) | Control Channel Cycle
2 s | Even second clock

External trigger type can be changed at any time.

In addition to the user selected external trigger type, there is also a fixed external trigger that is always present at the BASEBAND I/O port, which triggers each time a power control bit is generated.

Related Topics

GPIB Command: CALL:TRIGger

Manual Operation: How Do I Change Generator Information?


Fixed Settings

Fixed Settings

Last updated: June 23, 2006

In some tests, C.S0033 specifies particular values for parameters that are fixed in the test set. The following table describes the key fixed parameters and what values they are fixed to in the test set.

Fixed Settings

Setting

Description

Fixed Value
Access Offset

Indicates the amount of time offset for start of the access probe. It is sent in the AccessParameters Message when the Enhanced Access Channel MAC Protocol is in use.

 0 slot ('00')

ACK Channel Bit

If the ACK Channel Bit value is '0', the access terminal shall receive packets on the Forward Traffic Channel as if all the packets were successfully received in one slot duration. Even if a packet has not been successfully decoded in a single slot and its full-length in slots is greater than one, the access terminal shall stop receiving the packet after one slot. It shall accordingly continue generating and transmitting Loop Back Packets, if the Loop Back mode is enabled.

If the ACK Channel Bit value is '1', the access terminal shall receive packets on the Forward Traffic Channel as if all the packets were of full-length duration. The access terminal shall continue receiving the packet until the full-length in slots has elapsed even if the packet was successfully decoded earlier. It shall accordingly continue generating and transmitting Loop Back Packets if the Loop Back mode is enabled.

 '1' (Nak)
This value is sent to the AT when ACK Channel Bit Fixed Mode Attribute is on.
Active ARQ

Indicates whether the Forward Link ARQ channels (H-ARQ/L-ARQ, and P-ARQ) are actively set in response to the received Reverse Traffic Channel data packets. It effectively enables or disables active early termination of the reverse data packets.

When it is Disabled, the ACK R-Data After determines what bits are sent on the ARQ channels in response to the received Reverse Traffic Channel data packets.

 Disabled
Activity Bit

Indicates to the AT if the AN is busy.

 0 (not busy)

AT Noise Floor

-103 dBm
Burst Period

Indicates the duration of the PL_2 RETAP Test Packet generation period (in units of 600 slots). It is sent in the RETAPParameterAssignment Message of the Enhanced Test Application Protocol.

A setting of '0xFFFF' for Burst Period corresponds to infinite burst resulting in continuous reverse traffic packets.

0xFFFF
(see Burst Period Mode )
Burst Size

Indicates the burst size generated at the beginning of the PL_2 RETAP Test Packet generation period (in units of 1000 octets). It is sent in the RETAPParameterAssignment Message of the Enhanced Test Application Protocol.

A setting of '0xFFFF' for Burst Size corresponds to full buffer resulting in continuous reverse traffic packets.

0xFFFF
(see Burst Size Mode )

Connection Request Timeout

 See Connection Request State .

3.5 s

DRC Channel Gain Boost

Indicates the amount of dB boost (extra gain) for the DRC Channel when the DRC Value is changed. It is a configurable attribute of the Enhanced Forward Traffic Channel MAC Protocol.

0 dB

DRC Cover

 See Test Application Protocol and Enhanced Test Application Protocol .

001 (3 bits)

DRC Cover Fixed Mode

 See Test Application Protocol and Enhanced Test Application Protocol .

Off

DRC Length

8 slots

DRC Lock Period

`1' (16 slots)

DRC Lock Power Level

Indicates the power level of the DRC Lock code channel on the Forward Link MAC channel. The fixed level is different for different Physical Layer Subtypes.

-3.01 dB (for subtype 0 physical layer)

-12 dB (for subtype 2 physical layer)

DRC Value Fixed Mode

 (See Limited TAP ).

On

DSC Channel Gain Boost

Indicates the amount of dB boost (extra gain) for the DSC Channel when the DSC Value is changed. It is a configurable attribute of the Enhanced Forward Traffic Channel MAC Protocol.

0 dB

Forced Single Encapsulation

Indicates whether or not the Session Layer packet can be encapsulated with other Session Layer packets in the same Connection Layer packet.

For the test application protocols (TAP or ETAP), forced single encapsulation is required to ensure there is a one to one mapping between application packets and physical layer packets.

For the Default Packet Application (DPA), this setting is fixed to off so that packets can be consolidated to increase the throughput.

On (for TAP)
Off (for DPA, Lab Application only )

See Session Application Type .
Forward Link Early Termination

Indicates whether the forward link data packets are early terminated in response to the received Reverse ACK Channel (R-ACK). It effectively enables or disables active early termination of the forward link data packets.

When it is Disabled, Max Forward Packet Duration and the received DRC determine how many slots are transmitted for the current forward link data packet regardless of what is sent on the R-ACK channel.

 Disabled

Frame Offset

0 slots

Latitude

686512

Longitude

-1686032

Neighbor Count

16

Neighbor Pilot PN

256, 260, 264, 268, 272, 276, 280, 284, 288, 292, 296, 300, 304, 308, 312, 316, (320)

Packet Activity

100%

Pilot Strength Correction Max

It is used for the calculation of ProbeInitialAdjust for estimating the open loop power. See Expected Power . It is sent in the AccessParameters Message of the Enhanced Access Channel MAC Protocol.

0 dB ('000')

Pilot Strength Correction Min

It is used for the calculation of ProbeInitialAdjust for estimating the open loop power. See Expected Power . It is sent in the AccessParameters Message of the Enhanced Access Channel MAC Protocol.

0 dB ('000')

Pilot Strength Nominal

It is used for the calculation of ProbeInitialAdjust for estimating the open loop power. See Expected Power . It is sent in the AccessParameters Message of the Enhanced Access Channel MAC Protocol.

0 dB ('000')

Preamble Length Slots

Indicates the length of the access probe preamble in slots. It is sent as a bit value ('0' indicates 4 slots and '1' indicates 16slots) in the AccessParameters message when the Enhanced Access Channel MAC Protocol is in use. See Current Physical Layer Subtype and Associated Protocols for when the Enhanced Access Channel MAC Protocol is in use).

1 (16 slots)

RA Bits Power Level

Indicates the power level of the Reverse Activity (RA) code channel on the Forward Link MAC channel. The fixed level is different for different Physical Layer Subtypes.

-3.01 dB (for subtype 0 physical layer)

-12 dB (for subtype 2 physical layer)

Rate1M8Supported

Determines the Rate1M8Supported attribute of the Subtype 3 Reverse Traffic Channel MAC Protocol when the Rate 1M8 Supported Control is set to use the AN Specified negotiation control mode.

Yes

RPC Power Level

Indicates the power level of the Reverse Power Control (RPC) code channel on the Forward Link MAC channel.

-3.01 dB (for subtype 0 physical layer)

RPC Channel Level (settable for subtype 2 physical layer)

Sector Access Max Rate

Indicates the maximum access rate allowed by the sector. It is sent in the AccessParameters Message when Enhanced Access Channel MAC Protocol is in use.

The actual maximum access rate used by the AT, AccessRateMax, is the maximum of Sector Access Max Rate and Terminal Access Rate Max . The AccessRateMax can be overridden by Enhanced Access Rate .

38.4 kbps

Session Configuration Response Timeout

 (See Session Negotiate State ).

5 s

Session Close Message Timeout

Indicates how long the AN waits for a SessionClose message from the AT in response to the AN sending a SessionClose message before the AN finishes closing the session.

1 s

Terminal Access Rate Max

Indicates the maximum access rate to be used by the AT during that session. It is a configurable attribute of the Enhanced Access Channel MAC Protocol.

The actual maximum access rate used by the AT, AccessRateMax, is the maximum of Sector Access Max Rate and Terminal Access Rate Max. The AccessRateMax can be overridden by Enhanced Access Rate .

9.6 kbps

Transition Probability

Transition009k6_019k2,Transition019k2_038k4,
Transition038k4_076k8,Transition076k8_153k6,
Transition019k2_009k6,Transition038k4_019k2,
Transition076k8_038k4,Transition153k6_076k8

 0xFF (100%)


Front Panel Connectors

Front Panel Connectors

Description

AUDIO IN

The input to the audio analyzer is a floating input differential amplifier. Both the AUDIO IN High and AUDIO IN Low BNC connectors should be connected to provide noise immunity. Refer to the Technical Specifications in the Application Datasheet for more information.

AUDIO OUT

This BNC connector accesses the test set's Audio Generator and FM Demod signals. The Audio Generator is used to stimulate a system to measure audio performance characteristics. The FM Demod allows the user to access the demodulated FM signal for external analysis and baseband processing. Refer to the Technical Specifications in the Application Datasheet for more information.

NOTE
There will be no guaranteed performance for the signal present at the AUDIO OUT connector when FM Demod signal is selected for output.

DATA

This RJ-45 connector provides front panel access to the rear panel LAN connection. This connector is used for downloading firmware upgrades, or new test applications into the test set. No other types of communication are possible with the LAN port.

The the DATA connector on the front panel is connected internally to the ETHERNET TO FRONT PANEL connector on the rear panel. In order to use the front panel DATA connector, connect the rear panel LAN PORT, to the rear panel ETHERNET TO FRONT PANEL connector with the LAN jumper cable.

The LAN jumper cable, part number E5515-61160, is supplied with the test set.

DVM

Not functional for this release.

RF IN/OUT

This Type-N connector is the default path for all RF signals out of the test set, and is always used as the RF input. Refer to the Technical Specifications in the Application Datasheet for more information. See also RF OUT ONLY .

RF OUT ONLY

NOTE
This port cannot be used with the E1960A GSM test application or with the GSM personality in a test application suite (such as the E1985A GSM_AMPS/136_GPRS suite).

This Type-N connector is an optional path for all RF signals out of the test set. It is intended to be used for duplexed testing. Front panel selection of this port is provided by the RF Output Port ( F6 ) control on the System Config screen, and by the RFGenerator:OUTPut[:DESTination] IO/OUT command. The same amplitude offsets and output power settings are used for either selected port (RF IN/OUT or RF OUT ONLY). Refer to the Technical Specifications in the Application Datasheet for more information.

Related Topics

How Do I Configure the AUDIO OUT Port?


Help Mode

Help Mode

Description

This section explains:

  • What is Help Mode?
  • How do I use the help mode?

What is Help Mode?

The help mode implemented in your test set provides context sensitive GPIB command syntax assistance. When you put the test set into help mode, the test set displays the GPIB command syntax necessary to perform an action remotely for each action you perform from the front panel.

For example, if you put the test set into help mode and then select the test set's GPIB address, the GPIB command syntax for changing it remotely appears in the bottom left hand corner of the test set's screen.

NOTE
Operating the test set in Help Mode does not prevent you from changing parameters from the front panel. The parameters you change while in Help Mode are applied just as they would be normally.

How do I use the help mode?

  1. Put the test set into help mode by pressing the HELP key on the front panel.

    The Help annunciator should now be displayed in the bottom of the screen.

  2. Navigate to the screen and perform the action for which you would like to know the GPIB command syntax. For example, you could navigate to the Audio Generator instrument, and select Frequency ( F3 ). The GPIB command syntax to perform this action remotely appears in the bottom left of the screen.

    Refer to the user documentation on each command for more information.


FTAP Rate

FTAP Rate

Last updated: June 16, 2006

FTAP Rate determines the data rate (and number of slots) for transmitting the forward test packets when the test set is configured to TAP (0x0003) (see Test Application Configuration ) in Active Cell operating mode and the DRC Value Fixed Mode Attribute is set to On. In this case, the test set tells the access terminal to always request the DRC value that corresponds to the current FTAP Rate setting. The test set then uses the DRC value requested by the access terminal to set its forward rate.

FTAP Rate can be changed at any time. The following table shows the configuration of the forward traffic packet at each data rate for subtype 0 physical layer. Note that the actual number of slots transmitted by the test set for each data rate may be less depending upon the Max Forward Packet Duration .

FTAP Data Rates
FTAP Data Rate (kbps) | Slots per Physical Packet | Modulation Format | DRC Value
38.4 | 16 | QPSK | 0x1
76.8 | 8 | QPSK | 0x2
153.6 | 4 | QPSK | 0x3
307.2 | 2 | QPSK | 0x4
307.2 | 4 | QPSK | 0x5
614.4 | 1 | QPSK | 0x6
614.4 | 2 | QPSK | 0x7
921.6 | 2 | 8-PSK | 0x8
1228.8 | 1 | QPSK | 0x9
1228.8 | 2 | 16-QAM | 0xA
1843.2 | 1 | 8-PSK | 0xB
2457.6 | 1 | 16-QAM | 0xC

The test set uses the DRC value requested by the access terminal to set its forward rate. The DRC value requested by the access terminal is controlled either by the test set or determined by the access terminal according to the current link conditions. For details, see DRC Value Fixed Mode Attribute .

Related Topics

GPIB Command: CALL[:CELL]:APPLication:FTAProtocol:DRATe

Manual Operation: How Do I Change Call Parameters?

Test Application Protocol

Release A Physical Layer Subtype

RTAP Rate

Forward Traffic Rate in IS-856 Test Operating Mode


Forward Channel Overview

Forward Channel Overview

The forward channel consists of the Pilot Channel , MAC Channel , Control/Traffic Preamble , and Control/Traffic Channel . They are Time Division Multiplexed (TDM).

Along with the C.S0024 standard evolving from the release 0 to release A, the new Subtype 2 Physical Layer is introduced to support higher data rate transmission. This results in some modifications on both the forward channel and reverse channel structure. For details on the reverse channels, see Reverse Channel Overview . This section will discuss the key differences of forward channel structure between subtype 2 physical layer and subtype 0 physical layer.

Forward Channel Structure for Subtype 0 Physical Layer

Forward Channel Structure for Subtype 2 Physical Layer

  • Pilot Channel

    The Subtype 2 forward pilot channel is the same as that used in Subtypes 0. It is an unmodulated, direct-sequence spread spectrum signal transmitted every half slot in bursts of 96 chips centered at the middle of the half slot. The Pilot Channel allows an access terminal to acquire the timing of the forward channel, provides a phase reference for coherent demodulation, and provides means for signal strength comparisons between sectors for determining when to handoff. The forward pilot channel is transmitted on the I channel at the full power of the cell/sector.

  • MAC Channel

    The Subtype 2 MAC channel contains several sub-channels: the Reverse Power Control (RPC) and Reverse Activity (RA) channels (similar to Subtype 0) and three new channels (H-ARQ, L-ARQ, and P-ARQ channels). The ARQ channels are time-division multiplexed with the DRC Lock and RPC channels in a 3 to 1 ratio where the ARQ channels are transmitted for 3 slots and the DRC Lock and R-PC channels are transmitted for 1 slot. All MAC sub-channels are spread with 128 bit Walsh codes (Subtype 0 uses 64 bit Walsh codes) and transmitted on either the I or Q channels depending on the MAC Index assigned to the access terminal. (See also MAC Code Channels Overview )

    • The RA channel transmits data indicating the activity level in the reverse link. If the AN detects that the overall reverse traffic channel activity is too high to support the currently used data rate, it sets the RA bit to a value of '1'. Along with other parameters, this value is used to reduce the reverse traffic channel data rate.

    • The combination of the R-PC, DRC Lock and ARQ channels are sent in parallel to all ATs with an open connection.

      • RPC channel is used to signal the access terminal to increase or decrease its transmit power.
      • ARQ channels are used to indicate to the access terminal whether the access network can decode the reverse data packet sent by the access terminal. In Subtype 2 operation, the access terminal can transmit up to four subpackets for each transmitted physical layer packet (see Background Information (Subpacket) ). Hybrid ARQ bit (H-ARQ) is sent in response to the 1st, 2nd, and 3rd subpacket of a reverse-link physical packet. Last ARQ bit (L-ARQ) is sent in response to the 4th (last) subpacket of a reverse-link physical packet. Packet ARQ bit (P-ARQ) is sent after a physical layer packet has been successfully received (H-ARQ or L-ARQ sends ACK) or has failed to be received (L-ARQ sends NAK) after all four subpackets have been sent.
      • DRC Lock channel is used to indicate to the access terminal whether the access network can decode the DRC sent by the access terminal. If the AN sets the DRC Lock channel assigned of an AT to a value of '0', then the AT must direct its DRC to another sector. The ARQ channels are used to acknowledge each received subpackets on the R-TCH channel.

  • Control/Traffic Preamble

    The preamble transmitted at the beginning of each packet either identifies the packet as a control channel packet (MAC index 2 or 3), or identifies the target access terminal for receiving the forward traffic channel or AT-directed control channel packet (the access network uses the MAC index to identify the target access terminal. The MAC index is assigned by the AN and sent to the AT as part of the procedure for establishing a traffic connection.). See MAC Index for details.

  • Control/Traffic Channel

    The traffic data and control data are time multiplexed together on the forward link. This multiplexed control channel carries the broadcast messages for the system. These messages include the Sync Message, Quick Configuration Message, the Sector Parameters Message, the Access Parameters Message, and the Broadcast Reverse Rate Limit Message. In addition, signaling messages addressed to individual access terminals are also carried on the multiplexed control channel.

Related Topics

Reverse Channel Overview


Code Channel Parameters

Code Channel Parameters

Last updated: June 29, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

  • H-ARQ Modulation
  • H-ARQ/L-ARQ Channel Level
  • P-ARQ Channel Level
  • RPC Channel Level
  • Operating Considerations
  • Background Information: MAC Code Channels Overview
    • Generated MAC Code Channels When Current Physical Layer is Subtype 0
    • Generated MAC Code Channels When Current Physical Layer is Subtype 2

H-ARQ Modulation

H-ARQ Modulation setting (corresponds to ARQMode in C.S0024-A) determines the modulation type used to transmit the H-ARQ channel when the current physical layer subtype is Subtype 2 (see Release A Physical Layer Subtype ). The test set transmits H-ARQ bits after receiving the first, second, or third subpacket of a reverse physical layer packet. The ACK R-Data After is used to control what H-ARQ bit (ACK or NAK) is transmitted.

H-ARQ Modulation
H-ARQ Modulation | ARQMode Value (C.S0024-A) | Description
Bi-Polar Keying | 1 | The H-ARQ bit is sent using Bi-Polar keying where a +1 implies an ACK and -1 implies a NAK.
On-Off Keying | 0 | The H-ARQ bit is sent using ACK-oriented On-Off keying where a 1 implies an ACK and 0 implies a NAK.

H-ARQ Modulation setting ( ARQMode ) is a "Configurable Attribute" for the Subtype 3 Reverse Traffic Channel MAC Protocol. It is negotiated with the AT during session negotiation. When a session is open, changing the H-ARQ Modulation results in a session re-negotiation. See Session Negotiate State for details.

The L-ARQ bit and the P-ARQ bit are modulated using NAK-oriented ON-OFF Keying (0 implies ACK, -1 implies NAK).

H-ARQ/L-ARQ Channel Level

H-ARQ/L-ARQ Channel Level is used to set the power level of H-ARQ/L-ARQ Channel relative to the current Cell Power when the current physical layer subtype is Subtype 2 (see Release A Physical Layer Subtype ). It ranges from -30 dB to -6 dB. Changing this code level may be rejected due to an error generated (see Operating Considerations for details).

For details on the H-ARQ/L-ARQ code channel, see Generated MAC Code Channels When Current Physical Layer is Subtype 2 .

P-ARQ Channel Level

P-ARQ Channel Level is used to set the power level of P-ARQ Channel relative to the current Cell Power when the current physical layer subtype is Subtype 2 (see Release A Physical Layer Subtype ). It ranges from -30 dB to -6 dB. Changing this code level may be rejected due to an error generated (see Operating Considerations for details).

For details on the P-ARQ code channel, see Generated MAC Code Channels When Current Physical Layer is Subtype 2 .

RPC Channel Level

RPC Channel Level is used to set the power level of RPC Channel relative to the current Cell Power when the current physical layer subtype is Subtype 2 (see Release A Physical Layer Subtype ). It ranges from -30 dB to -6 dB. Changing this code level may be rejected due to an error generated (see Operating Considerations for details).

When the current physical layer subtype is Subtype 0, the RPC channel level is fixed by the test set. See Generated MAC Code Channels When Current Physical Layer is Subtype 0 and Generated MAC Code Channels When Current Physical Layer is Subtype 2 for details.

Operating Considerations

When the current physical layer subtype is Subtype 2 (see Release A Physical Layer Subtype ) and both Cell power and AWGN power are On, the power level of any MAC code channel generated must not be greater than 30dB below the current Total RF Power :

  • When any MAC code channel level is changed such that the code level is more than 30 dB below the current Total RF Power, an error message is posted to indicate the error condition. When this happens, the code channel level is rejected (remain at previous setting).
  • When any cell or AWGN power level is changed such that any code channel is more than 30dB below the current Total RF Power, an error message is posted to indicate the error condition. When this happens, the cell or AWGN setting is pended (saved but not applied to the hardware) and the current power setting is not updated (remain at previous setting) until the error condition is removed. See Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power .

MAC Code Channels Overview

The code channels generated in the forward MAC channel, their relative levels, and their modulation type depend on the current physical layer subtype (see Release A Physical Layer Subtype ).

  • Generated MAC Code Channels When Current Physical Layer is Subtype 0
  • Generated MAC Code Channels When Current Physical Layer is Subtype 2
Generated MAC Code Channels When Current Physical Layer is Subtype 0

MAC Channels

Description

RPC and DRC Lock (TDM)

The RPC and DRC Lock channels are time-division multiplexed (TDM) and BPSK modulated using the same 64-ary walsh code transmitted on either I or Q channel.

  • When an AT is assigned an even numbered MAC index, the RPC and DRC Lock channels are transmitted on the I channel. When an AT is assigned an odd numbered MAC index, the RPC and DRC Lock channels are transmitted on the Q channel.
  • The RPC Channel is transmitted in ( DRC Lock Period -1) slots out of every DRC Lock Period slots. The DRC Lock Channel is transmitted in one out of every DRC Lock Period slots.
  • The power levels for the RPC and DRC Lock code channels are fixed by the test set and equally divided between walsh channels (see RPC Power Level and DRC Lock Power Level ).

RA

The RA channel is transmitted using MAC Index 4 with 64-ary walsh code BPSK modulated on I channel. The power level for the RA code channels are fixed by the test set ( RA Bits Power Level ).
Generated MAC Code Channels When Current Physical Layer is Subtype 2

MAC Channels

Description

H-ARQ/L-ARQ and RPC (TDM)

The H-ARQ/L-ARQ and RPC channels are time-division multiplexed (TDM) and transmitted using the same 128-ary walsh code on either I or Q channel.

  • When an AT is assigned an even numbered MAC Index , the H-ARQ/L-ARQ and RPC channels are transmitted on the I channel. When an AT is assigned an odd numbered MAC index, the H-ARQ/L-ARQ and RPC channels are transmitted on the Q channel.
  • The H-ARQ/L-ARQ channel and RPC channel are time division multiplexed (TDM) in a 3 to 1 ratio where the H-ARQ/L-ARQ channel is transmitted for 3 slots and then the RPC channel is transmitted for 1 slot out of every 4 slots.
  • The H-ARQ bit is modulated based on the ARQMode (see H-ARQ Modulation ). The L-ARQ bit is modulated using NAK-oriented ON-OFF Keying (0 implies ACK, -1 implies NAK). The RPC channel uses the BPSK modulation.
  • The power level of the RPC channel is controlled by RPC Channel Level . The power level of the H-ARQ/L-ARQ channel is controlled by H-ARQ/L-ARQ Channel Level .

P-ARQ and DRC Lock (TDM)

The P-ARQ and DRC Lock channels are time-division multiplexed (TDM) and transmitted using the same 128-ary walsh code on either I or Q channel:

  • When an AT is assigned an even numbered MAC Index , the P-ARQ and DRC Lock channels are transmitted on the Q channel. When an AT is assigned an odd numbered MAC index, the P-ARQ and DRC Lock channels are transmitted on the I channel.
  • The P-ARQ and DRC Lock channels are time division multiplexed (TDM) in a 3 to 1 ratio where the P-ARQ channel is transmitted for 3 slots and then the DRC Lock channel is transmitted for 1 slot out of every 4 slots.
  • The P-ARQ bit is modulated using NAK-oriented ON-OFF Keying (0 implies ACK, -1 implies NAK). The DRC Lock channel uses the BPSK modulation
  • The power level of the RPC channel is controlled by P-ARQ Channel Level . The power level for the DRC Lock channel is fixed by the test set (see DRC Lock Power Level ).

RA

The RA channel for physical layer subtype 2 is similar to that of physical layer subtype 0 except for 128-ary walsh code used.

Related Topics

GPIB Command: CALL:MACCHannel

Manual Operation: How Do I Change Generator Information? (Code Channel Parameters menu)


F-Traffic Config

F-Traffic Config

This section is only applicable to the lab application and to a test application with the required feature license.

F-Traffic Config determines the forward transmission format (packets, slots, preamble) that the test set will be used to transmit the forward data packets (non-signaling message) when the following conditions are met:

  • the test set is in Active Cell operating mode with the DRC Value Fixed Mode Attribute set to off and the ETAP (0x000A) configured for subtype 2 physical layer (see Test Application Configuration ).

When the DRC Value Fixed Mode Attribute is off, the AT requests the DRC value based on the current link conditions as in real system operation. For subtype 2 physical layer, there are multiple transmission formats per each requested DRC value (see the table below). F-Traffic Config setting determines which transmission format is used for each requested DRC value:

  • Canonical - canonical transmission format for the DRC value received
  • Short Packet 1 - largest short packet size (non-canonical) format for the DRC value received
  • Short Packet 2 - 2nd largest short packet size (non-canonical) format for the DRC value received
  • Short Packet 3 - 3rd largest short packet size (non-canonical) format for the DRC value received

If there are no short packet formats or less than three short packet formats for the DRC value, the settings collapse as shown in the table below. The highlighted row for each DRC Value is called the canonical transmission format. The canonical transmission format is defined as the transmission format with the largest packet size for the DRC Value. Additional transmission formats for the DRC Value are called short packet (or non-canonical ) transmission formats.

Forward Traffic Packet Configurations
DRC Value | Single-User Transmission Format (physical layer packet size in bits, number of slots, preamble length in chips) | F-Traffic Config
 |  | Canonical | Short Packet 1 | Short Packet 2 | Short Packet 3
0x1 | (128, 16, 1024) |  |  |  | X
 | (256, 16, 1024) |  |  | X |
 | (512, 16, 1024) |  | X |  |
 | (1024, 16, 1024) | X |  |  |
0x2 | (128, 8, 512) |  |  |  | X
 | (256, 8, 512) |  |  | X |
 | (512, 8, 512) |  | X |  |
 | (1024, 8, 512) | X |  |  |
0x3 | (128, 4, 256) |  |  |  | X
 | (256, 4, 256) |  |  | X |
 | (512, 4, 256) |  | X |  |
 | (1024, 4, 256) | X |  |  |
0x4 | (128, 2, 128) |  |  |  | X
 | (256, 2, 128) |  |  | X |
 | (512, 2, 128) |  | X |  |
 | (1024, 2, 128) | X |  |  |
0x5 | (512, 4, 128) |  |  | X | X
 | (1024, 4, 128) |  | X |  |
 | (2048, 4, 128) | X |  |  |
0x6 | (128, 1, 64) |  |  |  | X
 | (256, 1, 64) |  |  | X |
 | (512, 1, 64) |  | X |  |
 | (1024, 1, 64) | X |  |  |
0x7 | (512, 2, 64) |  |  | X | X
 | (1024, 2, 64) |  | X |  |
 | (2048, 2, 64) | X |  |  |
0x8 | (1024, 2, 64) |  | X | X | X
 | (3072, 2, 64) | X |  |  |
0x9 | (512, 1, 64) |  |  | X | X
 | (1024, 1, 64) |  | X |  |
 | (2048, 1, 64) | X |  |  |
0xA | (4096, 2, 64) | X | X | X | X
0xB | (1024, 1, 64) |  | X | X | X
 | (3072, 1, 64) | X |  |  |
0xC | (4096, 1, 64) | X | X | X | X
0xD | (5120, 2, 64) | X | X | X | X
0xE | (5120, 1, 64) | X | X | X | X

When the DRC Value Fixed Mode Attribute is set to on, the forward transmission format for subtype 2 physical layer is determined by F-Traffic Format .

Operating Considerations

  • You should set the F-Traffic Config to Canonical if your AT does not support short packet transmission formats.
  • In some cases, changing the F-Traffic Config may result in an error message posted (see Short Packet Enabled Threshold for details).
  • Signaling messages are always sent in the canonical format. This is to avoid the Signaling Link Protocol (SLP) from having to make very small fragments for the signaling messages that would be required with some non-canonical formats and forced single encapsulation (required for Test Applications).

Related Topics

GPIB Command: CALL[:CELL]:APPLication:TRAFfic:PACKet:CONFigure

Manual Operation: How Do I Change Call Parameters?


F-Traffic Format

F-Traffic Format

Last updated: June 16, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

F-Traffic Format determines the specific DRC value and the transmission format (packets, slots, preamble) used to transmit the forward traffic test packets when the following conditions are met:

  • the test set is in Active Cell operating mode with the DRC Value Fixed Mode Attribute set to on and the ETAP (0x000A) configured for subtype 2 physical layer (see Test Application Configuration ).

In the Active Cell operating mode, the test set uses the DRC value requested by the access terminal to set its forward transmission format.

  • When the DRC Value Fixed Mode Attribute is set to on, the test set sends the DRC Value Fixed Mode attribute in the FETAP Parameter Assignment message (see Enhanced Test Application Protocol ) and sets the DRC Value for this attribute according to the F-Traffic Format setting. This means that the test set tells the access terminal to always request the DRC value that corresponds to the specified F-Traffic Format setting. The test set uses the specified transmission format associated with that DRC value to transmit the forward traffic packet.
  • When the DRC Value Fixed Mode Attribute is set to off, the AT requests the DRC value based on the current link conditions as in real system operation. Because the subtype 2 physical layer supports multiple transmission formats in response to a DRC value requested by the AT, the F-Traffic Config determines which transmission format is used for each requested DRC value.

The table below shows the configuration of the forward traffic packet for each DRC value.

  • The highlighted row for each DRC Value is called the canonical transmission format. The canonical transmission format is defined as the transmission format with the largest packet size for a given DRC Value. Additional transmission formats for the DRC Value are called short packet (or non-canonical ) transmission formats.
  • The DRC Value is defined by the Rate Metric and the Nominal Duration (slots).
  • The Rate Metric for a DRC Value is defined as the Nominal Data Rate of the canonical transmission format of the DRC Value.

DRC Value and Forward Transmission Formats
F-Traffic Format | DRC Value | Single-User Transmission Format (physical layer packet size in bits, number of slots, preamble length in chips) | Modulation Format | Nominal Duration (slots) | Rate Metric (kbps) | Nominal Data Rate (kbps)
1 (128, 16, 1024) | 0x1 | (128, 16, 1024) | QPSK | 16 | 38.4 | 4.8
1 (256, 16, 1024) |  | (256, 16, 1024) |  |  |  | 9.6
1 (512, 16, 1024) |  | (512, 16, 1024) |  |  |  | 19.2
1 (1024, 16, 1024) |  | (1024, 16, 1024) |  |  |  | 38.4
2 (128, 8, 512) | 0x2 | (128, 8, 512) | QPSK | 8 | 76.8 | 9.6
2 (256, 8, 512) |  | (256, 8, 512) |  |  |  | 19.2
2 (512, 8, 512) |  | (512, 8, 512) |  |  |  | 38.4
2 (1024, 8, 512) |  | (1024, 8, 512) |  |  |  | 76.8
3 (128, 4, 256) | 0x3 | (128, 4, 256) | QPSK | 4 | 153.6 | 19.2
3 (256, 4, 256) |  | (256, 4, 256) |  |  |  | 38.4
3 (512, 4, 256) |  | (512, 4, 256) |  |  |  | 76.8
3 (1024, 4, 256) |  | (1024, 4, 256) |  |  |  | 153.6
4 (128, 2, 128) | 0x4 | (128, 2, 128) | QPSK | 2 | 307.2 | 38.4
4 (256, 2, 128) |  | (256, 2, 128) |  |  |  | 76.8
4 (512, 2, 128) |  | (512, 2, 128) |  |  |  | 153.6
4 (1024, 2, 128) |  | (1024, 2, 128) |  |  |  | 307.2
5 (512, 4, 128) | 0x5 | (512, 4, 128) | QPSK | 4 | 307.2 | 76.8
5 (1024, 4, 128) |  | (1024, 4, 128) |  |  |  | 153.6
5 (2048, 4, 128) |  | (2048, 4, 128) |  |  |  | 307.2
6 (128, 1, 64) | 0x6 | (128, 1, 64) | QPSK | 1 | 614.4 | 76.8
6 (256, 1, 64) |  | (256, 1, 64) |  |  |  | 153.6
6 (512, 1, 64) |  | (512, 1, 64) |  |  |  | 307.2
6 (1024, 1, 64) |  | (1024, 1, 64) |  |  |  | 614.4
7 (512, 2, 64) | 0x7 | (512, 2, 64) | QPSK | 2 | 614.4 | 153.6
7 (1024, 2, 64) |  | (1024, 2, 64) |  |  |  | 307.2
7 (2048, 2, 64) |  | (2048, 2, 64) |  |  |  | 614.4
8 (1024, 2, 64) | 0x8 | (1024, 2, 64) | QPSK | 2 | 921.6 | 307.2
8 (3072, 2, 64) |  | (3072, 2, 64) | 8-PSK |  |  | 921.6
9 (512, 1, 64) | 0x9 | (512, 1, 64) | QPSK | 1 | 1228.8 | 307.2
9 (1024, 1, 64) |  | (1024, 1, 64) |  |  |  | 614.4
9 (2048, 1, 64) |  | (2048, 1, 64) |  |  |  | 1228.8
A (4096, 2, 64) | 0xA | (4096, 2, 64) | 16-QAM | 2 | 1228.8 | 1228.8
B (1024, 1, 64) | 0xB | (1024, 1, 64) | QPSK | 1 | 1843.2 | 614.4
B (3072, 1, 64) |  | (3072, 1, 64) | 8-PSK |  |  | 1843.2
C (4096, 1, 64) | 0xC | (4096, 1, 64) | 16-QAM | 1 | 2457.6 | 2457.6
D (5120, 2, 64) | 0xD | (5120, 2, 64) | 16-QAM | 2 | 1536.0 | 1536.0
E (5120, 1, 64) | 0xE | (5120, 1, 64) | 16-QAM | 1 | 3072.0 | 3072.0

Operating Considerations

  • You should set the F-Traffic Format to the canonical transmission format of a DRC value if your AT does not support short packet transmission formats.
  • In some cases, changing the F-Traffic Format may result in an error message posted (see Short Packet Enabled Threshold for details).
  • The actual number of slots transmitted for each transmission format may be less depending upon the Max Forward Packet Duration .
  • Signaling messages are always sent in the canonical format. This is to avoid the Signaling Link Protocol (SLP) from having to make very small fragments for the signaling messages that would be required with some non-canonical formats and forced single encapsulation (required for Test Applications).

Related Topics

GPIB Command: CALL[:CELL]:APPLication:TRAFfic:FORMat

Manual Operation: How Do I Change Call Parameters?

Enhanced Test Application Protocol

Release A Physical Layer Subtype

F-Traffic Config

FTAP Rate

C.S0029 Test Application Specification Description (TAP/ETAP)


Handoff

Handoff

Handoff State

The handoff state is a transitory state (see TAP/ETAP Data Connection Processing Lifecycle ).

To query the state of the data connection, see Data Connection State Synchronization .

Explicit versus Implicit Handoffs

There are two types of handoffs that the test set can perform, implicit and explicit.

Implicit handoffs are simply a side effect of changing any parameter that is negotiated using a Traffic Channel Assignment message (such as PN Offset, DRC Channel Gain, or Channel). For example, an implicit handoff occurs when you type in a new channel number in the Channel field or select a new Cell Band . You can perform an implicit handoff at any time. If you perform an implicit handoff while in idle state, the settings are immediately applied by the test set and there is no signalling to the access terminal. If you change the channel while in the session open state, the settings are immediately applied, the session is preserved, and a Sector Parameters message is sent to the access terminal. The session timer (see Fixed Settings ) is restarted to give the AT full time to respond to the change. If you perform an implicit handoff while in the connected state, the settings are applied and a Traffic Channel Assignment message is sent to the AT, directing it to the new band or channel (the Channel record in the message contains System Type, Band Class and Channel Number fields).

An explicit handoff can only be performed while in the connected state. Before performing an explicit handoff, you must first specify the handoff cell band and/or handoff channel (the cell band and channel you want to handoff to). Then, when you initiate the explicit handoff using the CALL:HANDoff command or by selecting the Execute Handoff soft key, the AT is directed to the handoff cell band and/or handoff channel by a Traffic Channel Assignment message. This allows you to set up the handoff channel and band in advance, and then direct the AT to a new cell band and channel with a single command during testing, which can save test time (instead of moving the AT first to the new cell band and then moving it again to the desired channel, you move it directly to the new cell band and channel).

In summary, you can perform an implicit handoff while in any state. You can only perform an explicit handoff while in the connected state. Performing an explicit handoff allows you to hand off to a new band and channel using a single command.

Programming Usage

Implicit handoff:

  • Changing the current cell band: CALL:BAND
  • Changing the current channel: CALL:CHANnel

Explicit handoff:

  • Specifying the handoff cell band and channel: CALL:SETup
  • Initiating the handoff: CALL:HANDoff
  • Programming example: Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Manual Operation

Implicit handoff:

  • How Do I Change Call Parameters?

Explicit handoff:

  • How Do I Perform a Handoff?

Related Topics

Connected State

TAP/ETAP Data Connection Processing States Lifecycle

TAP/ETAP Data Connection Call Flow

Data Connection State Synchronization

Cell Band

Channel


Hardware ID

Hardware ID

During the Session Negotiate State , the access network may send a Hardware ID Request message to the access terminal (see TAP/ETAP Data Connection Call Flow ). The access terminal then sends a Hardware ID Response message which includes Hardware ID Type and Hardware ID Value fields.

The Hardware ID Value field specifies the unique ID assigned to the access terminal by the manufacturer, uniquely identifying the access terminal. Hardware ID is displayed by the test set in two formats:

  • Hardware ID (Hex) is in hexadecimal number which corresponds directly to the Hardware ID Value returned by the access terminal.
  • Hardware ID (Decimal) provides the interpretation of the Hardware ID (Hex) based on the Hardware ID Type reported by the access terminal.

The length of the Hardware ID Value and how to interpret the Hardware ID Value are determined by Hardware ID Type. See Hardware ID Type for more information.

Hardware ID can be queried at any time, but a value will only be returned if a session has been negotiated between the test set and access terminal. Hardware ID (Hex) and Hardware ID (Decimal) are displayed on the Call Setup screen in the Access Terminal Information (AT Reported) window.

Related Topics

GPIB Commands:

  • CALL:MS:REPorted:HIDentity:HEX?


Hardware ID Type

Hardware ID Type

During the Session Negotiate State , the access network may send a Hardware ID Request message to the access terminal (see TAP/ETAP Data Connection Call Flow ). The access terminal then sends a Hardware ID Response message which includes Hardware ID Type and Hardware ID Value fields.

The Hardware ID Type determines the length of the Hardware ID Value and how to interpret the Hardware ID Value.

Hardware ID Type

Value

 Meaning Description Examples

0x010000

 Interpret the Hardware ID Value as an Electronic Serial Number (ESN)

Interpret the Hardware ID Value as follows:

  • The first 2 hex characters correspond to a 3 digit decimal number (use leading zeros if required) that indicates the manufacturer.
  • The last 6 hex characters correspond to a 8 digit decimal number (use leading zeros if required) that indicates the serial number.

Hardware ID Value = 0x74013C0A

Decimal Hardware ID = 116-00080906

0x00FFFF

 Interpret the Hardware ID Value as an Mobile Equipment Identifier (MEID)

Interpret the Hardware ID Value as follows:

  • The first 8 hex characters correspond to a 10 digit decimal number (use leading zeros if required) that indicates the manufacturer.
  • The last 6 hex characters correspond to a 8 digit decimal number (use leading zeros if required) that indicates the serial number.

Hardware ID Value = 0x0A0123450ABCDE

Decimal Hardware ID = 0167846725-00703710
0x00NNNN Interpret the Hardware ID Value as a Hardware ID "NNNN" from IETF RFC 1700 standard To convert the Hardware ID Value to a decimal number, simply convert the last 8 hex characters to a decimal number.

Hardware ID Value = 0x74013C0A

Decimal Hardware ID = 1946237962
0xFFFFFF Null

all others Invalid

Hardware ID type can be queried at any time, but a value will only be returned if a session has been negotiated between the test set and access terminal (see Session Negotiate State ). Hardware ID Type is displayed on the Call Setup screen in the Access Terminal Information (AT Reported) window.

Related Topics

GPIB Command: CALL:MS:REPorted:HIDentity:TYPE?


Idle State

Idle State

In the Idle state, there is no communication or connection between the test set and access terminal (AT). In this state, the AT does not have an assigned UATI. See Initialization Procedure .

The Idle state is a non-transitory state (see TAP/ETAP Data Connection Processing Lifecycle and Packet Data Connection Processing States Lifecycle ).

To query the state of the data connection, see Data Connection State Synchronization .

Related Topics

TAP/ETAP Data Connection Processing States Lifecycle

TAP/ETAP Data Connection Call Flow

Packet Data Connection Processing States Lifecycle ( Lab Application Only )

Packet Data Connection Call Flow ( Lab Application Only )


Preset Descriptions

Preset Descriptions

NOTE
It is recommended not to execute a preset/reset (full or partial) when a session is open with an AT. This is because executing a preset/reset (full or partial) will take the test set to Idle state without signaling to the AT and may cause the test set and AT in a mismatched state. In this case, some ATs can not open a new session with the test set.

Description

The test set is capable of accepting several different preset commands.

At no time during a preset operation, does transmit power exceed the last user setting of the transmit power. The input power is not set to any value lower than the last user setting of the input power. This is to avoid power spikes on the output and possible receiver damage on the input during transitions associated with preset operations.

Partial Preset

Partial preset saves setup time because measurement setup parameters remain unchanged. This is the recommended way to place the test set in a known condition.

When you fast switch between formats in a fast switching test application the test set behaves as if a partial preset has occurred. The table below lists some key partial preset results.

Example

OUTPUT 714;"SYSTEM:PRESET3" !Command for a partial preset when user in
                            !remote operation.

SYSTEM:PRESET3 is the recommended command for a partial preset operation. The SYSTEM:PRESET[1] command is not recommended for use at this time.

Press the green Preset key on the front panel to perform a partial preset.

Partial Preset Behavior
Function | Partial Preset Result
Trigger Arm | no change
Measurement parameters | no change
Calibration data | no change
Enable registers | no change
Positive Transition Filter registers | no change
Negative Transition Filter registers | no change
Contents of RAM | no change
Contents of output queue | no change
Contents of error queue | no change
Maskable Message Display State | no change
Operating Mode | Active Cell
Measurements | aborted and inactivated
Measurement results | NAN
Measurement integrity indicator | 1 = no result available
Transmit Power State | ON
Cell Activated State | ON
Call in progress | aborted
Call Control Status | Idle
Call Counters | cleared
Call Error Counters | cleared
SACCH | cleared
Pending Service request | not cleared

Full Preset

A full preset requires you to select new measurements and configure their parameters. If measurement parameters do not need to be changed, use a partial preset to save time.

Example

OUTPUT 714;"*RST" !Recommended command for a full preset, sets trigger arm to single.

OUTPUT 714;"SYSTEM:PRESET2" !Command for a full preset, sets trigger arm to continuous.

The *RST common command is the recommended command for a full preset operation.

NOTE
Transmit power is not set to OFF during a full preset, transmit power is set to the default value.

Full Preset Behavior
Function | Full Preset Result
Trigger Arm | Continuous (manual operation full preset or SYSTEM:PRESET2 command)
Trigger Arm | Single (remote operation full preset, *RST command)
Measurement Parameters | all set to defaults
Maskable Message Display State | On (manual operation full preset)
Maskable Message Display State | Off (remote operation full preset)

Status Preset

The STATUS:PRESET command sets the status system as defined in "SCPI 1995 Volume 2: Command Reference" section 20.7. All of the enable registers are set to 0, all PTR registers are set to 1, and all NTR registers are set to 0.

Example

OUTPUT 714;"STATUS:PRESET" !Presets the STATus subsystem.

Related Topics

SYSTem:PRESet


Instrument Status Area

Instrument Status Area

Description

The Instrument status area is found on the bottom center of the test set's display.

Status Area of the Test Set Display

Background

Users are able to initiate more than one measurement at a time with the test set. The test set's display will show a maximum of 2 measurements. When 3 or more measurements are initiated, or the MEASUREMENT screen is not displayed, the Background annunciator reminds you that measurements are active but not displayed.

<Operating Mode> Status

The call processing status and the operating modes are displayed in this area. This area may change (depending on the TA that is active) in order to provide TA specific information.

Shift

This annunciator indicates that the blue SHIFT key has been pressed, and that the next key you press will perform the shifted function indicated, also in blue.

Ext Ref

When a suitable external time base is connected to the rear panel 10MHz REF IN connector, this annunciator will turn on.

Int Ref

When a suitable external time base is not connected to the rear panel 10MHz REF IN connector, this annunciator will turn on.

Offset

Indicates that the Amplitude Offset state is set to On.

R L T S

This annunciator indicates the state of four different conditions of the test set:

  • Remote annunciator. `R' turns on when the test set is operated remotely.
  • Listen annunciator. `L' turns on when the test set is listening to a command.
  • Talk annunciator. `T' turns on when the test set is providing information over GPIB.
  • SRQ annunciator. `S' turns on when an SRQ is active.

Related Topics

TAP/ETAP Data Connection Processing States Lifecycle


Limited TAP

Limited TAP

IMPORTANT
If you are testing an access terminal with Qualcomm DMSS 5500 Release 3.1.50, you must verify that the test set is configured to the Test Application Protocol (TAP) (see Test Application Protocol ) and the Limited TAP is set to On . For access terminals with Qualcomm DMSS 5500 Release 3.1.50, when Test Application Protocol is set to FTAP, AT Directed Packets must not be greater than 50%, and RTAP Rate must be set to 9.6 kbps. Also, access probes sent by these access terminals are 3-4 dB below the expected value (see Under range occurs when testing access terminals with the Qualcomm DMSS 5500. ).

The test set supports the C.S0029 Test Application Specification (TAS) (see C.S0029 Test Application Specification Description (TAP/ETAP) ). The first commercial release of the Qualcomm 1xEV-DO access terminal chipset (DMSS 5500 Release 3.1.50, AA3150) has only limited support of the TAS functionality. The Limited TAP setting is provided to accommodate the limited TAS functionality of the first commercial release of the Qualcomm 1xEV-DO access terminal chipset.

When the test set is configured to the TAP (see Test Application Configuration ) in the Active Cell operating mode, the Limited TAP setting affects the test set behavior such as whether transmitting the forward test packets, what attributes are included in the FTAP Parameter Assignment Message and RTAP Parameter Assignment Message sent to the AT. For details, see Test Application Protocol . The Limited TAP being configured in the test set is displayed on the Call Setup screen in the Application Configuration window.

Related Topics

Programming: Step 2: Configure Test Set and Mobile Station Parameters

GPIB Command: CALL[:CELL]:APPLication:TAPRotocol:LIMited[:STATe]

Manual Operation: How Do I Change Call Parameters?

C.S0029 Test Application Specification Description (TAP/ETAP)

TAP/ETAP Data Connection Call Flow

Test Application Protocol

Troubleshooting Data Connection Processing


MAC Index

MAC Index

Last updated: June 20, 2006

  • Overview
  • MAC Index in Active Cell Operating Mode
  • MAC Index in IS-856 Test Operating Mode

Overview

The MAC (Medium Access Control) Indices are used by the Forward Channel for multiple functions including MAC channel identification, and preamble identification for both the forward control channel and the forward traffic channel.

A preamble sequence is transmitted with each Forward Traffic Channel or Control Channel physical layer packet. The preamble consists of all `0' symbols. The preamble either identifies the packet as a Control Channel packet (MAC index 2 or 3), or identifies the target access terminal for receiving the Forward Traffic Channel or AT-directed Control Channel packet (The access network uses the MAC index to identify the target access terminal. The MAC Index is assigned by the AN and sent to the AT as part of the procedure for establishing a traffic connection.).

There are 64 MAC Indices (numbered from 0 to 63) available for subtype 0 physical layer while 128 MAC Indices (numbered from 0 to 127) available for subtype 2 physical layer (To set the physical layer subtype, see Release A Physical Layer Subtype ). The following table shows how the MAC indices are used. For more description on the forward channels, see Forward Channel Overview .

MAC Index

Subtype 2 Physical Layer

Subtype 0 Physical Layer

MAC Index

MAC Channel

Traffic/Control Channel Preamble

MAC Channel

Traffic/Control Channel Preamble

0 - 1

Not Used

Not Used

Not Used

Not Used

2

Not Used

76.8 kbps Control Channel

Not Used

76.8 kbps Control Channel

3

Not Used

38.4 kbps Control Channel

Not Used

38.4 kbps Control Channel

4

RA (I channel)

Not Used

RA (I channel)

Not Used

5

Not Used

Broadcast

RPC, DRCLock 2

F-TCH for Single User packets

6 - 63

ARQ, DRCLock, RPC 1

F-TCH for Single User packets

66 - 70 3

Not Used

F-TCH for Multi-User Packet

Not Used

Not Used

71 4

Not Used

19.2, 38.4, 76.8 kbps Control Channel

72 - 127

ARQ, DRCLock, RPC 2

F-TCH for Single User packets
  1. Depending on the allocated MAC index, the subtype 2 physical layer MAC code channels (R-PC, DRC Lock, and ARQ channels) are spread with a 128 bit Walsh code transmitted on either the I or Q channels. When an AT is assigned an even numbered MAC index, the RPC and H-ARQ/L-ARQ channels are time-division multiplexed and transmitted on the I channel while the DRC Lock and P-ARQ channels are time-division multiplexed and transmitted on the Q channel. When an AT is assigned an odd numbered MAC index, the RPC and H-ARQ/L-ARQ channels are time-division multiplexed and transmitted on the Q channel while the DRC Lock and P-ARQ channels are time-division multiplexed and transmitted on the I channel.
  2. Depending on the allocated MAC index, the subtype 0 physical layer MAC code channels (R-PC and DRC Lock channels) are spread with a 64 bit Walsh code transmitted on either the I or Q channels. When an AT is assigned an even numbered MAC index, the RPC and DRC Lock channels are time-division multiplexed and transmitted on the I channel. When an AT is assigned an odd numbered MAC index, the RPC and DRC Lock channels are time-division multiplexed and transmitted on the Q channel.
  3. The test set does not support multi-user packet transmission.
  4. The test set does not support variable rate control channel packet.
  • MAC index 0 and 1 are not used.
  • The Control Channel transmissions have a preamble that is covered by a bi-orthogonal cover sequence with MAC index 2 (for the 76.8 kbps data rate) or 3 (for the 38.4 kbps data rate).
  • MAC index 4 is used to transmit the Reverse Activity (RA) Channel symbols.
  • MAC indices 5-63 (for subtype 0) and MAC indices 6-63 and 72 -127 (for subtype 2) are available to be assigned to an access terminal during establishing a traffic connection. The MAC index is then used to cover the RPC, DRC Lock and ARQ (only for subtype 2) Channels associated with the access terminal and identify which access terminal the packet is directed to by covering the preamble of Forward Traffic Channel.

MAC Index in Active Cell Operating Mode

In Active Cell operating mode, when a connection is established between the access terminal and test set, the test set assigns an MAC index (15, by default) to the access terminal. (Note that MAC Index 5 is always assigned to the AT in the E1966A releases no greater than A.05.11 and E6706A releases no greater than A.02.21. This has to be changed because MAC Index 5 is used for Broadcast in subtype 2 physical layer.)

The MAC index parameter is sent in the Traffic Channel Assignment message (see TAP/ETAP Data Connection Call Flow ).

MAC index can be queried ( CALL:STATus:MS:MACIndex? ) at any time, but a value will only be returned if a session is open (see Session Open State ). The MAC index that is assigned to the access terminal is displayed on the Call Setup screen in the Access Terminal Information (AN Assigned) window.

MAC Index in IS-856 Test Operating Mode

In the IS-856 Test Operating Mode , the test set does not send any signalling information on the forward link. You must specify an MAC Index value on the test set to match your AT's configuration so that the AT can successfully demodulate the test set's forward link signal. The MAC index you set on the test set is displayed on the Call Setup screen in the Configuration Information window.

Related Topics

Active Cell Operating Mode

  • GPIB command: CALL:STATus:MS:MACIndex?

IS-856 Test Operating Mode

  • Manual Operation: How Do I Change Parameters in IS-856 Test Operating Mode?
  • GPIB command: CALL:TEST856:MACIndex


Measuring Access Probe Power

Measuring Access Probe Power

Last updated: June 20, 2006

  • General Procedure
  • Testing 4.3.1 Range of Open Loop Output Power

General Procedure

NOTE
Channel power calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. The channel power calibration also calibrates the access probe power measurement. See Calibrating the Test Set for details.

  1. Connect the access terminal to the test set's front panel RF IN/OUT connector and power it on. If the access terminal does not automatically open a session, perform whatever actions are necessary to open a session. See How Do I Open a Session and Test Data Connection? for more details.
  2. Initialize the access probe power measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Access Probe Power measurement and press the knob.
  3. Select Access Probe Power Setup ( F1 ) to access the Access Probe Power Setup menu. From this menu you can configure measurement parameters such as Measurement Timeout and Trigger Arm , and also access parameters (such as Open Loop Adjust and Probe Sequence Max ), specified for some C.S0033 tests.
  4. Select Close Menu ( F6 ) to close the Access Probe Power Setup window.
  5. Set the access network to ignore all access attempts by setting Call Limit Mode to On ( F10 on the Call Parms 2 of 3 menu). See How Do I Change Call Parameters? for more details.
    NOTE

    It is recommended that you always turn Call Limit Mode on when measuring access probe power. The easiest way to induce access probes from the access terminal is to page the access terminal. If you do not have call limit mode set to on, when you page the access terminal, the connection will complete, which clears the access probe power result from the measurement screen.

    Set call limit mode back to off when you have finished measuring access probe power.

  6. If you wish to only capture the first access probe, set Trigger Arm to Single and press the START SINGLE key. When the Trigger Arm is set to Continuous , the test set will display the power level of the most recent access probe power measurement. In either case, a measurement result will not be returned until you complete step 7.
    IMPORTANT

    If Trigger Arm is set to Single , you must press the Start Single key to arm the measurement. The measurement will not operate until you arm it by pressing the Start Single key.

  7. In order to perform the access probe power measurement, the access terminal must send an access probe. The easiest way to induce this is to page the AT (open a connection) by selecting Start Data Connection ( F3 on the Control 2 of 2 menu). When the AT sends an access probe in response the page, its power level will be measured and displayed.
  8. After finishing the measurements:
    • End the connection attempt by selecting End Data Connection ( F3 on the Control 2 of 2 menu).
    • Turn the Call Limit Mode back to Off .
    • Turn the access probe power measurement off by pressing the Measurement selection key, selecting Access Probe Power , then Close Measurement ( F4 ).

IMPORTANT
If the access probe power measurement is on and waiting to measure a probe, all other measurements (except digital average power) will not be able to execute. It is therefore recommended that you turn off the access probe power measurement before attempting any other measurements.

A typical display is shown below:

Testing 4.3.1 Range of Open Loop Output Power

For details on performing the steps below, see the General Procedure above. In the lab application , the 4.3.1 test can also be performed with Graphical Access Probe Power measurement, see Measuring Graphical Access Probe Power .

  1. This test specifies using Default Access Channel MAC Protocol and Access Parameter message. See To Configure the Test Set to Default Access Channel MAC Subtype for detailed procedure.
  2. Set the Cell Band and Channel as needed and wait for access terminal automatically opening a session.
  3. Initialize the access probe measurement.
  4. Set Probe Power Step to 0 dB . This ensures that all access probes in the probe sequence will transmit at the same power level, rather than incrementing in power. This is beneficial in manual operation if you are running the measurement in continuous mode for the purpose of measuring the power level of all of the probes rather than just the first probe in the sequence.
  5. Set Probe Sequence Max to 1 .
  6. Set Preamble Length to 7 .
  7. Set Open Loop Adjust to 78 dB or 81 dB , depending upon band class.
  8. C.S0033 specifies to set the AN forward packet activity to 100%. Forward packet activity is fixed in the test set, always set to 100%. See Fixed Settings .
  9. Set the access network to ignore all access attempts by setting Call Limit Mode to On .
  10. Set Î or ( Cell Power ) to -25 , -65 or approximately -95 dBm/1.23 MHz (value depends on band class and access terminal class) for tests 1-3 as specified by C.S0033.

    IMPORTANT
    If Trigger Arm is set to Single , you must press the Start Single key to arm the measurement. The measurement will not operate until you arm it by pressing the Start Single key.

  11. Send a page to the access terminal by selecting Start Data Connection .
  12. Measure access probe power.
  13. Stop the page to the access terminal by selecting Stop Data Connection .
  14. Perform steps 10-13 for tests 1-3.

Related Topics

Access Probe Power Measurement Description


Measuring Packet Error Rate (PER)

Measuring Packet Error Rate (PER)

Last updated: June 29, 2006

  • General Procedure
  • Testing 3.2.1 Demodulation of Forward Traffic Channel in AWGN
  • Testing 3.2.2 Demodulation of Forward Traffic Channel in Multipath Fading Channel (Lab Application Only)
  • Testing 3.3.1 Receiver Sensitivity and Dynamic Range

General Procedure

  1. Connect the access terminal to the test set's front panel RF IN/OUT connector and power it on.
  2. Wait for the access terminal to open a session and then open an FTAP (for subtype 0 physical layer) or FETAP (for subtype 2 physical layer) test data connection for AT's receiver test. See How Do I Open a Session and Test Data Connection? for detailed procedure.
  3. Set the FTAP Rate ( F11 ) on the Call Parms 1 of 3 menu as needed if during an FTAP connection, or set the F-Traffic Format ( F12 ) on the Call Parms 1 of 3 menu as needed if during an FETAP connection.
  4. Initialize the PER measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Packet Error Rate measurement and press the knob.
  5. Select Packet Error Rate Setup ( F1 ) to access the Packet Error Rate Setup menu. From this menu you can configure measurement parameters such as Confidence Level , PER Requirement , as well as some general parameters that are required for some C.S0033 tests. For example, you can set AT Directed Packets , which helps you optimize PER test throughput.

    NOTE
    If Limited TAP is on while Test Application Protocol is set to FTAP, AT Directed Packets must not be greater than 50%.

  6. Select Close Menu ( F6 ) to close the Packet Error Rate Setup window.
  7. From the Call Parms menu, configure Cell Power ( F7 ) and FTAP Rate ( F11 ), as needed. See How Do I Change Call Parameters? for detailed procedure.

    NOTE
    If Limited TAP is on while Test Application Protocol is set to FTAP, RTAP Rate must be set to 9.6 kbps.

  8. From the Call Control menu, configure AWGN Power ( F3 ), as needed. (If you set AWGN Power too high relative to Cell Power, you may drop the connection). See How Do I Change Generator Information? for detailed procedure.
  9. Measure PER:
    • If the Trigger Arm field is set to Single , press the START SINGLE key to trigger each measurement.
    • If the Trigger Arm field is set to Continuous the measurement began executing as soon as you initialized it in step 3.

A typical display is shown below:

Testing 3.2.1 Demodulation of Forward Traffic Channel in AWGN

For details on performing the steps below, see the General Procedure above.

  1. C.S0033 specifies to set the AN forward packet activity to 100%. Forward packet activity is fixed in the test set, always set to 100%. See Fixed Settings .
  2. Set the Control Channel Data Rate to 38.4 kbps (see How Do I Change Cell Parameters? ).
  3. C.S0033 specifies to set Pilot Drop to -14 dB. Set Pilot Drop to 28 (see How Do I Change Cell Parameters? ). Note that changing the Pilot Drop results in a session re-negotiation.
  4. Set up a Test Application session and open an FTAP connection for tests 1-18. See How Do I Open a Session and Test Data Connection? for detailed procedure.
  5. Initialize the PER measurement.
  6. Set AT Directed Packets under the Application Config ( F10 on Call Parms 1 of 3 ) menu as needed (In an FTAP connection, if Limited TAP is on, AT Directed Packets must not be greater than 50%, and RTAP Rate must be set to 9.6 kbps).
  7. Set the ACK Channel Bit Fixed Mode Attribute to Off under the Application Config ( F10 on Call Parms 1 of 3 ) menu. (Otherwise, you may drop the data connection when AWGN is applied. This recommendation is based on many of experiments.)
  8. Set Î or ( Cell Power ) to -55 dBm/1.23 MHz .
  9. Set I oc ( AWGN Power ) and Data Rate/Slots per Physical Layer Packet ( FTAP Rate ) for tests 1-18 as specified by C.S0033.
    For example, in test 15, set the FTAP Data Rate to 307.2 kbps (2 Slot) and set the AWGN Power to -52.5 dBm/1.23 MHz .
  10. Set Confidence Level to 95% and PER Requirement as specified by C.S0033.
  11. Set Maximum Packet Count as desired.
  12. Measure PER for tests 1-18.
  13. If your AT supports Subtype 2 Physical Layer, continue to measure PER for tests 19-28 and 30 with the following setups.
    • Set Pilot Drop to 32 (corresponding to -16 dB). Note: This results in a session re-negotiation. See How Do I Change Cell Parameters? .
    • Set up a Test Application session and open an FETAP connection. See How Do I Open a Session and Test Data Connection? for detailed procedure.
    • Set Î or ( Cell Power ), I oc ( AWGN Power ) and forward packet format (packet size, slots, preamble length, data rate) per Physical Layer Packet for tests 19-30 as specified by C.S0033.
      For example, for test 25, set the Cell Power to -55 dBm/1.23 MHz , the AWGN Power to -47.07 dBm/1.23 MHz . Set the F-Traffic Format to 1 (512, 16, 1024) and the Max Forward Packet Duration to 4 slots which results in the nominal data rate of 19.2 kbps and the effective data rate of 76.8 kbps. (The Max Forward Packet Duration is set from the Termination Parameters menu, see How Do I Change Generator Information? for detailed procedure).
    • Repeat steps 9 -11 for tests 19-30.

Testing 3.2.2 Demodulation of Forward Traffic Channel in Multipath Fading Channel (Lab Application Only)

This test requires a faded signal with AWGN. When the test set is configured to generate faded forward channel signals with AWGN enabled, it requires a rear panel digital bus connection to an external PC running Baseband Studio software (see Digital Bus Information ).

The Baseband Studio software is capable of generating fading patterns and AWGN on the forward channel. RF power levels, including AWGN, are controlled by this software. (Note that when the test set is configured to generate a faded signal, the test set's internal AWGN generator is automatically turned off to allow the AWGN to be added by the external fading software. The resulting RF signal from the test set will have fading applied to the forward channel only, with no fading applied to AWGN.)

For detailed setup and operating instructions pertaining to the faded signal generation, refer to the:

E5515C Fading Solution Application Guide

(It can be downloaded at http://cp.literature.agilent.com/litweb/pdf/1000-1894.pdf ).

  1. C.S0033 specifies to set the AN forward packet activity to 100%. Forward packet activity is fixed in the test set, always set to 100%. See Fixed Settings .
  2. Set the Control Channel Data Rate to 38.4 kbps (see How Do I Change Cell Parameters? ).
  3. C.S0033 specifies to set Pilot Drop to -14 dB. Set Pilot Drop to 28 (see How Do I Change Cell Parameters? ).
  4. Set up a Test Application session and open an FTAP connection for tests 1-24. See How Do I Open a Session and Test Data Connection? for detailed procedure.
  5. Initialize the PER measurement. (See step 3 of General Procedure .)
  6. Set up the following key parameters from the Baseband Studio software. For example, for test 1:
    • Set the Cell Band to a value supported by your AT (for example, US PCS ).
    • Set the Channel to a value supported by your AT (for example, 425 ).
    • Set Î or ( Cell Power ) to -55 dBm/1.23 MHz .
    • Set I oc ( AWGN Power ) to -49 dBm/1.23 MHz (for Band 0: US Cellular) or -47.6 dBm/1.23 MHz (for Band 1: US PCS).
    • Select the 1xEV-DO Mobile Station fading configuration Case 1 from the standard Path Config menu.
  7. Set up the following key parameters from the Packet Error Rate Setup menu on the test set. For example, in test 1 as specified by C.S0033:
    • Set FTAP Rate (Data Rate/Slots per Physical Layer Packet) to 38.4kbp s.
    • Set Confidence Level to 95% and PER Requirement to 3.00% .
    • Set Maximum Packet Count as desired.
    • Set Minimum Packet Count to 375 for test 1. (C.S0033 specifies the minimum test duration required for channel simulator configuration 1 is 6000 slots. The test 1 specifies at data rate of 38.4 kbps (16 slots per packet). So the minimum packet count should be 6000/16=375 packets.)
    • Set AT Directed Packets as needed (if Limited TAP is on, AT Directed Packets must not be greater than 50%, and RTAP Rate must be set to 9.6 kbps).
  8. Measure PER. Repeat the steps 5 - 7 and change the parameters as required for each of the tests 1-24.
  9. If your AT supports Subtype 2 Physical Layer, continue to measure PER for tests 25-28 with the following setups.
    • Set up a Test Application session and open an FETAP connection. See How Do I Open a Session and Test Data Connection? for detailed procedure.
    • Follow the above steps 6-7, set Î or ( Cell Power ), I oc ( AWGN Power ) and transmission format (packet size, slots, preamble length, data rate) per Physical Layer Packet for tests 25-28 as specified by C.S0033.
      For example, for test 25, set the Cell Power to -55 dBm/1.23 MHz , the AWGN Power to -67.5 dBm/1.23 MHz (for Band 0: US Cellular) or -62.5 dBm/1.23 MHz (for Band 1: US PCS). Set the F-Traffic Format to 1 (512, 16, 1024) and the Max Forward Packet Duration to 4 slots which results in the nominal data rate of 19.2 kbps and the effective data rate of 76.8 kbps. (The Max Forward Packet Duration is set from the Termination Parameters menu, see How Do I Change Generator Information? for detailed procedure).

Testing 3.3.1 Receiver Sensitivity and Dynamic Range

For details on performing the steps below, see the General Procedure above.

  1. Set up a Test Application session and open an FTAP or FETAP connection. See How Do I Open a Session and Test Data Connection? for detailed procedure.
  2. Initialize the PER measurement.
  3. Set AT Directed Packets as needed (if in a FTAP connection, Limited TAP is on, AT Directed Packets must not be greater than 50%, and RTAP Rate must be set to 9.6 kbps).
  4. Receiver Sensitivity (test 1): Set Î or ( Cell Power ) to -105.5 dBm/1.23 MHz. Set FTAP Rate to 307.2 (2 Slot) if in an FTAP connection or set F-Traffic Format to 4 (1024, 2, 128) (corresponding to 307.2 kbps) if in an FETAP connection.
  5. Dynamic Range: Set Î or ( Cell Power ) to -25 dBm/1.23 MHz. Set FTAP Rate to 307.2 (2 Slot) for test 2 or 2457.6 (1 Slot) for test 3 if in an FTAP connection, or set F-Traffic Format to 4 (1024, 2, 128) for test 2 or C (4096, 1, 64) for test 3 if in an FETAP connection
  6. Set Confidence Level to 95% and PER Requirement to 0.50%.
  7. Set Maximum Packet Count as desired.
  8. Measure PER for each test.

Related Topics

Standard Abstract:

  • 3.2.1 Demodulation of Forward Traffic Channel in AWGN
  • 3.2.2 Demodulation of Forward Traffic Channel in Multipath Fading Channel (Lab Application Only)
  • 3.3.1 Receiver Sensitivity and Dynamic Range

Packet Error Rate (PER) Measurement Description

Programming a Packet Error Rate (PER) Measurement

Packet Error Rate Measurement Troubleshooting


Measuring Channel Power

Measuring Channel Power

  • General Procedure
  • Testing 4.3.5 Minimum Controlled Output Power

General Procedure

NOTE
Channel power calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. See Calibrating the Test Set for details.

  1. Connect the access terminal to the test set's front panel RF IN/OUT connector and power it on.
  2. Wait for the access terminal to open a session and then open an RTAP (for subtype 0 physical layer) or RETAP (for subtype 2 physical layer) data connection for AT's transmitter test. For details, see How Do I Open a Session and Test Data Connection? .
  3. Set the RTAP Rate ( F12 ) on the Call Parms 1 of 3 menu as needed if during an RTAP connection, or set the R-Data Pkt Size ( F12 ) on the Call Parms 1 of 3 menu as needed if during an RETAP connection.
  4. Initialize the channel power measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Channel Power measurement and press the knob.
  5. Select Channel Power Setup ( F1 ) to access the Channel Power Setup menu. From this menu you can configure measurement parameters such as Multi-Measurement Count , Trigger Arm , etc. (see Channel Power Measurement Parameters for details on these parameters). For statistical measurement results, highlight the Multi-Measurement Count parameter and press the ON key. The number of averages will default to 10. You can change the number as desired.
  6. Select Close Menu ( F6 ) to close the Channel Power Setup window.
  7. From the Call Parms menu, configure Cell Power ( F7 ), as needed.
  8. Measure channel power:
    • If the Trigger Arm field is set to Single , press the START SINGLE key to trigger each measurement.
    • If the Trigger Arm field is set to Continuous the measurement began executing as soon as you initialized it in step 3.

A typical measurement result (for subtype 0 physical layer) is shown below:

A typical measurement result (for subtype 2physical layer) is shown below:

Testing 4.3.5 Minimum Controlled Output Power

For details on performing the steps below, see the General Procedure above.

  1. For Subtype 0 or 1 Physical Layer, set up a Test Application session and open an RTAP connection with the RTAP Rate set to 9.6 kbps . For detailed procedure on how to open an RTAP session and connection, see How Do I Open a Session and Test Data Connection?

    For Subtype 2 Physical Layer, set up a Test Application session and open an RETAP connection with the following setups. For detailed procedure on how to open an RETAP session and connection, see How Do I Open a Session and Test Data Connection? .

    • Set the R-Data Pkt Size ( F12 on Call Parms 1 of 3 ) to 256 bits.
    • Set the Reverse Data Transmission Mode under the Application Config ( F10 on Call Parms 1 of 3 ) menu to High Capacity .
    • From the Power Parameters Info menu (see How Do I Change Channel Gain/Traffic Info Parameters? for how to access), set the 256-bit High Capacity Termination Target to 3 (4 sub-frames, resulting in 16 slots). (NOTE: You do not need to set this parameter unless its default value (3) is changed. Changing the setting results in an open data connection closed and a session re-negotiation. Once this happen, you need to re-open the connection.)

  2. Initialize the channel power measurement.
  3. Set the Call Drop Timer to Off ( F9 on the Call Parms 2 of 3 menu) to keep the test set from closing the connection based on the very low output power level of the access terminal.
  4. Set Î or ( Cell Power , F7 on the Call Parms 1 of 3 menu) to -25 dBm/1.23 MHz.
  5. Set Rvs Power Ctrl to All Down bits ( F7 on the Call Parms 2 of 3 menu) to transmit continuous down ('1') power control bits.
  6. Measure channel power.

    NOTE
    If Under Range is posted, it indicates that the measured power is below -61 dBm or is less than -9 dB below the expected power level of the receiver. When this happens, you should manually adjust the test sets receiver power and then repeat the test. (Setup procedure: on Call Parms 1 of 3 menu, select Manual in the Rcvr Power Ctrl ( F8 ), then set the Receiver Power ( F9 ) to a value close to the measured value being displayed on the Channel Power measurement screen.)

  7. When you have finished the testing, be sure to set the Call Drop Timer back to On and the Rvs Power Ctrl back to Active Bits to ensure that subsequent operation is successful.

Related Topics

4.3.5 Minimum Controlled Output Power


Measuring TX Spurious Emissions

Measuring TX Spurious Emissions

  • General Procedure
  • Testing 4.4.1 Conducted Spurious Emissions

General Procedure

NOTE
Channel power calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. The channel power calibration also calibrates the TX spurious emissions measurement. See Calibrating the Test Set for details.

  1. Connect the access terminal to the test set's front panel RF IN/OUT connector and power it on.
  2. Wait for the access terminal to open a session and then open an RTAP (for subtype 0 physical layer) or RETAP (for subtype 2 physical layer) data connection for AT's transmitter test. See How Do I Open a Session and Test Data Connection? for detailed procedure.
  3. Set the RTAP Rate ( F12 ) and FTAP Rate ( F11 ) on the Call Parms 1 of 3 menu as needed if during an RTAP connection, or set the R-Data Pkt Size ( F12 ) and F-Traffic Format ( F11 ) on the Call Parms 1 of 3 menu as needed if during an RETAP connection.
  4. Initialize the TX spurious emissions measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the TX Spurious Emissions measurement and press the knob.
  5. Select TX Spurious Emissions Setup ( F1 ) to access the TX Spurious Emissions Setup menu. From this menu you can configure measurement parameters such as Mask Control and Adjacent Limit and Alternate Limit . (These parameters are only available when Mask Control is set to Manual , see TX Spurious Emissions Measurement Parameters for more information.) For statistical measurement results, highlight the Multi-Measurement Count parameter and press the ON key. The number of averages will default to 10. You can change the value as desired.
  6. Select Close Menu ( F6 ) to close the TX Spurious Emissions Setup window.
  7. From the Call Parms menu, configure Cell Power ( F7 ), as needed.
  8. Measure TX spurious emissions:
    • If the Trigger Arm field is set to Single , press the START SINGLE key to trigger each measurement.
    • If the Trigger Arm field is set to Continuous , the measurement began executing as soon as you initialized it in step 3.
  9. Select Graph ( F3 ) to display a graphical view of the results, or Numeric ( F2 ) to display numeric results.
  10. When viewing the graphical display, you can select Marker Position ( F4 ) and turn the knob to display the spurious emissions levels at each of the frequency offsets.

Typical numeric and graphical measurement results are shown below:

Testing 4.4.1 Conducted Spurious Emissions

For details on performing the steps below, see the General Procedure above.

  1. Initialize the TX spurious emissions measurement.
  2. Set the following access parameters (see How Do I Change Access Parameters? ):
    • Set Open Loop Adjust to 81 dB or 84 dB, depending upon band class.
    • Set Probe Initial Adjust to 15 dB.
    • Set Probe Power Step to 7.5 dB/step.

  3. For Subtype 0 or 1 Physical Layer, set up a Test Application session and open an RTAP connection with the RTAP Rate ( F12 on the Call Parms 1 of 3 menu) set to 153.6 kbps . For detailed procedure on how to open an RTAP session and connection, see How Do I Open a Session and Test Data Connection? .

    For Subtype 2 Physical Layer, set up a Test Application session and open an RETAP connection with the following setups. For detailed procedure on how to open an RETAP session and connection, see How Do I Open a Session and Test Data Connection? .

    • Set the R-Data Pkt Size ( F12 on Call Parms 1 of 3 ) to 4096 bits.
    • Set the Reverse Data Transmission Mode under the Application Config ( F10 on Call Parms 1 of 3 ) menu to High Capacity .
    • From the Power Parameters Info menu (see How Do I Change Channel Gain/Traffic Info Parameters? for how to access), set the 4096-bit High Capacity Termination Target to 3 (4 sub-frames, 16 slots). (NOTE: You do not need to set these settings unless the default value (3) of these settings are changed. Changing these setting results in an open data connection closed because these settings are configured during session negotiation. Once this happen, you need to re-open the connection.)

  4. C.S0033 specifies to configure the Test Application FTAP (for Subtype 0 or 1 Physical Layer) or FETAP (for Subtype 2 Physical Layer) with a Forward Traffic Channel rate of 307.2 kbps (2-slot version) and the ACK Channel is transmitted at all the slots.
    To do this, set the FTAP Rate ( F11 on Call Parms 1 of 3 ) to 307.2 (2 Slot) if during subtype 0 physical layer test or set the F-Traffic Format ( F11 on Call Parms 1 of 3 ) to 4 (1024, 2, 128) if during subtype 2 physical layer test, and set ACK Channel Bit Fixed Mode to On from Application Config ( F10 on Call Parms 1 of 3 ).
  5. Set Î or ( Cell Power ) to -60 dBm/1.23 MHz.
  6. Set Rvs Power Ctrl to All Up bits ( F7 on the Call Parms 2 of 3 menu) to transmit continuous up power control bits.
  7. Measure TX Spurious Emissions, and note the pass/fail result.
  8. When you have finished testing, be sure to set the Rvs Power Ctrl back to Active bits to ensure that subsequent signalling is successful (see Reverse Closed Loop Power Control ).

Related Topics

TX Spurious Emissions Measurement Description


Measuring Digital Average Power

Measuring Digital Average Power

  • General Procedure
  • Testing 4.3.4 Maximum RF Output Power

General Procedure

NOTE
Digital average power calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. See Calibrating the Test Set for details.

  1. Connect the access terminal to the test set's front panel RF IN/OUT connector and power it on.
  2. Wait for the access terminal to open a session and then open an RTAP (for subtype 0 physical layer) or RETAP (for subtype 2 physical layer) data connection for AT's transmitter test. See How Do I Open a Session and Test Data Connection? for detailed procedure.
  3. Set the RTAP Rate ( F12 ) or FTAP Rate ( F11 ) on the Call Parms 1 of 3 menu as needed if during an RTAP connection, or set the R-Data Pkt Size ( F12 ) or F-Traffic Format ( F11 ) on the Call Parms 1 of 3 menu as needed if during an RETAP connection.
  4. Initialize the digital average power measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Digital Average Power measurement and press the knob.
  5. Select Digital Average Power Setup ( F1 ) to access the Digital Average Power Setup menu. From this menu you can configure measurement parameters such as Multi-Measurement Count and Trigger Arm . For statistical measurement results, highlight the Multi-Measurement Count parameter and press the ON key. The number of averages will default to 10. You can change the number as desired.
  6. Select Close Menu ( F6 ) to close the Digital Average Power Setup window.
  7. From the Call Parms menu, configure Cell Power ( F7 ), as needed.
  8. Measure digital average power:
    • If the Trigger Arm field is set to Single , press the START SINGLE key to trigger each measurement.
    • If the Trigger Arm field is set to Continuous , the measurement began executing as soon as you initialized it in step 3.

A typical measurement result (for subtype 0 physical layer) is shown below:

A typical measurement result (for subtype 2 physical layer) is shown below:

Testing 4.3.4 Maximum RF Output Power

For details on performing the steps below, see the General Procedure above.

  1. Initialize the digital average power measurement.
  2. Set the following access parameters (see How Do I Change Access Parameters? ):
    • Set Open Loop Adjust to 81 dB or 84 dB, depending upon band class. (for example, 81 for US Cellular band or 84 for US PCS band)
    • Set Probe Initial Adjust to 15 dB.
    • Set Probe Power Step to 7.5 dB/step.

  3. For Subtype 0 or 1 Physical Layer, set up a Test Application session and open an RTAP connection with the RTAP Rate set to 153.6 kbps . For detailed procedure on how to open an RTAP session and connection, see How Do I Open a Session and Test Data Connection? .

    For Subtype 2 Physical Layer, set up a Test Application session and open an RETAP connection with the following setups. For detailed procedure on how to open an RETAP session and connection, see How Do I Open a Session and Test Data Connection? .

    • Set the R-Data Pkt Size ( F12 on Call Parms 1 of 3 ) to 4096 bits.
    • Set the Reverse Data Transmission Mode under the Application Config ( F10 on Call Parms 1 of 3 ) menu to High Capacity .
    • From the Power Parameters Info menu (see How Do I Change Channel Gain/Traffic Info Parameters? for how to access), set the 4096-bit High Capacity Termination Target to 3 (4 sub-frames, 16 slots). (NOTE: You do not need to set these settings unless the default value (3) of these settings are changed. Changing these setting results in an open data connection closed because these settings are configured during session negotiation. Once this happen, you need to re-open the connection.)

  4. C.S0033 specifies to configure the Test Application FTAP (for Subtype 0 or 1 Physical Layer) or FETAP (for Subtype 2 Physical Layer) with a Forward Traffic Channel rate of 307.2 kbps (2-slot version) and the ACK Channel is transmitted at all the slots.
    To do this, set the FTAP Rate ( F11 on Call Parms 1 of 3 ) to 307.2 (2 Slot) if during subtype 0 physical layer test or set the F-Traffic Format ( F11 on Call Parms 1 of 3 ) to 4 (1024, 2, 128) if during subtype 2 physical layer test, and set ACK Channel Bit Fixed Mode to On from Application Config ( F10 on Call Parms 1 of 3 ).
  5. Set Î or ( Cell Power ) to -60 dBm/1.23 MHz.
  6. Set Rvs Power Ctrl to All Up bits ( F7 on the Call Parms 2 of 3 menu) to transmit continuous up power control bits.
  7. Measure digital average power.
  8. When you have finished testing, be sure to set the Rvs Power Ctrl back to Active bits to ensure that subsequent signalling is successful (see Reverse Closed Loop Power Control ).

Related Topics

Standard Abstract: 4.3.4 Maximum RF Output Power


Measuring Waveform Quality + Code Domain Power

Measuring Waveform Quality + Code Domain Power

  • General Procedure
  • Testing 4.2.2 Waveform Quality and Frequency Accuracy
  • Testing 4.3.7 RRI Channel Output Power
  • Testing 4.3.8 Code Domain Power

General Procedure

NOTE
Channel power calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. The channel power calibration also calibrates the waveform quality + code domain measurement. See Calibrating the Test Set for details.

  1. Connect the access terminal to the test set's front panel RF IN/OUT connector and power it on.
  2. Wait for the access terminal to open a session and then open an RTAP (for subtype 0 physical layer) or RETAP (for subtype 2 physical layer) data connection for AT's transmitter test. See How Do I Open a Session and Test Data Connection? for detailed procedure.
  3. Set the RTAP Rate ( F12 ) or FTAP Rate ( F11 ) on the Call Parms 1 of 3 menu as needed if during an RTAP connection, or set the R-Data Pkt Size ( F12 ) or F-Traffic Format ( F11 ) on the Call Parms 1 of 3 menu as needed if during an RETAP connection.
  4. Initialize the waveform quality + code domain measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Waveform Quality + Code Domain measurement and press the knob.
  5. Select Waveform Quality + Code Domain Setup ( F1 ) to access the Waveform Quality + Code Domain Setup menu. From this menu you can configure measurement parameters such as Slots to Measure , DRC Channel Gain , etc. For statistical measurement results, highlight the Multi-Measurement Count parameter and press the ON key. The number of averages will default to 10.
  6. Select Close Menu ( F6 ) to close the Waveform Quality + Code Domain Setup window.
  7. If needed, set the RTAP Rate ( F12 ) or FTAP Rate ( F11 ) on the Call Parms 1 of 3 menu when during an RTAP connection test, or set the R-Data Pkt Size ( F12 ) or F-Traffic Format ( F11 ) on the Call Parms 1 of 3 menu when during an RETAP connection test.
  8. Measure waveform quality and code domain power:
    • If the Trigger Arm field is set to Single , press the START SINGLE key to trigger each measurement.
    • If the Trigger Arm field is set to Continuous , the measurement began executing as soon as you initialized it in step 3.
  9. Select Numeric Rho ( F2 ) to view the waveform quality results. A typical display is shown below.
  10. Select Code Domain Power ( F3 ) to view the code domain results. A typical display is shown below. When viewing the code domain results, you can select Marker Position ( F6 ) and turn the knob to select a Walsh code and display its power.

  11. Select Code Domain Power + Noise ( F4 ) to view the code domain + noise results. A typical display is shown below. When viewing the code domain + noise results, you can select Marker Position ( F6 ) and turn the knob to select a Walsh code and display its power.

Testing 4.2.2 Waveform Quality and Frequency Accuracy

For details on performing the steps below, see the General Procedure above.

  1. For Subtype 0 or 1 Physical Layer, set up a Test Application session and open an RTAP connection with the RTAP Rate set to 9.6 kbps . For detailed procedure on how to open an RTAP session and connection, see How Do I Open a Session and Test Data Connection? .

    For Subtype 2 Physical Layer, set up a Test Application session and open an RETAP connection with the following setups. For detailed procedure on how to open an RETAP session and connection, see How Do I Open a Session and Test Data Connection? .

    • Set the R-Data Pkt Size ( F12 on Call Parms 1 of 3 ) to 256 bits.
    • Set the Reverse Data Transmission Mode under the Application Config ( F10 on Call Parms 1 of 3 ) menu to High Capacity .
    • From the Power Parameters Info menu (see How Do I Change Channel Gain/Traffic Info Parameters? for how to access), set the 256-bit High Capacity Termination Target to 3 (4 sub-frames, 16 slots). (NOTE: You do not need to set these settings unless the default value (3) of these settings are changed. Changing these setting results in an open data connection closed because these settings are configured during session negotiation. Once this happen, you need to re-open the connection.)

  2. C.S0033 specifies to configure the FTAP or FETAP such that the ACK Channel is transmitted at all the slots. To do this, set the ACK Channel Bit Fixed Mode to On from Application Config ( F10 under Call Parms 1 of 3 ).
  3. Initialize the waveform quality + code domain measurement. Set Slots to Measure to 1. See Recommended Slots to Measure Settings for details.
  4. Set Î or ( Cell Power ) to - 75 dBm/1.23 MHz .
  5. Measure waveform quality + code domain.
  6. Select Numeric Rho ( F2 ) to view the Rho , Frequency Error and Time Error results. A typical measurement result is shown below.

Testing 4.3.7 RRI Channel Output Power

For details on performing the steps below, see the General Procedure above.

  1. Test 1: Set up a Test Application session and open an RTAP connection (for Subtype 0 or 1 Physical Layer).
  2. Set Î or ( Cell Power ) to -75 dBm/1.23 MHz.
  3. Initialize the waveform quality + code domain measurement.
  4. Set Slots to Measure to 8. See Recommended Slots to Measure Settings .
  5. Measure waveform quality + code domain.
  6. Select Code Domain Power ( F3 ) to view the R-RRI [image] Pilot result (available in the last column of the table of data).
  7. Test 2: Set up an RETAP session (for Subtype 2 Physical Layer) with the following parameters and then open an RETAP connection. For detailed procedure on how to open an RETAP session and connection, see How Do I Open a Session and Test Data Connection? . (NOTE: It is recommended set the parameters prior to opening the session and connection because some of these settings are configured during session negotiation state)
    • Set the R-Data Pkt Size ( F12 on Call Parms 1 of 3 ) to 256 bits.
    • Set the Reverse Data Transmission Mode under the Application Config ( F10 on Call Parms 1 of 3 ) menu to High Capacity .
    • From the Power Parameters Info menu (see How Do I Change Channel Gain/Traffic Info Parameters? for how to access), set the 256-bit High Capacity T2P Transition to 3 (4 sub-frames) and 256-bit High Capacity Termination Target to 3 (4 sub-frames). (NOTE: You do not need to set these settings unless the default value (3) of these settings are changed. Changing these setting results in an open data connection closed because these settings are configured during session negotiation. Once this happen, you need to re-open the connection.)
    • From the RRI Gain Parameters Info menu (see How Do I Change Channel Gain/Traffic Info Parameters? for how to access), set the RRI Channel Gain Pre-Transition 3 to -6 dB and 256-bit High Capacity Termination Target to 3 (4 sub-frames). (NOTE: You do not need to set these settings unless the default value (3) of these settings are changed. Changing these setting results in an open data connection closed because these settings are configured during session negotiation. Once this happen, you need to re-open the connection.)
  8. Set Slots to Measure to 1. See Recommended Slots to Measure Settings .
  9. Measure waveform quality + code domain.
  10. Select Code Domain Power ( F3 ) to view the R-RRI [image] Pilot result (available in the last column of the table of data).
  11. A typical measurement result for test 2 is shown below.

Testing 4.3.8 Code Domain Power

For details on performing the steps below, see the General Procedure above.

  • Testing 4.3.8.1 DRC Channel Output Power
  • Testing 4.3.8.2 ACK Channel Output Power
  • Testing 4.3.8.3 Data Channel Output Power
  • Testing 4.3.8.4 DSC Channel Output Power

Testing 4.3.8.1 DRC Channel Output Power

  1. Set up a Test Application session and open an RTAP (for Subtype 0 or 1 Physical Layer) or an RETAP (for Subtype 2 Physical Layer) connection. See How Do I Open a Session and Test Data Connection? for detailed procedure.
  2. C.S0033 specifies to configure the FTAP or FETAP such that the ACK Channel is transmitted at all the slots. To do this, set the ACK Channel Bit Fixed Mode to On from Application Config ( F10 under Call Parms 1 of 3 ).
  3. Set Î or ( Cell Power ) to -75 dBm/1.23 MHz.
  4. Initialize the waveform quality + code domain measurement. Set the Slots to Measure to 2 if during a RTAP connection (for subtype 0 physical layer test) or set the Slots to Measure to 1 if during a RETAP connection (for subtype 2 physical layer test). See Recommended Slots to Measure Settings .
  5. Set DRC Channel Gain to 0 dB.
  6. Measure waveform quality + code domain.
  7. Select Code Domain Power ( F3 ) to view the R-DRC [image] Pilot result (available in the last column of the table of data).
  8. Set DRC Channel Gain to 3 dB and repeat steps 6 and 7.
  9. A typical measurement result is shown below.

Testing 4.3.8.2 ACK Channel Output Power

  1. Set up a Test Application session and open an RTAP (for Subtype 0 or 1 Physical Layer) or an RETAP (for Subtype 2 Physical Layer) connection. See How Do I Open a Session and Test Data Connection? for detailed procedure.
  2. C.S0033 specifies to configure the FTAP or FETAP such that the ACK Channel is transmitted at all the slots. To do this, set the ACK Channel Bit Fixed Mode to On from Application Config ( F10 under Call Parms 1 of 3 ).
  3. Set Î or ( Cell Power ) to -75 dBm/1.23 MHz.
  4. Initialize the waveform quality + code domain measurement. Set Slots to Measure to 2. See Recommended Slots to Measure Settings .
  5. Set ACK Channel Gain to 0 dB.
  6. Measure waveform quality + code domain.
  7. Select Code Domain Power ( F3 ) to view the R-ACK [image] Pilot result (available in the last column of the table of data).
  8. Set ACK Channel Gain to 3 dB and repeat steps 6 and 7.
  9. A typical measurement result is shown below.

Testing 4.3.8.3 Data Channel Output Power

The test set currently does not support tests 6 and 7 for measuring the capsule portion of each Access Channel probe.

  1. For Subtype 0 or 1 Physical Layer, set up a Test Application session and open an RTAP connection with the RTAP Rate set to 9.6 kbps . For detailed procedure on how to open an RTAP session and connection, see How Do I Open a Session and Test Data Connection? .

    For Subtype 2 Physical Layer, set up a Test Application session and open an RETAP connection with the following setups. For detailed procedure on how to open an RETAP session and connection, see How Do I Open a Session and Test Data Connection? .

    • Set the R-Data Pkt Size ( F12 on Call Parms 1 of 3 ) to 256 bits.
    • Set the Reverse Data Transmission Mode under the Application Config ( F10 on Call Parms 1 of 3 ) menu to High Capacity .
    • From the Power Parameters Info menu (see How Do I Change Channel Gain/Traffic Info Parameters? for how to access), set the 256-bit High Capacity Termination Target to 3 (4 sub-frames, resulting in 16 slots). (NOTE: You do not need to set this parameter unless its default value (3) is changed. Changing the setting results in an open data connection closed and a session re-negotiation. Once this happen, you need to re-open the connection.)

  2. C.S0033 specifies to configure the FTAP (for Subtype 0 or 1 Physical Layer) or FETAP (for Subtype 2 Physical Layer) such that the ACK Channel is transmitted at all the slots. To do this, set the ACK Channel Bit Fixed Mode to On from Application Config ( F10 under Call Parms 1 of 3 ).
  3. Set Î or ( Cell Power ) to -75 dBm/1.23 MHz.
  4. Initialize the waveform quality + code domain measurement.
  5. Set Slots to Measure to 2 (for subtype 0 physical layer) or 1 (for subtype 2 physical layer). See Recommended Slots to Measure Settings .
  6. Measure waveform quality + code domain.
  7. Select Code Domain Power ( F3 ) to view the R-Data [image] Pilot result and R-AuxPilot [image] Pilot results available in the last column of the table of data (R-Aux Pilot is only applicable to tests 8-10). In addition, for test 5, the power in all inactive Walsh codes can be obtained by placing a marker on the inactive walsh channel, then view the Marker power result. For tests 5, 8-10 during subtype 2 physical layer tests, the [image] Pilot power of individual walsh channels constituting the R-Data (such as I:2 SF=4 , Q:2 SF=4 , etc.) can be obtained by placing a marker on the walsh channel, then view the Bin [image] Pilot result following the Marker power result).
  8. Tests 2-5: Repeat steps 6-7 with RTAP rates of 19.2, 38.4, 76.8, 153.6 kbps (for subtype 0 physical layer) or with R-Data packet size of 512, 1024, 2048, 4096 bits and termination target of 16 slots (for subtype 2 physical layer).
  9. Tests 8-10: (only applicable to subtype 2 physical layer) Repeat steps 6-7 with R-Data packet size of 3072, 6144, 12288 bits and termination target of 16 slots. (In order for the R-Aux Pilot Channel to be active for the test, the Auxiliary Pilot Channel Min Payload accessed from the Enhanced Traffic Parameters menu (see How Do I Change Channel Gain/Traffic Info Parameters? for how to access) must be set to a value no greater than the current R-Data payload size. NOTE: You do not need to set this parameter unless its default value (3072 bits) is changed. Changing the setting results in an open data connection closed and a session re-negotiation. Once this happen, you need to re-open the connection.)
  10. A typical measurement result for test 8 is shown below.

Testing 4.3.8.4 DSC Channel Output Power

  1. Set up an RETAP session (for Subtype 2 Physical Layer) with the following setups and then open an RETAP connection. For detailed procedure on how to open an RETAP session and connection, see How Do I Open a Session and Test Data Connection? . (NOTE: It is recommended set the parameters prior to opening the session and connection because some of these settings are configured during session negotiation state)
    • Set the R-Data Pkt Size ( F12 on Call Parms 1 of 3 ) to 256 bits.
    • Set the Reverse Data Transmission Mode under the Application Config ( F10 on Call Parms 1 of 3 ) menu to High Capacity .
    • From the Power Parameters Info menu (see How Do I Change Channel Gain/Traffic Info Parameters? for how to access), set the 256-bit High Capacity Termination Target to 3 (4 sub-frames, resulting in 16 slots).
  2. C.S0033 specifies to configure the FETAP such that the ACK Channel is transmitted at all the slots. To do this, set the ACK Channel Bit Fixed Mode to On from Application Config ( F10 under Call Parms 1 of 3 ).
  3. Set Î or ( Cell Power ) to -75 dBm/1.23 MHz.
  4. Initialize the waveform quality + code domain measurement. Set Slots to Measure to 2. See Recommended Slots to Measure Settings .
  5. Set DSC Channel Gain to -9 dB.
  6. Measure waveform quality + code domain.
  7. Select Code Domain Power ( F3 ) to view the R-DSC [image] Pilot result (available in the last column of the table of data).
  8. Set DSC Channel Gain to -12 dB and repeat steps 6-7.
  9. A typical measurement result is shown below.

Related Topics

Standard Abstract:

  • 4.2.2 Waveform Quality and Frequency Accuracy
  • 4.3.7 RRI Channel Output Power
  • 4.3.8 Code Domain Power

Waveform Quality + Code Domain Measurement Description

Programming a Waveform Quality/Code Domain Measurement

Waveform Quality Measurement Troubleshooting


Measuring TX Dynamic Power

Measuring TX Dynamic Power

General Procedure

NOTE
Channel power calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. The channel power calibration also calibrates the TX dynamic power measurement. See Calibrating the Test Set for details.

NOTE
The measurement is expected to only be used when data connection status is Idle since the access terminal must be placed in a test mode, otherwise it may not produce meaningful results.

  1. Connect the access terminal to the test set's front panel RF IN/OUT connector and power it on.
  2. Place your access terminal in the test mode required for performing TX dynamic power. The access terminal should be set to transmit initial power at its maximum transmit power at the appropriate frequency for the test.
  3. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  4. Set test set's receiver power control to Manual mode and set the test set's Manual Receiver Power and Meas Frequency (see Manual Operation: Manual Receiver Control ) to the initial power level and frequency at which the access terminal will transmit. (It should be the maximum power the access terminal will transmit)
  5. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the TX Dynamic Power measurement and press the knob.

      IMPORTANT
      The TX dynamic power measurement does not run concurrently with any other measurements. If any measurements are running, they are closed when TX dynamic power measurement is initiated, and a message is displayed indicating that a measurement has been closed. Activating another measurement inactivates the TX dynamic power measurement.

  6. Set the measurement parameters as needed for your test situation.
    • Press the TX Dynamic Power Setup ( F1 ) key to access the TX Dynamic Power Setup menu.
    • Set the Power Step Size , Number of Power Steps , and Power Step Time to match your access terminal's test mode. See TX Dynamic Power Measurement Parameters for details.
    • Press the Close Menu ( F6 ) key.
  7. Press the START SINGLE key to arm the TX Dynamic Power measurement.
  8. Via the access terminal test mode interface, command the access terminal to generate an RF Rise impulse to trigger the measurement. After that, the access terminal will transmit power according to its test mode defined output power profile.
    IMPORTANT

    Don't change any test set settings until the measurement is complete. Otherwise, it may cause the measurement to abort due to the missed trigger (see TX Dynamic Power Measurement Troubleshooting ).

  9. A typical display for the TX Dynamic Power measurement result is shown below.
  10. Set up the graph display:
    • Press the Graph Control (F2 ).
    • Press the Start Step ( F3 ) and Span ( F4 ) to adjust the graph view.
    • Press the Marker Position ( F1 ). The power result that corresponds with the marker position is displayed above the graph and is highlighted in the table below the graphical display. The marker position also controls the table scrolling.

Related Topics

TX Dynamic Power Measurement Description


Measuring Time Response of Open Loop Power Control (TROLPC)

Measuring Time Response of Open Loop Power Control (TROLPC)

Last updated: May 24, 2006

  • General Procedure
  • Testing 4.3.2 Time Response of Open Loop Power Control

General Procedure

NOTE
Channel power calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. The channel power calibration also calibrates the TROLPC measurement. See Calibrating the Test Set for details.

  1. Connect the access terminal to the test set's front panel RF IN/OUT connector and power it on.
  2. Wait for the access terminal to open a session and then open an RTAP (for subtype 0 physical layer) or RETAP (for subtype 2 physical layer) data connection for AT's transmitter test. See How Do I Open a Session and Test Data Connection? for detailed procedure.
  3. Set the RTAP Rate ( F12 ) on the Call Parms 1 of 3 menu as needed if during an RTAP connection, or set the R-Data Pkt Size ( F12 ) on the Call Parms 1 of 3 menu as needed if during an RETAP connection.

  4. C.S0033 does not specify that the R-ACK Channel must be active for 4.3.2 Time Response of Open Loop Power Control. If the R-ACK Channel is active during this test, the access terminal's power may fall outside of the mask specifications. To help ensure that your access terminal does not fail this test, you should disable the R-ACK Channel by setting the following parameters from the Application Config ( F10 on the Call Parms 1 of 3 ):

    • Set ACK Channel Bit Fixed Mode Attribute to Off .
    • Set AT Directed Packets to 0% .

      IMPORTANT
      After completing TROLPC testing, you must return ACK Channel Bit Fixed Mode Attribute to on and set AT Directed Packets to a non-zero value, if needed.

  5. Initialize the TROLPC measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Time Response of Open Loop Power Control measurement and press the knob.

      NOTE
      If any measurements are open during initiation of a TROLPC, the test set will automatically close them and display an error message indicating the last measurement that was closed.

  6. Select Time Response of OLPC Setup ( F1 ) to access the Time Response of OLPC Setup menu. You can also configure AT directed packets and ACK channel bit fixed mode attribute from this menu.
  7. Select Close Menu ( F6 ) to close the Time Response of OLPC Setup window.
  8. From the Call Parms menu, configure Cell Power ( F7 ), as needed.
  9. Measure TROLPC:
    • Select Start Meas Up ( F2 ), which automatically increases Cell Power by 20 dB and captures the resulting access terminal output power for 100 ms, or
    • Select Start Meas Down ( F3 ) which automatically decreases Cell Power by 20 dB and captures the resulting access terminal output power for 100 ms.
    • You may also select START SINGLE to start the measurement. The cell power will increase by 20 dB if Start Meas Up was last performed (or if the test set is in a preset state), or decrease by 20 dB if Start Meas Down was last performed.
  10. After the measurement has completed, select Marker ( F4 ) and turn the knob to display power at points along the access terminal output power trace. If the test failed, next to the word "Fail," the first data point at which the test failed is displayed.

    NOTE
    As specified by C.S0033, the AT output power level curve is shown in absolute terms. The delta expressions above the display indicate the direction of power change.

An example of a "Fail" test result is shown below.

IMPORTANT
After completing TROLPC testing, you must return ACK Channel Bit Fixed Mode Attribute to on and set AT Directed Packets to a non-zero value appropriate for your test setup.

Testing 4.3.2 Time Response of Open Loop Power Control

For details on performing the steps below, see the General Procedure above.

  1. For Subtype 0 or 1 Physical Layer, set up a Test Application session and open an RTAP connection with the RTAP Rate set to 9.6 kbps . For detailed procedure on how to open an RTAP session and connection, see How Do I Open a Session and Test Data Connection? .

    For Subtype 2 Physical Layer, set up a Test Application session and open an RETAP connection with the following setups. For detailed procedure on how to open an RETAP session and connection, see How Do I Open a Session and Test Data Connection? .

    • Set the R-Data Pkt Size ( F12 on Call Parms 1 of 3 ) to 256 bits.
    • Set the Reverse Data Transmission Mode under the Application Config ( F10 on Call Parms 1 of 3 ) menu to High Capacity .
    • From the Power Parameters Info menu (see How Do I Change Channel Gain/Traffic Info Parameters? for how to access), set the 256-bit High Capacity Termination Target to 3 (4 sub-frames, 16 slots). (NOTE: You do not need to set these settings unless the default value (3) of these settings are changed. Changing these setting results in an open data connection closed because these settings are configured during session negotiation. Once this happen, you need to re-open the connection.)

  2. Configure the Test Application FTAP (for Subtype 0 or 1 Physical Layer) or FETAP (for Subtype 2 Physical Layer) so that the ACK Channel is not transmitted by the access terminal, by setting ACK Channel Bit Fixed Mode Attribute to Off and AT Directed Packets to 0% under the Application Config ( F10 on Call Parms 1 of 3 ) menu.
  3. Initialize the TROLPC measurement.
  4. Set Î or ( Cell Power ) to -60 dBm/1.23 MHz.
  5. C.S0033 specifies to send alternating `0' and `1' power control bits on the Forward Traffic Channel. When you start the TROLPC measurement, the test set automatically sends alternating closed loop power control bits during the test.
  6. Measure TROLPC:
    • Select Start Meas Up ( F2 ), (cell power transitions to -40 dBm/1.23 MHz), and note the pass/fail result.
    • Select Start Meas Down ( F3 ), (cell power transitions to -60 dBm/1.23 MHz), and note the pass/fail result.
    • Select Start Meas Down ( F3 ), (cell power transitions to -80 dBm/1.23 MHz), and note the pass/fail result.
    • Select Start Meas Up ( F2 ), (cell power transitions to -60 dBm/1.23 MHz), and note the pass/fail result.

Related Topics

Time Response of Open Loop Power Control (TROLPC) Measurement Description


How Do I Change Access Parameters?

How Do I Change Access Parameters?

Last updated: June 19, 2006

A. Select the Access Parameters Menu.

  1. Press the CALL SETUP key.
  2. Press the left More key, go to Call Control 2 of 2 (in the Test Application) or Call Control 2 of 3 (in the Lab Application).
  3. Select Access Network Info ( F2 ), go to AN Info menu.
  4. All access parameters are available by pressing the F4 on AN Info menu. Depending upon the current setting of the Access Channel MAC Subtype, the F4 is labeled as either Access Parameters or Enhanced Access Parameters .
    • When the test set is configured to Default Access Channel MAC Subtype (see To Configure the Test Set to Default Access Channel MAC Subtype for detailed procedure), the F4 is labeled as Access Parameters .
    • When the test set is configured to Enhanced Access Channel MAC Subtype (see To Configure the Test Set to Enhanced Access Channel MAC Subtype for detailed procedure), the F4 is labeled as Enhanced Access Parameters .
  5. Select F4 . A typical display for the Access Parameters menu or the Enhanced Access Parameters menu is shown as below.

B. Set an Access Parameter.

  1. Turn the knob to highlight a parameter and then press the knob.
  2. Enter a value or selection and press the knob.
  3. Select Close Menu ( F6 ).

To Configure the Test Set to Default Access Channel MAC Subtype

To configure the test set to Default Access Channel MAC Subtype,

  • set the Protocol Rel ( F11 on Call Parms 2 of 3) to 0 (1xEV-DO) , or
  • set the Protocol Rel ( F11 on Call Parms 2 of 3) to A (1xEV-DO-A) and set the Release A Physical Layer Subtype to Subtype 0 from the Protocol Subtype Configuration menu by pressing the F12 ( Protocol Subtype Config ).
  • set the Protocol Rel ( F11 ) to A (1xEV-DO-A) , set the Release A Physical Layer Subtype to Subtype 2 and PL Subtype 2 Access Channel MAC Subtype to Default from the Protocol Subtype Configuration menu by pressing the F12 ( Protocol Subtype Config ).

To Configure the Test Set to Enhanced Access Channel MAC Subtype

To configure the test set to Enhanced Access Channel MAC Subtype, set the Protocol Rel ( F11 ) to A (1xEV-DO-A) , set the Release A Physical Layer Subtype to Subtype 2 and PL Subtype 2 Access Channel MAC Subtype to Enhanced from the Protocol Subtype Configuration menu by pressing the F12 ( Protocol Subtype Config ).

Related Topics

Open Loop Adjust

Preamble Length

Probe Initial Adjust

Probe Num Step

Probe Power Step

Probe Sequence Max


How Do I Change Configurable Attribute Control Mode?

How Do I Change Configurable Attribute Control Mode?

Last updated: June 19, 2006

A. Select the Configurable Attribute Control Menu.

  1. Press the CALL SETUP key.
  2. Press the left More key, go to Call Control 2 of 2 (in the Test Application) or Call Control 2 of 3 (in the Lab Application).
  3. Select Access Network Info ( F2 ).
  4. Select Configurable Attribute Parms ( F1 ).
  5. The parameters under Configurable Attribute Control menu are different depending upon the current physical layer subtype.
    • When the test set is configured to subtype 0 physical layer (see To Configure the Test Set to Subtype 0 Physical Layer for detailed procedure), a typical display for Configurable Attribute Control menu is shown as below.
    • When the test set is configured to subtype 2 physical layer (see To Configure the Test Set to Subtype 0 Physical Layer for detailed procedure), a typical display for Configurable Attribute Control menu is shown as below.

B. Set the Control Mode for a Configurable Attribute.

IMPORTANT
You can not change the session negotiation control mode for a configurable attribute when a session is open and Call Limit Mode is on (because the test set would not be able to establish a traffic connection to re-negotiate the value when call limit mode is on).

  1. Turn the knob to highlight a parameter and then press the knob.
  2. Enter a value or selection and press the knob.
  3. Select Close Menu ( F6 ).

Related Topics

Preferred Control Channel Cycle


How Do I Change Call Parameters?

How Do I Change Call Parameters?

Last updated: June 19, 2006

  • General Procedure
  • To Configure the Test Set to FTAP/RTAP Protocols
  • To Configure the Test Set to FETAP/RETAP Protocols
  • To Configure the Test Set to Subtype 0 Physical Layer
  • To Configure the Test Set to Subtype 2 Physical Layer

General Procedure

  1. Press the CALL SETUP key.
  2. Select any Call Parms softkey ( F7 to F12 ) to select a parameter.
  3. Change the parameter as needed using the knob and/or keypad.
  4. Select More ( 1 of 3 ) under Call Parms for additional call parameters.
  5. Depending upon the current setting of the physical layer subtype, the Call Parms menus are different.
    • When the test set is configured to subtype 0 physical layer (see To Configure the Test Set to Subtype 0 Physical Layer for detailed procedure), a typical display for Call Parms menu is shown as below.
      Call Parms Menu (for Subtype 0 Physical Layer)
    • When the test set is configured to subtype 2 physical layer (see To Configure the Test Set to Subtype 2 Physical Layer for detailed procedure), a typical display for Call Parms menu is shown as below.
      Call Parms Menu (for Subtype 2 Physical Layer)

To Configure the Test Set to FTAP/RTAP Protocols

When the test set is configured to subtype 0 physical layer, the following parameters can be configured from the Application Configuration Window by selecting the Application Config ( F10 on Call Parms 1 of 3 ).

Application Configuration (for Subtype 0 Physical Layer)

  • To establish an FTAP connection for AT's receiver test in subtype 0 physical layer, you should set Test Application Protocol to FTAP . Change other parameters as needed for your tests.
  • To establish an RTAP connection for AT's transmitter test in subtype 0 physical layer, you should set Test Application Protocol to RTAP . Change other parameters as needed for your tests.
  • ( Lap Application Only ) To establish a DPA connection for data application test, you should set Session Application Type to Default Packet Application . (See Session Application Type ).

Your settings are displayed in the Application Configuration window on the Call Setup screen. Also, the application ( FTAP , RTAP or DPkt ) and physical layer subtype ( PLSub0 ) currently configured in the test set are displayed at the bottom of the screen.

To Configure the Test Set to FETAP/RETAP Protocols

When the test set is configured to subtype 2 physical layer, the following parameters can be configured from the Application Configuration Window by selecting the Application Config ( F10 on Call Parms 1 of 3 ).

Application Configuration (for Subtype 2 Physical Layer)

  • To establish an FETAP connection for AT's receiver test in subtype 2 physical layer, you should set Enhanced Test Application Protocol to FETAP . Change other parameters as needed for your tests.
  • To establish an RETAP connection for AT's transmitter test in subtype 2 physical layer, you should set Enhanced Test Application Protocol to RETAP . Change other parameters as needed for your tests.
  • ( Lap Application Only ) The test set currently does not support DPA test in subtype 2 physical layer.

Your settings are displayed in the Application Configuration window on the Call Setup screen. Also, the application ( FETAP or RETAP ) and physical layer subtype ( PLSub0 or PLSub2 ) being configured in the test set are displayed at the bottom of the screen.

To Configure the Test Set to Subtype 0 Physical Layer

To configure the test set to subtype 0 physical layer,

  • set the Protocol Rel ( F11 on Call Parms 2 of 3) to 0 (1xEV-DO) , or
  • set the Protocol Rel ( F11 on Call Parms 2 of 3) to A (1xEV-DO-A) and set the Release A Physical Layer Subtype to Subtype 0 from the Protocol Subtype Configuration menu by pressing the F12 ( Protocol Subtype Config ).

To Configure the Test Set to Subtype 2 Physical Layer

To configure the test set to subtype 2 physical layer, set the Protocol Rel ( F11 on Call Parms 2 of 3) to A (1xEV-DO-A) and set the Release A Physical Layer Subtype ( F12 on Call Parms 2 of 3) to Subtype 2 from the Protocol Subtype Configuration menu by pressing the F12 ( Protocol Subtype Config ).

Related Topics

How Do I Open a Session and Test Data Connection?

Cell Power

Cell Band

Channel

Application Config: Session Application Type ( Lab Application Only ), Test Application Protocol , Limited TAP , AT Directed Packets , DRC Value Fixed Mode Attribute , ACK Channel Bit Fixed Mode Attribute , Enhanced Test Application Protocol , ACK Channel Modulation Type , Reverse Data Transmission Mode , Enhanced Access Rate

FTAP Rate

RTAP Rate

F-Traffic Format

F-Traffic Config

R-Data Pkt Size

Reverse Closed Loop Power Control

Power Control Step

Call Limit Mode

Call Drop Timer

Protocol Rel

Protocol subtype config: Release A Physical Layer Subtype , PL Subtype 2 Access Channel MAC Subtype

Session Close

Rcvr Power Ctrl ( Manual Operation: Manual Receiver Control )

Meas Frequency ( Manual Operation: Manual Receiver Control )


How Do I Change Cell Parameters?

How Do I Change Cell Parameters?

Last updated: May 24, 2006

A. Select the Cell Parameters Menu.

  1. Press the CALL SETUP key.
  2. Press the left More key, go to Call Control 2 of 2 (in the Test Application) or Call Control 2 of 3 (in the Lab Application).
  3. Select Access Network Info ( F2 ), go to AN Info menu.
  4. Select Cell Parameters ( F2 ).

B. Set a Cell Parameter.

  1. Turn the knob to highlight a parameter and then press the knob.
  2. Enter a value or selection and press the knob.
  3. Select Close Menu ( F6 ).

Related Topics

Color Code

Control Channel Data Rate

Country Code

Preferred Control Channel Cycle

Sector ID

Subnet Mask

Pilot Drop


How Do I Change Channel Gain/Traffic Info Parameters?

How Do I Change Channel Gain/Traffic Info Parameters?

Last updated: June 19, 2006

A. Select the Channel Gain Info or Channel Gain/Traffic Info menu

  1. Press the CALL SETUP key.
  2. Press the left More key, go to Call Control 2 of 2 (in the Test Application) or Call Control 2 of 3 (in the Lab Application).
  3. Select Access Network Info ( F2 ), go to AN Info menu.
  4. Depending upon the current setting of the physical layer subtype, the F3 on AN Info menu is labeled as either Channel Gain Info (for subtype 0 physical layer) or Channel Gain / Traffic Info (for subtype 2 physical layer) which allows you to access different parameters. For detailed procedure on how to configure the physical layer subtype, see To Configure the Test Set to Subtype 0 Physical Layer and To Configure the Test Set to Subtype 0 Physical Layer respectively.
    • Press the F3 ( Channel Gain Info ), set the parameters as demonstrated at B1. Set parameters accessed from F3 (Channel Gain Info)
    • Press the F3 ( Channel Gain / Traffic Info ), set the parameters as demonstrated at B2. Set parameters accessed from F3 (Channel Gain/Traffic Info)

B1. Set parameters accessed from F3 (Channel Gain Info)

  1. When the F3 ( Channel Gain Info ) is pressed, the channel gain parameters can be accessed.
  2. Select Channel Gain Parameters ( F3 ).
  3. Turn the knob to highlight a parameter and then press the knob.
  4. Enter a value or selection and press the knob.
  5. Select Close Menu ( F6 ).

B2. Set parameters accessed from F3 (Channel Gain/Traffic Info)

  1. When the F3 ( Channel Gain / Traffic Info ) is pressed, more parameters relating to subtype 2 physical layer can be accessed.
    • To set subtype 2 physical layer T2P related parameters, select Power Parameters Info ( F1 ). A typical display is shown as below. Note that all of the T2P parameters for each data packet size and transmission mode are displayed on the Power Parameters screen. Which set of T2P parameters being applied in the test set (current values) is identified by a '>' indicator.
      • Press F1 ( T2P Setup Ctrl ), select a R-Data packet size (for example, 512 bits ). F2 is labeled according to the F1 setting (in this example, 512-bit Power Parameters is labeled for F2 ).
      • Press F2 , set the T2P parameters (such as T2P Transition value, Termination Target value, TxT2P Pre-Transition and Post-Transition gain values) for the specified packet size.
    • To set the following enhanced parameters for subtype 2 physical layer, select Enhanced Traffic Parameters ( F2 ).
    • To set the subtype 2 reverse channel gain, select Channel Gain Parameters ( F3 ). Note that the R-Data channel gains are set from the Power Parameters Info menu and the RRI channel gains are set from the RRI Gain Parameters menu.
    • To set the subtype 2 R-RRI channel gain, select RRI Gain Parameters ( F4 ).
  2. Turn the knob to highlight a parameter and then press the knob.
  3. Enter a value or selection and press the knob.
  4. Select Close Menu ( F6 ).

Related Topics

Data Offset Nom

Data Offset 9k6|19k2|38k4|76k8|153k6

ACK Channel Gain

DRC Channel Gain

DSC Channel Gain

Auxiliary Pilot Channel Gain

Enhanced Traffic Parameters

RRI Gain Parameters

Power Parameters Info


How Do I Close the Connection?

How Do I Close the Connection?

Last updated: May 24, 2006

  1. Press the CALL SETUP key.
  2. Select End Data Connection ( F3 ).
  3. Check for Session Open in the Active Cell status field (see Session Open State ).

Related Topics

How Do I Close the Session?


How Do I Close the Session?

How Do I Close the Session?

Last updated: May 24, 2006

  1. Press the CALL SETUP key.
  2. Select Close Session ( F4 ).
  3. Check for Idle in the Active Cell status field (see Idle State ).

You may also simply disconnect the access terminal from the test set. The test set's session timer will then expire (see Fixed Settings ) and the data connection will return to the idle state.

Related Topics

How Do I Close the Connection?


How Do I Configure the AUDIO OUT Port?

How Do I Configure the AUDIO OUT Port?

Last updated: May 24, 2006

A. Select a signal to output at the AUDIO OUT port.

  1. Press the SYSTEM CONFIG key.
  2. Press the More key on the left side of the display for additional system parameters.
  3. Press the Audio Out Port ( F1 ) key.
  4. Turn the knob to highlight a selection and then press the knob.

NOTE
To facilitate the change of signal selection for output to the front-panel AUDIO OUT port while performing different tasks, you can also access the Audio Out Port settings from several other menus: Audio Generator control menu, Swept Audio Setup menu, Call Parms menu (2 of 3) in AVC Test operating mode, and Call Parms menu (2 of 3) in Active Cell operating mode with AMPS system selected. Changing the selection on one menu will be applied to all other menus.

NOTE
Selection of FM Demod signal routed to the front-panel AUDIO OUT port is useful only in AMPS system. There will be no guaranteed performance for the signal present at the Audio Out Port when FM Demod is selected for output.

B. Set FM Demod signal.

When FM Demod signal is selected for output to the front-panel AUDIO OUT port, a bandpass filter, expander circuit, and de-emphasis circuit can be individually inserted or bypassed in the FM Demod signal path.

  1. Press the SYSTEM CONFIG key.
  2. Press the More key.
  3. Press the FM Demod Setup ( F2 ) key.
  4. Turn the knob to highlight a selection and then press the knob.
  5. Enter a value or selection and press the knob.
  6. Press the Close Menu ( F6 ) key.

NOTE
If the FM Demod Setup settings are changed while the Audio Out Port selection is not FM Demod (see A. Select a signal to output at the AUDIO OUT port. ), the values will be stored for use when Audio Out Port is set to FM Demod.

Related Topics

Configuring the Test Set's AUDIO OUT port


How Do I Change CDMA System Time Parameters?

How Do I Change CDMA System Time Parameters?

Last updated: May 24, 2006

A. Select CDMA System Time Parameters Menu.

  1. Press the CALL SETUP key.
  2. Press the left More key, go to Call Control 2 of 2 (in the Test Application) or Call Control 2 of 3 (in the Lab Application).
  3. Select Access Network Info ( F2 ), go to AN Info menu.
  4. Select CDMA System Time / Sync Info ( F5 ).
  5. Select CDMA System Time Parms ( F1 ) key.

B. Set CDMA System Time Parameters.

  1. Turn the knob to highlight a parameter and then press the knob.
  2. Enter a value and press the knob. The entered values will be shown on CDMA System Time Information window and updated in every two seconds.

    NOTE
    The CDMA System Time (Date) and the CDMA System Time (Time) can only be changed when the test set is in idle state. See Operating Consideration .

  3. Select Close Menu ( F6 ).

Related Topics

CDMA System Time Parameters


How Do I Configure Test Signals in CW Operating Mode?

How Do I Configure Test Signals in CW Operating Mode?

Last updated: May 24, 2006

  1. Press the CALL SETUP key.
  2. Press the Operating Mode ( F1 ) key and set the operating mode to CW .
  3. Press the Test Signal ( F9 ) key to select a signal for output to the front panel RF connector currently selected. See Front Panel Connectors to select either RF IN/OUT or RF OUT ONLY connector.
  4. Select a test signal from the menu and confirm the selection by selecting Yes in the dialog box.
    NOTE

    Changing test signal requires several seconds to complete.

  5. Press the Cell Power ( F7 ) key and set the signal output power level to meet your testing needs.
  6. Press the RF Gen Freq ( F8 ) key and set the signal output center frequency to meet your testing needs.
  7. Press the Receiver Control ( F12 ) key and manually set the test set's receiver control parameters (such as expected CW power, measurement receiver frequency, and reverse link receiver frequency) to the desired values (see Manual Receiver Control in CW Operating Mode ).

Related Topics

CW Operating Mode

Receiver Control


How Do I Change Generator Information?

How Do I Change Generator Information?

Last updated: May 24, 2006

A. Select the Generator Info Menu.

  1. Press the CALL SETUP key.
  2. Press the left More key, go to Call Control 2 of 2 (in the Test Application) or Call Control 2 of 3 (in the Lab Application).
  3. Select Generator Info ( F3 ) go to Gen Info menu.
  4. Depending upon the current Protocol Rel ( F11 on Call Parms 2 of 3) and Rel A Phys Layer ( F12 on Call Parms 2 of 3) settings, the Gen Info menu provides different parameters for your access as shown in the table below.

    Call Parms 2 of 3

    Gen Info menu

B. Set parameters on Gen Info menu.

  1. Select any Gen Info softkey ( F1 to F5 ) to select a parameter.
  2. Change the parameter as needed using the knob and/or keypad.

Related Topics

Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power

External Trigger Type

PN Offset

Termination Parameters

Code Channel Parameters


How Do I Perform a Handoff?

How Do I Perform a Handoff?

Last updated: May 24, 2006

  1. Press the CALL SETUP key.
  2. Select Handoff Setup ( F5 ).
  3. Highlight Handoff Cell Band and select the desired band.
  4. Highlight Handoff Channel and select the desired channel.
  5. Select Execute Handoff (F5 ) to complete the handoff, or Close Menu ( F6 ) to abort the handoff.
  6. Check for Connected in the Active Cell field (see Connected State ).

You can also simply change Cell Band and/or Channel from the Call Parms menu and the test set immediately negotiates the connection to the new cell band and/or channel.

Related Topics

How Do I Open a Session and Test Data Connection?


How Do I Make Measurements?

How Do I Make Measurements?

Last updated: May 24, 2006

A. Open a Data Connection

If required for your test purposes, open a session and connection. (see How Do I Open a Session and Test Data Connection? )

B. Initiate Measurements.

  1. Press the Measurement selection key.
  2. Highlight a measurement and press the knob.
  3. Repeat steps 1 and 2 to initiate additional measurements.

As the measurement executes, or when it completes, any non-zero integrity indicators (0 = normal) will be displayed below the measurement result (see Integrity Indicator )

Related Topics

How Do I Change the Measurement Setup?

How Do I Turn Off a Measurement?

Measuring Access Probe Power

Measuring Channel Power

Measuring Digital Average Power

Measuring Packet Error Rate (PER)

Measuring Time Response of Open Loop Power Control (TROLPC)

Measuring TX Spurious Emissions

Measuring Waveform Quality + Code Domain Power


How Do I Change the Measurement Setup?

How Do I Change the Measurement Setup?

Last updated: May 24, 2006

A. Select the Measurement to Set Up.

To set up a measurement, you must bring it to the top window position on the measurement screen. If the measurement you wish to set up is already in the top window position, proceed to step B below.

To bring a measurement to the top window position, you can:

  1. Press the Measurement selection key.
  2. Highlight the measurement you wish to set up, and press the knob.

Or, if the measurement is already active but in the bottom window position, you may:

  1. Select Swap Window Positions ( F5 ).

B. Set Up the Measurement.

  1. Press the MEASUREMENT key.
  2. Select (Measurement) Setup ( F1 ) to display the measurement's setup menu.
  3. Highlight a parameter and press the knob.

  4. Enter a value or selection and press the knob.

    Note

    For statistical measurement results, highlight the Multi-Measurement Count parameter and press the ON key. The number of averages will default to 10.

Note
  • Press the Close Menu ( F6 ) key.

    • Related Topics

    How Do I Make Measurements?


How Do I Open a Session and Test Data Connection?

How Do I Open a Session and Test Data Connection?

Last updated: June 20, 2006

To allow testing of access terminal (AT) minimum performance operating at subtype 0 physical layer, an FTAP or RTAP data connection must be established between the test set and the AT. To allow testing of access terminal (AT) minimum performance operating at subtype 2 physical layer, an FETAP or RETAP data connection must be established between the test set and the AT. (See C.S0029 Test Application Specification Description (TAP/ETAP) for more description on the TAP or ETAP.)

The general procedure includes:

  • A. Configure Call Parameters
  • B. Open a Session
  • C. Open a Test Application Connection

A. Configure Call Parameters

  1. Press the CALL SETUP key.
  2. Select Operating Mode ( F1 ) and set the operating mode to Active Cell .
  3. Configure the parameters necessary for your access terminal to find service with the test set, such as Cell Power , Cell Band and Channel (see How Do I Change Call Parameters? ).

  4. If you were using the Lab Application , prior to opening a test application session, verify that the Session Application Type accessed from the Application Config ( F10 on the Call Parms menu) is set to Test Application .

  5. If you plan to open a TAP test data connection, configure the test set to subtype 0 physical layer. See To Configure the Test Set to Subtype 0 Physical Layer for detailed procedure.

    If you plan to open an ETAP data connection, configure the test set to subtype 2 physical layer. See To Configure the Test Set to Subtype 2 Physical Layer for detailed procedure.

B. Open a Session

A session can only be established from the access terminal. The test set can not open a session.

  1. Turn on the access terminal and wait for it to open a session.
  2. Check for Session Open in the Active Cell status field (see Session Open State ) and AT reported information displayed on the Call Setup Screen.
    • If you've set the test set to subtype 0 physical layer, a typical display after a session open is as below.
    • If you've set the test set to subtype 2 physical layer, a typical display after a session open is as below.

C. Open a Test Application Connection

  1. If you've set the test set to subtype 0 physical layer, you can open an FTAP or RTAP connection for AT's receiver and transmitter tests.:

    • Select Application Config ( F10 on the Call Parms 1 of 3 menu).
    • Set Test Application Protocol to FTAP or RTAP . Select Close Menu ( F6 )
    • Set FTAP Rate ( F11 ) or RTAP Rate ( F12 ) on the Call Parms 1 of 3 menu, as needed.

    If you've set the test set to subtype 2 physical layer, you can open an FETAP or RETAP connection for AT's receiver and transmitter tests.:

    • Select Application Config ( F10 on the Call Parms menu).
    • Set Enhanced Test Application Protocol to FETAP or RETAP . Select Close Menu ( F6 )
    • Set F-Traffic Format ( F11 ) or R-Data Pkt Size ( F12 ) on the Call Parms 1 of 3 menu, as needed.

  2. Select Start Data Connection ( F3 on Call Control menu) to page the access terminal.
  3. Check for Connected in the Active Cell status field (see Connected State ). Also, the type of test application (FTAP, RTAP, FETAP or RETAP) and physical layer subtype (PLSub0 or PLSub2) being configured for the current connection is also indicated at the right bottom of the status area. An example display after an FTAP test data connection is shown as below.
  4. You can change the application type between FTAP and RTAP as well as the associated forward and reverse data rate as needed during a TAP data connection, or change the application type between FETAP and RETAP as well as the associated forward and reverse transmission format (data rate) as needed during an ETAP data connection. If required, change other parameters (such as AT Directed Packets , etc.). For detailed procedure, see How Do I Change Call Parameters? .

Related Topics

How Do I Close the Session?

How Do I Close the Connection?

Release A Physical Layer Subtype

Test Application Protocol

Enhanced Test Application Protocol

C.S0029 Test Application Specification Description (TAP/ETAP)

Paging State


Manual Operation: Manual Receiver Control

Manual Operation: Manual Receiver Control

Manual Receiver Control in Active Cell or Cell Off Operating Mode

As shown in figure below, to access receiver control settings while in Active Cell or Cell Off operating mode, press the CALL SETUP key, press the Call Parms More key until 3 of 3 is displayed. Select Manual in the Rcvr Power Ctrl ( F8 ), then select Receiver Power ( F9 ) and enter a new value to manually set the receiver's expected power. To manually set the receiver's measurement downconverter tune frequency, select Meas Frequency ( F10 ) and enter a new value to replace the Auto .

Manual Receiver Control in IS-856 Test Operating Mode

As shown in figure below, to access receiver control settings while in IS-856 Test operating mode, press the CALL SETUP key, press the Call Parms More key until 3 of 3 is displayed. Select Manual in the Rcvr Power Ctrl ( F7 ), then select Receiver Power ( F8 ) and enter a new value to manually set the receiver's expected power. To manually set the receiver's measurement downconverter tune frequency, select Meas Frequency ( F9 ) and enter a new value to replace the Auto . To manually set the receiver's demodulation downconverter tune frequency, select Rvs Link Freq ( F10 ) and enter a new value to replace the Auto . To manually set the RF generator's frequency, select Manual in the RF Gen Freq Ctrl ( F11 ), then select RF Gen Freq ( F12 ) and enter a new value.

Manual Receiver Control in CW Operating Mode

While in CW operating mode (see figure below), to access receiver control settings, press the CALL SETUP key. Select Receiver Control ( F12 ), then set the receiver's expected power ( Expected CW Power ), the measurement downconverter's tune frequency ( Measurement Frequency ), and the demodulation downconverter's tune frequency ( Uplink Frequency ) by highlighting the setting, pressing the knob, and entering or selecting the new value.

Related Topics

How Do I Change Call Parameters?


How Do I Use the Spectrum Monitor?

How Do I Use the Spectrum Monitor?

Last updated: May 24, 2006

The following procedure shows a typical usage of the spectrum monitor in each of its two modes of operation; Swept Mode and Zero Span mode.

  1. Establish a call with the mobile.

    Note

    The spectrum monitor can also be used with any of the test set's test mode operating modes.

Note
  • Press the Instrument selection key.
  • Select Spectrum Monitor .

    The spectrum monitor is displayed with the default settings as shown above. The center frequency is initially set at the expected frequency maintained by the test set's base station emulator. The Swap Window Positions ( F5 ) key is only displayed when other measurements are active at the same time as the spectrum monitor.

  • Set the axis control as needed for your testing situation using the Frequency Span ( F1 ), Reference ( F2 ), and dB/div ( F3 ) keys. See Frequency Span, Resolution Bandwidth and Dynamic Range to find the valid Frequency Span entries while in swept mode. To set the reference level manually ( Auto is the default), press the Reference ( F2) key then use the DATA ENTRY keys to enter the value you want.
  • Press the Trigger Setup ( F4 ) key to access the Trigger Setup menu.
  • Set the trigger settings to meet your testing needs. For example:

    • If you want the Spectrum Monitor to sweep immediately and continuously, ensure that Trigger Arm ( F3 ) is set to Continuous .
    • If you want to use external triggering, so that the Spectrum Monitor is triggered from a signal applied to the TRIG IN connector on the test set's rear panel, set Trigger Source ( F1 ) to External .
    • Trigger Delay ( F2 ) allows you to specify the point, relative to the trigger event where samples are taken (a negative trigger delay value collects pre-trigger samples). The same trigger delay setting is used for swept mode and zero span mode.
    • Res Bw allows you to set the resolution bandwidth. If you want the resolution bandwidth coupled with the with the Frequency Span , set this field to AUTO by pressing the gray DATA ENTRY softkey labeled ON , otherwise use the knob or the numeric DATA ENTRY softkeys to set the resolution bandwidth. See Frequency Span, Resolution Bandwidth and Dynamic Range to find the valid entries for the resolution bandwidth while in swept mode. Note that changing the resolution bandwidth does not modify the zero span resolution bandwidth setting.

  • Press the Return ( F6 ) key to exit the Trigger Setup menu.
  • Press the Display ( F6 ) key to access the display settings.

    A typical spectrum monitor trace display is shown above. In this case, the Display menu is open allowing you to access all of the display control settings using the ( F1 ) through ( F12 ) keys.

    The following list provides examples of some of the settings you may want to adjust:

    • Detection Method ( F2 ) determines the algorithm used to find the value that represents each frequency bin. See Detection Method for more information.

    • Peak Threshold ( F4 ) and Peak Excursion ( F5 ) set the peak threshold and peak excursion levels respectively. A peak is identified by using the peak threshold and peak excursion value. A point is only marked as a peak if it rises and falls more than the peak excursion value from the peak threshold value.

    • Marker Mode ( F8 ) sets the mode of the active marker. Position mode activates a single frequency marker. Delta mode freezes the active marker at its current location and uses it as a reference marker. A second marker is created at the position of the reference marker and is used as a delta marker, reporting any change in amplitude or frequency from that of the reference marker.

    • Peak Search ( F10 ) moves the active marker to the highest peak on the spectrum monitor display, returning the numeric amplitude and frequency values.

    • Marker -> Expected Freq ( F11 ) sets the base station emulator's expected frequency to the frequency of the active marker. This setting is not available in zero span mode.

    • Marker -> Expected Power ( F12 ) sets the base station emulator's expected power level to the amplitude of the active marker.

    A typical swept mode spectrum monitor display is shown above. In this case, the active marker is marker 1, which is set to Delta mode.

  • Press the Return ( F6 ) key to exit the Display menu.
  • To set the spectrum monitor to zero span mode, press the Frequency Span ( F1 ) key and use the numeric DATA ENTRY keys to enter a value of 0 MHz , or use the down-arrow key to reduce the span to zero.

    A typical zero span mode spectrum monitor display is shown above. Like swept mode, the Y-axis represents absolute amplitude. However, the X-axis now represents time rather than frequency.

  • Press the Trigger Setup ( F6 ) key. In zero span mode, additional trigger setup controls are available to you:
    • If you want to change the view window over which you are looking at the signal, use the Time Span ( F8 ) and Time Offset ( F9 ) keys. The measurement is made for the duration of the time span, beginning at the time defined by the trigger event plus the trigger delay plus the time offset.
    • If you want to change the resolution bandwidth, press the Zero Span RBW ( F7 ) key and select a value. (To measure the total power of a signal you must select a resolution bandwidth greater than or equal to the signal bandwidth.) See Frequency Span, Resolution Bandwidth and Dynamic Range to find the valid entries for the resolution bandwidth while in zero span mode. Note that changing the zero span resolution bandwidth does not modify the swept mode resolution bandwidth.

    A typical zero span mode spectrum monitor display showing a bursted signal. The viewing window has been adjusted to zoom in on a single burst.

    If the temperature of the test set drifts outwith the calibrated temperature range of the spectrum monitor, a Measurement Uncalibrated message is displayed. To calibrate the spectrum monitor for the current temperature, press the Calibrate Measurement ( F11 ) key on the Trigger Setup menu.


How Do I Configure the Test Set for My Test System?

How Do I Configure the Test Set for My Test System?

Last updated: May 24, 2006

A. Configure instrument information and setup.

  1. Press the SYSTEM CONFIG key.
  2. Press the Instrument Setup (F1) key.
  3. Adjust an instrument setting.
  4. Press the Close Menu (F6) key.

CAUTION
Always verify that the test set is responding to a new LAN IP Address by pinging the test set. If the test set does not respond to the ping, cycle power. This will ensure that the test set will respond to the new LAN IP Address.

B. Set amplitude offsets.

  1. On the Configuration Summary screen (not shown), press the RF IN/OUT Amptd Offset ( F5 ) key.
  2. On the RF IN/OUT Amplitude Offset screen, press the RF IN/OUT Amptd Offset Setup ( F2 ) key.
  3. Enter the amplitude offset for the test frequencies you use.
  4. Press the Close Menu ( F6 ) key.

C. Check message log.

  1. From any System Config screen, press the Message Log ( F7 ) key and view the message log.
  2. Press the Return ( F12 ) key.

Related Topics

Display Brightness

Configuring the Test Set's GPIB

Configuring the Test Set's LAN

Test Set Beeper

Test Application Switching

Amplitude Offset

Error Message Log


How Do I Change Parameters in IS-856 Test Operating Mode?

How Do I Change Parameters in IS-856 Test Operating Mode?

Last updated: May 24, 2006

A. Select the IS-856 Test Operating Mode.

  1. Press the CALL SETUP key.
  2. Select Operating Mode ( F1 ) and set the operating mode to IS-856 Test .
  3. All of parameters that are supported in IS-856 test operating mode can be configured from the Call Control and Call Parms menus.

B. Set the Parameters from Call Control Menus

Configure the parameters necessary for your test conditions, such as MAX Index , Cell Parameters , Access Parameters , etc.

  1. Select MAC Index ( F2 ) on Call Control 1 of 2 menu, and enter a value matching your AT's configuration.
  2. Press the left More key and go to Call Control 2 of 2 menu.
  3. Select Access Network Info ( F2 ).
    • Select Cell Parameters ( F2 ) and change the parameters as needed (such as Color code, control channel data rate, sector ID, etc.). See How Do I Change Cell Parameters? for details.
    • Select Channel Gain Parameters ( F3 ) and change the parameters as needed (such as data offset nom, etc.). See How Do I Change Channel Gain/Traffic Info Parameters? for details.
    • Select Access Parameters ( F4 ) and change the parameters as needed (such as Open loop adjust, probe initial adjust, etc.). See How Do I Change Access Parameters? for details.
  4. Select Generator Info ( F3 ) and change the parameters as needed (such as AWGN power, PN offset, etc.). See How Do I Change Generator Information? for details.

C. Set the Parameters from Call Parms Menus

Configure the parameters necessary for your test conditions, such as Cell Power , Cell Band , Channel , Forward Traffic Rate , Reverse Data Rate , etc.

  1. Select any Call Parms softkey ( F7 to F12 ) to select a parameter.
  2. Change the parameter as needed (such as s Cell Power , Cell Band , Channel , Forward Traffic Rate , Reverse Data Rate , etc.) using the knob and/or keypad.
  3. Press the right More ( 1 of 3 ) under Call Parms for additional call parameters.

Related Topics

IS-856 Test Operating Mode

MAC Index in IS-856 Test Operating Mode

Forward Traffic Rate in IS-856 Test Operating Mode

Expected Reverse Data Rate in IS-856 Test Operating Mode

AT Directed Packets

Reverse Closed Loop Power Control

Manual Receiver Control in IS-856 Test Operating Mode


How Do I Turn Off a Measurement?

How Do I Turn Off a Measurement?

Last updated: May 24, 2006

  1. Press the Measurement selection key.
  2. Use the knob to highlight the measurement you want to turn off.
  3. Select Close Measurement ( F4 ).
  4. Select Close Menu ( F6 ).

Related Topics

How Do I Make Measurements?


Open Loop Adjust

Open Loop Adjust

Open loop adjust is the nominal power to be used by the access terminal in the open loop power estimate (see Expected Power ).

Open Loop Adjust per Cell Band
Cell Band | Open Loop Adjust (dB)
US Cellular | 78
US PCS | 81
Japan CDMA | 78
Korean PCS | 81
NMT-450 | 78
IMT-2000 | 81
Secondary 800 | 78
US PCS 1900 | 81

Open loop adjust is sent in the Access Parameters message (see TAP/ETAP Data Connection Call Flow ).

Open loop adjust can be changed at any time and will be sent out in the next overhead message.

Related Topics

GPIB Command: CALL[:CELL]:APARameter:POWer:OLADjust <[:SELected]|:IMT2000|:JCDMa|:KPCS|:NMT450|:SECondary800|:USCellular|:USPCs|:USPCs1900>

Manual Operation: How Do I Change Access Parameters?


Operating Mode

Operating Mode

The operating mode specifies the fundamental mode of the base station emulator.

If operating mode is set (even to an existing value) while a session is open, the session is dropped without signalling to the access terminal and the test set returns to Idle State .

Available operating modes include:

  • Active Cell Operating Mode (default mode)
  • IS-856 Test Operating Mode
  • CW Operating Mode

Manual Operation: Set operating mode by selecting Operating Mode ( F1 on the Call Control 1 of 2 menu, Call Setup screen).

Related Topics

GPIB Command: CALL:OPERating:MODE


Paging State

Paging State

In the Paging state, the test set is paging the AT to establish a data connection. Before paging the AT, a session must be open (only the AT can initiate a session open). The test set pages the AT on the Control Channel (CCsynSS, that is Control Channel synchronous sleep state capsule).

When the test set is configured to the TAP or ETAP (see Test Application Configuration ), it pages the AT (by F3 (Start Data Connection ) or CALL:FUNCtion:DATA:STARt command) and directs the AT to send a Connection Request message (see Paging Procedure ).

( only for lab application ) when the Session Application Type is set to Default Packet Application , you can not directly page the AT in a Session Open state. The packet data connection can only be initiated from the AT. Only if the data connection status is in Dormant state, when you ping the AT from the test set or the test set receives an IP datagram from a host on the network addressed to the AT, the test set will page the AT to initiate a data connection (see AN Initiated Packet Data Connection Re-activation from Dormant State ).

The paging state is a transitory state (see TAP/ETAP Data Connection Processing Lifecycle and Packet Data Connection Processing States Lifecycle ).

To query the state of the data connection, see Data Connection State Synchronization .

Related Topics

GPIB Command: CALL:FUNCtion:DATA:STARt

Programming: Step 4: Make a connection

Manual Operation: How Do I Open a Session and Test Data Connection?

TAP/ETAP Data Connection Processing States Lifecycle

TAP/ETAP Data Connection Call Flow

Packet Data Connection Processing States Lifecycle ( Lab Application Only )

Packet Data Connection Call Flow ( Lab Application Only )


Release A Physical Layer Subtype

Release A Physical Layer Subtype

Last updated: June 19, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

  • Description
  • Key Enhancements in Subtype 2 Physical Layer Relative to Subtype 0
  • Operating Considerations

Description

In Active Cell operating mode, the Release A Physical Layer Subtype allows you to select the physical layer subtype protocol when the Protocol Rel is set to protocol release A (1xEV-DO-A) .

The protocol release A (1xEV-DO-A) supports both the new Subtype 2 physical layer and the original Subtype 0 physical layer as supported by the protocol release 0 (1xEV-DO). By default, the Release A Physical Layer Subtype is set to Subtype 2 physical layer for the protocol release A (1xEV-DO-A).

The Subtype 2 physical layer provides more functionality than the Subtype 0 physical layer. For details, see Key Enhancements in Subtype 2 Physical Layer Relative to Subtype 0 .

In Active Cell operating mode, the test set negotiates with the AT on the physical layer subtype during Session Negotiate State . As shown in the table below,

  • when a session is not open, the current physical layer subtype is always PLSub0 (subtype 0 physical layer).
  • when a session is successfully open, the specified physical layer subtype is configured for the session.
  • changing the physical layer subtype results in a session re-negotiation once a session is open.
The current physical layer subtype that the test set is emulating is displayed at the bottom area of the front panel display and can be queried with CALL:STATus:PROTocol:PLAYer? .
Determination of Current Physical Layer Subtype
Protocol Release | Connection State | Current Physical Layer Subtype
A (1xEV-DO-A) | Idle State (session not open) | Subtype 0
 | Session Open or Connected | Depends on the setting of Release A Physical Layer Subtype
0 (1xEV-DO) | Does not matter | Subtype 0

The current physical layer subtype indirectly determines the associated application layer protocols and the MAC Layer protocols being configured in the test set, as shown below.

Current Physical Layer Subtype and Associated Protocols

Protocol Release

0 (1xEV-DO)

A (1xEV-DO-A)

Current Physical Layer Subtype

Subtype 0
(fixed)

Subtype 0

Subtype 2

Associated Physical Layer Protocol

Subtype 0 Physical Layer Protocol

Subtype 2 Physical Layer Protocol
Associated Application Protocol
  • TAP (FTAP/RTAP)
    (when Session Application Type is set to Test Application )
  • DPA ( Lab Application Only )
    (when Session Application Type is set to Default Packet Application )
  • ETAP (FETAP/RETAP)
    (when Session Application Type is set to Test Application )
  • DPA currently is not supported
Associated MAC Layer Protocols

Default Access Channel MAC

  • Default Access Channel MAC (when PL Subtype 2 Access Channel MAC Subtype is set to Default )
  • Enhanced Access Channel MAC
    (when PL Subtype 2 Access Channel MAC Subtype is set to Enhanced )

Default Control Channel MAC

Subtype 1 Reverse Traffic Channel MAC

Subtype 3 Reverse Traffic Channel MAC

Default Forward Traffic Channel MAC

Enhanced Forward Traffic Channel MAC

Key Enhancements in Subtype 2 Physical Layer Relative to Subtype 0

  • Forward Link
  • Reverse Link

Forward Link

The Subtype 2 forward link physical layer has several modifications relative to the Subtype 0 physical layer:

  • Supporting variable and short physical layer packet size for the forward link at a given data rate (DRC value). Moreover, the forward link data rate can be from 4.8 kbps to 3072 kbps (Subtype 0: 38.4 kbps to 2457.6 kbps). See F-Traffic Format for details.
  • Supporting new forward ARQ channels (H-ARQ, L-ARQ and P-ARQ) used to acknowledge each received subpackets on the reverse traffic channel. For details, see Forward Channel Overview .
  • Supporting one-to-one correspondence with the MAC layer packet size and the physical layer packet size (in Subtype 0 physical layer, the MAC packet size is always fixed to 1024 bits and multiple MAC packets are required to fill up the large physical layer packets).
  • More available MAC indices (128 versus 64 in Subtype 0 Physical Layer). See MAC Index for details.

Reverse Link

The Subtype 2 reverse link physical layer is quite different from that of Subtype 0 physical layer:

  • Subtype 2 reverse traffic channel introduces two new channels (Auxiliary Pilot and DSC) in addition to the design changes of the existing subtype 0 channels (R-Pilot, RRI, R-ACK, and R-Data). For details, see Reverse Channel Overview .
  • Subtype 2 reverse data channel supports data rates from 4.8 kbps up to 1843.2 kbps (Subtype 0: 9.6 kbps to 153.6 kbps) and also uses five modulation schemes as opposed to the single scheme (BPSK) used in subtype 0 operation. See R-Data Pkt Size .
  • Subtype 2 reverse access channel supports data rates of 9.6 kbps, 19.2 kbps, and 38.4 kbps (Subtype 0: 9.6 kbps only). See Enhanced Access Rate .

Operating Considerations

  • If a session is open in Active Cell operating mode, changing the Release A Physical Layer Subtype results in a session re-negotiation. If a connection is open, changing the Release A Physical Layer Subtype results in the connection dropped with signaling. You will have to re-open the connection. For details, see Session Negotiate State .
  • The C.S0029-A specifies that the TAP operates with the Subtype 0 physical layer protocol and the ETAP operates with all of the Subtype 0, Subtype 1 and Subtype 2 physical layer protocols. However, the test set does not support Subtype 1 Physical Layer protocol and only supports TAP when current physical layer subtype is Subtype 0 and ETAP when current physical layer subtype is Subtype 2.
  • The test set currently does not support Subtype 2 Physical Layer in IS-856 Test operating mode.
  • ( Lab Application Only ) The test set does not support Default Packet Application protocol when physical layer subtype is Subtype 2 . If Subtype 2 is selected when the Protocol Rel is A (1xEV-DO-A) and Session Application Type is Default Packet Application , the setting will be rejected (revert back to Subtype 0) and an error message is posted to indicate the error condition.

Related Topics

GPIB Command: CALL[:CELL]:PROTocol:PLAYer

Manual Operation:

  • To Configure the Test Set to Subtype 0 Physical Layer
  • To Configure the Test Set to Subtype 2 Physical Layer

PL Subtype 2 Access Channel MAC Subtype

Protocol Rel

Test Application Protocol

Enhanced Test Application Protocol


Pilot Drop

Pilot Drop

Pilot drop is used by the access terminal to start a pilot drop timer for a pilot in the active or candidate set. If a pilot's strength falls below the pilot drop threshold and remains there until the pilot drop timer expires, the following occurs:

  • If the pilot is a member of the active set, the access terminal sends a Route Update message in the connected state.
  • If the pilot is a member of the candidate set, it is moved to the neighbor set.

The pilot drop threshold used by the access terminal is -0.5 dB times the pilot drop value sent by the test set.

Pilot drop is sent in the Configuration Request message (see TAP/ETAP Data Connection Call Flow ).

Pilot drop is a "Configurable Attribute" that is configured during the Session Negotiate State . Its value can not be changed when a session is open and Call Limit Mode is on. If pilot drop is changed when a connection is open, the connection will be closed. You will have to re-open the connection.

Pilot drop must be set to the proper value to avoid dropped connections (see Set "Pilot Drop" to proper value to avoid dropped connections ).

Related Topics

GPIB Command: CALL:MS:PDRop

Manual Operation: How Do I Change Cell Parameters?


PN Offset

PN Offset

PN offset (called Pilot PN in C.S0024) defines a cell. The PN offset indicates the timing of the cell's short codes relative to system time (PN sequence offset in units of 64 PN chips).

PN offset is sent in the Sync message (see TAP/ETAP Data Connection Call Flow ).

PN offset can be changed in the Idle State or Session Open State . PN offset can be changed during transient states that do not have a traffic channel connection present (see TAP/ETAP Data Connection Processing States Lifecycle ). Similar to an implicit handoff, (see Handoff ), the test set changes the PN offset without signalling to the access terminal. If PN offset is changed while a session is open, the session close timeout (see Session Close ) is restarted to allow time for the access terminal to respond to the change.

PN offset can not be changed in the Connected State , or during any transient states that have a traffic channel connection present (such as Session Negotiate State ).

Related Topics

GPIB Command: CALL[:CELL[1]]:PNOFfest

Manual Operation: How Do I Change Generator Information?


Power Control Step

Power Control Step

Power control step (called RPC Step in C.S0024) represents the power control step size the access terminal shall use when controlling the power of its reverse link (by closed loop power control). This setting tells the access terminal how much to increase or decrease its power according to the received power control bit (see Reverse Closed Loop Power Control ).

Power control step is sent in the Configuration Request message (see TAP/ETAP Data Connection Call Flow ).

Power control step is a "Configurable Attribute" that is configured during the Session Negotiate State . Its value can not be changed when a session is open and Call Limit Mode is on. If power control step is changed when a connection is open, the connection will be closed. You will have to re-open the connection.

Related Topics

GPIB Command: CALL[:CELL[1]]:CLPControl:REVerse:PCSTep

Manual Operation: How Do I Change Call Parameters?


Preamble Length

Preamble Length

Preamble length sets the length (in frames) of the access probe preamble.

Preamble length is sent in the Access Parameters message (see TAP/ETAP Data Connection Call Flow ). It can be changed at any time and will be sent out in the next Access Parameters message.

The Preamble Length value is not used (ignored) by the access terminal if the Preamble Length Slots field is sent in the Access Parameters Message. See Fixed Settings for details on when the Preamble Length Slots is sent.

Related Topics

GPIB Command: CALL[:CELL]:APARameter:PREamble:LENGth

Manual Operation: How Do I Change Access Parameters?

Fixed Settings : Preamble Length Slots


Preferred Control Channel Cycle

Preferred Control Channel Cycle

Preferred control channel cycle (PCCC) determines when the access terminal (AT) transitions out of the Sleep State in order to monitor the Control Channel (The AT in sleep state will shut down some processing resources to reduce power consumption).

The Preferred Control Channel Cycle attribute is a "Configurable Attribute" for Idle State Protocol as defined in the C.S0024 standard. It is configured during the session negotiation.

When the session is open, the Preferred Control Channel Cycle being used for the session is displayed on the Access Network Information screen in the Configurable Attribute In Use window and can be queried using the CALL:STATus:CCHannel:PCCCycle:NUMBer? and CALL:STATus:CCHannel:PCCCycle:STATe? .

Preferred Control Channel Cycle Control

The test set supports two session negotiation control mode for the PCCC attribute: AN Specified Control Mode and AT Specified Control Mode .

  • When the Preferred Control Channel Cycle Control is set to AN Specified ,
    • the test set specified PCCC value, if successfully negotiated, will be configured for the session.
    • the PCCC is disabled (off) on the test set by default. This means the PCCC value is determined by applying a hash function (as defined in the C.S0024 standard) that uses the session seed and the number of control channel cycles. Most of the ATs can successfully negotiate to use the hashed default value.
    • if you enable the PCCC setting and want to set on the test set, you must know the PCCC value specific for the AT. The PCCC value varies from AT to AT depending on the IMSI or ESN of the AT. Improper PCCC value will result in a rejection from the AT during session negotiation.
  • When the Preferred Control Channel Cycle Control is set to AT Specified ,
    • the AT-requested PCCC value, if successfully negotiated, will be configured for the session.
    • the test set does not send any Configuration Request message for the PCCC attribute. So changing the PCCC setting on the test set has no effect on the current session. The new setting is simply stored by the test set until the next session negotiation when the negotiation control is set to AN Specified mode.
    • it is useful for some hybrid mode ATs that only function with certain PCCC value and do not allow to use the hashed default value. You do not have to know the PCCC value specific for each AT prior to the proper setting because the AT-requested PCCC value will be configured for the session.

Operating Considerations

See Operating Considerations for details.

Related Topics

Session Negotiate State

Manual Operation:

  • How Do I Change Configurable Attribute Control Mode?
  • How Do I Change Cell Parameters?

GPIB Command:

  • CALL[:CELL]:CONTrol:CATTribute:ISTate:PCCCycle


Printing Screens

Printing Screens

Printing and Saving Screen Images

The test set's local area network (LAN) connection can be used to dump the currently-displayed screen image into a personal computer's web browser. The computer must either be connected to an existing LAN or have a LAN adapter installed that can be connected directly to the test set.

Computer Requirements for LAN Communications with the Test Set

The computer used to capture screen images from the test set must meet the following requirements:

  • 10 Base-T, IEEE 802.3 compliant, ethernet network interface using TCP/IP protocol and configured to run in half-duplex mode.
  • Windows 95, 98, 2000 or NT 4.0 (Windows 95, Windows 98, Windows 2000 and Windows NT 4.0 are U.S. registered trademarks of Microsoft Corporation.)

Test Set to Computer Connections

The test set's LAN connection can be made at either the rear-panel LAN PORT or at the front-panel DATA port. When using the DATA port, be sure to have the factory supplied jumper cable installed between the rear-panel LAN PORT and the ETHERNET TO FRONT PANEL port.

Connections from the test set to the computer must be made using the correct type of LAN cable:

  • If the test set is being connected to the computer through an existing network, use a standard LAN cable.
  • If the test set is being connected directly to the computer's LAN adapter, use a crossover LAN cable (such as the one shipped with the test set or with an older test application upgrade kit).

Capturing the Screen Image

  1. Press the test set's SYSTEM CONFIG key to display the test set's LAN settings, and record the LAN IP Address for use later in this procedure.
  2. Start a web browser application on your computer.
  3. Display the test set screen that you want to capture.
  4. Enter the following address/location into your web browser: http://<lan address>/display.htm
    where <lan address> is the LAN IP address of the test set .
  5. Within a few seconds, the test set's screen image appears in your browser. If the image does not appear on your browser within 30 seconds, refer to Test Your LAN Connections and Configuration by "Pinging" the Test Set below.
  6. To print the image, select File , Print .
  7. To save the file:
    1. Select File , or right-click on the image, and select Save As or Save Picture As .
    2. Enter the desired file name and directory path for saving the image as a GIF file.

The image can now be retrieved from your directory and used as needed.

Test Your LAN Connections and Configuration by "Pinging" the Test Set

Perform this operation only if you were not successful in downloading the test set screen image into your browser.

  1. Display the Command Prompt window on your computer. This is typically done in the Microsoft Windows operating system by selecting Start -> Programs -> Command Prompts .
  2. At the command prompt, enter the following command: ping <lan address>. The <lan address> is the test set's LAN IP address. (The command prompt does not have to be at the root (c:\) level before entering the command.)

    This example shows what should happen when you enter the ping command for a test set with the LAN IP address of 111.22.333.44. The test set should reply back to the Command Prompt screen indicating that data was received.
  3. If the message " Request Timed Out " is displayed instead of a reply from the test set, try entering the command again. If the request times out again, your LAN connections are incorrect and/or your LAN settings for the two devices do not match.

Troubleshooting LAN Connections

If your web browser did not display the test set's screen, or you could not "ping" your test set from your browser, refer to the following information to find the cause and fix the problem.

Try Altering Connections

  • If you are using the test set's front panel DATA port, make sure the jumper between the rear-panel LAN PORT and ETHERNET TO FRONT PANEL port is in place; or try connecting directly to the rear-panel LAN PORT.
  • Try using a different type of LAN cable. If you were using a crossover cable, try using a standard LAN cable; if using a standard LAN cable, try using a crossover cable. If this doesn't fix the problem, be sure to replace the cable with the type recommended in Test Set to Computer Connections above.

Reconfigure the Computer and Test Set LAN Settings

If the test set's image is still not displayed on your web browser, and the ping command still indicates that the test set is not communicating with the computer, you need to verify that the LAN settings for the computer and the test set are compatible. The following sections provide general guidelines in getting the LAN settings configured for both instruments to communicate with each other.

Perform the configuration in the following order:

  1. Configure the computer's LAN settings.
  2. Restart Windows on the computer to start using the new LAN configuration.
  3. Configure the test set's LAN settings to work with the computer's settings. (It is important that the computer be configured and re-started before configuring the test set's LAN settings.)
  4. Turn the test set off and back on to make sure it finds the computer's newly-configured LAN card on power up.

LAN Setting Guidelines

  • It is highly recommended that the Subnet Mask be set to 255.255.248.0 for the test set and the computer when using a direct computer-to-test set connection.
  • The first three groups of numbers for the LAN IP Address of the test set and the computer must match. Example; if the test set's LAN IP Address is set to 130.29.189.33, the computer's LAN IP address must begin with 130.29.189.

    The number in the fourth group of digits in the computer's and test set's LAN IP Addresses must NOT match. Example; if the test set is set to LAN IP Address 130.29.189.33, set the computer's LAN IP Address to 130.29.183.34 (or 130.29.183.77, 130.29.183.42...- just so the last number is not also set to 33). The last entry in the IP Address must not be >254 or 0.

Changing the LAN Setting on Your Computer

Network configuration procedures vary between operating systems. You may have to refer to your computer's help system, or your LAN adapter card's documentation, for assistance.

Perform the following steps to alter the network settings for most PCs using a Microsoft Windows operating system.

Access the Network Settings

  1. Double-click on the My Computer icon on the Windows desk top.
  2. Double-click on the Control Panel icon.
  3. Double-click on the Network icon.
  4. Select the TCP/IP -> [your Ethernet network adapter] entry from the list of components. Note: Do not select TCP/IP Dial-Up Adapter settings if present.
  5. Select Properties to access the TCP/IP settings screen.
Accessing Your Computer's LAN Settings

Set the IP Address and Subnet Mask

  1. Select the IP Address tab on the TCP/IP Properties screen.
  2. Select Specify an IP Address .
  3. Enter the IP Address for the computer. Remember, the last entry in the IP Address must not be >254 or 0.
  4. Enter the Subnet Mask (255.255.248.0).
Specifying the Computer's IP Address and Subnet Mask

Remove Any Gateway Setting

  1. Select the Gateway tab.
  2. If present, remove any existing setting.
  3. Click OK until you have closed the Network settings window.
Accessing the Gateway Setting

Restart Windows

Depending on your LAN network adapter, your computer may or may not apply the network configuration changes as they are made. It is import that you restart Windows NOW to make sure new LAN settings are in effect when you try to connect to the test set.

Changing the LAN Settings on Your Test Set

  1. Press the SYSTEM CONFIG key on the test set to display the current LAN settings.
  2. Press the F1 ( Instrument Setup ) key.

    NOTE
    Changing the LAN IP Address may alter the Subnet Mask setting. Therefore, change the LAN IP Address first, then change the Subnet Mask. Also, The last entry in the IP Address must not be >254 or 0.

  3. Turn the knob to highlight the setting you want to change.
  4. Press the knob to select the setting.
  5. Enter the new value using the keypad, and press the knob to complete the setting.
  6. Turn the test set off and back on to start using the new settings.

Related Topics

Configuring the Test Set's LAN


Probe Initial Adjust

Probe Initial Adjust

Probe Initial Adjust sets the power correction that the access terminal applies to the open loop power estimate to adjust its initial transmission on the Access Channel (when transmitting the initial access probe in an access probe sequence).

When the test set is in the Active Cell operating mode, Probe Initial Adjust is sent in the Access Parameters message (see TAP/ETAP Data Connection Call Flow ). It can be changed at any time and will be sent out in the next Access Parameters message.

When the test set is in the IS-856 Test Operating Mode , Probe Initial Adjust is set to the value that is expected to be used by the access terminal.

Related Topics

GPIB Command: CALL[:CELL]:APARameter:PROBe:IADJust

Manual Operation: How Do I Change Access Parameters?


Probe Num Step

Probe Num Step

Probe num step sets the number of steps (access probes) in a single access probe sequence.

Probe num step is sent in the Access Parameters message (see TAP/ETAP Data Connection Call Flow ).

Probe num step can be changed at any time and will be sent out in the next overhead message.

Related Topics

GPIB Command: CALL[:CELL]:APARameter:PROBe:STEP:COUNt

Manual Operation: How Do I Change Access Parameters?


Probe Power Step

Probe Power Step

Probe power step (called Power Step in C.S0024), sets the increase in power between access probes in an access probe sequence.

Probe power step is sent in the Access Parameters message (see TAP/ETAP Data Connection Call Flow ) as a representation of 0.5 dB increments (0 dB to + 7.5 dB is represented by 0 to 15).

Probe power step can be changed at any time and will be sent out in the next overhead message.

Related Topics

GPIB Command: CALL[:CELL]:APARameter:PROBe:POWer:STEP[:LEVel]

Manual Operation: How Do I Change Access Parameters?


Probe Sequence Max

Probe Sequence Max

Probe sequence max represents the maximum number of probes in a single access attempt.

Probe sequence max is sent in the Configuration Request message (see TAP/ETAP Data Connection Call Flow ).

Probe sequence max is a "Configurable Attribute" that is configured during the Session Negotiate State . Its value can not be changed when a session is open and Call Limit Mode is on. If probe sequence max is changed when a connection is open, the connection will be closed. You will have to re-open the connection.

Related Topics

GPIB Command: CALL[:CELL]:APARameter:PROBe:SEQuence[:MAXimum]

Manual Operation: How Do I Change Access Parameters?


Protocol Rel

Protocol Rel

Last updated: July 20, 2006

The 1xEV-DO air-interface standard (3GPP2 C.S0024) has evolved from release 0 (1xEV-DO) to release A (1xEV-DO-A). The protocol release A (1xEV-DO-A) offers more functionality and improved data rates on both the forward and reverse channels with the new subtype 2 physical layer protocol (see Release A Physical Layer Subtype for details).

Protocol Rel sets the protocol release (3GPP2 C.S0024 standard) that the test set is emulating. While in the Active Cell operating mode, the Protocol Rel was sent to the AT in the Sync Message (as defined by the C.S0024, the value 0x01 is sent for both release 0 and release A) on the control channel at a rate of 1.28 second period.

NOTE
You must purchase a feature license (E1966A-102) from Agilent Technologies to enable this functionality in a licensed test application or order a special free feature license (E6706A-102) from Agilent Technologies to enable this functionality in a licensed lab application. However, having the E1966A-102 or E6706A-102 feature license from Agilent Technologies does not grant you use of the Qualcomm® proprietary Release A functionality. You must obtain consent from Qualcomm® to utilize this feature, as explained in the following statement:

NOTICE
THE DELIVERY OF THE AGILENT PRODUCT DOES NOT CONVEY A LICENSE NOR IMPLY ANY RIGHTS TO USE THE "1xEV-DO REVISION A" CAPABILITY CONTAINED IN THE AGILENT PRODUCT. SUCH USE REQUIRES THE EXPRESS CONSENT OF OR A SEPARATE LICENSE FROM QUALCOMM INCORPORATED. CUSTOMERS AND PRODUCT USERS SHALL BE SOLELY RESPONSIBLE TO OBTAIN SUCH CONSENT OR LICENSE FROM QUALCOMM INCORPORATED IN CONJUNCTION WITH THE USE OF THE "1XEVDO REVISION A" CAPABILITY.

Operating Considerations

  • If a session is open in Active Cell operating mode, changing the protocol release results in a session re-negotiation (see Session Negotiate State ). If a data connection is open, changing the protocol release results in the connection dropped with signaling. You will have to re-open the connection.
  • ( Lab Application Only ) The test set currently does not support Default Packet Application (DPA) for subtype 2 physical layer. If protocol release A (1xEV-DO-A) is selected when Session Application Type is Default Packet Application and Release A Physical Layer Subtype is Subtype 2 (default value), the setting will be rejected (revert back to Release 0) with an error message.
  • The test set currently does not support protocol release A (1xEV-DO-A) in IS-856 Test operating mode. If protocol release A (1xEV-DO-A) is selected when the operating mode is IS-856 Test, the setting will be rejected (revert back to Release 0) with an error message.
  • The test set does not support Subtype 1 Physical Layer protocol and Enhanced Control Channel MAC Protocol as defined in the C.S0024-A standard. See Current Physical Layer Subtype and Associated Protocols .

Related Topics

GPIB Command: CALL[:CELL]:PROTocol[:SELected]

Manual Operation: How Do I Change Call Parameters?

Release A Physical Layer Subtype

PL Subtype 2 Access Channel MAC Subtype

Forward Channel Overview

Reverse Channel Overview


Rate 1M8 Supported Control

Rate 1M8 Supported Control

Last updated: June 16, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

The access terminal may support the transmission of the reverse traffic channel at 1843.2 kbps in subtype 2 physical layer. It negotiates with the test set in the Rate1M8Supported attribute of the Subtype 3 Reverse Traffic Channel MAC Protocol during session negotiation.

The Rate 1M8 Supported Control determines how the Rate1M8Supported attribute is negotiated during Session Negotiate State . When the Protocol Rel is set to A (1xEV-DO-A) and Release A Physical Layer Subtype is set to Subtype 2 , the test set supports two session negotiation control mode for the Rate1M8Supported attribute:

  • When the Rate 1M8 Supported Control is set to AN Specified , the Rate1M8Supported attribute, if successfully negotiated, will use AN-requested value for the session. See AN Specified Control Mode . The AN-requested value for the Rate1M8Supported attribute is fixed to 'Yes' by the test set (see Fixed Settings ).

    Note that if your AT does not support Rate1M8Supported attribute value of 'Yes', session negotiation for this attribute will be rejected by the AT and an error is posted to indicate that the session open is failed. When this happens, you should change the Rate 1M8 Supported Control to AT Specified .

  • When the Rate 1M8 Supported Control is set to AT Specified , the Rate1M8Supported attribute, if successfully negotiated, will use AT-requested value for the session. The test set does not send any Configuration Request message for the Rate1M8Supported attribute. See AT Specified Control Mode . Setting the Rate 1M8 Supported Control to AT Specified is useful for some ATs that does not support Rate1M8Supported attribute value of 'Yes'.

When a session is open with the Protocol Rel set to A (1xEV-DO-A) and Release A Physical Layer Subtype set to Subtype 2 , whether or not the access terminal supports 1843.2 kbps transmission on the reverse traffic channel is indicated on the Rate 1M8 Supported In Use field of the Configurable Attribute In Use window on the Access Network Information screen. When the session is not open, the Rate 1M8 Supported In Use field is set to the protocol default value of the Rate1M8Supported attribute as defined by C.S0024-A standard.

Operating Considerations

See Operating Considerations for details.

Related Topics

Manual Operation: How Do I Change Configurable Attribute Control Mode?

GPIB Command: CALL[:CELL]:CONTrol:CATTribute:RTCMac3:DARTe:KBPS1843[:SUPPort] , CALL:STATus:MS:TRAFfic:DRATe:KBPS1843[:SUPPort]?


Rear Panel Connectors

Rear Panel Connectors

Last Updated: May 24, 2006

Description

BASEBAND I/O

Four pins are functional on this connector:

  • I channel (pin 9)
  • Q channel (pin 26)
  • Ground
  • Ground

CLK IN

Not functional for this release.

COUNTER IN

Not functional for this release.

DATA IN

Not functional for this release.

DATA VALID IN

Not functional for this release.

ETHERNET TO FRONT PANEL

This RJ-45 connector is used with a separate LAN jumper cable to connect the front panel DATA connector to the rear panel LAN PORT.

The the DATA connector on the front panel is connected internally to the ETHERNET TO FRONT PANEL connector on the rear panel. In order to use the front panel DATA connector the user must connect the rear panel LAN PORT, to the rear panel ETHERNET TO FRONT PANEL connector with the LAN jumper cable.

The LAN jumper cable, part number E5515-61160, is supplied with the test set.

EXT INTERFACE CONTROL

Not functional for this release.

EXT SIG GEN/FRAME SYNCH

Not functional for this release.

FM MOD IN

This BNC connector allows you to use an external signal to frequency modulate the test set's RF generator. It has a fixed sensitivity of 20 KHz/volt, and a frequency range of 100Hz to 20 KHz.

GPIB

This GPIB connector allows test set control with compatible devices.

LAN PORT

This RJ-45 connector provides connection for downloading firmware upgrades, or new test applications into the test set. No other types of communication are possible with the LAN port.

PRINTER

Not functional for this release.

SERIAL 1

Not functional for this release.

SERIAL 2

Not functional for this release.

SERIAL 3

Not functional for this release.

TEST SET SYNCH IN

Not functional for this release.

TEST SET SYNCH OUT

Not functional for this release.

TIMEBASE ADJUST

This is the timebase adjust cover. Removing this screw allows access for timebase adjustment.

TRIG IN

This BNC connector provides the capability for you to trigger measurements or instruments from an external source. Setting the Trigger Source setting to External for measurements or instruments which support this feature causes the measurement or instrument to trigger when a positive-going TTL compatible pulse is applied to this connector. Currently, the only measurement or instrument which supports this feature is the Spectrum Monitor.

TRIG OUT

This BNC connector allows you to synchronize the test set to other equipment via a trigger signal.

VGA OUT

This DB-15 connector allows you to simultaneously route the test set's display to another monitor.

10 MHZ REF IN

This BNC connector accepts an external 10 MHz timebase signal. The nominal input impedance is 50 ohm. This version of test set can only accept a 10 MHz timebase signal.

10 MHZ REF OUT

This BNC connector provides a 10 MHz timebase signal to external test equipment. The accuracy of this signal is determined by the timebase used. The nominal output impedance is 50 ohm with a typical level of 0.5 V rms.

Related Topics

Configuring the Test Set's LAN


Remote/Local Mode

Remote/Local Mode

Description

Remote Mode

When the test set is operated remotely, all of the keys on the front panel of the test set are disabled (except the LOCAL key and the power switch). During remote operation the test set is controlled by the Remote User Interface, (RUI).

Any open menus are be closed, and any manual entries are be aborted when the test set transitions from local mode to remote mode.

The remote annunciator (R) will appear in the Instrument Status Area of the test set's display indicating that the test set is in remote mode.

When the test set is in remote mode press the LOCAL key on the front panel in order to gain manual control.

Local Mode

During local mode all front panel keys and the knob are enabled. During local operation the test set is controlled by the Manual User Interface, (MUI).

The remote annunciator (R) is turned off when the test set is operated in local mode.


Reverse Channel Overview

Reverse Channel Overview

The Reverse Channel consists of the Access Channel and the Reverse Traffic Channel according to the state of the data connection. The Access Channel is used by the access terminal to initiate communication with the access network or to respond to an access terminal directed message. The Reverse Traffic Channel is used by the access terminal to transmit user-specific traffic or signaling information to the access network.

Along with the C.S0024 standard evolving from the release 0 to release A, the new Subtype 2 Physical Layer is introduced to support higher data rate transmission. This results in some modifications on both the forward channel and reverse channel structure. For details on the forward channels, see Forward Channel Overview . This section will discuss the key differences of reverse channel structure between subtype 2 physical layer and subtype 0 physical layer.

  • Subtype 0 Reverse Channel Overview
  • Subtype 2 Reverse Channel Overview

Subtype 0 Reverse Channel Overview

The following figure shows the reverse channel structure as defined by subtype 0 physical layer protocol.

The following table summarizes the walsh code, spread factor and duty cycle for each subtype 0 reverse channel. For more description on spreading factor (SF), see Spread Factor Description .

Subtype 0 Reverse Channel Summary
Reverse Channel |  | Walsh Code | Spread Factor | Duty Cycle | Description
R-Pilot | Pilot Channel | I:0 | 16 | Last 7/8 of a slot | Is time-division multiplexed (TDM) with R-RRI channel.
R-RRI | Reverse Rate Indicator | I:0 | 16 | First 1/8 of a slot | Indicates the data rate of the Data Channel being transmitted on the Reverse Traffic Channel (so the access network does not have to perform blind detection). It is time-division multiplexed (TDM) with R-RRI channel
R-DRC | Data Rate Control | Q:8 | 16 | Full slot (but offset by a 1/2 slot) | Indicates the requested Forward Traffic Channel data rate and serving sector.
R-ACK | ACK Channel | I:4 | 8 | First 1/2 of a slot | Informs the access network whether a data packet transmitted on the Forward Traffic Channel was received.
R-Data | Data Channel | Q:2 | 4 | Full slot |

Subtype 2 Reverse Channel Overview

The subtype 2 reverse traffic channel has many changes in the definitions of the R-Pilot, R-RRI, R-ACK, and R-Data channels, and introduces two new reverse channels (R-DSC and R-Aux Pilot). Also, the R-Data channel uses a new timing structure (see Subtype 2 Reverse Link Frame Structure ).

The following figure shows the reverse channel structure as defined by subtype 2 physical layer protocol.

The following table summarizes the walsh code, spread factor and duty cycle (transmission duration) for each subtype 2 reverse channel. For more description on spreading factor (SF), see Spread Factor Description .

Subtype 2 Reverse Channel Summary
Reverse Channel |  | Walsh Code | Spread Factor | Duty Cycle | Description
R-Pilot | Pilot Channel | I:0 | 16 | Full slot |
R-RRI | Reverse Rate Indicator | I:4 | 16 | Full slot | Indicates the payload size and the sub-packet identifier of the physical layer packet transmitted on the Reverse Traffic Channel (so the access network does not have to perform blind detection).
R-DRC | Data Rate Control | Q:8 | 16 | Full slot (but offset by a 1/2 slot) | Indicates the requested Forward Traffic Channel data rate and serving sector. The serving sector is the sector that the access terminal selects for receiving the Forward Traffic Channel.
R-ACK | ACK Channel | I:12 | 32 | First half of a slot (time-division multiplexed with R-DSC) | Informs the access network whether a data packet transmitted on the Forward Traffic Channel was received.
R-DSC | Data Source Control | I:12 | 32 | Second half of a slot (time-division multiplexed with R-ACK) | Indicates the desired forward link serving cell which minimizes service interruption due to server switching on the forward link.
R-Data | Data Channel | Depending on modulation type as shown in the following table. |  |  |
R-Aux Pilot | Auxiliary Pilot Channel | I:28 | 32 | Full slot | Is transmitted only if R-Data payload size is equal to or greater that the specified minimum payload threshold. Aids AN for reverse link channel estimation when operating at high data rates. It is used instead of adding power to the R-Pilot so that other reverse link channels will not scale their power as the power energy increases.
Subtype 2 R-Data Channel Code Channel
R-Data Modulation Type | Modulation Name | Walsh Code | Spreading Factor | Duration
B4 | BPSK | Q:2 | 4 | Full slot
Q4 | QPSK | Q:2 | 4 | Full slot
 |  | I:2 | 4 | Full slot
Q2 | QPSK | Q:1 | 2 | Full slot
 |  | I:1 | 2 | Full slot
Q4Q2 | QPSK | Q:2 | 4 | Full slot
 |  | I:2 | 4 | Full slot
 |  | Q:1 | 2 | Full slot
 |  | I:1 | 2 | Full slot
E4E2 | 8-PSK | Q:2 | 4 | Full slot
 |  | I:2 | 4 | Full slot
 |  | Q:1 | 2 | Full slot
 |  | I:1 | 2 | Full slot

Subtype 2 Reverse Link Frame Structure

In subtype 2 operation, the R-Data channel uses a new timing structure. The frame and slot timing is the same as subtype 0 (each 26.67 ms frame consists of 16, 1.667 ms slots), but the concept of the subframe is introduced. Each subframe consists of four contiguous slots (6.667ms). Also new is the concept of a subpacket. A subpacket is defined to be the smallest unit of a reverse traffic channel transmission that can be acknowledged at the physical layer by the access network. A subpacket is transmitted over four contiguous slots, thus a subpacket is transmitted in one subframe.

Each physical layer packet can be transmitted in up to a maximum of four sub-packets. When more than one sub-packet is transmitted, the transmitted sub-packets use a three sub-frame interlacing. That is, the transmitted sub-packets of a physical layer packet is separated by two intervening sub-frames, and sub-packets of other physical layer packets may be transmitted in the sub-frames between those transmitted sub-packets.

The following figure shows how the four sub-packets from a single physical layer packet (a 4096 bit physical layer packer was used) can be transmitted on the R-Data channel. Note that not all of the sub-packets will be sent if the AN acknowledges the packet as received before all sub-packets have been transmitted (early termination).

Spread Factor Description

Spread Factor (SF) is a term which indicates which Walsh code set the Walsh code belongs to. For example, Walsh code 00000000 belongs to Walsh code set 8, and thus is said to have a spread factor of 8. The spread factor also indicates the length of the Walsh code (spread factor 8 indicates the Walsh code is 8 digits in length).

The diagram below shows an example of the Walsh code distribution of the subtype 0 reverse channels:

Subtype 0 Reverse Channel Walsh Code Distribution

Related Topics

Forward Channel Overview


Reverse Closed Loop Power Control

Reverse Closed Loop Power Control

The reverse closed loop power control parameter determines what bits are sent to the access terminal for closed loop power control.

Reverse closed loop power control
Setting | Description
Active Bits *

The test set actively determines if the access terminal is transmitting at a power level that is too high or too low (based on the expected R-Pilot level, see Expected Power ), and responds by sending the appropriate up or down power control bit.
Alternating Bits

The test set sends alternating "0" (up) and "1" (down) power control bits to the access terminal regardless of its output power.
All Up Bits
The test set sends all "0" (up) power control bits to the access terminal regardless of its output power.
All Down Bits | The test set sends all "1" (down) power control bits to the access terminal regardless of its output power.

* In addition to the Active Bits that is only available in Active Cell Operating Mode , all other settings are available in both Active Cell Operating Mode and IS-856 Test Operating Mode .

Operating Considerations

  • In Active Cell Operating Mode , in order for the test set to successfully decode signalling from the AT, the signal level into the test set's RF IN/OUT connector must be within 9 dB of the expected input power (see Expected Power ). When Reverse Closed Loop Power Control is set to All Up Bits or All Down Bits, the AT's power will not be within the required range, and all signalling will fail. Before attempting any signalling between the test set and AT, you must either set Reverse Closed Loop Power to Active Bits, or manually range the Receiver Power to the level that the AT is currently transmitting based on the Reverse Closed Loop Power Control setting (see Manual receiver power ).
  • In IS-856 Test Operating Mode , if the access terminal is responding to power control bits, and with alternating bits selected in the Rvs Power Ctrl field, cell power level changes will control the access terminal's power level according to open loop power control behavior.

Related Topics

GPIB Command: CALL[:CELL[1]]:CLPControl:REVerse:MODE<[:SELected]|:TA856>

Manual Operation: How Do I Change Call Parameters?


Reverse Data Transmission Mode

Reverse Data Transmission Mode

This section is only applicable to the lab application and to a test application with the required feature license.

The Subtype 3 Reverse Traffic Channel MAC Protocol defines two transmission modes, High Capacity and Low Latency. The Reverse Data Transmission Mode determines which transmission mode is configured for the active MAC flow for the R-Data channel.

When the test set is in Active Cell operating mode and the RETAP is being configured for the subtype 2 physical layer, the test set controls the R-Data transmission mode by sending the RETAP Parameter Assignment Message to the AT with the associated LinkFlowID field of the BurstPeriodMode and BurstSizeMode attributes set to the specified Reverse Data Transmission Mode (see FETAP/RETAP Parameter Assignment Messages Versus ETAP Setting for details). The specified transmission mode is displayed on the Call Setup screen in the Application Configuration window.

The transmission mode being configured for the R-Data channel determines the current TxT2P gain (see TxT2P Gain Settings ).

Note that when the test set is in Active Cell operating mode with FETAP being configured for the physical layer subtype 2, the High Capacity transmission mode is assumed to be used by the AT. For signaling, High Capacity mode for MAC flow 00 is always used.

Related Topics

GPIB Command: CALL[:CELL]:APPLication:DATA[:REVerse]:TRANsmission[:MODE]

Manual Operation: How Do I Change Call Parameters? (Application Configuration menu)


Power Parameters Info

Power Parameters Info

Last updated: June 16, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

The Power Parameters Info menu allows you to specify a set of T2P (Traffic To Pilot) parameters for each reverse data packet size and transmission mode. When the current physical layer subtype is subtype 2 (see Release A Physical Layer Subtype ), the T2P parameters used with other settings (such as R-Data transmission mode, R-Data packet size) to determine the current TxT2P gain (R-Data Channel gain relative to R-Pilot Channel) and current RRI Channel gain for the subpacket being transmitted.

The T2P parameters are negotiated with the AT during Session Negotiate State . They are configured via one of several complex configurable attributes of the Subtype 3 Reverse Traffic Channel MAC Protocol. When a session is open, changing these settings will result in a session re-negotiation. When a connection is open, changing these settings will result in the connection closed. You will have to re-open the connection. To determine when the Subtype 3 Reverse Traffic Channel MAC Protocol is active, see Current Physical Layer Subtype and Associated Protocols . Each complex configurable attribute is called PowerParameters PS attribute, where PS represents each supported data packet size. The complex attributes group all of the T2P parameters for a given data packet size together.

With the T2P Setup Ctrl setting (only used for front panel operation), you can specify a reverse data packet size that a set of T2P parameters are to be set for. (Note that changing the R-Data Pkt Size in RETAP configuration will also result in the T2P Setup Ctrl setting changed to the same value.) The T2P parameters for each reverse data packet size and transmission mode can be classified into three categories:

  • T2P Transition Settings
  • Termination Target Settings
  • TxT2P Gain Settings

T2P Transition Settings

The T2P Transition settings determine which TxT2P gain and RRI Channel Gain parameters are used for a subpacket transmitted at a given configuration (packet size and transmission mode). The T2P Transition values are set to one less than the number of subpackets that will use the Pre-Transition gain value. Subpackets after the T2P Transition value will use the Post-Transition gain value. See Determination of TxT2P Pre-Transition and Post-Transition Gain and RRI Channel Gain Parameters for details.

The T2P Transition values can be uniquely set for each data packet size and transmission mode. The <n-bit> <mode> T2P Transition settings corresponds to the Mode T2PTransition PS attribute as defined in the C.S0024-A standard, where Mode represents high capacity and low latency transmission modes and PS represents Packet Size (which can be 128, 256, 512, 768, 1024, 1536, 2048, 3072, 4096, 6144, 8192 or 12288 bits).

The current T2P Transition value indicates the T2P Transition value for the current configuration of data packet size and transmission mode. The current data packet size is determined by R-Data Pkt Size and the current transmission mode is determined by Reverse Data Transmission Mode .

The current T2P Transition value is used to control the current R-Data Channel Gain (TxT2P) and current RRI Channel Gain. See Determination of TxT2P Pre-Transition and Post-Transition Gain and RRI Channel Gain Parameters .

Termination Target Settings

The Termination Target settings are used to determine the target number of subpackets required to successfully transmit a physical traffic packet at a given configuration (packet size and transmission mode). The Termination Target values are set to one less than the number of subpackets needed to achieve the target Physical Layer erasure rate of the traffic packet in that configuration.

The Termination Target values can be uniquely set for each data packet size and transmission mode. The <n-bit> <mode> Termination Target setting corresponds to Mode TerminationTarget PS attribute as defined in the C.S0024-A standard, where Mode represents high capacity and low latency transmission modes and PS represents Packet Size (which can be 128, 256, 512, 768, 1024, 1536, 2048, 3072, 4096, 6144, 8192 or 12288 bits).

The current Termination Target value indicates the Termination Target value for the current configuration of data packet size and transmission mode. The current data packet size is determined by R-Data Pkt Size and the current transmission mode is determined by Reverse Data Transmission Mode .

The current Termination Target value does not directly affect the R-Data Channel Gain (TxT2P) and R-RRI Channel Gain.

TxT2P Gain Settings

The TxT2P gain settings determine the R-Data Channel gain relative to the R-Pilot Channel for each data packet size and transmission mode. Whether the TxT2P Pre-Transition or Post-Transition gain is used for a particular subpacket at the given configuration depends on the current T2P Transition Settings value, as shown below.

Determination of TxT2P Pre-Transition and Post-Transition Gain
Current T2P Transition Value | <n-bit><mode>TxT2P Pre-Transition and Post-Transition Gain (dB)
 | Subpacket 0 | Subpacket 1 | Subpacket 2 | Subpacket 3
0 | TxT2P Pre-Transition | TxT2P Post-Transition | TxT2P Post-Transition | TxT2P Post-Transition
1 | TxT2P Pre-Transition | TxT2P Pre-Transition | TxT2P Post-Transition | TxT2P Post-Transition
2 | TxT2P Pre-Transition | TxT2P Pre-Transition | TxT2P Pre-Transition | TxT2P Post-Transition
3 | TxT2P Pre-Transition | TxT2P Pre-Transition | TxT2P Pre-Transition | TxT2P Pre-Transition

The <n-bit> <mode> TxT2P Pre-Transition and Post-Transition settings corresponds to TxT2P Mode PreTransition PS and TxT2P Mode PostTransition PS attribute as defined in the C.S0024-A standard, where Mode represents high capacity and low latency transmission modes and PS represents Packet Size (which can be 128, 256, 512, 768, 1024, 1536, 2048, 3072, 4096, 6144, 8192 or 12288 bits).

Current TxT2P Pre-Transition and Post-Transition gain values indicate the TxT2P gain used for the current configuration of data packet size and transmission mode. The current data packet size is determined by R-Data Pkt Size and the current transmission mode is determined by Reverse Data Transmission Mode .

The power level of the R-Data channel is determined by the current TxT2P gain values (see Expected Power ).

Power Parameters Screen

All of the T2P parameters for each data packet size and transmission mode are displayed on the Power Parameters screen. Which set of T2P parameters being applied in the test set (current values) is identified by a '>' indicator as shown below.

Power Parameters Screen

Related Topics

GPIB Command: CALL:MS:T2Pilot commands (see CALL:MS )

Manual Operation: How Do I Change Channel Gain/Traffic Info Parameters? (Power Parameters Info menu)

Expected Power


R-Data Pkt Size

R-Data Pkt Size

Last updated: June 16, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

R-Data Pkt Size is used to set the reverse traffic packet size (as well as the data rate and modulation) when the following conditions are met:

  • the test set is in Active Cell operating mode with an RETAP data connection established for physical layer subtype 2. It is sent to the AT in the RETAP Parameter Assignment Message with the Packet Payload Size Mode attribute set to the associated data packet size (see Enhanced Test Application Protocol ).

The following table shows the associated data rate and modulation for each packet size.

R-Data Packet Size, Modulation and Effective Data Rate (for Subtype 2 Physical Layer)
Payload Size Index | R-Data Packet Size (bits) | Modulation Format | Effective Data Rate (kbps)
 |  |  | After 1 subpacket (4 slots) | After 2 subpackets (8 slots) | After 3 Subpackets (12 slots) | After 4 subpackets (16 slots)
1 | 128 | B4 | 19.2 | 9.6 | 6.4 | 4.8
2 | 256 | B4 | 38.4 | 19.2 | 12.8 | 9.6
3 | 512 | B4 | 76.8 | 38.4 | 25.6 | 19.2
4 | 768 | B4 | 115.2 | 57.6 | 38.4 | 28.8
5 | 1024 | B4 | 153.6 | 76.8 | 51.2 | 38.4
6 | 1536 | Q4 | 230.4 | 115.2 | 76.8 | 57.6
7 | 2048 | Q4 | 307.2 | 153.6 | 102.4 | 76.8
8 | 3072 | Q2 | 460.8 | 230.4 | 153.6 | 115.2
9 | 4096 | Q2 | 614.4 | 307.2 | 204.8 | 153.6
10 | 6144 | Q4Q2 | 921.6 | 460.8 | 307.2 | 230.4
11 | 8192 | Q4Q2 | 1228.8 | 614.4 | 409.6 | 307.2
12 | 12288 | E4E2 | 1843.2 | 921.6 | 614.4 | 460.8

  • In Subtype 2 physical layer operation, each reverse physical layer packet can be transmitted in up to four subpackets (see Background Information (Subpacket) ). The effective data rate depends on how many subpackets are transmitted for each physical layer packet. The ACK/NAK sent on the forward ARQ channel determines how many subpackets are sent for each reverse physical layer packet. For details on when the test set sends an ACK on the forward ARQ channels, see ACK R-Data After .

    When a single data rate for the reverse traffic channel is referenced, it usually refers to the effective data rate after 1 subpacket.

  • The name of the modulation is derived from the modulation type and the Walsh code length (as shown in the following table).

    • B4: indicating BPSK modulation with 4 bit walsh code for spreading, applied to Q channel.
    • Q4: indicating QPSK modulation with 4 bit walsh code for spreading, applied to both I and Q channels.
    • Q2: indicating QPSK modulation with 2 bit walsh code for spreading, applied to both I and Q channels.
    • Q4Q2: indicating QPSK modulation with both a 4 bit and a 2 bit walsh code for spreading, applied to both I and Q channels.
    • E4E2: indicating 8-PSK modulation with both a 4 bit and a 2 bit walsh code for spreading, applied to both I and Q channels.
      Subtype 2 R-Data Modulation Type vs. Walsh Code

      R-Data Packet Size (bits)

      R-Data Modulation Type

      Modulation Name

      Spreading Factor

      Walsh Code

      Duty Cycle

      128, 256, 512, 768 or 1024

      B4

      BPSK

      4

      Q:2

      Full slot

      1536 or 2048

      Q4

      QPSK

      4

      Q:2

      Full slot

      4

      I:2

      Full slot

      3072 or 4096

      Q2

      QPSK

      2

      Q:1

      Full slot

      2

      I:1

      Full slot

      6144 or 8192

      Q4Q2

               QPSK

      4

      Q:2

      Full slot

      4

      I:2

      Full slot

      2

      Q:1

      Full slot

      2

      I:1

      Full slot

      12288

      E4E2

      8-PSK

      4

      Q:2

      Full slot

      4

      I:2

      Full slot

      2

      Q:1

      Full slot

      2

      I:1

      Full slot

  • The AT may support transmission of the reverse traffic channel at 1843.2 kbps (12288 bit packet size) according to the Rate1M8Supported attribute (1 = support, 0 = not support). See Rate 1M8 Supported Control .

R-Data Pkt Size can be changed at any time. If a connection is open, it will be maintained.

Background Information (Subpacket)

In Subtype 2 physical layer operation, the R-Data channel uses a new timing structure. The frame and slot timing is the same as Subtype 0 physical layer (each 26.67 ms frame consists of 16, 1.667 ms slots), but the concepts of the sub-frame is introduced. Each Sub-frame consists of four contiguous slots (6.667 ms). Also new is the concept of a subpacket. A subpacket is defined to be the smallest unit of a R-TCH transmission that can be acknowledged at the physical layer by the AN. A subpacket is transmitted over four contiguous slots, thus a subpacket is transmitted in one sub-frame. Each physical layer packet can be transmitted in up to four subpackets. When more than one subpackets are required to successfully transmit the physical layer packet, the transmitted subpackets use a three sub-frame interlace pattern. This means that following the transmission of a subpacket, another subpacket belonging to the same physical layer packet cannot be transmitted until the third sub-frame after the previous subpacket is transmitted. The Subtype 2 R-Data channel also uses five modulation schemes as opposed to the single scheme used in Subtype 0 operation.

Related Topics

GPIB Command: CALL[:CELL]:APPLication:DATA[:REVerse]:PACKet[:SIZE]

Manual Operation: How Do I Change Call Parameters?


RRI Gain Parameters

RRI Gain Parameters

Last updated: June 16, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

The RRI Channel Gain parameters include seven settings: RRIChannelGainPreTransition0, RRIChannelGainPostTransition0, RRIChannelGainPreTransition1, RRIChannelGainPostTransition1, RRIChannelGainPreTransition2, RRIChannelGainPostTransition2, and RRIChannelGainPreTransition3. When the current physical layer subtype is subtype 2 (see Release A Physical Layer Subtype ), these parameters used with the current T2P Transition value (see T2P Transition Settings ) and current subpacket being transmitted determine the current R-RRI Channel gain (relative to R-Pilot channel).

The table below shows when the different RRI Channel Gain parameters are used to set the gain of the RRI Channel. The RRIChannelGainPreTransition X indicates the ratio of the power level of the R-RRI Channel relative to the power level of the R-Pilot Channel for those subpackets transmitted prior to the T2P Transition when T2P Transition value is X subpacket(s). For details on the T2P Transition, see T2P Transition Settings .

RRI Channel Gain Parameters
T2P Transition Value | RRI Channel Gain Parameters Used for Subpacket X Transmission
 | Subpacket 0 | Subpacket 1 | Subpacket 2 | Subpacket 3
0 | RRIChannelGainPreTransition0 | RRIChannelGainPostTransition0 | RRIChannelGainPostTransition0 | RRIChannelGainPostTransition0
1 | RRIChannelGainPreTransition1 | RRIChannelGainPreTransition1 | RRIChannelGainPostTransition1 | RRIChannelGainPostTransition1
2 | RRIChannelGainPreTransition2 | RRIChannelGainPreTransition2 | RRIChannelGainPreTransition2 | RRIChannelGainPostTransition2
3 | RRIChannelGainPreTransition3 | RRIChannelGainPreTransition3 | RRIChannelGainPreTransition3 | RRIChannelGainPreTransition3

The RRI Channel Gain parameters are "Configurable Attributes" for the Subtype 3 Reverse Traffic Channel MAC Protocol. They are negotiated with the AT in the RRIChannelPowerParameters attribute during Session Negotiate State . When a session is open, changing these settings will result in a session re-negotiation. When a connection is open, changing these settings will result in the connection closed. You will have to re-open the connection. To determine when the Subtype 3 Reverse Traffic Channel MAC Protocol is active, see Current Physical Layer Subtype and Associated Protocols .

The power level of the R-RRI channel is determined by the current R-RRI Channel gain (see Expected Power ).

Related Topics

GPIB Command: "CALL:MS:RRIGain commands (see CALL:MS )

Manual Operation: How Do I Change Channel Gain/Traffic Info Parameters? (RRI Gain Parameters menu)


RTAP Rate

RTAP Rate

Last updated: June 16, 2006

RTAP Rate determines the rate at which reverse traffic test packets are sent by the access terminal (AT) when an RTAP connection for subtype 0 physical layer is established in Active Cell operating mode. It is included in the Packet Rate Mode attribute in the RTAP Parameter Assignment Message sent to the AT. For details, see Test Application Protocol .

RTAP Data Rate (for Subtype 0 Physical Layer)
Rate Index | RTAP Data Rate (kbps) | RTAP Data Packet Size (bits) | Modulation Format
1 | 9.6 | 256 | BPSK
2 | 19.2 | 512 | BPSK
3 | 38.4 | 1024 | BPSK
4 | 76.8 | 2048 | BPSK
5 | 153.6 | 4096 | BPSK

When an RTAP connection is first established, the access terminal starts transmitting at 9.6 kbps and then increases its data rate to the RTAP Rate.

The transition probabilities used by the AT when changing data rates are determined by the Transition Probability .

When Limited TAP is on and Test Application Protocol is set to FTAP, RTAP Rate is also used to set the Rate Limit field of the Unicast Reverse Rate Limit message. The Unicast Reverse Rate Limit message is used by the test set to control the transmission rate on the reverse link for a particular access terminal. The Rate Limit field indicates the highest data rate that the access terminal is allowed to use on the Reverse Traffic Channel.

RTAP Rate can be changed at any time. If a connection is open, it will be maintained.

Operating Considerations

The RTAP Rate setting is only applicable to the RTAP connection for subtype 0 physical layer in Active Cell operating mode. To set the reverse traffic rate for an RETAP connection for subtype 2 physical layer, see R-Data Pkt Size .

Related Topics

GPIB Command: CALL[:CELL]:APPLication:RTAProtocol:DRATe

Manual Operation: How Do I Change Call Parameters?

Test Application Protocol

Release A Physical Layer Subtype

FTAP Rate

Expected Reverse Data Rate in IS-856 Test Operating Mode


Save and Recall Registers

Save and Recall Registers

Description

The test set provides up to five save/recall registers . Each register is identified by a number (1-5).

This section details the following:

  • Recalling Saved Registers
  • Deleting Saved Registers
  • Settings that are Saved
  • Settings that are not Saved
  • Saving Current Settings to a Register

Recalling Saved Registers

Press the Register recall hardkey.

Use the knob to scroll to a register that is labeled Full and press the knob.

When a register is recalled, the test set will clear all active measurements and display the Call Setup Screen. Registers can only be recalled in the format they were saved in. For example, in a fast switching application, a register that is saved in a specific format must also be recalled in that same format. If a register is attempted to be recalled in a format other than the one it was saved in, the following error will occur:

CAUTION
If the test set has had hardware options installed since the last time a registers were saved, delete the registers and re-save them. Failure to perform this step could result in a non-recoverable firmware "assert" when performing a register recall.

Deleting Saved Registers

Pressing the DELETE hardkey will display a menu indicating which registers have been saved (they are labeled "Full").

Use the knob to scroll to a register and press the knob. Select Yes to confirm the selection.

Settings that are Saved

All functions and parameters that have an associated static state or settable value will be saved. For example:

  • Cell parameters (System ID, Network ID, etc.)
  • Call control parameters (System Type, Operating Mode, etc.)
  • Measurement setup parameters (Trigger Arm state, Measurement Timeout, etc.)
  • Call Parms (Cell Power, Cell Band, etc.)

Settings that are not Saved

Functions that trigger immediate actions, such as originating a call or calibrating a measurement are not saved.

Settings saved in non-volatile memory (settings that are unchanged when power is cycled or the test set is preset) are not saved. For example:

  • LAN IP Address
  • Date/Time
  • RF IN/OUT Amplitude Offset
  • All other settings on the Instrument Setup menu on the System Config screen.
  • Measurement results
  • Call status
  • Active measurements

Read-only call processing results such as Mobile Station Information tables are not saved.

Saving Current Settings to a Register

To save the current state of the test set, press the SAVE hardkey.

A menu will be displayed that shows the status of all five registers. If the register status is "Full", the register has had instrument settings saved to it. If the register status is "Empty", it does not currently contain any instrument settings.

Use the knob to scroll to a register and press the knob. If the selected register is currently Full, select Yes in the Overwrite Save Reg? window and it will be overwritten.

CAUTION
When a test set application is upgraded using the 8960 File Utility Program, the new revision of the application will not automatically retain save/recall registers from the old revision. Prior to the application upgrade, it is recommended that you record the critical settings (such as call setup information) from registers that you will want to re-save after the test application upgrade.

Related Topics

SYSTem:REGister


Sector ID

Sector ID

The sector ID provides the 128 bit (32 hex character) address of the test set's sector.

Sector ID is sent in the Sector Parameters message and Quick Config message (see TAP/ETAP Data Connection Call Flow ).

Sector ID can be changed at any time.

Related Topics

GPIB Command: CALL[:CELL]:PARameter:SECTor:IDENtifier

Manual Operation: How Do I Change Cell Parameters?


Session Closing State

Session Closing State

The access terminal (AT) may close the session to conserve battery power, or because the user has turned it off. The network may order the AT to close the session (to free up its assigned UATI) if there is no activity for an extended time (see Session Close ).

In the session closing state, the test set is in the process of closing the current session.

Close the session by sending the CALL:SCLose command, or by selecting Close Session . This will close the data connection and the session at one time. See also Close Session Before Testing New AT .

You can close the session at any time, and the data connection will be taken to the idle state. However, most ATs will try to immediately re-establish a session (see Session Negotiate State ). You can prevent the AT from re-establishing a session by turning Call Limit Mode on (see Other Considerations for details).

The session closing state is a transitory state (see TAP/ETAP Data Connection Processing Lifecycle and Packet Data Connection Processing States Lifecycle ).

To query the state of the data connection, see Data Connection State Synchronization .

Related Topics

GPIB Command: CALL:SCLose

Programming: Step 7: End the Connection

Manual Operation: How Do I Close the Session?

TAP/ETAP Data Connection Processing States Lifecycle

TAP/ETAP Data Connection Call Flow

Packet Data Connection Processing States Lifecycle ( Lab Application Only )

Packet Data Connection Call Flow ( Lab Application Only )


Session Negotiate State

Session Negotiate State

Last updated: June 16, 2006

In the session negotiate state, the test set and the access terminal (AT) negotiate the protocols and the Configurable Attributes that are used for the session (the configurable attributes are sometimes called session settings). The test set also requests the AT's hardware ID (see Hardware ID and Hardware ID Type ) by sending a Hardware ID Request message during this state. For the messaging flow, see Session Negotiation Procedure .

Session negotiations are performed on a traffic channel connection. If a traffic channel connection is not present when the session is negotiated or re-negotiated, a temporary traffic channel connection is established (this temporary connection is closed after the session negotiation is complete).

The session negotiate state is a transitory state (see TAP/ETAP Data Connection Processing Lifecycle and Packet Data Connection Processing States Lifecycle ).

To query the state of the data connection, see Data Connection State Synchronization .

Configurable Attributes

During session negotiation, there are two distinct procedures: AT initiated negotiations (always first) and AN initiated negotiations. The test set uses AN Specified Control Mode and AT Specified Control Mode to control the exact negotiation procedure for each configurable attribute.

The table below summarizes the settable configurable attributes and the associated negotiation control modes that are supported by the test set.

  • By default, most of the configurable attributes are fixed to use the AN Specified control mode.
  • Preferred Control Channel Cycle and Rate 1M8 Supported Control are the configurable attributes that have a choice of negotiation control mode.
Configurable Attributes and Negotiation Control Mode
Configurable Attributes | Negotiation Control Mode Used
Auxiliary Pilot Channel Min Payload , Auxiliary Pilot Channel Gain , Data Offset 9k6|19k2|38k4|76k8|153k6 , Data Offset Nom , DSC Length , H-ARQ Modulation , Release A Physical Layer Subtype , Release A Access Channel MAC Subtype , Pilot Drop , Power Control Step , Power Parameters Info , Probe Sequence Max , RRI Gain Parameters , Session Close , Session Application Type ( Lab Application only ), Short Packet Enabled Threshold | Only support AN Specified Control Mode .
Preferred Control Channel Cycle and Rate 1M8 Supported Control | Support selection of AN Specified Control Mode and AT Specified Control Mode

AN Specified Control Mode

The AN Specified negotiation control mode indicates that the configurable attribute, if successfully negotiated, will use the test set's specified value for the session. If the test set is unable to negotiate the expected value, an error is posted with signaling and the test set returns to the idle state.

AT Specified Control Mode

The AT Specified negotiation control mode indicates that the configurable attribute, if successfully negotiated, will use AT-requested value for the session. The test set does not send any Configuration Request message for that configurable attribute. If the test set does not support the value requested by the AT for that configurable attribute, an error is posted with signaling and the test set returns to the idle state.

Operating Considerations

The behavior and restrictions for changing a configurable attribute setting depend on the session negotiation control mode.

Changing the Configurable Attribute Associated with AN Specified Control Mode

  • When a session is open, changing the configurable attribute setting will result in a session re-negotiation.
  • When a data connection is established, changing the configurable attribute setting will result in a session re-negotiation. Once the session negotiation is complete, the data connection will be closed. You must re-open the data connection.
  • If the configurable attribute setting is changed in idle state (no open session), it is stored and negotiated when the next session (when configured to use the AN Specified control mode) is established.
  • You can not change the configurable attribute setting when a session is open and Call Limit Mode is on (because the test set would not be able to establish a traffic connection to re-negotiate the value when call limit mode is on).

Changing the Configurable Attribute Associated with AT Specified Control Mode

For a configurable attribute setting that uses the AT Specified control mode, once a session is established, changing the value on the test set has no effect on the current session. Any setting change associated with that configurable attribute is simply stored and negotiated when the next session (when configured to use the AN Specified control mode) is established.

Changing the Negotiation Control Mode for a Configurable Attribute

The Preferred Control Channel Cycle is the only configurable attribute that supports the selection of the session negotiation control mode. Changing its session negotiation control mode has the same restrictions as Changing the Configurable Attribute Associated with AN Specified Control Mode .

Related Topics

TAP/ETAP Data Connection Processing States Lifecycle

TAP/ETAP Data Connection Call Flow

Packet Data Connection Processing States Lifecycle ( Lab Application Only )

Packet Data Connection Call Flow ( Lab Application Only )

Data Connection State Synchronization

Troubleshooting Data Connection Processing

Session Configuration Response Timeout: Fixed Settings


Session Open State

Session Open State

In the session open state, the access terminal (AT) has an assigned UATI, but is not assigned any dedicated air-link resources. Communications between the AT and test set occur on the Access Channel and Control Channel. During a single session the AT and test set can open and close a connection several times.

The session open state is a non-transitory state (see TAP/ETAP Data Connection Processing Lifecycle and Packet Data Connection Processing States Lifecycle ).

To query the state of the data connection, see Data Connection State Synchronization .

Operating Considerations

  • It is recommended not to execute a preset/reset (full or partial) when a session is open with an AT. This is because executing a preset/reset (full or partial) will take the test set to Idle state without signaling to the AT and may cause the test set and AT in a mismatched state. In this case, some ATs can not open a new session with the test set.
  • In the lab application , when the test set is configured to use the Default Packet Application (see Session Application Type ), the session open state indicates neither the dedicated air-link connection nor the PPP connection is open between the AT and the test set.

Related Topics

TAP/ETAP Data Connection Processing States Lifecycle

TAP/ETAP Data Connection Call Flow

Packet Data Connection Processing States Lifecycle ( Lab Application Only )

Packet Data Connection Call Flow ( Lab Application Only )


Session Seed

Session Seed

The session seed is a 32 bit (8 hex character) number which the access network uses to address the access terminal until the access terminal is assigned a UATI.

During the UATI Request State , the access terminal determines the session seed (using a pre-defined random number generator, seeded with a number based on the access terminal's hardware ID) and sends it to the access network in the UATI Request message (see TAP/ETAP Data Connection Call Flow ). The AT uses the Session Seed as the Random ATI that is its Transmit ATI, to identify itself to the AN during its UATI Request.

Session seed can be queried at any time, but a value will only be returned if a session is open (see Session Open State ). Session Seed is displayed on the Call Setup screen in the Access Terminal Information (AT Reported) window.

Related Topics

GPIB Command: CALL:MS:REPorted:SSEed?


Session Close

Session Close

Session Close (corresponding to T SMPClose in the C.S0024 standard) specifies the time period for which the test set has not heard from the AT before sending a SessionClose message to the AT.

The test set and AT use the keep-alive mechanism to verify that peer is still alive. Once a session is open (see Session Open State ), the session close timeout timer is started. If the test set has not heard from the AT for at least 1/3 of Session Close timeout period, it sends a KeepAliveRequest message to the AT. When the test set receives a KeepAliveResponse message from the AT, the test set resets the session close timeout timer and repeats the above process. If the test set does not receive a KeepAliveResponse message (or other messages from the AT) for at least 1/3 of Session Close timeout period, it sends a KeepAliveRequest message to the AT again. If the test set does not receive any response by the time the session close timeout timer expires, the test set assumes that the session with the AT has been lost. The test set will send a SessionClose message and go to Idle State . Also, an error message is posted to indicate that the session times out.

Setting the Session Close to zero turns off the session close timeout timer. In this case, the test set does not try to send KeepAliveRequest messages, and will not automatically close the session if not detecting any traffic from the AT.

The session close timeout timer is disabled while a data connection is present. When a traffic channel connection is present, the Call Drop Timer is used but note it can be disabled.

Session Close timeout is a "Configurable Attribute" that is configured during the Session Negotiate State . Its value can not be changed when a session is open and Call Limit Mode is on. If session close timeout is changed when a connection is open, the connection will be closed. You will have to re-open the connection.

Operating Considerations

During hybrid mode tests, to prevent the session from unexpected closing when the AT stays on the IS-95/IS-2000 system (for example, a voice call) longer than the default value (3 minutes), it is recommended set the Session Close to a larger value. See How Do I Make Hybrid Mode AT/MS Tests? for details. (Note that the Session Close on the front panel defaults to minutes while seconds are used by the GPIB command by default.)

Related Topics

GPIB Command: CALL:SCLose:TIMeout

Manual Operation: How Do I Change Call Parameters?


Subnet Mask

Subnet Mask

The subnet mask parameter indicates the number of consecutive 1's in the subnet mask of the subnet to which the test set's sector belongs.

The subnet mask is a 128 bit number whose binary representation consists of "n" consecutive 1's followed by "128 - n" consecutive 0's. The subnet mask parameter sent by the access network indicates the number of consecutive 1's in the subnet mask; the access terminal can then determine the number of consecutive 0's in the subnet mask, and thus determine the 128 bit subnet mask value.

Subnet mask is sent in the Sector Parameters message (see TAP/ETAP Data Connection Call Flow ).

Subnet mask can be changed at any time.

Related Topics

GPIB Command: CALL[:CELL]:PARameter:SECTor:SMASk

Manual Operation: How Do I Change Cell Parameters?


System Type

System Type

Currently while in Active Cell Operating Mode there is only one system type, IS-856 (programming mnemonic DIGital856). This value can not be changed. The handoff system type is also currently fixed to IS-856 (DIGital856).

While in CW Operating Mode , the only system type is CW.

Related Topics

Cell Band


C.S0029 Test Application Specification Description (TAP/ETAP)

C.S0029 Test Application Specification Description (TAP/ETAP)

Last updated: May 24, 2006

3GPP2 C.S0029 standard, the Test Application Specification (TAS) for High Rate Packet Data Air Interface, provides a set of procedures to allow testing of access terminal (AT) minimum performance. In a 1xEV-DO network, the link between the access terminal (AT) and access network (AN) are dynamic. As propagation conditions change, the AT requests data at different rates, and from different serving sectors. This type of dynamic system makes it very difficult to control the test conditions for performing AT minimum performance testing. The Test Application Specification allows many of the connection characteristics to be fixed during testing, and enables the AT to send Loop Back Packets to help characterize its receiver performance.

The C.S0029 has evolved from release 0 (C.S0029-0) to release A (C.S0029-A) to support the tests as required by the new release of air interface standard (C.S0024-A). The latest C.S0029-A defines two new sets of test application protocols: Enhanced Test Application Protocols (ETAP) and Broadcast Test Application Protocol (BTAP) in addition to the Test Application Protocols (TAP) that is originally defined in the C.S0029-0.

The test set does not support BTAP. The following description reviews the TAP and ETAP as defined in the C.S0029-A. This description discusses the TAP and ETAP functionality used to perform key access terminal minimum performance tests in a factory/laboratory environment. It does not discuss the usage of TAP and ETAP for gathering link statistics or characterizing the forward and reverse link performance in a field environment.

  • TAP Overview
  • ETAP Overview

TAP Overview

The TAP is specified in terms of two independent protocols: FTAP (Forward Test Application Protocol) and RTAP (Reverse Test Application Protocol). FTAP allows testing of the AT's receiver, whereas RTAP allows testing of the AT's transmitter. Both the FTAP and RTAP protocols operate with the Subtype 0 Physical Layer Protocol.

Prior to open a TAP connection, verify that the TAP (0x0003) is configured for the session (see Test Application Configuration ). FTAP or RTAP then uses the FTAP and RTAP Parameter Assignment messages for controlling and configuring the access terminal and the access network for conducting tests as the connection is established.

Forward Test Application Protocol (FTAP)

The FTAP allows testing of the access terminal's receiver. FTAP provides the procedures and messages used by the access terminal and the access network to:

  • Control the Forward Traffic Channel.
  • Configure the R-ACK and R-DRC Channels (transmit configured ACK Channel bits, DRC values and DRC covers.)
  • Generate and transmit FTAP Test Packets on the Forward Traffic Channel and process the received packets at the AT.
  • Generate and transmit information about the received FTAP Test Packets at the AT through FTAP Loop Back Packets sent by the AT.

Basic procedure:

  • TAP connection is opened.
  • The AN sends an FTAP Parameter Assignment message, which may include the following attributes:
    • DRC Value Fixed mode: If the DRC Value Fixed Mode attribute is sent, the AT shall set its transmitted DRC (data rate requested from the AN) to the specified DRC Value.
    • DRC Cover Fixed mode: If the DRC Cover Fixed Mode attribute is sent, the AT shall set its transmitted DRC Cover (sector cover associated with the current serving sector) to the specified DRC Cover.
    • ACK Channel Bit Fixed mode: If the ACK Channel Bit Fixed Mode attribute is sent, the AT shall transmit the specified ACK Channel Bit during every slot. If the specified ACK Channel Bit is `1' (NACK), then the AT shall receive the packets as if they were all of full-length duration, and continue receiving them until the full-length in slots has elapsed, even if the packet was successfully decoded earlier. If the ACK Channel Bit value is '0' (ACK), the access terminal shall receive packets on the Forward Traffic Channel as if all the packets were successfully received in one slot duration. Even if a packet has not been successfully decoded in a single slot and its full-length in slots is greater than one, the access terminal shall stop receiving the packet after one slot.
    • Loop Back mode: If the Loop Back Mode attribute is sent, the AT shall transmit FTAP Loop Back Packets on the Reverse Traffic Channel. The AT sends one or more FTAP Loop Back Packets for each 16 slot time period (frame), indicating how many FTAP Test Packets were successfully decoded in that frame. (Depending upon the Forward Traffic Channel data rate, from 1 to 16 valid FTAP Test Packets are sent each frame, but the standard specifies that only half of these packets be directed to the AT under test. See AT Directed Packets .) An FTAP Loop Back Packet is sent even if no FTAP Test Packets are received during the frame.
  • The AT sends an FTAP Parameter Complete message to indicate completion of test configurations specified by the FTAP Parameter Assignment message.
  • The access network and the access terminal exchange FTAP Test Packets and FTAP Loop Back Packets (if Loop Back Mode is enabled).
  • The AN calculates Packet Error Rate (PER) based on the number of FTAP Test Packets sent to the AT and the number successfully decoded by the AT.

Reverse Test Application Protocol (RTAP)

The Reverse Test Application Protocol allows testing of the access terminal's transmitter. RTAP provides the procedures and messages used by the access terminal and the access network to:

  • Control and configure the Reverse Traffic Channel.
  • Generate and transmit RTAP Test Packets on the Reverse Traffic Channel at the configured rate.

Basic procedure:

  • TAP connection is opened.
  • The AN sends an RTAP Parameter Assignment message, which may include the following attributes:
    • RTAP Test Packet mode: If the RTAP Test Pkt Enable attribute is sent, the AT shall generate an RTAP Test Packet at the beginning of every 16-slot interval aligned to the CDMA System Time (every frame).
    • Configured Packet Rate mode: If the Packet Rate Mode attribute is sent, AT shall generate RTAP Test Packets at a rate determined by the Min Rate and Max Rate specified.

      The AT shall obey the following rules to select a Reverse Traffic Channel rate. The access terminal shall maintain the following variables: MinRate (value of the MinRateIndex field received in the PacketRateMode attribute), MaxRate (value of the MaxRateIndex field received in the PacketRateMode attribute), MACMaxRate (RateIndex corresponding to the maximum rate allowed by the RTC MAC protocol), TargetRate (RateIndex corresponding to the desired rate), SelectedRate (RateIndex corresponding to the selected rate).

      For the first RTC MAC Packet following the start of the test, the access terminal shall set:
      TargetRate = MinRate, and SelectedRate = Min (TargetRate, MACMaxRate).
      For all the subsequent RTC MAC Packets, the access terminal shall choose the rate as follows:
      TargetRate = TargetRate + 1;
      If (TargetRate > MaxRate), TargetRate = MinRate, SelectedRate = Min (TargetRate, MACMaxRate).
  • The AT sends an RTAP Parameter Complete message to indicate completion of test configurations specified by the RTAP Parameter Assignment message.
  • For some AT transmitter tests it is required that the R-ACK channel be active. In this case, the FTAP Parameter Assignment message must be sent by the AN, with the ACK Channel Bit Fixed mode enabled. The AT must then send an FTAP Parameter Complete message.
  • If RTAP Test Packet mode is enabled, the AT sends RTAP Test Packets to the AN.

ETAP Overview

The ETAP is specified in terms of two independent protocols: FETAP (Forward Enhanced Test Application Protocol) and RETAP (Reverse Enhanced Test Application Protocol). FETAP allows testing of the AT's receiver, whereas RETAP allows testing of the AT's transmitter. Both the FETAP and RETAP protocols operate with the Subtype 0 Physical Layer Protocol, Subtype 1 Physical Layer Protocol, or Subtype 2 Physical Layer Protocol.

The test set does not support Subtype 1 Physical Layer Protocol and only supports ETAP to operate with Subtype 2 Physical Layer Protocol.

Prior to open an ETAP connection, verify that the ETAP (0x000A) is configured for the session (see Test Application Configuration ). FETAP or RETAP then uses the FETAP and RETAP Parameter Assignment messages or controlling and configuring the access terminal and the access network for conducting tests as the connection is established.

Forward Enhanced Test Application Protocol (FETAP)

The FETAP allows testing of the access terminal's receiver. FETAP provides the procedures and messages used by the access terminal and the access network to:

  • Control the Forward Traffic Channel.
  • Configure the R-ACK and R-DRC Channels (transmit configured ACK Channel bits, DRC values and DRC covers. Also, for Subtype 2 Physical Layer Protocol, transmit ACK Channel using configured modulation type).
  • Generate and transmit FETAP Test Packets on the Forward Traffic Channel and process the received packets at the AT.The access network shall not use Single User Multiplex Packets and Multi-User Packets upon sending FETAP Test Packets.
  • Generate and transmit information about the received FETAP Test Packets at the AT through FETAP Loop Back Packets sent by the AT.

Basic procedure:

  • ETAP connection is opened.
  • The AN sends an FETAP Parameter Assignment message, which may include the following attributes:
    • DRC Value Fixed mode: If the DRC Value Fixed Mode attribute is sent, the AT shall set its transmitted DRC (data rate requested from the AN) to the specified DRC Value.
    • DRC Cover Fixed mode: If the DRC Cover Fixed Mode attribute is sent, the AT shall set its transmitted DRC Cover (sector cover associated with the current serving sector) to the specified DRC Cover.
    • ACK Channel Bit Fixed mode: If the ACK Channel Bit Fixed Mode attribute is sent, the AT shall transmit the specified ACK Channel Bit during every slot. If the specified ACK Channel Bit is `1' (NACK), then the AT shall receive the packets as if they were all of full-length duration, and continue receiving them until the full-length in slots has elapsed, even if the packet was successfully decoded earlier. If the ACK Channel Bit value is '0' (ACK), the access terminal shall receive packets on the Forward Traffic Channel as if all the packets were successfully received in one slot duration. Even if a packet has not been successfully decoded in a single slot and its full-length in slots is greater than one, the access terminal shall stop receiving the packet after one slot
    • Loop Back mode: If the Loop Back Mode attribute is sent, the AT shall transmit FETAP Loop Back Packets on the Reverse Traffic Channel. The AT sends one or more FETAP Loop Back Packets for every 16-slot interval aligned to the CDMA System Time (every frame), indicating how many FETAP Test Packets were successfully decoded in each frame. (Depending upon the Forward Traffic Channel data rate, from 1 to 16 valid FETAP Test Packets are sent in each frame, but the standard specifies that only half of these packets be directed to the AT under test. See AT Directed Packets .) An FETAP Loop Back Packet is sent even if no FETAP Test Packets are received during the frame.
    • ACK Channel Modulation Type Fixed mode: If the ACK Channel Modulation Type Fixed Mode attribute is sent, the AT shall use the specified modulation for transmission of the ACK channel. Valid only for Subtype 2 Physical Layer Protocol. If this attribute is sent, then the ACK Channel Bit Fixed Mode attribute must also be included. The specified ACK Channel Modulation Type can be set to 0x00 (BPSK) or 0x01 (OOK).
  • The AT sends an FETAP Parameter Complete message to indicate completion of test configurations specified by the FETAP Parameter Assignment message.
  • The access network and the access terminal exchange FETAP Test Packets and FETAP Loop Back Packets (if Loop Back Mode is enabled).
  • The AN calculates Packet Error Rate (PER) based on the number of FETAP Test Packets sent to the AT and the number successfully decoded by the AT.

Reverse Enhanced Test Application Protocol (RETAP)

The RETAP allows testing of the access terminal's transmitter. RETAP provides the procedures and messages used by the access terminal and the access network to:

  • Control and configure the Reverse Traffic Channel.
  • Generate PL_0_1 RETAP Test and Fill Packets at the access terminal and transmit on the Reverse Traffic Channel at the configured rate. Process the received packets at the access network. Valid only for Subtype 0 and 1 Physical Layer Protocols. (The test set does not support ETAP operate with Subtype 0 and 1 Physical Layer Protocols.)
  • Generate PL_2 RETAP Test Packets at the access terminal and transmit packets at the configured Reverse Traffic Channel payload sizes on the Reverse Traffic Channel. Includes support for multiple concurrent MAC flows as specified in Subtype 3 RTC MAC Protocol. Process the received packets at the access network. Valid only for Subtype 2 Physical Layer Protocol.
  • Transmit packets at the configured Enhanced Access Channel rates. Valid only for Subtype 1 and 2 Physical Layer Protocols. (The test set does not support Physical Layer Subtype 1 Physical Layer Protocol.)

Basic procedure:

  • ETAP connection is opened.
  • The AN sends an RETAP Parameter Assignment message, which may include the following attributes:
    • RETAP Test Packet mode: If the RETAP Test Pkt Enable attribute is sent, the AT shall generate an RETAP Test Packet at the beginning of every 16-slot interval aligned to the CDMA System Time (every frame).
    • Configured Packet Rate mode (Valid for Subtype 0 and 1 Physical Layer Protocols. The test set does not support ETAP operating with Subtype 0 and 1 Physical Layer Protocols): If the Packet Rate Mode attribute is sent, the AT shall generate RETAP PL_0_1 Test Packets at a rate determined by the Min Rate and Max Rate specified.

      The AT shall obey the following rules to select a Reverse Traffic Channel rate. The access terminal shall maintain the following variables: MinRate (value of the MinRateIndex field received in the PacketRateMode attribute), MaxRate (value of the MaxRateIndex field received in the PacketRateMode attribute), MACMaxRate (RTC_PL_0_1RateIndex corresponding to the maximum rate allowed by the RTC MAC protocol), TargetRate (RateIndex corresponding to the desired rate), SelectedRate (RateIndex corresponding to the selected rate).

      For the first RTC MAC Packet following the start of the test, the access terminal shall set:
      TargetRate = MinRate, and SelectedRate = Min (TargetRate, MACMaxRate).
      For all the subsequent RTC MAC Packets, the access terminal shall choose the rate as follows:
      TargetRate = TargetRate + 1;
      If (TargetRate > MaxRate), TargetRate = MinRate, SelectedRate = Min (TargetRate, MACMaxRate).
    • Configured Packet Payload Size mode (Valid only for Subtype 2 Physical Layer Protocol): If the Packet Payload Size Mode attribute is sent, AT shall generate RETAP PL_2 Test Packets at a packet size determined by the MinPayloadSize and MaxPayloadSize specified.

      The AT shall obey the following rules to select a Reverse Traffic Channel payload size. The access terminal shall maintain the following variables: MinPayloadSize (value of the MinPayloadSizeIndex field received in the PacketPayloadSizeMode attribute), MaxPayloadSize (value of the MaxPayloadSizeIndex field received in the PacketPayloadSizeMode attribute), MACMaxPayloadSize (RTC_PL_2PayloadSizeIndex corresponding to the maximum payload size allowed by the Subtype 3 Reverse Traffic Channel MAC Protocol), TargetPayloadSize (RTC_PL_2PayloadSizeIndex corresponding to the desired payload size), SelectedPayloadSize (RTC_PL_2PayloadSizeIndex corresponding to the selected payload size)

      For the first RTC MAC Packet following the start of the test, the access terminal shall set:
      TargetPayloadSize = MinPayloadSize, and
      SelectedPayloadSize = Min (TargetPayloadSize, MACMaxPayloadSize).
      For all the subsequent RTC MAC Packets, the access terminal shall choose the payload size as follows:
      TargetPayloadSize = TargetPayloadSize + 1;
      If (TargetPayloadSize > MaxPayloadSize), TargetPayloadSize = MinPayloadSize; and
      SelectedPayloadSize = Min (TargetPayloadSize, MACMaxPayloadSize).
    • Configured Enhanced Access Channel Rate mode (Valid for Subtype 1 and 2 Physical Layer Protocols. The test set does not support Subtype 1 Physical Layer Protocol): If the Enhanced Access Channel Rate Mode attribute is sent, the access terminal shall select an Access Channel rate as follows:
      Min (EnhancedAccessChannelRateIndex, SectorAccessMaxRate).
    • Configured Enhanced Access Channel Rate mode (Valid for Subtype 1 and 2 Physical Layer Protocols. The test set does not support Subtype 1 Physical Layer Protocol): If the Enhanced Access Channel Rate Mode attribute is sent, the access terminal shall select an Access Channel rate as follows:
      Min (EnhancedAccessChannelRateIndex, SectorAccessMaxRate).
    • Burst Period mode (Valid for Subtype 2 Physical Layer Protocol): If the Burst Period Mode attribute is sent, the access terminal shall generate PL_2 RETAP Test Packet for the specified period (in units of 600 slots). If this attribute is sent, then the BurstSizeMode attribute must also be included.
    • Burst Size mode (Valid for Subtype 2 Physical Layer Protocol): If the Burst Size Mode attribute is sent, the access terminal shall use the specified burst size generated at the beginning of the PL_2 RETAP Test Packet generation period (in units of 1000 octets).
  • The AT sends an RETAP Parameter Complete message to indicate completion of test configurations specified by the RETAP Parameter Assignment message.
  • For some AT transmitter tests it is required that the R-ACK channel be active. In this case, the FETAP Parameter Assignment message must be sent by the AN, with the ACK Channel Bit Fixed mode enabled and ACK Channel Modulation Type Fixed Mode enabled (only for Subtype 2 Physical Layer Protocol). The AT must then send an FETAP Parameter Complete message.
  • If RETAP Test Packet mode is enabled, the AT sends RETAP Test Packets to the AN.

Related Topics

Test Application Protocol


Forward Traffic Rate in IS-856 Test Operating Mode

Forward Traffic Rate in IS-856 Test Operating Mode

The Forward Traffic Rate determines the rate (and number of slots) at which the forward traffic packets are transmitted by the test set in IS-856 Test Operating Mode .

You must select a Forward Traffic Rate as listed in the table below to match your AT's configuration because there's no signaling exchanged between the AT and the test set when in IS-856 test mode. What you set (including forward data rate, number of slots per physical packet, as well as the corresponding modulation type) is then displayed on the Call Setup screen in the Configuration Information window.

Forward Traffic Data Rates in IS-856 Test Mode
Forward Traffic Data Rate (kbps) | Slots per Physical Packet | Modulation Type
38.4 | 16 | QPSK
76.8 | 8 | QPSK
153.6 | 4 | QPSK
307.2 | 2 | QPSK
307.2 | 4 | QPSK
614.4 | 1 | QPSK
614.4 | 2 | QPSK
921.6 | 2 | 8-PSK
1228.8 | 1 | QPSK
1228.8 | 2 | 16-QAM
1843.2 | 1 | 8-PSK
2457.6 | 1 | 16-QAM

Related Topics

GPIB command: CALL:TEST856:TRAFfic[:FORWard]:DRATe

Manual Operation: How Do I Change Parameters in IS-856 Test Operating Mode?

IS-856 Test Operating Mode

To set the forward traffic data rate in the Active Cell operating mode, see FTAP Rate .


Expected Reverse Data Rate in IS-856 Test Operating Mode

Expected Reverse Data Rate in IS-856 Test Operating Mode

The Exp R-Data Rate determines the data rate at which the reverse data channel are expected to be transmitted by the access terminal (AT) in the IS-856 Test Operating Mode . It may not be the actual data rate being transmitted on the reverse data channel. The expected reverse data rate is primarily used for ranging the test set's receiver power (see Expected Power ).

Exp R-Data Rates
Exp R-Data Rate (kbps)
9.6
19.2
38.4
76.8
153.6

Related Topics

GPIB command: CALL:TEST856:DCHannel:REVerse:DRATe

Manual Operation: How Do I Change Parameters in IS-856 Test Operating Mode?

IS-856 Test Operating Mode

Expected Power

For the reverse data rate in Active Cell operating mode, see RTAP Rate .


UATI 024

UATI 024

UATI 024 represents the lower 24 bits of the UATI assigned by the AN to the AT when a UATI Request is processed from the AT.

UATI 024 is sent in the UATI Assignment message (see TAP/ETAP Data Connection Call Flow ).

UATI 024 can be queried at any time, but a value will only be returned if a session is open (see Session Open State ). The UATI 024 assigned to the access terminal by the test set is displayed on the Call Setup screen in the Access Terminal Information (AN Assigned) window.

Related Topics

GPIB Command: CALL:STATus:MS:UATI024?


UATI Color Code

UATI Color Code

UATI color code is the color code associated with the subnet to which the UATI belongs.

UATI color code is sent in the UATI Assignment message (see TAP/ETAP Data Connection Call Flow ).

UATI color code can be queried at any time, but a value will only be returned if a session is open (see Session Open State ). UATI Color Code is displayed on the Call Setup screen in the Access Terminal Information (AN Assigned) window.

Related Topics

GPIB Command: CALL:STATus:MS:UCCode?


UATI Request State

UATI Request State

In the UATI Request state, the test set is in the process of assigning the AT a UATI (Unicast Access Terminal Identifier). The access terminal (AT) initiates a session by sending a UATI Request message, using the Session Seed as its Transmit ATI. The Session Seed is used to address the AT until it is assigned a UATI. For the messaging flow, see UATI Request procedure .

The UATI request state is a transitory state (see TAP/ETAP Data Connection Processing Lifecycle and Packet Data Connection Processing States Lifecycle ).

To query the state of the data connection, see Data Connection State Synchronization .

Related Topics

Programming: Step 4: Make a connection

Manual Operation: How Do I Open a Session and Test Data Connection?

TAP/ETAP Data Connection Processing States Lifecycle

TAP/ETAP Data Connection Call Flow

Packet Data Connection Processing States Lifecycle ( Lab Application Only )

Packet Data Connection Call Flow ( Lab Application Only )


Getting Started with the 1xEV-DO Terminal Test and Lab Applications

Getting Started with the 1xEV-DO Terminal Test and Lab Applications

Last updated: July 20, 2006

This online user's guide provides detailed information about your application's features and functionality, as well as how to use these features to test your wireless device.

The Contents box on the left-hand side of this page provides access to all of the information contained within this online user's guide. The following is a description of these Contents topics. If you have trouble finding the information you need by navigating through the Contents topics, use the search field at the top of this page to search the contents of this guide.

  • Call Processing : Describes how to configure the test set's base station emulator and perform key call processing operations.
  • Measurements : Describes the measurements and instruments available within your application. Provides a list of which key conformance tests are supported by the test set.
  • Manual Operation : Describes how to configure the test set and perform call processing operations and measurements from the front panel.
  • Programming : Describes how to configure the test set and perform call processing operations and measurements by remote program.
  • GPIB Commands : Provides details on all of the GPIB syntax available to control the test set by remote program.
  • Protocol Logging ( lab application only ): Describes how to capture the exchange of data and control information between the test set and wireless device.
  • Data Channel ( lab application only ): Describes how to use the test set as an IP router, exchanging data between your wireless device and remote servers.
  • Troubleshooting : Provides troubleshooting information for performing measurements and key call processing events. Includes a test set block diagram.
  • Configuration : Describes how to set amplitude offsets, switch between applications, and configure the test set (such as GPIB and LAN ports).
  • Fast Switching : Explains how to use fast switching test and lab applications.
  • Release Notes : Lists the features and functionality of the applications for each release of the firmware.
  • Downloadable Manuals : Provides a portable version of this online user's guide, which you may download to your computer.

For pricing and availability, brochures and datasheets for the applications, visit the product page:

  • E1966A 1xEV-DO Terminal Test Application


ABORt

ABORt

Last updated: June 30, 2006

Diagram Conventions

ABORt[:ALL]

Function

Stops all measurements that are active.

You can also use the ABORt:<measurement mnemonic> commands to stop the active measurements individually.

If the trigger arm is set to single, the measurements will go to the idle state.

If the trigger arm is set to continuous, the measurements will re-arm and initiate again.

See Measurement States .
Requirements Test Application Revision: A.01.20 and above
Test Application Revision: A.02.20 and above: Added CTDPower
Lab Application Revision: A.01 and above: Added GAPPower
Test Application Revision A.06 and above with the required feature license: added CFDTune
Lab Application Revision: A.03 and above: Added CFDTune

Programming Example

OUTPUT 714;"ABORt"
!Aborts all active measurement in progress.

ABORt:<measurement mnemonic>

Function

This command stops the specified measurement if it is active:

  • AFANalyzer - Audio Frequency Analyzer measurement

  • CAPPower - Access Probe Power measurement

  • CFDTune - Fast Device Tune measurement ( lab application or feature-licensed test application only )

  • CPERror - Packet Error Rate measurement

  • CPOWer - Channel Power measurement

  • CTDPower - TX Dynamic Power measurement

  • CTXSpurious - TX Spurious Emissions measurement

  • DAPower - Digital Average Power measurement

  • DOWQuality - Waveform Quality measurement

  • GAPPower - Graphical Access Probe Power measurement (only applicable to the lab application)

  • SAUDio - Swept Audio measurement

  • SMONitor - Spectrum Monitor

  • TROPower - Time Response of Open Loop Power Control measurement

You can also use the ABORt[:ALL] command to stop all measurements that are active.

If the trigger arm is set to single, the measurements will go to the idle state.

If the trigger arm is set to continuous the measurements will re-arm and initiate again.

See Measurement States .
Requirements Test Application Revision: A.01.20 and above
Test Application Revision: A.02.20 and above: Added CTDPower
Lab Application Revision: A.01 and above: Added GAPPower
Test Application Revision A.06 and above with the required feature license: added CFDTune
Lab Application Revision: A.03 and above: Added CFDTune

Programming Example

OUTPUT 714;"ABORt:DOWQuality"
!Aborts the waveform quality measurement


ABORt Subsystem

ABORt Subsystem

Description

The ABORt command causes a measurement cycle in progress to stop. If the measurement is not being continuously armed (trigger arm set to single) , the measurement will remain in the idle state after this event. If the measurement is being continuously armed (trigger arm set to continuous), a new measurement cycle will begin after ABORt. If an ABORt command is issued from any measurement state other than measuring, the command is ignored.

Other Commands that Execute an ABORt Action

INITiate:<meas> will execute an ABORt:<meas> as part of the INITiate:<meas> command.

READ:<meas>? will execute an ABORt:<meas> action that aborts just one trigger sequence and then combines the INITiate and FETCh? commands.

Syntax Diagram and Command Descriptions

ABORt


AFGenerator

AFGenerator

Diagram Conventions

AFGenerator:COUPling

Function

 Sets the output of the audio generator to be ac or dc coupled to the front-panel AUDIO OUT port.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: AC or DC
Query

Range: AC|DC
*RST setting DC

Programming Example

OUTPUT 714;"AFGENERATOR:COUPling AC" !Sets the audio generator coupling to AC.

AFGenerator:FREQuency

Function

 Sets/queries the frequency of the audio generator. The units (HZ|KHZ|MHZ|GHZ) are optional. If no units are specified, then units default to HZ.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 1 Hz to 20 kHz

Resolution: 0.1 HZ
Query

Range: 1 Hz to 20 kHz

Resolution: 0.1 Hz
*RST setting 1 kHz

Programming Example

OUTPUT 714;"AFGENERATOR:FREQUENCY 1000" !Sets the audio generator frequency to 1000 Hz.

AFGenerator:PULSe[:STATe]

Function

Sets/queries the audio generator pulse state.

The pulse state must be on when the test set's audio generator is used for audio stimulation during a decoded audio measurement.

When the state is on, the audio signal from the test set is pulsed at a 10 Hz rate with a 50% duty cycle.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting | Range: 0 | OFF | 1 |ON

Query

Range: 0|1
*RST setting | 0 (off)

Programming Example

OUTPUT 714;"AFGENERATOR:PULSE ON" !Sets the audio generator pulse to ON.

AFGenerator:VOLTage[:SAMPlitude]

Function

 Sets /queries the amplitude of the audio generator in volts and turns the state to on. The units (V|mV) are optional. If no units are specified, then units default to V.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 0 to 9 V pk.

Resolution:

  • 0.5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
Query

Range: 0 to 9 V pk.

Resolution:

  • 0.5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
*RST setting 0 V

Programming Example

OUTPUT 714;"AFGENERATOR:VOLTAGE 2.1" !Sets the state to on and the output
                                     !voltage to 2.1 volts.

AFGenerator:VOLTage:AMPlitude

Function

 Sets/queries the amplitude for the audio generator when the audio generator state is on. The units (V|mV) are optional. If no units are specified, then units default to V.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 0 to 9 V pk.

Resolution:

  • 0.5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
Query

Range: 0 to 9 V pk.

Resolution:

  • 0.5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
*RST setting 0 V

Programming Example

OUTPUT 714;"AFGENERATOR:VOLTAGE:AMPLITUDE 1.414" !Sets the audio generator output
                                                 !voltage to 1.414 volts peak.

AFGenerator:VOLTage:STATe

Function

 Sets/queries the audio generator state

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting | 0 | OFF | 1 |ON

Query

0|1
*RST setting | 0 (off)

Programming Example

OUTPUT 714;"AFGENERATOR:VOLTAGE:STATE ON" !Set the audio generator state to ON.


AFGenerator Subsystem

AFGenerator Subsystem

Description

The AFGenerator subsystem is used to control an audio source which can be routed to the AUDIO OUT port on the test set's front panel (see also SYSTem:AUDio:OUTPut:SOURce ).

Syntax Diagram and Command Descriptions

AFGenerator


CALCulate Subsystem

CALCulate Subsystem

Description

The CALCulate subsystem is used to perform data processing on the measurement results. For example in the Spectrum Monitor the CALCulate subsystem uses the markers to find the peaks and read back their values.

Syntax Diagram and Command Descriptions

CALCulate:SMONitor


CALCulate:SMONitor

CALCulate:SMONitor

Diagram Conventions

CALCulate:SMONitor:MARKer:ALL:STATe

Function

This command determines whether all markers are turned on or turned off.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 1|ON|0|OFF

Query

Range: 1|ON|0|OFF
*RST Setting OFF

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:ALL:STATe 1"

!Turns on all markers.

CALCulate:SMONitor:MARKer[<n>]:AMPLitude?

Function

This query returns the amplitude for marker <n>, where <n> is a number 1 through 3. When no marker number is specified, marker 1 is used.

If you are using delta marker mode, the result is the delta marker amplitude result. (See CALCulate:SMONitor:MARKer[<n>]:MODE .)

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range

  • Position Mode: -180 dBm to +37 dBm

  • Delta Mode: -200 dB to +200 dB

Resolution: 0.01 dB

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:AMPLitude?" !Returns the amplitude of marker 2.

CALCulate:SMONitor:MARKer[<n>]:FREQuency

Function

This command sets/queries the frequency of marker <n>. where <n> is a number 1 through 3. When no marker number is specified, marker 1 is used.

If you are using delta marker mode, this command sets/queries the offset frequency of the delta marker. (See CALCulate:SMONitor:MARKer[<n>]:MODE .)

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Query

Range:

  • Position Mode

    Range: This is dependent on the settings of the center frequency and the frequency span. The markers frequency range is therefore equal to the center frequency +/- half the frequency span.

    Resolution: 0.001 MHz

  • Delta Mode:

    Range: The range is dependent on the center frequency, the frequency span and the position of the reference marker.

    Resolution: 0.001 MHz

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:FREQuency?"

!Queries the frequency of marker 1.

CALCulate:SMONitor:MARKer[<n>]:MODE

Function

This command sets the mode of the marker.

Position mode activates a single frequency marker at the center frequency.

Delta mode freezes the marker at its current location and uses it as a reference marker. A second marker is created at the position of the reference marker and is used a delta marker.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: POSition|DELTa|OFF

Query

Range: POS|DELT|OFF
*RST Setting Off

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:MODE DELT"

!Sets a reference marker and creates a delta marker.

CALCulate:SMONitor:MARKer:PEAK:EXCursion[:LEVel]

Function

This command sets the peak excursion level. A peak is identified by using the peak threshold and peak excursion value. A point is only marked as a peak if it rises and falls more than the peak excursion value from the peak threshold value. Setting this command to DEFault sets it to 6 dB.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 1 to 100 dB | DEFault

Resolution: 0.1 dB

Query

Range: 1 to 100 dBResolution: 0.1 dB
*RST Setting

6 dB

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:PEAK:EXCursion 20DB"

!Sets the peak excursion level to 20 dB.

CALCulate:SMONitor:MARKer[<n>]:PEAK:MAXimum

Function

This command moves the specified marker <n> (1 to 3) to the highest peak value. If no marker <n> is specified, then marker 1 is moved.

An error message is returned if no peaks were found in the trace.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:PEAK:MAXimum"

!Moves marker 2 to the highest peak value on the selected trace.

CALCulate:SMONitor:MARKer:PEAK:THReshold[:LEVel]

Function

This command sets peak threshold level. A peak is identified by using the peak threshold and peak excursion value. A point is only marked as a peak if it rises and falls more than the peak excursion value from the peak threshold value. Setting this command to DEFault sets it to -90 dBm.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: -120 to +37 dBm | DEFault

Resolution: 0.1

Query

Range: -120 to +37 dBmResolution: 0.1
*RST Setting

-90 dBm

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:PEAK:THReshold:LEVel 10DBM"

CALCulate:SMONitor:MARKer[<n>][:SET]:EXPected:POWer

Function

This command sets the base station emulator's expected power to the amplitude of the specified marker.

There are three markers <n> (1 to 3) that can be set. If no <n> is specified, marker 1 is used.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:EXPected:POWer"

CALCulate:SMONitor:MARKer[<n>][:SET]:EXPected:FREQuency

Function

This command sets the base station emulator's expected frequency to the frequency of the specified marker.

There are three markers <n> (1 to 3) that can be set. If no <n> is specified, marker 1 is used.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer3:EXPected:FREQuency"

CALCulate:SMONitor:MARKer[<n>]:STATe

Function

This command sets which markers are turned on.

There are three markers <n> (1 to 3) that can be set. If no <n> is specified, marker 1 is used.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 1|ON|0|OFF

Query

Range: 1|ON|0|OFF
*RST Setting OFF

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:STATE 1" !Turns on marker 2.

CALCulate:SMONitor:MARKer[<n>]:TIME

Function

This command sets/queries the time at marker <n>. where <n> is a number 1 through 3. When no marker number is specified, marker 1 is used.

If you are using delta marker mode, this command sets/queries the delta offset time. (See CALCulate:SMONitor:MARKer[<n>]:MODE .)

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: -50 ms to 10070 ms
Resolution: 0.25 us

Query

Range: -50 ms to 10070 ms
Resolution: 0.25 us
*RST Setting 5 ms

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:TIME 30" !Places marker 2 at 30 ms.


CALibration

CALibration

Diagram Conventions

CALibration:BMOFfset?

Function

Initiates Burst Modulator Offset DAC calibration for RF source 1. See Calibrating the Test Set .

It takes about fifty seconds to complete. It can't be aborted except by cycling the power switch.

When this calibration has completed, a value is returned to indicate the success or failure of calibration.

Requirements

 Test Application Revision: A.03 and above
Lab Application Revision: A.01 and above

Query

Range

  • 0 = Pass
  • -340 = Fail

Programming Example

OUTPUT 714;"CALibration:BMOFfset?"
!Initiates Burst Modulator Offset DAC calibration for RF source 1
!and returns a value (0 or -340) after completing the calibration.

CALibration:CPOWer?

Function

Initiates IF level calibration used by access probe power and channel power measurements.

No other GP-IB commands are processed until this calibration has completed.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range

  • 0 = Calibration passed
  • 1 = Channel power calibration failed due to temperature drift. Wait for temperature to stabilize.
  • 2 = Channel power calibration failed due to oven temperature out of range.
  • 3 = Channel power calibration failed due to loopback switch problem.
  • 7 = Channel power calibration failed due to source level problem.
  • -340 = Calibration failed

Programming Example

OUTPUT 714;"CALibration:CPOWer?"
!Initiates the IF level calibration process and queries the pass/fail result.

CALibration:DAPower?

Function

Initiates digital average power measurement calibration.

RF power must not be applied to the test set's front panel RF IN/OUT connector during calibration.

Digital average power measurement calibration will take about 10 minutes.

Power must be cycled when digital average power measurement calibration has completed.

No other GP-IB commands are processed until this calibration has completed.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range

  • 0 = Calibration passed
  • 1 = Digital average power calibration failed due to temperature drift. Wait for temperature to stabilize.
  • 2 = Digital average power calibration failed due to oven temperature out of range.
  • 3 = Digital average power calibration failed due to loopback switch problem.
  • -340 = Calibration failed

Programming Example

OUTPUT 714;"CALibration:DAPower?"
!Initiates the digital average power measurement calibration process and queries the pass/fail result.

CALibration:IQ[1]?

Function

Sets/queries the calibration of the IQ modulator for RF generator 1. It takes some time to complete calibration and can't be aborted except by cycling the power switch.

  • Calibrates the IQ modulator for RF generator 1.
  • Returns a value indicating success or failure of calibration.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range

  • 0 = Pass
  • -340 = Fail

Programming Example

OUTPUT 714;"CALibration:IQ1?"
!Performs a calibration of the IQ modulator for RF generator 1 and returns 0 or -340

NOTE
When the calibration is done the test set display will display:

IQ Calibration completed successfully for modulator 1.

CALibration:IQ2?

Function

Sets/queries the calibration of the IQ modulator for RF generator 2. It takes some time to complete calibration and can't be aborted except by cycling the power switch.

  • Calibrates the IQ modulator for RF generator 2.
  • Returns a value indicating success or failure of calibration.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range

  • 0 = Pass
  • -340 = Fail

Programming Example

OUTPUT 714;"CALibration:IQ2?"
!Performs a calibration of the IQ modulator for RF generator 2 and returns 0 or -340

NOTE
When the calibration is done the test set display will display:

IQ Calibration completed successfully for modulator 2.

CALibration:DATE

Function

Sets/queries the date of the last system calibration done to the test set; not the IQ calibration date. Returns a comma separated list YYYY,MM,DD in that order.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Sets the system calibration date.

Range

  • Year = 0000 to 9999

  • Month = 01 to 12

  • Day = 01 to 31

Query

Returns the date when system calibration was performed.

Range

  • Year = 0000 to 9999

  • Month = 1 to 12

  • Day = 1 to 31

Programming Example

OUTPUT 714;"CALibration:DATE 1999,01,04"
!Sets the date of the last system calibration year, month and day.

CALibration:SMONitor

Function

Starts the spectrum monitor calibration routine. It is important that no power is applied to the RF IN/OUT connector during calibration.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 through 10, and -340

  • 0 (Spectrum Monitor calibration completed successfully)
  • 1 (Spectrum Monitor calibration failed due to temperature drift. Wait for temperature to stabilize)
  • 2 (Spectrum Monitor calibration failed due to oven out of range)
  • 3 (Spectrum Monitor calibration failed due to loopback switch problem)
  • 4 (Spectrum Monitor calibration failed due to under range condition)
  • 5 (Spectrum Monitor calibration failed due to over range condition)
  • 6 (Spectrum Monitor calibration failed due to correlation problem)
  • 7 (Spectrum Monitor calibration failed due to source level problem)
  • 8 (Spectrum Monitor calibration failed due to IF filter coefficient problem)
  • 9 (Spectrum Monitor calibration failed due to IF frequency response problem)
  • 10 (Spectrum Monitor calibration failed due to waveform quality problem)
  • -340 (Spectrum Monitor calibration failed)

Programming Example

OUTPUT 714;"CALibration:SMONitor?" !Queries the spectrum monitor calibration.


CALibration Subsystem

CALibration Subsystem

Calibration Strategy

Various calibration routines must be run to ensure measurement accuracy. The type of calibration and appropriate intervals for performing calibrations vary with each application. See Calibrating the Test Set for more information.

Syntax Diagram and Command Descriptions

CALibration


CALL:APARameter

CALL:APARameter

Diagram Conventions

CALL[:CELL]:APARameter:POWer:OLADjust
<[:SELected]|:IMT2000|:JCDMa|:KPCS|:NMT450|:SECondary800|:USCellular|:USPCs|:USPCs1900>

Function

Sets/queries the Open Loop Adjust for the specified cell band. See Open Loop Adjust .

The optional [:SELected] keyword in this command specifies that the Open Loop Adjust being set or queried applies to the current cell band (see Cell Band ).

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Test Application Revision: A.06 and above: Support USPCs1900
Lab Application Revision: A.03 and above: Support USPCs1900

Setting

Range: 0 to 255 dB

Resolution: 1 dB

Query

 Same as setting

*RST Setting

[:SELected]: 81 dB (because *RST causes the band to be set to US PCS)

IMT2000, KPCS, USPCs, USPCs1900: 81 dB

JCDMa, USCellular, NMT450, SECondary800: 78 dB

Programming Example

OUTPUT 714;"CALL:APARameter:POWer:OLADjust 85"
! Sets the Open Loop Adjust for the currently selected band to 85 dB.

OUTPUT 714;"CALL:APARameter:POWer:OLADjust:KPCS 82"
! Sets the Open Loop Adjust for Korean PCS band to 82 dB.

CALL[:CELL]:APARameter:PREamble:LENGth

Function

Sets/queries the Preamble Length. See Preamble Length .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 7 frames

Resolution: 1 frame

Query

 Same as setting

*RST Setting

 2 frames

Programming Example

OUTPUT 714;"CALL:APARameter:PREamble:LENGth 5"
! Sets the preamble length to 5 frames.

CALL[:CELL]:APARameter:PROBe:POWer:STEP[:LEVel]

Function

Sets/queries the Power Step. See Probe Power Step .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0 to 7.5 dB per step

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 1.0 dB

Programming Example

OUTPUT 714;"CALL:APARameter:PROBe:POWer:STEP 5.5"
! Sets the power step size to 5.5 dB per step.

CALL[:CELL]:APARameter:PROBe:IADJust

Function

Sets/queries the Probe Initial Adjust. See Probe Initial Adjust .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: -16 to +15 dB

Resolution: 1 dB

Query

 Same as setting

*RST Setting

 0 dB

Programming Example

OUTPUT 714;"CALL:APARameter:PROBe:IADJust -10"
! Sets the initial probe power adjustment to -10 dB.

CALL[:CELL]:APARameter:PROBe:SEQuence[:MAXimum]

Function

Sets/queries the Probe Sequence Maximum. See Probe Sequence Max .

This is a "Configurable Attribute" that is set during session negotiation. Its value can not be changed while call limit mode is on (see Call Limit Mode ).

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 15

Resolution: integer

Query

 Same as setting

*RST Setting

 1

Programming Example

OUTPUT 714;"CALL:APARameter:PROBe:SEQuence 5"
! Sets the Probe Sequence Maximum to 5.

CALL[:CELL]:APARameter:PROBe:STEP:COUNt

Function

Sets/queries the Probe Num Step. See Probe Num Step .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 15

Resolution: integer

Query

 Same as setting

*RST Setting

 5

Programming Example

OUTPUT 714;"CALL:APARameter:PROBe:STEP:COUNt 7"
! Sets the Probe Num Step to 7.


CALL:APPLication

CALL:APPLication

Last updated: June 16, 2006

Diagram Conventions

CALL[:CELL]:APPLication[:TAPPlication][:TYPE]

Function

Sets/queries which test application protocol (Forward Test Application Protocol (FTAP) or Reverse Test Application Protocol (RTAP)) is used when a data connection is established using Test Application (0x0003). See Test Application Protocol .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: FTAProtocol|RTAProtocol

Query

Range: FTAP|RTAP

*RST Setting

 FTAP

Programming Example

OUTPUT 714;"CALL:APPLication RTAProtocol"
! Sets the application type to Reverse Test Application Protocol

CALL[:CELL]:APPLication:FTAProtocol:DRATe

Function

Sets/queries the data rate and number of slots used to transmit the forward test packets when the Application is FTAP. See FTAP Rate .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: S16Bps38400|S08Bps76800|S04Bps153600|S04Bps307200|S02Bps307200
|S02Bps614400|S01Bps614400|S01Kbps1229|S02Bps921600|S01Kbps1843
|S02Kbps1229|S01Kbps2458

Query

Range: S16B38400|S08B76800|S04B153600|S04B307200|S02B307200|S02B614400
|S01B614400|S01K1229|S02B921600|S01K1843|S02K1229|S01K2458

*RST Setting

S02B307200

Programming Example

OUTPUT 714;"CALL:APPLication:FTAProtocol:DRATe S16B38400"
! Sets the FTAP data rate to 38.4 kbps, 16 slots/packet

CALL[:CELL]:APPLication:RTAProtocol:DRATe

Function

Sets the rate at which the reverse test packets are sent when the Application is RTAP. See RTAP Rate .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: BPS9600|BPS19200|BPS38400
|BPS76800|BPS153600

Query

 Same as setting

*RST Setting

 BPS9600

Programming Example

OUTPUT 714;"CALL:APPLication:RTAProtocol:DRATe BPS19200"
! Sets the RTAP data rate to 19.2 kbps

CALL[:CELL]:APPLication:ACKChannel:BFMAttribute[:STATe]

Function

Sets/queries the ACK Channel Bit Fixed Mode Attribute state. See ACK Channel Bit Fixed Mode Attribute .

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (On)

Programming Example

OUTPUT 714;"CALL:APPLication:ACKChannel:BFMAttribute OFF"
! Turns ACK Channel Bit Fixed Mode Attribute state to off.

CALL[:CELL]:APPLication:ACKChannel:MODulation

Function

Sets/queries the modulation type of R-ACK Channel when ACK Channel Bit Fixed Mode Attribute is set to on. BPSKeying represents Bi-Polar Keying mode and OOKeying represents On-Off Keying mode. See ACK Channel Modulation Type for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: BPSKeying|OOKeying

Query

Range: BPSK|OOK

*RST Setting

BPSK

Programming Example

OUTPUT 714;"CALL:APPLication:ACKChannel:MODulation OOK"
! Sets ACK Channel Modulation Type to On-Off Keying.

CALL[:CELL]:APPLication:ATDPackets

Function

Sets/queries AT Directed Packets. See AT Directed Packets .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0 to 100%

Resolution: 1%

Query

 Same as setting

*RST Setting

 50

Programming Example

OUTPUT 714;"CALL:APPLication:ATDPackets 100"
! Sets AT Directed Packets to 100%

CALL[:CELL]:APPLication:DATA[:REVerse]:PACKet[:SIZE]

Function

Sets/queries the reverse data channel packet size which indirectly determines the data rate and modulation type. See R-Data Pkt Size .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: BIT128|BIT256|BIT512|BIT768|BIT1024|BIT1536|BIT2048|BIT3072
|BIT4096|BIT6144|BIT8192|BIT12288

Query

Range: same as setting

*RST Setting

BIT128

Programming Example

OUTPUT 714;"CALL:APPLication:DATA:PACKet BIT1024"
! Sets R-Data packet size to 1024 bits.

CALL[:CELL]:APPLication:DATA[:REVerse]:TRANsmission[:MODE]

Function

Sets/queries the R-Data channel transmission mode. HCAPacity represents High Capacity and LLATency represents Low Latency. See Reverse Data Transmission Mode .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: HCAPacity|LLATency

Query

Range: HCAP|LLAT

*RST Setting

HCAPacity

Programming Example

OUTPUT 714;"CALL:APPLication:DATA:TRANsmission LLATency"
! Sets R-Data transmission mode to low latency.

CALL[:CELL]:APPLication:DRCChannel:VFMAttribute[:STATe]

Function

Sets/queries the DRC Value Fixed Mode Attribute . It controls whether the DRCValueFixedMode attribute is sent to the AT.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (On)

Programming Example

OUTPUT 714;"CALL:APPLication:DRCChannel:VFMAttribute OFF"
! Sets DRC Value Fixed Mode Attribute to off.

CALL[:CELL]:APPLication:EACCess:DRATe

Function

Sets/queries the Enhanced Access Rate .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: BPS9600|BPS19200|BPS38400

Query

Range: same as setting

*RST Setting

BPS9600

Programming Example

OUTPUT 714;"CALL:APPLication:EACCess:DRATe BPS19200"
! Sets enhanced access rate to 19.2 kbps.

CALL[:CELL]:APPLication:ETAPlication[:TYPE]

Function

Sets/queries which enhanced test application protocol is used when a data connection is established using Enhanced Test Application (0x000A). FORWard indicates Forward Enhanced Test Application Protocol (FETAP) and REVerse indicates Reverse Enhanced Test Application Protocol (RETAP). See Enhanced Test Application Protocol .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: FORWard|REVerse

Query

Range: FORW|REV

*RST Setting

 FORWard

Programming Example

OUTPUT 714;"CALL:APPLication:ETAPlication REVerse"
! Sets enhanced test application type to RETAP.

CALL[:CELL]:APPLication:SESSion[:TYPE]

Function

Sets/queries which application is negotiated to during the Session Negotiate State .

DPAP indicates Default Packet Application and TAPP indicates Test Application.

See Session Application Type for details.

Requirements

 Lab Application Revision: A.01 and above

Setting

Range: DPAPlication|TAPPlication

Query

Range: DPAP|TAPP

*RST Setting

 TAPP

Programming Example

OUTPUT 714;"CALL:APPLication:SESSion DPAPlication"
!Sets session application type to Default Packet Application.

CALL[:CELL]:APPLication:TRAFfic:FORMat

Function

Sets/queries the forward traffic transmission format for subtype 2 physical layer when DRC Value Fixed Mode Attribute is On. See F-Traffic Format for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: <drc value>,<packet size in bits>,<number of slots>,<preamble length in chips>
(1, 128, 16, 1024); (1, 256, 16, 1024); (1, 512, 16, 1024); (1, 1024, 16, 1024);
(2, 128, 8, 512); (2, 256, 8, 512); (2, 512, 8, 512); (2,1024, 8, 512);
(3, 128, 4, 256); (3, 256, 4, 256); (3, 512, 4, 256); (3, 1024, 4, 256);
(4, 128, 2, 128); (4, 256, 2, 128); (4, 512, 2, 128); (4, 1024, 2, 128);
(5, 512, 4, 128); (5, 1024, 4, 128); (5, 2048, 4, 128);
(6, 128, 1, 64); (6, 256, 1, 64); (6, 512, 1, 64); (6, 1024, 1, 64);
(7, 512, 2, 64); (7, 1024, 2, 64); (7, 2048, 2, 648);
(8, 1024, 2, 64); (8, 3072, 2, 64);
(9, 512, 1, 64); (9, 1024, 1, 64); (9, 2048, 1, 648);
(10, 4096, 2, 64); (11, 1024, 1, 64); (11, 3072, 1, 64);
(12, 4096, 1, 64); (13, 5120, 2, 64); (14, 5120, 1, 64)

Query

Range: same as setting

*RST Setting

4, 1024, 2, 128

Programming Example

OUTPUT 714;"CALL:APPLication:TRAFfic:FORMat 5, 2048, 4, 128"
! Sets F-Traffic transmission format to DRC value 5,
! packet size 1024 bits, 4 slots per packet,
! preamble length 128 chips.

CALL[:CELL]:APPLication:TRAFfic:PACKet:CONFigure

Function

Sets/queries the forward traffic transmission format (canonical or short packets) for subtype 2 physical layer per DRC requested by the AT when DRC Value Fixed Mode Attribute is Off. See F-Traffic Config for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: CANonical|SPACket1|SPACket2|SPACket3

Query

Range: CAN|SPAC1|SPAC2|SPAC3

*RST Setting

CANonical

Programming Example

OUTPUT 714;"CALL:APPLication:TRAFfic:PACKet:CONFigure SPAC3"
! Sets F-Traffic transmission format to short packet 3.

CALL[:CELL]:APPLication:TRAFfic:PDURation:MAXimum

Function

Sets/queries the maximum slots required to transmit each physical layer packet. See Max Forward Packet Duration for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: 2 to 16 (slots)

Query

Range: same as setting

*RST Setting

 16

Programming Example

OUTPUT 714;"CALL:APPLication:TRAFfic:PDURation:MAXimum 8"
! Sets maximum transmission duration for each packet to 8 slots.

CALL[:CELL]:APPLication:TRAFfic:SPACket:THReshold

Function

Sets/queries the threshold that allows the forward traffic channel (for physical layer subtype 2) to use the short packet transmission formats for the DRC value requested by the AT. See Short Packet Enabled Threshold for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: BIT1024|BIT2048|BIT3072|BIT4096

Query

Range: same as setting

*RST Setting

 BIT4096

Programming Example

OUTPUT 714;"CALL:APPLication:TRAFfic:SPACket:THReshold BIT2048"
! Sets short packet enabled threshold to 2048 bits.

CALL[:CELL]:APPLication:TAPRotocol:LIMited[:STATe]

Function

Sets/queries the Limited TAP state. See Limited TAP .

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (Off)

Programming Example

OUTPUT 714;"CALL:APPLication:TAPRotocol:LIMited ON"
! Turns Limited TAP on.


CALL:AWGNoise

CALL:AWGNoise

Diagram Conventions

CALL:AWGNoise[:INTernal]:POWer[:SAMPlitude]<[:SELected]|:DIGital856>

Function

The setting form of this command performs two functions: (1) sets the additive white gaussian noise (AWGN) level and (2) turns the AWGN on/off state to on. The query form returns the desired AWGN power level. (See Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power for more information about desired versus current power levels).

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type (see System Type ).

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

 Range/Resolution: see CALL:AWGNoise[:INTernal]:POWer:AMPLitude<[:SELected]|:DIGital856>

Query

 Range/Resolution: see CALL:AWGNoise[:INTernal]:POWer:AMPLitude<[:SELected]|:DIGital856>

*RST Setting

 OFF, and see CALL:AWGNoise[:INTernal]:POWer:AMPLitude<[:SELected]|:DIGital856>

Programming Example

OUTPUT 714;"CALL:AWGNoise:POWer -30"
! Sets AWGN power state to ON and
! sets desired AWGN power level to -30 dBM/1.23 MHz for the current system type.
OUTPUT 714;"CALL:AWGNoise:POWer:DIGital856 -54"
! Sets AWGN power state to ON and
! sets AWGN power level to -54 dBm/1.23 MHz for the DIGital856 system type.

CALL:AWGNoise[:INTernal]:POWer:AMPLitude<[:SELected]|:DIGital856>

Function

Sets/queries the desired additive white gaussian noise (AWGN) level. (See Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power for more information about desired versus current power levels).

The optional [:SELected] keyword in this command specifies that the AWGN power level being queried applies to the current system type (see System Type ).

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: -170 dBm/1.23 MHz to +35 dBm/1.23 MHz (this is the range of settings accepted, see Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power for the actual hardware range of the source)

Resolution: 0.01 dB

Query

 Same as setting

*RST Setting

 -54 dBm/1.23 MHz

Programming Example

OUTPUT 714;"CALL:AWGNoise:POWer:AMPLitude -30"
! Sets the desired AWGN power level to -30 dBM/1.23 MHz for the current system type.

CALL:AWGNoise[:INTernal]:POWer:STATe<[:SELected]|:DIGital856>

Function

Sets/queries the additive white gaussian noise (AWGN) state.

The optional [:SELected] keyword in this command specifies that the AWGN power level being queried applies to the current system type (see System Type ).

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 OFF

Programming Example

OUTPUT 714;"CALL:AWGNoise:POWer:STATe ON"
! Turns on AWGN for the current system type.


CALL:BAND

CALL:BAND

Diagram Conventions

CALL[:CELL]:BAND<[:SELected]|:DIGital856>

Function

Sets/queries the cell band (see Cell Band ).

The optional [:SELected] keyword in this command specifies that the cell band being set/queried applies to the current system type (see System Type ).

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Test Application Revision: A.06 and above: added USPCs1900
Lab Application Revision: A.03 and above: added USPCs1900

Setting

Range: IMT2000|JCDMa|KPCS|NMT450|SECondary800|USCellular|USPCsr|USPCs1900

Query

Range: IMT2000|JCDM|KPCS|NMT450|SEC800|USC|USPC|USPC1900

*RST Setting

USPC

Programming Example

OUTPUT 714;"CALL:BAND KPCS"
!Selects the Korean PCS cell band.


CALL:CCHannel

CALL:CCHannel

Diagram Conventions

CALL:CCHannel:DRATe

Function

 Sets/queries the rate used on the Control Channel. See Control Channel Data Rate .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range:

  • BPS38400: 38.4 kbps
  • BPS76800: 76.8 kbps

Query

 Same as setting

*RST Setting

 BPS76800

Programming Example

OUTPUT 714;"CALL:CCHannel:DRATe BPS38400"
! Sets the Control Channel data rate to 38.4 kbps.

CALL:CCHannel:PCCCycle[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the Preferred Control Channel Cycle and (2) turns the Preferred Control Channel Cycle state to on (Preferred Control Channel Cycle enabled). The query form returns the Preferred Control Channel Cycle.

This setting is used only when the preferred control channel cycle control is set to AN Specified control mode (see CALL[:CELL]:CONTrol:CATTribute:ISTate:PCCCycle ).

This is a "Configurable Attribute" that is set during session negotiation. See Preferred Control Channel Cycle for details.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

 Range/Resolution: see CALL:CCHannel:PCCCycle:NUMBer .

Query

 Range/Resolution: see CALL:CCHannel:PCCCycle:NUMBer .

*RST Setting

 OFF, and see CALL:CCHannel:PCCCycle:NUMBer .

Programming Example

OUTPUT 714;"CALL:CCHannel:PCCCycle 9000"
! Sets the Preferred Control Channel Cycle state to ON and
! sets Preferred Control Channel Cycle to 9000.

CALL:CCHannel:PCCCycle:NUMBer

Function

Sets/queries the Preferred Control Channel Cycle value.

It is used only when the preferred control channel cycle is enabled ( CALL:CCHannel:PCCCycle:STATe ) and the preferred control channel cycle control is set to AN Specified control mode (see CALL[:CELL]:CONTrol:CATTribute:ISTate:PCCCycle ).

This is a "Configurable Attribute" that is set during session negotiation. See Preferred Control Channel Cycle for details.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0 to 32767

Resolution: 1 cycle

Query

 Same as setting

*RST Setting

 8096

Programming Example

OUTPUT 714;"CALL:CCHannel:PCCCycle:NUMBer 9000"
! Sets the Preferred Control Channel Cycle to 9000.

CALL:CCHannel:PCCCycle:STATe

Function

Sets/queries the Preferred Control Channel Cycle enable state. Preferred control channel cycle is disabled (off) by default. If your AT supports sleep mode, you can enable (turn on) preferred control channel cycle and set a proper value for your AT (see CALL:CCHannel:PCCCycle:NUMBer .)

This is a "Configurable Attribute" that is set during session negotiation. See Preferred Control Channel Cycle for details.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 OFF

Programming Example

OUTPUT 714;"CALL:CCHannel:PCCCycle:STATe ON"
! Enables Preferred Control Channel Cycle.


CALL:CCODe

CALL:CCODe

Diagram Conventions

CALL[:CELL]:CCODe

Function

Sets/queries the Color Code. See Color Code .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0 to 255

Resolution: integer

Query

 Same as setting

*RST Setting

 64

Programming Example

OUTPUT 714;"CALL:CCODe 80"
! Sets the Color Code to 80


CALL:CHANnel

CALL:CHANnel

Diagram Conventions

CALL:CHANnel<[:SELected]|:DIGital856>
<[:SELected]|:IMT2000|:JCDMa|:KPCS|:NMT450|:SECondary800|:USCellular|:USPCs|:USPCs1900>

Function

Sets/queries the physical channel number for the specified system type and specified cell band.

The first optional [:SELected] keyword in this command specifies that the channel being set/queried applies to the current system type (see System Type ).

The second optional [:SELected] keyword in this command specifies that the channel being set/queried applies to the current cell band (see Cell Band ).

Specifying a non-current band when setting a channel number will cause the test set to store the channel number for use when the specified band is made current. Also, specifying a non-current band when querying a channel number will return a stored channel number that is not the current channel the test set is transmitting.

To set (make current) a cell band or query the current cell band, use the CALL:BAND command.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Test Application Revision: A.05 and above: channel range of USCellular added 1024 to 1323
Lab Application Revision: A.02.10 and above: channel range of USCellular added 1024 to 1323
Test Application Revision: A.06 and above: Support USPCs1900 channels
Lab Application Revision: A.03 and above: Support USPCs1900 channels

Setting

Range:

  • IMT2000: 0 to 1199

  • JCDMa: 1 to 799, 801 to 1039, 1041 to 1199, 1201 to 1600

  • KPCS: 0 to 599

  • NMT450: 1 to 300, 539 to 871, 1039 to 1473, 1792 to 2016

  • SECondary800: 0 to 919

  • USCellular: 1 to 799, 991 to 1023, 1024 to 1323

  • USPCs: 0 to 1199

  • USPCs1900: 0 to 1299

Resolution: integer

Query

 Same as setting

*RST Setting
  • [:SELected]: 525 (because *RST causes the band to be set to US PCS)
  • IMT2000: 525
  • JCDMa: 76
  • KPCS: 325
  • NMT450: 210
  • SECondary800: 820
  • USCellular: 384
  • USPCs: 525
  • USPCs1900: 525

Programming Example

OUTPUT 714;"CALL:CHANNEL?"
! Queries the channel number of the current system and band.

OUTPUT 714;"CALL:CHANNEL 384"
! Sets the channel number of the current system and band to 384.

OUTPUT 714;"CALL:CHANNEL:DIGital856:KPCS 384"
! Sets the channel number for the Digital 856 system and Korean PCS band to 384.
! If this system and band are not current, the value 384 is stored
! and will be transmitted when Digital856 and Korean PCS are current.


CALL:CLPControl

CALL:CLPControl

Diagram Conventions

CALL[:CELL[1]]:CLPControl:REVerse:MODE<[:SELected]|:TA856>

Function

Sets/queries the reverse closed loop power control mode. See Reverse Closed Loop Power Control .

NOTE
In a fast switching application (such as E1985E), the :SELect, :TA856 and :TA2000 format mnemonics access the same shared setting value. It is recommended to use the CALL:CLPControl:REVerse:MODE (without any format mnemonic) to set the reverse closed loop power control mode.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: ACTive|ALTernating|DOWN|UP
(ACTive is not available in IS-856 Test Operating Mode .)

Query

Range: ACT|ALT|DOWN|UP
(ACT is not available in IS-856 Test Operating Mode .)

*RST Setting

 ACT

Programming Example

OUTPUT 714;"CALL:CLPControl:REVerse:MODE ALT"
! Sets the closed loop power control mode to alternating up/down bits.

CALL[:CELL[1]]:CLPControl:REVerse:PCSTep

Function

Sets/queries the reverse closed loop power control step size. See Power Control Step .

This is a "Configurable Attribute" that is set during session negotiation. Its value can not be changed while call limit mode is on (see Call Limit Mode ).

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range:

  • DB1: 1 dB
  • DBHalf: 0.5 dB

Query

Range: DB1|DBH

*RST Setting

 DB1

Programming Example

OUTPUT 714;"CALL:CLPControl:REVerse:PCSTep DBHalf"
! Sets the closed loop power control step size to 0.5 dB.


CALL:CONNected

CALL:CONNected

Diagram Conventions

CALL:CONNected:DROP:TIMer[:STATe]<[:SELected]|:TA856>

Function

Sets/queries the call drop timer state (turns the call drop timer on/off, or queries whether it's on/off). See Call Drop Timer .

Requirements

 Test Application Revision: A.01.20
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

ON

Programming Example

OUTPUT 714;"CALL:CONNected:DROP:TIMer 0"
! Turns the call drop timer off

CALL:CONNected:LIMit[:STATe]<[:SELected]|:TA856>

Function

Sets/queries the call limit mode state (turns call limit mode on/off, or queries whether it's on/off). See Call Limit Mode .

NOTE
In a fast switching application (such as E1987A), the :TA856 and :TA2000 format mnemonics access the same shared setting value while the :WCDMA format mnemonic accesses a separate setting value. If you do not add a format mnemonic to the CALL:CONNected:LIMit command, the command is sent to the active format.

Requirements

 Test Application Revision: A.01.20
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

OFF

Programming Example

OUTPUT 714;"CALL:CONNected:LIMit 1"
! Turns call limit mode on


CALL:CONTrol

CALL:CONTrol

Diagram Conventions

CALL[:CELL]:CONTrol:CATTribute:ISTate:PCCCycle

Function

Sets/queries the session negotiation control mode for the preferred control channel cycle (PCCC). If set to ANSPecified, the PCCC value is configured by CALL:CCHannel:PCCCycle[:SNUMber] . If set to ATSPecified, the PCCC value is configured by the AT requested value in the Configuration Request message.

The PCCC currently configured for the session can be queried with CALL:STATus:CCHannel:PCCCycle:STATe? and CALL:STATus:CCHannel:PCCCycle:NUMBer? .

See Preferred Control Channel Cycle

Requirements

 Test Application Revision: A.05 and above
Lab Application Revision: A.01 and above

Setting

Range: ANSPecified|ATSPecified

Query

 Range: ANSP|ATSP

*RST Setting

ANSP

Programming Example

OUTPUT 714;"CALL:CONTrol:CATTribute:ISTate:PCCCycle ATSP"
!Sets preferred control channel cycle session control mode
!to AT Specified.

CALL[:CELL]:CONTrol:CATTribute:RTCMac3:DARTe:KBPS1843[:SUPPort]

Function

Sets/queries the session negotiation control mode for the Rate1M8Support attribute. See Rate 1M8 Supported Control for details.

The Rate1M8Support attribute value to be negotiated for the session or being configured for an open session can be queried with CALL:STATus:MS:TRAFfic:DRATe:KBPS1843[:SUPPort]? .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: ANSPecified|ATSPecified

Query

 Range: ANSP|ATSP

*RST Setting

ANSP

Programming Example

OUTPUT 714;"CALL:CONTrol:CATTribute:RTCMac3:DARTe:KBPS1843 ATSP"
!Sets Rate 1M8 Supported session control mode
!to AT Specified.

CALL[:CELL]:CONTrol:DOWNlink:FREQuency:AUTO

Function

Sets/queries whether the user or the base station emulator is in control of the RF generator's CDMA forward channel frequency setting. It is available in CW Operating Mode and IS-856 Test Operating Mode .

If set to on (1), the base station emulator is in control and the frequency will automatically be set by the test set. This is done by mapping the selected CDMA physical channel number to a frequency as defined in applicable standards.

If set to off (0), the forward channel frequency is directly settable. Refer to CALL[:CELL]:RFGenerator:FREQuency to set the CDMA forward channel frequency.

Requirements

 Test Application Revision: A.05 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

1 (auto)

Programming Example

OUTPUT 714;"CALL:CONTrol:DOWNlink:FREQuency:AUTO OFF"
!Enables manual control of RF generator frequency.


CALL:CSTime

CALL:CSTime

Diagram Conventions

CALL[:CELL]:CSTime:DATE

Function

Sets/queries the date portion of the CDMA system time. The CDMA system time starts at what you set (or internal RTC time when shipped from the factory) and keeps going as a UTC time (Universal Coordinated Time) without leap seconds.

It is set/returned in three comma-separated values, in the order of <year>, <month> and <date>.

The CDMA system time consists of the date and time portions while the time portion is specified by CALL[:CELL]:CSTime:TIME .

See CDMA System Time for details.

Setting

Range: from January 6, 1980 to January 5, 2080 where

  • <year> 1980 to 2080,
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

Query

Range: from January 6, 1980 to January 5, 2096 where

  • <year> 1980 to 2096
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

or -1,-1,-1 is returned when the test set is not in Active Cell or IS-856 Test Mode operating mode.

Requirement

Test Application Revision: A.05 and above
Lab Application Revision: A.02 and above

*RST Setting

CDMA system time keeps going as the UTC time without leap seconds and is not affected by *RST.

Programming Example

OUTPUT 714;"CALL:CSTime:DATE 2005,8,1"
!Sets the date to August 1, 2005.
OUTPUT 714;"CALL:CSTime:DATE?"
!Returns +2005,+8,+1 if the date in the test set happens to be August 2, 2005 when queired.

CALL[:CELL]:CSTime:LOCal:LEAP

Function

Sets/queries the number of leap seconds since the start of CDMA system time.

See Leap Seconds for details.

Setting

Range: 0 to 255

Resolution: 1 second

Query

Range: same as setting

Requirement

Test Application Revision: A.05 and above
Lab Application Revision: A.02 and above

*RST Setting
  • 0 (when shipped from the factory)
  • What you set is stored in the NVRAM and is not affected by *RST.

Programming Example

OUTPUT 714;"CALL:CSTime:LOCal:LEAP 231"
!Sets the leap seconds to 231 seconds.

CALL[:CELL]:CSTime:LOCal:OFFSet[:SELected]

Function

Sets/queries the local time offset from CDMA system time for the currently selected application.

It is set/returned in two comma-separated values, in the order of <hour> and <minute>.

See IS856 Local Time Offset (hh.mm) for details.

Setting

Range:

  • <hour> -17 to 17
  • <minute> 0 to 59

Resolution: 1 minute

Query

Range: same as setting

Requirement

Test Application Revision: A.05 and above
Lab Application Revision: A.02 and above

*RST Setting
  • 0 (when shipped from the factory)
  • What you set is stored in the NVRAM and is not affected by *RST.

Programming Example

OUTPUT 714;"CALL:CSTime:LOCal:OFFSet 2,0"
!Sets local time offset to 2 hours.

CALL[:CELL]:CSTime:LOCal:OFFSet:TA856

Function

Sets/queries the local time offset from CDMA system time when using the 1xEV-DO application.

It is set/returned in two comma-separated values, in the order of <hour> and <minute>.

See IS856 Local Time Offset (hh.mm) for details.

Setting

Range:

  • <hour> -17 to 17
  • <minute> 0 to 59

Resolution: 1 minute

Query

Range: same as setting

Requirement

Test Application Revision: A.05 and above
Lab Application Revision: A.02 and above

*RST Setting
  • 0 (when shipped from the factory)
  • What you set is stored in the NVRAM and is not affected by *RST.

Programming Example

OUTPUT 714;"CALL:CSTime:LOCal:OFFSet:TA856 2,0"
!Sets local time offset to 2 hours.

CALL[:CELL]:CSTime:TIME

Function

Sets/queries the time portion of the CDMA system time. The CDMA system time starts at what you set (or internal RTC time when shipped from the factory) and keeps going as a UTC time (Universal Coordinated Time) without leap seconds.

It is set/returned in three comma-separated values, in the order of <hour>, <minute> and <second>.

The CDMA system time consists of the date and time portions while the date portion is specified by CALL[:CELL]:CSTime:DATE .

See CDMA System Time for details.

Setting

Range: Any time of a day where

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

Resolution: 1 second

Query

Range: Any time of a day where

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

or -1,-1,-1 is returned when the test set is not in Active Cell or IS-856 Test Mode operating mode.

Requirement

Test Application Revision: A.05 and above
Lab Application Revision: A.02 and above

*RST Setting

CDMA system time keeps going as a UTC time without leap seconds and is not affected by *RST.

Programming Example

OUTPUT 714;"CALL:CSTime:TIME 7,30"
!Sets the time of CDMA system time to 7:30.
OUTPUT 714;"CALL:CSTime:TIME?"
!Returns +7,+32,+19 if the time in the test set happens to be 7:32:19 when queried.


CALL:DCONnected

CALL:DCONnected

Diagram Conventions

CALL:DCONnected[:STATe]?

Function

This command queries whether or not the data connection is in the connected state (see Connected State for a description of this data connection state).

When the query is sent:

  • If the data connection is in the connected state, the query immediately returns a 1.
  • If the data connection is in any other non-transitory state, the query immediately returns a 0.
    • See TAP/ETAP Data Connection Processing Lifecycle for information about which states are transitory and non-transitory when the test set is configured to use the Test Application protocols (see Test Application Protocol ).
    • ( Lab Application Only) See Packet Data Connection Processing States Lifecycle for information about which states are transitory and non-transitory when the test set is configured to use the Default Packet Application (see Session Application Type ).
  • If the data connection is in a transitory state, the query waits until the data connection reaches a non-transitory state, and then returns a 1 if the state is connected or a 0 if the state is any other non-transitory state.

NOTE
The query will hang as long as the data connection is in a transitory state. However, the AT includes protocol timers which limit the time it may stay in a transitory state. So, the AT should force the connection to return to a non-transitory state after its protocol timers expire, and so the query will not hang forever.

The query behaves differently if the data connection state change detector (see Data Connection State Change Detector ) is armed when the query is sent:

  • If the data connection is in a non-transitory state, the query hangs until the data connection state reaches a different non-transitory state, then returns a 1 if the state is connected or a 0 if the state is any other non-transitory state. For example, if the data connection is in the connected state when the query is sent, the query hangs until the data connection leaves the connected state, reaches another non-transitory state such as idle or session open, and then returns a 0.
  • If the data connection is in a transitory state, the query hangs until the data connection reaches a non-transitory state, and then returns a 1 if the state is connected or a 0 if the state is any other non-transitory state.

NOTE
If the data connection state change detector timeout (see Data Connection State Change Detector ) expires before the data connection moves to a different non-transitory state, then the change detector is disarmed, which releases the query. The query will then immediately return a 1 for connected, 0 for idle or session open, or hang until any non-transitory state is reached or the AT protocol timers expire.

Using the CALL:DCONnected? query in conjunction with the data connection state change detector is useful in determining whether an attempt to open a connection has been successful. See Open a Connection from the Test Set and Data Connection State Synchronization .

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 1|0

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:DCONnected:STATe?"
! Queries whether the data connection state is connected.

CALL:DCONnected:ARM[:IMMediate]

Function

Arms the data connection state change detector. See Data Connection State Change Detector .

This is an overlapped command, and therefore has a Pending Operation Flag (POF) associated with it. The POF is set when the change detector is armed, and cleared when the change detector is disarmed. See Data Connection Processing Event Synchronization for more information about the behavior of overlapped commands.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DCONnected:ARM"
! Arms the data connection state change detector.

CALL:DCONnected:ARM:STATe?

Function

Queries the arm state of the data connection state change detector.

This command never hangs and immediately returns a one if the detector is armed, or a zero if the detector is not armed. See Data Connection State Change Detector .

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 1|0

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:DCONnected:ARM:STATe?"
! Returns the arm state of the data connection state change detector.

CALL:DCONnected:TIMeout

Function

Sets/queries the maximum time the test set will wait for the data connection state change detector to become disarmed (see Data Connection State Change Detector ).

Default setting units are seconds. To set timeout time in units other than seconds, include an optional unit specifier in the command string.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0 to 100 seconds
Resolution: 0.1 seconds

Query

Same as setting

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"CALL:DCONnected:TIMeout 3"
! Sets the CALL:DCONnected:STATe? query timeout time to 3 seconds.

OUTPUT 714;"CALL:DCONnected:TIMeout 500 MS"
! Sets the Sets the CALL:DCONnected:STATe? query timeout time to 500 milliseconds.


CALL Subsystem

CALL Subsystem

Description

The CALL subsystem handles all setup, control and query functions for data connection processing. This includes access terminal (AT) and access network (AN) functions.

Syntax Diagrams and Command Descriptions

CALL:APARameter CALL:MACCHannel
CALL:APPLication CALL:MCCode
CALL:AWGNoise CALL:MS
CALL:BAND CALL:OPERating:MODE
CALL:CCHannel CALL:PARameter:SECTor
CALL:CCODe | CALL:PLOGging ( Lab Application Only )
CALL:CHANnel CALL:PNOFfset
CALL:CLPControl CALL:POWer
CALL:CONNected CALL:PROTocol
CALL:CONTrol

CALL:RFGenerator
CALL:COUNt ( Lab Application Only )

CALL:SCLose
CALL:COUNt:DTMonitor ( Lab Application Only )

CALL:SETup
CALL:CSTime

CALL:SOPen?
CALL:DATA ( Lab Application Only )

CALL:STATus
CALL:DCONnected

CALL:TEST856

CALL:DORMant ( Lab Application Only ) | CALL:TOTal:POWer
CALL:FUNCtion:DATA

CALL:TRIGger


CALL:FUNCtion:DATA

CALL:FUNCtion:DATA

Diagram Conventions

CALL:FUNCtion:DATA:DORMant

Function

This command causes the test set to release the physical connection (traffic channel), but attempt to maintain the PPP connection with the AT. It may result in the data connection state going to Dormant. See Dormant State .

To verify the data connection status, see Data Connection State Synchronization .

Requirements

 Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FUNCtion:DATA:DORMant"
!Force data connection to dormant state.

CALL:FUNCtion:DATA:STARt

Function

Start Data causes the test set to Page the AT (when there is an active session open). This starts a data connection. See Paging State .

This is an overlapped command, and therefore has a Pending Operation Flag (POF) associated with it. See Data Connection Processing Event Synchronization for more information about the behavior of overlapped commands.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FUNCtion:DATA:STARt"
! Starts a data connection.

CALL:FUNCtion:DATA:STOP

Function

End Data causes the test set to close the currently active data connection. See Connection Closing State .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:FUNCtion:DATA:STOP"
! Ends the data connection.


CALL:HANDoff

CALL:HANDoff

May 24, 2006

Diagram Conventions

CALL:HANDoff[:IMMediate]

Function

Initiates a handoff to:

  • the handoff system type (see System Type ).

  • the handoff cell band selected by the CALL:SETup:BAND command (see CALL:SETup ).

  • the handoff physical channel selected by the CALL:SETup:CHANnel command (see CALL:SETup ).

See Handoff for more information about handoffs.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:HANDoff"
!initiates a handoff to the current handoff cell band and current handoff channel.


CALL:IDLE:DATA?

CALL:IDLE:DATA?

Last updated: May 24, 2006

Diagram Conventions

CALL:IDLE[:STATe]:DATA?

Function

This command queries whether or not the data connection is in the idle state (see Idle State for a description of this data connection state).

When the query is sent:

  • If the data connection is in the idle state, the query immediately returns a 1.
  • If the data connection is in any other non-transitory state, the query immediately returns a 0 (see TAP/ETAP Data Connection Processing Lifecycle for information about which states are non-transitory).
  • If the data connection is in a transitory state, the query waits until the data connection reaches a non-transitory state, and then returns a 1 if the state is idle or a 0 if the state is any other non-transitory state.

NOTE
The query will hang as long as the data connection is in a transitory state. However, the AT includes protocol timers which limit the time it may stay in a transitory state. So, the AT should force the connection to return to a non-transitory state after its protocol timers expire, and so the query will not hang forever.

The query behaves differently if the data connection state change detector (see Data Connection State Change Detector ) is armed when the query is sent:

  • If the data connection is in a non-transitory state, the query hangs until the data connection state reaches a different non-transitory state, then returns a 1 if the state is idle or a 0 if the state is any other non-transitory state. For example, if the data connection is in the idle state when the query is sent, the query hangs until the data connection leaves the idle state, reaches another non-transitory state such as session open or connected, and then returns a 0.
  • If the data connection is in a transitory state, the query hangs until the data connection reaches a non-transitory state, and then returns a 1 if the state is idle or a 0 if the state is any other non-transitory state.

NOTE
If the data connection state change detector timeout (see Data Connection State Change Detector ) expires before the data connection moves to a different non-transitory state, then the change detector is disarmed, which releases the query. The query will then immediately return a 1 for idle, 0 for session open or connected, or hang until any non-transitory state is reached or the AT protocol timers expire.

Using the CALL:IDLE:DATA? query in conjunction with the data connection state change detector is useful in determining whether an attempt to close a session has been successful. See Close the Session and Data Connection State Synchronization .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Query Range: 1|0

*RST Setting

 1

Programming Example

OUTPUT 714;"CALL:IDLE:DATA?"
!Queries whether the Data Connection state is idle.


CALL:MACCHannel

CALL:MACCHannel

Diagram Conventions

CALL:MACChannel:ARQ:LEVel

Function

Sets/queries the power level of H-ARQ/L-ARQ Channel relative to the current Cell Power when current physical layer subtype is Subtype 2. See H-ARQ/L-ARQ Channel Level .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: -30 to -6 dB
Resolution: 0.01 dB

Query

Range: same as setting

*RST Setting

-9 dB

Programming Example

OUTPUT 714;"CALL:MACChannel:ARQ:LEVel -10"
! Sets H-ARQ/L-ARQ Channel Level to -10 dB.

CALL:MACChannel:ARQ:ACK:DATA[:REVerse][:AFTer]

Function

Sets/queries when the test set starts to send ACK bit on the forward ARQ channel upon receiving the reverse data subpackets. It is applicable only when the test set is operating at physical layer subtype 2. See ACK R-Data After for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: SUBPacket0|SUBPacket1|SUBPacket2|SUBPacket3|NEVer

Query

Range: SUBP0|SUBP1|SUBP2|SUBP3|NEV

*RST Setting

NEVer (All NAK)

Programming Example

OUTPUT 714;"CALL:MACChannel:ARQ:ACK:DATA SUBPacket1"
! Sets the test set to start send ACK bit
! on the forward ARQ channel after receiving
! subpacket 1.

CALL:MACChannel:HARQ:MODulation

Function

Sets/queries the modulation type used to transmit the H-ARQ channel when the current physical layer subtype is Subtype 2. BPSKeying represents Bi-Polar Keying mode and OOKeying represents On-Off Keying mode. See H-ARQ Modulation for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: BPSKeying|OOKeying

Query

Range: BPSK|OOK

*RST Setting

BPSK

Programming Example

OUTPUT 714;"CALL:MACChannel:HARQ:MODulation OOK"
! Sets H-ARQ Channel Modulation Type to On-Off Keying.

CALL:MACChannel:PARQ:LEVel

Function

Sets/queries the power level of P-ARQ Channel relative to the current Cell Power when current physical layer subtype is Subtype 2. See P-ARQ Channel Level .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: -30 to -6 dB
Resolution: 0.01 dB

Query

Range: same as setting

*RST Setting

-9 dB

Programming Example

OUTPUT 714;"CALL:MACChannel:PARQ:LEVel -10"
! Sets P-ARQ Channel Level to -10 dB.

CALL:MACChannel:RPControl:LEVel

Function

Sets/queries the power level of RPC Channel relative to the current Cell Power when current physical layer subtype is Subtype 2. See RPC Channel Level .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: -30 to -6 dB
Resolution: 0.01 dB

Query

Range: same as setting

*RST Setting

-9 dB

Programming Example

OUTPUT 714;"CALL:MACChannel:RPControl:LEVel -10"
! Sets RPC Channel Level to -10 dB.


CALL:MCCode

CALL:MCCode

May 24, 2006

Diagram Conventions

CALL[:CELL]:MCCode<[:SELected]|:TA856>

Function

Sets/queries the country code. See Country Code .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0 to 999

Resolution: integer

Query

 Same as setting

*RST Setting

 310

Programming Example

OUTPUT 714;"CALL:MCCode 320"
! Sets the country code to 320.


CALL:MS

CALL:MS

Last updated: July 26, 2006

Diagram Conventions

CALL:MS:ACKGain[:RTPilot]

Function

Sets/queries Ack Channel Gain. See ACK Channel Gain .

Requirements:

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: -3 to +6 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 3 dB

Programming Example

OUTPUT 714;"CALL:MS:ACKGain 4"
! Sets the Ack Channel gain to +4 dB.

CALL:MS:APGain[:RTTRaffic]

Function

Sets/queries the power level of the R-Auxiliary Pilot channel relative to the power of the R-Data channel. It is used by the AT to compute the transmit power of the R-Auxiliary Pilot channel if transmitted. For details, see Auxiliary Pilot Channel Gain .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: -15 to 0 dB
Resolution: 1 dB

Query

Range: same as setting

*RST Setting

-12 dB

Programming Example

OUTPUT 714;"CALL:MS:APGain -10"
! Sets R-Auxiliary Pilot Channel Level relative to
! R-Data channel to -10 dB.

CALL:MS:APPayload[:MINimum]

Function

Sets/queries the minimum R-Data payload size at which point the AT is required to transmit the R-Aux Pilot channel. See Auxiliary Pilot Channel Min Payload for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: BIT128|BIT256|BIT512|BIT768|BIT1024|BIT1536|BIT2048|BIT3072
|BIT4096|BIT6144|BIT8192|BIT12288

Query

Range: same as setting

*RST Setting

BIT3072

Programming Example

OUTPUT 714;"CALL:MS:APPayload BIT2048"
! Sets R-Aux Pilot minimum payload size to 2048 bits.

CALL:MS:DOFFset:NOMinal

Function

Sets/queries Data Offset Nom. See Data Offset Nom .

This is a "Configurable Attribute" that is set during session negotiation. Its value can not be changed while call limit mode is on (see Call Limit Mode ).

Requirements:

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: -4.0 to +3.5 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 0 dB

Programming Example

OUTPUT 714;"CALL:MS:DOFFset:NOMinal -2.5"
!Sets the nominal offset to -2.5 dB.

CALL:MS:DOFFset<:BPS9600|:BPS19200|:BPS38400|:BPS76800|:BPS153600>

Function

Sets/queries Data Offset <rate>. See Data Offset 9k6|19k2|38k4|76k8|153k6 .

This is a "Configurable Attribute" that is set during session negotiation. Its value can not be changed while call limit mode is on (see Call Limit Mode ).

Requirements:

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: -2.0 to +1.75 dB

Resolution: 0.25 dB

Query

 Same as setting

*RST Setting

 0 dB

Programming Example

OUTPUT 714;"CALL:MS:DOFFset:BPS38400 -1.5"
! Sets the Data Offset 38k4 to -1.5 dB.

CALL:MS:DRCGain[:RTPilot]

Function

Sets/queries the DRC Channel gain. See DRC Channel Gain .

Requirements:

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: -9 to +6 dB

Resolution: 0.5 dB

Query

 Same as setting

*RST Setting

 3 dB

Programming Example

OUTPUT 714;"CALL:MS:DRCGain 4"
! Sets the DRC Channel gain to +4 dB.

CALL:MS:DSCGain[:RTPilot]

Function

Sets/queries the power of the R-DSC channel relative to the power of the R-Pilot channel. The R-DSC channel is expected to be transmitted from the AT when operating at physical layer subtype 2. See DSC Channel Gain .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: -15.5 to 0 dB
Resolution: 0.5 dB

Query

Range: same as setting

*RST Setting

-9 dB

Programming Example

OUTPUT 714;"CALL:MS:DSCGain -10"
! Sets R-DSC Channel Level relative to
! R-Pilot channel to -10 dB.

CALL:MS:DSCLength[:SLOTs]

Function

Sets/queries the length of a single DSC transmission (in units of 8 slots). See DSC Length .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: 8, 16, 24, 32, 40, 48, 56, 64, 72, 80, 88, 96, 104, 112, 120, 128, 136, 144, 152,
160, 168, 176, 184, 192, 200, 208, 216, 224, 232, 240, 248, 256

Query

Range: same as setting

*RST Setting

64 (slots)

Programming Example

OUTPUT 714;"CALL:MS:DSCLength 16"
! Sets R-DSC transmission duration to 16 slots.

CALL:MS:IP:ADDRess

Function

Sets/queries the IP address for a wireless device (such as an access terminal). See DUT IP Address for details.

This setting is stored in nonvolatile RAM and will NOT be changed by a reset, power cycle operations.

This setting has no effect if the CALL:DATA:PDSNode:EXTernal:STATe is set to On.

Requirements

Lab Application Revision: A.01 and above

Setting

Range: 15 characters formatted as follows: A.B.C.D.
The range of values for A= 0 to 126 and 128 to 223. The range of values for B,C, D = 0 to 255 (no embedded spaces).

Query

Range: same as setting.

*RST Setting
  • 0.0.0.1 (when shipped from the factory)
  • the value last set and stored in the nonvolatile RAM

Programming Example

OUTPUT 714;"CALL:MS:IP:ADDRess `130.29.179.219'"
!Sets the DUT IP Address to 130.29.179.219.

CALL:MS:PDRop

Function

Sets/queries the Pilot Drop parameter. See Pilot Drop .

Requirements:

 Test Application Revision: A.01.37 and above
Lab Application Revision: A.01 and above

Setting

Range: 0 to 63

Resolution: 1

Query

 Same as setting

*RST Setting

 18

Programming Example

OUTPUT 714;"CALL:MS:PDRop 28"
! Sets Pilot Drop to 28 (-14 dB).

CALL:MS:POWer:MAXimum
<[:SELected]|:IMT2000|:JCDMa|:KPCS|:NMT450|:SECondary800|:USCellular|:USPCs|:USPCs1900>

Function

Sets/queries the maximum power expected from the AT for the specified band. See AT Max Power .

The optional [:SELected] keyword in this command specifies that the maximum power being set or queried applies to the current cell band (see Cell Band ).

Requirements:

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Test Application Revision: A.06 and above: Support USPCs1900
Lab Application Revision: A.03 and above: Support USPCs1900

Setting

Range: (DBM8 = +8 dBm, for example)

  • IMT2000: DBM8|DBM13|DBM18|DBM20|DBM23|DBM28
  • JCDMa: DBM23|DBM27|DBM31
  • KPCS: DBM8|DBM13|DBM18|DBM23|DBM28
  • NMT450: DBM18|DBM23|DBM28|DBM33
  • SECondary800: DBM23|DBM27
  • USCellular: DBM23|DBM27|DBM31
  • USPCs: DBM8|DBM13|DBM18|DBM23|DBM28
  • USPCs1900: DBM8|DBM13|DBM18|DBM23|DBM28

Query

 Same as setting

*RST Setting
  • [:SELected]: DBM23 (because *RST causes the IS-856 Band to be set to US PCS)
  • IMT2000: DBM18
  • JCDMa, KPCs, NMT450, SECondary800, USCellular, USPCs, USPCs1900: DBM23

Programming Example

OUTPUT 714;"CALL:MS:POWer:MAXimum DBM28"
! Sets the AT Max Power for the currently selected band to +28 dBm.

OUTPUT 714;"CALL:MS:POW:MAXimum:KPCS DBM13"
! Sets the AT Max Power for Korean PCS band to +13 dBm.

CALL:MS:REPorted:HIDentity[:DECimal]?

Function

Queries the Decimal Hardware ID. It returns as a string. See Hardware ID .

Requirements:

Test Application Revision: A.01.20 and above
Test Application Revision: A.05 and above: query range changes

Lab Application Revision: A.01 and above
Lab Application Revision: A.02.10 and above: query range changes

Query

Range:

  • "" (Null) (when a Hardware ID is not reported)
  • 12 characters in the form "xxx-xxxxxxx" where the x's are characters from the set 0123456789 (when Hardware ID Type = 0x010000 for ESN)
  • 19 characters in the form of "xxxxxxxxxx-xxxxxxxx", where the x's are characters from the set 0123456789 (when Hardware ID Type = 0x00FFFF for MEID) - added since Test Application A.05 and Lab Application A.02.10
  • "0" to "4294967295" (1 to 10 characters from the set 0123456789) (when Hex Hardware ID Type = 0x00NNNN for IETF RFC 1700 standard)
  • "0" to "72057594037927935" (1 to 17 characters from the set 0123456789) (when Hex Hardware ID Type is invalid) - added since Test Application A.05 and Lab Application A.02.10

*RST Setting

 "" (Null)

Programming Example

OUTPUT 714;"CALL:MS:REPorted:HIDentity?"
! Queries the Decimal Hardware ID.

CALL:MS:REPorted:HIDentity:HEX?

Function

Queries the HardwareIDValue reported by the AT in hexadecimal format. It returns as a string. See Hardware ID .

Requirements:

Test Application Revision: A.01.20 and above
Test Application Revision: A.05 and above: query range added "0x00000000000000" to "0xFFFFFFFFFFFFFF"

Lab Application Revision: A.01 and above
Lab Application Revision: A.02.10 and above: query range added "0x00000000000000" to "0xFFFFFFFFFFFFFF"

Query

Range:

  • "" (Null)
  • "0x00000000" to "0xFFFFFFFF" (0x plus 8 characters from the set 0123456789ABCDEF)
    (Hardware ID Type = 0x010000 for ESN, or Hardware ID Type = 0x00NNNN for IETF RFC 1700 standard)
  • "0x00000000000000" to "0xFFFFFFFFFFFFFF" (0x plus 14 characters from the set 0123456789ABCDEF)
    (Hardware ID Type = 0x00FFFF for MEID or invalid)

*RST Setting

 "" (Null)

Programming Example

OUTPUT 714;"CALL:MS:REPorted:HIDentity:HEX?"
! Queries the Hex Hardware ID.

CALL:MS:REPorted:HIDentity:TYPE?

Function

Queries the Hardware ID Type received from the AT. See Hardware ID Type for details.

Requirements:

Test Application Revision: A.01.20 and above
Test Application Revision: A.05 and above: added "0x00FFFF" return value

Lab Application Revision: A.01 and above
Lab Application Revision: A.02.10 and above: added "0x00FFFF" return value

Query

Range:

  • "" (Null)
  • "0x000000" to "0xFFFFFF" (0x plus 6 characters from the set 0123456789ABCDEF)
    • "0x010000" indicates Hardware ID Type is ESN.
    • "0x00FFFF" indicates Hardware ID Type is MEID
    • "0x00NNNN" indicates a Hardware ID "NNNN" from IETF RFC 1700 standard.
    • "0xFFFFFF" indicates Hardware ID value is null when queried by CALL:MS:REPorted:HIDentity[:DECimal]? or CALL:MS:REPorted:HIDentity:HEX? .
    • all other values are invalid.

*RST Setting

 "" (Null)

Programming Example

OUTPUT 714;"CALL:MS:REPorted:HIDentity:TYPE?"
! Queries Hardware ID Type

CALL:MS:REPorted:SSEed?

Function

Queries the Session Seed. See Session Seed .

Requirements:

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range:

  • '' (0 characters), or
  • 0x followed by 8 characters from the set 0123456789ABCDEF (example: '0x00123ABC')

*RST Setting

 '' (0 characters)

Programming Example

OUTPUT 714;"CALL:MS:REPorted:SSEed?"
! Queries the Session Seed.

CALL:MS:RRIGain[:RTPilot]:TRANsition0:PRE

Function

Sets/queries the RRI Channel Gain Pre-Transition 0 which is used with the current T2P Transition value and current subpacket being transmitted to determine the current gain of the R-RRI Channel (relative to R-Pilot channel). See RRI Gain Parameters for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: - 8 to +7 dB
Resolution: 1 dB

Query

Range: same as setting

*RST Setting

0 dB

Programming Example

OUTPUT 714;"CALL:MS:RRIGain:TRANsition0:PRE -2"
! Sets RRI Channel Gain Pre-Transition 0 to -2 dB.

CALL:MS:RRIGain[:RTPilot]:TRANsition0:POST

Function

Sets/queries the RRI Channel Gain Post-Transition 0 which is used with the current T2P Transition value and current subpacket being transmitted to determine the current gain of the R-RRI Channel (relative to R-Pilot channel). See RRI Gain Parameters for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: - 8 to +7 dB
Resolution: 1 dB

Query

Range: same as setting

*RST Setting

-6 dB

Programming Example

OUTPUT 714;"CALL:MS:RRIGain:TRANsition0:POST -2"
! Sets RRI Channel Gain Post-Transition 0 to -2 dB.

CALL:MS:RRIGain[:RTPilot]:TRANsition1:PRE

Function

Sets/queries the RRI Channel Gain Pre-Transition 1 which is used with the current T2P Transition value and current subpacket being transmitted to determine the current gain of the R-RRI Channel (relative to R-Pilot channel). See RRI Gain Parameters for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: - 8 to +7 dB
Resolution: 1 dB

Query

Range: same as setting

*RST Setting

0 dB

Programming Example

OUTPUT 714;"CALL:MS:RRIGain:TRANsition1:PRE -2"
! Sets RRI Channel Gain Pre-Transition 1 to -2 dB.

CALL:MS:RRIGain[:RTPilot]:TRANsition1:POST

Function

Sets/queries the RRI Channel Gain Post-Transition 1 which is used with the current T2P Transition value and current subpacket being transmitted to determine the current gain of the R-RRI Channel (relative to R-Pilot channel). See RRI Gain Parameters for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: - 8 to +7 dB
Resolution: 1 dB

Query

Range: same as setting

*RST Setting

-6 dB

Programming Example

OUTPUT 714;"CALL:MS:RRIGain:TRANsition1:POST -2"
! Sets RRI Channel Gain Post-Transition 1 to -2 dB.

CALL:MS:RRIGain[:RTPilot]:TRANsition2:PRE

Function

Sets/queries the RRI Channel Gain Pre-Transition 2 which is used with the current T2P Transition value and current subpacket being transmitted to determine the current gain of the R-RRI Channel (relative to R-Pilot channel). See RRI Gain Parameters for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: - 8 to +7 dB
Resolution: 1 dB

Query

Range: same as setting

*RST Setting

-6 dB

Programming Example

OUTPUT 714;"CALL:MS:RRIGain:TRANsition2:PRE -2"
! Sets RRI Channel Gain Pre-Transition 2 to -2 dB.

CALL:MS:RRIGain[:RTPilot]:TRANsition2:POST

Function

Sets/queries the RRI Channel Gain Post-Transition 2 which is used with the current T2P Transition value and current subpacket being transmitted to determine the current gain of the R-RRI Channel (relative to R-Pilot channel). See RRI Gain Parameters for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: - 8 to +7 dB
Resolution: 1 dB

Query

Range: same as setting

*RST Setting

-6 dB

Programming Example

OUTPUT 714;"CALL:MS:RRIGain:TRANsition2:POST -2"
! Sets RRI Channel Gain Post-Transition 2 to -2 dB.

CALL:MS:RRIGain[:RTPilot]:TRANsition3:PRE

Function

Sets/queries the RRI Channel Gain Pre-Transition 3 which is used with the current T2P Transition value and current subpacket being transmitted to determine the current gain of the R-RRI Channel (relative to R-Pilot channel). See RRI Gain Parameters for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: - 8 to +7 dB
Resolution: 1 dB

Query

Range: same as setting

*RST Setting

-6 dB

Programming Example

OUTPUT 714;"CALL:MS:RRIGain:TRANsition3:PRE -2"
! Sets RRI Channel Gain Pre-Transition 3 to -2 dB.

CALL:MS:T2Pilot:BIT128:LLATency:TARGet[:TERMination]

CALL:MS:T2Pilot:BI256:LLATency:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT512:LLATency:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT768:LLATency:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT1024:LLATency:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT1536:LLATency:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT2048:LLATency:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT3072:LLATency:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT4096:LLATency:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT6144:LLATency:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT8192:LLATency:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT12288:LLATency:TARGet[:TERMination]

Function

Sets/queries the target number of subpackets required to successfully transmit a physical traffic packet at the specified packet size and low latency transmission mode. See Termination Target Settings for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: 0 to 3 (subpackets)
Resolution: 1

Query

Range: same as setting

*RST Setting

1 (subpacket)

Programming Example

OUTPUT 714;"CALL:MS:T2Pilot:BIT8192:LLATency:TARGet 2"
! Sets Termination Target value for the configuration with
! 8192 bits packet size and low latency transmission mode to 2 (subpackets).

CALL:MS:T2Pilot:BIT128:LLATency:TRANsition

CALL:MS:T2Pilot:BI256:LLATency:TRANsition

CALL:MS:T2Pilot:BIT512:LLATency:TRANsition

CALL:MS:T2Pilot:BIT768:LLATency:TRANsition

CALL:MS:T2Pilot:BIT1024:LLATency:TRANsition

CALL:MS:T2Pilot:BIT1536:LLATency:TRANsition

CALL:MS:T2Pilot:BIT2048:LLATency:TRANsition

CALL:MS:T2Pilot:BIT3072:LLATency:TRANsition

CALL:MS:T2Pilot:BIT4096:LLATency:TRANsition

CALL:MS:T2Pilot:BIT6144:LLATency:TRANsition

CALL:MS:T2Pilot:BIT8192:LLATency:TRANsition

CALL:MS:T2Pilot:BIT12288:LLATency:TRANsition

Function

Sets/queries the T2P Transition value for the specified packet size and low latency transmission mode. The T2P Transition values determine which TxT2P gain values and which RRI Channel Gain values are used for a subpacket transmitted at the given configuration (packet size and transmission mode). See T2P Transition Settings for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: 0 to 3 (subpackets)
Resolution: 1

Query

Range: same as setting

*RST Setting

1 (subpacket)

Programming Example

OUTPUT 714;"CALL:MS:T2Pilot:BIT8192:LLATency:TRANsition 2"
! Sets T2P Transition value for the configuration with
! 8192 bits packet size and low latency transmission mode to 2 (subpackets).

CALL:MS:T2Pilot:BIT128:LLATency:TRANsition:PRE

CALL:MS:T2Pilot:BI256:LLATency:TRANsition:PRE

CALL:MS:T2Pilot:BIT512:LLATency:TRANsition:PRE

CALL:MS:T2Pilot:BIT768:LLATency:TRANsition:PRE

CALL:MS:T2Pilot:BIT1024:LLATency:TRANsition:PRE

CALL:MS:T2Pilot:BIT1536:LLATency:TRANsition:PRE

CALL:MS:T2Pilot:BIT2048:LLATency:TRANsition:PRE

CALL:MS:T2Pilot:BIT3072:LLATency:TRANsition:PRE

CALL:MS:T2Pilot:BIT4096:LLATency:TRANsition:PRE

CALL:MS:T2Pilot:BIT6144:LLATency:TRANsition:PRE

CALL:MS:T2Pilot:BIT8192:LLATency:TRANsition:PRE

CALL:MS:T2Pilot:BIT12288:LLATency:TRANsition:PRE

Function

Sets/queries the TxT2P Pre-Transition gain for the specified packet size and low latency transmission mode. See TxT2P Gain Settings for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: 0 to 32 dB
Resolution: 0.25 dB

Query

Range: same as setting

*RST Setting

128 bit Low Latency TxT2P Pre-Transition: 7 dB
256 bit Low Latency TxT2P Pre-Transition: 10 dB
512 bit Low Latency TxT2P Pre-Transition: 13 dB
768 bit Low Latency TxT2P Pre-Transition: 14.75 dB
1024 bit Low Latency TxT2P Pre-Transition: 16.25 dB
1536 bit Low Latency TxT2P Pre-Transition: 18.25 dB
2048 bit Low Latency TxT2P Pre-Transition: 19.25 dB
3072 bit Low Latency TxT2P Pre-Transition: 19.25 dB
4096 bit Low Latency TxT2P Pre-Transition: 20.5 dB
6144 bit Low Latency TxT2P Pre-Transition: 21.75 dB
8192 bit Low Latency TxT2P Pre-Transition: 23.25 dB
12288 bit Low Latency TxT2P Pre-Transition: 26.25 dB

Programming Example

OUTPUT 714;"CALL:MS:T2Pilot:BIT8192:LLATency:TRANsition:PRE 20"
! Sets TxT2P Pre-Transition gain for the configuration with
! 8192 bits packet size and low latency transmission mode to 20 dB.

CALL:MS:T2Pilot:BIT128:LLATency:TRANsition:POST

CALL:MS:T2Pilot:BI256:LLATency:TRANsition:POST

CALL:MS:T2Pilot:BIT512:LLATency:TRANsition:POST

CALL:MS:T2Pilot:BIT768:LLATency:TRANsition:POST

CALL:MS:T2Pilot:BIT1024:LLATency:TRANsition:POST

CALL:MS:T2Pilot:BIT1536:LLATency:TRANsition:POST

CALL:MS:T2Pilot:BIT2048:LLATency:TRANsition:POST

CALL:MS:T2Pilot:BIT3072:LLATency:TRANsition:POST

CALL:MS:T2Pilot:BIT4096:LLATency:TRANsition:POST

CALL:MS:T2Pilot:BIT6144:LLATency:TRANsition:POST

CALL:MS:T2Pilot:BIT8192:LLATency:TRANsition:POST

CALL:MS:T2Pilot:BIT12288:LLATency:TRANsition:POST

Function

Sets/queries the TxT2P Post-Transition gain for the specified packet size and low latency transmission mode. See TxT2P Gain Settings for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: 0 to 32 dB
Resolution: 0.25 dB

Query

Range: same as setting

*RST Setting

128 bit Low Latency TxT2P Post-Transition: 0.75 dB
256 bit Low Latency TxT2P Post-Transition: 3.75 dB
512 bit Low Latency TxT2P Post-Transition: 7.0 dB
768 bit Low Latency TxT2P Post-Transition: 8.75 dB
1024 bit Low Latency TxT2P Post-Transition: 10.0 dB
1536 bit Low Latency TxT2P Post-Transition: 11.5 dB
2048 bit Low Latency TxT2P Post-Transition: 13.0 dB
3072 bit Low Latency TxT2P Post-Transition: 14.25 dB
4096 bit Low Latency TxT2P Post-Transition: 15.5 dB
6144 bit Low Latency TxT2P Post-Transition: 17.0 dB
8192 bit Low Latency TxT2P Post-Transition: 18.5 dB
12288 bit Low Latency TxT2P Post-Transition: 21.25 dB

Programming Example

OUTPUT 714;"CALL:MS:T2Pilot:BIT8192:LLATency:TRANsition:POST 20"
! Sets TxT2P Post-Transition gain for the configuration with
! 8192 bits packet size and low latency transmission mode to 20 dB.

CALL:MS:T2Pilot:BIT128:HCAPacity:TARGet[:TERMination]

CALL:MS:T2Pilot:BI256:HCAPacity:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT512:HCAPacity:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT768:HCAPacity:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT1024:HCAPacity:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT1536:HCAPacity:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT2048:HCAPacity:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT3072:HCAPacity:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT4096:HCAPacity:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT6144:HCAPacity:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT8192:HCAPacity:TARGet[:TERMination]

CALL:MS:T2Pilot:BIT12288:HCAPacity:TARGet[:TERMination]

Function

Sets/queries the target number of subpackets required to successfully transmit a physical traffic packet at the specified packet size and high capacity transmission mode. See Termination Target Settings for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: 0 to 3 (subpackets)
Resolution: 1

Query

Range: same as setting

*RST Setting

3 (subpacket)

Programming Example

OUTPUT 714;"CALL:MS:T2Pilot:BIT8192:HCAPacity:TARGet 2"
! Sets Termination Target value for the configuration with
! 8192 bits packet size and high capacity transmission mode to 2 (subpackets).

CALL:MS:T2Pilot:BIT128:HCAPacity:TRANsition

CALL:MS:T2Pilot:BI256:HCAPacity:TRANsition

CALL:MS:T2Pilot:BIT512:HCAPacity:TRANsition

CALL:MS:T2Pilot:BIT768:HCAPacity:TRANsition

CALL:MS:T2Pilot:BIT1024:HCAPacity:TRANsition

CALL:MS:T2Pilot:BIT1536:HCAPacity:TRANsition

CALL:MS:T2Pilot:BIT2048:HCAPacity:TRANsition

CALL:MS:T2Pilot:BIT3072:HCAPacity:TRANsition

CALL:MS:T2Pilot:BIT4096:HCAPacity:TRANsition

CALL:MS:T2Pilot:BIT6144:HCAPacity:TRANsition

CALL:MS:T2Pilot:BIT8192:HCAPacity:TRANsition

CALL:MS:T2Pilot:BIT12288:HCAPacity:TRANsition

Function

Sets/queries the T2P Transition value for the specified packet size and high capacity transmission mode. The T2P Transition values determine which TxT2P gain values and which RRI Channel Gain values are used for a subpacket transmitted at the given configuration (packet size and transmission mode). See T2P Transition Settings for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: 0 to 3 (subpackets)
Resolution: 1

Query

Range: same as setting

*RST Setting

1 (subpacket)

Programming Example

OUTPUT 714;"CALL:MS:T2Pilot:BIT8192:HCAPacity:TRANsition 2"
! Sets T2P Transition value for the configuration with
! 8192 bits packet size and high capacity transmission mode to 2 (subpackets).

CALL:MS:T2Pilot:BIT128:HCAPacity:TRANsition:PRE

CALL:MS:T2Pilot:BI256:HCAPacity:TRANsition:PRE

CALL:MS:T2Pilot:BIT512:HCAPacity:TRANsition:PRE

CALL:MS:T2Pilot:BIT768:HCAPacity:TRANsition:PRE

CALL:MS:T2Pilot:BIT1024:HCAPacity:TRANsition:PRE

CALL:MS:T2Pilot:BIT1536:HCAPacity:TRANsition:PRE

CALL:MS:T2Pilot:BIT2048:HCAPacity:TRANsition:PRE

CALL:MS:T2Pilot:BIT3072:HCAPacity:TRANsition:PRE

CALL:MS:T2Pilot:BIT4096:HCAPacity:TRANsition:PRE

CALL:MS:T2Pilot:BIT6144:HCAPacity:TRANsition:PRE

CALL:MS:T2Pilot:BIT8192:HCAPacity:TRANsition:PRE

CALL:MS:T2Pilot:BIT12288:HCAPacity:TRANsition:PRE

Function

Sets/queries the TxT2P Pre-Transition gain for the specified packet size and high capacity transmission mode. See TxT2P Gain Settings for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: 0 to 32 dB
Resolution: 0.25 dB

Query

Range: same as setting

*RST Setting

128 bit High Capacity TxT2P Pre-Transition: 0.75 dB
256 bit High Capacity TxT2P Pre-Transition: 3.75 dB
512 bit High Capacity TxT2P Pre-Transition: 7.0 dB
768 bit High Capacity TxT2P Pre-Transition: 8.75 dB
1024 bit High Capacity TxT2P Pre-Transition: 10.0 dB
1536 bit High Capacity TxT2P Pre-Transition: 11.5 dB
2048 bit High Capacity TxT2P Pre-Transition: 13.0 dB
3072 bit High Capacity TxT2P Pre-Transition: 14.25 dB
4096 bit High Capacity TxT2P Pre-Transition: 15.5 dB
6144 bit High Capacity TxT2P Pre-Transition: 17.0 dB
8192 bit High Capacity TxT2P Pre-Transition: 18.5 dB
12288 bit High Capacity TxT2P Pre-Transition: 21.25 dB

Programming Example

OUTPUT 714;"CALL:MS:T2Pilot:BIT8192:HCAPacity:TRANsition:PRE 20"
! Sets TxT2P Pre-Transition gain for the configuration with
! 8192 bits packet size and high capacity transmission mode to 20 dB.

CALL:MS:T2Pilot:BIT128:HCAPacity:TRANsition:POST

CALL:MS:T2Pilot:BI256:HCAPacity:TRANsition:POST

CALL:MS:T2Pilot:BIT512:HCAPacity:TRANsition:POST

CALL:MS:T2Pilot:BIT768:HCAPacity:TRANsition:POST

CALL:MS:T2Pilot:BIT1024:HCAPacity:TRANsition:POST

CALL:MS:T2Pilot:BIT1536:HCAPacity:TRANsition:POST

CALL:MS:T2Pilot:BIT2048:HCAPacity:TRANsition:POST

CALL:MS:T2Pilot:BIT3072:HCAPacity:TRANsition:POST

CALL:MS:T2Pilot:BIT4096:HCAPacity:TRANsition:POST

CALL:MS:T2Pilot:BIT6144:HCAPacity:TRANsition:POST

CALL:MS:T2Pilot:BIT8192:HCAPacity:TRANsition:POST

CALL:MS:T2Pilot:BIT12288:HCAPacity:TRANsition:POST

Function

Sets/queries the TxT2P Post-Transition gain for the specified packet size and high capacity transmission mode. See TxT2P Gain Settings for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: 0 to 32 dB
Resolution: 0.25 dB

Query

Range: same as setting

*RST Setting

128 bit High Capacity TxT2P Post-Transition: 0.75 dB
256 bit High Capacity TxT2P Post-Transition: 3.75 dB
512 bit High Capacity TxT2P Post-Transition: 7.0 dB
768 bit High Capacity TxT2P Post-Transition: 8.75 dB
1024 bit High Capacity TxT2P Post-Transition: 10.0 dB
1536 bit High Capacity TxT2P Post-Transition: 11.5 dB
2048 bit High Capacity TxT2P Post-Transition: 13.0 dB
3072 bit High Capacity TxT2P Post-Transition: 14.25 dB
4096 bit High Capacity TxT2P Post-Transition: 15.5 dB
6144 bit High Capacity TxT2P Post-Transition: 17.0 dB
8192 bit High Capacity TxT2P Post-Transition: 18.5 dB
12288 bit High Capacity TxT2P Post-Transition: 21.25 dB

Programming Example

OUTPUT 714;"CALL:MS:T2Pilot:BIT8192:HCAPacity:TRANsition:POST 20"
! Sets TxT2P Post-Transition gain for the configuration with
! 8192 bits packet size and high capacity transmission mode to 20 dB.


CALL:OPERating:MODE

CALL:OPERating:MODE

Diagram Conventions

CALL[:CELL]:OPERating:MODE

Function

Sets/queries the operating mode of the access network emulator (see Operating Mode ).

Requirements

Test Application Revision: A.01.20 and above
Test Application Revision: A.05 and above: added TEST856

Lab Application Revision: A.01 and above: added TEST856

Setting

Range:

  • CALL: Active Cell mode (see Active Cell Operating Mode ).
  • TEST856: IS-856 Test mode (see IS-856 Test Operating Mode )
  • CW: CW mode (see CW Operating Mode ).
  • OFF: The test set turns off the cell RF power and puts the data connection processing state machines into an inactive state.

Query

 Same as setting

*RST Setting

CALL

Programming Example

OUTPUT 714;"CALL:OPERating:MODE CW"
! Selects CW operating mode.


CALL:PARameter:SECTor

CALL:PARameter:SECTor

May 24, 2006

Diagram Conventions

CALL[:CELL]:PARameter:SECTor:IDENtifier

Function

Sets/queries the Sector ID. See Sector ID .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0 to FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
(1 to 32 characters from the set 0123456789aAbBcCdDeEfF).

Query

Range: "0x00000000000000000000000000000000" to "0xFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF"
(The return string is always 34 characters: 0x plus 32 characters from the set 0123456789ABCDEF)

*RST Setting

 "0xFEA00000000000000000000000000001"

Programming Example

OUTPUT 714;"CALL:PARameter:SECTor:IDENtifier 'FEA00000000000000000000000000002'"
! Sets the Sector ID to FEA00000000000000000000000000002

CALL[:CELL]:PARameter:SECTor:SMASk

Function

Sets/queries the sector's Subnet Mask. See Subnet Mask .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0 to 128

Resolution: integer

Query

 Same as setting

*RST Setting

 104

Programming Example

OUTPUT 714;"CALL:PARameter:SECTor:SMASk 100"
! Sets the sector's Subnet Mask to 100


CALL:PNOFfset

CALL:PNOFfset

Diagram Conventions

CALL[:CELL[1]]:PNOFfest

Function

Sets/queries the cell's pseudonoise (PN) offset. See PN Offset .

This command may take up to 2 seconds to complete.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0 to 511

Resolution: integer

Query

 Same as setting

*RST Setting

12

Programming Example

OUTPUT 714;"CALL:PNOFfset 333"
! Sets the PN offset to 333.


CALL:POWer

CALL:POWer

Diagram Conventions

CALL[:CELL]:POWer[:SAMPlitude]<[:SELected]|:CW|:DIGital856>

Function

The setting form of this command performs two functions: (1) sets the desired cell power level and (2) turns the cell power on/off state to on. The query form returns the desired cell power level. (See Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power for more information about desired versus current power levels).

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type (see System Type ).

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

 Range/Resolution: see CALL[:CELL]:POWer:AMPLitude<[:SELected]|:CW|:DIGital856>

Query

 Range/Resolution: see CALL[:CELL]:POWer:AMPLitude<[:SELected]|:CW|:DIGital856>

*RST Setting

 ON, and see CALL[:CELL]:POWer:AMPLitude<[:SELected]|:CW|:DIGital856>

Programming Example

OUTPUT 714;"CALL:POWer -30"
! Sets cell power state to ON and
! sets desired cell power level to -30 dBm for the current system type.
OUTPUT 714;"CALL:POWer:DIGital856 -56"
! Sets cell power state to ON and
! sets desired cell power level to -56 dBm/1.23 MHz for the DIGital856 system type.

CALL[:CELL]:POWer:AMPLitude<[:SELected]|:CW|:DIGital856>

Function

Sets/queries the desired cell power level. (See Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power for more information about desired versus current power levels).

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type (see System Type ).

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: (This is the range of settings accepted, see Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power for the actual hardware range of the source)

  • CW: -177 dBm to +40 dBm
  • DIGital856: -170 dBm/1.23 MHz to +37 dBm/1.23 MHz

Resolution: 0.01 dB

Query

 Same as setting

*RST Setting
  • CW: -50 dBm
  • DIGital856: -55 dBm/1.23 MHz

Programming Example

OUTPUT 714;"CALL:POWer:AMPLitude -30"
!Sets desired cell power level to -30 dBm for the current system type.
OUTPUT 714;"CALL:POWer:AMPLitude:DIGital856 -56"
! Sets desired cell power level to -56 dBm/1.23 MHz for the DIGital 856 system type.

CALL[:CELL]:POWer:STATe<[:SELected]|:CW|:DIGital856>

Function

Sets/queries the cell power state.

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type (see System Type ).

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

ON

Programming Example

OUTPUT 714;"CALL:POWer:STATe OFF"
!Turns off cell power for the current system type.


CALL:PROTocol

CALL:PROTocol

Last updated: June 19, 2006

Diagram Conventions

CALL[:CELL]:PROTocol[:SELected]

CALL[:CELL]:PROTocol:DIGital856

Function

Sets/queries the protocol release that the test set is emulating. PRELease0 indicates protocol release 0 (1xEV-DO) and PRA indicates protocol release A (1xEV-DO-A). See Protocol Rel for details.

The optional [:SELected] mnemonic in this command specifies that the protocol release being set or queried applies to the current system type (see System Type ).

Setting

Range: PRELease0|PRA

Query

Range: PREL0|PRA

*RST Setting

 PRELease0

Requirements

Test Application Revision: A.06 and above (NOTE: PRA is only applicable to the feature-licensed test application)
Lab Application Revision: A.03 and above.

Programming Example

OUTPUT 714;"CALL:PROTocol PRA"
!Selects protocal release A (1xEV-DO-A).

CALL[:CELL]:PROTocol:ACMac

Function

Sets/queries the Access Channel MAC protocol when the test set is configured to protocol release A (1xEV-DO-A) and subtype 2 physical layer. See PL Subtype 2 Access Channel MAC Subtype for details.

To set the protocol release, use CALL[:CELL]:PROTocol[:SELected] . To set the physical layer subtype, use CALL[:CELL]:PROTocol:PLAYer .

Setting

Range: ENHanced|DEFault

Query

Range: ENH|DEF

*RST Setting

 ENHanced

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"CALL:PROTocol:ACMac DEFault"
!Sets the Access Channel MAC protocol to Default protocol.

CALL[:CELL]:PROTocol:PLAYer

Function

Sets/queries the physical layer subtype protocol when the test set is configured to protocol release A (1xEV-DO-A). See Release A Physical Layer Subtype for details.

To set the protocol release, use CALL[:CELL]:PROTocol[:SELected] .

Setting

Range: SUBType0|SUBType2

Query

Range: SUBT0|SUBT2

*RST Setting

 SUBType2

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"CALL:PROTocol:PLAYer SUBT0"
!Sets the physical layer protocol to subtype 0.


CALL:RFGenerator

CALL:RFGenerator

Diagram Conventions

CALL[:CELL]:RFGenerator:FREQuency

Function

Sets/queries the forward frequency that the test set's RF generator shall be set to. It is used in IS-856 Test Operating Mode when RF generator is set to manual control (see CALL[:CELL]:CONTrol:DOWNlink:FREQuency:AUTO ) or used in CW Operating Mode .

If no units are specified the setting defaults to Hz.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 292 MHz to 2700 MHz
Resolution: 0.1 Hz

Query

 Same as setting

*RST Setting

851000000 Hz

Programming Example

OUTPUT 714;"CALL:RFGenerator:FREQuency 450 MHZ"
! Sets the RF generator frequency to 450 MHz.


CALL:SCLose

CALL:SCLose

Diagram Conventions

CALL:SCLose

Function

This immediate action causes the AN to close the currently active session. See Session Closing State .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:SCLose"
!Causes the AN to close the currently active session

CALL:SCLose:TIMeout

Function

Sets/queries the session close timeout time. Setting the value to zero turns off the session close timeout timer. See Session Close for details.

The unit defaults to second (S). Any setting you enter is rounded to the nearest minute. For example, if the session close time is set to 3 seconds, the query return is zero (because the actual value is rounded to the nearest minute).

Note that this parameter is displayed on the test set's front panel in units of minute.
Requirements Test Application Revision: A.05 and above
Lab Application Revision: A.02 and above

Setting

Range: 0 to 194400 seconds (0 to 3240 minutes or 54 hours)

Resolution: 1 second

Query

Same as setting, but in multiple of 60 seconds

*RST Setting

180 seconds

Programming Example

OUTPUT 714;"CALL:SCLose:TIMout 600"
!Sets session close timeout time to 10 minutes.


CALL:SETup

CALL:SETup

Diagram Conventions

CALL:SETup:BAND<[:SELected]|:DIGital856>

Function

Sets/queries the handoff cell band. This is the Cell Band that will be handed off to when the CALL:HANDoff command is sent. The handoff cell band is associated with a handoff system type (see System Type ). You can set one handoff cell band for each handoff system type.

The optional [:SELected] keyword in this command specifies that the handoff cell band being set/queried applies to the current handoff system type (see System Type ).

For more information about handoffs, see Handoff .

To set or query the current cell band, rather than the handoff cell band, use the CALL:BAND command.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Test Application Revision: A.06 and above: added USPCs1900 band
Lab Application Revision: A.03 and above: added USPCs1900 band

Setting

Range: IMT2000|JCDMa|KPCS |NMT450|SECondary800|USCellular|USPCs|USPCs1900

Query

Range: IMT2000|JCDM|KPCS|NMT450|SEC800|USC|USPC|USPC1900

*RST Setting

USPC

Programming Example

OUTPUT 714;"CALL:SETup:BAND KPCS"
! Sets the handoff cell band to Korean PCS. This is the cell band
! that the test set will move to when the CALL:HANDoff command is sent

CALL:SETup:CHANnel<[:SELected]|:DIGital856>
<[:SELected]|:IMT2000|:JCDMa|:KPCS|:NMT450|:SECondary800|:USCellular|:USPCs|USPCs1900>

Function

Sets/queries the handoff channel. This is the Channel that will be handed off to when the CALL:HANDoff command is sent. The handoff channel is associated with a handoff system type (see System Type ) and handoff cell band (see Cell Band ). You can set one handoff channel for each handoff cell band.

The first optional [:SELected] keyword in this command specifies that the handoff channel being set/queried applies to the current handoff system type (see System Type ).

The second optional [:SELected] keyword in this command specifies that the handoff channel being set/queried applies to the current handoff cell band (see Cell Band ). To set or query the current handoff cell band, use the CALL:SETup:BAND command (see CALL:SETup:BAND<[:SELected]|:DIGital856> ).

For more information about handoffs, see Handoff .

To set or query the current channel, rather than the handoff channel, use the CALL:CHANnel command.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Test Application Revision: A.05 and above: USCellular added channel range of 1024 to 1323
Lab Application Revision: A.02.10 and above: USCellular added channel range of 1024 to 1323
Test Application Revision: A.06 and above: support USPCs1900 channels
Lab Application Revision: A.03 and above: support USPCs1900 channels

Setting

Range:

  • IMT2000: 0 to 1199

  • JCDMa: 1 to 799, 801 to 1039, 1041 to 1199, 1201 to 1600

  • KPCS: 0 to 599

  • NMT450: 1 to 300, 539 to 871, 1039 to 1473, 1792 to 2016

  • SECondary800: 0 to 919

  • USCellular: 1 to 799, 991 to 1023, 1024 to 1323

  • USPCs: 0 to 1199

  • USPCs1900: 0 to 1299

Resolution: integer

Query

 Same as setting

*RST Setting
  • [:SELected]: 525 (because *RST causes the band to be set to US PCS)
  • IMT2000: 525
  • JCDMa: 76
  • KPCS: 325
  • NMT450: 210
  • SECondary800: 820
  • USCellular: 384
  • USPCs: 525
  • USPCs1900: 525

Programming Example

OUTPUT 714;"CALL:SETUP:CHANNEL?"
! Queries the channel number of the current handoff system type and handoff cell band.

OUTPUT 714;"CALL:SETUP:CHANNEL 384"
! Sets the channel number of the current handoff system type and handoff cell band.

OUTPUT 714;"CALL:SETUP:CHANNEL:DIGital856:KPCS 384"
! Sets the handoff channel number for the DIGital856 handoff system type and
! Korean PCS handoff cell band to 384. If this system type and cell band are not
! being handed off to (are not the current handoff system type and handoff cell band),
! the value 384 is stored.


CALL:SOPen?

CALL:SOPen?

Last updated:May 24, 2006

Diagram Conventions

CALL:SOPen[:STATe]?

Function

This command queries whether or not the data connection is in the session open state (see Session Open State for a description of this data connection state).

When the query is sent:

  • If the data connection is in the session open state, the query immediately returns a 1.
  • If the data connection is in any other non-transitory state, the query immediately returns a 0 (see TAP/ETAP Data Connection Processing Lifecycle for information about which states are non-transitory).
  • If the data connection is in a transitory state, the query waits until the data connection reaches a non-transitory state, and then returns a 1 if the state is session open or a 0 if the state is any other non-transitory state.

NOTE
The query will hang as long as the data connection is in a transitory state. However, the AT includes protocol timers which limit the time it may stay in a transitory state. So, the AT should force the connection to return to a non-transitory state after its protocol timers expire, and so the query will not hang forever.

The query behaves differently if the data connection state change detector (see Data Connection State Change Detector ) is armed when the query is sent:

  • If the data connection is in a non-transitory state, the query hangs until the data connection state reaches a different non-transitory state, then returns a 1 if the state is session open or a 0 if the state is any other non-transitory state. For example, if the data connection is in the session open state when the query is sent, the query hangs until the data connection leaves the session open state, reaches another non-transitory state such as idle or connected, and then returns a 0.
  • If the data connection is in a transitory state, the query hangs until the data connection reaches a non-transitory state, and then returns a 1 if the state is session open or a 0 if the state is any other non-transitory state.

NOTE
If the data connection state change detector timeout (see Data Connection State Change Detector ) expires before the data connection moves to a different non-transitory state, then the change detector is disarmed, which releases the query. The query will then immediately return a 1 for session open, 0 for idle or connected, or hang until any non-transitory state is reached or the AT protocol timers expire.

Using the CALL:SOPen? query in conjunction with the data connection state change detector is useful in determining whether an attempt to open a session has been successful (see Establish a Session from the Access Terminal ) or to confirm that an attempt to close a connection (but preserve the session) has been successful (see Close the Connection ). See Data Connection State Synchronization .

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 1|0

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:SOPen?"
! Queries whether the Data Connection state is session open.


CALL:STATus

CALL:STATus

Last updated: June 16, 2006

Diagram Conventions

CALL:STATus:APPLication:DATA[:REVerse]:PACKet[:SIZE]?

Function

Queries the current reverse data channel packet size which indirectly determines the data rate and modulation type. See R-Data Pkt Size .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Query

Range: BIT128|BIT256|BIT512|BIT768|BIT1024|BIT1536|BIT2048|BIT3072
|BIT4096|BIT6144|BIT8192|BIT12288

*RST Setting

BIT512

Programming Example

OUTPUT 714;"CALL:STATus:APPLication:DATA[:REVerse]:PACKet?"
! Quries the current R-Data packet size.

CALL:STATus:APPLication:DATA[:REVerse]:TRANsmission[:MODE]?

Function

Queries the expected transmission mode used by R-Data channel. See Reverse Data Transmission Mode .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Query

Range: HCAP|LLAT
HCAP (High Capacity); LLAT (Low Latency)

*RST Setting

HCAP

Programming Example

OUTPUT 714;"CALL:STATus:APPLication:DATA:TRANsmission?"
! Queries the expected R-Data transmission mode.

CALL:STATus:APPLication:EACCess:DRATe:EXPected?

Function

Queries the expected enhanced access rate. See Enhanced Access Rate .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Query

Range: BPS9600|BPS19200|BPS38400|UNKN

*RST Setting

BPS9600

Programming Example

OUTPUT 714;"CALL:STATus:APPLication:EACCess:DRATe:EXPected?"
! Queries the expected enhanced access rate.

CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude]<[:SELected]|:DIGital856>?

Function

Queries the current power level of the additive white Gaussian noise (AWGN) source for the specified system type.

The optional [:SELected] keyword in this command specifies that the AWGN power level being set or queried applies to the current system type (see System Type ).

See Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power for more information about desired versus current power levels.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range:

  • -170 dBm/1.23 MHz to +35 dBm/1.23 MHz (This is the range of possible query returns, see Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power for the actual hardware range of the source)
  • NAN (Returned if CALL:STATus:AWGNoise[:INTernal]:POWer:STATe<[:SELected]|:DIGital856>? is OFF)

Resolution: 0.01 dB

*RST Setting

 NAN

Programming Example

OUTPUT 714;"CALL:STATus:AWGN:POWer:AMPLitude?"
! Queries the current AWGN power

CALL:STATus:AWGNoise[:INTernal]:POWer:STATe<[:SELected]|:DIGital856>?

Function

Queries the current on/off state of the additive white Gaussian noise (AWGN) source for the specified system type.

The optional [:SELected] keyword in this command specifies that the AWGN power level being set or queried applies to the current system type (see System Type ).

See Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power for more information about desired versus current power levels.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 1|0

*RST Setting

 0 (Off)

Programming Example

OUTPUT 714;"CALL:STATus:AWGNoise:POWer:STATe?"
! Queries the current on/off state of the AWGN source

CALL:STATus:CCHannel:PCCCycle:NUMBer?

Function

Queries the Preferred Control Channel Cycle currently configured for the session. See Preferred Control Channel Cycle .

Requirements

 Test Application Revision: A.05 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 32767

Resolution: 1 cycle

*RST Setting

 9.91E+37 (NAN)

Programming Example

OUTPUT 714;"CALL:STATus:CCHannel:PCCCycle:NUMBer?"
! Queries the current Preferred Control Channel Cycle.

CALL:STATus:CCHannel:PCCCycle:STATe?

Function

Queries the Preferred Control Channel Cycle enable state. See Preferred Control Channel Cycle .

Requirements

 Test Application Revision: A.05 and above
Lab Application Revision: A.01 and above

Query

Range: 1|0

*RST Setting

 0 (off)

Programming Example

OUTPUT 714;"CALL:STATus:CCHannel:PCCCycle:STATe?"
! Queries the current Preferred Control Channel Cycle enable state.

CALL:STATus:CELL:SYSTem[:TYPE]?

Function

Queries which system type the test set is currently emulating (see System Type ).

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: CW|DIG856

*RST Setting

 DIG856

Programming Example

OUTPUT 714;"CALL:STATus:CELL:SYSTem?"
! Queries the current system type.

CALL:STATus:CELL[1]:POWer:[AMPLitude]<[:SELected]|:DIGital856>?

Function

Queries the current cell (1) power level for the specified system type.

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type (see System Type ).

See Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power for more information about desired versus current power levels.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range:

  • -170 dBm/1.23 MHz to +37 dBm/1.23 MHz (This is the range of possible query returns, see Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power for the actual hardware range of the source)
  • NAN (Returned if CALL:STATus:CELL[1]:POWer:STATe<[:SELected]|:DIGital856>? is OFF)

Resolution: 0.01 dB

*RST Setting

 -55 dBm

Programming Example

OUTPUT 714;"CALL:STATus:CELL:POWer?"
! Queries the current cell power level

CALL:STATus:CELL[1]:POWer:STATe<[:SELected]|:DIGital856>?

Function

Queries the current on/off state of cell (1) power for the specified system type.

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type (see System Type ).

See Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power for more information about desired versus current power levels.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 1|0

*RST Setting

 1 (on)

Programming Example

OUTPUT 714;"CALL:STATus:CELL:POWer:STATe?"
! Queries the current on/off state of cell power

CALL:STATus:CSTime:LOCal:DATE?

Function

Queries the date of the CDMA local time. The CDMA local time is a calculated value, see CDMA System Time for details.

To query the time of the day of the CDMA local time, see CALL:STATus:CSTime:LOCal:TIME? .

Query

Range: from January 6, 1980 to January 5, 2096. It is returned in three comma-separated values, in the order of <year>, <month> and <date> where

  • <year> 1980 to 2096
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

or -1,-1,-1 is returned when the test set is not in Active Cell or IS-856 Test Mode operating mode.

Requirement

Test Application Revision: A.05 and above
Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:STATus:CSTime:LOCal:DATE?"
!Queries the date of CDMA local time.

CALL:STATus:CSTime:LOCal:TIME?

Function

Queries the time of the day of the CDMA local time. The CDMA local time is a calculated value, see CDMA System Time for details.

To query the date of the CDMA local time, see CALL:STATus:CSTime:LOCal:DATE? .

Query

Range: any time of a day. It is returned in three comma-separated values, in the order of <hour>,<minute>,<second> where

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

or -1,-1,-1 is returned when the test set is not in Active Cell or IS-856 Test Mode operating mode.

Requirement

Test Application Revision: A.05 and above
Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:STATus:CSTime:LOCal:TIME?"
!Queries the time of the day of the CDMA local time.

CALL:STATus[:STATe]:DATA?

Function

Queries the status of the data connection. See Summary of Data Connection Processing States Description and Instrument Status Area .

Use the CALL:STATus:DATA? query after a handoff to verify the data connection state is still connected. See Handoff and Data Connection State Synchronization .
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range:

CCL ( Connection Closing State )

CNEG ( Connection Negotiate State )

CREQ ( Connection Request State )

DCON ( Connected State )

DORM ( Dormant State ) ( Lab Application Only )

HAND ( Handoff )

IDLE ( Idle State )

PAG ( Paging State )

SCL ( Session Closing State )

SNEG ( Session Negotiate State )

SOP ( Session Open State )

UREQ ( UATI Request State )

*RST Setting

 IDLE

Programming Example

OUTPUT 714;"CALL:STATus:DATA?"
!Queries the status of the data connection.

CALL:STATus:MS:AUTO:POWer:POST?

Function

Queries the expected power from AT which is computed using the post-transition levels of R-RRI and R-Data channels. It is applicable for subtype 2 physical layer. See Expected Power for Subtype 0 and Subtype 2 Physical Layer for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Query

Range: -69 to +30 dBm, 9.91E+37 (NAN)

Resolution: 0.01 dB

*RST Setting

 9.91E+37 (NAN)

Programming Example

OUTPUT 714;"CALL:STATus:MS:AUTO:POWer:POST?"
! Queries the expected terminal power [post] value.

CALL:STATus:MS:MACIndex?

Function

Queries the MAC Index assigned to the AT under test by the test set. See MAC Index .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 5 to 63, 9.91E+37 (NAN)

Resolution: integer

*RST Setting

 9.91E+37 (NAN)

Programming Example

OUTPUT 714;"CALL:STATus:MS:MACIndex?"
! Queries the MAC Index

CALL:STATus:MS:T2Pilot:GAIN:PRE?

Function

Queries the current TxT2P Pre-Transition gain being used for the current configuration of data packet size and transmission mode. See TxT2P Gain Settings for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Query

Range: 0 to 32 dB
Resolution: 0.25 dB

*RST Setting

7 dB

Programming Example

OUTPUT 714;"CALL:STATus:MS:T2Pilot:GAIN:PRE?"
! Queries the current TxT2P Pre-Transition gain.

CALL:STATus:MS:T2Pilot:GAIN:POST?

Function

Queries the current TxT2P Post-Transition gain being used for the current configuration of data packet size and transmission mode. See TxT2P Gain Settings for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Query

Range: 0 to 32 dB
Resolution: 0.25 dB

*RST Setting

7 dB

Programming Example

OUTPUT 714;"CALL:STATus:MS:T2Pilot:GAIN:POST?"
! Queries the current TxT2P Post-Transition gain.

CALL:STATus:MS:T2Pilot:TRANsition?

Function

Queries the current T2P Transition value being used for the current configuration of data packet size and transmission mode. See T2P Transition Settings for details.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Query

Range: 0 to 3 (subpackets)
Resolution: 1

*RST Setting

3

Programming Example

OUTPUT 714;"CALL:STATus:MS:T2Pilot:TRANsition?"
! Queries the current T2P Transition value.

CALL:STATus:MS:TRAFfic:DRATe:KBPS1843[:SUPPort]?

Function

Queries the Rate1M8Supported attribute value that will be negotiated during session negotiation (if a session is not open) or has been configured for the session (if a session is open). See Rate 1M8 Supported Control for details.

Query

Range: YES|NO

*RST Setting

 NO

Requirements

Test Application Revision: A.06 and above, with the required feature license.
Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"CALL:STATus:MS:TRAFfic:DRATe:KBPS1843"
!Queries Rate1M8Supported attribute value.

CALL:STATus:MS:UATI024?

Function

Queries the UATI 024. See UATI 024 .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 16777215, NAN

Resolution: integer

*RST Setting

 NAN

Programming Example

OUTPUT 714;"CALL:STATus:MS:UATI024?"
! Queries the UATI 024.

CALL:STATus:MS:UCCode?

Function

Queries the UATI Color Code. See UATI Color Code .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 255, NAN

Resolution: integer

*RST Setting

 NAN

Programming Example

OUTPUT 714;"CALL:STATus:MS:UCCode?"
! Queries the UATI Color Code.

CALL:STATus:MSPeed[:CPOWer]?

Function

Queries the current measurement speed being used by the channel power measurement. This speed may differ from the setting specified by the SETup:CPOWer:MSPeed command. See Measurement Speed .

Query

Range: FAST|VFAS

*RST Setting

 FAST

Requirements

Test Application Revision: A.02.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:MSPeed?"
!Queries the channel power measurement speed.

CALL:STATus:PROTocol:ACMac?

Function

Queries the current Access Channel MAC protocol being configured in the test set. See Determination of Current Access Channel MAC Subtype for details.

Query

Range: ENH|DEF

*RST Setting

 DEF

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"CALL:STATus:PROTocol:ACMac?"
!Queries the current Access Channel MAC protocol.

CALL:STATus:PROTocol:PLAYer?

Function

Queries the current physical layer subtype being configured in the test set. See Determination of Current Physical Layer Subtype for details.

Query

Range: SUBT0|SUBT2

*RST Setting

 SUBT0

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"CALL:STATus:PROTocol:PLAYer?"
!Queries the current physical layer subtype.

CALL:STATus:TOTal:POWer[:AMPLitude]<[:SELected]|:DIGital856>?

Function

Queries the current total RF power for the specified system type.

The total RF power is equal to the sum of the cell power and AWGN power.

The optional [:SELected] keyword in this command specifies that the total RF power level being set or queried applies to the current system type (see System Type ).

See Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power for more information about desired versus current power levels.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range:

  • -170 dBm/1.23 MHz to +42 dBm/1.23 MHz (This is the range of possible query returns, see Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power for the actual hardware range of the source)
  • NAN (Returned if CALL:STATus:TOTal:POWer:STATe<[:SELected]|:DIGital856>? is OFF)

Resolution: 0.01 dB

*RST Setting

 -55 dBm

Programming Example

OUTPUT 714;"CALL:STATus:TOTal:POWer?"
! Queries the current total RF power

CALL:STATus:TOTal:POWer:STATe<[:SELected]|:DIGital856>?

Function

Queries the current on/off state of total RF power for the specified system type.

This query will return a 1 (on) if either current cell power or current AWGN power states are on.

The optional [:SELected] keyword in this command specifies that the total RF power level being set or queried applies to the current system type (see System Type ).

See Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power for more information about desired versus current power levels.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 1|0

*RST Setting

 1 (on)

Programming Example

OUTPUT 714;"CALL:STATus:TOTal:POWer:STATe?"
! Queries the current on/off state of the total RF power

CALL:STATus:TRAFfic[:CELL[1]]:EBNTotal?

Function

Queries the cell energy per bit divided by noise, total (E b/ N t ). See Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range:

  • -24.26 to +33.80 dB
  • NAN (Returned if the data connection state is not Connected State )

Resolution: 0.01 dB

*RST Setting

 NAN

Programming Example

OUTPUT 714;"CALL:STATus:TRAFfic:EBNTotal?"
! Queries the current Eb/Nt


CALL:TEST856

CALL:TEST856

Diagram Conventions

CALL:TEST856:MACIndex

Function

Sets/queries the MAC Index assigned to the AT when in the IS-856 Test Operating Mode .

See MAC Index in IS-856 Test Operating Mode .

Requirements

 Test Application Revision: A.05 and above
Lab Application Revision: A.01 and above

Setting

Range: 5 to 63

Resolution: 1

Query

Range: 5 to 63

Resolution: 1

*RST Setting

 5

Programming Example

OUTPUT 714;"CALL:TEST856:MACIndex 6"
!Sets the MAC Index to 6.

CALL:TEST856:TRAFfic[:FORWard]:DRATe

Function

Sets/queries the data rate and number of slots used to transmit the forward traffic packets when in the IS-856 Test Operating Mode .

See Forward Traffic Rate in IS-856 Test Operating Mode for details.

Requirements

 Test Application Revision: A.05 and above
Lab Application Revision: A.01 and above

Setting

Range: S16Bps38400|S08Bps76800|S04Bps153600|S04Bps307200|S02Bps307200
|S02Bps614400|S01Bps614400|S01Kbps1229|S02Bps921600|S01Kbps1843
|S02Kbps1229|S01Kbps2458

Query

Range: S16B38400|S08B76800|S04B153600|S04B307200|S02B307200|S02B614400
|S01B614400|S01K1229|S02B921600|S01K1843|S02K1229|S01K2458

*RST Setting

S02B307200

Programming Example

OUTPUT 714;"CALL:TEST856:TRAFfic:DRATe S16B38400"
!Sets the forward traffic data rate in IS-856 Test operating mode
!to 38.4 kbps, 16 slots/packet

CALL:TEST856:DCHannel:REVerse:DRATe

Function

Sets/queries the rate at which the reverse data packets are expected to be transmitted from the AT when in the IS-856 Test Operating Mode .

See Expected Reverse Data Rate in IS-856 Test Operating Mode for details.

Requirements

 Test Application Revision: A.05 and above
Lab Application Revision: A.01 and above

Setting

Range: BPS9600|BPS19200|BPS38400|BPS76800|BPS153600

Query

 Same as setting

*RST Setting

 BPS9600

Programming Example

OUTPUT 714;"CALL:TEST856:DCHannel:REVerse:DRATe BPS38400"
!Sets the reverse data rate to 38.4 kbps in IS-856 Test mode.


CALL:TOTal:POWer

CALL:TOTal:POWer

Diagram Conventions

CALL:TOTal:POWer[:AMPLitude]<[:SELected]|:DIGital856>?

Function

Queries the desired total RF power. This is not a settable parameter; it is calculated from the settings for cell power and AWGN power. (See Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power for more information about desired versus current power levels).

The optional [:SELected] keyword in this command specifies that this query applies to the current system type (see System Type ).

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range:

  • -170 dBm/1.23 MHz to +42 dBm/1.23 MHz
  • 9.91 E+37 (NAN) is returned if both cell power and AWGN power are set to OFF

Resolution: 0.01 dB

*RST Setting

 -55 dBm/1.23 MHz

Programming Example

OUTPUT 714;"CALL:TOTal:POWer?"
! Queries the current setting for desired total RF power
! (based on the settings for desired cell power and AWGN power)

CALL:TOTal:POWer:STATe<[:SELected]|:DIGital856>?

Function

Queries the total RF power state.

The total RF power state is 1 (on) if either cell power or AWGN power is on.

The optional [:SELected] keyword in this command specifies that this query applies to the current system type (see System Type ).

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 1|0

*RST Setting

 1 (on)

Programming Example

OUTPUT 714;"CALL:TOTal:POWer:STATe?"
! Queries the total RF power state


CALL:TRIGger

CALL:TRIGger

Diagram Conventions

CALL:TRIGger[:OUTPut]:TYPE<[:SELected]|:TA856>

Function

Sets/queries the trigger that is routed to the rear panel. See External Trigger Type .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range:

  • US1667 (1.67 ms)
  • MS27 (26.67 ms)
  • MS427 (426.67 ms)
  • MS2000 (2 s)

Query

 Same as setting

*RST Setting

 MS2000

Programming Example

OUTPUT 714;"CALL:TRIGger:TYPE MS427"
! Sets the external trigger type to 426.67 ms.


CALL:WAVeform

CALL:WAVeform

Diagram Conventions

CALL[:CELL[1]]:WAVeform:TYPE:CW

Function

Sets/queries the type of test signals to be output to the currently selected front-panel RF connector while in CW operating mode. See CW Operating Mode for details.

The test signals include:

  • CW generates an unmodulated continuous sine waveform signal.
  • AM generates an amplitude modulated signal with 56% depth and 20 kHz modulation rate.
  • DSB generates a dual side-band suppressed carrier signal with 20 kHz spacing between the two carriers.

When in CW operating mode, switching test signals requires a few seconds. A few seconds of delay is also encountered when changing operating modes if the current test signal is not CW.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: CW|AM|DSB

Query

Range: CW|AM|DSB

*RST Setting

CW

Programming Example

OUTPUT 714;"CALL:WAVeform:TYPE:CW AM" !Sets the test singal to AM.


IEEE 488.2 Common Commands

IEEE 488.2 Common Commands

May 24, 2006

Description

*CLS

The *CLS, clear status command, is defined in "IEEE Std 488.2-1992", 10.3. This command will also clear and close the error message screen on the test set's display.

*ESE

The *ESE, standard event status enable command, is defined in "IEEE Std 488.2-1992", 10.10.

*ESE?

The *ESE?, standard event status enable query, is defined in "IEEE Std 488.2-1992", 10.11.

*ESR?

The *ESR?, standard event status register query, is defined in "IEEE Std 488.2-1992 ",10.12.

*IDN?

The *IDN?, identification query, is defined in "IEEE Std 488.2-1992", 10.14.*IDN? is used to retrieve information about the test set in ASCII format.

*IDN?, returns ASCII codes 32 through 126 excluding comma and semicolon in four comma separated fields. Field 1 returns the manufacturer, field 2 returns the instrument model number, field 3 returns the serial number, field 4 returns 0.

*OPC

The *OPC, operation complete command, is defined in "IEEE 488.2-1992", 10.18. *OPC causes the test set to continuously sense the No Operation Pending flag. When the No Operation Pending flag becomes TRUE, the OPC event bit in the standard event status register (ESR) is set to indicate that the state of all pending operations is completed. The *OPC common command is not recommended for use as an overlapped command.

*OPC?

The *OPC?, operation complete query, is defined in "IEEE Std 488.2-1992", 10.19. The *OPC? query allows synchronization between the controller and the test set using either the message available (MAV) bit in the status byte, or a read of the output OPC?. The *OPC? query does not effect the OPC event bit in the Standard Event Status Register (ESR). The *OPC? common command is not recommended for use as an overlapped command.

*OPT?

The *OPT?, option identification query, is defined in "IEEE Std 488.2-1992", 10.20. Each option will have a unique name, that name will be retuned with the query.

*RST

The *RST, full preset command, is defined in "IEEE Std 488.2-1992", 10.32. *RST is the recommended command when performing a full preset on the test set. A *RST restores the majority of settings to their default values.

  • *RST sets trigger arm to single
  • PRESet2 sets trigger arm to continuous

*SRE

The *SRE, service request enable command, is defined in "IEEE Std 488.2-1992", 10.34. The parameter range for this command is 0 through 255.

*SRE?

The *SRE?, service request enable query, is defined in "IEEE Std 488.2-1992", 10.35. Values returned by this query range from 0 through 255.

*STB?

The *STB?, read status byte query, is defined in "IEEE Std 488.2-1992", 10.36. Values returned by this query range from 0 through 255.

*WAI

The *WAI, wait-to-continue command, is defined in "IEEE Std 488.2-1992", 10.39. The *WAI command prevents the test set from executing any further commands or queries until all pending operation flags are false. The *WAI common command is not recommended for use as an overlapped command.

See also

Obtaining Identification Information (*IDN)

Preset Descriptions


DISPlay

DISPlay

Diagram Conventions

DISPlay:BRIGhtness

Function

Sets/queries the test set's display brightness.

A display backlight dimming feature lowers the display brightness after approximately 10 minutes without any manual user interaction with the test set. See Display Backlight Dimming .

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: MEDium | HIGH

Query

Range: MED | HIGH

Factory setting

HIGH (this parameter is not affected by any reset operation and can only be changed by direct user access)

Programming Example

OUTPUT 714;"DISPLAY:BRIGHTNESS MEDIUM" !Sets display brightness to medium.

DISPlay:MESSage:MASKable:STATe

Function

Blocks maskable messages from appearing on the test set display screen but not from the Message Log. Maskable messages are reported to the Message Log in either state. See Error Messages .

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: On | Off

Query

Range: On | Off

Factory setting

On

Programming Example

OUTPUT 714;"DISPLAY:MESSAGE:MASKABLE:STATE OFF"
!Prevents certain messages from appearing on the display.

DISPlay:MODE

Function

Sets/queries the test set's display mode.

See Display Mode (Track/Fast) for a description of fast and track display modes.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

 Range: FAST | TRACK

Query

 Range: FAST | TRAC
*RST setting TRACK

Programming Example

OUTPUT 714;"DISPLAY:MODE FAST" !Sets display mode to fast.

DISPlay:WINDow:ERRor:CLEar

Function

Clears the error message from the display screen but not from the Message Log.

Programming Example

OUTPUT 714;"DISPLAY:WINDOW:ERROR:CLEAR" !Clears an error message from the display.

DISPlay:OPERator:MESSage

Function

 Allows the operator to enter up to four messages, each up to 30 characters in length. These messages will be printed to the display when the command is sent and DISPlay:MODE is set to FAST.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

1|2 |3|4

1=uppermost field, 4=lowermost field
Factory setting Each message is initialized to a null string. Nothing will be displayed until one or more of the four GPIB messages is sent to the test set.

Programming Example

OUTPUT 714;"DISP:OPER:MESS1`Press F6 to stop test'"
!Writes the message "Press F6 to stop test" to the uppermost display field.


DISPlay Subsystem

DISPlay Subsystem

Description

The DISPlay subsystem is used to configure the test set's display mode or display brightness . Use of the DISPlay subsystem is not required to set or query any data or results.

Display Backlight Dimming

The test set's display brightness parameter has two settings at this time, high and medium. The life of the display's backlight will be maximized when brightness is set to medium. The test set has an auto dimming feature that will lower the display brightness automatically if approximately 10 minutes pass without a key being pressed on the test set's front panel. The display will return to the brightness level shown in the Display Brightness field when the test set is set to local and any front panel key is pressed. There is no other user control for this feature.

Syntax Diagram and Command Descriptions

DISPlay


FETCh:AFANalyzer

FETCh:AFANalyzer

Diagram Conventions

FETCh:AFANalyzer[:ALL]?

Function

Queries the AF analyzer measurements.

Measurement results are returned in the following order: integrity, average audio level, average SINAD, average distortion.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Average analog audio level

  • Range: 0 to 20 volts, 9.91 E+37

  • Resolution: The lesser of 4 significant digits or 10 uV

Average SINAD

  • Range:-99 to 99 dB, 9.91 E+37

  • Resolution: 0.01 dB

Average audio distortion

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:ALL?"
!Returns integrity, average audio level, average SINAD,and average audio distortion.

FETCh:AFANalyzer:DISTortion[:AVERage]?

Function

Queries the average audio distortion measurement.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Average audio distortion

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:AVERAGE?"

FETCh:AFANalyzer:DISTortion:ALL?

Function

Queries the audio distortion measurements.

The measurement results are returned in the following order: minimum distortion, maximum distortion, average distortion, standard deviation distortion.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Minimum, maximum, and average audio distortion:

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Standard deviation audio distortion:

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.001%

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:ALL?"
!Returns mininum, maximum, average, and standard deviation audio distortion.

FETCh:AFANalyzer:DISTortion:MAXimum?

Function

Queries the maximum audio distortion.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.01%

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:MAXIMUM?"

FETCh:AFANalyzer:DISTortion:MINimum?

Function

Queries the minimum audio distortion.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.01%

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:MINIMUM?"

FETCh:AFANalyzer:DISTortion:SDEViation?

Function

Queries the standard deviation audio distortion.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.001%

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:SDEVIATION?"

FETCh:AFANalyzer:FREQuency[:AVERage]?

Function

Queries the average audio frequency measurement.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Average audio frequency

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.1 Hz

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:AVERAGE?"

FETCh:AFANalyzer:FREQuency:ALL?

Function

Queries the audio frequency measurements.

The measurement results are returned in the following order: minimum frequency, maximum frequency, average frequency, standard deviation frequency.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Minimum, maximum, and average audio frequency:

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.1 Hz

Standard deviation audio frequency:

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.01 Hz

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:ALL?"
!Returns mininum, maximum, average, and standard deviation audio frequency.

FETCh:AFANalyzer:FREQuency:MAXimum?

Function

Queries the maximum audio frequency.

Query

Range: 0 to 99999 Hz, 9.91 E+37

Resolution: 0.1 Hz

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:MAXIMUM?"

FETCh:AFANalyzer:FREQuency:MINimum?

Function

Queries the minimum audio frequency.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 99999 Hz, 9.91 E+37

Resolution: 0.1 Hz

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:MINIMUM?"

FETCh:AFANalyzer:FREQuency:SDEViation?

Function

Queries the standard deviation audio frequency.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 99999 Hz, 9.91 E+37

Resolution: 0.01 Hz

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:SDEVIATION?"

FETCh:AFANalyzer:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 999

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:ICOUNT?"

FETCh:AFANalyzer:INTegrity?

Function

Queries the measurement integrity indicator for the last AF analyzer measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 1 through 16

Programming Example

OUTPUT 714;"FETCH:AFANalyzer:INTegrity?"
!Query the inegrity indicator for the AF analyzer results.

FETCh:AFANalyzer:SINAD[:AVERage]?

Function

Queries the average SINAD measurement.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Average SINAD

  • Range:-99 to 99 dB, 9.91 E+37

  • Resolution: 0.01 dB

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:AVERAGE"

FETCh:AFANalyzer:SINAD:ALL?

Function

Queries the SINAD measurements.

Measurement results are returned in the following order: minimum SINAD, maximum SINAD, average SINAD, and standard deviation SINAD.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Minimum, maximum, average SINAD:

  • Range: -99 to 99 dB, 9.91 E+37

  • Resolution: 0.01 dB

Standard deviation SINAD

  • Range: -99 to 99 dB, 9.91 E+37

  • Resolution: 0.001 dB

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:ALL?"
!Returns mininum, maximum, average, and standard deviation SINAD.

FETCh:AFANalyzer:SINAD:MAXimum?

Function

Queries the maximum SINAD measurements.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: -99 to 99 dB, 9.91 E+37

Resolution: 0.01 dB

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:MAXIMUM?"

FETCh:AFANalyzer:SINAD:MINimum?

Function

Queries the minimum SINAD measurements.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: -99 to 99 dB, 9.91 E+37

Resolution: 0.01 dB

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:MINIMUM?"

FETCh:AFANalyzer:SINAD:SDEViation?

Function

Queries the standard deviation SINAD measurements.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 99 dB, 9.91 E+37

Resolution: 0.001 dB

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:SDEVIATION?"

FETCh:AFANalyzer:VOLTage[:AVERage]?

Function

Queries the average audio level measurement.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 20 volts, 9.91 E+37

Resolution: the lesser of 4 significant digits or 10 uV

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:AVERAGE"

FETCh:AFANalyzer:VOLTage:ALL?

Function

Queries the audio level measurements.

Measurement results are returned in the following order: minimum audio level, maximum audio level, average audio level, standard deviation audio level.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 20 V, 9.91 E+37

Resolution: 4 significant digits

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:ALL?"
!Returns minimum, maximum, average, and standard deviation audio level.

FETCh:AFANalyzer:VOLTage:MAXimum?

Function

Queries the maximum audio level measurement.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 20 V, 9.91 E+37

Resolution: 4 significant digits

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:MAXIMUM?"

FETCh:AFANalyzer:VOLTage:MINimum?

Function

Queries the minimum audio level measurement.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 20 V, 9.91 E+37

Resolution: 4 significant digits

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:MAXIMUM?"

FETCh:AFANalyzer:VOLTage:SDEViation?

Function

Queries the standard deviation audio level measurement.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 20 V, 9.91 E+37

Resolution: 4 significant digits

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:SDEVIATION?"


FETCh:CAPPower

FETCh:CAPPower

Diagram Conventions

FETCh:CAPPower[:ALL]?

Function

Queries the access probe power measurement results.

This query returns an integrity indicator followed by the most recent access probe power measurement result (if results are available). See Access Probe Power Measurement Results .

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Programming Example

OUTPUT 714;"FETCH:CAPPower?" !Returns integrity, access probe power measurement.

FETCh:CAPPower:INTegrity?

Function

Queries the measurement integrity indicator for the last access probe power measurement completed.

Zero indicates a normal measurement. See Access Probe Power Measurement Results , "Integrity Indicator," for information about non-zero integrity results.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 through 23

Programming Example

OUTPUT 714;"FETCh:CAPPower:INTegrity?"
!Queries the integrity indicator for the most recent access probe power result.


FETCh:CFDTune

FETCh:CFDTune

Last updated: June 30, 2006

Diagram Conventions

FETCh:CFDTune[:ALL]?

Function

Queries the fast device tune (FDT) measurement results.

Results are returned in the following order:

  • Integrity
  • Number of Frequency Steps
  • Number of Power Steps
  • Number of MS TX power steps measured (in most cases, it equals Number of Frequency Steps multiplied by Number of Power Steps )
  • Comma-separated list of 400 MS Tx Power results. 400 results are always returned; if the test set measured fewer than 400 power steps from the mobile, the remaining values are NANs (9.91E+37). The power results for the first frequency in the MS TX Frequency Sequence are returned first, then the power results for the second frequency in the MS TX Frequency Sequence, etc., followed by NANs if fewer than 400 points were measured.

See Fast Device Tune Measurement Results .

Query

Integrity

  • Range: 0 to 31 (see Integrity Indicator )

  • Resolution: 1

Number of Frequency Steps

  • Range: 1 to 20, 9.91 E+37

  • Resolution: 1.0

Number of Power Steps

  • Range: 1 to 20, 9.91 E+37

  • Resolution: 1.0

Number of MS Tx Power Steps Measured

  • Range: 1 to 400, 9.91 E+37

  • Resolution: 1.0

MS Tx Power Results Array

  • Range: -100.00 to +100.00 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Requirement

Test Application Revision: A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"FETCh:CFDTune:ALL?"
!Returns integrity, number of frequency steps, number of power steps,
!Number of MS Tx Power steps measured, followed by a comma-separated list of
!400 MS Tx Power results.

FETCh:CFDTune:INTegrity?

Function

Queries the measurement integrity indicator for the fast device tune measurement.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 31 (see Integrity Indicator )

Requirement

Test Application Revision: A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"FETCh:CFDTune:INTegrity?"
!Queries the inegrity indicator for the fast device tune results.


FETCh:CPERror

FETCh:CPERror

Diagram Conventions

FETCh:CPERror[:ALL]?

Function

Queries the packet error rate (PER) measurement results.

This measurement returns up to 5 results in the following order:
integrity, confidence pass/fail, packet error rate, packet error count, packets tested.

See PER Measurement Results .

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

  • Resolution: 1

Confidence Pass/Fail

  • Range: 0 to 2 (0 = passed, 1 = failed, 2 = max packets), 9.91 E+37 indicates undefined

Packet Error Rate

  • Range: 0.00 to 100.00, 9.91 E+37

  • Resolution: 0.01 %

Packet Error Count

  • Range: 0 to 10,000,000, 9.91 E+37

  • Resolution: 1 packet

Packets Tested

  • Range: 0 to 10,000,000, 9.91 E+37

  • Resolution: 1 packet

Programming Example

OUTPUT 714;"FETCh:CPERror?"
! Returns integrity, confidence pass/fail, packet error rate,
! packet error count, packets tested.


FETCh:CPOWer

FETCh:CPOWer

Diagram Conventions

FETCh:CPOWer[:ALL]?

Function

Queries a channel power measurement result.

This query returns an integrity indicator followed by a channel power measurement result (if results are available). See Channel Power Measurement Results .

If the multi-measurement state is on, the result represents the average of a number of channel power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:CPOWer:COUNt[:SNUMber] .

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Programming Example

OUTPUT 714;"FETCh:CPOWer?"
! Returns integrity, channel power measurement.

FETCh:CPOWer:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

To set up multi-measurements, see SETup:CPOWer:COUNt[:SNUMber] .

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 999

Programming Example

OUTPUT 714;"FETCh:CPOWer:ICOunt?"
! Returns the intermediate count of channel power multi-measurements.

FETCh:CPOWer:INTegrity?

Function

Queries the measurement integrity indicator for the last channel power measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

See Channel Power Measurement Results

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 through 23

Programming Example

OUTPUT 714;"FETCH:CPOWER:INTegrity?"
!Queries the integrity indicator for the channel power results.

FETCh:CPOWer:MAXimum?

Function

Queries the maximum result of multiple channel power measurements.

The multi-measurement state is off by default. To set up multi-measurements, see SETup:CPOWer:COUNt[:SNUMber] .

This query returns the same channel power result as FETCh:CPOWer:MINimum? and FETCh:CPOWer[:ALL]? if the multi-measurement state is off.

Requirements

Test Application Revision: A.01.34 and above
Lab Application Revision: A.01 and above

Query

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Programming Example

OUTPUT 714;"FETCh:CPOWer:MAXimum?"
!Returns the maximum result of multiple channel power measurements.

FETCh:CPOWer:MINimum?

Function

Queries the minimum result of multiple channel power measurements.

Multi-measurement state is off by default. To set up multi-measurements, see SETup:CPOWer:COUNt[:SNUMber] .

This query returns the same channel power result as FETCh:CPOWer:MAXimum? and FETCh:CPOWer[:ALL]? if the multi-measurement state is off.

Requirements

Test Application Revision: A.01.34 and above
Lab Application Revision: A.01 and above

Query

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Programming Example

OUTPUT 714;"FETCh:CPOWer:MINimum?"
!Returns the minimum result of multiple channel power measurements.


FETCh:CTDPower

FETCh:CTDPower

Diagram Conventions

FETCh:CTDPower[:ALL]?

Function

Queries the TX dynamic power measurement result.

This query returns 101 comma-separated values, in the order of an integrity value followed by 100 power results.

The number of power measurements performed by the test set is equal to the setting of SETup:CTDPower:STEP:COUNt plus one, and can be queried using the FETCh:CTDPower:COUNt[:STEP]? command. If fewer than 100 power measurements were performed by the test set, the remaining power results will be returned as 9.91 E+37.

Query

  • Integrity - see Integrity Indicator

  • Power result for each measurement step

    • Range: -100.00 to 100.00 dBm, 9.91 E+37
    • Resolution: 0.01 dB

Requirements

Test Application Revision: A.02.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:CTDPower?"
!Returns integrity, 100 power values.

FETCh:CTDPower:COUNt[:STEP]?

Function

Queries the number of power measurements performed by the test set.

The number of power measurements performed by the test set is equal to the Number of Power Steps setting plus one.

Query

Range: 1 to 100

Requirements

Test Application Revision: A.02.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:CTDPower:COUNt?"
!Returns the number of power measurements performed by the test set.

FETCh:CTDPower:INTegrity?

Function

Queries the measurement integrity indicator for the TX dynamic power measurement.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: see Integrity Indicator

Requirements

Test Application Revision: A.02.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:CTDPower:INTegrity?"
!Queries the integrity indicator for the TX dynamic power results.


FETCh:CTXSpurious

FETCh:CTXSpurious

Diagram Conventions

FETCh:CTXSpurious<[:ALL]|:INTegrity>?

Function

Queries the TX spurious emissions measurement results.

This measurement returns results in the following order: integrity, TX spurious emissions pass/fail result, lower adjacent channel (-0.885 or -1.25 MHz) average TX spurious emissions, upper adjacent channel (+0.885 or +1.25 MHz) average TX spurious emissions, lower alternate channel (-1.98 MHz) average TX spurious emissions, upper alternate channel (+1.98 MHz) average TX spurious emissions.

See TX Spurious Emissions Measurement Results .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

  • Resolution: 1

TX spurious emissions pass/fail result

  • Range: 0 to 1 (0 = passed, 1 = failed), 9.91 E+37

Lower adjacent channel spurious emissions

  • Range: 0.00 to -80.00 dBc, 9.91 E+37

  • Resolution: 0.01 dBc

Upper adjacent channel spurious emissions

  • Range: 0.00 to -80.00 dBc, 9.91 E+37

  • Resolution: 0.01 dBc

Lower alternate channel spurious emissions

  • Range: 0.00 to -80.00 dBc, 9.91 E+37

  • Resolution: 0.01 dBc

Upper alternate channel spurious emissions

  • Range: 0.00 to -80.00 dBc, 9.91 E+37

  • Resolution: 0.01 dBc

Programming Example

OUTPUT 714;"FETCh:CTXSpurious?"

FETCh:CTXSpurious:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

The multi-measurement state, by default, is off. To set up multi-measurements, see SETup:CTXSpurious:COUNt[:SNUMber] .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 999

Programming Example

OUTPUT 714;"FETCh:CTXSpurious:ICOunt?"

FETCh:CTXSpurious:MASK[:FAIL]?

Function

Queries the pass/fail results. Pass/fail results are based on fixed limit lines on display.

See TX Spurious Emissions Measurement Results .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 (Pass)|1(Fail), 9.91 E+37

Programming Example

OUTPUT 714;"FETCh:CTXSpurious:MASK?"


FETCh:DAPower

FETCh:DAPower

Diagram Conventions

FETCh:DAPower[:ALL]?

Function

Queries a digital average power measurement result.

This query returns an integrity indicator followed by a digital average power measurement result (if results are available).

If the multi-measurement state is on, the result represents the average of a number of digital average power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:DAPower:COUNt[:SNUMber] .

See Digital Average Power Measurement Results .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Programming Example

OUTPUT 714;"FETCh:DAPower?"
! Returns integrity, average transmit power.

FETCh:DAPower:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

The multi-measurement state, by default, is off. To set up multi-measurements, see SETup:DAPower:COUNt[:SNUMber]

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 999

Programming Example

OUTPUT 714;"FETCh:DAPower:ICOunt?"

FETCh:DAPower:INTegrity?

Function

Queries the measurement integrity indicator for the last digital average power measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

See Digital Average Power Measurement Results .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 1 through 16

Programming Example

OUTPUT 714;"FETCh:DAPower:INTegrity?"
!Queries the inegrity indicator for the average digital tranmit power results.


FETCh? Subsystem

FETCh? Subsystem

Last updated: June 30, 2006

Description

The FETCh? query is a function that allows users to query results from a measurement that was previously INITiated or READ. It does NOT begin a measurement. If no measurement is in progress it will return the integrity and measurement values from the last measurement made, or return an integrity of No Result Available and results of NAN. If a measurement is in process, the query will hang until the results are available, or the measurement fails or times out. The exact results returned with a FETCh? will depend on the specific measurement. A measurement may have a number of different results or combination of results for a FETCh?. The FETCh? queries are intended to be used to provide overlapped operation access to measurement results from the test set. When used along with SETup and INITiate commands , FETCh? is the primary way for the user to retrieve measurement results. In order to use the test set's concurrent test capabilities the overlapped commands of INITiate and FETCh? must be used. Overlapped commands allow the user to send commands and not wait for completion.

Syntax Diagrams and Command Descriptions

FETCh:AFANalyzer (Audio Analyzer)
FETCh:CAPPower (Access Probe Power)
FETCh:CFDTune (Fast Device Tune) ( only applicable to the lab application or feature-licensed test application )
FETCh:CPERror (Packet Error Rate)
FETCh:CPOWer (Channel Power)
FETCh:CTDPower (TX Dynamic Power)
FETCh:CTXSpurious (Tx Spurious Emissions)
FETCh:DAPower (Digital Average Power)
FETCh:DOWQuality (Waveform Quality + Code Domain Power)
FETCh:GAPPower (Graphical Access Probe Power) ( Lab Application Only )
FETCh:SAUDio (Swept Audio)
FETCh:SMONitor (Spectrum Monitor)
FETCh:TROPower (Time Response of Open Loop Power Control)


FETCh:DOWQuality

FETCh:DOWQuality

Diagram Conventions

FETCh:DOWQuality[:ALL]?

FETCh:DOWQuality(:INTegrity|:RHO|:FERRor|:TERRor|:FEEDthrough|:PERRor|:MERRor|:EVM)?

Function

Queries the waveform quality measurement results. [:ALL] returns measurement results in the following order: integrity, rho, frequency error, time error (in seconds), carrier feedthrough, phase error (in degrees), magnitude error, and EVM. For details, see Waveform Quality Measurement Results .

If the multi-measurement state is on, each result represents the average of a number of waveform quality measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:DOWQuality:COUNt[:SNUMber] .

Instead of returning [:ALL] results, you may query the result for any particular measurement individually using the associated keyword, such as :RHO. If multi-measurement state is on, you may query the average, maximum, minimum or standard deviation for any particular measurement result individually by adding the :MAXimum, :MINimum or :SDEViation keyword.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Integrity

  • Range: 0 to 23
  • Resolution: 1

Rho

  • Range: 0.0000 to 1.0000, 9.91 E+37
  • Resolution: 0.0001

Frequency Error (in Hz)

  • Range: -9999.0 to 9999.0 Hz, 9.91 E+37
  • Resolution: 0.1 Hz

Time Error (in s)

  • Range: -99.99 E-6 to 99.99 E-6 s, 9.91 E+37
  • Resolution: 0.01 E-6 s

Carrier Feedthrough

  • Range: -100.00 to 0.00 dBc, 9.91 E+37
  • Resolution: 0.01 dB

Phase Error

  • Range: 0.00 to 359.99 degrees, 9.91 E+37
  • Resolution: 0.01 degrees

Magnitude Error

  • Range: 0.00 to 100.00%, 9.91 E+37
  • Resolution: 0.01%

Error Vector Magnitude (EVM)

  • Range: 0.00 to 100.00%, 9.91 E+37
  • Resolution: 0.01%

Programming Example

OUTPUT 714;"FETCh:DOWQuality?"
! Returns integrity, rho, frequency error, time error, carrier feedthrough, phase error,
! magnitude error, EVM (or average for each if multi-meas is on).

OUTPUT 714;"FETCh:DOWQuality:RHO?"
! Returns the rho result
! (or average rho result if multi-measurement state is on).

OUTPUT 714;"FETCh:DOWQuality:TERRor:MAXimum?"
! Returns the maximum time error measurement result
! (useful only if multi-measurement state is on).

FETCh:DOWQuality:PAYLoad?

Function

Queries the actual R-Data payload size (in bits) that the test set detects from the R-RRI channel (R-RRI channel carries the payload size and sub-packet identifier information) when measuring subtype 2 waveform quality. The R-Data payload size determines the modulation and walsh codes used on the R-Data channel. For details, see Waveform Quality Measurement Results .

If multi-measurement state is on, you may query the average, maximum, minimum or standard deviation for the payload size result by adding the :MAXimum, :MINimum or :SDEViation keyword. Multi-measurement state is off by default. To set up multi-measurements, see SETup:DOWQuality:COUNt[:SNUMber] .

Unlike most of other waveform quality measurement results (such as rho, frequency error, etc.), the payload size result can not be queried with FETCh:DOWQuality[:ALL]? command.

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Query

Payload Size (bits)

  • Range: 128, 256, 512, 768, 1024, 1536, 2048, 3072, 4096, 6144, 8192, 12288, 9.91 E+37 (NAN)
  • Resolution: 1.0

Programming Example

OUTPUT 714;"FETCh:DOWQuality:PAYLoad?"
! Returns R-Data payload size result
! (or average payload size result if multi-measurement state is on).

OUTPUT 714;"FETCh:DOWQuality:PAYLoad:MAXimum?"
! Returns the maximum payload size measurement result
! (useful only if multi-measurement state is on).

FETCh:DOWQuality:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement. See Measurement Progress Report .

Requirements

 Test Application Revision: A.01.20 and above

Query

Range: 0 to 999

Programming Example

OUTPUT 714;"FETCh:DOWQuality:ICOUNt?"

FETCh:DOWQuality:CDPower:ACKChannel[:REVerse]?

FETCh:DOWQuality:CDPower:DATA[:REVerse]?

FETCh:DOWQuality:CDPower:DRCChannel[:REVerse]?

FETCh:DOWQuality:CDPower:DSCChannel[:REVerse]?

FETCh:DOWQuality:CDPower:PILot[:REVerse]?

FETCh:DOWQuality:CDPower:PILot:AUXiliary[:REVerse]?

FETCh:DOWQuality:CDPower:RRIChannel[:REVerse]?

Function

These commands return code domain power measurement results for each of the reverse channels. The Subtype 0 reverse channels consist of the R-Pilot, R-RRI, R-DRC, R-ACK and R-Data and subtype 2 reverse channels consist of the R-Pilot, R-RRI, R-DRC, R-ACK, R-DSC, R-Aux Pilot and R-Data. So when measuring subtype 0 physical layer, querying R-Aux Pilot and R-DSC channels always returns 9.91E+37 (indicating not available).

The command for each channel returns 7 comma separated values, in the following order: modulation channel, Walsh code, spread factor, code domain power (dB), total code domain power (dB), normalized total code domain power (dB), and normalized total code domain power relative to R-Pilot (dB). See Code Domain Power Tabular Data for more information about these measurement results.

Note that when measuring subtype 2 R-Data channel with modulation type other than B4, the FETCh:DOWQuality:CDPower:DATA? command returns 7 comma separated values in the following order: modulation type, walsh code (9.91E+37), spread factor (9.91E+37), code domain power (9.91E+37), total code domain power (dB) of all walsh codes, normalized total code domain power (dB), and normalized total code domain power relative to R-Pilot (dB). The walsh code, spread factor and code domain power are always returned as 9.91E+37 (indicating not available) because the R-Data channel with modulation type other than B4 use more than one walsh channels (see Subtype 2 R-Data Packet Size, Modulation Type and Walsh Codes ). To determine the normalized total code domain power relative to R-Pilot for individual walsh channels that constitute R-Data channel, use FETCh:DOWQuality:CDPower:DATA[:REVerse]:RTPilot? .

If the multi-measurement state is on, the results are the average of a number of code domain power measurements. Multi-measurement state is off by default. To set up multi-measurements, see SETup:DOWQuality:COUNt[:SNUMber] .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Test Application Revision: A.06 and above, with the required feature license: Support for new subtype 2 reverse channels: R-DSC and R-Aux Pilot channels
Lab Application Revision: A.03 and above: Support for subtype 2 reverse channels: R-DSC and R-Aux Pilot channels

Query

Range:

For all of the Subtype 0 Reverse Channels:

  • Modulation Channel: 0=I, 1=Q; 9.91 E+37 (not available)
  • Walsh code: 0 to 15; 9.91 E+37 (not available)
  • Spread Factor: 4, 8, 16; 9.91 E+37 (not available)
  • Code Domain Power: -100.0 to 0.0 dB; 9.91 E+37 (not available)
  • Total Code Domain Power: -100.0 to 0.0 dB; 9.91 E+37 (not available)
  • Normalized Total Code Domain Power: -100.0 to 0.0 dB; 9.91 E+37 (not available)
  • Normalized Total Code Domain Power Relative to R-Pilot: -100.0 to +100.0 dB; 9.91 E+37 (not available)

For Subtype 2 R-Data Channel with modulation type B4 and all other Subtype 2 Reverse Channels:

  • Modulation Channel: 0=I, 1=Q; 9.91 E+37 (not available)
  • Walsh code: 0 to 31; 9.91 E+37 (not available)
  • Spread Factor: 2, 4, 8, 16, 32; 9.91 E+37 (not available)
  • Code Domain Power: -100.0 to 0.0 dB; 9.91 E+37 (not available)
  • Total Code Domain Power: -100.0 to 0.0 dB; 9.91 E+37 (not available)
  • Normalized Total Code Domain Power: -100.0 to 0.0 dB; 9.91 E+37 (not available)
  • Normalized Total Code Domain Power Relative to R-Pilot: -100.0 to +100.0 dB; 9.91 E+37 (not available)

For Subtype 2 R-Data Channel with modulation type other than B4:

  • Modulation Type: 0=I, 1=Q, 2=Q4, 3=Q2, 4=Q4Q2, 5=E4E2; 9.91 E+37 (not available)
  • Walsh code: 9.91 E+37 (not available)
  • Spread Factor: 9.91 E+37 (not available)
  • Code Domain Power: 9.91 E+37 (not available)
  • Total Code Domain Power: -100.0 to 0.0 dB; 9.91 E+37 (not available)
  • Normalized Total Code Domain Power: -100.0 to 0.0 dB; 9.91 E+37 (not available)
  • Normalized Total Code Domain Power Relative to R-Pilot: -100.0 to +100.0 dB; 9.91 E+37 (not available)

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPower:PILot?"
! Queries the R-Pilot code domain power measurement results.

OUTPUT 714;"FETCh:DOWQuality:CDPower:ACKChannel?"
! Queries the R-ACK code domain power measurement results.

FETCh:DOWQuality:CDPower:DATA[:REVerse]:RTPilot?

Function

Queries the normalized total code domain power relative to R-Pilot for individual walsh channels that constitute R-Data channel. The R-Data channel can occupy up to 4 walsh channels (that is, 4 bins) depending upon the R-Data modulation type (see Subtype 2 R-Data Packet Size, Modulation Type and Walsh Codes ).

This query returns 5 comma separated values which are R-Data modulation channel/type followed by up to 4 power values (the normalized total code domain power relative to R-Pilot for individual walsh channels of R-Data, see Bin Delta Pilot (only available for subtype 2 physical layer R-Data channel) ). If R-Data consists of less than 4 walsh channels, 9.91 E+37 (NAN) results are returned for the remaining values.

  • Modulation Channel or Type:
    • 0=I channel (indirectly indicating B4 modulation. This value is never returned because R-Data is allocated to Q channel for subtype 0 physical layer and for subtype 2 physical layer using B4 modulation)
    • 1=Q channel (indirectly indicating B4 modulation. This value is returned for R-Data channel for subtype 0 physical layer and for subtype 2 physical layer using B4 modulation)
    • 2 = Q4 modulation (only available for subtype 2 physical layer)
    • 3 = Q2 modulation (only available for subtype 2 physical layer)
    • 4 = Q4Q2 modulation (only available for subtype 2 physical layer)
    • 5 = E4E2 modulation (only available for subtype 2 physical layer)
  • 4 power values represent the following walsh channels based on the modulation type:
    • B4: power values returned for <Q:2 SF=4 >, <NAN>, <NAN>, <NAN>
    • Q4: power values returned for <I:2 SF=4 >, <Q:2 SF=4 >, <NAN>, <NAN>
    • Q2: power values returned for <I:1 SF=2 >, <Q:1 SF=2 > , <NAN>, <NAN>
    • Q4Q2: power values returned for <I:2 SF=4 >, <I:1 SF=2 >, <Q:2 SF=4 >, <Q:1 SF=2 >
    • E4E2: power values returned for <I:2 SF=4 >, <I:1 SF=2 >, <Q:2 SF=4 >, <Q:1 SF=2

To determine normalized total R-Data code domain power relative to R-Pilot (dB), use FETCh:DOWQuality:CDPower:DATA[:REVerse]? command.

If the multi-measurement state is on, the results are the average of a number of code domain power measurements. Multi-measurement state is off by default. To set up multi-measurements, see SETup:DOWQuality:COUNt[:SNUMber] .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Query

Range:

  • Modulation Channel or Type (for details, see the description above)
    0 = I, 1=Q, 2=Q4, 3=Q2, 4=Q4Q2, 5=E4E2, 9.91E+37 (not available)
  • Power: -100.0 to 100.0 dB; 9.91 E+37
    Resolution: 0.01 dB

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPower:DATA:RTPilot?"
! Returns 5 comma separated values, representing
! R-Data modulation type, the normalized total code domain power
! relative to R-Pilot for individual bins that make up R-Data channel.

FETCh:DOWQuality:CDPower:ICHannel:BIN? <bin num>

Function

Queries the I channel code domain power results for a specific bin. The results returned in the order of active/inactive, Walsh code, spread factor and power (dB), are the same as those returned for every bin using the FETCh:DOWQuality:CDPower[16]:ICHannel[:ALL]? or FETCh:DOWQuality:CDPower32:ICHannel[:ALL]? query.

The range of <bin num> is 0 to 15 (for subtype 0 physical layer) and 0 to 31 (for subtype 2 physical layer).

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Test Application Revision: A.06 and above, with the required feature license: Support for subtype 2 physical layer
Lab Application Revision: A.03 and above: Support for subtype 2 physical layer

Query

 Range:
Subtype 0 Physical Layer: see FETCh:DOWQuality:CDPower[16]:ICHannel[:ALL]?
Subtype 2 Physical Layer: see FETCh:DOWQuality:CDPower32:ICHannel[:ALL]?

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPower:ICHannel:BIN? 2"
! Queries the I channel code domain power results for bin 2.

FETCh:DOWQuality:CDPower:ICHannel:COUNt[:BIN]?

Function

This query indicates how many I channel bins contain measurement data. For example, if 13 is returned, I channel bins 0 through 12 contain measurement data and bins 13 through 15 (if for subtype 0 measurement) or bins 13 through 31 (if for subtype 2 measurement) contain 9.91 E+37 results.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Test Application Revision: A.06 and above, with the required feature license: Support for subtype 2 physical layer
Lab Application Revision: A.03 and above: Support for subtype 2 physical layer

Query

Range: 0 to 16 (for subtype 0 physical layer); 0 to 32 (for subtype 2 physical layer)

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPower:ICHannel:COUNt?"
! Returns the number of assigned bins (containing measurement results)

FETCh:DOWQuality:CDPower:QCHannel:BIN? <bin num>

Function

Queries the Q channel code domain power results for a specific bin. The results returned in the order of: active/inactive, Walsh code, spread factor and power (dB), are the same as those returned for every bin using the FETCh:DOWQuality:CDPower[16]:QCHannel[:ALL]? or FETCh:DOWQuality:CDPower32:QCHannel[:ALL]? query.

The range of <bin num> is 0 to 15 (for subtype 0 physical layer) and 0 to 31 (for subtype 2 physical layer).

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Test Application Revision: A.06 and above, with the required feature license: Support for subtype 2 physical layer
Lab Application Revision: A.03 and above: Support for subtype 2 physical layer

Query

 Range:
Subtype 0 Physical Layer: see FETCh:DOWQuality:CDPower[16]:QCHannel[:ALL]?
Subtype 2 Physical Layer: see FETCh:DOWQuality:CDPower32:QCHannel[:ALL]?

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPower:QCHannel:BIN? 13"
!Queries the Q channel code domain power results for bin 13.

FETCh:DOWQuality:CDPower:QCHannel:COUNt[:BIN]?

Function

This query indicates how many Q channel bins contain measurement data. For example, if 13 is returned, Q channel bins 0 through 12 contain measurement data and bins 13 through 15 (if for subtype 0 measurement) or bins 13 through 31 (if for subtype 2 measurement) contain 9.91 E+37 results.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Test Application Revision: A.06 and above, with the required feature license: Support for subtype 2 physical layer
Lab Application Revision: A.03 and above: Support for subtype 2 physical layer

Query

Range: 0 to 16 (for subtype 0 physical layer); 0 to 32 (for subtype 2 physical layer)

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPower:QCHannel:COUNt?"
! Returns the number of assigned bins (containing measurement results)

FETCh:DOWQuality:CDPower[16]:ICHannel[:ALL]?

Function

Queries the subtype 0 physical layer code domain power measurement results for all 16 bins on I channel.

This query returns 64 comma separated values. These represent 4 values for each of 16 bins. The 4 values returned for each bin are: active/inactive, Walsh code, spread factor, and power (dB). See Code Domain Power Measurement Results Available by Numbered Bins for more information about these measurement results.

There are frequently fewer than 16 bins with measurement data. For any unassigned bins (bins that don't contain measurement results), four 9.91 E+37 results are returned instead of data. This allows the query to always return 64 results regardless of how many bins contain measurement data. The FETCh:DOWQuality:CDPower:ICHannel:COUNt[:BIN]? command allows you to determine the total number of assigned bins (bins containing measurement results).

If the multi-measurement state is on, the results are the average of a number of code domain power measurements. Multi-measurement state is off by default. To set up multi-measurements, see SETup:DOWQuality:COUNt[:SNUMber] .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range:

  • Active/Inactive: 0 = inactive, 1 = active; 9.91 E+37 (not available)
  • Walsh code: 0 to 15; 9.91 E+37
  • Spread Factor: 4, 8, 16; 9.91 E+37
  • Power: -100.0 to 0.0 dB; 9.91 E+37

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPower:ICHannel?"
! Returns 1 or 0, Walsh code, spread factor, and power for bin 0.
! Then returns the same for bin 1, and repeats until the values for the last bin
! (bin 15) have been returned
! for a total of 64 comma separated values)

FETCh:DOWQuality:CDPower[16]:QCHannel[:ALL]?

Function

Queries the subtype 0 physical layer code domain power measurement results for all 16 bins on Q channel.

This query returns 64 comma separated values. These represent 4 values for each of 16 bins. The 4 values returned for each bin are: active/inactive, Walsh code, spread factor, and power (dB). See Code Domain Power Measurement Results Available by Numbered Bins for more information about these measurement results.

There are frequently fewer than 16 bins with measurement data. For any unassigned bins (bins that don't contain measurement results), four 9.91 E+37 results are returned instead of data. This allows the query to always return 64 results regardless of how many bins contain measurement data. The FETCh:DOWQuality:CDPower:QCHannel:COUNt[:BIN]? command allows you to determine the total number of assigned bins (bins containing measurement results).

If the multi-measurement state is on, the results are the average of a number of code domain power measurements. Multi-measurement state is off by default. To set up multi-measurements, see SETup:DOWQuality:COUNt[:SNUMber] .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range:

  • Active/Inactive: 0 = inactive, 1 = active; 9.91 E+37 (not available)
  • Walsh code: 0 to 15; 9.91 E+37
  • Spread Factor: 4, 8, 16; 9.91 E+37
  • Power: -100.0 to 0.0 dB; 9.91 E+37

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPower:QCHannel?"
! Returns 1 or 0, Walsh code, spread factor, and power for bin 0.
! Then returns the same for bin 1, and repeats until the values for the last bin
! (bin 15) have been returned
! (for a total of 64 comma separated values)

FETCh:DOWQuality:CDPower32:ICHannel[:ALL]?

Function

Queries the subtype 2 physical layer code domain power measurement results for all 32 bins on I channel.

This query returns 128 comma separated values. These represent 4 values for each of 32 bins. The 4 values returned for each bin are: active/inactive, Walsh code, spread factor, and power (dB). See Code Domain Power Measurement Results Available by Numbered Bins for more information about these measurement results.

There are frequently fewer than 32 bins with measurement data. For any unassigned bins (bins that don't contain measurement results), four 9.91 E+37 results are returned instead of data. This allows the query to always return 128 results regardless of how many bins contain measurement data. The FETCh:DOWQuality:CDPower:ICHannel:COUNt[:BIN]? command allows you to determine the total number of assigned bins (bins containing measurement results).

If the multi-measurement state is on, the results are the average of a number of code domain power measurements. Multi-measurement state is off by default. To set up multi-measurements, see SETup:DOWQuality:COUNt[:SNUMber] .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Query

Range:

  • Active/Inactive: 0 = inactive, 1 = active; 9.91 E+37 (not available)
  • Walsh code: 0 to 31; 9.91 E+37
  • Spread Factor: 2, 4, 8, 16, 32; 9.91 E+37
  • Power: -100.0 to 0.0 dB; 9.91 E+37

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPower32:ICHannel?"
! Returns 128 comma separated values, each four values represent
! 1 or 0, Walsh code, spread factor, and power for each of 32 bins.

FETCh:DOWQuality:CDPower32:QCHannel[:ALL]?

Function

Queries the subtype 2 physical layer code domain power measurement results for all 32 bins on Q channel.

This query returns 128 comma separated values. These represent 4 values for each of 32 bins. The 4 values returned for each bin are: active/inactive, Walsh code, spread factor, and power (dB). See Code Domain Power Measurement Results Available by Numbered Bins for more information about these measurement results.

There are frequently fewer than 16 bins with measurement data. For any unassigned bins (bins that don't contain measurement results), four 9.91 E+37 results are returned instead of data. This allows the query to always return 128 results regardless of how many bins contain measurement data. The FETCh:DOWQuality:CDPower:QCHannel:COUNt[:BIN]? command allows you to determine the total number of assigned bins (bins containing measurement results).

If the multi-measurement state is on, the results are the average of a number of code domain power measurements. Multi-measurement state is off by default. To set up multi-measurements, see SETup:DOWQuality:COUNt[:SNUMber] .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Query

Range:

  • Active/Inactive: 0 = inactive, 1 = active; 9.91 E+37 (not available)
  • Walsh code: 0 to 31; 9.91 E+37
  • Spread Factor: 2, 4, 8, 16, 32; 9.91 E+37
  • Power: -100.0 to 0.0 dB; 9.91 E+37

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPower32:QCHannel?"
! Returns 128 comma separated values, each four values represent
! 1 or 0, Walsh code, spread factor, and power for each of 32 bins

FETCh:DOWQuality:CDPNoise:ICHannel:BIN? <bin num>

Function

Queries the I channel code domain power + noise measurement results for a specific bin. The results returned in the order of Walsh code, spread factor, noise power (dB) and power (dB), are the same as those returned for every bin using the FETCh:DOWQuality:CDPNoise[16]:ICHannel[:ALL]? or FETCh:DOWQuality:CDPNoise32:ICHannel[:ALL]? query.

The range of <bin num> is 0 to 15 (for subtype 0 physical layer) and 0 to 31 (for subtype 2 physical layer).

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Test Application Revision: A.06 and above, with the required feature license: Support for subtype 2 physical layer
Lab Application Revision: A.03 and above: Support for subtype 2 physical layer

Query

 Range:
Subtype 0 Physical Layer: see FETCh:DOWQuality:CDPNoise[16]:ICHannel[:ALL]?
Subtype 2 Physical Layer: see FETCh:DOWQuality:CDPNoise32:ICHannel[:ALL]?

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPNoise:ICHannel:BIN? 13"
! Queries the I channel code domain power + noise results for bin 13.

FETCh:DOWQuality:CDPNoise:ICHannel:COUNt[:BIN]?

Function

This query indicates how many I channel bins contain measurement data. For example, if 13 is returned, Q channel bins 0 through 12 contain measurement data and bins 13 through 15 (if for subtype 0 measurement) or bins 13 through 31 (if for subtype 2 measurement) contain 9.91 E+37 results.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Test Application Revision: A.06 and above, with the required feature license: Support for subtype 2 physical layer
Lab Application Revision: A.03 and above: Support for subtype 2 physical layer

Query

Range: 0 to 16 (for subtype 0 physical layer); 0 to 32 (for subtype 2 physical layer)

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPNoise:ICHannel:COUNt?"
! Returns the number of assigned bins (containing measurement results)

FETCh:DOWQuality:CDPNoise:QCHannel:BIN? <bin num>

Function

Queries the Q channel code domain power + noise results for a specific bin. The results returned in the order of Walsh code, spread factor, noise power (dB) and power (dB), are the same as those returned for every bin using the FETCh:DOWQuality:CDPNoise[16]:QCHannel[:ALL]? or FETCh:DOWQuality:CDPNoise32:QCHannel[:ALL]? query.

The range of <bin num> is 0 to 15 (for subtype 0 physical layer) and 0 to 31 (for subtype 2 physical layer).

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Test Application Revision: A.06 and above, with the required feature license: Support for subtype 2 physical layer
Lab Application Revision: A.03 and above: Support for subtype 2 physical layer

Query

 Range:
Subtype 0 Physical Layer: see FETCh:DOWQuality:CDPNoise[16]:QCHannel[:ALL]?
Subtype 2 Physical Layer: see FETCh:DOWQuality:CDPNoise32:QCHannel[:ALL]?

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPNoise:QCHannel:BIN? 13"
! Queries the Q channel code domain power + noise results for bin 13.

FETCh:DOWQuality:CDPNoise:QCHannel:COUNt[:BIN]?

Function

This query indicates how many Q channel bins contain measurement data. For example, if 13 is returned, Q channel bins 0 through 12 contain measurement data and bins 13 through 15 (if for subtype 0 measurement) or bins 13 through 31 (if for subtype 2 measurement) contain 9.91 E+37 results.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Test Application Revision: A.06 and above, with the required feature license: Support for subtype 2 physical layer
Lab Application Revision: A.03 and above: Support for subtype 2 physical layer

Query

Range: 0 to 16 (for subtype 0 physical layer); 0 to 32 (for subtype 2 physical layer)

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPNoise:QCHannel:COUNt?"
! Returns the number of assigned bins (containing measurement results)

FETCh:DOWQuality:CDPNoise[16]:ICHannel[:ALL]?

Function

Queries the subtype 0 physical layer code domain power + noise measurement results for all 16 bins on I channel.

This query returns 64 comma separated values. These represent 4 values for each of 16 bins. The 4 values returned for each bin are: Walsh code, spread factor, noise power (dB) and power (dB). See Code Domain Power + Noise Measurement Results Available Programmatically for more information about these measurement results.

There are frequently fewer than 16 bins with measurement data. For any unassigned bins (bins that don't contain measurement results), four 9.91 E+37 results are returned instead of data. This allows the query to always return 64 results regardless of how many bins contain measurement data. The FETCh:DOWQuality:CDPNoise:ICHannel:COUNt[:BIN]? command allows you to determine the total number of assigned bins (bins containing measurement results).

If the multi-measurement state is on, the results are the average of a number of code domain power measurements. Multi-measurement state is off by default. To set up multi-measurements, see SETup:DOWQuality:COUNt[:SNUMber] .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range:

  • Walsh code: 0 to 15; 9.91 E+37
  • Spread Factor: 4, 8, 16; 9.91 E+37
  • Noise Power: -100.0 to 0.0 dB; 9.91 E+37
  • Power: -100.0 to 0.0 dB; 9.91 E+37

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPNoise:ICHannel?"
! Returns Walsh code, spread factor, noise power and power for bin 0.
! Then returns the same for bin 1, and repeats until the values for the last bin
! (bin 15) have been returned
! (for a total of 64 comma separated values)

FETCh:DOWQuality:CDPNoise[16]:QCHannel[:ALL]?

Function

Queries the subtype 0 physical layer code domain power + noise measurement results for all 16 bins on Q channel.

This query returns 64 comma separated values. These represent 4 values for each of 16 bins. The 4 values returned for each bin are: Walsh code, spread factor, noise power (dB) and power (dB). See Code Domain Power + Noise Measurement Results Available Programmatically for more information about these measurement results.

There are frequently fewer than 16 bins with measurement data. For any unassigned bins (bins that don't contain measurement results), four 9.91 E+37 results are returned instead of data. This allows the query to always return 64 results regardless of how many bins contain measurement data. The FETCh:DOWQuality:CDPNoise:ICHannel:COUNt[:BIN]? command allows you to determine the total number of assigned bins (bins containing measurement results).

If the multi-measurement state is on, the results are the average of a number of code domain power measurements. Multi-measurement state is off by default. To set up multi-measurements, see SETup:DOWQuality:COUNt[:SNUMber] .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range:

  • Walsh code: 0 to 15; 9.91 E+37
  • Spread Factor: 4, 8, 16; 9.91 E+37
  • Noise Power: -100.0 to 0.0 dB; 9.91 E+37
  • Power: -100.0 to 0.0 dB; 9.91 E+37

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPNoise:QCHannel?"
! Returns Walsh code, spread factor, noise power and power for bin 0.
! Then returns the same for bin 1, and repeats until the values for the last bin
! (bin 15) have been returned
! (for a total of 64 comma separated values)

FETCh:DOWQuality:CDPNoise32:ICHannel[:ALL]?

Function

Queries the subtype 2 physical layer code domain power + noise measurement results for all 32 bins on I channel.

This query returns 128 comma separated values. These represent 4 values for each of 32 bins. The 4 values returned for each bin are: Walsh code, spread factor, noise power (dB) and power (dB). See Code Domain Power + Noise Measurement Results Available Programmatically for more information about these measurement results.

There are frequently fewer than 32 bins with measurement data. For any unassigned bins (bins that don't contain measurement results), four 9.91 E+37 results are returned instead of data. This allows the query to always return 128 results regardless of how many bins contain measurement data. The FETCh:DOWQuality:CDPNoise:ICHannel:COUNt[:BIN]? command allows you to determine the total number of assigned bins (bins containing measurement results).

If the multi-measurement state is on, the results are the average of a number of code domain power measurements. Multi-measurement state is off by default. To set up multi-measurements, see SETup:DOWQuality:COUNt[:SNUMber] .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Query

Range:

  • Walsh code: 0 to 31; 9.91 E+37
  • Spread Factor: 2, 4, 8, 16, 32; 9.91 E+37
  • Noise Power: -100.0 to 0.0 dB; 9.91 E+37
  • Power: -100.0 to 0.0 dB; 9.91 E+37

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPNoise32:ICHannel?"
! Returns 128 comma separated values, each four values represent
! walsh code, spread factor, noise power and power for each of 32 bins

FETCh:DOWQuality:CDPNoise32:QCHannel[:ALL]?

Function

Queries the subtype 2 physical layer code domain power + noise measurement results for all 32 bins on Q channel.

This query returns 128comma separated values. These represent 4 values for each of 32 bins. The 4 values returned for each bin are: Walsh code, spread factor, noise power (dB) and power (dB). See Code Domain Power + Noise Measurement Results Available Programmatically for more information about these measurement results.

There are frequently fewer than 32 bins with measurement data. For any unassigned bins (bins that don't contain measurement results), four 9.91 E+37 results are returned instead of data. This allows the query to always return 128 results regardless of how many bins contain measurement data. The FETCh:DOWQuality:CDPNoise:ICHannel:COUNt[:BIN]? command allows you to determine the total number of assigned bins (bins containing measurement results).

If the multi-measurement state is on, the results are the average of a number of code domain power measurements. Multi-measurement state is off by default. To set up multi-measurements, see SETup:DOWQuality:COUNt[:SNUMber] .

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Query

Range:

  • Walsh code: 0 to 31; 9.91 E+37
  • Spread Factor: 2, 4, 8, 16, 32; 9.91 E+37
  • Noise Power: -100.0 to 0.0 dB; 9.91 E+37
  • Power: -100.0 to 0.0 dB; 9.91 E+37

Programming Example

OUTPUT 714;"FETCh:DOWQuality:CDPNoise32:QCHannel?"
! Returns 128 comma separated values, each four values represent
! walsh code, spread factor, noise power and power for each of 32 bins


FETCh:SAUDio

FETCh:SAUDio

Diagram Conventions

FETCh:SAUDio[:ALL]?

Function

This query returns the swept audio measurement results. This query returns results in the following order: integrity indicator, average swept audio level and average distortion for the first frequency point, average swept audio level and average distortion for the second frequency point, and so on. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.

For frequencies above 10 kHz, this measurement returns 9.91 E+37.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Average audio level

  • Range: 1 mV to 20 V, 9.91 E+37
  • Resolution: the lesser of 4 significant digits or 10 uV

Average distortion

  • Range: 0 to 99.9%, 9.91 E+37
  • Resolution: 0.01%

FETCh:SAUDio:DISTortion[:AVERage]?

Function

This query returns a comma separated list of the audio distortion measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.

For frequencies above 10 kHz, this measurement returns 9.91 E+37.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Average audio distortion

  • Range: 0 to 99.9%, 9.91 E+37

  • Resolution: 0.01%

FETCh:SAUDio:DISTortion:MAXimum?

Function | This query returns a comma separated list of the maximum audio distortion measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command. For frequencies above 10 kHz, this measurement returns 9.91 E+37.
Requirements | Test Application Revision: A.01.20 and above Lab Application Revision: A.01 and above
Query | Range: 0 to 99.9%, 9.91 E+37 Resolution: 0.01%

FETCh:SAUDio:DISTortion:MINimum?

Function | This query returns a comma separated list of the minimum audio distortion measured at each frequency point in the sweep. For frequencies above 10 kHz, this measurement returns 9.91 E+37.
Requirements | Test Application Revision: A.01.20 and above Lab Application Revision: A.01 and above
Query | Range: 0 to 99.9%, 9.91 E+37 Resolution: 0.01%

FETCh:SAUDio:DISTortion:SDEViation?

Function | This query returns a comma separated list of the standard deviation audio distortion measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command. For frequencies above 10 kHz, this measurement returns 9.91 E+37.
Requirements | Test Application Revision: A.01.20 and above Lab Application Revision: A.01 and above
Query | Range: 0 to 99.9%, 9.91 E+37 Resolution: 0.001%

FETCh:SAUDio:ICOunt?

Function | This query returns the intermediate count of swept audio multi-measurements completed. The total measurement count is the number of measurements specified in with the multi-measurement count command, SETup:SAUDio:COUNt[:SNUMber] , times the number of frequency points specified with the SETup:SAUDio:FREQuency:POINts . Therefore, when completing a 5 point sweep with multi-measurements turned off, the measurement will return 5 not 1. See also SETup:SAUDio:ICOunt:MAXimum? .
Requirements | Test Application Revision: A.01.20 and above Lab Application Revision: A.01 and above
Query | Range: 1 to 999 x 60 Resolution: 1

FETCh:SAUDio:INTegrity?

Function | This query returns the integrity indicator for the last swept audio measurement completed. Zero indicates a normal measurement. See Integrity Indicator for descriptions of non-zero integrity indicators.
Requirements | Test Application Revision: A.01.20 and above Lab Application Revision: A.01 and above
Query | Range: See Integrity Indicator . Resolution: 1

FETCh:SAUDio:SINAD[:AVERage]?

Function

This query returns a comma separated list of the average SINAD measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Average SINAD

  • Range: -99.99 to 99.99 dB, 9.91 E+37

  • Resolution: 0.01 dB

FETCh:SAUDio:SINAD:MAXimum?

Function | This query returns a comma separated list of the maximum SINAD measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Requirements | Test Application Revision: A.01.20 and above Lab Application Revision: A.01 and above
Query | Range: -99.99 to 99.99 dB, 9.91 E+37 Resolution: 0.01 dB

FETCh:SAUDio:SINAD:MINimum?

Function | This query returns a comma separated list of the minimum SINAD measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Requirements | Test Application Revision: A.01.20 and above Lab Application Revision: A.01 and above
Query | Range: -99.99 to 99.99 dB, 9.91 E+37 Resolution: 0.01 dB

FETCh:SAUDio:SINAD:SDEViation?

Function | This query returns a comma separated list of the standard deviation of SINAD measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Requirements | Test Application Revision: A.01.20 and above Lab Application Revision: A.01 and above
Query | Range: 0 to 99.99 dB, 9.91 E+37 Resolution: 0.001 dB

FETCh:SAUDio:VOLTage[:AVERage]?

Function | This query returns a comma separated list of the average swept audio level measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command. Value is returned in units of V.
Requirements | Test Application Revision: A.01.20 and above Lab Application Revision: A.01 and above
Query | Range: 1 mV to 20, 9.91 E+37 Resolution: 4 significant digits

FETCh:SAUDio:VOLTage:MAXimum?

Function | This query returns a comma separated list of the maximum audio voltage measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Requirements | Test Application Revision: A.01.20 and above Lab Application Revision: A.01 and above
Query | Range: 1 mV to 20 V, 9.91 E+37 Resolution: 4 significant digits

FETCh:SAUDio:VOLTage:MINimum?

Function | This query returns a comma separated list of minimum audio voltage measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Requirements | Test Application Revision: A.01.20 and above Lab Application Revision: A.01 and above
Query | Range: 1 mV to 20 V, 9.91 E+37 Resolution: 4 significant digits

FETCh:SAUDio:VOLTage:SDEViation?

Function | This query returns a comma separated list of the standard deviation of audio voltage measured at each point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Requirements | Test Application Revision: A.01.20 and above Lab Application Revision: A.01 and above
Query | Range: 1 mV to 20 V, 9.91 E+37 Resolution: 4 significant digits


FETCh:SMONitor

FETCh:SMONitor

Diagram Conventions

FETCh:SMONitor[:ALL]?

Function

Queries the Spectrum Monitor measurement results.

This query returns 402 comma-separated values, in the order of an integrity value followed by 401 points representing the amplitude results (in dBm) of the trace data for the last spectrum monitor measurement performed.

See Integrity Indicator for descriptions of non-zero integrity indicators.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Integrity Indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Trace Data:

  • For spans of 125 kHz and 500 kHz

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: -50 to +55 dB

  • For all other spans

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: (reference level - 60 dB) to +55 dB

FETCh:SMONitor:INTegrity?

Function | Returns the integrity indicator value for the last spectrum monitor measurement performed. Zero indicates a normal result. See Integrity Indicator for descriptions of non-zero integrity indicators.
Requirements | Test Application Revision: A.01.20 and above Lab Application Revision: A.01 and above
Query | Range: See Integrity Indicator . Resolution: 1

FETCh:SMONitor:TRACe?

Function

 Queries the spectrum monitor and returns 401 points representing the amplitude results (in dBm) of the trace data.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range:

  • For spans of 125 kHz and 500 kHz

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: -50 to +55 dB

  • For all other spans

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: (reference level - 60 dB) to +55 dB


FETCh:TROPower

FETCh:TROPower

Diagram Conventions

FETCh:TROPower[:ALL]?

Function

Queries the time response of open loop power control measurement results.

This measurement returns results in the following order: integrity, time response of open loop power pass/fail result. See TROLPC Measurement Results .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

  • Resolution: 1

Time response of open loop power pass/fail result

  • Range: 0 to 1 (0 = passed, 1 = failed), 9.91 E+37 (undefined)

  • Resolution: 1

Programming Example

OUTPUT 714;"FETCh:TROPower?"

FETCh:TROPower:MASK[:FAIL]?

Function

Queries the pass/fail results of the time response of open loop power control measurement. If any measurement data points fail to meet the requirements of the mask shown on the test set's display, the measurement will fail. See TROLPC Measurement Results .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

 Range: 0 to 1 (0 = passed, 1 = failed), 9.91 E+37 (undefined)

Programming Example

OUTPUT 714;"FETCH:TROPower:MASK?"

FETCh:TROPower:TRACe?

Function

Queries the time response of open loop power control trace.

A total of 371 comma-separated values are returned. If valid measurement results are available, each comma-separated measurement value will be 16 characters in length and represent the change (delta) of power level in units of dB. If no trace is present, each comma-separated value is 7 characters in length (9.91E37).

The first value corresponds to t = 0 ms. The last value corresponds to t = 100 ms. This implies that the time between values is 100 ms ÷ 370 (approximately 270.270 µs).

Returned values are in dB.

See TROLPC Measurement Results , "Power Versus Time Data Points."

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 2967 to 6306 characters, representing 371 values.

Programming Example

OUTPUT 714;"FETCH:TROPower:TRACe?"


INITiate

INITiate

Last updated: June 30, 2006

Diagram Conventions

INITiate:<measurement mnemonic>[:ON]

Function

This command initiates (starts) the specified measurements:

  • AFANalyzer - Audio Frequency Analyzer measurement

  • CAPPower - Access Probe Power measurement

  • CFDTune - Fast Device Tune measurement ( lab application or feature-licensed test application only )
  • CPERror - Packet Error Rate measurement

  • CPOWer - Channel Power measurement

  • CTDPower - TX Dynamic Power measurement

  • CTXSpurious - TX Spurious Emissions measurement

  • DAPower - Digital Average Power measurement

  • DOWQuality - Waveform Quality measurement

  • GAPPower - Graphical Access Probe Power measurement (lab application only)

  • SAUDio - Swept Audio measurement

  • SMONitor - Spectrum Monitor

  • TROPower - Time Response of Open Loop Power Control measurement

The INITiate command is associated with the SETup Subsystem and the FETCh? Subsystem .

One or more measurements can be initiated with the same program line (see Concurrent Measurements and the Programming Example below).

See INITiate Programming Examples (how INIT commands are used) .
Requirements Test Application Revision: A.01.20 and above
Test Application Revision: A.02.20 and above: Added CTDPower
Lab Application Revision: A.01 and above: Added GAPPower
Test Application Revision A.06 and above with the required feature license: added CFDTune
Lab Application Revision: A.03 and above: Added CFDTune

Programming Example

OUTPUT 714;"INITiate:CPOWer;DOWQuality"
! Initiates a channel power and a waveform quality measurement.

INITiate:CFDTune:ARMed?

Function

Queries the arm state of the fast device tune measurement.

  • This command immediately returns a 1 if the fast device tune measurement has been initiated and is ready to be triggered.
  • This command hangs if the fast device tune measurement has been initiated but is not ready to be triggered (it will return a 1 once the measurement becomes ready to be triggered).
  • This command immediately returns a 0 if the fast device tune measurement is not in the process of preparing for a trigger (for example, if the fast device tune measurement has not been initiated, has been aborted, or has already been triggered).

Query

Range: 0 | 1

Requirement

Test Application Revision A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"INITiate:CFDTune:ARMed?"
!Queries whether the test set's hardware is successfully
!set up for FDT measurement.

INITiate:<measurement mnemonic>:OFF

Function

Deactivates the selected measurement. See Measurement States .

Only one measurement can be deactivated at a time. See INITiate:<measurement mnemonic>[:ON] for a list of the measurement mnemonics.

To stop one or more measurements and leave them in the active state, use ABORt .
Requirements Test Application Revision: A.01.20 and above
Test Application Revision: A.02.20 and above: Added CTDPower
Lab Application Revision: A.01 and above: Added GAPPower
Test Application Revision A.06 and above with the required feature license: added CFDTune
Lab Application Revision: A.03 and above: Added CFDTune

Programming Example

OUTPUT 714;"INITiate:CPOWer:OFF"
! Deactivates the channel power measurement.

INITiate:COUNt?

Function

Queries the number of measurements that have been initiated (are active). See Measurement States .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 0 to 10

Programming Example

OUTPUT 714;"INITiate:COUNt?"
! Queries the number of currently active measurements

INITiate:DONE?

Function

Queries (one at a time) which measurements, if any, are finished or have timed-out.

See INITiate Programming Examples (how INIT commands are used) and Measurement Event Synchronization for how to use this command.

See Measurement States to understand the test set's measurement states.

See INITiate:DONE:FLAG:<measurement mnemonic> for include or exclude commands.
Requirements Test Application Revision: A.01.20 and above
Test Application Revision: A.02.20 and above: Added CTDPower
Lab Application Revision: A.01 and above: Added GAPPower
Test Application Revision A.06 and above with the required feature license: added CFDTune
Lab Application Revision: A.03 and above: Added CFDTune
Query

Range:

  • AFAN - Audio Frequency Analyzer measurement

  • CAPP - Access Probe Power measurement

  • CFDT - Fast Device Tune measurement ( Only applicable to the lab application or feature-licensed test application )

  • CPER - Packet Error Rate measurement

  • CPOW - Channel Power measurement

  • CTDP - TX Dynamic Power measurement

  • CTXS - TX Spurious Emissions measurement

  • DAP - Digital Average Power measurement

  • DOWQ - Waveform Quality measurement

  • GAPP - Graphical Access Probe Power measurement ( Only applicable to the lab application )

  • SAUD - Swept Audio measurement

  • SMON - Spectrum Monitor

  • TROP - Time Response of Open Loop Power Control measurement

  • NONE - there are no measurements in the measuring state.
  • WAIT - there are one or more measurements in the measuring state, and none are ready to be fetched.

Programming Example

OUTPUT 714;"INITiate:DONE?"
!Queries which measurements are finished

INITiate:DONE:CLEar

Function

Clears the done flag from all measurements. See INITiate:DONE? and INITiate:DONE:FLAG[:ALL] .
Requirements Test Application Revision: A.01.20 and above
Test Application Revision: A.02.20 and above: Added CTDPower
Lab Application Revision: A.01 and above: Added GAPPower
Test Application Revision A.06 and above with the required feature license: added CFDTune
Lab Application Revision: A.03 and above: Added CFDTune

Programming Example

OUTPUT 714;"INITiate:DONE:CLEar"
! Clears the done flag from all measurements

INITiate:DONE:FLAG[:ALL]

Function

Specifies that all measurements are either included or excluded when the INITitate:DONE? query is sent.

If a measurement trigger arm is left in continuous mode, the done flag for that measurement will toggle between DONE and WAIT. The INITiate:DONE? query will probably not be able to catch the measurement at the instant it is done; therefore, the measurement will never appear to be done. If a measurement's triggering must be continuously armed, you should exclude the measurement using INITiate:DONE:FLAG:<measurement mnemonic> .

Use INITitate:DONE:FLAG:ALL EXCLude to exclude all measurements.

Once INITiate:DONE:FLAG has been set to EXCLude for a measurement, the user must send the INCLude command for that measurement in order to query that measurement with the INITiate:DONE? query. The test set will not reset any excluded measurement with any type of preset.
Requirements Test Application Revision: A.01.20 and above
Test Application Revision: A.02.20 and above: Added CTDPower
Lab Application Revision: A.01 and above: Added GAPPower
Test Application Revision A.06 and above with the required feature license: added CFDTune
Lab Application Revision: A.03 and above: Added CFDTune

Setting

Range: INCLude|EXCLude

*RST Setting

 INCLude

Programming Example

OUTPUT 714;"INITiate:DONE:FLAG INCLude"

! Includes all measurements in the INITiate:DONE? query.

INITiate:DONE:FLAG:<measurement mnemonic>

Function

Specifies if a measurement done flag is considered (using the INCLude or EXCLude settings) when the INITitate:DONE? query is sent. See INITiate:<measurement mnemonic>[:ON] for a list of the measurement mnemonics.

If more than one measurement is active, and one or more measurement trigger arm states is continuous, the INITiate:DONE? query may not be effective. The best solution is to change the arm state of all measurements to single using the SETup:CONTinuous command. However, if a measurement must be continuously triggered, you should exclude the measurement using the EXCLude setting provided by this command if you want to use INITiate:DONE? to query measurement done status.

The test set will not reset any excluded measurement to included with any type of preset.
Requirements Test Application Revision: A.01.20 and above
Test Application Revision: A.02.20 and above: Added CTDPower
Lab Application Revision: A.01 and above: Added GAPPower
Test Application Revision A.06 and above with the required feature license: added CFDTune
Lab Application Revision: A.03 and above: Added CFDTune

Setting

Range: INCLude|EXCLude

*RST Setting

 INCLude

Programming Example

OUTPUT 714;"INITiate:DONE:FLAG:DAPower EXCLude"
!Excludes the digital average power measurement from responding to the INITiate:DONE? query.

INITiate:ON?

Function

Queries the measurements that are on. See Measurement States .

Returns a comma separated list of measurement mnemonics.
Requirements Test Application Revision: A.01.20 and above
Test Application Revision: A.02.20 and above: Added CTDPower
Lab Application Revision: A.01 and above: Added GAPPower
Test Application Revision A.06 and above with the required feature license: added CFDTune
Lab Application Revision: A.03 and above: Added CFDTune

Query

Range:

  • AFAN - Audio Frequency Analyzer measurement

  • CAPP - Access Probe Power measurement

  • CFDTune - Fast Device Tune measurement

  • CPER - Packet Error Rate measurement

  • CPOW - Channel Power measurement

  • CTDP - TX Dynamic Power measurement

  • CTXS - TX Spurious Emissions measurement

  • DAP - Digital Average Power measurement

  • DOWQ - Waveform Quality measurement

  • GAPPower - Graphical Access Probe Power measurement (lab application only)

  • SAUD - Swept Audio measurement

  • SMON - Spectrum Monitor

  • TROP - Time Response of Open Loop Power Control measurement

  • NONE - no measurements are on

Programming Example

OUTPUT 714;"INITiate:ON?"
! Queries which measurements are on.


INITiate Subsystem

INITiate Subsystem

May 24, 2006

Syntax Diagrams and Command Descriptions

INITiate

Description

INITiate Command Functions

The INITiate subsystem is used to:

  • Start (activate) individual or multiple (concurrent) measurements.

  • Turn individual measurements off.

  • Determine the number of measurements currently active (INIT:COUNT?).

  • Determine the names of the measurements currently active (INIT:ON?).

  • Determine which measurements are finished (INIT:DONE?).

What Happens When a Measurement is INITiated?

When a measurement is started using INITiate commands, a new measurement cycle is started. If the selected measurement is currently in a measurement cycle, it is aborted. If a timeout is specified, the timeout period begins when a measurement is initiated.

NOTE
The INITiate subsystem is derived from SCPI, but has some modifications to make it more compatible with the manual operation of the test set. Most notably, the choice of single or continuous measurement triggering is made using the SETup subsystem.

INITiate Programming Examples (how INIT commands are used)

The INITiate command is used to start measurements.

INITiate commands allow multiple measurements to be started without waiting for other measurement processes to complete. For example, the following program example starts the Digital Average Power and Waveform Quality measurements, and then uses the INITiate:DONE? command in a loop to query the completion status of these measurements. See Measurement Event Synchronization .

As each measurement is completed, the FETCh command can be used to acquire the results, and the results entered into variables in the controlling application.

This program ends when the INITiate:DONE? command returns the string `NONE' indicating that all initiated measurements have gone through the measuring state see Measurement States .

The INIT:DONE? command is only useful when performing concurrent testing. When initiating only one measurement at a time, simply send the INITiate command immediately followed by the FETCh command to retrieve the results.

Trigger arming for each measurement is controlled in the SETup subsystem. The choices are single or continuous. The best practice (during remote operation) is to use single measurement mode. This simplifies the tasks of starting concurrent measurements, then using the INIT subsystem commands to determine which measurements are ready to be FETChed.

10       OUTPUT 714;"SETup:ALL:CONTinuous:OFF"
20       ! select single trigger mode for all measurements.
30       OUTPUT 714;"INITiate:DAPower;DOWQuality"
40       ! start digital average power and waveform quality measurements.
50       LOOP
60           OUTPUT 714;"INITiate:DONE?"
70           ! query to find out if any measurements are done.
80           ENTER 714;Meas_complete$
90           SELECT Meas_complete$
100           CASE "DAP"
110           ! test for the string "DAP" indicating
120           ! digital average power measurement is done.
130               OUTPUT 714;"FETCh:DAPower?"
140               ! query digital average power measurement.
150               ENTER 714;Dap_int;Dapower
160           CASE "DOWQ"
170           ! test for the string "DOWQ" indicating
180           ! that the waveform quality measurement is done.
190               OUTPUT 714;"FETCh:DOWQ:RHO?"
200               ! query rho.
210               ENTER 714;Rho
220           END SELECT
230       EXIT IF Meas_complete$="NONE"
240       END LOOP
250       PRINT Dapower
260       PRINT Rho
270       END


READ

READ

Last updated: June 30, 2006

Diagram Conventions

READ:AFANalyzer[:ALL]?

Function

Initiates and fetches an audio frequency analyzer measurement as a sequential operation.

Measurement results are returned in the following order: integrity, average audio level, average SINAD, average audio distortion.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

  • Resolution: 1

Average audio level

  • Range: 0 to 20 volts, 9.91 E+37
  • Resolution: the lesser of 4 significant digits or 10 uV.

Average SINAD

  • Range: -99.00 to 99.00 dB, 9.91 E+37
  • Resolution: 0.01 dB

Average audio distortion

  • Range: 0.00 to 99.00%, 9.91 E+37
  • Resolution: 0.01%

READ:CAPPower[:ALL]?

Function

Initiates and fetches an access probe power measurement as a sequential operation.

Measurement results are returned in the following order: integrity, access probe power.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

  • Resolution: 1

Access probe power

  • Range: -100.00 to 100.00 dBm, 9.91 E+37
  • Resolution: 0.01 dB

READ:CFDTune[:ALL]?

Function

Initiates and fetches a fast device tune measurement as a sequential operation.

Results are returned in the following order:

  • Integrity
  • Number of Frequency Steps
  • Number of Power Steps
  • Number of MS TX power steps measured (in most cases, it equals Number of Frequency Steps multiplied by Number of Power Steps )
  • Comma-separated list of 400 MS Tx Power results. 400 results are always returned; if the test set measured fewer than 400 power steps from the mobile, the remaining values are NANs (9.91E+37). The power results for the first frequency in the MS TX Frequency Sequence are returned first, then the power results for the second frequency in the MS TX Frequency Sequence, etc., followed by NANs if fewer than 400 points were measured.

See Fast Device Tune Measurement Results .
Query

Integrity

  • Range: 0 to 31 (see Integrity Indicator )

  • Resolution: 1

Number of Frequency Steps

  • Range: 1 to 20, 9.91 E+37

  • Resolution: 1.0

Number of Power Steps

  • Range: 1 to 20, 9.91 E+37

  • Resolution: 1.0

Number of MS Tx Power Steps Measured

  • Range: 1 to 400, 9.91 E+37

  • Resolution: 1.0

MS Tx Power Results Array

  • Range: -100.00 to +100.00 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Requirement

Test Application Revision: A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

READ:CPERror[:ALL]?

Function

Initiates and fetches the PER (packet error rate) measurement as a sequential operation.

This measurement returns up to 5 results in the following order:
integrity, confidence pass/fail, packet error rate, packet error count, packets tested.

See Packet Error Rate (PER) Measurement Description ).

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

  • Resolution: 1

Confidence Pass/Fail

  • Range: 0 to 2 (0 = passed, 1 = failed, 2 = max packets), 9.91 E+37 indicates undefined

Packet Error Rate

  • Range: 0.00 to 100.00, 9.91 E+37

  • Resolution: 0.01 %

Packet Error Count

  • Range: 0 to 10,000,000, 9.91 E+37

  • Resolution: 1 packet

Packets Tested

  • Range: 0 to 10,000,000, 9.91 E+37

  • Resolution: 1 packet

READ:CPOWer[:ALL]?

Function

Initiates and fetches a channel power measurement as a sequential operation.

Measurement results are returned in the following order: integrity, average channel power.

If the multi-measurement state is on, the result represents the average of a number of channel power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:CPOWer:COUNt[:SNUMber] .

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

  • Resolution: 1

Channel power

  • Range: -100.00 to 100.00 dBm, 9.91 E+37
  • Resolution: 0.01 dB

READ:CTDPower[:ALL]?

Function

Initiates and fetches Tx dynamic power measurement as a sequential operation.

Measurement result returns a comma separated list of 101 values in the order of an integrity value followed by 100 power results. If the dynamic power measurement consists of less than 100 measurement steps (determined by FETCh:CTDPower:COUNt[:STEP]? ), the query results will be padded with NAN's (9.91 E+37), which means no results were available.

Requirements

Test Application Revision: A.02.20 and above
Lab Application Revision: A.01 and above
Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

  • Resolution: 1

Power result

  • Range: -100.00 to 100.00 dBm, 9.91 E+37
  • Resolution: 0.01 dB

READ:CTXS purious[:ALL]?

Function

Initiates and fetches the TX spurious emission measurement as a sequential operation.

FER measurement results are returned in the following order: integrity,TX spurious emission pass/fail result, lower adjacent channel (-0.885 or -1.25 MHz) average spurious emissions, upper adjacent channel (+0.885 or +1.25 MHz) average spurious emissions, lower alternate channel (-1.98 MHz) average spurious emissions, upper alternate channel (+1.98 MHz) average spurious emissions.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

  • Resolution: 1

TX spurious emissions pass/fail result

  • Range: 0 to 1 (0 = passed, 1 = failed), 9.91 E+37

Lower adjacent channel spurious emissions

  • Range: 0.00 to -80.00 dBc, 9.91 E+37

  • Resolution: 0.01 dBc

Upper adjacent channel spurious emissions

  • Range: 0.00 to -80.00 dBc, 9.91 E+37

  • Resolution: 0.01 dBc

Lower alternate channel spurious emissions

  • Range: 0.00 to -80.00 dBc, 9.91 E+37

  • Resolution: 0.01 dBc

Upper alternate channel spurious emissions

  • Range: 0.00 to -80.00 dBc, 9.91 E+37

  • Resolution: 0.01 dBc

READ:DAPower[:ALL]?

Function

Initiates and fetches a digital average power measurement as a sequential operation.

Measurement results are returned in the following order: integrity, digital average transmit power.

If the multi-measurement state is on, the result represents the average of a number of digital average power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:DAPower:COUNt[:SNUMber] .

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

  • Resolution: 1

Digital average power:

  • Range: -100.00 to 100.00 dBm, 9.91 E+37
  • Resolution: 0.01 dB

READ:DOWQuality[:ALL]?

Function

Initiates and fetches the waveform quality measurements as a sequential operation.

Measurement results are returned in the following order: integrity, rho, frequency error, time error (in seconds), carrier feedthrough, phase error (in degrees), magnitude error, EVM.

If the multi-measurement state is on, each result represents the average of a number of waveform quality measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:DOWQuality:COUNt[:SNUMber] .

See Waveform Quality + Code Domain Measurement Description .

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Query

Integrity

  • Range: 0 to 23 see Integrity Indicator
  • Resolution: 1

Rho

  • Range: 0.0000 to 1.0000, 9.91 E+37
  • Resolution: 0.0001

Frequency Error

  • Range: -9999.0 to 9999.0 Hz, 9.91 E+37
  • Resolution: 0.1 Hz

Time Error

  • Range: -99.99 E-6 to 99.99 E-6 s, 9.91 E+37
  • Resolution: 0.01 E-6 s

Carrier Feedthrough

  • Range: -100.00 to 0.00 dBc, 9.91 E+37
  • Resolution: 0.01 dB

Phase Error

  • Range: 0.00 to 359.99 degrees, 9.91 E+37
  • Resolution: 0.01 degrees

Magnitude Error

  • Range: 0.00 to 100.00%, 9.91 E+37
  • Resolution: 0.01%

Error Vector Magnitude (EVM)

  • Range: 0.00 to 100.00%, 9.91 E+37
  • Resolution: 0.01%

READ:GAPPower[:ALL][:RANGe20]?

Function

Initiates and fetches a graphical access probe power measurement cycle as a sequential operation.

This query returns 21 comma-separated values, in the order of an overall integrity value, followed by 20 power results for the first 20 access probes.

If the measurement consists of less than 20 access probes, the remaining power results will be returned as 9.91 E+37, which means no results were available.

You can use FETCh:GAPPower[:ALL]:RANGe60? to query power results for up to 60 access probes.

The total number of the access probes measured is equal to Probe Sequence Max times Probe Num Step .

If the test set does not receive the expected number of access probes and no timeouts have been set up (see SETup:GAPPower:TIMeout[:STIMe] ), this command will hang indefinitely.

Requirements

Lab Application Revision: A.01 and above
Query

Integrity

  • Range: 0 to 23 (see Integrity Indicator )

    Resolution: 1

Access probes

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.0000001 dBm

READ:GAPPower[:ALL]:RANGe60?

Function

Initiates and fetches a graphical access probe power measurement cycle as a sequential operation.

This query returns 61 comma-separated values, in the order of an overall integrity value, followed by 60 power results for the first 60 access probes.

If the measurement consists of less than 60 access probes, the remaining power results will be returned as 9.91 E+37, which means no results were available.

You can use FETCh:GAPPower[:ALL][:RANGe20]? to query power results for up to 20 access probes.

The total number of the access probes measured is equal to Probe Sequence Max times Probe Num Step .

If the test set does not receive the expected number of access probes and no timeouts have been set up (see SETup:GAPPower:TIMeout[:STIMe] ), this command will hang indefinitely.

Requirements

Lab Application Revision: A.01 and above
Query

Integrity

  • Range: 0 to 23 (see Integrity Indicator )

    Resolution: 1

Access probes

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.0000001 dBm

READ:SAUDio[:ALL]?

Function

Initiates and fetches a swept audio measurement as a sequential operation.

Measurement results are returned in the following order: integrity, and a comma separated list of average audio level and average audio distortion for each frequency point in the sweep.

For frequencies about 10 kHz, the measurement will return 9.91 E+37.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

  • Resolution: 1

Average Audio Level

  • Range: 1 mV to 20 V, 9.91 E+37
  • Resolution: the lesser of 4 significant digits or 10 uV

Average Audio Distortion

  • Range: 0 to 99.9%, 9.91E+37
  • Resolution: 0.1

READ:SMONitor:TRACe?

Function

Initiates and fetches a spectrum monitor measurement as a sequential operation.Returns a comma separated list of 401 points representing the amplitude results of the trace data.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range

  • For spans of 125 kHz and 500 kHz
    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: -50 to +55 dB
  • For all other spans
    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: (reference level - 60 dB) to +55 dB

READ:TROPower[:ALL]?

Function

Initiates and fetches a time response of open loop power control measurement as a sequential operation.

Measurement results are returned in the following order: integrity, time response of open loop power control pass/fail result. For the pass/fail result, 0 = pass, 1 = fail, 9.91 E+37 = undefined.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

  • Resolution: 1

Time Response of Open Loop Power Control

  • Range: 0, 1, 9.91 E+37


READ? Subsystem

READ? Subsystem

May 24, 2006

Syntax Diagram and Command Descriptions

READ

Description

The READ? command provides a sequential method to make measurements and retrieve the results. READ? will hang the GPIB bus until the measurement is completed, or until the timeout value has been exceeded. Associated SETup commands (for each measurement) are used with the READ? command to retrieve desired measurement results in a sequential manner.

Sending a READ? command is equivalent to an INITiate/FETCh cycle for a measurement. A READ? command executes an abort action on that measurement followed by an INITiate and a FETCH?.

READ? commands can be mixed with FETCH? queries in order to make combinations of sequential and overlapped operations. One measurement can be issued a READ? command (sequential), and the next measurement can be issued INITiate/FETCh? commands (overlapped), if necessary.

The advantage of using the READ? commands to obtain measurement results, as opposed to the INITiate/FETCh method is:

  • It is simpler. Fewer commands are required to obtain measurement results.

Some disadvantages of using READ? over INITiate and FETCh are:

  • The test set does not process any additional GPIB commands until the requested measurement results are available.
  • The sequential nature of the READ? command does not allow the user to make concurrent measurements. Concurrent measurements require the overlapped commands INITiate, DONE? and FETCh? .
  • The READ? command does not provide measurement results such as statistics that are available using the INITiate/FETCh method.
  • The READ? commands have pre-defined measurement results. If additional results are needed from a measurement they may be obtained with a FETCh? query.

NOTE
Trigger arming for each measurement is controlled in the SETup subsystem. Best practice during remote operation is to set trigger arm to single (Continuous Off).

Program Example - READ:DAPower?

OUTPUT 714;"READ:DAPower?" ! Starts digital average power measurement. As soon as the
                           ! measurement cycle has completed, the test set
                           ! provides the digital average power measurement results to the
                           ! controlling application.
ENTER 714;Integrity, Dapower ! Enters the integity indicator and
                             ! digital average power measurement values into
                       ! controlling application.


RFANalyzer

RFANalyzer

Diagram Conventions

RFANalyzer:AUTO:POWer<[:SELected]|:DIGital856>?

Function

Queries the expected input power when receiver power control mode is set to automatic using the RFANalyzer:CONTrol:POWer:AUTO command. For subtype 2 physical layer, this query returns the value calculated based on Expected Power [Pre]. See Expected Power for information on how the expected input power level is determined by the test set in automatic mode.

The optional [:SELected] keyword in this command specifies that the expected input power being queried applies to the current system type (see System Type ).

Receiver power control mode is always manual in CW Operating Mode . To the expected input power when in CW operating mode, use RFANalyzer:CW:EXPected:POWer .

See Receiver Control for more information about manual versus automatic receiver control.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: -69 dBm to +30 dBm

Resolution: 0.01 dBm
*RST setting

-20.72 dBm

Expected power due to the following *RST settings:

  • Cell Power: -55 dBm/1.23 MHz
  • Open Loop Adjust: 81 dB
  • Probe Initial Adjust: 0 dB
  • Data Offset Nom: 0 dB
  • Data Offset 9k6: 0 dB

Programming Example

OUTPUT 714;"RFANalyzer:AUTO:POWer:SELected?"
!Queries the expected input power when receiver power control mode
!is set to automatic.

RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO

Function

Sets/queries the receiver measurement frequency control mode.

ON = automatic control

OFF = manual control

The receiver measurement frequency can also be set to manual control using the RFANalyzer:MANual:MEASurement[:MFRequency] command.

Receiver measurement frequency control is always manual in CW Operating Mode . See Receiver Control for more information about manual versus automatic receiver control.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

 Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (automatic)

Programming Example

OUTPUT 714;"RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO OFF"
!Enables manual control of the receiver measurement frequency.

RFANalyzer:CONTrol:POWer:AUTO

Function

Sets/queries the receiver power control mode.

ON = automatic receiver power control

OFF = manual receiver power control

Receiver power control is always manual in CW Operating Mode . To set the receiver expected input power manually, use RFANalyzer:CW:EXPected:POWer in CW operating mode and use RFANalyzer:MANual:POWer<[:SELected]|:DIGital856> in Active Cell and IS-856 Test operating mode. See Receiver Control for more information about manual versus automatic receiver control.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (automatic)

Programming Example

OUTPUT 714;"RFANalyzer:CONTrol:POWer:AUTO OFF"
!Enables manual control of the expected input power level.

RFANalyzer:CONTrol:UPLink:FREQuency:AUTO

Function

Sets/queries the receiver demodulation frequency control mode.

ON = automatic control

OFF = manual control

The receiver demodulation frequency can also be set to manual using the RFANalyzer:MANual:UPLink[:MFRequency] command.

This command applies to IS-856 Test Operating Mode and CW Operating Mode .There is no manual control of the receiver demodulation frequency while in Active Cell Operating Mode .

Receiver demodulation frequency control is always manual in CW Operating Mode . See Receiver Control for more information about manual versus automatic receiver control.

Requirements

 Test Application Revision: A.05 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (on)

Programming Example

OUTPUT 714;"RFANalyzer:CONTrol:UPLink:FREQuency:AUTO OFF"
!Enables manual control of the receiver demodulation frequency.

RFANalyzer:CW:EXPected:POWer

Function

Sets/queries the expected CW input power.

This command only applies to CW Operating Mode .

Receiver power control is always manual in CW Operating Mode . See Receiver Control for more information about manual versus automatic receiver control.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: -80 dBm to +93 dBm (This is the range of settings accepted, see Expected Power for the actual hardware range of the detector)

Resolution: 0.01 dBm

Query

 Same as setting
*RST setting +13 dBm

Programming Example

OUTPUT 714;"RFANalyzer:CW:EXPected:POWer -20"
!Sets the expected CW input power level to -20 dBm

RFANalyzer:MANual:MEASurement[:MFRequency]

Function

The setting form of this command performs two functions: (1) sets the receiver measurement frequency (see RFANalyzer:MANual:MEASurement:FREQuency ), and (2) sets the receiver measurement frequency mode to manual (see RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO ).

The query form of this command returns the receiver measurement frequency.

If no units are specified the setting defaults to Hz.

The receiver measurement frequency mode is always manual for CW Operating Mode so this command performs the same function as RFANalyzer:MANual:MEASurement:FREQuency when in CW operating mode.

See Receiver Control for more information about manual versus automatic receiver control.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

 Range/Resolution: See RFANalyzer:MANual:MEASurement:FREQuency

Query

 Range/Resolution: See RFANalyzer:MANual:MEASurement:FREQuency
*RST setting 896000000 Hz (but *RST returns receiver measurement frequency mode to automatic)

Programming Example

OUTPUT 714;"RFANalyzer:MANual:MEASurement 942.6 MHZ"
!Enables manual control of the receiver measurement frequency and
!sets the tune frequency to 942.6 MHz.

RFANalyzer:MANual:MEASurement:FREQuency

Function

Sets/queries the receiver measurement frequency when the receiver measurement frequency control mode is set to manual (see RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO ). If no units are specified the setting defaults to Hz.

The receiver measurement frequency can also be set using the RFANalyzer:MANual:MEASurement[:MFRequency] command.

The receiver measurement frequency is always manual in CW Operating Mode . See Receiver Control for more information about manual versus automatic receiver control.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

 Same as setting
*RST setting 896000000 Hz

Programming Example

OUTPUT 714;"RFANalyzer:MANual:MEASurement:FREQuency 942.6 MHZ"
!Sets the receiver measurement frequency to 942.6 MHz
!when in manual control mode.

RFANalyzer:MANual:POWer<[:SELected]|:DIGital856>

Function

Sets/queries the expected input power when the receiver power control mode is set to manual using the RFANalyzer:CONTrol:POWer:AUTO command in Active Cell and IS-856 Test operating mode.

The optional [:SELected] keyword in this command specifies that the expected input power setting applies to the current system type (see System Type ).

Receiver power control is always manual in CW Operating Mode . Use RFANalyzer:CW:EXPected:POWer to set the expected input power in CW operating mode.

See Receiver Control for more information about manual versus automatic receiver control.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: -129 dBm to +80 dBm (This is the range of settings accepted, see Expected Power for the actual hardware range of the detector)

Resolution: 0.01 dBm

Query

 Same as setting
*RST setting 0 dBm

Programming Example

OUTPUT 714;"RFANalyzer:MANual:POWer 24"
!Sets the receiver expected input power level
!for the currently selected system type to 24 dBm.

RFANalyzer:MANual:UPLink[:MFRequency]

Function

The setting form of this command performs two functions: (1) sets the receiver demodulation frequency (see RFANalyzer:MANual:UPLink:FREQuency ), and (2) sets the receiver demodulation frequency mode to manual (see RFANalyzer:CONTrol:UPLink:FREQuency:AUTO ).

The query form of this command returns the receiver demodulation frequency.

If no units are specified the setting defaults to Hz.

This command applies to IS-856 Test Operating Mode and CW Operating Mode .There is no manual control of the receiver demodulation frequency while in Active Cell Operating Mode .

The receiver demodulation frequency mode is always manual for CW Operating Mode so this command performs the same function as RFANalyzer:MANual:UPLink:FREQuency when in CW operating mode.

See Receiver Control for more information about manual versus automatic receiver control.

Requirements

 Test Application Revision: A.05 and above
Lab Application Revision: A.01 and above

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

 Range: 292.5 MHz to 2700 MHz
*RST setting 896 MHz

Programming Example

OUTPUT 714;"RFANalyzer:MANual:UPLink 1955.030 MHZ"
!Enables receiver demodulation frequency manual control
!and sets the tune frequency to 1955.030 MHz.

RFANalyzer:MANual:UPLink:FREQuency

Function

Sets/queries the receiver demodulation frequency when the receiver demodulation frequency control mode is set to manual using the RFANalyzer:CONTrol:UPLink:FREQuency:AUTO command.

If no units are specified the setting defaults to Hz.

The receiver demodulation frequency can also be set using the RFANalyzer:MANual:UPLink[:MFRequency] command.

This command applies to IS-856 Test Operating Mode and CW Operating Mode . There is no manual control of the receiver demodulation frequency while in Active Cell Operating Mode .

The receiver demodulation frequency mode is always manual for CW Operating Mode . See Receiver Control for more information about manual versus automatic receiver control.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

 Same as setting
*RST setting 896000000 Hz

Programming Example

OUTPUT 714;"RFANalyzer:MANual:UPLink:FREQuency 942.6 MHZ"
!Sets the receiver demodulation frequency to 942.6 MHz.


RFANalyzer Subsystem

RFANalyzer Subsystem

Description

The RFANalyzer command subsystem performs "lower-level" functions that control the test set's measuring receiver. The measuring receiver includes three separate signal paths:

  • Power detector
  • Demodulation
  • Measurement

Refer to the Block Diagram for a description of the signal paths.

The RFANalyzer commands allow manual settings to the tune frequency or expected power level to each of these paths if it is necessary to override automatic settings.

Syntax Diagrams and Command Descriptions

RFANalyzer


RFGenerator:OUTPut

RFGenerator:OUTPut

Diagram Conventions

RFGenerator:OUTPut[:DESTination]

Function

Sets/queries the RF output port destination: RF IN/OUT (IO) or RF OUT ONLY (OUT).

If the correct hardware is not installed when trying to change to the RF OUT ONLY port, the test set displays the following error: Hardware error; RFIO version does not support RF out only selection.

The query form will always return a value, regardless of the hardware version.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Hardware: RF Input/Output module with second RF output connector, modified front panel.

Setting

Range: IO|OUT

Query

Range: IO|OUT

*RST Setting

 IO

Programming Example

OUTPUT 714;"RFGenerator:OUTPut OUT"
!Sets the RF generator's output destination to the RF Out Only port.


RFGenerator Subsystem

RFGenerator Subsystem

Description

The RFGenerator subsystem selects the RF generator output port on test sets equipped with both the RF IN/OUT port and the RF OUT ONLY port. If the test set does not have the RF OUT ONLY port, an error message is generated when attempting to switch output ports.

The RF OUT ONLY port may not be used with some test applications or lab applications. In that case, a message is displayed that tells you that the port could not be switched.

Syntax Diagrams and Command Descriptions

RFGenerator:OUTPut


SETup:AFANalyzer

SETup:AFANalyzer

Diagram Conventions

SETup:AFANalyzer:CONTinuous

Function

Sets/queries the trigger arm state for the AF analyzer measurement. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:AFANalyzer:COUNt[:SNUMber]

Function

Sets/queries the number of AF analyzer measurements to be made in a mulit-measurement setup. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:AFANalyzer:COUNt:NUMBer

Function

Sets/queries the number of AF analyzer measurements to be made when milt-measurement state is ON.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:COUNT:NUMBER 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:AFANalyzer:COUNt:STATe

Function

Sets/queries the multi-measurement state of the AF analyzer measurement.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:COUNT:STATE ON" !Turns on multi-measurements.

SETup:AFANalyzer:DEMPhasis:STATe

Function

Sets/queries whether 750 us de-emphasis is enabled.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:DEMPHASIS:STATE ON"

SETup:AFANalyzer:DETector[:TYPE]

Function

Sets/queries the detector type for audio level measurements.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: RMS|PEAK

Query

Range: RMS|PEAK

*RST setting

RMS

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:DETECTOR:TYPE PEAK"

SETup:AFANalyzer:EXPandor[:SRLevel]

Function

Sets/queries the expandor's reference level and automatically sets the expandor's state to ON.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 10 mV to 10 V

Resolution: 1 mV

Query

Range: 10 mV to 10 V

*RST setting

1 V

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:EXPANDOR:SRLEVEL 5V"
!Sets expandor state to on and level to 5 V.

SETup:AFANalyzer:EXPandor:RLEVel

Function

Sets/queries the expandor's reference level to be used when the expandor's state is set to ON.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 10 mV to 10 V

Resolution: 1 mV

Query

Range: 10 mV to 10 V

*RST setting

1 V

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:EXPANDOR:RLEVEL 5V" !Sets expandor reference level to 5 V.

SETup:AFANalyzer:EXPandor:STATe

Function

Sets/queries whether the expandor is enabled.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:EXPANDOR:STATE ON"

SETup:AFANalyzer:FILTer[:TYPE]

Function

Sets/queries the filter type for audio measurements.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: NONE|TBPass|CMESsage|BPASs50|BPASs300

Query

Range: NONE|TBP|CMES|BPAS50|BPAS300

*RST setting

NONE

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:FILTER:TYPE BPASS50"
!Selects the 50 Hz to 15 kHz bandpass filter.

SETup:AFANalyzer:FILTer:TBPass[:FREQuency]

Function

Sets/queries the center frequency for the 100 Hz tunable bandpass filter (TBPass).

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 300.0 to 20000 Hz

Resolution: 0.1

Query

Range: 300.0 to 20000 Hz

*RST setting

1000

Programming Example

10 OUTPUT 714;"SETUP:AFANALYZER:FILTER:TBPASS:FREQUENCY 300HZ"

SETup:AFANalyzer:FREQuency:STATe

Function

Sets/queries whether the audio frequency measurement is enabled.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:FREQUENCY:STATE ON"

SETup:AFANalyzer:PEAK:VOLTage

Function

Sets/queries the expected peak voltage for audio measurements.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.001 to 20 Vpk

Resolution: 0.001

Query

Range: 0.001 to 20 Vpk

*RST setting

20

Programming Example

10 OUTPUT 714;SETUP:AFANALYZER:PEAK:VOLTAGE 10V"

SETup:AFANalyzer:SDIStortion:FREQuency

Function

Sets/queries the fundamental frequency setting for the SINAD/distortion measurement.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 100.0 to 10000 Hz

Resolution: 0.1

Query

Range: 100.0 to 10000 Hz

*RST setting

1000

Programming Example

10 OUTPUT 714;SETUP:AFANALYZER:SDISTORTION:FREQUENCY 300HZ"

SETup:AFANalyzer:SDIStortion:STATe

Function

Sets/queries whether the SINAD/distortion measurement is enabled.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|0N|0|OFF

Query

Range: 1|0

*RST setting

0 (off)

Programming Example

10 OUTPUT 714;SETUP:AFANALYZER:SDISTORTION:STATE ON"

SETup:AFANalyzer:TIMeout[:STIMe]

Function

Sets/queries the AF analyzer measurement's timeout setting and automatically sets the timeout state to ON.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:TIMEOUT:STIME 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:AFANalyzer:TIMeout:STATe

Function

Sets/queries the AF analyzer measurement's timeout state.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:TIMEOUT:STATE ON"

SETup:AFANalyzer:TIMeout:TIME

Function

Sets/queries the AF analyzer measurement's timeout setting to be used when the timeout state is set to ON.

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:TIMEOUT:TIME 5S"


SETup:CONTinuous

SETup:CONTinuous

Diagram Conventions

SETup[:ALL]:CONTinuous:OFF|:ON

Function

These commands set the trigger arm state for all measurements. Determines whether all measurements will make one measurement then stop (:OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (:ON (continuous)). See Trigger Arm (Single or Continuous) Description ).

This setting overrides previously set trigger arm settings for individual measurements (see SETup Subsystem ).
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETup:CONTinuous:OFF"
! Sets all measurements to single trigger mode.


SETup:CAPPower

SETup:CAPPower

NOTE
Some of the access parameters (such as power step, number of steps, sequence maximum, etc.) directly affect access probe power measurements. GPIB commands for these parameters can be found in the CALL:APARameter syntax diagrams.

To limit a call attempt to the access attempt state, see CALL:CONNected:LIMit[:STATe]<[:SELected]|:TA856> .

Diagram Conventions

SETup:CAPPower:CONTinuous

Function

Sets/queries the trigger arm state for the access probe power measurement. The trigger arm state determines whether the access probe power measurement will be made on the first access probe in an access probe sequence then stop (0|OFF (single)), or automatically re-arm and make measurements on each of the following access probes (1|ON (continuous)).

Continuous trigger arming can be used to measure access probe power sequences, however single triggering allows program counters to synchronize with mobile station transmitted power steps. This is important if you want measurement triggering to stop when an access probe sequence has completed.

See Access Probe Power Measurement Parameters , "Trigger Arm."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:CAPPower:CONTinuous OFF"
!Sets measurement to single trigger mode.

SETup:CAPPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the access probe power measurement's timeout (see Measurement Timeouts ) value, and (2) sets the access probe power measurement's timeout STATe to 1 (on).

The query form returns the access probe power measurement's timeout value.

If the timeout timer is not turned on, and an access probe is not received, the access probe power measurement will hang on the FETCh? command indefinitely.

See Access Probe Power Measurement Parameters , "Timeout Time/State."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETup:CAPPower:TIMeout 5"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:CAPPower:TIMeout:STATe

Function

Sets/queries the access probe power measurement's timeout state. See Access Probe Power Measurement Parameters , "Timeout Time/State."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:CAPPower:TIMeout:STATe ON"

SETup:CAPPower:TIMeout:TIME

Function

Sets/queries the access probe power measurement's timeout setting to be used when the timeout state is set to ON. See Access Probe Power Measurement Parameters , "Timeout Time/State."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETup:CAPPower:TIMeout:TIME 5"


SETup:CFDTune

SETup:CFDTune

Last updated: June 30, 2006

Diagram Conventions

SETup:CFDTune:FREQuency:STEP:COUNt

Function

Sets/queries the Number of Frequency Steps .

Setting

Range: 1 to 20

Resolution: 1

Query

Range: 1 to 20

*RST Setting

5

Requirement

Test Application Revision: A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SETup:CFDTune:FREQuency:STEP:COUNt 10"
!Sets the number of frequency steps to 10.

SETup:CFDTune:MS:RX:FREQuency:STEP[:VALues]

Function

Sets/queries the MS RX Frequency Step Values .

If you set fewer than 40 values, the remaining values are set to NAN (9.91E+37).

Setting

Range:

Although you can enter any frequencies between 421 and 2170 MHz, when running the Fast Device Tune measurement in the 1xEV-DO application/format, you can only test frequencies within a single 1xEV-DO frequency band range:

  • 421 to 489 MHz (Band: NMT-450)
  • 800 to 960 MHz (Bands: US Cellular, Japan CDMA, China Cellular, and Secondary 800)
  • 1840 to 1870 MHz (Band: Korean PCS)
  • 2110 to 2170 MHz (Band: IMT-2000)
  • 1930 to 1995 (Bands: US PCS and US PCS 1900)

Resolution: 1 Hz

Query

 Same as setting

*RST Setting

1933.0MHz, 1933.2MHz, 1933.4MHz, 1933.6MHz, 1933.8MHz, 1934.0MHz, 1934.2MHz, 1934.4MHz, 1934.6MHz, 1934.8MHz, 1935.0MHz, 1935.2MHz, 1935.4MHz, 1935.6MHz, 1935.8MHz, 1936.0MHz, 1936.2MHz, 1936.4MHz, 1936.6MHz, 1936.8MHz, 872.0MHz, 872.2MHz, 872.4MHz, 872.6MHz, 872.8MHz, 873.0MHz, 873.2MHz, 873.4MHz, 873.6MHz, 873.8MHz, 874.0MHz, 874.2MHz, 874.4MHz, 874.6MHz, 874.8MHz, 875.0MHz, 875.2MHz, 875.4MHz, 875.4MHz, 875.6MHz, 875.8MHz

Requirement

Test Application Revision: A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:RX:FREQuency:STEP 1932 MHz, 1933 MHz, 1934 MHz, 1935 MHz"
! Sets MS RX Frequency Step Values to 1932 MHz, 1933 MHz, 1934 MHz, 1935 MHz.

SETup:CFDTune:MS:RX:FREQuency:STEP:STARt:[INDex]

Function

 Sets/queries the MS RX Frequency Step Values .

Setting

Range: 0 to 39

Resolution: 1

Query

 Same as setting

*RST Setting

0

Requirement

Test Application Revision: A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:RX:FREQuency:STEP:STARt 6"
!Sets the MS RX Frequency Step Start Index to 6.

SETup:CFDTune:MS:RX:POWer:STEP[:LEVels]

Function

Sets/queries the MS RX Power Step Levels .

If you set fewer than 40 values, the remaining values are set to NAN (9.91E+37).

Setting

Range:

Although you can enter any power levels between -165 and 37 dBm, when running the Fast Device Tune measurement in the 1xEV-DO application/format, the test set can only transmit test power levels in the range of -120 to -13 dBm (this range assumes an amplitude offset of 0; the allowable range changes as you change amplitude offsets, see Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power ).

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15.0dBm, -20.0dBm, -25.0dBm, -30.0dBm, -35.0dBm, -40.0dBm, -45.0dBm, -50.0dBm, -55.0dBm, -60.0dBm, -65.0dBm, -70.0dBm, -75.0dBm, -80.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm

Requirement

Test Application Revision: A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:RX:POWer:STEP -16, -20, -30, -40, -50,-60, -70, -80, -90, -100"
! Sets MS RX Power Step Levels to -16, -20, -30, -40, -50,-60, -70, -80, -90, -100 dBm.

SETup:CFDTune:MS:RX:POWer:STEP:STARt:[INDex]

Function

 Sets/queries the MS RX Power Step Start Index .

Setting

Range: 0 to 39

Resolution: 1

Query

 Same as setting

*RST Setting

0

Requirement

Test Application Revision: A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:RX:POWer:STEP:STARt 6"
!Sets the MS RX Power Step Start Index to 6.

SETup:CFDTune:MS:TX:FREQuency:STEP[:VALues]

Function

Sets/queries the MS TX Frequency Step Values .

If you set fewer than 40 values, the remaining values are set to NAN (9.91E+37).

Setting

Range:

Although you can enter any frequencies between 411 and 1980 MHz, when running the Fast Device Tune measurement in the 1xEV-DO application/format, you can only test frequencies within a single 1xEV-DO frequency band range:

  • 411 to 479 MHz (Band: NMT-450)
  • 806 to 924 MHz (Bands: US Cellular, Japan CDMA, China Cellular, and Secondary 800)
  • 1750 to 1780 MHz (Band: Korean PCS)
  • 1920 to 1980 MHz (Band: IMT-2000)
  • 1850 to 1915 (Bands: US PCS and US PCS 1900)

Resolution: 1 Hz

Query

 Same as setting

*RST Setting

1853.0MHz, 1853.2MHz, 1853.4MHz, 1853.6MHz, 1853.8MHz, 1854.0MHz, 1854.2MHz, 1854.4MHz, 1854.6MHz, 1854.8MHz, 1855.0MHz, 1855.2MHz, 1855.4MHz, 1855.6MHz, 1855.8MHz, 1856.0MHz, 1856.2MHz, 1856.4MHz, 1856.6MHz, 1856.8MHz, 827.0MHz, 827.2MHz, 827.4MHz, 827.6MHz, 827.8MHz, 828.0MHz, 828.2MHz, 828.4MHz, 828.6MHz, 828.8MHz, 829.0MHz, 829.2MHz, 829.4MHz, 829.6MHz, 829.8MHz, 830.0MHz, 830.2MHz, 830.4MHz, 830.6MHz, 830.8MHz

Requirement

Test Application Revision: A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:TX:FREQuency:STEP 1852 MHz, 1853 MHz, 1854 MHz, 1855 MHz"
! Sets MS TX Frequency Step Values to 1852 MHz, 1853 MHz, 1854 MHz, 1855 MHz.

SETup:CFDTune:MS:TX:FREQuency:STEP:STARt:[INDex]

Function

 Sets/queries the MS TX Frequency Step Start Index .

Setting

Range: 0 to 39

Resolution: 1

Query

 Same as setting

*RST Setting

0

Requirement

Test Application Revision: A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:TX:FREQuency:STEP:STARt 6"
!Sets the MS TX Frequency Step Start Index to 6.

SETup:CFDTune:MS:TX:POWer:STEP[:LEVels]

Function

Sets/queries the MS TX Power Step Levels .

If you set fewer than 40 values, the remaining values are set to NAN (9.91E+37).

Setting

Range:

Although you can enter any power levels between -129 and +80 dBm (because this measurement is common to the W-CDMA/HSDPA, 1xEV-DO and cdma2000 formats), when running the Fast Device Tune measurement in the 1xEV-DO application/format, you can only measure power levels in the range of -79 to +30 dBm and the measurement is only specified for power levels in the range of -61 to +30 dBm (these ranges assume an amplitude offset of 0; the ranges change as you change amplitude offsets, see Amplitude Offset ).

Resolution: 0.01

Query

 Same as setting

*RST Setting

 12.0dBm, 7.0dBm, 2.0dBm, -8.0dBm, -13.0dBm, -18.0dBm, -23.0dBm, -28.0dBm, -33.0dBm, -38.0dBm, -43.0dBm, -48.0dBm, -53.0dBm, -58.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm

Requirement

Test Application Revision: A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:TX:POWer:STEP 20, 16, 12, 8, 4, 0, -4, -8, -12, -16, -20, -30, -40, -50"
!Sets Rx Power Step Sequency values to 20, 16, 12, 8, 4, 0, -4, -8, -12, -16, -20, -30, -40, -50.

SETup:CFDTune:MS:TX:POWer:STEP:STARt:[INDex]

Function

 Sets/queries the MS TX Power Step Start Index .

Setting

Range: 0 to 39

Resolution: 1

Query

 Same as setting

*RST Setting

0

Requirement

Test Application Revision: A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:TX:POWer:STEP:STARt 6"
!Sets the MS TX Power Step Start Index to 6.

SETup:CFDTune:POWer:STEP:COUNt

Function

Sets/queries the Number of Power Steps .

Setting

Range: 1 to 20

Resolution: 1

Query

Range: 1 to 20

*RST Setting

10

Requirement

Test Application Revision: A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SETup:CFDTune:POWer:STEP:COUNt 15"
!Sets the number of power steps to 15.

SETup:CFDTune:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the Fast Device Tune measurement's timeout (see Measurement Timeouts ) value, and (2) sets the Fast Device Tune measurement's timeout state to 1 (on).

The query form returns the Fast Device Tune measurement's timeout value.

See Fast Device Tune Measurement Parameters

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds, off

Requirement

Test Application Revision: A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SETup:CFDTune:TIMeout 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:CFDTune:TIMeout:STATe

Function

 Sets/queries Fast Device Tune measurement's timeout state (see Measurement Timeouts ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirement

Test Application Revision: A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SETup:CFDTune:TIMeout:STATe ON"

SETup:CFDTune:TIMeout:TIME

Function

 Sets/queries Fast Device Tune measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds

Requirement

Test Application Revision: A.06 and above, with the required feature license

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SETup:CFDTune:TIMeout:TIME 5S"


SETup:CPERror

SETup:CPERror

Diagram Conventions

SETup:CPERror:CONFidence[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the PER (packet error rate) measurement's confidence level, and (2) sets the PER measurement's confidence level STATe to 1 (on).

The query form of this command returns the PER measurement's confidence level setting.

See PER Measurement Parameters .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range/Resolution: see SETup:CPERror:CONFidence:LEVel .

Query

Range/Resolution: see SETup:CPERror:CONFidence:LEVel .

*RST Setting

95%, on

Programming Example

OUTPUT 714;"SETup:CPERror:CONFidence 90"

! Turns confidence level testing on
! and sets the PER confidence level to 90%

SETup:CPERror:CONFidence:STATe

Function

Sets/queries whether the confidence level will be used during PER testing.

See PER Measurement Parameters .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

1|0

*RST Setting

1 (on)

Programming Example

OUTPUT 714;"SETup:CPERror:CONFidence:STATe OFF"
! Turns confidence level testing off.

SETup:CPERror:CONFidence:LEVel

Function

Sets/queries the PER (packet error rate) measurement's confidence level to be used when the confidence level state is set to on using the SETup:CPERror:TIMeout:STATe command.

See PER Measurement Parameters .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 80 to 99.99%

Resolution: 0.01%

Query

 Same as setting

*RST Setting

 95%

Programming Example

OUTPUT 714;"SETup:CPERror:CONFidence:LEVel 90"

! Sets the confidence level to 90%.

SETup:CPERror:CONFidence:REQuirement[:RATio]

Function

Sets/queries the PER (packet error rate) measurement's PER requirement.

See PER Measurement Parameters .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.10 to 15.0%

Resolution: 0.01%

Query

Same as setting

*RST Setting

 1.00%

Programming Example

OUTPUT 714;"SETup:CPERror:CONFidence:REQuirement 2"

! Sets the confidence level requirement to 2%.

SETup:CPERror:CONTinuous

Function

Sets/queries the trigger arm state for the PER (packet error rate) measurement. The trigger arm state determines whether the waveform quality measurement will be made once then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

See PER Measurement Parameters .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:CPERror:CONTinuous OFF"
! Sets the PER measurement to single trigger mode.

SETup:CPERror:COUNt[:MAXimum]

Function

Sets/queries the maximum number of packets to be counted during a PER measurement.

See PER Measurement Parameters .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 25 to 10,000,000 packets

Resolution: 1 packet

Query

Same as setting

*RST Setting

 10,000 packets

Programming Example

OUTPUT 714;"SETup:CPERror:COUNt 20000"
! Sets the maximum packet count value to 20,000 packets.

SETup:CPERror:COUNt:MINimum

Function

Sets/queries the minimum number of packets to be tested before applying the statistic analysis when the confidence level state is on ( SETup:CPERror:CONFidence:STATe ).

See PER Measurement Parameters .

Requirements

Test Application Revision: A.05 and above
Lab Application Revision: A.01 and above

Setting

Range: 0 to 10,000,000

Query

Range: 0 to 10,000,000

*RST Setting

 0

Programming Example

OUTPUT 714;"SETup:CPERror:COUNt:MINimum 200"
!sets the minimum packets to be tested to 200.

SETup:CPERror:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the PER (packet error rate) measurement's timeout value, and (2) sets the PER measurement's timeout STATe to 1 (on).

The query form returns the PER measurement's timeout value.

See PER Measurement Parameters .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range/Resolution: SETup:CPERror:TIMeout:TIME .

Query

 Range/Resolution: SETup:CPERror:TIMeout:TIME .

*RST Setting

267.0 seconds, off

Programming Example

OUTPUT 714;"SETup:CPERror:TIMeout 300"
! Sets timeout state to ON and sets the timeout time to 300 seconds.

SETup:CPERror:TIMeout:STATe

Function

Sets/queries the PER (packet error rate) measurement's timeout state.

See PER Measurement Parameters .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:CPERror:TIMeout:STATe ON"
! Sets the timeout state to ON.

SETup:CPERror:TIMeout:TIME

Function

Sets/queries the PER (packet error rate) measurement's timeout setting to be used when the timeout state is set to ON using the SETup:CPERror:TIMeout:STATe command.

See PER Measurement Parameters .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.1 to 266,667.0 seconds

Resolution: 0.1 seconds

Query

Same as setting

*RST Setting

267.0 seconds (allows time for the default of 10,000 max packets to be tested)

Programming Example

OUTPUT 714;"SETup:CPERror:TIMeout:TIMe 300"
! Sets the timeout time to 300 seconds.


SETup:CPOWer

SETup:CPOWer

Diagram Conventions

SETup:CPOWer:CONTinuous

Function

Sets/queries the trigger arm state for the channel power measurement. The trigger arm state determines whether the channel power measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)). See Channel Power Measurement Parameters .
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:CPOWer:CONTinuous OFF"
!Sets measurement to single trigger mode.

SETup:CPOWer:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of channel power measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of channel power multi-measurements to be made when multi-measurement state is ON.

See Channel Power Measurement Parameters .
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Programming Example

OUTPUT 714;"SETup:CPOWer:COUNt 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:CPOWer:COUNt:NUMBer

Function

Sets/queries the number of channel power measurements to be made when the multi-measurement state is ON.

See Channel Power Measurement Parameters .
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETup:CPOWer:COUNt:NUMBer 5"
!Sets the number of channel power multi-measurements to 5.

SETup:CPOWer:COUNt:STATe

Function

Sets/queries the channel power multi-measurement state. See Channel Power Measurement Parameters .
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:CPOWer:COUNt:STATe ON" !Turns on channel power multi-measurements.

SETup:CPOWer:MSPeed

Function

Sets/queries the channel power measurement speed. See Measurement Speed .

Requirements

Test Application Revision: A.02.20 and above
Lab Application Revision: A.01 and above

Setting

Range: FAST|VFASt

Query

Range: FAST|VFAS

*RST Setting

 FAST

Programming Example

OUTPUT 714;"SETup:CPOWer:MSPeed VFASt"
!Sets the channel power measurements speed to very fast.

SETup:CPOWer:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the channel power measurement's timeout (see Measurement Timeouts ) value, and (2) sets the channel power measurement's timeout STATe to 1 (on).

The query form returns the channel power measurement's timeout value.

See Channel Power Measurement Parameters .
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETup:CPOWer:TIMeout 5"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:CPOWer:TIMeout:STATe

Function

Sets/queries the channel power measurement's timeout (see Measurement Timeouts ) state. See Channel Power Measurement Parameters .
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:CPOWer:TIMeout:STATe ON"

SETup:CPOWer:TIMeout:TIME

Function

Sets/queries the channel power measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON. See Channel Power Measurement Parameters .
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETup:CPOWer:TIMeout:TIME 5"


SETup:CTDPower

SETup:CTDPower

Diagram Conventions

SETup:CTDPower:STEP[:LEVel]

Function

Sets/queries the power step size by which the test set expect the access terminal to decrease its output power at each step. See Power Step Size .

Requirements

Test Application Revision: A.02.20 and above
Lab Application Revision: A.01 and above

Setting

Range: - 90 to -0.01 dB

Query

Range: -90 to -0.01 dB

*RST Setting

 - 4 dB

Programming Example

OUTPUT 714;"SETUP:CTDPOWER:STEP:LEVEL -5 DB"
!Sets the power step size for the measurement.

SETup:CTDPower:STEP:COUNt

Function

Sets/queries the number of power down steps that the test set expects the access terminal to transmit. See Number of Power Steps .

The total number of measurements actually made will be this setting plus one which can be queried with FETCh:CTDPower:COUNt[:STEP]? .

Requirements

Test Application Revision: A.02.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0 to 99

Query

Range: 0 to 99

*RST Setting

 19

Programming Example

OUTPUT 714;"SETUP:CTDPOWER:STEP:COUNT 5"
!Sets the number of steps to be 5.

SETup:CTDPower:STEP:TIME

Function

Sets/queries the duration (20 ms, 40 ms, or 80 ms) that the test set expects the AT to hold its power constant at each power step. The test set triggers each channel power measurement relative to the first RF rise trigger based on this setting. See Number of Power Steps .

Requirements

Test Application Revision: A.02.20 and above
Lab Application Revision: A.01 and above

Setting

Range: MS20|MS40|MS80

Query

Range: MS20|MS40|MS80

*RST Setting

 MS20

Programming Example

OUTPUT 714;"SETUP:CTDPOWER:STEP:TIME MS40"
!Set the period to be 40 ms.

SETup:CTDPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the TX dynamic power measurement's timeout (see Measurement Timeouts ) value, and (2) sets the TX dynamic power measurement's timeout state to 1 (on).

The query form returns the channel power measurement's timeout value.

Requirements

Test Application Revision: A.02.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETUP:CTDPOWER:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:CTDPower:TIMeout:STATe

Function

Sets/queries TX dynamic power measurement's timeout state (see Measurement Timeouts ).

Requirements

Test Application Revision: A.02.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:CTDPOWER:TIMEOUT:STATE ON"

SETup:CTDPower:TIMeout:TIME

Function

Sets/queries TX dynamic power measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON.

Requirements

Test Application Revision: A.02.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETUP:CTDPOWER:TIMEOUT:TIME 5 S"


SETup:CTXSpurious

SETup:CTXSpurious

Diagram Conventions

SETup:CTXSpurious:CONTinuous

Function

Sets/queries the trigger arm state for the tx spurious emissions measurement. The trigger arm state determines whether the tx spurious emissions measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

See TX Spurious Emissions Measurement Parameters , "Trigger Arm."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:CTXSpurious:CONTinuous OFF"
!Sets measurement to single trigger mode.

SETup:CTXSpurious:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of tx spurious emissions measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of tx spurious emissions multi-measurements to be made when multi-measurement state is ON.

See TX Spurious Emissions Measurement Parameters , "Multi-Measurement Count."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Programming Example

OUTPUT 714;"SETup:CTXSpurious:COUNt 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:CTXSpurious:COUNt:NUMBer

Function

Sets/queries the number of tx spurious emissions measurements to be made when the multi-measurement state is ON.

See TX Spurious Emissions Measurement Parameters , "Multi-Measurement Count."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETup:CTXSpurious:COUNt:NUMBer 5"
!Sets the number of tx spurious emissions multi-measurements to 5.

SETup:CTXSpurious:COUNt:STATe

Function

Sets/queries the tx spurious emissions multi-measurement state.

See TX Spurious Emissions Measurement Parameters , "Multi-Measurement Count."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:CTXSpurious:COUNt:STATe ON"
! Turns on tx spurious emissions multi-measurements.

SETup:CTXSpurious:MASK:AUTO

Function

Sets/queries the mask control.

ON (1) sets the mask limits to the values specified in C.S0033. OFF (0) allows you to set arbitrary limits (see SETup:CTXSpurious:MASK:MANual:ADJacent[:LIMit] and SETup:CTXSpurious:MASK:MANual:ALTernate[:LIMit] ).

See TX Spurious Emissions Measurement Parameters , "Mask Control."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (ON)

Programming Example

OUTPUT 714;"SETup:CTXSpurious:MASK:AUTO ON"

SETup:CTXSpurious:MASK:MANual:ADJacent[:LIMit]

Function

Sets/queries the tx spurious emissions manually set measurement limit mask. This limit is activated when SETup:CTXSpurious:MASK:AUTO is set to OFF (0).

See TX Spurious Emissions Measurement Parameters , "Adjacent Limit."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: -10.00 to -65.00 dBc

Resolution: 0.01 dB

Query

Range/Resolution: Same as setting.

*RST Setting

-42 dBc

Programming Example

OUTPUT 714;"SETup:CTXSpurious:MASK:MANual:ADJacent -45"

SETup:CTXSpurious:MASK:MANual:ALTernate[:LIMit]

Function

Sets/queries the tx spurious emissions manually set measurement limit mask. This limit is activated when SETup:CTXSpurious:MASK:AUTO is set to OFF (0).

See TX Spurious Emissions Measurement Parameters , "Alternate Limit."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: -10.00 to -65.00 dBc

Resolution: 0.01 dB

Query

 Range/Resolution: Same as setting.

*RST Setting

 -50 dBc

Programming Example

OUTPUT 714;"SETup:CTXSpurious:MASK:MANual:ALTernate -55".

SETup:CTXSpurious:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the tx spurious emissions measurement's timeout (see Measurement Timeouts ) value, and (2) sets the tx spurious emissions measurement's timeout STATe to 1 (on).

The query form returns the tx spurious emissions measurement's timeout value.

See TX Spurious Emissions Measurement Parameters , "Timeout Time/State."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETup:CTXSpurious:TIMeout 5"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:CTXSpurious:TIMeout:STATe

Function

Sets/queries the tx spurious emissions measurement's timeout (see Measurement Timeouts ) state.

See TX Spurious Emissions Measurement Parameters , "Timeout Time/State."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:CTXSpurious:TIMeout:STATe ON"

SETup:CTXSpurious:TIMeout:TIME

Function

Sets/queries the tx spurious emissions measurement's timeout (see Measurement Timeouts ) setting to be used when the timeout state is set to ON.

See TX Spurious Emissions Measurement Parameters , "Timeout Time/State."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETup:CTXSpurious:TIMeout:TIME 5"


SETup:DAPower

SETup:DAPower

Diagram Conventions

SETup:DAPower:CONTinuous

Function

Sets/queries the trigger arm state for the digital average power measurement. The trigger arm state determines whether the digital average measurement will be made once then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

See Digital Average Power Measurement Parameters , "Trigger Arm."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:DAPower:CONTinuous ON"
!Sets measurement to single trigger mode.

SETup:DAPower:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of digital average power measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of digital average power multi-measurements to be made when multi-measurement state is ON.

See Digital Average Power Measurement Parameters , "Multi-Measurement Count."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Programming Example

OUTPUT 714;"SETup:DAPower:COUNt 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:DAPower:COUNt:NUMBer

Function

Sets/queries the number of digital average power measurements to be made when the multi-measurement state is ON.

See Digital Average Power Measurement Parameters , "Multi-Measurement Count."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETup:DAPower:COUNt:NUMBer 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:DAPower:COUNt:STATe

Function

Sets/queries the multi-measurement state of the digital average power measurement.

See Digital Average Power Measurement Parameters , "Multi-Measurement Count."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:DAPower:COUNt:STATe ON"
! Turns on multi-measurements.

SETup:DAPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the digital average power measurement's timeout value, and (2) sets the digital average power measurement's timeout STATe to 1 (on).

The query form returns the channel power measurement's timeout value.

See Digital Average Power Measurement Parameters , "Timeout Time/State."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETup:DAPower:TIMeout 5"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:DAPower:TIMeout:STATe

Function

Sets/queries the digital average power measurement's timeout state.

See Digital Average Power Measurement Parameters , "Timeout Time/State."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:DAPower:TIMeout:STATe ON"

SETup:DAPower:TIMeout:TIME

Function

Sets/queries the digital average power measurement's timeout setting to be used when the timeout state is set to ON.

See Digital Average Power Measurement Parameters , "Timeout Time/State."
Requirements Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETup:DAPower:TIMeout:TIME 5"


SETup Subsystem

SETup Subsystem

Last updated: June 30, 2006

Description

The SETup subsystem is used to configure the test set for each measurement. Typical settings include:

  • Multi-Measurement Count, how many measurements will be made each time a measurement is initiated.
  • Trigger Arm, determines if a measurement will make one measurement then return to idle (single), or automatically rearm on completion of a measurement and repeat the process (continuous).
  • Trigger Source, how a measurement is triggered.
  • Trigger Delay, controls the delay time between the trigger and the start of sampling.
  • Measurement Timeout, length of time before a measurement times out.

NOTE
Trigger arming for each measurement is controlled in the SETup subsystem. The choices are single or continuous. In most cases, it is a best practice (during remote operation) to use "single" measurement mode. This simplifies the tasks of starting concurrent measurements, using the INIT subsystem commands to determine which measurements are ready to be fetched, then using the FETCh subsystem to obtain results. The command "SETup:CONTinuous:OFF sets all measurements to "single" trigger mode.

Syntax Diagrams and Command Descriptions

SETup:CONTinuous
SETup:AFANalyzer (Audio Analyzer)
SETup:CAPPower (Access Probe Power)
SETup:CFDTune (Fast Device Tune) ( only applicable to the lab application or feature-licensed test application )
SETup:CPERror (Packet Error Rate)
SETup:CPOWer (Channel Power)
SETup:CTDPower (TX Dynamic Power)
SETup:CTXSpurious (TX Spurious Emissions)
SETup:DAPower (Digital Average Power)
SETup:DOWQuality (Waveform Quality + Code Domain)
SETup:GAPPower (Graphical Access Probe Power) ( Lab Application Only )
SETup:SAUDio (Swept Audio)
SETup:SMONitor (Spectrum Monitor)
SETup:TROPower (Time Response of Open Loop Power Control)


SETup:DOWQuality

SETup:DOWQuality

Diagram Conventions

SETup:DOWQuality:CONTinuous

Function

Sets/queries the trigger arm state for the waveform quality measurement. The trigger arm state determines whether the waveform quality measurement will be made once then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

See Waveform Quality + Code Domain Measurement Parameters , "Trigger Arm."

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:DOWQuality:CONTinuous OFF"
! Sets measurement to single trigger mode.

SETup:DOWQuality:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of waveform quality measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of waveform quality multi-measurements to be made when multi-measurement state is ON.

See Waveform Quality + Code Domain Measurement Parameters , "Multi-Measurement Count."

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: See SETup:DOWQuality:COUNt:NUMBer

Query

Range: See SETup:DOWQuality:COUNt:NUMBer

*RST Setting

 10, off

Programming Example

OUTPUT 714;"SETup:DOWQuality:COUNt 5"
! Turns on multi-measurements and sets the number of measurements to 5.

SETup:DOWQuality:COUNt:STATe

Function

Sets/queries the multi-measurement state of the waveform quality measurement.

Set the number of measurements to be made using the SETup:DOWQuality:COUNt:NUMBer command.

See Waveform Quality + Code Domain Measurement Parameters , "Multi-Measurement Count."

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:DOWQuality:COUNt:STATe ON"
! Turns on multi-measurements.

SETup:DOWQuality:COUNt:NUMBer

Function

Sets/queries the number of waveform quality measurements to be made when the multi-measurement state is set to ON using the SETup:DOWQuality:COUNt:STATe command.

See Waveform Quality + Code Domain Measurement Parameters , "Multi-Measurement Count."

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 999

Resolution: 1

Query

 Same as setting

*RST Setting

 10

Programming Example

OUTPUT 714;"SETup:DOWQUality:COUNt:NUMBer 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:DOWQuality:SLOT:COUNt[:PLSubtype0]

Function

Sets/queries the number of slots to measure when the measurement is performed for subtype 0 physical layer.

See Waveform Quality + Code Domain Measurement Parameters , "Slots to Measure."

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 8 (for subtype 0 physical layer); 1 to 4 (for subtype 2 physical layer)

Resolution: 1

Query

 Same as setting

*RST Setting

 1

Programming Example

OUTPUT 714;"SETup:DOWQUality:SLOT:COUNt 8"
!Sets the number of slots to measure to 8

SETup:DOWQuality:SLOT:COUNt:PLSubtype2

Function

Sets/queries the number of slots to measure when the measurement is performed for subtype 2 physical layer.

See Waveform Quality + Code Domain Measurement Parameters , "Slots to Measure."

Requirements

 Test Application Revision: A.06 and above, with the required feature license
Lab Application Revision: A.03 and above

Setting

Range: 1 to 4

Resolution: 1

Query

 Same as setting

*RST Setting

 1

Programming Example

OUTPUT 714;"SETup:DOWQuality:SLOT:COUNt:PLSubtype2 2"
!Sets the number of slots to measure to 2

SETup:DOWQuality:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the waveform quality measurement's timeout value, and (2) sets the waveform quality measurement's timeout STATe to 1 (on).

The query form returns the waveform quality measurement's timeout value.

See Waveform Quality + Code Domain Measurement Parameters , "Timeout Time/State."

Requirements

 Test Application Revision: A.01 and above
Lab Application Revision: A.01 and above

Setting

 Range/Resolution: See SETup:DOWQuality:TIMeout:TIME

Query

 Range/Resolution: See SETup:DOWQuality:TIMeout:TIME

*RST Setting

 10 s, off

Programming Example

OUTPUT 714;"SETup:DOWQuality:TIMeout 5"
!Sets timeout state to ON and sets the timeout time to 5 s.

SETup:DOWQuality:TIMeout:STATe

Function

Sets/queries the waveform quality measurement's timeout state.

Set the timeout time using the SETup:DOWQuality:TIMeout:TIME command.

See Waveform Quality + Code Domain Measurement Parameters , "Timeout Time/State."

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:DOWQuality:TIMeout:STATe ON"
! Sets the measurement timeout time to 5 s.

SETup:DOWQuality:TIMeout:TIME

Function

Sets/queries the waveform quality measurement's timeout setting to be used when the timeout state is set to ON using the SETup:DOWQuality:TIMeout:STATe command.

See Waveform Quality + Code Domain Measurement Parameters , "Timeout Time/State."

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 999 seconds

Resolution: 0.1 second

Query

 Same as setting

*RST Setting

10 s

Programming Example

OUTPUT 714;"SETup:DOWQuality:TIMeout:TIME 5"
! Sets the waveform quality timeout time to 5 seconds.


SETup:SAUDio

SETup:SAUDio

Diagram Conventions

SETup:SAUDio:CONTinuous

Function

Sets/queries the trigger arm state for the swept audio measurement. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:SAUDIO:CONTINUOUS ON" !Turns on continuous triggering.

SETup:SAUDio:COUNt[:SNUMber]

Function

Sets/queries the number of audio measurements to perform at each measurement point in a single multi-measurement sweep. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETUP:SAUDIO:COUNT:SNUMBER 5" !Turns on multi-measurements and makes 5 measurements at each frequency point in the sweep.

SETup:SAUDio:COUNt:NUMBer

Function

Sets/queries the number of audio measurements to perform at each measurement point in a single multi-measurement sweep when the SETup:SAUDio:COUNt:STATe is set to 1 (on).

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

10

Programming Example

OUTPUT 714;"SETUP:SAUDIO:COUNT:NUMBER 5" !Makes 5 measurements at each frequency point in the sweep.

SETup:SAUDio:COUNt:STATe

Function

Selects/queries the swept audio measurement's multi-measurement count state.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:SAUDIO:COUNT:STATE ON" !Turns on multi-measurement for the swept audio measurement.

SETup:SAUDio:COUPling

Function

Sets/queries the audio generator's coupling to the AUDIO OUT port.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: AC|DC

Query

Range: AC|DC

*RST Setting

 DC

Programming Example

OUTPUT 714;"SETUP:SAUDIO:COUPLING AC" !Select AC coupling to the AUDIO OUT port.

SETup:SAUDio:DETector[:TYPE]

Function

Sets/queries the type of level detector used in swept audio measurements.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: RMS|PEAK

Query

Range: RMS|PEAK

*RST Setting

 RMS

Programming Example

OUTPUT 714;"SETUP:SAUDIO:DETECTOR:TYPE PEAK" !Select the peak detector for the AF analzyer.

SETup:SAUDio:FILTer[:TYPE]

Function

Sets/queries the type of filter on the sampled data, before any measurements are performed.

The filter choices are: none, TBPass (100 Hz bandwidth bandpass), CMESsage (C-Message), BPASs50 (50 Hz to 15 kHz bandpass), BPASs300 (300 Hz to 15 kHz bandpass)

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: NONE|TBPass|CMESsage|BPASs50|BPASs300

Query

Range: NONE|TBP|CMES|BPAS50|BPAS300

*RST Setting

None

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FILTER:TYPE TBPASS" !Selects the 100 Hz bandpass filter.

SETup:SAUDio:FREQuency[:VALue]?

Function

Returns a comma-separated list of the generated frequency for each frequency point (see SETup:SAUDio:FREQuency:POINts ).

When you specify the start frequency, stop frequency, and the number of measurement points, the test set calculates the intermediate frequencies that are generated. You cannot directly set the intermediate frequencies using this command, you can only query them.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: up to 60 comma separated values

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FREQUENCY:VALUE?" !Queries the list of generated frequencies.

SETup:SAUDio:FREQuency:POINts

Function

Sets/queries the number of evenly-spaced frequency points in the sweep. If this value is set to 1, only the start frequency is used in the sweep.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 to 60

Query

Range: 1 to 60

*RST Setting

5

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FREQUENCY:POINTS 20" !Make audio measurements at 20 frequency points in the sweep.

SETup:SAUDio:FREQuency:STARt

Function

Sets/queries the frequency at which to begin the sweep. The default units are Hz.

It is possible to set the start frequency higher than the stop frequency. If this is done, the sweep starts at the higher frequency and stops at the lower frequency.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 300.0 to 15000.0 Hz

Query

Range: 300.0 to 15000.0 Hz

*RST Setting

300 Hz

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FREQUENCY:START 450HZ" !Start the frequency sweep at 450 Hz.

SETup:SAUDio:FREQuency:STOP

Function

Sets/queries the frequency at which to end the sweep. The default units are Hz.

It is possible to set the stop frequency lower than the start frequency. If this is done, the sweep starts at the higher frequency and stops at the lower frequency.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 300.0 to 15000.0 Hz

Query

Range: 300.0 to 15000.0 Hz

*RST Setting

 3000 Hz

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FREQUENCY:STOP 1500HZ" !Stop the frequency sweep at 1500 Hz.

SETup:SAUDio:ICOunt:MAXimum?

Function

Queries the total multi-measurement count. This is equal to the number of frequency points in the sweep multiplied by the multi-measurement count set for the swept audio measurement.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 1 to 59940 (60 measurement points multiplied by 999 multi-measurements)

*RST Setting

 5

Programming Example

OUTPUT 714;"SETUP:SAUDIO:ICOUNT:MAXIMUM?" !Queries the total number of measurements made.

SETup:SAUDio:PEAK:VOLTage

Function

Sets/queries the expected peak voltage of the swept audio measurement. This determines the range and resolution of the sampled votage values.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1 mV to 20 V

Resolution: 1 mV

Query

Range: 1 mV to 20 V

*RST Setting

20 V peak

Programming Example

OUTPUT 714;"SETUP:SAUDIO:PEAK:VOLTAGE 5V"

SETup:SAUDio:SETTling[:TIMe]

Function

Sets/queries how long swept audio measurements wait to start an audio measurement after setting the audio source's frequency. A setting of 0.0 seconds let's swept audio measurements run at maximum speed.

Settling time may be needed when testing a device that has a time delay through the audio path. Path delays can cause the audio generator's signal to change frequencies before the output signal can be analyzed at that frequency. Specifying a settling time ensures that the audio generator stays at each frequency point long enough for the audio analyzer to correctly measure the device's audio output.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.0 to 999 ms

Resolution: 1 ms

Query

Range: 0.0 to 999 ms

*RST Setting

0 ms

Programming Example

OUTPUT 714;"SETUP:SAUDIO:SETTLING:TIME 20MS"

SETup:SAUDio:SDIStortion:STATe

Function

Sets/queries whether SINAD and distortion measurements are enabled. Turning on SINAD/Distortion measurements will cause the swept audio measurement to run significantly slower because of added sampling and calculation times.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:SAUDIO:SDISTORTION:STATE ON"

SETup:SAUDio:TIMeout[:STIMe]

Function

 Selects/queries the timeout value in seconds that is used for swept audio measurements and sets the timeout state to ON. Units (S|MS) are optional, if no units are specified then units default to S (seconds).

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

*RST Setting

 10 seconds

Programming Example

OUTPUT 714;"SETUP:SAUDIO:TIMEOUT:STIME 10" !Enables timeouts and sets the value to 10 seconds.

SETup:SAUDio:TIMeout:TIME

Function

 Selects/queries the timeout value in seconds that is used for swept audio measurements when the timeout state is set to ON. Units (S|MS) are optional, if no units are specified then units default to S (seconds).

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

*RST Setting

 10 seconds

Programming Example

OUTPUT 714;"SETUP:SAUDIO:TIMEout:TIME 10" !Sets the timeout value to 10 seconds.

SETup:SAUDio:TIMeout:STATe

Function

 Selects/queries the swept audio measurement timeout state. Timeout is set using the SETup:SAUDio:TIMeout:TIME command.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:SAUDIO:TIMEOUT:STATE ON" !Enables timeouts for swept audio measurements.

SETup:SAUDio:VOLTage:AMPLitude

Function

Sets/queries the output level (peak voltage) of the audio generator when it is turned on. This command does not turn on the audio generator.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.0 to 9.0 V peak (R L > 600 ohms)

Resolution:

  • < 0.5 mV peak (less than or equal to 1 V peak output)
  • < 5 mV peak (greater than 1 V peak output)

Query

Range: 0.0 to 9.0 V peak (R L > 600 ohms)

*RST Setting

0.0 V peak

Programming Example

OUTPUT 714;"SETUP:SAUDIO:VOLTAGE:AMPLITUDE 1V" !Set the audio generator's output to 1Vpeak.


SETup:SMONitor

SETup:SMONitor

Diagram Conventions

SETup:SMONitor:AMPLitude:PDIVision

Function

This command sets the scale of the spectrum monitor's display in dB per division (dB/div).

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 0.1 to 20 dB

Resolution: 0.1

Query

Range: 0.1 to 20 dBResolution: 0.1
*RST Setting

10 dB

Programming Example

OUTPUT 714;"SETup:SMONitor:AMPLitude:PDIVision 1DB"

!Sets scale of the spectrum monitor's display to 1 dB per division.

SETup:SMONitor:AMPLitude:RLEVel:AUTO

Function

This command allows you to set whether or not the spectrum monitor's reference level is selected automatically by the test set.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting

OFF

Programming Example

OUTPUT 714;"SETup:SMONitor:AMPLitude:RLEVel:AUTO ON"

!Sets spectrum monitor's reference level to set automatically.

SETup:SMONitor:AMPLitude:RLEVel:MANual

Function

This command allows you to set the spectrum monitors actual reference level in dBm. The range settings are coupled to the amplitude offset value for the current value of the expected frequency (set using SYSTem:CORRection:[:SGAin] ). Changing the amplitude offset value does not change the reference value, unless the new value for the amplitude offset forces the current value of the reference level to exceed the range limits. If this happens the reference level is set to its limit.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: (-50 dBm + Amplitude Offset) to +37 dBm

Resolution: 0.1 dB

Query

Range: (-50 dBm + Amplitude Offset) to +37 dBmResolution: 0.1 dB
*RST Setting

+37 dB + Amplitude Offset

Programming Example

OUTPUT 714;"SETup:SMONitor:AMPLitude:RLEVel:MANual -20DBM"

!Sets spectrum monitor's reference level to -20 dBm.

SETup:SMONitor:BANDwidth|BWIDth[:RESolution]?

Function

This command queries the resolution bandwidth being used by the spectrum monitor measurement. It is returned in the unit of Hz.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Query

Range: 300 Hz to 5MHz

*RST Setting 30000 Hz

Programming Example

OUTPUT 714;"SETup:SMONitor:BAND?"

!Returns spectrum monitor's resolution bandwidth.

SETup:SMONitor:BANDwidth|BWIDth:AUTO

Function

This command sets/queries the Spectrum Monitor Resolution Bandwidth Coupling State. When the state of this parameter is ON the Resolution Bandwidth is determined by the Frequency Span setting ( SETup:SMONitor:FREQuency:SPAN ). When this parameter is set to OFF the Frequency Span and the Resolution Bandwidth parameters are decoupled and can be set separately to any valid Frequency Span and Resolution Bandwidth. See Frequency Span, Resolution Bandwidth and Dynamic Range for the complete list of valid settings for Frequency Span and Resolution Bandwidth.

The command to set the Frequency Span is SETup:SMONitor:FREQuency:SPAN

The command to set the resolution bandwidth is SETup:SMONitor:BANDwidth|BWIDth:MANual .

Requirements

 Test Application Revision: A.05 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting 1

Programming Example

OUTPUT 714;"SETup:SMONitor:BAND:AUTO 0"

!Turns Spectrum Monitor Resolution Bandwidth Coupling parameter OFF.

SETup:SMONitor:BANDwidth|BWIDth:MANual

Function

This command sets/queries the value of the resolution bandwidth when SETup:SMONitor:BANDwidth|BWIDth:AUTO is set to OFF. When SETup:SMONitor:BANDwidth|BWIDth:AUTO is set to ON, the resolution bandwidth is determined by the Frequency Span setting ( SETup:SMONitor:FREQuency:SPAN ) and can be queried using the SETup:SMONitor:BANDwidth|BWIDth[:RESolution]? command.

When using this command the values in the Frequency Span and Resolution Bandwidth columns of Frequency Span, Resolution Bandwidth and Dynamic Range are no longer coupled. Therefore, the Frequency Span and the Resolution Bandwidth parameters can be set to any value in the Frequency Span and Resolution Bandwidth columns, respectively.

This command also sets the Spectrum Monitor Reference Level Coupling State to OFF (see SETup:SMONitor:AMPLitude:RLEVel:AUTO ).

The units (HZ|KHZ|MHZ) are optional, if no units are specified then the default is HZ.

Requirements

Test Application Revision: A.05 and above
Lab Application Revision: A.01 and above

Setting

Range: A value in the range 300 Hz to 5 MHz can be entered, however the value is rounded to a valid entry. The decision point for rounding up or down is the halfway point between the first valid entry below the setting and the first valid entry above the setting. The valid entries include: 300 Hz, 1 kHz, 3 kHz, 10 kHz, 30 kHz, 100 kHz, 300 kHz, 1 MHz, 5 MHz.

Query

300 Hz, 1 kHz, 3 kHz, 10 kHz, 30 kHz, 100 kHz, 300 kHz, 1 MHz, 5 MHz.
*RST Setting 30 kHz

Programming Example

OUTPUT 714;"SETup:SMONitor:BANDwidth:MANual 600 khz"

!Sets the Resolution Bandwidth to 300 kHz because the first valid entry below the setting is 300 kHz !and the first valid entry above the setting is 1 MHz. The middle point between the two valid values is !650 kHz and since 600 kHz is below 650 kHz, the test set rounds 600 kHz to 300 kHz.

SETup:SMONitor:BANDwidth|BWIDth:ZSPan[:RESolution]

Function

This command sets/queries the resolution bandwidth when the spectrum monitor is operating in zero span mode. To change the spectrum monitor to zero span mode, use the command SETup:SMONitor:FREQuency:SPAN , to set the frequency span to 0 Hz.

To measure the total power of a signal you must select a resolution bandwidth greater than or equal to the signal bandwidth. To resolve two spectral components the resolution bandwidth must be less than the difference between them.

The units (HZ|KHZ|MHZ) are optional, if no units are specified then the default is HZ.

Any setting you enter is rounded to the nearest of the three settings.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 100 kHz|300 kHz|1 MHz

Query

Range: 100 kHz|300 kHz|1 MHz

*RST Setting 300 kHz

Programming Example

OUTPUT 714;"SETup:SMONitor:BAND:ZSPan 100 KHZ"

!Sets spectrum monitor's zero span resolution bandwidth to 100 kHz.

SETup:SMONitor:COUNt[:SNUMber]

Function

This command sets/queries the averaging count and turns on averaging.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 1 to 999

Query

Range: 1 to 999
*RST Setting

100

Programming Example

OUTPUT 714;"SETup:SMONitor:COUNt 200"

!Sets the averaging count to 200 and sets the averaging the state to on.

SETup:SMONitor:COUNt:NUMber

Function

This command sets/queries the averaging count used when the averaging is turned on.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 1 to 999

Query

Range: 1 to 999
*RST Setting

100

Programming Example

OUTPUT 714;"SETup:SMONitor:COUNt:NUMBer 200" !Sets the averaging count to 200.

SETup:SMONitor:COUNt:STATe

Function

This command sets/queries the averaging state.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting

OFF

Programming Example

OUTPUT 714;"SETup:SMONitor:COUNt:STATe 1" !Turns on averaging.

SETup:SMONitor:CONTinous

Function

This command arms triggering for a measurement sweep. Trigger arming can be single (OFF) or continuous (ON). With single triggering, the measurement sweep starts when an INITiate or READ command is received. With continuous triggering, measurement sweeps initiate immediately and continuously.

The *RST (remote full preset) default setting is single triggering. At power-on or after a front-panel preset, the default setting is continuous triggering.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: ON|1|OFF|0

Query

Range: 1|0
*RST Setting OFF

Programming Example

OUTPUT 714;"SETup:SMONitor:CONTinuous ON" ! Sets the trigger mode to continuous.

SETup:SMONitor:DETector[:TYPE]

Function

 This command sets/queries the Spectrum Monitor Detection Method. There are three detection methods available in the test set's Spectrum Monitor: Peak Detection, Sample Detection, and RMS Detection. See Detection Method for more information.

Requirements

Test Application Revision: A.05 and above
Lab Application Revision: A.01 and above
Setting

Range: PEAK|SAMPle|RMS

Query

Range: PEAK|SAMP|RMS
*RST Setting PEAK

Programming Example

OUTPUT 714;"SETup:SMONitor:DETector RMS"
! Sets Detection Method to RMS.

SETup:SMONitor:FREQuency:SPAN

Function

This command sets/queries the spectrum monitor's frequency span.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range:

  • A value in the range 125 kHz to 100 MHz can be entered, however the value is rounded to the nearest of: 125 kHz, 500 kHz, 1.25 MHz, 2.5 MHz, 4 MHz, 5 MHz, 10 MHz, 12 MHz, 20 MHz, 40 MHz,
    80 MHz, 100 MHz
  • 0 Hz (indicates the spectrum monitor is operating in zero span mode. To set the resolution bandwidth when the spectrum monitor is operating in zero span mode, use SETup:SMONitor:BANDwidth|BWIDth:ZSPan[:RESolution] )
Query

Range: Same as setting range.
*RST Setting 5 MHz

Programming Example

OUTPUT 714;"SETup:SMONitor:FREQuency:SPAN 10MHZ" ! Sets the frequency span to 10 MHz.

SETup:SMONitor:TIME:OFFSet

Function

 This command sets/queries the time offset. You can specify the time window for viewing the signal using this command and the SETup:SMONitor:TIME:SPAN . The measurement is made for the duration of the time span, beginning at the time defined by the trigger event plus the trigger delay plus the time offset. The units (S|MS|US|NS) are optional, if no units are specified then the default is S.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 0 us to 10 s

Resolution: 0.1 us
Query

Range: 0 us to 10 s

Resolution: 0.1 us
*RST Setting 0 us

Programming Example

OUTPUT 714;"SETup:SMONitor:TIME:OFFSet 25 MS"
! Sets the spectrum monitor's time offset to 25 millisecond.

SETup:SMONitor:TIME:SPAN

Function

 This command sets/queries the span of the time display. The units (S|MS|US) are optional, if no units are specified then the default is S.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 50 us to 70 ms

Resolution: 0.250 us
Query

Range: 50 us to 70 ms

Resolution: 0.250 us
*RST Setting 10 ms

Programming Example

OUTPUT 714;"SETup:SMONitor:TIME:SPAN 30MS"
! Sets the spectrum monitor's time span to 30 millisecond.

SETup:SMONitor:TIMeout[:STIMe]

Function

This command sets/queries the spectrum monitor's timeout interval and turns on the timeout state. The units (S|MS|US) are optional, if no units are specified then the default is S.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 1 to 999 seconds

Resolution: 0.1 second
Query

Range: 1 to 999 seconds

Resolution: 0.1 second
*RST Setting 10 s

Programming Example

OUTPUT 714;"SETup:SMONitor:TIMeout:STIMe 12S"
! Turns on the timeout timer and sets the timer to expire in 12 seconds.

SETup:SMONitor:TIMeout:STATe

Function

This command sets/queries the state of the spectrum monitor's timeout timer.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 1|ON|0|OFF
Query

Range: 1|0
*RST Setting OFF

Programming Example

OUTPUT 714;"SETup:SMONitor:TIMeout:STATe 1" ! Turns on the timeout timer.

SETup:SMONitor:TIMeout:TIME

Function

This command sets/queries the spectrum monitor's timeout interval. The units (S|MS|US) are optional, if no units are specified then the default is S.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: 1 to 999 seconds

Resolution: 0.1 seconds
Query

Range: 1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting 10 seconds

Programming Example

OUTPUT 714;"SETup:SMONitor:TIMeout:TIME 20S"
! Generates a timeout error if no results are reported within 20 seconds.

SETup:SMONitor:TRACe:MODE

Function

This command sets/queries the trace update parameter.

  • WRITe (Clear-write) erases any data previously stored in the selected trace.
  • MAXHold (maximum hold) maintains the maximum level for each trace point of the selected trace and updates each trace point if a new maximum level is detected in successive sweeps.
  • MINHold (minimum hold) maintains the minimum level for each trace point of the selected trace and updates each trace point if a new minimum level is detected in successive sweeps.

If you change the center, start, or the frequency span, or the resolution bandwidth, the MAXHold and MINHold traces are restarted. These traces are not restarted if you change only the reference level or the scale.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: WRITe|MAXHold|MINHold
Query

Range: WRIT|MAXH|MINH
*RST Setting WRITe

Programming Example

OUTPUT 714;"SETup:SMONitor:TRACe:MODE MAXH"
! Sets the update method to maximim hold.

SETup:SMONitor:TRiGger:DELay

Function

This command sets/queries the trigger delay. This command allows you to add a time delay following the trigger event before samples are taken. The delay can be positive or negative. The units (S|MS|US) are optional, if no units are specified then the default is S.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: -50 ms to +50 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
Query

Range: -50 ms to +50 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
*RST Setting 350 us

Programming Example

OUTPUT 714;"SETup:SMONitor:TRIGger:DELay 1MS" ! Sets the trigger delay to 1 millisecond.

SETup:SMONitor:TRiGger:SOURce

Function

This command sets the trigger source. Immediate triggering happens as soon as the measurement is armed. RF rise triggering is initiated by the rising edge of an RF burst. With protocol triggering, sampling is initiated by a signaling event such as the start of a burst. An external trigger is used when set to external.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting

Range: IMMediate|PROTocol|RISE|EXTernal
Query

Range: IMM|PROT|RISE|EXT
*RST Setting IMMediate

Programming Example

OUTPUT 714;"SETup:SMONitor:TRIGger:SOURce RISE"
! Sets the measurement to trigger on the rising edge of an RF burst.


SETup:TROPower

SETup:TROPower

Diagram Conventions

SETup:TROPower:STEP

Function

 Sets the direction of the test set's cell power change. The mobile's output power is expected to change in the opposite direction as the 20 dB test set cell power change. See Time Response of Open Loop Power Control (TROLPC) Measurement Description .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: UP20|DOWN20

*RST Setting

 UP20

Programming Example

OUTPUT 714;"SETup:TROPower:STEP UP20"

SETup:TROPower:TIMeout[:STIMe]

Function

Sets the time response of open loop power control measurement's timeout value, and sets the measurement's timeout STATe to 1 (on). See TROLPC Measurement Parameters .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9 seconds

*RST Setting

10 seconds, off

Programming Example

OUTPUT 714;"SETup:TROPower:TIMeout 20"
!Sets timeout state to ON and sets the timeout time to 20 seconds.

SETup:TROPower:TIMeout:STATe

Function

Sets/queries the time response of open loop power control measurement's timeout state. See TROLPC Measurement Parameters .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:TROPower:TIMeout:STATe ON"
! sets the timeout state to on.

SETup:TROPower:TIMeout:TIME

Function

Sets/queries the time response of open loop power control measurement's timeout setting to be used when the timeout state is set to ON. See TROLPC Measurement Parameters .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

Range: 0.1 to 999.9 seconds

Resolution: 1 second

Query

Range: 0.1 to 999.9 seconds

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETup:TROPower:TIMeout:TIME 20"
! sets the timeout time to 20 seconds.


STATus Subsystem

STATus Subsystem

Description

The STATus subsystem is used to communicate current test set status information to the controlling application program.

Syntax Diagrams and Command Descriptions

STATus:OPERation

STATus:PRESet

STATus:QUEStionable

Status Byte Register
Standard Event Status Register

Related Topics

Status Subsystem Overview


STATus:OPERation

STATus:OPERation

Last updated: June 30, 2006

Diagram Conventions

STATus:OPERation Condition Register Bit Assignments

The OPERation status register set contains bits which give an indication of conditions that are part of the test set's normal operation.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | KEYPressed Summary | This bit is the summary bit for the STATus:OPERation:KEYPressed register.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | SYSTem:SYNChronized | This condition bit is "pulsed" by the SYSTem:SYNChronized command. This will allow the status system to indicate that the input buffer is synchronized to the point where this command is parsed and that all prior sequential commands are completed and all prior overlapped commands have started.
11 | 2048 | HARDware Summary | This bit is the summary bit for the STATus:OPERation:HARDware register.
10 | 1024 | CALL Summary | This bit is the summary bit for the STATus:OPERation:CALL register.
9 | 512 | NMRReady (New Measurement Result Ready) Summary | This bit is the summary bit for the STATus:OPERation:NMRReady register.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation

OUTPUT 714;"STATUS:OPERATION:EVENT?" !Queries the Operation Event Register.
OUTPUT 714;"STATUS:OPERATION:CONDITION?" !Queries the Operation Condition Register.
OUTPUT 714;"STATUS:OPERATION:ENABLE 1024" !Sets the Operation Enable Register for bit 10.
OUTPUT 714;"STATUS:OPERATION:NTR 1024" !Sets the Operation Negative Transition
                                       !Register for bit 10.
OUTPUT 714;"STATUS:OPERATION:PTR 512" !Sets the Operation Event Positive Transition
                                      !Register for bit 9.

STATus:OPERation:CALL Condition Register Bit Assignment

The STATus:OPERation:CALL register bits will be used to indicate status of processes that occur during normal call processing operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | DIGital856 Summary bit. | This bit is the summary bit for the STATus:OPERation:CALL:DIGital856 register.
13 | 8192 | TA856 Summary bit. | This bit is the summary bit for the STATus:OPERation:CALL:TA856 register.
12 | 4096 | GPRS Summary bit. | This bit is the summary bit for the STATus:OPERation:CALL:GPRS register.
11 | 2048 | WCDMa Summary bit. | This bit is the summary bit for the STATus:OPERation:CALL:WCDMa register.
10 | 1024 | FDD Summary bit. | This bit is the summary bit for the STATus:OPERation:CALL:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:TA136 register.
4 | 16 | DIGital136 Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:DIGITAL136 register.
3 | 8 | AMPS Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:GSM register.
1 | 2 | COMMon Summary bit | This bit is the summary bit for the STATus:OPERation:CALL:COMMon register.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:CALL

OUTPUT 714;"STATUS:OPERATION:CALL:EVENT?" !Queries the Operation Call Event !Register.
OUTPUT 714;"STATUS:OPERATION:CALL:CONDITION?" !Queries the Operation Call Condition Register.
OUTPUT 714;"STATUS:OPERATION:CALL:ENABLE 4"
    !Sets the Operation Call Enable Register for bit 2.
OUTPUT 714;"STATUS:OPERATION:CALL:NTR 4" !Sets the Negative Transition Register for bit 2.
OUTPUT 714;"STATUS:OPERATION:CALL:PTR 256" !Sets the Positive Transition Register for bit 8.

STATus:OPERation:CALL:CDMA Condition Register Bit Assignment

The STATus:OPERation:CALL:CDMA register bits will be used to indicate status of processes that occur during CDMA call processing operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:CALL:CDMA

OUTPUT 714;"STATUS:OPERATION:CALL:CDMA:EVENT?"
    !Queries the Operation Call CDMA Event Register.
OUTPUT 714;"STATUS:OPERATION:CALL:CDMA:CONDITION?"
    !Queries the Operation Call CDMA Condition Register.
OUTPUT 714;"STATUS:OPERATION:CALL:CDMA:ENABLE 2"
    !Sets the Operation Call CDMA Enable Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:CALL:CDMA:NTR 4"
    !Sets the CDMA Negative Transition Register for bit 2.
OUTPUT 714;"STATUS:OPERATION:CALL:CDMA:PTR 256"
    !Sets the CDMA Positive Transition 	Register for bit 8.

STATus:OPERation:CALL:COMMon Condition Register Bit Assignment

The STATus:OPERation:CALL:COMMon register bits will be used to indicate status of processes that occur during normal call processing operations.

Bit Number

Binary Weighting

Condition

Description

15

32768

Not Used. Defined by SCPI.

This bit is always 0.

14

16384

Data Summary

 This bit is the summary bit for the STATus:OPERation:CALL:COMMON:DATA register.

13

8192

 Call Control Status Access Probe

This bit is a 1 when the test set is in the call control status access probe state.

12

4096

Call Control Status Set Up Request

This bit is a 1 when the test set is in the call control status set up request state.

11

2048

Call Control Status Releasing

This bit is a 1 when the test set is in the call control status releasing state.

10

1024

Call Control Status Paging

This bit is a 1 when the test set is in the call control status paging state.

9

512

Registering (BS initiated)

This bit is set to a 1 when the Base Station initiates registration.

8

256

Reserved for future use.

This bit is always 0.

7

128

BS Originating

This bit is a 1 when:

  • Active Cell mode - the call processing state leaves the idle state

  • Test mode - the test set has noted a base station origination.

6

64

 Call Control Status Changing

This bit is a 1 when the test set is in the call control status changing state.

5

32

Call Control Status Handover/Handoff

This bit is a 1 when the test set is in the call control handover or handoff state.

4

16

Call Control Status Registering

This bit will be a 1 when the test set is in the call control status registering state.

3

8

Call Control Status Alerting

This bit is a 1 when the test set is in the call alerting state (ringing).

2

4

Call Control Status is Connected

This bit is a 1 when the test set is in the call connected state.

1

2

Call Control Status is Idle

This bit is a 1 when the test set is in the call idle state.

0

1

Extension Bit

This bit is always 0.

Program Examples - STATus:OPERation:CALL:COMMon

OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:EVENT?" !Queries the Operation Call Common Event
                                          !Register.
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:CONDITION?" !Queries the Operation Call Common
                                              !Condition Register.
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:ENABLE 8" !Sets the Operation Call Common Enable
                                            !Register for bit 3.
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:NTR 8" !Sets the Negative Transition
                                         !Register for bit 3.
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:PTR 256" !Sets the Positive Transition
                                           !Register for bit 8.

STATus:OPERation:CALL:COMMon:DATA Condition Register Bit Assignment

The STATus:OPERation:CALL:COMMon:DATA register bits are used to indicate status of processes that occur during normal data connection processing operations.

Bit Number

Binary Weighting

Condition

Description

15

32768

Not Used. Defined by SCPI.

This bit is always 0.

14

16384

Ping Active.

This bit is a 1 when the ping operation is active (in progress).

13

8192

Reserved for future use.

This bit is always 0.

12

4096

Reserved for future use.

This bit is always 0.

11

2048

Reserved for future use.

This bit is always 0.

10

1024

Data Connection Status Dormant

This bit is a 1 when the data connection status is Dormant.

9

512

Data Connection Status Session Open

This bit is a 1 when the data connection status is Session Open.

8

256

 PDP Active State This bit is a 1 when the PDP is active, zero when inactive.

7

128

Starting Data Connection

This bit is a 1 when:

  • Active Cell mode - the data connection status leaves the idle state

  • Test mode - the test set has noted a base station origination.

6

64

Data Connection Status Changing

This bit is set to a 1 when the data connection status change detector has been armed.

5

32

 Data Connection Status Off This bit is set to 1 when the test set is in the call control status handover/handoff state.

4

16

 Data Connection Status Data Connected

This bit is set to 1 when data connection status is in the data Connected state.

3

8

Data Connection Status Transferring

This bit is set to 1 when the data connection status is Transferring.

2

4

Data Connection Status Attached

This bit is set to 1 when the data connection status is Attached.

1

2

Data Connection Status Idle

This bit is set to 1 when the data connection status is Idle.

0

1

Extension Bit

This bit will always be 0.

Program Examples STATus:OPERation:CALL:COMMon:DATA

OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:EVENT?" !Queries and clears the Operation
                                                      !Call Common Data Event Register
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:CONDITION?" !Queries and clears the Operation
                                                          !Call Common Data Condition
                                                          !Register
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:ENABLE 128" !Sets the Operation Call Common
                                                          !Data Enable Register for bit 7
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:NTRANSITION 2" !Sets the Operation Call Common
                                                        !Data Negative Transition Filter
                                                        !Register for bit 1
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:PTRANSITION 2" !Sets the Operation Call Common
                                                        !Data Positive Transition Filter
                                                        !Register for bit 1

STATus:OPERation:CALL:DIGital856 Condition Register Bit Assignment

The STATus:OPERation:CALL:DIGital856 register bits will be used to indicate status of processes that occur during DIGital856 call processing operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:CALL:DIGital856

OUTPUT 714;"STATUS:OPERATION:CALL:DIGITAL856:EVENT?"
    !Queries the Operation Call DIGital856 Event Register.
OUTPUT 714;"STATUS:OPERATION:CALL:DIGITAL856:CONDITION?"
    !Queries the Operation Call DIGital856Condition Register.
OUTPUT 714;"STATUS:OPERATION:CALL:DIGITAL856:ENABLE 2"
    !Sets the Operation Call DIGital856Enable Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:CALL:DIGITAL856:NTR 4"
    !Sets the DIGital856 Negative Transition Register for bit 2.
OUTPUT 714;"STATUS:OPERATION:CALL:DIGITAL856:PTR 256"
    !Sets the DIGital856 Positive Transition 	Register for bit 8.

STATus:OPERation:CALL:TA856 Condition Register Bit Assignment

The STATus:OPERation:CALL:TA856 register bits will be used to indicate status of processes that occur during TA856 call processing operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:CALL:TA856

OUTPUT 714;"STATUS:OPERATION:CALL:TA856:EVENT?"
    !Queries the Operation Call TA856 Event Register.
OUTPUT 714;"STATUS:OPERATION:CALL:TA856:CONDITION?"
    !Queries the Operation Call TA856Condition Register.
OUTPUT 714;"STATUS:OPERATION:CALL:TA856:ENABLE 2"
    !Sets the Operation Call TA856Enable Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:CALL:TA856:NTR 4"
    !Sets the TA856 Negative Transition Register for bit 2.
OUTPUT 714;"STATUS:OPERATION:CALL:TA856:PTR 256"
    !Sets the TA856 Positive Transition 	Register for bit 8.

STATus:OPERation:HARDware Condition Register Bit Assignments

The STATus:OPERation:HARDware register bits indicate when a softkey on the test set's front panel has been pressed while the test set is in remote operating mode.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | External Timebase in use | This bit is a 1 if a suitable external timebase is connected to the test set's 10 MHz REF IN connector on the rear panel of the test set.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:HARDware

OUTPUT 714;"STATUS:OPERATION:HARDware:EVENT?"
    !Queries the HARDware Event Register.
OUTPUT 714;"STATUS:OPERATION:HARDware:CONDITION?"
    !Queries the HARDware Condition Register.
OUTPUT 714;"STATUS:OPERATION:HARDware:ENABLE 16"
    !Sets HARDware Enable register for bit 4.
OUTPUT 714;"STATUS:OPERATION:HARDware:NTR 2"
    !Sets the HARDware Negative Transition Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:HARDware:PTR 4"
    !Sets the HARDware Positive Transition Register for bit 2

STATus:OPERation:KEYPressed Condition Register Bit Assignments

The STATus:OPERation:KEYPressed register bits indicate when a softkey on the test set's front panel has been pressed while the test set is in remote operating mode.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | F12 softkey | This bit is a 1 when the test set's F12 softkey has been pressed.
10 | 1024 | F11 softkey | This bit is a 1 when the test set's F11 softkey has been pressed.
9 | 512 | F10 softkey | This bit is a 1 when the test set's F10 softkey has been pressed.
8 | 256 | F9 softkey | This bit is a 1 when the test set's F9 softkey has been pressed.
7 | 128 | F8 softkey | This bit is a 1 when the test set's F8 softkey has been pressed.
6 | 64 | F7 softkey | This bit is a 1 when the test set's F7 softkey has been pressed.
5 | 32 | F6 softkey | This bit is a 1 when the test set's F6 softkey has been pressed.
4 | 16 | F5 softkey | This bit is a 1 when the test set's F5 softkey has been pressed.
3 | 8 | F4 softkey | This bit is a 1 when the test set's F4 softkey has been pressed.
2 | 4 | F3 softkey | This bit is a 1 when the test set's F3 softkey has been pressed.
1 | 2 | F2 softkey | This bit is a 1 when the test set's F2 softkey has been pressed.
0 | 1 | F1 softkey | This bit is a 1 when the test set's F1 softkey has been pressed.

Program Examples - STATus:OPERation:KEYPressed

OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:EVENT?"
    !Queries the Keypressed Event Register.
OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:CONDITION?"
    !Queries the Keypressed Condition Register.
OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:ENABLE 16"
    !Sets Keypressed Enable register for bit 4.
OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:NTR 2"
    !Sets the Keypressed Negative Transition Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:PTR 4"
    !Sets the Keypressed Positive Transition Register for bit 2

STATus:OPERation:NMRReady Condition Register Bit Assignments

The STATus:OPERation:NMRReady register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | DIGital856 | This bit is the summary bit for the STATus:OPERation:NMRReady:DIGital856 register.
13 | 8192 | TA856 | This bit is the summary bit for the STATus:OPERation:NMRReady:TA856 register.
12 | 4096 | GPRS | This bit is the summary bit for the STATus:OPERation:NMRReady:GPRS register.
11 | 2048 | WCDMa | This bit is the summary bit for the STATus:OPERation:NMRReady:WCDMa register.
10 | 1024 | FDD | This bit is the summary bit for the STATus:OPERation:NMRReady:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:TA136 register.
4 | 16 | DIGITAL136 Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:DIGITAL136 register.
3 | 8 | AMPS Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary bit for the OPERation:NMRReady:GSM register.
1 | 2 | COMMON Summary bit | This bit is the summary bit for the STATus:OPERation:NMRReady:COMMon register.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady

OUTPUT 714;"STATUS:OPERATION:NMRREADY:EVENT?" !Queries the New Measurement
                                              !Results Ready Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CONDITION?" !Queries the New Measurement
                                                  !Results Ready
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:ENABLE 16" !Sets New Measurement Results
                                                 !Ready Enable Regigter
                                                 !for bit 4.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:NTR 2" !Sets the New Measurement Results
                                             !Ready Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:PTR 4" !Sets the New Measurement
                                             !Results Ready Positive
                                             !Transition Register
                                             !for bit 2

STATus:OPERation:NMRReady:CDMA Condition Register Bit Assignments

The STATus:OPERation:NMRReady:CDMA register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | CFDTune New Measurement Result Ready. | This bit is a 1 if the Fast Device Tune measurement has completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | CTDPower New Measurement Result Ready | This bit is a 1 if the measurement has completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
9 | 512 | GAPPower New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
8 | 256 | CTXSpurious New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
7 | 128 | GPOWer New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
6 | 64 | TROPower New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
5 | 32 | CAPPower New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
4 | 16 | CFERror New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
3 | 8 | CPOWer New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
2 | 4 | WQUality New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
1 | 2 | DAPower New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:CDMA

OUTPUT 714;"STATUS:OPERATION:NMRREADY:CDMA:EVENT?" !Queries the New Measurement
                                              !Results Ready CDMA Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CDMA:CONDITION?" !Queries the New Measurement
                                                  !Results Ready CDMA
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CDMA:ENABLE 8" !Sets New Measurement Results
                                                 !Ready CDMA Enable Regigter
                                                 !for bit 3.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CDMA:NTR 2" !Sets the New Measurement Results
                                             !Ready CDMA Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CDMA:PTR 4" !Sets the New Measurement
                                             !Results Ready CDMA Positive
                                             !Transition Register
                                             !for bit 2

STATus:OPERation:NMRReady:COMMon Condition Register Bit Assignments

The STATus:OPERation:NMRReady:COMMon register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Spectrum Monitor New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Audio Analyzer New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:COMMon

OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:EVENT?" !Queries the New Measurement
                                              !Results Ready Common Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:CONDITION?" !Queries the New Measurement
                                                  !Results Ready Common
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:ENABLE 2" !Sets New Measurement Results
                                                 !Ready Common Enable Register
                                                 !for bit 1.

OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:NTR 2" !Sets the New Measurement Results
                                             !Ready Common Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:PTR 2" !Sets the New Measurement
                                             !Results Ready Common Positive
                                             !Transition Register
                                             !for bit 1

STATus:OPERation:NMRReady:DIGital856 Condition Register Bit Assignments

The STATus:OPERation:NMRReady:DIGital856 register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | DOWQuality New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
1 | 2 | CPERror New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:DIGital856

OUTPUT 714;"STATUS:OPERATION:NMRREADY:DIGITAL856:EVENT?" !Queries the New Measurement
                                              !Results Ready DIG856 Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:DIGITAL856:CONDITION?" !Queries the New
                                                  !Measurement Results Ready DIG856
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:DIGITAL856:ENABLE 8" !Sets New Measurement Results
                                                 !Ready DIG856 Enable Register
                                                 !for bit 3.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:DIGITAL856:NTR 2" !Sets the New Measurement Results
                                             !Ready DIG856 Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:DIGITAL856:PTR 4" !Sets the New Measurement
                                             !Results Ready DIG856 Positive
                                             !Transition Register
                                             !for bit 2

STATus:OPERation:NMRReady:TA856 Condition Register Bit Assignments

The STATus:OPERation:NMRReady:TA856 register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:TA856

OUTPUT 714;"STATUS:OPERATION:NMRREADY:TA856:EVENT?" !Queries the New Measurement
                                              !Results Ready DIG2000 Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:TA856:CONDITION?" !Queries the New
                                                  !Measurement Results Ready DIG2000
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:TA856:ENABLE 8" !Sets New Measurement Results
                                                 !Ready DIG2000 Enable Register
                                                 !for bit 3.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:TA856:NTR 2" !Sets the New Measurement Results
                                             !Ready DIG2000 Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:TA856:PTR 4" !Sets the New Measurement
                                             !Results Ready DIG2000 Positive
                                             !Transition Register
                                             !for bit 2


STATus:PRESet

STATus:PRESet

Diagram Conventions

STATus:PRESet

Function

Presets the status subsystem.

Presetting the status subsystem performs the following functions:

  • All enable registers are set to 0 (not enabled)
  • All Positive Transition Registers (PTR's) are set to 1 (positive transitions enabled).
  • All Negative Transition Registers (NTR's) are set to 0 (negative transitions disabled).


STATus:QUEStionable

STATus:QUEStionable

Diagram Conventions

STATus:QUEStionable Condition Register Bit Assignment

The STATus:QUEStionable register contains bits which give an indication that the data currently being acquired or generated is of questionable quality due to some condition affecting the functionality associated with that bit.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | QUEStionable:HARDware summary | This bit is the summary bit for the STATus:QUEStionable:HARDware register.
10 | 1024 | QUEStionable:CALL summary | This bit is the summary bit for the STATus:QUEStionable:CALL register.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | QUEStionable:ERRors summary | This bit is the summary bit for the STATus:QUEStionable:ERRors register.
0 | 1 | Reserved for future use. | This bit is always 0.

Program Example - STATus:QUEStionable Register Bit Assignments

OUTPUT 714;"STATUS:QUESTIONABLE:EVENT?" !Queries and clears the Questionable Event
                                        !Register
OUTPUT 714;"STATUS:QUESTIONABLE:CONDITION?" !Queries and clears the Questionable Condition
                                            !Register
OUTPUT 714;"STATUS:QUESTIONABLE:ENABLE 1024" !Sets the Questionable Enable Register
                                             !for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:NTRANSITION 2" !Sets the Questionable Negative
                                               !Transition Filter Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:PTRANSITION 2" !Sets the Questionable Positive
                                               !Transition Filter Register for bit 1

STATus:QUEStionable:CALL Condition Register Bit Assignment

The STATus:QUEStionable:CALL registers will contain information about which event(s) occurred during call processing that indicate what call processing procedure failed

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | DIGital856 Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:DIGital856 register.
13 | 8192 | TA856 Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:TA856 register.
12 | 4096 | GPRS Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:GPRS register.
11 | 2048 | WCDMa Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:WCDMa register.
10 | 1024 | FDD Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary bit for the STATus:QUEStionable:ERRors:CALL:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary bit for the STATus:QUEStionable:ERRors:CALL:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:TA136 register.
4 | 16 | DIGital136 Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:DIGital136 register.
3 | 8 | AMPS Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:GSM register.
1 | 2 | COMMon Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:COMMon register.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:CALL Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:CALL:EVENT?" !Queries and clears the Questionable
                                             !Call Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:CONDITION?" !Queries and clears the Questionable
                                                 !Call Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:ENABLE 1024" !Sets the Questionable
                                                  !Call Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:NTRANSITION 2" !Sets the Questionable Call
                                                    !Negative Transition Filter Register
                                                    !for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:PTRANSITION 2" !Sets the Questionable Call
                                                    !Positive Transition Filter Register
                                                    !for bit 1

STATus:QUEStionable:CALL:CDMA Condition Register Bit Assignment

The STATus:QUEStionable:CALL:CDMA registers will contain information about which event(s) occurred during call processing that indicate what call processing procedure failed

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | MUI Maskable Message. | This bit is a 1 when a Maskable Message occurs.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Session timer timed out. | This bit is a 1 when (RHRUIPD 10-001734 rev 25).
4 | 16 | Call drop timer timed out. | This bit is a 1 after 250 consecutive bad frames are counted indicating that the reverse link is lost
3 | 8 | Service connect completion not received. | This bit is a 1 when the test set has not received a message from the MS that it has completed the change to a new Service Option or Radio Configuration.
2 | 4 | Service Option or Radio Configuration rejected by MS. | This bit is a 1 when the MS receives a Service Option or a Radio Configuration that it does not support.
1 | 2 | Traffic channel preamble not received. | This bit is a 1 if no preamble was received from the MS.
0 | 1 | Extension Bit. | This bit is always 0.

Program Example - STATus:QUEStionable:CALL:CDMA Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:CALL:CDMA:EVENT?"
    !Queries and clears the Questionable Call CDMA Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:CDMA:CONDITION?"
    !Queries and clears the Questionable Call CDMA Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:CDMA:ENABLE 1024"
    !Sets the Questionable Call CDMA Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:CDMA:NTRANSITION 2"
    !Sets the Questionable Call CDMA Negative Transition Filter Register !for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:CDMA:PTRANSITION 2"
    !Sets the Questionable Call CDMA Positive Transition Filter Registerfor bit 1

STATus:QUEStionable:CALL:COMMon Condition Register Bit Assignment

The STATus:QUEStionable:CALL:COMMon registers contain information about which event(s) occurred during normal call processing that indicate why the call processing procedure failed.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:CALL:COMMon Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:CALL:COMMON:EVENT?" !Queries and clears the Questionable
                                                    !Call Common Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:COMMON:CONDITION?" !Queries and clears the Questionable
                                                        !Call Common Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:COMMON:ENABLE 1024" !Sets the Questionable Call Common
                                                         !Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:COMMON:NTRANSITION 2" !Sets the Questionable Call
                                                           !Common Negative Transition
                                                           !Filter Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:GSM:PTRANSITION 2" !Sets the Questionable Call
                                                        !Common Positive Transition
                                                        !Filter Register for bit 1

STATus:QUEStionable:CALL:DIGital856 Condition Register Bit Assignment

The STATus:QUEStionable:CALL:DIGital856 registers will contain information about which event(s) occurred during call processing that indicate what call processing procedure failed

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:CALL:TA2000 Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:CALL:DIGITAL856:EVENT?"
    !Queries and clears the Questionable Call Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:DIGITAL856:CONDITION?"
    !Queries and clears the Questionable Call Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:DIGITAL856:ENABLE 1024"
    !Sets the Questionable Call Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:DIGITAL856:NTRANSITION 2"
    !Sets the Questionable Call Negative Transition Filter Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:DIGITAL856:PTRANSITION 2"
    !Sets the Questionable Call Positive Transition Filter Register for bit 1

STATus:QUEStionable:CALL:TA856 Condition Register Bit Assignment

The STATus:QUEStionable:CALL:TA856 registers will contain information about which event(s) occurred during call processing that indicate what call processing procedure failed

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | MUI Maskable Message. | This bit is a 1 when a Maskable Message occurs.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Handoff rejected due to no traffic channel. | This bit is a 1 when
5 | 32 | FTAP Parameter Assignment Complete message not received. | This bit is a 1 when
4 | 16 | RTAP Parameter Assignment Complete message not received. | This bit is a 1 when
3 | 8 | Close Connection message not received. | This bit is a 1 when
2 | 4 | Session Close message not received in response to Session Close message sent. | This bit is a 1 when
1 | 2 | Hardware ID Response message not received. | This bit is a 1 when
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:CALL:TA2000 Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:CALL:TA856:EVENT?"
    !Queries and clears the Questionable Call Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:TA856:CONDITION?"
    !Queries and clears the Questionable Call Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:TA856:ENABLE 1024"
    !Sets the Questionable Call Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:TA856:NTRANSITION 2"
    !Sets the Questionable Call Negative Transition Filter Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:TA856:PTRANSITION 2"
    !Sets the Questionable Call Positive Transition Filter Register for bit 1

STATus:QUEStionable:ERRors Condition Register Bit Assignment

The STATus:QUEStionable:ERRors register bits will be used to indicate information about test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | DIGital856 Summary bit | This bit is the summary bit for the STATus:QUEStionable:ERRors:DIGital856 register.
13 | 8192 | TA856 Summary bit | This bit is the summary bit for the STATus:QUEStionable:ERRors:TA856 register.
12 | 4096 | GPRS Summary bit | This bit is the summary bit for the STATus:QUEStionable:ERRors:GPRS register.
11 | 2048 | WCDMa Summary bit | This bit is the summary bit for the STATus:QUEStionable:ERRors:WCDMa register.
10 | 1024 | FDD Summary bit | This bit is the summary bit for the STATus:QUEStionable:ERRors:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary bit for the STATus:QUEStionable:ERRors:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary bit for the STATus:QUEStionable:ERRors:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary bit for the STATus:QUEStionable:ERRors:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary bit for the STATus:QUEStionable:ERRors:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary bit for the STATus:QUEStionable:ERRors:TA136 register.
4 | 16 | DIGital136 Summary bit | This bit is the summary bit for the STATus:QUEStionable:ERRors:DIGital136 register.
3 | 8 | AMPS Summary bit | This bit is the summary bit for the STATus:QUEStionable:ERRors:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary bit for the STATus:QUEStionable:ERRors:GSM register.
1 | 2 | COMMon Summary bit | This bit is the summary bit for the STATus:QUEStionable:CALL:ERRors register.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors Register Bit Assignments

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:EVENT?" !Queries and clears the Questionable
                                               !Errors Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:CONDITION?" !Queries and clears the Questionable
                                                   !Errors Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:ENABLE 1024" !Sets the Questionable
                                                    !Errors Enable
                                                    !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:NTRANSITION 2" !Sets the Questionable Errors
                                                      !Negative Transition Filter Register
                                                      !for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:PTRANSITION 2" !Sets the Questionable Errors
                                                      !Positive Transition Filter Register
                                                      !for bit 1

STATus:QUEStionable:ERRors:CDMA Condition Register Bit Assignments

The STATus:QUEStionable:ERRors:CDMA register bits will be used to indicate information about CDMA related test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | MUI Maskable Message. | This bit is a 1 when a Maskable Message occurs.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit will be pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors:CDMA Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:CDMA:EVENT?" !Queries and clears the Questionable
                                                    !Errors CDMA Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:CDMA:CONDITION?" !Queries and clears the Questionable
                                                        !Errors CDMA Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:CDMA:ENABLE 1024" !Sets the Questionable
                                                         !Errors CDMA Enable
                                                         !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:CDMA:NTRANSITION 2" !Sets the Questionable Errors
                                                           !CDMA Negative Transition
                                                           !Filter Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:CDMA:PTRANSITION 2" !Sets the Questionable Errors
                                                           !CDMA Positive Tranasition
                                                           !Filter Register for bit 1

STATus:QUEStionable:ERRors:COMMon Condition Register Bit Assignments

The STATus:QUEStionable:ERRors:COMMon register bits will be used to indicate information about the COMMon test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | RUI Maskable Messages. | This bit is a 1 when a Maskable Message occurs.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors:COMMon Register Bit Assignments

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:EVENT?" !Queries and clears the Questionable
                                                      !Errors Common Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:CONDITION?" !Queries the and clears the
                                                          !Questionable Errors
                                                          !Common Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:ENABLE 1024" !Sets the Questionable
                                                           !Errors Common Enable
                                                           !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:NTRANSITION 2" !Sets the Questionable Errors
                                                             !Common Negative Transition
                                                             !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:PTRANSITION 2" !Sets the Questionable Errors
                                                             !Common Positive Tranasition
                                                             !Register for bit 1

STATus:QUEStionable:ERRors:DIGital856 Condition Register Bit Assignment

The STATus:QUEStionable:ERRors:DIGital856 register bits will be used to indicate information about DIGital856 related test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | MUI Maskable Message. | This bit is a 1 when a Maskable Message occurs.???
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit will always be 0.

Program Example - STATus:QUEStionable:ERRors:DIGital2000 Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:DIGITAL856:EVENT?" !Queries and clears the
                                                     !Questionable Errors
                                                     !DIGITAL2000 Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:DIGITAL856:CONDITION?" !Queries and clears the
                                                         !Qestionable Errors
                                                         !DIGITAL2000 Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:DIGITAL856:ENABLE 1024" !Sets the Questionable
                                                          !Errors DIGITAL2000 Enable
                                                          !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:DIGITAL856:NTRANSITION 2" !Sets the Questionable
                                                            !Errors DIGITAL2000 Negative
                                                            !Transition Filter
                                                            !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:DIGITAL856:PTRANSITION 2" !Sets the Questionable
                                                            !Errors DIGITAL2000 Positive
                                                            !Transition Filter
                                                            !Register for bit 1

STATus:QUEStionable:ERRors:TA856 Condition Register Bit Assignment

The STATus:QUEStionable:ERRors:TA856 register bits will be used to indicate information about TA856 related test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | MUI Maskable Message. | This bit is a 1 when a Maskable Message occurs.???
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit will always be 0.

Program Example - STATus:QUEStionable:ERRors:DIGital95 Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:TA856:EVENT?" !Queries and clears the
                                                     !Questionable Errors
                                                     !DIGITAL95 Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:TA856:CONDITION?" !Queries and clears the
                                                         !Qestionable Errors
                                                         !DIGITAL95 Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:TA856:ENABLE 1024" !Sets the Questionable
                                                          !Errors DIGITAL95 Enable
                                                          !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:TA856:NTRANSITION 2" !Sets the Questionable
                                                            !Errors DIGITAL95 Negative
                                                            !Transition Filter
                                                            !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:TA856:PTRANSITION 2" !Sets the Questionable
                                                            !Errors DIGITAL95 Positive
                                                            !Transition Filter
                                                            !Register for bit 1

STATus:QUEStionable:HARDware Condition Register Bit Assignment

The STATus:QUEStionable:HARDware register bits give an indication that the data/signals currently being acquired or generated are of questionable quality.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit will always be 0.
11 | 2048 | Reserved for future use. | This bit will always be 0.
10 | 1024 | Reserved for future use. | This bit will always be 0.
9 | 512 | Reserved for future use. | This bit will always be 0.
8 | 256 | Reserved for future use. | This bit will always be 0.
7 | 128 | Reserved for future use. | This bit will always be 0.
6 | 64 | Reserved for future use. | This bit will always be 0.
5 | 32 | Reserved for future use. | This bit will always be 0.
4 | 16 | Power-up Self Test(s) Failed | This bit will be a 1 if the power-up self tests failed.
3 | 8 | Reserved for future use. | This bit will always be 0.
2 | 4 | Reserved for future use. | This bit will always be 0.
1 | 2 | Reserved for future use. | This bit will always be 0.
0 | 1 | Extension Bit. | This bit will always be 0.

Program Example - STATus:QUEStionable:HARDware Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:EVENT?" !Queries and clears the Questionable
                                                 !Hardware Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:CONDITION?" !Queries and clears the Questionable
                                                     !Hardware Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:ENABLE 1024" !Sets the Questionable
                                                      !Hardware Enable
                                                      !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:NTRANSITION 2" !Sets the Questionable
                                                        !Hardware Negative Transition Filter
                                                        !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:PTRANSITION 2" !Sets the Questionable
                                                        !Hardware Positive Transition Filter
                                                        !Register for bit 1


Status Byte Register

Status Byte Register

Last updated: June 21, 2006

*STB?

NOTE
The Status Byte Register can also be read with a serial poll. For example, the command "Status_byte = SPOLL(714)" would perform a serial poll of the Status Byte Register, returning and releasing RQS (bit 6).

Status Byte Register Bit Assignments

Bit Number | Binary Weighting | Label | Description
7 | 128 | STATus: OPERation | Summarizes the STATus: OPERationStatus Register, which fans out to theNMRReady and CALL Status Registers.
6 | 64 | RQS (SRQ TRUE?)/Master Summary Status | RQS is read by a serial poll (SPOLL)Master Summary Status is read by a *STB? query - defined by IEEE 488.2
5 | 32 | Standard Event Status Register | Summarizes the Standard Event Status Register
4 | 16 | Message Available | SCPI - Defined
3 | 8 | STATus: QUEStionableStatus Register | Summary Message comes from theSTATus: QUEStionable Status Register,which fans out to the CALL andHARDware Status Registers
2 | 4 | Error/ Event Queue | SCPI - Defined
1 | 2 | Reserved |
0 | 1 | Reserved |

Program Example - Status Byte Register Bit Assignments

OUTPUT 714;"*STB?" !Queries the Status Byte.


Standard Event Status Register

Standard Event Status Register

*ESR?

*ESE?

*ESE

Diagram Conventions

Standard Event Status Register Bit Assignment

Bit Number

Binary Weighting

Condition

Description

15

32768

Reserved by IEEE.

This bit will always be 0.

14

16384

Reserved by IEEE.

This bit will always be 0.

13

8192

Reserved by IEEE.

This bit will always be 0.

12

4096

Reserved by IEEE.

This bit will always be 0.

11

2048

Reserved by IEEE.

This bit will always be 0.

10

1024

Reserved by IEEE.

This bit will always be 0.

9

512

Reserved by IEEE.

This bit will always be 0.

8

256

Reserved by IEEE.

This bit will always be 0.

7

128

Power On

This bit is set to 1 if the power supply has been turned off and on since the last time this register was read or otherwise cleared. Defined in "IEEE Std. 488.2-1992",11.5.1.1.2

6

64

Reserved for future use.

This bit will always be 0.

5

32

Command Error

This bit is set to 1 if the test set detects an error while trying to process a command. The following events cause a command error:

  • An IEEE 488.2 syntax error. The test set received a message that did not follow the syntax defined by the standard.

  • A semantic error. For example the test set received an incorrectly spelled command.

  • The test set received a group execution trigger (GET) inside a program message

4

16

Execution Error

This bit is set to 1 if the test set detects an error while trying to execute a command. The following events cause a execution error:

  • A <PROGRAM DATA> element received in a command is outside the legal range for the test set, or it is inconsistent with the operation of the test set.

  • The test set could not execute a valid command due to some test set hardware/firmware condition.

3

8

Device Dependent Error

This bit is set to 1 if a test set operation does not execute properly due to an internal condition (such as, overrange). This bit indicates that the error was not a command, query, or execution error.

2

4

Query Error

This bit is set to 1 if an error has occurred while trying to read the test set's output queue. The following events cause a query error:

  • An attempt is made to read data from the output queue when no data is present or is pending.

  • Data in the output queue has been lost. An example of this would be an output queue overflow.

1

2

Reserved for future use.

This bit will always be 0.

0

1

Operation Complete

This bit is set to 1 when the test set has completed all pending operations and is ready to accept new commands. This bit is only generated in response to the *OPC IEEE 488.2 common command.

Program Example - Standard Event Status Register

OUTPUT 714;"*ESR?" !Queries (reads) the Standard Event Status Register.


Diagram Conventions

Diagram Conventions

Last updated: June 21, 2006

Description

Diagram Description

Mnemonics are connected by lines. Each line can be followed in only one direction, as indicated by the arrow at the end of the line. Any combination of mnemonics that can be generated by starting at the root mnemonic and following the line in the direction of the arrow is syntactically correct.

The uppercase letters of a mnemonic represent the short form of the mnemonic, whereas the long form of a mnemonic is the short form followed by the lowercase letters. The test set accepts either the long form or the short form of the mnemonic. The mnemonics that are inside square brackets are optional. That is, a command operates the same whether or not the mnemonic in square brackets is used in the command.

The drawings show the proper use of spaces. Where spaces are required they are indicated by <sp>, otherwise no spaces are allowed between mnemonics.

Complex Command Description

Complex commands are valuable because they set the state of the parameter and a value for that parameter. For example, the command in the above figure that contains the mnemonic [:SAMPlitude] is a complex command because sets the state to ON as well as the amplitude. You can use parameters such as amplitude, frequency, gain, number, time, and value as a complex command. Refer to the specific command for the parameter that applies.

Data Type Description

num value

Integer, float or scientific values.

For example,

CALL:POWer -55.5

CALL:POWer -5.55E+001

CALL:CHANnel 525

string

Characters. The string will often need to be enclosed in single or double quotes, depending upon your programming environment.

For example,

CALL:CIDentity "#0123456789*"

CALL:UPLink:PRAChannel:ASUBchannels '111111111111'

The string returned by the test set is enclosed by double quotes.
choice1|choice2|choice3

Specific character choices.

For example,

CALL:OPERating:MODE D2KTest

SYSTem:COMMunicate:GPIB:DEBug ON

Unit Type Description

Some commands have optional units of measurement. These are displayed in square brackets. If no units are specified in the command then the default unit in bold font is used. The test set accepts the specified unit either with or without a space inserted between the <num value> and the unit (for example, both 10S and 10 S are valid). The following table summarizes the units available.

Description

Optional Units

Example

Amplitude (linear)

V |MV

To set the spectrum monitor's timeout interval to 20 seconds, use any of the following formats:

SETup:SMONitor:TIMeout:TIME 20
SETup:SMONitor:TIMeout:TIME 20S
SETup:SMONitor:TIMeout:TIME 20 S

Power (logarithmic)

DBM |DBW

Level (relative)

DB

Frequency

HZ |KHZ|MHZ|GHZ

Time

S |MS|US|NS

Percentage

PCT

[:SELected] Mnemonic

The [:SELected] Mnemonic is an optional mnemonic that implies a current selection on the test set. Often there are other mnemonics that can be used in place of the [:SELected] mnemonic to configure a setting that is not the currently selected configuration on the test set. The mnemonics that can replace the [:SELected] mnemonic are listed in parentheses separated by vertical bars ( | ) in the description table title. An example of a command that contains the [:SELected] mnemonic is shown in the following table.


SYSTem:APPLication

SYSTem:APPLication

Last updated: July 13, 2006

Diagram Conventions

SYSTem:APPLication[:CURRent][:NAME]?

Function

Queries the name of the currently running application.

To query the revision of the currently running application, see SYSTem:APPLication[:CURRent]:REVision? .

To switch applications, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication?"

SYSTem:APPLication[:CURRent]:REVision?

Function

Queries the revision of the currently running application.

To query the name of the currently running application, see SYSTem:APPLication[:CURRent][:NAME]? .

To switch to a different revision of an application, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01"

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:REVision?"

SYSTem:APPLication:CATalog[:NAME]?

Function

Queries the names of the applications stored on the test set.

This query returns a comma-separated list of double-quoted strings (one for each application stored on the test set).

To query the number of applications stored on the test set, see SYSTem:APPLication:CATalog[:NAME]:COUNt? .

To switch applications, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: One or more of the following strings, separated by commas -

  • "1xEV-DO Lab App"
  • "1xEV-DO Lab App T'
  • "1xEV-DO Terminal Test"
  • "AMPS/136 Mobile Test"
  • "CDMA 2000 Lab App"
  • "CDMA 2000 Lab App B"
  • "CDMA 2000 Lab App T"
  • "CDMA 2000 Mobile Test"
  • "CDMA 2000_1xEV-DO"
  • "EGPRS Lab App"
  • "Fast Switch Test App"
  • "GPRS Lab Application"
  • "GPRS Lab App B"
  • "GPRS Mobile Test"
  • "GSM Mobile Test"
  • "GSM/GPRS Lab App C"
  • "GSM/GPRS Lab App D"
  • "GSM/GPRS Lab App E"
  • "GSM/GPRS Lab App T"
  • "GSM/GPRS Mobile Test"
  • "GSM/GPRS RF Modem"
  • "GSM/GPRS_AMPS/136"
  • "GSM/GPRS_AMPS/136_WCDMA"
  • "GSM/GPRS_CDMA 2000"
  • "GSM/GPRS_WCDMA Lab App"
  • "GSM/GPRS_WCDMA Lab App B"
  • "GSM/GPRS_WCDMA Lab App C"
  • "GSM/GPRS_WCDMA Lab App D"
  • "GSM/GPRS_WCDMA Lab App T"
  • "WCDMA Lab App"
  • "WCDMA Lab App B"
  • "WCDMA Lab App C"
  • "WCDMA Lab App D"
  • "WCDMA Lab App T"
  • "WCDMA Mobile Test"

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog?"

SYSTem:APPLication:CATalog[:NAME]:COUNt?

Function

Queries the total number of applications stored on the test set.

To query the names of the applications stored on the test set, see SYSTem:APPLication:CATalog[:NAME]? .

Query

Range: 0 through 30

Resolution: 1

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:COUNt?"

SYSTem:APPLication:CATalog:FORMat?

Function

Queries the names of the formats in the current application.

This query returns a comma-separated list of double-quoted strings (one for each format in the application).

To query the number of formats in the current application, see SYSTem:APPLication:CATalog:FORMat:COUNt? .

To switch formats in a fast switching application, see SYSTem:APPLication:FORMat[:NAME] .

Query

Range: One or more of the following strings separated by commas -

  • "1xEV-DO"
  • "AMPS/136"
  • "GSM/GPRS" (Note: this query return represents GSM, GPRS and EGPRS formats)
  • "IS-2000/IS-95/AMPS"
  • "IS-856"
  • "WCDMA"

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:FORMat?"

SYSTem:APPLication:CATalog:FORMat:COUNt?

Function

Queries the number of formats in the current application.

To query the names of the formats in the current application, see SYSTem:APPLication:CATalog:FORMat? .

Query

Range: 0 to 30

Resolution: 1

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:FORMat:COUNt?"

SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>'

Function

Queries the license status for the specified application/revision. The application/revision does not have to be installed in the test set.

The query must include a parameter for the application name and revision, enclosed by single quotes and separated by a comma. For application names and revisions, see SYSTem:APPLication:CATalog[:NAME]? and SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' . Note that the application name and revision parameters are not case-sensitive.

Query

Range: LIC|NLIC|PART|UNKN

  • "LIC" indicates this is a licensed application/revision.
  • "NLIC" indicates this is not a licensed application/revision.
  • "PART" indicates that not all of the formats in this application/revision are licensed. (To determine the license status of each format, see SYSTem:APPLication:FORMat:LICense?<sp>'<format name>' .)
  • "UNKN" indicates that license status is unknown.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense? 'CDMA 2000 Mobile Test','B.07.00'"

SYSTem:APPLication:CATalog:LICense:APPLication:ALL?

Function

Queries the names of the applications, formats and features that are licensed for the test set. The applications, formats and features do not have to be installed in the test set to be returned by this query.

This query returns a comma-separated list of double-quoted strings (two for each application, one for each format or feature).

To query the number of licensed applications, formats and features for the test set, see SYSTem:APPLication:CATalog:LICense:APPLication:COUNt? .

Query

Range: One or more of the following strings, separated by commas.

Applications -

  • "E1960A","GSM Mobile Test"
  • "E1961A","AMPS/136 TA"
  • "E1962B","CDMA 2000 TA"
  • "E1963A","WCDMA TA"
  • "E1964A","GPRS Mobile Test"
  • "E1966A","1xEV-DO TA"
  • "E1968A","GSM/GPRS Mobile Test"
  • "E1985A","GSM/GPRS_AMPS/136"
  • "E1985B","GSM/GPRS_AMPS/136_WCDMA"
  • "E1985C","GSM/GPRS_CDMA 2000"
  • "E1985E","CDMA 2000_1xEV-DO"
  • "E1987A","Fast Switch Test App"
  • "E6590A","GSM/GPRS RF Modem"
  • "E6701A","GPRS LA"
  • "E6701B","GPRS LA rev B"
  • "E6701C","GSM/GPRS LA rev C"
  • "E6701D","GSM/GPRS LA rev D"
  • "E6701E","GSM/GPRS LA rev E"
  • "E6701T","GSM/GPRS LA rev T"
  • "E6702A","CDMA2000 LA"
  • "E6702B","CDMA2000 LA rev B"
  • "E6702T","CDMA2000 LA rev T"
  • "E6703A","WCDMA LA"
  • "E6703B","WCDMA LA rev B"
  • "E6703C","WCDMA LA rev C"
  • "E6703D","WCDMA LA rev D"
  • "E6703T","WCDMA LA rev T"
  • "E6704A","EGPRS LA"
  • "E6706A","1xEV-DO Lab App"
  • "E6706T","1xEV-DO LA rev T"
  • "E6785A","GSM/GPRS_WCDMA Lab App"
  • "E6785B","GSM/GPRS_WCDMA LA rev B"
  • "E6785C","GSM/GPRS_WCDMA LA rev C"
Query (continued)
  • "E6785D","GSM/GPRS_WCDMA LA rev D"
  • "E6785T","GSM/GPRS_WCDMA LA rev T"

Formats -

  • "E1968A-101","GSM TA"
  • "E1968A-102","GPRS TA"
  • "E1968A-103","EGPRS TA"
  • "E1968A-201","GSM/GPRS TA"
  • "E1968A-202","GSM/GPRS/EGPRS TA"
  • "E6590A-101","GSM/GPRS"
  • "E6590A-102","EGPRS"
  • "E6590A-103","RF Modem"

Features -

  • "E1962B-401","CDMA2000 RelA"
  • "E1962B-402","AMPS Enhancement"
  • "E1962B-403","CDMA2000 Authenticat"
  • "E1963A-401","WCDMA Video Call"
  • "E1963A-403","HSDPA Test Modes"
  • "E1966A-102","1xEV-DO RelA"
  • "E1968A-401","Fast Cal"
  • "E1968A-410","Phase & Ampl vs Time"
  • "E1999A-201","Fast Device Tune"
  • "E6706A-102","1xEV-DO Rel A ETAP"
  • "E6706T-102","1xEV-DO Rel A ETAP"

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:ALL?"

SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?

Function

Queries the number of applications, formats and features that are licensed for the test set. The applications, formats and features do not have to be installed in the test set to be included in the query result.

To query the names of the licensed applications, formats and features for the test set, see SYSTem:APPLication:CATalog:LICense:APPLication:ALL? .

Query

Range: 0 to 300

Resolution: 1

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?"

SYSTem:APPLication:CATalog:REVision?<sp>'<application name>'

Function

Queries the revisions stored on the test set for the specified application.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

This query returns a comma-separated list of double-quoted strings (one for each revision of the application).

Note, if you have several revisions of the application stored on the test set, you may need to increase your GPIB controller's timeout time to avoid a timeout condition.

To query the number of revisions stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>' .

To switch to a different revision of an application, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

 Range: Comma-separated list of 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01","A.02.01"

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:REVision? 'CDMA 2000 MOBILE TEST'"

SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>'

Function

Queries the number of revisions stored on the test set for the specified application.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

To query the revision numbers stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' .

Query

Range: 0 to 30

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:REVision:COUNt? 'CDMA 2000 MOBILE TEST'"

SYSTem:APPLication:FORMat[:NAME]

Function

Switches to the specified format (in the current application). Only fast switching applications include more than one format. To determine what formats are available in the current application, see SYSTem:APPLication:CATalog:FORMat? . To determine the license status of a format, see SYSTem:APPLication:FORMat:LICense?<sp>'<format name>' .

Queries the name of the currently active format in the current application.

Setting

Range: See SYSTem:APPLication:CATalog:FORMat?

Query

Range: same as setting

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:FORMat 'IS-2000/IS-95/AMPS'"

OUTPUT 714;"SYSTem:APPLication:FORMat?"

SYSTem:APPLication:FORMat:LICense?<sp>'<format name>'

Function

Queries the license status of the specified format in the current application.

The query must include a parameter for the format name enclosed by single quotes. For format names, see SYSTem:APPLication:CATalog:FORMat? . Note that the format name parameter is not case-sensitive.

Query

Range: LIC|NLIC|UNKN

  • "LIC" indicates this is a licensed format.
  • "NLIC" indicates this is not a licensed format.
  • "UNKN" indicates that the license status is unknown.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:FORMat:LICense? 'IS-2000/IS-95/AMPS'"

SYSTem:APPLication:SELect[:NAME]

Function

Switches to the specified application (this includes a reboot of the test set). To determine what applications are stored on the test set, see SYSTem:APPLication:CATalog[:NAME]? . The revision that is switched to is determined by SYSTem:APPLication:SELect:REVision . To determine the license status of the application/revision, see SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>' .

Queries the name of the application that will be loaded after the next reboot of the test set.

Setting

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Query

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect 'CDMA 2000 MOBILE TEST'"

OUTPUT 714;"SYSTem:APPLication:SELect?"

SYSTem:APPLication:SELect:REVision

Function

Sets the revision that will be loaded when the application is switched to using the SYSTem:APPLication:SELect[:NAME] command.

To determine what application is to be switched to, see SYSTem:APPLication:SELect[:NAME] . To determine what revisions are stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' . To determine the license status of a revision, see SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>' .

To query the revision that will be loaded when an application is switched to, see SYSTem:APPLication:SELect:REVision?<sp>'<application name>' .

NOTE
GSM Mobile Test revisions prior to A.04.00 did not have application switching and provide no way to return to revisions that have switching. If you switch to a GSM Mobile Test application revision prior to A.04.00, the only way to return to a newer revision is by downloading it using the process for upgrading firmware.

Setting

Range: see SYSTem:APPLication:CATalog[:NAME]? and SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' .

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect:REVision 'CDMA 2000 Mobile Test','B.06.30'"

SYSTem:APPLication:SELect:REVision?<sp>'<application name>'

Function

Queries the revision that will be loaded when the specified application is switched to using the SYSTem:APPLication:SELect[:NAME] command.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

To set the revision that will be loaded when the specified application is switched to, see SYSTem:APPLication:SELect:REVision .

NOTE
GSM Mobile Test revisions prior to A.04.00 did not have application switching and provide no way to return to revisions that have switching. If you switch to a GSM Mobile Test application revision prior to A.04.00, the only way to return to a newer revision is by downloading it using the process for upgrading firmware.

Query

 Range: 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01"

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect:REVision? `CDMA 2000 MOBILE TEST'"

Related Topics

Test Application Switching


SYSTem:AUDio

SYSTem:AUDio

Diagram Conventions

SYSTem:AUDio:OUTPut:SOURce

Function

Set/queries whether the audio generator signal or the FM demodulation signal is selected to be routed to the AUDIO OUT port of the test set's front panel.

When audio generator is selected for output at the front-panel AUDIO OUT port, use AFGenerator to control the audio generator.

NOTE
The selection of FM Demod signal is useful only in AMPS system. A bandpass filter, expander circuit, and deemphasis circuit can be individually inserted or bypassed in the FM Demod signal path. Use the command SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe to insert the bandpass filter. Use the command SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe to insert the expandor circuit. Use the command SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe to insert the deemphasis filter.

NOTE
There will be no guaranteed performance for the signal present at the Audio Out port when FM Demod is selected for output.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Setting

AFGenerator|FMDemod

Query

AFG|FMD

*RST Setting

AFG

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:SOURce FMDemod"

!Selects FM Demod signal for output at the front panel AUDIO OUT port.

SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe

Function

Sets/queries whether the fixed bandpass filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port (see SYSTem:AUDio:OUTPut:SOURce ).

When the state is ON, a 300 Hz to 3 KHz bandpass filter is inserted in the audio signal path. When the state is OFF, the bandpass filter is bypassed in the audio signal path

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting | Range: 0|OFF|1|ON

Query

Range: 0|1
*RST setting | 0 (OFF)

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe ON"

!Sets the bandpass filter state to ON.

SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe

Function

Sets/queries whether the expandor filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port (see SYSTem:AUDio:OUTPut:SOURce ).

When the state is ON, the expandor filter is inserted in the audio signal path. When the state is OFF, the expandor filter is bypassed in the audio signal path.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting | Range: 0|OFF|1|ON

Query

Range: 0|1
*RST setting | 0 (OFF)

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe ON" !Sets the expandor filter state to ON.

SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe

Function

Sets/queries whether the deemphasis filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port (see SYSTem:AUDio:OUTPut:SOURce ).

When the state is ON, the deemphasis filter is inserted in the audio signal path. When the state is OFF, the deemphasis filter is bypassed in the audio signal path.

Requirements

 Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above
Setting | Range: 0|OFF|1|ON

Query

Range: 0|1
*RST setting | 0 (OFF)

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe ON"

!Sets the deemphasis filter state to ON.


SYSTem:BEEPer

SYSTem:BEEPer

Diagram Conventions

SYSTem:BEEPer:STATe

Function

Sets/queries the beeper state of the test set.

Setting

0|OFF | 1|ON

Query

0|1

*RST Setting

1 (on)

Related Topics

Test Set Beeper

Programming Example

OUTPUT 714;"SYSTEM:BEEPER:STATE OFF" !Sets beeper state to off.


SYSTem:COMMunicate

SYSTem:COMMunicate

Diagram Conventions

SYSTem:COMMunicate:GPIB:[:SELF]:ADDRess

Function

 Sets/queries the test set's GPIB address.

Setting

Range: 0 to 30

Resolution: 1

Query

Range: 0 to 30

Resolution: 1

Factory setting

14 (this parameter is not affected by any reset operation and can only be changed by direct user access)

Related Topics

 Configuring the Test Set's GPIB

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:GPIB:SELF:ADDRESS 14" !Sets the GPIB address to 14.

SYSTem:COMMunicate:GPIB:DEBug[:STATe]

Function

Sets/queries the test set's SCPI debugger state.

When the state is on; enhanced error messages (displayed when GPIB commands with syntax errors are detected) will be displayed on the test set display. Also, all GPIB commands will be displayed in red characters at the bottom left area of the test set's display.

The error message is printed along with the syntax. <ERR> is displayed at the end of the incorrect node. Non-printable characters will be replaced with the $ symbol.

See Error Messages for a list of the errors.

The debugger state should be used only during GPIB code development. Test times may be longer than necessary if the debugger state is left on.

Setting

 Range: 0|OFF | 1|ON
Query 0|1

*RST setting

0|off

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:GPIB:DEBUG:STATE ON" !Sets the GPIB debugger state on.

SYSTem:COMMunicate:LAN[:SELF]:ADDRess

Function

Sets/queries the test set's LAN IP address. The value of A is used to determine the subnet mask, see SYSTem:COMMunicate:LAN[:SELF]:SMASk .

If the LAN address is changed the subnet mask should be checked to insure that it is set to the proper class for that LAN address.

Setting

Range: 15 characters formatted as follows: A.B.C.D. The range of values for A= 0 to 126 and 128 to 223. The range of values for B,C, D = 0 to 255 (no embedded spaces).

Query

Range: 15 characters formatted as follows: A.B.C.D. The range of values for A= 0 to 126 and 128 to 223. The range of values for B,C, D = 0 to 255 (no embedded spaces).

Factory setting

0.0.0.0 (this parameter is not affected by any reset operation and can only be changed by direct user access)

Related Topics

 Configuring the Test Set's LAN

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:ADDRESS '130.015.156.255'"
!Sets the LAN IP address.

SYSTem:COMMunicate:LAN[:SELF]:DGATeway

Function

Sets/queries the LAN IP router/gateway address for the test set.

Setting

Range: 15 characters formatted as follows: A.B.C.D where A= 0 to 223 B,C,D = 0 to 255 (no embedded spaces), blank field

Query

Range: 15 characters formatted as follows: A.B.C.D where A,B,C,D = 0 to 255 (no embedded spaces). blank field

Factory setting

blank field, (this parameter is not affected by any reset operation)

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:DGATEWAY '130.2.6.200'"

SYSTem:COMMunicate:LAN[:SELF]:SMASk

Function

Sets/queries the subnet mask of the test set based on the LAN IP address selected. The subnet mask changes according to the value of A used for the LAN IP address.

If A is less than 127, the default subnet mask is 255.0.0.0.

If A is greater than 127 and less or equal to 191, the default subnet mask is 222.255.0.0.

If A is grater than 191, the default subnet mask is 255.255.255.0.

If the LAN address is changed the default subnet mask should be checked to insure that it is set to the proper class for that LAN address.

Setting

Range: 15 characters formatted as follows: A.B.C.D where A,B,C,D are between = 0 to 255 (no embedded spaces)

Query

Range: 15 characters formatted as follows: A.B.C.D where A,B,C,D are between = 0 to 255 (no embedded spaces)

Factory setting

0.0.0.0 (this parameter is not affected by any reset operation and can only be changed by direct user access)

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:SMASK '255.2.6.200'"

SYSTem:COMMunicate:LAN:EXTernal:ADDRess

Function

Sets/queries the IP address of the Sync Sever for the synchronization. See Ext 8960 IP Addr .

Setting

Range: 15 characters formatted as follows: A.B.C.D where A,B,C,D are between = 0 to 255 (no embedded spaces)

Query

Range: same as setting.

Factory setting

0.0.0.0 (this parameter is not affected by any reset operation and can only be changed by direct user access)

Requirement

Lab Application revision: A.02 and above

Programming Example

OUTPUT 714;"SYSTem:COMMunicate:LAN:EXTernal:ADDRess '255.2.6.200'"

SYSTem:COMMunicate:LAN:EXTernal:SYNChronize

Function

Initiates the synchronization action. See Sync To External Server .

Requirement

Lab Application revision: A.02 and above

Programming Example

OUTPUT 714;"SYSTem:COMMunicate:LAN:EXTernal:SYNChronize"

SYSTem:COMMunicate:LAN:EXTernal:SYNChronize:INDication:CLEar

Function

Clear all of indications and annuciators associated with the synchronization. See Clear Sync Indications .

This action doesn't affect the current synchronization status between two test sets.

Requirement

Lab Application revision: A.02 and above

Programming Example

OUTPUT 714;"SYSTem:COMMunicate:LAN:EXTernal:SYNChronize:INDication:CLEar"

Related Topics

Configuring the Test Set's LAN


SYSTem:CONFigure

SYSTem:CONFigure

Last updated: November 4, 2004

Diagram Conventions

SYSTem:CONFigure:INFormation:HARDware:VERBose?

Function

Query the manufacturer, model number, model number of the test application running, serial number, revision, board ID, and cal file information. The information provided by the query represents the configuration that existed when the test set was powered up.

*RST Setting

Resets have no effect on this information. The information is gathered during the power up cycle.

Related topics

Hardware Configuration Report

Programming Example

OUTPUT 714;"SYSTEM:CONFIGURE:INFORMATION:HARDWARE:VERBOSE?" !Queries system hardware.


SYSTem:CORRection

SYSTem:CORRection

November 4, 2004

Diagram Conventions

SYSTem:CORRection:[:SGAin]

Function

Sets/queries up to 20 comma-separated amplitude offset values in dB. This command sets the state to On.

See Amplitude Offset .

The units, dB, are optional. If no units are specified then units default to dB.

Sending a null list (no values) sets the state of all offsets to Off.

Setting

Range: 0 to 20 values between -100 to +100

Resolution: 0.01

Query

Range: 1 to 20 values between -100 to +100, and NAN (9.91E+37)

Resolution: 0.01

Factory Setting

Offsets 1 through 20, are set to 0.00 dB, state is set to Off

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:SGAIN -2.55,-3.12,-3.68,-4.23,-4.74,-5.3"
!A complex command that sets up to 20 comma separated offsets
!and sets the state to On for the frequencies, offsets and
!RF IN/OUT Amplitude Offset State

OUTPUT 714;"SYSTEM:CORRECTION:SGAIN"
!Sets the state for all frequencies and offsets to Off

SYSTem:CORRection:FREQuency

Function

Sets/queries up to 20 comma-separated frequency values in MHz. Each frequency value corresponds with a gain setting. See SYSTem:CORRection:GAIN .

The units, (GHz, MHz, kHz, Hz) are optional. If no units are specified, units default to Hz.

See Amplitude Offset .

Sending a null list (no values) sets the state of all frequencies to Off.

Setting

Range: 0 to 20 comma separated values ranging from 292.5 MHz to 2700 MHz

Resolution: 1 Hz

Query

Range: 1 to 20 comma separated values ranging from 292.5 MHz to 2700 MHz, and NAN (9.91E+37)

Resolution: 1 HZ

Factory Setting
  1. 800.00 MHz Off
  2. 810.00 MHz Off
  3. 820.00 MHz Off
  4. 830.00 MHz Off
  5. 840.00 MHz Off
  6. 850.00 MHz Off
  7. 860.00 MHz Off
  8. 870.00 MHz Off
  9. 880.00 MHz Off
  10. 890.00 MHz Off
  11. 900.00 MHz Off
  12. 910.00 MHz Off
  13. 920.00 MHz Off
  14. 930.00 MHz Off
  15. 940.00 MHz Off
  16. 950.00 MHz Off
  17. 960.00 MHz Off
  18. 970.00 MHz Off
  19. 980.00 MHz Off
  20. 990.00 MHz Off

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:FREQUENCY 1784.8 MHZ,1879.8 MHZ"
!Sets up to 20 comma separated frequencies

OUTPUT 714;"SYSTEM:CORRECTION:FREQUENCY"
!Sets the state for all frequencies and offsets to Off

SYSTem:CORRection:GAIN

Function

Sets/queries the up to 20 comma separated offset gain values in units of dB. Each gain value corresponds with a frequency setting. See SYSTem:CORRection:FREQuency .

See Amplitude Offset .

The units, dB, are optional. If no units are specified, units default to dB.

Sending a null list (no values) sets the state of all offsets to Off.

Setting

Range: 0 to 20 values between -100 to +100

Resolution: 0.01

Query

Range: 1 to 20 values between -100 to +100, and NAN (9.91E+37)

Resolution: 0.01

Factory Setting

Offsets 1 through 20, are set to 0.00 dB, state is set to off

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:GAIN -3.12,-3.68,-4.23"
!Sets up to 20 comma separated offset values.

OUTPUT 714;"SYSTEM:CORRECTION:GAIN"
!Sets the state for all frequencies and offsets to Off.

SYSTem:CORRection:POINts

Function

Query returns the number of offsets that are in their On state when the RF IN/OUT Amplitude Offset State is also set to On.

See Amplitude Offset .

Query

Range: 1 to 20, and NAN (9.91E+37)

Resolution: 1

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:POINTS?"

!Returns the number of frequencies and offsets with their state set to On.

SYSTem:CORRection:SFRequency

Function

Sets/queries up to 20 comma separated frequency values in MHz. This command sets the state to On.

The units (GHz, MHz, kHz, Hz) are optional. If no units are specified, units default to MHz.

See Amplitude Offset .

Sending a null list (no values) sets the state of all frequencies to Off.

Setting

Range: 0 to 20 comma separated values from 292.5 MHz to 2700 MHz

Resolution: 1 Hz

Query

Range: 1 to 20 comma separated values from 292.5 MHz to 2700 MHz, and NAN (9.91E+37)

Resolution: 1 HZ

Factory Setting
  1. 800.00 MHz Off
  2. 810.00 MHz Off
  3. 820.00 MHz Off
  4. 830.00 MHz Off
  5. 840.00 MHz Off
  6. 850.00 MHz Off
  7. 860.00 MHz Off
  8. 870.00 MHz Off
  9. 880.00 MHz Off
  10. 890.00 MHz Off
  11. 900.00 MHz Off
  12. 910.00 MHz Off
  13. 920.00 MHz Off
  14. 930.00 MHz Off
  15. 940.00 MHz Off
  16. 950.00 MHz Off
  17. 960.00 MHz Off
  18. 970.00 MHz Off
  19. 980.00 MHz Off
  20. 990.00 MHz Off

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:SFREQUENCY 1710.2 MHZ,1805.2 MHZ,1784.8 MHZ,1879.8 MHZ"
!Sets up to 20 comma separated frequencies and sets the state to On for the frequency,
!offset, and RF IN/OUT Amplitude Offset State

OUTPUT 714;"SYSTEM:CORRECTION:SFREQUENCY"
!Sets the state for all frequencies and offsets to Off

SYSTem:CORRection:STATe

Function

Sets/queries the RF IN/OUT Amplitude Offset State. The state must be On before any of the offsets are active regardless of the state for any of the frequencies or offsets.

When the RF IN/OUT Amplitude Offset State is On, the Instrument Status Area will indicate "Offset" regardless of the state for any of the frequencies or offsets.

Setting any of the frequency or offset states to On will set the RF IN/OUT Amplitude Offset State to On.

See Amplitude Offset .

Setting

0|OFF | 1|ON

Query

0|1

Factory Setting

0 (off)

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:STATE ON" !Sets the RF IN/OUT
                                        !Amplitude Offset State to On


SYSTem:CURRent:TA

SYSTem:CURRent:TA

Last updated: November 4, 2004

Diagram Conventions

SYSTem:CURRent:TA:MODel?

Function | Queries the model number of the test application running. Printable ASCII characters up to a 15 character string.
Query | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting | non volatile, read from the test set's hard disk

SYSTem:CURRent:TA:NAME?

Function | Queries the name of the test application running. Printable ASCII characters up to a 25 character string. This command is not recommended see SYSTem:APPLication[:CURRent][:NAME]? .
Query | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting | non volatile, read from the test set's hard disk

SYSTem:CURRent:TA:REVision?

Function | Queries the coordinated codeware revision for the test application running. Printable ASCII characters up to a 20 character string. This command is not recommended see SYSTem:APPLication[:CURRent]:REVision? .
Query | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting | non volatile, read from the test set's hard disk.


SYSTem:DATE

SYSTem:DATE

Last udpated: August 9, 2005

Diagram Conventions

SYSTem:DATE

Function

Sets/queries the date.

Setting

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

Query

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

*RST Setting

 This feature is not affected by instrument preset

Requirements

 Test Application Revision: B.03.00 and above

Programming Example

OUTPUT 714;"SYSTEM:DATE 2001,9,27" !Sets the date to September 27,2001.

OUTPUT 714;"SYSTEM:DATE? !Returns "+2001,+9,+27" if the date has been set to September 27,2001.


SYSTem Subsystem

SYSTem Subsystem

Last updated: July 28, 2006

Description

The SYSTem subsystem collects the functions that are not related to test set performance. Examples include functions for performing general housekeeping and functions related to setting global configurations, such as TIME or CORRection (amplitude offset).

Syntax Diagrams and Command Descriptions

SYSTem:APPLication
SYSTem:AUDio
SYSTem:BEEPer
SYSTem:COMMunicate
SYSTem:CONFigure
SYSTem:CORRection
SYSTem:CURRent:TA
SYSTem:DATE
SYSTem:ERRor?
SYSTem:FATal
SYSTem:INSTrument
SYSTem:MEASurement:RESet
SYSTem:PRESet
SYSTem:REGister
SYSTem:ROSCillator
SYSTem:SYNChronized
SYSTem:STATus ( Lab Application Only )
SYSTem:TIME


SYSTem:ERRor?

SYSTem:ERRor?

Last updated: December 19, 2005

Diagram Conventions

SYSTem:ERRor?

Function

Queries the contents of the error/event queue. The error/event queue may contain one or more messages with an error or event description. See Error Messages .

Manual users may view the message log from the SYSTEM CONFIG screen. See Error Message Log .

The contents of the error/event queue and the message log may not match. For example, manual user errors (see Manual User Error Messages ) are not returned with SYSTem:ERRor? query command. They are viewed from the message log.
Query

Error/Event Queue

  • Range: 0 to 100 messages up to 255 characters in length

Programming Example

OUTPUT 714;"SYSTEM:ERROR?" !Query the contents of the Error/Event Queue


SYSTem:FATal

SYSTem:FATal

Last updated: November 19, 2005

Diagram Conventions

SYSTem:FATal:ERRor:RESTart

Function

This command sets/queries the state of the Restart on Fatal Error parameter. See Restart on Fatal Error for more information.

Error messages that are created when a fatal error occurs are entered in the error/event queue that can be queried with the command SYSTem:ERRor? .

This is a nonvolatile setting, that is the instrument does not require a power supply to retain the setting its memory.

Requirements

Test Application Revision: A.05 and above
Lab Application Revision: A.01 and above

Setting

Range: ON|1|OFF|0

Query

Range: 1|0

*RST Setting

 0 (off)

Programming Example

OUTPUT 714;"SYSTem:FATal:ERRor:RESTart ON"
!Commands the instrument to restart if a fatal error occurs.


SYSTem:INSTrument

SYSTem:INSTrument

Last updated: July 28, 2006

Diagram Conventions

SYSTem:INSTrument:THERmal:POWer:NULL:ADJust?

Function

Starts the Thermal Power Null Adjustment .

IMPORTANT
Ensure that your test set has warmed up at least 30 minutes and that no power is present at the front panel RF connectors before performing any calibrations.

When this adjustment has completed, a value is returned to indicate the success or failure of the adjustment. 0 indicates the adjustment completed successfully, 1 indicates that it failed.

Query

 Range: 0 (success), 1 (failure)

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SYSTem:INSTrument:THERmal:POWer:NULL:ADJust?"
! Starts the Thermal Power Null Adjustment and returns a value indicating success or failure.


SYSTem:MEASurement:RESet

SYSTem:MEASurement:RESet

December 12, 2002

Diagram Conventions

SYSTem:MEASurement:RESet

Function | Aborts all measurements. If continous triggering is enabled, measurements will begin a new measurement cycle.
Setting | Measurement results are set to their default values when measurement reset occurs.


SYSTem:PRESet

SYSTem:PRESet

December 12, 2002

Diagram Conventions

SYSTem:PRESet[1] (not recommended for use)

Function

Not recommended for use at this time. See SYSTem:PRESet3 for a recommended partial preset.

Performs a partial preset. This command is intended to be used when changing from remote operation to manual operation and a partial preset is needed.

Any call in process is disconnected and all measurements are aborted and inactivated. Measurement parameters are not changed.

A partial preset will not modify any measurement settings including trigger arm. See Trigger Arm (Single or Continuous) Description .
Related Topics

See Partial Preset for more details

Programming Example

OUTPUT 714;"SYSTem:PRESet" !Partial preset when changing from remote to manual operation.

SYSTem:PRESet2

Function

Performs a full preset of the test set. This is the remote equivalent of pressing the SHIFT Preset keys on the front panel of the test set.

All parameters are set to their default values. All measurements are aborted the trigger arm is set to continuous. See Trigger Arm (Single or Continuous) Description .

The *RST command will set the trigger arm to single.
Related Topics See Full Preset for details about the *RST full preset.

Programming Example

OUTPUT 714;"SYSTem:PRESet2" !Full preset, trigger arm set to continuous.

SYSTem:PRESet3

Function

Performs a partial preset. This is the recommended command for users when a partial preset is needed during remote operation of the test set.

Any call in process is disconnected and all measurements are aborted and inactivated. Measurement parameters are not changed.

A partial preset will not modify any measurement settings including trigger arm.

Related Topics

See Partial Preset for more details.

Programming Example

OUTPUT 714;"SYSTem:PRESet3" !Partial preset when in remote operation.


SYSTem:REGister

SYSTem:REGister

Last updated: November 18, 2003

Diagram Conventions

SYSTem:REGister:SAVe

Function

Saves the current test set settings to one of five available registers.

If this command is used to save to a register that is already full, the old contents of the register will be overwritten.

Setting

1|2|3|4|5

Query

No query

*RST Setting

 Not applicable

Requirements

Test Application Revision: A.01.20 or above

Programming Example

OUTPUT 714;"SYSTem:REGister:SAVe 1" !Saves the current test set configuration to save register 1.

SYSTem:REGister:RECall

Function

Recalls a saved register from one of five registers.

If this command is used to recall a register that is empty, an error message will be displayed.

Setting

1|2|3|4|5

Query

No query

*RST Setting

 Not applicable

Requirements

Test Application Revision: A.01.20 or above

Programming Example

OUTPUT 714;"SYSTem:REGister:RECall 1" !Recalls register 1.

SYSTem:REGister:DELete

Function

Deletes any contents saved in the selected register.

Setting

1|2|3|4|5

Query

No query

*RST Setting

 Not applicable

Requirements

Test Application Revision: A.01.20 or above

Programming Example

OUTPUT 714;"SYSTem:REGister:DELete 1" !Deletes register 1.

Related Topics

Save and Recall Registers


SYSTem:ROSCillator

SYSTem:ROSCillator

December 12, 2002

Diagram Conventions

SYSTem:ROSCillator[:TIMebase]?

Function

Queries the timebase source.

If an external timebase is used, it must have these characteritics:

  • an output level of 0 to +13 dBm

  • frequency of 10 MHz

Query

Range:

INT = internal source

EXT = external source

SYSTem:ROSCillator:LOCKed?

Function | Queries the timebase to find out if it is locked or unlocked. Returns 0 or 1.
Query | Range: 0 = unlocked 1 = locked


SYSTem:SYNChronized

SYSTem:SYNChronized

December 12, 2002

Diagram Conventions

SYSTem:SYNChronized

Function | Sets/queries the test set to see that all prior sequential commands have completed or that all prior overlapped commands have started, indicating that the input buffer is synchronized.
Setting | Bit 12 of the status operation condition register is pulsed.
Query | Range: 1


SYSTem:TIME

SYSTem:TIME

Last updated: November 18, 2003

Diagram Conventions

SYSTem:TIME

Function

Sets/queries the local time of day.

UTC time will track changes made directly to local time settings. Also, if new settings are made to UTC time, local time will track UCT time.

Changes to time zone will cause changes to local time, but will not directly affect UTC time.

Setting

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59
Note

The resolution of local time setting is minutes. A number within the parameter range must be entered for <second> but it will not affect the minute setting.

Note

Query

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59
Note

The resolution of the local time setting is minutes. The value returned for <second> will not provide useful information.

Note

*RST Setting

 This feature is not affected by instrument preset

Requirements

 Test Application Revision: B.03.00 and above

Programming Example

OUTPUT 714;"SYSTEM:TIME 7,30,0" !Sets local time to 7:30

OUTPUT 714;"SYSTEM:TIME?" !Returns "+7,+30,+0" if local time has been set to 7:30.

Related Topics

SYSTem:UTC[:TIME]


SYSTem:TZONe

SYSTem:TZONe

Last updated: November 18, 2003

Diagram Conventions

SYSTem:TZONe

Function

Sets/queries the time zone.

Changes to time zone will cause changes to local time, but will not directly affect UTC time.

Setting

Range:

  • <hour> -12 to +15
  • <minute> 0 to 59

Query

Range:

  • <hour> -12 to +15
  • <minute> 0 to 59

*RST Setting

 This feature is not affected by instrument preset

Requirements

 Test Application Revision: B.03.00 and above

Programming Example

OUTPUT 714;"SYSTEM:TZONe 8,0" !Sets time zone to 8 hours and 0 minutes.

OUTPUT 714;"SYSTEM:TZONe?" !Returns "+8,+0" if time zone has been set to 8 hours.

Related Topics

SYSTem:TIME


SYSTem:UTC

SYSTem:UTC

Last updated: April 15, 2005

Diagram Conventions

SYSTem:UTC[:TIME]

Function

Sets/queries the Universal Coordinated Time (UTC) time of day. (UTC is also known as UCT, Zulu, and Greenwich Mean Time.)

Local time will track UTC time settings. Also, if new settings are made to local time, UTC time will track local time.

Setting

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

NOTE
The resolution of the UTC time setting is minutes. A number within the parameter range must be entered for <second> but it will not affect the minute setting.

Query

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

  • The resolution of the UTC time setting is minutes. The value returned for <second> will not provide useful information.

*RST Setting

 This feature is not affected by instrument preset

Requirements

Test Application Revision: A.01.20 and above
Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTEM:UTC:TIME 7,30,0" !Sets UCT time to 7:30

OUTPUT 714;"SYSTEM:UTC:TIME?" !Returns "+7,+30,+0" if UTC time has been set to 7:30.

SYSTem:UTC:DATE

Function

Sets/queries the Universal Coordinated Time (UTC) date. (UTC is also known as UCT, Zulu, and Greenwich Mean Time.)

Setting

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

Query

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

*RST Setting

 This feature is not affected by instrument preset

Requirements

 Test Application Revision: B.03.00 and above

Programming Example

OUTPUT 714;"SYSTEM:UTC:DATE 2001,9,27" !Sets the UTC date to September 27,2001.

OUTPUT 714;"SYSTEM:UTC:DATE? !Returns "+2001,+9,+27" if the UTC date has been set to September 27,2001.

Related Topics

SYSTem:DATE


Performing Specific Measurements and C.S0033 Tests Manually

Performing Specific Measurements and C.S0033 Tests Manually

  • Measuring Access Probe Power
    • Testing 4.3.1 Range of Open Loop Output Power
  • Measuring Channel Power
    • Testing 4.3.5 Minimum Controlled Output Power
  • Measuring Digital Average Power
    • Testing 4.3.4 Maximum RF Output Power
  • Measuring Graphical Access Probe Power ( Lab Application Only )
    • Testing 4.3.1 Range of Open Loop Output Power
  • Measuring Packet Error Rate (PER)
    • Testing 3.2.1 Demodulation of Forward Traffic Channel in AWGN
    • Testing 3.2.2 Demodulation of Forward Traffic Channel in Multipath Fading Channel (Lab Application Only)
    • Testing 3.3.1 Receiver Sensitivity and Dynamic Range
  • Measuring Time Response of Open Loop Power Control (TROLPC)
    • Testing 4.3.2 Time Response of Open Loop Power Control
  • Measuring TX Dynamic Power
  • Measuring TX Spurious Emissions
    • Testing 4.4.1 Conducted Spurious Emissions
  • Measuring Waveform Quality + Code Domain Power
    • Testing 4.2.2 Waveform Quality and Frequency Accuracy


3.2.1 Demodulation of Forward Traffic Channel in AWGN

3.2.1 Demodulation of Forward Traffic Channel in AWGN

Last updated: June 16, 2006

Definition

Demodulation of Forward Traffic Channel in AWGN is the most important receiver test, for it tests the raw decoder ability of the baseband ASIC and the IF bandwidth of the access terminal (AT). This test evaluates how well the AT demodulates the Forward Traffic Channel in the presence of noise (how well it extracts the desired signal from the noise). The AWGN source simulates the interference power coming from surrounding cells when the AT is operating in a fully loaded network environment. The figure of merit is Packet Error Rate (PER).

Method of Measurement

  1. Connect the access network emulator and AWGN to the AT.
  2. Set the AN forward packet activity to 100%.
  3. Set the Control Channel data rate to 38.4 kbps (because the default power level for 38.4 kbps Control Channel is high enough to overcome the large AWGN power required for these tests).
  4. Set Pilot Drop to -14 dB (to prevent the access terminal from generating Pilot Strength Measurement Reports due to the low Pilot Channel to AWGN ratio).
  5. Set Î or to -55 dBm/1.23 MHz
  6. Set up a Test Application session and open an FTAP connection (for Subtype 0 or 1 Physical Layer).
  7. Perform tests 1 - 18 which evaluate the AT's performance at all Forward Traffic Channel data rates (38.4 to 2,457.6 kbps) that are supported by Subtype 0 or 1 Physical Layer for varying E b /N t . Set I oc as specified for each test.
  8. If your AT supports Subtype 2 Physical Layer, set Pilot Drop to -16 dB. Set up a Test Application session and open an FETAP connection (for Subtype 2 Physical Layer).
  9. Perform tests 19 - 30 which evaluate the AT's performance at Forward Traffic Channel data rates and transmission formats (such as short packets) that are only supported by Subtype 2 Physical Layer for varying E b /N t . Set I oc as specified for each test.
  10. Calculate PER for each test.

Minimum Standard

PER shall not exceed 0.5% to 5% with 95% confidence (depending upon data rate and E b /N t ).

NOTE
The following known Issues for 3.2.1 tests in C.S0033-A V1.0 will be fixed in next standard release:

  • In Table A.1.1.1-8, the Data Rates for tests 23 and 24 are incorrect and should be 38.4 kbps.
  • The Î or /I oc for test 29 should be 23.44 dB resulting in a constant Î or value -55 dBm/1.23 MHz as for all other tests (1-28, and 30).

Related Topics

Manual Operation: Testing 3.2.1 Demodulation of Forward Traffic Channel in AWGN


3.3.1 Receiver Sensitivity and Dynamic Range

3.3.1 Receiver Sensitivity and Dynamic Range

Definition

Receiver Sensitivity: This test evaluates how well the access terminal (AT) demodulates a very low level Forward Traffic Channel signal. This simulates the AT in very poor propagation conditions, typically far from an access network sector or cell, where it would request a low data rate.

Dynamic Range: This test evaluates how well the access terminal (AT) demodulates a very high level Forward Traffic Channel signal (tests whether it gets overloaded). This simulates the AT in very good propagation conditions, typically very near an access network, where it would request a high data rate.

The figure of merit for each test is Packet Error Rate (PER).

Method of Measurement

  1. Connect the access network emulator to the AT.
  2. Set up a Test Application session and open an FTAP (for Subtype 0 or 1 Physical Layer) or FETAP (for Subtype 2 Physical Layer) connection.
  3. Receiver Sensitivity (test 1): Set the Forward Traffic Channel rate to 307.2 kbps (2 slot) and Î or to -105.5 dBm/1.23 MHz.
  4. Dynamic Range (tests 2-3): Set the Î or to -25 dBm/1.23 MHz and the Forward Traffic Channel rate to 307.2 kbps (2 slot) for test 2 and 2,457.6 kbps (1 slot) for test 3.
  5. Calculate PER for each test.

Minimum Standard

PER shall be less than or equal to 0.5% with 95% confidence.

Related Topics

Manual Operation: Testing 3.3.1 Receiver Sensitivity and Dynamic Range


4.2.2 Waveform Quality and Frequency Accuracy

4.2.2 Waveform Quality and Frequency Accuracy

Definition

Waveform quality is the basic measure of the performance of a CDMA transmitter. The figure of merit for waveform quality is rho. Rho, also called the power correlation coefficient, is the percentage of transmitted power that correlates to the ideal code. Rho provides a measure of how well the signal's power distribution matches the ideal power distribution. A value of 1.00 indicates that all of the transmitted power correlates with the ideal transmission code.

Several measurement results are returned when a rho measurement is performed, including frequency error and transmit time error. Frequency error is a measure of how accurately the access terminal is transmitting at its assigned frequency. Transmit time error indicates how accurately the AT has aligned its timing to the access network's pilot in static conditions.

This test measures rho, and also encompasses the 4.1.2 Frequency Accuracy and 4.2.1 Time Reference (static only) tests.

Method of Measurement

  1. Connect the access network emulator to the AT.
  2. Set up a Test Application session. For Subtype 0 or 1 Physical Layer, open an RTAP connection and configure the Reverse Data Channel rate to 9.6 kbps. For Subtype 2 Physical Layer, open an RETAP connection and configure the Reverse Data Channel payload size to 256 bits with Termination Target of 16 slots.
  3. Configure the Test Application FTAP (for Subtype 0 or 1 Physical Layer) or FETAP (for Subtype 2 Physical Layer) so that the ACK Channel is transmitted at all the slots. (It is necessary for the access terminal to transmit the R-ACK Channel to determine modulation quality of its complete signal.) In order for the R-ACK Channel to be active in all slots, you must set ACK Channel Bit Fixed Mode Attribute to on.
  4. Set Î or to -75 dBm/1.23 MHz.
  5. Measure rho, frequency error and transmit time error.

Minimum Standard

Rho shall be >0.944.

Frequency error shall be within +/- 300 Hz for band classes 0, 2, 3, 5, 7, 9 and 10, 11, 12 and within +/- 150 Hz for band classes 1, 4, 6 and 8.

Static transmit time error shall be within +/- 1 ms.

Related Topics

Manual Operation: Testing 4.2.2 Waveform Quality and Frequency Accuracy


4.3.1 Range of Open Loop Output Power

4.3.1 Range of Open Loop Output Power

Definition

This test verifies that the access terminal transmits at the proper power level determined by the open loop output equation. It is important that the AT transmit at the proper power level without the assistance of closed loop power control adjustments so that it can acquire a traffic channel successfully.

Method of Measurement

  1. Connect the access network emulator to the AT.
  2. Set Probe Sequence Max to 1 sequence (via Default Access Channel MAC Protocol).
  3. Set Preamble Length to 7 frames.
  4. Set Open Loop Adjust to -78 dB or -81 dB, depending upon band class.
  5. Set the AN forward packet activity to 100%.
  6. There are 3 tests which evaluate the AT's performance for Î or at high, medium and low levels:
    • Test 1: Î or = -25 dBm/1.23 MHz
    • Test 2: Î or = -65 dBm/1.23 MHz
    • Test 3: Î or is set to a level between -103 and -81 dBm/1.23 MHz, depending upon band class and access terminal class.
  7. Set the access network to ignore all access attempts.
  8. Send a page to the access terminal.
  9. Measure the output power of the access terminal during transmission of a probe (this assumes probe Power Step is set to 0 dB and all probes will be at the initial probe power level, so measuring any one will suffice).
  10. Repeat all tests with a forward packet activity of 0%. (This verifies the AT is able to transmit at the proper open loop power level when the forward channel is bursted.)

Minimum Standard

The access terminal output power shall be within +/- 9.5 dB of the correct level (this includes 0.5 dB allowance for test equipment uncertainties). A Probe Initial Adjust of 0 dB is assumed in calculating the correct level.

Related Topics

Manual Operation: Testing 4.3.1 Range of Open Loop Output Power

Programming an Access Probe Power Measurement

Access Probe Power Measurement Description

Access Probe Power Troubleshooting

Test Adherence to Standards

Lab Application Only :

  • Manual Operation: Measuring Graphical Access Probe Power


4.3.2 Time Response of Open Loop Power Control

4.3.2 Time Response of Open Loop Power Control

Definition

Following a step change in the mean input power, the mean output power of the access terminal changes as a result of the open loop power control. This test measures the open loop power control time response to a step change in the mean input power.

Method of Measurement

  1. Connect the access network emulator to the AT.
  2. Set up a Test Application session. For Subtype 0 or 1 Physical Layer, open an RTAP connection and configure the Reverse Data Channel rate to 9.6 kbps. For Subtype 2 Physical Layer, open an RETAP connection and configure the Reverse Data Channel payload size to 256 bits with Termination Target of 16 slots.
  3. Configure the Test Application FTAP (for Subtype 0 or 1 Physical Layer) or FETAP (for Subtype 2 Physical Layer) so that the ACK Channel Bit Fixed mode is disabled.
  4. Set the frame activity factor for the access terminal under test to zero by setting the access network to send all packets to one or more alternate access terminals.
  5. Set Î or to -60 dBm/1.23 MHz.
  6. Send alternating `0' and `1' power control bits on the Forward Traffic Channel.
  7. Change Î or by +20 dB, -20 dB, -20 dB, and +20 dB and measure the transmitted output power as a function of time after each step change for 100 ms.

Minimum Standard

The mean output power of the access terminal shall transition to its final value in a direction opposite in sign to the change in Î or , with a magnitude contained between the mask limits as pictured below:

Simplified Mask Limit Equations

For an Î or step change of 20 dB, the mask limit equations can be simplified and are as follows:

The upper pass/fail limit line is made up of three line segments. In the following formulas, p is mobile station power delta, in dB, and t is equal to time in milliseconds.

Upper limit line segment 1:

Upper limit line segment 2:

Upper limit line segment 3:

The lower pass/fail limit line is made up of one line segment and a curve. In the following formulas, let t 1 equal:

Calculating the value of t 1 (in ms):

Lower limit line segment 1:

Lower limit line segment 2:

Related Topics

Manual Operation: Testing 4.3.2 Time Response of Open Loop Power Control


4.3.4 Maximum RF Output Power

4.3.4 Maximum RF Output Power

Definition

This test measures the maximum power that the access terminal transmits as measured at the access terminal antenna connector.

Method of Measurement

  1. Set Open Loop Adjust to -81 dB or -84 dB, depending upon band class.
  2. Set Probe Initial Adjust to 15 dB.
  3. Set Power Step to 7.5 dB/step.
  4. Connect the access network emulator to the AT.
  5. Set up a Test Application session. For Subtype 0 or 1 Physical Layer, open an RTAP connection and configure the Reverse Data Channel rate to 153.6 kbps. For Subtype 2 Physical Layer, open an RETAP connection and configure the Reverse Data Channel payload size to 4096 bits with Termination Target of 16 slots.
  6. Configure the Test Application FTAP (for Subtype 0 or 1 Physical Layer) or FETAP (for Subtype 2 Physical Layer) so that the Forward Traffic Channel data rate corresponds to 307.2 kbps (2-slot version), and the ACK Channel is transmitted at all the slots. (It is necessary for the access terminal to transmit the R-ACK Channel to provide its maximum output power.)
  7. Set Î or to -60 dBm/1.23 MHz.
  8. Transmit continuous '0' (up) power control bits.
  9. Measure the access terminal power.

Minimum Standard

The mean output power of the access terminal shall be within the specified limits (the limits range between -22 dBW and 10 dBW, depending upon band class and access terminal class).

Related Topics

Manual Operation: Testing 4.3.4 Maximum RF Output Power


4.3.5 Minimum Controlled Output Power

4.3.5 Minimum Controlled Output Power

Definition

The minimum controlled output power of the access terminal is the output power, measured at the access terminal antenna connector, when both closed loop and open loop power control indicate minimum output.

Method of Measurement

  1. Connect the access network emulator to the AT.
  2. Set up a Test Application session. For Subtype 0 or 1 Physical Layer, open an RTAP connection and configure the Reverse Data Channel rate to 9.6 kbps. For Subtype 2 Physical Layer, open an RETAP connection and configure the Reverse Data Channel payload size to 256 bits with Termination Target of 16 slots.
  3. Set Î or to -25 dBm/1.23 MHz.
  4. Transmit continuous '1' (down) power control bits.
  5. Measure the access terminal power.

Minimum Standard

The mean output power of the access terminal shall be less than -50 dBm/1.23 MHz centered at the CDMA Channel frequency.

Related Topics

Manual Operation: Testing 4.3.5 Minimum Controlled Output Power


4.3.7 RRI Channel Output Power

4.3.7 RRI Channel Output Power

Last updated: June 16, 2006

Definition

For access terminals supporting Subtype 0 or Subtype 1 Physical Layer, the RRI Channel is transmitted over the first 256 chips of every slot during a connection. The RRI Channel punctures the Pilot Channel and both channels are transmitted at the same power level. For access terminals supporting Subtype 2 Physical Layer, the RRI Channel is transmitted throughout the whole slot at a different code channel from the Pilot Channel at a power level RRIChannelGain relative to the Pilot Channel power level.

This test verifies that the RRI Channel is transmitted at the same power level as the Pilot Channel for access terminals supporting Subtype 0 or Subtype 1 Physical Layer or that the RRI Channel is transmitted at a power level of RRIChannelGain relative to the Pilot Channel power level.

Test 1 is applicable only to access terminals that support Subtype 0 or Subtype 1 Physical Layer. Test 2 is applicable only to access terminals that support Subtype 2 Physical Layer.

Method of Measurement

  1. Connect the access network emulator to the AT.
  2. Set up a Test Application session and open an RTAP connection (for Subtype 0 or 1 Physical Layer).
  3. Set Î or to -75 dBm/1.23 MHz.
  4. Test 1: Measure Delta RRI/Pilot .
  5. Test 2: Set up a Test Application session and open an RETAP connection (for Subtype 2 Physical Layer).
  6. Configure the Test Application RETAP so that the Reverse Link Data Channel is transmitted at the 256-bit payload. The Transmission Mode is High Capacity with HiCapT2PTransition256 set to 0x3 (4 sub-frames) and HiCapTerminationTarget256 set to 0x3 (4 sub-frames).
  7. Set the RRIChannelPowerParameters Attribute of the Subtype 3 Reverse Traffic Channel MAC Protocol with RRIChannelGainPreTransition3 set to 0xA (-6 dB).
  8. Measure the power of the Pilot and RRI Channels.

Minimum Standard

Test 1: 10 log 10 (Delta RRI/Pilot ) shall be within +/- 0.25 dB.

Test 2: the difference of 10 log 10 (Power RRI /Power Pilot ) and RRIChannelGain (dB) shall be between -0.25 and +0.25 dB. (The current standard is wrongly to say between -6.25 and -5.75 dB which will be fixed soon in the next release)

Related Topics

Manual Operation: Testing 4.3.7 RRI Channel Output Power


4.3.8 Code Domain Power

4.3.8 Code Domain Power

The code domain power is a measure of the power in each code channel of a CDMA Channel. The time reference used in the code domain power test is derived from the Reverse Channel overall waveform and is used as the reference for demodulation of all the code channels. For details on the reverse code channels, see Reverse Channel Overview .

  • 4.3.8.1 DRC Channel Output Power
  • 4.3.8.2 ACK Channel Output Power
  • 4.3.8.3 Data Channel Output Power
  • 4.3.8.4 DSC Channel Output Power

4.3.8.1 DRC Channel Output Power

Definition

The DRC Channel is transmitted at a power level DRCChannelGain relative to the Pilot/RRI Channel power level. This test verifies the output power of the DRC Channel relative to that of the Pilot Channel.

Method of Measurement

  1. Connect the access network emulator to the AT.
  2. Set DRCChannelGain to 0 dB.
  3. Set up a Test Application session and open an RTAP (for Subtype 0 or 1 Physical Layer) or an RETAP (for Subtype 2 Physical Layer) connection.
  4. Configure the Test Application FTAP (for Subtype 0 or 1 Physical Layer) or FETAP (for Subtype 2 Physical Layer) so that the ACK Channel is transmitted at all the slots. (In order for the R-ACK Channel to be active in all slots, you must set ACK Channel Bit Fixed Mode Attribute to on.)
  5. Set Î or to -75 dBm/1.23 MHz.
  6. Measure the power of the Pilot and DRC Channels.
  7. Repeat for DRCChannelGain set to 3 dB.

Minimum Standard

10 log 10 (Power DRC /Power Pilot ) shall be within DRCChannelGain (dB) +/- 0.25 dB.

4.3.8.2 ACK Channel Output Power

Definition

When transmitted, the ACK Channel is transmitted at a power level ACKChannelGain relative to the Pilot/RRI Channel power level. This test verifies the output power of the ACK Channel relative to that of the Pilot Channel.

Method of Measurement

  1. Connect the access network emulator to the AT.
  2. Set ACKChannelGain to 0 dB.
  3. Set up a Test Application session and open an RTAP (for Subtype 0 or 1 Physical Layer) or an RETAP (for Subtype 2 Physical Layer) connection.
  4. Configure the Test Application FTAP (for Subtype 0 or 1 Physical Layer) or FETAP (for Subtype 2 Physical Layer) so that the ACK Channel is transmitted at all the slots. (In order for the R-ACK Channel to be active in all slots, you must set ACK Channel Bit Fixed Mode Attribute to on.)
  5. Set Î or to -75 dBm/1.23 MHz.
  6. Measure the power of the Pilot and ACK Channels.
  7. Repeat for ACKChannelGain set to 3 dB.

Minimum Standard

10 log 10 (Power ACK /Power Pilot ) shall be within ACKChannelGain (dB) +/- 0.25 dB.

4.3.8.3 Data Channel Output Power

Definition

For Subtypes 0 and 1 Physical Layer, the Data Channel, when transmitted, is transmitted on the Q-phase at a power level DataChannelGain relative to the Pilot/RRI Channel power level. For Subtype 2 Physical Layer, the Data Channel, when transmitted, is transmitted on the Q-phase (and also I-phase for the higher payloads) at a power level Traffic-to-Pilot power ratio (T2P) relative to the Pilot Channel power level. The value of DataChannelGain or T2P varies with Reverse Data Channel rate (and TerminationTarget for Subtype 2 Physical Layer) and is set as part of the configuration of the Reverse Traffic Channel MAC Protocol.

This test verifies the output power of the Data Channel (and Auxiliary Pilot Channel where applicable) relative to that of the Pilot Channel.

Method of Measurement

  1. Connect the access network emulator to the AT.
  2. Set up the Test Application and open an RTAP session (for Subtype 0 or 1 Physical Layer) or an RETAP session (for Subtype 2 Physical Layer).
  3. Configure the Test Application FTAP (for Subtype 0 or 1 Physical Layer) or FETAP (for Subtype 2 Physical Layer) so that the ACK Channel is transmitted at all the slots. (In order for the R-ACK Channel to be active in all slots, you must set ACK Channel Bit Fixed Mode Attribute to on.)
  4. Set Î or to -75 dBm/1.23 MHz.
  5. If the access terminal supports Subtype 0 or 1 Physical Layer, perform tests 1-5. If the access terminal supports Subtype 2 Physical Layer, perform tests 1-10.
  6. Tests 1-4: Open an RTAP (for Subtype 0 or 1 Physical Layer) or an RETAP (for Subtype 2 Physical Layer) connection. For Subtype 0 or 1 Physical Layer, configure the Test Application RTAP with a Reverse Data Channel rates of 9.6, 19.2, 38.4, 76.8 kbps. For Subtype 2 Physical Layer, configure the Test Application RETAP with the Reverse Data Channel payload size of 256, 512, 1024, 2048 bits with Termination Target of 16 slots. Measure the power of the R-Pilot and R-Data Channels.
  7. Test 5: Open an RTAP (for Subtype 0 or 1 Physical Layer) or an RETAP (for Subtype 2 Physical Layer) connection. For Subtype 0 or 1 Physical Layer, configure the Test Application RTAP with a Reverse Data Channel rates of 153.6 kbps. For Subtype 2 Physical Layer, configure the Test Application RETAP with the Reverse Data Channel payload size of 4096 bits with Termination Target of 16 slots. Measure the power of the R-Pilot and R-Data Channels. Also measure the power of individual walsh channels (Q2 SF=4 and I2 SF=4 ) constituting the R-Data, as well as all of I channel Walsh codes and all of Q channel Walsh codes.
  8. Tests 6 -7: For Subtype 1 or 2 Physical Layer, configure the Test Application RETAP with a Access Channel Data Channel rate of 9.6, 38.4 kbps. Page the access terminal and measure the power of the R-Pilot and R-Data over the capsule portion of each Access Channel probe.
  9. Tests 8-10: Open an RETAP (for Subtype 2 Physical Layer) connection. Configure the Test Application RETAP with the Reverse Data Channel payload size of 3072 bits, 6144 bits, 12288 bits, with Termination Target of 16 slots for each test. Measure the power of the R-Pilot, R-Aux Pilot and R-Data Channels, as well as the power of individual walsh channels constituting the R-Data. (In order for the R-Aux Pilot Channel to be active for the test, you must set Auxiliary Pilot Channel Min Payload no greater than the Reverse Data Channel payload size.)

Minimum Standard

Tests 1-5:

  • For Subtypes 0 and 1 Physical Layer, 10 log 10 (power Data /power Pilot ) shall be within DataChannelGain (dB) +/- 0.25 dB. The default DataChannelGain values are as follows:
    DataChannelGain (Default Values) vs. Rate (Subtype 0 and 1 Physical Layer)

    Rate (kbps)

    DataChannelGain (dB)

    9.6

    3.75

    19.2

    6.75

    38.4

    9.75

    76.8

    13.25

    153.6

    18.5
  • For Subtypes 2 Physical Layer, 10 log 10 (Power Data /Power Pilot ) shall be within T2P gain (dB) +/- 0.25 dB. For Test 5, the power of individual walsh channels constituting the R-Data, 10 log 10 (Power of Data[I:2 SF4 ]/Power of Pilot) and 10 log 10 (Power of Data[Q:2 SF4 ]/Power of Pilot) shall be within T2P gain (dB) +/- 0.25 dB. (R-Data occupies two walsh channels [I:2 SF4 ] and [Q:2 SF4 ]) The default T2P gain values are as follows:
    T2P and AuxiliaryPilotGain vs. Payload size (Subtype 2 Physical Layer)

    Payload Size
    (bits)

    T2P (dB) (on Walsh code or total)

    AuxiliaryPilotGain (dB) *
    I:2 SF4

    Q:2 SF4

            I:1 SF2

    Q:1 SF2

    Total

    256

             N/A N/A N/A N/A 3.75 N/A
    512 N/A N/A N/A N/A 7 N/A

    1024

             N/A N/A N/A N/A

    10

             N/A

    2048

    9.99

    9.99

             N/A N/A

    13

             N/A

    3072

             N/A N/A 11.24

    11.24

    14.25

    2.25

    6144

    9.22

             9.22 12.23 12.23

    17

    5

    12288

             13.47 13.47

    16.48

             16.48

    21.25

    9.25
    * The value of AuxPilotChannelGain in Subtype 3 Reverse Traffic Channel MAC Protocol is defined relative to the T2P in C.S0024-A. The values listed here are relative to the Pilot Channel transmit power level taking into account the T2P in each case.
  • In test 5, the code domain power in each inactive channel shall be 23 dB or more below the total transmit power. When either component of a code channel is active, the whole code channel is considered active, and this requirement shall not apply. That is, the test for inactive code channels will apply only if the channel is inactive on both the I and Q components.

    Note: For Subtype 0 and 1 Physical layer, the code channels R-Pilot (I:0 SF16 ), R-DRC (Q:8 SF16 ), R-ACK (I:4 SF8 ), and R-Data (Q:2 SF4 ) constitute the only measurements with active channels. For Subtype 2 Physical layer, the code channels R-Pilot (I:0 SF16 ), R-DRC (Q:8 SF16 ), R-DSC (I:12 SF32 ), R-RRI (I:4 SF16 ), R-ACK (I:12 SF32 ), R-AuxPilot (I:28 SF32 ) (if transmitted), R-Data (I:1 SF2 ) and R-Data (Q:1 SF2 ) constitute the only measurements with active channels.

Test 6:

  • 10 log 10 (Power Data /Power Pilot ) shall be within DataChannelGain (dB) +/- 0.25 dB (the default DataChannelGain is 3.75 dB because the capsule portion of Access Channel data rate is 9.6 kbps).

Test 7:

  • 10 log 10 (Power Data /Power Pilot ) shall be within DataChannelGain (dB) +/- 0.25 dB (the default DataChannelGain is 9.75 dB because the capsule portion of Access Channel data rate is 38.4 kbps).

Tests 8-10: (Table T2P and AuxiliaryPilotGain vs. Payload size (Subtype 2 Physical Layer) gives the default values of T2P gain and Auxiliary Pilot gain for comparison)

  • 10 log 10 (Power Data /Power Pilot ) shall be within T2P gain (dB) +/- 0.25 dB.
  • The power of each walsh channel constituting the R-Data, such as the 10 log 10 (Power of R-Data[I:2 SF4 ]/Power of Pilot), 10 log 10 (Power of R-Data[Q:2 SF4 ]/Power of Pilot), 10 log 10 (Power of R-Data[I:1 SF2 ]/Power of Pilot), and 10 log 10 (Power of R-Data[Q:1 SF2 ]/Power of Pilot) shall be within +/- 0.25 dB of their corresponding component T2P (as shown in the table T2P and AuxiliaryPilotGain vs. Payload size (Subtype 2 Physical Layer) ).
  • 10 log 10 (Power AuxPilot /Power Pilot ) shall be within AuxiliaryPilotGain (dB) +/- 0.25 dB. (The value of AuxPilotChannelGain as defined in the C.S0024-A Subtype 3 Reverse Traffic Channel MAC Protocol is defined relative to the T2P. The AuxPilotChannelGain in the table T2P and AuxiliaryPilotGain vs. Payload size (Subtype 2 Physical Layer) taking into account the T2P, are relative to the Pilot Channel transmit power level.)

4.3.8.4 DSC Channel Output Power

This test is applicable only to access terminals that support Subtype 2 Physical Layer.

Definition

The DSC Channel is transmitted at a power level of DSCChannelGain relative to the Pilot Channel power level. This test verifies the output power of the DSC Channel relative to that of the Pilot Channel.

Method of Measurement

  1. Connect the access network emulator to the AT.
  2. Set DSCChannelGain to -9 dB.
  3. Set up a Test Application session and open an RETAP connection (for Subtype 2 Physical Layer).
  4. Configure the Test Application FETAP (for Subtype 2 Physical Layer) so that the ACK Channel is transmitted at all the slots. (In order for the R-ACK Channel to be active in all slots, you must set ACK Channel Bit Fixed Mode Attribute to on.)
  5. Configure the Test Application RETAP with Reverse Data Channel rate corresponds to 9.6 kbps (256-bit payload with HighCapacity Transmission Mode and a HiCapTerminationTarget256 of 0x3 (16 slots).
  6. Set Î or to -75 dBm/1.23 MHz.
  7. Measure the power of the Pilot and DSC Channels.
  8. Repeat for DSCChannelGain set to -12 dB.

Minimum Standard

10 log 10 (Power DSC /Power Pilot ) shall be within DSCChannelGain (dB) +/- 0.25 dB.

Related Topics

Manual Operation: Testing 4.3.8 Code Domain Power


4.4.1 Conducted Spurious Emissions

4.4.1 Conducted Spurious Emissions

Definition

Conducted spurious emissions are emissions at frequencies that are outside the assigned CDMA Channel, measured at the access terminal antenna connector. This test measures the spurious emissions during continuous transmission.

Method of Measurement

  1. Set Open Loop Adjust to -81 dB or -84 dB, depending upon band class.
  2. Set Probe Initial Adjust to 15 dB.
  3. Set Power Step to 7.5 dB/step.
  4. Connect the access network emulator to the AT.
  5. Set up a Test Application session. For Subtype 0 or 1 Physical Layer, open an RTAP connection and configure the Reverse Data Channel rate to 153.6 kbps. For Subtype 2 Physical Layer, open an RETAP connection and configure the Reverse Data Channel payload size to 4096 bits with Termination Target of 16 slots.
  6. Configure the Test Application FTAP (for Subtype 0 or 1 Physical Layer) or FETAP (for Subtype 2 Physical Layer) so that the Forward Traffic Channel data rate corresponds to 307.2 kbps (2-slot version), and the ACK Channel is transmitted at all the slots. (It is necessary for the access terminal to transmit the R-ACK Channel to provide its maximum output power.)
  7. Set Î or to -60 dBm/1.23 MHz.
  8. Transmit continuous '0' (up) power control bits.
  9. Measure the spurious emission levels at the specified frequency offsets.

Minimum Standard

The spurious emissions shall be within the specified limits for each band class. The key specifications are as follows:

Key Minimum Standard Specifications
Band Classes | Frequency Offsets | Emission Limit
0, 2, 5, 7, 9 | 885 kHz to 1.98 MHz | less stringent of -42 dBc/30 kHz or -54 dBm/1.23 MHz
0, 2, 5, 7, 9 | 1.98 MHz to 4.00 MHz | less stringent of -54 dBc/30 kHz or -54 dBm/1.23 MHz
1, 4, 6, and 8 | 1.25 MHz to 1.98 MHz | less stringent of -42 dBc/30 kHz or -54 dBm/1.23 MHz
1, 4, 6, and 8 | 1.98 MHz to 4.00 MHz | less stringent of -50 dBc/30 kHz or -54 dBm/1.23 MHz

Related Topics

Manual Operation: Testing 4.4.1 Conducted Spurious Emissions


Test Adherence to Standards

Test Adherence to Standards

Last updated: June 29, 2006

Standards Table

Unless otherwise indicated, the capabilities shown in the tables apply to both the E1966A and the E6706A applications.

Support of C.S0033-A Tests

C.S0033-A Test

Supported by Test Set?

Comments

3. Receiver Tests

3.1 Frequency Coverage Requirements

Yes

Supports Band Classes 0, 1, 3, 4, 5, 6, 10 and 14.

See Cell Band .
3.2.1 Demodulation of Forward Traffic Channel in AWGN

Yes

See Testing 3.2.1 Demodulation of Forward Traffic Channel in AWGN .

3.2.2 Demodulation of Forward Traffic Channel in Multipath Fading Channel

Yes. ( Lab Application Only )

Requires external fader and AWGN generator. For example, the E5515C Fading Solution, see Digital Bus Information for reference information. ( Lab Application Only )

See also Testing 3.2.2 Demodulation of Forward Traffic Channel in Multipath Fading Channel (Lab Application Only) .

3.2.3 Decision of Power Control Bit for Channels Belonging to Different Power Control Sets During Soft Handoff

No

 Requires soft handoff capability.

3.2.4 Decision of Power Control Bit for Channels Belonging to the Same Power Control Set

No

 Requires soft handoff capability.

3.2.5 Demodulation of Reverse Power Control Channel During Soft Handoff

No

 Requires soft handoff capability.

3.2.6 Demodulation of ARQ Channel

No

3.2.7 Demodulation of Broadcast Channel

No
3.3.1 Receiver Sensitivity and Dynamic Range Yes

See Testing 3.3.1 Receiver Sensitivity and Dynamic Range .

3.3.2 Single Tone Desensitization

 Partially

Requires external CW signal generator.

3.3.3 Intermodulation Spurious Response Attenuation

Partially

Requires two external CW signal generators.

3.3.4 Adjacent Channel Selectivity

Partially

Requires external HRPD (1xEV-DO) and CDMA sources.

3.3.5 Receiver Blocking Characteristics

 Partially Requires external CW signal generator.

3.4.1 Conducted Spurious Emissions

No

Requires full spectrum analyzer

3.4.2 Radiated Spurious Emissions

No

Requires full spectrum analyzer

4. Transmitter Tests

4.1.1 Frequency Coverage

Yes

Supports Band Classes 0, 1, 3, 4, 5, 6, 10 and 14.

See Cell Band .

4.1.2 Frequency Accuracy

 Yes See Testing 4.2.2 Waveform Quality and Frequency Accuracy .

4.2.1 Time Reference

 Partially

Supports static time reference only.

See Testing 4.2.2 Waveform Quality and Frequency Accuracy .
4.2.2 Waveform Quality and Frequency Accuracy

Yes

 See Testing 4.2.2 Waveform Quality and Frequency Accuracy .

4.3.1 Range of Open Loop Output Power

Partially

Supports 100% forward packet activity only (see Fixed Settings ).

See Testing 4.3.1 Range of Open Loop Output Power .

If you want to view the access probe sequence graphically, use Measuring Graphical Access Probe Power ( Lab Application Only ).
4.3.2 Time Response of Open Loop Power Control

Yes

See Testing 4.3.2 Time Response of Open Loop Power Control

4.3.3 Range of Closed Loop Power Control

Partially

 Supports tests 1 and 3-11, Minimum Standard (a) only, by remote program only.

4.3.4 Maximum RF Output Power

Yes

See Testing 4.3.4 Maximum RF Output Power

4.3.5 Minimum Controlled Output Power

Yes

 See Testing 4.3.5 Minimum Controlled Output Power

4.3.6 Standby Output Power

Partially

Supports idle standby output power fully.

Supports measurement of standby power between access probe bursts by remote program only.
4.3.7 RRI Channel Output Power

Yes

 See Testing 4.3.7 RRI Channel Output Power
4.3.8.1 DRC Channel Output Power

Yes

 See Testing 4.3.8 Code Domain Power
4.3.8.2 ACK Channel Output Power

Yes

 See Testing 4.3.8 Code Domain Power
4.3.8.3 Data Channel Output Power Partially

Supports tests 1-5, 8-10.

See Testing 4.3.8 Code Domain Power

4.3.8.4 DSC Channel Output Power

Yes

This test is only used for subtype 2 physical layer testing. See Testing 4.3.8 Code Domain Power

4.4.1 Conducted Spurious Emissions

Yes

Supports adjacent and alternate channels only.

Testing 4.4.1 Conducted Spurious Emissions

4.4.2 Radiated Spurious Emissions

Partially

Requires external spectrum analyzer.

4.4.3 Occupied Bandwidth

Partially

Requires external spectrum analyzer.

Related Topics

E1966A 1xEV-DO Terminal Test Application Revision Information


Audio Frequency Measurement Description

Audio Frequency Measurement Description

How is an Audio Frequency measurement made?

Audio Frequency measures the frequency of the signal applied to the front-panel AUDIO IN connectors, and is one of the Audio Analyzer measurements. Audio frequency can be measured for signals in the frequency range of 100 Hz to 15 kHz, at levels from 7.1 mV peak to 20 V peak, and with a signal-to-noise ratio of 30 dB or greater.

The audio frequency measurement is made after any filtering and processing are selected for the Audio Analyzer.

Considerations When Making Manual Audio Frequency Measurements

When manually controlling the test set from the front panel, all measurements default to using continuous triggering. If you make digital measurements on a DTC using RF Rise or Protocol triggering, and then hand off to an AVC and select an analog measurement, the analog measurement may not trigger and display a result. This is because the digital measurement is still waiting for a burst transmission to trigger it (which it won't get from an analog signal) and therefore the measurements "freeze". To prevent this from happening when making analog measurements, either turn off the digital measurements or set their trigger source to Immediate.

Related Topics

Programming an Audio Frequency Measurement


Audio Level Measurement Description

Audio Level Measurement Description

How is an Audio Level measurement made?

Audio Level measures the AC voltage of the signal applied to the front-panel AUDIO IN connectors, and is one of the Audio Analyzer measurements. Audio Level can be measured for signals in the frequency range of
100 Hz to 20 kHz, at levels from 1 mV peak to 20V peak . The measurement is made after any filtering is applied, and can be made using an rms or peak detector. The type of detector being used for the measurement is displayed next to the measurement value.

When measuring very low voltages, it may be helpful to use the Audio Analyzer's adjustable bandpass filter and the rms detector to reduce noise components.

For information on using the Audio Analyzer, see Audio Analyzer Measurement Description .

This measurement is not affected by the Amplitude Offset setting.

Considerations When Making Manual Audio Level Measurements

When manually controlling the test set from the front panel, all measurements default to using continuous triggering. If you make digital measurements on a DTC using RF Rise or Protocol triggering, and then hand off to an AVC and select an analog measurement, the analog measurement may not trigger and display a result. This is because the digital measurement is still waiting for a burst transmission to trigger it (which it won't get from an analog signal) and therefore the measurements "freeze". To prevent this from happening when making analog measurements, either turn off the digital measurements or set their trigger source to Immediate.

Related Topics

Programming an Audio Level Measurement


Audio Analyzer Block Diagram

Audio Analyzer Block Diagram

Related Topics

Audio Analyzer Measurement Description


Audio Analyzer Measurement Description

Audio Analyzer Measurement Description

How is an analog audio measurement made?

The Audio Analyzer can measure Audio Level (V), SINAD (dB), Distortion (%), and Audio Frequency. Measurements are made through the test set's front panel AUDIO IN connectors. When measuring a mobile's audio output, the audio signal may come from either an acoustic coupler or from a test interface connection to the mobile's audio circuitry.

See Audio Analyzer Block Diagram .

The AUDIO IN connectors feed the inputs to a floating-input differential amplifier, with each input having an impedance of about 100,000 ohms to chassis ground. For best noise immunity, connect the audio signal and its ground reference to the two input ports through shielded coaxial cables, or input the signal to the AUDIO IN HI connector and ground the AUDIO IN LO connector's center contact.

None of the analog audio measurement results are affected by the Amplitude Offset setting.

SINAD/Distortion State

Select On or Off to enable or disable the SINAD and Distortion measurements. When On, these measurement results are displayed below the Audio Level measurement and the SINAD/Distortion Fundamental Frequency must be entered to specify the audio frequency for the measurement (range: 100 Hz to 10 kHz). When Off, four dashes are displayed in place of the measurement results.

Audio Frequency State

Select On or Off to enable or disable the Audio Frequency measurement.

Filter Type

  • None - no filtering is provided (default).
  • 100 Hz BW Band Pass Filter (Tunable) - The 100 Hz BW BPF Center Frequency setting is available when this filter is selected, and can be set in the range of 300 Hz to 15 kHz.
  • C-Message
  • 50 Hz to 15 kHz
  • 300 Hz to 15 kHz

Detector Type

Select either Peak or RMS (default) for making and displaying an Audio Level measurement (does not affect other measurements). The type of detector selected is displayed next to the Audio Level measurement results. A 1-volt rms sinewave input signal would measure 1.414 V Peak when the Peak detector is used. A 1-volt peak input signal would measure 0.707 V RMS when the RMS detector is used.

Expected Peak Voltage

The Expected Amplitude sets the analog audio clipping level and must be set. This voltage is always the absolute peak audio input signal voltage expected at the AUDIO IN connectors, and must be in the range of 7.07 mV peak (5 mVrms) to 20 V peak . Remember, measuring a 1-volt rms sinewave input signal would require a 1.414 V peak expected voltage value to avoid clipping (over-driving) the input.

De-Emphasis State

Set to On or Off (default) to enable or disable 750 microsecond de-emphasis.

Expandor Reference Level

Set value from 10 mV/kHz to 10 V/kHz, or Off (default). Entering a numeric value automatically turns the state to On. Entering Off disables the expandor (state = off).

Trigger Source

Audio Analyzer measurements use immediate triggering and are continuously re-triggered by the analyzer any time the Trigger Arm parameter is set to Continuous. Trigger timing is independent of any mobile protocol signaling.

Considerations When Making Manual Audio Analyzer Measurements

When manually controlling the test set from the front panel, all measurements default to using continuous triggering. If you make digital measurements on a DTC using RF Rise or Protocol triggering, and then hand off to an AVC and select an analog measurement, the analog measurement may not trigger and display a result. This is because the digital measurement is still waiting for a burst transmission to trigger it (which it won't get from an analog signal) and therefore the measurements "freeze". To prevent this from happening when making analog measurements, either turn off the digital measurements or set their trigger source to Immediate.

Related Topics

Audio Analyzer Block Diagram

Audio Analyzer Troubleshooting

Audio Level Measurement Description

Audio Frequency Measurement Description

SINAD Measurement Description

Distortion Measurement Description

Programming an Audio Frequency Measurement

Programming an Audio Level Measurement

Programming a SINAD Measurement

Programming a Distortion Measurement

Statistical Measurement Results (Multi-measurements)


Distortion Measurement Description

Distortion Measurement Description

How is a Distortion measurement made?

Distortion is an audio quality measurement that compares the audio signal level from the mobile at a specified (desired) frequency to the level of signals present at other frequencies. The audio signals from the mobile are typically demodulated tones sent over an analog voice channel (AVC).

The test set makes two measurements to determine distortion. First, the test set measures the total audio signal level into the Audio Analyzer. Next, a precise notch filter is then used to remove the signal at the specified frequency. The remaining signal level indicates the level of unwanted signals (distortion). Distortion is expressed as a percentage of the total audio signal.

Distortion can be measured in the range of 100 Hz to 10 kHz. For information on using the Audio Analyzer, see Audio Analyzer Measurement Description .

The distortion measurement can be used to perform the audio harmonic distortion test. In this test, two audio signals are used: a 1004 Hz tone and the 6000 Hz SAT. The 1004 Hz tone is notched out to make the measurement. See IS-137A, section 2.2.2.5 for more information.

Considerations When Making Manual Distortion Measurements

When manually controlling the test set from the front panel, all measurements default to using continuous triggering. If you make digital measurements on a DTC using RF Rise or Protocol triggering, and then hand off to an AVC and select an analog measurement, the analog measurement may not trigger and display a result. This is because the digital measurement is still waiting for a burst transmission to trigger it (which it won't get from an analog signal) and therefore the measurements "freeze". To prevent this from happening when making analog measurements, either turn off the digital measurements or set their trigger source to Immediate.

Related Topics

Audio Analyzer Measurement Description


SINAD Measurement Description

SINAD Measurement Description

How is a SINAD measurement made?

SINAD is a receiver audio quality measurement for mobiles on an analog voice channel (AVC). It is the ratio of Signal+Noise+Distortion divided by Noise+Distortion, expressed in dB. SINAD is measured using the test set's Audio Analyzer. SINAD can be measured in the range of 100 Hz to 10 kHz. For information on using the Audio Analyzer, see Audio Analyzer Measurement Description .

The SINAD measurement is used to determine receiver RF sensitivity. SINAD is usually measured either of two ways:

  • Reduce the Cell Power from the test set until 12 dB SINAD is displayed (re-triggering for each measurement), or
  • Set the Cell Power from the test set to a specified low level and verify a 12 dB SINAD reading.

See IS-137A, section 2.3.1.1, for more information.

Difference in Agilent 8960 Series 10 and 8920B Test Set SINAD Measurements

If you have previously used the Agilent 8920B RF Communications Test Set to measure SINAD, you may notice that the Agilent 8960 Series 10 test set's SINAD value may be lower by up to 0.8 dB when measuring 12 dB SINAD. This is due to the more precise digital notch filter used by the 8960, causing a more accurate noise measurement to be made. The 8920B uses an analog filter that does not have as tight a filter notch as the 8960.

Considerations When Making Manual SINAD Measurements

When manually controlling the test set from the front panel, all measurements default to using continuous triggering. If you make digital measurements on a DTC using RF Rise or Protocol triggering, and then hand off to an AVC and select an analog measurement, the analog measurement may not trigger and display a result. This is because the digital measurement is still waiting for a burst transmission to trigger it (which it won't get from an analog signal) and therefore the measurements "freeze". To prevent this from happening when making analog measurements, either turn off the digital measurements or set their trigger source to Immediate.

Related Topics

Programming a SINAD Measurement


Calibrating the Test Set

Calibrating the Test Set

Last updated: July 28, 2006

Description

  • Calibration Process Requirements
  • Recommended Calibration Intervals
  • Calibration Descriptions
    • IQ Calibrations
    • Burst Mod Offset 1 Calibration
    • Digital Average Power Calibration
    • Spectrum Monitor Calibration
    • Calibrate Measurements
    • Channel Power Calibration
    • Thermal Power Null Adjustment

Various calibration routines must be run periodically to ensure measurement accuracy, source accuracy and allow the most robust demodulation of the device-under-test's signal. This document describes the various calibrations available in the test set and when they should be performed.

Calibration Process Requirements

IMPORTANT
Before performing any calibrations on your test set:

  • Ensure that the calibration is necessary - running calibrations more often than necessary wastes your time and effort, and if the calibration is performed incorrectly, could actually result in degraded test set performance.
  • Ensure that the test set is in its ambient operating environment - in other words, ensure that the test set has warmed up (at least 30 minutes) and is in a location similar to the one it will be used in. For example, if you are going to be using the test set in a racked test system, then you must calibrate the test set while it is in that test system, and all of the equipment has reached a stable operating temperature.
  • Ensure that no power is present at the front panel RF connectors - remove any cables or connectors from the RF IN/OUT and RF OUT ONLY connectors. If you are operating in a high RF environment, it is recommended that you also terminate the RF connectors with a 50 Ohm load.

Recommended Calibration Intervals

This section indicates when the test set calibrations should be performed. Procedures are given for test sets that include Option 003: Flexible Radio Link and test sets that do not. Refer to Calibration Descriptions for details about the calibrations and how to perform them.

  • Once every year you must perform a full calibration by following steps 1-7 of the Calibration Procedure for Test Sets with Option 003 (or steps 1-2 of the Calibration Procedure for Test Sets without Option 003 if your test set does not include option 003).
  • You must also perform steps 1-7 of the Calibration Procedure for Test Sets with Option 003 (or steps 1-2 of the Calibration Procedure for Test Sets without Option 003 if your test set does not include option 003) if any of the following events occur:
    • When you receive the test set, before using it for the first time (regardless of whether the test set is new, being returned from service, or on loan from a colleague).
    • After adding a new application or format to the test set.
      Note: Upgrading firmware already present in the test set does not typically require running the calibration procedures. However, when upgrading firmware, it is advisable to check the release notes for any major feature changes that require re-calibration of the test set.
    • After you perform any kind of repair or service on your test set.
  • It is recommended that once every month you perform steps 4-7 of the Calibration Procedure for Test Sets with Option 003 (or step 2 of the Calibration Procedure for Test Sets without Option 003 if your test set does not include option 003).
  • You must also perform steps 4-7 of the Calibration Procedure for Test Sets with Option 003 (or step 2 of the Calibration Procedure for Test Sets without Option 003 if your test set does not include option 003) if any of the following events occur:
    • The operating environment for your test set changes significantly (for example, the temperature changes by more than 10 degrees C or the test set is moved from a racked test system to a bench top).
    • A measurement returns integrity indicator 19 ( Uncalibrated Due to Temperature ).

IMPORTANT
Ensure that your test set has warmed up at least 30 minutes and that no power is present at the front panel RF connectors before performing any calibrations.

Calibration Procedure for Test Sets with Option 003

Calibration Procedure for Test Sets without Option 003

Calibration Descriptions

If any of the following calibrations fail, ensure that you have followed the Calibration Process Requirements and have performed the calibrations in the order prescribed by Recommended Calibration Intervals . If the calibration still fails, contact your local Agilent Sales Representative for assistance.

IQ Calibrations

When performed from a GSM/GPRS/EGPRS or AMPS/136 application or format, the First IQ Modulator calibration sends a signal from the Baseband Generator 1 module to the RF Source 1 module to optimize the phase accuracy of RF Source 1 as a function of frequency. The optimization data is then stored in the test set and accessed whenever the RF Source frequency is set. The Second IQ Modulator calibration performs a similar procedure for RF Source 2 (RF Source 2 is only present if the test set includes option 002: RF Source 2).

When performed from a W-CDMA/HSDPA, cdma2000/IS-95/AMPS or 1xEV-DO application or format (which require option 003: Flexible Radio Link), the IQ calibrations perform the same phase optimizations explained above. Additionally, a signal is sent from the Flexible Radio Link Subsystem to the RF sources to calibrate phase accuracy for those alternative paths as well. This additional calibration data is written to the same calibration data file as above, but in a different area of the calibration table.

The IQ calibrations ensure that the test set accurately generates IQ-modulated signals. If the test set's IQ modulators have not been properly calibrated, the test set's output power (when producing an IQ-modulated signal) will be inaccurate, which may result in degraded receiver test results.

If you perform the IQ calibrations from a W-CDMA/HSDPA, cdma2000/IS-95/AMPS or 1xEV-DO application or format, you do not need to perform them from any other application or format. However, note that if you perform the IQ calibrations from a GSM/GPRS/EGPRS or AMPS/136 application/format, you must still perform them once from a W-CDMA/HSDPA, cdma2000/IS-95/AMPS or 1xEV-DO application or format.

The IQ calibrations do not need to be run frequently. See Recommended Calibration Intervals .

To initiate the IQ calibrations from the front panel, press SYSTEM CONFIG , press the right More ( 1 of 2 ) key, select Service ( F7 ), then select Cal. first IQ Modulator or Cal. second IQ Modulator . To initiate the IQ calibrations from a remote program, use the CALibration:IQ[1]|2? queries.

Each IQ calibration takes 5-6 minutes to execute.

Burst Mod Offset 1 Calibration

This calibration is only applicable to W-CDMA/HSDPA, cdma2000/IS-95/AMPS, and 1xEV-DO applications and formats. This calibration is only required when using the test set to generate an AM or DSB-SC test signal (select ( F9 ) Test Signal when in CW Operating Mode ). These test signals are used for calibrating Zero Intermediate Frequency (Zero IF) devices which utilize Qualcomm's radioOne™ architecture.

You do not have to perform the Burst Mod Offset 1 calibration for each application/format in your test set; performing it from one application/format provides calibration data to all relevant applications and formats.

The Burst Mod Offset 1 calibration does not need to be run frequently. See Recommended Calibration Intervals .

The Burst Mod Offset 1 calibration calibrates the noise and signal level of RF Source 1 (as a function of frequency) to most accurately produce the AM and DSB-SC test signals required for Zero IF device calibration. The calibration is performed by generating the modulated test signals and adjusting RF Source 1 to optimize gain and minimize the noise floor. The optimization data is then stored in the test set and accessed whenever the RF Source frequency is set.

To initiate the Burst Mod Offset 1 calibration from the front panel, press SYSTEM CONFIG , press the right More ( 1 of 2 ) key, select Service ( F7 ), then select Cal. Burst Mod Offset 1 . To initiate the Burst Mod Offset 1 calibration from a remote program, use the CALibration:BMOFfset? query.

The Burst Mod Offset 1 calibration takes less than 1 minute to execute.

Digital Average Power Calibration

The Digital Average Power calibration is only applicable to the cdma2000/IS-95/AMPS and 1xEV-DO applications/formats.

You do not have to perform the Digital Average Power calibration for each application/format in your test set; performing it from one application/format provides calibration data to all relevant applications and formats.

The Digital Average Power calibration does not need to be run frequently. See Recommended Calibration Intervals .

IMPORTANT
You must cycle the test set's power after the Digital Average Power calibration is complete in order to complete the calibration (the calibration data is not available to the test set until it has been restarted).

The Digital Average Power calibration generates calibration data for the Fast Power Detector for use by cdma2000/IS-95/AMPS and 1xEV-DO applications and formats. This calibration improves the accuracy of the Fast Power Detector when used to measure IS-95 and reverse RC-1 and RC-2 signals.

The calibration generates a CW signal at a given power level, measures it using the Fast Power Detector, generates a CDMA-modulated signal at the same power level, measures it using the Fast Power Detector and notes the difference. The calibration then generates a CW signal at a given power level, measures it using the Thermal Power Detector, generates a CDMA-modulated signal at the same power level, measures it using the Thermal Power Detector and notes the difference. Calibration data is then created by comparing these results. This is repeated for several power levels.

The Digital Average Power calibration provides calibration data for the following measurements:

  • Digital Average Power
  • Maximum/Minimum Power

To initiate the Digital Average Power calibration from the front panel, press Measurement selection , select Digital Average Power , then select Calibrate Digital Avg Pwr (F4) . To initiate the Digital Average Power calibration from a remote program, use the CALibration:DAPower? query.

The Digital Average Power calibration takes approximately 9 minutes to execute.

Spectrum Monitor Calibration

Performing the Spectrum Monitor calibration from one application/format does not provide calibration data to all relevant applications and formats. The calibration data files are shared as follows:

  • cdma2000/IS-95/AMPS and 1xEV-DO share the same Spectrum Monitor calibration data file.
  • W-CDMA/HSDPA has its own Spectrum Monitor calibration data file.
  • GSM/GPRS/EGPRS and AMPS/136 share the same Spectrum Monitor calibration data file.

Thus, if you perform the Spectrum Monitor calibration from a 1xEV-DO application/format, you do not need to perform it from a cdma2000/IS-95/AMPS application/format. However you do still need to perform it from a W-CDMA/HSDPA application/format and then again from either a GSM/GPRS/EGPRS or AMPS/136 application/format.

The Spectrum Monitor calibration should be run monthly, or whenever the test set's operating environment changes. See Recommended Calibration Intervals .

Performing the Spectrum Monitor calibration from a cdma2000/IS-95/AMPS or 1xEV-DO application/format executes the same routine as performing the Channel Power Calibration .

Performing the Spectrum Monitor calibration from a W-CDMA/HSDPA application/format executes the same routine as performing the Calibrate Measurements routine.

Performing the Spectrum Monitor calibration from a GSM/GPRS/EGPRS or AMPS/136 application/format calibrates the IF signal path in the Measurement Downconverter, using a CW signal.

To initiate the Spectrum Monitor calibration from the front panel, press Instrument selection , select Spectrum Monitor , select Trigger Setup ( F4 ), then select Calibrate Measurement ( F11 ). To initiate the Spectrum Monitor calibration from a remote program, use the CALibration:SMONitor? query.

The Spectrum Monitor calibration takes between 45 seconds and 3 minutes to execute, depending upon which application/format it is executed from.

Calibrate Measurements

The Calibrate Measurements routine is only applicable to W-CDMA/HSDPA applications/formats.

The Calibrate Measurements routine should be run monthly, or whenever the test set's operating environment changes. See Recommended Calibration Intervals .

The Calibrate Measurements routine calibrates the signal paths through the Measurement Downconverter and Demod Downconverter using both a CW signal and a modulated signal. The calibration is performed by comparing measured signals through the MDC and DDC to measurements made using the Fast Power Detector (for CW signals) and the Thermal Power Detector (for modulated signals). Both of these detectors are calibrated at the factory and temperature controlled for stability. During the Calibrate Measurements calibration, the internal temperature of the test set is measured and stored with the calibration data. If the internal temperature of the test set drifts by more than +/- 10 C since the last calibration, measurements utilizing this calibration will return integrity indicator 19 ( Uncalibrated Due to Temperature ).

The Calibrate Measurements routine provides calibration data for the following measurements:

  • Adjacent Channel Leakage Ratio
  • Channel Power
  • Change of TFC ( lab application only )
  • Code Domain
  • Fast Device Tune ( lab application or feature-licensed test application only )
  • Dynamic Power Analysis
  • Inner Loop Power
  • IQ Tuning
  • Occupied Bandwidth
  • Phase Discontinuity
  • PRACH Preamble Analysis ( lab application only )
  • PRACH Transmit On/Off Power
  • Spectrum Emission Mask
  • Spectrum Monitor
  • TX Dynamic Power
  • Waveform Quality

Performing the Calibrate Measurements routine executes the same routine as performing the Spectrum Monitor Calibration from a W-CDMA/HSDPA application/format.

To initiate the Calibrate Measurements routine from the front panel, initiate any of the measurements listed above and select Calibrate Measurements (F4) . To initiate the Calibrate Measurements routine from a remote program, use the CALibration:MEASurements? query.

The Calibrate Measurements routine takes approximately 3 minutes to execute.

Channel Power Calibration

The Channel Power calibration is applicable to the cdma2000/IS-95/AMPS and 1xEV-DO applications/formats.

You do not have to perform the Channel Power calibration for each application/format in your test set; performing it from one application/format provides calibration data to all relevant applications and formats.

The Channel Power calibration should be run monthly, or whenever the test set's operating environment changes. See Recommended Calibration Intervals .

The Channel Power calibration calibrates the signal paths through the Measurement Downconverter and Demod Downconverter using both a CW signal and a modulated signal. The calibration is performed by comparing measured signals through the MDC and DDC to measurements made using the Fast Power Detector (which is calibrated at the factory and temperature controlled for stability). During the Calibrate Measurements calibration, the internal temperature of the test set is measured and stored with the calibration data. If the internal temperature of the test set drifts by more than +/- 10 C since the last calibration, measurements utilizing this calibration will return integrity indicator 19 ( Uncalibrated Due to Temperature ).

The Channel Power calibration provides calibration data for the following measurements:

  • Access Probe Power
  • Channel Power
  • Code Channel Time/Phase Error
  • Fast Device Tune ( lab application or feature-licensed test application only )
  • Gated Power
  • Graphical Access Probe Power ( lab application only )
  • Handoff Waveform Quality
  • Maximum/Minimum Power
  • Time Response of Open Loop Power Control
  • TX Dynamic Power
  • TX Spurious Emissions
  • Waveform Quality + Code Domain
  • Spectrum Monitor

Performing the Channel Power calibration executes the same routine as performing the Spectrum Monitor Calibration from a cdma2000/IS-95/AMPS or 1xEV-DO application/format.

To initiate the Channel Power calibration from the front panel, initiate any of the measurements listed above and select Calibrate Channel Power (F4) . To initiate the Channel Power calibration from a remote program, use the CALibration:CPOWer? query.

The Channel Power calibration takes approximately 2 minutes to execute.

Thermal Power Null Adjustment

The Thermal Power Null Adjustment is only applicable to the cdma2000/IS-95/AMPS, 1xEV-DO and W-CDMA/HSDPA applications/formats.

The Thermal Power Detector is calibrated at the factory and temperature controlled for stability. However, it is still possible for the auto-null circuit within the detector to drift over time. The Thermal Power Null Adjustment should be run monthly to:

  • Re-center the auto-null circuit to provide optimum accuracy for the affected measurements.
  • Ensure that the auto-null circuit has not drifted such that it is no longer able to null the power detector. If this occurs, the Thermal Power Null Adjustment returns a 1 (fail).

See Recommended Calibration Intervals .

You do not have to perform the Thermal Power Null Adjustment from each application/format in your test set; performing it from one application/format checks the auto-null circuit and provides re-centering data as needed. However, to achieve the accuracy optimization that results from re-centering, each of your applications must include the Thermal Power Null Adjustment feature (because only applications including the Thermal Power Null Adjustment feature are able to instruct the Thermal Power Detector to use the re-centering data generated by the Thermal Power Null Adjustment ).

This adjustment affects the Thermal Power (W-CDMA/HSDPA) measurement, as well as all measurements that are calibrated by the Digital Average Power Calibration (cdma2000/IS-95/AMPS, 1xEV-DO) and Calibrate Measurements (W-CDMA/HSDPA) routine.

To initiate the Thermal Power Null Adjustment from the front panel, press SYSTEM CONFIG , press the right More ( 1 of 2 ) key, and select Thermal Power Null Adjust ( F9 ). To initiate the Thermal Power Null Adjustment from a remote program, use the SYSTem:INSTrument:THERmal:POWer:NULL:ADJust? query.

The Thermal Power Null Adjustment takes between 30 seconds and 3 minutes.

Related Topics

CALibration


Access Probe Power Measurement Description

Access Probe Power Measurement Description

Last updated: June 16, 2006

  • How is an Access Probe Power Measurement Made?
  • Access Probe Power Measurement Parameters
  • Access Probe Power Measurement Results
  • Access Probe Power Input Signal Requirements
  • Key C.S0033 Tests Performed using the Access Probe Power Measurement
  • Calibrating the Access Probe Power Measurement

How is an Access Probe Power Measurement Made?

The test set's access probe power measurement is a channel power measurement (see Channel Power Measurement Description ) triggered by a rise in RF power detected on the test set's RF input. When an input signal appears that is within +/- 9 dB of the expected power for an access probe, the measurement is triggered. To prevent the measurement from triggering on noise, the signal level must be at least -45 dBm/1.23 MHz.

The access probe power measurement captures an access probe and digitizes the waveform. It then uses DSP to determine the average power level (within the 1.23 MHz measurement bandwidth) of the first ~1.667 ms of the probe.

Considerations when Making Access Probe Power Measurements

IMPORTANT
If the access probe power measurement is on and waiting to measure a probe, all other measurements (except digital average power) will not be able to execute. It is therefore recommended that you turn off the access probe power measurement before attempting any other measurements.

Access probe sequences consist of a series of RF power "steps" which increase in power according to the step size setting until the maximum number of steps is reached, or the data connection processing event completes (for example when the data connection is established). For the parameters that determine the access probe sequence characteristics, see Access Probe Power Measurement Parameters .

To view the full access probe sequence, you must prevent the test set from responding to the access terminal by turning Call Limit Mode on.

NOTE
It is recommended that you always turn Call Limit Mode on when measuring access probe power. The easiest way to induce access probes from the access terminal is to page the access terminal. If you do not have call limit mode set to on, the connection will complete, which clears the access probe power result from the measurement screen. Set call limit mode back to off when you have finished measuring access probe power.

Access Probe Power Measurement Parameters

  • Trigger Arm - (see Trigger Arm (Single or Continuous) Description ). When the test set is making access probe power measurements in the continuous trigger arm state, it will display the power level of the most recent access probe power measurement. To measure only the first access probe and prevent triggering on subsequent access probes, set Trigger Arm to Single . You must then press Start Single to arm the measurement.
  • Timeout Time/State - (see Measurement Timeouts ).
  • The following parameters determine the access probe sequence characteristics: Open Loop Adjust , Probe Initial Adjust , Probe Power Step , Probe Num Step , Probe Sequence Max , Preamble Length , Enhanced Access Rate ( only for subtype 2 physical layer with Enhanced Access Channel MAC protocol )
    NOTE

    The Probe Sequence Max is a "Configurable Attribute" that is configured during the Session Negotiate State . Its value can not be changed when a session is open and Call Limit Mode is on.

Access Probe Power Measurement Results

  • Integrity Indicator - (see Integrity Indicator ).
  • Access Probe Power (in dBm/1.23 MHz): The average power level of the first ~1.667 ms of the captured access probe.
  • The Expected Access Terminal Power (see Expected Power ) is also displayed on the measurement screen when either of the following conditions is met:
    • Current physical layer subtype is Subtype 0 (see Release A Physical Layer Subtype ), the receiver power control is set to auto and Test Application Protocol is set to RTAP.
    • Current physical layer subtype is Subtype 2 (see Release A Physical Layer Subtype ), the receiver power control is set to auto and Enhanced Test Application Protocol is set to RETAP.

An example measurement result (for subtype 0 physical layer) is shown below:

Access Probe Power Input Signal Requirements

Input Signal Requirements

Key C.S0033 Tests Performed using the Access Probe Power Measurement

  • 4.3.1 Range of Open Loop Output Power

Calibrating the Access Probe Power Measurement

The access probe power measurement is automatically calibrated during a channel power calibration. Follow the channel power calibration schedule and the access probe power measurement will be properly calibrated. Refer to Calibrating the Test Set for a description of channel power calibration.

Related Topics

Manual Operation: Measuring Access Probe Power

Programming an Access Probe Power Measurement

Access Probe Power Troubleshooting

Test Adherence to Standards

Graphical Access Probe Power Measurement Description ( Lab Application Only )


Fast Device Tune Measurement Description

Fast Device Tune Measurement Description

Last updated: June 30, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

  • How is a Fast Device Tune Measurement Made?
  • Fast Device Tune Measurement Parameters
    • Configuring the MS TX Frequency/Power Series
    • Configuring the MS RX Frequency/Power Series
    • Triggering the Fast Device Tune Measurement
    • Required Initial Conditions
  • Fast Device Tune Measurement Results
  • Fast Device Tune Input Signal Requirements
  • Calibrating the Fast Device Tune Measurement

How is a Fast Device Tune Measurement Made?

The Fast Device Tune measurement allows you to simultaneously calibrate your mobile station's transmitter (TX) output power and receiver (RX) input level across level and frequency in a single sweep (per frequency band range). The measurement is not performed with a call established between the test set and mobile station (MS). Rather, you must place your MS into a test mode which forces it to transmit a predefined series of power steps at various frequencies, and forces it to simultaneously tune its receiver to perform measurements of the test set's signal (to determine RSSI, for example) at various frequencies and power levels.

Example MS TX and MS RX Frequency/Power Series for Fast Device Tune Measurement

Before initiating the measurement, you must specify the power sequence that the MS will transmit (MS TX Power Sequence), and the frequencies at which the MS will transmit the power sequence (MS TX Frequency Sequence). You must also specify the power sequence you want the test set to transmit (MS RX Power Sequence), and the frequencies at which you want the test set to transmit the power sequence (MS RX Frequency Sequence).

Configuring the MS TX Frequency/Power Series

The MS TX Power Sequence may include up to 20 steps (of 20 ms duration) that span some or all of the measurement's input range (the levels can step up or down with varying magnitudes of change, as long as the first step in the sequence provides a 20 dB rise to trigger the measurement). The MS TX Frequency Sequence may include up to 20 frequencies (within one frequency band range).

The test set can measure a total of 400 power points in one measurement cycle (20 power values at 20 different frequencies). However, the measurement allows you to enter up to 40 MS TX Power Step Levels and 40 MS TX Frequency Step Values (indexed from 0 to 39). You must then use the MS TX Power Step Start Index and Number of Power Steps settings to specify which power steps comprise the MS TX Power Sequence, and the MS TX Frequency Step Start Index and Number of Frequency Steps settings to specify which frequency steps comprise the MS TX Frequency Sequence. See Frequency/Power Series Example for an example illustrating how to utilize this flexibility.

The test set uses the values in the MS TX Power Sequence and the MS TX Frequency Sequence to build the MS TX Frequency/Power Series, which drives how the test set's receiver is tuned throughout the measurement cycle. To build the MS TX Frequency/Power Series, the test set simply repeats the MS TX Power Sequence at each of the frequencies in the MS TX Frequency Sequence, and inserts a frequency re-tune step in between each repetition of the power sequence (to allow the test set and MS to re-tune to the new frequency; no measurements are performed by the test set during the frequency re-tune steps). During the frequency re-tune steps, the test set tunes its receiver to the power and frequency values required for the first step in the next power sequence. The frequency re-tune steps are the same step length as the power sequence steps (20 ms).

Before initiating the measurement, you must ensure that your MS is set to transmit the MS TX Frequency/Power Series you've set in the test set, including the frequency re-tune steps.

Configuring the MS RX Frequency/Power Series

While the test set is measuring the MS TX Power Sequence, it also transmits a MS RX Power Sequence for the MS to measure. This MS RX Power Sequence must include the same number of power steps as the MS TX Power Sequence (up to 20 steps of 20 ms duration). These steps can be at any power level in the test set's Cell Power output range.

The test set transmits its MS RX Power Sequence at each of the frequencies in the MS RX Frequency Sequence. The MS RX Frequency Sequence may include up to 20 frequencies within one frequency band range (which does not have to be the same frequency band range as the MS TX Frequency Sequence). The number of frequencies in the MS RX Frequency Sequence must match the number of frequency steps in the MS TX Frequency Sequence.

If you do not want the MS to measure test set power at as many power levels or frequencies as you want the test set to measure from the MS, simply place "dummy" power levels or frequencies at the end of the MS RX Power Sequence and MS RX Frequency Sequence (for example, simply repeat the final power level or frequency). You can then ignore the mobile station's measurement results for these "dummy" points. Likewise, if you need more measurement points in the MS RX Frequency/Power Series than in the MS TX Frequency/Power Series, you can place "dummy" power levels and frequencies in the MS TX Frequency/Power Series, but note that the test set will still measure and report power for these "dummy" points. You must simply ignore these results.

As with the MS TX Frequency/Power Series, the test set can transmit a total of 400 power points in one measurement cycle (20 power values at 20 different frequencies), but the measurement allows you to enter up to 40 MS RX Power Step Levels and 40 MS RX Frequency Step Values (indexed from 0 to 39). You must then use the MS RX Power Step Start Index and Number of Power Steps settings to specify which power steps comprise the MS RX Power Sequence, and the MS RX Frequency Step Start Index and Number of Frequency Steps settings to specify which frequency steps comprise the MS RX Frequency Sequence. See Frequency/Power Series Example for an example illustrating how to utilize this flexibility.

As with the MS TX Frequency/Power Series, the test set uses the values in the MS RX Power Sequence and the MS RX Frequency Sequence to build the MS RX Frequency/Power Series, which drives how the test set's generator is tuned throughout the measurement cycle. To build the MS RX Frequency/Power Series, the test set simply repeats the MS RX Power Sequence at each of the frequencies in the MS RX Frequency Sequence, and inserts a frequency re-tune step in between each repetition of the power sequence (to allow the test set and MS to re-tune to the new frequency; the MS should not perform any measurements on the test set's signal during this time, or if a measurement is performed, you should ignore the measurement results). During the frequency re-tune steps, the test set moves its generator to the power and frequency values required for the first step in the next power sequence. The frequency re-tune steps are the same step length as the power sequence steps (20 ms).

Before initiating the measurement, you must ensure that your MS is set to measure the MS RX Frequency/Power Series you've set in the test set, and that its tuning profile includes the frequency re-tune steps. Your mobile station should be configured to measure the test set's signal 5 ms after the start of each step, to allow the test set's source to settle.

Frequency/Power Series Example

The test set can measure/transmit 400 power points in one measurement cycle (20 power values at 20 different frequencies). However, you can enter up to 40 power values and 40 frequencies for both the MS TX and MS RX sequences. This flexibility is present to make it more efficient for you to test different power sequences over different sets of frequencies or, more commonly, to test the same power sequence over different bands. You must load in the superset of power levels and frequency values once. Then for each measurement cycle, you simply change the start index and number of steps as needed and initiate the measurement.

For example, to measure a MS TX sequence of 14 power step levels in both the US Cellular and US PCS frequency bands:

  • MS transmit power levels (dBm): 20, 16, 12, 8, 4, 0,-4, -8, -12, -16, -20, -30, -40, -50
  • US Cellular band, frequencies (MHz): 826.2, 829.2, 835.2, 838.2, 841.2, 847.2
  • US PCS band, frequencies (MHz): 1852.5, 1856.5, 1860.5, 1864.5, 1870.5, 1874.5, 1878.5, 1882.5, 1886.5, 1890.5, 1894.5, 1898.5, 1902.5

and to transmit a MS RX sequence of 8 power step levels for the mobile station to measure:

  • Test set transmit power levels (dBm): -90, -80, -70, -60, -50, -40, -30, -20
  • US Cellular band, frequencies (MHz): 871.2, 874.2, 880.2, 883.2, 886.2, 892.2
  • US PCS band, frequencies (MHz): 1932.5, 1936.5, 1940.5, 1944.5 1950.5, 1954.5, 1958.5, 1962.5, 1966.5, 1970.5, 1974.5, 1978.5, 1982.5

for multiple US Cellular/US PCS mobile stations, set the following:

  1. MS TX Power Step Levels = 20, 16, 12, 8, 4, 0,-4, -8, -12, -16, -20, -30, -40, -50
    MS RX Power Step Levels = -90, -80, -70, -60, -50, -40, -30, -20, -75, -75, -75, -75, -75, -75 (note that the last six values "-75" are "dummy" values required so that there are an equal number of power steps in the MS TX and MS RX sequences)
    MS TX Frequency Step Values = 826.2, 829.2, 835.2, 838.2, 841.2, 847.2, 1852.5, 1856.5, 1860.5, 1864.5, 1870.5, 1874.5, 1878.5, 1882.5, 1886.5, 1890.5, 1894.5, 1898.5, 1902.5
    MS RX Frequency Step Values = 871.2, 874.2, 880.2, 883.2, 886.2, 892.2, 1932.5, 1936.5, 1940.5, 1944.5 1950.5, 1954.5, 1958.5, 1962.5, 1966.5, 1970.5, 1974.5, 1978.5, 1982.5
  2. MS TX Power Step Start Index = 0
    MS RX Power Step Start Index = 0
    Number of Power Steps = 14
  3. Mobile station #1:
    • MS TX Frequency Step Start Index = 0
      MS RX Frequency Step Start Index = 0
      Number of Frequency Steps = 6
      Initiate the measurement, query INITiate:CFDTune:ARMed?, fetch the results
    • MS TX Frequency Step Start Index = 6
      MS RX Frequency Step Start Index = 6
      Number of Frequency Steps = 13
      Initiate the measurement, query INITiate:CFDTune:ARMed?, fetch the results
  4. Mobile station #2: repeat step 3
  5. Mobile station #3: repeat step 3
  6. ...

Triggering the Fast Device Tune Measurement

The MS must trigger the measurement with a positive change in power of at least 20 dB (the mobile station's power must rise from 20 dB below the level of the first step in the MS TX Power Sequence to within 9 dB of the level of the first step).

To ensure successful triggering, it is recommended that you do the following:

  1. Order the MS to transmit continuously at >20 dB below the power level of the first step in the MS TX Power Sequence.
    Note: If your MS TX Power Sequence starts at a power level that is less than 20 dB above the minimum transmit power of your MS, then you must include a trigger pulse as the first step in the MS TX Power Sequence. The power level of this trigger pulse will be measured by the test set as one of the steps in the sequence.
  2. Initiate the Fast Device Tune measurement (this prepares the test set's hardware to execute the frequency/power series you've specified and arms the measurement's RF rise trigger).
  3. Send the INITiate:CFDTune:ARMed? query and wait for it to return a value of 1 , indicating that the measurement is armed and ready to be triggered (or wait ~2 seconds if running the measurement from the front panel).
  4. Order the MS to begin transmission of its MS TX Frequency/Power Series (the MS should then increase its output power by more than 20 dB to reach the first step in the series, which triggers the measurement with an RF rise).

Once triggered, the Fast Device Tune measurement performs a series of channel power measurements, one near the center of each step of the MS TX Power Sequence (while simultaneously transmitting the MS RX Power Sequence you've specified), then repeats the measurements at the next specified MS TX frequency (while simultaneously transmitting the MS RX Power Sequence at the next specified MS RX frequency). The test set tunes its receiver for each step according to the power levels you've specified for the MS TX Power Sequence. The MS must step its power according to the MS TX Power Sequence (and be within +/- 9 dB of the expected power level for each step) and hold its power constant for the duration of the measurement interval (312.5 us, 7 ms after the start of each step). After completing a measurement at each step of the MS TX Frequency/Power Series, the measurement returns power results for all of the measured steps.

Required Initial Conditions

  • Operating Mode must be set to IS-856 Test .
  • Rcvr Power Ctrl must be set to Manual and Meas Frequency must be set to manual control (See Manual Receiver Control in IS-856 Test Operating Mode ).
    To set Meas Frequency to manual control from the front panel, press the OFF/MANUAL key. This sets Meas Frequency to the last frequency value that this parameter was set to. The Fast Device Tune measurement ignores the specific value that Meas Frequency is set to, so it can be set to any supported input frequency; the measurement simply requires that Meas Frequency be in manual control mode
  • RF Gen Freq Ctrl must be set to Manual . See Manual Receiver Control in IS-856 Test Operating Mode .
  • AWGN Power must be Off . If in the Lab Application , also make sure no external fading is applied (see Digital Bus Information ).
  • The Fast Device Tune measurement is only supported on the RF IN/OUT port. If your test set includes an RF OUT ONLY port, RF Output Port ( F6 on the System Config screen) must be set to RF IN/OUT .
  • You must configure the MS TX Frequency/Power Series to match the pattern of power levels to be transmitted by the MS and configure the MS RX Frequency/Power Series to match the pattern of power levels to be measured by the MS.

Operating Considerations

The Fast Device Tune measurement must re-range and re-trigger for every step in the MS TX Power Sequence. To ensure that this process is not interrupted by other operations, it is recommended that you not send any GPIB commands to the test set or press any front panel keys until the measurement has completed. If the measurement misses a trigger, it aborts and returns Integrity Indicator 30 : Missed Trigger .

No other measurements can be running when a Fast Device Tune measurement is performed. If any measurements are running when a Fast Device Tune measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while a Fast Device Tune measurement is running, the Fast Device Tune measurement is closed and a message is displayed.

Measurement results (and the RF generator output level) are affected by any RF IN/OUT Amplitude Offsets that are entered (see Amplitude Offset ).

Fast Device Tune Measurement Parameters

Fast Device Tune Setup

  • Measurement Timeout

    See Measurement Timeouts . Ensure that you set the Measurement Timeout to a value great enough to allow you to command the MS to transmit its MS TX Frequency/Power Series and for the test set to measure the MS TX Frequency/Power Series. For example, measuring the maximum allowable number of 400 power points can take more than 10 seconds (400 steps plus the 19 re-tune steps: 419 x 20 ms = 8.4 seconds, plus ~ 2 seconds required for the measurement to prepare for triggering).

    GPIB command: SETup:CFDTune:TIMeout[:STIMe]

  • MS TX Power Step Start Index

    Indicates which of the MS TX Power Step Levels is the first step in the MS TX Power Sequence.

    This parameter can be set to any integer value between 0 and 39. However, MS TX Power Step Start Index + Number of Power Steps must not exceed 40.

    Also, you must ensure that the range of values selected by MS TX Power Step Start Index and Number of Power Steps do not include any NANs (9.91E+37) or values that are outside of the input range for the current application format (considering the amplitude offset settings).

    GPIB command: SETup:CFDTune:MS:TX:POWer:STEP:STARt:[INDex]

  • MS TX Frequency Step Start Index

    Indicates which of the MS TX Frequency Step Values is the first frequency in the MS TX Frequency Sequence.

    This parameter can be set to any integer value between 0 and 39. However, MS TX Frequency Step Start Index + Number of Frequency Steps must not exceed 40.

    Also, the frequencies indicated by MS TX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range (and must not include any NANs (9.91E+37)).

    GPIB command: SETup:CFDTune:MS:TX:FREQuency:STEP:STARt:[INDex]

  • MS RX Power Step Start Index

    Indicates which of the MS RX Power Step Levels is the first step in the MS RX Power Sequence.

    This parameter can be set to any integer value between 0 and 39. However, MS RX Power Step Start Index + Number of Power Steps must not exceed 40.

    Also, you must ensure that the range of values selected by MS RX Power Step Start Index and Number of Power Steps do not include any NANs (9.91E+37) or values that are outside of the output range for the current application format (considering the amplitude offset settings).

    GPIB command: SETup:CFDTune:MS:RX:POWer:STEP:STARt:[INDex]

  • MS RX Frequency Step Start Index

    Indicates which of the MS RX Frequency Step Values is the first frequency in the MS RX Frequency Sequence.

    This parameter can be set to any integer value between 0 and 39. However, MS RX Frequency Step Start Index + Number of Frequency Steps must not exceed 40.

    Also, the frequencies indicated by MS RX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range (and must not include any NANs (9.91E+37)).

    GPIB command: SETup:CFDTune:MS:RX:FREQuency:STEP:STARt:[INDex]

  • Number of Power Steps

    Indicates how many (consecutive) MS TX Power Step Levels are used for the MS TX Power Sequence, and how many (consecutive) MS RX Power Step Levels are used for the MS RX Power Sequence.

    This parameter can be set to any integer value between 1 and 20, but MS TX Power Step Start Index + Number of Power Steps and MS RX Power Step Start Index + Number of Power Steps must not exceed 40.

    Also, you must ensure that the range of power values selected by MS TX Power Step Start Index, MS RX Power Step Start Index and Number of Power Steps do not include any NANs (9.91E+37) or values that are outside of the input or output ranges for the current application format (considering the amplitude offset settings).

    GPIB command: SETup:CFDTune:POWer:STEP:COUNt

  • Number of Frequency Steps

    Indicates how many (consecutive) MS TX Frequency Step Values are used for the MS TX Frequency Sequence, and how many (consecutive) MS RX Frequency Step Values are used for the MS RX Frequency Sequence.

    This parameter can be set to any integer value between 1 and 20, but MS TX Frequency Step Start Index + Number of Frequency Steps and MS RX Frequency Step Start Index + Number of Frequency Steps must not exceed 40.

    Note that the frequencies indicated by MS TX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range. Likewise, the frequencies indicated by MS RX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range, but do not have to be in the same frequency band range as the MS TX Frequency Sequence. Ensure that none of the frequency values you've selected are NANs (9.91E+37)).

    GPIB command: SETup:CFDTune:FREQuency:STEP:COUNt

Fast Device Tune MS TX/RX Parameters

  • MS TX Power Step Levels

    You can specify up to 40 mobile station output power levels (indexed from 0 up to 39). You must use the MS TX Power Step Start Index and Number of Power Steps settings to specify which of these (consecutive) power levels (up to 20) are used for the MS TX Power Sequence.

    Although you can enter any power levels between -129 and +80 dBm (because this measurement is common to the W-CDMA/HSDPA, 1xEV-DO and cdma2000 formats), when running the Fast Device Tune measurement in the 1xEV-DO application/format, you can only measure power levels in the range of -79 to +30 dBm and the measurement is only specified for power levels in the range of -61 to +30 dBm (these ranges assume an amplitude offset of 0; the ranges change as you change amplitude offsets, see Amplitude Offset ).

    GPIB command: SETup:CFDTune:MS:TX:POWer:STEP[:LEVels]

  • MS TX Frequency Step Values

    You can specify up to 40 mobile station uplink frequencies (indexed from 0 up to 39). You must use the MS TX Frequency Step Start Index and Number of Frequency Steps settings to specify which of these (consecutive) frequencies (up to 20) are used for the MS TX Frequency Sequence.

    Although you can enter any frequencies between 411 and 1980 MHz, when running the Fast Device Tune measurement in the 1xEV-DO application/format, you can only test frequencies within a single 1xEV-DO frequency band range:

    • 411 to 479 MHz (Band: NMT-450)
    • 806 to 924 MHz (Bands: US Cellular, Japan CDMA, China Cellular, and Secondary 800)
    • 1750 to 1780 MHz (Band: Korean PCS)
    • 1920 to 1980 MHz (Band: IMT-2000)
    • 1850 to 1915 (Bands: US PCS and US PCS 1900)

    GPIB command: SETup:CFDTune:MS:TX:FREQuency:STEP[:VALues]

  • MS RX Power Step Levels

    You can specify up to 40 test set output power levels (indexed from 0 up to 39). You must use the MS RX Power Step Start Index and Number of Power Steps settings to specify which of these (consecutive) power levels (up to 20) are used for the MS RX Power Sequence.

    Although you can enter any power levels between -165 and 37 dBm, when running the Fast Device Tune measurement in the 1xEV-DO application/format, the test set can only transmit test power levels in the range of -120 to -13 dBm (this range assumes an amplitude offset of 0; the allowable range changes as you change amplitude offsets, see Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power ).

    GPIB command: SETup:CFDTune:MS:RX:POWer:STEP[:LEVels]

  • MS RX Frequency Step Values

    You can specify up to 40 test set downlink frequencies (indexed from 0 up to 39). You must use the MS RX Frequency Step Start Index and Number of Frequency Steps settings to specify which of these (consecutive) frequencies (up to 20) are used for the MS RX Frequency Sequence.

    Although you can enter any frequencies between 421 and 2170 MHz, when running the Fast Device Tune measurement in the 1xEV-DO application/format, you can only test frequencies within a single 1xEV-DO frequency band range:

    • 421 to 489 MHz (Band: NMT-450)
    • 800 to 960 MHz (Bands: US Cellular, Japan CDMA, China Cellular, and Secondary 800)
    • 1840 to 1870 MHz (Band: Korean PCS)
    • 2110 to 2170 MHz (Band: IMT-2000)
    • 1930 to 1995 (Bands: US PCS and US PCS 1900)

    GPIB command: SETup:CFDTune:MS:RX:FREQuency:STEP[:VALues]

Fast Device Tune Measurement Results

The Fast Device Tune measurement results are currently only available via GPIB command (see FETCh:CFDTune[:ALL]? ). Measurement results are not available on the front panel screen.

  • Integrity Indicator
  • Power

    The test set performs a channel power measurement near the center of each step (7 ms after the start of the step), with a measurement interval of 312.5 us (1/4 timeslot). Power (dBm/1.23 MHz) is returned for each step in the MS TX Frequency/Power Series (except for the frequency re-tune steps). The total number of results returned by the measurement is always 400 ( Number of Power Steps x Number of Frequency Steps power result values are returned, followed by 9.91E+37 (NAN) for all remaining values up to 400). The power results for the first frequency in the MS TX Frequency Sequence are returned first, then the power results for the second frequency in the MS TX Frequency Sequence, etc., followed by NANs if fewer than 400 points were measured.

Note that the test set does not report the mobile station's measurement results (for example, RSSI). You must capture the mobile station's measurement results so that you can compare its measurements with the test set's actual transmission levels.

Fast Device Tune Input Signal Requirements

The Fast Device Tune measurement meets specifications when the following input signal requirements are met:

  • Frequency: 411 to 420 MHz, 450 to 484 MHz, 824 to 934 MHz, 1750 to 1780 MHz, 1850 to 1980 MHz
  • Input level: -61 dBm to +30 dBm (the measurement can accept power within the range of -79 dBm to +30 dBm)

Calibrating the Fast Device Tune Measurement

You must calibrate this measurement using the Calibrate Measurements procedure (see Calibrating the Test Set ).

Related Topics

Programming a Fast Device Tune Measurement


Packet Error Rate (PER) Measurement Description

Packet Error Rate (PER) Measurement Description

Last updated: July 10, 2006

  • How is a PER Measurement Made?
  • PER Measurement Parameters
  • PER Measurement Results
  • PER Input Signal Requirements
  • Key C.S0033 Tests Performed Using PER

How is a PER Measurement Made?

Packet Error Rate (PER) is used to test the performance of an access terminal's receiver. PER is the ratio, in percent, of the number of FTAP or FETAP Test Packets not successfully received by the access terminal (AT) to the number of FTAP or FETAP Test Packets sent to the AT by the test set. See Forward Test Application Protocol (FTAP) and Forward Enhanced Test Application Protocol (FETAP) .

To perform a packet error rate measurement, the test set sends an FTAP (when current physical layer subtype is subtype 0) or FETAP Test Packet (when current physical layer subtype is subtype 2) to the access terminal. See Release A Physical Layer Subtype to configure the physical layer subtype. Each packet contains 16 FCS (Frame Check Sequence) bit, which provide information about the packet. If the AT is able to decode the packet and the FCS checks (the information relayed by the FCS matches the packet characteristics), then the packet is successfully received.

The AT sends one or more FTAP or FETAP Loop Back Packets to the test set to indicate how many FTAP or FETAP Test Packets were successfully received for each 16-slot "observation interval" (frame). The AT sends one Loop Back Packet (or more, if needed to convey all of the records) containing a record for each FTAP or FETAP Test Packet in the observation interval. The Loop Back Packets are queued for transmission on the Reverse Traffic Channel, and the AT must provide buffering for at least 8 FTAP or FETAP Loop Back Packets. An FTAP or FETAP Loop Back Packet is generated even if no FTAP or FETAP Test Packets were received during the 16-slot observation interval.

In performing the PER measurement, the test set:

  • always operates with 100% packet activity (see Fixed Settings ). 100% packet activity means that all slots contain Forward Traffic Channel or Control Channel packets (data). The test set fills any empty slots with filler data directed to a random AT other than the AT under test. (0% packet activity means that the source is pulsed off when there is no data to transmit in the slot, and then pulsed on to transmit the MAC and Pilot Channels. This is not supported by the test set.)
  • always implements forced single encapsulation. Forced single encapsulation means that there is always only one valid MAC Packet per Physical Packet, regardless of the size of the Physical Packet. Depending upon data rate, the Physical Packet can be contain between 1 and 4 MAC Packets. If other MAC Packets are contained in the Physical Packet, they are loaded with all "F" data and the indicator bits are set to indicate that these packets are invalid.
  • by default, only directs half of the valid FTAP or FETAP Test Packets to the AT under test, as per C.S0033 specifications. ( AT Directed Packets is set to 50% by default. However this parameter may be adjusted to optimize PER throughput based on AT performance. If Limited TAP is on while Test Application Protocol is set to FTAP, AT Directed Packets must not be greater than 50%, and RTAP Rate must be set to 9.6 kbps.)

You must establish an FTAP (for Subtype 0 Physical Layer) or FETAP (for Subtype 2 Physical Layer) connection to perform packet error rate measurements (see Measuring Packet Error Rate (PER) for detailed procedure).

Confidence Level Testing

Confidence level testing is a feature of PER measurements that applies statistical analysis to PER measurements so that pass/fail test results can be obtained in the shortest possible time.

When confidence level is on, the PER measurement keeps track of the number of packets measured, the number of packet errors and performs a statistical analysis of the probability that the value entered in the PER requirement field will (or will not) be exceeded.

The confidence level parameter is typically set at 95%. With that setting, the PER measurement returns a pass result before the maximum packet count is reached if statistically there is a 95% probability that the percentage of packet errors will not exceed the PER requirement value if the measurement is allowed to reach the maximum packet count. The PER measurement returns a fail result before the maximum packet count is reached if statistically there is a 95% probability that the percentage of packet errors counted will exceed the PER requirement if the measurement is allowed to reach the maximum packet count. If the number of packet errors counted does not allow a reliable prediction of "pass" or "fail," the measurement continues until the number of packets tested equals max packets. "Max packets" and the PER percentage result are then returned.

If confidence level is off, the measurement always runs until the number of packets tested equals the specified maximum packets. "Max packets" and the PER percentage result are then returned.

During a fading test, the PER measurement must run for a sufficient length of time (the minimum number of packets) to allow fading statistics to average out (mean power standard deviation must be less than 0.2 dB). After the minimum number of packets have been measured, the statistical analysis is applied. This can prevent the PER measurement from failure too early due to power uncertainty. The early failure termination is not compatible with some tests (such as requiring faded signals) to achieve reliable results.

PER Measurement Parameters

  • Confidence State - Controls whether the confidence level will be used during the PER measurement. If confidence level is on, the PER measurement will continue until a pass/fail indication occurs, or until maximum packet count is reached. If confidence level is off, the PER measurement will run until maximum packet count is reached.
  • Confidence Level - Sets the required confidence level for the PER requirement (range is 80% to 99.99%).
  • PER Requirement - Sets the PER percentage that must not be exceeded for a "pass" result to be returned (range is 0.1% to 15%).
  • Minimum Packet Count - Sets the minimum number of packets (range is 0 to 10,000,000 frames) to be tested before applying the statistic analysis when the Confidence State is on. It does not apply when Confidence State is off. See Confidence Level Testing for details. The minimum packet count is required for some faded test as specified in the C.S0033 standard.
  • Maximum Packet Count - Sets the maximum number of packets to be counted during the PER measurement (range is 25 to 10,000,000 packets). If the number of packets tested reaches Maximum Packet Count, the measurement will stop.
  • Control Channel Data Rate
  • AT Directed Packets
  • Max Forward Packet Duration
  • Trigger Arm - (See Trigger Arm (Single or Continuous) Description ).
  • Timeout Time/State - Range is 0.1 to 266,667.0 seconds. (See Measurement Timeouts ).

PER Measurement Results

  • Integrity Indicator - (see Integrity Indicator ).
  • PER - ratio, in percent, of the packet error count to the number of packets tested.
  • Confidence Pass/Fail - indicates whether the measurement achieved confidence of failure or success, or whether maximum packet count was reached.
  • Packet Error Count - number of packets received with errors.
  • Packets Tested - number of packets tested.

Intermediate measurement results are periodically available on the front panel display, but are not available programmatically through the GPIB interface.

A typical display is shown below:

PER Input Signal Requirements

Input Signal Requirements

Key C.S0033 Tests Performed Using PER

3.2.1 Demodulation of Forward Traffic Channel in AWGN

3.2.2 Demodulation of Forward Traffic Channel in Multipath Fading Channel ( Lab Application Only )

3.3.1 Receiver Sensitivity and Dynamic Range

Related Topics

Manual Operation: Measuring Packet Error Rate (PER)

Programming a Packet Error Rate (PER) Measurement

Packet Error Rate Measurement Troubleshooting

Test Adherence to Standards

C.S0029 Test Application Specification Description (TAP/ETAP)


Channel Power Measurement Description

Channel Power Measurement Description

Last updated: June 16, 2006

  • How is a Channel Power Measurement Made?
  • Channel Power Measurement Parameters
  • Channel Power Measurement Results
  • Channel Power Input Signal Requirements
  • Key C.S0033 Tests Performed using the Channel Power Measurement
  • Calibrating the Channel Power Measurement

How is a Channel Power Measurement Made?

Channel power measurements are made by analyzing a digitized version of the input signal's downconverted IF using the test set's DSP (see Block Diagram ). The measurement triggers on the test set's internal ~1.667 ms slot clock. The measurement thus always starts at the beginning of a slot. Depending upon the Measurement Speed setting, the test set either measures the power over an entire slot or just the first 1/4 of the slot, and reports the average power. Because the measurement is triggered on the slot clock rather than the frame clock, any slot within the frame can be measured, increasing measurement speed. The measurement only measures power within a 1.23 MHz measurement bandwidth. The measurement is cross-calibrated with digital average power to determine the absolute power level. The result is given in dBm/1.23 MHz.

Channel Power Measurement Parameters

  • Multi-Measurement Count

    When ON, this enables averaging of multiple channel power results. For example, when multi-measurement count is set to 3, the test set calculates the average power in a slot, then calculates the average power in the next available slot, then calculates the average power in the next available slot. The test set then averages these 3 results, and reports the maximum and minimum results as well. (See Statistical Measurement Results ).

  • Trigger Arm - (see Trigger Arm (Single or Continuous) Description ).
  • Measurement Speed

    There are two channel power measurement speeds, Fast and Very Fast , which are determined by the signal sampling time.

    When measurement speed is set to Fast , the measurement triggers on the test set's internal ~1.667 ms slot clock and samples the input signal for 1 slot (1.667 ms).

    When the measurement speed is set to Very Fast , the measurement samples the input signal for 1/4 slot (0.3125 milliseconds) with immediate trigger.

    NOTE
    It is recommended to turn off other measurements if you expects to make the fast/very fast channel power measurements take as little time as possible. Turning on other measurements at the same time causes your measurements to run slower than expected. See Concurrent Measurements .

    GPIB command: SETup:CPOWer:MSPeed .

  • Timeout Time/State - (see Measurement Timeouts ).

Channel Power Measurement Results

  • Integrity Indicator - (see Integrity Indicator ).
  • Channel Power (in dBm/1.23 MHz). If Multi-Measurement Count is on, average, maximum and minimum channel power results are displayed on the measurement screen and available by remote program query.
  • The Expected Terminal Power (see Expected Power ) is also displayed on the measurement screen when either of the following conditions is met:
    • Current physical layer subtype is Subtype 0 (see Release A Physical Layer Subtype ), the receiver power control is set to auto and Test Application Protocol is set to RTAP.
    • Current physical layer subtype is Subtype 2 (see Release A Physical Layer Subtype ), the receiver power control is set to auto and Enhanced Test Application Protocol is set to RETAP.

An example measurement result display (for subtype 0 physical layer) is shown below:

An example measurement result display (for subtype 2physical layer) is shown below:

Channel Power Input Signal Requirements

Input Signal Requirements

Key C.S0033 Tests Performed using the Channel Power Measurement

4.3.5 Minimum Controlled Output Power

Calibrating the Channel Power Measurement

Refer to Calibrating the Test Set for a description of channel power calibration.

Related Topics

Manual Operation: Measuring Channel Power

Programming a Channel Power Measurement

Channel Power Measurement Troubleshooting

Test Adherence to Standards

C.S0029 Test Application Specification Description (TAP/ETAP)


TX Spurious Emissions Measurement Description

TX Spurious Emissions Measurement Description

  • How is a TX Spurious Emissions Measurement Made?
  • TX Spurious Emissions Measurement Parameters
  • TX Spurious Emissions Measurement Results
  • TX Spurious Emissions Input Signal Requirements
  • Key C.S0033 Tests Performed using the TX Spurious Emissions Measurement
  • Calibrating the TX Spurious Emissions Measurement

How is a TX Spurious Emissions Measurement Made?

TX Spurious Emissions is a measure of the access terminal's transmission at frequencies outside its assigned channel.

The test set's TX Spurious Emissions measurement is made by first making a channel power measurement centered on the assigned channel, to determine carrier power. The test set then measures the power at four frequencies offset from the center of the assigned channel. The test set measures the average power present at each frequency offset, over a slot, within a 30 kHz filter centered on the offset frequency. The test set then reports the power of each frequency offset relative to the carrier power (the result is given in dBc).

The four frequency offsets at which power is measured depends upon the AT band class:

  • Frequency offsets for band classes 1, 4, and 6:
    • ± 885 kHz (lower and upper adjacent channels)
    • ± 1.98 MHz (lower and upper alternate channels)
  • Frequency offsets for band classes 0, 3, 5, and 9:
    • ± 1.25 MHz (lower and upper adjacent channels)
    • ± 1.98 MHz (lower and upper alternate channels)

The measurement triggers on the test set's internal ~1.667 ms slot clock.

You must establish an RTAP (for Subtype 0 Physical Layer) or RETAP (for Subtype 2 Physical Layer) connection to perform the TX spurious emissions measurement (see Measuring TX Spurious Emissions for detailed procedure).

TX Spurious Emissions Measurement Parameters

  • Mask Control: When set to auto, the pass/fail limits for the spurious emissions at the adjacent and alternate channels are set as specified by C.S0033 3.1.2.4.1. When set to manual, you can set the pass/fail limits for the measurement. Separate pass/fail limits are provided for the adjacent and alternate channel measurements.
  • Adjacent Limit (in dBc): Sets the pass/fail limit for the adjacent channel measurement (range is -65 to -10 dBc).
  • Alternate Limit (in dBc): Sets the pass/fail limit for the alternate channel measurement (range is -65 to -10 dBc).
  • Multi-Measurement Count - When ON, this enables averaging of the TX spurious emissions results. (See Statistical Measurement Results ).
  • Trigger Arm - (see Trigger Arm (Single or Continuous) Description ).
  • Timeout Time/State - (see Measurement Timeouts ).

TX Spurious Emissions Measurement Results

  • Integrity Indicator - (see Integrity Indicator ).
  • Pass/Fail Result: An overall pass/fail indicator is displayed on the measurement screen and is available via GPIB commands (see FETCh:CTXSpurious:MASK[:FAIL]? ). The pass/fail result indicates whether the spurious emissions for all adjacent and alternate channels are within limits.
  • Spurious Emissions for Adjacent and Alternate Channels: The test set returns the spurious emissions levels for all adjacent and alternate channels. These spurious emissions levels are available from the measurement screen marker and via GPIB commands (see FETCh:CTXSpurious<[:ALL]|:INTegrity>? ).

The TX Spurious Emissions Measurement Screen

The TX Spurious Emissions measurement screen can display numeric results or a graphical display.

  • The y-axis on the graphical display is fixed at -80 dBc/30 kHz to 0 dBc/30 kHz.
  • The x-axis on the graphical display is fixed at -2.5 MHz to 2.5 MHz relative to the carrier frequency.
  • Pass/fail limit lines are shown in green on the graphical display. These lines are set based on Mask Control and Adjacent/Alternate Limit (see TX Spurious Emissions Measurement Parameters ). If spurious emissions at any adjacent or alternate channel exceed a limit line, the word Fail appears on the display.
  • The carrier is displayed in the center of the display as a solid yellow bar. The spurious emissions power at the four frequency offsets is displayed as yellow bars.
  • The marker can be positioned on each of the four frequency offsets. The spurious emissions for that frequency offset is then displayed.

TX Spurious Emissions Input Signal Requirements

Input Signal Requirements

Key C.S0033 Tests Performed using the TX Spurious Emissions Measurement

  • 4.4.1 Conducted Spurious Emissions

Calibrating the TX Spurious Emissions Measurement

The TX spurious emissions measurement is automatically calibrated during a channel power calibration. Follow the channel power calibration schedule and the TX spurious emissions measurement will be properly calibrated. Refer to Calibrating the Test Set for a description of channel power calibration.

Related Topics

Manual Operation: Measuring TX Spurious Emissions

Programming a Tx Spurious Emissions Measurement

Tx Spurious Emissions Measurement Troubleshooting

Test Adherence to Standards

C.S0029 Test Application Specification Description (TAP/ETAP)


Digital Average Power Measurement Description

Digital Average Power Measurement Description

Last updated: June 16, 2006

  • How is a Digital Average Power Measurement Made?
  • Digital Average Power Measurement Parameters
  • Digital Average Power Measurement Results
  • Digital Average Power Input Signal Requirements
  • Key C.S0033 Tests Performed using the Digital Average Power Measurement
  • Calibrating the Digital Average Power Measurement

How is a Digital Average Power Measurement Made?

Digital average power measurements are broadband power measurements made directly on the RF input (the signal is not downconverted in frequency, see Block Diagram ). The input waveform is detected by a true average power detector. The test set's digital signal processor (DSP) then determines the average power of the signal over a 10 ms measurement period (6 slots).

The measurement triggers on the test set's internal ~1.667 ms slot clock. The result is reported in dBm.

The digital average power measurement has a bandwidth of approximately 4 GHZ. For this reason, significant signal energy outside the 1.23 MHz access terminal transmit bandwidth will increase the measured value.

Digital Average Power Measurement Parameters

  • Multi-Measurement Count - (See Statistical Measurement Results ).
  • Trigger Arm - (see Trigger Arm (Single or Continuous) Description ).
  • Timeout Time/State - (see Measurement Timeouts ).

Digital Average Power Measurement Results

  • Integrity Indicator - (see Integrity Indicator ).
  • Digital Average Power (in dBm).
  • The Expected Terminal Power (see Expected Power ) is also displayed on the measurement screen when either of the following conditions is met:
    • Current physical layer subtype is Subtype 0 (see Release A Physical Layer Subtype ), the receiver power control is set to auto and Test Application Protocol is set to RTAP.
    • Current physical layer subtype is Subtype 2 (see Release A Physical Layer Subtype ), the receiver power control is set to auto and Enhanced Test Application Protocol is set to RETAP.

An example measurement result display (for subtype 0 physical layer) is shown below:

An example measurement result display (for subtype 2 physical layer) is shown below:

Digital Average Power Input Signal Requirements

Input Signal Requirements

Key C.S0033 Tests Performed using the Digital Average Power Measurement

  • 4.3.4 Maximum RF Output Power

Calibrating the Digital Average Power Measurement

Refer to Calibrating the Test Set for a description of digital average power calibration.

Related Topics

Manual Operation: Measuring Digital Average Power

Programming a Digital Average Power Measurement

Digital Average Power Troubleshooting

Test Adherence to Standards

C.S0029 Test Application Specification Description (TAP/ETAP)


Waveform Quality + Code Domain Measurement Description

Waveform Quality + Code Domain Measurement Description

Last Updated: June 16, 2006

  • How is a Waveform Quality + Code Domain Measurement Made?
    • Operating Considerations
  • Waveform Quality + Code Domain Measurement Parameters
  • Waveform Quality + Code Domain Measurement Results
    • Waveform Quality Measurement Results
    • Code Domain Power:
      • Code Domain Power Measurement Results Available from the Measurement Screen
      • Code Domain Power Measurement Results Available Programmatically
    • Code Domain Power + Noise:
      • Code Domain Power + Noise Measurement Results Available from the Measurement Screen
      • Code Domain Power + Noise Measurement Results Available Programmatically
  • Waveform Quality + Code Domain Input Signal Requirements
  • Key C.S0033 Tests Performed Using the Waveform Quality + Code Domain Measurement
  • Calibrating the Waveform Quality + Code Domain Measurement
  • Background Information:
    • Relationship Between Spread Factors and Walsh Code Space

How is a Waveform Quality + Code Domain Measurement Made?

Waveform quality is the basic measure of the performance of a CDMA transmitter. Waveform quality provides information on how well the access terminal's signal matches the ideal signal.

The test set's waveform quality measurement is made by sampling (on a slot-by-slot basis) the AT transmitter down-converted input signal, then applying DSP (Digital Signal Processing) techniques to determine the original data input to the access terminal transmitter's Walsh spreading function for each channel. The DSP then generates a representation of what the "ideal" signal would be given the coding and data in use at the time of transmission. The ideal waveform is then compared with the measured waveform to determine the waveform quality.

Code domain power determines the power in each Walsh code of the access terminal's signal. This allows you to determine how the power is distributed in the access terminal's signal.

The test set's code domain measurements are made by decoding each Walsh code in the access terminal's signal using a Walsh code correlation algorithm. This algorithm measures the waveform correlation factor for each Walsh code. Once the channels are decoded, the power in each code channel is determined.

The waveform quality + code domain measurement returns two sets of results: waveform quality results and code domain results. When you initiate the waveform quality + code domain measurement, both sets of results are always determined, you do not need to initiate them individually (saving you measurement time). The measurement triggering occurs on the test set's internal ~26.667 ms frame clock (the measurement always begins at the start of a frame).

Operating Considerations

You must establish an RTAP ( for subtype 0 physical layer ) or RETAP ( for subtype 2 physical layer ) connection prior to making the waveform quality + code domain measurements. For detailed manual procedure, see Measuring Waveform Quality + Code Domain Power .

Waveform Quality + Code Domain Measurement Parameters

  • Slots to Measure - Sets the number of contiguous slots that are sampled during the waveform quality + code domain measurement. It can be set to any integer from 1 to 8 slots ( for subtype 0 physical layer ) or 1 to 4 slots ( for subtype 2 physical layer ). The returned measurement result indicates the average result over the specified slots.

    C.S0033 specifications require that all code domain power measurements acquire 1.66... ms (1 slot) of active data for each channel involved in the calculation. Because not all channels are active for an entire slot, code domain measurements often must acquire data for several slots to compile 1.66... ms of active data for the channels under test. For example, for any subtype 0 physical layer code domain tests involving the power in the R-Pilot channel, the measurement must obtain data from 2 slots, since the R-Pilot channel is only active for 7/8 of a slot.

    According to the duty cycle of each channel (percentage of active time during a slot) (see Subtype 0 Reverse Channel Summary and Subtype 2 Reverse Channel Summary respectively), the recommended Slots to Measure settings are thus as follows:

    Recommended Slots to Measure Settings
    C.S0033-A Test

    Description

             Recommended Slots to Measure Setting
    Subtype 0 Physical Layer Subtype 2 Physical Layer

    4.1.2 Frequency Accuracy

             1 1

    4.2.1 Time Reference

             1 1

    4.2.2 Waveform Quality and Frequency Accuracy

             1 1
    4.3.7 RRI Channel Output Power

    This test compares the R-RRI Channel power to the R-Pilot Channel power.

    8 (Because the RRI Channel is only active for 1/8 of a slot and the R-Pilot Channel is only active for 7/8 of a slot, you must set Slots to Measure to at least 8 for this test.)

    1 (Because both the R-RRI and R-Pilot channels are active for full slot, you can set Slots to Measure to at least 1 for this test.)

    4.3.8.1 DRC Channel Output Power

    This test compares the R-DRC Channel power to the R-Pilot Channel power.

             2 (Because the DRC Channel is active for full slot and the R-Pilot Channel is only active for 7/8 of a slot, you must set Slots to Measure to at least 2 for this test.) 1 (Because both the DRC and R-Pilot channels are active for full slot, you can set Slots to Measure to at least 1 for this test.)

    4.3.8.2 ACK Channel Output Power

    This test compares the R-ACK Channel power to the R-Pilot Channel power.

            2 (Because the R-ACK Channel is only active for 1/2 of a slot and the R-Pilot Channel is only active for 7/8 of a slot, you must set Slots to Measure to at least 2 for this test.) 2 (Because the R-ACK Channel is only active for 1/2 of a slot and the R-Pilot Channel is active for full slot, you must set Slots to Measure to at least 2 for this test.)

    4.3.8.3 Data Channel Output Power
    (Tests 1-4, 6-10)

    These tests compare the R-Data Channel power to the R-Pilot Channel power.

    2 (Because the R-Data channel is active for full slot and the R-Pilot Channel is only active for 7/8 of a slot, you must set Slots to Measure to at least 2 for these tests.)

    1 (Because Both the R-Data and R-Pilot channels are active for full slot, you can set Slots to Measure to at least 1 for these tests.)

    4.3.8.4 DSC Channel Output Power

    This test compares the R-DSC Channel power to the R-Pilot Channel power.

            Not applicable 2 (Because the R-DSC Channel is only active for 1/2 of a slot and the R-Pilot Channel is active for full slot, you must set Slots to Measure to at least 2 for this test.)

    4.3.8.3 Data Channel Output Power
    (Test 5)

             This test compares the inactive channel power to the total power. 1 (This test measures the power in the inactive channels relative to total power. There is no comparison to R-Pilot power, so Slots to Measure can be set to 1 for this test.) 1 (This test measures the power in the inactive channels relative to total power.)

  • Multi-Measurement Count - Sets the number of times the measurement will be performed. Each measurement begins on the next available frame boundary (it must wait for the previous measurement to complete, then it begins on the next available frame boundary). When all of the measurements have been performed, the average, minimum, maximum and standard deviation of the results are returned for waveform quality (standard deviation is only available programmatically), only average result is returned for code domain.
    For example, if Slots to Measure is set to two and Multi-Measurement Count is set to four:
    1. Two contiguous slots are measured and averaged
    2. On the next available frame boundary, two contiguous slots are measured and averaged.
    3. On the next available frame boundary, two contiguous slots are measured and averaged.
    4. On the next available frame boundary, two contiguous slots are measured and averaged.
    5. The results of steps 1-4 are averaged and reported.

    (See Statistical Measurement Results ).

  • Ack Channel Gain - (see ACK Channel Gain )
  • DRC Channel Gain - (see DRC Channel Gain )
  • DSC Channel Gain ( only available for subtype 2 physical layer ) - (see DSC Channel Gain )
  • Trigger Arm - (see Trigger Arm (Single or Continuous) Description ).
  • Timeout Time/State - (see Measurement Timeouts ).

Waveform Quality + Code Domain Measurement Results

  • Integrity Indicator - (see Integrity Indicator ).
  • Waveform Quality Measurement Results
  • Code Domain Power Measurement Results Available from the Measurement Screen
  • Code Domain Power Measurement Results Available Programmatically
  • Code Domain Power + Noise Measurement Results Available from the Measurement Screen
  • Code Domain Power + Noise Measurement Results Available Programmatically

Waveform Quality Measurement Results

The waveform quality (numeric rho) measurement returns:

  • Multi-Code Rho: The fraction of signal energy that correlates with an ideal signal after time offset and frequency error have been removed. Range is 0.0000 to 1.0000, with 1 being a perfectly correlated signal.
  • Frequency Error (in Hz): Measure of how accurately the access terminal is transmitting at its assigned center frequency.
  • Time Error (in µs on measurement screen, in s programmatically): Measure of how accurately the access terminal has aligned its timing to the pilot signal broadcast from the test set.
  • Carrier Feedthrough (in dBc): The ratio of the movement away from the origin of the constellation of the transmitted signal to the unit circle magnitude of the constellation (measure of I/Q modulator DC offsets).
  • Phase Error (in degrees): The root-mean-square sum of the phase components of each of the error vectors included in the EVM calculation, expressed in degrees (rms phase difference between the ideal and actual signal).
  • Magnitude Error (in %): The ratio of the root-mean-square sum of the magnitude components of each of the error vectors included in the EVM calculation to the unit circle magnitude of the signal vector (rms amplitude difference between the ideal and actual signal).
  • Error Vector Magnitude (EVM) (in %): The ratio of the root-mean-square sum of the magnitude of each of the error vectors to the unit circle magnitude of the signal vector.
  • Payload Size (in bits): ( Only available for subtype 2 physical layer )
    It indicates the R-Data payload size that the test set detects from the R-RRI channel (R-RRI channel carries the payload size and sub-packet identifier information). The test set uses the detected payload size to demodulate the R-Data channel. Payload Size can be queried with the FETCh:DOWQuality:PAYLoad? .

    The R-Data packet size determines the modulation format, walsh codes and spread factor of the R-Data channel, as shown in the table below.

    Subtype 2 R-Data Packet Size, Modulation Type and Walsh Codes

    R-Data Packet Size (bits)

    R-Data Modulation Type

    Modulation Name

    Spreading Factor (SF)

    Walsh Code

    Duty Cycle

    128, 256, 512, 768 or 1024

    B4

    BPSK

    4

    Q:2

    Full slot

    1536 or 2048

    Q4

    QPSK

    4

    Q:2

    Full slot

    4

    I:2

    Full slot

    3072 or 4096

    Q2

    QPSK

    2

    Q:1

    Full slot

    2

    I:1

    Full slot

    6144 or 8192

    Q4Q2

             QPSK

    4

    Q:2

    Full slot

    4

    I:2

    Full slot

    2

    Q:1

    Full slot

    2

    I:1

    Full slot

    12288

    E4E2

    8-PSK

    4

    Q:2

    Full slot

    4

    I:2

    Full slot

    2

    Q:1

    Full slot

    2

    I:1

    Full slot

    NOTE
    For subtype 0 physical layer, the waveform quality + code domain measurement always uses the RTAP Rate parameter to demodulate R-Data channel. So when the specified R-Data data rate is different from the actual R-Data data rate, the measurement results are incorrect. For example, the measurement can be accessed in FTAP and Default Packet Application connection where the results look good but should not be used because the actual R-Data date rate does not match the specified value.

    Instead of using the specified R-Data Pkt Size , the subtype 2 waveform quality + code domain measurement uses the actual payload size detected from the R-RRI channel (R-RRI channel carries the payload size and sub-packet identifier information) to demodulate the R-Data channel. The results reflect the current reverse link data signal.

A typical waveform quality measurement result is shown below:

Code Domain Power Measurement Results Available from the Measurement Screen

The Code Domain Power measurement displays the power and noise levels of reverse code channels. Two measurement results screen are available for Code Domain Power.

  • Code Domain Power Graphical Display
  • Code Domain Power Tabular Data

An example display for the Code Domain Power measurement results for subtype 0 physical layer is shown as below.

Code Domain Power Graphical Display

  • The x axis always has a resolution of 16 walsh codes (corresponding to the spreading factor (SF) 16 for subtype 0 physical layer ) or 32 walsh codes (corresponding to the SF 32 for subtype 2 physical layer ).

    Note that the Walsh codes are not displayed in sequential order of 0 to 15 or 0 to 31, but rather in bit reversed order (see Bit reversal ). This ordering allows for a reverse channel occupying more walsh codes grouped together to form one contiguous wide bar (called a bin) on the display. As shown in the figure above, Q:2 SF16 , Q:10 SF16 , Q:6 SF16 , and Q:14 SF16 constitute subtype 0 R-Data (Q:2 SF4 ). See also Subtype 0 Reverse Channel Walsh Code Distribution .

  • The height of the histogram bars indicates power level on that walsh code. A red histogram bar indicates that the Walsh code is active. A yellow bar indicates that the Walsh code is inactive (noise).

  • Marker: A marker can be positioned on any of the 16 or 32 Walsh codes and it applies to both the I and the Q graphs simultaneously. When the marker is positioned on a single walsh code, the power of that walsh code is displayed in dB. For example, for subtype 0 physical layer, if you select Walsh code I:4, the power in I:4 SF16 is displayed. In subtype 2 physical layer, if you select Walsh code I:4, the power in I:4 SF32 is displayed.

    The maker power (in dB) is the average power in the Walsh code integrated over a slot, divided by the total power in all of the Walsh codes during the same slot. This power level includes any desired signal as well as noise present in the selected Walsh code (SF = 16 or 32).

    For a reverse channel occupying more than one SF 16 or 32 walsh codes, the test set measures the power in all of the Walsh codes for that reverse channel, then determines and reports the average power present in each of the Walsh codes for that reverse channel. For example, for subtype 0 physical layer, the R-ACK channel (I:4 SF8 ) encompasses both I:4 SF16 and I:12 SF16 . The test set thus measures the power in I:4 SF16 and I:12 SF16 , then divides by 2 to determine the average power in each of these Walsh codes. The marker powers reported for Walsh codes I:4 SF16 and I:12 SF16 are thus always identical.

  • Bin Delta Pilot ( only available for subtype 2 physical layer R-Data channel )

    For the subtype 2 physical layer, the R-Data channel may comprise one, two or four walsh channels (I:2 SF=4 , Q:2 SF=4 , I:1 SF=2 , Q:1 SF=2 , see Subtype 2 R-Data Packet Size, Modulation Type and Walsh Codes for details). When you place a marker on a walsh code belonging to any of the walsh channel of R-Data channel, the Bin [image] Pilot result (normalized total code domain power of the walsh channel relative to R-Pilot) is also displayed following the Marker power result. For details on how this result is derived, see Delta Pilot (Normalized Total CDP Relative to R-Pilot) . This new result is required for the R-Data code domain power test as defined in the C.S0033-A 4.8.3.3.

    The figure below is an example display for subtype 2 physical layer R-Data channel (with R-Data packet size of 6144 bits) assigned with I:2 SF=4 , Q:2 SF=4 , I:1 SF=2 and Q:1 SF=2 walsh channels.

Code Domain Power Tabular Data

The table below the graph provides code domain power measurement results for each of the reverse channels. The subtype 0 reverse channels include R-Pilot, R-RRI, R-DRC, R-ACK and R-Data and subtype 2 reverse channels include R-Pilot, R-Aux Pilot R-RRI, R-DSC, R-DRC, R-ACK and R-Data. For details, see Reverse Channel Overview .

The measurement results are as follows:

  • Walsh

    This column reports whether the channel resides on I or Q, and at what Walsh code.
    Note: For subtype 2 physical layer, the modulation type of the R-Data is displayed here which indirectly determines the I/Q channel, Walsh code and spreading factor (SF) being used. For example, Q4Q2 indicates QPSK modulation with both a 4 bit (SF=4) and a 2 bit (SF=2) walsh code for spreading, applied to both I and Q channels. This results in R-Data encompassing I:2 SF=4 , Q:2 SF=4 , I:1 SF=2 and Q:1 SF=2 walsh channels. For details, see Subtype 2 R-Data Packet Size, Modulation Type and Walsh Codes .

  • SF (Spread Factor)

    This column indicates the spread factor of the channel. It also indicates the length of the Walsh code (For example, spread factor 8 indicates the Walsh code is 8 digits in length).

    For subtype 2 physical layer, the SF for R-Data with modulation type other than B4 is not displayed because R-Data may be assigned to more than one walsh channels with different SF (see Subtype 2 R-Data Packet Size, Modulation Type and Walsh Codes for details).

    Note that the SF of the channel affects its bar width displayed on the graph. For subtype 0 physical layer, if the channel has a SF of 16, 8 or 4, it will occupy 1, 2, or 4 of the total 16 bars, respectively. For subtype 2 physical layer, if the channel has a SF of 32, 16, 8, 4 or 2, it will occupy 1, 2, 4, 8 or 16 of the total 32 bars, respectively. For details, see Relationship Between Spread Factors and Walsh Code Space .

  • CDP (Code Domain Power)

    This column indicates the average power in one of the channels' walsh code over a slot, divided by the total power in all of the Walsh codes during the same slot. It may not equal to the Marker power if the channel is not transmitted at full slot. See the following table for details.

    Code Domain Power (CDP)
    Channel Subtype 0 Physical Layer Subtype 2 Physical Layer

    R-Pilot

    The test set measures the power in Walsh code I:0 SF16 during the last 7/8 of the slot. Since the power in the first 1/8 of the slot contains the R-RRI transmission, the test set sets this power to zero. It then averages this power distribution over the entire slot and divides by the total power in all of the Walsh codes during the same slot.

    If you add the values for R-Pilot and R-RRI CDP, the result is equal to the Marker Power for Walsh code I:0 SF16 .

    R-Pilot channel (I:0 SF16 ) encompasses both I:0 SF32 and I:16 SF32 . The test set measures the power in Walsh codes I:0 SF32 and I:16 SF32 and divides by the total power in all of the Walsh codes during the same slot. The test set then divides this result by 2 and thus reports the average power for one spread factor 32 Walsh code of the R-Pilot channel.

    Because R-Pilot is transmitted over an entire slot, this result is equal to the Marker Power for any of the Walsh codes I:0 SF32 and I:16 SF32 .
    R-RRI

    The test set measures the power in Walsh code I:0 SF16 during the first 1/8 of the slot. Since the power in the last 7/8 of the slot contains the R-Pilot transmission, the test set sets this power to zero. It then averages this power distribution over the entire slot, and divides by the total power in all of the Walsh codes during the same slot.

    If you add the values for R-Pilot and R-RRI CDP, the result is equal to the Marker Power for Walsh code I:0 SF16 .

    R-RRI channel (I:4 SF16 ) encompasses both I:4 SF32 and I:20 SF32 . The test set measures the power in Walsh codes I:4 SF32 and I:20 SF32 and divides by the total power in all of the Walsh codes during the same slot. The test set then divides this result by 2 and thus reports the average power for one spread factor 32 Walsh code of the R-RRI channel.

    Because R-RRI is transmitted over an entire slot, this result is equal to the Marker Power for any of Walsh codes I:4 SF32 and I:20 SF32 .

    R-DRC

    The test set measures the power in Walsh code Q:8 SF16 and divides by the total power in all of the Walsh codes during the same slot.

    Because R-DRC is transmitted over an entire slot, this result is equal to the Marker Power for Walsh code Q:8 SF16 .

    R-DRC channel (Q:8 SF16 ) encompasses both Q:8 SF32 and Q:24 SF32 . The test set measures the power in Walsh codes Q:8 SF32 and Q:24 SF32 and divides by the total power in all of the Walsh codes during the same slot. The test set then divides this result by 2 and thus reports the average power for one spread factor 32 Walsh code of the R-DRC channel.

    Because R-DRC is transmitted over an entire slot, this result is equal to the Marker Power for any of the Walsh codes Q:8 SF32 and Q:24 SF32 .
    R-ACK

    R-ACK channel (I:4 SF8 ) encompasses both I:4 SF16 and I:12 SF16 (see Subtype 0 Reverse Channel Walsh Code Distribution ). The test set measures the power in Walsh codes I:4 SF16 and I:12 SF16 during the first 1/2 of the slot. Since the R-ACK doesn't transmit during the second 1/2 of the slot, the test set sets this power to zero. It then averages this power distribution over the entire slot, and divides by the total power in all of the Walsh codes during the same slot. The test set then divides this result by 2 and thus reports the average power for one spread factor 16 Walsh code of the R-ACK channel.

    Ideally this value is equal to the Marker Power for Walsh code I:4 SF16 or I:12 SF16 (They will only be equal if the power in Walsh code I:4 SF16 or I:12 SF16 during the second 1/2 of the slot is zero. If there is noise, or some of the R-ACK transmission occurs in the second 1/2 of the slot, then that power will not be measured and included in the CDP result. However the marker power will include this power, since it does not assume the power in the second 1/2 of the slot is zero, but actually measures it.)

    The test set measures the power in Walsh code I:12 SF32 during the first half of the slot. Since the power in the last half of the slot contains the R-DSC transmission, the test set sets this power to zero. It then averages this power distribution over the entire slot and divides by the total power in all of the Walsh codes during the same slot.

    If you add the CDP values for R-ACK and R-DSC, the result is equal to the Marker Power for Walsh code I:12 SF32 .

    R-Data

    R-Data channel (Q:2 SF4 ) encompasses the Q:2 SF16 , Q:6 SF16 , Q:10 SF16 and Q:14 SF16 (see Subtype 0 Reverse Channel Walsh Code Distribution ). The test set measures the power in Walsh codes Q:2 SF16 , Q:6 SF16 , Q:10 SF16 and Q:14 SF16 and divides by the total power in all of the Walsh codes during the same slot. The test set then divides this result by 4 and thus reports the average power for one spread factor 16 Walsh code of the R-Data channel.

    Because R-Data is transmitted over an entire slot, this result is equal to the Marker Power for any of the Walsh codes Q:2 SF16 , Q:6 SF16 , Q:10 SF16 and Q:14 SF16 .

    The walsh channels allocated to R-Data channel varies based on the R-Data modulation type (see Subtype 2 R-Data Packet Size, Modulation Type and Walsh Codes ). The R-Data channel may consist of 1, 2, or 4 walsh channels:

    • Q:2 SF4 for B4 modulation
    • Q:2 SF4 and I:2 SF4 for Q4 modulation
    • Q:1 SF2 and I:1 SF2 for Q2 modulation
    • Q:2 SF4 , I:2 SF4 , Q:1 SF2 and I:1 SF2 for Q4Q2 or E4E2 modulation

    The test set measures the code domain power for each of the walsh channels allocated to the R-Data channel. There may have 1, 2, or 4 CDP values. The R-Data CDP value is only displayed for B4 modulation (Q:2 SF4 ). In all other cases, the CDP values are not displayed but used for calculating the total CDP value.

    R-DSC

             Not applicable.

    The test set measures the power in Walsh code I:12 SF32 during the last half of the slot. Since the power in the first half of the slot contains the R-ACK transmission, the test set sets this power to zero. It then averages this power distribution over the entire slot and divides by the total power in all of the Walsh codes during the same slot.

    If you add the values for R-ACK and R-DSC CDP, the result is equal to the Marker Power for Walsh code I:12 SF32 .
    R-Aux Pilot Not applicable.

    The test set measures the power in Walsh code I:28 SF32 and divides by the total power in all of the Walsh codes during the same slot.

    Because R-Aux Pilot is transmitted over an entire slot, this result is equal to the Marker Power for Walsh code I:28 SF32 .

    Note that the R-Auxiliary Pilot channel may not be transmitted. See Auxiliary Pilot Channel Min Payload for details.

  • Total CDP (Total Code Domain Power)

    This column indicates the total power in the channel. It is derived mathematically from the CDP column, by multiplying CDP value for each channel by the base SF 16 or 32 and dividing by the SF of the particular channel. So the channel's Total CDP (dB) = CDP (dB) + 10log(Base SF)/SF ch ).
    For subtype 2 physical layer, R-Data using modulation type other than B4 may comprise two or four walsh channels. The total CDP value for each walsh channel of the R-Data should be converted according to the above formula, then added together to obtain the Total CDP for the R-Data channel. (Note that the interim results, total CDP for each walsh channel of the R-Data, are also used for deriving the Bin [image] Pilot result for that walsh channel of R-Data, see Bin Delta Pilot (only available for subtype 2 physical layer R-Data channel) .)

    Total CDP Calculation

    Reverse Channel

    Subtype 0 Physical Layer

    (Base SF = 16)

    Subtype 2 Physical Layer

    (Base SF = 32)

    Spread Factor

             Value to Add to CDP
    10log(Base SF/SF ch ) dB

    Spread Factor

             Value to Add to CDP
    10log(Base SF/SF ch ) dB

    R-Pilot

    16

    0 dB

    16

    3.01 dB

    R-RRI

    16

    0 dB

    16

    3.01 dB

    R-DRC

    16

    0 dB

    16

    3.01 dB

    R-ACK

    8

    3.01 dB

    32

    0 dB

    R-Data

    4

    6.02 dB

    Modulation type dependent (see Subtype 2 R-Data Packet Size, Modulation Type and Walsh Codes )

    Q:2 SF=4 : add 9.03 dB
    I:2 SF=4 : add 9.03 dB
    Q:1 SF=2 : add 12.04 dB
    I:1 SF=2 : add 12.04 dB

    R-DSC

    Not applicable.

    32

    0 dB

    R-Aux Pilot

    Not applicable.

    32

    0 dB
  • Norm Total (Normalized Total Code Domain Power)

    This column is derived mathematically from the Total CDP column, normalizing the power according to the channel's duty cycle (the fraction of a slot that the channel is transmitting). It multiplies the channel's Total CDP by 1 slot and divides by the channel's duty cycle. So the channel's Norm Total CDP (dB) = Total CDP (dB) + 10log(1/Duty Cycle ch )
    The Norm Total result is equal to the total CDP if the channel's duty cycle is full slot. For example, regardless of the type of the physical layer subtype, the R-Data and R-DRC channes are always transmitted at full slot. So the Norm Total results for the R-Data and R-DRC equal to their Total CDP results.

    Normalized Total CDP Calculation

    Reverse Channel

    Subtype 0 Physical Layer

    Subtype 2 Physical Layer

    Duty Cycle
    (Slot)

             Value to Add to Total CDP
    10log(1 /Duty Cycle) dB

    Duty Cycle
    (Slot)

             Value to Add to Total CDP
    10log(1 /Duty Cycle) dB

    R-Pilot

    7/8

    0.58 dB

    1

    0 dB

    R-RRI

    1/8

    9.03 dB

    1

    0 dB

    R-DRC

    1

    0 dB

    1

    0 dB

    R-ACK

    1/2

    3.01 dB

    1/2

    3.01 dB

    R-Data

             1

    0 dB

    1

    0 dB

    R-DSC

    Not applicable.

    1/2

    3.01 dB

    R-Aux Pilot

    Not applicable.

    1

    0 dB
  • Delta Pilot (Normalized Total CDP Relative to R-Pilot)

    The [image] Pilot column compares the Norm Total power of each reverse channel to the Norm Total power of the R-Pilot Channel. It is derived mathematically from the Norm Total column by subtracting the R-Pilot Norm Total power (in dB), from each reverse channel's Norm Total power (in dB). The [image] Pilot results for each reverse channel is required by the code domain power tests as defined in the C.S0033-A test standard (see Key C.S0033 Tests Performed Using the Waveform Quality + Code Domain Measurement ).

    For subtype 2 physical layer, the R-Data channel may comprise one, two or four walsh channels. The R-Data code domain power test as defined in the C.S0033-A 4.8.3.3 not only requires the R-Data [image] Pilot result but also the [image] Pilot results for each walsh channel of R-Data channel. The [image] Pilot results for each walsh channel of R-Data channel is derived by substracting the R-Pilot Norm Total power (in dB), from each walsh channel's Norm Total power (in dB) of R-Data channel. The [image] Pilot results for each walsh channel of R-Data channel can be viewed by placing a marker on the walsh channel belonging to the R-Data channel (see Bin Delta Pilot (only available for subtype 2 physical layer R-Data channel) ).

    Normalized Total CDP Relative to R-Pilot (dB)

    Reverse Channel

    Subtype 0 Physical Layer

    Subtype 2 Physical Layer

    R-Pilot

    This value is always 0 dB.

    R-RRI

    Ideally, this value should equal 0 dB because the R-RRI power level should be transmitted at the same power level as the R-Pilot

    Ideally, this value should equal Current RRI Channel Gain Pre-Transition or Post-Transition (see RRI Gain Parameters ).

    R-DRC

    Ideally, this value should equal DRC Channel Gain (see DRC Channel Gain )

    Ideally, this value should equal DRC Channel Gain (see DRC Channel Gain )

    R-ACK

    Ideally, this value should equal ACK Channel Gain (see ACK Channel Gain ).

    Ideally, this value should equal ACK Channel Gain (see ACK Channel Gain ).

    R-Data

    Ideally, this value should equal Data Offset Nom + Data Offset <rate> + Data Channel Gain (see Expected Power ).

    Ideally, this value should equal Current TxT2P Pre-Transition or Post-Transition (see Expected Power ).

    R-DSC

    Not applicable.

    Ideally, this value should equal DSC Channel Gain (see DSC Channel Gain ).

    R-Aux Pilot

    Not applicable.

    Ideally, this value should equal Auxiliary Pilot Channel Gain + [image] Pilot value of R-Data (see Expected Power ).

Code Domain Power Measurement Results Available Programmatically

From the measurement screen, you can obtain code domain power results from the graphical display and from the tabular data below it. Similarly, there are two groups of commands for obtaining code domain power results programmatically.

  • Code Domain Power Measurement Results Available for Each Reverse Channel - similar to the tabular data on the measurement screen
  • Code Domain Power Measurement Results Available by Numbered Bins - similar to the graphical display results on the measurement screen

Code Domain Power Measurement Results Available for Each Reverse Channel

The code domain power measurement results can be queried by using the commands that refer to code channels by name. The returned results for each code channel are similar to those available from the tabular display on the measurement result screen (see Code Domain Power Tabular Data ).

  • FETCh:DOWQuality:CDPower:PILot[:REVerse]?
  • FETCh:DOWQuality:CDPower:ACKChannel[:REVerse]?
  • FETCh:DOWQuality:CDPower:RRIChannel[:REVerse]?
  • FETCh:DOWQuality:CDPower:DRCChannel[:REVerse]?
  • FETCh:DOWQuality:CDPower:DATA[:REVerse]?
  • FETCh:DOWQuality:CDPower:DATA[:REVerse]:RTPilot? (only useful for subtype 2 physical layer when querying the code domain power of each walsh channel of R-Data relative to R-Pilot channel)
  • FETCh:DOWQuality:CDPower:DSCChannel[:REVerse]? (only useful for subtype 2 physical layer because DSC channel is only available for subtype 2 physical layer)
  • FETCh:DOWQuality:CDPower:PILot:AUXiliary[:REVerse]? (only useful for subtype 2 physical layer because R-Aux Pilot channel is only available for subtype 2 physical layer)

Code Domain Power Measurement Results Available by Numbered Bins

The code domain power measurement results can be obtained collectively by I channel and Q channel designation. The measurement results for each bar displayed on I and Q graphs can be queried by bins. The following figure takes subtype 0 reverse channels as an example to show the bin numbering system:

Bin Numbering System

Bins are dynamically allocated to code channels depending upon which code channels are active and the code channel spread factors. For subtype 0 physical Layer , if no channel has spread factor less than 16, 16 I bins and 16 Q bins (numbered 0 to 15) are assigned values. For subtype 2 physical layer , if no channel has spread factor less than 32, 32 I bins and 32 Q bins (numbered 0 to 31) are assigned values. For example, on the Q graph of the figure above, R-Data (Q:2 SF4 ) occupying four spread factor 16 walsh codes (Q:2 SF16 , Q:10 SF16 , Q:6 SF16 , and Q:14 SF16 ) is displayed in a contiguous wide bar and assigned to one bin (bin 4). Bins (0, 2, 3 and 5 through 12) that are not active, only contain noise power (yellow bars). Bins 13-15 are unassigned (do not contain any measurement data).

You can query the results for all bins or query the results for a particular bin programmatically.

GPIB Commands for Querying Measurement Results By Bin

Commands for Querying All Bins

Commands for Querying Bins Individually

The commands to query results for all bins on the I or Q channel are:

  • FETCh:DOWQuality:CDPower[16]:ICHannel[:ALL]? ( for subtype 0 physical layer )
  • FETCh:DOWQuality:CDPower[16]:QCHannel[:ALL]? ( for subtype 0 physical layer )
  • FETCh:DOWQuality:CDPower32:ICHannel[:ALL]? ( for subtype 2 physical layer )
  • FETCh:DOWQuality:CDPower32:QCHannel[:ALL]? ( for subtype 2 physical layer )

These commands always return 64 or 128 comma-separated values (4 results for each of 16 or 32 bins). If less than 16 or 32 bins are assigned data (due to some Walsh codes with spread factors less than 16 or 32), four comma-separated +9.91 E+37 (NAN) values will be returned for each unassigned bin. In other words, after all assigned bin data is reported, a series of +9.91 E+37 values separated by commas will be returned until a total of 64 or 128 values have been returned

The commands to query results for a particular I or Q channel bin are:

  • FETCh:DOWQuality:CDPower:ICHannel:BIN? <bin num>
  • FETCh:DOWQuality:CDPower:QCHannel:BIN? <bin num>

The commands to query how many bins are assigned for the I or Q channels are:

  • FETCh:DOWQuality:CDPower:ICHannel:COUNt[:BIN]?
  • FETCh:DOWQuality:CDPower:QCHannel:COUNt[:BIN]?

The following measurement results are returned for each bin.

  • Walsh code state: active (1) or inactive (0).
  • Walsh code number.
  • Spread Factor (SF): See SF (Spread Factor) .
  • Bin Power (in dB)

    Bin power is similar to the Marker power. It is the average power over a slot in one Walsh code (SF=16 or 32), divided by the total power in all of the Walsh codes during the same slot. This power level includes any desired signal as well as noise present in the selected Walsh code. The difference between Bin Power and Marker Power is:

    • Marker Power - There are always 16 or 32 marker positions containing measurement results, each position reporting the power for one spread factor 16 or 32 Walsh code.
    • Bin Power - There are often fewer than 16 or 32 bins containing measurement results, and a single bin may report the power for several Walsh codes with spread factor 16 or 32.

    For example, in the figure Bin Numbering System , the SF reported for I channel bin 2 is 8, indicating that two SF 16 Walsh codes are assigned to the bin 2. The bin power returned for I channel bin 2 is the power level of either Walsh code I:12 SF16 or I:4 SF16 , which are part of I:4 SF8

An example return result for FETCh:DOWQuality:CDPower[16]:QCHannel[:ALL]? is shown below. This command always returns 64 comma-separated values (4 results for each of 16 bins). If less than 16 bins are assigned data (due to some Walsh codes with spread factors less than 16), four comma-separated +9.91 E+37 (NAN) values will be returned for each unassigned bin. In other words, after all assigned bin data is reported, a series of +9.91 E+37 values separated by commas will be returned until a total of 64 values have been returned:

+0.00000000E+000,+0.00000000E+000,+1.60000000E+001,-3.17802200E+001,
+1.00000000E+000,+8.00000000E+000,+1.60000000E+001,-4.97573800E+000,
+0.00000000E+000,+4.00000000E+000,+1.60000000E+001,-3.44952500E+001,
+0.00000000E+000,+1.20000000E+001,+1.60000000E+001,-3.44952500E+001,
+1.00000000E+000,+2.00000000E+000,+4.00000000E+000,-1.02941100E+001,
+0.00000000E+000,+1.00000000E+000,+1.60000000E+001,-4.28410000E+001,
+0.00000000E+000,+9.00000000E+000,+1.60000000E+001,-4.29233900E+001,
+0.00000000E+000,+5.00000000E+000,+1.60000000E+001,-4.27497100E+001,
+0.00000000E+000,+1.30000000E+001,+1.60000000E+001,-4.27871900E+001,
+0.00000000E+000,+3.00000000E+000,+1.60000000E+001,-4.30107000E+001,
+0.00000000E+000,+1.10000000E+001,+1.60000000E+001,-4.26903300E+001,
+0.00000000E+000,+7.00000000E+000,+1.60000000E+001,-4.30544700E+001,
+0.00000000E+000,+1.50000000E+001,+1.60000000E+001,-4.32616100E+001,
9.91E37,9.91E37,9.91E37,9.91E37,
9.91E37,9.91E37,9.91E37,9.91E37,
9.91E37,9.91E37,9.91E37,9.91E37

Note that four comma-separated +9.91 E+37 (NAN) values are returned for bins 13, 14 and 15. These bins are not assigned and do not contain measurement results (see Bin Numbering System ).

Code Domain Power + Noise Measurement Results Available from the Measurement Screen

The measurement screen for Code Domain Power + Noise includes a graphical display which is identical to that on the Code Domain Power screen, except for the treatment of active Walsh codes.

  • On the Code Domain Power screen, active Walsh codes are displayed on the histogram as solid red bars, and when a Walsh code is selected by the marker, the power reported is the total of desired signal power and noise present in the selected Walsh code.
  • On the Code Domain Power + Noise screen, the active Walsh codes are displayed as red and yellow bars, with yellow indicating the noise power in the Walsh code. When the marker is placed on a Walsh code, the total power for the Walsh code is reported as on the Code Domain Power screen, but a separate value is also given for the noise power in the Walsh code.

The following results are thus available from the graphical display:

  • A red and yellow histogram bar, or a solid red bar (if no noise is measured in the Walsh code) indicates that the Walsh code is active. A solid yellow bar indicates that the Walsh code is inactive.
  • Marker Power of the Walsh code (in dB):
    This is identical to the Marker Power for Code Domain Power (see Code Domain Power Graphical Display ).
  • Noise Power of the Walsh code (in dB):
    When the marker is positioned on a Walsh code, the noise power of that Walsh code (SF = 16 or 32) is also displayed. This is the average power level of the noise present in the Walsh code over a slot, divided by the total power in all of the Walsh codes during the same slot.

A typical Code Domain Power + Noise measurement result for subtype 0 physical layer is shown below:

Code Domain Power + Noise Measurement Results Available Programmatically

The following code domain power + noise measurement results are available for all bins on the I and Q channels programmatically:

  • Walsh code state: active (1) or inactive (0).
  • Spread factor: See SF (Spread Factor) .
  • Noise Power (in dB):
    This is the level of noise present in each of the Walsh codes (SF=16 or 32) assigned to the bin. It is the average power level of the noise present in the Walsh code over a slot, divided by the total power in all of the Walsh codes during the same slot.
  • Bin Power (in dB):
    This is identical to the Code Domain Power Bin Power result (see Code Domain Power Measurement Results Available by Numbered Bins ).

You can query these results for all bins or query the results for a particular bin.

Code Domain Power Measurement Results - Query By Bin

Commands for Querying All Bins

Commands for Querying Bins Individually

The commands to query this data for all bins on the I or Q channel are:

  • FETCh:DOWQuality:CDPNoise[16]:ICHannel[:ALL]? ( for subtype 0 physical layer )
  • FETCh:DOWQuality:CDPNoise[16]:QCHannel[:ALL]? ( for subtype 0 physical layer )
  • FETCh:DOWQuality:CDPNoise32:ICHannel[:ALL]? ( for subtype 2 physical layer )
  • FETCh:DOWQuality:CDPNoise32:QCHannel[:ALL]? ( for subtype 2 physical layer )

These commands always return 64 or 128 comma-separated values (4 results for each of 16 or 32 bins). If less than 16 or 32 bins are assigned data (due to some Walsh codes with spread factors less than 16 or 32), four comma-separated +9.91 E+37 (NAN) values will be returned for each unassigned bin. In other words, after all assigned bin data is reported, a series of +9.91 E+37 values separated by commas will be returned until a total of 64 or 128 values have been returned.

The commands to query results for a particular I or Q channel bin are:

  • FETCh:DOWQuality:CDPNoise:ICHannel:BIN? <bin num>
  • FETCh:DOWQuality:CDPNoise:QCHannel:BIN? <bin num>

The commands to query how many bins are assigned for the I or Q channels are:

  • FETCh:DOWQuality:CDPNoise:ICHannel:COUNt[:BIN]?
  • FETCh:DOWQuality:CDPNoise:QCHannel:COUNt[:BIN]?

Waveform Quality + Code Domain Input Signal Requirements

Input Signal Requirements

Key C.S0033 Tests Performed Using the Waveform Quality + Code Domain Measurement

4.2.2 Waveform Quality and Frequency Accuracy

4.3.7 RRI Channel Output Power

4.3.8 Code Domain Power

Calibrating the Waveform Quality + Code Domain Measurement

The waveform quality + code domain measurement is automatically calibrated during a channel power calibration. Follow the channel power calibration schedule and the waveform quality + code domain power measurement will be properly calibrated. Refer to Calibrating the Test Set for a description of channel power calibration.

Relationship Between Spread Factors and Walsh Code Space

Spread Factor (SF) is a term which indicates which Walsh code set the Walsh code belongs to. For example, Walsh code 11111111 belongs to Walsh code set 8, and thus is said to have a spread factor of 8. The spread factor also indicates the length of the Walsh code (spread factor 8 indicates the Walsh code is 8 digits in length).

The diagram below shows an example of the Walsh code distribution of the subtype 0 reverse channels.

Subtype 0 Reverse Channel Walsh Code Distribution

Note in the figure above, the R-Data is assigned to use Walsh code 2 with a spread factor of four (W2 SF=4 ) on the Q channel. Four SF 16 Walsh codes (W2 SF16 , W6 SF16 , W10 SF16 and W14 SF16 ) are all occupied by Walsh code (W2 SF=4 ). That is, the R-Data occupies four of 16 code space bars as shown Spread Factor 4 Code Space .

Spread Factor 4 Code Space

Bit reversal

Note the order of the spread factor 16 Walsh codes are shown in 16 Bit Walsh Code Order . This order is derived from applying bit reversal to the decimal numbers 0 to 15. Consider Marker Position 13, which corresponds with Walsh code 11.

16 Bit Walsh Code Order

Marker Position 13 evaluates to a binary coded decimal value of 1101. If you reverse that bit sequence, the resulting pattern is 1011. When 1011 is converted back to a decimal value, the result is Walsh code 11, as shown in Walsh Channel Bit Reversal . This numbering system allows supplemental channels with higher data rates to be displayed as one contiguous block.

Walsh Channel Bit Reversal

Related Topics

Manual Operation: Measuring Waveform Quality + Code Domain Power

Programming a Waveform Quality/Code Domain Measurement

Waveform Quality Measurement Troubleshooting

Reverse Channel Overview

Test Adherence to Standards

C.S0029 Test Application Specification Description (TAP/ETAP)


TX Dynamic Power Measurement Description

TX Dynamic Power Measurement Description

  • How is a TX Dynamic Power Measurement Made?
  • TX Dynamic Power Measurement Parameters
  • TX Dynamic Power Measurement Results
  • TX Dynamic Power Input Signal Requirements
  • Calibrating the TX Dynamic Power Measurement

How is a TX Dynamic Power Measurement Made?

The TX dynamic power measurement provides a fast power calibration method for your AT. It is available in Active Cell and IS-856 Test operating modes ( Operating Mode ).

The measurement is not performed with a call established between the test set and AT. Rather, you must place your AT into a test mode which controls the AT to transmit a power sequence of successive down steps of fixed size and duration. An example AT output power sequence for TX Dynamic Power Measurement is shown in the figure below.

Before starting the TX dynamic power measurement, you must set the test set's receiver using manual control, with the power set to match the initial transmit power of the AT's power sequence, and with the frequency set to match the AT's transmit frequency (see Receiver Control ). This is required for the test set to tune its receiver properly for the initial measurement.

Typically, the dynamic power range of an AT is 90 dB, from -60dBm to +30 dBm. The TX dynamic power measurement can measure the AT's output power sequence ranging from -61 dBm to +37 dBm, in up to 99 steps. The Power Step Time may be 20, 40 or 80 ms in duration.

AT Output Power Profile for TX Dynamic Power Measurement

The TX dynamic power measurement is firstly triggered by an RF rise impulse from the AT (a positive change in power from 20 dB below the initial transmit power). To ensure successful triggering, it is recommended that you first command the AT to transmit continuously at the initial transmit power level, initiate the measurement, then command the AT to drop and then raise its output power by more than 20 dB to create the RF rise trigger.

Once triggered, the TX dynamic power measurement performs a series of channel power measurements in Very Fast speed (see Measurement Speed ), one at each step of the power sequence. The AT's initial transmit power (step 0) is measured at 6 ms, or 16 ms, or 36 ms (corresponding to the Power Step Time set to 20ms, 40ms or 80ms) after receiving the RF rise trigger. This is to ensure that the measurements always sample the stable portions of the data record. The test set then tunes its receiver to the proper level before performing each subsequent channel power measurement based on the measured power of the prior step and the Power Step Size setting. Each subsequent channel power measurement is automatically triggered at every 20, 40, or 80 ms (depending on the Power Step Time setting). The AT must step its power down and then hold its power constant at each step for Power Step Time duration. After completing the measurements at all of the requested power steps ( Number of Power Steps ), the test set returns power results for the initial AT transmit power (step 0) and each of the down steps.

So, the general procedure for making a TX dynamic power measurement is:

  1. Set the test set's receiver in manual control with the power set to match the initial transmit power of the AT's power sequence, and with the frequency set to match the AT's transmit frequency (see Manual Operation: Manual Receiver Control ).
  2. Set the Power Step Size , Number Of Power Steps and Power Step Time parameters (see TX Dynamic Power Measurement Parameters ) to match the power sequence to be transmitted by the AT.
  3. Place your AT into the test mode required for performing TX dynamic power and command it to transmit continuously at the initial transmit power level (for example, the maximum power).
  4. Arm the TX Dynamic Power measurement by the INIT command or by pressing the START SINGLE key.
  5. Using the AT test mode interface, command the AT to generate an RF rise impulse (with a positive change in power from 20 dB below the initial transmit power) to trigger the measurement, and then transmit a power sequence of successive down steps of expected size and duration.
  6. The test set measures the AT's initial transmit power and all of the requested power steps, then displays the measurement results in graphical "Bars" and numeric values. See TX Dynamic Power Measurement Results .

Operating Considerations

  • The TX dynamic power measurement is re-ranged and re-triggered for every step in the AT's power sequence. To prevent from missing an internal trigger at each step of a power sequence measurement, it is recommended that you do not send any GPIB commands to the test set or press any front panel keys until the measurement has completed. If the measurement misses a trigger, it aborts and returns Integrity Indicator 30 : Missed Trigger
  • The dynamic power measurement is not available in a multi-measurement mode.
  • The TX dynamic power measurement is expected to only be used when data connection status is Idle as the AT must be operating in a test mode to transmit the required power sequence.
  • The TX dynamic power measurement does not run concurrently with any other measurements. If any measurements are running when TX dynamic power measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while a TX dynamic power measurement is running, the TX dynamic power measurement is closed and a message is displayed.

TX Dynamic Power Measurement Parameters

  • Power Step Size

    Sets the power change (in dB) that the test set expects the AT to decrease between power steps. The test set re-ranges its receiver for each step power measurement based on the measured power of the prior step and this setting.

    GPIB command: SETup:CTDPower:STEP[:LEVel]

  • Number of Power Steps

    Sets the number of power steps (steps down since its initial transmit power) that the test set expects the AT to transmit. The total number of power results returned will be the number of this setting plus one and can be queried using the FETCh:CTDPower:COUNt[:STEP]? .

    GPIB command: SETup:CTDPower:STEP:COUNt

  • Power Step Time

    Sets the duration (20, 40 or 80 ms) of each power measurement. The test set expects the AT to hold its power constant during each power step. The test set triggers each channel power measurement relative to the first RF rise trigger based on this setting.

    GPIB command: SETup:CTDPower:STEP:TIME

  • Measurement Timeout - see Measurement Timeouts . Ensure that you set the Measurement Timeout to a value great enough to allow you to command the AT to transmit its power sequence and for the test set to measure the power sequence.

TX Dynamic Power Measurement Results

  • Integrity Indicator - (see Integrity Indicator ).
  • Power Results - Power (dBm/1.23 MHz) are returned for the AT's initial transmit power (step 0) and each down step of the AT's transmit power sequence (see FETCh:CTDPower[:ALL]? ). The total number of power results returned is 1 + Number of Power Steps and can be queried using the FETCh:CTDPower:COUNt[:STEP]? command.

The TX dynamic power measurement result is displayed in both a tabular and a bar graph format. See TX Dynamic Power Measurement Display .

TX Dynamic Power Measurement Display

Graphical Display

The graphical display shows the measurement result for each step with a graphical "Bar". The x-axis graph represents the number of the power steps and y-axis represents the absolute power of the measurement step in units of dBm/1.23 MH. Up to 100 steps of the measurement results can be displayed on the graph. The view window can be adjusted to include a view of the entire 100 power step range, or reduced to include only the measurement steps of particular interest by the Graph Control softkeys (see Measuring TX Dynamic Power ).

NOTE
The number of displayed bars equals the value of Number of Power Steps plus one. For example, when Number of Power Steps is set to 3, the display shows 4 yellow bars in one measurement.

  • Marker ( F1 ) - sets a marker position across the current span of the graph. The measurement result that corresponds with the marker position is highlighted in the table below the graphical display. This setting also controls the table scrolling.
  • Start Step ( F3 ) - sets the first measurement step displayed on the graph. It is used to adjust the view window together with the Span ( F4 ).
  • Span ( F4 ) - sets the number of measurement steps displayed on the graph. It is used to adjust the view window together with the Start Step ( F3 ).
  • Default Scale ( F5 ) - sets the Graph Marker, Start Step, and Span to their default values.

Tabular Display

A table below the graphical display lists the absolute power of each step measurement in units of dBm/1.23 MHz. The table has the capacity to display 40 steps of measurement results. To scroll through the table adjust the setting in Marker field.

TX Dynamic Power Input Signal Requirements

Input Signal Requirements

Calibrating the TX Dynamic Power Measurement

The TX dynamic power measurement is automatically calibrated during a channel power calibration. Follow the channel power calibration schedule and the TX dynamic power measurement will be properly calibrated. Refer to Calibrating the Test Set for a description of channel power calibration.

Related Topics

Measuring TX Dynamic Power

Programming a TX Dynamic Power Measurement

TX Dynamic Power Measurement Troubleshooting

Channel Power Measurement Description

Receiver Control


Input Signal Requirements

Input Signal Requirements

All measurements meet or exceed specifications when the following requirements are met:

  • The frequency of the signal being measured must be in the range of 412 MHz to 483 MHz, 800 MHz to 960 MHz, or 1.7 GHz to 2.0 GHz, and within 100 kHz of the expected frequency.
  • The signal level into the test set's RF IN/OUT connector must be within 9 dB of the expected input power (see Expected Power ), and must be:
Input Signal Power Level Requirements
Measurement | Input Signal Power Level Requirement
Access Probe Power | between -45 dBm and +37 dBm (-45 is the minimum level required to trigger the access probe power measurement).
Channel Power | between -61 dBm and +37 dBm (with reliable but unspecified performance down to -69 dBm).
Digital Average Power | between -30 dBm and +37 dBm.
Packet Error Rate | between -25 dBm and +37 dBm.
TX Dynamic Power | between -61 dBm and +37 dBm (with reliable but unspecified performance down to -69 dBm).
TX Spurious Emissions | between 0 dBm and +30 dBm.
TROLPC | between -25 dBm and +37 dBm.
Waveform Quality + Code Domain | between -25 dBm and +37 dBm.


Instrument Configuration Measurement Matrix

Instrument Configuration Measurement Matrix

The following table shows which measurements and instruments are available in each Operating Mode .

Measurement and Instrument Availability in Operating Modes
Measurement/Instrument | Operating Mode
 | Active Cell | IS-856 Test | CW | Off
Access Probe Power | X | X |  |
Audio Analyzer: Audio Frequency, Audio Level, Distortion, SINAD | X | X | X | X
Audio Generator | X | X | X | X
Channel Power | X | X |  |
Digital Average Power | X | X |  |
Data Throughout Monitor ( Lab Application Only ) | X | X |  |
Graphical Access Probe Power ( Lab Application Only ) | X | X |  |
Packet Error Rate | X |  |  |
Spectrum Monitor | X | X | X | X
Swept Audio | X | X | X | X
Time Response of Open Loop Power Control | X | X |  |
TX Dynamic Power | X | X |  |
TX Spurious Emissions | X | X |  |
Waveform Quality/Code Domain | X |  |  |

Related Topics

Test Adherence to Standards


Swept Audio Measurement Description

Swept Audio Measurement Description

Description

How are swept audio measurements made?

Swept audio measurements synchronize the frequencies of the test set's audio generator and audio analyzer instruments to automatically make measurements at up to 60 frequency points. Audio level, SINAD, and distortion measurements can be performed at each measurement point in the sweep.

This measurement only generates and analyzes audio signals; no modulation of the RF generator, or demodulation by the receiver, is performed. A representation of this operation is shown below.

Swept Audio Measurements Block Diagram

To perform the swept audio measurements, you must route audio generator signal to the AUDIO OUT port (not the FM Demod signal). See Interactions with the Audio Analyzer and Audio Generator Instruments . The audio signal from the device under test is sent to the audio analyzer through the AUDIO IN ports.

The start and stop frequencies for the sweep define the frequency range. The user specifies the number of measurement points, which are evenly spaced through the specified frequency range.

Measurement settling time can be set to specify how long the audio signal is generated at each frequency before a measurement is made by the audio analyzer. This is used to account for settling time in the device being tested and any signal delay through the device. Increasing the settling time increases the sweep time.

If the 100 Hz BW bandpass filter is selected, the center frequency of the filter is synchronized to the audio generator and audio analyzer frequencies.

Typical applications include measuring the audio distortion of a mobile station across several frequencies and measuring the frequency response of an audio filter or amplifier.

This is not a measurement procedure specified in the EIA/TIA standards.

Operating Considerations

Front Panel Access

Swept Audio measurements are accessed manually by pressing the front-panel Instrument selection key.

Multi-measurement Use

When multi-measurements are used with the swept audio measurement, the AF analyzer makes the number of measurements specified at each point in the sweep. For example, if five measurement points are specified, and the multi-measurement count is set to 20, a total of 100 measurements are performed during the sweep.

Interactions with the Audio Analyzer and Audio Generator Instruments

To route Audio Generator signal to the front panel AUDIO OUT port, use the "SYSTem:AUDio:OUTPut:SOURce" command or press the System Config hardkey, then select Audio Out Port ( F1 ) on the System Config Screen (2 of 2).

The Swept Audio measurement and the Audio Analyzer instrument cannot be used at the same time to make audio measurements. If you enable either function while the other function is already enabled, the first function is turned off and a message is displayed that informs you of this situation.

Selecting the Swept Audio measurement will automatically adjust Audio Generator instrument settings. These settings will not be restored to their original values when the Swept Audio measurement is closed.

The amplitude of the Audio Generator instrument can be changed while the Swept Audio measurement is enabled. However, trying to change the Audio Generator instrument's frequency while using swept audio measurements is not allowed, and causes an error message to be displayed.

Specifying a Specific Measurement Frequency Point Within a Sweep

If you need to make sure that a measurement is performed at a specific frequency within the sweep, you can use the following algorithms to calculate the values to enter:

For example if you wanted to make a measurement at 1004 Hz (F) during a sweep of 15 points (P) that begins at 300 Hz (S) and ends after 3 kHz (Emin), the first algorithm tells you that 1004 Hz occurs at the fourth point in the sweep (n). Use the second algorithm to calculate the actual stop frequency (E) you would enter for that sweep (3585.333 Hz).

Related Topics

Programming a Swept Audio Measurement

Swept Audio Measurement Troubleshooting

Audio Analyzer Measurement Description

Audio Level Measurement Description

Distortion Measurement Description

SINAD Measurement Description


Spectrum Monitor Description

Spectrum Monitor Description

How is the spectrum monitor (SMON) used?

The Spectrum Monitor (SMON) can be used to locate, identify and measure transmitted signals from a device under test. The Spectrum Monitor can be used while a call is in progress.

The Spectrum Monitor is intended to be used for indication only. The Spectrum Monitor does not have the same level accuracy specifications as other measurements provided by the test set, and should therefore not be used when parametric accuracy is required (for example, calibration of a mobile). It is recommended that you use the other wireless format-specific measurements when you require accurate parametric measurements.

From the test set's front panel, the Spectrum Monitor can be accessed by pressing the Instrument Selection key, then selecting Spectrum Monitor . If you require more details on manual operation of the Spectrum Monitor, see How Do I Use the Spectrum Monitor? .

The Spectrum Monitor has the following two modes of operation:

  • Swept mode, in which the X axis represents frequency , and the Y axis represents absolute amplitude.
  • Zero span mode, in which the X axis represents time and the Y axis represents absolute amplitude.

You can use the markers on the Spectrum Monitor's graphical display to set the expected frequency and power levels that are used by the test or lab application for parametric measurements.

The center frequency used by the Spectrum Monitor is initially set at the expected frequency maintained by the test set's base station emulator. The expected frequency range is 292.5 MHz to 2700 MHz.

The range of frequencies which the spectrum monitor is calibrated to measure is determined by the range of traffic band frequencies supported by the specific test or lab application that is currently running. For example, if you are using the GSM Test Application, any of the frequencies used by the GSM traffic bands are available for you to monitor accurately. You can view signals which fall outside of any of the frequencies used by GSM, but the Spectrum Monitor will not be calibrated.

Detection Method

Frequency binning is used when the Spectrum Monitor divides the frequency span by the number of display points such that each bin contains a segment of the frequency span. Within each frequency bin, a single value representing each frequency bin is displayed on the test set's screen. The algorithm used to find the value that represents each frequency bin is determined by the detection method. There are three detection methods available in the test set's Spectrum Monitor:

  • Peak Detection

    The largest spectral component in the frequency bin is used to represent each bin.

  • Sample Detection

    The last spectral component in the frequency bin is used to represent each bin.

  • RMS Detection

    The sum of the power across the frequency bin is used to represent each bin.

The command to change the detection method is SETup:SMONitor:DETector[:TYPE] .

Resolution Bandwidth and Frequency Span

The resolution bandwidth can be used to resolve two or more closely spaced signals as long as the resolution bandwidth is less than the difference between the spectral components. A resolution bandwidth greater than or equal to the signal bandwidth can be used to measure the total power of a signal.

Refer to Frequency Span, Resolution Bandwidth and Dynamic Range below. When the Resolution Bandwidth Coupling State is OFF, the Frequency Span and the Resolution Bandwidth can be set to any value in their respective columns, and Resolution Bandwidth setting determines the Displayed Dynamic Range. When the Resolution Bandwidth Coupling State is On, the Resolution Bandwidth and Displayed Dynamic Range settings are coupled with the Frequency Span setting. For example, if the Frequency Span is 100 MHz, the test set automatically sets the Resolution Bandwidth to 5 MHz and the Displayed Dynamic Range to 55 dB.

Frequency Span, Resolution Bandwidth and Dynamic Range
Frequency Span | Resolution Bandwidth | Displayed Dynamic Range
100 MHz | 5 MHz | 50 dB
80 MHz | 1 MHz | 55 dB
40 MHz | 300 kHz | 60 dB
20 MHz | 100 kHz | 65 dB
12 MHz | 100 kHz | 65 dB
10 MHz | 100 kHz | 65 dB
5 MHz | 30 kHz | 70 dB
4 MHz | 30 kHz | 70 dB
2.5 MHz | 10 kHz | 75 dB
1.25 MHz | 3 kHz | 80 dB
500 kHz | 1 kHz | 80 dB
125 kHz | 300 Hz | 80 dB
0 Hz (zero span mode) | 100 kHz | 65 dB
 | 300 kHz | 60 dB
 | 1 MHz | 55 dB

The command to set the Resolution Bandwidth Coupling State is SETup:SMONitor:BANDwidth|BWIDth:AUTO .

The command to set the Resolution Bandwidth is SETup:SMONitor:BANDwidth|BWIDth:MANual , and the command to set the Frequency Span is SETup:SMONitor:FREQuency:SPAN .

Single or Multi-Measurements

The Spectrum Monitor can return either single or averaged results.

  • If you set the averaging state OFF then the trace represents a single measurement sweep.

  • If you set the averaging state ON, and the averaging count number to a value greater than one, then the trace represents the rolling average of the specified number of sweeps.

Input Signal Requirements

The Spectrum Monitor will complete and meet its accuracy specifications under the following input signal conditions.

  • The signal is within 40 dB of the reference level.
  • The measurement frequency is within the traffic band frequencies supported by the specific lab or test application that is currently running, and the expected frequency is tuned to the carrier.

Trigger Source

Triggering choices available for the Spectrum Monitor are Immediate, Protocol, RF Rise, and External.

For more information on measurement triggering, refer to Triggering of Measurements .

Calibrating the Spectrum Monitor

See Calibrating the Test Set .

Related Topics

Programming the Spectrum Monitor


Time Response of Open Loop Power Control (TROLPC) Measurement Description

Time Response of Open Loop Power Control (TROLPC) Measurement Description

Last updated: May 24, 2006

  • How is a TROLPC Measurement Made?
  • TROLPC Measurement Parameters
  • TROLPC Measurement Results
  • TROLPC Input Signal Requirements
  • Key C.S0033 Tests Performed using the TROLPC Measurement
  • Calibrating the TROLPC Measurement

How is a TROLPC Measurement Made?

The TROLPC measurement is a power versus time measurement that analyzes the output power of a mobile station for the 100 ms period following an abrupt (step) change in output power from the test set (+ or - 20 dB).

When you initiate the test set's TROLPC measurement, cell power either increases or decreases by 20 dB (depending upon whether you initiate an up or down step change). When the cell power changes, the access terminal reacts by decreasing or increasing it power, according to the open loop equation. The test set automatically sends alternating up and down closed loop power control bits while the measurement is executing, so the access terminal's response is determined solely by the open loop equation, and not influenced by closed loop power control (the alternating power control bits appear only as "ripple" on the measured trace).

The test set begins measuring the AT power as soon as the test set's source begins its transition to the new cell power setting (this transition is very rapid), and continues to measure power for the 100 ms following the change in cell power. The test set measures power at 371 data points over the 100 ms following the step change in cell power. Data point 0 reports the average power from 0 ms to ~0.270 ms after the power transition. Data point 1 reports the average power from ~0.270 ms to ~0.540 ms, and so on, up to data point 370 which reports the average power from ~99.730 ms to 100 ms. (Each data point reports the average power over a period of ~270 µs, within the 1.23 MHz measurement bandwidth.)

Before the test set's source begins its transition, the test set begins sending alternating closed loop power control bits. The test set then transitions its source such that the power control bit sent at the power transition is opposite in direction to the transition (the bit sent at the power transition is an "up" bit when the cell power transition is -20 dB, and a "down" bit when the cell power transition is +20 dB).

The test set automatically ranges its measuring receiver to the maximum expected value from the AT as the test is performed.

When the measurement is complete, the test set returns closed loop power control to the mode it was set to before the measurement was initiated.

You must establish an RTAP (for Subtype 0 Physical Layer) or RETAP (for Subtype 2 Physical Layer) connection to perform the TROLPC measurement (see Measuring Time Response of Open Loop Power Control (TROLPC) for detailed procedure).

C.S0033 specifies that the R-ACK Channel is not transmitted by the access terminal for the test 4.3.2 Time Response of Open Loop Power Control. If the R-ACK Channel is transmitted during this test, the access terminal's power may fall outside of the mask specifications. To make your access terminal not transmit the R-Ack Channel, you should set ACK Channel Bit Fixed Mode Attribute to off and AT Directed Packets to 0% for this test.

Important

No other measurements can be running while the TROLPC measurement is active. If any measurements are running, they are closed when TROLPC is initiated, and a message is displayed indicating that a measurement has been closed. Activating another measurement inactivates the TROLPC measurement.

Important

TROLPC Measurement Parameters

  • Timeout Time/State - (see Measurement Timeouts ).

TROLPC Measurement Results

  • Integrity Indicator - (see Integrity Indicator ).
  • Pass/Fail: An overall pass/fail indicator is displayed on the measurement screen and is available via GPIB commands (see FETCh:TROPower:MASK[:FAIL]? ). Fail is returned if the access terminal's power does not stay within the amplitude mask as defined in C.S0033 3.1.2.3.2 (see 4.3.2 Time Response of Open Loop Power Control ).
  • Power Versus Time Data Points: The 371 data points that describe the access terminal's power versus time behavior are available from the measurement screen marker, and via GPIB commands (see FETCh:TROPower:TRACe? ).
  • First Fail Point: If the measurement result is "Fail," the measurement screen displays the first point that the access terminal output power crossed the amplitude mask.

The TROLPC Measurement Screen

The TROLPC measurement screen includes two softkeys to initiate the measurement for either a +20 dB or -20 dB step change ( Start Meas Up ( F1 ) or Start Meas Down ( F2 )). A graphical display is provided to show the measurement result, which you can navigate with the marker.

  • The y-axis on the graphical display is fixed at -5 dB to +30 dB. There are no polarity indicators on the y-axis, in accordance with the test standard specifications. All changes in mobile station output power are displayed as absolute values.
  • The x-axis on the graphical display is fixed from 0 ms to 100 ms.
  • The directions of cell power and access terminal power level changes are displayed in text above the grid.
  • The amplitude mask is displayed as green lines on the display. (The access terminal power trace is shown in yellow.)
  • The marker can be positioned on each of the 371 power versus time data points. The access terminal power level for that data point is then displayed.

TROLPC Input Signal Requirements

Input Signal Requirements

Key C.S0033 Tests Performed using the TROLPC Measurement

  • 4.3.2 Time Response of Open Loop Power Control

Calibrating the TROLPC Measurement

The TROLPC measurement is automatically calibrated during a channel power calibration. Follow the channel power calibration schedule and the TROLPC measurement will be properly calibrated. Refer to Calibrating the Test Set for a description of channel power calibration.

Related Topics

Manual Operation: Measuring Time Response of Open Loop Power Control (TROLPC)

Programming a Time Response of Open Loop Power Control (TROLPC) Measurement

Time Response of Open Loop Power Control Troubleshooting

ACK Channel Bit Fixed Mode Attribute

Test Adherence to Standards

C.S0029 Test Application Specification Description (TAP/ETAP)


Programming an Audio Frequency Measurement

Programming an Audio Frequency Measurement

This section provides an example of how to make an audio frequency measurement with the Audio Analyzer (AFANalyzer) via GPIB.

The following procedure assumes that an audio source is connected to the AUDIO IN connectors. See Audio Analyzer Measurement Description .

  1. Configure audio analyzer measurement parameters using the SETup subsystem. When more than one audio frequency signal may be present, use the 100 Hz bandpass filter to isolate the desired signal for measurement (see the Programming Example below).
  2. Start the audio analyzer measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain audio analyzer measurement results.

Programming Example

10  OUTPUT 714;"SETup:AFANalyzer:CONTinuous OFF" !Set the audio analyzer
20                                           !measurements to single trigger mode.
30 ! OUTPUT 714;"SETup:AFANalyzer:PEAK:VOLTage 3V" !Set the Expected peak voltage
40                                                !for the audio input level in Vpeak.
50  OUTPUT 714;"SETup:AFANalyzer:FREQuency:STATe ON" !Enable audio frequency meausurement.
60  OUTPUT 714;"SETup:AFANalyzer:FILTer TBPass" !Select the 100 Hz bandpass filter.
70  OUTPUT 714;"SETup:AFANalyzer:FILTer:TBPass 6000 Hz" !Set the 100 Hz bandpass
80     !filter's center frequency to 6 kHz (example; to measure SAT frequency).
90  OUTPUT 714;"SETup:AFANalyzer:TIMeout 3S" !Set a timeout value of 3 seconds
100                                      !in case the measurement cannot be made.
110 OUTPUT 714;"INITiate:AFANalyzer" !Start the AF Analyzer measurement.
120 OUTPUT 714;"FETCh:AFANalyzer:FREQuency?" !Fetch the Audio Frequency  result.
130 ENTER 714;Audio_frequency !Enter the returned value into a variable.
140 END

Related Topics

Audio Frequency Measurement Description

Audio Analyzer Troubleshooting

Audio Analyzer Measurement Description

INITiate

SETup:AFANalyzer

FETCh:AFANalyzer


Programming an Audio Level Measurement

Programming an Audio Level Measurement

This section provides an example of how to make an audio level measurement with the Audio Analyzer (AFANalyzer) via GPIB.

The following procedure assumes that an audio source is connected to the AUDIO IN connectors. See Audio Analyzer Measurement Description .

  1. Configure audio analyzer measurement parameters using the SETup subsystem. Even though default settings exist for each parameter, it is a good idea to deliberately set each parameter to make sure the setting is correct for the specific audio analyzer measurement you are making.
  2. Start the audio analyzer measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain audio analyzer measurement results.

Programming Example

10  OUTPUT 714;"SETup:AFANalyzer:CONTinuous OFF" !Set the audio analyzer
20                                           !measurements to single trigger mode.
30  OUTPUT 714;"SETup:AFANalyzer:PEAK:VOLTage 3V" !Set the Expected Amplitude level for
40                                                !audio input voltage in Vpeak.
50  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:STATe OFF" !Turn off the SINAD and
60                                                  !distortion measurements since
70                                                  !they are not being used.
80  OUTPUT 714;"SETup:AFANalyzer:FILTer NONE" !Bypass all audio filters.
90  OUTPUT 714;"SETup:AFANalyzer:DEMPhasis:STATe OFF" !Turn off de-emphasis.
100 OUTPUT 714;"SETup:AFANalyzer:EXPandor:STATe OFF" !Turn off the expandor.
110 OUTPUT 714;"SETup:AFANalyzer:DETector RMS" !Specify the RMS detector for the
120                                            !audio measurement.
130 OUTPUT 714;"SETup:AFANalyzer:TIMeout 3S" !Set a timeout value of 3 seconds
140                                      !in case the measurement cannot be made.
150 OUTPUT 714;"INITiate:AFANalyzer" !Start the AF Analyzer measurement.
160 OUTPUT 714;"FETCh:AFANalyzer:VOLTage?" !Fetch the Audio Level result.
170 ENTER 714;Audio_level  !Enter the returned value into a variable.
180 END

Returned Values

The results returned by this program are:

  • Integrity returns the measurement integrity indicator (0 means a successful measurement with no errors). See Integrity Indicator .
  • Audio_level returns the analog audio level in volts rms.

Related Topics

Audio Analyzer Measurement Description

Audio Analyzer Troubleshooting

INITiate

SETup:AFANalyzer

FETCh:AFANalyzer


Programming a Distortion Measurement

Programming a Distortion Measurement

This section provides an example of how to make distortion measurements via GPIB. It is patterned after TIA/EIA IS-137, Audio Harmonic Distortion (section 2.2.2.5).

SINAD and Distortion measurements are affected by the same STATe and INITiate commands, so both measurements are enabled and triggered at the same time. However, measurement results are queried separately. See Audio Analyzer Measurement Description .

The following procedure assumes that the mobile's audio output is connected to the AUDIO IN connectors and the mobile is on an analog voice channel (AVC). The AVC is being modulated with a 1004 Hz tone at ۲ kHz peak deviation, and a 6000 Hz SAT at ۬ kHz peak deviation. It is also assumed that the Cell Power from the test set is set to -50 dBm (IS-137 standard).

  1. Configure audio analyzer measurement parameters using the SETup subsystem.
  2. Start the audio analyzer measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain audio analyzer measurement results.

Programming Example

10  OUTPUT 714;"SETup:AFANalyzer:CONTinuous OFF" !Set the audio analyzer
20                                           !measurements to single trigger mode.
30  OUTPUT 714;"SETup:AFANalyzer:PEAK:VOLTage 3V" !Set the Expected Amplitude level for
40                                                !audio input voltage in Vpeak.
50  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:STATe ON" !Turn on the SINAD and
60                                                  !distortion measurements.
70  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:FREQuency 1004 HZ" !Specify the audio
80                                      !frequency to use for the measurements.
90  OUTPUT 714;"SETup:AFANalyzer:FILTer CMessage" !Select the c-message filter.
100 OUTPUT 714;"SETup:AFANalyzer:DEMPhasis:STATe OFF" !Turn off de-emphasis.
110 OUTPUT 714;"SETup:AFANalyzer:EXPandor:STATe OFF" !Turn off the expandor.
120 OUTPUT 714;"SETup:AFANalyzer:TIMeout 3S" !Set a timeout value of 3 seconds
130                                      !in case the measurement cannot be made.
140 OUTPUT 714;"INITiate:AFANalyzer" !Start the AF Analyzer measurement.
150 OUTPUT 714;"FETCh:AFANalyzer:INTegrity?" !Query the integrity indicator to
160                           !verify that a reliable measurement was made.
170 ENTER 714;Integrity  !Enter the returned value into a variable for comparison
180                      !with possible integrity indicator values (not shown here).
190 IF Integrity=0 THEN  !Only fetch measurement result if integrity indicator is 0.
200 OUTPUT 714;"FETCh:AFANalyzer:DISTortion?" ! Fetch the Distortion result.
210 ENTER 714;Distortion !Enter the returned value into a variable.
220 END IF
230 END

Returned Values

The results returned by this program are:

  • Integrity returns the measurement integrity indicator; 0 means a successful measurement with no errors. See Integrity Indicator .
  • Distortion returns the Distortion measurement value in percent (%).

Related Topics

Audio Analyzer Measurement Description

Audio Analyzer Troubleshooting

Distortion Measurement Description

INITiate

SETup:AFANalyzer

FETCh:AFANalyzer


Programming a SINAD Measurement

Programming a SINAD Measurement

May 24, 2006

This section provides an example of how to make SINAD measurement via GPIB. It is patterned after TIA/EIA IS-137, Analog RF Sensitivity (section 2.3.1.1).

SINAD and Distortion measurements are affected by the same STATe and INITiate commands, so both measurements are enabled and triggered at the same time. However, measurement results are queried separately. See Audio Analyzer Measurement Description .

The following procedure assumes that the mobile's audio output is connected to the AUDIO IN connectors and the mobile is on an analog voice channel (AVC) that is being modulated with a 1004 Hz tone at ۲ kHz peak deviation. It is also assumed that the Cell Power from the test set is set to a minimum usable level (typically about -116 dBm).

  1. Configure audio analyzer measurement parameters using the SETup subsystem.
  2. Start the audio analyzer measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain audio analyzer measurement results.

Programming Example

10  OUTPUT 714;"SETup:AFANalyzer:CONTinuous OFF" !Set the audio analyzer
20                                           !measurements to single trigger mode.
30  OUTPUT 714;"SETup:AFANalyzer:PEAK:VOLTage 3V" !Set the Expected Amplitude level for
40                                                !audio input voltage in Vpeak.
50  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:STATe ON" !Turn on the SINAD and
60                                                  !distortion measurements.
70  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:FREQuency 1004 HZ" !Specify the audio
80                                      !frequency to use for the measurements.
90  OUTPUT 714;"SETup:AFANalyzer:FILTer CMESsage" !Select the c-message filter.
100 OUTPUT 714;"SETup:AFANalyzer:DEMPhasis:STATe OFF" !Turn off de-emphasis.
110 OUTPUT 714;"SETup:AFANalyzer:EXPandor:STATe OFF" !Turn off the expandor.
120 OUTPUT 714;"SETup:AFANalyzer:TIMeout 3S" !Set a timeout value of 3 seconds
130                                      !in case the measurement cannot be made.
140 OUTPUT 714;"INITiate:AFANalyzer" !Start the AF Analyzer measurement.
150 OUTPUT 714;"FETCh:AFANalyzer:INTegrity?" !Query the integrity indicator to
160                           !verify that a reliable measurement was made.
170 ENTER 714;Integrity  !Enter the returned value into a variable for comparison
180                      !with possible integrity indicator values (not shown here).
190 IF Integrity=0 THEN !Only fetch measurement result if integrity indicator is 0.
200 OUTPUT 714;"FETCh:AFANalyzer:SINAD?" !Fetch the SINAD result.
210 ENTER 714;Sinad  !Enter the returned value into a variable.
220 END IF
230 END

Returned Values

The results returned by this program are:

  • Integrity returns the integrity indicator (0 means a successful measurement with no errors). See Integrity Indicator .
  • SINAD returns the SINAD value in dB.

Related Topics

Audio Analyzer Measurement Description

Audio Analyzer Troubleshooting

INITiate

SETup:AFANalyzer

FETCh:AFANalyzer


Programming an Access Probe Power Measurement

Programming an Access Probe Power Measurement

Last Updated: May 24, 2006

General Programming Procedure

  1. Prompt the user to connect the access terminal to the test set's front panel RF IN/OUT connector and power it on. Instruct the user that if the access terminal does not automatically open a session, perform whatever actions are necessary to open a session. See Establish a Session from the Access Terminal for more details.
  2. Set up the access parameters as needed using the CALL:APARameter commands.
  3. Set up the access probe power measurement parameters as needed using the SETup:CAPPower commands.
  4. Turn on call limit mode so the test set does not acknowledge the access terminal's access attempt, using the CALL:CONNected:LIMit[:STATe]<[:SELected]|:TA856> command.
    NOTE: You must set all parameters that are configured during the Session Negotiate state (such as Probe Sequence Max ) before turning call limit mode on (see Call Limit Mode for more information).
  5. Set cell power as needed using the CALL:POWer command.
  6. Page the access terminal (to initiate access probes) using the CALL:FUNCtion:DATA:STARt command.
  7. Initiate the access probe power measurement using the INITiate:<measurement mnemonic>[:ON] command. The <measurement mnemonic> for the access probe power measurement is CAPPower.
  8. Use the FETCh:CAPPower commands to obtain the measurement results. (You can also replace steps 7 and 8 with a single command - READ:CAPPower[:ALL]? ).
  9. Use the CALL:FUNCtion:DATA:STOP command to stop paging the access terminal.

Programming Example: 4.3.1 Range of Open Loop Output Power

10 ! 4.3.1 Range of Open Loop Output Power
20 ! This programming example assumes the access terminal
30 ! is connected to the test set and in the session open state.
40 !
50       Testset=714
60 !
70       DISP "Testing Range of Open Loop Power"
80 !
90 !***Set up test parameters***
100 !
110       Ior1=-25
120       ! First level for test
130       Ior2=-65
140       ! Second level for test
150       Ior3=-93.5
160       ! Ior for test 3 Band Class 0, AT Class III
170       Ol_adjust=78
180       ! Set Open Loop Adjust for Band Class 0
190 !
200       OUTPUT Testset;"CALL:APAR:POWER:OLADJUST ";Ol_adjust
210       ! Set Open Loop Adjust
220       OUTPUT Testset;"CALL:APAR:PREAMBLE:LENGTH 7"
230       ! Set preamble length in frames
240       OUTPUT Testset;"CALL:APAR:PROBE:IADJUST 0"
250       ! Set Probe Initial Adjust
260       OUTPUT Testset;"CALL:APAR:PROBE:STEP:COUNT 1"
270       ! Set Probe Num Steps
280       OUTPUT Testset;"CALL:APAR:PROBE:SEQUENCE 1"
290       ! Set Probe Sequence Max
300       ! This must be done BEFORE call limit mode is turned on
310       OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP 0"
320       ! Set Probe Power Step
330 !
340 !***Set up measurement parameters***
350 !
360       OUTPUT Testset;"SETUP:CAPPOWER:CONTINUOUS OFF"
370       ! Set measurement to single trigger
380       OUTPUT Testset;"SETUP:CAPP:TIMEOUT 10"
390       ! Set access probe power timeout to 10 seconds
400 !
410 !***Set test conditions***
420 !
430       OUTPUT Testset;"CALL:CONNECTED:LIMIT:STATE 1"
440       ! Turn on call limit mode so connection is not established
450       ! This must be done AFTER probe sequence max is set
460 !
470 !***Obtain measurement results***
480 !
490       OUTPUT Testset;"CALL:POW ";Ior1
500       ! Set cell power for test 1
510       WAIT .1
520       ! Settling time for access terminal output power to slew
530       OUTPUT Testset;"CALL:FUNCTION:DATA:START"
540       ! Page access terminal
550       OUTPUT Testset;"READ:CAPP?"
560       ! Read access probe power
570       ENTER Testset;Integrity1,Test1
580       OUTPUT Testset;"CALL:FUNCTION:DATA:STOP"
590       ! Stop data connection paging before repaging at next level
600 !
610       OUTPUT Testset;"CALL:POW ";Ior2
620       ! Set cell power for test 2
630       WAIT .1
640       ! Settling time for mobile output power to slew
650       OUTPUT Testset;"CALL:FUNCTION:DATA:START"
660       ! Page access terminal
670       OUTPUT Testset;"READ:CAPP?"
680       ! Read access probe power
690       ENTER Testset;Integrity2,Test2
700       OUTPUT Testset;"CALL:FUNCTION:DATA:STOP"
710       ! Stop data connection paging before repaging at next level
720 !
730       OUTPUT Testset;"CALL:POW ";Ior3
740       ! Set cell power for test 3
750       WAIT .1
760       ! Settling time for mobile output power to slew
770       OUTPUT Testset;"CALL:FUNCTION:DATA:START"
780       ! Page access terminal
790       OUTPUT Testset;"READ:CAPP?"
800       ! Read access probe power
810       ENTER Testset;Integrity3,Test3
820       OUTPUT Testset;"CALL:FUNCTION:DATA:STOP"
830       ! Stop data connection paging
840 !
850 !***Print measurement results***
860 !
870       CLEAR SCREEN
880       PRINT "Range of Open Loop Output Power Test Results:"
890       PRINT
900       PRINT "Test 1 Integrity/Result = ";Integrity1,Test1
910       PRINT "Test 2 Integrity/Result = ";Integrity2,Test2
920       PRINT "Test 3 Integrity/Result = ";Integrity3,Test3
930       PRINT
940       PRINT "Range of Open Loop Output Power Test Complete"
950 !
960 !***Post test clean up***
970 !
980       OUTPUT Testset;"CALL:CONNECTED:LIMIT:STATE 0"
990       ! Turn off call limit mode
1000       ! Must do BEFORE can change probe max sequence
1010       OUTPUT Testset;"CALL:POW -55"
1020       ! Set Cell Power to default
1030       ! Do this before reconfiguring other parms so signaling
1040       ! is successful (don't want cell power too low for signaling)
1050       OUTPUT Testset;"CALL:APAR:PREAMBLE:LENGTH 7"
1060       ! Set preamble length in frames
1070       OUTPUT Testset;"CALL:APAR:PROBE:IADJUST 0"
1080       ! Set Probe Initial Adjust
1090       OUTPUT Testset;"CALL:APAR:PROBE:STEP:COUNT 3"
1100       ! Set Probe Num Steps
1110       OUTPUT Testset;"CALL:APAR:PROBE:SEQUENCE 1"
1120       ! Set Probe Sequence Max
1130       OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP 3"
1140       ! Set Probe Step
1150 !
1160       OUTPUT Testset;"INIT:CAPP:OFF"
1170       ! Set access probe power meas off
1180       DISP ""
1190 !
1200       END

Related Topics

Access Probe Power Measurement Description

Manual Operation: Measuring Access Probe Power


Programming a Fast Device Tune Measurement

Programming a Fast Device Tune Measurement

Last updated: June 30, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

This section provides an example of how to make a Fast Device Tune (FDT) measurement via GPIB.

The following program example assumes that the access terminal (AT) is connected to the test set's RF IN/OUT connector.

The basic procedure to make the FDT measurement is as follows:

  1. Set the test set's initial conditions required for FDT measurement (refer to Set_init_cond subroutine):
    set the operating mode to IS-856 Test mode, measurement frequency to manual mode, receiver power to manual mode, and RF generator frequency control to manual mode.
  2. Set the MS Rx Frequency/Power series (10 power step levels at 4 frequency points) on the test set to match your AT's configuration (refer to Set_msrx_series subroutine). See SETup:CFDTune for details on the commands.
  3. Set the MS Tx Frequency/Power series (10 power step levels at 4 frequency points) on the test set to match your AT's configuration (refer to Set_mstx_series subroutine). See SETup:CFDTune for details on the commands.
  4. Verify that your AT is placed into the test mode and has properly configured for calibration.
  5. Order the MS to transmit continuously at >20 dB below the power level of the first step in the MS TX Power Sequence.
    Note: If your MS TX Power Sequence starts at a power level that is less than 20 dB above the minimum transmit power of your MS, then you must include a trigger pulse as the first step in the MS TX Power Sequence. The power level of this trigger pulse will be measured by the test set as one of the steps in the sequence.
  6. Initiate (arm) the FDT measurement using the INITiate:<measurement mnemonic>[:ON] (this prepares the test set's hardware to execute the frequency/power series you've specified and arms the measurement's RF rise trigger).
  7. Send the INITiate:CFDTune:ARMed? query and wait for it to return a value of 1 , indicating that the measurement is armed and ready to be triggered.
  8. Order your AT to begin transmission of its MS TX Frequency/Power Series (the MS should then increase its output power by more than 20 dB to reach the first step in the series, which triggers the measurement with an RF rise).
  9. Once triggered, the FDT measurement performs a series of channel power measurements at each step of the MS TX Frequency/Power Series. When finished, use the FETCh:CFDTune commands to obtain power results for all of the measured steps.

Programming Example

10 ! ====================================================================
20 ! This program is intended to control the 1xEV-DO Fast Devie Tune
30 ! measurement for use with the Qualcomm 6500 MS.
40 ! ====================================================================
50 !
60 ! *** Initialize Program Variables ***
70 !
80 OPTION BASE 0
90 Testset=714
100 CLEAR SCREEN
110 CLEAR 7
120 CLEAR Testset
130 PRINT "*** Fast Device Tune (CFDT) Measurement Program for 1xEV-DO***"
140 PRINT
150 !
160 !***Set up GPIB timeout***
170 ON TIMEOUT 7,32 CALL Timeout
180 ! Call "Timeout" routine after 32 seconds of GP-IB hang-up
190 !
200 ! *** Variable declarations for the FDT measurements ***
210 DIM Mstx_pow$[8000]
220 !
230 ALLOCATE REAL Mstx_pow_res(0:399)
240 Sz=16*(20+19)   !ASCII Arrays = 16*(20+19) elements
250 ALLOCATE Freq_rx$[Sz],Pow_rx$[Sz],Freq_tx$[Sz],Pow_tx$[Sz]
260 !
270 Op_mode$="TEST856"   !Operation mode.
280 Meas_timeout=15  !Measurement timeout.
290 !
300 Num_freq_steps=4  !Number of Rx and Tx Frequency Steps
310 Num_pow_steps=10   !Number of Rx and Tx Power Steps
320 !
330 Str_ind_freq_rx=0        !Start Index of Rx Frequencies to be hopped
340 Str_ind_pow_rx=0         !Start Index of Rx Power series
350 Freq_rx$="872E6, 873E6, 874E6, 875E6"
351 !Forward Channel Frequencies in Band Class 0 (US Cellular)
360 Pow_rx$="-15,-20,-25,-60,-35,-40,-45,-50,-55,-60"
370 !
380 Str_ind_freq_tx=0        !Start Index of Tx Frequency series
390 Str_ind_pow_tx=0         !Start Index of Tx Power series
400 Freq_tx$="827.2E6, 828E6, 829E6, 830E6"
401 !Reverse Channel Frequencies in Band Class 0 (US Cellular)
410 Pow_tx$="0,-5,-10,-15,-20,-25,-30,-35,-40,-45"
420 !
430 !Uncomment the pass loss varables and set the value as needed.
440 !Loss_frequency$=" 8.3652E+8,8.60E+8" !Set frequencies for path loss.
450 !Expected_loss$=" -1.5,-1.5" !Set path loss at frequencies specified
460 !
470 !************************************
480 !***Simple Test Executive
490 !************************************
500 !
510 GOSUB Preset_test_set
520 !End any current connection and preset test set
530 !GOSUB Set_path_loss
540 !If needed, uncomment this line and set the pass loss required for your test.
550 GOSUB Set_init_cond
560 !Set initial conditions required for the FDT test
570 GOSUB Set_msrx_series
580 !Set up the MS Rx Freq/Power Series
590 GOSUB Set_mstx_series
600 !Set up the MS Tx Freq/Power Series
610 GOSUB Check_ms_config
620 !Check MS settings matching what you've set on the test set
630 GOSUB Fdt_meas
640 !Make the Fast Device Tune measurement.
650 GOTO End_program
660   !
670 !
680 !**************************************************************************
690 ! BEGINNING OF SUBROUTINES
700 !**************************************************************************
710 !
720 !
730  Preset_test_set:     !
740     !*******************************************************************
750     ! Subroutine: Preset the test set (Step 1: Set Up the Test Set)
760     !*******************************************************************
770       !
780 OUTPUT Testset;"*RST"
790     ! Full preset test set
800 OUTPUT Testset;"*OPC?"
810 ENTER Testset;Opc$
820 RETURN
830      !
840  Set_path_loss: !
850  !*******************************************************************
860  ! Subroutine: Set path loss values
870  !*******************************************************************
880       !
890 OUTPUT Testset;"SYST:CORR:FREQ";Loss_frequency$
900     ! Set the frequencies for amplitude offset
910 OUTPUT Testset;"SYST:CORR";Expected_loss$
920     ! Set the amplitude offsets for above frequencies
930 RETURN
940       !
950  Set_init_cond: !
960  !*******************************************************************
970  ! Subroutine: Set initial conditions required for the FDT Test
980  !*******************************************************************
990        !
1000     !GOSUB Set_path_loss !Set pass loss as required for your test
1010     !If needed, uncomment above line
1020 OUTPUT Testset;"CALL:OPER:MODE ";Op_mode$
1030     !Set Operating Mode to IS856 Test Mode
1040 OUTPUT Testset;"SET:CFDT:TIM "&VAL$(Meas_timeout)
1050     !Set measurement timeout.
1060 OUTPUT Testset;"CALL:CONT:DOWN:FREQ:AUTO OFF"
1070     !Set RF generator frequency control to manual mode.
1080 OUTPUT Testset;"RFAN:CONT:MEAS:FREQ:AUTO OFF"
1090     !Set receiver measurement frequency control to manual mode.
1100 OUTPUT Testset;"RFAN:CONT:POW:AUTO OFF"
1110     !Set receiver power control to manual mode.
1120 RETURN
1130 !
1140  Set_msrx_series: !
1150      !*******************************************************************
1160      ! Subroutine: Set up the MS Rx Freq/Power Series
1170      !*******************************************************************
1180     !
1190 PRINT "*** Set the number of Tx/Rx Frequency and Power Steps ***"
1200 OUTPUT Testset;"SET:CFDT:FREQ:STEP:COUN ";Num_freq_steps
1210 OUTPUT Testset;"SET:CFDT:POW:STEP:COUN ";Num_pow_steps
1220 PRINT "Number of Tx/Rx Frequency Steps =";Num_freq_steps
1230 PRINT "Number of Tx/Rx Power Steps =";Num_pow_steps
1240 PRINT
1250 PRINT "*** Set MS Rx Freq/Power Series ***"
1260 Stp_ind_freq_rx=Str_ind_freq_rx+Num_freq_steps
1270     !Compute Stop Index of Frequency steps
1280 Stp_ind_pow_rx=Str_ind_pow_rx+Num_pow_steps
1290     ! Compute Stop Index of Power steps
1300     !
1310     ! Check for Mx Rx Test Freq/Power Indicies Out of Range
1320 IF (Stp_ind_freq_rx<40 AND Stp_ind_pow_rx<40) THEN
1330      ! Set MS Rx Frequency and Power Start Indicies
1340 OUTPUT Testset;"SET:CFDT:MS:RX:FREQ:STEP:STAR:IND ";Str_ind_freq_rx
1350 OUTPUT Testset;"SET:CFDT:MS:RX:POW:STEP:STAR:IND ";Str_ind_pow_rx
1360 PRINT "MS Rx Test Start Freq Index = ";Str_ind_freq_rx
1370 PRINT "MS Rx Test Start Power Index = ";Str_ind_pow_rx
1380 ELSE
1390   PRINT
1400   PRINT "Error-The number of freq steps or power steps Out of Range (>40)"
1410   PRINT
1420   PRINT "Program Stopped"
1430   STOP
1440 END IF
1450       !
1460     !*** Set MS Rx Freq/Power Values ***
1470 OUTPUT Testset;"SET:CFDT:MS:RX:FREQ:STEP ";Freq_rx$
1480 PRINT "MS Rx Test Freq Seires = ";Freq_rx$
1490 OUTPUT Testset;"SET:CFDT:MS:RX:POW:STEP ";Pow_rx$
1500 PRINT "MS Rx Test Power Series = ";Pow_rx$
1510 PRINT
1520     !
1530 RETURN
1540     !
1550  Set_mstx_series:  !
1560   !*******************************************************************
1570   ! Subroutine: Set up the MS Tx Freq/Power Series
1580   !*******************************************************************
1590 PRINT "*** Set MS Tx Freq/Power Series ***"
1600 Stp_ind_freq_tx=Str_ind_freq_tx+Num_freq_steps
1610     !Compute Stop Index of Frequency steps
1620 Stp_ind_pow_tx=Str_ind_pow_tx+Num_pow_steps
1630     ! Compute Stop Index of Power steps
1640     !
1650     ! Check for Mx Tx Test Freq/Power Indicies Out of Range
1660 IF (Stp_ind_freq_tx<40 AND Stp_ind_pow_tx<40) THEN
1670         ! Set MS Tx Frequency and Power Start Indicies
1680 OUTPUT Testset;"SET:CFDT:MS:TX:FREQ:STEP:STAR:IND ";Str_ind_freq_tx
1690 OUTPUT Testset;"SET:CFDT:MS:TX:POW:STEP:STAR:IND ";Str_ind_pow_tx
1700 PRINT "MS Tx Test Start Freq Index =";Str_ind_freq_tx
1710 PRINT "MS Tx Test Start Power Index =";Str_ind_pow_tx
1720 ELSE
1730 PRINT
1740 PRINT "Error-The number of freq steps or power steps Out of Range (>40)"
1750 PRINT
1760 PRINT "Program Stopped"
1770 STOP
1780 END IF
1790       !
1800      !*** Set MS Tx Freq/Power Values ***
1810      !
1820 OUTPUT Testset;"SET:CFDT:MS:TX:FREQ:STEP ";Freq_tx$
1830 PRINT "MS Tx Test Freq Series = ";Freq_tx$
1840 OUTPUT Testset;"SET:CFDT:MS:TX:POW:STEP ";Pow_tx$
1850 PRINT "MS Tx Test Power Series = ";Pow_tx$
1860 PRINT
1870     !
1880 RETURN
1890 !
1900  Check_ms_config:     !
1910     !*******************************************************************
1920     ! Subroutine: Check AT Configuration Matching Test Set's
1930     !*******************************************************************
1940 PRINT "************** NOTE *****************************************"
1950 PRINT "Make sure that your AT is placed into a test mode, and is properly"
1960 PRINT "configured to measure the MS Rx Freq/Power series and transmit"
1970 PRINT "the MS Tx Freq/Power series you've set in the test set."
1980 PRINT
1990 PRINT "Order your AT to transmit continuously at >20 dB below the power level"
2000 PRINT "of the first step in MS Tx Power Series, for at least 1 ms"
2010 PRINT "*************************************************************"
2020 PRINT
2030 LINPUT "Press ENTER when finished",Keyboard$
2040 RETURN
2050       !
2060  Fdt_meas:!
2070   !*******************************************************************
2080   ! Subroutine: Perform FDT Measurement
2090  !*******************************************************************
2100 !
2110 OUTPUT Testset;"INIT:CFDT"
2120 !Arm the FDT measurement and start to build the MS Tx and Rx Freq/Power Series.
2130 OUTPUT Testset;"INIT:CFDT:ARMed?"
2140 !Queries that the MS Tx and Rx Freq/Power Series is successfully built
2150 !and the test set is ready for test.
2160 ENTER Testset;Meas_arm
2170 IF Meas_arm THEN
2180   PRINT "Command the AT to trigger the measurement (20 dB RF rise)..."
2190   LINPUT "Press ENTER when finished",Keyboard$
2200   LOOP
2210       OUTPUT Testset;"INITiate:DONE?"
2220       !Query to find out if FDT measurement is done.
2230       ENTER Testset;Meas_done$
2240       SELECT Meas_done$
2250         CASE "CFDT"
2260         ! test for the string "CFDT" indicating
2270         ! Fast Device Tune measurement is done.
2280         !***Obtain measurement results***
2290         OUTPUT Testset;"FETC:CFDT?"
2300         ENTER Testset;Integrity,Freq_step_cnt,Pow_step_cnt,Num_meas,Mstx_pow$
2310       END SELECT
2320       EXIT IF Meas_done$="NONE"
2321       ! Exit loop when the measurement completes
2330   END LOOP
2331   ! If Meas_done$="WAIT" then loop continues until "NONE"
2340 ELSE
2350   PRINT "The test set is not properly armed. Please check the MS Tx and"
2360   PRINT "Rx Freq/Power Series Setups."
2370   GOTO End_program
2380 END IF
2390      !
2400 PRINT "*** Print MS Tx Measurement Results ***"
2410 PRINT
2420 PRINT "Integrity = ";Integrity
2430 PRINT "Number of Freq Steps = ";Freq_step_cnt
2440 PRINT "Number of Power Steps = ";Pow_step_cnt
2450 PRINT "Total Number of Meas Results = ";Num_meas
2460 PRINT
2470     !
2480     !Convert ASCII Arra to Real Array
2490 FOR N=1 TO Num_meas
2500   Dynamic_mkr=((N-1)*17)
2510   !Set up a marker that will jump to each comma in the ascii string
2520   Mstx_pow_res(N)=VAL(Mstx_pow$[Dynamic_mkr+1,Dynamic_mkr+16])
2530   !Convert ascii to a numeric value
2540 NEXT N
2550       !
2560     ! PRINT "MS Tx Power Results:"
2570 PRINT "Freq Step #   Power Step #  Meas Power[dBm/1.23MHz]"
2580 PRINT
2590 FOR N_freq=0 TO Freq_step_cnt-1
2600   FOR N_pow=0 TO Pow_step_cnt-1
2610    PRINT N_freq+1," ",N_pow+1," ",Mstx_pow_res(N_freq*Pow_step_cnt+N_pow+1)
2620   NEXT N_pow
2630 PRINT
2640 NEXT N_freq
2650   !
2660 RETURN
2670  !
2680  End_program:!
2690     !*******************************************************************
2700     ! Subroutine: End of all testing clean up
2710     !*******************************************************************
2720       !
2730 OUTPUT Testset;"*RST"
2740 !Full preset test set
2750 OUTPUT Testset;"*OPC?"
2760 ENTER Testset;Opc$
2770 DEALLOCATE Mstx_pow_res(*),Freq_rx$,Pow_rx$,Freq_tx$,Pow_tx$
2780 PRINT
2790 PRINT "End of Program"
2800 END
2810 !
2820 !**************************************************************************
2830 ! SUB-PROGRAM SECTION
2840 !**************************************************************************
2850       !
2860  Timeout: SUB Timeout       ! Global timeout handler
2870    PRINT
2880    PRINT "Program timed out, check setup"
2890    CLEAR 7
2900    CLEAR Testset
2910    STOP
2920 SUBEND
2930 !

The measurement results include an integrity indicator, number of the frequency steps (Freq_step_cnt), number of the power steps at each frequency (Pow_step_cnt), total number of the measured power steps (Num_meas should equal to Freq_step_cnt * Pow_step_cnt), followed by Num_meas of power results transmitted by the AT.

A sample output from this program example is shown below:

Related Topics

Fast Device Tune Measurement Description


Comprehensive Program Example for AT Test (based on TAP test data connection)

Comprehensive Program Example for AT Test (based on TAP test data connection)

Last updated: May 24, 2006

10 !******************************************************************************
20 ! E1966A Comprehensive Programming Example
30 ! Revision: Nov. 22, 2002
40 !
50 ! This program opens an RTAP connection with a 1xEV-DO Access Terminal and
60 ! measures waveform quality, maximum power, minimum power,
70 ! TX spurious emissions, TROLPC, and range of open loop power.
80 ! It then moves to an FTAP connection and measures receiver sensitivity,
90 ! receiver dymanic range, and demodulation of traffic channel in AWGN.
100 !
110 ! The simple test executive allows you to set the test sequence by using gosubs
120 ! to call subroutines for each test.
130 !
140 ! You may un-comment handoffs and test subroutine calls and perform the
150 ! tests at various channels as needed.
160 !******************************************************************************
170 !
180 !***Initialize program variables***
190 !
200       OPTION BASE 1
210 !
220       COM Testset,Result_file$[30] ! Declare common variables
230       COM /File/Openfile_flag
240       ! Results file open flag,
250       ! 1=Open a results file, 0=No results file opened
260       ! Results file is stored under C:\Results\
270 !
280       DIM Pass_fail$[40]           ! Declare Pass or Fail indication string
290       DIM Sector_id$[40]           ! Declare Sector ID string
300       DIM Awgn_per_data$(18,3)[12]
310       ! Declare array to hold data AWGN PER test
320 !
330       Testset=714
340       ! Set "Testset" to GPIB address of test set
350 !
360       CLEAR SCREEN                 ! Clear the PC display
370 !
380 !***Set up GPIB timeout***
390 !
400       ON TIMEOUT 7,20 CALL Timeout
410       ! Call "Timeout" routine after 20 seconds of GP-IB hang-up
420 !
430 !**************************************************************************
440 ! STEP 1: SET UP THE TEST SET
450 !**************************************************************************
460 !
470 !***Turn on GPIB debugger.  Comment out when done debugging program***
480 !
490       OUTPUT Testset;"SYST:COMM:GPIB:DEB:STAT ON"
500       ! Turn debug state on
510 !
520 !***Set system path loss values.  Include cable and coupler losses.***
530 !
540       Loss_frequency$=" 800 MHZ,2000 MHZ"
550       ! Set frequencies for amplitude offset (path loss)
560       Expected_loss$=" -1.5,-1.5"
576       ! Set path loss at frequencies specified
580 !
590       OUTPUT Testset;"SYSTEM:BEEPER:STATE OFF"
600       ! Turn Off System Beeper
610 !
620 !**************************************************************************
630 ! STEP 2: CONFIGURE TEST SET AND ACCESS TERMINAL PARAMETERS
640 !**************************************************************************
650 !
660 !***Variable declarations for call setup. (AT-specific, change as needed)***
670 !
680       Band$="USPCs"                  ! Set cell band to US PCS
690       Primary_channel=400          ! Set RF channel for access network
700       Country_code=310             ! Set Access Terminal Country Code
710       Subnet_mask=104              ! Set Sector Subnet mask
720       At_max_power$="DBM23"        ! Set AT Maximum Power
730                                    ! (DBM8, DBM13, DBM18, DBM20, DBM23
740                                    !  DBM27, DBM28, DBM31, DBM33)
750       Init_cell_power=-50
760       ! Set initial cell power for connection setup
770       Current_chan=Primary_channel
780       ! Set the current channel to equal primary channel
790 !
800 !**************************************************************************
810 ! SIMPLE TEST EXECUTIVE
820 !**************************************************************************
830 !
840 !**************************************************************************
850 ! STEP 1: SET UP THE TEST SET
860 !**************************************************************************
870 !
880       GOSUB Preset_test_set
890       ! End any current connection and preset test set
900       GOSUB Set_path_loss
910       ! Set path loss values into test set RF Offset Table
920 !
930 !**************************************************************************
940 ! STEP 2: CONFIGURE TEST SET AND ACCESS TERMINAL PARAMETERS
950 !**************************************************************************
960 !
970       OUTPUT Testset;"CALL:APPLICATION:TAPROTOCOL:LIMITED OFF"
980       ! If you are testing an access terminal with Qualcomm
990       ! DMSS 5500 Release 3.1, you must set Limited TAP to On
1000 !
1010       GOSUB Set_call_parms         ! Set up Access Terminal parameters
1020 !
1030 !**************************************************************************
1040 ! STEP 3: SET MEASUREMENT PARAMETERS
1050 !**************************************************************************
1060 !
1070       GOSUB Set_up_meas
1080       ! Set all measurement triggering to single
1090 !
1100 !***Start test time***
1110 !
1120       GOSUB Start_time
1130 !
1140 !**************************************************************************
1150 ! STEP 4: MAKE A CONNECTION (Open a session and open an RTAP connection)
1160 !**************************************************************************
1170 !
1180       GOSUB Session_open
1190       ! Open a session with the AT and read AT parameters
1200 !
1210 !**************************************************************************
1220 !***Open results file***
1230 !
1240       Openfile_flag=1
1250       IF Openfile_flag THEN GOSUB Open_rslts_file
1260       ! Store results in text file, file name= hid+current time
1270 !
1280 !***Print ACCESS TERMINAL information***
1290 !
1300       Print_title("Access Terminal Information:")
1310       PRINT
1320       Print_res_str("Session Seed:",Sseed$)
1330       Print_res_str("Hardware ID Type:",Hid_type$)
1340       Print_res_str("Hardware ID Hex:",Hid_hex$)
1350       Print_res_str("Hardware ID Dec:",Hid_dec$)
1360       Print_title(" ")
1370 !**************************************************************************
1380 !
1390       GOSUB Rtap_connect
1400       ! Open an RTAP connection
1410 !
1420 !***Hand off to first channel to be tested***
1430 !
1440       !Handoff_band$="USPCS"
1450       ! Only specify handoff band when performing interband HO
1460       !Handoff_chan=75
1470       ! Hand off to "low" channel for test
1480       !GOSUB Handoff
1490       ! Hand off to the handoff band and channel specified
1500 !
1510 !**************************************************************************
1520 ! STEP 5: INITIATE AND FETCH TX MEASUREMENTS
1530 !**************************************************************************
1540 !
1550       GOSUB Waveform_qual          ! Test waveform quality
1560       GOSUB Max_pow_spur           ! Test max power and TX spurious emissions
1570       GOSUB Min_pow                ! Test min power
1580       GOSUB Time_resp_olp          ! Test time response of open loop power
1590       GOSUB Rng_open_loop          ! Test range of open loop output power
1600 !
1610 !**************************************************************************
1620 ! STEP 6: RECONFIGURE TEST SET AND AT PARMS (Change to an FTAP connection)
1630 !**************************************************************************
1640 !
1650       GOSUB Ftap_connect           ! Change to an FTAP connection
1660 !
1670 !**************************************************************************
1680 ! STEP 5: INITIATE AND FETCH RX MEASUREMENTS
1690 !**************************************************************************
1700 !
1710       GOSUB Sensitivity            ! Test receiver sensitivity
1720       GOSUB Dynamic_range          ! Test dynamic range
1730       GOSUB Traf_per_awgn          ! Test demod of traffic channel in AWGN
1740 !
1750 !**************************************************************************
1760 ! STEP 6: RECONFIGURE TEST SET AND ACCESS TERMINAL CONNECTION PARAMETERS
1770 !         (Perform a handoff to a new channel and repeat testing as needed)
1780 !**************************************************************************
1790 !
1800 !      GOSUB Rtap_connect         ! Move to an RTAP connection
1810 !      Handoff_chan=1023          ! Hand off to "high" channel for test
1820 !      GOSUB Handoff
1830 !
1840 !      GOSUB Waveform_qual
1850 !      GOSUB Max_pow_spur
1860 !      GOSUB Min_pow
1870 !      GOSUB Time_resp_olp
1880 !      GOSUB Rng_open_loop
1890 !
1900 !      GOSUB Ftap_connect         ! Move to an FTAP connection
1910 !
1920 !      GOSUB Sensitivity
1930 !      GOSUB Dynamic_range
1940 !      GOSUB Traf_per_awgn
1950 !
1960 !      GOSUB Rtap_connect         ! Move to an RTAP connection
1970 !      Handoff_chan=799           ! Hand off to "medium" channel for test
1980 !      GOSUB Handoff
1990 !
2000 !      GOSUB Waveform_qual
2010 !      GOSUB Max_pow_spur
2020 !      GOSUB Min_pow
2030 !      GOSUB Time_resp_olp
2040 !      GOSUB Rng_open_loop
2050 !
2060 !      GOSUB Ftap_connect         ! Move to an FTAP connection
2070 !
2080 !      GOSUB Sensitivity
2090 !      GOSUB Dynamic_range
2100 !      GOSUB Traf_per_awgn
2110 !
2120 !**************************************************************************
2130 ! STEP 7: END THE CONNECTION
2140 !**************************************************************************
2150 !
2160  End_exec:!
2170       GOSUB End_connection                 ! End the current connection
2180       GOSUB End_time                       ! Stop test time
2190       GOTO End_program
2200       ! Jump to end of program. Do not remove this line.
2210       ! Must jump over the sub-routines to the end.
2220                                              !
2230 !**************************************************************************
2240 !
2250 !**************************************************************************
2260 ! BEGINNING OF SUBROUTINES
2270 !**************************************************************************
2280 !
2290  Preset_test_set:!
2300 !*******************************************************************
2310 ! Subroutine: Preset the test set (Step 1: Set Up the Test Set)
2320 !*******************************************************************
2330 !
2340       OUTPUT Testset;"*RST"
2350       ! Full preset test set
2360       OUTPUT Testset;"*OPC?"
2370       ENTER Testset;Opc$
2380       RETURN
2390 !
2400  Set_path_loss:!
2410 !*******************************************************************
2420 ! Subroutine: Set path loss values (Step 1: Set Up the Test Set)
2430 !*******************************************************************
2440 !
2450       OUTPUT Testset;"SYST:CORR:FREQ";Loss_frequency$
2460       ! Set the frequencies for amplitude offset
2470       OUTPUT Testset;"SYST:CORR";Expected_loss$
2480       ! Set the amplitude offsets for above frequencies
2490       RETURN
2500 !
2510  Set_call_parms:!
2520 !*******************************************************************
2530 ! Subroutine: Step 2: Configure Test Set and Access Terminal Parameters
2540 !*******************************************************************
2550 !
2560       DISP "Setting up Test Set and Access Terminal Parameters"
2570 !
2580       OUTPUT Testset;"CALL:BAND ";Band$
2590       ! Set Cell Band
2600       OUTPUT Testset;"CALL:CHAN ";Primary_channel
2610       ! Set RF Channel for selected Cell Band
2620       OUTPUT Testset;"CALL:POW ";Init_cell_power
2630       ! Set and turns on Cell Power for connection
2640       OUTPUT Testset;"CALL:MS:POWER:MAXIMUM "&At_max_power$
2650       ! Set AT maximum expected power
2660       OUTPUT Testset;"CALL:MCCODE ";Country_code
2670       ! Set AT country code specified
2680       OUTPUT Testset;"CALL:PARAMETER:SECTOR:SMASK ";Subnet_mask
2690       ! Set MS subnet mask specified
2700       RETURN
2710 !
2720  Set_up_meas:!
2730 !*******************************************************************
2740 ! Subroutine: Set all measurement triggers to single
2750 !             (Step 3: Set Meas Parms)
2760 !*******************************************************************
2770 !
2780       OUTPUT Testset;"SETUP:CONTINUOUS:OFF"
2790       ! Set all measurements to single trigger
2800       RETURN
2810 !
2820  Session_open:!
2830 !*******************************************************************
2840 ! Subroutine: Open session
2850 !*******************************************************************
2860 !
2870       OUTPUT Testset;"CALL:DCONNECTED:TIMEOUT 30"
2880       ! Set connection change detector timeout
2890       OUTPUT Testset;"CALL:DCONNECTED:ARM"
2900       ! Arm the connection state change detector
2910 !
2920       BEEP
2930       LINPUT "Connect AT and power on, press ENTER when session open",Keyboard$
2940       DISP "Verifying session is open"
2950 !
2960       OUTPUT Testset;"CALL:SOPEN?"
2970       ! Query the session open state
2980       ENTER Testset;Session_open
2990       IF Session_open=0 THEN
3000       ! If session did not open then end program
3010           BEEP
3020           Print_title("Access Terminal did not open session, check settings")
3030           Print_title("Terminating Testing")
3040           GOTO End_program
3050       END IF
3060 !
3070       DISP "Session Open"
3080 !
3090 !***Read ACCESS TERMINAL information***
3100 !
3110       OUTPUT Testset;"CALL:MS:REP:SSEED?"
3120       ENTER Testset;Sseed$
3130       OUTPUT Testset;"CALL:MS:REP:HID:TYPE?"
3140       ENTER Testset;Hid_type$
3150       OUTPUT Testset;"CALL:MS:REP:HID:HEX?"
3160       ENTER Testset;Hid_hex$
3170       OUTPUT Testset;"CALL:MS:REP:HID:DEC?"
3180       ENTER Testset;Hid_dec$
3190 !
3200       RETURN
3210 !
3220  Rtap_connect:!
3230 !*******************************************************************
3240 ! Subroutine: Open an RTAP connection
3250 !*******************************************************************
3260 !
3270       DISP "Opening (or Moving to) an RTAP Connection"
3280 !
3290       IF NOT FNConnected THEN
3300           DISP "Connection is not currently open"
3310           ! If the state is NOT connected, then see if it is session open
3320 !
3330           IF NOT FNSession_check THEN
3340           ! If the state is NOT session open, then end program
3350               Print_title("Session is not currently open")
3360               Print_title("Ending Testing")
3370               GOTO End_program
3380           END IF
3390           ! If the state is session open, then change to RTAP and
3400           ! open a connection
3410           DISP "Session is open, opening an RTAP connection now"
3420 !
3430           OUTPUT Testset;"CALL:APPLICATION RTAP"
3440           ! Set application type to RTAP (for TX testing)
3450           OUTPUT Testset;"CALL:APPLICATION:RTAP:DRATE BPS9600"
3460           ! Set RTAP data rate to 9600 kbps
3470           GOSUB Start_data
3480 !
3490       ELSE
3500           DISP "Connection is currently open, changing to RTAP"
3510           ! If state is connected, then change to RTAP
3520           OUTPUT Testset;"CALL:APPLICATION RTAP"
3530           ! Set application type to RTAP (for TX testing)
3540           OUTPUT Testset;"CALL:APPLICATION:RTAP:DRATE BPS9600"
3550           ! Set RTAP data rate to 9600 kbps
3560 !
3570           IF NOT FNConnected THEN
3580           ! This additional loop is only necessary if Limited TAP is On
3590               DISP "Connection was closed when Application changed"
3600               ! If the state is NOT connected, then see if session open
3610               IF NOT FNSession_check THEN
3620               ! If the state is NOT session open, then end program
3630                   Print_title("Session is not currently open")
3640                   Print_title("Ending Testing")
3650                   GOTO End_program
3660               END IF
3670               ! If the state is session open, then re-open a connection
3680               DISP "Session is open, re-opening an RTAP connection now"
3690               GOSUB Start_data
3700           END IF
3710 !
3720           DISP "RTAP Connection Open"
3730 !
3740       END IF
3750 !
3760       RETURN
3770 !
3780  Ftap_connect:!
3790 !*******************************************************************
3800 ! Subroutine: Open an FTAP connection
3810 !*******************************************************************
3820 !
3830       DISP "Opening (or Moving to) an FTAP Connection"
3840 !
3850       IF NOT FNConnected THEN
3860           DISP "Connection is not currently open"
3870           ! If the state is NOT connected, then see if it is session open
3880 !
3890           IF NOT FNSession_check THEN
3900           ! If the state is NOT session open, then end program
3910               Print_title("Session is not currently open")
3920               Print_title("Ending Testing")
3930               GOTO End_program
3940           END IF
3950           ! If the state is session open, then change to FTAP and
3960           ! open a connection
3970           DISP "Session is open, opening an FTAP connection now"
3980 !
3990           OUTPUT Testset;"CALL:APPLICATION FTAP"
4000           ! Set application type to FTAP (for RX testing)
4010           OUTPUT Testset;"CALL:APPLICATION:FTAP:DRATE S02B307200"
4020           ! Set FTAP data rate to 2-slot 307.2 kbps
4030           GOSUB Start_data
4040 !
4050       ELSE
4060           DISP "Connection is currently open, changing to FTAP"
4070           ! If state is connected, then change to FTAP
4080           OUTPUT Testset;"CALL:APPLICATION FTAP"
4090           ! Set application type to FTAP (for RX testing)
4100           OUTPUT Testset;"CALL:APPLICATION:FTAP:DRATE S02B307200"
4110           ! Set FTAP data rate to 2-slot 307.2 kbps
4120 !
4130           IF NOT FNConnected THEN
4140               DISP "Connection was closed when Application changed"
4150               ! If the state is NOT connected, then see if session open
4160               IF NOT FNSession_check THEN
4170               ! If the state is NOT session open, then end program
4180                   Print_title("Session is not currently open")
4190                   Print_title("Ending Testing")
4200                   GOTO End_program
4210               END IF
4220               ! If the state is session open, then re-open a connection
4230               DISP "Session is open, re-opening an FTAP connection now"
4240               GOSUB Start_data
4250           END IF
4260 !
4270           DISP "FTAP Connection Open"
4280 !
4290       END IF
4300 !
4310       RETURN
4320 !
4330  Start_data:!
4340 !*******************************************************************
4350 ! Subroutine: Start data connection and verify it has connected
4360 !*******************************************************************
4370 !
4380       OUTPUT Testset;"CALL:DCONNECTED:TIMEOUT 10"
4390       ! Set connection change detector timeout
4400       OUTPUT Testset;"CALL:DCONNECTED:ARM"
4410       ! Arm the connection state change detector
4420       OUTPUT Testset;"CALL:FUNCTION:DATA:START"
4430       ! Page the access terminal
4440       OUTPUT Testset;"CALL:DCONNECTED?"
4450       ! Query the connection status
4460       ENTER Testset;Data_started
4470 !
4480       IF Data_started=0 THEN
4490           Print_title("Data connection could not be opened")
4500           Print_title("Ending Testing")
4510           GOTO End_program
4520       END IF
4530 !
4540       DISP "Data Connection Open"
4550 !
4560       RETURN
4570 !
4580  Handoff:!
4590 !*******************************************************************
4600 ! Subroutine: Set up and perform a hard handoff
4610 !*******************************************************************
4620 !
4630 !***Set up a hard handoff***
4640 !
4650       OUTPUT Testset;"CALL:SETUP:BAND "&Handoff_band$
4660       ! Specify the cell band to hand off to
4670       OUTPUT Testset;"CALL:SETUP:CHANNEL ";Handoff_chan
4680       ! Specify the channel number to hand off to
4690 !
4700 !***Perform a hard handoff***
4710 !
4720       OUTPUT Testset;"CALL:HANDOFF"
4730       ! Initiate a hard handoff
4740 !
4750       IF NOT FNConnected THEN
4760       ! Verify connection is still open after handoff
4770           DISP "Handoff attempt failed, program stopped"
4780           GOTO End_program
4790       ELSE
4800           PRINT
4810           Print_results("Handoff completed to channel: ",Handoff_chan,"")
4820           PRINT "Call connected"
4830           PRINT
4840           Current_chan=Handoff_chan
4850           Band$=Handoff_band$
4860 !
4870       END IF
4880 !
4890       RETURN
4900 !
4910  Waveform_qual:!
4920 !*******************************************************************
4930 ! Subroutine: Waveform Quality + Code Domain Measurement
4940 !             4.2.2 Waveform Quality and Frequency Accuracy
4950 !*******************************************************************
4960 !
4970       DISP "Measuring Waveform Quality"
4980 !
4990 !***Set up test parameters***
5000 !
5010       Ior=-75                      ! Cell power for test
5020 !
5030       OUTPUT Testset;"CALL:APPLICATION:RTAP:DRATE BPS9600"
5040       ! Set RTAP data rate to 9600
5050       OUTPUT Testset;"CALL:POW ";Ior
5060       ! Set cell power
5070 !
5080 !***Set up measurement parameters***
5090 !
5100       OUTPUT Testset;"SETUP:DOWQ:TIMEOUT 10"
5110       ! Set waveform quality measurement timeout to 10 seconds
5120       OUTPUT Testset;"SETUP:DOWQ:SLOT:COUNT 1"
5130       ! Set slots to measure to 1
5140 !
5150 !***INITiate and FETCh measurement results***
5160 !
5170       OUTPUT Testset;"INITIATE:DOWQUALITY"
5180       ! Initiate a waveform quality + code domain measurement
5190       OUTPUT Testset;"FETCh:DOWQUALITY?"
5200       ! Query the test set for waveform quality measurement results
5210       ENTER Testset;Integrity,Rho,F_err,T_err,C_feed,P_err,M_err,Evm
5220 !
5230 !***Print Waveform Quality results***
5240 !
5250       Print_title("Waveform Quality Test Results:")
5260       PRINT
5270       Print_results("Channel= ",Current_chan,"")
5280       Print_results("Integrity indicator = ",Integrity,"")
5290       Print_results("Rho = ",Rho,"")
5300       Print_results("Frequency error = ",F_err,"Hz")
5310       Print_results("Time error = ",T_err,"us")
5320       Print_results("Carrier feedthrough = ",C_feed,"dBc")
5330       Print_results("Phase error = ",P_err,"deg")
5340       Print_results("Magnitude error = ",M_err,"%")
5350       Print_results("Error vector magnitude = ",Evm,"%")
5360       PRINT
5370       Print_title("Waveform Quality Test Complete")
5380       PRINT
5390       PRINT
5400 !
5410 !***Post test clean up***
5420 !
5430       OUTPUT Testset;"INIT:DOWQ:OFF"
5440       OUTPUT Testset;"CALL:POW ";Init_cell_power
5450       ! Set cell power back to initial level
5460       DISP ""
5470 !
5480       RETURN
5490 !
5500  Max_pow_spur:!
5510 !*******************************************************************
5520 ! Subroutine: Digital Average Power and
5530 !             TX Spurious Emissions Measurements
5540 !             4.3.4 Maximum RF Output Power
5550 !             4.4.1 Conducted Spurious Emissions
5560 !*******************************************************************
5570 !
5580       DISP "Measuring Maximum Power and TX Spurious Emissions"
5590 !
5600 !***Set up test parameters***
5610 !
5620       Ior=-60                   ! Set cell power for test
5630 !
5640       IF Band$="KPCS" OR Band$="USPCS" OR Band$="USPCs1900" OR Band$="IMT2000" THEN
5650       ! Set open loop adjust for test
5660           Ol_adjust=84
5670       ELSE
5680           Ol_adjust=81
5690       END IF
5700 !
5710       OUTPUT Testset;"CALL:APPLICATION:RTAP:DRATE BPS153600"
5711       ! Set RTAP data rate to 153600
5715       OUTPUT Testset;"CALL:APPLICATION:FTAP:DRATE S02BPS307200"
5716       ! Set FTAP data rate to 307.2kbps (2 slots).
5720       OUTPUT Testset;"CALL:APPLICATION:ACKChannel:BFMAttribute 1"
5721       ! Set ACK channel bit fixed mode attribute to On.
5730       OUTPUT Testset;"CALL:APAR:POWER:OLADJUST ";Ol_adjust
5740       ! Set Open Loop Adjust
5750       OUTPUT Testset;"CALL:APAR:PROBE:IADJUST 15"
5760       ! Set Probe Initial Adjust
5850       OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP 7.5"
5860       ! Set Probe Step
5870 !
5880 !***Set up measurement parameters***
5890 !
5900       OUTPUT Testset;"SETUP:DAPOWER:TIMEOUT 1"
5910       ! Set DIGITAL Power timeout to 1 sec
5920       OUTPUT Testset;"SETUP:CTXS:TIMEOUT 5"
5930       ! Set TX Spur Emissions timeout to 5 sec
5940 !
5950 !***Set test conditions***
5960 !
5970       OUTPUT Testset;"CALL:POW ";Ior
5980       ! Set Cell Power for Test
5990       OUTPUT Testset;"CALL:CLPCONTROL:REVERSE:MODE UP"
6000       ! Start transmission of All Up (0) power control bits
6010       WAIT 1
6020       ! Settling time to allow mobile power to slew up to maximum power
6030 !
6040 !***Obtain measurement results***
6050 !
6060       OUTPUT Testset;"INITIATE:DAPOWER;CTXS"
6070       ! Initiate digital average power and
6080       ! TX spurious emissions measurements
6090 !
6100       LOOP
6110           OUTPUT Testset;"INIT:DONE?"
6120           ! Determine if a measurement is done
6130           ENTER Testset;Meas_done$
6140           ! Obtain measurement results as they are ready
6150 !
6160           SELECT Meas_done$
6170           CASE "DAP"
6180               OUTPUT Testset;"FETCh:DAPOWER?"
6190               ENTER Testset;Integrity,Avg_power_dbm
6200           CASE "CTXS"
6210               OUTPUT Testset;"FETCH:CTXS?"
6220               ENTER Testset;Ctxs_integ,Ctxs_pf,Low_adj,Upp_adj,Low_alt,Upp_alt
6230           END SELECT
6240 !
6250       EXIT IF Meas_done$="NONE"
6260       ! Exit loop when all measurements are complete
6270       END LOOP
6280       ! If Meas_done$="WAIT" then loop continues until "NONE"
6290 !
6300       Avg_power_dbw=Avg_power_dbm-30
6310       ! Convert dBm to dBW
6320 !
6330       SELECT Ctxs_pf
6340       ! Assign CTXS pass/fail results to a string
6350       CASE 0
6360           Pass_fail$="PASS"
6370       CASE 1
6380           Pass_fail$="FAIL"
6390       END SELECT
6400 !
6410 !***Print Max Power Test Results***
6420 !
6430       Print_title("Max Power Test Results:")
6440       PRINT
6450       Print_results("Channel= ",Current_chan,"")
6460       Print_results("Integrity indicator = ",Integrity,"")
6470       Print_results("Maximum Power dBm:",Avg_power_dbm,"dBm")
6480       Print_results("Maximum Power dBW:",Avg_power_dbw,"dBW")
6490       PRINT
6500       Print_title("Max Power Test Complete")
6510       PRINT
6520       PRINT
6530 !
6540 !***Print TX Spurious Test Results
6550 !
6560       Print_title("TX Spurious Test Results:")
6570       PRINT
6580       Print_results("Channel= ",Current_chan,"")
6590       Print_results("Integrity indicator = ",Ctxs_integ,"")
6600       Print_res_str("Test Result: ",Pass_fail$)
6610       Print_results("Lower Adjacent Power",Low_adj,"dBc")
6620       Print_results("Upper Adjacent Power",Upp_adj,"dBc")
6630       Print_results("Lower Alternate Power",Low_alt,"dBc")
6640       Print_results("Upper Alternate Power",Upp_alt,"dBc")
6650       PRINT
6660       Print_title("TX Spurious Test Complete")
6670       PRINT
6680       PRINT
6690 !
6700 !***Post test clean up***
6710 !
6720       OUTPUT Testset;"CALL:CLPCONTROL:REVERSE:MODE ACTIVE"
6730       ! Return to active power control bits
6740       OUTPUT Testset;"CALL:POW ";Init_cell_power
6750       ! Set cell power back to initial level
6760       ! Do this before reconfiguring other parms
6770       OUTPUT Testset;"CALL:APAR:PROBE:IADJUST 0"
6780       ! Set Access parameters for test
6790       OUTPUT Testset;"CALL:APAR:PROBE:STEP:COUNT 5"
6800       ! Set Access paramters for test
6840       OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP 1"
6850       ! Set Access paramters for test
6860       OUTPUT Testset;"INIT:DAP:OFF"
6870       ! Turn digital ave power off
6880       OUTPUT Testset;"INIT:CTXS:OFF"
6890       ! Turn TX spurious emissions off
6900       DISP ""
6910 !
6920       RETURN
6930 !
6940  Min_pow:!
6950 !*******************************************************************
6960 ! Subroutine: Channel Power Measurement
6970 !             4.3.5 Minimum Controlled Output Power
6980 !*******************************************************************
6990 !
7000       DISP "Measuring Minimum Power"
7010 !
7020 !***Set up test parameters***
7030 !
7040       Ior=-25
7050 !
7060       OUTPUT Testset;"CALL:APPLICATION:RTAP:DRATE BPS9600"
7070       ! Set RTAP data rate to 9600
7080       OUTPUT Testset;"CALL:CONNECTED:DROP:TIMER:STATE 0"
7090       ! Turn the call drop timer off
7100 !
7110 !***Set up measurement parameters***
7120 !
7130       OUTPUT Testset;"SETUP:CPOWER:TIMEOUT .5"
7140       ! Set Channel Power timeout to 0.5 sec
7150 !
7160 !***Set test conditions***
7170 !
7180       OUTPUT Testset;"CALL:POW ";Ior
7190       ! Set cell power for test
7200       OUTPUT Testset;"CALL:CLPCONTROL:REVERSE:MODE DOWN"
7210       ! Start transmission of All Down (1) power control bits
7220       WAIT 1
7230       ! Settling time for mobile output power to slew down
7240 !
7250 !***INITiate and FETCh measurements***
7260 !
7270       GOSUB Meas_chan_pow
7280       ! Subroutine for measuring channel power, includes ranging
7290 !
7300 !***Print measurement results***
7310 !
7320       Print_title("Minimum Power Test Results:")
7330       PRINT
7340       Print_results("Channel= ",Current_chan,"")
7350       Print_results("Integrity indicator = ",Integrity,"")
7360       Print_results("Minimum Power dBm:",Channel_power,"dBm/1.23 MHz")
7370       PRINT
7380       Print_title("Minimum Power Test Complete")
7390       PRINT
7400       PRINT
7410 !
7420 !***Post test clean up***
7430 !
7440       OUTPUT Testset;"CALL:CLPCONTROL:REVERSE:MODE ACTIVE"
7450       ! Return to active power control bits
7460       OUTPUT Testset;"CALL:POW ";Init_cell_power
7470       ! Set cell power back to initial level
7480       OUTPUT Testset;"CALL:CONNECTED:DROP:TIMER:STATE 1"
7490       ! Return call drop timer to ON
7500       OUTPUT Testset;"INIT:CPOW:OFF"
7510       ! Turn channel power off
7520       DISP ""
7530 !
7540       RETURN
7550 !
7560  Rng_open_loop:!
7570 !*******************************************************************
7580 ! Subroutine: Access Probe Power Measurement
7590 !             4.3.1 Range of Open Loop Output Power
7600 !*******************************************************************
7610 !
7620       DISP "Testing Range of Open Loop Power"
7630 !
7640 !***End current connection***
7650 !
7660       IF FNConnected THEN
7670       ! Check to see if currently connected
7680           GOSUB End_connection
7690       END IF
7700 !
7710 !***Verify session is open***
7720 !
7730       IF NOT FNSession_check THEN
7740       ! Check to see if session open
7750           Print_title("Session must be open during Range of Open Loop")
7760           Print_title("Ending Testing")
7770           GOTO End_program
7780       END IF
7790 !
7800 !***Set up test parameters***
7810 !
7820       Ior1=-25                     ! First level for test
7830       Ior2=-65                     ! Second level for test
7840       Ior3=-93.5
7850       ! Ior for test 3 Band Class 0, AT Class III
7860       Ol_adjust=78
7870       ! Set Open Loop Adjust for Band Class 0
7880 !
7890       OUTPUT Testset;"CALL:APAR:POWER:OLADJUST ";Ol_adjust
7900       ! Set Open Loop Adjust
7910       OUTPUT Testset;"CALL:APAR:PREAMBLE:LENGTH 7"
7920       ! Set preamble length in frames
7970       OUTPUT Testset;"CALL:APAR:PROBE:SEQUENCE 1"
7980       ! Set Probe Sequence Max
7990       ! This must be done BEFORE call limit mode is turned on
8000       OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP 0"
8010       ! Set Probe Power Step
8020 !
8030 !***Set up measurement parameters***
8040 !
8050       OUTPUT Testset;"SETUP:CAPP:TIMEOUT 10"
8060       ! Set access probe power timeout to 10 seconds
8070 !
8080 !***Set test conditions***
8090 !
8100       OUTPUT Testset;"CALL:CONNECTED:LIMIT:STATE 1"
8110       ! Turn on call limit mode so connection is not established
8120       ! This must be done AFTER probe sequence max is set
8130 !
8140 !***Obtain measurement results***
8150 !
8160       OUTPUT Testset;"CALL:POW ";Ior1
8170       ! Set cell power for test 1
8180       WAIT .1
8190       ! Settling time for access terminal output power to slew
8200       OUTPUT Testset;"CALL:FUNCTION:DATA:START"
8210       ! Page access terminal
8220       OUTPUT Testset;"READ:CAPP?"
8230       ! Read access probe power
8240       ENTER Testset;Integrity1,Test1
8250       OUTPUT Testset;"CALL:FUNCTION:DATA:STOP"
8260       ! Stop data connection paging before repaging at next level
8270 !
8280       OUTPUT Testset;"CALL:POW ";Ior2
8290       ! Set cell power for test 2
8300       WAIT .1
8310       ! Settling time for mobile output power to slew
8320       OUTPUT Testset;"CALL:FUNCTION:DATA:START"
8330       ! Page access terminal
8340       OUTPUT Testset;"READ:CAPP?"
8350       ! Read access probe power
8360       ENTER Testset;Integrity2,Test2
8370       OUTPUT Testset;"CALL:FUNCTION:DATA:STOP"
8380       ! Stop data connection paging before repaging at next level
8390 !
8400       OUTPUT Testset;"CALL:POW ";Ior3
8410       ! Set cell power for test 3
8420       WAIT .1
8430       ! Settling time for mobile output power to slew
8440       OUTPUT Testset;"CALL:FUNCTION:DATA:START"
8450       ! Page access terminal
8460       OUTPUT Testset;"READ:CAPP?"
8470       ! Read access probe power
8480       ENTER Testset;Integrity3,Test3
8490       OUTPUT Testset;"CALL:FUNCTION:DATA:STOP"
8500       ! Stop data connection paging
8510 !
8520 !***Print measurement results***
8530 !
8540       Print_title("Range of Open Loop Power Control Results:")
8550       PRINT
8560       Print_results("Channel= ",Current_chan,"")
8570       Print_results("Integrity indicator = ",Integrity1,"")
8580       Print_results("Test 1 @ "&VAL$(Ior1)&" dBm:",Test1,"dBm/1.23 MHz")
8590       Print_results("Integrity indicator = ",Integrity2,"")
8600       Print_results("Test 2 @ "&VAL$(Ior2)&" dBm:",Test2,"dBm/1.23 MHz")
8610       Print_results("Integrity indicator = ",Integrity1,"")
8620       Print_results("Test 3 @ "&VAL$(Ior3)&" dBm:",Test3,"dBm/1.23 MHz")
8630       PRINT
8640       Print_title("Range of Open Loop Power Test Complete")
8650       PRINT
8660       PRINT
8670 !
8680 !***Post test clean up***
8690 !
8700       OUTPUT Testset;"CALL:CONNECTED:LIMIT:STATE 0"
8710       ! Turn off call limit mode
8720       ! Must do BEFORE can change probe max sequence
8721       WAIT .5
8730       OUTPUT Testset;"CALL:POW ";Init_cell_power
8740       ! Set Cell Power to default
8750       ! Do this before reconfiguring other parms so signaling
8760       ! is successful (don't want cell power too low for signaling)
8770       OUTPUT Testset;"CALL:APAR:PREAMBLE:LENGTH 7"
8780       ! Set preamble length in frames
8790       OUTPUT Testset;"CALL:APAR:PROBE:IADJUST 0"
8800       ! Set Probe Initial Adjust
8810       OUTPUT Testset;"CALL:APAR:PROBE:STEP:COUNT 3"
8820       ! Set Probe Num Steps
8850       OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP 3"
8860       ! Set Probe Step
8861       !OUTPUT Testset;"CALL:APAR:PROBE:SEQUENCE 1"
8862       ! Set Probe Sequence Max.It requires session negotiation.
8863       !WAIT 20
8880       OUTPUT Testset;"INIT:CAPP:OFF"
8890       ! Set access probe power meas off
8900       DISP ""
8910 !
8920       RETURN
8930 !
8940  Time_resp_olp:!
8950 !*******************************************************************
8960 ! Subroutine: Time Response of Open Loop Power Control Measurement
8970 !             4.3.2 Time Response of Open Loop Power Control
8980 !*******************************************************************
8990 !
9000       DISP "Testing Time Response of Open Loop Power Control"
9010 !
9020 !***Set up test parameters***
9030 !
9040       Ior=-60                      ! Start Level for test
9050 !
9060 !***Set up measurement parameters***
9070 !
9080       OUTPUT Testset;"SETUP:TROP:TIMEOUT 5"
9090       ! Set TROLPC measurement timeout to 5 s
9100 !
9110 !***Set test conditions***
9120 !
9130       OUTPUT Testset;"CALL:APPLICATION:RTAP:DRATE BPS9600"
9140       ! Set RTAP data rate 9.6 kbps
9150       OUTPUT Testset;"CALL:APPLICATION:ACKCHANNEL:BFMATTRIBUTE OFF"
9160       ! Turn off ACK Channel Bit Fixed Mode Attribute
9170       OUTPUT Testset;"CALL:APPLICATION:ATDPACKETS 0"
9180       ! Set AT Directed Packets to 0 to disable R-ACK Channel
9190       OUTPUT Testset;"CALL:POW ";Ior
9200       ! Set cell power for Test
9210       WAIT .1
9220       ! Open Loop Time Response settling time after cell power change
9230 !
9240       Print_title("Time Response of Open Loop Power Test Results:")
9250       FOR J=1 TO 4
9260       ! Loop to measure power after 4 step changes in cell power
9270           SELECT J
9280           ! Set step direction for each measurement
9290           CASE 1
9300               Test_number=J
9310               Step$="UP20"
9320           CASE 2
9330               Test_number=J
9340               Step$="DOWN20"
9350           CASE 3
9360               Test_number=J
9370               Step$="DOWN20"
9380           CASE 4
9390               Test_number=J
9400               Step$="UP20"
9410           END SELECT
9420 !
9430 !***Obtain measurement results***
9440 !
9450           OUTPUT Testset;"SETUP:TROP:STEP "&Step$
9460           ! Set step direction for measurement
9470           OUTPUT Testset;"READ:TROP?"
9480           ! Initiate Time Response of Open Loop measurement,
9490           ! which automatically induces step change in direction
9500           ! set by SETUP:TROP:STEP, then fetch results
9510           ENTER Testset;Integrity,Pass_fail
9520 !
9530           SELECT Pass_fail
9540           ! Assign pass/fail results to a string
9550           CASE 0
9560               Pass_fail$="PASS"
9570           CASE 1
9580               Pass_fail$="FAIL"
9590           CASE ELSE
9600               Pass_fail$="ERROR"
9610           END SELECT
9620 !
9630 !***Print measurement results***
9640 !
9650           PRINT
9660           Print_title("Test Number "&VAL$(Test_number))
9670           Print_results("Channel= ",Current_chan,"")
9680           Print_results("Integrity indicator = ",Integrity,"")
9690           Print_res_str("Test Result:",Pass_fail$)
9700 !
9710       NEXT J
9720 !
9730       PRINT
9740       Print_title("Time Response of Open Loop Power Test Complete")
9750       PRINT
9760       PRINT
9770 !
9780 !***Post test clean up***
9790 !
9800       OUTPUT Testset;"INIT:TROP:OFF"
9810       ! Turn off measurement
9820       OUTPUT Testset;"CALL:APPLICATION:ACKCHANNEL:BFMATTRIBUTE ON"
9830       ! Turn ACK Channel Bit Fixed Mode Attribute back on
9840       OUTPUT Testset;"CALL:APPLICATION:ATDPACKETS 50"
9850       ! Set AT Directed Packets back to default value of 50%
9860       OUTPUT Testset;"CALL:POW ";Init_cell_power
9870       ! Set cell power back to initial level
9880       DISP ""
9890 !
9900       RETURN
9910 !
9920  Sensitivity:!
9930 !*******************************************************************
9940 ! Subroutine: Packet Error Rate Measurement
9950 !             3.3.1 Receiver Sensitivity
9960 !*******************************************************************
9970 !
9980       DISP "Testing Receiver Sensitivity"
9990 !
10000 !***Set up test parameters***
10010 !
10020       Ior=-105.5                  ! Level for sensitivity test
10030 !
10040 !***Set up measurement parameters***
10050 !
10060       Max_packets=10000           ! Maximum packets
10065       Conf_limit=95                ! 95% confidence limit
10070       Per_limit=.5                ! 0.5% per requirement
10080 !
10090       OUTPUT Testset;"SETUP:CPERROR:COUNT ";Max_packets
10095       ! Set MAXIMUM PACKETS FOR TEST
10100       OUTPUT Testset;"SETUP:CPERROR:CONF ";Conf_limit
10105       ! Set Confidence level
10110       OUTPUT Testset;"SETUP:CPERROR:CONF:REQ ";Per_limit
10120       ! Set PER Requirement
10130       OUTPUT Testset;"SETUP:CPERROR:TIMEOUT 10"
10140       ! Set PER measurement timeout to 10 s
10150 !
10160 !***Set test conditions***
10170 !
10180       OUTPUT Testset;"CALL:APPLICATION:ATDPACKETS 50"
10190       ! Set AT Directed Packets to 50%
10200       OUTPUT Testset;"CALL:APPLICATION:FTAP:DRATE S02B307200"
10210       ! Set FTAP data rate to 2 slot 307.2 kbps
10220       OUTPUT Testset;"CALL:POW ";Ior
10230       ! Set Cell Power for Test
10240       WAIT .5
10250       ! Settling time for access terminal power to slew
10260 !
10270 !***Obtain measurement results***
10280 !
10290       OUTPUT Testset;"INITIATE:CPERROR"
10300       ! Initiate a packet error rate measurement
10310       DISP "Measuring PER"
10320       OUTPUT Testset;"FETCh:CPERROR?"
10330       ! Query the test set for packet error rate measurement results
10340       ENTER Testset;Integrity,Per_test,Per_ratio,Per_count,Packets_tested
10350 !
10360       SELECT Per_test
10370       ! Assign pass/fail results to a string
10380       CASE 0
10390           Pass_fail$="PASS"
10400       CASE 1
10410           Pass_fail$="FAIL"
10420       CASE 2
10430           Pass_fail$="MAX PACKETS"
10440       CASE 3
10450           Pass_fail$="UNKNOWN"
10460       END SELECT
10470 !
10480 !***Print measurement results***
10490 !
10500       Print_title("Sensitivity Packet Error Rate Test Results:")
10510       PRINT
10520       Print_results("Channel= ",Current_chan,"")
10530       Print_results("Integrity indicator = ",Integrity,"")
10540       Print_res_str("PER Test Results",Pass_fail$)
10550       Print_results("PER Ratio",Per_ratio,"%")
10560       Print_results("PER Errors Count",Per_count,"packets")
10570       Print_results("Packets Tested",Packets_tested,"")
10580       PRINT
10590       Print_title("Sensitivity PER Test Complete")
10600       PRINT
10610       PRINT
10620 !
10630 !***Post test clean up***
10640 !
10650       OUTPUT Testset;"INIT:CPER:OFF"
10660       ! Turn off PER measurement
10670       OUTPUT Testset;"CALL:POW ";Init_cell_power
10680       ! Set cell power back to normal level
10690       DISP ""
10700 !
10710       RETURN
10720 !
10730  Dynamic_range:!
10740 !*******************************************************************
10750 ! Subroutine: Packet Error Rate Measurement
10760 !             3.3.1 Dynamic Range
10770 !*******************************************************************
10780 !
10790       DISP "Testing Dynamic Range"
10800 !
10810 !***Set up test parameters***
10820 !
10830       Ior=-25                      ! Level for dynamic range test
10840 !
10850 !***Set up measurement parameters***
10860 !
10870       Max_packets=10000            ! Maximum packets
10880       Conf_limit=.5                ! 0.5% confidence limit
10890 !
10900       OUTPUT Testset;"SETUP:CPERROR:COUNT ";Max_packets
10910       ! Set MAXIMUM PACKETS FOR TEST
10920       OUTPUT Testset;"SETUP:CPERROR:CONF:REQ ";Conf_limit
10930       ! Set CONFIDENCE LIMIT
10940       OUTPUT Testset;"SETUP:CPERROR:TIMEOUT 10"
10950       ! Set PER measurement timeout to 10 s
10960 !
10970 !***Set test conditions***
10980 !
10990       OUTPUT Testset;"CALL:APPLICATION:ATDPACKETS 50"
11000       ! Set AT Directed Packets to 50%
11010       OUTPUT Testset;"CALL:APPLICATION:FTAP:DRATE S01K2458"
11020       ! Set FTAP data rate to 1 slot 2457.8 kbps
11030       OUTPUT Testset;"CALL:POW ";Ior
11040       ! Set Cell Power for Test
11050       WAIT .5
11060       ! Settling time for access terminal power to slew
11070 !
11080 !***Obtain measurement results***
11090 !
11100       OUTPUT Testset;"INITIATE:CPERROR"
11110       ! Initiate a packet error rate measurement
11120       DISP "Measuring PER"
11130       OUTPUT Testset;"FETCh:CPERROR?"
11140       ! Query the test set for packet error rate measurement results
11150       ENTER Testset;Integrity,Per_test,Per_ratio,Per_count,Packets_tested
11160 !
11170       SELECT Per_test
11180       ! Assign pass/fail results to a string
11190       CASE 0
11200           Pass_fail$="PASS"
11210       CASE 1
11220           Pass_fail$="FAIL"
11230       CASE 2
11240           Pass_fail$="MAX PACKETS"
11250       CASE 3
11260           Pass_fail$="UNKNOWN"
11270       END SELECT
11280 !
11290 !***Print measurement results***
11300 !
11310       Print_title("Dynamic Range Packet Error Rate Test Results:")
11320       PRINT
11330       Print_results("Channel= ",Current_chan,"")
11340       Print_results("Integrity indicator = ",Integrity,"")
11350       Print_res_str("PER Test Results",Pass_fail$)
11360       Print_results("PER Ratio",Per_ratio,"%")
11370       Print_results("PER Errors Count",Per_count,"packets")
11380       Print_results("Packets Tested",Packets_tested,"")
11390       PRINT
11400       Print_title("Dynamic Range PER Test Complete")
11410       PRINT
11420       PRINT
11430 !
11440 !***Post test clean up***
11450 !
11460       OUTPUT Testset;"INIT:CPER:OFF"
11470       ! Turn off PER measurement
11480       OUTPUT Testset;"CALL:POW ";Init_cell_power
11490       ! Set cell power back to normal level
11500       DISP ""
11510 !
11520       RETURN
11530 !
11540  Traf_per_awgn:!
11550 !*******************************************************************
11560 ! Subroutine: Packet Error Rate Measurement
11570 !             3.2.1 Demodulation of Forward Traffic Channel in AWGN
11580 !*******************************************************************
11590 !
11600       DISP "Testing Demod of Traffic Channel in AWGN"
11610 !
11620 !***Set up test parameters***
11630 !
11640       Ior=-55                               ! Cell power for test
11650 !
11660 !***Set up measurement parameters***
11670 !
11680       Max_packets=10000                     ! Maximum packets
11690 !
11700       OUTPUT Testset;"SETUP:CPERROR:COUNT ";Max_packets
11710       ! Set MAXIMUM PACKETS for test
11720       OUTPUT Testset;"SETUP:CPERROR:TIMEOUT 25"
11730       ! Set PER measurement timeout to 25 s
11740 !
11750 !***Set test conditions***
11760 !
11770       OUTPUT Testset;"CALL:APPLICATION:ATDPACKETS 50"
11780       ! Set AT Directed Packets to 50%
11790       OUTPUT Testset;"CALL:POW ";Ior
11800       ! Set cell power for test
11801       OUTPUT Testset;"CALL:MS:PDRop 28"
11802       ! Set Pilot Drop to -14 dB
11803       GOSUB Ftap_connect
11804       ! After setting Pilot Drop, connection will be dropped.
11805       ! Must re-establish the FTAP connection
11810 !
11820 ! Read test data into array.
11830 ! Values are Ioc (AWGN), FTAP data rate, and PER requirement for
11840 ! 18 tests (C.S0033 tests 6 and 10 are not performed because
11850 ! settings are duplicates)
11860 !
11870       RESTORE
11880       DATA -70.4,"S01K2458",1,-68.4,"S01K2458",1,-65.8,"S01K1843",1
11890       DATA -65.1,"S01K1843",1,-60.9,"S02K1229",3,-61.0,"S02K1229",.5
11900       DATA -58.1,"S02B921600",3,-58.2,"S02B921600",.5,-60.5,"S01K1229",1
11910       DATA -55.5,"S02B614400",1,-52.5,"S04B307200",1,-55.6,"S01B614400",5
11920       DATA -55.7,"S01B614400",1,-55.8,"S01B614400",.5,-52.5,"S02B307200",1
11930       DATA -49.4,"S04B153600",1,-46.4,"S08B76800",1,-43.6,"S16B38400",1
11940 !
11950       READ Awgn_per_data$(*)
11960 !
11970       FOR I=1 TO 18
11980       ! Loop to set parameters and measure PER for 18 tests
11990 !
12000           OUTPUT Testset;"SETUP:CPERROR:CONF:REQ "&Awgn_per_data$(I,3)
12010           ! Set CONFIDENCE LIMIT
12020           OUTPUT Testset;"CALL:APPLICATION:FTAP:DRATE "&Awgn_per_data$(I,2)
12030           ! Set FTAP data rate
12040           OUTPUT Testset;"CALL:AWGN:POW "&Awgn_per_data$(I,1)
12050           ! Set AWGN POWER level
12060           WAIT .1
12070 !
12080 !***Obtain measurement results***
12090 !
12100           OUTPUT Testset;"INITIATE:CPERROR"
12110           ! Initiate a packet error rate measurement
12120           DISP "Measuring PER"
12130           OUTPUT Testset;"FETCh:CPERROR?"
12140           ! Query the test set for packet error rate results
12150           ENTER Testset;Integrity,Per_test,Per_ratio,Per_count,Packets_tested
12160 !
12170           SELECT Per_test
12180           ! Assign pass/fail results to a string
12190           CASE 0
12200               Pass_fail$="PASS"
12210           CASE 1
12220               Pass_fail$="FAIL"
12230           CASE 2
12240               Pass_fail$="MAX PACKETS"
12250           CASE 3
12260               Pass_fail$="UNKNOWN"
12270           END SELECT
12280 !
12290 !***Print measurement results***
12300 !
12310           Print_title("Results PER with AWGN, "&Awgn_per_data$(I,2)&" Rate")
12320           PRINT
12330           Print_results("Channel= ",Current_chan,"")
12340           Print_results("Integrity indicator = ",Integrity,"")
12350           Print_res_str("PER Test Results",Pass_fail$)
12360           Print_results("PER Ratio",Per_ratio,"%")
12370           Print_results("PER Errors Count",Per_count,"packets")
12380           Print_results("Packets Tested",Packets_tested,"")
12390           PRINT
12400 !
12410       NEXT I
12420 !
12430       Print_title("PER with AWGN Tests Complete")
12440       PRINT
12450       PRINT
12460 !
12470 !***Post test clean up***
12480 !
12490       OUTPUT Testset;"CALL:AWGN:POW:STATE OFF"
12500       ! Turn off AWGN
12510       OUTPUT Testset;"INIT:CPER:OFF"
12520       ! Turn off PER measurement
12530       OUTPUT Testset;"CALL:POW ";Init_cell_power
12540       ! Set cell power back to normal level
12550       DISP ""
12560 !
12570       RETURN
12580 !
12590  Meas_chan_pow:!
12600 !*******************************************************************
12610 ! Subroutine: Measure Channel Power
12620 !             Implements simple ranging in case over/under range
12630 !*******************************************************************
12640 !
12650       FOR I=1 TO 5
12660           OUTPUT Testset;"INITIATE:CPOWER"
12670           ! Initiate a channel power measurement
12680           OUTPUT Testset;"FETCh:CPOWER?"
12690           ! Fetch channel power measurement results
12700           ENTER Testset;Integrity,Channel_power
12710           ! Read Integrity bit and channel power result
12720 !
12730           IF (Integrity=6 OR Integrity=5) AND 30>Channel_power>-80 THEN
12740           ! Measurement out of-range, recover by setting Receiver
12750           ! control to manual and entering measured level as expected
12760           ! level, then measure channel power again.
12770           ! Repeat up to 5 times.
12780               OUTPUT Testset;"RFAN:CONTROL:POWER:AUTO OFF"
12790               ! Set RF Analyzer ranging to manual
12800               OUTPUT Testset;"RFAN:MANUAL:POWER ";INT(Channel_power);" DBM"
12810               ! Set RF Analyzer expected power to measured level
12820           ELSE
12830               I=5 ! Exits loop if integrity is not under/over range
12840           END IF
12850 !
12860       NEXT I
12870                         !
12880       OUTPUT Testset;"RFANALYZER:CONTROL:POWER:AUTO ON"
12890       ! Return expected power control to auto
12900 !
12910       RETURN
12920 !
12930  End_connection:               !
12940 !*******************************************************************
12950 ! Subroutine: Close data connection
12960 !*******************************************************************
12970 !
12980       DISP "Closing data connection"
12990 !
13000       OUTPUT Testset;"CALL:DCONNECTED?"
13010       ! Checks connection status
13020       ENTER Testset;Data_stopped
13030 !
13040       IF Data_stopped=0 THEN
13050           DISP "Data connection closed"
13060 !
13070       ELSE
13080           OUTPUT Testset;"CALL:DCONNECTED:TIMEOUT 10"
13090           ! Set connection change detector timeout
13100           OUTPUT Testset;"CALL:DCONNECTED:ARM"
13110           ! Arm the connection state change detector
13120           OUTPUT Testset;"CALL:FUNCTION:DATA:STOP"
13130           ! Close the data connection
13140           OUTPUT Testset;"CALL:DCONNECTED?"
13150           ! Query the data connection status
13160           ENTER Testset;Data_stopped
13170 !
13180           IF Data_stopped=1 THEN
13190               Print_title("Data connection could not be closed")
13200               Print_title("Ending Testing")
13210               GOTO End_program
13220           END IF
13230 !
13240           DISP "Data connection closed"
13250       END IF
13260 !
13270       RETURN
13280 !
13290  Open_rslts_file:!
13300 !*******************************************************************
13310 ! Subroutine: Open text file to save test results to
13320 !             C:\RESULTS\current date\(file name is HID plus current time)
13330 !*******************************************************************
13340 !
13350       Fileopened_flag=0
13360       ! Indicates that a results file is not yet open
13361       Cur_dt$=DATE$(TIMEDATE)
13370       ON ERROR RECOVER Make_dir
13380       ! If error occurs (presumably because the directory doesn't exist),
13390       ! then create directory
13400       MASS STORAGE IS "C:\RESULTS"&"\"&Cur_dt$
13410       ! Sets the current directory
13420       GOTO Skip_create
13430  Make_dir: CREATE DIR "C:\RESULTS"&"\"&Cur_dt$
13440  Skip_create: OFF ERROR
13450  !Returns error handling to the default: "report to user with a pause"
13460       Cur_tm$=TIME$(TIMEDATE)
13470       Cur_tm$[3]="_"&Cur_tm$[4]
13480       ! Replace the ":" in TIME$ to "_"
13490       Cur_tm$[6]="_"&Cur_tm$[7]
13500       ! Replace the ":" in TIME$ to "_"
13510       Result_file$=Hid_dec$[4,11]&" "&Cur_tm$&".txt"
13520       ! Name the result file using HID and current time
13530       CREATE Result_file$,130
13540       ! Create the result file with 130 records
13550       ASSIGN @File TO Result_file$
13560       ! Wherever @File appears, use Result_file$
13570       ! Create data file using hardware ID and current time
13580       COM /File/@File
13590       Fileopened_flag=1
13600       ! Set open file flag to true
13610       RETURN
13620 !
13630  Start_time:!
13640 !*******************************************************************
13650 ! Subroutine: Start Test Time
13660 !*******************************************************************
13670 !
13680       Start_time=TIMEDATE
13690       RETURN
13700 !
13710  End_time:!
13720 !*******************************************************************
13730 ! Subroutine: End Test Time
13740 !*******************************************************************
13750 !
13760       End_time=TIMEDATE
13770       RETURN
13780 !
13790  End_program:!
13800 !*******************************************************************
13810 ! Subroutine: End of all testing clean up
13820 !*******************************************************************
13830 !
13840       GOSUB End_time
13850       Print_title("End of Test")
13860       Print_results("Total Test Time= ",End_time-Start_time," Seconds")
13870 !
13880 !***End connection and return to default call processing settings***
13890 !
13900       OUTPUT Testset;"CALL:POW ";Init_cell_power
13910       ! Set cell power back to normal level
13920       OUTPUT Testset;"CALL:CHAN ";Primary_channel
13930       ! Set Primary RF Channel for selected System Type and Cell Band
13940 !
13950       IF Fileopened_flag THEN ASSIGN @File TO *
13960       ! Close the data file
13970 !
13980       PRINT
13990       PRINT "End of Program"
14000       END
14010 !
14020 !**************************************************************************
14030 ! SUB-PROGRAM SECTION
14040 !**************************************************************************
14050 !
14060  Timeout: SUB Timeout ! Global timeout handler
14070           COM Testset,Result_file$
14080           PRINT
14090           PRINT "Program timed out, check setup"
14100           CLEAR 7
14110           CLEAR Testset
14120           STOP
14130       SUBEND
14140 !
14150  Print_results: SUB Print_results(Name$,Res1,OPTIONAL Units$)
14160           COM Testset,Result_file$
14170           COM /File/Openfile_flag
14180           IF Res1=9.91E+37 THEN
14190               PRINT USING "5X,40A,5X,1D.E,1X,20A";Name$;Res1;Units$
14200               IF Openfile_flag THEN
14210                   COM /File/@File
14220                   OUTPUT @File USING "5X,40A,5X,1D.E,1X,20A";Name$;Res1;Units$
14230               END IF
14240           ELSE
14250               PRINT USING "5X,40A,5X,M4D.2D,1X,20A";Name$;Res1;Units$
14260               IF Openfile_flag THEN
14270                   OUTPUT @File USING "5X,40A,5X,M4D.2D,1X,20A";Name$;Res1;Units$
14280               END IF
14290           END IF
14300       SUBEND
14310 !
14320  Print_res_str: SUB Print_res_str(String_name$,OPTIONAL Results$)
14330           COM Testset,Result_file$
14340           COM /File/Openfile_flag
14350           PRINT USING "5X,40A,5X,20A";String_name$;Results$
14360           IF Openfile_flag THEN
14370               COM /File/@File
14380               OUTPUT @File USING "5X,40A,5X,20A";String_name$;Results$
14390           END IF
14400       SUBEND
14410 !
14420  Print_title: SUB Print_title(Title$)
14430           COM Testset,Result_file$
14440           COM /File/Openfile_flag
14450           PRINT USING "3X,72A";Title$
14460           IF Openfile_flag THEN
14470               COM /File/@File
14480               OUTPUT @File USING "2A,/";" "
14490               OUTPUT @File USING "3X,72A,/";Title$
14500           END IF
14510       SUBEND
14520 !
14530  Connected: DEF FNConnected ! Function to check connected state
14540           COM Testset,Result_file$
14550           OUTPUT Testset;"CALL:DCONNECTED?"
14560           ! Query the connected status
14570           ENTER Testset;Connected
14580           RETURN Connected
14590           ! Function returns 1 for connected, 0 for idle or session open
14600       FNEND
14610 !
14620  Session_check: DEF FNSession_check ! Function to check session open state
14630           COM Testset,Result_file$
14640           OUTPUT Testset;"CALL:SOPEN?"
14650           ! Query the session open state
14660           ENTER Testset;Session_check
14670           RETURN Session_check
14680           ! Function returns 1 for session open, 0 for idle or connected
14690       FNEND

Related Topics

Test Adherence to Standards


Comprehensive Program Example for AT Test (based on ETAP test data connection)

Comprehensive Program Example for AT Test (based on ETAP test data connection)

Last updated: May 24, 2006

10 !******************************************************************************
20 ! E1966A Comprehensive Programming Example - Rel A Subtype 2 Physical Layer
30 ! Revision: June 18, 2006
40 !
50 ! This program is for subtype 2 physical layer tests.
51 ! It opens an RETAP connection with a 1xEV-DO Access Terminal and
60 ! measures waveform quality, maximum power, minimum power,
70 ! TX spurious emissions, TROLPC, and range of open loop power.
80 ! It then moves to an FETAP connection and measures receiver sensitivity,
90 ! receiver dymanic range, and demodulation of traffic channel in AWGN.
100 !
110 ! The simple test executive allows you to set the test sequence by using gosubs
120 ! to call subroutines for each test.
130 !
140 ! You may un-comment handoffs and test subroutine calls and perform the
150 ! tests at various channels as needed.
160 !******************************************************************************
170 !
180 !***Initialize program variables***
190 !
200  OPTION BASE 1
210 !
220  COM Testset,Result_file$[50]      ! Declare common variables
230  COM /File/Openfile_flag
240       ! Results file open flag,
250       ! 1=Open a results file, 0=No results file opened
260       ! Results file is stored under C:\Results\current date
270 !
280  DIM Pass_fail$[40]                ! Declare Pass or Fail indication string
290  DIM Sector_id$[40]                ! Declare Sector ID string
300  DIM Awgn_per_data$(1,3)[20]
310       ! Declare array to hold data AWGN PER test
320 !
330  Testset=714
340       ! Set "Testset" to GPIB address of test set
350 !
360  CLEAR SCREEN                      ! Clear the PC display
370 !
380 !***Set up GPIB timeout***
390 !
400  ON TIMEOUT 7,20 CALL Timeout
410       ! Call "Timeout" routine after 20 seconds of GP-IB hang-up
420 !
430 !**************************************************************************
440 ! STEP 1: SET UP THE TEST SET
450 !**************************************************************************
460 !
470 !***Turn on GPIB debugger.  Comment out when done debugging program***
480 !
490  OUTPUT Testset;"SYST:COMM:GPIB:DEB:STAT ON"
500       ! Turn debug state on
510 !
520 !***Set system path loss values.  Include cable and coupler losses.***
530 !
540  Loss_frequency$=" 800 MHZ,2000 MHZ"
550       ! Set frequencies for amplitude offset (path loss)
560  Expected_loss$=" -1.5,-1.5"
570       ! Set path loss at frequencies specified
580 !
590  OUTPUT Testset;"SYSTEM:BEEPER:STATE OFF"
600       ! Turn Off System Beeper
610 !
620 !**************************************************************************
630 ! STEP 2: CONFIGURE TEST SET AND ACCESS TERMINAL PARAMETERS
640 !**************************************************************************
650 !
660 !***Variable declarations for call setup. (AT-specific, change as needed)***
670 !
671  P_rev$="PRA"                      ! Set to protocol release A
672  Phy_sub$="SUBT2"                  ! Set to physical layer subtype 2
680  Band$="USC"                     ! Set cell band
690  Primary_channel=129               ! Set RF channel for access network
700  Country_code=310                  ! Set Access Terminal Country Code
710  Subnet_mask=104                   ! Set Sector Subnet mask
720  At_max_power$="DBM23"             ! Set AT Maximum Power
730                                    ! (DBM8, DBM13, DBM18, DBM20, DBM23
740                                    !  DBM27, DBM28, DBM31, DBM33)
750  Init_cell_power=-50
760       ! Set initial cell power for connection setup
770  Current_chan=Primary_channel
780       ! Set the current channel to equal primary channel
790 !
800 !**************************************************************************
810 ! SIMPLE TEST EXECUTIVE
820 !**************************************************************************
830 !
840 !**************************************************************************
850 ! STEP 1: SET UP THE TEST SET
860 !**************************************************************************
870 !
880  GOSUB Preset_test_set
890       ! End any current connection and preset test set
900  GOSUB Set_path_loss
910       ! Set path loss values into test set RF Offset Table
920 !
930 !**************************************************************************
940 ! STEP 2: CONFIGURE TEST SET AND ACCESS TERMINAL PARAMETERS
950 !**************************************************************************
960 !
980  GOSUB Set_call_parms              ! Set up Access Terminal parameters
1020 !
1030 !**************************************************************************
1040 ! STEP 3: SET MEASUREMENT PARAMETERS
1050 !**************************************************************************
1060 !
1070 GOSUB Set_up_meas
1080       ! Set all measurement triggering to single
1090 !
1100 !***Start test time***
1110 !
1120 GOSUB Start_time
1130 !
1140 !**************************************************************************
1150 ! STEP 4: MAKE A CONNECTION (Open a session and open an RETAP connection)
1160 !**************************************************************************
1170 !
1180 GOSUB Session_open
1190       ! Open a session with the AT and read AT parameters
1200 !
1210 !**************************************************************************
1220 !***Open results file***
1230 !
1240 Openfile_flag=1
1250 IF Openfile_flag THEN GOSUB Open_rslts_file
1260       ! Store results in text file, file name= hid+current time
1270 !
1280 !***Print ACCESS TERMINAL information***
1290 !
1300 Print_title("Access Terminal Information:")
1310 PRINT
1320 Print_res_str("Session Seed:",Sseed$)
1330 Print_res_str("Hardware ID Type:",Hid_type$)
1340 Print_res_str("Hardware ID Hex:",Hid_hex$)
1350 Print_res_str("Hardware ID Dec:",Hid_dec$)
1360 Print_title(" ")
1370 !**************************************************************************
1380 !
1390 GOSUB Retap_connect
1400       ! Open an RETAP connection
1410 !
1420 !***Hand off to first channel to be tested***
1430 !
1440       !Handoff_band$="USPCS"
1450       ! Only specify handoff band when performing interband HO
1460       !Handoff_chan=75
1470       ! Hand off to "low" channel for test
1480       !GOSUB Handoff
1490       ! Hand off to the handoff band and channel specified
1500 !
1510 !**************************************************************************
1520 ! STEP 5: INITIATE AND FETCH TX MEASUREMENTS
1530 !**************************************************************************
1540 !
1550 GOSUB Waveform_qual                ! Test waveform quality
1560 GOSUB Max_pow_spur           ! Test max power and TX spurious emissions
1570 GOSUB Min_pow                ! Test min power
1580 GOSUB Time_resp_olp          ! Test time response of open loop power
1590 GOSUB Rng_open_loop          ! Test range of open loop output power
1600 !
1610 !**************************************************************************
1620 ! STEP 6: RECONFIGURE TEST SET AND AT PARMS (Change to an FETAP connection)
1630 !**************************************************************************
1640 WAIT .2
1650 GOSUB Fetap_connect                 ! Change to an FTAP connection
1660 !
1670 !**************************************************************************
1680 ! STEP 5: INITIATE AND FETCH RX MEASUREMENTS
1690 !**************************************************************************
1700 !
1710 GOSUB Sensitivity            ! Test receiver sensitivity
1720 GOSUB Dynamic_range          ! Test dynamic range
1730 GOSUB Traf_per_awgn          ! Test demod of traffic channel in AWGN
1740 !
1750 !**************************************************************************
1760 ! STEP 6: RECONFIGURE TEST SET AND ACCESS TERMINAL CONNECTION PARAMETERS
1770 !         (Perform a handoff to a new channel and repeat testing as needed)
1780 !**************************************************************************
1790 !
1800 !      GOSUB Retap_connect         ! Move to an RETAP connection
1810 !      Handoff_chan=1023          ! Hand off to "high" channel for test
1820 !      GOSUB Handoff
1830 !
1840 !      GOSUB Waveform_qual
1850 !      GOSUB Max_pow_spur
1860 !      GOSUB Min_pow
1870 !      GOSUB Time_resp_olp
1880 !      GOSUB Rng_open_loop
1890 !
1900 !      GOSUB Fetap_connect         ! Move to an FETAP connection
1910 !
1920 !      GOSUB Sensitivity
1930 !      GOSUB Dynamic_range
1940 !      GOSUB Traf_per_awgn
1950 !
1960 !      GOSUB Retap_connect         ! Move to an RETAP connection
1970 !      Handoff_chan=799           ! Hand off to "medium" channel for test
1980 !      GOSUB Handoff
1990 !
2000 !      GOSUB Waveform_qual
2010 !      GOSUB Max_pow_spur
2020 !      GOSUB Min_pow
2030 !      GOSUB Time_resp_olp
2040 !      GOSUB Rng_open_loop
2050 !
2060 !      GOSUB Fetap_connect         ! Move to an FETAP connection
2070 !
2080 !      GOSUB Sensitivity
2090 !      GOSUB Dynamic_range
2100 !      GOSUB Traf_per_awgn
2110 !
2120 !**************************************************************************
2130 ! STEP 7: END THE CONNECTION
2140 !**************************************************************************
2150 !
2160  End_exec:!
2170 GOSUB End_connection                       ! End the current connection
2180 GOSUB End_time                             ! Stop test time
2190 GOTO End_program
2200       ! Jump to end of program. Do not remove this line.
2210       ! Must jump over the sub-routines to the end.
2220                                              !
2230 !**************************************************************************
2240 !
2250 !**************************************************************************
2260 ! BEGINNING OF SUBROUTINES
2270 !**************************************************************************
2280 !
2290  Preset_test_set:!
2300 !*******************************************************************
2310 ! Subroutine: Preset the test set (Step 1: Set Up the Test Set)
2320 !*******************************************************************
2330 !
2340 OUTPUT Testset;"*RST"
2350       ! Full preset test set
2360 OUTPUT Testset;"*OPC?"
2370 ENTER Testset;Opc$
2380 RETURN
2390 !
2400  Set_path_loss:!
2410 !*******************************************************************
2420 ! Subroutine: Set path loss values (Step 1: Set Up the Test Set)
2430 !*******************************************************************
2440 !
2450 OUTPUT Testset;"SYST:CORR:FREQ";Loss_frequency$
2460       ! Set the frequencies for amplitude offset
2470 OUTPUT Testset;"SYST:CORR";Expected_loss$
2480       ! Set the amplitude offsets for above frequencies
2490 RETURN
2500 !
2510  Set_call_parms:!
2520 !*******************************************************************
2530 ! Subroutine: Step 2: Configure Test Set and Access Terminal Parameters
2540 !*******************************************************************
2550 !
2560 DISP "Setting up Test Set and Access Terminal Parameters"
2570 !
2571 OUTPUT Testset;"CALL:PROTocol ";P_rev$
2572       ! Set protocol release
2573 OUTPUT Testset;"CALL:PROTocol:PLAYer ";Phy_sub$
2574       ! Set physical layer subtype for Release A
2575 OUTPUT Testset;"CALL:BAND ";Band$
2590       ! Set Cell Band
2600 OUTPUT Testset;"CALL:CHAN ";Primary_channel
2610       ! Set RF Channel for selected Cell Band
2620 OUTPUT Testset;"CALL:POW ";Init_cell_power
2630       ! Set and turns on Cell Power for connection
2640 OUTPUT Testset;"CALL:MS:POWER:MAXIMUM "&At_max_power$
2650       ! Set AT maximum expected power
2660 OUTPUT Testset;"CALL:MCCODE ";Country_code
2670       ! Set AT country code specified
2680 OUTPUT Testset;"CALL:PARAMETER:SECTOR:SMASK ";Subnet_mask
2690       ! Set MS subnet mask specified
2700 RETURN
2710 !
2720  Set_up_meas:!
2730 !*******************************************************************
2740 ! Subroutine: Set all measurement triggers to single
2750 !             (Step 3: Set Meas Parms)
2760 !*******************************************************************
2770 !
2780 OUTPUT Testset;"SETUP:CONTINUOUS:OFF"
2790       ! Set all measurements to single trigger
2800 RETURN
2810 !
2820  Session_open:!
2830 !*******************************************************************
2840 ! Subroutine: Open session
2850 !*******************************************************************
2860 !
2870 OUTPUT Testset;"CALL:DCONNECTED:TIMEOUT 30"
2880       ! Set connection change detector timeout
2890 OUTPUT Testset;"CALL:DCONNECTED:ARM"
2900       ! Arm the connection state change detector
2910 !
2920 BEEP
2930 LINPUT "Connect AT and power on, press ENTER when session open",Keyboard$
2940 DISP "Verifying session is open"
2950 !
2960 OUTPUT Testset;"CALL:SOPEN?"
2970       ! Query the session open state
2980 ENTER Testset;Session_open
2990 IF Session_open=0 THEN
3000       ! If session did not open then end program
3010     BEEP
3020     Print_title("Access Terminal did not open session, check settings")
3030     Print_title("Terminating Testing")
3040     GOTO End_program
3050 END IF
3060 !
3070 DISP "Session Open"
3080 !
3090 !***Read ACCESS TERMINAL information***
3100 !
3110 OUTPUT Testset;"CALL:MS:REP:SSEED?"
3120 ENTER Testset;Sseed$
3130 OUTPUT Testset;"CALL:MS:REP:HID:TYPE?"
3140 ENTER Testset;Hid_type$
3150 OUTPUT Testset;"CALL:MS:REP:HID:HEX?"
3160 ENTER Testset;Hid_hex$
3170 OUTPUT Testset;"CALL:MS:REP:HID:DEC?"
3180 ENTER Testset;Hid_dec$
3190 !
3200 RETURN
3210 !
3220  Retap_connect:!
3230 !*******************************************************************
3240 ! Subroutine: Open an RETAP connection
3250 !*******************************************************************
3260 !
3270 DISP "Opening (or Moving to) an RETAP Connection"
3280 !
3290 IF NOT FNConnected THEN
3300     DISP "Connection is not currently open"
3310           ! If the state is NOT connected, then see if it is session open
3320 !
3330     IF NOT FNSession_check THEN
3340           ! If the state is NOT session open, then end program
3350         Print_title("Session is not currently open")
3360         Print_title("Ending Testing")
3370         GOTO End_program
3380     END IF
3390           ! If the state is session open, then change to RETAP and
3400           ! open a connection
3410     DISP "Session is open, opening an RETAP connection now"
3420 !
3430     OUTPUT Testset;"CALL:APPLication:ETAPlication REVerse"
3440           ! Set application type to RETAP (for AT transmitter testing)
3450     OUTPUT Testset;"CALL:APPLication:DATA:PACKet BIT256"
3460           ! Set Reverse data packet size to 256 bits.
3470     GOSUB Start_data
3480 !
3490 ELSE
3500     DISP "Connection is currently open, changing to RETAP"
3510           ! If state is connected, then change to RETAP
3520     OUTPUT Testset;"CALL:APPLication:ETAPlication REVerse"
3530           ! Set application type to RETAP (for AT transmitter testing)
3540     OUTPUT Testset;"CALL:APPLication:DATA:PACKet BIT256"
3550           ! Set Reverse data packet size to 256 bits.
3560 !
3570           !IF NOT FNConnected THEN
3580           ! This additional loop is only necessary if Limited TAP is On
3590               !DISP "Connection was closed when Application changed"
3600               ! If the state is NOT connected, then see if session open
3610               !IF NOT FNSession_check THEN
3620               ! If the state is NOT session open, then end program
3630                   !Print_title("Session is not currently open")
3640                   !Print_title("Ending Testing")
3650                   !GOTO End_program
3660               !END IF
3670               ! If the state is session open, then re-open a connection
3680               !DISP "Session is open, re-opening an RETAP connection now"
3690               !GOSUB Start_data
3700           !END IF
3710 !
3720     DISP "RETAP Connection Open"
3730 !
3740 END IF
3750 !
3760 RETURN
3770 !
3780  Fetap_connect:!
3790 !*******************************************************************
3800 ! Subroutine: Open an FETAP connection
3810 !*******************************************************************
3820 !
3830 DISP "Opening (or Moving to) an FETAP Connection"
3840 !
3850 IF NOT FNConnected THEN
3860     DISP "Connection is not currently open"
3870           ! If the state is NOT connected, then see if it is session open
3880 !
3890     IF NOT FNSession_check THEN
3900           ! If the state is NOT session open, then end program
3910         Print_title("Session is not currently open")
3920         Print_title("Ending Testing")
3930         GOTO End_program
3940     END IF
3950           ! If the state is session open, then change to FETAP and
3960           ! open a connection
3970     DISP "Session is open, opening an FETAP connection now"
3980 !
3990     OUTPUT Testset;"CALL:APPLication:ETAPlication FORWard"
4000           ! Set application type to FETAP  (for AT Receiver testing)
4010     OUTPUT Testset;"CALL:APPLication:TRAFfic:FORMat 4,1024,2,128"
4020           ! Set F-Traffic transmission format resulting in 307.2kbps,2slots
4030     GOSUB Start_data
4040 !
4050 ELSE
4060     DISP "Connection is currently open, changing to FETAP"
4070           ! If state is connected, then change to FETAP
4080     OUTPUT Testset;"CALL:APPLication:ETAPlication FORWard"
4090           ! Set application type to FETAP  (for AT Receiver testing)
4100     OUTPUT Testset;"CALL:APPLication:TRAFfic:FORMat 4,1024,2,128"
4110           ! Set F-Traffic transmission format resulting in 307.2kbps,2slots
4120 !
4130     IF NOT FNConnected THEN
4140         DISP "Connection was closed when Application changed"
4150               ! If the state is NOT connected, then see if session open
4160         IF NOT FNSession_check THEN
4170               ! If the state is NOT session open, then end program
4180             Print_title("Session is not currently open")
4190             Print_title("Ending Testing")
4200             GOTO End_program
4210         END IF
4220               ! If the state is session open, then re-open a connection
4230         DISP "Session is open, re-opening an FETAP connection now"
4240         GOSUB Start_data
4250     END IF
4260 !
4270     DISP "FETAP Connection Open"
4280 !
4290 END IF
4300 !
4310 RETURN
4320 !
4330  Start_data:!
4340 !*******************************************************************
4350 ! Subroutine: Start data connection and verify it has connected
4360 !*******************************************************************
4370 !
4380 OUTPUT Testset;"CALL:DCONNECTED:TIMEOUT 10"
4390       ! Set connection change detector timeout
4400 OUTPUT Testset;"CALL:DCONNECTED:ARM"
4410       ! Arm the connection state change detector
4420 OUTPUT Testset;"CALL:FUNCTION:DATA:START"
4430       ! Page the access terminal
4440 OUTPUT Testset;"CALL:DCONNECTED?"
4450       ! Query the connection status
4460 ENTER Testset;Data_started
4470 !
4480 IF Data_started=0 THEN
4490     Print_title("Data connection could not be opened")
4500     Print_title("Ending Testing")
4510     GOTO End_program
4520 END IF
4530 !
4540 DISP "Data Connection Open"
4550 !
4560 RETURN
4570 !
4580  Handoff:!
4590 !*******************************************************************
4600 ! Subroutine: Set up and perform a hard handoff
4610 !*******************************************************************
4620 !
4630 !***Set up a hard handoff***
4640 !
4650 OUTPUT Testset;"CALL:SETUP:BAND "&Handoff_band$
4660       ! Specify the cell band to hand off to
4670 OUTPUT Testset;"CALL:SETUP:CHANNEL ";Handoff_chan
4680       ! Specify the channel number to hand off to
4690 !
4700 !***Perform a hard handoff***
4710 !
4720 OUTPUT Testset;"CALL:HANDOFF"
4730       ! Initiate a hard handoff
4740 !
4750 IF NOT FNConnected THEN
4760       ! Verify connection is still open after handoff
4770     DISP "Handoff attempt failed, program stopped"
4780     GOTO End_program
4790 ELSE
4800     PRINT
4810     Print_results("Handoff completed to channel: ",Handoff_chan,"")
4820     PRINT "Call connected"
4830     PRINT
4840     Current_chan=Handoff_chan
4850     Band$=Handoff_band$
4860 !
4870 END IF
4880 !
4890 RETURN
4900 !
4910  Waveform_qual:!
4920 !*******************************************************************
4930 ! Subroutine: Waveform Quality + Code Domain Measurement
4932 !             4.1.2 Frequency Accuracy
4933 !             4.2.1 Timer Reference (static test only)
4940 !             4.2.2 Waveform Quality and Frequency Accuracy
4941 !             4.3.7 RRI Channel Output Power
4942 !             4.3.8.1 DRC Channel Output Power (for test 2)
4943 !             4.3.8.2 ACK Channel Output Power (for test 2)
4945 !             4.3.8.4 DSC Channel Output Power (for test 1)
4946 !             4.3.8.3 Data Channel Output Power (for test 1)
4947 !             4.3.8.3 Data Channel Output Power (for test 8)
4950 !*******************************************************************
4960 !
4970 DISP "Measuring Waveform Quality and Code Domain Power"
4980 !
4990 !***Set up test parameters***
4991 ! To simplify the program, only one example of those tests as specified
4992 ! in standard are given here. You can refer to this example to program
4993 ! your test cases.
5000 !
5010 Ior=-75              ! Cell power for tests
5011 Drc_gain=3          ! DRC channel gain. Change as desired.
5012 Ack_gain=3          ! Ack channel gain. Change as desired.
5013 Dsc_gain=-9          ! DSC channel gain. Change as desired.
5014 Rri_gain=-6          ! RRI channel gain. Change as desired
5015 Meas_slots=2          ! Set slots to measure. Change as desired.
5020 !
5021 !
5022 OUTPUT Testset;"CALL:MACChannel:ARQ:ACK:DATA SUBP0"
5023       ! Set Ack R-Data After to subpacket 0.
5030 OUTPUT Testset;"CALL:APPLication:DATA:PACKet BIT256"
5040       ! Set R-Data Packet size to 256 bits.
5041 OUTPUT Testset;"CALL:APPLication:DATA:TRANsmission HCAPacity"
5042       ! Set R-Data transmission mode to high capacity.
5043       !OUTPUT Testset;"CALL:MS:T2Pilot:BIT256:HCAPacity:TRANsition 3"
5044       ! Set 256 bits high capacity T2P Tranistion to 4 subframes.
5045       ! It is required only if you've change the test set default value.
5046       ! NOTE:changing this parameter results in a session renegotionation,
5047       ! You should set this parameter prior to a data connection.
5048       !OUTPUT Testset;"CALL:MS:T2Pilot:BIT256:HCAPacity:TARGet 3"
5049       ! Set 256 bits high capacity termination target to 4 subframes.
5052       ! It is required only if you've change the test set default value.
5053       ! NOTE:changing this parameter results in a session renegotionation,
5054       ! You should set this parameter prior to a data connection.
5055 OUTPUT Testset;"CALL:APPLICATION:ACKCHANNEL:BFMATTRIBUTE ON"
5056       ! Turn on ACK Channel Bit Fixed Mode Attribute. It is required
5057       ! only if you've change the test set default setting.
5058       !OUTPUT Testset;"CALL:MS:RRIGain:TRANsition3:PRE ";Rri_gain
5059       ! Only required for 4.3.7 test. Set RRIChannelGainPreTransition3 to -6dB.
5061       ! It is required only if you've change the test set default setting.
5062       ! NOTE:changing this parameter results in a session renegotionation,
5063       ! You should set this parameter prior to a data connection.
5064 OUTPUT Testset;"CALL:MS:DRCGain ";Drc_gain
5065       ! Only required for 4.3.8.1 test.
5066       ! Set DRC ChannelGain to 3 dB for test 2.
5067       ! It is required only if you've change the test set default setting.
5069 OUTPUT Testset;"CALL:MS:ACKGain ";Ack_gain
5070       ! Only for 4.3.8.2 test. Set ACK ChannelGain to 3 dB.
5071       ! It is required only if you've change the test set default setting.
5073 OUTPUT Testset;"CALL:MS:DSCGain ";Dsc_gain
5074       ! Only for 4.3.8.4 test. Set DSC ChannelGain to -9 dB.
5075       ! It is required only if you've change the test set default setting.
5077 OUTPUT Testset;"CALL:POW ";Ior
5078       ! Set cell power
5079 WAIT .1
5080 !
5081 !***Set up measurement parameters***
5090 !
5100 OUTPUT Testset;"SETUP:DOWQ:TIMEOUT 10"
5110       ! Set waveform quality measurement timeout to 10 seconds
5120 OUTPUT Testset;"SETUP:DOWQ:SLOT:COUNT ";Meas_slots
5130       ! Set slots to measure.
5140 !
5150 !***INITiate and FETCh measurement results***
5160 !
5170 OUTPUT Testset;"INITiate:DOWQuality"
5180       ! Initiate a waveform quality + code domain measurement
5190 OUTPUT Testset;"FETCh:DOWQuality?"
5200       ! Query the test set for waveform quality measurement results
5210 ENTER Testset;Integrity,Rho,F_err,T_err,C_feed,P_err,M_err,Evm
5211       !
5220 OUTPUT Testset;"FETCh:DOWQuality:CDPower:RRIChannel?"
5221       ! Query the test set for RRI channel CDP measurement results.
5222 ENTER Testset;Rri_chan,Rri_walsh,Rri_sf,Rri_cdp,Rri_total_cdp,Rri_norm_total,Rri_delta_pilot
5223       !
5224 OUTPUT Testset;"FETCh:DOWQuality:CDPower:DRCChannel?"
5225       ! Query the test set for DRC channel CDP measurement results.
5226 ENTER Testset;Drc_chan,Drc_walsh,Drc_sf,Drc_cdp,Drc_total_cdp,Drc_norm_total,Drc_delta_pilot
5227       !
5228 OUTPUT Testset;"FETCh:DOWQuality:CDPower:ACKChannel?"
5229       ! Query the test set for ACK channel CDP measurement results.
5230 ENTER Testset;Ack_chan,Ack_walsh,Ack_sf,Ack_cdp,Ack_total_cdp,Ack_norm_total,Ack_delta_pilot
5231       !
5232 OUTPUT Testset;"FETCh:DOWQuality:CDPower:DSCChannel?"
5233       ! Query the test set for DSC channel CDP measurement results.
5234 ENTER Testset;Dsc_chan,Dsc_walsh,Dsc_sf,Dsc_cdp,Dsc_total_cdp,Dsc_norm_total,Dsc_delta_pilot
5235 !
5236 OUTPUT Testset;"FETCh:DOWQuality:CDPower:DATA?"
5237       ! Query the test set for Data channel CDP measurement results
5238       ! for Test 1: 256 bits R-Data Pkt size.
5239 ENTER Testset;T1_chan,T1_walsh,T1_sf,T1_cdp,T1_total_cdp,T1_norm_cdp,T1_delta_pilot
5240 !
5243 !
5244 !***Print Waveform Quality results***
5245 !
5250 Print_title("Waveform Quality Test Results:")
5260 PRINT
5270 Print_results("Channel/Band= ",Current_chan,Band$)
5280 Print_results("Integrity indicator = ",Integrity,"")
5290 Print_results("Rho = ",Rho,"")
5300 Print_results("Frequency error = ",F_err,"Hz")
5310 Print_results("Time error = ",T_err,"us")
5320 Print_results("Carrier feedthrough = ",C_feed,"dBc")
5330 Print_results("Phase error = ",P_err,"deg")
5340 Print_results("Magnitude error = ",M_err,"%")
5350 Print_results("Error vector magnitude = ",Evm,"%")
5360 PRINT
5370 Print_title("Waveform Quality Test Complete")
5380 PRINT
5390 PRINT
5400       !
5410 !***Print RRI Channel Code Domain results***
5411 !
5412 Print_title("RRI Channel Output Power Results:")
5413 PRINT
5414 IF (Rri_chan=0) THEN
5416 Print_results("RRI walsh code =",Rri_walsh,"on I channel")
5417 ELSE
5418 Print_results("RRI walsh code =",Rri_walsh,"on Q channel")
5419 END IF
5420 Print_results("Spread Factor (SF) = ",Rri_sf,"")
5421 Print_results("RRI Power Relative to R-Pilot= ",Rri_delta_pilot,"dB")
5422 PRINT
5425 Print_title("RRI Channel Output Power Test Complete")
5427 PRINT
5428 PRINT
5429       !
5430 !***Print DRC Channel Code Domain results***
5440 !
5441 Print_title("DRC Channel Output Power Results:")
5442 PRINT
5443 IF (Drc_chan=0) THEN
5444 Print_results("DRC walsh code =",Drc_walsh,"on I channel")
5445 ELSE
5446 Print_results("DRC walsh code =",Drc_walsh,"on Q channel")
5447 END IF
5448 Print_results("Spread Factor (SF) = ",Drc_sf,"")
5449 Print_results("DRC Power Relative to R-Pilot= ",Drc_delta_pilot,"dB")
5450 PRINT
5451 Print_title("DRC Channel Output Power Test Complete")
5452 PRINT
5453 PRINT
5454       !
5455 !***Print ACK Channel Code Domain results***
5456 !
5457 Print_title("ACK Channel Output Power Results:")
5458 PRINT
5459 IF (Ack_chan=0) THEN
5460 Print_results("ACK walsh code =",Ack_walsh,"on I channel")
5461 ELSE
5462 Print_results("ACK walsh code =",Ack_walsh,"on Q channel")
5464 END IF
5465 Print_results("Spread Factor (SF) = ",Ack_sf,"")
5466 Print_results("ACK Power Relative to R-Pilot = ",Ack_delta_pilot,"dB")
5467 PRINT
5468 Print_title("ACK Channel Output Power Test Complete")
5469 PRINT
5470 PRINT
5471       !
5472 !***Print DSC Channel Code Domain results***
5481 !
5482 Print_title("DSC Channel Output Power Results:")
5483 PRINT
5484 IF (Dsc_chan=0) THEN
5485 Print_results("DSC walsh code =",Dsc_walsh,"on I channel")
5486 ELSE
5487 Print_results("DSC walsh code =",Dsc_walsh,"on Q channel")
5488 END IF
5489 Print_results("Spread Factor (SF) = ",Dsc_sf,"")
5490 Print_results("DSC Power Relative to R-Pilot= ",Dsc_delta_pilot,"dB")
5491 PRINT
5492 Print_title("DSC Channel Output Power Test Complete")
5493 PRINT
5494 PRINT
5495       !
5496 !***Print Data Channel Code Domain results for R-Data Pkt Size 256 bits (Test 1)***
5497 !
5498 Print_title("Data Channel Output Power Results (256 bits pkt size):")
5499 PRINT
5500 IF (T1_chan=0) THEN
5501 Print_results("R-Data walsh code =",T1_walsh,"on I channel")
5502 ELSE
5503 Print_results("R-Data walsh code =",T1_walsh,"on Q channel")
5504 END IF
5505 Print_results("Spread Factor (SF) = ",T1_sf,"")
5506 Print_results("R-Data Power Relative to R-Pilot = ",T1_delta_pilot,"dB")
5507 PRINT
5508 Print_title("Data Channel Output Power Test Complete")
5509 PRINT
5510 PRINT
5511 !
5513 !***Set up test parameters for 4.3.8.3 (test 8)***
5531 !
5532 OUTPUT Testset;"CALL:APPLication:DATA:PACKet BIT3072"
5533       ! Set R-Data Packet size to 3072 bits.
5538       ! It is required only if you've change the test set default value.
5539       !OUTPUT Testset;"CALL:MS:T2Pilot:BIT3072:HCAPacity:TARGet 3"
5540       ! Set 3072 bits high capacity termination target to 4 subframes.
5541       ! It is required only if you've changed test set default value.
5542       ! NOTE:changing this parameter results in a session renegotiation,
5543       ! You should set this parameter prior to a data connection. Otherwise,
5544       ! you need to re-open the connection
5545       !OUTPUT Testset;"CALL:MS:APPayload BIT3072"
5546       ! Set auxiliary pilot channel minimum playload to 3072 bits.
5547       ! It is required only if you've change the test set default setting.
5548       ! NOTE:changing this parameter results in a session renegotiation,
5549       ! You should set this parameter prior to a data connection. Otherwise,
5550       ! you need to re-open the connection.
5551 !
5552 !***Set up measurement parameters for 4.3.8.3 (test 8)***
5561 !
5564 OUTPUT Testset;"SETUP:DOWQ:SLOT:COUNT 1"
5565       ! Set slots to measure to 1
5566 !
5567 !***INITiate and FETCh measurement results for 4.3.8.3 (test 8)***
5568 !
5569 OUTPUT Testset;"INITiate:DOWQuality"
5570       ! Initiate a waveform quality + code domain measurement
5571 !
5572 OUTPUT Testset;"FETCh:DOWQuality:CDPower:DATA?"
5573       ! Query for Data channel CDP results for R-Data Pkt Size 3072 bits (test 8).
5574 ENTER Testset;T8_chan,T8_walsh,T8_sf,T8_cdp,T8_total_cdp,T8_norm_cdp,T8_delta_pilot
5575 !
5576 OUTPUT Testset;"FETCh:DOWQuality:CDPower:DATA:RTPilot?"
5577       ! Query for CDP power of each walsh channel constituting the Data channel.
5579 ENTER Testset;T8_chan,Cdp_1,Cdp_2,Cdp_3,Cdp_4
5580       !
5581 OUTPUT Testset;"FETCh:DOWQuality:CDPower:PILot:AUXiliary?"
5582       ! Query for Auxiliary Pilot channel CDP results.
5583 ENTER Testset;Ap_chan,Ap_walsh,Ap_sf,Ap_cdp,Ap_total_cdp,Ap_norm_cdp,Ap_delta_pilot
5584       !
5585 !***Print Data Channel Code Domain results for R-Data Pkt Size 3072 bits (Test 8)***
5586 !
5587 Print_title("Data Channel Output Power Results (3072 bits pkt size):")
5588 PRINT
5589     SELECT T8_chan
5590           ! Set step direction for each measurement
5591     CASE 1
5592         Modu_typ$="B4"
5593         Walsh_ch$="1 walsh channel"
5594         Print_res_str("R-Data Modulation Type is ",Modu_typ$)
5595         Print_res_str("R-Data occupies ",Walsh_ch$)
5596         Print_results("R-Data on Q:2(SF=4) Relative to R-Pilot= ",Cdp1,"dB")
5597         Print_results("R-Data Power Relative to R-Pilot= ",T8_delta_pilot,"dB")
5598     CASE 2
5599         Modu_typ$="Q4"
5600         Walsh_ch$="2 walsh channel"
5602         Print_res_str("R-Data Modulation Type is ",Modu_typ$)
5603         Print_res_str("R-Data occupies ",Walsh_ch$)
5605         Print_results("R-Data on I:2(SF=4) Rel.to R-Pilot= ",Cdp1,"dB")
5606         Print_results("R-Data on Q:2(SF=4) Rel.to R-Pilot= ",Cdp2,"dB")
5607         Print_results("R-Data Power Relative to R-Pilot= ",T8_delta_pilot,"dB")
5608     CASE 3
5609         Modu_typ$="Q2"
5610         Wwalsh_ch$="2 walsh channel"
5612         Print_res_str("R-Data Modulation Type is ",Modu_typ$)
5613         Print_res_str("R-Data occupies ",Walsh_ch$)
5615         Print_results("R-Data on I:1(SF=2) Rel.to R-Pilot= ",Cdp1,"dB")
5616         Print_results("R-Data on Q:1(SF=2) Rel. to R-Pilot= ",Cdp2,"dB")
5617         Print_results("R-Data Power Relative to R-Pilot= ",T8_delta_pilot,"dB")
5618     CASE 4
5619         Modu_typ$="Q4Q2"
5620         Walsh_ch$="4 walsh channel"
5622         Print_res_str("R-Data Modulation Type is ",Modu_typ$)
5623         Print_res_str("R-Data occupies ",Walsh_ch$)
5624         Print_results("R-Data on I:2(SF=4) Rel. to R-Pilot= ",Cdp1,"dB")
5628         Print_results("R-Data on I:1(SF=2) Rel. to R-Pilot= ",Cdp2,"dB")
5629         Print_results("R-Data on Q:2(SF=4) Rel. to R-Pilot= ",Cdp3,"dB")
5630         Print_results("R-Data on Q:1(SF=2) Rel. to R-Pilot= ",Cdp4,"dB")
5631         Print_results("R-Data Power Relative to R-Pilot= ",T8_delta_pilot,"dB")
5632     CASE 5
5633         Modu_typ$="E4E2"
5634         Walsh_ch$="4 walsh channel"
5636         Print_res_str("R-Data Modulation Type is ",Modu_typ$)
5637         Print_res_str("R-Data occupies ",Walsh_ch$)
5640         Print_results("R-Data on I:2(SF=4) Rel. to R-Pilot= ",Cdp1,"dB")
5641         Print_results("R-Data on I:1(SF=2) Rel. to R-Pilot= ",Cdp2,"dB")
5642         Print_results("R-Data on Q:2(SF=4) Rel. to R-Pilot= ",Cdp3,"dB")
5643         Print_results("R-Data on Q:1(SF=2) Rel. to R-Pilot= ",Cdp4,"dB")
5644         Print_results("R-Data power Relative to R-Pilot= ",T8_delta_pilot,"dB")
5645     CASE ELSE
5646         Print_res_str("Invalid measurement results","")
5647     END SELECT
5648 PRINT
5649 PRINT
5650 !
5651 !***Print Auxiliary Pilot Channel Code Domain results***
5652 !
5653 Print_title("Auxiliary Pilot Channel Output Power Results (R-Data Pkt Size=3072bits):")
5654 PRINT
5655 IF (Ap_chan=0) THEN
5656 Print_results("Auxiliary Pilot walsh code =",Ap_walsh,"on I channel")
5657 ELSE
5658 Print_results("Auxiliary Pilot walsh code =",Ap_walsh,"on Q channel")
5659 END IF
5660 Print_results("Spread Factor (SF) = ",Ap_sf,"")
5661 Print_results("Auxiliary Pilot Power Relative to R-Pilot= ",Ap_delta_pilot,"dB")
5662 PRINT
5663       !
5664 Print_title("Data Channel Output Power Test for 3072 pkt size Complete")
5665 PRINT
5666 PRINT
5667                 !
5668 !***Post test clean up***
5669 !
5670 OUTPUT Testset;"INIT:DOWQ:OFF"
5671 OUTPUT Testset;"CALL:POW ";Init_cell_power
5672       ! Set cell power back to initial level
5673 DISP ""
5674 !
5675 RETURN
5676 !
5677  Max_pow_spur:!
5678 !*******************************************************************
5679 ! Subroutine: Digital Average Power and
5680 !             TX Spurious Emissions Measurements
5681 !             4.3.4 Maximum RF Output Power
5682 !             4.4.1 Conducted Spurious Emissions
5683 !*******************************************************************
5684 !
5685 DISP "Measuring Maximum Power and TX Spurious Emissions"
5686 !
5687 !***Set up test parameters***
5688 !
5689 Ior=-60                         ! Set cell power for test
5690 !
5691 IF Band$="KPCS" OR Band$="USPCS" OR Band$="USPCs1900" OR Band$="IMT2000" THEN
5692       !
5693       ! Set open loop adjust for test
5694     Ol_adjust=84
5695 ELSE
5696     Ol_adjust=81
5697 END IF
5710 !
5721 OUTPUT Testset;"CALL:APPLication:DATA:PACKet BIT4096"
5722       ! Set R-Data Packet size to 4096 bits.
5723 OUTPUT Testset;"CALL:APPLication:DATA:TRANsmission HCAPacity"
5724       ! Set R-Data transmission mode to high capacity.
5725 !OUTPUT Testset;"CALL:MS:T2Pilot:BIT4096:HCAPacity:TARGet 3"
5726       ! Set 4096 bits high capacity termination target to 4 subframes.
5727       ! It is required only if you've changed test set default value.
5728       ! NOTE:changing this parameter results in a session renegotiation,
5729       ! You should set this parameter prior to a data connection. Otherwise,
5730       ! you need to re-open the connection
5734 OUTPUT Testset;"CALL:APPLication:TRAFfic:FORMat 4,1024,2,128"
5735       ! Set F-Traffic transmission format to 307.2 kbps (2 slots).
5736 OUTPUT Testset;"CALL:APPLication:ACKChannel:BFMAttribute 1"
5737       ! Set Ack channel bit fixed mode attribute to On.
5738       !
5739 OUTPUT Testset;"CALL:APAR:POWER:OLADJUST ";Ol_adjust
5740       ! Set Open Loop Adjust
5750 OUTPUT Testset;"CALL:APAR:PROBE:IADJUST 15"
5760       ! Set Probe Initial Adjust
5770 OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP 7.5"
5860       ! Set Probe Power Step
5870 !
5880 !***Set up measurement parameters***
5890 !
5900 OUTPUT Testset;"SETUP:DAPOWER:TIMEOUT 1"
5910       ! Set DIGITAL Power timeout to 1 sec
5920 OUTPUT Testset;"SETUP:CTXS:TIMEOUT 5"
5930       ! Set TX Spur Emissions timeout to 5 sec
5940 !
5950 !***Set test conditions***
5960 !
5970 OUTPUT Testset;"CALL:POW ";Ior
5980       ! Set Cell Power for Test
5990 OUTPUT Testset;"CALL:CLPCONTROL:REVERSE:MODE UP"
6000       ! Start transmission of All Up (0) power control bits
6010 WAIT 1
6020       ! Settling time to allow mobile power to slew up to maximum power
6030 !
6040 !***Obtain measurement results***
6050 !
6060 OUTPUT Testset;"INITIATE:DAPOWER;CTXS"
6070       ! Initiate digital average power and
6080       ! TX spurious emissions measurements
6090 !
6100 LOOP
6110     OUTPUT Testset;"INIT:DONE?"
6120           ! Determine if a measurement is done
6130     ENTER Testset;Meas_done$
6140           ! Obtain measurement results as they are ready
6150 !
6160     SELECT Meas_done$
6170     CASE "DAP"
6180         OUTPUT Testset;"FETCh:DAPOWER?"
6190         ENTER Testset;Integrity,Avg_power_dbm
6200     CASE "CTXS"
6210         OUTPUT Testset;"FETCH:CTXS?"
6220         ENTER Testset;Ctxs_integ,Ctxs_pf,Low_adj,Upp_adj,Low_alt,Upp_alt
6230     END SELECT
6240 !
6250 EXIT IF Meas_done$="NONE"
6260       ! Exit loop when all measurements are complete
6270 END LOOP
6280       ! If Meas_done$="WAIT" then loop continues until "NONE"
6290 !
6300 Avg_power_dbw=Avg_power_dbm-30
6310       ! Convert dBm to dBW
6320 !
6330 SELECT Ctxs_pf
6340       ! Assign CTXS pass/fail results to a string
6350 CASE 0
6360     Pass_fail$="PASS"
6370 CASE 1
6380     Pass_fail$="FAIL"
6390 END SELECT
6400 !
6410 !***Print Max Power Test Results***
6420 !
6430 Print_title("Max Power Test Results:")
6440 PRINT
6450 Print_results("Channel/Band= ",Current_chan,Band$)
6460 Print_results("Integrity indicator = ",Integrity,"")
6470 Print_results("Maximum Power dBm:",Avg_power_dbm,"dBm")
6480 Print_results("Maximum Power dBW:",Avg_power_dbw,"dBW")
6490 PRINT
6500 Print_title("Max Power Test Complete")
6510 PRINT
6520 PRINT
6530 !
6540 !***Print TX Spurious Test Results
6550 !
6560 Print_title("TX Spurious Test Results:")
6570 PRINT
6580 Print_results("Channel/Band= ",Current_chan,Band$)
6590 Print_results("Integrity indicator = ",Ctxs_integ,"")
6600 Print_res_str("Test Result: ",Pass_fail$)
6610 Print_results("Lower Adjacent Power",Low_adj,"dBc")
6620 Print_results("Upper Adjacent Power",Upp_adj,"dBc")
6630 Print_results("Lower Alternate Power",Low_alt,"dBc")
6640 Print_results("Upper Alternate Power",Upp_alt,"dBc")
6650 PRINT
6660 Print_title("TX Spurious Test Complete")
6670 PRINT
6680 PRINT
6690 !
6700 !***Post test clean up***
6710 !
6720 OUTPUT Testset;"CALL:CLPCONTROL:REVERSE:MODE ACTIVE"
6730       ! Return to active power control bits
6740 OUTPUT Testset;"CALL:POW ";Init_cell_power
6750       ! Set cell power back to initial level
6760       ! Do this before reconfiguring other parms so signaling
6770 OUTPUT Testset;"CALL:APAR:PROBE:IADJUST 0"
6780       ! Set Access parameters for test
6790 OUTPUT Testset;"CALL:APAR:PROBE:STEP:COUNT 5"
6800       ! Set Access paramters for test
6810 OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP 1"
6850       ! Set Access paramters for test
6860 OUTPUT Testset;"INIT:DAP:OFF"
6870       ! Turn digital ave power off
6880 OUTPUT Testset;"INIT:CTXS:OFF"
6890       ! Turn TX spurious emissions off
6900 DISP ""
6910 !
6920 RETURN
6930 !
6940  Min_pow:!
6950 !*******************************************************************
6960 ! Subroutine: Channel Power Measurement
6970 !             4.3.5 Minimum Controlled Output Power
6980 !*******************************************************************
6990 !
7000 DISP "Measuring Minimum Power"
7010 !
7020 !***Set up test parameters***
7030 !
7040 Ior=-25
7050 !
7060 OUTPUT Testset;"CALL:APPLication:DATA:PACKet BIT256"
7070       ! Set R-Data Packet size to 256 bits.
7071 OUTPUT Testset;"CALL:APPLication:DATA:TRANsmission HCAPacity"
7072       ! Set R-Data transmission mode to high capacity.
7073       !OUTPUT Testset;"CALL:MS:T2Pilot:BIT256:HCAPacity:TARGet 3"
7074       ! Set 256 bits high capacity termination target to 4 subframes.
7075       ! It is required only if you've change the test set default value.
7076       ! NOTE:changing this parameter results in a session renegotionation,
7077       ! You should set this parameter prior to a data connection.
7080 OUTPUT Testset;"CALL:CONNECTED:DROP:TIMER:STATE 0"
7090       ! Turn the call drop timer off
7100 !
7110 !***Set up measurement parameters***
7120 !
7130 OUTPUT Testset;"SETUP:CPOWER:TIMEOUT .5"
7140       ! Set Channel Power timeout to 0.5 sec
7150 !
7160 !***Set test conditions***
7170 !
7180 OUTPUT Testset;"CALL:POW ";Ior
7190       ! Set cell power for test
7200 OUTPUT Testset;"CALL:CLPCONTROL:REVERSE:MODE DOWN"
7210       ! Start transmission of All Down (1) power control bits
7220 WAIT 1
7230       ! Settling time for mobile output power to slew down
7240 !
7250 !***INITiate and FETCh measurements***
7260 !
7270 GOSUB Meas_chan_pow
7280       ! Subroutine for measuring channel power, includes ranging
7290 !
7300 !***Print measurement results***
7310 !
7320 Print_title("Minimum Power Test Results:")
7330 PRINT
7340 Print_results("Channel/Band= ",Current_chan,Band$)
7350 Print_results("Integrity indicator = ",Integrity,"")
7360 Print_results("Minimum Power dBm:",Channel_power,"dBm/1.23 MHz")
7370 PRINT
7380 Print_title("Minimum Power Test Complete")
7390 PRINT
7400 PRINT
7410 !
7420 !***Post test clean up***
7430 !
7440 OUTPUT Testset;"CALL:CLPCONTROL:REVERSE:MODE ACTIVE"
7450       ! Return to active power control bits
7460 OUTPUT Testset;"CALL:POW ";Init_cell_power
7470       ! Set cell power back to initial level
7480 OUTPUT Testset;"CALL:CONNECTED:DROP:TIMER:STATE 1"
7490       ! Return call drop timer to ON
7500 OUTPUT Testset;"INIT:CPOW:OFF"
7510       ! Turn channel power off
7520 DISP ""
7530 !
7540 RETURN
7550 !
7560  Rng_open_loop:!
7570 !*******************************************************************
7580 ! Subroutine: Access Probe Power Measurement
7590 !             4.3.1 Range of Open Loop Output Power
7600 !*******************************************************************
7610 !
7620 DISP "Testing Range of Open Loop Power"
7630 !
7640 !***End current connection***
7650 !
7660 IF FNConnected THEN
7670       ! Check to see if currently connected
7680     GOSUB End_connection
7690 END IF
7700 !
7710 !***Verify session is open***
7720 !
7730 IF NOT FNSession_check THEN
7740       ! Check to see if session open
7750     Print_title("Session must be open during Range of Open Loop")
7760     Print_title("Ending Testing")
7770     GOTO End_program
7780 END IF
7790 !
7800 !***Set up test parameters***
7810 !
7820 Ior1=-25                           ! First level for test
7830 Ior2=-65                           ! Second level for test
7840 Ior3=-93.5
7850       ! Ior for test 3 Band Class 0, AT Class III
7860 Ol_adjust=78
7870       ! Set Open Loop Adjust for Band Class 0
7880 !
7890 OUTPUT Testset;"CALL:APAR:POWER:OLADJUST ";Ol_adjust
7900       ! Set Open Loop Adjust
7910 OUTPUT Testset;"CALL:APAR:PREAMBLE:LENGTH 7"
7920       ! Set preamble length in frames
7930 OUTPUT Testset;"CALL:APAR:PROBE:SEQUENCE 1"
7980       ! Set Probe Sequence Max
7990       ! This must be done BEFORE call limit mode is turned on
8000 OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP 0"
8010       ! Set Probe Power Step
8020 !
8030 !***Set up measurement parameters***
8040 !
8050 OUTPUT Testset;"SETUP:CAPP:TIMEOUT 10"
8060       ! Set access probe power timeout to 10 seconds
8070 !
8080 !***Set test conditions***
8090 !
8100 OUTPUT Testset;"CALL:CONNECTED:LIMIT:STATE 1"
8110       ! Turn on call limit mode so connection is not established
8120       ! This must be done AFTER probe sequence max is set
8130 !
8140 !***Obtain measurement results***
8150 !
8160 OUTPUT Testset;"CALL:POW ";Ior1
8170       ! Set cell power for test 1
8180 WAIT .1
8190       ! Settling time for access terminal output power to slew
8200 OUTPUT Testset;"CALL:FUNCTION:DATA:START"
8210       ! Page access terminal
8220 OUTPUT Testset;"READ:CAPP?"
8230       ! Read access probe power
8240 ENTER Testset;Integrity1,Test1
8250 OUTPUT Testset;"CALL:FUNCTION:DATA:STOP"
8260       ! Stop data connection paging before repaging at next level
8270 !
8280 OUTPUT Testset;"CALL:POW ";Ior2
8290       ! Set cell power for test 2
8300 WAIT .1
8310       ! Settling time for mobile output power to slew
8320 OUTPUT Testset;"CALL:FUNCTION:DATA:START"
8330       ! Page access terminal
8340 OUTPUT Testset;"READ:CAPP?"
8350       ! Read access probe power
8360 ENTER Testset;Integrity2,Test2
8370 OUTPUT Testset;"CALL:FUNCTION:DATA:STOP"
8380       ! Stop data connection paging before repaging at next level
8390 !
8400 OUTPUT Testset;"CALL:POW ";Ior3
8410       ! Set cell power for test 3
8420 WAIT .1
8430       ! Settling time for mobile output power to slew
8440 OUTPUT Testset;"CALL:FUNCTION:DATA:START"
8450       ! Page access terminal
8460 OUTPUT Testset;"READ:CAPP?"
8470       ! Read access probe power
8480 ENTER Testset;Integrity3,Test3
8490 OUTPUT Testset;"CALL:FUNCTION:DATA:STOP"
8500       ! Stop data connection paging
8510 !
8520 !***Print measurement results***
8530 !
8540 Print_title("Range of Open Loop Power Control Results:")
8550 PRINT
8560 Print_results("Channel/Band= ",Current_chan,Band$)
8570 Print_results("Integrity indicator = ",Integrity1,"")
8580 Print_results("Test 1 @ "&VAL$(Ior1)&" dBm:",Test1,"dBm/1.23 MHz")
8590 Print_results("Integrity indicator = ",Integrity2,"")
8600 Print_results("Test 2 @ "&VAL$(Ior2)&" dBm:",Test2,"dBm/1.23 MHz")
8610 Print_results("Integrity indicator = ",Integrity1,"")
8620 Print_results("Test 3 @ "&VAL$(Ior3)&" dBm:",Test3,"dBm/1.23 MHz")
8630 PRINT
8640 Print_title("Range of Open Loop Power Test Complete")
8650 PRINT
8660 PRINT
8670 !
8680 !***Post test clean up***
8690 !
8700 OUTPUT Testset;"CALL:CONNECTED:LIMIT:STATE 0"
8710       ! Turn off call limit mode
8720       ! Must do BEFORE can change probe max sequence
8721 WAIT .5
8730 OUTPUT Testset;"CALL:POW ";Init_cell_power
8740       ! Set Cell Power to default
8750       ! Do this before reconfiguring other parms so signaling
8760       ! is successful (don't want cell power too low for signaling)
8770 OUTPUT Testset;"CALL:APAR:PREAMBLE:LENGTH 7"
8780       ! Set preamble length in frames
8790 OUTPUT Testset;"CALL:APAR:PROBE:IADJUST 0"
8800       ! Set Probe Initial Adjust
8810 OUTPUT Testset;"CALL:APAR:PROBE:STEP:COUNT 3"
8820       ! Set Probe Num Steps
8850 OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP 3"
8860       ! Set Probe Step
8861       !OUTPUT Testset;"CALL:APAR:PROBE:SEQUENCE 1"
8862       ! Set Probe Sequence Max.It requires session negotiation.
8863       !WAIT 20
8870 !
8880 OUTPUT Testset;"INIT:CAPP:OFF"
8890       ! Set access probe power meas off
8900 DISP ""
8910 !
8920 RETURN
8930 !
8940  Time_resp_olp:!
8950 !*******************************************************************
8960 ! Subroutine: Time Response of Open Loop Power Control Measurement
8970 !             4.3.2 Time Response of Open Loop Power Control
8980 !*******************************************************************
8990 !
9000 DISP "Testing Time Response of Open Loop Power Control"
9010 !
9020 !***Set up test parameters***
9030 !
9040 Ior=-60                            ! Start Level for test
9050 !
9060 !***Set up measurement parameters***
9070 !
9080 OUTPUT Testset;"SETUP:TROP:TIMEOUT 5"
9090       ! Set TROLPC measurement timeout to 5 s
9100 !
9110 !***Set test conditions***
9130 !
9140 OUTPUT Testset;"CALL:APPLication:DATA:PACKet BIT256"
9141       ! Set R-Data Packet size to 256 bits.
9142 OUTPUT Testset;"CALL:APPLication:DATA:TRANsmission HCAPacity"
9143       ! Set R-Data transmission mode to high capacity.
9144       !OUTPUT Testset;"CALL:MS:T2Pilot:BIT256:HCAPacity:TARGet 3"
9145       ! Set 256 bits high capacity termination target to 4 subframes.
9146       ! It is required only if you've change the test set default value.
9147       ! NOTE:changing this parameter results in a session renegotionation,
9148       ! You should set this parameter prior to a data connection.
9150 OUTPUT Testset;"CALL:APPLICATION:ACKCHANNEL:BFMATTRIBUTE OFF"
9160       ! Turn off ACK Channel Bit Fixed Mode Attribute
9170 OUTPUT Testset;"CALL:APPLICATION:ATDPACKETS 0"
9180       ! Set AT Directed Packets to 0 to disable R-ACK Channel
9190 OUTPUT Testset;"CALL:POW ";Ior
9200       ! Set cell power for Test
9210 WAIT .1
9220       ! Open Loop Time Response settling time after cell power change
9230 !
9240 Print_title("Time Response of Open Loop Power Test Results:")
9250 FOR J=1 TO 4
9260       ! Loop to measure power after 4 step changes in cell power
9270     SELECT J
9280           ! Set step direction for each measurement
9290     CASE 1
9300         Test_number=J
9310         Step$="UP20"
9320     CASE 2
9330         Test_number=J
9340         Step$="DOWN20"
9350     CASE 3
9360         Test_number=J
9370         Step$="DOWN20"
9380     CASE 4
9390         Test_number=J
9400         Step$="UP20"
9410     END SELECT
9420 !
9430 !***Obtain measurement results***
9440 !
9450     OUTPUT Testset;"SETUP:TROP:STEP "&Step$
9460           ! Set step direction for measurement
9470     OUTPUT Testset;"READ:TROP?"
9480           ! Initiate Time Response of Open Loop measurement,
9490           ! which automatically induces step change in direction
9500           ! set by SETUP:TROP:STEP, then fetch results
9510     ENTER Testset;Integrity,Pass_fail
9520 !
9530     SELECT Pass_fail
9540           ! Assign pass/fail results to a string
9550     CASE 0
9560         Pass_fail$="PASS"
9570     CASE 1
9580         Pass_fail$="FAIL"
9590     CASE ELSE
9600         Pass_fail$="ERROR"
9610     END SELECT
9620 !
9630 !***Print measurement results***
9640 !
9650     PRINT
9660     Print_title("Test Number "&VAL$(Test_number))
9670     Print_results("Channel/Band= ",Current_chan,Band$)
9680     Print_results("Integrity indicator = ",Integrity,"")
9690     Print_res_str("Test Result:",Pass_fail$)
9700 !
9710 NEXT J
9720 !
9730 PRINT
9740 Print_title("Time Response of Open Loop Power Test Complete")
9750 PRINT
9760 PRINT
9770 !
9780 !***Post test clean up***
9790 !
9800 OUTPUT Testset;"INIT:TROP:OFF"
9810       ! Turn off measurement
9820 OUTPUT Testset;"CALL:APPLICATION:ACKCHANNEL:BFMATTRIBUTE ON"
9830       ! Turn ACK Channel Bit Fixed Mode Attribute back on
9840 OUTPUT Testset;"CALL:APPLICATION:ATDPACKETS 50"
9850       ! Set AT Directed Packets back to default value of 50%
9860 OUTPUT Testset;"CALL:POW ";Init_cell_power
9870       ! Set cell power back to initial level
9880 DISP ""
9890 !
9900 RETURN
9910 !
9920  Sensitivity:!
9930 !*******************************************************************
9940 ! Subroutine: Packet Error Rate Measurement
9950 !             3.3.1 Receiver Sensitivity
9960 !*******************************************************************
9970 !
9980 DISP "Testing Receiver Sensitivity"
9990 !
10000 !***Set up test parameters***
10010 !
10020 Ior=-105.5                        ! Level for sensitivity test
10030 !
10040 !***Set up measurement parameters***
10050 !
10060 Max_packets=10000                 ! Maximum packets
10061 Conf_limit=95                      ! 95% confidence limit
10070 Per_limit=.5                      ! 0.5% PER requirement
10080 !
10090 OUTPUT Testset;"SETUP:CPERROR:COUNT ";Max_packets
10100       ! Set Maximum Packets for tests
10101 OUTPUT Testset;"SETUP:CPERROR:CONF ";Conf_limit
10102       ! Set Confidence limit
10110 OUTPUT Testset;"SETUP:CPERROR:CONF:REQ ";Per_limit
10120       ! Set PER requirement
10130 OUTPUT Testset;"SETUP:CPERROR:TIMEOUT 10"
10140       ! Set PER measurement timeout to 10 s
10150 !
10160 !***Set test conditions***
10170 !
10180 OUTPUT Testset;"CALL:APPLICATION:ATDPACKETS 50"
10190       ! Set AT Directed Packets to 50%
10200 OUTPUT Testset;"CALL:APPLication:TRAFfic:FORMat 4,1024,2,128"
10210       ! Set F-Traffic Format to DRC value of 2, 1024 bits pkt size,
10211       ! 2 slot duration, 128 chips preamble (307.2 kbps).
10220 OUTPUT Testset;"CALL:POW ";Ior
10230       ! Set Cell Power for Test
10240 WAIT .5
10250       ! Settling time for access terminal power to slew
10260 !
10270 !***Obtain measurement results***
10280 !
10290 OUTPUT Testset;"INITIATE:CPERROR"
10300       ! Initiate a packet error rate measurement
10310 DISP "Measuring PER"
10320 OUTPUT Testset;"FETCh:CPERROR?"
10330       ! Query the test set for packet error rate measurement results
10340 ENTER Testset;Integrity,Per_test,Per_ratio,Per_count,Packets_tested
10350 !
10360 SELECT Per_test
10370       ! Assign pass/fail results to a string
10380 CASE 0
10390    Pass_fail$="PASS"
10400 CASE 1
10410    Pass_fail$="FAIL"
10420 CASE 2
10430    Pass_fail$="MAX PACKETS"
10440 CASE 3
10450    Pass_fail$="UNKNOWN"
10460 END SELECT
10470 !
10480 !***Print measurement results***
10490 !
10500 Print_title("Sensitivity Packet Error Rate Test Results:")
10510 PRINT
10520 Print_results("Channel/Band= ",Current_chan,Band$)
10530 Print_results("Integrity indicator = ",Integrity,"")
10540 Print_res_str("PER Test Results",Pass_fail$)
10550 Print_results("PER Ratio",Per_ratio,"%")
10560 Print_results("PER Errors Count",Per_count,"packets")
10570 Print_results("Packets Tested",Packets_tested,"")
10580 PRINT
10590 Print_title("Sensitivity PER Test Complete")
10600 PRINT
10610 PRINT
10620 !
10630 !***Post test clean up***
10640 !
10650 OUTPUT Testset;"INIT:CPER:OFF"
10660       ! Turn off PER measurement
10670 OUTPUT Testset;"CALL:POW ";Init_cell_power
10680       ! Set cell power back to normal level
10690 DISP ""
10700 !
10710 RETURN
10720 !
10730  Dynamic_range:!
10740 !*******************************************************************
10750 ! Subroutine: Packet Error Rate Measurement
10760 !             3.3.1 Dynamic Range
10770 !*******************************************************************
10780 !
10790 DISP "Testing Dynamic Range"
10800 !
10810 !***Set up test parameters***
10820 !
10830 Ior=-25                            ! Level for dynamic range test
10840 !
10850 !***Set up measurement parameters***
10860 !
10870 Max_packets=10000                 ! Maximum packets
10880 Conf_limit=95                      ! 95% confidence limit
10890 Per_limit=.5                      ! 0.5% PER requirement
10900 !
10910 OUTPUT Testset;"SETUP:CPERROR:COUNT ";Max_packets
10920       ! Set Maximum Packets for tests
10930 OUTPUT Testset;"SETUP:CPERROR:CONF ";Conf_limit
10931       ! Set Confidence limit
10932 OUTPUT Testset;"SETUP:CPERROR:CONF:REQ ";Per_limit
10933       ! Set PER requirement
10940 OUTPUT Testset;"SETUP:CPERROR:TIMEOUT 10"
10950       ! Set PER measurement timeout to 10 s
10960 !
10970 !***Set test conditions***
10980 !
10990 OUTPUT Testset;"CALL:APPLICATION:ATDPACKETS 50"
11000       ! Set AT Directed Packets to 50%
11001       !
11002 FOR I=1 TO 2
11003       ! Loop to set parameters and measure PER for tests 2 and 3
11004 !
11005    IF (I=1) THEN
11006      Data_rate$="4,1024,2,128"
11008             ! Set F-Traffic Format to DRC value of 2, 1024 bits pkt size,
11009             ! 2 slot duration, 128 chips preamble (307.2 kbps) for test 2.
11010      Drate_str$="307.2 kbps"
11011    ELSE
11012      Data_rate$="12,4096,1,64"
11013             ! Set F-Traffic Format to DRC value of 12, 4096 bits pkt size,
11014             ! 1 slot duration, 64 chips preamble (2457.6 kbps) for test 3.
11015      Drate_str$="2457.6 kbps"
11016    END IF
11017           !
11018 OUTPUT Testset;"CALL:APPLication:TRAFfic:FORMat ";Data_rate$
11020       ! Set F-Traffic Format to DRC value of 2, 1024 bits pkt size,
11021       ! 2 slot duration, 128 chips preamble (307.2 kbps).
11022 WAIT .2
11030 OUTPUT Testset;"CALL:POW ";Ior
11040       ! Set Cell Power for Test
11050 WAIT .5
11060       ! Settling time for access terminal power to slew
11070 !
11080 !***Obtain measurement results***
11090 !
11100 OUTPUT Testset;"INITIATE:CPERROR"
11110       ! Initiate a packet error rate measurement
11120 DISP "Measuring PER"
11130 OUTPUT Testset;"FETCh:CPERROR?"
11140       ! Query the test set for packet error rate measurement results
11150 ENTER Testset;Integrity,Per_test,Per_ratio,Per_count,Packets_tested
11160 !
11170 SELECT Per_test
11180       ! Assign pass/fail results to a string
11190 CASE 0
11200    Pass_fail$="PASS"
11210 CASE 1
11220    Pass_fail$="FAIL"
11230 CASE 2
11240    Pass_fail$="MAX PACKETS"
11250 CASE 3
11260    Pass_fail$="UNKNOWN"
11270 END SELECT
11280 !
11290 !***Print measurement results***
11300 !
11310 Print_res_str("Dynamic Range Packet Error Rate Test Results at ",Drate_str$)
11320 PRINT
11330 Print_results("Channel/Band= ",Current_chan,Band$)
11340 Print_results("Integrity indicator = ",Integrity,"")
11350 Print_res_str("PER Test Results",Pass_fail$)
11360 Print_results("PER Ratio",Per_ratio,"%")
11370 Print_results("PER Errors Count",Per_count,"packets")
11380 Print_results("Packets Tested",Packets_tested,"")
11390 PRINT
11400 Print_title("Dynamic Range PER Test Complete")
11410 PRINT
11420 PRINT
11421       !
11422 NEXT I
11430 !
11440 !***Post test clean up***
11450 !
11460 OUTPUT Testset;"INIT:CPER:OFF"
11470       ! Turn off PER measurement
11480 OUTPUT Testset;"CALL:POW ";Init_cell_power
11490       ! Set cell power back to normal level
11491 WAIT .1
11500 DISP ""
11510 !
11520 RETURN
11530 !
11540  Traf_per_awgn:!
11550 !*******************************************************************
11560 ! Subroutine: Packet Error Rate Measurement
11570 !             3.2.1 Demodulation of Forward Traffic Channel in AWGN
11571 !             (The following example is for test 19)
11580 !*******************************************************************
11590 !
11600 DISP "Testing Demod of Traffic Channel in AWGN"
11610 !
11620 !***Set up test parameters***
11630 !
11640 Ior=-55                                     ! Cell power for test
11650 !
11660 !***Set up measurement parameters***
11670 !
11680 Max_packets=10000                           ! Maximum packets
11681 Conf_limit=95                      ! 95% confidence limit
11682 Min_packets=100        !Minimum packets
11690 !
11700 OUTPUT Testset;"SETUP:CPERROR:COUNT ";Max_packets
11710       ! Set MAXIMUM PACKETS for test
11711 OUTPUT Testset;"SETUP:CPERROR:COUNT:MINimum ";Min_packets
11712       ! Set MAXIMUM PACKETS for test
11713 OUTPUT Testset;"SETUP:CPERROR:CONF ";Conf_limit
11714       ! Set Confidence limit
11720 OUTPUT Testset;"SETUP:CPERROR:TIMEOUT 200"
11730       ! Set PER measurement timeout to 200 s
11740 !
11750 !***Set test conditions***
11760 !
11770 OUTPUT Testset;"CALL:APPLICATION:ATDPACKETS 50"
11780       ! Set AT Directed Packets to 50%
11781 OUTPUT Testset;"CALL:APPLICATION:ACKChannel:BFMAttribute OFF"
11782       ! Turn off ACK channel fixed mode attribute
11792 OUTPUT Testset;"CALL:POW ";Ior
11800       ! Set cell power for test
11801 OUTPUT Testset;"CALL:MS:PDRop 32"
11802       ! Set Pilot Drop to -16 dB
11803 WAIT .2
11804 GOSUB Fetap_connect
11805       ! After setting Pilot Drop, connection will be dropped.
11806       ! Must re-establish the FETAP connection
11810 !
11811 !
11820 ! Read test data into array.
11830 ! Values are Ioc (AWGN), F-Traffic Format, and PER requirement for
11840 ! 12 tests (tests 19 to 30) for subtype 2 physical layer.
11870 !RESTORE
11880 !DATA -52.5,"6,512,1,64",1,-49.72,"6,256,1,64",1,-48.07,"6,128,1,64",1
11890 !DATA -43.5,"2,512,8,512",1,-44.0,"3,256,4,256",1,-45.54,"4,128,2,128",1
11900 !DATA -47.07,"1,512,16,1024",1,-44.51,"1,256,16,1024",1,-45.68,"1,128,16,1024",1
11910 !DATA -63.11,"13,5120,2,64",1,-78.44,"14,5120,1,64",1,-75.45,"14,5120,1,64",1
11940 !
11941 !
11942 ! Read test data into array.
11943 ! Values are Ioc (AWGN), F-Traffic Format, and PER requirement for
11944 ! 12 tests (tests 19 to 30) for subtype 2 physical layer.
11945 RESTORE
11946 DATA -52.5,"6,512,1,64",1
11950 READ Awgn_per_data$(*)
11960 !
11970 FOR I=1 TO 1
11980       ! Loop to set parameters and measure PER for 18 tests
11991 !
11992    !IF (I<6 OR I>9) THEN
11993      Max_pkts=16
11994    !ELSE
11995      !Max_pkts=4
11996    !END IF
11997           !
11998    OUTPUT Testset;"CALL:APPLication:TRAFfic:PDURation:MAXimum ";Max_pkts
11999           ! Set Max Forward Packet Duration which may result in
12000           ! effective data rate lower than nominal data rate.
12004    OUTPUT Testset;"SETUP:CPERROR:CONF:REQ "&Awgn_per_data$(I,3)
12005           ! Set CONFIDENCE LIMIT
12010           !
12020    OUTPUT Testset;"CALL:APPLication:TRAFfic:FORMat "&Awgn_per_data$(I,2)
12030           ! Set FETAP data rate
12031    WAIT .5
12040    OUTPUT Testset;"CALL:AWGN:POW "&Awgn_per_data$(I,1)
12050           ! Set AWGN POWER level
12060    WAIT .5
12070 !
12080 !***Obtain measurement results***
12090 !
12100    OUTPUT Testset;"INITIATE:CPERROR"
12110           ! Initiate a packet error rate measurement
12120    DISP "Measuring PER"
12130    OUTPUT Testset;"FETCh:CPERROR?"
12140           ! Query the test set for packet error rate results
12150    ENTER Testset;Integrity,Per_test,Per_ratio,Per_count,Packets_tested
12160 !
12170    SELECT Per_test
12180           ! Assign pass/fail results to a string
12190    CASE 0
12200        Pass_fail$="PASS"
12210    CASE 1
12220        Pass_fail$="FAIL"
12230    CASE 2
12240        Pass_fail$="MAX PACKETS"
12250    CASE 3
12260        Pass_fail$="UNKNOWN"
12270    END SELECT
12280 !
12290 !***Print measurement results***
12300 !
12310    Print_title("Results PER with AWGN, "&Awgn_per_data$(I,2)&" Rate")
12320    PRINT
12330    Print_results("Channel/Band= ",Current_chan,Band$)
12340    Print_results("Integrity indicator = ",Integrity,"")
12350    Print_res_str("PER Test Results",Pass_fail$)
12360    Print_results("PER Ratio",Per_ratio,"%")
12370    Print_results("PER Errors Count",Per_count,"packets")
12380    Print_results("Packets Tested",Packets_tested,"")
12390    PRINT
12391   !
12392 OUTPUT Testset;"CALL:AWGN:POW:STATE OFF"
12393       ! Turn off AWGN
12394 WAIT .2
12400 !
12410 NEXT I
12420 !
12430 Print_title("PER with AWGN Tests Complete")
12440 PRINT
12450 PRINT
12460 !
12470 !***Post test clean up***
12480 !
12501 OUTPUT Testset;"CALL:APPLICATION:ACKChannel:BFMAttribute OFF"
12502       ! Turn ACK channel fixed mode attribute back to on
12510 OUTPUT Testset;"INIT:CPER:OFF"
12520       ! Turn off PER measurement
12530 OUTPUT Testset;"CALL:POW ";Init_cell_power
12540       ! Set cell power back to normal level
12550 DISP ""
12560 !
12570 RETURN
12580 !
12590  Meas_chan_pow:!
12600 !*******************************************************************
12610 ! Subroutine: Measure Channel Power
12620 !             Implements simple ranging in case over/under range
12630 !*******************************************************************
12640 !
12650 FOR I=1 TO 5
12660    OUTPUT Testset;"INITIATE:CPOWER"
12670           ! Initiate a channel power measurement
12680    OUTPUT Testset;"FETCh:CPOWER?"
12690           ! Fetch channel power measurement results
12700    ENTER Testset;Integrity,Channel_power
12710           ! Read Integrity bit and channel power result
12720 !
12730    IF (Integrity=6 OR Integrity=5) AND 30>Channel_power>-80 THEN
12740           ! Measurement out of-range, recover by setting Receiver
12750           ! control to manual and entering measured level as expected
12760           ! level, then measure channel power again.
12770           ! Repeat up to 5 times.
12780        OUTPUT Testset;"RFAN:CONTROL:POWER:AUTO OFF"
12790               ! Set RF Analyzer ranging to manual
12800        OUTPUT Testset;"RFAN:MANUAL:POWER ";INT(Channel_power);" DBM"
12810               ! Set RF Analyzer expected power to measured level
12811        WAIT .5
12820    ELSE
12830        I=5        ! Exits loop if integrity is not under/over range
12840    END IF
12850 !
12860 NEXT I
12870                         !
12880 OUTPUT Testset;"RFANALYZER:CONTROL:POWER:AUTO ON"
12890       ! Return expected power control to auto
12891       WAIT .5
12900 !
12910 RETURN
12920 !
12930  End_connection:               !
12940 !*******************************************************************
12950 ! Subroutine: Close data connection
12960 !*******************************************************************
12970 !
12980 DISP "Closing data connection"
12990 !
13000 OUTPUT Testset;"CALL:DCONNECTED?"
13010       ! Checks connection status
13020 ENTER Testset;Data_stopped
13030 !
13040 IF Data_stopped=0 THEN
13050    DISP "Data connection closed"
13060 !
13070 ELSE
13080    OUTPUT Testset;"CALL:DCONNECTED:TIMEOUT 10"
13090           ! Set connection change detector timeout
13100    OUTPUT Testset;"CALL:DCONNECTED:ARM"
13110           ! Arm the connection state change detector
13120    OUTPUT Testset;"CALL:FUNCTION:DATA:STOP"
13130           ! Close the data connection
13140    OUTPUT Testset;"CALL:DCONNECTED?"
13150           ! Query the data connection status
13160    ENTER Testset;Data_stopped
13170 !
13180    IF Data_stopped=1 THEN
13190        Print_title("Data connection could not be closed")
13200        Print_title("Ending Testing")
13210        GOTO End_program
13220    END IF
13230 !
13240    DISP "Data connection closed"
13250 END IF
13260 !
13270 RETURN
13280 !
13290  Open_rslts_file:!
13300 !*******************************************************************
13310 ! Subroutine: Open text file to save test results to
13320 !             C:\RESULTS\current date\(file name is HID plus current time)
13330 !*******************************************************************
13340 !
13350 Fileopened_flag=0
13360       ! Indicates that a results file is not yet open
13370 Cur_dt$=DATE$(TIMEDATE)
13380 ON ERROR RECOVER Make_dir
13390       ! If error occurs (presumably because the directory doesn't exist),
13400       ! then create directory
13410 MASS STORAGE IS "C:\RESULTS"&"\"&Cur_dt$
13420       ! Sets the current directory
13430 GOTO Skip_create
13440  Make_dir: CREATE DIR "C:\RESULTS"&"\"&Cur_dt$
13441  Skip_create: OFF ERROR
13450  !Returns error handling to the default: "report to user with a pause"
13460 Cur_tm$=TIME$(TIMEDATE)
13470 Cur_tm$[3]="_"&Cur_tm$[4]
13480       ! Replace the ":" in TIME$ to "_"
13490 Cur_tm$[6]="_"&Cur_tm$[7]
13500       ! Replace the ":" in TIME$ to "_"
13510 Result_file$=Hid_dec$[4,11]&" "&Cur_tm$&".txt"
13520       ! Name the result file using HID and current time
13530 CREATE Result_file$,130
13540       ! Create the result file with 130 records
13550 ASSIGN @File TO Result_file$
13560       ! Wherever @File appears, use Result_file$
13570       ! Create data file using hardware ID and current time
13580 COM /File/@File
13590 Fileopened_flag=1
13600       ! Set open file flag to true
13610 RETURN
13620 !
13630  Start_time:!
13640 !*******************************************************************
13650 ! Subroutine: Start Test Time
13660 !*******************************************************************
13670 !
13680 Start_time=TIMEDATE
13690 RETURN
13700 !
13710  End_time:!
13720 !*******************************************************************
13730 ! Subroutine: End Test Time
13740 !*******************************************************************
13750 !
13760 End_time=TIMEDATE
13770 RETURN
13780 !
13790  End_program:!
13800 !*******************************************************************
13810 ! Subroutine: End of all testing clean up
13820 !*******************************************************************
13830 !
13840 GOSUB End_time
13850 Print_title("End of Test")
13860 Print_results("Total Test Time= ",End_time-Start_time," Seconds")
13870 !
13880 !***End connection and return to default call processing settings***
13890 !
13900 OUTPUT Testset;"CALL:POW ";Init_cell_power
13910       ! Set cell power back to normal level
13920 OUTPUT Testset;"CALL:CHAN ";Primary_channel
13930       ! Set Primary RF Channel for selected System Type and Cell Band
13940 !
13950 IF Fileopened_flag THEN ASSIGN @File TO *
13960       ! Close the data file
13970 !
13980 PRINT
13990 PRINT "End of Program"
14000 END
14010 !
14020 !**************************************************************************
14030 ! SUB-PROGRAM SECTION
14040 !**************************************************************************
14050 !
14060  Timeout: SUB Timeout ! Global timeout handler
14070    COM Testset,Result_file$
14080    PRINT
14090    PRINT "Program timed out, check setup"
14100    CLEAR 7
14110    CLEAR Testset
14120    STOP
14130 SUBEND
14140 !
14150  Print_results: SUB Print_results(Name$,Res1,OPTIONAL Units$)
14160    COM Testset,Result_file$
14170    COM /File/Openfile_flag
14180    IF Res1=9.91E+37 THEN
14190        PRINT USING "5X,40A,5X,1D.E,1X,20A";Name$;Res1;Units$
14200        IF Openfile_flag THEN
14210            COM /File/@File
14220            OUTPUT @File USING "5X,40A,5X,1D.E,1X,20A";Name$;Res1;Units$
14230        END IF
14240    ELSE
14250        PRINT USING "5X,40A,5X,M5D.2D,1X,20A";Name$;Res1;Units$
14260        IF Openfile_flag THEN
14270            OUTPUT @File USING "5X,40A,5X,M4D.2D,1X,20A";Name$;Res1;Units$
14280        END IF
14290    END IF
14300 SUBEND
14310 !
14320  Print_res_str: SUB Print_res_str(String_name$,OPTIONAL Results$)
14330    COM Testset,Result_file$
14340    COM /File/Openfile_flag
14350    PRINT USING "5X,40A,5X,20A";String_name$;Results$
14360    IF Openfile_flag THEN
14370        COM /File/@File
14380        OUTPUT @File USING "5X,40A,5X,20A";String_name$;Results$
14390    END IF
14400 SUBEND
14410 !
14420  Print_title: SUB Print_title(Title$)
14430    COM Testset,Result_file$
14440    COM /File/Openfile_flag
14450    PRINT USING "3X,72A";Title$
14460    IF Openfile_flag THEN
14470        COM /File/@File
14480        OUTPUT @File USING "2A,/";" "
14490        OUTPUT @File USING "3X,72A,/";Title$
14500    END IF
14510 SUBEND
14520 !
14530  Connected: DEF FNConnected ! Function to check connected state
14540    COM Testset,Result_file$
14550    OUTPUT Testset;"CALL:DCONNECTED?"
14560           ! Query the connected status
14570    ENTER Testset;Connected
14580    RETURN Connected
14590           ! Function returns 1 for connected, 0 for idle or session open
14600 FNEND
14610 !
14620  Session_check: DEF FNSession_check ! Function to check session open state
14630    COM Testset,Result_file$
14640    OUTPUT Testset;"CALL:SOPEN?"
14650           ! Query the session open state
14660    ENTER Testset;Session_check
14670    RETURN Session_check
14680           ! Function returns 1 for session open, 0 for idle or connected
14690 FNEND

Related Topics

Test Adherence to Standards


Programming a Packet Error Rate (PER) Measurement

Programming a Packet Error Rate (PER) Measurement

The following example is based on an FTAP data connection for subtype 0 physical layer test. The general procedure is also applicable to the test based on an FETAP data connection. See Control Program Examples for the comprehensive test programs.

General Programming Procedure

  1. Prompt the user to connect the access terminal to the test set's front panel RF IN/OUT connector and power it on. Instruct the user that if the access terminal does not automatically open a session, perform whatever actions are necessary to open a session. See Establish a Session from the Access Terminal for more details.
  2. Prompt the user to establish an FTAP data connection. See Step 4: Make a connection for more details.
  3. Set up the PER measurement parameters as needed using the SETup:CPERror commands.
  4. Set AT Directed Packets using the CALL[:CELL]:APPLication:ATDPackets command.
  5. Set cell power as needed using the CALL:POWer command.
  6. Set the FTAP Rate as needed using the CALL[:CELL]:APPLication:FTAProtocol:DRATe command.
  7. Set the AWGN level as needed using the CALL:AWGNoise[:INTernal]:POWer[:SAMPlitude]<[:SELected]|:DIGital856> command.
  8. Initiate the PER measurement using the INITiate:<measurement mnemonic>[:ON] command. The <measurement mnemonic> for the PER measurement is CPERror.
  9. Use the FETCh:CPERror commands to obtain the measurement results. (You can also replace steps 8 and 9 with a single command - READ:CPERror[:ALL]? ).

Programming Example: 3.2.1 Demodulation of Forward Traffic Channel in AWGN

10 ! 3.2.1 Demodulation of Forward Traffic Channel in AWGN,
20 ! This programming example assumes the access terminal
30 ! is connected to the test set and in an FTAP data connection.
40 !
50       Testset=714
60       OPTION BASE 1
70       DIM Awgn_per_data$(18,3)[12]
80        ! Declare array to hold data AWGN PER test
90 !
100       DISP "Testing Demod of Traffic Channel in AWGN"
110 !
120 !***Set up test parameters***
130 !
140       Ior=-55
150       ! Cell power for test
160 !
170 !***Set up measurement parameters***
180 !
190       Max_packets=10000
200       ! Maximum packets
210 !
220       OUTPUT Testset;"SETUP:CPERROR:COUNT ";Max_packets
230       ! Set MAXIMUM PACKETS for test
240       OUTPUT Testset;"SETUP:CPERROR:CONTINUOUS OFF"
250       ! Set measurement to single trigger
260       OUTPUT Testset;"SETUP:CPERROR:TIMEOUT 25"
270       ! Set measurement timeout to 25 s
280 !
290 !***Set test conditions***
300 !
310       OUTPUT Testset;"CALL:APPLICATION:ATDPACKETS 50"
320       ! Set AT Directed Packets to 50%
330       OUTPUT Testset;"CALL:POW ";Ior
340       ! Set cell power for test
341		       OUTPUT Testset;"CALL:MS:PDRop 28"
342       ! Set Pilot Drop to -14 dB
343       GOSUB Ftap_connect
344       ! After setting Pilot Drop, connection will be dropped.
345       ! Must re-establish the FTAP connection using proper sub-routine.
350 !
360 ! Read test data into array.
370 ! Values are Ioc (AWGN), FTAP data rate, and PER requirement for
380 ! 18 tests (C.S0033 tests 6 and 10 are not performed because
390 ! settings are duplicates)
400 !
410       RESTORE
420       DATA -70.4,"S01K2458",1,-68.4,"S01K2458",1,-65.8,"S01K1843",1
430       DATA -65.1,"S01K1843",1,-60.9,"S02K1229",3,-61.0,"S02K1229",.5
440       DATA -58.1,"S02B921600",3,-58.2,"S02B921600",.5,-60.5,"S01K1229",1
450       DATA -55.5,"S02B614400",1,-52.5,"S04B307200",1,-55.6,"S01B614400",5
460       DATA -55.7,"S01B614400",1,-55.8,"S01B614400",.5,-52.5,"S02B307200",1
470       DATA -49.4,"S04B153600",1,-46.4,"S08B76800",1,-43.6,"S16B38400",1
480 !
490       READ Awgn_per_data$(*)
500 !
510       CLEAR SCREEN
520 !
530       FOR I=1 TO 18
540       ! Loop to set parameters and measure PER for 18 tests
550 !
560           OUTPUT Testset;"SETUP:CPERROR:CONF:REQ "&Awgn_per_data$(I,3)
570           ! Set CONFIDENCE LIMIT
580           OUTPUT Testset;"CALL:APPLICATION:FTAP:DRATE "&Awgn_per_data$(I,2)
590           ! Set FTAP data rate
600           OUTPUT Testset;"CALL:AWGN:POW "&Awgn_per_data$(I,1)
610           ! Set AWGN POWER level
620           WAIT .1
630 !
640 !***Obtain measurement results***
650 !
660           OUTPUT Testset;"INITIATE:CPERROR"
670           ! Initiate a packet error rate measurement
680           DISP "Measuring PER"
690           OUTPUT Testset;"FETCh:CPERROR?"
700           ! Query the test set for packet error rate results
710           ENTER Testset;Integrity,Per_test,Per_ratio,Per_count,Packets_tested
720 !
730           SELECT Per_test
740           ! Assign pass/fail results to a string
750           CASE 0
760               Pass_fail$="PASS"
770           CASE 1
780               Pass_fail$="FAIL"
790           CASE 2
800               Pass_fail$="MAX PACKETS"
810           CASE 3
820               Pass_fail$="UNKNOWN"
830           END SELECT
840 !
850 !***Print measurement results***
860 !
870           PRINT
880           PRINT "Results PER with AWGN, "&Awgn_per_data$(I,2)&" Rate"
890           PRINT
900           PRINT "Integrity indicator        = ",Integrity
910           PRINT "PER Test Results           = ",Pass_fail$
920           PRINT "PER Ratio (%)              = ",Per_ratio
930           PRINT "PER Errors Count (Packets) = ",Per_count
940           PRINT "Packets Tested             = ",Packets_tested
950           PRINT
960 !
970       NEXT I
980 !
990       PRINT "PER with AWGN Tests Complete"
1000 !
1010 !***Post test clean up***
1020 !
1030       OUTPUT Testset;"CALL:AWGN:POW:STATE OFF"
1040       ! Turn off AWGN
1050       OUTPUT Testset;"INIT:CPER:OFF"
1060       ! Turn off PER measurement
1070       OUTPUT Testset;"CALL:POW -55"
1080       ! Set cell power back to normal level
1090       DISP ""
1100 !
1110       END

Programming Example: 3.3.1 Receiver Sensitivity

10 ! 3.3.1 Receiver Sensitivity
20 ! This programming example assumes the access terminal
30 ! is connected to the test set and in a 307.2 kbps
40 ! (2-slot version) FTAP data connection.
50 !
60       Testset=714
70 !
80       DISP "Testing Receiver Sensitivity"
90 !
100 !***Set up test parameters***
110 !
120       Ior=-105.5
130       ! Cell power for sensitivity test
140 !
150 !***Set up measurement parameters***
160 !
170       Max_packets=10000
180       ! Maximum packets
190       Conf_limit=.5
200       ! 0.5% confidence limit
210 !
220       OUTPUT Testset;"SETUP:CPERROR:COUNT ";Max_packets
230       ! Set MAXIMUM PACKETS FOR TEST
240       OUTPUT Testset;"SETUP:CPERROR:CONF:REQ ";Conf_limit
250       ! Set CONFIDENCE LIMIT
260       OUTPUT Testset;"SETUP:CPERROR:CONTINUOUS OFF"
270       ! Set measurement to single trigger
280       OUTPUT Testset;"SETUP:CPERROR:TIMEOUT 10"
290       ! Set mesurement timeout to 10 s
300 !
310 !***Set test conditions***
320 !
330       OUTPUT Testset;"CALL:APPLICATION:ATDPACKETS 50"
340       ! Set AT Directed Packets to 50%
350       OUTPUT Testset;"CALL:POW ";Ior
360       ! Set Cell Power for Test
370       WAIT .5
380       ! Settling time for access terminal power to slew
390 !
400 !***Obtain measurement results***
410 !
420       OUTPUT Testset;"INITIATE:CPERROR"
430       ! Initiate a packet error rate measurement
440       DISP "Measuring PER"
450       OUTPUT Testset;"FETCh:CPERROR?"
460       ! Query the test set for packet error rate measurement results
470       ENTER Testset;Integrity,Per_test,Per_ratio,Per_count,Packets_tested
480 !
490       SELECT Per_test
500       ! Assign pass/fail results to a string
510       CASE 0
520           Pass_fail$="PASS"
530       CASE 1
540           Pass_fail$="FAIL"
550       CASE 2
560           Pass_fail$="MAX PACKETS"
570       CASE 3
580           Pass_fail$="UNKNOWN"
590       END SELECT
600 !
610 !***Print measurement results***
620 !
630       CLEAR SCREEN
640       PRINT "Sensitivity Test Results:"
650       PRINT
660       PRINT "Integrity Indicator       = ",Integrity
670       PRINT "PER Test Result           = ",Pass_fail$
680       PRINT "PER Ratio (%)             = ",Per_ratio
690       PRINT "PER Error Count (Packets) = ",Per_count
700       PRINT "Packets Tested            = ",Packets_tested
710       PRINT
720       PRINT "Sensitivity Test complete"
730 !
740 !***Post test clean up***
750 !
760       OUTPUT Testset;"INIT:CPER:OFF"
770       ! Turn off PER measurement
780       OUTPUT Testset;"CALL:POW -55"
790       ! Set cell power back to normal level
800       DISP ""
810 !
820       END

Programming Example: 3.3.1 Dynamic Range

10 ! 3.3.1 Dynamic Range
20 ! This programming example assumes the access terminal
30 ! is connected to the test set and in a 2457.6 kbps
40 ! (1-slot version) FTAP data connection.
50 !
60       Testset=714
70 !
80       DISP "Testing Dynamic Range"
90 !
100 !***Set up test parameters***
110 !
120       Ior=-25
130       ! Level for dynamic range test
140 !
150 !***Set up measurement parameters***
160 !
170       Max_packets=10000
180       ! Maximum packets
190       Conf_limit=.5
200       ! 0.5% confidence limit
210 !
220       OUTPUT Testset;"SETUP:CPERROR:COUNT ";Max_packets
230       ! Set MAXIMUM PACKETS FOR TEST
240       OUTPUT Testset;"SETUP:CPERROR:CONF:REQ ";Conf_limit
250       ! Set CONFIDENCE LIMIT
260       OUTPUT Testset;"SETUP:CPERROR:CONTINUOUS OFF"
270       ! Set measurement to single trigger
280       OUTPUT Testset;"SETUP:CPERROR:TIMEOUT 10"
290       ! Set measurement timeout to 10 s
300 !
310 !***Set test conditions***
320 !
330       OUTPUT Testset;"CALL:APPLICATION:ATDPACKETS 50"
340       ! Set AT Directed Packets to 50%
350       OUTPUT Testset;"CALL:POW ";Ior
360       ! Set Cell Power for Test
370       WAIT .5
380       ! Settling time for access terminal power to slew
390 !
400 !***Obtain measurement results***
410 !
420       OUTPUT Testset;"INITIATE:CPERROR"
430       ! Initiate a packet error rate measurement
440       DISP "Measuring PER"
450       OUTPUT Testset;"FETCh:CPERROR?"
460       ! Query the test set for packet error rate measurement results
470       ENTER Testset;Integrity,Per_test,Per_ratio,Per_count,Packets_tested
480 !
490       SELECT Per_test
500       ! Assign pass/fail results to a string
510       CASE 0
520           Pass_fail$="PASS"
530       CASE 1
540           Pass_fail$="FAIL"
550       CASE 2
560           Pass_fail$="MAX PACKETS"
570       CASE 3
580           Pass_fail$="UNKNOWN"
590       END SELECT
600 !
610 !***Print measurement results***
620 !
630       CLEAR SCREEN
640       PRINT "Dynamic Range Test Results:"
650       PRINT
660       PRINT "Integrity Indicator        = ",Integrity
670       PRINT "PER Test Results           = ",Pass_fail$
680       PRINT "PER Ratio (%)              = ",Per_ratio
690       PRINT "PER Errors Count (Packets) = ",Per_count
700       PRINT "Packets Tested             = ",Packets_tested
710       PRINT
720       PRINT "Dynamic Range Test complete"
730 !
740 !***Post test clean up***
750 !
760       OUTPUT Testset;"INIT:CPER:OFF"
770       ! Turn off PER measurement
780       OUTPUT Testset;"CALL:POW -55"
790       ! Set cell power back to normal level
800       DISP ""
810 !
820       END

Related Topics

Packet Error Rate (PER) Measurement Description

Manual Operation: Measuring Packet Error Rate (PER)

Packet Error Rate Measurement Troubleshooting

3.2.1 Demodulation of Forward Traffic Channel in AWGN

3.3.1 Receiver Sensitivity and Dynamic Range

Programming: Getting Started Guide for 1xEV-DO Terminal Test


Programming a Channel Power Measurement

Programming a Channel Power Measurement

The following example is based on an RTAP data connection for subtype 0 physical layer test. The general procedure is also applicable to the test based on an RETAP data connection. See Control Program Examples for the comprehensive test programs.

General Programming Procedure

  1. Prompt the user to connect the access terminal to the test set's front panel RF IN/OUT connector and power it on. Instruct the user that if the access terminal does not automatically open a session, perform whatever actions are necessary to open a session. See Establish a Session from the Access Terminal for more details.
  2. Prompt the user to establish an RTAP data connection. See Step 4: Make a connection for more details.
  3. If you will be measuring very low access terminal power levels, turn the Call Drop Timer off to prevent dropping the connection, using the CALL:CONNected:DROP:TIMer[:STATe]<[:SELected]|:TA856> command.
  4. Set up the channel power measurement parameters as needed using the SETup:CPOWer commands.
  5. Set cell power as needed using the CALL:POWer command.
  6. Set the Reverse Closed Loop Power Control mode as needed using the CALL[:CELL[1]]:CLPControl:REVerse:MODE<[:SELected]|:TA856> command.
  7. Initiate the channel power measurement using the INITiate:<measurement mnemonic>[:ON] command. The <measurement mnemonic> for the channel power measurement is CPOWer.
  8. Use the FETCh:CPOWer commands to obtain the measurement results. (You can also replace steps 7 and 8 with a single command - READ:CPOWer[:ALL]? ).

Programming Example: 4.3.5 Minimum Controlled Output Power

10 ! 4.3.5 Minimum Controlled Output Power
20 ! This programming example assumes the access terminal
30 ! is connected to the test set and in a 9.6 kbps
40 ! RTAP data connection.
50 !
60       Testset=714
70 !
80       DISP "Measuring Minimum Power"
90 !
100 !***Set up test parameters***
110 !
120       Ior=-25
130       ! Cell power for test
140 !
150       OUTPUT Testset;"CALL:CONNECTED:DROP:TIMER:STATE 0"
160       ! Turn the call drop timer off
170 !
180 !***Set up measurement parameters***
190 !
200       OUTPUT Testset;"SETUP:CPOWER:CONTINUOUS OFF"
210       ! Set measurement to single trigger
220       OUTPUT Testset;"SETUP:CPOWER:TIMEOUT .5"
230       ! Set Channel Power timeout to 0.5 sec
240 !
250 !***Set test conditions***
260 !
270       OUTPUT Testset;"CALL:POW ";Ior
280       ! Set cell power for test
290       OUTPUT Testset;"CALL:CLPCONTROL:REVERSE:MODE DOWN"
300       ! Start transmission of All Down (1) power control bits
310       WAIT 1
320       ! Settling time for mobile output power to slew down
330 !
340 !***INITiate and FETCh measurements***
350 !
360       OUTPUT Testset;"INITIATE:CPOWER"
370       ! Initiate a channel power measurement
380       OUTPUT Testset;"FETCh:CPOWER?"
390       ! Fetch channel power measurement results
400       ENTER Testset;Integrity,Channel_power
410       ! Read Integrity bit and channel power result
420 !
430 !***Print measurement results***
440 !
450       CLEAR SCREEN
460       PRINT "Minimum Power Test Results:"
470       PRINT
480       PRINT "Integrity Indicator          = ",Integrity
490       PRINT "Minimum Power (dBm/1.23 MHz) = ",Channel_power
500       PRINT
510       PRINT "Minimum Controlled Output Power Test Complete"
520 !
530 !***Post test clean up***
540 !
550       OUTPUT Testset;"CALL:CLPCONTROL:REVERSE:MODE ACTIVE"
560       ! Return to active power control bits
570       OUTPUT Testset;"CALL:POW -55"
580       ! Set cell power back to initial level
590       OUTPUT Testset;"CALL:CONNECTED:DROP:TIMER:STATE 1"
600       ! Return call drop timer to ON
610       OUTPUT Testset;"INIT:CPOW:OFF"
620       ! Turn channel power off
630       DISP ""
640 !
650       END

Related Topics

Channel Power Measurement Description

Manual Operation: Measuring Channel Power


Programming a Tx Spurious Emissions Measurement

Programming a Tx Spurious Emissions Measurement

Last updated May 24, 2006

The following example is based on an RTAP data connection for subtype 0 physical layer test. The general procedure is also applicable to the test based on an RETAP data connection. See Control Program Examples for the comprehensive test programs.

General Programming Procedure

  1. Prompt the user to connect the access terminal to the test set's front panel RF IN/OUT connector and power it on. Instruct the user that if the access terminal does not automatically open a session, perform whatever actions are necessary to open a session. See Establish a Session from the Access Terminal for more details.
  2. Prompt the user to establish an RTAP data connection. See Step 4: Make a connection for more details.
  3. Set up the access parameters as needed using the CALL:APARameter commands.
  4. Set up the TX spurious emissions measurement parameters as needed using the SETup:CTXSpurious commands.
  5. Set cell power as needed using the CALL:POWer command.
  6. Set the Reverse Closed Loop Power Control mode as needed using the CALL[:CELL[1]]:CLPControl:REVerse:MODE<[:SELected]|:TA856> command.
  7. Initiate the TX spurious emissions measurement using the INITiate:<measurement mnemonic>[:ON] command. The <measurement mnemonic> for the TX spurious emissions measurement is CTXSpurious.
  8. Use the FETCh:CTXSpurious commands to obtain the measurement results. (You can also replace steps 7 and 8 with a single command - READ:CTXS purious[:ALL]? ).

Programming Example: 4.4.1 Conducted Spurious Emissions

10 ! 4.4.1 Conducted Spurious Emissions
20 ! This programming example assumes the access terminal
30 ! is connected to the test set and in a 153.6 kbps
40 ! RTAP data connection.
50 !
60       Testset=714
70 !
80       DISP "Measuring TX Spurious Emissions"
90 !
100 !***Set up test parameters***
110 !
120       Ior=-60
130       ! Set cell power for test
140       Ol_adjust=84
150       ! Set Open Loop Adjust for Band Class 4
160 !
170       OUTPUT Testset;"CALL:APAR:POWER:OLADJUST ";Ol_adjust
180       ! Set Open Loop Adjust
190       OUTPUT Testset;"CALL:APAR:PROBE:IADJUST 15"
200       ! Set Probe Initial Adjust
210       OUTPUT Testset;"CALL:APAR:PROBE:STEP:COUNT 15"
220       ! Set Probe Num Steps
230       !OUTPUT Testset;"CALL:APAR:PROBE:SEQUENCE 15"
240       ! Set Probe Sequence Max - this parameter setting is required
250       ! by C.S0033 but does not affect test results. It is a legacy
260       ! parameter setting from IS-98. Changing this parameter drops
270       ! the connection, as required by C.S0024. It is recommended not
280       ! to send this command.
290       OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP 7.5"
300       ! Set Probe Step
310 !
320 !***Set up measurement parameters***
330 !
340       OUTPUT Testset;"SETUP:CTXSPURIOUS:CONTINUOUS OFF"
350       ! Set measurement to single trigger
360       OUTPUT Testset;"SETUP:CTXS:TIMEOUT 5"
370       ! Set TX Spur Emissions timeout to 5 sec
380 !
390 !***Set test conditions***
400 !
410       OUTPUT Testset;"CALL:POW ";Ior
420       ! Set Cell Power for Test
430       OUTPUT Testset;"CALL:CLPCONTROL:REVERSE:MODE UP"
440       ! Start transmission of All Up (0) power control bits
450       WAIT 1
460       ! Settling time to allow mobile power to slew up to maximum power
470 !
480 !***Obtain measurement results***
490 !
500       OUTPUT Testset;"INITIATE:CTXS"
510       ! Initiate TX spurious emissions measurement
520 !
530       OUTPUT Testset;"FETCH:CTXS?"
540       ! Fetch TX spurious emissions results
550       ENTER Testset;Ctxs_integ,Ctxs_pf,Low_adj,Upp_adj,Low_alt,Upp_alt
560 !
570       SELECT Ctxs_pf
580       ! Assign CTXS pass/fail results to a string
590       CASE 0
600           Pass_fail$="PASS"
610       CASE 1
620           Pass_fail$="FAIL"
630       END SELECT
640 !
650 !***Print TX Spurious Test Results
660 !
670       CLEAR SCREEN
680       PRINT "TX Spurious Emissions Test Results:"
690       PRINT
700       PRINT "Integrity Indicator               = ",Integrity
710       PRINT "TX Spurious Emissions Test Result = ",Pass_fail$
720       PRINT "Lower Adjacent Power (dBc)        = ",Low_adj
730       PRINT "Upper Adjacent Power (dBc)        = ",Upp_adj
740       PRINT "Lower Alternate Power (dBc)       = ",Low_alt
750       PRINT "Upper Alternate Power (dBc)       = ",Upp_alt
760       PRINT
770       PRINT "TX Spurious Emissions Test Complete"
780 !
790 !***Post test clean up***
800 !
810       OUTPUT Testset;"CALL:CLPCONTROL:REVERSE:MODE ACTIVE"
820       ! Return to active power control bits
830       OUTPUT Testset;"CALL:POW -55"
840       ! Set cell power back to initial level
850       ! Do this before reconfiguring other parms so signaling
860       OUTPUT Testset;"CALL:APAR:PROBE:IADJUST 0"
870       ! Set Access parameters for test
880       OUTPUT Testset;"CALL:APAR:PROBE:STEP:COUNT 5"
890       ! Set Access paramters for test
900       !OUTPUT Testset;"CALL:APAR:PROBE:SEQUENCE 1"
910       ! Set Access paramters for test (not necessary if commented
920       ! out command before test)
930       OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP 1"
940       ! Set Access paramters for test
950       OUTPUT Testset;"INIT:CTXS:OFF"
960       ! Turn TX spurious emissions off
970       DISP ""
980 !
990       END

Related Topics

TX Spurious Emissions Measurement Description

Manual Operation: Measuring TX Spurious Emissions


Programming a Digital Average Power Measurement

Programming a Digital Average Power Measurement

The following example is based on an RTAP data connection for subtype 0 physical layer test. The general procedure is also applicable to the test based on an RETAP data connection. See Control Program Examples for the comprehensive test programs.

General Programming Procedure

  1. Prompt the user to connect the access terminal to the test set's front panel RF IN/OUT connector and power it on. Instruct the user that if the access terminal does not automatically open a session, perform whatever actions are necessary to open a session. See Establish a Session from the Access Terminal for more details.
  2. Prompt the user to establish an RTAP data connection. See Step 4: Make a connection for more details.
  3. Set up the access parameters as needed using the CALL:APARameter commands.
  4. Set up the digital average power measurement parameters as needed using the SETup:DAPower commands.
  5. Set cell power as needed using the CALL:POWer command.
  6. Set the Reverse Closed Loop Power Control mode as needed using the CALL[:CELL[1]]:CLPControl:REVerse:MODE<[:SELected]|:TA856> command.
  7. Initiate the digital average power measurement using the INITiate:<measurement mnemonic>[:ON] command. The <measurement mnemonic> for the digital average power measurement is DAPower.
  8. Use the FETCh:DAPower commands to obtain the measurement results. (You can also replace steps 7 and 8 with a single command - READ:DAPower[:ALL]? ).

Programming Example: 4.3.4 Maximum RF Output Power

10 ! 4.3.4 Maximum RF Output Power
20 ! This programming example assumes the access terminal
30 ! is connected to the test set and in a 153.6 kbps
40 ! RTAP data connection.
50 !
60       Testset=714
70 !
80       DISP "Measuring Maximum Power"
90 !
100 !***Set up test parameters***
110 !
120       Ior=-60
130       ! Set cell power for test
140       Ol_adjust=84
150       ! Set Open Loop Adjust for Band Class 4
160 !
170       OUTPUT Testset;"CALL:APAR:POWER:OLADJUST ";Ol_adjust
180       ! Set Open Loop Adjust
190       OUTPUT Testset;"CALL:APAR:PROBE:IADJUST 15"
200       ! Set Probe Initial Adjust
210       OUTPUT Testset;"CALL:APAR:PROBE:STEP:COUNT 15"
220       ! Set Probe Num Steps
230       !OUTPUT Testset;"CALL:APAR:PROBE:SEQUENCE 15"
240       ! Set Probe Sequence Max - this parameter setting is required
250       ! by C.S0033 but does not affect test results. It is a legacy
260       ! parameter setting from IS-98. Changing this parameter drops
270       ! the connection, as required by C.S0024. It is recommended not
280       ! to send this command.
290       OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP 7.5"
300       ! Set Probe Step
310 !
320 !***Set up measurement parameters***
330 !
340       OUTPUT Testset;"SETUP:DAPOWER:CONTINUOUS OFF"
350       ! Set measurement to single trigger
360       OUTPUT Testset;"SETUP:DAPOWER:TIMEOUT 1"
370       ! Set DIGITAL Power timeout to 1 sec
380 !
390 !***Set test conditions***
400 !
410       OUTPUT Testset;"CALL:POW ";Ior
420       ! Set Cell Power for Test
430       OUTPUT Testset;"CALL:CLPCONTROL:REVERSE:MODE UP"
440       ! Start transmission of All Up (0) power control bits
450       WAIT 1
460       ! Settling time to allow mobile power to slew up to maximum power
470 !
480 !***Obtain measurement results***
490 !
500       OUTPUT Testset;"INITIATE:DAPOWER"
510       ! Initiate digital average power measurement
520 !
530       OUTPUT Testset;"FETCh:DAPOWER?"
540       ! Fetch the digital average power measurement results
550       ENTER Testset;Integrity,Avg_power_dbm
560 !
570       Avg_power_dbw=Avg_power_dbm-30
580       ! Convert dBm to dBW
590 !
600 !***Print Max Power Test Results***
610 !
620       CLEAR SCREEN
630       PRINT "Max Power Test Results:"
640       PRINT
650       PRINT "Integrity Indicator = ",Integrity
660       PRINT "Maximum Power (dBm) = ",Avg_power_dbm
670       PRINT "Maximum Power (dBW) = ",Avg_power_dbw
680       PRINT
690       PRINT "Maximum Output Power Test Complete"
700 !
710 !***Post test clean up***
720 !
730       OUTPUT Testset;"CALL:CLPCONTROL:REVERSE:MODE ACTIVE"
740       ! Return to active power control bits
750       OUTPUT Testset;"CALL:POW -55"
760       ! Set cell power back to initial level
770       ! Do this before reconfiguring other parms so signaling
780       OUTPUT Testset;"CALL:APAR:PROBE:IADJUST 0"
790       ! Set Access parameters for test
800       OUTPUT Testset;"CALL:APAR:PROBE:STEP:COUNT 5"
810       ! Set Access parameters for test
820       !OUTPUT Testset;"CALL:APAR:PROBE:SEQUENCE 1"
830       ! Set Access parameters for test (not necessary if commented
840       ! out command before test)
850       OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP 1"
860       ! Set Access paramters for test
870       OUTPUT Testset;"INIT:DAP:OFF"
880       ! Turn digital ave power off
890       DISP ""
900 !
910       END

Related Topics

Digital Average Power Measurement Description

Manual Operation: Measuring Digital Average Power


Programming a Waveform Quality/Code Domain Measurement

Programming a Waveform Quality/Code Domain Measurement

The following example is based on an RTAP data connection for subtype 0 physical layer test. The general procedure is also applicable to the subtype 2 physical layer test based on an RETAP data connection. Note that more measurement results are available for new reverse channels of Release A subtype 2 physical layer. See Control Program Examples for the comprehensive test programs.

General Procedure

  1. Prompt the user to connect the access terminal to the test set's front panel RF IN/OUT connector and power it on. Instruct the user that if the access terminal does not automatically open a session, perform whatever actions are necessary to open a session. See Establish a Session from the Access Terminal for more details.
  2. Prompt the user to establish an RTAP data connection. See Step 4: Make a connection for more details.
  3. Set up the waveform quality + code domain measurement parameters as needed using the SETup:DOWQuality commands. See Waveform Quality + Code Domain Measurement Parameters for information on setting slots to measure to the proper value for your test.
  4. Set cell power as needed using the CALL:POWer command.
  5. Initiate the waveform quality + code domain power measurement using the INITiate:<measurement mnemonic>[:ON] command. The <measurement mnemonic> for the waveform quality + code domain measurement is DOWQuality.
  6. Use the FETCh:DOWQuality commands to obtain the measurement results. (You can also replace steps 5 and 6 with a single command - READ:DOWQuality[:ALL]? ).

Programming Example

10 ! 4.2.2 Waveform Quality and Frequency Accuracy
20 ! This programming example assumes the access terminal
30 ! is connected to the test set and in a 9.6 kbps
40 ! RTAP data connection.
50 !
60       Testset=714
70 !
80       DISP "Measuring Waveform Quality"
90 !
100 !***Set up test parameters***
110 !
120       Ior=-75
130       ! Cell power for test
140 !
150       OUTPUT Testset;"CALL:POW ";Ior
160       ! Set cell power
170 !
180 !***Set up measurement parameters***
190 !
200       OUTPUT Testset;"SETUP:DOWQUALITY:CONTINUOUS OFF"
210       ! Set measurement to single trigger
220       OUTPUT Testset;"SETUP:DOWQ:TIMEOUT 10"
230       ! Set waveform quality measurement timeout to 10 seconds
240       OUTPUT Testset;"SETUP:DOWQ:SLOT:COUNT 1"
250       ! Set slots to measure to 1
260 !
270 !***INITiate and FETCh measurement results***
280 !
290       OUTPUT Testset;"INITIATE:DOWQUALITY"
300       ! Initiate a waveform quality + code domain measurement
310       OUTPUT Testset;"FETCh:DOWQUALITY?"
320       ! Query the test set for waveform quality measurement results
330       ENTER Testset;Integrity,Rho,F_err,T_err,C_feed,P_err,M_err,Evm
340 !
350 !***Print Waveform Quality results***
360 !
370       CLEAR SCREEN
380       PRINT "Waveform Quality Test Results:"
390       PRINT
400       PRINT "Integrity Indicator       = ",Integrity
410       PRINT "Rho                       = ",Rho
420       PRINT "Frequency Error (Hz)      = ",F_err
430       PRINT "Time Error (s)            = ",T_err
440       PRINT "Carrier Feedthrough (dBc) = ",C_feed
450       PRINT "Phase Error (degrees)     = ",P_err
460       PRINT "Magnitude Error (%)       = ",M_err
470       PRINT "EVM (%)                   = ",Evm
480       PRINT
490       PRINT "Waveform Quality Test Complete"
500 !
510 !***Post test clean up***
520 !
530       OUTPUT Testset;"INIT:DOWQ:OFF"
540       OUTPUT Testset;"CALL:POW -55"
550       ! Set cell power back to initial level
560       DISP ""
570 !
580       END

Related Topics

Waveform Quality + Code Domain Measurement Description

Manual Operation: Measuring Waveform Quality + Code Domain Power


Programming a TX Dynamic Power Measurement

Programming a TX Dynamic Power Measurement

This section provides an example of how to make a TX dynamic power measurement via GPIB.

The following program example assumes that the access terminal (AT) is connected to the test set's RF IN/OUT connector.

Since the measurement is expected to be used only when data connection status is Idle, no data connection is needed.

The basic procedure to measure TX dynamic power is as follows:

  1. Set the test set's receiver to the proper power and frequency using the RFANalyzer:CONTrol:POWer:AUTO , RFANalyzer:MANual:POWer<[:SELected]|:DIGital856> and RFANalyzer:MANual:MEASurement[:MFRequency] commands.
  2. Set the TX dynamic power setup parameters to match your AT's power sequence using the SETup:CTDPower commands.
  3. Place your AT into the test mode required for performing TX dynamic power and order it to transmit continuously at the initial transmit power level.
  4. Initiate (arm) the TX dynamic power measurement using the INITiate:<measurement mnemonic>[:ON] command.
  5. Using the AT's test mode interface, command your AT to generate the RF rise needed to trigger the measurement.
  6. When the measurement is finished, use the FETCh:CTDPower commands to obtain the measurement results.

NOTE
The buffer size for the measurement results should be set above 1445 characters. If the results are printed in format display, you should assign larger buffer size. See example below.

Programming Example

10       CLEAR SCREEN
20       DIM Dypow_res$[3400]
30       DIM Dynamic_val(200)
40       !
50       !The size of buffer which contains the return value
60       !should be set above 1445. It is suggested to be 1450.
70       !The buffer size is suggested to be set above 3400 if
80       !the results are displayed with print format as shown below.
90       Testset=714
100       !
110       ON TIMEOUT 7,20 CALL Timeout
120       !Calls "Timeout" routine
130       OUTPUT Testset;"SYST:COMM:GPIB:DEB:STAT ON"
140       !Turns GPIB debug state on
150       !
160       PRINT "***Set up measurement parameters***"
170       !
180       OUTPUT Testset;"SETUP:CTDPOWER:TIMEOUT:STIME 20 S"
190       !Sets measurment timeout to 20 seconds
200       !
210       !***Set up measurement parameters***
220       OUTPUT Testset;"RFAN:CONT:POW:AUTO OFF"
230       !Sets the receiver power control to manual mode
240       OUTPUT Testset;"RFAN:MAN:POW:SEL 0 dBm"
250       !Sets the receiver power to the initial power (max power)
260       !at which the AT will transmit.
260       OUTPUT Testset;"RFAN:MAN:MEAS:MFR 851 MHZ"
270       !Sets the frequecy at which the AT will transmit
280       OUTPUT Testset;"SETUP:CTDP:STEP:LEV -1.0 dB"
290       !Set the dynamic power measurement step size to -1.0 dB
300       OUTPUT Testset;"SETUP:CTDP:STEP:COUN 29"
310       !Set the dynamic power measurement number of Steps
320       !to 30.
330       !
340       PRINT "***Arm the TX dynamic power measurement***"
350       OUTPUT Testset;"INITIATE:CTDPOWER:ON"
360       !Initiate TX dynamic power measurement
370       !
380       PRINT "***Command the AT to trigger the measurement***"
390       !This depends upon the design of the AT.
400       !***Obtain measurement results***
410       PRINT "***Obtain measurement results***"
420       OUTPUT Testset;"FETCH:CTDPOWER:COUNT:STEP?"
430       ENTER Testset;Numofstep
440       OUTPUT Testset;"FETCh:CTDPOWER?"
450       ENTER Testset;Integrity,Dypow_res$
460       !***Display measurement results
470       PRINT "Integrity indicator = ";Integrity
480       PRINT "The number of Step = ";Numofstep
490       FOR I=1 TO Numofstep
500         Dynamic_mkr=((I-1)*17)
510         !Set up a marker that will jump to each comma in the ascii string
520         Dynamic_val(I)=VAL(Dypow_res$[Dynamic_mkr+1;Dynamic_mkr+16])
530         !Convert ascii to a numeric value
540         PRINT "Dynamic ";I-1;" measurement is ";Dynamic_val(I);" dBm/1.23 MHz"
550       NEXT I
560      !
570       END
580  Timeout: SUB Timeout            ! Global timeout handler
590         PRINT "Program timed out"
600         CLEAR 7
610         CLEAR 714
620       SUBEND

The measurement results include an integrity indicator followed by power results for AT initial transmit power and each of the successive down steps.

Related Topics

TX Dynamic Power Measurement Description

Manual Operation: Measuring TX Dynamic Power


Dealing With Semicolon Separated Response Data Lists

Dealing With Semicolon Separated Response Data Lists

Description

In accordance with IEEE 488.2-1992 Section 8.4.1 the test set uses the semicolon (;) as the response message unit separator (RMUS). The RMUS separates sequential response message unit elements from one another when multiple response message unit elements are sent in a response message. This condition would occur when combining multiple queries into a single GPIB transaction.

Query Response Data Types Used By Test Set

The test set can return the following data types in response to queries:

  • character data (char): ASCII characters A-Z (65-90 decimal), underscore (95 decimal), digits (48-57 decimal).

  • string data: ASCII characters enclosed in quotes (for example, "5551212" or "PGSM")

  • numeric response data (nr1): numeric data in the form +/- dddddddd

  • numeric response data (nr3): numeric data in the form +/- ddd.ddd E +/- dddd

Semicolon Separated Response Data Lists Containing Mixed Data Types

Problems can occur when trying to enter semicolon separated response data lists containing mixed data types.

For example: If the following command string is sent to the test set, the test set will respond by constructing a response message which contains multiple response message unit elements (that is, one response message unit element for each query item contained in the command string). Some response message unit elements are string data type, some are character data type and some are nr3 data type.

OUTPUT 714;"CALL:MS:REP:IMSI?;PCL?;REV?;SBAN?;ONUM?;MCC?;MNC?;LAC?"

An example response message generated by the test set in response to the above OUTPUT statement would be:

"001012345678901";+4.00000000E+000;PHAS1;"PGSM";"5551212";9.91E37;9.91E37;9.91E37

Constructing the following data entry statement will account for multiple responses from the query:

ENTER 714;Imsi$,Pcl,Rev$,Sban$,Onum$,Mcc,Mnc,Lac

In the Basic programming environment the above ENTER statement will fail with an `Insufficient data for ENTER' error. Some programming languages, Basic for example, cannot use the semicolon character as a data item terminator for string variables. In this example Basic will attempt to enter data into Imsi$ until it sees a LF (line feed) data item terminator. The test set does not send the LF until all the data has been sent. Consequently when Basic sees the LF it terminates entry of data into Imsi$ and starts to look for data to enter into Pcl. Since the test set is no longer sending any data the error message `Insufficient data for ENTER' is generated.

One possible workaround is to enter all the data into a single string variable, replace all semicolons with line feeds and then enter the data from the string into the individual data items. For example:

DIM Response$[500]
!
!
OUTPUT 714;"CALL:MS:REP:IMSI?;PCL?;REV?;SBAN?;ONUM?;MCC?;MNC?;LAC?"
ENTER 714;Response$
Semicolon=POS(Response$,";")
WHILE Semicolon
Response$[Semicolon,Semicolon]=CHR$(10)
Semicolon=POS(Response$,";")
END WHILE
ENTER Response$;Imsi$,Pcl,Rev$,Sban$,Onum$,Mcc,Mnc,La

Semicolon Separated Response Data Lists Containing Only Numeric Data Types

Semicolon separated response data lists containing only numeric data types do not present the types of problem associated with semicolon separated response data lists containing mixed data types. The number building routines in most languages will use any non-numeric character (that is, anything other than +/- 0123456789 E .) as the data item terminator. Consequently when the number building routines encounter the semicolon the data item is terminated. The following example illustrates this:

OUTPUT 714;"FETCH:TXP:INT?;POW:MIN?;MAX?"
ENTER 714;Integrity,Min_power,Max_power


Concurrent Measurements

Concurrent Measurements

Last updated: June 30, 2006

Description

A number of measurements can be initiated (with the INITiate command) while other measurements are being made, and the test set will perform as many operations simultaneously as its architecture allows. This technique is referred to as concurrency. Performing measurements concurrently can greatly improve test throughput.

Operating Considerations

The test set has three parallel signal paths to improve measurement throughput.

  • Demodulation downconverter path.
  • Measurement downconverter path.
  • Power detector path.

Since measurements are DSP (digital signal processor) based, and there are four A/D converters available to digitize or "sample" the input signal for analysis by the DSP, the test set will always have the capability to perform one transmitter measurement, one receiver measurement, and maintain the radio link concurrently. The test set's ability to perform multiple transmitter, or multiple receiver tests concurrently will depend on the availability of resources within the test set and availability of the signal to be tested.

1xEV-DO Terminal Test Application Measurement Concurrency

Measurement Concurrency
Measurement | Concurrency
Transmitter Measurements
Access Probe Power | Not concurrent with any measurements except Digital Average Power. When Access Probe Power is awaiting a probe, all other measurements except Digital Average Power hang.
Channel Power | Concurrent with Packet Error Rate (however, access terminals do not allow concurrent transmitter and receiver measurements, see 1xEV-DO Concurrent Testing Consideration ), Tx Spurious Emissions, Digital Average Power and Waveform Quality + Code Domain Power.
Digital Average Power | Concurrent with Packet Error Rate (however, access terminals do not allow concurrent transmitter and receiver measurements, see 1xEV-DO Concurrent Testing Consideration ), and all other transmitter measurements except TROLPC.
Fast Device Tune | Not concurrent with any measurements. When Fast Device Tune is initiated, the test set turns all other measurements off.
Graphic Access Probe Power ( Lab Application Only ) | Not concurrent with any measurements except Digital Average Power. When Graphic Access Probe Power is awaiting a probe, all other measurements except Digital Average Power hang.
Time Response of Open Loop Power Control (TROLPC) | Not concurrent with any measurements. When TROLPC is initiated, the test set turns all other measurements off.
TX Dynamic Power | Not concurrent with any measurements. When TX Dynamic Power is initiated, the test set turns all other measurements off.
Tx Spurious Emissions | Concurrent with Packet Error Rate (however, access terminals do not allow concurrent transmitter and receiver measurements, see 1xEV-DO Concurrent Testing Consideration ), Channel Power, Digital Average Power and Waveform Quality + Code Domain Power.
Waveform Quality + Code Domain | Concurrent with Packet Error Rate (however, access terminals do not allow concurrent transmitter and receiver measurements, see 1xEV-DO Concurrent Testing Consideration ), Tx Spurious Emissions, Channel Power, and Digital Average Power.
Receiver Measurements
Packet Error Rate | Concurrent with Tx Spurious Emissions, Channel Power, Digital Average Power and Waveform Quality + Code Domain Power (however, access terminals do not allow concurrent transmitter and receiver measurements, see 1xEV-DO Concurrent Testing Consideration ).

Concurrent Testing

In order to be able to perform tests concurrently, the measurements required to perform the test must be concurrent. However, that is not the only requirement to allow concurrent testing - the test conditions required for the tests must also be identical. For example, the test conditions for 4.3.4 Maximum RF Output Power and 4.4.1 Conducted Spurious Emissions are identical, and the measurements required for these tests are concurrent. Thus, these tests can be performed concurrently (see Step 5: INITiate and FETCh Measurements )

1xEV-DO Concurrent Testing Consideration

To perform receiver tests on a 1xEV-DO access terminal, the access terminal must send FTAP or FETAP Loop Back Packets on the Reverse Traffic Channel to indicate whether the test set's FTAP or FETAP Test Packets were successfully received. To perform transmitter tests on a 1xEV-DO access terminal, the access terminal must send RTAP or RETAP Test Packets on the Reverse Traffic Channel. (See C.S0029 Test Application Specification Description (TAP/ETAP) for more details).

Currently, access terminals are not able to send both FTAP or FETAP Loop Back Packets and RTAP or RETAP Test Packets simultaneously. Therefore, although many of the test set's receiver and transmitter measurements are concurrent, 1xEV-DO transmitter and receiver tests can not be performed concurrently.

Related Topics

Block Diagram


Integrity Indicator

Integrity Indicator

Last updated: June 19, 2006

Description

The test set can evaluate its own performance and make a determination as to the validity of a measurement result. The test set evaluates the conditions surrounding a measurement and reports to the user its evaluation of these conditions in a parameter called the measurement integrity indicator. A measurement integrity indicator value is returned for every completed measurement. It is recommended that the user take advantage of this feature in every measurement.

The returned value defines whether or not a problem was encountered by the measurement process. It is not, however, guaranteed to be the only or root cause of the measurement problem. This is because some of the conditions surrounding a measurement may interact, and the test set may have insufficient information to determine the root cause of the measurement problem. However, in most cases, the value returned is the most likely cause of the problem.

Not all of the integrity indicator values are available for each measurement or test application, if a value doesn't apply it will not be available.

Integrity Indicator Values

NOTE
GSM, GPRS and EGPRS measurements return integrity indicators (8, 9, 11) when the measurement synchronization is set to midamble.

Integrity Indicator Number

Integrity Indicator Message

0

Normal: Indicates the measurement completed successfully without error and the result is accurate.

1

No Result Available: Indicates that there is no measurement result and returns NAN (not a number).

2

Measurement Timeout: Indicates that a measurement has timed out. The measurement timeout state must be set to ON.

3

Hardware Not Installed: Indicates that a piece of hardware is not installed in the test set, or the hardware has failed in a way which leads the instrument controller to believe it isn't installed.

4

Hardware Error: Indicates that a hardware failure has occurred. These include failures such as a phase lock loop out-of-lock, defective DSP samplers, or power detectors that can not be calibrated.

5

Over Range: Indicates that the input signal is over range. The amplitude of the device-under test's (DUT's) signal is causing the voltage at a DSP sampler to be above its maximum input level or the frequency is too high or the voltage measured is beyond the maximum voltmeter range, either positive or negative.

6

Under Range: Indicates that the input signal is under range. The amplitude of the DUT's signal is not high enough for the DSP sampler to produce accurate results with the measurement algorithm.

7

Burst Short: Indicates that the burst duration is too short, or part of the burst was not sampled due to improper triggering.

8

Trigger Early or Fall Early: Indicates that the DUT's burst amplitude fell prematurely or, due to an early trigger (early relative to a transmitted burst) the measurement sampling operation terminated before the falling edge of the burst.

9

Trigger Late or Rise Late: Indicates that either the rising edge of the DUT's burst was late or, due to a late trigger (late relative to a transmitted burst) the measurement sampling operation didn't start until after the rising edge of the transmitted burst.

10

Signal Too Noisy: Indicates that the measurement algorithm has found the signal measured to be too noisy to provide accurate results.

11

Sync Not Found: For the GSM/GPRS/EGPRS power versus time measurement, indicates that the midamble was not found therefore the measurement was not synchronized. For the W-CDMA BER and BLER measurements, indicates that the test set has lost synchronization with the UE.

12

Oven Out of Range: Indicates that a temperature controlled oven (other than the internal timebase oven) is outside of its operating range. The power meter's oven is checked and its condition reported with this value. (The internal timebase generates a temporary error message (out of lock) that is sent to the system error queue and the display. This is not an integrity indicator value, it is an error message.)

13

Unidentified Error: Indicates errors which are not covered by the other integrity values. Examples include: parameter errors, algorithm memory errors (too many measurements), measurements unavailable (unable to control), autorange unable to converge, default calibration data used.
14

PCM Full Scale Warning: Indicates that the PCM signal has reached plus or minus full scale. The measurement made will be accurate on the PCM signal but would typically indicate an overdriven or oscillating element in the DUT.
15

Questionable Result for Phase 1 Mobile: Indicates that the user attempted to make an FBER measurement in a phase 1 system. FBER is only possible in a phase 2 GSM system. This indicator is available only when the selected broadcast band is PGSM.

16

Questionable Result:
1. Indicates that the channel mode was NOT set to Full Rate Speech while a Decoded Audio measurement was active. Decoded Audio is only supported for FS Speech.
2. For the cdma2000 lab application, this integrity indicator is used to indicate that the Digital Average Power measurement result is questionable if the reverse channel is in 1/8 rate gated transmission in radio configuration 3 and above or the test set can not determine whether the reverse channel is in gated transmission (for example, while in a voice call).
3. For the GPRS Bit Error and GPRS Block Error measurements, this integrity indicator is returned when the Connection Type is set to an invalid parameter, i.e. SRB Loopback.

17

Can not Correlate: Indicates that the test sets internally generated reference signal does not correlate with the received signal.

Some conditions that could cause this integrity indicator result include the following:

  • an input signal that is corrupted
  • the input signal is extremely distorted
  • the input signal is off by more than 10 ms.
  • the frequency of the input signal deviates more than allowed
  • something is wrong with the long-code mask coming from the mobile ID

18

Frequency Out Of Range: Indicates that a Channel Power Measurement was attempted at a frequency for which there is no calibration data. The test set display will indicate 4 dashes.

19

Uncalibrated Due To Temperature: Indicates that the ambient temperature changes more than 10 degrees C since latest calibration, when attempting a Channel Power Measurement.

20

 Potential Receiver Saturation: Indicates that an input signal immediately prior to the measured input was high enough to potentially saturate the receiver hardware.

21

Parameter Error: Indicates that a measurement setup parameter has been set in a way that gives invalid measurement results.

22

Unsupported Configuration: Indicates that some parameter, other than a measurement setup parameter has been set so that it causes an invalid measurement result. Typically this would be a base station emulator parameter.

23

Call Processing Operation Failed: Indicates that a call processing operation, (base station emulator) needed in the course of making the measurement could not complete.

24

Calibration Error

25

 Burst Not Found
26 | Missing Loopback Packets or AT Buffer Overflow: Indicates that Loopback Packets are missing, or the Access Terminal had an overflow. This integrity indicator was added for the 1xEV-DO Packet Error Rate measurement.

27

No AT Loopback Packets: Indicates that no Loopback Packets from the Access Terminal were detected for a period of several seconds. This integrity indicator was added to provide an early termination criteria for the 1xEV-DO Packet Error Rate measurement.

28

 Questionable MS-to-Cell Data: Indicates that a condition exists on the uplink or reverse channel that has caused the measurement results to be in question. In the case of the WCDMA Loopback BER measurement, an example condition that could cause this integrity indicator would be detection of a CRC error in an uplink transport block.
30 | Trigger Missed: Indicates one or more triggers were missed during the measurement. In the case of the CDMA TX dynamic power measurement, an example condition that may cause this integrity indicator would be GPIB or LAN activities occur during the measurement. This integrity indicator was added to prevent the CDMA TX dynamic power measurement from hanging forever and provide an early termination criteria for the measurement.

31

Dual Measurement Request: Indicates that a request has been received for a measurement type that is already running.

32

Measurement Not Licensed: Indicates that the required feature license for the measurement is not present. See

http://www.agilent.com/find/8960upgrades

for details on hardware and software requirements to run a specific feature.

Example Program

10  OUTPUT 714;"INITiate:DAPower" !Start Digital Average measurement
20  OUTPUT 714;"FETCH:DAPower?" !Request measurement results.
30  ENTER 714;Integrity,Ave_power !Read measurement results.
40  IF Integrity = 0 THEN !Permits measurement to be printed if integrity indicator
50                        !indicates a successful measurement
60  PRINT "Digital Average Power =";Ave_power!if 0 then measurement was successful
70  ELSE
80  PRINT "Measurement integrity questionable, integrity value = ";Integrity !If
90                                                                           !integrity
100                                                                          !not zero
110                                                                          !then print
120                                                                          !integrity
130                                                                          !value.
140 END IF
150 END

Related Topics

Error Messages


Measurement Timeouts

Measurement Timeouts

Description

The primary use of measurement timeouts is to regain control of the test set's GPIB in cases where the bus could potentially "hang."

The time normally required for a measurement to complete may vary greatly depending on the individual measurement, its settings, it's multiple measurement count value, and so forth. Because of this, you may need to set the timeout longer than the default for measurements where a large number of multiple measurements are requested or where measurement triggers may be infrequent.

Be careful when setting a timeout that is shorter than the default. It is possible to specify a timeout that is so short the measurement does not even have a chance to begin. Measurement timeouts should always be at least several seconds long.

Timeout units default to S (seconds). The seconds suffix is an optional part of the command. If you want MS (milliseconds), US (microseconds) or NS (nanoseconds), you must specify these units in the suffix.

Timeout Values

All measurements in the 1xEV-DO Terminal Test Application default to a timeout value of 10 seconds, except PER (see Packet Error Rate (PER) Measurement Description ). The PER measurement timeout default is 267 seconds.

Related Topics

Integrity Indicator


Step 1: Set Up the Test Set

Step 1: Set Up the Test Set

The following information provides additional details on Step 1 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you initialize the test set and set up the general operating conditions.

Contents

  • Initialize the Test Set
  • Set Up General Operating Conditions

Initialize the Test Set

  • Fully Preset the Test Set

    It is important to get the test set to a known state before each production session.

    Sending the *RST command fully presets the test set, which ends all call processing and measurement processes and restores all values to defaults.

  • Clear the Error Queue

    Before each production session, it is useful to clear the error queue of any old messages. That way, you know that any messages logged are relevant to the current production session.

    Sending the *CLS command clears the error queue.

Set Up General Operating Conditions

  • Turn Debugger On

    While developing your code, it is very useful to enable the GPIB debugger using the
    SYST:COMM:GPIB:DEB ON command. When the debugger is on, the test set alerts you when you send an incorrect command, and it also tells you which symbol or letter in the command is incorrect.

NOTE
You should turn the debugger off once you have finished development and your code is stable.

  • Set Operating Mode

    The test set contains a base station emulator (BSE), whose primary purpose is to provide enough call processing to allow parametric measurements of a mobile station's RF signal.

    An important characteristic of the test set's base station emulator is its operating mode. The operating mode sets the way in which the base station emulator interacts with the mobile station.

    Active cell mode is used when emulating a normal cell. Active cell mode allows active signaling between the mobile station and BSE. The mobile station camps to the BSE signal, and an actual call is established.

    In test mode, the mobile station synchronizes to the BSE signal and transmits an appropriate signal which the test set analyzes.

    The test set's operating mode is set using the following command:

    Command to Set the Test Set's Operating Mode

    Command

             Example

    CALL:OPER:MODE <operating mode>

    CALL:OPER:MODE CALL

  • Set Amplitude Offsets

    To achieve accurate measurement results, it is important to account for losses in the cabling and fixturing between the mobile station and test set. You must determine what the losses are for your test setup and then specify the appropriate frequency-dependent amplitude offset values.

    You can specify amplitude offsets for up to 20 frequencies using the following commands:

    Commands to Set Amplitude Offsets

    Command

             Example

    SYST:CORR:FREQ <freq1>, <freq2>, <freq3>

    SYST:CORR:FREQ 800MHz, 1800MHz,
    1900MHz

    SYST:CORR[:SGAin] <offset1>,
    <offset2>, <offset3>

             SYST:CORR -0.7, -1.0, -1.2

  • Set Display Mode

    To achieve a slightly faster test execution speed, you can disable the front panel display on the test set using the DISP:MODE FAST command.


Step 2: Configure Test Set and Mobile Station Parameters

Step 2: Configure Test Set and Mobile Station Parameters

The following information provides additional details on Step 2 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you configure the parameters that allow a connection to be made between the test set and mobile station. This mainly involves setting up channels and power levels.

Contents

  • Set Up Channels
  • Set Cell Power
  • Set Mobile Station Transmit Power
  • Set Up Additional Connection Parameters

Set Up Channels

For many technologies, setting up channels involves specifying the channel associated with every band and channel type (for example, analog or digital), and then setting the active band and channel type. For some technologies, such as W-CDMA, you simply specify the downlink and uplink UARFCNs (channels).

  • Specify Channel Numbers

    All of the test set's test applications can test in more than one frequency band (for example, US Cellular, US PCS, or Korean PCS). To produce the most efficient code, you should configure the channel information for each band in advance. Then, to move to a new band during testing, you only need to send the command to change bands. You do not need to also specify the channel of the new band. This reduces test time.

    To set up the channel number for the various bands, use one of the following commands (depending upon which test application you are using):

    Commands to Set the Channel for a Band

    Command

             Example Technology

    CALL:<channel mnemonic>:<band mnemonic>
    <num value>

    CALL:TCH:EGSM 124

             GSM/GPRS/EGPRS

    CALL:SET:<channel type mnemonic>:<band
    mnemonic> <num value>

    CALL:SET:DTC:PCS 777

             AMPS/136

    CALL:CHAN:<channel type mnemonic>:<band
    mnemonic> <num value>

    CALL:CHAN:DIG2000:K
    PCS 384

             cdma2000/IS-95/AMPS

    This practice also applies to test applications which test both analog and digital channel types. In this case you should specify the channel for the analog and digital channel types in advance. Then, switching between them requires only one command to initiate the change, and not an additional change to specify the channel of the new channel type.

    If you specify channels in advance as described, the only time you need to specify a channel during testing is if you move to a new channel within the same band and channel type.

  • Set Active Band and Mode

    Once you have specified the channel information for each band and channel type, you must set the active band using one of the following commands (depending upon which test application you are using):

    Commands to Set the Active Band

    Command

             Example Technology

    CALL:<channel mnemonic>:BAND <band mnemonic>

    CALL:TCH:BAND
    EGSM

             GSM/GPRS/EGPRS

    CALL:SET:<channel type mnemonic>:BAND <band
    mnemonic>

             CALL:SET:DTC:BAND
    PCS     		AMPS/136
    CALL:BAND:<channel mnemonic> <band mnemonic>

    CALL:BAND:DIG2000
    KPCS

             cdma2000/IS-95/AMPS

    If the test application you are using supports testing of both analog and digital channel types, then you must also set the channel type using the following command:

    Command to Set the Active Channel Type

    Command

             Example

    CALL:<channel mnemonic>:TYPE <channel type
    mnemonic>

    CALL:TCH:TYPE
    DTC

  • Active Cell and Test Mode Considerations

    The function of the CALL commands differ depending upon whether you are in active cell or test mode.

    In active cell mode, when you use the CALL commands to set the channel numbers, the test set's output frequency and receiver frequency are set. A message is also sent to the mobile station to set its frequency.

    However, in test mode, since the BSE does not send call processing information to the mobile station, the CALL commands only configure the test set's output frequency and receiver frequency. You need to also send the appropriate test mode commands to the mobile station to set it to the correct frequency.

    In test mode, instead of using the CALL commands to configure the test set's frequencies, you may prefer to manually control the RF generator and RF analyzer using the CALL:RFG and RFAN commands, respectively. In either case, you must still send the appropriate test mode commands to the mobile station to move it to the proper frequency.

Set Cell Power

To set the output power of the test set, use the following command:

Command to Set Cell Power
Command | Example
CALL:POW <num value> | CALL:POW -75

  • Active Cell and Test Mode Considerations

    You can use the CALL:POW command to set the cell power in both active cell and test mode. However, in test mode you may prefer to manually control the output power of the test set using the CALL:RFG commands.

Set Mobile Station Transmit Power

In active cell mode, use one of the following commands to set the mobile station transmit power level (depending upon which test application you are using):

Commands to Set Mobile Station Transmit Power
Command | Example | Technology
CALL:MS:TXL:<band mnemonic> <num value> | CALL:MS:TXL:DCS <num value> | GSM
CALL:SET:MS:<channel type mnemonic>:TXL:<band mnemonic> <num value> | CALL:SET:MS:DIG:TXL:PCS <num value> | AMPS/136
CALL:<channel mnemonic>:MS:TXL:<band mnemonic>:BURS <num value> | CALL:PDTCH:MS:TXL:DCS: BURS <num value> | GPRS/EGPRS

In addition to setting the mobile station transmit level, these commands also automatically configure the test set's receiver at the expected input level, whether in active cell or test mode. However, in test mode, you must also send the appropriate test mode commands to the mobile station to command it to output at the correct level. This is due to the fact that the BSE is not transmitting call processing commands to the mobile station.

  • Manually Setting Expected Power

    Sending the CALL commands in Commands to Set Mobile Station Transmit Power automatically sets the expected input level of the test set's receiver. However, there is another option for setting the receiver's input level in both active cell and test mode. It is often beneficial to manually set the expected input power level using the RFAN commands, rather than using the CALL commands.

    When you set the expected power manually, you tell the test set exactly what power level to expect. Whereas the CALL commands simply tell the test set the range of input level to expect, based on the definition of the mobile station power level (for example, an AMPS/136 mobile station transmitting at power level 3 has an output level in the range of +20 dBm to +26 dBm).

Set Up Additional Connection Parameters

Depending upon the test application you are using, there may be other connection parameters to specify, such as timeslot, timing advance, vocoder, or data rates and types.

In active cell mode, you may also choose to set up network parameters, such as base station identifier numbers (for example, SID) and color codes.

All of these parameters are configured using the CALL subsystem.


Step 3: Set Measurement Parameters

Step 3: Set Measurement Parameters

The following information provides additional details on Step 3 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you set up the conditions under which the measurements operate. You do this by configuring measurement parameters.

Contents

  • Measurement Parameters Overview
  • Generic Measurement Parameters
  • Measurement-Specific Measurement Parameters

Measurement Parameters Overview

There are two different types of measurement parameters:

  • Generic Measurement Parameters
  • Measurement-Specific Measurement Parameters

The SETup subsystem is used to configure measurement parameters. Each individual measurement parameter can be set and queried using the associated SETup subsystem command. The general hierarchy of the SETup subsystem command structure is as follows:

SETup:<measurement mnemonic>:<measurement parameter> <parameter setting/value>

NOTE
Not all measurements use all measurement parameters. Refer to the GPIB syntax listing for the detailed list of measurement parameters for individual measurements.

Generic Measurement Parameters

There are three types of generic measurement parameters:

  • Measurement Count (used by most measurements)
    Measurement Count State
    Measurement Count Number

  • Measurement Timeout (used by all measurements)
    Measurement Timeout State
    Measurement Timeout Time

  • Measurement Trigger (used by most measurements)
    Trigger Arm (used by all measurements)
    Trigger Source (not applicable to analog measurements)
    Trigger Delay (not applicable to analog measurements)

Measurement Count Parameters

The measurement count parameters control measurement averaging. The STATe command turns averaging on or off, and the NUMBer command determines the number of averages. The SNUMber command is a complex command which allows you to turn averaging on and set the number of averages in one command.

Statistical Measurement Results Parameters
Parameter | Command Syntax
Measurement Count State | SETup:<meas-mnemonic>:COUNt:STATe <ON|1|OFF|0>
Measurement Count Number | SETup:<meas-mnemonic>:COUNt:NUMBer <numeric value>
Measurement Count Number and State | SETup:<meas-mnemonic>:COUNt[:SNUMber] <numeric value>
Programming Example:

OUTPUT Test_set;"SET:DTXP:COUN 10"

sets the multi-measurement count state to ON and set the number of averages to 10 for the digital transmit power measurement.

Measurement Timeout Parameters

Measurement timeout parameters control the maximum time that a measurement executes. TIMe sets the amount of time and STATe determines if the timeout is in use. The STIMe command is a complex command which enables you to set both parameters in one command.

Measurement Timeout Parameters
Parameters | Command Syntax
Measurement Timeout Time and State | SETup:<meas-mnemonic>:TIMeout[:STIMe] <numeric value>[<suffix>]
Measurement Timeout State | SETup:<meas-mnemonic>:TIMeout:STATe <ON|1|OFF|0>
Measurement Timeout Time | SETup:<meas-mnemonic>:TIMeout:TIME <numeric value>[<suffix>]
Programming Example:

OUTPUT Test_set;"SET:DTXP:TIM 10"

sets the measurement timeout state to ON and set the measurement timeout time to 10 seconds for the digital transmit power measurement.

Measurement Trigger Parameters

There are three measurement trigger parameters. They control the arming of a measurement, the source of the trigger, and the trigger's delay.

  • The trigger arm parameter determines whether the test set makes one measurement and then stops (single), or automatically re-arms upon completion of one measurement and repeats the process (continuous). The recommended setting when writing a control program is single (CONTinuous OFF).

  • The trigger source parameter selects the source of the measurement trigger signal. The recommended Trigger Source setting when writing a control program is AUTO.

NOTE
Trigger source is always IMMediate for analog measurements and cannot be changed by the user.

  • The trigger delay parameter controls the delay between the trigger event (the point in time at which the trigger signal is received) and the start of sampling. Negative values indicate that the sampling should occur prior to the trigger event.

NOTE
Trigger delay is not applicable to analog measurements.

Measurement Trigger Parameters
Parameter | Command Syntax
Trigger Arm | SETup:<meas-mnemonic>:CONTinuous <ON|1|OFF|0>
Trigger Source | SETup:<meas-mnemonic>:TRIGger:SOURce <AUTO|IMMediate|PROTocol|RISE>
Trigger Delay | SETup:<meas-mnemonic>:TRIGger:DELay <numeric value>[<suffix>]

NOTE
You can set the Trigger Arm for all measurements to single (CONTinuous OFF) using the following command syntax:

SETup[:ALL]:CONTinuous:OFF

Programming Example:

OUTPUT Test_set;"SET:CONT:OFF"

sets the trigger arm to single for all measurements.

Programming Example:

OUTPUT Test_set;"SET:DTXP:TRIG:SOUR AUTO"

sets the trigger source to AUTO for the digital transmit power measurement.

Programming Example:

OUTPUT Test_set;"SET:DTXP:TRIG:DEL 10 US"

sets the trigger delay to 10 microseconds for the digital transmit power measurement.

Measurement-Specific Measurement Parameters

Measurement-specific measurement parameters set up operating conditions for a specific measurement. For example:

  • Setting the channel power measurement speed in IS-2000
  • Setting ORFS frequency offsets in GPRS
  • Setting number of bits for the FBER measurement in GSM

Refer to the GPIB syntax listing for the detailed list of measurement parameters for individual measurements.

Programming Example:

OUTPUT Test_set;"SET:CPOW:MSP FAST"

sets the IS-2000 channel power measurement speed to fast.

Programming Example:

OUTPUT Test_set;"SET:ORFS:SWIT:FREQ 400 KHZ"

sets the first ORFS offset to 400 kHz.

Programming Example:

OUTPUT Test_set;"SET:FBER:COUN 10000"

sets the number of fast BER bits to test to 10,000 bits.

Program Example Setting Both Generic and Measurement-Specific Measurement Parameters

! Set trigger arm to single for all measurements:
!
OUTPUT Test_set;"SET:CONT:OFF"
!
! *****************************************************
! Configure Modulation Accuracy Measurement:
!
OUTPUT Test_set;"SET:MACC:COUN 5"
! Example of using a complex command to set both the
! measurement count state and number at the same time.
!
OUTPUT Test_set;"SET:MACC:TRIG:SOUR AUTO"
! Sets trigger source to auto.
!
OUTPUT Test_set;"SET:MACC:TIM 15"
! Sets timeout state to ON and time to 15 sec.
!
OUTPUT Test_set;"SET:MACC:EVM10:STAT ON"
! Turns the EVM10 State ON
!
! ******************************************************
! Configure Digital TX Power Measurement:
!
OUTPUT Test_set;"SET:DTXP:COUN 5"
OUTPUT Test_set;"SET:DTXP:TRIG:SOUR AUTO"
OUTPUT Test_set;"SET:DTXP:TIM 5"
!
! ******************************************************
! Configure Frequency Stability Measurement:
!
OUTPUT Test_set;"SET:FST:COUN 3"
OUTPUT Test_set;"SET:FST:TIM 10"
!
! ******************************************************
! Configure Analog TX Power Measurement:
!
OUTPUT Test_set;"SET:ATXP:COUN 5"
OUTPUT Test_set;"SET:ATXP:TRIG:SOUR AUTO"
OUTPUT Test_set;"SET:ATXP:TIM 15"


Step 4: Make Connection

Step 4: Make Connection

The following information provides additional details on Step 4 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you make a connection between the mobile station and test set. How you do this depends upon whether you are in active cell or test mode. In active cell mode you establish a phone call between the test set and mobile station. In test mode, you command the mobile station to synchronize to the test set's signal and begin transmitting back an appropriate signal.

Contents

  • Establish a Call in Active Cell Mode
  • Make a Test Mode Connection

Establish a Call in Active Cell Mode

To test a mobile station in active cell mode, you must first establish a call between the test set and mobile station. Your control program must issue the commands necessary to initiate the call connection process, either to the test set (for a base station originated call) or to the mobile station (for a mobile station originated call). Your control program must then determine when the call has successfully connected so that it can proceed to testing. The control program must also determine if the call has not been successfully connected so that it can take appropriate action.

Call States

At any instant in time a call can be in a stable state such as the idle or the connected state, or in one of many transitory states such as alerting, handoff, registering, releasing or paging. These are referred to as transitory states because the amount of time which the call can spend in any of these states is limited by the mobile station's protocol. The call is not allowed to stay in a transitory state indefinitely.

NOTE
If repeat paging or repeat registration are on, it is possible for the call process to stay in one of the transitory states beyond the time specified by the mobile station's protocol timers.

Call Connection Synchronization Commands

The test set has a set of commands designed specifically for call connection and release synchronization.

Call Connection Synchronization Commands
Synchronization Command | Command Syntax
Call-Connected-State Query | CALL:CONNected[:STATe]?
Call-State-Change Detector Arm | CALL:CONNected:ARM[:IMMediate]
Call-State-Change Detector Timeout | CALL:CONNected:TIMeout

  • Call-Connected-State Query

    The CALL:CONN? query allows the control program to determine if a call is in the connected state or in the idle state.

    Responses Returned by the CALL:CONN? Query
    Response | Meaning
    1 | The call is in the connected state.
    0 | The call is in the idle state.

    If the call is in one of the transitory states, the query waits until the call reaches the idle state or connected state before returning a value.

  • Call-State-Change Detector Arm Command

    The test set has a call-state-change detector which can be used to temporarily hold the response to a CALL:CONN? query until the call state has moved from idle to connected or vice versa.

    Without the call-state-change detector, the CALL:CONN? query only hangs if the call is in a transitory state. Otherwise, it immediately returns a 1 or 0. Therefore, if a call connection process is started and the CALL:CONN? query is sent before the call state has transitioned from idle to one of the transitory states, the query immediately returns a 0. This indicates that the call is in the idle state (and therefore that the connection attempt failed). In reality, the call likely connected, but not until after the CALL:CONN? query immediately returned a 0.

    When the call-state-change detector is armed during a connection attempt, if the CALL:CONN? query is sent while the call state is still idle, the query waits until the state changes to connected, and then returns a 1.

    The CALL:CONNected:ARM[:IMMediate] command is used to arm this call-state-change detector.

  • Call-State-Change Detector Timeout Command

    If the call-state-change detector is armed and a call connection is attempted but the call state never changes from the idle state, the CALL:CONN? query hangs the bus. This easily happens if the mobile is badly broken, the mobile is not connected to the test set, or no one pushes the send button on the mobile.

    The CALL:CONNected:TIMeout command is used to set the timeout value for the call-state-change detector.

    The timeout timer is started whenever the call-state-change detector is armed, and should be set to the maximum amount of time the control program should wait between arming the detector and the beginning of the connection process (when the call state moves from the idle state). If the timer expires before the call state has moved from the idle or connected state, the call-state-change detector is disarmed, which releases the CALL:CONN? query if it is currently hanging.

Process for Making a Base Station Originated Call

Process for Making a Base Station Originated Call

NOTE
It is not necessary for you to send the CALL:CONN:TIM and CALL:CONN:ARM commands as they are automatically sent by the test set during a base station originated call or base station release.

Programming Example

OUTPUT Test_set;"CALL:PAG:PNUM `0000574016'"! Set paging number
OUTPUT Test_set;"CALL:PAG:REP ON" ! Set paging repeat state
OUTPUT Test_set;"CALL:ORIG" ! Start a base station originated call
OUTPUT Test_set;"CALL:CONN?"  ! Hanging GPIB query
ENTER Test_set;Call_connected      ! Program hangs here until
                                   ! origination passes or fails
IF NOT Call_connected THEN
   OUTPUT Test_set;"CALL:END"
! <put error handler here>
END IF
! Call is connected so proceed with control program

Process for Making a Mobile Station Originated Call

Process for Making a Mobile Station Originated Call

NOTE
The test set cannot originate a call from the mobile station. You must physically dial a number on the mobile station and press send, or send commands to a test bus built into the mobile station. For mobile station originated calls where the call is originated by physically dialing a number (as opposed to using a test bus) ensure that the call-state-change detector timeout time is long enough to allow the number to be dialed.

Programming Example

OUTPUT Test_set;"CALL:CONN:TIM 10"         ! Set timeout time to 10 seconds
OUTPUT Test_set;"CALL:CONN:ARM"            ! Arm the change detector
DISP "Initiate a call from the mobile"
OUTPUT Test_set;"CALL:CONN?"          ! Initiate a call connected state query
ENTER Test_set;Call_connected              ! Program hangs here until
                                           ! origination passes or fails
IF NOT Call_connected THEN
   OUTPUT Test_set;"CALL:END"
! <put error handler here>
END IF
! Call is connected.  Proceed with the control program.

Make a Test Mode Connection

To make a connection between the test set and mobile station in test mode, you must send the appropriate test mode commands to the mobile station to command it to synchronize to the test set's signal and begin transmitting.

You may also want to make a quick power measurement to ensure that the connection has been made.


Step 5: INITiate and FETCh Measurements

Step 5: INITiate and FETCh Measurements

The following information provides additional details on Step 5 of the Programming Flowchart. This information is applicable to all test applications.

Description

This step involves making measurements on the mobile station.

The test set has multiple signal paths and processors, which means you can make measurements concurrently and reduce test time. Making concurrent measurements involves starting a group of measurements, fetching the results of the measurements as they complete, and then verifying that the results are valid.

In this step you may also choose to make measurements in a more sequential way.

Contents

  • Concurrent Measurement Process
  • Alternative Measurement Process

Concurrent Measurement Process

Process for Making Concurrent Measurements

Start a Set of Concurrent Measurements

The INITiate command is used to start measurements. Each individual measurement can be started using the INITiate command. For starting measurements, the syntax of the INITiate command is as follows:

INITiate:<measurement mnemonic>[:ON]

More than one measurement can be started using a single INITiate command. For example:

OUTPUT Test_set;"INIT:TXP;PFER"

starts the transmit power measurement and the phase and frequency error measurement. These measurements then run concurrently.

Determine if a Measurement Is Done

Use the INITiate:DONE? query command to determine which measurement has completed.

This command is a query only and returns only one response per query. The responses returned and their meanings are shown in the following table:

Responses Returned from INITiate:DONE? Query
Response String | Meaning
<MEASUREMENT1 mnemonic> | MEASUREMENT1 is done.
<MEASUREMENT2 mnemonic> | MEASUREMENT2 is done.
WAIT | There are one or more measurements that are in progress, but none of those measurements are done yet.
NONE | No measurements are in progress.

Once a measurement is reported as being complete via the INITiate:DONE? query it is removed from the done list (it is not reported again). To use the INITiate:DONE? query properly, your control program should immediately fetch a measurement's results once it is reported as being complete.

Obtain a Set of Measurement Results

In order to minimize bus traffic and reduce test time, the test set's measurements are designed to return multiple measured values in response to a single measurement request.

For example, if a transmit power measurement with averaging is initiated there are five measurement results available. These are:

  1. Measurement integrity value
  2. Average value
  3. Minimum value
  4. Maximum value
  5. Standard deviation value

The test set can return the measurement results in a variety of formats to suit your needs using the FETCh? subsystem. The general structure of the FETCh? command is as follows:

FETCh:<measurement mnemonic>:<result format>?

For example, the transmitter power measurement results can be returned as:

Example FETCh? Result Formats
Command | Results Returned
FETC:TXP? | Measurement integrity and average value
FETC:TXP:POW:ALL? | Minimum, maximum, average and standard deviation values
FETC:TXP:POW:AVER? | Average value only
FETC:TXP:POW:MIN? | Minimum value only
FETC:TXP:POW:MAX? | Maximum value only
FETC:TXP:POW:SDEV? | Standard deviation value only
FETC:TXP:INT? | Measurement integrity value only
Concurrent Measurement Process Programming Example

! Start a Set of Concurrent Measurements:
!
OUTPUT Test_set;"INIT:TXP;PFER"
!
! Determine if a Measurement Is Done:
!
LOOP
  OUTPUT Test_set;"INIT:DONE?"
  ENTER Test_set;Meas_done$
!
! Obtain a Set of Measurement Results:
!
  SELECT Meas_done$
    CASE "TXP"
      OUTPUT Test_set;"FETC:TXP:POW?"
      ENTER Test_set;Avg_tx_power
    CASE "PFER"
      OUTPUT Test_set;"FETC:PFER:RMS?"
      ENTER Test_set;Max_rms_phas_er
  END SELECT
EXIT IF Meas_done$="NONE"
END LOOP

Validate Measurement Results

Validating measurement results is extremely important. The test set returns a result if it is capable of making a measurement, even if this result is obtained under adverse conditions.

The measurement integrity indicator is a measurement result and therefore is queried using the FETCh subsystem. A value of 0 indicates that the measurement is valid. A value other than 0 indicates that an error occurred during the measurement process.

Example Integrity Indicators
Value Returned | Description (message also appears on test set)
0 | Normal
1 | No Result Available
2 | Measurement Timeout
5 | Over Range
6 | Under Range
Programming Example

OUTPUT Test_set;"FETC:DTXP?"
ENTER Test_set;Integrity,Avg_dig_pow
IF Integrity=0 THEN
   PRINT "AVG DIG POW= ";Avg_dig_pow
ELSE
   PRINT "DTXP Measurement Error"
   PRINT "DTXP Measurement Integrity is ";Integrity
END IF

Alternative Measurement Process

You may choose to test in a sequential way rather than use the concurrent measurement process.

For instance, instead of using the INIT:DONE? query to determine when a measurement is complete, you may choose to initiate a set of measurements and then simply fetch them sequentially.

Programming Example

OUTPUT Test_set; "INIT:DTXP;MACC"
OUTPUT Test_set; "FETC:DTXP:POW?"
ENTER Test_set;Avg_dig_pow
OUTPUT Test_set; "FETC:MACC:EVM[1]?"
ENTER Test_set;Max_EVM1

In this example, the test set starts both measurements at the same time. However, if the MACC measurement finishes first, the results are not fetched until the DTXP measurement finishes. Therefore, this process requires that you understand the order in which measurements will complete in order to optimize your testing speed.


Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Last updated: May 24, 2006

The following information provides additional details on Step 6 of the Programming Flowchart. This information is applicable to all test applications.

Description

After performing a set of measurements on the mobile station using the configuration established in step 2, you may want to change this configuration and test the mobile station again. This step involves changing testing conditions such as channel, mobile station transmit power level, or cell power.

Contents

  • Change Channels
  • Change Other Connection Parameters

Change Channels

In a manufacturing environment it is common to test a mobile station on more than one channel. Some or all of the tests may be performed on multiple channels, to verify the mobile station's performance in a range of operating frequencies.

Perform a Handoff (Handover) in Active Cell Mode

If you are operating in active cell mode, to change channels you perform a handoff (handover) to the new channel. The control program sends the commands to initiate the handoff (handover), and then determines whether the transition was successfully completed. This is accomplished using the CALL:STATus? query.

The CALL:STATus? query immediately returns the state of the call at the time the query is received.

Example Responses Returned from the CALL:STAT? Query
Response | Meaning
IDLE | The call is in the Idle state
ALER | The call is in the Alerting transitory state.
HAND | The call is in the Handoff transitory state.
PAG | The call is in the Paging transitory state.
CONN | The call is in the Connected state.

After issuing the commands to perform a handoff (handover), you should send the CALL:STAT? query to verify that the call is still connected before resuming testing.

Process for Performing a Handoff (Handover)

Test Mode Considerations

In test mode, you can either change the test set's frequencies by using the handoff (handover) commands, or directly control the RF generator and RF analyzer.

In either case, you must also send the appropriate test mode commands to the mobile station to move it to the new channel.

Change Other Connection Parameters

You may also choose to change the mobile station transmit power level or cell power, or other connection parameters such as timeslot or timing advance.


Step 7: End Connection

Step 7: End Connection

The following information provides additional details on Step 7 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you release the call (in active cell mode) or end the mobile station transmission (in test mode).

Contents

  • Release the Call in Active Cell Mode
  • End the Mobile Station Test Mode Transmission
  • Partially Preset the Test Set

Release the Call in Active Cell Mode

In active cell mode, you can release the call with the mobile station in one of two ways:

  • Release from the Base Station

  • Release from the Mobile Station

Releasing an Active Call from the Base Station

Process for Releasing an Active Call from the Base Station
Programming Example

OUTPUT Test_set;"CALL:END"        ! Initiate a base station release.
OUTPUT Test_set;"CALL:CONN?" 	 	! Send call connected state query.
ENTER Test_set;Call_connected     ! Program hangs here until state
                                  ! change or timer expires.
IF Call_connected THEN            ! Check if disconnection successful
! <put error handler here>
END IF
! Call is disconnected so proceed with control program

Releasing an Active Call from the Mobile Station

Process for Terminating an Active Call from the Mobile Station

NOTE
The test set cannot initiate a call disconnection from the mobile station. You must manually push the end button on the mobile station or send commands to a test bus built into the mobile station. For a mobile station release where the call is terminated by physically pushing a button on the phone (as opposed to using a test bus) ensure that the call-state-change-detector timeout time is long enough to allow the end button to be pushed.

Programming Example

OUTPUT Test_set;"CALL:CONN:TIM 5" !Set timeout time to 5 seconds.
OUTPUT Test_set;"CALL:CONN:ARM"   !Arm the change detector.
DISP "Terminate the call from the mobile station."
OUTPUT Test_set;"CALL:CONN?" !Initiate call connected state query.
ENTER Test_set;Call_connected     !Program hangs here until state
                                  !change or timer expires.
IF Call_connected THEN            !Check if disconnection successful.
! <put error handler here>
END IF
! Call is disconnected so proceed with control program

End the Mobile Station Test Mode Transmission

In test mode, you must send the necessary test mode commands to end the mobile station transmission.

Partially Preset the Test Set

At this point, it is good practice to partially preset the test set by sending the SYST:PRES3 command. This command stops all measurement and call processing processes, but does not reset all values to default.


1xevdo_prog_getting_started_flowchart

Programming: Getting Started Guide for 1xEV-DO Terminal Test

Introduction

Last updated: April 14, 2005

The Getting Started Guide is organized around the basic set of tasks a control program normally performs when testing a mobile station in a manufacturing environment.

  • Step 1: Set up the Test Set
  • Step 2: Configure Test Set and Mobile Station Parameters
  • Step 3: Set Measurement Parameters
  • Step 4: Make a connection
  • Step 5: INITiate and FETCh Measurements
  • Step 6: Reconfigure Test Set and Mobile Station Connection Parameters
  • Step 7: End the Connection

Click on any step in the flowchart below to learn more about how to program the Agilent Technologies 8960 to perform these tasks.

Programming Flowchart

You can also use the navigation buttons on each page to move between steps, return to the flowchart, find more detailed information about each step, or to go the comprehensive example programs.

Conventions used in this Getting Started Guide

Throughout this Getting Started Guide the term "test set" refers to an Agilent Technologies 8960 Series 10 wireless communications test set with the E1966A 1xEV-DO Terminal Test Application installed.

The variable Test_set used in the steps of the Getting Started Guide refers to the test set's GPIB address.

About the Programming Examples Presented in this Guide

Programming Language:

Programming examples presented in this guide are written in the HTBasic for Windows. The use of HTBasic is not an endorsement of the HTBasic product.

Line Numbers

All of the programming examples in the guide with line numbers are sections from a comprehensive program example available on-line for you to download.

Code that is not part of the downloadable comprehensive program example does not have line numbers. This code may represent an alternate method of performing the task or may illustrate a feature not used by the control program example.

Syntax used in Programming Examples:

  • The programming examples use the unshortened form of the command syntax, simply to make them as readable as possible. You may choose to use the shortened form of the commands to minimize GPIB bus transactions. The shortened form of a command is defined by use of capital letters in the command syntax. For the command syntax:

 RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO?

    the shortened form would be:

 RFAN:CONT:MEAS:FREQ:AUTO?
  • The programming examples do not include optional nodes. Optional nodes in the command syntax are defined by enclosing the node inside the [ ] brackets. For example, the command syntax:

 CALL[:CELL]:POWer[:SAMPlitude] -80dBm

    appears in the programming examples as:

 CALL:POWer -80dBm

  • Programming examples make use of compound commands using the ; and the ;: separators. Refer to the on-line information for the definition and use of these command separators.

Complex Commands

Complex commands are used to configure the state and assign values to parameters simultaneously. Complex commands can be used to save programming steps and minimize GPIB bus transactions.

  • The syntax below turns the state of the parameter on.

    OUTPUT Test_set;"SET:CPOW:TIM:STAT ON"

  • The syntax below is used to assign a value to the parameter.

    OUTPUT Test_set;"SET:CPOW:TIM:TIME 10 S"

  • Both of the above actions can be accomplished with one syntax command:

    OUTPUT Test_set;"SET:CPOW:TIM:STIM 10 S"

    The command above sets the parameter state to ON and the value of the parameter to 10 seconds. Note that in this example the optional command mnemonic :STIMe has been included to clarify that this complex command was used to set both the state and the value.

  • This command can be shortened further by removing the optional command mnemonic :STIMe, as shown below.

    OUTPUT Test_set;"SET:CPOW:TIM 10 S"

    This is the format that will be used throughout this guide.

Navigation


Step 1: Set up the Test Set

Step 1: Set up the Test Set

Last updated: April 14, 2005

The main actions in this step include presetting the test set and accounting for system path loss. Click on the "More Details on this Step" icon below for additional information on this step.

An excerpt from the comprehensive example program is shown below:

430 !**************************************************************************
440 ! STEP 1: SET UP THE TEST SET
450 !**************************************************************************
460 !
470 !***Turn on GPIB debugger.  Comment out when done debugging program***
480 !
490       OUTPUT Testset;"SYST:COMM:GPIB:DEB:STAT ON"
500       ! Turn debug state on
510 !
520 !***Set system path loss values.  Include cable and coupler losses.***
530 !
540       Loss_frequency$=" 800 MHZ,2000 MHZ"
550       ! Set frequencies for amplitude offset (path loss)
560       Expected_loss$=" -1.5,-1.5"
570       ! Set path loss at frequencies specified
580 !
590       OUTPUT Testset;"SYSTEM:BEEPER:STATE OFF"
600       ! Turn Off System Beeper

2340       OUTPUT Testset;"*RST"
2350       ! Full preset test set
2360       OUTPUT Testset;"*OPC?"
2370       ENTER Testset;Opc$

2450       OUTPUT Testset;"SYST:CORR:FREQ";Loss_frequency$
2460       ! Set the frequencies for amplitude offset
2470       OUTPUT Testset;"SYST:CORR";Expected_loss$
2480       ! Set the amplitude offsets for above frequencies

Navigation


Step 2: Configure Test Set and Mobile Station Parameters

Step 2: Configure Test Set and Mobile Station Parameters

Last updated: April 14, 2005

In this step you set up the parameters which characterize the test set's forward channel signal, the access terminal's reverse channel signal, and the connection between them.

You may choose to configure some of the following parameters during this step:

  • Connection parameters - Limited TAP , Cell Band and Channel .
  • Parameters which characterize the test set's forward channel - Color Code , Control Channel Data Rate , Country Code , Preferred Control Channel Cycle , Sector ID , Subnet Mask , PN Offset and cell power (see Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power ).
  • Parameters which characterize the access terminal's reverse channel:
    • Gains - ACK Channel Gain , DRC Channel Gain , Data Offset Nom , and Data Offset 9k6|19k2|38k4|76k8|153k6 .
    • Open loop output power and access probes - Open Loop Adjust , Preamble Length Probe Initial Adjust Probe Num Step Probe Power Step and Probe Sequence Max
    • AT Max Power

Some of these parameters are set or changed while performing specific C.S0033 tests as discussed in Step 5: INITiate and FETCh Measurements or during Step 6: Reconfigure Test Set and Mobile Station Connection Parameters .

An excerpt from the comprehensive example program is shown below:

620 !**************************************************************************
630 ! STEP 2: CONFIGURE TEST SET AND ACCESS TERMINAL PARAMETERS
640 !**************************************************************************
650 !
660 !***Variable declarations for call setup. (AT-specific, change as needed)***
670 !
680       Band$="USC"                  ! Set cell band
690       Primary_channel=400          ! Set RF channel for access network
700       Country_code=310             ! Set Access Terminal Country Code
710       Subnet_mask=104              ! Set Sector Subnet mask
720       At_max_power$="DBM23"        ! Set AT Maximum Power
730                                    ! (DBM8, DBM13, DBM18, DBM20, DBM23
740                                    !  DBM27, DBM28, DBM31, DBM33)
750       Init_cell_power=-50
760       ! Set initial cell power for connection setup

970       OUTPUT Testset;"CALL:APPLICATION:TAPROTOCOL:LIMITED OFF"
980       ! If you are testing an access terminal with Qualcomm
990       ! DMSS 5500 Release 3.1, you must set Limited TAP to On

2560       DISP "Setting up Test Set and Access Terminal Parameters"
2570 !
2580       OUTPUT Testset;"CALL:BAND ";Band$
2590       ! Set Cell Band
2600       OUTPUT Testset;"CALL:CHAN ";Primary_channel
2610       ! Set RF Channel for selected Cell Band
2620       OUTPUT Testset;"CALL:POW ";Init_cell_power
2630       ! Set and turns on Cell Power for connection
2640       OUTPUT Testset;"CALL:MS:POWER:MAXIMUM "&At_max_power$
2650       ! Set AT maximum expected power
2660       OUTPUT Testset;"CALL:MCCODE ";Country_code
2670       ! Set AT country code specified
2680       OUTPUT Testset;"CALL:PARAMETER:SECTOR:SMASK ";Subnet_mask
2690       ! Set MS subnet mask specified

Navigation


Step 3: Set Measurement Parameters

Step 3: Set Measurement Parameters

Last updated: April 14, 2005

In this step you set up the measurement parameters which are fixed throughout testing, such as measurement timeouts and trigger arm. It is recommended that you set all measurements to single trigger (see Trigger Arm (Single or Continuous) Description ).

Click on the "More Details on this Step" icon below for additional information on this step.

You set up other less general measurement parameters while performing specific C.S0033 tests as discussed in Step 5: INITiate and FETCh Measurements .

An excerpt from the comprehensive example program is shown below:

1030 !**************************************************************************
1040 ! STEP 3: SET MEASUREMENT PARAMETERS
1050 !**************************************************************************

2780       OUTPUT Testset;"SETUP:CONTINUOUS:OFF"
2790       ! Set all measurements to single trigger

5110       OUTPUT Testset;"SETUP:DOWQ:TIMEOUT 10"
5120       ! Set waveform quality measurement timeout to 10 seconds

5910       OUTPUT Testset;"SETUP:DAPOWER:TIMEOUT 1"
5920       ! Set DIGITAL Power timeout to 1 sec
5930       OUTPUT Testset;"SETUP:CTXS:TIMEOUT 5"
5940       ! Set TX Spur Emissions timeout to 5 sec

7140       OUTPUT Testset;"SETUP:CPOWER:TIMEOUT .5"
7150       ! Set Channel Power timeout to 0.5 sec

8060       OUTPUT Testset;"SETUP:CAPP:TIMEOUT 10"
8070       ! Set access probe power timeout to 10 seconds

9090       OUTPUT Testset;"SETUP:TROP:TIMEOUT 5"
9100       ! Set TROLPC measurement timeout to 5 s

10060       OUTPUT Testset;"SETUP:CPERROR:TIMEOUT 10"
10070       ! Set PER measurement timeout to 10 s

Navigation


Step 4: Make a connection

Step 4: Make a connection

Last updated: April 14, 2005

In this step you make a connection between the test set and access terminal (AT). To do this you must first open a session from the AT. You may then open a connection from the test set or prompt the user to open a connection from the AT.

  • Establish a Session from the Access Terminal
  • Open a Connection from the Test Set

Establish a Session from the Access Terminal

A session can only be established from the access terminal. The test set can not open a session.

In this step you:

  1. Set the Data Connection State Change Detector timeout.
  2. Arm the Data Connection State Change Detector .
  3. Prompt the user to open a session from the AT and then continue the program execution.
  4. Query the session open state of the data connection using the CALL:SOPen? query, to verify a session was opened successfully.

An excerpt from the comprehensive example program is shown below:

1140 !**************************************************************************
1150 ! STEP 4: MAKE A CONNECTION (Open a session)
1160 !**************************************************************************

1190       ! Open a session with the AT and read AT parameters

2870       OUTPUT Testset;"CALL:DCONNECTED:TIMEOUT 30"
2880       ! Set connection change detector timeout
2890       OUTPUT Testset;"CALL:DCONNECTED:ARM"
2900       ! Arm the connection state change detector
2910 !
2920       BEEP
2930       LINPUT "Connect AT and power on, press ENTER when session open",Keyboard$
2940       DISP "Verifying session is open"
2950 !
2960       OUTPUT Testset;"CALL:SOPEN?"
2970       ! Query the session open state
2980       ENTER Testset;Session_open
2990       IF Session_open=0 THEN
3000       ! If session did not open then end program
3010           BEEP
3020           Print_title("Access Terminal did not open session, check settings")
3030           Print_title("Terminating Testing")
3040           GOTO End_program
3050       END IF
3060 !
3070       DISP "Session Open"
3080 !
3090 !***Read ACCESS TERMINAL information***
3100 !
3110       OUTPUT Testset;"CALL:MS:REP:SSEED?"
3120       ENTER Testset;Sseed$
3130       OUTPUT Testset;"CALL:MS:REP:HID:TYPE?"
3140       ENTER Testset;Hid_type$
3150       OUTPUT Testset;"CALL:MS:REP:HID:HEX?"
3160       ENTER Testset;Hid_hex$
3170       OUTPUT Testset;"CALL:MS:REP:HID:DEC?"
3180       ENTER Testset;Hid_dec$

14550  Session_check: DEF FNSession_check ! Function to check session open state
14560           COM Testset,Result_file$
14570           OUTPUT Testset;"CALL:SOPEN?"
14580           ! Query the session open state
14590           ENTER Testset;Session_check
14600           RETURN Session_check
14610           ! Function returns 1 for session open, 0 for idle or connected
14620       FNEND

Open a Connection from the Test Set

In this step you first determine the status of the data connection. The data connection must be in the session open state before you can open a connection. If the data connection is in the session open state, then you:

  1. Specify whether you would like to open an RTAP or FTAP connection, and at what rate, using the CALL:APPLication commands.
  2. Set the Data Connection State Change Detector timeout.
  3. Arm the Data Connection State Change Detector .
  4. Page the access terminal using the CALL:FUNCtion:DATA:STARt command.
  5. Query the connected state of the data connection using the CALL:DCONnected[:STATe]? query to verify a connection was opened successfully.

An excerpt from the comprehensive example program is shown below:

1140 !**************************************************************************
1150 ! STEP 4: MAKE A CONNECTION (Open an RTAP connection)
1160 !**************************************************************************

3280       DISP "Opening (or Moving to) an RTAP Connection"
3290 !
3300       IF NOT FNConnected THEN
3310           DISP "Connection is not currently open"
3320           ! If the state is NOT connected, then see if it is session open
3330 !
3340           IF NOT FNSession_check THEN
3350           ! If the state is NOT session open, then end program
3360               Print_title("Session is not currently open")
3370               Print_title("Ending Testing")
3380               GOTO End_program
3390           END IF
3400           ! If the state is session open, then change to RTAP and
3410           ! open a connection
3420           DISP "Session is open, opening an RTAP connection now"
3430 !
3440           OUTPUT Testset;"CALL:APPLICATION RTAP"
3450           ! Set application type to RTAP (for TX testing)
3460           OUTPUT Testset;"CALL:APPLICATION:RTAP:DRATE BPS9600"
3470           ! Set RTAP data rate to 9600 kbps
3480           GOSUB Start_data
3490 !
3500       ELSE
3510           DISP "Connection is currently open, changing to RTAP"
3520           ! If state is connected, then change to RTAP
3530           OUTPUT Testset;"CALL:APPLICATION RTAP"
3540           ! Set application type to RTAP (for TX testing)
3550           OUTPUT Testset;"CALL:APPLICATION:RTAP:DRATE BPS9600"
3560           ! Set RTAP data rate to 9600 kbps
3570 !
3580           IF NOT FNConnected THEN
3590           ! This additional loop is only necessary if Limited TAP is On
3600               DISP "Connection was closed when Application changed"
3610               ! If the state is NOT connected, then see if session open
3620               IF NOT FNSession_check THEN
3630               ! If the state is NOT session open, then end program
3640                   Print_title("Session is not currently open")
3650                   Print_title("Ending Testing")
3660                   GOTO End_program
3670               END IF
3680               ! If the state is session open, then re-open a connection
3690               DISP "Session is open, re-opening an RTAP connection now"
3700               GOSUB Start_data
3710           END IF
3720 !
3730           DISP "RTAP Connection Open"
3740 !
3750       END IF

4340  Start_data:!
4350 !*******************************************************************
4360 ! Subroutine: Start data connection and verify it has connected
4370 !*******************************************************************
4380 !
4390       OUTPUT Testset;"CALL:DCONNECTED:TIMEOUT 10"
4400       ! Set connection change detector timeout
4410       OUTPUT Testset;"CALL:DCONNECTED:ARM"
4420       ! Arm the connection state change detector
4430       OUTPUT Testset;"CALL:FUNCTION:DATA:START"
4440       ! Page the access terminal
4450       OUTPUT Testset;"CALL:DCONNECTED?"
4460       ! Query the connection status
4470       ENTER Testset;Data_started
4480 !
4490       IF Data_started=0 THEN
4500           Print_title("Data connection could not be opened")
4510           Print_title("Ending Testing")
4520           GOTO End_program
4530       END IF
4540 !
4550       DISP "Data Connection Open"
4560 !
4570       RETURN

14460  Connected: DEF FNConnected ! Function to check connected state
14470           COM Testset,Result_file$
14480           OUTPUT Testset;"CALL:DCONNECTED?"
14490           ! Query the connected status
14500           ENTER Testset;Connected
14510           RETURN Connected
14520           ! Function returns 1 for connected, 0 for idle or session open
14530       FNEND
14540 !
14550  Session_check: DEF FNSession_check ! Function to check session open state
14560           COM Testset,Result_file$
14570           OUTPUT Testset;"CALL:SOPEN?"
14580           ! Query the session open state
14590           ENTER Testset;Session_check
14600           RETURN Session_check
14610           ! Function returns 1 for session open, 0 for idle or connected
14620       FNEND

Navigation


Step 5: INITiate and FETCh Measurements

Step 5: INITiate and FETCh Measurements

Last updated: April 14, 2005

In this step you configure any parameters that are required for the test you are performing, then initiate the measurement and fetch the results. You can also use the READ command to both start the measurement and retrieve the results instead of using the INITiate/FETCh commands.

If the test conditions (cell power, parameter settings, etc.) for any tests are identical, and the required measurements are concurrent (see Concurrent Measurements ), you can perform the tests simultaneously, saving test time. To do this you must use the INITiate/FETCh commands along with the INITiate:DONE? command.

NOTE
The INIT:DONE? command is only useful when performing concurrent testing. When initiating only one measurement at a time, simply send the INITiate command immediately followed by the FETCh command to retrieve the results.

An excerpt from the comprehensive example program is shown below:

5520 !*******************************************************************
5530 ! Subroutine: Digital Average Power and
5540 !             TX Spurious Emissions Measurements
5550 !             3.1.2.3.4 Maximum RF Output Power
5560 !             3.1.2.4.1 Conducted Spurious Emissions
5570 !*******************************************************************
5580 !
5590       DISP "Measuring Maximum Power and TX Spurious Emissions"
5600 !
5610 !***Set up test parameters***
5620 !
5630       Ior=-105.5                   ! Set cell power for test
5640 !
5650       IF Band$="KPCS" OR Band$="USPCS" OR Band$="IMT2000" THEN
5660       ! Set open loop adjust for test
5670           Ol_adjust=84
5680       ELSE
5690           Ol_adjust=81
5700       END IF
5710 !
5720       OUTPUT Testset;"CALL:APPLICATION:RTAP:DRATE BPS153600"
5730       ! Set RTAP data rate to 153600
5740       OUTPUT Testset;"CALL:APAR:POWER:OLADJUST ";Ol_adjust
5750       ! Set Open Loop Adjust
5760       OUTPUT Testset;"CALL:APAR:PROBE:IADJUST 15"
5770       ! Set Probe Initial Adjust
5780       OUTPUT Testset;"CALL:APAR:PROBE:STEP:COUNT 15"
5790       ! Set Probe Num Steps
5800       !OUTPUT Testset;"CALL:APAR:PROBE:SEQUENCE 15"
5810       ! Set Probe Sequence Max - this parameter setting is required
5820       ! by C.S0033 but does not affect test results. It is a legacy
5830       ! parameter setting from IS-98. Changing this parameter drops
5840       ! the connection, as required by C.S0024. It is recommended not
5850       ! to send this command.
5860       OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP 7.5"
5870       ! Set Probe Step

5960 !***Set test conditions***
5970 !
5980       OUTPUT Testset;"CALL:POW ";Ior
5990       ! Set Cell Power for Test
6000       OUTPUT Testset;"CALL:CLPCONTROL:REVERSE:MODE UP"
6010       ! Start transmission of All Up (0) power control bits
6020       WAIT 1
6030       ! Settling time to allow mobile power to slew up to maximum power
6040 !
6050 !***Obtain measurement results***
6060 !
6070       OUTPUT Testset;"INITIATE:DAPOWER;CTXS"
6080       ! Initiate digital average power and
6090       ! TX spurious emissions measurements
6100 !
6110       LOOP
6120           OUTPUT Testset;"INIT:DONE?"
6130           ! Determine if a measurement is done
6140           ENTER Testset;Meas_done$
6150           ! Obtain measurement results as they are ready
6160 !
6170           SELECT Meas_done$
6180           CASE "DAP"
6190               OUTPUT Testset;"FETCh:DAPOWER?"
6200               ENTER Testset;Integrity,Avg_power_dbm
6210           CASE "CTXS"
6220               OUTPUT Testset;"FETCH:CTXS?"
6230               ENTER Testset;Ctxs_integ,Ctxs_pf,Low_adj,Upp_adj,Low_alt,Upp_alt
6240           END SELECT
6250 !
6260       EXIT IF Meas_done$="NONE"
6270       ! Exit loop when all measurements are complete
6280       END LOOP
6290       ! If Meas_done$="WAIT" then loop continues until "NONE"

Navigation


Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Last updated: April 14, 2005

There are several ways you may want to reconfigure the connection between the test set and access network when you reach this step.

  • Move to RTAP/FTAP Connection to Allow Transmitter/Receiver Testing
  • Hand Off to a New Channel or Band

Move to RTAP/FTAP Connection to Allow Transmitter/Receiver Testing

You must have an RTAP connection open to test the access terminal's transmitter, or an FTAP connection open to perform receiver testing. In this step, you thus may need to change the Test Application Protocol parameter so that you may test the access terminal's transmitter or receiver.

Hand Off to a New Channel or Band

In this step you may choose to move to a new band and/or channel for testing. To do this you:

  1. Specify the handoff band and/or channel using the CALL:SETup commands.
  2. Initiate a handoff using the CALL:HANDoff command.
  3. Query the data connection state to verify it is still connected, using either the CALL:DCONnected or CALL:STATus[:STATe]:DATA? query.

An excerpt from the comprehensive example program is shown below:

1750 !**************************************************************************
1760 ! STEP 6: RECONFIGURE TEST SET AND ACCESS TERMINAL CONNECTION PARAMETERS
1770 !         (Perform a handoff to a new channel)
1780 !**************************************************************************

1440       Handoff_band$="USPCS"
1450       ! Only specify handoff band when performing interband HO

1810 !      Handoff_chan=1023          ! Hand off to "high" channel for test

4640 !***Set up a hard handoff***
4650 !
4660       OUTPUT Testset;"CALL:SETUP:BAND "&Handoff_band$
4670       ! Specify the cell band to hand off to
4680       OUTPUT Testset;"CALL:SETUP:CHANNEL ";Handoff_chan
4690       ! Specify the channel number to hand off to
4700 !
4710 !***Perform a hard handoff***
4720 !
4730       OUTPUT Testset;"CALL:HANDOFF"
4740       ! Initiate a hard handoff
4750 !
4760       IF NOT FNConnected THEN
4770       ! Verify connection is still open after handoff
4780           DISP "Handoff attempt failed, program stopped"
4790           GOTO End_program
4800       ELSE
4810           PRINT
4820           Print_results("Handoff completed to channel: ",Handoff_chan,"")
4830           PRINT "Call connected"
4840           PRINT
4850           Current_chan=Handoff_chan
4860           Band$=Handoff_band$
4870 !
4880       END IF

14460  Connected: DEF FNConnected ! Function to check connected state
14470           COM Testset,Result_file$
14480           OUTPUT Testset;"CALL:DCONNECTED?"
14490           ! Query the connected status
14500           ENTER Testset;Connected
14510           RETURN Connected
14520           ! Function returns 1 for connected, 0 for idle or session open
14530       FNEND

Navigation


Step 7: End the Connection

Step 7: End the Connection

Last updated: April 14, 2005

In this step you end the connection between the access terminal and test set, as well as prepare the test set to test the next access terminal.

To end the connection you can choose to only close the data connection which makes the session still open (see Close the Connection ) or choose to close the session which will close the data connection and the session at one time (see Close the Session ).

To prepare to test the next access terminal, you should then partially preset the test set. See Partially Preset the Test Set .

Close the Connection

To close the connection, you:

  1. Set the Data Connection State Change Detector timeout.
  2. Arm the Data Connection State Change Detector .
  3. Send the CALL:FUNCtion:DATA:STOP command.
  4. Query the state of the data connection using the CALL:DCONnected[:STATe]? or CALL:SOPen? query.

An excerpt from the comprehensive example program is shown below:

2120 !**************************************************************************
2130 ! STEP 7: END THE CONNECTION
2140 !**************************************************************************

12910       DISP "Closing data connection"
12920 !
12930       OUTPUT Testset;"CALL:DCONNECTED?"
12940       ! Checks connection status
12950       ENTER Testset;Data_stopped
12960 !
12970       IF Data_stopped=0 THEN
12980           DISP "Data connection closed"
12990 !
13000       ELSE
13010           OUTPUT Testset;"CALL:DCONNECTED:TIMEOUT 10"
13020           ! Set connection change detector timeout
13030           OUTPUT Testset;"CALL:DCONNECTED:ARM"
13040           ! Arm the connection state change detector
13050           OUTPUT Testset;"CALL:FUNCTION:DATA:STOP"
13060           ! Close the data connection
13070           OUTPUT Testset;"CALL:DCONNECTED?"
13080           ! Query the data connection status
13090           ENTER Testset;Data_stopped
13100 !
13110           IF Data_stopped=1 THEN
13120               Print_title("Data connection could not be closed")
13130               Print_title("Ending Testing")
13140               GOTO End_program
13150           END IF
13160 !
13170           DISP "Data connection closed"
13180       END IF

Close the Session

Before disconnecting the AT under test and connecting a new AT to test, you should close the session using the CALL:SCLose command. This will close the data connection and the session at one time. See Close Session Before Testing New AT .

Partially Preset the Test Set

Partially presetting the test set using the SYSTem:PRESet3 command will also return the data connection to the idle state, as well as stop any measurements in progress.

Navigation


Invalid Measurement Results

Invalid Measurement Results

Last updated: April 14, 2005

Description

Invalid measurement results are returned by the test set when conditions such as signal level are not within the present measurement range. Three different invalid measurement results are provided in order to help you understand the condition that caused the invalid result.

  • 9.9E+37 = INFinity (Infinity)
  • -9.9E+37 = NINF (Negative Infinity)
  • 9.91E+37 = NAN (Not A Number)

9.9E+37 (INFinity)

9.9E+37 is returned by the test set when the measurement is out of range and results are far above the present measurement range.

-9.9E+37 (NINFinity)

-9.91E+37 is returned by the test set when the measurement is out of range and results are far below the present measurement range.

9.91E+37 (NAN)

9.91E+37 is returned by the test set when the measurement is out of range but it can not be determined if measurement results are far above, or far below the measurement range.

If a measurement exceeds its measurement timeout value before a valid result is determined, 9.91E+37 is returned.

FETCH? and READ? Invalid Results

When a FETCH? or READ? query is performed on a measurement with invalid results, the integrity indicator returns a value of 1, indicating No Result Available.

Manual Users Invalid Results

Manual users will generally see four dashes , "----" on the test set display. When the measurement timeout value has been exceeded, "Measurement Timeout" is displayed as well as the four dashes.


Measurement Progress Report

Measurement Progress Report

Last updated: April 14, 2005

Description

The measurement progress report is a query of how far along a multi-measurement cycle has progressed. When the multi-measurement count is greater than one, the measurement progress report will indicate the number of measurements that have completed. The returned value will be the last update and not the actual number, because the value is updated periodically and not for each multi-measurement cycle. Every measurement has the measurement progress report available.

Example

OUTPUT 714;"FETCH:DAPOWER:ICOUNT?" !Returns the approximate number of
                                  !multi-measurement cycles completed during a
                                  !multi-measurement count cycle

Related Topics

Statistical Measurement Results


Measurement Event Synchronization

Measurement Event Synchronization

Last updated: April 15, 2005

Description

Measurement event synchronization saves time by controlling the communication between the controller, the test set, and the mobile station, so that no device does something before it is supposed to (which can cause errors or do something well after it could have). Because some measurements can run concurrently, it is necessary that the control program know when individual measurement results are available.

Measurement event synchronization is accomplished using the INITiate subsystem's command INITiate:DONE? or the STATus:OPERation:NMRReady status registers.

INITiate:DONE?

The INITiate:DONE? query returns a string that indicates which, if any, measurements have completed since the last INITiate command was received. This query is useful when performing measurements concurrently, and is generally used within a loop, with a loop exit when all measurements have been obtained. The INITiate:DONE? query returns a measurement name, "WAIT," or "NONE" after each pass through the loop. See INITiate:DONE? and INITiate Programming Examples (how INIT commands are used) for more details about this query.

Note

The INIT:DONE? command is only useful when performing concurrent testing. When initiating only one measurement at a time, simply send the INITiate command immediately followed by the FETCh command to retrieve the results.

Note

STATUS:OPERATION:NMRREADY

The STATus:OPERation:NMRReady command allows the program to immediately branch to the next operation or command without continuing through a loop as in INITiate:DONE? See STATus:OPERation:NMRReady Condition Register Bit Assignments for more details about this command.

You must enable the following so that as soon as the enabled NMRReady bit is true the program moves on.

  • Positive or negative transition filter. See Transition Filters .
  • STATus:OPERation:NMRReady bit for the measurement desired
  • STATus:OPERation bit (512 for NMRReady). See Status Subsystem Overview .
  • Service Request Enabling (*SRE 128 for NMRReady). See Status Subsystem Overview .

The STATus:OPERation:NMRReady Condition Register Bit Assignments status register provides status reporting on the cdma2000 measurements.

Note

The following program uses the E1960A GSM Mobile Test Application Bit Error Rate measurement for the example. Refer to STATus:OPERation:NMRReady Condition Register Bit Assignments for bit assignments for other Test Applications.

Note

Generating a Service Request (SRQ) Interrupt - Bit Error Rate NMRR

The following example illustrates the use of the STATus subsystem to generate a service request when a BERR measurement has completed. This code assumes a call is already connected and the BERR measurement is setup (mobile station must be in loopback type A or B).

10  OUTPUT 714;"STATUS:OPERATION:NMRREADY:PTR 256" !Enable positive transition
20                                                 !filter on fast BER bit.
30  OUTPUT 714;"STATUS:OPERATION:NMRREADY:ENABLE 256" !Enable the fast BER Bit to
40                                                    !generate a summary message.
50  OUTPUT 714;"STATUS:OPERATION:ENABLE 512" !Enable the Operation summary bit to
60                                           !generate a summary message.
70  OUTPUT 714;"*SRE 128" !Enable the service request enable register to generate SRQ.
80  OUTPUT 714;"*CLS" !Clear all status data structures.
90  ON INTR 7,15 CALL Meas_complete !Define interrupt-initiated branch with a priority
100                                 !of 15 (highest)
110 ENABLE INTR 7;2 !Enable interrupt on interface card 7 with a bit mask
120                 !(for interface's interrupt-enable register) of 2.
130 OUTPUT 714;"SETUP:FBER:CONTINUOUS OFF;:INITIATE:FBERROR" !Initiate a single
140                                                          !fast BER test.
150 LOOP
160 DISP "Waiting for BERR test to complete"
170 WAIT .1 !"Dummy" loop
180 END LOOP
190 !Instead of a "dummy" loop, controlling application could be performing setups,
200 !making measurements, etc.
210 END
220 SUB Meas_complete
230 DISP "BER test complete, OK to FETCh results now"
240 Clear_interrupt=SPOLL(714) !Clear the RQS message in the status byte register.
250 STOP
260 SUBEND

Operating Considerations

Only one indicator is returned per query.

All active measurements must be set to single trigger mode. This ensures that when a measurement completes it remains in the "DONE" state rather than restarting. Sending the "*RST" command at the beginning of your test code or using the "SETup:CONTinuous:OFF" command during measurement setup are ways to set trigger to single for all measurements.

Related Topics

Test System Synchronization Overview


Control Program Examples

Control Program Examples

HTBASIC

The programming examples shown in the Programming: Getting Started Guide for 1xEV-DO Terminal Test are excerpts from a comprehensive example program based on TAP (Test Application Protocol ) test data connection. This program, written using HTBasic, is a fully functional 1xEV-DO control program. You can use this as a starting point for developing your own program. Click on the link below to view this program.

  • Comprehensive Program Example for AT Test (based on TAP test data connection)

A comprehensive example program based on ETAP (Enhanced Test Application Protocol ) test data connection is also provided to help you develop a test program for your Release A access terminal. Click on the link below to view this program.

  • Comprehensive Program Example for AT Test (based on ETAP test data connection)

To learn more about TAP and ETAP, see C.S0029 Test Application Specification Description (TAP/ETAP) .


Test System Synchronization

Test System Synchronization

  • Test System Synchronization Overview


Obtaining Measurement Results

Obtaining Measurement Results

Last updated: April 15, 2005

  • Statistical Measurement Results
  • Measurement Timeouts
  • Triggering of Measurements
  • Integrity Indicator
  • Measurement Progress Report
  • Invalid Measurement Results


Programming a Swept Audio Measurement

Programming a Swept Audio Measurement

Last updated: April 14, 2005

This section provides an example of how to make swept audio measurements via the GPIB.

The following example assumes that some device under test is connected between the test set's AUDIO OUT and AUDIO IN ports. The default audio level measurement, and the optional SINAD and distortion measurements, are performed at each frequency point in the sweep.

  1. Configure the swept audio measurement using the SETup subsystem.
  2. Start the measurement using the INITiate subsystem.
  3. Use the FETCh subsystem to obtain the audio analyzer's results for all points in the sweep.

Programming Example

10    OUTPUT 714;"SETup:SAUDio:FREQuency:STARt 300 Hz" !Start the frequency
20                                         !sweep at 300 Hz.
30    OUTPUT 714;"SETup:SAUDio:FREQuency:STOP 4 kHz" !Stop the frequency
40                                         !sweep at 4 kHz.
50    OUTPUT 714;"SETup:SAUDio:FREQuency:POINts 5"  !Make measurements at 5 frequencies
60                       !spaced evenly between the start and stop frequencies.
70    OUTPUT 714;"SETup:SAUDio:SETTling 1.5 ms" !Set a settling time of
80                                          !1.5 milliseconds.
90    OUTPUT 714;"SETup:SAUDio:VOLTage:AMPLitude 1 V" !SET the audio generator
100                                         !voltage to 1 volt peak.
110   OUTPUT 714;"SETup:SAUDio:DETector PEAK" !Select the peak detector for
120                                         !the audio analyzer.
130   OUTPUT 714;"SETup:SAUDio:FILTer TBPass" !Select the AF analyzer's 100 Hz bandwidth
140    !band pass filter for making the measurements. The center frequency for the filter
150                                !automatically tracks the AF generator's frequency.
160   OUTPUT 714;"SETup:SAUDio:PEAK:VOLTage 1 V" !Set the expected peak voltage
170                                         !at the AUDIO IN port.
180   OUTPUT 714;"SETup:SAUDio:SDIStortion:STATe ON" !Turn on the SINAD
190                                         !and distortion measurements.
200   OUTPUT 714;"SETup:SAUDio:CONTinuous OFF" !Set the swept audio
210                                         !measurement to single trigger mode.
220   OUTPUT 714;"SETup:SAUDio:TIMeout 5 S" !Set a measurement timeout of
230                                      !5 seconds in case the measurement cannot be made.
240   OUTPUT 714;"INITiate:SAUDio"          !Start the swept audio measurements.
250   OUTPUT 714;"FETCh:SAUDio?"            !Query the audio level and distortion results.
260   ENTER 714;Integrity,Lev1,Dist1,Lev2,Dist2,Lev3,Dist3,Lev4,Dist4,Lev5,Dist5 !Enter the
270                        !returned integrity value, and the level and distortion values
280                        !for each of the five measurement points, into variables.
290   OUTPUT 714;"FETCh:SAUDio:SINAD?"       !Query the SINAD results.
300   ENTER 714;Sinad1,Sinad2,Sinad3,Sinad4,Sinad5 !Enter the 5 returned SINAD values
310                                          !into variables.
320   END

Returned Values

The results returned by this program are:

  • Integrity returns the measurement integrity indicator (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Lev1 through Lev5 return the audio level (voltage) at each of the five measurement points. In this example, the value is returned in volts peak because the peak detector was specified.
  • Dist1 through Dist5 return the distortion value at each of the five measurement points.
  • Sinad1 through Sinad5 return the SINAD value at each of the five measurement points.

The example program uses the single FETCh:SAUDio[:ALL]? query to return the integrity value, the audio level (voltage) values, and the distortion values, at one time. These values can also be queried separately if required. The SINAD value is always queried separately.

Related Topics

Swept Audio Measurement Description

Swept Audio Measurement Troubleshooting

INITiate

SETup:SAUDio

FETCh:SAUDio


Programming the Spectrum Monitor

Programming the Spectrum Monitor

Last updated: April 14, 2005

This section provides an example of how to use the Spectrum Monitor via the GPIB.

The following procedure assumes that the mobile station's antenna output is connected to the RF IN/OUT connector, and that the mobile station is transmitting an uplink signal.

  1. Configure the Spectrum Monitor parameters using the SETup subsystem.
  2. Start the Spectrum Monitor using the INITiate subsystem.
  3. Use the INITiate:DONE? command to determine if Spectrum Monitor results are available.
  4. Use the FETCh? commands to obtain Spectrum Monitor results.
  5. Use the CALCulate commands to set and query the Spectrum Monitor markers.

Programming Example

10       REAL Amplitudes(400)
20       ! Set up array to hold 401 amplitude results (trace data)
30       OUTPUT 714;"SETUP:SMONITOR:CONTINUOUS OFF"!Configures the Spectrum Monitor to
40                                                !single trigger mode.
50       OUTPUT 714;"SETUP:SMONITOR:COUNT:NUMBER 20"!Configures a multi-measurement
60                                                  !of 20.
70       OUTPUT 714;"SETUP:SMONITOR:TRIGGER:SOURCE IMMEDIATE"!Configure trigger source
80                                                     !to immediate.
90       OUTPUT 714;"SETUP:SMONITOR:FREQUENCY:SPAN 20 MHz"!Set frequency span
100       OUTPUT 714;"SETUP:SMONITOR:BWIDth:MANUAL 300 KHZ"!Decouples the frequency span
110                     ! and the resolution bandwidth, and sets the resolution bandwidth.
120       OUTPUT 714;"INITIATE:SMONITOR"!Start the Spectrum Monitor
130     !
140       OUTPUT 714;"FETCH:SMONITOR:INTEGRITY?"!Fetch SMON Integrity
150       ENTER 714;Integrity
160       PRINT "Spectrum Monitor Integrity: ";Integrity
170       IF Integrity=0 THEN                  !Fetch results if SMON
180           OUTPUT 714;"FETCH:SMONITOR:TRACE?"!has valid integrity.
190           ENTER 714;Integrity,Amplitudes(*)!Load valid results into array
200           PRINT "Trace Data Amplitude Results (dB):"
210           PRINT "--------------------------------------------------"
220           PRINT Amplitudes(*) !Prints the 401 stored data points.
230           PRINT "--------------------------------------------------"
240       ELSE
250           PRINT "Bad Integrity value =";Integrity
260           STOP
270       END IF
280     ! Move the marker to the signal peak and query the frequency and level
290       OUTPUT 714;"CALCULATE:SMONITOR:MARKER1:PEAK:MAXIMUM"
300       OUTPUT 714;"CALCULATE:SMONITOR:MARKER1:FREQUENCY?"
310       ENTER 714;Peak_frequency
320       PRINT "Maximum Peak Frequency (MHz): ";Peak_frequency
330       OUTPUT 714;"CALCULATE:SMONITOR:MARKER1:AMPLITUDE?"
340       ENTER 714;Peak_amplitude
350       PRINT "Maximum Peak Amplitude (dBm): ";Peak_amplitude
360       END

Returned Values

The results returned by this program are:

  • Integrity returns the Spectrum Monitor Integrity Indicator (0 means that the Spectrum Monitor completed with no errors).
  • Amplitudes() returns 401 points representing the amplitude results (in dBm) of the trace data.
  • Peak_frequency returns the frequency in MHz at marker 1. In this case, marker 1 is positioned at the highest peak value.
  • Peak_amplitude returns the amplitude in dBm at marker 1. In this case, marker 1 is positioned at the highest peak value.

Related Topics

Spectrum Monitor Description

SETup:SMONitor

INITiate

FETCh:SMONitor

CALCulate:SMONitor


Statistical Measurement Results

Statistical Measurement Results

Last updated: April 14, 2005

Description

Most measurements have a setup window that provides for the entry of a multi-measurement count value. This specifies how many measurements the test set will perform to obtain a set of values from which to calculate the following statistical measurement results:

  • Average (arithmetic mean) of measurement set
  • Minimum value from measurement set
  • Maximum value from measurement set
  • Standard Deviation of measurement set

Operating Considerations

The advantages of using the multi-measurement feature to obtain statistical measurement data include: reduced time associated with GPIB bus traffic, and reduced time configuring hardware. This is because the number of measurements specified in the multi-measurement count value are performed during one measurement cycle.

Programming Example

OUTPUT 714;"SETUP:DAPOWER:COUNt 10" 	!Enters a Digital Average Power count
                                      !of 10, and turns the Digital Average Power
                                      !multi-measurement state on.

Related Topics

Measurement Progress Report


Status Subsystem Overview

Status Subsystem Overview

Last updated: June 30, 2006

The following pages present an overview of the entire status subsystem, including test applications which may or may not be loaded in your test set.

Description

Overview of STATus Reporting Structure

Status Reporting Structure For STATus QUEStionable Registers

Status Reporting Structure For STATus OPERation Registers

Status Reporting Structures for the COMMon Registers

Status Reporting Structure for the SMService Register

Status Reporting Structure for the GSM Registers

Status Reporting Structure For the GPRS Registers

Status Reporting Structure for the AMPS Registers

Status Reporting Structure for the DIGital136 Registers

Status Reporting Structures for the TA136 Registers

Status Reporting Structure for the DIGital95 Registers

Status Reporting Structure for the DIGital 2000 Registers

Status Reporting Structure for the CDMA Registers

Status Reporting Structure for the TA 2000 Registers

Status Reporting Structure for the FDD Registers

Status Reporting Structure for the WCDMA Registers

Status Reporting Structure For the TA856 Registers

Status Reporting Structure for the DIGital856 Registers

Status Data Structure - Register Model

The generalized status register model consists of a Condition Register, Transition Filters, an Event Register, an Enable Register, and a Summary Message Bit.

Condition Register

A condition is a test set state that is either TRUE or FALSE (a GPIB command error has occurred or a GPIB command error has not occurred). Each bit in a Condition Register is assigned to a particular test set state. A Condition Register continuously monitors the hardware and firmware states assigned to it. There is no latching or buffering of any bits in a Condition Register; it is updated in real time. Condition Registers are read-only. Condition Registers in the test set are 16 bits long and may contain unused bits. All unused bits return a zero value when read.

Transition Filters

In the test set, the Transition Filters are implemented as two registers: a 16-bit positive transition (PTR) register and a 16-bit negative transition (NTR) register.

For each bit in the Condition Register, a Transition Filter bit determines the state transitions which will set a corresponding bit in the Event Register. Transition Filters may be set to pass positive transitions (PTR), negative transitions (NTR) or either (PTR or NTR). A positive transition refers to a condition bit which has changed from 0 to 1. A negative transition refers to a condition bit which has changed from 1 to 0.

A positive transition of a bit in the Condition register will be latched in the Event Register if the corresponding bit in the positive transition filter is set to 1. A positive transition of a bit in the Condition register will not be latched in the Event Register if the corresponding bit in the positive transition filter is set to 0.

A negative transition of a bit in the Condition register will be latched in the Event Register if the corresponding bit in the negative transition filter is set to 1. A negative transition of a bit in the Condition register will not be latched in the Event Register if the corresponding bit in the negative transition filter is set to 0. Either transition (PTR or NTR) of a bit in the Condition Register will be latched in the Event Register if the corresponding bit in both transition filters is set to 1. No transitions (PTR or NTR) of a bit in the Condition Register will be latched in the Event Register if the corresponding bit in both transition filters is set to 0.

Transition Filters are read-write.

Transition Filters are unaffected by a *CLS (clear status) command.

Transitions Filters are set to pass positive transitions (all 16 bits of the PTR register are set to 1 and all 16 bits of the NTR register are set to 0) at power on or after receiving the *RST (reset) command.

Event Register

The Event Register captures bit-state transitions in the Condition Register as defined by the Transition Filters. Each bit in the Event Register corresponds to a bit in the Condition Register. Bits in the Event Register are latched, and, once set, they remain set until cleared by a query of the Event Register or a *CLS (clear status) command. This guarantees that the application can't miss a bit-state transition in the Condition Register. There is no buffering; so while an event bit is set, subsequent transitions in the Condition Register corresponding to that bit are ignored. Event Registers are read-only. Event Registers in the test set are 16 bits long and may contain unused bits. All unused bits return a zero value when read.

Event Enable Register

The Event Enable Register defines which bits in the Event Register will be used to generate the Summary Message. Each bit in the Enable Register has a corresponding bit in the Event Register. The test set logically ANDs corresponding bits in the Event and Enable registers and then performs an inclusive OR on all the resulting bits to generate the Summary Message. By using the enable bits the application program can direct the test set to set the Summary Message to the 1 or TRUE state for a single event or an inclusive OR of any group of events. Enable Registers are read-write. Enable Registers in the test set are 16 bits long and may contain unused bits which correspond to unused bits in the associated Event Register. All unused bits return a zero value when read and are ignored when written to. Enable Registers are unaffected by a *CLS (clear status) command or queries.

Standard Event Status Register Model

Summary Message Bit

The Summary Message is a single-bit message which indicates whether or not one or more of the enabled events have occurred since the last reading or clearing of the Event Register. The test set logically ANDs corresponding bits in the Event and Enable registers and then performs an inclusive OR on all the resulting bits to generate the Summary Message. By use of the enable bits, the application program can direct the test set to set the Summary Message to the 1, or TRUE, state for a single event or an inclusive OR of any group of events.

The Summary Message is TRUE, logic 1, if the register contains some information and an enabled event in the Event Register is set TRUE.

The Summary Message is FALSE, logic 0, if the queue is empty and no enabled events are TRUE. Registers can be cleared by reading all the information from the queue. Registers can also be cleared using the *CLS (clear status) command.

Service Request Enabling Register Model

Status Byte Register

The Status Byte Register is an 8 bit register that provides single bit summary messages, each summary message summarizes and overlaying status data structure. Summary messages always track the current status of the associated status data structure. Service request enabling determines if one or more of the summary messages will generate a message. Device status reporting is defined in IEEE 488.2-1992, 11.1.

The Status Byte Register contains the STB and RQS (or MSS) messages from the test set. The Status Byte Register can be read with either a serial poll or the *STB? common query. The value for bit 6 is dependent on which method used.

When reading with a serial poll the status byte and the RQS message are returned as a single data byte. The RQS message indicates if the SRQ is TRUE. The Status Byte Register is not affected by a serial poll, the RQS is set to FALSE when polled.

The *STB? query allows you to read the status byte and the MSS. The response represents the sum of the binary weighted values of the Status Byte Register from bit 0-5 and 7.

The Master Summary Status (MSS) message from bit 6 indicates when there is at least one reason for requesting service.

The Message Available (MAV) summary message from bit 4 is TRUE when there is a message is in the output queue.

The Status Byte Register is cleared with the *CLS common command. The output queue and the MAV are not affected by the *CLS command.

Service Request Enable Register

The Service Request Enable Register is an 8 bit register that enables corresponding summary messages in the Status Byte Register. Enabling the service request with the *SRE command allows you to choose which bits in the Status Byte Register will trigger a service request.

The Service Request Enable Register is read with the *SRE? query. The returned value is the sum of the binary weighted values of the Service Request Enable Register, with a range of 0 through 63 or 128 through 191.

The value of the unused bit 6 will always be zero.

System Synchronization Bit

Bit 12 of the status operation condition register is "pulsed" when the SYSTem:SYNChronized command is sent. This allows the status system to indicate that:

  • the input buffer is synchronized to the point where this command is parsed
  • all prior sequential commands are completed
  • all prior overlapped commands have started

Related Topics

STATus Subsystem


Data Connection Processing Event Synchronization

Data Connection Processing Event Synchronization

Last updated: April 14, 2005

Description

Using the call processing subsystem overlapped command synchronization commands, you can query the test set to find out when an overlapped command operation is done (:DONE?, :OPC?), force the test set to not execute any more commands until an overlapped command operation has completed (:WAIT), or simply force an overlapped command to behave as a sequential command (:SEQ).

Pending Operation Flags

Associated with each overlapped command, the test set maintains a binary indicator known as a pending operation flag. A pending operation flag is set true when the operation started by the overlapped command is executing, and is set false when the operation is no longer executing.

NOTE
In addition to the call processing subsystem overlapped commands, the test set also provides the measurement-related INITiate <measurement> overlapped commands.

Call Processing Subsystem Overlapped Command Synchronization Commands

Overlapped Commands
Command Purpose Of Command

Example

:DONE?

Returns a 0 if the associated command's pending operation flag is true, or a 1 if it is false.

10 OUTPUT 714;"CALL:TCH 65"
20 OUTPUT 714;"SETUP:TXP:CONT OFF"
30 OUTPUT 714;"SETUP:PFER:CONT OFF"
40 REPEAT
50 OUTPUT 714;"CALL:TCH:DONE?"
60 ENTER 714;Process_done
70 UNTIL Process_done
80 OUTPUT 714;INIT:TXP;PFER"
90 END

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and execute two setup commands. After the two setup commands have finished, the :DONE? command is used to find out if the handover is finished

:SEQuential

Forces an overlapped command to execute in a sequential manner. No subsequent commands will be executed until the pending operation flag for this operation is false.

OUTPUT 714;"CALL:TCH:SEQ 65"

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and to not execute any more commands until the pending operation flag associated with the CALL:TCH command is false.

:WAIT

Forces the test set to wait until the associated command's pending operation flag is false before executing any more commands.

10 OUTPUT 714;"CALL:TCH 65"
20 OUTPUT 714;"SETUP:TXP:CONT OFF"
30 OUTPUT 714;"SETUP:PFER:CONT OFF"
40 OUTPUT 714;"CALL:TCH:WAIT"
50 OUTPUT 714;"INIT:TXP;PFER"
60 END

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and execute two setup commands. After the two setup commands have finished, the :WAIT command is sent to prevent the test set from executing the INITiate command until the handover is finished.

:OPComplete?

Places a 1 in the test set's output queue when the associated command's pending operation flag goes false. Controlling program hangs on this query until the 1 is retrieved.

10 OUTPUT 714;"CALL:TCH 65"
20 OUTPUT 714;"SETUP:TXP:CONT OFF"
30 OUTPUT 714;"SETUP:PFER:CONT OFF"
40 OUTPUT 714;"CALL:TCH:OPC?"
50 ENTER 714;Op_complete
60 OUTPUT 714;"INIT:TXP;PFER"
70 END

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and execute two setup commands. After the two setup commands have finished, the :OPC? command is sent to hang program execution until a 1 is put in the test set's output queue, satisfying the ENTER statement and allowing program execution to continue with the INITiate command.

Operating Considerations

When using the call processing subsystem overlapped command synchronization commands, check the conditions that set the operation's pending operation flag (POF) false to avoid unexpected results.

Call Processing Subsystem Overlapped Commands

Overlapped Commands
Call Processing Command | Purpose Of Command | Pending Operation Flag (POF) is false when
CALL:FUNCtion:DATA:STARt | Attempts to open the connection. | The data connection state is any non-transitory state (that is, idle, session open, or connected).
CALL:DCONnected:ARM[:IMMediate] | Arms the data connection state change detector. | The call control status change detector has been disarmed. See Data Connection State Change Detector .

Related Topics

Test System Synchronization Overview


Data Connection State Synchronization

Data Connection State Synchronization

Last updated: April 14, 2005

One of the most important and difficult aspects of synchronizing the external controller, test set and DUT is synchronizing the movement between data connection states. There are several specialized commands available to help you determine the state of the data connection, and verify that data connection processing events were successful.

Data Connection Query Summary

The suggested usage of these data connection queries is as follows:

Data Connection Query Usage
Query | Description | Suggested Usage | Programming Example
CALL:STATus[:STATe]:DATA? | Queries the status of the data connection. Immediately returns the state: CCL|CNEG|CREQ|DCON |DORM|HAND|IDLE|PAG| SCL|SNEG|SOP|UREQ. | Use after a handoff to verify the data connection state is still "connected". | Hand Off to a New Channel or Band
The following non-transitory state queries are most useful in conjunction with the Data Connection State Change Detector . For more information about which data connection states are transitory and non-transitory, see TAP Data Connection Processing Lifecycle and Packet Data Connection Processing Lifecycle .
CALL:IDLE[:STATe]:DATA? | Queries whether or not the data connection is in the idle state. Immediately returns 1 or 0, or waits for a state change if the Data Connection State Change Detector is armed. | Use with the Data Connection State Change Detector to verify that your attempt to close the session was successful. | Close the Session
CALL:SOPen[:STATe]? | Queries whether or not the data connection is in the session open state. Immediately returns 1 or 0, or waits for a state change if the Data Connection State Change Detector is armed. | Use with the Data Connection State Change Detector to verify that your attempt to open a session was successful, or to verify your attempt to close a connection (and preserve the session) was successful. | Establish a Session from the Access Terminal , or Close the Connection
CALL:DCONnected[:STATe]? | Queries whether or not the data connection is in the connected state. Immediately returns 1 or 0, or waits for a state change if the Data Connection State Change Detector is armed. | Use with the Data Connection State Change Detector to verify that your attempt to open a connection was successful. | Open a Connection from the Test Set
CALL:DORMant[:STATe]? ( Lab Application Only ) | Queries whether or not the packet data connection is in the dormant state. Immediately returns 1 or 0, or waits for a state change if the Data Connection State Change Detector is armed. | Use with the Data Connection State Change Detector to verify that your attempt to force the connection to dormant was successful. |

Data Connection State Change Detector

The data connection state change detector is useful when you expect a change in the data connection state, and want to know when it is complete. The change detector is used in conjunction with the non-transitory state queries (CALL:IDLE:DATA?, CALL:SOPen?, CALL:DORMant? and CALL:DCONnected?). For more information about which data connection states are transitory and non-transitory, see TAP Data Connection Processing Lifecycle when the test set is configured to use the Test Application protocols ( Test Application Protocol ). In the lab application, when the test set is configured to use the Default Packet Application ( Session Application Type ), see Packet Data Connection Processing Lifecycle for more information about which data connection states are transitory and non-transitory.

  • If the change detector is not armed when any of these data connection queries are sent:
    • If the data connection is in a non-transitory state (idle, session open, dormant or connected), the test set immediately returns 1 or 0.
    • If the data connection is in a transitory state, the test set waits until the data connection reaches a non-transitory state, and then returns 1 or 0.
  • The queries' behavior is different when the change detector is armed. When you arm the change detector, the test set notes what the initial data connection state is. Then, when any of these data connection queries are sent, the test set does not return the state of the data connection until there has been a change from the initial state to a new non-transitory state. The change detector "holds off" the data connection queries to wait for a change from the initial state to a non-transitory state that is different from the initial state.

Arming the Data Connection State Change Detector

The data connection state change detector is automatically armed by the test set when data connection processing operations originating from the test set are requested.

When the test set is configured to use the Test Application protocols (see Test Application Protocol ), the operations that can be originated from the test set are as follows:

  • open a connection using the command: CALL:FUNCtion:DATA:STARt
  • close a connection using the command: CALL:FUNCtion:DATA:STOP
  • close a session using the command: CALL:SCLose

For the lab application , when the test set is configured to use the Default Packet Application protocols (see Session Application Type ), the operations that can be originated from the test set are as follows:

  • force a packet data connection to Dormant state using the command: CALL:FUNCtion:DATA:DORMant
  • close a session using the command: CALL:SCLose

You only need to arm the change detector to hold off the data connection queries when you are opening or closing a session or connection from the AT.

Arm the change detector using the CALL:DCONnected:ARM[:IMMediate] command.

Data Connection State Change Detector Timeout

The data connection state change detector includes a timeout that you can set to limit the amount of time that the test set will wait for a change in the data connection state. The timer begins when the change detector is armed or rearmed when already armed. The duration of this timeout is set using the CALL:DCONnected:TIMeout command and should be greater than the maximum amount of time the control program needs to wait between arming the data connection state change detector and the data connection operation starting. Once the process starts and the data connection state has moved to one of the transitory states, the protocol timers take over and prevent the data channel's state from staying in a transitory state forever. If the timer expires, the change detector is disarmed, and the data connection query returns 1 or 0 as soon as any non-transitory state is reached. The timeout is user-settable, but the user setting is only applied during AT originated data connection processing operations. For test set originated operations, the timeout is automatically set to 60 seconds by the test set.

Disarming the Data Connection State Change Detector

In summary, the change detector is disarmed by:

  • a change from the initial non-transitory state to a new non-transitory state
  • a change from the initial transitory state to any non-transitory state
  • the change detector timeout expiring
  • one of the test set's fixed timers expiring (see Fixed Timer Messages )

When the change detector is disarmed, the query returns 1 or 0 as soon as a non-transitory state is reached.

Access Terminal Session Establishment - Arming the Change Detector

The following example illustrates the use of the data connection state change detector along with the CALL:SOPen? query to synchronize a controlling application with a data connection processing state change during an AT-initiated session establishment.

When the CALL:DCONnected:ARM command is received by the test set, the change detector becomes armed and configures the test set to hold off on returning a result for the CALL:SOPen? query until the detector is disarmed by one of the four events described above.

10    OUTPUT 714;"CALL:DCONnected:TIMeout 10S" ! Sets the change detector
20                                             ! timeout to 10 seconds.
30    OUTPUT 714;"CALL:DCONnected:ARM" ! Arm the change detector
35	                                     ! (initial state is noted, timeout timer starts).
40    DISP "Establish a session from the access terminal. Continue when done."
50    PAUSE
60    OUTPUT 714;"CALL:SOPen?" ! The session open query.
70    ENTER 714;Session_open
80    IF Session_open=1 THEN
90      DISP "Session is open."
100     WAIT 2
110   ELSE
120     DISP "Session is not open."
130     WAIT 2
140   END IF
150   END

Related Topics

Test System Synchronization Overview


Test System Synchronization Overview

Test System Synchronization Overview

Last updated: April 14, 2005

Description

Typical test systems include an external controller with a GPIB connection to the test set, an RF (and possible AF) connection between the test set and a mobile station under test, and a serial connection between the mobile station and the external controller.

Synchronizing an external controller with the test set and a mobile station under test ensures that no device does something before it is supposed to, which can cause errors, or does something well after it could have, which wastes time.

Test System

Sequential versus overlapped commands

The test set uses both sequential and overlapped commands:

  • Sequential commands must finish executing before the next command starts to execute.
  • Overlapped commands do not finish executing before the next command starts to execute.

Overlapped commands are more difficult to synchronize because an overlapped operation that started several commands earlier may still be executing as subsequent commands are being parsed out from the input buffer and executed. This can present a problem unless the external controller is properly synchronized to the test set's execution of commands. Overlapped commands allow the test set to use its internal resources as efficiently as possible.

Methods for synchronization

The test set's GPIB command set supports the following methods to achieve synchronization for overlapped commands. In some cases, combinations of these methods will provide the best results:

Methods one and two do not require the external controller to query the test set, nor to perform any branching or decision-making associated with information acquired from the test set.

Methods three through six rely on responses from the test set to an external controller, indicating that some event has occurred. The external controller can then make decisions based on these responses to control the flow of commands to the test set and other devices in the test system.

  1. Force the test set to execute overlapped commands sequentially.
  2. Force the test set to wait until an overlapped command is done executing before executing any more commands.
  3. Query the test set to determine when a command has finished executing.
  4. Query the test set to determine when all commands sent to it have at least begun executing.
  5. Query the test set to determine the current call or data connection processing state.
  6. Program the test set to generate a service request when an operation has completed or the test set is in a certain state.

Commands used for synchronization:

  • :SEQ
    This specialized command can be appended to data connection processing overlapped commands to support synchronization method one. See Call Processing Subsystem Overlapped Command Synchronization Commands .

  • :WAIT
    This specialized command can be appended to data connection processing overlapped commands to support synchronization method two. See Call Processing Subsystem Overlapped Command Synchronization Commands

  • :DONE? and :OPC?
    These specialized commands can be appended to data connection processing overlapped commands to support synchronization method three. See Call Processing Subsystem Overlapped Command Synchronization Commands .

  • :INITiate:DONE?
    This specialized command causes the test set to return a mnemonic indicating if a measurement is done. If not, the returned mnemonic will indicate if the measurement is still executing. This command supports synchronization method three. See INITiate:DONE? and Measurement Event Synchronization .

  • CALL:STATus
    This command queries the test set's current data connection processing state. This command supports synchronization method five. See CALL:STATus[:STATe]:DATA? and Data Connection State Synchronization .

  • CALL:IDLE:DATA?, CALL:SOPen?, CALL:DCONnected?, CALL:DORMant?
    These commands determine the idle/session open/connected/dormant state of the data connection. A feature called the change detector provides the user with a way to hold off the response to these queries until a data connection processing state transition has taken place. These commands support synchronization method five. See CALL:IDLE[:STATe]:DATA? , CALL:SOPen[:STATe]? , CALL:DCONnected[:STATe]? , CALL:DORMant[:STATe]? , and Data Connection State Synchronization .

  • SYSTem:SYNChronized
    This specialized command puts a 1 in the test set's output queue. The test set responds to the query by sending a 1 to the external controller indicating that all prior sequential commands have completed, and all prior overlapped commands have at least begun execution. The condition bit is set then cleared. This command supports synchronization four and six. See SYSTem:SYNChronized . See STATus:OPERation Condition Register Bit Assignments .

  • STATUS:<register>
    Status bits in the STATus:OPERation:CALL:COMMon:DATA Condition Register Bit Assignment register are provided to indicate the test set's data connection processing state. These bits support synchronization methods five and six.
    Status bits in the STATus:OPERation:NMRReady:CDMA Condition Register Bit Assignments , STATus:OPERation:NMRReady:COMMon Condition Register Bit Assignments , and STATus:OPERation:NMRReady:DIGital856 Condition Register Bit Assignments are provided to indicate when a measurement is ready to be fetched. These bits support synchronization method three and six.
    Many other status bits are provided in the GPIB status subsystem that are useful for synchronization. See STATus Subsystem .

  • *OPC , *OPC? , and *WAI (not recommended)
    Note: These commands look at all of the test set's operations collectively. Because multiple processes are likely to be executing at the same time, it is recommended that the other commands above be used instead.

Related Topics

Data Connection Processing Event Synchronization


Triggering of Measurements

Triggering of Measurements

Last updated: April 14, 2005

Description

  • Trigger Source Description
  • Triggering Process Description
  • Trigger Arm (Single or Continuous) Description
  • Trigger Delay Description
  • Trigger Qualification Description

Trigger Source Description

A measurement trigger causes hardware (for example, a sampler) to capture data which is used by a measurement algorithm to produce a measurement result. Not all of the trigger source choices are available in every measurement, or every test application.

RF Rise Trigger Source:

When RF rise triggering is selected, a measurement dependent threshold is used to define the trigger point on the envelope of the signal being measured. The envelope amplitude must fall below this threshold and remain there for a measurement-dependent period of time before the trigger is armed. After the trigger is armed, a trigger will occur as the envelope amplitude increases and passes through the threshold.

Protocol Trigger Source:

When protocol triggering is selected, a data capture is triggered by a protocol generated signal. The test set's protocol engine knows when the DUT's signal should be present and generates a trigger signal for use by the measurement to trigger the data capture.

External Trigger Source:

When external triggering is selected, the user supplies an external trigger signal via the rear panel TRIG IN connector in order to trigger data capture. The trigger will occur on the rising edge of this signal.

Immediate Trigger Source:

When immediate triggering selected, the trigger occurs as soon as any pre-trigger samples required by the measurement algorithm are taken. Data capture is triggered when the measurement is initiated.

Auto Trigger Source:

When auto triggering is selected, the test set automatically chooses the best trigger source for that measurement. This trigger source setting is convenient because the measurement trigger doesn't need to be changed when switching parameters. Auto trigger source is the best choice for most users.

Triggering Process Description

The triggering process controls the present and future states of the test set during the measurement cycle. Triggers are set up using the SETup commands and can be set up when a measurement is in the inactive state. A measurement is activated (selected) with an INITiate command. If a measurement is initiated while in its measurement cycle, it will terminate that measurement and restart it. The active state is not a single state but a collection of any state other than the inactive state. Deactivating (de-selecting) the measurement is accomplished through an INITiate:<MEAS>:OFF command.

Manually, a measurement is activated by selecting it from the Measurement Selection menu. A measurement is deactivated by pressing the Measurement Selection key, scrolling to measurement in the Measurement Selection menu, and then pressing F4 (Close Measurement) .

The Test Set's Measurement States

Measurement States

The following examples describe states of the test set under various conditions. Refer to The Test Set's Measurement States .

Inactive State

If the test set has just been powered on, or any form of preset has been performed, then the measurement state is inactive.

Wait for Trigger State

If a measurement has been initiated with the INITiate command but has not been triggered, or a measurement has been selected from the Measurement Selection menu but has not been triggered, then the measurement state is wait for trigger.

Measuring and Idle States (Trigger Arm Single)

If the trigger arm is set to single, the trigger source is available, and the trigger qualifier (optional) is satisfied, the measurement state transitions to measuring and measurement results are now available to the user. The state then transitions to idle (awaiting another INITiate).

Measuring State (Trigger Arm Continuous)

If the trigger arm is set to continuous, the trigger source is available, and the trigger qualifier (optional) is satisfied, the measurement state transitions to measuring and measurement results are now available to the user. The measurement is continually triggered until the measurement is deactivated. Measurement results are only available after the measurement completes and before it rearms. The measurement is deactivated using the INITiate:<MEAS>:OFF. or Close Measurement .

Trigger Arm (Single or Continuous) Description

Trigger arm determines if a measurement will make one measurement then return to idle (single), or automatically rearm on completion of a measurement and repeat the process (continuous).

NOTE
When operating the test set remotely, the recommended setting for the trigger arm parameter is single. This ensures proper operation of the INIT:DONE? query which is used to control the retrieval of measurement results when measurements are initiated concurrently.

When a continuously armed measurement gets a result, it is available to any currently pending (waiting, hanging) FETCh? query. Then another measurement cycle is started immediately. At this point the results are no longer valid. The INIT:DONE? query is used to determine when there is a completed measurement with valid results that can be fetched. If you look for a continuously armed measurement with valid results that can be fetched using INIT:DONE? then you are unlikely to get anything but WAIT. Each time the Test Set is queried, it is 99% likely to be making another measurement. Even if it did return a measurement name, by the time the control program determines which FETCh? query to send, it is too late to fetch the results and the FETCh? query just hangs until the next measurement cycle is done, nullifying the efficiency provided by the INIT:DONE? query.

Pressing the Start Single key on the front panel will cause all currently active measurements with trigger arm set to single to arm and make the measurement.

Pressing Shift, Start Single (Stop) causes all measurements with trigger arm set to single to abort the measurement.

It is unnecessary for you to arm a measurement if the trigger arm is set to continuous. When in continuous mode, the measurement is automatically rearmed after completing a measurement.

Trigger Arm Default Settings
Action | Trigger Arm Default Setting
Power up of test set | Continuous
Manual Full Preset | Continuous
*RST (Remote) Full Preset | Single
Partial Preset | No change

Trigger Delay Description

Trigger delay controls the delay time between the trigger and the start of sampling. Resolution is 1 nanosecond per measurement and the units are in seconds. A negative value indicates the sampling should occur prior to the trigger. The default is zero seconds which is preferred for most measurements.

Trigger Qualification Description

When Trigger Qualification is on, the test set samples the input signal when a trigger is received. It then determines if the input signal was valid by looking at its power level. If the power level during sampling did not meet the requirements of a valid signal, the state returns to wait for trigger without processing the samples. If a valid signal is present, then it is qualified, and the samples are processed.

Related Topics

Integrity Indicator


Programming a Time Response of Open Loop Power Control (TROLPC) Measurement

Programming a Time Response of Open Loop Power Control (TROLPC) Measurement

Last updated: May 24, 2006

The following example is based on an RTAP data connection for subtype 0 physical layer test. The general procedure is also applicable to the test based on an RETAP data connection. See Control Program Examples for the comprehensive test programs.

General Programming Procedure

  1. Prompt the user to connect the access terminal to the test set's front panel RF IN/OUT connector and power it on. Instruct the user that if the access terminal does not automatically open a session, perform whatever actions are necessary to open a session. See Establish a Session from the Access Terminal for more details.
  2. Prompt the user to establish an RTAP data connection. See Step 4: Make a connection for more details.
  3. Set up the TROLPC measurement parameters as needed using the SETup:TROPower commands.
  4. Disable the R-ACK Channel by turning CALL[:CELL]:APPLication:ACKChannel:BFMAttribute[:STATe] to off and setting CALL[:CELL]:APPLication:ATDPackets to 0%.
  5. Set cell power using the CALL:POWer command. (Set cell power to -60 dBm/1.23 MHz when performing C.S0033 test 4.3.2).
  6. Specify the direction of the step change in cell power using the SETup:TROPower:STEP command. When the measurement is initiated, the test set will change its cell power in the direction indicated by this command.
  7. Initiate the TROLPC measurement using the INITiate:<measurement mnemonic>[:ON] command. The <measurement mnemonic> for the TROLPC measurement is TROPower. When the TROLPC measurement is initiated, the test set will change its cell power by 20 dB, and then measure the access terminal power for 100 ms.
  8. Use the FETCh:TROPower[:ALL]? command to obtain the measurement results. (You can also replace steps 7 and 8 with a single command - READ:TROPower[:ALL]? ).
  9. You must repeat steps 6 - 8 to test each 20 dB step change.
  10. A pass or fail indication is returned for each measurement.
  11. In addition to retrieving the pass/fail result, you can retrieve data points representing the access terminal output power trace using the FETCh:TROPower:TRACe? command. You can then compare the data points to the equations for the mask (see 4.3.2 Time Response of Open Loop Power Control ) to determine any failure points.

Programming Example: 4.3.2 Time Response of Open Loop Power Control

10 ! 4.3.2 Time Response of Open Loop Power Control
20 ! This programming example assumes the access terminal
30 ! is connected to the test set and in a 9.6 kbps
40 ! RTAP data connection.
50 !
60       Testset=714
70 !
80       DISP "Testing Time Response of Open Loop Power Control"
90 !
100 !***Set up test parameters***
110 !
120       Ior=-60
130       ! Start Level for test
140 !
150 !***Set up measurement parameters***
160 !
170       OUTPUT Testset;"SETUP:TROP:TIMEOUT 5"
180       ! Set mesurement timeout to 5 s
190 !
200 !***Set test conditions***
210 !
220       OUTPUT Testset;"CALL:APPLICATION:ACKCHANNEL:BFMATTRIBUTE OFF"
230       ! Turn off ACK Channel Bit Fixed Mode Attribute
240       OUTPUT Testset;"CALL:APPLICATION:ATDPACKETS 0"
250       ! Set AT Directed Packets to 0 to disable R-ACK Channel
260       OUTPUT Testset;"CALL:POW ";Ior
270       ! Set cell power for Test
280       WAIT .1
290       ! Open Loop Time Response settling time after cell power change
300 !
310       CLEAR SCREEN
320       PRINT "Time Response of Open Loop Power Test Results:"
330 !
340       FOR J=1 TO 4
350       ! Loop to measure power after 4 step changes in cell power
360           SELECT J
370           ! Set step direction for each measurement
380           CASE 1
390               Test_number=J
400               Step$="UP20"
410           CASE 2
420               Test_number=J
430               Step$="DOWN20"
440           CASE 3
450               Test_number=J
460               Step$="DOWN20"
470           CASE 4
480               Test_number=J
490               Step$="UP20"
500           END SELECT
510 !
520 !***Obtain measurement results***
530 !
540           OUTPUT Testset;"SETUP:TROP:STEP "&Step$
550           ! Set step direction for measurement
560           OUTPUT Testset;"READ:TROP?"
570           ! Initiate Time Response of Open Loop measurement,
580           ! which automatically induces step change in direction
590           ! set by SETUP:TROP:STEP, then fetch results
600           ENTER Testset;Integrity,Pass_fail
610 !
620           SELECT Pass_fail
630           ! Assign pass/fail results to a string
640           CASE 0
650               Pass_fail$="PASS"
660           CASE 1
670               Pass_fail$="FAIL"
680           CASE ELSE
690               Pass_fail$="ERROR"
700           END SELECT
710 !
720 !***Print measurement results***
730 !
740           PRINT
750           PRINT "Test Number "&VAL$(Test_number)
760           PRINT "Integrity Indicator = ",Integrity
770           PRINT "TROLPC Test Result  = ",Pass_fail$
780 !
790       NEXT J
800 !
810       PRINT
820       PRINT "Test 1 is +20 dB change"
830       PRINT "Test 2 is -20 dB change"
840       PRINT "Test 3 is -20 dB change"
850       PRINT "Test 4 is +20 dB change"
860       PRINT
870       PRINT "Time Response of Open Loop Power Control Test Complete"
880 !
890 !***Post test clean up***
900 !
910       OUTPUT Testset;"INIT:TROP:OFF"
920       ! Turn off measurement
930       OUTPUT Testset;"CALL:APPLICATION:ACKCHANNEL:BFMATTRIBUTE ON"
940       ! Turn ACK Channel Bit Fixed Mode Attribute back on
950       OUTPUT Testset;"CALL:APPLICATION:ATDPACKETS 50"
960       ! Set AT Directed Packets back to default value of 50%
970       OUTPUT Testset;"CALL:POW -55"
980       ! Set cell power back to initial level
990       DISP ""
1000 !
1010       END

Related Topics

Time Response of Open Loop Power Control (TROLPC) Measurement Description

Manual Operation: Measuring Time Response of Open Loop Power Control (TROLPC)


E1966A and E6706A Applications: GPIB Command Revision Information

E1966A and E6706A Applications: GPIB Command Revision Information

Last updated: July 31, 2006

The table below indicates new and revised GPIB commands for the 1xEV-DO test and lab applications at each release.

  • GPIB Changes for E1966A A.06.06, E6706A A.03.06 - July 2006
  • GPIB Changes for E1966A A.05.11, E6706A A.02.21 - January 2006
  • GPIB Changes for E6706A A.02 Beta Release - August 2005
  • GPIB Changes for E6706A A.01.10 - April 2005 (in addition to all commands available in the E1966A A.03 releases)
GPIB Changes for E1966A A.06.06, E6706A A.03.06 - July 2006
GPIB Command | New | Revised | Test Application | Lab Application
ABORt:CFDTune (see ABORt ) | X |  | X* | X
CALL[:CELL]:APARameter:POWer:OLADjust:USPCs1900 (see CALL:APARameter ) | X |  | X | X
CALL[:CELL]:APPLication:ACKChannel:MODulation | X |  | X* | X
CALL[:CELL]:APPLication:DATA[:REVerse]:PACKet[:SIZE] | X |  | X* | X
CALL[:CELL]:APPLication:DATA[:REVerse]:TRANsmission[:MODE] | X |  | X* | X
CALL[:CELL]:APPLication:DRCChannel:VFMAttribute[:STATe] | X |  | X* | X
CALL[:CELL]:APPLication:EACCess:DRATe | X |  | X* | X
CALL[:CELL]:APPLication:ETAPlication[:TYPE] | X |  | X* | X
CALL[:CELL]:APPLication:TRAFfic:FORMat | X |  | X* | X
CALL[:CELL]:APPLication:TRAFfic:PACKet:CONFigure | X |  | X* | X
CALL[:CELL]:APPLication:TRAFfic:PDURation:MAXimum | X |  | X* | X
CALL[:CELL]:APPLication:TRAFfic:SPACket:THReshold | X |  | X* | X
CALL[:CELL]:CONTrol:CATTribute:RTCMac3:DARTe:KBPS1843[:SUPPort] | X |  | X* | X
CALL[:CELL]:PROTocol[:SELected] | X |  | X | X
CALL[:CELL]:PROTocol:DIGital856 | X |  | X | X
CALL[:CELL]:PROTocol:ACMac | X |  | X* | X
CALL[:CELL]:PROTocol:PLAYer | X |  | X* | X
CALL:BAND |  | X | X | X
CALL:CHANnel[:SELected]:USPCs1900 (see CALL:CHANnel ) | X |  | X | X
CALL:CHANnel:DIGital856:USPCs1900 (see CALL:CHANnel ) | X |  | X | X
CALL:COUNt:CLEar:MS:TRAFfic:HISTogram | X |  |  | X
CALL:COUNt:MS:DRC:RX:HISTogram[:ALL]? | X |  |  | X
CALL:COUNt:MS:DRC:RX:HISTogram:SPAN | X |  |  | X
CALL:COUNt:MS:DRC:RX:S16Bps4800:DRC01? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S16Bps9600:DRC01? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S16Bps19200:DRC01? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S08Bps9600:DRC02? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S08Bps19200:DRC02? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S08Bps38400:DRC02? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S04Bps19200:DRC03? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S04Bps38400:DRC03? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S04Bps76800:DRC03? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S02Bps38400:DRC04? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S02Bps76800:DRC04? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S02Bps153600:DRC04? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S04Bps76800:DRC05? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S04Bps153600:DRC05? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S01Bps76800:DRC06? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S01Bps153600:DRC06? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S01Bps307200:DRC06? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S02Bps153600:DRC07? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S02Bps307200:DRC07? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S02Bps307200:DRC08? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S01Bps307200:DRC09? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S01Bps614400:DRC09? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S01Bps614400:DRC11? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S02Kbps1536[:DRC13]? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S01Kbps3072[:DRC14]? | X |  |  | X
CALL:COUNt:MS:PPRate:TX:BPS4800[:BIT128]? | X |  |  | X
CALL:COUNt:MS:PPRate:TX:BPS28800[:BIT768]? | X |  |  | X
CALL:COUNt:MS:PPRate:TX:BPS57600[:BIT1536]? | X |  |  | X
CALL:COUNt:MS:PPRate:TX:BPS115200[:BIT3072]? | X |  |  | X
CALL:COUNt:MS:PPRate:TX:BPS230400[:BIT6144]? | X |  |  | X
CALL:COUNt:MS:PPRate:TX:BPS307200[:BIT8192]? | X |  |  | X
CALL:COUNt:MS:PPRate:TX:BPS460800[:BIT12288]? | X |  |  | X
CALL:MACChannel:ARQ:LEVel | X |  | X* | X
CALL:MACChannel:ARQ:ACK:DATA[:REVerse][:AFTer] | X |  | X* | X
CALL:MACChannel:HARQ:MODulation | X |  | X* | X
CALL:MACChannel:PARQ:LEVel | X |  | X* | X
CALL:MACChannel:RPControl:LEVel | X |  | X* | X
CALL:MS:APGain[:RTTRaffic] | X |  | X* | X
CALL:MS:APPayload[:MINimum] | X |  | X* | X
CALL:MS:DSCGain[:RTPilot] | X |  | X* | X
CALL:MS:DSCLength[:SLOTs] | X |  | X* | X
CALL:MS:POWer:MAXimum:USPCs1900 (see CALL:MS ) | X |  | X | X
CALL:MS:RRIGain[:RTPilot]:TRANsition0:PRE | X |  | X* | X
CALL:MS:RRIGain[:RTPilot]:TRANsition0:POST | X |  | X* | X
CALL:MS:RRIGain[:RTPilot]:TRANsition1:PRE | X |  | X* | X
CALL:MS:RRIGain[:RTPilot]:TRANsition1:POST | X |  | X* | X
CALL:MS:RRIGain[:RTPilot]:TRANsition2:PRE | X |  | X* | X
CALL:MS:RRIGain[:RTPilot]:TRANsition2:POST | X |  | X* | X
CALL:MS:RRIGain[:RTPilot]:TRANsition3:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT128:LLATency:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BI256:LLATency:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT512:LLATency:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT768:LLATency:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT1024:LLATency:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT1536:LLATency:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT2048:LLATency:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT3072:LLATency:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT4096:LLATency:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT6144:LLATency:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT8192:LLATency:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT12288:LLATency:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT128:LLATency:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BI256:LLATency:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT512:LLATency:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT768:LLATency:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT1024:LLATency:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT1536:LLATency:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT2048:LLATency:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT3072:LLATency:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT4096:LLATency:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT6144:LLATency:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT8192:LLATency:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT12288:LLATency:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT128:LLATency:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BI256:LLATency:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT512:LLATency:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT768:LLATency:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT1024:LLATency:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT1536:LLATency:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT2048:LLATency:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT3072:LLATency:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT4096:LLATency:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT6144:LLATency:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT8192:LLATency:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT12288:LLATency:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT128:LLATency:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BI256:LLATency:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT512:LLATency:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT768:LLATency:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT1024:LLATency:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT1536:LLATency:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT2048:LLATency:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT3072:LLATency:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT4096:LLATency:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT6144:LLATency:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT8192:LLATency:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT12288:LLATency:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT128:HCAPacity:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BI256:HCAPacity:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT512:HCAPacity:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT768:HCAPacity:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT1024:HCAPacity:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT1536:HCAPacity:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT2048:HCAPacity:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT3072:HCAPacity:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT4096:HCAPacity:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT6144:HCAPacity:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT8192:HCAPacity:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT12288:HCAPacity:TARGet[:TERMination] | X |  | X* | X
CALL:MS:T2Pilot:BIT128:HCAPacity:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BI256:HCAPacity:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT512:HCAPacity:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT768:HCAPacity:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT1024:HCAPacity:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT1536:HCAPacity:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT2048:HCAPacity:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT3072:HCAPacity:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT4096:HCAPacity:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT6144:HCAPacity:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT8192:HCAPacity:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT12288:HCAPacity:TRANsition | X |  | X* | X
CALL:MS:T2Pilot:BIT128:HCAPacity:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BI256:HCAPacity:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT512:HCAPacity:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT768:HCAPacity:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT1024:HCAPacity:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT1536:HCAPacity:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT2048:HCAPacity:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT3072:HCAPacity:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT4096:HCAPacity:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT6144:HCAPacity:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT8192:HCAPacity:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT12288:HCAPacity:TRANsition:PRE | X |  | X* | X
CALL:MS:T2Pilot:BIT128:HCAPacity:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BI256:HCAPacity:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT512:HCAPacity:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT768:HCAPacity:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT1024:HCAPacity:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT1536:HCAPacity:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT2048:HCAPacity:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT3072:HCAPacity:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT4096:HCAPacity:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT6144:HCAPacity:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT8192:HCAPacity:TRANsition:POST | X |  | X* | X
CALL:MS:T2Pilot:BIT12288:HCAPacity:TRANsition:POST | X |  | X* | X
CALL:SETup:BAND[:SELected] (see CALL:SETup ) |  | X | X | X
CALL:SETup:BAND:DIGital856 (see CALL:SETup ) |  | X | X | X
CALL:SETup:CHANnel[:SELected]:USPCs1900 (see CALL:SETup ) | X |  | X | X
CALL:SETup:CHANnel:DIGital856:USPCs1900 (see CALL:SETup ) | X |  | X | X
CALL:STATus:APPLication:DATA[:REVerse]:PACKet[:SIZE]? | X |  | X* | X
CALL:STATus:APPLication:DATA[:REVerse]:TRANsmission[:MODE]? | X |  | X* | X
CALL:STATus:APPLication:EACCess:DRATe:EXPected? | X |  | X* | X
CALL:STATus:MS:AUTO:POWer:POST? | X |  | X* | X
CALL:STATus:MS:T2Pilot:GAIN:PRE? | X |  | X* | X
CALL:STATus:MS:T2Pilot:GAIN:POST? | X |  | X* | X
CALL:STATus:MS:T2Pilot:TRANsition? | X |  | X* | X
CALL:STATus:MS:TRAFfic:DRATe:KBPS1843[:SUPPort]? | X |  | X* | X
CALL:STATus:PROTocol:ACMac? | X |  | X* | X
CALL:STATus:PROTocol:PLAYer? | X |  | X* | X
FETCh:CFDTune[:ALL]? | X |  | X* | X
FETCh:CFDTune:INTegrity? | X |  | X* | X
FETCh:DOWQuality:PAYLoad? | X |  | X* | X
FETCh:DOWQuality:CDPower:DATA[:REVerse]:RTPilot? | X |  | X* | X
FETCh:DOWQuality:CDPower:DSCChannel[:REVerse]? | X |  | X* | X
FETCh:DOWQuality:CDPower:PILot:AUXiliary[:REVerse]? | X |  | X* | X
FETCh:DOWQuality:CDPower:ICHannel:BIN? <bin num> |  | X | X | X
FETCh:DOWQuality:CDPower:ICHannel:COUNt[:BIN]? |  | X | X | X
FETCh:DOWQuality:CDPower:QCHannel:BIN? <bin num> |  | X | X | X
FETCh:DOWQuality:CDPower:QCHannel:COUNt[:BIN]? |  | X | X | X
FETCh:DOWQuality:CDPower32:ICHannel[:ALL]? | X |  | X* | X
FETCh:DOWQuality:CDPower32:QCHannel[:ALL]? | X |  | X* | X
FETCh:DOWQuality:CDPNoise:ICHannel:BIN? <bin num> |  | X | X | X
FETCh:DOWQuality:CDPNoise:ICHannel:COUNt[:BIN]? |  | X | X | X
FETCh:DOWQuality:CDPNoise:QCHannel:BIN? <bin num> |  | X | X | X
FETCh:DOWQuality:CDPNoise:QCHannel:COUNt[:BIN]? |  | X | X | X
FETCh:DOWQuality:CDPNoise32:ICHannel[:ALL]? | X |  | X* | X
FETCh:DOWQuality:CDPNoise32:QCHannel[:ALL]? | X |  | X* | X
READ:CFDTune[:ALL]? | X |  | X* | X
INITiate:CFDTune[:ON] (see INITiate ) | X |  | X* | X
INITiate:CFDTune:ARMed? | X |  | X* | X
INITiate:CFDTune:OFF (see INITiate ) | X |  | X* | X
INITiate:DONE:FLAG:CFDTune (see INITiate ) | X |  | X* | X
SETup:CFDTune:FREQuency:STEP:COUNt | X |  | X* | X
SETup:CFDTune:MS:RX:FREQuency:STEP[:VALues] | X |  | X* | X
SETup:CFDTune:MS:RX:FREQuency:STEP:STARt:[INDex] | X |  | X* | X
SETup:CFDTune:MS:RX:POWer:STEP[:LEVels] | X |  | X* | X
SETup:CFDTune:MS:RX:POWer:STEP:STARt:[INDex] | X |  | X* | X
SETup:CFDTune:MS:TX:FREQuency:STEP[:VALues] | X |  | X* | X
SETup:CFDTune:MS:TX:FREQuency:STEP:STARt:[INDex] | X |  | X* | X
SETup:CFDTune:MS:TX:POWer:STEP[:LEVels] | X |  | X* | X
SETup:CFDTune:MS:TX:POWer:STEP:STARt:[INDex] | X |  | X* | X
SETup:CFDTune:POWer:STEP:COUNt | X |  | X* | X
SETup:CFDTune:TIMeout[:STIMe] | X |  | X* | X
SETup:CFDTune:TIMeout:STATe | X |  | X | X
SETup:CFDTune:TIMeout:TIME | X |  | X | X
SETup:DOWQuality:SLOT:COUNt:PLSubtype2 | X |  | X* | X
SYSTem:INSTrument:THERmal:POWer:NULL:ADJust? | X |  | X | X

* Only applicable to the lab application or feature-licensed test application.

GPIB Changes for E1966A A.05.11, E6706A A.02.21 - January 2006
GPIB Command | New | Revised | Test Application | Lab Application
CALL[:CELL]:CONTrol:CATTribute:ISTate:PCCCycle | X |  | X | X
CALL[:CELL]:CONTrol:DOWNlink:FREQuency:AUTO | X |  | X | X
CALL[:CELL]:CSTime:DATE | X |  | X | X
CALL[:CELL]:CSTime:LOCal:LEAP | X |  | X | X
CALL[:CELL]:CSTime:LOCal:OFFSet[:SELected] | X |  | X | X
CALL[:CELL]:CSTime:LOCal:OFFSet:TA856 | X |  | X | X
CALL[:CELL]:CSTime:TIME | X |  | X | X
CALL:CHANnel<[:SELected]|:DIGital856> <[:SELected]|:IMT2000|:JCDMa|:KPCS|:NMT450|:SECondary800|:USCellular|:USPCs|:USPCs1900> |  | X | X | X
CALL:DATA:PDSNode:EXTernal:TIMeout[:CONNect] |  | X |  | X
CALL:MS:REPorted:HIDentity[:DECimal]? |  | X | X | X
CALL:MS:REPorted:HIDentity:HEX? |  | X | X | X
CALL:MS:REPorted:HIDentity:TYPE? |  | X | X | X
CALL[:CELL]:OPERating:MODE |  | X | X | X
CALL:SCLose:TIMeout | X |  | X | X
CALL:SETup:CHANnel<[:SELected]|:DIGital856> <[:SELected]|:IMT2000|:JCDMa|:KPCS|:NMT450|:SECondary800|:USCellular|:USPCs|USPCs1900> |  | X | X | X
CALL:STATus:CCHannel:PCCCycle:NUMBer? | X |  | X | X
CALL:STATus:CCHannel:PCCCycle:STATe? | X |  | X | X
CALL:STATus:CSTime:LOCal:DATE? | X |  | X | X
CALL:STATus:CSTime:LOCal:TIME? | X |  | X | X
CALL:TEST856:MACIndex | X |  | X | X
CALL:TEST856:TRAFfic[:FORWard]:DRATe | X |  | X | X
CALL:TEST856:DCHannel:REVerse:DRATe | X |  | X | X
RFANalyzer:CONTrol:UPLink:FREQuency:AUTO | X |  | X | X
RFANalyzer:MANual:UPLink[:MFRequency] | X |  | X | X
SETup:CPERror:COUNt:MINimum | X |  | X | X
SETup:SMONitor:BANDwidth|BWIDth:AUTO | X |  | X | X
SETup:SMONitor:BANDwidth|BWIDth:MANual | X |  | X | X
SETup:SMONitor:DETector[:TYPE] | X |  | X | X
SYSTem:FATal:ERRor:RESTart | X |  | X | X
CALL:MS:REPorted:HIDentity[:DECimal]? |  | X | X | X
CALL:MS:REPorted:HIDentity:HEX? |  | X | X | X
CALL:MS:REPorted:HIDentity:TYPE? |  | X | X | X
CALL:SETup:CHANnel<[:SELected]|:DIGital856> <[:SELected]|:IMT2000|:JCDMa|:KPCS|:NMT450|:SECondary800|:USCellular|:USPCs|USPCs1900> |  | X | X | X
GPIB Changes for E6706A A.02 Beta Release - August 2005
GPIB Command | New | Revised | Test Application | Lab Application
CALL[:CELL]:CSTime:DATE | X |  |  | X
CALL[:CELL]:CSTime:LOCal:LEAP | X |  |  | X
CALL[:CELL]:CSTime:LOCal:OFFSet[:SELected] | X |  |  | X
CALL[:CELL]:CSTime:LOCal:OFFSet:TA856 | X |  |  | X
CALL[:CELL]:CSTime:TIME | X |  |  | X
CALL:SCLose:TIMeout | X |  |  | X
CALL:STATus:CSTime:LOCal:DATE? | X |  |  | X
CALL:STATus:CSTime:LOCal:TIME? | X |  |  | X
SYSTem:COMMunicate:LAN:EXTernal:ADDRess | X |  |  | X
SYSTem:COMMunicate:LAN:EXTernal:SYNChronize | X |  |  | X
SYSTem:COMMunicate:LAN:EXTernal:SYNChronize:INDication:CLEar | X |  |  | X
SYSTem:STATus:COMMunicate:LAN:EXTernal:SYNChronize:INDication? | X |  |  | X
GPIB Changes for E6706A A.01.10 - April 2005
GPIB Command | New | Revised | Test Application | Lab Application
ABORt:<measurement mnemonic> |  | X |  | X
CALL[:CELL]:APPLication:SESSion[:TYPE] | X |  |  | X
CALL[:CELL]:CONTrol:CATTribute:ISTate:PCCCycle | X |  |  | X
CALL[:CELL]:CONTrol:DOWNlink:FREQuency:AUTO | X |  |  | X
CALL:COUNt:CLEar:MS:IP | X |  |  | X
CALL:COUNt:CLEar:MS:RLP | X |  |  | X
CALL:COUNt:CLEar:MS:TRAFfic | X |  |  | X
CALL:COUNt:DTMonitor:CLEar | X |  |  | X
CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe:STARt | X |  |  | X
CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe:STOP | X |  |  | X
CALL:COUNt:DTMonitor[:ALL]:DISPlay:SPAN:TIME | X |  |  | X
CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory:UNUMber? | X |  |  | X
CALL:COUNt:DTMonitor:OTATx:DISPlay:STATe | X |  |  | X
CALL:COUNt:DTMonitor:OTARx:DISPlay:STATe | X |  |  | X
CALL:COUNt:DTMonitor:IPTX:DISPlay:STATe | X |  |  | X
CALL:COUNt:DTMonitor:IPRX:DISPlay:STATe | X |  |  | X
CALL:COUNt:DTMonitor:OTATx:DRATe? | X |  |  | X
CALL:COUNt:DTMonitor:OTARx:DRATe? | X |  |  | X
CALL:COUNt:DTMonitor:IPTX:DRATe? | X |  |  | X
CALL:COUNt:DTMonitor:IPRX:DRATe? | X |  |  | X
CALL:COUNt:DTMonitor:OTATx:TRACe? | X |  |  | X
CALL:COUNt:DTMonitor:OTARx:TRACe? | X |  |  | X
CALL:COUNt:DTMonitor:IPTX:TRACe? | X |  |  | X
CALL:COUNt:DTMonitor:IPRX:TRACe? | X |  |  | X
CALL:COUNt:DTMonitor:OTATx:TRACe:HISTory? | X |  |  | X
CALL:COUNt:DTMonitor:OTARx:TRACe:HISTory? | X |  |  | X
CALL:COUNt:DTMonitor:IPTX:TRACe:HISTory? | X |  |  | X
CALL:COUNt:DTMonitor:IPRX:TRACe:HISTory? | X |  |  | X
CALL:COUNt:MS:DRC:RX:ATDirected? | X |  |  | X
CALL:COUNt:MS:DRC:RX:HISTogram[:ALL]? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S16Bps38400[:DRC01]? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S08Bps76800[:DRC02]? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S04Bps153600[:DRC03]? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S02Bps307200[:DRC04]? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S04Bps307200[:DRC05]? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S01Bps614400[:DRC06]? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S02Bps614400[:DRC07]? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S02Bps921600[:DRC08]? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S01Kbps1229[:DRC09]? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S02Kbps1229[:DRC10]? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S01Kbps1843[:DRC11]? | X |  |  | X
CALL:COUNt:MS:DRC:RX:S01Kbps2458[:DRC12]? | X |  |  | X
CALL:COUNt:MS:IP[:ALL]? | X |  |  | X
CALL:COUNt:MS:IP:RX? | X |  |  | X
CALL:COUNt:MS:IP:TX? | X |  |  | X
CALL:COUNt:MS:PPRate:TX:BPS9600[:BIT256]? | X |  |  | X
CALL:COUNt:MS:PPRate:TX:BPS19200[:BIT512]? | X |  |  | X
CALL:COUNt:MS:PPRate:TX:BPS38400[:BIT1024]? | X |  |  | X
CALL:COUNt:MS:PPRate:TX:BPS76800[:BIT2048]? | X |  |  | X
CALL:COUNt:MS:PPRate:TX:BPS153600[:BIT4096]? | X |  |  | X
CALL:COUNt:MS:PPRate:TX:BPSNull[:BITNull]? | X |  |  | X
CALL:COUNt:MS:RLP:RX[:TOTal]:PACKets? | X |  |  | X
CALL:COUNt:MS:RLP:RX:DATA:NEW2? | X |  |  | X
CALL:COUNt:MS:RLP:RX:DATA:REXMitted2? | X |  |  | X
CALL:COUNt:MS:RLP:RX:NAK? | X |  |  | X
CALL:COUNt:MS:RLP:RX:NAKKed2? | X |  |  | X
CALL:COUNt:MS:RLP:RX:RESet? | X |  |  | X
CALL:COUNt:MS:RLP:TX[:TOTal]:PACKets? | X |  |  | X
CALL:COUNt:MS:RLP:TX:DATA:NEW2? | X |  |  | X
CALL:COUNt:MS:RLP:TX:DATA:REXMitted2? | X |  |  | X
CALL:COUNt:MS:RLP:TX:NAK? | X |  |  | X
CALL:COUNt:MS:RLP:TX:NAKKed2? | X |  |  | X
CALL:COUNt:MS:RLP:TX:RESet? | X |  |  | X
CALL:DATA:PING[:ALL]? | X |  |  | X
CALL:DATA:PING:ICOunt? | X |  |  | X
CALL:DATA:PING:PACKets:RX? | X |  |  | X
CALL:DATA:PING:PACKets:TX? | X |  |  | X
CALL:DATA:PING:PLOSs? | X |  |  | X
CALL:DATA:PING:SETup:ALTernate:IP:ADDRess | X |  |  | X
CALL:DATA:PING:SETup:COUNt | X |  |  | X
CALL:DATA:PING:SETup:DEVice | X |  |  | X
CALL:DATA:PING:SETup:TIMeout | X |  |  | X
CALL:DATA:PING:STARt | X |  |  | X
CALL:DATA:PING:STOP | X |  |  | X
CALL:DATA:PING:TIME[:AVERage]? | X |  |  | X
CALL:DATA:PING:TIME:MAXimum? | X |  |  | X
CALL:DATA:PING:TIME:MINimum? | X |  |  | X
CALL:DATA:PDSNode:EXTernal:IP:ADDRess | X |  |  | X
CALL:DATA:PDSNode:EXTernal:STATe | X |  |  | X
CALL:DATA:PDSNode:EXTernal:TCP:PORT | X |  |  | X
CALL:DATA:PDSNode:EXTernal:TIMeout[:CONNect] | X |  |  | X
CALL:DORMant[:STATe]? | X |  |  | X
CALL:FUNCtion:DATA:DORMant | X |  |  | X
CALL:MS:IP:ADDRess | X |  |  | X
CALL[:CELL]:OPERating:MODE |  | X |  | X
CALL:PLOGging:STARt | X |  |  | X
CALL:PLOGging:STOP | X |  |  | X
CALL:PLOGging<:STATus|STATe>? | X |  |  | X
CALL:PLOGging:CONNected? | X |  |  | X
CALL:PLOGging:ACTive? | X |  |  | X
CALL:PLOGging:DONE? | X |  |  | X
CALL:STATus:CCHannel:PCCCycle:NUMBer? | X |  |  | X
CALL:STATus:CCHannel:PCCCycle:STATe? | X |  |  | X
CALL:STATus[:STATe]:DATA? (added a new return value, DORM) |  | X |  | X
CALL:TEST856:MACIndex | X |  |  | X
CALL:TEST856:TRAFfic[:FORWard]:DRATe | X |  |  | X
CALL:TEST856:DCHannel:REVerse:DRATe | X |  |  | X
FETCh:GAPPower[:ALL][:RANGe20]? | X |  |  | X
FETCh:GAPPower[:ALL]:RANGe60? | X |  |  | X
FETCh:GAPPower:ICOunt? | X |  |  | X
FETCh:GAPPower:INTegrity? | X |  |  | X
FETCh:GAPPower:INTegrity20? | X |  |  | X
FETCh:GAPPower:INTegrity60? | X |  |  | X
FETCh:GAPPower:RTPRevious[:RANGe19]? | X |  |  | X
FETCh:GAPPower:RTPRevious:RANGe59? | X |  |  | X
FETCh:GAPPower:TIME[:RANGe19]? | X |  |  | X
FETCh:GAPPower:TIME:RANGe59? | X |  |  | X
INITiate:<measurement mnemonic>[:ON] |  | X |  | X
INITiate:<measurement mnemonic>:OFF |  | X |  | X
INITiate:DONE? |  | X |  | X
INITiate:DONE:FLAG:<measurement mnemonic> |  | X |  | X
INITiate:ON? |  | X |  | X
READ:GAPPower[:ALL][:RANGe20]? | X |  |  | X
READ:GAPPower[:ALL]:RANGe60? | X |  |  | X
RFANalyzer:CONTrol:UPLink:FREQuency:AUTO | X |  |  | X
RFANalyzer:MANual:UPLink[:MFRequency] | X |  |  | X
SETup:CPERror:COUNt:MINimum | X |  |  | X
SETup:GAPPower:TIMeout[:STIMe] | X |  |  | X
SETup:GAPPower:TIMeout:STATe | X |  |  | X
SETup:GAPPower:TIMeout:TIME | X |  |  | X
SETup:SMONitor:BANDwidth|BWIDth:AUTO | X |  |  | X
SETup:SMONitor:BANDwidth|BWIDth:MANual | X |  |  | X
SETup:SMONitor:DETector[:TYPE] | X |  |  | X
SYSTem:FATal:ERRor:RESTart | X |  |  | X


E1966A 1xEV-DO Terminal Test Application Revision Information

E1966A 1xEV-DO Terminal Test Application Revision Information

Last updated: July 31, 2006

This document describes features and functionality that are part of the Agilent Technologies E1966A 1xEV-DO Terminal Test Application releases. This document contains the original features, as well as enhancements that have been added over time.

CAUTION
You may need to upgrade the hardware in your test set before installing the application firmware described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up (see Test Set Lockup Due to Power Up Sequence ).
  • The application may not run.
  • Some features in the application may be inaccessible, or may not perform to specifications.

To determine if a hardware upgrade is required for your testing needs, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Select the appropriate link below to view the required release.

  • A.06.06 Release - July 2006
  • A.05.11 Release - January 2006
  • A.04.09 Release - May 2005
  • A.03 .17 Release - January 2005
  • A.02.32 Release - August 2004
  • A.02.15 Release - January 2004
  • A.01.37 Release - August 2003
  • A.01.34 Release - July 2003
  • A.01.20 Release - December 2002

A.06.06 Release - July 2006

Summary of GPIB command changes for this release: GPIB Changes for E1966A A.06.06, E6706A A.03.06 - July 2006

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Access Network Emulation

  • Supports protocol release A in Active Cell operating mode.

    NOTE
    You must purchase a feature license (E1966A-102) from Agilent Technologies to enable this functionality in a licensed test application. However, purchasing the E1966A-102 feature license from Agilent Technologies does not grant you use of the Qualcomm® proprietary Release A functionality. You must obtain consent from Qualcomm® to utilize this feature, as explained in the following statement:

    NOTICE
    THE DELIVERY OF THE AGILENT PRODUCT DOES NOT CONVEY A LICENSE NOR IMPLY ANY RIGHTS TO USE THE "1xEV-DO REVISION A" CAPABILITY CONTAINED IN THE AGILENT PRODUCT. SUCH USE REQUIRES THE EXPRESS CONSENT OF OR A SEPARATE LICENSE FROM QUALCOMM INCORPORATED. CUSTOMERS AND PRODUCT USERS SHALL BE SOLELY RESPONSIBLE TO OBTAIN SUCH CONSENT OR LICENSE FROM QUALCOMM INCORPORATED IN CONJUNCTION WITH THE USE OF THE "1XEVDO REVISION A" CAPABILITY.

    With the protocol release A selected (see Protocol Rel ), the test set can emulate new air-interface standard (3GPP2 C.S0024-A) which offers more functionality and improved data rates with the new design of the forward and reverse channels. In addition to all existing subtype 0 forward channels (Pilot, RPC, DRC Lock, RA and Control/Traffic channels), the subtype 2 forward link adds new forward ARQ channels (H-ARQ, L-ARQ and P-ARQ) to acknowledge each received subpackets on the reverse traffic channel. For subtype 2 reverse link, two new channels (Auxiliary Pilot and DSC) are introduced in addition to the design changes of the existing subtype 0 channels (R-Pilot, RRI, R-ACK, and R-Data). For a general overview of forward and reverse channels, see Forward Channel Overview and Reverse Channel Overview respectively.

  • Supports both subtype 0 and subtype 2 physical layer protocols for protocol release A. See Release A Physical Layer Subtype for setting details. To learn more about subtype 2 physical layer protocol, see Key Enhancements in Subtype 2 Physical Layer Relative to Subtype 0 .
  • Supports both the Default and Enhanced Access Channel MAC protocols for subtype 2 physical layer. See PL Subtype 2 Access Channel MAC Subtype .
  • Supports Enhanced Test Application Protocols (ETAP) for protocol release A plus subtype 2 physical layer configuration. Note: we currently does not support Default Packet Application (DPA) for protocol release A with subtype 2 physical layer configuration. See Enhanced Test Application Protocol for setting details. For a general overview of ETAP, see C.S0029 Test Application Specification Description (TAP/ETAP) .
  • Subtype 2 forward traffic supports variable and short physical layer packet size at a given data rate (DRC value). The forward link data rate can be from 4.8 kbps to 3072 kbps (Subtype 0: 38.4 kbps to 2457.6 kbps). See F-Traffic Format for details.
  • Subtype 2 reverse data channel supports data rates from 4.8 kbps up to 1843.2 kbps (Subtype 0: 9.6 kbps to 153.6 kbps) and also uses five modulation schemes as opposed to the single scheme (BPSK) used in subtype 0 operation. See R-Data Pkt Size .
  • Subtype 2 reverse access channel supports data rates of 9.6 kbps, 19.2 kbps, and 38.4 kbps (Subtype 0: 9.6 kbps only). See Enhanced Access Rate .

  • Other new parameters added to Application Config menu for release A plus subtype 2 physical layer configuration:

    • ACK Channel Modulation Type
    • Reverse Data Transmission Mode
    • Enhanced Access Rate
    • DRC Value Fixed Mode Attribute (changed from fixed value to a settable value. It is applicable to both subtype 0 and subtype 2 physical layer)

  • Other new parameters added to Access Network Info menus for release A plus subtype 2 physical layer configuration

    • Configurable Attribute Parms: Rate 1M8 Supported Control
    • Channel Gain/Traffic Info:
      • Channel Gain Parameters: Auxiliary Pilot Channel Gain , DSC Channel Gain
      • Power Parameters Info including: T2P Transition Settings , Termination Target Settings , TxT2P Gain Settings , Power Parameters Screen
      • Enhanced Traffic Parameters including: Auxiliary Pilot Channel Min Payload , DSC Length , Short Packet Enabled Threshold
      • RRI Gain Parameters

  • Other new parameters added to Generator Info menus for release A plus subtype 2 physical layer configuration

    • Code Channel Parameters including: H-ARQ Modulation , H-ARQ/L-ARQ Channel Level , P-ARQ Channel Level , RPC Channel Level
    • Termination Parameters including: Max Forward Packet Duration , ACK R-Data After

  • Supports Band Class 14 (US PCS 1900) as well as the related channels (0-1299). See Cell Band and Channel .

Measurements

  • Added a new Fast Device Tune measurement ( An additional feature license is required to enable this functionality in a licensed test application. See www.agilent.com/find/8960upgrades for more information )

    The Fast Device Tune measurement allows you to simultaneously calibrate your access terminal's transmitter (TX) output power and receiver (RX) input level across level and frequency in a single sweep (per frequency band range). See Fast Device Tune Measurement Description for details.

  • The Waveform Quality + Code Domain Measurement is enhanced to support new reverse channel structure of Release A subtype 2 physical layer. See Waveform Quality + Code Domain Measurement Description for details.
  • There is no change for all other existing measurements to support for release A subtype 2 physical layer tests. For release A subtype 2 physical layer tests as defined in C.S0033-A test standard, you are required to establish an ETAP test data connection (FETAP for AT receiver tests and RETAP for AT transmitter tests) instead of TAP test data connection as used in the release 0 tests. The Test Adherence to Standards lists the tests that are supported by the test set and provides the direct links to the related manual operation procedure for making the test.

Additional Information

  • A new comprehensive example program for AT's transmitter and receiver tests based on FETAP/RETAP test data connection is available. You can use this as a starting point for developing your own program. Click the link Comprehensive Program Example for AT Test (based on ETAP test data connection) to view this program.
  • New Thermal Power Null Adjustment .

A.05.11 Release - January 2006

The most current documentation for the 1xEV-DO applications is the Online User's Guide located at:

http://wireless.agilent.com/rfcomms/refdocs/1xevdo/

Summary of GPIB command changes for this release: GPIB Changes for E1966A A.05.11, E6706A A.02.21 - January 2006

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Access Network Emulation

  • Supports MEID type of Hardware ID

    Mobile Equipment Identifier (MEID) is a new way to uniquely identify AT equipment. MEID is a 56-bit number that allows for a larger number of ATs to be identified than the existing ESN numbering system. MEID is a type of Hardware ID that is supported in the 1xEV-DO. See Hardware ID Type and Hardware ID for details.

  • Supports settable CDMA system time.

    The CDMA system time is the time reference used by all IS-856 and IS-95/IS-2000 systems. The test set emulating an AN allows you to set the CDMA system time which are sent to the AT in the overhead messages ( Sync Message and SectorParameters Message ). For details, see CDMA System Time Parameters .

  • Supports IS-856 Test operating mode:

    The IS-856 Test operating mode provides a way for measuring access terminal (AT) when it is not possible, or not desired, to communicate via over-the-air signaling with the access terminal (AT), but forward link stimulus and reverse link measurements are still needed. For details, see IS-856 Test Operating Mode .

  • Adds a new setting - Preferred Control Channel Cycle (PCCC) Control

    By control of the session negotiation for the PCCC, the PCCC attribute can be configured to follow the test set's specified value or the AT-requested value during session negotiation. This provides flexibility for AT test because it allows ATs to determine the PCCC value without having to know the valid PCCC values for each AT under test. For details, see Preferred Control Channel Cycle .

  • Adds a new setting - Session Close

    The session timeout was changed from a fixed setting (3 minutes) to a user-settable parameter. This setting specifies the time period for which the test set has not heard from the AT before sending a SessionClose Message to the AT. For details, see Session Close .

  • Frequency Range of US Cellular Band Changes

    It is to support an extension to the existing Band Class 0 that is being allocated in Japan. The forward link frequency range of US Cellular cell band is changed from 869 - 894 MHz to 860 - 894 MHz and the reverse link frequency range of US Cellular cell band is changed from 824 - 849 MHz to 815 to 849 MHz. See Cell Band .

  • Channel Range of US Cellular Band Changes

    It is to support an extension to the existing Band Class 0 that is being allocated in Japan. The channel range of US Cellular cell band is extended to include the channels of 1024 - 1323. See Channel .

Measurements

  • Tx Dynamic Power Measurement Enhancements

    This measurement has been changed since its first release in the E1966A A.02.15 Release - January 2004 . Before performing each power step measurement in a power sequence, the test set automatically re-tunes its receiver based on the measured power of the prior step in addition to the Power Step Size setting that is only based on in the old releases. This change improves the test set ability to measure those ATs that do not correctly transmit the power sequence as expected without aborting the measurement. See TX Dynamic Power Measurement Description for details.

  • Packet Error Rate Measurement Enhancements

    A new setting, Minimum Packet Count, is added to the Packet Error Rate Setup menu. It is required for fading test. See PER Measurement Parameters for details.

  • Spectrum Monitor Enhancements

    Span and resolution bandwidth can now be set independently, new Detection Method. See Resolution Bandwidth and Frequency Span and Detection Method for details.

Other Features/Enhancements

  • New Restart on Fatal Error setting.
  • Pilot Drop setting is moved to the Cell Parameters menu. See How Do I Change Cell Parameters?

Resolved Known Issues

  • Some BCMCS (BroadCast MultiCase Service) capable access terminals can not open a session with the test set.

For more information, visit the 8960 Known Issues web site:

http://wireless.agilent.com/rfcomms/issues

A.04.09 Release - May 2005

This is a maintenance release. The functionality present in this release is identical to that in the A.03 release (see A.03 .17 Release - January 2005 ).

Hardware Requirements

http://www.agilent.com/find/8960upgrades

A.03 .17 Release - January 2005

The most current documentation for the 1xEV-DO applications is the Online User's Guide located at:

http://wireless.agilent.com/rfcomms/refdocs/1xevdo/

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1966A_A03_E6706A_A02_Ref_Guide.chm

NOTE
To properly view the CHM Help File, you must Save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties >> Unblock .

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Other Features

  • Adds a new calibration - Burst Mod Offset 1. It is used when the test set is configured to generate test signals (such as AM or DSB-SC) in calibration of mobile stations that are based on Zero Intermediate Frequency (Zero IF) chipsets. See Calibrating the Test Set for details.

A.02.32 Release - August 2004

The functionality present in this release is identical to that in the A.02.20 release (see A.02.15 Release - January 2004 ).

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Resolved Known Issues

  • Call processing stability can require instrument reboot.
  • Instrument can occasionally lockup when sending CALL:OPER:MODE? command.
  • Occasional missed messages on Control Channel.
  • Session may not open if the default preamble length is changed.

For more information, visit the 8960 Known Issues web site:

http://wireless.agilent.com/rfcomms/issues

A.02.15 Release - January 2004

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Transmitter Measurements

  • TX Dynamic Power Measurement - This new measurement provides a fast calibration method that covers the typical 90 dB (from -60 dBm to +30 dBm) dynamic range of a CDMA access terminal. See TX Dynamic Power Measurement Description for details.
  • Channel Power Measurement Enhancement - A new measurement speed, Very Fast, is added to the channel power measurement. The very fast speed channel power measurement samples the input signal for 1/4 slot (0.3125 milliseconds) with immediate trigger upon receipt of the measurement request. See Measurement Speed .

A.01.37 Release - August 2003

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Access Network Emulation

  • Made pilot drop a settable parameter instead of a fixed setting. (See Pilot Drop .)
    The pilot drop parameter should be set to 18 (-9 dB) for most operations and test scenarios (some C.S0033 tests specify that pilot drop be set to -14 dB, such as 3.2.1 Demodulation of Forward Traffic Channel in AWGN ).
    This release also corrects an error in the A.01.34 release of the E1966A firmware. The A.01.34 release incorrectly sends a fixed pilot drop value of 60 (-30 dB) instead of the intended 28 (-14 dB). This low pilot drop value can cause dropped connections when moving from high to low cell power levels, during a handoff, or when operating with a high level of AWGN.

A.01.34 Release - July 2003

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Access Network Emulation

  • Changed the Transition Probability used by the AT to determine transition probabilities. Set all transition probabilities to 100% (0xFF). See Transition Probability .

Transmitter Measurements

  • Channel Power - When Multi-Measurement Count is on, two new measurement results are available, Maximum and Minimum Channel Power. See Channel Power Measurement Results .

    GPIB commands:

    • FETCh:CPOWer:MAXimum?
    • FETCh:CPOWer:MINimum?

A.01.20 Release - December 2002

These are the original features of the Agilent E1966A.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Access Network Emulator Functionality

  • Call Processing
    • Start Data Connection
    • End Data Connection
    • Close Session
    • Hard Handoff (Cell Band and Channel)
  • Access Network Emulation
    • Cell Power: Pilot, Traffic, Control, and MAC Channels
    • AWGN
    • Cell Bands (see Cell Band )
  • Test Application Protocol (TAP) support:
    • Forward Test Application Protocol (FTAP)
    • Reverse Test Application Protocol (RTAP)

Transmitter Measurements

  • 1xEV-DO:
    • Channel Power
    • Digital Average Power
    • Access Probe Power
    • Waveform Quality + Code Domain Power
    • Time Response of Open Loop Power Control (TROLPC)
    • Tx Spurious Emissions
  • Analog:
    • Frequency Modulation
      • FM Deviation
      • Distortion
      • Modulation Frequency
    • Frequency Stability
      • Frequency Error
      • Frequency
    • Analog Transmit Power

Receiver Measurements

  • Packet Error Rate (PER)

Instruments

  • Swept Audio
    • Audio generator
    • Audio analyzer
    • SINAD meter
    • Distortion meter
  • Audio Generator
    • Amplitude measurements
    • Frequency measurements
  • Audio Analyzer
    • Audio level measurements
    • Audio frequency measurements
    • SINAD measurements
    • Distortion measurements

Other Features

  • The ability to print test set screens over a LAN connection to a PC web browser and save directly as .GIF

Features Not Supported


Audio Analyzer Troubleshooting

Audio Analyzer Troubleshooting

December 13, 2002

Possible Setup Issues

During remote operation of the Audio Analyzer, you should always set the Trigger Arm to Single. The length of time required to return a measurement over GPIB using continuous triggering varies, but is always longer than when using single triggering. Continuous triggering can also cause problems when the INITiate:DONE? query is used.

If digital measurements are active, turn them off or set their trigger source to Immediate. See Triggering of Measurements .

The Detector Type selected (peak or rms) also sets how Audio Level measurements are displayed; as a peak value or an rms value. When comparing returned values over GPIB to your specifications, be sure to take into account the type of detector being used.

The Expected Peak Voltage is always set in V peak , regardless of the Detector Type selected, and cannot exceed 20 V peak (14.1 V rms ).

For accurate measurements, always set all Audio Analyzer setup parameters to their proper settings for the measurement being made. The SINAD and Distortion measurements typically use different settings than the Audio Level measurement. See Audio Analyzer Measurement Description and Audio Analyzer Block Diagram .

For very low level audio signals, use the 100 Hz BW BPF filter to reduce the affects of noise (see Audio Level Measurement Description ).

For accurate Audio Frequency measurements where more than one signal may be present, use the 100 Hz BW BPF filter to isolate the desired signal (see Audio Level Measurement Description ).

Interpreting Integrity Indicator Values

See Integrity Indicator .

If over range (5) is returned, the input level is greater than 4.9 dB above the Expected Peak Amplitude value or the maximum input level of 20 volts peak.

If under range (6) is returned, the input level is lower than 8 dB below the Expected Peak Amplitude value.

If the signal has both over range and under range conditions, only the over range condition (5) is indicated.


Access Probe Power Troubleshooting

Access Probe Power Troubleshooting

Last updated: April 14, 2005

IMPORTANT
If the access probe power measurement is on and waiting to measure a probe, all other measurements (except digital average power) will not be able to execute. It is therefore recommended that you turn off the access probe power measurement before attempting any other measurements. To optimize access probe power measurement speed, it is also recommended that you turn off all other measurements when performing an access probe power measurement.

Possible Setup Issues

  • If Trigger Arm is set to Single during manual operation, you must press the START SINGLE key to arm the measurement before it can measure the power of an access probe.
  • During remote operation of this measurement, you should configure the Trigger Arm to Single. See SETup:CAPPower:CONTinuous or SETup[:ALL]:CONTinuous:OFF|:ON .
  • It is recommended that you always turn Call Limit Mode on when measuring access probe power. The easiest way to induce access probes from the access terminal is to page the access terminal. If you do not have call limit mode set to on, the connection will complete, which clears the access probe power result from the measurement screen. Set call limit mode back to off when you have finished measuring access probe power.
  • There are several parameters that affect the access probe measurement results, such as Call Limit Mode, Probe Initial Adjust, and Probe Power Step. See Considerations when Making Access Probe Power Measurements for details.
  • Access probe power measurements are triggered by a rise in RF power that must cross at least -45 dBm/1.23 MHz. See How is an Access Probe Power Measurement Made? for details.

Troubleshooting Techniques

  • Turn off the access probe power measurement. Turn on the channel power measurement and page the access terminal. Check to see if any access probes are detected by the channel power measurement. You can also use the spectrum monitor or an external spectrum analyzer to try to detect the access probes.
  • Turn call limit mode off and try to open a connection with the current setup.
  • Check to see if an integrity indicator other than 0 (normal) was returned with a measurement result (see Channel Power Troubleshooting Techniques ).

Other Considerations

  • To help avoid over range or under range integrity indicators, correct for system path loss (see Amplitude Offset ).
  • If you are manually controlling the test set's receiver, be certain that you have entered the correct frequency and power values for your test setup (see Receiver Control ).
  • Under range occurs when testing access terminals with the Qualcomm DMSS 5500.

    Access terminals with the Qualcomm DMSS 5500 transmit access probes that are several dB lower than expected. When testing these access terminals, you must manually range the receiver power to ensure that the input signal is within the required measurement range (see Manual receiver power and Input Signal Requirements ).
    When testing these access terminals at high cell power, you may find that the access probe power level is too close to the noise level to allow the measurement to trigger. In this case you may need to lower the cell power level until the access probe power becomes high enough to measure. Specifically, this problem may occur when performing the 3.1.2.3.1 Range of Open Loop Output Power Test 1 (cell power of -25 dBm).

  • Ensure that the measurement is properly calibrated. See Calibrating the Access Probe Power Measurement .

Related Topics

Access Probe Power Measurement Description


Fast Device Tune Troubleshooting

Fast Device Tune Troubleshooting

Last updated: July 13, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

Possible Setup Issues

  • The measurement is not performed with a call established between the test set and mobile station (MS). Rather, you must place your MS into a test mode which forces it to transmit a predefined series of power steps at various frequencies, and forces it to simultaneously tune its receiver to perform measurements of the test set's signal (to determine RSSI, for example) at various frequencies and power levels. Note that the test set does not report the mobile station's measurement results (for example, RSSI). You must capture the mobile station's measurement results so that you can compare its measurements with the test set's actual transmission levels.
  • During front panel operation of this measurement, you must press the START SINGLE key to initiate the measurement.
  • Ensure that you have met the Fast Device Tune Input Signal Requirements .
  • Before performing a fast device tune measurement, ensure that the measurement has been properly calibrated (see Calibrating the Test Set ).
  • The MS RX Power Sequence must include the same number of power steps as the MS TX Power Sequence, and the number of frequencies in the MS RX Frequency Sequence must match the number of frequency steps in the MS TX Frequency Sequence. If you do not want the MS to measure test set power at as many power levels or frequencies as you want the test set to measure from the MS, simply place "dummy" power levels or frequencies at the end of the MS RX Power Sequence and MS RX Frequency Sequence (for example, simply repeat the final power level or frequency). You can then ignore the mobile station's measurement results for these "dummy" points. Likewise, if you need more measurement points in the MS RX Frequency/Power Series than in the MS TX Frequency/Power Series, you can place "dummy" power levels and frequencies in the MS TX Frequency/Power Series, but note that the test set will still measure and report power for these "dummy" points. You must simply ignore these results.
  • To ensure successful triggering of the measurement, follow the instructions at Triggering the Fast Device Tune Measurement .
  • If you are running the measurement from the front panel, you must wait 2 seconds after initiating the measurement before instructing your mobile station to trigger the test set (if using the measurement remotely, you can use the INITiate:CFDTune:ARMed? query to determine that the measurement is ready; a separate wait statement is not required). To ensure that the test set triggered on the first transmission from the mobile, verify that the "Number of MS TX Power Steps Measured" returned by the FETCh:CFDTune[:ALL]? commands is equal to Number of Frequency Steps multiplied by Number of Power Steps .
  • Required initial conditions:
    • Operating Mode must be set to IS-856 Test .
    • Rcvr Power Ctrl must be set to Manual and Meas Frequency must be set to manual control (See Manual Receiver Control in IS-856 Test Operating Mode ).
      To set Meas Frequency to manual control from the front panel, press the OFF/MANUAL key. This sets Meas Frequency to the last frequency value that this parameter was set to. The Fast Device Tune measurement ignores the specific value that Meas Frequency is set to, so it can be set to any supported input frequency; the measurement simply requires that Meas Frequency be in manual control mode
    • RF Gen Freq Ctrl must be set to Manual . See Manual Receiver Control in IS-856 Test Operating Mode .
    • AWGN Power must be Off . If in the Lab Application , also make sure no external fading is applied (see Digital Bus Information ).
    • The Fast Device Tune measurement is only supported on the RF IN/OUT port. If your test set includes an RF OUT ONLY port, RF Output Port ( F6 on the System Config screen) must be set to RF IN/OUT .
    • You must configure the MS TX Frequency/Power Series to match the pattern of power levels to be transmitted by the MS and configure the MS RX Frequency/Power Series to match the pattern of power levels to be measured by the MS (and at the appropriate frequencies). Ensure that you have included the frequency retune steps in your mobile station's transmit/receive sequences (for example, the number of power steps you've configured your mobile to transmit should be equal to the Number of Power Steps setting + 1).
    • Your access terminal should be configured to measure the test set's signal 5 ms after the start of each step, to allow the test set's source to settle.
  • Ensure that you set the Measurement Timeout to a value great enough to allow you to command the MS to transmit its MS TX Frequency/Power Series and for the test set to measure the MS TX Frequency/Power Series. For example, measuring the maximum allowable number of 400 power points can take more than 10 seconds (400 steps plus the 19 re-tune steps: 419 x 20 ms = 8.4 seconds, plus ~ 2 seconds required for the measurement to prepare for triggering).
  • MS TX Power Step Start Index + Number of Power Steps and MS RX Power Step Start Index + Number of Power Steps must not exceed 40.
  • You must ensure that the range of power values selected by MS TX Power Step Start Index, MS RX Power Step Start Index and Number of Power Steps do not include any NANs (9.91E+37) or values that are outside of the input or output ranges for the current application format (considering the amplitude offset settings).
  • MS TX Frequency Step Start Index + Number of Frequency Steps and MS RX Frequency Step Start Index + Number of Frequency Steps must not exceed 40.
  • The frequencies indicated by MS TX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range. Likewise, the frequencies indicated by MS RX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range, but do not have to be in the same frequency band range as the MS TX Frequency Sequence. Ensure that none of the frequency values you've selected are NANs (9.91E+37)).
  • Note that if you specify fewer than 40 values for the following commands: SETup:CFDTune:MS:RX:FREQuency:STEP[:VALues] , SETup:CFDTune:MS:RX:POWer:STEP[:LEVels] , SETup:CFDTune:MS:TX:FREQuency:STEP[:VALues] and SETup:CFDTune:MS:TX:POWer:STEP[:LEVels] , the remaining values are set to NAN (9.91E+37).
  • Although you can enter any power levels for MS TX Power Step Levels between -129 and +80 dBm (because this measurement is common to the W-CDMA/HSDPA, 1xEV-DO and cdma2000 formats), when running the Fast Device Tune measurement in the 1xEV-DO application/format, you can only measure power levels in the range of -79 to +30 dBm and the measurement is only specified for power levels in the range of -61 to +30 dBm (these ranges assume an amplitude offset of 0; the ranges change as you change amplitude offsets, see Amplitude Offset ).
  • Although you can enter any frequencies for MS TX Frequency Step Values between 411 and 1980 MHz, when running the Fast Device Tune measurement in the 1xEV-DO application/format, you can only test frequencies within a single 1xEV-DO frequency band range:
    • 411 to 479 MHz (Band: NMT-450)
    • 806 to 924 MHz (Bands: US Cellular, Japan CDMA, China Cellular, and Secondary 800)
    • 1750 to 1780 MHz (Band: Korean PCS)
    • 1920 to 1980 MHz (Band: IMT-2000)
    • 1850 to 1915 (Bands: US PCS and US PCS 1900)
  • Although you can enter any power levels for MS RX Power Step Levels between -165 and 37 dBm, when running the Fast Device Tune measurement in the W-CDMA/HSDPA application/format, the test set can only transmit test power levels in the range of -120 to -13 dBm (this range assumes an amplitude offset of 0; the allowable range changes as you change amplitude offsets, see Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power ).
  • Although you can enter any frequencies for MS RX Frequency Step Values between 421 and 2170 MHz, when running the Fast Device Tune measurement in the 1xEV-DO application/format, you can only test frequencies within a single 1xEV-DO frequency band range:
    • 421 to 489 MHz (Band: NMT-450)
    • 800 to 960 MHz (Bands: US Cellular, Japan CDMA, China Cellular, and Secondary 800)
    • 1840 to 1870 MHz (Band: Korean PCS)
    • 2110 to 2170 MHz (Band: IMT-2000)
    • 1930 to 1995 (Bands: US PCS and US PCS 1900)

Other Considerations

  • The Fast Device Tune measurement must re-range and re-trigger for every step in the MS TX Power Sequence. To ensure that this process is not interrupted by other operations, it is recommended that you not send any GPIB commands to the test set or press any front panel keys until the measurement has completed. If the measurement misses a trigger, it aborts and returns Integrity Indicator 30 : Missed Trigger .
  • No other measurements can be running when a Fast Device Tune measurement is performed. If any measurements are running when a Fast Device Tune measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while a Fast Device Tune measurement is running, the Fast Device Tune measurement is closed and a message is displayed.
  • Measurement results (and the RF generator output level) are affected by any RF IN/OUT Amplitude Offsets that are entered (see Amplitude Offset ).
  • The Fast Device Tune measurement results are currently only available via GPIB command (see FETCh:CFDTune[:ALL]? ). Measurement results are not available on the front panel screen.

Related Topics

Fast Device Tune Measurement Description


Packet Error Rate Measurement Troubleshooting

Packet Error Rate Measurement Troubleshooting

Last updated: July 10, 2006

IMPORTANT
If the access probe power measurement is on and waiting to measure a probe, all other measurements (except digital average power) will not be able to execute. It is therefore recommended that you turn off the access probe power measurement before attempting any other measurements.

Possible Setup Issues

  • You must establish an FTAP (for subtype 0 physical layer) or FETAP (for subtype 2 physical layer) connection to perform the Packet Error Rate (PER) measurement (see How Do I Open a Session and Test Data Connection? ).
  • DRC Value Fixed Mode Attribute should be set to on and AT Directed Packets must be set to a non-zero value.
  • If Limited TAP is on (while Test Application Protocol is set to FTAP), AT Directed Packets must not be greater than 50%, and RTAP Rate must be set to 9.6 kbps
  • Before turning AWGN on, verify that cell power is not set to a level significantly below the AWGN level, or the connection may be dropped (see Troubleshooting Setting Power Levels ).
  • Confidence level is only available when confidence state is set to on (see PER Measurement Parameters ).

Troubleshooting Techniques

  • Check to see if an integrity indicator other than 0 (normal) was returned with a measurement result (see Integrity Indicator ).
  • During the PER measurement, if the loopback packets are not returned to the test set, or the AT's input buffer overflows as a result of packets received from the test set, or a duplicate loopback packet is received by the test set, the PER measurement returns the Integrity Indicator "Missing Loopback Packets or AT Overflow".

Other Considerations

  • The AT sends one Loop Back Packet containing a record for each FTAP or FETAP Test Packet in the observation interval. If you have set Maximum Packet Count to 100 (for example), the FTAP or FETAP Test Packet which relays information about packet number 100 will often contain information about packets numbered greater than 100. The test set displays the results for all of the packets reported by this final FTAP or FETAP Test Packet. Thus, the Packets Tested will often exceed the Maximum Packet Count.

  • To avoid over range or under range integrity indicators, correct for system path loss (see Amplitude Offset ).
  • If you are manually controlling the test set's receiver, be certain that you have entered the correct frequency and power values for your test setup (see Receiver Control ).
  • PER Input Signal Requirements

Related Topics

Packet Error Rate (PER) Measurement Description


Channel Power Measurement Troubleshooting

Channel Power Measurement Troubleshooting

Important

If the access probe power measurement is on and waiting to measure a probe, all other measurements (except digital average power) will not be able to execute. It is therefore recommended that you turn off the access probe power measurement before attempting any other measurements.

Important

Possible Setup Issues

  • If the channel power result is not what you expected, consider whether you intend for the R-ACK Channel to be active. In order for the R-ACK Channel to be active, you must set ACK Channel Bit Fixed Mode Attribute to on, and set AT Directed Packets to a non-zero value.
  • During remote operation of this measurement, you should configure the Trigger Arm to Single. See SETup:CPOWer:CONTinuous or SETup[:ALL]:CONTinuous:OFF|:ON . If single triggering is used during manual operation, press the START SINGLE key to trigger each measurement.

Troubleshooting Techniques

  • Check to see if an integrity indicator other than 0 (normal) was returned with a measurement result (see Integrity Indicator ).

    If Over Range (5) is returned; the input power has exceeded +37 dBm or is greater than +9 dB above the expected power level of the receiver.

    If Under Range (6) is returned; the input power is below -61 dBm or is less than -9 dB below the expected power level of the receiver.

    Channel Power Under Range/Over Range Integrity Indicators

Other Considerations

  • To help avoid over range or under range integrity indicators, correct for system path loss (see Amplitude Offset ).
  • If you are manually controlling the test set's receiver, be certain that you have entered the correct frequency and power values for your test setup (see Receiver Control ).
  • Calibrating the Channel Power Measurement

Related Topics

Channel Power Measurement Description


Tx Spurious Emissions Measurement Troubleshooting

Tx Spurious Emissions Measurement Troubleshooting

Important

If the access probe power measurement is on and waiting to measure a probe, all other measurements (except digital average power) will not be able to execute. It is therefore recommended that you turn off the access probe power measurement before attempting any other measurements.

Important

Possible Setup Issues

  • You must establish an RTAP (for Subtype 0 Physical Layer) or RETAP (for Subtype 2 Physical Layer) connection to perform the TX Spurious emissions measurement (see How Do I Open a Session and Test Data Connection? ).
  • C.S0033 4.4.1 Conducted Spurious Emissions requires that the R-ACK Channel be active. In order for the R-ACK Channel to be active, you must set ACK Channel Bit Fixed Mode Attribute to on, and set AT Directed Packets to a non-zero value.
  • During remote operation of this measurement, you should configure the Trigger Arm to Single. See SETup:CTXSpurious:CONTinuous or SETup[:ALL]:CONTinuous:OFF|:ON . If single triggering is used during manual operation, press the START SINGLE key to trigger each measurement.

Troubleshooting Techniques

  • Check to see if an integrity indicator other than 0 (normal) was returned with a measurement result (see Integrity Indicator ).

Other Considerations

  • To avoid over range or under range integrity indicators, correct for system path loss (see Amplitude Offset ).
  • If you are manually controlling the test set's receiver, be certain that you have entered the correct frequency and power values for your test setup (see Receiver Control ).
  • TX Spurious Emissions Input Signal Requirements
  • Calibrating the TX Spurious Emissions Measurement

Related Topics

TX Spurious Emissions Measurement Description


Digital Average Power Troubleshooting

Digital Average Power Troubleshooting

Possible Setup Issues

  • The digital average power measurement has a bandwidth of approximately 4 GHZ. For this reason, significant signal energy outside the 1.23 MHz access terminal transmit bandwidth will increase the measured value.
  • C.S0033 4.3.4 Maximum RF Output Power requires that the R-ACK Channel be active. In order for the R-ACK Channel to be active, you must set ACK Channel Bit Fixed Mode Attribute to on, and set AT Directed Packets to a non-zero value.
  • During remote operation of this measurement, you should configure the Trigger Arm to Single. See SETup:DAPower:CONTinuous or SETup[:ALL]:CONTinuous:OFF|:ON . If single triggering is used during manual operation, press the START SINGLE key to trigger each measurement.

Troubleshooting Techniques

  • Check to see if an integrity indicator other than 0 (normal) was returned with a measurement result (see Integrity Indicator ).

    If over range (5) is returned the input power has exceeded the test set's internal sampler maximum value during some part of the sampling or the input power has exceeded the calibrated range of the test set's power detector.

    If under range (6) is returned the measurement result is below the expected input power level. Under range is also indicated if the input power is below the calibrated range of the test set's power detector.

Other Considerations

  • To avoid over range or under range integrity indicators, correct for system path loss (see Amplitude Offset ).
  • If you are manually controlling the test set's receiver, be certain that you have entered the correct frequency and power values for your test setup (see Receiver Control ).
  • Digital Average Power Input Signal Requirements
  • Calibrating the Digital Average Power Measurement

Related Topics

Digital Average Power Measurement Description


Troubleshooting Data Connection Processing

Troubleshooting Data Connection Processing

Last updated: June 21, 2006

Possible Setup Issues

  • It is recommended not to execute a preset/reset (full or partial) when a session is open with an AT. This is because executing a preset/reset (full or partial) will take the test set to Idle state without signaling to the AT and may cause the test set and AT in a mismatched state. In this case, some ATs can not open a new session with the test set.
  • If you are trying to establish a session or connection:
    • Cell band and channel must be set to the proper values for your access terminal (see How Do I Change Call Parameters? ).
    • Verify that your AT supports protocol release A prior to changing the Protocol Rel set to release A (1xEV-DO-A) . Otherwise, negotiating a session will fail.
    • The PL Subtype 2 Access Channel MAC Subtype defaults to the Enhanced setting. Negotiating a session when the Protocol Rel set to release A (1xEV-DO-A) and the Release A Physical Layer Subtype set to Subtype 2 will fail if the AT does not support Enhanced Access Channel MAC protocol. When using an AT that does not support Enhanced Access Channel MAC Protocol, the PL Subtype 2 Access Channel MAC Subtype should be changed from Enhanced to Default.
    • Call Limit Mode must be set to off.
    • Cell Power must be set to an adequate level and AWGN Power must be set to an adequately low level to allow for successful data connection processing.
    • The input signal from the access terminal must meet the Input Signal Requirements .
    • If you are manually controlling the receiver, you must have the expected power and frequency set to the proper values (see Receiver Control ).
  • Ensure that the Preferred Control Channel Cycle is set to the correct setting for your test conditions.
  • Ensure that Reverse Closed Loop Power Control mode is set to the correct setting for your test conditions.
  • Ensure that Test Application Protocol is set to the correct value for your test conditions.

    IMPORTANT
    In order for the test set to successfully decode signalling from the AT, the signal level into the test set's RF IN/OUT connector must be within 9 dB of the expected input power (see Expected Power ). When Reverse Closed Loop Power Control is set to All Up Bits or All Down Bits, the AT's power will not be within the required range, and all signalling will fail. Before attempting any signalling between the test set and AT, you must either set Reverse Closed Loop Power to Active Bits, or manually range the Receiver Power to the level that the AT is currently transmitting based on the Reverse Closed Loop Power Control setting (see Manual receiver power ).

  • lab application only :
    • If you are trying to establish a packet data connection, ensure that the Session Application Type is set to the Default Packet Application.
    • The packet data connection can not be started from the test set. Starting a data connection by sending a CALL:FUNCtion:DATA:STARt command will result in an error due to without having a PPP connection established.
    • If you are trying to end a packet data connection from the test set, use CALL:FUNCtion:DATA:DORMant command instead of the CALL:FUNCtion:DATA:STOP. This results in data connection status going to Dormant state which indicates that the physical connection (air-link) is closed but PPP connection is maintained. See Dormant State .

Other Considerations

  • While on a connection, if you change a parameter that is configured during the Session Negotiate State , the connection is closed. You must re-open the connection. This behavior is specified by C.S0024.
  • You can not change a parameter which is configured during the Session Negotiate State when a session is open and Call Limit Mode is set to on.
  • Close Session Before Testing New AT

    When you have finished testing your AT, before disconnecting it from the test set and connecting a new AT to test, you should close the current session (see Session Closing State ). If you do not close the session before disconnecting the old AT and connecting a new AT, when the new AT sends a UATI Request message to initiate a session, the following error will be returned by the test set +271 Closing current session due to new RATI-addressed packet received , and there will be a short delay before a session is established with the new AT. The fastest way to establish a session with the new AT is to close the session with the old AT before disconnecting it from the test set.

    DO NOT close an session when the data connection is open by the command CALL:FUNCtion:DATA:STOP (close data connection) and then followed by CALL:SCLose (close the session). Sometimes it may cause problems. Some AT is instantly sleeping after the data connection is closed so that AT can not guarantee to listen the close session (CALL:SCLose) command. This leaves the AT and the test set in different states and can cause bad problems. It's recommended to directly send CALL:SCLose to close the session when the data connection is open. This will close the data connection and the session at one time.

  • You can close the session at any time. However, most ATs will try to immediately re-establish a session. To prevent the AT from re-establishing a session, the recommended procedure is as follows:

    • Establish a data connection.
    • Set Call Limit Mode to On .
    • Execute Session Close .
    • Set Cell Power to Off . (Turning the cell power to off can prevent the AT from sending the UATIRequest message. If the AT can detect the pilot signal from the test set, it will keep sending the UATIRequest messages to try to get a response from the test set. This may result in negative consequences in most ATs.)

    To re-establish a session, the following steps should be taken:

    • Set Call Limit Mode to Off .
    • Set Cell Power to On .

  • Set Pilot Drop to proper value to avoid dropped connections

    The A.01.37 Release - August 2003 and above firmware for the E1966A allow you to set the pilot drop parameter to any value between 0 and 63. The pilot drop parameter should be set to 18 (-9 dB) for most operations and test scenarios (some C.S0033 tests specify that pilot drop be set to -14 dB, such as 3.2.1 Demodulation of Forward Traffic Channel in AWGN ).
    The A.01.34 Release - July 2003 firmware for the E1966A incorrectly sends a fixed pilot drop value of 60 (-30 dB) instead of the intended 28 (-14 dB). This low pilot drop value can cause dropped connections when moving from high to low cell power levels, during a handoff, or when operating with a high level of AWGN.

  • When testing an access terminal that requires setting Limited TAP to on:
    • The access terminal may not implement the parameter settings sent in the Traffic Channel Assignment message (see TAP/ETAP Data Connection Call Flow ). In this case, to change a parameter that is sent in the Traffic Channel Assignment message, you must close the connection, change the parameter, and then re-open the connection (this includes a handoff to a new band and/or channel).
  • The test set defaults the Short Packet Enabled Threshold to 4096 bits. This allows for all non-canonical (short packet) formats. It is not expected to be changed unless some ATs failed to open a session with this value. The default value set in the test set is not the protocol default value (2048 bits) as defined in the C.S0024-A. This opens the possibility of session failure for some ATs that only support the protocol default value. In this case, you may need to change the Short Packet Enabled Threshold to the value supported by your AT. See Short Packet Enabled Threshold for details.

Related Topics

TAP/ETAP Data Connection Processing States Lifecycle

TAP/ETAP Data Connection Call Flow

Packet Data Connection Processing States Lifecycle ( Lab Application Only )

Packet Data Connection Call Flow ( Lab Application Only )


Waveform Quality Measurement Troubleshooting

Waveform Quality Measurement Troubleshooting

Last updated: June 16, 2006

IMPORTANT
If the access probe power measurement is on and waiting to measure a probe, all other measurements (except digital average power) will not be able to execute. It is therefore recommended that you turn off the access probe power measurement before attempting any other measurements.

Possible Setup Issues

  • You must establish an RTAP (for subtype 0 physical layer) or RETAP (for subtype 2 physical layer) prior to performing the waveform quality + code domain power measurement. Making the measurement in other cases may get incorrect measurement results.
  • C.S0033 4.3.8.2 ACK Channel Output Power and test 5 of 4.3.8.3 Data Channel Output Power require that the R-ACK Channel be active. In order for the R-ACK Channel to be active, you must set ACK Channel Bit Fixed Mode Attribute to on, and set AT Directed Packets to a non-zero value.
  • During remote operation of this measurement, you should configure the Trigger Arm to Single. See SETup:DOWQuality:CONTinuous or SETup[:ALL]:CONTinuous:OFF|:ON . If single triggering is used during manual operation, press the START SINGLE key to trigger each measurement.

Troubleshooting Techniques

  • Check to see if an integrity indicator other than 0 (normal) was returned with a measurement result (see Integrity Indicator ).

Other Considerations

  • For subtype 0 physical layer, the waveform quality + code domain measurement always uses the RTAP Rate parameter to demodulate R-Data channel. So when the specified R-Data data rate is different from the actual R-Data data rate, the measurement results are incorrect. For example, the measurement can be accessed in FTAP and Default Packet Application connection where the results look good but should not be used because the actual R-Data date rate does not match the specified value.

    Instead of using the specified R-Data Pkt Size , the subtype 2 waveform quality + code domain measurement uses the actual payload size detected from the R-RRI channel (R-RRI channel carries the payload size and sub-packet identifier information) to demodulate the R-Data channel. The results reflect the current reverse link data signal.

  • To avoid over range or under range integrity indicators, correct for system path loss (see Amplitude Offset ).
  • If you are manually controlling the test set's receiver, be certain that you have entered the correct frequency and power values for your test setup (see Receiver Control ).
  • Waveform Quality + Code Domain Input Signal Requirements
  • Calibrating the Waveform Quality + Code Domain Measurement

Related Topics

Waveform Quality + Code Domain Measurement Description


TX Dynamic Power Measurement Troubleshooting

TX Dynamic Power Measurement Troubleshooting

IMPORTANT
The TX dynamic power measurement does not run concurrently with any other measurements. If any measurements are running, they are closed when TX dynamic power measurement is initiated, and a message is displayed indicating that a measurement has been closed. Activating another measurement inactivates the TX dynamic power measurement.

Possible Setup Issues

  • The TX dynamic power measurement is not performed with a data connection established between the test set and AT. Rather, you must place your AT into a test mode which forces it to transmit a power sequence of successive down steps of fixed size and duration.
  • Before starting the TX dynamic power measurement, you must set the test set's receiver using manual control, with the power set to match the initial transmit power of the AT's power sequence, and with the frequency set to match the AT's transmit frequency (see Receiver Control ).
  • You must set the Power Step Size , Number Of Power Steps and Power Step Time parameters (see TX Dynamic Power Measurement Parameters ) to match the power sequence to be transmitted by the AT.
  • During front panel operation of this measurement, you must press the START SINGLE key to initiate the measurement.
  • Once the measurement has been initiated, the AT must trigger the measurement with an RF rise (a positive change in power from 20 dB below the initial transmit power).
  • Ensure that you have met the TX Dynamic Power Input Signal Requirements .
  • Before performing a TX dynamic power measurement, ensure that the measurement has been properly calibrated (see Calibrating the TX Dynamic Power Measurement ).
  • Ensure that you have entered the proper Amplitude Offset values for your test setup.
  • Ensure that you set the Measurement Timeout to a value great enough to allow you to command the AT to transmit its power sequence and for the test set to measure the power sequence.
  • For front panel graph control, the Start Step and the Span settings can not add up to more than 100. Otherwise, the new value will be rejected with an error indicating "Upper limit exceeded".
  • See also Operating Considerations .

Troubleshooting Techniques

Check to see if an integrity indicator other than 0 (normal) was returned with a measurement result (see Integrity Indicator ).

  • If Trigger Missed (30) is returned, one or more triggers were missed during the AT's power sequence measurement. This can prevent the TX dynamic power measurement from hanging and provide an early termination for the measurement.
  • If Over Range (5) is returned; the input power has exceeded +37 dBm or is greater than +9 dB above the expected power level of the receiver.
  • If Under Range (6) is returned; the input power is below -61 dBm or is less than -9 dB below the expected power level of the receiver.
  • If the measurement has both over range and under range conditions, only the over range (5) will be indicated.
  • If the measurement has several errors, the error which has the highest priority will be indicated.

Related Topics

TX Dynamic Power Measurement Description

Manual Operation: Measuring TX Dynamic Power


Fixed Timer Messages

Fixed Timer Messages

Last updated: July 28, 2006

Description

This is the list of fixed timers with a brief explanation and their values. A timer expiry message appears in its own window, on the test set display. The user has no access to these values and can not change them. None of the fixed timers are active when operating mode is Test Mode.

Timer Name | Description | Value
T100 RADIO-LINK-TIMEOUT | Detects the presence of the radio link by detecting SACCH frames every 480 ms. | 4 SACCH multiframes. That is 1.92 seconds if the SACCH is completely absent.
T200 Data link timer | Used for re-transmission on the data link. The value varies depending on the message type. | 155 ms for FACCH
T301 Alerting (ringing) timer | Timer used to limit the amount of time a user has to answer a call. | 20 seconds
T303 Mobility Management connection timer | Time the network waits after sending a CM SERVICE REQUEST until receiving a response. This occurs before initiating call clearing procedures towards the MS. | 10 seconds
T305 Release timer | Time the network waits after transmitting a DISCONNECT message until receiving a RELEASE message. | 10 seconds
T306 In-band tones release timer | Time the network waits after transmitting a DISCONNECT message while in-band tones/announcements are provided, until receiving a RELEASE message. | 10 seconds
T308 Release timer | Time the network waits after sending a RELEASE message until receiving a RELEASE COMPLETE message. This occurs before re-transmitting the RELEASE or releasing the Mobility Management connection. | 10 seconds
T310 Call proceeding timer | Time the network waits after receiving a CALL CONFIRMED message until receiving a ALERTING, CONNECT, or DISCONNECT message before initiating clearing procedures towards the MS. | 10 seconds
T313 Connect acknowledge timer | Time the network waits after transmitting a CONNECT message until receiving the CONNECT ACKNOWLEDGE message before performing clearing procedures with the MS. | 10 seconds
T323 Modify complete timer | Time the network waits after sending a MODIFY message during call mode changes, until receiving a MODIFY COMPLETE or MODIFY REJECT message before initiating call clearing procedures. | 10 seconds
T3101 Immediate assignment timer | Time the network waits after sending the IMMEDIATE ASSIGNMENT or IMMEDIATE ASSIGNMENT EXTENDED message until the main signalling link is established before releasing the newly allocated channels. | 1 second
T3103 Handover timer | Time the network waits after transmitting a HANDOVER COMMAND message until receiving HANDOVER COMPLETE or HANDOVER FAILURE or the MS re-establishes the call before the old channels are released. If the timer expires and the network has not received a correctly decoded L2 (format A or B) or TCH frame, then the newly allocated channels are released. | 2 seconds
T3105 Physical information repetition timer | Time the network waits after sending the PHYSICAL INFORMATION message until receiving a correctly decoded L2 (format A or B) or TCH frame. This occur before re-transmitting the PHYSICAL INFORMATION message or releasing the newly allocated channels. | 50 ms
T3107 Channel assignment timer | Time the network waits after transmitting an ASSIGNMENT COMMAND message until receiving the ASSESSMENT FAILURE message or the MS re-establishes the call before releasing the old and the new channels. | 3 seconds
T3109 Signalling disconnection timer | Time the network waits after sending the CHANNEL RELEASE message before disconnecting the signalling link. | 5 seconds
T3111 Channel deactivation after disconnection timer | Time the network waits after disconnecting the signalling link before deactivating the channel. | 500 ms
T3113 Paging timer | Time the network waits after transmitting the PAGING REQUEST message until receiving the PAGING RESPONSE message. This occurs before re-transmitting the PAGING REQUEST (if the maximum number of re-transmissions have not been exceeded). | 5 seconds
T3212 Location update timer | The location update timer is set to zero, periodic location update by the MS are disabled. If the MS camps to the BCH and decodes a new MCC or MNC from the one it last camped on, it should perform a location update. | zero = infinite time
T3250 TMSI reallocation timer | Time the network waits after sending the TMSI REALLOCATION COMMAND until receiving TMSI REALLOCATION COMPLETE. This occurs before aborting the procedure and releasing the Radio Resource connection. | 5 seconds
T3260 Authentication response timer | Time the network waits after an AUTHENTICATION REQUEST until receiving AUTHENTICATION RESPONSE. This occurs before aborting the procedure and releasing the Radio Resource connection. | 5 seconds


Error Messages

Error Messages

Last updated December 19, 2005

Error Message Descriptions

Fixed Timer Messages

Manual User Error Messages

-400 through -499 Error Message Descriptions

-300 through -399 Error Message Descriptions

-200 through -299 Error Message Descriptions

-100 through -199 Error Message Descriptions

+100 through +199 Error Message Descriptions

+200 through +299 Error Message Descriptions

+300 through +399 Link Control Device-Specific Error

+400 through +499 Error Message Descriptions

+500 through +599 Application Hardware Device-Specific Error

+600 through +699 Error Message Descriptions

+700 through +799 Error Message Descriptions

+800 through +899 Error Message Descriptions

Description

Reading Error Messages

Each error message that is generated is recorded in either the error/event queue or the message log or both. Error messages are shown in a message window at the center of the test set's display.

When an error message is displayed, an audio beep occurs; the beeper state of the test set can be set to on or off.

The error/event queue is read remotely using the SYSTem:ERRor? query. The error/event queue is able to hold 100 messages. To read the entire error/event queue use the following program.

10 DIM Err_msg$[255]
20 REPEAT
30 OUTPUT 714;"SYSTEM:ERROR?"
40 ENTER 714; Err_num,Err_msg$
50 PRINT Err_num,Err_msg$
60 UNTIL Err_num = 0

The message log may be viewed on the test set's display by pressing the SYSTEM CONFIG screen's Message Log key. The message log can display up to 24 entries over two pages.

Error messages can be cleared from the test set's display using the DISPlay:WINDow:ERRor:CLEar command. Pressing any functional front panel key, i.e. the LOCAL key, will clear an error message from the test set's display.

Classes of Errors

Error messages are divided into classes, each class of error is handled differently by the test set. The message log is cleared when the test set is power cycled.

Measurement Integrity Indicators

These messages occur as a result of a measurement, they indicate the validity of the measurement. Measurement integrity indicators are read with the FETCh command.

Non-Persistent Errors

These messages are generated when a condition occurs that is incorrect, but has no serious or long lasting effect on the test set's operation. Examples could include an out of range value to a parameter, or an invalid GPIB mnemonic. The message window is cleared when any front panel key is pressed.

Persistent Errors

These errors are generated when a non-transitory error condition exists. Persistent errors occur when a hardware failure is found, or when damage or injury to a person or the test set may occur.

The test set displays these errors in the error message window and as a prompt at the bottom of the display screen where it remains until the error condition no longer exists.

Fatal Errors

When these errors occur no further operation of the test set is possible without cycling the power switch. Fatal errors are not saved in the error message log. The test set display will provide the user with information about what to do next and some details about what the test set was doing when the fatal error occurred.

Maskable Messages

These messages are intended to inform the user of a condition within the test set. They are generally meant to provide information to the user. The user will need to decide if this condition is undesirable and if they want the message to appear.

Maskable Message Display State

The Maskable Messages Display State found in the Instrument Setup menu gives users a way to block these messages and the associated beep from ever happening. When the state is Off these messages and their associated beep will be blocked. The Maskable Message Display State can be set manually or with the following GPIB command:

OUTPUT 714;"DISPLAY:MESSAGE:MASKABLE:STATE OFF"
! Prevents certain messages from appearing on the display.

Instrument Maskable Messages

  • Instrument warning: Audio Generator instrument has been closed.
  • Instrument warning: Audio Analyzer instrument has been closed.
  • Instrument warning: Analog Audio instrument has been closed.

Related Topics

SYSTem:ERRor?


Error Message Log

Error Message Log

Last updated: December 19, 2005

Description

When an error message is displayed, it is also logged in the error message log. This log is only accessible manually; it is not available through GPIB. The error message log can be displayed by pressing the F7 menu key from the SYSTEM CONFIG screen. Next Page and Previous Page controls are provided.

All errors and events that are generated are displayed in the error message log. When the log is full a new message is sent to the log and the oldest message is removed from the log. The log is cleared when the test set powers up or when you press F10 (Clear Error Message Log).

Related Topics

Manual User Error Messages


Manual User Error Messages

Manual User Error Messages

Last updated: June 23, 2006

Description

These messages are intended to be displayed on the manual user interface only, and are not entered into the Error/Event Queue.

Error Message | Description
The function you requested is not yet available. | The test set does not have this capability.
IQ Calibration completed successfully for modulator <N> | <N> is the IQ modulator number that you are attempting to calibrate, <N> is 1 or 2.
IQ Calibration failed for modulator <N> | <N> is the IQ modulator number that you are attempting to calibrate, <N> is 1 or 2.
The function you requested is not available in this TA. | This function is used in another Test Application.
IQ Calibration for modulator 1 in progress (10 minutes). Call processing disabled. | This error is cleared by either the; IQ Calibration completed successfully for modulator <N>, or IQ Calibration failed for modulator <N>.
IQ Calibration for modulator 2 in progress (6 minutes). Call processing disabled. | This error is cleared by either the; IQ Calibration completed successfully for modulator <N>, or IQ Calibration failed for modulator <N>.
Instrument warning: Audio generator instrument has been closed. | The audio generator instrument was closed automatically by the test set.
Measurement warning: Audio Analyzer instrument has been closed. | The audio analyzer instrument was closed automatically by the test set.
Measurement warning: Analog audio measurement has been closed. | Analog audio measurements have been closed by the test set.
Protocol warning: Setting change has terminated the link with the DUT | Some setting change has caused the call to disconnect.
Warning; Call processing disabled | The call processing functions are not active because the test set is performing calibration operations.
IQ first modulator calibration X% | IQ modulator calibration in progress, X represents the percent complete.
IQ second modulator calibration X% | IQ modulator calibration in progress, X represents the percent complete.

Device Specific MUI Errors

TA856 MUI Errors
Error Message | Description
MUI100 "Call processing disabled" | This error, during calibration, is part of the test set's normal operation. If this error occurs during mobile station testing, an internal error has occurred in the test set's firmware.
CDMA MUI Errors (Continued)
Error Message | Description
Channel power calibration failed due to oven out of range | This error message occurs when the internal temperature of the test set has drifted more that +/- 10 deg C since the last calibration. Normally, letting the test set fully warm up before calibrating will eliminate this problem.
Channel power calibration failed due to loopback switch problem | The only user requirement for performing calibration is to make sure the test set is warmed up and to remove RF power to the front panel RF IN/OUT connector. If these requirements have been met and this message appears a test set failure condition exists.
Channel power calibration failed due to under range condition | The only user requirement for performing calibration is to make sure the test set is warmed up and to remove RF power to the front panel RF IN/OUT connector. If these requirements have been met and this message appears a test set failure condition exists.
Channel power calibration failed due to over range condition | The only user requirement for performing calibration is to make sure the test set is warmed up and to remove RF power to the front panel RF IN/OUT connector. If these requirements have been met and this message appears a test set failure condition exists.
Channel power calibration failed due to correlation problem | The only user requirement for performing calibration is to make sure the test set is warmed up and to remove RF power to the front panel RF IN/OUT connector. If these requirements have been met and this message appears a test set failure condition exists.
Channel power calibration failed | The only user requirement for performing calibration is to make sure the test set is warmed up and to remove RF power to the front panel RF IN/OUT connector. If these requirements have been met and this message appears a test set failure condition exists.
Channel power calibration in progress. Do not apply RF power during calibration. | This error message is displayed for information purposes only.
Channel power calibration<x>%. | This error message is displayed for information purposes only.
Digital average power calibration completed successfully. Cycle power to continue. | This error message is displayed for information purposes only.
Digital average power calibration failed due to temperature drift. Wait for temperature to stabilize. | This error message occurs when the internal temperature of the test set has drifted more that +/- 10 deg C since the last calibration. Normally, letting the test set fully warm up before calibrating will eliminate this problem.
Digital average power calibration failed due to oven out of range | This error message occurs when the internal temperature of the test set has drifted more that +/- 10 deg C since the last calibration. Normally, letting the test set fully warm up before calibrating will eliminate this problem.
Digital average power calibration failed due to loopback switch problem | The only user requirement for performing calibration is to make sure the test set is warmed up and to remove RF power to the front panel RF IN/OUT connector. If these requirements have been met and this message appears a test set failure condition exists.
Digital average power calibration failed | The only user requirement for performing calibration is to make sure the test set is warmed up and to remove RF power to the front panel RF IN/OUT connector. If these requirements have been met and this message appears a test set failure condition exists.
Digital average power calibration in progress. Do not apply RF power during calibration | This error message is displayed for information purposes only.
Digital average power calibration <x>%. | This error message is displayed for information purposes only.
Digital average power measurement has been closed | This error message is displayed for information purposes only.
Waveform quality measurement has been closed | This error message is displayed for information purposes only.
Channel power measurement has been closed | This error message is displayed for information purposes only.
CDMA measurement warning; TX dynamic power measurement has been closed. | This error message is displayed for information purposes only.
Channel power calibration failed due to source level problem |
MUI252 CDMA measurement warning; Fast Device Tune measurement has been closed |
Digital856 MUI Errors
Error Message | Description
MUI300 Digital856 warning; Call processing disabled | This error, during calibration, is part of the test set's normal operation. If this error occurs during mobile station testing, an internal error has occurred in the test set's firmware.
MUI341 Digital856 measurement warning; Packet error rate measurement has been closed | This error message is displayed for information purposes only.
MUI342 Digital856 measurement warning; Waveform quality measurement has been closed | This error message is displayed for information purposes only.

Related Topics

Error Message Log


-100 through -199 Error Message Descriptions

-100 through -199 Error Message Descriptions

December 13, 2002

Description

A command error indicates that the test set's GPIB parser has detected an IEEE 488.2 syntax error.

When one of these errors is generated, the command error bit in the event status register is set.

Error Message | Description
-100 Command error | This event bit (Bit 5) indicates a syntax error, or a semantic error, or a GET command was entered, see IEEE 488.2, 11.5.1.1.4.
-101 Invalid character | Indicates a syntactic elements contains a character which is invalid for that type.
-102 Syntax error | Indicates that an unrecognized command or data type was encountered. For example, a string was received when the device does not accept strings.
-103 Invalid separator | The parser was expecting a separator and encountered an illegal character. For example, the semicolon was omitted after a program message unit.
-104 Data type error | The parser recognized a data element different than one allowed. For example, numeric or string data was expected but block data was encountered.
-105 Get not allowed | Indicates a Group Execute Trigger was received within a program message. Correct the program so that the GET does not occur within the program code.
-108 Parameter not allowed | Indicates that more parameters were received than expected for the header. For example, *ESE common command only accepts one parameter, so *ESE 0,1 is not allowed.
-109 Missing parameter | Indicates that less parameters were received than required for the header. For example, *ESE requires one parameter, *ESE is not allowed.
-110 Command header error | Indicates an error was detected in the header. This error is used when the device cannot detect the more specific errors -111 through -119.
-111 Header separator error | Indicates that a character that is not a legal header separator was encountered while parsing the header.
-112 Program mnemonic too long | Indicates that the header contains more that twelve characters, see IEEE 488.2, 7.6.1.4.1.
-113 Undefined header | Indicates the header is syntactically correct, but it is undefined for this specific device. For example, *XYZ is not defined for any device.
-114 Header suffix out of range | Indicates the value of a header suffix attached to a program mnemonic makes the header invalid.
-120 Numeric data error | This error, as well as errors -121 through -129, are generated when parsing a data element which appears to be numeric, including non-decimal numeric types. This particular error is used if the device cannot detect a more specific error.
-121 Invalid character in number | Indicates an invalid character for the data type being parsed was encountered. For example, an alpha in a decimal numeric or a "9" in octal data.
-123 Exponent too large | Indicates the magnitude of an exponent was greater than 32000, see IEEE 488.2, 7.7.2.4.1.
-124 Too many digits | Indicates the mantissa of a decimal numeric data element contained more than 255 digits excluding leading zeros, see IEEE 488.2, 7.7.2.4.1.
-128 Numeric data not allowed | Indicates that a legal numeric data element was received, but the device does not accept one in this position for the header.
-130 Suffix error | This error, as well as errors -131 through -139, are generated when parsing a suffix. This particular error message is used if the device cannot detect a more specific error.
-131 Invalid suffix | Indicates the suffix does not follow the syntax described in IEEE 488.2, 7.7.3.2, or the suffix is inappropriate for this device.
-134 Suffix too long | Indicates the suffix contain more than 12 characters, see IEEE 488.2, 7.7.3.4.
-138 Suffix not allowed | Indicates that a suffix was encountered after a numeric element that does not allow suffixes.
-140 Character data error | This error, as well as errors -141 through -149, are generated when parsing a character data element. This particular error message is used if the device cannot detect a more specific error.
-141 Invalid character data | Indicates that the character data element contains an invalid character or the particular element received is not valid for the header.
-144 Character data too long | Indicates the character data element contains more than twelve characters, see IEEE 488.2, 7.7.1.4.
-148 Character not allowed | Indicates a legal character data element was encountered where prohibited by the device.
-150 String data error | This error, as well as errors -151 through -159, are generated when parsing a string data element. This particular error message is used if the device cannot detect a more specific error.
-151 Invalid string data | Indicates that a string data element was expected, but was invalid, see IEEE 488.2, 7.7.5.2. For example, an END message was received before the terminal quote character.
-158 String data not allowed | Indicates that a string data element was encountered but was not allowed by the device at this point in parsing.
-160 Block data error | This error, as well as errors -161 through -169, are generated when parsing a block data element. This particular error message is used if the device cannot detect a more specific error.
-161 Invalid block data | Indicates a block data element was expected, but was invalid, see IEEE 488.2, 7.7.6.2. For example, and END message was received before the end length was satisfied.
-168 Block data not allowed | Indicates a legal block data element was encountered, but not allowed by the device at this point in parsing.
-170 Expression error | This error, as well as errors -171 through -179, are generated when parsing an expression data element. This particular error message is used if the device cannot detect a more specific error.
-171 Invalid expression | Indicates the expression data element was invalid, see IEEE 488.2, 7.7.7.2. For example, unmatched parentheses or an illegal character.
-178 Expression data not allowed | Indicates a legal expression data was encountered, but was not allowed by the device at this point in parsing.
-180 Macro error | This error, as well as error -181 through -189, are generated when defining a macro or execution a macro. This particular error message is used if the device cannot detect a more specific error.
-181 Invalid output macro definition | Indicates that a macro parameter place holder was encountered outside of a macro definition.
-183 Invalid inside macro definition | Indicates that the program message unit sequence, sent with a *DDT or a *DMC command, is syntactically invalid, see IEEE 488.2, 10.7.6.3.
-184 Macro parameter error | Indicates that a command inside the macro definition had the wrong number or type of parameters.


-200 through -299 Error Message Descriptions

-200 through -299 Error Message Descriptions

December 13, 2002

Description

These errors are generated when something occurs that is incorrect in the current state of the instrument. These errors may be generated by a user action from either the remote or the manual user interface.

Error Message | Description
-200 Execution error | This event bit (Bit 4) indicates a PROGRAM DATA element following a header was outside the legal input range or otherwise inconsistent with the device's capabilities, see IEEE 488.2, 11.5.1.1.5.
-203 Command protected | Indicates that a legal password-protected program command or query could not be executed because the command was disabled.
-220 Parameter error | Indicates that a program data element related error occurred.
-221 Setting conflict | Indicates that a legal program data element was parsed but could not be executed due to the current device state.
-222 Data out of range | Indicates that a legal program data element was parsed but could not be executed because the interpreted value was outside the legal range defined by the devices
-223 Too much data | Indicates that a legal program data element of block, expression, or string type was received that contained more data than the device could handle due to memory or related device-specific requirements.
-224 Illegal parameter value | Indicates that the value selected was not part of the list of values given.
-225 Out of memory | The device has insufficient memory to perform the requested operation.
-226 Lists not the same length | Attempted to use LIST structure having individual LIST's of unequal lengths.
-230 Data corrupt or stale | Indicates invalid data, a new reading started but not completed since the last access.
-231 Data questionable | Indicates that measurement accuracy is suspect.
-233 Invalid version | Indicates that a legal program data element was parsed but could not be executed because the version of the data is incorrect to the device. For example, a not supported file version, a not supported instrument version.
-240 Hardware error | Indicates that a legal program command or query could not be executed because of a hardware problem in the device.
-241 Hardware missing | Indicates that a legal program command or query could not be executed because of missing device hardware. For example, an option was not installed.
-250 Mass storage error | Indicates that a mass storage error occurred. The device cannot detect the more specific errors described for errors -251 through -259.
-251 Missing mass storage | Indicates that a legal program command or query could not be executed because of missing mass storage.
-252 Missing media | Indicates that a legal program command or query could not be executed because of missing media. For example, no disk.
-253 Corrupt media | Indicates that a legal program command or query could not be executed because of corrupt media. For example, bad disk or wrong format.
-254 Media full | Indicates that a legal program command or query could not be executed because the media is full. For example, there is no room left on the disk.
-255 Directory full | Indicates that a legal program command or query could not be executed because the media directory was full.
-256 File name not found | Indicates that a legal program command or query could not be executed because the file name was not found on the media.
-257 File name error | Indicates that a legal program command or query could not be executed because the file name on the device media was in error. For example, an attempt was made to read or copy a nonexistent file.
-258 Media protected | Indicates that a legal program command or query could not be executed because the media was protected. For example, the write-protect switch on a memory card was set.
-270 Macro error | Indicates that a macro related execution error occurred.
-271 Macro syntax error | Indicates that a syntactically legal macro program data sequence, according to IEEE 488.2, 10.7.2, could not be executed due to a syntax error within the macro definition.
-272 Macro execution error | Indicates that a syntactically legal macro program data sequence could not be executed due to some error in the macro definition, see IEEE 488.2, 10.7.6.3.
-273 Illegal macro label | Indicates that the macro label was not accepted, it did not agree with the definition in IEEE 488.2, 10.7.3
-274 Macro parameter error | Indicates that the macro definition improperly used a macro parameter placeholder, see IEEE 4882, 10.7.3.
-275 Macro definition too long | Indicates that a syntactically legal macro program data sequence could not be executed because the string of block contents were too long for the device to handle, IEEE 488.2, 10.7.6.1.
-276 Macro recursion error | Indicates that a syntactically legal macro program data sequence count not be executed because it would be recursive, see IEEE 488.2, 10.7.6.6.
-277 Macro redefinition not allowed | Indicates that redefining an existing macro label, see IEEE 488.2, 10.7.6.4.
-278 Macro header not found | Indicates that a legal macro label in the *GMS?, see IEEE 488.2, 10.13, could not be executed because the header was not previously defined.


-300 through -399 Error Message Descriptions

-300 through -399 Error Message Descriptions

December 13, 2002

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error. When one of these errors is generated, the device specific error bit in the event status register is set.

Error Message | Description
-300 Device specific error | This event bit (Bit 3) indicates that a device operation did not properly complete due to some condition, such as overrange see IEEE 488.2, 11.5.1.1.6.
-311 Memory error | Indicates some physical fault in the devices memory, such as a parity error.
-312 PUD memory lost | Indicates protected user data saved by the *PUD command has been lost, see IEEE 488.2, 10.27.
-313 Calibration memory lost | Indicates that nonvolatile calibration data used by the *CAL? command has been lost, see IEEE 488.2, 10.2.
-314 Save/recall memory lost | Indicates that the nonvolatile data saved by the *SAV command has been lost, see IEEE 488.2, 10.33.
-315 Configuration memory lost | Indicates that nonvolatile configuration data saved by the device has been lost.
-320 Storage fault | Indicates that the firmware detected a fault when using data storage. This is not an indication of physical damage or failure of any mass storage element.
-321 Out of memory | An internal operation needed more memory than was available
-330 Self test failed | Indicates a problem with the device that is not covered by a specific error message. The device may require service.
-340 Calibration failed | Indicates a problem during calibration of the device that is not covered by a specific error.
-350 Queue overflow | Indicates that there is no room in the queue and an error occurred but was not recorded. This code is entered into the queue in lieu of the code that caused the error.
-360 Communication error | This is the generic communication error for devices that cannot detect the more specific errors described for error -361 through -363.
-361 Parity error in program message | Parity bit not correct when data received for example, on a serial port.
-362 Framing error in program message | A stop bit was not detected when data was received for example, on a serial port (for example, a baud rate mismatch).
-363 Input buffer overrun | Software or hardware input buffer on serial port overflows with data caused by improper or nonexistent pacing.


-400 through -499 Error Message Descriptions

-400 through -499 Error Message Descriptions

December 13, 2002

Description

A Query error is generated either when data in the instrument's GPIB output queue has been lost, or when an attempt is being made to read data from the output queue when no output is present or pending.

Error Message | Description
-400 Query error | This event bit (Bit 2) indicates that an attempt to read data from the Output Queues when no output is present or pending, to data in the Output Queue has been lost see IEEE488.2, 11.5.1.1.7.
-410 Query INTERRUPTED | Indicates the test set has been interrupted by a new program message before it finishes sending a RESPONSE MESSAGE see IEEE 488.2, 6.3.2.3.
-420 Query UNTERMINATED | Indicates an incomplete Query in the program see IEEE 488.2, 6.3.2.2.
-430 Query DEADLOCKED | Indicates that the Input Buffer and Output Queue are full see IEEE 488.2, 6.3.1.7.
-440 Query UNTERMINATED after indefinite response | Indicates that a query was received in the same program message after a query requesting an indefinite response was executed see IEEE 488.2, 6.5.7.5.


+100 through +199 Error Message Descriptions

+100 through +199 Error Message Descriptions

Last updated: June 29, 2006

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error.

These are general errors generated by the core instrument. When one of these errors is generated, the `+100 errors' bit in the questionable error status register is set.

Error Message

Description

+101 Assert; Cycle power. Assert message<message1>

<message1> will appear as:

;P:DSP T:<task ID> E:<error code> C:<error classif.> F1:<flag 1> F2:<flag 2> if the DSP generated the assert.

;P:Protocol T:<task ID> L:<line number> F:<file name> if the Protocol processor generated the assert.

;P:Host T:<task ID> L:<line number> F:<file name> if the Host processor generated the assert.

+102 Exception; Cycle power. Exception message<message2>

<message2> will appear as: T:<task ID> or V:<vector number> or PC:<program counter> or DA:<data adrs reg value>.

Vector number, program counter and data address register values are hexadecimal format.

+103 Failure; No measurements or settings can be made

Indicates none of the VI's are operational because a serious problem exists.

+104 Failure; No settling operations will take place

Indicates none of the VI's are operational because a serious problem exists.

+105 Failure; No measurements or setting can be made for the function selected

Indicates none of the VI's are operational because a serious problem exists.

+110 Input pacing; Internal communication queue overflow likely

Indicates that GPIB commands are too fast for the device input queue and should be slowed.

+111 Input pacing; Internal communication queue overflow imminent. Pacing increased

Indicates that GPIB commands were too fast and the device input queue has not kept pace.

+112 Internal error; Protocol error <message3>

<message3> is an eight digit hexadecimal number that is the error code reported by protocol.

+113 Internal error; <VI NAME> forced inactive

Indicates that a VI is inactivated when not executed.

<VI NAME> includes: "IntVmVI","GprsBsEmulVI", "GsmComBsEmulVI","GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI", "TdmaTaBsEmulVI".

+114 Internal error; <VI NAME> not responding

Indicates that a VI has not been instantiated or the state is not available.

<VI NAME> includes: "IntVmVI","GprsBsEmulVI", "GsmComBsEmulVI", "GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI", "TdmaTaBsEmulVI", "RfHwAccessVI".

+115 Internal error; <VI NAME> inactive

Indicates that a VI has been made inactive.

<VI NAME> includes: "IntVmVI", "GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI".

+120 Warning; Receiver over range due to requested settings

Indicates the total received power (a combination of received power and amplitude offset) is above the range of the test set.

+121 Warning; Receiver under range due to requested settings

Indicates the total received power (a combination of received power and amplitude offset) is below the range of the test set.
+122 Warning; Reference out of lock

Indicates the test set's internal reference is out of lock.

+123 Warning; Duplicate RF IN/OUT Amplitude Offset Frequency entry. First frequency entry in RF IN/OUT Amplitude Offset table will be used.

Indicates that an amplitude offset value for that frequency has already been entered. The test set will use the amplitude offset value entered first.

+124 Warning; Source over range due to requested settings

The setting selected for total transmit power (a combination of cell power, AWGN power, amplitude offset) is above the test set's range.

+125 Warning; Source under range due to requested settings

The setting selected for total transmit power (a combination of cell power, AWGN power, amplitude offset) is below the test set's range.

+129 Configuration warning: License will expire soon

The temporary license is about to expire. This message will give the license number and the number of days before it is scheduled to expire.

+130 Configuration error; Unable to switch to indicated Test Application

The test application selected is not available for this test set.

+131 Configuration error; Current Test Application is not licensed (License = N). Select another Test Application

The test application selected is not licensed. Select another revision or test application that is licensed (License = L).

+132 Configuration error; Selected Test Application Format is not available.

Indicates that the fast switching operation will not activate a particular radio format. Check the revision number of the test application associated with the radio format, does the revision correspond with what the fast switching test application needs?
+133 Configuration error; Selected Test Application Format is not licensed, (License = N).

The radio format selected is not licensed. Select another revision or obtain a licensed revision of the test application test application that is licensed (License = L).

+134 Configuration error; Unable to switch to selected Test Application Format

The Test Application Format name used is correct but for some reason the test set can not switch to that format.

+137 Configuration error; The license has expired for the selected format

When a license expires you must switch applications by pressing the SYSTEM CONFIG key and then selecting Format Switch (F2) or Application Selection (F3).

+138 Configuration error; Selected format is not licensed due to unexpected system time change

 This message is displayed when a temporary license expires due to a change occurring to system time.

+139 Configuration error; Functionality is not available

+140 Operation rejected; Command is not supported in this operating mode

+141 Operation Rejected; A Measurement Is Currently Controlling This Setting. | An attempt has been made to access a setting that is being controlled by a measurement.

+142 Configuration error; Functionality not available

An attempt has been made to access lab application functions from a test application.

+143 Operation Rejected; Selected measurement is not available in the current measurement selection list

An attempt has been made to access a measurement that is not available in the current application.

+144 Operation rejected; PC connection not established

+145 Operation rejected; Feature is not licensed. See www.agilent.com/find/8960upgrades for additional information

The feature you are attempting to access is not licensed in your test set. Visit www.agilent.com/find/8960upgrades to find out how to acquire the required license.

+146 Operation rejected; External 8960 connection feature is not licensed. See www.agilent.com/find/8960upgrades for additional information

The external 8960 connection feature requires a license in a test application. Visit www.agilent.com/find/8960upgrades to find out how to acquire the required license.
+146 FDD operation rejected; HSDPA is not licensed. See www.agilent.com/find/8960upgrades for additional information | The HSDPA feature requires a license in a test application. Visit www.agilent.com/find/8960upgrades to find out how to acquire the required license.

+150 Calibration operation; Recalibrating due to present temperature

Indicates that the test set is recalibrating due to hardware inaccuracies based on temperature changes. Any measurements that are running will be temporarily aborted and then restarted after the recalibration is complete.

+160 Save/Recall error; File operation error

 Occurs if there is any disk read or write problems when trying to save, recall or delete a register.

+161 Save/Recall error; Recalling available (empty) register

 Occurs if an attempt is made to recall any register that has not been saved.
+162 Save/Recall error; Functionality is not yet available for current application. | Occurs when an attempt to save a save/recall register while using an application that has not implemented this feature.

+163 Save/Recall error; Functionality is not yet available for current application

+170 Warning; RF source 1 ALC mode set to closed due to requested setting

+171 Warning; 8960 has been restarted after a non-recoverable error occurred.

Occurs when the instrument has completed its power up sequence after restarting due to a fatal error.

Device Specific General Errors

TA856 General Errors
Error Message | Description
+113 TA856 error; <VI NAME> forced inactive | Indicates that a VI is inactivated when not executed. <VI NAME> includes: "IntVmVI","GprsBsEmulVI", "GsmComBsEmulVI","GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI", "TdmaTaBsEmulVI".
+114 TA856 error; <VI NAME> not responding | Indicates that a VI has not been instantiated or the state is not available. <VI NAME> includes: "IntVmVI","GprsBsEmulVI", "GsmComBsEmulVI", "GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI", "TdmaTaBsEmulVI", "RfHwAccessVI".
+115 TA856 error; <VI NAME> inactive | Indicates that a VI has been made inactive. <VI NAME> includes: "IntVmVI", "GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI".
Digital856 General Errors
Error Message | Description
+113 Digital856 error; <VI NAME> forced inactive | Indicates that a VI is inactivated when not executed. <VI NAME> includes: "IntVmVI","GprsBsEmulVI", "GsmComBsEmulVI","GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI", "TdmaTaBsEmulVI".
+114 Digital856 error; <VI NAME> not responding | Indicates that a VI has not been instantiated or the state is not available. <VI NAME> includes: "IntVmVI","GprsBsEmulVI", "GsmComBsEmulVI", "GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI", "TdmaTaBsEmulVI", "RfHwAccessVI".
+115 Digital856 error; <VI NAME> inactive | Indicates that a VI has been made inactive. <VI NAME> includes: "IntVmVI", "GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI".
+181 Digital856 setting deferred: Cell power and AWGN power >35 dB apart | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+182 Digital856 setting(s) deferred; Cell power and external AWGN power > 35 dB apart | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+183 Digital856 setting(s) deferred; AWGN power and external AWGN power > 35 dB apart | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+184 Digital856 setting(s) deferred; Physical layer subtype 2 code channel level(s) > 30 dB below total RF power | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+185 Digital856 setting rejected; Physical layer subtype 2 code channel level(s) > 30 dB below total RF power | This error message is displayed for information purposes only.
+186 Digital856 setting rejected; Default packet application is not currently supported with physical layer subtype 2 | This error message is displayed for information purposes only.
+187 Digital856 setting rejected; Protocol release A is not currently supported in IS-856 test mode | This error message is displayed for information purposes only.


+200 through +299 Error Message Descriptions

+200 through +299 Error Message Descriptions

Last updated: June 16, 2006

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error. Errors are categorized as follows:

  • CDMA: errors common to CDMA systems (IS-95, IS-2000, IS-856 and W-CDMA)

  • TA856: errors with test application scope

  • Digital856: errors applicable to only the IS-856 System Type

When one of these errors is generated, the +200 errors bit in the questionable error status register is set.

CDMA Call Processing Errors
Error Message | Description
+237 "CDMA operation rejected; Data out of range for CDMA system time or local time offset" | This error message is displayed for information purposes only.
+253 "CDMA call processing error; Operation not allowed due to incorrect operating mode or system type" | This error message is displayed for information purposes only.
+254 "CDMA call processing error; Operation not allowed due to call status not idle" | This error message is displayed for information purposes only.
+255 "CDMA call processing error; Synchronizing to external server failed due to no response from external server" | This error message is displayed for information purposes only.
+256 "CDMA call processing error; Synchronizing to external server failed due to unknown error on external server" | This error message is displayed for information purposes only.
+257 "CDMA call processing error; Synchronizing to external server failed due to incorrect operating mode or system type on external server" | This error message is displayed for information purposes only.
+258 "CDMA call processing error; Synchronizing to external server failed due to external trigger not set to 2s on external server" | This error message is displayed for information purposes only.
+259 "CDMA call processing error; Synchronizing to external server failed due to multi-unit synchronization feature not available on external server" | This error message is displayed for information purposes only.
+260 "CDMA call processing error; Synchronizing to external server failed due to unexpected response received" | This error message is displayed for information purposes only.
+261 "CDMA call processing error; Synchronizing to external server failed due to no trigger received from TRIG IN" | This error message is displayed for information purposes only.
+262 "CDMA call processing error; Enhanced origination message (EOM) is not supported" | This error message is displayed for information purposes only.
+270 Traffic channel preamble not received | This error message is associated with a failed call attempt.
+271 MS ack of initial BS ack order not received | This error message is displayed for information purposes only.
+272 MS ack order not received | This error message is displayed for information purposes only.
+273 Service Option or Radio Configuration rejected by MS | Some mobile stations do not support all service options provided for a given radio configuration. Use the FCH Service Option Setup (F12) key to select a different service option.
+274 Service response not received | This error message is associated with a failed call attempt or dropped call.
+275 Service request not received | This error message is associated with a failed call attempt or dropped call.
+276 Service connect completion not received | This error message is associated with a failed call attempt or dropped call.
+277 Call drop timer timed out | This error message is associated with a dropped connection or session.
+278 Status response not received | This error message is displayed for information purposes only.
+279 Walsh code cannot be changed while a call is connected | This error message is displayed for information purposes only.
+280 PN Offset cannot be changed while a call is connected | This error message is displayed for information purposes only.
+281 Origination failed due to F-FCH/Traffic state off | This error message is associated with a failed call attempt.
+282 Power control step size rejected | This error message is displayed for information purposes only.
+283 Session timer timed out | This error message is associated with a dropped connection or session.
TA856 Call Processing Errors
Error Message | Description
+260 UATIComplete message not received | Associated with failed session establishment or data connection
+261 Handoff rejected due to no traffic channel | Information only
+262 Setting or action rejected due to current data connection status | Information only
+263 Session management protocol failure during negotiation of session | Associated with failed session establishment or data connection
+264 Address management protocol failure during negotiation of session | Associated with failed session establishment or data connection
+265 Traffic channel assignment complete message not received | Associated with failed session establishment or data connection
+266 Connection request not received in response to a page | Associated with failed session establishment or data connection
+267 Reverse traffic channel data rate control and pilot not detected | Associated with failed session establishment or data connection
+268 FTAP parameter assignment complete message not received | Information only
+269 RTAP parameter assignment complete message not received | Information only
+270 CloseConnection message not received | Information only
+271 Closing current session due to new RATI-addressed packet received | This error is posted when a session is already open and a UATI Request is sent with a RandomATI. The test set then sends a session close message for the current session, and processes the new UATI Request after reaching the idle state. (It is expected that the test set will timeout waiting for a reply to the session close message, which will generate error +291 SessionClose messages not received in response to SessionClose message sent ). See Close Session Before Testing New AT .
+272 Unexpected message ignored in signaling network protocol | Information only
+273 Unexpected message ignored in signaling link protocol | Information only
+274 Unexpected message ignored in session management protocol | Information only
+275 Unexpected message ignored in address management protocol | Information only
+276 Unexpected message ignored in session configuration protocol | Information only
+277 Unexpected message ignored in air link management protocol | Information only
+278 Unexpected message ignored in initialization state protocol | Information only
+279 Unexpected message ignored in idle state protocol | Information only
+280 Unexpected message ignored in connected state protocol | Information only
+281 Unexpected message ignored in packet consolidation protocol | Information only
+282 Unexpected message ignored in route update protocol | Information only
+283 Unexpected message ignored in overhead messages protocol | Information only
+284 Unexpected message ignored in control channel MAC protocol | Information only
+285 Unexpected message ignored in forward traffic channel MAC protocol | Information only
+286 Unexpected message ignored in access channel MAC protocol | Information only
+287 Unexpected message ignored in reverse traffic channel MAC protocol | Information only
+288 Unexpected message ignored in physical layer protocol | Information only
+289 Unexpected message ignored in test application protocol | Information only
+290 Unexpected message ignored in stream protocol | Information only
+291 SessionClose messages not received in response to SessionClose message sent | Information only
+292 HardwareIDResponse message not received | Information only
+293 ConfigurationResponse message not received in response to ConfigurationRequest message | Associated with failed session establishment or data connection
+294 ConfigurationRequest or ConfigurationComplete message not received in response to ConfigurationStart | Associated with failed session establishment or data connection
+295 TA856 call processing error; Setting or action rejected due to application configuration | Information only
+296 TA856 call processing error; FETAP parameter assignment complete message not received | Information only
+297 TA856 call processing error; RETAP parameter assignment complete message not received | Information only
Digitial856 Call Processing Errors
Error Message | Description
+250 Digital856 call processing error; Session could not be configured to protocol default value | Associated with failed session establishment or data connection
+251 Digital856 call processing error; Session could not be configured to session configuration protocol ProtocolSubtype attribute | Associated with failed session establishment or data connection
+252 Digital856 call processing error; Session could not be configured to enhanced forward traffic channel MAC protocol ShortPacketsEnabledThresh attribute | Associated with failed session establishment or data connection
+253 Digital856 call processing error; Session could not be configured to enhanced forward traffic channel MAC protocol DSCLength attribute | Associated with failed session establishment or data connection
+254 Digital856 call processing error; Session could not be configured to subtype 3 reverse traffic channel MAC protocol AuxiliaryPilotChannelParameters attribute | Associated with failed session establishment or data connection
+255 Digital856 call processing error; Session could not be configured to subtype 3 reverse traffic channel MAC protocol RRIChannelPowerParameters attribute | Associated with failed session establishment or data connection
+256 Digital856 call processing error; Session could not be configured to subtype 3 reverse traffic channel MAC protocol TransmissionModeNN attribute | Associated with failed session establishment or data connection
+257 Digital856 call processing error; Session could not be configured to subtype 3 reverse traffic channel MAC protocol ARQMode attribute | Associated with failed session establishment or data connection
+258 Digital856 call processing error; Session could not be configured to subtype 3 reverse traffic channel MAC protocol PowerParameters128 attribute | Associated with failed session establishment or data connection
+259 Digital856 call processing error; Session could not be configured to subtype 3 reverse traffic channel MAC protocol PowerParameters256 attribute | Associated with failed session establishment or data connection
+260 Digital856 call processing error; Session could not be configured to subtype 3 reverse traffic channel MAC protocol PowerParameters512 attribute | Associated with failed session establishment or data connection
+261 Digital856 call processing error; Session could not be configured to subtype 3 reverse traffic channel MAC protocol PowerParameters768 attribute | Associated with failed session establishment or data connection
+262 Digital856 call processing error; Session could not be configured to subtype 3 reverse traffic channel MAC protocol PowerParameters1024 attribute | Associated with failed session establishment or data connection
+263 Digital856 call processing error; Session could not be configured to subtype 3 reverse traffic channel MAC protocol PowerParameters1536 attribute | Associated with failed session establishment or data connection
+264 Digital856 call processing error; Session could not be configured to subtype 3 reverse traffic channel MAC protocol PowerParameters2048 attribute | Associated with failed session establishment or data connection
+265 Digital856 call processing error; Session could not be configured to subtype 3 reverse traffic channel MAC protocol PowerParameters3072 attribute | Associated with failed session establishment or data connection
+266 Digital856 call processing error; Session could not be configured to subtype 3 reverse traffic channel MAC protocol PowerParameters4096 attribute | Associated with failed session establishment or data connection
+267 Digital856 call processing error; Session could not be configured to subtype 3 reverse traffic channel MAC protocol PowerParameters6144 attribute | Associated with failed session establishment or data connection
+268 Digital856 call processing error; Session could not be configured to subtype 3 reverse traffic channel MAC protocol PowerParameters8192 attribute | Associated with failed session establishment or data connection
+269 Digital856 call processing error; Session could not be configured to subtype 3 reverse traffic channel MAC protocol PowerParameters12288 attribute | Associated with failed session establishment or data connection
+270 Session could not be configured to stream protocol StreamConfiguration attribute | Associated with failed session establishment or data connection
+271 Session could not be configured to access channel MAC protocol PowerParameters attribute | Associated with failed session establishment or data connection
+272 Session could not be configured to reverse traffic channel MAC protocol PowerParameters attribute | Associated with failed session establishment or data connection
+273 Session could not be configured to idle state protocol PreferredControlChannelCycle attribute | Associated with failed session establishment or data connection
+274 Session could not be configured to access channel MAC protocol InitialConfiguration attribute | Associated with failed session establishment or data connection
+275 Session could not be configured to session management protocol SMPClose time attribute | Associated with failed session establishment or data connection
+276 Session could not be configured to route update protocol SetManagementSameChannelParameters attribute | Associated with failed session establishment or data connection
+277 Session could not be configured to route update protocol SearchParameters attribute | Associated with failed session establishment or data connection
+278 Session could not be configured to route update protocol SetManagementDifferentChannelParameters attribute | Associated with failed session establishment or data connection
+279 Session could not be configured to session configuration protocol ProtocolType attribute | Associated with failed session establishment or data connection
+280 Session could not be configured to session configuration protocol PriorSession attribute | Associated with failed session establishment or data connection
+281 Session could not be configured to forward traffic channel MAC protocol DRCGating attribute | Associated with failed session establishment or data connection
+282 Session could not be configured to forward traffic channel MAC protocol DRCLock attribute | Associated with failed session establishment or data connection
+283 Session could not be configured to forward traffic channel MAC protocol HandoffDelays attribute | Associated with failed session establishment or data connection
+284 Session could not be configured to reverse traffic channel MAC protocol RateParameters attribute | Associated with failed session establishment or data connection
+286 Digital856 call processing error; Unable to leave dormant due to physical connection failure | Information only
+287 Digital856 call processing error; PDSN data connection could not be established | Information only
+288 Digital856 call processing error; PDSN data connection could not be established due to invalid DUT IP address | Information only
+289 Digital856 call processing error; PDSN data connection could not be established due to invalid DUT IP address | Information only
+299 Digital856 call processing setting(s) deferred; Short packets enabled threshold incompatible with forward traffic configuration | Information only


+300 through +399 Link Control Device-Specific Error

+300 through +399 Link Control Device-Specific Error

December 13, 2002

These errors are generated when a problem occurs in maintaining the link between the test set and a DUT. These errors generally occur when a message is received from the DUT that is unexpected.

When one of these errors is generated, the `+300 errors' bit in the questionable error status register is set. Refer to Standard Event Status Register for information on this register.

No link control errors are currently defined for this test application.


+400 through +499 Error Message Descriptions

+400 through +499 Error Message Descriptions

Last updated: April 14, 2005

Description

These errors are generated when a problem occurs in one of the test set's hardware modules that is part of the test set's core instrument.

When one of these errors is generated, the `+400 errors' bit in the questionable error status register is set.

Error Message | Description
+400 Hardware failure; Hardware is not available |
+401 Hardware failure; Protocol processor hardware is not responding |
+402 Hardware failure; Demod receiver hardware is not responding |
+403 Hardware failure; Measurement receiver hardware is not responding |
+404 Hardware failure; RF source 1 hardware is not responding |
+405 Hardware failure; RF source 1 digital modulation hardware is not responding |
+406 Hardware failure; RF source 1 level hardware is not responding |
+407 Hardware failure; DSP demod control hardware is not responding |
+408 Hardware failure; 2nd demod receiver hardware is not responding |
+409 Hardware failure; Base station emulator trigger hardware is not responding |
+410 Hardware failure; Audio source hardware is not responding |
+411 Hardware failure; RF source 2 hardware is not responding |
+412 Hardware failure; Internal voltmeter hardware is not responding |
+413 Hardware failure; Fixed timebase input is not responding |
+414 Hardware failure; Fixed external reference output is not responding |
+415 Hardware failure; Instrument reference is not responding |
+416 Hardware failure; Bit clock A is not responding |
+417 Hardware failure; RF source 2 frequency hardware is not responding |
+418 Hardware failure; RF source 2 digital modulation hardware is not responding |
+419 Hardware failure; RF source 2 level hardware is not responding |
+420 Hardware failure; RF source hopping hardware is not responding |
+421 Hardware failure; Digital demod hopping hardware is not responding |
+422 Hardware failure; Misc VI hardware is not responding |
+423 Hardware failure; Unable to access networking information |
+424 Hardware failure; Bit clock B is not responding |
+425 Hardware failure; Invalid EEPROM checksum <EEPROM board ID> | See the list of EEPROM board ID names below.
+426 Hardware failure; Unable to write to EEPROM <EEPROM board ID> | See the list of EEPROM board ID names below.
+427 Hardware failure; Unable to read from EEPROM <EEPROM board ID> | See the list of EEPROM board ID names below.
+428 Hardware failure; Board not identified <board ID> | See the list of board ID names below.
+429 Hardware failure; Could not create board identification <board ID> | See the list of board ID names below.
+430 Hardware failure; Control version not compatible with FW <board ID> | See the list of board ID names below.
+431 Hardware failure; RF IO DAC cannot be calibrated due to present temperature |
+432 Hardware failure; RF hardware is not responding |
+433 Hardware failure; RF source FM hardware is not responding |
+434 Hardware failure; Audio source FM hardware is not responding |
+460 Hardware failure; Hardware doesn't support requested operation. See www.agilent.com/find/8960upgrades for additional information | This error occurs when an action is attempted that is not possible with the test set's hardware. Visit www.agilent.com/find/8960upgrades to find out how to acquire the necessary hardware.
+461 Hardware failure; Link subsystem hardware is not responding. Call processing functionality not operational. | This error occurs any time the link subsystem is not operating correctly. The message is persistent to warn the user that any call processing operations will not work.
+462 Hardware error; Hardware not supported; <board ID><part_number> | This error appears when an operation was attempted that requires hardware that is not installed in the test set.
+463 Hardware error: RFIO version does not support loopback switching. |
+464 Hardware error: RFIO version does not support RF out only selection. | This error occurs when trying to select the RF OUT ONLY port when the test set has the RF I/O module that only has the RF IN/OUT port.
+470 Hardware error; Hardware doesn't support requested operation. Feature is not licensed. See www.agilent.com/find/8960upgrades for additional information | This error occurs you attempt to access a feature which is not licensed in the test set and is not possible with the test set's hardware. Visit www.agilent.com/find/8960upgrades to find out how to acquire the necessary hardware and license.

<board ID> names

3 GHZ ATTENUATOR 1| ;3GHZ ATTENUATOR 2| ;AUDIO BD| ;ROM BASEBAND GENERATOR 1| ;ROM BASEBAND GENERATOR 2| ;DEMOD DOWNCONVERTER| ;VECTOR OUTPUT BOARD 1| ;VECTOR OUTPUT BOARD 2| ;IVF MEASUREMENT| ;MEASUREMENT DOWCONVERTER| ;RF POWER DETECTORS| ;REFERENCE MODULE| ;SYNTH DOUBLER 1| ;SYNTH DOUBLER 2| ;TIMING REF| ;MOMENTUM INSTRUMENT| ;RF MOTHER BOARD| ;JUMPER BOARD| ;DIGITAL MOTHER BOARD| ;FLAT PANEL ADAPTER| ;REAR PANEL BOARD

<EEPROM board ID> names

Instrument Eeprom ID State| ;Atten 1 Eeprom ID State| ;Atten 2 Eeprom ID State| ;Audio Eeprom ID State| ;BaseBandGen 1 Eeprom ID State| ;BaseBandGen 2 Eeprom ID State| ;Demod DC Eeprom ID State| ;Digital Mother Board Eeprom ID State| ;IQ Output 1 Eeprom ID State| ;IQ Output 2 Eeprom ID State| ;IVF Meas Eeprom ID State| ; Jumper Board Eeprom ID State| ; Meas DC Eeprom ID State| ;RF Mother Board Eeprom ID State| ;RF Interface Eeprom ID State| ; Ref Mod Eeprom ID State| ;Sig Gen 1 Eeprom ID State| ; Sig Gen 2 Eeprom ID State| ;Time Ref Eeprom ID State| ;Display Interface Eeprom ID State| ;Rear Panel Eeprom ID State


+500 through +599 Application Hardware Device-Specific Error

+500 through +599 Application Hardware Device-Specific Error

Last updated: June 19, 2006

Description

These errors are generated when a problem occurs with a hardware module that is required for a particular application.When one of these errors is generated, the `+500 errors' bit in the questionable error status register is set.

+500 through +599 Error Messages
Error Message | Description
+501 Protocol logging failure; No observation points enabled | This error message is displayed for information purposes only.
+520 Configuration error; DUT IP address must be on same subnet as instrument | This error message is generated if the DUT IP address is not on the same subnet as the instrument. This situation may arise because the instrument IP address was set after the DUT IP address, or the instrument subnet mask changed.
+521 Configuration error; DUT IP address cannot be the same as the instrument LAN address | This error message is generated if the DUT IP address and the instrument IP address are the same. This situation may arise because the instrument IP address was set after the DUT IP address.
+522 Configuration Error; Operation Rejected Due To Invalid IP Address | This error is returned when attempting to Connect to External 8960 if the Ext 8960 IP Addr is invalid.
+524 Operation rejected; External PDSN state can not be changed while data connection is dormant | This error message is displayed for information purposes only.
+525 Configuration error; External PDSN IP address must be on same subnet as instrument |
+526 Configuration error; External PDSN IP address cannot be the same as instrument LAN address | This error message is generated if the External PDSN IP address and the instrument IP address are the same.
+527 Operation rejected; External PDSN state change to on not allowed if external PDSN IP address is undefined | This error message is displayed for information purposes only.
+528 Operation rejected; External PDSN service not available; external PDSN state set to off | This error message is displayed for information purposes only
+529 Warning; External PDSN control connection dropped; external PDSN state set to off. | This error message is associated with a lost control connection between test set and MOB-IP-SIM.
+530 Operation rejected; External PDSN settings cannot be changed when external PDSN state is on. | This error message is displayed for information purposes only.
+531 Operation rejected; External PDSN state cannot be changed while a data connection is established. | This error message is displayed for information purposes only.
+532 Warning; External PDSN data connection dropped | This error message is associated with a lost data connection between MOB-IP-SIM and MS.
+533 Operation rejected; ping DUT functionality is not available while external PDSN state is on. | This error message is displayed for information purposes only.
+534 Operation Rejected; No Response From The External Device | This error is returned when attempting to Connect to External 8960 if the external 8960 does not respond to the connection request.
+535 Operation Rejected; The Device Rejected The Connection Request | This error is returned when attempting to Connect to External 8960 if the external 8960 rejects the connection request (this would happen, for example, if the external 8960 already has a connection to another 8960).
+536 Warning; Connection Is Already Established With The External Device | This error is returned when attempting to Connect to External 8960 if your test set is already connected to the external 8960.
+537 Operation Rejected; Change Allowed Only When A Connection To An External Device Does Not Exist | This error is returned when attempting to set the Ext 8960 IP Addr while External Device Conn Status is not Disconnected .
+538 Operation Rejected; External 8960 Test Set IP Address Cannot Be The Same As Instrument LAN IP Address | This error is returned when attempting to set the Ext 8960 IP Addr to the same value as LAN IP Address .
+539 Warning; Connection To The External Device Has Been Lost; All Calls Have Been Disconnected | This error occurs if the External Device Connection is broken (for example, if you disconnect the LAN cable from the test set).
+540 Operation Rejected; Cannot Process Request While Attempting To Connect To Or Disconnect From The External Device | This error is returned when attempting to Connect to External 8960 or Disconnect from External 8960 if the External Device Conn Status is Connecting or Disconnecting .
+541 Operation Rejected; External 8960 Test Set IP Address Cannot Be The Same As The DUT IP Address | This error is returned when attempting to set the Ext 8960 IP Addr to the same value as DUT IP Address .
+542 Operation Rejected; Service Not Available Without A Connection To An External Device | This error is returned when attempting to originate an end-to-end service without an External Device Connection in place.
+543 HTTP Client Error; failed to create socket |
+544 HTTP Client Error; failed to connect to the socket |
+545 HTTP Client Error; invalid IP address specified |
+546 HTTP Client Error; timeout |
+547 HTTP Client Error; could not access socket |
+548 HTTP Client Error; bad request URL |
+549 HTTP SMS request ignored; Illegal parameter in request | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface containing a parameter that is not supported.
+550 HTTP SMS request ignored; Request parameter out of range | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface containing a parameter value out of the supported range.
+551 HTTP SMS request ignored; Incompatible parameters in request | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface containing parameters that can not be used together in the same request URL.
+552 HTTP SMS request ignored; Missing mandatory parameter in request | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface that does not contain parameters required by the test set.
+553 HTTP SMS warning; Output message URL exceeded maximum length and has been truncated | This error is generated when the constructed URL received by the test set's HTTP interface for a mobile originated SMS message exceeds the maximum size of 1500 characters. This generally occurs if one or more tags have been duplicated in the output URL format string, causing the length restriction to be exceeded.
+561 Operation failed; The external device connection request failed likely because there is a firmware incompatibility between the two connecting devices. See www.agilent.com/find/8960upgrades for additional information | The underlying architecture of the External Device Connection feature has changed over time. The two implementations are not compatible. To establish an External Device Connection between two test sets, the test sets must have compatible firmware (see www.agilent.com/find/8960upgrades for more information)
+562 Operation failed; The incoming request for an external device connection request failed likely because there is a firmware incompatibility between the two connecting devices. See www.agilent.com/find/8960upgrades for additional information | The underlying architecture of the External Device Connection feature has changed over time. The two implementations are not compatible. To establish an External Device Connection between two test sets, the test sets must have compatible firmware (see www.agilent.com/find/8960upgrades for more information)
+563 Operation rejected; Calling party number 1 and calling party number 2 can not be set to the same number. | This error is generated when calling party1 number is set to the same value as calling party 2 number.


+600 through +699 Error Message Descriptions

+600 through +699 Error Message Descriptions

Last updated: December 17, 2004

Description

These errors are generated when a problem occurs that is specific to one of the test set's instruments. These errors are part of the test set's core. Note that these measurements may not be present in every test application and therefore, these errors may not be present in every test application. There is no plan at present to support test application specific instruments.

An instrument in this context refers to the measurement-like functionality such as the audio generator and not to the test set as a whole.

When one of these errors is generated, the `+600 errors' bit in the questionable error status register is set.

Error Message | Description
+601 Instrument failure; Audio generator hardware is not responding | Indicates a problem occurs when attempting to control the test set's audio generator.
+602 Data out of range; Spectrum Monitor; No peaks left |
+603 Data out of range; Spectrum Monitor; No peaks right |
+604 Data out of range; Spectrum Monitor; No peaks found |
+605 Operation rejected; Spectrum Monitor; Receiver power currently set to Auto |
+606 Operation rejected; Spectrum Monitor; Meas frequency currently set to Auto |
+607 Operation rejected; Spectrum Monitor; Marker Frequency out of Meas Frequency tune range |
+608 Operation rejected; Spectrum Monitor instrument is inactive |
+620 Data out of range; Total multi-tone audio downlink level upper limit exceeded; no change |
+621 Data out of range; Total multi-tone audio uplink level upper limit exceeded; no change |
+622 Warning; Multi-tone audio downlink level over range due to requested setting |
+623 Operation rejected; Multi-tone audio downlink levels cannot be set when total level state is on |
+624 Operation rejected; Multi-tone audio uplink levels cannot be set when total level state is on |


+700 through +799 Error Message Descriptions

+700 through +799 Error Message Descriptions

Last updated: June 30, 2006

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error. Errors are categorized as follows:

  • CDMA: errors common to CDMA systems (IS-95, IS-2000, IS-856 and W-CDMA)

  • Digital856: errors applicable to only the IS-856 system type

When one of these errors is generated, the +700 errors bit in the questionable error status register is set.

CDMA Measurement Errors
Error Message | Description
+701 Digital average power measurement is not responding | This error message indicates an internal software or hardware error.
+702 Waveform quality measurement is not responding | This error message indicates an internal software or hardware error.
+703 Channel power measurement is not responding | This error message indicates an internal software or hardware error.
+704 Frame error rate measurement is not responding | This error message indicates an internal software or hardware error.
+705 Access probe power measurement is not responding | This error message indicates an internal software or hardware error.
+706 Time response of open loop power control measurement is not responding | This error message indicates an internal software or hardware error.
+707 Gated power measurement is not responding | This error message indicates an internal software or hardware error.
+708 Tx spurious emissions measurement is not responding | This error message indicates an internal software or hardware error.
+710 CDMA measurement failure; Tx dynamic power measurement is not responding | This error message indicates an internal software or hardware error.
+713 CDMA measurement failure; Fast Device Tune measurement is not responding. |
+727 "CDMA measurement failure; Time response of open loop power control measurement requires receiver power control set to auto" |
+728 "CDMA measurement failure; Time response of open loop power control measurement requires receiver power to be within range before and after the measurement" |
+729 "CDMA measurement failure; Time response of open loop power control measurement requires cell power to be within range before and after the measurement" |
+741 "CDMA measurement failure; TX dynamic power measurement requires receiver power control set to manual" |
+780 CDMA measurement failure; Fast Device Tune measurement setup is not correct. Refer to your documentation CD or go to www.agilent.com/find/8960 for correct setup steps |
+781 CDMA operation rejected; Fast Device Tune feature is not licensed. See www.agilent.com/find/8960upgrades for additional information |
+782 CDMA measurement failure; Fast Device Tune measurement MS Tx/Rx frequency step sequence table start index + frequency step count must be less than or equal to 40 |
+783 CDMA measurement failure; Fast Device Tune measurement MS Tx/Rx power step sequence table start index + power step count must be less than or equal to 40 |
+784 CDMA measurement failure; Fast Device Tune measurement MS Tx/Rx frequency values in use must not be NAN |
+785 CDMA measurement failure; Fast Device Tune measurement MS Tx/Rx power levels in use must be not NAN |
+786 CDMA measurement failure; Fast Device Tune measurement MS Tx frequency values in use are not in the same band |
+787 CDMA measurement failure; Fast Device Tune measurement MS Rx frequency values in use are not in the same band |
+788 CDMA measurement failure; Fast Device Tune measurement MS Tx power levels in use are out of range |
+789 CDMA measurement failure; Fast Device Tune measurement MS Rx power levels in use are out of range. |
+790 CDMA measurement failure; Fast Device Tune measurement unable to build frequency and power sequence tables. Measurement is unavailable. Check the Message Log for error details |
+792 CDMA measurement failure; Fast Device Tune measurement first frequency in frequency sequence not in recognized frequency band |
Digitial856 Measurement Errors
Error Message | Description
+701 Packet error rate measurement is not responding | This error message indicates an internal software or hardware error.
+702 Waveform quality measurement is not responding | This error message indicates an internal software or hardware error.


+800 through +899 Error Message Descriptions

+800 through +899 Error Message Descriptions

Last updated: December 17, 2004

Description

These errors are generated when a problem occurs that is specific to one of the test set's core measurements (such as analog audio).

When one of these errors is generated, the `+800 errors' bit in the questionable error status register is set.

Error Message | Description
+801 Measurement failure; Analog audio hardware is not responding | Indicates that a problem occurs when attempting to control the measurement's hardware.
+802 Measurement failure; Audio analyzer hardware is not responding | Indicates that a problem occurs when attempting to control the measurement's hardware.
+803 Measurement failure; Signal Finder hardware is not responding |
+805 Measurement failure; Multi-tone audio hardware is not responding |


Using GPIB Command Debug Mode

Using GPIB Command Debug Mode

Description

It is recommended that you set the test set's operating environment to debug during GPIB code development. Test times may be longer than necessary if the debugger state is left on. When debug mode is on, the error message displayed on the test set's front panel when incorrect GPIB syntax is sent to the test set is enhanced with additional information to help you correct the syntax error.

To set the test set debug mode to "ON" use the following syntax:

SYSTem:COMMunicate:GPIB:DEBug ON

Related Topics

SYSTem:COMMunicate:GPIB:DEBug[:STATe]


Troubleshooting Setting Power Levels

Troubleshooting Setting Power Levels

Last updated: June 29, 2006

Before turning AWGN on, be sure cell power is not set to a level significantly below the AWGN level, or the connection may be dropped.

A power level may be within the settable range but cause an error message to be displayed. You should verify that:

  • The difference between cell power and AWGN power must not be more than 35 dB when both powers are ON.
  • The total RF power and amplitude offset must not set the source outside its valid hardware range.
  • When the test set is configured to physical layer subtype 2 and both Cell power and AWGN power are On, the power level of any MAC code channel generated must not be greater than 30dB below the current Total RF Power:
    • When any cell or AWGN power level is changed such that any code channel is more than 30dB below the current Total RF Power, an error message is posted to indicate the error condition. When this happens, the cell or AWGN setting is pended (saved but not applied to the hardware) and the current power setting is not updated (remain at previous setting) until the error condition is removed. See Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power .
    • When any MAC code channel level is changed such that the code level is more than 30 dB below the current Total RF Power, an error message is posted to indicate the error condition. When this happens, the code channel level is rejected (remain at previous setting). See Code Channel Parameters .

Related Topics

Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power


Swept Audio Measurement Troubleshooting

Swept Audio Measurement Troubleshooting

December 13, 2002

Possible Setup Issues

During remote operation of the Swept Audio measurement, you should always set the Trigger Arm setting to Single. The length of time required to return a measurement over GPIB using continuous triggering varies, but is always longer than when using single triggering. Continuous triggering can also cause problems when the INITiate:DONE? query is used.

If digital measurements are active, turn them off or set their trigger source to Immediate. See Triggering of Measurements .

The Detector Type selected (peak or rms) also sets how Audio Level measurements are displayed; as a peak value or an rms value. When comparing returned values over GPIB to your specifications, be sure to take into account the type of detector being used.

The Expected Peak Voltage is always set in V peak , regardless of the Detector Type selected, and cannot exceed 20 V peak (14.1 V rms ).

For accurate measurements, always set the Detector Type, Filter Type, and other audio analyzer settings for the type of measurement being made. The SINAD and Distortion measurements typically use different settings than the Audio Level measurement. See Audio Analyzer Measurement Description and Audio Analyzer Block Diagram .

For very low level audio signals, or for measurements made in a noisy environment, use the 100 Hz BW BPF filter to reduce the affects of noise (see Audio Analyzer Measurement Description ).

Interpreting Integrity Indicator Values

See Integrity Indicator .

If over range (5) is returned, the input level is greater than 4.9 dB above the Expected Peak Amplitude value or the maximum input level of 20 volts peak.

If under range (6) is returned, the input level is lower than 8 dB below the Expected Peak Amplitude value.

If the signal has both over range and under range conditions, only the over range condition (5) is indicated.


Spectrum Monitor Troubleshooting

Spectrum Monitor Troubleshooting

Last updated: December 13, 2002

Possible Setup Issues

During remote operation of the Spectrum Monitor you should configure the trigger arm to single, see SETup:SMONitor .

If the trigger arm is not set to single, the Spectrum Monitor may not return a result. When trigger arm is continuous the Spectrum Monitor rearms itself and starts another measurement cycle, during remote operation the fetch query may not be synchronized to the measurement cycle, see Measurement States .

If trigger source immediate is used for burst modulated signals the results returned will be unreliable. Burst modulated signals should be measured with Trigger Source set to RF Rise or Auto. For RF Rise triggering to work correctly, the signal should be no less than 20 dB below the reference and greater than -20 dBm.

Interpreting Integrity Indicator values

See Integrity Indicator .


Test Set Lockup Due to Power Up Sequence

Test Set Lockup Due to Power Up Sequence

Description

Loading application firmware onto your test set that is not compatible with your test set's hardware configuration will cause your test set to lock up when restarted.

For information on application firmware and test set hardware compatibility, see:

http://www.agilent.com/find/E5515

(select either E5515B or E5515C Release Notes).

Test sets shipped after February, 2004 include a lockup recovery utility in the event that a test set lockup occurs. If your test set has locked up during its power up sequence, turn the test set off. Turn the test set back on, and when the following text is displayed:

"Press `SYSTEM CONFIG' key to enter application selection utility."

press the SYSTEM CONFIG key.

If you press the SYSTEM CONFIG key within five seconds from the time this message is first displayed, a menu of installed applications is displayed that allows you to select an application to load.

Select an application that is compatible with your test set's hardware by entering the appropriate number listed on the display using the DATA ENTRY keys.


Time Response of Open Loop Power Control Troubleshooting

Time Response of Open Loop Power Control Troubleshooting

IMPORTANT
No other measurements can be running while the TROLPC measurement is active. If any measurements are running, they are closed when TROLPC is initiated, and a message is displayed indicating that a measurement has been closed. Activating another measurement inactivates the TROLPC measurement.

Possible Setup Issues

  • You must establish an RTAP (for Subtype 0 Physical Layer) or RETAP (for Subtype 2 Physical Layer) connection to perform the TROLPC measurement (see How Do I Open a Session and Test Data Connection? ).
  • C.S0033 does not specify that the R-ACK Channel must be active for 4.3.2 Time Response of Open Loop Power Control. If the R-ACK Channel is active during this test, the access terminal's power may fall outside of the mask specifications. To help ensure that your access terminal does not fail this test, you should disable the R-ACK Channel by setting ACK Channel Bit Fixed Mode Attribute to off and setting AT Directed Packets to 0%.

    IMPORTANT
    After completing TROLPC testing, you must return ACK Channel Bit Fixed Mode Attribute to on and set AT Directed Packets to a non-zero value appropriate for your test setup.

  • Cell power must be at least 20 dB below the maximum cell power level to perform a TROLPC measurement with a +20 dB step change in cell power. Cell power must be at least 20 dB above the minimum cell power level to perform a TROLPC measurement with a -20 dB step change in cell power. The cell power range is affected by amplitude offsets (see Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power ).
  • AWGN power must be off (see Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power ).
  • Receiver power must be set to auto (see Receiver Control ).
  • During remote operation of this measurement, you must specify the cell power step change direction using the SETup:TROPower:STEP command, and then start the measurement using either the INITiate:<measurement mnemonic>[:ON] or READ:TROPower[:ALL]? command. During manual operation, you must select either Start Meas Up ( F2 ) or Start Meas Down ( F3 ), or press the START SINGLE key to trigger each measurement. Each time you start the measurement, one 20 dB step change is performed.

Troubleshooting Techniques

  • Check to see if an integrity indicator other than 0 (normal) was returned with a measurement result (see Integrity Indicator ).

Other Considerations

  • To avoid over range or under range integrity indicators, correct for system path loss (see Amplitude Offset ).
  • If you are manually controlling the test set's receiver, be certain that you have entered the correct frequency value for your test setup (see Receiver Control ).
  • TROLPC Input Signal Requirements
  • Calibrating the TROLPC Measurement

Related Topics

Time Response of Open Loop Power Control (TROLPC) Measurement Description


User Interface (UI) Log

User Interface (UI) Log

Description

To help you troubleshoot or optimize your GPIB control programs, you can configure the test set to capture GPIB interface traffic and store it in the UI (User Interface) Log. To enable GPIB logging, see Step 2: Turn On UI Log GPIB State .

The UI log buffer can store up to 51200 bytes of information. If the buffer is full, the oldest entry is removed from the top of the log and the newest entry is added to the end.

You can reset and access the UI Log through either the GPIB interface or a Web Browser.

The following procedures demonstrate how to reset and access the UI Log.

  • Step 1: Clear UI Log Data
  • Step 2: Turn On UI Log GPIB State
  • Step 3-1: Get UI Log Data
  • Step 3 - 2: Get Other UI Log Information (Optional)
  • Step 4: Save UI Log Data

Step 1: Clear UI Log Data

Before capturing new GPIB traffic, you can clear the residual information in UI Log storage. Two methods are valid to clear UI Log data storage in the test set.

  • Clear the UI Log via Local Area Network (LAN)

    • Connect you computer to the test set via LAN or directly via a LAN crossover cable.
    • Go to the URL of the test set using a web browser such as Internet Explorer.
      URL in Web Browser to Clear UI Log Data
      Command | Example
      http:// <test_set_ip_address> /uilogclear | http://111.222.333.444/uilogclear

    Clear UI Log Data

  • Clear the UI log via GPIB

    • Connect your computer to the test set via a GPIB interface.
    • Send the GPIB command in the following table to the test set and the log is cleared
    GPIB Command to Clear the UI Log
    Command | Example
    SYSTem:LOG:UI:CLEAR | SYST:LOG:UI:CLEAR
    .

Step 2: Turn On UI Log GPIB State

  • Send the GPIB command in the following table to the test set before you run your test program or send it from the point in your program where it is desired to start GPIB logging.

    NOTE
    The Log GPIB state is reset to OFF after cycling power. It is not reset by a full preset.

    UI Log GPIB State Command
    Command Example

    SYSTem:LOG:UI:GPIB[:STATe] ON|OFF

    SYST:LOG:UI:GPIB:STAT ON

Step 3-1: Get UI Log Data

  • Go to the URL of the test set using your web browser to retrieve the GPIB log. The GPIB log is displayed in the browser window.

    NOTE
    You must ensure the computer is connected to the test set either via Ethernet LAN or a direct connection using a LAN crossover cable.

    URL in Web Browser to get the UI Log Data
    Command | Example
    http:// <test_set_LAN_IP_Address> /uilog | http://111.222.333.444/uilog
    Display UI Log Data in Web Browser

    NOTE
    In addition to GPIB traffic information, the UI Log also includes data regarding the key presses, knob turns and error messages that occur as you operate your test set from the front panel. Only the lines with the prefix "rem:" indicate the GPIB commands.

The UI Log display is not real time, therefore the latest UI log does not display automatically in the web browser. To capture multiple logs, click Refresh in the View menu.

Step 3 - 2: Get Other UI Log Information (Optional)

You can get more information about UI log data by sending the GPIB queries.

  • Query the number of lines containing GPIB commands in the UI Log

    The GPIB query in the following table returns the number of lines in the log since the latest time the log is cleared and before receiving this query.

    Query the numbers of GPIB commands in the UI Log
    Command Example

    SYSTem:LOG:UI:COUNt?

    SYST:LOG:UI:COUN?
  • Query the string at the specified line in the UI Log

    The GPIB query in the following table returns the string located at the line you specified in the log.

    Query the string in the UI Log
    Command Example

    SYSTem:LOG:UI:REPort? <sp><number value>

    SYST:LOG:UI:REP? 11

Step 4: Save UI Log Data

To save the log in the Web Browser to a file:

  1. In the File menu, click Save As....
  2. In the Save as type: box, select Text File (*.txt).
  3. In the File name: box, type the file name.
  4. Click the Save button.

Related Topics

SYSTem:COMMunicate:GPIB:DEBug[:STATe]


Data Channel Applications

Data Channel Applications

Last updated: April 14, 2005

This section is only applicable to the lab application.

Data applications such as interactive and multimedia applications are appearing more often on wireless devices as data rates go up. The test set's data channel feature supports the following applications:

  • WAP Functional Test
  • HTTP Functional Test
  • FTP Functional Test
  • Access Network Emulation

WAP Functional Test

The test set's Data Channel facilitates the functional test of a Wireless Application Protocol (WAP) device such as a WAP-enabled mobile station.

Logging data during this process provides protocol data at useful points in the stack, which may help in debugging a 1xEV-DO wireless device.

Before you use the data channel for WAP functional test, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network (not the same as the WAP gateway)
  • a valid IP address for the DUT
  • the default WAP gateway address (this may be required by the 1xEV-DO wireless device)

HTTP Functional Test

The data channel feature facilitates Hypertext Transfer Protocol (HTTP) based application test via the wireless device. Typically this is done with a dial-up connection to an external PC using a 1xEV-DO wireless modem.

Before you use the data channel for HTTP testing, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network
  • a valid IP address for the modem or its controlling PC (even though the modem is the Device Under Test (DUT), typically a PC will be assigned the IP address)
  • a valid IP address for the HTTP server

FTP Functional Test

The Data Channel facilitates File Transfer Protocol (FTP) based application test via the wireless device. Typically this is done with a dial-up connection to an external PC using a 1xEV-DO wireless modem.

With appropriate evaluation tools on the Control PC, you can measure the throughput of the modem. Many commercial FTP programs provide detailed information on transfer speed.

To empirically measure the throughput, the performance of the network must be known. For this reason, it is not recommended to perform this evaluation while connected to the Internet. A direct connection or Intranet connection should be used instead.

Before you use the data channel for FTP testing, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network
  • a valid IP address for the modem or its controlling PC (even though the modem is the Device Under Test (DUT), typically a PC will be assigned the IP address)
  • a valid IP address for the FTP server

Access Network Emulation

You can use the Data Channel and the test set to emulate an access network with packet data services. This is particularly useful when you want to have an access network available, for example when demonstrating a wireless application, or when functionally testing wireless devices on a workbench. You may also want to vary key parameters of the cell, such as transmit power, and observe how the DUT performs.

Before you use the data channel for Base Station Emulation, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network
  • a valid IP address for the DUT

Related Topics

Packet Data Service Example Procedure (via Simple IP)


Summary of Data Channel Operations in the Test Set

Summary of Data Channel Operations in the Test Set

This section is only applicable to the lab application.

The data channel function allows you to use the test set as an IP router, exchanging packet data between a 1XEV-DO wireless device and a packet switched network (such as an IP network) via a packet data connection. It is useful when the performance of data applications such as music download, interactive and multimedia applications needs to be tested in a controlled environment. There are several applications of the Data Channel (see Data Channel Applications ).

The Session Application Type must be set to the Default Packet Application before an AT will initiate a packet data connection with the test set.

When operating in the Default Packet Application,

  • the test set supports packet data connections using Simple IP protocol via its internal PDSN simulation (see How Does Test Set Support Simple IP Packet Data Connection? ). This allows you to test the Simple IP based data applications running on a 1xEV-DO wireless device. See Packet Data Service Example Procedure (via Simple IP) .

  • the test set supports packet data connections using either Simple IP or Mobile IP by working with an external Mobile IP Simulator (MOB-IP-SIM) provided by the Software Concepts, Inc. (see How Does Test Set Support Mobile IP Packet Data Connection? ). This allows you to test the Mobile IP based data applications running on a 1xEV-DO wireless device. See Packet Data Service Example Procedure (via Mobile IP) .

  • the test set provides several tools such as Data Counters , Data Throughput Monitor and Wireless Protocol Advisor (WPA) software (see Protocol Logging ) to monitor and evaluate the performance of your wireless device on data transfer.

  • you should always set the AT Directed Packets to 100% for maximum throughout. The test set transmits the forward traffic data at a rate requested by the AT via the DRC channel with a DRC length of 8 slots. The test set determines the reverse traffic data rate from the Reverse Rate Indicator (RRI) channel that is used by the AT to indicate the data rate at which the reverse traffic channel is transmitted. The settings of Limited TAP , FTAP Rate and RTAP Rate that are used in a TAP (test application protocols) connection have no effect on the data transfer rate while in a DPA (default packet application) connection

    To evaluate the effects of the RF degradation on the data rate, you can change the Cell power or add an AWGN (Additive White Gaussian Noise) noise source (see Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power ) during data transfer. The Traffic Channel Packet Information screen will provide you with the information on how much packets are transferred at what data rate on the forward and reverse traffic channels. Also, you can use Data Throughput Monitor to analyze data transfer rates under various RF conditions.

  • the test set supports consolidated packets transmission. That is, the connection layer can consolidate as many as four session layer packets as opposed to the one used in Forced Single Encapsulation (see Forced Single Encapsulation . This efficiently increases the throughout.
  • the test set provides a Ping tool to help check system interconnects.

Related Topics

Data Channel


Data Counters

Data Counters

Last updated: June 16, 2006

This section is only applicable to the lab application.

  • Data Counters
  • Traffic Channel Packet Information

Data Counters

When a packet data connection is established (see How Do I Make a Packet Data Connection? ), the test set keeps a running count of the Radio Link Protocol (RLP) control messages, RLP user packets, and Internet Protocol (IP) packets as data is transferred. This information is recorded in the Data Counters table as shown in the figure below.

Data Counters

  • RLP Control counters: keep a running count of RLP control messages transferred on both the forward and reverse traffic channels.

    • Reset Message is sent by both the AT and the test set to reset RLP.
    • NAK message is sent by both the AT and the test set to request the retransmission of one or more octets.
    • NAKKed Octets indicates the total number of octets requested in the NAK messages for retransmission.

    When these RLP control counters reach their maximum value (10,000,000,000), they automatically reset to zero and resume the count.

  • RLP Data counters: keep a running count of RLP user data for both the new and retransmitted octets transferred on both the forward and reverse traffic channels. A RLP packet is composed of a RLP header and a RLP payload (a number of user data octets).

    When these RLP data counters reach their maximum value (10,000,000,000), they automatically reset to zero and resume the count

  • IP Data counters: keep a running counter of IP packets and bytes transferred on both the forward and reverse traffic channels.

    When these IP data counters reach their maximum value (9,999,999,999), they remain at that value until cleared.

To Clear Data Counters

All of the data counters (including RLP and IP) will be cleared when the test set performs a power-up or full preset. You can also clear the RLP counters and IP counters individually (see How Do I Access the Data Counters? ).

Traffic Channel Packet Information

Traffic Channel Packet Information is used to show the traffic activity on both the forward and reverse link. The information allows you to determine how many physical layer packets are transmitted or received at the particular data rate or packet size. The test set transmits the forward data packets at a rate requested by the AT via the DRC channel and determines the reverse traffic data rate detected from the R-RRI channel (the R-RRI channel is used by the AT to indicate the data rate at which the reverse traffic channel is transmitted).

When a data connection is established, the test set begins to accumulate the physical layer packets transmitted on both the forward and reverse traffic channels. If the data connection is disconnected, the packet accumulation will be suspended until another connection is made and the accumulation continues. Packet accumulation can be cleared by a power-up, full preset, measurement reset or an explicit clear operation, see To Clear Traffic Channel Packet Counters for details.

The test set provides two ways to view the traffic channel packet information:

  • Traffic Channel Packet Info Screen (a set of numeric counters for both the forward and reverse traffic)
  • Traffic Channel Packet Histogram (intuitive graph view for forward traffic only)

Traffic Channel Packet Info Screen

Two sets of counters are available on the Traffic Channel Packet Info screen:

  • Forward Packets per DRC counters record the physical layer packets being sent on the forward traffic channel at each specific transmission format (data rate or packet size).

    Total Directed counter records the total number of forward traffic packets that were directed to the AT under test. Not Directed counter records the total number of forward traffic packets that were not directed to the AT under test (that is, directed to a non-existent AT via a different MAC Index. See AT Directed Packets for more description).

  • Reverse Packets per Data Rate or Packet Size counters record the physical layer packets being received on the reverse traffic channel at each specific data rate or packet size. Null packets indicate the packets that do not contain traffic data.

When a data connection is established, all these counters keep a running count of the traffic packets sent at each specific transmission format since the counters were cleared. The counters are updated approximately once every second. When the counters reach their maximum value (100,000,000), they automatically reset to zero and resume the counting.

  • For subtype 0 physical layer, when a TAP (Test Application Protocol) or DPA (Default Packet Application) data connection is established, the Traffic Channel Packet Info screen is displayed as shown in the Traffic Channel Packet Info (for Subtype 0 Physical Layer) .
    • For a TAP test data connection (see Test Application Protocol ), the AT always requests the forward data rate as specified by the FTAP Rate and transmits the reverse test packet at a rate as specified by the RTAP Rate .
    • For a DPA data connection (see Session Application Type ), the forward and reverse data rates are determined based on the actual radio link conditions. For example, when you change the Cell power or add an AWGN (Additive White Gaussian Noise) power (see Cell Power, AWGN (Additive White Gaussian Noise) Power and Total RF Power ), you will see that the forward and reverse data rates requested or indicated by the AT are varied.
    Traffic Channel Packet Info (for Subtype 0 Physical Layer)
  • For subtype 2 physical layer, when an ETAP (Enhanced Test Application Protocol) test data connection is established, the Traffic Channel Packet Info screen is displayed as shown in the Traffic Channel Packet Info (for Subtype 2 Physical Layer) .
    • For an ETAP test data connection (see Enhanced Test Application Protocol ), the F-Traffic Format (if DRC Value Fixed Mode Attribute is on) or the F-Traffic Config (if DRC Value Fixed Mode Attribute is off) is used to control the forward packet transmission format. The R-Data Pkt Size is used to control the reverse data packet size.
    • Note that the test set currently does not support DPA connection in subtype 2 physical layer (see Release A Physical Layer Subtype ).
    Traffic Channel Packet Info (for Subtype 2 Physical Layer)

Traffic Channel Packet Histogram

As shown in the figure below, the Traffic Channel Packet Histogram screen uses both the bar graph and tabular data to show the forward traffic activity (per each DRC) when a data connection is established. The histogram screen only displays the forward traffic activity (the total number of forward traffic packets that is transmitted by the test set to the AT for the given DRC and transmission format) during the last (most recent) Time Span period.

  • The Time Span can be specified from 1 to 30 seconds. The Traffic Channel Histogram counters will be cleared whenever the Time Span is changed.
  • The Traffic Channel Histogram graph can be paused and resumed with the Freeze Histogram and Resume Histogram . Note that the freezing action only pauses the display and does not stop the test set from counting. Once resumed, the Histogram display are updated to the last Time Span seconds of records based on the internal counters which continued to update while the histogram results were paused.
  • A marker can be placed at a particular DRC to observe the associated instantaneous statistic results. The marker value is displayed at top of the graph and also highlighted in the table below the graph. Note that when operating at the subtype 2 physical layer, the test set counts all of the packets at that DRC (including canonical and short packets transmission formats). The marker value displayed at the top of the graph provides individual results for each of the transmission format at that DRC. The tabular data gives the total number of packets transmitted at that DRC and transmission format. Markers can be used in conjunction with the Freeze Histogram feature to analyze the forward data packets transmitted at a particular DRC at a particular time.
  • The green line on the histogram indicates the theoretical maximum number of packets that can be sent at that DRC during the specified time span. It is calculated by 600*time_span/num_slots, 600 is the number of slots transmitted in one second, time_span is equal to the specified Time Span in seconds and num_slots is the number of slots required to send a packet at that DRC and transmission format. (Note that even at 100% AT Directed Activity and no early termination the histogram bars can never reach the green line because control packets transmitted on the traffic channel are not counted).

To Clear Traffic Channel Packet Counters

The following operations will clear all of the counters on the Traffic Channel Packet Info Screen and the Traffic Channel Packet Histogram :

  • the test set performs a power-up, full preset, or measurement reset;
  • the Current Physical Layer Subtype (see Release A Physical Layer Subtype ) is changed;
  • you press the F3 ( Clear Traffic Counters ) key or send the CALL:COUNt:CLEar:MS:TRAFfic command.
In addition to above operations, the Histogram counters can also be cleared by:
  • pressing the F3 ( Clear Histogram ) key or sending the CALL:COUNt:CLEar:MS:TRAFfic:HISTogram command;
  • changing the histogram Time Span with F1 key or the CALL:COUNt:MS:DRC:RX:HISTogram:SPAN .

Related Topics

Manual Operation: How Do I Access the Data Counters?

GPIB commands: CALL:COUNt


Packet Data Service Example Procedure (via Simple IP)

Packet Data Service Example Procedure (via Simple IP)

Last updated: May 24, 2006

This section is only applicable to the lab application.

The following procedure is an example of how to use the test set for IP packet data transfer. This example uses the test set's internal PDSN simulation to provide simple IP protocol. In this case, the test set is responsible for actual termination of the PPP link and propagating the encapsulated IP packets directly to the ethernet interface (LAN port).

All test sets capable of running the 1xEV-DO Lab Application have an internal server with an 8960 web site. This web site provides screen capture images and supports printouts.

The following procedure will demonstrate how to access this web site via the RF interface using a 1xEV-DO access terminal (AT) as a wireless modem. The AT will be connected to the USB port on a laptop computer (PC) running USB port software developed by the manufacturer of the access terminal. The Wireless Protocol Advisor (WPA) can be used for logging the protocol messages during the packet data transfer. See HTTP Functional Test for a typical connection.

The purpose of this procedure is to serve as an overview of the tasks required for a typical data channel application. If your particular application involves accessing internet or intranet sites via the test set's LAN interface, additional requirements such as getting through corporate firewalls may complicate setup procedures.

If you want to test data applications using mobile IP protocol, see Packet Data Service Example Procedure (via Mobile IP)

A. PC Setup

Install and Configure Device Driver

Install the USB and modem drivers provided by the wireless modem manufacturer. Connect the USB port from the wireless modem to the PC. When run for the first time, the software prompts the user for setup information. When properly configured, the PC will recognize the wireless modem on the USB (or other) port.

Configure the PC for a dial-up connection to the Internet via the wireless modem

The laptop has to be configured to include the wireless modem in its list of networks. The network dial-up connection properties must be configured according to the requirements of the wireless modem and the data port driver (NOTE: Most access terminals require the dialed number to be #777). When the PC is properly configured, the "Network and Dial-up Connections menu" should include the wireless modem in its list of connections.

In this example, on the PC running the Windows 2000, select the Network and Dialup Connections from the Control Panel. Select Local Area Connection icon, right click, and select Disable. Then select the Make New Connection icon, set up an internet connection with the new added modem (the connection is named as "Wireless Modem", for example).

B. Hardware Connections

There are many different configurations for testing wireless modems (or other wireless appliances such as WAP enabled access terminals) data handling performance. See HTTP Functional Test for a diagram of the connection used for this example.

  • RF (Wireless Modem to Test Set): Connect the wireless modem RF cable to the test set's RF In/Out port.
  • PC to Wireless Modem: For this example, the USB port provides the connection. Connect the USB port from the wireless modem to the PC

C. Test Set Setup

  1. Set up test set's LAN IP address. For example,
    • Press the SYSTEM CONFIG key.
    • Press the Instrument Setup ( F1 ) key.
    • Set LAN IP Address to 130.29.181.1
    • Set Subnet Mask to 255.255.0.0
    • Set Default Gateway to be blank (enter a 0 to make it blank)
    • Press F6 ( Close Menu ).

    NOTE
    The settings of LAN IP Address , Subnet Mask and Default Gateway depend on your local network that the test set is connected to. You should work with your IT department for proper IP settings.

  2. Set up call parameters required for an open session during the packet data connection (see How Do I Change Call Parameters? for a general procedure).
    • Press the Call Setup key.
    • Select Application Config ( F10 on Call Parms 1 of 3) and set Service Application Type to Default Packet Application .
    • You may need to set some parameters (such as Cell Power, Cell Band, Channel, etc.) required for your wireless devices to find service with the test set.

  3. Set up data channel parameters required for the packet data connection (see How Do I Set Up Data Channel Parameters? for a general procedure).

    • Select the Data Channel Info ( F2 on Call Control 3 of 3).
    • Select the Data Channel Parameters ( F1 ).
    • Set the DUT IP Address (for example, 130.29.181.2).
      In this example, you should set the DUT IP Address and the test set's IP address (you have done in step 2) unique and in the same subnet (see IP Address Requirements ). Note that the DUT IP Address will be sent to the PC via AT (modem) if you set the Internet Protocol (TCP/IP) Properties to "Obtain an IP address automatically" menu.
    • Make sure that the External PDSN State is set to Off (Indicating using test set's internal PDSN).
    • Press F6 ( Close Menu ).

  4. Now, the test set setup are ready for a dial-up connection from the PC.

D. Functional Test

In order to test the functioning of the wireless modem, it must first complete a dial-up connection between the PC and the test set.

  1. Turn the wireless modem (AT) on and wait for it to open a session. Check for Session Open in the Active Cell status field and the access terminal information shown on the Call Setup screen. See B. Open a Session .
  2. On the PC (for example, Windows 2000), select Start, Settings, and Control Panel. In the Control Panel window double click Network and Dial-up Connections.
  3. Double click the icon labeled with "Wireless Modem" which has been set up during the procedure of Configure the PC for a dial-up connection to the Internet via the wireless modem .
  4. In the Dial-up Connection window, select the Dial button.
  5. Verify that a connection is active by looking for Connected shown in the Active Cell field on the bottom center portion of the test set's screen. Now, you are ready for the demonstration to continue.

  6. Open the browser on the PC (for example, Internet Explorer). Enter the test set's IP address on the address area of the PC's browser (in this example, http://130.29.181.1). The PC browser should display the test set's internal web server page:

  7. Double-click on the Get Image , the current screen on your test set's front panel will be displayed on your browser. As data is transferred, monitor the Data Counters (see Data Counters ). or the Data Throughput Monitor window (see Data Throughput Monitor ) from the test set. You can see the data rate variation during the data transfer. To evaluate the effects of the RF degradation on the data rate, you can adjust the Cell power or add an AWGN (Additive White Gaussian Noise) power. The data rate changes can be easily identified from the Traffic Channel Packet Information screen.
  8. You can also use the Wireless Protocol Advisor (WPA) to log 1xEV-DO SLP (Signaling Link Protocol), RLP (Radio Link Protocol), PPP (Point-to-Point Protocol) and IP (Internet Protocol) messages for protocol analysis. See Protocol Logging .

Related Topics

Simple IP and Mobile IP


Packet Data Service Example Procedure (via Mobile IP)

Packet Data Service Example Procedure (via Mobile IP)

Last updated: May 24, 2006

This section is only applicable to the lab application.

The following procedure is an example of how to use the test set and an external PDSN simulator (MOB-IP-SIM) using Mobile IP protocol for IP packet data transfer. In this case, the test set will forward the PPP octets delivered by RLP data to the external MOB-IP-SIM. The MOB-IP-SIM is responsible for actual termination of the PPP link and interpreting all protocol layers necessary to pass the end-to-end encapsulated IP packets directly onto the network (IP, UDP, MIP).

This procedure will demonstrate how to access the MOB-IP-SIM built-in web site via the RF interface using a 1xEV-DO wireless device (such as an access terminal) as a wireless modem. The access terminal will be connected to the USB port on a laptop computer (PC) running USB port software developed by the manufacturer of the access terminal. The Wireless Protocol Advisor (WPA) can be used for logging the protocol messages during the packet data transfer. See Test Set's Mobile IP Solution Setup for a typical setup.

If you want to use the test set's internal PDSN simulation without the need of an external PDSN simulator for packet data transfer, see Packet Data Service Example Procedure (via Simple IP) .

The purpose of this procedure is to serve as an overview of the tasks required for a typical data channel application using the mobile IP protocol. If your particular application involves accessing internet or intranet sites via the MOB-IP-SIM's LAN interface, additional requirements such as getting through corporate firewalls may complicate setup procedures.

A. Pre-Setup

  • Ensure the access terminal is pre-programmed with known parameters (such as home IP address).
  • Refer to the MOB-IP-SIM technical manual to properly configure the MOB-IP-SIM (for example, IP address, subnet mask, etc.).
  • Set up the PC using wireless modem (access terminal) for dial-up connection (see A. PC Setup ).

B. Hardware Connection

Refer to the Test Set's Mobile IP Solution Setup for a typical connection.

  • Connect the access terminal (support of mobile IP protocol) to the test set's front panel RF IN/OUT connector.
  • Connect the access terminal to the USB port on a laptop computer (PC) running a web browser (for example, internet explorer).
  • Connect the test set and the MOB-IP-SIM to a LAN.
  • (Optional) If you want to log the protocol messages during the packet data connection, connect an PC running the Wireless Protocol Advisor (WPA) to the LAN. This PC is also used to configure the MOB-IP-SIM.

C. Test Set Configuration

  1. Set up the test set's LAN IP address. See step 1 described in C. Test Set Setup .
  2. Set up call parameters required for an open session for the packet data connection. See step 2 described in C. Test Set Setup .

  3. Set up data channel parameters required to use the external PDSN (MOB-IP-SIM) for the packet data connection (see How Do I Set Up Data Channel Parameters? for a general procedure).

    • Select the Data Channel Info ( F2 on Call Control 3 of 3).
    • Select the Data Channel Parameters ( F1 ).
    • Set the External PDSN IP Address to match the MOB-IP-SIM's IP address you've set in A. Pre-Setup .
    • Set the External PDSN TCP Port to the default value (currently, the TCP port for the MOB_IP_SIM is fixed to 53613)
    • Set the External PDSN State to On . (Indicating the external PDSN is used. You should properly set the External PDSN IP Address and the External PDSN TCP Port and then turn the External PDSN State to On .)
    • Press F6 ( Close Menu ).

    In this example, the home IP Address of your access terminal is obtained from the external PDSN (MOB-SIM-IP) instead of from the test set's DUT IP Address setting. Refer to the MOB-IP-SIM technical manual to properly configure the Home Node IP address for your access terminal.

  4. Now, the test set setup are ready for a dial-up connection from the PC.

D. Functional Test

In order to test the functioning of the wireless modem, it must first complete a dial-up connection between the test set and the PC.

  1. Follow the steps 1 - 4 described in D. Functional Test to make a a dial-up connection from the PC.
  2. Verify that a connection is active by looking for Connected shown in the Active Cell field on the bottom center portion of the test set's screen. Now, you are ready for the demonstration to continue.

  3. To access the MOB-IP-SIM built-in web site, open the web browser (for example, Internet Explorer) on your laptop and enter the MOB-IP-SIM's IP address (for example, http://130.29.181.1). The browser should display the MOB-IP-SIM's internal web home page:

  4. You can click on the links to view the desired information. As data is transferred, monitor the Data Counters (see Data Counters ), or the Data Throughput Monitor window (see Data Throughput Monitor ) from the test set. These tools are useful for analyzing data transfer throughout. To evaluate the effects of the RF degradation on the data rate, you can adjust the Cell power or add an AWGN (Additive White Gaussian Noise) power. The data rate changes can be easily identified from the Traffic Channel Packet Information screen.
  5. You can also use the Wireless Protocol Advisor (WPA) to log 1xEV-DO SLP (Signaling Link Protocol) and RLP (Radio Link Protocol), as well as PPP (Point-to-Point Protocol) and IP (Internet Protocol) packets for protocol analysis. See Protocol Logging .

Related Topics

Simple IP and Mobile IP


Getting Started with the Data Channel

Getting Started with the Data Channel

Last updated: April 14, 2005

This section is only applicable to the lab application.

The data channel feature allows you to use the test set as an IP router, exchanging packet data between a 1xEV-DO wireless device and an external IP network via a packet data connection.

For general information to help you become more familiar with the data channel feature, see Data Channel Overview .

To review the setup and use of the data channel feature, see Data Channel Configuration and Data Channel Capabilities .

TO RETURN TO THE MAIN MEASUREMENTS PAGE, click here: Data Channel .


Hybrid Mode

Hybrid Mode

Last updated: December 1, 2005

This section is only applicable to the lab application.

  • Overview
  • How Does Test Set Support Hybrid Mode AT/MS Tests?
    • Prerequisite Setup
    • General Test Procedure
    • Operating Considerations

NOTE
The terms of the access terminal (AT) and access network (AN) that are used in the IS-856 (1xEV-DO) system are equivalent to the terms of the mobile station (MS) and base station (BS) used in the IS-2000/IS-95 (CDMA) system.

Overview

In a wireless network that supports both the IS-2000/IS-95 (CDMA) and IS-856 (1xEV-DO) systems, a hybrid mode AT/MS is capable of:

  • acquiring both the IS-2000/IS-95 and IS-856 systems, and maintaining registration and overhead information on both types of system concurrently.

    A hybrid mode AT/MS on power-up will first try to search and acquire an IS-2000/IS-95 system and then acquire a collocated IS-856 system. Once acquiring, the AT registers to the IS-2000/IS-95 system and opens a session with the IS-856 system. It will then periodically monitor the IS-2000 paging channel and IS-856 control channel.

    Note that some hybrid mode AT/MSs are designed as primarily a CDMA device with 1xEV-DO capabilities. This kind of hybrid mode AT/MS will first try to search and acquire a CDMA system before searching for a collocated 1xEV-DO system. If CDMA service is not acquired first, the hybrid mode AT/MS will not try to acquire 1xEV-DO service, even if available.

  • supporting services on both the IS-2000/IS-95 and IS-856 systems.

    While operating on both the IS-2000/IS-95 and IS-856 systems, a hybrid mode AT/MS can connect services available on either system in response to an origination request or page match. The most advantage of hybrid mode AT/MS is able to monitor voice calls when in a 1xEV-DO data connection. Moreover, voice services takes a higher priority over packet data service. That is, the packet data being transferred will be pending and the voice call is serviced whenever there is a voice call.

    The hybrid mode AT/MS supports two operating modes: non-simultaneous voice and data (non-SVD) mode and SVD mode. The key difference between the non-SVD and the SVD modes is as follows:

    • For the AT/MS that supports non-SVD mode, whenever a voice call is received or originated on the IS-2000/IS-95 system while the AT having an active packet data transfer on the IS-856 system, the packet data being transferred will be pending on the IS-856 system. The packet data transfer will not resume on the IS-856 system until the voice call is terminated. To avoid wasting forward link capacity of the IS-856 system, the hybrid mode AT/MS sets the cover of the R-DRC channel to the null value shortly before tuning away to the IS-2000/IS-95 system (this stops forward packet transmission and causes the IS-856 data session to go dormant). When the voice call is terminated, the hybrid mode AT/MS returns to the IS-856 system and resumes the data session (coming out of dormancy).
    • For the AT/MS that supports SVD mode, when there is a dormant/active data connection on IS-856 system and a voice call is attempted, the AT/MS will establish the voice call on IS-2000 system and also transfer the packet data session from IS-856 system to IS-2000 system via dormancy. If the user application attempts to send data, it will trigger a service option 33 packet data connection while keeping the voice connection on the IS-2000 system.

      NOTE
      The test set does not support SVD operation.

  • supporting handoff of an existing packet data session between IS-2000 and IS-856 systems.

    NOTE
    The data session handoff are not supported by a hybrid mode AT/MS when operating on an IS-95 system.

    Since packet data service can be provided on either an IS-2000 system or an IS-856 system, a hybrid mode AT/MS is able to handoff an existing packet data connection across systems when the current connected system is unavailable. However, the preference of packet data service is given to the IS-856 system when both systems are available.

    • A hybrid mode AT/MS can handoff an active or dormant data connection from IS-856 system to IS-2000 system.

      This is because the AT periodically monitors the IS-2000 channel and has knowledge of both the IS-856 and IS-2000 channel conditions and the up-to-date IS-2000 overhead information. When IS-856 system is lost (for example, user drives out of the IS-856 system coverage) during an active or dormant data connection, the hybrid mode AT/MS will initiate an SO33 packet data connection on the IS-2000 system.

    • A hybrid mode AT/MS can handoff a dormant data session from IS-2000 system to IS-856 system, but does not support an active data session handoff from IS-2000 system to IS-856 system.

      When a packet data session is dormant on IS-2000 system, AT monitors for IS-856 system. Since the preference of packet data service is given to the IS-856 system, AT immediately hands off the dormant data session from IS-2000 system to IS-856 system when IS-856 system is available and found.

      The hybrid mode AT/MS does not support monitoring IS-856 system when IS-2000 traffic channel is active. Therefore, when the AT has an active packet data session on IS-2000 system, it stays on IS-2000 system (even if the IS-856 system is available) until data connection is terminated on IS-2000 system.

    • A hybrid mode AT/MS supports implicit handoff during origination. If AT fails to open IS-856 data connection for a few attempts, AT transfers the data session and originates on the IS-2000 system.

How Does Test Set Support Hybrid Mode AT/MS Tests?

  • Prerequisite Setup
  • General Test Procedure
  • Operating Considerations

Prerequisite Setup

To perform the functional test of the hybrid mode AT/MS, two test sets, one providing a CDMA network emulation and another one providing an 1xEV-DO network emulation, are required. A typical connection diagram for hybrid mode AT/MS test is shown in the figure below and followed with description.

  • Make sure you have two test sets available. The test set #1 running the E6702B lab application is to emulate an IS-2000/IS-95 system (CDMA) and the test set #2 running the E6706A lab application is to emulate an IS-856 system (1xEV-DO).
  • Have the two test sets synchronized on CDMA system time. For detailed procedure on how to get the two test sets synchronized, see Multi-unit Synchronization . Once the two test sets are synchronized, the trigger connection between the two test sets are not necessary but the 10 MHz REF connection should be kept.
  • Connect the two test sets' individual RF In/Out ports together to a lowloss resistive combiner and the output of the combiner is connected to the antenna port of the hybrid mode AT/MS.
  • If you want to log the messages exchanged between the hybrid mode AT/MS and test sets, a PC running the wireless protocol advisor (WPA) software is required to be connected to the same subnet of the two test sets. In addition, the PC can be installed as a WAP, FTP, HTTP server (depending upon your packet data application) for verifying your hybrid AT/MS packet data capabilities.

The following additional setups are required for hybrid mode AT/MS tests using mobile IP (MIP) (see tests 21-28 on Specific Procedures for Recommended Tests ).

  • An external mobile IP simulator (MOB-IP-SIM, provided by the Software Concepts, Inc.) is recommended to connect to the same subnet with the two test sets. The MOB-IP-SIM provides functions such as PDSN simulation, Home Agent, etc. to allow testing the hybrid mode AT/MS that uses mobile IP technology to provide seamless high speed data connections in a mobile environment. For details on the MOB-IP-SIM functionality and configurations, see the MOB-IP-SIM technical manual available on the web:

    http://www.softwareconceptsinc.net/MIP-5850.html

Now, the hardware connection is finished and you are ready to perform the hybrid mode AT/MS tests.

General Test Procedure

There are many test cases recommended by Qualcomm® to evaluate the hybrid mode AT/MS's capabilities (as described on Overview ). For details on these tests' definitions, see Recommended Functional Tests for Hybrid Mode AT/MS .

The general procedure for the hybrid mode AT/MS test is as follows:

  1. Make sure you have finished the Prerequisite Setup , especially ensure that the two test sets are synchronized on CDMA system time.
  2. Set the call parameters on the two test sets properly so that the hybrid mode AT/MS can successfully acquire both the IS-2000/IS-95 and IS-856 systems, get registered on the IS-2000/IS-95 system and open a session on the IS-856 system.

    NOTE
    Most ATs will immediately initiate a session with the IS-856 system (1xEV-DO) once they reach the idle state upon power-up. So you will see Session Open state is always shown on the test set #2 when the hybrid mode AT/MS has successfully acquired/negotiated on the IS-856 system (1xEV-DO).

  3. Change the parameters as required for each recommended test and verify the hybrid mode AT/MS's behavior.

For the detailed test procedure, see How Do I Make Hybrid Mode AT/MS Tests? .

Operating Considerations

  • Prior to making the hybrid mode AT/MS tests, make sure your AT/MS is correctly programmed to operate in the hybrid mode. Refer to your wireless device's technical manual for details on the configuration.
  • Prior to making the hybrid mode AT/MS tests, make sure you have made the proper connection and the two test sets are synchronized on CDMA system time. See Prerequisite Setup .
  • The two test sets should not operate on the same RF frequency. The RF frequency for each test set is determined by the Cell Band and Channel settings. You should set the test sets to match the parameters stored in the hybrid mode AT/MS.
  • The Preferred Control Channel Cycle Control must be set to AT Specified (from Call Control 2 of 3 , F2 Access Network Info , F1 Configurable Attribute Ctrl ). This allows the AT/MS to propose the PCCC attribute during the session negotiation to guarantee that the preferred 1xEV-DO control channel cycle offset does not overlap in time with the CDMA paging channel slot that the AT is required to use.
  • To ensure that the hybrid mode AT/MS can successfully acquire the systems, you may need to set the SID on the test set #1 (CDMA) and/or the Sector ID on the test set #2 (1xEV-DO) to match the parameters stored in the hybrid mode AT/MS.
  • To establish a packet data connection on IS-856 system, Default Packet Application must be firstly set on the test set #2 (1xEV-DO). For details on packet data applications on IS-856 system, see Data Channel .
  • To establish a packet data connection on IS-2000 system, service option 33 ( SO33 or SO33 (+F-SCH) ) must be firstly set on the test set #1 (CDMA). For details on packet data applications on IS-2000 system, see:

    cdma2000: Data Channel

  • The test set does not support simultaneous voice and data (SVD) operation. For details on the SVD and non-SVD operating modes, see Overview .

Related Topics

How Do I Make Hybrid Mode AT/MS Tests?


Recommended Functional Tests for Hybrid Mode AT/MS

Recommended Functional Tests for Hybrid Mode AT/MS

Last updated: August 9, 2005

This section is only applicable to the lab applications.

There are many test cases recommended by Qualcomm® for evaluating hybrid mode AT/MS capabilities as described in Overview . The Test cases for hybrid mode AT/MS gives the simple definition for each test supported by the test sets. To perform these tests, see How Do I Make Hybrid Mode AT/MS Tests? .

These tests can be broadly divided into three categories:

  • The tests 1 - 4 are to verify that the hybrid mode AT/MS can acquire both the IS-2000/IS-95 (cdma2000) and the IS-856 (1xEV-DO) systems, and perform dual-idle monitoring of the paging channel of the IS-2000/IS-95 system and the control channel of the IS-856 system concurrently.
  • The tests 5 - 20 are to verify that the hybrid mode AT/MS can support services on both the IS-2000/IS-95 and IS-856 systems.
    • The tests 5 - 10 are to verify that the AT/MS can initiate/accept a voice call on the IS-2000/IS-95 system while in an active/dormant packet data connection or in idle state on the IS-856 system.
    • The tests 11 - 16 are to verify that the AT/MS can initiate/accept SMS services on the IS-2000/IS-95 system while in an active/dormant packet data connection or in idle state on IS-856 system.
    • The tests 17 - 20 are to verify that the AT/MS can establish a packet data connection on the IS-856 system, or on the IS-2000 system when IS-856 system is unavailable.
  • The tests 21 - 28 are related to the MIP operations of the hybrid mode AT/MS.
    • The tests 21 - 24 are to verify that the hybrid mode AT/MS can handoff the packet data connection between the IS-856 and IS-2000 system while using the AT/MS in MIP.
    • The tests 25 - 28 are to verify the fundamental MIP operations. For example, connect a MIP call using static or dynamic home IP address, perform a MIP to SIP fallback if MIP registration fails, etc.
Test cases for hybrid mode AT/MS
No. | Test Cases | Definition | Minimum Standards
1 | Hybrid mode system acquisition | This test will verify that a hybrid mode AT/MS first acquires the CDMA system and then acquires a collocated 1xEV-DO system specified in the AT roaming list. | A hybrid mode AT/MS should be able to first acquire a CDMA system followed by the collocated 1xEV-DO system. AT should be able to monitor the CDMA paging channel and 1xEV-DO control channel in the dual-idle state.
2 | 1xEV-DO power save mode | This test will verify that the hybrid mode AT/MS enters 1xEV-DO power save mode after failing to acquire a 1xEV-DO system, either during initial acquisition upon power up or after successful acquisition followed by losing the 1xEV-DO system. | AT should be able to enter power save mode after losing 1xEV-DO coverage. AT shall be able to periodically search for 1xEV-DO system while in power save mode.
3 | Preferred Control Channel Cycle (PCCC) negotiation | This test will verify that the AT and the AN successfully perform PCCC negotiation and the AT always proposes an appropriate PCCC to avoid potential collisions between mobile directed CDMA paging channel messages and 1xEV-DO control channel messages. The AT proposes PCCC attribute during the AT initiated phase of the session negotiation. | A hybrid mode AT/MS shall be able to successfully determine and negotiate a suitable PCCC in order to avoid potential collisions between the CDMA paging slot and the 1xEV-DO control channel.
4 | Dual-idle operation on CDMA and 1xEV-DO | This test will verify that the hybrid mode AT/MS performs dual-idle monitoring of the paging channel of the CDMA system and the control channel of the 1xEV-DO system concurrently. It also verifies that upon losing 1xEV-DO system during dual-idle operation, the hybrid mode AT/MS tries to reacquire the 1xEV-DO system; and upon losing the CDMA system during dual-idle operation, the hybrid mode AT/MS tries to reacquire the CDMA system. | After moving to an area where no 1xEV-DO signal is available but a good CDMA signal is available, AT shall try to reacquire 1xEVDO system while idle on CDMA system. After moving to a good hybrid coverage area with good CDMA and 1xEV-DO signal, AT shall be able to reacquire 1xEVDO and continue dual-idle operation.
5 | CDMA voice call origination in dual-idle state | This procedure verifies that the hybrid mode AT/MS can originate CDMA voice calls while in dual-idle state. | A hybrid mode AT/MS should be able to successfully originate CDMA voice calls in dual-idle state.
6 | CDMA voice call origination in dormant 1xEV-DO state | This procedure verifies that the hybrid mode AT/MS can originate CDMA voice calls while in CDMA idle and dormant 1xEV-DO state. | A hybrid mode AT/MS shall be able to successfully originate CDMA voice calls in dormant 1xEV-DO state.
7 | CDMA voice call origination in 1xEV-DO connected state | This test verifies that the hybrid mode AT/MS can originate CDMA voice calls while in 1xEV-DO connected state and at the end of the voice call gets into 1xEV-DO connected state if there is data to send. | A hybrid mode AT/MS shall be able to originate voice calls while in 1xEV-DO connected state.
8 | CDMA voice call termination in dual-idle state | This procedure verifies that the hybrid mode AT/MS can receive CDMA voice pages while in dual-idle state. | A hybrid mode AT/MS shall be able to successfully terminate CDMA voice calls in dual-idle state.
9 | CDMA voice call termination in CDMA idle/1xEV-DO dormant state | This procedure verifies that the hybrid mode AT/MS can receive CDMA voice pages while in 1xEV-DO dormant state. | A hybrid mode AT/MS shall be able to successfully terminate CDMA voice calls in CDMA idle/1xEV-DO dormant state.
10 | CDMA voice call termination in 1xEV-DO connected state | This test verifies that the hybrid mode AT/MS can receive CDMA voice pages while in 1xEV-DO connected state. | A hybrid mode AT/MS shall be able to receive CDMA voice pages while in 1xEV-DO connected state.
11 | SMS origination in dual-idle state | This procedure verifies that the hybrid mode AT/MS can originate SMS while in dual-idle state. | A hybrid mode AT/MS shall be able to successfully originate SMS in dual-idle state.
12 | SMS origination in CDMA idle/1xEV-DO dormant state | This procedure verifies that the hybrid mode AT/MS can originate SMS while in CDMA idle/1xEV-DO dormant state. | A hybrid mode AT/MS shall be able to successfully originate SMS in CDMA idle/1xEV-DO dormant states.
13 | SMS origination in 1xEV-DO connected state | This test verifies that the hybrid mode AT/MS can send CDMA SMS while in 1xEV-DO connected state. | A hybrid mode AT/MS shall be able to send CDMA SMS while in CDMA idle and 1xEV-DO connected states.
14 | SMS termination in dual-idle state | This procedure verifies that the hybrid mode AT/MS can receive SMS while in dual-idle state. | A hybrid mode AT/MS shall be able to successfully terminate SMS in dual-idle state.
15 | SMS termination in CDMA idle/1xEV-DO dormant state | This procedure verifies that the hybrid mode AT/MS can terminate SMS while in CDMA idle/1xEV-DO dormant state. | A hybrid mode AT/MS shall be able to successfully terminate SMS in CDMA idle/1xEV-DO dormant state.
16 | SMS termination in 1xEV-DO connected state | This test verifies that the hybrid mode AT/MS can receive CDMA SMS while in 1xEV-DO connected state. | A hybrid mode AT/MS shall be able to receive CDMA SMS while in CDMA idle and 1xEV-DO connected states.
17 | 1xEV-DO packet data call origination in dual-idle state | This test verifies that the hybrid mode AT/MS can originate 1xEV-DO packet data calls while in dual-idle state. | The hybrid mode AT/MS shall be able to originate 1xEV-DO packet data calls while in dual-idle state.
18 | 1xEV-DO packet data call reorigination in 1xEV-DO dormant state | This test verifies that the hybrid mode AT/MS can reoriginate 1xEV-DO packet data call while in 1xEV-DO dormant state. | The hybrid mode AT/MS shall be able to reoriginate 1xEV-DO packet data call and should be able to come out of dormant 1xEV-DO state into connected state.
19 | 1xEV-DO packet data call termination in 1xEV-DO dormant state | This test verifies that the hybrid mode AT/MS can receive 1xEV-DO packet data pages while in dormant state on 1xEV-DO. | The hybrid mode AT/MS shall be able to receive data pages while in CDMA idle/1xEV-DO dormant state.
20 | CDMA packet data call origination when 1xEV-DO service is unavailable | This test verifies that the hybrid mode AT/MS can originate a packet data call on CDMA when 1xEV-DO service is not available. | A hybrid mode AT/MS should be able to originate a packet data call on CDMA when 1xEV-DO service is not available.
21 | Active 1xEV-DO to CDMA data session handoffs | If a hybrid mode AT/MS moves out of the hybrid coverage area (where both CDMA and 1xEV-DO are present) to CDMA only coverage area while it has an active packet data session on 1xEV-DO system, AT should hand-down the active data session from 1xEV-DO to CDMA system. This test verifies the AT-AN ability to perform an active 1xEV-DO to CDMA data session handoffs with minimum interruption to the data session when both CDMA and 1xEV-DO use different PDSN's. | Hybrid AT should be able to hand-down an active 1xEV-DO data session to a CDMA system, if 1xEV-DO is lost and the time it takes to transfer the data session from 1xEV-DO to CDMA should conform to the carrier's requirement. Also data transfer should continue after PPP is resynced.
22 | Dormant 1xEV-DO to CDMA data session handoff | If a hybrid AT moves out of the hybrid coverage area (where both CDMA and 1xEV-DO are present) to CDMA only coverage area while it has a dormant packet data session on 1xEV-DO system, AT should handoff the dormant data session from 1xEV-DO to CDMA system. This test verifies the AT-AN ability to perform a dormant 1xEV-DO to CDMA data session handoff with minimum interruption to the data session when both CDMA and 1xEV-DO use different PDSN's. | A hybrid AT should be able to hand off a dormant 1xEV-DO data session to a CDMA system, if 1xEV-DO coverage is lost and the time it takes to transfer the data session from 1xEV-DO to CDMA should conform to the carrier's requirement. Also data transfer should continue after PPP is resynced.
23 | Dormant CDMA to 1xEV-DO data session handoff | If a hybrid AT moves from a CDMA only coverage area to a hybrid mode coverage area with a dormant data session on the CDMA system, AT will try to handoff the data session to 1xEV-DO system after acquiring it. This test verifies the AT-AN ability to perform a dormant CDMA to 1xEV-DO data session handoff without any interruption to the data session when both CDMA and 1xEV-DO use different PDSN's. | A hybrid AT should be able to hand off a dormant CDMA data session to a 1xEV-DO system, if AT moves back to 1xEV-DO coverage area and data transfer continues after ppp is resynced. Also the time it takes to transfer the data session from 1xEV-DO to CDMA should conform to the carrier's requirement.
24 | 1xEV-DO to CDMA to 1xEV-DO data session handback | If a hybrid AT moves from a 1xEV-DO coverage to CDMA only coverage area and back to a hybrid mode coverage area with a dormant data session on the CDMA system, AT will try to handoff the data session to 1xEV-DO system after acquiring it. This test verifies the AT-AN ability to perform a 1xEV-DO to CDMA to 1xEV-DO data session handback with minimum interruption to the data session when both CDMA and 1xEV-DO use different PDSN's. | A hybrid AT should be able to hand back a dormant CDMA data session to the 1xEV-DO system, if AT moves from 1xEV-DO coverage area to CDMA only coverage area and then back to hybrid coverage area and data transfer continues after ppp is resynced. Also the time it takes to transfer the data session from 1xEV-DO to CDMA and CDMA-1xEV-DO should conform to the carrier's handoff requirements.
25 | MIP call when using static home IP | A hybrid mode AT/MS should be able to successfully connect a MIP call while using a static Home address in AT MIP profile. | The hybrid mode AT/MS should be able to successfully connect a MIP call while using a static Home address in AT MIP profile.
26 | MIP call when using dynamic home IP | A hybrid mode AT/MS should be able to successfully connect a MIP call while using a dynamic Home address in AT MIP profile. | The hybrid mode AT/MS should be able to successfully connect a MIP call while using a dynamic Home address in AT MIP profile.
27 | MIP to SIP fallback if MIP call fails while trying packet data call on 1xEV-DO | A hybrid AT should be able to successfully fallback to SIP if MIP fails while trying to setup a packet data call from dual-idle state on 1xEV-DO. | Hybrid AT should be able to successfully fall back to SIP on 1xEV-DO if the MIP call fails on 1xEV-DO while trying to setup a packet data call from dual-idle state.
28 | MIP to SIP fallback if MIP call fails while trying packet data call on CDMA | A hybrid AT should be able to successfully fallback to SIP if MIP fails while trying to setup a packet data call from CDMA idle state on CDMA. | Hybrid AT should be able to successfully fall back to SIP on CDMA if the MIP call fails on CDMA while trying to setup a packet data call from CDMA idle state.

Related Topics

How Do I Make Hybrid Mode AT/MS Tests?


Simple IP and Mobile IP

Simple IP and Mobile IP

Last updated: April 14, 2005

This section is only applicable to the lab application.

  • What is Simple IP and Mobile IP?
  • How Does Test Set Support Simple IP Packet Data Connection?
  • How Does Test Set Support Mobile IP Packet Data Connection?

What is Simple IP and Mobile IP?

The 1xEV-DO system supports packet data connections to a public or private data network using either mobile IP or simple IP protocol. Only a brief definitions for the simple IP and mobile IP protocols are provided here. For details, see 3GPP2 P.S0001-B Version 2.0 standard.

  • For simple IP protocol, moving from the coverage area of one PDSN to another PDSN constitutes a change in packet data session. A wireless device must obtain a new IP address (and lose existing connections) every time it changes its point of attachment (such as PDSN). A packet data session and a PPP session are concurrent in simple IP, that is, the existence of the packet data session is dependent upon a PPP session.
  • For mobile IP protocol, a packet data session can span several PDSNs as long as the user continuously maintains mobility bindings at the Home Agent (the IP address is persistent). A wireless device is allowed to maintain the same IP address as it moves across PDSNs and preserve existing packet data session during moves. The packet data session can exist through several changes of the PPP session. The mobile IP allows the PPP session to be terminated and re-established without the termination of the packet data session.
  • PPP session: A PPP session describes the time during which a particular PPP connection is maintained between the wireless device and the PDSN. The PPP session is maintained during periods when the wireless device is dormant. If a user hands off from one Radio Network (RN) to another RN but is still connected to the same PDSN, the PPP session remains. If a user changes PDSN, a new PPP session is created at the new PDSN.
  • Packet Data Session: Describes continuous use of packet data service by the user. A packet data session begins when the user invokes packet data service. A packet data session ends when the user or the network terminates packet data service. (A packet data service indicates any packet switched data service offered by the cdma2000 wireless network (for example, 1xEV-DO AN) to a user through the AT.

How Does Test Set Support Simple IP Packet Data Connection?

The Session Application Type must be set to Default Packet Application before an access terminal (AT) initiates a packet data connection.

The test set supports packet data connection using simple IP protocol via it's internal PDSN simulation (see Packet Data Network Emulation in the Test Set ). To use the test set's internal PDSN simulation, the External PDSN State must be set to Off (see Data Channel Parameters ). In this case, the AT's PPP connection is terminated by the test set, propagating the encapsulated IP packets directly to the ethernet interface (LAN port).

An example procedure for packet data connection using simple IP is described in Packet Data Service Example Procedure (via Simple IP) .

How Does Test Set Support Mobile IP Packet Data Connection?

By working together with an external PDSN (MOB-IP-SIM) provided by the Software Concepts, Inc., the test set supports both the simple IP and mobile IP protocol tests required to ensure compliance with the TIA/EIA-IS-835 standard. A typical connection diagram between the test set and the MOB-IP-SIM is shown in the figure below.

Test Set's Mobile IP Solution Setup

Both the simple IP and mobile IP protocols are implemented in the MOB-IP-SIM. For details on the MOB-IP-SIM functionality and configurations, see the MOB-IP-SIM technical manual available on the web:

http://www.softwareconceptsinc.net/MIP-5850.html

If the external MOB-IP-SIM is providing PDSN simulation, the test set will forward the PPP octets delivered by RLP data to the external MOB-IP-SIM. The MOB-IP-SIM is responsible for actual termination of the PPP link and interpreting all protocol layers necessary to pass the end-to-end encapsulated IP packets directly onto the network (IP, UDP, MIP).

The Session Application Type must be set to Default Packet Application before an AT initiates a packet data connection. To work with the External MOB-IP-SIM, the test set must be properly configured (see Data Channel Parameters ). An example procedure for packet data connection using mobile IP is described in Packet Data Service Example Procedure (via Mobile IP) .

As the external MOB-IP-SIM only includes the logging of higher layer protocols (such as IP, UDP, MIP), it cannot display those messages of the lower protocols (for example, SLP, RLP, etc.). These air interface messages can be logged using the Wireless Protocol Adviser (WPA) (see Protocol Logging ).

Related Topics

Packet Data Service Example Procedure (via Simple IP)


IP Address Requirements

IP Address Requirements

Last updated: November 19, 2005

This section is only applicable to the lab application.

Description

The test set provides a field for entering the IP Address for a wireless device being tested using the packet and CS (circuit switched) data channels.

There are two requirements for the DUT IP Address field:

  1. The network portion (see IP Address Formatting ) of the wireless device's DUT IP address must be the same as the network and subnet portion of the test set's LAN IP Address.

  2. The host portion of the wireless device's DUT IP address must be unique. (It should not be the same as any other host on the network or subnet that the test set is connected to.)

How Network Addresses Are Assigned

Network IDs are assigned by the NIC (Network Information Center). The network portion (first two bytes) of the class B address in the example above would be acquired from the NIC by a network administrator to avoid conflicts with other networks. The network administrator is then free to allocate subnets as needed since subnetting is not visible outside the network.

If you do not know the IP address the test set and/or DUT should be set to, or which unique host IDs are available, you should contact your network administrator.

How to Interpret IP Addresses

The network portion of the LAN IP Address depends on the address classification as shown below:

LAN IP Address Classification

Class A = 1.0.0.0 to 127.255.255.255
Class B = 128.0.0.0 to 191.255.255.255
Class C = 192.0.0.0 to 223.255.255.255
Class D = 224.0.0.0 to 247.255.255.255

An IP Address consists of a 4-byte (32 bit) number. Each byte is in a decimal form separated from other bytes by a dot. This is referred to as a "dotted decimal" format.

NOTE
The test set does not allow LAN IP Addresses in the range of 127.0.0.0 to 127.255.255.255 because these addresses are assigned for use as the Internet host loopback address.

The IP address class defines which bytes contain the network portion of the address. For Class A addresses, the first byte from the left identifies the network. For class B it is the first two bytes from the left, and for class C it is the first three bytes. Class D addresses are multicast, which are used when a datagram is directed to multiple hosts. See IP Address Formatting .

IP Address Formatting
Class | Byte 1 | Byte 2 | Byte 3 | Byte 4
A | Network | Host
B | Network |  | Host
C | Network |  |  | Host
D | Multicast

Determining the Test Set's Network Address

If the test set's LAN IP Address is set to 130.29.183.121, as shown below, the first two bytes represent the network portion since this is a Class B address.

If the test set is on a subnet, the Subnet Mask must be applied to determine the subnet address. This is done by performing bit-wise AND logic between the binary values of the LAN IP Address and Subnet Mask. See Applying the Subnet Address

Applying the Subnet Address
LAN IP Address | 130 |  |  |  |  |  |  |  | 29 |  |  |  |  |  |  |  | 183 |  |  |  |  |  |  |  | 121
Subnet Mask | 255 |  |  |  |  |  |  |  | 255 |  |  |  |  |  |  |  | 255 |  |  |  |  |  |  |  | 0
Subnet Mask (Binary) | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
LAN IP Address (Binary) | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 1 | 0 | 1 | 1 | 1 | 1 | 0 | 0 | 1
Subnet Address (Binary) | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
Subnet Address | Network130 |  |  |  |  |  |  |  | Network 29 |  |  |  |  |  |  |  | Subnet 183 |  |  |  |  |  |  |  | Host 0

As shown in the table above, the Subnet Mask splits the 16 bit host portion of the class B address into an 8-bit subnet ID and an 8-bit host ID.

In this example the DUT IP Address would need to be set to 130.29.183.XXX to match the test set's subnet ID. The host portion of the LAN IP Address is identified by the bits corresponding to the 0 bits in the Subnet Mask. Therefore, the last byte in the DUT IP Address must not be 121 or any address that corresponds with any other host on the subnet at 130.29.183.XXX

Related Topics

How Do I Set Up Data Channel Parameters?


Packet Data Network Emulation in the Test Set

Packet Data Network Emulation in the Test Set

This section is only applicable to the lab application.

  • Network Reference Model
  • Protocol Reference Model
    • Default Packet Application Description
  • Standard References

Network Reference Model

In addition to testing wireless devices with TAP in a factory/laboratory environment (see C.S0029 Test Application Specification Description (TAP/ETAP) ), the lab application can emulate a real-world access network to provide packet data connection between an access terminal (AT) and a packet data network (such as the Internet). This is achieved by emulating the relevant behaviors of the Access Network (AN) using the Default Packet Application protocol (see Session Application Type ), the Packet Control Function (PCF) as well as the Packet Data Service Node (PDSN) as shown in the figure below.

Network Reference Model for Packet Data Connection

  • The AN supporting Default Packet Application protocols provide a means of establishing and maintaining traffic channels for packet data transmission over the air interface.
  • The PCF is used to manage the relay of packets between the PDSN and the AN.
  • The PDSN is used to establish, maintain, and terminate link layer sessions (such as PPP session) and route packet data between an AT and the packet data network (such as the Internet).

When a packet data connection is established (that is, both the physical traffic channel and PPP connection are open between the AT and the test set), the AT can send or receive data through the test set's front panel RF connector, and the test set will route data through the rear panel LAN port to or from a packet data network (see How Does Test Set Support Simple IP Packet Data Connection? ).

There are several applications of the Data Channel. See Data Channel Applications .

For the signaling procedures during packet data connection establishment, see Packet Data Connection Call Flow .

For the state transitions during a packet data connection establishment, see Packet Data Connection Processing States Lifecycle .

Protocol Reference Model

The figure below shows a simplified protocol reference model for packet data service. The Default Packet Application Description (DPA) protocols are briefly explained here. For other communication protocols, refer to the Standard References .

Protocol Reference Model for Packet Data Service

Default Packet Application Description

The Default Packet Application (DPA) is an application layer protocol defined in the 3GPP2 C.S0024 Section 3 . It provides an octet stream used for transporting user data. The applications used and the streams upon which they operate are negotiated as part of session negotiation. The DPA protocol consists of the following protocols:

  • Radio Link Protocol (RLP): provides retransmission and duplicate detection for an octet aligned data stream. The RLP carries an octet stream from the upper layer and is unaware of higher layer framing. It operates on a featureless octet stream and uses a Negative AcKnowledge based (NAK-based) retransmissions. That is, the receiver does not acknowledge received data frames and only requests the retransmission of data frames that were not received. When a frame is missing RLP responds by sending a NAK message to request the retransmission. When a new or retransmitted frame is received it is placed in a storage buffer that manages sequential delivery of RLP frames to the upper layers.
  • Location Update Protocol (LUP): provides mobility management between data service networks.
  • Flow Control Protocol (FCP): provides flow control of data traffic such as enabling or disabling the data flow.

Standard References

  • 3GPP2 C.S0024-A V2.0 cdma2000 High Rate Packet Data Air Interface Specification
  • A.S0007-A V2.0, Inter-Operability Specification (IOS) for High Rate Packet Data (HRPD) Access Network Interfaces.
  • P.S0001-B V2.0, cdma2000 Wireless IP Network Standard.

Related Topics

Data Channel


Data Channel Parameters

Data Channel Parameters

Last updated: November 22, 2005

This section is only applicable to the lab application.

Before an access terminal (AT) initiates a packet data connection either through the test set's internal PDSN or via the external PDSN (MOB-IP-SIM), the following data channel parameters must be correctly set.

Data Channel Parameters versus Internal/External PDSN

Internal/External PDSN

 You should:

If the test set's internal PDSN is to be used (see How Does Test Set Support Simple IP Packet Data Connection? )

Set External PDSN State to off and set a proper DUT IP Address for your AT.

If the external PDSN (MOB-IP-SIM) is to be used (see How Does Test Set Support Mobile IP Packet Data Connection? )

Set a proper External PDSN IP Address and External PDSN TCP Port matching your external PDSN (MOB-IP-SIM), and make sure the External PDSN Connect Timeout is not set to zero. Then turn the External PDSN State to on.

In this case, the AT's IP address is assigned by the external PDSN and so the DUT IP Address setting is invalid.

  • DUT IP Address

    Sets an IP address for the AT (see CALL:MS:IP:ADDRess ). It is used to establish a packet data connection using test set's internal PDSN with the AT (see Packet Data Service Example Procedure (via Simple IP) ) or used by Ping functionality ( Ping the DUT from the test set ).

    This setting can be changed when in Data Connection states of Idle, Session Open, or Connected and is applied only when the Session Application Type is set to Default Packet Application and the External PDSN State is set to Off . If this setting is changed, any existing PPP data connection and physical connection (between test set and At) will be ended with signaling.

    When the External PDSN State is On , the DUT IP address is assigned by the external MOB-IP-SIM and the ping to a DUT functionality is not functioning.

    The DUT IP Address and the test set's LAN IP address should be unique and in the same subnet (see also IP Address Requirements ). The DUT IP Address setting is stored in nonvolatile RAM and will NOT be changed by a reset, power cycle operations.

  • External PDSN State

    Sets whether to use the test set's internal PDSN or the external PDSN simulator (MOB-IP-SIM) ( CALL:DATA:PDSNode:EXTernal:STATe ).

  • External PDSN IP Address

    Sets an IP address for the external MOB-IP-SIM ( CALL:DATA:PDSNode:EXTernal:IP:ADDRess ).

    It should be set before turning the External PDSN State to On. If the External PDSN State is On, you can not change the External PDSN IP Address.

    The external MOB-IP-SIM's IP address and the test set's LAN IP address should be unique, but without the requirement to be within the same subnet. See also IP Address Requirements .

  • External PDSN TCP Port

    Sets a TCP port for the external MOB-IP-SIM ( CALL:DATA:PDSNode:EXTernal:TCP:PORT ).

    It should be set before turning the External PDSN State to on. If the External PDSN State is On, you can not change the External PDSN TCP Port.

  • External PDSN Connect Timeout

    Sets the maximum amount of time (1 - 19 seconds) that the test set will wait for an acknowledgment when trying to connect to the external PDSN (MOB-IP-SIM). See CALL:DATA:PDSNode:EXTernal:TIMeout[:CONNect] .

    If the external PDSN connect timeout timer expires or the external PDSN rejects the connection request, the test set will generate an error. When External PDSN State is Off , this setting has no effect.

    The External PDSN Connect Timeout value is stored in nonvolatile RAM and will NOT be changed by a reset, power cycle, or save/recall operations.

    NOTE
    The External PDSN Connect Timeout is allowed to be set to the range of 0 to 19 seconds in the earlier E6706A firmware revisions (A.01 and A.02). However, you should not set the External PDSN Connect Timeout to zero. Otherwise, changing the External PDSN State to On will result in an error message indicating that the External PDSN is not available and the state will remain off.

    If the value is set to zero and you boot up into a newer version of firmware (E6706A A.02.10 and above), the value stored in NVRAM will be changed to one second on power-up.

Setting Considerations

  • Before turning the External PDSN State to on, you must firstly set the External PDSN IP Address and External PDSN TCP Port parameters to match the values as required for the external MOB-IP-SIM, and make sure the External PDSN Connect Timeout is not set to zero.
  • The External PDSN State will be set to the default value ( Off ) by a full preset or power cycle.
  • The External PDSN IP Address, the External PDSN TCP Port and the External PDSN Connect Timeout are stored in nonvolatile RAM and will not be changed by a reset, power cycle, or save/recall operations
  • The External PDSN State can be saved and recalled by the operation of Save and Recall Registers . Recalling the External PDSN State will, if the saved state is On, attempt to reconnect to the external PDSN (MOB-IP-SIM) at the currently specified External PDSN IP address and TCP port. The external PDSN IP address and TCP port can not be saved and recalled.
  • If the test set has a packet data connection with the external MOB-IP-SIM ( External PDSN State is On ), changing the External PDSN State to Off will drop the current data connection without an error prompt.
  • If the test set has a packet data connection with the external MOB-IP-SIM ( External PDSN State is On ), you can not change the External PDSN IP Address or the External PDSN TCP Port.
  • When the external MOB-IP-SIM is providing PDSN service to the AT, the AT's IP address is assigned by the MOB-IP-SIM. The setting of DUT IP Address is ignored and the ping to DUT functionality is not functional (see Ping the DUT from the test set ).

Related Topics

Manual Operation: How Do I Set Up Data Channel Parameters?


Ping

Ping

Last updated: April 14, 2005

This section is only applicable to the lab application.

Ping Description

Ping is a tool to help check system interconnects. The test set has a Ping feature that allows you to ping either the device under test (DUT) or an alternate address (see How Do I Ping a Device From the Test Set? ). It sends an IP datagram (technically an ICMP message: Internet Control Message Protocol) from the test set to the ping target, and expects a response from the target. You can define the size of the IP datagram. The default is 64 bytes. If a response is received it is recorded on the test set's display.

Ping is the simplest implementation of the Data Channel feature. If you are trying to debug a system that is not responding to a full network setup (for example a WAP setup), try pinging the DUT from a computer attached to the network. Experiment with very large packets, very long timeouts and continuous pings.

How to Read the Ping Results

If the connection is good, then the DUT will return a packet to the test set and the packet transfer information is displayed on the test set's screen. In the example below ping count was set to 1. Note that it took 2700 milliseconds to complete the ping.

Ping data passing between the test set and the access terminal can be logged using the Wireless Protocol Advisor (WPA). See Protocol Logging During Ping .

Operating Considerations

  • When pinging the DUT, a packet data connection must be in the connected or dormant state (see Ping the DUT from the test set ).
  • There are restrictions regarding IP Addresses that are valid for use. See IP Address Requirements for more information.
  • When the Ping originates from the test set and the target is the DUT, the Source Address in the Forward/Down direction is always 130.29.181.203, and the Destination Address in the Reverse/Up direction is the same value. See Method 1: Ping the access terminal from the Test Set for more information.
  • When External PDSN State is On , the operation to ping the DUT from the test set ( Ping the DUT from the test set ) will be rejected since the IP address of the DUT is assigned by the external MOB-IP-SIM instead of the specified DUT IP Address on the test set (see Data Channel Parameters ).
  • Ping to a DUT in progress will be aborted when the External PDSN State changes to On.

Related Topics

How Do I Ping a Device From the Test Set?


Protocol Logging During Ping

Protocol Logging During Ping

Last updated: April 14, 2005

This section is only applicable to the lab applications.

Ping data passing between the test set and the access terminal can be logged using the Wireless Protocol Advisor (WPA) (see Protocol Logging ). The log results during ping depend on the method used. Here are several methods and descriptions of the log results.

  • Method 1: Ping the access terminal from the Test Set
  • Method 2: Ping an Alternate IP Address From the Test Set
  • Method 3: Using Ping From Other Devices
  • Ping Log

Method 1: Ping the access terminal from the Test Set

To capture a protocol log while pinging the access terminal from the test set, start a capture in the WPA and then follow the steps in Ping the DUT from the test set .

Looking at the Protocol Log

Note that the Source Address for the IP datagram in the Forward/Down direction is an unknown IP address (130.29.181.203). This is an internal address the test set uses to originate IP traffic from the test set to the access terminal.

See Ping Log for more information about the log.

Method 2: Ping an Alternate IP Address From the Test Set

To capture a protocol log while pinging an alternate IP address from the test set, start a capture in the WPA and then follow the steps in Ping an alternate address from the test set .

If your Alternate Ping Address is anything but the access terminal address, the test set's protocol logging does not log this ping. The test set's logging only captures messages exchanged between the test set and the access terminal. If you have a network logging device on your LAN, it will show that the source IP address is the test set's LAN IP address. If your Alternate Ping Address is the access terminal address, then the data is logged by the test set, and the Source Address for the datagram in the Forward/Down direction that contains the ping data is the same IP address as in Method 1.

Method 3: Using Ping From Other Devices

Any device on the network that has a ping feature can ping any other device, including the access terminal. For example, if you have a PC on the LAN that the test set is connected to, you can use ping from that PC to ping the access terminal.

Example procedure of pinging the access terminal from another device (e.g. a Windows PC):

  1. Start protocol logging. See Protocol Logging .
  2. Open a MS DOS command prompt on the PC.
  3. Type the following command

    ping xxx.xxx.xxx.xxx

    where xxx.xxx.xxx.xxx is the IP address of the access terminal.

  4. The ping should respond as normal.
  5. Stop logging.

In this case, the Source Address for the datagram in the For/Down direction that contains the ping data is the IP address of your PC.

Ping Log

The Ping can be logged using the Wireless Protocol Advisor (WPA) (see Protocol Logging ), and certain information can be derived from the log of the Ping.

  • "For/Down" in the "Direction" column of the WPA indicates that this is a forward/down link message and is therefore passing from the test set to the access terminal.
  • Ping is an Internet Control Message Protocol (ICMP) protocol message.
  • Message Type is Echo Message, which is the instruction to the peer layer at the destination address to generate an Echo Reply message.
  • The IP address of the access terminal is the Destination Address on the forward/down link datagram and is the Source Address on the reverse/up link datagram. The alternate address is an address within the test set that originated the Ping data packet.
  • The Type, Code, Checksum, Identifier and Sequence Number are all listed.

Related Topics

Ping


Data Throughput Monitor

Data Throughput Monitor

Last updated: April 14, 2005

This section is only applicable to lab and protocol applications.

Description

What is Data Throughput?

As part of the test set's lab application, a data throughput monitor is provided to analyze data transfer rates under various RF and call processing conditions. The monitor is selected by pressing the Instrument selection key, and accessed by pressing the MEASUREMENT key.

Data throughput is the rate of data transfer to and from a wireless device.

NOTE

This feature does not attempt to monitor application layer data throughput (FTP, HTTP, TELNET, etc.).

Four statistical results are available from the data throughput monitor:

  • OTA Rx and OTA Tx

    OTA (Over the Air) throughput counts the data transmitted and received by the test set protocol stack. The location of the measurement point in the protocol stack is dependent on system type; this data could be a byte stream from RLP (Radio LInk Protocol) or RLC (Radio Link Control) or PPP (point to point protocol). OTA throughput does not count physical layer overhead such a mid-amble, guard, or tail bits, or bits added by the encoding process.

  • IP Rx and IP Tx

    IP (Internet Protocol) throughput counts the data transmitted and received by the test set. It measures the IP data transferred between the external LAN connector and the protocol stack. It provides a measure of the IP data packets being transferred to/from the wireless device.

How is Data Throughput Displayed?

When the Data Throughput Monitor is selected and a data call is connected, the test set begins to accumulate data throughput statistics. If a data call is disconnected, data accumulation will be suspended until another connection is made and data accumulation continues. Data accumulation can be cleared by performing a measurement reset or clearing the graph.

The test set provides two tools to analyze data throughput:

  • Graphical trace
  • Summary table

Graphical trace

The graphical trace presents up to the most recent 600 seconds (10 minutes) of data throughput statistics. Each of the following color-coded traces can be turned on or off:

  • OTA Tx - (Over The Air Transmitted bits-per-second). This is the rate of link-layer bit transfer sent from the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in WCDMA and GPRS, or PPP in GSM. Tx refers to the reverse or uplink channel direction.
  • OTA Rx - (Over The Air Received bits-per-second). This is the rate of link-layer bit transfer received by the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in WCDMA and GPRS, or PPP in GSM. Rx refers to the forward or downlink channel direction.
  • IP Tx - Internet Protocol Transmitted. This is the rate of network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.
  • IP Rx - Internet Protocol Received. This is the rate of network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.

A marker can be assigned to each trace to display instantaneous numeric data throughput values. Markers can be used in conjunction with the Freeze Graph feature to analyze points of interest on traces.

Summary table

The summary table provides the latest statistics for the four monitored measurements. Each measurement is displayed with the following statistics:

  • Marker

    The data rate at the measurement's marker position in bits-per-second.

  • Current

    The measurement's instantaneous data in bits-per-second.

  • Average

    The measurement's average data rate in bits-per-second over the length of the data connection or since the last time the measurement was cleared.

  • Peak

    The measurement's peak data rate in bits-per-second over the length of the data connection or since the last time the measurement was cleared.

  • Data Transfer

    The measurement's total data throughput count, in bytes, over the length of the data connection or since the last time the measurement was cleared

Related Topics

Manual Operation: How Do I Use the Data Throughput Monitor?

GPIB commands: CALL:COUNt:DTMonitor


Multi-unit Synchronization

Multi-unit Synchronization

This section is only applicable to the lab application.

  • Overview
  • Synchronization Connection Setup
  • Synchronization Configuration Requirements
  • Synchronization Parameters Description
  • Synchronization Information and Annuciators
  • Operating Consideration

Overview

Multiple test sets either running the E6702B cdma2000 lab application or the E6706A 1xEV-DO lab application can be synchronized on CDMA system time. It is very useful for hybrid mode AT/MS tests which requires two test sets, one running the E6702B cdma2000 lab application and another one running the E6706A 1xEV-DO lab application to be synchronized (see Hybrid Mode ).

During the synchronization, the test set providing CDMA system time and 2 seconds trigger signal is called Sync Server while the test set initiates the synchronization and requests the Sync Server to provide CDMA system time is called Sync Client. The test set can act as either a Sync Client or a Sync Server at a time. If as a Sync Server, the test set can process multiple Sync Clients' sync requests.

Prior to the synchronization, the test sets must be properly connected (see Synchronization Connection Setup ) and configured (see Synchronization Configuration Requirements ). When the synchronization is initiated by the Sync Client (see Sync To External Server ). the following procedure is automatically performed.

  1. The Sync Client sends a sync request to the Sync Server through the LAN.
  2. When the Sync Server receives the sync request , it sends its CDMA system time to the Sync Client or responds with an error if error occurs.
  3. When the Sync Client receives the CDMA system time from the Sync Server, it sets its CDMA system time to the same value as received when the next 2-second trigger occurs. Once the synchronization completes, the two test sets are synchronized on CDMA system time within 1 us (see CDMA System Time and Synchronization Information ). The synchronization remains until an event that causes the loss of the synchronization occurs (see Operating Consideration ).

    If the Sync Client receives a response with errors or does not receive any response within 3 seconds, the Sync Client posts an error message and the synchronization fails.

Synchronization Connection Setup

The following diagram demonstrates an example of synchronization connection for two test sets.

  • Connect one test set's 10 MHz REF IN to another one's 10 MHz REF OUT connector directly, or connect both test sets' 10 MHz REF IN connector to an external instrument that provides 10 MHz timebase signal.
  • Connect the Sync Server's TRIG OUT to the Sync Client's TRIG IN connector.
  • Connect the two test sets to the LAN using a standard LAN cable, or directly connect them using a crossover LAN cable.

Synchronization Connection Setups for Two Test Sets

Synchronization Configuration Requirements

Prior to the synchronization, you should properly configure the test sets as shown in the table below. For detailed procedure, see How Do I Perform Multi-unit Synchronization? .

Setting Requirements on the Sync Client and Sync Server
Settings | Sync Client |  | Sync Server
 | Test Set (E6702B) | Test Set (E6706A) | Test Set (E6702B) | Test Set (E6706A)
Operating Mode | Active Cell or IS-2000 Test | Active Cell or IS-856 Test | Active Cell or IS-2000 Test | Active Cell or IS-856 Test
System Type | IS-2000 or IS-95 | IS-856 | IS-2000 or IS-95 | IS-856
Ext 8960 IP Addr | Must be set to LAN IP address of the Sync Server. |  | Does not matter.
Call Status | Idle |  | Does not matter.
External Trigger | Does not matter. |  | 2 seconds (see External Trigger Type )

Synchronization Parameters Description

  • Ext 8960 IP Addr

    Sets the IP address of the Sync Server. It should be same as the LAN IP Address of the test set acting as the Sync Server (see Configuring the Test Set's LAN ).

    GPIB Command: SYSTem:COMMunicate:LAN:EXTernal:ADDRess

  • Sync To External Server

    This action initiates the synchronization and sends a sync request to the Sync Server at the address specified by Ext 8960 IP Addr .

    Prior to this action, make sure that you have finished the configurations as shown on Setting Requirements on the Sync Client and Sync Server .

    GPIB Command: SYSTem:COMMunicate:LAN:EXTernal:SYNChronize

  • Clear Sync Indications

    This action clears all synchronization indications including Sync Annuciators , Client Sync Indication and Server Sync Indication .

    GPIB Command: SYSTem:COMMunicate:LAN:EXTernal:SYNChronize:INDication:CLEar

Synchronization Information and Annuciators

The Local Synchronization Information window and the Sync Annuciators at the left corner of test set screen provide helpful information about the synchronization operation. A typical display for a successful synchronization between two test sets is shown below.

CDMA System Time and Synchronization Information

  • Client Sync Indication

    Indicates whether the test set has successfully completed a synchronization when acting as a Sync Client.The possible sync indications as a Sync Client are: Operation Complete , Attempting Sync , or null string (no sync).

  • Server Sync Indication

    Indicates whether the test set has successfully completed a synchronization when acting as a Sync Server. The possible sync indications as a Sync Server are: Operation Complete , Processing Sync Request , or null string (no sync).

  • Ext 8960 IP Addr (Server)

    Indicates the IP address of the Sync Server specified by Ext 8960 IP Addr .

  • Sync Annuciators

    • C OPC : Indicates that the test set has successfully completed a synchronization when acting as a Sync Client.
    • S OPC : Indicates that the test set has successfully completed a synchronization when acting as a Sync Server.
    • CS OPC : Indicates that the test set has successfully completed a synchronization when acting as a Sync Client and then successfully completed a synchronization when acting as a Sync Server. In this case, Operation Complete will be shown on both the Client Sync Indication and Server Sync Indication fields of this test set.
    • Null (no sync).

    GPIB Command: SYSTem:STATus:COMMunicate:LAN:EXTernal:SYNChronize:INDication?

Operating Consideration

Prior to the synchronization, make sure you have made the proper connection (see Synchronization Connection Setup ) and configuration (see Synchronization Configuration Requirements ) for your test situation.

Once the synchronization has successfully completed, the following possible reasons cause the loss of synchronization.

  • You change the CDMA System Time on either test set being synchronized.
  • Some actions cause the +/-1 second uncertainty on CDMA system time (see Operating Consideration ).

Related Topics

Manual Operation How Do I Perform Multi-unit Synchronization?

CDMA System Time Parameters


Packet Data Connection Processing States Lifecycle

Packet Data Connection Processing States Lifecycle

This section is only applicable to the lab application.

As shown in the figure below, there are several key state transitions in the packet data connection processing lifecycle. The Session Application Type must be set to the Default Packet Application before an AT initiates a packet data connection with the test set. For the key steps and messaging to establish a packet data connection (DPA), see Packet Data Connection Call Flow .

Packet Data Connection Processing Lifecycle

  1. Once the access terminal (AT) is powered on, it acquires the system and then moves into Idle state (see Idle State ).
  2. Before the AT can send or receive any data, it must first establish a session, and then open a data connection. Most ATs will immediate initiate a session once they reach the idle state. That way, when the user is ready to retrieve some data, the AT can immediately move from the session open to connected state. Only the AT can initiate a session. The test set can't send data to the AT unless the AT has established a session. The AT initiates a session by sending a UATI Request (see UATI Request State ).
  3. The session is then configured through the negotiation of configurable attributes such as Session Application Type, Preferred Control Channel Cycle, Probe Sequence Max, etc. (see Session Negotiate State ). Note that the Session Application Type must be set to Default Packet Application before an AT initiates a packet data connection with the test set.
  4. Once this is complete, the session is open (see Session Open State ) and configured to Default Packet Application (DPA) on Stream 1 Application (0x15). To change any of the configurable attributes for the session, the session must be renegotiated.
  5. The packet data connection can then be initiated from the AT (the AT must be assigned an IP address. See Data Channel Parameters ). For example, the user may use AT to browse a web page or download e-mails. If the AT is initiating the connection, it simply sends a Connection Request (see Connection Request State ). (Note that you can not start packet data connection by paging AT from the test set.)
  6. When receiving the connection request from the AT, the test set starts the traffic channel establishment procedure.
  7. When this is complete, the AT will indicate it is ready to start data transmission by sending an Xon request to the test set. The PPP establishment procedure is then performed during which the AT is assigned an IP address. See AT Initiated Packet Data Connection from Idle State .
  8. When this is complete, a packet data connection is established between the AT and the test set. The AT and the test set can use the assigned traffic channel to send packet data to each other. The data status is "Connected" (see Connected State ).
  9. The AT may handoff to a new frequency because it is moving out of the current frequency coverage area, or perhaps the current frequency is heavily loaded and the network wants to balance the load (see Handoff State ).
  10. The connection may be closed to the Dormant State by either the test set (see AN Initiated Connection Close to Dormant State ) or the AT (see AT Initiated Connection Close to Dormant State ). For example,
    • the F2 ( Force Dormant ) on the Call Control 1 of 3 menu) or the CALL:FUNCtion:DATA:DORMant is executed by the test set, or
    • the test set receives a Connection Close message from the AT (for example, if the AT's data activity timer expiries, or the packet data connection is terminated in some AT-dependent manner).
    • If for some reason the PPP connection can not be maintained or the AT, the data connection will go to Session Open State (see Session Open State
  11. While in the dormant state, either the AT or the test set can re-activate the packet data connection to the Connected state by sending a Connection Request message:
    • The test set receives an IP datagram addressed to the AT. The datagram may come from another host on the network or from the test set itself when the user presses the Start Ping ( F3 on Ping Control menu) (see AN Initiated Packet Data Connection Re-activation from Dormant State ).
    • AT has a connection request to retrieve data (see AT Initiated Packet Data Connection Re-activation from Dormant State ).
  12. The session may be closed by either the test set or AT (see Session Closing State ).

NOTE
Access Network (AN): The network equipment providing data connectivity between a packet switched data network (typically the Internet) and the access terminals. An access network is equivalent to a base station in a cdma2000 system.
(The test set can emulate an AN so that the term of the test set and the AN are interchangeable throughout this section.)

Access Terminal (AT): A device providing data connectivity to a user. An access terminal may be connected to a computing device such as a laptop personal computer or it may be a self-contained data device such as a personal digital assistant. An access terminal is equivalent to a mobile station in a cdma2000 system.

Related Topics

Packet Data Connection Call Flow

Packet Data Network Emulation in the Test Set

Idle State

UATI Request State

Session Negotiate State

Session Open State

Paging State

Connection Request State

Connected State

Dormant State

Handoff

Connection Closing State

Session Closing State

Data Connection State Synchronization

Summary of Data Connection Processing States Description


Digital Bus Information

Digital Bus Information

Last updated: July 3, 2006

This section is only applicable to the lab application with rear panel digital bus.

Description

A test set equipped with cdma2000, 1xEV-DO or W-CDMA lab applications can perform mobile station tests that require faded signals. The test set must be equipped with a rear panel that includes a connector labeled Digital Bus.

NOTE
For detailed setup and operating instructions pertaining to faded signal generation, refer to

E5515C Fading Solution Application Guide

It can be downloaded at http://cp.literature.agilent.com/litweb/pdf/1000-1894.pdf .

When a faded signal from the test set is needed, the forward baseband signal path from the Test Set is diverted to a PC running Baseband Studio software. This software is capable of digitally adding fading patterns requested by the user.

Fader Setup

Baseband Studio software also controls the test set's call parameters and digital bus signal path switching modes. The status of the various digital bus parameters and the controls themselves are made available by selecting Digital Bus Info from the Call Control screen.

  • Baseband Studio Summary - The current values in use for baseband signal level adjustments.
  • Digital Bus Summary - The current data and clock rates for the modulation type of the faded signal.

With the Digital Bus Information screen displayed, the following fading parameters are displayed:

The Bbio Control menu provides three settings:

  • Digital Bus Path - Must be Internal for non-faded signal operation.

  • ALC Mode - Must be Closed Loop for non-faded signal operation.

  • Calibrate Open Loop ALC - Used to generate calibration tables that are needed when ALC Mode is Open Loop.

IMPORTANT
The Digital Bus Path and ALC Mode fields are controlled by the Baseband Studio software when a faded signal is generated by the test set. The only time these field settings will need to be manually changed is during certain diagnostic routines. Refer to the Installation Note (E5515-90243) shipped with the Option 504 kit for instructions on performing diagnostic tests.

Related Topics

Testing 3.2.2 Demodulation of Forward Traffic Channel in Multipath Fading Channel (Lab Application Only)


Dormant State

Dormant State

This section is only applicable to the lab application.

In the dormant state, a PPP connection is open but the physical connection (traffic channel) is closed between the access terminal (AT) and the test set.

The dormant state is an important advantage of the packet data service offering since it allows the AT's natural state to be dormancy where the AT does not utilize any radio resources and has minimal power consumption. The packet data connection can be reactivated from dormancy to the connected state without having to re-establish PPP link again when an IP packet arrives from the test set or any host on the network destined to the AT (for example, file transfer over FTP, ping the AT from the test set, etc.). This makes the connection faster.

The dormant state is a non-transitory state (see Packet Data Connection Processing States Lifecycle ).

To query the state of the data connection, see Data Connection State Synchronization .

Transition from Connected State to Dormant State

When the Session Application Type is set to the Default Packet Application , the packet data connection will transition from the connected state to the dormant state if

  • you press the F2 ( Force Dormant ) on the Call Control 1 of 3 menu) or sends CALL:FUNCtion:DATA:DORMant to the test set (see AN Initiated Connection Close to Dormant State ), or
  • the test set receives a Connection Close message from the AT (for example, if the AT's data activity timer expiries, or the packet data connection is terminated in some AT-dependent manner). See AT Initiated Connection Close to Dormant State .

If for some reason the PPP connection can not be maintained, the test set will transition to Session Open State .

Transition from Dormant State to Connected State

In the dormant state, either the test set or the AT can re-activate the packet data connection by sending a Connection Request message when

  • the test set receives an IP datagram addressed to the AT. The datagram may come from another host on the network or from the test set itself when the user presses the Start Ping key (see Ping and AN Initiated Packet Data Connection Re-activation from Dormant State ), or
  • the AT requests to retrieve data (see AT Initiated Packet Data Connection Re-activation from Dormant State ).

Related Topics

Connected State

Session Open State

Packet Data Connection Processing States Lifecycle ( Lab Application Only )

Packet Data Connection Call Flow ( Lab Application Only )


Packet Data Connection Call Flow

Packet Data Connection Call Flow

This section is only applicable to the lab application.

The following diagrams illustrate the key steps and messaging to establish a packet data connection between the access terminal (AT) and the test set when the test set is configured to use the Default Packet Application (DPA) (see Session Application Type ).

For the key steps and messaging to establish a test data connection (TAP/ETAP), see TAP/ETAP Data Connection Call Flow

  • AT Initiated Packet Data Connection from Idle State
  • AT Initiated Connection Close to Dormant State
  • AN Initiated Connection Close to Dormant State
  • AT Initiated Packet Data Connection Re-activation from Dormant State
  • AN Initiated Packet Data Connection Re-activation from Dormant State

AT Initiated Packet Data Connection from Idle State

AT Initiated Connection Close to Dormant State

AN Initiated Connection Close to Dormant State

AT Initiated Packet Data Connection Re-activation from Dormant State

AN Initiated Packet Data Connection Re-activation from Dormant State

Related Topics

Packet Data Connection Processing States Lifecycle


How Do I Access the Data Counters?

How Do I Access the Data Counters?

Last updated: May 24, 2006

This section is only applicable to the lab application.

When a test or packet data connection is established (see How Do I Open a Session and Test Data Connection? or How Do I Make a Packet Data Connection? ), the test set provides several data counters to keep a running count of traffic packets on both the forward and reverse link as data is transferred (see Data Counters for a description of these counters).

  1. Press the CALL SETUP key.
  2. Press the left More key and go to Call Control 3 of 3 .
  3. Press the F2 ( Data Channel Info ). The Data Counters table is displayed to provide the RLP (radio link protocol) and IP data information.
  4. (Optional) To clear the counters for IP data, press the F3 ( Clear IP Counters ). To clear the counters for RLP control and data, press the F4 ( Clear RLP Counters ). These counters will also be cleared when the test set cycles power or full presets.
  5. Press the F2 ( Traffic Channel Packet Info ), the Traffic Channel Packet Info screen is displayed providing the number of the traffic channel packets per data rate on both the forward and reverse link. A typical display (in an ETAP test data connection) is shown below. To clear the counters for the traffic channel packets, press the F3 ( Clear Traffic Counters ).
  6. Change the Cell power or AWGN power, then observe how these counters varied. You will see the effects of RF degradation on data rate changes.
  7. You can also view the forward traffic activity from a graph display - Traffic Channel Packet Histogram which can be accessed by press the F4 ( Traffic Channel Histogram ).

    The Traffic Channel Histogram display provides the forward traffic activity (the total number of forward traffic packets that is transmitted by the test set to the AT for the given DRC and transmission format) during the most recent time period as specified by the Time Span ( F1 ) (range: 1 to 30 seconds). You can place a marker on any DRC you interested using F5 ( Marker Position ), and pause/resume the histogram display by pressing the F4 ( Pause/Resume Histogram ). To clear the histogram display, press the F3 ( Clear Histogram ).

Related Topics

Data Counters


How Do I Set Up Data Channel Parameters?

How Do I Set Up Data Channel Parameters?

Last updated: May 24, 2006

This section is only applicable to the lab application.

  1. Press the CALL SETUP key.
  2. Press the left More key until 3 of 3 is displayed.
  3. Press the Data Channel Info ( F2 ) key.
  4. Press the Data Channel Parameters ( F1 ) key.
  5. Turn the knob to highlight a parameter and enter/select a value as desired.

Data Channel Parameters

Related Topics

Data Channel Parameters


How Do I Make a Packet Data Connection?

How Do I Make a Packet Data Connection?

Last updated: April 14, 2005

This section is only applicable to the lab application.

The packet data connection can only be initiated from the wireless device (such as an 1xEV-DO access terminal). This example procedure only shows the key setups to access a web server on a PC from an AT's built-in web browser via the test set emulating an access network.

  1. Hardware Connection Setup (see Access Network Emulation ):
    • Connect the test set's rear panel LAN PORT to a LAN or a PC running a server application.
    • Connect a web browser enabled wireless device to the test set's front panel RF IN/OUT connector.
  2. Packet Data Connection Parameters Setup:
    • Set up the test set such as Cell Power, Cell Band, Channel, etc. required for your wireless devices to open a session with the test set. See A. Configure Call Parameters .
    • Select Application Config ( F10 on Call Parms 1 of 4) and set Service Application Type to Default Packet Application . See How Do I Change Call Parameters? .
    • Select Data Channel Info ( F2 on Call Control 3 of 3). Set the DUT IP Address to a proper value for your AT and set the External PDSN State to Off indicating the test set's internal PDSN is used (see How Do I Set Up Data Channel Parameters? ).
  3. Turn your AT on and wait for it to open a session with the test set. See B. Open a Session .
  4. After the session is open (the Active Cell status area should show Session Open ), navigate to the web browser on your AT (depending upon your AT's design) and attempt to access the PC's web server.
  5. The Active Cell status area should show Connected (see Packet Data Connection Processing States Lifecycle ) indicating a successful packet data connection. Observe the AT's display, the web page you were accessing should be shown on your AT's screen.
  6. As data is transferred, you can use the data counters (see How Do I Access the Data Counters? ) and the Data Throughout Monitor ( How Do I Use the Data Throughput Monitor? ), etc., to monitor the data rate variations. Add an AWGN power ( How Do I Change Generator Information? ) or change the Cell power, observe the effects of the RF degradation on the data rate.

Related Topics

Packet Data Service Example Procedure (via Simple IP)


How Do I Use the Data Throughput Monitor?

How Do I Use the Data Throughput Monitor?

Last updated: April 14, 2005

This section is only applicable to the lab applications.

Description

The following procedure illustrates typical usage of the data throughput monitor.

Accessing the Monitor Controls

  1. Press the Instrument selection key.
  2. Select Data Throughput Monitor .

    The data throughput monitor is displayed with the default settings as shown above. The Swap Window Positions ( F5 ) is displayed only when another measurement or instrument is active.

    Once the data throughput monitor is selected, it can be accessed by pressing the MEASUREMENT key, followed by the Swap Window Positions ( F5 ) key if necessary.

  3. Set the axis control as needed for your testing situation using the Axis Control ( F1 ) key to access the Time Span ( F1 ), Start Data Rate ( F2 ) Stop Data Rate ( F3 ) keys. For example, if you expect data rates to exceed the default value of 100 kbps, press the ( F1 ) key followed by the ( F3 ) key and enter a new value in the Stop Data Rate field using the DATA ENTRY keys.
  4. Press the Return ( F6 ) key to exit the Axis Control menu.
  5. Select the traces you would like to display by pressing the Trace Control ( F2 ) key followed by the Trace Display ( F1 ) key. To select a trace, turn the value to On. There are four color-coded traces and any combination can be selected:
    • OTA Tx - (Over The Air Transmitted bits-per-second). This is the rate of link-layer bit transfer sent from the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in WCDMA and GPRS, or PPP in GSM. Tx refers to the reverse or uplink channel direction.
    • OTA Rx - (Over The Air Received bits-per-second). This is the rate of link-layer bit transfer received by the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in WCDMA and GPRS, or PPP in GSM. Rx refers to the forward or downlink channel direction.
    • IP Tx - Internet Protocol Transmitted. This is the rate of network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.
    • IP Rx - Internet Protocol Received. This is the rate of network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.

    By default, the OTA Tx and OTA Rx traces are the only traces turned on.

  6. Press the Return ( F6 ) key to exit the Trace Control menu.

  7. Establish a data connection with the mobile.

    The Data Throughput Monitor will begin displaying numerical and graphical information. The numerical information pertains to the period of time beginning with the establishment of the first data connection, and the graphical traces represent up to 600 seconds of the latest data throughput statistics.

  8. Set a marker.

    Using the Trace Control menu, select a marker by pressing the corresponding F2 , F3 , F4 , or F5 keys followed by the Data Entry key labeled ON.

    Press the Return ( F6 ) key.

    After allowing the monitor to accumulate throughput for at least one minute, change the Time Span to 50 seconds (see step 3 above). This will expand the graphical view to improve resolution.

    Press the Return ( F6 ) key.

  9. Freeze the graph.

    Press the Freeze Graph (F4) key.

    Turn the knob to adjust the position of the marker. Marker results will be displayed in the summary table

  10. Press the Return ( F6 ) key to exit the Trace Control menu.
  11. Press the Resume Graph ( F4 ) key to display the most recent trace data.
  12. Press the Clear Graph ( F3 ) key to reset the traces and the numeric counters.

Changing Data Rates

Data throughput can be analyzed under various call processing and RF conditions. This section illustrates the steps required to change data rates.

It is assumed that the data throughput monitor is displayed and a data call is connected.

  1. Press the CALL SETUP key.
  2. Change the data rate (see Related Topics).
  3. Press the MEASUREMENT key.

Related Topics

Data Throughput Monitor

To change the data rate, increase or decrease the AWGN Power or Cell Power (see also Traffic Channel Packet Information ).


Measuring Graphical Access Probe Power

Measuring Graphical Access Probe Power

Last updated: June 20, 2006

This section is only applicable to the lab application.

  • General Procedure
  • Testing 4.3.1 Range of Open Loop Output Power

NOTE
Channel power calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. The channel power calibration also calibrates the graphical access probe power measurement. See Calibrating the Test Set for details.

General Procedure

  1. Connect the access terminal to the test set's front panel RF IN/OUT connector and power it on. If the access terminal does not automatically open a session, perform whatever actions are necessary to open a session. See How Do I Open a Session and Test Data Connection? for more details.
  2. Initialize the graphical access probe power measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Graphical Access Probe Power measurement and press the knob.
  3. Select Graphical Access Probe Pwr Setup ( F1 ) to access the Graphical Access Probe Power Setup menu. Turn the knob to select the parameters and set the value as required for your test situation. For example,
    • set Probe Power Step to 2.0 dB .
    • set Probe Num Step to 6 .
    • set Probe Sequence Max to 4 .
    • set Preamble Length (Frames) to 7 .

    NOTE
    The Probe Sequence Max is a "Configurable Attribute" that is configured during the Session Negotiate State . Its value can not be changed when a session is open and Call Limit Mode is on.

  4. Select Close Menu ( F6 ) to close the Graphical Access Probe Power Setup menu.
  5. Set the access network to ignore all access attempts by setting Call Limit Mode to On ( F10 on the Call Parms 2 of 3 menu). See How Do I Change Call Parameters? for more details.
    NOTE

    It is recommended that you always turn Call Limit Mode on when measuring graphical access probe power. The easiest way to induce access probes from the access terminal is to page the access terminal. If you do not have call limit mode set to on, when you page the access terminal, the connection will complete, which clears the access probe power result from the measurement screen.

    Set call limit mode back to off when you have finished measuring access probe power.

  6. Press the START SINGLE key to arm the measurement. The measurement result will not be returned until you complete step 7.
    IMPORTANT

    The measurement will not operate until you arm it by pressing the Start Single key.

  7. In order to perform the graphical access probe power measurement, the access terminal must send access probes. The easiest way to induce this is to page the AT (open a connection) by selecting Start Data Connection ( F3 on the Call Control 2 of 2 menu).
  8. When the AT sends access probes as specified in step 3, their power levels will be measured and displayed. As shown below, the measurement results are displayed in both a tabular and a bar graph formats (see Graphical Access Probe Power Measurement Results for more description).
  9. (Optional) To adjust the display view, see Set Up the Graphical View .
  10. After finishing the measurements:
    • End the connection attempt by selecting End Data Connection ( F3 on the Control 2 of 2 menu).
    • Turn the Call Limit Mode back to Off .
    • Turn the graphical access probe power measurement off by pressing the Measurement selection key, selecting Graphical Access Probe Power , then Close Measurement ( F4 ).

IMPORTANT
If the access probe power measurement is on and waiting to measure a probe, all other measurements will not be able to execute. It is therefore recommended that you turn off the graphical access probe power measurement before attempting any other measurements.

Set Up the Graphical View

  1. Press the More key on the left side of the display until 1 of 2 is displayed.
  2. Press the Graph Control ( F2 ) key.
  3. Select the Start ( F3 ) and Span ( F4 ) to adjust the span of the graph display. The graph window can be adjusted to include the entire 120 second range or only a portion of the 120 second time period of particular interests. The graph can display up to 60 access probes, labeled 0 through 59.
  4. The Marker Mode ( F1 ) sets the mode of the active marker.
    • When Position is selected, use the Marker Position ( F2 ) to position the marker at any bar across the current span of the graph. Measurement results that correspond with the bar at the position marker (in this example, the power levels for the 7th access probe and the time offset relative to the 1st access probe) are displayed above the graph and become highlighted in the table below the graph.
    • When Delta is selected, it first freezes the current position marker and uses it as a reference marker. A second marker is created at the position specified by the Delta Position ( F2 ) offset from that of the position marker. Any change in power between the second marker and the position marker is calculated as delta values. Measurement results that correspond with the position marker and the delta marker (in this example, the two values to the right of the "Mkr" indicates the power levels for the 7th access probe and the time offset relative to the 1st access probe, and the two values to the right of the delta symbol indicates the delta power and time between the 9th access probe and the 7th access probe) are displayed above the graph and become highlighted in the table below the graph.
  5. (Optional) Press the MEASUREMENT RESET key to clear the display.

Testing 4.3.1 Range of Open Loop Output Power

For details on performing the steps below, see the General Procedure above. The 4.3.1 test can also be performed with Access Probe Power measurement, see Measuring Access Probe Power .

  1. This test specifies using Default Access Channel MAC Protocol and Access Parameter message. See To Configure the Test Set to Default Access Channel MAC Subtype for detailed procedure.
  2. Set the Cell Band and Channel as needed and wait for access terminal automatically opening a session.
  3. Initialize the graphical access probe measurement.
  4. Set Probe Power Step to 0 dB . This ensures that all access probes in the probe sequence will transmit at the same power level, rather than incrementing in power.
  5. Set Probe Sequence Max to 1 .
  6. Set Preamble Length to 7 .
  7. Set Open Loop Adjust to 78 dB or 81 dB , depending upon band class (for example, use 78 for US Cellular band, or use 81 for US PCS band).
  8. C.S0033 specifies to set the AN forward packet activity to 100%. Forward packet activity is fixed in the test set, always set to 100%. See Fixed Settings .
  9. Set the access network to ignore all access attempts by setting Call Limit Mode to On .
  10. Set Î or ( Cell Power ) to -25 , -65 or approximately -95 dBm/1.23 MHz (value depends on band class and access terminal class) for tests 1-3 as specified by C.S0033.
  11. Press the Start Single key to arm the measurement.

    IMPORTANT
    The measurement will not operate until you arm it by pressing the Start Single key.

  12. Send a page to the access terminal by selecting Start Data Connection .
  13. Measure access probe power.
  14. Stop the page to the access terminal by selecting Stop Data Connection .
  15. Perform steps 10-14 for tests 1-3.

Related Topics

Graphical Access Probe Power Measurement Description


How Do I Make Hybrid Mode AT/MS Tests?

How Do I Make Hybrid Mode AT/MS Tests?

Last updated: December 1, 2005

This section is only applicable to the lab applications.

  • General Procedure
  • Specific Procedures for Recommended Tests

General Procedure

  1. Make sure you have finished the pre-requisite setups, especially ensure that the two test sets are synchronized on CDMA system time. For details, see Prerequisite Setup .
  2. Set up the test set #1 running the E6702B cdma2000 lab application to allow the hybrid mode AT/MS to acquire the IS-2000 or IS-95 system successfully. In the following example, IS-2000 system is used.
    • Set the Cell Band ( F8 on Call Parms 1 of 3 ) and Channel ( F9 on Call Parms 1 of 3 ) to match your AT/MS's configuration for IS-2000 system.
    • Set the SID (from Call Control 2 of 4 , F2 Cell Info , F2 Cell Parameters ) for your AT/MS if required.
    • Set the Cell Power ( F7 on Call Parms 1 of 3 ) to a proper value (for example, -50 dBm/1.23 MHz ).
    • Set all other parameters to the default values (for example, Active Cell operating mode, IS-2000 system type, etc.).
  3. Set up the test set #2 running the E6706A 1xEV-DO lab application to allow the hybrid mode AT/MS to acquire the IS-856 system successfully.
    • Set the Cell Band ( F8 on Call Parms 1 of 3 ) and the Channel ( F9 on Call Parms 1 of 3 ) to match your AT/MS's configuration for IS-856 system. Note that the RF frequency determined by bands and channels for IS-856 system must be different from that of the IS-2000/IS-95 system.
    • Set the Session Application Type to Default Packet Application (from Call Parms 1 of 3 , F10 Application Config ).
    • Set the Preferred Control Channel Cycle Control to AT Specified (from Call Control 2 of 3 , F2 Access Network Info , F1 Configurable Attribute Ctrl ). This allows the AT/MS to propose the PCCC value during the session negotiation to guarantee that the preferred 1xEV-DO control channel cycle offset does not overlap in time with the CDMA paging channel slot that the AT/MS is required to use.
    • Set the Cell Power ( F7 on Call Parms 1 of 3 ) to a proper value (for example, -50 dBm/1.23 MHz ).
    • Set the Session Close ( F12 on Call Parms 2 of 3 ) to a larger value (see Session Close ) as required.

      NOTE
      To prevent the session from unexpected closing when the AT stays on the test set #1 (for example, a voice call) longer than the default value (3 minutes), it is recommended to set the Session Close to a larger value prior to perform the tests 5 - 10 as shown on Specific Procedures for Recommended Tests .

    • All other parameters can be set to the default value (for example, Active Cell operating mode, IS-856 system type, etc.).
  4. (Optional) If you would like to log the protocol messages exchanged between the test sets and the hybrid mode AT/MS, set up the Wireless Protocol Advisor (WPA) and start logging. See Protocol Logging for details.
  5. Power up the hybrid mode AT/MS and verify that AT/MS first acquires and registers on the IS-2000 system (test set #1), and then acquires and opens a session on the IS-856 system (test set #2).

    On test set #1, you will see the hybrid mode AT/MS's reported registration data is shown in the Mobile Station Information window. The test set # 1 goes to idle state.

    On test set #2, you will see that the hybrid mode AT/MS establishes an open session on IS-856 system and is assigned a UATI. The AT/MS related information is shown on the Access Terminal Information windows.

    NOTE
    Most ATs will immediately initiate a session once they reach the idle state upon power-up. So you will see Session Open state is always shown on the test set #2 when the hybrid mode AT/MS has successfully negotiated with the IS-856 system (1xEV-DO).

  6. When the hybrid mode AT/MS has successfully acquired both systems, you are ready to perform the following recommended tests.

Specific Procedures for Recommended Tests

NOTE
Prior to performing the tests, you should verify that:

  • the test set #1 (CDMA) can provide voice and SMS services.
  • the packet data services can be provided by both test set #1 (CDMA) and test set #2 (1xEV-DO) but the precedence is given to test set #2. That is, the packet data session is established on test set #2 (1xEV-DO) while both 1xEV-DO and CDMA signal exist. Only when the 1xEV-DO signal (test set #2) is unavailable the packet data session is established on test set #1 (CDMA) if properly set up.

Perform the following procedures to make the functional tests of the hybrid mode AT/MS as recommended by Qualcomm®.

  1. Make sure that the hybrid mode AT/MS has successfully acquired both test sets, registered on the test set #1 (CDMA) and opened a session on the test set #2 (1xEV-DO). If not, perform the General Procedure .

  2. Follow the instructions as described in the table below to perform the recommended tests that are supported by the test sets. These tests can be broadly divided into three categories:

    • The tests 1 - 4 are to verify that the hybrid mode AT/MS can acquire both the IS-2000/IS-95 (cdma2000) and the IS-856 (1xEV-DO) systems, and perform dual-idle monitoring of the paging channel of the IS-2000/IS-95 system and the control channel of the IS-856 system concurrently.
    • The tests 5 - 20 are to verify that the hybrid mode AT/MS can support services on both the IS-2000/IS-95 and IS-856 systems.
      • The tests 5 - 10 are to verify that the AT/MS can initiate/accept a voice call on the IS-2000/IS-95 system while in an active/dormant packet data connection or in idle state on the IS-856 system.
      • The tests 11 - 16 are to verify that the AT/MS can initiate/accept SMS services on the IS-2000/IS-95 system while in an active/dormant packet data connection or in idle state on IS-856 system.
      • The tests 17 - 20 are to verify that the AT/MS can establish a packet data connection on the IS-856 system, or on the IS-2000 system when IS-856 system is unavailable.
    • The tests 21- 28 are related to the MIP operations of the hybrid mode AT/MS.
      • The tests 21 - 24 are to verify that the hybrid mode AT/MS can handoff the packet data connection between the IS-856 and IS-2000 system while using the AT/MS in MIP.
      • The tests 25 - 28 are to verify the fundamental MIP operations. For example, connect a MIP call using static or dynamic home IP address, perform a MIP to SIP fallback if MIP registration fails, etc.

    For details on these tests' definitions, see Recommended Functional Tests for Hybrid Mode AT/MS .

    Instructions for Recommended Test Cases
    Test No. Instructions

    1

    To verify that the hybrid mode AT/MS periodically (based on the Slot Cycle Index) tunes away to IS-2000/IS-95 system for monitoring its paging channel slot while having an open session on IS-856 system:

    • Make sure that the Timer Based Registration State is set to On on the test set #1.
    • Verify that the AT/MS makes registrations on test set #1 periodically which indicates the AT/MS will monitor the paging channel slot while having an open session on IS-856 system. This can be observed from the updated registration data in the Mobile Station Information window.

    2

    To verify that the hybrid mode AT/MS enters 1xEV-DO power save mode after failing to acquire a 1xEV-DO system:

    • On test set #2, press the Close Session ( F7 on Call Parms 1 of 3 ) to close the current open session (go to Idle state), and then set the Cell Power ( F7 on Call Parms 1 of 3 ) to Off to simulate that the 1xEV-DO system is unavailable.
    • You should see that the hybrid mode AT/MS can not automatically re-open a session and the test set # 2 stays at Idle state.

    3

    To verify that the hybrid mode AT/MS always proposes an appropriate PCCC during the session negotiation:

    • Change the AT/MS's MIN using your specific service programming tool. You can not change the MIN from the test set. The PCCC value varies based on the MIN of the hybrid mode AT/MS.
    • Observe the Access Network Information screen on the test set #2. You should see that the Preferred Control Channel Cycle Control value proposed by hybrid mode AT/MS is changed along with the change of the MIN and is updated after a successful session negotiation. The session is then successfully re-opened again.

    4

    To verify the hybrid mode AT/MS's behavior when it moves to a location where no 1xEV-DO signal is available but a good CDMA signal is available, and when it moved back where both signals were available:

    • On test set #2, press the Close Session ( F7 on Call Parms 1 of 3 ) to close the current open session, and then set the Cell Power ( F7 on Call Parms 1 of 3 ) to Off to simulate that the 1xEV-DO system is unavailable.
    • You should see that the hybrid mode AT/MS can not automatically re-open a session and the test set # 2 stays at Idle state.
    • On test set #2, set the Cell Power ( F7 on Call Parms 1 of 3 ) back to -50 dBm to simulate that the 1xEV-DO signal is available again.
    • Wait for a while, you should see that the AT/MS will re-acquire the 1xEV-DO system and open a session on the test set #2.
    • The hybrid mode AT/MS remains registered on the test set #1 during above operations.

    To verify the hybrid mode AT/MS's behavior when it moves to a location where no CDMA signal is available but a good 1xEV-DO signal is available, and when it moved back where both signals were available:

    • On test set #1, set the Cell Power ( F7 on Call Parms 1 of 3 ) to Off to simulate that the CDMA signal is unavailable.
    • On test set #1, press the Clear MS Capabilities & Info ( F5 on Call Control 2 of 5 ) to clear the AT/MS's last registration data in the Mobile Station Information window.
    • On test set #1, press Register Mobile ( F5 on Call Control 1 of 5 ) to force the hybrid mode AT/MS to make a registration.
    • The Mobile Station Information window on test set #1 should remain empty because AT/MS can not register to the CDMA system (no CDMA signal is available).
    • On test set #1, set the Cell Power ( F7 on Call Parms 1 of 3 ) back to -50 dBm to simulate that the CDMA signal is available again. The hybrid mode AT/MS will try to register on the test set #1 and the registration data will be shown on the Mobile Station Information window.
    • The hybrid mode AT/MS remains keeping an open session on the test set #2 during above operations.

    5

    To verify that the hybrid mode AT/MS can originate CDMA voice calls in dual-idle state, make an AT/MS originated voice call. The key steps include:

    • On test set #1, set the service option for the radio configuration in which you would like to bring up the call to a voice service option. For example, SO3 is configured for the Radio Config (Fwd 3, Rvs 3) .
    • Originate a voice call from the AT. For example, entering a phone number and pressing SEND on the AT.
    • When the voice call is successfully established, Connected is shown on the test set #1. During the above operations, the test set #2 remains keeping an open session with the AT.
    • Terminate the voice call from the AT/MS (for example, press the End on the AT) or from the test set by pressing the End Call ( F3 on Call Control 1 of 5) . When the voice call is successfully ended, test set #1 returns to Idle state. During the above operations, the test set #2 remains keeping an open session with the AT/MS.

    For details on how to make a CDMA voice call, see Related Topics .

    6

    To verify that the hybrid mode AT/MS can originate CDMA voice calls while in CDMA idle and 1xEV-DO dormant state, perform the following procedure:

    • Originate a packet data call from the AT/MS to the test set #2. See Related Topics for an example procedure which uses the AT/MS as wireless modem for a packet data connection. The example procedure varies depending upon your data applications.
    • When a packet data connection is successfully established, Connected is shown on the test set #2.
    • On test set #2, press the F2 ( Force Dormant ) on the Call Control 1 of 3 menu to make the AT/MS go dormant. You should see that the test set #2 displays Dormant state.
    • Follow the procedure for test 5 to make an AT/MS originated voice call. Verify that the voice call is successfully connected on the test set #1. Any data transfer is not allowed while during a voice call. The test set #2 remains at Dormant state during voice call operations. Only when the voice call is ended, the data transfer can be re-started on the test set #2 if there is data to send.

    7

    To verify that the hybrid mode AT/MS can originate CDMA voice calls while in CDMA idle and connected 1xEV-DO state, the procedure is similar to that of 6 except that:

    • You do not need to make the AT/MS go dormant before originating a voice call.
    • Originate a voice call from the AT/MS while in an active 1xEV-DO packet data connection.
      Verify that the current packet data connection will go dormant on the test set #2 when a voice call is connected on the test set #1. Any data transfer is not allowed while during a voice call. The test set #2 remains at Dormant state during a voice call. Only when the voice call is ended, the packet data connection will re-established on test set #2 if there's data to transmit (for example, start a ping session). For details on a Ping procedure, see Related Topics .

    8

    To verify that the hybrid mode AT/MS can receive CDMA voice pages in dual-idle state, the procedure is similar to that of the test 5 except that the voice call is originated from the test set #1 instead of from the AT/MS:

    • Press the Originate Call ( F3 on Call Control 1 of 5 ) to page the AT/MS from the test set #1. When the AT/MS answers the voice page, the voice call is connected and the test set #1 displays Connected state. The AT/MS remains keeping an open session with the test set #2 during the voice call operation.

    9

    To verify that the hybrid mode AT/MS can receive CDMA voice pages while in 1xEV-DO dormant state, the procedure is similar to that of the test 6 except that the voice call is originated from the test set #1 instead of from the AT/MS:

    • Press the Originate Call ( F3 on Call Control 1 of 5 ) to page the AT/MS from the test set #1. When the AT/MS answers the voice page, the test set #1 goes to Connected state. The AT/MS remains dormant on the test set #2 during a voice call. Any data transfer is not allowed while during a voice call. Only when the voice call is ended, the packet data connection can re-established on test set #2 if there's data to transmit.

    10

    To verify that the hybrid mode AT/MS can receive CDMA voice pages in 1xEV-DO connected state, this procedure is similar to the procedure of the test 7 except that the voice call is originated from the test set #1 instead of from the AT:

    • Press the Originate Call ( F3 on Call Control 1 of 5 ) to page the AT/MS from the test set #1. When the AT/MS answers the voice page, the test set #1 goes to Connected state and the data session on the test set #2 will enter into Dormant state. Only when the voice call is ended, the packet data connection can re-established on test set #2 if there's data to transmit.

    11

    To verify that the hybrid mode AT/MS can originate an SMS while in dual-idle state, send a short message from the AT/MS to the test set #1. The key steps include:

    • Create a short message on the AT/MS and then send to the test set #1.
    • Verify that the short message is successfully received by the test set #1 and displayed on the Short Message Service Information screen. The AT/MS remains keeping an open session with the test set #2.

    For details on AT/MS originated SMS procedure, see Related Topics .

    12

    To verify that the hybrid mode AT/MS can originate an SMS in 1xEV-DO dormant state, the procedure is similar to that of the test 6 except that an AT/MS originated SMS takes the place of AT/MS originated voice call.

    For details on AT/MS originated SMS procedure, see Related Topics .

    Verify that the short message is successfully received by the test set #1 and displayed on the Short Message Service Information screen. The AT/MS remains keeping a dormant data session on the test set #2.

    13

    To verify that the hybrid mode AT/MS can originate SMS while in 1xEV-DO connected state, the procedure is similar to that of the test 7 except that an AT/MS originated SMS takes the place of AT/MS originated voice call.

    For details on AT/MS originated SMS procedure, see Related Topics .

    Verify that the short message is successfully received by the test set #1 and displayed on the Short Message Service Information screen. Because the SMS is typically short-lived and would only cause brief interruptions to the 1xEV-DO service, the packet data connection may continue to remain active on the test set #2 or go dormant if the time allowed to spend on SMS service expires. The data transfer (for example, a ping operation) can be re-started after the SMS service.

    14

    To verify that the hybrid mode AT/MS can receive SMS while in dual-idle state, the procedure is similar to that of the test 11 except that an AT/MS terminated SMS takes the place of AT/MS originated SMS.

    For details on AT/MS terminated SMS procedure, see Related Topics .

    Verify that the short message is successfully received by the AT/MS and displayed on the AT/MS's screen. The AT/MS remains keeping an open session with the test set #2

    15

    To verify that the hybrid mode AT/MS can receive SMS in 1xEV-DO dormant state, the procedure is similar to that of the test 12 except that an AT/MS terminated SMS takes the place of AT/MS originated SMS.

    For details on AT/MS terminated SMS procedure, see Related Topics .

    Verify that the short message is successfully received by the AT/MS and displayed on the AT/MS's screen. The AT/MS remains keeping a dormant data session on the test set #2.

    16

    To verify that the hybrid mode AT/MS can receive SMS while in 1xEV-DO connected state, the procedure is similar to that of the test 13 except that an AT/MS terminated SMS takes the place of AT/MS originated SMS.

    For details on AT/MS terminated SMS procedure, see Related Topics .

    Verify that the short message is successfully received by the AT/MS and displayed on the AT/MS's screen. Because the SMS is typically short-lived and would only cause brief interruptions to the 1xEV-DO service, the packet data connection may continue to remain active on the test set #2 or go dormant if the time allowed to spend on SMS service expires. The data transfer (for example, a ping operation) can be re-started after the SMS service.

    17

    To verify that the hybrid mode AT/MS can originate 1xEV-DO packet data calls while in dual-idle state, perform the following procedure:

    • Originate a packet data connection from the AT/MS and verify that data can be transferred over test set #2. See Related Topics for an example procedure which uses AT/MS as a wireless modem for a packet data connection on 1xEV-DO system. The example procedure varies depending upon your data applications.

    18

    To verify that the hybrid mode AT/MS can re-originate 1xEV-DO packet data call while in 1xEV-DO dormant state, perform the following procedure:

    • When a packet data connection has established on test set #2 (if not, see the procedure of test 17 ), press the F2 ( Force Dormant ) on the Call Control 1 of 3 menu to make the AT/MS go dormant. The Dormant state should be shown on test set #2.
    • Make an AT/MS originated packet data connection. For example, start a ping session from the PC which is using AT/MS as a modem to the test set's built-in HTTP server. The Connected state should be shown on the test set #2, which indicates a successful packet data connection established.

    19

    To verify that the hybrid mode AT/MS can receive 1xEV-DO packet data pages while in dormant state on 1xEV-DO, the procedure is similar to that of the test 18 except that:

    • Make an AT/MS terminated packet data connection. For example, start a ping session from the test set #2 to the AT/MS. For detailed ping procedure, see Related Topics . You should see that the test set #2 returns to Connected state, which indicates a successful packet data connection established.

    20

    To verify that the hybrid mode AT/MS can originate a packet data call on CDMA when 1xEV-DO service is not available, perform the following procedure:

    • On test set #2, press the Close Session ( F7 on Call Parms 1 of 3 ) to close the current open session, and then set the Cell Power ( F7 on Call Parms 1 of 3 ) to Off to simulate that thee 1xEV-DO system is unavailable.
    • You should see that the hybrid mode AT/MS can not re-open a session and will go to power save mode on 1xEV-DO system.
    • Set up a packet data call and verify that the packet data connection is established on test set #1. Note that you must set the service option to SO33 or SO33 (+ F-SCH) on test set #1 before the hybrid mode AT/MS can initiate a packet data connection on IS-2000 system. For an example procedure of the packet data connection on IS-2000 system, see Related Topics . The example procedure varies depending upon your data applications.

    21 - 28

    The tests 21 - 28 require the external MOB-IP-SIM to provide MIP simulation. Refer to Prerequisite Setup to properly connect the external MOB-IP-SIM for these tests.

    To make the two test sets work with the MOB-IP-SIM for packet data handoff, the following key parameters should be properly set:

    • On test set #1, a service option 33 should be properly configured for the selected radio configuration. Either SO33 or SO33 (+ F-SCH) is required for a packet data connection on IS-2000 system.
    • On test set #2, the Default Packet Application should be configured as the session application. This is required for a packet data connection on IS-856 system.
    • On both test sets,
      • set the call parameters that are required for the hybrid mode AT/MS to acquire the IS-2000 and IS-856 systems successfully. For details, see General Procedure .
      • set the LAN IP addresses to make the two test sets in the same subnet. On each test set, set its LAN IP Address , Subnet Mask , Default Gateway from the Instrument Setup menu (accessing by SYSTEM CONFIG -> F1 Instrument Setup ) that are assigned by your network administrator.
      • set them to be able to work with the external MOB-IP-SIM. On each test set, set the External PDSN IP Address and External PDSN TCP Port matching your MOB-IP-SIM's configuration, and then turn the External PDSN State to on. This indicates the MOB-IP-SIM will be used to provide MIP functions.
      • Refer to the MOB-IP-SIM technical manual to properly configure the MOB-IP-SIM (for example, IP address, subnet mask, etc.) for MIP operations.

    NOTE
    To simplify the packet data handoff functional tests, the two test sets are set to share the same PDSN simulated by the MOB-IP-SIM. This guarantees that the same IP address is assigned to the hybrid mode AT/MS for seamless data session handoffs between the two networks. It further reduces any latency due to PPP re-sync on handoffs.

    21

    To verify that the hybrid mode AT/MS is able to hand off an active data session from 1xEV-DO to CDMA system when 1xEV-DO system is unavailable, perform the following key steps:

    • Verify that you've finished the setups as described in 21 - 28 and the hybrid mode AT/MS has successfully registered on the test set #1 and opened a session on the test set #2.
    • Make a packet data connection on test set #2 through the external MOB-IP-SIM. See Related Topics for an example MIP based packet data connection on 1xEV-DO system.
    • On test set #2, set the Cell Power ( F7 on Call Parms 1 of 3 ) to Off to simulate that the AT/MS moves out of the 1xEV-DO coverage.
    • Verify that the hybrid mode AT/MS will hand off the packet data connection from test set #2 to test set #1. The data transfer (if you are downloading a large file) can be continued through the test set # 1 after a small delay. You should see that Connected state is shown on test set #1 and Idle state is shown on test set #2.

    22

    To verify that the hybrid mode AT/MS is able to hand off a dormant data session from 1xEV-DO to CDMA system when 1xEV-DO system is unavailable, the procedure is similar to that of the test 21 except that:

    • Let the hybrid mode AT/MS go dormant by pressing the F2 ( Force Dormant ) on the Call Control 1 of 3 menu on test set #2. Then turn the Cell Power on the test set #2 to off to simulate that the AT/MS moves out of the 1xEV-DO coverage.
    • Start a data transfer (for example, start a ping session from the PC which is using the AT/MS as a modem). Verify that the data connection is made on test set #1. This indicates that the data session is handed off from 1xEV-DO to CDMA system.

    23

    To verify that the hybrid mode AT/MS is able to hand off a dormant data session from CDMA to 1xEV-DO system when 1xEV-DO system is available again, perform the following key steps:

    • Verify that you've finished the setups as described in 21 - 28 and the hybrid mode AT/MS has successfully registered on the test set #1 and opened a session on the test set #2.
    • On test set #2, press the Close Session ( F7 on Call Parms 1 of 3 ) to close the current open session, and then set the Cell Power ( F7 on Call Parms 1 of 3 ) to Off to emulate that the AT/MS is at CDMA-only coverage.
    • Make a packet data connection on test set #1 through the external MOB-IP-SIM. See Related Topics for an example MIP based packet data connection on IS-2000 system.
    • Let the AT/MS go dormant by pressing the F2 ( Force Dormant ) on the Call Control 1 of 3 menu on the test set #1.
    • On test set #2, set the Cell Power ( F7 on Call Parms 1 of 3 ) back to -50 dBm to simulate that the AT/MS moves back to the hybrid coverage (both systems are available).
    • Verify that the hybrid mode AT/MS acquires the 1xEV-DO system and opens a session on test set #2.
    • Start a ping session. Verify that the data connection is made on test set #2, which indicates the data session is handed off from CDMA to 1xEV-DO system. This is because the packet data service takes the precedence on 1xEV-DO system when both systems are available).

    24

    To verify that the hybrid mode AT/MS is able to perform a 1xEV-DO to CDMA to 1xEV-DO data session hand off when the hybrid mode AT/MS moves from a hybrid coverage area to CDMA only coverage area and then back to a hybrid mode coverage area, you can refer to the procedure of the tests 21 and 23 . The key points to perform this test is:

    • To simulate that the AT/MS moves from a 1xEV-DO coverage to CDMA only coverage area, set the Cell Power ( F7 on Call Parms 1 of 3 ) to Off on test set #2.
    • To simulate that the AT/MS moves from the CDMA only coverage area back to a hybrid mode coverage, set the Cell Power ( F7 on Call Parms 1 of 3 ) back to -50 dBm on the test set #2.

    25 - 28

    These tests are to verify the most fundamental MIP behavior of the hybrid mode AT/MS, such as making an MIP call, MIP to SIP fallback operations if an MIP registration fails.

    To perform these tests, you are required to set the AT/MS properly in the AT/MS MIP profile using a service programming tool. For details, see your AT/MS's technical manual. Also, you should properly set the MOB-IP-SIM to support these MIP tests. For details on the MOB-IP-SIM functionality and configurations, see the MOB-IP-SIM technical manual.

Related Topics

Hybrid Mode

Recommended Functional Tests for Hybrid Mode AT/MS

Test Set #2 (1xEV-DO) Related Procedures:

  • To establish a packet data connection (using SIP) on test set #2 (1xEV-DO), see Packet Data Service Example Procedure (via Simple IP) .
  • To establish a packet data connection (using MIP) on test set #2 (1xEV-DO), see Packet Data Service Example Procedure (via Mobile IP) .
  • To ping the hybrid mode AT/MS from the on test set #2 (1xEV-DO), see How Do I Ping a Device From the Test Set? .

Test Set #1 (CDMA) Related Procedures:

  • To establish a voice call on test set #1 (CDMA), see:

    cdma2000: How Do I Set Up a Call?

  • To perform an AT/MS originated SMS on test set #1 (CDMA), see:

    cdma2000: Mobile-Originated SMS Procedure

  • To perform an AT/MS terminated SMS on test set #1 (CDMA), see:

    cdma2000: Mobile-Terminated SMS Procedure

  • To establish a CDMA packet data connection (using SIP) on test set #1 (CDMA), see:

    cdma2000: Packet Data Service Example Procedure (via Simple IP)

  • To establish a CDMA packet data connection (using MIP) on test set #1 (CDMA), see:

    cdma2000: Packet Data Service Example Procedure (via Mobile IP)

  • To ping the hybrid mode AT/MS from the on test set #1 (CDMA), see:

    cdma2000: How Do I Ping a Device From the Test Set?


How Do I Ping a Device From the Test Set?

How Do I Ping a Device From the Test Set?

Last updated: April 14, 2005

This section is only applicable to the lab application.

You can use the Ping feature of the test set to:

  • Ping the DUT from the test set : It's useful to check the IP connection between the test set and the DUT. Pinging a DUT from the test set involves upper layer protocols such as IP control protocol called ICMP in the test set and the DUT. So although the air link connection sometimes is good (data connection status indicating Connected), the Ping may still be failed due to the problem of upper layer protocols.
  • Ping an alternate address from the test set : It's useful to check the IP connection between the test set and a remote host (such as an PC acting as a FTP server).

Ping the DUT from the test set

  1. From the test set front panel, press the CALL SETUP key.
  2. Press the left More key two times until Call Control 3 of 3 is displayed.
  3. Press the Data Channel Info ( F2 ) key.
  4. Press the Data Channel Parameters ( F1 ) key.
  5. Select the DUT IP Address and enter a proper IP address assigned to your AT.

    NOTE
    The DUT's IP address must be on the same subnet as the test set's IP Address. See IP Address Requirements .

  6. Press F6 ( Close Menu ) to close the Data Channel Parameters menu.
  7. Press F6 ( Return ), go back to Call Control 3 of 3 menus.
  8. Press the Ping ( F3 ) key.
  9. Press the Ping Setup ( F1 ) key and verify that Device to Ping is set to DUT . If required, set the Ping Count , Timeout , and Packet Size .
  10. Verify that the current packet data connection status indicates Connected or Dormant . Otherwise, follow the procedure of How Do I Make a Packet Data Connection? to establish a packet data connection.
  11. Press Start Ping ( F3 ) key. If the connection is good, the DUT will return packets to the test set and the packet transfer information is displayed on the test set's screen. A typical display is shown below.

Ping an alternate address from the test set

  1. From the test set front panel, press the CALL SETUP key.
  2. Press the left More key two times until Call Control 3 of 3 is displayed.
  3. Press the Ping ( F3 ) key.
  4. Select Ping Setup ( F1 ) .
  5. Set the Alternate Ping Address to your desired target IP address (for example, a remote server running the data applications is connected to the same LAN with your test set).
  6. Set Device to Ping to Alternate .
  7. Select Start Ping( F3 ) . If the connection is good, then the device being pinged (such as the remote server) will return packets to the test set and the packet transfer information is displayed on the test set's screen

Related Topics

Ping


How Do I Perform Multi-unit Synchronization?

How Do I Perform Multi-unit Synchronization?

Last updated: November 21, 2005

This section is only applicable to the lab application.

Multiple Sync Clients can synchronize to the same Sync Server at the same time. The following procedure provides an example of how to make a synchronization between two test sets. It assumes that the test set running the E6702B cdma2000 lab application acts as a Sync Client and another one running the E6706A 1xEV-DO lab application acts as a Sync Server.

Prior to the following procedure, make sure you have finished the synchronization connection between the two test sets (see Synchronization Connection Setup ).

  • Step 1: Configure the Sync Server
  • Step 2: Configure the Sync Client
  • Step 3: Perform the synchronization between two test sets

Step 1: Configure the Sync Server

  1. Press the SYSTEM CONFIG key.
  2. Press the Instrument Setup ( F1 ) key and set up the LAN IP Address as required.
  3. Press the CALL SETUP key.
  4. Verify that the Operating Mode ( F1 ) is set to Active Cell and System Type ( F2 )is set to IS-856 for this example.
  5. Verify the External Trigger is set to 2 s. Go to Call Control 2 of 3, press the Generator Info ( F3 ), and then press the External Trigger ( F4 ). For details, see How Do I Change Generator Information? .
  6. Set the CDMA System Time (Date) and CDMA System Time (Time) as desired. For detailed procedure, see How Do I Change CDMA System Time Parameters? ).

Step 2: Configure the Sync Client

  1. Press the CALL SETUP key.
  2. Verify that the Operating Mode ( F1 ) is set to Active Cell and System Type ( F2 ) is set to IS-2000 for this example.
  3. Make sure that test set is in idle state.
  4. Press the More key until Call Control 2 of 5 is displayed.
  5. Press Cell Info ( F2 ) key.
  6. Press CDMA System Time/Sync Info ( F5 ) key.
  7. Press Clear Sync Indications ( F4 ) to clear the last synchronization information.
  8. Set the Ext 8960 IP Add r ( F2 ) to the same value of the LAN IP Address of the Sync Server that you have set in Step 1: Configure the Sync Server .

Step 3: Perform the synchronization between two test sets

  1. On the test set that acts as Sync Client, press the Sync To External Server ( F3 ) which initiates the synchronization.
  2. The synchronization takes 2-4 seconds. Once the synchronization successfully completes, the CDMA system time on the sync client is same as that of the sync server. Observe the CDMA System Time and Synchronization Information on both test sets, a typical display on the Sync Client and the Sync Server is shown below.

Related Topics

Multi-unit Synchronization


Session Application Type

Session Application Type

Last updated: June 16, 2006

This section is only applicable to the lab application.

NOTE
In the E1966A Test Application , the Session Application Type setting is not settable and implicitly fixed to the Test Application .

The 1x EV-DO system supports a number of different applications. Each application defines a unique set of procedures and capabilities.

The Session Application Type is a "Configurable Attribute" for the Stream Protocol. It determines which application will be configured on Stream 1 Application (0x15) during session negotiation. When a session is open, changing the Session Application Type results in a session re-negotiation (see Session Negotiate State for details).

  • When the Default Packet Application is selected, the test set is configured to the Default Packet Application (DPA) on Stream 1 Application (0x15) during session negotiation.

    The test set does not support Default Packet Application when Protocol Rel is A (1xEV-DO-A) and Release A Physical Layer Subtype is Subtype 2 . Otherwise, selection of Default Packet Application will be rejected and an error message is posted.

    The DPA as defined in the C.S0024 Air Interface Standard is an application layer protocol used in actual 1xEV-DO network. It provides Internet connectivity to access terminals for transporting real user data. See Packet Data Network Emulation in the Test Set for details.

  • When the Test Application is selected, the test set is configured to either the Test Application Protocol (TAP) or the Enhanced Test Application Protocol (ETAP). Which test application is being configured depends on the Protocol Rel and Release A Physical Layer Subtype settings as shown in the following table.

    Test Application Configuration

    When Session Application Type = Test Application

    Protocol Release

    Physical Layer Subtype

    Test Application Protocol

    0 (1xEV-DO-0)

    Subtype 0 (not settable)

    TAP

    A (1xEV-DO-A)

    Subtype 0

    TAP *

    Subtype 2

    ETAP

    Note:

    * C.S0029-A specifies that both the TAP and ETAP can operate with subtype 0 physical layer, but the test set only supports TAP operating with subtype 0 physical layer.

    The test application protocols as defined in the C.S0029 Test Application Specification (TAS) are mainly used for access terminal minimum performance tests in a factory/laboratory environment (no real user data but using test data packets).

    The C.S0029 TAS has evolved from release 0 (C.S0029-0) to release A (C.S0029-A) to support the tests as required by the new air interface protocol release A (C.S0024-A). The latest C.S0029-A TAS defines three sets of test application protocols: Test Application Protocols (TAP), Enhanced Test Application Protocols (ETAP), and Broadcast Test Application Protocol (BTAP) whereas the test set only supports TAP and ETAP. For details, see C.S0029 Test Application Specification Description (TAP/ETAP) .

    • When the TAP (0x0003) is configured on Stream 1 Application (0x15), the Test Application Protocol can be used to enable the FTAP or RTAP on a TAP data connection ( TAP/ETAP Data Connection Call Flow ).
    • When the ETAP (0x000A) is configured on Stream 1 Application (0x15), the Enhanced Test Application Protocol can be used to enable the FETAP or RETAP on an ETAP data connection ( TAP/ETAP Data Connection Call Flow ).

The Session Application Type is displayed on the Call Setup screen in the Application Configuration window in Active Cell operating mode.

Operating Considerations

  • The test set currently does not support Default Packet Application when Protocol Rel is A (1xEV-DO-A) and Release A Physical Layer Subtype is Subtype 2 . Otherwise, selection of Default Packet Application will be rejected and an error message is posted.
  • The C.S0029-A specifies that the TAP can operates with both the Subtype 0 and Subtype 2 physical layer protocols. However, the test set only supports TAP operating with subtype 0 physical layer and ETAP operating with subtype 2 physical layer. See Test Application Configuration .
  • The test set does not support Broadcast Test Application Protocol (BTAP) as defined in the C.S0029-A standard.

Related Topics

GPIB Command: CALL[:CELL]:APPLication:SESSion[:TYPE]

Manual Operation: How Do I Change Call Parameters?

Test Application Protocol

Enhanced Test Application Protocol

Packet Data Network Emulation in the Test Set

Data Channel

Protocol Rel

Release A Physical Layer Subtype

C.S0029 Test Application Specification Description (TAP/ETAP)


CALL:COUNt

CALL:COUNt

Last updated:May 24, 2006

Diagram Conventions

CALL:COUNt:CLEar:MS:IP

Function

 Clears all of the data counters for the IP (Internet Protocol) packets and bytes on both the forward and reverse channels. See Data Counters .

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:CLEar:MS:IP"
!Clears all of the IP counters.

CALL:COUNt:CLEar:MS:RLP

Function

 Clears all of the data counters for the RLP (Radio Link Protocol) control message and data octets on both the forward and reverse channels. See Data Counters .

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:CLEar:MS:RLP"
!Clears all of the RLP counters.

CALL:COUNt:CLEar:MS:TRAFfic

Function

 Clears all of the physical layer packet counters for both the forward and reverse traffic channels. These counters are displayed on the Traffic Channel Packet Info screen and Traffic Channel Packet Histogram screen. See To Clear Traffic Channel Packet Counters .

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:CLEar:MS:TRAFfic"
!Clears all traffic channel packet counters.

CALL:COUNt:CLEar:MS:TRAFfic:HISTogram

Function

 Clears all of the forward traffic packet counters displayed on the Traffic Channel Packet Histogram screen. See To Clear Traffic Channel Packet Counters .

Requirements

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"CALL:COUNt:CLEar:MS:TRAFfic:HISTogram"
!Clears all of traffic channel packet histogram counters.

CALL:COUNt:MS:DRC:RX:ATDirected?

Function

Queries the total number of forward traffic packets that were directed by the test set to the AT.

Power up, full preset, or the clear traffic counters command ( CALL:COUNt:CLEar:MS:TRAFfic ) will clear all traffic counters.

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count. See Traffic Channel Packet Info (for Subtype 0 Physical Layer) .

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:ATDirected?"
!Queries the total number of forward traffic packets
!directed by test set to AT.

CALL:COUNt:MS:DRC:RX:ATDirected?

Function

Queries the total number of forward traffic packets that were directed by the test set to the AT.

Power up, full preset, or the clear traffic counters command ( CALL:COUNt:CLEar:MS:TRAFfic ) will clear all traffic counters.

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count. See Traffic Channel Packet Info (for Subtype 0 Physical Layer) .

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:ATDirected?"
!Queries the total number of forward traffic packets
!directed by test set to AT.

CALL:COUNt:MS:DRC:RX:HISTogram[:ALL]?

Function

Queries all of the Traffic Channel Packet Histogram counters, each of which records the total number of forward traffic packets at the specific transmission format (DRC, packet size, data rate) during the last time period as specified by CALL:COUNt:MS:DRC:RX:HISTogram:SPAN .

Regardless of the physical layer subtype, this query always returns 37 comma-separated values for the forward transmission formats, in the order of:
DRC 0x1 (128, 16, 1024) [4.8 kbps], DRC 0x1 (256, 16, 1024) [9.6 kbps],
DRC 0x1 (512, 16, 1024) [19.2 kbps], DRC 0x1 (1024, 16, 1024) [38.4 kbps],
DRC 0x2 (128, 8, 512) [9.6 kbps], DRC 0x2 (256, 8, 512) [19.2 kbps],
DRC 0x2 (512, 8, 512) [38.4 kbps], DRC 0x2 (1024, 8, 512) [76.8 kbps],
DRC 0x3 (128, 4, 256) [19.2 kbps], DRC 0x3 (256, 4, 256) [38.4 kbps],
DRC 0x3 (512, 4, 256) [76.8 kbps], DRC 0x3 (1024, 4, 256) [153.6 kbps],
DRC 0x4 (128, 2, 128) [38.4 kbps], DRC 0x4 (256, 2, 128) [76.8 kbps],
DRC 0x4 (512, 2, 128) [153.6 kbps], DRC 0x4 (1024, 2, 128) [307.2 kbps],
DRC 0x5 (512,4, 128) [76.8 kbps], DRC 0x5 (1024, 4, 128) [153.6 kbps],
DRC 0x5 (2048, 4, 128) [307.2 kbps], DRC 0x6 (128, 1, 64) [76.8 kbps],
DRC 0x6 (256, 1, 64) [153.6 kbps], DRC 0x6 (512, 1, 64) [307.2 kbps],
DRC 0x6 (1024, 1, 64) [614.4 kbps], DRC 0x7 (512, 2, 64) [153.6 kbps],
DRC 0x7 (1024, 2, 64) [307.2 kbps], DRC 0x7 (2048, 2, 64) [614.4 kbps],
DRC 0x8 (1024, 2, 64) [307.2 kbps], DRC 0x8 (3072, 2, 64) [921.6 kbps],
DRC 0x9 (512, 1, 64) [307.2 kbps]), DRC 0x9 (1024, 1, 64) [614.4 kbps],
DRC 0x9 (2048, 1, 64) [1228.8 kbps], DRC 0xA (4096, 2, 64) [1228.8 kbps],
DRC 0xB (1024, 1, 64) [614.4 kbps], DRC 0xB (3072, 1, 64) [1843.2 kbps],
DRC 0xC (4096, 1, 64) [2457.6 kbp4s], DRC 0xD (5120, 2, 64) [1536.0 kbps],
DRC 0xE (5120, 1, 64) [3072.0 kbps].

When current physical layer subtype is Subtype 0, the results corresponding to those transmission formats that are only available for subtype 2 physical layer will be returned as zeroes. See FTAP Rate for details on the forward transmission formats for subtype 0 physical layer. See F-Traffic Format for details on the forward transmission formats for subtype 2 physical layer.

There are several operations to clear these Histogram counters. See To Clear Traffic Channel Packet Counters for details.

When the counter reaches its maximum value (100000000), it rolls over to zero and resumes the count.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 18000 (for each of the 37 values)

Resolution: 1

*RST Setting

0 (for each of the 37 values)

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:HISTogram?"
!Queries the forward traffic packets results
!associated with the Histogram counters.

CALL:COUNt:MS:DRC:RX:HISTogram:SPAN

Function

Sets/queries the time period over which the Traffic Channel Packet Histogram counters are recorded. The units (S|MS|US) are optional, if no units are specified then the default is S (seconds).

Changing this setting will cause all of the Traffic Channel Packet Histogram counters cleared.

Requirements

Lab Application Revision: A.03 and above

Setting

Range: 1 to 30 second

Resolution: 1

Query

 Same as setting

*RST Setting

5 seconds

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:HISTogram:SPAN 10"
!Sets the Histogram time span to 10 seconds.

CALL:COUNt:MS:DRC:RX:S16Bps4800:DRC01?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x1 (128, 16, 1024) at a rate of 4.8 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S16Bps4800:DRC01?"
!Queries the number of forward traffic packets with
!the transmission format DRC 0x1 (128, 16, 1024) [4.8 kbps].

CALL:COUNt:MS:DRC:RX:S16Bps9600:DRC01?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x1 (256, 16, 1024) at a rate of 9.6 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S16Bps9600:DRC01?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x1 (256, 16, 1024) [9.6 kbps].

CALL:COUNt:MS:DRC:RX:S16Bps19200:DRC01?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x1 (512, 16, 1024) at a rate of 19.2 kbps. It is only available for the subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S16Bps19200:DRC01?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x1 (512, 16, 1024) [19.2 kbps].

CALL:COUNt:MS:DRC:RX:S16Bps38400[:DRC01]?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x1 (1024, 16, 1024) at a rate of 38.4 kbps. It is available for both subtype 0 and subtype 2 physical layers. For details on the forward transmission format, see FTAP Rate and F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S16Bps38400?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x1 (1024, 16, 1024) [38.4 kbps].

CALL:COUNt:MS:DRC:RX:S08Bps9600:DRC02?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x2 (128, 8, 512) at a rate of 9.6 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S08Bps9600:DRC02?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x2 (128, 8, 512) [9.6 kbps].

CALL:COUNt:MS:DRC:RX:S08Bps19200:DRC02?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x2 (256, 8, 512) at a rate of 19.2 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S08Bps19200:DRC02?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x2 (256, 8, 512) [19.2 kbps].

CALL:COUNt:MS:DRC:RX:S08Bps38400:DRC02?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x2 (512, 8, 512) at a rate of 38.4 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S08Bps38400:DRC02?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x2 (512, 8, 512) [38.4 kbps].

CALL:COUNt:MS:DRC:RX:S08Bps76800[:DRC02]?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x2 (1024, 8, 512) at a rate of 76.8 kbps. It is available for both subtype 0 and subtype 2 physical layers. For details on the forward transmission format, see FTAP Rate and F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S08Bps76800?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x2 (1024, 8, 512) [76.8 kbps].

CALL:COUNt:MS:DRC:RX:S04Bps19200:DRC03?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x3 (128, 4, 256) at a rate of 19.2 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S04Bps19200:DRC03?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x3 (128, 4, 256) [19.2 kbps].

CALL:COUNt:MS:DRC:RX:S04Bps38400:DRC03?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x3 (256, 4, 256) at a rate of 38.4 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S04Bps38400:DRC03?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x3 (256, 4, 256) [38.4 kbps].

CALL:COUNt:MS:DRC:RX:S04Bps76800:DRC03?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x3 (512, 4, 256) at a rate of 76.8 kbps. It is available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S04Bps76800:DRC03?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x3 (512, 4, 256) [76.8 kbps].

CALL:COUNt:MS:DRC:RX:S04Bps153600[:DRC03]?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x3 (1024, 4, 256) at a rate of 153.6 kbps. It is available for both subtype 0 and subtype 2 physical layers. For details on the forward transmission format, see FTAP Rate and F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S04Bps153600?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x3 (1024, 4, 256) [153.6 kbps].

CALL:COUNt:MS:DRC:RX:S02Bps38400:DRC04?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x4 (128, 2, 128) at a rate of 38.4 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S02Bps38400:DRC04?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x4 (128, 2, 128) [38.4 kbps].

CALL:COUNt:MS:DRC:RX:S02Bps76800:DRC04?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x4 (256, 2, 128) at a rate of 76.8 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S02Bps76800:DRC04?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x4 (256, 2, 128) [76.8 kbps].

CALL:COUNt:MS:DRC:RX:S02Bps153600:DRC04?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x4 (512, 2, 128) at a rate of 153.6 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S02Bps153600:DRC04?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x4 (512, 2, 128) [153.6 kbps].

CALL:COUNt:MS:DRC:RX:S02Bps307200[:DRC04]?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x4 (1024, 2, 128) at a rate of 307.2 kbps. It is available for both subtype 0 and subtype 2 physical layers. For details on the forward transmission format, see FTAP Rate and F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S02Bps307200?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x4 (1024, 2, 128) [307.2 kbps].

CALL:COUNt:MS:DRC:RX:S04Bps76800:DRC05?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x5 (512, 4, 128) at a rate of 76.8 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S04Bps76800:DRC05?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x5 (512, 4, 128) [76.8 kbps].

CALL:COUNt:MS:DRC:RX:S04Bps153600:DRC05?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x5 (1024, 4, 128) at a rate of 153.6 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S04Bps153600:DRC05?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x5 (1024, 4, 128) [153.6 kbps].

CALL:COUNt:MS:DRC:RX:S04Bps307200[:DRC05]?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x5 (2048, 4, 128) at a rate of 307.2 kbps. It is available for both subtype 0 and subtype 2 physical layers. For details on the forward transmission format, see FTAP Rate and F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S04Bps307200?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x5 (2048, 4, 128) [307.2 kbps].

CALL:COUNt:MS:DRC:RX:S01Bps76800:DRC06?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x6 (128, 1, 64) at a rate of 76.8 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S01Bps76800:DRC06?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x6 (128, 1, 64) [76.8 kbps].

CALL:COUNt:MS:DRC:RX:S01Bps153600:DRC06?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x6 (256, 1, 64) at a rate of 153.6 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S01Bps153600:DRC06?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x6 (256, 1, 64) [153.6 kbps].

CALL:COUNt:MS:DRC:RX:S01Bps307200:DRC06?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x6 (512, 1, 64) at a rate of 307.2 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S01Bps307200:DRC06?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x6 (512, 1, 64) [307.2 kbps].

CALL:COUNt:MS:DRC:RX:S01Bps614400[:DRC06]?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x6 (1024, 1, 64) at a rate of 614.4 kbps. It is available for both subtype 0 and subtype 2 physical layers. For details on the forward transmission format, see FTAP Rate and F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S01Bps614400?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x6 (1024, 1, 64) [614.4 kbps].

CALL:COUNt:MS:DRC:RX:S02Bps153600:DRC07?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x7 (512, 2, 64) at a rate of 153.6 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S02Bps153600:DRC07?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x7 (512, 2, 64) [153.6 kbps].

CALL:COUNt:MS:DRC:RX:S02Bps307200:DRC07?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x7 (1024, 2, 64) at a rate of 307.2 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S02Bps307200:DRC07?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x7 (1024, 2, 64) [307.2 kbps].

CALL:COUNt:MS:DRC:RX:S02Bps614400[:DRC07]?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x7 (2048, 2, 64) at a rate of 614.4 kbps. It is available for both subtype 0 and subtype 2 physical layers. For details on the forward transmission format, see FTAP Rate and F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S02Bps614400?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x7 (2048, 2, 64) [614.4 kbps].

CALL:COUNt:MS:DRC:RX:S02Bps307200:DRC08?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x8 (1024, 2, 64) at a rate of 307.2 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S02Bps307200:DRC08?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x8 (1024, 2, 64) [307.2 kbps].

CALL:COUNt:MS:DRC:RX:S02Bps921600[:DRC08]?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x8 (3072, 2, 64) at a rate of 921.6 kbps. It is available for both subtype 0 and subtype 2 physical layers. For details on the forward transmission format, see FTAP Rate and F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S02Bps921600?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x8 (3072, 2, 64) [921.6 kbps].

CALL:COUNt:MS:DRC:RX:S01Bps307200:DRC09?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x9 (512, 1, 64) at a rate of 307.2 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S01Bps307200:DRC09?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x9 (512, 1, 64) [307.2 kbps].

CALL:COUNt:MS:DRC:RX:S01Bps614400:DRC09?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x9 (1024, 1, 64) at a rate of 614.4 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S01Bps614400:DRC09?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x9 (1024, 1, 64) [614.4 kbps].

CALL:COUNt:MS:DRC:RX:S01Kbps1229[:DRC09]?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x9 (2048, 1, 64) at a rate of 1228.8 kbps. It is available for both subtype 0 and subtype 2 physical layers. For details on the forward transmission format, see FTAP Rate and F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S01Kbps1229?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x9 (2048, 1, 64) [1228.8 kbps].

CALL:COUNt:MS:DRC:RX:S02Kbps1229[:DRC10]?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x10 (4096, 2, 64) at a rate of 1228.8 kbps. It is available for both subtype 0 and subtype 2 physical layers. For details on the forward transmission format, see FTAP Rate and F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S02Kbps1229?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x10 (4096, 2, 64) [1228.8 kbps].

CALL:COUNt:MS:DRC:RX:S01Bps614400:DRC11?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x11 (1024, 1, 64) at a rate of 614.4 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S01Bps614400:DRC11?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x11 (1024, 1, 64) [614.4 kbps].

CALL:COUNt:MS:DRC:RX:S01Kbps1843[:DRC11]?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x11 (3072, 1, 64) at a rate of 1843.2 kbps. It is available for both subtype 0 and subtype 2 physical layers. For details on the forward transmission format, see FTAP Rate and F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S01Kbps1843?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x11 (3072, 1, 64) [1843.2 kbps].

CALL:COUNt:MS:DRC:RX:S01Kbps2458[:DRC12]?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x12 (4096, 1, 64) at a rate of 2457.6 kbps. It is available for both subtype 0 and subtype 2 physical layers. For details on the forward transmission format, see FTAP Rate and F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S01Kbps2458?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x12 (4096, 1, 64) [2457.6 kbps].

CALL:COUNt:MS:DRC:RX:S02Kbps1536[:DRC13]?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x13 (5120, 2, 64) at a rate of 1536.0 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S02Kbps1536?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x13 (5120, 2, 64) [1536.0 kbps].

CALL:COUNt:MS:DRC:RX:S01Kbps3072[:DRC14]?

Function

Queries the total number of forward traffic packets transmitted by the test set to the AT with the transmission format DRC 0x14 (5120, 1, 64) at a rate of 3072.0 kbps. It is only available for subtype 2 physical layer. For details on the forward transmission format, see F-Traffic Format .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:DRC:RX:S01Kbps3072?"
!Queries the number of forward traffic packets with
!transmission format DRC 0x14 (5120, 1, 64) [3072.0 kbps].

CALL:COUNt:MS:IP[:ALL]?

Function

Queries the number of IP (Internet Protocol) packets and bytes transferred between the test set and the AT on both the forward and reverse channels. Results are returned in the order of <forward packets>, <forward bytes>, <reverse packets>, <reverse bytes>.

Power up, full preset, or the clear counters command ( CALL:COUNt:CLEar:MS:IP ) will clear these IP counters.

When IP counters reach their maximum value (9,999,999,999), they remain at that value until cleared. See Data Counters .

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP?"
!Queries the count of IP packet and IP byte
!on both the forward and reverse channels

CALL:COUNt:MS:IP:RX?

Function

Queries the number of IP (Internet Protocol) packets and bytes received by the AT from the test set on the forward channel. Results are returned in the order of <packets>, <bytes>.

Power up, full preset, or the clear counters command ( CALL:COUNt:CLEar:MS:IP ) will clear these IP counters.

When IP counters reach their maximum value (9,999,999,999), they remain at that value until cleared. See Data Counters .

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP:RX?"
!Queries the IP packet and byte count on the forward channel.

CALL:COUNt:MS:IP:TX?

Function

Queries the number of IP (Internet Protocol) packets and bytes received by the test set from the AT on the reverse channel. Results are returned in the order of <packets>, <bytes>.

Power up, full preset, or the clear counters command ( CALL:COUNt:CLEar:MS:IP ) will clear these IP counters.

When IP counters reach their maximum value (9,999,999,999), they remain at that value until cleared. See Data Counters .

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP:TX?"
!Queries the IP packet and byte count on the reverse channel.

CALL:COUNt:MS:PPRate:TX:BPS4800[:BIT128]?

Function

Queries the total number of reverse traffic packets received by the test set from the AT with the packet size 128 bits at a rate of 4.8 kbps.It is only available for subtype 2 physical layer. For details on the reverse packet data rate, see R-Data Pkt Size .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:PPRate:TX:BPS4800?"
!Queries the number of reverse traffic packets with
!packet size 128 bits at 4.8 kbps.

CALL:COUNt:MS:PPRate:TX:BPS9600[:BIT256]?

Function

Queries the total number of reverse traffic packets received by the test set from the AT with the packet size 256 bits at a rate of 9.6 kbps.It is available for both the subtype 0 and subtype 2 physical layers. For details on the reverse packet data rate, see RTAP Rate and R-Data Pkt Size .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:PPRate:TX:BPS9600?"
!Queries the number of reverse traffic packets
!with packet size 256 bits at 9.6kbps.

CALL:COUNt:MS:PPRate:TX:BPS19200[:BIT512]?

Function

Queries the total number of reverse traffic packets received by the test set from the AT with the packet size 512 bits at a rate of 19.2 kbps.It is available for both the subtype 0 and subtype 2 physical layers. For details on the reverse packet data rate, see RTAP Rate and R-Data Pkt Size .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:PPRate:TX:BPS19200?"
!Queries the number of reverse traffic packets
!with packet size 512 bits at 19.2kbps.

CALL:COUNt:MS:PPRate:TX:BPS28800[:BIT768]?

Function

Queries the total number of reverse traffic packets received by the test set from the AT with the packet size 768 bits at a rate of 28.8 kbps.It is only available for subtype 2 physical layer. For details on the reverse packet data rate, see R-Data Pkt Size .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:PPRate:TX:BPS28800?"
!Queries the number of reverse traffic packets with
!packet size 768 bits at 28.8 kbps.

CALL:COUNt:MS:PPRate:TX:BPS38400[:BIT1024]?

Function

Queries the total number of reverse traffic packets received by the test set from the AT with the packet size 1024 bits at a rate of 38.4 kbps.It is available for both the subtype 0 and subtype 2 physical layers. For details on the reverse packet data rate, see RTAP Rate and R-Data Pkt Size .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:PPRate:TX:BPS38400?"
!Queries the number of reverse traffic packets
!with packet size 1024 bits at 38.4kbps.

CALL:COUNt:MS:PPRate:TX:BPS57600[:BIT1536]?

Function

Queries the total number of reverse traffic packets received by the test set from the AT with the packet size 1536 bits at a rate of 57.6 kbps.It is only available for subtype 2 physical layer. For details on the reverse packet data rate, see R-Data Pkt Size .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:PPRate:TX:BPS57600?"
!Queries the number of reverse traffic packets with
!packet size 1536 bits at 57.6kbps.

CALL:COUNt:MS:PPRate:TX:BPS76800[:BIT2048]?

Function

Queries the total number of reverse traffic packets received by the test set from the AT with the packet size 2048 bits at a rate of 76.8 kbps.It is available for both the subtype 0 and subtype 2 physical layers. For details on the reverse packet data rate, see RTAP Rate and R-Data Pkt Size .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:PPRate:TX:BPS76800?"
!Queries the number of reverse traffic packets
!with packet size 2048 bits at 76.8kbps.

CALL:COUNt:MS:PPRate:TX:BPS115200[:BIT3072]?

Function

Queries the total number of reverse traffic packets received by the test set from the AT with the packet size 3072 bits at a rate of 115.2 kbps.It is only available for subtype 2 physical layer. For details on the reverse packet data rate, see R-Data Pkt Size .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:PPRate:TX:BPS115200?"
!Queries the number of reverse traffic packets with
!packet size 3072 bits at 115.2 kbps.

CALL:COUNt:MS:PPRate:TX:BPS153600[:BIT4096]?

Function

Queries the total number of reverse traffic packets received by the test set from the AT with the packet size 4096 bits at a rate of 153.6 kbps.It is available for both the subtype 0 and subtype 2 physical layers. For details on the reverse packet data rate, see RTAP Rate and R-Data Pkt Size .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:PPRate:TX:BPS153600?"
!Queries the number of reverse traffic packets
!with packet size 4096 bits at 153.6 kbps.

CALL:COUNt:MS:PPRate:TX:BPS230400[:BIT6144]?

Function

Queries the total number of reverse traffic packets received by the test set from the AT with the packet size 6144 bits at a rate of 230.4 kbps.It is only available for subtype 2 physical layer. For details on the reverse packet data rate, see R-Data Pkt Size .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:PPRate:TX:BPS230400?"
!Queries the number of reverse traffic packets with
!packet size 6144 bits at 230.4 kbps.

CALL:COUNt:MS:PPRate:TX:BPS307200[:BIT8192]?

Function

Queries the total number of reverse traffic packets received by the test set from the AT with the packet size 8192 bits at a rate of 307.2 kbps.It is only available for subtype 2 physical layer. For details on the reverse packet data rate, see R-Data Pkt Size .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:PPRate:TX:BPS307200?"
!Queries the number of reverse traffic packets with
!packet size 8192 bits at 307.2 kbps.

CALL:COUNt:MS:PPRate:TX:BPS460800[:BIT12288]?

Function

Queries the total number of reverse traffic packets received by the test set from the AT with the packet size 12288 bits at a rate of 460.8 kbps.It is only available for subtype 2 physical layer. For details on the reverse packet data rate, see R-Data Pkt Size .

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.03 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:PPRate:TX:BPS460800?"
!Queries the number of reverse traffic packets with
!packet size 12288 bits at 460.8 kbps.

CALL:COUNt:MS:PPRate:TX:BPSNull[:BITNull]?

Function

Queries the number of null packets (does not contain traffic data) received by the test set from the AT. It is available for both the subtype 0 and subtype 2 physical layers.

When the counter reaches its maximum value (100,000,000), it rolls over to zero and resumes the count.

There are several operations to clear the counter. See To Clear Traffic Channel Packet Counters for details.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 100000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:PPRate:TX:BPSNull?"
!Queries the number of frames that did not have
!a reverse traffic packet reveived by test set.

CALL:COUNt:MS:RLP:RX[:TOTal]:PACKets?

Function

Queries the total number of RLP packets received by the AT from the test set on the forward channel. It includes both the new and retransmitted octets.

Power up, full preset, or the clear RLP counters command ( CALL:COUNt:CLEar:MS:RLP ) will clear all RLP counters.

When RLP counters reach their maximum value (10,000,000,000), they automatically reset to zero and resume the count. See Data Counters .

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 10000000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX:PACKets?"
!Queries the total number of RLP packets
!received by AT on forward channel.

CALL:COUNt:MS:RLP:RX:DATA:NEW2?

Function

Queries the number of new RLP octets received by the AT from the test set on the forward channel.

Power up, full preset, or the clear RLP counters command ( CALL:COUNt:CLEar:MS:RLP ) will clear all RLP counters.

When RLP counters reach their maximum value (10,000,000,000), they automatically reset to zero and resume the count. See Data Counters .

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 10000000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX:DATA:NEW2?"
!Queries the number of new RLP octets
!received by AT on forward channel.

CALL:COUNt:MS:RLP:RX:DATA:REXMitted2?

Function

Queries the number of retransmitted RLP octets received by the AT from the test set on the forward channel.

Power up, full preset, or the clear RLP counters command ( CALL:COUNt:CLEar:MS:RLP ) will clear all RLP counters.

When RLP counters reach their maximum value (10,000,000,000), they automatically reset to zero and resume the count. See Data Counters .

Query

Range: 0 to 10000000000, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX:DATA:REXMitted2?"
!Queries the number of retransmitted RLP octets
!received by AT on forward channel.

CALL:COUNt:MS:RLP:RX:NAK?

Function

Queries the number of RLP NAK messages received by the AT from the test set on the forward channel.

Power up, full preset, or the clear RLP counters command ( CALL:COUNt:CLEar:MS:RLP ) will clear all RLP counters.

When RLP counters reach their maximum value (10,000,000,000), they automatically reset to zero and resume the count. See Data Counters .

Query

Range: 0 to 10000000000, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX:NAK?"
!Queries the number of RLP NAK messages
!received by AT on forward channel.

CALL:COUNt:MS:RLP:RX:NAKKed2?

Function

Queries the total number of NAKKed octets requested in all NAK message received by the AT from the test set on the forward channel.

Power up, full preset, or the clear RLP counters command ( CALL:COUNt:CLEar:MS:RLP ) will clear all RLP counters.

When RLP counters reach their maximum value (10,000,000,000), they automatically reset to zero and resume the count. See Data Counters .

Query

Range: 0 to 10000000000, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX:NAKKed2?"
!Queries the number of NAKKed RLP octets requested in a
!NAK message received by AT on forward channel.

CALL:COUNt:MS:RLP:RX:RESet?

Function

Queries the number of RLP Reset messages received by the AT from the test set on the forward channel.

Power up, full preset, or the clear RLP counters command ( CALL:COUNt:CLEar:MS:RLP ) will clear all RLP counters.

When RLP counters reach their maximum value (10,000,000,000), they automatically reset to zero and resume the count. See Data Counters .

Query

Range: 0 to 10000000000, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX:RESet?"
!Queries the number of RLP Reset messages
!received by AT on forward channel.

CALL:COUNt:MS:RLP:TX[:TOTal]:PACKets?

Function

Queries the total number of RLP packets sent from the AT to the test set on the reverse channel. It includes both the new and retransmitted octets.

Power up, full preset, or the clear RLP counters command ( CALL:COUNt:CLEar:MS:RLP ) will clear all RLP counters.

When RLP counters reach their maximum value (10,000,000,000), they automatically reset to zero and resume the count. See Data Counters .

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 10000000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX:PACKets?"
!Queries the total number of RLP packets
!received by test set on reverse channel.

CALL:COUNt:MS:RLP:TX:DATA:NEW2?

Function

Queries the number of new RLP octets sent from the AT to the test set on the reverse channel.

Power up, full preset, or the clear RLP counters command ( CALL:COUNt:CLEar:MS:RLP ) will clear all RLP counters.

When RLP counters reach their maximum value (10,000,000,000), they automatically reset to zero and resume the count. See Data Counters .

Requirements

Lab Application Revision: A.01 and above

Query

Range: 0 to 10000000000, 9.91 E+37

Resolution: 1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX:DATA:NEW2?"
!Queries the number of new RLP octets
!received by test set on reverse channel.

CALL:COUNt:MS:RLP:TX:DATA:REXMitted2?

Function

Queries the number of retransmitted RLP octets sent from the AT to the test set on the reverse channel.

Power up, full preset, or the clear RLP counters command ( CALL:COUNt:CLEar:MS:RLP ) will clear all RLP counters.

When RLP counters reach their maximum value (10,000,000,000), they automatically reset to zero and resume the count. See Data Counters .

Query

Range: 0 to 10000000000, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX:DATA:REXMitted2?"
!Queries the number of retransmitted RLP octets
!received by test set on reverse channel.

CALL:COUNt:MS:RLP:TX:NAK?

Function

Queries the number of RLP NAK messages sent from the AT to the test set on the reverse channel.

Power up, full preset, or the clear RLP counters command ( CALL:COUNt:CLEar:MS:RLP ) will clear all RLP counters.

When RLP counters reach their maximum value (10,000,000,000), they automatically reset to zero and resume the count. See Data Counters .

Query

Range: 0 to 10000000000, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX:NAK?"
!Queries the number of RLP NAK messages
!received by test set on reverse channel.

CALL:COUNt:MS:RLP:TX:NAKKed2?

Function

Queries the total number of NAKked octets requested in all NAK message sent from the AT to the test set on the reverse channel.

Power up, full preset, or the clear RLP counters command ( CALL:COUNt:CLEar:MS:RLP ) will clear all RLP counters.

When RLP counters reach their maximum value (10,000,000,000), they automatically reset to zero and resume the count. See Data Counters .

Query

Range: 0 to 10000000000, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX:NAKKed2?"
!Queries the number of NAKKed RLP octets requested in a
!NAK message received by test set on reverse channel.

CALL:COUNt:MS:RLP:TX:RESet?

Function

Queries the number of RLP Reset messages sent from the AT to the test set on the reverse channel.

Power up, full preset, or the clear RLP counters command ( CALL:COUNt:CLEar:MS:RLP ) will clear all RLP counters.

When RLP counters reach their maximum value (10,000,000,000), they automatically reset to zero and resume the count. See Data Counters .

Query

Range: 0 to 10000000000, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX:RESet?"
!Queries the number of RLP Reset messages
!received by test set on reverse channel.


CALL:COUNt:DTMonitor

CALL:COUNt:DTMonitor

Last updated:April 21, 2005

Diagram Conventions

CALL:COUNt:DTMonitor:CLEar

Function

This command clears all traces from the data throughput monitor display and resets the numeric summary table values to zero.

Requirements

 Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:CLEar"
!Clears all Data Throughput Monitor results.

CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe:STARt

CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe:STOP

Function

These commands set the data rate range (y-axis) for the data throughput monitor graphical display.

Setting

Start Range: 0 to 4999 kbps
Stop Range: 1 to 5000 kbps

Query

Start Range: 0 to 4999 kbps
Stop Range: 1 to 5000 kbps
*RST Setting

Start: 0 kbps
Stop: 100 kbps

Requirements

 Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:DISPlay:DRATe:STARt 10"
!Sets the data throughput monitor range to start at 10 kbps.

OUTPUT 714;"CALL:COUNt:DTMonitor:DISPlay:DRATe:STOP 50"
!Sets the data throughput monitor range to stop at 50 kbps.

CALL:COUNt:DTMonitor[:ALL]:DISPlay:SPAN:TIME

Function

This command sets the time span (x-axis) for the data throughput monitor graphical display.

Setting

Range: 5 to 600 seconds

Query

Range: 5 to 600 seconds
*RST Setting 600 seconds

Requirements

 Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:DISPlay:SPAN:TIME 100"
!Sets the data throughput monitor time span to 100 seconds.

CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory:UNUMber?

Function

This query returns the number of 10-minute trace data collection periods since the last time the monitor was enabled or cleared.

Query

Range: 0 to 2,147,483,647 10-minute periods, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: A.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:TRACe:HISTory:UNUMber?"
!Queries the number of 10-minute collection periods.

CALL:COUNt:DTMonitor:OTATx:DISPlay:STATe

CALL:COUNt:DTMonitor:OTARx:DISPlay:STATe

CALL:COUNt:DTMonitor:IPTX:DISPlay:STATe

CALL:COUNt:DTMonitor:IPRX:DISPlay:STATe

Function

These commands set/query which data throughput traces are displayed.

Setting

Range: 1|ON|0|OFF
*RST Setting

OTA Tx - ON

OTA Rx - ON

IP Tx - OFF

IP RX - OFF

Requirements

 Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:IPTX:DISPlay:STATe ON"
!Turns the IP TX display On.

OUTPUT 714;"CALL:COUNt:DTMonitor:IPRX:DISPlay:STATe ON"
!Turns the IP RX display On.

OUTPUT 714;"CALL:COUNt:DTMonitor:OTATx:DISPlay:STATe OFF"
!Turns the OTA TX display state Off.

OUTPUT 714;"CALL:COUNt:DTMonitor:OTARx:DISPlay:STATe ON"
!Turns the OTA RX display state Off.

CALL:COUNt:DTMonitor:OTATx:DRATe?

CALL:COUNt:DTMonitor:OTARx:DRATe?

CALL:COUNt:DTMonitor:IPTX:DRATe?

CALL:COUNt:DTMonitor:IPRX:DRATe?

Function

These query commands return the summary table values (except for Marker) for any of the four traces:

  • OTA Tx
  • OTA Rx
  • IP Tx
  • IP Rx

The query results for each trace will be returned in a comma-separated string with values in the following order:

  • Average data throughput (bps)
  • Current data throughput (bps)
  • Peak data throughput (bps)
  • Total data transfer (bytes)

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: A.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTATx:DRATe?
!Queries OTA Tx summary

OUTPUT 714;"CALL:COUNt:DTMonitor:OTARx:DRATe?
!Queries OTA Rx summary

OUTPUT 714;"CALL:COUNt:DTMonitor:IPTX:DRATe?
!Queries IP Tx summary

OUTPUT 714;"CALL:COUNt:DTMonitor:IPRX:DRATe?
!Queries IP Rx summary

CALL:COUNt:DTMonitor:OTATx:TRACe?

CALL:COUNt:DTMonitor:OTARx:TRACe?

CALL:COUNt:DTMonitor:IPTX:TRACe?

CALL:COUNt:DTMonitor:IPRX:TRACe?

Function

These query commands return the trace data values for any of the four traces:

  • OTA Tx
  • OTA Rx
  • IP Tx
  • IP Rx

The query results for each trace will be returned in a 600 comma-separated trace values for spreadsheet plotting. These values represent the most recent 10 minute trace data collection period.

NOTE
If the graph is frozen (see Accessing the Monitor Controls ), this command will not return values representative of the graph. If you would like to see the graph this command will return values for, resume the graph then query the trace values.

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: A.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTATx:TRACe?"
!Queries OTA Tx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:OTARx:TRACe?"
!Queries OTA Rx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:IPTX:TRACe?"
!Queries IP Tx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:IPRX:TRACe?"
!Queries IP Rx trace data values.

CALL:COUNt:DTMonitor:OTATx:TRACe:HISTory?

CALL:COUNt:DTMonitor:OTARx:TRACe:HISTory?

CALL:COUNt:DTMonitor:IPTX:TRACe:HISTory?

CALL:COUNt:DTMonitor:IPRX:TRACe:HISTory?

Function

These query commands return the trace data values for any of the four traces:

  • OTA Tx

  • OTA Rx

  • IP Tx

  • IP Rx

The query results for each trace will be returned in a 600 comma-separated trace values for the last 10-minute trace data collection period captured since the data throughput monitor was enabled or cleared. To find out how many 10-minute periods have elapsed, see CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory:UNUMber?

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: A.01 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTATx:TRACe:HISTory?"
!Queries OTA Tx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:OTARx:TRACe:HISTory?"
!Queries OTA Rx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:IPTX:TRACe:HISTory?"
!Queries IP Tx trace data values.

OUTPUT 714;"CALL:COUNt:DTMonitor:IPRX:TRACe:HISTory?"
!Queries IP Rx trace data values.


CALL:DATA

CALL:DATA

Last updated: November 22, 2005

Diagram Conventions

CALL:DATA:PING[:ALL]?

Function

This command returns the following results: packets transmitted, packets received, percent packets lost, minimum round trip time (in seconds), average round trip time (in seconds), maximum round trip time (in seconds).

This command will return 9.91 E+37 if the ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:ALL?"
ENTER 714;Pxmit,Prcvd,Plost,Min_time,Avg_time,Max_time

CALL:DATA:PING:ICOunt?

Function

This command queries the value that is available when the query is received.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:ICOUNT?"

CALL:DATA:PING:PACKets:RX?

Function

This command queries the number of packets received from the device being tested or from the alternate device if CALL:DATA:PING:SETup:DEVice is set to ALTernate.

This command will return 9.91 E+37 if the ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:PACKETS:RX?"
!Queries the number of packets received from the device being tested.

CALL:DATA:PING:PACKets:TX?

Function

This queries the number of packets transmitted from the test set.

This command will return 9.91 E+37 if the ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:PACKETS:TX?"
!Queries the number of packets transmitted from the test set.

CALL:DATA:PING:PLOSs?

Function

This command queries the percentage of packets lost during the ping session.

This command will return 9.91 E+37 if the ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:PLOSS?" !Queries the percentage of lost packets.

CALL:DATA:PING:SETup:ALTernate:IP:ADDRess

Function

This sets/queries the alternate internet protocol (IP) address. This address will be used as the address to ping instead of the device under test if the CALL:DATA:PING:SETup:DEVice command is set to ALT.

Setting

Range: IP v4 address in dotted decimal format.

Query

Same as setting.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:ALTERNATE:IP:ADDRESS `192.168.16.57'"

CALL:DATA:PING:SETup:COUNt

Function

This command set/queries the number of ping IP messages sent for each uninterrupted invocation of the CALL:DATA:PING:STARt command.

Setting

Range: 1 to 1000

Query

Range: 1 to 1000
Requirements Lab Application Revision: A.01 and above

*RST Setting

 10

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:COUNT 20"

CALL:DATA:PING:SETup:DEVice

Function

This command sets/queries which device address is used in the ping IP packets, the address of the device under test, or the address of an alternate device.

Setting

Range: DUT|ALTernate

Query

Range: DUT|ALT
Requirements Lab Application Revision: A.01 and above

*RST Setting

 DUT

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:DEVice ALT"

CALL:DATA:PING:SETup:TIMeout

Function

This command sets or queries how long the test set will wait before ending a ping session.

This command will return 9.91 E+37 if the ping results are not available.

Setting

Range: 1 to 100 seconds

Query

Range: 1 to 100 seconds
Requirements Lab Application Revision: A.01 and above

*RST Setting

 5 seconds

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:TIMEOUT 10"

CALL:DATA:PING:STARt

Function

This command starts a ping session.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:START"

CALL:DATA:PING:STOP

Function

This command immediately stops a ping session. The ping results will not include counts for any ping message that has not yet received a response.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:STOP"

CALL:DATA:PING:TIME[:AVERage]?

Function

This command queries the average round trip time (in seconds) for a series of pings.

This command will return 9.91 E+37 if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:TIME:AVERAGE?"

CALL:DATA:PING:TIME:MAXimum?

Function

This command queries the maximum round trip time (in seconds) for a series of pings.

This command will return 9.91 E+37 if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:TIME:MAXIMUM?"

CALL:DATA:PING:TIME:MINimum?

Function

This command queries the minimum round trip time (in seconds).

This command will return 9.91 E+37 if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:TIME:MINIMUM?"

CALL:DATA:PDSNode:EXTernal:IP:ADDRess

Function

Sets/queries the IP address of external PDSN (MOB-IP-SIM). It will not take effect until the CALL:DATA:PDSNode:EXTernal:STATe is set to ON. See External PDSN IP Address for details.

This setting is stored in the nonvolatile RAM, and will not be changed by a reset or cycling power of the test set.

Setting

Range: 15 characters formatted as follows: A.B.C.D or "" (empty string)
The range of values for A = 0 to 126 and 128 to 223. The range of values for B,C, D = 0 to 255 (no embedded spaces).
("0.0.0.0", "0" or "" (an empty string) will set the external PDSN IP address to be undefined)

Query

Range: same as setting

*RST Setting
  • "" (empty string when shipped from the factory)
  • the value last set and stored in the nonvolatile RAM

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PDSNode:EXTernal:IP:ADDRess '130.29.179.220'"
!Sets the External PDSN IP Address to 130.29.179.220.

CALL:DATA:PDSNode:EXTernal:STATe

Function

Sets/queries whether to use the external PDSN simulator (MOB-IP-SIM) or the test set's internal PDSN simulation.

  • On - indicates using external PDSN simulator (MOB-IP-SIM)
  • Off - indicates using test set's internal PDSN

You must specify a valid IP address ( CALL:DATA:PDSNode:EXTernal:IP:ADDRess ) and a valid TCP port ( CALL:DATA:PDSNode:EXTernal:TCP:PORT ) for the external PDSN (MOB-IP-SIM) before changing the external PDSN state to on. See External PDSN State for details.

Setting

Range: 1|ON|0|OFF

Query

same as setting

*RST Setting

 0 (OFF)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PDSNode:EXTernal:STATe ON"
!Sets to use the External PDSN.

CALL:DATA:PDSNode:EXTernal:TCP:PORT

Function

Sets/queries the TCP port of the external PDSN (MOB-IP-SIM). It will not take effect until the CALL:DATA:PDSNode:EXTernal:STATe is set to ON. See External PDSN TCP Port .

This setting is stored in nonvolatile RAM, and will not be changed by a reset or cycling power of the test set.

Setting

Range: 0 to 65535
Resolution: 1

Query

Range: same as setting

*RST Setting
  • 53613 (when shipped from the factory)
  • the value last set and stored in the nonvolatile RAM

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PDSNode:EXTernal:TCP:PORT 53613"
!Sets the External PDSN TCP port to 53613.

CALL:DATA:PDSNode:EXTernal:TIMeout[:CONNect]

Function

Sets/queries the maximum amount of time the test set will wait to connect to the external PDSN (MOB-IP-SIM). It will not take effect until the CALL:DATA:PDSNode:EXTernal:STATe is set to ON. See External PDSN Connect Timeout for details.

This setting is stored in nonvolatile RAM, and will not be changed by a reset or cycling power of the test set.

Setting

Range: 1 to 19 seconds
Resolution: 1 second

Query

Range: same as setting

*RST Setting
  • 2 (when shipped from the factory)
  • the value last set and stored in the nonvolatile RAM

Requirements

Lab Application Revision: A.01 and above
Lab Application Revision: A.02.10 and above, value range changed from 0 - 19 seconds to 1 - 19 seconds.

Programming Example

OUTPUT 714;"CALL:DATA:PDSNode:EXTernal:TIMeout 10S"
!Sets the External PDSN timeout to 10 seconds.


CALL:DORMant

CALL:DORMant

Last updated: April 14, 2005

Diagram Conventions

CALL:DORMant[:STATe]?

Function

This command queries whether or not the data connection is in the dormant state (see Dormant State for a description of this data connection state).

When the query is sent:

  • If the data connection is in the dormant state, the query immediately returns a 1.
  • If the data connection is in any other non-transitory state, the query immediately returns a 0 (see Packet Data Connection Processing States Lifecycle for information about which states are transitory and non-transitory).
  • If the data connection is in a transitory state, the query waits until the data connection reaches a non-transitory state, and then returns a 1 if the state is dormant or a 0 if the state is any other non-transitory state.

NOTE
The query will hang as long as the data connection is in a transitory state. However, the AT includes protocol timers which limit the time it may stay in a transitory state. So, the AT should force the connection to return to a non-transitory state after its protocol timers expire, and so the query will not hang forever.

The query behaves differently if the data connection state change detector is armed, see Data Connection State Change Detector .

Using the CALL:DORMant? query in conjunction with the data connection state change detector is useful in determining whether an attempt to force a connection to dormant has been successful.

Requirements

Lab Application Revision: A.01 and above

Query

Range: 1|0

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:DORMant:STATe?"
!Queries whether the packet data connection is in dormant state.


CALL:PLOGging

CALL:PLOGging

Last updated: April 15, 2005

Diagram Conventions

CALL:PLOGging:STARt

Function

This command will cause the test set to transition to the Active logging state. Once in the Active Logging state the test set can begin forwarding messages to the protocol logging software.

The protocol logging software must be in real-time mode (not post-capture mode) and a real-time logging session must be connected before transition to the Active logging state is possible.

A real-time logging session is connected by entering the IP Address of the test set in the Tools, Configuration window found in the protocol logging software. When a real-time logging session is connected, the test set's front panel logging annunciator will display Logging:Idle (see the Idle description in CALL:PLOGging<:STATus|STATe>? .)

After the transition from the Idle to Active logging state has occurred, the test set's front paned logging annunciator will appear as Logging:Active .

NOTE
The test set can also be transitioned to the Active logging state by clicking on the REC (record) button located in the protocol logging software (Wireless Protocol Advisor).

Requirements

Lab Application Revision: A.01 and above

Programming Example

 OUTPUT 714;"CALL:PLOGGING:START"
!Starts protocol logging.

CALL:PLOGging:STOP

Function

This command will cause the test set to transition to the Idle logging state.

The test set must be in the Active state before transition to the Idle logging state is possible.

After the transition from the Active to the Idle logging state, the test set's front panel logging annunciator will appear as Logging:Idle .

NOTE
The test set can also be transitioned to the Idle logging state by clicking on the STOP button located in the protocol logging software (Wireless Protocol Advisor).

Requirements

Lab Application Revision: A.01 and above

Programming Example

 OUTPUT 714;"CALL:PLOGGING:STOP"
!Stops protocol logging.

CALL:PLOGging<:STATus|STATe>?

Function

This command queries the status of the test set's protocol logging data source. The logging status can be viewed on the test set front panel's logging annunciator.

Possible query results are:

  • DISC (Disconnected) - There is no real-time protocol logging session established between the test set and the protocol logging software.
  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.
  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.
  • STRTG (Starting) - This is a transitional state while the protocol logging software attempts to start logging test set protocol messages.
  • STPG (Stopping) - This is a transitional state while the protocol logging software attempts to stop logging test set protocol messages.

Query

 Range: DISC|IDLE|ACT|STRTG|STPG

Requirements

Lab Application Revision: A.01 and above

Programming Example

 OUTPUT 714;"CALL:PLOGGING:STATe?"
!Queries the protocol logging state.

CALL:PLOGging:CONNected?

Function

This query returns an integer value of 1 if the status of the test set's protocol logging data source is either:

  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.
  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.

See CALL:PLOGging<:STATus|STATe>? .

If the state of the test set's protocol logging data source is not one of the above, this query will "hang" until a transition to one of these states occurs, or a bus timeout or device clear terminates the query attempt.

Query

 Range: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

 OUTPUT 714;"CALL:PLOGGING:CONN?"
!Queries the connected state.

CALL:PLOGging:ACTive?

Function

This query returns an integer value of 1 if the status of the test set's protocol logging data source is:

  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.

See CALL:PLOGging<:STATus|STATe>? .

If the state of the test set's protocol logging data source is not Active, this query will "hang" until a transition to the Active state occurs, or a bus timeout or device clear terminates the query attempt.

Query

 Range: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

 OUTPUT 714;"CALL:PLOGGING:ACT?"
!Queries the Active state.

CALL:PLOGging:DONE?

Function

This query returns an integer value of 1 if the status of the test set's protocol logging data source is either:

  • DISC (Disconnected) - There is no real-time protocol logging session established between the test set and the protocol logging software.
  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.

See CALL:PLOGging<:STATus|STATe>? .

If the state of the test set's protocol logging data source is not one of the above, this query will "hang" until a transition to one of these states occurs, or a bus timeout or device clear terminates the query attempt.

Query

 Range: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

 OUTPUT 714;"CALL:PLOGGING:DONE?"
!Queries the done (logging) state.


FETCh:GAPPower

FETCh:GAPPower

Last updated: April 14, 2005

Diagram Conventions

FETCh:GAPPower[:ALL][:RANGe20]?

Function

Queries the graphical access probe power measurement results for the first 20 access probes.

This query returns 21 comma-separated values, in the order of an overall integrity value, followed by 20 power results for the first 20 access probes.

If the measurement consists of less than 20 access probes, the remaining power results will be returned as 9.91 E+37, which means no results were available.

You can use the FETCh:GAPPower[:ALL]:RANGe60? to query power results for up to 60 access probes.

The total number of the access probes measured is equal to Probe Sequence Max times Probe Num Step .

If the test set does not receive the expected number of access probes and no timeouts have been set up (see SETup:GAPPower:TIMeout[:STIMe] ), this command will hang indefinitely.

Query

Integrity

  • Range: 0 to 23 (see Integrity Indicator )

    Resolution: 1

Access probes

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.0000001 dBm

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower?"

!Queries the overall integrity result and power levels
!for up to 20 access probe power measurements.

FETCh:GAPPower[:ALL]:RANGe60?

Function

Queries the graphical access probe power measurement results for up to 60 access probes.

This query returns 61 comma-separated values, in the order of an overall integrity value, followed by 60 power results for the first 60 access probes.

If the measurement consists of less than 60 access probes, the remaining power results will be returned as 9.91 E+37, which means no results were available.

You can use FETCh:GAPPower[:ALL][:RANGe20]? to query power results for up to 20 access probes.

The total number of the access probes measured is equal to Probe Sequence Max times Probe Num Step .

If the test set does not receive the expected number of access probes and no timeouts have been set up (see SETup:GAPPower:TIMeout[:STIMe] ), this command will hang indefinitely.

Query

Integrity

  • Range: 0 to 23 (see Integrity Indicator )

    Resolution: 1

Access probes

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.0000001 dBm

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:RANGe60?"

!Queries the overall integrity result and power levels
!for up to 60 access probes.

FETCh:GAPPower:ICOunt?

Function

Queries the intermediate count of access probe measurements displayed in the Measurement Progress Indicator field (see Graphical Access Probe Power Measurement Results ).

Query

Range: 0 to 999

Resolution: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:ICOunt?"
!Queries the current number of access probes
!in the measurement progress indicator field.

FETCh:GAPPower:INTegrity?

Function

Queries the overall integrity indicator of the graphical access probe power measurement.

Zero indicates all access probes were normal. If the result of this query is non-zero, it applies to the last access probe measurement with non-zero integrity indicator.

See Integrity Indicator for information about non-zero integrity results.

To query the integrity indicator for each of the access probes during a graphical access probe power measurement cycle, use FETCh:GAPPower:INTegrity20? or FETCh:GAPPower:INTegrity60? .

Query

Range: 0 through 23

Resolution: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:INTegrity?"

!Queries the overall integrity indicator for the graphical access probe power measurement.

FETCh:GAPPower:INTegrity20?

Function

Queries the integrity indicator values for each of the first 20 access probes during a graphical access probe power measurement.

Twenty values will be returned. If the measurement consists of less than 20 access probes, the remaining results will be returned as 1 (one), which means no results were available.

See Integrity Indicator for information about non-zero integrity results.

You can use FETCh:GAPPower:INTegrity60? to query integrity values for up to 60 access probes. The overall integrity indicator can be queried with FETCh:GAPPower:INTegrity? .

The total number of the access probes measured is equal to Probe Sequence Max times Probe Num Step .

Query

Range: 20 integers each ranging in value from 0 through 23

Resolution: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:INTegrity20?"
!Queries up to 20 access probe measurement integrity indicators.

FETCh:GAPPower:INTegrity60?

Function

Queries the integrity indicator values for each of the first 60 access probes during a graphical access probe power measurement.

Sixty values will be returned. If the measurement consists of less than 60 access probes, the remaining results will be returned as 1 (one), which means no results were available.

See Integrity Indicator for information about non-zero integrity results.

You can use FETCh:GAPPower:INTegrity20? to query integrity values for up to 20 access probes. The overall integrity indicator can be queried with FETCh:GAPPower:INTegrity? .

The total number of the access probes measured is equal to Probe Sequence Max times ( Probe Num Step .

Query

Range: 60 integers each ranging in value from 0 through 23

Resolution: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:INTegrity60?"
!Queries up to 60 access probe measurement integrity indicators.

FETCh:GAPPower:RTPRevious[:RANGe19]?

Function

Queries the delta power values between adjacent access probes for the first 20 access probe measurements (there will be no delta value for the first access probe) during a graphical access probe power measurement cycle.

Nineteen values will be returned. If the measurement consists of less than 20 access probes, the remaining results will be returned as 9.91 E+37, which means no results were available.

You can use FETCh:GAPPower:RTPRevious:RANGe59? to query up to 59 delta power values.

The total number of the access probes measured is equal to Probe Sequence Max times Probe Num Step .

Query

Range: 19 real numbers

Resolution: 0.0000001 dB

Requirements

Lab Application Revision: A.01 and above

Programming ExampleOUTPUT 714;"FETCh:GAPPower:RTPRevious?"
!Queries delta power values for the first
!20 access probes except the first.

FETCh:GAPPower:RTPRevious:RANGe59?

Function

Queries the delta power values between adjacent access probes for the first 60 access probe measurements (there will be no delta value for the first access probe) during a graphical access probe power measurement cycle.

Fifty nine values will be returned. If the measurement consists of less than 60 access probes, the remaining result will be returned as 9.91 E+37, which means no results were available.

You can use FETCh:GAPPower:RTPRevious[:RANGe19]? to query up to 19 delta power values.

The total number of the access probes measured is equal to Probe Sequence Max times Probe Num Step .

Query

Range: 59 real numbers

Resolution: 0.0000001 dB

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:RTPRevious:RANGe59?"
!Queries delta power values for the first
!60 access probes except the first.

FETCh:GAPPower:TIME[:RANGe19]?

Function

Queries the time offset relative to the first access probe for the first 20 access probe measurements (there will be no time offset value for the first access probe) during a graphical access probe power measurement cycle.

Nineteen values will be returned. If the measurement consists of less than 20 access probes, the remaining results will be returned as 9.91 E+37, which means no results were available.

You can use FETCh:GAPPower:TIME:RANGe59? to query up to 59 time offset values.

The total number of the access probes measured is equal to Probe Sequence Max times Probe Num Step .

Query

Range: 19 real numbers

Resolution: 0.01 seconds

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:TIME?"
!Queries the time offset values for the first
!20 access probes except the first.

FETCh:GAPPower:TIME:RANGe59?

Function

Queries the time offset relative to the first access probe for the first 60 access probe measurements (there will be no time offset value for the first access probe) during a graphical access probe power measurement cycle.

Nineteen values will be returned. If the measurement consists of less than 60 access probes, the remaining results will be returned as 9.91 E+37, which means no results were available.

You can use FETCh:GAPPower:TIME[:RANGe19]? to query up to 19 time offset values.

The total number of the access probes measured is equal to Probe Sequence Max times Probe Num Step .

Query

Range: 59 real numbers

Resolution: 0.01 seconds

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:TIME:RANGe59?"

!Queries the time offset values for the
!first 60 access probes except the first.


SETup:GAPPower

SETup:GAPPower

Last updated: April 14, 2005

NOTE
Some of the access parameters (such as power step, number of steps, sequence maximum, etc.) directly affect graphical access probe power measurements. GPIB commands for these parameters can be found in the CALL:APARameter syntax diagrams.

To limit a call attempt to the access attempt state, see CALL:CONNected:LIMit[:STATe]<[:SELected]|:TA856> .

Diagram Conventions

SETup:GAPPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the measurement timeout value (see SETup:GAPPower:TIMeout:TIME ), and (2) sets the measurement timeout state to on (see SETup:GAPPower:TIMeout:STATe ).

The query form of this command returns the measurement timeout value.

If the timeout timer is not turned on, and an access probe is not received, the graphical access probe power measurement will hang on the FETCh? command indefinitely.

For a description of the timeout, see Measurement Timeouts .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETup:GAPPower:TIMeout 5"
!Sets timeout state to ON and timeout time to 5 seconds.

SETup:GAPPower:TIMeout:STATe

Function

Sets/queries the measurement timeout state.

The measurement timeout state can also be set to on using the SETup:GAPPower:TIMeout[:STIMe] command.

For a description of the timeout, see Measurement Timeouts .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETup:GAPPower:TIMeout:STATe ON"

SETup:GAPPower:TIMeout:TIME

Function

Sets/queries the measurement timeout value to be used when the timeout state is set to on.

The measurement timeout state can also be set using the SETup:GAPPower:TIMeout[:STIMe] command.

For a description of the timeout, see Measurement Timeouts .

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETup:GAPPower:TIMeout:TIME 5"


SYSTem:STATus

SYSTem:STATus

Last updated: August 9, 2005

Diagram Conventions

SYSTem:STATus:COMMunicate:LAN:EXTernal:SYNChronize:INDication?

Function

Queries the synchronization annuciators. See Sync Annuciators .

Query

Range: UNKN|COC|SOC|CSOC

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"SYSTem:STATus:COMMunicate:LAN:EXTernal:SYNChronize:INDication?"


3.2.2 Demodulation of Forward Traffic Channel in Multipath Fading Channel

3.2.2 Demodulation of Forward Traffic Channel in Multipath Fading Channel

Last updated: May 24, 2006

This section is only applicable to the lab application.

Definition

Demodulation of Forward Traffic Channel in multipath fading channel is one of the most important receiver tests, for it tests and evaluates how well the AT demodulates the Forward Traffic Channel in the real-world channel conditions (various fading and noise environments.) The figure of merit is Packet Error Rate (PER). The PER is calculated for 38.4 kbps and 76.8 kbps data rates. The following table summarizes the fading tests to be performed

Channel Simulator Configuration Number | Description
1 (8 km/h, 2 paths) | Case 1 tests the demodulation performance for the 8 km/h, two-path case by checking the PER at the 38.4 kbps and 76.8 kbps data rates.
2 (3 km/h, 1paths) | Case 2 tests the demodulation performance for the 3 km/h, single-path case by checking the PER at the 38.4 kbps and 76.8 kbps data rates.
3 (30km/h, 1paths) | Case 3 tests the demodulation performance for the 30 km/h, single-path case by checking the PER at the 38.4 kbps and 76.8 kbps data rates.
4 (100 km/h, 3paths) | Case 4 tests the demodulation performance for the 100 km/h, three-path case by checking the PER at the 38.4 kbps and 76.8 kbps data rates.
.

Method of Measurement

  1. Connect the access network emulator, the channel simulator and an AWGN to the AT.
  2. Set the AN forward packet activity to 100%.
  3. Set the Control Channel data rate to 38.4 kbps (because the default power level for 38.4 kbps Control Channel is high enough to overcome the interference signals required for these tests).
  4. Set Pilot Drop to -14 dB (to prevent the access terminal from generating Pilot Strength Measurement Reports due to the low Pilot Channel to AWGN ratio).
  5. Set Î or to -55 dBm/1.23 MHz.
  6. Set up a Test Application session and open an FTAP connection (for Subtype 0 or 1 Physical Layer).
  7. Perform tests 1 - 24 which evaluate the AT's performance operating at Subtype 0 or 1 Physical Layer for varying E b /N t . Set I oc as specified for each test. The Channel Simulator Configuration number defines the fading profile used for each test case.
    • Set I oc as specified for each test (ranges from -63 to -45.9 dBm/1.23 MHz).
    • Set the Forward Traffic Channel data rates (38.4 or 76.8 kbps) as specified for each test.
    • Set the correct Channel Simulator Configuration. Some fading simulator software (for example, Baseband Studio software) has set up all of the parameters for each standard fading profile (such as number of paths, delays, and Doppler shifts), all you need to do is to select the Channel Simulator Configuration number as required for each test.
  8. If your AT supports Subtype 2 Physical Layer, set up a Test Application session and open an FETAP connection (for Subtype 2 Physical Layer).
  9. Perform tests 25-28 which evaluate the AT's performance operating at Subtype 2 Physical Layer for varying E b /N t . Set the forward data rate and I oc as specified for each test.
  10. Calculate PER for each test.

Minimum Standard

PER shall not exceed 0.3% to 5% with 95% confidence (depending upon data rate and E b /N t ).

Related Topics

Manual Operation: Testing 3.2.2 Demodulation of Forward Traffic Channel in Multipath Fading Channel (Lab Application Only)


Graphical Access Probe Power Measurement Description

Graphical Access Probe Power Measurement Description

Last updated: July 10, 2006

This section is only applicable to the lab application.

  • How is a Graphical Access Probe Power Measurement Made?
  • Graphical Access Probe Power Measurement Parameters
  • Graphical Access Probe Power Measurement Results
  • Input Signal Requirements
  • Key C.S0033 Tests Performed using the Graphical Access Probe Power Measurement
  • Calibrating the Graphical Access Probe Power Measurement

How is a Graphical Access Probe Power Measurement Made?

The graphical access probe power measurement consists of a series of up to 60 channel power measurements (see Channel Power Measurement Description ), each triggered by a rise in RF power detected on the test set's RF input. When an input signal appears that is within +/- 9 dB of the expected power for an access probe, the measurement is triggered. To prevent the measurement from triggering on noise, the signal level must be at least -45 dBm/1.23 MHz.

The graphical access probe power measurement measures a number of access probes transmitted from the access terminal as specified (see Graphical Access Probe Power Measurement Parameters ). It captures each access probe and digitizes the waveform. It then uses DSP to determine the average power level (within the 1.23 MHz measurement bandwidth) of the first ~1.667 ms of each probe.

An access probe is sent by the access terminal as a way to determine the correct power level needed to access the test set. Initially, the access probe power level will be minimal and then increase in amplitude until the test set responds to the signal.

When the Current Access Channel MAC Subtype is the Default , the access probe power measurement is operating in the Default Access Channel MAC protocol. The access probe power measurement looks for a bursted signal that is approximately 200 ms in length and occurs randomly. The power of preamble part is same with the power of the data portion.

When the Current Access Channel MAC Subtype is the Enhanced , the access probe power measurement is operating in the Enhanced Access Channel MAC Protocol. The preamble length is currently fixed to 16 slots by the test set and the length of data portion is from 26.67 ms (when Enhanced Access Rate is 38.4 kbps) to 106.88 ms (when Enhanced Access Rate is 9.6 kbps). When the Enhanced Access Rate is other than 9.6 kpbs, the power of data portion is higher than the preamble power.

Operating Considerations When Making the Measurement

NOTE
Graphical access probe power measurements can not run concurrently with any other measurements. If any measurement(s) are open when graphical access probe power is opened, they will automatically be closed.

Each graphical access probe power measurement cycle is initiated by a INIT:GAPPower command or by pressing the START SINGLE key. During a measurement cycle, the easiest way to induce access probes from the access terminal is to page the access terminal.

Access probe sequences consist of a series of RF power "steps" which increase in power according to the step size setting until the maximum number of steps is reached, or the data connection processing event completes (for example when the data connection is established). For the parameters that determine the access probe sequence characteristics, see Graphical Access Probe Power Measurement Parameters .

To view the full access probe sequence, you must prevent the test set from responding to the access terminal by turning Call Limit Mode on.

NOTE

It is recommended that you always turn Call Limit Mode on when measuring access probe power. The easiest way to induce access probes from the access terminal is to page the access terminal. If you do not have call limit mode set to on, the connection will complete, which clears the access probe power result from the measurement screen. Set call limit mode back to off when you have finished measuring access probe power.

Graphical Access Probe Power Measurement Parameters

  • Timeout Time/State - (see Measurement Timeouts ).
  • The following parameters determine the access probe sequence characteristics: Open Loop Adjust , Probe Initial Adjust , Probe Power Step , Probe Num Step , Probe Sequence Max , Preamble Length ( only used when the test set is configured to Default Access Channel MAC protocol , see PL Subtype 2 Access Channel MAC Subtype ), Enhanced Access Rate ( only used when the test set is configured toEnhanced Access Channel MAC protocol, see PL Subtype 2 Access Channel MAC Subtype )

Graphical Access Probe Power Measurement Results

As shown in the figure below, each measurement is displayed in both a tabular and a bar graph format. Pressing the MEASUREMENT RESET key will clear the display.

Graphical Access Probe Power Measurement Display

Graphical Display

The graphical display shows the access probe power bar graph covering a time span of up to 120 seconds from the first access probe. Access probe power is displayed using yellow bars on the graph and the graph can display up to 60 access probes, labeled 0 through 59. Power levels are displayed in units of dBm/1.23 MHz.

The graphical display is controlled from the Graph Control menu by selecting the Graph Control ( F2 ).

  • The view window can be adjusted to include the entire 120 second range or only a portion of the 120 second time period of particular interests by using the Start ( F3 ) and Span ( F4 ).
  • The Marker Mode ( F1 ) sets the mode of the active marker.
    • When Position is selected, it activates a single marker. Use the Marker Position ( F2 ) to position the marker at any access probe power measurement across the current span of the graph. Measurement results that correspond with the position marker are displayed above the graph (The two values to the right of the "Mkr" indicates absolute power level and the time relative to the 1st access probe) and become highlighted in the table below the graph.
    • When Delta is selected, it first freezes the current position marker and uses it as a reference marker. A second marker is created at the position specified by the Delta Position ( F2 ) offset from that of the reference marker. Any change in power between the second marker and the reference marker is calculated as a delta power. Two markers provide the added capability to display relative (delta) power levels between any two access probes. Measurement results that correspond with the reference marker and the delta marker are displayed above the graph (The two values to the right of the "Mkr" indicates the absolute power level for the reference marker and the time relative to the 1st access probe. The two values to the right of the delta symbol indicates the delta power and delta time at the second marker relative to the reference marker.) and become highlighted in the table in the table below the graph.

NOTE
If the absolute power level of an access probe falls below the range of the graph, the value will cause the bar to clip.

Tabular Display

A table below the graphical display lists the following measurement results for up to 60 access probes:

  • An access probe number indexed to each marker position (0 - 59).
  • The absolute power of each access probe measurement in units of dBm/1.23 MHz.
  • The delta power between adjacent access probes.
  • The time that each access probe arrived relative to the first access probe.

The table has the capacity to display 20 access probes at one screen. To scroll through the table, adjust the Marker Position or Marker Delta field.

Measurement Progress Indicator

A measurement progress indicator in the lower left portion of the display continually updates the ratio of access probes received to the number of access probes expected. Each access probe power measurement cycle ends when the expected number of access probes have been received, the measurement times out, or the measurement is aborted or reset.

NOTE
If there is a measurement problem associated with an access probe, a non-zero integrity indicator (see Integrity Indicator ) will be displayed below the table and the access probe's power measurement will appear in reverse video (black text on a white background).

Input Signal Requirements

Input Signal Requirements

Key C.S0033 Tests Performed using the Graphical Access Probe Power Measurement

  • Same as the tests supported by Access Probe Power Measurement: 4.3.1 Range of Open Loop Output Power

Calibrating the Graphical Access Probe Power Measurement

The graphical access probe power measurement is automatically calibrated during a channel power calibration. Follow the channel power calibration schedule and the graphical access probe power measurement will be properly calibrated. Refer to Calibrating the Test Set for a description of channel power calibration.

Related Topics

Manual Operation: Measuring Graphical Access Probe Power

Programming a Graphical Access Probe Power Measurement

Graphical Access Probe Power Troubleshooting

Access Probe Power Measurement Description

Test Adherence to Standards


Getting Started with Protocol Logging

Getting Started with Protocol Logging

Last updated: April 14, 2005

This section is only applicable to the lab application.

You can use a PC software application, the Wireless Protocol Advisor (WPA), to analyze communication between a wireless device and the test set. If you're using the data channel feature of the test set as an IP router to exchange data between the wireless device and a network server, then the WPA can also monitor these communications.

The software connects with the test set through the LAN port, to capture messages and data used to set up and maintain links and transfer data. Messages and data can be filtered to include specific protocol layers and message fields. Refer to:

Agilent E6584A Wireless Protocol Advisor Operation Guide

[http://cp.literature.agilent.com/litweb/pdf/1000-1868.pdf]

Moreover, most of the information necessary to establish a connection and to display, filter, store, print, and analyze the message exchange between the test set and a mobile station is accessible through the Help feature available on-line when the WPA application is running.

TO RETURN TO THE MAIN MEASUREMENTS PAGE, click here: Protocol Logging .


Protocol Logging Requirements

Protocol Logging Requirements

Last updated: April 14, 2005

This section is only applicable to the lab application.

The Lab Application enables the test set to log protocol messages. Protocol messages are forwarded to the Wireless Protocol Advisor (WPA) software, which is required for message display and analysis. This software is included with the lab application and will run on PCs that meet the following system requirements:

Summary of Requirements for the Wireless Protocol Advisor

NOTE
These requirements are subject to change or addition without notice. Always refer to the product web page for the latest information.

  • PC Operating System:
    • Microsoft® Windows® 98
    • Microsoft® Windows® NT 4 SP3/4/5
    • Microsoft® Windows® 2000
    • Microsoft® Windows® XP
  • 300 MHz Pentium or equivalent recommended
  • 128 MB RAM recommended
  • 250 MB available disk space required for installation
  • 100 MB available disk space recommended for storing logged information
  • Video resolution minimum 800 by 600 pixels with at least 256 colors
  • LAN or WAN card must be installed and connected to a network


Activating Protocol Logging From the Test Set

Activating Protocol Logging From the Test Set

Last updated: April 14, 2005

This section is only applicable to the lab application.

Once a connection is established between the PC running the WPA (Wireless Protocol Advisor) and the test set, a logging session can be activated (or deactivated) by selecting the start (or stop) softkey from the test set's front panel or by sending GPIB commands that perform the same functions:

NOTE
The WPA software performs the same start/stop functions when the REC (RECord) button is selected. Refer to the WPA on-line Help for details.

Test Set Control of Protocol Logging

If a PC with the WPA software has not yet connected with the test set, an error message will be generated if an attempt is made to start protocol logging. Exactly one PC/WPA can be connected to a test set at one time.

Front Panel Control of Protocol Logging

  1. Press the CALL SETUP key to go to the Call Setup screen.
  2. Press the left More key two times, go to Call Control 3 of 3 .
  3. Press Protocol Logging ( F1 ).
  4. Press Start Protocol Logging ( F1 ) to begin logging.

Remote Control of Protocol Logging

The GPIB command to control Protocol Logging is CALL:PLOGging .

Related Topics

Protocol Logging


Programming a Graphical Access Probe Power Measurement

Programming a Graphical Access Probe Power Measurement

This section is only applicable to the lab application.

General Programming Procedure

  1. Prompt the user to connect the access terminal to the test set's front panel RF IN/OUT connector and power it on. Instruct the user that if the access terminal does not automatically open a session, perform whatever actions are necessary to open a session. See Establish a Session from the Access Terminal for more details.
  2. Set up the access parameters (such as power step size, number of steps, etc.) as needed using the CALL:APARameter commands.
  3. Set up the graphical access probe power measurement parameters. Turn on the graphical access probe power measurement timeout timer on using the SETup:GAPPower:TIMeout[:STIMe] command. If the timeout timer is not turned on, and an access probe is not received, the measurement will hang on the FETCh? command indefinitely.
  4. Turn on call limit mode so the test set does not acknowledge the access terminal's access attempt, using the CALL:CONNected:LIMit[:STATe]<[:SELected]|:TA856> command. You must set all parameters that are configured during the Session Negotiate state (such as Probe Sequence Max ) before turning call limit mode on (see Call Limit Mode for more information).
  5. Set cell power as needed using the CALL:POWer command.
  6. Page the access terminal (to initiate access probes) using the CALL:FUNCtion:DATA:STARt command.
  7. Initiate the access probe power measurement using the INITiate:<measurement mnemonic>[:ON] command. The <measurement mnemonic> for the access probe power measurement is GAPPower.
  8. Use the FETCh:GAPPower[:ALL][:RANGe20]? or FETCh:GAPPower[:ALL]:RANGe60? commands to obtain the measurement results. (You can also replace steps 7 and 8 with a single command - READ:GAPPower[:ALL][:RANGe20]? or READ:GAPPower[:ALL]:RANGe60? ).
  9. Use the CALL:FUNCtion:DATA:STOP command to stop paging the access terminal.

Programming Example: 4.3.1 Range of Open Loop Output Power

10 !**********************************************************************
20 ! 4.3.1 Range of Open Loop Output Power
30 !This programming example assumes the access terminal
40 !is connected to the test set and in the session open state.
41 !This example commands the AT send 5 access probes for each test.
50 !
60  Testset=714
70  DISP "Testing Range of Open Loop Power"
80 !
90 !***Test parameters variables***
100     Ior1=-25       !First level for test
110     Ior2=-65       !Second level for test
120     Ior3=-93.5       ! Ior for test 3 Band Class 0, AT Class III
130     Ol_adjust=78       ! Set Open Loop Adjust for Band Class 0
140     Preamble_len=7       !Set Preamble Length to 7 frames
150     Prb_ini_adj=0       !Set Probe Initial Adjust to 0 dB
160     Prb_pwr_step=0
170     !Set Probe Power Step to 0 dB. This is to ensure that
180     !all access probes in the probe sequence will transmit at
190     !the same power level so that you can easily verify the test.
200     Prb_num_step=4       !Set Probe Num Step to 4
210     Prb_seq_max=1       !Set Probe Sequence Max to 1
220     Total_probes= Prb_num_step*Prb_seq_max
230     !total number of access probes to be measured
240 !
250 !***Set up access parameters***
260 OUTPUT Testset;"CALL:APAR:POWER:OLADJUST ";Ol_adjust
270 ! Set Open Loop Adjust
280 OUTPUT Testset;"CALL:APAR:PREAMBLE:LENGTH ";Preamble_len
290 ! Set preamble length in frames
300 OUTPUT Testset;"CALL:APAR:PROBE:IADJUST ";Prb_ini_adj
310 ! Set Probe Initial Adjust
320 OUTPUT Testset;"CALL:APAR:PROBE:STEP:COUNT ";Prb_num_step
330 ! Set Probe Num Steps
340 OUTPUT Testset;"CALL:APAR:PROBE:SEQUENCE ";Prb_seq_max
350 ! Set Probe Sequence Max
360 ! This must be done BEFORE call limit mode is turned on
370 OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP ";Prb_pwr_step
380 ! Set Probe Power Step
390 !
400 !***Set up measurement parameters***
410 OUTPUT Testset;"SETUP:GAPP:TIMEOUT 60"
420 ! Set access probe power timeout to 60 seconds
430 !
440 !***Set test conditions***
450 OUTPUT Testset;"CALL:CONNECTED:LIMIT:STATE 1"
460 ! Turn on call limit mode so connection is not established
470 ! This must be done after probe sequence max is set
480 !
490 !***Obtain measurement results***
500 !
510 DIM Access_probe(20)
520 DIM Gapp_meas$[500]
530 !
540 !***Test 1***
550 OUTPUT Testset;"CALL:POW ";Ior1
560 ! Set cell power for test 1
570 WAIT .1   ! Settling time for access terminal output power to slew
580 OUTPUT Testset;"CALL:FUNCTION:DATA:START"
590 ! Page access terminal
600 OUTPUT Testset;"READ:GAPP?"
610 ! Read power results for up to 20 access probes. If more than 20 access
620 ! probes measured, use the command, READ:GAPP:RANG60?
630 ENTER Testset;Gapp_meas$
640 OUTPUT Testset;"CALL:FUNCTION:DATA:STOP"
650 ! Stop data connection paging before repaging at next level
660 CLEAR SCREEN
670 PRINT "************************************************"
680 PRINT "*Range of Open Loop Output Power Test 1 Results*"
690 PRINT "************************************************"
700 GOSUB Print_result
710 !
720 !***Test 2***
730 !
740 OUTPUT Testset;"CALL:POW ";Ior2
750 ! Set cell power for test 2
760 WAIT .1
770 ! Settling time for mobile output power to slew
780 OUTPUT Testset;"CALL:FUNCTION:DATA:START"
790 ! Page access terminal
800 OUTPUT Testset;"READ:GAPP?"
810 ! Read access probe power
820 ENTER Testset;Gapp_meas$
830 OUTPUT Testset;"CALL:FUNCTION:DATA:STOP"
840 ! Stop data connection paging before repaging at next level
850 PRINT "************************************************"
860 PRINT "*Range of Open Loop Output Power Test 2 Results*"
870 PRINT "************************************************"
880 GOSUB Print_result
890 !
900 !***Test 3***
910 !
920 OUTPUT Testset;"CALL:POW ";Ior3
930 ! Set cell power for test 3
940 WAIT .1
950 ! Settling time for mobile output power to slew
960 OUTPUT Testset;"CALL:FUNCTION:DATA:START"
970 ! Page access terminal
980 OUTPUT Testset;"READ:GAPP?"
990 ! Read access probe power
1000 ENTER Testset;Gapp_meas$
1010 !OUTPUT Testset;"CALL:FUNCTION:DATA:STOP"
1020 ! Stop data connection paging
1030 PRINT "************************************************"
1040 PRINT "*Range of Open Loop Output Power Test 3 Results*"
1050 PRINT "************************************************"
1060 GOSUB Print_result
1070 !
1080 PRINT
1090 PRINT "All Tests Complete!"
1100 PRINT
1110 !
1120 GOTO End_program
1130 !
1140 !*************
1150 !Sub Prgrams:*
1160 !*************
1170 !
1180  Print_result:!
1190 !
1200 !***Print measurement results sub-program***
1210 !
1220   Separator$=","!GAPP measurements are returned in a comma-separated string
1230   First_acc_probe=POS(Gapp_meas$,Separator$)
1240   !Find the first comma, which separates the integrity indicator from the
1250   !first access probe measurement
1260   Integrity=VAL(Gapp_meas$[1;First_acc_probe-1])
1270   !Convert the ascii integrity characters to a numeric value
1280       PRINT "Integrity Indicator = ";Integrity
1290       FOR I=1 TO Total_probes
1300         Acc_probe_mkr=First_acc_probe+((I-1)*17)
1310         !Set up a marker that will jump to each comma in the ascii string
1320         Access_probe(I)=VAL(Gapp_meas$[Acc_probe_mkr+1;Acc_probe_mkr+16])
1330         !Convert ascii to a numeric value
1340         PRINT "Access probe ";I-1;" measurement is ";Access_probe(I);" dBm/1.23 MHz"
1350       NEXT I
1360       DISP "Test complete"
1370   RETURN
1380 !
1390  End_program:!
1400 !
1410  !***Post test clean up***
1420  !
1430   OUTPUT Testset;"CALL:CONNECTED:LIMIT:STATE 0"
1440   ! Turn off call limit mode
1450   ! Must do BEFORE can change probe max sequence
1460   OUTPUT Testset;"CALL:POW -55"
1470   ! Set Cell Power to default. Do this before reconfiguring other parms
1480   ! so signaling is successful (don't want cell power too low for signaling)
1490   OUTPUT Testset;"CALL:APAR:PREAMBLE:LENGTH 7"
1500   ! Set preamble length in frames
1510   OUTPUT Testset;"CALL:APAR:PROBE:IADJUST 0"
1520   ! Set Probe Initial Adjust
1530   OUTPUT Testset;"CALL:APAR:PROBE:STEP:COUNT 3"
1540   ! Set Probe Num Steps
1550   OUTPUT Testset;"CALL:APAR:PROBE:SEQUENCE 1"
1560   ! Set Probe Sequence Max
1570   OUTPUT Testset;"CALL:APAR:PROBE:POWER:STEP 3"
1580   ! Set Probe Step
1590   OUTPUT Testset;"INIT:GAPP:OFF"
1600   ! Set access probe power meas off
1610   DISP ""
1620 END

Related Topics

Manual Operation: Measuring Graphical Access Probe Power


E6706A/T 1xEV-DO Terminal Lab Application Revision Information

E6706A/T 1xEV-DO Terminal Lab Application Revision Information

Last updated: July 20, 2006

This document describes features and functionality that are part of the Agilent Technologies 1xEV-DO Lab Application releases. This document contains the original features, as well as enhancements that have been added over time.

CAUTION
You may need to upgrade the hardware in your test set before installing the application firmware described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up (see Test Set Lockup Due to Power Up Sequence ).
  • The application may not run.
  • Some features in the application may be inaccessible, or may not perform to specifications.

To determine if a hardware upgrade is required for your testing needs, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Select the appropriate link below to view the required release.

  • A.03.06 Release - July 2006
  • T.00.04 Special Release (E6706T) - May 2006
  • A.02.21 Release - January 2006
  • A.02 Beta Release - August 2005
  • A.01.10 Release - April 2005

A.03.06 Release - July 2006

Summary of GPIB command changes for this release: GPIB Changes for E1966A A.06.06, E6706A A.03.06 - July 2006

This release includes all of the features and functionality present in the E1966A 1xEV-DO Terminal Test Application A.06.06 Release - July 2006 . The unique features of the E6706A Lab Application are indicated below.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Access Network Emulation

  • Supports protocol release A in Active Cell operating mode. (All of the functionalities associated with the release A are same as what are listed in the E1966A 1xEV-DO Terminal Test Application A.06.06 Release - July 2006 except for the license mentioned below)

    NOTE
    To enable this functionality in a licensed lab application, you must order a special free feature license (E6706A-102) from Agilent Technologies. However, ordering the E6706A-102 feature license from Agilent Technologies does not grant you use of the Qualcomm® proprietary Release A functionality. You must obtain consent from Qualcomm® to utilize this feature, as explained in the following statement:

    NOTICE
    THE DELIVERY OF THE AGILENT PRODUCT DOES NOT CONVEY A LICENSE NOR IMPLY ANY RIGHTS TO USE THE "1xEV-DO REVISION A" CAPABILITY CONTAINED IN THE AGILENT PRODUCT. SUCH USE REQUIRES THE EXPRESS CONSENT OF OR A SEPARATE LICENSE FROM QUALCOMM INCORPORATED. CUSTOMERS AND PRODUCT USERS SHALL BE SOLELY RESPONSIBLE TO OBTAIN SUCH CONSENT OR LICENSE FROM QUALCOMM INCORPORATED IN CONJUNCTION WITH THE USE OF THE "1XEVDO REVISION A" CAPABILITY.

  • Traffic Channel Packet Histogram Display

    In addition to a set of numeric counters, an intuitive histogram graph view is also provided to analyze the traffic activity on both the forward and reverse links. The information allows you to determine how many physical layer packets are transmitted or received at the particular data rate or packet size. See Traffic Channel Packet Information for details.

T.00.04 Special Release (E6706T) - May 2006

The E6706T can only be loaded onto an E5515C with Special High Data Rate Hardware (or an instrument with the equivalent hardware upgrades). Loading the E6706T onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6706T may not meet the E6706A measurement parametric specifications, and has a maximum operating temperature specification of 35° C.

The features and functionality offered in this special release are identical to those offered in the A.02.21 Release - January 2006 , with the following key exceptions:

  • The E6706T Special High Data Rate 1xEV-DO Lab Application (along with the appropriate hardware option) supports the maximum throughout of 2.4 Mbps at both baseband and IP with the proper configurations (see Other Configurations ).
  • You must use the new LAN 2 PORT for transferring data to the test set.

For information on how to use these E6706T features, see E6706T User Documentation .

For information on how to use the features that are common to the E6706A and E6706T, see the 1xEV-DO online user's guide located at:

http://wireless.agilent.com/rfcomms/refdocs/1xevdo/default.php

A.02.21 Release - January 2006

The most current documentation for the 1xEV-DO applications is the Online User's Guide located at:

http://wireless.agilent.com/rfcomms/refdocs/1xevdo/

Summary of GPIB command changes for this release: GPIB Changes for E1966A A.05.11, E6706A A.02.21 - January 2006

This release includes all of the features and functionality present in the last pre-release firmware A.02 Beta Release - August 2005 as well as the following enhancements.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Access Network Emulation

  • Supports MEID type of Hardware ID

    Mobile Equipment Identifier (MEID) is a new way to uniquely identify AT equipment. MEID is a 56-bit number that allows for a larger number of ATs to be identified than the existing ESN numbering system. MEID is a type of Hardware ID that is supported in the 1xEV-DO. See Hardware ID Type and Hardware ID for details.

  • Frequency Range of US Cellular Band Changes

    It is to support an extension to the existing Band Class 0 that is being allocated in Japan. The forward link frequency range of US Cellular cell band is changed from 869 - 894 MHz to 860 - 894 MHz and the reverse link frequency range of US Cellular cell band is changed from 824 - 849 MHz to 815 to 849 MHz. See Cell Band .

  • Channel Range of US Cellular Band Changes

    It is to support an extension to the existing Band Class 0 that is being allocated in Japan. The channel range of US Cellular cell band is extended to include the channels of 1024 - 1323. See Channel .

Other Features/Enhancements

  • Pilot Drop setting is moved to the Cell Parameters menu. See How Do I Change Cell Parameters?
  • The value range of the External PDSN Connect Timeout is changed from 0 - 19 seconds to 1 - 19 seconds. See External PDSN Connect Timeout . If the value is set to zero in the earlier version of firmware and you boot up into a newer version, the value stored in NVRAM will be changed to one second on power-up.

Resolved Known Issues

  • Some BCMCS (BroadCast MultiCase Service) capable access terminals can not open a session with the test set.

For more information, visit the 8960 Known Issues web site:

http://wireless.agilent.com/rfcomms/issues

A.02 Beta Release - August 2005

This is pre-release firmware. A pre-release is early firmware that has not been fully qualified.

The most current documentation for the 1xEV-DO applications is the Online User's Guide located at:

http://wireless.agilent.com/rfcomms/refdocs/1xevdo/

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1966A_A03_E6706A_A02_Ref_Guide.chm

NOTE
To properly view the CHM Help File, you must Save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties >> Unblock .

This release includes all of the features and functionality present in the E1966A 1xEV-DO Terminal Test Application Release A.03 (see A.03 .17 Release - January 2005 ). The unique features of the E6706A Lab Application since A.01.10 Release - April 2005 are indicated below.

Summary of GPIB command changes for this release: GPIB Changes for E6706A A.02 Beta Release - August 2005

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Data Connection Processing

  • Supports hybrid mode AT/MS tests.

    When a test set emulating an IS-2000/IS-95 base station and another emulating an IS-856 (1xEV-DO) access network are synchronized on CDMA system time, you can perform the functional tests of the hybrid mode AT/MS. For details, see Hybrid Mode .

  • Supports settable CDMA system time.

    The CDMA system time is the time reference used by all IS-856 and IS-95/IS-2000 systems. The test set emulating an AN allows you to set the CDMA system time which are sent to the AT in the overhead messages ( Sync Message and SectorParameters Message ). For details, see CDMA System Time Parameters .

  • Supports multiple test sets synchronization.

    Multiple test sets either running the E6702B cdma2000 lab application or the E6706A 1xEV-DO lab application can be synchronized on CDMA system time. It is very useful for hybrid mode AT/MS tests. For details, see Multi-unit Synchronization .

  • Adds a new setting - Session Close

    The session timeout was changed from a fixed setting (3 minutes) to a user-settable parameter. This setting specifies the time period for which the test set has not heard from the AT before sending a SessionClose Message to the AT. For details, see Session Close .

A.01.10 Release - April 2005

These are the original features of the Agilent E6706A.

The E6706A Release A.01 includes all of the features and functionality present in the E1966A 1xEV-DO Terminal Test Application Release A.03 (see A.03 .17 Release - January 2005 ). The unique features of the E6706A Lab Application are indicated below.

Summary of GPIB command changes for this release: GPIB Changes for E6706A A.01.10 - April 2005

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Data Connection Processing

  • Supports Default Packet Application (DPA).

    The DPA is an application layer protocol used in the actual 1xEV-DO network. See Session Application Type for details.

  • Provides data channel functionalities.

    The data channel function allows you to use the test set as an IP router, exchanging packet data between a 1XEV-DO wireless device (such as an access terminal (AT)) and a packet switched network (such as an IP network) via a packet data connection (using DPA). The performance of data applications such as music download, interactive and multimedia applications can then be evaluated with a set of tools such as Data Throughout Monitor, Data Counters, etc.

    By working with an external Mobile IP Simulator (MOB-IP-SIM) provided by the Software Concepts, Inc., the test set also supports Mobile IP based packet data connection.

    Ping, a utility that provides a simple IP connection check, is also supported.

    For details, see Data Channel .

  • Supports protocol logging.

    With the protocol logging function, the test set can capture the signaling information exchanged between the test set and an access terminal, and then forward the captured information to a PC software referred to as the WPA (Wireless Protocol Advisor) for signaling analysis. For example, the Signal Link Protocol (SLP), Radio Link Protocol (RLP), Point-to-Point Protocol (PPP), Internet Protocol (IP) as well as the Test Application Protocol (TAP) can be decoded. For details, see Protocol Logging .

  • Adds a new setting - Preferred Control Channel Cycle (PCCC) Control.

    By control of the session negotiation for the PCCC, the PCCC attribute can be configured to follow the test set's specified value or the AT-requested value during session negotiation. This provides flexibility for AT test because it allows ATs to determine the PCCC value without having to know the valid PCCC values for each AT under test. For details, see Preferred Control Channel Cycle .

  • Supports IS-856 Test operating mode:

    The IS-856 Test operating mode provides a way for measuring access terminal (AT) when it is not possible, or not desired, to communicate via over-the-air signaling with the access terminal (AT), but forward link stimulus and reverse link measurements are still needed. For details, see IS-856 Test Operating Mode .

Measurements

  • New Graphical Access Probe Power Measurement.

    The graphical access probe power measurement provides an intuitive bar graph results representing the access probe powers in addition to the numeric results. From the graph display, you can easily verify whether the AT sends the number of access probes as specified. Up to 60 access probes can be displayed at one time. For details, see Graphical Access Probe Power Measurement Description .

  • Supports Data Throughout Monitor.

    The data throughput monitor is provided to analyze data transfer rates under various RF and call processing conditions. For details, see Data Throughput Monitor .

  • Packet Error Rate measurement Enhancement

    A new setting, Minimum Packet Count, is added to the Packet Error Rate Setup menu. It is required for fading test. See PER Measurement Parameters for details.

  • Tx Dynamic Power Measurement Enhancements

    This measurement has been changed since its first release in the E1966A A.02.15 Release - January 2004 . Before performing each power step measurement in a power sequence, the test set automatically re-tunes its receiver based on the measured power of the prior step in addition to the Power Step Size setting that is only based on in the old releases. This change improves the test set ability to measure those ATs that do not correctly transmit the power sequence as expected without aborting the measurement. See TX Dynamic Power Measurement Description for details.

  • Spectrum Monitor Enhancements

    Span and resolution bandwidth can now be set independently, new Detection Method. See Resolution Bandwidth and Frequency Span and Detection Method for details.

Other Features

  • Supports signal fading.

    To generate faded forward channel signals with AWGN enabled, the test set requires a rear panel digital bus connection to an external PC running Baseband Studio software. See Digital Bus Information for reference information. This configuration supports the faded tests as specified in the C.S0033 test standard (for example, test 3.1.1.2.2).

  • New Restart on Fatal Error setting.


Data Channel Troubleshooting

Data Channel Troubleshooting

Last updated: November 19, 2005

This section is only applicable to the lab application.

Possible Setup Issues

  • Before trying to establish a packet data connection, you must make sure that the following settings properly configured:
    • the Session Application Type must be set to the Default Packet Application.
    • Cell band and channel must be set to the proper values for your AT (see How Do I Change Call Parameters? ).
    • Call Limit Mode must be set to off.
    • Cell Power must be set to an adequate level and AWGN Power must be set to an adequately low level to allow for successful data connection processing.
  • If the test set's internal PDSN is used for packet data connection via simple IP protocol (see How Does Test Set Support Simple IP Packet Data Connection? ).
    • you must properly set a DUT IP Address for your AT and make sure the External PDSN State is set to Off (see Data Channel Parameters ).
    • see Packet Data Service Example Procedure (via Simple IP) for an example packet data connection procedure using Simple IP protocol.
  • If the external MOB-IP-SIM is used to supply the PDSN simulation (providing Mobile IP protocol, see How Does Test Set Support Mobile IP Packet Data Connection? ).
    • you must properly specify the External PDSN IP Address and the External PDSN TCP Port , and make sure the External PDSN Connect Timeout is not set to zero. Then turn the External PDSN State to On . See Data Channel Parameters .
    • see Packet Data Service Example Procedure (via Mobile IP) for an example packet data connection procedure using Mobile IP protocol.

Other Considerations

  • It is recommended not to execute a preset/reset (full or partial) when a session is open with an AT. This is because executing a preset/reset (full or partial) will take the test set to Idle state without signaling to the AT and may cause the test set and AT in a mismatched state. In this case, some ATs can not open a new session with the test set.
  • You should always set the AT Directed Packets to 100% for maximum throughout. This allows the test set to send data to the AT under test in all possible slots. Note that achieving maximum throughout also depends on other parameters of your test setup such as Window Size, TCP or UDP protocol, etc.
  • The packet data connection can only be started from your AT. You can not start a packet data connection using CALL:FUNCtion:DATA:STARt command. Otherwise, an error message will be generated due to without having a PPP connection established.
  • If you are trying to end a packet data connection from the test set, use CALL:FUNCtion:DATA:DORMant command instead of the CALL:FUNCtion:DATA:STOP. Sending CALL:FUNCtion:DATA:DORMant command results in data connection status going to Dormant state. This indicates that the physical connection (traffic channel) is closed but PPP connection is maintained. See Dormant State .
  • Use Ping function to verify the system interconnect.
    • See How Do I Ping a Device From the Test Set? .
    • When the external MOB-IP-SIM is providing PDSN service to the AT, the AT's IP address is assigned by the MOB-IP-SIM. The setting by DUT IP Address is ignored and the ping to DUT functionality is not functioning (see Ping the DUT from the test set ).
  • Ping log has an unknown IP address: If you log a Ping that originated from the test set, the Ping forward link Source Address and the reverse link Destination Address have a fixed value of 130.29.181.203. This is because the test set uses an internal address to originate IP data from the test set to the AT. See Protocol Logging During Ping for more information.

Related Topics

Data Channel


Graphical Access Probe Power Troubleshooting

Graphical Access Probe Power Troubleshooting

Last updated: April 14, 2005

This section is only applicable to the lab application.

IMPORTANT
If the graphical access probe power measurement is on and waiting to measure a probe, all other measurements will not be able to execute. It is therefore recommended that you turn off the graphical access probe power measurement before attempting any other measurements.

Possible Setup Issues

  • You must press the START SINGLE key to arm the graphical access probe power measurement before it can measure the power of an access probe. At that time, the test set calculates the number of expected access probes based on number of steps and maximum probe sequence parameters.
  • It is recommended that you always turn Call Limit Mode on when measuring access probe power. The easiest way to induce access probes from the access terminal is to page the access terminal. If you do not have call limit mode set to on, the connection will complete, which clears the access probe power result from the measurement screen. Set call limit mode back to off when you have finished measuring access probe power.
  • There are several parameters that affect the access probe measurement results, such as Call Limit Mode, Probe Initial Adjust, and Probe Power Step. See Operating Considerations When Making the Measurement for details.
  • Access probe power measurements are triggered by a rise in RF power that must cross at least -45 dBm/1.23 MHz. See How is a Graphical Access Probe Power Measurement Made? for details.
  • If the probe power step and number of steps are set up such that the absolute power level of an access probe falls below the range of the graph, the value will cause the bar to clip (it will appear that the access terminal is transmitting a lower power level than expected).

Troubleshooting Techniques

  • See Troubleshooting Techniques of the Access Probe Power measurement.

Other Considerations

  • See Other Considerations of the Access Probe Power measurement.
  • Graph display: if the absolute power level of an access probe falls below the range of the graph, the value will cause the bar to clip

Related Topics

Manual Operation: Measuring Graphical Access Probe Power


E6706T User Documentation

E6706T User Documentation

Last updated: June 19, 2006

The features and functionality present in the E6706T Special High Data Rate 1xEV-DO Lab Application are identical to those offered in the E6706A 1xEV-DO Lab Application, with the exceptions described in this document. For information on how to use the features that are common to the E6706A and E6706T, see the 1xEV-DO online user's guide located at:

http://wireless.agilent.com/rfcomms/refdocs/1xevdo/default.php

The E6706T can only be loaded onto an E5515C with Special High Data Rate Hardware (or a test set with the equivalent hardware upgrades). Contact your local Agilent Sales Representative for more information, or visit www.agilent.com/find/8960upgrades.

In a test set with Special High Data Rate Hardware, the standard Protocol Processor is replaced with a High Data Rate Protocol Processor, and the test set's rear panel is modified to include a new LAN 2 PORT , which you must use for sending data to the test set (previously the LAN 1 PORT was used for this purpose).

The E6706T Special High Data Rate 1xEV-DO Lab Application (along with the appropriate hardware option) supports up to 2.4 Mbps throughput at both baseband and IP with the proper configurations (see Other Configurations ).

LAN 2 PORT

The Special High Data Rate Hardware required to run the E6706T includes a modified rear panel with a new LAN 2 PORT . To use the E6706T Data Channels functionality (to establish a Default Packet Application data connection, for example), you must connect your data server to LAN 2 PORT , rather than to LAN 1 PORT as in the past. LAN 1 PORT is still used for all other LAN operations such as protocol logging, firmware downloads and screen captures.

The LAN 2 PORT connects directly to the test set's High Data Rate protocol processor, as shown in the block diagram below.

Set LAN 2 PORT Address

You must configure the address of the LAN 2 PORT using the LAN IP Address 2 (Data+) setting (see Configuring the Test Set's LAN for general information about LAN IP addresses). LAN IP Address 2 (Data+) must not be the identical to the LAN IP Address setting, and must be on the same subnet as the LAN IP Address setting. If LAN IP Address or Subnet Mask is changed such that LAN IP Address 2 (Data+) is identical to or is no longer on the same subnet as LAN IP Address , then LAN IP Address 2 (Data+) is set to 0.0.0.0 and a warning is posted.

LAN IP Address 2 (Data+) is accessible from the Instrument Setup menu on the System Config Screen . The GPIB command for LAN IP Address 2 (Data+) is SYSTem:COMMunicate:LAN[:SELF]:ADDRess2<sp><string> . See SYSTem:COMMunicate:LAN[:SELF]:ADDRess for range information.

Other Configurations

To establish a packet data connection between a 1XEV-DO wireless device and a packet switched network, you should verify that:

  • Service Application Type is Default Packet Application (see Session Application Type )
  • External PDSN State is off (see Data Channel Parameters )
  • LAN IP Address 2 (Data+) (see Set LAN 2 PORT Address ) and DUT IP Address (see Data Channel Parameters ) should be unique and in the same subnet.
  • If your AT only supports certain PCCC value, set the Preferred Control Channel Cycle Control to AT Specified . This is to make sure the session can successfully open with any AT-requested PCCC value. See Preferred Control Channel Cycle Control for details.

Additional Information

  • The SYSTem:APPLication:CATalog[:NAME]? query includes "1xEV-DO Lab App T" , "CDMA 2000 Lab App T" , "GSM/GPRS Lab App T" , and "WCDMA Lab App T" .
  • The SYSTem:APPLication:CATalog:LICense:APPLIcation:ALL? query includes "E6701T","GSM/GPRS LA rev T" , "E6702T","CDMA2000 LA rev T" , "E6706T","WCDMA LA rev T" , "E6706T","1xEV-DO LA rev T" , and "E6706T-102","1xEV-DO Re A ETAP" .
  • In the E6706T, the SYSTem:APPLication[:CURRent][:NAME]? query returns "1xEV-DO Lab App T" .